How To Customize the SAP User Interface Using Theme Editor

Applicable Releases:

SAP NetWeaver 7.0 and 7.11

Version 1.0
June 2010
These materials are subject to change without notice. These materials are provided by SAP AG and its affiliated companies ("SAP Group") for informational purposes only, without representation or warranty of any kind, and SAP Group shall not be liable for errors or omissions with respect to the materials. The only warranties for SAP Group products and services are those that are set forth in the express warranty statements accompanying such products and services, if any. Nothing herein should be construed as constituting an additional warranty.

These materials are provided "as is" without a warranty of any kind, either express or implied, including but not limited to, the implied warranties of merchantability, fitness for a particular purpose, or non-infringement. SAP shall not be liable for damages of any kind including without limitation direct, special, indirect, or consequential damages that may result from the use of these materials.

SAP does not warrant the accuracy or completeness of the information, text, graphics, links or other items contained within these materials. SAP has no control over the information that you may access through the use of hot links contained in these materials and does not endorse your use of third party web pages nor provide any warranty whatsoever relating to third party web pages.

SAP NetWeaver “How-to” Guides are intended to simplify the product implementation. While specific product features and procedures typically are explained in a practical business context, it is not implied that those features and procedures are the only approach in solving a specific business problem using SAP NetWeaver. Should you wish to receive additional information, clarification or support, please refer to SAP Consulting.

Any software coding and/or code lines / strings ("Code") included in this documentation are only examples and are not intended to be used in a productive system environment. The Code is only intended better explain and visualize the syntax and phrasing rules of certain coding. SAP does not warrant the correctness and completeness of the Code given herein, and SAP shall not be liable for errors or damages caused by the usage of the Code, except if such damages were caused by SAP intentionally or grossly negligent.

Disclaimer

Some components of this product are based on Java™. Any code change in these components may cause unpredictable and severe malfunctions and is therefore expressively prohibited, as is any decompilation of these components. Any Java™ Source Code delivered with this product is only to be used by SAP’s Support Services and may not be modified or altered in any way.
## Document History

<table>
<thead>
<tr>
<th>Document Version</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.00</td>
<td>First official release of the Theme Editor guide</td>
</tr>
</tbody>
</table>
## Typographic Conventions

<table>
<thead>
<tr>
<th>Type Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Example Text</em></td>
<td>Words or characters quoted from the screen. These include field names, screen titles, pushbuttons labels, menu names, menu paths, and menu options. Cross-references to other documentation</td>
</tr>
<tr>
<td><strong>Example text</strong></td>
<td>Emphasized words or phrases in body text, graphic titles, and table titles</td>
</tr>
<tr>
<td><strong>Example text</strong></td>
<td>File and directory names and their paths, messages, names of variables and parameters, source text, and names of installation, upgrade and database tools.</td>
</tr>
<tr>
<td><strong>Example text</strong></td>
<td>User entry texts. These are words or characters that you enter in the system exactly as they appear in the documentation.</td>
</tr>
<tr>
<td><strong>&lt;Example text&gt;</strong></td>
<td>Variable user entry. Angle brackets indicate that you replace these words and characters with appropriate entries to make entries in the system.</td>
</tr>
<tr>
<td><strong>EXAMPLE TEXT</strong></td>
<td>Keys on the keyboard, for example, F2 or ENTER.</td>
</tr>
</tbody>
</table>

## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Warning" /></td>
<td>Caution</td>
</tr>
<tr>
<td><img src="image" alt="Tip" /></td>
<td>Note or Important</td>
</tr>
<tr>
<td><img src="image" alt="Example" /></td>
<td>Example</td>
</tr>
<tr>
<td><img src="image" alt="Tip" /></td>
<td>Recommendation or Tip</td>
</tr>
</tbody>
</table>
1. Business Scenario

Branding applications has become more and more important for end users and is seen as one of the critical use case requirements that must be satisfied by UI Infrastructure.

End users might not only like the option available to change the company logo, but also like to adapt the look and feel of user interfaces to reflect their own corporate branding.

2. Background Information

You can host SAP applications as a stand-alone application or within an SAP NetWeaver Portal. SAP NetWeaver Portal provides a Web-based tooling environment to facilitate creation of custom themes. SAP also ships several predefined themes which can be used as is or extended to meet your needs.

However, branding Web Dynpro applications (both ABAP and Java) hosted outside SAP NetWeaver Portal has limited offerings within the current solution.

Theme Editor is an Eclipse-based, feature-rich, lightweight tool. This tool aims to provide a unified tooling environment for defining and maintaining custom themes for SAP applications. This tool is intended to be used on top of SAP NetWeaver Developer studio or on standard Eclipse and supports branding for various technology flavors such as:

- Web Dynpro ABAP/Java
- SAP NetWeaver Portal offerings

3. Prerequisites

You have:

- A working knowledge of Eclipse
- Installed Eclipse SDK 3.5 or higher
- Installed Java 5.0 or higher
- SDN downloads for Theme Editor are as follows:
  - EclipseThemeEditorVersion2_ReleaseIndependentPlugin.zip – The Eclipse-based tooling
  - Eclipse_Theme_Editor_version2_Project_File.zip – A sample themes project containing all standard SAP Theme templates

Caution

The sample themes are intended to be used only for evaluation purpose of the tool. They are not guaranteed to work in the productive environment and there shall be no support provided to resolve any such identified issues. Nevertheless, any issue identified with the Theme Editor shall be supported; raise an OSS ticket on the component BC-DWB-THM-DT.

- One of the following operating systems:
  - Windows XP or
  - Windows Vista
- Internet Explorer 6.0 or higher
4. Getting Started

This section provides installation details and step-by-step tasks to create a custom theme.

4.1 Installing Theme Editor

To install Theme Editor, proceed as follows:

1. Start Eclipse.
2. Navigate to Help > Install New Software...
3. In the wizard window, click Add...
4. Click Archive... and navigate to the location where the EclipseThemeEditorVersion2_ReleaseIndependentPlugin.zip file is downloaded.
5. Provide a Name for the site, for example, <ThemeEditor> and click OK.
6. Select the listed features.
7. Unselect the options listed below in the wizard:
   a. Contact all update sites during install to find required software.
   b. Show only the latest versions of available software.
8. Click Next. Accept the license agreement and click Finish.
9. Restart the IDE to complete the installation.

The Theme Editor is installed successfully. This can be validated by opening the Themes Perspective:

- Navigate to Window > Open Perspective > Other... > SAP Themes.

4.2 Working with Theme Editor

This section will help you to get started with Theme Editor. This section provides a step-by-step approach to design a custom theme. The custom theme thus designed can be deployed on SAP NetWeaver Portal or Web Dynpro ABAP repository. It is then possible to apply the custom theme to the applications hosted in the above environments.

4.2.1 Importing SAP Themes

SAP Themes form the base for defining custom themes. It is a prerequisite to import SAP Themes into Theme Editor to define custom themes. The SAP Themes project is available as a zip file along with Theme Editor in the SDN Software Download Catalog. You can import a project only once to the given workspace.

Procedure

1. Open the SAP Themes Perspective (Window > Open Perspective > Other... > SAP Themes).
2. Choose File > Import.
3. In the Import wizard, choose SAP Themes > Import Themes.
4. Choose Next.
5. Enter a name for the project. For example, `<CustomThemes>`.

6. Define the source. Browse to the downloaded `Eclipse_Theme_Editor_version2_Project_File.zip` on the file system. The SAP Themes are extracted from the zip file and listed under *Projects*, with all the themes selected by default.

**Note**

Clear or select an SAP Theme to remove or include it in the *Theme Explorer* view.

7. Define a target. Browse to a location on the file system to save the theme content.
Figure 2: Imported SAP Themes

8. Click Finish.

The SAP Themes are imported into the workspace within the project, CustomThemes.

Figure 3: SAP Themes
4.2.2 Creating Custom Themes

You can create a new custom theme by extending one of the SAP Themes.

Procedure

1. Choose Themes > New Theme and click on Next.
2. Enter a name for the new theme, for example, <MyCustomTheme>.

   Note

   A theme name cannot include spaces or special characters.

3. Select a base theme. It can be one of the SAP Themes or any custom themes already created.
4. Click Finish.

   The custom theme is created and listed in Theme Explorer.

Figure 4: Custom Theme
4.2.3 Editing Custom Themes

The different Views within the SAP Themes Perspective helps to change the properties of the UI Elements.

Figure 5: Theme Editor Perspective

Theme Explorer

The Theme Explorer View appears in the left pane. It provides a view of the Themes (both SAP and Custom) and associated UI Elements.
**SAP Themes** are pre-defined, read-only templates offered by SAP. However, it is possible to extend the SAP Themes to create custom themes. SAP Themes serve as a basis for creating custom themes and includes styling information for a collection of UI Elements. The UI Elements within a theme are classified as:

- Complex Elements
- Global Styles Content Area
- Patterns
- Screen Areas
- Simple Elements

**Control Preview**

The Control Preview provides a preview of a UI Element. It allows to view and change different properties of a UI Element. It is also possible to preview a UI element in an external browser using the **Launch External Preview** action on the toolbar. The default external browser can be configured in the **Preferences** page (Window > Preferences) by navigating to General > Web Browser.

**Properties**

The **Properties** View is displayed at the bottom of the Perspective by default. It displays all the properties of the UI Element that is configurable. The configurable properties of every UI Element are classified in one of the below categories:

- Text
- Layout
- Fill
- Border

It is possible to change the value of one or more properties. For example, open the Button UI Element defined under Simple Elements in MyCustomTheme, in the Control Preview.

To change the font text color of a standard button follow the steps below:

1. Select the **Default** button under the **Standard** category in the preview.
   
   The configurable properties for the selected UI Element state is displayed in the **Properties** View.

2. Select the **Fill** category in the **Properties** View.

3. Click **Standard Font Color**. All the states that get affected with this property are highlighted by a red outline in the Control Preview.

4. Choose a color from the color picker.

   **Note**

   The font color of the affected states in the Preview can also be changed by moving the mouse pointer over the color picker. Alternatively, the new color value can also be typed in the field.

5. Save the changes.
4.2.4 Switching Theme Explorer Views

The content of the Theme Explorer can be grouped under any of the following categories:

- **Arrange By Themes**: This view lists themes as root elements in Theme Explorer.
- **Arrange By Theme Project Types**: This view lists themes under its respective projects. This is the default view in Theme Editor.

**Procedure**

1. Open the SAP Themes Perspective.
   - The **Arrange By Theme Project Types** appears by default.
2. On the **Theme Explorer** pane, choose View Menu.
3. Select a view.

Similarly it is possible to change one or more properties for a given UI Element.
4.2.5 Exporting Custom Themes

After you have designed the custom theme, you need to apply the theme to the required SAP application. This task allows you to export custom themes so that you can apply them to the required SAP applications hosted in SAP NetWeaver Portal or Web Dynpro ABAP applications, and so on.

Procedure

1. Select a custom theme.
2. From the context menu:
   a. Choose Generate to create stylesheets for the custom theme using theme metadata.
   b. Choose Export to Portal, to create a zip file containing custom themes that can be exported to an SAP NetWeaver Portal.
      Or
   c. Choose Export to Web Dynpro to create a zip file containing custom themes that can be exported to Web Dynpro.
3. Save the custom theme as a zip file.
5. Appendix

The below options are applicable on every custom theme that is displayed in the Theme Explorer.

- **Refresh**: Refreshes the content of the Theme Explorer.

- **Export to Portal**: Creates a zip file containing custom theme artifacts, which can be later exported to an SAP NetWeaver Portal. The *Export to Portal* option is enabled only for custom themes and not for SAP Themes.

- **Export to Web Dynpro**: Creates a zip file containing the custom themes artifacts, which can be later exported to R/3 Web Dynpro ABAP system. The *Export to Web Dynpro* option is enabled only for custom themes and not for SAP Themes.

- **Generate**: Generates stylesheets for all the UI Elements defined in the theme. It is mandatory to trigger this generation before exporting to SAP NetWeaver Portal or R/3 Web Dynpro ABAP system.

- **Reload**: Loads the theme metadata and then generates the style sheets for the UI Elements.

![Figure 9: Theme Explorer Context Menu](image-url)
www.sdn.sap.com/irj/sdn/howtoguides