How To Edit
Web Dynpro Themes
Version 2.00

Applicable Releases:
SAP NetWeaver 7.0
SAP, R/3, mySAP, mySAP.com, xApps, xApp, SAP NetWeaver, and other SAP products and services mentioned herein as well as their respective logos are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other product and service names mentioned are the trademarks of their respective companies.

Data syntax and phrasing rules of certain coding. SAP does not warrant the correctness and completeness of the Code given herein, and SAP shall not be liable for errors or damages caused by the usage of the Code, except if such damages were caused by SAP intentionally or grossly negligent.
# Table of contents

1  THEME EDITING SCENARIOS ............................................................... 1
2  INTRODUCTION ...................................................................................... 1
3  PREREQUISITES ..................................................................................... 1
4  STEP BY STEP GUIDE ............................................................................ 2  
   4.1  INSTALLATION ...................................................................................... 2  
   4.2  PROJECT SETUP .................................................................................. 5  
   4.3  BROWSING SAP TEMPLATE THEMES ................................................... 10  
   4.4  EDITING SAP TEMPLATE THEMES ....................................................... 14  
   4.5  USING DIFFERENT BROWSERS ............................................................. 21  
   4.6  HANDLING PORTAL DATA ................................................................. 24  
   4.7  TROUBLESHOOTING ........................................................................... 28
1 Theme Editing Scenarios

If you are running within a SAP Enterprise Portal, UI themes can be changed with the Portal Theme Editor which is part of the Enterprise System Administration role.

SAP also offers a version of the Theme Editor as a stand-alone tool via SDN. The usage of this stand-alone tool is described in this document.

2 Introduction

The stand-alone Theme Editor is an Eclipse Plug-In. It is optimized for MS Windows since it uses MS Internet Explorer for previewing functionality.

You can edit any themes from Netweaver 04S (or higher) with the Eclipse based Theme Editor. See also SAP Note 1364095.

3 Prerequisites

Your computer needs at least 512 MB memory; a 2 GHz processor is recommended.

You should have downloaded the following files from SAP:

themeEditor32.zip
This File contains the complete Theme Editor Eclipse PlugIn. The step by step guide will show you how to install it.

project.zip
A sample Theme Editor project which contains all standard SAP theme templates. Please unzip it to your hard-disk in a directory of your choice. You do not need this file if you have downloaded your project from an R/3 Web Dynpro ABAP system.
4 Step By Step Guide

4.1 Installation

1. Download and install the latest version of Java 5 from http://java.sun.com/javase/download/index_jdk5.jsp

2. Install the latest version of Eclipse 3.2 or 3.3 from http://www.eclipse.org/downloads


4. Create a shortcut to eclipse.exe
5. Make sure eclipse gets enough memory by supplying the shortcut with the following arguments:
eclipse -vmargs -Xmx512M.

You might also want to include proxy settings:
-DproxySet=true
-DproxyHost=<your proxy server>
-DproxyPort=<your proxy port>


7. Unzip themeEditor32.zip into the plugins directory of your eclipse installation.
   The plugins folder should then contain the subfolders com.sap.ur.lib.cssrepository,
   com.sap.ur.lib.sgen,
   com.sap.ur.lib.ssom,
   com.sap.ur.lib.themeEditor32 and
   com.sap.ur.plugins.themeEditor32
8. Launch eclipse shortcut.

9. Make sure you have unzipped project.zip to your local filesystem, e.g. C:\sample_project. (see prerequisites)
4.2 Project setup

10. The Theme Editor consists of several panels for viewing and editing themes. In Eclipse lingo, such a combination is called a “perspective”.

Open the SAP UR Themes perspective by choosing the following menu: “Window -> OpenPerspective -> Other”

11. Choose “SAP UR Themes”.
12. The SP UR Themes perspective is opened. Select the new button at the top right-hand corner of the theme projects view to open an existing project (see prerequisites).

13. Enter a project name and click the browse button to select the project location.

14. Select the folder where you have unzipped your project as project location.

   Click the OK button.
15. Hit the finish button.

16. Now you can see your project inside the theme projects view.
17. Opening the project folder shows the standard SAP themes.

The number of standard SAP themes may vary.

18. Note that standard SAP themes cannot be modified.

You can create your own themes by copying a standard SAP theme with a right-click.
19. Add a name and id for your custom theme.

![Save theme as dialog]

20. A progress window pops up.

![Progress Information dialog]

21. Once the progress window has disappeared, our new editable custom theme appears in the theme projects view.
4.3 Browsing SAP template themes

22. Double-click your new theme and it will be displayed in a theme editor tab.

All available UI elements are grouped in a tree in the upper left-hand panel.

23. Open one of the tree folders and you will get a list of the corresponding UI elements.

In this screen, we have opened the “Simple Elements” folder.
24. A double-click on one of the UI-elements (e.g. Buttons) in the tree leads to the display of its preview and all its editable theme parameters.

Note that the first display of the preview and parameters might be delayed by a couple of seconds.

25. Let’s have a closer look at the parameters.

Open “Buttons->Standard Buttons” in the parameter panel tree.

The values of all available parameters are displayed in the parameter panel.
26. Whenever your mouse pointer hovers over one of the parameters, red rectangles show the impact of the parameter in the preview.

27. If you do not want these rectangles, you can disable them.

Choose the menu “Window -> Preferences…” and a preferences dialog will pop up.
28. Choose "Themes Editor Preferences" and disable the "highlight parameter in preview" checkbox.

Click the "OK" button, the preferences dialog disappears.

29. Back to the parameter panel:

For some parameters there is additional information available.

This is indicated by a question mark icon in the parameter pane next to the parameter value.

Click the icon and an info window will pop up.
4.4 Editing SAP template themes

In this section, we will change and export our custom theme.

30. Let’s modify our theme by editing a parameter. Simply click on the parameter in the value column.

The table cell changes and the parameter is ready to be changed.

Note that you can not edit any SAP standard template themes, they are read-only.

31. If you are a CSS expert you may now type in a hex value for the parameter value. Type #F00 and hit return.

This results in refreshing the preview showing the updated parameter.
32. Alternatively, you can click the button labeled “…” and a color choice dialog appears.

Click the “Cancel” button for now.

33. Now let’s change an image parameter:

Open “Buttons->Previous Steps Button” in the parameter panel tree.

Click on “button/BtnPrevStep.gif” in the value column of the tree.
34. Note that the path and name of the image can not be changed.

We will only replace the content of the image.

Style sheets are generated separately for Left-To-Right writing and Right-To-Left writing (as applied in Arabic and Hebrew).

Depending on whether you need LTR style sheets, RTL or both, you will see a “ltr” button, a “rtl” button or both.

35. You can choose whether you want the Theme Editor to generate LTR stylesheets, RTL or both.

Choose the menu “Window -> Preferences…” and select “Themes Editor Preferences” again.

Let us stick to LTR for now and click OK. The Preferences dialog disappears.
36. Click the ltr button in the parameter panel.

37. A dialog pops up which lets you choose an image. Browse to your local directory, select an image of your choice and click the “Open” button.
38. The content of the image will be changed and the preview will update within a few seconds.

39. Currently, your theme has not been saved yet. This is indicated by the asterisk in your theme editor’s tab (see circle at the upper left-hand corner in the screenshot).

Type Ctrl-S, click the save icon or choose the “File->Save” menu to save your custom theme.

The asterisk disappears.
40. If you want to import your theme into your R/3 Web Dynpro ABAP system, you need to export it from the theme editor first.

Click on the “export to Web Dynpro” button.

41. A dialog appears. Choose a directory and file name for your theme and press the “Open” button.

42. A theme consists of metadata, resources and style sheets.

Whenever you export a custom theme to Web Dynpro, all the style sheets are generated. This might take a while.

A message dialog appears while the style sheet generation is done.
43. Once the dialog has disappeared, the export is complete and the zip file has been written to your local hard disk.

Congratulations, you are done!

44. In case you are editing more than one custom theme at the same time:

You can export all of the themes in one step by right-clicking on the root node of your project in the Theme Projects View.

Choose “export all custom themes to Web Dynpro”, pick a name and directory, wait a little and you have exported all your custom themes into a single file.
4.5 Using different browsers

45. The preview within eclipse always uses Microsoft Internet Explorer. You can also launch the current preview in any external browser, which can be configured in the standard eclipse preferences.

Choose the “Window->Preferences” menu and open the “General->Web Browser” entry.

46. Choose “Use external Web browser” and select the browser of your choice.

Click the “OK” button.

n.b. If the browser is installed on your computer but does not appear in the “External Web browsers” list yet, you need to add it by choosing the “New” button.
47. Once you have configured your external browser, click on the “external preview” button in the theme editor panel.

48. As a result you will see the preview in an external browser window.
49. Note that a different set of customizing parameters is offered for different browsers.

If you want to have access to all possible customizing parameters for FireFox, please select the preferences entry “show parameters for” accordingly.
4.6 Handling portal data

The Theme Editor can also handle theme data for the SAP Enterprise Portal.

The tool of choice for editing themes within the portal is the Portal Theme Editor (see Theme Editing Scenarios). However, you might want to use the Eclipse-based Theme Editor for migrating themes from the Portal to Web Dynpro and vice versa.

This document does not describe how to export themes from or import themes into a portal; have a look at the Portal Theme Editor documentation instead.

50. Importing a portal theme.

Right-click on the root node of your project in the Theme Projects view.

Choose “import theme from portal”.

51. A dialog pops up, browse to your zipped portal theme and click “Open”.
52. The Theme Editor starts to import the portal theme, a progress dialog pops up.

Note: this might take a couple of minutes.

53. Once the progress dialog has disappeared, the theme shows up in your project.

You are done!
54. Exporting a portal theme

You can also export a theme from the Eclipse-based Theme Editor to the Portal.

Simply click on the “export to Portal” Button.

55. A dialog appears. Please choose a name and directory and click “Open”.

56. The Theme Editor starts to export the portal theme, a progress dialog pops up.
57. Once the progress dialog has disappeared you are done. A zip file with the portal theme data is now located on your local hard disc.
4.7 Troubleshooting

58. I can not open the SAP UR Themes perspective. It is not offered in the choice of perspectives

Check whether the plugins directory of your eclipse installation contains the following directories:

- com.sap.ur.lib.cssrepository
- com.sap.ur.lib.sgen
- com.sap.ur.lib.ssom
- com.sap.ur.lib.themeEditor32
- com.sap.ur.plugins.themeEditor32

If they are not there, unzip themeEditor32.zip again (see installation).

59. I can not open the SAP UR Themes perspective. It is offered, but nothing happens when I choose it.

Please have a look at eclipse’s error log. Browse to your eclipse workspace directory, open the .metadata directory and open the .log file.

If it contains an error such as “java.lang.UnsupportedClassVersionError: com/sap/ur/plugins/ThemeEditorPlugin (Unsupported major.minor version 49.0)”, chances are you need to update to a newer version of the Java Runtime Environment.
60. My preview shows the error message such as “HTTP Status 500”.

The Theme Editor uses an internal JSP container for previewing; something has gone seriously wrong there. Enable the traces.

61. My preview is displayed but not updated properly I

The preview is displayed by a local Microsoft Internet Explorer control that comes with eclipse.

To achieve WYSIWYG editing of themes you need to configure Internet Explorer.

Start an instance of Internet Explorer externally and choose the menu “Tools->Internet Options…”. 
62. My preview is displayed but not updated properly II

Set the Temporary Internet Files settings to “Every visit to the page”.

Close the external instance of Internet Explorer, the settings will automatically affect the Internet Explorer control used by the Theme Editor.

Your preview within eclipse should now get updated properly whenever you change a parameter.

63. I am using FireFox as an external browser. The preview does not reflect the customizing modifications I made.

Chances are you have not configured the style sheet generation for FireFox.

Go to the Theme Editor preferences and verify the settings: Make sure that “generate style sheets for FireFox” is checked.