Toad 제목 페이지

Toad의 최신 기능 살펴보기

Toad의 새로운 기능

최근 수정일: 2006년 10월

Toad™for Oracle® 9.0

© 2006 Quest Software, Inc.

ALL RIGHTS RESERVED.

본 안내서에는 저작권의 보호를 받는 고유 정보가 들어 있습니다. 본 안내서의 소프트웨어는 소프트웨어 저작권과 비밀 유지 계약서의 보호를 받습니다. 본 소프트웨어는 적절한 계약에 따라서만 복사하거나 사용할 수 있습니다. 본 안내서의 어떤 부분도 Quest Software, Inc.의 서면 허가 없이 구매자의 개인적인 이용 목적을 제외한 다른 목적으로 사진 복사 및 녹화를 포함한 전자적 또는 기계적인 어떤 방법이나 어떤 형태로도 재생산하거나 전송할 수 없습니다.

본 자료의 사용에 대한 질문은 다음으로 문의하십시오.

Quest Software World Headquarters
LEGAL Dept
5 Polaris Way
Aliso Viejo, CA 92656

www.quest.com

전자 메일: legal@quest.com

지역 및 국제 사무실에 대한 정보는 웹 사이트를 참조하십시오.

부인

본 안내서에 있는 정보는 Quest 제품과 관련하여 제공됩니다. 본 문서나 Quest 제품의 판매에 관련해서는 금반언 조항에 의해서나 다른 방식으로 명시적 또는 암시적인 어떤 종류의 지적 재산권도 부여되지 않습니다. 이 제품의 사용권 계약에 지정된 QUEST의 약관과 규정에 명시되지 않은 한, QUEST는 이 제품에 관하여 상업성, 특정 목적에 대한 합목적성 또는 비침해를 포함하며 이에 제한되지는 않는 어떠한 명시적, 암시적 또는 법적 보증도 부인하며 어떠한 책임도 지지 않습니다. QUEST에서 피해 가능성에 대해 통지한 적이 있는 어떠한 경우라도 QUEST는 본 문서를 사용하거나 사용하지 못하여 발생하는 직간접적, 결과적, 처벌, 특수 또는 부수적인 피해(이익의 상실, 비즈니스 방해 또는 정보 손실 등을 포함하며 이에 제한되지는 않는)에 대해 책임을 지지 않습니다. Quest는 본 문서의 정확성이나 완전성에 대해 어떠한 표현이나 보증도 하지 않으며 언제든지 통보 없이 세부 사항과 제품 설명을 변경할 권리가 있습니다. Quest는 본 문서에 포함된 정보의 업데이트에 대해 어떠한 책임도 지지 않습니다.

상표

Quest, Quest Software, Quest Software 로고, Aelita, Benchmark Factory, Big Brother, DataFactory, DeployDirector, ERDisk, Fastlane, Final, Foglight, Funnel Web, I/Watch, Imceda, InLook, InTrust, IT Dad, JClass, JProbe, LeccoTech, LiveReorg, NBSpool, NetBase, PerformaSure, PL/Vision, Quest Central, RAPS, SharePlex, Sitraka, SmartAlarm, Speed Change Manager, Speed Coefficient, Spotlight, SQL Firewall, SQL Impact, SQL LiteSpeed, SQL Navigator, SQLab, SQLab Tuner, SQLab Xpert, SQLGuardian, SQLProtector, SQL Watch, Stat, Stat!, Toad, T.O.A.D., Tag and Follow, Vintela, Virtual DBA 및 XRT는 Quest Software, Inc.의 상표 및 등록 상표입니다. 본 안내서에서 사용된 다른 상표 및 등록 상표는 해당 업체의 소유입니다.

타사 기여

이 제품은 다음 회사에서 개발한 소프트웨어가 포함됩니다.

Indy Project, Componentage Software, /N Software, Digital Metaphors Corporation, Deep Software, Virtual Shell Tools, Axolot Data, EldoS Corporation, Soft-Gems, Developer Express Corporation, FastReports, Core Lab, Oracle USA, Inc., Anders Melander 및 EControl, Ltd.


Toad의 새로운 기능

© Copyright Quest Software, Inc. 1994-2006. All rights reserved.

최근 수정일: 2006년 10월

Toad의 새로운 기능

새로운 기능 및 창이 약간 추가되었습니다. 새로운 기능 및 버그 수정의 전체 목록은 릴리스 정보를 참조하십시오.

버전 9.0

Standard Toad

  • Editor가 모두 하나의 Toad Editor 창으로 통합되었습니다. 새 Editor의 장점은 다음과 같습니다.

  • 상황에 맞는 실행: Toad는 코드가 SQL 또는 PL/SQL인지 파악하고 있으며 이에 따라 실행 또는 컴파일합니다.

  • Hex 및 XML을 지원합니다.

  • 탭당 여러 구문을 지원합니다. 이로 인해 <F9>와 <SHIFT><F9>를 누르면 다른 결과가 나타납니다. (자세한 내용은 구문 실행을 참조하십시오.)

  • 개체 컴파일 및 다시 로드를 위한 마우스 오른쪽 단추 누르기 동작 등의 향상된 Navigator.

  • 코드 접기

  • 블록 선택

  • Editor의 변경 내용으로 인해 Toad Options가 전부 다시 작업되었고 이전 Editor options 페이지는 Toad Options로 통합되었습니다. 항목의 위치를 검토하고 Options Search 기능을 사용할 준비를 하십시오.

  • 구문 강조표시는 이제 사용자가 원하는 대로 설정할 수 있는 강력한 기능입니다.

  • 업그레이드할 때 도구 모음의 사용자 정의 메뉴는 그대로 둡니다. Customize Toolbars 페이지에서 새로운 기능을 보고 추가할 수 있습니다.

  • 새 설치 프로그램에 자동 설치 옵션이 보강되었습니다.

  • 새로운 Toad Advisor - 경고, 알림, 힌트 및 Toad 설치에 대한 현재 상태 정보를 제공합니다.

  • Language Management 옵션을 사용하여 Toad의 코드 분석 및 강조표시 방식을 제어할 수 있습니다. 또한 새 언어를 만들고, 다른 언어에 하위 언어를 포함하기로 선택할 수 있습니다. 이렇게 하면 예를 들어 동일한 Editor 창에서 PL/SQL 및 Java를 모두 강조표시할 수 있습니다.

  • Action Console에 마우스 오른쪽 단추를 눌러 개체를 작동합니다.

  • 이제 Create 화면에서 Project Manager로 모든 개체를 추가할 수 있습니다.

  • 이제 Project Manager 파일별로 Schema Browser를 필터링할 수 있습니다.

  • Excel 유형 필터가 EQUAL 및 NOT EQUAL 문자열의 와일드카드(%, *, _ 및 ?)를 지원합니다.

  • Toad에서 사용자 파일을 저장하기 위해 사용하는 위치를 변경할 수 있습니다. (Options>General>User Files Directory 참조)

  • Reports Manager는 생성 및 인쇄용으로 미리 작성한 보고서를 유지하기 위해 Toad Reports를 교체합니다. 이제 명령줄를 사용하여 보고서를 예약할 수도 있습니다.

  • SQL Modeler가 Query Builder로 이름이 변경되어 질의 리버스 엔지니어링을 지원합니다. SQL 리버스 엔지니어링은 괄목할 만한 기술 향상을 나타냅니다. 개발 주기를 통해 전체적으로 엄격한 테스트를 거쳤다고 해도 질의가 광범위하게 배열될 수 있으므로 질의를 작성할 수는 있지만 취소가 불가능할 수도 있습니다. 이러한 질의를 발견할 경우 Quest에 알리는 것이 좋습니다.

  • 새로운 Explain Plan

Professional Editions

  • 이제 CodeXpert를 Toad 내의 여러 위치에 있는 마우스 오른쪽 단추 메뉴에서 사용할 수 있습니다. Schema Browser에서 함수, 프로시저, 패키지 및 보기에 대해 CodeXpert 분석을 실행할 수 있습니다. 또한 User 페이지에서 실행할 수 있으며 Toad는 해당 사용자 소유의 개체를 모두 포함하게 됩니다.

  • Code Xpert는 또한 Code Reviews를 예약하여 자동화할 수 있습니다.

Quest DBA Module

  • DBMS_REDEFINITION 마법사가 추가되어 온라인으로 표를 쉽게 재정의 및 재구성할 수 있습니다. 이 기능은 Oracle의 DBMS_REDEFINITION 패키지를 사용합니다.

  • Top Session Finder의 Session Browser에서 마우스를 한 번만 클릭하여 선택한 세션을 찾습니다.

  • ADDM/AWR 기능이 크게 확대되었습니다. 여러 자동 보고서를 실행하고, Toad에서 스냅샷 및 기준선을 쉽게 작성합니다.

Quest eBiz Module

  • 보고 기능이 Toad Reports Manager와 병합되어 보고서를 보다 쉽게 찾고 관리할 수 있습니다.

버전 8.6

Standard Toad

  • 새롭게 향상된 Master Detail Browser. 세부 사항 설정 수에 제한이 없으며 세부 사항 설정은 중첩될 수 있습니다.

  • 이제 Script Manager를 보다 쉽게 사용할 수 있습니다.

  • 마우스 오른쪽 단추 메뉴가 함께 그룹으로 다시 구성되었습니다.

  • 이제 Connection Color로 Windows의 태그를 지정할 수 있으므로 모든 연결에 적용되는 창을 쉽게 추적할 수 있습니다.

  • SQL Modeler가 다시 설계되어 복잡한 질의를 보다 쉽게 작성할 수 있습니다.

  • 이제 Editor를 사용하여 Results 영역의 Profiler tab에서 Profiler를 액세스할 수 있습니다.

Professional Editions

  • 프로시저 실행 및 디버깅 이전의 익명 블록에서 개체의 스키마가 Toad Options|Editor에서 설정한 옵션에 관계없이 개체 이름으로 미리 보류됩니다. 다른 위치는 계속 옵션을 따릅니다.

  • SQL Tuning이 Toad의 GUI에 보다 강력하게 통합되었습니다. Editor에 복사하지 않고도 여러 위치에서 SQL을 조정할 수 있습니다.

Quest DBA Module

  • ADDM Report Generator는 문제 없이 실행 중인 문제 영역 및 데이터베이스 영역 모두 문서로 작성할 수 있습니다.

Quest eBiz Module

  • 모든 것이 새로운 기능입니다. 실제로 eBiz 모듈 전체가 새로운 옵션입니다. 자세한내용은 eBiz Module 개요를 참조하십시오.


Toad 소개

Toad는 고급 SQL 및 PL/SQL 편집기로 구성된 강력한 응용프로그램 개발 도구입니다. Toad를 사용하면 PL/SQL 패키지, 절차, 트리거, 기능 등을 작성하고 테스트할 수 있습니다. 또한 데이터베이스 테이블, 보기, 색인, 제약 조건 및 사용자를 작성하고 편집할 수 있습니다. Schema Browser 및 Project Manager를 통해 데이터베이스 개체에 빠르게 액세스할 수 있습니다.

Toad는 여러 버전에서 각각 다른 기능을 제공합니다. 다른 버전에 대한 자세한 내용은 Toad 버전 항목을 참조하십시오.

Toad Editor를 사용하면 스크립트 및 질의를 쉽고 효율적으로 기록 및 테스트할 수 있으며, 강력한 데이터 눈금을 통해 Oracle 데이터를 쉽게 보고 편집할 수 있습니다.

Toad에서는 다음을 수행할 수 있습니다.

  • Oracle Dictionary 보기

  • 개체 작성, 찾아보기 또는 수정

  • 그래픽을 사용하여 질의 작성, 실행 및 조정

  • PL/SQL 편집 및 저장 프로시저 프로파일

  • 중심 창 하나로 공용 DB 작업 관리

  • 제약 조건, 트리거, 범위, 색인 및 부여를 통해 데이터베이스 문제 찾기 및 수정

  • 바로 가기 및 템플릿에서 코드 작성

  • 사용자 정의 코드 템플릿 작성

  • Toad의 공동 원본 제어 기능을 사용하여 코드 액세스 및 개발 제어(타사 버전 제어 제품 사용 또는 미사용)

  • 보다 쉬운 작업 관리를 위해 프로젝트 작성

Debugger

디버거에서 실행되는 코드를 진행할 수 있습니다. 이 모듈을 사용하면 인수를 사용하거나 사용하지 않는 디버그 세션을 실행하고 중단점을 설정하며, 변수를 감시하는 등의 작업을 수행할 수 있습니다.

Quest DBA Module

Quest DBA Module은 Toad에 데이터베이스 관리 기능을 추가합니다. 이 모듈을 사용하면 공간을 관리하고 스키마를 비교하며, 데이터베이스 성능을 모니터하고 새 데이터베이스를 작성하고, 반복 실행 로그를 유지관리하며 상태 확인을 수행하는 등의 작업을 수행할 수 있습니다.

SQL Optimizer Module

SQL Optimizer(이전의 SQL Tuner/SQL Tuning/Xpert Tuning)는 코드에서 문제가 있는 SQL을 바로 식별하며, 어느 수준의 사용자에게나 최상의 구문 품질과 성능을 보장하는 강력한 SQL 재작성 엔진을 제공합니다.

eBiz Module

Oracle e-Business Suite에서 응용프로그램, 동시 프로그램, 현재 및 지난 활동, 사용자, 책임, 워크플로, 유연한 필드, 요청 세트, 패치, 프로파일 옵션, 프린터, 메뉴, 잘못된 개체, 데이터 그룹 등에 관한 정보를 신속하게 찾을 수 있습니다.


Toad 버전

Toad for Oracle, 버전 9.0에는 네 가지 버전이 제공됩니다. 따라서 사용자 환경에 적합한 버전을 선택할 수 있습니다.

Toad 버전

버전 | 설명
Toad for Oracle | Oracle 전문가가 질의를 작성 및 실행하고 데이터베이스 개체를 작성 및 관리하는 데 사용되는 기초와 기본 도구를 제공합니다. 여기에는 XML 편집, 데이터 찾아보기, 데이터 비교, SQL 회수, 코드 조각 및 코드 서식이 포함됩니다. 이 버전을 사용하면 Toad의 추가된 유틸리티와 사용자 정의 보고서 쓰기로 플러그 인할 수도 있습니다.
Toad for Oracle Professional | Toad for Oracle의 모든 기능에 디버깅 기능, 전문가 코드 검증 및 통합 지식 기반을 포함합니다. 이 버전에는 PL/SQL Debugger, Script Debugger for SQL*Plus, CodeXpert, 통합 PL/SQL Knowledge Xpert를 비롯하여 Data Pump for Oracle 10g도 포함되어 있습니다.
Toad for Oracle Xpert | Toad for Oracle Professional의 모든 기능에 통합 SQL Optimizer 및 SQL Scanning 기술이 포함됩니다. 여기에는 SQL Optimizer Module과 SQL Scanning이 포함되어 있습니다.
Toad for Oracle Suite | 전체 응용프로그램 수명 주기 패키지. Toad for Oracle Xpert의 모든 기능에 다양한 개발 도구가 포함됩니다. 여기에는 정확한 물리 데이터 모델을 작성하고 리버스 엔지니어링하는 데 사용되는 Quest DBA Module, Database Administration Knowledge Xpert, DataFactory® Developer Edition 및 Benchmark Factory® for Oracle이 포함되어 있습니다.

선택적인 추가 기능 모듈

선택적인 추가 모듈을 사용하여 Toad의 기능을 확장할 수도 있습니다.

Quest DBA Module

Toad에 고급 데이터베이스 관리 기능을 추가합니다.

이 모듈을 사용하면 공간을 관리하고 스키마를 비교하며, 데이터베이스 성능을 모니터하고 새 데이터베이스를 작성하고, 반복 실행 로그를 유지관리하는 등의 작업을 수행할 수 있으며 Knowledge Xpert for Oracle Administration(Toad 외부에서 실행 가능)이 포함되어 있습니다.

SQL Optimizer Module

SQL Optimizer(이전의 SQL Tuner/SQL Tuning/Xpert Tuning)는 코드에서 문제가 있는 SQL을 바로 식별하며, 어느 수준의 사용자에게나 최상의 구문 품질과 성능을 보장하는 강력한 SQL 재작성 엔진을 제공합니다.

eBiz Module

Oracle e-Business Suite에서 응용프로그램, 동시 프로그램, 현재 및 지난 활동, 사용자, 책임, 워크플로, 유연한 필드, 요청 세트, 패치, 프로파일 옵션, 프린터, 메뉴, 잘못된 개체, 데이터 그룹 등에 관한 정보를 신속하게 찾을 수 있습니다.


DBA Module 개요

Quest DBA Module 개요

Quest DBA Module은 데이터베이스 관리자가 사용하도록 디자인된 Toad 기능 구성입니다. Quest DBA Module은 Toad 전체에서 확장된 기능을 추가합니다.

ADDM Report Generator

문제 영역 및 정상적으로 실행 중인 데이터베이스 영역을 모두 문서화합니다.

ASM Manager

Oracle 데이터베이스 내에서 Oracle DB 파일 시스템을 관리하는 데 사용합니다.

Audit Objects

선택한 데이터베이스 개체에 대한 Audit Monitoring 옵션을 표시합니다. 각 개별 개체나 개체 그룹에 대한 모니터링 수준을 입력하고 수정할 수 있습니다.

Audit SQL/SysPrivs

데이터베이스의 SQL 문 개체, 예약어 및 시스템 권한에 대한 Audit Monitoring 옵션을 표시합니다.

Compare Schemas

이 기능의 DBA 버전을 사용하면 def 파일을 로드할 수 있으며 마이그레이션/동기화 보고서를 스크립트 파일에 저장하거나 복사할 수 있습니다.

Compare Databases

두 개의 데이터베이스를 비교합니다.

Control Files

컨트롤 파일에는 시작할 때와 정상적인 작업 동안 인스턴스에서 액세스하는 데이터베이스에 필요한 연관된 데이터베이스에 대한 정보가 있습니다. 컨트롤 파일의 정보는 Oracle에서만 수정할 수 있으며, 데이터베이스 관리자나 최종 사용자는 데이터베이스의 컨트롤 파일을 편집할 수 없습니다. 이 옵션을 사용하여 컨트롤 파일을 볼 수 있습니다.

Database Monitor

9개의 차트인 Logical IO, Physical IO, Event Waits, Sessions, Call Rates, Miss Rates, SGA Memory Usage, Shared Pool 및 Indexed Queries %를 사용하여 데이터베이스 성능을 모니터링할 수 있습니다. 가로 스크롤 막대를 사용하여 모든 차트를 볼 수 있습니다.

Database Browser

이 기능을 사용하면 TNS 이름 파일 또는 활성 연결 목록에서 데이터베이스와 관련된 정보를 찾을 수 있습니다. 정보를 수집하려면 탐색할 데이터베이스에 연결되어 있어야 합니다. 또한 개별 데이터베이스 노드가 아니라 호스트 트리 노드를 선택하여 모든 호스트 서버의 데이터베이스에 대한 집계된 정보를 볼 수 있습니다.

Database Probe

Toad Database Probe는 큰 경고 모음을 제공하는 실시간 모니터링 창입니다. 경고를 직접 작성할 수도 있습니다.

Database Health Check

Database Health Check는 선택한 데이터베이스에서 일련의 검사를 수행하고 결과를 표시합니다. 결과를 색으로 구분된 RTF 또는 HTML 파일이나 일반 텍스트 파일에 저장할 수 있습니다. 또한 전자 메일을 통해 결과를 다른 주소로 보낼 수 있습니다.

DataPump Import/Export 마법사

Oracle Data Pump는 Oracle 10g에 추가된 가져오기/내보내기 유틸리티입니다. 이 유틸리티는 표준 가져오기/내보내기 유틸리티보다 훨씬 더 빠르고 효율적으로 대용량의 데이터를 로드할 수 있습니다. Toad의 Data Pump Import/Export 마법사를 통해 이 작업을 더 쉽게 수행할 수 있습니다. 또한 Toad에는 가져오기/내보내기 작업을 관리하는 데 도움이 되는 Data Pump 작업 관리자가 있습니다.

DBMS_REDEFINITION 마법사

이 마법사를 사용하여 Oracle 버전 10 이상에서 Oracle의 DBMS_REDEFINITION 패키지에 쉽게 액세스할 수 있습니다.

Export Utility 마법사

이 창을 사용하여 가상 DBA 루틴을 통해 스키마 스크립트를 내보낼 수 있습니다.

Export File Browser

이 창을 사용하여 내보내기 파일의 내용을 탐색하고 데이터와 DDL을 가져오지 않고도 쉽게 볼 수 있습니다.

Generate Schema Script

선택한 스키마와 정의 파일을 가져오고 모든 선택한 개체에 대한 DDL 및/또는 정의 파일을 작성합니다.

Generate Database Script

기존 데이터베이스에 기초하여 새 데이터베이스를 만듭니다.

Identify Space Deficits

다음 익스텐트를 할당하기 위한 충분한 디스크 여유 공간이 없는 테이블을 표시합니다.

Import Utility Wizard

이 창을 사용하여 가상 DBA 루틴을 통해 스키마 스크립트를 가져올 수 있습니다.

Index Monitoring

인덱스를 모니터링하여 사용 여부를 확인할 수 있습니다. 그런 다음 사용하지 않는 인덱스를 삭제하여 불필요한 문 오버헤드를 없앨 수 있습니다.

Instance Manager

Instance Manager는 액세스할 수 있는 다양한 데이터베이스의 상태를 확인할 수 있도록 디자인되었습니다.

Log Switch Frequency Map

이 화면에는 데이터베이스가 로그 전환을 수행하는 시점이 표시됩니다. 이 창을 사용하여 로그 전환이 균형을 이루는지 판단할 수 있습니다.

LogMiner

SCN(System Change Number)으로 인해 손상 문제가 발생한 경우 LogMiner를 사용하여 데이터베이스를 쉽게 분석하고 손상 전의 트랜잭션으로 복구할 수 있습니다.

New Database 마법사

Toad Database 마법사는 Orace 데이터베이스를 신속하게 만들 수 있는 방법을 DBA에 제공합니다. 이 마법사는 5개의 화면으로 구성되는 마법사 스타일 인터페이스를 제공합니다. 이러한 화면에서는 데이터베이스 매개 변수 파일(INIT.ORA)을 생성하기 위한 매개 변수 값뿐만 아니라 마법사가 생성한 배치 파일(Windows) 또는 스크립트(UNIX)에서 나중에 실행될 수 있는 SQL 파일을 생성하는 데 사용되는 값을 선택하라는 메시지가 표시됩니다.

NLS(National Language Support) Parameters

세션, 인스턴스 및 데이터베이스 매개 변수 설정을 보고 세션 및/또는 인스턴스 매개 변수를 변경할 수 있습니다.

다음을 포함하는 운영 체제 유틸리티

  • Unix Monitor – Unix Monitor를 사용하면 상위 10개 장치에 대한 CPU Usage, Process Queues, Disk IO in Kb/Sec 차트와 사용자별로 정보를 세분화하는 한 개의 프로세스 목록 그리드를 사용하여 데이터베이스 성능을 모니터링할 수 있습니다. 프로세스 목록에는 기본적으로 %CPU로 정렬되는 상위 20개 CPU 사용 프로세스가 표시됩니다.

  • Unix Job Scheduler - Unix 컴퓨터에 대한 작업을 예약할 수 있습니다.

  • Windows Registry Parms - Toad와 Oracle을 더 효율적으로 실행하기 위해 Windows 레지스트리 매개 변수를 쉽게 설정할 수 있습니다.

  • Unix Kernel Parms - Toad와 Oracle을 더 효율적으로 실행하기 위해 Unix 커널 매개 변수를 쉽게 설정할 수 있습니다.

Oracle Parameters

Base Toad를 사용하여 Oracle Parameters를 볼 수 있지만 Quest DBA Module에서 매개 변수를 변경할 수 있습니다.

Pinned Code

코드를 항상 액세스할 수 있고 새 데이터로 덮어쓰지 않도록 메모리 버퍼에 코드를 고정할 수 있습니다.

Redo Log Manager

데이터베이스의 다시 실행 로그를 유지 관리할 수 있습니다. 다시 실행 레코드는 다시 실행 로그 버퍼에 저장된 다음 버퍼가 가득 차거나 연관된 트랜잭션이 커밋될 경우 다시 실행 로그 파일에 기록됩니다. Redo Log Manager를 사용하여 이러한 버퍼의 크기와 이름을 관리할 수 있습니다.

Resource Plan Scheduling

리소스 계획에 대한 일정을 쉽게 예약 및 변경합니다. 리소스 계획 일정을 변경하려면 SYSDBA로 로그인해야 합니다.

Segment Advisor

테이블, 인덱스 및 파티션을 검사하여 SHRINK 명령으로 공간을 회수할 수 있는지와 회수할 수 있는 공간 크기를 확인합니다.

Tablespaces Map

이 맵은 데이터베이스의 테이블 공간에 대한 그래픽 보기를 제공합니다.

Top Session Finder

가장 많은 리소스를 소비하는 데이터베이스의 세션을 찾을 수 있습니다. Oracle에서는 데이터베이스의 각 세션에 대한 수백 개의 통계를 추적하며 사용자는 Top Session Finder를 통해 임의의 조합된 매개 변수 사용에 따라 세션을 쉽게 정렬할 수 있습니다.

Undo Advisor

Undo Advisor는 조언을 제공하며 데이터베이스 실행 취소 환경의 설정을 자동화하는 데 도움을 줍니다. Undo Advisor는 현재 실행 취소 구성의 전체적인 상태나 지정된 시간 범위 내의 상태를 알려줍니다.

Schema Browser 및 Database|Create 메뉴

Schema Browser 및 Database|Create 메뉴에서 Quest DBA Module은 다음 기능을 추가합니다.

  • Dimensions- 차원을 만들거나 변경할 수 있습니다.

  • Directories – 디렉토리를 만들거나 변경할 수 있습니다.

  • Libraries – 라이브러리를 만들거나 변경하거나 삭제할 수 있습니다. 또한 세부 정보를 볼 수 있습니다.

  • Oracle Scheduler - 다음을 포함하는 Oracle Scheduler 기능이 지원됩니다.

  • Sched.Programs

  • Sched.Schedules

  • Sched.Jobs

  • Sched.Job Classes

  • Sched.Windows

  • Sched.Window Groups

  • Policies - 정책을 작성, 활성화, 비활성화, 편집 및 삭제할 수 있습니다. 또한 정책 세부 정보를 볼 수 있습니다.

  • Policy Groups - 정책 그룹을 만들거나 삭제할 수 있습니다.

  • Profiles - 프로파일을 만들거나 수정하거나 삭제할 수 있습니다. 또한 리소스 세부 정보를 볼 수 있습니다.

  • Roles - 역할을 만들거나 변경하거나 삭제할 수 있습니다. 또한 역할 및 권한 세부 정보를 볼 수 있습니다.

  • Rollback Segments - 롤백 세그먼트를 만들거나 변경하거나 삭제할 수 있습니다. 롤백 세그먼트를 온라인 또는 오프라인으로 만들 수 있습니다. 또한 롤백 세그먼트의 매개 변수에 대한 세부 정보를 볼 수 있습니다.

  • Refresh Groups - 그룹에서 구체화된 보기를 추가 및 제거하거나 그룹을 삭제할 수 있습니다.

  • Resource Plans - 리소스 계획을 만들거나 변경하거나 삭제할 수 있습니다. 또한 세부 정보와 일정 계획을 볼 수 있습니다.

  • Resource Consumer Groups - 리소스 소비자 그룹을 만들거나 변경하거나 삭제할 수 있습니다.

  • System Privs - 시스템 권한을 받는 사람을 쉽게 구성할 수 있습니다.

  • Tablespaces - 테이블 공간을 만들거나 변경하거나 삭제할 수 있습니다. 테이블 공간을 온라인 또는 오프라인으로 만들 수 있습니다. 또한 테이블 공간의 세부 정보를 볼 수 있습니다.

View Tablespaces

Space, Space History 및 IO History 탭은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

또한 Tablespace Details 창에는 Schema Browser|Tablespaces 탭에 있는 것과 동일한 정보가 표시됩니다. 그러나 고유한 창에 표시되기 때문에 스크롤 없이 대부분의 그리드를 볼 수 있습니다.

Code Road Map 및 ER diagram

이러한 두 창에 있는 Create Object scripts 단추는 Quest DBA Module에서만 사용할 수 있습니다. Code Road Map 및 ER Diagram을 참조하십시오.

Flat File Export 창

SQL*Loader 탭은 Quest DBA Module에서만 사용할 수 있습니다. Flat File Export를 참조하십시오.

Knowledge Xpert™ for Oracle Administration

Knowledge Xpert™ for Oracle Administration은 DBA의 일상적인 업무를 완전하게 예측하는 포괄적인 Windows 기반의 기술 리소스입니다. DBA가 문제를 해결하고 솔루션을 적용하는 데 필요한 통찰력, 데이터베이스 분석 정보 및 작업 예를 수천 개의 항목에서 제공합니다.

다음과 같이 DBA 작업에 도움을 줍니다.

  • 여러 버전 범위(Oracle 7.3 - 10g)를 제공하므로 대답을 찾기 위해 매뉴얼 사이를 이동할 필요가 없습니다.

  • 여러 버전의 Oracle에서 25,000개 이상의 오류 메시지(10g 메시지 포함)를 조회합니다.

  • 고유한 메모, 문서 및 심지어 웹 사이트를 추가하여 지식을 기록하고 팀과 공유할 수 있습니다.


창 권한 및 Toad

최소한 Toad를 설치, 실행 및 연결하고 기본적인 작업을 수행하려면 사용자가 Power User여야 하고, 연결에 사용할 Oracle 홈 디렉토리에 대한 읽기/쓰기 권한이 있어야 합니다. Power User인 경우에는 Oracle 클라이언트 폴더에 대한 읽기 액세스 권한도 추가로 필요합니다.


설치 메모: Toad를 읽기 전용으로 만들기

Toad for Oracle, 읽기 전용

Toad는 READONLY.LIC 및 FULLToad.LIC의 두 가지 라이센스 파일을 사용하여 읽기 전용으로 만들 수 있습니다.

Toad Read Only란?

Toad Read Only는 사용자가 데이터베이스를 변경하지 않고 Toad를 통해 데이터 및 SQL을 볼 수 있는 방식입니다.

Toad Read Only를 사용하는 이유

Toad Read Only를 사용하면 관리자가 사용자가 민감한 생산 인스턴스를 변경하는 문제에 대해 걱정할 필요 없이 사용자에게 강력한 도구를 제공할 수 있습니다.

Toad는 Oracle 사용자에게 권한을 부여하는 반면, Toad Read Only를 사용하면 사용자가 데이터베이스 내용을 절대 변경할 수 없게 됩니다.

Toad Read Only를 구하는 방법

Toad 설치를 모두 읽기 전용으로 만들 수 있으며 Toad Security를 사용하여 선택한 사용자 또는 역할을 읽기 전용으로 만들 수도 있습니다. 또는 사용자가 변경하지 못하도록 막아주는 제외 사항이 있는 특별 읽기 전용 설치 프로그램을 얻을 수도 있습니다.

Toad 설치를 읽기 전용으로 만드는 방법

라이센스 파일 사용

Toad는 Toad가 설치되어 있는 설치 디렉토리에 위치한 READONLY.LIC 및 FULLToad.LIC의 두 가지 라이센스 파일을 사용하여 읽기 전용으로 만들 수 있습니다.

Toad.EXE는 전체 Toad 또는 읽기 전용인지 확인하기 위해 Toad.LIC를 읽을 수만 있습니다. 라이센스 파일에는 읽기 전용 데이터베이스 액세스에 대한 설정이 포함되어 있습니다. 네트워크 관리자는 개별 워크스테이션의 Toad.LIC에 READONLY.LIC를 복사하여 해당 워크스테이션에서 Toad read-only를 만들 수 있습니다. Toad.LIC 파일은 반드시 Toad 폴더에 있어야 합니다.

이것은 Toad를 제한하는 방법 중 안전성이 최소한 보장됩니다.

읽기 전용 라이센스 파일을 사용하려면

  • 개별 워크스테이션의 TOAD.LIC에 READONLY.LIC를 복사합니다.

Toad Security

Toad Security를 사용하여 선택한 사용자 또는 역할에 Toad 읽기 전용을 만들 수 있습니다. 데이터베이스 개체를 봐야 하지만 변경할 권리는 없는 경우에 유용합니다.

주: 이 Toad Security 옵션은 DBA 모듈에 적용되지 않습니다. Toad 전체를 제한하려면 해당 사용자의 DBA 모듈을 제한해야 합니다.

Toad Security를 사용하여 Toad를 읽기 전용으로 만들려면

  • Features 비 메뉴 목록의 Read-only Override 기능을 Toad Security 창의 Restricted 기능으로 이동합니다. 이렇게 하면 선택한 사용자에게 Toad는 읽기 전용이 됩니다.

Toad Read Only 설치

Quest Software, Inc.는 Toad의 읽기 전용 복사본을 제공할 수 있습니다. Toad Standard Edition - READ ONLY 설치는 사용자가 데이터베이스를 변경하지 못하도록 설계된 읽기 전용 실행 파일입니다. 따라서 Quest ScriptRunner(스크립트를 기록하여 데이터베이스 개체를 업데이트할 수 있음), SQLMonitor(OCI 계층을 사용하여 SQL 호출 기록) 또는 Server Side Install(Toad 스키마를 변경할 수 있음)은 포함되지 않습니다.

Toad Standard Edition - READ ONLY 설치를 다운로드하려면

  • Toad Standard Edition - READ ONLY 설치는 Quest Software 기술 지원 다운로드 사이트에서 사용하거나 다운로드할 수 있습니다.


설치 메모: 네트워크 설치

네트워크 설치

Toad를 네트워크 설치를 통해 설치할 경우(자세한 내용은 Toad 시작 안내서 참조) Toad 라이센스 키가 서버에 기록됩니다.

클라이언트측에서는 Toad를 처음으로 실행할 때 라이센스 키를 묻는 메시지가 표시됩니다. Toad를 처음으로 실행할 때 서버가 읽기 전용이면 안 됩니다.


Citrix 지원

Toad는 Citrix 서버에 설치할 수 있습니다.

Citrix 서버에 Toad 설치

Citrix 관리자가 Citrix 서버에 Toad를 설치해야 합니다. 그런 다음 사용자는 Citrix 로그온을 통해 이러한 인스턴스로 연결하게 됩니다.

Citrix 지원은 적절한 설치 옵션(Select Installation Type 대화상자의 Citrix/Terminal Server)으로 활성화됩니다. Toad에는 설치 도중 해당 서버 레지스트리의 쓰기 액세스가 필요하며 런타임 도중 Citrix 지원을 받기 위해 읽기 액세스가 필요합니다.

Citrix 서버에 Toad를 설치하는 전체 과정은 시작 안내서에 있습니다.

Citrix를 통해 Toad에 연결

클라이언트를 통해 연결하려면

  • Citrix Program Neighborhood로 로그인하고 Toad를 실행합니다.

주: 처음 Toad를 실행하면 라이센스 키를 입력하라는 메시지가 표시됩니다. Citrix 관리자가 라이센스 키를 제공할 것입니다.

Citrix의 사용자 구성 파일

Toad는 Citrix 서버에 설치되고 개별 사용자 설정은 각 클라이언트 시스템에 유지됩니다.

개별 사용자 설정 및 속성 파일은 사용자의 설정 파일에 유지됩니다.

C:\Documents and Settings\user_name\Application Data\Quest Software\Toad

주: 로드 균형 조정 또는 로밍 Citrix 사용자가 있는 경우 사용자 파일 디렉토리를 지정하려고 할 것입니다. 이 작업은 개별 사용자 시스템마다 이루어져야 합니다. (Options|General|User Files Directory 참조)

Script Manager 및 Citrix

Toad는 Script Manager로 패키지 SQL 스크립트를 설치합니다. Toad가 Citrix 환경에서 실행되고 있으면 이러한 스크립트 관리자 파일의 기본 경로가 잘못됩니다.

이러한 파일을 사용하려면 수동으로 경로를 한 번에 변경해야 합니다.

Citrix와 함께 사용하기 위해 Script Manager 경로를 변경하려면

  1. Utilities|Script Manager를 열고 드롭다운 상자에서 DBA category를 선택합니다.

  2. 이동 단추를 누르고 새 경로를 입력합니다. C:\Documents and Settings\User Name\Application Data\Quest Software\TOAD\ScriptMgr\DBA.

  3. Schema Objects 카테고리도 위와 마찬가지로 반복하고 C:\Documents and Settings\User Name\Application Data\Quest Software\TOAD\ScriptMgr\Schema Objects로 이동합니다.


자동 설치

Toad for Oracle에는 자동 설치를 구성하는 기능이 있습니다. 다른 설치 옵션에 대한 자세한 내용은 시작 안내서를 참조하십시오.

자동 설치 구성

구성 파일을 작성하려면

설치 실행 파일과 동일한 폴더에 install_values.ini라는 파일을 작성합니다. 이 파일은 설치 프로그램이 구성 변수를 찾는 위치입니다.

다음 텍스트를 파일에 복사합니다.

[INSTALLATION]

INSTALL_TYPE=A

UPGRADE=A

INSTALL_DIR=C:\Program Files\Quest Software\Toad for Oracle9.0

NETWORK_DIR

KXPERT=A

SQL_OPTIMIZER=A

TOADSHORTCUT=YES

LICENSE_KEY=

LICENSE_MSG=

"=" 오른쪽에 값을 입력하고 파일을 저장합니다. install_values.ini를 원하는 만큼 복사하여 변형할 수 있지만 런타임 시 설치 프로그램에서는 install_values.ini만 찾습니다. 변수 자체의 이름을 바꾸지 마십시오.

구성 변수

INSTALL_TYPE

A - 전체 로컬 설치

B - Network 설치, 클라이언트측(서버측을 먼저 설치해야 함)

C - Network 설치, 서버측

D - Citrix 설치

UPGRADE

A - 새로 설치

B - 이전 버전에서 업그레이드

INSTALL_DIR

설치할 대상 폴더

NETWORK_DIR

서버측 설치의 대상 폴더

Client/Server 설치를 자동으로 설치하는 경우에는 서버측(설치 유형 'C')을 먼저 실행해야 합니다. 서버측 설치를 진행하는 동안 INSTALL_DIR 변수는 비어 있고 NETWORK_DIR 변수는 서버의 설치 경로를 가리켜야 합니다. 다음 클라이언트측 설치에서는 NETWORK_DIR 변수를 그대로 남겨 두고 INSTALL_DIR 변수가 클라이언트측에 대해 정의되어야 합니다.

KXPERT

A - Knowledge Xpert for PL/SQL 설치

공백 - Knowledge Xpert 설치 건너뛰기

SQL _OPTIMIZER

A - SQL Optimizer 설치

공백 - SQL Optimizer 설치 건너뛰기

TOADSHORTCUT

YES - 바탕 화면에 바로 가기 만들기

공백 - 바로 가기를 만들지 않음

LICENSE_KEY

Quest에서 발행한 라이센스 키 번호

LICENSE_MSG

Quest에서 발행한 라이센스 키 메시지(사이트 메시지)

주: Citrix 설치(설치 유형 'D')인 경우에는 LICENSE_KEY와 LICENSE_MSG 값이 서버에서 'ClientFiles' 하위 폴더에 있는 'QSAuth11.key'라는 파일에 복사됩니다. 그러면 초기 실행 시 Toad에서 이 파일을 로컬에 복사합니다.

업그레이드(UPGRADE=B)를 수행하는 경우에는 LICENSE_KEY와 LICENSE_MSG 값이 무시됩니다.

자동 설치 실행

구성 파일을 작성하여 실행 파일과 동일한 폴더에 저장하고 나면 자동 설치를 실행할 수 있습니다.

자동 설치를 실행하려면

  • 명령줄에서 다음 형식을 사용하여 설치를 실행합니다.

C:[download folder]\ToadforOracle90Setup /S

주: 맨 뒤의 “S”는 대문자여야 합니다.


설치 메모: SQL_Net 및 Net8

SQL*Net 및 Net8

Toad에는 32비트 Net 클라이언트 자체 외에는 지원되는 기타 라이브러리가 필요하지 않습니다.

Oracle 버전 | 클라이언트 소프트웨어 이름 | DLL 이름
Oracle 7 | SQL*Net | Oracle 7.x용 Ora7x.dll (예: Oracle 7.3.4용 Ora7.3.dll)
Oracle 8 및 8i | Net8 | Oraclient8.dll
Oracle 9i | Oracle Net | Oraclient9.dll
Oracle 10g Standard Client | Oracle Net | oraclient10.dll
Oracle 10g Instant Client(Universal Installer 버전) | Oracle Net | oraociei10.dll

위와 같이 설치된 클라이언트가 있고 Oracle 도구(SQL*Plus 예외)를 사용하여 Oracle에 연결할 수 있을 경우 Toad가 올바르게 작동해야 합니다.

주: 문제가 발생하는 가장 흔한 원인은 PATH 환경 변수의 재설정입니다. 기본 Oracle 홈은 Oracle Home 선택기(Oracle과 함께 제공)를 사용하여 정확하게 설정할 수 있습니다. (자세한 내용은 Oracle 관련 문서를 참조하십시오.)


설치 메모: 기타

설치 파일

INSTALL.LOG

INSTALL.LOG는 Toad 설치 도중 발생한 내용을 정확하게 나열하는 Toad 설치 스크립트에서 생성한 ASCII 파일입니다. 이 파일은 제거 엔진에서 사용되므로 편집하지 마십시오. 제거 엔진(UNINSTALL.EXE)은 INSTALL.LOG에서 찾은 모든 내용을 읽고 취소합니다. 이 파일을 사용하면 디스크 공간 또는 NT 권한 부족 등의 설치 문제를 진단하려고 할 때도 도움이 됩니다.

INSTALL.TXT

INSTALL.TXT는 또한 설치 시 생성되는 ASCII 파일로, 사용자에게 보다 친숙한 형식입니다. 기본적으로는 설치 스크립트의 진행 방식을 간략하게 기록한 것입니다. 아이콘 작성 문제 등의 설치 문제가 있는 경우 이 파일을 사용하면 문제가 발생하는 원인을 파악하는 데 도움이 됩니다.

UNINSTALL.EXE

제거 엔진입니다. 시작 메뉴에서 제거를 선택하거나 제어판에서 프로그램 추가/제거 애플릿을 선택합니다. 제거 엔진은 INSTALL.LOG에서 찾은 모든 내용(Toad의 파일, 아이콘 및 기타 부분 제거 등)을 읽고 취소합니다.


Toad Advisor

Toad는 자체적으로 진단합니다. Toad에서 해결할 수 없는 문제가 있을 경우 Toad Advisor의 도움을 받을 수 있습니다. 경고, 알림, 힌트 및 Toad 설치에 대한 현재 상태 정보를 제공합니다.

도움말 메뉴 아래에서 Toad Advisor를 찾을 수 있습니다.

Toad Advisor를 사용하려면

  1. Help 메뉴에서 Toad Advisor를 선택합니다.

  2. 상황에 맞도록 Toad를 조정하는 방법에 대한 내용은 트리 구조를 확인합니다.

  3. Warnings - 즉시 수정해야 할 내용을 설명합니다.

  4. Alerts - Toad의 기능에 영향을 줄 수 있는 내용을 설명합니다.

  5. Hints - Toad 사용 방식에 영향을 줄 수 있는 Toad 설치에 대한 내용을 제공합니다.

  6. Performance suggestions - 성능 속도 향상을 위해 변경할 수 있는 설정을 설명합니다.


필요한 V$표

주: 이 목록은 항상 확장 중입니다. "Table does not Exist" 오류가 발생하면 Toad가 사용 중인 코드를 보기 위해 화면으로 SQL을 스풀링하여 누락된 표를 찾을 수 있습니다.

선택한 Toad 창에 필요한 V$ 동의어 액세스는 다음과 같습니다.

AutoTrace (Editor/Query Builder)

V_$Sesstat

V$Statname

V$Session

Optimization & Session Info 화면

다음 공개 동의어가 있어야 합니다.

v$rowcache

v$sysstat

v$system_event

v$librarycache

v$STATNAME

v$SESSTAT

v$sess_io

v$session

v$process

v$latch

Database Browser

다음 공개 동의어가 있어야 합니다.

V$DATABASE

v$datafile

v$filestat

V$INSTANCE

v$latch

v$librarycache

V$OPTION

V$PARAMETER

v$rollname

v$rollstat

v$sess_io

v$session

v$sesstat

v$sgastat

v$sqlarea

v$statname

v$sysstat

v$system_event

v$tablespace

Database Probe

다음 공개 동의어가 있어야 합니다.

V$ARCHIVE_PROCESSES

V$BH

v$buffer_pool

V$buffer_pool_statistics

v$database

v$dispatcher

V$INSTANCE

v$librarycache

v$library_cache_memory

V$LOG

V$LOG_history

V$PARAMETER

v$pq_slave

v$process

V$ROWCACHE

v$session

V$SESSTAT

v$sga

v$sgastat

V$STATNAME

v$sysstat

v$version

DBA > Database Monitor

다음 공개 동의어가 있어야 합니다.

v$sysstat

v$system_event

v$session

v$librarycache

x$ksllt

v$sgastat

DBA > Database Health Check

다음 공개 동의어가 있어야 합니다.

v$version

v$instance

v$sysstat

v$librarycache

v$rowcache

v$sgastat

v$parameter

v$database

v$log_history

v$filestat

v$datafile

v$tablespace

DBA>Index Monitor

자신의 소유가 아닌 색인을 보려면 다음을 액세스할 수 있어야 합니다.

sys.ob$

sys.ind$

sys.user$

sys.object_usage

또한 ALTER ANY INDEX 권한이 있어야 합니다.

DBA > Oracle 매개 변수

다음 공개 동의어가 있어야 합니다.

v$parameter

DBA > LogMiner

다음 공개 동의어가 있어야 합니다.

v$logmnr_contents

v$logmnr_logs

또한 다음 내용이 있어야 합니다.

  • DBMS_logmnr 실행 권한

  • DBMS_logmnr_d 실행 권한

  • init.ora의 매개 변수 UTL_FILE_DIR 집합(Oracle 8i에만 해당)

디버깅

특별 공개 동의어가 필요하지는 않지만

DBMS_DEBUG가 유효해야 합니다.

10g 데이터베이스:

Debug Connect Session 권한이 부여되어야 합니다.

eBiz Module

SYS.OBJ$ -- 브라우저의 Activity 탭에서만 사용

SYS.USER$ -- 브라우저의 Activity 탭에서만 사용

V$INSTANCE -- 브라우저의 Activity 및 'User' 탭에서만 사용

V$LOCK -- 브라우저의 Activity 탭에서만 사용

V$PROCESS -- 브라우저의 Activity 탭에서만 사용

V$SESS_IO -- 브라우저의 Activity 탭에서만 사용

V$SESSION -- 브라우저의 Activity 탭에서만 사용

또한 여러 Oracle 응용프로그램 보기에 대한 SELECT 권한이 필요합니다. 자세한 내용은 eBiz 사용 권한 요구 사항을 참조하십시오.

Instance Manager > Shutdown

다음 공개 동의어가 있어야 합니다.

v$parameter

V$INSTANCE

Tools > SGA Trace

다음 공개 동의어가 있어야 합니다.

v$sqlarea

v$sqltext_with_newlines

또한 다음 내용이 있어야 합니다.

V$ Oracle Dictionary 보기 액세스

Toad Server Statistics > Analysis

다음 공개 동의어가 있어야 합니다.

V$SESS_IO

V$SESSION

V$PROCESS

V$STATNAME

V$ROWCACHE

V$SYSSTAT

V$SYSTEM_EVENT

V$LIBRARYCACHE

V$SESSION_PRIVS

Toad Server Statistics > Waits

다음 공개 동의어가 있어야 합니다.

V$SYSTEM_EVENT

Toad Server Statistics > Latches

다음 공개 동의어가 있어야 합니다.

V$LATCH

Toad Server Statistics > Sessions

다음 공개 동의어가 있어야 합니다.

V$SESS_IO

V$SESSION

V$PROCESS

V$STATNAME

Toad Server Statistics > Instance Summary

다음 공개 동의어가 있어야 합니다.

V$SYSSTAT

Toad Session Browser

다음 공개 동의어가 있어야 합니다.

V$SESSION

V$PROCESS

V$SESS_IO

V$SESSION_WAIT

V$SESSION_EVENT

V$ACCESS

V$SESSSTAT

V$STATNAME

V$OPEN_CURSOR

V$SQL

V$LOCK

V$SESSION_LONGOPS

V$SQLTEXT_WITH_NEWLINES

또한 다음을 액세스할 수 있어야 합니다.

SYS.V_$TRANSACTION

SYS.V_$ROLLNAME

Space Manager 설정

다음 공개 동의어가 있어야 합니다.

V$SYSSTAT

Toad 스키마는 작업 작성 및 변경, 표와 프로시저 작성 및 삭제에 대한 권한이 있어야 하며 다음에 대한 SELECT 액세스가 가능해야 합니다.

DBA_DATA_FILES

DBA_FREE_SPACE

DBA_JOBS

DBA_TABLESPACES

V_$FILESTAT


속성 파일

Toad의 옵션 설정은 여러 위치에 저장됩니다. 적은 옵션만 재설정 또는 공유하기 쉽도록 이러한 방식을 유지합니다.

위치 | 옵션 파일 | 기능
Toad for Oracle 디렉토리 | 3rdprtylic.txt | 타사 사용권 계약 사본 포함
 | beef.dat | 파일 브라우저 내보내기
 | chc.rev | CodeXpert
 | CMDLineCEGrid.xslt | CodeXpert 명령줄 - 눈금
 | CMDLineCEScripts.xslt | CodeXpert 명령줄 - 스크립트
 | CMDLineCETrees.xslt | CodeXpert 명령줄 - 트리
 | cvs.ini | CVS 무결성을 위한 옵션 및 로그인을 포함합니다.
 | DatabaseProbe.txt | 설정을 저장하고 Database Probe에 경고합니다.
 | FmtPlus.opt, FmtOptions.ini | 코드 포맷용 옵션을 포함합니다.
 | install.txt | Toad 설치 시작 및 종료 시간을 포함합니다.
 | install.log | Toad 설치 세부 사항 로그 파일
 | qc0450.chm | SQL Optimizer(Tuner) 도움말 파일
 | qexplainplan2full.msi | Explain plan 설치 파일
 | QSR.ini | Quest ScriptRunner(qsr.exe)용 설정을 저장합니다.
 | releasenotes.html | Toad 릴리스 정보
 | rolelog.txt | 이전에 작성한 Team Coding 역할을 저장합니다.
 | RNetPin.ini | CHC.rev 파일의 전체 경로를 저장합니다. 설치 프로그램에 의해 설치되고 Toad 디렉토리를 다른 위치에 복사할 경우 수정이 필요합니다.
 | RuleUniverse.xml | CodeXpert 규칙을 저장합니다.
 | SBQueries.dat | Schema Browser의 사용자 정의 질의를 저장합니다.
 | SettingsLocations.ini | /User 파일 폴더의 경로를 저장합니다.
 | SilentInstallNotes90 | 자동 설치 지침을 저장합니다.
 | TNSLoad.xslt | TNSNames Editor
 | TNSSave.xslt | TNSNames Editor
 | TNSValidate.xslt | TNSNames Editor
 | unidbmon.cfg | Quest SQL Monitor(SQLMonitor.exe)용 설정을 저장합니다.
Toad for Oracle\RuleSets 디렉토리 |  | CodeXpert용 RuleSets를 포함합니다. Toad에서 RuleSets dialog box를 제외하고 이를 수정하면 안됩니다.
Toad for Oracle\User 파일 | aliases.txt | 이전에 사용한 표 별칭을 저장합니다.
 | codemap.ini | 개체용 색상을 Code Road Map에 저장합니다.
 | CodeXpert.ini | CodeXpert에서 사용하는 모든 규칙 집합의 위치 및 이름을 저장합니다. 또한 CodeXpert가 사용하는 모달 창의 창 크기 조절 및 위치를 저장합니다.
 | coloring.txt | Script Engine(QSE.exe) 구문 강조표시.
 | coloring1.txt | Script Engine(QSE.exe) 구문 강조표시.
 | connections.ini | server login 창의 연결 정보를 저장합니다.
 | Connectionpwds.ini | 서버 정보 및 Toad에서 저장하기로 선택한 모든 암호를 저장합니다. 하나의 시스템에 연결되어 있습니다. Toad 설정을 다른 시스템으로 이동할 경우 암호는 관찰되지 않습니다.
 | DatabaseBrowser.tdb | Database Browser의 왼쪽에 대한 트리 보기를 저장합니다.
 | DatabaseProbe.ini | 사용자 정의 설정을 저장하고 Database Probe에 경고합니다.
 | DataModeler.ini | Query Builder의 구성을 저장합니다.
 | <dbname>\DefSchema.txt | 해당 데이터베이스의 기본 스키마 이름을 포함합니다.
 | <dbname>\<username>_tablefilters.xml | 특정 연결에 대한 오른쪽 눈금에 Schema Browser용 필터를 저장합니다.
 | <dbname>\<username>\ DefSchema.txt | user\database 조합의 기본 스키마 이름을 포함합니다.
 | DBWizSettings.ini | Database Creation 마법사 설정을 저장합니다.
 | desktops.xml | Toad 데스크탑 구성을 포함합니다.
 | EditorBars.ini | Editor의 사용자 정의 도구 모음 구성을 저장합니다.
 | Explainplancolumndefs.xml | Explain Plan의 기본 열 설정을 저장합니다.
 | ExplainPlanGlobalPrefs.xml | Explain Plan 텍스트 색상 및 글꼴을 저장합니다.
 | ExplainPlanUserPrefs.XML | Explain Plan 열 가시성 정보, 너비 및 순서를 저장합니다.
 | ExportWizSettings.ini | Export Utility 마법사 설정을 저장합니다.
 | Filters.txt | Grid|Filter Data 창의 이전 필터를 저장합니다.
 | Filecompare.ini | Differences Viewer 옵션을 포함합니다.
 | .FLT 확장자의 파일 | Schema Browser 필터를 왼쪽에 저장합니다.
 | SDF 확장자의 파일 | Script Manager의 카테고리를 저장합니다.
 | .TMD 확장자의 파일 | Master/Detail 브라우저의 구성 정보를 저장합니다.
 | FindDirs.txt | 디렉토리가 저장하는 Find 대화상자를 저장합니다.
 | ftp.ini | 사용자 FTP 정보를 저장합니다.
 | Healthcheck.htm | Database Health Check 파일.
 | htmlsub.txt | HTML 편집기 자동 고침 설정을 저장합니다.
 | ImportWizSettings.ini | Import Utility 마법사 설정을 저장합니다.
 | jobdates.txt | Toad를 통해 편집할 수 없지만 사용자가 변경하여 Create/Alter job 창의 드롭다운 메뉴를 변경할 수 있습니다.
 | LoginGrd.ini | Server Login 창의 눈금 구성을 저장합니다.
 | MenuShortcuts.ini | 기본 Toad 메뉴의 바로 가기 키를 사용자 정의합니다.
 | Newfunc.sql, Newproc.sql, Newpackage.sql, NewPackageBody.sql, NewPkgFunc.sql, NewPkgProc.sql, Newtrig.sql, Newtype.sql, Newtypebody.sql, NewTypefunc.sql, NewTypeproc.sql | Editor에서 새 개체를 작성하는 데 필요한 기본 템플릿.
 | Oracle 8i Data Dictionary.sdf | 미리 작성된 Oracle 8i 사전 스크립트를 포함하고 있는 Script Manager 데이터 파일.
 | Params.txt | SQL Editor의 한 줄(스크립트로 실행 안됨) 질의 매개 변수.
 | Project.tpr | Project Manager 창의 정보를 포함합니다.
 | Project_bak.tpr | Project Manager 창의 정보를 백업으로 포함합니다.
 | ProjectConfig.txt | Project Manager 창의 정보를 포함합니다.
 | SavedSQL.xml | 명명된 SQL, 개인 SQL 및 SQL 기록을 저장합니다.
 | SBFilterList.xml | Schema Browser 필터 목록.
 | SBProjManFilterList.xml | Project Manager의 Schema Browser 필터를 저장합니다.
 | SchemaCompSummary | Schema Compare 기능의 요약 정보를 저장합니다.
 | SchemaObjects.sdf | 미리 작성한 Schema 개체가 포함된 Script Manager 데이터 파일.
 | Services.ini | Service Manager 창의 서비스 목록을 저장합니다.
 | SGATrace.ini | SGA Trace 창 눈금의 레이아웃을 저장합니다.
 | SQLLoaderSettings.ini | SQL*Loader 마법사 설정을 저장합니다.
 | Sysviews.txt | 시스템 보기 이름을 유지합니다.
 | templates.xml | MakeCode 및 CodeSnippets 템플릿을 저장합니다.
 | temptxt.txt | Schema Compare의 임시 텍스트를 저장합니다.
 | Terr.sql | 내보내기 부여를 포함합니다. 저장하는 동안 연결이 끊어지면 이 파일이 작성됩니다.
 | TOAD.INI | View|Toad 옵션의 대부분의 항목을 포함하는 여러 기본 Toad 옵션을 저장합니다.
 | Toad_GUI.ini | Toad Session Browser GUI 설정을 저장합니다.
 | Toad_GUI2.ini | 기타 Toad 창의 GUI 설정을 저장합니다.
 | Toad_SessBrowFilters.ini | Session Browser의 필터를 저장합니다.
 | ToadMAIL.ini | View|Toad Options|Email Settings의 설정을 저장합니다.
 | ToadMONITORS.ini | View|Toad Options|Monitors and View|Toad Options|Instance Manager의 설정을 저장합니다.
 | ToadParams.ini | 이전에 디버거에 입력한 매개 변수를 저장합니다.
 | ToadRun.txt | Toad 명령줄 실행 파일.
 | Toad_SessBrowFilters.ini | Session Browser의 필터를 저장합니다.
 | toadstats.ini | Toad를 통해 편집할 수 없지만 DBA|Server Statistics 창에 영향을 주도록 사용자가 변경할 수 있습니다.
 | toolbars.ini | 기본 Toad 창의 도구 모음 및 메뉴 구성.
 | TopSess.ini | Top Session Finder의 프로필 목록을 포함합니다.
 | views.txt | 사용자 검토를 유지합니다.
 | \<servicename>\ <username>Syns.txt | 구문 강조표시의 동의어 목록을 포함합니다.
 | \<servicename>\ <username>Views.txt | 구문 강조표시의 동의어 및 보기 목록을 포함합니다.
 | \<servicename>\ projects.lst | Schema Browser의 Favorites 탭 구성을 포함합니다.
Toad for Oracle\unixjobs 디렉토리 | .JDF 확장자의 파일 | Unix Scheduler 정보를 저장합니다.


Toad INI 파일 설정

Toad INI 파일

TOAD.INI 파일을 수동으로 편집해야 할 몇 가지 설정이 있습니다. 기타 설정의 경우 적합한 GUI를 사용합니다.

SQL Results 패널 분할자

[SETTINGS]

SLIDER_TOP=200

MDI 창을 너무 작게 조절하여 SQL Results 패널을 볼 수 없을 경우 Toad를 종료하고, 이 값을 150 또는 200의 낮은 수로 편집한 다음 Toad를 다시 시작합니다. 기본값은 없습니다.

사용자의 표 삭제 또는 잘림 방지

[SETTINGS]

ALLOW_DROP_TBL=0

기본값으로 Toad는 사용자가 표를 삭제하고 자를 수 있도록 허용합니다. Toad 사용자에게 이러한 권한을 부여하고 싶지 않으면 TOAD.INI 파일에 ALLOW_DROP_TBL=0을 삽입합니다. 기본값은 1입니다.

프로시저 식별자와 이름 사이에 설명 삽입

기본값으로 TOAD.INI 파일에 자동으로 포함되어 있지 않습니다. 다음과 같이 추가할 수 있습니다.

[SETTINGS]

PELineOffsetOverride=1

On은 1이며 0으로 설정하여 삭제하지 않고 끕니다.

프로시저의 식별자와 이름 사이에 설명을 삽입하고자 할 경우 이 값을 설정해야 합니다.

프로시저 작성 또는 교체
-- xx
-- yy
aaa
as
begin
raise no_data_found ;
end ;
/

Toad가 위의 예에서 올바른 줄 번호를 사용하도록 이 설정은 (PELineOffsetOverride=1)이어야 합니다.

하지만 (PELineOffsetOverride=1)일 경우 다음 작업을 수행하는 위치에서 잘못된 줄 번호를 얻게 됩니다.

프로시저 aaa 작성 또는 교체
-- xx
-- yy
as
begin
raise no_data_found ;
end ;
/


Oracle\Temps\ToadStats.ini 파일에 Toad를 생성하는 방법

Toad Server Statistics 창의 Analysis 탭에서 Oracle\Temps\ToadStats.ini 임계값 파일에 Toad가 없으면 다음 기본 임계값이 사용됩니다.

INI 항목 | 최소값 | 경고값 | 최대값 | 설명 | 경고 메시지
dg_row | -9999 | -9999 | -9999 | 사전 얻기 | n/a
dm_row | 98 | -9999 | -9999 | 사전 누락 | n/a
dcr_row | -9999 | -9999 | -9999 | 사전 캐시 히트 비율 | 사전 캐시 누락 높음
bcr_row | 90 | -9999 | -9999 | 버퍼 캐시 히트 비율 | db_block_buffers 증가 필요
dsr_row | -9999 | -9999 | 10 | 디스크 정렬 비율 | SORT_AREA_SIZE 증가 또는 SQL 조정
bbw_row | -9999 | -9999 | 1 | 버퍼 사용 중 대기 비율 | 표에 빈 목록이 충분하지 않음 또는 롤백 세그먼트 또는 익스텐트 너무 적음
fbw_row | -9999 | -9999 | 1 | 버퍼 대기 비율 여유 있음 | 디스크 정렬 너무 많음
lchr_row | 85 | -9999 | -9999 | 라이브러리 캐시 얻기 히트 비율 | 동적 또는 공유 불가능 SQL
lcpr_row | -9999 | -9999 | 1 | 반복 공간 대기 비율 | n/a
lcpr_row | 90 | -9999 | -9999 | 라이브러리 캐시 핀 히트 비율 | 공유 풀 영역이 너무 작음
rswr_row | -9999 | -9999 | 1 | 반복 공간 대기 비율 | n/a
cfr_row | -9999 | -9999 | 0.01 | 연속 가져오기 비율 | 표에 PCTFREE가 너무 적음
per_row | -9999 | -9999 | 20 | 분석/실행 비율 | 실행 시 분석 비율 높음
cpo_row | -9999 | -9999 | 15 | cpu 분석 오버헤드 | 분석 cpu 오버헤드 높음
tsr_row | -9999 | -9999 | -9999 | 색인/총 행의 행 비율 | 낮은 비율이 꽉 차있음을 나타냄
dbwra_row | -9999 | -9999 | 255 | DBWR 평균 스캔 깊이 | # DB_FILES 너무 높음
dbwrs_row | -9999 | -9999 | -9999 | DBWR 평균 버퍼 스캔 | n/a

-9999 = 값 없음

사용자 정의 임계값을 설정하려면 ToadStats.ini라는 ini 파일을 작성합니다. 이 파일은 Toad의 Oracle\Temps 폴더에 둡니다.

위의 각 "INI 항목"에 최소값, 경고값 및 최대값을 설정할 수 있습니다. 또한 경고값이 초과되면 사용자 정의 제목을 지정하고 경고 메시지를 설정할 수 있습니다.

경고값이 초과되면 원이 분홍색으로 바뀝니다. 최대값이 초과되면 원이 빨간색으로 바뀝니다.

표준 Windows .ini 형식과 같이 왼쪽 및 오른쪽 괄호에 "INI 항목" 문자열을 둡니다. 이렇게 하면 섹션이 됩니다. 그런 다음 각 섹션에 Min, Warn, Max, Title 및 ErrorMsg 항목을 배치할 수 있습니다.

예:

[dm_row]

Min=98

[bcr_row]

Min=90

[dsr_row]

Max=10

[bbw_row]

Max=1

[fbw_row]

Max=1

[lchr_row]

Min=85

Warn=90

ErrorMsg=Dynamic or Unsharable SQL?

[lcpr_row]

Max=190

Warn=80

Title=library cache pin hit ratio

[rswr_row]

Max=1

[cfr_row]

Max=0.01

[per_row]

Warn=17

Max=20

Title=Parse to Execute Ratio

ErrorMsg=High parse to execute ratio

[cpo_row]

Max=15

[dbwra_row]

Max=255


구성 파일 전송

새 컴퓨터에 Toad를 설치할 경우 새 시스템에 설정, 개인 SQL, SQL 기록 및 명명된 SQL 구문을 이동할 수 있습니다. 이렇게 하면 모든 설정을 다시 작성하지 않아도 됩니다.

이렇게 하려면 이전 시스템의 다음 파일을 새 시스템에 복사해야 하며 파일 구조는 동일해야 합니다. 이것이 기본 설정입니다. 개인별 설정을 모두 송신하려면 사용자 정의할 수 있는 구성 파일의 추가 정보는 속성 파일 항목에서 찾을 수 있습니다.

위치 | 내용
<Toad folder>\TOAD.INI | Toad 설정
<Toad folder>\ToadParams.ini | Toad 매개 변수(Toad 매개 변수를 설정하지 않았을 경우 이 파일은 없습니다.)
<Toad folder>\perssqls.dat | 개인 SQL
<Toad folder>\sqls.dat | SQL 기록
<Toad folder>\temps\namedsql.dat | 명명된 SQL 구문
<Toad folder>\toolbars.ini | 도구 모음 구성


서버측 개체 설치

Toad의 여러 기능에는 Oracle 인스턴스의 서버측에 설치된 개체가 필요합니다. 이러한 개체는 Toad 스키마, 개별 스키마, 또는 공개 액세스가 가능한 세 번째 스키마에 설치할 수 있습니다. 이 중 하나 이상에 설치하지 못할 수도 있거나 문제가 발생할 수도 있습니다.

서버측 개체 기능 | 기능을 설치할 수 있는 스키마
 | Toad | 개별 | 공개 액세스 가능
CodeXpert | X |  | X
Explain Plan† | X | X | X
Profiler | X | X | X
Team Coding | X |  | X
Space Manager* | X |  |
Security | X |  |

†Explain Plan 서버측 개체는 Toad 자체에서 설치 및 편집할 수 있지만 Server Side Objects 마법사에 포함되어 있지 않습니다.

* Space Manager 마법사는 Toad의 권한 설정을 돕지만 View Tablespaces 창은 개체를 설치 및 관리합니다.

주: 이러한 서버측 개체는 해당 기능에만 적용되며 Toad의 다른 기능은 서버측 개체가 없어도 성공적으로 실행됩니다.

주의: Explain Plan 표 및 Toad Profiler 개체는 Toad 스키마 또는 개별 사용자 스키마 중 하나에 설치해야 합니다.

Server Side Objects Install 마법사를 사용하면 해당 개체를 보다 쉽게 설치 및 관리할 수 있습니다. 마법사는 Toad를 설치할 때 실행되며 Toad 내에서 액세스하여 설치 후 개체를 따로 작성 또는 관리할 수 있습니다.

주: Server Side Objects Install 마법사의 단계 순서는 각 단계에서 선택한 내용에 따라 달라집니다. 따라서 설명은 도움말 파일에서 단계로 지정되지 않습니다. F1 키를 사용하여 현재 마법사의 단계에 해당하는 도움말 항목을 여는 것이 좋습니다.

설치 마법사가 열리면 기존의 TOAD.INI 파일을 찾습니다. 이 파일이 있으면 마법사가 Server Login 창에서 연결 옵션을 사용합니다(Toad Home, Force SQLNet 등).


Server Side Install 마법사 액세스

서버측 개체를 설치하려면 Toad 사용자 계정, 개체를 설치하는 스키마의 계정 또는 DBA 역할이 있는 계정에 액세스해야 합니다.

서버측 개체를 설치하려면

  1. Tools 메뉴에서 Server Side Objects Wizard를 선택합니다. 마법사가 나타납니다.

  2. 수행할 작업을 선택합니다.

  • 모든 사용자가 공유할 수 있도록 개체 설치, 업그레이드 또는 삭제

TOAD라는 특수 스키마를 작성 및 관리하려면 이 옵션을 사용합니다. 이 스키마는 Toad에서 위에 언급된 부분을 실행하는 데 필요한 테이블을 유지관리할 수 있는 중앙 위치를 제공합니다. 해당 개체 중 일부(Explain Plan 및 Profiler)는 개체를 사용하려는 모든 스키마에 작성할 수 있지만(즉, 모든 스키마에 동일한 필수 테이블이 있게 됨. 아래 참조.) 사용자가 많은 경우에는 TOAD 스키마를 사용하는 것이 보다 효율적입니다. 뿐만 아니라 Toad Security, ObjectName 및 Team Coding이 Toad 스키마에 상주해야 합니다.

  • 별도의 스키마가 사용할 수 있도록 개체 설치, 업그레이드 또는 삭제

Toad 사용자를 작성하지 않으려면 개체를 사용하려는 스키마에서 일부 개체를 작성 및 관리할 수 있습니다. 해당 특수 기능을 이용하려는 사용자가 소수이고 일부 사용자만 이 기능에 액세스하도록 하려면 이 방법이 더 효율적입니다.

  • 데이터베이스 연결 없이 설정 스크립트 작성

필요한 데이터베이스 연결에 액세스하지 않고 Toad 스키마를 설정하는 스크립트를 작성할 수 있습니다. 그런 다음 나중에 로그인하여 스크립트를 실행할 수 있습니다.

  3. Next를 누릅니다.


Toad 또는 기타 Publicly Accessible 스키마 관리

Server Side Objects Installation 마법사에서 Toad 스키마 작성 또는 관리를 선택하면 Toad 사용자 또는 DBA 역할이 있는 사용자 계정에 액세스할 수 있어야 합니다.

  • 수행할 작업을 선택합니다.

  • Toad 스키마의 공유 개체를 설치, 업그레이드 또는 삭제합니다.

  • 전체 Toad 스키마 및 개체의 모든 공개 동의어를 삭제합니다.

  • Toad가 아닌 스키마의 공유 개체를 설치, 업그레이드 또는 삭제합니다.

  2. 이 화면에 로그온 정보를 입력한 다음 Next를 누릅니다.

주: TNS 파일이나 LDAP 서버 중 어느 것을 사용하는 경우에도 서버가 데이터베이스 드롭다운에 나열됩니다.


Toad 사용자 삭제

Toad 사용자 및 모든 공개 동의어를 쉽게 삭제할 수 있습니다. 하지만 반드시 삭제한 다음 계속해야 합니다.

Toad 사용자를 삭제하려면

  1. Main 마법사 페이지(서버측 개체 설치 참조)에서 Drop Toad User를 선택하고 Next를 누릅니다. Connection information 화면이 나타납니다.

  2. 연결 정보를 입력합니다. 사용자는 이 작업 수행을 위해 데이터베이스에 대한 DBA 권한이 있어야 합니다. Toad 스키마를 삭제할 위치에 데이터베이스를 입력합니다.

  3. Next를 누릅니다.

  4. 확인 대화상자에 Toad 사용자 및 공개 동의어 삭제 여부를 묻는 메시지가 나타납니다. 입력한 정보를 다시 확인한 다음 Yes를 누릅니다.

Toad 사용자와 관련 공개 동의어가 삭제됩니다. 이전에 이 클라이언트를 사용하여 데이터베이스에 Team Coding을 설정한 경우에는 Team Coding용으로 작성한 모든 역할을 삭제할지 묻는 메시지도 표시됩니다.


Team Coding 역할 지정

Team Coding을 설치하기로 선택한 경우 Team Coding 환경에 사용되는 다양한 역할 또한 지정해야 합니다.

각 옵션에 대해 새 역할을 작성하고, 기존의 역할에 Team Coding 기능을 할당하고, PUBLIC에 역할 권한을 부여하거나 역할 작성을 무시할 수 있습니다.

Team Coding Administrator

이 역할은 Team Coding 구성에 필요한 모든 권한에 자동으로 부여됩니다. "Freeze Code"를 제외한 Team Coding의 모든 기능은 이 역할을 가진 사용자에게 사용할 수 있습니다.

Team Coding Project Manager

이 역할은 Code Control Groups(CCGs) 작성 및 삭제에 필요한 권한에 부여됩니다. 이 역할에서는 구성 및 "Freeze Code"를 사용할 수 없습니다.

Team Coding Team Leader Role

이 역할은 CCG 작성 및 수정에 필요한 권한 및 "Freeze Code" 능력에 부여됩니다. CCG 및 구성은 삭제할 수 없습니다.


TOAD 스키마 항목에 대한 표 공간 선택

Server Side Objects Install 마법사의 이 페이지에서 다양한 Toad 스키마 항목에 대한 표 공간을 선택할 수 있습니다.

표 공간이 필요한 항목은 다음과 같습니다.

  • Profiler 표

  • Toad Security 표

  • Team Coding 표 및 색인

드롭다운 메뉴를 사용하여 Toad 스키마 개체를 작성하는 기존의 표 공간에서 선택합니다. 표 공간을 선택하지 않을 경우 Toad 사용자의 기본 표 공간에 개체가 작성됩니다.


개체 선택

이제 관리 대상을 선택할 수 있습니다. 선택하면 Next를 누릅니다.

Toad 스키마를 선택한 경우 Toad는 이 스키마를 확인하고 상태와 함께 서버측 개체를 포함하는 기능을 나열합니다. 공개적으로 액세스할 수 있는 다른 스키마를 선택한 경우 Toad는 이 스키마를 확인하고 사용할 수 있는 기능을 나열합니다. 가능한 상태는 다음과 같습니다.

  • Found and OK

  • Not found

  • Error

오류는 문제를 보다 자세히 설명합니다. 예를 들어, 이전 Oracle 버전을 사용할 경우 Toad Profiler 아래에 다음과 같은 메시지가 나타날 수 있습니다.

Profiler not applicable to Oracle versions less than 8.1.

아니면 다음과 같은 문제가 발생할 수 있습니다.

Synonyms missing, Toad_PROFILER package is modified or out of date.

Toad 개체

Toad Security

관리자는 Toad 기능에 대한 사용자의 액세스를 제한할 수 있습니다.

주: 이 기능은 Toad 스키마에 설치되어 있어야 합니다.

Toad Security 개체의 경우 다음을 수행할 수 있습니다.

  • Add - 이 옵션을 사용하여 Toad Security 권한을 계속 추적하기 위해 필요한 Toad RESTRICTIONS 표를 추가할 수 있습니다.

  • Remove - Toad Security를 삭제하기로 선택할 수 있습니다. Toad 개체를 삭제하면 사용자의 스키마에 없을 경우 Toad의 일부를 사용할 수 없게 됩니다.

  • Administer - 이 옵션을 사용하여 Toad Security 표의 관리자를 작성 및 삭제할 수 있습니다. Toad Security에 대한 자세한 내용은 Toad Security 항목을 참조하십시오.

  • Add Security Admin을 눌러 대화상자를 표시하여 특정 사용자에게 관리자 권한을 추가합니다. 사용자를 선택하고 Grant를 눌러 권한을 추가합니다.

  • 눈금에서 관리자 역할의 사용자를 선택한 다음 Revoke Security Admin을 눌러 특정 사용자의 관리자 권한을 해지합니다.

Toad Profiler

DBMS_PROFILER에 대한 Toad의 인터페이스를 사용합니다.

주의: Toad Profiler 개체는 Toad 스키마 또는 개별 사용자 스키마 중 하나에 설치해야 합니다.

  • Add - 이 옵션을 사용하여 현재 Toad 스키마에 없는 개체를 추가할 수 있으며 이 개체는 DBMS_PROFILER에 대한 Toad의 인터페이스에 필요합니다.

  • Remove - 개체를 삭제하기로 선택할 수 있습니다. Toad 개체를 삭제하면 사용자의 스키마에 없을 경우 Toad의 일부를 사용할 수 없게 됩니다.

  • Drop and Recreate All - 이 옵션을 사용하여 Profiler에 필요한 개체를 모두 삭제한 다음 다시 작성합니다. 이 옵션은 Toad가 해결할 수 없는 Profiler 개체에 문제가 있을 경우 사용할 수 있습니다.

  • Recompile and Update - 이 옵션을 사용하여 Profiler 개체를 다시 컴파일하고 업데이트할 수 있습니다. 이 옵션은 Toad가 해결할 수 있는 Profiler 개체에 문제가 있을 경우 사용할 수 있습니다. Found and OK 상태이어도 Toad_PROFILER를 언제든지 업데이트할 수도 있습니다.

Team Coding

PL/SQL 개체를 체크인 및 체크아웃하고 선택적으로 해당 개체를 타사 소스 제어 제공자와 연결할 수 있습니다.

주: 이 기능은 Toad 스키마 또는 SQLNAV 등의 공개적으로 액세스할 수 있는 다른 스키마에 설치되어 있어야 합니다. SQL Navigator Team Coding 환경 사용 방법에 대한 자세한 내용은 SQL Navigator 환경에서 Team Coding 사용을 참조하십시오.

  • Add - 이 옵션을 사용하여 Toad 스키마에 Team Coding 개체를 추가할 수 있습니다.

  • Remove - 데이터베이스에서 Team Coding을 삭제하기로 선택할 수 있습니다.

CodeXpert

사용자는 보고서를 데이터베이스에 저장하고 나중에 검색할 수 있습니다.

  • Add - 이 옵션을 사용하여 Toad 스키마에 CodeXpert 개체를 추가할 수 있습니다.

  • Remove - 데이터베이스에서 CodeXpert를 삭제하기로 선택할 수 있습니다.

Space Manager

DBA 모듈의 일부입니다. Toad 스키마에 연결된 상태로 Toad 내에 설정되어 있어야 합니다. Space Manager 설정을 참조하십시오. 공간 사용 및 I/O 시간 초과를 추적합니다. Server Side Objects 마법사에서 다음을 수행할 수 있습니다.

  • Drop the Space Manager job and objects - Toad Space Manager의 사용 능력을 삭제합니다. 다시 설치하려면 Toad 스키마로 로그인하고 Space Manager 설정에 설명된 대로 설치해야 합니다.

  • Grant Toad the necessary privileges to use Space Manager - Space Manager를 설정하기 위해 필요하며 View Tablespace 창에서 사용할 수 있는 권한을 부여합니다. Toad Space Manager를 사용하고자 할 경우 이 작업이 완료된 후 위에 설명된 대로 Space Manager 표를 설정해야 합니다.


Toad Security Administrator 할당

TOAD 스키마를 작성 또는 관리할 때 사용자에게 Security Administrator 권한을 추가하거나 이 권한을 해지할 수 있습니다.

이러한 권한을 부여 또는 해지하려면 Toad 사용자로 연결되어 있어야 합니다. Toad 사용자로 연결되어 있지 않을 경우 마법사의 Select Toad Security Administrators 창에서 Connect as Toad를 누르고 해당 연결 정보를 입력합니다.

주: Security Administration에 대한 권한을 직접 부여받지 못한 사용자는 역할 또는 시스템 권한을 통해 적절한 권한이 부여되었을 경우 Toad Security를 계속 관리할 수 있습니다. 사용자에게 부여할 권한을 엄격하게 관리하면 이러한 문제를 없앨 수 있습니다.

Security Administrator를 추가하려면

  1. Add Security Admin을 누릅니다. Add Toad Security Administrator 대화상자가 표시됩니다.

  2. 드롭다운 화살표를 눌러 이 데이터베이스의 Users 목록을 표시합니다. Security Administrator 권한을 부여할 사용자를 선택합니다. 부여 중인 권한의 설명은 대화상자의 상단에 제공됩니다.

  3. Grant를 눌러 권한을 부여합니다. 사용자 이름 및 관련 권한이 눈금에 나타납니다.

  4. 필요한 경우 여러 명의 관리자를 추가할 수 있습니다. 1단계부터 반복하면 됩니다.

Security Administrator를 해지하려면

회사 내에서 위치가 변경되거나 사직한 사용자의 경우 관리 권한을 해지해야 할 수도 있습니다.

  1. 사용자 눈금에서 권한을 해지해야 할 Users를 선택합니다. 누르는 동안 <Shift> 또는 <CTRL>을 계속 눌러 여러 명을 선택할 수 있습니다.

  2. Revoke Security Admin을 누릅니다. 해지가 완료되었다는 확인 대화상자가 나타납니다.


TOAD 스키마 업데이트

이 화면에서 Toad 스크립트를 작성하고 나중에 실행할 수 있도록 저장하거나 바로 실행할 수 있습니다.

스크립트를 작성 또는 실행하려면

  • Run Script를 누릅니다.

또는

Save Script to Disk를 누릅니다.

스크립트를 저장한 다음 바로 실행할 수 있습니다. 이렇게 하면 방금 실행한 스크립트의 기록이 저장됩니다.

Run Script

스크립트가 실행되고 Toad 스키마가 변경 내용으로 작성 또는 업데이트됩니다.

스크립트가 실행되었으면 작업한 내용의 기록이 창에 나타납니다. 여기서 Save the Script 또는 Save the Output, 또는 둘 다 수행할 수 있습니다.

Next를 누릅니다.

Save Script to Disk

작성한 스크립트를 저장하라는 메시지가 표시됩니다. 기본값으로, Toad는 스크립트 ToadSetupScript.sql의 이름을 지정하고 기본 Toad 디렉토리에 보관합니다. 필요한 경우 변경할 수 있습니다.

Next를 눌러 계속합니다.


Setup 마법사 완료

마지막 화면에는 스크립트가 실행 또는 저장되었는지 여부와 설치가 완료되었는지 여부가 표시됩니다.

오류가 발생한 경우에는 해당 내용이 표시되고 사용자가 로그를 참조하여 확인할 수 있습니다.

뿐만 아니라, Toad는 데이터베이스에 여러 가지 다른 검사를 실행하고 다음 내용을 설명합니다.

  • SYS.DBMS_DEBUG 상태(선택 사항인 Debugger 모듈 사용에 필요)

  • DBMS_DEBUG_JDWP 상태(Java Debugger 사용에 필요)

  • SYS.DBMS_PROFILER 상태(Toad Profiler 사용에 필요)


개인 스키마에 개체 설치/제거

개인 스키마에 개체 설치, 업그레이드 또는 제거

Explain Plan 지원 및 Toad Profiler 지원은 개별적으로 제공할 수 있습니다.

Toad 사용자를 작성하지 않으려면 개체를 사용하려는 스키마에서 일부 개체를 작성 및 관리할 수 있습니다. 해당 특수 기능을 이용하려는 사용자가 소수이고 일부 사용자만 이 기능에 액세스하도록 하려면 이 방법이 더 효율적입니다.

이 옵션을 선택한 경우에는 기능을 이용할 각 사용자를 개별적으로 설정해야 합니다.

프로세스를 시작하려면

  1. 개체를 작성할 사용자 계정의 로그온 정보를 입력합니다.

  2. Next를 누릅니다.

관리용 개체 선택으로 이동합니다.


관리할 개체 선택

Toad는 선택한 사용자 스키마를 확인하고 상태와 함께 서버측 개체를 포함하는 기능을 나열합니다.

  • Found and OK

  • Not found

  • Error

이 알림은 문제를 보다 자세히 설명합니다. 예를 들어, 이전 Oracle 버전을 사용할 경우 Toad Profiler 아래에 다음과 같은 메시지가 나타날 수 있습니다.

Profiler not applicable to Oracle versions less than 8.1.

아니면 다음과 같은 문제가 발생할 수 있습니다.

Synonyms missing, Toad_PROFILER package is modified or out of date.

개인 스키마에서 관리할 개체 및 작업할 내용을 선택합니다.

이제 관리 대상을 선택할 수 있습니다. 선택하면 Next를 누릅니다.

Profiler 표

DBMS_PROFILER에 대한 Toad의 인터페이스를 사용합니다.

주의: Toad Profiler 개체는 Toad 스키마 또는 개별 사용자 스키마 중 하나에 설치해야 합니다.

  • Add - 이 옵션을 사용하여 현재 선택된 스키마에 없는 개체를 추가할 수 있으며 이 개체는 DBMS_PROFILER에 대한 Toad의 인터페이스에 필요합니다.

  • Remove - 개체를 삭제하기로 선택할 수 있습니다. Toad 개체를 삭제하면 Toad 스키마에 없을 경우 Toad의 일부를 사용할 수 없게 됩니다.

  • Drop and Recreate All - 이 옵션을 사용하여 Profiler에 필요한 개체를 모두 삭제한 다음 다시 작성합니다. 이 옵션은 Toad가 해결할 수 없는 Profiler 개체에 문제가 있을 경우 사용할 수 있습니다.

  • Recompile and Update - 이 옵션을 사용하여 Profiler 개체를 다시 컴파일하고 업데이트할 수 있습니다. 이 옵션은 Toad가 해결할 수 있는 Profiler 개체에 문제가 있을 경우 사용할 수 있습니다. Found and OK 상태이어도 Toad_PROFILER를 언제든지 업데이트할 수도 있습니다.


스키마 업데이트

이 화면에서 사용자의 업데이트 스크립트를 작성하고 나중에 실행할 수 있도록 저장하거나 바로 실행할 수 있습니다.

스크립트를 작성 또는 실행하려면

  • Perform Update를 누릅니다.

또는

Save Script to Disk를 누릅니다.

스크립트를 저장한 다음 바로 실행할 수 있습니다.

Perform Update

스크립트가 실행되고 스키마가 변경 내용으로 업데이트됩니다.

스크립트가 실행되었으면 작업한 내용의 기록이 창에 나타납니다. 여기서 Save the Script 또는 Save the Output, 또는 둘 다 수행할 수 있습니다.

  • Next를 누릅니다.

Save Script to Disk

작성한 스크립트를 저장하라는 메시지가 표시됩니다. 기본값으로, Toad는 스크립트 ToadSetupScript_USERNAME.sql의 이름을 지정하고 기본 Toad 디렉토리에 보관합니다. 필요한 경우 변경할 수 있습니다.

  • Next를 눌러 계속합니다.


연결하지 않고 스크립트 작성

필요한 데이터베이스 연결에 액세스하지 않고 Toad 스키마를 설정하는 스크립트를 작성하고 개인 스키마에서 Explain Plans를 활성화할 수 있습니다. 그런 다음 나중에 로그인하여 스크립트를 실행할 수 있습니다.

연결하지 않고 스크립트를 작성하려면

  1. 첫 번째 마법사 화면에서 Create setup scripts without a database connection을 선택하고 Next를 누릅니다.

  2. 작성할 스크립트를 선택합니다. (All 또는 None을 눌러도 됩니다.)

  3. 작성할 스크립트의 경로 및 파일 이름을 표시합니다. 이 작업을 따로 수행하거나, 필요한 경우 창의 상단에 있는 Set Directory를 눌러 선택한 모든 스크립트의 경로를 설정할 수도 있습니다.

  4. Finish를 눌러 선택한 스크립트를 작성합니다.

스크립트가 이미 존재할 경우 기존 스크립트를 덮어 써도 좋은지 묻는 대화상자가 나타납니다.

이제 Toad Editor에 스크립트를 로드하고 필요한 개체를 작성할 수 있습니다.


Toad 등록

Product Authorization 대화상자에서 Quest 소프트웨어 등록 ID를 입력할 수 있습니다. 입력하면 인증된 사용자임을 Toad에 알립니다.

Toad를 등록하려면

  1. Help|Register Toad 메뉴 항목을 선택합니다.

  2. Enter authorization key 필드를 누르고 키를 입력합니다. Toad가 적절한 위치에 하이픈을 자동으로 추가합니다.

  3. OK를 눌러 프로세스를 완료합니다.


utPLSQL과 함께 Toad 사용

Toad는 PL/SQL 응용 프로그램용 단위 테스트 프레임워크인 Steven Feuerstein의 오픈 소스 utPLSQL 프로그램과 함께 작동합니다.

utPLSQL의 배경에 대한 자세한 내용은 다음 웹 사이트에서 확인할 수 있습니다. http://oracle.oreilly.com/utplsql

다음 오픈 소스 프로젝트 홈 페이지를 방문하여 utPLSQL을 다운로드할 수 있습니다. https://sourceforge.net/projects/utplsql/

주: Quest Software, Inc.는 이러한 명령과 스크립트에 대한 지원을 제공합니다. utPLSQL에 대한 모든 지원 문제는 위에 언급한 웹 사이트 중 하나를 참조해야 합니다.

도구 모음/바로 가기에서 utPLSQL을 실행하려면

  1. 스크립트를 C:\utplsql\runtest(또는 다른 유효한 Windows 파일 이름)로 저장합니다.

  2. Configure/Execute 도구의 메뉴 드롭다운을 누르고 Configure를 선택합니다.

  3. Add를 누릅니다.

  4. Title 상자에 Unit Test in utPLSQL과 같은 제목을 입력합니다.

  5. Program 상자에 path to SQL*Plus를 입력합니다.

  6. Parameters 상자에 다음을 입력합니다.

$UID/$UPW@$SID @c:\utplsql\runtest $FIL

여기서 runtest에 대한 경로는 위에서 선택한 경로입니다.

  7. Shortcut 상자를 누르고 원하는 바로 가기를 입력합니다.

  8. OK를 눌러 마칩니다.

주: 다음과 같은 공백을 사용하는 디렉토리에 runtest 스크립트를 설치한 경우

C:\Program Files\Quest\…

parameters 상자에서 작은따옴표를 사용해야 합니다. 이는 소스 코드에도 동일하게 적용됩니다. 예를 들어 utPLSQL 패키지를 D:\Program Files\Quest SoftwarePLSQL에 설치하는 경우 parameters 상자는 다음과 같아야 합니다.

$UID/$UPW@$SID @'D:\Program Files\Quest Software\utPLSQL\unit_test.sql' '$FIL'

이제 mypack.pkb 등의 패키지 파일이나 ut_mypack.pks 등의 단위 테스트 패키지를 편집하는 중이면 utplsql.test('mypack')가 실행됩니다. 패키지 이름이 파일 이름에서 반영되는 이 명명 규칙을 파일에 사용하는 것은 사용자가 결정해야 할 사항입니다.

Toad에서 작동하는 스크립트:

SET serveroutput ON

SET verify OFF

DECLARE

filename VARCHAR2(100) := '&1';

dot PLS_INTEGER;

slash PLS_INTEGER;

BEGIN

--Strip off the directory

slash := INSTR(filename, '\', -1, 1);

IF slash <> 0 THEN

filename := SUBSTR(filename, slash + 1);

END IF;

--Strip off the extension

dot := INSTR(filename, '.', 1, 1);

IF dot <> 0 THEN

filename := SUBSTR(filename, 1, dot - 1);

END IF;

--Strip off ut prefix

IF filename LIKE utconfig.prefix || '%' THEN

filename := SUBSTR(filename, LENGTH(utconfig.prefix) + 1);

END IF;

--Now run the test

utplsql.test(filename);

END;

/

pause Press ANY KEY TO CLOSE

exit


Oracle 10g 기술 지원

Toad 8은 Oracle의 이전 버전과 같이 기본적으로 연결 및 작동할 수 있는 Oracle 10g을 지원하는 것으로 간주되었습니다. 이전 버전은 10g 데이터베이스에 연결하지 못합니다.

Toad for Oracle Version 8.5는 10g에 소개된 여러 가지의 새로운 기능을 이용하여 10g 데이터베이스를 지원합니다.

표 공간 이름 바꾸기

Schema Browser에서 마우스 오른쪽 단추를 눌러 표 공간의 이름을 바꿀 수 있습니다.

기본 표 공간

Schema Browser는 기본 임시 및 기본 영구 표 공간을 나타내며 마우스 오른쪽 단추를 눌러 변경할 수 있습니다.

표 공간 그룹

표 공간 그룹은 표 공간 작성/변경 창 및 사용자 작성/변경 창에서 지원됩니다.

Segment Advisor/기록

Oracle의 Segment Advisor와 상호 작용하는 TOAD의 전체 화면이 있습니다.

전체 해시 분할 색인

Create and Alter index 창 및 ddl 압축 풀기에서 지원됩니다.

Datapump 마법사

Toad는 새 데이터 펌프 가져오기 및 내보내기 마법사가 있는 Quest DBA Module의 Oracle 데이터 펌프 및 데이터 펌프 작업 관리자를 지원합니다.

온라인 세그먼트 축소

다음 화면에서 지원됩니다.

  • 표 변경

  • 스냅샷 변경

  • 스냅샷 로그 변경

  • 색인 변경

Undo Advisor

Oracle의 Undo Advisor와 상호 작용하는 TOAD의 전체 화면이 있습니다.

향상된 작업 스케줄러 - 모니터링

새 Schema Browser 탭

새 Schema Browser 탭은 Oracle 10g Scheduler와 상호 작용합니다.

  • 스케줄러 작업

  • 작업 등급

  • 일정

  • 프로그램

  • Windows 및 Window 그룹

작성/변경 창

모든 새 Schema Browser 탭에 작성 및 변경 창이 있습니다.

Generate Schema 스크립트 및 스키마 비교에서 지원

새 Oracle Scheduler 탭은 모두 Generate Schema 스크립트 및 스키마 비교에서 지원됩니다.

휴지통

새 Schema Browser 탭은 표 플래시백 및 휴지통 비우기 등의 휴지통 작업 전체를 지원합니다.

새 데이터 형식

DOUBLE, FLOAT, BINARY_DOUBLE, BINARY_FLOAT가 데이터 눈금에서 지원되며 화면을 작성/변경합니다.

큰 파일 표 공간

표 공간 작성/변경 화면에서 지원됩니다.

전체 분할 색인 - 해시 분할

색인 작성/변경 화면 및 스크립트 생성에서 지원됩니다.

인스턴트 클라이언트

TOAD는 이 클라이언트를 사용하여 연결할 수 있습니다.

새 행 타임스탬프 의사 열

데이터 눈금에서 지원됩니다.


RAC 지원

여러 데이터베이스 서버 상자가 있으면 Oracle RAC에서 각 서버의 Oracle 인스턴스를 시작하고 모든 인스턴스로 동일한 공유 데이터베이스(또는 데이터 파일 공유 집합)를 열 수 있습니다. 이러한 방법으로 사용자를 추가할 때 컴퓨터를 따로 추가하여 데이터베이스 서버 크기를 조절할 수 있습니다. 컴퓨터는 여러 개지만 데이터베이스는 하나입니다. Toad는 RAC 시스템에 대한 Oracle 10g의 지원을 지원합니다.

RAC 연결 추가 정보

RAC 연결로 로그인하면 Toad가 이 사실을 파악하고 해당 연결을 쉽게 관리할 수 있도록 몇 개의 창에서 사용할 수 있는 추가 정보를 만듭니다.

제목

RAC 연결이 유효할 경우 Toad 기본 창의 제목이 다음과 같이 반영됩니다. TOAD: RAC[n], 여기서 n은 세션 ID입니다.

연결 막대

연결 막대에서 RAC 연결이 SCHEMA@RAC[n]으로 나열됩니다. 여기서 n은 해당 연결의 인스턴스 수입니다.

데이터베이스 모니터

데이터베이스 모니터 내에서 모든 정보는 하나의 연결을 기준으로 제공됩니다. 하지만 RAC 클러스터를 구성하는 모든 인스턴스에 대해 요약 또는 집계됩니다. 예를 들어, SGA 메모리에서 각 RAC 인스턴스가 150 MB이고 두 개의 RAC 인스턴스가 있으면 이 열은 300 MB를 표시합니다.

Oracle Parameters 화면

RAC 데이터베이스 단일 눈금 보기 - 눈금 위 및 도구 모음의 오른쪽에 있는 Single Grid 확인란은 Toad에 단일 눈금 또는 여러 눈금이 표시되는지 여부를 전환합니다. Toad는 기본값으로 일단 옵션을 정렬한 다음 쉽게 읽을 수 있도록 인스턴스를 기준으로 정렬합니다.

RAC 데이터베이스 여러 눈금 보기 - 여러 눈금 보기를 선택하면 Toad에 각 RAC 인스턴스의 별도 탭이 표시됩니다.


Toad 오류

명령이 실패하면 Toad Error 대화상자가 나타납니다.

  • Clipboard 단추를 사용하여 오류를 복사합니다. 그런 다음 고객 지원 서비스에 보내는 전자 메일에 붙여 넣습니다. (Help: Support 참조)

  • 위의 예와 같이 오류 대화상자에 ORA-number가 포함되어 있으면 Help를 누릅니다. Toad가 Oracle 도움말 파일을 요청하여 새 창에 오류 메시지 항목을 표시합니다. 이 창에서 항목을 인쇄하거나 Oracle 도움말의 색인 또는 목차로 이동할 수 있습니다.

  • Knowledge Xpert가 설치되어 있는 경우(추가 기능 제품 참조) 오류에 대한 자세한 기술 정보를 보려면 Details를 누릅니다.

  • OK를 눌러 Toad Error 대화상자를 닫습니다.


끌어다 놓기

여러 Toad 창 및 Toad와 일부 외부 응용프로그램 간의 개체를 끌어다 놓을 수 있습니다.

사용 가능한 끌어다 놓기 조합에는 다음이 포함됩니다.

대상 | 놓을 위치 | 동작 | 적용 가능한 개체
Project Manager | Query Builder | 표 모델 영역에 추가된 개체 | 표/보기/동의어
 | ER 다이어그램 | 표 모델 영역 및 LHS 목록에 추가된 개체 | 표/보기/동의어
 | Editor | 편집기에 추가된 개체 이름 | 모든 개체
 | Editor | 편집기에 로드된 파일 또는 편집기에 로드된 파일 내용 | 파일
 | Editor | 편집기에 추가된 개체 이름 | 모든 개체와 PL/SQL 개체 및 형식
 | Editor | 편집기에 로드된 개체 | PL/SQL 개체 및 형식
 | Editor | 편집기에 로드된 파일 | 파일
 | Text Editor | 편집기에 추가된 개체 이름 | 모든 개체
 | Text Editor | 텍스트 편집기에 로드된 파일 | 파일
 | Schema Browser - Favorites 탭 | Favorites 탭의 폴더에 추가된 개체 | Schema Browser와 동의어 및 형식에서 지원되는 모든 개체
 | Script Manager | Script Manager에 추가된 파일 참조 | 파일
Object Search | Query Builder | 표 모델 영역에 추가된 개체 | 표/보기/동의어
 | ER 다이어그램 | 표 모델 영역 및 LHS 목록에 추가된 개체 | 표/보기/동의어
 | Editor | 편집기에 추가된 개체 이름 | 모든 개체
 | Editor | 편집기에 추가된 개체 이름 | 모든 개체와 PL/SQL 개체 및 형식
 | Editor | 편집기에 로드된 개체 | PL/SQL 개체 및 형식
 | Text Editor | 편집기에 추가된 개체 이름 | 모든 개체
 | Project Manager | Project Manager 프로젝트에 추가된 개체 | Object Search에서 지원되는 모든 개체
 | Schema Browser - Favorites 탭 | Favorites 탭의 폴더에 추가된 개체 | Schema Browser와 동의어 및 형식에서 지원되는 모든 개체
Object Palette | Query Builder | 표 모델 영역에 추가된 개체 | 표/보기/동의어
 | ER 다이어그램 | 표 모델 영역 및 LHS 목록에 추가된 개체 | 표/보기/동의어
 | Editor | 편집기에 추가된 개체 이름 | 표/보기/동의어/열
 | Editor | 편집기에 추가된 개체 이름 | 표/보기/동의어/열
 | Text Editor | 편집기에 추가된 개체 이름 | 표/보기/동의어/열
 | Project Manager | Project Manager 프로젝트에 추가된 개체 | 표/보기/동의어
 | Schema Browser - Favorites 탭 | Favorites 탭의 폴더에 추가된 개체 | 표/보기
Schema Browser | Query Builder | 표 모델 영역에 추가된 개체 | 표/보기/동의어
 | ER 다이어그램 | 표 모델 영역 및 LHS 목록에 추가된 개체 | 표/보기/동의어
 | Editor | 편집기에 추가된 개체 이름 | 모든 개체
 | Editor | 편집기에 추가된 개체 이름 | 모든 개체와 PL/SQL 개체 및 형식
 | Editor | 편집기에 로드된 개체 | PL/SQL 개체 및 형식
 | Text Editor | 편집기에 추가된 개체 이름 | 모든 개체
 | Project Manager | Project Manager 프로젝트에 추가된 개체 | Project Manager에서 지원되는 모든 개체
 | Schema Browser - Favorites 탭 | Favorites 탭의 폴더에 추가된 개체 | Schema Browser와 동의어 및 형식에서 지원되는 모든 개체
Output 창/Find In Files | Project Manager - Project 노드 | Project Manager에 추가된 파일 참조 | 프로젝트 파일
 | Project Manager - Folder 노드 | 추가한 참조 | 파일
 | Project Manager - FTP 노드 | FTP 서버로 파일 업로드 | 파일
 | Editor | 편집기에 로드된 파일. 파일 이름이 새 탭에 나타납니다. | 파일
 | Editor | 편집기에 로드된 파일. 파일 이름이 새 탭에 나타납니다. | 파일
 | Text Editor | 텍스트 편집기에 로드된 파일. 파일 이름이 새 탭에 나타납니다. | 파일
 | Script Manager | Script Manager에 추가된 파일 참조 | 파일
Windows 탐색기 | Project Manager | Project Manager에 추가된 파일 참조 | 파일
 | Editor | 편집기에 로드된 파일 | 파일
 | Editor | 편집기에 로드된 파일 | 파일
 | Text Editor | 텍스트 편집기에 로드된 파일 | 파일
코드 조각 | Editor | 편집기에 추가된 조각 | 목록의 코드 조각
 | Editor | 편집기에 추가된 조각 | 목록의 코드 조각
 | Text Editor | 텍스트 편집기에 추가된 조각 | 목록의 코드 조각
Archive 창 | Project Manager - Folder 노드 | 폴더에 압축되지 않은 상태로 추가된 파일. PM에 추가하라는 프롬프트 표시 | zip 보관 파일 내의 파일
 | Project Manager - FTP 노드 | 압축되지 않은 상태로 업로드된 파일. PM에 추가하라는 프롬프트 표시 | zip 보관 파일 내의 파일
Toad 작업 스케줄러 인터페이스 | Project Manager | Project Manager에 추가된 Windows 작업 노드 | 예약된 작업


작업 표시줄 & 상태 표시줄

작업 표시줄

View|Toad Options|Toolbars/Menus|Show Connect Strings를 사용하여 이 기능을 활성화 또는 비활성화합니다. 기본 Toad 창의 아래에서 Toad는 현재 열려 있는 여러 연결을 표시합니다.

  • 이 연결 중 하나를 눌러 해당 연결에 사용한 마지막 창을 활성화합니다. 연결에 마우스를 올려 놓으면 다음 정보가 표시됩니다.

  • 사용자

  • 연결 형식(sysDBA, sysOPER)

  • 서버의 sysdate

  • 데이터베이스 버전

  • 세션 ID

주: V$session을 액세스할 수 있고 sysDBA 또는 sysOPER로 로그인하지 않은 경우 SID만 표시됩니다.

  • SQL 창이 최대화되면 이 연결 중 하나에 마우스 오른쪽 단추를 누릅니다. 그러면 Toad가 옵션 메뉴를 표시합니다.

이 메뉴에서 다음 작업을 수행할 수 있습니다.

  • 선택한 연결 종료

  • 선택한 연결 변경

  • 선택한 연결에 마지막으로 변경한 내용 롤백

  • 이 연결의 Editor 창을 Toad 앞에 가져온 뒤 활성화

상태 표시줄

Toad 내의 각 별도의 창 아래에 상태 표시줄이 있습니다. 이 표시줄은 현재 창에 대한 정보를 제공합니다.

  • 상태 표시줄의 첫 번째 프레임은 커서가 결과 눈금에 위치한 행 및 열입니다. 결과 눈금을 열지 않았거나 커서가 눈금에 있지 않으면 이 프레임은 빈 상태가 됩니다.

  • 두 번째 프레임은 이 창에서 사용하는 연결입니다.

  • 마지막 프레임은 마지막에 표시된 오류입니다.

이 표시줄의 정보에 마우스를 올려 놓아 추가 정보를 볼 수 있습니다. 이 정보에는 세션 ID(SID), sysdate 및 사용 중인 Oracle 버전이 포함됩니다. V$session을 액세스할 수 있고 SysDBA 또는 SysOper로 로그인하지 않은 경우에만 SID가 표시됩니다.

실행 시간

Editor에서 스크립트 또는 명령을 실행하면 첫 번째 프레임이 시간으로 변경됩니다. 타이밍은 Toad가 Oracle에 질의를 보내고 첫 번째 결과 집합이 반환되는 시점의 시간입니다. 데이터를 가져오는 데 소요되는 시간을 설명하지는 않습니다.


방화벽과 함께 Toad 사용

SSH© Secure Shell™ 소프트웨어 버전 2.4.0을 사용하는 방화벽을 통해 Oracle에 Toad를 연결할 수 있습니다. 다른 소프트웨어도 작동할 수 있지만 Toad에서 테스트되지 않았습니다. Toad가 연결된 상태로 남아 있도록 하려면 SSH 터널 및 클라이언트를 모두 실행해야 합니다.

방화벽을 통해 연결하려면

  1. 기본 SSH Secure Shell 화면에서 profile/edit profile 메뉴 단추를 선택합니다.

  2. Profiles 창의 우측 패널에 있는 탭에서 Outgoing Tunneling을 선택합니다.

  3. Edit를 누릅니다. Edit Outgoing Tunnel 대화상자에서 터널 정보를 입력합니다.

  5. Tnsnames.ora 파일을 다음과 같이 편집합니다.

주: 터널을 설정할 때 사용한 파일에 해당하는 포트를 수정하십시오.

add (server=dedicated)

CADEV.world =

(DESCRIPTION =

(ADDRESS_LIST =

(ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 11521))

)

(CONNECT_DATA =

(SID = cadev)

(server=dedicated)

)

)

  6. SSH client를 시작하고 Toad에 연결합니다.


ASCII 차트

Dec | Hex | Oct | UTS | ASCII | CharName
0 | $00 | 0000 |  | NUL | NUL
1 | $01 | 0001 |  | SOH | SOH
2 | $02 | 0002 |  | STX | STX
3 | $03 | 0003 |  | ETX | ETX
4 | $04 | 0004 |  | EOT | EOT
5 | $05 | 0005 |  | ENQ | ENQ
6 | $06 | 0006 |  | ACK | ACK
7 | $07 | 0007 |  | BEL | BEL
8 | $08 | 0010 |  | BS | BS
9 | $09 | 0011 |  | HT | HT
10 | $0A | 0012 |  | LF | LF
11 | $0B | 0013 |  | VT | VT
12 | $0C | 0014 |  | FF | FF
13 | $0D | 0015 |  | CR | CR
14 | $0E | 0016 |  | SO | SO
15 | $0F | 0017 |  | SI | SI
16 | $10 | 0020 |  | ACK | ACK
17 | $11 | 0021 |  | DC1 | DC1
18 | $12 | 0022 |  | DC2 | DC2
19 | $13 | 0023 |  | DC3 | DC3
20 | $14 | 0024 |  | DC4 | DC4
21 | $15 | 0025 |  | NAK | NAK
22 | $16 | 0026 |  | SYN | SYN
23 | $17 | 0027 |  | ETB | ETB
24 | $18 | 0030 |  | CAN | CAN
25 | $19 | 0031 |  | EM | EM
26 | $1A | 0032 |  | SUB | SUB
27 | $1B | 0033 |  | ESC | ESC
28 | $1C | 0034 |  | FS | FS
29 | $1D | 0035 |  | GS | GS
30 | $1E | 0036 |  | RS | RS
31 | $1F | 0037 |  | US | US
32 | $20 | 0040 | 1 |  | 공백
33 | $21 | 0041 | 2 | ! | 감탄 부호
34 | $22 | 0042 | 3 | " | 큰따옴표
35 | $23 | 0043 | 4 | # | 숫자 부호
36 | $24 | 0044 | 5 | $ | 달러 부호
37 | $25 | 0045 | 6 | % | 퍼센트 부호
38 | $26 | 0046 | 7 | & | 앰퍼샌드
39 | $27 | 0047 | 8 | ' | 작은따옴표
40 | $28 | 0050 | 9 | ( | 왼쪽 괄호
41 | $29 | 0051 | 10 | ) | 오른쪽 괄호
42 | $2A | 0052 | 11 | * | 별표
43 | $2B | 0053 | 12 | + | 플러스 부호
44 | $2C | 0054 | 13 | , | 쉼표
45 | $2D | 0055 | 14 | - | 마이너스 부호
46 | $2E | 0056 | 15 | . | 마침표
47 | $2F | 0057 | 16 | / | 슬래시, 사선
48 | $30 | 0060 | 17 | 0 | 0
49 | $31 | 0061 | 18 | 1 | 1
50 | $32 | 0062 | 19 | 2 | 2
51 | $33 | 0063 | 20 | 3 | 3
52 | $34 | 0064 | 21 | 4 | 4
53 | $35 | 0065 | 22 | 5 | 5
54 | $36 | 0066 | 23 | 6 | 6
55 | $37 | 0067 | 24 | 7 | 7
56 | $38 | 0070 | 25 | 8 | 8
57 | $39 | 0071 | 26 | 9 | 9
58 | $3A | 0072 | 27 | : | 콜론
59 | $3B | 0073 | 28 | ; | 세미콜론
60 | $3C | 0074 | 29 | < | 이하 부호
61 | $3D | 0075 | 30 | = | 등호
62 | $3E | 0076 | 31 | > | 이상 부호
63 | $3F | 0077 | 32 | ? | 물음표
64 | $40 | 0100 | 33 | @ | 애트 부호
65 | $41 | 0101 | 34 | A | A
66 | $42 | 0102 | 35 | B | B
67 | $43 | 0103 | 36 | C | C
68 | $44 | 0104 | 37 | D | D
69 | $45 | 0105 | 38 | E | E
70 | $46 | 0106 | 39 | F | F
71 | $47 | 0107 | 40 | G | G
72 | $48 | 0110 | 41 | H | H
73 | $49 | 0111 | 42 | I | I
74 | $4A | 0112 | 43 | J | J
75 | $4B | 0113 | 44 | K | K
76 | $4C | 0114 | 45 | L | L
77 | $4D | 0115 | 46 | M | M
78 | $4E | 0116 | 47 | N | N
79 | $4F | 0117 | 48 | O | O
80 | $50 | 0120 | 49 | P | P
81 | $51 | 0121 | 50 | Q | Q
82 | $52 | 0122 | 51 | R | R
83 | $53 | 0123 | 52 | S | S
84 | $54 | 0124 | 53 | T | T
85 | $55 | 0125 | 54 | U | U
86 | $56 | 0126 | 55 | V | V
87 | $57 | 0127 | 56 | W | W
88 | $58 | 0130 | 57 | X | X
89 | $59 | 0131 | 58 | Y | Y
90 | $5A | 0132 | 59 | Z | Z
91 | $5B | 0133 | 60 | [ | 왼쪽 대괄호
92 | $5C | 0134 | 61 | \ | 백슬래시
93 | $5D | 0135 | 62 | ] | 오른쪽 대괄호
94 | $5E | 0136 | 63 | ^ | 곡절 부호
95 | $5F | 0137 | 64 | _ | 밑줄
96 | $60 | 0140 | 65 | ` | 강세
97 | $61 | 0141 | 66 | a | a
98 | $62 | 0142 | 67 | b | b
99 | $63 | 0143 | 68 | c | c
100 | $64 | 0144 | 69 | d | d
101 | $65 | 0145 | 70 | e | e
102 | $66 | 0146 | 71 | f | f
103 | $67 | 0147 | 72 | g | g
104 | $68 | 0150 | 73 | h | h
105 | $69 | 0151 | 74 | i | i
106 | $6A | 0152 | 75 | j | j
107 | $6B | 0153 | 76 | k | k
108 | $6C | 0154 | 77 | l | l
109 | $6D | 0155 | 78 | m | m
110 | $6E | 0156 | 79 | n | n
111 | $6F | 0157 | 80 | o | o
112 | $70 | 0160 | 81 | p | p
113 | $71 | 0161 | 82 | q | q
114 | $72 | 0162 | 83 | r | r
115 | $73 | 0163 | 84 | s | s
116 | $74 | 0164 | 85 | t | t
117 | $75 | 0165 | 86 | u | u
118 | $76 | 0166 | 87 | v | v
119 | $77 | 0167 | 88 | w | w
120 | $78 | 0170 | 89 | x | x
121 | $79 | 0171 | 90 | y | y
122 | $7A | 0172 | 91 | z | z
123 | $7B | 0173 | 92 | { | 왼쪽 중괄호
124 | $7C | 0174 | 93 | | | 세로 막대
125 | $7D | 0175 | 94 | } | 오른쪽 중괄호
126 | $7E | 0176 | 95 | ~ | 물결
127 | $7F | 0177 | 96 | DEL | DEL


필터

필터는 표시된 데이터의 양을 감소시켜 보고자 하는 것만 표시할 수 있습니다. 필터는 데이터를 가져오는 데 사용하는 질의를 수정하여 작동됩니다.

Schema Browser 필터

브라우저 필터는 스키마/소유자 이름으로 지정됩니다. 스키마 DEMO의 필터 하나와 PRODUCTION의 다른 필터를 정의할 수 있으며 Schema Browser에 해당 스키마가 나타날 때 해당 필터가 로드됩니다. Toad에서 로드해야 할 개체가 적어질 수록 보다 빨리 실행되기 때문에 브라우저 필터는 여러 개체가 포함된 스키마에 유용합니다. 필터 결과에 초점을 좁힐 수 있으며 스키마의 다른 개체를 모두 무시할 수 있습니다.

필터 창은 선택한 Schema Browser 목록의 필터링 대상에 따라 달라집니다. 기본 필터 창에는 항목(필터가 없거나 필터를 지운다는 뜻의 None 포함) 필터링 방식과 상자를 선택하여 드롭다운 선택에 따라 포함 또는 제외할 문자를 입력할 수 있습니다. 라디오 단추 및 필터 확인란에서 항목을 나중에라도 필터링할 수 있습니다.

주: 실행하기 전에 필터를 보거나 편집할 수 있습니다. 작성한 필터가 어떤 작업을 할지 모를 경우 필터를 검토하여 질의를 확인하는 것이 좋습니다. 브라우저 필터 질의 편집을 참조하십시오.

기본 드롭다운 필터 목록에는 다음이 포함됩니다.

  • None - 필터가 없거나 필터를 지웁니다.

  • In - IN 절의 내용을 입력합니다.

선택 구문은 다음과 같이 포맷됩니다. SELECT * FROM user_tables WHERE table_name IN (n) 여기서 n은 필터 상자에서 입력한 내용입니다. 그러므로 표 이름을 입력하려면 작은 따옴표를 넣습니다. ('TEST'). 이렇게 하면 이 상자에서 여러 표 이름을 입력할 수 있습니다. 예:'표1', '표2', '표3'. 또는 다음과 같이 하위 질의를 입력할 수 있습니다. SELECT SOMECOLUMN FROM SOMETABLE.

  • Not In - NOT IN 절의 내용을 입력합니다. 동일한 구문이 IN 절과 함께 적용됩니다.

  • Starts with - 필터링한 결과가 시작되는 문자를 입력합니다.

  • Includes - 필터링한 결과에 포함될 문자를 입력합니다.

  • Ends with - 필터링한 결과가 종료되는 문자를 입력합니다.

  • Does not Start with - 필터링한 결과가 시작되지 않는 문자를 입력합니다.

  • Does not End with - 필터링한 결과가 종료되지 않는 문자를 입력합니다.

  • Does not Include - 필터링한 결과에 포함되지 않는 문자를 입력합니다.

필터를 설정하고 OK를 누르고 나면 브라우저에 결과 개체가 표시됩니다.

브라우저 필터를 설정하려면

  • Filter [image] 단추를 누르면 필터 창이 나타납니다.

View|Toad Options|Files 대화상자의 필터

이 대화상자에서 시스템 대화상자 창에 표시되는 파일 확장자를 사용자 정의할 수 있습니다. 다른 필터를 추가하려면 빈 행에 입력합니다.

기본 필터에는 다음이 포함됩니다.

파일 | 필터
SQL | *.sql
텍스트 파일 | *.txt
질의 파일 | *.qry
모든 파일 | *.*

관련 항목

기본 브라우저 필터 작성

브라우저 필터 질의 편집

브라우저 필터 로드 및 적용

브라우저 필터 저장

스키마용 브라우저 필터 보기


Excel 스타일 필터링

Toad Options| Data Grids - Visual 에서는 기본적으로 Excel 스타일 필터링을 사용하도록 선택할 수 있습니다.

주: 그리드에 대해 Excel 스타일 필터링이 활성화된 경우 Grid|Filter Data가 비활성화됩니다(그렇지 않은 경우에는 활성화됨).

Excel 스타일 필터링을 사용하면 결과 그리드의 열 머리글에서 직접 필터링할 수 있습니다. 각 머리글에 연결된 드롭다운 화살표는 필터 대화 상자를 표시합니다. 모든 열에서 최대 두 개의 조건을 사용할 수 있습니다.

예

select * from Scott.Emp

이 경우 다음 results 그리드를 얻게 됩니다.

Job이 SALESMAN 또는 SALES MANAGER인 결과만 보려면 다음 SQL 문을 사용할 수 있습니다.

select * from scott.emp where job like 's%'

또는 Excel 스타일 필터링을 사용하여 results 그리드를 필터링할 수 있습니다.

Excel 스타일 필터링을 사용하려면

  1. Job 열 머리글에서 드롭다운을 누릅니다. 메뉴에서 Custom을 선택합니다.

  2. Filter 대화 상자에서 상자를 채워 필터 조건을 지정합니다.

  3. OK를 누르면 select 문에서 like 절을 사용할 경우처럼 S로 시작하는 직업으로만 그리드가 제한됩니다.

관련 항목

Toad Options


Server Login 창

이 창에서 다음 작업을 수행할 수 있습니다.

  • 새 Oracle 연결 작성

  • 이전 연결 목록에서 연결

  • Toad를 열 때 이전 연결로 연결할 자동 연결 설정

  • 연결용 암호 저장

  • 자주 사용하는 로그온 선택 및 보기

  • 연결을 나타낼 색상 선택

  • Oracle 홈 선택

  • 기본 Oracle 홈 선택

  • SQL Net 설정 편집

  • TNS Names 파일 편집

Server Login 창에 Server(데이터베이스 별칭), User(스키마) 및 Last Connect(날짜 및 시간)의 이전 연결이 나열됩니다. 연결 옵션 또한 정의할 수 있습니다. 예를 들면 다음과 같습니다.

  • auto connect

  • save the password

  • connect mode

이전에 Make this the Toad default home 확인란을 선택하지 않았으면 Toad가 사용하는 기본 홈과 Oracle Home Selector에서 선택한 홈이 일치합니다.

TNSNames Editor 및 SQLNet Editor 링크 옆에 체크 표시 또는 "X"가 나타납니다. 이는 Toad가 관련 파일을 찾았거나(체크 표시) 찾지 못했음(X)을 나타냅니다.

연결 눈금 사용

연결 눈금에는 과거에 사용한 연결이 포함됩니다. 즐겨찾기 목록에 연결을 추가한 경우 화면 아래의 Favorites 확인란을 눌러 해당 연결만 볼 수 있습니다.

열 머리글을 눌러 처음 3개의 열 중 하나를 오름차순 또는 내림차순으로 정렬할 수 있습니다.

눈금 열 너비는 전체 내용을 표시하기 위해 자동으로 조정됩니다.

Toad는 눈금 정렬 열, 순서, 크기 및 Server Login 창의 크기를 저장하고 다음에 창을 열 때 모두 복원합니다.

선택한 Oracle 홈을 사용하는 연결만 표시

다른 Oracle 홈을 사용하는 연결이 많을 경우 눈금에서 특정 홈을 사용하는 연결만 표시할 수 있습니다.

하나의 Oracle 홈에 연결을 제한하려면

  1. 로그인 창의 오른쪽에서 표시할 Oracle 홈을 선택합니다.

  2. 창 아래의 Show selected home only 확인란을 누릅니다.

Oracle 정보 새로 고침

창 아래에 Refresh 단추가 있습니다. 이 단추를 누르면 다음과 같이 됩니다.

  • Oracle 별칭 목록이 새로 고쳐집니다.

  • 레지스트리 및 디스크에 저장된 정보로 클라이언트 정보가 새로 고쳐집니다.


새 연결 작성

Server Login 창에서 여러 가지 방법으로 Oracle 데이터베이스로의 새 연결을 작성할 수 있습니다.

TNSNAMES 파일

Toad는 Oracle TNSNames 파일의 목록을 사용하여 연결할 수 있습니다. Toad는 TNSNames 파일 항목이 들어 있는 데이터베이스 상자를 수용하며 이를 통해 사용할 연결을 선택할 수 있습니다.

TNS Names 파일을 사용하여 새 연결을 작성하려면

  1. User/Schema 상자에서 user 이름을 입력합니다.

  2. Password 상자에서 이 사용자의 password를 입력합니다. 추가한 보안에 대해 문자는 입력한 대로 나타나지 않고 대신 별표가 나타납니다.

  3. 활성화되어 있지 않은 경우 TNS 탭을 누르고 Database 드롭다운 상자에서 database 이름을 선택합니다.

주: 데이터베이스 상자에 데이터베이스 이름을 입력하지 않으면 Toad는 선택한 홈에 ORACLE_SID를 사용합니다. ORACLE_SID 값이 없고 데이터베이스를 지정하지 않으면 아무 것도 연결할 수 없습니다.

  2. 적합한 권한이 있는 경우 Connect As 드롭다운을 통해 SYSDBA 또는 SYSOPER로 연결할 수 있습니다. 이 상자의 기본값은 Normal입니다.

  3. 이 연결에 색상 코드를 지정하려면 Color 드롭다운 상자에서 색상을 선택합니다. (자세한 내용은 연결 색상 선택을 참조하십시오.)

  4. OK를 누릅니다.

또는

<ENTER>를 누릅니다.

데이터베이스의 드롭다운 목록에서 데이터베이스를 지정하지 않으면 선택한 홈의 ORACLE_SID가 사용됩니다. ORACLE_SID는 사용자 PC에 설치된 홈의 레지스트리에 지정됩니다. ORACLE_SID 값이 없고 드롭다운에서 데이터베이스를 지정하지 않으면 아무 것도 연결할 수 없습니다. ORACLE_SID는 기본적으로 홈의 기본 데이터베이스이며 이를 통해 사용자는 user/pwd를 입력하여 드롭다운에서 기본 데이터베이스를 찾지 않고 기본 데이터베이스에 연결할 수 있습니다.

쉬운 연결 문자열을 사용하여 연결

쉬운 연결 문자열을 사용하여 TNS 탭에서 연결할 수 있습니다.

쉬운 연결 문자열을 사용하여 연결하려면

  • 데이터베이스 상자에 문자열을 입력합니다. (쉬운 연결 문자열 형식: host:port\service_name)

데이터베이스에 직접 연결

Toad는 사용할 데이터베이스에 직접 연결할 수 있습니다.

데이터베이스에 직접 새 연결을 작성하려면

  1. User/Schema 상자에서 user 이름을 입력합니다.

  2. Password 상자에서 이 사용자의 password를 입력합니다. 추가한 보안에 대해 문자는 입력한 대로 나타나지 않고 대신 별표가 나타납니다.

  3. Direct 탭을 누릅니다.

  4. Host, Port 및 연결할 데이터베이스의 Service Name 또는 SID를 입력합니다.

  5. 적합한 권한이 있는 경우 Connect As 드롭다운을 통해 SYSDBA 또는 SYSOPER로 연결할 수 있습니다. 이 상자의 기본값은 Normal입니다.

  6. 이 연결에 색상 코드를 지정하려면 Color 드롭다운 상자에서 색상을 선택합니다. (자세한 내용은 연결 색상 선택을 참조하십시오.)

  7. OK를 누릅니다.

LDAP를 사용하여 연결

Toad는 공식적으로 Oracle 이름 디렉토리 서비스를 지원합니다. 이러한 지원에는 Oracle OID 및 Microsoft Active Directory 서버 모두 포함됩니다.

Oracle Instant Client LDAP 지원

  • Instant Client LDAP 지원은 Oracle이 기본값으로 설치하지 않는 특정 LDAP DLL에 따라 달라집니다. ORALDAPCLNT10.DLL은 oci.dll 파일과 동일한 위치에 있어야 합니다.

  • TNSNAMES.ora, LDAP.ora, SQLNET.ora는 TNS_ADMIN 시스템 변수가 지정하는 동일한 위치에 있어야 합니다.

  • Logon 대화상자의 드롭다운 목록은 채워지지 않지만 로그온 화면의 'Database 필드'에 DB 이름을 수동으로 입력하여 연결할 수 있습니다.

LDAP를 사용하여 새 연결을 작성하려면

  1. User/Schema 상자에서 user 이름을 입력합니다.

  2. Password 상자에서 이 사용자의 password를 입력합니다. 추가한 보안에 대해 문자는 입력한 대로 나타나지 않고 대신 별표가 나타납니다.

  3. LDAP 탭을 누릅니다.

  4. 연결할 데이터베이스의 LDAP Descriptor를 입력합니다.

  5. 적합한 권한이 있는 경우 Connect As 드롭다운을 통해 SYSDBA 또는 SYSOPER로 연결할 수 있습니다. 이 상자의 기본값은 Normal입니다.

  6. 이 연결에 색상 코드를 지정하려면 Color 드롭다운 상자에서 색상을 선택합니다. (자세한 내용은 연결 색상 선택을 참조하십시오.)

  7. OK를 누릅니다.


연결 색상 선택

Toad를 작업할 때 한 번에 여러 연결을 열 수 있습니다. 연결과 관련된 열린 창을 계속 추적하는 것이 힘들 수 있습니다. 이때 연결에 색상을 지정하면 도움이 됩니다.

특정 연결에 색상이 지정되면 이 연결에 관련되어 열려 있는 모든 창, 창 표시줄 단추 및 상태 표시줄에 해당 색상의 윤곽선이 만들어집니다. 이렇게 하면 예를 들어 SQL Editor가 Test 또는 Production 데이터베이스에 연결되어 있을 경우 확인하기 쉽습니다.

새 연결에 연결 색상을 선택하려면

  1. Server Login 창에서 연결을 작성합니다.

  2. 오른쪽 Color 드롭다운 상자에서 해당 연결에 지정할 색상을 선택합니다.

연결 색상을 변경하려면

  1. Server Login 창 연결 눈금에서 색상을 변경할 연결의 Color 열을 누릅니다.

  2. 드롭다운 목록에서 사용할 색상을 선택합니다.


자동 연결

Toad는 Toad를 시작할 때마다 선택한 연결로 연결할 수 있습니다.

Server Login 창에서 이 작업을 수행하십시오.

자동 연결을 작성하려면

  1. Server Login 창을 엽니다.

  2. 이전 연결(왼쪽 패널)의 목록에 "Auto Connect?"라는 열이 있습니다. 자동으로 연결할 연결을 찾고 상자를 선택합니다. 이제 Toad가 시작하면 이 연결이 자동으로 연결됩니다.

주: 여러 연결이 있을 경우 Toad가 자동 연결을 시작한 후에도 취소할 수 있습니다. Toad는 현재 연결을 끝내고 아직 연결되지 않은 연결을 모두 취소합니다.

자동 연결을 제거하려면

  1. Server Login 창의 이전 연결 목록에서 해당 연결을 찾습니다.

  2. "Auto Connect?" 확인란을 눌러 체크 표시를 제거합니다. 이제 Toad가 시작하면 연결이 더 이상 자동으로 연결되지 않습니다.


연결용 암호 저장

Save Pwd?라는 열이 이전에 사용한 연결 눈금에 나타납니다.

암호는 connectionpwds.ini라는 암호화된 파일에 저장됩니다. 이 파일은 작성된 시스템에 연결되어 있으며 보안 상의 목적으로 다른 시스템에 전송할 수 없습니다.

이 기능을 사용하여 해당 행의 연결의 암호를 저장합니다.

주: 이 열은 "Save passwords for all Oracle connections" 옵션이 선택 취소되어 있을 경우에만 나타납니다. 이 옵션은 창 아래의 확인란을 사용하여 변경할 수 있습니다.

암호 옵션

이 화면에서 2개의 암호 옵션을 사용할 수 있습니다. 저장한 암호는 모두 자동으로 암호화됩니다.

모든 Oracle 연결용 암호 저장

다시 연결하기 위해 암호 기억


즐겨찾기 연결 선택 및 보기

연결 목록의 길이가 길지만 일관되게 사용하는 연결 수가 상대적으로 적은 경우 해당 연결을 즐겨찾기로 선택하고 해당 연결만 나열되도록 할 수 있습니다. 전체 목록은 계속해서 쉽게 볼 수 있습니다.

즐겨찾기 연결을 선택하려면

  • connection 그리드에서 즐겨찾기로 만들려는 연결의 Favorite 확인란을 선택합니다.

그리드에서 즐겨찾기를 보려면

  • connection 그리드 아래에서 Show Favorites Only 확인란을 선택합니다.

그리드의 모든 연결을 보려면

  • connection 그리드 아래에서 Show Favorites Only 확인란을 선택 취소합니다.


기존 연결 사용

Server Login 창에서 기존 연결을 선택하여 활성화합니다.

이전 연결을 사용하려면

  1. 드롭다운 콤보 상자에서 User/Database 조합을 선택합니다.

또는

왼쪽 패널의 목록에서 이전 연결을 두 번 누릅니다.
Toad가 사용자 이름을 Password 상자에 복사하고 Password 상자에 커서를 둡니다.

  2. PASSWORD가 USER와 동일하지 않으면 PASSWORD를 입력합니다. (1/10은 스키마가 password = schema로 작성됩니다. 예를 들어, DEMO/DEMO와 같습니다. Toad가 암호를 추측하지만 다른 암호를 입력할 수 있습니다.) 암호가 만료되어 Password Expired 오류가 발생하면 Toad는 새 암호를 입력하라는 프롬프트를 표시하면서 변경하려고 합니다.

  3. OK를 누릅니다.

또는

<ENTER>를 누릅니다.

Toad는 Toad 세션 간의 USER/DATABASE 조합을 저장하지만 암호는 저장하지 않습니다.

주의: View > Options > General > Save passwords for Oracle connections 옵션은 시스템에 암호를 저장합니다. 안전한 환경이 보장될 경우에만 이 옵션을 사용하십시오.


SQLNET Editor

SQLNET Editor에서 SQLNET.ORA 매개 변수를 쉽게 편집할 수 있습니다. 이 매개 변수는 Oracle 표준입니다. 자세한 내용이 필요할 경우 Oracle 설명서에서 SQLNET.ORA 프로파일 매개 변수를 참조하십시오.

뿐만 아니라, 현재 파일을 보고, 백업 사본을 작성하거나 이전에 저장한 SQLNET.ORA 사본에서 복원할 수 있습니다.

SQLNet Editor 창이 읽기 전용 모드로 나타납니다. 이렇게 되면 실수로 편집되는 일은 발생하지 않습니다.

SQLNET 연결 파일을 편집하려면

  1. Server Login 창의 Installed Clients 영역에서 SQLNET Editor를 누릅니다. 그러면 Editor가 새 창에서 열립니다.

  2. Make settings editable 확인란을 선택합니다.

  3. 매개 변수를 필요한 만큼 변경한 다음 OK를 누릅니다.

주: 멀티스레드 서버를 사용 중이고 PL/SQL 디버거를 사용할 계획이면 USE_DEDICATED_SERVER 확인란을 표시합니다. 이렇게 하면 PL/SQL 디버거가 작동할 수 있습니다.

SQLNET.ORA 파일을 보려면

  1. Server Login 창의 Installed Clients 영역에서 SQLNET Editor를 누릅니다. 그러면 Editor가 새 창에서 열립니다.

  2. 창 아래의 View File 단추를 누릅니다.

SQLNET 파일 백업

변경하기 전에 SQLNET.ORA 파일의 백업 파일을 작성하는 것이 좋습니다. 이렇게 하면 문제가 발생할 경우 원래 설정을 복원할 수 있습니다.

SQLNET.ORA 파일의 백업 사본을 작성하려면

  1. Server Login 창의 Installed Clients 영역에서 SQLNET Editor를 누릅니다. 그러면 Editor가 새 창에서 열립니다.

  2. SQLNET 연결 파일을 편집하려면에 설명된 대로 필요한 만큼 변경합니다.

  3. Create Backup File 단추를 누릅니다.

  4. 백업 파일이 작성된 위치를 기록하고 OK를 누릅니다.

SQLNET.ORA 파일의 백업 사본을 작성하려면

  1. Server Login 창의 Installed Clients 영역에서 SQLNET Editor를 누릅니다. 그러면 Editor가 새 창에서 열립니다.

  2. Restore Backup File 단추를 누릅니다.

  3. Open file 대화상자가 나타나면 복원할 백업 파일을 선택합니다.

  4. Open을 누릅니다.

  5. Toad에서 확인 대화상자가 표시됩니다. OK를 누릅니다.


LDAP Editor

LDAP Editor를 사용하여 LDAP 매개 변수를 편집할 수 있습니다. Toad는 Oracle LDAP 및 Windows LDAP 서버 모두 지원합니다.

LDAP Editor를 액세스하려면

  • Server Login 창에서 LDAP Editor 단추를 누릅니다.

LDAP 파일 백업

변경하기 전에 LDAP 파일의 백업 파일을 작성하는 것이 좋습니다. 이렇게 하면 문제가 발생할 경우 원래 설정을 복원할 수 있습니다.

백업 파일을 작성하려면

  • Create Backup File을 누릅니다.

백업에서 복원하려면

  • Restore Backup File을 누릅니다.

LDAP Editor 사용

Editor의 위에는 현재 편집 주인 파일의 경로가 표시됩니다. 아래는 편집 가능한 디렉토리 서버 목록 및 기본 관리 구문입니다.

디렉토리 서버를 추가하려면

  1. Directory Servers 영역에서 Add를 누릅니다.

  2. 호스트, 포트 및 SSL 포트 정보를 입력합니다.

  3. OK를 누릅니다.

기본 관리 구문을 설정하려면

주: 기본 관리 구문은 Directory Server 영역에 나열된 모든 서버에 적용됩니다.

  • Default Admin Context 영역에서 사용할 구문을 입력합니다.

Admin 구문 및 Default admin 구문에 대한 자세한 내용은 Oracle 설명서를 참조하십시오.

서버 유형을 설정하려면

주: 디렉토리 서버 유형은 Directory Server 영역에 나열된 모든 서버에 적용됩니다.

  • Directory Server Type 상자에서 드롭다운을 누르고 사용할 서버 유형(Microsoft Active Directory 또는 Oracle Internet Directory 중 하나)을 선택합니다.


Oracle Home 선택

Server Login 창에서 Oracle Home을 변경할 수 있습니다. 한 번에 하나의 Oracle 홈만 사용할 수 있습니다. 즉, 한 번 연결되면 나중에 모든 연결이 기본 홈과 상관없이 동일한 Oracle 홈을 사용하여 자동으로 이루어집니다.

Oracle 홈은 각 연결 또는 Toad 전체에 할당할 수 있습니다. 기본 Oracle Home에 대한 내용은 기본 Oracle Home 선택을 참조하십시오.

Oracle Home 선택

이전에 연결되지 않았으면 Oracle Home의 드롭다운 목록을 사용하여 Oracle Home을 선택합니다.

선택한 홈에 대한 내용을 보거나 SID, NLS_LANG 또는 SQLPATH를 변경하려면 드릴다운 [image] 단추를 눌러 Oracle Home Editor를 엽니다.

주: Toad를 다시 시작하여 여기서 변경해야 적용됩니다.

Toad가 Oracle Client DLL을 찾는 방법

  1. Toad는 우선 Toad 명령줄에서 OCIDLL을 찾습니다.

  2. 찾을 수 없을 경우 Toad는 다음과 같이 Oracle 홈에 대한 경로를 찾습니다.

  3. 명령줄 인수 "ORACLEHOME"이 전달되면 Toad가 해당 홈을 사용합니다.

  4. 정의된 Toad 홈이 없으면 Toad가 드롭다운에서 기본값으로 Oracle의 Home Selector를 사용하여 기본 홈으로 설정되어 있는 홈을 표시합니다. Toad는 드롭다운에서 활성화되어 있는 홈을 사용하게 됩니다.

  5. 드롭다운을 채우기 위해 Toad는 다음과 같이 레지스트리를 검색합니다.

    • Toad는 우선 HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\ALL_HOMES 아래의 키에서 Oracle 홈 이름 목록을 읽습니다.

    • Oracle 홈이 없을 경우 Oracle 홈은 HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE로 설정됩니다.

    • 그렇지 않으면 Toad는 필요에 따라 각 Oracle 홈에 대한 ORACLE_HOME 값을 찾습니다. 그런 다음 Toad는 PATH라는 시스템 환경 변수를 확인하여 ORACLE_HOME 아래의 "bin" 폴더가 포함되어 있는지 점검합니다. Toad는 PATH의 처음에 경로가 나타나는 Oracle 홈을 선택합니다.

  • Toad가 계속 Oracle 홈을 찾지 못할 경우 HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE을 사용합니다.

  3. Oracle 홈을 발견한 경로 아래의 "Bin" 폴더에서 클라이언트 DLL을 찾습니다.

  4. 찾을 수 없을 경우 Toad는 HKEY_LOCAL_MACHINE\ORACLE\SOFTWARE 아래의 ORACLE_HOME 키를 찾고 "Bin" 폴더에서 클라이언트 dll을 찾습니다.

  5. 그래도 찾을 수 없을 경우 Toad는 PATH의 모든 \bin 디렉토리에서 클라이언트 dll을 찾습니다.


기본 Oracle Home 선택

연결 색상을 선택하는 것과 동일한 방식으로 기본 Oracle 홈을 선택할 수 있습니다. 기본 홈은 연결 또는 Toad에 할당할 수 있습니다.

기본 Oracle 홈이 특정 연결에 할당되면 연결 눈금에서 이 연결을 수행할 때마다 Toad는 자동으로 해당 Oracle 홈을 사용합니다. 기본 Oracle 홈이 Toad에 할당되면 Toad는 새 데이터베이스 연결을 작성할 때마다 Oracle 홈을 자동으로 사용합니다.

주: 한 번에 하나의 Oracle 홈만 사용할 수 있습니다. 모든 기본 Oracle 홈은 현재 활성화되어 있는 연결에 사용되는 홈을 활용합니다.

새 연결에 대한 Oracle 홈을 선택하려면

  • Server Login 창에서 연결된 것이 아무 것도 없으면 Connect Using 드롭다운에서 현재 연결과 함께 사용할 Oracle 홈을 선택합니다.

이 Oracle 홈은 선택한 연결과 연관되며 연결 눈금의 홈 열에 나열됩니다.

Toad 기본 Oracle 홈을 선택하려면

  1. Server Login 창 연결 눈금에서 활성화되어 있는 연결이 없으면 Connect Using 드롭다운에서 Oracle 홈을 선택합니다.

  2. Make this the Toad Default Home 확인란을 선택합니다.

데이터베이스를 변경하면 이 연결이 Oracle 홈 드롭다운에 입력됩니다.


Oracle Home Editor

Oracle Home Editor를 사용하여 사용 가능한 Oracle Home을 분석할 수 있습니다.

노드를 눌러 Oracle Home을 선택합니다. 다음을 수행할 수 있습니다.

  • Clipboard를 누릅니다. 이렇게 하면 전자 메일 또는 다른 문서에 붙여 넣을 수 있도록 선택한 정보가 클립보드에 복사됩니다.

  • Advice를 누릅니다. 이렇게 하면 이 홈에 대한 올바른 SQL*Net 설치 프로그램이 있는지 묻거나 설치에 대한 변경을 요구할 수 있습니다.

  • 마우스 오른쪽 단추를 누르고 다음 중 하나를 편집하기로 선택합니다.

  • 선택한 홈의 SID

  • 선택한 홈의 NLS_LANG

  • 선택한 홈의 SQLPATH


TNSNames Editor

TNSNames Editor 개요

TNSNames Editor에서 TNSNames 파일을 쉽게 편집할 수 있습니다. 새 서비스를 추가하고, 서비스를 편집하고, 서비스를 삭제하거나 두 개의 파일을 작업하여 파일 간에 서비스를 송/수신할 수 있습니다.

이 창에서 다음 작업을 수행할 수 있습니다.

  • TNSNAMES 파일 로드 및 보기

  • 서비스 추가

  • 서비스 편집

  • 서비스 삭제

  • 연결 테스트

  • 두 개의 파일 작업

TNSNames Editor를 액세스하려면

  • Utilities menu|TNSNames Editor에서 이 창을 액세스합니다.

또는

Server Login 창의 우측 하단에서 TNSNames Editor를 누릅니다.


TNSNAMES 파일 로드 및 보기

활성화된 TNSNames 파일을 로드하려면

  1. TNSNames Editor를 엽니다.

  2. Open active file [image] 단추를 누릅니다. 그러면 표준 찾아보기 창이 열립니다.

저장된 파일을 로드하려면

TNSNames 파일 및 파일 내의 특정 서비스를 쉽게 로드하고 볼 수 있습니다.

  1. TNSNames Editor를 엽니다.

  2. Load tnsnames.ora [image] 단추를 누릅니다. 그러면 표준 찾아보기 창이 열립니다.

  3. TNSNames 파일이 위치한 디렉토리를 찾아 선택합니다. 그러면 Editor로 파일이 로드됩니다.

파일을 보려면

파일을 볼 수 있는 방법은 두 가지가 있습니다.

  • 트리 보기의 항목을 눌러 특정 서비스 항목을 볼 수 있습니다. 항목은 Text 탭의 화면 아래에 표시됩니다.

  • 트리 보기의 항목 부분을 눌러 서비스 항목의 일부를 볼 수 있습니다. 예를 들면 다음과 같습니다.

  • ADDRESS_LIST

  • ADDRESS

  • PROTOCOL

선택한 항목 부분이 아래 패널에서 강조표시됩니다.


TNSNames Editor 구문 확인

구문 확인

언제든지 Editor에서 TNSNames 파일에 있는 특정 항목에 대한 구문을 확인할 수 있습니다. 오류가 있을 경우 Toad는 목록으로 만들어 해결 방법을 제시합니다. 오류가 없을 경우 "Validation successful"이라는 대화상자가 표시됩니다.

구문을 확인하려면

  1. 트리 보기에서 확인할 항목을 선택합니다.

  2. 하단 패널에서 Check Syntax 탭을 누릅니다.

관련 항목

TNSNames Editor

TNSNAMES 파일 로드 및 보기


서비스 추가

서비스 및 세부 사항 추가

TNSNames Editor를 사용하면 새 서비스 항목 또는 이미 작성한 항목의 세부 사항을 쉽게 추가할 수 있습니다.

서비스를 추가하려면

  1. 편집기의 한쪽 부분으로 tnsnames.ora 파일을 로드하고 New Service [image] 단추를 누릅니다.

  2. 해당 서비스에 사용할 Service Name을 입력합니다. 이름 상자에서 쉼표 또는 공백이 있는 여러 별칭을 구분합니다. (예: ORACLE10G.WORLD, PRODUCTION10G 또는 ORACLE10G.WORLD PRODUCTION10G.)

  3. 이 서비스에 템플릿을 사용하려면 Use Template 확인란을 선택합니다.

  4. OK를 누릅니다.

세부 사항 추가 - 선택한 템플릿

  • 트리 보기에서 아래에 설명된 대로 적절한 서비스 정보를 값 열에 입력합니다.

  • 프로토콜 - 드롭 다운에서 적절한 항목을 선택합니다.

  • 호스트 - 상자에 호스트 IP를 입력합니다.

  • 포트 - 상자에 포트 번호를 입력합니다.

  • 서비스 이름

세부 사항 추가 - 선택한 템플릿 없음

  1. 트리 보기에서 새 서비스에 대한 노드를 선택합니다.

  2. Add Detail [image] 단추를 누르고 추가할 세부 사항을 선택합니다.

  3. 설명

  4. 설명 목록

  3. 세부 사항 중 하나를 선택하고 Add Detail 단추를 눌러 하위 세부 사항을 추가합니다.

  4. 서비스 항목의 모든 부분이 추가될 때까지 3단계를 반복합니다.


서비스 편집

기존 서비스의 서비스 정보를 변경할 수 있습니다.

서비스를 편집하려면

  1. 편집할 서비스 노드의 세부 사항을 선택합니다.

  2. 세부 사항의 값 열을 누릅니다.

  3. 상자의 세부 사항 값을 변경합니다.

  4. 변경할 값이 많을 경우 모두 이 단계를 반복합니다.

  5. OK 단추는 파일을 저장합니다. Cancel 단추는 마지막으로 저장된 이후 파일을 편집한 내용을 모두 취소합니다. 서비스 정보 편집이 완료되면 OK를 누릅니다.

세부 사항 별도 추가

기존 항목에 세부 사항을 별도로 추가할 수 있습니다. 세부 사항을 추가할 항목을 선택한 다음 세부 사항 추가 - 선택한 템플릿 없음의 지침을 따릅니다.


서비스 삭제

서비스 또는 세부 사항 삭제

TNSNames 파일에서 서비스 또는 세부 사항을 쉽게 삭제할 수 있습니다.

주: 삭제할 노드를 선택할 때 아래에 있는 노드도 모두 삭제됩니다.

서비스를 삭제하려면

  1. 서비스 목록에서 삭제할 서비스를 선택합니다.

  2. Delete [image] 단추를 누르거나 키보드의 <DELETE>를 누릅니다. 삭제 확인 프롬프트가 표시됩니다. OK를 누릅니다.

세부 사항을 삭제하려면

  1. 서비스 목록에서 삭제할 세부 사항을 선택합니다.

  2. Delete [image] 단추를 누르거나 키보드의 <DELETE>를 누릅니다. 삭제 확인 프롬프트가 표시됩니다. OK를 누릅니다.


TNSNames 파일에 변경 내용 저장

화면 아래의 OK 단추를 누르면 파일이 저장되고 Editor가 닫힙니다.

Editor를 닫지 않고 파일을 저장하려면

  • 도구 모음의 Save [image] 단추를 누르면 현재 파일 이름으로 파일이 저장됩니다.

또는

Save as [image] 단추를 누르면 파일 이름을 변경할 수 있습니다.

저장하지 않고 취소하려면

  • Cancel 단추를 누르면 마지막으로 저장된 이후 파일을 편집한 내용이 모두 취소되고 Editor가 닫힙니다.

TNSNames Editor가 파일을 겹쳐 쓸 때마다 우선 동일한 디렉토리에 해당 파일의 백업을 만듭니다. 실수로 파일에 문제가 발생할 경우 백업 파일을 사용하면 됩니다.


연결 테스트

TNSPing 기능을 사용하여 새 연결 또는 변경 내용을 테스트할 수 있습니다.

연결을 테스트하려면

  1. TNSping 실행 파일이 파일을 읽는 위치에 파일을 저장합니다.

  2. 테스트할 연결 목록에서 하나의 연결을 선택합니다.

  3. 도구 모음에서 TNSPing [image] 단추를 누릅니다. 확인 대화상자에 다음 메시지가 표시됩니다.

  4. Test Failed

  5. Test Succeeded


두 개의 파일 작업

서비스 간에 비교 및 복사할 TNSNames 파일이 두 개가 있을 수 있습니다. TNSNames Editor를 사용하면 이러한 작업을 쉽게 수행할 수 있습니다. 이 파일은 동일한 파일이거나 다른 파일일 수도 있습니다. 동일한 파일을 Editor의 양쪽에 로드하면 편집하기 전에 서비스 이름을 쉽게 중복시킬 수 있습니다.

두 개의 TNSNames 파일을 작업하려면

  1. Editor의 왼쪽에 있는 TNSNames 파일 중 하나를 로드합니다.

  2. 다른 파일을 오른쪽에 로드합니다.

  3. 그런 다음 한 쪽에서 서비스를 선택하고 중앙에 있는 단추를 사용하여 다른 쪽으로 복사할 수 있습니다.

주: TNSNames Editor는 tnsnames.ora 파일에 항목이 중복되지 않도록 합니다. 여기서 서비스를 복사한 다음 편집할 수 있습니다.

아이콘 | 동작
> | 선택한 서비스를 파일의 왼쪽에서 오른쪽으로 이동합니다.
< | 선택한 서비스를 오른쪽에서 왼쪽으로 이동합니다.
>> | 모든 서비스를 왼쪽에서 오른쪽으로 이동합니다.
<< | 모든 서비스를 오른쪽에서 왼쪽으로 이동합니다.


도구 모음 레이아웃

View|Options|Toolbars에서 서로 다른 여러 도구 모음 레이아웃을 사용할 수 있습니다. 여기에는 다음이 포함됩니다.

·

·

주: View|Toad Options| Toolbars 화면을 보면 현재 사용 중인 도구 모음 구성을 확인할 수 있습니다.

어떤 이유로 TOAD.INI를 삭제한 경우 도구 모음을 선택하라는 메시지가 표시됩니다(새 설치를 의미함). 하지만 사용자 정의 도구 모음은 없어지지 않습니다.

·

· View|Toad Options|Toolbars/Menus로 가서 작성해야 합니다.

User Default

User Default를 사용하면 사용자가 7.3에서 사용자 정의한 도구 모음을 보존할 수 있습니다. 또는 새 사용자에게 Default 도구 모음(Toad Default, all items)이 제공됩니다.

Toad Default [all items]

7.4 이전 버전에서와 마찬가지로 기본 Toad 도구 모음을 로드합니다. All items는 모든 항목을 의미합니다. 라이센스에서 허용되는 모든 항목이 표시됩니다.

DBA Module이 없는 경우에는 DBA module 메뉴 항목이 표시되지 않습니다. DBA 라이센스 키를 입력하면 나타납니다.

이 유형의 파일은 읽기 전용입니다. 사용자 정의는 할 수 없지만 목적에 적합한 새 도구 모음 구성을 추가할 수는 있습니다.


새 도구 모음 추가

새 도구 모음 배치 추가

구성된 도구 모음은 마음에 들지만 Toad에서 제공하는 것과 다른 구성이 필요한 경우에는 Toad 기능을 사용하여 직접 도구 모음을 작성할 수 있습니다.

배치를 추가하려면

  1. View|Toad Options|Toolbars/Menus|Toolbars를 선택한 후 Add…를 눌러 Toolbar Configuration을 추가합니다. Add toolbar configuration대화 상자가 나타납니다.

  • Template: 시작 위치를 선택합니다. 여기에는 기존 Toolbar Configuration에서 Toad Default를 뺀 것이 포함되며, 이전에 추가한 새 구성이 모두 포함됩니다.

  • Name: 구성의 이름입니다. 옵션 화면에 구성이 나타나는 방식을 지정합니다.

  • INI filename (without path): 도구 모음 구성에 사용할 파일의 이름입니다.

  2. OK를 눌러 구성을 추가합니다.

구성을 추가하고 나면 View|Toad Options|Toolbars/Menus|Toolbars로 돌아가 현재 구성을 방금 작성한 구성으로 설정합니다.

사용자 지정 도구 모음 배치 배포

그 후에는 원하는 대로 사용자 지정하여 배포할 수 있습니다. 배포하려면 다음 줄이 포함되도록 TOAD.INI를 편집합니다.

[ToolbarConfiguration6]

Desc=newtoolbarconfiguration

Filename=filename.ini

ToolbarConfiguration6은 첫 번째 새 구성이 됩니다. 필요에 따라 이 값을 늘리십시오.

주: Toad를 사용자 지정 구성으로 배포하는 경우에만 수동으로 TOAD.INI를 편집해야 합니다.


구성 가능한 도구 모음

구성 가능한 도구 모음 및 메뉴 - 개요

허용되는 도구 모음 레이아웃 구성을 사용하는 경우 주 Toad 도구 모음 및 메뉴 표시줄뿐만 아니라 편집기 도구 모음도 구성할 수 있습니다. 이렇게 하면 Toad를 정렬하여 작업 방식에 최선으로 반영할 수 있습니다. 기본 도구 모음 및 편집기 도구 모음 항목에서 기본 도구 모음의 내용을 볼 수 있습니다.

사용자 정의 구성을 사용 중인 경우 Toad를 업그레이드할 때 사용자 정의 도구 모음에 새 명령이 추가되지 않습니다. 그러나 새 명령과 도구 모음 및 메뉴에서 제거한 명령을 모두 쉽게 확인할 수 있습니다.

새로운/제거한 명령을 확인하고 추가하려면

  1. 도구 모음에서 마우스 오른쪽 단추를 누르고 Customize를 선택합니다.

  2. Commands 탭을 누릅니다.

  3. 명령 목록에서 [New] 또는 [Removed]를 선택합니다.

  4. 선택한 도구 모음/메뉴에 명령을 끌어다 놓습니다.

  5. 완료되면 Close를 누릅니다.

사용 구성

Toad 메뉴 표시줄은 Toad와 함께 작업할 수 있도록 자체 구성할 수도 있습니다. 작업 시 Toad는 가장 자주 사용하는 명령의 데이터를 수집합니다. 메뉴는 가장 자주 사용하는 명령을 목록 위에 가깝게 이동하고 거의 사용하지 않는 명령을 숨기면서 사용자의 작업 습관에 맞추어 설정됩니다. 이 기능을 사용하려면 자세한 내용은 Customize 옵션을 참조하십시오.

다음을 수행할 수 있습니다.

  • 도구 모음 변경(메뉴 표시줄 포함)

  • 도구 모음 표시 및 숨김. 메뉴 표시줄은 숨길 수 없습니다.

  • 새로운 사용자 정의 도구 모음 작성.

  • 기본 도구 모음 복원.

  • 메뉴 명령 바로 가기 키 변경 및 추가.

  • 도구 모음 표시 및 도킹 방식 조정(옵션: 도구 모음 참조).


일반 바로 가기 키

다음은 일반 Toad 바로 가기 키 목록입니다. 또한 Debugger 및 Editor의 특정 바로 가기 키도 있습니다.

Configure Menu Shortcuts 대화상자를 사용하여 바로 가기 키를 편집할 수도 있습니다.

바로 가기 키 | 기능
F1 | Windows 도움말 파일
F2 | 전체 화면 편집기 전환
<SHIFT> <F2> | 전체 화면 눈금 전환
F3 | 다음 항목 찾기
<SHIFT> <F3> | 이전 항목 찾기
F4 | 팝업 창에서 표, 보기, 프로시저, 함수 또는 패키지 설명
F5 | Editor: PL/SQL 디버깅용 Editor에서 중단점 설정 또는 삭제 Editor: 스크립트로 실행
F6 | Editor 및 Results 패널 간 전환
F7 | 모든 텍스트 지우기, Editor로 추적
F8 | Editor의 이전 SQL 구문 회수, PL/SQL 디버깅용 Editor에서 프로시저 단위 실행
F9 | SQL 편집기에서 구문 실행, Editor에서 컴파일
<CTRL> F9 | Editor에서 실행(분석) 없이 구문 확인, PL/SQL 디버깅용 Editor에서 매개 변수 설정
<SHIFT> F9 | Editor에서 커서에 위치한 현재 구문 실행, PL/SQL 디버깅 없이 Editor에서 현재 원본 실행
F10 | 팝업 메뉴
F11 | PL/SQL 디버깅용 Procedure Editor에서 실행(실행 계속)
F12 | PL/SQL 디버깅용 Editor에서 커서로 실행
<CTRL> F12 | SQL 또는 Editor 내용을 특정 External Editor로 전달(Options > Editors에서 지정)
<CTRL> A | 모든 텍스트 선택
<CTRL><ALT>B | PL/SQL Debugger Breakpoints 창 표시
<CTRL> C | 복사
<CTRL> D | 프로시저 매개 변수 표시
<CTRL><ALT>D | PL/SQL Debugger DBMS Output 창 표시
<CTRL> E | 현재 구문에서 Explain Plan 실행
<CTRL><ALT>E | PL/SQL Debugger Evaluate/Modify 창 표시
<CTRL> F | 텍스트 찾기
<CTRL> G | 행으로 이동
<CTRL> L | 텍스트를 소문자로 변환
<CTRL> M | 코드 구문 만들기
<CTRL> N | 명명된 SQL 구문 회수
<CTRL> O | 텍스트 파일 열기
<CTRL> P | 코드 구문 제거
<CTRL> R | 찾기 및 바꾸기
<SHIFT> <CTRL> R | ALIASES.TXT 파일을 사용하여 별칭과 관련 표 이름 대체
<CTRL> S | 파일 저장
<SHIFT> <CTRL> S | 다른 이름으로 파일 저장
<CTRL><ALT>S | PL/SQL Debugger Call Stack 창 표시
<CTRL> T | 열 드롭다운
<CTRL> U | 텍스트를 대문자로 변환
<CTRL> V | 붙여넣기
<CTRL><ALT>W | PL/SQL Debugger Watches 창 표시
<CTRL> X | 잘라내기
<CTRL> Z | 마지막 변경 내용 취소
<SHIFT> <CTRL> Z | 마지막 취소 내용 반복
<ALT> <UP> | 이전 구문 표시
<ALT> <DOWN> | 다음 구문 표시(<ALT> <UP> 후)
<CTRL><HOME> | 데이터 눈금에서 레코드 집합의 위로 이동
<CTRL><END> | 데이터 눈금에서 레코드 집합의 끝으로 이동
<CTRL><TAB> | MDI 하위 창 수집을 통해 순환
<CTRL><ENTER> | 현재 SQL 실행(<SHIFT>F9와 동일)
<CTRL> (마침표) | 표 이름 자동 완성

관련 항목

일반 편집 도구 모음

메뉴 바로 가기 키 구성

SQL Editor 바로 가기 키

도구 모음 기본 창


Editor 바로 가기

Editor 바로 가기 키

아래 목록은 Editor에서 사용되는 바로 가기 키입니다. 다른 영역의 바로 가기 키에 대한 자세한 내용은 일반 바로 가기 키를 참조하십시오.

바로 가기 키 | 기능
F1 | Windows 도움말 파일
F2 | 전체 화면 Editor 전환
F3 | 다음 항목 찾기
<SHIFT> <F3> | 이전 항목 찾기
F4 | 커서 위치의 개체와 팝업 창의 테이블, 보기, 프로시저, 함수 또는 패키지 설명
F5 | 스크립트로 실행
F6 | Editor 및 Results 탭 사이 전환
F7 | 모든 텍스트 지우기
F8 | 이전 SQL 문 회수
F9 | 문 실행
<CTRL> F9 | 커서 위치의 문 설명
<SHIFT> F9 | 커서 위치의 코드 조각 실행
F10 | 팝업 메뉴
<CTRL> A | 모든 텍스트 선택
<CTRL> C | 복사
<CTRL> E | 현재 문의 Explain Plan 실행
<CTRL> F | 텍스트 찾기
<CTRL> G | 줄로 이동
<CTRL> H | 코드 조각 강조표시
<CTRL> L | 텍스트를 소문자로 변환
<CTRL> M | 코드 문 만들기
<CTRL> N | 명명된 SQL 문 회수
<CTRL> O | 파일 열기
<CTRL> P | 코드 문 제거
<CTRL> R | 찾기 및 바꾸기
<CTRL> S | 파일 저장
<SHIFT> <CTRL> S | 파일을 다른 이름으로 저장
<CTRL> T | 열 드롭다운
<CTRL> U | 텍스트를 대문자로 변환
<CTRL> V | 붙여넣기
<CTRL> X | 잘라내기
<CTRL> Z | 마지막 변경 실행 취소
<CTRL>. | 일치하는 테이블 이름의 팝업 목록 표시
<SHIFT> <CTRL> Z | 마지막 실행 취소 다시 실행
<ALT> <UP> | 이전 문 표시
<ALT> <DOWN> | 다음 문 표시(<ALT> <UP> 이후)
<ALT> <PageUP> | editor에서 이전 탭으로 이동
<ALT> <PageDOWN> | editor에서 다음 탭으로 이동
<CTRL> <ALT> <PageUP> | 이전 results 패널 탭으로 이동
<CTRL> <ALT> <PageDOWN> | 다음 results 패널 탭으로 이동
<CTRL><HOME> | Data 그리드에서 레코드 집합의 맨 위로 이동
<CTRL><END> | Data 그리드에서 레코드 집합의 끝으로 이동
<CTRL><SPACE> | 코드 템플릿 선택 목록 표시
<CTRL><TAB> | MDI Child 창 모음 순환

관련 항목

Configure_Menu_Shortcuts

Debugger_Shortcut_Keys

General_Shortcut_Keys


Debugger 바로 가기 키

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

여기서는 Debugger에 사용되는 바로 가기 키의 목록을 소개합니다. 다른 영역의 바로 가기 키에 대한 자세한 내용은 일반 바로 가기 키를 참조하십시오.

바로 가기 키

기능

<SHIFT>F5

현재 줄에서 중단점 설정 또는 삭제

<CTRL>F5

커서 위치에 조사식 추가

<SHIFT>F7

단계별 추적

<SHIFT>F8

절차 단위 실행

<SHIFT>F10

전체 추적

<SHIFT><CTRL>F9

매개 변수 설정

F10

마우스 오른쪽 단추 메뉴 표시

F11

디버거 선택에 적절한 방법을 사용하여 문 실행:

  • 스크립트 디버거 - 스크립트로 실행

  • DBMS 또는 JDWP 디버거 - PL/SQL로 실행

F12

커서까지 실행

<CTRL><ALT>B

중단점 표시

<CTRL><ALT>D

DBMS_Output 표시

<CTRL><ALT>E

계산/수정

<CTRL><ALT>S

Call Stack 표시

<CTRL><ALT>W

조사식 표시

<CTRL><Pg Up>

탐색 트리에서 위로 이동

<CTRL><Pg Down>

탐색 트리에서 아래로 이동

<CTRL>마우스 누르기

커서 위치에 있는 개체의 소스를 Editor에 로드


메뉴 바로 가기 키 구성

메뉴 핫 키 및 바로 가기 키와 같은 메뉴 바로 가기 키 유형은 모두 구성할 수 있습니다. 다른 영역의 기본 바로 가기 키에 대한 자세한 내용은 일반 바로 가기 키를 참조하십시오.

메뉴 핫 키

메뉴 핫 키는 <Alt> 키 및 메뉴 또는 명령을 열기 위해 밑줄이 그어진 메뉴 항목의 문자를 눌러 액세스하는 키입니다.

밑줄이 그어진 문자를 구성할 수 있습니다.

핫 키를 변경하려면

  1. 도구 모음 영역에서 Customize에 마우스 오른쪽 단추를 눌러 선택합니다. 아니면 Tools 메뉴에서 Customize를 선택합니다. Customize 대화상자가 나타납니다.

  2. 변경할 메뉴 항목에 마우스 오른쪽 단추를 누릅니다. 이름 상자에서 밑줄이 그어진 문자 앞에 앰퍼샌드(&)가 있는지 확인합니다.

  3. 앰퍼샌드의 위치를 변경하여 밑줄이 그어진 문자를 변경할 수 있습니다. 예를 들어, &Tools는 T에 밑줄을 긋는 반면, T&ools는 O에 밑줄을 긋습니다.

바로 가기 키

바로 가기 키는 메뉴로 이동하지 않고 직접 명령을 액세스하기 위해 입력하는 키입니다. 예를 들어, <CTRL><S>를 사용하여 파일을 저장할 수 있습니다.

Toad를 통해 이러한 키를 구성하여 명령을 보다 쉽게 액세스할 수 있습니다.

바로 가기 키를 구성하려면

  1. 도구 모음 영역에서 Menu Shortcuts에 마우스 오른쪽 단추를 눌러 선택합니다. Menu shortcut customization 대화상자가 나타납니다.

  2. 바로 가기 키에 설정할 명령을 누릅니다. 사용할 키 입력을 입력합니다. 이 옵션을 사용하면 컨트롤 키(예: <CTRL> 또는 <ALT>) 뒤에 키 입력을 하나만 사용할 수 있습니다.

  3. 바로 가기 키는 입력하는 대로 변경됩니다. 다른 바로 가기 키와 충돌이 있으면 Conflict 열에 별표(*)가 나타납니다. 충돌이 발견되면 삭제하면 됩니다.


도구 모음 옵션 사용자 정의

Customize 대화상자의 Options 탭에서 표시 방법을 사용자 정의할 수 있습니다.

도구 모음 옵션을 사용자 정의하려면

  1. 도구 모음에서 마우스 오른쪽 단추를 누르고 Customize를 선택합니다.

Customize 선택 내용이 보이지 않으면 표시하여 Toad Options|Toolbars|Configurations|Toad Default (all items)가 선택되어 있지 않은지 확인합니다.

  2. Options 탭을 누릅니다.

개인별 메뉴 및 도구 모음

Toad 메뉴 표시줄은 Toad와 함께 작업할 수 있도록 자체 구성할 수 있습니다. 작업 시 Toad는 가장 자주 사용하는 명령의 데이터를 수집합니다. 메뉴는 가장 자주 사용하는 명령을 목록 위에 가깝게 이동하고 거의 사용하지 않는 명령을 숨기면서 사용자의 작업 습관에 맞추어 설정됩니다.

  • Options 탭에서 Menus show recently used commands first를 선택합니다.

  • 이 옵션을 끄려면 Menus show recently used commands first를 선택 취소합니다.

아니면 메뉴를 선택하고 몇 초간 기다릴 때 숨겨진 명령이 표시될 수 있으며 남은 메뉴가 나타납니다. 이 옵션은 선택 또는 선택 취소할 수 있습니다. 선택 취소되어 있는 경우 메뉴의 마지막 옵션인 화살표를 눌러 남은 메뉴를 표시할 수 있습니다.

기타

도구 모음에 대한 기타 사용자 정의 내용은 다음과 같습니다.

  • 큰 아이콘

  • 도구 모음의 도구 설명 표시/숨김

  • 도구 설명의 바로 가기 키 표시/숨김

  • 펼침 메뉴, 슬라이딩 메뉴, 임의 애니메이션 등의 메뉴 애니메이션


기본 도구 모음

기본 Toad 창의 기본 도구 모음은 구성 가능합니다. 도구 모음이 아래와 다르게 나타나면 사용자 정의되어 있을 수 있습니다. 도구 모음 구성 및 기본 설정 복원에 대한 자세한 내용은 구성 가능한 도구 모음 - 개요를 참조하십시오.

단추 | 명령
 | 현재 활성화되어 있는 연결로 새 Editor 창을 엽니다.
 | 현재 활성화되어 있는 연결로 새 Schema Browser 창을 엽니다.
 | 새 Database Browser 창을 엽니다.
 | 새 Session Browser 창을 엽니다.
 | 새 Project Manager 창을 엽니다.
 | 현재 활성화되어 있는 연결로 새 Query Builder 창을 엽니다.
 | 새 ER Diagram을 엽니다.
 | 새 Code Road Map 다이어그램을 엽니다.
 | 현재 활성화되어 있는 연결에 Output window를 엽니다.
 | 현재 활성화되어 있는 연결로 새 Object Search 창을 엽니다.
 | 통합 도구의 액세스를 허용합니다. 추가 기능 제품 을 참조하십시오.
 | 현재 연결로 새 Script Manager 창을 엽니다.
 | 외부 도구를 구성 또는 실행할 수 있습니다. 외부 도구 구성을 참조하십시오. 도구가 최근에 실행되었을 경우 이 아이콘이 변경됩니다. 외부 도구 실행을 참조하십시오.
 | Toad Options 창을 엽니다.
 | Toad를 종료할 때 정상적으로 저장한 모든 옵션을 저장합니다.
 | PL/SQL Profiling을 전환합니다.
 | 컴파일과 디버깅을 전환합니다.
 | 이 스키마에 모든 변경 작업을 실행합니다.
 | 이 스키마에 모든 변경 작업을 롤백합니다.
 | 데이터베이스의 새 Oracle 연결을 엽니다. 기본 단추로 Server Login 창을 엽니다. 화살표를 눌러 이전에 사용한 연결을 선택합니다.
 | 현재 활성화되어 있는 Oracle 연결을 종료합니다. 기본 단추로 Select Session 대화상자를 엽니다. 화살표를 눌러 활성화되어 있는 연결을 선택합니다.

Editor 창의 도구 모음, Editor 창의 도구 모음 및 Schema Browser의 도구 모음 항목을 참조하십시오.


Edit 도구 모음

단추 | 명령
 | 이전에 저장한 SQL을 회수합니다.
 | Explain Plan을 실행합니다.
 | SQL Tuning Optimization 모듈을 사용하여 코드를 조정합니다.
 | 선택한 코드의 서식을 지정합니다.
 | 선택한 코드의 프로파일을 작성합니다.
 | 코드를 만듭니다.
 | 코드를 제거합니다.

관련 항목

Schema_Browser 도구 모음

SQL_Edit_Toolbar

Procedure_Edit_Toolbar


Desktop 도구 모음

desktop 도구 모음은 Editor 및 주 Toad 도구 모음에서 사용할 수 있습니다.

단추 | 명령
 | 바탕 화면 드롭다운 선택
 | 현재 바탕 화면 저장
 | 현재 바탕 화면 삭제

바탕 화면 저장

Save current desktop 단추를 누를 경우 Save Desktop 대화 상자가 나타납니다. 저장한 바탕 화면이 더 이상 필요하지 않은 경우 삭제할 수 있습니다.

바탕 화면을 저장하려면

  1. Save Current Desktop [image] 단추를 누릅니다.

  2. 새 바탕 화면의 이름을 입력하고 OK를 누릅니다.

현재 바탕 화면을 삭제하려면

  1. Delete Current Desktop [image] 단추를 누릅니다.

  2. OK를 눌러 삭제를 확인합니다.

관련 항목

바탕 화면 구성


창 표시줄

창 표시줄은 기본 창의 하단에 나타나며 현재 Toad에서 열려 있는 창을 표시합니다. 창 표시줄의 도구 설명은 전체 창 제목을 표시합니다.

창 표시줄의 옵션은 Toad Options|Toolbars/Menus 아래에 나타납니다.

창 표시줄을 해제하려면

  • 창 표시줄에 마우스 오른쪽 단추를 누르고 Window Bar 확인란을 선택 취소합니다.

주: 읽기 전용 도구 모음 구성을 사용 중이고 창 표시줄을 해제 상태로 두려면 Options|Toolbars/Menus|Allow docking/hiding of read only toolbars를 표시합니다.

창 표시줄을 설정하려면

  • 기본 도구 모음에 마우스 오른쪽 단추를 누르고 Window Bar를 표시합니다.

창을 변경하려면

  • 창 표시줄에서 활성화할 창 이름을 누릅니다.


도구 모음 표시/숨김

여러 개의 사용자 정의 도구 모음을 작성하고 나면 특정 도구 모음을 숨기거나 표시할 수 있습니다. 이 작업은 쉽게 수행할 수 있습니다.

주: 메뉴는 숨길 수 없습니다.

표시한 도구 모음을 변경하려면

  1. 도구 모음 영역에 마우스 오른쪽 단추를 누릅니다. 아니면 Tools 메뉴에서 Customize를 선택합니다. 사용자 정의된 메뉴가 나타납니다.

  2. 표시할 도구 모음을 선택하고 숨길 도구 모음을 선택 취소합니다. 한 번에 하나의 도구 모음을 적용해야 합니다.

아니면 여러 도구 모음을 표시하거나 숨길 경우 도구 모음 영역에 마우스 오른쪽 단추를 누르고 Customize를 선택한 다음 Customize 대화상자에서 도구 모음을 표시 및 취소합니다.

  3. 도구 모음은 화면의 모든 측면에서 도킹할 수 있거나 화면에 띄워 놓을 수도 있습니다. 화면에 띄워 놓으면 모든 Toad 창의 위에 배치됩니다.


기본 도구 모음 재설정

도구 모음의 기본 설정을 복원할 수 있습니다.

기본 도구 모음을 복원하려면

  1. 메뉴 표시줄에서 마우스 오른쪽 단추를 누르고 Customize를 선택합니다. 아니면 Tools 메뉴에서 Customize를 선택합니다.

  2. 기본값으로 복원할 도구 모음을 선택합니다. 대부분의 경우 Standard 도구 모음 또는 Main Menu가 됩니다.

  3. Reset을 누릅니다. 확인 대화상자가 나타납니다.

  4. OK를 누릅니다. 도구 모음이 Toad의 기본 설정으로 재설정됩니다.

손실된 도구 모음을 복원하려면

Editor에서 모든 도구 모음을 제거할 수 있습니다. 그렇게 할 경우 도구 모음을 창으로 복원할 수 있습니다.

  1. Editor에 마우스 오른똑 단추를 누릅니다.

  2. Desktop Panels|Customize Toolbar를 선택합니다. 사용자 정의 가능한 도구 모음 창이 나타나고, 여기서 도구 모음을 다시 활성화할 수 있습니다.


도구 모음 병합

도구 모음을 재설정하기 위해 사용할 수 있는 또 다른 방법은 Merged Toolbars 기능을 활성화하는 것입니다. 이 기능을 사용하면 모든 도구 모음이 기본 아이콘으로 재설정되고 Editor 창의 두 행에 맞도록 정렬됩니다.

병합된 도구 모음은 현재 Toad 창에서 넓은 작업 공간을 제공하는 반면 가장 자주 사용하는 명령을 표시하기 위해 설계되었습니다.

병합 도구 모음을 전환하려면

  • 도구 모음에서 마우스 오른쪽 단추를 누르고 Merged를 선택합니다.


도구 모음 작성

기본 도구 모음이 Toad 기본 도구 모음과 다르게 보이도록 하려면 사용자 정의 도구 모음을 작성하는 것이 보다 쉽습니다.

사용자 정의 도구 모음을 작성하려면

  1. 도구 모음에서 Customize에 마우스 오른쪽 단추를 눌러 선택합니다. 아니면 Tools 메뉴에서 Customize를 선택합니다. Customize 대화상자가 나타납니다.

  2. New를 누릅니다. Custom 대화상자가 나타납니다. 새 도구 모음의 이름을 지정하고 OK를 누릅니다. 새 도구 모음이 Customize 대화상자의 바로 왼쪽에 나타납니다.

  3. Customize 대화상자에서 Commands 탭을 누릅니다. 명령은 카테고리로 구분됩니다. 왼쪽 패널에 나열된 각 카테고리는 메뉴는 제외하고 메뉴 표시줄의 메뉴 항목에 해당하며 새 도구 모음에 전체 메뉴를 넣을 수 있습니다.

  4. 추가할 명령이 들어 있는 category를 누릅니다. 예를 들어, 명령 옵션은 View 메뉴 아래에 있습니다. View를 누릅니다. 그런 다음 Options가 나타날 때까지 Commands 목록을 아래로 스크롤할 수 있습니다.

  5. 이제 새 도구 모음에 명령을 끌어다 놓을 수 있습니다. 기본값으로, 해당 명령의 아이콘이 있는 경우 아이콘이 도구 모음에 표시됩니다.

아이콘 대신 텍스트 또는 텍스트 대신 아이콘을 표시하려면 도구 모음의 아이콘에 마우스 오른쪽 단추를 누르고 해당 옵션을 선택합니다. (자세한 내용은 도구 모음 변경을 참조하십시오.)

  6. 원하는 방식으로 메뉴가 구성될 때까지 계속 명령을 추가합니다.

  • 아이콘 또는 텍스트를 누르고 끌어다 놓아 도구 모음의 명령을 다른 순서로 움직일 수 있습니다. 명령 그룹 간에 분리 기호를 추가하려면 명령 중 하나를 누르고 오른쪽으로 약간 끌어다 놓습니다. 구분 기호는 도구 모음 구성 방식에 따라 이동한 명령 위 또는 왼쪽으로 배치됩니다.

  • 측면을 누르고 끌어서 도구 모음의 크기를 조절할 수도 있습니다.

  7. 도구 모음은 화면의 모든 측면에서 도킹할 수 있거나 화면에 띄워 놓을 수도 있습니다. 화면에 띄워 놓으면 모든 Toad 창의 위에 배치됩니다.


도구 모음 변경

사용자 정의가 가능한 도구 모음으로 할 수 있는 일 중 하나는 기본 도구 모음 및 메뉴 표시줄을 다시 정렬하는 것입니다.

이러한 작업을 수행하려면 도구 모음에서 마우스 오른쪽 단추를 누르고 Customize를 선택합니다. Customize 대화상자가 나타나고 도구 모음 및 Customize 대화상자 모두에서 명령으로 작업할 수 있습니다.

명령 순서 변경

메뉴 항목 또는 아이콘의 텍스트 모두 도구 모음에서 항목을 눌러 원하는 위치로 끌어 옮겨 명령 순서를 변경합니다. I 모양의 막대 포인터는 명령이 놓일 위치를 표시합니다.

메뉴 및 하위 메뉴에서도 이러한 작업을 수행할 수 있습니다(메뉴|명령 다시 정렬 참조).

명령 추가

Customize 대화상자의 오른쪽 패널에서 도구 모음으로 명령을 끌어다 놓습니다. I 모양의 막대 포인터는 명령이 놓일 위치를 표시합니다.

아이콘에서 텍스트 또는 텍스트에서 아이콘으로 변경

명령 아이콘을 텍스트로, 또는 텍스트를 아이콘으로 변경할 수 있습니다. 또는 Toad는 아이콘 및 텍스트를 모두 표시할 수 있습니다.

변경할 명령에 마우스 오른쪽 단추를 누르고 적절한 옵션을 선택합니다.

Default

이 옵션은 기본적으로 선택됩니다. 도구 모음에 아이콘이 있으면 해당 아이콘이 표시됩니다. 명령과 연결된 아이콘이 없으면 텍스트가 표시됩니다. 메뉴 표시줄에 아이콘 및 텍스트가 모두 표시됩니다.

Text only (always)

이 옵션은 옵션을 변경하여 명령 텍스트만 표시합니다. 아이콘이 숨겨집니다.

Text only (in menus)

이 옵션은 도구 모음이 메뉴 표시줄일 경우 명령 텍스트만 표시합니다. 명령이 도구 모음에 나열되면 기본값이 계속 적용됩니다.

Image and text

이 옵션은 명령이 도구 모음에 있거나 메뉴의 일부이어도 아이콘과 텍스트를 모두 표시합니다.

명령 텍스트 변경

도구 모음에 나타나는 텍스트를 변경할 수 있습니다. 도구 모음이 다른 모양으로 나타나도록 하려면 표시할 텍스트 세트가 있어야 합니다.

주: 이것은 아이콘 또는 명령 위에서 마우스를 움직일 때 나타나는 도구 설명 힌트와 동일하지 않습니다.

도구 모음의 텍스트를 변경하려면

  1. 변경할 아이콘 또는 텍스트에 마우스 오른쪽 단추를 누릅니다.

  2. Name 상자를 누르고 명령의 이름을 변경합니다. 핫 키를 정의하려면 정의할 문자 앞에 앰퍼샌드(&)를 넣습니다. (Toad 바로 가기 키와 동일하지 않지만 키보드 탐색을 위해 문자에 밑줄이 있습니다.)

도구 모음에서 명령 제거

도구 모음에서 명령을 제거하려면 도구 모음에서 눌러서 끌어옵니다.

제거 확인

명령 목록에서 [Removed]를 선택합니다. 메뉴 및 도구 모음에서 제거한 명령 목록이 표시됩니다.

명령 복원

두 가지 방법 중 하나를 이용하여 도구 모음에 명령을 복원할 수 있습니다.

명령을 복원하려면

  • [Removed] 목록에서 도구 모음 또는 메뉴로 명령을 끌어다 놓습니다.

또는

Toolbars 탭에서 복원할 도구 모음을 선택하고 Restore를 누릅니다.


메뉴 추가

메뉴 표시줄에 쉽게 전체 메뉴를 추가할 수 있습니다.

Toad 메뉴를 추가하려면

  1. 메뉴 표시줄에서 마우스 오른쪽 단추를 누르고 메뉴에서 Customize를 선택합니다.

  2. Commands 탭을 누릅니다.

  3. 창의 왼쪽 부분에서 Menus 카테고리를 선택합니다.

  4. 오른쪽 패널에서 추가할 메뉴(예: Team Coding)를 누르고 이동할 메뉴 표시줄로 끌어다 놓습니다. 포인터는 메뉴 표시줄에서 세로 막대로 변경됩니다.

사용자 정의 메뉴를 추가하려면

  1. 메뉴 표시줄에서 마우스 오른쪽 단추를 누르고 메뉴에서 Customize를 선택합니다.

  2. Commands 탭을 누릅니다.

  3. 창의 왼쪽 부분에서 New Menu 카테고리를 선택합니다.

  4. 오른쪽 패널에서 New Menu를 누르고 이동할 메뉴로 끌어다 놓습니다. 포인터는 메뉴 표시줄에서 배치를 위해 세로 막대로 변경됩니다.

  5. 메뉴 이름 변경에 설명된 대로 메뉴의 이름을 변경합니다.

  6. 원하는 대로 명령을 추가합니다.


명령 삭제

메뉴에서 명령을 쉽게 삭제할 수 있습니다.

메뉴에서 명령을 삭제하려면

  1. 메뉴 표시줄에서 마우스 오른쪽 단추를 누르고 메뉴에서 Customize를 선택합니다.

  2. 해당 명령이 포함되어 있는 메뉴를 누릅니다.

  3. 메뉴에서 명령을 누르고 끌어서 삭제합니다.


명령 추가

메뉴 표시줄에 쉽게 명령을 추가할 수 있습니다.

명령을 추가하려면

  1. 메뉴 표시줄에서 마우스 오른쪽 단추를 누르고 메뉴에서 Customize를 선택합니다.

  2. Commands 탭을 누릅니다.

  3. 나열된 카테고리에서 선택합니다. 사용 가능한 명령 목록이 오른쪽 패널에 나타납니다.

  4. 오른쪽 패널에서 명령을 누르고 이동할 메뉴로 끌어다 놓습니다. 포인터는 메뉴에서 세로 막대로 변경되고 메뉴가 열리면 가로 막대로 변경됩니다. 원하는 메뉴 어디든지 배치할 수 있습니다.

메뉴 플라이아웃 추가

기존 또는 새 메뉴에 메뉴 플라이아웃을 추가하여 메뉴를 세분화할 수 있습니다.

메뉴 플라이아웃을 따로 추가하려면

  1. 메뉴 표시줄에서 마우스 오른쪽 단추를 누르고 메뉴에서 Customize를 선택합니다.

  2. Commands 탭을 누릅니다.

  3. New Menu 카테고리를 선택합니다.

  4. Commands 패널에서 New Menu를 선택하고 이동할 메뉴로 끌어다 놓습니다. 포인터는 메뉴 표시줄에서 세로 막대로 변경되고 메뉴가 열리면 가로 막대로 변경됩니다. 원하는 메뉴 어디든지 배치할 수 있습니다.

  5. 메뉴 자체에 추가하는 방식과 동일하게 플라이아웃에 명령을 추가합니다.


명령 재정렬

명령을 재정렬하려면

  1. Customize 창을 엽니다. 메뉴 또는 도구 모음을 마우스 오른쪽 단추로 누르고 Customize를 선택합니다.

  2. 원하는 메뉴 위치에 항목을 끌어다 놓습니다. I 모양의 막대 포인터는 명령이 놓일 위치를 표시합니다.


메뉴 이름 바꾸기

사용자 정의 가능한 도구 모음/메뉴를 사용하고 있는 경우 원하는 대로 메뉴의 이름을 바꿀 수 있습니다.

메뉴의 이름을 바꾸려면

  1. 도구 모음 영역에서 Customize에 마우스 오른쪽 단추를 눌러 선택합니다. 아니면 Tools 메뉴에서 Customize를 선택합니다. Customize 대화상자가 나타납니다.

  2. 변경할 메뉴 또는 메뉴 항목에 마우스 오른쪽 단추를 누릅니다. 메뉴 또는 메뉴 항목의 새 이름을 입력합니다. 메뉴 핫 키는 동시에 변경하거나 제거할 수 있습니다. (메뉴 바로 가기 키 구성을 참조하십시오.)


메뉴 삭제

사용하지 않는 메뉴가 있는 경우 메뉴 표시줄에서 삭제할 수 있습니다.

메뉴를 삭제하려면

  1. 메뉴 표시줄에서 마우스 오른쪽 단추를 누르고 Customize를 선택하여 Customize 창을 표시합니다.

  2. 삭제할 메뉴에 마우스 오른쪽 단추를 누릅니다. 메뉴에서 Delete를 선택합니다. 메뉴가 삭제됩니다.


Toad 데이터 눈금

Toad에 걸쳐 질의 데이터가 데이터 눈금에 표시될 수 있습니다. 일부 데이터 눈금에는 표시되는 위치에 한정되는 기능이 있습니다. 대부분의 데이터 눈금은 다음 기능을 제공합니다.

  • 계산기 액세스

  • 행 높이 변경

  • 표시 옵션 변경

  • 하나의 행을 복사하여 새 행 작성

  • Windows 클립보드로 행 복사 또는 파일로 저장

  • 선택한 행 삭제

  • 단일 파일로 데이터 내보내기

  • 데이터 찾기

  • 현재 열 수정

  • 눈금 옵션

  • 행 삽입

  • 현재 열 미리 보기/미리 보기 제거

  • 종이로 눈금 내용 인쇄

  • 열 순서 다시 정렬

  • 순서 설정

  • 사용자 정의 너비 설정으로 열 너비 설정

  • 눈금 데이터 정렬

  • 임시로 일부 열 숨김

  • Memo Edit 팝업 창에서 큰 열의 내용 보기 및/또는 편집

  • BFILE 데이터 보기

  • 커서 보기

  • 중첩된 표 데이터 보기

  • 개체 데이터 보기

  • VARRAY 데이터 보기


Data Grid 도구 모음

결과 데이터 집합을 편집할 수 있는 경우 results grid 도구 모음에 있는 여러 단추(삽입, 삭제, 업데이트 게시 등)가 활성화됩니다.

단추 | 명령
 | 첫 번째 행으로 이동
 | 이전 행으로 이동
 | 다음 행으로 이동
 | 마지막 행으로 이동
 | 새 행 추가
 | 선택한 행 삭제
 | 데이터 게시
 | 게시되지 않은 데이터 변경 내용 되돌리기


결과 필터링

Toad에서 두 가지 방법으로 결과를 필터링할 수 있습니다.

  • Filter Condition 대화 상자를 사용하면 필터 조건을 results 패널에 적용할 수 있습니다.

  • Excel 스타일 필터를 사용하면 results 그리드의 열 머리글에서 직접 필터링할 수 있습니다.


Filter Condition

Filter Condition 대화 상자를 사용할 수 있습니다. 이 대화 상자를 사용하면 SQL Results 패널에 필터 조건을 적용할 수 있습니다.

SQL Results 그리드의 Grid|Filter Data 메뉴 항목에서 이 창에 액세스할 수 있습니다.

주: Grid|Filter Data는 그리드에 Excel 스타일 필터링이 활성화된 경우 비활성화되고 그렇지 않은 경우 활성화됩니다.


그리드의 데이터 정렬

질의에 "Order By" 명령이 포함되지 않은 경우 Editor 또는 Schema Browser에서 그리드 열 헤더를 누르면 Sort Options 대화 상자가 나타납니다. 그리드에 적용할 옵션을 선택하고 Apply를 누릅니다.

  • Remove Sort – 열 순서를 원래 순서로 되돌립니다.

  • Sort ASC – 이 열을 기준으로 그리드를 오름차순으로 정렬합니다.

  • Sort DESC – 이 열을 기준으로 그리드를 내림차순으로 정렬합니다.

  • NULLS - First - 처음에 그리드에 모든 null을 포함합니다.

  • NULLS - Last - 마지막에 그리드에 모든 null을 포함합니다.

주: 이 대화 상자가 표시되지 않을 경우 마우스 오른쪽 단추를 누르고 Grid Options를 선택한 다음 "Confirm sorts when clicking on column header" 옵션이 선택되었는지 확인합니다.


편집 가능한 결과 집합

질의 자체에서 업데이트 가능한 결과 집합을 반환하는 경우 SQL 쿼리의 결과를 표시하는 Data 그리드는 완전히 편집 가능합니다. 쿼리 문은 업데이트 가능하려면 반드시 ROWID를 반환해야 합니다.

예를 들어 다음 문은

select * from employee

업데이트할 수 없지만 다음 문은

select employee.*, rowid from employee

업데이트 가능합니다.

여기에서 번거로운 부분을 줄이려면 Toad에서 업데이트 가능 버전의 문으로 변환하는 EDIT 항목을 대체합니다.

예를 들면 다음과 같습니다.

edit employee

결과 집합이 편집 가능해야 하지만 읽기 전용으로 남아 있는 경우 Toad Options|Data Grids - Data 탭의 Use Read-Only Queries 확인란이 활성화되지 않았는지 확인합니다.

주: 날짜는 mm/dd/yy 또는 mm/dd/yyyy 형식이나 Windows 제어판, 국가별 설정, 날짜, 간단한 날짜 스타일 형식으로만 입력할 수 있습니다. 예를 들어 프랑스에서는 dd/mm/yy 또는 dd/mm/yyyy 날짜 입력이 허용됩니다. dd-mon-yy 형식으로 입력한 날짜는 거부됩니다.


플랫 파일에 데이터 내보내기

데이터를 플랫 파일에 내보내려면

  • Grid 메뉴나 마우스 오른쪽 단추 메뉴에서 Export to Flat File 메뉴 항목을 선택합니다. 플랫 파일에 데이터를 내보내기 전에 추가 입력 옵션을 위한 Flat File Export from Query 창이 나타납니다.


행 복제

편집을 위해 전체 행을 복사하려면

  1. 래코드 집합을 편집한 다음 복사할 행의 셀을 누릅니다.

  2. Grid|Duplicate Row 메뉴 항목을 선택합니다(마우스 오른쪽 단추 메뉴에서도 사용할 수 있음).

이렇게 하면 SQL Results 그리드의 맨 아래에 전체 행이 복사되므로 편집할 준비가 됩니다.

또한 이 기능은 LONG 열의 데이터를 복사합니다. LOB-type, LONG RAW, XMLType 또는 개체 유형 열의 데이터는 복사되지 않습니다.

주: Copy 또는 Duplicate Row 기능이 작동하려면 레코드 집합이 편집 가능해야 합니다. 셀 내용을 편집한 후에 행을 Oracle로 보내기 위해 위 행으로 이동합니다. 이 행의 추가를 취소하려면 <ESC> 키를 누릅니다.


데이터 찾기

Toad에서는 모든 레코드에서 값을 검색하고 일치하는 첫 번째 값에 레코드 집합을 배치합니다. 레코드가 캐시되면 검색이 빨라집니다. 레코드 집합에서 질의를 빠르게 수행해야 할 경우에는 데이터베이스에서 추가 행이 반입될 때까지 기다려야 합니다.

데이터를 찾으려면

  1. 마우스 오른쪽 단추 메뉴 또는 Grid 메뉴에서 Find Data를 선택합니다.

  2. 검색할 열을 선택합니다.

  3. 찾을 키워드나 값을 입력하고 대/소문자 및 부분 일치 옵션을 선택합니다.

  4. OK 단추를 누릅니다.


행 삽입 및 삭제

결과 집합이 편집 가능한 경우 결과 집합 내에서 행을 삽입하거나 삭제할 수 있습니다.

행을 삽입하려면

  • 편집 가능한 결과 집합에서 Data 그리드 도구 모음의 Insert Row [image] 단추를 누릅니다.

행을 삭제하려면

  • 편집 가능한 결과 집합에서 Data 그리드 도구 모음의 Delete Row [image] 단추를 누릅니다.

관련 항목

편집 가능한 결과 집합

SQL Results 그리드

Results 그리드


데이터 게시

데이터 게시 및 되돌리기

편집 가능한 결과 집합에서 데이터를 변경한 후에 변경 내용을 데이터베이스에 게시하거나 되돌릴 수 있습니다.

데이터를 게시하려면

  1. results 그리드에서 편집 가능한 결과 집합을 변경합니다.

  2. Results 그리드 도구 모음에서 Post Data [image] 단추를 누릅니다.

데이터를 되돌리려면

  1. results 그리드에서 편집 가능한 결과 집합을 변경합니다.

  2. Results 그리드 도구 모음에서 Revert Data [image] 단추를 누릅니다.

관련 항목

Results 그리드

SQL Results 그리드

편집 가능한 결과 집합


LONG 및 LONG RAW 지원

Toad에서는 LONG 및 LONG RAW 열이 모두 지원됩니다. 이러한 데이터 형식을 모두 editor에서 볼 수 있습니다.

LONG 열은 최대 2GB의 문자 데이터를 포함하는 열입니다. 이러한 열을 SQL 스크립트에서 "long"으로 정의합니다. LONG RAW 열은 GIF, Word 문서 등과 같이 표시할 수 없는 이진 데이터를 포함합니다. Toad에서는 SQL Edit 그리드에서 LONG RAW 열에 대한 데이터를 표시하지 않습니다.

LONG 열은 처음 몇 개의 문자를 표시합니다. LONG RAW 열은 (BLOB)으로 표시됩니다.

LONG 및 LONG RAW 열 편집

Editor Results 그리드에서 이러한 열을 편집할 수 있습니다.

LONG 열의 경우 Text Editor 창이 표시됩니다.

LONG RAW 열의 경우 BLOB Editor가 표시됩니다.

LONG 열에 대한 팝업 editor에는 열 텍스트가 표시됩니다. editor에서 편집하거나 파일을 editor에 로드할 수 있습니다.

LONG RAWS에 대한 팝업 editor에서는 Load a File 또는 Save to File 기능이 제공됩니다.

editor에서 다음을 수행할 수 있습니다.

  • Load From File 을 사용하면 하드 드라이브에서 파일을 선택하고 Oracle 데이터베이스의 LONG RAW 열에 로드할 수 있습니다.

  • Save To File 을 사용하면 데이터베이스의 LONG RAW 열에서 데이터를 가져오고 Schema Browser 창에서 편집할 수 없는 LONG 및 LONG RAW 열의 파일에 저장할 수 있습니다.

주: 팝업 editor에서 데이터를 편집하려면 레코드 집합이 편집 가능해야 합니다. 레코드 집합을 편집할 수 없는 경우에도 팝업 editor에서 데이터의 읽기 전용 보기를 사용할 수 있습니다. Data 그리드에서 LONG 열을 파일에 저장할 수는 없습니다.

LONG 열을 편집하려면

  1. 테이블을 작성합니다: "create table long_test (id number, long_ col long)").

  2. 테이블을 편집합니다: "edit long_test"

  3. 행을 삽입합니다: 1(long col 셀을 두 번 누르기)

  4. 텍스트를 입력합니다.

  5. 오른쪽 화살표를 누릅니다. "select * from long_test"는 long col(적어도 처음 몇 개의 문자)을 포함하여 모든 레코드를 표시해야 합니다.

LONG RAW 열을 편집하려면

  1. 테이블을 작성합니다: "create table long_raw_test (id number, long_raw_col long raw)"

  2. 테이블을 편집합니다: "edit long_raw_test"

  3. 행을 삽입합니다: 1(long raw col 셀을 두 번 누르기)

  4. 가져올 파일을 선택합니다. "select * from long_raw_test"는 id만 표시하고
    long_raw_col은 (blob)을 표시해야 합니다.


계산기 액세스

Toad Data 그리드 내에서 계산기에 액세스할 수 있습니다. 계산기를 사용하려면 테이블은 편집 가능해야 합니다. 계산기를 사용하여 셀 내에서 계산을 수행합니다. 최종 결과에 만족할 경우 계산기 영역의 바깥쪽을 누르면 새 숫자가 셀에 표시된 상태로 있습니다.


BFILE 데이터 보기

BFILE 데이터를 볼 수 있습니다.

BFILE 정보가 있는 셀에는 BFILE이라는 단어가 포함됩니다. 또한 BFILE 디렉토리를 표시하기 위해 다른 열이 그리드에 추가됩니다.

BFILE 데이터를 보려면

  • 셀을 마우스 오른쪽 단추로 누르고 popup editor를 선택합니다.

또는

셀을 두 번 누릅니다. Popup Memo Editor on double-click 옵션이 활성화된 경우에만 작동합니다.

데이터가 이미지 또는 텍스트 파일인 경우 Toad 내에서 해당 데이터가 표시됩니다. 그렇지 않은 경우에는 해당 확장명에 맞는 연관된 프로그램이 시작됩니다.

BFILE을 서버의 다른 파일로 가리킬 수도 있습니다.


큰 열 보기/편집

Memo Edit 팝업 창에서 데이터를 변경하려면 결과 집합이 편집 가능해야 합니다. 그렇지 않을 경우 데이터는 읽기 전용으로 유지됩니다.

memo editor를 두 가지 방법 중 하나로 열 수 있습니다.

두 번 눌러 열려면

  1. View|Toad Options|Data Grids - Data, Popup memo editor on double-click 확인란이 선택되었는지 확인합니다.

  2. Memo Edit 팝업 창에서 해당 값을 편집할 열을 두 번 누릅니다.

두 번 눌러 열기가 비활성화된 경우 열려면

  • 마우스 오른쪽 단추를 누르고 Popup Editor를 선택합니다.


중첩 테이블 데이터 보기

중첩 데이터를 포함하는 results 그리드의 셀은 "DATASET"으로 표시됩니다.

중첩 테이블 데이터를 보려면

  • 이 셀을 두 번 눌러 memo editor를 열고 데이터를 표시합니다. Popup Memo Editor on double-click 옵션이 활성화된 경우에만 작동합니다.

또는

셀을 마우스 오른쪽 단추로 누르고 Popup Editor를 선택합니다.


VARRAY 데이터 보기

VARRAY 데이터를 보고 편집할 수 있습니다. VARRAY 정보가 있는 셀에는 VARRAY라는 단어가 포함됩니다.

VARRAY 데이터를 보려면

  • 셀을 마우스 오른쪽 단추로 누르고 Popup Editor를 선택합니다.

또는

셀을 두 번 누릅니다. Popup Memo Editor on double-click 옵션이 활성화된 경우에만 작동합니다.

표시되는 Memo editor에는 VARRAY로 되어 있는 처음 100개의 항목이 표시됩니다.


개체 데이터 보기

개체 데이터를 보고 편집할 수 있습니다. 개체 유형 데이터를 포함하는 셀에는 괄호로 묶인 데이터가 쉼표로 구분되어 표시됩니다.

개체 데이터를 보고 편집하려면

  • 셀을 마우스 오른쪽 단추로 누르고 Popup Editor를 선택합니다.

또는

셀을 두 번 누릅니다. Popup Memo Editor on double-click 옵션이 활성화된 경우에만 작동합니다.

주: 중첩 개체 유형을 편집할 수 있지만 중첩 테이블 또는 CLOB와 같은 특정 유형의 특성은 편집할 수 없습니다.


CURSOR 보기

CURSOR가 있는 질의 실행은 Data 그리드에 결과를 표시합니다. 커서가 있는 셀에 CURSOR라는 단어가 표시됩니다.

CURSOR를 보려면

  • 커서 데이터를 보려는 셀을 두 번 누릅니다. Popup Memo Editor on double-click 옵션이 활성화된 경우에만 작동합니다.

또는

셀을 마우스 오른쪽 단추로 누르고 popup Editor를 선택합니다.

주: 질의가 실행될 때마다 각 셀에 대해 데이터를 한 번만 표시할 수 있습니다. 데이터가 표시되고 나면 질의가 다시 실행될 때까지 해당 데이터는 손실됩니다.

예를 들면 다음과 같습니다.

SELECT m.ename, CURSOR (SELECT e.ename

FROM scott.emp e

WHERE e.mgr = m.empno) employees

FROM scott.emp m

WHERE job = ‘MANAGER’

결과 중 하나에서 CURSOR를 두 번 누를 경우 다음 대화 상자가 나타납니다.


BLOB

BLOB Editor

SQL Results 패널에서 column 필드에 입력된 BLOB 또는 ORABLOB는 BLOB이 해당 필드에 있다는 것을 나타냅니다. BLOB 또는 ORABLOB가 모두 대문자인 경우 필드가 null이 아니라는 것을 나타냅니다. 이러한 단어의 맨 앞 문자만 대문자인 경우(Blob 또는 Orablob) 필드가 null일 수 있거나 BLOB가 초기화되지 않았다는 것을 나타냅니다.

BLOB을 편집할 수 있습니다.

BLOB을 편집하려면

  • LONG RAW 또는 BLOB 데이터 형식 열이 포함된 테이블의 Data 그리드에서 다음 중 하나를 수행합니다.

  • Data Grids - Data 옵션 창에서 Popup memo editor on double-click 옵션이 선택된 경우 LONG RAW 또는 BLOB 개체가 포함된 필드를 두 번 누르면 BLOB editor가 표시됩니다.

  • 이 옵션이 선택되지 않은 경우 해당 필드를 마우스 오른쪽 단추로 누르고 Memo Editor를 선택합니다. BLOB editor가 표시됩니다.

BLOB Editor 도구 모음

BLOB editor에는 blob을 삽입, 편집 및 탐색하는 데 도움이 되는 간단한 도구 모음이 있습니다.

단추 | 명령
 | 파일 로드
 | 파일에 BLOB 저장
 | 파일에 BLOB 저장 및 BLOB 열기 주: 해당 파일 확장명을 포함해야 합니다.
 | 데이터를 16진수 또는 텍스트로 보기
 | 첫 번째 레코드로 이동
 | 이전 레코드로 이동
 | 다음 레코드로 이동
 | 마지막 레코드로 이동
 | 맨 위 창에 유지 - BLOB editor를 다른 창의 맨 위에 유지합니다.


Date Editor

Date Editor를 사용하여 날짜를 변경하거나 날짜 형식을 선택하거나 날짜 또는 시간을 null로 설정할 수 있습니다. Text Editor와 같이 레코드를 탐색하고 편집한 내용을 게시하거나 취소할 수 있습니다.

날짜를 변경하려면

  • 날짜 옆에 있는 드롭다운을 누르고 팝업 달력에서 올바른 날짜를 선택합니다.

날짜 형식을 변경하려면

  • Long date format 확인란을 선택하거나 선택 취소합니다.

날짜나 시간을 null로 설정하려면

  • 해당 정보 옆에 있는 Null [image] 단추를 누릅니다.


외부 편집기

원하는 외부 편집기를 사용할 수 있습니다. Toad Editor의 텍스트를 외부 편집기에서 열어서 텍스트를 편집한 다음 결과를 다시 Toad로 가져올 수 있습니다.

외부 편집기를 설정하려면

  1. View 메뉴에서 Toad Options를 선택한 다음 Editor를 선택합니다.

  2. External Editor Command Line 상자에 사용할 외부 편집기의 전체 경로, 공백 및 %s를 입력합니다.

예: c:\winnt\notepad.exe %s

외부 편집기에서 텍스트를 열려면

외부 편집기가 설정된 후 Editor의 텍스트를 외부 편집기에서 열 수 있습니다.

  • Editor에서 <Ctrl><F12>를 누릅니다(또는 Edit 메뉴에서 Load in External Editor 선택). 외부 편집기가 열리고 현재 Toad Editor 내용이 로드됩니다.

주: Toad editor의 내용을 파일에 저장하지 않은 경우 외부 편집기를 시작하기 전에 파일 이름을 묻는 메시지가 표시됩니다.

외부 편집기에서 Toad로 돌아오려면

  1. 외부 편집기에서 파일을 저장한 다음 편집기를 닫습니다.

  2. 다시 Toad를 누릅니다. View|Toad Options|Editor|Open/Save|Prompt for reload on activation if timestamp has changed 옵션이 선택된 경우에만 파일 내용을 다시 로드할지 묻는 메시지가 표시됩니다.


Popup Editor

text editor를 사용하여 긴 열의 내용을 편집할 수 있고 date editor를 사용하여 날짜 열의 서식을 변경할 수 있습니다.

주: Popup Editor 창에서 데이터를 편집하려면 레코드 집합이 편집 가능해야 합니다.

Text Editor에 액세스하려면

  • SQL Results 그리드 또는 Schema Browser Data 그리드에서 마우스 오른쪽 단추를 누르고 Popup Editor를 선택합니다.

또는

CHAR, VARCHAR, CLOB 또는 LONG 열을 두 번 누릅니다.

Date Editor에 액세스하려면

  • SQL Results 그리드 또는 Schema Browser Data 그리드에서 마우스 오른쪽 단추를 누르고 Popup Editor를 선택합니다.

또는

Date 열을 두 번 누릅니다.

주: 다른 팝업 편집기에는 BLOB editor, BFILE editor, Object data editor 및 Nested table editor가 있습니다.

관련 항목

BLOB editor

BFILE editor

Object data editor

Nested table editor

VARRAY_data editor


Window: Single Record View

Single Record View

이 대화 상자를 사용하여 SQL results 패널에서 레코드를 보고 편집할 수 있습니다.

단일 레코드 보기에 액세스하려면

  • SQL results 패널에서 그리드 머리글과 레코드 선택기/행 번호의 교차 부분에 있는 열린 책 아이콘을 누릅니다.

주: Single Record View 팝업 창을 사용하여 레코드의 데이터를 편집하려면 레코드 집합이 편집 가능해야 합니다. 자세한 내용은 편집 가능한 결과 집합을 참조하십시오.

단일 레코드를 인쇄하려면

  • Print [image] 단추를 누릅니다.


표시 옵션 변경

글꼴을 변경하거나 레코드 다중 선택을 허용 또는 허용하지 않거나 열 너비의 크기를 데이터 너비로 변경하거나 레코드 선택기에서 행 번호를 표시할 수 있습니다.

이 작업을 수행하는 방법에 대한 자세한 내용은 Data Grids - Visual을 참조하십시오.


Grid Options

마우스 오른쪽 단추 메뉴에서 이 명령을 선택하면 옵션을 선택하기 위한 Data Grids 옵션 페이지가 활성화됩니다.


행 높이 변경

마우스를 사용하여 행 높이를 쉽게 변경할 수 있습니다. 높이 조정이 테이블의 모든 행에 자동으로 적용됩니다.

  • 첫 번째 열의 왼쪽에 있는 거터에서 행 분할자 선 위에 마우스를 이동합니다. 포인터가 이중 화살표로 변경되면 행을 누르고 위쪽이나 아래쪽으로 끌어 해당 높이를 변경합니다.


열 너비 설정

Data 그리드에서 열 너비를 쉽게 변경할 수 있습니다.

열 너비를 변경하려면

  • 두 열 사이의 테두리 위에 있는 그리드 머리글로 마우스 포인터를 이동하고 왼쪽이나 오른쪽으로 끕니다.

질의 열이 질의마다 동일한 경우 이러한 사용자 정의 열 너비가 유지됩니다. 예를 들어 WHERE 절이나 ORDER BY 등을 추가하고 질의를 다시 실행할 수 있는데 이 경우 열 너비가 동일하게 유지됩니다.


시퀀스 설정

Set Sequence Column 창을 사용하면 이전에 작성한 시퀀스를 Data 그리드의 선택할 열에 적용할 수 있습니다. 시퀀스가 적용된 후 테이블에서 새 레코드를 추가하고 시퀀스된 열을 비워 둘 경우 열에 적용된 시퀀스로 다음 번호가 자동 생성됩니다.

할당된 시퀀스가 있는 열은 바다색으로 표시됩니다.

예 1

다음 예에서는 SEQ Sequence 필드를 사용합니다.

  • Editor에서 다음 스크립트를 실행합니다. 이러한 스크립트는 FIRST_NME, LAST_NME 및 ID_NMR이라는 열이 있는 SEQ_TABLE이라는 테이블을 듭니다. 또한 1부터 시작하여 1씩 증가하며 최대값이 4인 SEQA라는 시퀀스가 작성됩니다.

DROP TABLE SEQ_TABLE CASCADE CONSTRAINTS ;

CREATE TABLE SEQ_TABLE (

FIRST_NME CHAR (20),

LAST_NME CHAR (20),

ID_NMR NUMBER (4) NOT NULL,

CONSTRAINT UNIQUEID

UNIQUE (ID_NMR))

CREATE SEQUENCE SEQA START WITH 1 INCREMENT BY 1 MINVALUE 1 MAXVALUE 4 NOCACHE NOCYCLE NOORDER

예 2

다음으로 SEQ_Table에 대한 Data 그리드를 표시해야 합니다. Editor 또는 Schema Browser를 통해 이 작업을 수행할 수 있습니다. 이 예에서는 Schema Browser를 사용합니다.

  1. Schema Browser > Tables 목록에서 SEQ_Table을 선택합니다. details 패널에서 Data 탭을 누릅니다. 셀에는 현재 데이터가 비어 있습니다.

  2. Data 그리드를 마우스 오른쪽 단추로 누르고 Set Sequence Field를 선택합니다.

  3. Set Sequence Column 창이 나타납니다.

  4. Sequence 드롭다운에서 SEQA를 선택합니다. Column 드롭다운에서 ID_NMR을 선택합니다.

주: Sequence 드롭다운에서 <none>을 선택하여 Sequence 필드를 지울 수 있습니다.

  5. OK를 누릅니다.

  6. FIRST_NME 및 LAST_NME의 레코드에 데이터를 삽입합니다.

  7. Insert Record를 누릅니다. 1이 자동으로 삽입됩니다.

  8. 이름 레코드 3개를 추가로 삽입합니다. ID_NMR 열이 2, 3 및 4로 채워집니다.

  9. 5번째 레코드에 대한 데이터 삽입을 시도합니다. 오류 메시지인 "ORA-8004: sequence SEQA.NEXTVAL exceeds MAXVALUE and cannot be instantiated."가 표시됩니다. 이는 마지막 스크립트에서 최대 레코드 수를 4로 설정하기 때문입니다.

이제 레코드를 삭제할 수 있습니다.


현재 열 고정

Data 그리드의 왼쪽에서 열을 고정할 수 있습니다. 이렇게 하면 스크롤을 많이 수행할 때 정보를 더 쉽게 추적할 수 있습니다.

주: 행 번호는 자동으로 고정 열로 표시됩니다. 행 번호를 제외한 고정 열을 편집할 수 있습니다.

열을 고정하려면

  1. 열을 눌러 선택합니다.

  2. 마우스 오른쪽 단추를 누른 다음 Fix Column을 선택하여 선택한 열을 고정합니다. 선택한 열은 왼쪽에 고정됩니다. 고정 영역 밖으로 열을 이동하려면 열을 눌러 굵게 표시된 고정 열 분할자 막대의 오른쪽으로 끕니다.


Select Columns

질의 후에 SQL Results 그리드에서 열을 숨길 수 있습니다.

이 대화 상자를 사용하면 열 목록을 알파벳 순서대로 표시하도록 선택할 수 있습니다. 이렇게 하면 표시하거나 숨기려는 열을 더 쉽게 찾을 수 있습니다.

표시하거나 숨길 열을 선택하려면

  • 다음 작업 중 하나를 수행하십시오.

  • SQL Edit 창 results 그리드를 마우스 오른쪽 단추로 누른 다음 Select Columns를 선택합니다.

  • Schema Browser|Tables 페이지에서 Data 탭 그리드를 선택합니다.

  • Schema Browser| Views 페이지에서 Data 탭을 선택합니다.

  2. 열 이름 옆의 확인란을 눌러 그리드에 표시되는 열을 선택 및 선택 취소합니다.


Temporarily Hide Columns

이 대화 상자에는 Row Numbers 확인란이 있습니다. Row Numbers 확인란을 선택하여 그리드에서 행 번호를 표시할 수 있습니다.

여러 열을 숨기려면

  • 마우스 오른쪽 단추 메뉴에서 Select Columns를 선택합니다. 숨기려는 열을 선택 취소합니다. 해당 열은 copy to clipboard 또는 save to file에 포함되지 않습니다.

끌어서 열을 숨기려면

  • 열 머리글을 그리드 밖으로 끕니다. 커서는 슬래시가 있는 원으로 바뀝니다.

마우스 단추를 놓으면 열이 숨겨집니다.

숨겨진 열을 복원하려면

  • 마우스 오른쪽 단추 메뉴에서 Select Columns를 선택합니다. 복원할 열을 선택합니다.


열 순서 다시 정렬

눌러서 끌기 동작을 사용하여 열 순서를 다시 정렬할 수 있습니다. 순서를 변경한 후 데이터를 클립보드에 복사하거나 파일에 저장할 경우 데이터는 새 열 순서가 됩니다.

  • 머리글을 눌러 이동할 열을 선택하고 왼쪽이나 오른쪽으로 끌어 다시 정렬합니다.


행 복사 또는 저장

행을 복사하거나 저장하려면

  • Grid|Save As 메뉴 항목을 선택한 다음 Save Grid Contents 창에서 설정을 선택하면 데이터가 클립보드에 복사되거나 지정한 텍스트 파일에 저장됩니다.


현재 열 미리 보기

선택한 열의 값을 표시하는 각 데이터 행 아래의 전체 행을 표시하거나 숨길 수 있습니다.

현재 열을 미리 보려면

  • Data 그리드를 마우스 오른쪽 단추로 누르고 Preview Column 또는 Remove Preview Column을 선택합니다.


Save As

이 대화상자를 사용하여 현재 SQL 결과 패널을 클립보드 또는 파일로 내보냅니다. 또한 여기서 선택 사항을 설정한 다음 나중에 명령줄 결과를 실제로 내보낼 수 있습니다.

눈금 내용을 저장하려면

  • Grid menu에서 Save As를 선택합니다.

또는

데이터 눈금에서 마우스 오른쪽 단추를 누르고 Save As를 선택합니다.

주: Save As에는 CLOB 및 BLOB가 자동으로 포함됩니다. LONG 열은 이 방법으로 저장되지 않습니다. 자세한 내용은 LONG 및 LONG RAW 지원 항목을 참조하십시오.

Save As 창을 열면 데이터 저장 방식을 사용자 정의할 수 있습니다. 형식 및 파일 경로를 사용자 정의할 수 있습니다.

파일 경로를 사용자 정의하려면

  • Save Grid Contents 창 아래의 Save to file 상자에 정확한 파일 경로를 입력합니다.

관련 항목

파일 저장

저장 형식


Data Pump 개요

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Oracle Data Pump는 Oracle 10g에서 추가된 가져오기/내보내기 유틸리티입니다. 대량의 데이터를 로드하는 경우에 표준 가져오기/내보내기 유틸리티보다 훨씬 더 빠르고 효율적입니다.

두 가져오기/내보내기 엔진 사이의 중요한 차이는 다음과 같습니다.

가져오기/내보내기 | Data Pump
클라이언트 컴퓨터에서 실행 | 데이터베이스 서버에서 실행
클라이언트 컴퓨터에 있는 파일에 액세스 | 데이터베이스 서버에 있는 파일에 액세스
SQL*Net을 통한 데이터 전송 | 네트워크를 통한 데이터 전송 없음
모달 유틸리티(프로세스를 시작한 후 분리할 수 없음) | 비모달 유틸리티(프로세스를 시작한 후 분리할 수 있음)
모든 버전의 Oracle 클라이언트에서 작동 | Oracle 클라이언트 버전 10g 이상에서만 작동

Data Pump 클라이언트 프로세스는 서버에서 실행 중인 세션에서 분리될 수 있기 때문에 작업을 중단하지 않고도 가져오기/내보내기 실행 창을 닫을 수 있습니다. 가져오기/내보내기는 계속됩니다.

주: Data Pump 엔진은 이전 가져오기/내보내기 유틸리티와 호환되지 않는 파일을 생성합니다. 즉, Toad Export File Browser를 사용하여 Data Pump에서 생성된 내보내기 파일을 열거나 검토할 수 없습니다.

Data Pump 요구 사항

Data Pump를 사용하려면 내보내기 디렉토리에 대한 읽기/쓰기 권한이 있어야 합니다. 로컬 디렉토리가 공유되고, 여기에 대한 읽기/쓰기 권한이 있어야 하며 네트워크 경로로 표시되어야 합니다. 기본적으로 Data Pump 매개 변수 파일은 Toad 설치 디렉토리(C:\Program Files\Quest Software\Toad for Oracle)에 저장됩니다.

또한 클라이언트 Oracle bin 디렉토리에 가져오기/내보내기 유틸리티가 있어야 합니다. 일부 10g 설치에서는 이 유틸리티가 자동으로 설치되지 않습니다. 다음 유틸리티가 필요합니다.

  • IMPDP.EXE는 Data Pump 클라이언트 가져오기 유틸리티입니다.

  • EXPDP.EXE는 Data Pump 클라이언트 유틸리티입니다.

주: 이 유틸리티는 이전의 가져오기/내보내기 유틸리티와 다릅니다. 이전 버전의 Oracle에서 데이터를 가져와야 하는 경우에는 이전 버전의 유틸리티가 필요합니다. Import Utility 마법사 및 Export Utility 마법사를 참조하십시오.

이 유틸리티의 경로는 Toad.ini 파일에 저장됩니다. View|Toad Options|Executables에서 보고 변경할 수 있습니다. Import/Export Utility 마법사가 열려 있고 내보내기 유틸리티에 대한 경로가 지정되어 있지 않으면 Toad에서 경로를 검색하고 발견된 경우 자동으로 입력합니다.

관련 항목

Data Pump Import 마법사

Data Pump Export 마법사

가져오기/내보내기 디렉토리 설정

질의를 사용하여 데이터 필터링

스키마, 테이블 공간 및 데이터 파일 다시 매핑

테이블 이름 입력


Data Pump Job Manager 개요

Data Pump Job Manager는 Data Pump 작업을 추적하는 방법을 제공합니다. Data Pump가 연결에 제한되지 않기 때문에 작업을 시작한 후에 창을 닫을 수도 있습니다. Job Manager를 사용하면 이러한 작업을 관리하고 Data Pump 마법사 창이 닫힌 후에 작업을 시작, 중지 및 중단할 수 있습니다.

Data Pump Job Manager 도구 모음

단추 | 명령
 | 활성 세션 변경
 | 선택한 작업 시작
 | 선택한 작업 중지
 | 선택한 작업 중단
 | 그리드 새로 고침

관련 항목

Data Pump 개요

Data Pump Import 마법사

Data Pump Export 마법사


가져오기/내보내기 디렉토리 설정

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Data Pump를 사용하려면 가져오기/내보내기 디렉토리를 설정해야 합니다.

Data Pump를 사용하려면 가져오기/내보내기 디렉토리에 대한 읽기/쓰기 권한이 있어야 합니다. 로컬 디렉토리가 공유되고 읽기/쓰기 권한이 있어야 하며 네트워크 경로에 표시되어야 합니다.

Data Pump를 사용하게 하려는 사용자가 읽기/쓰기 권한을 갖고 있고 디렉토리가 공유되는지 확인하면서 네트워크상이나 로컬에서 디렉토리를 만듭니다.

관련 항목

디렉토리 만들기

Data Pump 개요

Data Pump Import 마법사

Data Pump Export 마법사


Remapping Schemas, Tablespaces, and Datafiles

Note: This Toad feature is only available in the commercial version of Toad in either the Professional Edition or with the optional Quest DBA Module.

You can remap schemas, tablespaces, and datafiles, depending on the mode and choices you have made. The tabs for these will usually all appear. However, if you choose one that is inappropriate to the choices made, it will fail when run by Oracle.

The remapping grid requires the following:

  • A source can only appear once in each remapping grid.

  • A row must contain both a source and a target.

To remap

  1. From the remapping screen of the Data Pump Import wizard, click the tab of the type of object you want to remap (Remapped Schemas, Remapped Tablespaces, or Remapped Datafiles).

  2. Click in the Source column and enter the name of the schema, tablespace or datafile you want to remap.

  3. Press <Tab>

Or

Click in the Target column.

  4. Enter the name of the schema, tablespace or datafile where you want the data in the Source column to be placed.

  5. Click the + button to add additional remappings.

To remove a remap from the grid

  • Select an item in the grid and then click the - button to remove it.

Related Topics

Data Pump Overview

Filtering Data with Queries

Entering Table Names

Data Pump Import Wizard

Data Pump Export Wizard


질의를 사용하여 데이터 필터링

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Data Pump를 사용하여 데이터를 가져오거나 내보낼 경우 질의를 사용하여 가져오거나 내보내는 데이터를 필터링할 수 있습니다.

이러한 질의의 형식은 중요하며 가져오거나 내보내는 데이터에 영향을 줍니다.

질의 문은 다음 형식이어야 합니다.

[[schema_name.]table_name:]"query_clause"

스키마 이름과 테이블 이름은 선택적입니다. query_clause는 WHERE 문입니다.

테이블 이름이 지정되지 않은 경우 질의가 모든 테이블에 적용됩니다.

다음은 몇 가지 샘플 질의 문입니다.

문 | 정의
DEPT:"WHERE DName='ACCOUNTING'" | 열 DName='Accounting'인 행으로만 DEPT 테이블의 가져오기를 제한합니다.
SCOTT.EMP:"WHERE EName='SMITH'" | SCOTT.EMP 테이블을 제한합니다.
"WHERE Col1=10" | 덤프 파일의 모든 테이블을 제한합니다. 이 질의가 작동하려면 각 테이블에 "Col1"이 있어야 합니다.

질의에서의 다시 매핑 효과

가져올 때 스키마를 다른 스키마에 다시 매핑하면(스키마, 테이블 공간 및 데이터 파일 다시 매핑 참조) 질의 결과에 영향을 줄 수 있습니다.

예를 들어 SCOTT 테이블을 제한하는 위의 두 번째 질의에서 SCOTT 스키마를 JSMITH에 다시 매핑할 경우 질의가 실패하고 모든 데이터를 가져옵니다.

이 시나리오에서 첫 번째 및 세 번째 질의는 계속 작동합니다.

오류 및 결과 없음 비교

질의는 해결할 수 없는 경우 실패합니다.

예를 들면 다음과 같습니다.

  • 스키마를 새 스키마에 다시 매핑한 다음 이전 스키마를 찾을 경우 모든 데이터를 가져옵니다.

  • 위의 세 번째 질의 예에서 일부 테이블에 Col1이 없는 경우 모든 데이터를 가져오게/내보내게 됩니다.

질의가 올바르지만 일치하는 항목이 없을 경우 데이터를 가져오지/내보내지 않습니다.

예를 들면 다음과 같습니다.

  • 첫 번째 질의 예에서 DName 열이 있지만 DName=Accounting인 항목이 없습니다. 이 경우 DEPT 테이블에서 데이터를 가져오지/내보내지 않습니다.

  • 위의 세 번째 질의 예에서 모든 테이블에 Col1이 있지만 10 항목이 있는 테이블이 없습니다. 이 경우 모든 테이블에서 데이터를 가져오지/내보내지 않습니다.

관련 항목

Data Pump 개요

스키마, 테이블 공간 및 데이터 파일 다시 매핑

테이블 이름 입력

Data Pump Import 마법사

Data Pump Export 마법사


Metadata Filter 사용

Metadata Filter 그리드 사용

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Data Pumpt의 장점 중 하나는 Metadata Filter를 사용하여 데이터를 필터링할 수 있다는 점입니다. 개체 유형별로 필터링할 수 있습니다.

Import/Export 마법사의 Metadata Filter 페이지를 사용하면 개체의 전체 범주를 포함하거나 제외할 수 있습니다. 이름 한정자를 Clause 상자에 있는 그리드에 추가하여 이러한 범주를 세부적으로 필터링할 수 있습니다. 자세한 내용은 Oracle 설명서를 참조하십시오.

Metadata Filter 그리드을 사용하려면

  1. 필터링할 유형 옆에 있는 확인란을 선택합니다.

  2. Clause 상자에 사용할 세부 선택 기준을 입력합니다. 예를 참조하십시오.

  3. 다음 중 하나를 선택합니다.

  4. Include - 선택한 데이터 유형만 포함합니다.

  5. Exclude - 선택한 데이터 유형만 제외합니다.

  6. No metadata filter(기본값)

예

사용자가 특정 기준과 일치하는 테이블에서만 Table 메타데이터를 가져오려고 합니다.

사용자가 확인란을 눌러 그리드에서 TABLE을 선택합니다. 그런 다음 INCLUDE를 선택합니다. 그러면 가져오기가 테이블 메타데이터로만 제한됩니다.

“EXCLUDE”를 누른 경우 테이블 메타데이터만 내보내기에서 제외되고 다른 모든 유형이 포함됩니다.

사용자가 메타데이터를 세부적으로 필터링하려고 합니다. 그래서 필터링 기준을 입력합니다. 이 기능은 선택 사항이며 가져오기 또는 내보내기에 추가할 항목을 어떻게 제어할지 세부적으로 조정합니다.

기준은 SQL 식이어야 하며 메타데이터에 대해 작동합니다. 이 예에서는 사용자가 “LIKE ‘SCRIPT%’”를 입력합니다.

덤프 파일에서 JSMITH 스키마에 이 기준과 이름이 일치하는 테이블은 두 개 뿐이며 SCOTT 스키마에는 하나도 없습니다. 따라서 Oracle에서는 가져온 두 JSMITH 테이블의 메타데이터만 반환합니다.

관련 항목

Data Pump 개요

Data Pump Import 마법사

Data Pump Export 마법사

질의를 사용하여 데이터 필터링

스키마, 테이블 공간 및 데이터베이스 다시 매핑


테이블 이름 입력

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

테이블을 가져올 때 그리드에 테이블 이름을 입력해야 합니다. 이러한 테이블 이름의 형식은 가져오기에 매우 중요합니다.

테이블 이름의 형식은 다음과 같습니다.

[SCHEMA].TABLENAME:[partition name]

스키마 및 파티션 이름은 선택적입니다. 그러나 항목에서 스키마를 지정하지 않을 경우 현재 사용자가 가정됩니다. 따라서 사용자가 JSMITH로 로그인했으며 SCOTT 스키마에서 테이블을 가져오는 중이면 다음과 같이 테이블 이름에 SCOTT 접두사를 추가해야 합니다.

SCOTT.SCOTTSTABLE

또한 이 기능을 사용하여 파티션을 가져올 수 있습니다. 파티션 구문의 예는 다음과 같습니다.

SCOTT.SCOTTSTABLE:scotts_partition

관련 항목

Data Pump 개요

질의를 사용하여 데이터 필터링

스키마, 테이블 공간 및 데이터 파일 다시 매핑

Data Pump Import 마법사

Data Pump Export 마법사


Data Pump Import 마법사

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Data Pump Import 마법사를 사용하면 Oracle의 Data Pump를 사용하여 데이터베이스로 대량의 데이터를 쉽게 가져올 수 있습니다.

Data Pump에는 다음과 같은 다섯 가지 가져오기 모드가 있습니다.

  • Full Import

  • Schema

  • Table

  • Tablespace

  • Transportable Tablespace

Toad 마법사는 이 다섯 가지를 모두 지원하며 기존 매개 변수 파일의 로드 및 실행에 대한 지원도 추가됩니다.

Data Pump Import 마법사에 액세스하려면

  1. Database 메뉴에서 Import를 선택합니다.

  2. Data Pump Import Wizard를 선택합니다.

관련 항목

Data Pump 개요

Data Pump Export 마법사

전체 가져오기 수행

테이블 가져오기

사용자 가져오기

테이블 공간 가져오기

전송 가능한 테이블 공간 가져오기

기존 매개 변수 파일을 사용하여 가져오기


전체 가져오기 수행

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

가져오기의 기본 모드는 "Full"입니다. 이 모드에서 Oracle은 파일 작성에 사용된 내보내기 모드 그대로 전체 덤프 파일을 가져옵니다. 따라서 "tablespaces" 모드로 내보낸 파일을 전체 가져오기로 가져오면 전체를 "tablespace" 모드로 가져오게 됩니다.

주: 다음 절차에 있는 대부분의 매개 변수는 Oracle에서 정의됩니다. 이와 관련된 자세한 내용은 Oracle 문서를 참조하십시오.

전체 가져오기를 수행하려면

  1. Database 메뉴에서 Import|Data Pump Import Wizard를 선택합니다.

  2. Import를 선택하고 드롭다운 메뉴에서 Entire Dumpfile을 선택합니다.

  3. Next를 누릅니다.

  4. 사용할 질의를 입력하여 데이터를 필터링합니다. 질의에 대한 자세한 내용은 질의를 사용하여 데이터 필터링을 참조하십시오.

  5. Next를 누릅니다.

  6. 다른 영역으로 가져올 스키마, 테이블 공간 또는 데이터 파일을 다시 매핑합니다. 자세한 내용은 스키마, 테이블 공간 및 데이터 파일 다시 매핑을 참조하십시오.

  7. Next를 누릅니다.

  8. Content 매개 변수를 입력합니다.

  9. All

  10. Data Only

  11. Metadata Only

  9. 테이블이 이미 있는 경우에 사용할 작업을 선택합니다(TABLE_EXISTS_ACTION 매개 변수에 해당).

  10. Skip

  11. Append

  12. Truncate

  13. Replace

  10. ESTIMATE 매개 변수의 값을 선택합니다.

  11. Blocks

  12. Statistics

  11. Reuse Datafiles 매개 변수를 선택하거나 선택을 취소합니다.

  12. 상태 보고서 사이의 원하는 간격을 초 단위로 입력합니다. 상태 보고서는 Data Pump Watch 창에 표시됩니다. 각 개체 유형이 완료될 때에만 업데이트하려면 0을 입력합니다.

  13. Next를 누릅니다.

  14. 포함하거나 제외할 개체 유형을 선택합니다.

  15. Next를 누릅니다.

  16. 디렉토리를 선택하고 입력 파일 이름, 로그 파일 이름 및 SQL 파일 이름을 입력합니다.

선택한 디렉토리에 입력 파일 이름이 있어야 합니다. 선택한 디렉토리에 로그 파일이 작성됩니다. SQL 파일 이름을 입력하면 가져오기가 이루어지지 않습니다. 가져오기 수행에 필요한 DDL이 지정된 이름의 파일로 생성 및 저장되며 파일은 디렉토리 선택에서 지정한 디렉토리에 작성됩니다.

주: 디렉토리는 가져오기/내보내기 디렉토리 설정에서 설명한 대로 작성해야 합니다.

  11. Toad에서 매개 변수 파일 이름을 자동으로 작성하지만, 이 이름은 사용자가 변경할 수 있습니다.

  12. 선택적으로 Data Pump 작업 이름을 입력할 수 있습니다.

  13. Next를 누릅니다.

  14. 다음 중 하나를 선택합니다.

  15. Execute Now

  16. Schedule to run later

  17. Just build the parameter file

  18. Finish를 누릅니다.

관련 항목

Data Pump 개요

Data Pump Import 마법사

Data Pump Export 마법사

테이블 가져오기

사용자 가져오기

테이블 공간 가져오기

전송 가능한 테이블 공간 가져오기

기존 매개 변수 파일을 사용하여 가져오기


테이블 가져오기

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Data Pump Import 마법사를 사용하여 테이블을 가져올 수 있습니다. 덤프 파일에서 모든 테이블을 가져오는 중이면 "전체 가져오기"를 수행하고 단지 14단계에서 Tables - Include를 지정할 수 있습니다.

Import tables 모드를 사용하면 가져올 테이블을 지정할 수 있습니다.

주: 다음 절차에 있는 대부분의 매개 변수는 Oracle에서 정의합니다. 이러한 매개 변수에 대한 자세한 내용은 Oracle 설명서를 참조하십시오.

테이블을 가져오려면

  1. Database 메뉴에서 Import|Data Pump Import Wizard를 선택합니다.

  2. Import를 선택하고 드롭다운 메뉴에서 Tables를 선택합니다.

  3. Next를 누릅니다.

  4. 포함할 테이블의 이름을 입력합니다. 테이블 이름 입력을 참조하십시오.

  5. Next를 누릅니다.

  6. 데이터를 필터링하는 데 사용할 질의를 입력합니다. 질의에 대한 자세한 내용은 질의를 사용하여 데이터 필터링을 참조하십시오.

  7. Next를 누릅니다.

  8. 다른 영역으로 가져와야 하는 스키마, 테이블 공간 또는 데이터 파일을 다시 매핑합니다. 자세한 내용은 스키마, 테이블 공간 및 데이터 파일 다시 매핑을 참조하십시오.

  9. Next를 누릅니다.

  10. Content 매개 변수를 입력합니다.

  11. All

  12. Data Only

  13. Metadata Only

  11. 테이블이 이미 있을 경우 사용할 작업을 선택합니다(TABLE_EXISTS_ACTION 매개 변수에 해당).

  12. Skip

  13. Append

  14. Truncate

  15. Replace

  12. ESTIMATE 매개 변수의 값을 선택합니다.

  13. Blocks

  14. Statistics

  13. Reuse Datafiles 매개 변수를 선택하거나 선택 취소합니다.

  14. 상태 보고서 사이의 시간(초)을 입력합니다. 상태 보고서는 Data Pump Watch 창에 표시됩니다. 각 개체 형식이 완료되었을 때만 업데이트하려면 0을 입력합니다.

  15. Next를 누릅니다.

  16. 포함하거나 제외할 개체 형식을 선택합니다. 자세한 내용은 메타 필터 그리드 사용을 참조하십시오.

  17. Next를 누릅니다.

  18. 디렉토리를 선택하고 입력 파일 이름, 로그 파일 이름 및 SQL 파일 이름을 입력합니다.

입력 파일 이름은 선택한 디렉토리에 있어야 합니다. 로그 파일은 선택한 디렉토리에서 만들어집니다. SQL 파일 이름이 제공된 경우 가져오기가 수행되지 않습니다. 가져오기를 수행하는 데 필요한 DDL이 생성되어 지정된 이름의 파일에 저장되며 디렉토리 선택에 지정된 디렉토리에서 파일이 만들어집니다.

주: 가져오기/내보내기 디렉토리 설정에 설명된 대로 디렉토리가 만들어져야 합니다.

  19. Toad에서 매개 변수 파일 이름을 자동으로 만들지만 사용자가 이름을 변경할 수 있습니다.

  20. 선택적으로 Data Pump 작업 이름을 입력할 수 있습니다.

  21. Next를 누릅니다.

  22. 다음 중 하나를 선택합니다.

  23. Execute Now

  24. Schedule to run later

  25. Just build the parameter file

  23. Finish를 누릅니다.

관련 항목

Data Pump 개요

Data Pump Import 마법사

Data Pump Export 마법사

전체 가져오기 수행

사용자 가져오기

테이블 공간 가져오기

전송 가능한 테이블 공간 가져오기

기존 매개 변수 파일에서 가져오기


사용자 가져오기

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Data Pump Import 마법사를 사용하여 사용자를 가져올 수 있습니다. 덤프 파일에서 모든 사용자를 가져오는 중이면 "전체 가져오기"를 수행하고 단지 14단계에서 Users - Include를 지정할 수 있습니다.

Import Users 모드를 사용하면 가져올 사용자를 지정할 수 있습니다.

주: 다음 절차에 있는 대부분의 매개 변수는 Oracle에서 정의합니다. 이러한 매개 변수에 대한 자세한 내용은 Oracle 설명서를 참조하십시오.

사용자를 가져오려면

  1. Database 메뉴에서 Import|Data Pump Import Wizard를 선택합니다.

  2. Import를 선택하고 드롭다운 메뉴에서 Users를 선택합니다.

  3. Next를 누릅니다.

  4. 가져올 사용자를 선택합니다. (현재 데이터베이스에 없는 사용자는 사용자 이름을 입력하고 <Enter> 키를 눌러 수동으로 입력할 수 있습니다.)

  5. Next를 누릅니다.

  6. 사용할 질의를 입력하여 데이터를 필터링합니다. 질의에 대한 자세한 내용은 질의를 사용하여 데이터 필터링을 참조하십시오.

  7. Next를 누릅니다.

  8. 다른 영역으로 가져와야 하는 스키마, 테이블 공간 또는 데이터 파일을 다시 매핑합니다. 자세한 내용은 스키마, 테이블 공간 및 데이터 파일 다시 매핑을 참조하십시오.

  9. Next를 누릅니다.

  10. Content 매개 변수를 입력합니다.

  11. All

  12. Data Only

  13. Metadata Only

  11. 테이블이 이미 있을 경우 사용할 작업을 선택합니다(TABLE_EXISTS_ACTION 매개 변수에 해당).

  12. Skip

  13. Append

  14. Truncate

  15. Replace

  12. ESTIMATE 매개 변수의 값을 선택합니다.

  13. Blocks

  14. Statistics

  13. Reuse Datafiles 매개 변수를 선택하거나 선택 취소합니다.

  14. 상태 보고서 사이의 시간(초)을 입력합니다. 상태 보고서는 Data Pump Watch 창에 표시됩니다. 각 개체 형식이 완료되었을 때만 업데이트하려면 0을 입력합니다.

  15. Next를 누릅니다.

  16. 포함하거나 제외할 개체 형식을 선택합니다. 자세한 내용은 메타 필터 그리드 사용을 참조하십시오.

  17. Next를 누릅니다.

  18. 디렉토리를 선택하고 입력 파일 이름, 로그 파일 이름 및 SQL 파일 이름을 입력합니다.

입력 파일 이름은 선택한 디렉토리에 있어야 합니다. 로그 파일은 선택한 디렉토리에서 만들어집니다. SQL 파일 이름이 제공된 경우 가져오기가 수행되지 않습니다. 가져오기를 수행하는 데 필요한 DDL이 생성되어 지정된 이름의 파일에 저장되며 디렉토리 선택에 지정된 디렉토리에서 파일이 만들어집니다.

주: 가져오기/내보내기 디렉토리 설정에 설명된 대로 디렉토리가 만들어져야 합니다.

  19. Toad에서 매개 변수 파일 이름을 자동으로 만들지만 사용자가 이름을 변경할 수 있습니다.

  20. 선택적으로 Data Pump 작업 이름을 입력할 수 있습니다.

  21. Next를 누릅니다.

  22. 다음 중 하나를 선택합니다.

  23. Execute Now

  24. Schedule to run later

  25. Just build the parameter file

  23. Finish를 누릅니다.

관련 항목

Data Pump 개요

Data Pump Import 마법사

Data Pump Export 마법사

전체 가져오기 수행

테이블 가져오기

테이블 공간 가져오기

전송 가능한 테이블 공간 가져오기

기존 매개 변수 파일에서 가져오기


테이블 공간 가져오기

Data Pump Import 마법사를 사용하여 테이블 공간을 가져올 수 있습니다. 덤프 파일에서 모든 테이블 공간을 가져오는 중이면 "전체 가져오기"를 수행하고 단지 14단계에서 Tablespaces - Include를 지정할 수 있습니다.

Import Tablespaces 모드를 사용하면 가져올 테이블 공간을 지정할 수 있습니다.

주: 다음 절차에 있는 대부분의 매개 변수는 Oracle에서 정의합니다. 이러한 매개 변수에 대한 자세한 내용은 Oracle 설명서를 참조하십시오.

테이블 공간을 가져오려면

  1. Database 메뉴에서 Import|Data Pump Import Wizard를 선택합니다.

  2. Import를 선택하고 드롭다운 메뉴에서 Tablespaces를 선택합니다.

  3. Next를 누릅니다.

  4. 가져올 Tablespaces를 선택합니다.

  5. Next를 누릅니다.

  6. 사용할 질의를 입력하여 데이터를 필터링합니다. 질의에 대한 자세한 내용은 질의를 사용하여 데이터 필터링을 참조하십시오.

  7. Next를 누릅니다.

  8. 다른 영역으로 가져와야 하는 스키마, 테이블 공간 또는 데이터 파일을 다시 매핑합니다. 자세한 내용은 스키마, 테이블 공간 및 데이터 파일 다시 매핑을 참조하십시오.

  9. Next를 누릅니다.

  10. Content 매개 변수를 입력합니다.

  11. All

  12. Data Only

  13. Metadata Only

  11. 테이블이 이미 있을 경우 사용할 작업을 선택합니다(TABLE_EXISTS_ACTION 매개 변수에 해당).

  12. Skip

  13. Append

  14. Truncate

  15. Replace

  12. ESTIMATE 매개 변수의 값을 선택합니다.

  13. Blocks

  14. Statistics

  13. Reuse Datafiles 매개 변수를 선택하거나 선택 취소합니다.

  14. 상태 보고서 사이의 시간(초)을 입력합니다. 상태 보고서는 Data Pump Watch 창에 표시됩니다. 각 개체 형식이 완료되었을 때만 업데이트하려면 0을 입력합니다.

  15. Next를 누릅니다.

  16. 포함하거나 제외할 개체 형식을 선택합니다. 자세한 내용은 메타 필터 그리드 사용을 참조하십시오.

  17. Next를 누릅니다.

  18. 디렉토리를 선택하고 입력 파일 이름, 로그 파일 이름 및 SQL 파일 이름을 입력합니다.

입력 파일 이름은 선택한 디렉토리에 있어야 합니다. 로그 파일은 선택한 디렉토리에서 만들어집니다. SQL 파일 이름이 제공된 경우 가져오기가 수행되지 않습니다. 가져오기를 수행하는 데 필요한 DDL이 생성되어 지정된 이름의 파일에 저장되며 디렉토리 선택에 지정된 디렉토리에서 파일이 만들어집니다.

주: 가져오기/내보내기 디렉토리 설정에 설명된 대로 디렉토리가 만들어져야 합니다.

  19. Toad에서 매개 변수 파일 이름을 자동으로 만들지만 사용자가 이름을 변경할 수 있습니다.

  20. 선택적으로 Data Pump 작업 이름을 입력할 수 있습니다.

  21. Next를 누릅니다.

  22. 다음 중 하나를 선택합니다.

  23. Execute Now

  24. Schedule to run later

  25. Just build the parameter file

  23. Finish를 누릅니다.

관련 항목

Data Pump 개요

Data Pump Import 마법사

Data Pump Export 마법사

전체 가져오기 수행

테이블 가져오기

사용자 가져오기

전송 가능한 테이블 공간 가져오기

기존 매개 변수 파일에서 가져오기


전송 가능한 테이블 공간 가져오기

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

전송 가능한 테이블 공간을 사용하면 Oracle 데이터베이스의 하위 집합을 한 Oracle 데이터베이스에서 다른 Oracle 데이터베이스로 신속하게 이동할 수 있습니다.

Data Pump Import 마법사를 통해 전송 가능한 테이블 공간을 만들 수 있습니다.

전송 가능한 테이블 공간을 가져오려면

  1. Database 메뉴에서 Import|Data Pump Import Wizard를 선택합니다.

  2. Import a transportable tablespace를 선택합니다.

  3. Next를 누릅니다.

  4. 각 데이터 파일에 대한 정규화된 디렉토리 경로와 파일 이름을 입력합니다.

주: Oracle DIRECTORY 개체는 이 단계에 사용할 수 없습니다.

  5. 가져오기 도중에 지정된 테이블 공간 집합에 종속성이 없는지 확인하려면 Check for dependencies 확인란을 선택합니다.

  6. Next를 누릅니다.

  7. 사용할 질의를 입력하여 데이터를 필터링합니다. 질의에 대한 자세한 내용은 질의를 사용하여 데이터 필터링을 참조하십시오.

  8. Next를 누릅니다.

  9. 다른 영역으로 가져와야 하는 스키마, 테이블 공간 또는 데이터 파일을 다시 매핑합니다. 자세한 내용은 스키마, 테이블 공간 및 데이터 파일 다시 매핑을 참조하십시오.

  10. Next를 누릅니다.

  11. 디렉토리를 선택하고 입력 파일 이름, 로그 파일 이름 및 SQL 파일 이름을 입력합니다.

입력 파일 이름은 선택한 디렉토리에 있어야 합니다. 로그 파일은 선택한 디렉토리에서 만들어집니다. SQL 파일 이름이 제공된 경우 가져오기가 수행되지 않습니다. 가져오기를 수행하는 데 필요한 DDL이 생성되어 지정된 이름의 파일에 저장되며 디렉토리 선택에 지정된 디렉토리에서 파일이 만들어집니다.

주: 가져오기/내보내기 디렉토리 설정에 설명된 대로 디렉토리가 만들어져야 합니다.

  12. Toad에서 매개 변수 파일 이름을 자동으로 만들지만 사용자가 이름을 변경할 수 있습니다.

  13. 선택적으로 Data Pump 작업 이름을 입력할 수 있습니다.

  14. Next를 누릅니다.

  15. 다음 중 하나를 선택합니다.

  16. Execute Now

  17. Schedule to run later

  18. Just build the parameter file

  16. Finish를 누릅니다.

관련 항목

Data Pump 개요

Data Pump Import 마법사

Data Pump Export 마법사

전체 가져오기 수행

테이블 가져오기

사용자 가져오기

테이블 공간 가져오기

기존 매개 변수 파일에서 가져오기


기존 매개 변수 파일에서 가져오기

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

이전 가져오기에서 만든 모든 기존 매개 변수 파일을 로드할 수 있습니다. 이렇게 하면 가져오기를 미리 준비하고 매개 변수 파일을 나중에 로드하여 데이터를 가져올 수 있습니다.

기존 매개 변수 파일을 로드하려면

  1. Database 메뉴에서 Import|Data Pump Import Wizard를 선택합니다.

  2. Load Existing Parameter File을 선택합니다.

  3. Next를 누릅니다.

  4. 사용할 매개 변수 파일의 경로와 이름을 입력합니다.

또는

드릴다운 [image] 단추를 눌러 매개 변수 파일을 선택합니다.

  5. Next를 누릅니다.

  6. 다음 중 하나를 선택합니다.

  7. Execute Now

  8. Schedule to run later

  7. Finish를 누릅니다.

관련 항목

Data Pump 개요

Data Pump Import 마법사

Data Pump Export 마법사

전체 가져오기 수행

테이블 가져오기

사용자 가져오기

테이블 공간 가져오기

전송 가능한 테이블 공간 가져오기


Data Pump Export 마법사

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Data Pump Export 마법사를 사용하면 Oracle의 Data Pump를 사용하여 데이터베이스에서 대량의 데이터를 쉽게 내보낼 수 있습니다.

Data Pump에는 다음과 같은 다섯 가지 내보내기 모드가 있습니다.

  • Full Export

  • Schema

  • Table

  • Tablespaces

  • Transportable Tablespaces

Data Pump Export 마법사를 열려면

  • Database 메뉴에서 Export를 선택한 후 Data Pump Export Wizard를 선택합니다.

관련 항목

Data Pump 개요

테이블 내보내기

사용자 내보내기

데이터베이스 내보내기

테이블 공간 내보내기

전송 가능한 데이터베이스 생성

기존 매개 변수 파일 로드


테이블 내보내기

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Data Pump Export 마법사에서 테이블을 쉽게 내보낼 수 있습니다.

주: 다음 절차에 있는 대부분의 매개 변수는 Oracle에서 정의합니다. 이러한 매개 변수에 대한 자세한 내용은 Oracle 설명서를 참조하십시오.

테이블을 내보내려면

  1. Database 메뉴에서 Export|Data Pump Export Wizard를 선택합니다.

  2. Export를 선택하고 드롭다운 메뉴에서 Tables를 선택합니다.

  3. Next를 누릅니다.

  4. Schema 드롭다운에서 Schema를 선택하고 내보낼 해당 스키마 내의 테이블을 선택합니다. Selections 탭을 눌러 선택한 테이블을 볼 수 있습니다.

  5. Next를 누릅니다.

  6. 내보내는 데이터를 제한하는 데 사용할 질의를 입력합니다. 질의에 대한 자세한 내용은 질의를 사용하여 데이터 필터링을 참조하십시오.

  7. Next를 누릅니다.

  8. 내보낼 콘텐츠를 선택합니다.

  9. All

  10. Data

  11. Metadata

  9. 내보내기 파일에 대한 추가 매개 변수를 지정합니다.

  10. Estimate space

  11. Estimate in blocks or statistics

  12. Provide status every n minutes

  10. Next를 누릅니다.

  11. 보고서에서 포함하거나 제외할 개체 형식을 선택합니다. 자세한 내용은 메타 필터 그리드 사용을 참조하십시오.

  12. Next를 누릅니다.

  13. 디렉토리를 선택하고 출력 파일 이름과 로그 파일 이름을 입력합니다.

주: 가져오기/내보내기 디렉토리 설정에 설명된 대로 디렉토리가 만들어져야 합니다.

  14. Toad에서 매개 변수 파일 이름을 자동으로 만들지만 사용자가 이름을 변경할 수 있습니다.

  15. 선택적으로 Data Pump 작업 이름과 최대 파일 크기를 입력할 수 있습니다.

  16. Next를 누릅니다.

  17. 다음 중 하나를 선택합니다.

  18. Execute Now

  19. Schedule to run later

  20. Just build the parameter file

  18. Finish를 누릅니다.

관련 항목

Data Pump 개요

Data Pump Export 마법사

사용자 내보내기

데이터베이스 내보내기

테이블 공간 내보내기

전송 가능한 데이터베이스 생성

기존 매개 변수 파일 로드


사용자 내보내기

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Data Pump Export 마법사를 사용하여 사용자를 쉽게 내보낼 수 있습니다.

주: 다음 절차에 있는 대부분의 매개 변수는 Oracle에서 정의합니다. 이러한 매개 변수에 대한 자세한 내용은 Oracle 설명서를 참조하십시오.

사용자를 내보내려면

  1. Database 메뉴에서 Export|Data Pump Export Wizard를 선택합니다.

  2. Export를 선택하고 드롭다운 메뉴에서 Users를 선택합니다.

개체를 소유하는 사용자만 사용 가능한 사용자 패널에 표시하도록 선택할 수 있습니다.

  3. 사용 가능한 사용자 패널에서 사용자를 선택 또는 다중 선택하고 선택한 사용자 패널로 이동합니다.

  4. Next를 누릅니다.

  5. 내보내는 데이터를 제한하는 데 사용할 질의를 입력합니다. 질의에 대한 자세한 내용은 질의를 사용하여 데이터 필터링을 참조하십시오.

  6. Next를 누릅니다.

  7. 내보낼 콘텐츠를 선택합니다.

  8. All

  9. Data

  10. Metadata

  8. 내보내기 파일에 대한 추가 매개 변수를 지정합니다.

  9. Estimate space

  10. Estimate in blocks or statistics

  11. Provide status every n minutes

  9. Next를 누릅니다.

  10. 덤프 파일에서 포함하거나 제외할 개체 형식을 선택합니다. 자세한 내용은 메타 필터 그리드 사용을 참조하십시오.

  11. Next를 누릅니다.

  12. 디렉토리를 선택하고 출력 파일 이름과 로그 파일 이름을 입력합니다.

주: 가져오기/내보내기 디렉토리 설정에 설명된 대로 디렉토리가 만들어져야 합니다.

  13. Toad에서 매개 변수 파일 이름을 자동으로 만들지만 사용자가 이름을 변경할 수 있습니다.

  14. 선택적으로 Data Pump 작업 이름과 최대 파일 크기를 입력할 수 있습니다.

  15. Next를 누릅니다.

  16. 다음 중 하나를 선택합니다.

  17. Execute Now

  18. Schedule to run later

  19. Just build the parameter file

  17. Finish를 누릅니다.

관련 항목

Data Pump 개요

Data Pump Export 마법사

테이블 내보내기

데이터베이스 내보내기

테이블 공간 내보내기

전송 가능한 데이터베이스 생성

기존 매개 변수 파일 로드


데이터베이스 내보내기

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Data Pump Export 마법사를 사용하여 전체 데이터베이스를 쉽게 내보낼 수 있습니다.

주: 다음 절차에 있는 대부분의 매개 변수는 Oracle에서 정의합니다. 이러한 매개 변수에 대한 자세한 내용은 Oracle 설명서를 참조하십시오.

현재 데이터베이스를 내보내려면

  1. Database 메뉴에서 Export|Data Pump Export Wizard를 선택합니다.

  2. Export를 선택하고 드롭다운 메뉴에서 Database를 선택합니다.

  3. 내보내는 데이터를 제한하는 데 사용할 질의를 입력합니다. 질의에 대한 자세한 내용은 질의를 사용하여 데이터 필터링을 참조하십시오.

  4. Next를 누릅니다.

  5. 내보낼 콘텐츠를 선택합니다.

  • All

  • Data

  • Metadata

  8. 내보내기 파일에 대한 추가 매개 변수를 지정합니다.

  9. Estimate space

  10. Estimate in blocks or statistics

  11. Provide status every n minutes

  9. Next를 누릅니다.

  10. 덤프 파일에서 포함하거나 제외할 개체 형식을 선택합니다. 자세한 내용은 메타 필터 그리드 사용을 참조하십시오.

  11. Next를 누릅니다.

  12. 디렉토리를 선택하고 출력 파일 이름과 로그 파일 이름을 입력합니다.

주: 가져오기/내보내기 디렉토리 설정에 설명된 대로 디렉토리가 만들어져야 합니다.

  13. Toad에서 매개 변수 파일 이름을 자동으로 만들지만 사용자가 이름을 변경할 수 있습니다.

  14. 선택적으로 Data Pump 작업 이름과 최대 파일 크기를 입력할 수 있습니다.

  15. Next를 누릅니다.

  16. 다음 중 하나를 선택합니다.

  17. Execute Now

  18. Schedule to run later

  19. Just build the parameter file

  17. Finish를 누릅니다.

관련 항목

Data Pump 개요

Data Pump Export 마법사

테이블 내보내기

사용자 내보내기

테이블 공간 내보내기

전송 가능한 데이터베이스 생성

기존 매개 변수 파일 로드


테이블 공간 내보내기

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Data Pump Export 마법사를 사용하여 테이블 공간을 쉽게 내보낼 수 있습니다.

주: 다음 절차에 있는 대부분의 매개 변수는 Oracle에서 정의합니다. 이러한 매개 변수에 대한 자세한 내용은 Oracle 설명서를 참조하십시오.

테이블 공간을 내보내려면

  1. Database 메뉴에서 Export|Data Pump Export Wizard를 선택합니다.

  2. Export를 선택하고 드롭다운 메뉴에서 Tablespaces를 선택합니다.

개체를 소유하는 사용자만 사용 가능한 사용자 패널에 표시하도록 선택할 수 있습니다.

  3. 사용 가능한 테이블 공간 패널에서 테이블 공간을 선택 또는 다중 선택하고 선택한 테이블 공간 패널로 이동합니다.

  4. Next를 누릅니다.

  5. 내보내는 데이터를 제한하는 데 사용할 질의를 입력합니다. 질의에 대한 자세한 내용은 질의를 사용하여 데이터 필터링을 참조하십시오.

  6. Next를 누릅니다.

  7. 내보낼 콘텐츠를 선택합니다.

  8. All

  9. Data

  10. Metadata

  8. 내보내기 파일에 대한 추가 매개 변수를 지정합니다.

  9. Estimate space

  10. Estimate in blocks or statistics

  11. Provide status every n minutes

  9. Next를 누릅니다.

  10. 덤프 파일에서 포함하거나 제외할 개체 형식을 선택합니다. 자세한 내용은 메타 필터 그리드 사용을 참조하십시오.

  11. Next를 누릅니다.

  12. 디렉토리를 선택하고 출력 파일 이름과 로그 파일 이름을 입력합니다.

주: 가져오기/내보내기 디렉토리 설정에 설명된 대로 디렉토리가 만들어져야 합니다.

  13. Toad에서 매개 변수 파일 이름을 자동으로 만들지만 사용자가 이름을 변경할 수 있습니다.

  14. 선택적으로 Data Pump 작업 이름과 최대 파일 크기를 입력할 수 있습니다.

  15. Next를 누릅니다.

  16. 다음 중 하나를 선택합니다.

  17. Execute Now

  18. Schedule to run later

  19. Just build the parameter file

  17. Finish를 누릅니다.

관련 항목

Data Pump 개요

Data Pump Export 마법사

테이블 내보내기

사용자 내보내기

데이터베이스 내보내기

전송 가능한 데이터베이스 생성

기존 매개 변수 파일 로드


전송 가능한 데이터베이스 생성

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

전송 가능한 테이블 공간을 사용하면 Oracle 데이터베이스의 하위 집합을 한 Oracle 데이터베이스에서 다른 Oracle 데이터베이스로 신속하게 이동할 수 있습니다.

Data Pump Export 마법사를 통해 전송 가능한 테이블 공간을 생성할 수 있습니다.

주: 다음 절차에 있는 대부분의 매개 변수는 Oracle에서 정의합니다. 이러한 매개 변수에 대한 자세한 내용은 Oracle 설명서를 참조하십시오.

전송 가능한 데이터베이스를 생성하려면

  1. Database 메뉴에서 Export|Data Pump Export Wizard를 선택합니다.

  2. Generate Transportable Database를 선택합니다.

  3. Next를 누릅니다.

  4. 내보내는 데이터를 제한하는 데 사용할 질의를 입력합니다. 질의에 대한 자세한 내용은 질의를 사용하여 데이터 필터링을 참조하십시오.

  5. Next를 누릅니다.

  6. 전송 가능한 집합에 포함할 테이블 공간을 선택합니다. 전송 가능한 집합 내부 및 외부에 있는 개체 간의 종속성을 확인할 수도 있습니다.

  7. 디렉토리를 선택하고 출력 파일 이름과 로그 파일 이름을 입력합니다.

주: 가져오기/내보내기 디렉토리 설정에 설명된 대로 디렉토리가 만들어져야 합니다.

  5. Toad에서 매개 변수 파일 이름을 자동으로 만들지만 사용자가 이름을 변경할 수 있습니다.

  6. 선택적으로 Data Pump 작업 이름과 최대 파일 크기를 입력할 수 있습니다.

  7. Next를 누릅니다.

  8. 다음 중 하나를 선택합니다.

  9. Execute Now

  10. Schedule to run later

  11. Just build the parameter file

  9. Finish를 누릅니다.

관련 항목

Data Pump 개요

Data Pump Export 마법사

테이블 내보내기

사용자 내보내기

데이터베이스 내보내기

테이블 공간 내보내기

기존 매개 변수 파일 로드


기존 매개 변수 파일에서 내보내기

기존 매개 변수 파일 로드

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

이전 내보내기에서 만든 모든 기존 매개 변수 파일을 로드할 수 있습니다. 이렇게 하면 내보내기를 미리 준비하고 매개 변수 파일을 나중에 로드하여 데이터를 내보낼 수 있습니다.

기존 매개 변수 파일을 로드하려면

  1. Database 메뉴에서 Export|Data Pump Export Wizard를 선택합니다.

  2. Load Existing Parameter File을 선택합니다.

  3. Next를 누릅니다.

  4. 사용할 매개 변수 파일의 경로를 입력합니다.

또는

드릴다운 [image] 단추를 눌러 매개 변수 파일을 선택합니다.

  5. Next를 누릅니다.

  6. 다음 중 하나를 선택합니다.

  7. Execute Now

  8. Schedule to run later

  7. Finish를 누릅니다.

관련 항목

Data Pump 개요

Data Pump Export 마법사

테이블 내보내기

사용자 내보내기

데이터베이스 내보내기

테이블 공간 내보내기

전송 가능한 데이터베이스 생성


Toad Editor

Toad Editor를 사용하면 다양한 유형의 문과 코드를 편집할 수 있습니다. 동일한 탭에서 SQL 및 PL/SQL을 코딩할 수 있으며 Toad는 editor에서 각 코드 부분을인식할 수 있습니다.

Toad의 활성 연결에 editor가 연결되지만 연결이 없는 경우에도 editor를 텍스트 편집기로 사용할 수 있습니다. 또한 Editor 도구 모음에서 활성 세션을 변경할 수 있습니다.

editor는 세 개의 영역인 navigator 패널, editor 영역 및 editor 아래의 영역으로 구성됩니다. editor 아래의 영역에는 결과, DBMS output, 중단점, 조사식 및 코드를 더 잘 이해하고 사용하는 데 필요한 기타 정보가 표시됩니다. 이러한 바탕 화면 영역을 정렬 및 구성할 수 있습니다.

Navigator 패널

Navigator 패널에는 활성 탭에 있는 editor 콘텐츠가 간략하게 표시됩니다. 나열된 항목을 눌러 editor의 해당 문으로 이동할 수 있습니다.

Editor

주 editor 창에는 별개의 탭에 코드가 표시됩니다. 다른 코드 부분 또는 다른 코드 유형에 대한 탭을 작성할 수 있습니다. SQL 및 PL/SQL은 동일한 탭에 포함될 수 있습니다. Toad에서는 커서의 위치를 확인하고 필요에 따라 PL/SQL을 컴파일하거나 SQL을 실행할 수 있습니다.

주: editor에 여러 문이 있는 경우 세미콜론과 같은 유효한 문 종료자가 이러한 문 뒤에 와야 합니다.

또한 탭을 열어 Java 및 16진수 코드를 편집하고 디버깅할 수 있습니다.

아래쪽 패널

아래쪽 패널에는 현재 작업하고 있는 코드 종류와 코드를 사용하여 수행할 작업에 따라 탭 표시를 위한 여러 옵션이 포함되어 있습니다. 몇 가지 옵션은 다음과 같습니다.

  • SQL Results

  • DBMS Output

  • Breakpoints

  • Watches

  • Code Xpert

  • Script Debug

  • Query Viewer

  • And more!

주: 이러한 옵션 중 일부는 특정 Toad 버전에서만 사용할 수 있습니다.

아래쪽 패널에서 탭을 표시하고 숨기려면

  • 탭 행을 마우스 오른쪽 단추로 누르고 Desktop을 선택합니다. 표시하거나 숨기려는 탭을 선택 또는 선택 취소합니다.

관련 항목

Editor 도구 모음


자동 백업

Toad를 통해 임시 파일 이름을 사용하여 편집기 파일의 백업을 자동으로 작성할 수 있습니다. Toad가 비정상적으로 닫히면 다음에 Toad를 열 때 백업 복구 또는 폐기를 묻는 프롬프트가 나타납니다. 자동 백업이 매 3분의 백업 간격으로 자동으로 활성화됩니다. Toad Options|Editor|Behavior 페이지에서 이 내용을 변경할 수 있습니다.

자동 백업을 사용하여 문서를 수동으로 복구할 수도 있습니다.

메뉴에서 문서를 복구하려면

  • File 메뉴에서 Recover Documents를 선택합니다.

관련 항목

Options - Editor Behavior


바탕 화면 구성

Editor 바탕 화면에 표시되는 패널과 이러한 패널이 표시되는 위치를 쉽게 구성할 수 있습니다.

패널을 선택하여 한 번에 하나씩 표시하거나 그룹으로 표시할 수 있습니다. 바탕 화면을 구성한 후에는 고유한 이름으로 저장하여 필요할 때마다 사용할 수 있습니다. 또한 Auto-save current desktop을 설정할 수 있지만 탭을 변경하거나 Toad를 닫을 때 바탕 화면을 설정하면 다음에 editor를 열 때 정의된 바탕 화면이 적용됩니다.

패널을 한 번에 하나씩 표시하려면

  1. 창 맨 아래 근처의 패널 영역을 마우스 오른쪽 단추로 누릅니다.

  2. Desktop을 선택한 다음 표시하거나 숨기려는 패널을 선택합니다.

바탕 화면을 한 번에 구성하려면

  1. 창 맨 아래 근처의 패널 영역을 마우스 오른쪽 단추로 누릅니다.

  2. Desktop을 선택한 다음 Configure Desktop을 선택합니다.

  3. Desktop Panels 대화 상자에서 Show 열에 표시할 패널을 선택하고 Dock Site 열에서 드롭다운 메뉴를 눌러 패널이 도킹되는 위치를 변경합니다.

  4. 원하는 모든 패널을 선택하거나 숨긴 후에 OK를 눌러 변경 내용을 저장합니다.

바탕 화면을 저장하려면

  1. Desktops 도구 모음에서 Save desktop [image] 단추를 누릅니다.

  2. 이 바탕 화면에 사용할 이름을 입력합니다.

  3. OK를 누릅니다. 이제 바탕 화면이 저장되고 이름이 지정되며 드롭다운 바탕 화면 메뉴에서 사용할 수 있습니다.

바탕 화면 복원

두 가지 방법 중 하나로 바탕 화면을 복원할 수 있습니다. 바탕 화면을 변경한 경우 처음 열었을 때의 시점으로 복원할 수 있습니다. 또는 기본값으로 복원할 수 있습니다.

마지막으로 저장한 바탕 화면을 복원하려면

  1. Save Desktops [image] 단추에서 드롭다운 화살표를 누릅니다.

  2. Revert to Last Saved Desktop을 선택합니다.

현재 바탕 화면을 기본값으로 복원하려면

  1. Save Desktops [image] 단추에서 드롭다운 화살표를 누릅니다.

  2. Restore Default Desktop을 선택합니다.

관련 항목

바탕 화면 도구 모음


XML Editor

XML Editor 개요

Toad의 Text Editor는 XML Editor로 작동하며 XML Navigator가 왼쪽에 있습니다. XML Navigator에서는 XML 요소가 트리 보기로 표시되고 선택한 요소의 특성과 하위 요소를 표시하기 위한 그리드가 있습니다. 오른쪽에는 XML의 텍스트가 표시되고 기본적으로 HTML을 위한 파서 스크립트가 사용됩니다(파서 스크립트 변경 참조).

XML Editor에 액세스하려면

  1. Text Editor [image] 단추를 눌러 Text Editor를 엽니다.

  2. Open File [image] 단추를 누르고 XML 파일을 선택합니다. 파일이 열리면 Editor는 XML을 편집하도록 구성됩니다.

XML 모드

Text Editor에는 XML 코드를 편집하는 데 사용할 수 있는 세 가지 모드가 있습니다.

  • Offline mode(Tools 메뉴에서 사용할 수 있음)

  • Data-bound mode for character data(CHAR, VARCHAR2 또는 CLOB 데이터에 대한 그리드에서 팝업)

  • Data-bound mode for XML data(XMLTYPE 데이터에 대한 그리드에서 팝업)

Offline mode

Offline mode에서 Text Editor는 다음 경우에 항상 XML Editor로 작동합니다.

  • 로드된 파일이 <?xml version= 문자열로 시작합니다.

  • 로드된 파일의 확장명이 .xml입니다.

Data-bound mode for character data

Data-bound mode for character data에서 Text Editor는 셀에서 처음 로드된 데이터가 <?xml version= 텍스트로 시작할 때마다 XML 편집기로 작동합니다.

Data-bound mode for XMLTYPE data

Data-bound mode for XMLTYPE data에서 Text Editor는 항상 XML Editor로 작동합니다.

관련 항목

Offline Editor

Text Editor


Editor 문제 해결

Editor는 쉽게 구성할 수 있는 창입니다. 필요한 항목을 볼 수 없도록 구성된 경우 간단하게 문제를 해결할 수 있습니다.

누락된 패널

패널을 볼 수 없는 경우 바탕 화면에서 제거되었거나 부주의하게 숨겨졌기 때문일 수 있습니다.

누락된 패널을 복원하려면

  1. Editor 창을 마우스 오른쪽 단추로 누르고 Desktop을 선택합니다.

  2. 찾고 있는 패널에 확인 표시가 되어 있는지 확인합니다. 확인 표시가 없을 경우 지금 선택합니다.

숨겨진 패널

위에 설명된 대로 확인 표시가 있는 패널이 표시되어야 하지만 여전히 숨겨진 경우가 있습니다. 일반적으로 패널이 숨겨지는 것은 볼 수 있는 범위를 벗어나 스크롤되었기 때문입니다.

숨겨진 패널을 보려면

  • 패널이 표시되어야 하는 영역에서 활성 스크롤 [image] 단추를 누릅니다.

누락된 도구 모음 단추

Toad의 도구 모음을 구성할 수 있습니다. 편집을 위한 충분한 공간을 확보하기 위해 Editor에서 최소한의 기본 도구 모음만 표시됩니다. 포함된 일부 단추가 정기적으로 사용하는 단추가 아니거나 사용하는 일부 단추를 도구 모음에 포함하고 싶을 수 있습니다. 작업 방식에 맞도록 도구 모음을 쉽게 조정할 수 있습니다. 자세한 내용은 구성 가능한 도구 모음을 참조하십시오.

누락된 도구 모음

도구 모음 영역에서 모든 도구 모음이 삭제될 수 있습니다. 이 경우 도구 모음을 복원할 수 있습니다.

누락된 도구 모음을 복원하려면

  • Editor를 마우스 오른쪽 단추로 누른 다음 Customize toolbars를 선택합니다. 표시할 하나 이상의 도구 모음을 선택합니다.


Editor 구성

주 editor 창에서 Toad editor를 사용하여 SQL 텍스트를 편집할 수 있습니다. Toad에서는 여러 다른 창에서 동일한 editor가 읽기 전용 모드로 사용됩니다. 이 editor는 다음 기능을 제공합니다.

  • 사용자 구성 가능 구문 색 강조표시

  • 책갈피

  • 일반 편집 명령을 위한 사용자 정의 키 입력

  • Auto Replace 대체 항목 (입력한 대로 바꾸기)

  • 코드 완성 템플릿

  • 실행 취소/다시 실행

  • 코드 블록 주석 처리

  • 닫는 괄호 찾기

  • 찾기, 다음 찾기 및 바꾸기

  • 검색 후 모두 표시

  • 구성 가능한 인쇄 옵션

  • 자동 줄 바꿈, 자동 들여쓰기 및 다른 모든 일반 editor 기능

Editor 옵션 변경

Toad Options|Editor 노드에서 Editor 옵션을 변경할 수 있습니다.

관련 항목

Editor - Behavior

Editor - Code Assist

Editor - Display

Editor - Open/Save

Editor - Printing


파일 열기

디스크에서 파일을 열 경우 여러 작업 중 하나를 수행할 수 있습니다.

  • 파일에 사용되는 형식을 Toad에서 결정하게 할 수 있습니다. 이는 기본 동작이며 대부분의 응용 프로그램은 이 방법으로 작동합니다.

  • 형식을 지정하여 Toad에서 해당 형식을 파일에 사용하도록 강제할 수 있습니다.

  • 즐겨찾기 목록에 파일을 추가할 수 있습니다.

형식 강제

가장 분명한 형식이 아닌 다른 형식을 사용하도록 Toad에 강제할 수 있습니다. 예를 들어 프로시저로 잘못 분류된 파일이 있고 이 파일이 16진수 파일이라는 것을 알게 된 경우 해당 파일을 16진수 파일로 열도록 Toad에 강제할 수 있습니다. 기본 형식은 Auto입니다.

형식을 강제하려면

  1. 열려는 파일을 선택합니다.

  2. file format 상자에서 사용할 형식(예: Hex)을 선택합니다.

즐겨찾기에 파일 추가

즐겨찾기 목록에 파일을 추가할 수도 있습니다. 데이터베이스에서 로드하는 대신에 디스크에서 정기적으로 로드해야 하는 파일의 경우에 이 방법이 유용합니다.

즐겨찾기에 파일을 추가하려면

  1. Open 창에서 즐겨찾기에 추가할 파일을 선택합니다.

  2. Add Favorite 단추를 누릅니다.

이제 해당 즐겨찾기에 대한 경로가 Favorites 드롭다운에 나열됩니다.

주: 즐겨찾기를 선택해도 파일 형식이 변경되지는 않습니다. 강제로 hex를 사용하도록 설정한 경우 즐겨찾기는 16진수 파일로 열립니다.


Editor 탭 닫기

Editor 탭을 원하는 만큼 열어둘 수 있습니다. Toad에서는 탭 수와 입력할 수 있는 스크립트 크기가 시스템 메모리에 의해서만 제한됩니다.

Editor 화면 중 하나를 쉽게 닫을 수 있습니다.

Editor 탭을 닫으려면

  • 닫을 탭을 마우스 오른쪽 단추로 누르고 Close 탭을 선택합니다.

관련 항목

Editor

Editor 도구 모음

스크립트 만들기

스크립트 열기


Debugger 개요

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Toad의 선택 사항인 Debugger 모듈에서는 PL/SQL 프로시저, 함수 및 트리거를 쉽게 디버깅할 수 있는 기능을 제공합니다. 또한, 스크립트 디버깅을 사용하여 SQL 스크립트를 디버깅하고 Java 디버깅을 사용하여 Java를 디버깅할 수 있습니다.

디버그 유형 선택

Toad에서 디버깅을 수행하려면 Toad 인스턴스 당 열린 모든 데이터베이스 인스턴스에 대해 한 번에 한 디버깅 유형을 선택해야 합니다. 예를 들어 Toad 인스턴스 하나에 세 개의 데이터베이스 연결이 있다면 모두 같은 디버깅 상태(PL/SQL, 스크립트 또는 Java)에 있어야 합니다. 그 후에 같은 연결이나 다른 연결을 사용하여 Toad의 다른 인스턴스를 여는 경우에는 서로 다른 디버깅 상태에 있을 수도 있습니다.

디버그 유형을 선택하려면

  • Debug 메뉴에서 다음 중 하나를 선택합니다.

  • DBMS Debugger

  • JDWP Debugger

  • Script Debugger

디버그 정보를 사용하여 컴파일 토글

디버거를 PL/SQL 또는 Java 패키지와 함께 완전히 사용하려면 디버그 정보를 사용하여 개체를 컴파일해야 합니다. 디버그 정보를 사용하여 컴파일하지 않은 경우, 10g 이전 버전의 데이터베이스에서는 단위를 한 단계씩 실행하고, 프로시저 단위로 실행하는 등의 작업을 수행할 수 있지만, 개체가 디버그를 사용하여 컴파일되지 않았기 때문에 조사식을 볼 수는 없습니다. 10g 데이터베이스에서는 디버그를 사용하여 컴파일되지 않은 개체의 코드를 한 단계씩 실행하거나 프로시저 단위로 실행할 수 없습니다. 실행만 가능합니다.

디버그 정보를 사용하여 컴파일하려면

  • Session 메뉴에서 [image] Toggle Compiling with Debug Information을 선택합니다.

주: 이 옵션은 Editor를 열면 기본적으로 선택됩니다. 기본적으로 선택되지 않게 하려면 Toad Options|Editor|Debugging|Default to "Compile with Debug"에서 변경합니다.

디버그 정보를 사용하여 종속 관계 컴파일

종속 개체가 있는 개체를 디버깅하는 경우에는 디버그 정보를 사용하여 컴파일하지 않으면 종속 관계를 한 단계씩 실행할 수 없습니다. 자세한 내용은 종속 관계를 참조하십시오.

Toad의 디버거 사용에 대한 자습서는 디버깅 자습서 설명서(프로시저 또는 함수 디버깅 또는 패키지 디버깅)를 참조하십시오.

PL/SQL 디버깅

PL/SQL Debugger는 Editor 내에서 작동합니다. Debugger를 사용하면 중단점과 조사식을 설정하고, 호출 스택을 보고, 코드의 매개 변수를 설정할 수 있습니다. 또한, DBMS Output을 디버깅할 수 있습니다.

주: PL/SQL Debugger를 사용하며 RAC 인스턴스에 연결하는 경우에는 해당 인스턴스에 서버의 연결 사용 또는 현재 위치 세션을 지시하는 TNSNAMES 항목이 있어야 합니다. 또는 서버에서 인스턴스를 할당하게 하지 말고 직접 인스턴스에 연결해야 합니다.

Java 디버깅

JDWP Debugger는 PL/SQL Debugger와 같은 기본 사용자 인터페이스를 사용합니다. JDWP debugger는 DBMS_DEBUG 대신 Oracle 패키지 DBMS_DEBUG_JDWP를 사용하여 디버깅 기능에 액세스하기 때문에 전적으로 Oracle 지향적입니다. 즉, Toad를 통해 사용할 수 있는 디버깅 프로시저에 Oracle로 인한 한계가 적용됩니다.

스크립트 디버깅

SQL 스크립트도 디버깅할 수 있습니다. 일반 편집기 기능뿐만 아니라 스크립트에 대해 중단점 설정, 커서까지 실행, 프로시저 단위 실행, 단계별 추적, 실행 중지 등의 작업을 수행할 수 있습니다. 이러한 기능은 스크립트 문제를 신속하게 해결하는 데 도움이 됩니다. Script Debugger에 있는 동안에는 디버거 도구 모음에 PL/SQL 또는 Java Debugger와 다른 아이콘이 표시됩니다.

관련 항목

PL/SQL Debugger 도구 모음

Debugger 설정

Script Debugger

Java Debugger

Code Xpert


Debugger 설정

Debugger 등록

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Toad의 선택적 모듈을 확인하려면

  1. 사용자의 Toad 버전에 현재 설치된 옵션을 확인합니다. Help 메뉴에서 About을 선택합니다.

  2. 설치된 옵션이 예를 들어 "Options: Debugger, DBA"와 같이 버전 줄 아래에 나열됩니다. 이 옵션 중에 Debugger가 나열되어 있으면 이미 설치되어 있으므로 사용할 수 있습니다.

  3. 새 Procedure Editor 창을 엽니다. Debug 메뉴에 있는 항목을 사용할 수 있어야 합니다. 그렇지 않은 경우에는 Debugger 설치로 가십시오.

Debugger를 설치하려면

  1. 키가 있으면 Toad를 시작합니다.

  2. Help 메뉴에서 Register Toad를 선택합니다. Product Authorization 창이 나타납니다.

  3. Quest Software가 발급한 소프트웨어 등록 키를 Enter authorization key: 상자에 입력합니다.

  4. OK를 누릅니다.

  5. 새 Editor 창을 엽니다. 이제 Debug 메뉴에 있는 항목을 사용할 수 있어야 합니다.


Debugger 도구 모음

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

활성화된 디버깅 모드에 따라(Debugger 개요 참조) Debugger 도구 모음에 표시되는 디버깅 단추가 다릅니다.

PL/SQL 및 Java 도구 모음

아이콘 | 명령
 | 기존 인수를 사용하여 절차 실행
 | 매개 변수 설정
 | 절차 단위 실행
 | 단계별 추적
 | 전체 추적
 | 커서까지 실행
 | 중단점 추가
 | 조사식 추가
 | 외부 세션에 디버거 첨부(Just_in_Time_Debugging_Overview 참조)

Script Debugger 도구 모음

아이콘 | 명령
 | 기존 인수를 사용하여 절차 실행
 | 매개 변수 설정
 | 절차 단위 실행
 | 단계별 추적
 | 전체 추적
 | 커서에서 단계 모드 시작
 | 커서까지 실행
 | 조사식 추가
 | 중단점 추가
 | 외부 세션에 디버거 첨부(Just_in_Time_Debugging_Overview 참조)


최소 Oracle 데이터베이스 요구 사항

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

모든 데이터베이스에서 Toad를 사용하여 PL/SQL을 디버깅하려면 Oracle Probe API v2.0 이상이 설치되어 있어야 합니다.

Oracle Probe API 버전을 확인하려면

  1. SYS 스키마에 DBMS_DEBUG라는 패키지가 있는지 확인합니다.

  2. 설치된 Probe API의 버전을 확인하려면 SQL Editor에서 DBMS Output 창 탭을 선택한 상태로 다음의 익명 PL/SQL 블록을 실행합니다.

declare

probe_major_ver varchar2(10);

probe_minor_ver varchar2(10);

begin

dbms_debug.probe_version(probe_major_ver, probe_minor_ver);

dbms_output.put_line('MAJOR='||probe_major_ver);

dbms_output.put_line('MINOR='||probe_minor_ver);

end;

  3. DBMS Output 창이 다음과 같이 나타나면:

MAJOR=2

MINOR=2

Oracle Probe API의 버전은 2.2입니다.

데이터베이스 버전별 문제

Debugger다음 데이터베이스 버전에서 작동합니다. 각 버전에 대한 주의 사항을 참고하십시오.

데이터베이스 버전 참고 사항

Oracle 버전 | 메모
Oracle 7.3.4 | Call Stack을 표시하려면 init.ora Oracle Initialization 매개 변수 파일에서 BLANK_TRIMMING 값을 TRUE로 설정하고 데이터베이스를 다시 시작해야 합니다. 그렇지 않으면 Call Stack 창을 불러오는 동안 로드 오류가 발생합니다. BLANK_TRIMMING 설정의 효과에 대한 내용은 Oracle 설명서를 참조하십시오.
Oracle 8 | BLANK_TRIM 요구 사항에는 데이터베이스 8.0.4 및 8.0.5도 언급되어 있습니다. PL/SQL Debugger는 Oracle8 데이터베이스에서 문제 없이 작동합니다.
Oracle 8i | 메모나 문제가 없습니다. PL/SQL Debugger는 Oracle8i 데이터베이스에서 문제 없이 작동합니다.
Oracle 10g | DEBUG CONNECT SESSION 권한이 있어야 합니다. 그렇지 않으면 Oracle에서 DBMS_DEBUG를 사용할 수 없습니다.

추가 메모

  • Evaluate/Modify 창을 사용하여 인수 값을 변경할 수 없습니다.

  • Oracle 7 데이터베이스에서 "Debugger is not responding" 메시지가 표시되면 모든 DBMS_OUTPUT 문을 주석으로 표시한 후 다시 컴파일하고 조사식을 사용하여 값을 표시합니다. 디버깅 세션을 시작하기 전에 항상 Enable DBMS Output의 선택도 취소해야 합니다.

  • Probe v2.2 이상에서만 패키지 변수에 조사식을 사용할 수 있습니다.


Debugger 문제 해결

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Debugger 실행 속도가 너무 느린 경우

"Show executable line indicators in gutter" 옵션을 사용하면 모든 실행 가능 코드 옆에 있는 거터에 파랑색 점이 표시되기 때문에 디버거 속도가 느려질 수 있습니다.

디버깅 속도가 느리고 이 점이 표시되는 경우에는 View|Toad Options|Editor|Debug로 이동하여 이 옵션의 선택을 취소하십시오.

자세한 내용은 Toad Options|Editor|Debug 도움말 항목을 참조하십시오.

Debugger에서 주석 블록이 강조표시되는 경우

CREATE 문 앞에 주석 블록이 있으면 제외되어 서버에 저장되지 않습니다. 따라서 화면에 보이는 코드는 실제로 실행되는 코드가 아닙니다.

주석 블록을 보존하고 Debugger에서 제대로 작동하게 하려면 주석 블록을 CREATE 문 뒤에 두어야 합니다.

익명 블록에 예외 발생 - PLS-00302 오류

Oracle의 한계 때문에 사용자에게 사용자 이름과 같은 이름의 개체가 있는 경우 Debugger 작업이 실패합니다. 따라서 사용자 JSMITH에게 JSMITH라는 이름의 테이블이 있으면 JSMITH는 해당 테이블이나 JSMITH라는 이름의 기타 개체를 디버그할 수 없습니다.

이런 경우의 코드를 한 단계씩 실행하려고 시도하면 PLS-00302 오류를 포함하는 익명 블록 예외가 발생합니다. Toad에서는 다음과 비슷한 오류 메시지를 표시합니다.

주: 사용자 이름과 같은 공개 동의어가 있는 경우에도 이 오류가 발생할 수 있습니다.

권장 작업(다음 작업 중 하나 수행):

  • 개체 이름을 변경하거나 삭제합니다.

  • 디버깅을 시작하기 전에 Set Parameters 창에 있는 익명 블록에서 스키마 이름을 편집합니다.

Debugger에서 복잡한 데이터 유형을 인식하지 못하는 경우

시작할 때 Formatter dll을 찾을 수 없거나 Formatter dll 버전이 잘못되었다는 내용의 경고가 표시되면 Debugger 기능이 이 부분에서 이렇게 제대로 수행되지 않습니다.

Formatter dll을 올바른 버전으로 업데이트합니다.

디버깅할 때 Toad가 잠기는 경우

Debugger와 작은 OCISPY 유틸리티를 동시에 사용하면 Toad가 잠깁니다. OCISPY를 닫고 Debugger를 단독으로 실행하십시오.

기타 일반 디버깅 문제

데이터베이스가 최소 Oracle 데이터베이스 요구 사항에 맞는지 거듭 확인하면 다른 디버깅 문제를 피할 수 있는 경우가 많습니다. 자세한 내용은 최소 Oracle 데이터베이스 요구 사항을 참조하십시오.


Debugger 시작

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Toad의 Editor에서는 탭 당 하나의 PL/SQL 개체만 디버깅할 수 있습니다. Editor에서 전체 패키지나 유형을 열면 스펙과 본문이 개별 탭에서 열립니다.

이 두 탭은 이름이 같기 때문에 다음과 같은 아이콘으로 표시됩니다.

아이콘 | 탭
 | 스펙
 | 본문

개체의 분할, 재조합 및 저장 방법을 제어하는 옵션은 Toad Options|Editor|Open/Save| File Splitting에서 찾을 수 있습니다.

Debugger를 시작하려면

  1. Editor를 연 후:

주: OCISPY를 실행하여 Toad 세션을 모니터하는 경우에는 Debugger를 사용하기 전에 닫습니다.

  2. PL/SQL 개체를 Editor에 로드하고(디스크에 있는 파일이나 데이터베이스에 있는 기존 개체에서) F9 키를 누르거나 Editor 도구 모음에 있는 Compile 단추를 눌러 프로시저를 컴파일합니다.

  3. <Shift-F7>을 눌러 코드를 단계별로 실행하기 시작합니다. 그러면 이 프로시저의 디버그 정보만을 얻기 위해 필요한 기호 테이블이 자동으로 생성됩니다.

다른 프로시저를 한 단계씩 실행하고 디버그 정보를 보려는 경우에는 도구 모음에 있는 Compile With Debug [image] 단추를 눌러 컴파일해야 합니다.

주: 디버깅을 수행하는 동안 여러 Editor를 사용하는 것은 좋지 않습니다.

하지만 그럴 필요가 있는 경우에는 Debugger 창(DBMS Output, Breakpoints, Watches 및 Call Stack)이 한 Editor에 도킹되어 있어도 모든 Editor에 적용된다는 점에 유의해야 합니다.


Debugger 중지

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

디버깅 중에 Debugger를 중지하려면

  1. Halt 도구 모음 단추를 누릅니다.

또는

Debug 메뉴에서 Halt Execution을 선택합니다.

상태 패널이 "Running"에서 "Idle"로 재설정됩니다.

  2. PL/SQL 코드 디버깅을 완료하고 나면 디버그 기호 테이블을 삭제합니다. F9를 눌러 다시 컴파일합니다.


Debugger - General Options

General Options

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

디버깅용으로 옵션을 변경하려면

  • View 메뉴에서 Toad Options를 선택한 후 왼쪽 패널에서 Editor|Debug를 누릅니다. 오른쪽 패널에 옵션 목록이 나타납니다.

이러한 옵션 설정은 모두 TOAD.INI에 저장되며 다음에 Toad를 열면 복원됩니다. 자세한 내용은 Options: Debugging 항목을 참조하십시오.


매개 변수 설정

일부 PL/SQL에는 코드를 실행하기 전에 설정해야 하는 가변 매개 변수가 있습니다. 이 변수 값을 설정하지 않은 경우 코드를 실행하면 Oracle 오류가 발생합니다.

매개 변수를 설정하려면

  1. Debug 메뉴에서 Set Parameters를 선택하거나 도구 모음에서 Set Parameters [image] 단추를 누릅니다.

  2. Arguments 그리드에 필요한 값을 입력합니다.

  3. Output Options(출력 옵션 참조)를 눌러 출력 표시 방법을 지정합니다.

  4. Rebuild code를 눌러 코드에 입력한 변수를 봅니다.

  5. OK를 눌러 Editor로 돌아갑니다.

QSR에서 실행

매개 변수를 설정한 후 Quest ScriptRunner에서 코드를 실행할 수 있습니다. Return REF Cursor results from memory 옵션을 선택하지 않은 경우 이 단추를 사용할 수 있습니다.

QSR에서 실행하려면

  • 매개 변수를 설정하고 창의 맨 아래에서 QSR을 누릅니다.


Debugger Output 옵션

Output Arguments 및 REF CURSOR의 출력 옵션을 아래 설명과 같이 설정할 수 있습니다.

Print OUT arguments/RETURN values to DBMS Output

이 옵션은 ref cursor가 아닌 인쇄 가능한 모든 데이터 유형을 제어합니다.

Print to DBMS Output (char/number 열만 해당)

이 옵션을 선택하면 ref cursor에서 데이터를 반입하는 코드를 생성하고 줄 당 한 행씩 DBMS Output에 인쇄합니다. 열 이름이 표시된 헤더 행도 인쇄됩니다.

주: 줄이 255자를 넘으면 DBMS_output_print_line()에서 예외가 발생합니다. 이 옵션은 char/number 데이터 유형의 값만 인쇄합니다. 다른 데이터 유형의 경우에는 데이터 유형 이름이 대괄호 내에 인쇄됩니다.

RPAD columns to a width of N characters

이 옵션을 사용하면 간단하게 출력 서식을 지정할 수 있습니다. 이 옵션을 선택하면 DBMS Output에 인쇄되는 모든 값에 RPAD() 함수를 적용하도록 생성된 코드를 수정하여 사용자 지정 너비 값을 전달합니다. 그러면 값 오른쪽을 공백으로 채울 뿐 아니라 지정된 너비보다 긴 값을 자를 수도 있습니다. 열 이름에도 적용됩니다.

Create and write to table(기존 테이블 삭제)

이 옵션은 ref cursor의 레코드 유형에 따라 테이블을 작성하는 코드를 (현재 스키마에) 생성하고 반입된 데이터를 삽입합니다. 테이블에는 Toad_DEBUG_SOME_RC와 같은 이름이 지정되며, 여기서 SOME_RC는 코드에 있는 ref cursor의 이름입니다.

주: 저장 테이블이 있는 테이블에는 이 옵션이 적용되지 않으며 VARCHAR2(n CHAR) 열을 처리할 수도 없습니다. 이 열은 VARCHAR2(n)로 선언됩니다.

Fetch no more than N rows per cursor

반입되는 행의 수를 제한합니다. DBMS Output과 테이블 옵션 모두에 적용됩니다.


종속 관계

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Debugger를 사용하여 종속 관계를 확인할 수 있습니다.

종속 개체 자동 검색

Toad에서 추가 질의를 자동으로 실행하여 현재 프로시저를 호출하는 프로시저가 있는지 확인할 수 있습니다. 이 기능을 설정하려면 옵션을 선택합니다.

옵션을 선택했을 때 질의에 종속 관계(프로시저를 호출하는 다른 프로시저)가 포함되어 있으면 Compile Dependencies [image] 단추를 사용할 수 있게 됩니다. 프로시저를 호출하는 모든 프로시저를 다시 컴파일하려면 Compile Dependencies 단추를 누릅니다.

종속 관계가 없거나 종속 관계를 모두 컴파일한 경우에는 단추를 사용할 수 없습니다. 추가로 편집을 수행하고 프로시저를 컴파일하면 단추를 사용할 수 있습니다.

선택하지 않은 경우 Compile Dependencies 단추는 누를 때까지 사용할 수 있는 상태로 유지됩니다. 컴파일 후에 다시 사용할 수 있습니다.

종속 개체 처리 옵션을 설정하려면

  1. View 메뉴에서 Options를 선택합니다.

  2. 왼쪽 창에서 Editor|Debug를 선택합니다.

  3. Compile Dependencies 영역에서 다음 중 하나를 선택합니다.

  4. Yes - Toad에서 항상 종속 관계를 컴파일합니다.

  5. No - Toad에서 종속 관계를 컴파일하지 않습니다.

  6. Prompt - Toad에서 종속 관계를 확인하고 컴파일 여부를 묻습니다.

종속 관계 및 해당 상태 보기

종속 관계와 해당 상태를 시각적으로 확인할 수 있습니다.

종속 관계를 보려면

  1. Schema Browser의 Objects 패널에서Procedures, Functions, or Packages 탭을 누릅니다.

  2. 디버깅할 프로시저를 선택한 후 Details 패널에서Deps(uses) 및 Deps (used by) 탭을 누릅니다. Details 패널에 프로시저의 상태가 Valid 또는 Invalid로 나열됩니다.


프로덕션용으로 PL/SQL 코드 준비

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

PL/SQL 코드 디버깅을 완료하고 나면 코드에 디버그 기호 테이블이 남습니다. 이로 인해 코드가 커지고 성능이 저하될 수 있습니다.

성능을 향상시키려면

  • 프로시저와 호출된 프로시저를 디버그 정보 없이 마지막으로 컴파일합니다(디버그 토글 [image] 단추 꺼짐). 그러면 디버그 기호 테이블 없이 다시 컴파일됩니다. 이로 인해 코드가 작아지며 실행이 빨라집니다.


유형 디버깅

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

type body를 디버깅해야 하는 경우가 있습니다. Debugger에는 Editor로 유형 본문을 로드하고 "Run"을 눌러 디버깅하는 기능이 지원되지 않지만, 아래 설명과 같이 type body를 간접적으로 디버깅할 수 있습니다.

type body를 간접적으로 디버깅하려면

  1. 프로시저에서 type body를 호출합니다.

  2. 프로시저를 디버깅할 때 type body의 코드도 한 단계씩 실행합니다.


Java Debugger 개요

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

JDWP Debugger는 PL/SQL Debugger와 같은 기본 사용자 인터페이스를 사용합니다. JDWP debugger는 DBMS_DEBUG 대신 Oracle 패키지 DBMS_DEBUG_JDWP를 사용하여 디버깅 기능에 액세스하기 때문에 전적으로 Oracle 지향적입니다. 즉, Toad를 통해 사용할 수 있는 디버깅 프로시저에 Oracle로 인한 한계가 적용됩니다.

Toad Java Debugger에서는 다음을 수행할 수 있습니다.

  • Editor 창에서 Java 소스 작성.

  • 한 단계씩 Java 코드 실행.

  • Java 코드에 중단점 설정.

  • Java 변수 값 조사.

  • 코드 프로파일.

관련 항목

Java Debugger 시작

중단점 설정

조사식 설정

한 단계씩 Java 코드 실행

Java 디버깅 문제 해결


Java Debugger 시작

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Java Debugger로 작업을 수행하려면 먼저 Oracle의 Java Debugger와 함께 사용할 수 있게 Toad를 구성해야 합니다.

Java 코드 디버깅을 준비하려면

  1. Oracle 9.2 이상을 실행 중인지 확인합니다.

  2. 디버그 패키지 DBMS_DEBUG_JDWP가 있으며 유효한 상태인지 확인합니다.

그렇지 않으면 다음을 수행합니다.

  1. SYS로 로그온합니다.

  2. $ORACLE_HOME/rdbms/admin 디렉토리에 있는 dbmsjdwp.sql 및 pvrtjdwp.plb 스크립트를 실행합니다.

  3. Toad Main 메뉴에서 View|Toad Options를 선택하고 왼쪽에서 Editor|Debug를 누릅니다.

  4. Use JDWP debugger for Oracle 9.2+를 선택합니다.

  5. 아래 설명과 같이 구성 정보를 포함합니다.

  • Host - IP 주소(Oracle 클라이언트 9.2 이상이 설치된 컴퓨터의 IP 주소) 또는 로컬 컴퓨터의 이름이어야 합니다. 디버깅 세션 중에 디버거 호스트로 사용됩니다.

  • Port - Toad Debugger가 수신할 TCP 포트를 선택합니다. 이 값을 Use any available로 두면 Toad에서 적절한 포트를 선택합니다.

  • Allow stepping into Java Source - 일부 플랫폼에서는 Java 코드를 한 단계씩 실행하면 디버거가 중지될 수 있습니다. 이 확인란은 이 문제를 방지하기 위해 도입되었습니다. 그런 문제가 발생하는 경우 PL/SQL 코드를 계속 디버깅하려면 이 확인란의 선택을 취소합니다.

  • Enable DBMS_JAVA – 기본적으로 System.out.* java 호출은 로컬에 표시되지 않습니다. 이 출력을 DBMS_OUT로 리디렉션하려면 적절한 버퍼 크기로 DBMS_JAVA에 대한 호출을 사용해야 합니다. System.out.* java 호출을 DBMS Output 창으로 보내려면 이 옵션을 선택합니다.

관련 항목

Java Debugger 개요

중단점 설정

조사식 설정

한 단계씩 Java 코드 실행

Java 디버깅 문제 해결


한 단계씩 Java 코드 실행

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Java Debugger를 사용하면 Java 코드를 한 단계씩 실행하며 디버깅할 수 있습니다.

코드를 한 단계씩 실행하려면

  • <Shift - F7>을 눌러 코드를 한 단계씩 실행합니다.

문제 해결

Java Debugger가 선택되어 있는지 확인

Java 디버깅이 설정되었는지 확인하려면

  • Debug 메뉴에서 JDWP debugger가 선택되어 있는지 확인합니다.

Oracle 디버거 정지

일부 플랫폼에서는 코드를 한 단계씩 실행하면 Oracle 디버거가 정지됩니다. 이 경우에는 Java 코드를 한 단계씩 실행할 수 없습니다.

디버깅을 계속하려면

  • Toad Options|Editor|Debugging에서 Allow stepping into Java Source 상자의 선택을 취소합니다.

관련 항목

Java Debugger 개요

Java Debugger 시작

중단점 설정

조사식 설정


Java 디버깅의 한계

Java 디버깅 문제 해결

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Java Debugger는 PL/SQL Debugger와 같은 기본 사용자 인터페이스를 사용합니다. Java Debugger는 Oracle 패키지 DBMS_DEBUG_JDWP를 사용하여 디버깅 기능에 액세스하기 때문에 전적으로 Oracle 지향적입니다. 즉, Toad를 통해 사용할 수 있는 디버깅 프로시저에 Oracle로 인한 한계가 적용됩니다.

일반 한계

Java debugger는 트리거를 지원하지 않습니다.

Oracle 9iR2 문제

Debugger 패키지(DBMS_DEBUG_JDWP)는 처음에 Oracle 9iR2와 함께 릴리스되었습니다. 이 릴리스에는 몇 가지 한계가 있습니다.

한 단계씩 코드 실행

Debugger에서 Java 소스를 한 단계씩 실행할 때 데이터베이스에서 ORA-03113 오류가 생성될 수도 있습니다.

디버깅을 계속하려면

  • Toad Options|Editor|Debugging에서 Allow stepping into Java Source 상자의 선택을 취소합니다.

주: 이 상자의 선택을 취소하면 Java 소스 코드를 한 단계씩 실행할 수 없습니다.

Oracle 10g 문제

Debugger가 코드의 글머리 기호가 있는 줄을 건너뛰는 경우

Windows 서버에서 Debugger가 글머리 기호가 있는 Java 소스 코드 줄을 건너뛸 수 있습니다. 아직은 이 문제를 해결할 방법이 알려져 있지 않습니다.

Debugger 거터 줄 실행 글머리 기호가 보이지 않는 경우

JDWP 디버깅에서는 Debugger가 호출되어 초기화될 때까지 줄 맵을 검색할 수 없습니다. 그러면 디버깅이나 실행이 시작될 때까지 거터 글머리 기호가 표시되지 않습니다.

DBMS Output 창으로 출력 전환

Windows OS에서 9iR2를 사용하는 경우 dbms_java.set_output 명령을 실행하는 줄에서 Oracle이 ORA-3113 오류를 반환할 수 있습니다.

DBMS Output 창을 호출하는 코드를 단계별로 추적하면 오류가 생성됩니다.

System.out.println 단계별 추적

System.out.println을 단계별로 추적하면 ORA-3113 오류가 생성될 수 있습니다.

관련 항목

Java Debugger 개요

Java Debugger 시작

중단점 설정

조사식 설정

한 단계씩 Java 코드 실행


Script Debugger 개요

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Script Debugger는 짧은 스크립트를 디버깅하는 데 사용할 수 있는 Editor 확장입니다.

여러 스크립트를 로드할 수 있으며 각 스크립트는 자체 탭에서 열립니다(자세한 내용은 스크립트 열기 참조).

Script Debugger를 사용하면 표준 Editor 기능 외에도 다음을 수행할 수 있습니다.

  • 중단점 설정

  • 커서까지 실행

  • 절차 단위 실행

  • 단계별 추적

  • 실행 중지

변경 사항을 적용하려면

  • Main 도구 모음에서 Commit [image] 단추를 누릅니다. 그러면 두 세션의 변경 사항이 모두 적용됩니다.

관련 항목

Script Debugger 도구 모음

Quest 확장

문 실행

Navigator 패널

Script Output 탭

Script Debugger 탭

Source Control 사용


Script Output 탭

스크립트를 실행하고 나면 Toad에서 시스템 변수와 사용자 변수의 실행 목록을 유지합니다. 이를 통해 설정 내용을 추적할 수 있습니다. 실행을 전체적으로 완료하고 나면 목록이 새로 고쳐집니다.

디버깅 모듈이 있는 경우에는 코드를 한 단계씩 실행하기 시작할 때 이 모듈도 새로 고쳐집니다. Toad에서는 중단점 기록과 다양한 창의 탐색에 도움이 되는 호출 스택도 유지합니다.

Environment 탭

시스템 변수

시스템 변수는 Environment 영역의 System Variables 노드 아래에 표시됩니다. 시스템 변수에는 다음 등이 포함됩니다.

  • 자동 적용 설정

  • echo 설정/해제

  • 줄 크기

  • 제목 설정/해제

시스템 변수를 보려면

  • System Variables 노드를 두 번 누릅니다.

또는

System Variables 노드 옆에 있는 <+>를 누릅니다.

사용자 변수

사용자 변수는 Environment 영역의 User Variables 노드 아래에 표시됩니다. 사용자 변수 영역에서는 사용자가 스크립트에 할당한 변수를 설명합니다.

사용자 변수를 보려면

  • User Variables 노드를 두 번 누릅니다.

또는

User Variables 노드 옆에 있는 <+>를 누릅니다.

Output

Output 탭에는 실행하는 스크립트의 출력이 모두 표시됩니다. 여기에는 다음 등이 포함됩니다.

  • 오류

  • 시스템 변수의 상태(예: AUTOTRACE ON, AUTOCOMMIT OFF)

  • 출력 형식의 데이터

데이터 그리드

데이터 그리드에는 스크립트에서 선택된 데이터가 표시됩니다. 모든 select 문에 대해 그리드가 하나씩 표시됩니다.

데이터 그리드를 보려면

  1. 스크립트를 실행합니다.

  2. 아직 선택되어 있지 않은 경우 Script Debugger의 맨 아래 패널에 있는 Script Output 탭을 누릅니다.

  3. Grid 탭을 눌러 데이터 그리드를 표시합니다.

History

History에는 이 세션 중에, 또는 History 탭의 내용이 지워질 때까지 실행된 모든 스크립트의 출력이 표시됩니다.

기록이 표시되지 않으면 다음과 같이 History 탭을 표시할 수 있습니다.

기록을 표시하려면

  1. 다른 두 탭 중 하나를 마우스 오른쪽 단추로 누릅니다.

  2. Show History 탭을 선택합니다.

관련 항목

Script Debugger 개요

Debugger 도구 모음

Quest 확장

문 실행

Navigator 패널

Script Output 탭

Source Control 사용

Breakpoints 창

Call Stack 창


SD_Quest 확장

Quest 확장

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Quest 확장은 스크립트 확장으로 Toad의 Script Debugger 내에서 스크립트 출력을 제어하는 데 사용됩니다.

Quest 확장은 remark 내에 있으며 $QX로 지정됩니다. $QX가 remark 내에서 처음에 있는 것이어야 합니다. $QX는 PL/SQL 블록이나 EXECUTE 문의 remark에 사용되지 않고 별도의 스크립트 remark 문에만 사용됩니다.

그리드 표시/숨기기

Script Output 탭 내에서 Quest 확장을 사용하여 쉽게 그리드 표시를 끌 수 있습니다.

그리드를 숨기려면

  • remark에서 다음 명령을 입력합니다.

$QX $GRID HIDE

그 줄의 스크립트에서 생성된 모든 그리드는 아래 설명과 같이 다시 표시할 때까지 줄에서 숨겨집니다.

그리드를 표시하려면

  • remark에서 다음 명령을 입력합니다.

$QX $GRID SHOW

그 줄에서부터 생성된 모든 그리드가 표시됩니다.

관련 항목

Script Debugger 개요

Script Debugger 도구 모음

문 실행

Navigator 패널

Script Output 탭

Script Debugger 탭

Source Control 사용


REF CURSOR Results 창

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Toad에서 REF CURSOR 결과를 별도 창에 보내도록 할 수 있습니다. 이 창은 다른 디버거 창에 도킹할 수 있습니다.

디버그 세션이 종료되면 이 창에는 매개 변수 설정에서 설명한 Create and write to table 옵션의 REF CURSOR에 대해 작성된 각 테이블이 표시됩니다. 각 테이블은 창에서 별도 탭의 그리드에 표시됩니다.

주: REF CURSOR 창에는 다음과 같은 한계가 있습니다.

  • 유형이 엄격하게 검사되는 REF CURSOR에만 적용됩니다.

  • REF CURSOR 유형이 현재 로그인된 사용자에 속한 패키지에서 선언된 경우에만 적용됩니다.

세 개의 도구 모음 단추는 다음과 같습니다.

  • Refresh - 현재 탭에 있는 그리드를 새로 고칩니다(select * 문 다시 실행).

  • Close Tab - 현재 탭을 닫습니다.

  • Drop Table - 현재 테이블을 삭제하고 탭을 닫습니다.

그리드는 일반 팝업 편집기를 모두 지원하지만 읽기 전용 질의입니다.


DBMS Output 디버깅

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Editor에서 디버깅을 수행할 때 DBMS Output 창에는 "DBMS_OUTPUT.PUT_LINE()" 문의 결과가 자동으로 표시됩니다.

주: 출력은 프로시저 실행이 완료된 후에만 표시되며 코드를 한 단계씩 실행하는 동안에는 표시되지 않습니다. 중첩된 프로시저 호출의 경우에는 DBMS Output 내용을 표시하려면 모든 프로시저가 완전히 실행되어야 합니다.

DBMS Output 창은 Watches, Call Stacks 및 Breakpoints 창에 도킹할 수도 있고 끌어서 따로 놓을 수도 있습니다. 이 모든 창을 그룹으로 묶으면 Editor 창의 아래쪽에 도킹시킬 수 있습니다.

주: 아래쪽으로부터 한 번에 하나씩 창의 도킹을 해제한 경우, Toad에서는 도킹이 해제된 것을 기억하지 못합니다. 모든 디버깅 창의 도킹을 한꺼번에 해제하려면 도킹된 창의 왼쪽에 있는 세로 막대를 두 번 누릅니다.

DBMS Output 비활성화

DBMS Output이 DBMS Output 창에 표시되지 않도록 비활성화할 수 있습니다.

DBMS Output을 비활성화하려면

  • DBMS Output 창 맨 위에서 Enable/Disable 토글 단추를 누릅니다.

  • 단추가 녹색이면 DBMS Output이 활성화된 것입니다.

  • 단추가 빨강색이면 DBMS Output이 비활성화된 것이며, 이 경우 창 이름 옆에 (disabled)가 표시됩니다.

DBMS Output용 명령

마우스 오른쪽 단추 메뉴를 사용하여 DBMS Output용 명령에 액세스할 수 있습니다. 여기에는 다음 항목이 포함됩니다.

  • Enabled (toggle)

  • Clear Output

  • Save to File

  • Print

  • Set Buffer Size

  • Stay on Top

  • Dockable

DBMS Output 내용 편집

DBMS Output 내용을 편집하여 주석을 만들고 출력에서 특정 줄을 삭제하는 등의 작업을 수행할 수 있습니다. 표준 복사, 잘라내기 및 붙여넣기 키도 DBMS Output 상자에서 사용할 수 있습니다.

관련 항목

DBMS Output 창

Polling_for_Output


Breakpoints 창

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

중단점은 코드에서 디버깅 중에 실행을 중지할 위치를 나타내는 마커입니다. Breakpoints 창에는 Debug 메뉴를 통해 액세스할 수 있습니다.

  • Debug 메뉴에서 Breakpoints를 선택합니다. Breakpoints 창이 나타납니다.

  • Breakpoints 창에서는 중단점 작업을 쉽게 수행할 수 있습니다. 창 자체에 있는 도구 모음에서 기능을 선택할 수도 있고 마우스 오른쪽 단추 메뉴를 사용하여 더 많은 기능에 액세스할 수도 있습니다.

  • Breakpoints 창은 Watches, Call Stacks 및 DBMS Output 창과 도킹할 수 있으며 Breakpoints 창을 Editor의 어느 쪽에나 도킹시킬 수도 있습니다. 이 모든 창을 그룹으로 묶으면 Editor 창의 아래쪽에 도킹시킬 수 있습니다.

Breakpoints 창 도구 모음

Breakpoints 창에 있는 도구 모음에는 중단점 명령에 쉽게 액세스하는 데 사용할 수 있는 단추 몇 개가 있습니다.

단추 | 명령
 | Edit Breakpoint – 선택한 중단점의 편집 창을 엽니다.
 | Add Breakpoint – 커서 위치에 중단점을 추가합니다.
 | Delete Breakpoint – 선택한 중단점을 삭제합니다.
 | Enable Breakpoint – 선택한 중단점을 활성화합니다.
 | Disable Breakpoint – 선택한 중단점을 비활성화합니다.
 | View Source - 선택한 중단점에서 참조하는 소스의 줄에 커서를 두고 검정색 화살표로 표시합니다.


중단점 설정

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

여러 위치에서 중단점을 설정(추가)할 수 있습니다.

Editor에서 중단점을 설정하려면

Editor에서는 중단점을 여러 가지 방법으로 설정할 수 있습니다.

  • Editor 거터를 한 번 눌러 중단점을 설정 또는 재설정합니다.

또는

<Shift><F5>를 눌러 Editor의 현재 줄에 중단점을 설정 또는 재설정합니다.

중단점은 거터에 중지 기호로 표시됩니다.

주: 거터 너비를 35로 설정하는 것이 좋습니다. 그러려면 Edit 메뉴에서 Editor Options를 선택한 후 Gutter Width 필드에 35를 입력합니다.

Breakpoints 창에서 중단점을 설정하려면

  1. 마우스 오른쪽 단추를 누르고 Add Breakpoint를 선택합니다.

  2. 적절한 정보를 입력하고 OK를 누릅니다.

또는

  1. Add Breakpoint [image] 단추를 누릅니다.

  2. 적절한 정보를 입력하고 OK를 누릅니다.

Breakpoints 탭에서 중단점을 설정하려면

  • <INSERT> 키를 눌러 중단점을 추가합니다.

Debug 메뉴에서 중단점을 설정하려면

  1. 중단점을 설정할 줄을 누릅니다.

  2. Debug 메뉴에서 Add Breakpoint at cursor를 선택합니다.


중단점 속성 설정

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Breakpoint Properties 대화 상자를 사용하면 표준 중단점, 조건부 중단점, 패스 수 중단점 또는 조건부 중단점과 패스 수 중단점의 조합을 설정할 수 있습니다. 속성은 각 개별 중단점에서 변경합니다.

중단점 속성을 변경하려면

  1. Desktop 메뉴에서 Breakpoints를 선택합니다. Breakpoints 창이 나타납니다.

  2. 속성을 설정할 Breakpoint를 두 번 누릅니다.

표준 중단점

표준 중단점을 사용하면 코드를 실행하거나 한 단계씩 실행할 때 중단점에서 중단됩니다. 표준 중단점을 사용하는 경우에는 속성 대화 상자의 Condition 및 Pass count 줄이 비어 있습니다.

조건부 중단점

코드를 실행할 때 특정 조건이 충족되어야만 중단되도록 중단점을 설정할 수 있습니다.

조건부 중단점을 설정하려면

  1. Breakpoints 창에서 중단점을 선택합니다.

  2. 마우스 오른쪽 단추를 누른 다음 Edit Breakpoint를 선택합니다. 중단점의 조건(예: "salary_in > 5000")을 입력합니다. 코드를 실행하면 조건이 충족되는 경우에만 중단점에서 Debugger가 중지됩니다.

조건부 중단점의 형식

"Condition" 줄의 형식은 변수 연산자 값입니다. 예를 들어 "salary_in"(변수) ">"(연산자) "5000"(값)과 같습니다.

지원되는 연산자

연산자 | 의미
<= | 작거나 같음
<> | 같지 않음
>= | 크거나 같음
< | 작음
> | 큼
= | 같음

패스 수 중단점

루프에서 일정한 패스 수를 채운 후에만 중단되는 중단점을 설정할 수 있습니다.

이 경우 n번째 패스 수의 중단점 줄 직전에 도달할 때까지는 Debugger가 중단점 줄에서 중지되지 않습니다. 패스는 FOR 루프, DO WHILE 루프, IF/END IF 등이 될 수 있습니다. "COUNTER_VAR" 값과는 관계가 없습니다.

패스 수를 사용하여 중단점을 설정하려면

  1. Breakpoints 창에서 중단점을 선택합니다.

  2. 마우스 오른쪽 단추를 누른 다음 Edit Breakpoint를 선택합니다. 중단점의 Pass Count 값을 입력합니다(예: 5). 실행하면 Debugger는 중단점을 5번째로 지나기 직전의 중단점에 중지됩니다.

조건부 중단점과 패스 수 중단점 조합

조건과 패스 수가 모두 지정된 경우에는 조건이 충족된 후 n번째에만 실행이 중지됩니다.


중단점 활성화/비활성화

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

중단점을 비활성화하려면

중단점을 설정하고 나면 일시적으로 비활성화할 수 있습니다.

  • 다음 중 한 가지 방법을 사용합니다.

  • 중단점을 한 번 눌러 선택하고 도구 모음에 있는 Disable Breakpoint [image] 아이콘을 누릅니다.

  • breakpoint를 두 번 누르고 Enabled 확인란의 선택을 취소합니다.

  • breakpoint를 선택하고 마우스 오른쪽 단추를 누르고 Debug를 선택한 다음 Disable Breakpoint를 선택합니다.

비활성화된 중단점은 Breakpoints 창에서 회색으로 표시됩니다.

중단점을 활성화하려면

중단점을 비활성화하면 Breakpoints 창에서 회색으로 표시됩니다. 비활성화할 때 사용한 것과 같은 방법으로 다시 활성화할 수 있습니다.

  • 다음 중 한 가지 방법을 사용합니다.

  • 중단점을 한 번 눌러 선택하고 도구 모음에 있는 Enable Breakpoint [image] 아이콘을 누릅니다.

  • breakpoint를 두 번 누르고 Enabled 확인란을 선택합니다.

  • breakpoint를 선택하고 마우스 오른쪽 단추를 누르고 Debug를 선택한 다음 Enable Breakpoint를 선택합니다.


중단점 삭제

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

중단점을 여러 가지 방법으로 삭제할 수 있습니다.

중단점을 삭제하려면

  • 중단점을 삭제하려면 다음 중 한 가지를 수행합니다.

  • Breakpoints 창에서 breakpoint를 선택하고 Delete를 누릅니다.

  • Editor에서 커서를 line containing a breakpoint 에 두고 F5 키를 누릅니다.

  • Editor에서 거터에 있는 stop sign [image] 아이콘을 누릅니다.


중단점 마우스 오른쪽 단추 메뉴

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Breakpoints 창에서 마우스 오른쪽 단추를 누르면 중단점 마우스 오른쪽 단추 메뉴에 액세스할 수 있습니다. 이 메뉴에는 다음과 같은 옵션이 있습니다.

  • Edit Breakpoint

  • Add Breakpoint

  • Enable Breakpoint

  • Disable Breakpoint

  • Delete Breakpoint

  • View Source – 중단점에서 참조하는 소스의 줄에 커서를 두고 검정색 화살표로 표시합니다.

  • Enable All Breakpoints – 모든 중단점을 활성화합니다.

  • Disable All Breakpoints – 모든 중단점을 비활성화합니다.

  • Delete All Breakpoints – 모든 중단점을 삭제합니다.

  • Stay on Top – 이 옵션을 선택하면 창은 다른 모든 창의 위에 남아 있습니다.

  • Dockable– 이 옵션을 선택하면 Breakpoints 창이 Watches, Call Stacks 및 DBMS Output 창과 도킹할 수 있으며 탭을 통해 이 모든 창에 액세스할 수 있습니다.


Watches 창

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Toad에서는 명시적 및 암시적으로 정의된 레코드, %ROWTYPE 레코드 및 커서와 같은 복잡한 데이터 유형을 포함하여 명시적인 변수와 암시적인 변수를 조사할 수 있습니다. 지원되는 유형의 예는 복잡한 데이터 유형 예를 참조하십시오. 지원되지 않는 유형에 대한 자세한 내용은 조사식의 한계를 참조하십시오.

Watches 창에서는 조사식 작업을 쉽게 수행할 수 있습니다. 창 자체에 있는 도구 모음에서 기능을 선택할 수도 있고 마우스 오른쪽 단추 메뉴를 사용하여 더 많은 기능에 액세스할 수도 있습니다.

주: 정식으로 조사식을 설정하지 않은 채 마우스를 변수 위에 두고 값을 확인할 수도 있습니다.

Watches 창은 Breakpoints, Call Stacks 및 DBMS Output 창에 도킹할 수도 있고 끌어서 따로 놓을 수도 있습니다. 이 모든 창을 그룹으로 묶으면 Editor 창의 아래쪽에 도킹시킬 수 있습니다.

주: 아래쪽으로부터 한 번에 하나씩 창의 도킹을 해제한 경우, Toad에서는 도킹이 해제된 것을 기억하지 못합니다. 모든 디버깅 창의 도킹을 한꺼번에 해제하려면 도킹된 창의 왼쪽에 있는 세로 막대를 두 번 누릅니다.

Watches 창에는 Debug 메뉴를 통해 액세스할 수 있습니다.

Watches 창에 액세스하려면

  • Output 영역에서 마우스 오른쪽 단추를 누르고 Desktop Panels|Watches를 선택합니다. Watches 창이 데스크톱 패널에 추가됩니다.

Watches 창 도구 모음

Watches 창에 있는 도구 모음에는 조사식 명령에 쉽게 액세스하는 데 사용할 수 있는 단추 몇 개가 있습니다.

Edit Watch – 선택한 조사식의 편집 창을 엽니다.

Add Watch – 커서 위치에 조사식을 추가합니다.

Delete Watch – 선택한 조사식을 삭제합니다.

Enable Watch – 선택한 조사식을 활성화합니다.

Disable Watch – 선택한 조사식을 비활성화합니다.


복잡한 데이터 유형 예

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Toad에서는 여러 복잡한 데이터 유형을 조사할 수 있습니다. 아래에서는 그 중 일부에 대해 설명합니다.

주: 레코드 변수에 대한 조사식은 Debugger를 통해 절차를 한 단계씩 실행한 후 설정해야 합니다. Toad에서는 변수의 컨텍스트가 있어야 레코드인지 여부를 확인할 수 있습니다.

명시적 레코드 선언

아래 예에서는 매개 변수 pow와 변수 rec의 유형이 pow_rec로 명시적으로 선언되었기 때문에 선언이 명시적입니다.

CREATE ORREPLACE packagepowexample is

TYPE POW_REC IS RECORD

(

NAME VARCHAR2(30),

RANK VARCHAR2(30),

SERIALNO VARCHAR2(30)

);

PROCEDURE POWRECPROC(POW IN POW_REC);

end;

/

CREATE ORREPLACE packagebody powexample is

PROCEDURE POWRECPROC(POW IN POW_REC) IS

TMPVAR VARCHAR2(30);

REC POW_REC;

BEGIN

REC.NAME:= 'DAVID';

REC.RANK:= 'GENERAL';

REC.SERIALNO:= '555-00-0000';

TMPVAR :=POW.NAME;

TMPVAR :=POW.RANK;

TMPVAR :=POW.SERIALNO;

END POWRECPROC;

end;

/

암시적 레코드 선언

아래의 예에서는 루프 색인 변수 rec가 선언되지 않았기 때문에 선언이 암시적입니다.

주: 해당 질의의 선택 목록에 변수가 있는 암시적 목록은 조사할 수 없습니다. 이 선택 목록에 변수가 있으면 빈 조사식이 반환됩니다. 레코드 구조를 검색할 때 WHERE 절에 있는 변수는 무시되고 조사가 정상적으로 진행됩니다.

이 예에는 레코드(REC)와 커서(C1)가 모두 포함되어 있습니다.

CREATE OR REPLACE PROCEDURE ForLoopProc IS

cursor C1 is select * from employee;

BEGIN

for rec in C1

loop

dbms_output.put_line(rec.empname);

end loop;

END ForLoopProc;

예 2

CREATE OR REPLACE PROCEDURE CursorForLoopProc IS

BEGIN

for rec in (select * from new_user)

loop

dbms_output.put_line(rec.first);

end loop;

END CursorForLoopProc;

%ROWTYPE 레코드:

이 예에서는 tmpVar가 레코드로 확장됩니다.

CREATE OR REPLACE FUNCTION returnrowtype RETURN employee%ROWTYPE as

tmpVar employee%ROWTYPE;

BEGIN

tmpvar.empid := 1;

tmpvar.empname := 'DAVID';

tmpvar.salary := 100000;

RETURN tmpvar;

END returnrowtype;

컬렉션 레코드

Toad에서는 컬렉션 결과를 DBMS Output 창으로 표시하는 기능도 지원됩니다.

이 옵션을 사용하면 컬렉션 결과가 DBMS Output 창에 표시되고 행 서식이 적용됩니다.

주: 이 경우에는 행 제한이 적용되지 않습니다.

컬렉션 결과를 활성화하려면

  • Editor|Set Parameters|Options에서 DBMS Output을 선택합니다.


조사식 추가

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

몇 가지 방법으로 조사식을 추가할 수 있습니다.

Editor에서 조사식을 추가하려면

  1. Editor에서 variable을 누릅니다.

  2. 도구 모음에서 Add Watch [image] 단추를 누릅니다. 변수가 조사식 목록에 추가됩니다. Watches 창이 열려 있지 않은 경우 이 창을 열어 조사식을 봐야 합니다.

또는

Editor 안쪽을 마우스 오른쪽 단추로 누르고 Debug를 선택한 후 Add Watch at Cursor를 선택합니다.

Watches 창에서 조사식을 추가하려면

  • 마우스 오른쪽 단추를 누르고 Add Watch 메뉴 항목을 선택합니다. Watch Properties 대화 상자가 나타납니다.

또는

<CTRL>F5를 눌러 커서 위치에 있는 변수를 조사식 목록에 추가합니다. 조사식이 추가되지만 Watch Properties 대화 상자는 표시되지 않습니다.

Debug 메뉴에서 조사식을 추가하려면

  1. 감시할 variable을 누릅니다.

  2. Debug 메뉴에서 Add Watch at cursor를 선택합니다.

주: "Add Watch at Cursor"가 선택되어 있는데 텍스트를 선택한 경우에는 Toad에서 선택한 텍스트에 조사식을 설정합니다. 텍스트가 선택되지 않은 경우에는 커서 아래에 있는 텍스트를 사용합니다. 이 변경은 recordname.fieldname이 있는 경우에 recordname만을 강조표시하여 조사식을 설정할 수 있도록 이루어집니다. v_List(2)와 같은 식(여기서 v_List는 varray)이 있는 경우에는 전체 식을 강조표시하여 조사식을 둘 수 있습니다.

관련 항목

조사식의 한계


조사식의 한계

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Oracle Probe API의 한계 때문에 일부 구성은 조사할 수 없습니다.

  • Oracle 7에서는 패키지 변수에 대한 조사를 지원하지 않습니다.

  • Toad에서는 조사식의 산술을 지원하지 않습니다. 예를 들어 두 변수의 합을 조사할 수 없습니다.

  • :new.column 또는 :old.column value 트리거를 조사할 수 없습니다.


Watch Properties 설정

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

조사식을 추가하면서 Watch Properties를 설정할 수도 있고 기존 조사식에서 Watch Properties를 설정할 수도 있습니다.

일부 조사식 추가 방법에서는 Watch Properties 대화 상자를 표시합니다. (조사식 추가 참조)

기존 조사식의 속성을 변경하려면 Watches 창에서 속성을 변경할 조사식을 두 번 누릅니다. Watch Properties 대화 상자가 나타납니다.

Watch Properties를 설정하려면

  1. Expression 필드에서 조사할 변수의 이름을 입력합니다.

  2. 패키지 본문이나 패키지 스펙에 있는 변수는 자동으로 확인됩니다. 변수를 패키지 변수로 지정하고 적절한 상자에서 다른 스키마나 패키지를 참조할 수도 있습니다.

  3. 조사할 수 있는 일반 데이터 유형(예: date, number, varchar2) 외에도 배열 값과 레코드 유형을 조사할 수 있습니다. MyArray(1..10)와 같은 배열이 있고 MyArray(1)에 대한 조사식을 설정한 경우에는 Repeat Count 값을 3으로 설정하여 MyArray(1), MyArray(2), MyArray(3)을 모두 동시에 설정할 수도 있습니다.

  4. 표시할 유효 숫자의 수를 입력합니다.

  5. 조사식 값의 서식을 기본값과 다르게 설정하려면 형식 옵션에서 적절한 값을 선택합니다(예: floating point, scientific 등). 레코드의 조사식에는 서식을 지정할 수 없습니다. 조사할 레코드를 선택하는 경우에는 Watch Properties 창에서 이 영역을 사용할 수 없습니다.

주: 문자열에 인쇄할 수 없는 문자(ASCII 0-31)가 포함되어 있으면 대부분의 글꼴에서 의미 있는 방식으로 렌더링되지 않기 때문에 혼동되는 오류가 발생하고 디버그가 어려워질 수 있습니다. "String\Dec"는 CR, LF와 같이 인쇄할 수 없는 문자를 십진수로 표시합니다(예: "This is a test.\013\010"). "String\Hex"는 인쇄할 수 없는 문자를 16진수로 표시합니다(예: "This is a test.\$D\$A").

  6. 값이 변경되었을 때 Debugger가 중단되도록 설정하려면 Break on value change 확인란을 선택하고 원하는 중단 유형을 선택합니다.

  7. Never

  8. Always

  9. When a specific condition is met(예: x=4)

주: 선택한 조사식이 레코드인 경우에는 이 기능을 사용할 수 없으며 Watch Properties 창에서 이 기능이 비활성화됩니다.

  6. OK를 눌러 속성을 변경 또는 설정합니다.


조사식 활성화/비활성화

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

조사식을 설정하고 나면 일시적으로 비활성화할 수 있습니다. 일부 조사식을 비활성화하여 Debugger의 성능을 향상시킬 수 있습니다. 코드의 각 줄을 실행하면서 각 조사식을 계산해야 합니다. 계산할 조사식이 적을수록 실행이 빨라집니다.

조사식을 비활성화하려면

  • Watches 창에서 watch를 두 번 누르고 Enabled 확인란의 선택을 취소합니다.

또는

Watches 창에서 watch를 선택하고 마우스 오른쪽 단추를 누르고 Disable Watch를 선택합니다.

비활성화된 조사식은 Watches 창에서 회색으로 표시되고 DISABLED라는 단어가 표시됩니다.

모든 조사식을 비활성화하려면

  • Watches 창에서 마우스 오른쪽 단추를 누르고 Disable All Watches를 선택합니다. 모든 조사식이 회색으로 표시되며 비활성화됩니다.

조사식을 활성화하려면

  • Watches 창에서 조사식을 두 번 누르고 Enabled 확인란을 선택합니다.

또는

Watches 창에서 조사식을 선택하고 마우스 오른쪽 단추를 누른 후 Enable Watch를 선택합니다.

모든 조사식을 활성화하려면

  • Watches 창에서 마우스 오른쪽 단추를 누르고 Enable All Watches를 선택합니다. 모든 조사식이 활성화됩니다.


조사식 편집

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

기존 조사식을 변경하려면

  • 다음 작업 중 하나를 수행하십시오.

  • Watches 창에서 watch를 두 번 누릅니다.

  • watch를 한 번 눌러 선택하고 마우스 오른쪽 단추를 눌러 메뉴를 표시한 후 Edit Watch를 선택합니다.

  • <CTRL>E를 누릅니다.

  2. Watch Properties 대화 상자가 나타납니다. Watch Properties 설정에 설명된 대로 속성을 변경합니다.


조사식 삭제

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

조사식을 하나 또는 모두 삭제할 수 있습니다.

단일 조사식을 삭제하려면

  • Watches 창에서 watch you want to delete를 선택하고 <Delete> 키를 누릅니다. 조사식이 삭제됩니다.

모든 조사식을 삭제하려면

  • Watches 창에서 마우스 오른쪽 단추를 누르고 Delete all Watches를 선택합니다. 모든 조사식이 삭제됩니다.


Watches 마우스 오른쪽 단추 메뉴

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Watches 창에서 마우스 오른쪽 단추를 눌러 조사식용 명령이 포함된 마우스 오른쪽 단추 메뉴를 표시할 수 있습니다.

  • Edit Watch

  • Add Watch

  • Enable Watch

  • Disable Watch

  • Delete Watch

  • Enable All Breakpoints

  • Disable All Breakpoints

  • Delete All Breakpoints

  • Stay on Top – 이 옵션을 선택하면 창은 다른 모든 창의 위에 남아 있습니다.

  • Dockable– 이 옵션을 선택하면 Watches 창이 Breakpoint, Call Stacks 및 DBMS Output 창과 도킹할 수 있으며 탭을 통해 이 모든 창에 액세스할 수 있습니다.


Evaluate/Modify

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다. 현재 이 기능은 JDWP 디버깅에서 사용할 수 없습니다.

Evaluate/Modify 창을 사용하면 조사식을 설정하지 않고도 변수 값을 바로 볼 수 있습니다. 변수 값을 변경하고 실행을 계속할 수도 있습니다. 이 기능은 "FOR COUNTER_VAR IN 1..500 LOOP" 루프의 끝으로 루프 변수를 보내는 경우에 유용합니다. 이 경우에는 Counter_Var를 계산하고 새 값을 499로 설정합니다. 그러면 루프를 498번 더 단계별로 실행할 필요가 없습니다. 날짜 변수를 변경하려면 DD-MON-YY 또는 DD-MON-YYYY 형식으로 새 날짜를 입력하고 날짜를 작은 따옴표로 묶습니다. 예를 들어 '31-DEC-99'와 같습니다.

  • 계산할 변수가 로컬 변수가 아니라 패키지 수준 변수인 경우에는 Package Variable 확인란을 선택합니다.

Evaluate/Modify 창은 나머지 디버그 창에 도킹할 수 없습니다.


Just in Time 디버깅 개요

일반 디버깅을 수행할 때 Toad는 두 가지를 수행합니다. 첫 번째 Oracle 세션에서는 디버깅하려는 절차를 실행하기 시작하고, 두 번째 세션에서는 첫 번째 세션을 디버거에 담습니다.

Just in Time 디버깅을 사용하면 Visual Basic, Delphi, PowerBuilder, Developer/2000 등 모든 클라이언트 서버 응용 프로그램에서 작성 및 실행되는 PL/SQL 코드를 디버깅할 수 있습니다. 외부 응용 프로그램이 동일한 컴퓨터에 있어야 할 필요는 없습니다.

Just in Time 디버깅은 PL/SQL Debugger와 함께 사용됩니다. 현재 이 기능은 JDWP Debugger와 호환되지 않습니다.

이 기능은 클라이언트 서버 응용 프로그램에서 커서와 같이 Toad에서 쉽게 시뮬레이트할 수 없는 복잡한 매개 변수를 사용하여 저장된 프로그램을 호출하는 경우에 매우 유용합니다. Toad 내에서 복잡한 환경을 시뮬레이트하는 대신 외부 응용 프로그램에 연결한 후 자체 환경에서 코드를 디버깅할 수 있습니다.

관련 항목

PL/SQL Debugger 개요

외부 응용 프로그램에 첨부하기 위한 요구 사항

디버깅용으로 외부 세션 첨부


외부 응용 프로그램에 첨부하기 위한 요구 사항

초기화 전

외부 세션에서 디버거를 초기화하기 전에 'set serveroutput off' 명령을 사용하여 서버 출력을 비활성화해야 합니다. 서버 출력 캡처를 활성화하면 DBMS_OUTPUT 패키지에 대한 호출이 발생할 때마다 호출을 디버깅하기 위해 Oracle이 고정됩니다. 그러면 응용 프로그램이 별다른 이유 없이 고정된 것처럼 보입니다.

초기화

Debug 모드를 초기화하려면 외부 응용 프로그램에서 다음 세 가지 명령을 실행해야 합니다.

ALTER SESSION SET PLSQL_DEBUG=TRUE

id := dbms_debug.initialize('TOAD')

dbms_debug.debug_on;

여기서 TOAD는 ID 문자열로 바꿀 수 있습니다. 이 매개 변수를 생략하면 초기화 반환 값이 Session ID로 사용됩니다. 이 ID 문자열도 Debug menu|Attach External Session에서 Toad에 입력해야 합니다.

ALTER SESSION 명령(SQL)은 별도로 실행해야 하지만, dbms_debug.initialize 및 dbms_debug.debug_off(PL/SQL)는 동일한 PL/SQL 블록에 넣을 수 있습니다.

모든 프로시저를 디버그를 사용하여 컴파일한 경우에는 ALTER SESSION 명령을 생략할 수 있습니다.

외부 응용 프로그램 실행 후

외부 응용 프로그램에서 디버깅이 필요한 코드를 실행하고 나면 다음 명령을 실행해야 합니다.

dbms_debug.debug_off

그렇지 않으면 이 응용 프로그램에서 이후에 제출하는 모든 PL/SQL 코드가 디버그 모드에서 실행됩니다. 그러면 Toad가 다시 첨부될 때까지 응용 프로그램이 정지됩니다.

관련 항목

Just in Time 디버깅 개요

PL/SQL Debugger 개요

디버깅용으로 외부 세션 첨부


디버깅용으로 외부 세션 첨부

다음 절차에서 5단계를 4단계보다 먼저 수행할 수 있지만 그러면 Session ID 전달이 어려워집니다(하드 코딩을 하지 않는 한). 중요한 것은 다음 시점에서 응용 프로그램과 디버거가 동기화되어 있어야 한다는 것입니다.

  • 응용 프로그램이 디버그 모드에서 PL/SQL 코드를 실행할 때

그리고

  • ATTACH 명령이 Toad에서 발행될 때

주: 외부 세션에서 디버거를 초기화하기 전에 'set serveroutput off' 명령을 사용하여 서버 출력을 비활성화해야 합니다. 서버 출력 캡처를 활성화하면 DBMS_OUTPUT 패키지에 대한 호출이 발생할 때마다 호출을 디버깅하기 위해 Oracle이 고정됩니다. 그러면 응용 프로그램이 별다른 이유 없이 고정된 것처럼 보입니다.

디버깅용으로 외부 세션을 첨부하려면

  1. 외부 응용 프로그램 데이터베이스에 연결합니다.

  2. Toad에서 외부 응용 프로그램으로 같은 데이터베이스 인스턴스에 연결합니다. 디버깅할 코드가 Editor에 표시됩니다.

  3. Toad의 Debug 메뉴에서 Attach External Session을 선택합니다.

  4. Initialize 문에서 전달 또는 반환되는 것과 같은 Session ID를 입력합니다. Toad에서는 응용 프로그램의 PL/SQL 코드 실행을 기다립니다.

  5. 응용 프로그램에서 디버깅할 저장된 프로그램을 호출하는 PL/SQL 블록을 실행합니다. Toad에서 모든 디버깅 명령을 활성화합니다.

  6. PL/SQL 코드 실행이 완료되면 Execution complete 메시지가 표시되고 외부 응용 프로그램이 일반 작업을 계속하는지 확인합니다.

관련 항목

Just in Time 디버깅 개요

PL/SQL Debugger 개요

외부 응용 프로그램에 첨부하기 위한 요구 사항


Call Stack 창

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Call Stack 창에는 연속된 함수와 프로시저가 호출됨에 따라 호출되는 순서로 표시되며, 최근 함수 또는 프로시저가 맨 위에 표시됩니다.

각 프로시저 이름의 끝에는 프로시저 내의 현재 줄 번호가 표시됩니다. 따라서 프로시저 A의 5줄에서 프로시저 B로 한 단계씩 실행한 경우 호출 스택은 다음과 같습니다.

프로시저 B(1)

프로시저 A(5)

Call Stack 창은 Watches, Breakpoints 및 DBMS Output 창에 도킹할 수도 있고 끌어서 따로 놓을 수도 있습니다. 이 모든 창을 그룹으로 묶으면 Editor 창의 아래쪽에 도킹시킬 수 있습니다.

주: 아래쪽으로부터 한 번에 하나씩 창의 도킹을 해제한 경우, Toad에서는 도킹이 해제된 것을 기억하지 못합니다. 모든 디버깅 창의 도킹을 한꺼번에 해제하려면 도킹된 창의 왼쪽에 있는 세로 막대를 두 번 누릅니다.

호출 스택에 액세스하려면

  • Debug 메뉴에서 Call Stack을 선택합니다. Call Stack 탭이 선택된 상태로 Breakpoints, Watches, Call Stack & DBMS Output 창이 나타납니다.

주: Oracle 8.0.5 이하를 사용하는 경우 Call Stack 탭을 보려면 init.ora 파일에서 BLANK_TRIMMING 값을 TRUE로 설정해야 합니다. 그렇게 설정하지 않으면 Call Stack 메뉴 옵션이 회색으로 표시되고 탭에는 Breakpoints, Watches, Call Stack 및 DBMS Output 창에는 탭이 표시되지 않습니다.


여러 프로시저 탐색

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Call Stack 창을 사용하여 여러 프로시저 사이를 탐색할 수 있습니다.

볼 프로시저를 선택하려면

  • 다음 중 한 가지 방법을 선택합니다.

  • procedure name을 두 번 누릅니다.

  • procedure를 선택하고 마우스 오른쪽 단추를 눌러 Right-Click Menu를 표시한 다음 View Source를 선택합니다.

Navigator 단추 사용

Tabs 도구 모음에 있는 Navigator 단추를 사용하여 Call Stack을 탐색할 수도 있습니다.


트리거에서 매개 변수 설정

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

트리거가 실행되면 미리 프로그램된 작업이 테이블에서 수행됩니다. 트리거를 디버깅하는 일은 프로시저나 함수를 디버깅하는 것과 다릅니다. 첫째, Set Parameters 창에 입력하는 값은 인수 값이 아니라 열 값입니다.

트리거를 실행하려면 먼저 트리거에 매개 변수를 설정해야 합니다. 트리거 유형에 따라 필요한 매개 변수 집합도 다릅니다.

주: 그리드의 Value 열에 값을 입력할 때 값을 다시 NULL로 만들려면 NULL을 입력합니다. 값을 삭제하기만 하면 값은 빈 문자열로 돌아갑니다.

INSERT

INSERT 트리거를 디버깅할 때 입력하는 값은 삽입할 값으로 사용됩니다. 그러면 디버깅 중에 데이터베이스가 변경되지 않도록 레코드가 롤백됩니다.

INSERT 트리거를 디버깅하려면

  • Value 필드에 삽입할 값을 입력합니다.

열 값을 입력할 때까지는 INSERT INTO… 코드가 유효하지 않습니다.

UPDATE

SET… 절과 WHERE… 절의 값을 입력합니다. 열 값을 입력할 때까지는 UPDATE TABLE… 코드가 유효하지 않습니다.

UPDATE 트리거를 디버깅하려면

  1. Value 필드에 SET… 절의 값을 입력합니다.

  2. WHERE 값 필드에 WHERE… 절의 값을 입력합니다.

디버깅 중에 데이터베이스가 변경되지 않도록 업데이트된 레코드가 롤백됩니다.

DELETE

DELETE 트리거를 디버깅하는 경우에는 WHERE… 절의 값을 입력해야 합니다.

DELETE 트리거를 디버깅하려면

  • Value 필드에 WHERE… 값을 입력합니다. 열 값을 입력할 때까지는 DELETE FROM… 코드가 유효하지 않습니다.

여러 트리거 속성

여러 BEFORE 또는 AFTER 작업이 있는 경우에는 트리거 유형에 따라 우선 순위가 결정되며 다음과 같이 수행됩니다.

  • INSERT

  • UPDATE

  • DELETE


프로시저 또는 함수 디버깅

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

프로시저 또는 함수 디버깅은 가장 간단한 디버깅 프로시저입니다. 하지만 여기에도 여러 방법을 적용할 수 있습니다. 이 자습서에서는 가장 일반적인 명령과 방법 몇 가지를 설명합니다. 이 자습서의 목적은 PL/SQL 코드를 가르치는 것이 아니라 Toad Debugger의 기본 기능을 보여주는 것입니다.

Editor에 코드 입력

  1. 아래에 있는 코드를 복사하여 Editor에 붙여넣습니다. 붙여넣을 때, 끝에 추가된 저작권 통지는 삭제합니다.

CREATE OR REPLACE PROCEDURE Loopproc ( INVAL NUMBER) IS

TMPVARNUMBER;

TMPVAR2NUMBER;

TOTALNUMBER;

BEGIN

TMPVAR:=0;

TMPVAR2:=0;

TOTAL:=0;

FOR LCV IN 1 .. INVAL LOOP

  TOTAL :=2*TOTAL + 1 - TMPVAR2;

  TMPVAR2 :=TMPVAR;

  TMPVAR :=TOTAL;

END LOOP;

DBMS_OUTPUT.PUT_LINE('TOTAL IS: ' || TOTAL);

END Loopproc;

/

  2. File 메뉴에서 Save As를 선택하여 이 프로시저를 저장합니다. 이제 맨 위 탭에 "Loopproc.prc"가 표시됩니다.

  3. Compile 단추 [image] 를 누릅니다. 코드가 컴파일되며 실행할 준비가 됩니다. 매개 변수를 설정하려면 먼저 코드를 컴파일해야 합니다.

계속


조사식 추가

조사식을 추가하는 방법에는 여러 가지가 있습니다. 다음 단계에서는 각각 다른 방법으로 세 개의 조사식을 추가합니다. 나중에 그 중에서 가장 적절한 방법을 선택할 수 있습니다.

  1. 조사식은 변수에 추가해야 합니다. 코드의 둘째 줄에서 TMPVAR라는 단어를 누르고 Add Watch 아이콘 [image] 을 누릅니다. Watches 창이 나타나고 조사식이 추가됩니다.

  2. TMPVAR2에 조사식을 추가합니다. 이번에는 <CTRL>F5를 눌러 커서에 위치에서 조사식을 추가합니다.

  3. 그리고 마지막으로 TOTAL 변수에 조사식을 추가합니다. Debug 메뉴에서 Add Watch를 선택합니다.

돌아가기 계속


Set Parameters

일부 PL/SQL에는 코드를 실행하기 전에 설정해야 하는 가변 매개 변수가 있습니다. 이 변수 값을 설정하지 않은 경우 코드를 실행하면 Oracle 오류가 발생합니다. Loopproc 프로시저에서 INVAL 변수를 설정해야 합니다.

  1. Set Parameters [image] 단추를 누릅니다.

주: 설정할 매개 변수가 있는 경우에 코드 실행을 선택하면 Set Parameters 창이 자동으로 표시됩니다. 이 자습서에서 다루지 않는 매개 변수도 다수 포함되어 있습니다. 그런 매개 변수에 대한 자세한 내용은 매개 변수 설정을 참조하십시오.

  2. 코드에 사용자 정의 매개 변수가 설정되어 있기 때문에 Set parameters가 나타납니다. 이 경우 INVAL에서는 코드를 실행할 횟수를 정의합니다. INVAL 변수의 Value 필드를 누릅니다. NULL이 강조표시됩니다.

  3. 값을 10으로 설정합니다. value 필드에 10을 입력합니다.

  4. OK를 누릅니다. 값이 설정되고 Set Parameters 창이 닫힙니다.

돌아가기 계속

관련 항목

매개 변수 설정


코드 실행 및 출력 표시

  1. Run [image] 단추를 누릅니다. 참조된 개체를 디버그 정보를 사용하여 컴파일할 것인지를 묻는 확인 상자가 나타납니다. Yes를 누릅니다. 코드가 컴파일된 후 실행되지만 너무 빨라서 조사식을 볼 수는 없습니다.

  2. 코드가 실행되었는지 확인하려면 Breakpoints, Watches, Call Stacks & DBMS Output 창에 있는 DBMS Output 탭을 누릅니다. 창에 다음이 표시됩니다.

돌아가기 계속


Watch Properties 변경

  1. Tmpvar2의 Watch Properties를 공학 형식으로 변경합니다. Watches 탭을 누릅니다. Watches 창에서 Tmpvar2를 두 번 누릅니다. Watch Properties 창이 나타납니다.

  2. Format 영역에서 Scientific을 누릅니다. OK를 눌러 변경 사항을 저장하고 창을 닫습니다.

돌아가기 계속


조사식 비활성화

따르지 않을 조사식을 비활성화할 수 있습니다. Tmpvar의 조사식을 비활성화합니다.

  1. Watches 창에서 tmpvar를 두 번 누릅니다. Watch Properties 대화 상자가 나타납니다.

  2. Enabled 확인란을 누릅니다. 체크 표시가 사라집니다.

  3. OK를 누릅니다. Watch Properties 대화 상자가 닫힙니다. Tmpvar가 Watch 창에서 회색으로 표시됩니다.

주: 비활성화한 조사식을 활성화하려면 Watches 창에서 watch를 눌러 선택한 후 Watch 창을 마우스 오른쪽 단추로 누르고 메뉴에서 Enable을 선택합니다.

돌아가기 계속


코드 단계별 실행

코드 단계별 실행

  1. 설정한 조사식을 실제로 보려면 코드를 단계에 따라 줄 단위로 실행해야 합니다. Shift-F7을 몇 번 눌러 코드를 단계별로 실행합니다. Shift-F7을 누를 때마다 조사식의 값이 변경되는 것을 확인합니다.

변수 값 확인

조사식으로 표시한 변수의 값은 Watches 창에 표시됩니다. 하지만 현재 조사하고 있지 않은 변수의 값을 확인할 수도 있습니다. 방법은 쉽습니다.

  2. 마우스 포인터를 INVAL 변수 위에 둡니다. 잠시 후 변수 값이 포함된 작은 팝업이 나타납니다.

돌아가기 계속


중단점 추가

이 자습서의 다음 섹션에서는 중단점에 대해 중점적으로 설명합니다. 여기서는 Introductory 및 Watches 섹션을 완료했다고 가정합니다.

  1. Breakpoints, Watches, Call Stacks & DBMS Output창에서 Breakpoints 탭을 누릅니다. 그러면 설정한 중단점을 볼 수 있습니다.

  2. 거터에 줄 번호가 표시됩니다.

  3. Edit 메뉴에서 Editor Options를 선택합니다. Editor Options – PLSQL 창이 나타납니다.

  4. 왼쪽 패널에서 General Options를 누릅니다. 오른쪽 패널에서 Display Options를 두 번 누릅니다. 표시 옵션 목록이 나타납니다.

  5. Display line numbers in Gutter 옆에 있는 확인란이 비어 있으면 눌러서 옵션을 켭니다.

  6. Show Gutter 옆에 있는 확인란이 비어 있으면 눌러서 이 옵션도 켭니다. OK를 누릅니다. 이제 절차 옆의 회색 거터에 줄 번호가 표시됩니다.

  3. 11 줄에 중단점을 추가합니다. 11 줄 옆의 Gutter를 누릅니다. 코드 줄이 강조표시되고 거터에 Stop Sign 아이콘이 나타납니다. 중단점이 적용되었습니다.

  4. 12 줄에 중단점을 추가합니다. 이번에는 코드 줄을 누른 후 F5를 누릅니다.

  5. Run [image] 을 누릅니다. 코드가 11 줄에서 중지됩니다. 다시 Run을 누르면 코드가 12 줄에서 중지됩니다.

돌아가기 계속


중단점 비활성화

조사식과 마찬가지로, 중단점 역시 일시적으로 비활성화할 수 있습니다.

  1. 12줄에 있는 중단점을 비활성화합니다. Breakpoints 창에서 12줄을 두 번 누릅니다. Breakpoint Properties 대화 상자가 나타납니다.

  2. Enabled 확인란을 누릅니다. 체크 표시가 사라집니다.

  3. OK를 누릅니다. Breakpoint Properties 대화 상자가 닫힙니다. 이제 12줄은 Breakpoints 창에서 회색으로 표시됩니다.

주: 비활성화한 중단점을 활성화하려면 Breakpoints 창에서 중단점을 눌러 선택한 후 Breakpoints 창을 마우스 오른쪽 단추로 누르고 메뉴에서 Enable을 선택합니다.

  4. 중단점을 비활성화하는 대신 완전히 삭제할 수 있습니다. Procedure Editor에서 11줄 옆의 여백에 있는 Stop sign [image] 아이콘을 누릅니다. 중단점이 제거됩니다.

돌아가기 계속


줄 번호 편집

새 중단점을 작성하고 기존 중단점을 삭제하는 대신 기존 중단점의 줄 번호를 변경할 수 있습니다.

  1. Breakpoints 창에서 12줄 중단점을 두 번 누릅니다. Breakpoint Properties 대화 상자가 나타납니다.

  2. Line number 상자를 두 번 누릅니다. 줄 번호가 강조표시됩니다. 번호를 11로 변경합니다. Breakpoint를 활성화합니다.

  3. OK를 누릅니다. 대화 상자가 닫히고 중단점이 11줄로 이동합니다.

돌아가기 계속


Passcount 사용

루프를 통해 일정 횟수가 반복된 후에만 중단되도록 중단점을 설정할 수 있습니다. 지정된 횟수(예를 들어 7번)만큼 반복된 후 중단되도록 설정할 수 있기 때문에 매우 긴 루프 코드에서 작업하는 경우에 유용합니다.

  1. Breakpoints 창에서 11줄에 있는 breakpoint [image] 아이콘을 두 번 누릅니다.

  2. Passcount 필드를 두 번 누릅니다. 7을 입력합니다.

  3. Run [image] 아이콘을 누릅니다. 프로시저는 루프를 6번 반복하고 7번째로 11줄에 도달하기 전에 중지됩니다.

  4. Call Stack 탭을 누릅니다. LOOPPROC(11)이라고 되어 있어야 합니다. 이 값은 실행을 중지한 줄을 표시합니다.

  5. Watches 탭을 누릅니다. 조사식이 아직 설정되어 있고 실행이 완료되지 않았기 때문에 값이 있습니다.

  6. Run 아이콘을 다시 누릅니다. "Execution terminated"라는 메시지가 표시된 대화 상자가 나타납니다. 이 메시지는 프로시저 실행이 완료된 것을 나타냅니다.

돌아가기 계속


조건부 중단점 사용

조건이 충족되지 않으면 실행이 중지되지 않도록 중단점에 조건을 설정할 수 있습니다.

  1. Breakpoints 창에서 11줄에 있는 중단점을 두 번 누릅니다.

  2. Passcount 필드를 두 번 누르고 7을 0으로 바꿉니다.

  3. Condition 필드에 LCV>=7을 추가합니다. 이제 LCV가 7 이상이 되면 11줄에서 실행이 중단됩니다.

  4. Run 아이콘을 누릅니다. 11줄에서 실행이 중지됩니다. 포인터를 LCV 변수 위에 둡니다. 값은 7이어야 합니다.

  5. Run 아이콘을 다시 누릅니다. 이제 LCV가 7보다 큰 8이기 때문에 실행이 다시 중지됩니다.

  6. 중단점을 삭제하지 않고 비활성화합니다. Breakpoints 창에서 breakpoint를 선택하고 마우스 오른쪽 단추를 누른 후 Disable breakpoint를 선택합니다. 중지 기호 아이콘을 사용할 수 없습니다.

  7. Run 아이콘을 눌러 실행을 완료합니다. 실행이 종료되었다는 내용의 대화 상자가 나타나면 OK를 누릅니다.

돌아가기 계속


Passcount와 조건 함께 사용

중단점에 Passcount와 조건을 조합하여 사용할 수 있습니다. 이 경우에는 Passcount에서 코드가 줄 번호를 지난 횟수가 아니라 조건이 충족된 횟수를 계산한다는 점에 주의해야 합니다.

  1. Set Parameters를 누릅니다. INVAL 값을 17로 변경한 후 OK를 누릅니다.

  2. Breakpoints 창에서 11줄에 있는 중단점을 두 번 누릅니다.

  3. Enabled 상자를 선택하여 중단점을 활성화합니다.

  4. 중단점에서 조건을 그대로 두고 passcount of 9를 추가합니다. OK를 누릅니다. Breakpoints Properties 창이 닫힙니다.

이제 중단점의 passcount는 9이고 조건은 LCV>=7입니다.

  5. 코드를 다시 실행합니다. 실행은 9번째 반복에서 중지됩니다. LCV 위에 커서를 두고 값이 15인 것을 확인합니다. LCV>=7가 충족된 것이 9번째이기 때문입니다.

돌아가기

프로시저 또는 함수 디버깅으로 돌아가기


패키지 디버깅

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

패키지 디버깅은 프로시저나 함수를 디버깅하는 것과 비슷하게 작동합니다. 그러나 프로시저 또는 함수 그룹 및 해당 작업 방법을 디버깅하는 것이기 때문에 조금 다릅니다. 이 자습서에서는 조사식과 중단점, 그리고 프로시저 또는 함수 디버깅 자습서에 설명된 기능에 익숙한 것으로 가정합니다.

  1. 새 Procedure Editor를 엽니다.

  2. 아래에 있는 코드를 Editor로 복사합니다. 이것이 사용할 패키지입니다. 끝에 추가된 저작권 통지는 삭제합니다.

CREATE OR REPLACE PACKAGE Trigonometry IS

FUNCTION SINE (Opposite IN NUMBER, Hypotenuse IN NUMBER, Message OUT VARCHAR2) RETURN NUMBER;

FUNCTION COSINE (Adjacent IN NUMBER, Hypotenuse IN NUMBER, Message OUT VARCHAR2) RETURN NUMBER;

FUNCTION TANGENT (Opposite IN NUMBER, Adjacent IN NUMBER, Message OUT VARCHAR2) RETURN NUMBER;

NumCallsNUMBER:=0;

END Trigonometry;

/

CREATE OR REPLACE PACKAGE BODY Trigonometry AS

FUNCTION SINE (Opposite IN NUMBER, Hypotenuse IN NUMBER, Message OUT VARCHAR2) RETURN NUMBER IS

tmpSineNUMBER;

BEGIN

  NumCalls :=NumCalls +1;

IF (Opposite <= 0) OR (Hypotenuse <= 0)

 OR(OppositeISNULL)OR(HypotenuseISNULL)THEN

Message:='Opposite and Hypotenuse must be numbers > 0';

RETURN NULL;

 ELSE

/*Calculate the Sine*/

tmpSine:=Opposite/Hypotenuse;

IF tmpSine BETWEEN -1 AND 1 THEN

Message:='Success';

   RETURNtmpSine;

ELSE

Message:='Unreasonable Sine: ' || tmpSine;

RETURN NULL;

END IF;

 ENDIF;

END SINE;

FUNCTION COSINE (Adjacent IN NUMBER, Hypotenuse IN NUMBER, Message OUT VARCHAR2) RETURN NUMBER IS

tmpCosineNUMBER;

BEGIN

  NumCalls :=NumCalls +1;

 IF(Adjacent<=0) OR (Hypotenuse <= 0)

 OR(AdjacentISNULL)OR(HypotenuseISNULL)THEN

Message:='Adjacent and Hypotenuse must be numbers > 0';

RETURN NULL;

 ELSE

 /*Calculate the Cosine*/

  tmpCosine :=Adjacent/Hypotenuse;

 IFtmpCosine BETWEEN -1 AND 1 THEN

   Message := 'Success';

   RETURN tmpCosine;

 ELSE

  Message :='Unreasonable Cosine: ' || tmpCosine;

 RETURNNULL;

 ENDIF;

 ENDIF;

END COSINE;

FUNCTION TANGENT (Opposite IN NUMBER, Adjacent IN NUMBER, Message OUT VARCHAR2) RETURN NUMBER IS

BEGIN

  NumCalls :=NumCalls +1;

 IF(Adjacent<=0) OR (Opposite <= 0)

 OR(AdjacentISNULL)OR(OppositeISNULL)THEN

Message:='Opposite and Adjacent must be numbers > 0';

RETURN NULL;

 ELSE

/*Return the value of the tangent*/

   Message :='Success';

 RETURNOpposite/Adjacent;

END IF;

END TANGENT;

END Trigonometry;

/

  3. Compile 단추 [image] 를 눌러 패키지를 컴파일합니다. 패키지 위에 있는 탭에 Trigonometry가 나타나고 패키지의 구조가 왼쪽 패널에 나타납니다.

계속


적절한 옵션 설정

이 패키지 예를 디버깅하기 전에 Debugger 옵션을 설정해야 합니다.

주: 사용자가 자신의 패키지를 디버깅하는 경우에는 설정이 필요하지 않을 수도 있고, 디버깅 프로시저의 다른 단계에서 옵션을 설정할 수도 있습니다.

  1. View 메뉴에서 Toad Options를 선택합니다.

  2. 왼쪽 패널에서 Editor|Debug를 선택합니다. 오른쪽 패널에 debugging options 패널이 나타납니다.

  3. Step through package initialization이 선택되어 있는지 확인합니다. 그러면 코드를 단계별로 실행할 때 초기화도 단계별로 실행하게 됩니다. 이 옵션을 선택하지 않으면 Toad에서 초기화를 실행한 후 디버깅하려고 선택한 프로시저만 단계별로 실행합니다.

  4. OK를 누릅니다. Options 창이 닫힙니다.

돌아가기 계속


조사식 및 중단점 설정

중단점 또는 조사식을 설정합니다.

  1. 22줄에 중단점을 설정합니다.

  2. 6줄에 있는 Numcalls 변수에 조사식을 설정합니다. 이 변수는 패키지 변수입니다. 이 변수를 조사하려면 속성을 변경해야 합니다.

  3. Watches 창에서 Numcalls에 있는 조사식을 두 번 누릅니다. Watches Properties 대화 상자가 나타납니다.

  4. Package Variable 확인란을 누릅니다. OK 단추가 회색으로 표시되는 것을 확인합니다. 이 옵션을 활성화하려면 패키지를 선택해야 합니다.

  5. Owner Name에 현재 스키마 소유자가 자동으로 입력됩니다. 필요한 경우 드롭다운 메뉴를 사용하여 변경합니다. 이제 정확한 값이 표시되어야 합니다. 드롭다운 Package 메뉴에서 Trigonometry를 선택한 후 OK를 누릅니다. 그러면 패키지 변수에 조사식이 작성됩니다.

  6. 22줄에 있는 tmpSine 변수에 조사식을 추가합니다.

돌아가기 계속


실행할 프로시저 또는 함수 선택

패키지를 디버깅할 때에는 한 번에 한 프로시저 또는 함수만 디버깅할 수 있습니다. 패키지가 초기화 프로세스를 실행합니다(또는 Options 창에서 옵션이 선택된 경우 한 단계씩 실행 – 자세한 내용은 이 자습서의 적절한 옵션 설정 참조).

  1. 도구 모음에 있는 Set Parameters [image] 아이콘을 누릅니다. Set Parameters 창이 나타납니다.

  2. 왼쪽 창에서 Sine을 누릅니다. 그러면 이 프로시저가 선택됩니다. 오른쪽 창에서 인수가 변경되는 방식을 확인합니다.

  3. 반대편의 value 필드를 누릅니다. 15를 입력합니다.

  4. 사변의 value 필드를 누릅니다. 20을 입력합니다.

  5. OK를 누릅니다. Set Parameters 창이 닫힙니다.

돌아가기 계속


패키지 단계별 실행

  1. Shift-F7을 누릅니다. Toad는 Package 초기화를 다른 탭에서 열면서 한 단계씩 실행합니다. Numcalls 조사식이 NULL로 표시됩니다.

  2. Shift-F7을 다시 누릅니다. Toad가 SINE 프로시저로 이동합니다. 이제 Numcalls의 조사식이 0입니다.

  3. Shift-F7을 다시 누릅니다. Numcalls 조사식이 1로 올라가고 Toad 단계는 14줄로 이동합니다.

  4. Run 아이콘 [image] 을 누릅니다. Toad가 22줄의 중단점에서 중지합니다.

  5. Run을 다시 누릅니다. Toad에서 SINE 프로시저 실행을 완료하고 실행이 종료되었음을 알립니다. 모든 조사식은 "process not accessible"로 돌아갑니다.

패키지에 있는 다른 프로시저를 디버깅하려면 원하는 대로 조사식과 변수를 설정하고 Parameters 창의 왼쪽 창에서 적절한 프로시저를 선택합니다. 그런 다음 코드를 다시 단계별로 실행하고 원하는 결과가 나올 때까지 값을 변경합니다.

돌아가기

패키지 디버깅으로 돌아가기


Navigator

Navigator 패널

이 패널에는 활성 창에 있는 코드가 간략하게 표시됩니다. 나열된 항목을 눌러 Editor에 있는 해당 문으로 이동할 수 있습니다.

Navigator에 액세스하려면

  1. Editor 창을 마우스 오른쪽 단추로 누릅니다.

  2. Desktop Panels|Navigator를 선택합니다.

왼쪽 패널에는 Navigator 목록, 문 목록, Editor에 있는 개체 또는 패키지 내용이 포함되어 있습니다.

목록은 각 요소가 개별적으로 구분된 채로 계층으로 표시됩니다(이 요소 중 일부를 숨기려면 계층을 마우스 오른쪽 단추로 누르고 Configure Navigator Panel을 선택합니다. 코드에 있는 요소는 구분되어 다음과 같이 표시됩니다.

아이콘 | 의미
DDL | DDL 문
DML | DML 문
SQL | SQL 문
 | 프로시저
 | 함수
 | 상수
 | 커서
 | 예외
 | 필드
 | 매개 변수
 | 레코드
 | 하위 유형
 | 변수


Reload Object

reload object 옵션을 사용하면 PL/SQL 소스를 마찬가지로 데이터베이스에 존재하는 개체와 쉽게 동기화할 수 있습니다.

여러 방법 중 하나를 사용하여 개체를 다시 로드할 수 있습니다.

Navigator에서 개체를 다시 로드하려면

  1. Navigator 패널에서 다시 로드할 개체를 선택합니다.

  2. 마우스 오른쪽 단추를 누루고 Reload Object를 선택합니다.

Navigator에서 모든 개체를 다시 로드하려면

  1. Navigator 패널에서 다시 로드할 개체를 선택합니다.

  2. 마우스 오른쪽 단추를 누루고 Reload All Objects를 선택합니다.

도구 모음에서 다시 로드하려면

  1. Editor에서 다시 로드할 개체에 커서를 놓습니다.

  2. 도구 모음에서 Reload from Database [image] 단추를 누릅니다.


Navigator 패널 사용

Navigator 목록의 도구 모음에서 다음을 수행할 수 있습니다.

아이콘 | 의미
 | Navigator 목록을 새로 고칩니다.
 | Navigator 목록을 알파벳 순서대로 정렬합니다(누를 경우 항목이 알파벳 순서로 표시되고 누르지 않은 경우 목록이 소스 코드 순서로 표시됨).
 | Navigator 목록을 열린 상태로 고정하거나 슬라이드 방식으로 열고 닫을 수 있습니다.
 | Navigator 목록을 닫습니다.

이외에도 마우스 오른쪽 단추 메뉴에서 전체 트리를 확장하거나 축소할 수 있습니다.

전체 문을 표시하려면

  • Navigator에서 항목 위에 포인터를 놓습니다. 전체 문이 도구 서명으로 표시됩니다.

문으로 이동하려면

  • Navigator에서 문을 누르면 Editor의 해당 지점으로 커서가 이동합니다.

Navigator 패널을 새로 고치려면

  • 현재 파일을 저장합니다.

또는

Refresh [image] 단추를 누릅니다.

문 그룹화 및 정렬

Navigator 패널에서 문을 그룹화 및 정렬할 수 있습니다.

기본적으로 Group이 선택되고 Sort는 선택되지 않습니다.

주: Sort와 Group이 모두 선택된 경우 항목이 알파벳 순서대로 정렬되어 그룹화되므로 스크립트에 있는 동일한 유형의 모든 문이 단일 노드 아래에 놓입니다.

Group Similar

Group similar는 트리의 단일 노드 아래에서 단일 문 유형의 모든 연속 실행을 그룹화합니다(예를 들어 모든 연속 SELECT 문이 SELECT 노드 아래에서 그룹화됨). 또 다른 일련의 SELECT가 스크립트 아래에 더 멀리 떨어져 있는 경우 이러한 문은 별개의 SELECT 노드 아래에 놓입니다.

이 옵션은 기본적으로 선택되어 있습니다.

Sort

트리를 알파벳 순서대로 정렬하려면 Sort를 선택합니다. 이 옵션을 선택하지 않으면 트리 항목이 스크립트에 표시되는 순서대로 나타나도록 트리가 정렬됩니다.

관련 항목

Navigator 패널

Navigator 패널 구성


Navigator 옵션

Editor에서는 보려는 선언만 표시하도록 navigator 패널을 구성할 수 있습니다. 또한 작업 방식에 적합하도록 패널의 모양을 변경할 수 있습니다.

Configure Navigator 패널에 액세스하려면

  • Navigation 패널에서 마우스 오른쪽 단추를 누르고 Navigator Options를 선택합니다.

Configure Navigator 패널에서 아래 설명된 옵션을 설정할 수 있습니다.

General

Initial Node Expansion

이 영역에서는 처음 열었을 때 계층이 확장되는 방법을 선택할 수 있습니다. 한 수준, 모든 수준 또는 수준 없음으로 확장하도록 선택할 수 있습니다.

Exclude Comments

이 옵션을 선택하면 navigator 패널에 주석이 표시되지 않고 고유한 노드에 주석이 포함됩니다.

Lower-case text

이 옵션을 선택하면 선언이 소문자로 표시되고 선택하지 않으면 대문자로 표시됩니다. 소문자가 화면 공간을 적게 차지합니다.

이 옵션은 기본적으로 선택되어 있습니다.

Sort

이 옵션을 선택하면 선언이 계층 내에서 알파벳 순서로 정렬됩니다. 선택하지 않으면 선언은 코드에 선언된 순서대로 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Font

Navigator 트리에서 사용할 글꼴을 선택하려면 Font 단추를 누릅니다.

Statements

Statements 영역에서는 navigator에 표시할 항목을 선택할 수 있습니다. 기본적으로 모든 문 유형이 포함됩니다. 여기에는 패키지, 패키지 본문, 함수, SQL*Plus, 익명 블록 등이 포함됩니다. 또한 트리 구조에서 항목이 표시되는 순서를 다시 정렬할 수 있습니다.

트리 구조를 다시 정렬하려면

  1. 이동할 항목을 누릅니다.

  2. Up 또는 Down 단추를 눌러 표시에서 위로 또는 아래로 이동합니다.

PL/SQL Components

PL/SQL Components 영역에서는 navigator에 표시할 PL/SQL 항목을 선택할 수 있습니다. 기본적으로 모든 유형이 포함됩니다. 여기에는 상수, 예외, 하위 유형, 커서, 참조 커서, 로컬 하위 프로그램 등이 포함됩니다. 또한 트리 구조에서 항목이 표시되는 순서를 다시 정렬할 수 있습니다.

트리 구조를 다시 정렬하려면

  1. 이동할 항목을 누릅니다.

  2. Up 또는 Down 단추를 눌러 표시에서 위로 또는 아래로 이동합니다.

기타 구성 옵션

트리 구조 영역 옆에는 Navigator 패널을 구성하는 데 사용할 수 있는 여러 다른 옵션이 있습니다.

Include parameter direction

매개 변수가 입력 또는 출력 매개 변수인 경우 선언이 다르게 표시됩니다. 이 옵션을 선택하면 트리의 레이블이 약간 더 많은 공간을 차지합니다.

이 옵션은 기본적으로 선택되어 있습니다.

Include Datatype

이 옵션을 선택하면 선언 옆에 데이터 형식이 표시됩니다. 예를 들어 변수가 다음과 같이 표시됩니다.

이 옵션을 선택하지 않으면 변수가 다음과 같이 표시됩니다.


작업 콘솔

작업 콘솔을 사용하면 Toad 내에서 개체에 대한 모든 작업을 쉽게 수행할 수 있습니다. 현재는 다음 위치에서 이 콘솔을 사용할 수 있습니다.

  • 개체 팔레트

  • Object Search results 그리드

  • Data 그리드

  • Editor Navigator

  • Editor

작업 콘솔을 열 경우 Toad에서는 해당 개체에서 수행할 수 있는 모든 작업의 목록을 제공합니다. 따라서 SQL 결과를 사용하면서 개체 이름을 바꾸는 등의 작업을 쉽게 수행할 수 있습니다. 개체 팔레트가 열려 있는 상태에서 작업할 경우 도중에 개체를 쉽게 변경할 수 있습니다.

작업 결과

대부분의 작업은 즉시 수행됩니다. 예를 들어 Alter Object는 선택한 개체에 대한 alter 창을 엽니다. 데이터베이스에 즉각적이고 중대한 효과를 가져오는 Drop과 같은 작업에서는 수행되기 전에 확인 대화 상자가 열립니다. 스크립트 작성과 같은 작업은 필요한 모든 위치에 붙여넣을 수 있도록 클립보드에 스크립트를 작성합니다.

작업 콘솔을 사용하려면

  1. Toad 내에서 개체를 마우스 오른쪽 단추로 누릅니다.

주: Data 그리드 내에서 데이터베이스 개체가 포함된 셀을 마우스 오른쪽 단추로 누릅니다.

  2. Action Console을 선택합니다.

  3. 수행할 작업을 선택합니다.

  4. OK를 누릅니다.

관련 항목

개체 팔레트

개체 검색

Data 그리드


Editor 도구 모음

사용자의 작업 방식에 맞게 Toad editor의 도구 모음을 정렬하고 구성할 수 있습니다. editor에는 최소한의 표준 도구 모음만 표시됩니다. 그러나 사용할 수 있는 많은 명령이 있으므로 도구 모음에 원하는 대로 추가할 수 있습니다(자세한 내용은 도구 모음 변경 참조).

editor의 표준 도구 모음은 다음과 같습니다.

  • Desktop

  • Debugger 도구 모음(디버거가 포함된 Toad 버전용)

  • Edit 도구 모음

  • Execute (no debug) 도구 모음

  • Source Control 도구 모음

  • Standard Editor 도구 모음

  • Tabs 도구 모음

관련 항목

기본 도구 모음

도구 모음 변경


Current Schema 도구 모음

Current Schema 도구 모음을 사용하면 연결된 스키마가 아닌 스키마를 작업할 수 있습니다. 예를 들어 테스트 스키마에서 SQL 문을 테스트했으며 이제 연결을 끊었다가 다시 연결하지 않고 여러 다른 스키마에서 해당 문을 실행하려는 경우 이 기능이 유용합니다. 이 기능을 사용하려면 ALTER SESSION 권한이 있어야 합니다.

기본적으로 현재 스키마는 현재 연결로 설정됩니다. 이 명령을 사용할 경우 Toad에서는 다음 절차를 따릅니다.

  • ALTER SESSION SET current_schema 명령이 실행됩니다.

  • 이제 해당 스키마에 대해 sql 문을 실행할 수 있습니다.

  • ALTER SESSION SET current_schema 명령이 다시 실행되고 연결 스키마로 돌아갑니다.

주: 이 기능은 스크립트 실행 또는 디버깅 명령에서 작동하지 않습니다.

단추 | 명령
 | 드롭다운을 사용하여 스키마를 설정합니다.


Execute (no debug) 도구 모음

아이콘 | 명령
 | 매개 변수 설정
 | 기존 인수를 사용하여 프로시저 실행


Source Control 도구 모음

Source Control 도구 모음은 SQL Editor와 Editor 모두에서 표시될 수 있습니다. 이 도구 모음에는 기본 소스 제어만 포함되어 있으므로 Team Coding과 혼동하지 마십시오.

아이콘 | 명령
 | Source Control에서 체크아웃
 | Source Control로 체크인
 | 체크아웃 실행 취소
 | Source Control에서 최신 버전 가져오기
 | Source Control에 추가
 | Source Control의 활성 프로젝트 선택

관련 항목

기본 소스 제어

Team Coding 개요


Standard Editor 도구 모음

단추 | 명령
 | 이전에 저장한 SQL을 회수합니다.
 | Explain Plan을 실행합니다.
 | SQL Tuning Optimization 모듈을 사용하여 코드를 조정합니다.
 | 선택한 코드의 서식을 지정합니다.
 | 선택한 코드의 프로파일을 작성합니다.
 | 코드를 만듭니다.
 | 코드를 제거합니다.


Tabs 도구 모음

아이콘 | 명령
 | 새 editor 탭을 엽니다. 드롭다운을 사용하여 editor 유형을 선택합니다.
 | 활성 editor 탭을 닫습니다.
 | 호출 스택에서 개체를 뒤로 탐색합니다. 개체를 열기 위해 <Ctrl> 키와 마우스 단추가 사용되었습니다.
 | 호출 스택에서 개체를 앞으로 탐색합니다. 개체를 열기 위해 <Ctrl> 키와 마우스 단추가 사용되었습니다.


책갈피

책갈피를 사용하여 파일을 관리할 수 있습니다. 책갈피는 해당 줄로 쉽게 되돌아갈 수 있도록 Editor 내에서 위치를 표시합니다. 하나의 editor에서 최대 10개의 개별 책갈피를 설정할 수 있습니다.

팝업 메뉴를 통해서나 다음 키보드 명령을 사용하여 책갈피에 액세스합니다.

책갈피를 설정하려면

  • <CTRL><SHIFT>#을 누릅니다. 여기서 #은 0부터 9까지의 숫자입니다.

책갈피 숫자를 포함하는 작은 녹색 상자가 editor 거터에 표시됩니다.

책갈피로 되돌아가려면

  • <CTRL>#을 누릅니다. 여기서 #은 이전에 정의한 0과 9 사이의 책갈피입니다. #은 키보드의 숫자 행에서 호출해야 합니다. 숫자 키패드를 사용하면 책갈피가 호출되지 않습니다.

주: 이러한 키 입력에서는 기본 editor 키를 변경하지 않았다고 가정합니다.


포맷 도구

Toad 내에서 코드를 쉽게 포맷할 수 있습니다. Editor에서 이 작업을 수행할 수 있습니다.

Project Manager에서 한 번에 여러 스크립트를 포맷할 수 있습니다. (파일 포맷 참조.)

SELECT 구문을 포맷하려면

  1. 포맷할 구문을 강조표시합니다.

  2. 마우스 오른쪽 단추를 누르고 Formatting Tools를 선택합니다.

전체 스크립트를 포맷하려면

  1. 편집기에서 스크립트를 엽니다.

  2. 마우스 오른쪽 단추를 누르고 Formatting Tools를 선택한 다음 Format Code를 선택합니다.

관련 항목

파일 포맷

포맷 옵션


Uncomment Code Block

이 기능은 각 줄의 시작 부분에서 "--"을 제거하여 선택한 텍스트 블록에서 주석을 제거합니다. editor 탭의 마우스 오른쪽 단추 메뉴와 Edit 메뉴에서 이 기능을 사용할 수 있습니다.

관련 항목

Comment Code Block

Edit: Comment Block and Uncomment Block


Comment Code Block

이 기능은 각 줄 앞에 "--"을 추가하여 선택한 텍스트 블록을 주석으로 처리합니다.

editor 탭에서 마우스 오른쪽 단추를 눌러 이 기능에 액세스할 수 있습니다. 또한 이 기능은 Edit 메뉴에 있습니다.

관련 항목

Uncomment Code Block

Comment Block and Uncomment Block


Find Closing Block

이 기능은 닫는 괄호, 일치하는 BEGIN에 대한 END 또는 일치하는 IF에 대한 END IF를 찾습니다.

왼쪽 괄호, BEGIN 또는 IF를 선택/강조표시할 경우 이 기능은 일치하는 오른쪽 괄호, END 또는 END IF를 표시합니다.

닫는 블록을 찾으려면

  • Editor에서 마우스 오른쪽 단추를 누르고 Find Closing Block을 선택합니다.


XML 파서 스크립트 변경

XML Editor에서 사용하는 파서 스크립트를 변경할 수 있습니다.

파서 스크립트를 변경하려면

  1. View 메뉴에서 Toad Options를 선택합니다.

  2. 왼쪽 패널에서 Editor - Behavior를 누르고 Language Management 영역에서 구문 분석하는 데 사용할 언어를 선택합니다.

  3. OK를 누릅니다.


XML 서식 지정

editor에서 XML 코드의 서식을 지정할 수 있습니다.

XML 코드의 서식을 지정하려면

  1. 서식 지정할 코드를 선택합니다. editor에서 선택한 코드가 없을 경우 editor의 모든 모든 코드에 서식이 지정됩니다.

  2. 마우스 오른쪽 단추를 누르고 Format XML을 선택합니다.

서식 규칙

다음 형태의 노드는

<nodename att1="val"/>

다음과 같이 서식 지정됩니다.

<nodename att1="val"></nodename>

XML 파서의 관점에서 보면 이러한 형식은 동일합니다.

트리의 마우스 오른쪽 단추 메뉴에 있는 Duplicate node 기능은 비슷한 변환을 수행합니다.

관련 항목

XML Editor


XML Editor 옵션

XML editor에서 액세스할 수 있는 여러 옵션이 있습니다.

XML Editor 옵션에 액세스하려면

  1. XML Editor 개요에 설명된 대로 XML editor를 엽니다.

  2. 왼쪽 패널의 맨 위에서 Options [image] 단추를 누릅니다.

  3. 변경할 옵션을 선택합니다. 다음과 같은 옵션이 있습니다.

  4. Updating text when tree changes

  5. Moving Cursor in Source on Navigation Tree

  6. Defining Small files

  4. 옵션을 선택한 후 계속하려면 OK를 누릅니다.


Update Text when Tree Changes

이 영역의 옵션은 XML navigator 트리, subnodes 그리드 또는 attributes 그리드에서 사용자가 항목을 편집할 때 소스 텍스트가 자동으로 업데이트되는지 여부를 결정합니다.

주: 큰 파일의 경우 동기화 속도가 느려질 수 있습니다.

Always

소스 텍스트가 항상 자동으로 업데이트됩니다.

Only when XML is “Small”

텍스트의 총 크기가 작은 파일 정의에 지정된 크기보다 작거나 같을 경우에만 소스 텍스트가 자동으로 업데이트됩니다.

Never

소스 텍스트가 업데이트되지 않습니다. 왼쪽에서 변경이 있을 경우 사용자가 편의에 따라 텍스트를 업데이트할 수 있도록 synchronize 단추가 나타납니다.


탐색 트리의 소스에서 커서 이동

다음 옵션은 트리 보기에서 노드를 눌렀을 때 editor에서 텍스트의 해당 지점에 자동으로 스크롤되는 시점을 결정합니다.

주: 큰 파일의 경우 자동 탐색이 느려질 수 있습니다.

Always

트리 보기에서 노드를 누를 때마다 자동 탐색이 발생합니다.

Only when XML is “Small”

텍스트의 총 크기가 작은 파일 정의에 지정된 크기보다 작거나 같을 경우에만 자동 탐색이 발생합니다.

Never

navigator 트리를 눌렀을 때 소스 텍스트의 선택 항목이 영향을 받지 않습니다.


작은 파일 정의

다른 XML 옵션을 위한 용도로 Toad에서 "작은 파일"로 간주하는 파일을 정의할 수 있습니다.

작은 파일을 정의하려면

  1. XML Editor 옵션을 엽니다.

  2. "Small Files" are less than: 상자에 Toad에서 "작은 파일"로 간주해야 하는 파일의 크기를 지정합니다. 기본값은 1MB입니다.


SQL Results 그리드

SQL Results 그리드는 Editor의 아래쪽 부분에 있는 Data 탭과 Schema Browser의 오른쪽 detail 패널에 있는 Data 탭에서 볼 수 있습니다. 결과는 Editor Data 그리드에 표시됩니다. 질의 결과로 수행할 수 있는 여러 작업이 있습니다. 이러한 작업은 Toad Data 그리드 항목에 설명되어 있습니다.


AutoTrace

AutoTrace는 클라이언트에서 신속한 결과를 직접 표시하는 소형 버전의 SQL Trace입니다. Toad에서 결과는 Editor 또는 Query Builder 창 아래 표시됩니다.

AutoTrace를 활성화하려면

  • Editor를 마우스 오른쪽 단추로 누르고 AutoTrace 메뉴 옵션을 누릅니다.

AutoTrace 결과를 보려면

  • Editor 결과 영역에서 AutoTrace 탭을 누릅니다.

  • AutoTrace 탭을 볼 수 없는 경우 마우스 오른쪽 단추를 누른 다음 Desktop|Autotrace를 선택합니다.

AutoTrace results 패널이 표시되고 AutoTrace 모드에서 실행된 모든 문은 생성된 결과를 갖게 됩니다.

주: AutoTrace는 질의 결과에서 모든 데이터를 읽도록 강제합니다. 따라서 약간의 시간이 걸릴 수 있습니다. 쿼리에서 많은 수의 행을 반환하고 시간이 중요한 경우 AutoTrace를 사용하지 않는 것이 좋습니다.

AutoTrace results 영역에서 열을 정렬하거나 그리드를 인쇄하거나 결과를 클립보드에 복사할 수 있습니다.

AutoTrace는 Toad에서 제공하는 여러 최적화 기능 중 하나입니다. 이러한 기능에 대한 자세한 내용은 최적화 항목을 참조하십시오. 이 기능을 사용하려면 특정 V$ 보기에 액세스할 수 있어야 합니다. 자세한 내용은 V$ Tables Required: AutoTrace를 참조하십시오.


PL/SQL 코드를 디버깅하기 위한 DBMS Output

Oracle은 PL/SQL 코드를 디버깅하기 위한 기능이 있는 DBMS_OUTPUT이라는 특수하게 설계된 패키지를 제공합니다. 이 패키지는 PL/SQL 코드가 기록되는 버퍼를 사용합니다. 그런 다음 별도의 프로세스에서 버퍼를 질의하고 다음과 같은 내용을 표시합니다.

"The current value of x is 15"

코드를 한 단계씩 진행할 때가 아니라 프로시저의 실행이 완료된 후에만 출력이 표시됩니다. 중첩 프로시저 호출에서는 모든 프로시저의 실행이 완료되어야 모든 DBMS Output 내용이 표시됩니다.

Oracle DBA에게 문의하여 데이터베이스에서 DBMS_OUTPUT 패키지가 활성화되었는지 확인합니다.

Toad의 Editor 창에서 다음과 같은 PL/SQL 프로시저를 작성한다고 가정합니다.

CREATE ORREPLACE PROCEDURE TEST_DBMS_OUTPUTIS
x NUMBER;
BEGIN
for x in 1.. 5 loop
DBMS_OUTPUT.PUT_LINE( 'The value of x is '||to_char(x) );
end loop;
END TEST_DBMS_OUTPUT;
/

그런 다음 프로시저를 컴파일합니다. 정보를 디버그 버퍼에 기록하기 위한 DBMS_OUTPUT 패키지 내의 함수는 PUT_LINE입니다. 해당 줄을 입력하기 위한 바로 가기는 PL/SQL editor의 마우스 오른쪽 단추 메뉴에 있는 Blank Output Statement입니다. "Make Output Statement"는 텍스트가 이미 선택된 경우 사용됩니다.

이제 Editor 창으로 이동하여 테스트 프로시저를 실행하는 다음 익명 PL/SQL 블록을 입력합니다.

begin
test_dbms_output;
end;

주 Toad 도구 모음에서 "Open a new DBMS Output window" 단추를 눌러 DBMS Output 창을 엽니다. ON/OFF 단추는 기본적으로 ON(녹색)입니다. Toad에서는 5초마다 DBMS Output 내용을 스캔하여 표시합니다. ON/OFF 단추를 눌러 출력을 해제합니다. 이렇게 하면 단추가 빨간색으로 바뀝니다. 슬라이더를 사용하여 빈도를 2초부터 15까지 조정할 수 있습니다.

F9 키를 사용하여 Editor 창에서 익명 PL/SQL 블록을 실행합니다.

1초 또는 2초 후에 DBMS Output 창에 다음이 표시됩니다.

The value of x is 1

The value of x is 2

The value of x is 3

The value of x is 4

The value of x is 5

DBMS Output 창을 보려면

  • 아래쪽 창에서 마우스 오른쪽 단추를 누르고 Desktop을 선택한 다음 DBMS Output을 선택합니다.


최적화

Toad에서는 질의를 최적화하거나 서버에 대한 성능 통계를 보는 데 도움이 되는 여러 기능이 제공됩니다. Toad에서 이러한 통계 및/또는 Oracle 유틸리티에 액세스할 수 있지만 이 섹션에서는 결과를 해석하는 방법이 아니라 Toad 내의 기능을 사용하는 방법만 설명합니다. SQL Tuning에 대한 뛰어난 안내서로 추천할 만한 책은 Prentice Hall Press에서 제공하는 Guy Harrison의 Oracle SQL - High Performance Tuning입니다. 이 책에서는 이러한 기능 중 대부분을 자세하게 설명하고 있습니다.

Explain Plan

문을 조정하기 위해 Oracle 내에서 제공되는 가장 유용한 클라이언트 쪽 기능입니다. Explain Plan은 Oracle에서 문을 처리하는 경로와 순서를 보여 줍니다. 여러 문 변형에 대한 Explain Plan을 처리하여 조정이 실행에 끼치는 영향을 알 수 있습니다. 자세한 내용은 Explain Plan 항목을 참조하십시오.

AutoTrace

AutoTrace는 클라이언트에서 신속한 결과를 직접 표시하는 소형 버전의 SQL Trace입니다. Toad에서 결과는 Editor 창 아래 표시됩니다. AutoTrace를 활성화하려면 Editor를 마우스 오른쪽 단추를 누르고 AutoTrace 메뉴 옵션을 누릅니다. AutoTrace results 패널이 표시되고 AutoTrace 모드에서 실행된 모든 문은 생성된 결과를 갖게 됩니다.

주: AutoTrace는 질의 결과에서 모든 데이터를 읽도록 강제합니다. 쿼리에서 많은 수의 행을 반환할 경우 AutoTrace를 사용하지 않는 것이 좋습니다.

SQL Trace(tkprof)

SQL Trace는 문에 대한 CPU, IO 요구 사항 및 리소스 사용을 표시하는 서버 쪽 추적 유틸리티입니다. SQL Trace는 AutoTrace보다 훨씬 더 완벽한 유틸리티이지만 출력 파일이 서버에서 작성되기 때문에 결과를 보는 것이 어려울 수 있습니다. Editor의 마우스 오른쪽 단추 메뉴에서 현재 Toad 세션에 대해 SQL Trace를 활성화할 수 있습니다.

Server Statistics

server statistics 창에는 Oracle V$ 테이블을 사용한 Wait, Latch 및 파생된(계산된) 통계가 표시됩니다. 이 창의 필수 테이블에 액세스하는 데 문제가 있는 경우 힌트와 팁: 테이블 없음 오류 를 참조하십시오.

Optimizer Mode

이 옵션은 현재 세션의 Optimizer 모드를 선택하는 Editor의 마우스 오른쪽 단추 옵션입니다. 이 옵션은 세션 또는 optimizer 설정 기간 동안에 모든 질의(Toad의 자체 질의 포함)에 영향을 줍니다. 자세한 내용은 Oracle7 Server Concepts 매뉴얼을 참조하십시오.

주: Optimizer 모드는 Oracle 10g 데이터베이스에서 사용할 수 없습니다. 따라서 10g 데이터베이스에 연결된 경우 Toad에서는 이 옵션을 비활성화합니다.

SQL Tuning

SQL Tuning 패키지가 포함된 Toad 버전이 있는 경우 코드를 최적화하는 데 도움이 되도록 해당 패키지를 사용할 수 있습니다. 자세한 내용은 SQL Tuning을 참조하십시오.


행 번호

Toad에서는 해당 옵션이 선택된 경우 Editor Data 그리드에서 행 번호를 표시합니다. View > Options > Data Grids 탭 > Show row numbers in all grids (applies to data grid on Browser also) 확인란이 선택되었는지 확인합니다.

결과 집합에 반환되는 총 행 수는 사용자가 결과 집합의 끝으로 스크롤한 후에만 창의 맨 아래에 있는 상태 표시줄에 표시됩니다. 이는 전반적인 성능을 향상시키기 위해 결과 집합을 필요에 따라서면 반입하기 때문입니다. 마지막 행이 반입되면 총 개수가 표시됩니다.

SQL Results 그리드에서 Oracle 의사 열 ROWNUM을 반환하려면 "ROWNUM"을 질의에 추가합니다.

select rownum, emp.* from employee emp

rownum은 Oracle 의사 열이기 때문에 테이블 정의 또는 데이터와 함께 저장되기 않지만 질의 시에 파생된다는 것에 주의합니다.

질의에서 ROWID를 반환하려면 열과 데이터 형식을 지정합니다.

select rowidtochar(rowid), emp.* from employee emp

주: 해당 확인란을 눌러 View > Options > Data Grids 탭에서 "Show ROWID in data grids"를 활성화할 수도 있습니다. 이렇게 하면 코딩에 의존하지 않고 동일한 작업을 수행할 수 있습니다.


Toad 질의 결과 저장

아래 절차에 따라 Toad의 모든 창 질의 결과를 Windows 클립보드나 파일에 저장할 수 있습니다. 일부 대화 상자에는 "Copy to Clipboard" 또는 "Save to Disk" 기능이 없습니다. 여기에 해당 기능을 복제할 수 있는 방법이 설명되어 있습니다.

질의 결과를 저장하려면

  1. 디스크 파일로 출력을 스풀하도록 Database|Spool|Spool SQL To File을 선택합니다.

  2. 원하는 Toad 창(예: Schema Differences 창)을 실행하고 원하는 각 탭을 선택합니다.

  3. Toad TEMPS 폴더에서 DEBUG.SQL 을 엽니다.

  4. 각 SQL을 Editor 창에 복사합니다.

  5. Editor 창에서 각 SQL을 실행하여 바인드 매개 변수를 하드 코딩된 값으로 대체하거나 단순히 메지시가 표시되었을 때 Variables 대화 상자에 값을 입력합니다.

  6. Grid > Save As 메뉴 항목을 사용하여 그리드 내용을 클립보드나 디스크 파일에 저장합니다.


시간 값

날짜와 함께 시간을 표시할 경우 시간 값이 12:00:00 AM(자정)이면 Delphi 및 Toad에서 시간 값을 표시하지 않습니다. 날짜의 시간 부분이 0이므로 Toad에서는 날짜 표시에 값을 추가하지 않습니다.

Oracle에서는 날짜를 기원전 4712년 1월 1일부터 차감되는 큰 분수 숫자로 저장합니다. 그런 다음 이 숫자는 완전한 날짜와 시간으로 변환됩니다. 이 방법은 지난 Y2K에도 제대로 작동합니다.

"Select sysdate from dual" 질의를 수행하면 시간이 표시되며 마찬가지로 DATE 데이터 형식 열의 질의는 자정이 아닌 경우 시간을 표시합니다.

View|Toad Options|Data Grids의 시간 드롭다운은 이 시간 출력에 영향을 주지 않습니다.


스크립트 작성

Editor를 처음 열면 "No Name"이라는 레이블이 있는 탭인 빈 편집 창이 나타납니다.

이 창에서 SQL 또는 PL/SQL 코드를 직접 입력할 수 있습니다. XML 또는 Hex editor를 사용하려면 이 탭을 마우스 오른쪽 단추로 누르고 New Tab|XML 또는 New Tab|Hex를 선택합니다. 그러면 해당 유형의 코드에 대해 활성화되는 새 탭이 열립니다.

스크립트를 저장하려면

  • Editor 도구 모음에서 Save as [image] 단추를 누릅니다.

관련 항목

SQL 스크립트 실행

문 실행

Toad Editor

Editor 주 도구 모음

스크립트 작성

스크립트 열기


문 실행

Toad에서는 질의 문, DDL 문, 프로시저 SQL 블록 등이 지원됩니다.

또한 Toad에서는 따옴표 안의 대체 변수를 다음과 같이 인식합니다.

  • &이 이스케이프된 경우 값을 묻는 메시지가 표시되지 않습니다.

  • &이 문자열의 마지막 문자인 경우 대체 변수로 간주되지 않습니다.

코드 실행을 위한 명령

<F9>

<F9> 키를 누르면 커서 위치의 문이 실행되거나 커서 위치의 PL/SQL이 컴파일됩니다. 전체 창에서 커서 위치에 문이나 스크립트만 포함되어 있지 않은 경우 전체 창의 내용은 여기에 해당하지 않습니다.

커서 위치의 문을 실행하려면

  • <F9> 키를 누릅니다.

또는

도구 모음에서 Execute Statement 단추를 누릅니다.

editor 텍스트의 일부를 처리하려면

  • 해당 부분을 강조표시하고 <F9> 키를 누릅니다.

또는

도구 모음에서 Execute Statement 단추를 누릅니다.

<SHIFT><F9>

<SHIFT><F9>를 누르면 커서 위치의 코드 조각만 실행됩니다. 전체 프로시저, 함수 또는 트리거가 실행되거나 컴파일되지는 않습니다. <SHIFT><F9>를 누를 경우 다음 중 두 개 사이에 있는 모든 내용이 실행됩니다.

  • ;(세미콜론)

  • 빈 줄

  • /(슬래시)

  • 파일 표시기의 끝과 시작

하나 이상의 빈 줄로 구분된 여러 문 사이에서 하나의 문을 실행하려면

  1. 문 안이나 실행할 문 뒤의 빈 줄에서 캐럿/커서를 누르거나 배치합니다.

  2. <SHIFT><F9> 또는 <CTRL><ENTER>를 누릅니다.

또는

도구 모음에서 Run Current Statement 단추를 누릅니다.

SQL 코드 단편 강조표시

Explain Plan이 해당 코드에서만 실행되도록 하거나 문을 실행하기 전에 문의 일부로 포함되는 내용을 볼 수 있도록 코드 부분을 쉽게 강조표시할 수 있습니다. 코드를 강조표시할 때는 <SHIFT><F9>와 동일한 논리가 사용됩니다.

SQL 코드 조각을 강조표시하려면

  • 강조표시할 코드에 커서를 놓은 다음 <CTRL><H>를 누릅니다.


SQL_Plus 명령

SQL*Plus 명령

Toad에서 모든 SQL*Plus 명령이 지원되지는 않습니다. Toad에서 지원하거나, 무시하거나 지원하지 않는 명령이 아래 목록에 설명되어 있습니다.

SQL*Plus 구문 - 지원됨

Toad에서 지원하는 SQL*Plus 명령은 다음과 같습니다.

@ 및 @@

/(슬래시)

특정 명령(익명 블록, PL/SQL 및 Create Type 문) 간의 구분 기호로 필요합니다.

SQL*Plus와 같이 Toad에서 명령 버퍼를 저장하지 않기 때문에 버퍼의 내용이 실행되지는 않습니다.

&(앰퍼샌드)

&&(2개의 앰퍼샌드)

ACCEPT

BREAK/BRE

BTITLE/BTI

CLEAR

  • CLEAR SCREEN이 지원되지 않습니다.

  • SQL이 지원되지 않습니다.

  • BUFFER가 지원되지 않습니다.

COLUMN/COL

COMPUTE/COMP

  • SUM, MIN 및 MAX는 하나의 세부 수준에서 지원됩니다.

CONNECT/CON 및 DISCONNECT/DISC

DEFINE/DEF 및 UNDEFINE/UNDEF

  • CONNECT IDENTIFIER가 지원되지 않습니다.

  • SQLPLUS RELEASE가 지원되지 않습니다.

  • EDITOR가 지원되지 않습니다.

EXEC/EXECUTE

EXIT/QUIT

HOST

MERGE

PAUSE/PAU

PASSWORD

PROMPT/PRO

PRINT

REM/REMARK

REPFOOTER

REPHEADER

SET APPINFO(스크립트가 실행될 때 단지 모듈 이름 변경)

SET AUTOCOMMIT

SET AUTOPRINT

SET AUTOTRACE/AUTOT(기본값 OFF)

SET COLSEP

SET DEFINE/DEF(기본값 ON)

SET ECHO(기본값 OFF)

SET ESCAPE/ESC

SET FEEDBACK/FEED

SET HEADING/HEA(기본값 ON)

SET HEADSEP

SET LINESIZE/LINES(기본값 80, 최대값 2000)

SET LONG

SET LONGCHUNK SIZE

SET NEWPAGE

SET NULL

SET NUMFORMAT

SET NUMWIDTH

SET PAGESIZE

SET RECSEP

SET RECSEPCHAR

SET SCAN(기본값 ON)

SET SERVEROUTPUT/SERVEROUT(기본값 OFF)

  • ON 및 OFF가 지원됩니다.

  • SIZE가 지원됩니다.

SET SHOW

SET SQLCONTINUE

SET SQLNUMBER

SET SQLPROMPT

SET SQLTERMINATOR

SET TERMOUT/TERM(기본값 ON)

SET TIMING

SET TRIMOUT

SET TRIMSPOOL

SET UNDERLINE

SET VERIFY

SET WRAP

SHOW

SPOOL Filename 및 SPOOL OFF(또한 SPO)

  • Toad에서 경로가 지정되지 않은 파일은 Toad 디렉토리에 작성됩니다.

  • Quest ScriptRunner에서 경로가 지정되지 않은 파일은 Quest ScriptRunner와 동일한 디렉토리에 작성됩니다.

  • 상대 스풀 경로를 지원합니다.

  • SQL*Plus와 같이 SPOOL 파일을 하위 스크립트에 전달합니다.

START

STORE SET

TTITLE

VARIABLE

WHENEVER OSERRER

WHENEVER SQLERROR

SQL*Plus 구문 - 무시됨

다음 명령은 무시되지만 오류가 발생하지는 않습니다.

SET ARRAYSIZE | SET DESCRIBE | SET MARKUP
SET AUTORECOVERY | SET EDITFILE | SET PAUSE
SET BLOCKTERMINATOR | SET EMBEDDED | SET SHIFTINOUT
SET CMDSEP | SET FLAGGER | SET SQLBLANKLINES
SET COMPATIBILITY | SET FLUSH | SET SQLCASE
SET CONCAT | SET INSTANCE | SET SQLPREFIX
SET COPYCOMMIT | SET LOBOFFSET | SET SUFFIX
SET COPYTYPECHECK | SET LOGSOURCE | SET TAB
 |  | SET TIME

SQL*Plus - 지원되지 않음

다음 SQL*Plus 명령을 사용하면 Script Output 탭에서 "Statement Ignored" 오류가 발생합니다.

APPEND | COPY | LIST
ARCHIVE LOG | DEL | RECOVER
ATTRIBUTE | EDIT | RUN
CHANGE | GET | SAVE
CLEAR SCREEN | HELP | SHUTDOWN
CLEAR SQL | INPUT | STARTUP
CLEAR BUFFER |  |


SQL 스크립트 실행

Editor 창에서는 DDL 문, INSERT 문 등이 포함된 간단한 SQL 스크립트를 처리할 수 있습니다. Toad에서 SQL 스크립트를 처리할 때 일부 SQL*Plus 명령은 무시됩니다. 자세한 내용은 SQL*Plus 명령 항목을 참조하십시오.

또는 Quest ScriptRunner를 사용하여 긴 스크립트를 실행하는 것이 유용할 수 있습니다. Quest ScriptRunner가 백그라운드에서 실행되므로 Toad는 다른 작업을 자유롭게 수행할 수 있습니다. 자세한 내용은 Quest ScriptRunner 도움말 파일(Quest ScriptRunner에서 <F1> 키를 누름)을 참조하십시오.

Toad에서 SQL 스크립트를 실행하려면

  1. 스크립트를 Editor 창에 로드합니다.

  2. Editor 메뉴에서 Execute as Script를 선택합니다.

주: Toad에서의 줄 크기는 SQL*Plus와 같이 기본적으로 80입니다. 이 크기를 더 큰 값으로 변경하려면 스크립트에서 SET LINESIZE 명령을 사용하면 됩니다.

또는 TOAD.INI 파일에서 다음 줄을 정확하게 추가할 수 있습니다.

[SCRIPTS]

LineSize=300

300으로 되어 있는 부분에 원하는 줄 크기를 입력할 수도 있습니다. 숫자 뒤에 공백을 포함하지 마십시오.

주의: 변경 내용이 있는 경우 현재 창의 스크립트가 자동으로 저장된 다음 스크립트로 실행됩니다.

Quest ScriptRunner에서 SQL 스크립트를 실행하려면

  1. 스크립트를 Editor 창에 로드합니다.

  2. Editor 메뉴에서 Execute SQL via QSR을 선택합니다. Quest ScriptRunner가 현재 연결을 사용하여 열리고 스크립트가 실행됩니다.

현재 창을 SQL Script로 실행하려면

  • Editor 메뉴에서 select Execute SQL via SQL*Plus를 선택합니다. 현재 창의 스크립트가 저장된 다음 스크립트로 실행됩니다.

주: Execute Current Window as Script 명령에서는 바인드 변수가 지원되지 않습니다.


코드 폴딩

코드 폴딩을 사용하면 코드의 일부를 축소하여 볼 필요가 있는 코드 부분을 더 많이 표시할 수 있습니다. 나중에 폴딩된 코드를 사용해야 할 경우 코드를 확장할 수 있습니다.

코드 폴딩의 기초가 되는 것은 Language management입니다. 코드 폴딩을 위한 일부 표준 설정이 Toad에 포함되어 있지만 이 기능은 쉽게 구성할 수 있다는 이점이 있습니다. 폴딩하려는 코드 부분을 폴딩하도록 Toad를 설정할 수 있습니다.

코드 폴딩을 활성화하려면

  • Toad Options|Editors|Behavior에서 Enable code folding을 선택합니다.

코드를 폴딩하도록 표시

Language Management 영역 내에서 새 범위를 작성하여 Toad에서 코드를 폴딩하도록 새 영역을 작성할 수 있습니다. 코드 폴딩이 활성화되면 해당 범위 내에서 코드를 폴딩할 수 있습니다.

코드 폴딩 범위를 설정하려면

  1. Toad Options|Editors|Behavior|Language Management에서 폴딩할 코드 유형을 선택한 다음 Edit를 누릅니다.

  2. Rules 탭을 누릅니다.

  3. 새 규칙을 추가합니다. 규칙의 이름을 지정할 때 If start에서와 같이 Start를 포함할 수 있습니다. If end와 같이 범위를 종료할 위치를 정의하는 또 다른 규칙을 작성합니다.

  4. 방금 작성한 시작 조건을 선택합니다.

  5. 범위의 시작을 정의하는 데 사용할 조건을 설정합니다(예: Identifier = one or more tokens).

  6. Properties 탭을 누릅니다.

  7. rule type 상자에서 Range start를 선택합니다.

  8. 범위 종료 조건을 조건을 끝낼 규칙으로 설정합니다.

  9. 범위가 선택될 경우 표시할 스타일을 설정합니다. If start의 경우 기본 스타일은 Current block입니다.

  10. 활성화할 다른 옵션을 선택합니다. 원할 경우 Advanced 탭을 변경합니다.

  11. 작성한 종료 규칙에서 동일한 방식으로 범위 종료 조건을 설정하고 이번에는 Range End를 규칙 유형으로 선택합니다.

  12. Apply 또는 OK를 누릅니다.

관련 항목

Language Management 개요

Rules 탭


샘플 문

여기에는 Editor 창에서 실행할 수 있는 몇 가지 샘플 SQL 문이 있습니다.

CREATE DATABASE LINK JFPROD CONNECT TO PRODUCTION
IDENTIFIED BY PRODUCTION USING 'JFPDB'

INSERT INTO DONOR_REP_TYPES
SELECT * FROM DONOR_REP_TYPES@JFPROD

DELETE FROM DONORS WHERE DONOR_NO = 3

INSERT INTO INDIVIDUALS
SELECT * FROM INDIVIDUALS@TEMPDEV
WHERE IND_NO IN
( SELECT DNR_IND_NO FROM DONORS
WHERE DNR_IND_NO IS NOT NULL AND
DNR_INDIVIDUAL_BOOL = 1 )

SELECT * FROM FUNDING_NEEDS
WHERE
FND_UNFUNDED_AMOUNT IS NOT NULL AND
FND_UNFUNDED_AMOUNT > 0 AND
FND_ALLOCATION_MEETING_BOOL = 1

DESC DONORS

DECLARE
t_owner varchar2(30) := 'MYNAME';
CURSOR all_obj_cur IS
SELECT table_name
FROM all_tables
WHERE owner = UPPER (t_owner);
disable_cursor INTEGER;
out_str VARCHAR2(1000);
BEGIN
FOR obj_rec IN all_obj_cur
LOOP
disable_cursor := DBMS_SQL.OPEN_CURSOR;
out_str := 'ALTER TABLE ' || obj_rec.table_name ||
' ENABLE ALL TRIGGERS';
DBMS_SQL.PARSE (disable_cursor, out_str, DBMS_SQL.V7);
DBMS_SQL.CLOSE_CURSOR (disable_cursor);
END LOOP;
END;


테이블 이름 자동 완성

Toad에서는 전체 내용을 입력할 필요 없이 테이블 이름을 쉽게 찾을 수 있습니다.

Toad에서는 사용자가 입력한 문자와 일치하는 테이블 목록을 찾습니다. 일치하는 항목이 하나만 발견되면 editor에서 테이블 이름이 자동으로 완성됩니다. 일치하는 항목이 여러 개인 경우 원하는 테이블을 선택하도록 팝업 목록이 나타납니다.

주: 이 기능을 사용하려면 먼저 테이블 이름이 로드되어야 합니다. 테이블 이름이 로드되지 않은 경우 테이블 이름을 로드하라는 메시지가 나타납니다.

테이블 이름을 자동 완성하려면

  • 스키마의 테이블 이름 중 처음 몇 개의 문자를 입력한 다음 <CTRL>.(마침표)를 누릅니다.


Results 그리드

Editor의 맨 아래에는 편집 창 내에서의 작업 결과를 표시하는 탭이 있습니다.

Toad 버전에 따라 다음 위치에서 결과가 표시될 수 있습니다.

  • Data 그리드

  • DBMS Output 영역

  • Script Output 영역

  • Script Debugging 영역

Data 그리드

Data 그리드에는 반입된 데이터가 표시됩니다. Results 패널에는 Data, Explain Plan, Auto Trace, DBMS Output, Code Statistics 및 Script Output에 대한 탭이 포함되어 있습니다. Debugger module을 갖고 있는 경우에는 Script Debugger도 표시될 수 있습니다.

Editor와 Results 패널 사이의 가로 분할자를 사용하면 각 구성 요소의 크기를 지정할 수 있습니다.

Data 그리드는 사용자가 구성할 수 있으며 다음이 포함되어 있습니다.

  • 선택 사항인 이동 가능한 열

  • 팝업 창별 LONG 및 LONG RAW 열 지원

  • 데이터를 디스크로 내보내기 지원

  • 인쇄

  • 데이터 편집

또한 이 그리드에는 그리드 구성 옵션에 신속하게 액세스하기 위한 마우스 오른쪽 단추 메뉴가 있습니다. 결과 데이터 집합이 편집 가능한 경우 Results 그리드 도구 모음에 있는 여러 단추(삽입, 삭제, 업데이트 게시 등)가 활성화됩니다.

주: 날짜는 mm/dd/yy 또는 mm/dd/yyyy 형식이나 Windows 제어판, 국가별 설정, 날짜, 간단한 날짜 스타일 형식으로만 입력할 수 있습니다. 예를 들어 프랑스에서는 dd/mm/yy 또는 dd/mm/yyyy 날짜 입력이 허용됩니다. dd-mon-yy 형식으로 입력한 날짜는 거부됩니다.

DBMS Output

동일한 Editor 창에서 DBMS Output을 볼 수 있습니다.

DBMS output 창을 보려면

  • Results 영역에서 DBMS Output 탭을 누릅니다.

관련 항목

SQL Results 그리드

Script Output

Script Debugging


별칭

테이블 별칭을 설정하는 작업을 통해 질의 열에 대한 바로 가기를 작성할 수 있습니다. 그런 다음 긴 열 이름이나 경로 대신에 별칭을 SQL 문에서 사용할 수 있습니다.


ALIASES.TXT 파일

aliases.txt가 텍스트 파일이므로 텍스트 편집기를 사용하여 수동으로 편집할 수 있습니다. Toad가 실행되고 있지 않은 경우에 이 작업을 수행합니다. 그렇지 않을 경우 이 작업을 수행하면 종료 시나 옵션을 저장할 때 파일을 덮어씁니다.

별칭 목록을 미리 작성하기 위해 이 파일을 수동으로 편집할 수 있습니다. 또는 파일에서 유지 관리를 수행하거나 외부 또는 여러 항목을 제거하기 위해 파일을 수동으로 편집할 수 있습니다. 현재는 Toad에서 이 작업을 직접 수행할 수 있는 방법은 없습니다.

별칭 목록을 제어하는 텍스트 파일은 /Toad/temps/aliases.txt에 있습니다. aliases.txt의 형식은 다음과 같습니다.

table_name=alias

예를 들면 다음과 같습니다.

AAX_ACCESSGROUP_APPLICATION=aax

ADD_ADDENDUM=add

ADT_ADDRESS_TYPE=adt

AFP_ACTIVITY_FIRM_PARTIC=afp

AGX_APPLICATION_GROUP_ITEM=agx

DEPARTMENT=dept


별칭 사용

별칭을 사용하기 위해 ini 변경이 필요하지는 않습니다. 다음 예와 같이 전체 테이블 이름 대신에 별칭을 입력하여 Editor에서 별칭을 사용합니다.

SELECT DEPT.

올바른 Oracle 테이블을 선택하기 위한 열 목록이 팝업으로 표시됩니다(이 경우에는 DEPARTMENT).

ALIASES.TXT에서 이러한 테이블 별칭을 설정한 경우 질의를 작성하기 위해 해당 테이블을 선택하면 Query Builder 대화 상자에서 해당 별칭이 제공됩니다.

위의 SELECT SQL 문을 완성하려면 테이블 별칭과 비슷한 Auto Replace 대체 항목 이름을 사용합니다. 이러한 이름은 View|Editing Options|Auto Replace 탭을 통해 액세스할 수 있습니다.

또한 코드 완성 템플릿 항목을 참조하십시오.


별칭 건너뛰기

사용하는 개체 이름이 다른 테이블의 별칭인 경우가 있습니다. 일반 Columns Select 방법을 사용하는 경우 Toad에서는 별칭이 참조하는 테이블의 열을 반환합니다.

별칭을 건너뛰고 별칭이 아니라 개체에 대한 열 목록을 열 수 있습니다.

별칭을 건너뛰려면

  • Edit|Picklist드롭다운에서 no alias를 선택합니다.

또는

<CTRL><Shift> T를 누릅니다.


SQL Scanning

Toad에서는 사용자가 SQL을 사용하여 별칭을 작성할 때 이러한 별칭을 추적합니다. Toad에서는 테이블과 별칭을 확인하기 위해 select 문의 FROM 절을 스캔합니다.

주: Toad는 모든 단일 문에서 첫 번째 FROM 절만 찾습니다. 따라서 통합 또는 하위 질의와 같은 복잡한 문의 추가 테이블과 별칭이 발견되지 않습니다.

현재 SQL 문의 FROM 절에서 테이블 별칭이 발견될 경우 Toad에서는 다음 작업이 수행됩니다.

  • 이미 목록에 있는 별칭의 경우 Toad에서 열 드롭다운 기능을 사용하기 위해 FROM 절에 별칭이 정의될 필요가 없습니다.

  • 별칭이 SQL 문에서 식별되어 있고 Columns Select가 별칭에서 사용될 경우 aliases.txt에 자동으로 추가됩니다.

  • aliases.txt에 해당 별칭에 대한 항목이 이미 있는 경우 현재 FROM 절에 정의된 쌍이 이전 항목을 대체합니다.


스크립트 열기

이전에 저장한 스크립트를 열어 편집할 수 있습니다. Editor Main 도구 모음에서 이 작업을 쉽게 수행할 수 있습니다.

저장된 스크립트를 열려면

  1. Editor|File 도구 모음에서 Open File [image] 단추를 누릅니다.

  2. Load File 대화 상자에서 파일을 선택하고 Open을 누릅니다.

최근에 사용한 저장된 스크립트를 열려면

  1. Editor|File 도구 모음에서 Open File [image] 드롭다운을 누릅니다.

  2. 제공된 목록에서 파일을 선택합니다.

관련 항목

스크립트 작성


저장 프로시저 호출

Editor 창에서

다음은 Editor 창에서 실행할 수 있는 PL/SQL의 작은 익명 블록 예입니다. 저장 프로시저에 대한 호출은 완전한 익명 PL/SQL 블록이어야 합니다(다시 말해서 BEGIN 및 END가 있어야 함).

begin
CallMyProc();
end;

Schema Browser에서

또한 Schema Browser 창에서 저장 프로시저를 호출할 수 있습니다.

Schema Browser에서 저장 프로시저를 호출하려면

  1. Schema Browser를 열고 Object 패널에서 Procs를 선택합니다.

  2. PL/SQL 프로시저, 함수 또는 패키지를 선택하고 Execute를 누릅니다.

관련 항목

Schema Browser: Procs

Procs: 팝업 메뉴

새 프로시저 작성


Window: Variables

Variables

Variables 창은 SQL 질의에 지정된 매개 변수가 있을 경우 Editor 창에서 문을 실행할 때 나타납니다. 예를 들어 다음을 실행합니다.

SELECT * FROM EMPLOYEE WHERE EMPLOYEE_ID = :EMPID

또는

SELECT * FROM EMPLOYEE WHERE EMPLOYEE_ID = &EMPID

variables 창이 나타나면 각 바운드 변수를 선택하고 데이터 형식을 선택한 다음 원하는 값을 입력합니다. OK 를 눌러 결과 SQL 문의 실행을 완료합니다.

주: 바운드 매개 변수 대체는 익명 PL/SQL 블록에서 지원되지 않습니다.

바운드 변수를 삭제하려면

  • 해당 매개 변수를 선택하고 Delete를 누릅니다.

삭제된 바운드 변수를 추가하려면

  • Scan SQL을 누릅니다. Toad에서는 SQL을 다시 스캔하고 변수를 다시 입력합니다.


Strip Code Statement 및 Make Code Statement 기능

Editor 창에는 Toad의 SQL 문을 Delphi, VB, C++, Java, Perl 등의 코드 개발 도구에 복사하고 이러한 코드 개발 도구의 SQL 문을 다시 Toad에 복사하는 작업을 단순화하는 두 가지 기능이 있습니다. 이러한 기능은 Editor 메뉴에서 사용할 수 있는 Strip Code Statement(<CTRL>P) 및 Make Code Statement(<CTRL>M)입니다.

Strip Code Statement

Toad에서 실행할 준비가 되도록 SQL 문에서 코드 개발 도구 구문을 제거합니다.

예를 들어 VB 코드를 VB 개발 도구에서 가져와 복사하고 Toad에 붙여넣은 다음 Strip Code Statement를 실행할 수 있습니다. 이 경우 다음 SQL 문은

Sql= " select count(*) as cnt"
Sql = Sql & " from all_tables"
Sql = Sql & " where owner = 'DEMO'"
Sql = Sql & " and table_name = 'EMPLOYEE'"

다음과 같이 변경됩니다.

select count(*) as cnt
 from all_tables
 where owner = 'DEMO'
 and table_name = 'EMPLOYEE'

이제 SQL은 Toad에서 실행할 준비가 되었습니다.

Editor에 여러 SQL 문이 있는 경우 Strip Code Statement 기능을 실행하기 전에 제거할 문을 강조표시합니다.

Make Code Statement

코드 개발 도구 구문을 Editor의 SQL 문에 추가하고 개발 도구 코드에 붙여넣을 수 있도록 준비합니다.

Strip Code Statement 기능과 같이 Editor 창에서 코드를 변경하지 않고 코드 문을 만들 때 Make Code Statement 기능은 현재 강조표시된 SQL 문을 가져와 코드 개발 도구 구문으로 변환한 다음 클립보드에 붙여넣습니다. 그런 다음 사용자는 코드 개발 도구로 전환하여 결과에 붙여넣을 수 있습니다. "VB statement was copied to the clipboard"와 같은 메시지가 상태 패널에 표시됩니다.

Editor에 여러 SQL 문이 있는 경우 Make Code Statement 기능을 실행하기 전에 만들려는 문을 강조표시합니다.

코드 개발 도구 선택

View|Toad Options|Editor|Code Assist|Make Code Format 상자에서 코드 개발 도구를 선택합니다. Make Code Format 상자를 사용하면 Toad에서 SQL 문을 언어 구문으로 변환(Make Code Statement 기능)하거나 언어 구문에서 변환(Strip Code Statement 기능)할 때의 언어 구문을 선택할 수 있습니다. 현재는 Delphi, VB, C++, Java 및 Perl이 지원됩니다. 기본적으로 VB가 선택됩니다. 언어 템플릿을 직접 작성할 수도 있습니다. 자세한 내용은 Toad Options|Editor 항목을 참조하십시오.


Make Code Template 작성

코드 만들기 템플릿 작성

Toad Options|Editor - Code Assist 창에서 코드 만들기 템플릿을 작성할 수 있습니다.

다음 변수를 사용하여 사용자 언어 템플릿을 작성합니다.

  • %SqlVar% - Toad Options|Editor|Code Assist|MakeCodeVariable 상자에 입력하는 MakeCode 변수입니다. 변수 사용은 선택 사항입니다.

  • %SqlLength% - 선택된 한 줄 또는 여러 줄의 모든 SQL에 있는 문자 수로 대체됩니다.

  • %SqlText% - 선택한 SQL의 첫 줄로 대체됩니다.

  • %SqlTextNext% - 선택한 SQL의 이후 줄로 대체됩니다. 이 값은 누적되며 SQL의 이후 줄 전체를 포함합니다.

주: 최고의 출력 결과를 얻으려면 %SqlTextNext% 변수를 별도 줄에 포함하는 것이 좋습니다. 주석에는 왼쪽 및 오른쪽 중괄호를 사용합니다.

설명(템플릿 이름 등)은 대괄호 안에 포함해야 합니다.

예:

다음 SQL을 사용하고:

Select *

from

Employees

다음 코드 템플릿을 사용하면 아래와 같은 결과를 얻을 수 있습니다.

템플릿 | 결과
{C# Language Template} string %SqlVar%& = "%SqlText% " + "%SqlTextNext% " | string SQL = "Select * " + "from " + "employees " ;
{C++ Language Template} char %SqlVar%[%SqlLength%]; strcpy(%SqlVar%,"%SqlText%"); strcat(%SqlVar%,"%SqlTextNext%"); | char SQL[23]; strcpy(SQL,"Select * "); strcat(SQL,"from "); strcat(SQL,"employees");
{ Java Language Template } "%SqlText% " + "%SqlTextNext% " | "Select * " + "from " + "employees "

관련 항목

Strip_Code_Statement_및_Make_Code_Statement_함수

Toad Options|Editor - 코드 지원


빠른 설명

코드에서 테이블, 보기, 프로시저, 함수 또는 패키지 이름 위에 커서를 두면 해당 개체를 완전하게 설명하는 팝업 창이 표시됩니다.

개체를 설명하려면

  1. 코드에서 개체 이름을 찾아 선택합니다.

  2. <F4> 키를 누릅니다.

주: <F4> 설명 외에도 개체를 <CTRL>Click하거나 마우스 오른쪽 단추로 누르고 Describe를 선택할 수 있습니다.

팝업 설명 창을 맨 위에 유지

팝업 창을 맨 위에 유지하려면 Toad Options Editor를 참조하십시오. "DESCRIBE TABLE"의 결과를 SQL Results 패널이나 팝업 창에 두도록 선택할 수 있습니다.

관련 항목

Editor 옵션

Edit: Describe

개체 팔레트


SQL Statement Recall

SQL Statement Recall 창은 도킹 가능하며 고정하거나 숨길 수 있습니다.

Editor에서 실행되는 모든 문이 문 회수 목록에 추가됩니다. 이 목록에서는 최근 SQL이 맨 위에 옵니다. 이 목록에서 문을 선택하여 실행거나 문을 제거하거나 쉽게 회수할 수 있도록 문에 이름을 지정할 수 있습니다. 또한 SQL 문을 개인 SQL 또는 명명된 SQL로 분류할 수 있습니다.

모든 문(Toad Options|Editor|Execute/Compile|SQL Recall에 설정된 최대값까지)은 Toad 세션 사이에서 Toad for Oracle\User Files\SAVEDSQL.xml 파일에 저장됩니다.

SQL Recall 창에는 다음 정보가 표시됩니다.

  • SQL의 이름(있을 경우)

  • SQL 문

  • 연결 정보

  • 마지막 연결 날짜 및 시간

유효한 SQL 문만 저장

성공적으로 실행된 SQL 문만 저장할 수 있습니다. 이렇게 하면 철자가 잘못된 열 이름, SQL 절 등이 목록에 포함되지 않습니다.

유효한 SQL만 저장하도록 Toad를 설정하려면

  • View|Toad Options|Editor|Execute/Compile 창에서 Save Only Statements that are Valid 확인란을 선택합니다.

저장된 SQL 특성 편집

SQL Recall 그리드 내의 이름, 유형 및 SQL과 같은 저장된 SQL 문 특성을 편집할 수 있습니다.

저장된 SQL 특성을 편집하려면

  1. 선택한 SQL 문의 해당 셀을 두 번 누릅니다.

  2. 변경을 수행합니다.

  3. 선택한 셀의 외부를 누르거나 <Enter> 키를 누릅니다.

관련 항목

SQL Statement Recall 도구 모음

Add to Personal SQLs

Add to Named SQLs

회수된 SQL 보기 및 작업


SQL Statement Recall 도구 모음

SQL Statement Recall 도구 모음에는 사용자의 요구에 따라 개별적으로 숨기거나 표시할 수 있는 두 부분이 있습니다.

주 도구 모음

주 SQL Statement Recall 도구 모음에는 Toad에서 보관한 SQL 문을 사용하기 위한 명령이 포함되어 있습니다.

단추 | 명령
 | 선택한 SQL 문을 파일에 저장합니다.
 | 선택한 SQL 문을 클립보드에 복사합니다.
 | 선택한 SQL 문을 SQL 목록에서 제거합니다.
 | 선택한 SQL 문을 Editor에 복사합니다.
 | 이전 문
 | 다음 문
db 및 날짜를 표시합니다. | 연결 정보와 마지막 실행 날짜를 표시하거나 숨깁니다.

SQL Filter 도구 모음

SQL Filter 도구 모음에는 SQL 문 목록에 대한 필터링 옵션이 포함되어 있습니다.

단추 | 명령
SQL Contains | SQL에 포함된 문자열로 목록을 필터링합니다.

관련 항목

SQL Statement Recall

Add to Personal SQLs

Add to Named SQLs

회수된 SQL 보기 및 작업


회수된 SQL 보기

회수된 SQL 문을 그룹 또는 개별적으로 볼 수 있으며 작업하기 위해 editor로 쉽게 이동할 수 있습니다. 여러 방법으로 SQL 문을 볼 수 있습니다.

SQL 문 기록을 보려면

  1. View 메뉴에서 SQL Command Recall|History를 선택합니다.

  2. 창의 맨 아래에서 All SQL 탭을 누릅니다.

개인 또는 명명된 SQL을 보려면

  1. View 메뉴에서 SQL Command Recall|Personal 또는 Named를 선택합니다.

  2. 창의 맨 아래에서 All SQL 탭을 누릅니다.

개별 SQL을 보려면

  1. View 메뉴에서 SQL Command Recall을 선택합니다.

  2. 그리드의 맨 위에서 해당 탭을 선택합니다.

  3. 하나 이상의 SQL 문을 선택합니다.

  4. 창의 맨 아래에서 Single SQL 탭을 누릅니다.

주:Single SQL 탭에서는 Editor에서와 같이 F4 키, <CTRL>click 및 마우스 오른쪽 단추로 DESCRIBE 누르기 작업을 사용할 수 있습니다.

관련 항목

SQL Statement Recall

SQL Statement Recall 도구 모음

Add to Personal SQLs

Add to Named SQLs

Options - Editor - SQL Recall


회수된 SQL 작업

Editor에서 SQL 문을 열거나 Editor 또는 Text Editor로 끌어서 놓을 수 있습니다.

SQL 문을 끌어서 놓으려면

  1. SQL Recall 창에서 하나 이상의 SQL 문을 선택합니다.

  2. editor 중 하나로 끌어서 editing 창에 놓습니다.

Recall 창에서 SQL을 편집하려면

  1. SQL Recall 창에서 하나 이상의 SQL 문을 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Edit를 선택합니다.

Editor에서 SQL 문을 직접 열려면

  • 원하는 SQL 문을 두 번 누릅니다.


Add to Personal SQLs

이 명령은 Editor에서 강조표시한 SQL 문을 개인 SQL에 추가합니다.

SQL 문을 개인 SQL에 추가하려면

  • Editor|Add to Personal SQLs 메뉴 항목을 누릅니다.

모든 문(Toad Options|Editor|Code Assist|SQL Recall area에 설정된 최대값까지)은 Toad 세션 사이에서 Toad for Oracle\Temps\SAVEDSQL.xml 파일에 저장됩니다.

관련 항목

SQL Statement Recall

SQL Statement Recall 도구 모음

Add to Named SQLs

회수된 SQL 보기 및 작업


Window: Add to Named SQLs

Add to Named SQLs

이 창에서 SQL 문을 명명된 즐겨찾기 목록에 추가할 수 있습니다.

명명된 SQL 문 목록에 SQL을 추가하려면

  1. 문을 강조표시합니다.

  2. Editor|Add to Named SQLs 메뉴 항목을 선택합니다.

  3. 나중에 쉽게 기억할 수 있는 이 SQL 문의 이름을 입력합니다.

즐겨찾기의 이름이 지정되지 않고 표준 회수 SQL 문이 실행된 문 목록을 저장하기 때문에 이 목록은 즐겨찾기 SQL 문 목록과 다릅니다.

이 명명된 SQL 문 목록에서 SQL 문을 회수하려면 <CTRL>N을 누르거나 Editor|Recall Named SQL 메뉴 항목을 선택합니다.

이름은 대/소문자를 구분합니다. 따라서 "sql1"과 "SQL1"을 모두 저장할 수 있습니다.

이미 존재하는 것과 동일한 이름의 명명된 SQL 문을 추가하려고 하면 해당 문을 대체할지 묻는 대화 상자가 표시됩니다. 추가하려면 Yes를 누르고 취소하려면 No를 누릅니다. No를 누를 경우 명명된 문이 작성되지 않았다는 메시지가 표시됩니다.

모든 문(Toad Options|Editor|Execute/Compile에 설정된 최대값까지)은 Toad 세션 사이에서 Toad for Oracle\User Files\savedsql.xml 파일에 저장됩니다.

관련 항목

SQL Statement Recall

SQL Statement Recall 도구 모음

Add to Personal SQLs

회수된 SQL 보기 및 작업


Editor 파일 분할 옵션 사용

Editor는 패키지, 형식, 프로시저 및 함수를 쉽게 개발할 수 있도록 설계되었습니다. Oracle에서 패키지 또는 형식의 스펙과 본문은 함께 작동하지만 별개의 다른 두 개체입니다. Editor가 스크립트 편집기 또는 프로세서가 아니기 때문에 여러 개체가 별개의 탭에서 유지 관리됩니다(개체당 하나의 탭).

별개의 탭에서 하나의 개체를 유지 관리함으로써 대화형 디버깅, Team Coding 및 고급 구문 분석 기능과 같은 고급 기능이 Toad에서 제공될 수 있습니다.

개별 탭에서 개체를 유지하면 단순히 <CTRL><SHIFT>를 누르고 개체 이름을 눌러 스펙에서 본문으로 쉽게 이동할 수 있습니다.

그러나 일부 개발자는 패키지의 스펙 및 본문을 모두 하나의 파일에 저장하길 원할 수 있습니다. Toad에서는 파일 분할 옵션을 사용하여 이 작업을 수행할 수 있습니다.

스펙과 본문이 모두 포함된 이전 버전 Toad의 파일이 있는 경우 파일 분할 옵션을 설정하여 파일을 열 때 해당 탭으로 분할되도록 할 수 있습니다. 그런 다음 하나의 파일로 저장할지 아니면 별개의 파일(개체당 하나)로 저장할지 선택할 수 있습니다.


Create New PL/SQL Object

이 대화 상자에서는 새 프로시저, 함수, 패키지 또는 트리거를 위한 템플릿을 사용할 수 있습니다.

새 PL/SQL 개체를 작성하려면

  1. Editor의 도구 모음에서 Create New PL/SQL Object 단추를 누릅니다.

  2. 작성하려는 개체 유형을 선택합니다.

  • Function

  • Procedure

  • Package (spec)

  • Package Body

  • Type (spec)

  • Type Body

  • Trigger

  2. New Object Name 상자에 새 개체의 이름을 입력하거나 이 상자를 비워 두고 개체를 저장할 때 이름을 입력합니다.

  3. 기본 템플릿은 Toad for Oracle\User Files 폴더에서 읽습니다. 기본값이 아닌 작성한 템플릿을 사용하려면 드롭다운 메뉴에서 선택합니다. 다음 기본 템플릿은 Toad for Oracle\User Files 폴더에 있습니다.

  4. NEWPROC.SQL 새 프로시저 작성용

  5. NEWFUNC.SQL 새 함수 작성용

  6. NEWPackage.SQL 새 패키지 스펙 작성용

  7. NEWPackageBody.SQL 새 패키지 본문 작성용

  8. NEWType.SQL 새 형식 스펙 작성용

  9. NEWTypeBody.SQL 새 형식 본문 작성용

  10. NEWTrigger.SQL 새 트리거 스펙 작성용

주: 위 템플릿 외에도 두 개의 다른 템플릿이 Toad/User Files 폴더에 저장되어 있고 위에 설명된 대로 편집할 수 있습니다. 이러한 템플릿은 작성된 패키지 내에서 사용할 수 있으며 패키지 프로시저 및 패키지 함수를 모두 포함합니다. 자세한 내용은 패키지 내에서 템플릿 사용을 참조하십시오.

  4. 주석 프롤로그, 표준 오류 처리 섹션 등을 조정하는 방식으로 Editor에서 이러한 파일을 원하는 대로 편집할 수 있습니다. 원하는 텍스트 편집기를 사용하거나 Toad Options|Editor|Proc Templates 항목에서 파일을 선택하고 Edit를 누릅니다.

  5. 또한 새 파일을 원하는 대로 삭제, 변경 또는 추가할 수 있습니다. Toad Options|Editor|Proc Templates를 참조하십시오.

  6. 모든 네트워크 경로에서 이러한 새 프로시저 템플릿을 로드할 수 있습니다.

파일을 목록에 추가할 때는 파일 위치만 지정하면 됩니다. 경로를 변경하려면 새 경로를 추가하고 이전 항목을 삭제해야 합니다.

자동 바꾸기 키워드

템플릿을 열 때 값으로 자동 대체되는 여러 키워드가 템플릿에 있습니다. 이러한 키워드 외에도 Options: Editor - Proc Templates 에서 사용자 정의 키워드를 지정할 수 있습니다.

키워드 결과 대체

%YourObjectName% 개체 이름

%SYSDATE% 워크스테이션 날짜(예: mm/dd/yyyy)

%DATETIME% 워크스테이션 날짜 및 시간(예: mm/dd/yyyy hh:mm:ss am)

%DATE% 워크스테이션 날짜(예: mm/dd/yyyy)

%TIME% 워크스테이션 시간(예: hh:mm:ss am)

%USERNAME% Toad Options, Editor 노드에 지정된 사용자 이름

%TRIGGEROPTS% 각 행에 대한 트리거 전용 트리거 옵션(예: Before insert on)

주:

  • 이전 버전과의 호환성을 위해 "*YourObjectName*"도 지원됩니다.

  • 키워드에서는 대/소문자를 구분하지 않습니다.

  • 날짜 및 시간 형식은 Windows 제어판 설정에서 제공됩니다.

  • 이 기능은 프리웨어 Toad가 아니라 상용 버전의 Toad에서만 사용할 수 있습니다.

관련 항목

Schema Browser: Procs

Procs: 팝업 메뉴

저장 프로시저 호출

패키지 내에서 템플릿 사용

Options: Editor: Proc Templates


PL/SQL 코드 내에서 SQL 실행

@ 명령(@whereami.sql 등)을 포함하는 항목을 Editor에서 스크립트로 실행하면 Toad는 계층에 따라 실행할 whereami.sql 파일을 찾습니다.

계층은 다음과 같습니다.

  1. 상위 스크립트 디렉토리. @scriptb.sql 명령이 있는 scripta.sql을 로드할 경우 Toad는 우선 scripta.sql이 위치한 디렉토리를 찾습니다.

  2. 현재 Editor 디렉토리(Editor에서 File > open).

  3. Toad 디렉토리/사용자 파일.

  4. SQLPATH 환경 변수.


패키지 내에서 템플릿 사용

패키지 내에서만 사용할 수 있는 두 가지 템플릿 유형이 있습니다. 이러한 두 가지 유형은 패키지 함수 및 패키지 프로시저입니다. Toad Options|Editor|Proc Templates 페이지에서 이러한 템플릿을 작성 및 편집할 수 있지만 Create PL/SQL Object 창에서 액세스할 수는 없습니다.

패키지 함수 또는 패키지 프로시저 템플릿을 사용하려면

  1. Editor에서 패키지 스펙을 로드하거나 새 패키지 스펙을 작성합니다.

  2. 패키지 프로시저 또는 함수에 대한 새 선언을 스펙에 입력합니다.

  3. <Ctrl><Shift><C>를 누릅니다. 기본 패키지 프로시저 또는 패키지 함수 템플릿이 패키지 본문에서 새 프로시저를 만드는 데 사용됩니다.

주: 여러 템플릿을 작성한 경우 사용할 템플릿이 기본값으로 지정되어야 합니다. 다른 모든 템플릿은 사용되지 않습니다.

관련 항목

Schema Browser: Procs

Procs: 팝업 메뉴

저장 프로시저 호출

패키지 내에서 템플릿 사용

Options: Editor: Proc Templates


Load Database Object

이 대화 상자를 사용하여 기존 개체를 추가 편집을 위해 Stored Edit/Compile 창에 로드할 수 있습니다.

데이터베이스에서 개체를 로드하려면

  1. Editor 창에서 Load Database Object 도구 모음 단추를 누릅니다.

  2. Schemas/Owners 드롭다운에서 로드할 개체의 Schema/Owner를 선택합니다.

  3. 드롭다운 목록에서 로드할 개체 유형을 선택합니다. 이 옵션을 사용하면 패키지 본문 또는 스펙만 로드할지 아니면 전체 패키지와 함수, 트리거 등을 로드할지 선택할 수 있습니다.

  • 개체가 거의 없는 데이터베이스의 경우 All을 선택합니다.

  • 개체가 많은 데이터베이스의 경우 개체 유형을 선택한 다음 필터를 선택하여 아래의 왼쪽 패널에 관리 가능한 목록을 표시합니다.

  4. 왼쪽 패널에서 개체를 눌러 선택할 수 있습니다. 오른쪽 패널에는 미리 보기가 자동으로 표시됩니다. 대화 상자의 오른쪽 상단에서 토글 아이콘을 사용하여 이 미리 보기를 해제할 수 있습니다.


Save All

Editor 도구 모음의 Save All 명령을 사용하면 열려 있는 모든 파일에 대한 변경 내용을 신속하게 저장할 수 있습니다. 파일 이름을 지정하지 않은 경우 이름과 위치를 제공하라는 메시지가 표시됩니다. 제공되는 이름은 Editor의 탭 순서대로 되어 있습니다.

이 명령을 도구 모음에 추가하려면

이 단추를 도구 모음에 수동으로 추가해야 합니다.

  1. Editor 도구 모음을 마우스 오른쪽 단추를 누르고 Customize를 선택합니다.

  2. Commands 탭을 선택하고 File을 선택합니다. Save All을 Editor 도구 모음으로 끌어다 놓은 다음 Customize 창을 닫습니다.


CodeXpert 개요

주: 이 확장된 Toad 기능은 Toad for Oracle Professional Edition 이상에서만 사용할 수 있습니다.

CodeXpert에서는 규칙 집합에 대해 코드를 분석하여 최적의 방법을 찾습니다. 이러한 규칙은 규칙 집합에 저장되며 사용자 정의 규칙이나 미리 정의된 규칙일 수 있습니다(규칙 집합 구성 참조). Toad 내의 다양한 위치에서 CodeXpert에 액세스할 수 있습니다.

CodeXpert에서는 데이터베이스의 Toad 스키마에 보고서를 저장할 수 있습니다. 이 기능을 사용하려면 Server Side Objects 창을 사용하여 CodeXpert 개체를 설정해야 합니다.

편집기에서 CodeXpert 액세스

CodeXpert 창은 편집기에서 실행될 때 Output Frame 내에 탭으로 열립니다. 창은 CodeXpert 도구 모음, Results 탭, CodeXpert Report 탭, 규칙 및 문 합계로 구성됩니다.

편집기에서 CodeXpert에 액세스하려면

  • Formatter 도구 모음에서 CodeXpert [image] 단추를 누릅니다.

Toad를 통해 CodeXpert 액세스

CodeXpert를 자체 창에서 실행할 수 있습니다. File 메뉴를 사용하거나 Toad 내의 다양한 위치에서 마우스 오른쪽 단추 메뉴를 통해 이를 실행할 수 있습니다. 이러한 영역에서 CodeXpert를 실행하면 여러 개체에서 동시에 작업을 수행할 수 있습니다. 편집기가 아닌 영역에서 실행하는 경우, CodeXpert는 자체 창에서 열립니다. 또한 작업하는 동안 이 창으로 개체를 끌어 놓아 코드를 분석할 수 있습니다.

메뉴에서 CodeXpert에 액세스하려면

  • Database 메뉴에서 Diagnose|CodeXpert를 선택합니다.

다른 창에서 CodeXpert에 액세스하려면

  • 마우스 오른쪽 단추를 누르면 CodeXpert를 다음 위치에서 실행할 수 있습니다.

  • Schema Browser

- 프로시저

- 함수

- 패키지

- 트리거

- 보기

- 사용자(선택한 사용자가 소유한 모든 개체에서 CodeXpert 실행)

  • Project Manager

  • Code Road Map


Icon Legend

CodeXpert Icon Legend

주: 이 확장된 Toad 기능은 Toad for Oracle Professional Edition 이상에서만 사용할 수 있습니다.

CodeXpert의 트리 구조에는 나열된 다양한 개체를 식별하는 아이콘이 포함되어 있습니다.

Toad에는 이러한 이미지를 쉽게 해독할 수 있는 Icon Legend가 포함되어 있습니다.

Icon Legend에 액세스하려면

  • General CodeXpert 도구 모음에서 Icon Legend [image] 단추를 누릅니다.


CodeXpert 도구 모음

주: 이 확장된 Toad 기능은 Toad for Oracle Professional Edition 이상에서만 사용할 수 있습니다.

CodeXpert 창 맨 위에 있는 도구 모음을 사용하면 관리자 기능에 쉽게 액세스할 수 있습니다. 도구 모음에는 두 가지가 있으며 Editor 바탕 화면 탭과 CodeXpert 창 중 어느 쪽에서 CodeXpert에 액세스하는가에 따라 단추를 약간 다르게 배열할 수도 있습니다. 하지만 일반적으로 Main 도구 모음이 탭이나 창의 맨 위에 있고, 보고서 도구 모음이 Results 탭에 있습니다.

단추 | 명령
 | Procedure Editor에 있는 코드에 대해 CodeXpert 실행
 | 선택한 규칙 집합 포함
 | CodeXpert를 실행할 때 SQL Optimization 스캔
 | CodeXpert에서는 데이터베이스의 Toad 스키마에 보고서를 저장할 수 있습니다. 이 기능을 사용하려면 Server Side Objects 창을 사용하여 CodeXpert 개체를 설정해야 합니다.
 | 결과 트리에서 규칙 번호별로 규칙 찾기
 | 선택한 규칙의 조언 팁 보기
 | 규칙 집합 선택
 | RuleSet 창을 시작하여 규칙 집합 구성, 편집, 작성 또는 제거
 | 결과 트리 범례 보기
 | 요약 확대: 요약 보고서를 별도 창에서 열기
 | CodeXpert 보고서를 다양한 HTML 형식으로 저장
 | 인쇄 미리 보기
 | 인쇄
 | SQL Scanning 옵션 구성

관련 항목

General CodeXpert 도구 모음

Report 도구 모음


명령줄에서 CodeXpert 실행

주: 이 확장된 Toad 기능은 Toad for Oracle Professional Edition 이상에서만 사용할 수 있습니다.

명령줄에서 CodeXpert를 실행하고 Toad의 존재 여부에 관계 없이 어느 위치에서나 액세스할 수 있는 CodeXpert 보고서를 작성할 수 있습니다.

명령줄에서 CodeXpert를 실행하려면 먼저 매개 변수 파일을 설정해야 합니다. 그 후에 CodeXpert를 실행할 수 있습니다. 작업이 완료되면 html, xml, bin 하위 폴더가 매개 변수 파일에 지정된 출력 디렉토리에 배치됩니다.

명령줄에서 CodeXpert를 실행하려면

  1. CodeXpert 매개 변수 파일에서 설명한 대로 매개 변수 파일을 설정합니다.

  2. 다음 구문을 사용하여 명령줄에서 CodeXpert를 실행합니다.

Toad.exe CX=C:\CMDLineCodeXpertINIFile.ini

  3. 지정한 OUTPUT DIRECTORY에 있는 html 파일을 봅니다.

주: 작성된 웹 페이지(html 파일)는 MS Internet Explorer에서 가장 잘 보입니다.

CodeXpert 예약

CodeXpert ini 파일을 작성할 때 작은 프로그램을 작성한 후 나중에 스캔 예약에 사용할 수 있습니다. 응용 프로그램에서는 다음을 수행해야 합니다.

  • 명령줄 CodeXpert INI 파일을 동적으로 작성

  • INI 파일을 매개 변수로 전달하여 Toad 실행(Toad.exe CE=C:\MyDynamicallyCreateINIFile)

관련 항목

CodeXpert 매개 변수 파일


CodeXpert 매개 변수 파일

수동으로 매개 변수 파일을 작성하거나 Toad 자체에서 생성할 수 있습니다.

매개 변수 파일 생성

Toad에서 파일을 생성하면 모든 암호가 암호화되며, 수동으로 작성할 때보다 파일 보안이 더 강화됩니다. Toad에서 매개 변수 파일을 생성하게 하는 것이 더 좋습니다.

주: Toad에서 CodeXpert를 실행하도록 예약하려는 경우에는 매개 변수 파일을 수동으로 작성해야 합니다.

매개 변수 파일을 생성하려면

  1. CodeXpert 창을 엽니다.

  2. Database 메뉴에서 Diagnose|CodeXpert를 선택합니다.

  3. Schema Browser에서 적절한 개체를 마우스 오른쪽 단추로 누르고 Send to CodeXpert를 선택합니다.

  2. 명령줄에서 실행할 개체 또는 파일을 그리드에서 선택합니다.

  3. 마우스 오른쪽 단추를 누르고 Create Command Line Parameter File을 선택합니다.

  4. 매개 변수 파일을 저장할 디렉토리를 선택합니다.

  5. OK를 누릅니다.

수동으로 매개 변수 파일 작성

매개 변수 파일을 직접 작성하는 경우에는 다음 형식을 따라야 합니다.

주: 파일을 직접 작성하는 경우에는 암호를 입력할 수 있도록 PASSWORDS_ENCRYPTED 옵션을 "0"으로 설정해야 합니다. 이 방법은 안전하지 않습니다.

[OPTIONS]

RULESET_FILENAME=C:\Work\Toad\RuleSets\All2.rst

OUTPUTDIR=C:\CodeXpertResults

CODEXPERT_SCAN=1

SQL_SCAN=1

PASSWORDS_ENCRYPTED=0

[CONNECTIONS]

LOGIN1=schema/password@dbalias

LOGIN2=schema/password@dbalias

[OBJECTS]

OBJECT1=LOGIN1, USERNAME, OBJECTNAME

OBJECT2=LOGIN1, USERNAME, OBJECTNAME

OBJECT3=LOGIN2, USERNAME, OBJECTNAME

[FILES]

FILE1=C:\MyProcedure.sql

FILE1=C:\MyFunction.sql

구성 변수 | 의미
RULESET_FILENAME= | 사용할 규칙 집합의 경로입니다.
OUTPUTDIR= | 출력을 저장할 디렉토리의 경로입니다.
CODEXPERT_SCAN= | 1이면 CodeXpert를 실행하고, 0이면 실행하지 않습니다.
SQL_SCAN= | 1이면 SQL Scan을 실행하고, 0이면 실행하지 않습니다.
CONNECTIONS | 사용할 연결을 지정합니다. 연결을 최소한 하나 이상 지정해야 합니다.
OBJECTS | 스캔을 실행할 데이터베이스 개체를 LOGINn, USERNAME, OBJECTNAME 형식으로 지정합니다.
FILES | 스캔을 실행할 파일을 지정합니다.

주 - 지정할 수 있는 개체 수와 스캔할 파일 조합에는 제한이 없습니다.

관련 항목

명령줄에서 CodeXpert 실행


Results 탭

주: 이 확장된 Toad 기능은 Toad for Oracle Professional Edition 이상에서만 사용할 수 있습니다.

Results 탭에는 분석 결과가 표시됩니다. 결과는 트리 계층으로 제공됩니다.

트리 아래에는 세 개의 탭이 더 있습니다.

  • All Rules by Objects(기본 디스플레이) - 규칙 스캔 결과를 나열합니다(자세한 내용은 규칙 참조).

  • Properties - 분석된 코드의 속성을 표시합니다(속성 참조).

  • SQL Scan - 코드에서 SQL 스캔을 실행한 결과를 표시합니다. (SQL Scanning 개요 참조)

관련 항목

규칙

통계 분석

속성

보고서


CodeXpert 규칙

규칙

주: 이 확장된 Toad 기능은 Toad for Oracle Professional Edition 이상에서만 사용할 수 있습니다.

Rules 영역의 내용은 RuleSet에서의 정렬 옵션 구성 방식에 따라 정렬됩니다. 다음과 같은 두 가지 정렬 옵션이 있습니다.

  • 심각도 우선, 차후 목표

  • 목표 우선, 심각도 차후

항목의 왼쪽에 다양한 유형의 규칙 문제가 아이콘으로 표시됩니다. 자세한 내용은 Icon Legend를 참조하십시오.

왼쪽에서 오른쪽으로 이동하면서 Rules 노드의 두 번째 수준에서 제공되는 정보는 다음과 같습니다.

  • 아이콘

  • 코드 요소

  • 규칙 번호

  • (발생 횟수)

  • 규칙 제목

예를 들어 위 화면에서 강조표시된 항목은 Rule 2609 ‘Consider using a parameter list to reference variables outside of this cursor’가 발생한, 'Cursor' 코드 요소 그룹에 속한 46개 중 하나를 표시한 것입니다.

괄호 안에 있는 숫자는 코드에서 항목이 발생한 위치를 나타냅니다.

(453, 38) = 코드의 453줄, 27열

트리에 있는 아이콘을 보면 이 규칙이 유지 목표, 경고 심각도에 해당되는 것을 알 수 있습니다.

관련 항목

통계 분석

속성

보고서


CodeXpert 통계 분석

통계 분석

주: 이 확장된 Toad 기능은 Toad for Oracle Professional Edition 이상에서만 사용할 수 있습니다.

독립 실행형 CodeXpert에는 통계 열이 있고 편집기의 CodeXpert 패널에는 코드의 통계 분석을 표시하는 탭이 있습니다.

Statistics 트리에는 다음 기준을 초과하는 프로그램 단위를 강조표시하는 세 섹션이 있습니다.

  • Computational Complexity (Halstead Volume)

  • Cyclomatic Complexity (McCabe’s)

  • Maintainability Index

관련 항목

규칙

속성

보고서


CodeXpert 속성

속성

주: 이 확장된 Toad 기능은 Toad for Oracle Professional Edition 이상에서만 사용할 수 있습니다.

Properties 트리에는 PL/SQL 프로파일 분석이 포함되어 있습니다. 범주에는 다음이 포함됩니다.

  • 커서 분석

  • 선언 분석

  • DML 분석

  • 예외 처리 분석

  • 모듈 분석

  • Oracle 버전 종속 관계

  • 프로시저/함수 분석

관련 항목

규칙

통계 분석

보고서


CodeXpert Report 탭

Report 탭

주: 이 확장된 Toad 기능은 Toad for Oracle Professional Edition 이상에서만 사용할 수 있습니다.

Report 탭에는 CodeXpert의 분석이 그래픽으로 표시됩니다. 이 보고서는 HTML 문서로 저장되거나, 인쇄 또는 Report 도구 모음의 기능을 통해 별도 뷰어에서 볼 수 있습니다.

관련 항목

Results 탭

규칙

통계 분석

속성

보고서


문 다시 정의

주: 이 확장된 Toad 기능은 Toad for Oracle Professional Edition 이상에서만 사용할 수 있습니다.

특정 항목을 다시 정의할 수 있습니다. 다시 정의된 항목은 ‘Flagged’된 전체 문 계산에 포함되지 않습니다.

이 기능은 단일 사용자 환경에서만 사용할 수 있으며 Source Control을 사용하여 다른 사용자가 코드 분석을 실행하면 덮어쓰기됩니다.

Toad에서는 코드에 주석을 추가하여 다시 정의할 특정 규칙이나 규칙 위반 항목을 표시합니다.

규칙을 다시 정의하려면

  1. 다시 정의할 규칙을 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Override Rule을 선택합니다.

항목을 다시 정의하려면

  1. 다시 정의할 규칙 항목을 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Override Occurrence를 선택합니다.

해당 항목은 더 이상 트리 구조에 표시되지 않습니다.

관련 항목

Code Xpert

규칙 및 문 분해


규칙 집합 구성

주: 이 확장된 Toad 기능은 Toad for Oracle Professional Edition 이상에서만 사용할 수 있습니다.

선택한 CodeXpert 규칙 집합에 따라 특정 분석에 포함되거나 포함되지 않는 규칙이 결정됩니다. 규칙 집합은 CodeXpert RuleSet 창을 통해 구성합니다. 규칙 집합을 작성하거나 RuleSet 창을 사용하는 방법에 대한 자세한 내용은 RuleSet 창을 참조하십시오.

규칙 집합을 구성하려면

  1. CodeXpert General 도구 모음에 있는 Launch RuleSets [image] 단추를 누릅니다.

  2. 포함하거나 제외할 규칙에 해당되는 확인란을 선택하거나 선택 취소합니다.

  3. Close를 누릅니다.

관련 항목

RuleSet 창

RuleSet 도구 모음

Rules 탭 도구 모음

Summary 탭 도구 모음

규칙 집합 작성


RuleSet 창

주: 이 확장된 Toad 기능은 Toad for Oracle Professional Edition 이상에서만 사용할 수 있습니다.

RuleSet 창은 두 패널로 나뉘며, 오른쪽 패널에는 두 개의 탭이 있습니다.

왼쪽 패널

왼쪽 패널에는 CodeXpert에서 사용할 수 있는 모든 규칙 집합의 목록인 RuleSet 목록이 있습니다. 모든 규칙 집합은 속성을 통해 고유하게 식별되며 사용자 정의와 Quest 정의의 두 가지 유형 중 하나에 속합니다.

아이콘 | 의미
 | Quest 정의 규칙 집합
 | 사용자 정의 규칙 집합

오른쪽 패널

오른쪽 패널에는 Rules와 Summary라는 두 탭이 있습니다.

Rules 탭

Rules 탭에는 CodeXpert에서 사용할 수 있는 모든 규칙의 목록인 Rules 목록이 있습니다. 모든 규칙은 규칙 번호로 식별됩니다. 이러한 규칙은 Rules 탭 도구 모음에서 정렬하고, 찾으며, 전체 SQL 스캔을 사용하도록 구성할 수 있습니다.

규칙의 조언 팁을 보려면

  • 목록에 있는 항목을 두 번 누릅니다.

Summary 탭

Summary 탭에는 규칙 집합의 속성과 특징이 그래픽으로 표시됩니다. 이 요약은 HTML 문서로 저장하거나, 인쇄하거나, 별도의 뷰어에서 볼 수 있습니다. 자세한 내용은 Summary 탭 도구 모음 항목을 참조하십시오.

관련 항목

규칙 집합 구성

RuleSet 도구 모음

Rules 탭 도구 모음

Summary 탭 도구 모음

규칙 집합 작성


RuleSet 도구 모음

주: 이 확장된 Toad 기능은 Toad for Oracle Professional Edition 이상에서만 사용할 수 있습니다.

단추 | 명령
 | 새 규칙 집합을 작성합니다. RuleSet 노드가 활성화된 경우에만 사용할 수 있습니다.
 | 선택한 사용자 정의 규칙 집합을 삭제합니다. 주: Toad 규칙 집합은 삭제할 수 없습니다.
 | 기존 규칙 집합을 로드합니다.
 | 규칙 집합을 저장합니다.
 | 규칙 집합을 새 이름으로 저장합니다.
 | 모든 규칙 집합을 저장합니다.

관련 항목

규칙 집합 구성

RuleSet 창

Rules 탭 도구 모음

Summary 탭 도구 모음

규칙 집합 작성


Rules 탭 도구 모음

주: 이 확장된 Toad 기능은 Toad for Oracle Professional Edition 이상에서만 사용할 수 있습니다.

Rules 탭 도구 모음에서는 다음을 수행할 수 있습니다.

  • 선택한 규칙의 정렬 순서 변경

  • 규칙 번호로 규칙 찾기

  • 아이콘 범례 보기

단추 | 명령
Sort Order | 드롭다운 메뉴에서 정렬 순서를 선택합니다.
 | 번호로 규칙을 찾습니다.
 | Icon Legend를 봅니다.
 | CodeXpert 옵션을 엽니다.

관련 항목

규칙 집합 구성

RuleSet 창

RuleSet 도구 모음

Summary 탭 도구 모음

규칙 집합 작성


Summary 탭 도구 모음

주: 이 확장된 Toad 기능은 Toad for Oracle Professional Edition 이상에서만 사용할 수 있습니다.

단추 | 명령
 | 별도의 뷰어에서 요약을 실행
 | 요약을 다양한 HTML 형식으로 저장
 | 인쇄 미리 보기
 | 인쇄

관련 항목

규칙 집합 구성

RuleSet 창

RuleSet 도구 모음

Rules 탭 도구 모음

규칙 집합 작성


규칙 집합 작성 - 개요

규칙 집합 작성

주: 이 확장된 Toad 기능은 Toad for Oracle Professional Edition 이상에서만 사용할 수 있습니다.

회사에 따라 코드가 따라야 할 규칙이 포함된 사용자 정의 규칙 집합을 작성할 수 있습니다. 규칙 집합은 RuleSets 트리의 RuleSet 노드 아래에 폴더로 구성할 수 있습니다.

새 폴더를 작성하려면

  • 트리 구조를 마우스 오른쪽 단추로 누른 다음 New Folder를 선택합니다. 폴더 이름을 지정합니다.

규칙 집합을 작성하려면 두 가지 방법 중 하나를 사용합니다.

다음을 수행할 수 있습니다.

  • 빈 규칙 집합에서 작성

  • 템플릿에서 작성

빈 규칙 집합에서 작성하려면

  1. 규칙 집합을 작성할 폴더 또는 노드를 선택합니다.

  2. RuleSet 도구 모음에서 Create New RuleSet [image] 단추를 누릅니다.

템플릿에서 작성하려면

  1. 규칙 집합을 작성할 폴더 또는 노드를 선택합니다.

  2. New RuleSet [image] 단추 오른쪽에 있는 드롭다운 화살표를 누릅니다.

  3. 템플릿으로 사용할 기존 규칙 집합을 선택합니다. 기존 규칙 집합에서 선택된 모든 규칙이 새 템플릿에서도 선택됩니다.

관련 항목

규칙 집합 구성

RuleSet 창

RuleSet 도구 모음

Rules 탭 도구 모음

Summary 탭 도구 모음

규칙 집합 속성


규칙 집합 속성

주: 이 확장된 Toad 기능은 Toad for Oracle Professional Edition 이상에서만 사용할 수 있습니다.

새로 작성된 규칙 집합은 RuleSet 트리에 일반 노드로 표시되며 보통 RuleSet0*과 같은 이름이 지정됩니다. 이 이름은 이 규칙 집합에 속성이 설정되지 않았으며 저장하기 전에 설정해야 함을 나타냅니다.

규칙 집합에 속성을 설정하고 규칙을 선택한 후 저장한 다음에는 CodeXpert General 도구 모음에 있는 RuleSet 드롭다운에서 선택하여 사용할 수 있습니다.

규칙 집합 속성을 선택하려면

  1. RuleSet을 마우스 오른쪽 단추로 누르고 Properties를 선택합니다.

  2. 속성을 설정합니다.

  3. Rule Set Title – 제목은 트리에서 규칙 집합을 식별하는 이름입니다.

  4. Author – 규칙 집합의 작성자입니다.

  5. Comments – 규칙 집합에 대한 주석을 여기에 입력할 수 있습니다.


SQL Scanning 개요

주: 이 확장된 Toad 기능은 Toad for Oracle XPert Edition에서만 사용할 수 있습니다.

규칙 집합에 SQL 스캔을 포함하면 코드를 향상시킬 추가적인 방법을 찾을 수 있습니다. 모든 규칙 집합에 SQL 스캔을 첨부하거나 제한된 수의 규칙 집합에만 첨부할 수 있습니다.

SQL 스캔을 포함하려면

  1. 편집기의 맨 아래에 있는 Code Xpert 탭을 누릅니다.

  2. Include SQL Scan [image] 토글 단추를 선택합니다.

  3. SQL Scanning Options [image] 단추를 누르고 SQL Scanning 옵션을 선택합니다.

  4. 사용할 규칙 집합이 있는 경우 원한다면 이를 사용하여 선택된 코드에 대해 CodeXpert를 실행합니다.

관련 항목

SQL Scanning 개요

SQL Scanning 옵션

SQL Classification 탭

SQL Scanning 탭

Classification 옵션 적용


SQL Scanning 결과

주: 이 확장된 Toad 기능은 Toad for Oracle XPert Edition에서만 사용할 수 있습니다.

SQL Scanning이 포함된 규칙 집합을 선택하면 Report 탭의 결과 노드에 SQL Scan Results 노드가 포함됩니다.

결과는 다음 네 가지 영역으로 나뉩니다.

  • Invalid SQL

  • Problematic SQL

  • Complex SQL

  • Simple SQL

괄호 안에 있는 숫자는 코드에 있는 SQL 문의 위치를 나타냅니다. 예를 들어 (10,1)은 해당 코드가 10줄, 1열에서 시작되는 것을 나타냅니다.

또한 Toad에서 코드를 변환한 경우에는(SQL 변환 개요 참조) 그 내용이 표시됩니다. Double-click for more information 노테이션이 표시됩니다. 이 줄을 두 번 누르면 변환에 대한 세부 정보가 있는 대화 상자가 표시됩니다. 다른 관련 정보는 항목 아래의 줄에 표시됩니다.


SQL 변환 개요

주: 이 확장된 Toad 기능은 Toad for Oracle XPert Edition에서만 사용할 수 있습니다.

스캔 프로세스에서 SQL 문이 확인되면 실행 계획이 검색됩니다. 실행 계획을 검색할 수 없는 경우에는 SQL 문에 SQL 변환을 적용하여 SQL 문을 유효한 독립 실행형 SQL 문으로 렌더링할 수 있는지 확인합니다. 다음과 같은 변환을 적용할 수 있습니다.

  • 표시기 변환

  • 외부 매개 변수 변환

  • PL/SQL 변환

  • 날짜 변환

  • COBOL 변환

  • 로컬 변수 변환

스캔 프로세스를 진행하는 동안 위와 같은 변환이 한 가지라도 SQL 문에 적용된 경우에는 적용된 변환과 SQL 텍스트의 변경 사항이 결과 패널에 표시됩니다.

관련 항목

표시기 변환

외부 매개 변수 변환

PL/SQL 변환

날짜 변환

COBOL 변환

로컬 변수 변환


표시기 변환

주: 이 확장된 Toad 기능은 Toad for Oracle XPert Edition에서만 사용할 수 있습니다.

Pro*C 또는 이와 유사한 프로그래밍 언어에서는 모든 호스트 변수를 선택 사항인 표시기 변수와 연결할 수 있습니다. SQL 스캔 알고리즘에 표시기 변환을 적용할 수 있는 경우는 두 가지가 있습니다.

INTO 절에 INDICATOR 키워드가 있는 경우

INTO 절에 INDICATOR 키워드가 있으면 변수 이름과 연결됩니다. 예를 들면 다음과 같습니다.

원본 SQL 문

SELECT EMP_ID, EMP_NAME

INTO :v_empid INDICATOR :I_emp_id,

:v_empname INDICATOR :I_empname

FROM EMPLOYEE

WHERE EMP_ID = 100

변환 후

SELECT EMP_ID, EMP_NAME

INTO :v_empid_INDICATOR_:I_emp_id,

:v_empname_INDICATOR_:I_empname

FROM EMPLOYEE

WHERE EMP_ID = 100

INTO 절에 구분 기호 없이 두 변수를 사용한 경우

INTO 절에 구분 기호로 쉼표를 사용하지 않고 두 변수를 사용한 경우에는 서로 연결됩니다. 예를 들면 다음과 같습니다.

원본 SQL 문

SELECT EMP_ID, EMP_NAME

INTO :v_empid :I_emp_id,

:v_empname :I_empname

FROM EMPLOYEE

WHERE EMP_ID = 100

변환 후

SELECT EMP_ID, EMP_NAME

INTO :v_empid_:I_emp_id,

:v_empname_:I_empname

FROM EMPLOYEE

WHERE EMP_ID = 100

관련 항목

SQL 변환 개요

외부 매개 변수 변환

PL/SQL 변환

날짜 변환

COBOL 변환

로컬 변수 변환


외부 매개 변수 변환

주: 이 확장된 Toad 기능은 Toad for Oracle XPert Edition에서만 사용할 수 있습니다.

일부 소스 코드에서는 물음표(?)를 사용하여 외부 매개 변수를 정의합니다. 개별 매개 변수의 고유 참조를 사용할 수 있게 하기 위해 SQL Scanner에서는 각 매개 변수가 SQL 문 내에서 고유한 이름을 가지도록 번호를 추가합니다. 예를 들면 다음과 같습니다.

원본 SQL 문

SELECT EMP_ID

FROM EMPLOYEE

WHERE EMP_ID = ?

AND EMP_NAME = ?

변환 후

SELECT EMP_ID

FROM EMPLOYEE

WHERE EMP_ID = ?1

AND EMP_NAME = ?2

관련 항목

SQL 변환 개요

표시기 변환

PL/SQL 변환

날짜 변환

COBOL 변환

로컬 변수 변환


PL/SQL 변환

주: 이 확장된 Toad 기능은 Toad for Oracle XPert Edition에서만 사용할 수 있습니다.

이 변환에서는 optimizer_mode가 FIRST_ROWS일 때 /*+CHOOSE*/ 힌트를 추가하여 PL/SQL의 동작을 시뮬레이트합니다. 예를 들면 다음과 같습니다.

원본 SQL 문

SELECT EMP_ID

FROM EMPLOYEE

WHERE EMP_ID = 100

변환 후

SELECT /*+CHOOSE*/ EMP_ID

FROM EMPLOYEE

WHERE EMP_ID = 100

관련 항목

SQL 변환 개요

표시기 변환

외부 매개 변수 변환

날짜 변환

COBOL 변환

로컬 변수 변환


날짜 변환

주: 이 확장된 Toad 기능은 Toad for Oracle XPert Edition에서만 사용할 수 있습니다.

날짜 변환은 날짜 변수의 매개 변수에 TO_DATE 함수를 추가합니다. 이 변환은 다음과 같은 방식으로 처리합니다.

원본 SQL에서 실행 계획을 검색했을 때 "Inconsistent datatype" 오류가 반환된 경우, 날짜만 다른 날짜를 사용하여 계산을 수행할 수 있기 때문에 SQL Scanner에서 날짜를 사용하여 변수 계산을 확인하고(예: var_date - date_field) 변환을 적용합니다. 여전히 "Inconsistent datatype" 오류가 발생하는 경우에는 SQL Scanner에서 모든 나머지 변수 이름으로부터 "'%date%"을(를) 확인하고 이름에 "date"라는 말이 포함된 모든 변수를 변환합니다(예: datefield - lastdateused).

식이 date_field - var_a와 같은 패턴으로 되어 있고 변수 이름이 식의 오른쪽에 있으며 “date”라는 말이 포함되지 않은 경우에는 식을 변환하지 않습니다. 변수가 날짜, 숫자 또는 문자열이 될 수도 있기 때문입니다. Oracle에서는 이 변수나 이 식의 결과에 암시적 변환을 수행할 수 있기 때문에 식의 오른쪽에 있는 변수가 실제로 날짜인지 여부를 알기 어렵습니다.

다음은 변환이 적용되는 경우의 예입니다.

예 1

원본

SELECT 1 FROM dual WHERE a - sysdate = 1

변환

SELECT 1 FROM dual WHERE to_date(a) - sysdate = 1

예 2

원본

SELECT 1 FROM dual WHERE sysdate - mydate = 1

변환

SELECT 1 FROM dual WHERE sysdate - to_date(mydate) = 1

예 3

원본

SELECT 1 FROM dual WHERE sysdate - a = 1

변환

변환 없음

관련 항목

SQL 변환 개요

표시기 변환

외부 매개 변수 변환

PL/SQL 변환

COBOL 변환

로컬 변수 변환


COBOL 변환

COBOL 변환에서는 SQL 문의 구문 중 COBOL에는 허용되지만 SQL 구문에는 사용할 수 없는 1) 변수 이름 내의 대시 또는 빼기 기호, 2) SQL 문 중간에 있는 주석, 3) 연결 기호로 사용된 ]](이중 오른쪽 대괄호)의 세 항목을 검색합니다.

변수 이름 변환

변수 이름에 빼기 기호("-")가 포함되어 있는 경우에는 "_"로 바꿉니다.

주석 변환

줄의 7번째 열이 별표("*")면 줄 전체가 주석으로 인식됩니다.

연결 문자 변환

"]]"(오른쪽 대괄호 두 개)는 열 이름 연결에 사용됩니다. 이 문자는 "+"로 바뀝니다.

예:

원본 SQL 문:

SELECT * FROM EMPLOYEE

* Get the department number

WHERE EMP_ID > :employee-id

AND ENAME]]JOB = :name-job

변환 후:

SELECT *

FROM EMPLOYEE -- * Get the department number

WHERE EMP_ID > @employee_id

AND ENAME || JOB = @name_job

주: COBOL 파일의 코드 줄 시작 부분에 태그가 있는 경우에는 Preferences 창의SQL Scanner 탭 페이지에 있는 "Number of characters to be skipped at the beginning of every line for all files"옵션을 사용해야 합니다.

이 변환은 Add Jobs 창에 있는 Source Codes 탭의 COBOL 옵션을 사용하여 스캐너 작업을 Job Manager 창에 추가한 경우에만 적용됩니다.

관련 항목

SQL 변환 개요

표시기 변환

외부 매개 변수 변환

PL/SQL 변환

날짜 변환

로컬 변수 변환


로컬 변수 변환

주: 이 확장된 Toad 기능은 Toad for Oracle XPert Edition에서만 사용할 수 있습니다.

로컬 변수 변환은 SCLD(Single Command Line Dynamic) SQL 파일과 데이터베이스 개체에만 적용됩니다.

SQL 문에서 로컬 변수가 발견되면 SQL Scanner에서 해당 변수 이름을 "&["와 "]"로 묶습니다.

예:

스캔하기 전의 원본 SQL 문:

"SELECT " + VEMPID + " FROM EMPLOYEE WHERE EMP_ID > 100"

변환 후:

SELECT &[VEMPID] FROM EMPLOYEE WHERE EMP_ID > 100

주: 스캔한 SQL 문의 로컬 변수는 바인딩 변수가 아닌 대체 변수로 취급해야 합니다. 따라서 SQL 문을 최적화하기 전에 값을 하드 코딩해야 합니다. 값을 하드 코딩하는 이유는 로컬 변수가 리터럴인 경우 응용 프로그램을 실행하면 SQL을 데이터베이스로 보내기 전에 이 값이 바뀌기 때문입니다. 그래서 SQL Scanner에서 "&["와 "]"를 사용하여 로컬 변수를 바인딩 변수와 구분합니다.

이 변환은 Add Jobs 창의 Summary 탭 페이지나 Job Manager 창의 팝업 메뉴에 있는 Modify 옵션에서 SCLD 옵션을 선택한 경우에만 적용됩니다.

관련 항목

SQL 변환 개요

표시기 변환

외부 매개 변수 변환

PL/SQL 변환

날짜 변환

COBOL 변환


SQL Scanning 옵션

주: 이 확장된 Toad 기능은 Toad for Oracle XPert Edition에서만 사용할 수 있습니다.

Scanning

Scanning 옵션은 스캐너에서 스캔을 수행하는 방법과 대상을 지정하는 일에 도움이 되도록 설계되어 있습니다. 이러한 방식으로 중복된 문을 무시하고 일부 SQL을 건너뛰는 것 등을 선택할 수 있습니다. 자세한 내용은 SQL Scanning 탭을 참조하십시오.

SQL Classification 옵션

SQL 문의 분류는 데이터베이스 환경에서 성능 문제를 일으킬 가능성이 높은 SQL 문을 빠르게 식별하는 일에 도움이 되도록 설계되어 있습니다. 이 분류를 사용하면 SQL 문을 분석하는 기준을 지정할 수 있습니다. SQL 문에는 성능 저하를 일으킬 수 있는 특징이 있기 때문에 Problematic SQL 문이 있으면 성능 문제가 발생할 수 있습니다. 이러한 SQL 문을 최적화하면 데이터베이스 성능을 최대한 향상시킬 수 있습니다.

이러한 분류 설정은 Simple, Complex, Problematic SQL 문의 기준을 설정하는 일에 사용됩니다. 자세한 내용은 SQL Classification 탭을 참조하십시오.

SQL Scanning 옵션을 선택하려면

  • CodeXpert 도구 막대에 있는 Configure Options for Optimization Scan [image] 단추를 누릅니다.

관련 항목

SQL Scanning 개요

SQL Classification 탭

SQL Scanning 탭

Classification 옵션 적용


SQL Scanning 탭

Scanning 탭

주: 이 확장된 Toad 기능은 Toad for Oracle XPert Edition에서만 사용할 수 있습니다.

Skip SQL within comments

스캔 알고리즘에서 /* */, // 또는 -- 주석 형식을 사용하는 주석 내의 SQL 문을 무시하도록 지정합니다. 그렇지 않으면 스캔 알고리즘은 응용 프로그램 내에서 현재 실행되지 않는 SQL 문을 찾습니다. 주석 텍스트 안에 SELECT, INSERT, UPDATE 또는 DELETE라는 단어가 있는 경우 SQL 문을 작성하려 할 수도 있습니다.

Skip SQL that only involves the SYS.DUAL table

SYS.DUAL 테이블만 참조하는 SQL 문을 모두 무시하려면 지정합니다.

Ignore duplicate SQL statements

SQL 문이 텍스트에서 여러 번 발견되는 경우 스캔 결과에 한 번만 포함하려면 지정합니다.

Whole word matching for the first SQL keyword

SELECT, INSERT, UPDATE 또는 DELETE를 단어 전체 일치로 검색하려면 지정합니다. 이 옵션을 선택하면 이 키워드로 단어가 시작되어야 하며 뒤에는 공백이나 줄의 끝을 나타내는 문자가 와야 하기 때문에 INSERT라는 단어가 포함된 PROCEDUREINSERT와 같은 텍스트가 있어도 SQL Scanner에서 이를 찾은 다음 SQL 문을 작성하려 하지 않습니다.

Maximum scanned word size(Bytes)

스캔되는 단어의 최대 크기(바이트)를 지정합니다. 이 크기보다 큰 단어가 있으면 그 SQL은 무시되고 그 다음 위치에서 스캔이 계속됩니다.

기본값은 1024KB입니다. 30 - 9,999,999 중에서 선택합니다.

관련 항목

SQL Scanning 개요

SQL Scanning 옵션

SQL Classification 탭

Classification 옵션 적용


SQL Classification 탭

주: 이 확장된 Toad 기능은 Toad for Oracle XPert Edition에서만 사용할 수 있습니다.

분류를 사용하면 SQL 문을 분석하는 기준을 지정할 수 있습니다. SQL 문에는 성능 저하를 일으킬 수 있는 특징이 있기 때문에 Problematic SQL 문이 있으면 성능 문제가 발생할 수 있습니다. 이러한 SQL 문을 최적화하면 데이터베이스 성능을 최대한 향상시킬 수 있습니다.

Simple SQL

Number of table scan operations less than

이 읽기 전용 필드는 실행 계획에서 참조되는 테이블 스캔 작업의 수를 나타냅니다. 테이블 스캔 작업의 전체 횟수가 이 값보다 작으면 이 SQL 문이 Simple로 분류됩니다. 이 값은 Complex 테이블 스캔 작업 범위의 하한값과 같습니다.

기본값은 2입니다.

Complex SQL

Number of table scan operations

Complex SQL 문의 실행 계획에서 참조되는 테이블 스캔 작업의 수를 지정합니다. 기본값은 2 /3이고 범위는 2 - 99입니다.

Including SYS.DUAL table

SQL 문에서 참조하는 테이블의 수를 계산할 때 SYS.DUAL 테이블을 포함하려면 이 상자를 선택합니다.

With Full Index Scan

전체 색인 스캔이 있는 SQL 문을 Complex SQL 문으로 분류할지 여부를 지정합니다.

Problematic SQL

Number of table scan operations greater than

실행 계획에서 참조되는 테이블 스캔 작업의 수를 나타내는 읽기 전용 필드입니다. 테이블 스캔 작업의 전체 횟수가 이 값보다 크면 SQL 문이 Problematic으로 분류됩니다. 이 값은 Complex 테이블 스캔 작업 범위의 상한값과 같습니다.

기본값은 3입니다.

With full table scan

테이블 크기가 정의된 테이블 크기(KB) 이상이거나 지정된 행 수 이상인 경우 전체 테이블 스캔이 하나 이상 있는 SQL 문을 Problematic으로 분류할지 여부를 지정합니다. 테이블 크기 설정이나 행 수 설정에 대한 자세한 내용은 전체 테이블 스캔 임계값 항목을 참조하십시오.

Table size

기본값은 8이고 선택할 수 있는 값의 범위는 8 - 9,999,996입니다. Table size(KBytes) 옵션에서 비교 단위는 KB입니다. Table size(KBytes) 옵션에 지정되는 값은 4의 배수여야 합니다.

Number of rows

테이블에서 Table size 또는 Number of rows를 선택하여 SQL 문이 Problematic으로 분류되기 전에 필요한 기준 테이블 크기를 결정합니다.

기본값은 1000입니다.

주: 좀 더 정밀한 테이블 크기 계산이 필요한 경우에는 Table size(KBytes)를 사용하는 것이 좋습니다.

Including SYS.DUAL table

SYS.DUAL 테이블을 참조하는 전체 테이블 스캔을 조사하려면 지정합니다.

With full table scan iterated by nested loop

전체 테이블 스캔이 중첩된 루프 안에 있는 SQL 문을 Problematic으로 분류하려면 지정합니다. 이 분류는 테이블의 크기에 따라 결정됩니다. 이 테이블 크기 설정이나 행 수 설정에 대한 자세한 내용은 전체 테이블 스캔 임계값 항목을 참조하십시오.

Table size

Table Size(KB)를 선택한 경우에는 크기 상자에 테이블 크기를 KB 단위로 입력합니다. 기본값은 8입니다. 크기 값은 최대 9,999,996까지 선택할 수 있습니다. Table size(KBytes) 옵션에서 비교 단위는 KB입니다. Table size(KBytes) 옵션에 지정되는 값은 4의 배수여야 합니다.

Number of rows

Number of rows를 선택한 경우에는 크기 상자에 테이블의 행 수 값을 입력합니다. 기본값은 8입니다. 크기 값은 최대 9,999,996까지 선택할 수 있습니다.

주: 좀 더 정밀한 테이블 크기 계산이 필요한 경우에는 Table size(KBytes)를 사용하는 것이 좋습니다.

Include SYS.DUAL table

SYS.DUAL 테이블을 참조하는 전체 테이블 스캔을 조사하려면 지정합니다.

Retrieve table size by counting: SYS.DBA_SEGMENTS

SQL Scanner는 SYS.DBA_SEGMENTS를 사용하여 테이블에 할당된 전체 바이트 수를 계산하는 방식으로 테이블 크기를 계산합니다. 이 정보는 다음 SQL 문을 사용하여 얻습니다.

SELECT SUM(BYTES)/1024 AS "KB"

FROM SYS.DBA_SEGMENTS

WHERE OWNER = :OWNER

AND SEGMENT_NAME = :TABLE_NAME

AND SEGMENT_TYPE LIKE 'TABLE%'

Retrieve table size by counting: System tables

SQL Scanner에서는 테이블 크기 계산에 테이블 블록에 있는 정보를 활용합니다. 이 정보는 다음 SQL 문을 사용하여 얻습니다.

SELECT SUM(SEG.BLOCKS * TS.BLOCKSIZE)/1024 AS "KB"

FROM SYS.USER$ USR,

SYS.OBJ$ OBJ,

SYS.TS$ TS,

SYS.SYS_OBJECTS TAB,

SYS.SEG$ SEG

WHERE SEG.FILE# = TAB.HEADER_FILE

AND SEG.BLOCK# = TAB.HEADER_BLOCK

AND SEG.TS# = TAB.TS_NUMBER

AND SEG.TYPE# = TAB.SEGMENT_TYPE_ID

AND SEG.TS# = TS.TS#

AND TAB.OBJECT_ID = OBJ.OBJ#

AND TAB.OBJECT_TYPE_ID = OBJ.TYPE#

AND OBJ.OWNER# = USR.USER#

AND TAB.OBJECT_TYPE_ID IN (2, 19, 34)

AND USR.NAME = :OWNER

AND OBJ.NAME = :TABLE_NAME

관련 항목

SQL Scanning 개요

SQL Scanning 옵션

SQL Scanning 탭

Classification 옵션 적용


Classification 옵션 적용

주: 이 확장된 Toad 기능은 Toad for Oracle XPert Edition에서만 사용할 수 있습니다.

스캔하는 동안 실행 계획에서 전체 테이블 스캔을 분석하여 SQL 문을 Problematic으로 분류할 것인지 여부를 지정할 수 있습니다.

전체 테이블 스캔 임계값

각 데이터베이스 환경은 고유하기 때문에 Problematic으로 간주하는 기준 임계값(테이블 크기)을 전체 테이블 스캔에 사용자가 지정할 수 있습니다. 전체 테이블 스캔 임계값이 초과되었는데 실행 계획에 전체 테이블 스캔 작업이 있는 경우에는 SQL 문이 Problematic으로 분류됩니다.

기본값

전체 테이블 스캔 작업의 기본 테이블 크기 임계값은 8KB입니다. 임계값이 프로덕션 시스템에 대해 너무 낮을 수 있습니다. SQL Scanner를 사용하기 전에 SQL Classification 옵션을 살펴 보는 것이 좋습니다.

테이블 크기 계산

SQL Scanner는 Retrieving table size by counting 옵션에서 선택한 사항에 따라 다음 방법 중 하나를 사용하여 테이블 크기를 전체 테이블 스캔 임계값과 비교하여 계산합니다.

  • 방법 1 - SYS.DBA_SEGMENTS 시스템 보기에 있는 테이블 정보 활용

  • 방법 2 - 시스템 테이블 SYS.SEG$, SYS.OBJ$, SYS.TS$, SYS.SYS_OBJECTS 및 SYS.USER$에 있는 테이블 정보 활용

활용하는 시스템 보기나 테이블에서 Oracle로 사용할 수 있는 정보에 따라 각 방법에서 보고되는 테이블 크기가 다를 수 있습니다. 특정 데이터베이스 환경에 따라 각 방법에서 테이블 정보를 검색하는 성능이 달라져서 스캔에 걸리는 시간에 영향을 줄 수 있습니다.

SYS.DBA_SEGMENTS 또는 시스템 테이블을 사용하려면 SQL Classification 기본 설정의 Problematic SQL 섹션에서 해당 옵션을 선택합니다.

예 - SYS.DBA_SEGMENTS를 사용하여 전체 테이블 스캔 임계값 결정

이 예에서는 SQL 문을 분류하기 위한 전체 테이블 스캔 임계값의 KB 값을 결정하는 방법에 대해 설명합니다. 이 예에서는 EMPLOYEE 테이블의 전체 테이블 스캔이 이 데이터베이스의 성능 문제가 아니며 따라서 Problematic으로 분류해서는 안 됩니다.

먼저, EMPLOYEE 테이블의 전체 테이블 스캔은 이 데이터베이스의 성능 문제가 아니며문제로 분류해서는 안 됩니다.

다음으로, EMPLOYEE 테이블의 테이블 크기는 SYS.DBA_SEGMENTS를 사용하여 위의 방법 1에 소개된 SQL 문을 실행해서 얻습니다.

SELECT SUM(BYTES)/1024 AS "KB"

FROM SYS.DBA_SEGMENTS

WHERE OWNER = OWNER_NAME

AND SEGMENT_NAME = EMPLOYEE

AND SEGMENT_TYPE LIKE 'TABLE%'

이 SELECT 문의 결과 EMPLOYEE 테이블의 테이블 크기는 64,804KB로 표시되었습니다.

그런 다음, CodeXpert - SQL Classification 옵션에서 SYS.DBA_SEGMENTS 옵션을 선택하고 전체 테이블 스캔 임계값을 64,800 KB(또는 성장을 고려하여 약간 더 높은 값)로 설정합니다.

관련 항목

SQL Scanning 개요

SQL Scanning 옵션

SQL Classification 탭

SQL Scanning 탭


Explain Plan 개요

Explain Plan Current SQL

Explain Plan은 성능 문제를 위해 SQL 문을 분석하는 Oracle 기능입니다. Explain Plan은 지정된 SQL 문이 실행될 때 Oracle에서 따르는 실행 계획을 결정합니다. Explain Plan은 실행 계획의 각 단계를 설명하는 행을 지정된 테이블에 삽입합니다. 비용 기반의 최적화를 사용하는 중이면 이 문은 선택한 문의 실행 비용도 결정합니다.

Explain Plan의 결과에는 다음이 포함됩니다.

  • Oracle에서 테이블을 검색 및 조인하는 순서

  • 사용된 액세스 유형(인덱스 검색 또는 전체 테이블 스캔)

  • 사용된 인덱스의 이름

Toad에서는 Windows 사용자 이름과 함께 날짜 및 시간을 사용하여 Explain Plan에 대한 고유한 문 ID를 생성합니다. 사용자가 일반 사용자 이름보다 긴 이름을 가진 경우 Plan 테이블의 Statement_ID 열을 확장해야 할 수 있습니다.

Explain Plan 테이블을 설정하지 않았거나 Toad Options|Oracle|General에 지정된 Plan 테이블을 설정하지 않은 경우 해당 작업을 수행하라는 메시지가 표시됩니다. 이전 Explain Plan 결과를 저장하지 않으려면 Toad Options|Oracle|General 창에서 Save previous Plan results 옵션을 비활성화합니다. 이렇게 하면 테이블을 만들라는 메시지가 반복하여 표시되지 않습니다.

주: Explain Plan 테이블을 설정하지 않은 경우 이전 Explain Plan을 회수할 수 없습니다.

Explain Plan 결과에 대한 자세한 내용은 Explain Plan 결과를 참조하십시오.

현재 문에 대한 Explain Plan 보기

Editor 도구 모음의 Explain Plan [image] 단추는 현재 문(전체 창 또는 강조표시된 부분)에 대한 Explain Plan을 실행합니다. 그런 다음 editor 아래의 Explain Plan 탭에 결과가 표시됩니다.

결과는 여러 형식으로 표시될 수 있습니다. 기본적으로 계획은 트리 보기로 표시됩니다. 계획 정보를 일반 영어로 표시하거나 두 개의 그래픽 모드 중 하나로 표시하도록 선택할 수도 있습니다.

표시 형식을 변경하려면

  1. Explain Plan을 마우스 오른쪽 단추로 누른 다음 Display Mode를 선택합니다.

  2. 보려는 표시 형식을 선택합니다.

  • Tree

  • Plain English

  • Graphic

  • MS Graph(MS SQL Server 순서도 형식)

Explain Plan 실행

Explain Plan을 전체 스크립트 안의 문이나 단일 SQL 문에서 실행할 수 있습니다.

SQL 문의 Explain Plan 실행

필요한 Toad 임시 테이블을 만들지 않고 Explain Plan을 활성화하려고 하면 테이블이나 보기가 존재하지 않는다는 오류 메시지가 나타납니다.

이는 View|Explain Plan에서 액세스할 수 있는 Explain Plan 창 표시에 영향을 주지 않습니다.

Explain Plan 기록은 Toad_PLAN_SQL 및 Toad_PLAN_TABLE에 저장됩니다.

SQL Editor에서 SQL 문의 Explain Plan을 실행하려면

  • SQL 문에 커서를 놓습니다. Editor|Explain Plan Current SQL을 선택합니다.

또는

<CTRL>E를 입력합니다.


Explain Plan 결과

Explain Plan 트리 보기에는 지정된 문 ID에 대한 Toad_PLAN_TABLE의 내용이 나열됩니다. 이 트리 보기에 대한 정보를 검색하는 데 사용되는 질의는 utlxplp.sql에서 Oralce이 제공하는 질의에 기초합니다. 자세한 내용은 Explain Plan 테이블과 해당 열에 대한 Oracle 설명서를 참조하십시오.

Explain Plan 결과는 다음과 같은 여러 형식으로 표시될 수 있습니다.

  • Tree

  • Plain English

  • Graphic

  • MS Graph

또한 트리 보기에서 일부 열이 표시되는 방법을 선택하거나 모든 열이 표시되도록 할 수 있습니다. 결과를 주 계획과 함께 인라인으로 표시하는 대신에 열로 표시할 경우 사용자의 요구에 맞게 사용자 정의된 표시를 만들 수 있습니다.

표시 모드를 변경하려면

  1. Explain Plan을 마우스 오른쪽 단추로 누른 다음 Display Mode를 선택합니다.

  2. 보려는 표시 형식을 선택합니다.

  • Tree

  • Plain English

  • Graphic

  • MS Graph

내용 조정

Execution Plan Preferences 대화 상자를 사용하여 Explain Plan의 내용을 조정할 수 있습니다. 이 대화 상자에서는 여러 열을 표시하거나 정보를 완전히 숨길 수 있을 뿐만 아니라 정보를 트리 보기와 함께 인라인으로 표시할지 아니면 트리 보기의 왼쪽에 열로 표시할지 선택할 수 있습니다.

트리 보기에서만 내용을 조정할 수 있습니다.

내용을 조정하려면

  1. Explain Plan을 마우스 오른쪽 단추로 누르고 Adjust Content를 선택합니다.

  2. Visible 열에서 확인란을 선택하거나 선택 취소하여 연관된 정보를 표시하거나 숨깁니다.

  3. As Column 열의 확인란을 선택하거나 선택 취소하여 연관된 정보를 계획과 함께 인라인으로 표시하거나 계획 왼쪽의 열에 표시합니다.

  4. Explain Plan에서 원하는 위치로 열을 직접 끌어 열을 다시 정렬합니다. 이 방법으로 열을 원하는 순서대로 또는 계획의 오른쪽에 배치할 수 있습니다.


Explain Plan 인쇄 및 복사

Explain Plan을 실행한 경우 그리드 또는 Explain Plan 창에서 인쇄하거나 클립보드에 복사하여 다른 문서에 붙여넣을 수 있습니다.

Explain Plan을 클립보드에 복사하거나 인쇄할 경우 계층, 일반 텍스트 또는 그래픽인지 여부에 상관없이 표시되는 그대로 복사되거나 인쇄됩니다.

클립보드에 복사하려면

  1. Explain Plan을 실행합니다.

  2. 사용할 Display Mode를 선택합니다.

  3. Explain Plan을 마우스 오른쪽 단추로 누르고 Copy to Clipboard를 선택합니다.

인쇄하려면

  1. Explain Plan을 실행합니다.

  2. 사용할 Display Mode를 선택합니다.

  3. Explain Plan을 마우스 오른쪽 단추로 누르고 Print를 선택합니다.

  4. 프린터 설정을 선택한 다음 OK를 누릅니다.


이전 Explain Plan 결과 보기

주 창 도구 모음의 Explain Plan [image] 단추는 Explain Plan 창을 표시합니다.

이 창에는 Explain Plan에 대한 이전 호출의 결과가 표시됩니다. 이러한 Explain Plan의 형식은 SQL에서 계획을 실행했을 경우와 동일합니다(자세한 내용은 Editor/Explain_Plan_Overview 참조). 이전 계획 출력을 보면 비슷한 문에 대한 다른 결과 또는 수정된 동일한 문에 대한 다른 결과를 비교할 수 있습니다.

사용자가 Explain Plan 창에서 CLEAR 단추를 사용하여 지울 때까지 이전 계획 결과는 Toad 테이블에 남아 있습니다.


Explain Plan 저장

Toad에서 Explain Plan을 저장하는 두 가지 방법이 있습니다.

Database|Optimize|Explain Plan에서 보기 위해 자동으로 저장하거나 XML 파일에 저장할 수 있습니다. 후자의 방법을 사용하면 이후에 현재 또는 기록 Explain Plan을 저장된 파일과 비교할 수 있습니다.

Explain Plan을 자동으로 저장하려면

  1. Toad Options 화면에서 Oracle|General 페이지를 선택합니다.

  2. Save previous Explain Plan results 상자를 선택합니다.

이제부터 실행되는 모든 Explain Plan은 사용자가 지정한 plan_table에 저장됩니다.

Explain Plan을 xml 파일에 저장하려면

  1. Explain Plan을 실행합니다.

  2. 계획을 마우스 오른쪽 단추로 누르고 Save to XML file을 선택합니다.

  3. 위치를 선택하고 파일 이름을 지정한 다음 OK를 누릅니다.

xml 파일을 로드하려면

  1. Explain Plan 영역을 마우스 오른쪽 단추로 누릅니다.

  2. Load from XML file을 선택한 다음 로드할 파일을 선택하고 OK를 누릅니다.

또는

  1. Windows 탐색기에서 Explain Plan 창으로 xml 파일을 끕니다.

관련 항목

Explain Plan 비교

Explain Plan


Explain Plan 비교

현재 실행된 Explain Plan이나 계획 테이블에 저장된 Explain Plan을 XML 파일에 저장한 Explain Plan과 비교할 수 있습니다. 동일한 SQL의 변형을 비교하는 경우 이 작업이 유용할 수 있습니다.

화면의 각 측면은 다른 데이터베이스에 연결될 수 있으므로 이 기능을 사용하여 두 개의 다른 데이터베이스에 있는 동일한 SQL에 대한 계획을 비교할 수 있습니다.

Explain Plan을 비교하면 비교하고 있는 계획의 비교 보기가 나란히 표시됩니다. Explain Plan은 Difference Viewer를 사용하여 비교합니다. 차이를 표시하기 위한 강조표시는 제공되지 않습니다. 그러나 왼쪽 패널 위의 상태 영역에는 필요에 따라 파란색의 Plans Match나 빨간색의 Plans Differ가 표시됩니다.

차이를 강조표시하려면 Explain Plan을 트리 보기로 표시해야 합니다.

Explain Plan을 비교하려면

  1. 다음 중 하나에서 비교할 Explain Plan을 선택합니다.

Editor에서 실행되는 현재 계획

또는

View|Explain Plan 창에서 여는 Explain Plan

  2. 계획을 마우스 오른쪽 단추로 누르고 Compare to another Plan을 선택합니다.

Difference Viewer가 열리고 선택한 계획이 왼쪽에 표시됩니다.

  3. 오른쪽 패널 도구 모음에서 Open Plan 단추를 누르고 비교를 위한 저장된 계획을 선택합니다.

  4. OK를 누릅니다.

관련 항목

파일 차이 보기


Project Manager 개요

Project Manager를 사용하여 작업 영역을 쉽게 구성할 수 있습니다. 창은 트리 구조로 구성되며 트리의 모든 항목은 다른 개체를 가리키는 노드입니다. 여러 다른 Oracle 연결 및 FTP 연결을 하나의 프로젝트로 결합하여 업로드, 다운로드 및 데이터베이스 작업을 쉽게 수행할 수 있습니다. 작업을 추가로 구성하기 위해 하위 프로젝트 폴더를 프로젝트에 추가할 수 있습니다.

최근에 Toad를 업그레이드했고 마우스 오른쪽 단추 메뉴와 같은 새로 사용할 수 있는 Project Manager 작업을 보려면 Project Manager configuration 화면에서 Popup Menus 탭을 선택합니다.

Project Manager 환경을 세부적으로 구성하지 않은 경우에는 창 내의 모든 새 작업을 보기 위해 "Reset all defaults"를 수행할 수도 있습니다.

Connection 패널

Connection 패널은 다양한 연결에 대한 작업을 수행하는 영역입니다. 이 영역에서 새 연결을 작성하거나 연결을 끝내거나 특정 연결에서 스크립트를 실행하는 등의 작업을 수행할 수 있습니다. 자세한 내용은 Connection 패널 사용을 참조하십시오.

노드

Project Manager에서는 사용자가 작업을 정렬할 수 있도록 다음 유형의 노드를 사용합니다.

프로젝트 폴더

오버레이 조직 구성 단위가 프로젝트 폴더 노드입니다. 이 노드는 다른 프로젝트 폴더, 다른 유형의 폴더 또는 다른 콘텐츠를 포함할 수 있습니다.

파일 폴더

파일 폴더 노드를 사용하여 로컬 또는 네트워크 디스크의 폴더를 나타낼 수 있습니다.

파일

폴더 항목 노드를 사용하여 로컬 또는 네트워크 디스크의 파일을 나타낼 수 있습니다. 이러한 파일에는 .sql 파일, .html 파일, .doc 파일 등이 포함될 수 있습니다. 이 노드는 파일 폴더 노드 아래에 있습니다.

FTP 폴더

FTP 폴더 노드를 사용하여 외부 FTP 서버의 폴더를 나타낼 수 있습니다. FTP 파일을 포함합니다.

FTP 파일

FTP 파일 노드를 사용하여 외부 FTP 서버의 파일을 나타낼 수 있습니다. 이 노드는 항상 FTP 폴더 아래에 있습니다.

DB 스키마

데이터베이스 스키마 노드를 추가하여 데이터베이스의 스키마에 대한 연결을 나타낼 수 있습니다. 데이터베이스 개체를 포함할 수 있습니다.

DB 개체

스키마 노드 내에 데이터베이스 개체 노드를 포함할 수 있습니다. 이러한 노드는 데이터베이스에 있는 개체를 나타냅니다. DB 스키마 노드에 포함되어야 합니다.

작업

Project Manager에서는 Windows 작업 스케줄러를 사용하여 작업을 예약할 수 있습니다.

할 일 모음

사용자가 작성한 검사 목록을 나타냅니다. 할 일 모음 항목이 아래에 추가됩니다.

URL

URL을 나타내며 해당 사이트의 바로 가기처럼 작동할 수 있습니다.

노드에서 작업

Project Manager는 구성 가능성이 뛰어나므로 사용자가 간편하게 다양한 개체를 한 번에 작업할 수 있습니다. 다음 작업의 동작을 구성할 수 있습니다.

  • 끌어서 놓기

  • 두 번 누르기

  • 팝업(마우스 오른쪽 단추) 메뉴

  • DDL

  • 정렬

Project Manager를 처음 사용하는 경우에는 이 도움말 파일에서 Project Manager 사용(다른 형식의 개체를 동시에 사용 부분부터)을 읽어보면 이 창에서 수행할 수 있는 작업 유형의 개요를 확인할 수 있을 것입니다. 그런 다음 최적의 방식으로 작동하도록 창을 사용자 정의하는 방법에 대한 설명을 제공하는 Project Manager 구성 항목을 읽어봅니다.

관련 항목

Project Manager 개요

Project Manager 구성

PM - General 옵션

PM - Associations

PM - 끌어서 놓기 작업

PM - 두 번 누르기 작업

PM - 팝업 메뉴

PM - DDL


Project Manager 도구 모음

이 도구 모음을 사용하면 마우스 단추를 눌러 여러 작업을 수행할 수 있습니다.

단추 | 명령
 | 드롭다운 메뉴를 선택하고 추가할 항목을 선택합니다.
 | 프로젝트 파일을 로드합니다.
 | 새 프로젝트 파일을 작성합니다.
 | 프로젝트 파일을 다른 이름으로 저장합니다.
 | 현재 프로젝트 파일을 저장합니다.
 | 프로젝트를 인쇄합니다.
 | Project Manager 내에서 항목을 이동할 수 있도록 순서 바꾸기 모드를 전환합니다. 기본적으로 항목은 추가된 순서대로 계층에 포함됩니다.
 | 데드 링크를 제거합니다.
 | Project Manager를 구성하기 위해 Project Manager 옵션에 액세스합니다.

관련 항목

Project Manager 개요

Project Manager 구성

PM - General 옵션

PM - Associations

PM - 끌어서 놓기 작업

PM - 두 번 누르기 작업

PM - 팝업 메뉴

PM - DDL


데드 링크 제거

프로젝트의 모든 데드 링크를 제거할 수 있습니다. 더 이상 스키마에 존재하지 않는 노드, 더 이상 존재하지 않는 창 작업 등이 여기에 포함됩니다.

제거할 링크 유형을 선택할 경우 해당 유형의 모든 데드 링크가 제거됩니다. 제한된 수의 링크를 제거하려면 해당 노드를 수동으로 제거해야 합니다. 데드 링크를 제거할 경우 데드 노드와 모든 하위 노드가 제거됩니다.

데드 링크를 제거하려면

  1. Project Manager 도구 모음에서 Remove Dead Links [image] 단추를 누릅니다.

  2. Remove Dead Links 대화 상자에서 제거할 데드 링크 유형을 선택합니다. 다음과 같은 옵션이 있습니다.

  3. Database Objects

  4. Folders

  5. Folder Items

  6. Tasks

  7. Named SQL Items

  8. Zip File References

  3. OK를 누릅니다.


Project Manager 구성

Project Manager를 원하는 방식대로 작동하도록 구성할 수 있습니다. 파일을 다른 파일이나 노드로 끌 때 Toad에서 실행하는 명령을 지정할 수 있습니다.

마우스 오른쪽 단추(팝업) 메뉴에 표시되는 메뉴 항목처럼 두 번 누르기를

사용자 정의할 수도 있습니다.

Project Manager를 구성하려면

  1. Project Manager에서 Project Manager Options [image] 단추를 누릅니다.

  2. 구성할 옵션을 선택하거나 선택 취소합니다.

모든 기본값을 재설정하거나 특정 탭에 대한 기본값을 사용하도록 선택할 수도 있습니다.

  3. OK를 누릅니다.

Reset all Defaults

이 대화 상자의 맨 아래에 있는 Reset all Defaults를 누르면 모든 탭에서 기본값이 재설정됩니다.

Use Defaults

개별 탭에서 Use Defaults 단추를 누르면 해당 탭의 경우만 기본 설정으로 돌아갑니다.

관련 항목

Project Manager 개요

Project Manager 구성

PM - General 옵션

PM - Associations

PM - 끌어서 놓기 작업

PM - 두 번 누르기 작업

PM - 팝업 메뉴

PM - DDL


General 옵션

General 옵션을 사용하면 전체 Project Manager의 옵션을 변경할 수 있습니다.

Editor file load options

Reload into existing window

Editor 내용을 기존 Editor 창에 로드하려면 이 옵션을 선택합니다.

이 옵션을 선택하면 새 데이터를 창에 있는 데이터에 추가할지, 창 내용을 완전히 대체할지, 새 탭을 작성하여 SQL을 로드할지 선택해야 합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Load into new window

파일을 로드할 새 Editor 창을 열려면 이 옵션을 선택합니다. 이 옵션은 파일 로드를 위한 기본 옵션입니다.

Generate Script for Multiple check box - 이 옵션을 선택하면 로드할 여러 스크립트가 선택된 경우 다음과 같이 선택한 스크립트를 참조하는 스크립트가 작성됩니다(직원 1부터 3까지 로드하도록 선택했다고 가정).

@"c:\one\two\employees.sql"

@"c:\one\two\employees1.sql"

@"c:\one\two\employees2.sql"

Navigate to previous invocation

이 옵션을 선택하면 이미 Editor에 있는 파일을 Editor에 로드하도록 선택할 경우 해당 Editor 탭으로 이동합니다. 또한 이 옵션을 선택하면 이전에 파일이 로드되었던 Editor를 찾아서 맨 앞으로 가져오고 파일이 로드된 탭이 활성 탭이 됩니다(여러 개가 열린 경우 단순히 탭이 아니라 SE로 이동).

Prompt each time

이 옵션을 선택하면 새 파일을 로드하도록 선택할 때마다 위 옵션 중 하나를 선택하라는 메시지가 표시됩니다.

Export Options

Compress export file (.zip)

이 옵션을 선택하면 내보낸 파일을 .zip 형식으로 압축합니다. 이 옵션은 기본적으로 선택되어 있지 않습니다.

Watch progress

이 옵션을 선택하면 오래 걸리는 내보내기의 진행률을 조사합니다.

FTP server passwords

Save encrypted passwords

이 옵션을 선택하면 FTP 사이트의 암호가 암호화된 형식으로 저장됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Hints

Named SQL

이 옵션을 선택하면 명명된 SQL 항목 위에 포인터를 놓았을 때 기본 SQL을 표시하는 Windows 힌트가 나타납니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Database Objects

이 옵션을 선택하면 데이터베이스 개체 위에 포인터를 놓았을 때 해당 항목과 연관된 메모가 힌트로 표시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

To-Do

이 옵션을 선택하면 할 일 모음 항목 위에 포인터를 놓았을 때 해당 항목과 연관된 메모가 힌트로 표시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

To-Do

Past due color drop down

할 일 모음 항목은 기본적으로 검정색 텍스트로 표시됩니다. 기한을 초과하면 색이 인스턴트 미리 알림으로 변경됩니다. 드롭다운 color 메뉴에서 기한 초과 항목에 사용할 색을 선택합니다.

기본값은 빨간색입니다.

Server side compression

Utility for 'compress' action

compress 드롭다운에서 서버측 압축에 사용할 유틸리티를 선택합니다.

선택 항목은 compress, zip 또는 gzip입니다. 기본값은 compress입니다.

Web Browser

Toad에서 웹 기반 작업에 사용할 웹 브라우저를 선택할 수 있습니다.

Filename

웹 브라우저의 위치를 아는 경우 Filename 상자에 전체 경로를 입력할 수 있습니다.

Browse

표준 Windows Open 대화 상자를 사용하여 웹 브라우저를 찾으려면 Browse 단추를 누릅니다.

Find default

Find default 단추를 누르면 Toad에서 기본 브라우저를 찾아 Filename 상자에 입력합니다.

Dragging and Dropping

Prompt if multiple actions are available

이 옵션을 선택했으며 여러 작업을 사용할 수 있는 경우 수행할 작업을 선택하기 위한 대화 상자가 표시됩니다. 이 대화 상자에서 작업을 기본값으로 만들고 메시지 표시를 해제할 수도 있습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Use user setting

이 옵션을 선택하면 Project Manager Options 창의 "Drag and drop operations" 탭에서 선택한 값이나 기본값이 사용됩니다.

Refresh folder links

Include subdirectories

이 옵션을 선택하면 노드에 있는 폴더의 모든 하위 디렉토리가 새로 고침에 포함됩니다. Project Manager에 전체 폴더 트리가 작성됩니다.

이 옵션을 선택하지 않으면 폴더의 주 디렉토리 아래에 있는 파일만 표시됩니다. 하위 폴더는 추가되지 않습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Refresh after changing properties

이 옵션을 선택하면 필터를 설정하거나 폴더의 속성을 변경할 경우 OK를 눌렀을 때 모든 폴더 링크가 새로 고쳐집니다. 이 옵션을 선택하지 않으면 폴더 링크가 새로 고쳐지지 않습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Prompt before rebuilding

이 옵션을 선택하면 폴더 항목을 새로 고칠 때 모든 링크를 다시 작성하기 전에 확인 메시지가 표시됩니다. 이 옵션을 선택하지 않으면 확인 메시지 없이 링크가 작성됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Shell for remote file execution

파일을 원격을 실행할 때 사용할 셸을 선택할 수 있습니다. 드롭다운 메뉴에서 선택합니다. 다음 일반 셸을 사용할 수 있습니다.

  • Bourne 셸(sh)

  • Korn 셸(ksh)

  • CSH

또한 상자에 해당 셸 이름을 입력하여 고유한 셸 선택을 제공할 수 있습니다.

Tree

Font

Font 단추를 누르면 Project Manager에서 사용되는 글꼴 및 글꼴 속성을 선택하기 위한 표준 Font 대화 상자가 표시됩니다.

기본값은 MS Sans Serif입니다.

SmartExpand

한 번에 하나의 최상위 수준 프로젝트 노드만 확장할 수 있도록 허용하려면 이 확인란을 선택합니다. 하나의 노드를 확장하면 다른 노드가 축소됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

관련 항목

Project Manager 개요

Project Manager 구성

PM - Associations

PM - 끌어서 놓기 작업

PM - 두 번 누르기 작업

PM - 팝업 메뉴

PM - DDL


PM - Associations

Applications Properties 상자를 사용하여 다양한 파일 확장명에 대한 연결을 선택할 수 있습니다.

Application Properties 대화 상자는 Project Manager에서 액세스할 수 있습니다.

응용 프로그램 속성을 설정하려면

  1. 도구 모음에서 Settings [image] 단추를 누릅니다.

  2. Associations 탭을 누릅니다.

  3. Add를 누르거나 연결을 선택하고 Edit를 누릅니다. Application Properties 대화 상자가 나타납니다.

이 대화 상자에서 연결을 쉽게 작성하거나 편집할 수 있습니다.

Property Descriptions

Title

Project Manager에서 연결에 사용할 제목을 입력합니다.

Program

프로그램의 전체 경로 이름을 입력하거나 찾아보기 [image] 단추를 눌러 검색합니다.

Working dir

이 응용 프로그램의 작업 디렉토리로 지정할 디렉토리의 전체 경로 이름을 입력합니다.

Parameters

다음 매개 변수 중 하나 이상을 사용하여 응용 프로그램을 구성할 수 있습니다.

  5. $UID - 현재 Toad 사용자 ID를 입력합니다.

  6. $UPW - 현재 Toad 사용자 암호를 입력합니다.

  7. $SID - 현재 Toad 데이터베이스 ID를 입력합니다.

  8. $CWD - 현재 Toad 작업 디렉토리를 입력합니다.

  9. $TMP - Windows 임시 디렉토리를 입력합니다.

  10. $FIL - 활성 Editor에 파일을 입력합니다.

  11. %S(또는 "%S") - 파일 이름이 표시되어야 하는 위치를 지정합니다(지정하지 않을 경우 표준 규칙인 "app.exe -options filename"이 사용됨).

이러한 매개 변수를 개별적으로 또는 결합하여 사용할 수 있습니다. 예를 들어 활성 Editor의 현재 파일과 함께 메모장을 자동으로 열려면 위에 설명된 것처럼 메모장을 열기 위한 정보를 입력하고 Parameters 필드에 $FIL을 입력합니다.

또한 현재 Toad 연결과 함께 sql plus를 시작하는 sqlplusw.exe $UID/$UPW@$SID 명령을 입력할 수 있습니다.

Extensions

이 응용 프로그램과 연결할 확장명을 입력합니다.

Run

다음과 같이 응용 프로그램에 액세스했을 때 응용 프로그램이 실행되는 방법에 대한 매개 변수를 입력합니다.

  • Window type - 열려는 창 유형으로 Normal, Minimized 또는 Maximized를 지정합니다.

  • Launch new - Project Manager에서 액세스할 때 응용 프로그램의 새 인스턴스를 시작합니다.

  • Use existing if possible - 응용 프로그램의 기존 인스턴스가 실행 중이면 응용 프로그램을 다시 시작하기 전에 기존 인스턴스의 사용을 시도합니다.

아이콘

이 응용 프로그램을 사용하는 파일과 연결할 아이콘을 선택합니다.

관련 항목

Toad 도구 구성


PM - 끌어서 놓기 작업

끌어서 놓기 작업 화면을 사용하여 Project Manager에서 항목을 끌었을 때 Toad에서 수행하는 작업을 구성할 수 있습니다.

그리드는 "다음 소스 및 대상일 경우 다음 작업 수행" 형식으로 간단하게 구성됩니다. 수행되는 작업을 다른 작업으로 쉽게 설정할 수 있습니다.

끌어서 놓기에서 수행되는 작업을 변경하려면

  1. 변경할 작업을 누릅니다. 셀의 오른쪽에 화살표가 나타납니다.

  2. 화살표를 눌러 가능한 작업 메뉴를 표시합니다.

  3. 선택할 작업을 누릅니다.

관련 항목

Project Manager 개요

Project Manager 구성

기본 동작 변경

PM - General 옵션

PM - Associations

PM - 두 번 누르기 작업

PM - 팝업 메뉴

PM - DDL


PM - 두 번 누르기 작업

두 번 누르기 작업 화면을 사용하여 Project Manager에서 항목을 끌었을 때 Toad에서 수행하는 작업을 구성할 수 있습니다.

그리드는 "다음 소스일 경우 다음 작업 수행" 형식으로 간단하게 구성됩니다. 수행되는 작업을 다른 작업으로 쉽게 설정할 수 있습니다.

두 번 누르기에서 수행되는 작업을 변경하려면

  1. 변경할 작업을 누릅니다. 셀의 오른쪽에 화살표가 나타납니다.

  2. 화살표를 눌러 가능한 작업 메뉴를 표시합니다.

  3. 선택할 작업을 누릅니다.

관련 항목

Project Manager 개요

Project Manager 구성

PM - General 옵션

PM - Associations

PM - 끌어서 놓기 작업

PM - 팝업 메뉴

PM - DDL


PM - 팝업 메뉴

Project Manager에 있는 다양한 개체에 대한 마우스 오른쪽 단추 메뉴를 사용자 정의할 수 있습니다.

왼쪽 창에 있는 각각의 다른 개체 유형은 연결된 팝업(마우스 오른쪽 단추) 메뉴를 가집니다. 이는 FTP 폴더를 선택한 경우 FTP 아래의 선택된 항목이 메뉴에 나타난다는 것을 의미합니다. 대부분의 경우 추가한 항목은 마우스 오른쪽 단추 메뉴의 맨 위 영역에 추가됩니다. Add, Remove, Rename, Copy, Properties 등의 표준 항목은 아래쪽 영역에 있습니다.

주: 열린 연결이 있는 스키마 노드 아래의 데이터베이스 개체의 경우 마우스 오른쪽 단추 메뉴의 맨 위 부분에는 해당 개체 유형에 대한 Schema Browser 메뉴가 있습니다. 이 부분은 사용자 정의할 수 없습니다. 모든 변경 내용은 Schema Browser 메뉴 아래에 적용됩니다.

또한 경우에 따라서는 특정 파일 형식에만 관련된 특정 메뉴 항목(예: SQL 파일에 대해서만 표시되는 Run in Quest ScriptRunner 항목)이 표시될 수 있습니다. 이러한 항목은 해당 확장명에 정의된 파일 형식에만 관련되며 사용자 정의할 수 없습니다.

팝업 메뉴를 사용자 정의하려면

  1. Configuration 창에서 Popup menus 탭을 누릅니다.

  2. 다양한 메뉴에 표시할 메뉴 항목을 선택하고 표시하지 않을 항목을 선택 취소합니다.

  3. OK를 누릅니다.

기본값 재설정

기본값을 팝업 메뉴 영역에서만 재설정하거나 Project Manager 전체에서 재설정할 수 있습니다.

팝업 메뉴에서만 기본값을 재설정하려면

  • Use Defaults 단추를 누릅니다.

Project Manager 전체에서 기본값을 재설정하려면

  • Restore Defaults 단추를 누릅니다.

관련 항목

Project Manager 개요

Project Manager 구성

PM - General 옵션

PM - Associations

PM - 끌어서 놓기 작업

PM - 두 번 누르기 작업

PM - DDL


PM - DDL

copy DDL to Folder와 같은 DDL 작업을 선택할 경우 Toad에서 작성하는 DDL 스크립트 절을 수정할 수 있습니다.

DDL 절을 수정하려면

  1. Configuration 대화 상자에서 DDL 탭을 누릅니다.

  2. 변경할 DDL이 포함된 개체를 나열하는 탭을 누릅니다.

  3. 스크립트의 일부로 포함할 각 스크립트 유형의 절을 선택합니다. 포함하지 않으려는 절은 선택 취소합니다.

  4. 다른 탭을 누르거나 OK를 누릅니다.

관련 항목

Project Manager 개요

Project Manager 구성

PM - General 옵션

PM - Associations

PM - 끌어서 놓기 작업

PM - 두 번 누르기 작업

PM - 팝업 메뉴


다른 형식의 개체를 동시에 사용

Project Manager를 사용하는 가장 중요한 이점 중 하나는 여러 형식의 개체를 동시에 작업할 수 있다는 것입니다. 이러한 개체를 끌어서 놓는 방법으로 기능에 액세스할 수 있습니다.

다양한 형식의 데이터베이스 개체를 하나 이상의 스키마 노드 아래에 추가한 후 다음을 수행할 수 있습니다.

  • 여러 데이터베이스를 개체를 선택하고 마우스 오른쪽 단추를 누른 다음 DDL to clipboard, DDL to file, Load DDL into Editor 또는 Describe(개체 유형에 따라서는 Describe를 사용하지 못할 수도 있음)를 선택합니다.

  • 개체를 다른 개체로 끌어 비교합니다.

  • 개체를 로컬 또는 원격 파일 폴더 링크로 끌어 로컬 또는 원격 폴더에 저장되는 DDL 파일을 생성합니다.

  • 개체를 로컬 또는 원격 파일로 끌어 개체에 대한 DDL을 생성하고 대상 파일을 DDL로 덮어씁니다.


서버 디렉토리 및 파일 작업

Project Manager의 또 다른 이점 중 하나는 FTP 서버 디렉토리와 파일을 쉽게 작업할 수 있는 기능입니다.

FTP 폴더를 작성하고(FTP 폴더 참조) 서버 정보를 추가한 후 노드 복사 기능을 사용하여 추가 노드와 서버를 신속하게 작성할 수 있습니다. 또한 마우스 오른쪽 단추를 선택하고 Rename을 선택하여 디렉토리에 포함된 내용을 더 논리적으로 표현하기 위해 Toad UNIX Scheduler log files와 같은 형태로 노드의 이름을 바꿀 수 있습니다.

여기에서 다음을 수행할 수 있습니다.

  • 하나 이상의 서버 노드를 선택하고 마우스 오른쪽 단추를 누른 다음 Refresh server links를 선택합니다. 이렇게 하면 선택한 서버 디렉토리 아래의 모든 파일에 대한 바로 가기가 작성됩니다. 서버 디렉토리 내용의 업데이트 목록을 얻으려면 새로 고침을 선택하여 노드를 다시 작성하면 됩니다.

  • 서버 파일 링크를 로컬 디렉토리로 끌어서 파일을 다운로드합니다.

  • 로컬 파일 링크를 서버 디렉토리로 끌어서 파일을 서버에 업로드합니다.

  • 파일을 휴지통으로 끌어서 휴지통으로 이동합니다.


Toad 창 또는 외부 응용 프로그램에 로컬 또는 서버 파일 로드

Toad 또는 다른 응용 프로그램에서 파일에 대한 작업을 자주 수행하는 경우 Project Manager에서 해당 링크를 추가할 수 있습니다. 그런 다음 파일 확장명을 Toad 창이나 정의된 외부 응용 프로그램에 연결할 수 있습니다. 확장명 연결에 대한 자세한 내용은 Project Manager 구성을 참조하십시오.

파일을 연결할 수 있는 Toad 창은 Editor, Offline Editor, SQL*Loader, Query Builder, TNSNames Editor, Export File Browser 및 Project Manager 자체입니다. 두 번 누르거나 마우스 오른쪽 단추를 누르고 Load를 선택하면 이러한 창에 대한 미리 정의된 확장명과 일치하는 파일이 로드됩니다.

주: 모든 옵션을 보고 있는지 확인하려면 Add defaults 단추를 누릅니다.

Project Manager 옵션에서 General 탭을 사용하여 Toad 창의 기본 확장명을 변경하거나 외부 응용 프로그램 자체를 추가할 수 있습니다. 예를 들어 Internet Explorer를 응용 프로그램으로 추가하고 htm 및 html 파일과 연결할 수 있습니다.

연결할 수 있는 모든 파일 형식을 보려면

  • Add defaults를 누릅니다.

여러 파일을 로드하려면

  1. 파일을 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Load를 선택합니다. Editor에 로드하는 경우 각 항목에 대한 별개의 탭이 작성됩니다. Enter 키는 한 번에 하나의 노드/파일에서만 발생할 수 있는 두 번 누르기 이벤트에 연결되므로 Enter 키를 누르면 하나의 파일만 로드됩니다.


로컬 파일 및 디렉토리 작업

Windows 탐색기에서 폴더를 프로젝트에 끌어서 놓는 방법으로 로컬 폴더와 파일에 대한 링크를 작성할 수 있습니다. 또한 프로젝트를 마우스 오른쪽 단추로 누르고 Add|Folder and Add|Folder Items를 선택할 수 있습니다.

로컬 폴더와 파일에 대한 바로 가기가 있으면 다음을 수행할 수 있습니다.

  • 폴더를 마우스 오른쪽 단추로 누르고 Refresh folder links를 선택하여 해당 폴더의 모든 파일에 대한 바로 가기 목록을 자동으로 작성합니다.

  • 파일을 다른 파일로 끌어서 Toad의 파일 비교를 수행합니다.

  • 파일과 폴더를 서버 디렉토리로 끌어서 업로드합니다. 폴더를 서버 폴더로 끌면 모든 기본 파일이 업로드됩니다.

  • 파일을 휴지통으로 끌어서 휴지통으로 이동합니다.


기본 동작 변경

Project Manager는 완전히 사용자가 프로그래밍할 수 있습니다. 즉, Project Manager에 여러 미리 정의된 작업이 있는 것으로 생각할 수 있습니다. 세 가지 다른 유형의 사용자 작업인 끌어서 놓기, 두 번 누르기 및 마우스 오른쪽 단추 누르기 도중에 이러한 작업이 발생합니다. 이러한 작업 중 하나를 수행할 때 Project Manager의 동작을 변경할 수 있습니다. 여기에서는 수행할 수 있는 작업 유형의 개요가 제공됩니다. 각 작업에 대한 작업을 변경하는 방법은 Project Manager 구성을 참조하십시오.

끌어서 놓기

끌어서 놓기 작업에 대한 작업을 지정할 경우 먼저 끌려는 노드 유형과 끌어서 놓을 위치에 해당하는 노드 유형을 고려해야 합니다. 그런 다음 끌어서 놓기가 수행될 때 발생할 작업을 Project Manager에 지시할 수 있습니다. 예를 들어 파일 폴더 항목을 파일 폴더로 끄는 경우 파일을 이동할지 아니면 복사할지 여부를 Project Manager에 알릴 수 있습니다.

두 번 누르기

두 번 누르기 작업에는 더 많은 가능성이 있습니다. 대부분의 데이터베이스 개체 유형에 대한 기본값은 ‘Describe’ 창을 여는 것입니다. 그러나 각 데이터베이스 개체 노드 유형에 대해 이 기본값을 ‘DDL to clipboard,’ ‘DDL to file’ 및 ‘Load DDL into Editor’와 같은 다른 작업으로 변경할 수 있습니다. 소스 코드의 경우 ‘Load into Editor’도 있습니다.

마우스 오른쪽 단추 메뉴

마우스 오른쪽 단추 메뉴도 구성할 수 있습니다. 메뉴에 표시되는 항목뿐만 아니라 해당 순서를 선택할 수 있습니다. 메뉴의 맨 아래 부분은 정적입니다. 또한 일부 데이터베이스 개체 노드 유형의 경우 마우스 오른쪽 단추 메뉴에는 해당 개체 유형에 대한 전체 Schema Browser 마우스 오른쪽 단추 메뉴가 포함됩니다.

관련 항목

Project Manager 개요

Project Manager 구성

PM - General 옵션

PM - Associations

PM - 끌어서 놓기 작업

PM - 두 번 누르기 작업

PM - 팝업 메뉴

PM - DDL


프로젝트 간 노드 복사

한 번에 여러 프로젝트를 진행 중이고 동일한 파일, FTP 연결 또는 스키마에 대한 링크가 필요한 경우 한 프로젝트에서 다른 프로젝트에 복사할 수 있습니다.

이 복사 기능은 두 번째 수준 노드인 스키마, 폴더 및 FTP 폴더에 적용됩니다. 이 기능은 선택한 노드와 그 아래에 있는 모든 항목을 복사합니다.

프로젝트 간에 노드를 복사하려면

  1. 복사할 노드를 선택합니다. <SHIFT> 또는 <CTRL> 키를 사용하여 여러 노드를 선택할 수 있습니다.

  2. 마우스 오른쪽 단추를 누르고 메뉴에서 Copy를 선택합니다. Destination Projects 대화 상자가 나타납니다. 이 대화 상자에는 Project Manager에서 설정한 다른 모든 프로젝트 폴더 목록이 있습니다.

  3. 하나 이상의 프로젝트를 선택합니다. All 또는 None 단추를 사용하여 모든 프로젝트를 선택하거나 선택 취소할 수 있습니다.

  4. OK를 누릅니다. 선택한 노드가 다른 프로젝트에 복사되고 사용자는 Project Manager로 돌아갑니다.


Project Manager 정렬

Project Manager에서 모든 노드 아래의 항목을 쉽게 정렬할 수 있습니다.

  1. 정렬할 노드를 선택합니다.

주: 한 번에 하나의 노드만 선택합니다. 여러 노드를 선택할 경우 정렬되지 않습니다.

  2. 마우스 오른쪽 단추를 누르고 Sort를 선택합니다. 이제 선택한 노드 바로 아래에 있는 노드가 알파벳 순서대로 표시됩니다.

관련 항목

노드 검색

Project Manager 개요

Project Manager 도구 모음


노드 검색

Project Manager가 구성되었으며 파일과 스키마가 준비된 경우 입력한 항목을 쉽게 찾을 수 있습니다. 왼쪽 트리 보기에서 아무 곳이나 누르고 입력을 시작합니다. 커서 뒤에 입력한 내용의 첫 번째 항목이 검색되고 강조표시됩니다.


파일 서식 지정

Project Manager에서 파일의 서식을 지정할 수 있습니다. 이 기능을 통해 스크립트, 프로시저, 함수 등을 더 쉽게 변환함으로써 회사의 서식 요구 사항을 준수할 수 있습니다.

서식 지정할 파일은 Project Manager에 노드로 포함되어야 합니다. 폴더 항목 추가를 참조하십시오.

주: 서식은 팝업 메뉴에서 즉시 액세스할 수 없습니다. Project Manager 구성 - 팝업 메뉴에 설명된 대로 메뉴에 추가해야 합니다.

파일은 자동으로 서식이 지정되고 서식 지정 프로세스의 결과가 Output 창의 Formatting Results 탭에 표시됩니다. 적절한 서식 지정을 방해하는 구문 오류가 코드에 있는 경우 해당 오류도 나열됩니다.

Project Manager에서 한 파일의 서식을 지정하려면

  1. Project Manager에서 서식 지정할 파일을 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Format Files를 선택합니다.

Project Manager에서 여러 파일의 서식을 지정하려면

  1. Project Manager에서 서식 지정할 파일을 선택합니다.

또는

서식 지정할 파일을 직접 포함하는 폴더나 프로젝트 노드를 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Format Files를 선택합니다.

관련 항목

구문 오류

프로파일링


파일에서 구문 검사

Project Manager 트리에서 파일의 구문을 검사할 수 있습니다. 여러 파일을 검사하거나 한 번에 하나씩 검사할 수 있습니다.

Output 창의 Syntax Check Results 탭에 결과가 표시됩니다.

파일에서 구문 오류를 검사하려면

  1. Project Manager 트리에서 하나 이상의 파일을 선택합니다.

또는

검사할 파일이 포함된 폴더나 프로젝트 노드를 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Check Syntax를 선택합니다.

관련 항목

파일 서식 지정

Connection 패널 사용


Connection 패널 사용

connection 패널은 Project Manager 도구 모음 바로 아래의 맨 위 패널에 있습니다.

connection 패널에서 연결을 쉽게 관리할 수 있습니다. 다음을 수행할 수 있습니다.

  • 활성 세션을 선택하고 프로젝트 폴더로 끌어 새 스키마 노드를 작성합니다.

  • 새 연결을 작성합니다.

  • 선택한 연결에 대해 quickscript를 실행합니다.

  • 선택한 연결에 대해 명명된 sql을 실행합니다.

  • TNS 이름 정보를 클립보드에 복사합니다.

  • 여러 데이터베이스에서 개체를 작성합니다.

관련 항목

새 연결 작성

여러 데이터베이스에서 개체 작성

명명된 SQL 실행

QuickScript 실행

TNS 이름 정보를 클립보드에 복사


새 연결 작성

Project Manager의 Connection 패널을 여러 방법으로 사용하여 새 연결을 작성할 수 있습니다.

세 연결을 작성하려면

  1. Connection 패널을 마우스 오른쪽 단추로 누릅니다.

  2. New Connection을 선택합니다.

빠른 연결을 작성하려면

  1. Connection 패널을 마우스 오른쪽 단추로 누릅니다.

  2. Quick Connect를 선택합니다.

  3. All을 선택하여 사용 가능한 모든 연결을 나열합니다.

또는

서버를 선택한 다음 서버 메뉴에서 연결을 선택합니다.

  4. 암호가 저장되지 않은 경우 로그인 정보를 제공하라는 메시지가 표시되고 Server Login 창이 나타납니다. 암호가 저장된 경우 연결이 자동으로 설정됩니다.


QuickScript 실행

Project Manager의 Connection 패널에서 구성된 모든 QuickScript를 선택한 연결에 대해 실행할 수 있습니다.

QuickScript를 실행하려면

  1. ConnectioSn 패널에서 QuickScript를 실행할 하나 이상의 연결을 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Execute QuickScript를 선택합니다.

  3. 실행할 스크립트를 선택합니다.


명명된 SQL 실행

Project Manager의 Connection 패널에서 선택한 연결에 대해 명명된 SQL을 실행할 수 있습니다.

명명된 SQL을 실행하려면

  1. Connection 패널에서 하나 이상의 연결을 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Execute Named SQL을 선택합니다.

  3. 실행할 SQL을 선택합니다.


여러 데이터베이스에서 개체 작성

Project Manager Connection 패널을 사용하여 여러 데이터베이스에서 개체를 작성할 수 있습니다. 이 방법은 다양한 스키마에서 동일한 개체가 필요한 경우 매우 유용합니다. 개체를 한 번에 작성하여 시간을 절약할 수 있습니다.

여러 데이터베이스에서 개체를 작성할 경우 열리는 Create 창은 선택한 가장 낮은 Oracle 버전에 해당합니다. 따라서 Oracle 8i 데이터베이스에 대한 연결과 Oracle 10g 데이터베이스에 대한 연결을 선택한 경우 Create 창의 옵션은 8i와 호환됩니다. 스키마 목록 및 사용 가능한 데이터 형식과 같은 창에 로드되는 모든 DB 정보는 하위 Oracle 버전에서 로드됩니다.

이는 가장 낮은 Oracle 버전에서 Create를 소유하며 생성된 SQL이 Connection 패널에서 선택한 다른 연결에 대해 실행된다는 것을 의미합니다.

여러 데이터베이스에서 개체를 작성하려면

  1. Connection 패널에서 개체를 작성할 연결을 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Multi-database Create를 선택합니다.

  3. 작성할 개체 유형을 선택합니다.

  4. Policy

  5. Policy Group

  6. Profile

  7. Resource Consumer Group

  8. Resource Plan

  9. Role

  10. Table

  11. User

  4. 표시되는 Create 창에 해당 정보를 입력합니다.

  5. Create를 누릅니다.

Schedule 단추를 사용하여 나중에 데이터베이스에 대해 스크립트를 실행할 수도 있습니다.


TNS 이름 정보를 클립보드에 복사

하나 이상의 선택한 연결에 대한 TNS 이름 정보를 클립보드에 복사할 수 있습니다. 클립보드에서 필요한 모든 위치로 정보를 붙여넣을 수 있습니다.

TNS 이름 정보를 복사하려면

  1. connection 패널에서 하나 이상의 활성 연결을 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Copy TNS Names Info to Clipboard를 선택합니다.

  3. 필요한 위치에 붙여넣습니다.


프로젝트 노드

프로젝트 노드는 Project Manager 창의 핵심입니다. 프로젝트 노드는 파일을 쉽게 구성하는 데 필수적입니다.

각 프로젝트 노드 내에서 FTP 폴더, 일반 폴더, 연결 링크 및 데이터베이스 개체에 대한 링크를 저장할 수 있습니다. 여러 다른 프로젝트 노드가 동일한 항목에 대한 링크를 포함할 수 있습니다. 예를 들어 동일한 파일에 대한 링크를 포함하는 개발을 위한 프로젝트와 프로덕션을 위한 프로젝트가 존재할 수 있습니다.

다음을 수행할 수 있습니다.

  • 프로젝트 노드 추가

  • 프로젝트 저장

  • 프로젝트 이름 바꾸기

  • 프로젝트 제거


프로젝트 노드 추가

두 가지 방법으로 프로젝트 노드를 추가할 수 있습니다.

프로젝트 노드를 추가하려면

  • 마우스 오른쪽 단추를 누르고 Add Project를 선택합니다.

또는

도구 모음의 Add Item 드롭다운에서 Projec를 선택합니다.

주: Schema Browser에서 항목을 추가하는 중이면 드롭다운 목록에서 선택하는 대신에 프로젝트 이름을 Name 상자에 입력하여 새 프로젝트를 작성할 수 있습니다.

관련 항목

프로젝트 노드

프로젝트 저장

프로젝트 이름 바꾸기

프로젝트 제거


프로젝트 저장

Project Manager 구성을 파일에 저장할 수 있습니다. 따라서 유지 관리하는 프로젝트가 있을 경우 해당 설정을 새 파일에 저장할 수 있으며 현재 프로젝트를 위해 Project Manager 창을 비워둘 수 있습니다. 그런 다음 필요한 경우 해당 프로젝트를 다시 로드할 수 있습니다. 이렇게 하면 Project Manager 창을 단순하게 유지하는 데 도움이 됩니다.

프로젝트를 저장하려면

  • 도구 모음에서 Save to File [image] 단추를 눌러 Project Manager의 내용을 새 파일 이름으로 저장합니다.

이미 프로젝트를 저장했으며 단순히 업데이트하려는 경우 도구 모음의 save [image] 단추를 누릅니다. 또한 Project Manager 창을 닫을 경우 현재 Project Manager 파일이 자동으로 저장됩니다.

관련 항목

프로젝트 노드

프로젝트 노드 추가

프로젝트 이름 바꾸기

프로젝트 제거


프로젝트 이름 바꾸기

프로젝트가 Project Manager에 처음 추가되면 Toad Project라는 이름이 지정되지만 프로젝트는 Rename Mode에서 작성됩니다. 이 이름을 작업 환경에 더 적합하게 변경할 수 있습니다. 단순히 새 이름을 입력하고 <Enter> 키를 누르면 됩니다.

프로젝트 이름을 변경하려면

  1. 프로젝트 계층에서 프로젝트를 선택하고 <F2> 키를 누릅니다.

또는

프로젝트을 마우스 오른쪽 단추로 누르고 Rename을 선택합니다.

  2. 새 프로젝트 이름을 입력하고 <ENTER> 키를 누릅니다.

관련 항목

프로젝트 노드

프로젝트 노드 추가

프로젝트 저장

프로젝트 제거


프로젝트 제거

Project Manager에서 프로젝트를 완전히 제거할 수도 있습니다.

Project Manager에서 프로젝트를 제거하려면

  1. 프로젝트를 하나 이상 선택하고 마우스 오른쪽 단추를 누른 다음 메뉴에서 Remove를 선택합니다.

  2. 확인 대화 상자가 나타납니다. Yes를 눌러 프로젝트 노드를 제거합니다.

이렇게 하면 노드와 노드 아래의 항목에 대한 모든 링크가 Project Manager에서 제거됩니다. 하드 드라이브에서 파일이 제거되지는 않습니다.

관련 항목

프로젝트 노드

프로젝트 노드 추가

프로젝트 저장

프로젝트 이름 바꾸기


스키마 노드

각 프로젝트 내에서 여러 다른 스키마나 사용자를 사용할 수 있습니다. Project Manager를 사용하여 연결에 액세스하거나 연결되었는지 확인하거나 현재 연결되지 않은 경우 연결할 수 있습니다. 또한 스키마 노드를 다른 스키마 노드로 끌었을 때 두 노드에서 스키마 비교를 자동으로 실행하도록 Project Manager를 구성할 수 있습니다.

또한 스키마 노드를 마우스 오른쪽 단추로 눌러 다음을 비롯한 작업 목록을 사용할 수 있습니다.

  • Editor 창 열기

  • Schema Browser 창 열기

  • Query Builder 창 열기

  • Procedure Edit 창 열기

  • 스키마에 연결

  • 스키마에서 연결 끊기

다른 구성 옵션은 Project Manager 구성을 참조하십시오.


데이터베이스 개체

스키마 노드 내에서 데이터베이스 개체에 대한 작업을 수행할 수 있습니다.

추가

스키마 노드 내에서 데이터베이스 개체를 추가할 수 있습니다. 이 작업을 수행하는 여러 방법이 있으며 추가하는 개체에 따라 달라집니다. 일부 개체는 한 방법으로 추가할 수 있지만 다른 방법으로는 추가할 수 없습니다. 데이터베이스 개체 목록과 이러한 개체를 프로젝트에 추가하는 방법에 대한 자세한 내용은 데이터베이스 개체 기능을 참조하십시오.

  • 스키마 이름을 마우스 오른쪽 단추로 누른 다음 Add|Database Object…를 선택합니다.

  • Schema Browser에서 개체를 끌어 Project Manager의 프로젝트 노드에 놓습니다.

  • Schema Browser에서 추가할 개체를 선택하고 마우스 오른쪽 단추를 누른 다음 Add to Projects window를 선택합니다.

마지막 두 옵션에서 Toad는 Schema Browser의 현재 스키마와 일치하는 선택한 프로젝트 노드 내의 모든 스키마 노드를 자동으로 찾습니다. 해당 노드가 발견되지 않으면 새로 작성되고 해당 스키마 아래에 개체가 추가됩니다.

마우스 오른쪽 단추 누르기

마우스 오른쪽 단추 메뉴는 선택한 데이터베이스 개체에 대한 Schema Browser 마우스 오른쪽 단추 메뉴를 표시합니다. 또한 Schema Browser 선택 항목 아래에 팝업 메뉴에서 선택한 선택 항목을 추가합니다.

메모 속성

모든 데이터베이스 개체 노드에 메모를 추가할 수 있습니다. 이 메모는 힌트로 표시될 수 있습니다.

관련 항목

Project Manager에 개체 추가


데이터베이스 개체 기능

Project Manager를 사용하면 데이터베이스 개체를 프로젝트에 쉽게 추가할 수 있습니다. 그러나 일부 개체는 Object Browser에서만 추가할 수 있습니다. 아래 표에서는 가능한 데이터베이스 개체, 이러한 개체를 추가하는 방법, 현재 이러한 개체와 관련된 기능을 설명합니다.

Schema Browser 액세스의 경우 다른 언급이 없는 한 개체를 Project Manager에 끌어서 놓거나 마우스 오른쪽 단추를 누르고 Add to Project Manager를 선택할 수 있습니다.

개체 유형 | Project Manager에 추가하는 방법 | 끌어서 놓기 작업 | 두 번 누르기 작업 | 팝업 메뉴 작업
클러스터 | 개체 검색/Schema Browser/끌어서 놓기 | Y | Y | Y
제약 조건 | 개체 검색/끌어서 놓기 | Y | Y | Y
DB 링크 | 개체 검색/Schema Browser/끌어서 놓기 | Y | Y | Y
차원 | 개체 검색/Schema Browser/끌어서 놓기 | Y | Y | Y
디렉토리 | 개체 검색/끌어서 놓기 | Y | Y | Y
함수 | 개체 검색/Schema Browser/끌어서 놓기 | Y | Y | Y
색인 | 개체 검색/Schema Browser/끌어서 놓기 | Y | Y | Y
Java 클래스 | 개체 검색/끌어서 놓기 | Y | Y | Y
Java 리소스 | 개체 검색/끌어서 놓기 | Y | Y | Y
Java 소스 | 개체 검색/끌어서 놓기 Schema Browser/끌어서 놓기 | Y | Y | Y
작업 | Schema Browser/끌어서 놓기 | Y | Y | Y
라이브러리 | 개체 검색/Schema Browser/끌어서 놓기 | Y | Y | Y
패키지 | 개체 검색/Schema Browser/끌어서 놓기 | Y | Y | Y
패키지 본문 | 개체 검색/Schema Browser | Y | Y | Y
정책 | 추가할 수 없음 | N | N | N
정책 그룹 | 추가할 수 없음 | N | N | N
프로시저 | 개체 검색/Schema Browser/끌어서 놓기 | Y | Y | Y
프로파일 | 끌어서 놓기 | Y | Y | Y
대기열 | 개체 검색 | Y | Y | Y
대기열 테이블 | 개체 검색 | N | N | N
새로 고침 그룹 | 추가할 수 없음 | N | N | N
리소스 그룹 | 추가할 수 없음 | N | N | N
리소스 계획 | 추가할 수 없음 | N | N | N
역할 | Schema Browser/끌어서 놓기 | N | Y | Y
롤백 세그먼트 | 개체 검색/끌어서 놓기 | Y | Y | Y
시퀀스 | 개체 검색/Schema Browser/끌어서 놓기 | Y | Y | Y
스냅숏 | Schema Browser/끌어서 놓기 | Y | Y | Y
스냅숏 로그 | Schema Browser/끌어서 놓기 | Y | Y | Y
동의어 | 개체 검색/Schema Browser/끌어서 놓기 | Y | Y | Y
테이블 | 개체 검색/Schema Browser/끌어서 놓기 | Y | Y | Y
테이블 공간 | 개체 검색/Schema Browser/끌어서 놓기 | Y | Y | Y
트리거 | 개체 검색/Schema Browser/끌어서 놓기 | Y | Y | Y
사용자 | Schema Browser/끌어서 놓기 | Y | Y | Y
사용자 유형 | 개체 검색 | Y | Y | Y
사용자 유형 본문 | 개체 검색 | Y | Y | Y
사용자 컬렉션 | 개체 검색 | N | N | N
보기 | 개체 검색/Schema Browser/끌어서 놓기 | Y | Y | Y


폴더 추가

폴더를 원하는 수만큼 프로젝트에 추가할 수 있습니다. 각 폴더는 하드 드라이브나 네트워크 드라이브에 이미 있어야 합니다. Project Manager에 폴더를 추가하면 폴더 경로가 매핑됩니다.

주: Refresh folder list 기능은 네트워크 폴더 노드의 경우 제한됩니다. 네트워크 폴더 노드의 상위 디렉토리만 새로 고쳐지지만 해당 하위 폴더와 내용은 새로 고쳐지지 않습니다.

폴더를 추가하려면

  1. Project Manager의 왼쪽 창에서 프로젝트 노드를 마우스 오른쪽 단추로 누릅니다.

  2. New|Folder를 선택합니다.

  3. 경로 상자에 폴더의 경로를 입력합니다.

또는

드릴다운 [image] 단추를 누르고 추가할 폴더를 찾습니다.

  4. Filter 상자에 필터를 추가합니다.

기본적으로 폴더를 두 번 누르면 Windows 탐색기가 해당 폴더로 열리므로 내용을 쉽게 탐색할 수 있습니다.

또한 폴더에 포함된 항목을 Project Manager 창에 추가하여 직접 액세스할 수 있도록 만들 수 있습니다. 폴더 항목 추가를 참조하십시오.

관련 항목

폴더 제거

폴더 항목 추가

폴더 항목 제거

폴더 항목 필터링

FTP 폴더


폴더 제거

폴더를 추가할 때와 마찬가지로 Project Manager에서 폴더를 간단하게 제거할 수 있습니다.

폴더를 제거하려면

  • 하나 이상의 폴더를 선택하고 마우스 오른쪽 단추를 누른 다음 Remove를 선택합니다.

Project Manager 목록에서 폴더가 제거됩니다. 하드 드라이브에서 폴더가 삭제되지는 않습니다.

주의: 마우스 오른쪽 단추 메뉴에서 Remove를 선택해야 하고 Delete를 선택해서는 안 됩니다. Delete는 폴더가 비어 있는 경우 폴더를 완전히 삭제합니다.

관련 항목

폴더 추가

폴더 항목 추가

폴더 항목 제거

폴더 항목 필터링

FTP 폴더


폴더 항목 추가

Project Manager에서 매핑한 폴더에 폴더 항목을 추가하면 폴더 항목을 더 쉽게 열 수 있습니다. 더 이상 Windows 탐색기를 열 필요가 없고 Project Manager에서 직접 열 수 있습니다.

Project Manager에서는 전체 경로 이름을 사용하여 이러한 폴더의 이름을 자동으로 지정합니다. 사용자는 Project Manager 내에서 더 쉽게 기억할 수 있는 이름으로 이러한 폴더의 이름을 바꿀 수도 있습니다.

폴더의 이름을 바꾸려면

  1. 폴더를 마우스 오른쪽 단추로 누르고 Rename을 선택합니다.

또는

폴더를 선택하고 <F2> 키를 누릅니다.

  2. 폴더의 새 이름을 입력하고 OK를 누릅니다.

경로 이름이 유지되지만 이제 폴더 이름을 Project Manager에서 더 쉽게 관리할 수 있습니다.

관련 항목

폴더 추가

폴더 제거

폴더 항목 제거

폴더 항목 필터링

FTP 폴더


폴더 항목 필터링

파일 폴더의 속성을 추가하거나 볼 경우 폴더에 표시되는 파일 목록을 필터링할 수 있습니다. 표시되는 파일 폴더 항목이 많고 특정 파일을 쉽게 찾아야 하는 경우 이 기능이 유용할 수 있습니다.

파일 폴더 속성을 변경하려면

  1. 파일 폴더를 마우스 오른쪽 단추로 누르고 Properties를 선택합니다.

  2. 드릴다운 단추로 탐색하거나 경로를 직접 입력하여 디렉토리 정보를 변경할 수 있습니다.

  3. 표준 DOS 와일드카드 문자를 사용하여 Filter 상자에 필터 정보를 입력합니다. 예를 들어 *.txt는 .txt 파일만 표시하고 fill*은 문자 "fill"로 시작하는 파일만 찾습니다.

  4. 마우스 오른쪽 단추를 누르고 메뉴에서 Refresh folder links를 선택합니다. 확인 메시지가 표시된 후 모든 현재 링크가 제거되고 제공된 필터와 일치하는 파일만 해당 폴더 아래에 링크로 작성됩니다. 새 링크가 작성되지 않고 기존 링크만 필터링됩니다.

  5. 속성 대화 상자로 돌아와 모든 파일(*.*)로 복원한 후 다시 새로 고치면 모든 링크가 복원됩니다.

관련 항목

폴더 추가

폴더 제거

폴더 항목 추가

폴더 항목 제거

FTP 폴더


폴더 항목 제거

Project Manager에서 간단하게 폴더 항목을 제거할 수도 있습니다.

폴더 항목을 제거하려면

  • 하나 이상의 항목을 선택하고 마우스 오른쪽 단추를 누른 다음 Remove를 선택합니다.

Project Manager 목록에서 폴더가 제거됩니다. 그러나 폴더가 완전히 삭제되지는 않습니다.

주의: 마우스 오른쪽 단추 메뉴에서 Remove를 선택해야 하고 Delete를 선택해서는 안 됩니다. Delete는 항목을 완전히 삭제합니다.

관련 항목

폴더 추가

폴더 제거

폴더 항목 추가

폴더 항목 필터링

FTP 폴더


FTP 폴더

FTP 폴더는 원격 서버에 대한 연결을 나타냅니다. FTP 폴더는 작성한 프로젝트 폴더의 하위 노드로 배치됩니다. 매핑할 각 서버 디렉토리에 대한 별개의 폴더를 추가할 수 있습니다.

FTP 폴더를 추가하려면

  1. FTP 폴더가 있게 될 프로젝트를 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Add|FTP Folder를 선택합니다.

  3. FTP 로그온에 설명된 대로 FTP 연결을 설정합니다.

  4. OK를 누릅니다.

FTP 폴더를 제거하려면

  1. 제거할 하나 또는 여러 폴더를 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 메뉴에서 Remove를 선택합니다.

FTP 폴더 작업

FTP 폴더가 추가된 경우 마우스 오른쪽 단추 메뉴에서 여러 작업을 수행할 수 있습니다. FTP 폴더를 마우스 오른쪽 단추로 누르고 다음을 선택합니다.

  • Refresh Server Links

  • Browse - FTP 연결을 열고 FTP 연결 내용을 탐색할 수 있습니다. 클라이언트 디렉토리가 로컬 디렉토리로 사용됩니다.

  • Add Folder item(아래 참조)

FTP 폴더 항목 추가

FTP 폴더 항목은 원격 서버의 파일을 나타냅니다. 항목을 FTP 폴더에 추가하면 해당 항목의 위치와 이름이 Toad에 알려집니다. 항목에 대한 작업을 수행할 때는 서버에 연결되어 항목을 다운로드하고 편집합니다. 그런 다음 FTP를 사용하여 다시 서버에 보낼 수 있습니다.

FTP 폴더 항목을 추가하려면

  1. 파일이 있는 FTP 폴더를 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 메뉴에서 Add|FTP Items를 선택합니다.

  3. 폴더에 추가할 파일을 선택합니다. 해당 단추를 눌러 모든 파일을 쉽게 선택하거나 선택 취소할 수 있습니다.

  4. OK를 누릅니다. 선택한 FTP 폴더 노드에 파일이 추가됩니다.

FTP 폴더 항목을 제거하려면

  1. 제거할 폴더를 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 메뉴에서 Remove를 선택합니다.

주의: Delete Server File이 아니라 Remove를 선택해야 합니다. Delete Server File은 서버 디렉토리에서 파일을 제거합니다.

관련 항목

폴더 추가

폴더 제거

폴더 항목 추가

폴더 항목 제거

폴더 항목 필터링

FTP 폴더


할 일 모음

"할 일 모음"을 작성하여 프로젝트와 완료해야 하는 사항을 추적할 수 있습니다.

할 일 모음 항목은 노드나 다른 할 일 모음 항목 아래에 나열될 수 있습니다. 따라서 작업을 구성 요소 부분으로 분리해야 할 경우 여러 하위 항목을 작성할 수 있습니다.

할 일 모음 노드를 작성하려면

  • Project Node에서 마우스 오른쪽 단추를 누르고 Add|To Do List를 선택합니다. 이름이 선택된 상태로 새 목록이 나타나므로 즉시 변경할 수 있습니다.

할 일 모음 항목을 작성하려면

  1. To Do List 또는 To Do Item을 마우스 오른쪽 단추로 누르고 Add|To Do Item을 선택합니다.

  2. 항목의 이름을 지정합니다.

  3. 항목을 마우스 오른쪽 단추로 누르고 Properties를 선택합니다. 여기에서 다음 작업을 수행할 수 있습니다.

  4. 항목을 완료된 것으로 표시합니다.

  5. 항목에 대한 메모를 추가합니다.

  6. 만기일을 변경합니다(기본값은 현재 날짜로부터 3일)

  4. OK를 눌러 속성 변경을 적용합니다.


Query Builder 개요

다음과 같은 두 가지 방법으로 Query Builder에 액세스할 수 있습니다.

  • Database|Report|Query Builder 메뉴 항목에서

  • 부모 Toad 창 도구 모음의 Query Builder 단추를 사용하여

Query Builder 대화 상자를 사용하면 Select, Insert, Update 또는 Delete 문의 프레임워크를 빠르게 작성할 수 있습니다. 테이블, 보기 또는 동의어를 선택하고, 열을 결합하고, 열을 선택하고, 원하는 유형의 문을 작성할 수 있습니다.

항목을 누르거나 키보드를 사용하여 해당 항목을 Query Builder 주위로 이동할 수 있습니다. 위쪽/아래쪽 화살표 키를 눌러 목록에서 주위로 이동하거나 스페이스 바를 눌러 확인란을 선택/선택 취소할 수 있습니다. <tab> 키를 눌러 테이블, 메뉴, 목록 등을 한 영역 앞으로 이동하거나 Shift-Tab을 눌러 한 영역 뒤로 이동할 수 있습니다.

  • A - Table Model Area - 위쪽 패널에서 질의를 그래픽 방식으로 배치합니다. 자세한 내용은 모델 영역을 참조하십시오.

  • B - Tree View- 트리 보기의 현재 질의

  • C - Generated SQL Query - 모델의 결과로 자동 생성된 SQL이 모델 영역 아래의 results 그리드에 표시됩니다. Query Results 탭에는 작성된 질의의 결과가 표시됩니다.

  • D - Query Builder 도구 모음 - 가장 자주 사용되는 모델러 기능이 포함되어 있습니다. 도구 모음 항목에 대한 설명은 Query Builder 도구 모음을 참조하십시오. 팝업 메뉴에는 더 많은 모델러 기능이 있습니다.

관련 항목

Query Builder 도구 모음

빠른 시작

모델 영역

Query Builder 옵션


Query Builder 도구 모음

Query Builder 도구 모음에서 사용할 수 있는 명령은 다음과 같습니다.

단추 | 명령
 | SQL 문 실행
 | 활성 세션 변경
 | Object Palette 토글
 | 새 모델 작성
 | 다음 위치에서 모델 열기
 | 다른 이름으로 모델 저장
 | 디스크에 저장
 | 모델 인쇄(단추 옆의 드롭다운 메뉴에서 인쇄 확대/축소 선택)
 | 현재 모델 정보 편집
 | 계산된 필드 추가
 | SELECT 문 생성(다양한 유형의 질의를 작성하기 위한 드롭다운이 있음)
 | Explain Plan 실행
 | SQL 창에서 SQL 보기
 | 하위 질의를 저장하고 마스터 질의로 돌아가기
 | 하위 질의를 취소하고 마스터 질의로 돌아가기
 | 전역 WHERE 조건 설정
 | 전역 HAVING 조건 설정(반드시 Group By 조건이 있어야 함)
 | 조인 보기
 | 보기 작성
 | 자동으로 조인 찾기
 | 활성 세션 변경
 | modeler 창 확대/축소 비율


빠른 시작

Query Builder 사용을 빨리 시작하려면 다음 절차를 따릅니다.

Query Builder를 사용하려면

  1. 테이블, 보기 또는 동의어를 Schema Browser, Project Manager, Object Palette 또는 Object Search window 에서 모델링 영역으로 끌어 놓습니다.

  2. 각 열의 확인란을 눌러 해당 열을 선택하거나 선택 취소합니다.

주: 이 확인란을 누르면 열이 기본 질의에 추가됩니다. 열을 하위 질의에 추가하려면 끌기 기능을 사용해야 합니다.

  3. 테이블 간의 조인을 생성하려면 열을 한 테이블에서 다른 테이블로 끌어 놓습니다.

  4. 트리 보기 노드의 열을 마우스 오른쪽 단추로 눌러 WHERE 절 또는 GROUP by 절을 추가하고 Add ton clause를 선택합니다. 필요한 경우 마우스 오른쪽 단추를 누르고 절에 대한 속성을 조정합니다.

  5. 도구 모음에서 Save Model as [image] 단추를 눌러 모델을 디스크에 저장합니다.

  6. Generated Query 탭을 눌러 생성된 질의를 표시한 다음 Load in Editor [image] 단추를 눌러 질의를 Editor에 복사합니다.

관련 항목

Query Builder 개요

Query Builder 도구 모음

모델 영역

WHERE 절 채우기

HAVING 절 채우기


모델 영역

모델 영역을 사용하여 테이블, 보기 또는 동의어를 시각적으로 연결하거나 조작할 수 있습니다. 테이블 헤더를 누른 다음 모델 영역의 원하는 위치로 테이블을 끌어 놓을 수 있습니다.

조인을 직접 설정하려면

  • 열을 한 테이블에서 다른 테이블로 끌어 놓습니다. 선이 그려지면 해당 선을 두 번 눌러 선의 속성(예: Inner Joinvs. Outer Join 또는 Join Test)을 조정할 수 있습니다. 예를 들어 같음(=), 작음(<), 큼(>) 등이 있습니다.

질의를 위한 열을 지정하려면

  • 원하는 각 열의 확인란을 누릅니다. 확인란에 체크 표시가 나타납니다. 선택된 열의 정보가 탐색 트리에 나타나고 해당 열이 질의에 포함됩니다.

주: 테이블 열을 선택하지 않은 경우 모든 열이 질의에 포함됩니다.

F4 설명

설명 항목에서 설명한 것처럼 <F4> 키를 사용하여 선택된 테이블을 설명할 수 있습니다. F4 키를 누를 때 테이블을 선택하지 않으면 마지막 선택된 테이블이 설명됩니다.


Query Builder Explain Plan

Explain Plan

Query Builder 도구 모음에서 Explain Plan 단추를 눌러 Explain Plan 출력을 생성 및 표시할 수 있습니다.

마우스 오른쪽 단추 메뉴에 포함되는 기능은 다음과 같습니다.

  • Copy to Clipboard- explain plan 문(텍스트 모드)을 클립보드에 복사합니다.

  • Optimizer Mode - Choose, Default, Rule, First Rows 또는 All Rows 중에서 query optimizer 모드를 선택할 수 있습니다.


Query Builder 옵션

Toad Options 창에서 많은 Query Builder 옵션을 설정하거나 변경할 수 있습니다. 이 창에서 다음을 수행할 수 있습니다.

  • 조인 선의 색상 등 일반 옵션 설정

  • Query Builder에서 사용 가능한 함수 추가 또는 제거

  • Query Builder 동작 제어

Query Builder 옵션에 액세스하려면

  1. View 메뉴에서 Toad Options를 선택합니다.

  2. 왼쪽에서 Query Builder를 누릅니다.

  3. 원하는 대로 옵션을 변경한 다음 OK를 누릅니다.

관련 항목

옵션 - Query Builder


조인 보기

도구 모음에서 View Joins [image] 단추를 누르거나 Modeler 자체에서 join line을 두 번 눌러 조인을 볼 수 있습니다. view joins 대화 상자가 나타납니다.

이 대화 상자에서 개별 조인을 빠르게 표시하고, 조인을 찾아보거나 변경할 수 있습니다.

  • 트리 보기의 JOIN 섹션에서 <Enter> 키를 누르거나 마우스 단추를 두 번 눌러 조인을 볼 수 있습니다.

  • <Delete> 키를 누르거나 마우스 오른쪽 단추를 누르고 Delete를 선택하여 조인을 삭제할 수 있습니다.

  • 맨 위의 두 영역에서는 한 테이블에서 다른 테이블로 결합된 조인 필드에 대해 설명합니다.

  • Join Type을 Inner에서 Outer로 변경할 수 있습니다. 선 색상은 조인의 유형을 나타냅니다.

  • Outer join을 선택한 경우 Outer join이 수행되는 테이블을 변경할 수 있습니다.

  • 조인에 대한 테스트를 Equal to 대신 Less than, Greater than 등으로 변경할 수 있습니다.

  • 현재 조인을 삭제할 수 있습니다.

  • 조인 목록에서 앞으로 이동하려면 Next Join을 누릅니다.

  • 뒤로 이동하려면 Previous Join을 누릅니다.

  • OK를 눌러 창을 닫고 Query Builder로 돌아갑니다.


Where 절 채우기

Query Builder에서 생성되는 SQL의 WHERE 절은 개별 WHERE 또는 전역 WHERE의 두 가지 방법으로 채울 수 있습니다.

where 절을 채우려면

  1. SELECT 노드에서 열을 마우스 오른쪽 단추로 누르고 Include in Where Clause를 선택합니다.

또는

열을 select 노드에서 WHERE 노드로 끌어 놓습니다.

  2. 조건을 추가하고 적용할 외부 조인을 선택하거나 선택 취소합니다.

고급 질의를 작성하려면 Expert 탭을 누르고 맨 위 상자에 직접 입력하거나 함수와 데이터 필드를 두 번 눌러 입력하는 방식으로 코드를 입력합니다.

  3. OK를 누릅니다.

  4. 모든 조건이 추가될 때까지 반복합니다.

  5. 주: WHERE 절에 여러 열을 추가할 경우 해당 열이 자동으로 배치됩니다.

  6. 조건이 AND가 아닌 OR이어야 하는 경우 마우스 오른쪽 단추로 누르고 OR를 선택합니다.

전역 WHERE 절을 작성하려면

  1. Table Model 영역을 마우스 오른쪽 단추로 누릅니다.

  2. SQL|Global Where Clauses를 선택합니다.

  3. Add [image] 단추를 누릅니다.

  4. 조건을 입력하거나 생성합니다.

  5. OK를 눌러 Definition 창을 닫습니다.

  6. OK를 누릅니다.

예

다음과 같은 질의를 구성하려면

SELECT DEPT.DEPTNO, DEPT.DNAME, DEPT.LOC

FROM DEPT

WHERE (((UPPER (RTRIM (DNAME)) = 'SALES') AND (DEPT.DEPTNO < 40)) AND ((DEPT.LOC = 'CHICAGO')OR ((DEPT.LOC IS NULL = '')))

다음을 수행합니다.

  1. Query Builder를 엽니다.

  2. Object Palette에서 Scott 스키마를 선택하고 DEPT 테이블을 두 번 눌러 모델에 추가합니다.

  3. DEPT를 마우스 오른쪽 단추로 누르고 Select All을 선택합니다.

  4. DEPTNO 열을 WHERE 노드로 끌어 놓습니다.

  5. operator 상자에서 <을 선택하고 Constant를 누른 다음 condition 상자에 40을 입력합니다.

  6. OK를 누릅니다.

  7. LOC 열을 WHERE 노드로 끌어 놓습니다.

  8. WHERE Definition 대화 상자에서 Expert 탭을 누릅니다. OK를 눌러 확인합니다.

  9. SQL Operators 영역에서 IS NULL을 두 번 누른 다음 OK를 누릅니다.

  10. 트리 보기에서 DEPTNO를 LOC 위로 끌어 놓습니다.

  11. LOC 열을 마우스 오른쪽 단추로 누르고 OR를 선택합니다.

  12. OR|LOC를 마우스 오른쪽 단추로 누르고 Properties를 선택합니다. operator 상자에서 =을 선택하고 Constant를 누른 다음 condition 상자에 CHICAGO를 입력합니다.

  13. OK를 누릅니다.

  14. 테이블 모델 영역(테이블 이미지 주위 영역)에서 마우스 오른쪽 단추를 누르고 SQL|Global Where를 선택합니다. Add [image] 단추를 누릅니다.

  15. 맨 위 입력란에 (UPPER (RTRIM (DNAME))) = 'SALES'를 입력합니다.

  16. OK를 누른 다음 OK를 다시 누릅니다.

생성된 질의가 위에서 설명한 대로 표시되어야 합니다.


Having 절 채우기

Query Builder에서 생성되는 SQL의 Having 절은 두 가지 방법 중 하나를 사용하여 자동으로 채울 수 있습니다.

주: HAVING 절을 작성하려면 GROUP BY 노드에 열을 추가해야 합니다.

Having 항목이 <식1> <연산자> <식2> 형태여야 합니다.

HAVING 절을 채우려면

  1. 트리에서 원하는 열을 마우스 오른쪽 단추로 누른 다음 Include in Having Clause를 선택합니다.

또는

열을 Table Model 영역의 테이블에서 HAVING 절로 끌어 놓습니다.

  2. 조건을 입력하거나 작성합니다.

  3. OK를 누릅니다.

  4. 완료될 때까지 반복합니다.

전역 HAVING 절

전역 HAVING 절을 포함하려면 GROUP BY 절도 있어야 합니다.

전역 HAVING 절을 작성하려면

  1. Table Model 영역을 마우스 오른쪽 단추로 누릅니다.

  2. SQL|Global Having을 선택합니다.

  3. Add 단추를 누릅니다.

  4. 조건을 입력하거나 생성합니다.

  5. OK를 눌러 Definition 창을 닫습니다.

  6. OK를 누릅니다.

예

다음과 같은 질의를 구성하려면

SELECT emp.empno, emp.ename, emp.job, emp.mgr, emp.sal,

emp.comm, emp.deptno

FROM emp

GROUP BY emp.deptno, emp.comm, emp.sal, emp.mgr, emp.job,

emp.ename, emp.empno

HAVING ((emp.sal + NVL (emp.comm, 0) > 4000))

다음을 수행합니다.

  1. Query Builder를 엽니다.

  2. Object Palette에서 Scott 스키마를 선택합니다.

  3. EMP 테이블을 두 번 눌러 모델에 추가합니다.

  4. EMP를 마우스 오른쪽 단추로 누르고 Select All을 선택한 다음 Hiredate를 선택 취소합니다.

  5. DEPTNO, COMM, SAL, MGR, JOB, ENAME 및 EMPNO를 Group by 노드로 끌어 놓습니다.

  6. Table Model 영역을 마우스 오른쪽 단추로 누르고 SQL|Global Having을 선택합니다. Add [image] 단추를 눌러 새 전역 Having 절을 추가합니다.

  7. 다음 Having 절을 입력합니다.

EMP.SAL + NVL(EMP.COMM, 0) > 4000

  8. OK를 두 번 누릅니다.

생성된 질의가 위에서 설명한 대로 표시되어야 합니다. 이 질의는 급여와 수수료를 합하여 4000이 넘는 모든 직원을 선택합니다.

NVL 명령은 지정된 열의 null 값을 지정된 값(이 경우 0)으로 대체합니다.


하위 질의 작성

원하는 경우 하위 질의를 쉽게 작성할 수 있습니다. 이전 하위 질의의 해당 절에 새 하위 질의를 작성하여 중첩된 하위 질의를 작성할 수도 있습니다. 하위 질의는 SELECT 절, FROM 절 또는 WHERE 절에서 작성할 수 있습니다.

하위 질의에 배치하려면 현재 문이나 테이블 영역에서 열을 직접 끌어 놓아야 합니다. 모델 영역에서 열을 선택하면 해당 열이 기본 질의에 추가됩니다.

WHERE 절에서 하위 질의를 작성하려면

  1. 열을 WHERE 또는 FROM 노드로 끌어 놓습니다.

  2. WHERE 정의 대화 상자에서 subquery를 선택하고 그 아래 목록에서 하위 질의 유형을 선택합니다.

  3. 일반 질의를 작성할 때와 동일한 방법으로 하위 질의를 작성합니다.

EXISTS 하위 질의를 작성하려면

  1. 트리 보기에서 WHERE 절을 마우스 오른쪽 단추로 누릅니다.

  2. Include EXISTS subquery를 선택합니다.

  3. 일반 질의를 작성할 때와 같은 방법으로 하위 질의를 작성합니다.

FROM 또는 SELECT 노드에서 하위 질의를 작성하려면

  1. 트리 보기에서 SELECT 또는 FROM 절을 마우스 오른쪽 단추로 누릅니다.

  2. Include subquery를 선택합니다.

  3. 일반 질의를 작성할 때와 같은 방법으로 하위 질의를 작성합니다.

주: SELECT 절을 기반으로 하는 하위 질의는 여러 열을 가질 수 없으므로 ORDER BY 노드가 없습니다.

관련 항목

Query Builder 개요

중첩된 하위 질의 작성


질의 리버스 엔지니어링

필요한 경우 이미 생성한 질의를 리버스 엔지니어링할 수 있습니다.

질의는 Query Builder에서 원래 작성될 수 있었던 질의여야 합니다. Query Builder에서 원본 질의를 작성할 수 없는 경우 리버스 엔지니어링된 질의에 결함이 있을 수 있습니다. Query Builder는 작성할 수 없는 질의를 시각적으로 표시할 수 없기 때문입니다. 질의에 계산된 필드가 포함되어 있는 경우 Add Calculated field 단추를 눌러 계산된 필드를 테이블에 수동으로 연결해야 할 수 있습니다.

이 때 Query Builder는 중첩된 하위 질의가 있는 질의를 작성할 수 있지만 Toad는 해당 질의를 리버스 엔지니어링할 수 없습니다.

주: 개발 수명 주기 동안에 철저하게 테스트했지만 가능한 질의 배열이 너무 많기 때문에, 작성 가능하지만 리버스 엔지니어링은 불가능한 질의가 존재할 수 있습니다. 그런 질의를 발견한 사용자는 Quest에 알려주시면 감사하겠습니다.

Toad는 다음과 같은 질의를

  • Select

  • Insert

  • Update

  • Delete

한 번에 하나씩 리버스 엔지니어링할 수 있습니다.

질의를 리버스 엔지니어링하려면

  1. Editor에 질의를 입력합니다.

또는

Editor에서 질의를 포함한 파일을 엽니다.

  2. 질의를 마우스 오른쪽 단추로 누르고 Send to Query Builder를 선택합니다.


Query Report Format

Query Builder에서 "Execute as SQL*Plus Report"를 선택한 경우에 실행 가능합니다. Query Report Format 창에서 보고서의 서식을 지정할 수 있습니다.

SQL*Plus Report로 실행하려면

  • 모델을 작성한 후 Criteria 또는 Generated Query 탭을 마우스 오른쪽 단추로 누르고 Execute as SQL*Plus Report를 선택합니다.

Columns 탭

이 탭에서 보고서에 인쇄할 부분을 선택할 수 있습니다. 열의 인쇄 여부를 선택하거나, 연속 복제물을 억제하거나(BREAK), 열 양쪽 맞춤을 변경하거나, 값의 합계를 구하거나, 합계를 break 열에 적용하도록 선택할 수 있습니다.

보고서 생성 옵션을 설정할 경우 도구 모음에서 Print the Report [image] 단추를 누릅니다. 스크립트가 script 탭으로 전송되고 출력이 Output 탭으로 전송됩니다.

도구 모음에서 Printer 단추를 눌러 output 탭을 인쇄할 수 있습니다.

Output 탭

보고서를 인쇄하면 출력이 output 탭에 표시됩니다.

도구 모음에서 Print Output Tab [image] 단추를 눌러 이 탭의 내용을 인쇄할 수 있습니다.

Script 탭

보고서를 인쇄하고 나면 Script 탭에 출력을 생성하는 데 사용된 스크립트가 포함됩니다. 그러면 도구 모음에서 Save to file 단추를 눌러 스크립트를 파일에 저장할 수 있습니다.


Generated Query

이 탭에는 자동으로 생성된 SQL 문이 나열됩니다. 모델 또는 열 Criteria를 변경하면 이 SQL 문이 자동으로 다시 생성됩니다.

질의를 클립보드에 복사하려면

  • 질의를 선택하고 <CTRL>C를 누릅니다.

또는

마우스 오른쪽 단추를 누르고 Copy를 선택합니다.

Query Builder 도구 모음에서 SQL 단추를 눌러 질의를 Editor 창에 직접 복사할 수도 있습니다.

SQL을 SQL*Plus Report로 실행할 수도 있습니다. SQL 영역을 마우스 오른쪽 단추로 누르고 Execute as SQL*Plus Report를 선택합니다. Query Report Format 창이 나타납니다.

"Generated Query" 탭 대화 상자에서 SQL을 직접 편집할 수 없습니다.

질의 조정

Toad Edition에 SQL Tuning 기능이 있는 경우 질의를 조정할 수 있습니다.

질의를 조정하려면

  • 생성된 Query 탭에서 SQL Tuning 단추를 누릅니다.

관련 항목

Toad 버전

Toad에서 SQL Tuning 사용

SQL Tuning


Query Results

이 그리드에는 생성된 질의의 실행 결과가 표시됩니다. Insert, Update 및 Delete 질의는 Editor 창에서만 실행할 수 있습니다.

테이블 또는 열을 변경한 다음 Query Results 탭을 누르면 데이터를 다시 질의할지 여부를 묻는 확인 메시지가 표시됩니다.

마우스 오른쪽 단추 메뉴에서 다음을 선택할 수 있습니다.

  • Print Grid – Print Grid 대화 상자를 엽니다.

  • Save As – Save Grid Contents 대화 상자를 열어 결과를 다양한 형식으로 저장할 수 있습니다.

  • Export to Flat File – 표준 스프레드시트 응용프로그램에서 열 수 있는 일반 파일로 질의 결과를 내보낼 수 있습니다.

  • Find data – Find data 대화 상자를 열어 결과 그리드에서 문자열을 검색할 수 있습니다. 많은 결과가 있을 때 특정 결과를 찾아야 하는 경우 이 옵션을 사용하면 검색 범위를 줄일 수 있습니다.

  • Record Count – 결과 그리드의 레코드 수를 계산하고 합계를 표시합니다.


트리에서 열 제거

코드를 모델링할 때 모델에서 열을 제거해야 할 수 있습니다.

트리에서 열을 제거하려면

  • 원하는 열을 트리 구조의 휴지통으로 끌어 놓습니다.

관련 항목

Query Builder 개요


Schema Browser 창

주: Quest DBA Module이 있는 최신 상용 버전의 Toad가 없는 경우에는 이 기능 중 일부를 사용하지 못할 수도 있습니다.

Main 도구 모음에 있는 Schema Browser 도구 모음 단추(두 번째 단추)나 Database|Schema Browser 메뉴 항목에서 Schema Browser에 액세스합니다. 또한 View|Toad Options|Windows 대화 상자로 이동하여 Schema Browser 행의 Auto Open 열에 있는 확인란을 선택하면 새로 연결될 때 자동으로 Schema Browser가 열리도록 설정할 수 있습니다.

Schema Browser는 왼쪽 패널과 오른쪽 패널로 구성됩니다. 왼쪽 패널에는 Schema Browser에서 작업을 수행할 수 있는 개체 유형이 포함되어 있습니다. (아래 Schema Browser Object 탭 참조). 사용자의 작업 습관에 맞게 구성할 수 있습니다(Schema Browser 개인 설정 참조).

주: 현재 연결이 아닌 스키마를 보는 경우, Schema Browser의 캡션에 연결 문자열 다음에 있는 스키마가 표시됩니다.

탭, 드롭다운 목록 또는 트리 보기 형태로 유형을 나열하도록 왼쪽 패널을 구성할 수 있습니다. 예를 들어 테이블 유형을 선택하면 왼쪽 패널에 모든 테이블이 표시되고, 보기 유형을 선택하면 왼쪽 패널에 모든 보기가 표시되는 식입니다.

개체를 선택하면 해당 개체의 세부 사항 또는 DDL 구조가 오른쪽 패널에 표시됩니다. 따라서 원하는 데이터를 찾기 위해 계층 구조를 드릴다운할 필요가 없습니다. 또한 마우스를 한 번 눌러 같은 유형의 개체 간에 세부 사항을 비교할 수 있습니다. 키보드 사용자는 스크롤 키를 사용하여 동일한 작업을 쉽게 수행할 수 있습니다.

성능을 위해 Toad에서는 목록이 필요한 드롭다운이나 탭이 활성화될 때까지 일부 스키마 목록의 반입을 지연합니다.

Statement Processing 팝업에서 오랫 동안 실행되며 목록을 채우는 몇 가지 질의를 취소할 수 있습니다.

Schema Browser에서 대부분의 개체를 삭제하고, 해당 개체를 활성화/비활성화하고, 테이블이나 전체 스키마의 트리거를 비활성화할 수 있습니다. 프로시저, 함수, 패키지, 트리거 및 보기를 다시 컴파일하거나 데이터베이스에서 추출한 후 SQL 또는 Editor에 로드할 수 있습니다.

Schema Browser Object 탭

Schema Browser Object 탭은 두 그룹으로 나뉩니다. 왼쪽에는 Object Type이 있습니다. 오른쪽에는 개체에 대해 자세히 설명하는 Details 패널이 있습니다.

자세한 내용은 도구 모음 Schema Browser 항목을 참조하십시오.

개체 목록 필터링

Quickfilter Edit 상자는 탭 및 드롭다운 목록으로 구성된 Schema Browser 보기의 Schema 드롭다운 아래에 있습니다. QuickFilter를 사용하면 데이터베이스를 다시 질의하지 않고 개체 목록을 필터링할 수 있습니다. 이렇게 하면 Browser 필터를 사용할 때보다 빠르게 목록을 필터링할 수 있습니다. Quickfilter Edit 상자에 대한 자세한 내용은 QuickFilter 상자 사용을 참조하십시오.

Object 탭 숨기기

대부분의 Schema Browser 탭(Tables 및 View 탭 예외)에서 표시되는 마우스 오른쪽 단추 메뉴에는 Schema Browser에서 사용할 수 있는 개체 목록이 있습니다. 체크 표시가 있는 개체는 현재 Objects 탭에 표시되어 있습니다. 이 메뉴에서 항목을 선택하여 표시할 개체를 선택하거나 선택 취소할 수 있습니다. Object 탭 구성에 대한 자세한 내용은 Schema Browser 개인 설정을 참조하십시오.

데이터 새로 고침

Object 패널에서 <F5> 키를 눌러 현재 개체 목록을 새로 고칠 수 있습니다.

현재 Details 패널 탭에 있는 데이터는 <Shift><F5>를 누르면 새로 고칠 수 있습니다.

Schema Browser 옵션

Schema Browser 옵션에 대한 자세한 내용은 Toad 옵션 Schema Browser 항목을 참조하십시오.

마우스 오른쪽 단추 메뉴

Schema Browser 패널에는 마우스 오른쪽 단추 메뉴가 있습니다. Tables 및 Views와 같은 여러 페이지에는 페이지의 개체 패널과 세부 사항 패널에 있는 모든 단추에 대한 메뉴 항목을 포함하는 확장된 마우스 오른쪽 단추 메뉴가 있습니다.


Schema Browser 도구 모음

Objects 패널 도구 모음

Schema Browser 창에는 Objects 패널(왼쪽 패널)과 일부 Details 패널(오른쪽 패널)에 있는 개체 유형에 대한 도구 모음이 있습니다. 각 개체 유형에는 자체 도구 모음이 있으며, 이러한 것에 대해서는 특정 유형에 대한 항목에서 자세히 설명합니다.

Details 패널 도구 모음

주 Details 패널 도구 모음

주 Details 패널 도구 모음은 Schema Browser 장의 오른쪽에 있는 Details 패널 의 맨 위에 있습니다. 여기에는 다음 명령에 대한 아이콘이 포함되어 있습니다.

단추 | 명령
 | Show history - 이 드롭다운에는 가장 최근에 방문한 Schema Browser 페이지가 나열됩니다. 목록에서 하나를 선택하면 해당 페이지로 돌아갈 수 있습니다. 브라우저 기록에 보존되는 항목의 수는 Toad Options|Schema Browser|Visual|Browser History에서 설정할 수 있습니다.
 | Refresh all Lists - 이 아이콘은 Objects 패널과 Details 패널 모두에 있는 목록을 전부 새로 고칩니다.
 | Refresh Objects Panel - 이 항목을 누르면 개체 패널에 있는 데이터만 새로 고칩니다.
 | Refresh Details Panel - 이 아이콘을 누르면 Details 패널에 있는 데이터만 새로 고칩니다.
 | Clear filters - 이 아이콘을 누르면 Details 패널에서 활성화되어 있는 모든 필터를 지웁니다.
 | Icon Legend - 아이콘 범례를 열어 선택한 Schema Browser 페이지에 표시합니다.
 | Browser Style - 이 드롭다운을 눌러 Schema Browser의 시각적인 스타일을 선택합니다. 이러한 스타일에 대해서는 Schema Browser 사용자 지정에서 자세히 설명합니다.
 | Change active session - 이 아이콘을 눌러 활성 Toad 세션을 변경합니다. 이미지를 눌러 Change Session 대화 상자를 호출하거나 화살표를 누르고 드롭다운에 나열된 열린 세션 중에서 선택할 수 있습니다.

특정 Details 패널 도구 모음

주 Details 패널에 있는 도구 모음 외에도, 일부 Details 패널에는 특정 개체에 대한 도구 모음이 있습니다. 자세한 내용은 특정 개체 유형을 참조하십시오.


Icon Legend

Schema Browser에 있는 여러 창에는 포함된 다양한 개체를 식별하는 아이콘이 있습니다.

Toad에는 이러한 이미지를 쉽게 해독할 수 있는 Icon Legend가 포함되어 있습니다.

Icon Legend에 액세스하려면

  • Schema Browser 도구 모음에서 Schema Browser Icon Legend [image] 단추를 누릅니다.

활성 상태인 Schema Browser 페이지의 노드가 펼쳐지고 나머지 노드가 접힌 Icon Legend가 열립니다. 다음을 선택할 수 있습니다.

  • 모든 노드 펼침

  • 모든 모드 접음

  • 창을 항상 맨 위에 유지


Enable Drop All Button

기본값으로 Schema Browser의 DROP ALL 단추는 해로운 사용자 오류가 발생할 수 있으므로 비활성화되어 있습니다. View|Toad Options|Schema Browser - Visual|Enable DROP-ALL buttons 확인란을 통해 활성화할 수 있습니다.

이 설정은 영구적이지 않습니다. Toad는 세션 간의 설정을 저장하지 않습니다.

주의: Toad는 브라우저의 모든 DROP 동작을 확인하지만 확인 후에는 어떤 DROP 동작도 바꿔놓을 수 없습니다.


Privileges

이 창에서 선택한 표의 권한을 보거나 수정하고 다른 사용자 스키마 계정을 봅니다.

Privileges 창을 액세스하려면

  1. Schema Browser 에서 이 창을 액세스합니다. Tables 탭, Views 탭, Sequences 탭 또는 Procs 탭 중 하나를 선택합니다.

  2. 탭의 목록에서 개체를 선택하고 Privileges 도구 모음 [image] 단추를 누릅니다. Privileges 창이 나타납니다.

Privileges 창에서 데이터베이스 개체의 권한을 보고, 부여하고 해지할 수 있습니다. 모든 사용자 및 권한을 볼 수 있습니다. 개체 소유자가 아니면 "grant option"이 제공될 경우 권한을 부여할 수 있습니다.

부여는 파란색으로, admin 부여는 노란색으로 강조표시됩니다.

  • Ctrl 키를 사용하여 여러 명의 사용자를 선택합니다. 여러 사용자에게 변경 내용을 적용할 때 도움이 됩니다. 여러 명의 사용자를 선택하고, 열에 마우스 오른쪽 단추를 누르고, 마우스 오른쪽 단추 메뉴에서 부여 또는 해지합니다.

  • Revoke All 을 눌러 모든 사용자의 선택된 개체에 대한 권한을 모두 해지합니다.

  • Show SQL 을 눌러 변경 내용을 적용하기 전에 SQL을 미리 봅니다.

  • Apply 를 눌러 변경한 내용을 적용합니다.

개체를 변경할 충분한 권한이 없을 경우 경고 메시지가 나타나고 권한이 변경되지 않습니다. 해당 개체에 대한 모든 사용자의 권한을 계속 볼 수 있으며 열 순서를 바꿀 수도 있습니다.

  • Show only users who have grants assigned 를 표시하여 표시되는 사용자를 제한합니다. 이 상자가 표시되어 있지 않으면 모든 사용자를 볼 수 있습니다.

  • 열 머리글을 누르고 끌어서 열 순서를 바꿉니다.


창: Statement Processing

Statement Processing

이 대화상자는 Schema Browser 창에서 LONG 질의를 실행할 때 나타납니다.

이 창에서 질의가 포함된 Schema Browser 목록의 오랜 실행을 취소할 수 있습니다.


Schema Browser 사용자 지정

주: 최신 상용 버전의 Toad가 없으면 이 기능 중 일부를 사용하지 못할 수도 있습니다. Quest DBA Module이 없으면 이 기능 중 일부를 사용하지 못할 수도 있습니다.

작업 방법에 맞게 Schema Browser의 표시 방법을 사용자 지정할 수 있습니다. 각 표시 옵션에는 서로 다른 장점이 있습니다.

Schema Browser는 다음 중 하나로 표시할 수 있습니다.

  • Dropdown Object Types - 개체 유형 목록이 알파벳 드롭다운으로 표시됩니다.

  • Treeview

  • Tabbed Object Types - 개체 유형 목록이 다음 둘 중 한 가지 방법으로 나타납니다.

  • 여러 행의 탭

  • 한 줄의 탭과 스크롤 막대

주: Tabbed Object Types를 선택하면 개체 이름을 Editor로 끌 수도 있습니다.


브라우저 디스플레이 변경

Schema Browser에서 개체 유형을 표시하는 방법은 두 가지 중 한 가지 방법으로 변경할 수 있습니다.

Toad Options 페이지에서 디스플레이를 변경하려면

  1. 주 도구 모음에 있는 Options [image] 단추를 누릅니다.

  2. 왼쪽 창에서 Schema Browser|Visual을 선택합니다.

  3. 오른쪽 창에서 적절한 디스플레이 옵션을 선택합니다.

주: 모든 Schema Browser 옵션을 보려면 Toad 옵션: Schema Browser 를 참조하십시오.

Schema Browser 내에서 디스플레이를 변경하려면

  1. Schema Browser 도구 모음에 있는 Browser Style [image] 단추를 누릅니다.

  2. 드롭다운 메뉴에서 사용할 디스플레이 유형을 선택합니다.

주: 다음 중 하나를 선택하여 수행할 수도 있습니다.

  • 개체 유형 구성

  • 왼쪽(LHS) 이미지 비활성화(드롭다운 개체 제목의 이미지 비활성화)

  • 왼쪽 항목 힌트 비활성화(Object 패널에서 항목 위로 마우스 포인터를 가져갔을 때 표시되는 힌트 비활성화).

관련 항목

Schema Browser 사용자 지정

브라우저 디스플레이 변경

브라우저 탭 구성


브라우저 탭 구성

탭이 있는 개체 유형을 사용하는 경우 Schema Browser 개체 유형 마우스 오른쪽 단추 메뉴에는 Configure 메뉴 항목이 있습니다. 이 항목을 사용하면 탭의 제목을 다시 지정하고 다시 정렬할 수 있는 Configure Browser Tabs 창을 열 수 있습니다.

이 구성을 변경하면 단일 줄 탭, 여러 줄 탭, 드롭다운, 트리 보기의 네 가지 브라우저 탭 유형이 모두 영향을 받습니다.

Configure Browser Tabs 창을 열려면

  • Schema Browser|Object Panel에서 마우스 오른쪽 단추를 누르고 Configure를 선택합니다.

또는

Schema Browser 도구 모음의 Browser Style [image] 단추에서 Configure Object Types를 선택합니다.

브라우저 탭 순서

Configure Browser Tabs 창에는 세 개의 열이 있습니다.

  • Object type - 실제 범주 이름을 나열합니다.

  • Caption - Toad에서 현재 탭에 표시하는 캡션을 나열합니다. 셀 안을 누르고 입력하면 이 캡션의 제목을 변경할 수 있습니다.

  • Visible - Schema Browser에서 탭이 보이는지 여부를 표시합니다.

탭의 순서를 다시 정렬하려면

작업이 완료되면 목록에 있는 첫 번째 항목이 기본 탭이 됩니다.

  • 이동할 항목 행의 왼쪽 끝에 있는 회색 상자를 누르고 행을 목록의 새 위치로 끌어갑니다.

또는

Object Type 또는 Caption 셀을 선택하고 창에서 Up Arrow 또는 Down Arrow를 눌러 행 전체를 목록에서 위 또는 아래로 이동합니다.


일반 Schema Browser 작업

찾아보는 개체 유형에 관계 없이 Schema Browser에서 몇 가지 작업을 수행할 수 있습니다. 다음을 수행할 수 있습니다.

  • 개체 스크립트 작성

  • 개체 삭제

  • 브라우저에서 개체 이름 복사

  • 브라우저 필터링

  • 개체 목록에서 열 선택

  • 개체로 이동

  • 사용자 지정 질의 작성

  • 새로 고침 그룹 옵션 변경

  • Project Manager에 개체 추가


개체 스크립트 작성

Toad에서는 Schema Browser에 표시되는 대부분의 개체에 대해 개체를 다시 작성하는 Oracle 문인 DDL 스크립트를 작성할 수 있습니다. 스크립트 생성에 사용되는 Create Script 단추는 보통 왼쪽 패널에 있는 각 드롭다운의 도구 모음에 있는 첫 번째 단추입니다. 스크립트는 기본적으로 항상 클립보드에 복사됩니다.

주: Tables의 세부 정보 탭 중 하나의 Browser 창에 있는 동안 테이블 및 색인 작성 스크립트를 볼 수 있습니다.


Project Manager에 추가

Project Manager에 개체 추가

Schema Browser에서 개체를 Project Manager 프로젝트에 쉽게 추가할 수 있습니다.

끌어서 놓기로 개체 추가

개체를 두려는 노드에 끌어서 놓는 방법으로 Project Manager에 개체를 추가할 수 있습니다. 이 방법으로 Project Manager를 원하는 방식으로 설정하고 노드의 이름을 지정할 수 있습니다.

개체에 맞게 설계된 노드에 개체를 끌어야 합니다. 예를 들어 테이블은 올바른 연결 아래의 테이블 노드로 이동해야 합니다. 허용되지 않는 노드로 개체를 끌 수는 없습니다.

끌어서 놓기로 개체를 추가하려면

  1. Schema Browser의 Object 목록에서 하나의 개체나 여러 개체를 선택합니다.

  2. 개체를 두려는 Project Manager의 노드로 끕니다.

마우스 오른쪽 단추 메뉴에서 개체 추가

마우스 오른쪽 단추 메뉴를 사용하여 개체를 추가할 경우 장점과 단점이 있습니다. 가장 중요한 장점은 도중에 새 프로젝트를 작성할 수 있다는 것입니다.

새 프로젝트 아래의 모든 노드가 작성되고 이름이 지정됩니다.

예를 들어 "SPEC"라는 테이블을 "Test"라는 새 프로젝트에 추가할 경우 다음 노드가 작성됩니다.

메뉴를 사용하여 개체를 추가하려면

  1. Schema Browser의 Object 목록에서 하나의 개체나 여러 개체를 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Add to Project Manager를 선택합니다.

  3. Select Project 대화 상자의 드롭다운 메뉴에서 프로젝트 이름을 선택하거나 새 프로젝트 이름을 입력합니다.

  4. OK를 누릅니다.

관련 항목

Project Manager 개요

프로젝트 노드

스키마 노드

데이터베이스 개체


개체 삭제

많은 개체를 Schema Browser에서 직접 삭제할 수 있습니다. 개체에 Drop 단추가 있으면 해당 탭의 목록에서 개체를 선택할 때마다 이 단추가 활성화됩니다.

Drop All 단추가 기본적으로 활성화되는 경우는 없습니다. Drop All 단추를 활성화하려면 View|Toad Options에서 수동으로 활성화해야 합니다. 그 덕분에 잠재적으로 파괴적인 작업이 약간 더 복잡해집니다. Drop All 설정은 저장되지 않으며 Toad를 시작할 때마다 다시 선택해야 합니다. 자세한 내용은 Enable Drop All Button을 참조하십시오.

테이블을 선택한 후 키보드에서 <Delete> 키를 누르면 테이블을 삭제할 수 있습니다.

주의: Toad에서는 브라우저 상에서 이루어지는 모든 삭제 작업을 확인하지만, 일단 확인하고 나면 복원할 수 없습니다.


브라우저에서 복사

브라우저 왼쪽의 개체 목록에 표시된 개체 이름은 강조표시된 개체 이름에서 <CTRL>C 를 누르면 클립보드에 복사할 수 있습니다.

브라우저 오른쪽의 세부 정보 그리드에 표시된 모든 데이터 열은 강조표시된 그리드 셀에서 <CTRL>C 를 누르면 클립보드에 복사할 수 있습니다.

테이블 정보의 세부 정보 그리드는 약간 다르게 작동합니다. 테이블 세부 정보를 표시하는 그리드는 여러 행 선택을 지원하며 항상 첫 번째 열을 클립보드에 복사합니다. 예를 들어 테이블에 있는 열 목록의 그리드 표시를 보는 경우 <CTRL> 키를 누른 채로 열을 눌러서 두 열 이상을 선택한 후 <CTRL>C를 누를 수 있습니다. 그러면 선택한 열이 클립보드에 복사되며 열 사이에 쉼표가 표시됩니다(쉼표로 구분된 목록). 그러면 목록을 SQL Editor나 다른 응용 프로그램에 붙여넣을 수 있습니다.


브라우저 필터링

브라우저에 있는 대부분의 기본 개체 목록은 스키마에 있는 비슷한 모든 개체의 하위 집합만 표시하도록 필터링할 수 있습니다. 예를 들어 스키마에 수백 개의 테이블이 있지만 그 중에서 테이블 이름이 "GEO"로 시작하는 것만 보려는 경우가 있습니다. 현재 Tables, Constraints, Synonyms, Views, Triggers, Indexes 및 Procedures 필터가 있습니다.

브라우저 필터는 특정 스키마/소유자 이름에 따라 달라집니다. 즉, 스키마 DEMO에 필터를 정의하고 PRODUCTION에 다른 필터를 정의하면 Schema Browser에서 해당 스키마를 볼 때 적절한 필터가 로드됩니다.

Table 필터를 사용하면 테이블 이름 및 열 이름에서 필터링이 허용됩니다. 예를 들어 열 이름의 어느 위치에서나 FND_NO가 있는 열이 있는 모든 테이블을 찾을 수 있습니다. 테이블 이름도 검색할 수 있습니다.

제약 조건은 제약 조건 이름이나 제약 조건 열 이름으로 검색할 수 있습니다.

동의어는 스키마에서만 소유, 스키마와 공개 동의어에서 소유, SYS 및 SYSTEM 동의어 제외 등의 동의어 범위로 필터링할 수 있습니다.

주: Toad에서는 성능상의 이유로 창에서 목록에 대한 질의를 수행하고 나면 현재 스키마의 테이블 이름 목록을 캐시합니다. 기본적으로 Schema Browser 창을 필터링하기 위한 브라우저 필터는 Toad 전체의 테이블 목록에도 영향을 줍니다. 따라서 예를 들어 GEO로 시작하는 테이블만 표시하도록 필터가 설정된 경우에는 필터가 변경될 때까지 모든 테이블 목록에 필터링된 목록이 표시됩니다.

필터는 표시되는 데이터의 양을 줄일 뿐 아니라 데이터를 가져오는 데 사용되는 질의도 수정한다는 점에 주의해야 합니다. 따라서 표시가 더 빨리 새로 고쳐질 뿐 아니라 질의로 가져오는 행 수도 적기 때문에 데이터베이스로부터의 응답도 빨라집니다.

기본적으로 브라우저는 다음과 같이 표시됩니다.

  • Tables는 모든 테이블을 표시합니다.

  • Constraints는 기본 제약 조건만 표시합니다.

  • Synonyms는 모두 표시하지만 SYS 및 SYSTEM에서 소유한 개체는 제외합니다.

  • Views는 모든 보기를 표시합니다.

  • Triggers는 모든 트리거를 표시합니다.

  • Procedures는 모든 프로시저를 표시합니다.

모든 브라우저 개체의 필터는 Session|Schema Browser Filters 메뉴 아래에 있는 단일 창에서 볼 수 있습니다. 자세한 내용은 스키마의 브라우저 필터 항목을 참조하십시오.

4방향 필터

두 탭(Tables 및 Views)에서 4방향 필터 단추를 누르면 정렬 및/또는 필터링을 수행할 수 있는 대화 상자가 표시됩니다. 필터에는 비어 있음, 필터링됨, 오름차순/내림차순 필터링됨, 오름차순/내림차순 비어 있음의 네 가지 상태를 표시할 수 있습니다.

관련 항목

Browser Filters

기본 필터 편집

기본 브라우저 필터 작성

브라우저 필터 로드 및 적용

브라우저 필터 저장


개체 목록에서 열 선택

기본적으로 Schema Browser의 개체 목록에는 선택할 수 있는 개체의 이름이 표시됩니다. 하지만 이러한 개체에 대한 추가 정보를 볼 수도 있습니다. 보는 개체의 유형에 따라 표시할 수 있는 열이 달라집니다.

표시할 열을 선택하려면

  1. 표시할 개체의 유형을 선택합니다(테이블, 보기, 제약 조건 등).

  2. Objects 패널에서 열 헤더를 마우스 오른쪽 단추로 누릅니다. 표시할 열을 선택합니다.

  3. 사용 가능한 열 중에서 원하는 각 열에 대해 반복합니다.


Schema Browser: Jump to Object

개체는 Schema Browser에서 오른쪽에 두 가지 중 한 가지 방법으로 표시됩니다. data 그리드에 표시할 수도 있고 레이블에 표시할 수도 있습니다. 이러한 표시된 개체에서 개체에 대해 설명을 수행하거나 다른 개체로 이동할 수 있습니다. 두 가지 방법으로 작업을 수행할 수 있습니다.

data 그리드

개체가 Schema Browser 오른쪽의 그리드에 있는 경우에는 개체를 설명하거나 개체로 이동할 수 있습니다.

개체를 설명하려면

  • <F4> 키를 눌러 개체에서 설명을 수행합니다.

개체로 이동하려면

  • <Shift><F4>를 누릅니다.

또는

두 번 눌러 선택한 개체로 이동합니다.

레이블

개체가 레이블에 있는 경우에는 다음을 수행할 수 있습니다.

  • 레이블에서 Schema Browser에 있는 개체로 직접 이동합니다.

  • 개체 레이블을 눌러 설명을 수행합니다.

예를 들어 다음 예에 있는 제약 조건의 오른쪽에서 다음을 수행할 수 있습니다.

  • JEFF.ENTERPRISE를 눌러 설명을 수행합니다.

  • <CTRL> 키를 누른 채로 JEFF.ENTERPRISE를 눌러 Schema Browser의 Tables 페이지에 있는 JEFF.ENTERPRISE 테이블로 이동합니다.


Custom Queries

사용자 지정 질의 작성

Schema Browser에서 빠른 사용자 지정 질의를 작성할 수 있습니다. 질의는 선택한 개체로 작성되며 편집 또는 실행을 위해 Editor에 넣습니다.

사용자 지정 질의를 작성하려면

  1. Schema Browser의 왼쪽 패널에서 질의에 사용할 개체를 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Custom Queries를 선택합니다. 그 후에 기본 질의 목록에서 선택할 수 있습니다. 질의가 작성되어 Editor에 로드됩니다.

사용자 지정 질의를 편집하려면

  • Schema Browser를 마우스 오른쪽 단추로 누르고 Custom Queries|Edit Custom Queries를 선택합니다.

이 창에서 몇 가지를 수행할 수 있습니다.

  • 질의 이름 변경

  • 적절한 Oracle 버전 선택 또는 선택 취소

  • 질의를 작성하는 동안 변수 선택 및 추가

질의를 편집하는 방법에 대한 자세한 내용은 브라우저 필터 질의 편집을 참조하십시오.

새 질의 템플릿 작성

사용자 지정 질의는 사용자 지정 SELECT 문을 만드는 대신 선택한 테이블에 관한 데이터 사전에서 데이터를 선택하도록 설계되어 있습니다. 새 질의 템플릿을 작성하는 경우에는 이 사항을 염두에 두어야 합니다.

예를 들어 다음 질의는 특정 개체가 지정되지 않았기 때문에 사용자 지정 질의로서 유효하지 않습니다.

select * from <ObjectOwner>.<ObjectList>

하지만 특정 사항이 많이 지정된 다음 질의는 유효합니다.

select *

from dba_tables

where owner = <ObjectOwner>

and table_name in <ObjectList>

새 질의 템플릿을 작성하려면

  1. 위 설명과 같이 Edit Custom Queries 창을 엽니다.

  2. 질의 목록 위에서 Add Query [image] 단추를 누릅니다. 새로 빈 질의가 작성됩니다.

  3. 새 질의 이름과 질의를 입력합니다.

  4. Post Edits [image] 단추를 눌러 질의를 작성하고 선택 목록에 추가합니다. 이제 표준으로 제공되는 질의를 사용하는 것과 같은 방법으로 새 질의를 사용할 수 있습니다.


단일 개체 비교

Schema Browser에서 단일 개체를 비교할 수 있습니다.

이 기능을 지원하는 개체 유형은 다음과 같습니다.

  • Tables

  • Views

  • Procedures

  • Triggers 등

개체를 비교하려면

  1. 개체를 선택하고 마우스 오른쪽 단추를 누릅니다.

  2. 메뉴에서 Compare with another object를 선택합니다. 참조 원본 정보가 채워집니다.

  3. 개체를 비교할 텍스트 파일이나 사용 중인 스키마의 개체로 비교 원본 정보를 입력합니다.

  4. Toad를 선택 사항인 Quest DBA Module과 함께 사용하는 경우에는 대화 상자의 맨 위에서 결과를 보는 방법으로 두 가지 중 하나를 선택합니다.

  5. File Compare - 이 옵션은 Differences Viewer를 사용하여 선택한 두 개체를 비교합니다. Differences Viewer에 대한 자세한 내용은 Compare Files를 참조하십시오.

  6. Sync Script - 이 옵션은 선택한 개체의 이름이 같고 스키마가 다른 경우에만 사용할 수 있습니다. 개체를 비교하고 동기화 스크립트를 만듭니다.


동의어

동의어 작성

Schema Browser에서 선택한 개체의 동의어를 작성할 수 있습니다.

동의어를 작성하려면

  1. Schema Browser|Objects 패널에서 동의어를 작성할 개체를 선택합니다.

  2. Details 패널에서 Synonyms 탭을 누른 후 New Synonym [image] 단추를 누릅니다.

주: 개체에 동의어를 지정할 수 없으면 Synonyms 탭을 사용할 수 없습니다.

  3. 동의어 정보를 선택합니다.

  4. Public 또는 Private를 선택합니다.

  5. 동의어 이름을 입력합니다.

  4. OK를 눌러 선택한 개체의 동의어를 작성합니다.

관련 항목

Schema Browser: Synonyms

Create Synonym

Export Synonym


Refresh Options

Schema Browser data 그리드에서 작업하는 경우 설정한 새로 고침 옵션때문에 수행할 작업이 방해를 받을 수 있습니다. 이 경우 Options 페이지를 열지 않고 선택한 옵션을 수정할 수 있습니다.

Schema Browser에서 data 그리드 옵션을 변경하려면

  1. Schema Browser|Tables, View 또는 Snapshots 페이지에서 개체를 선택하고 Details 패널에서 Data 탭을 누릅니다.

  2. data 그리드를 마우스 오른쪽 단추로 누르고 Refresh Options를 선택합니다.

  3. 적용할 새로 고침 옵션을 선택하고 다른 옵션의 확인란 선택을 취소합니다.

  4. OK를 눌러 선택한 새로 고침 옵션을 설정합니다.


Schema Browser 필터

브라우저 필터는 여러 개의 개체를 포함하는 스키마에 유용합니다. Toad가 로드해야 할 개체가 적어질 수록 보다 빨리 실행됩니다. 초점을 좁히는 데("Toad_"로 시작하는 개체 이름 등) 유용하며 일시적으로 스키마의 다른 개체를 모두 무시합니다.

이 창에서 다음 작업을 수행할 수 있습니다.

  • 브라우저 필터 저장

  • 브라우저 필터 로드 및 적용

  • 실행하기 전에 필터 질의 편집

  • 기본 필터 작성

  • Project Manager 파일별 필터

브라우저 필터를 사용하려면

  1. Session|Schema Browser Filters를 선택합니다. 이렇게 하면 활성 스키마의 모든 개체 형식에 대한 필터가 모두 표시됩니다.

또는

Schema Browser의 개체 패널에서 Browser Filter [image] 단추를 누릅니다. 이렇게 하면 선택한 개체 형식 및 스키마에 대한 브라우저 필터가 표시됩니다.

  2. 적절한 항목을 선택하여 필터를 작성합니다.

  3. 필터를 파일로 저장하거나, 파일로 저장하지 않고도 필터를 사용할 수도 있습니다. 선택하고 나면 OK만 눌러 적용할 수 있습니다.


브라우저 필터 로드 및 적용

브라우저 필터를 하나 이상 저장한 경우에는 필요에 따라 로드하여 적용할 수 있습니다.

브라우저 필터를 로드 및 적용하려면

  1. 창의 오른쪽 위에서 Saved Filters 드롭다운을 누릅니다.

  2. Load Filter를 선택한 후 나타나는 Open File 대화 상자에서 필터를 선택합니다.

또는

드롭다운 맨 아래에서 필터 이름을 선택합니다.

브라우저 필터가 로드되면 현재 스키마에 자동으로 적용됩니다.

  3. OK를 눌러 필터를 적용하고 FIlters 대화 상자를 종료합니다.


브라우저 필터 저장

브라우저 필터를 작성하여 저장해 두고 나중에 어느 스키마에서나 사용할 수 있습니다.

브라우저 필터를 저장하려면

  1. 창의 오른쪽 위에서 Saved Filters 드롭다운을 누릅니다.

  2. Save Filter As를 선택합니다.

  3. Filter Name 상자에 필터의 이름을 입력합니다. 이 이름은 필터 드롭다운에 표시됩니다. 이 상자에 이름을 입력하지 않아도 드롭다운에 필터가 표시되지만, 빈 줄로 표시됩니다.

  4. File Name 상자에 필터의 파일 이름을 입력합니다.

주: 기본적으로 필터는 Toad User Files 폴더에 XML 파일(연결 당 하나)로 저장됩니다. File Name 대화 상자에 전체 경로를 입력하면 다른 폴더에 저장할 수 있습니다.

  5. OK를 누릅니다.


브라우저 필터 질의 편집

Schema Browser 그리드는 선택한 필터에 따라 결정되는 일련의 표준 질의로 채워집니다. 하지만 브라우저 필터에 의해 작성된 질의를 편집할 수도 있습니다. 그러면 Schema Browser의 왼쪽 부분에 채우는 내용을 완전히 제어할 수 있습니다.

사용자 지정 필터를 선택하지 않은 경우 이 옵션은 사용 후에 자동으로 꺼지며 필터 변경 사항이 저장되지 않습니다.

사용자 지정 필터

브라우저 필터를 편집하는 경우 브라우저 필터 질의를 편집할 때 사용자 지정 필터를 작성할 수 있습니다. 사용자 지정 질의의 편집은 모두 질의 보기/편집 창에서 이루어져야 합니다.

사용자 지정 필터를 작성하고 나면 Custom Filter가 선택되어 있는 동안 계속 적용됩니다. 사용자 지정 필터는 Clear Custom Filter를 누를 때까지 사용 가능한 상태로 유지됩니다.

사용자 지정 필터를 작성하려면

  1. Schema Browser에서 Filter [image] 단추를 누릅니다.

  2. Custom Filter (Use View/Edit Query to adjust)를 선택합니다.

  3. View/Edit Query Before Executing을 선택합니다.

  4. OK를 누릅니다.

  5. 브라우저 필터 질의를 편집하려면에 설명된 대로 질의를 편집합니다.

주: 사용자 지정 필터 사용을 중지하려면 Custom Filter 확인란의 선택을 취소합니다. Clear Custom Filter를 누를 때까지는 사용 가능한 상태로 유지됩니다.

사용자 지정 필터를 다시 활성화하려면

  1. Schema Browser에서 Filter [image] 단추를 누릅니다.

  2. Custom Filter (Use View/Edit Query to adjust)를 선택합니다.

  3. OK를 누릅니다.

브라우저 필터 질의를 편집하려면

  1. browser filter를 엽니다. 필터의 기본 기준을 구성한 후에 View/Edit Query Before Executing 상자를 선택하고 OK를 누릅니다. 그러면 브라우저를 채울 질의가 표시됩니다.

  2. WHERE 또는 ORDER BY 절은 원하는 방식으로 변경할 수 있습니다.

주의: SELECT 목록은 변경하지 마십시오.

  3. 질의에서 바인드 변수를 편집하려면 Variables 단추를 누릅니다. 바인드 변수가 포함된 질의는 다음과 같은 형태입니다.

select....

from...

where s.owner = :var1

and s.table_name = :var2

  4. Check를 눌러 새 질의가 정확하게 구문 분석되는지 확인합니다.

  5. OK를 눌러 Schema Browser를 필터링합니다.


기본 브라우저 필터 작성

일반 Browser Filters 대화 상자에서 모든 새 스키마에 적용되는 기본 필터를 설정할 수 있습니다.

브라우저 필터는 개체가 많이 포함된 스키마에 유용합니다. Toad에서 로드해야 할 개체가 적을수록 실행 속도는 빨라집니다. 이 기능은 포커스를 좁혀("Toad_"로 시작되는 개체 이름만 등) 스키마에 있는 다른 모든 개체를 일시적으로 무시하는 데 유용합니다. 여러 가지 방법으로 작업을 수행할 수 있습니다. "바로" 적용할 수 있는 브라우저 필터를 저장할 수도 있고 선택한 스키마에서 개체를 볼 때 항상 적용되는 기본 브라우저 필터를 작성할 수도 있습니다.

주의: 항상 Toad 인터페이스를 사용하여 변경하십시오. 이러한 파일을 직접 편집하려 하면 안 됩니다.

기본 필터를 작성하려면

  1. View 메뉴에서 Browser Filters를 선택합니다.

  2. Browser Filters for: 대화 상자의 맨 위에서 Show Default filters를 누릅니다. 이제 정상적으로 필터를 작성할 수 있습니다.

  3. 필터를 파일에 저장할 필요는 없습니다. 파일 작성이 완료되면 OK를 누릅니다.

기본 필터는 Toad for Oracle\Temps 폴더에 있는 Toad_DEF.FLT 파일에 저장됩니다.


Project Manager 파일을 기준으로 필터링

Schema browser 필터를 사용하여 Project Manager 파일을 기준으로 필터링을 수행할 수 있습니다.

Project Manager 파일을 기준으로 필터링하려면

  • Filter by Project Manager file [image] 단추를 누른 다음 Project Manager 파일을 선택하고 Open을 누릅니다.

주: Project Manager 파일에 여러 프로젝트가 있는 경우에는 필터링을 시작하기 전에 프로젝트도 선택해야 합니다.

또는

filter 단추 옆에 있는 드롭다운 기록 목록을 사용하여 이전에 사용했던 파일을 선택합니다.


QuickFilter 상자 사용

Quickfilter Edit 상자는 탭 및 드롭다운 목록으로 구성된 Schema Browser 보기의 Schema 드롭다운 목록 아래에 있습니다. QuickFilter를 사용하면 데이터베이스를 다시 질의하지 않고도 개체 목록을 필터링할 수 있습니다. 이렇게 하면 브라우저 필터를 사용할 때보다 더 빨리 목록을 필터링할 수 있습니다.

Quickfilter는 클라이언트측 필터이므로 데이터베이스를 다시 질의하지 않고 모든 Schema Browser 개체 목록을 필터링합니다. 이 필터는 기존 Browser 필터와 함께 작동합니다.

기본적으로 이 필터에는 "select all" 와일드카드 문자(*)가 포함되어 있습니다. 이 상자의 내용을 변경하여 개체 목록을 빠르고 쉽게 필터링할 수 있습니다.

주: Quickfilter는 Treeview Schema Browser 또는 Favorites Schema Browser 탭에서 작동하지 않습니다.

주 개체 도구 모음에도 더 자세한 필터링에 사용할 수 있는 필터 단추가 있습니다. 자세한 내용은 Browser Filters를 참조하십시오.

Quickfilter 상자를 사용하려면

  • 필터 정보를 입력합니다. 필터에서 언제라도 와일드카드 문자를 사용할 수 있습니다.

주: Quickfilter에서는 최대 25개 항목으로 된 기록을 제공하며 최근 항목이 첫번째로 표시됩니다. Quickfilter를 마우스 오른쪽 단추로 누르면 이 목록에 액세스할 수 있습니다.

관련 항목

와일드카드 문자

Browser Filters

Schema Browser


와일드카드 문자

Quickfilter에서는 와일드카드 문자가 허용됩니다. 또한 필터링할 범위를 선택할 수 있습니다. 사용할 수 있는 와일드카드 문자 및 범위 설정은 다음과 같습니다.

와일드카드 | 의미
* 및 % | 여러 문자 와일드카드
? 및 _ | 단일 문자 와일드카드
[] | 반환된 값 집합
! | 집합에 포함되지 않은 값
- | 값 범위

와일드카드 및 집합 예

찾으려는 문자 대신에 와일드카드를 사용할 수 있습니다.

집합은 여는 대괄호([)로 시작하고 닫는 대괄호(])로 끝납니다. 대괄호 사이의 각 요소는 리터럴 문자 또는 문자 범위를 나타냅니다. 초기 값, 대시 및 최종 값으로 지정되는 범위는 해당 값을 모두 포함합니다. 요소를 구분하기 위해 공백이나 쉼표를 사용해서는 안 됩니다.

모든 비교는 대/소문자를 구분합니다.

예를 들면 다음과 같습니다.

입력 | 반환
*ploy 또는 %ploy | "deploy", "employ" 등
em* 또는 em% | "employee", "employ", "empresses" 등
_at 또는 ?at | cat, bat 등(flat, latitude 등은 반환되지 않음)
_at* 또는 ?at% | cat, bat, latitude 등
[a-c]* | a, b 또는 c로 시작하는 모든 항목
[def]* | d, e 또는 f로 시작하는 모든 항목
[!abc]* | a, b 또는 c로 시작하지 않는 모든 항목

관련 항목

QuickFilter 상자 사용


Schema Browser: Clusters

클러스터는 테이블 데이터를 저장하는 다른 방법으로, 열을 공유하는 테이블의 데이터가 데이터베이스에 한 번만 저장됩니다. 이 방법을 사용하면 데이터베이스를 줄이고 액세스 시간을 대폭 빨라지게 할 수 있습니다. 클러스터와 효율적인 클러스터 사용 방법에 대한 자세한 내용은 Oracle 관련 문서를 참조하십시오.

Schema Browser에서 클러스터를 작성, 수정 및 삭제할 수 있습니다. 목록을 필터링하고 클러스터 스크립트를 클립보드에 복사할 수도 있습니다.

Objects 패널

Objects 패널에는 선택한 스키마에서 사용할 수 있는 클러스터가 나열됩니다.

Cluster 도구 모음

단추 | 명령
 | 클러스터 스크립트를 클립보드에 복사합니다.
 | 새 클러스터를 작성합니다.
 | 선택한 클러스터를 수정합니다.
 | Filter cluster list - Browser Filters 창을 열고 개체 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Drop cluster - 선택한 클러스터를 삭제합니다.

Details 패널

Details 패널에는 선택한 클러스터에 관한 정보가 있으며, 여기에서 클러스터 스크립트를 보고 편집할 수 있습니다.

클러스터 스크립트에서 몇 가지 항목을 선택하여 포함 또는 제거할 수 있습니다. 여기에는 다음 항목이 포함됩니다. 스키마 소유자, 테이블, 저장소, drop 문 및 색인.

클러스터 스크립트를 편집하려면

  1. 확인란을 눌러 제공된 옵션을 선택하거나 선택 취소합니다.

  2. 선택한 방법으로 스크립트를 변경하려면 Refresh [image] 단추를 누릅니다.

  3. 그 후 다음을 누를 수 있습니다.

  4. Copy script to clipboard [image] 단추

  5. Copy script to SQL Editor [image] 단추

관련 항목

Create Cluster

Alter Cluster


Create Cluster

이 대화 상자에서 새 클러스터를 작성할 수 있습니다. 새 클러스터는 색인 클러스터일 수도 있고 해시 클러스터일 수도 있습니다.

클러스터를 작성하려면

  1. 다음 중 한 가지 방법으로 Create Cluster 창에 액세스합니다.

  2. Database|Create 메뉴에서 Cluster를 선택합니다.

  3. Schema Browser|Cluster 페이지에서 Create Cluster [image] 단추를 누릅니다.

  2. Schema 드롭다운에서 클러스터를 넣을 스키마를 선택합니다.

  3. 클러스터의 이름을 입력합니다.

  4. Indexed Cluster 또는 Hash Cluster를 선택합니다. 해시 클러스터를 선택하면 Hash Info 탭이 새로 나타납니다.

  5. 선택적으로 Add to PM 확인란을 선택하면 Project Manager에 개체를 추가할 수 있습니다.

  6. 아래 탭의 설명과 같이 클러스터 관련 정보를 입력합니다.

탭

Columns

사용할 열 정보를 입력합니다. <Tab> 키나 마우스를 사용하여 상자 사이를 이동할 수 있습니다. 각 열에 다음 정보를 입력해야 합니다.

  • Column name - Column name 열에 이름을 입력합니다.

  • Data type - 드롭다운 메뉴에서 선택하거나, 사용할 데이터 유형의 처음 몇 자만 입력하거나, 데이터 유형 전체를 입력할 수 있습니다.

  • Size - 필요한 경우 열 크기를 입력합니다.

  • Precision - 필요한 경우 열에서 사용할 정밀도를 입력합니다.

  • Scale - 필요한 경우 열에서 사용할 배율을 입력합니다.

저장소 옵션

저장소 옵션에 필요한 정보를 입력합니다.

Hash Info

Hash Info 영역에서는 단일 테이블을 선택할 수 있고, 해시 키 수와 해시 식을 입력할 수 있습니다.

주: 해시 식을 입력할 때 "Hash is" 키워드를 입력하지 마십시오.

관련 항목

Clusters

Alter Cluster


Alter Cluster

이 대화 상자에서 기존 클러스터를 수정할 수 있습니다. 클러스터는 색인 클러스터일 수도 있고 해시 클러스터일 수도 있습니다. 저장소 속성에 대한 정보는 Toad에서만 수정할 수 있습니다. 클러스터를 좀더 본격적으로 변경하려면 삭제한 후 새 클러스터를 작성해야 합니다.

클러스터를 수정하려면

  1. Schema Browser|Cluster 페이지에서 Alter Cluster [image] 단추를 누릅니다.

  2. Storage 탭을 누르고 클러스터에 대한 저장소 정보를 변경합니다.

관련 항목

Clusters

Create Cluster


Schema Browser: Constraints

Schema Browser 창에서 제약 조건을 활성화 및 비활성화하고 개체를 필터링할 수 있습니다.

Objects 패널

Schema Browser의 왼쪽 패널에는 제약 조건 목록이 표시됩니다. 제약 조건의 세부 정보를 보려면 세부 정보를 누릅니다. 세부 정보가 오른쪽 패널에 표시됩니다. 이 창에서는 제약 조건을 변경할 수 없습니다. 제약 조건을 변경하려면 Create Constraint 항목을 참조하십시오.

제약 조건의 여러 유형과 상태를 다양한 아이콘으로 구분합니다. 자세한 내용은 Icon Legend를 참조하십시오.

Constraint 도구 모음

단추 | 명령
 | 새 제약 조건을 작성합니다.
 | 제약 조건을 수정합니다.
 | Enable current Trigger or Constraint - 이 명령을 사용하려면 먼저 제약 조건을 선택해야 합니다. 그런 다음 아이콘을 눌러 활성화해야 합니다.
 | Disable current Trigger or Constraint - 이 명령을 사용하려면 먼저 제약 조건을 선택해야 합니다. 그런 다음 아이콘을 눌러 비활성화해야 합니다.
 | Filter - Browser Filters 창을 열고 개체 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다. 주: Schema Browser에서 제약 조건의 필터를 지우면 기본 제약 조건만 표시되도록 제약 조건 옵션이 자동으로 업데이트됩니다.
 | Drop - 데이터베이스에서 선택한 제약 조건을 삭제합니다.

관련 항목

Create Constraint

Alter Constraint


제약 조건 작성

이 대화상자에서 표 제약 조건을 추가로 작성합니다.

Create Constraint 창을 액세스하려면

  • Create 메뉴에서 Constraint를 선택합니다.

또는

Schema Browser|Tables|Add Constraint 도구 모음 단추에서

다음을 작성할 수 있습니다.

  • Primary Key 제약 조건

  • Foreign Key 제약 조건

  • Check 제약 조건

  • Unique 제약 조건

Primary Key 제약 조건을 작성하려면

  1. Constraint Name 상자에서 제약 조건 이름을 입력합니다.

  2. 필요한 경우 Create Constraint Disabled 확인란을 선택합니다.

  3. 드롭다운 목록에서 "from" 스키마 및 "from" 표를 선택합니다. 그러면 질의가 작성되고 열이 Table Columns 목록에 채워집니다.

  4. Primary Key 옵션 단추를 누릅니다.

주: Primary Key 제약 조건이 선택한 표에 이미 존재할 경우 Primary Key 단추가 비활성화됩니다.

  5. Table Columns 목록에서 기본 키로 지정할 열을 선택합니다. (하나 이상의 항목을 선택하려면 항목을 누르고 있는 동안 <CTRL> 키를 누릅니다.)

  6. 필요한 경우 저장 매개 변수를 선택합니다.

  7. 오른쪽 화살표 단추를 눌러 Constrained Columns 패널로 선택한 항목을 이동합니다.

새 제약 조건에 부합하지 않는 레코드를 다른 표로 이동하려는 경우 Exceptions 탭을 누르고, 스키마, 기존 표를 선택하거나, 새 표 이름을 입력하고 Create a New Exceptions Table 단추를 누릅니다.

  8. SQL 탭을 눌러 실행하기 전에 SQL을 검토할 수 있습니다.

  9. 아니면 Add to PM 확인란을 선택하여 Project Manager에 개체를 추가합니다.

  10. Execute 단추를 눌러 Primary Key 제약 조건을 작성합니다.

Foreign Key 제약 조건을 작성하려면

  1. Constraint Name 을 입력합니다.

  2. 필요한 경우 확인란을 Create Constraint Disabled 로 선택합니다.

  3. 드롭다운 목록에서 "from" 스키마 및 "from" 표를 선택합니다. 이렇게 하면 Available Table Columns 목록이 채워집니다.

  4. Foreign Key 옵션 단추를 누르거나 Cascade Deletes 확인란을 표시합니다.

  5. This Table 탭에서 Constrained Columns로 만들 열을 선택합니다.

  6. 오른쪽 화살표 단추를 눌러 선택한 내용을 Constrained Columns 창으로 이동합니다.

  7. Referenced Table 탭을 누릅니다.

  8. Referenced Table 스키마, 표 및 열을 누릅니다. 하나 이상의 항목을 선택하려면 항목을 누르고 있는 동안 <CTRL> 키를 누릅니다.

새 제약 조건에 부합하지 않는 레코드를 다른 표로 덤프하려는 경우 Exceptions 탭을 누르고, 스키마, 기존 표를 선택하거나, 새 표 이름을 입력하고 Create a New Exceptions Table 단추를 누릅니다.

  9. SQL 탭을 눌러 실행하기 전에 SQL을 검토할 수 있습니다.

  10. Project Manager에 개체를 추가하려면 Add to PM 확인란을 선택합니다.

  11. Execute 단추를 눌러 SQL을 실행하고 Foreign Key 제약 조건을 추가합니다.

Check 제약 조건을 작성하려면

  1. Constraint Name 상자에서 제약 조건 이름을 입력합니다.

  2. 필요한 경우 확인란을 Create Constraint Disabled로 선택합니다.

  3. 드롭다운 목록에서 "from" 스키마 및 "from" 표를 선택합니다. 이렇게 하면 Table Columns 목록이 채워집니다.

  4. Check 옵션 단추를 누릅니다.

  5. Check Constraint Condition 상자에서 Check 제약 조건 텍스트를 입력합니다(예: "SALARY < 100000 and COMMISSION > 5000").

새 제약 조건에 부합하지 않는 레코드를 다른 표로 이동하려는 경우 Exceptions 탭을 누르고, 스키마, 기존 표를 선택하거나, 새 표 이름을 입력하고 Create a New Exceptions Table 단추를 누릅니다.

  6. SQL 탭을 눌러 실행하기 전에 SQL을 검토할 수 있습니다.

  7. Project Manager에 개체를 추가하려면 Add to PM 확인란을 선택합니다.

  8. Execute 단추를 눌러 SQL을 실행하고 Check 제약 조건 을 추가합니다.

Unique 제약 조건을 작성하려면

  1. Constraint Name을 입력합니다.

  2. 필요한 경우 Create Constraint Disabled 확인란을 선택합니다.

  3. 드롭다운 목록에서 "from" 스키마 및 "from" 표를 선택합니다. 이렇게 하면 Table Columns 목록이 채워집니다.

  4. Unique 라디오 단추를 누릅니다.

  5. Table Columns 목록에서 Constrained Columns로 만들 열을 선택합니다.

  6. 오른쪽 화살표 단추를 눌러 선택한 내용을 Constrained Columns 창으로 이동합니다.

  7. 새 제약 조건에 부합하지 않는 레코드를 다른 표로 덤프하려는 경우 Exceptions 탭을 누르고, 스키마 및 기존 표를 선택하거나 새 표 이름을 입력합니다.

  8. SQL 탭을 눌러 실행하기 전에 SQL을 검토할 수 있습니다.

  9. Project Manager에 개체를 추가하려면 Add to PM 확인란을 선택합니다.

  10. Execute 단추를 눌러 SQL을 실행하고 Unique Key 제약 조건을 추가합니다.

관련 항목

제약 조건

제약 조건 변경


Alter Constraint

이 대화 상자를 사용하면 기존 제약 조건을 수정할 수 있습니다.

제약 조건을 수정하려면

  1. Objects Panel에서 수정할 제약 조건을 선택합니다.

  2. Objects Panel 도구 모음에 있는 Alter Constraint [image] 단추를 누릅니다.

  3. Alter Constraint 대화 상자를 사용하면 다음을 변경할 수 있습니다.

  4. 제약 조건 상태

  5. Validation 절

  6. Rely 절

색인을 활성화 또는 비활성화할 때 예외 테이블도 지정할 수 있습니다.

적용할 options를 선택한 후 OK를 누릅니다.

관련 항목

Constraints

Create Constraint

제약 조건 이름 변경


제약 조건 이름 변경

Schema Browser에서 손쉽게 제약 조건 이름을 변경할 수 있습니다.

제약 조건 이름을 변경하려면

  1. Schema Browser | Constraints 페이지에서 이름을 변경할 제약 조건을 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Rename Constraint를 선택합니다.

  3. New Constraint Name 상자에서 제약 조건의 새 이름을 입력합니다.

Toad에서 새 제약 조건 이름의 제안을 제공할 수 있습니다. Suggest 단추를 눌러 제안을 얻습니다. 제공되는 것은 제안에 불과하기 때문에 쉽게 덮어쓸 수 있습니다.

  4. OK를 누릅니다.

관련 항목

Schema Browser: Constraints

Create Constraint

Alter Constraint


Schema Browser: Contexts

컨텍스트는 기능 기반 보안 정책을 응용 프로그램에 링크하여 세밀한 액세스 제어에 도움을 주는 개체입니다.

주: 컨텍스트는 Oracle 버전 8i 이상에서만 사용할 수 있습니다.

컨텍스트 변수는 고유한 컨텍스트 이름에 연결되어 있는 저장된 패키지에 포함된 함수 및 프로시저 집합에 매핑됩니다. Oracle에서는 SYS_CONTEXT 함수를 통한 관계를 사용하여 패키지에 정의된 변수 또는 상수에 대해 유효성을 검사합니다.

컨텍스트 개체는 SYS 사용자가 소유하며 SYS 스키마에 있습니다. 컨텍스트가 연결되면 SYS_CONTEXT 함수에서 지정된 특성을 반입합니다. 그러면 특성이 보안 데이터베이스 개체에 캡슐화되어 제어할 수 있게 됩니다. 모든 컨텍스트는 SYS가 소유하지만, Toad의 Schema Browser에서는 각 컨텍스트와 연결된 패키지를 소유한 스키마 아래에 컨텍스트를 나열합니다.

Toad를 통해 컨텍스트를 작성, 수정 및 삭제할 수 있습니다.

Objects 패널

Schema Browser의 왼쪽 패널에는 컨텍스트 목록이 나타납니다. 컨텍스트의 세부 정보를 보려면 컨텍스트를 누릅니다. 오른쪽 패널에 세부 정보가 표시됩니다.

Database Links 도구 모음

단추 | 명령
 | Create script from context - 이 명령은 선택한 컨텍스트의 스크립트를 작성하고 클립보드에 복사합니다. 이 명령을 사용하려면 컨텍스트를 선택해야 합니다. 그런 다음 스크립트를 Editor에 붙여넣을 수 있습니다.
 | Alter a context - Alter Context에서 설명한 대로 컨텍스트를 변경할 수 있는 Alter Context 창을 표시합니다. Toad에서는 원래 링크를 삭제하고 변경 사항을 적용한 새 링크를 작성합니다.
 | Create a new context - Create Context 창을 표시합니다.
 | Filter contexts - Browser Filters 창을 열고 개체 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Drop context - 이 항목을 누르면 선택한 컨텍스트가 삭제됩니다. 이 명령을 사용하려면 컨텍스트를 선택해야 합니다.

Details 패널

Details 패널에는 General Info 탭과 Script regeneration 탭이 있습니다.


Create Context

Toad를 사용하여 손쉽게 새 컨텍스트를 작성할 수 있습니다. 네 개의 구성 요소만 있으면 Toad에서 컨텍스트를 작성할 수 있습니다.

컨텍스트를 작성하려면

  1. Schema Browser|Context 페이지에서 Create Context [image] 단추를 누릅니다.

  2. Context Name 상자에 컨텍스트 이름을 입력합니다.

  3. Basic Info 탭에 패키지 스키마를 입력합니다. 기본값은 활성 스키마입니다.

  4. 적절한 상자에 패키지 이름과 유형을 입력합니다.

  5. OK를 누릅니다.


Alter Context

기존 컨텍스트를 수정할 수 있습니다. 컨텍스트의 이름은 변경할 수 없지만 속성을 변경할 수 있습니다.

컨텍스트를 수정하려면

  1. Schema Browser|Context 페이지에서 Alter context [image] 단추를 누릅니다.

  2. Basic Info 탭에서 다음을 변경할 수 있습니다.

  3. 패키지 스키마

  4. 패키지 이름

  5. 유형


Schema Browser: DB Links

Schema Browser 창에서는 데이터베이스 링크에서 스크립트를 작성하고, 새 링크를 작성하고, 링크를 삭제할 수 있습니다.

주: 데이터 사전에서 데이터베이스 링크 암호를 추출할 수 없습니다.

Objects 패널

Schema Browser의 왼쪽 패널에는 데이터베이스 링크 목록이 나타납니다. 링크의 세부 정보를 보려면 링크를 누릅니다. 오른쪽 패널에 세부 정보가 표시됩니다. 데이터베이스 링크를 변경할 수는 없지만 삭제한 후 새로 작성할 수는 있습니다.

데이터베이스 링크의 여러 유형과 상태를 다양한 아이콘으로 구분합니다. 자세한 내용은 Icon Legend를 참조하십시오.

Database Links 도구 모음

단추 | 명령
 | Create script from database link - 이 명령은 선택한 데이터베이스 링크에서 스크립트를 작성하고 클립보드에 복사합니다. 이 명령을 사용하려면 데이터베이스 링크를 선택해야 합니다. 그런 다음 스크립트를 Editor에 붙여넣을 수 있습니다.
 | Create a new database link - Create Database Link 창을 표시합니다. 확인란을 사용하면 링크를 공개 링크로 만들거나 기존 링크를 삭제할 수 있습니다. Name 상자에 링크 이름을 입력합니다. 드롭다운을 사용하여 연결할 데이터베이스를 선택할 수 있습니다. 텍스트 상자를 사용하면 연결 사용자 이름과 암호를 입력할 수 있습니다.
 | Alter a database link - Create Database Link에서 설명한 대로 링크를 변경할 수 있는 Alter Database Link 창을 표시합니다. Toad에서는 원래 링크를 삭제하고 변경 사항을 적용한 새 링크를 작성합니다.
 | Test database link - 이 항목을 누르면 선택한 데이터베이스 링크를 테스트할 수 있습니다. 결과는 클립보드에 복사하거나 다른 곳에 붙여넣을 수 있는 옵션이 포함된 대화 상자에 표시됩니다.
 | Filter database links - Browser Filters 창을 열고 개체 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Drop database link - 이 항목을 누르면 선택한 데이터베이스 링크가 삭제됩니다. 이 명령을 사용하려면 데이터베이스 링크를 선택해야 합니다.

Details 패널

Details 패널에는 매개 변수와 값(소유자, 호스트, 사용자, 날짜 등)을 표시하는 Info 탭이 있습니다.

관련 항목

Create Database Link


데이터베이스 링크 작성

데이터베이스 링크를 작성하려면

  • Create에서 Database Link를 선택합니다.

또는

Schema Browser|DB Links 페이지에서 Create new database link 단추를 선택합니다.

DB 링크는 각 표 또는 보기 이름 끝의 질의에 사용됩니다.

이렇게 하면 데이터베이스 링크를 작성하기 위해 정보를 입력할 수 있는 위치에 Create Database Link 창이 표시됩니다. 드롭다운 메뉴를 통해 연결할 데이터베이스 목록에서 선택할 수 있습니다. Project Manager에 개체를 추가하려면 Add to PM 확인란을 선택합니다. 상자에 정보를 입력한 후 Execute 단추를 눌러 데이터베이스 링크를 작성합니다.

관련 항목

DB 링크

데이터베이스 링크 작성


Schema Browser: Dimensions

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

차원은 기본 테이블에서 그 테이블을 기반으로 하는 Materialized View(스냅숏)로 질의를 리디렉션하는 프로세스입니다. 이를 통해 최고의 요약 테이블을 참조하여 질의를 더 빠르게 실행할 수 있습니다.

예를 들어 일별 세일즈 정보가 포함된 DAILY_SALES라는 테이블이 있습니다. 일부 사용자는 세일즈 보고서를 주별 또는 월별로 보는 것을 선호합니다. 따라서 DAILY_SALES 테이블을 기반으로 하여 WEEKLY_SALES와 MONTHLY_SALES라는 Materialized View(스냅숏)를 작성합니다. 이제 Oracle에 이 테이블이 서로를 기반으로 한다는 것을 알리는 차원을 작성할 수 있습니다(일별 기록을 합산하여 주별 기록으로, 주별 기록을 합산하여 월별 기록으로).

이제 사용자가 DAILY_SALES를 질의하여 주별이나 월별로 요약된 데이터를 요청하면 Oracle에서 WHERE 절과 가장 잘 맞는 요약 테이블을 사용하도록 질의를 다시 작성합니다. 이 작업은 계획 설명 단계 전에 수행되며 사용자는 질의가 리디렉션되었다는 것을 알 수 없습니다.

스플리터에서는 마지막 페이지를 열었을 때의 위치를 기억합니다.

Objects 패널

Dimensions 페이지에 있는 Objects 패널을사용하면 차원을 보고, 작성하고, 컴파일하고, 삭제할 수 있습니다.

Objects 패널 도구 모음

단추 | 명령
 | 스크립트를 작성하고 클립보드에 복사합니다.
 | Create new dimension - 차원 속성을 지정할 수 있는 Create New Dimension 창을 엽니다.
 | Compile dimension - 차원을 컴파일합니다.
 | 차원 목록을 필터링합니다. Browser Filters 창을 열고 개체 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | 차원 삭제

Details 패널

Dimensions 페이지의 Details 패널을 사용하면 선택한 차원에 대한 정보를 표시할 수 있습니다. 이 정보에는 Create Dimension 항목에서 설명한 대로 작성된 수준과 계층이 포함됩니다. 차원을 정의하는 스크립트를 볼 수도 있습니다.

"dependant col" 열에 특성이 표시됩니다.

관련 항목

Create Dimension


Create Dimension

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

여러 가지 방법으로 새 차원을 작성할 수 있습니다.

차원을 작성하려면

  1. Database|Create 메뉴에서 Create Dimension을 선택합니다.

또는

Schema Browser에서 Dimension 페이지를 선택한 다음 도구 모음에서 Create Dimension 단추를 누릅니다.

어느 경우나 Create Dimension 대화 상자가 나타납니다.

  2. 차원을 작성할 스키마를 선택합니다. 현재 연결된 스키마가 이미 입력되어 있습니다.

  3. Dimension Name 상자에 새 차원의 이름을 입력합니다.

  4. +를 누르고 수준 이름을 지정하여 최소한 하나 이상의 수준을 작성합니다. 수준을 작성하고 나면 테이블과 열을 추가할 수 있습니다. dependant col 열에 특성이 표시됩니다.

이 영역에서는 다음을 수행할 수 있습니다.

  • +수준 추가

  • -수준 삭제

  • 수준 이름 편집

  5. 이제 차원에 계층을 추가할 수 있습니다. 수준을 작성한 것과 같은 방법으로 작업을 수행합니다.

이 영역에서는 다음을 수행할 수 있습니다.

  • +계층 추가

  • -계층 삭제

  • 계층 이름 편집

  6. Parent/Child 수준을 levels 편집 상자에서 Parent/Child Levels 트리로 끌어 내립니다. 그러면 선택한 계층의 DDL에서 <level> Child of… 섹션이 구성됩니다.

  7. 각 계층에 Join 키를 설정합니다.

  8. Show SQL을 눌러 이 대화 상자에서 작성한 SQL을 표시합니다. Show SQL 대화 상자에서 Copy to Clipboard 또는 Save to File을 수행할 수 있습니다.

  9. 선택적으로 Add to PM 확인란을 선택하면 Project Manager에 개체를 추가할 수 있습니다.

  10. OK를 눌러 새 차원을 작성합니다.

관련 항목

Dimensions


Schema Browser: Directories

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Schema Browser: Directories 페이지는 Oracle 8 이상을 사용하는 경우에만 사용할 수 있습니다.

디렉토리를 작성 또는 수정할 수 있습니다. Create Directory 항목을 참조하십시오.

Objects 패널

Objects 패널에서는 이름과 경로를 포함한 Directory 창을 표시합니다.

Directory 도구 모음

단추 | 명령
 | 디렉토리 스크립트를 작성하고 클립보드에 복사합니다.
 | Create a new directory - Directory 창을 여는 Create|Directory 메뉴 항목을 통해 새 디렉토리를 작성할 수도 있습니다.
 | Alter directory - 선택한 디렉토리를 수정할 수 있습니다.
 | View/Edit privileges - View/Edit privileges 창을 엽니다. 권한이 충분한 경우에는 관련 권한을 편집할 수 있습니다.
 | Filter directory list - Browser Filters 창을 열고 개체 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Drop directory - 선택한 디렉토리를 삭제할 수 있습니다.

Details 패널

Details 패널에는 Info, External Tables, Script, Auditing 및 Grants 탭이 있습니다.

관련 항목

Create Directory


창: Create Directory

Create Directory

주: 이 Toad 기능은 선택 사항인 Quest DBA Module과 함께 Toad의 상용 버전에서만 사용할 수 있습니다.

이 창은 새 디렉토리 개체를 작성하는 데 사용합니다. 디렉토리 개체는 큰 외부 이진 개체(BFILE)가 저장되는 위치에서 서버 파일 시스템에 있는 디렉토리에 대한 별칭입니다.

디렉토리를 작성하려면

  1. Create 에서 Directory를 선택합니다.

또는

Schema Browser|Directories 페이지에서 Create Directory 단추를 누릅니다.

  2. 아래 설명된 대로 옵션을 입력합니다.

  3. 아니면 Add to PM 확인란을 선택하여 Project Manager에 개체를 추가합니다.

  4. OK를 눌러 디렉토리를 작성합니다.

Directory Name

디렉토리의 별칭 이름을 입력합니다.

Path

지정 경로를 입력합니다. 드릴다운 단추를 누르면 Browse for folder(디렉토리 브라우저) 창이 표시되며, 여기서 디렉토리를 선택할 수 있습니다. 그런 다음 OK를 누릅니다. 선택한 경로가 자동으로 Path 상자에 입력됩니다.

Show SQL 단추를 누르면 Create Directory SQL 구문이 표시되는 위치에 SQL 구문 창이 열립니다. 창의 Clipboard 단추를 누르면 클립보드에 구문이 복사됩니다. Save to File 단추를 누르면 Save As 대화상자가 열리고, 여기서 경로를 선택하고 파일 이름을 입력할 수 있습니다.

관련 항목

Schema Browser: 디렉토리


Favorites

이 페이지를 사용하면 자주 사용하는 여러 종류의 개체를 그룹으로 묶어 Schema Browser에 탭으로 표시할 수 있습니다. 이러한 여러 개체는 하나 이상의 "폴더"에 그룹으로 묶을 수 있습니다. 이 탭의 구성은 Toad for Oracle\Temps\<server name>\Projects.lst라는 파일에 보존되며 구성은 인스턴스 수준에서 유지됩니다. 즉, 폴더는 연결이나 스키마가 아닌 인스턴스별로 적용됩니다. 이 페이지에서 여러 폴더를 작성할 수도 있습니다. 폴더를 작성하고 나면 개체를 추가할 수 있습니다.

이 창에서 지원되는 개체에는 테이블, 보기, PL/SQL 코드(프로시저, 함수, 패키지, 트리거) 및 파일이 포함됩니다.

주: Favorites 페이지는 Schema Browser의 트리 보기에서 사용할 수 없습니다.

폴더 작성

Favorites 탭에 개체를 추가하려면 먼저 개체를 그룹으로 묶을 폴더를 작성해야 합니다.

폴더를 작성하려면

  1. 도구 모음에 있는 Add New Folder [image] 단추를 누릅니다. Folder 대화 상자가 나타납니다.

  2. 폴더의 이름을 입력한 후 OK를 누릅니다.

폴더에 개체 추가

오른쪽 패널의 폴더에 손쉽게 개체를 추가할 수 있습니다. 데이터베이스 개체 또는 스크립트/파일을 추가할 수 있습니다.

데이터베이스 개체를 추가하려면

  1. 왼쪽 패널에서 개체를 넣을 폴더를 선택하거나 마우스 오른쪽 단추로 누릅니다.

  2. Add Database Object를 선택하거나 도구 모음에 있는 Add Database Object [image] 단추를 누릅니다. Object Search 창이 나타납니다.

  3. 검색 기능을 사용하여 추가할 개체를 찾습니다. 결과 그리드에서 추가할 개체를 강조표시한 후 마우스 오른쪽 단추를 누릅니다. Schema Browser에 있는 탭 중에는 마우스 오른쪽 단추 메뉴에 "Add to Favorites list"가 있는 것이 많습니다. 그렇지 않은 것은 별로 없습니다.

  4. 메뉴에서 Add to SB Folder List를 선택합니다. Select Folder 대화 상자가 나타납니다. 개체를 넣을 폴더를 선택하고 OK를 누릅니다.

  5. Toad에서 개체를 추가했다는 내용의 확인 대화 상자를 표시합니다. 이제 Object Search 창을 닫을 수 있습니다. 선택한 개체가 적절한 폴더에 포함됩니다.

스크립트/파일을 추가하려면

  1. 왼쪽 패널에서 스크립트를 넣을 폴더를 마우스 오른쪽 단추로 누릅니다.

  2. 메뉴에서 Add Script/File을 선택합니다. Select files for folder 대화 상자가 열립니다. 이 대화 상자를 표준 "Open" 대화 상자로 사용하면서 한 가지 예외에 주의합니다. 여기서는 한 번에 여러 파일을 선택하여 추가할 수 있습니다. Open을 누릅니다.

  3. 메뉴에서 Add to SB Folder List를 선택합니다. Select Folder 대화 상자가 나타납니다. 개체를 추가할 폴더를 선택하고 OK를 누릅니다.

폴더에서 개체 제거

입력할 때와 마찬가지로 손쉽게 개체를 폴더에서 제거할 수 있습니다.

개체를 제거하려면

  1. 제거할 개체를 선택합니다.

  2. Configure the Favorites Folders [image] 단추를 누릅니다.

  3. 메뉴에서 Remove Item을 선택합니다. 확인 대화 상자가 나타납니다.

  4. Yes를 누릅니다. 폴더에서 항목이 제거됩니다.

Favorites 폴더 비우기 또는 제거

폴더를 비우거나 Favorites 페이지에서 한꺼번에 제거할 수 있습니다.

Favorites 폴더를 비우거나 제거하려면

  1. 왼쪽 패널에서 비우거나 제거할 폴더를 선택합니다.

  2. 폴더 이름을 마우스 오른쪽 단추로 누릅니다.

또는

Configure Favorites Folders [image] 단추를 눌러 작업 메뉴를 표시합니다.

  3. 메뉴에서 Remove Folder 또는 Empty Folder를 선택합니다. 전자의 경우에는 전체 폴더가 제거됩니다. 후자의 경우에는 폴더에서 개체를 비우지만 폴더 자체는 Favorites 페이지에 남습니다.


Schema Browser: Indexes

Objects 패널

Indexes 페이지의 Objects 패널에는 색인 목록, 그리고 색인의 작성, 수정, 분석 등에 사용되는 도구 모음이 표시됩니다.

색인 목록에서 아이콘은 색인의 여러 유형 또는 상태를 표시합니다. Schema Browser에서 사용되는 아이콘 범례 보기에 대한 자세한 내용은 Icon Legend 항목을 참조하십시오.

Indexes 도구 모음

단추 | 명령
 | Create script from index - 이 명령은 선택한 색인에서 스크립트를 작성하고 클립보드에 복사합니다. 이 명령을 사용하려면 색인을 선택해야 합니다. 그런 다음 스크립트를 DEditor에 붙여넣을 수 있습니다.
 | New index - Create Index 창을 표시합니다. 자세한 내용은 Create Index 항목을 참조하십시오.
 | Alter index - Alter Index 창을 표시합니다. 자세한 내용은 Alter Index 항목을 참조하십시오.
 | Rebuild index - Rebuild Index 창을 표시합니다. 자세한 내용은 Rebuild Index 항목을 참조하십시오.
 | Analyze index - 이 대화 상자를 사용하면 색인 개체 목록에서 선택한 색인을 분석할 수 있습니다. 그러면 통계를 수집하여 비용 기반 질의 최적화를 사용할 수 있습니다. 그 결과 Optimizer에서 질의를 더 잘 실행할 수 있습니다. 통계를 추정하거나(계산보다 빠름), 통계를 계산하거나, 현재 통계를 삭제할 수 있습니다.
 | Filter index list - Browser Filters 창을 열고 개체 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨간색으로 바뀝니다.
 | Drop selected index - 이 항목을 누르면 선택한 색인이 삭제됩니다. 이 명령을 사용하려면 색인을 선택해야 합니다.

Details 패널

Details 패널에는 선택한 색인에 대한 정보가 Columns, Partitions 및 Script 등의 탭으로 구성되어 표시됩니다.

관련 항목

Create Index

Alter Index

Rebuild Index

Rename Index


색인 작성

주: Toad는 이번에는 다음 기능을 지원하지 않습니다.

  • 파티션 합성

  • 일부 해시 파티션 기능(개별 파티션 이름 지정 기능: 현재 시스템에서 생성)

  • 하위 파티션

Create Index를 액세스하려면

  • Database|Create 메뉴에서 Index를 선택합니다.

또는

Schema Browser|Indexes에서 Create New Index 단추를 누릅니다.

색인은 보다 빠른 표 데이터 경로를 제공하여 실행 속도를 늘릴 수 있습니다.

이 대화상자를 사용하여 스키마 소유자, 표 이름을 선택하고 Index 탭에서 Primary Key 색인, Unique 색인, Non-Unique 색인, 기능 기반의 색인 또는 Bitmap 색인 작성 여부를 선택하고, 색인 열 및 선택 사항인 저장 매개 변수를 선택합니다.

  • Schema - 상단의 Schema 드롭다운에서 색인이 상주할 스키마를 선택할 수 있습니다.

  • Name - Name 상자에서 새로운 색인의 이름을 지정할 수 있습니다.

  • Show SQL - Index Create DDL에 대한 SQL 구문을 표시합니다.

  • Add to PM - 이 확인란을 표시하면 Project Manager에 색인이 추가됩니다.

  • OK - 색인을 작성할 수 있는 명령이 부여됩니다.

  • Cancel - 확인 대화상자가 표시되며, 여기서 OK를 눌러 확인할 경우 Toad가 변경 내용을 취소하고 Index 창을 닫습니다.

Physical Attributes 탭

Percent Used 필드는 Create Index와 관련이 없으므로 비활성화됩니다.

Partitions 탭

Available Columns 는 색인에 대한 열로 선택한 열과 동일합니다(제외되는 데이터 형식 열: BLOB, CLOB, NCLOB, BFILE, ROWID, UROWID, MLSLABEL). Available Columns 목록에서 열을 선택하여 파티션의 기준 열을 결정합니다. 각 파티션은 색인을 위해 동일한 열 목록을 기준으로 작성되었습니다.

Add a Partition

기준으로 지정할 파티션에 대한 열을 선택한 다음 파티션을 추가할 수 있습니다.

범위 파티션을 추가하려면

  • Add 단추를 누릅니다. Add Partition 대화상자가 나타나며, 여기서 파티션 이름을 입력할 수 있습니다. 파티션 내의 각 열에 대한 상위 범위를 입력하거나 대화상자의 드롭다운 목록에서 Maxvalue를 선택합니다.

주: 문자열 상한 경계값은 눈금 안에 작은따옴표로 묶여 있어야 합니다(예를 들어, varchar2 데이터 형식의 Last Name 열의 경우 상한 경계값이 'Smith'가 될 수 있음). 작은따옴표는 눈금 안에 입력해야 합니다.

해시 파티션을 추가하려면

  • 표 공간을 선택하여 해시 파티션을 사용합니다. 수량은 색인 기준의 해시 파티션과는 관계 없으므로 비활성화됩니다.

Schema Browser|Indexes 페이지|Modify 단추를 눌러 색인을 변경할 수 있습니다.

관련 항목

색인

색인 변경

색인 재구성

색인 이름 바꾸기


색인 기본 정보 작성

적절한 옵션을 선택하여 작성 또는 수정할 색인의 기본 정보를 지정합니다.

Table Index

테이블을 기반으로 한 색인을 사용하려면 Table Index 단추를 선택합니다. 이 단추는 기본적으로 선택됩니다.

Cluster Index

클러스터를 기반으로 한 색인을 사용하려면 Cluster Index 단추를 선택합니다.

Schema

색인을 지정할 테이블 또는 클러스터가 있는 스키마를 선택합니다. 여기서는 해당 스키마의 테이블 또는 클러스터를 스키마 드롭다운 아래의 Table/Cluster 드롭다운 상자에 로드합니다.

Table/Cluster

이 드롭다운은 색인을 작성할 테이블 또는 클러스터를 선택하는 위치입니다. Table Index 라디오 단추를 선택한 경우 드롭다운은 Table 드롭다운입니다. Cluster 라디오 단추를 선택한 경우 드롭다운은 Cluster 드롭다운입니다. 테이블을 선택하면 열이 Columns 탭에 표시됩니다.

Bitmap

이 항목은 색인이 B-트리가 아닌 비트맵으로 작성되도록 지정합니다. 웨어하우징과 같이 동시 트랜잭션 수준이 낮은 응용 프로그램에 가장 적합합니다. 이 기능은 Oracle 8 이상이 있는 경우에만 활성화됩니다.

Logging

이 확인란은 색인 작성을 다시 실행 로그 파일에 기록할 것인지(선택) 기록하지 않을 것인지(선택 취소) 결정합니다. 여기서는 선택에 따라 색인에 대한 이후의 Direct Loader(SQL*Loader) 및 직접 로드 INSERT 작업을 기록할 것인지 여부도 지정합니다. 기본적으로 선택됩니다.

Oracle 8 이전 버전에서는 이 개념을 복구 가능(Recoverable)이라고 합니다. 따라서 Oracle 8 이전 버전에서는 옵션이 Logging 대신 Recoverable로 표시됩니다.

Monitoring

Oracle 버전 9i 이상에는 색인을 모니터하여 그 사용 여부를 확인하는 수단이 제공됩니다. 그 후에 사용되지 않는 색인을 삭제하여 불필요한 문 오버헤드를 제거할 수 있습니다. 이 옵션을 선택하면 Oracle에서 이 색인을 모니터합니다. 색인 모니터링에 대한 자세한 내용은 Index Monitoring을 참조하십시오.

Parallel 확인란

이 옵션은 Parallel 편집 필드를 활성화 또는 비활성화합니다. 이 옵션을 선택하면 Oracle에서는 모든 참가 인스턴스에서 사용할 수 있는 CPU 수에 PARALLEL_THREADS_PER_CPU 초기화 매개 변수 값을 곱한 결과를 병렬 처리도로 선택합니다. 값을 지정한 경우 이 값은 병렬 처리도, 즉 병렬 작업에 사용되는 병렬 스레드의 수를 나타냅니다. 각 병렬 스레드는 한 개 또는 두 개의 병렬 실행 서버를 사용할 수 있습니다. Oracle에서는 보통 최적 병렬 처리도를 계산하기 때문에 값을 지정할 필요가 없습니다. 이 옵션을 선택하면 병렬 처리도 및 인스턴스 매개 변수를 지정해야 합니다.

이 옵션은 기본적으로 선택 취소(병렬 없음)됩니다.

Reverse

이 확인란이 선택되어 있으면 색인 블록의 바이트가 역순으로 저장됩니다. Reverse 확인란과 Not Sorted 확인란은 함께 선택할 수 없습니다. 동시에 선택할 수 없습니다. 이 기능은 Oracle 8 이상이 있는 경우에만 활성화됩니다.

Domain

이 확인란을 선택하면 이 색인을 도메인 색인으로 만들 수 있습니다. 도메인 색인에 대한 자세한 내용은 Oracle 관련 문서를 참조하십시오. 이 상자를 선택하면 Domain Info 탭이 표시됩니다.

Uniqueness

Non-unique

이 항목을 선택하면 unique 제약 조건이 적용되지 않습니다.

Unique

이 항목을 선택하면 색인의 기반으로 사용되는 열 값이 고유해야 한다고 지정할 수 있습니다. 보통 이 항목을 사용하는 것은 좋지 않습니다. Oracle 권장 사항에 따르면 UNIQUE 무결성 제약 조건은 테이블을 작성할 때 사용하는 것이 좋습니다.

Primary Key

이 항목은 제공된 색인 이름과 같은 이름을 가지고 선택한 열에 기반하는 특정 테이블에 대해 Primary Key 제약 조건을 작성합니다.

Creations 옵션

Compute Statistics 확인란

이 상자를 선택하면 색인을 작성하는 동안 통계를 수집할 수 있습니다. 이러한 통계는 데이터 사전에 저장해 두고 SQL 문 실행 계획을 선택할 때 최적화 프로그램에서 지속적으로 사용할 수 있습니다. 이 기능은 Oracle 8.1 이상이 있는 경우 활성화됩니다.

Not Sorted 확인란

이 확인란을 선택하면 Oracle에서는 데이터베이스에 행이 오름차순으로 저장되기 때문에 색인을 작성할 때 행을 정렬할 필요가 없다는 것을 알게됩니다. Not Sorted 확인란과 Reverse 확인란은 함께 선택할 수 없습니다. 동시에 선택할 수 없습니다. 이 기능은 Oracle 8 이상이 있는 경우에만 활성화됩니다.

Online 확인란

이 옵션을 선택하면 Toad에서는 색인을 작성하는 동안 테이블에서의 DML 작업을 허용합니다. 이 기능은 Oracle 8 이상이 있는 경우에만 활성화됩니다.

Key Compression

주: Key Compression 라디오 단추는 Oracle 8 이상이 있는 경우에만 활성화됩니다.

  • Compress - Compress 라디오 단추는 Compress columns 입력 필드를 활성화 또는 비활성화합니다. Compress를 선택한 경우에는 압축할 열의 수를 입력해야 합니다. Compress를 선택하면 키 압축이 활성화되어 반복되는 키 열 값을 제거하고 저장 공간을 대폭 절약할 수 있습니다.

  • Value - 값 상자를 사용하면 접두사 길이(압축할 접두사 열 수)를 지정할 수 있습니다. Compress 옵션을 선택한 경우에는 이 상자를 채워야 합니다.

Unique 색인의 경우 유효한 접두사 길이 값 범위는 1부터 키 열 수 빼기 1까지입니다. 기본 접두사 길이는 키 열 수 빼기 1입니다.

Nonunique 색인의 경우 유효한 접두사 길이 값의 범위는 1에서 키 열 수까지입니다. 기본 접두사 길이는 키 열 수입니다.

  • Oracle에서는 적어도 두 열에 대한 비고유 또는 고유 색인인, 분할되지 않은 색인만 압축합니다.

  • No Compress - No Compress를 선택하면 키 압축이 비활성화됩니다.


Create Index - Columns 탭

Bitmap Join Index

비트맵 결합 색인에 대한 From 절과 where 절을 입력할 수 있는 텍스트 상자를 표시하려면 이 확인란을 선택합니다.

Table Columns

이 패널에는 선택한 테이블의 열이 표시됩니다.

두 번 누르거나 끌어서 놓으면 Table Columns 목록에서 Index Columns 목록으로 항목을 이동할 수 있습니다. 다음의 정렬 순서를 조정할 수 있습니다.

Index

이 패널에는 색인용으로 선택한 테이블 열이 표시됩니다.


Create Index - Domain Info 탭

이 탭에 있는 옵션을 사용하여 작성된 도메인 색인의 매개 변수를 설정합니다.

  • Index Type Owner 상자에 유형 소유자를 입력합니다.

  • Index Type Name 상자에 유형 이름을 입력합니다.

  • 적용할 매개 변수를 입력합니다.


Create Index - Physical Attributes 탭

Percent Free

향후 업데이트를 위해 남겨 둘 여유 공간의 백분율 값을 입력합니다. 이 상자를 비워 두면 기본값 10이 설정됩니다.

Initial Trans 입력란

테이블에 할당된 각 데이터 블록 내에 할당되는 트랜잭션 항목의 초기 수를 지정합니다.

Max Trans 입력란

이 입력란은 테이블에 할당된 데이터 블록을 업데이트할 수 있는 최대 동기 트랜잭션 수를 지정합니다.

Tablespace 드롭다운

색인을 보관할 테이블 공간의 이름을 지정하는 위치입니다. 테이블 공간 이름을 지정하지 않으면 Oracle에서 색인을 포함하는 스키마 소유자의 기본 테이블 공간에 색인을 작성합니다.

Storage

색인의 저장소 매개 변수를 입력합니다. 이러한 매개 변수에 대한 자세한 설명은 Oracle 관련 문서를 참조하십시오.


색인 변경

색인을 변경하려면

  1. Schema Browser|Indexes 탭에서 Alter Index를 액세스합니다(그런 다음 색인 선택).

  2. Alter Index [image] 단추를 누릅니다.

이 창에서 선택한 색인을 수정 또는 변경할 수 있습니다.

Schema 드롭다운

색인이 상주하는 스키마입니다. 변경할 수 없으므로 드롭다운이 비활성화됩니다.

Name 상자

색인의 이름을 표시합니다. 변경할 수 없습니다. 색인의 이름을 바꾸려면 색인 이름 바꾸기를 참조하십시오.

Index 탭

Deallocate Unused Space 확인란

표시되어 있으면 Oracle이 색인 끝의 사용하지 않는 공간을 명시적으로 할당 취소합니다. 이렇게 하면 표 공간의 다른 세그먼트에 사용할 수 있는 여유 공간이 만들어집니다. 워터마크 위의 사용하지 않는 공간만 확보할 수 있습니다. 표시되어 있으면 Keep 상자가 활성화됩니다.

Keep 상자

할당 취소 후 색인에 포함될 워터마크 위의 바이트 수를 지정합니다.

Bytes 드롭다운

Kilobytes 또는 Megabytes 를 선택할 수 있습니다. 기본값은 Kilobytes입니다.

Deallocate Unused Space는 Allocate New Extent와 동시에 적용할 수 없습니다. 하나가 표시되어 있으면 다른 하나는 자동으로 표시되지 않습니다. 둘 다 선택할 수는 없습니다.

Allocate New Extent 확인란

표시되어 있으면 색인의 새 범위를 명시적으로 할당합니다. 해시 분할된 표의 로컬 색인의 경우 Oracle이 색인의 각 파티션에 새 범위를 할당합니다. 표시되어 있으면 Size 상자가 활성화됩니다.

Size

범위 크기를 바이트 단위로 지정합니다. Size가 생략되어 있으면 Oracle은 색인의 저장 매개 변수 값에 따라 크기를 결정합니다.

Bytes 드롭다운

Kilobytes 또는 Megabytes 를 선택할 수 있습니다. 기본값은 Kilobytes입니다.

Allocate New Extent는 Deallocate Unused Space와 동시에 적용할 수 없습니다. 하나가 표시되어 있으면 다른 하나는 자동으로 표시되지 않습니다. 둘 다 선택할 수는 없습니다.

옵션

Mark Unusable 확인란

표시되어 있으면 색인을 사용 불가능한 것으로 표시합니다. 색인이 사용 불가능한 것으로 표시되면 사용할 수 있기 전에 다시 구성하거나 삭제한 다음 다시 작성해야 합니다.

Coalesce 확인란

표시되어 있으면 Oracle은 다시 사용하기 위해 블럭을 확보할 수 있는 위치마다 색인의 목차를 병합합니다.

Parallel 확인란

표시되어 있으면 작성하는 동안 사용되는 Parallel 값을 변경합니다.

Logging 라디오 단추 및 No Logging 라디오 단추

이러한 라디오 단추는 작성하는 동안 사용되는 Logging 값을 변경합니다.

Storage 탭

여기서 저장 매개 변수를 지정합니다.

Buffer Pool 의 경우 드롭다운에서 Default, Keep 및 Recycle 을 선택할 수 있습니다. 이 기능은 Oracle 8.0 이상 버전에서만 활성화됩니다.

Partitions 탭

분할된 색인에 Partitions 탭도 표시됩니다. 이 탭에서 파티션을 별도로 편집, 삭제 및 분할할 수 있습니다.

관련 항목

색인

색인 작성

색인 재구성

색인 이름 바꾸기


색인 재구성

질의 성능을 향상시키기 위해 색인을 주기적으로 재구성해야 합니다. 코드가 표 및 색인에 추가되고 기타 레코드가 표 및 색인 중간에서 삭제되므로 표 및 색인을 읽을 때 레코드를 찾을 때까지 디스크 장치가 체인의 위쪽과 뒤쪽을 지그재그로 이동해야 합니다. 색인을 재구성하면 체인도 연속적으로 재구성되며 질의 성능이 매우 향상됩니다.

색인을 재구성하려면

  1. Schema Browser에서 Rebuild Index 대화상자를 액세스합니다.

  2. Indexes 탭의 목록에서 색인을 선택하고 Rebuild Index를 누릅니다.

  3. Rebuild Index 대화상자에는 Options 및 Sql의 두 개의 탭이 있습니다. 아래에 설명된 대로 두 개의 탭의 옵션을 설정합니다. 설정이 완료되면 Execute를 눌러 색인을 재구성합니다.

Options 탭

Options 탭에서 색인 구성 방식을 설정할 수 있습니다.

Parallel/Not Parallel

적절한 옵션을 선택합니다. Parallel을 선택할 경우 숫자 필드에 숫자를 입력합니다.

Logging/No Logging or Recoverable/Not Recoverable

이 드롭다운에서 색인 작성을 반복 로그 파일에 기록할 것인지(Logging) 아니면 기록하지 않을 것인지(No Logging) 지정할 수 있습니다. 또한 선택에 따라 색인에 대한 연속 Direct Loader(SQL*Loader) 및 직접 로드 INSERT 작업의 기록 여부를 지정할 수 있습니다. 기본값은 "Default"이며, DDL 스크립트 작성에 구문이 포함되지 않는다는 뜻입니다.

Oracle 8 이전 버전은 이 개념을 Recoverable 로 참조합니다. 따라서 Oracle 8 이전 버전의 경우 Logging 대신 Recoverable로 옵션이 표시되고, 드롭다운 선택 사항은 Default, Recoverable 및 Unrecoverable이 됩니다.

Storage

초기 범위, 다음 범위 및 증가 비율의 Storage 양을 해당 필드에 입력합니다.

Tablespace

색인을 배치할 위치에서 tablespace를 선택합니다.

Sql 탭

SQL 탭에서 SQL을 봅니다. Toad가 색인 재구성에 사용합니다.

관련 항목

색인

색인 작성

색인 변경

색인 이름 바꾸기

여러 개체 재작성: 색인 재구성


Rename Index

Schema Browser에서 손쉽게 색인 이름을 변경할 수 있습니다.

색인 이름을 변경하려면

  1. Schema Browser에서 Indexes 페이지를 선택합니다.

  2. Objects Panel에서 이름을 변경할 index를 선택합니다.

  3. 마우스 오른쪽 단추를 누르고 Rename Index를 선택합니다.

  4. index name 상자에 새 이름을 입력한 다음 OK를 누릅니다.


Schema Browser: Invalid Objects

Objects 패널

Invalid Objects 페이지의 Objects 패널에는 선택한 스키마의 잘못된 개체 목록, 그리고 잘못된 개체를 수정, 컴파일, 비교할 수 있는 도구 모음이 있습니다.

Toad에서는 간단한 질의를 실행하여 권한 및 설정에 따라 DBA_OBJECTS, ALL_OBJECTS 또는 USER_OBJECTS에 있는 잘못된 개체를 모두 찾습니다.

이 질의는 다음을 표시합니다.

  • 프로시저

  • 함수

  • 패키지(스펙 및 본문)

  • 트리거

  • 보기

  • 유형(스펙 및 본문)

  • Java

  • 스냅숏

평가 컨텍스트를 볼 수도 있습니다(오른쪽이 비어 있음). Schema Browser에서는 이러한 개체를 지원하지 않습니다.

이 탭에는 사용할 수 없는 색인(또는 사용할 수 없는 파티션이나 하위 파티션이 있는 색인)도 포함되어 있습니다.

Invalid objects 도구 모음

단추 | 명령
 | 선택한 개체를 수정합니다.
 | 개체를 다른 개체와 비교합니다.
 | Compile selected object - 이 옵션은 선택한 사용할 수 없는 색인도 재구축합니다.
 | Compile all invalid objects - 이 옵션에는 사용할 수 없는 색인이 포함되지 않습니다.
 | Filter index list - Browser Filters 창을 열고 개체 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Drop selected index - 이 항목을 누르면 선택한 색인이 삭제됩니다. 이 명령을 사용하려면 색인을 선택해야 합니다.

Details 패널

Details 패널에는 선택한 개체에 대한 정보가 포함됩니다. Details 패널의 탭과 요구 사항은 선택한 개체의 유형에 따라 달라집니다.


Java

Oracle 8i 이상을 실행 중인 경우 Schema Browser에 있는 Java 페이지를 사용하여 Java 개체를 컴파일 또는 삭제할 수 있습니다. Java를 PL/SQL로 변환할 수도 있습니다.

Java 개체의 여러 유형과 상태를 다양한 아이콘으로 구분합니다. 자세한 내용은 Icon Legend를 참조하십시오.

Objects 패널

Java 페이지에 있는 Objects 패널에는 Java 개체 목록과 개체에 대한 작업을 수행하기 위한 도구 모음이 표시됩니다.

개체 목록에서 아이콘은 Java 코드의 여러 유형 또는 상태를 표시합니다. Schema Browser에서 사용되는 아이콘 범례 보기에 대한 자세한 내용은 Icon Legend 항목을 참조하십시오.

Java 도구 모음

단추 | 명령
 | 스크립트를 작성하여 클립보드에 복사합니다.
 | 선택한 개체를 컴파일합니다.
 | 선택한 Java 개체를 PL/SQL로 게시합니다. 자세한 내용은 Publish Java to PL/SQL 마법사 개요 항목을 참조하십시오.
 | 소스 코드를 파일에 저장합니다.
 | Editor에서 개체를 엽니다.
 | Add public synonym - 개체를 선택하고 이 아이콘을 눌러 선택한 항목의 공개 동의어를 작성합니다.
 | View/Edit privileges - View/Edit privileges 창을 엽니다. 권한이 충분한 경우에는 관련 권한을 편집할 수 있습니다.
 | Filter java list - Browser Filters 창을 열고 개체 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | 데이터베이스에서 개체를 삭제합니다.

Java 개체를 컴파일하거나 삭제하려면

  • Objects 패널에 있는 개체 목록에서 개체를 선택한 후 다음 중 하나를 누릅니다.

  • To compile the object

  • To drop the object from the database

Java 개체에는 Drop All을 사용할 수 없습니다.

Details 패널

Details 패널을 사용하면 선택한 Java 개체에 대한 정보를 볼 수 있습니다. 탭에는 Code, Errors, Synonyms 및 Grants가 포함됩니다.


Publish Java to PL/SQL 마법사 개요

Oracle 8i 이상에서는 Java 클래스를 데이터베이스에 저장할 수 있습니다. PL/SQL 프로그램에서는 PL/SQL 래핑 패키지를 통해 Java 클래스에 액세스할 수 있습니다. 래퍼 패키지는 호출할 프로시저 및 기능 세트를 정의하고 Java 클래스의 메서드에 매핑합니다.

Publish Java to PL/SQL Wizard는 데이터베이스에서 선택한 Java 클래스의 PL/SQL 래퍼 패키지를 손쉽게 작성할 수 있는 수단입니다. Java 클래스가 컴파일되어야 하며, 마법사를 사용하려면 제대로 컴파일되어 있어야 합니다.

주: Java 마법사를 사용하려면 데이터베이스에 /com/quest/Reflector 클래스와 QUEST_REFLECTOR 패키지가 설치되어 있어야 합니다. 마법사를 열었을 때 이 두 가지가 없으면 마법사에서는 해당 클래스를 작성하라는 내용의 메시지를 표시하고 프로세스를 진행합니다.

마법사의 주 기능 중 하나는 Oracle 반환 유형에 Java 반환 유형을 매핑하는 것입니다. 매핑된 Oracle 유형 중 일부는 업데이트하여 사용할 수 있게 하려면 수동으로 편집해야 합니다. 반환할 수 있는 유형의 목록은 Java 유형 및 Oracle 반환 유형을 참조하십시오.

Java를 PL/SQL로 게시하려면

  1. Schema Browser|Java 페이지에서 Java to PL/SQL 마법사에 액세스합니다.

  2. Objects 패널에서 java 클래스를 선택하고 마우스 오른쪽 단추를 누릅니다. 메뉴에서 Publish to PL/SQL…을 선택합니다. Publish Java to PL/SQL 마법사가 열립니다. 자세한 내용은 패키지 생성을 참조하십시오.


Java 유형 및 Oracle 반환 유형

다음은 Java 유형 및 그와 매핑되는 Oracle 유형의 목록입니다. 매핑된 Oracle 유형 중 일부는 업데이트하여 사용할 수 있게 하려면 수동으로 편집해야 합니다.

Java 유형 | Oracle 유형으로 변환
oracle.sql.CustomDatum, oracle.sql.Datum, oracle.sql.RAW | RAW
oracle.sql.STRUCT | OBJECT
oracle.sql.REF | REF
oracle.sql.CLOB | CLOB
array, boolean, java.lang.String, oracle.sql.BLOB, oracle.sql.CHAR, 기타: java.awt.Component, java.awt.Graphics 등 | VARCHAR2
byte, java.lang.Byte, java.lang.Double, java.lang.Float, java.lang.Integer, java.lang.Long, java.lang.Short, java.math.BigDecimal, oracle.sql.NUMBER, short, double, float, int, long | NUMBER
java.sql.Date, java.sql.Time, java.sql.Timestamp, oracle.sql.DATE | DATE
oracle.sql.BFILE | BFILE
oracle.sql.ARRAY | VARRAY
oracle.sql.ROWID | ROWID


패키지 생성

Java 코드를 PL/SQL SQL로 게시하는 데 중심이 되는 기능은 클래스에 있는 각각, 일부 또는 모든 메서드에 대해 패키지를 생성하는 기능입니다. Publishing 마법사를 사용하면 이 작업을 손쉽게 수행할 수 있습니다.

주: 게시할 Java 클래스를 포함한 스키마의 소유자로 로그인되어 있어야 합니다. 그렇지 않으면 화면 2가 제대로 표시되지 않습니다.

마법사를 열려면

  1. Schema Browser의 개체 패널에서 Java class를 선택합니다. Object 패널 도구 모음에 있는 Compile 단추를 눌러 Java 클래스를 컴파일합니다. Java 클래스가 컴파일되어야 하며, 마법사를 사용하려면 제대로 컴파일되어 있어야 합니다.

  2. Java class를 마우스 오른쪽 단추로 누른 다음 메뉴에서 Publish to PL/SQL을 선택합니다. Publish Java to PL/SQL 마법사가 나타납니다.

화면 1

PL/SQL 패키지의 이름을 입력하려면

  1. 이미 입력된 기본 이름은 선택한 Java 클래스 이름과 같지만 따옴표 안에 들어 있고 전부 대문자로 되어 있습니다.

  2. PL/SQL 패키지가 이미 있는 경우 바꿀 수도 있습니다.

  3. Next를 누릅니다.

화면 2

주: 게시할 Java 클래스를 포함한 스키마의 소유자로 로그인되어 있어야 합니다. 그렇지 않으면 화면 2가 제대로 표시되지 않습니다.

포함할 메서드를 선택하려면

  1. 포함할 메서드를 다음과 같은 방법으로 선택합니다.

  2. Class 열 왼쪽에 있는 확인란을 하나 이상 선택합니다.

  3. Select all을 누릅니다.

  4. 화면 맨 아래에 있는 확인란을 선택하면 상위 클래스의 메서드를 표시하거나 숨길 수 있습니다.

  2. Next를 누릅니다.

화면 3

Toad에서 PL/SQL 패키지 작성을 위해 생성한 코드를 표시하려면

  1. 코드를 실행하기 전에 편집하려면 Yes, open in Editor를 선택합니다.

  2. 패키지만 작성하려면 No, create package as shown을 선택합니다.

  3. Finish를 누릅니다. 마법사가 닫히고 선택에 따라 패키지가 작성되거나 Editor에서 열립니다.


Schema Browser: Jobs

Jobs 페이지에는 Objects 패널에 에 작업의 목록이 표시되며 Details 패널에는 선택한 작업의 세부 정보가 표시됩니다.

Schema Browser에서 Jobs 페이지를 사용하려면 SYS 스키마에 sys.dbms.job 패키지가 설치되어 있어야 합니다. 이 패키지가 설치되어 있지 않으면 DBA에게 catproc.sql을 실행하여 설치해 달라고 요청하십시오.

Objects 패널

Objects 패널에는 작업 목록이 표시됩니다. Toad에서는 다음 아이콘을 사용하여 작업을 온라인 또는 오프라인으로 지정합니다.

  • 온라인 - 작업이 온라인이면 아이콘이 표시되지 않습니다. 도구 모음에 있는 Place Offline 단추가 활성화되며 작업 목록에 작업 이름이 표시됩니다.

  • 오프라인 - 작업이 오프라인이면 작업 목록에서 그 옆에 Place Offline 아이콘이 표시됩니다. 도구 모음의 Place Online 단추가 활성화됩니다.

Jobs 도구 모음

단추 | 명령
 | Create new job - 작업 번호 상자, 다음 실행 날짜(날짜를 쉽게 선택할 수 있는 달력 드롭다운 사용)와 간격을 입력하는 입력란 및 실행할 작업에 대한 상자를 포함하는 Job Definition 창이 표시됩니다. 참고 항목: Create Job.
 | Alter job - Create Job에서 설명한 대로 선택한 작업의 Job Definition 창을 표시하며 그 후 수정할 수 있습니다. 주: DBMS_IJOB에 대한 액세스 권한이 없는 경우 이 명령을 수행하려면 작업 소유자로서 연결되어 있어야 합니다.
 | Place online - 선택한 작업이 오프라인인 경우에 사용할 수 있습니다. 선택한 작업을 온라인으로 설정하여 트랜잭션에 사용할 수 있게 만듭니다. 주: DBMS_IJOB에 대한 액세스 권한이 없는 경우 이 명령을 수행하려면 작업 소유자로서 연결되어 있어야 합니다.
 | Place offline - 선택한 작업이 온라인인 경우에 사용할 수 있습니다. 선택한 작업을 오프라인으로 설정하여 트랜잭션에 사용하지 못하게 만듭니다. 주: DBMS_IJOB에 대한 액세스 권한이 없는 경우 이 명령을 수행하려면 작업 소유자로서 연결되어 있어야 합니다.
 | Execute job immediately - 선택한 작업을 실행합니다. 주: DBMS_IJOB에 대한 액세스 권한이 없는 경우 이 명령을 수행하려면 작업 소유자로서 연결되어 있어야 합니다.
 | Filter jobs list - Browser Filters 창을 열고 개체 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Remove job - 선택한 작업을 삭제합니다. 이 명령을 수행하려면 작업 소유자로서 연결되어 있어야 합니다.

Details 패널

위쪽

위쪽 Details 패널에는 LOG, USER, NEXT DATE 및 INTERVALS와 같은 선택한 작업의 다양한 매개 변수가 표시됩니다.

아래쪽

아래쪽 Details 패널에는 선택한 작업에 사용된 SQL이 표시됩니다.

마우스 오른쪽 단추 메뉴

Jobs 패널에는 다음과 같은 명령이 포함된 사용자 정의 마우스 오른쪽 단추 메뉴가 있습니다.

  • Disable Job - 이 명령은 선택한 작업을 오프라인으로 만듭니다. 위 Take Offline을 참조하십시오.

  • Enable Job - 이 명령은 선택한 작업을 온라인으로 만듭니다. 위 Place Online을 참조하십시오.

  • Alter Job - Create New Job에서 설명한 대로 선택한 작업의 Job Definition 창을 표시하며 그 후 수정할 수 있습니다. 이 명령을 수행하려면 작업 소유자로서 연결되어 있어야 합니다.

  • Execute Job - 선택한 작업을 실행합니다. 이 명령을 수행하려면 작업 소유자로서 연결되어 있어야 합니다.

관련 항목

Create Job


창: Create Job

Create Job

Create Job 기능을 사용하여 작업을 작성 및 스케줄링할 수 있습니다. 이렇게 하여 표준 및 반복 작업을 자동화할 수 있습니다. 자세한 SQL 스크립트처럼 복잡하거나 하나의 운영 체제 명령을 실행하는 것처럼 간단할 수도 있습니다. 작업이 작성 및 스케줄링되면 나중에 Schema Browser|Jobs 페이지에서 조작할 수 있습니다.

작업을 작성하려면

  1. Create|Job…에서 Create Job 창을 액세스합니다.

또는

Schema Browser|Jobs 페이지에서 New Job 단추를 누릅니다.

  2. 제공된 필드에 해당하는 내용을 입력합니다.

  • Execute this job on: 필드에 작업을 실행할 날짜를 입력합니다.

  • At this time: 필드에 작업을 실행할 시간을 입력합니다.

  • 작업을 반복된 스케줄로 실행하려는 경우 간격을 입력합니다.

드롭다운 메뉴에서 이러한 예제를 선택할 수 있으며 해당 필드에 구문이 입력됩니다. 텍스트 필드와 마찬가지로 구문을 조정할 수 있습니다.

이러한 예제는 jobdates.txt 파일에 구성되며 텍스트 Editor를 사용하여 변경할 수 있습니다.

  3. Select Parse 또는 No Parse를 입력합니다.

  4. SQL을 입력하여 실행합니다.

  5. 아니면 Add to PM 확인란을 선택하여 Project Manager에 개체를 추가합니다.

  6. OK를 눌러 작업을 작성합니다. Job Number/Identifier가 작성됩니다.

예제

작업은 정기적 및 자동화 기준으로 실행할 모든 코드처럼 될 수 있습니다. 예를 들어, 날짜 열이 포함된 표가 있을 경우 이 코드를 사용하여 프로시저를 작성하고 ADD_DATE로 호출할 수 있습니다.

CREATE OR REPLACE PROCEDURE ADD_DATE;

BEGIN

INSERT INTO JSMITH.TEST1 (currentdate) VALUES (SYSDATE);

END ADD_DATE;

/

그런 다음, 매일 아침 표에 날짜를 삽입하려면 대화상자를 다음과 같이 설정합니다.

OK를 누르면 작업이 Job Number에 할당 및 작성됩니다. 이제 Schema Browser의 Jobs 탭에 나타나야 합니다.

관련 항목

Schema Browser 작업


Schema Browser: Libraries

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

라이브러리는 Oracle 8 이상을 사용하는 경우에만 사용할 수 있습니다.

라이브러리를 작성, 수정 또는 삭제할 수 있습니다. 세부 정보를 볼 수도 있습니다.

Objects 패널

Libraries 페이지에 있는 Objects 패널에서 라이브러리를 작성, 수정 및 삭제할 수 있습니다.

Library 도구 모음

단추 | 명령
 | Copy script to clipboard - 이 명령은 선택한 라이브러리에서 스크립트를 작성하고 클립보드에 복사합니다. 이 명령을 사용하려면 라이브러리를 하나 이상 선택해야 합니다. 그런 다음 스크립트를 Editor에 붙여넣을 수 있습니다.
 | Create library - 드롭다운 목록에서 스키마를 선택하고, 라이브러리 이름을 입력하고, 파일 이름을 입력할 수 있는 Library 창을 표시합니다. 자세한 내용은 Create Library 항목을 참조하십시오.
 | Alter library - 선택한 라이브러리의 Alter Library 창을 표시합니다.
 | 권한 보기/편집
 | Filter the library list - Browser Filters 창을 열고 개체 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Drop library - 선택한 라이브러리를 삭제합니다.

Details 패널

Details 패널 에는 선택한 라이브러리의 Info, Used by, Grants 및 Scripts 정보를 볼 수 있는 탭이 있습니다.

관련 항목

Create Library


창: Create Library

Create Library

주: 이 Toad 기능은 선택 사항인 Quest DBA Module과 함께 Toad의 상용 버전에서만 사용할 수 있습니다.

이 창에서 새 라이브러리 개체를 작성할 수 있습니다. 라이브러리 개체는 외부 함수를 호출하기 위해 SQL 또는 PL/SQL에서 사용할 수 있는 운영 체제 공유 라이브러리(.DLL)의 별칭입니다.

새 라이브러리 개체를 작성하려면

  1. Database|Create|Library 메뉴 항목을 선택합니다.

또는

Schema Browser|Libraries 페이지에서 Create new Library 단추를 누릅니다.

  2. 드롭다운에서 Schema를 선택합니다. 이 스키마는 라이브러리를 소유한 스키마가 됩니다.

  3. 텍스트 상자를 사용하여 라이브러리 Name(라이브러리 별칭 이름) 및 File Name을 입력합니다.

  4. 아니면 Add to PM 확인란을 선택하여 Project Manager에 개체를 추가합니다.

  5. Show SQL 단추를 누르면 SQL Statement 창이 표시되며, 여기서 Create Library 구문이 표시되고 Clipboard 단추를 사용하여 복사하거나 Save to File 단추를 눌러 저장할 수 있습니다.

관련 항목

라이브러리


Schema Browser: Scheduler

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

Oracle Scheduler는 Oracle 10g 이상에 포함되어 있습니다.

주의: Oracle Scheduler는 Oracle 10g의 새로운 기능입니다. 10g 이전의 클라이언트 버전을 사용하여 Oracle 10g 데이터베이스에 연결하는 경우에는 오류 및 실패가 발생할 수 있습니다.

Toad에서는 Schema Browser의 여러 새 페이지에 이 스케줄러를 사용합니다. 여기에는 다음 항목이 포함됩니다.

  • Jobs

  • Job Classes

  • Programs

  • Schedules

  • Windows

  • Window Groups

Oracle Scheduler에 대한 자세한 내용은 Oracle 관련 문서를 참조하십시오.


Scheduler: Jobs

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

작업은 특정 작업(task)을 수행할 시기를 정의한 것입니다. 10g 스케줄러에서 작업은 기본적인 세 가지 작업 부분을 다시 사용하기 때문에 비슷한 작업(task)을 매번 다시 작성할 필요가 없습니다. Oracle Scheduler 작업에 대한 자세한 내용은 Oracle 관련 문서를 참조하십시오.

Objects 패널

Schema Browser의 Objects 패널에 있는 Sched.Jobs 페이지에서 작업을 작성, 수정 및 삭제할 수 있습니다.

Sched:Jobs 도구 모음

Objects 패널에 있는 도구 모음에는 여러 옵션이 있습니다. 이러한 작업 중 일부에 대해 두 개 이상의 작업을 선택할 수 있습니다.

단추 | 명령
 | Create script from job - 이 명령은 선택한 작업에서 스크립트를 작성하고 클립보드에 복사합니다. 이 명령을 사용하려면 작업을 선택해야 합니다. 그런 다음 스크립트를 Procedure Editor 또는 Editor에 붙여넣을 수 있습니다.
 | Create new job - Job Definition 창을 표시합니다.
 | Alter job - 선택한 작업의 Job Definition 창을 표시합니다. 이 명령을 수행하려면 작업 소유자로서 연결되어 있어야 합니다.
 | Filter jobs list - Browser Filters 창을 열고 개체 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨간색으로 바뀝니다.
 | Remove job - 선택한 작업을 삭제합니다. 이 명령을 수행하려면 작업 소유자로서 연결되어 있어야 합니다.

Details 패널

Details 패널에는 선택한 작업의 세부 정보를 나열하는 Info 및 Scripts 탭이 있습니다.

관련 항목

스케줄러 작업 작성

스케줄러 작업 수정


스케줄러 작업 작성

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

스케줄러 작업을 작성하는 것은 이전에 작업을 작성하는 것만큼 쉽습니다.

스케줄러 작업을 작성하려면

  1. Schema Browser|Sched.Jobs 페이지|Objects Panel에서 New Job 단추를 누릅니다.

  2. 스키마 드롭다운에서 작업을 작성할 Schema를 선택합니다.

  3. Name 상자에 작업 이름을 입력합니다.

  4. 다음 세 개의 정보 탭에서 작업의 매개 변수를 선택합니다.

  5. Basic Info

  6. Schedule Info

  7. Program Info

  5. 선택적으로 Add to PM 확인란을 선택하면 Project Manager에 개체를 추가할 수 있습니다.

  6. 다음 중 하나를 누릅니다.

  7. Show SQL: 코드를 봅니다.

  8. Schedule: 나중에 실행하도록 예약합니다.

  9. OK: 작업을 작성합니다.

관련 항목

Schema Browser: Scheduler

Scheduler: Jobs

스케줄러 작업 수정

작업 기본 정보

작업 예약 정보

작업 프로그램 정보


스케줄러 작업 수정

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

이전에 작성한 Oracle 스케줄러 작업을 수정할 수 있습니다.

Oracle 스케줄러 작업을 수정하려면

  1. Schema Browser|Oracle Scheduler|Jobs 페이지에서 수정할 작업을 선택합니다.

  2. Alter Job [image] 단추를 누릅니다.

  3. 다음을 변경합니다.

  4. Basic Info

  5. Schedule Info

  6. Program Info

  4. 다음 중 하나를 누릅니다.

  5. Show SQL: 코드를 봅니다.

  6. Schedule: 나중에 실행하도록 예약합니다.

  7. OK: 작업을 수정합니다.

관련 항목

Schema Browser: Scheduler

Scheduler: Jobs

스케줄러 작업 작성

스케줄러 작업 수정

작업 기본 정보

작업 스케줄러 정보

작업 프로그램 정보


작업 기본 정보

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

Basic Info 탭에는 스케줄러 작업에 설정해야 할 일반 정보가 포함되어 있습니다.

Job Class

이 작업이 속할 클래스를 선택합니다. 기본값은 DEFAULT_JOB_CLASS입니다.

Schedule limit

예약 제한을 사용하면 작업을 다시 실행하기 전의 대기 시간을 제한할 수 있습니다.

Logging Level

로깅 수준은 기록할 작업 정보를 지정합니다.

Max Failures

허용되는 작업 실패 수를 지정합니다.

Max Runs

허용되는 작업 실행 수를 지정합니다.

Priority

Scheduler 내에서 실행 우선 순위를 선택할 수 있습니다. 우선 순위가 가장 높은 것은 1이고 가장 낮은 것은 5입니다. 기본값은 3입니다.

Enabled

선택하면 작업이 활성화되고 선택 취소하면 작업이 비활성화됩니다. 기본적으로 선택되어 있지 않습니다.

Auto Drop

이 상자를 선택하면 실행 후 작업을 삭제합니다. 반복되지 않는 작업에서만 사용할 수 있습니다. 기본적으로 선택되어 있지 않습니다.

Restartable

이 항목이 선택되어 있으면 작업이 실패한 경우 다시 시작됩니다. 선택되어 있지 않으면 작업이 실패한 경우 Oracle에서 다시 실행하려고 시도하지 않습니다. 기본적으로 선택됩니다.

Stop on window

이 항목을 선택했을 때 창 내에서 작업이 실행 중인 경우 창이 데이터베이스에서 삭제되면 작업이 즉시 중지됩니다. 이 항목을 지정하지 않으면 작업이 완료될 수 있습니다. 기본적으로 선택되어 있지 않습니다.

Comments

이 작업에 연결할 주석을 추가합니다.

관련 항목

Schema Browser: Scheduler

Scheduler: Jobs

스케줄러 작업 작성

스케줄러 작업 수정

작업 예약 정보

작업 프로그램 정보


작업 예약 정보

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

Schedule Info 탭을 사용하면 이 작업을 실행할 예약에 관한 정보를 지정할 수 있습니다. 미리 정의된 예약을 사용할 수도 있고 이 작업을 위해 특별히 예약을 지정할 수도 있습니다.

미리 정의된 예약을 입력하려면

  • 적절한 상자에 예약 소유자와 예약 이름을 입력합니다.

또는

드릴다운 [image] 단추를 눌러 예약을 선택합니다.

이 작업의 예약을 입력하려면

  • 적절한 상자에 시작 날짜, 끝 날짜, 반복 간격을 입력합니다. Oracle 특정 형식으로 입력해야 합니다.

주: Repeat Interval 상자 옆에 있는 Show Next 10 Run Times [image] 단추를 눌러 작업이 실행되는 다음 날짜 몇 개를 볼 수 있습니다.

관련 항목

Schema Browser: Scheduler

Scheduler: Jobs

스케줄러 작업 작성

스케줄러 작업 수정

작업 기본 정보

작업 프로그램 정보


작업 프로그램 정보

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

Program Info 탭을 사용하면 이 작업의 프로그램에 대한 정보를 지정할 수 있습니다. 미리 정의된 프로그램을 사용할 수도 있고 이 작업을 위해 특별히 예약을 지정할 수도 있습니다.

미리 정의된 프로그램을 입력하려면

  • 적절한 상자에 프로그램 소유자와 프로그램 이름을 입력합니다.

또는

드릴다운 [image] 단추를 눌러 프로그램을 선택합니다.

이 작업의 프로그램을 입력하려면

  1. Specify Program Info를 선택합니다.

  2. 프로그램 유형을 입력 또는 선택합니다.

  3. Program Action [image] 드릴다운을 누르고 What to Execute 대화 상자에서 원하는 옵션을 선택합니다.

  4. OK를 누릅니다.

관련 항목

Schema Browser: Scheduler

Scheduler: Jobs

스케줄러 작업 작성

스케줄러 작업 수정

작업 기본 정보

작업 예약 정보


스케줄러 작업 인수

작업 인수

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

선택한 프로그램에 필요한 인수를 입력합니다.

프로그램을 선택하면 인수 값을 쉽게 입력할 수 있도록 필요한 인수가 그리드를 채웁니다.

인수를 입력하려면

  • 인수의 Value 상자를 누르고 해당 인수의 값을 입력합니다.

관련 항목

Schema Browser: Scheduler

Scheduler: Jobs

스케줄러 작업 작성

스케줄러 작업 수정

작업 기본 정보

작업 예약 정보

작업 프로그램 정보


Scheduler: Job Classes

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

작업 클래스를 사용하여 비슷한 작업을 그룹으로 묶을 수 있습니다. 예를 들어 동시에 실행해야 하는 작업, 비슷한 작업(예: 데이터베이스 관리)을 수행하는 작업 등을 그룹으로 묶을 수 있습니다. 그러면 필요할 때 적절한 작업을 더 쉽게 찾을 수 있습니다.

Objects 패널

Schema Browser의 Objects 패널에 있는 Sched.Jobs Classes 페이지에서 작업 클래스를 작성, 수정 및 삭제할 수 있습니다.

Sched.Jobs Classes 도구 모음

Objects 패널에 있는 도구 모음에는 여러 옵션이 있습니다. 이러한 작업 중 일부에 대해 두 개 이상의 작업 클래스를 선택할 수 있습니다.

단추 | 명령
 | Create script from job class - 이 명령은 선택한 작업 클래스에서 스크립트를 작성하고 클립보드에 복사합니다. 이 명령을 사용하려면 작업 클래스를 선택해야 합니다. 그런 다음 스크립트를 Editor에 붙여넣을 수 있습니다.
 | Create new job class - Job Class Definition 창을 표시합니다.
 | Alter job class - 선택한 작업 클래스의 Job Class Definition 창을 표시하며 그 후 수정할 수 있습니다. 이 명령을 수행하려면 작업 클래스 소유자로서 연결되어 있어야 합니다.
 | Filter job class list - Browser Filters 창을 열고 개체 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨간색으로 바뀝니다.
 | Remove job class - 선택한 작업 클래스를 삭제합니다. 이 명령을 수행하려면 작업 클래스 소유자로서 연결되어 있어야 합니다.

Details 패널

Details 패널에는선택한 작업 클래스의 정보와 관련 스크립트를 볼 수 있는 탭이 있습니다.

관련 항목

스케줄러 작업 클래스 작성

스케줄러 작업 클래스 수정


스케줄러 작업 클래스 작성

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

스케줄러 작업 클래스를 작성하는 일은 쉽습니다.

스케줄러 작업 클래스를 작성하려면

  1. Schema Browser|Sched.Job Class page|Objects Panel에서 New Job Class [image] 단추를 누릅니다.

  2. Job Class Name 상자에 작업 이름을 입력합니다.

  3. 작업 클래스를 연결할 자원 소비자 그룹을 선택합니다.

  4. 원하는 경우 Service 상자에 작업 클래스가 속하는 서비스를 입력합니다.

  5. Log History 상자에서 로그를 보존할 일 수를 선택합니다. 기본값은 30입니다.

  6. Logging Level 드롭다운에서 로깅 수준을 선택합니다. 다음 중에서 선택합니다.

  7. Runs - 이 작업 클래스의 각 실행에 대해 세부 정보를 기록합니다.

  8. Off - 기록 안 함

  9. Full - 클래스의 모든 작업에서 수행되는 각 실행 및 모든 작업을 기록합니다. 작성, 활성화, 비활성화, 수정 등이 수행된 작업을 기록합니다.

  7. 이 작업 클래스와 연결할 주석을 입력합니다. 기본적으로 이 매개 변수는 NULL로 남습니다.

  8. 선택적으로 Add to PM 확인란을 선택하면 Project Manager에 개체를 추가할 수 있습니다.

  9. OK를 누릅니다.

주: SQL을 표시하여(Show SQL 누름) 작업 클래스를 작성할 수도 있고 이 작업을 나중에 수행하도록 선택할 수도 있습니다(Schedule 누름).

관련 항목

Scheduler: Job Classes

스케줄러 작업 클래스 수정


스케줄러 작업 클래스 수정

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

스케줄러 작업 클래스를 수정하는 것은 쉬운 절차입니다.

스케줄러 작업 클래스를 수정하려면

  1. Schema Browser|Sched.Job Class 페이지|Objects Panel에서 Objects 목록에 있는 작업 클래스를 선택한 후 Alter Job Class [image] 단추를 누릅니다.

  2. 작업 클래스의 매개 변수를 변경합니다.

  3. OK를 누릅니다.

주: SQL을 표시하여(Show SQL 누름) 작업 클래스를 작성할 수도 있고 이 작업을 나중에 수행하도록 선택할 수도 있습니다(Schedule 누름).

관련 항목

Scheduler: Job Classes

스케줄러 작업 클래스 작성


Scheduler: Programs

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

Oracle Scheduler에서 프로그램은 무엇이 실행되는지를 정의합니다. 여기에는 스케줄러에서 실행할 대상에 대한 정보가 있습니다. 프로그램 이름, 프로그램 작업(예: 프로시저 또는 실행 파일 이름), 프로그램 유형(PL/SQL 저장된 프로시저, 익명 블록 또는 OS 실행 파일) 및 실행에 필요한 인수의 수 등이 여기에 포함됩니다.

프로그램은 작업과 별개입니다. 작업에 프로그램이 포함될 수 있으며, 여러 작업에서 같은 프로그램을 사용할 수도 있습니다. 적절한 권한이 있으면 여러 사용자가 같은 프로그램을 다시 정의할 필요 없이 사용할 수도 있습니다.

Oracle Scheduler 프로그램에 대한 자세한 내용은 Oracle 관련 문서를 참조하십시오.

Objects 패널

Schema Browser의 Objects 패널에 있는 Sched.Programs 페이지에서 프로그램을 작성, 수정 및 삭제할 수 있습니다.

Programs 도구 모음

Objects 패널에 있는 도구 모음에는 여러 옵션이 있습니다. 이러한 작업 중 일부에 대해 두 개 이상의 프로그램을 선택할 수 있습니다.

단추 | 명령
 | Create script from program - 이 명령은 선택한 프로그램에서 스크립트를 작성하고 클립보드에 복사합니다. 이 명령을 사용하려면 프로그램을 선택해야 합니다. 그런 다음 스크립트를 Editor에 붙여넣을 수 있습니다.
 | Create new program - Program Definition 창을 표시합니다.
 | Alter program - 선택한 프로그램의 Program Definition 창을 표시하며 그 후 수정할 수 있습니다. 이 명령을 수행하려면 프로그램 소유자로서 연결되어 있어야 합니다.
 | Filter program list - Browser Filters 창을 열고 개체 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Remove program - 선택한 프로그램을 삭제합니다. 이 명령을 수행하려면 프로그램 소유자로서 연결되어 있어야 합니다.

Details 패널

Details 패널에는 선택한 프로그램에 대한 정보와 프로그램에 연결된 스크립트를 나열하는 Info 및 Script 탭이 있습니다.

관련 항목

스케줄러 프로그램 작성

프로그램 기본 정보

프로그램 인수

프로그램 주석


스케줄러 프로그램 작성

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

스케줄러의 프로그램을 손쉽게 작성할 수 있습니다. 그 후 이 프로그램은 프로그램 라이브러리에서 관리하며 올바른 권한이 있는 여러 사용자가 사용할 수 있습니다.

스케줄러 프로그램을 작성하려면

  1. Schema Browser|Sched. Programs 페이지에서 New Program [image] 단추를 누릅니다.

  2. Schema 드롭다운 상자에서 새 프로그램을 소유할 스키마를 선택합니다.

  3. Name 상자에 프로그램의 이름을 입력합니다.

  4. 적절한 Basic Info를 선택합니다.

  5. 적절한 Arguments를 선택합니다.

  6. 필요한 경우 Comments를 추가합니다.

  7. 선택적으로 Add to PM 확인란을 선택하면 Project Manager에 개체를 추가할 수 있습니다.

  8. 다음 중 하나를 누릅니다.

  9. Show SQL: 코드를 봅니다.

  10. Schedule: 나중에 실행하도록 예약합니다.

  11. OK: 예약을 작성합니다.

관련 항목

Scheduler: Programs

프로그램 기본 정보

프로그램 인수

프로그램 주석


스케줄러 프로그램 수정

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

이전에 작성한 Oracle 스케줄러 작업을 수정할 수 있습니다.

Oracle 스케줄러 프로그램을 수정하려면

  1. Schema Browser|Oracle Scheduler|Programs 페이지에서 수정할 프로그램을 선택합니다.

  2. Alter Program [image] 단추를 누릅니다.

  3. 다음을 변경합니다.

  4. Basic Info

  5. Arguments

  6. Comment

  4. 다음 중 하나를 누릅니다.

  5. Show SQL: 코드를 봅니다.

  6. Schedule: 나중에 실행하도록 예약합니다.

  7. OK: 프로그램을 수정합니다.

관련 항목

Scheduler: Programs

스케줄러 프로그램 작성

프로그램 기본 정보

프로그램 인수

프로그램 주석


Schd.프로그램 기본 정보

프로그램 기본 정보

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

프로그램을 지정하는 경우에는 몇 가지 기본적인 사항을 선택할 수 있습니다.

Program Type

Program Type은 다음 세 가지 코드 유형 중 하나일 수 있습니다.

  • PL/SQL Block

  • Stored Procedure

  • Executable

Program Action

Stored Procedure를 선택한 경우에는 실행할 개체를 선택해야 합니다. 프로시저나 패키지를 선택할 수 있습니다.

실행할 개체를 선택하려면

  1. Create New Program 창의 Program Type 상자에서 Stored Procedure를 선택합니다.

  2. Program Action [image] 단추를 누릅니다.

  3. What to execute 대화 상자에서 다음을 선택합니다.

  4. 개체 유형

  5. 개체 유형이 있는 스키마

  6. 개체 이름

  7. 필요한 경우 하위 개체

  4. OK를 누릅니다.

Enabled 확인란

이 확인란을 선택하거나 선택 취소하면 프로그램을 활성화 또는 비활성화할 수 있습니다. Oracle Scheduler 프로그램은 기본적으로 비활성화된 상태로 작성됩니다. 이 옵션을 사용하면 작성 후에 활성화하는 단계를 생략할 수 있습니다.

관련 항목

Scheduler: Programs

스케줄러 프로그램 작성

프로그램 인수

프로그램 주석


프로그램 인수

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

기본 정보를 입력한 후에 작성한 프로그램을 실행하려면 인수가 필요한 경우, 여기에 인수가 나열됩니다.

이러한 인수는 Editor에서와 마찬가지로 그리드 형식으로 표시됩니다. 자세한 내용은 Debugger: 매개 변수 설정을 참조하십시오.

인수를 설정하려면

  1. Create Program 또는 Alter Program 창에서 Arguments 탭을 누릅니다.

  2. 그리드에서 적절한 상자에 필요한 인수를 입력합니다.

  3. 다른 탭 중 하나를 눌러 추가 정보를 입력합니다.

또는

OK를 눌러 프로그램을 작성합니다.

관련 항목

매개 변수 설정

Scheduler: Programs

스케줄러 프로그램 작성

프로그램 기본 정보

프로그램 주석


프로그램 주석

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

프로그램과 함께 저장될 주석을 입력할 수 있습니다.

Oracle에서는 이 필드에 240자 제한이 있습니다.

관련 항목

Scheduler: Programs

스케줄러 프로그램 작성

프로그램 기본 정보

프로그램 인수


Scheduler: Schedules

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

예약은 작업을 수행하는 시기와 방법을 정의합니다. 여러 프로그램에 같은 예약을 사용할 수 있습니다.

Objects 패널

Schema Browser의 Objects 패널에 있는 Sched.Schedules 페이지에서 예약을 작성, 수정 및 삭제할 수 있습니다.

Schedules 도구 모음

Objects 패널에 있는 도구 모음에는 여러 옵션이 있습니다. 이러한 작업 중 일부에 대해 두 개 이상의 예약을 선택할 수 있습니다.

단추 | 명령
 | Create script from schedule - 이 명령은 선택한 예약에서 스크립트를 작성하고 클립보드에 복사합니다. 이 명령을 사용하려면 예약을 선택해야 합니다. 그런 다음 스크립트를 Editor에 붙여넣을 수 있습니다.
 | Create new schedule - Schedule Definition 창을 표시합니다.
 | Alter schedule - 선택한 예약의 Schedule Definition 창을 표시하며 그 후 수정할 수 있습니다. 이 명령을 수행하려면 예약 소유자로서 연결되어 있어야 합니다.
 | Filter schedule list - Browser Filters 창을 열고 개체 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Remove schedule - 선택한 예약을 삭제합니다. 이 명령을 수행하려면 예약 소유자로서 연결되어 있어야 합니다.

Details 패널

Details 패널에는 선택한 예약에 대한 정보와 예약을 정의하는 스크립트를 나열하는 Info 및 Scripts 탭이 있습니다.

관련 항목

스케줄러 예약 작성

스케줄러 예약 수정


스케줄러 예약 작성

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

예약을 손쉽게 작성할 수 있습니다.

예약을 작성하려면

  1. Schema Browser|Sched.Schedule 페이지의 Objects Panel에서 Create New Schedule [image] 단추를 누릅니다.

  2. 예약을 넣을 schema를 선택합니다.

  3. name 상자에 예약 이름을 입력합니다.

  4. 적절한 상자에 시작 날짜, 끝 날짜, 반복 간격을 입력합니다. 이러한 선택의 적절한 형식에 대해서는 Oracle 관련 문서를 참조하십시오.

  5. Comment 상자에 주석을 입력합니다. Oracle에서는 주석에 240자 제한이 있습니다.

  6. 선택적으로 Add to PM 확인란을 선택하면 Project Manager에 개체를 추가할 수 있습니다.

  7. 다음 중 하나를 누릅니다.

  8. Show SQL: 코드를 봅니다.

  9. Schedule: 나중에 실행하도록 예약합니다.

  10. OK: 예약을 작성합니다.

관련 항목

Scheduler: Schedules

스케줄러 예약 작성

스케줄러 예약 수정


스케줄러 예약 수정

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

예약을 쉽게 수정할 수 있습니다.

예약을 수정하려면

  1. Schema Browser|Sched.Schedule 페이지의 Objects Panel에서 Alter New Schedule [image] 단추를 누릅니다.

  2. 예약 매개 변수를 변경합니다.

  3. 다음 중 하나를 누릅니다.

  4. Show SQL: 코드를 봅니다.

  5. Schedule: 나중에 실행하도록 예약합니다.

  6. OK: 예약을 수정합니다.

관련 항목

Scheduler: Schedules

스케줄러 예약 작성


Scheduler: Windows

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

스케줄러에서 창이라는 말은 컴퓨터 모니터 상의 화면보다는 시간을 나타내는 말로 사용됩니다. 피크 시간을 정의하고 해당 시간의 데이터베이스 활동을 기준으로 작업을 예약할 수 있습니다. Oracle Scheduler 창에 대한 자세한 내용은 Oracle 관련 문서를 참조하십시오.

Objects 패널

Schema Browser의 Objects 패널에 있는 Sched.Windows 페이지에서 창을 작성, 수정 및 삭제할 수 있습니다.

Windows 도구 모음

Objects 패널에 있는 도구 모음에는 여러 옵션이 있습니다. 이러한 작업 중 일부에 대해 두 개 이상의 창을 선택할 수 있습니다.

단추 | 명령
 | Create script from window - 이 명령은 선택한 창에서 스크립트를 작성하고 클립보드에 복사합니다. 이 명령을 사용하려면 창을 선택해야 합니다. 그런 다음 스크립트를 Editor에 붙여넣을 수 있습니다.
 | Create new window - Window Definition 화면을 표시합니다.
 | Alter window - Create Window에서 설명한 대로 선택한 창의 Window Definition 창을 표시하며 그 후 수정할 수 있습니다. 이 명령을 수행하려면 창 소유자로서 연결되어 있어야 합니다.
 | Filter window list - Browser Filters 창을 열고 개체 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨간색으로 바뀝니다.
 | Remove window - 선택한 창을 삭제합니다. 이 명령을 수행하려면 창 소유자로서 연결되어 있어야 합니다.

Details 패널

Details 패널에는 선택한 창에 대한 정보와 창을 정의하는 스크립트를 나열하는 Info 및 Scripts탭이 있습니다.

관련 항목

스케줄러 창 작성

스케줄러 창 수정

창 기본 정보

창 예약 정보


스케줄러 창 작성

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

스케줄러 창을 작성하려면

  1. Schema Browser|Sched.Window 페이지의 Objects Panel에서 Create New Scheduler Window [image] 단추를 누릅니다.

  2. Name 상자에 창의 이름을 입력합니다.

  3. 다음 두 개의 정보 탭에서 작업의 매개 변수를 선택합니다.

  4. Basic Info

  5. Schedule Info

  4. 선택적으로 Add to PM 확인란을 선택하면 Project Manager에 개체를 추가할 수 있습니다.

  5. 다음 중 하나를 누릅니다.

  6. Show SQL: 코드를 봅니다.

  7. Schedule: 나중에 실행하도록 예약합니다.

  8. OK: 예약을 작성합니다.

관련 항목

Scheduler: Windows

스케줄러 창 수정

창 기본 정보

창 예약 정보


스케줄러 창 수정

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

스케줄러 창을 작성하려면

  1. Schema Browser|Sched.Window 페이지의 Objects Panel에서 Alter New Scheduler Window [image] 단추를 누릅니다.

  2. 다음 두 개의 정보 탭에서 작업의 매개 변수를 변경합니다.

  3. Basic Info

  4. Schedule Info

  4. 다음 중 하나를 누릅니다.

  5. Show SQL: 코드를 봅니다.

  6. Schedule: 나중에 실행하도록 예약합니다.

  7. OK: 예약을 작성합니다.

관련 항목

Scheduler: Windows

스케줄러 창 작성

창 기본 정보

창 예약 정보


Schd.창 기본 정보

창 기본 정보

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

Basic Information 탭에는 스케줄러 창에 설정해야 할 일반 정보가 포함되어 있습니다.

Resource Plan

자원 계획을 선택합니다. 자원 계획을 사용하면 작성된 창이 지속되는 동안 작업 클래스 사이에 자원를 할당하는 방법을 지정할 수 있습니다.

Duration

창이 열려 있는 시간을 지정합니다. 이 특성에는 기본값이 없습니다. 오류를 방지하려면 기간을 지정해야 합니다.

다음 형식을 사용합니다.

Interval 'n' type

예를 들어 interval '5' hour는 다섯 시간을 지정하고, interval '6' minutes는 6분을 지정합니다.

기간 간격 범위는 1분에서 99일까지입니다.

Window Priority

이 매개 변수는 두 창이 겹치는 경우에만 관련됩니다. 한 번에 한 개의 창에만 적용될 수 있으며 Oracle에서는 창 우선 순위를 사용하여 적용할 창을 결정합니다.

high와 low 우선 순위 중에서 선택할 수 있습니다. 기본값은 low입니다.

Enabled

선택하면 창을 활성화 또는 비활성화할 수 있습니다.

Active

이 항목을 선택하면 작성 즉시 창이 활성화됩니다. 기본적으로 선택되어 있지 않습니다.

Comment

창에 연결할 주석을 입력합니다.

관련 항목

Scheduler: Windows

스케줄러 창 작성

스케줄러 창 수정

창 예약 정보


Schd.창 예약 정보

창 예약 정보

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

Schedule Info 탭을 사용하면 이 작업을 실행할 예약에 관한 정보를 지정할 수 있습니다. 미리 정의된 예약을 사용할 수도 있고 이 작업을 위해 특별히 예약을 지정할 수도 있습니다.

미리 정의된 예약을 입력하려면

  • 적절한 상자에 예약 소유자와 예약 이름을 입력합니다.

또는

드릴다운 [image] 단추를 눌러 예약을 선택합니다.

이 작업의 예약을 입력하려면

  • 적절한 상자에 시작 날짜, 끝 날짜, 반복 간격을 입력합니다. Oracle 특정 형식으로 입력해야 합니다.

관련 항목

Scheduler: Windows

스케줄러 창 작성

스케줄러 창 수정

창 기본 정보


Scheduler: Window Groups

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

비슷한 창을 창 그룹으로 묶으면 작업과 예약을 더 쉽게 관리할 수 있습니다. Oracle Scheduler 창에 대한 자세한 내용은 Oracle 관련 문서를 참조하십시오.

Objects 패널

Schema Browser의 Objects 패널에 있는 Sched.Window Group 페이지에서 창 그룹을 작성, 수정 및 삭제할 수 있습니다.

Window Groups 도구 모음

Objects 패널에 있는 도구 모음에는 여러 옵션이 있습니다. 이러한 작업 중 일부에 대해 두 개 이상의 창 그룹을 선택할 수 있습니다.

단추 | 명령
 | Create script from window group - 이 명령은 선택한 창 그룹에서 스크립트를 작성하고 클립보드에 복사합니다. 이 명령을 사용하려면 창 그룹을 선택해야 합니다. 그런 다음 스크립트를 Editor에 붙여넣을 수 있습니다.
 | Create new window group - Window Group Definition 화면을 표시합니다.
 | Alter window group - Create window group에서 설명한 대로 선택한 창 그룹의 Window Group Definition 창을 표시하며 그 후 수정할 수 있습니다. 이 명령을 수행하려면 창 그룹 소유자로서 연결되어 있어야 합니다.
 | Filter window group list - Browser Filters 창을 열고 개체 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨간색으로 바뀝니다.
 | Remove window group - 선택한 창 그룹을 삭제합니다. 이 명령을 수행하려면 창 그룹 소유자로서 연결되어 있어야 합니다.

Details 패널

Details 패널에는 선택한 창 그룹에 대한 정보와 창 그룹을 정의하는 스크립트를 나열하는 Info 및 Scripts 탭이 있습니다.

관련 항목

스케줄러 창 그룹 작성

스케줄러 창 그룹 수정

창 그룹 기본 정보

Window Groups Member Windows


스케줄러 창 그룹 작성

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

스케줄러 창 그룹을 작성하려면

  1. Schema Browser|Sched.Window Group 페이지의 Objects Panel에서 Create New Scheduler Window Group [image] 단추를 누릅니다.

  2. Name 상자에 창의 이름을 입력합니다.

  3. 다음 두 개의 정보 탭에서 작업의 매개 변수를 선택합니다.

  4. Basic Info

  5. Member Windows

  4. 선택적으로 Add to PM 확인란을 선택하면 Project Manager에 개체를 추가할 수 있습니다.

  5. 다음 중 하나를 누릅니다.

  6. Show SQL: 코드를 봅니다.

  7. Schedule: 나중에 실행하도록 예약합니다.

  8. OK: 창 그룹을 작성합니다.

관련 항목

Scheduler: Window Groups

스케줄러 창 그룹 수정

창 그룹 기본 정보

Window Groups Member Windows


스케줄러 창 그룹 수정

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

스케줄러 창을 작성하려면

  1. Schema Browser|Sched.Window 페이지의 Objects Panel에서 Alter New Scheduler Window [image] 단추를 누릅니다.

  2. 다음 두 개의 정보 탭에서 작업의 매개 변수를 변경합니다.

  3. Basic Info

  4. Member Windows

  4. 다음 중 하나를 누릅니다.

  5. Show SQL: 코드를 봅니다.

  6. Schedule: 나중에 실행하도록 예약합니다.

  7. OK: 예약을 작성합니다.

관련 항목

Scheduler: Window Groups

스케줄러 창 그룹 작성

창 그룹 기본 정보

Window Groups Member Windows


창 그룹 기본 정보

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

Basic Info 페이지에는 작성하는 창 그룹에 대한 정보가 포함되어 있습니다.

Enabled

창 그룹을 작성한 후에 즉시 활성화하려면 Enabled 확인란을 선택합니다. 이 확인란을 선택하지 않으면 비활성화된 상태로 작성됩니다. 기본적으로 선택되어 있지 않습니다.

# of Windows

창 그룹에 포함된 창의 수를 표시합니다. Member Window 페이지에 창을 추가할 때까지는 숫자가 나열되지 않습니다.

Comments

창 그룹에 대한 주석을 입력합니다.

관련 항목

Scheduler: Window Groups

스케줄러 창 그룹 작성

스케줄러 창 그룹 수정

Window Groups Member Windows


Window Group Member Windows

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 Toad에서만 사용할 수 있습니다.

이 페이지를 사용하여 창 그룹에서 구성원 창을 추가 및 제거할 수 있습니다.

구성원 창을 추가하려면

  1. Add Window를 누릅니다.

  2. Windows 그리드에서 추가할 창을 선택합니다.

  3. OK를 누릅니다.

창 그룹에서 창을 제거하려면

  1. 삭제할 창을 선택합니다.

  2. Delete Selected Windows를 누릅니다.

  3. OK를 누릅니다.

관련 항목

Scheduler: Window Groups

스케줄러 창 그룹 작성

스케줄러 창 그룹 수정

창 그룹 기본 정보


Schema Browser: Policies

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

정책은 Oracle 8i 이상을 사용하는 경우에만 사용할 수 있습니다.

정책을 작성, 활성화, 비활성화, 편집 및 삭제할 수 있습니다. 또한 정책 세부 정보를 볼 수 있습니다. Create Policy Definition 항목을 참조하십시오.

Objects 패널

Objects 패널에는 선택한 스키마의 정책이 나열됩니다. 서술 패키지 소스를 작성, 활성화, 비활성화, 편집하고 정책을 삭제할 수 있습니다.

Policy 도구 모음

단추 | 명령
 | Create New Policy - 정책 이름의 상자가 있는 Policy Definition 창을 표시합니다. 또한 여기에는 Schema, Table/View, Schema Containing Predicate Package 및 Predicate Function 드롭다운이 있습니다.
 | Enable Policy - 선택한 정책이 비활성화되어 있으면 이 단추가 활성화됩니다. 선택한 정책을 활성화합니다.
 | Disable Policy - 선택한 정책이 활성화되어 있으면 이 단추가 활성화됩니다. 선택한 정책을 비활성화합니다. 비활성화된 정책은 개체 목록에서 앞에 빨간색 X가 표시됩니다.
 | 정책 새로 고침
 | Edit Policy Predicate Package Source - 선택한 정책의 서술 패키지 소스를 Editor에서 편집할 수 있습니다.
 | Filter Policies - Browser Filters 창을 열고 Policies 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨간색으로 바뀝니다.
 | Drop Policy - 선택한 정책을 삭제합니다.

Details 패널

Details 패널에는 Name, Predicate Package, Predicate Function과 같은 선택한 정책의 다양한 매개 변수와 값이 표시됩니다.

관련 항목

Create Policy Definition

Policy Groups

Create Policy Group


정책 정의 작성

주: 이 기능은 새로운 Toad 기능(선택 사항)이므로 선택 사항인 Quest DBA Module과 함께 Toad의 상용 버전에서만 사용할 수 있습니다.

이 창에서 DBMS_RLS 패키지를 통해 새 정책을 작성합니다. DBMS_RLS가 없을 경우 Toad에서 이 기능을 사용할 수 없습니다. 자세한 내용은 Oracle 관련 문서를 참조하십시오.

새 정책 정의를 작성하려면

  1. Schema Browser|Policies 페이지에서 Create new policy 단추를 누릅니다.

또는

Create 메뉴에서 Policy를 선택합니다.

  2. 이름 필드에 새 정책의 이름을 입력합니다.

  3. 표 또는 보기를 찾을 위치에서 스키마를 선택합니다.

  4. Tables 또는 Views 옵션을 선택한 다음 Table/View 필드에서 포함할 표 또는 보기를 선택합니다.

  5. Schema containing the predicate package, Predicate Package 및 Predicate Function을 선택합니다.

  6. 구문 형식을 선택합니다. Select, Insert, Update, Delete(10g 데이터베이스에 연결될 경우 Index도 사용 가능).

  7. Another 확인란에서 Enable the Policy at Creation을 선택할 수 있습니다.

  8. Oracle 10g 이상의 버전을 사용할 경우

Security Relevant Columns 탭을 눌러 sec_relevant_cols 절에 포함하거나 sec_relevant_cols_opt 절을 설정할 열을 선택합니다.

  9. 아니면 Add to PM 확인란을 선택하여 Project Manager에 개체를 추가합니다.

  10. Execute를 눌러 정책 그룹 정의를 작성합니다.

관련 항목

정책

정책 그룹

정책 그룹 작성


Schema Browser: Policy Groups

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

정책 그룹은 테이블에 두 개 이상의 보안 정책을 적용하는 수단입니다. 자세한 내용은 Oracle 관련 문서를 참조하십시오. 정책 그룹은 Oracle 9i 이상을 사용하는 경우에만 사용할 수 있습니다.

정책 그룹을 작성 및 삭제할 수 있습니다. 정책 세부 정보를 볼 수도 있습니다.

Objects 패널

Objects 패널에는 선택한 스키마의 정책 그룹이 나열됩니다.

Policy 도구 모음

단추 | 명령
 | Copy Script to Clipboard - SQL 스크립트를 작성하고 클립보드에 복사합니다.
 | Create New Policy group - 새 정책 그룹을 정의할 수 있는 Policy Group Definition 창을 표시합니다.
 | Filter Policy Groups - Browser Filters 창을 열고 Policy Group 목록을 필터링할 수 있게 해 줍니다. 필터가 사용 중이면 아이콘이 빨간색으로 바뀝니다.
 | Drop Policy Group - 선택한 정책 그룹을 삭제합니다.

Details 패널

Details 패널에는 다양한 매개 변수와 선택한 정책 그룹의 값이 Info, Policies and Objects 및 Script의 세 탭으로 구성되어 표시됩니다.

관련 항목

Policies

Create Policy Definition

Create Policy Group


Create Policy Group

주: 이 기능은 새로운 Toad 기능(선택 사항)이기 때문에 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

이 창을 사용하면 DBMS_RLS 패키지를 통해 새 정책 그룹을 작성할 수 있습니다. DBMS_RLS가 없는 경우에는 Toad에서 이 기능을 사용할 수 없습니다. 자세한 내용은 Oracle 관련 문서를 참조하십시오.

정책 그룹을 작성하려면

  1. 다음 중 한 가지 방법을 사용하여 Policy Group Definition 창에 액세스합니다.

  2. Database|Create 메뉴에서 Policy Group을 선택합니다.

  3. Schema Browser|Policy Group 페이지에서 New Policy Group [image] 단추를 누릅니다.

  2. name 상자에 새 정책 그룹의 이름을 입력합니다.

  3. 테이블 또는 보기를 넣을 Schema를 선택합니다.

  4. Tables 또는 Views 옵션을 선택한 후 Table/View 상자에서 포함할 테이블 또는 보기를 선택합니다.

  5. 선택적으로 Add to PM 확인란을 선택하면 Project Manager에 개체를 추가할 수 있습니다.

  6. Execute를 눌러 정책 그룹 정의를 작성합니다.

관련 항목

Policies

Create Policy Definition

Policy Groups


Schema Browser: Procs

Objects 패널

Procedures 페이지 Objects 패널에는 PL/SQL 프로시저, 패키지 또는 함수가 나열됩니다. 함수와 패키지에는 별도의 탭이 있습니다. Editor에서 열어 실행하거나 컴파일하거나 파일에 저장할 수 있습니다.

프로시저, 패키지 또는 함수의 여러 유형과 상태는 다양한 아이콘으로 구분됩니다. 자세한 내용은 Icon Legend를 참조하십시오.

Procedures 팝업 메뉴에서 사용할 수 있는 세부 명령도 있습니다.

Procedures 도구 모음

단추

명령

Copy script to clipboard

Save to a SQL file - 선택한 프로시저를 파일에 저장하려면 이 옵션을 누릅니다(이 파일의 확장명은 View|Toad Options|File-General에서 구성). Save as 대화 상자가 나타납니다. 파일에 이름을 지정하고 저장할 수 있습니다.

Open in Procedure Editor - 이 명령을 사용하려면 먼저 프로시저, 패키지 또는 함수를 선택해야 합니다. 그런 다음 도구 모음에 있는 아이콘을 누릅니다. 선택한 개체가 새 Editor 창에 복사되며 이 창에서 개체를 디버깅하거나 개체에 대한 작업을 수행할 수 있습니다.

Compile Selected Procedure - Schema Browser에서 프로시저, 패키지 또는 함수를 다시 컴파일할 수 있습니다. 다시 컴파일할 개체를 선택하고 도구 모음에서 Compile Procedure를 누릅니다. 개체가 컴파일됩니다. 잘못된 개체(빨강색 X로 표시)가 올바르게 컴파일이 되면 유효함으로 표시가 변경되며 개체 이름 옆에 더 이상 X가 나타나지 않습니다. 또한, 이 단추의 드롭다운에서 패키지 스펙, 본문 또는 둘 모두를 선택하여 컴파일할 수 있습니다.

Compile Procedures - Compile All 단추는 현재 스키마의 모든 프로시저, 함수, 패키지 및 트리거를 컴파일합니다. 8.1.7 이전의 데이터베이스에서는 잘못된 개체만 컴파일합니다.

잘못된 모든 프로시저, 패키지 또는 함수를 따로 선택하지 않고 한꺼번에 컴파일할 수 있습니다. 도구 모음에서 Compile all을 누르면 필터를 사용하여 숨긴 항목을 포함하여 개체 목록에 있는 모든 잘못된 항목이 컴파일됩니다.

주: 목록에 있는 항목의 수에 따라 이 옵션에서 시간이 오래 걸릴 수 있습니다.

Filter Procedure list - 개체 목록을 필터링할 수 있는 Browser Filters 창이 열립니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.

Compile Dependent Procedures - 선택한 프로시저, 패키지 또는 함수에서 종속 프로시저, 패키지 또는 함수를 컴파일할 수 있습니다. 프로시저, 패키지 또는 함수를 선택한 후 도구 모음에서 Compile Dependent Procedures 아이콘을 누릅니다. 선택한 프로시저, 패키지 또는 함수에 종속된 모든 프로시저, 패키지 또는 함수가 다시 컴파일됩니다. 종속 프로시저, 패키지 또는 함수의 컴파일에 대한 자세한 내용은 종속 관계를 참조하십시오.

Execute Procedure - Schema Browser에서 프로시저, 패키지 또는 함수를 실행하려면 해당 항목을 선택하고 Execute를 누릅니다. 매개 변수가 필요한 경우에는 Toad에서 매개 변수를 입력하라는 메시지가 표시되며 여기에 응답하면 프로시저, 패키지 또는 함수가 실행됩니다.

주: Debugger에서는 프로시저, 패키지 또는 함수를 호출하면서 실행을 중지할 수도 있기 때문에(중단점 설정을 통해) 이 단추를 Run이라고 합니다.

Add or change privileges - Privileges 창이 표시됩니다.

사용자 목록에서 CTRL 단추를 누른 상태에서 여러 사용자 이름을 누르면 여러 항목을 선택할 수 있습니다.

권한을 추가 또는 해지하려면 권한을 부여할 사용자를 선택한 후 마우스 오른쪽 단추를 누르고 마우스 오른쪽 단추 메뉴에서 Grant, Grant - with Admin 또는 Revoke 중 적절한 항목을 선택합니다. Apply 를 누릅니다.

Revoke All을 누르면 모든 권한을 해지할 수 있습니다.

Make Synonym - 프로시저, 패키지 또는 함수를 선택하고 이 아이콘을 눌러 선택한 항목의 동의어를 작성합니다. 이 기본값은 공개 동의어 작성입니다.

Drop procedure - 프로시저, 패키지 또는 함수를 선택하고 Drop을 누릅니다. Toad에서 확인 메시지를 표시하고 선택한 프로시저, 패키지 또는 함수가 데이터베이스에서 삭제됩니다.

Details 패널

Details 패널에는 선택한 프로시저, 패키지 또는 함수에 대한 정보를 볼 수 있는 탭이 포함되어 있습니다. 다음과 같은 탭이 있습니다. Code, Arguments, Deps(Uses), Deps(Used by), Errors 및 Grants

Objects 패널에서 프로시저, 패키지 또는 함수를 선택하면 Details 패널 맨 위에 개체의 만든 날짜와 마지막으로 수정한 날짜가 표시됩니다. 개체가 패키지인 경우에는 스펙과 본문 정보가 포함됩니다.

관련 항목

Procs: 팝업 메뉴

새 프로시저 작성

저장된 프로시저 호출


프로시저: 팝업 메뉴

마우스 오른쪽 단추 메뉴

Objects 패널에서 개체를 선택한 다음 Objects 패널 또는 Details 패널을 마우스 오른쪽 단추로 누릅니다.

Save to file

Save as 대화 상자를 표시하려면 Save to file을 선택합니다. 이 대화 상자에서 프로시저, 함수 또는 트리거를 지정한 파일에 저장합니다.

Compile

프로시저, 함수 또는 트리거를 컴파일하려면 Compile을 선택합니다. 이 옵션은 유효하지 않은 프로시저를 컴파일하는 데 유용합니다.

Compile Dependencies

선택한 프로시저, 함수 또는 패키지에서 종속 프로시저를 컴파일할 수 있습니다. 프로시저를 선택한 다음 도구 모음에서 Compile Dependent Procedures 아이콘을 누릅니다. 선택한 프로시저에 종속하는 모든 프로시저가 다시 컴파일됩니다. 종속 프로시저 컴파일에 대한 자세한 내용은 종속 관계를 참조하십시오.

Load in Editor

선택한 프로시저에 대한 SQL을 Editor에 로드하려면 이 옵션을 선택합니다.

Execute Procedure

프로시저, 함수 또는 트리거를 실행하려면 이 옵션을 선택합니다. parameters 대화 상자가 표시되면 필수 매개 변수를 입력하고 OK를 눌러 프로시저를 실행합니다. 이 옵션은 어떠한 디버깅 옵션도 활성화하지 않고 단순히 전체 프로시저를 실행합니다.

Privileges

프로시저, 함수 또는트리거에 대한 권한을 변경하려면 이 옵션을 선택합니다.

이 옵션을 선택하면 privileges 창이 표시됩니다.

  • CTRL 키를 누르고 여러 사용자 이름을 눌러 사용자 목록에서 여러 항목을 선택할 수 있습니다.

  • 권한을 추가하거나 취소하려면 권한을 갖게 할 사용자를 선택하고 마우스 오른쪽 단추를 누른 다음 마우스 오른쪽 단추 메뉴에서 Grant, Grant - with Admin 또는 Revoke를 선택합니다. 그런 다음 Apply를 누릅니다.

  • Revoke All 을 눌러 모든 권한을 취소할 수 있습니다.

Copy Source to Clipboard

이 옵션을 사용하면 전체 소스 SQL을 클립보드에 복사하고 editor나 다른 응용 프로그램에 붙여넣을 수 있습니다.

Copy Selected Source to Clipboard

소스 SQL의 일부만 클립보드에 복사할 수도 있습니다.

선택한 소스를 복사하려면

  1. 프로시저, 함수 또는 트리거를 선택한 다음 Details 패널에서 Code 탭을 누릅니다. 선택한 항목에 대한 SQL이 표시됩니다.

  2. 코드의 일부를 선택하고 마우스 오른쪽 단추를 누른 다음 Copy Selected Source to Clipboard를 선택합니다. 선택한 부분이 클립보드에 복사됩니다.

Print Source

이 옵션은 Code 탭의 내용을 기본 프린터로 직접 보냅니다.

관련 항목

Schema Browser: Procs

새 프로시저 작성

저장 프로시저 호출


Schema Browser: Profiles

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

프로파일을 만들거나 수정하거나 삭제할 수 있습니다. 또한 리소스 세부 정보를 볼 수 있습니다.

Objects 패널

Profiles Objects 패널에서는 선택한 스키마의 프로파일 목록을 제공합니다. 도구 모음에서 프로파일을 만들거나 수정하거나 삭제하거나 또는 SQL 스크립트를 만들 수 있습니다.

Profiles 도구 모음

단추 | 명령
 | Create Script - SQL 스크립트를 작성하여 클립보드에 복사합니다.
 | Filter Scripts - Profiles 목록을 필터링할 수 있는 Browser Filters 창이 열립니다. 필터가 사용 중이면 아이콘이 빨간색으로 바뀝니다.
 | Create New Profile - Create Profile 창이 표시됩니다. 이 창에 대한 설명은 Create Profile 항목을 참조하십시오.
 | Create Like - 이 명령은 Create Profile 창을 열고 선택한 프로파일을 모방하여 공백을 채웁니다. 이 명령을 사용하면 유사한 프로파일을 쉽게 만들 수 있습니다.
 | Modify Profile - 선택한 프로파일의 Modify Profile 창이 표시됩니다. 이 창의 기능은 Create Profile 창과 같습니다.
 | Drop Profile - 선택한 프로파일을 삭제합니다.

Details 패널

Details 패널에는 선택한 프로파일의 다양한 세부 정보를 표시하는 여러 탭이 있습니다.

Resource 탭

Resource 탭에는 프로파일 매개 변수와 각각에 대한 값이 표시됩니다.

Password 탭

Oracle 8 이상에서 Password 탭에는 선택한 프로파일의 암호 매개 변수가 표시됩니다.

Users 탭

선택한 프로파일의 사용자, 각 사용자를 작성한 시기 및 사용자에 대해 사용할 기본 테이블 공간이 표시됩니다.

관련 항목

Create profile


창: Create Profile

Create Profile

주: 이 Toad 기능은 선택 사항인 Quest DBA Module과 함께 Toad의 상용 버전에서만 사용할 수 있습니다.

프로파일은 제한된 데이터베이스 자원 집합입니다. 프로파일을 사용자에게 할당할 경우 사용자는 이러한 제한을 초과할 수 없습니다.

프로파일을 작성하려면

  1. Database|Create 메뉴에서 Profile을 선택합니다.

또는

Schema Browser|Profiles 페이지에서 Create New Profile 단추를 누릅니다.

  2. Resource Parameters 및 Password Parameters 탭에서 매개 변수 항목에 대한 Default 또는 Unlimited를 선택합니다.

  3. 아니면 Add to PM 확인란을 선택하여 Project Manager에 개체를 추가합니다.

  4. Show SQL을 눌러 SQL Strings, SQL Text, Clause Text 및 Values를 확인합니다.

관련 항목

프로파일


Queue Tables

Advanced Queuing은 Oracle 8 및 8i 이상에서만 지원됩니다. 이전 버전의 Oracle을 실행 중인 경우에는 Toad에서 Schema Browser의 Queue Tables 및 Queues 페이지를 숨깁니다.

Objects 패널

Schema Browser의 Objects Panel에서 Queue Tables라는 제목의 탭을 누릅니다. 선택한 스키마에 있는 대기열 테이블 목록이 나타납니다.

Queue Tables 도구 모음

Objects 패널에 있는 도구 모음에는 여러 옵션이 있습니다.

단추 | 명령
 | Copy Script to Clipboard - SQL 스크립트를 작성하여 클립보드에 복사합니다.
 | Create New Queue Table - 대기열 테이블이 미리 선택된 Create Table 창이 표시됩니다. 자세한 내용은 Create Queue Table 항목을 참조하십시오.
 | Alter Queue Table - 선택한 대기열 테이블의 Alter Table 창을 표시합니다. 자세한 내용은 Alter Queue Table 항목을 참조하십시오. 주: Alter Queue Table은 Oracle 8.0에서 지원되지 않습니다.
 | Filter Queue Tables - 이 항목을 선택하면 Browser Filters 창을 열고 대기열 테이블 목록을 필터링할 수 있습니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Drop Queue Table - 선택한 대기열 테이블을 삭제합니다. 확인 창에서 선택한 테이블을 정말로 삭제할 것인지 묻습니다. 테이블을 삭제하려면 Yes를 누릅니다.

Details 패널

Details 패널에는 선택한 테이블에 대한 정보가 제공됩니다.

General

General 탭에는 선택한 대기열 테이블에 관한 정보가 표시됩니다. 이 정보에는 페이로드 유형, 호환성 및 옵션이 포함됩니다.

Queues

Details 패널에 있는 Queues 탭을 사용하면 목록에서 대기열을 선택한 후 도구 모음을 사용하여 다양한 대기열의 enqueue 및 dequeue를 시작하고 중지할 수 있습니다.

주: 예외 대기열에는 enqueue를 수행할 수 없습니다.

Scripts

Scripts 탭에는 대기열 테이블에 있는 모든 대기열을 다시 작성할 수 있는 전체 스크립트 집합이 표시됩니다.

Statistics

Statistics 탭에는 현재 대기열 테이블에 있는 모든 대기열의 통계가 표시됩니다. 이러한 통계에는 현재 대기, 준비 및 만료 상태에 있는 각 대기열의 메시지 수가 포함됩니다. 하나의 그리드 행은 하나의 대기열을 나타냅니다.

Schedules

Schedules 탭에는 현재 대기열 테이블에 있는 모든 대기열에 대해 메시지를 전파하는 현재 예약이 표시됩니다.

관련 항목

Create Queue Table

Alter Queue Table

Queues


Create Queue Table

Advanced Queuing 테이블은 Oracle의 Advanced Queuing 기능에 사용되는 테이블 유형입니다. Create Queue table 명령에서는 Oracle의 DBMS_AQADM.CREATE_QUEUE_TABLE 프로시저를 사용합니다. 대기열 테이블은 두 가지 방법 중 하나를 사용하여 작성할 수 있습니다.

대기열 테이블을 작성하려면

  • Database|Create|Table에 있는 테이블 유형 선택 라디오 단추 중에서 Advanced Queuing을 선택합니다.

또는

Schema Browser|Queue Tables 페이지|도구 모음의 Create New Table 단추로 Advanced Queuing 라디오 단추가 미리 선택되어 있는 Create table 대화 상자를 엽니다.

Queue Table을 작성할 때에는 네 개의 표준 개체가 작성됩니다.

  • 테이블에 연결된 기본 예외 대기열. aq$_<queue_table_name>_e라고 합니다.

  • 데이터 질의용 AQ 응용 프로그램에서 사용하는 읽기 전용 보기. aq$<queue_table_name>이라고 합니다.

  • 색인 또는 대기열 모니터 작업을 위해 색인으로 구성된 테이블(여러 소비자 대기열인 경우에서). aq$_<queue_table_name>_t라고 합니다.

  • 색인 또는 색인으로 구성된 테이블(dequeue 작업에 대한 여러 소비자 대기열인 경우에서). aq$_<queue_table_name>_i라고 합니다.

Oracle8i와 호환되는 대기열 테이블을 작성한 경우에는 색인으로 구성된 다음 세 테이블도 작성됩니다.

  • 구독자에 대한 정보를 저장하는 테이블. aq$_<queue_table_name>_s라고 합니다.

  • 구독 규칙에 대한 정보를 저장하는 테이블. aq$_<queue_table_name>_r라고 합니다.

  • dequeue 기록 데이터를 저장하는 테이블. aq$_<queue_table_name>_h라고 합니다.

Organization 탭

이 탭을 사용하여 테이블의 공간 요구 사항을 구성하고 설정합니다.

Comments 탭

테이블에 첨부할 주석을 여기에 입력합니다.

Queue 탭

Advanced Queuing 테이블을 실제로 설정하려면 Queue 탭을 사용합니다. 이 대화 상자를 사용하면 Oracle 매개 변수 설정에 필요한 정보를 쉽게 입력할 수 있습니다.

Payload type

이 테이블에서 처리할 페이로드의 유형을 입력합니다. 이 옵션은 DBMS_AQADM.CREATE_QUEUE_TABLE 페이로드 매개 변수에 매핑됩니다.

Options

Allow subscribers는 DBMS_AQADM.CREATE_QUEUE_TABLE multiple_consumers 매개 변수에 매핑됩니다.

Allow message grouping은 DBMS_AQADM.CREATE_QUEUE_TABLE message_grouping 매개 변수에 매핑됩니다.

Compatibility

이 테이블에 대해 원하는 호환성을 선택합니다.

예를 들어 Oracle 9i를 사용하는 경우 이 테이블을 Oracle 8 Advanced Queuing과 호환되게 하려면 8.0을 선택합니다.

주: Oracle 8.0을 사용하는 경우 Compatibility는 설정할 수 있는 매개 변수가 아닙니다. 이 상자는 숨겨집니다.

Sort list

dequeue 순서 지정을 위한 정렬 키가 있는 경우에는 테이블을 작성할 때 정의해야 합니다. 아래 표에서 설명한 네 가지 방법 중 하나를 사용하여 정렬할 대기열을 지정할 수 있습니다. 정렬을 지정하지 않으면 대기열 테이블에 있는 모든 대기열이 enqueue 시간에 따라 오름차순으로 정렬됩니다.

정렬 키 | 의미
ENQ_TIME | 조사 시간별
PRIORITY | 대기열 우선 순위별
PRIORITY, ENQ_TIME | 대기열 우선 순위별 후 조사 시간별
ENQ_TIME, PRIORITY | 조사 시간별 후 우선 순위별

주: 기본 순서를 지정한 경우라도 dequeuer에서 이 순서에 맞지 않게 dequeue할 메시지를 선택할 수 있습니다. msgid, correlation, sequence_deviation이 지정된 경우에는 기본 dequeue 순서보다 우선적으로 처리됩니다.

관련 항목

Queue Table

Alter Queue Table

Queues


Alter Queue Table

Advanced Queuing 테이블은 Oracle의 Advanced Queuing 기능에 특수하게 사용되는 테이블 유형입니다. 따라서 수정 방법이 제한됩니다.

Alter Queue table 명령에서는 Oracle의 DBMS_AQADM.ALTER_QUEUE_TABLE 프로시저를 사용합니다. 이 창에서는 다음을 수행할 수 있습니다.

  • Organization 탭에서 제한된 저장소 매개 변수를 변경합니다.

  • Comments 탭에서 주석을 변경합니다.

  • Queue 탭에서 호환성 매개 변수를 변경합니다.

대기열 테이블을 수정하려면

  • Schema Browser|Queue Tables 페이지에서 도구 모음에 있는 Alter Queue Table [image] 단추를 누릅니다.

관련 항목

Queue Table

Create Queue Table

Queues


Schema Browser: Queues

Advanced Queuing은 Oracle 8 및 8i 이상에서만 지원됩니다. 이전 버전의 Oracle을 실행하는 경우에는 Toad에서 Schema Browser의 Queue Tables 및 Queues 페이지를 숨깁니다.

Objects 패널

Schema Browser의 Objects 패널에서Queues라는 제목의 탭을 누릅니다. 선택한 스키마에 있는 대기열 목록이 나타납니다.

Queues 도구 모음

Objects 패널에 있는 도구 모음에는 여러 옵션이 있습니다.

단추 | 명령
 | Copy Script to Clipboard - 대기열을 다시 만드는 데 사용되는 SQL 스크립트를 작성하여 클립보드에 복사합니다.
 | Create Queue - 새 대기열을 만들 수 있습니다. 자세한 내용은 Create Queue를 참조하십시오.
 | Alter Queue - 기존 대기열을 수정할 수 있습니다. 자세한 내용은 Alter Queue를 참조하십시오.
 | Filter Queue list - Browser Filters 창이 열리고 개체 목록을 필터링할 수 있습니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Start Enqueue - DBMS_AQADM.START_QUEUE 기능을 사용하여 선택한 대기열에서 enqueue를 활성화합니다.
 | Stop Enqueue - DBMS_AQADM.STOP_QUEUE 기능을 사용하여 선택한 대기열에서 enqueue를 중지합니다.
 | Start Dequeue - DBMS_AQADM.START_QUEUE 기능을 사용하여 선택한 대기열에서 dequeue를 활성화합니다.
 | Stop Dequeue - DBMS_AQADM.STOP_QUEUE 기능을 사용하여 선택한 대기열에서 dequeue를 중지합니다.
 | Drop Queue - 선택한 대기열을 하나 이상 삭제할 수 있습니다.

Details 패널

Details 패널에는 매개 변수와 매개 변수 값을 나열하는 Info 및 Stats 탭이 있습니다.

관련 항목

Create Queue

Alter Queue

Queue Tables


Create Queue

Create Queue 창에서는 아래 설명에 따라 비영구 대기열을 작성하는 경우를 제외하고는 DBMS_AQADM.CREATE_QUEUE 프로시저를 사용합니다.

먼저 창의 맨 위에 있는 드롭다운에서 스키마를 선택하고 대기열에 이름을 지정합니다.

General 탭

General 탭에서는 이 대기열에 연결된 기본 매개 변수를 설정할 수 있습니다.

Queue table

이 대기열에 연결할 대기열 테이블을 선택합니다.

Comment

원하는 경우 대기열을 설명하는 주석을 입력합니다.

Queue Type

  • Normal - 일반 대기열을 작성합니다.

  • Exception - 예외 대기열을 작성합니다. 예외 대기열에서는 Queue Type 그룹 상자 아래에서 정보를 설정할 수 없습니다.

  • Non-persistent - 이 항목을 선택하면 CREATE_NP_QUEUE 프로시저를 사용하여 메모리 내 대기열을 작성합니다.

  • Allow subscribers 확인란 - 비영구 대기열에 구독자를 허용하려면 Allow subscribers 확인란을 선택합니다. 이 확인란을 선택하면 Subscribers 탭(아래 참조)이 보입니다.

Retries

재시도 횟수와 각 재시도 사이의 지연을 설정할 수 있습니다.

Enqueue

이 대기열의 enqueue를 활성화 또는 비활성화할 수 있습니다.

Dequeue

이 대기열의 dequeue를 활성화 또는 비활성화할 수 있습니다.

Message retention

dequeue된 메시지를 보존하는 기간을 선택합니다.

Subscribers 탭

구독자를 허용하는 비영구 대기열을 작성하지 않은 경우 Subscribers 탭은 숨겨져 있습니다.

이 탭에서는 대기열의 구독자를 추가, 편집 및 삭제할 수 있습니다.

Subscribers 탭에서는 Oracle DBMS_AQADM.ADD_SUBSCRIBER 프로시저를 사용합니다.

관련 항목

Queues

Alter Queue

Queue Table


Alter Queue

예외 대기열이 아닌 대기열에서는 Queue type을 제외한 대부분의 매개 변수를 수정할 수 있습니다. 매개 변수는 Alter Queue 창에 Create Queue 창과 같은 형식으로 나열됩니다.

예외 대기열에서는 다른 정보를 수정할 수 없고 주석만 수정할 수 있습니다.

관련 항목

Queues

Create Queue

Queue Table


Schema Browser: Recycle Bin

Oracle 버전 10g 이상에서는 휴지통을 사용하여 데이터베이스에서 삭제한 테이블과 관련 개체(색인, 제약 조건, 트리거 등)를 검색할 수 있습니다. Schema Browser의 Recycle Bin 페이지에서는 필요한 경우 이 휴지통에 액세스하여 삭제된 테이블을 검색할 수 있습니다.

Objects 패널

Objects 패널에는 선택한 스키마의 휴지통에서 사용할 수 있는 개체가 나열됩니다.

Refresh Group 도구 모음

단추 | 명령
 | 선택한 테이블을 플래시백합니다. 주: 테이블을 삭제할 때 Purge를 선택한 경우에는 휴지통에서 검색할 수 없습니다.
 | 휴지통을 비웁니다.
 | Filter refresh group list - 개체 목록을 필터링할 수 있는 Browser Filters 창이 열립니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.

Details 패널

세부 사항 패널에는 삭제된 개체에 대한 정보가 들어 있습니다.


Flashback Table

휴지통에서 손쉽게 테이블을 검색하여 데이터베이스에 다시 넣을 수 있습니다.

테이블을 플래시백하려면

  1. Schema Browser|Recycle Bin에서 검색할 테이블을 선택합니다.

  2. Objects Panel 도구 모음에 있는 Flashback Table [image] 단추를 누릅니다.

  3. 삭제된 테이블과 같은 이름을 사용합니다.

또는

테이블 이름 변경을 선택하고 Rename To 상자에 새 이름을 입력합니다.

  4. OK를 눌러 테이블을 바꿉니다.


휴지통에서 개체 제거

휴지통에서 손쉽게 개체를 삭제(제거)할 수 있습니다.

휴지통을 비우려면

  1. Schema Browser|Recycle Bin|Objects Panel에서 제거할 개체를 선택합니다.

  2. 도구 모음에 있는 Purge Objects from the Recycle Bin [image] 단추를 누릅니다.

  3. 다음 옵션 중에서 선택합니다.

  4. Purge Selected Tables and Indexes(트리거는 개별적으로 제거할 수 없음)

  5. Purge everything from connected schema (SCHEMANAME)

  6. Purge Entire recycle bin - 데이터베이스 전체

  7. Purge Everything in specified tablespace

  4. 선택한 테이블 공간에서 모든 것을 제거하기로 선택한 경우:

  5. 제거할 테이블 공간을 입력합니다.

  6. 테이블 공간에 있는 한 사용자로 제거를 제한하려는 경우에는 Only specified user's objects 상자를 선택하고 사용자 이름을 입력합니다.

  5. OK를 누릅니다.


Schema Browser: Refresh Groups

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Schema Browser에서 기존 새로 고침 그룹에 구체화된 보기를 추가하고, 구체화된 보기를 제거하고, 선택한 그룹을 새로 고치고, 그룹을 삭제할 수 있습니다.

Objects 패널

Objects 패널에는 선택한 스키마에서 사용할 수 있는 새로 고침 그룹이 나열됩니다.

Refresh Group 도구 모음

단추 | 명령
 | 선택한 개체의 스크립트를 작성하여 클립보드에 복사합니다.
 | 새 새로 고침 그룹을 작성합니다.
 | 기존 새로 고침 그룹을 수정합니다.
 | 구체화된 보기를 새로 고침 그룹에 추가합니다.
 | 구체화된 보기를 새로 고침 그룹에서 제거합니다.
 | Refresh the object list - Object 패널에 있는 새로 고침 그룹의 목록을 새로 고칩니다.
 | Filter refresh group list - 개체 목록을 필터링할 수 있는 Browser Filters 창이 열립니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Drop refresh group - 선택한 새로 고침 그룹을 삭제합니다.

Details 패널

Details 패널에는 선택한 새로 고침 그룹에 대한 정보가 들어 있습니다.


Create Refresh Group

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

이 창을 사용하면 손쉽게 새로 고침 그룹을 작성할 수 있습니다..

새로 고침 그룹을 작성하려면

  1. Database|Create 메뉴에서 Refresh Group을 선택합니다.

또는

Schema Browser|Refresh Group 페이지에서 Create New [image] 단추를 누릅니다.

  2. Refresh Group Name 상자에 이름을 입력하여 그룹 이름을 지정합니다.

  3. Properties 탭을 누르고 새로 고침 그룹을 작성하는 데 사용할 옵션을 선택합니다.

  4. Objects 탭을 누른 후 Add MV를 누릅니다.

  5. Add Materialized Views 대화 상자에서는 다음을 수행할 수 있습니다.

  6. 보기 목록 필터링

  7. 추가할 Materialized View 하나 이상 선택

  8. 추가 질의 편집(Edit Query 누름)

  6. Materialized View에 대한 선택이 끝나면 OK를 누릅니다.

  7. 선택적으로 Add to PM 확인란을 선택하면 Project Manager에 개체를 추가할 수 있습니다.

  8. 새로 고침 그룹을 작성하는 질의를 보려면 View SQL을 누릅니다.

또는

OK를 눌러 새로 고침 그룹을 작성합니다.


Alter Refresh Group

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

이 창을 사용하면 손쉽게 기존 새로 고침 그룹을 수정할 수 있습니다..

새로 고침 그룹을 수정하려면

  1. Schema Browser|Refresh Group 페이지에서 새로 고침 그룹을 선택하고 Alter [image] 단추를 누릅니다.

  2. Create Refresh Group 항목에 설명된 것과 같은 방법을 사용하면 새로 고침 그룹에서 이름만 제외하고 모든 것을 수정할 수 있습니다.

주: Implicit destroy를 선택한 경우 그룹에서 Materialized View를 모두 제거하면 그룹도 제거됩니다.


새로 고침 그룹 옵션

Properties 탭

Implicit Destroy

이 항목을 선택하면 새로 고침 그룹에서 모든 mview를 삭제한 경우에 Oracle이 새로 고침 그룹도 자동을 삭제합니다.

Job #

새로 고침 그룹의 식별 번호입니다. Oracle에서 작성됩니다.

Push Deferred RPC

이 옵션은 업데이트할 수 있는 스냅숏에만 사용됩니다. 로컬 업데이트를 마스터 사이트로 다시 밀어넣는 것을 나타내려면 이 상자를 선택합니다.

이 옵션을 선택하지 않으면 새로 고침을 수행하는 동안 로컬 업데이트가 보이지 않습니다.

Refresh After Errors

이 옵션은 업데이트할 수 있는 스냅숏에만 사용됩니다. DEFERROR 데이터 사전 보기에 오류가 있는 경우에도 새로 고침이 이루어지는 것을 나타내려면 이 상자를 선택합니다.

Job Broken

이 옵션을 선택하면 작업이 손상된 것으로 표시되어 Oracle에서 작업이 실행되지 않습니다.

Rollback Segment

이 새로 고침 그룹에 사용할 롤백 세그먼트를 입력합니다. Oracle에서 새로 고침 그룹에 있는 스냅숏을 새로 고치면 서버에서 막대한 양의 롤백 데이터가 생성될 수 있습니다. 그룹의 새로 고침에 충분히 사용할 수 있을 정도로 큰 롤백 세그먼트를 선택해야 합니다. 이 항목을 비워 두면 기본 롤백 세그먼트가 사용됩니다.

Next Date

새로 고침이 다음으로 발생할 날짜를 입력합니다.

Interval

새로 고침 간의 간격을 입력합니다. 예를 들어 7일마다 자정에 새로 고침을 수행할 수 있습니다. 드릴다운 [image] 단추를 누르고 표준 간격 목록에서 선택합니다.

Specify Parallelism

이 옵션은 push_deferred_rpc를 선택한 경우에만 적용됩니다. 이 옵션은 최대 병렬 처리도를 지정합니다. 기본값은 1입니다.

Specify Purge Option

이 옵션은 push_deferred_rpc를 선택한 경우에만 적용됩니다. 이 옵션이 제거 옵션을 결정합니다. 기본값은 1입니다. 이러한 유형의 제거에 대한 자세한 내용은 Oracle 관련 문서를 참조하십시오.

  • 0 - 제거 안 함

  • 1 - 소극적으로

  • 2 - 적극적으로

Specify Heap Size

이 옵션은 병렬 처리 > 0인 경우에만 사용됩니다. 여기서는 병렬 예약을 결정하기 위해 동시에 검사할 최대 트랜잭션 수를 설정합니다. 선택하지 않고 지정하지 않으면 Oracle에서 이 값을 결정합니다.

Objects in Group 탭

이 탭의 그리드를 사용하여 새로 고침 그룹에서 mview 추가 또는 제거를 수행할 수 있습니다.

주: 이 그룹이 Implicit Destroy로 설정된 경우 그룹에서 모든 mview를 제거하면 그룹도 삭제됩니다.


Schema Browser: Resource Consumer Groups

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

대기 중인 리소스 소비자 그룹을 만들거나 수정하거나 삭제하거나 지울 수 있습니다. 또한 리소스 소비자 그룹 세부 정보를 볼 수 있습니다.

주: 리소스 소비자 그룹은 Oracle 8i 이상에서만 사용할 수 있습니다.

Objects 패널

Objects 패널에는 선택한 스키마에서 사용할 수 있는 리소스 소비자 그룹이 나열됩니다.

Research Consumer Group 도구 모음

단추 | 명령
 | Copy script to clipboard - SQL 스크립트를 작성하여 클립보드에 복사합니다.
 | Create resource consumer group- Create Resource Consumer Group 창이 열립니다.
 | Alter resource consumer group - 선택한 역할의 Alter Resource Consumer Group 창이 열립니다.
 | Filter resource consumer group list - 개체 목록을 필터링할 수 있는 Browser Filters 창이 열립니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Clear pending area - 리소스 소비자 그룹을 만드는 중에는 "대기 중" 영역에 상주하게 됩니다. 리소스 소비자 그룹을 작성/수정/삭제하는 동안에 오류가 발생하면 개체가 대기 중 영역에 남아 있을 수 있습니다. Toad의 GUI에서는 일반적으로 오류가 발생할 때 대기 중 영역을 지우지만, 이 명령은 필요한 경우 대기 중 영역을 수동으로 지울 수 있습니다.
 | Drop resource consumer group - 선택한 리소스 소비자 그룹을 삭제합니다.

Details 패널

Details 패널에는 리소스 계획의 세부 정보를 표시하는 탭이 있습니다.

세부 정보는 다음과 같습니다.

  • 정보

  • 권한을 받는 사람

  • 계획

  • 스크립트

관련 항목

Create Resource Consumer Group

Alter Resource Consumer Group


Create Resource Consumer Group

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

이 창을 사용하면 손쉽게 자원 소비자 그룹을 작성할 수 있습니다..

자원 소비자 그룹을 작성하려면

  1. Database|Create 메뉴에서 Resource Consumer Group을 선택합니다.

또는

Schema Browser|Resource Consumer Group 페이지에서 Create New [image] 단추를 누릅니다.

  2. Resource Group Name 상자에 이름을 입력하여 그룹 이름을 지정합니다.

  3. 지금은 Oracle에서 ROUND-ROBIN CPU 방법만 허용됩니다. Comments 상자에 포함할 주석을 입력합니다.

  4. 선택적으로 Add to PM 확인란을 선택하면 Project Manager에 개체를 추가할 수 있습니다.

  5. 다음 중 하나를 누릅니다.

  6. Show SQL: SQL을 실행하기 전에 표시합니다.

  7. OK: 자원 소비자 그룹을 작성합니다.

관련 항목

자원 소비자 그룹

Alter Resource Consumer Groups


Alter Resource Consumer Groups

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

이 창을 사용하면 손쉽게 자원 소비자 그룹을 수정할 수 있습니다..

자원 소비자 그룹을 수정하려면

  1. Schema Browser|Resource Consumer Group 페이지에서 Alter [image] 단추를 누릅니다.

  2. 자원 그룹의 이름은 변경할 수 없습니다. 지금은 Oracle에서 ROUND-ROBIN CPU 방법만 허용됩니다.

  3. Comments 상자에 포함할 주석을 입력 또는 변경합니다.

  4. 다음 중 하나를 누릅니다.

  5. Show SQL: SQL을 실행하기 전에 표시합니다.

  6. OK: 자원 소비자 그룹을 수정합니다.

관련 항목

자원 소비자 그룹

Create Resource Consumer Group


Schema Browser: Resource Plans

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

대기 중인 리소스 계획을 만들거나 변경하거나 삭제하거나 예약하거나 지울 수 있습니다. 또한 리소스 계획 세부 정보를 볼 수 있습니다.

Objects 패널

Objects 패널에는 선택한 스키마에서 사용할 수 있는 리소스 계획이 나열됩니다.

리소스 계획의 유형과 상태는 다양한 아이콘으로 구분됩니다. 자세한 내용은 Icon Legend를 참조하십시오.

Research Plan 도구 모음

단추 | 명령
 | Copy script to clipboard - SQL 스크립트를 작성하여 클립보드에 복사합니다.
 | Create resource plan- Create Resource Plan 창이 열립니다.
 | Alter resource plan- 선택한 역할의 Alter Resource Plan 창이 열립니다.
 | Filter resource plan list - 개체 목록을 필터링할 수 있는 Browser Filters 창이 열립니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Activate resource plan - 자원 계획을 활성화하려면 이 아이콘을 누릅니다. 마우스 오른쪽 단추 메뉴에서도 사용할 수 있습니다. 주: 한 번에 한 계획만 활성화할 수 있습니다. 새 계획을 활성화하면 첫 번째 계획이 비활성화됩니다.
 | Deactivate resource plan - 리소스 계획을 비활성화하려면 이 아이콘을 누릅니다. 마우스 오른쪽 단추 메뉴에서도 사용할 수 있습니다.
 | Schedule resource plan - 매일의 리소스 계획 예약을 수정하려면 이 아이콘을 누릅니다. 이 명령은 DBA 메뉴에서도 사용할 수 있습니다. 주: 이 예약을 수정하려면 SYS로 로그인해야 합니다.
 | Clear pending area - 리소스 계획을 만드는 중에는 "대기 중" 영역에 상주하게 됩니다. 리소스 계획을 작성/수정/삭제하는 동안에 오류가 발생하면 개체가 대기 중 영역에 남아 있을 수 있습니다. Toad의 GUI에서는 일반적으로 오류가 발생할 때 대기 중 영역을 지우지만, 이 단추를 누르면 필요한 경우 대기 중 영역을 수동으로 지울 수 있습니다.
 | Drop resource plan- 선택한 리소스 계획을 삭제합니다.

Details 패널

Details 패널에는 리소스 계획의 세부 정보를 표시하는 탭이 있습니다.

세부 정보는 다음과 같습니다.

  • 일반 정보

  • 수준

  • 병렬 처리

  • 리소스 계획을 관리하는 SQL 스크립트

관련 항목

Create Resource Plan

Alter Resource Plan

Schedule Resource Plan


Create Resource Plan

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

이 창을 사용하면 손쉽게 자원 계획을 작성할 수 있습니다.

자원 계획을 작성하려면

  1. Database|Create 메뉴에서 Resource Plan을 선택합니다.

또는

Schema Browser|Resource Plan 페이지에서 Create New [image] 단추를 누릅니다.

  2. 새 자원 계획에 이름을 지정합니다.

  3. 사용 가능한 자원 소비자 그룹 및 하위 계획을 Available Groups and Subplans 영역에서 Resource Plan Directives 영역으로 끌어 새 계획 지시문을 작성합니다.

  4. 주석 패널에서 전체 자원 계획의 주석을 입력합니다. 이것은 큰 텍스트 상자입니다. 누른 후 입력을 시작합니다.

  5. Levels 탭을 누릅니다. 적절한 셀을 누르고 키보드 또는 마우스를 사용하여 백분율을 조정하는 방법으로 CPU 백분율 값을 설정합니다.

  6. Parallelism 탭을 누릅니다. Maximum Degree of Parallelism 열을 눌러 선택한 그룹의 설정을 변경합니다. 기본값은 unlimited입니다.

  7. Directive Comments 탭을 누르고 계획 지시문에 대한 주석을 입력합니다.

  8. 선택적으로 Add to PM 확인란을 선택하면 Project Manager에 개체를 추가할 수 있습니다.

관련 항목

Resource Plans

Alter Resource Plan

Schedule Resource Plan


Alter Resource Plan

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

이 창을 사용하면 손쉽게 기존 자원 계획을 수정할 수 있습니다..

자원 계획을 수정하려면

  1. Schema Browser|Resource Plan 페이지에서 Alter [image] 단추를 누릅니다. 그 후에 다음과 같이 항목을 변경할 수 있습니다.

  2. 사용 가능한 자원 소비자 그룹 및 하위 계획을 Available Groups and Subplans 영역에서 Resource Plan Directives 영역으로 끌어 새 계획 지시문을 변경 또는 작성합니다.

  3. 주석 패널에서 전체 자원 계획의 주석을 입력합니다. 이것은 큰 텍스트 상자입니다. 누른 후 입력을 시작합니다.

  4. Levels 탭을 누릅니다. 적절한 셀을 누르고 키보드 또는 마우스를 사용하여 백분율을 조정하는 방법으로 CPU 백분율 값을 설정합니다.

  5. Parallelism 탭을 누릅니다. Maximum Degree of Parallelism 열을 눌러 선택한 그룹의 설정을 변경합니다. 기본값은 unlimited입니다.

  6. Directive Comments 탭을 누르고 계획 지시문에 대한 주석을 입력합니다.

  2. OK를 눌러 자원 계획을 수정합니다.

관련 항목

Resource Plans

Create Resource Plan

Schedule Resource Plan


Schedule Resource Plan

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

자원 계획을 예약하려면 로그인에 사용한 스키마가 SYSDBA로 연결되어 있어야 합니다.

주: 이 스케줄러는 Schema Browser의 Jobs 탭에서 볼 수 있는 작업을 작성합니다. 이러한 작업을 수정하는 것은 바람직하지 않으며 스케줄러가 잘못 수행되는 결과를 초래할 수 있습니다.

자원 계획을 예약하려면

  1. Schema Browser|Resource Plans 페이지에서 Schedule Resource Plan [image] 단추를 누릅니다.

  2. 나타나는 Daily Resource Plan Schedule에서는 다음을 수행할 수 있습니다.

  3. Add Plan [image] 단추를 눌러 새 계획을 추가합니다.

  4. Remove Plan [image] 단추를 눌러 계획을 제거합니다.

  5. 그리드에서 Enabled 확인란을 선택하거나 Enable All을 눌러 계획을 활성화합니다.

  6. Enabled 확인란 선택을 취소하거나 Disable All을 눌러 계획을 비활성화합니다.

  7. Show SQL을 눌러 변경을 일으킬 SQL을 표시합니다. 이 대화 상자에서 SQL을 파일에 저장하여 나중에 실행할 수 있습니다.

  3. OK를 눌러 SQL을 실행하거나 Cancel을 눌러 내용을 변경하지 않고 창을 닫습니다.

관련 항목

Resource Plans

Create Resource Plan

Alter Resource Plan


Schema Browser: Roles

역할 및 권한 세부 정보를 볼 수 있습니다. Quest DBA Module이 있는 경우에는 또한 역할을 만들거나 변경하거나 삭제할 수 있습니다.

Objects 패널

Objects 패널에는 선택한 스키마에서 사용할 수 있는 역할이 나열됩니다.

Roles 도구 모음

단추 | 명령
 | Copy script to clipboard - SQL 스크립트를 작성하여 클립보드에 복사합니다.
 | Create role - Create Role 창이 열립니다. 이 창에 대한 설명은 Create Role 항목을 참조하십시오.
 | Alter role - 선택한 역할의 Alter Role 창이 열립니다.
 | Filter resource plan list - 개체 목록을 필터링할 수 있는 Browser Filters 창이 열립니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Drop role - 선택한 역할을 삭제합니다.

Details 패널

Details 패널에는 역할의 세부 정보를 표시하는 탭이 있습니다. 다음과 같은 탭이 있습니다. Info, Role Grants, System Privileges, Object Grants 및 Resource Groups

주:

  • Object Privileges 탭에는 SYS 및 SYSTEM 개체가 포함되지 않습니다.

  • Configure grantees는 Quest DBA Module에서만 사용할 수 있습니다.

관련 항목

Create Role

Alter Role


창: Create Role

Create Role

주: 이 Toad 기능은 선택 사항인 Quest DBA Module과 함께 Toad의 상용 버전에서만 사용할 수 있습니다.

Create Role 창을 액세스하려면

  • Database|Create 메뉴에서 Role을 선택합니다.

또는

Schema Browser|Roles 페이지에서 Create new Role 단추를 누릅니다.

이 창에서 역할을 작성하여 권한을 할당할 수 있습니다. 다음 네 가지 탭에서 이 작업을 수행할 수 있습니다. Role Info , Roles , System Privileges 및 Grants . OK를 누르면 모든 탭의 내용이 합쳐지고 작성 중인 역할에 포함됩니다.

  • 모든 권한을 선택하고 새 역할에 대한 정보를 모두 입력하면 Show SQL을 눌러 역할을 작성할 코드를 표시합니다. SQL Statement 대화상자에서 SQL을 클립보드로 저장하고, 파일로 저장하거나 창을 닫을 수 있습니다.

  • 아니면 Add to PM 확인란을 선택하여 Project Manager에 개체를 추가합니다.

  • OK 를 눌러 새 역할을 작성합니다.

Role Info 탭

이 탭에서 작성 중인 역할에 대한 기본 정보를 삽입합니다. 이 작업은 여러 탭에서 OK를 누르기 전에 수행해야 합니다.

Name 상자

  • Role에 부여할 이름 을 입력합니다.

Identification 라디오 단추

  • Not Identified

  • Use Database Authentication

주: 이 라디오 단추를 선택하면 Password 상자에 암호를 입력해야 합니다.

  • Use Operating System Authentication

  • Use Enterprise Authentication

Roles 탭

이 탭에서 작성 중인 사용자 역할에 다양한 역할을 부여합니다.

해당 확인란을 눌러 새 역할에 대한 각 역할 이름에 별도로 Grant 및 Administrative 권한을 선택하거나 상단의 단추를 눌러 다음과 같이 한 번에 선택할 수 있습니다.

Admin All

나열된 역할의 관리 상자를 모두 자동으로 점검합니다.

Admin None

나열된 역할의 모든 관리 확인란을 지웁니다.

Grant All

나열된 역할에 부여된 상자를 모두 점검합니다.

Revoke All

나열된 역할에 부여된 모든 상자를 지웁니다.

System Privileges 탭

이 탭에서 위의 Roles 탭과 동일한 방법으로 새 역할에 다양한 시스템 권한을 선택합니다.

Grants 탭

이 탭에서 위의 Roles 탭과 동일한 방법으로 새 역할에 다양한 부여 권한을 선택합니다.

관련 항목

스키마 브라우저 역할

역할 변경


Alter Role

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

작성한 역할을 수정할 수 있습니다.

역할을 수정하려면

  • Schema Browser|Roles 페이지에서 수정할 역할을 선택하고 도구 모음에 있는 Alter Role [image] 단추를 누릅니다. Modify role 창이 나타납니다. 아래 설명과 같이 네 탭에서 정보를 수정합니다.

Role Info

역할 이름을 식별하는 방법을 수정할 수 있습니다. 새 라디오 단추를 선택합니다.

  • Not Identified

  • Use Database Authentication

주: 이 라디오 단추를 선택하면 암호 상자에 암호를 입력해야 합니다.

  • Use Operating System Authentication

  • Use Enterprise Authentication

Roles

이 탭을 사용하면 수정하는 사용자 역할에 다양한 역할을 부여하거나 해지할 수 있습니다.

해당 확인란을 눌러 새 역할에 대해 각 역할 이름의 Grant 및 Administrative 권한을 개별적으로 변경하거나 맨 위에 있는 단추를 사용하여 다음과 같이 한꺼번에 선택할 수도 있습니다.

  • Admin All- 나열된 역할의 Administrative 상자를 모두 자동으로 선택합니다.

  • Admin None -나열된 역할의 모든 Administrarive 상자를 선택 취소합니다.

  • Grant All -나열된 역할의 모든 Grant 상자를 선택합니다.

  • Revoke All -나열된 역할의 모든 Grant 상자를 선택 취소합니다.

System Privileges

이 탭을 사용하면 위 Roles 탭과 같은 방법으로 새 역할의 다양한 시스템 권한을 변경할 수 있습니다.

Grants

이 탭을 사용하면 위 Roles 탭과 같은 방법으로 새 역할의 다양한 Grant를 변경할 수 있습니다.

관련 항목

Roles

Create Role


Schema Browser: Rollback Segments

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Objects 패널

Schema Browser의 Objects 패널에 있는 Rollback Segments 페이지에서 롤백 세그먼트를 만들거나 변경하거나 삭제할 수 있습니다. 롤백 세그먼트를 온라인 또는 오프라인으로 만들 수 있습니다. 또한 롤백 세그먼트의 매개 변수에 대한 세부 정보를 볼 수 있습니다. Create Rollback Segment 항목을 참조하십시오.

롤백 세그먼트의 여러 유형과 상태는 다양한 아이콘으로 식별됩니다. 자세한 내용은 Icon Legend를 참조하십시오.

Rollback 도구 모음

Objects 패널에 있는 도구 모음에는 여러 옵션이 있습니다. 이 작업 중 일부에 대해 두 개 이상의 롤백 세그먼트를 선택할 수 있습니다.

단추 | 명령
 | Create new rollback segment - 롤백 세그먼트를 만들 수 있는 Rollback Segment 창이 표시됩니다.
 | Alter rollback segment - 선택한 롤백 세그먼트의 Alter Rollback Segment 창이 표시됩니다.
 | Shrink segment - 이 단추를 사용하면 선택한 롤백 세그먼트를 축소할 수 있습니다.
 | Place online - 롤백 세그먼트가 오프라인 상태인 경우 이 단추를 사용할 수 있습니다. 이 아이콘을 누르면 선택한 롤백 세그먼트가 온라인 상태가 되며 트랜잭션에서 사용할 수 있게 됩니다. 세그먼트의 Info 탭(Details 패널)에 상태 값이 ONLINE으로 표시됩니다.
 | Place offline - 롤백 세그먼트가 온라인 상태인 경우 이 단추를 사용할 수 있습니다. 이 아이콘을 누르면 선택한 롤백 세그먼트가 오프라인 상태가 되며 트랜잭션에서 사용할 수 없게 됩니다. 세그먼트의 Info 탭(Details 패널)에 상태 값이 OFFLINE으로 표시됩니다. 오프라인 세그먼트는 세그먼트 목록(왼쪽 패널)에서 왼쪽에 빨강색 X 아이콘이 표시됩니다.
 | Filter scripts - Profiles 목록을 필터링할 수 있는 Browser Filters 창이 열립니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Drop rollback segment - 선택한 롤백 세그먼트를 삭제합니다. 확인 창에서 선택한 세그먼트를 삭제할 것인지 묻습니다. 세그먼트를 삭제하려면 Yes를 누릅니다. 롤백 세그먼트가 온라인 상태인 경우 Drop을 누르면 먼저 자동으로 오프라인 상태로 만듭니다.

Details 패널

Details 패널에는 매개 변수와 매개 변수 값을 나열하는 Info 및 Stats 탭이 있습니다.

관련 항목

Create Rollback Segment


창: Create Rollback Segment

Create Rollback Segment

주: 이 Toad 기능은 선택 사항인 Quest DBA Module과 함께 Toad의 상용 버전에서만 사용할 수 있습니다.

이 창에서 새 롤백 세그먼트를 작성할 수 있습니다. 롤백 세그먼트는 Oracle에서 완료되지 않은 트랜잭션에 의해 변경된 내용을 취소하는 데 필요한 데이터를 저장할 때 사용하는 개체입니다.

롤백 세그먼트를 작성하려면

  1. Database|Create|Rollback Segment 메뉴 항목에서 창을 엽니다.

또는

Schema Browser|Rollback Segments 페이지에서 Create New Rollback Segment 단추를 누릅니다.

  2. 상자에 Name을 입력하고 Tablespace를 찾아 롤백 세그먼트를 드롭다운에서 작성합니다.

  3. 모든 인스턴스에 사용할 수 있도록 롤백 세그먼트를 공개로 만들려면 Public 확인란을 표시합니다. 기본값으로 표시되어 있지 않습니다.

  4. 다음 드롭다운을 사용하여 Extents 및 Size를 선택합니다.

  5. Initial Extent 는 개체의 첫 번째 범위의 크기를 지정합니다.

  6. Next Extent 는 개체에 할당된 다음 범위의 크기를 지정합니다.

  7. Min Extents 는 개체가 작성될 때 할당할 범위의 총 수를 지정합니다.

  8. Max Extents 는 할당할 수 있는 범위의 최대수를 지정합니다.

  9. Optimal Size 는 롤백 세그먼트의 최적 크기를 지정합니다.

  5. 아니면 Add to PM 확인란을 선택하여 Project Manager에 개체를 추가합니다.

  6. Show SQL 단추를 눌러 새 롤백 세그먼트의 작성 구문을 표시합니다.

  7. Clipboard 단추를 눌러 클립보드에 구문을 복사합니다.

  8. Save to File 단추를 눌러 구문을 저장합니다.

관련 항목

Schema Browser: 롤백 세그먼트


Schema Browser: Sequences

순서는 오름차순이나 내림차순일 수 있습니다. Oracle에서는 메모리에 있는 지정된 수의 순서 값을 요청되기 전에 계산하여 캐시합니다. 이렇게 하면 Toad와 Oracle 실행이 빨라집니다.

마우스 오른쪽 단추 메뉴

이 옵션은 마우스 오른쪽 단추 메뉴에서 액세스할 수 있습니다. Objects 패널 또는 Details 패널을 마우스 오른쪽 단추로 눌러 옵션을 찾을 수 있습니다.

Alter Sequence

Schema Browser Sequences 탭에 있는 이 마우스 오른쪽 단추 옵션은 Alter Sequence 대화 상자를 표시합니다. 이 매개 변수를 변경하고 Execute를 누르면 Toad에서 ALTER SEQUENCE 명령이 실행됩니다.

Recreate Sequence

Schema Browser Sequences 탭에 있는 이 마우스 오른쪽 단추 옵션은 순서의 현재 매개 변수가 채워진 Alter Sequence 창을 표시합니다. 이 매개 변수를 수정하고 Execute를 누르면 Toad에서 ALTER SEQUENCE 명령 대신 DROP SEQUENCE 명령과 CREATE SEQUENCE 명령이 실행됩니다.

Reset Next Value

이 마우스 오른쪽 단추 옵션은 순서의 최대값을 수정하여 순환 순서로 변경한 후 최대값까지 돌아갈 때까지 순서를 증가시켜 순서 값을 재설정합니다. 그런 다음 순서의 최대값과 순환/비순환 동작을 복원합니다. 증가 값이 양수인 순서만 지원됩니다.

Objects 패널

Objects 패널에는 선택한 스키마에 있는 순서 목록이 포함되어 있습니다. 목록에서 순서 이름을 눌러 선택할 수 있습니다. 순서에 대한 자세한 내용은 아래에 있는 Details 패널을 참조하십시오.

Sequences 도구 모음

단추 | 명령
 | Create script - 다른 창이나 응용 프로그램에 붙여넣을 수 있도록 선택한 순서의 SQL 스크립트를 만들어 클립보드에 복사합니다. 다른 대화 상자에서 스크립트에 개체 부여를 포함할 것인지 여부를 묻습니다.
 | Create new sequence - 이름 상자가 포함된 Create Sequence 창이 표시됩니다. 최대값을 사용하지 않으려면 Max Value 상자를 비워 둡니다. 캐시를 사용하지 않으려면 Number to Cache를 비워 둡니다. Create Sequence 를 참조하십시오.
 | Alter sequence - 이 명령은 순서를 변경할 수 있는 Alter sequence 대화 상자를 표시합니다.
 | Add or edit privileges - Privileges 창이 표시됩니다.
 | Add Public Synonym - 선택한 순서의 공개 동의어를 추가합니다.
 | Filter the Table List - 개체 목록을 필터링할 수 있는 Browser Filters 창이 열립니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Drop sequence - 선택한 순서를 목록에서 삭제합니다.

Details 패널

Details 패널l의 Info 탭에는 선택한 순서의 최대값, 증분, 캐시 수 및 마지막 값이 표시됩니다.

Details 패널의 Grants 탭에서 부여를 볼 수 있습니다.

관련 항목

Create Sequence

Alter Sequence

Export Sequence


시퀀스 작성

시퀀스는 Oracle이 고유 정수를 계속 생성하는 카운터입니다. 자동으로 기본 키 값을 생성하는 데 사용할 수 있습니다. 시퀀스는 표와는 상관이 없으므로 동일한 시퀀스는 하나 이상의 표 및 여러 사용자를 위해 값을 생성하는 데 사용할 수 있습니다.

이 명령의 Oracle 구문은 복잡하지만 Toad는 마우스 단추를 한 번 눌러 Create sequence 명령을 생성할 수 있습니다.

새 시퀀스를 작성하려면

  1. Database|Create 메뉴에서 Sequence를 선택합니다.

또는

Schema Browser|Sequences 페이지에서 Create New Sequence 단추를 누릅니다.

  2. 시퀀스 정보를 입력합니다.

  3. 아니면 Add to PM 확인란을 선택하여 Project Manager에 개체를 추가합니다.

  4. Execute 단추를 눌러 시퀀스를 작성합니다.

관련 항목

시퀀스

시퀀스 변경

시퀀스 내보내기


Alter Sequence

이 대화 상자를 사용하면 시퀀스를 수정하거나 다시 작성할 수 있습니다. 이 대화 상자에 액세스하려면

Schema Browser에서 시퀀스 드롭다운 항목 또는 탭을 선택합니다.

시퀀스를 수정하려면

  1. Objects Panel에서 sequence를 선택합니다..

  2. Details Panel에서 Modify 또는 Recreate를 누릅니다..

  • Modify는 기존 시퀀스를 조정합니다.

  • Recreate는 시퀀스를 삭제하고 다시 작성한 후 권한을 다시 부여합니다.

주: Alter Sequence는 Objects Panel 도구 모음이나 마우스 오른쪽 단추 메뉴에서도 사용할 수 있습니다.

  3. 원하는 Start With, Max Value, Increment By, Cycle 및 Number to Cache 옵션을 선택한 후 Execute를 누릅니다.

관련 항목

Sequences

시퀀스 작성

시퀀스 내보내기


Schema Browser: Snapshots

Schema Browser: Snapshots/M-Views

구체화된 보기는 스냅숏과 같은 의미입니다. Oracle 8i에서 이 개체 이름이 변경되었기 때문에 8i 이전의 데이터베이스에 연결하는 경우에는 캡션이 Snapshot으로 표시되고 8i 이상에 연결하는 경우에는 캡션이 Materialized View로 표시됩니다.

스냅숏(Oracle 8i 이상의 경우에는 구체화된 보기)을 만들거나 삭제할 수 있습니다. 또한 세부 정보를 보고 여러 스냅숏을 선택할 수 있습니다.

Create Snapshots/M-View 항목을 참조하십시오.

Objects 패널

Objects 패널에는 선택한 스키마에 있는 스냅숏의 목록이 표시됩니다.

구체화된 보기의 여러 유형과 상태는 다양한 아이콘으로 구분됩니다. 자세한 내용은 Icon Legend를 참조하십시오.

Snapshots 도구 모음

단추 | 명령
 | Create script - 선택한 스냅숏의 SQL 스크립트를 만들고 클립보드에 복사합니다.
 | Create new snapshot - 새 스냅숏(구체화된 보기)을 만들 수 있는 Snapshots/M-Views 창이 표시됩니다. 자세한 내용은 Create Snapshot/M-View를 참조하십시오.
 | Alter snapshot - 이전에 만든 스냅숏을 수정할 수 있는 Snapshots/M-Views 창이 표시됩니다. Alter Snapshot을 참조하십시오.
 | Refresh snapshot - Oracle의 스냅숏 데이터를 새로 고치는 SQL 스크립트를 실행합니다.
 | Filter snapshots list - 개체 목록을 필터링할 수 있는 Browser Filters 창이 열립니다. 필터가 사용 중이면 아이콘이 빨간색으로 바뀝니다.
 | Drop snapshot - 선택한 스냅숏을 삭제합니다.

Details 패널

Details 패널에는Info, Snapshot Query, Script 및 Data 탭이 있습니다.

관련 항목

Create Snapshot/M-View

Alter Snapshot/M-View

Snapshots/Materialized View Logs

Refresh Options


Snapshots 팝업 메뉴

Snapshot 페이지의 팝업 메뉴에는 도구 모음에 있는 것과 같은 명령이 많이 있습니다. 또한 다음을 수행할 수 있습니다.

Compile snapshot

이 명령을 사용하여 스냅숏/구체화된 보기의 유효성을 명시적으로 검사할 수 있습니다. Oracle의 compile 절을 사용하면 스냅숏이 종속된 개체가 삭제 또는 수정된 경우 스냅숏을 질의 다시 쓰기에 적합하게 만들 수 있습니다. 구체화된 보기의 유효성을 검사하지 못하면 새로 고치거나 질의 다시 쓰기에 사용할 수 없습니다.

Format Snapshot Query

이 명령은 오른쪽 Query 탭에 있는 스냅숏 질의에 서식을 지정합니다.

Save As

이 항목은 스냅숏의 데이터를 파일로 내보냅니다. 내보내기에 대한 자세한 내용은 Save Grid Contents를 참조하십시오.

Refresh Options

데이터 집합 새로 고침 옵션은 Data 탭에서 간단하게 변경할 수 있습니다. 자세한 내용은 Refresh Options를 참조하십시오.


창: 스냅샷/M 보기 작성

스냅샷/M 보기 작성

Snapshot/M-View 창에서 스냅샷을 작성, 업데이트 또는 수정할 수 있습니다.

스냅샷(M 보기라고도 함)은 기본적으로 표의 일부(서브셋) 또는 전체 사본입니다. 사용자가 행 삽입, 수정 또는 삭제할 수 있도록 Toad 스냅샷을 읽기 전용 또는 업데이트가 가능하도록 설정할 수 있습니다. 스냅샷은 마스터 표와 동일한 데이터베이스 또는 다른 데이터베이스에 저장할 수 있습니다.

스냅샷/M 보기를 작성하려면

  1. Database|Create 메뉴에서 Snapshot/M-View를 선택합니다.

또는

Schema Browser|Snapshots 페이지에서 Create New Snapshot 단추를 누릅니다.

  2. 드롭다운을 눌러 새 스냅샷의 Schema를 선택합니다.

  3. Name 텍스트 상자에 새 스냅샷의 이름을 입력합니다.

  4. Show SQL 단추를 눌러 해당하는 Create SQL 구문을 표시합니다. Clipboard 단추를 눌러 구문을 클립보드에 복사하거나 Save to File 단추를 눌러 저장합니다.

  5. 아니면 Add to PM 확인란을 선택하여 Project Manager에 개체를 추가합니다.

  6. 창의 4개 탭을 사용하여 이 영역에 스냅샷에 대한 정보를 입력합니다.창에는 다음과 같은 4개의 탭이 있습니다.

  7. Snapshot Info

  8. Physical Attributes

  9. Snapshot SubQuery

  10. Partitions

Snapshot Info 탭

Cluster 확인란

표시되어 있으면 Toad가 지정한 클러스터의 일부로 스냅샷을 작성합니다.

Cluster 상자

여기에 클러스터 이름을 입력합니다.

Cluster 목록 상자

여기에 클러스터 열이 표시됩니다. Add, Edit 및 Delete 단추로 이 목록을 수정할 수 있습니다.

Tablespace 드롭다운

스냅샷을 작성할 표 공간을 선택합니다.

Logging 확인란

표시되어 있으면 Toad가 반복 로그 파일에 스냅샷, 파티션 또는 LOB 저장 특징을 기록합니다.

Cache 확인란

표시되어 있으면 표 스캔을 수행할 때 버퍼 캐시에 데이터 블럭이 저장됩니다.

Parallel 확인란

표시되어 있으면 스냅샷이 병렬 처리됩니다.

Parallel number 상자

Parallel 확인란이 표시되어 있으면 입력 상자가 활성화됩니다. 병렬 처리의 정도(사용된 스레드 수)를 입력하거나 위쪽/아래쪽 화살표를 사용하여 숫자를 스크롤합니다.

Using Index 확인란

표시되어 있으면 Toad에서 스냅샷 색인의 매개 변수를 지정할 수 있습니다. 이 옵션이 표시되어 있으면 드릴다운 단추가 활성화됩니다. 드릴다운 단추를 누르면 Physical Attributes 창이 열립니다.

Allow Updates 확인란

표시되어 있으면 스냅샷(읽기/쓰기)을 업데이트할 수 있습니다. 표시되어 있지 않으면 스냅샷이 읽기 전용입니다.

Enable Query Rewrite 확인란

표시되어 있으면 질의 재작성을 위해 스냅샷이 활성화됩니다.

Build 확인란

표시되어 있으면 스냅샷을 채우는 시점을 지정할 수 있습니다. 표시되어 있으면 라디오 단추가 활성화됩니다. Immediate 또는 Deferred 구성을 선택할 수 있습니다. Immediate는 스냅샷을 즉시 채우고 Deferred는 다음 새로 고침 도중 스냅샷을 채웁니다.

On Prebuilt Table 확인란

표시되어 있으면 미리 초기화된 스냅샷에 표가 등록됩니다. 표 및 스냅샷은 동일한 이름이어야 합니다. 표시되어 있으면 라디오 단추가 활성화됩니다. Without Reduced Precision을 선택할 경우 표 또는 스냅샷 열의 정확성이 하위 질의 결과의 정확성과 완전히 일치해야 합니다. With Reduced Precision을 선택할 경우 표 또는 스냅샷 보기 열의 정확성이 하위 질의 결과와 완전히 일치하지 않아도 됩니다.

Refresh 확인란

표시되어 있으면 Oracle이 스냅샷을 자동으로 새로 고치는 방식을 사용자 정의할 수 있습니다. 표시되어 있으면 새로 고침 옵션이 활성화됩니다.

Never Refresh 확인란

표시되어 있으면 스냅샷이 자동으로 새로 고쳐지지 않습니다.

Refresh 옵션

  • Fast -마스터/세부 사항 표와 관련된 스냅샷 로그의 데이터만 업데이트합니다.

  • Complete - 스냅샷 보기를 다시 실행합니다.

  • Force - 빨리 새로 고칠 수 있을 경우 Fast 새로 고침을 수행하고 그렇지 않으면 Complete 새로 고침을 수행합니다.

On Demand 확인란

On Commit 확인란과 함께 동시에 적용할 수 없습니다. 표시되어 있으면 요청 시 스냅샷이 새로 고쳐집니다.

On Commit 확인란

On Demand 확인란과 함께 동시에 적용할 수 없습니다. 표시되어 있으면 다음 실행 도중 스냅샷이 자동으로 새로 고쳐집니다.

Date

  • Start With - Next 확인란과 함께 동시에 적용할 수 없습니다. 표시되어 있으면 드롭다운을 사용하여 처음 자동 새로 고침 시간의 날짜를 선택한 달력을 올립니다.

  • Next - Start With 확인란과 함께 동시에 적용할 수 없습니다. 표시되어 있으면 드롭다운을 사용하여 자동 새로 고침 간의 간격을 계산하기 위해 날짜를 선택한 달력을 올립니다.

With

  • Primary Key 라디오 단추 - 선택되어 있으면 기본 키 스냅샷이 작성됩니다.

  • Rowid 라디오 단추 - 선택되어 있으면 RowID 스냅샷이 작성됩니다.

  • Rollback Segment 확인란 - 여기서 사용할 롤백 세그먼트를 지정할 수 있습니다. 표시되어 있으면 Master 및 Local 라디오 단추를 활성화합니다.

  • Master 라디오 단추 - Rollback Master 옵션이 선택되어 있으면 원격 롤백 세그먼트가 스냅샷의 원격 마스터에서 사용됩니다.

  • Local 라디오 단추 - Rollback Local 옵션이 선택되어 있으면 원격 롤백 세그먼트가 로컬 새로 고침 그룹의 스냅샷에 사용됩니다.

  • Default Segment 확인란 - 표시되어 있으면 스냅샷이 기본 롤백 세그먼트를 사용합니다. 표시되어 있지 않으면 Rollback Segment 상자가 활성화됩니다.

  • Rollback Segment 상자 - 이 상자는 Default Segment 확인란이 표시되어 있지 않으면 활성화됩니다. 사용할 롤백 세그먼트를 입력합니다.

Physical Attributes 탭

Physical Attributes 탭의 드롭다운 및 값 상자를 사용하여 백분율, 저장 범위 및 버퍼 풀 등의 물리적 옵션을 정의할 수 있습니다.

Snapshot/MView Subquery 탭

여기에 스냅샷 생성을 위해 사용할 하위 질의를 입력합니다.

Partitions 탭

이 탭을 활성화하려면 Snapshot Subquery 탭에 유효한 하위 질의를 입력해야 합니다. Available Columns 목록에서 열을 선택하여 파티션의 기준 열을 결정합니다. 열 이름을 두 번 누르거나 열을 누르고 오른쪽 화살표를 눌러 선택한 열을 Partitions Columns 목록으로 이동합니다.

Add a Partition

기준으로 지정할 파티션에 대한 열을 선택한 다음 파티션을 추가할 수 있습니다.

  • Range Partitions 범위 파티션의 경우 Add 단추를 눌러 이 작업을 수행할 수 있습니다. Add Partition 대화상자가 나타나며, 여기서 파티션 이름을 입력할 수 있습니다. 파티션 내의 각 열에 대한 상위 범위를 입력하거나 대화상자의 드롭다운 목록에서 Maxvalue를 선택합니다.

주: 문자열 상한 경계값은 눈금 안에 작은따옴표로 묶여 있어야 합니다(예를 들어, varchar2 데이터 형식의 Last Name 열의 경우 상한 경계값이 'Smith'가 될 수 있음). 작은따옴표는 눈금 안에 입력해야 합니다.

  • Hash Partitions 해시 파티션을 추가하려면 대화상자 아래의 Hash Partitions 탭을 선택한 다음 해시 파티션에 사용할 표 공간을 파티션 영역으로 이동합니다.

  • Subpartitions 해시 또는 목록에 하위 파티션을 추가할 수도 있습니다.

관련 항목

스냅샷

스냅샷/M 보기 변경

Snapshots/Materialized View 로그


Alter Snapshot

작성한 스냅숏을 수정할 수 있습니다.

스냅숏을 수정하려면

  • Schema Browser|Snapshots 페이지에서 수정할 스냅숏을 선택합니다. 도구 모음에서 Alter Snapshot [image] 단추를 누릅니다. Alter Snapshot 창이 나타납니다.

이 창에는 Snapshot Info, Physical Attributes, Partitions 및 Subpartition Templates의 세 탭이 있습니다.

Snapshot Info

이 탭에서 아래 설명과 같이 새로 고침 모드 정보를 수정할 수 있습니다.

Refresh 옵션

  • Fast - 스냅숏 로그에서 마스터/세부 정보 테이블과 연결된 스냅숏 로그만 업데이트합니다.

  • Complete - 스냅숏 보기를 다시 실행합니다.

  • Force - 고속 새로 고침을 사용할 수 있는 경우 고속 새로 고침을 수행하고, 그렇지 않은 경우 전체 새로 고침을 수행합니다.

Date

  • Start - 이 옵션을 선택하면 드롭다운을 사용하여 첫 번째 자동 새로 고침 시간의 날짜를 선택할 달력을 표시할 수 있습니다.

  • Next - 이 항목을 선택하면 날짜를 입력하여 자동 새로 고침 사이의 간격을 계산할 수 있습니다.

With

  • Primary Key - 이 항목을 선택하면 primary 키 스냅숏이 작성됩니다.

  • Rowid - 이 항목을 선택하면 rowid 스냅숏이 작성됩니다.

Physical Attributes

Physical Attributes 탭에는 여유 공간 비율, 저장소 범위, 버퍼 풀 등의 물리적 옵션을 수정할 수 있는 드롭다운 목록과 값 상자가 포함되어 있습니다.

파티션

기반이 될 파티션의 칼럼을 선택하고 나면 파티션을 첨부할수 있습니다.

파티션 범위 지정

Add 단추를 클릭하여 파티션 범위를 지정할 수 있습니다. Add Partition 대화 상자가 나타나면 파티션 이름을 입력할 수 있습니다. 파티션 내의 각 열에서 위쪽 범위를 입력하거나 대화 상자에 있는 드롭다운 목록에서 Maxvalue를 선택해야 합니다.

주: 문자열 값 상한은 그리드에서 작은 따옴표로 묶어야 합니다. 예를 들어 데이터 형식이 varchar2인 Last Name 열에서 상한은 'Smith'가 될 수 있습니다. 작은 따옴표는 그리드 안에 입력해야 합니다.

해시 파티션

해시 파티션을 추가하려면 대화 상자 맨 아래에 있는 Hash Partitions 탭을 선택한 후 해시 파티션에 사용할 테이블 공간을 파티션 영역으로 이동합니다.

하위 파티션

해시 또는 목록에 하위 파티션을 추가할 수도 있습니다.

Subpartition Template

Subpartition Templates를 사용하여 하위 파티션을 지원하는 모든 Oracle 버전에 하위 파티션을 작성할 수도 있습니다. Oracle은 9iR2에서 이 기능을 지원하며, 9iR2 데이터베이스에 연결되어 있으면 create table 문에 subpartition template 절도 추가됩니다.

Snapshot Query

이 기능을 사용하면 스냅숏 생성에 사용되는 하위 질의를 볼 수 있습니다. 이 화면은 수정할 수 없습니다.

관련 항목

스냅숏

Create Snapshot/M-View

Snapshots/Materialized View 로그


Schema Browser: Snapshot Log

Schema Browser: Snapshot/Materialized View Logs

구체화된 보기는 스냅숏과 같은 의미입니다. Oracle 8i에서 이 개체 이름이 변경되었기 때문에 8i 이전의 데이터베이스에 연결하는 경우에는 캡션이 Snapshot으로 표시되고 8i 이상에 연결하는 경우에는 캡션이 Materialized View로 표시됩니다.

스냅숏(Oracle 8i 이상의 경우에는 구체화된 보기 로그) 로그를 만들거나 삭제할 수 있습니다. 또한 세부 정보를 보고 여러 스냅숏 로그를 선택할 수 있습니다.

Objects 패널

Objects 패널에는 선택한 스키마에 있는 스냅숏 로그 목록이 표시됩니다.

스냅숏 로그의 여러 유형과 상태는 다양한 아이콘으로 구분됩니다. 자세한 내용은 Icon Legend를 참조하십시오.

Snapshot Logs 도구 모음

단추 | 명령
 | Create script - 선택한 스냅숏 로그의 SQL 스크립트를 만들고 클립보드에 복사합니다.
 | Create new snapshot log - 새 스냅숏(구체화된 보기) 로그를 만들 수 있는 Snapshots/M-View Logs 창이 표시됩니다. 자세한 내용은 Create Snapshot/M-View Logs를 참조하십시오.
 | Alter snapshot log - 이전에 만든 스냅숏을 수정할 수 있는 Snapshots/M-Views 창이 표시됩니다. Alter Snapshot Logs를 참조하십시오.
 | Filter snapshot log list - 개체 목록을 필터링할 수 있는 Browser Filters 창이 열립니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Drop snapshot log - 선택한 스냅숏 로그를 삭제합니다.

Details 패널

Details 패널에는Info 및 Script 탭이 있습니다.

관련 항목

Snapshot Logs

Alter Snapshot Logs

스냅숏 로그 작성

Snapshots


Snapshot Logs

스냅숏 로그는 스냅숏의 마스터 테이블에 연결된 테이블입니다. 여기에는 스냅숏을 새로 고치는 데 사용되는 연결된 마스터 테이블의 변경에 관한 정보가 포함되어 있습니다. Oracle에서는 빠른 새로 고침이 있는 스냅숏을 지원하는 모든 마스터 테이블에 대해 스냅숏 로그가 있어야 합니다.

Database|Create|Snapshot Log에서 Create Snapshot/MView Logs 대화 상자에 액세스하거나 Schema Browser의 Snapshot Logs 도구 모음에 있는 New Snapshot Log 단추를 누릅니다. 나머지 상자가 채워져 스냅숏 로그를 작성합니다(아래 설명 참조).

스냅숏 로그를 설정하는 동안 대화 상자 맨 아래의 ShowSQL을 누르면 언제든지 SQL을 볼 수 있습니다. Show SQL 창에서는 SQL을 Editor로 이동하거나 클립보드에 복사할 수 있습니다.

적절한 옵션을 모두 선택하고 나면 대화 상자의 맨 아래에 있는 OK를 눌러 생성된 SQL을 실행하고 로그 파일을 즉시 작성할 수 있습니다.

Schema

로그를 작성할 스키마를 선택합니다. 마스터 테이블과 같은 스키마에 있어야 합니다.

Snapshot/MView Log 탭

Table

로그의 테이블 이름을 입력합니다.

Tablespace

로그를 저장할 테이블 공간을 선택합니다.

Logging 및 Cache 확인란

이러한 옵션은 Oracle 버전 8 이상에서만 사용할 수 있습니다.

New Values

새 값을 포함 또는 제외하려면 선택합니다.

With

WITH 절에 포함할 항목을 선택합니다. Rowid, Primary Key, Object ID 및 Sequence를 포함할 수 있습니다. 열을 지정할 수도 있습니다.

Physical Attributes

Percent Free 입력란

데이터 블록에서 업데이트용으로 예약된 공간의 백분율입니다.

Percent Used 입력란

Oracle에서 테이블의 각 데이터 블록에 대해 유지하는 사용된 공간의 최소 백분율입니다.

Initial Trans 입력란

테이블에 할당된 각 데이터 블록 내에 할당되는 트랜잭션 항목의 초기 수를 지정합니다.

Max Trans 입력란

이 입력란은 테이블에 할당된 데이터 블록을 업데이트할 수 있는 최대 동기 트랜잭션 수를 지정합니다.

Storage options

Oracle 기본값에서 저장소 옵션을 변경해야 하는 경우에는 여기에서 변경할 수 있습니다.

Partitions

열을 파티션 열로 만들려면 사용 가능한 열에서 선택한 후 화살표 단추를 사용하여 선택한 열을 Partition 열 창으로 이동합니다.

탭 맨 아래에 있는 하위 탭에서 범위 또는 해시 파티션을 추가, 편집 또는 삭제합니다.

Subpartition Templates

하위 파티션 템플릿을 사용하여 하위 파티션을 지원하는 모든 Oracle 버전에 하위 파티션을 작성할 수 있습니다. Oracle은 9iR2에서 이러한 기능을 지원하며, 9iR2 데이터베이스에 연결되어 있으면 create table 문에 subpartition template 절도 추가됩니다.

관련 항목

Schema Browser: Snapshot Logs

Alter Snapshot Logs

스냅숏 로그 작성

Snapshots


스냅샷 로그 작성

스냅샷 로그는 스냅샷의 마스터 표와 연관된 표입니다. 이 로그에는 스냅샷을 새로 고치는 데 사용하는 관련 마스터 표의 변경 내용이 들어 있습니다. Oracle에서는 빨리 새로 고칠 수 있는 스냅샷을 지원하는 모든 마스터 표의 스냅샷 로그가 필요합니다.

스냅샷/MView 로그를 작성하려면

  1. Database|Create 메뉴에서 Snapshot Log를 선택합니다.

  2. 아래에 설명된 대로 상자에 기입하여 스냅샷 로그를 작성합니다.

  3. Schema - 로그를 작성할 스키마를 선택합니다.

  4. Tablename - 로그의 표 이름을 입력합니다.

  5. Tablespace - 이 드롭다운에서 저장할 표 공간을 선택합니다.

  6. Logging 및 Cache 확인란 - 이 옵션은 Oracle 버전 8 이상에서만 사용할 수 있습니다.

  7. Percent Free 항목 상자 - 업데이트에 예약되는 데이터 블럭의 공간 비율입니다.

  8. Percent Used 항목 상자 - Oracle이 표의 데이터 블럭마다 유지하는 공간의 최소 비율입니다.

  9. Initial Trans 항목 상자 - 표에 할당되어 있는 각 데이터 블럭 내에 할당된 트랜잭션 항목의 초기 수를 지정합니다.

  10. Max Trans 항목 상자 - 표에 할당되어 있는 데이터 블럭을 업데이트할 수 있는 최대 동시 트랜잭션 수를 지정합니다.

  11. Storage - 이 드롭다운에서 새 스냅샷 로그의 저장 매개 변수를 선택할 수 있습니다.

  3. 아니면 Add to PM 확인란을 선택하여 Project Manager에 개체를 추가합니다.

  4. Show SQL 단추를 눌러 명령을 실행하기 전에 SQL을 표시합니다. 나타나는 대화상자에서 SQL을 클립보드나 파일에 저장하거나 창을 닫아도 됩니다.

  5. OK를 눌러 스냅샷 로그를 작성합니다.

관련 항목

Snapshots/Materialized View 로그

스냅샷 로그

스냅샷 로그 변경

스냅샷


Alter Snapshot Logs

이 대화 상자에서 이전에 작성된 스냅숏 로그의 정의 중 일부를 수정할 수 있습니다.

스냅숏 로그를 수정하려면

  1. Schema Browser|Snapshot Logs 페이지에서 로그를 선택하고 도구 모음에 있는 Alter Snapshot Log [image] 단추를 누릅니다.

  2. 변경이 완료되면 다음을 수행할 수 있습니다.

  3. Show SQL을 눌러 생성된 SQL을 Editor나 클립보드에 복사합니다.

  4. OK를 눌러 Alter 대화 상자에서 코드를 실행합니다.

Snapshot/MView Log 탭

이 탭에서 다음 정보를 수정할 수 있습니다.

  • Tablespace - 로그를 저장할 테이블 공간을 변경합니다.

  • Logging and Cache 확인란 - 이러한 옵션은 Oracle 버전 8 이상에서만 사용할 수 있습니다.

  • New Values - 새 값을 포함 또는 제외하려면 이 항목을 선택합니다.

  • With - WITH 절에 새 항목을 추가할 수 있습니다. WITH 절에서 항목을 제거할 수는 없습니다.

Physical Attributes

이 탭에서는 로그 파일의 물리적 특성 중 일부를 변경할 수 있습니다. 예를 들어 여유 공간 백분율과 사용 공간 백분율을 변경할 수 있습니다.

Partitions

이 탭에서 로그의 파티션을 추가, 편집 또는 분할할 수 있습니다.

관련 항목

Snapshots/Materialized View 로그

스냅숏 로그

스냅숏 로그 작성

스냅숏


Schema Browser: Synonyms

Objects 패널

Objects 패널에는 사용 가능한 동의어 목록과 이 개체 작업에 사용할 명령 도구 모음이 있습니다.

동의어의 여러 유형과 상태는 다양한 아이콘으로 구분됩니다. 자세한 내용은 Icon Legend를 참조하십시오.

Synonyms 도구 모음

단추 | 명령
 | Create script - 선택한 동의어에 대해 Create Public Synonym 스크립트를 작성하여 복사합니다.
 | Create new synonym - Create Synonym 창이 열립니다.
 | Filter synonyms list - 개체 목록을 필터링할 수 있는 Browser Filters 창이 열립니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Save list to file for syntax highlighting - 구문 강조표시 파일에 동의어 목록을 저장합니다. 저장하기 전에 확인 대화 상자가 나타납니다. 이 목록에 대한 자세한 내용은 Syntax Highlighting을 참조하십시오.
 | Drop Synonym - 선택한 동의어를 삭제합니다.

Details 패널

Details 패널에는 Columns, Source, Data, Grants, Deps(Uses) 및 Deps(Used by) 탭이 있습니다.


Schema Browser: System Privileges

Objects 패널

Objects 패널에는 사용 가능한 시스템 권한 목록과 이 개체 작업에 사용할 명령 도구 모음이 있습니다.

Sys Privs 도구 모음

단추 | 명령
 | Create script - 선택한 권한에 대한Create System Privileges 스크립트를 만들어 복사합니다.
 | Configure grantees - 선택한 권한의 Grants 창이 열립니다. 이 창에서 해당 상자를 선택하거나 선택 취소하여 선택한 사용자의 권한을 부여 또는 해지할 수 있습니다. 선택한 역할에도 같은 작업을 수행할 수 있습니다.
 | Filter system privileges - 개체 목록을 필터링할 수 있는 Browser Filters 창이 열립니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.

Details 패널

주: Configure grantees는 Quest DBA 모듈에서만 사용할 수 있습니다.

Details 패널에는 권한을 부여 받는 사람이 나열되며 선택한 시스템 권한의 스크립트를 표시하는 탭이 있습니다.


권한 부여 구성

System Privileges 창을 사용하면 선택한 사용자에게서 선택한 권한을 부여하거나 해지할 수 있습니다. 선택한 역할에도 같은 작업을 수행할 수 있습니다.

권한을 부여 또는 해지하려면

  1. Schema Browser의 System Privileges 페이지에서 권한을 선택합니다.

  2. Configure Grantees [image] 단추를 누릅니다.

  3. 적절한 상자를 선택 또는 선택 취소하여 사용자 또는 역할의 권한을 부여 또는 해지합니다.


Schema Browser: Tables

Objects 패널

Objects 패널에는 현재 스키마에 있는 테이블과 명령 도구 모음이 나열됩니다.

테이블 목록

테이블의 여러 유형과 상태는 테이블 이름 앞에 있는 다양한 아이콘으로 구분됩니다. 자세한 내용은 Icon Legend를 참조하십시오.

테이블이 두 개 이상의 유형에 해당되지만 여백에 여러 아이콘 중 하나만 표시되는 경우가 있습니다. 이 경우에는 우선 순위가 제일 높은 아이콘이 표시됩니다. 예를 들어 분할된 스냅숏 테이블은 스냅숏 아이콘을 표시합니다.

테이블에 대한 자세한 내용은 Create Table 항목을 참조하십시오.

주: Advanced Queuing 테이블은 Schema Browser의 Tables 페이지에 나열되지 않습니다. Advanced Queuing 테이블에 대한 자세한 내용은 Queue Table을 참조하십시오.

Tables 도구 모음

단추 | 명령
 | Create SQL script - 선택한 테이블의 SQL 스크립트를 만들어 복사합니다. 그런 다음 Editor에 붙여넣을 수 있습니다.
 | Create table - Create Table 대화 상자를 호출하려면 Create Table을 누릅니다.
 | Modify table - 선택한 테이블의 Alter table 대화 상자를 표시하려면 테이블을 선택한 후 이 아이콘을 누릅니다.
 | Generate a file of INSERT statements for selected table - 파일에 있는 데이터를 클립보드나 파일로 내보내려면 테이블을 선택한 후 이 아이콘을 누릅니다. 이 기능이 작동하는 방식에 대한 자세한 내용은 Data Export를 참조하십시오.
 | Open table in ER diagram - 테이블을 선택하고 이 아이콘을 누르면 Toad에서는 열려는 참조 테이블의 수를 지정할 수 있으며 ER Diagram에서 테이블이 열립니다.
 | Add or edit privileges - Privileges 창이 표시됩니다.
 | Add constraint - Create Constraint 대화 상자를 표시하려면 테이블을 선택하고 Add constraint를 누릅니다. 자세한 내용은 Create Constraint 항목을 참조하십시오.
 | Analyze table - 이 대화 상자를 사용하면 테이블 개체 목록에서 선택한 테이블을 분석할 수 있습니다. 그러면 통계를 수집하여 비용 기반 질의 최적화를 사용할 수 있습니다. 그러므로 Optimizer에서 질의를 더 잘 실행할 수 있습니다. 통계를 추정하거나(계산보다 빠름) 통계를 계산하거나 현재 통계를 삭제할 수 있습니다.
 | Add synonym - 선택한 테이블에 동의어를 추가합니다.
 | Filter the table list - 개체 목록을 필터링할 수 있는 Browser Filters 창이 열립니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Rebuild table - Rebuild Table을 누르면 Rebuild Table 창이 표시됩니다. 자세한 내용은 Rebuild Table 항목을 참조하십시오. 주: 찾고 있는 스키마에서 테이블을 다시 작성하려면 해당 스키마를 소유하고 있어야 합니다.
 | Compile dependencies - 선택한 프로시저, 함수 또는 패키지에서 종속 프로시저를 컴파일할 수 있습니다. 프로시저를 선택한 후 도구 모음에서 Compile Dependent Procedures 아이콘을 누릅니다. 첫 번째 프로시저에 종속된 모든 프로시저가 다시 컴파일됩니다. 종속 프로시저의 컴파일에 대한 자세한 내용은 종속 관계를 참조하십시오.
 | Drop selected table - 선택한 테이블을 삭제합니다.
 | Remove all data from selected table - Truncate Table을 수행하려면 테이블을 선택하고 이 아이콘을 누릅니다.

Details 패널

Details 패널에서 선택한 테이블의 데이터를 보거나 편집할 수 있습니다. 또한 색인, 제약 조건, 트리거, 부여, 동의어, 파티션, 참조 테이블 상태 등 여러 정보를 볼 수 있습니다.

Data 탭 도구 모음

그리드 편집 내용을 데이터베이스에 적용합니다.

data 그리드를 필터링하고 정렬 기준을 설정합니다.

첫 번째 레코드로 이동합니다.

이전 레코드로 이동합니다.

다음 레코드로 이동합니다.

마지막 레코드로 이동합니다.

레코드를 삽입합니다.

레코드를 삭제합니다.

그리드 편집을 게시합니다.

그리드 편집을 취소합니다.

그리드를 새로 고칩니다.

Columns 탭 도구 모음

단추 | 명령
 | 테이블의 끝에 열을 추가합니다.
 | 테이블에서 열을 삭제합니다.
 | 모든 필터를 지웁니다.

관련 항목

Alter Table

Create Table Like

Create Table

Column Definition

Table Script Creation

Tables - Data Grids


창: 표 작성

표 작성

주: Toad는 이번에는 다음 기능을 지원하지 않습니다. 외부 키 참조, LOB 저장 및 Varray.

이 창에서 새 Oracle 표를 작성할 수 있습니다.

탭과 옵션은 작성 중인 표의 종류에 따라 약간 다릅니다.

  • 표준 표, 색인 구성 표 및 클러스터 표 - 표준 작성 표 참조

  • 전체 임시 표 - 전체 임시 표 참조

  • 고급 대기열 표 - 대기열 표 작성 참조

  • 외부 표 - 외부 표 참조

표를 작성하려면

  1. Database|Create 메뉴에서 Table을 선택합니다.

또는

Schema Browser|Tables 페이지에서 Create Table 단추를 누릅니다.

  2. Table Name 상자에서 표 이름을 입력합니다.

  3. Table Types에 설명된 대로 표 형식을 선택합니다.

주: Schema 상자에 드롭다운이 있습니다. Name 상자에 표 이름을 입력한 다음 이름을 눌러 표 형식을 선택합니다.

  3. 탭을 사용하여 표를 정의합니다.

  4. Columns

  5. Physical Attributes

  6. Additional Attributes

  7. Constraints

  8. Partitions

  9. Subpartition Template

  10. Comments

  4. 아니면 Add to PM 확인란을 선택하여 Project Manager에 개체를 추가합니다.

  5. Execute 단추를 눌러 표를 작성합니다.

관련 항목

스키마 브라우저: 표

표 변경

표 작성

대기열 표 작성

열 정의

표 스크립트 작성

표 - 데이터 눈금


Table Types

Table Type에는 선택하면 관련 매개 변수 옵션을 활성화 또는 비활성화하는 라디오 단추가 포함됩니다.

Standard Table

일반적인 표를 원할 경우 Standard Table을 선택합니다.

Global Temporary Table

데이터가 현재 세션에서만 보이는 표를 원할 경우 이 표를 선택합니다.

Index Organized Table

데이터 행이 기본 키 색인에 저장되는 표를 원할 경우 이 표를 선택합니다.

Clustered Table

클러스터의 일부인 표를 원할 경우 이 표를 선택합니다.

Advanced Queuing

향상된 대기열 표를 작성하고자 할 경우 이 표를 선택합니다. 향상된 대기열 표에 대한 자세한 내용은 대기열 표 작성을 참조하십시오.

External

External 표는 Oracle 9i 이상 버전만 사용해야 작성할 수 있습니다. 자세한 내용은 External Tables를 참조하십시오.

관련 항목

표 작성


파일에서 열 로드

테이블의 열을 수동으로 입력하는 대신에 파일에서 로드할 수 있습니다.

파일에서 열을 로드하려면

  1. Create Table 창에서 Load Columns from File 단추를 누릅니다.

  2. 데이터가 있는 파일의 형식을 선택합니다.

  3. XLS file

  4. Delimited text file

  5. MS Access DB file

  3. 파일 이름을 입력하거나 드릴다운 [image] 단추를 누르고 파일을 선택합니다.

  4. MS Access 데이터베이스를 소스로 사용하는 중이면 테이블 상자에서 소스 테이블을 선택합니다.

  5. OK를 눌러 열을 가져옵니다.

주: Clear all Columns를 누르면 테이블에 입력한 모든 열이 지워집니다.

관련 항목

테이블 만들기


표 작성

작성

Schema Browser|Tables 페이지에서 다른 표를 기반으로 표를 작성할 수 있습니다.

다른 표를 기반으로 표를 작성하려면

  1. Schema Browser에서 Tables 페이지를 선택합니다. 새 표의 템플릿으로 사용할 표를 선택합니다.

  2. 선택한 table에 마우스 오른쪽 단추를 누르고 메뉴에서 Create Like를 선택합니다. Name 상자가 선택되고 템플릿 표에 정보가 입력된 상태로 Table 대화상자가 나타납니다.

  3. 새 표에 사용할 name을 입력합니다.

  4. 이제 Create Table 대화상자를 통해 모든 탭의 표를 변경할 수 있습니다.

  5. Show SQL을 눌러 표를 작성하는 데 사용할 SQL을 표시합니다.

  6. OK를 눌러 표를 작성합니다.

관련 항목

스키마 브라우저: 표

표 변경

표 작성

열 정의

표 스크립트 작성

표 - 데이터 눈금


Model Table 대화 상자

Model Table 대화 상자를 사용하면 SQL Model을 작성할 때 로드할 참조 테이블의 수준을 선택할 수 있습니다.

참조 테이블의 수를 입력하려면

  1. Schema Browser에서 Tables 페이지를 선택합니다.

  2. 테이블을 선택하고 Open in Query Builder [image] 단추를 누르거나 마우스 오른쪽 단추를 누르고 메뉴에서 Open in Query Builder를 선택합니다.

  3. referential tables 수를 입력하고 Close를 누릅니다. 대화 상자가 닫히고 선택한 테이블과 참조가 열린 Query Builder가 열립니다.


전역 임시 테이블 작성

전역 임시 테이블의 Create Table 창은 Columns, Organization 및 Comments의 세 탭으로 나뉩니다.

Show SQL 단추를 누르면 연결된 SQL 문을 포함하는 SQL Statement 창이 표시됩니다.

Columns 탭

Object Table

테이블이 개체 테이블인 경우 이 항목을 선택합니다.

Grid

  • State - 첫 번째 열은 상태 열입니다. 테이블 열의 상태를 비트맵을 사용하여 표시합니다. +(더하기)는 열 추가, -(빼기)는 열 삭제, 삼각형은 변경된 열, 거미줄은 사용되지 않는 열 설정을 나타냅니다.

  • Name - 테이블 열의 이름을 표시합니다. 새 테이블의 경우에는 이 위치에 테이블 이름을 입력합니다.

  • Data Type - 테이블 열의 데이터 유형을 표시합니다. 데이터 유형 드롭다운 목록에서는 기본 Oracle 데이터 유형을 먼저 표시하고, 다음으로 ANSI 데이터 유형을 표시하며, 그런 다음 Oracle 8을 사용하는 경우 사용자 정의 개체 유형을 표시합니다. 파선은 서로 다른 데이터 유형 그룹을 구분합니다. 새 테이블의 경우에는 드롭다운에서 데이터 유형을 선택합니다.

  • Size - 적용 가능한 경우 데이터 유형의 크기를 표시합니다. 드롭다운에서 선택한 데이터 유형에 따라 자동으로 생성되는 경우도 있습니다. 크기를 변경하려면 상자를 누르고 값을 입력하거나 위/아래 화살표를 사용하여 숫자를 스크롤합니다.

  • Precision - 적용 가능한 경우 데이터 유형의 정밀도를 표시합니다.

  • Scale - 적용 가능한 경우 데이터 유형의 배율을 표시합니다.

  • Not null - 상자를 눌러 선택/선택 취소합니다. 선택한 경우 열에는 Null 값을 넣을 수 없습니다.

  • Primary Key - 상자를 눌러 선택/선택 취소합니다. 선택한 경우 열은 Primary Key입니다.

  • Unique - 상자를 눌러 선택/선택 취소합니다. 선택한 경우 열에 고유한 제약 조건이 있습니다.

  • Ref - 상자를 눌러 선택/선택 취소합니다. 선택한 경우 데이터 유형은 ref 개체입니다. 개체 데이터 유형에만 적용됩니다.

  • Default - 새 행의 기본 열 값입니다. 상자 안을 누르면 기본 열 값을 입력할 수 있습니다.

  • Check Constraint - 열 제약 조건 식입니다. 상자 안을 누르면 제약 조건 식을 입력할 수 있습니다.

  • Comment - 열 주석입니다. 상자 안을 누르면 열에 대한 주석을 입력할 수 있습니다.

편집 단추

Add - 열 그리드에 새로운 빈 행을 추가합니다.

Drop - 선택한 열을 삭제합니다. Alter 기능에서는 삭제할 열을 표시합니다. 이 기능은 이 기능이 처음으로 도입된 Oracle 8.1.5 이상에서만 활성화되어 있습니다.

Unused - 선택한 열을 사용되지 않는 열로 설정합니다. Alter 기능에만 사용되며 Create Table 기능에서는 비활성화되어 있습니다. 이 기능은 이 기능이 처음으로 도입된 Oracle 8.1.5 이상에서만 활성화되어 있습니다.

바로 가기 키

명령 | 기능
<Ins> | 추가
<Ctrl><Del> | 삭제
<Home> | 그리드의 첫 번째 열로 이동
<End> | 그리드의 마지막 열로 이동
<Ctrl><Home> | 그리드의 첫 번째 행으로 이동
<Ctrl><End> | 그리드의 마지막 행으로 이동

Organization 탭

Organization 탭에는 주 창에서 테이블 유형을 선택하여 활성화 또는 비활성화되는 매개 변수 옵션이 포함되어 있습니다.

  • Cache - 캐시 기능을 선택하거나 선택 취소할 수 있습니다.

  • Global Temporary Parameters - Toad에서 커밋을 수행할 때 다음 중 하나를 수행하도록 할 수 있습니다.

  • Delete Rows

  • Preserve Rows

Comments 탭

주석 상자에 테이블에 대한 설명을 입력할 수 있습니다.


외부 테이블

외부 테이블은 Oracle 9i 이상에서만 사용할 수 있습니다.

외부 테이블의 Create Table 창은 Columns 및 External Properties의 두 탭으로 나뉩니다.

Show SQL 단추를 누르면 연결된 SQL 문을 포함하는 SQL Statement 창이 표시됩니다.

Columns 탭

Object Table

테이블이 개체 테이블인 경우 이 항목을 선택합니다.

Grid

  • State - 첫 번째 열은 상태 열입니다. 테이블 열의 상태를 비트맵을 사용하여 표시합니다. +(더하기)는 열 추가, -(빼기)는 열 삭제, 삼각형은 변경된 열, 거미줄은 사용되지 않는 열 설정을 나타냅니다.

  • Name - 테이블 열의 이름을 표시합니다. 새 테이블의 경우에는 이 위치에 테이블 이름을 입력합니다.

  • Data Type - 테이블 열의 데이터 유형을 표시합니다. 데이터 유형 드롭다운 목록에서는 기본 Oracle 데이터 유형을 먼저 표시하고, 다음으로 ANSI 데이터 유형을 표시하며, 그런 다음 Oracle 8을 사용하는 경우 사용자 정의 개체 유형을 표시합니다. 파선은 서로 다른 데이터 유형 그룹을 구분합니다. 새 테이블의 경우에는 드롭다운에서 데이터 유형을 선택합니다.

  • Size - 여기에는 적용 가능한 경우 데이터 유형의 크기를 표시합니다. 드롭다운에서 선택한 데이터 유형에 따라 자동으로 생성되는 경우도 있습니다. 크기를 변경하려면 상자를 누르고 값을 입력하거나 위/아래 화살표를 사용하여 숫자를 스크롤합니다.

  • Precision - 적용 가능한 경우 데이터 유형의 정밀도를 표시합니다.

  • Scale - 적용 가능한 경우 데이터 유형의 배율을 표시합니다.

  • Not null - 상자를 눌러 선택/선택 취소합니다. 선택한 경우 열에는 Null 값을 넣을 수 없습니다.

  • Primary Key - 상자를 눌러 선택/선택 취소합니다. 선택한 경우 열은 Primary Key입니다.

  • Unique - 상자를 눌러 선택/선택 취소합니다. 선택한 경우 열에 고유한 제약 조건이 있습니다.

  • Ref - 상자를 눌러 선택/선택 취소합니다. 선택한 경우 데이터 유형은 ref 개체입니다. 개체 데이터 유형에만 적용됩니다.

  • Default - 새 행의 기본 열 값입니다. 상자 안을 누르면 기본 열 값을 입력할 수 있습니다.

  • Check Constraint - 열 제약 조건 식입니다. 상자 안을 누르면 제약 조건 식을 입력할 수 있습니다.

  • Comment - 열 주석입니다. 상자 안을 누르면 열에 대한 주석을 입력할 수 있습니다.

편집 단추

Add - 열 그리드에 새로운 빈 행을 추가합니다.

Drop - 선택한 열을 삭제합니다. Alter 기능에서는 삭제할 열을 표시합니다. 이 기능은 이 기능이 처음으로 도입된 Oracle 8.1.5 이상에서만 활성화되어 있습니다.

Unused - 선택한 열을 사용되지 않는 열로 설정합니다. Alter 기능에만 사용되며 Create Table 기능에서는 비활성화되어 있습니다. 이 기능은 이 기능이 처음으로 도입된 Oracle 8.1.5 이상에서만 활성화되어 있습니다.

바로 가기 키

명령 | 기능
<Ins> | 추가
<Ctrl><Del> | 삭제
<Home> | 그리드의 첫 번째 열로 이동
<End> | 그리드의 마지막 열로 이동
<Ctrl><Home> | 그리드의 첫 번째 행으로 이동
<Ctrl><End> | 그리드의 마지막 행으로 이동

External Properties

이 화면을 사용하면 외부 테이블의 속성을 설정할 수 있습니다.

Access Driver

Access Driver의 기본값은 ORACLE_LOADER입니다.

Access Type

Access Type의 기본값은 CLOB입니다.

Default Directory

직접 기본 디렉토리를 설정할 수 있습니다. 드롭다운 목록에서 선택하거나 Create New Directory [image] 단추를 눌러 새 디렉토리를 작성합니다.

Locations

Oracle에서는 외부 테이블 작성에 사용되는 파일에 대해 여러 위치를 설정할 수 있습니다. 외부 테이블이 서버의 서로 다른 여러 디렉토리에 있는 여러 파일로 구성된 경우에는 이 영역을 사용하여 위치를 지정합니다.

Reject Limit

거부 제한은 외부 테이블에서 SELECT가 실패할 때까지 거부될 수 있는 레코드의 수입니다. 기본값은 Unlimited이지만 Specify를 선택하고 관련 상자에 적절한 숫자를 입력할 수 있습니다.

Parallel

테이블이 병렬인지 여부를 선택할 수 있습니다. 이 상자를 선택한 경우에는 기본 병렬 처리도를 적용하거나 Degree 상자에 새 값을 입력할 수 있습니다.

Access Parameters

액세스 매개 변수는 다음 세 가지 중 한 가지 방법으로 작성할 수 있습니다.

  • 데이터를 샘플링하여 GUI로 작성

  • GUI를 이용하여 수동으로 작성

  • 기존 SQL*Loader 제어 파일을 편집하여 수동으로 작성


표준 Create Table 탭

색인으로 구성되어 클러스터된 표준 테이블에 대한 Create Table 창은 탭으로 나뉩니다. 여기에는 다음 항목이 포함됩니다.

  • Columns

  • Physical Attributes

  • Additional Attributes

  • Constraints

  • Partitions

  • Subpartition Template

  • Comments

  • Queue

Show SQL 단추를 누르면 연결된 SQL 문을 포함하는 SQL Statement 창이 표시됩니다.


Create Table: Columns 탭

주: 또한 파일에서 열을 로드할 수 있습니다. 자세한 내용은 파일에서 열 로드를 참조하십시오.

Object Table

테이블이 개체 테이블인 경우 이 열을 선택합니다.

Grid

  • State - 첫 번째 열이 상태 열입니다. 이 열에는 테이블 열의 상태가 비트맵을 사용하여 표시됩니다. 예를 들어 +(열 추가), -(열 삭제), 삼각형(변경된 열), 거미집(설정된 사용되지 않은 열) 등으로 표시됩니다.

  • Name - 이 열에는 테이블 열의 이름이 표시됩니다. 새 테이블의 경우 여기에 테이블의 이름을 입력합니다.

  • Data Type - 테이블 열의 데이터 유형입니다. 데이터 유형 드롭다운에는 원시 Oracle 데이터 유형, ANSI 데이터 유형, 사용자 정의 개체 유형(Oracle 8을 사용하는 경우)의 순서로 데이터 유형이 나열됩니다. 파선으로 데이터 유형 그룹을 나눕니다. 새 테이블인 경우 드롭다운에서 데이터 유형을 선택합니다.

  • Size - 이 열에는 적용 가능한 경우 데이터 유형의 크기가 표시됩니다. 드롭다운에서 선택한 데이터 유형을 기반으로 이 열이 자동으로 생성되는 경우도 있습니다. 크기를 변경하려면 상자를 누르고 값을 입력하거나 위쪽/아래쪽 화살표를 사용하여 숫자를 스크롤합니다.

  • Precision - 이 열에는 적용 가능한 경우 데이터 유형의 정밀도가 표시됩니다.

  • Scale - 이 열에는 적용 가능한 경우 데이터 유형의 배율이 표시됩니다.

  • Nullable - 상자를 눌러 선택/선택 취소합니다. 선택한 경우 열에 null 값을 사용할 수 있습니다.

  • Primary Key - 상자를 눌러 선택/선택 취소합니다. 선택한 경우 열이 기본 키입니다.

  • Unique - 상자를 눌러 선택/선택 취소합니다. 선택한 경우 열에 대한 고유한 제약 조건이 있습니다.

  • Ref - 상자를 눌러 선택/선택 취소합니다. 선택한 경우 데이터 유형이 ref 개체입니다. 이 열은 개체 데이터 유형에만 적용됩니다.

  • Default - 새 행에 대한 기본 열 값입니다. 상자를 눌러 기본 열 값을 입력합니다.

  • Constraint - 열 제약 조건 식입니다. 상자를 눌러 제약 조건 식을 입력합니다.

  • Comment - 열 주석입니다. 상자를 눌러 주석을 입력합니다.

Editing 단추

Add 단추 - 열 그리드에 비어 있는 새 행을 추가합니다.

Drop 단추 - 선택된 열을 삭제합니다. Alter 기능에서 이 단추는 삭제할 열을 표시합니다. 이 기능이 도입된 Oracle 8.1.5 이상을 사용하는 경우에만 이 기능이 활성화됩니다.

Unused 단추 - 선택된 열을 사용되지 않은 열로 설정합니다. 이 단추는 Alter 기능에만 적용되며 Create Table 기능에서는 비활성화됩니다. 이 기능이 도입된 Oracle 8.1.5 이상을 사용하는 경우에만 이 기능이 활성화됩니다.

바로 가기 키

명령 | 기능
<Ins> | 추가
<Ctrl><Del> | 삭제
<Home> | 그리드의 첫 번째 열로 이동
<End> | 그리드의 마지막 열로 이동
<Ctrl><Home> | 그리드의 첫 번째 행으로 이동
<Ctrl><End> | 그리드의 마지막 행으로 이동


Create Table: Physical Attributes 탭

이 옵션은 Standard Table 라디오 단추나 Index-Organized table 라디오 단추를 선택한 경우에 활성화됩니다.

  • Percent Free 입력란 - 데이터 블록에서 업데이트용으로 예약된 공간의 백분율입니다.

  • Percent Used 입력란 - Oracle에서 테이블의 각 데이터 블록에 대해 유지하는 사용된 공간의 최소 백분율입니다.

  • Initial Trans 입력란 - 테이블에 할당된 각 데이터 블록 내에 할당되는 트랜잭션 항목의 초기 수를 지정합니다.

  • Max Trans 입력란 - 이 입력란은 테이블에 할당된 데이터 블록을 업데이트할 수 있는 최대 동기 트랜잭션 수를 지정합니다.

  • Tablespace 상자/드릴다운 - Oracle에서 테이블을 작성하는 테이블 공간을 지정합니다.

Storage

상자에 저장소 요구 사항을 입력합니다. 상자에 새 값을 입력하거나 각 옵션의 드롭다운 목록을 사용하여 기존 값을 선택할 수 있습니다. 다음과 같은 옵션이 있습니다.

  • Initial Extent

  • Next Extent

  • Pct Increase

  • Free Lists

  • Free Groups

  • Min Extents

  • Max Extents

  • Buffer Pool


Create Table: Other Attributes 탭

Create Table: Additional Attributes 탭

이 탭을 누르면 새 테이블에 추가 특성을 설정할 수 있습니다. 여기에는 다음 항목이 포함됩니다.

  • Parallel

  • Degree

  • Instances

  • Logging - 이 항목을 선택하면 테이블 작성이 다시 실행 로그에 기록됩니다.

  • Cache

  • Monitoring

  • Row Dependencies

  • Enable Row Movement

색인 구성 매개 변수

이 옵션은 Index-Organized Table 라디오 단추를 선택한 경우에 활성화됩니다.

  • Mapping table - 매핑 테이블을 작성하려면 이 상자를 선택합니다.

  • Threshold Pct 상자 - 데이터 행의 색인에 보존되는 공간의 백분율을 나타냅니다.

  • Key Compression 확인란 - 이 확인란을 선택하면 키 압축을 사용하여 Primary key 열 값이 반복적으로 발생하지 않게 만들 수 있습니다. 이 기능은 Oracle 8 이상이 있는 경우에만 활성화됩니다.

  • Columns 상자 - 압축할 접두사 Primary key 열의 수입니다.

  • Overflow 확인란 - 이 확인란을 선택하면 Threshold Pct 값을 초과하는 데이터 행이 오버플로 데이터 세그먼트에 들어갑니다.

  • Overflow Column 드롭다운 - 이 드롭다운을 사용하여 테이블을 색인과 오버플로 부분으로 나누는 열을 지정합니다. 드롭다운 목록에서 열을 선택할 수 있습니다.

클러스터 매개 변수

이 옵션은 Clustered Table 라디오 단추를 선택한 경우에 활성화됩니다.

  • Cluster 상자/드롭다운 - 테이블이 속하는 클러스터의 이름을 입력 또는 선택합니다.

  • Columns 확인란 목록 - 클러스터 열에 해당되는 열을 선택합니다.


Create Table: Constraints 탭

테이블에 제약 조건을 추가하고 추가된 제약 조건을 보려면 이 탭을 누릅니다.

제약 조건 추가

손쉽게 제약 조건을 추가할 수 있습니다.

제약 조건을 추가하려면

  1. Create Table 대화 상자에서 Constraint 탭을 누릅니다.

  2. Add Constraint를 누릅니다.

  3. 제공되는 상자에 제약 조건 매개 변수를 입력합니다.

제약 조건 다시 정렬

제약 조건을 화면에서 다시 정렬하여 편집할 제약 조건을 표시할 수 있습니다. 여기서는 작성된 제약 조건 사이를 돌아가며 각 제약 조건을 번갈아 맨 위로 보냅니다.

화면에서 제약 조건을 다시 정렬하려면

  1. Create Table 대화 상자에서 Constraint 탭을 누릅니다.

  2. Rearrange를 누릅니다.


Create Table: Partitions 탭

Available Columns 목록에서 열을 선택하여 파티션의 기준 열을 결정합니다. 열 이름을 두 번 누르거나 열을 누른 다음 단일 오른쪽 화살표를 눌러 선택된 열을 Partitions Columns 목록으로 이동합니다.

파티션 추가

파티션 기준 열을 선택한 후 파티션을 추가할 수 있습니다.

  • 범위 파티션

범위 파티션의 경우 Add 버튼을 눌러 파티션을 추가할 수 있습니다. Add Partition 대화 상자가 나타나면 파티션 이름을 입력할 수 있습니다. 파티션 내에서 각 열의 최대 범위를 입력하거나, 해당 대화 상자의 드롭다운 목록에서 Maxvalue를 선택해야 합니다.

주: 문자열 값의 상한 경계값은 그리드 내에서 작은 따옴표로 표시해야 합니다. 예를 들어 데이터 유형이 varchar2인 Last Name 열의 상한 경계값은 'Smith'일 수 있습니다. 작은 따옴표를 그리드에 입력해야 합니다.

  • 해시 파티션

해시 파티션을 추가하려면 대화 상자의 맨 아래에 있는 Hash Partitions 탭을 선택한 다음 해시 파티션에 사용할 테이블 공간을 파티션 영역으로 이동합니다.

  • 하위 파티션

해시 파티션 또는 목록 파티션에 하위 파티션을 추가할 수도 있습니다.


Create Table: Subpartition 템플릿

하위 파티션의 유형을 선택한 다음 Editing 단추를 사용하여 하위 파티션을 작성합니다.

Editing 단추

  • Auto Add - Auto Add를 눌러 하위 파티션 이름을 자동으로 작성합니다. 기본 이름 및 테이블 공간 이름 지정을 선택할 수 있습니다.

  • Add 1 - Add 1을 눌러 해시 하위 파티션을 추가합니다.

  • Delete - delete를 눌러 하위 파티션 그리드에서 행을 하나만 선택하여 삭제하거나 모든 행을 삭제할 수 있습니다.

  • Tablespaces -

  • Clear tablespace names - 그리드에서 모든 테이블 공간 이름을 지웁니다.

  • Fill blank tablespaces with selected - 그리드에서 테이블 공간 이름을 선택한 다음 이 옵션을 선택하여 모든 빈 테이블 공간을 이 정보로 채웁니다.

  • Assign a tablespace to selected subpartitions


Create Table: Queue 탭

이 옵션은 Advanced Queuing 테이블 유형을 선택하면 활성화됩니다. 이 매개 변수에 대한 자세한 내용은 Oracle 관련 문서를 참조하십시오.

Payload type

RAW 또는 Object를 선택합니다. Object를 선택하면 페이로드의 스키마와 유형을 지정해야 합니다.

Compatibility

적절한 Oracle 데이터베이스를 선택합니다.

  • 8.0

  • 8i

  • 10g

Sort List

다음 옵션 중에서 선택합니다.

  • ENQ_TIME

  • PRIORITY

  • PRIORITY, ENQ_TIME

  • ENQ_TIME, PRIORITY

옵션

Allow subscribers

기본적으로 선택 취소됩니다.

Allow message grouping

기본적으로 선택 취소됩니다.

Secure

기본적으로 선택 취소됩니다.

Primary Instance

기본값은 0입니다.

Secondary Instance

기본값은 0입니다.


Create Table: Comments 탭

Comments 탭을 눌러 테이블에 대한 설명을 입력할 공간에 액세스할 수 있습니다.


창: Column Definition

Column Definition

Schema Browser|Tables 페이지|Columns 탭에서 선택한 테이블에 열을 추가하려면 Add Column [image] 단추를 누릅니다. 그러면 Column Definition 창이 표시됩니다.

열을 정의하려면

  1. 열 이름, 데이터 유형 및 기타 적절한 정보를 입력합니다.

  2. Execute를 눌러 열을 추가합니다.

유효한 "ALTER TABLE..." 문을 만들려면 문자 기본값을 작은 따옴표로 묶어야 합니다.

추가 열은 항상 테이블 정의의 끝에 추가됩니다. 열은 삽입할 수 없습니다.

열 이름을 변경하거나 열을 다시 정렬하거나 삭제하려면 Rebuild Table 대화 상자를 참조하십시오.

관련 항목

Schema Browser: Tables

Alter Table

Create Table Like

Create Table

Table Script Creation

Tables - data 그리드


Table Referential 대화 상자

Table Referentials

Schema Browser, Tables 탭, Referential 탭에는 테이블 계층과 선택한 테이블이 다음을 수행하는 방법이 있습니다.

  • 다른 테이블에서 참조

  • 다른 테이블을 참조

주: 이 창은 sys.con$, sys.cdef, sys.user$, sys.obj$ 및 dba_cons_columns에 대한 액세스 권한이 있으면 더 빨리 채워집니다.

계층의 각 노드에는 표준 참조인 경우 "체인" 모양 비트맵, 그리고 참조가 "Cascade on Delete"인 경우 가위 한 쌍 모양의 비트맵이 있습니다.

EMPLOYEE.EMPLOYEE_ID를 참조하는 EMPLOYEE.MANAGER_ID와 같은 순환 참조는 캡처되기 때문에 예를 들어 emp_id is를 manager_id에서 참조하고 이를 다시 emp_id에서 참조하는 것과 같이 계층에서 끝없이 드릴다운할 수 없습니다.

개체 세부 정보

  • 목록에서 항목을 선택하고 <F4>를 누르면 개체를 자세히 설명하는 팝업 창이 표시됩니다.

계층 펼치기

  • 분기 항목을 선택하고 키보드의 키패드에서 더하기 키(+)를 눌러 항목을 펼칩니다.

  • 분기 항목 옆에 있는 더하기 를 눌러 항목을 펼칩니다.

  • CTRL-SPACE 를 눌러 트리 전체를 펼칩니다.

  • 키패드에 있는 별표 키(*)를 눌러 선택한 노드를 완전히 펼칩니다.


Alter Table

이 창을 사용하면 열을 삭제, 수정 및 추가하고, 저장소 매개 변수를 변경하고, 데이터 유형을 변경하고, null이 아닌 제약 조건을 추가하고, 사용되지 않는 열을 설정할 수 있습니다. Create Table 창과 같은 창이지만 기존 테이블의 수정에 사용한다는 점이 다릅니다.

주: Toad에서는 현재 다음 기능을 지원하지 않습니다.

  • Foreign key 참조

  • LOB 저장소

  • Varray

테이블을 수정하려면

  • Schema Browser|Tables 페이지에 있는 개체 목록에서 테이블을 선택하고 Alter Table [image] 단추를 누릅니다.

Table 창에 선택한 테이블의 Schema와 Name이 자동으로 표시됩니다. 테이블의 스키마나 이름은 수정할 수 없습니다.

관련 항목

Schema Browser: Tables

Create Table Like

Create Table

Column Definition

Table Script Creation

Tables - data 그리드


Insert 문 작성

Schema Browser|Tables|Data Grid에서는 data 그리드의 모든 행을 포함하거나 선택한 행만을 포함하는 INSERT 문을 작성할 수 있습니다.

선택한 행에 INSERT 문을 작성하려면

  1. data 그리드를 마우스 오른쪽 단추로 누르고 Allow Multi-select가 선택되어 있는지 확인합니다.

  2. data 그리드에서 Insert 문을 작성할 행을 선택합니다.

  3. 마우스 오른쪽 단추를 누르고 Create INSERT for selected rows를 선택합니다. Data Export 창이 나타납니다. 설정을 변경하고 OK를 누릅니다.

기본적으로 Insert 문은 클립보드에 복사되며, Editor 내에 이 문을 붙여넣으면 편집 또는 실행할 수 있습니다. 하지만 옵션 탭을 누르면 대상을 지정할 수 있습니다.

모든 행에 INSERT 문을 작성하려면

  1. data 그리드를 마우스 오른쪽 단추로 누르고 Allow Multi-select가 선택 취소되어 있는지 확인합니다.

  2. data 그리드를 마우스 오른쪽 단추로 누른 후 Create INSERT for all rows를 선택합니다. Data Export 창이 나타납니다. 설정을 변경하고 OK를 누릅니다.

기본적으로 Insert 문은 클립보드에 복사되며, Editor 내에 이 문을 붙여넣으면 편집 또는 실행할 수 있습니다. 하지만 옵션 탭을 누르면 대상을 지정할 수 있습니다.

관련 항목

Data Export 창

플랫 파일로 내보내기


점진적으로 테이블 삭제

데이터베이스에서 매우 큰 테이블을 삭제해야 하는 경우가 있습니다. 이 작업을 한 번에 수행하면 서버 자원이 너무 오래 묶일 수도 있습니다. Toad에서는 테이블을 점진적으로 삭제하여 이 문제를 해결할 수 있습니다.

이를 위해 Toad에서는 먼저 테이블을 자른 후 일부씩 삭제하여, 이 절차를 지정한 시간 동안 나눠서 수행합니다.

주: 크기가 200Mg를 넘고 범위가 1000개를 넘는 경우에만 테이블을 점진적으로 삭제할 수 있습니다.

테이블을 점진적으로 삭제하려면

  1. Schema Browser에서 Tables 탭을 선택합니다.

  2. 삭제할 테이블을 마우스 오른쪽 단추로 누른 다음 메뉴에서 Incrementally Drop Table을 선택합니다. 확인 대화 상자가 나타납니다.

  3. Yes를 누릅니다. 테이블이 충분히 크지 않으면 경고 대화 상자가 나타납니다. 그러면 작업을 취소해야 합니다. 테이블을 점진적으로 삭제할 수 있는 경우에는 Deallocate Table Extents 대화 상자가 나타납니다.

  4. day to begin the deallocation/drop process를 선택합니다. dropdown menu를 누르고 달력에서 적절한 날짜를 선택합니다.

  5. 회전자를 사용하여 할당 취소 프로세스를 시작할 시간을 설정합니다.

  6. 둘째 회전자에서 테이블의 할당 취소에 사용할 일 수를 설정합니다. 5일보다 짧은 기간을 선택할 수는 없습니다.

  7. Execute를 누릅니다. 프로시저가 예약되었습니다.

  8. 프로시저를 삭제하거나 예약되었는지 확인하려면 Jobs 탭을 누릅니다. 작업 목록에 있는 작업 중 마지막 몇 가지는 선택한 테이블을 할당 취소하고 삭제하는 것입니다. 목록에서 관련 작업을 모두 삭제하면 점진적 삭제 작업을 삭제할 수 있습니다.


창: Truncate Table

Truncate Table

이 창을 사용하면 테이블을 자르고 저장소를 다시 사용하거나 삭제할 수 있습니다.

테이블을 자르려면

  1. Schema Browser 에서 Tables 탭을 선택합니다. 테이블 을 선택한 후 Truncate Table 도구 모음 단추를 누릅니다. Truncate Table 대화 상자가 나타납니다.

  2. 사용할 할당 옵션을 선택하고 Execute를 누릅니다. 테이블이 잘리고 저장소가 복원되거나 삭제됩니다.


Analyze Tables

이 대화 상자를 사용하면 테이블 개체 목록에서 선택한 테이블을 분석할 수 있습니다. 그러면 통계를 수집하여 비용 기반 질의 최적화를 사용할 수 있습니다. 그 결과 Optimizer에서 질의를 더 잘 실행할 수 있습니다.

통계를 추정하거나(계산보다 빠름), 통계를 계산하거나, 현재 통계를 삭제할 수 있습니다.

테이블을 분석하려면

  • Schema Browser|Tables 페이지에서 도구 모음에 있는 Analyze Tables [image] 단추를 누릅니다.


Schema Browser: Tables - Data Grids

필터 및 정렬

Tables - Data 탭에서 data 그리드에 있는 열을 필터링하거나 정렬할 수 있습니다.

데이터를 필터링하려면

  • 그리드 바로 위의 Filter Data [image] 단추를 누릅니다. 그러면 정렬하거나 필터링할 열을 선택할 수 있는 Table Sort 대화 상자가 열립니다.

모든 테이블/보기 필터를 한꺼번에 지우려면 Clear Filters를 누릅니다.

주: 날짜는 mm/dd/yy, mm/dd/yyyy 또는 Windows 제어판, 국가별 설정, 날짜, 간단한 날짜 형식으로만 입력할 수 있습니다. 예를 들어 프랑스어의 경우 dd/mm/yy 또는 dd/mm/yyyy 형식으로 날짜를 입력할 수 있습니다. dd-mon-yy 형식으로 입력한 날짜는 거부됩니다.

레코드 삽입

또한 Schema Browser|Tables|Data 탭에서 레코드를 삽입할 수 있습니다.

레코드를 삽입하려면

  1. data 그리드를 누른 다음 "+" 단추를 누릅니다. 커서 위치 위에 새 레코드가 삽입됩니다.

  2. <tab> 키를 눌러 필드 사이를 이동하며 그리드에 데이터를 입력합니다.

Auto Commit 옵션을 선택하지 않은 경우 Commit 단추를 누를 때까지 데이터가 적용되지 않습니다.

주: 삽입 후에도 데이터를 적용하고 데이터 집합을 새로 고칠 때까지 Toad에서 rowid를 인식하지 못합니다. 데이터 집합 새로 고침 옵션은 Schema Browser에서 간단하게 변경할 수 있습니다. 자세한 내용은 Refresh Options를 참조하십시오.

따라서 마우스 오른쪽 단추 메뉴에서 Allow Multiselect를 선택한 경우에는 새 행만 선택한 후 Create Insert Statement for Selected Rows를 선택하면 테이블의 모든 행에 대해 insert 문이 만들어집니다. 새 행이 선택한 행 그룹의 일부인 경우에는 선택한 행에 insert 문이 포함되고 새 행은 무시됩니다.

관련 항목

Schema Browser: Tables

Refresh Options

Alter Table

Create Table Like

Create Table

Column Definition

Table Script Creation


Table Sort

Table Sort 대화 상자 액세스

Schema Browser의 Tables 탭에서 테이블에 있는 데이터를 정렬하고 필터링할 수 있습니다.

  • Schema Browser의 Objects 패널에서 Tables 탭을 누릅니다.

  • Details 패널 에서 Data 탭을 누릅니다.

  • 그리드 바로 위에 있는 Filter/Sort 단추를 누릅니다.

Views 탭에서 정렬 및 필터링을 수행할 수도 있습니다.

  • Schema Browser 의 Objects 패널에서 Tables 탭을 누릅니다.

  • Details 패널에서 Data 탭을 누릅니다.

  • 그리드 바로 위에 있는 Filter/Sort 단추를 누릅니다.

정렬 기준을 설정하려면

  1. Table Sort 대화 상자에서 Table Sort 대화 상자의 왼쪽 열 목록에서 정렬할 열 을 선택합니다. 오름차순 또는 내림차순 아이콘을 누릅니다.

열은 오른쪽 패널에 나열된 순서대로 정렬됩니다. 오른쪽 패널에서 열을 선택하고 다음 단추를 사용하면 정렬 창 내에서 열을 이동할 수 있습니다.

단추 | 명령
 | 열을 정렬에서 열 목록으로 다시 이동합니다.
 | 열을 열 목록에서 위로 이동합니다.
 | 열을 열 목록에서 아래로 이동합니다.

  2. 그리드도 필터링하려면 Filter 탭 을 누릅니다. 필터로 사용할 열, 연산자 및 값 을 선택합니다.

Add to filter를 눌러 선택 사항을 필터에 추가하거나, AND into filter를 눌러 ADD 명령을 사용하여 옵션을 추가하거나, OR into filter를 눌러 OR 명령을 사용하여 옵션을 추가합니다. 필터의 SQL이 대화 상자 맨 아래에 있는 메모 편집기에 나타납니다. 이 SQL을 더 편집할 수 있습니다.

  3. 작업이 완료된 후 OK 를 누르면 그리드에 있는 데이터가 지정된 대로 정렬 및/또는 필터링됩니다.

이 정렬 및 필터 기준은 schema.tbl, schema.tni 및 \TEMPS\SCHEMA\TABLE.CNI 파일에 저장됩니다.

기준 지우기

정렬을 지우려면

  • Clear Sort 를 눌러 Table Sort 대화 상자에서 모든 정렬 기준을 지웁니다.

필터를 지우려면

  • Clear Filter 를 눌러 Table Sort 대화 상자에서 모든 필터 기준을 지웁니다.

모든 필터/정렬을 지우려면

모든 테이블과 보기 의 필터/정렬 기준을 한꺼번에 지울 수 있습니다.

  • Details 패널 맨 위에서 회색 Clear Filters 아이콘을 누릅니다. 확인 프롬프트가 표시된 후 모든 필터와 정렬이 재설정됩니다.

Clear Filter 아이콘에서는 이제 필터 기준과 정렬 기준을 지웁니다.


Copy data to another Schema

한 테이블이나 여러 테이블에서 다른 스키마 또는 데이터베이스에 있는 같은 테이블로 데이터를 빠르게 복사할 수 있습니다. Toad에서는 변수에서 배열 바인딩을 사용하여 데이터를 복사하는 insert 문을 작성합니다. 배열 크기를 500으로 설정하면 한 insert 문으로 500 행이 삽입됩니다. 배열 크기는 조정할 수 있습니다.

데이터 복사에 액세스하려면

  1. Schema Browser에서 하나 이상의 테이블을 선택하고 마우스 오른쪽 단추를 누릅니다.

  2. 메뉴에서 Copy data to another schema를 선택합니다.

Source/Dest and Options

소스 대상 및 옵션을 선택하려면

  1. Source/Dest and Options 탭을 눌러 대상 연결, 스키마 및 옵션을 선택합니다.

주: Toad는 같은 테이블 이름을 가진 테이블 간에 한 스키마에서 다른 스키마로 데이터를 복사합니다. 테이블은 이 명령을 실행하기 전에 마련되어 있어야 합니다.

  2. destination connection과 schema를 선택합니다.

  3. 옵션을 선택합니다. truncate 옵션, array size를 변경하고, 롤백 세그먼트를 지정하고, 커밋 옵션을 선택할 수 있습니다. 또한 Where Clauses 탭을 누르고 데이터를 선택하는 SQL에 where 절을 적용할 수 있습니다.

주: 기본값은 각 삽입 후에 자동으로 커밋하는 것입니다. 이 옵션은 사용자나 데이터베이스에 대해 최적이 아닐 수도 있습니다.

또한 소스 연결이 대상 연결과 같고 소스 스키마가 대상 스키마와 같은 경우에는 잘라내기를 사용할 수 없게 되며 "proceed -- are you sure" 대화 상자가 나타납니다.

Where Clauses (optional)

작성된 코드에 where 절을 추가할 수 있습니다.

where 절을 추가하려면

  1. Where Clauses (Optional) 탭을 누릅니다.

  2. WHERE 절을 적용할 테이블을 선택합니다.

  • 나열된 모든 테이블에 적용하려면 All Tables를 선택합니다.

  • 모든 테이블이 아닌 일부 테이블에 적용하려면 목록에서 테이블을 선택하고 Selected Tables Only를 선택합니다.

  3. 오른쪽 패널에 WHERE 절을 입력합니다. "WHERE"를 절에 포함합니다. Test Query를 누르면 질의를 확인할 수 있습니다.

  4. Apply Where Clause To를 눌러 where 절을 적절한 테이블에 적용합니다. where 절이 적용된 테이블은 보라색 계열로 나열되며 where 절이 없는 테이블은 검정색으로 계속 표시됩니다.

  5. 각 테이블에 다른 where 절을 적용하려면 필요에 따라 2-5단계를 반복합니다.

  6. Test Query를 누르면 질의를 확인할 수 있습니다.

  7. where 절이 추가되면 테이블을 눌러 where 절을 보고, 필요한 경우 편집할 수 있습니다.

설정 저장 및 로드

설정을 파일에 저장한 후 나중에 파일에서 다시 로드할 수 있습니다. 그러면 나중에 WHERE 절을 다시 작성하거나 옵션을 다시 채우지 않고도 비슷한 복사본을 쉽게 작성할 수 있습니다.

또한 설정을 파일에 저장하면 나중에 Copy 기능을 명령줄에서 실행할 수도 있습니다. 자세한 내용은 명령 프롬프트에서 다른 스키마로 복사 실행을 참조하십시오.


창: Table Script Create

Create Table Script

이 창은 테이블 스크립트를 작성하는 두 단계 프로세스 중 첫 번째 부분입니다. 이 대화 상자의 다음 부분에 대해서는 Table Script Creation을 참조하십시오.

테이블 스크립트를 작성하려면

  1. Database|Export메뉴에서Table Scripts 메뉴 항목을 선택합니다.

  2. 스크립트를 생성할 테이블을 선택하고 OK 단추를 누릅니다. <CTRL> 키를 사용하여 여러 항목을 선택할 수 있습니다.

관련 항목

Table Script Creation

테이블 옵션

스크립트 옵션

제약 조건 옵션

관련 개체 포함

출력


창: Table Script Creation

Table Script Creation

테이블 스크립트를 쉽게 작성할 수 있습니다.

테이블 스크립트를 작성하려면

  1. Schema Browser|Tables 페이지에서 Create Script [image] 단추를 누릅니다.

또는

Database|Export|Table Scripts 메뉴 항목에서 목록에 있는 테이블을 선택하고 OK를 누릅니다. Create Table Script를 참조하십시오.

  2. Options 탭을 누르고 Table Scripts 출력에 넣을 옵션을 선택합니다. 예를 들어 테이블 공간 정보, 트리거 등이 있습니다.

  3. Output 탭을 눌러 출력을 단일 파일에 넣을지 여부 또는 Windows 클립보드에 복사할지 여부를 선택합니다.

  4. 옵션을 선택하고 나면 Execute를 눌러 테이블 스크립트를 생성하거나 CANCEL 단추를 눌러 Table Script Creation 대화 상자를 닫습니다.

선택한 옵션은 TOAD.INI에 유지되며 다음에 대화 상자를 사용할 때 복원됩니다.

관련 항목

테이블 옵션

스크립트 옵션

제약 조건 옵션

관련 개체 포함

출력


테이블 스크립트 작성 옵션

테이블 옵션

테이블 스크립트를 작성할 때 다음 옵션 중에서 선택합니다.

Storage clauses

이 옵션을 선택하면 TABLESPACE와 STORAGE 절이 CREATE TABLE과 CREATE INDEX 명령 뒤에 배치됩니다.

Storage clauses - Tablespace Only

이 옵션을 선택하면 INITIAL 익스텐트 크기 등의 다른 저장소 정보를 지정하지 않고 Toad에서 테이블 및 색인에 대한 테이블 공간을 지정합니다.

Storage clauses - Exclude Lob Storage

LOB 보기는 속도가 매우 느릴 수 있기 때문에 이 옵션을 사용하여 질의를 피할 수 있습니다.

이 옵션을 선택하면 Toad에서 테이블의 LOB storage 절을 제외합니다.

Explicitly specify NULL in table DDL

이 항목을 선택하면 Toad에서 CREATE TABLE 문에 있는 모든 열에 대해 NULL 또는 NOT NULL을 지정합니다.

Rebuild FK's referencing selected tables

이 항목을 선택하면 Toad에서 스크립트에 이 테이블을 참조하는 Foreign Key를 포함합니다. 테이블을 다시 작성해야 할 경우 Foreign Key도 다시 작성해야 합니다.

Include Insert Statements

이 항목을 선택하면 Toad에서 주 테이블 스크립트 뒤에 INSERT 문을 포함하여 테이블 정의와 데이터를 포함합니다.

Always exclude these Parameters

이 항목을 선택하면 테이블 스크립트에서 매개 변수가 제외됩니다.

  • Monitoring/No Monitoring

  • Cache/NoCache

  • Parallel/NoParallel

  • Logging/ NoLogging

  • Compress/ NoCompress

관련 항목

Table Script Creation

스크립트 옵션

제약 조건 옵션

관련 개체 포함

출력


스크립트 옵션

옵션

Include Schema Name

이 항목을 선택하면 다른 사용자로 연결된 경우에도 모든 문을 실행하고 개체가 계속 원래 스키마에서 작성되도록 모든 명령에 스키마 이름을 포함합니다.

Include Drop Statement

이 옵션을 선택하면 테이블 스크립트의 맨 위에 DROP 문이 배치됩니다.

Sort for Creation

이 옵션을 선택하고 여러 테이블을 선택하면 스크립트가 성공할 수 있도록 스크립트에서 테이블을 참조 무결성 순서에 따라 정렬합니다.

주: 이 Toad 옵션은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Script comments

이 옵션을 선택하면 Toad에서 각 CREATE 문의 위에 개체 이름이 있는 주석을 표시합니다.

Script comments - List Dependencies

이 옵션을 선택하면 각 CREATE 문 위에 개체가 종속된 항목이 나열됩니다.

Script comments - Include counts

이 옵션을 선택하면 각 CREATE 문 위의 테이블에 행 수가 포함됩니다.

주: 이 옵션은 테이블이 분석된 경우에만 테이블 개수를 포함합니다.

Always use / to end SQL statements

이 옵션을 선택하면 Toad에서 스크립트의 모든 명령 뒤에 세미콜론 대신 "/" 문자를 사용합니다.

One line per statement

이 옵션을 선택하면 각 문을 여러 줄로 분할하지 않고 길게 한 줄로 만듭니다.

관련 항목

Table Script Creation

테이블 옵션

제약 조건 옵션

관련 개체 포함

출력


제약 조건 옵션

제약 조건 옵션은 테이블 옵션의 하위 집합이기 때문에 테이블 옵션과 함께 있습니다.

제약 조건 옵션에 액세스하려면

  • Table Script Creation 대화 상자에서 Table Options 탭을 누릅니다.

Check

이 항목을 선택하면 Toad에서 스크립트에 check 제약 조건을 포함합니다.

Unique

이 항목을 선택하면 Toad에서 스크립트에 unique 제약 조건을 포함합니다.

Primary key

이 항목을 선택하면 Toad에서 스크립트에 테이블의 Primary key를 포함합니다.

Foreign Key

이 항목을 선택하면 Toad는 이 테이블에서 다른 테이블로 가는 Foreign Key를 포함합니다.

List constraints following table columns

이 항목을 선택하면 Toad에서 테이블에 있는 제약 조건을 CREATE TABLE 문에 포함합니다.

Individual Alter Table Commands

이 항목을 선택하면 Toad에서 "CREATE TABLE" 명령 뒤에 check 제약 조건을 넣습니다.

이 항목을 선택하지 않으면 Toad는 "CREATE TABLE" 명령 안에 check 제약 조건을 넣습니다.

One big Alter Table Command

이 항목을 선택하면 Toad에서 한 ALTER TABLE 문을 사용하여 테이블의 모든 제약 조건을 다시 작성합니다.

관련 항목

Table Script Creation

테이블 옵션

스크립트 옵션

관련 개체 포함

출력


관련 개체 포함

개체 포함

관련 개체를 테이블 스크립트에 포함할 수 있습니다.

관련 개체를 포함하려면

  1. Table Script Creation 대화 상자에서 Script Options 탭을 누릅니다.

  2. 포함할 개체를 선택합니다.

사용 가능한 개체

다음 개체 중 어느 것이든 포함할 수 있습니다.

  • Table Comments

  • Column Comments

  • Private Synonyms

  • Public Synonyms

  • Grants

  • Policies

  • Audit Stmts

  • Policy Groups

  • Indexes

  • Indexes - no constraint indexes

이 항목을 선택하면 Toad에서는 Primary Key 또는 고유 제약 조건과 연결된 색인의 CREATE INDEX 문을 생략합니다.

  • Triggers

  • Triggers - never parse triggers for schema names

이 항목을 선택하면 Toad에서는 현재 데이터베이스에 저장된 것과 일치하는 설명을 사용하여 트리거를 다시 작성합니다. 그렇지 않은 경우 "Include schema name"이 선택되어 있으면 트리거 설명에 스키마 이름이 포함되고, "Include schema name"이 선택되어 있지 않으면 스키마 이름이 제외됩니다.

관련 항목

Table Script Creation

테이블 옵션

스크립트 옵션

제약 조건 옵션

출력


테이블 스크립트 작성 출력

출력 옵션

To Clipboard

이 항목을 선택하면 Toad에서 테이블 스크립트를 Windows 클립보드에 출력합니다.

To File

이 항목을 선택하면 Toad에서 테이블 스크립트를 Filename 상자에서 선택한 단일 파일에 출력합니다.

To Screen

이 항목을 선택하면 Toad에서 테이블 스크립트를 클립보드나 파일이 아닌 화면에 직접 출력합니다. 표시되는 화면에는 클립보드 또는 파일에 내용을 저장하는 데 사용되는 단추가 포함되어 있습니다.

Filename 상자

드라이브, 경로 및 파일 이름을 입력하거나 표준 파일 대화 상자의 드릴다운 단추(타원)를 누릅니다.

To Separate files (one file per object)

이 항목을 선택하면 Toad에서 출력 디렉토리의 각 유형의 개체에 대해 폴더를 작성한 후 테이블 스크립트의 각 개체를 적절한 폴더의 별도 파일에 출력합니다.

To Separate files (one file per table)

이 항목을 선택하면 Toad에서 테이블 스크립트를 각각 별도 파일에 출력합니다. 파일 이름은 테이블 이름에 확장명 "sql"을 붙인 이름으로 지정됩니다.

Path

파일을 작성할 디렉토리의 경로를 입력하거나 표준 디렉토리 대화 상자의 드릴다운 단추(타원)를 누릅니다.

관련 항목

Table Script Creation

테이블 옵션

스크립트 옵션

제약 조건 옵션

관련 개체 포함

출력


Foreign Key Lookup

Schema Browser에서 테이블 데이터를 편집할 때 손쉽게 Foreign Key를 조회하고 선택한 테이블에 관련 데이터를 입력할 수 있습니다.

Foreign Key 조회는 그리드가 읽기 전용 모드인 경우에도 작동합니다. 이 기능은 Toad Options|Schema Browser|Data and Grids|Enable FK Lookup에서 비활성화할 수 있습니다.

Foreign Key를 조회하려면

  1. Schema Browser에서 Tables 탭을 누릅니다.

  2. 편집할 테이블을 선택하고 Details 패널에서Data 탭을 누릅니다.

  3. Foreign Key가 있는 열을 누릅니다. 다시 눌러 편집 모드를 활성화합니다. 드릴다운 단추가 나타납니다.

  4. 드릴다운 [image] 단추를 누르면 참조 테이블의 행이 표시됩니다. 행을 선택하고 OK를 누르면 data 그리드의 적절한 열에 데이터가 입력됩니다.

Foreign Key Lookup 창

Lookup 창에는 모든 Foreign Key 제약 조건이 포함됩니다. Toad에서 비활성화된 제약 조건을 무시하도록 하려면 Toad Options|Schema Browser|Data를 참조하십시오.

질의를 입력하거나 직접 편집하여 행을 필터링할 수 있습니다.

입력을 통해 행을 필터링하려면

  1. 왼쪽 아래에 있는 Filter by 상자가 선택되어 있는지 확인합니다.

  2. 표시된 열 중 하나에 커서를 놓습니다. 이제 입력을 통해 필터링할 수 있습니다("ab"를 입력하면 "ab"로 시작하지 않는 행 제외).

질의를 편집하여 행을 필터링하려면

  1. Edit Query를 누릅니다.

  2. 편집 창 내에서 질의를 편집합니다.

  3. Variable 단추를 누르고 변수 정보를 입력하여 변수를 지정합니다.

  4. Check 단추를 눌러 질의 구문이 정확한지 확인합니다.

  5. OK를 눌러 새 질의를 실행하고 조회 그리드를 필터링합니다.


Schema Browser: Tablespaces

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

테이블 공간을 만들거나 수정하거나 삭제할 수 있습니다. 테이블 공간을 온라인 또는 오프라인으로 만들 수 있습니다. 또한 테이블 공간의 세부 정보를 볼 수 있습니다.

Objects 패널

Objects 패널에는 테이블 공간을 만들고 수정하는 단추, 테이블 공간을 온라인 또는 오프라인으로 만드는 단추 및 삭제/모두 삭제 단추가 포함되어 있습니다.

테이블 공간의 여러 유형과 상태는 다양한 아이콘으로 구분됩니다. 자세한 내용은 Icon Legend를 참조하십시오.

Tablespaces 도구 모음

단추 | 명령
 | Create script - 다른 Toad 창이나 다른 응용 프로그램에 붙여넣을 수 있도록 사용자 스크립트를 만들고 클립보드에 복사합니다.
 | Create new tablespace - Tablespace 창을 표시하고 새 테이블 공간을 작성하려면 이 아이콘을 누릅니다. Create Tablespace 를 참조하십시오.
 | Alter tablespace - 선택한 테이블 공간의 Alter tablespace 창이 표시됩니다.
 | Filters - 개체 목록을 필터링할 수 있는 Browser Filters 창이 열립니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Place online - 선택한 테이블 공간이 오프라인 상태인 경우 사용할 수 있습니다. 선택한 테이블 공간을 온라인으로 만들 수 있습니다.
 | Place offline - 선택한 테이블 공간이 온라인 상태인 경우 사용할 수 있습니다. 테이블 공간을 오프라인으로 만들 것임을 확인하면 트랜잭션에서는 사용할 수 없는 Normal, Temporary, Intermediate 및 For Recover의 네 가지 옵션을 사용하여 선택한 테이블 공간을 오프라인으로 만들 수 있습니다.
 | Show tablespace map - 이 명령은 선택한 테이블 공간의 테이블 공간 맵을 새 창에 표시합니다.
 | Export tablespace - 이 명령은 선택한 테이블 공간을 내보낼 수 있도록 Export Utility 마법사를 표시합니다.
 | Coalesce tablespace - 이 단추를 사용하면 선택한 테이블 공간을 쉽게 통합할 수 있습니다. Toad에서 통합 명령을 수행하기 전에 확인 대화 상자를 표시합니다.
 | Drop tablespace - 선택한 테이블 공간을 삭제합니다. 테이블 공간을 삭제할 것임을 확인하면 Toad에서 데이터 파일 및/또는 계단식 제약 조건 등의 내용을 포함할 것인지 묻는 메시지를 표시합니다.

Details 패널

Details 패널에는 Datafiles, Free Space, Fragmentation, Objects, Quotas, Extents 및 Properties 탭이 있습니다.

관련 항목

Create Tablespace

Drop Tablespace

Export Tablespaces

테이블 공간 할당량 작성/수정

Datafile Definition

데이터 파일 이름 변경/이동


창: 표 공간 작성

표 공간 작성

주: 이 Toad 기능은 선택 사항인 Quest DBA Module과 함께 Toad의 상용 버전에서만 사용할 수 있습니다.

Create Tablespace 창을 사용하여 Toad 내에서 새 표 공간을 쉽게 작성할 수 있습니다.

새 표 공간을 작성하려면

  1. Database|Create 메뉴에서 Tablespace을 선택합니다.

또는

Schema Browser|Tablespaces 페이지에서 Create New Tablespace 단추를 누릅니다.

  2. 정보를 입력하여 표 공간을 정의합니다.

  3. 텍스트 상자에서 이름을 입력합니다.

  4. 드롭다운에서 범위를 지정합니다.

  5. 라디오 단추에서 Temporary 또는 Permanent 개체를 지정합니다.

  6. Extent Management가 표시된 상태에서 표 공간으로 SQL 사전 표를 사용하여 공간 사용을 추적할 경우 Dictionary를 선택할 수 있습니다. Local을 선택할 경우 비트맵이 공간 사용을 추적합니다.

  3. 아니면 Add to PM 확인란을 선택하여 Project Manager에 개체를 추가합니다.

관련 항목

스키마 브라우저: 표 공간

표 공간 삭제

표 공간 내보내기

표 공간 할당량 작성/변경

데이터 파일 정의

데이터 파일 이름 바꾸기/이동


Alter Tablespace

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

이 테이블 공간 편집기를 사용하면 DBA에서 DDL을 구성하고 제출하여 기존 테이블 공간을 수정할 수 있습니다.

Alter Tablespace에 액세스하려면

  • 다음 작업 중 하나를 수행하십시오.

  • Schema Browser | Tablespaces 페이지에서 Object 패널에 있는 테이블 공간을 강조표시한 후 도구 모음에서 Alter Tablespace를 선택합니다.

  • Identify Space Deficits 창에서 Alter Tablespace를 누릅니다.

  • Database 메뉴|Administer|Tablespaces에서 테이블 공간을 선택하고 도구 모음에서 Alter Tablespace를 누릅니다.

Alter Tablespace 창을 사용하면 영구 및 임시 테이블 공간을 수정할 수 있습니다. Oracle 8i 이상을 사용하는 경우에는 사전 관리 테이블 공간과 로컬 테이블 공간을 모두 수정할 수 있습니다. 그런 다음 두 유형 사이에서 마이그레이션할 수 있습니다.

Alter Tablespace 창을 열면 테이블 공간에서 편집할 수 없는 부분이 회색으로 표시됩니다. 이러한 부분은 편집하는 테이블 공간의 유형과 온라인/오프라인 상태인지 여부에 따라 달라집니다.

새 데이터 정의 파일을 작성하려면

  1. Add를 눌러 파일 세부 사항 영역에 새 데이터 정의 파일을 작성합니다.

  2. 데이터 파일 이름 및 크기 정보를 입력합니다.

  3. 데이터 파일을 자동으로 확장하려면 auto Extend 확인란을 선택하고 공간 할당 정보를 입력합니다.

  4. Execute를 눌러 새 데이터 파일을 추가합니다.

데이터 정의 파일을 편집하려면

  1. Edit를 눌러 새 데이터 정의 파일을 작성합니다.

  2. Data Definition 대화 상자에서 필요에 따라 데이터 파일 정보를 변경합니다.

  3. Execute를 눌러 편집을 완료하고 Alter Tablespace 창으로 돌아갑니다.

테이블 공간 마이그레이션

Oracle 8i 이상을 사용하는 경우에는 로컬 관리 테이블 공간과 사전 관리 테이블 공간 사이에서 쉽게 마이그레이션할 수 있습니다.

주: DBA 사용자로서 이 기능을 사용하려면 DBMS_SPACE_ADMIN에 대한 EXECUTE 권한이 있어야 합니다. 이 권한은 SYS 사용자가 부여할 수 있습니다.

로컬 관리 테이블 공간에는 Locally Managed 확인란이 선택되어 있습니다.

  • 로컬 관리 테이블 공간에서 사전 테이블 공간으로 전환하려면 이 상자의 선택을 취소한 후 Execute를 누릅니다. SQL을 화면으로 스풀하면 실행되는 SQL을 볼 수 있습니다. 이는 다음과 같이 표시됩니다.

begin

sys.dbms_space_admin.tablespace_migrate_from_local (‘migrate’);

end;

  • 사전 관리 테이블 공간에서 로컬 관리 테이블 공간으로 전환하려면 Locally Managed 확인란을 선택하고 Execute를 누릅니다. SQL을 화면으로 스풀하면 실행되는 SQL을 볼 수 있습니다. 이는 다음과 같이 표시됩니다.

begin

sys.dbms_space_admin.tablespace_migrate_To_local (‘migrate’);

end;

데이터 파일 삭제

Oracle 10g, 릴리스 2 이상을 실행하는 경우에는 테이블 공간에서 데이터 파일을 삭제할 수도 있습니다. 데이터 파일은 비어 있어야 하며 테이블 공간의 마지막 데이터 파일이 아니어야 합니다. 비어 있지 않은 파일을 삭제하면 Oracle에서 오류가 반환됩니다. 마지막 남은 파일인 경우에는 Delete 단추를 사용할 수 없습니다.

데이터 파일을 삭제하려면

  • 삭제할 빈 데이터 파일을 선택하고 Delete를 누릅니다.


테이블 공간 삭제

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

테이블 공간 삭제를 선택하면 Toad에서 확인 대화 상자를 표시합니다.

테이블 공간 삭제를 확인하고 나면 몇 가지 옵션을 사용하여 삭제할 수 있습니다.

Including contents

이 옵션을 선택하지 않으면 Oracle에서는 테이블 공간이 비어 있지 않은 경우 삭제를 허용하지 않습니다. 이 옵션을 선택하면 테이블 공간과 그 내용이 함께 삭제됩니다. 이 옵션을 선택하면 다음 옵션을 사용할 수 있습니다.

  • And Datafile - Oracle 9i 전용. 이 옵션을 선택하면 Oracle이 서버에서 테이블 공간의 데이터 파일을 제거합니다. 이 옵션을 선택하지 않으면 데이터 파일이 남게 되며 수동으로 삭제해야 합니다.

  • Cascade Constraints - "Including Contents"를 선택한 경우에만 사용할 수 있습니다. 이 옵션을 선택하면 테이블 공간 외부의 테이블에서 테이블 공간 안의 테이블 Primary 키 및 고유 키를 참조하는 모든 참조 무결성 제약 조건이 삭제됩니다. 이 옵션을 선택하지 않은 경우 그러한 참조 무결성 제약 조건이 존재하면 Oracle은 오류를 반환하고 테이블 공간을 삭제하지 않습니다.

관련 항목

Schema Browser: Tablespaces

Create Tablespace

테이블 공간 내보내기

테이블 공간 할당량 작성/수정

Datafile Definition

데이터 파일 이름 변경/이동


Drop Datafile

Oracle 10gR2 이상을 사용하는 경우에는 Schema Browser - Tablespaces 페이지에서 데이터 파일을 삭제할 수 있습니다. 데이터 파일은 비어 있어야 하며 테이블 공간에 있는 첫 번째 파일이 아니어야 합니다.

주: 이 단추는 로컬에서 관리하는 임시 테이블 공간의 데이터 파일도 삭제합니다.

데이터 파일을 삭제하려면

  1. Schema Browser|Tablespaces에서 테이블 공간을 선택합니다.

  2. Details panel에 있는 Datafile 탭을 누릅니다..

  3. 삭제할 데이터 파일을 선택합니다.

  4. Datafiles 탭 도구 모음에 있는 Drop datafile [image] 단추를 누릅니다.


테이블 공간 할당량 작성/수정

Tablespace quota 창을 사용하면 선택한 테이블 공간 또는 사용자의 테이블 공간 할당량을 작성 또는 수정할 수 있습니다.

Tablespace quota 창에 액세스하려면

  1. Schema Browser에서 Tablespaces 페이지를 선택한 후 테이블 공간을 선택합니다.

  2. 오른쪽에서 Quotas 탭을 누릅니다.

  3. Create/Alter Tablespace 단추를 누릅니다.

또는:

  1. Schema Browser에서 Users 페이지를 선택한 후 사용자를 선택합니다.

  2. 오른쪽에서 Quotas 탭을 누릅니다.

  3. Create/Alter Tablespace 단추를 누릅니다.

할당량 작성 또는 수정

테이블 공간 할당량 그리드는 User Name, Tablespace, Unlimited, Quota 및 Units로 구성되어 있습니다. 이 정보는 테이블 공간에 할당되는 사용자를 설명합니다.

  • 사용자가 no quota이면 Quota 및 Units 열이 비어 있습니다.

  • 할당량이 Unlimited이면 Unlimited 상자에 체크 표시가 있습니다.

할당량을 추가 또는 변경하려면

  1. 대화 상자의 맨 위에서 Unlimited 상자를 선택하거나 추가할 할당량의 크기를 입력합니다. 할당량의 크기를 입력하는 경우에는 드롭다운을 사용하여 MB 또는 KB를 선택합니다.

  2. 적절한 라디오 단추를 선택합니다.

  3. All: 모든 사용자에게 할당량을 적용합니다.

  4. Selected: 그리드에서 적절한 행을 선택합니다. <Ctrl> 키를 누른 상태로 항목을 누르면 여러 항목을 선택할 수 있습니다.

행에서 만든 할당량이 기존의 할당량을 대체합니다.

  3. Apply To를 누릅니다.

  4. 이제 다음 중 하나를 선택할 수 있습니다.

  5. Execute를 눌러 즉시 변경 사항을 적용합니다.

  6. Show SQL을 누르고 클립보드에 복사하거나 파일에 저장합니다.

관련 항목

Schema Browser: Tablespaces

Create Tablespace

테이블 공간 삭제

테이블 공간 내보내기

Datafile Definition

데이터 파일 이름 변경/이동


Datafile Definition

Datafile Definition 창에서는 데이터 파일 정의를 변경하거나 테이블 공간에 추가할 수 있습니다.

데이터 파일을 정의하려면

  1. Schema Browser에서 Tablespaces 탭을 누릅니다(또는 드롭다운에서 Tablespaces를 선택).

  2. Objects 패널에서 테이블 공간을 선택합니다. Details 패널의 Datafiles 화면에 테이블 공간의 데이터 파일 이름이 나타납니다.

  3. 데이터 파일의 추가 또는 변경을 선택합니다.

  4. 데이터 파일을 변경하려면 데이터 파일 이름을 두 번 누릅니다. Datafile Definition 창이 표시됩니다.

  5. 데이터 파일을 추가하려면 Datafile 화면 맨 위에 있는 New Datafile 단추를 누릅니다.

설정 변경 또는 추가

Datafile Name

Datafile Size

MB(메가바이트), KB(킬로바이트) 또는 GB(기가바이트)를 선택합니다.

Autoextend

테이블 공간의 자동 확장을 선택할 수 있습니다.

자동 확장을 선택한 경우에는 추가할 공간의 크기를 선택하고 데이터 파일에 허용할 최대 공간을 선택합니다.

단추

SQL을 실행하기 전에 표시하여 변경하거나, 바로 실행하거나, 변경을 취소할 수 있습니다.

Show SQL

Show SQL 단추를 누르면 SQL을 실행하기 전에 표시할 수 있습니다. Sql Statement 대화상자에서는 다음을 수행할 수 있습니다.

  • 클립보드에 복사

  • 파일에 저장

  • 창 닫기

Execute

Execute를 누르면 선택한 변경 사항을 즉시 적용할 수 있습니다.

Rename

Rename 단추는 기존 데이터 파일에만 나타납니다. 데이터 파일 이름을 변경하면 OS 수준에서 데이터 파일이 이동합니다. 자세한 내용은 데이터 파일 이름 변경/이동을 참조하십시오.

Minimize Size

Minimize size를 누르면 Toad에서 데이터 파일을 분석하고 데이터 파일의 최소 크기가 얼마나 작아질 수 있는지 알리는 대화 상자를 표시합니다.

관련 항목

Schema Browser: Tablespaces

Create Tablespace

테이블 공간 삭제

테이블 공간 내보내기

테이블 공간 할당량 작성/수정

데이터 파일 이름 변경/이동


데이터 파일 이름 변경/이동

데이터 파일 이름을 변경할 수 있습니다. 그러려면 테이블 공간을 오프라인으로 만들고 파일을 이동해야 합니다.

데이터 파일 이름을 변경하려면

  1. Datafile Definition 창에서 Rename을 누릅니다. Rename/move 대화 상자가 표시됩니다.

  2. Toad에서 데이터 파일 이름과 테이블 공간을 채웁니다. 현재 테이블 공간 상태가 ONLINE이면 1단계가 활성화됩니다. Execute를 눌러 테이블 공간을 오프라인으로 만듭니다.

  3. 테이블 공간이 오프라인이 되면 2단계로 진행할 수 있습니다. 새 파일 이름의 전체 경로와 파일 이름을 입력합니다. 그런 다음 Copy Unix 명령을 눌러 파일을 클립보드로 이동하거나 Copy DOS 명령을 눌러 파일을 클립보드로 이동합니다.

계속하기 전에 서버에서 저장된 명령을 실행하라는 경고 대화 상자가 표시됩니다. 이 명령을 실행하면 실제로 파일 이름이 변경됩니다.

  4. 3단계에서 "Alter Database" SQL을 발행하여 파일이 이동한 것을 Oracle에 알립니다. Execute를 누릅니다.

  5. 4단계에서 테이블 공간을 다시 온라인으로 만듭니다. Execute를 누릅니다.

  6. Close를 누릅니다.

관련 항목

Schema Browser: Tablespaces

Create Tablespace

테이블 공간 삭제

테이블 공간 내보내기

테이블 공간 할당량 작성/수정

Datafile Definition


Schema Browser: Triggers

Objects 패널

Objects 패널에는 선택한 트리거 또는 모든 트리거를 컴파일하는 단추, 선택한 트리거 또는 모든 트리거를 활성화/비활성화하는 단추, 트리거 필터 단추, 삭제/모두 삭제 단추가 포함되어 있습니다.

트리거의 여러 유형과 상태는 다양한 아이콘으로 구분됩니다. 자세한 내용은 Icon Legend를 참조하십시오.

Triggers 도구 모음

단추 | 명령
 | Create script - 다른 Toad 창이나 다른 응용 프로그램에 붙여넣을 수 있도록 사용자 스크립트를 만들고 클립보드에 복사합니다.
 | Create new trigger - Create Trigger 대화 상자를 사용하여 새 트리거를 작성하려면 이 아이콘을 누릅니다.
 | Save to file - 선택한 트리거를 SQL 파일에 저장하려면 이 아이콘을 누릅니다. Save as 대화 상자가 나타납니다. 파일에 이름을 지정하고 저장할 수 있습니다.
 | Alter trigger - Alter Trigger 대화 상자를 사용하여 기존 트리거를 수정하려면 이 아이콘을 누릅니다.
 | Open in procedure editor - 이 명령을 사용하려면 먼저 프로시저, 패키지 또는 함수를 선택해야 합니다. 그리고 도구 모음에 있는 아이콘을 누릅니다. 선택한 개체가 새 Procedure Edit 창에 복사되며 여기에서 개체를 디버깅하거나 개체에 대한 작업을 수행할 수 있습니다.
 | Compile trigger - Schema Browser에서 트리거를 다시 컴파일할 수 있습니다. 다시 컴파일할 개체를 선택하고 도구 모음에서 Compile Procedure를 누릅니다. 개체가 컴파일됩니다. 잘못된 개체(빨강색 X로 표시)가 올바르게 컴파일이 되면 유효함으로 표시가 변경되며 개체 이름 옆에 더 이상 X가 나타나지 않습니다.
 | Disable selected trigger - 트리거를 비활성화하려면 목록에서 활성화된 트리거를 선택하고 이 아이콘을 누릅니다.
 | Enable selected trigger - 트리거를 활성화하려면 목록에서 비활성화된 트리거를 선택하고 이 아이콘을 누릅니다.
 | Filter trigger list - Browser Filters 창이 열리고 개체 목록을 필터링할 수 있습니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Drop selected triggers - 목록에서 트리거를 하나 이상 선택하고 이 아이콘을 누르면 선택한 트리거만 데이터베이스에서 삭제할 수 있습니다.

개체 목록

개체 목록에서 항목의 왼쪽에 있는 아이콘은 트리거의 다양한 유형과 상태를 나타냅니다. Icon Legend를 통해 각 아이콘의 의미에 대한 정보를 얻을 수 있습니다.

Details 패널

Details 패널에는 Source, Columns 및 Errors 탭이 있습니다.

마우스 오른쪽 단추 메뉴에는 Compile, Edit, Disable, Enable 및 Save to File 항목이 있습니다.

관련 항목

Create Trigger

Alter Trigger


트리거 작성

Create Trigger 창은 Create 메뉴 또는 스키마 브라우저의 Trigger 페이지에서 사용할 수 있습니다. 데이터베이스의 새 트리거를 쉽게 작성할 수 있습니다.

트리거를 작성하려면

  • Database|Create 메뉴에서 Create Trigger를 선택합니다.

또는

Schema Browser|Trigger 페이지에서 Create Trigger 단추를 누릅니다.

Create Trigger 창이 세 영역으로 나뉩니다. Main 창 및 Basic Info/Fire Control 탭에는 트리거의 단추 및 주요 정보가 들어 있습니다. 두 개의 추가 정보 탭을 통해 WHEN 정 및 트리거 내용을 작성할 수 있습니다.

Main 창

Schema

Schema 드롭다운에서 트리거를 배치할 스키마를 선택합니다.

Trigger Name

Trigger name 상자에서 트리거 이름을 입력합니다.

Include Schema Name in SQL

창의 아래에 있는 이 확인란을 통해 트리거에 스키마 이름을 포함할 것인지 여부를 정의할 수 있습니다. 표시되어 있으면 개체 이름이 다음과 같이 정의됩니다. schemaname.object. 표시되어 있지 않으면 다음과 같이 입력됩니다. objectname.

Show SQL

이 메뉴를 눌러 새 트리거를 작성할 SQL을 표시합니다. 이 창에서 해당 코드를 클립보드에 저장하거나 파일로 저장할 수도 있습니다.

Send to Editor

Send to Editor를 눌러 실행하기 전에 편집하기 위해 작성 완료된 트리거 코드를 새 편집기 탭으로 보냅니다.

OK

OK를 눌러 트리거를 작성합니다.

Basic Info/Fire control

이 탭을 사용하여 트리거의 기본 정보, 즉 동작 기준, 실행 시기 및 참조 대상을 제어합니다.

On

이 영역에서 트리거가 표, 보기, 보기의 중첩 표, 데이터베이스 또는 전체 스키마에 따라 작동하는지 여부를 선택합니다.

주: 이 영역에 표 또는 보기가 있고 이 상자가 표시되어 있으면 F4를 눌러 해당 표의 설명 창을 표시합니다. 설명 항목을 참조하십시오.

Fire When

트리거의 실행 시기를 다음과 같이 선택합니다. Fire On 동작의 Before, After 또는 Instead.

Fire On

트리거의 동작 기준을 다음과 같이 선택합니다. Delete, Insert 및/또는 Update.

Status

트리거의 상태를 선택합니다. 처음 작성할 때 활성화되어 있어야 합니까, 아니면 비활성화되어 있어야 합니까?

For Each

각 행 또는 구문에 대한 트리거 실행 여부를 선택합니다.

Referencing

기본값으로 Toad는 작성한 트리거에서 New as New 및 Old as Old를 참조합니다. 이러한 참조를 변경해야 할 경우 해당 상자에 새 참조를 입력합니다. "Nested table of view"가 On 영역에서 선택되어 있을 경우 "Parent as" 상자가 나타납니다.

When 절

When 절의 탭에서 특정 절을 입력할 수 있습니다.

주: "WHEN"으로 시작하지 마십시오. 절 자체를 입력하면 됩니다. Toad는 SQL을 컴파일할 때처럼 WHEN을 포함합니다.

내용

트리거의 내용 코드를 입력합니다. 템플릿이 지원됩니다. Toad가 템플릿을 로드할 수 없을 경우 이 영역에 "your code here" 주석이 나타납니다. 그런 다음 코드로 교체합니다. 이제 트리거를 작성할 준비가 되었습니다.

관련 항목

스키마 브라우저: 트리거

트리거 변경


Alter Trigger

Alter Trigger 창은 세 영역으로 나뉩니다. 단추 및 트리거 관련 주요 정보가 포함된 주 창과 Basic Info/Fire Control 탭, 그리고 트리거의 절과 본문을 작성할 때 사용되는 두 개의 정보 탭이 해당 영역입니다.

주: 이 창은 "Team Coding 인식" 창입니다. Team Coding을 사용하는 경우, 트리거가 Team Coding에서 제어되며 체크아웃되지 않았으면 창은 읽기 전용입니다.

트리거를 수정하려면

  • Schema Browser|Triggers에서 Alter Trigger [image] 단추를 누릅니다. 아래에 설명된 선택 사항을 변경합니다.

주 창

Schema

이 스키마를 수정할 수 없습니다.

Trigger Name

트리거 이름을 수정할 수 없습니다.

Include Schema Name in SQL

창 아래쪽에 있는 이 확인란을 사용하면 트리거에 스키마 이름을 포함할 것인지 여부를 정의할 수 있습니다. 이 확인란을 선택하면 개체 이름이 schemaname.object로 정의됩니다. 이 확인란을 선택하지 않으면 ObjectName으로 입력됩니다.

Show SQL

트리거를 수정하는 SQL을 표시하려면 이 항목을 누릅니다. 이 창에서 코드를 클립보드에 저장하거나 파일에 저장할 수 있습니다.

Send to Editor

완료된 Alter Trigger 코드를 새 Editor 탭으로 보내어 실행 전에 편집하려면 Send to Editor를 누릅니다.

OK

트리거를 수정하려면 OK를 누릅니다.

Basic Info/Fire control

이 탭을 사용하면 트리거의 기본 정보, 즉 작업 대상, 발동 시기, 참조 항목 등을 수정할 수 있습니다.

On

이 영역에서 트리거가 테이블, 보기, 보기의 중첩된 테이블, 데이터베이스 또는 전체 스키마에서 작동하는지 여부를 선택합니다.

주: 이 영역에 테이블 또는 보기가 있고 이 상자에 포커스가 있으면 F4 키를 눌러 해당 테이블에 대한 설명 창을 표시할 수 있습니다. Describe 항목을 참조하십시오.

Fire When

트리거의 발동 시기를 Fire On 작업 전, 후 또는 해당 작업 대신 중에서 선택합니다.

Fire On

트리거로 발동할 작업을 Delete, Insert 및/또는 Update 중에서 선택합니다.

Status

트리거의 상태를 선택합니다. 처음 작성할 때 활성화 또는 비활성화 여부를 결정합니다.

For Each

각 행 또는 각 문 중 어느 쪽에 대해 트리거가 발동하는지 선택합니다.

Referencing

기본적으로 Toad는 작성된 트리거에서 New를 New로, Old를 Old로 참조합니다. 이러한 참조를 변경해야 하는 경우에는 적절한 상자에 새 참조를 입력합니다.

When 절

When 절의 탭을 사용하면 특정 절을 입력 또는 변경할 수 있습니다.

주: "WHEN"이라는 단어로 시작하면 안 됩니다. 절 자체만 입력합니다. Toad에서 SQL을 컴파일하는 동안 WHEN이 포함됩니다.

Body

이 탭에서 트리거의 본문 코드를 수정할 수 있습니다.

관련 항목

Schema Browser: Triggers

Create Trigger


Schema Browser: Types

유형은 Objects 옵션을 사용하는 Oracle 8, 8i 이상의 버전에서만 지원됩니다. 이전 버전의 Oracle을 실행하는 경우에는 Toad에서 Types 페이지를 숨깁니다.

Objects 패널

Objects 패널에는 새 개체를 만들고, 개체를 수정하고, 개체를 파일에 저장하고, Editor에 로드하고, 컴파일하고, 권한을 변경하고, 개체를 삭제하는 데 사용되는 단추가 있습니다.

Objects 패널은 드롭다운 목록에서 선택한 스키마가 소유하는 개체 유형의 계층 구조 목록으로 구성됩니다. 적절한 Oracle 데이터베이스 권한이 있으면 다른 스키마에 있는 개체를 찾아보거나 편집할 수 있습니다.

항목을 두 번 누르거나 더하기 또는 빼기 기호를 한 번 누르면 드릴업/드릴다운을 수행할 수 있습니다. 숫자 키패드에서 "+"(더하기) 키를 눌러 드릴다운하거나, "-"(빼기)를 눌러 드릴업하거나, "*"(별표)를 눌러 모두 펼칠 수 있습니다.

다양한 유형과 유형의 상태는 다양한 아이콘으로 구분됩니다. 자세한 내용은 Icon Legend를 참조하십시오.

지정된 가로 화면 공간에 개체 이름을 표시할 수 없는 경우에는 도구 설명 팝업에 전체 개체 이름이 표시됩니다.

Types 도구 모음

Types 도구 모음에는 새 개체를 만들고, 개체를 수정하고, 개체를 파일에 저장하고, Editor에 로드하고, 컴파일하고, 권한을 변경하고, 개체를 삭제하는 데 사용되는 단추가 포함되어 있습니다.

단추 | 명령
 | Create script - 다른 Toad 창이나 다른 응용 프로그램에 붙여넣을 수 있도록 사용자 스크립트를 만들고 클립보드에 복사합니다.
 | Create user type - 새 사용자 유형을 만들어 특성을 할당할 수 있는 New Object Type 창이 표시됩니다. Create Object Type을 참조하십시오.
 | Alter user type - Edit Object Type이 표시됩니다. Edit Object Type을 참조하십시오. 수집은 편집할 수 없습니다.
 | Save to file - 선택한 유형을 파일에 저장할 수 있습니다.
 | Load in procedure editor - 선택한 개체를 세부적으로 편집할 수 있도록 Editor 창에 로드합니다. 그 옆에 있는 드롭다운 메뉴를 사용하면 전체 프로시저를 로드하거나 스펙 또는 본문만 로드할 수 있습니다.
 | Compile - 선택한 개체를 컴파일합니다. 그 옆에 있는 드롭다운 메뉴를 사용하면 스펙, 본문 또는 두 가지 모두를 선택하여 컴파일할 수 있습니다.
 | Privileges - 다른 사용자나 역할에 이 유형에 대한 EXECUTE 권한을 부여할 수 있습니다.
 | Create object table - 선택한 개체에서 개체 테이블을 만듭니다. 수집에서는 개체 테이블을 만들 수 없습니다.
 | Filter types list - 개체 목록을 필터링할 수 있는 Browser Filters 창이 열립니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Drop user type - 선택한 개체를 삭제합니다.

Details 패널

Details 패널은 Objects 패널에 있는 유형에 대한 정보를 제공합니다.

정보는 다음과 같은 여러 탭으로 구성되어 있습니다.

Object types

이 탭은 선택한 스키마에 있는 다양한 개체 유형을 분해하여 표시합니다. 이 목록에는 개체 이름, 특성 수, 메서드 수, true/false 상태(미리 정의 및 완료) 및 개체 식별자가 포함됩니다. 목록은 알파벳 순으로 정렬됩니다.

Collections

이 탭은 선택한 스키마에 있는 다양한 수집 유형을 분해하여 표시합니다.

Attributes

이 탭은 선택한 개체 유형의 특성에 대한 정보를 표시합니다. 선택한 유형에 연결된 특성이 없으면 이 탭이 비어 있습니다.

Methods

이 탭은 선택한 개체 유형의 메서드에 대한 정보를 제공합니다. 선택한 유형에 연결된 메서드가 없으면 이 탭이 비어 있습니다.

Specification

이 탭은 선택한 개체 또는 수집 유형의 사양 코드를 표시합니다.

Body

이 탭은 선택한 개체 또는 수집 유형의 본문 코드를 표시합니다.

Dependencies

이 탭은 선택한 유형에 첨부된 모든 종속 관계에 대한 정보를 표시합니다. Autoload 옵션이 꺼져 있으면(View|Schema Browser|Options|Types 탭) 그리드 중 하나를 마우스 오른쪽 단추로 누르고 Load를 선택하여 정보를 표시합니다.

관련 항목

개체 유형 만들기

수집 유형 만들기

Edit Object Type


개체 유형 작성

유형은 Oracle 8, 8i 이상의 Objects 옵션이 활성화된 버전에서만 지원됩니다.

새 개체 유형을 작성하려면

  • Schema Browser|Types 페이지에서 도구 모음에 있는 New Object Type 단추를 누릅니다.

또는

Database|Create 메뉴에서 Object를 선택합니다.

왼쪽 패널 개체 계층

창의 왼쪽에는 선택한 개체에 포함되어 있는 특성과 메서드의 계층 목록이 있습니다.

계층의 각 항목에는 쉽게 참조할 수 있도록 아이콘이 연결되어 있습니다. 여기에는 다음 항목이 포함됩니다.

아이콘 | 의미
 | 개체
 | 특성
 | 메서드
 | 변경되었지만 아직 다시 컴파일되지 않은 개체

개체 이름 변경

개체와 그 특성 및 메서드에는 기본 이름이 지정됩니다. 유형이나 관련된 특성 및 메서드 이름을 변경할 수 있습니다. 이름을 변경할 항목을 마우스 오른쪽 단추로 누르고 새 이름을 입력합니다.

도구 모음

도구 모음을 사용하면 새 특성 또는 메서드를 추가하고, 개체 유형의 코드를 작성하거나 새로 고칠 수 있습니다.

아이콘 | 의미
 | New Attribute - 누르면 이 개체와 연결된 새 특성을 작성할 수 있습니다.
 | New Method - 누르면 이 개체와 연결된 새 메서드를 작성할 수 있습니다. 드롭다운을 사용하면 New Procedure, New Function, New Map Procedure 및 New Order Function의 기본 매개 변수를 사용하여 메서드를 작성할 수 있습니다.
 | Build/Refresh Code - 누르면 이 개체 유형의 본문 및 사양 코드를 생성하거나 새로 고칠 수 있습니다. 이 코드는 Body 및 Specification 탭에 표시됩니다.

오른쪽 패널 개체 세부 사항

개체를 선택하면 오른쪽 세부 사항 패널에 Properties, Specification 및 Body의 세 가지 탭으로 된 인터페이스가 표시됩니다.

  • 루트 유형을 선택한 경우에는 Specification과 Body의 두 탭만 표시됩니다.

  • 특성을 선택한 경우 Properties 탭에는 데이터 유형, 스키마, 개체, 길이, 정밀도 및 배율을 포함한 특성에 대한 세부 정보가 표시됩니다.

  • 메서드를 선택하면 Properties 탭에 메서드의 매개 변수, 메서드 유형 및 메서드의 제약 조건이 있는 목록이 표시됩니다.

Properties 탭

특성

계층에서 특성을 선택하면 Properties 탭을 사용하여 특성의 설정을 선택 또는 조정할 수 있습니다. 특성에 대해 기본 데이터 유형 중에서 선택할 수 있습니다. 예를 들어 INTEGER, VARCHAR2, DATE 등을 선택할 수도 있고 Schema 및 Object 드롭다운 목록이 활성화된 경우에는 REF 또는 Nested Object를 선택할 수도 있습니다.

메서드

계층에서 메서드를 선택하면 Properties 탭에는 매개 변수 이름, 데이터 유형, 모드(IN, OUT 등) 및 Object를 포함한 메서드의 매개 변수 목록이 표시됩니다.

또한 Properties 탭에는 메서드 유형(Procedure, Function, Map Function 또는 Order Function)을 선택하는 드롭다운 목록, 메서드의 오버로드 여부를 나타내는 레이블(True 또는 False), 메서드 반환 데이터 유형(Function 여부)에 사용되는 드롭다운, 반환 유형이 개체에 대한 REF나 Nested Object인 경우 Schema 및 Object의 드롭다운 목록, 그리고 메서드 제약 조건 WNDS, RNDS, WNPS 및 RNPS의 확인란도 있습니다.

메서드 제약 조건은 메서드에서 데이터베이스에 연결할 때 필요한 액세스 종류를 PL/SQL 컴파일러에 알립니다. 그 후 컴파일러에서는 데이터베이스 테이블, 패키지 변수 또는 둘 모두의 메서드 읽기/쓰기 액세스를 거부할 수 있습니다. pragma가 정의된 메서드는 SQL 식에서 호출할 수 있습니다.

  • WNDS는 "데이터베이스 상태 쓰지 않음"을 의미합니다.

  • WNPS는 "패키지 상태 쓰지 않음"을 의미합니다.

  • RNDS는 "데이터베이스 상태 읽지 않음"을 의미합니다.

  • RNPS는 "패키지 상태 읽지 않음"을 의미합니다.

적절한 Add, Edit 또는 Delete 단추를 눌러 메서드 매개 변수를 추가, 편집 또는 삭제할 수 있습니다. Add 또는 Edit의 경우에는 매개 변수 이름, 모드(IN, OUT 또는 IN OUT), 데이터 유형, 그리고 REF 또는 Nested Object의 경우 Schema와 Object를 입력하는 프롬프트가 표시됩니다.

Map Function에는 메서드 매개 변수를 연결할 수 없습니다. Procedure, Function 등에서 Map Function으로 변경하면 모든 메서드 매개 변수를 자동으로 삭제할 것인지 여부를 묻는 프롬프트가 표시됩니다.

Order Function에는 개체와 같은 유형의 IN 매개 변수가 하나가 있어야 합니다. Order Function을 선택하면 모든 메서드 매개 변수를 자동으로 제거하고 적절한 유형의 매개 변수 하나를 추가할 것인지 묻는 프롬프트가 표시됩니다.

Specification 탭

여기에는 개체의 특성과 메서드에 대한 사양이 표시됩니다. Toad의 다른 메모 편집기와 마찬가지로 텍스트를 선택한 후 <CTRL>C 를 사용하여 다른 곳에 복사할 수 있습니다.

Body 탭

여기에는 개체 메서드의 코드가 표시됩니다.

관련 항목

Schema Browser: Types

수집 유형 작성

Edit Object Type


수집 유형 작성

유형은 Oracle 8, 8i 이상의 Objects 옵션이 활성화된 버전에서만 지원됩니다.

새 수집 유형을 작성할 수 있습니다. 두 가지 방법 중 하나를 사용하여 New Collection Type 창을 표시할 수 있습니다.

수집 유형을 작성하려면

  • Schema Browser|Types 페이지에서 계층에 있는 Collection Types 그룹을 선택하고 도구 모음에 있는 New Object Type 단추를 누릅니다.

또는

Schema Browser|Types 페이지에서 도구 모음의 New Object Type 단추 옆에 있는 드롭다운 메뉴로부터 새 수집 유형을 선택합니다.

수집 이름을 지정하려면

  1. 왼쪽 패널에서 NEWCOLLECTION 이름을 마우스 오른쪽 단추로 누릅니다. 메뉴에서 Rename을 선택합니다. 이름이 강조표시됩니다.

  2. 수집의 새 이름을 입력하고 <Enter> 키를 누릅니다.

속성 설정

오른쪽 패널에서 새 수집에 적절한 속성을 선택합니다. 옵션은 Varray 또는 Nested Table 중에서 선택한 라디오 단추에 따라 활성화되거나 회색으로 표시됩니다.

관련 항목

Schema Browser: Types

개체 유형 작성

Edit Object Type


Edit Object Type

유형과 그에 연결된 특성 및 메서드를 편집할 수 있습니다.

Schema Browser|Object Panel|Types 페이지에서 편집할 유형을 선택하고 Alter User Type 단추를 누릅니다. Edit Object Type 대화 상자가 나타납니다.

왼쪽 패널 개체 계층

창의 왼쪽에는 선택한 개체에 포함되어 있는 특성과 메서드의 계층 목록이 있습니다.

계층의 각 항목에는 쉽게 참조할 수 있도록 아이콘이 연결되어 있습니다. 여기에는 다음 항목이 포함됩니다.

아이콘 | 의미
 | 개체
 | 특성
 | 메서드
 | 변경되었지만 아직 다시 컴파일되지 않은 개체

개체 이름 변경

유형이나 관련된 특성 및 메서드 이름을 변경할 수 있습니다. 유형 자체의 이름을 변경하면 이전 유형이 그대로 유지되고 새 유형이 새 이름으로 작성됩니다. 이전 유형을 바꾸려면 Schema Browser|Types 페이지로 돌아가서 이전 유형을 삭제합니다.

특성 제거

특성은 제거할 수 있지만 메서드는 제거할 수 없습니다.

특성을 제거하려면

  • 왼쪽 패널 계층에서 특성을 선택하고 마우스 오른쪽 단추를 누른 후 Remove를 선택합니다.

OK를 누를 때까지는 계층에서 특성이 완전히 제거되지 않습니다. Cancel을 눌러 특성을 복원할 수 있습니다.

오른쪽 패널 개체 세부 사항

개체를 선택하면 오른쪽 세부 사항 패널에 Properties, Specification 및 Body의 세 가지 탭으로 된 인터페이스가 표시됩니다.

  • 루트 유형을 선택한 경우에는 Specification과 Body의 두 탭만 표시됩니다.

  • 특성을 선택한 경우 Properties 탭에는 데이터 유형, 스키마, 개체, 길이, 정밀도 및 배율을 포함한 특성에 대한 세부 정보가 표시됩니다.

  • 메서드를 선택하면 Properties 탭에 메서드의 매개 변수, 메서드 유형 및 메서드의 제약 조건이 있는 목록이 표시됩니다.

Properties 탭

개체 유형 작성에 설명된 대로 특성 및 메서드에 대해 속성을 설정 또는 조정할 수 있습니다.

Specification 탭

여기에는 개체의 특성 및 메서드 사양이 표시됩니다. Toad의 다른 메모 편집기와 마찬가지로 텍스트를 선택한 후 <CTRL>C 를 사용하여 다른 곳에 복사할 수 있습니다.

Body 탭

여기에는 개체 메서드의 코드가 표시됩니다.

주: 수집 유형에 이 탭을 사용할 수 없습니다.

관련 항목

Schema Browser: Types

개체 유형 작성

수집 유형 작성


수집 유형 편집

수집 유형과 그에 연결된 특성 및 메서드를 편집할 수 있습니다.

Schema Browser|Object Panel|Types 페이지에서 편집할 수집 유형을 선택하고 Alter User Type [image] 단추를 누릅니다. Edit Collection Type 대화 상자가 나타납니다.

오른쪽 패널 개체 세부 사항

개체가 선택되면 오른쪽 세부 사항 패널에 Specification이 표시됩니다.

Specification 탭

여기에는 개체의 특성 및 메서드 사양이 표시됩니다. Toad의 다른 메모 편집기와 마찬가지로 텍스트를 선택한 후 <CTRL>C 를 사용하여 다른 곳에 복사할 수 있습니다.


Schema Browser: Users

Create User 항목을 참조하십시오.

Objects 패널

Objects 패널에는 현재 데이터베이스의 모든 사용자가 나열되며 이 사용자와 쉽게 작업을 수행할 수 있습니다.

사용자의 여러 유형과 상태는 다양한 아이콘으로 구분됩니다. 자세한 내용은 Icon Legend를 참조하십시오.

Users 도구 모음

Objects 패널에서는 도구 모음 단추를 사용하여 여러 명령에 액세스할 수 있습니다. 이 명령은 다음과 같이 작동합니다.

단추 | 명령
 | Create script - 다른 Toad 창이나 다른 응용 프로그램에 붙여넣을 수 있도록 사용자 스크립트를 만들고 클립보드에 복사합니다.
 | Create new user - 사용자를 만들고 권한, 역할 및 기타 정보를 지정할 수 있는 Create User 창이 표시됩니다. To Clipboard 단추를 사용하면 SQL 스크립트를 클립보드에 복사할 수 있습니다.
 | Modify user - User Information, Tablespace information, Roles, System Privileges, Grants 및 Quotas 값을 수정할 수 있는 Modify User Data 창이 표시됩니다. To Clipboard 단추를 사용하면 SQL 스크립트를 클립보드에 복사할 수 있습니다.
 | Copy this user - 사용자를 복사하고 복사본에 새 이름과 암호를 할당할 수 있는 New User Information 창이 표시됩니다.
 | Filters - 개체 목록을 필터링할 수 있는 Browser Filters 창이 열립니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Lock user - 선택한 계정을 잠급니다. 계정 상태가 잠금으로 변경되고 잠금 날짜가 기록됩니다. 잠긴 계정은 개체 목록에서 이름의 왼쪽에 자물쇠가 표시됩니다. 잠긴 계정에 액세스하려는 경우 계정이 잠겼음을 나타내는 메시지가 표시됩니다. 잠금 상태는 세부 사항 패널의 Info 탭에 표시됩니다. 주: 계정을 잠그려면 DBA 권한이 있어야 합니다.
 | Unlock user - 선택한 사용자 계정의 잠금을 해제합니다. 계정의 상태가 잠금 해제로 변경되고 잠금 날짜가 삭제됩니다. 주: 계정의 잠금을 해제하려면 DBA 권한이 있어야 합니다.
 | Drop this user - 선택한 사용자를 데이터베이스에서 삭제합니다.

Details 패널

Users 페이지의 Details 패널에는 선택한 사용자의 Info, Role Grants, System Privileges, Object Grants, Objects, Extents, Quotas 및 Resource Groups 탭이 있습니다.

Roles와 Privileges 탭에는 Revoke와 Revoke All 단추가 있습니다.

주: Object Privileges 탭에는 SYS 및 SYSTEM 개체가 포함되어 있지 않습니다.

관련 항목

Create User

New User Info


사용자 작성

Create User에서 기존 사용자의 권한에 따라 새 사용자를 작성할 수 있습니다.

사용자를 작성하려면

  1. Database|Create 메뉴에서 User를 선택합니다.

또는

Schema Browser|Users 페이지에서 Create New User [image] 단추를 누릅니다.

  2. 아래에 설명된 대로 필드에 필수 정보를 입력합니다.

  3. 아니면 Add to PM 확인란을 선택하여 Project Manager에 개체를 추가합니다.

  4. 탭 위의 단추를 사용하여 클립보드로 저장하고, 코드를 실행하고(Create User), 취소할 수 있습니다.

User Info 탭

텍스트 상자에서 User Name 및 Password를 입력할 수 있습니다.

Use Database Authentication 라디오 단추 - 표준 및 기본값입니다.

Use Operating System Authentication 라디오 단추 - Oracle 네트워크 ID를 사용합니다.

Use Enterprise Authentication - 전체 외부 인증을 설정합니다.

표준 Verify Password 상자도 있습니다.

Password expired (user must change password on next login) 확인란을 표시하면 다음에 연결할 때 암호를 변경해야 합니다.

드롭다운에서 Resource Profile을 선택할 수 있습니다.

Account is locked 확인란을 표시하여 계정을 잠글 수 있습니다.

Tablespace 탭

드롭다운에서 Default Tablespace 및 Temporary Tablespace를 선택할 수 있습니다.

Quota on default tablespace의 경우 Unlimited 확인란을 표시하거나 값을 입력할 수 있으며 라디오 단추를 사용하여 megabytes 또는 kilobytes를 선택할 수 있습니다.

드롭다운에서 Temporary tablespace를 선택할 수 있습니다.

여기서 선택한 내용을 모든 새 사용자의 기본값이 되도록 설정할 수도 있습니다. Set Tablespace names as defaults for all User Creates 상자를 표시합니다.

Roles 탭

Available Roles의 목록이 들어 있습니다. 확인란은 Granted, Default 및 Admin roles 열에 정렬됩니다. 확인란을 눌러 사용자에게 역할을 부여하거나 해지합니다.

Admin All 단추를 누르면 Admin 권한 열의 모든 항목을 표시합니다. Admin None 단추를 누르면 Admin 권한 목록의 모든 항목을 선택 취소합니다.

Grant All 단추를 누르면 Granted 열의 모든 항목을 표시합니다. Revoke All을 누르면 이러한 표시가 삭제됩니다.

Default All 단추를 누르면 Default 열의 모든 항목을 표시합니다. Default None 단추를 누르면 이러한 표시가 삭제됩니다.

Copy From 단추를 눌러 선택한 사용자의 역할 및 권한을 복사합니다. 목록에서 사용자를 선택하고 OK를 누릅니다. 이 대화상자에서는 여러 개를 선택할 수 없습니다. 그러나 여러 번 선택할 수 있으며 추가 역할이 이전에 선택한 내용으로 추가됩니다.

System Privileges 탭

사용자의 Privileges 목록이 들어 있습니다. 확인란은 Granted 및 Admin privileges 열에 정렬됩니다. 확인란을 표시하여 사용자에게 권한을 부여하거나 해지합니다.

Admin All 단추를 누르면 Admin 권한 열의 모든 항목을 표시합니다. Admin None 단추를 누르면 Admin 권한 목록의 모든 항목을 선택 취소합니다.

Grant All 단추를 누르면 Granted 열의 모든 항목을 표시합니다. Revoke All을 누르면 이러한 표시가 삭제됩니다.

Copy From 단추를 눌러 선택한 사용자의 역할 및 권한을 복사합니다. 목록에서 사용자를 선택하고 OK를 누릅니다. 이 대화상자에서는 여러 개를 선택할 수 없습니다. 그러나 여러 번 선택할 수 있으며 추가 역할이 이전에 선택한 내용으로 추가됩니다.

Object Grants 탭

Object Grants 탭을 눌러 특정 개체의 권한을 봅니다.

이 화면에서 다음 작업을 수행할 수 있습니다.

  • 이전에 부여한 권한을 해지합니다.

  • 또는 기존 사용자의 권한을 복사합니다. 그러나 새 권한을 추가할 수는 없습니다. 새 권한은 Editor의 SQL 구문에서 추가해야 합니다.

Grants Received 또는 Grants Made를 작업하기로 선택할 수 있습니다.

Quotas 탭

Quotas 탭을 눌러 새 사용자 또는 선택한 사용자의 표 공간 할당량을 추가 또는 수정할 수 있습니다.

새 사용자를 작성 중인 경우 반드시 새 사용자를 작성한 다음 할당량을 추가해야 합니다.

Quotas 페이지에서 New/Alter quota [image] 단추를 누릅니다.

Resource Groups 탭

Resource Groups 탭을 눌러 새 사용자 또는 선택한 사용자의 자원 그룹을 추가 또는 수정할 수 있습니다.

사용할 수 있는 그룹 목록이 페이지의 왼쪽에 표시됩니다. 오른쪽에 있는 확인란을 눌러 다음과 같이 해당 그룹의 권한을 선택합니다.

Switch

Switch는 세션 도중 자원 그룹으로 전환할 수 있는 권한을 부여합니다.

Initial Group

데이터베이스에 처음 연결할 때 사용자가 속한 그룹입니다. 연결이 구축되면 "switch" 목록에 포함된 모든 자원 그룹으로 전환할 수 있습니다.

주: 한 사용자에게 한 번의 초기 그룹만 허용됩니다.

Admin

Admin 권한이 있는 사용자는 해당 그룹을 다른 사용자로 전환할 수 있는 권한을 부여할 수 있습니다.

Proxies 탭

Proxies 탭을 누르고 다른 사용자를 추가하여 이 사용자를 프록시 사용자로 만듭니다.

관련 항목

Schema Browser: 사용자

새 사용자 정보


창: New User Info

New User Info

선택한 사용자의 역할/권한을 기반으로 새 사용자를 작성합니다. 이 창에서는 새 사용자 이름과 암호를 입력할 수 있습니다. 선택 사항인 확인란을 사용하면 운영 체제 확인을 사용할 수도 있습니다.

다른 사용자를 기반으로 새 사용자를 작성하려면

  • Schema Browser|Users 페이지에서 Copy this user 단추를 누릅니다.

관련 항목

Schema Browser: Users

Create User


Schema Browser: Views

Create View 항목을 참조하십시오.

Objects 패널

Objects 패널에 있는 정보는 보기 상태를 쉽게 확인할 수 있도록 설계되어 있습니다. 보기 이름의 왼쪽에 아이콘이 표시됩니다. 이 아이콘의 범례를 보려면 Icon_Legend를 참조하십시오.

Views 도구 모음

Objects 패널에서 도구 모음 단추를 사용하여 여러 명령에 액세스할 수 있습니다. 이 명령은 다음과 같이 작동합니다.

단추 | 명령
 | Create script - 선택한 보기의 SQL 스크립트를 작성하고 클립보드에 복사합니다.
 | New view - Create View 대화 상자를 표시하고 새 보기를 작성하려면 이 아이콘을 누릅니다.
 | Alter view - 이 명령을 사용하려면 먼저 보기를 선택해야 합니다. 이 아이콘은 선택한 보기의 설정을 변경할 수 있는 Create view 대화 상자를 표시합니다.
 | Show views in an Editor - 선택한 보기의 스크립트가 있는 Editor를 표시합니다.
 | Save to file - 파일을 저장하는 데 사용되는 Save As 창을 표시합니다.
 | Compile - 선택한 보기를 컴파일합니다.
 | Compile all - 나열된 모든 보기를 컴파일합니다.
 | View/Edit privileges - 선택한 보기의 Privileges 창이 표시되며 여기에서 기존 권한을 추가하거나 바꿀 수 있습니다.
 | Filter views - 개체 목록을 필터링할 수 있는 Browser Filters 창이 열립니다. 필터가 사용 중이면 아이콘이 빨강색으로 바뀝니다.
 | Add synonym - 선택한 항목의 동의어를 작성하려면 보기를 선택하고 이 아이콘을 누릅니다.
 | Compile dependent procedures - 종속 프로시저를 컴파일할 수 있습니다. 보기를 선택한 후 도구 모음에서 Compile Dependent Procedures 아이콘을 누릅니다. 보기에 종속된 모든 프로시저가 다시 컴파일됩니다. 종속 프로시저의 컴파일에 대한 자세한 내용은 종속 관계를 참조하십시오.
 | Save list to file for syntax highlighting - 구문 강조표시 파일에 보기 목록을 저장합니다. 저장하기 전에 확인 대화 상자가 나타납니다. 이 목록에 대한 자세한 내용은 Syntax Highlighting을 참조하십시오.
 | Drop view - 선택한 보기를 삭제합니다.

Details 패널

Details 패널에는 Columns, Source, Data, Grants, Deps(Used), Deps(Used by), Triggers 및 Errors 탭이 있습니다.

관련 항목

Create View

Views - Data Grids


창: 보기 작성

보기 작성

이 창은 새 보기를 작성하는 데 사용합니다. 보기는 표 또는 다른 보기의 데이터를 사용자 취향에 맞게 표시한 것입니다. 보기는 저장 공간을 필요로 하지 않습니다(저장된 질의는 제외). 기본적으로 표 형식의 질의 출력을 표시합니다.

새 보기를 작성하려면

  1. Database|Create|View 메뉴 항목

또는

Schema Browser|Views 페이지에서 New View 단추를 누릅니다.

  2. 드롭다운에서 Schema를 선택하고 상자에 Name을 입력합니다.

  3. 아래에 설명된 대로 영역에 필수 또는 선택 사항 보기 정보를 입력합니다.

  4. 아니면 Add to PM 확인란을 선택하여 Project Manager에 개체를 추가합니다.

  5. 다음 중 하나를 누르십시오.

  6. Show SQL 단추 - Show SQL 구문 단추가 새 보기에 대한 보기 SQL 구문을 표시할 SQL 구문 창을 표시합니다.

  7. Clipboard 단추 - 클립보드에 구문을 복사합니다.

  8. Save to File 단추 - 구문을 파일로 저장합니다.

View Info 탭

Aliases 섹션

별칭에 대한 자세한 내용은 별칭을 참조하십시오.

  • Add 단추 - 별칭의 이름을 입력할 수 있는 Add Alias 창을 표시합니다. 기본값은 Alias1, Alias2 등입니다.

  • Edit 단추 - 선택한 별칭에 대해 Edit Alias 창을 표시합니다. 그런 다음 별칭의 이름을 변경하고 OK를 눌러 변경 내용을 적용합니다.

  • Delete 단추 - 선택한 별칭을 삭제합니다.

  • Clear 단추 - Alias 목록을 지웁니다.

Force 확인란

표시되어 있으면 사용자에게 표 액세스 권한이 없어도 보기가 강제로 작성됩니다.

With 확인란

표시되어 있으면 다음 확인란이 활성화됩니다.

  • Read Only - 표시되어 있으면 별칭이 읽기 전용이 됩니다.

  • Check 옵션 - Check 옵션은 보기를 통해 수행한 삽입 및 업데이트로 인해 보기 질의가 선택할 수 있는 행이 나타나도록 지정합니다. Check 옵션은 이 보기 또는 이 보기의 기준이 되는 모든 보기의 질의에 하위 질의가 있거나 INSERT, UPDATE 또는 DELETE 작업이 INSTEAD OF 트리거를 사용하여 수행되는지 보장할 수 없습니다.

Source 탭

이 섹션에 하위 질의를 입력할 수 있습니다. 하위 질의를 입력하면 Check Query를 눌러 실행하기 전에 제대로 분석하는지 확인할 수 있습니다.

관련 항목

Schema Browser: 보기

보기 - 데이터 눈금


Views - data 그리드

Schema Browser|Views|Data 탭에서 data 그리드에 있는 열을 필터링 및/또는 정렬할 수 있습니다. 보기를 업데이트할 수 있는 경우에는 그리드에서 데이터를 편집할 수도 있습니다.

데이터 필터링

그리드 바로 위에 있는 Filter Data 도구 모음 단추를 누릅니다. 그러면 정렬 및/또는 필터링할 열을 선택할 수 있는 Table Sort 대화 상자가 열립니다.

모든 테이블/보기 필터를 한꺼번에 지우려면 Clear Filters를 누릅니다.

주: 날짜는 mm/dd/yy, mm/dd/yyyy 또는 Windows 제어판, 국가 및 언어 설정, 날짜, 간단한 날짜 형식으로 입력할 수 있습니다. 예를 들어 프랑스어에서는 dd/mm/yy 또는 dd/mm/yyyy 형식으로 날짜를 입력할 수 있습니다. dd-mon-yy 형식으로 입력한 날짜는 거부됩니다.

data 그리드에서 보기 편집

보기를 업데이트할 수 있는 경우에는 그리드에서 데이터를 편집할 수 있습니다.

편집할 수 있지만 RowID가 없는 보기의 경우는 예외입니다. 이러한 보기는 편집할 수 없는 것으로 반환됩니다. 여기에는 보기 계층에 있는 보기, INSTEAD OF 트리거가 있는 Primary Key를 사용하지 않는 결합이 포함된 보기가 포함됩니다.

주: 편집 후 또는 편집을 시도하는 중에 데이터를 새로 고칠 수 없는 경우 Refresh 옵션에 문제가 있을 수 있습니다. 데이터 집합 새로 고침 옵션은 Data 탭에서 간단하게 변경할 수 있습니다. 자세한 내용은 Refresh Options를 참조하십시오.

관련 항목

Schema Browser: Views

Create View

Refresh Options


Script Manager 개요

Script Manager는 자주 사용하는 스크립트를 관리할 수 있는 Toad의 중앙 위치입니다. Script Manager를 사용하여 다음을 수행할 수 있습니다.

  • 스크립트를 다양한 범주로 구성

  • 스크립트를 쉽게 액세스

  • 한 번에 여러 연결에 대한 스크립트 실행

  • 한 번에 여러 스크립트 실행

  • 여러 연결에 대해 여러 스크립트 실행

주 Script Manager 영역

Script Manager는 scripts, output 및 messages의 새 영역으로 나뉩니다.

Scripts

script 영역을 사용하여 스크립트를 정렬, 분류, 로드 및 실행합니다(스크립트 그리드 사용 참조).

Output

output 영역에는 선택된 스크립트의 출력이 표시됩니다. 아래쪽에 있는 탭을 사용하여 출력을 탐색할 수 있습니다. 실행되는 각 스크립트에 대해 하나의 탭이 작성됩니다. 또한 해당 스크립트에 포함된 각 SELECT 문에 대한 하위 탭이 스크립트 탭 내에 추가됩니다.

Messages

messages 영역에는 실행되는 스크립트에 대한 시스템 메시지가 표시됩니다. 메시지는 파선으로 된 구분 선으로 분류되며 스크립트 경로와 메시지를 포함합니다.


Script Manager 열기

File 메뉴에서

  • Utilities 메뉴에서 Script Manager를 선택합니다. Script Manager 창이 나타납니다.

도구 모음에서

  • Main 도구 모음에서 Script Manager(Run Script) [image] 아이콘을 누릅니다. Script Manager 창이 나타납니다.

시작할 때 Script Manager 열기

Toad를 시작할 때 Editor 대신 Script Manager 창을 열도록 Toad를 설정할 수 있습니다.

시작할 때 Script Manager를 열도록 설정하려면

  1. View 메뉴에서 Toad Options를 선택합니다.

  2. 완쪽 패널에서 Windows를 선택합니다.

  3. Script Manager 행에서 Auto open 확인란을 선택합니다.

관련 항목

시작


Toad와 함께 제공된 스크립트

여러 스크립트가 Toad와 함께 제공됩니다. Toad는 스크립트에 쉽게 액세스할 수 있도록 User Files 디렉토리에 ScriptMgr라는 폴더를 설치합니다. 스크립트 데이터 파일(.sdf)은 일반적으로 Toad.exe와 동일한 디렉토리에 저장되지만, 사용자가 원하는 위치에 저장할 수 있습니다.

DBA 스크립트

DBA 작업 관련 스크립트는 DBA.sdf라는 .sdf(범주) 파일에 나열됩니다. 이 파일은 User Files 하위 디렉토리에 설치됩니다. "DBA" 폴더는 ScriptMgr 폴더에 배치됩니다. Toad에서 제공되는 DBA 관련 스크립트가 이 폴더에 설치됩니다.

기본적으로 DBA.sdf는 Toad가 기본 설치 디렉토리인 "C:\Program Files\Quest Software\Toad for Oracle"에 설치될 것으로 예상합니다. Toad가 이 위치에 설치된 경우 DBA.sdf를 로드하고 스크립트를 계속 사용할 수 있습니다.

Toad가 다른 위치에 설치된 경우에 스크립트 위치를 설정하려면

  1. 먼저 DBA.sdf를 Script Manager로 로드합니다.

  2. 마우스 오른쪽 단추를 누르고 Batch Directory Change를 선택하여 스크립트의 디렉토리를 변경합니다. 자세한 내용은 모든 스크립트 디렉토리 변경을 참조하십시오.

Oracle 8i Data Dictionary 스크립트

.sdf(범주) 파일 Oracle 8i Data Dictionary.sdf는 Toad.exe와 동일한 디렉토리에 설치됩니다.

기본적으로 "Oracle 8i Data Dictionary"는 Oracle 8i와 관련 스크립트가 Oracle 8i의 적절한 기본 설치 위치인 "D:\ORACLE\ORA817"에 설치될 것으로 예상합니다. Oracle 8i가 이 위치에 설치된 경우 Oracle 8i Data Dictionary를 로드하고 스크립트를 계속 사용할 수 있습니다.

Oracle 8i가 다른 위치에 설치된 경우:

  • 먼저 Oracle 8i Data Dictionary.sdf를 Script Manager로 로드합니다.

  • Move를 누르고 스크립트의 디렉토리를 변경합니다. 자세한 내용은 모든 스크립트 디렉토리 변경을 참조하십시오.

관련 항목

Script Manager 개요

Script Manager 열기

Script Manager 도구 모음


Script Manager 도구 모음

도구 모음을 사용하면 마우스를 한 번만 눌러 여러 작업을 수행할 수 있습니다.

단추 | 명령
 | 선택된 스크립트를 실행합니다. Quest ScriptRunner와 같은 다른 응용프로그램에서 실행하려면 드롭다운 목록을 누릅니다.
 | 데이터 파일을 로드합니다. 드롭다운 메뉴를 사용하여 최근에 사용된 파일에서 선택합니다.
 | 새 스크립트 데이터 파일을 작성합니다.
 | 데이터 파일을 저장합니다.
 | script options 창을 엽니다.
 | 스크립트를 실행할 때 사용할 연결을 선택합니다. 드롭다운 목록에서 여러 연결을 선택할 수 있습니다.


새 스크립트 데이터 파일 작성

스크립트 데이터 파일을 사용하면 스크립트를 저장하고 나중에 검색할 수 있습니다. 각 데이터 파일은 여러 스크립트를 포함할 수 있습니다. 이러한 데이터 파일을 사용하여 스크립트를 범주로 구성하면 필요한 스크립트를 언제든지 쉽게 찾을 수 있습니다.

데이터 파일은 스크립트 당 한 줄씩 표시되는 ASCII 텍스트 파일입니다. 기본적으로 데이터 파일은 .sdf 확장명으로 저장됩니다.

데이터 파일을 작성하려면

  1. Script Manager를 엽니다. 개요를 참조하십시오.

  2. Script Manager 도구 모음에서 Create New Script Datafile [image] 단추를 누릅니다.

  3. 데이터 파일에 사용할 이름을 상자에 입력합니다. 예를 들어 "Toad Setup Scripts"라고 입력합니다.

  4. OK를 누릅니다.

Add Script Entry 창이 즉시 나타납니다. 여기서는 스크립트를 추가할 필요가 없습니다. 기다렸다가 나중에 스크립트를 추가할 수 있습니다.

적절한 스크립트 데이터 파일 이름

이름에 사용되는 문자는 Windows 파일 이름에 허용되는 문자여야 합니다. 예를 들어 *는 인식되는 문자가 아니기 때문에 범주의 이름을 SQL*Plus Scripts로 지정할 수 없습니다. 이러한 문자 중 하나를 사용하여 데이터 파일의 이름을 지정할 경우 파일이 작성되지 않습니다.


다른 이름으로 데이터 파일 저장

현재 데이터 파일을 새 이름으로 저장할 수 있습니다.

데이터 파일을 새 이름으로 저장하려면

  1. 이름을 변경할 데이터 파일을 엽니다.

  2. Script Manager 도구 모음에서 Save As [image] 단추를 누릅니다.

  3. 데이터 파일에 대한 새 이름을 입력합니다.

주: 이 때 원본 데이터 파일은 삭제되지 않습니다.

관련 항목

스크립트 데이터 파일 삭제


스크립트 데이터 파일 삭제

다른 파일과 마찬가지로 스크립트 데이터 파일도 Windows 탐색기에서 삭제할 수 있습니다.


스크립트에서 연결 사용

스크립트에서 다양한 연결을 사용할 수 있습니다. 이러한 연결은 각 데이터 파일과 함께 저장되거나 모든 스크립트에서 사용할 전역 값으로 저장됩니다. 디렉토리에 Toad에 대한 경로가 포함되어 있는 경우 상대적 디렉토리로 저장됩니다.

실행을 위해 사용하는 연결은 데이터 파일에 기본값으로 저장될 수 있습니다.

데이터 파일 기본값을 사용하려면

  1. Connections to execute against [image] 드롭다운 단추를 누릅니다.

  2. Set to datafile defaults를 선택합니다.

데이터 파일 기본값을 저장하려면

  1. 연결 기본값을 추가할 데이터 파일을 로드합니다.

  2. Script Manager options 단추를 누릅니다.

  3. Default Execution Connections 영역에서 Add를 누르고 이 스크립트를 실행할 연결을 추가합니다.

  4. OK를 누릅니다.

  5. Save datafile as [image] 단추를 누릅니다.

  6. 데이터 파일의 이름을 지정하고 Save를 누릅니다.

관련 항목

Script Manager Options

다른 이름으로 데이터 파일 저장


스크립트 그리드 사용

스크립트 그리드는 Toad의 다른 많은 data 그리드와 동일한 방법으로 작동합니다. 스크립트 그리드에서 데이터를 편집하려면 스크립트 항목 편집을 참조하십시오.

스크립트 그리드에 액세스하려면

  • Scripts 탭을 누릅니다.

그리드 순서 변경

그리드 위에 있는 화살표를 사용하여 스크립트 항목의 순서를 변경할 수 있습니다. 열 헤더를 누르면 그리드가 일시적으로 정렬되지만, 이 단추를 사용하면 순서가 영구히 변경됩니다. 그러면 스크립트가 실행될 순서를 지정할 수 있습니다. 선택된 스크립트는 영구 그리드 순서의 맨 위에서 맨 아래로 실행됩니다.

그리드에서 스크립트 순서를 변경하려면

  1. 이동할 스크립트를 선택합니다.

  2. 목록에서 스크립트를 위로 이동하려면 [image] 아이콘을 누릅니다.

  3. 목록에서 스크립트를 아래로 이동하려면 [image] 아이콘을 누릅니다.

Print Grid

데이터 파일에 대한 스크립트 그리드를 인쇄할 수 있습니다.

스크립트 그리드를 인쇄하려면

  1. 인쇄할 데이터 파일을 엽니다.

  2. Grid 메뉴에서 Print Grid를 선택합니다. Report Link Designer가 나타납니다.

  3. 원하는 옵션을 선택하고 OK를 누릅니다. 그리드가 인쇄됩니다.


Script Grid 도구 모음

script grid 도구 모음은 Script Manager의 Scripts 탭에 있습니다. 이 도구 모음에서 그리드에 나열된 스크립트에 대한 작업을 수행할 수 있습니다.

단추 | 명령
 | 데이터 파일에 스크립트 추가
 | 스크립트 편집
 | 선택된 스크립트 삭제
 | 선택된 스크립트 결합
 | 실행할 스크립트 예약
 | 행을 위로 이동
 | 행을 아래로 이동
 | 그룹화 기준


스크립트 항목 추가

스크립트 데이터 파일을 작성한 후 스크립트를 범주에 추가할 수 있습니다.

스크립트 항목을 추가하려면

  1. 스크립트를 기입할 데이터 파일을 엽니다.

  2. Scripts 탭을 누른 다음 Add Scripts [image] 단추를 누릅니다.

  3. Use 상자에 Use를 입력합니다. 예를 들어 품질 보증을 위해 이 스크립트를 사용하는 경우 "QA"를 입력합니다. 둘 이상의 스크립트가 동일한 Description을 공유할 수 있습니다. Tab을 누르거나 Description 상자를 누릅니다.

  4. 스크립트에 대한 Description을 입력합니다. 둘 이상의 스크립트가 동일한 Description을 공유할 수 있습니다.

  5. Add를 누릅니다. Save As 대화 상자가 나타납니다. 이 대화 상자를 통해 이 Description과 Use를 사용하여 추가할 스크립트를 찾아볼 수 있습니다. 원하는 스크립트를 선택한 다음 Save를 누릅니다. 이 때 <Ctrl> 키를 누른 상태로 해당 스크립트를 눌러 여러 스크립트를 선택할 수도 있습니다.

선택한 스크립트가 Add Script Entry 대화 상자의 파일 이름 영역에 나열됩니다.

  6. OK를 누릅니다. 이제 스크립트가 그리드에 추가됩니다. Use와 Description은 추가한 모든 스크립트에 대해 동일합니다.


스크립트 항목 편집

스크립트를 범주에 입력한 후 항목을 편집할 수 있습니다.

항목을 편집하려면

  1. 스크립트가 있는 데이터 파일에서 스크립트 이름을 누르고 Edit Script [image] 단추를 누르거나, 마우스 오른쪽 단추를 누르고 Edit를 선택합니다.

  2. 스크립트에 대한 description, use 또는 pathname을 변경합니다.

주: 경로 이름을 변경하기 전에 스크립트가 새 위치에 있어야 합니다.


스크립트 항목 제거

데이터 파일에서 스크립트 항목을 쉽게 제거할 수 있습니다.

스크립트 항목을 제거하려면

  1. 스크립트가 있는 데이터 파일에서 제거할 스크립트를 선택하여 강조표시합니다.

  2. Scripts 탭 도구 모음에서 Delete [image] 단추를 누르거나 마우스 오른쪽 단추를 누르고 Remove Scripts를 선택합니다.

  3. Yes를 눌러 데이터 파일에서 스크립트를 영구히 제거함을 확인합니다.

주: 스크립트가 하드 드라이브에서 제거되지는 않고, 선택한 데이터 파일에서만 제거됩니다.


모든 스크립트 디렉토리 변경

스크립트 디렉토리 변경

선택된 범주 내에 있는 모든 스크립트의 디렉토리를 변경할 수 있습니다.

모든 스크립트 디렉토리를 변경하려면

  1. 스크립트 그리드의 스크립트 열에서 스크립트 사용(맨 위) 노드를 선택합니다.

  2. 마우스 오른쪽 단추를 누른 다음 Batch Directory Change를 선택합니다.

  3. 디렉토리의 새 경로 이름을 입력합니다.

또는

드릴다운 단추를 누르고 적절한 디렉토리를 선택합니다.

  4. OK를 누릅니다. 이 범주 내에 있는 모든 스크립트의 디렉토리가 변경됩니다.

주: 이 명령을 사용해도 스크립트가 다른 디렉토리로 실제로 이동하지는 않습니다. 디렉토리 열이 잘못된 디렉토리를 가리키고 있는 경우 이 절차를 사용하여 스크립트에 액세스할 수 있는 올바른 디렉토리를 쉽게 가리킬 수 있습니다.


스크립트 예약

스크립트를 나중에 실행하도록 쉽게 예약할 수 있습니다.

주: 실행하도록 예약된 스크립트는 Quest ScriptRunner를 사용하여 실행됩니다.

스크립트를 예약하려면

  1. Script Manager에서 예약할 스크립트를 선택합니다.

  2. Script 탭 도구 모음에서 Schedule [image] 단추를 누릅니다.

  3. 여러 스크립트를 선택하면 결합할지 여부를 묻는 메시지가 표시됩니다. Yes 또는 No를 누릅니다.

  4. 표시되는 Add Task 마법사를 사용하여 예약 프로세스를 완료합니다.

관련 항목

Task Scheduler

Script Manager 개요


스크립트 그룹화

스크립트 그리드를 표시할 방법을 선택할 수 있습니다.

그룹화 기준 <none>

None을 선택하면 스크립트가 그룹화되지 않습니다. 이 옵션을 선택하면 스크립트가 표시되도록 선택한 순서대로 단순히 나열됩니다. 이 순서는 기본적으로 스크립트가 데이터 파일에 추가된 순서지만, 스크립트 그리드 도구 모음에서 위로 이동 및 아래로 이동 단추를 사용하여 순서를 변경할 수 있습니다.

그룹화 기준 Use

Use를 선택하면 지정된 Use 필드를 기준으로 모든 스크립트가 그룹화됩니다. 각 Use 필드가 노드로 표시되고 그 아래에 스크립트가 나열됩니다. 이 옵션은 가장 강력한 선택 옵션 중 하나입니다.

그룹화 기준 Extension

Extension을 선택하면 모든 스크립트가 확장명을 기준으로 그룹화됩니다. 각 확장명(.sql, .prc, 등)이 맨 위 노드가 되고 모든 스크립트는 그 아래에 그룹화됩니다.

그룹화 기준 Directory

Directory를 선택하면 모든 스크립트가 디렉토리를 기준으로 그룹화됩니다. 디렉토리가 맨 위 노드가 되고 모든 스크립트는 그 아래에 그룹화됩니다.


스크립트 보기

스크립트를 Script Manager에 입력한 후 쉽게 볼 수 있습니다.

스크립트를 보려면

  1. Script Manager의 Scripts 탭에서 스크립트가 있는 데이터 파일을 엽니다.

  2. 필요한 경우 스크립트를 표시할 맨 위 수준 노드를 확장합니다.

  3. 보려는 스크립트를 선택합니다.

  4. 마우스 오른쪽 단추를 누르고 메뉴에서 View를 선택합니다.

선택한 각 스크립트에 대해 하나의 메모장 사본이 열립니다.


데이터 파일 로드

Script Manager 범주의 데이터 파일을 로드할 수 있습니다. 이 기능은 다른 사용자로부터 범주와 해당 범주에서 사용되는 스크립트를 받는 경우에 유용할 수 있습니다.

데이터 파일(범주)을 로드하려면

  1. 주 Script Manager 도구 모음에서 Open Datafile [image] 단추를 누릅니다.

  2. 로드할 데이터 파일을 선택합니다. 데이터 파일의 확장명은 .sdf입니다.

로드된 파일이 Script Manager에 나타납니다. 새 스크립트의 Directory 열에서 경로 이름을 확인합니다. 경로 이름이 컴퓨터의 구성과 일치하지 않는 경우 경로 이름을 변경하거나 스크립트를 이동해야 합니다. 그렇지 않으면 스크립트에 액세스할 수 없습니다. 자세한 내용은 스크립트 항목 편집을 참조하십시오.


스크립트 항목 결합

Script Manager를 사용하여 두 개 이상의 스크립트를 하나로 결합할 수 있습니다. 스크립트를 결합하려면 모든 스크립트가 동일한 데이터 파일 내에 있어야 합니다.

결합된 후 새 스크립트는 활성 데이터 파일에 자동으로 추가됩니다.

여러 스크립트를 단일 스크립트로 결합하려면

  1. Script Manager에서 스크립트가 있는 데이터 파일을 선택합니다.

  2. 스크립트 그리드에서 결합할 스크립트를 선택합니다.

  3. Scripts 탭 도구 모음에서 Combine Scripts [image] 단추를 누릅니다.

주: 기본 경로 이름은 결합된 스크립트의 경로 이름과 같습니다. 스크립트를 다른 디렉토리에 넣으려면 여기에 전체 경로 이름을 입력할 수 있습니다.


옵션을 사용하여 스크립트 실행

Script Manager에서 스크립트를 실행하는 경우 스크립트가 실행되는 방법을 정의하는 다양한 옵션을 설정할 수 있습니다.

실행할 스크립트를 선택하려면

  1. Script Manager에서 작업할 데이터 파일을 선택합니다.

  2. 실행할 스크립트를 선택합니다.

옵션을 설정하려면

  1. Script Manager 대화 상자에서 Options [image] 단추를 누릅니다.

  2. 옵션을 설정하고 OK를 누릅니다.

스크립트 실행

Quest ScriptRunner를 사용하거나 Toad의 Script Manager에서 스크립트를 실행할 수 있습니다.

모든 데이터베이스에 대해 스크립트를 실행할 수 있습니다. 활성 연결이 없는 경우 Toad에서 연결을 연 다음 스크립트 실행이 완료되면 해당 연결을 닫습니다.

스크립트를 실행하려면

  1. 실행할 스크립트를 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Run을 선택합니다.

또는

마우스 오른쪽 단추를 누르고 Run in Quest Scriptrunner를 선택합니다.


Script Manager Options

Execution options

Execute scripts via Editor

SQL을 Editor로 스풀하고 스크립트 출력을 Script Output 탭에 표시하려면 이 옵션을 선택합니다.

이 옵션을 선택한 경우 Spool Output to File 옵션을 사용할 수 없습니다.

Spool Output to File

Editor에 출력을 표시하는 대신 SQL을 파일로 스풀하려면 이 옵션을 선택합니다.

이 옵션을 선택한 경우 Execute Scripts via Editor 옵션을 사용할 수 없습니다.

Use single file

이 옵션은 모든 출력을 지정된 단일 파일로 보냅니다. 해당 상자에 전체 경로를 포함하여 파일 이름을 입력합니다.

Use separate file for each script (autonamed)

이 옵션은 각 스크립트에 대해 별도의 파일을 작성합니다. 이 경우 Toad에서 파일 이름을 자동으로 지정합니다. 그러나 파일을 저장할 디렉토리는 지정해야 합니다.

주의: 파일은 .txt 확장명을 사용하여 원본 스크립트 이름으로 저장됩니다. 원본 스크립트의 확장명이 .txt인 경우에 원본 스크립트가 있는 디렉토리를 선택하면 새 파일이 원본 스크립트를 덮어씁니다.

Filename

사용할 출력 파일에 대한 파일 이름을 지정할 수 있습니다. 이 이름은 전역적이거나 사용하는 데이터 파일(.sdf)에만 고유할 수 있습니다.

Global

모든 데이터 파일에 사용할 출력 파일의 이름을 지정하거나 browse [image] 단추를 눌러 browse 창에서 이름을 하나 선택합니다.

Filename

선택된 데이터 파일에 사용할 출력 파일의 이름을 지정하거나 browse [image] 단추를 눌러 browse 창에서 이름을 하나 선택합니다. 지정한 SPOOL= path를 포함하는 줄이 데이터 파일에 포함됩니다.

Default execution connections

Toad에서 다양한 데이터 파일로부터의 코드를 하나 이상의 연결에서 자동으로 실행하게 할 수 있습니다. 이 상자에서 이 목록에 대해 스크립트를 실행할 연결을 추가하면 해당 연결이 데이터 파일(.sdf)에 포함됩니다. 나중에 이 데이터 파일에서 실행하는 모든 스크립트는 기본적으로 나열된 모든 연결에 대해 실행됩니다.

주: connections 드롭다운에서 Set to datafile defaults를 선택하여 연결에 대해 스크립트를 실행하도록 도구 모음에서 선택할 수 있습니다.

이 상자가 비어 있으면 connection 드롭다운에서 선택한 연결에 대해 스크립트가 자동으로 실행됩니다.

QuickScripts

Load only (no execute)

QuickScripts 목록에서 선택한 스크립트를 실행하지 않고 SQL 편집기로 로드하려면 이 옵션을 선택합니다.

기본값은 선택되지 않습니다.

Use single editor

이 옵션은 모든 스크립트를 Editor 창에 추가합니다. 이 옵션은 기본 설정입니다.

Use separate editor for each script

이 옵션은 실행하는 각 스크립트에 대해 새로운 Editor 창을 엽니다.


그리드에서 실행

옵션 단계를 진행하지 않으려면(옵션을 사용하여 스크립트 실행 참조) Editor 또는 Quest ScriptRunner를 사용하여 그리드에서 스크립트를 직접 실행할 수 있습니다.

그리드에서 스크립트를 실행하려면

  1. Script Manager에서 실행할 스크립트가 들어 있는 범주를 선택합니다.

  2. 스크립트를 마우스 오른쪽 단추로 누르고 메뉴에서 Run을 누르거나 도구 모음의 run 단추를 누릅니다.

주: 긴 스크립트를 실행할 때 스크립트가 실행되는 동안 작업을 계속하려면 Run using Quest ScriptRunner를 선택하는 것이 좋습니다. 그러면 스크립트를 배경에서 실행하고 작업을 계속할 수 있습니다.

  3. SQL Editor 또는 Quest ScriptRunner가 선택된 스크립트를 열어서 실행합니다.


QuickScripts 목록 구성

QuickScripts 목록은 Script Manager 도구 모음 [image] 단추 및 File|Run Script 메뉴에 있는 드롭다운 메뉴입니다. QuickScripts 실행 및 로드를 참조하십시오. QuickScript를 실행하려면 QuickScripts 목록을 구성해야 합니다.

QuickScripts 목록을 구성하려면

  1. 둘 이상의 데이터 파일에서 스크립트를 선택할 수 있습니다. Script Manager에서 스크립트가 있는 데이터 파일을 선택합니다.

  2. 스크립트 그리드에서 목록에 나열할 스크립트에 대해 On File Menu 확인란을 누릅니다. 그러면 해당 스크립트가 QuickScript 목록에 추가됩니다.

주: Use 그룹에 있는 모든 스크립트를 나열하려면 해당 노드에 대한 상자를 선택합니다. 그룹 내의 모든 스크립트가 선택됩니다.

  3. 나열할 모든 데이터 파일 및 스크립트에 대해 1-2단계를 반복합니다.


QuickScripts 실행

QuickScripts 실행 또는 로드

Script Manager에서 QuickScripts를 구성한 후 도구 모음 또는 File 메뉴에서 QuickScripts를 실행하거나 로드할 수 있습니다.

도구 모음에서 QuickScript를 실행하려면

  1. Main 도구 모음에서 Script Manager 드롭다운 [image] (화살표)을 누릅니다. 데이터 파일 목록이 나타납니다.

  2. 데이터 파일 중 하나를 선택합니다. 스크립트 목록이 나타납니다.

  3. 목록에서 스크립트를 선택합니다.

스크립트가 새 Editor 탭에서 실행됩니다.

File 메뉴에서 QuickScript를 실행하려면

  1. File | Run Script를 선택합니다.

  2. 하위 메뉴에서 데이터 파일을 선택합니다.

  3. 실행할 스크립트를 선택합니다.

스크립트가 새 Editor 탭에서 실행됩니다.

도구 모음 또는 File 메뉴에서 QuickScript를 로드하려면

  1. Script Manager Options 페이지에서 Load Only (no execute)가 선택되어 있는지 확인합니다.

  2. 위에 나열된 QuickScripts 실행 지침을 따릅니다. 스크립트가 실행되는 대신 로드됩니다.


Session Browser 개요

Toad Session Browser를 사용하여 세션을 쉽게 보고 작업할 수 있습니다. 모든 세션에 대한 정보는 그리드 양식으로 구성되고, Session Browser를 연 세션은 빨간색으로 표시됩니다.

Session Browser에서 다음을 수행할 수 있습니다.

  • 세션 보기 구성

  • 세부 정보 보기

  • 세션 중단

  • 추적 시작

  • 추적 중지

  • 세션에서 보류되거나 습득된 잠금 보기

  • 온라인 롤백 세그먼트에 대한 트랜잭션 정보 보기

Session Browser에 액세스하려면

  • Database|Monitor 메뉴에서 Session Browser를 선택합니다.

관련 항목

세션 중단

세션 추적

Session Browser 도구 모음

세션 그룹화


Session Browser 도구 모음

Session Browser 도구 모음을 사용하면 Session Browser를 구성할 수 있습니다.

단추 | 명령
 | 활성 세션 변경
 | 데이터 새로 고침
 | 세션 필터링
 | 자동 새로 고침에 대한 새로 고침 빈도(초) 설정
 | 자동 새로 고침 토글
 | 세부 정보 자동 가져오기 토글


Session Browser 배치 대칭 이동

Session Browser는 기본적으로 두 개의 세로 창으로 배치됩니다. 위쪽 창에는 트리 보기가 있고 아래쪽 창에는 세부 정보가 있습니다. 기본 배치에서 제공된 모든 정보를 표시하기 어려운 경우 배치를 대칭 이동하여 창을 옆으로 나란히 배치할 수 있습니다.

양식 배치를 대칭 이동하도록 선택하면 위쪽 창에 대한 참조가 왼쪽 창을 나타내고 아래쪽 창에 대한 참조가 오른쪽 창을 나타냅니다.

양식 배치를 대칭 이동하려면

  • 주 Session Browser 도구 모음에서 Flip Form [image] 단추를 누릅니다.


세션 보기

어느 한 시점에서 데이터베이스에 수천 개의 세션이 존재할 수 있습니다. 따라서 세션을 관리하기 쉽게 구성하여 표시하는 것이 좋습니다.

Session Browser의 왼쪽에는 V$SESSION에서 질의되는 하나 이상의 열이 표시됩니다. 이 패널에서 다음을 수행할 수 있습니다.

  • 7가지 다른 방법으로 V$SESSION에서 반환된 행 그룹화

  • 행을 필터링하여 행의 더 작은 하위 집합 표시


세션 도구 모음

단추 | 명령
 | 세션 중단
 | 추적 설정
 | 추적 해제
 | 세션 필터링
 | 그룹화 기준
 | 표시 열
 | 창 배치 뒤집기
 | 세부 정보 패널 새로 고침
Limit... to | 선택된 열을 필터로 제한


세션 그룹화

세션 그룹화는 세션을 보는 데 사용할 필드를 선택하는 것입니다.

예를 들어 지정된 사용자에 대한 모든 세션을 표시하도록 선택하면 위쪽 창 트리가 사용자를 기준으로 구성됩니다.

세션을 그룹화하는 기준은 다음과 같습니다.

  • 세션이 실행되는 프로그램

  • 사용자

  • 세션 상태

  • 세션이 실행되는 서버

  • 세션 유형

  • 자원 소비자 그룹

  • 운영 체제 사용자

세션을 그룹화하려면

  • 위쪽 창을 마우스 오른쪽 단추로 누르고 Group by를 선택합니다.

또는

Group by [image] 드롭다운 단추를 선택합니다.

트리가 새로 고쳐지고 선택한 열에 따라 세션이 그룹화됩니다. 이 때 첫 번째 열의 캡션이 업데이트되어 새 조직이 반영됩니다.


세션 필터링

맨 위 패널에 표시된 세션을 사용자 정의 필터와 정적 필터의 두 가지 방법으로 필터링할 수 있습니다.

사용자 정의 필터

사용자 정의 필터는 결과 집합에서 수행되는 하위 질의나 조건을 나타냅니다. 기준을 정의하고 이름을 지정합니다. 그러면 디스크에서 TOAD.INI와 동일한 디렉토리에 있는 Toad_SESSBROWFILTERS.INI 파일에 저장됩니다.

정적 필터

정적 필터를 선택할 수도 있습니다. 정적 필터는 사용자 정의 필터와 함께 사용되는 사전 정의된 읽기 전용 필터입니다.


Session Browser: 사용자 정의 필터

사용자 정의 필터

사용자 정의 필터는 결과 집합에서 수행되는 하위 질의나 조건을 나타냅니다. 기준을 정의하고 이름을 지정합니다. 그러면 디스크에서 TOAD.INI와 동일한 디렉토리에 있는 Toad_SESSBROWFILTERS.INI 파일에 저장됩니다.

사용자 정의 필터를 작성하고 관리하려면

  • Sessions 탭에서 Filter [image] 단추를 누릅니다.

왼쪽 패널

Filters 대화 상자의 왼쪽 패널에는 현재 정의된 필터 목록이 표시됩니다.

최소 버전

필터를 작성하면 식에 포함된 열 목록을 구문 분석한 후 다양한 Oracle 버전의 알려진 열 목록과 비교하여 검사합니다.

이전 버전 Oracle에 없는 열을 선택하면 식을 평가한 후 필요한 최소 Oracle 버전을 필터의 일부로 저장합니다. 사용자가 Session Browser를 열면 현재 Oracle 연결에 유효한 필터만 창 맨 위의 드롭다운 필터 목록에 표시됩니다.

오른쪽 패널

오른쪽에는 Session Browser에서 평가된 필터 식이 표시되고 Session Browser에서 맨 위 패널 트리 보기를 채우기 위해 실행할 질의가 표시됩니다. 이 영역은 읽기 전용입니다.

편의를 위해 필터 INI의 이름과 위치가 이 창의 상태 표시줄에 표시됩니다.


사용자 정의 필터 추가

사용자 자신의 필터를 정의하여 세션을 구성할 수 있습니다.

필터를 추가하려면

  1. Filter Name 상자에 이름을 입력합니다. 이 때 필터를 쉽게 식별할 수 있는 설명적인 이름을 사용해야 합니다.

  2. Expression 상자에 식을 입력합니다.

  3. 식을 작성한 후 Test를 눌러 식에 대한 질의를 생성하고 그 결과를 Filter Test 창에 표시합니다. 그러면 올바른 구문으로 질의 식을 작성했는지 및 기대한 결과 집합이 표시되는지를 간단하게 확인할 수 있습니다.

  4. 필터를 완전히 정의했으면 OK를 눌러 필터를 Toad_SESSBROWFILTERS.INI 파일에 저장합니다.

Add Filter 대화 상자 기능

Expression 상자

자유 형태 텍스트나 그 아래의 선택 상자를 사용하여 요소를 끌어 놓거나 두 번 눌러 식에 포함시킵니다.

Columns

Columns 트리에는 필터에 포함될 수 있는 세 가지 보기 각각에 대한 모든 열이 표시됩니다. 트리 보기에서 열을 선택하면 원래의 보기에 따라 열 이름에 별칭 접두사가 붙습니다.

보기 | 접두사
V$SESSION | .s
V$PROCESS | .p
V$SESS_IO | .io

주: Expression 상자에 열을 수동으로 입력하는 경우 이 별칭 규칙을 준수해야 필터가 작동합니다.

Lookup

Lookup 단추는 기본 보기에서 열에 대한 값을 고유하게 선택합니다. 예를 들어 사용자 목록에 대해 반환되는 세션을 제한하려면 세션 트리 보기 노드에서 Username 열을 선택하고 Lookup을 누를 수 있습니다.

여러 Lookup 창을 한 번에 열 수 있습니다. 이 창은 데이터베이스의 현재 상한값과 하한값을 표시하기 때문에 범위 검사를 수행하려는 숫자 열 또는 대형 목록에 유용할 수 있습니다.

Lookup을 사용하려면

  • 열 영역에서 열을 선택하고 Lookup을 누릅니다.

열에 있는 값이 표시된 작은 Stay-on-Top 창이 나타납니다. 이 작은 창에서 다음을 수행할 수 있습니다.

  • 값을 두 번 눌러 Expression 상자에 복사

  • 값을 끌어서 Expression 상자에 놓기

  • 여러 개의 값을 선택한 다음 Expression 상자로 끌어서 놓기

문자열 값의 경우 값을 Expression 상자로 복사하면 값이 작은 따옴표로 구분됩니다.


사용자 정의 필터 편집

새 필터를 추가하는 것과 동일한 방법으로 사용자 정의 필터를 편집합니다. 이름을 포함하여 필터의 모든 부분을 편집할 수 있습니다.

사용자 정의 필터를 편집하려면

  • Session Browser Filter 대화 상자에서 편집할 필터를 선택한 다음 Edit를 누릅니다.

Edit Filter 대화 상자가 표시되면 사용자 정의 필터 추가 항목에서 설명한 것과 동일한 도구를 사용할 수 있습니다.


사용자 정의 필터 삭제

직접 작성한 필터인지 Toad와 함께 제공된 표준 필터인지 여부에 관계 없이 사용자 정의 필터를 쉽게 삭제할 수 있습니다.

사용자 정의 필터를 삭제하려면

  1. Session Browser Filters 대화 상자에서 삭제할 필터를 선택한 다음 Delete를 누릅니다.

이 필터를 영구히 삭제할지 묻는 확인 메시지가 표시됩니다.

  2. OK를 누릅니다.

주: 표준 필터를 편집하거나 삭제하면 해당 필터가 toad_sessbrowfilters.ini 파일에서 제거됩니다. 이러한 필터를 변경할 경우 이 파일의 백업을 보관해 두는 것이 좋습니다.


정적 필터

정적 필터는 사용자 정의 필터와 함께 또는 단독으로 적용되는 내부 조건입니다.

정적 필터를 적용하려면

  • Filter dropdown [image] 단추(화살표 누름)를 누르고 다음 중 하나를 선택합니다.

  • Exclude NULL and SYSTEM OS Users

  • Exclude parallel slaves

정적 필터를 선택하면 해당 필터에 확인 표시가 나타나고 필터 아이콘이 빨간색으로 바뀝니다.

한 번에 둘 이상의 정적 필터를 선택할 수도 있고, 정적 필터와 사용자 정의 필터를 함께 사용할 수도 있습니다. 어느 경우든 정적 필터는 사용자 정의 필터 식의 끝에 AND 조건으로 포함됩니다.

NULL 제외

( (s.USERNAME is not null) and (NVL(s.osuser,''x'') <> ''SYSTEM'') and (s.type <> ''BACKGROUND'') )

종속 제외

(s.ownerid = 2147483644)

병렬 종속의 정의에 대한 내용은 병렬 종속 프로세스의 항목을 참조하십시오.


병렬 종속 프로세스

Oracle은 특정 SQL 작업을 병렬화할 수 있습니다. 여기에는 각각 별도의 프로세스에서 처리되는 작은 단위로 작업을 분할하는 과정이 포함됩니다. 이러한 별도의 프로세스는 V$SESSION 보기에 표시되지만 해당 프로세스를 생성한 프로세스의 소유이기 때문에 종료하거나 추적할 수 없습니다. 또한 왼쪽 트리 보기에서 해당 프로세스를 소유한 프로세스 아래에 하위 노드로 표시됩니다.

병렬 종속 프로세스는 트리의 세 번째 수준에 표시되는 유일한 노드입니다.

주: 트리 보기에서 맨 위 수준 노드(예: 프로그램 이름)를 선택하면 detail 탭에 병렬 종속에 대한 세션 정보가 자동으로 표시되지 않습니다. 병렬 종속에 대한 세부 정보를 표시하려면 마스터 세션이나 종속 자체를 선택해야 합니다.

병렬 종속 프로세스는 사용 가능한 종속 풀에서 가져오면 작업이 완료될 때까지 V$SESSION에 표시된 다음 풀로 돌아갑니다.

이러한 프로세스를 작성하는 질의 예는 다음과 같습니다.

select /*+ parallel(x,4) parallel(y,4) */ * from all_objects x, all_objects y;

종속 세션은 2147483644와 같지 않은 ownerid를 가지고 V$SESSION에 표시됩니다. 즉, 종속 세션이 아닌 모든 세션은 소유자 ID가 2147483644입니다. 종속 세션은 ownerid가 4바이트 값입니다. 여기서 하위 2바이트는 소유 세션의 세션 번호를 나타내고, 상위 바이트는 질의 코디네이터를 나타냅니다.

이러한 종속 세션이 트리에 표시되지 않게 할 수 있는 정적 필터가 있습니다(정적 필터 참조).


표시할 열 선택

V$SESSION의 대부분의 열은 Session Browser의 왼쪽 트리 보기 표시에 포함될 수 있습니다.

둘 이상의 열을 선택한 경우 해당 열을 보려면 스크롤해야 할 수도 있습니다. 열을 원하는 위치로 끌어 놓아서 다시 정렬할 수 있습니다. 그러나 첫 번째 열은 위치를 변경할 수 없으므로 열을 끌어서 첫 번째 열을 바꿀 수 없습니다.

V$SESSION 열을 표시하려면

  1. Sessions 탭을 선택합니다.

  2. 아래에 나열된 방법 중 하나를 수행합니다.

  3. 맨 위 패널 트리 보기를 마우스 오른쪽 단추로 누르고 Visible Columns를 선택한 다음 표시할 열을 선택합니다. 마우스 오른쪽 단추 메뉴에서 열을 개별적으로 선택해야 합니다.

  4. 도구 모음에서 Visible Columns [image] 단추를 눌러 여러 열을 한 번에 선택할 수 있습니다.

계산된 V$SESSION 열

목록에는 Last_call이라는 계산된 열도 하나 포함되어 있습니다. 이 열은 다음과 같이 계산됩니다.

SYSDATE-Last_call_et

Last_call_et는 마지막 세션이 호출된 이후에 경과한 시간(초)이고 Last_call은 이 값의 보다 유용한 표현입니다. Last_call은 연결의 유휴 상태를 나타냅니다.


세션 세부 정보 보기

Session Browser의 오른쪽에는 왼쪽에서 선택된 세션에 대한 세부 정보가 표시됩니다. 세션을 하나만 선택할 수도 있고 여러 세션을 선택하여 집계 정보를 볼 수도 있습니다.

세션 정보를 보려면

  • 맨 위 패널에서 Sessions 탭을 누릅니다. 하나 이상의 세션을 선택합니다.

오른쪽에는 다음 주제에 대한 세부 정보를 볼 수 있는 탭 페이지가 표시됩니다.

  • Session

  • Locks

  • Long Ops

  • RBS Usage

  • Statistics

  • Waits

  • Process

  • IO

  • Current Statement(단일 세션을 선택한 경우에만 사용 가능)

  • Open Cursors

  • Access


Session 세부 정보

다음 질의를 사용하여 Session 세부 정보를 표시합니다.

SELECT * FROM V$SESSION WHERE {currently selected left side SIDs}

Session 페이지의 맨 아래에 있는 탭을 사용하여 단일 보기 또는 여러 보기를 선택할 수 있습니다.

단일 레코드 보기

단일 SID 보기에는 선택된 session에 대한 보다 많은 정보 열이 제공됩니다.

단일 레코드에 대한 정보를 보려면

  1. 맨 위 패널에서 보려는 session을 선택합니다.

  2. 아래쪽 패널에서 Session 탭을 누릅니다.

  3. 페이지 맨 아래에 있는 Single탭을 누릅니다.

여러 레코드 보기

여러 레코드 보기에는 모든 선택된 session에 대한 집계 정보가 제공됩니다.

여러 레코드에 대한 정보를 보려면

  1. 맨 위 패널에서 보려는 session을 여러 개 선택합니다. 모든 세션은 동일한 노드 내에 있어야 합니다.

  2. 아래쪽 패널에서 Session 탭을 누릅니다.

  3. 페이지 맨 아래에 있는 Multi탭을 누릅니다.


Process 세부 정보

Process 세부 정보는 다음 질의를 사용하여 제공됩니다.

SELECT * FROM V$PROCESS WHERE {currently selected left side process addresses}

맨 위 패널에서 단일 세션을 선택한 경우 Process 페이지 아래쪽에 있는 탭을 사용하여 보기를 하나 또는 여러 개 선택할 수 있습니다.

단일 레코드 보기

단일 레코드 보기에는 선택된 세션에 대한 보다 많은 정보 열이 제공됩니다.

단일 레코드에 대한 정보를 보려면

  1. 맨 위 패널에서 보려는 세션을 선택합니다.

  2. 맨 아래 패널에서 Process 탭을 누릅니다.

  3. 페이지 맨 아래에 있는 Single탭을 누릅니다.

여러 레코드 보기

여러 레코드 보기에는 모든 선택된 세션에 대한 집계 정보가 제공됩니다.

여러 레코드에 대한 정보를 보려면

  1. 맨 위 패널에서 보려는 세션을 여러 개 선택합니다. 모든 세션은 동일한 노드 내에 있어야 합니다.

  2. 맨 아래 패널에서 Process 탭을 누릅니다.

  3. 페이지 맨 아래에 있는 Multi탭을 누릅니다.

관련 항목

Session Browser 개요


IO 세부 정보

IO 세부 정보는 다음 질의를 사용하여 제공됩니다.

SELECT * FROM V$SESS_IO WHERE {currently selected left side SIDs}

위쪽 패널에서 단일 세션을 선택한 경우 IO 페이지 아래쪽에 있는 탭을 사용하여 보기를 하나 또는 여러 개 선택할 수 있습니다.

단일 레코드 보기

단일 레코드 보기는 선택된 세션에 대해 보다 많은 정보 열을 제공합니다.

단일 레코드에 대한 정보를 보려면

  1. 위쪽 패널에서 보려는 세션을 선택합니다.

  2. 아래쪽 패널에서 IO 탭을 누릅니다.

  3. 페이지 아래쪽에 있는 Single탭을 누릅니다.

여러 레코드 보기

여러 레코드 보기에는 모든 선택된 세션에 대한 집계 정보가 제공됩니다.

여러 레코드에 대한 정보를 보려면

  1. 위쪽 패널에서 보려는 세션을 여러 개 선택합니다. 모든 세션은 동일한 노드 내에 있어야 합니다.

  2. 아래쪽 패널에서 IO 탭을 누릅니다.

  3. 페이지 아래쪽에 있는 Multi탭을 누릅니다.


Waits 세부 정보

Waits 세부 정보를 사용하여 데이터베이스에 대해 가능한 조정 고려 사항을 제공할 수 있습니다.

페이지는 V$SESSION_WAIT 및 V$SESSION_EVENT에서 선택된 다양한 열로 구성됩니다.

주: WAIT_TIME 열은 빠른 타이밍 메커니즘을 지원하지 않는 플랫폼에서 -2 값을 포함합니다. 이러한 플랫폼 중 하나에서 실행할 때 이 열에 실제 대기 시간을 표시하려면 TIMED_STATISTICS 매개 변수를 TRUE로 설정해야 합니다. 그렇게 하면 시스템 성능에 약간의 나쁜 영향을 줄 수 있습니다.

대기 세부 정보를 보려면

  1. session 또는 multiple sessions을 선택합니다.

  2. Waits 탭을 눌러 선택된 세션이 대기 중인 자원 또는 이벤트를 봅니다.

열 헤더를 눌러 대기 데이터를 정렬할 수 있습니다.


Current Statement Details

Session Browser의 이 페이지에서 선택된 세션에 대한 현재 SQL 문을 볼 수 있습니다. 한 번에 하나의 선택된 세션에 대한 데이터만 볼 수 있습니다. 둘 이상의 세션을 선택하면 데이터 영역에 "Multiple sessions selected"라는 메시지가 표시됩니다.

Current Statement 도구 모음

Current Statement 탭의 도구 모음을 사용하여 문을 여러 방법으로 조작할 수 있습니다.

단추 | 명령
 | 클립보드에 스크립트 복사
 | Editor에서 스크립트 로드
 | SQL Tuning/Optimizer를 사용하여 문 조정

문 세부 정보 보기

문 세부 정보를 보려면

  1. 맨 위 패널에서 세션을 선택합니다.

  2. Current Statement 탭을 눌러 선택된 세션에 대한 현재 문을 표시합니다.

  3. Explain Plan 탭을 눌러 조정 또는 문제 해결을 위해 현재 문에 대한 explain plan을 표시합니다.

  4. Information 탭을 눌러 V$SQL 보기의 데이터를 표시합니다. 여기에는 공유 SQL 영역에 대한 통계 데이터가 포함되어 있습니다.


Open Cursors Details

이 페이지를 사용하여 V$OPEN_CURSOR의 데이터를 볼 수 있습니다. 이 데이터에는 선택한 각 세션에서 열고 구문 분석한 커서가 나열되어 있습니다. 한 번에 여러 세션의 데이터를 볼 수 있습니다.

Open Cursors Details를 보려면

  1. 맨 위 패널 트리 보기에서 하나 이상의 세션을 선택합니다. 열려 있고 구문 분석된 커서를 포함하는 문이 맨 아래 패널에 표시됩니다.

  2. Explain Plan 탭을 눌러 Open Cursor data 그리드에 현재 선택되어 있는 문에 대한 설명 계획을 표시하여 조정 또는 문제 해결을 검토할 수 있습니다.

  3. Information 탭을 눌러 V$SQL 보기의 데이터를 표시할 수 있습니다. 여기에는 공유 SQL 영역에 대한 통계 데이터가 포함되어 있습니다.


액세스 세부 정보

이 페이지에는 V$ACCESS의 데이터가 표시되고 선택된 세션에서 현재 잠겨 있는 데이터베이스의 개체가 나열됩니다.

액세스 세부 정보를 보려면

  1. 맨 위 패널 트리 보기에서 하나 이상의 세션을 선택합니다.

  2. Access 탭을 누릅니다.


Locks 세부 정보

사용자 잠금과 시스템 잠금이 여기에 표시됩니다. 사용자 잠금에는 트랜잭션, 사용자 및 차단 잠금이 표시됩니다. 이 데이터는 V$LOCK에서 질의됩니다.

주: 다음 절차에서 표시된 정보는 개별 데이터베이스 정보입니다. 집계 잠금 세부 정보에 대한 자세한 내용은 잠금 집계 정보 보기 항목을 참조하십시오.

잠금 유형

locks 페이지에서 잠금은 Transaction, DML & PL/SQL 잠금과 Blocked 또는 Blocking 잠금의 두 그룹으로 구분됩니다. Blocking 및 Blocked 잠금은 맨 위 영역에서 선택한 트랜잭션에 종속됩니다.

페이지 아래쪽에서 사용자를 차단하거나 선택된 사용자에 대해 차단될 잠금을 표시하도록 선택할 수 있습니다.

잠금 세부 정보를 보려면

  1. Sessions 탭을 누릅니다(선택하지 않은 경우).

  2. 맨 위 패널의 세션 트리 보기에서 하나 이상의 세션을 선택합니다.

  3. 맨 아래 패널에서 Locks 탭을 누릅니다.

주: Locks 탭을 보려면 맨 아래 패널에서 탭을 스크롤해야 할 수도 있습니다.

사용자 잠금을 보려면

  • Locks 페이지 맨 아래에 있는 User 탭을 선택합니다.

시스템 잠금을 보려면

  • Locks 페이지 맨 아래에 있는 System 탭을 선택합니다.


RBS Usage 세부 정보

선택된 세션의 온라인 롤백 세그먼트에 대한 트랜잭션 정보를 표시하려면 이 탭을 선택합니다. 이 정보는 SYS.V_$TRANSACTION 및 SYS.V_$ROLLNAME에서 질의됩니다.

이 절차에서 제공되는 정보는 개별 RBS Usage 정보입니다. 집계 정보는 RBS Usage 집계 정보 보기를 참조하십시오.

RBS Usage 세부 정보를 보려면

  1. Sessions 탭을 누릅니다(선택하지 않은 경우).

  2. 맨 위 패널의 세션 트리 보기에서 세션 하나를 선택합니다.

  3. 오른쪽 패널에서 RBS Usage 탭을 누릅니다.

주: RBS Usage 탭을 보려면 오른쪽 패널에서 탭을 스크롤해야 할 수도 있습니다.


Long Ops 세부 정보

현재 선택된 세션에 대한 V$SESSION_LONGOPS의 데이터입니다. Oracle에서는 일부 백업 및 복구 기능, 통계 수집 및 질의 실행을 포함하여 6초 이상 실행되는 작업을 long ops라고 합니다. Long Ops에 포함되는 작업에 대한 자세한 내용은 Oracle 설명서를 참조하십시오.

Long Ops 세부 정보를 보려면

  1. Sessions 탭을 누릅니다(선택하지 않은 경우).

  2. 맨 위 패널의 세션 트리 보기에서 하나 이상의 세션을 선택합니다.

  3. 맨 아래 패널에서 Long Ops 탭을 누릅니다.

주: Long Ops 탭을 보려면 맨 아래 패널에서 탭을 스크롤해야 할 수도 있습니다.

Percent 열 계산

Percent 열은 다음과 같이 계산됩니다.

decode(totalwork, 0, 0, round(100 * sofar/totalwork, 2))


Statistics Details

이 탭에는 현재 선택된 세션에 대한 세션 통계인 V$SESSTAT의 데이터가 표시됩니다.

통계 세부 정보를 보려면

  1. Sessions 탭을 누릅니다(선택하지 않은 경우).

  2. 맨 위 패널의 세션 트리 보기에서 하나 이상의 세션을 선택합니다.

  3. 맨 아래 패널에서 Statistics 탭을 누릅니다.

주: Statistics 탭을 보려면 맨 아래 패널에서 탭을 스크롤해야 할 수도 있습니다.

열 헤더를 눌러 대기 데이터를 정렬할 수 있습니다.


잠금 집계 정보 보기

여기에는 페이지 맨 아래에서 선택한 탭에 따라 사용자 잠금 및 시스템 잠금이 표시됩니다.

주: 여기에 표시되는 정보는 집계 데이터베이스 정보입니다. 개별 세션에 대한 잠금 세부 정보 보기에 대한 자세한 내용은 잠금 세부 정보 항목을 참조하십시오.

잠금 유형

locks 페이지에서 잠금은 Transaction, DML & PL/SQL 잠금과 Blocked 또는 Blocking 잠금의 두 그룹으로 구분됩니다. Blocking 및 Blocked 잠금은 맨 위 영역에서 선택한 트랜잭션에 종속됩니다.

페이지 아래쪽에서 사용자를 차단하거나 선택된 사용자에 대해 차단될 잠금을 표시하도록 선택할 수 있습니다.

사용자 잠금

사용자 잠금에는 트랜잭션, 사용자 및 차단 잠금이 표시됩니다. 이 데이터는 V$LOCK에서 질의됩니다. Transaction Lock 그리드의 행이 변경되면 해당 선택에 대한 사용자 및 차단 잠금 그리드가 업데이트됩니다.

사용자 잠금을 보려면

  1. 위쪽 패널의 맨 위에 있는 Locks 탭을 누릅니다.

  2. 표시되는 패널의 맨 아래에 있는 User 탭을 누릅니다.

시스템 잠금

시스템 잠금을 보려면

  1. 위쪽 패널의 맨 위에 있는 Locks 탭을 누릅니다.

  2. 표시되는 패널의 맨 아래에 있는 Session 탭을 누릅니다.


RBS Usage 정보 보기

RBS Usage 집계 정보 보기

이 페이지에는 SYS.V_$TRANSACTION 및 SYS.V_$ROLLNAME에서 질의되는 온라인 롤백 세그먼트에 대한 트랜잭션 정보가 표시됩니다.

주: 여기에 표시된 RBS Usage 정보는 집계 데이터베이스 정보입니다. 개별 RBS Usage에 대한 자세한 내용은 RBS Usage 세부 정보를 참조하십시오.

RBS Usage 정보를 보려면

  • 위쪽 패널의 맨 위에 있는 RBS Usage 탭을 누릅니다.


세션 종료

세션 중단단

세션 중단 기능은 권한 상태에 따라 다릅니다. 대부분의 비종속 세션은 다음 중 한 가지 방법으로 중단할 수 있습니다.

  • 선택된 세션 중단

  • 여러 개를 선택하여 한 번에 여러 세션 중단

  • 맨 위 수준 노드를 중단하여 해당 노드 아래의 모든 세션 중단

예를 들어 선택된 사용자에 대한 모든 세션을 중단할 수 있습니다. 맨 위 수준 노드를 여러 개 선택하여 선택된 모든 노드와 해당 하위 노드를 중단할 수도 있습니다.

종속 세션에 대한 자세한 내용은 병렬 종속 프로세스를 참조하십시오.

세션을 중단하려면

  1. 중단할 세션을 쉽게 볼 수 있도록 세션을 필터링하거나 그룹화합니다.

  2. 위쪽 패널 트리 보기에서 중단할 세션, 여러 세션 또는 노드를 선택합니다.

  3. 다음 작업 중 하나를 수행하십시오.

  4. 도구 모음에서 Kill Session [image] 단추를 누릅니다.

  5. 마우스 오른쪽 단추를 누르고 Kill Sessions를 선택합니다.

  4. OK를 눌러 선택을 확인하고 세션을 중단합니다.

세션을 중단하는 데 사용되는 질의

이후 버전의 Oracle에서는 다음과 같은 질의가 사용됩니다.

ALTER SYSTEM DISCONNECT SESSION <sid, serial#> IMMEDIATE

이전 버전의 Oracle에서는 다음과 같은 구문이 사용됩니다.

ALTER SYSTEM KILL SESSION <sid, serial#>


세션 추적

Session Browser에서 선택된 세션에 대한 추적 기능을 설정하거나 해제할 수 있습니다.

Toad에서는 다음과 같은 절차를 사용하여 세션을 추적합니다.

SYS.DBMS_SYSTEM.SET_SQL_TRACE_IN_SESSION( sid, serial#, TRUE/FALSE )

주: 추적 파일은 INIT.ORA 매개 변수 user_dump_dest에 기록됩니다. 이 매개 변수는 일반적으로 서버의 bdump 디렉토리입니다. 해당 위치에서 찾을 수 없는 경우 Oracle 매개 변수에서 user_dump_dest의 경로 이름이 변경되었는지 확인합니다.

추적 기능을 설정하려면

  1. 추적할 세션을 쉽게 볼 수 있도록 세션을 필터링하거나 그룹화합니다.

  2. 위쪽 패널 트리 보기에서 세션, 여러 세션 또는 노드를 선택합니다.

  3. 다음 작업 중 하나를 수행하십시오.

  4. 도구 모음에서 Trace On 단추를 누릅니다.

  5. 마우스 오른쪽 단추를 누르고 Start Trace를 선택합니다.

  4. 확인 창에서 OK를 누릅니다.

추적 기능을 해제하려면

  1. 추적할 세션을 쉽게 볼 수 있도록 세션을 필터링하거나 그룹화합니다.

  2. 위쪽 패널 트리 보기에서 세션, 여러 세션 또는 노드를 선택합니다.

  3. 다음 작업 중 하나를 수행하십시오.

  4. 도구 모음에서 Trace Off 단추를 누릅니다.

  5. 마우스 오른쪽 단추를 누르고 Stop Trace를 선택합니다.

  4. 확인 창에서 OK를 누릅니다.


소스 제어

기본 소스 제어

Toad에서는 Microsoft API인 SCC(Source Code Control)가 지원됩니다. SCC는 개발 환경과 소스 제어 제품 간의 표준 인터페이스를 정의합니다. SCC API는 체크아웃, 체크인 및 파일 추가와 같은 일반 소스 제어 작업을 수행하기 위한 기능을 제공합니다.

SCC는 다음 위치에서 구현됩니다.

  • Schema Browser|Favorites 페이지

  • Project Manager

  • Editor

  • Script Debugger

기본 체크인 및 체크아웃 기능보다 많은 기능이 필요한 경우 Team Coding을 사용하는 것을 고려하십시오. Team Coding과 SCC는 함께 사용할 수 있습니다. 자세한 내용은 Team Coding 및 SCC 상호 작용을 참조하십시오.

다음 공급업체는 SCC API를 지원하며 Toad에서 테스트되었습니다.

  • Win98 및 NT4/Win2K/XP에서의 Microsoft Visual SourceSafe 6.0

  • NT4/Win2K/XP에서의 PVCS 6.6.0, 6.7.0, 6.8.0, 6.8.1, 7.5.0(VM Development Interface 필요)

  • Win98 및 NT4/Win2K/XP에서의 StarTeam 5.2(VB 및 Developer Studio Integration 옵션 필요)

  • Quma QVCS 3.5(QVCS 클라이언트를 사용하여 QVCS를 소스 제어 제공자로 추가)

  • NT4/Win2K/XP에서의 CS-RCS 2.5.140 및 3.0.192(ComponentSoftware)

  • CVS 1.11.14

주: 이러한 소프트웨어 제품의 이전 버전은 Toad에서 테스트되지 않았으므로 호환성을 보장할 수 없습니다. 다른 공급업체가 이 API를 따를 수도 있지만 Toad에서 테스트되지 않았기 때문에 현재는 통합을 보장할 수 없습니다.

각 SCC 규격 제품은 자신을 SCC 제공자로 식별하고 SCC 기능을 호출하는 데 사용되는 DLL의 위치를 식별하는 항목을 레지스트리에 만듭니다.

주: 소스 제어 설치의 클라이언트 부분이 실행되어야 합니다. 소스 제어 설치의 서버 부분만 실행할 수는 없습니다.

소스 제어를 처음 설정

소스 제어를 사용하도록 준비하려면

  1. 클라이언트를 설치합니다.

  2. SCC API를 지원하도록 클라이언트가 구성되었는지 확인합니다. 클라이언트 또는 클라이언트 설치에서 SCC API 레지스트리 키를 작성했는지 검사하여 이를 확인합니다.

  3. View 메뉴에서 Toad Options를 선택하고 Source Control을 누릅니다.

  4. SCC 제공자를 선택하고 옵션을 원하는 대로 선택/선택 취소합니다. 소스 제어 옵션을 참조하십시오.

  5. Editor에서 파일을 엽니다. Toad 소스 제어가 Editor를 통해 실행된다는 것에 주의합니다.

  6. Editor를 마우스 오른쪽 단추로 누르고 Source Control을 선택합니다. Select Project를 누릅니다.

  7. SCC 제공자는 프로젝트를 선택하라는 대화 상자를 표시합니다. 제공자와 구성에 따라 로그인하거나 데이터베이스를 탐색하라는 메시지가 표시될 수도 있습니다. 작업 폴더를 설정하기 위한 위치가 제공될 수 있습니다. 자세한 내용은 소스 제어 제공자의 설명서를 참조하십시오.

주: 선택한 프로젝트의 작업 디렉토리는 파일을 로드한 디렉토리와 일치해야 합니다.

  8. 파일이 이미 소스 제어에 저장된 경우 체크인 및 체크아웃할 수 있습니다. 그렇지 않은 경우에는 마우스 오른쪽 단추를 누르고 Source Control > Add File을 선택하여 소스 제어 데이터베이스에 추가할 수 있습니다. 이렇게 하면 체크인된 상태가 파일에 할당됩니다. 파일을 수정하려면 체크아웃해야 합니다.

소스 제어 옵션

View|Toad Options|Team Coding 페이지에서 소스 제어 옵션을 선택하여 SCC에 대한 인터페이스도 구성해야 합니다.

소스 제어 옵션을 설정하려면

  1. 드롭다운 메뉴에서 Toad와 함께 사용할 소스 제어 제공자를 선택합니다. 소스 제어 제공자 드롭다운에는 레지스트리에서 발견된 SCC 제공자가 나열됩니다. 소스 제어 제공자가 설치되지 않은 경우 드롭다운 메뉴는 비어 있습니다.

주: 제공자를 전환할 경우 Toad를 다시 시작해야 합니다.

  2. 해당 Prompt for Comment 확인란을 선택하거나 선택 취소합니다. 선택할 경우 해당 작업과 함께 주석을 입력하라는 메시지가 표시됩니다.

참고 항목: 소스 제어 옵션


Source Control 실행

Source Control은 Editor에서 실행됩니다. Editor 도구 모음에서 파일을 체크 인 또는 체크 아웃할 수 있습니다. 다른 기능은 모두 아래 설명대로 마우스 오른쪽 단추 메뉴에서 액세스할 수 있습니다.

Source Control을 작업할 때 다음 사항을 유의합니다.

  • 파일이 체크 아웃되지 않으면 읽기 전용 상태여야 합니다. 읽기 전용 파일을 편집할 수 없습니다.

  • 모든 SCC 함수는 현재 로드된 파일에 따라 작동합니다.

  • Source Control 기능은 데이터베이스 개체가 아닌 파일만 작업합니다.

마우스 오른쪽 단추 메뉴

Source Control 마우스 오른쪽 단추 옵션에서 다음 기능을 액세스할 수 있습니다.

Check-out File

파일을 Editor 도구 모음 및 마우스 오른쪽 단추 메뉴에서 모두 사용할 수 있는지 체크 아웃합니다. 파일이 체크 아웃되면 해당 파일이 Source Control 파일에서 다시 로드되어 기록할 수 있게 됩니다. 파일은 한 사람이 한 번만 체크 아웃할 수 있습니다. 이 파일이 가장 최신 파일이 됩니다. 로컬로 저장한 읽기 전용 파일과 다를 수 있습니다.

Check-in File

파일을 Editor 도구 모음 및 마우스 오른쪽 단추 메뉴에서 모두 사용할 수 있는지 체크 인합니다. 파일이 체크 인되면 다시 읽기 전용으로 설정됩니다.

Undo-checkout

이 명령은 변경한 내용을 모두 취소하고 원래 읽기 전용 버전을 사용합니다. 변경한 다음 적용 불가능한 것으로 결정할 경우 유용합니다.

주: 파일을 체크 아웃하는 동안 변경한 내용은 모두 손실됩니다.

Get latest version

이 명령은 Source Control에서 파일을 새로 고치고 로컬 시스템에 파일을 다시 로드합니다. 파일이 읽기 전용으로 남습니다. 변경하려면 체크 아웃해야 합니다.

Add File

새 파일을 작성한 경우 Add File 명령을 사용하여 Source Control에 추가하고 로컬 사본을 읽기 전용으로 만듭니다. 새 프로젝트(파일)에만 사용해야 합니다.

Select project

이 명령은 Source Control 프로젝트를 선택할 수 있는 제공자 특정 대화상자를 만듭니다. 선택한 프로젝트는 Toad 세션 간의 .ini 파일에 유지됩니다.


Team Coding 및 SCC 상호 작용

Team Coding 기능과 SCC(Source Code Control)를 함께 사용할 수 있습니다. 두 기능은 다음과 같이 상호 작용합니다.

SCC 구현 | 파일의 TC 구현
Schema Browser, Favorites 페이지 | Schema Browser, Favorites 페이지
Project Manager | Editor(스크립트)
Editor | Editor

Team Coding을 활성화하면 Editor에서 SCC 기능이 비활성화되고 그 외의 위치에서는 SCC 기능이 활성화된 상태로 유지됩니다.


SQL Navigator 환경에서 Team Coding 사용

Team Coding에서는 SQL Navigator로 설치한 Team Coding 환경을 사용할 수 있습니다. 그러면 동일한 데이터베이스에서 Toad 사용자와 SQL Navigator 사용자 간에 Team Coding 협력이 가능합니다.

Team Coding 환경 요구 사항

데이터베이스에 설치된 SQL Navigator Team Coding 환경이 버전 6여야 합니다. 이 버전은 SQL Navigator 4.3과 함께 릴리스되었습니다. 이전 버전 Team Coding 환경이 검색될 경우 해당 환경을 업데이트할 때까지 Team Coding이 비활성화됩니다. Toad Server Side Object 마법사를 사용하여 환경을 업데이트할 수 있습니다.

주: SQL Navigator를 통해 SQL Navigator 개체를 설정해야 합니다. Toad에서 SQL Navigator Team Coding 개체를 사용하도록 지정하고 Toad에서 해당 환경을 사용할 수 있도록 Toad를 통해 이전 버전을 업데이트할 수 있습니다.

SQL Navigator 환경에서 사용하도록 Team Coding 설정

Toad를 설치할 때 SQL Navigator Team Coding 버전 6 환경이 있는 경우 Team Coding 사용을 위해 별도의 작업을 수행할 필요가 없습니다.

SQL Navigator 4.1 또는 4.2를 사용하여 환경을 작성한 경우에는 Server Side Objects 마법사를 사용하여 해당 환경을 업그레이드해야 합니다.

SQL Navigator Team Coding 환경을 업그레이드하려면

  1. Database|Administer 메뉴에서 Server Side Install 마법사를 엽니다.

  2. Install, upgrade or remove objects for all users to share를 선택한 다음 Next를 누릅니다.

  3. 세 번째 단추(Install, upgrade or remove objects in a schema other than Toad)를 선택하고 SQLNAV 사용자로 로그온합니다. Next를 누릅니다.

  4. Team Coding 영역에서 Upgrade to 6.0 objects를 선택합니다. Next를 누릅니다.

  5. 원하는 경우 Team Coding 역할을 변경합니다. Next를 누릅니다.

  6. Run Script를 눌러 Team Coding 개체를 업그레이드합니다.

또는

Save Script to Disk를 눌러 스크립트를 저장한 후 나중에 실행할 수 있습니다.

  7. Finish를 누릅니다.

문제 해결

Toad에서 자체 Team Coding 환경을 사용 중일 때 SQL Navigator 환경을 사용해야 하는 경우에는 둘 중 한 가지를 수행하여 문제를 해결할 수 있습니다.

Server Side Install 방법을 사용하려면

  • Server Side Objects Install 마법사를 사용하여 데이터베이스에서 Toad Team Coding 개체를 제거합니다.

또는 다음과 같은 방법으로 Toad에서 적절한 환경을 사용하도록 직접 지정할 수 있습니다.

수동 방법을 사용하려면

  • 선택한 TC 개체가 설치된 스키마에서 TC config 테이블을 가리키도록 공개 동의어 QUEST_COM_TEAM_CODING을 수정합니다.

주의: 계속하기 전에 환경을 변경할지를 확인합니다. 이 변경은 선택한 데이터베이스의 모든 사용자에게 적용됩니다.

SQL Navigator 버전을 사용하려면

  1. 공개 동의어 'QUEST_COM_TEAM_CODING'을 삭제합니다.

  2. Editor에서 다음을 실행합니다.

CREATE PUBLIC SYNONYM 'QUEST_COM_TEAM_CODING' FOR SQLNAV.SQLNAV4_VCS_CONFIG

Toad 버전을 사용하려면

  1. 공개 동의어 'QUEST_COM_TEAM_CODING'을 삭제합니다.

  2. Editor에서 다음을 실행합니다.

CREATE PUBLIC SYNONYM 'QUEST_COM_TEAM_CODING' FOR <schema>.TC_CONFIG

여기서 <schema>는 TC가 설치된 장소입니다.


Team Coding 설치 옵션

Team Coding을 사용하려면 설치를 위한 세 가지 기본 단계를 수행해야 합니다.

Team Coding을 설치하려면

  1. Toad에서 Team Coding에 액세스하는 데 필요한 개체가 데이터베이스에 있습니다. Tools 메뉴에서 액세스할 수 있는 Server Side Objects Installation 마법사에서 이러한 스크립트를 설치할 수 있습니다.

  2. Server Side Objects 설치가 끝나면 사용자에게 Team Coding 역할을 부여할 수 있습니다. 이 작업은 Schema Browser의 Users 탭에서 수행할 수 있습니다.

  3. Oracle Instance에서 Team Coding을 활성화합니다. Team Coding 기능을 사용하려면 Administrator 역할이 부여된 사용자가 Oracle 인스턴스에서 새 기능을 활성화해야 합니다. 자세한 내용은 데이터베이스에서 Team Coding 활성화를 참조하십시오.

주: 또한 Team Coding을 사용하기 전에 Toad Options|Editor|Execute/Compile|Toggle modified flag when compiling source loaded from database를 선택했는지 확인해야 합니다.

이 세 단계는 기본적인 소스 제어를 제공합니다. Automatic check in/out을 선택한 경우 항목을 열고 닫을 때 해당 항목을 체크인/체크아웃할지 묻는 메시지가 표시됩니다. 또한 Code Control Groups를 설정하고 타사 버전 제어 시스템을 사용할 수도 있습니다.

  4. Code Control Groups를 작성합니다. Team Coding을 활성화한 경우 Code Control Groups에 프로젝트를 구성하기 시작할 수 있습니다. 타사 시스템을 사용하지 않는 경우 Code Control Groups를 반드시 사용할 필요는 없지만, Code Control Groups에서 작업 구성을 위한 방법을 제공할 수 있습니다.

  5. 데이터베이스 개체를 데이터베이스에서 Version Control로 내보냅니다.


버전 제어 제품 지원

Toad의 Team Coding 기능은 다음과 같은 타사 제품을 직접 지원합니다.

  • Microsoft Visual SourceSafe 5.0, 6.0, 2005 (8.0)

  • Concurrent Versions System (CVS) 1.11.12

  • PVCS VM 6.6, 6.7, 6.8.1 및 7.5.0

  • PVCS VM 5.2, 5.3, 6.0

  • Serena(이전의 PVCS(Merant Version Manager)) 8.02

  • Serena(이전의 PVCS) Version Manager 8.1

주: PVCS 6.6.1 및 6.8.0은 Team Coding에서 명시적으로 지원되지 않습니다.

또한 Team Coding은 Microsoft의 SCC API를 제공하는 제품에서 작동합니다. SCC를 통해 Toad의 Team Coding에서 테스트를 거친 제품은 다음과 같습니다.

  • Rational Clearcase 5.0 (2002)

  • ComponentSoftware CS-RCS 2.5.140, 3.0.192 및 3.0.196 Workgroup 모드 전용

  • Quma QVCS 3.5 및 3.6(코드 제어 그룹을 하나만 허용)

  • Borland StarTeam 5.2 및 5.4(Borland의 SCC Integration 구성 요소 필요)

  • Microsoft Visual SourceSafe 6.0 및 2005

  • PVCS VM 6.7.00

Toad의 legacy Source Control 기능은 SCC API를 통해 파일을 체크인 및 체크아웃합니다. 이 소스 제어는 Editor 및 Project Manager에서만 사용할 수 있으며, 데이터베이스 개체를 인식하지 못합니다. 이 기능으로 테스트를 거친 제품은 다음과 같습니다.

  • Rational ClearCase 4.1

  • ComponentSoftware CS-RCS 2.5.140, 3.0.192 및 3.0.196

  • Quma QVCS 3.5 및 3.6

  • Borland StarTeam 5.4(Borland의 SCC Integration 구성 요소 필요)

  • Microsoft Visual SourceSafe 6.0

  • PVCS VM 6.7.00

주: Team Coding을 사용할 때 SourceSafe 및 PVCS에 원시 API(SCC Integration 아님)를 사용하는 것이 좋습니다.

각 제품에서는 사용자 정의 설치를 사용하여 SCC 인터페이스를 설치해야 합니다. 버전 호환성에 대한 최신 정보는 릴리스 정보를 참조하십시오.

SCC 인터페이스를 구현하는 Version Control 제품의 사용자는 이 Toad 버전에서 다음과 같은 작업상의 차이를 볼 수 있습니다.

  • 타사 제품의 자체 사용자 인터페이스로 대체되어 Toad Version Control Browser를 사용할 수 없습니다.

  • 새 Code Control Group을 작성할 때의 프로젝트 트리 표시가 타사 제품의 자체 대화 상자로 대체되었습니다.

CVS 지원

CVS 요구 사항은 CVS 요구 사항 항목을 참조하십시오.


Team Coding 역할

Team Coding에서는 Oracle 테이블 및 열 권한을 사용하여 액세스를 제어합니다. 역할은 Server Side Objects 마법사에서 Team Coding 개체를 작성할 때 자동으로 설정됩니다.

이러한 권한의 표준 사용을 나타내는 설정을 사용하여 다음과 같은 기본 역할을 작성했습니다.

  • Administrator(TC_ADMIN_ROLE)

인스턴스를 구성하여 Team Coding 작업 방법, 사용되는 VCS(있는 경우) 등을 정의할 수 있습니다. 이 역할은 Toad 사용자에게 자동으로 할당됩니다.

  • Project Manager(TC_MGR_ROLE)

CCG(Code Control Group)를 작성 및 삭제하고 VCS 프로젝트에 연결할 수 있습니다.

  • Team Leader(TC_LDR_ROLE)

CCG를 수정하고, 그룹에 포함되는 개체 또는 스크립트를 정의하고, 개체를 고정할 수 있습니다. 또한 Team Coding Viewer에서 행을 삭제할 수 있습니다.

이 세 역할 중 하나가 부여되지 않은 사용자는 개발자 역할이 부여된 것으로 간주됩니다. 이러한 사용자는 Team Coding Viewer를 사용하여 개체의 상태를 보고 소스 제어에서 항목을 체크인 및 체크아웃할 수 있습니다.

역할을 작성한 후 해당 역할을 사용자에게 부여해야 합니다(사용자에게 Team Coding 역할 부여 참조).


사용자에게 Team Coding 역할 부여

다른 역할을 부여하는 것과 동일한 방식으로 사용자에게 Team Coding 역할을 부여합니다.

주: 역할을 부여할 DBA 사용자로 연결해야 합니다.

Schema Browser, Users 페이지에서 역할을 부여할 수 있습니다.

사용자에게 역할을 부여하려면

  1. 왼쪽 패널에서 user를 선택합니다.

  2. Alter User [image] 단추를 누릅니다.

  3. Roles 탭을 누릅니다. 원하는 경우 역할을 추가하거나 제거합니다.

Editor에서 역할을 부여할 수도 있습니다. 해당 SQL을 입력하여 실행합니다. 예를 들면 다음과 같습니다.

grant TC_ADMIN_ROLE to ARTHUR

grant TC_LDR_ROLE to SUSAN


데이터베이스에서 Team Coding 활성화

Team Coding을 사용하려면 Oracle 연결에서 Team Coding을 활성화해야 합니다. 이 작업은 TC_ADMIN_ROLE 권한을 가진 사용자가 수행해야 합니다.

Team Coding을 활성화하려면

  1. Team Coding 도구 모음에서 View Team Coding Status for this session [image] 단추를 누릅니다. 제목 표시줄에 연결 정보가 있는 Team Coding Status 대화 상자가 표시됩니다.

Team Coding을 활성화하면 Permissions 영역에서 Team Coding Available 옆에 녹색 확인 표시가 나타나고 현재 사용자가 가진 권한이 표시됩니다.

  2. Settings를 눌러 이 연결에 대한 Team Coding 상태를 보고 편집합니다.

  3. Enable Team Coding을 선택합니다.

  4. Code Control Group 또는 타사 버전 제어를 사용하려면 해당 항목도 함께 선택합니다. 타사 버전 제어를 선택할 경우 확인란 아래의 목록에서 해당 버전 제어 시스템을 선택해야 합니다.

주: 설치한 VCS만 선택 상자에 표시됩니다.


Team Coding 설정

Team Coding Administrator는 Team Coding에서 데이터베이스로 작업하는 방법을 구성할 수 있습니다. 개별 사용자는 개별 옵션을 구성할 수 있습니다. 자세한 내용은 Source Control/Team Coding 옵션을 참조하십시오.

Team Coding 설정에 액세스하려면

  • Team Coding Status 대화 상자를 연 다음 Settings를 누릅니다.

Team Coding 설정은 다음과 같은 세 그룹으로 분류됩니다.

  • Configuration

  • File Extension Options

  • General

이 세 그룹을 사용하면 Team Coding이 조직의 작업 방법에 맞게 유연하고 쉽게 구성되도록 할 수 있습니다. 모든 팀 구성원은 연결된 데이터베이스에 대해 선택된 설정을 볼 수 있습니다. 하지만 설정을 변경하려면 Administrator 역할이 있어야 합니다. 자세한 내용은 Team Coding 역할을 참조하십시오.

Configuration

Configuration에는 현재 데이터베이스에 있는 Team Coding의 기본 사항이 포함되어 있습니다.

다음을 수행할 수 있습니다.

  • Team Coding 활성화

  • Code Control Groups 활성화

  • 타사 버전 제어 활성화(VCS)

File Extension Options

File Extension Options를 사용하면 Toad에서 Version Control System에 저장된 파일에 추가하는 확장을 제어할 수 있습니다. 기본 확장은 다음과 같습니다.

  • Procedure PRC

  • Function FNC

  • Package PKS

  • Package Body PDB

  • Trigger TRG

  • Type TYP

  • Type Body TPB

General

General 설정을 사용하면 사용자 기본 설정을 지정하고 전역 설정을 조정할 수 있습니다. 또한 스크립트 파일 확장을 변경하거나 추가할 수 있습니다.

사용자 설정

사용자별 설정은 Toad Options 페이지에서 설정할 수 있습니다. 자세한 내용은 Toad Options|TeamCoding을 참조하십시오.

주: 또한 Team Coding을 사용하기 전에 View|Toad Options|Editor|Execute/Compile|Toggle modified flag after compiling source from database를 선택했는지 확인해야 합니다.

전역 설정

Update Database after Check-in

데이터베이스 개체가 체크인된 작업 파일과 동일해지도록 체크인 후에 데이터베이스 개체를 강제로 업데이트합니다. 이 옵션은 버전 제어 제품이 파일을 체크인할 때 키워드 확장을 수행하는 경우에 유용합니다.

Force Comment during Check-in

이 설정을 선택한 경우 Check-In 대화 상자를 닫으려면 사용자가 주석을 입력해야 합니다.

Script File Extensions

스크립트를 저장할 때 Toad에서 사용되는 파일 확장을 사용자 정의하려면 이 설정을 사용합니다. 기본값은 ".sql"입니다.


Team Coding Status

언제라도 현재 데이터베이스의 Team Coding 기능의 상태를 볼 수 있습니다. 올바른 권한(Administrator 역할)이 있는 경우 설정 및 권한을 변경할 수 있습니다.

Team Coding 상태를 표시하려면

  • 도구 모음에서 Team Coding Status [image] 단추를 누릅니다. Team Coding Status 대화 상자가 표시됩니다.

이 페이지에는 이 데이터베이스에 대해 활성화된 Team Coding 부분과 사용자의 권한이 표시됩니다.

또한 Settings 를 눌러 Team Coding 기능 설정을 확인하거나 Messages를 눌러 현재 연결에 대한 상태 메시지를 확인할 수 있습니다.


Team Coding 개요

Team Coding은 공동 소스 제어 기능입니다. Team Coding을 단독으로 사용하거나 타사 버전 제어 시스템과 함께 사용할 수 있습니다. Team Coding을 Editor에서 사용하여 함수, 프로시저, 패키지, 트리거 및 유형에 대한 액세스와 개발을 제어할 수 있습니다.

또한 Team Coding은 Editor와 Editor 모두에서 스크립트를 지원합니다.

주: Team Coding은 Toad의 Version Control을 대체할 필요는 없지만 보다 통합된 환경에서 더 많은 기능을 제공합니다.

Team Coding 단독 사용:

  • PL/SQL 개발자에게 동일한 개체를 동시에 수정하지 않고 저장된 프로그램을 개발할 수 있는 기능을 제공합니다.

  • 항목 상태를 나타내는 내장 뷰어를 제공합니다.

  • 이 작업은 타사 버전 제어 제품이 필요하지 않은 체크인/체크아웃 시스템을 통해 수행됩니다.

타사 버전 제어 제품과 함께 사용:

  • 버전 제어 아카이브를 사용하여 코드에 대한 수정 기록을 보관할 수 있습니다.

  • Toad 내에서 타사 VCS 제공자의 브라우저(VSS 또는 PVCS를 사용하지 않는 경우)를 실행할 수 있습니다.

  • 사용자 매핑을 사용하여 여러 Oracle 사용자가 자체 스키마에서 Team Coding 제어 프로젝트 작업을 수행할 수 있습니다.

  • 코드 제어 아래에 스크립트 파일을 배치합니다.

  • Code Control Group을 가져오기/내보내기합니다.

Team Coding 내장 기능

중요 Team Coding 내장 기능은 다음과 같습니다.

  • 유연한 CCG(Code Control Group)의 사용자 정의 가능 그룹화 기능을 사용하면 하나 이상의 스키마에서 개체를 제어할 수 있습니다.

  • 특정 데이터베이스 개체와 유사 개체 컬렉션(Oracle % 와일드카드 사용)을 모두 나타내는 개체 마스크를 사용하여 CCG에 개체를 구성할 수 있습니다. 제외 마스크를 설정하여 CCG에서 특정 개체를 제외할 수도 있습니다.

  • 타사 버전 제어 제품이 없는 경우에도 CCG를 사용할 수 있으므로, 수정 기록은 없지만 Team Coding을 통해 참조 개체를 추적할 수 있습니다.

  • 모든 구성 데이터는 데이터베이스의 Team Coding 제어 아래에 저장됩니다. 개별 워크스테이션을 구성할 필요는 없습니다.


Team Coding 도구 모음

Team Coding 도구 모음에서는 마우스를 한 번만 눌러 모든 Team Coding 명령을 사용할 수 있습니다. Team Coding 도구 모음은 기본적으로 숨겨져 있습니다.

Team Coding 도구 모음을 표시하려면

  1. 표시된 도구 모음을 마우스 오른쪽 단추로 누릅니다.

  2. 도구 모음 목록에서 Team Coding을 선택합니다.

Team Coding 도구 모음

단추 | 명령
 | Code Control Groups 대화 상자 보기 또는 구성
 | Team Coding Viewer 열기
 | Version Control Browser 열기/실행
 | 선택된 개체/파일의 최신 수정 가져오기
 | 선택된 개체/파일 체크아웃
 | 선택된 개체/파일 체크인
 | 선택된 개체/파일 체크아웃 실행 취소
 | 사용자가 잠근 모든 개체 체크인
 | 이 세션에 대한 Team Coding 상태 보기
 | VCS 로그온


Team Coding Viewer

Team Coding Viewer에는 체크아웃되는 개체, 개체가 마지막으로 체크인된 시간 등을 포함하여 Team Coding 제어 중인 개체 세부 정보가 표시됩니다.

Team Coding Viewer에 액세스하려면

  • Team Coding 도구 모음에서 Team Coding Viewer [image] 단추를 누릅니다.

개체 세부 정보가 그리드 형식으로 나열됩니다. 창을 닫으면 그리드 열 너비와 정렬 순서가 TOAD.INI 파일에 저장됩니다.

상태 아이콘이 상태 열에 다음과 같이 표시됩니다.

이 창에서 개체를 체크인 또는 체크아웃할 수 있습니다. 다른 사용자가 개체를 수정할 수 없도록 적절한 권한을 사용하여 개체를 고정할 수 있습니다.

Team Coding Viewer에 표시되는 개체 목록을 필요한 개체로 제한할 수 있습니다. 표시할 개체를 지정하려면 Team Coding Viewer Filter 대화 상자를 사용합니다.

단추 | 명령
 | 목록 새로 고침
 | 개체 목록을 필터링합니다. 필터가 사용 중이면 이 아이콘이 빨간색으로 바뀝니다.
 | 선택된 개체의 최신 수정 가져오기
 | 소스 제어에서 선택된 개체 체크아웃
 | 선택된 개체를 소스 제어에 체크인
 | 체크아웃 실행 취소
 | 선택된 개체 고정
 | 선택된 개체 고정 취소
 | 선택된 개체 열기
 | 뷰어에서 선택된 개체 삭제
 | 선택된 개체/스크립트와 최신 VCS 수정 간의 차이 보기
 | 선택된 개체에 대한 세부 정보 보기


Team Coding 개체 상태 보기

Team Coding 상태를 보는 방법에는 여러 가지가 있습니다. 상태는 Editor 및 Editor의 맨 아래에 있는 상태 영역에 표시됩니다. 여기에는 세부 정보를 볼 수 있는 별도의 상태 창이 있습니다.

편집기 상태 표시줄 또는 Team Coding Viewer Status 열의 상태

편집기의 Team Coding 제어에서 개체 또는 스크립트를 열면 아래쪽의 창 테두리 옆에 있는 편집기 상태 표시줄에 개체의 Team Coding 상태가 표시됩니다. 또한 개체의 상태가 Team Coding Viewer의 Status 열에 표시됩니다.

Status | 의미 | 편집 가능 여부 | 허용된 작업
Uncontrolled | Team Coding에서 제어되지 않음 | 편집 가능 | 없음
Available | 체크아웃 가능 | 읽기 전용 | 체크아웃 고정
Checked Out | 체크아웃됨 | 편집 가능 | 체크아웃 실행 취소 체크인 고정
Locked | 다른 사용자에게 체크아웃되었거나 사용자 매핑 체크아웃을 사용하여 잠김 | 읽기 전용 | 고정
Frozen | 고정됨 | 읽기 전용 | 고정 취소
Disabled | Team Coding의 특정 오류로 인해 비활성화됨 | 읽기 전용 | 없음

세부 파일 속성

또한 Team Coding Viewer에서 개체를 마우스 오른쪽 단추로 누르고 Properties를 선택할 수 있습니다. 그러면 개체에 대한 세부 정보가 표시됩니다.


개체 및 스크립트 체크인 및 체크아웃

Team Coding 메뉴, Team Coding Viewer 도구 모음 및 Version Control Browser 도구 모음(VSS 또는 PVCS를 타사 VCS 제공자로 사용하는 경우)에서 개체와 스크립트를 체크인 및 체크아웃할 수 있습니다.

  • Automatic Check-in 및 Automatic Check-out 사용

Automatic Check-In 및 Automatic Check-Out 기능을 활성화한 경우 항목을 열 때 해당 항목을 체크아웃하라는 메시지가 자동으로 표시되고, 항목을 받을 때 항목을 체크인하라는 메시지가 자동으로 표시됩니다. "Prompt for comment options"를 선택 취소하여 이러한 프롬프트를 무시할 수 있습니다. 자세한 내용은 Toad Options|Team Coding을 참조하십시오.

  • 수동으로 체크인 또는 체크아웃

또는 Team Coding 메뉴의 명령을 사용하여 체크인 또는 체크아웃을 수동으로 시작할 수 있습니다.

Automatic Check-Out을 활성화한 경우 개체 또는 스크립트를 체크아웃하려면

  1. Editor에서 데이터베이스의 개체 또는 스크립트를 엽니다.

  2. Check-Out 대화 상자가 나타나면 프롬프트에 따라 항목을 체크아웃하거나 Cancel을 선택하여 항목을 읽기 전용 모드로 엽니다.

Automatic Check-In을 활성화한 경우 개체 또는 스크립트를 체크인하려면

  1. Editor에서 개체 또는 스크립트를 닫습니다.

  2. Check-In 대화 상자가 나타나면 프롬프트에 따라 항목을 체크인합니다.

수동으로 체크인 및 체크아웃하려면

  1. Editor에서 개체 또는 스크립트를 엽니다. 또는 다음 Toad 창 중 하나에서 개체를 선택합니다.

  • Schema Browser: Procs, Types 및 Favorites 탭

  • Version Control Browser

  • Project Manager

  • Team Coding Viewer

  2. Team Coding 메뉴 또는 도구 모음, Schema Browser, Project Manager 또는 바로 가기 메뉴에서 Check In 또는 Check Out을 선택합니다.

  3. Undo Check Out을 선택하여 체크아웃을 취소하고 변경을 되돌릴 수 있습니다.


체크인 또는 체크아웃에 대한 주석 입력

개체를 체크인 또는 체크아웃할 때 향후에 수행할 예정이거나 이전에 수행한 수정에 대한 주석을 입력할 수 있습니다.

가장 최근의 주석이 Team Coding Viewer에 표시됩니다. 타사 VCS를 사용 중인 경우에는 아카이브에 있는 새 수정에 대해서도 체크인 주석이 기록됩니다.

타사 버전 제어를 사용 중인 경우에는 체크인 작업 중에 Force Revision 옵션(Team Coding Settings>General 참조)을 사용할 수 있습니다.

주: 모든 타사 제공자에 대해 Force Revision 옵션을 사용할 수 있는 것은 아닙니다.

Force Revision 옵션을 사용하면 변경되지 않은 개체를 데이터베이스에서 업데이트할 수 있기 때문에 새 주석 또는 변경된 주석을 저장할 수 있습니다. 이 확인란에 대한 기본값은 Toad Options > Team Coding/Source Control에서 설정할 수 있습니다.


Check In All

체크아웃한 항목 중 일부 또는 모두를 체크인하도록 선택할 수 있습니다.

항목을 체크인하려면

  1. Team Coding 도구 모음에서 Check in All [image] 단추를 누릅니다. Check In All 대화 상자가 나타납니다.

  2. 목록의 왼쪽에 있는 확인란을 선택하거나 지워 항목을 선택하거나 선택 취소합니다. 선택된 항목이 체크인됩니다.

주: 오른쪽에서 해당 단추를 눌러 Select All 또는 Clear All을 수행하도록 선택할 수도 있습니다.

  3. 선택된 모든 항목에 대해 동일한 주석을 입력하도록 선택할 수 있습니다. 이 확인란은 기본적으로 선택되어 있지 않습니다.

  4. 모든 항목을 강제 수정하려면 선택합니다. 이 확인란을 선택하면 변경 여부에 관계 없이 선택된 항목에 대해 새 버전이 작성됩니다.

  5. OK를 누릅니다.

  6. 모든 항목에 동일한 주석을 적용하도록 선택한 경우 항목이 체크인되고 대화 상자가 닫힙니다.

  7. 각 항목에 대해 새 주석을 입력하도록 선택한 경우 목록의 첫 번째 항목이 활성화된 상태로 check in 대화 상자가 나타납니다. 여기서 OK를 눌러 각 항목을 차례대로 처리할 수 있습니다.


Undo Checkout

개체를 소스 제어로 체크인할 때와 동일한 방법으로 체크아웃을 실행 취소할 수 있습니다.

체크아웃을 실행 취소하려면

  • 메뉴에서 Undo Checkout을 선택합니다.

또는

도구 모음에서 Undo Check Out 단추를 누릅니다.

체크아웃을 실행 취소하도록 선택하면 항목의 저장된 데이터베이스 버전(체크아웃하기 이전의 상태)을 복원할지를 확인하는 메시지가 표시됩니다.

주의: 확인 메시지에 No라고 대답하고 변경 사항을 저장하면 결과에서 VCS에 저장된 버전이 데이터베이스에 저장된 버전과 달라집니다.


개체 고정

TEAM LEADER 이상의 역할을 가진 사용자는 Team Coding Viewer에서 개체를 고정 및 고정 취소할 수 있습니다.

개체를 고정하면 해당 개체가 수정되지 않도록 잠기므로, 체크아웃할 수 없습니다. 이러한 개체는 Procedure Editor에서 읽기 전용 파일로 열 수 있습니다.

상태가 Team Coding Viewer의 status 열이나 Procedure Editor의 상태 표시줄에 Frozen으로 표시됩니다.

개체를 고정하려면

Team Leader 역할을 가진 개체만 고정할 수 있습니다.

  1. Team Coding Viewer에서 고정할 개체를 선택합니다.

  2. 도구 모음에서 Freeze 단추를 누르거나 마우스 오른쪽 단추 메뉴에서 Freeze를 선택합니다.

개체를 고정 취소하려면

Team Leader 역할을 가진 개체만 고정 취소할 수 있습니다.

  1. Team Coding Viewer에서 고정 취소할 개체를 선택합니다.

  2. 도구 모음에서 Unfreeze 단추를 누르거나 마우스 오른쪽 단추 메뉴에서 Unfreeze를 선택합니다.


파일 비교

파일 비교 창(File Differences Viewer)을 사용하여 디스크에 있는 두 개의 파일 내용, 개체와 파일 또는 다른 개체와 비교할 수 있습니다.

3개의 다른 영역에서 Differences Viewer를 액세스할 수 있습니다. 각 영역은 Differences Viewer를 사용하여 다른 개체를 비교합니다.

디스크에 있는 두 개의 파일을 비교하려면

  • Utilities 메뉴에서 Compare Files를 선택합니다.

스키마 브라우저의 개체를 비교하려면

  • Procs 또는 Views 페이지 중 하나에서 개체에 마우스 오른쪽 단추를 누르고 Compare with another object를 선택합니다. 자세한 내용은 개체 비교를 참조하십시오.

스키마 비교와 다른 개체를 비교하려면

  • Schemas|Results (Interactive) 탭에서 스키마끼리 다른 개체 목록의 개체에 마우스 오른쪽 단추를 누르고 Show Difference Details를 선택하여 두 개체의 스크립트를 비교합니다. 자세한 내용은 스키마 비교 를 참조하십시오.

관련 항목

파일 차이 보기

파일 비교 규칙

Difference Viewer 옵션


파일 차이 보기

파일, 데이터베이스 개체 또는 스크립트와 비교할 개체를 지정하면 Differences Viewer가 나타납니다.

Differences Viewer를 통해 분할된 창에서 데이터베이스 개체를 비교할 수 있습니다. 개체 간의 차이가 강조표시되고 도구 모음을 통해 보기를 사용자 정의하고 보고서를 작성하기 위한 컨트롤을 액세스할 수 있습니다.

파일 비교 규칙 및 옵션에서 Toad가 두 개의 파일 또는 파일의 두 가지 버전에 대한 유사성 및 차이를 표시하는 방식을 지정할 수 있습니다.

Differences Viewer 도구 모음

단추 | 명령
 | 파일 다시 로드 및 비교 실행
 | 파일 열기
 | 선택한 Viewer 측면에 클립보드 내용 붙여넣기
 | 측면 전환
 | 이전 차이로 이동
 | 다음 차이로 이동
 | 비교한 개체의 모든 줄 표시
 | 차이가 있는 줄만 표시
 | 큰 차이가 있는 줄만 표시(Differences Viewer 기본 설정에 정의됨)
 | 일치하는 줄만 표시
 | 텍스트 문자열 찾기
 | 다음 텍스트 문자열 찾기
 | 특정 줄 번호로 이동
 | 차이 보고서 작성
 | 비교 요약 생성
 | 물결(~) 문자를 사용하여 공백 문자 표시
 | 줄 번호 설정 또는 해제
 | 파일의 미리 보기 표시
 | 옵션 표시 및 설정
 | 파일 비교 규칙 설정

미리 보기

미리 보기를 통해 파일 부분을 빠르게 변경할 수 있습니다. 미리 보기(보기 모드의 왼쪽)는 차이를 시각적으로 요약해 놓은 것입니다. 색상이 지정된 줄은 줄 불일치와 관련된 위치를 표시합니다. 흰색의 직사각형은 현재 Differences Viewer 창에서 볼 수 있는 텍스트의 일부를 나타냅니다. 미리 보기를 눌러 문서에 Viewer의 위치를 배치할 수 있습니다.

관련 항목

파일 비교 개요

파일 비교 규칙

Difference Viewer 옵션


파일 비교 규칙

파일 비교 규칙을 액세스하려면

  • Difference viewer 도구 모음에서 File Comparison Rules [image] 단추를 누릅니다.

사용 가능한 규칙

규칙은 다음과 같이 4개의 탭으로 구분됩니다.

  • General

  • Define Minor

  • Line Weights

  • Miscellaneous

General 탭

Tab Stops - 이 영역을 사용하여 탭 정지를 설정합니다.

Synchronization Settings - Synchronization Settings는 파일 간의 차이 및 유사점을 보고하는 비교 엔진을 제어합니다. 비교 동기화 알고리즘에 대한 경험이 없으면 기본 설정이 대부분의 상황에 잘 맞다는 것을 알게 될 것입니다. 일반적으로 다음과 같은 원칙이 적용됩니다.

작은 차이에 대해 보다 효율적으로 검색할 수 있도록 동기화 매개 변수를 낮게 설정합니다.

큰 차이가 있는 파일을 보다 많이 다룰 수 있도록 동기화 매개 변수를 높게 설정합니다.

Initial Match Requirement는 텍스트 동기화가 발생하기 위해 일치해야 하는 최소 행 수를 나타냅니다.

Skew Tolerance는 일치 여부 검색 시 Differences Viewer에서 앞 또는 뒤쪽으로 검색할 행 수입니다. 숫자가 낮을 수록 성능이 향상됩니다.

Suppress Recursion은 일치 스캔 방법을 참조합니다. Recursion은 텍스트의 작은 부분뿐만 아니라 보다 넓은 부분을 일치시킬 수 있는 능력을 향상시키지만 더 많은 시간이 소요될 수 있습니다.

Minor Differences - Ignore Minor Differences 확인란을 사용하여 Differences Viewer 창에서 작은 차이점 강조표시를 활성화 또는 비활성화합니다. (아래에 설명된 대로 Define Minor Differences 아래의 Rules 옵션에서 작은 차이점의 구성 요소를 지정합니다.)

Define Minor 탭

설명 또는 공백 문자, 탭 등의 작은 차이점을 강조표시 또는 무시하는 비교 엔진이 있습니다. 이렇게 하면 중요한 차이점에만 초점을 두거나 버전 간의 작은 차이점을 검토할 수 있습니다. 작은 차이점으로 분류할 항목 옆에 체크 표시를 합니다. 그런 다음 General 카테고리 아래에서 Ignore Minor Differences 확인란을 선택 또는 취소할 수 있습니다.

Line Weights 탭

Line Weights 탭에서 일치하는 행에 동기화 우선 순위를 지정할 수 있습니다. 탭에 나열된 값을 사용하거나 값을 만들 수도 있습니다.

Miscellaneous 탭

Miscellaneous 탭을 사용하여 행 종료에 대해 선택합니다.

비교 상자에서 열 범위를 입력하여 비교를 특정 열로 제한할 수도 있습니다.

관련 항목

파일 비교 개요

파일 차이 보기

Difference Viewer 옵션


Different Files 대화상자 응답

개체 또는 스크립트를 열면 Team Coding이 VCP(Version Control Provider) 리포지토리의 최신 버전과 비교합니다. 표시되어 있지 않으면 이 경우 Toad는 파일의 읽기 전용 버전을 읽습니다. 데이터베이스 개체 또는 스크립트가 VCP 리포지토리에 저장된 버전과 다르면 Toad에서 알려줍니다.

개체의 차이는 비율 수가 원인일 수 있습니다. 예를 들면 다음과 같습니다.

  • 개체 편집에 다른 도구를 사용했습니다.

  • 개체를 수정한 스크립트를 실행했습니다.

  • VCP 리포지토리의 보관 파일이 Team Coding이 아닌 다른 방법으로 업데이트되었습니다.

Different Files 대화상자에서 다음 옵션 중 하나를 선택할 수 있습니다.

옵션 | 설명
View Differences | 두 개의 개체를 비교할 수 있도록 Differences Viewer를 시작합니다.
Open Database Version | 읽기 전용 모드에서 VOE 또는 Procedure Editor에 데이터베이스 버전을 로드합니다.
Open VCP Version | 데이터베이스를 VCP 리포지토리 버전으로 업데이트하고 읽기 전용 모드에서 VOE 또는 Editor에 로드합니다. 주의: 리포지토리에서 버전을 열면 데이터베이스의 개체가 업데이트됩니다.
Make editable | 선택한 항목을 편집하기 위해 표시합니다.


Code Control Groups 개요

Toad의 CCG(Code Control Group)는 Team Coding의 가장 강력하고 유연한 기능입니다.

개념적으로 CCG는 데이터베이스 개체 모음으로 구성되어 개발자가 함께 작업하는 프로젝트와 비슷합니다. Code Control Group 구성에서는 모음을 호칭하는 이름을 제공하고 개체가 속하는 CCG를 결정하는 데 사용할 수 있는 필터 집합을 지정합니다. 이러한 필터를 DB Object Masks라고 합니다.

CCG를 사용하여 제어된 개체를 개발 프로젝트와 연관된 그룹으로 구성할 수 있습니다. 예를 들어 단일 Oracle 인스턴스에 대해 여러 CCG를 작성할 수 있습니다. 각 CCG에는 고객 응용 프로그램과 관련된 모든 저장된 프로그램에 대한 참조가 포함되어 있습니다.

  • CCG를 비활성화한 상태에서 Team Coding을 활성화하면 Team Coding이 데이터베이스에 있는 모든 지원되는 개체에 적용됩니다.

  • CCG를 활성화한 경우에는 Team Coding이 Code Control Group의 구성원인 개체에만 적용됩니다.

타사 버전 제어 제공자와 함께 CCG를 사용할 수도 있습니다. 타사 버전 제어 제공자를 사용하는 경우 추가 Code Control Group 기능이 있습니다.

예 1에서는 단일 프로젝트에 대해 한 개의 CCG를 사용하는 데 대한 설명을 제공합니다.

예 2에서는 여러 프로젝트에 대해 여러 CCG를 사용하는 데 대해 설명합니다.


Code Control Groups 사용 예 1 -
단일 응용 프로그램

Oracle 인스턴스에서 단일 응용 프로그램에 모두 연결되는 저장된 프로그램이 들어 있는 스키마가 있다고 가정합니다. 해당 스키마에 있는 모든 개체를 포함하는 CCG를 쉽게 작성한 다음 제공자 아카이브의 Version Control System에 매핑할 수 있습니다.

CCG를 사용하여 여러 스키마의 개체를 하나의 VCS 프로젝트에 매핑

특정 유형 및 스키마 포함

다른 스키마에 있는 일부 개체가 응용 프로그램에 포함되어 있는 경우 해당 개체를 포함하도록 CCG를 쉽게 수정할 수 있습니다. 또한 다음을 포함하도록 CCG를 구성할 수도 있습니다.

  • 특정 스키마 또는 스키마 마스크(예: PROD%) 기반 개체 마스크

  • 모든 유형 또는 특정 유형(예: Trigger)의 저장된 프로그램

  • 이름을 가진, 또는 이름 마스크(예: ACC_%)를 사용하는 개체

  • 특정 유형 및 스키마

개체 마스크를 사용하여 제외 및 포함 작업을 모두 수행할 수 있으므로, 예를 들어 DBG_%와 같은 이름을 가진 모든 개체를 제외한 개체 그룹을 쉽게 포함할 수 있습니다.

개체 제외

또한 스키마에 제어하지 않을 일부 개체가 포함되어 있는 경우(예: 응용 프로그램에 포함되지 않는 일부 테스트 패키지가 들어 있는 경우) CCG에서 제외 참조(Object Mask)를 쉽게 추가할 수 있습니다. 개체 마스크 지정을 참조하십시오.

스크립트

응용 프로그램에 보조 스크립트가 포함되어 있는 경우 CCG에 해당 스크립트에 대한 참조를 포함할 수 있습니다. 다른 개체에서와 마찬가지로 와일드카드 마스크 및 확장을 사용할 수 있습니다.


Code Control Groups 사용 예 2 -
여러 CCG

나중에 두 번째 응용 프로그램을 개발할 때 첫 번째 응용 프로그램에 사용된 것과 동일한 스키마에 저장된 개체를 사용하여 두 번째 CCG를 쉽게 작성할 수 있습니다. 이 새 CCG에 새 응용 프로그램과 관련된 저장 프로그램을 위한 개체 마스크가 포함되어 있고, 새 CCG를 버전 제어 리포지토리의 다른 프로젝트에 연결합니다.

예를 들어 두 번째 응용 프로그램이 이름이 공통 접두사(예: "ACC")로 시작하는 절차로 구성되어 있는 경우 두 번째 CCG에는 ACC%와 같은 이름을 가진 스키마의 모든 프로시저에 대한 Object 마스크가 포함되어 있습니다. Team Coding은 새 개체 마스크와 일치하는 이름을 가진 개체를 자동으로 인식하여 첫 번째 VCS 프로젝트가 아니라 두 번째 VCS 프로젝트에 매핑합니다.

주: 개체를 둘 이상의 CCG에 매핑할 수 없습니다.

CCG를 사용하여 한 스키마의 개체를 다른 VCS 프로젝트에 매핑


Code Control Groups 도구 모음

Code Control Groups 창에 대한 도구 모음입니다.

단추 | 명령
 | 새 Code Control Group 작성
 | Group을 열어 설정 보기 또는 변경
 | Group 삭제
 | Group 다시 매핑
 | 목록 새로 고침
 | VCS로 내보내기
 | 데이터베이스로 가져오기
 | Group에 현재 사용자 매핑
 | 모든 매핑된 사용자 나열


Enabling Code Control Groups

이 옵션을 사용할 경우 CCG에서 참조되지 않는 개체는 Team Coding 제어 아래 있지 않습니다.

CCG를 구성한 경우 개체 또는 스크립트가 수정되면서 Version Control System에 자동으로 추가되기 때문에 Team Coding 기능을 즉시 사용할 수 있습니다.

CCG를 활성화하려면

  1. Team Coding 메뉴에서 Team Coding Status를 선택합니다. Team Coding Status 대화 상자가 나타납니다.

  2. Settings를 누릅니다. 이 연결에 대한 Team Coding Settings가 나타납니다. Team Coding Features 영역에서 Use Code Control Groups를 선택합니다.

  3. 이제 타사 버전 제어를 사용하기 위한 옵션이 제공됩니다. 목록에는 사용하기 위해 직접 설치한 버전 제어 제품만 표시됩니다. SCC API Team Coding을 사용 중인 경우 나중에 Version Control Browser를 선택하면 타사 제품의 사용자 인터페이스가 대신 시작됩니다.


CCG 작성

Code Control Group을 쉽게 작성할 수 있습니다.

주: 새 CCG를 작성하려면 Code Control Group을 활성화해야 합니다.

CCG를 작성하려면

  1. Toad 메뉴 표시줄에서 Team Coding|Code Control Groups를 선택하거나, Team Coding 도구 모음에서 Code Control Groups [image] 단추를 누릅니다.

  2. Code Control Groups 도구 모음에서 Add Group [image] 단추를 누릅니다.

  3. login 창이 나타나면 필요한 정보를 입력합니다.

  4. New Group 대화 상자에 Group에 대한 설명이 포함된 이름을 입력합니다.

  5. 타사 VCS(Version Control System)를 사용하는 경우 표시되는 대화 상자의 프롬프트에 따라 VCS 프로젝트를 선택합니다. 해당 프롬프트는 사용 중인 대화 상자에 따라 다릅니다. Code Control Group 창이 나타납니다.

VCS를 사용하고 있지 않은 경우 Code Control Group 창이 즉시 나타납니다.

  6. Code Control Group 창에서 현재 CCG에 대한 새 개체 및 스크립트 마스크 정의를 작성합니다.


CCG 보기 및 수정

이미 작성한 CCG(Code Control Group)를 보거나 수정할 수 있습니다. 그룹을 아직 작성하지 않은 경우 CCG 작성 항목을 참조하십시오.

CCG를 보거나 수정하려면

  1. Toad 메뉴 표시줄에서 Team Coding|Code Control Groups를 선택하거나, Team Coding 도구 모음에서 Code Control Groups [image] 단추를 누릅니다.

  2. Code Control Groups 창의 목록에서 그룹을 선택한 다음 Open Group [image] 단추를 누릅니다. Code Control Group 대화 상자가 열립니다. 이 대화 상자에서 DBmasks 작성, 스크립트 마스크 작성, DBmasks 삭제, 마스크 편집 등을 수행할 수 있습니다.

관련 항목

메뉴 추가


CCG 개체 마스크 지정

개체 마스크는 CCG(Code Control Group)를 정의하는 참조입니다. Team Coding은 CCG를 처리할 때 개체 마스크에 특정 순위를 연결하여 해당 CCG에 속하는 데이터베이스 개체를 결정합니다.

서로 다른 여러 마스크를 지정할 수 있습니다. 그러면 Team Coding에서 특정 CCG에 포함할 개체를 결정할 때 각 마스크에 순위를 지정합니다. 개체 마스크 순위를 참조하십시오.

Mask Properties 대화 상자를 사용하여 CCG에 포함될 개체 또는 개체 그룹을 지정합니다.

CCG 개체 마스크를 지정하려면

  • Code Control Group 창에서 마스크를 추가할 그룹을 선택한 다음 Open Group [image] 단추를 누릅니다.

  • New Database Mask [image] 단추를 누릅니다. Mask Properties 대화 상자가 표시됩니다.

  • 다음 옵션 중에서 선택합니다.

  • Object Type View, Procedure, Function, Package, Package Body 또는 All 중에서 선택합니다.

  • Schema 목록에서 사용자를 선택하거나 스키마 이름을 입력합니다. % 와일드카드 문자를 사용할 수 있습니다.

  • Object Name % 와일드카드를 포함하여 개체 이름을 입력할 수 있습니다. 또는 Open DB Object 대화 상자를 실행하여 Object Type 및 Schema 설정과 일치하는 개체를 선택할 수 있습니다.

  • Excluded CCG에서 이 개체 마스크와 일치하는 개체를 제외하려면 Excluded를 선택합니다.


개체 마스크 순위

개체 마스크의 순위를 지정하면 중복되는 일치 마스크를 올바른 CCG(Code Control Group)에 맞추는 개체를 확인할 수 있습니다.

  • 개체 마스크의 순위는 포함된 와일드카드 수를 기반으로 지정됩니다.

  • 가장 높은 순위에는 가장 특정한 마스크가 지정됩니다.

  • 서로 다른 순위를 가진 중복 마스크가 있는 경우 가장 높은 순위의 마스크가 우선적으로 사용됩니다. 동일한 순위를 가진 중복 마스크가 있는 경우 올바른 CCG에 대한 개체를 확인할 수 없습니다.

마스크 순위는 다음과 같습니다(높은 순위 우선).

특정 개체 참조

Trigger SCHEMA.NAME

와일드카드 하나만

Any Type SCHEMA.NAME

Trigger SCHEMA%.NAME

Trigger SCHEMA.NAME%

와일드카드 두 개

Any Type SCHEMA%.NAME

Any Type SCHEMA.NAME%

Trigger SCHEMA%.NAME%

와일드카드 세 개

Any Type SCHEMA%.NAME%


파일 서버 스크립트 지정

Mask Properties 대화 상자를 사용하여 CCG에 포함할 파일 서버 스크립트 그룹 또는 특정 스크립트를 지정할 수 있습니다.

파일 서버 스크립트를 지정하려면

  • Add Script Mask [image] 단추를 눌러 새 스크립트 또는 스크립트 그룹을 추가합니다.

  • 다음 옵션 중에서 선택합니다.

  • File Name/Mask 특정 스크립트 파일의 경로를 입력하거나, 찾아보고 선택합니다. * 와일드카드 문자를 사용하여 스크립트 그룹을 지정할 수 있습니다.

  • Include Path 경로 이름을 포함시키려면 이 확인란을 선택합니다.

  • File Path 이 옵션은 Include Path를 선택한 경우에만 활성화됩니다. 스크립트 파일을 찾았으면 경로가 자동으로 입력됩니다. 경로 없이 파일 이름을 입력하면 Toad에서는 기본 작업 폴더를 경로로 사용하는 것으로 간주합니다.

  • Excluded CCG에서 이 개체 마스크와 일치하는 스크립트를 제외하려면 Excluded를 선택합니다.


CCG에 사용자 매핑

개발자의 스키마를 특정 CCG(Code Control Group)에 연결할 수 있습니다. 즉, 개발자가 자신의 스키마에서 개체를 열 경우 Toad는 매핑된 CCG에서 개체를 검색한 후 원본 스키마에서 연 경우처럼 해당 개체를 잠급니다. 개체를 체크아웃하면 원본 스키마의 아카이브가 체크아웃되고 개체는 개발자 스키마와 원본 스키마 모두에서 잠깁니다.

이 기능은 자신의 스키마에서 종종 작업하지만 실제로는 다른 스키마에 있는 개체가 포함된 프로젝트에 대해 작업할 경우에 유용합니다.

따라서 사용자를 CCG에 매핑하면 기본적으로 첫 번째 CCG와 동일하지만 특정 사용자 스키마를 참조하는 모든 개체 마스크가 있는 새 CCG가 작성됩니다. 사용자 스키마와 원본 CCG에 포함된 스키마 간에 동일한 VCS 아카이브를 공유합니다. 예를 참조하십시오.

CCG에 사용자를 매핑하려면

매핑할 사용자로 로그인해야 합니다.

  1. Code Control Groups 창을 엽니다(Toad menu bar|Team Coding|Code Control Groups).

  2. 해당 CCG를 선택합니다.

  3. 도구 모음에서 Map Current User [image] 단추를 누릅니다.

  4. CCG에 여러 스키마에 대한 개체 마스크가 있는 경우 프롬프트에 따라 원하는 스키마를 선택합니다.

  5. 필요한 경우 Import를 수행하여 스키마의 개체를 업데이트합니다.

모든 매핑된 사용자를 표시하려면

Code Control Groups 창 도구 모음의 도구 모음 단추를 사용하여 특정 CCG에 매핑되는 사용자를 확인할 수 있습니다.

  • Code Control Groups 창에서 CCG를 선택하고 Display all Users [image] 단추를 누릅니다. 매핑된 사용자 목록이 나타납니다.

관련 항목

메뉴 추가


User Mapping 예

개발자는 User Mapping을 통해 자신의 스키마에서 일반적인 코드로 작업할 수 있습니다.

예:

  • 개발 환경에 대한 모든 코드를 포함하는 공용 스키마가 있습니다.

  • 개발자가 자체 스키마를 사용하여 소스 제어 제품으로부터 코드를 체크인/체크아웃하는 것을 선호합니다.

  • 필요한 경우 테스트를 위해 "master" 스키마를 업데이트하고 코드를 Production으로 이동합니다.

User Mapping을 사용하면 개발자가 CCG(Code Control Group)에서 제어되는 스키마("master")에 있는 자체 개체의 사본에 대해 작업할 수 있습니다. 즉, master 스키마에 있는 개체는 Import 기능을 사용하여 버전 제어 시스템에서 master 스키마를 업데이트할 때까지는 개발 중에 변경되지 않은 상태로 유지될 수 있습니다.

주: CCG를 master 스키마로 가져오려면 먼저 CCG를 버전 제어 시스템으로 내보내야 합니다.

이 예에서는 개발자가 CCG를 작성한 대상 REPORTS 스키마에 매핑하는 방법을 보여 줍니다. (Code Control Group 작성 참조)

master 스키마의 개체 사본을 개발자의 스키마에 추가하려면 아래에 설명한 것처럼 각 개발자가 CCG를 가져와야 합니다.

개발자 Scott를 REPORTS라는 CCG에 매핑하려면

  1. 개발자 SCOTT로 로그인합니다.

  2. Team Coding 메뉴에서 Code Control Groups 창을 열고 REPORTS Group을 선택합니다.

  3. Map User [image] 단추를 누릅니다. 그룹 이름 옆에 user-mapping 아이콘이 나타납니다.

  4. Code Control Groups 창에서 Import to Database [image] 단추를 누릅니다.

  5. Import into Database 창에서 가져올 개체를 선택합니다. 이 CCG에 대한 VCS에 있는 개체만 표시됩니다. 선택이 끝나면 OK를 누릅니다.

  6. Import Options 창에서 Update another schema 옵션을 선택합니다. OK를 눌러 가져오기를 시작합니다.

Scott는 이제 자신의 스키마에서 REPORTS 개체를 체크아웃할 수 있습니다. 사용자 매핑 개체를 체크아웃하거나 체크인할 때 Team Coding Check Out/In 대화 상자에 개체의 Master Owner가 표시됩니다.

개발자가 사용자 매핑 개체 사본을 체크아웃한 경우 다른 모든 복사본이 잠깁니다. 다른 개발자는 해당 사본을 체크아웃할 수도 없고 Master Owner가 될 수도 없습니다.


프로젝트 연결 다시 매핑

적절한 권한(Team Coding 역할 참조)을 사용하여 CCG와 VCS 프로젝트 사이의 연결을 변경할 수 있습니다. 예를 들어 처음에 Version Control 제품(VCS)을 사용하지 않고 CCG를 구성한 다음 나중에 VCS를 사용하도록 결정한 경우 다시 매핑 기능을 사용하여 CCG와 VCS 프로젝트를 연결할 수 있습니다.

프로젝트 연결을 다시 매핑하려면

  1. Toad 주 메뉴 표시줄에서 Team Coding|Code Control Groups를 선택합니다.

  2. Code Control Groups 창에서 Remap [image] 단추를 누릅니다. Remap 대화 상자가 표시됩니다.

  3. 그룹을 매핑할 VCS 프로젝트를 선택한 다음 OK를 누릅니다.

관련 항목

메뉴 추가


Team Coding Viewer 필터

Team Coding Viewer에 표시되는 개체 목록을 원하는 개체로 제한할 수 있습니다. 표시할 개체를 지정하려면 Team Group Filter 대화 상자를 사용합니다.

필터를 사용하려면

  1. Team Coding Viewer Filter 대화 상자에 액세스하려면 Team Coding Viewer 도구 모음에서 Filter [image] 단추를 누릅니다.

  2. Object Types 및 Status 영역에서 확인란을 선택하거나 선택 취소하여 해당 항목을 표시하거나 숨깁니다.

  3. 소유자, 이름 또는 사용자를 필터링하려면 Text 필드를 누르고 포함할 텍스트를 입력합니다. % 와일드카드 문자를 입력해도 됩니다.

이 필터를 사용하여 다음을 기준으로 목록을 필터링할 수 있습니다.

  • 개체 유형

  • 프로시저

  • 함수

  • 패키지

  • 패키지 본문

  • 유형

  • 유형 본문

  • 트리거

  • 스크립트

  • Team Coding 상태

  • 사용 가능

  • 체크아웃

  • 잠김

  • 고정

  • 개체 소유자

  • 개체 이름

  • Oracle 사용자

  • OS 사용자


개체 가져오기

Import 기능을 사용하여 선택된 CCG에 대한 Version Control System에서 Oracle 인스턴스를 업데이트할 수 있습니다.

개체를 가져오려면

  1. Code Control Groups 도구 모음에서 Import [image] 단추를 누릅니다.

  2. Import 대화 상자를 사용하여 가져올 개체를 선택(또는 제외)합니다. Import 목록은 VCS에 있는 기존 아카이브를 기반으로 채워지지만 CCG에 정의된 해당 개체만 필터링됩니다. 이러한 개체가 반드시 Oracle 인스턴스에 존재해야 하는 것은 아닙니다.

  3. OK를 누릅니다. Import Options 대화 상자가 나타납니다.

  4. 원본 스키마 또는 다른 스키마에서 작업하려면 다음 옵션을 선택합니다.

  • Update original schema
    CCG 및 아카이브 파일 이름을 기준으로 Oracle 인스턴스의 원래 위치에서 개체를 작성하거나 업데이트합니다.

  • Update another schema
    대체 대상 스키마를 선택합니다. 아카이브가 작성된 원본 개체에 관계 없이 모든 개체가 이 스키마에서 작성됩니다.

대상 스키마에서 개체를 작성하려면 적절한 권한이 있어야 합니다.

  5. 수행할 작업을 선택합니다.

  • Update database
    데이터베이스를 즉시 업데이트합니다.

  • Generate import script
    사용자가 스크립트를 실행하기 전에 검토 및 변경할 수 있도록 가져오기 스크립트를 생성하여 Editor로 로드합니다. 데이터베이스를 변경하려면 먼저 생성된 스크립트를 실행해야 합니다.

  • Add new revision to VCS
    데이터베이스를 직접 업데이트하려면 이 확인란을 선택할 수 있습니다. 그러면 VCS 아카이브에 새 수정이 추가됩니다. 그런 다음 새 수정에 대한 수정 주석을 추가할 수도 있습니다.


개체 내보내기

Export 기능을 사용하여 다음을 수행할 수 있습니다.

  • 버전 제어 아카이브에서 응용 프로그램 개발 프로젝트의 첫 번째 수정 구성

  • 모든 개체 및 스크립트에 대한 새 수정 작성. 예를 들어 프로젝트를 완료하고 프로덕션 서버를 업데이트했을 때 입니다.

이러한 작업을 수행하려면 CCG에서 참조하는 모든 개체에 대한 액세스 권한이 있어야 합니다. 그렇지 않으면 개체의 모든 다른 소유자가 프로세스를 여러 번 시작해야 합니다.

개체를 아카이브로 내보내려면

  1. Code Control Groups 창 도구 모음에서 Export [image] 단추를 누릅니다.

  2. Export 대화 상자를 사용하여 내보낼 개체 및 스크립트를 선택(또는 제외)합니다.

  3. Export Options 대화 상자에서 다음 옵션을 선택합니다.

  4. Add objects not existing in the VCS
    새로운 개체와 스크립트를 VCS 아카이브에 추가할 수 있습니다. VCS 아카이브에 이미 있는 개체는 업데이트되지 않습니다.

  5. Create a new revision for existing objects
    VCS에 있는 모든 기존 아카이브를 강제로 업데이트하고 새 데이터베이스 개체에 대해 새 아카이브를 추가합니다.

  6. Create a revision only if the object has changed
    데이터베이스에 있는 개체를 VCS에 있는 아카이브와 비교하여 서로 다를 경우 업데이트합니다. 이 옵션은 Toad의 Object Editor를 제외한 도구로 개체 또는 스크립트를 수정한 경우에 유용합니다.

  7. Prompt individually for all existing objects
    아카이브에 이미 있는 각 개체를 업데이트할지 여부를 묻습니다.

  8. Comment
    아카이브에 작성된 모든 새 수정에 적용할 주석을 입력합니다.

  4. 필요한 경우 제공된 단추를 사용하여 상태 보고서를 저장하거나 인쇄합니다.


Version Control Browser

Version Control Browser를 사용하여 모든 프로젝트에서 모든 버전 제어 아카이브를 볼 수 있습니다.

수정 간의 차이를 보고 개체 및 스크립트를 체크아웃할 수 있습니다.

SCC API Team Coding 지원 사용자는 이 브라우저를 사용할 수 없습니다. 대신 이 옵션을 선택하면 사용 중인 타사 제품의 사용자 인터페이스가 시작됩니다.

주: CVS를 사용할 경우 VCS 브라우저는 개체가 체크아웃되었는지 여부를 알지 못합니다. 따라서 VCS 브라우저를 통해 파일을 체크아웃할 수는 있지만 체크인할 수는 없습니다.

버전 제어를 찾아보려면

  1. Team Coding 메뉴에서 Version Control Browser를 찾습니다.

  2. 창 제어를 사용하여 파일 수정 선택, 수정 기록 보기, 파일 체크인/체크아웃, 수정 간의 차이 보기 등을 수행할 수 있습니다.

  • 노드를 펼치려면 + 기호를 누르거나 텍스트 부분을 두 번 누릅니다.

  • 개체에 대해 작업을 수행하려면 바로 가기 메뉴 또는 Browser 도구 모음에서 명령을 선택합니다.

수정 간의 차이를 보려면

Browser 도구 모음에서 View Differences를 선택한 경우 다음 옵션 중에서 선택할 수 있습니다.

  • View differences between two specified revisions

  • View differences between the selected revision and the database object (using CCG mapping)

  • View differences between the selected revision and any database object or file system script

트리에서 개체를 열려면

  • 다음 중 하나를 선택합니다.

  • 노드를 마우스 오른쪽 단추로 누르고 바로 가기 메뉴에서 Open을 선택합니다.

  • 브라우저에서 항목을 선택하고 브라우저 도구 모음에서 Open 단추를 누릅니다.


TC Locks 옵션

Version Control Browser에는 TC Locks 설정 옵션이 있습니다. 이 옵션의 설정에 따라 Toad에서 버전 제어 중인 파일의 상태를 확인하는 방법이 결정됩니다.

이 옵션을 사용하면 프로젝트 노드를 펼치는 데 걸리는 시간이 대폭 증가할 수 있습니다. 하지만 CVS는 파일 잠금을 지원하지 않기 때문에 CVS를 Version Control Provider로 사용할 경우 이 옵션은 특히 유용합니다. 이 경우 Show TC Locks를 사용하는 것만이 Team Coding이 CVS에서 잠근 파일을 확인하는 유일한 방법입니다.

주: Show TC Locks 옵션을 선택한 후 이미 펼쳐진 프로젝트 노드를 새로 고치십시오. 이 작업은 자동으로 수행되지 않습니다.

VCS Browser를 닫으면 Show TC Locks 옵션의 상태가 저장됩니다.

TC Locks 선택 안 함

이 옵션을 선택하지 않은 경우 VCS Browser는 Version Control Provider를 질의하여 잠긴 파일을 확인합니다. 각 파일의 상태는 제공자의 자체 GUI에서 볼 때처럼 표시됩니다.

TC Locks 선택

Show TC Locks 옵션을 선택한 경우 VCS Browser는 개체와의 연결을 통해 Team Coding에서 파일이 잠겨 있는지 여부를 확인하려고 시도합니다. 이 경우 파일 아이콘이 Team Coding 체크아웃 아이콘(현재 사용자가 개체를 잠근 경우) 또는 Team Coding 잠김 아이콘(다른 사용자가 개체를 잠근 경우)으로 변경됩니다. 이러한 아이콘은 Team Coding Viewer에 사용되는 아이콘과 동일합니다.

VCS Browser는 TC 잠금이 파일에 적용되는지 확인할 수 없는 경우에는 다른 잠김 아이콘을 적절하게 사용하여 일반 Version Control Provider 잠금을 표시합니다.


버전 제어 아카이브 찾아보기

Code Control Groups 및 타사 VCS 제공자를 사용하는 경우 Toad Version Control Browser를 사용하여 모든 프로젝트에 있는 모든 버전 제어 아카이브를 볼 수 있습니다. Version Control Browser에서 개체와 스크립트를 체크아웃하여 Editor에서 열 수 있습니다. 이전 버전 아카이브는 항상 Editor에서 열립니다. 수정 간의 차이점을 확인할 수도 있습니다.

주: SCC API Team Coding 지원 사용자는 이 브라우저를 사용할 수 없습니다. 대신 이 옵션을 선택하면 사용 중인 타사 제품의 사용자 인터페이스가 시작됩니다.

관련 항목

개체 및 스크립트 체크인 및 체크아웃

최신 수정 가져오기

수정 간 차이점 보기


수정 간 차이 보기

서로 다른 두 수정 간의 차이를 볼 수 있습니다.

수정 간의 차이를 보려면

  1. 비교할 파일을 선택합니다. 수정 노드 중 하나 또는 주 파일 노드를 선택할 수 있습니다.

  2. View Differences [image] 단추를 누르거나 마우스 오른쪽 단추를 누르고 View Differences를 선택합니다. View Differences 대화 상자가 나타납니다.

  3. 차이를 볼 방법을 선택합니다. 수정을 비교하려면 비교할 수정 번호를 선택합니다.

  4. OK를 누릅니다. Differences Viewer가 표시됩니다.


최신 수정 가져오기

Team Coding 환경에서 작업할 경우 VCS에 보관된 최신 버전의 개체 또는 스크립트로 작업하고 있는지 확인할 필요가 종종 있습니다. Get Latest Revision 명령을 사용하여 이 작업을 수행할 수 있습니다.

Get Latest Revision 명령은 다음 창에서 개체를 선택할 때 Team Coding 메뉴 및 도구 모음에서 사용할 수 있습니다.

  • Editor

  • Project Manager

  • Schema Browser

  • Procs 페이지

  • Types(마우스 오른쪽 단추 사용 안 함) 페이지

  • Favorites 페이지

  • Team Coding Viewer

  • Version Control Browser

메뉴에서 Get Latest Revision을 선택하거나 해당 창의 도구 모음에서 Get Latest Revision [image] 단추를 누를 수 있습니다.

주의: Get Latest Revision 명령은 데이터베이스에 있는 개체 또는 스크립트의 버전을 VCS에 보관된 최신 버전으로 대체하여 덮어씁니다.


CVS 요구 사항

Toad의 Team Coding 기능을 통해 CVS(Concurrent Versions System)를 사용할 수 있습니다.

그러려면 몇 가지 기본 구성 작업을 수행해야 합니다. 다음 항목에서는 구성 프로세스에 대해 설명합니다.

또한 CVS 클라이언트를 시스템에 설치해야 합니다(예: WinCVS, CVSNT, TortoiseCVS).

Team Coding은 다음을 사용하여 테스트했습니다.

  • CVS 클라이언트 1.11.9/1.11.17 및 CVSNT 클라이언트 2.0.8/2.0.41a(pserver 인증 방법 사용)

  • CVS 클라이언트 1.11.12(pserver 및 ssh 인증 방법 사용)

  • CVSNT 클라이언트 2.0.11, 2.0.26, 2.0.34 및 2.0.41(sserver, pserver 및 sspi 인증 방법 사용)

  • CVSNT 클라이언트 2.0.14(sserver, pserver, sspi, ssh, ext 및 로컬 인증 방법 사용)

관련 항목

Oracle 데이터베이스 설정

CVS를 사용하도록 Toad 구성

CVS 구성 옵션

CVS 로그인

여러 연결 및 CVS 로그인


Oracle 데이터베이스 설정

Team Coding과 CVS를 함께 사용하려면 먼저 그렇게 하도록 Oracle Database를 구성해야 합니다.

CVS를 설정하기 이전에 Team Coding을 데이터베이스에 설치한 것으로 간주합니다. Team Coding 설치를 참조하십시오.

Oracle 데이터베이스를 설정하려면

  1. 데이터베이스에 Team Coding Administrator 사용자로 연결합니다.

  2. Team Coding|Team Coding Status를 선택합니다.

  3. Settings 단추를 누릅니다.

  4. Enable Team Coding을 선택합니다.

  5. Use Code Control Groups를 선택합니다.

  6. Use 3rd Party Version Control을 선택합니다.

  7. Version Control Provider에서 CVS(Concurrent Versions System)를 선택합니다.

관련 항목

CVS 요구 사항

CVS에서 사용하도록 Toad 구성

CVS Configurations Options

CVS 로그인

여러 연결 및 CVS 로그인

메뉴 추가


Toad 구성

Team Coding에서 CVS를 사용하도록 Toad 구성

Toad의 Team Coding 기능을 CVS와 함께 사용하려면 Team Coding에서 CVS를 사용하도록 올바르게 구성된 데이터베이스에 연결해야 합니다. Team Coding 관리자가 이 작업을 수행해야 합니다. 자세한 내용은 Oracle 데이터베이스 설정을 참조하십시오.

Toad를 구성하려면

  1. 데이터베이스에 연결합니다.

  2. View|Toad Options|Team Coding을 선택합니다.

  3. VCS Provider Options 단추를 누릅니다.

  4. CVS Configuration Options 대화 상자에 해당 정보를 입력합니다.

주: 옵션에 대한 자세한 내용은 CVS 구성 옵션 항목을 참조하십시오.

  5. OK를 눌러 구성을 완료하고 대화 상자를 닫습니다.

관련 항목

CVS 요구 사항

Oracle 데이터베이스 설정

CVS 구성 옵션

CVS 로그인

여러 연결 및 CVS 로그인

인증 방법 및 CVSRoot


CVS 구성 옵션

CVS Configuration Options 대화 상자에는 Toad에서 CVS로 작업하는 방법을 구성하는 데 사용할 수 있는 다양한 옵션이 있습니다. 아래에서는 이러한 옵션에 대해 설명합니다.

CVS 영역

CVS Executable

여기에 CVS 프로그램 파일의 이름을 입력합니다. 기본값은 CVS.EXE입니다. 파일의 이름이 다른 경우 여기에 해당 이름을 입력할 수 있습니다.

파일의 전체 경로(예: C:\Program Files\CVS\cvs.exe)를 지정할 수 있습니다. 이 옵션은 강제로 Toad에서 지정된 프로그램을 사용하도록 합니다.

전체 경로 대신 파일 이름만 입력하는 경우 프로그램 파일의 위치가 시스템 경로에 있어야 합니다. 그럴 경우 Toad는 지정된 파일 이름으로 된 첫 번째 항목을 사용합니다.

Global Options

Toad에서 CVS 명령을 실행할 때마다 Toad에서 CVS에 전달할 전역 옵션을 지정하려면 이 옵션을 사용합니다. 예를 들어 기본 옵션 -f는 CVS에서 .cvsrc 옵션 파일을 무시하도록 지정합니다.

기본값은 -f입니다.

둘 이상의 옵션을 사용할 수 있습니다. 공백으로 여러 옵션을 구분합니다.

주: 여기에 -d CVSROOT 옵션을 입력하지 마십시오. Toad에서는 CVS Login 창에 제공된 CVSROOT를 사용하여 이 옵션을 자동으로 추가합니다.

CVS 출력의 날짜와 시간

Date Format/Separator, Time Format/Separator

이러한 옵션은 CVS에서 날짜와 시간을 전송하는 방법을 Toad에 지시합니다. 이 옵션을 사용하면 Toad에서 VCS Browser와 같은 창에 올바른 수정 날짜와 타임스탬프를 표시할 수 있습니다.

Date Format의 기본값: yyyymmdd

Date Separator의 기본값: /

Time Format의 기본값: hhnnss

Time Separator의 기본값: :

Available Date/Time 형식

형식 | 표시
d | 앞에 오는 0을 사용하지 않고 날짜를 숫자로 표시(1-31)
dd | 앞에 오는 0을 사용하여 날짜를 숫자로 표시(01-31)
m | 앞에 오는 0을 사용하지 않고 월을 숫자로 표시(1-12)
mm | 앞에 오는 0을 사용하여 월을 숫자로 표시(01-12)
yy | 연도를 두 자리 숫자로 표시(00-99)
yyyy | 연도를 네 자리 숫자로 표시(0000-9999)
h | 앞에 오는 0을 사용하지 않고 시간 표시(0-23)
hh | 앞에 오는 0을 사용하여 시간 표시(00-23)
n | 앞에 오는 0을 사용하지 않고 분 표시(0-59)
nn | 앞에 오는 0을 사용하여 분 표시(00-59)
s | 앞에 오는 0을 사용하지 않고 초 표시(0-59)
ss | 앞에 오는 0을 사용하여 초 표시(00-59)

Time Zone

이 옵션은 CVS 명령의 출력으로부터 읽은 타임스탬프를 조정하도록 지시합니다. 예를 들어 모든 타임스탬프에서 8시간을 빼려면 값으로 -800을 지정합니다. 3시간을 추가하려면 값으로 300을 입력합니다.

기본값은 0000입니다.

Login

이 옵션은 CVS에 로그인하려고 시도할 때의 Toad 동작을 제어합니다. Toad에서는 콘솔 창을 작성하여 명령 프롬프트에서 CVS Login 명령을 실행합니다. 암호 프롬프트가 나타나면 Toad는 지정된 암호를 전송합니다.

Login Automatically

이 옵션을 선택한 경우 데이터베이스에 연결하면 Toad에서 확인 메시지를 표시하지 않고 CVS에 자동으로 로그인합니다. 가장 최근에 사용한 CVSRoot가 사용됩니다.

이 옵션을 사용하려면 다음 조건이 충족되어야 합니다.

  • Team Coding 옵션 "Disable Login Prompt on Connection"을 선택하지 않아야 합니다.

  • TC=NO 명령줄 옵션을 사용하지 않아야 합니다.

  • Toad에서 CVS에 로그인한 적이 있어야 합니다.

  • 이전 로그인에서 암호를 요구하지 않는 인증 방법을 사용했어야 합니다.

또는

로그인 양식에서 Save Password 옵션을 선택해야 합니다.

Password Prompt Timeout

Toad에서 CVS 암호 프롬프트가 표시되도록 대기하는 시간(초)을 입력합니다. 암호 프롬프트가 나타나기 이전에 제한 시간이 만료되면 로그인이 실패합니다.

기본값은 10입니다.

Login Timeout

암호를 전송한 이후에 Toad에서 로그인 결과가 반환될 때까지 대기하는 시간(초)을 입력합니다. 결과가 반환되기 이전에 제한 시간이 만료되면 로그인이 실패합니다.

기본값은 10입니다.

Time Between Keypresses

이 옵션은 암호의 각 문자를 CVS 암호 프롬프트로 전송한 후 Toad가 일시 중지되는 시간(밀리초)을 제어합니다.

기본값은 0입니다.

주: CVS에서 "invalid password" 오류를 반환하는 경우 이 숫자를 증가시켜야 할 수 있습니다. 제안된 숫자는 100밀리초입니다.

Restore Defaults

모든 옵션을 기본값으로 복원하려면 Restore Defaults를 누릅니다.

관련 항목

CVS 요구 사항

Oracle 데이터베이스 설정

CVS를 사용하도록 Toad 구성

CVS 로그인

여러 연결 및 CVS 로그인


작업 폴더 업데이트

CVS 리포지토리에 있는 파일과 폴더를 확인할 수 있도록 작업 폴더를 최신 상태로 유지해야 합니다.

작업 폴더를 수동으로 업데이트해야 합니다.

작업 폴더를 업데이트하려면

  • CVS 클라이언트를 사용하여 전체 체크아웃 및 업데이트를 수행합니다. 이 작업은 CVS 명령줄 클라이언트에서 루트 작업 폴더에 다음 CVS 명령을 입력하여 수행할 수 있습니다.

cvs co .

cvs update .


CVS 로그인

기본적으로 CVS 설정을 사용하는 Team Coding이 있는 경우 데이터베이스에 연결할 때 CVS 로그인 프롬프트가 자동으로 표시됩니다.

자동으로 연결하지 않으려면 Team Coding 옵션인 Disable Login Prompt on Connection을 활성화할 수 있습니다.

주: Toad에서 CVS에 로그인할 때 Toad는 암호를 CVS 서버로 전송할 명령 프롬프트 창을 엽니다. 이 창이 전경이 아니라 배경에서 열려서 로그인이 실패할 수 있습니다. 그럴 경우 Team Coding 메뉴 또는 도구 모음에서 Log in to VCS Provider를 선택한 후 다시 로그인합니다.

로그인 프롬프트를 수동으로 표시하려면

  • Utilities|Team Coding 메뉴에서 VCS Logon을 선택합니다.

Team Coding 메뉴가 메뉴 표시줄에 표시되지 않는 경우 해당 메뉴를 수동으로 추가할 수 있습니다. 자세한 내용은 메뉴 추가를 참조하십시오.

CVS에 로그인하려면

  1. 사용할 루트를 선택합니다. 다음 두 옵션 중 하나를 선택할 수 있습니다.

  2. Use $CVSROOT Environment variable

Toad에서 CVSROOT 환경 변수를 사용하려고 시도합니다. 이 옵션을 선택하면 현재 CVSROOT 환경 변수가 첫 번째 상자에 표시됩니다.

주: 이 변수는 Toad에서 편집할 수 없습니다. 환경 변수 변경에 대한 지침은 Windows 도움말을 참조하십시오.

  • Specify CVSROOT

CVS 명령을 실행할 때 사용할 CVSROOT를 지정하려면 이 옵션을 선택합니다. Toad에서는 -d 옵션을 사용하여 이 변수를 CVS에 전달합니다. 가장 최근에 사용된 최대 10개의 CVS ROOT 값이 기억됩니다. 상자 오른쪽에 있는 화살표를 눌러 값을 선택할 수 있습니다.

  2. Working Directory 상자에 선택한 작업 디렉토리의 경로를 입력합니다. 전체 경로를 직접 입력하는 대신 Select [image] 단추를 눌러 디렉토리를 선택할 수 있습니다.

  3. password 상자에 지정된 CVSROOT에 대한 암호를 입력합니다. 암호 인증을 사용하지 않는 CVSROOT를 지정한 경우(예: :local:method) 이 입력란을 비워둘 수 있습니다. 그러면 Toad에서 CVS 로그인 명령을 실행하지 않습니다.

  4. Save Password 확인란을 선택하거나 선택 취소합니다. 이 확인란을 선택하면 암호가 CVS.INI 파일에 암호화된 형식으로 저장됩니다.

  5. OK를 눌러 CVS 로그인을 계속합니다.

또는

로그인 프로세스를 중지하려면 Cancel을 누릅니다.

주: Team Coding|VCS Logon을 선택하면 로그온 프롬프트에서 Cancel을 누르더라도 현재 연결에 대한 CVS로부터 로그아웃됩니다. 다시 연결하려면 값을 변경하지 않고 OK를 누릅니다.

관련 항목

CVS 요구 사항

Oracle 데이터베이스 설정

Toad 구성

여러 연결 및 CVS 로그인

인증 방법 및 CVSRoot


여러 연결 및 CVS 로그인

한 개의 Toad 인스턴스에서 여러 데이터베이스에 연결할 수 있습니다.

다음을 수행할 수 있습니다.

  • 각 데이터베이스에 대해 서로 다른 CVS 로그인 설정

  • 여러 인스턴스 간에 동일한 로그인 공유

CVS에 로그인한 이후에는 첫 번째 인스턴스가 연결된 상태로 유지되는 한 로그인 상태가 유지되므로 CVS Login 대화 상자가 표시되지 않습니다.

주: Toad에서 데이터베이스에 새로 연결할 때마다 가장 최근에 설정된 연결의 CVS 로그인이 사용됩니다.

원하는 경우 처음에 로그인한 이후에 다른 CVSROOT로 로그인할 수 있습니다.

최초 로그온 이후에 다른 CVSROOT로 로그인하려면

  • Utilities|Team Coding|VCS Logon을 선택합니다. CVS 로그인에서 설명한 대로 로그인합니다.

관련 항목

CVS 요구 사항

Oracle 데이터베이스 설정

CVS를 사용하도록 Toad 구성

CVS 구성 옵션

CVS 로그인

여러 연결 및 CVS 로그인


인증 방법 및 CVS 루트

대부분의 CVS 서버는 다양한 인증 방법을 지원합니다. CVS 서버에 액세스하는 데 사용되는 인증 방법은 CVSRoot의 첫 번째 부분에서 지정됩니다. CVSRoot는 다음과 같은 섹션으로 구성됩니다.

:authentication method:user@host:port:/path

경로를 제외한 모든 섹션은 선택 사항입니다. 다음과 같은 규칙이 적용됩니다.

  • 경로만으로 구성되는 CVSRoot는 로컬 인증 방법을 사용하며, 다음과 동의어입니다.

:local:/path

  • 사용자 섹션을 생략하면 CVS 클라이언트는 Window 로그인 이름을 사용합니다.

  • 호스트 섹션은 로컬을 제외한 모든 방법에 포함되어야 합니다.

  • 포트 섹션은 CVS 서버가 기본 포트(2401) 이외의 포트를 수신 대기하는 경우에만 필요합니다.

Toad에서 테스트된 CVS 인증 방법

Toad는 pserver, sserver, ssh, sspi, ext 및 로컬과 같은 CVS 인증 방법으로 테스트되었습니다.

pserver 및 sserver 방법 사용

pserver 및 sserver 사용법은 간단합니다.

  • 두 방법 모두 사용자 이름과 암호가 필요합니다.

  • 두 방법에서 Toad는 CVS 로그인 명령을 실행합니다.

  • sspi에서는 사용자 이름이 선택 사항입니다. 사용자 이름을 제공하면 Toad는 CVS 로그인 명령을 실행합니다. 사용자 이름을 제공하지 않는 경우 Toad는 CVS 로그인 명령을 실행하지 않습니다.

로컬 및 ext 방법 사용

로컬 및 ext 방법에는 암호가 필요하지 않습니다.

  • 로컬 방법은 로컬 CVS 리포지토리에 액세스하는 데 사용됩니다. 이 방법은 인증 방법이 지정되지 않은 경우를 가정합니다.

  • ext 방법은 SSH 인증에 사용됩니다. SSH 사용에 대한 자세한 내용은 ext 방법을 통한 SSH 인증을 참조하십시오.

관련 항목

CVS를 사용하도록 Toad 구성

CVS 로그인

ext 방법을 통한 SSH 인증


ext 방법을 통한 SSH 인증

Toad에서는 다음과 같은 조건이 충족될 경우 ext 방법을 통한 SSH(Secure Shell) 사용을 지원합니다.

  • 외부 SSH 클라이언트 및 SSH Authentication Agent를 설치하고 구성해야 합니다.

  • SSH 인증이 투명해야 합니다. Toad에서는 개인 키 또는 암호문구 요청에 응답할 수 없습니다.

  • SSH 클라이언트 프로그램이 "ssh"가 아닐 경우 CVS_RSH 사용자 환경 변수를 설정하여 SSH 클라이언트 프로그램을 지정해야 합니다.

SSH 구성 단계 예:

이 구성에서는 Plink를 SSH 클라이언트로 Pageant를 SSH 인증 에이전트로 사용합니다. Plink, Pageant 및 PuttyGen은 Simon Tathem의 PuTTy 소프트웨어 패키지에 포함되어 있습니다.

주: 이 구성은 예제 구성에 불과합니다.

  1. PuTTy 설치(Plink 및 Pageant 포함)

  2. PuttyGen을 사용하여 공개 및 개인 키를 생성합니다.

  3. 공개 키를 CVS 서버에 업로드합니다. 이 서버는 SSHD를 실행 중이어야 합니다.

  4. Pageant를 로드하고 개인 키를 등록합니다. SSH를 사용할 때마다 Pageant를 실행 상태로 유지합니다.

  5. CVS_RSH 환경 변수를 plink.exe의 경로(예: c:\program files\Putty\plink.exe)로 설정합니다.

  6. CVSRoot를 :ext:user@host:port:/path로 설정합니다. 여기서

  7. user = CVS 서버에서 사용자의 SSH 로그인 이름

  8. host = CVS 서버 호스트 이름 또는 IP 주소

  9. port = CVS 서버 포트(선택 사항)

  10. path = 서버의 CVS 리포지토리 경로(예: :ext:smithj@cvs.toadrocks.com:2401:/usr/local/cvs/project)

관련 항목

CVS에서 사용하도록 Toad 구성

인증 방법 및 CVS 루트

CVS 로그인


Missing CVS\Entries File 오류

Missing CVS/Entries File 오류

Toad는 Entries라는 파일을 읽어 CVS 리포지토리에 있는 파일 및 폴더를 확인합니다. 이 파일은 일반적으로 각 작업 폴더 아래의 CVS라는 폴더에 있습니다. Toad가 작업 폴더에서 이 파일을 찾을 수 없는 경우 Missing CVS/Entries file 오류가 표시됩니다.

이 오류는 다음 중 한 가지 방법으로 발생할 수 있습니다.

  • 아직 cvs co.를 수행하여 모두를 체크아웃하지 않은 경우 Entries 및 Repository 파일이 자동으로 작성되지 않습니다. 이 오류는 cvs co.를 수행하면 해결됩니다. 이 때 명령에 점을 포함시켜야 합니다.

  • 일부 CVS 버전은 CVS/Entries 파일을 루트 작업 폴더에 자동으로 작성하지 않습니다. 그러면 일반 CVS 작업에는 영향을 미치지 않지만 Toad의 CVS 지원이 작동하지 않습니다.

CVS/Entries 파일 오류 문제를 수동으로 해결하려면

  1. 루트 작업 폴더에서 CVS라는 새 폴더를 작성합니다.

  2. 새 CVS 폴더에서 Entries라는 빈 파일을 작성합니다.

  3. 새 CVS 폴더에서 단일 문자 .(점)이 캐리지 리턴 앞에 있는 단일 행을 포함하는 Repository라는 파일을 작성합니다.

  4. CVS에 로그인합니다.

  5. 루트 작업 폴더에서 다음 CVS 명령을 실행합니다. cvs co .

  6. 루트 작업 폴더에서 다음 CVS 명령을 실행합니다. cvs update .

주: 전체 리포지토리 대신 개별 파일 또는 프로젝트에서 "update"를 수행해야 할 수도 있습니다.

Entries 파일 설정

Entries 파일을 작성한 후에는 원하는 파일을 체크아웃하도록 Entries 파일을 설정할 수 있습니다. 전체 리포지토리를 체크아웃하거나 일부 프로젝트만 체크아웃할 수 있습니다.

전체 리포지토리를 체크아웃하려면

  • 전체 리포지토리를 체크아웃하려면 Entries 파일을 비워 둡니다.

리포지토리에 있는 일부 프로젝트를 체크아웃하려면

  1. 일부 프로젝트만 리포지토리에 보관하려면 아래 설명과 같이 Entries 파일에 프로젝트를 입력합니다.

D/Project1///

D/Project2///

D/Project3///

여기서 Projectn은 프로젝트의 이름입니다.

  2. 각 프로젝트를 하나씩 체크아웃하고 업데이트합니다. 예를 들면 다음과 같습니다.

>cvs co Project1

>cvs update Project1

>cvs co Project2

>cvs update Project2


추가 CVS Entries 파일 정보

Entries 파일 설정

원하는 파일을 체크아웃하도록 Entries 파일을 설정할 수 있습니다. 전체 리포지토리를 체크아웃하거나 일부 프로젝트만 체크아웃할 수 있습니다.

전체 리포지토리를 체크아웃하려면

  • 전체 리포지토리를 체크아웃하려면 Entries 파일을 비워 둡니다.

리포지토리에 있는 일부 프로젝트를 체크아웃하려면

  1. 일부 프로젝트만 리포지토리에 보관하려면 아래 설명과 같이 Entries 파일에 프로젝트를 입력합니다.

Project1/Project2/Project3

  2. 각 프로젝트를 하나씩 체크아웃하고 업데이트합니다. 예를 들면 다음과 같습니다.

>cvs co Project1

>cvs update Project1

>cvs co Project2

>cvs update Project2

관련 항목

CVS\Entries 파일 없음

CVS 요구 사항


Background Process 창

Update, Insert, and Delete statements in background 옵션이 표시되어 있거나 Process PL/SQL statements in background 옵션이 표시되어 있으면(자세한 내용은 Toad Options|Editor 참조) 이러한 구문 중 하나가 Editor에서 실행될 때 이 창이 표시됩니다.

이러한 구문 중 하나가 실행되면 구문이 별도의 배경 프로세스 창으로 복사되어 구문이 실행 중임을 나타냅니다.

배경 창은 별도의 Oracle 연결이며, Toad와는 별개입니다. 배경 창의 바깥쪽을 누르면 모든 Toad 창 뒤에 숨겨집니다. 다시 표시하려면 해당 세션의 작업 표시줄에 마우스 오른쪽 단추를 누르고 메뉴에서 Background Process: statement 옵션을 선택합니다.

Background Process 도구 모음

Background Process 창의 도구 모음에서 다음 작업을 수행할 수 있습니다.

단추 | 명령
 | DBMS 출력이 구문에서 생성된 모든 DBMS 출력을 표시합니다.
 | 배경 프로세스에서 실행되는 구문에 의해 변경된 내용만 실행합니다.
 | 배경 프로세스에서 실행되는 구문에 의해 변경된 내용만 롤백합니다.
 | 현재 구문을 다시 실행합니다.
CANCEL | 진행 중인 구문 실행을 취소합니다.
Close after commit/rollback | 이 확인란에서 변경 내용을 실행 또는 롤백한 후 창을 닫거나 열린 상태로 둘 수 있습니다.


지원되는 열 이름

열 이름은 문자 A-Z, 숫자 0-9 및 밑줄 문자"_"만 지원되는 열 문자를 포함합니다.

Toad는 표 열 이름에 공백, 소문자 및 특수 문자를 지원하지 않습니다.

예를 들어, "This is a test"라는 열은 지원되지 않지만 "this_is_a_test"는 지원됩니다.


창: Graph Properties

Graph Properties

Profiler Analysis 창에서 이 창을 열 수 있습니다.

이 창에서 원형 차트/막대형 차트 그래프 속성을 조정할 수 있습니다.


OPS$ 계정

Toad는 운영 체제가 사용자 및 암호의 유효성을 검사하는 위치에서 로그인을 수락합니다. 데이터베이스 별칭을 선택하고 Username 및 Password 상자는 빈 상태로 둡니다. Oracle이 워크스테이션 로그인을 미리 수정하고 로그인을 시도합니다.

OPS$ 계정을 사용하기 위해 사용자의 데이터베이스 init.ora 초기화 매개 변수 파일에는 다음의 두 가지 항목이 있어야 합니다.

remote_os_authent = TRUE

os_authent_prefix = OPS$

(또는 선택한 모든 접미사)

사용자 계정은 다음과 같이 만들어야 합니다.

create user (username) identified externally...

Oracle은 운영 체제의 사용자 이름이 데이터베이스 연결에 지정된 데이터베이스 사용자 이름과 일치하는지 확인합니다. Oracle은 운영 체제 사용자 이름을 사용합니다. 예를 들면 SCC14433입니다. 또한 "os_authent_prefix" 값을 "OPS$SCC14433" 앞에 둡니다. 그런 다음 Oracle의 스키마 이름으로 사용합니다. 예: "select * from all_objects where owner = 'OPS$SCC14433'".

예:

Joe Smith씨가 ORA805 데이터베이스에 로그인하고 Database 상자에서 "ORA805"를 입력하고 Username 및 Password는 빈 상태로 둡니다. 그의 NT 로그인은 "JSMITH"가 되고 그 앞에 "OPS$"가 붙게 되어 사용자 이름이 "OPS$JSMITH"가 됩니다. Oracle이 로그인을 시도하고 Toad가 시작됩니다.

다음에 Server Login 창이 나타나면 O/S 인증 로그인이었던 이전 로그인은 모두 "EXTERNAL"이라는 사용자 이름을 가지게 됩니다. 따라서, 다시 연결할 때 Username 상자에 EXTERNAL을 입력하지 않아도 됩니다.

"Create user ... identified externally..."를 사용하면 데이터베이스 관리자가 특정 운영 체제 계정에서만 액세스할 수 있는 데이터베이스 사용자를 만들 수 있습니다. 데이터베이스 연결 도중 Oracle은 운영 체제 사용자 이름이 특정 데이터베이스 이름(초기화 매개 변수 OS_AUTHENT_PREFIX 포함)과 일치하는지 확인합니다. 기본적으로, 운영 체제의 로그인 인증에 따라 특정 운영 체제 사용자에게 특정 데이터베이스 사용자에 대한 액세스가 있는지 확인할 수 있습니다. 따라서, 이러한 데이터베이스 계정의 효율적인 보안은 운영 체제의 보안 시스템 성능에 전적으로 달려 있습니다. 이는 Windows 95 및 98에 보안상의 허점이 있음을 나타내며, 이러한 운영 체제에서는 특정 사용자가 확인되지 않습니다. Windows NT는 특정 사용자 이름의 모든 사용자를 확인합니다.


도킹된 창 보기 또는 숨기기

Toad 내의 여러 창을 기본 창으로 도킹할 수 있습니다. 다음과 같습니다.

  • Project Manager

  • Output window

  • Code Snippets

  • Object Palette

도킹할 때 이 창을 언제든지 표시하거나 마우스 포인터를 실행하지 않을 경우 탭의 형식에서 숨길 수 있습니다.

도킹된 창을 숨기려면

  • 도킹된 창의 우측 상단 모서리에 thumbtack 단추가 있습니다. 표시되면 thumbtack 이미지가 가로 모양이 됩니다. thumbtack [image] 단추를 눌러 도킹된 창을 숨깁니다.

숨겨진 도킹된 창을 보려면

도킹된 창이 숨겨져 있으면 창 이름의 탭이 나타나며 화면 공간이 보다 커집니다.

  • 창을 보려면 탭에 마우스를 올려놓습니다.

숨겨진 도킹된 창을 표시하려면

  • 도킹된 창의 우측 상단 모서리에 thumbtack 단추가 있습니다. 도킹된 창이 숨겨져 있으면 thumbtack 이미지가 세로 모양이 됩니다. thumbtack [image] 단추를 눌러 도킹된 창을 표시합니다.


PL/SQL 오류 주변 원본 보기

이 질의를 사용하여 오류 줄 앞뒤로 PL/SQL 줄을 확인할 수 있습니다. 즐겨찾기 목록에 추가하십시오!

select decode(to_char(us.line), '1', ue.text||'
Pkg:'||us.name||chr(10)||chr(10)||
' '||to_char(us.line,'99990')||' '||us.text,
to_char(ue.line-7),ue.text||' Pkg:'||us.name||' ',
to_char(ue.line-6),'',
to_char(ue.line+6),'',
to_char(ue.line) ,'-->'||to_char(us.line,'99990')
||' '||us.text
,' '||to_char(us.line,'99990')
||' '||us.text) outline
from user_source us, user_errors ue
where us.line between (ue.line-7) and (ue.line+6)
and us.name = ue.name
and us.type =ue.type
and ue.text not like 'PL/SQL: Statement ignored'
and ue.text not like 'PL/SQL: Declaration ignored'
order by ue.name, ue.line, ue.text, us.line;

위 질의의 일부 예제 출력입니다.

PLS-00103: Encountered the symbol "=" when expecting one of the following:

:= . ( @ % ;

The symbol ":= was inserted before "=" to continue.

Pkg:FOO

20 LIMITATIONS:

21 ALGORITHM:

22 NOTES:

23 ******************************************************************************/

24 BEGIN

--> 25 tmpVar = 0;

26

27 EXCEPTION

28 WHEN NO_DATA_FOUND THEN

29 Null;

30


명령줄 옵션

Toad을 열고 제어하는 데 사용할 수 있는 여러 명령줄 옵션이 있습니다.

명령줄 옵션을 추가 또는 편집하려면 File Explorer에서 새 Toad 바로 가기를 작성합니다. Toad의 원래 바로 가기는 유지하면서 수행할 각 유형의 명령줄 옵션 또는 기능에 대한 바로 가기를 작성합니다.

다음 위치로 드릴다운합니다.

C:\WINNT\PROFILES\USER\START MENU\PROGRAMS\QUEST SOFTWARE\Toad for Oracle(NT)

또는

C:\WINDOWS\START MENU\PROGRAMS\QUEST SOFTWARE\Toad for Oracle(WIN95/98)

기존 Toad 응용 프로그램 바로 가기를 복사하여 동일한 폴더에 붙여넣은 다음 수행할 기능(예: "Toad Auto Exec DO_PROC")으로 이름을 바꾸어 새 바로 가기를 쉽게 작성할 수 있습니다.

바로 가기에 명령줄 옵션을 포함하려면

  • 바로 가기를 선택하고 File|Properties로 이동한 다음 Shortcut 탭을 누르고 Target 상자에 다음을 입력합니다.

"Toad.EXE" PATH= CONNECT= filename /EXEC /PRINT /SCRIPT

여기서

"Toad.EXE"는 Toad 실행 파일의 정규화된 경로입니다.

PATH=은 로컬 사용자 파일의 경로입니다(네트워크 공유에서 Toad.EXE를 읽을 경우).

CONNECT=은 schema/password@dbalias 연결 정보입니다.

filename =은 로드, 실행 또는 인쇄할 파일의 정규화된 경로입니다.

/EXEC는 로드된 파일의 실행을 스크립트로 트리거합니다.

/PRINT는 소스 코드 인쇄를 트리거합니다.

/SCRIPT는 로드된 파일을 스크립트로 실행하는 작업을 트리거합니다.

주: /EXEC, /PRINT 또는 /SCRIPT를 한 번에 하나만 사용할 수 있습니다. PATH는 선택 사항입니다.

프로시저 실행

Toad를 자동으로 시작하여 프로시저를 실행하려면 "Toad Auto Exec Statement"와 같은 이름이 지정된 새 바로 가기를 작성하고 다음을 바로 가기로 입력합니다.

"C:\Program Files\Quest Software\Toad for Oracle\Toad.exe" CONNECT=schema/password@dbalias c:\temp\exec.sql /EXEC

BEGIN

  do_proc;

END;

바로 가기를 호출할 경우 Toad는 로드되어 데이터베이스에 연결된 다음 파일을 Editor에 로드하고 하나의 문으로 실행합니다.

PL/SQL 컴파일

Toad를 자동으로 시작하여 PL/SQL 스크립트를 컴파일하려면 "Toad Auto Compile Proc"와 같은 이름이 지정된 새 바로 가기를 작성하고 다음을 바로 가기로 입력합니다.

"C:\Program Files\Quest Software\Toad for Oracle\Toad.exe" CONNECT=schema/password@dbalias c:\temp\exec.prc /EXEC

이 경우 exec.prc에는 컴파일할 프로시저가 포함됩니다.

CREATE OR REPLACE PROCEDURE A IS

BEGIN

 B;

END;

/

바로 가기를 호출할 경우 Toad는 로드되어 데이터베이스에 연결된 다음 파일을 Proc Editor에 로드하고 컴파일합니다.

파일 확장명 연결은 Toad Options|Files 탭에서 설정합니다.

자동 연결

특정 스키마 및 데이터베이스와 함께 Toad를 자동으로 시작하려면 "Toad Auto Start Schema Database"와 같은 이름이 지정된 새 바로 가기를 작성하고 다음을 바로 가기로 입력합니다.

"C:\Program Files\Quest Software\Toad for Oracle\Toad.EXE"

CONNECT=schema/password@dbalias

바로 가기를 호출할 경우 Toad는 로드되어 데이터베이스에 연결된 다음 사용자가 Toad Options, Startup 대화 상자에서 선택한 모든 창을 엽니다.

파일을 스크립트로 실행

Toad를 자동으로 시작하여 스크립트 파일을 실행하려면 "ToadAuto Start Exec Script"와 같은 이름이 지정된 새 바로 가기를 작성하고 다음을 바로 가기로 입력합니다.

"C:\Program Files\Quest Software\Toad for Oracle\Toad.exe" CONNECT=schema/password@dbalias c:\temp\exec.sql /SCRIPT

바로 가기를 호출할 경우 Toad는 로드되어 데이터베이스에 연결된 다음 파일을 Editor에 로드하고 스크립트로 실행합니다. Editor에서는 이 작업이 인식되지 않습니다. 또한 익명 PL/SQL 블록은 스크립트로 실행될 경우 지원되지 않습니다.

파일 로드

Toad를 자동으로 시작하여 원하는 파일을 로드하려면 "Toad Auto Start File"과 같은 이름이 지정된 새 바로 가기를 작성하고 다음을 바로 가기로 입력합니다.

"C:\Program Files\Quest Software\Toad for Oracle\Toad.exe" CONNECT=schema/password@dbalias c:\temp\exec.sql

바로 가기를 호출할 경우 Toad는 로드되어 데이터베이스에 연결된 다음 파일 확장명에 기초한 Editor에 파일을 로드합니다.

명령줄 작업 도중 Toad 최소화

MINIMIZE=YES를 명령줄에 추가하여 명령줄 작업을 실행하는 동안 Toad를 최소화된 상태로 유지할 수 있습니다.

파일 인쇄

Toad를 자동으로 시작하여 원하는 파일을 인쇄하려면 "Toad Auto Start Print File"과 같은 이름이 지정된 새 바로 가기를 작성하고 다음을 바로 가기로 입력합니다.

"C:\Program Files\Quest Software\Toad for Oracle\Toad.exe" CONNECT=schema/password@dbalias C:\temp\exec.sql /PRINT

바로 가기를 호출할 경우 Toad는 로드되어 데이터베이스에 연결된 다음 파일 확장명에 기초한 Editor에 파일을 로드하고 파일을 인쇄합니다.

Team Coding 로그인 프롬프트 해제

다음 명령을 명령줄에 추가하여 명령줄에서 작업할 때 Team Coding 로그인 프롬프트를 표시하지 않을 수 있습니다.

TC=NO


명령 프롬프트에서 데이터베이스 비교 실행

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

다른 사용자에 의한 예기치 않은 변경 내용을 모니터링하기 위해 데이터베이스를 정기적으로 비교해야 할 수 있습니다. 약간의 준비를 하면 자리를 비울 때 명령 프롬프트에서 비교를 수행할 수 있습니다. 결과를 파일에 저장하거나 전자 메일로 보낼 수 있습니다.

오류는 Toad의 시작 디렉토리에 있는 ToadErrors.log라는 파일에 기록됩니다. 이 파일은 Toad를 닫을 때 작성됩니다. 오류 파일이 작성될 경우 Toad는 0이 아닌 종료 코드와 함께 닫힙니다.

데이터베이스 비교를 실행하기 위해 파일을 작성하려면

  1. Toad를 시작합니다.

  2. Database 메뉴에서 Compare|Compare Databases를 선택합니다.

  3. 비교를 수행하기 위한 모든 설정을 지정하되(데이터베이스 비교 참조) Compare를 누르지 않습니다.

  4. 대신에 Options 탭에서 Save All Settings to File 단추를 누릅니다. Save를 눌러 설정 정보를 저장합니다.

파일 조정

위 절차의 결과로 얻어진 파일을 메모장이나 다른 텍스트 편집기를 사용하여 편집할 수 있습니다. 명령줄에서 사용할 수 있으려면 설정 파일에서 명령을 활성화하여 스크립트를 생성해야 합니다.

명령은 파일의 끝이나 시작 부분에 존재할 수 있으며 실행하려는 순서대로 되어 있어야 합니다. 사용자의 편리를 위해 사용 가능한 모든 명령이 설정 파일에 기록되어 주석으로 처리됩니다. 쉽게 주석을 제거하고 명령을 잘라내어 실행하려는 순서대로 붙여 넣을 수 있습니다. 또한 이러한 명령의 축약된 집합이 설정 파일 주석에 있습니다.

명령

각 명령은 표시된 대로 정확하게 입력해야 합니다(단, 대/소문자는 원하는 대로 입력할 수 있고 파일 경로와 이름을 변경할 수 있음). 명령의 앞뒤나 명령과 매개 변수 목록 사이에 공백이 허용되지 않습니다. 주석이나 파일의 끝 부분을 제외하고는 빈 줄이 파일에 있으면 안 됩니다.

  • SaveInteractiveResultsAsText(‘c:\InteractiveResultsFile.txt’) - ‘Interactive Results’ 탭의 내용을 텍스트 형식으로 저장합니다. RTF 형식으로는 저장할 수 없습니다.

  • SaveRTFResultsAsRTF(‘c:\RTFResultsFile.rtf’) - ‘Results(RTF)’ 탭의 내용을 RTF 형식으로 저장합니다.

  • SaveRTFResultsAsText(‘c:\TextResultsFile.txt’) - ‘Results(RTF)’ 탭의 내용을 텍스트 형식으로 저장합니다.

  • SaveSummaryAsRTF(‘c:\RTFSummaryFile.rtf’) - ‘Results(Summary)’ 탭의 내용을 RTF 형식으로 저장합니다.

  • SaveSummaryAsText(‘c:\RTFSummaryFile.txt’) - ‘Results(Summary)’ 탭의 내용을 텍스트 형식으로 저장합니다.

  • SaveSyncScript('c:\SyncScript.sql') - 비교 소스 데이터베이스를 참조 소스 데이터베이스로 변환하기 위한 sql인 SyncScript를 지정된 파일에 저장합니다. 파일 경로와 이름을 변경할 수 있습니다.

  • EmailInteractiveResultsAsText - ‘Interactive Results’ 탭의 내용을 텍스트 형식으로 저장하고 View|Toad Options|Email Settings에 지정된 주소에 파일을 전자 메일로 보냅니다. RTF 형식은 사용할 수 없습니다.

  • EmailRTFResultsAsRTF - ‘Results(RTF)’ 탭의 내용을 RTF 형식으로 저장하고 View|Toad Options|Email Settings에 지정된 주소에 파일을 전자 메일로 보냅니다.

  • EmailRTFResultsAsText - ‘Results(RTF)’ 탭의 내용을 텍스트 형식으로 저장하고 View|Toad Options|Email Settings에 지정된 주소에 파일을 전자 메일로 보냅니다.

  • EmailSummaryAsRTF - ‘Results(Summary)’ 탭의 내용을 RTF 형식으로 저장하고 View|Toad Options|Email Settings에 지정된 주소에 파일을 전자 메일로 보냅니다.

  • EmailSummaryAsText - ‘Results(Summary)’ 탭의 내용을 텍스트 형식으로 저장하고 View|Toad Options|Email Settings에 지정된 주소에 텍스트 파일을 전자 메일로 보냅니다.

  • EmailSyncScript - SyncScript의 내용을 저장하고 View|Toad Options|Email Settings에 지정된 주소에 파일을 전자 메일로 보냅니다.

  • CloseToad - 스크립트가 끝난 후에 Toad를 닫습니다.

  • CloseComparison - 비교가 끝난 후에 데이터베이스 비교 창을 닫습니다.

  • # - 이 줄은 주석이며 무시됩니다.

주: 모든 전자 메일 설정은 View|Toad Options|Email Settings |Compare Databases에서 가져옵니다.

명령 프롬프트에서 실행

한 번만 비교

파일이 준비되면 명령줄에서 비교를 실행할 수 있습니다.

명령 프롬프트를 열고 명령줄을 입력합니다. 다음과 같은 형태여야 합니다.

Toad.exe Connect=system/manager@mydb COMPDB=c:\MYfile.txt

주: Toad.exe가 있는 디렉토리와 동일한 디렉토리에 있어야 하며 그렇지 않을 경우에는 명령줄에 전체 경로 이름을 입력해야 합니다.

  • CONNECT 명령 다음의 문자는 사용자 ID와 Oracle 데이터베이스를 반영해야 합니다.

  • myfile.txt를 위에서 저장한 설정 파일의 이름으로 변경합니다.

여러 번 비교

Toad에서 둘 이상의 비교를 수행하려면 다음 명령줄로 Toad를 호출합니다.

Toad.exe CONNECT=system/manager@myOraDB CmdFile=c:\commandfile.txt

이 경우 commandfile.txt는 특정 명령을 포함하는 별개의 파일입니다. 이 파일은 다음과 같아야 합니다.

COMP=c:\Comparison1.txt

COMP=c:\Comparison2.txt

COMP=c:\Comparison3.txt

CloseToad

여기에서 Comparison1.txt, Comparison2.txt 및 Comparison3.txt는 세 개의 개별 데이터베이스 비교 설정 파일이며 Toad는 호출될 경우 이러한 파일에 정의된 세 개의 데이터베이스 비교를 실행합니다. 비교가 끝나면 Toad가 자동으로 닫힙니다.

주: 비교 설정 파일에 CLOSEToad 명령이 있는 경우에도 모든 데이터베이스 비교가 실행될 때까지 Toad는 닫히지 않습니다.


명령 프롬프트에서 스키마 비교 실행

다른 사용자에 의한 예기치 않은 변경 내용을 모니터링하기 위해 스키마를 정기적으로 비교해야 할 수 있습니다. 약간의 준비를 하면 자리를 비울 때 명령 프롬프트에서 비교를 수행할 수 있습니다. 결과를 파일에 저장하거나 전자 메일로 보낼 수 있습니다.

오류는 Toad의 시작 디렉토리에 있는 ToadErrors.log라는 파일에 기록됩니다. 이 파일은 Toad를 닫을 때 작성됩니다. 오류 파일이 작성될 경우 Toad는 0이 아닌 종료 코드와 함께 닫힙니다.

스키마 비교를 실행하기 위해 파일을 작성하려면

  1. Toad를 시작합니다.

  2. Database 메뉴에서 Compare|Compare Schemas를 선택합니다.

  3. 비교를 수행하기 위한 모든 설정을 지정하되(스키마 비교 참조) Compare를 누르지 않습니다.

  4. 대신에 Options 탭에서 Save All Settings to File 단추를 누릅니다. Save를 눌러 설정 정보를 저장합니다.

파일 조정

위 절차의 결과로 얻어진 파일을 메모장이나 다른 텍스트 편집기를 사용하여 편집할 수 있습니다. 명령줄에서 사용할 수 있으려면 설정 파일에서 명령을 활성화하여 스크립트를 생성해야 합니다.

명령은 파일의 끝이나 시작 부분에 존재할 수 있으며 실행하려는 순서대로 되어 있어야 합니다. 사용자의 편리를 위해 사용 가능한 모든 명령이 설정 파일에 기록되어 주석으로 처리됩니다. 쉽게 주석을 제거하고 명령을 잘라내어 실행하려는 순서대로 붙여 넣을 수 있습니다. 또한 이러한 명령의 축약된 집합이 설정 파일 주석에 있습니다.

명령

각 명령은 표시된 대로 정확하게 입력해야 합니다(단, 대/소문자는 원하는 대로 입력할 수 있고 파일 경로와 이름을 변경할 수 있음). 명령의 앞뒤나 명령과 매개 변수 목록 사이에 공백이 허용되지 않습니다. 주석이나 파일의 끝 부분을 제외하고는 빈 줄이 파일에 있으면 안 됩니다.

  • SaveInteractiveResultsAsText(‘c:\InteractiveResultsFile.txt’) - ‘Interactive Results’ 탭의 내용을 텍스트 형식으로 저장합니다. RTF 형식으로는 저장할 수 없습니다.

  • SaveRTFResultsAsRTF(‘c:\RTFResultsFile.rtf’) - ‘Results(RTF)’ 탭의 내용을 RTF 형식으로 저장합니다.

  • SaveRTFResultsAsText(‘c:\TextResultsFile.txt’) - ‘Results(RTF)’ 탭의 내용을 텍스트 형식으로 저장합니다.

  • SaveSummaryAsRTF(‘c:\RTFSummaryFile.rtf’) - ‘Results(Summary)’ 탭의 내용을 RTF 형식으로 저장합니다.

  • SaveSummaryAsText(‘c:\RTFSummaryFile.txt’) - ‘Results(Summary)’ 탭의 내용을 텍스트 형식으로 저장합니다.

  • SaveSyncScript('c:\SyncScript.sql') - 비교 소스 스키마를 참조 소스 스키마로 변환하기 위한 sql인 SyncScript를 지정된 파일에 저장합니다. 파일 경로와 이름을 변경할 수 있습니다.

  • EmailInteractiveResultsAsText - ‘Interactive Results’ 탭의 내용을 텍스트 형식으로 저장하고 View|Toad Options|Email Settings에 지정된 주소에 파일을 전자 메일로 보냅니다. RTF 형식은 사용할 수 없습니다.

  • EmailRTFResultsAsRTF - ‘Results(RTF)’ 탭의 내용을 RTF 형식으로 저장하고 View|Toad Options|Email Settings에 지정된 주소에 파일을 전자 메일로 보냅니다.

  • EmailRTFResultsAsText - ‘Results(RTF)’ 탭의 내용을 텍스트 형식으로 저장하고 View|Toad Options|Email Settings에 지정된 주소에 파일을 전자 메일로 보냅니다.

  • EmailSummaryAsRTF - ‘Results(Summary)’ 탭의 내용을 RTF 형식으로 저장하고 View|Toad Options|Email Settings에 지정된 주소에 파일을 전자 메일로 보냅니다.

  • EmailSummaryAsText - ‘Results(Summary)’ 탭의 내용을 텍스트 형식으로 저장하고 View|Toad Options|Email Settings에 지정된 주소에 텍스트 파일을 전자 메일로 보냅니다.

  • EmailSyncScript - SyncScript의 내용을 저장하고 View|Toad Options|Email Settings에 지정된 주소에 파일을 전자 메일로 보냅니다.

  • CloseToad - 스크립트가 끝난 후에 Toad를 닫습니다.

  • CloseComparison - 비교가 끝난 후에 스키마 비교 창을 닫습니다.

  • # - 이 줄은 주석이며 무시됩니다.

주: 모든 전자 메일 설정은 View|Toad Options|Email Settings에서 가져옵니다.

명령 프롬프트에서 실행

한 번만 비교

파일이 준비되면 명령줄에서 비교를 실행할 수 있습니다.

명령 프롬프트를 열고 명령줄을 입력합니다. 다음과 같은 형태여야 합니다.

Toad.exe CONNECT=system/manager@myOraDB COMP=c:\myfile.txt

주: Toad.exe가 있는 디렉토리와 동일한 디렉토리에 있어야 하며 그렇지 않을 경우에는 명령줄에 전체 경로 이름을 입력해야 합니다.

  • CONNECT 명령 다음의 문자는 사용자 ID와 Oracle 데이터베이스를 반영해야 합니다.

  • myfile.txt를 위에서 저장한 설정 파일의 이름으로 변경합니다.

여러 번 비교

Toad에서 둘 이상의 비교를 수행하려면 다음 명령줄로 Toad를 호출합니다.

Toad.exe CONNECT=system/manager@myOraDB CmdFile=c:\commandfile.txt

이 경우 commandfile.txt는 특정 명령을 포함하는 별개의 파일입니다. 이 파일은 다음과 같아야 합니다.

COMP=c:\Comparison1.txt

COMP=c:\Comparison2.txt

COMP=c:\Comparison3.txt

CloseToad

여기에서 Comparison1.txt, Comparison2.txt 및 Comparison3.txt는 세 개의 개별 스키마 비교 설정 파일이며 Toad는 호출될 경우 이러한 파일에 정의된 세 개의 스키마 비교를 실행합니다. 비교가 끝나면 Toad가 자동으로 닫힙니다.

주: 비교 설정 파일에 CLOSEToad 명령이 있는 경우에도 모든 스키마 비교가 실행될 때까지 Toad는 닫히지 않습니다.


명령줄에서 데이터베이스 스크립트 생성 실행

명령 프롬프트에서 데이터베이스 스크립트 생성 실행

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

데이터베이스 스크립트 생성을 실행하기 위해 파일을 작성하려면

  1. Toad를 시작합니다.

  2. Database 메뉴에서 Export|Generate Database Script를 선택합니다.

  3. 모든 탭에서 모든 설정을 지정하되(데이터베이스 스크립트 생성 참조) Execute를 누르지 않습니다.

  4. 대신에 도구 모음에서 Save All Settings to File 단추를 누릅니다. Save를 눌러 설정 정보를 저장합니다. 설정은 기본적으로 Toad 폴더에 저장되지만 사용자는 원하는 위치를 선택하여 저장할 수 있습니다.

파일 조정

위 절차의 결과로 얻어진 파일을 메모장이나 다른 텍스트 편집기를 사용하여 편집할 수 있습니다. 명령줄에서 사용할 수 있으려면 설정 파일에서 명령을 활성화하여 스크립트를 생성해야 합니다.

명령은 파일의 끝이나 시작 부분에 존재할 수 있으며 실행하려는 순서대로 되어 있어야 합니다. 사용자의 편리를 위해 사용 가능한 모든 명령이 설정 파일에 기록되어 주석으로 처리됩니다. 쉽게 주석을 제거하고 명령을 잘라내어 실행하려는 순서대로 붙여 넣을 수 있습니다. 또한 이러한 명령의 축약된 집합이 설정 파일 주석에 있습니다.

명령

각 명령은 표시된 대로 정확하게 입력해야 합니다(단, 대/소문자는 원하는 대로 입력할 수 있음). 명령의 앞뒤나 명령과 매개 변수 목록 사이에 공백이 허용되지 않습니다. 주석이나 파일의 끝 부분을 제외하고는 빈 줄이 파일에 있으면 안 됩니다.

  • CloseToad - 스크립트가 끝난 후에 Toad를 닫습니다.

  • CloseGDBS - 데이터베이스 스크립트 생성이 끝난 후에 Generate Database Script 창을 닫습니다.

  • # - 이 줄은 주석이며 무시됩니다.

명령 프롬프트에서 실행

하나의 스트립트만 생성

파일이 준비되면 명령줄에서 데이터베이스 스크립트 생성을 실행할 수 있습니다.

명령 프롬프트를 열고 명령줄을 입력합니다. 다음과 같은 형태여야 합니다.

Toad.exe CONNECT=system/manager@myOraDB COMP=c:\myfile.txt

주: Toad.exe가 있는 디렉토리와 동일한 디렉토리에 있어야 하며 그렇지 않을 경우에는 명령줄에 전체 경로 이름을 입력해야 합니다.

  • CONNECT 명령 다음의 문자는 사용자 ID와 Oracle 데이터베이스를 반영해야 합니다.

  • myfile.txt를 위에서 저장한 설정 파일의 이름으로 변경합니다.

여러 스크립트

Toad에서 둘 이상의 스크립트를 생성하려면 다음 명령줄로 Toad를 호출합니다.

Toad.exe CONNECT=system/manager@myOraDB CmdFile=c:\commandfile.txt

이 경우 commandfile.txt는 특정 명령을 포함하는 별개의 파일입니다. 이 파일은 다음과 같아야 합니다.

COMP=c:\script1.txt

COMP=c:\ script2.txt

COMP=c:\ script3.txt

CloseToad

여기에서 Script1.txt, Script2.txt 및 Script3.txt는 세 개의 개별 데이터베이스 스크립트 생성 설정 파일이며 Toad는 호출될 경우 이러한 파일에 정의된 세 개의 데이터베이스 스크립트를 생성합니다. 명령이 끝나면 Toad가 자동으로 닫힙니다.

주: 비교 설정 파일에 CLOSEToad 명령이 있는 경우에도 모든 스키마 스크립트가 생성될 때까지 Toad는 닫히지 않습니다.


명령줄에서 Generate Schema Script 실행

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Generate Schema Script를 실행하기 위해 파일을 작성하려면

  1. Toad를 시작합니다.

  2. Database 메뉴에서 Export|Generate Schema Script를 선택합니다.

  3. 모든 탭에서 모든 설정을 지정하되(Generate Schema Script 참조) Execute를 누르지 않습니다.

  4. 대신에 도구 모음에서 Save All Settings to File 단추를 누릅니다. Save를 눌러 설정 정보를 저장합니다. 설정은 기본적으로 Toad 폴더에 저장되지만 사용자는 원하는 위치를 선택하여 저장할 수 있습니다.

파일 조정

위 절차의 결과로 얻어진 파일을 메모장이나 다른 텍스트 편집기를 사용하여 편집할 수 있습니다. 명령줄에서 사용할 수 있으려면 설정 파일에서 명령을 활성화하여 스크립트를 생성해야 합니다.

명령은 파일의 끝이나 시작 부분에 존재할 수 있으며 실행하려는 순서대로 되어 있어야 합니다. 사용자의 편리를 위해 사용 가능한 모든 명령이 설정 파일에 기록되어 주석으로 처리됩니다. 쉽게 주석을 제거하고 명령을 잘라내어 실행하려는 순서대로 붙여 넣을 수 있습니다. 또한 이러한 명령의 축약된 집합이 설정 파일 주석에 있습니다.

명령

각 명령은 표시된 대로 정확하게 입력해야 합니다(단, 대/소문자는 원하는 대로 입력할 수 있음). 명령의 앞뒤나 명령과 매개 변수 목록 사이에 공백이 허용되지 않습니다. 주석이나 파일의 끝 부분을 제외하고는 빈 줄이 파일에 있으면 안 됩니다.

  • CloseToad - 스크립트가 끝난 후에 Toad를 닫습니다.

  • CloseGSS - 스키마 스크립트 생성이 끝난 후에 Generate Schema Script 창을 닫습니다.

  • # - 이 줄은 주석이며 무시됩니다.

명령 프롬프트에서 실행

하나의 스키마 스트립트만 생성

파일이 준비되면 명령줄에서 Generate Schema Script를 실행할 수 있습니다.

명령 프롬프트를 열고 명령줄을 입력합니다. 다음과 같은 형태여야 합니다.

Toad.exe CONNECT=system/manager@myOraDB COMP=c:\myfile.txt

주: Toad.exe가 있는 디렉토리와 동일한 디렉토리에 있어야 하며 그렇지 않을 경우에는 명령줄에 전체 경로 이름을 입력해야 합니다.

  • CONNECT 명령 다음의 문자는 사용자 ID와 Oracle 데이터베이스를 반영해야 합니다.

  • myfile.txt를 위에서 저장한 설정 파일의 이름으로 변경합니다.

여러 스키마 스크립트

Toad에서 둘 이상의 스크립트를 생성하려면 다음 명령줄로 Toad를 호출합니다.

Toad.exe CONNECT=system/manager@myOraDB CmdFile=c:\commandfile.txt

이 경우 commandfile.txt는 특정 명령을 포함하는 별개의 파일입니다. 이 파일은 다음과 같아야 합니다.

COMP=c:\script1.txt

COMP=c:\ script2.txt

COMP=c:\ script3.txt

CloseToad

여기에서 Script1.txt, Script2.txt 및 Script3.txt는 세 개의 개별 스키마 스크립트 생성 설정 파일이며 Toad는 호출될 경우 이러한 파일에 정의된 세 개의 스키마 스크립트를 생성합니다. 생성이 끝나면 Toad가 자동으로 닫힙니다.

주: 비교 설정 파일에 CLOSEToad 명령이 있는 경우에도 모든 스키마 스크립트가 생성될 때까지 Toad는 닫히지 않습니다.

관련 항목

Generate Schema Script

Source and Output

Object Types

Objects

Filters

Script Options


Health Check - 명령 프롬프트에서 실행

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

예기치 않은 변경 내용을 모니터링하기 위해 Health Check를 정기적으로 실행해야 할 수 있습니다. 약간의 준비를 하면 자리를 비울 때 명령 프롬프트에서 Health Check를 수행할 수 있습니다. 결과는 파일에 저장됩니다.

Health Check를 실행하기 위해 파일을 작성하려면

  1. Toad를 시작합니다.

  2. Database 메뉴에서 Diagnose|Health Check를 선택합니다.

  3. 비교를 수행하기 위한 모든 설정을 지정하되(Health Check 참조) Execute를 누르지 않습니다.

  4. 대신에 도구 모음에서 Save All Settings to File [image] 드롭다운을 누릅니다. Save Options to File을 선택합니다. Save를 눌러 설정 정보를 저장합니다. 설정은 기본적으로 Toad 폴더에 저장되지만 사용자는 원하는 위치를 선택하여 저장할 수 있습니다.

주: 또한 Options 탭을 마우스 오른쪽 단추로 누르고 Save Options to File을 선택하여 옵션을 파일에 저장할 수 있습니다.

파일 조정

위 절차의 결과로 얻어진 파일을 메모장이나 다른 텍스트 편집기를 사용하여 편집할 수 있습니다. 명령줄에서 사용할 수 있으려면 설정 파일에서 명령을 활성화하여 스크립트를 생성해야 합니다.

명령을 파일의 끝 부분이나 시작 부분에 둘 수 있습니다. 명령을 실행 순서대로 작성합니다. 사용자의 편리를 위해 사용 가능한 모든 명령이 설정 파일에 기록되어 주석으로 처리됩니다. 쉽게 주석을 제거하고 명령을 잘라내어 실행하려는 순서대로 붙여 넣을 수 있습니다. 또한 이러한 명령의 축약된 집합이 설정 파일 주석에 있습니다.

이 파일에서 하나 이상의 연결 정보 행이 부분적으로 주석 처리된 것을 볼 수 있습니다. 이러한 연결은 Toad를 열기 위해 명령줄에서 사용하는 연결과 관련이 없습니다. 이러한 연결 정보는 실행 중인 다양한 Health Check에 대한 것입니다. 주석 처리된 줄 부분은 암호화된 연결 정보에 포함되는 모든 정보를 포함하지는 않지만 어떠한 파일 부분이 어떠한 연결과 관계가 있는지 알 수 있는 방법을 제공합니다. 이러한 주석을 제거할 수 있지만 이러한 주석으로 연결 정보를 식별할 수 있습니다. 연결 정보를 변경해야 하고 암호화 여부가 중요하지 않은 경우 줄을 SELECTEDDB:USER/PASS@DB로 변경할 수 있습니다.

명령

각 명령은 표시된 대로 정확하게 입력해야 합니다(단, 대/소문자는 원하는 대로 입력할 수 있음). 명령의 앞뒤나 명령과 매개 변수 목록 사이에 공백이 허용되지 않습니다. 주석이나 파일의 끝 부분을 제외하고는 빈 줄이 파일에 있으면 안 됩니다.

  • CloseToad - 스크립트가 끝난 후에 Toad를 닫습니다.

  • CloseHealthCheck - Health Check가 끝난 후에 Health Check 창을 닫습니다.

  • # - 이 줄은 주석이며 무시됩니다.

명령 프롬프트에서 실행

파일이 준비되면 명령줄에서 비교를 실행할 수 있습니다.

명령 프롬프트를 열고 명령줄을 입력합니다. 다음과 같은 형태여야 합니다.

Toad.exe Connect=system/manager@mydb HC=c:\thisfile.txt

주: Toad.exe가 있는 디렉토리와 동일한 디렉토리에 있어야 하며 그렇지 않을 경우에는 명령줄에 전체 경로 이름을 입력해야 합니다.

  • CONNECT 명령 다음의 문자는 사용자 ID와 Oracle 데이터베이스를 반영해야 합니다.

  • thisfile.txt를 위에서 저장한 설정 파일의 이름으로 변경합니다.


명령 프롬프트에서 HTML Schema Generator 실행

저장한 파일을 사용하고 일부 수정하여 명령줄에서 HTML Schema Documentation Generator를 실행할 수 있습니다.

HTML Schema Generator를 실행할 파일을 구성하려면

  1. Toad를 시작합니다.

  2. Tools 메뉴에서 HTML Schema Generator를 선택합니다.

  3. 문서를 생성할 모든 설정을 만듭니다(HTML Schema Doc Generator 참조).

  4. 대신 Save Settings to File 단추를 누릅니다. Save file 대화상자가 나타납니다. Save를 눌러 설정 정보를 저장합니다.

파일 조정

위의 절차로 인한 파일을 Notepad 또는 기타 텍스트 편집기로 편집할 수 있습니다. 명령은 명령줄에서 사용할 수 있도록 설정 파일에서 활성화하여 스크립트로 만들어야 합니다.

명령은 파일의 시작 또는 끝에 원하는 실행 순서대로 배치할 수 있습니다. 편리하게 사용할 수 있도록 사용 가능한 명령은 모두 설정 파일에 기록되고 설명이 삽입됩니다. 설명을 쉽게 삭제할 수 있으며 원하는 실행 순서대로 명령을 잘라 붙여 넣을 수 있습니다. 이러한 간략한 지침 세트는 설정 파일 설명에도 있습니다.

명령

  • CreateHTMLDocumentation('c:\HTMLDir\index.htm') - 이 명령은 생성 과정을 시작합니다. "c:\HTMLDir\index.htm"은 대상 파일 경로이며 변경할 수 있습니다.

  • CloseHTML - 이 명령은 Toad 내의 HTML Schema Doc Generation 창을 닫습니다.

  • CloseToad - 이 명령은 프로세스가 완료된 후 Toad를 닫습니다.

  • # - 이것은 설명이며 명령 파일이 실행될 때 무시됩니다.

명령 프롬프트에서 실행

파일이 준비되면 명령 프롬프트에서 HTML Schema Generator를 실행할 수 있습니다.

명령 프롬프트를 열고 명령줄을 입력합니다. 다음과 유사하게 표시되어야 합니다.

Toad.exe CONNECT=SYSTEM/manager@mydb GENHTML=c:\thisfile.txt

주: Toad.exe가 위치한 동일한 디렉토리에 있거나 명령줄에서 전체 경로 이름을 입력해야 합니다.

  • CONNECT 명령 후의 문자는 사용자 ID 및 Oracle 데이터베이스를 반영해야 합니다.

  • C:\THISFILE.TXT를 설정 파일의 경로 및 파일 이름으로 바꿉니다.


명령 프롬프트에서 색인 재구성 실행

명령 프롬프트에서 개체 재구성 실행

정기적으로 색인 또는 표를 재구성하거나 작업하지 않는 동안 재구성될 수 있도록 설정할 수 있습니다. 약간의 준비만 하면 명령 프롬프트에서 색인을 재구성할 수 있습니다. 명령을 배치 파일로 저장할 경우 NT Scheduler로 배치 파일을 스케줄링하여 자리에 없을 때 실행합니다. 결과는 파일로 저장됩니다.

명령 프롬프트에서 색인을 점검 및 재구성할 수 있습니다.

파일을 구성하여 Rebuild Multiple Objects를 실행하려면

  1. Toad를 시작합니다.

  2. Database|Optimize 메뉴에서 Rebuild Multiple Objects을 선택합니다.

  3. 모든 설정을 비교 작업을 수행할 수 있도록 만듭니다(색인 재구성 참조). 그러나 Rebuild 또는 Examine 색인을 누르지 마십시오.

  4. 대신, Options 탭 중 하나의 도구 모음에서 Save All Settings to File 단추를 누릅니다. Save file 대화상자가 나타납니다. Save를 눌러 설정 정보를 저장합니다. 기본값으로 설정이 Toad 폴더에 저장되지만 선택하는 위치에 따라 저장할 수 있습니다.

파일 조정

위의 절차로 인한 파일을 Notepad 또는 기타 텍스트 편집기로 편집할 수 있습니다. 명령은 명령줄에서 사용할 수 있도록 설정 파일에서 활성화하여 스크립트로 만들어야 합니다.

명령은 파일의 시작 또는 끝에 원하는 실행 순서대로 배치할 수 있습니다. 편리하게 사용할 수 있도록 사용 가능한 명령은 모두 설정 파일에 기록되고 설명이 삽입됩니다. 설명을 쉽게 삭제할 수 있으며 원하는 실행 순서대로 명령을 잘라 붙여 넣을 수 있습니다. 이러한 간략한 지침 세트는 설정 파일 설명에도 있습니다.

수행할 동작에 대한 설정 파일의 모든 명령줄에 설명을 없앱니다. 따옴표 안의 모든 파일 이름 및 항목은 편집할 수 있습니다. 한 줄당 하나 이상의 명령을 입력하지 마십시오. 명령 앞에 공백을 두지 마십시오. 전자 메일 설정은 View|Toad Options|Email Settings에서 찾을 수 있습니다.

명령은 설정 파일에 표시된 대로 논리적 순서로 실행됩니다. 색인을 재구성하기 전에 로드해야 합니다.

설명

#로 시작하는 파일의 모든 줄은 설명이며, 이 줄에 포함된 명령은 수행되지 않습니다. 명령을 활성화하려면 #을 삭제합니다.

눈금 로드 명령

  • LoadUserIndexes('USERA', 'USERB', 'USERC') - 이 명령은 특정 사용자에 대한 User 색인을 로드합니다. 사용자를 필요한 만큼 변경, 삭제 및 추가합니다.

  • LoadTableIndexes(TABLEOWNER='USERA')(TABLES='TABA', 'TABB','TABC') - 이 명령은 특정 표에 대한 색인을 로드합니다. 표 이름을 필요한 만큼 변경, 삭제 및 추가합니다. 표 소유자 및 표를 반드시 지정해야 합니다.

  • LoadTablespaceIndexes('TABLESPACEA', 'TABLESPACEB') - 이 명령은 표 공간 색인을 로드합니다. 표 공간 이름 필요한 만큼 변경, 삭제 및 추가합니다.

  • LoadUserTables(‘USERA’, ‘USERB’, ‘USERC’) - 이 명령은 특정 사용자에 대한 User 표를 로드합니다. 사용자를 필요한 만큼 변경, 삭제 및 추가합니다.

  • LoadTablespaceTables(‘TABLESPACEA’, ‘TABLESPACEB’, TABLESPACEC’) - 이 명령은 표 공간 표를 로드합니다. 표 공간 이름 필요한 만큼 변경, 삭제 및 추가합니다.

  • ImporTablestFromText('c:\MyTextFile.txt') - 이 명령을 사용하여 이전에 저장한 텍스트 파일의 표 목록에 대한 설정을 가져올 수 있습니다. 경로 및 파일 이름을 편집할 수 있습니다.

  • ImportTablesFromBinary('c:\MyBinaryFile.bin'); - 이 명령을 사용하여 이전에 저장한 이진 파일의 표 목록에 대한 설정을 가져올 수 있습니다. 경로 및 파일 이름을 편집할 수 있습니다.

  • ImporIndexesFromText('c:\MyTextFile.txt') - 이 명령을 사용하여 이전에 저장한 텍스트 파일의 색인 목록에 대한 설정을 가져올 수 있습니다. 경로 및 파일 이름을 편집할 수 있습니다.

  • ImportIndexesFromBinary('c:\MyBinaryFile.bin'); - 이 명령을 사용하여 이전에 저장한 이진 파일의 색인 목록에 대한 설정을 가져올 수 있습니다. 경로 및 파일 이름을 편집할 수 있습니다.

다시 로드 명령

  • ReloadAllIndexes - 이 명령은 현재 로드한 색인의 정보를 다시 로드합니다. 텍스트 또는 이진 파일에서 색인을 로드한 후 모든 정보가 최신인지 확인하기 위해 사용할 수 있습니다.

  • ReloadAllTables - 이 명령은 현재 로드한 표의 정보를 다시 로드합니다. 텍스트 또는 이진 파일에서 표를 로드한 후 모든 정보가 최신인지 확인하기 위해 사용할 수 있습니다.

모두 재구성 또는 검사할 표/색인 선택 명령

  • CheckAllIndexes - 이 명령은 모든 색인을 체크 표시합니다. 아래에 설명된 대로 …Selected 명령과 함께 사용됩니다.

  • CheckAllTables - 이 명령은 모든 표를 체크 표시합니다. 아래에 설명된 대로 …Selected 명령과 함께 사용됩니다.

  • CheckUnusable - 이 명령은 Unusable로 체크 표시된 상태의 색인 및 표를 표시합니다. 아래에 설명된 대로 …Selected 명령과 함께 사용됩니다.

  • RemoveIndexConsiderationFailures - 이 명령은 Thresholds 및 Performance Options 탭의 Consider Indexes for Rebuild Only If 섹션 아래의 설정을 확인합니다. 구성된 설정에 부합하지 않는 목록에서 색인을 삭제합니다. 이 명령을 사용하여 여러 범위를 가지고 있지 않거나 작은 색인을 제외합니다.

  • RemoveTableConsiderationFailures - 이 명령은 Thresholds 및 Performance Options 탭 섹션의 표에 대한 Conditional Threshold 설정을 확인합니다. 구성된 설정에 부합하지 않는 목록에서 표를 삭제합니다. 이 명령을 사용하여 여러 범위를 가지고 있지 않거나 작은 표를 제외합니다.

표시된 색인 재구성 또는 검사 명령

  • ExamineSelectedIndexes - 이 명령은 선택된 색인을 모두 검사하고 재구성하도록 권장되어 있는지 표시합니다. RebuildRecommended 명령이 수행되기 전에 수행해야 합니다.

  • RebuildRecommendedIndexes - 이 명령은 Examine 명령에 의해 Rebuild Recommended로 표시된 색인을 모두 재구성합니다.

  • RebuildSelectedIndexes - 이 명령은 재구성 권장 여부와 상관 없이 표시된 색인을 모두 재구성합니다.

  • RebuildSelectedTables - 이 명령은 표시된 표를 모두 재구성합니다.

사용 결과

명령 그룹은 결과를 파일 또는 전자 메일로 보낼 때 사용합니다.

주: 결과를 전자 메일로 보낼 수 있는 화면 옵션이 있습니다. 이 옵션은 설정 파일에 포함되어 있으므로 표시되어 있을 경우 명령줄에서 설정이 실행되어도 결과가 전자 메일로 전송됩니다. 자세한 내용은 전자 메일 알림 - 다중 색인 재구성을 참조하십시오.

  • ExportIndexesToHtml('c:\MyHTMLFile.htm') - 이 명령은 색인 재구성 또는 검사 명령의 결과를 HTML 파일로 내보냅니다. 경로 및 파일 이름은 편집할 수 있습니다.

  • ExportIndexesToExcel('c:\MyExcelFile.xls') - 이 명령은 색인 재구성 또는 검사 명령의 결과를 Excel 파일로 내보냅니다. 경로 및 파일 이름은 편집할 수 있습니다.

  • ExportIndexesToText('c:\MyTextFile.txt') - 이 명령은 색인 재구성 또는 검사 명령의 결과를 텍스트 파일로 내보냅니다. 경로 및 파일 이름은 편집할 수 있습니다.

  • ExportIndexesToBinary('c:\MyBinaryFile.bin') - 이 명령은 색인 재구성 또는 검사 명령의 결과를 이진 파일로 내보냅니다. 경로 및 파일 이름은 편집할 수 있습니다.

  • ExportTablesToHtml('c:\MyHTMLFile.htm') - 이 명령은 표 재구성 명령의 결과를 HTML 파일로 내보냅니다. 경로 및 파일 이름은 편집할 수 있습니다.

  • ExportTablesToExcel('c:\MyExcelFile.xls') - 이 명령은 표 재구성 명령의 결과를 Excel 파일로 내보냅니다. 경로 및 파일 이름은 편집할 수 있습니다.

  • ExportTablesToText('c:\MyTextFile.txt') - 이 명령은 표 재구성 명령의 결과를 텍스트 파일로 내보냅니다. 경로 및 파일 이름은 편집할 수 있습니다.

  • ExportTablesToBinary('c:\MyBinaryFile.bin') - 이 명령은 표 재구성 명령의 결과를 이진 파일로 내보냅니다. 경로 및 파일 이름은 편집할 수 있습니다.

닫기

  • CloseRMO - 이 명령은 이전 명령이 완료된 후 Rebuild Multiple Indexes 페이지를 닫습니다.

  • CloseToad - 이 명령은 모든 명령줄 동작이 완료된 후 Toad를 닫습니다.

뒤로 호환 가능한 명령

이전 Toad 버전으로 작성된 설정 파일을 사용 중인 경우 다음 명령만 색인에 적용됩니다. Quest Software, Inc.에서는 사용 가능한 최신 명령을 사용하도록 강력히 권장합니다.

  • ImportFromText('c:\MyTextFile.txt')

  • ImportFromBinary('c:\MyBinaryFile.bin')

  • ExportToHtml('c:\MyHTMLFile.htm')

  • ExportToExcel('c:\MyExcelFile.xls')

  • ExportToText('c:\MyTextFile.txt')

  • ExportToBinary('c:\MyBinaryFile.bin')

  • ReloadAll

  • CheckAll

  • CheckUnusable

  • RemoveConsiderationFailures

  • ExamineSelected

  • RebuildRecommended

  • RebuildSelectedInds

  • CloseRMI

명령 프롬프트에서 실행

설정 파일이 하나만 있을 경우

파일이 준비되면 명령줄에서 파일을 검사/재구성할 수 있습니다.

명령 프롬프트를 열고 명령줄을 입력합니다. 다음과 유사하게 표시되어야 합니다.

Toad.exe Connect=system/manager@mydb RMI=c:\thisfile.txt

주: Toad.exe가 위치한 동일한 디렉토리에 있거나 명령줄에서 전체 경로 이름을 입력해야 합니다.

  • CONNECT 명령 후의 문자는 사용자 ID 및 Oracle 데이터베이스를 반영해야 합니다.

  • thisfile.txt를 위에 저장한 설정 파일의 이름으로 변경합니다.

설정 파일이 여러 개일 경우

이 명령줄로 Toad를 호출하여 명령 파일에서 Rebuild Multiple Indexes 기능을 실행할 수 있습니다.

Toad.exe CONNECT=system/manager@myOraDB CmdFile=c:\commandfile.txt

또한 명령 파일에서 다음과 같이 색인 재구성을 호출할 수도 있습니다.

c:\toad\Toad.exe Connect=system/manager@mydb CMDFILE=c:\mycommandfile.txt

이러한 경우 mycommandfile.txt는 특정 명령이 포함된 별도의 파일이 됩니다. 색인 재구성을 두 번 실행하고 스키마를 비교한 다음 일부 html 스키마 설명서를 구성할 경우 파일이 다음과 같을 수 있습니다.

RMI=c:\rebuild1.txt

RMI=c:\rebuild2.txt

COMP=c:\schemacomp1.txt

GENHTML=c:\html1.txt

여기서 rebuild1.txt 및 rebuild2.txt는 색인 재구성입니다. Schemacomp1.txt는 스키마 비교 설정 파일입니다. Toad가 호출되면 이러한 파일에 의해 정의된 색인 검사/재구성을 두 번 실행하고 스키마를 비교한 다음 HTML 파일을 작성합니다. 비교가 완료되면 Toad가 스스로 닫힙니다.

주: 설정 파일에 CLOSEToad 명령이 있어도 Toad는 명령 파일의 모든 명령이 실행될 때까지 닫히지 않습니다.


명령 프롬프트에서 다른 스키마로 복사 실행

다른 스키마로 데이터 복사를 실행할 파일 작성

  1. Toad를 시작합니다.

  2. Schema Browser, Tables 페이지에서 하나 이상의 테이블을 선택하고 마우스 오른쪽 단추를 누릅니다.

  3. 메뉴에서 Copy data to another Schema를 선택합니다.

  4. 모든 탭에서 모든 설정을 수행하되(Copy Data to another Schema 참조), Execute는 누르지 않습니다.

  5. 대신 도구 모음에서 Save All Settings to File 단추를 누릅니다. Save file 대화 상자가 나타납니다. Save를 눌러 설정 정보를 저장합니다. 설정은 기본적으로 Toad 폴더에 저장되지만 선택한 위치에 저장할 수도 있습니다.

파일 조정

위 절차의 결과로 작성된 파일은 메모장이나 다른 텍스트 편집기를 사용하여 편집할 수 있습니다. 명령줄에서 사용하려면 설정 파일에서 명령을 활성화하여 스크립트를 구성해야 합니다.

명령은 파일의 끝이나 시작 부분에 있을 수 있으며 실행할 순서대로 되어 있어야 합니다. 편의상 사용 가능한 모든 명령이 설정 파일에 쓰여져 주석으로 처리되어 있습니다. 손쉽게 주석을 제거하고 명령을 잘라내어 실행할 순서대로 붙여넣을 수 있습니다. 이러한 명령의 축약된 집합이 설정 파일 주석에도 있습니다.

이 파일을 편집할 수 있지만 다음과 같은 규칙을 지켜야 합니다.

  1. 소스 테이블이 여러 스키마에서 온 경우에는 DestSchemaName 줄을 주석으로 처리해야 합니다. 소스 테이블이 모두 한 스키마에서 온 경우에는 이 줄이 필요하기 때문에 주석으로 처리하지 말아야 합니다.

  2. 필요한 경우 DestSchemaName은 연결 정보 뒤에 지정해야 합니다.

  3. WHERE 절에서 줄 바꿈은 {NL}로 표시해야 합니다. 이 줄 바꿈 표현을 따르지 않으면 'where' 절의 일부가 무시됩니다.

명령 프롬프트에서 실행

파일이 준비되면 명령 프롬프트에서 저장을 실행할 수 있습니다.

명령 프롬프트를 열고 명령줄을 입력합니다. 다음과 비슷해야 합니다.

c:\toad\Toad.exe Connect=system/manager@mydb DATACOPY=c:\thisfile.txt

Toad의 경로와 연결 정보는 다를 수 있습니다. 'c:\thisfile.txt'는 작성한 파일을 나타냅니다.


명령줄에서 표, 보기, SQL 질의 내보내기

명령줄 프롬프트에서 표, 보기 및 SQL 질의를 내보낼 수 있습니다.

명령 파일 구성

명령줄에서 내보내기 명령을 실행하기 전에 명령 파일을 구성해야 합니다.

표 및 보기를 내보내려면

  1. Schema Browser에서 내보낼 Table 또는 View를 선택하고 마우스 오른쪽 단추를 누른 다음 메뉴에서 Save As를 선택합니다. Save Table/View 대화상자가 나타납니다.

  2. 내보낸 파일이 포함할 설정을 선택하고 Destination Directory 상자에서 디렉토리 이름을 입력합니다.

  3. Save Settings to File [image] 단추를 누릅니다.

SQL 질의를 내보내려면

  1. Editor에서 Save Grid Contents 대화상자를 엽니다.

  2. 내보낸 파일이 포함할 설정을 선택하고 Save to File 상자에서 파일 이름 및 경로를 입력합니다.

  3. Save Settings to File 단추( [image])를 누릅니다.

명령 파일 조정

생성된 설정 파일을 확인하고 필요하면 변경해야 합니다. 기본 지침이 생성된 설정 파일에 포함됩니다. 명령 및 형식에 대한 보다 자세한 내용은 아래에 설명되어 있습니다.

내보내기용 명령 파일은 간단한 텍스트 파일입니다. 파일에는 설정 명령 및 동작 명령의 두 가지 종류의 명령이 있습니다(명령 참조). 각 명령은 필요한 만큼 반복할 수 있습니다.

설정 명령을 반복하면 해당 설정 값이 변경됩니다. 동작 명령은 내보낼 표, 보기 및 질의를 내보내는 데 필요한 만큼 반복할 수 있습니다. 즉, 모든 형식 조합 및 출력 디렉토리에서 표, 보기 및 질의를 내보낼 수 있습니다.

파일은 공백 행을 포함할 수 있습니다. 이렇게 하면 나중에 보다 읽기 쉬워집니다. Single Line Comments(#로 표시)는 BEGINQRY 및 ENDQRY 명령 사이를 제외하고 파일의 아무 곳에나 위치할 수 있습니다.

표 및 보기는 이에 맞는 이름의 파일로 내보내지며 명령 파일 구성에서 지정한 디렉토리로 배치됩니다. 특정 출력 디렉토리 또는 파일이 없으면 생성됩니다.

명령 프롬프트에서 실행

주: 명령 파일이 Toad를 시작하기 때문에 명령 프롬프트에서 이를 실행하기 전에 Toad를 닫아야 합니다.

직접 옵션

c:\toad\Toad.exe connect=system/manager@myoradb EXP=c:\exp_file.txt

여기서 exp_file.txt는 내보내기 명령 및 설정을 포함하는 파일입니다..

명령 파일 옵션

c:\toad\Toad.exe connect=system/manager@myoradb CMDFILE=c:\command_file.txt

여기서 command_file.txt는 다음과 같은 직접 옵션과 유사한 행을 포함하는 파일입니다.

EXP=c:\exp_file.txt

이 옵션을 사용하여 다른 내보내기 설정 파일로 여러 내보내기를 수행할 수 있으며 Toad에서 명령줄에서 사용할 수 있는 다른 작업(스키마 비교, 스키마 스크립트 생성, html 스키마 설명서 생성, 건강 검진 실행 또는 색인 재구성 등)을 수행할 수도 있습니다.

이 옵션 중 하나를 사용하여 경로, 연결 정보 및 파일 이름이 달라집니다.

오류

오류는 남은 내보내기 작업을 중지하지 않습니다. 오류가 발생할 경우 Toad의 시작 디렉토리에 ToadError.log라는 파일에 기록됩니다.


명령

설정 명령

명령 | 설명 | 수용 가능한 값 | 기본값 | 예제
FORMAT | 내보내기 형식 정의 | Ascii, DelimTab, DelimOther, HTML, XLS, XML, INSERTS, SQLLDR | Ascii | FORMAT=XLS
QUOTES | 문자열을 따옴표에 넣습니까? | 예 또는 아니오 | 아니오 | QUOTES=YES
COLUMNS | 열 이름을 포함합니까? | 예 또는 아니오 | 아니오 | COLUMNS=YES
COMPRESS | 파일을 .zip 형식으로 압축된 상태로 둠 | 예 또는 아니오 | 아니오 | COMPRESS=YES
NULLS | Null 텍스트를 포함합니까? (삽입, ascii 및 구분 기호 내보내기) | 예 또는 아니오 | 아니오 | NULLS=YES
DELIMCHAR | DelimOther 형식에 대한 구분 기호 문자 | 공백을 제외한 모든 문자 | 탭 | DELIMCHAR=!
DELIMINT | DelimOther 형식에 대한 구분 기호 문자 숫자 값 | 모든 정수 값 | 9 (9=TAB) | DELIMINT=134
OUTPUTDIR | 표 및 보기를 위한 대상 디렉토리 | PC의 모든 유효한 디렉토리 | ‘start in’ 디렉토리 | OUTPUTDIR=c:\exports\
INSERTTABLE | 삽입 구문 및 SQL*Loader에 사용되는 표 이름 지정 | 표 이름으로 사용할 수 있는 모든 문자열 | 없음 | INSERTTABLE=EMP
INSERTOWNER | 삽입 구문 및 SQL*Loader에 사용되는 스키마 소유자 지정 | 스키마 이름으로 사용할 수 있는 모든 문자열 | 없음 | INSERTOWNER=SCOTT
FIELDSEP | SQL*Loader만 해당. 상자를 구분할 문자 지정 | 모든 문자열 값 | ; | FIELDSEP=!~!
STRENCLOSE | SQL*Loader만 해당. 문자열 필드 넣기에 사용되는 문자 지정 | 모든 문자열 값 | " | STRENCLOSE=""
SQLLDRMODE | SQL*Loader만 해당. 삽입 모드를 지정합니다. | APPEND, INSERT, REPLACE 또는 TRUNCATE | TRUNCATE | SQLLDRMODE=INSERT
OWNER | 삽입 기호로 스키마 이름을 지정합니까? | 예 또는 아니오 | 예 | OWNER=YES
COMMIT | 삽입 구문 간격 실행 | 모든 정수 | 없음 | COMMIT=1000

주:

  • 구문 또는 SQL*Loader 파일로 삽입할 질의를 내보낼 때 삽입 중의 표는 INSERTTABLE로 지정되어야 합니다(INSERTOWNER은 선택 사항). 표 또는 보기에서 삽입 구문으로 내보낼 때 삽입 구문은 추출되었던 표 또는 보기로 삽입되므로 표 이름을 지정할 필요는 없습니다.

  • 실행 간격이 지정되지 않을 경우 전혀 실행되지 않습니다. 스크립트 끝에서 실행하도록 지정하려면 COMMIT=0을 사용합니다. 모든 간격에서 실행하도록 지정하려면 COMMIT=n을 사용합니다. 여기서 n은 간격입니다.

  • DELIMOTHER 형식에 구분 기호 문자를 지정해야 할 경우 DELIMCHAR 또는 DELIMINT를 사용할 수 있으며 Toad의 ‘Grid-Save as’ 화면과 동일한 값을 설정하므로 둘 다 지정할 필요가 없습니다.

  • INSOWNER=something을 지정하면 이전의 OWNER=NO가 무시됩니다. INSOWNER를 지정하지 않고 OWNER=YES를 지정하면 INSOWNER=login user id가 생겨납니다.

한 줄 동작 명령

명령 | 설명 | 수용 가능한 값 | 예제
CLOSEToad | 명령줄 동작 후 Toad 종료 |  | CLOSEToad
SCHEMATABLES | 스키마의 모든 표 내보내기 | 모든 스키마 이름 | SCHEMATABLES=SCOTT
SCHEMAVIEWS | 스키마의 모든 보기 내보내기 | 모든 스키마 이름 | SCHEMAVIEWS=SCOTT
TABLE | 하나의 표 내보내기 | 모든 표 이름 | TABLE=SYS.TAB$
VIEW | 하나의 보기 내보내기 | 모든 보기 이름 | VIEW=SYS.DBA_TABLES

여러 줄 동작 명령

여러 줄 동작 명령은 하나만 있습니다. 입력할 수 있는 질의를 내보내는 명령입니다.

주의: 질의 끝에 세미콜론 또는 슬래시를 삽입하지 마십시오.

이 동작은 다음과 같이 이루어집니다.

BEGINQRY fully_qualified_destination_file_name

질의 텍스트가 여기에 삽입됩니다.

필요한 만큼 여러 줄을 사용합니다.

ENDQRY


예제 파일

이 파일을 실행하기 전에 텍스트 파일로 저장한 다음 명령 프롬프트에서 실행에 설명된 대로 Toad를 닫습니다.

예제 파일은 다음과 같습니다.

  1. 명령줄 동작이 완료되면 Toad를 닫습니다.

  2. SCOTT의 표를 d:\temp\scott로 HTML 형식으로 내보냅니다.

  3. SYSTEM의 보기를 d:\temp\system으로 XLS 형식으로 내보냅니다.

  4. SYS.TAB$ 및 USER_TABLES를 d:\temp\misc로 HTML 형식으로 내보냅니다.

  5. 스크립트를 MYCONS라는 표의 삽입 데이터로 내보냅니다.

  6. DELIMCHAR을 지정합니다. 그러나 DELIMOTHER 형식이 사용되지 않으므로 필요하지 않습니다.

  7. TEST_SCHEMA 표를 SQL*Loader 파일로 내보냅니다.

예제 파일

CLOSEToad

FORMAT=HTML

COLUMNS=YES

QUOTES=NO

NULLS=NO

DELIMCHAR=@

OUTPUTDIR=D:\TEMP\SCOTT

SCHEMATABLES=SCOTT

FORMAT=XLS

OUTPUTDIR=D:\TEMP\SYSTEM

SCHEMAVIEWS=SYSTEM

FORMAT=HTML

OUTPUTDIR=D:\TEMP\MISC

TABLE=SYS.TAB$

VIEW=USER_TABLES

FORMAT=INSERTS

OWNER=NO

COMMIT=100

INSERTTABLE=MYCONS

BEGINQRY D:\TEMP\QRY\mycons.sql

select * from user_constraints

ENDQRY

FORMAT=SQLLDR

OUTPUTDIR=D:\TEMP\LDR

SQLLDRMODE=TRUNCATE

SCHEMATABLES=TEST_SCHEMA


QSR을 사용하여 코드 실행

Quest ScriptRunner를 사용하여 여러 방법으로 스크립트를 실행할 수 있습니다.

  • Editor 메뉴에서 Execute SQL via QSR을 선택합니다.

  • 메뉴의 Execute 도구 모음에서 Execute|Execute SQL via QSR을 선택합니다.

  • set parameters 창에서 QSR 단추를 누릅니다.


파일 저장

현재 파일을 저장합니다. 이름을 선택하지 않은 경우 Save As 창이 열리고, 여기서 이름을 선택하거나 입력할 수 있습니다.

파일을 저장하려면

  • File 메뉴에서 Save를 선택합니다.


Save As 대화상자

이 대화상자에서 Editor 코드의 출력 파일을 선택할 수 있습니다.

대상 파일이 읽기 전용 파일 시스템 특성으로 표시되어 있으면 Toad가 해당 파일로 Editor 코드를 저장할 수 없게 됩니다. 다른 파일을 선택합니다.

주: Save Grid contents 명령을 사용하여 데이터 결과 눈금의 내용을 저장할 수도 있습니다.

Save As를 액세스하려면

  • File|Save As 메뉴 항목을 선택합니다.


File: Reopen File

파일 다시 열기

파일을 다시 열면 이전에 연 마지막 10개의 파일을 모두 열 수 있습니다.

파일을 다시 열려면

  1. Editor를 엽니다.

  2. File 메뉴에서 Reopen File을 선택합니다.

Toad는 이전에 연 마지막 10개의 파일 목록을 표시합니다. 이 목록은 Toad의 Oracle\Temps 폴더에 있는 SQLFILES.TXT 파일에 저장 및 복원됩니다.


파일 이름 바꾸기

이 창은 FTP 인터페이스의 파일 이름을 바꿉니다.

FTP에 대한 자세한 내용은 FTP를 참조하십시오.

Rename File을 액세스하려면

  • Toad FTP 창에서 이 창을 열 수 있습니다.


File: Print

인쇄

이 메뉴는 인쇄 명령을 프린터에 전송합니다.

File|Print는 SyntaxMemo 컨트롤이 현재 사용 중일 경우 모든 Toad 창에서 작동합니다. 예: Schema Browser, Tables 탭, Scripts 탭. 결과 스크립트를 누르고 File|Print를 선택합니다. 표 스크립트가 프린터에 전송됩니다.

주: Toad Freeware에서 File > Print는 SQL Edit 및 Proc Edit 창에서만 작동합니다.


File: Print Setup

Page Setup 창을 액세스하려면

  • File|Print Setup을 누릅니다.

  • 드롭다운에서 종이 크기 및 원본을 선택할 수 있습니다.

  • 라디오 단추를 사용하여 방향을 선택할 수 있습니다. 기본값은 세로입니다.

  • 여백을 변경할 수도 있습니다.

  • Printer 단추는 Printers, Properties 등을 선택할 수 있는 창을 표시합니다.


Edit: Undo

Edit|Undo 명령은 마지막 키 입력 내용을 취소합니다.


Edit: Redo

Edit|Redo 명령은 마지막으로 취소한 작업을 반복합니다.


Edit: Popup Menu

Edit|Popup Menu 항목을 눌러 관련 팝업 메뉴(마우스 오른쪽 메뉴)를 표시합니다.

Editor를 사용하는 동안 마우스 오른쪽 단추를 눌러 이 메뉴를 액세스할 수도 있습니다.

관련 항목

힌트 및 팁: 오른쪽 마우스 단추


Edit: Toggle Fullscreen Editor

Edit|Toggle Fullscreen Editor(Editor를 사용하는 동안)를 눌러 분할 화면 편집/결과 창과 전체 화면 편집 창을 전환합니다. 또한 <F2> 키를 눌러 전체 화면 편집기를 전환할 수 있습니다.


Edit: Swap This/Prev Lines

Edit| Swap This/Prev Lines 메뉴 항목은 커서가 SQL 스크립트에 있는 줄과 이전 줄을 전환합니다.

예를 들어, 커서가 줄 8에 있는 경우 전환하면 줄 8의 내용은 줄 7이 되고 줄 7의 내용은 줄 8이 됩니다.


Edit: Comment Block 및 Uncomment Block

Comment Block 및 Uncomment Block 명령은 Editor에 적용됩니다. SQL 스크립트 섹션에 설명을 넣으려면 블럭을 선택한 다음 Edit|Comment Block 메뉴 항목을 누릅니다. 이제 선택한 내용이 설명으로 나타납니다. 섹션에 설명을 없애려면 블럭을 선택한 다음 Edit|Uncomment Block 메뉴 항목을 누릅니다.

Comment Block 및 Uncomment Block 명령은 SQL Editor의 마우스 오른쪽 단추 메뉴에서도 사용할 수 있습니다.


Edit: Upper Case 및 Lower Case

선택한 텍스트 블럭의 대소문자를 변경할 수 있습니다.

  • Upper Case로 선택을 변경하려면 Edit|Upper Case 메뉴 항목을 누르거나 <CTRL> <U>를 누릅니다.

  • Lower Case로 선택을 변경하려면 Edit| Lower Case 메뉴 항목을 누르거나 <CTRL> <L>을 누릅니다.

Editor Options, 강조표시 메뉴, 대문자 효과 드롭다운에서 설정한 대문자 효과는 Upper Case 및 Lower Case 변환을 무시할 수 있습니다.


Edit: Columns Dropdown

Columns Dropdown은 코드에 포함할 열을 선택할 수 있는 선택된 표에서 열 목록을 표시합니다.

열 드롭다운을 활성화하려면

  • 표 이름에 커서를 둔 다음 Edit|Pick List Dropdown을 누릅니다.

또는

<CTRL><T>를 누릅니다.


Edit: Describe

설명

선택한 개체를 설명하는 팝업 창이 표시됩니다. 항목이 프로시저일 경우 프로시저 팝업 창에 표시됩니다.

설명을 사용하려면

  • Schema Browser, Object Palette 또는 Editor 창에서 개체를 선택합니다.

  • 다음 작업 중 하나를 수행하십시오.

  • Edit 메뉴에서 Describe를 선택합니다.

  • <F4>를 누릅니다.

  • 마우스 오른쪽 단추를 누르고 Describe를 선택합니다.

관련 항목

힌트 및 팁: 오른쪽 마우스 단추


찾기

이 대화상자를 사용하여 Editor 창 또는 Procedure Edit 창에서 키워드 또는 구문을 입력하여 검색할 수 있습니다.

대소문자 구분, 전체 단어 찾기, 정규식 사용 및 버퍼에서 앞 또는 뒤쪽 검색에 대한 옵션이 있습니다.

Find 대화상자를 열기 전에 텍스트가 강조표시되어 있으면 해당 텍스트는 Text to Find 데이터 입력 상자에 배치됩니다. 강조표시된 텍스트가 없으면 커서에 있는 단어가 Text to Find 데이터 입력 상자에 배치됩니다. 마지막 n 찾기 항목은 드롭다운 목록에서 사용할 수 있습니다. Toad 세션에서 Toad 세션으로 저장되지 않습니다.

<CTRL>V를 사용하여 다른 텍스트를 복사하여 Find 대화상자에 붙여 넣을 수도 있습니다.

Find 단추가 도구 모음에 없어도 창에서 사용할 수 있습니다. 이러한 경우 키보드에서 <CTRL>F를 사용하여 이 기능을 사용할 수 있습니다.

Find 상자를 열려면

  • Edit|Find 메뉴 항목을 사용하여 이 대화상자를 엽니다.

또는

편집 도구 모음의 Find 단추

또는

<CTRL>F 바로 가기를 사용할 수도 있습니다.


파일에서 찾기

Toad에서는 원하는 텍스트가 포함된 파일을 찾기 위해 파일 내를 검색할 수 있습니다.

파일에서 찾으려면

  1. Search 메뉴에서 Find in files를 선택합니다.

  2. 찾으려는 텍스트를 입력합니다.

  3. 옵션을 선택하거나 선택 취소합니다.

  4. File mask 상자에서 검색할 디렉토리를 선택합니다.

  5. 하위 디렉토리를 포함하려면 Include subdirectories 상자를 선택합니다.

  6. OK를 눌러 파일에서 검색합니다.

옵션

Case sensitive

대/소문자를 구분하여 단어를 검색하려면 이 옵션을 선택합니다. 예를 들어 sql의 반대는 SQL입니다.

Whole words

전체 단어만 검색하려면 이 옵션을 선택합니다. 이 옵션은 다른 단어 내에 포함될 수 있는 단어를 구별하도록 지정합니다. 예를 들어 "finding"이 아니라 "find" 단어만 찾을 수 있습니다.

Regular Expressions

정규식을 사용하여 검색하려면 이 옵션을 선택합니다. text to find 상자에 식을 입력합니다.

First occurrence only

이 옵션을 선택하면 선택한 텍스트의 첫 번째 경우만 검색됩니다.


Find Next, Find Previous

Search|Find Next 및 Search|Find Previous 메뉴 항목은 Find를 수행한 후에만 활성화됩니다.

  • Search|Find Next(또는 <F3>)는 검색 중인 텍스트의 다음 항목으로 이동합니다.

  • Search|Find Previous(또는 <SHIFT> <F3>)는 검색 중인 텍스트의 이전 항목으로 이동합니다.


창: Find and Replace Text

Find and Replace Text

이 대화상자를 사용하여 Editor 창에서 다른 키워드 또는 구문으로 교체할 수 있습니다.

텍스트를 찾아서 바꾸려면

  • Edit 메뉴에서 다음 중 하나를 수행하십시오.

  • Replace를 선택합니다.

  • 편집 도구 모음의 Replace 단추를 누릅니다.

  • <CTRL>R 바로 가기를 누릅니다.

전체 단어 찾기, 선택한 텍스트만 검색, 대소문자 구분으로 검색 및 한 번에 하나씩 또는 한꺼번에 모두 바꾸기 등의 옵션이 있습니다. 기본값은 대소문자 구분 없이 일부 단어를 찾는 것입니다.

<CTRL>V를 사용하여 다른 텍스트를 복사하여 Replace 대화상자에 붙여 넣을 수도 있습니다.

관련 항목

정규식 검색


찾은 후 모두 표시

모두 표시

FIND 명령을 수행한 후에만 이 명령을 사용할 수 있습니다. FIND를 사용하여 단어 또는 구를 텍스트에서 찾은 후 Search에서 Show All 메뉴를 누를 수 있으며 Show All이 모든 검색 구 아래에 빨간색 줄을 표시합니다.

편집기에서 텍스트를 변경한 후 줄이 삭제됩니다.

찾은 후 모두 표시하려면

  • Search|Show All을 선택합니다.


Goto Line

이 대화상자에서 Editor 창에서 커서를 배치할 행 번호를 입력합니다.

큰 파일을 탐색할 때 도움이 됩니다.

정수 0부터 버퍼 내용의 마지막 행 번호까지 입력해야 합니다.

책갈피 를 사용하여 버퍼 내용을 빠르게 탐색할 수도 있습니다.

Goto Line을 액세스하려면

  • Edit|Goto Line을 선택합니다.


Object Search

기본 도구 모음의 Find Object 단추에서, 또는 Search|Object Search 항목을 눌러 Object Search 창을 액세스합니다.

Object Search는 사용자가 입력한 구에 대해 모든 데이터베이스 개체, 표 열, 색인 열, 제약 조건 열, 트리거 열 및 프로시저 원본 코드를 검색합니다. 이전에 나열된 각 항목은 옵션을 사용하여 검색하거나 제외할 수 있습니다.

Object Search 창에서 Options [image] 단추를 눌러 DDL Script Options를 변경할 수 있습니다. Object Search DLL Script Options 대화상자가 나타납니다.

Object Search 창의 여러 기능은 Filters for the Schema Browser 창에 있으며, 브라우저에서 검색 결과를 확인할 수 있습니다.

SYS 및 SYSTEM 스키마를 포함 또는 제외하여 모든 사용자를 대상으로 검색할 수 있습니다.


Object Search DDL Script Options

이 창에서 Object Search 창에 대한 DDL 스크립트 포함을 변경할 수 있습니다. Tables, Indexes, Views, Users, Tablespaces 및 All others에 대한 DDL 스크립트를 추가 또는 삭제할 수 있습니다.

스크립트를 포함(표시) 또는 제외(선택 취소)하려면 확인란을 누릅니다. 기본값으로 모든 스크립트가 포함되어 있습니다.


정규식 검색

정규식 사용과 유용성을 다루는 여러 책들이 나와 있습니다. Toad에서는 Perl 정규식 구문이 사용되며 찾기 및 바꾸기 상자에서 이러한 구문이 사용될 수 있습니다.

이 항목에서는 정규식 사용의 기본적인 내용을 다룹니다. 정규식을 사용하면 정확한 문자를 검색하는 대신에 해당 특징으로 텍스트를 지정할 수 있습니다. 또한 정규식을 사용하여 쉽게 검색할 수 없는 문자열을 찾을 수 있습니다. 이는 정규식의 기본적인 용도 중 하나입니다.

단순 일치

단순 일치는 단순히 지정된 문자를 찾습니다. 문자열에 메타 문자가 포함되지 않은 경우 Toad에서는 단순 일치가 사용됩니다. 예를 들어 "toad"를 입력하면 "toad"와 일치합니다.

메타 문자

메타 문자라고 하는 특수 문자는 해당 문자를 일치시키는 것이 아니라 다른 목적으로 사용됩니다. 필요한 경우에는 특수 문자와 정확하게 일치하도록 할 수 있습니다. 문자를 이스케이프하여 해당 문자 자체와 일치하게 하려면 앞에 백슬래시(\)를 추가하면 됩니다. 예를 들어 ^은 "문자열의 시작 부분과 일치"를 의미하지만 \^은 "^"과 일치합니다. 같은 방식으로 메타 문자가 아닌 문자를 경우에 따라 백슬래시를 앞에 추가하여 메타 문자로 만듭니다. 예를 들어 "t"는 모든 "t"와 일치하지만 \t는 탭 문자를 찾습니다.

메타 문자는 정규식의 핵심입니다. 여러 다른 종류의 메타 문자가 있습니다. 가장 일반적으로 사용되는 메타 문자가 아래 설명되어 있습니다.

식 | 의미
\r | 캐리지 리턴
\n | 줄 바꿈
\f | 폼 피드
\t | 탭 문자
\b | 백스페이스
\s | 공백 문자
\S | 공백
. | 모든 단일 문자. 예를 들어 c.b는 cab, cob 및 cub과 일치합니다.
[] | 대괄호에 있는 문자 중 하나, 하이픈으로 구분된 문자 범위 또는 문자 클래스 연산자
[^] | 캐럿 뒤에 있는 문자를 제외한 모든 문자. 예를 들어 c[^u]b는 cab 및 cob와 일치하지만 cut와는 일치하지 않습니다.
^ | 줄의 시작
$ | 줄의 끝(줄 바꿈 문자 제외)
* | 앞 문자 또는 식이 없거나 1개 이상인 경우와 일치합니다. 예를 들어 bo*t는 bt, bot 및 boot와 일치합니다.
? | 앞 문자 또는 식이 없거나 1개인 경우와 일치합니다. 예를 들어 bo?t는 bt 및 bot와 일치하지만 boot와는 일치하지 않습니다.
+ | 앞 문자 또는 식이 1개 이상인 경우와 일치합니다. 예를 들어 bo+t는 bot 및 boot와 일치하지만 bt와는 일치하지 않습니다.

관련 항목

문자 클래스

메타 문자

정규식 예


정규식 문자 클래스

문자 클래스

문자 목록을 대괄호([])로 묶어 포함된 목록의 임의 문자 하나와 일치하는 정규식의 문자 클래스를 지정할 수 있습니다. [ 다음의 첫 번째 문자가 "^"일 경우 클래스는 목록에 없는 모든 문자와 일치합니다.

클래스 목록 내에서 "-" 문자를 사용하여 범위를 지정합니다. 예를 들어 a-z는 a와 z(포함) 사이의 모든 문자입니다. "-"을 목록의 시작 또는 끝에 포함하거나 백슬래시로 이스케이프하여 클래스의 구성원으로 포함할 수 있습니다.

예

식 | 일치 항목
m[aeiou]ke | 'make', 'meke', 'mike' 등과 일치하지만 'mke','mbke', 'mcke' 등과는 일치하지 않음
m[^aeiou]ke | 'mbke', 'mcke' 등과 일치하지만 'make', 'meke' 등과는 일치하지 않음
[-az] | 'a', 'z' 및 '-'
[az-] | 'a', 'z' 및 '-'
[a\-z] | 'a', 'z' 및 '-'
[a-z] | 'a'에서 'z'까지의 모든 26개 소문자
[\n-\x0D] | 다음 중 하나: '10', '11', '12' 또는 '13'
[\d-t] | 임의의 숫자, '-' 또는 't'
[]-a] | ']'에서 'a'까지의 임의 문자

관련 항목

정규식 검색

메타 문자

정규식 예


정규식 메타 문자

메타 문자

여러 다른 유형의 메타 문자가 있습니다. 각 메타 문자는 다른 종류의 문자열을 찾습니다.

줄 구분 기호

문자 | 일치 항목
^ | 줄의 시작
$ | 줄의 끝
\A | 텍스트의 시작
\Z | 텍스트의 끝
. | 줄의 모든 문자

미리 정의된 클래스

식 | 일치 항목
\w | 영숫자 문자("_" 포함)
\W | 영숫자가 아닌 문자
\d | 숫자
\D | 숫자가 아닌 문자
\s | 모든 유형의 공백([\t\n\r\f]으로 쓸 수도 있음)
\S | 공백이 아닌 문자

단어 경계

식 | 일치 항목
\b | 단어 경계
\B | 단어가 아닌 경계

반복자

정규식 다음에 반복자가 올 수 있습니다. 이러한 메타 문자를 사용하면 이전 문자, 메타 문자 또는 하위 식의 경우 수를 지정할 수 있습니다.

반복자 | 일치 항목
& | 0개 이상(최대), {0}과 비슷함
+ | 0개 이상(최대), {1,}와 비슷함
? | 0 또는 1개(최대), {0,1}과 비슷함
{n} | 정확하게 n번(최대)
{n,} | 최소한 n번 이상(최대)
{n,m} | 최소한 n번 이상, m번 이하(최대)
*? | 0개 이상(최대 아님), {0,}?와 비슷함
+? | 1개 이상(최대 아님), {1,}?와 비슷함
?? | 0 또는 1개(최대 아님), {0,1}?와 비슷함
{n}? | 정확하게 n번(최대 아님)
{n,}? | 최소한 n번 이상(최대 아님)
{n,m}? | 최소한 n번 이상, m번 이하(최대 아님)

대체 항목

| 기호를 사용하여 패턴의 대체 항목을 구분합니다.

식 | 일치 항목
m(a|e)t | mat 또는 met

하위 식

하위 식을 검색에 추가하여 식을 결합할 수 있습니다. 하위 식은 여는 괄호의 왼쪽에서 오른쪽 순서에 기초하여 번호가 매겨집니다. 다음과 같은 예가 있습니다.

식 | 일치 항목
(match){5,7} | 5, 6 또는 7개의 "match"를 포함하는 문자열
mat([0-9]|c+)h | mat0h, mat1h, match, matcch 등

관련 항목

정규식 검색

문자 클래스

정규식 예


정규식 예

다음은 나열된 메타 문자를 사용하는 몇 가지 정규식입니다.

식 | 일치 항목
^make | 줄의 시작 부분에 있는 경우에만 문자열 'make'와 일치
make$ | 줄의 끝 부분에 있는 경우에만 문자열 'make'와 일치
^make$ | 줄에서 유일한 문자열인 경우에만 문자열 'make'와 일치
m.ke | 'make', 'mike', 'mbke', 'm1ke' 등과 같은 문자열과 일치
mat\dh | 'mat1h', 'mat2h' 등과 같은 문자열과 일치하지만 'match', 'matbh', 'matrh' 등과는 일치하지 않음
mat[\w\s]h | 'match', 'mat h', 'mathh' 등과 같은 문자열과 일치하지만 'mat1h', 'mat2h' 등과는 일치하지 않음
mat.*h | 'match', 'matasdkfjdf9sasf', 'math' 등과 같은 문자열과 일치
mat.+h | 'match', 'masjdfksjfs9fsj' 등과 같은 문자열과 일치하지만 'math'와는 일치하지 않음
mat.?h | 'matah', 'matbh', 'math' 등과 같은 문자열과 일치하지만 'mat9h' 등과는 일치하지 않음
mat{2}h | 'matth' 문자열과 일치
mat{2,}h | 'matth', 'mattt', 'matttth' 등과 같은 문자열과 일치
mat{2,3}h | 'matth', 'mattth' 등과 같은 문자열과 일치하지만 'matttth' 등과는 일치하지 않음
(match){6,10} | 6, 7, 8, 9 또는 10개의 "match"를 포함하는 문자열과 일치
mat([0-9]|a+)h | 'mat0r', 'mat1r', 'match', 'matah' 등과 같은 문자열과 일치

관련 항목

정규식 검색

문자 클래스

메타 문자

정규식 예


눈금 인쇄

Legacy Print Grid

Toad의 데이터베이스는 모두 인쇄할 수 있습니다. Legacy Print grid를 사용하는 경우(Toad Options|Data Grid|Data|Use Legacy Print Grid 참조), Print Grid 기능은 인쇄하기 전에 다음과 같은 포맷 확장을 허용합니다.

  • 열 삭제

  • 데이터의 글꼴 변경

  • 머리글의 글꼴 변경

  • 개별 열 또는 머리글의 정렬

  • 숫자 열의 총계(SUM)

  • 머리글 및 바닥글 옵션

  • 열 크기 조절

  • 열 순서 다시 지정

눈금 내용을 인쇄하려면

  1. Grid|Print Grid 메뉴 또는 SQL 결과의 마우스 오른쪽 단추 메뉴에서 Print Grid 메뉴 항목을 선택합니다.

  2. Print 대화상자에서 Print를 누르거나 Preview 페이지에서 File|Print를 선택합니다.

머리글/바닥글

맨 윗줄 및 두 번째 줄 머리글과 한 줄 바닥글을 선택할 수 있습니다.

Print page numbers 상자를 확인할 수도 있으며 페이지 번호가 인쇄됩니다.

페이지 설정

드롭다운 단추를 사용하여 프린터를 선택할 수 있습니다.

페이지 설정의 기본 방향은 Landscape입니다. 화면의 너비가 Portrait 방향 너비보다 크기 때문에 Landscape 방향을 사용하여 인쇄해야 합니다. (Toad에는 인쇄 미리 보기가 없습니다.)

열

화면 글꼴이 프린터 글꼴과 약간 다르기 때문에 인쇄 버전에 열 사이에 충분한 공백이 있을 수 있도록 열 사이에 공백을 두는 것이 좋습니다.

  • 확인란을 사용하여 열 제목을 굵게 인쇄할 수 있습니다.

  • 드롭다운 목록에서 텍스트 정렬을 선택할 수 있습니다.

  • Remove Column 단추를 사용하여 열을 삭제할 수 있습니다.

  • 드롭다운 목록에서 날짜 정렬을 선택할 수 있습니다.

  • 열의 총 수를 계산하려면 Report에서 화면대로 인쇄할 열을 선택한 다음 Total this column 확인란을 선택합니다.

Report Link Designer를 사용하여 인쇄 옵션을 설정할 수도 있습니다. 자세한 내용은 Report Link Designer를 참조하십시오.

관련 항목

눈금 인쇄

눈금 내용 인쇄

Report Link Designer

Reports Manager


눈금: 행 복사

행을 복사하려면

  1. Grid 메뉴에서 Duplicate Row를 선택합니다.

  2. 복사할 셀의 내부를 누른 다음 Grid|Copy Row 메뉴 항목을 선택합니다(마우스 오른쪽 단추 메뉴에서도 사용 가능). 이렇게 하면 전체 행이 SQL Results 눈금 아래에 복사되어 편집할 준비가 됩니다.

주: Copy Row 기능이 작동하도록 레코드 집합을 편집할 수 있어야 합니다.


창: 질의를 단일 파일로 내보내기

질의를 단일 파일로 내보내기

이 창은 Grid|Flat File Export 창 메뉴 항목 또는 Grid 마우스 오른쪽 단추 메뉴를 통해 액세스할 수 있습니다. 이 창에는 데이터를 단일 파일로 내보내기 전에 입력할 수 있는 옵션이 보다 많이 제공됩니다.

단일 파일 내보내기에 대한 자세한 내용은 표를 단일 파일로 내보내기 를 참조하십시오.


Grid Data Find

이 대화상자에서 일치하는 데이터의 첫 번째 행을 찾습니다.

Find Data를 액세스하려면

Grid|Find Data 메뉴 항목을 사용하여 이 대화상자를 엽니다.

또는

눈금에서 작업 중일 경우 <CTRL>F를 누릅니다. (Editor의 <CTRL>F는 스크립트 텍스트를 찾습니다.)

데이터를 찾으려면

  1. 검색할 열을 선택하고 검색할 값을 입력한 다음 Add 단추를 누릅니다.

  2. 여러 열을 검색하려면 열과 값을 더 많이 선택합니다.

  3. OK 를 누르면 SQL Results 눈금이 검색 조건의 첫 번째 결과에 삽입됩니다.

  4. 검색 조건의 다음 결과를 찾으려면 다음 중 하나를 수행하십시오.

  5. Grid 메뉴에서 Find Next Data를 선택합니다.

  6. <F3>을 누릅니다.

SQL Results 눈금이 다음 결과에 삽입됩니다.


보고서

Toad에서는 Fast Reports, Inc.의 강력한 보고 도구를 사용할 수 있습니다. 이 도구를 사용하여 Editor 데이터 눈금, Master/Detail Browser 및 Schema Browser를 포함한 Toad 내의 모든 눈금에서 보고서를 작성할 수 있습니다.

미리 설계된 여러 개의 보고서가 Toad에 포함되어 있으며, 이 보고서로 데이터를 보고서 형식으로 쉽고 빠르게 구성할 수 있습니다(Report Manager 참조).

관련 항목

Reports Manager


명령줄에서 보고서 인쇄 또는 내보내기

보고서를 다시 실행할 때마다 FastReports 페이지를 열 필요 없이 명령줄에서 보고서를 쉽게 인쇄하거나 내보낼 수 있습니다.

또한 이 기능을 사용하여 보고서 실행 시기를 스케줄링할 수 있습니다.

"파일로 저장"할 수 있는 확장자

지원되는 확장자는 다음과 같습니다.

  • .pdf

  • .txt

  • .xls

  • .bmp

  • .rtf

  • .jpg

  • .gif

  • .csv

  • .htm(l)

지원되는 매개 변수

매개 변수를 필요한 만큼 추가할 수 있습니다. 유효한 매개 변수 형식은 String, Number, Date 또는 Substitution(질의가 실행되기 전에 텍스트 교체)입니다. String, Number 및 Date 형식은 일반 연결 변수입니다.

명령줄에서 인쇄하거나 내보내려면

  1. Editor에서 질의를 입력한 다음 보고서를 설계합니다(Report Builder 마법사 참조).

  2. 보고서 정의를 .fr3 파일로 저장합니다.

  3. 질의 앞 또는 뒤의 줄에 다음 설명을 입력합니다.

--ParamName: 매개 변수를 포함하고자 할 경우의 매개 변수.

--ParamType: ParamName의 매개 변수 형식.

--ParamValue: 매개 변수 값.

--하나 이상일 경우 위의 Param 옵션을 반복합니다.

--ReportFile:.fr3 파일의 전체 경로.

--Print(인쇄하고자 할 경우).

--Save To File:작성하여 내보낼 파일의 전체 경로.

--CloseToad(작업 완료 시 Toad를 종료하고자 할 경우)

  4. 파일에 추가한 줄과 함께 질의를 저장합니다.

  5. 명령줄에서 다음과 같이 호출합니다.

c:\toad\toad.exe connect=scott/tiger@orcl rep=c:\your_query_file.sql

연결 문자열 및 파일 이름을 반드시 변경해야 합니다.

SQL 파일 인쇄 예제

매개 변수가 하나일 경우

SELECT *

FROM SCOTT.EMP

where empno>=:x

order by 1

--Paramname:x

--ParamType:number

--ParamValue:7700

--ReportFile:c:\emp.fr3

--Save To File:c:\emp.pdf

--CloseToad

매개 변수가 여러 개일 경우

SELECT *

FROM * &y

WHERE empno>=:x

order by 1

--ParamName:x

--ParamType:number

--ParamValue7700

--ParamName:y

-- ParamType:subst

-- ParamValue:scott.emp

-- ReportFile:c:\emp.fr3

-- Save To File: c:\emp.pdf

-- CloseToad


Report Builder 마법사

하나의 데이터 집합 보고서를 작성할 때 Toad는 보고서를 보다 쉽게 작성할 수 있도록 Report Builder 마법사를 제공합니다. 이 보고서를 Reports Manager로 가져온 다음 Master/Detail 보고서로 확장하고, 다른 스키마에서 반복하여 생성하거나 작업할 수 있습니다.

마법사를 사용하여 보고서를 작성하려면

Grid 메뉴에서 Report를 선택합니다.

  1. 1단계 - 필드

  1. 표시할 데이터 집합을 선택하고 Add>를 누릅니다.

  2. 필드를 선택하고 위쪽 또는 아래쪽 화살표를 눌러 선택한 필드를 다시 정렬합니다.

  3. Groups 탭 또는 Next를 누릅니다.

  2. 2단계 - 그룹(선택 사항)

  1. 데이터를 그룹화하는 데 사용할 수 있는 필드를 선택하고 Add>를 누릅니다.

  2. 필드를 선택하고 위쪽 또는 아래쪽 화살표를 눌러 선택한 필드를 다시 정렬합니다.

  3. Layout 탭 또는 Next를 누릅니다.

  3. 3단계 - 레이아웃

  1. 사용할 페이지 방향을 선택합니다(세로 또는 가로).

  2. 사용할 레이아웃을 선택합니다(표 또는 열 형식).

  3. Fit fields to page width 확인란을 선택 또는 선택 취소합니다.

  4. Style 탭 또는 Next를 누릅니다.

  4. 4단계 - 유형

  1. 미리 설계된 유형을 선택합니다.

  2. Finish를 누릅니다.

마법사를 사용하지 않고 보고서를 작성하려면

  1. Grid 메뉴에서 Report를 선택합니다.

  2. Report Builder가 나타나면 Cancel을 누릅니다.

  3. Fast Report를 사용하여 보고서를 작성합니다.

보고서 도구 사용에 대한 추가 도움말은 Fast Report 온라인 사용 설명서를 참조하십시오.


저장 형식

눈금 내용을 저장할 때 여러 가지의 다른 형식을 선택할 수 있습니다. 형식마다 다른 옵션이 제공되어 파일을 원하는 대로 설정할 수 있습니다. 이러한 형식은 다음과 같습니다.

  • 구분된 텍스트

  • 고정 필드 너비

  • HTML

  • 삽입 구문

  • 병합 구문

  • SQL Loader

  • XLS 파일

  • XLS 인스턴스

  • XML(일반)

  • XML(XSL 포함)

이러한 일부 형식을 사용하여 클립보드에 복사할 수 있으며 다른 형식의 경우 문서를 파일로 저장해야 합니다. 옵션은 선택한 형식에 따라 달라집니다.

주: 표에 XML 데이터가 포함된 열이 있을 경우 다음 형식에서 가져올 때 문제가 발생할 수 있습니다.

  • SQL Loader

  • XML(XSL 포함)

  • XML(일반)


텍스트 옵션

Save as Text를 선택하면 선택한 내용에 구분 기호를 설정할 수 있습니다. 기본값은 파이프(|)입니다.

일반 구분 기호로 변경하려면

  • 구분 기호 상자에서 마우스 오른쪽 단추를 누른 다음 사용할 구분 기호를 선택하거나 키보드를 사용하여 구분 기호를 입력합니다.

다음 옵션을 선택하거나 지울 수도 있습니다.

  • Include delimiter after last column

  • Selected rows only

  • No Word Wrap

  • Double quote char (text) columns

  • Include cell borders?

  • Include column headers(선택되어 있으면 소문자로 저장할 수 있으며 따옴표로 묶을 수도 있음)

  • Include NULL text

  • Zip resulting files

  • Include SQL Statement

  • Clone Cursor

  • Click the Substitutions button

관련 항목

고정 필드 너비

HTML

삽입 구문

SQL Loader

XLS 파일

XLS 인스턴스

XML(일반)

XML(XSL 포함)

Clone Cursor


고정 필드 너비

고정 필드 너비로 눈금을 내보낼 수 있습니다.

너비는 열 정의에서 파생되었습니다.

주: 너비는 눈금에서의 모양이 아닌 데이터베이스의 표 정의에서 파생됩니다.

다음 옵션을 선택하거나 지울 수도 있습니다.

  • Double quote char (text) columns?

  • Include column headers

이 옵션이 선택되어 있으면 머리글을 소문자로 유지하도록 선택할 수도 있습니다.

  • Include Null text

  • Zip resulting files

  • Include SQL statement

  • Clone Cursor

  • Click the Substitutions button

관련 항목

구분된 텍스트

HTML

삽입 구문

SQL Loader

XLS 파일

XLS 인스턴스

XML(일반)

XML(XSL 포함)

Clone Cursor


HTML 옵션

결과를 HTML 표로 내보내기로 선택할 수 있습니다.

이 형식을 선택하면 다음 옵션에서 선택할 수 있습니다.

  • Include column headers(이 옵션이 선택되어 있으면 소문자로 저장하기로 선택할 수도 있습니다.)

  • Include NULL text

  • Zip resulting files

  • Clone Cursor

  • No Word Wrap

  • Include cell borders

  • Click the Substitutions button

관련 항목

구분된 텍스트

고정 필드 너비

삽입 구문

SQL Loader

XLS 파일

XLS 인스턴스

XML(일반)

XML(XSL 포함)

Clone Cursor


삽입 구문 옵션

결과를 INSERT 구문으로 내보내기로 선택하면 열 머리글이 자동으로 포함됩니다. 다음 옵션을 설정할 수도 있습니다.

  • Commit interval

  • Lowercase column headers

  • Include NULL text

  • Include Schema name

  • Zip resulting files

  • Include SQL statement

  • Clone Cursor

  • Click the Substitutions button

또한 다음을 지정할 수 있습니다.

  • 삽입 스키마

  • 삽입 표

삽입 스키마 또는 삽입 표 이름을 자동으로 포함하려면

  • Auto를 눌러 질의를 분석하고 Insert Schema 및 Insert Table 상자에 FROM 절의 스키마 및 표 이름을 입력합니다.

주: 이 옵션은 데이터베이스에서 실행 중인 커서에 연결되어 있는 눈금에서만 사용할 수 있습니다.

관련 항목

구분된 텍스트

고정 필드 너비

HTML

SQL Loader

XLS 파일

XLS 인스턴스

XML(일반)

XML(XSL 포함)

Clone Cursor


병합 구문

이 옵션을 선택하여 눈금을 MERGE 구문 계열로 저장합니다. 이 병합은 표의 기본 키에 따라 만들어집니다. 기본 키가 없을 경우 병합할 열을 선택하면 됩니다. 보이지 않는 눈금 열은 병합 구문에서 제외됩니다.

주: 이러한 구문은 모든 Oracle 버전에서 생성할 수 있지만 Oracle 9i 이상에서만 실행할 수 있습니다.

관련 항목

구분된 텍스트

고정 필드 너비

HTML

삽입 구문 옵션

SQL Loader

XLS 파일

XLS 인스턴스

XML(일반)

XML(XSL 포함)

Clone Cursor


SQL*Loader 옵션

SQL Loader를 선택하면 SQL Loader 파일이 작성됩니다.

다음 옵션 중에서 선택합니다.

  • Insert

  • Truncate

  • Append

  • Replace

  • Include schema name

  • Zip resulting file(s)

  • Include SQL Statement

  • Clone Cursor

  • Click the Substitutions button

또한 다음을 지정할 수 있습니다.

  • Discard max

  • Field Separator(기본값: ;)

  • String Field encloded by(기본값: ")

  • Insert Schema

  • Insert Table

관련 항목

구분된 텍스트

고정 필드 너비

HTML

삽입 구문

XLS 파일

XLS 인스턴스

XML(일반)

XML(XSL 포함)

Clone Cursor


XLS 파일 옵션

XLS 파일로 내보내기로 선택할 경우 긴 옵션 목록에서 선택할 수 있습니다. 다음을 수행할 수 있습니다.

  • Match cell fonts to grid

  • Use only 'general' cell formatting

  • Auto column width

  • Hide time and portion of date if zero

  • Include column headers (선택되어 있을 경우 머리글을 소문자로 만들 수 있음)

  • Include NULL text

  • Include SQL Statement

  • Clone Cursor

  • Date Format

  • Set Locality (기존의 MSExcel 파일을 사용하여 Toad가 내보낼 때 사용하는 로컬 코드를 설정할 수 있음)

  • #of Decimals for numbers (none for Integers)

  • Include cell borders

  • Click the Substitutions button

관련 항목

구분된 텍스트

고정 필드 너비

HTML

삽입 구문

SQL Loader

XLS 인스턴스

XML(일반)

XML(XSL 포함)

Clone Cursor


XLS Instance 옵션

Instance 옵션을 설정하면 시스템에 실행 중인 현재 Excel 인스턴스 내에 Excel 파일이 작성됩니다. 다음 옵션을 사용할 수 있습니다.

  • Include column headers - 선택되어 있을 경우 소문자 열 머리글을 사용할 수 있게 됩니다.

  • Start at active cell - 선택되어 있을 경우 내보낸 데이터를 MS Excel의 활성 셀(왼쪽 상단 모서리)에 배치합니다. 이 옵션을 사용하여 시트 내의 어느 곳이든지 데이터를 배치할 수 있습니다. 표시되어 있지 않으면 데이터가 새 시트의 A1 셀에서 시작됩니다.

  • String Fields as Strings - 선택되어 있을 경우 Toad가 Excel에서 문자열로 처리하면서 문자열 필드 앞에 작은따옴표를 전송합니다. 앞에 오는 0은 그대로 둡니다.

  • Include NULL text

  • Clone Cursor

  • Click the Substitutions button

관련 항목

구분된 텍스트

고정 필드 너비

HTML

삽입 구문

SQL Loader

XLS 파일

XML(일반)

XML(XSL 포함)

Clone Cursor


XML(일반) 옵션

이 형식 옵션은 결과를 일반 XML 파일로 내보냅니다.

결과 파일의 압축 및/또는 커서 복제를 선택할 수 있습니다. 또한 Substitutions 단추를 눌러 데이터 대체를 지정할 수도 있습니다.

관련 항목

구분된 텍스트

고정 필드 너비

HTML

삽입 구문

SQL Loader

XLS 파일

XLS 인스턴스

XML(XSL 포함)

Clone Cursor


XML(XSL 포함) 옵션

이 포맷 옵션은 결과를 XML 파일(XSL 포함)로 내보냅니다. 결과 파일의 압축 및/또는 커서 복제를 선택할 수 있습니다. 또한 Substitutions 단추를 눌러 데이터 대체를 지정할 수도 있습니다.

관련 항목

구분된 텍스트

고정 필드 너비

HTML

삽입 구문

SQL Loader

XLS 파일

XLS 인스턴스

XML(일반)

Clone Cursor


Clone Cursor 옵션

눈금 내용을 저장할 때 커서 복제를 선택할 수 있습니다. 이 동작에는 장점 및 단점이 있습니다.

  • Clone Cursor가 선택되어 있지 않은 경우

Toad는 데이터 눈금에 연결되어 있는 실제 커서를 사용합니다. 여기서 장점은 질의를 다시 실행할 필요가 없다는 것입니다. 스크롤 가능한 데이터 집합(눈금에서 스크롤이 가능한 구조)이므로 전체 데이터 집합을 PC의 RAM에 보관해야 한다는 것이 단점입니다. 큰 데이터 집합을 가지고 있으면 많은 양의 메모리를 수용할 수 있습니다.

  • Clone Cursor가 선택되어 있는 경우

Toad는 스크롤이 불가능한 새 커서를 만듭니다. 여기서 장점은 행을 읽고 대상 파일로 전송하므로 더 이상 메모리에 보관되지 않으며 최소한의 RAM만 사용된다는 것입니다. 단점은 이러한 문제가 발생하므로 질의를 다시 실행해야 한다는 것입니다.

질의가 너무 많은 행을 반환하여 PC의 RAM에 보관할 수 없는 경우 질의 실행에 많은 시간이 소요되어도 Clone Cursor를 선택해야 합니다.

전체 데이터 집합을 PC의 메모리에 쉽게 보관할 수 있도록 질의가 여러 행을 반환할 경우 질의의 실행 시간을 고려합니다. 실행 시간이 느릴 경우 Clone Cursor를 선택되지 않은 상태로 둡니다. 실행 시간이 빠를 경우 두 가지 방법 모두 수행할 수 있습니다.


Editor: 구문 실행

SQL 창에서 SQL을 실행하려면 <F9>를 누르거나 Editor|Execute SQL All 메뉴 항목을 선택합니다. 이 명령은 Editor 창의 모든 것 또는 선택한 모든 내용(강조 표시)을 실행합니다.

Editor 창은 DDL 구문, 삽입 구문 등을 포함하는 SQL 스크립트를 처리할 수 있습니다. 일부 SQL*Plus 명령은 Toad에서 SQL 스크립트를 처리할 때 무시됩니다. 이러한 명령에는 Describe, Show Errors, Set, Remark 및 Prompt가 포함됩니다. 다른 SQL*Plus 명령을 포함하는 스크립트의 경우, SQL Editor > Execute SQL Window using SQL*Plus 메뉴 항목을 사용하여 스크립트를 계속 실행할 수 있습니다.

관련 항목

예제 구문


Editor: 현재 SQL 실행

Editor: Execute Snippet

Editor|Execute Snippet 메뉴 항목을 누르거나 <SHIFT><F9>키를 눌러 Execute Snippet 명령을 활성화할 수 있습니다.

Execute Snippet 명령은 Editor에서 현재 구문을 실행하고 PL/SQL 디버깅을 위해 Editor에서 현재 원본을 실행합니다.


코드 조각 강조표시

커서 위치의 코드를 강조표시합니다.


창: 질의 설명

선택 질의 설명(분석)

이 기능을 사용하여 질의가 실행될 경우 반환되는 열을 알아볼 수 있습니다.

질의를 설명하려면

  • Editor|Describe (Parse) Select Query 메뉴 항목에서 이 기능을 실행합니다.

또는

<CTRL>F9 를 누릅니다.

이렇게 하면 열 이름, 데이터 형식 및 실행될 경우 질의에서 반환될 열의 데이터 길이가 나열된 창이 나타납니다. 실행되기 전에 LONG 질의를 조정하는 데 도움이 됩니다.


스크립트로 실행

이 명령은 현재 Editor 창의 내용을 스크립트로 실행합니다.

Execute as Script 도구 모음 단추 옆의 드롭다운을 클릭해도 됩니다. 이렇게 하면 Toad 대신 Quest ScriptRunner를 사용하여 스크립트를 실행할 수 있습니다.

Editor의 내용을 스크립트로 실행하려면

  • Editor|Execute as Script 메뉴 항목 또는 도구 모음 단추를 누릅니다.


Editor: Load and Execute a Script File

SQL 창: Load and Execute a Script File

Editor|Load and Execute a Script File 메뉴 항목은 Select Script File for Execution 창을 엽니다. 파일을 선택하여 Editor에 로드할 수 있습니다. Toad는 Editor에 파일을 로드하여 해당 파일을 실행합니다.


SQL*Plus를 통해 SQL 실행

이렇게 하면 DOS 상자가 열리고 SQL*Plus를 사용하여 Editor의 내용이 실행됩니다.

SQL*Plus를 위해 MS DOS를 액세스하려면

  • Editor|Execute SQL via SQL*Plus를 선택합니다.


창: 세션 선택

세션 선택

이 대화상자에서 다음 작업을 수행합니다.

  • 종료할 현재 세션을 선택합니다.

주: 이 연결에 연결되어 있는 창은 모두 닫힙니다.

  • 전환할 세션을 선택합니다. Change Active Session 단추에서 이 창을 액세스하면 전환할 새 세션을 작성할 수 있도록 NEW 단추가 나타납니다. 이를 통해 Server Login 창 이 나타나고 새 세션을 구축할 수 있습니다.

Select Session을 액세스하려면

  • File 메뉴에서 End Connection을 선택합니다.

또는

Toad의 창에서 여러 Change Active Session 단추 중 하나를 누릅니다.


연결 종료

Toad를 닫지 않고 연결 종료를 선택할 수 있습니다. 이 대화상자를 사용하여 세션을 변경할 수도 있습니다.

하나의 연결을 종료하려면

  • Session|End Connection을 선택하여 선택한 연결을 종료합니다.

여러 개의(전부가 아닌) 연결을 종료하려면

  1. 종료할 연결을 선택합니다.

  2. Session|End Connection을 선택하여 선택한 연결을 종료합니다.

연결을 모두 종료하려면

  • 연결을 모두 종료하려면 Session|End All Connections를 선택합니다.


File: Test Connections

연결 테스트

이 명령은 Oracle이 세션을 삭제한 경우 다시 연결합니다.

연결을 테스트하려면

  • Session|Test Connections (Reconnect)를 선택합니다.


Toggle Compiling with Debug

이 명령은 디버그 정보를 사용하여 코드를 컴파일하는 경우에 사용합니다. 디버그를 사용하여 컴파일하면 Toad에서 Debugger를 사용하여 코드를 탐색하는 데 필요한 정보가 제공됩니다.

디버그를 사용하여 컴파일하려면

  • Session 메뉴에서 Toggle compiling with debug를 선택합니다.

관련 항목

Debugger 개요


PL/SQL Profiling 전환

이 명령을 사용하여 PL/SQL Profiling을 켭니다.

  • Session|Toggle PL/SQL Profiling을 선택합니다.

관련 항목

프로파일러 분석 개요

프로파일러 설정

프로파일러 사용

프로파일러 분석


사용자 목록 구성

여러 데이터베이스에는 수백 명의 사용자가 있으며 대부분 데이터베이스 개체가 없고 데이터베이스를 안전하게 액세스하기 위해서만 존재합니다. Oracle Users List에서 사용자를 선택하여 Toad 내의 여러 화면의 드롭다운 사용자 목록에서 원하지 않는 사용자를 삭제할 수 있습니다.

Oracle Users List는 현재 데이터베이스 연결에 모든 사용자 목록을 표시합니다. 확인란을 눌러 이 창에서 사용자 또는 사용자 그룹을 선택할 수 있습니다. OK 를 누르면 Toad가 모든 드롭다운 사용자 목록을 선택한 사용자로 제한합니다.

사용자 목록은 ASCII 파일, SCHEMA_DATABASE.LST에 저장되며, 여기서 SCHEMA는 사용 중인 스키마이고 DATABASE는 현재 데이터베이스 별칭입니다.

데이터베이스의 개체를 소유하고 있는 사용자만 표시할 수 있는 다른 옵션이 있습니다. 자세한 내용은 Toad Options|Schema Browser를 참조하십시오.

사용자 목록 구성을 액세스하려면

  • Session|Oracle Users Lists를 선택합니다.


창: 세션 정보

세션 정보

일반 용도의 유틸리티 창에 Oracle 연결 자체에 대한 정보뿐만 아니라 현재 Oracle 사용자에 대한 정보도 표시됩니다.

이 창에 다음 내용이 표시됩니다.

  • 현재 사용자의 세션 권한

  • 현재 사용자에게 할당된 역할

  • 현재 사용자 역할에 의해 할당된 액세스

  • 코어 Oracle 프로세스에 대한 버전 정보

  • Oracle에 대한 레지스트리 정보

세션 정보를 보려면

  • Session|Session Info 메뉴 항목을 선택합니다.


암호 변경

암호를 변경하려면

  1. Session|Change Password에서 Change Password 대화상자를 액세스합니다. Change Password 대화상자가 나타납니다.

  2. 이전 암호가 입력되지만 보안을 위해 별표로만 표시됩니다. New Password 필드에 새 암호를 입력합니다.

  3. Verify Password 필드에 암호를 다시 입력합니다.

  4. OK를 누릅니다.

이제 암호가 변경되었습니다.


데이터베이스: 실행 & 롤백

변경 내용을 실행하려면

  • Session|Commit을 선택합니다.

변경 내용을 롤백하려면

  • Session|Rollback을 선택합니다.


연결 및 분리

연결 및 분리 메뉴 항목을 사용하여 이전에 사용한 스키마에서 쉽게 연결 또는 분리하도록 선택할 수 있습니다. 스키마는 연결 목록에 나열되어야 합니다(자세한 내용은 Server Login 창 참조).

스키마에 연결하려면

  • Session 메뉴에서 연결할 Connect| 스키마를 선택합니다.

스키마에서 분리하려면

  • Session 메뉴에서 분리할 Disconnect| 스키마를 선택합니다.

관련 항목

Server Login 창

새 연결 작성


Audit SQL/Sys Privs

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Audit SQL/Sys Privs 창에는 데이터베이스에 있는 SQL 문 개체, 예약된 단어 및 시스템 권한에 대한 Audit Monitoring 옵션이 표시됩니다.

이 창에서 각 유형 또는 유형 그룹의 모니터링 수준을 입력 및 수정할 수 있습니다. 선택한 스키마의 감사 내역 레코드를 볼 수도 있습니다.

Toad에서 감사 기능을 사용하려면 AUDIT_TRAIL이 DB로 설정되어 있어야 합니다.

주: 이 화면을 사용하려면 특정 권한이 필요합니다. 여기에는 다음 항목이 포함됩니다.

  • SQL 문의 항목을 감사하려면 AUDIT SYSTEM 권한이 있어야 합니다.

  • 스키마 개체의 작업을 감사하려면 감사를 위해 선택한 개체가 자체 스키마에 있거나 AUDIT ANY 시스템 권한이 있어야 합니다. 또한 감사를 위해 선택한 개체가 디렉토리 개체인 경우에는 직접 작성한 경우라도 AUDIT ANY 시스템 권한이 필요합니다.

Audit SQL/Sys Privileges 도구 모음

SQL/Sys Privileges 도구 모음에는 사용하기 쉬운 몇 가지 기능이 있습니다.

단추 | 명령
 | 활성 연결 변경
Schema | 스키마 선택
Audit Options | Audit 옵션 보기
Audit Trail | 감사 내역 보기

감사 세부 정보를 보려면

  1. Database 메뉴에서 Administer|Audit SQL/Sys Privs를 선택합니다.

  2. Schema 드롭다운 메뉴에서 감사할 스키마를 선택합니다.

  3. Audit Options

또는

Audit Trail을 누르고 원하는 정보를 봅니다.


창: NLS 매개 변수

NLS 매개 변수

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

이 창은 Session, Instance 및 Database 매개 변수 설정을 보고 Session 및/또는 Instance 매개 변수를 변경하는 데 사용됩니다.

이 창에는 Session, Instance 및 Database 관련 탭이 들어 있습니다.

NLS 매개 변수 액세스

  • Database메뉴에서 Administer|NLS Parameters를 선택합니다.

NLS(National Language Support) 설정을 변경하려면

  • parameter를 두 번 누른 후 팝업 창에 새 설정을 입력합니다.

  • 매개 변수 행을 한 번 누르고 Edit 단추를 누른 후 팝업 창에 새 설정을 입력합니다.

매개 변수를 편집할 수 없는 경우에는 Edit 단추를 사용할 수 없습니다. Session 매개 변수는 모두 편집할 수 있습니다. 다른 매개 변수는 편집할 수 없습니다.

하나의 셀에 있는 값을 변경하면 다른 셀의 값도 변경됩니다. 예를 들어 NLS_TERRITORY를 America에서 Japan으로 변경하면 NLS_CURRENCY 기호가 달러에서 엔으로 변경됩니다.


Toad 기능 보안

이 기능은 특정 Toad 기능에 대한 Toad 사용자의 액세스를 제한합니다. 기본값으로 사용자에게 Toad의 모든 기능을 액세스할 수 있는 권한이 부여됩니다. 개인 또는 사용자 그룹의 Toad의 일부 기능에 대한 액세스를 제한할 수 있습니다. 뿐만 아니라, 개인 또는 사용자 그룹에 Toad를 읽기 전용으로 만들 수 있습니다.

주: 완전히 다시 설계된 Toad Security의 구조로 인해 Toad 7.3 이상의 버전으로 업그레이드하려거나 이전 버전의 Toad에 이미 보안 기능이 설정되어 있을 경우 보안 표를 다시 작성하고 새 형식에 따라 제한을 지정해야 합니다.

주의: Toad Security 읽기 전용은 Base Toad에만 영향을 줍니다. Debugger 또는 DBA 모듈이 있을 경우 이 모듈 구성 요소가 완전히 액세스할 수 있는 상태로 남게 됩니다.

보안 시스템을 설정하려면

1. Server Side Objects Install 마법사를 실행하여 Toad 스키마에 Toad_RESTRICTIONS 표를 작성합니다. 이것은 Toad 스키마에는 필요하지만 동의어가 가리키고 있는 다른 스키마에서는 필요하지 않습니다.

주: 7.3뿐만 아니라 이전 버전의 Toad를 사용하고 있을 경우 이 스크립트를 사용하여 이전 Toad Security 표가 삭제되지 않습니다. Toad 7.3에서 사용한 새 표가 추가됩니다.

2. Toad를 실행하고, DBA_USER(1단계에서 설정한 대로)로 로그인한 다음 Administer|Toad Security 메뉴 항목을 선택하여 Toad Features Security 창을 엽니다.

o       사용자 또는 역할을 선택한 다음 해당 사용자 또는 역할을 부인할 기능을 선택합니다.

o

3. 사용자 또는 역할이 Toad.Toad_RESTRICTIONS 표를 볼 수 있도록 Grant Select 단추를 누릅니다.

o

o

4. Features 목록에서 Restricted Features 목록으로 이동합니다. Toad의 모든 단추, 메뉴 또는 기능이 이 보안 스키마에 포함되어 있는 것은 아닙니다. 다른 기능을 제한해야 할 경우 알려주십시오.

5. OK를 눌러 변경 내용을 저장합니다. 기존의 Oracle 역할을 사용하여 Toad 기능 모음을 작성할 수 있습니다. 역할(예: DEVELOPER_ROLE)에 기능을 부여하면 Toad 사용자가 여러 사용자에게 동일한 Toad 기능 목록을 설정할 필요 없이 Toad 기능의 모음을 얻게 됩니다.

예제

다른 종류의 Toad 기능 목록을 설정하려면 선택한 사용자 그룹의 기능 목록을 해지하고 다음을 수행합니다.

1. Toad를 시작하고, 사용자 Toad로 로그인한 다음 Administer||Toad Security를 선택합니다.

2.

주의: Toad Security에 대해 사용자의 DBA 역할을 사용하지 마십시오. Toad가 시작하면 사용자에게 DBA 역할이 있을 경우 보안을 포함한 모든 것을 무시합니다.

3. DEVELOPER_ROLE에 Toad.Toad_RESTRICTIONS 표에 대한 Select 권한이 있는지 확인합니다. Grant Select 단추 제목이 "Grant Select"일 경우 눌러서 권한을 부여합니다. 단추 제목이 "Revoke Select"일 경우 권한 부여가 이미 존재합니다.

4. 원하는 기능을 "Restricted Features" 목록에 복사합니다.

5. OK를 누릅니다. Toad가 "developer_role에 toad_restrictions에 대한 select 권한을 부여"하고 Toad_RESTRICTIONS 표에 이 기록을 작성합니다.

USER_NAME | 기능
DEVELOPER_ROLE | 암호 변경
DEVELOPER_ROLE | 롤백 세그먼트 작성
DEVELOPER_ROLE | 스냅샷 로그 작성
DEVELOPER_ROLE | 사용자 작성

6. 사용자 [grant developer_role to scott]에게 Oracle 역할이 부여되었는지 확인합니다.

7. Toad에 사용자 SCOTT를 로그 오프/온합니다. Scott의 Toad 기능은 지정된 대로 제한해야 합니다.

8. TUNER_ROLE, MAINTENANCE_ROLE 등의 원하는 기타 역할에 제한된 기능을 반복하여 설정합니다.

Disable Saving Oracle Passwords by Toad

이 옵션은 Features|Non-menu list Save passwords에 있습니다. Restricted 목록으로 이동하면 암호 저장 기능을 비활성화할 수 있습니다.

Read-only

선택한 사용자 또는 역할에 Toad 읽기 전용을 만들 수 있습니다. 데이터베이스 개체를 봐야 하지만 변경할 권리는 없는 경우에 유용합니다.

Toad를 읽기 전용으로 만들려면 Features|Non-menu 목록의 Read-only Override 기능을 Restricted 기능 목록으로 이동합니다. 이렇게 하면 선택한 사용자에게 Toad는 읽기 전용이 됩니다.

주: 이 Toad Security 옵션은 DBA 모듈에 적용되지 않습니다. Toad 전체를 제한하려면 해당 사용자의 DBA 모듈을 제한해야 합니다.


ASM Manager 개요

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Oracle 10g에서 Oracle은 Oracle 데이터베이스: ASM(Automatic Storage Management) 내에서 Oracle DB 파일 시스템을 관리할 수 있는 수단을 제공합니다.

ASM에서는 독립 실행형 Oracle 인스턴스가 원시 서버 디스크를 디스크 그룹에 수집하고 데이터베이스 인스턴스에서 ASM 파일을 사용할 수 있게 하는 데 필요한 관리 기능을 수행합니다. 그러면 Oracle 데이터베이스 파일이 이 디스크 그룹에 저장됩니다.

ASM에서는 파일을 작성하는 동안 파일 속성 모음인 템플릿을 사용합니다. 템플릿을 사용하면 복잡한 파일 속성 세부 사항을 단일 이름에 매핑하여 파일 작성을 단순화할 수 있습니다. 각 Oracle 파일 유형에는 기본 템플릿이 있습니다. 기본 템플릿의 속성을 수정하거나 새 템플릿을 작성할 수 있습니다.

ASM, 원시 서버 디스크 및 템플릿에 대한 자세한 내용은 Oracle 설명서를 참조하십시오.

Toad의 ASM Manager는 Oracle ASM 기능에 대한 쉬운 인터페이스를 제공하고 디스크 그룹을 쉽게 관리할 수 있게 해 줍니다.

주: ASM 인스턴스에 대한 연결은 DBA 메뉴에서 Toad ASM Manager를 통해 작성됩니다. Toad는 다른 어떤 방법으로도 이 인스턴스에 대한 연결 작성을 지원하지 않습니다.

ASM Manager에 액세스하려면

  • Database 메뉴에서 Administer|ASM Manager를 선택합니다.

ASM Manager 창은 탭을 통해 액세스할 수 있는 Disk Groups와 Clients의 두 페이지로 나뉩니다. 데이터베이스 인스턴스 또는 ASM 인스턴스별로 보기를 수행하여 정보 작업을 수행하는 동안 인스턴스에 대한 새 연결을 열 수 있습니다. ASM 인스턴스를 사용하면 더 많은 데이터가 표시되며 디스크 그룹을 변경할 수 있습니다.

Disk group 탭에서는 다음을 수행할 수 있습니다.

  • 디스크 그룹 보기

  • 디스크 그룹 작성

  • 디스크 그룹 삭제

  • 디스크 그룹 수정

Clients 탭에서는 다양한 디스크 그룹의 클라이언트 정보를 볼 수 있습니다.

관련 항목

디스크 그룹 보기

디스크 그룹 작성 및 삭제

디스크 그룹 수정

클라이언트 보기


ASM 디스크 그룹 보기

디스크 그룹 보기

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Toad의 ASM Manager에서 디스크 그룹을 볼 수 있습니다.

디스크 그룹 정보는 요약 정보와 세부 정보로 나뉩니다. 요약 정보는 위쪽 그리드에 표시되며 그룹 번호와 디스크 그룹 이름이 포함됩니다. 세부 정보는 위쪽 패널에서 디스크 그룹을 선택하면 아래쪽 그리드에 표시됩니다.

디스크 그룹을 보려면

  1. Database 메뉴에서 Administer|ASM Manager를 선택합니다.

  2. 사용할 데이터베이스 인스턴스나 ASM 인스턴스를 선택합니다.

ASM 인스턴스는 더 많은 데이터를 제공하며 변경을 허용합니다.

  3. 선택되어 있지 않은 경우 Disk Groups 탭을 누릅니다.

  4. 위쪽 패널에서 보려는 디스크 그룹을 선택합니다.

디스크 그룹의 데이터가 아래쪽 패널에 표시됩니다.

요약 정보

특정 디스크 그룹에 대한 요약 정보는 그리드의 위쪽 영역에서 볼 수 있습니다. 제공되는 정보에는 그룹 번호, 디스크 그룹 이름, 섹터 크기, 블록 크기, 할당 단위 크기, 상태, 유형, 전체 MB, 사용 가능한 MB, 필요한 미러 사용 가능한 MB 등이 있습니다.

ASM 인스턴스에 연결되어 있으면 도구 모음을 사용하여 디스크 그룹을 작성, 삭제 및 수정할 수 있습니다(관련 항목 참조).

Disk Group 도구 모음

단추 | 명령
 | 위쪽 창 새로 고침
 | 디스크 그룹 작성
 | 디스크 그룹 수정
 | 디스크 그룹 삭제
 | 세부 드롭다운
 | 아래쪽 창 새로 고침

세부 정보

세부 정보는 아래쪽 패널 그리드에 표시됩니다. 정보는 Disks, Templates, Operations 및 Files, Directories and Aliases의 네 가지 데이터 그리드로 구분됩니다. ASM 인스턴스에 연결된 경우에는 제공되는 도구 모음을 사용하여 Files, Directories and Aliases를 변경할 수 있습니다.

Files, Directories and Aliases 도구 모음

단추 | 명령
 | 선택한 파일의 별칭 작성
 | 선택한 디렉토리에 디렉토리 작성
 | 선택한 개체 이름 변경
 | 선택한 개체 삭제

관련 항목

ASM Manager 개요

디스크 그룹 작성 및 삭제

디스크 그룹 수정

클라이언트 보기


디스크 그룹 작성 및 삭제

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

ASM 인스턴스를 통해 연결된 경우에는 Disk Groups 도구 모음에서 디스크 그룹을 작성 및 삭제할 수 있습니다.

디스크 그룹 작성

Oracle ASM과 Toad의 ASM Manager를 사용하여 신속하게 디스크 그룹을 작성할 수 있습니다.

디스크 그룹을 작성하려면

  1. Database 메뉴에서 Administer|ASM Manager를 선택합니다.

  2. Connected To 상자에서 ASM 인스턴스를 선택합니다.

  3. New Disk Group [image] 단추를 누릅니다.

  4. Disk Group Name 상자에 이름을 입력합니다.

  5. 이미 선택되어 있지 않은 경우 Basic Info 탭을 누릅니다.

  6. 디스크 그룹의 리던던시를 선택합니다.

  • High

  • Normal

  • External

  7. Status after creation 드롭다운 상자에서 가용성을 선택합니다. 다음과 같은 옵션이 있습니다.

  • Mounted

  • Dismounted

주: 디스크 그룹을 작성할 때에는 Alter Actions 섹션을 사용할 수 없습니다. 이 영역의 사용에 대해서는 디스크 그룹 수정을 참조하십시오.

  8. Disks 탭을 누릅니다.

  9. Add Disks를 누르고 이 디스크 그룹에 포함할 디스크를 모두 선택합니다. OK를 누릅니다.

  10. OK를 눌러 디스크 그룹을 추가합니다.

디스크 그룹 삭제

디스크 그룹 쉽게 삭제할 수도 있습니다.

디스크 그룹을 삭제하려면

  1. ASM Manager|Disk Groups 탭에서 삭제할 디스크 그룹을 선택합니다.

  2. Drop disk group [image] 단추를 누릅니다.

  3. Confirm 대화 상자에서 디스크 그룹을 삭제할 때 내용을 포함할 것인지 제외할 것인지 선택합니다.

  4. OK를 누릅니다.

관련 항목

디스크 그룹 보기

디스크 그룹 수정


디스크 그룹 수정

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

디스크 그룹을 수정하려면

  1. Database 메뉴|Administer|ASM Manager에서 Disk Groups 탭을 누릅니다.

  2. Connected To 드롭다운 상자에서 ASN 인스턴스가 선택되어 있는지 확인합니다.

  3. 수정할 디스크 그룹을 선택한 후 Alter [image] 단추를 누릅니다.

  4. 필요한 사항을 변경합니다. 다음 세 탭 중 하나에서 디스크 그룹을 변경할 수 있습니다.

  5. Basic Info

  6. Disks

  7. Templates

  5. OK를 눌러 변경 사항을 적용합니다.

Basic Info

가용성을 변경하거나 Alter 대화 상자에서 특정 수정 작업을 선택할 수 있습니다.

가용성

디스크 그룹의 가용성을 Alter 명령으로 변경할 수 있습니다. Toad에서는 디스크 그룹의 현재 상태를 표시하고 새 상태를 쉽게 선택할 수 있도록 드롭다운에 변경 사항을 제공합니다.

수정 작업

다음 옵션을 선택하거나 선택을 취소합니다(이 옵션에 대한 자세한 내용은 Oracle 설명서 참조).

  • Check All Disks

  • Repair

  • Rebalance(단독으로 사용 또는 Add/Drop/Resize Disk 명령과 함께 사용)

  • Specify power

  • Wait

Disks

그리드에 디스크를 추가하거나 그리드에서 디스크를 삭제하여 디스크 그룹을 수정할 수 있습니다.

디스크를 추가하려면

  1. Disks 탭을 누릅니다.

  2. Add를 누릅니다.

  3. 추가할 디스크를 선택한 후 OK를 누릅니다.

디스크를 삭제하려면

  1. Disks 탭을 누릅니다.

  2. 삭제할 디스크를 선택합니다.

  3. Drop을 누릅니다.

디스크를 수정하려면

  1. Disks 탭을 누릅니다.

  2. 수정할 셀을 누르고 변경합니다.

주: 일부 데이터를 수정할 수 있지만 모든 데이터를 수정할 수는 없습니다.

Templates

그리드에 템플릿을 추가하거나 그리드에서 템플릿을 삭제하여 디스크 그룹을 수정할 수 있습니다. 또한 그리드에 있는 데이터를 변경하여 템플릿을 수정할 수도 있습니다.

템플릿을 추가하려면

  1. Templates 탭을 누릅니다.

  2. Add를 누릅니다.

  3. 추가할 템플릿을 선택한 후 OK를 누릅니다.

템플릿을 삭제하려면

  1. Templates 탭을 누릅니다.

  2. 삭제할 템플릿을 선택합니다.

  3. Drop을 누릅니다.

템플릿을 수정하려면

  1. Templates 탭을 누릅니다.

  2. 수정할 셀을 누르고 변경합니다.


클라이언트 보기

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

각 디스크 그룹의 클라이언트 정보를 볼 수 있습니다.

디스크 그룹의 경우와 마찬가지로, ASM 인스턴스에 연결되면 데이터베이스 인스턴스를 통해 연결되는 경우보다 더 많은 정보가 표시됩니다.

클라이언트 정보를 보려면

  1. Database 메뉴에서 Administer|ASM Manager를 선택합니다.

  2. Connected to 드롭다운에서 Database instance(기본값) 또는 ASM instance를 선택합니다.

  3. Clients 탭을 누릅니다. 정보가 그리드 안에 표시됩니다.

  4. 필요할 경우 Refresh [image] 단추를 눌러 그리드를 새로 고칩니다.

관련 항목

ASM Manager 개요

디스크 그룹 보기


Audit Objects

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Audit Objects 창에는 선택한 데이터베이스 개체의 Audit Monitoring 옵션이 표시됩니다. 개별 개체 또는 개체 그룹의 모니터링 수준을 입력하고 수정할 수 있습니다.

Toad에서 감사 기능을 사용하려면 AUDIT_TRAIL이 DB로 설정되어 있어야 합니다.

주: 개체의 감사 매개 변수는 Schema Browser|Object Page|RHS Auditing 탭에서도 사용할 수 있습니다.

Audit Objects 도구 모음

Audit Objects 도구 모음을 사용하면 감사하는 개체를 쉽게 제어할 수 있습니다.

단추 | 명령
 | 개체 목록 지우기
 | 개체 로드
 | 활성 연결 변경
Object Type | 드롭다운 메뉴에서 감사할 개체 유형 선택
Apply Changes | 그리드의 변경 사항 적용

감사 개체 데이터 그리드를 채우려면

  1. Database 메뉴에서 Administer|Audit Objects를 선택합니다.

  2. Object Type 드롭다운에서 감사할 개체의 유형을 선택합니다.

  3. Load [image] 드롭다운을 누른 후 다음 중에서 선택합니다.

  4. Load My objects.

  5. Load Object by schema.

  6. Load Objects by Schema and Name.

관련 항목

Audit SQL/Sys Privs


개체 감사 설정

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

그리드의 특정 개체나 모든 개체에서 특정 작업에 감사를 설정할 수 있습니다.

감사는 그리드에서 약어 코드로 표시됩니다. 성공할 경우의 감사 옵션이 맨 앞에 오고 슬래시가 온 다음에 실패할 경우의 감사 옵션이 뒤에 옵니다.

옵션 | 약어
By Access | A
By Session | S
No Audit | -

따라서 감사 패턴은 다음과 같이 그리드에 표시됩니다.

A/S - 액세스별로 성공할 경우와 세션별로 실패할 경우를 감사에서 기록

감사 옵션을 설정하려면

  1. 감사 개체 그리드를 채웁니다.

  2. 감사할 개체가 포함된 행에서 수행할 감사의 열을 누릅니다.

예를 들어 Alter 명령에서 감사하려면 Alter 상자를 누릅니다. 드릴다운 단추가 나타납니다.

  3. 드릴다운 [image] 단추를 누릅니다.

  4. 명령이 성공하거나 실패할 경우에 감사할 옵션을 선택합니다.

  5. OK를 누릅니다.


Multiple Object Privileges

Multiple Object Privileges 화면에서 여러 개체에 대한 권한을 관리할 수 있습니다. 여러 개체에 대한 권한을 한 번에 부여 또는 해지할 수 있습니다.

Multiple Object Privileges를 액세스하려면

  • Tools 메뉴에서 Multiple Object Privileges를 선택합니다.

권한을 부여하려면

  • Grant 탭을 누릅니다.

권한을 해지하려면

  • Revoke 탭을 누릅니다.


여러 권한 부여

선택한 개체 또는 화면의 모든 개체에 한 번에 여러 권한을 부여할 수 있습니다.

선택한 수여자에게 개체를 모두 부여하려면

  1. Objects Owned by 드롭다운에서 부여할 개체를 소유한 스키마를 선택합니다.

  2. Grantees 영역에서 권한을 부여할 사용자 또는 역할을 선택합니다.

주: Users 및 Roles 확인란을 선택 또는 취소하여 목록을 One, The Other 또는 Both로 제한할 수 있습니다.

  3. Actions를 누르고 Grant all objects to selected grantees를 선택합니다.

  4. 개체에 부여할 권한을 선택합니다.

  5. 다음 중 하나를 누르십시오.

  6. Show SQL - 실행되기 전에 SQL 구문을 봅니다.

  7. Execute - 완료된 SQL 구문을 실행 및 부여합니다.

  8. Cancel - 아무 것도 부여하지 않고 Multiple Object Privileges 화면으로 돌아갑니다.

선택한 수여자에게 선택한 개체를 부여하려면

  1. Objects Owned by 드롭다운에서 부여할 개체를 소유한 스키마를 선택합니다.

  2. Objects 영역에서 부여할 개체를 선택합니다.

  3. Grantees 영역에서 권한을 부여할 사용자 또는 역할을 선택합니다.

주: Users 및 Roles 확인란을 선택 또는 취소하여 목록을 One, The Other 또는 Both로 제한할 수 있습니다.

  3. Actions를 누르고 Grant selected objects to selected grantees를 선택합니다.

  4. 개체에 부여할 권한을 선택합니다.

  5. 다음 중 하나를 누르십시오.

  6. Show SQL - 실행되기 전에 SQL 구문을 봅니다.

  7. Execute - 완료된 SQL 구문을 실행 및 부여합니다.

  8. Cancel - 아무 것도 부여하지 않고 Multiple Object Privileges 화면으로 돌아갑니다.


여러 권한 해지

권한을 부여할 때처럼 쉽게 여러 권한을 해지할 수도 있습니다.

권한을 해지하려면

  1. Multiple Object Privileges 화면에서 해지할 권한이 있는 개체를 소유한 스키마를 선택합니다.

  2. Revoke 탭을 누릅니다.

  3. All을 선택합니다.

또는

Objects I granted를 선택합니다.

  4. 눈금에서 해지할 권한을 선택합니다.

주: 열 머리글의 화살표를 눌러 모든 열을 기준으로 눈금을 필터링할 수 있습니다. Custom을 선택하고 필터를 설정합니다.

  5. Actions를 누릅니다.

  6. Revoke all

또는

Revoke selected를 선택합니다.


Oracle Parameters

Oracle Parameters를 사용하면 System Modifiable 및 Session Modifiable 옵션을 수정하거나 편집할 수 있습니다.

DBA|Oracle Parameters 메뉴 항목에서 이 창에 액세스합니다. 그리드에서는 선택한 세션의 Oracle 매개 변수에 대한 정보가 제공됩니다.

주: 이 옵션을 사용하려면 일부 V$ 테이블에 대한 액세스 권한이 필요합니다. 이러한 사용 권한 목록을 보려면 Oracle Parameters를 참조하십시오.

매개 변수를 변경할 때 다음이 제공됩니다.

매개 변수 도구 모음

단추 | 명령
 | 활성 세션을 변경합니다.
 | 그리드 데이터를 새로 고칩니다.
 | 매개 변수를 편집합니다.
 | 매개 변수 그리드를 인쇄합니다.
 | 그리드를 저장합니다.
Default | Default 열 내용에 따라 그리드를 Yes, No 또는 All로 신속하게 필터링하려면 이 드롭다운을 사용합니다.
Single Grid | Oracle RAC 데이터베이스에 연결될 때 Toad에서 단일 그리드를 표시하는지 아니면 다중 그리드를 표시하는지 여부를 전환합니다. 단일 그리드 보기에서는 더 쉽게 알아볼 수 있도록 먼저 옵션의 기본값으로 정렬한 다음 인스턴스 이름으로 정렬합니다. 다중 그리드 보기를 선택한 경우 각 RAC 인스턴스에 대한 별개의 탭이 표시됩니다.


매개 변수 문자열 보기

매개 변수 문자를 쉽게 찾아서 볼 수 있습니다.

매개 변수 설정 보기

Quest DBA module이 없으면 매개 변수를 볼 수는 있지만 변경할 수는 없습니다.

매개 변수 설정을 보려면

  • 보려는 매개 변수를 두 번 누릅니다.

매개 변수 설정 검색

매개 변수 문자열을 검색하는 방법에는 몇 가지가 있습니다. 예를 들면 다음과 같습니다.

  • 증분 검색을 사용하여 그리드의 열에서 특정 Oracle 설정을 검색할 수 있습니다.

  • QuickFilter를 사용하여 그리드를 필터링할 수 있습니다.

증분 검색을 사용하여 매개 변수 설정을 찾으려면

  1. 찾으려는 매개 변수를 설명하는 열을 누릅니다.

  2. 찾으려는 항목의 처음 몇 글자를 입력합니다. 문자를 입력하면 커서가 해당 항목으로 이동합니다.

관련 항목

Oracle 매개 변수

매개 변수 문자열 변경


매개 변수 문자열 변경

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

매개 변수를 세션과 시스템 모두에서 수정할 수 있는 경우, Toad는 시스템 수준에서 수정합니다. 매개 변수 설정을 개별적으로 변경할 수 있습니다.

RAC 기반 데이터베이스를 사용하는 경우에는 변경 사항을 모든 인스턴스에 적용할 것인지 또는 현재 인스턴스에만 적용할 것인지 선택할 수도 있습니다.

마우스를 사용하여 설정을 변경하려면

  1. 변경할 매개 변수를 두 번 누릅니다.

또는

변경할 매개 변수를 누릅니다. 그리드의 해당 줄이 강조표시되면 Alter Parameter Setting [image] 단추를 누릅니다.

  2. 설정을 변경하고 OK를 누릅니다.

키보드를 사용하여 설정을 변경하려면

  1. 변경할 매개 변수를 두 번 누릅니다.

  2. 설정을 변경하고 OK를 누릅니다.

주: 일부 매개 변수에는 변경이 허용되지 않을 수도 있습니다. 그러한 매개 변수를 눌러도 Change Parameter Setting 단추는 사용할 수 없는 상태로 유지됩니다.

관련 항목

Oracle 매개 변수

매개 변수 문자열 보기


View Tablespaces

이 대화 상자를 사용하면 테이블 공간 정보를 볼 수 있습니다.

테이블 공간 정보를 보려면

  • Database 메뉴에서 Administer|Tablespaces를 선택합니다.

주: 이 기능을 사용하려면 DBA_ Oracle 사전 보기에 대한 SELECT 액세스가 필요합니다. 액세스가 없으면 "This function requires access to: dba_free_space, dba_data_files, and dba_tablespaces"라는 오류 대화 상자가 나타납니다.

  • 세션을 변경하고 다른 테이블 공간을 보려면 Change Session 단추를 누르고 다른 세션 또는 새 세션을 선택합니다.

  • 정보에 대한 가로 방향 하드 카피 보고서를 출력하려면 Printer 단추를 누릅니다.

  • 적당한 개체를 선택한 후 <F4>를 눌러 설명을 수행합니다.

  • Space 또는 Data Files 탭에서 테이블 공간을 두 번 눌러 해당 테이블 공간에 대한 자세한 내용을 봅니다. (주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.) Tablespace Details를 참조하십시오.

이 대화 상자에는 Space, Data Files, Free Space (in KB), Objects, Fragmentation, Space History 및 IO History라는 7개의 정보 탭이 있습니다.

주: Space, Space History 및 IO History 탭은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

이러한 각각의 탭에서 정보를 오름차순으로 정렬하려면 원하는 열 헤더를 누릅니다. 내림차순으로 정렬하려면 같은 열 헤더를 한 번 더 누릅니다. 두 열 제목 사이에 있는 구분 표시(마우스 포인터가 왼쪽 및 오른쪽 화살표가 있는 수직선 모양으로 바뀜)를 두 번 누르면 데이터 너비에 맞게 열 크기가 조정됩니다.

Space

각 테이블 공간을 Usage, Size Mgs, Free Mgs, Used Mgs, Free Pct 및 Used Pct 등 이름별로 나열합니다.

Data Files

각 테이블 공간을 Status, Used MB, Free MB, Initial Extent, Next Extent, Min Extents, Max Extents, Percent Increase 및 Filename 등 이름별로 나열합니다.

Free Space (in KB)

각 테이블 공간을 Blocks, Min, Average, Max 및 Total 등 이름별로 나열합니다.

Objects

드롭다운 목록에서 테이블 공간을 선택합니다. Toad에서 Owner, Object Name, Object Type, Size (MB), Initial Extent, Next Extent, Num Extents 및 Size (bytes) 등 선택한 테이블 공간 안에 포함된 모든 개체를 표시합니다.

totals of Size (MB), Num Extents 및 Size (bytes)가 목록 맨 아래에 있는 "TOTAL SIZE" 행에 나열됩니다.

Fragmentation

이 탭은 총 블록 수, 빈 블록 수, 존재하는 조각 수, 조각 크기(최대, 최소 및 평균) 및 상한값보다 낮은 범위 개수 등 테이블 공간의 조각화에 대해 설명합니다.

Space History

Space History 탭에서 Space Manager는 시간에 따른 데이터베이스 사용을 추적하여 결과를 읽기 쉽고 구성하기 쉬운 그래프 형식으로 표시합니다.

자세한 내용은 Space Manager 사용을 참조하십시오.

IO History

Space History 탭에서 Space Manager는 시간에 따른 데이터 파일 사용을 추적하여 결과를 읽기 쉽고 구성하기 쉬운 그래프 형식으로 표시합니다. 자세한 내용은 Space Manager 사용을 참조하십시오.


Tablespace Details

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Tablespace Details 창에는 Schema Browser|Tablespaces 탭에 있는 것과 동일한 정보가 표시됩니다. 그러나 고유한 창에 표시되기 때문에 스크롤 없이 대부분의 그리드를 볼 수 있습니다.

Tablespace Details에 액세스하려면

  • View Tablespaces 창의 Space 또는 Data Files 탭에서 테이블 공간을 두 번 누릅니다. Tablespace Details 창이 나타납니다.

탭

Tablespace Details 창의 각 탭에는 테이블 공간에 대한 다른 유형의 정보가 표시됩니다.

Datafiles

각 파일에 있는 파일 수, 사용 그래프, 사용 비율 등과 같은 파일에 대한 일반 정보를 나열합니다.

Free Space

데이터 파일의 여유 공간 매개 변수에 대한 통계를 표시합니다.

Fragmentation

파일 수와 이러한 파일의 일반 단편화에 대한 정보(예: 조각 수, 단편의 크기, 나머지 빈 블록 수 등)를 표시합니다.

Objects

데이터 파일에 있는 모든 개체의 목록과 관련 통계를 표시합니다.

Quotas

선택한 데이터 파일에 대한 사용자별 할당량 및 공간 사용 통계를 목록으로 표시합니다.

Extents

익스텐트에 대한 세그먼트, 소유자 및 ID 번호 목록을 표시합니다.


Space Manager 설정

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Toad Space Manager는 View Tablespaces 창의 일부분입니다. Space Manager를 사용하려면 TOAD 스키마에 특정 개체가 있어야 합니다.

Space Manager에 액세스하려면

이 옵션을 사용하려면 여러 V$ 테이블에 대한 SELECT 권한이 있어야 합니다. 필요한 사용 권한 목록을 보려면 Space Manager 설정을 참조하십시오.

  1. Database 메뉴에서 Administer|Tablespaces를 선택합니다. Tablespaces 창이 나타납니다.

  2. Space Manager는 Tablespaces 창에 있는 마지막 두 개의 탭인 Space History 및 IO History로 구성됩니다. 이러한 탭 중 하나를 눌러 Space Manager에 액세스합니다.

Space Manager를 설정하려면

Space Manager를 사용할 수 있으려면 Toad 스키마에서 특정 개체를 설정해야 합니다.

  1. Create/Recreate Toad Space Manager Tables 단추 [image] 를 누릅니다. Toad 스키마 아래에서 로그인하지 않은 경우 다음 대화 상자가 나타납니다.

  2. OK를 누른 다음 Toad 스키마 아래에서 로그인합니다.

주: Toad 스키마에는 작업을 작성 및 변경하고 고유한 테이블과 프로시저를 작성 및 삭제할 수 있는 권한과 DBA_TABLESPACES, DBA_DATA_FILES, DBA_FREE_SPACE 및 V_$FILESTAT에 대한 SELECT 권한이 있어야 합니다.

  3. Toad schema의 View Tablespaces에서 Create/Recreate Toad Space Manager Tables 단추 [image] 를 누릅니다. Space Manager 테이블이 이미 있는 경우 확인 대화 상자가 나타납니다. Yes를 선택하면 모든 기존 데이터가 손실됩니다.

Yes를 누릅니다.

  4. Collection Status 영역에는 기존 Space Manager 작업의 상태인 Active, Inactive 또는 Not Present가 표시됩니다. Space Manager 테이블이 다시 만들어지면 필요한 경우 작업이 만들어지거나 활성화됩니다.

  5. 수집 일정 정보를 설정합니다.

  6. 작업을 실행할 시작 날짜를 입력합니다. 드롭다운을 눌러 달력을 표시하거나 편집 상자에서 날짜와 연도를 직접 편집합니다. 수집 작업이 없을 경우 기본값은 이후 몇 분입니다. 수집 작업이 활성 상태인 경우 기본값은 기존 수집 작업의 다음 실행 날짜입니다. 수집 작업이 비활성 상태인 경우 기본값은 이후 몇 년입니다(Oracle에서 기존 작업의 다음 실행 날짜로 저장하는 값).

  7. At this time: 필드에 데이터 수집을 수행할 시간을 입력합니다.

  8. 정보를 수집할 빈도를 결정합니다. 다음을 수행할 수 있습니다.

  9. At this time: 필드 아래의 드롭다운 메뉴에서 항목을 선택합니다.

  10. 또는 Execute this job on: 필드 아래의 필드에 수식을 직접 입력할 수 있습니다. 작업이 실행된 후 Toad에서는 항상 이 수식을 사용하여 다음 실행 날짜를 계산합니다.

주: 이러한 필드에 입력한 수식에 상관없이 Space Manager는 매일 두 번 이상 정보를 수집할 수 없습니다.

  6. History Retention information을 설정합니다. 슬라이딩 스케일을 사용하여 정보를 유지할 기간을 선택합니다. Days, Weeks 또는 Months에 대한 적절한 선택 항목을 누릅니다.

  7. Data initialization information을 설정합니다.

  • Start with empty tables - 첫 번째 수집에서만 데이터가 제공됩니다. 기록을 채우려고 시도하지 않습니다.

  • Back fill tables with generated values indicating positive growth - 생성된 기록과 함께 데이터가 제공됩니다. 이 기록은 Toad에 의해 만들어지고 시간이 지남에 따라 공간 사용이 증가함을 나타냅니다.

Toad에서는 Space Manager 기록을 유지 관리하기 위해 필요한 테이블을 만듭니다. 이러한 테이블의 정보는 Space Manager 탭에 표시되는 그래프에 대한 기초를 제공합니다.

Space Manager 설정 정보를 편집하려면

설정할 때와 비슷한 방법으로 Space Manager 정보를 편집할 수 있습니다. 수집 작업이 삭제된 경우 Collection Status가 Not Present로 표시됩니다. Space Manager 설정을 변경하면 작업이 다시 만들어집니다.

  1. Toad 스키마 아래에서 로그인해야 합니다. DBA 메뉴에서 Tablespaces를 선택합니다. Tablespace 창이 나타나면 Space History 또는 IO History 탭을 누릅니다.

  2. Edit Space Manager 단추 [image] 를 누릅니다. 위의 Space Manager 설정에 설명된 대로 정보를 변경한 다음 OK를 누릅니다.


Space Manager 사용

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Toad Space Manager는 View Tablespaces 창의 일부입니다. Space Manager를 사용하려면 TOAD 스키마에 특정 테이블이 작성되어 있어야 합니다. Space Manager에서는 이러한 테이블을 자동으로 추가할 수 있습니다. 이러한 테이블을 TOAD 스키마에 추가하려면 Space Manager 설정을 참조하십시오.

Space Manager는 시간에 따른 데이터베이스 사용을 추적하여 결과를 읽기 쉽고 구성하기 쉬운 그래프 형식으로 표시합니다.

Space Manager에 액세스하려면

Space Manager 창을 보려면 DBA 권한이 있어야 합니다.

  1. Database 메뉴에서 Administer|Tablespaces를 선택합니다. View Tablespace 창이 나타납니다.

  2. Space Manager는 View Tablespace 창의 마지막 두 탭인 Space History와 IO History로 구성됩니다. 이 탭 중 하나를 눌러 Space Manager에 액세스합니다.

Space History 탭

Space History 탭에서는 사용 상황을 몇 가지 다양한 방법으로 그래프에 표시할 수 있습니다. 또한 그래프를 인쇄하고 향후 사용 상황을 예측할 수도 있습니다.

사용 그래프

Space History 탭의 그래프에는 테이블 공간 사용 상황이 표시됩니다. 테이블 공간 그래프는 다양한 구성으로 표시할 수 있습니다.

  • 모든 테이블 공간 보기 - By datafile 상자를 선택 취소하고 Tablespaces 드롭다운에서 <All>을 선택합니다.

  • 특정 테이블 공간 선택 - By datafile 상자를 선택 취소하고 드롭다운 Tablespaces: 메뉴에서 tablespace를 선택합니다.

  • 데이터 파일별로 테이블 공간 보기 - By datafile 상자를 선택하고 드롭다운 Datafile 메뉴에서 Datafile을 선택합니다.

  • 모든 데이터 파일 보기 - By datafile 상자를 선택하고 두 드롭다운 모두에서 <All>을 선택합니다.

그래프에 선이 너무 많아서 색이 엉켜 보이는 경우가 있습니다. 이제 특정 선을 쉽게 찾을 수 있습니다.

한 선을 찾으려면

  1. 범례에서 테이블 공간을 누르고 보고 싶은 선을 강조표시합니다.

  2. 선을 눌러 강조표시합니다.

  3. 마우스를 선 위로 이동합니다. 상태 표시줄에 테이블 공간 이름과 날짜 및 그 날짜에 해당하는 # mb 값이 표시됩니다. 예를 들면 다음과 같습니다.

SYSTEM (12/11/2002, 123 mb)

사용 예측

Forecasting 도구를 사용하여 테이블 공간과 데이터 파일의 사용을 예측할 수 있습니다. 앞으로의 일 수를 설정하면 Toad에서 선형 회귀(경사나 추세에 따라 선을 연장)를 사용하여 지정된 시간의 테이블 공간 및 데이터 파일 공간 사용을 추정합니다.

사용을 예측하려면

  1. 위의 사용 그래프에서 설명한 것과 같이 예측할 그래프를 작성합니다.

  2. Space Manager 도구 모음에서 Forecast 단추 [image] 를 누릅니다. Forecast 창이 나타납니다.

  3. Forecast 창 아래쪽에서 예측할 미래의 일 수(기본값은 30)를 선택할 수 있습니다. 예상 MB 수가 나타나고 일 수를 변경하면 그래프가 그에 따라 변경됩니다.

  4. 예측을 인쇄하려면 Print를 누릅니다.

  5. OK를 눌러 Forecast 창을 닫습니다.

확대/축소

그래프를 확대하고 스크롤할 수 있습니다.

그래프를 확대/축소하려면

  • 원하는 그래프를 마우스 오른쪽 단추로 누르고 Zoom을 선택합니다. 그래프가 새 창에 나타납니다. 이 창을 스크롤하여 그래프의 더 많은 부분을 볼 수 있습니다.

그래프 인쇄

원하는 그래프 보기를 선택하고 나면 그래프 위의 도구 모음을 사용하여 인쇄할 수 있습니다.

그래프를 인쇄하려면

  • Print 아이콘 [image] 을 누르면 그래프가 프린터로 바로 전송됩니다.

IO History 탭

추적 정보

Space Manager의 IO History 부분에서는 데이터 파일 I/O 기록을 추적합니다. 여기서는 다음 정보를 그래프로 표시합니다.

  • 물리적 읽기

  • 물리적 쓰기

  • 블록 읽기

  • 블록 쓰기

  • 읽기 시간

  • 쓰기 시간

데이터 파일 선택

  • 탭 맨 위에 있는 드롭다운 메뉴를 누르고 목록에서 해당 데이터 파일(또는 All Datafiles)을 선택하는 방식으로 데이터 파일을 선택합니다. 그래프가 즉시 바뀌어 새 데이터 파일의 정보를 표시합니다.

확대/축소

그래프를 확대하고 스크롤할 수 있습니다.

그래프를 확대/축소하려면

  • 원하는 그래프를 마우스 오른쪽 단추로 누르고 Zoom을 선택합니다. 그래프가 새 창에 나타납니다. 이 창을 스크롤하여 그래프의 더 많은 부분을 볼 수 있습니다.

그래프 인쇄

원하는 그래프 보기를 선택하고 나면 탭 위의 도구 모음을 사용하여 인쇄할 수 있습니다.

그래프를 인쇄하려면

  • Print 아이콘 [image] 을 누르면 그래프가 프린터로 바로 전송됩니다.


창: Redo Log Manager

Redo Log Manager

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Oracle 백그라운드 프로세스 로그 기록기(LGWR)는 다시 실행 로그 파일에 데이터베이스 변경 내용에 대한 정보를 저장합니다. 이러한 파일을 사용하면 변경 사항을 다시 적용하여 실패 시 데이터베이스를 복구할 수 있습니다. 다시 실행 레코드가 SGA의 다시 실행 로그 버퍼에 저장된 후 버퍼가 다 찼거나 관련 트랜잭션이 커밋될 때 다시 실행 로그에 기록됩니다.

DBA에서는 동일한(같은 크기의) 다시 실행 로그의 "groups"를 정의하므로 LGWR에서는 그룹의 각 구성원에 대해 동일한 정보를 동시에 기록하고 순환 방식으로 그룹 간에 전환합니다. 그룹 내의 각 다시 실행 로그를 "member"라고 합니다. 하나의 그룹을 활성화하면서 다른 그룹을 보관할 수 있도록 Oracle 데이터베이스에는 두 개 이상의 그룹이 있어야 합니다(ARCHIVELOG 모드인 경우).

아래쪽 패널은 다음에서 설명한 대로 선택한 그룹의 구성원을 표시합니다.

위쪽 패널

위쪽 패널은 그룹 및 그룹 관련 정보를 한 번에 표시합니다.

팁: 현재 그룹은 파란색으로 강조표시됩니다.

로그 그룹의 균형이 맞지 않으면 Members 열이 빨간색으로 표시되며 그리드 위에 수정 제안이 표시됩니다. 또한 도구 모음을 사용하여 다음을 수행할 수 있습니다.

단추 | 명령
 | 세션 변경
 | 화면 다시 고침
 | 로그 그룹 추가
 | 선택한 로그 그룹 삭제
 | 선택한 로그 그룹 지우기
 | 로그 전환
 | 시스템 보관 로그 수정

아래쪽 패널

아래쪽 패널에는 각 로그 그룹의 구성원에 대한 세부 정보가 있습니다. 도구 모음에서 각 구성원에 액세스하거나 구성원을 변경 또는 삭제할 수 있습니다.

단추 | 명령
 | 그리드 새로 고침
 | 로그 그룹 구성원 추가
 | 로그 그룹 구성원 삭제

관련 항목

다시 실행 로그 그룹 분산


로그 그룹 분산

다시 실행 로그 그룹 분산

각 다시 실행 로그 "group"에는 동일한 수의 "members"가 있어야 합니다. 즉, 다시 실행 로그 파일은 모두 서로 크기가 같아야 합니다.

위 조건 중 하나가 충족되지 않으면 항목은 분산되지 않은 것으로 간주되어 빨간색으로 표시됩니다. 예를 들면 다음과 같습니다.

이 예에서는 그룹 4의 구성원 조건이 충족되지 않습니다. 다른 그룹에는 각각 구성원이 2개씩 있지만 그룹 4에는 구성원이 하나 뿐입니다.

아래쪽 패널의 그리드 아래에 있는 Add 단추를 사용하여 구성원을 하나 더 추가합니다.

이제 Members 그리드가 다음과 같이 전부 검정색으로 표시됩니다.

관련 항목

Redo Log Manager


데이터 비교

Toad의 Compare Data 마법사를 사용하여 다른 스키마 또는 데이터베이스 내에서 표 데이터를 비교할 수 있습니다. 예를 들어, 생산 및 테스트 환경에서 데이터를 비교할 때 도움이 됩니다.

이 작업은 다음의 6가지 단계를 통해 이루어집니다.

  • 데이터 원본 선택

  • 성능 옵션 선택

  • 비교할 열 선택

  • "order by" 명령 지정

  • 행 개수 검토

  • 차이 검토

  • 개체 2가 아닌 개체 1의 행

  • 개체 1이 아닌 개체 2의 행

  • 모든 차이

전체적으로 다음 단추를 눌러 마법사를 통해 이동할 수 있습니다.

  • Start - 마법사의 시작으로 돌아갑니다. 설정한 내용이 삭제되지 않습니다.

  • Back - 한 단계 이전으로 이동합니다.

  • Next - 다음 단계로 이동합니다.


데이터 원본 선택

Compare Data 마법사의 첫 번째 창에서 데이터 원본을 선택할 수 있습니다. 데이터 원본은 로컬 또는 원격 원본에서 Database Link에 의해 연결될 수 있습니다.

데이터 원본을 선택하려면

  1. 첫 번째 데이터 원본이 원격 데이터일 경우 Use DB Link 상자의 드롭다운 메뉴에서 기존의 DB 링크를 선택합니다.

첫 번째 데이터 원본이 로컬 데이터일 경우 이 상자를 공란으로 둡니다.

  2. 비교할 개체 형식을 선택합니다. 표, 보기 및 스냅샷이 지원됩니다.

  3. Object Owner 드롭다운 메뉴에서 개체를 소유한 스키마를 선택합니다.

  4. Object Name 목록에서 Object Name을 선택합니다.

  5. 선택한 개체에 고유 색인이 있으면 기록됩니다.

  6. 필요한 경우 "Where" 절을 입력하여 데이터를 제한합니다.

  7. Next를 눌러 성능 옵션 선택 작업을 계속하십시오.

관련 항목

데이터 비교

성능 옵션 선택

비교할 열 선택

"order by" 명령 지정

행 개수 검토

차이 검토


성능 옵션 선택

Compare Data 마법사의 이 창에서 성능 옵션을 설정할 수 있습니다. 이러한 옵션은 다음과 같습니다.

Sort area size

영역 크기를 정렬하면 Database Link를 통과하는 질의만 영향을 받습니다.

기본값은 선택되어 있지 않습니다.

선택되어 있을 경우

  • 기본 영역 크기는 10MB입니다.

  • 첫 번째 창이 닫히면 다른 정렬 영역 크기를 설정하기로 선택할 수 있습니다. 이 옵션의 기본값 또한 10MB입니다.

Optimizer Hints

Use Full Table Scan hint

기본값으로 표시되어 있습니다.

Use Parallel hint

기본값으로 표시되어 있지 않습니다. 선택되어 있으면 원하는 병렬 처리의 양을 설정할 수 있습니다. 이 옵션의 기본값은 4입니다.

관련 항목

데이터 비교

데이터 원본 선택

비교할 열 선택

"order by" 명령 지정

행 개수 검토

차이 검토


비교할 열 선택

Compare Data 마법사의 이 창에는 두 개의 데이터 원본을 비교할 수 있는 열 목록이 제공됩니다.

열은 다음 색상별로 구분됩니다.

  • 검정색 - 양쪽 원본에 열이 나타나며 비교할 수 있습니다.

  • 빨간색 - 열을 비교할 수 없습니다.

  • 자주색 - 원본 1에만 열이 나타납니다.

  • 청록색 - 원본 2에만 열이 나타납니다.

열을 선택하려면

  • 비교할 열의 옆에 있는 확인란을 누릅니다.

관련 항목

데이터 비교

데이터 원본 선택

성능 옵션 선택

"order by" 명령 지정

행 개수 검토

차이 검토


Order By 지정

Compare Data 마법사의 이 창에서 ORDER BY 절을 적용할 열을 지정할 수 있습니다.

ORDER BY 절을 지정하려면

  1. 순서를 정할 기준 열을 두 번 누릅니다.

  2. Asc/Desc 열을 두 번 눌러 Ascending 또는 Descending에서 변경합니다.

  3. Reset을 눌러 열을 지우고 다시 시작합니다.

관련 항목

데이터 비교

데이터 원본 선택

성능 옵션 선택

비교할 열 선택

행 개수 검토

차이 검토


행 개수 검토

Compare Data 마법사의 이 창에서 다양한 개체의 행 개수를 검토할 수 있습니다.

데이터 원본으로 사용한 각 개체의 경우 행 개수를 구할 수 있습니다.

행 개수를 검토하려면

  1. Show SQL을 눌러 행 개수에 사용한 SQL을 확인합니다. Show SQL 대화상자에서 SQL을 클립보드에 복사하거나 파일로 저장할 수 있습니다.

  2. Execute를 눌러 행 개수를 실행합니다.

관련 항목

데이터 비교

데이터 원본 선택

성능 옵션 선택

비교할 열 선택

"order by" 명령 지정

차이 검토


차이 검토

Compare Data 마법사의 최근 세 개의 창에서 데이터 원본 간의 차이를 검토할 수 있습니다.

  • 첫 번째 창은 원본 2에 없는 원본 1의 행을 검토합니다.

  • 두 번째 창은 원본 1에 없는 원본 2의 행을 검토합니다.

  • 마지막 창은 모든 차이를 검토합니다.

아래에 설명된 대로 각 창에 SQL 코드를 실행해야 합니다.

편집 가능한 데이터 집합

눈금 내에서 데이터 집합을 편집할 수 있습니다. 일부 Toad 버전에서는 하나의 표에서 삭제한 행을 눈금의 다른 표로 삽입할 수 있습니다.

데이터 집합을 편집할 수 있도록 하려면

  • Review Differences 페이지에서 Editable Dataset 확인란을 선택합니다.

행을 검토하려면

  1. 필요한 단계를 다음과 같이 모두 수행합니다.

  • View/Edit SQL 단추를 눌러 차이 비교에 사용한 SQL을 보거나 편집합니다. Edit SQL 대화상자에서 변경할 수 있습니다.

  2. Check를 눌러 질의가 올바르게 분석되는지 확인합니다.

  3. OK를 눌러 질의의 변경 내용을 적용합니다.

  4. Execute를 눌러 비교할 열의 차이를 찾습니다.

선택한 행을 삭제하려면

  1. 삭제할 행을 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Delete Selected Rows를 선택합니다.

모든 행을 삭제하려면

  • 마우스 오른쪽 단추를 누르고 Delete All Rows를 선택합니다.

관련 항목

데이터 비교

데이터 원본 선택

성능 옵션 선택

비교할 열 선택

"order by" 명령 지정

행 개수 검토


Compare Databases

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

이 창을 사용하면 두 데이터베이스를 비교하고 원본 참조 소스에서 비교 소스로 변경된 사항을 확인할 수 있습니다.

데이터베이스를 비교하려면

  1. Database 메뉴에서 Compare|Compare Databases를 선택합니다.

  2. Databases 및 Objects & Options 탭에서 필요한 사항을 선택한 후 Compare를 눌러 Results 탭을 표시합니다.

또는 Options 탭에서 Save all settings to file 단추를 누른 후 나중에 명령줄에서 비교를 실행할 수도 있습니다. 명령 프롬프트에서 Compare Databases 실행 을 참조하십시오.

  3. 결과 가 Results 탭에서 액세스할 수 있는 페이지에 표시됩니다.

Databases 탭

Reference Source와 Comparison Source를 선택합니다. 라디오 단추를 사용하면 Database 또는 Definition File을 선택할 수 있습니다.

Database

사용 중인 데이터베이스를 직접 비교하려면 Database를 선택합니다.

Database를 선택한 경우에는 Connection과 Schema를 모두 선택합니다.

Definition File

저장된 정의 파일과 비교하려면 Definition File을 선택합니다. 이 옵션은 변경되지 않는 데이터베이스가 있거나 다양한 데이터베이스를 특정 템플릿에 맞게 하려는 경우에 유용합니다.

주: 정의 파일 작성에 대한 자세한 내용은 데이터베이스 스크립트 생성을 참조하십시오.

Objects and Options 탭

페이지를 마우스 오른쪽 단추로 눌러 모든 선택 항목을 선택하거나 선택 취소할 수 있습니다.

Objects

비교할 개체를 선택합니다. Specify Object Set를 선택하면 Object Set 탭이 나타납니다.

Options

확인란을 사용하면 옵션을 선택할 수 있고, 맨 아래 상자에는 동기화 파일의 파일 이름을 입력할 수 있습니다. 대부분의 옵션은 자명하거나 Oracle과 관련되어 있습니다.

"Safe Drop" on users, tblspaces, and profiles

이 옵션은 기본적으로 선택되어 있습니다.

"Safe Drop" on users, tblspaces and profiles가 선택되어 있는 경우

  • 마이그레이션 스크립트의 DROP USER 문에 CASCADE 키워드가 포함되지 않습니다.

  • CASCADE가 포함되지 않으면 스크립트에서는 사용자에게 개체가 없는 경우에만 사용자를 삭제할 수 있습니다.

  • 마이그레이션 스크립트의 DROP PROFILE 문에 CASCADE 키워드가 포함되지 않습니다.

  • CASCADE가 포함되지 않으면 스크립트에서는 사용자가 프로파일에 없는 경우에만 프로파일을 삭제할 수 있습니다.

  • 마이그레이션 스크립트의 DROP TABLESPACE 문에 INCLUDING CONTENTS 키워드 또는 AND DATAFILES(9i 이상인 경우) 키워드가 포함되지 않습니다.

  • INCLUDING CONTENTS가 포함되지 않으면 스크립트에서는 개체가 테이블 공간에 없는 경우에만 테이블 공간을 삭제할 수 있습니다.

"Safe Drop" on users, tblspaces and profiles가 선택되지 않은 경우

  • 마이그레이션 스크립트의 DROP USER 문에 CASCADE 키워드가 포함됩니다.

  • 마이그레이션 스크립트의 DROP PROFILE 문에 CASCADE 키워드가 포함됩니다.

    • CASCADE가 포함되면 삭제된 프로파일이 있는 사용자가 모두 DEFAULT 프로파일에 다시 할당됩니다.

  • 마이그레이션 스크립트의 DROP TABLESPACE 문에 INCLUDING CONTENTS 키워드, 및 AND DATAFILES 키워드(9i 이상인 경우)가 포함됩니다.

개체 집합

두 개의 데이터베이스를 선택하고 Objects and Options 탭에서 개체를 선택한 후에 개체 집합을 로드할 수 있습니다.

개체 집합을 로드하려면

  1. Load Object Set [image] 단추를 누릅니다.

  2. 비교에 포함할 개체의 확인란을 선택합니다.


데이터베이스 비교 결과

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Results in General

데이터베이스 비교의 결과에는 두 번째 데이터베이스를 참조 데이터베이스와 같은 모양으로 만드는 데 필요한 변경 내용이 표시됩니다. 따라서 데이터베이스의 순서를 반대로 할 경우 "누락"된 것으로 보고되는 개체 수가 다를 수 있습니다.

Compare Database 창의 가운데에 있는 Switch [image] 단추를 눌러 데이터베이스의 순서를 전환할 수 있습니다.

Results (Interactive)

데이터베이스 간의 차이가 대화형 형식으로 자세하게 목록에 표시됩니다. 차이는 세 개의 그룹으로 구분됩니다. 각 항목 유형에는 할당된 아이콘이 있으므로 해당하는 개체가 무엇인지 쉽게 파악할 수 있습니다.

아이콘 | 정의
 | 다른 개체
 | 참조 소스에 있지만 비교 소스에 없는 개체
 | 비교 소스에 있지만 참조 소스에 없는 개체

오른쪽 단추 메뉴

오른쪽 단추 메뉴를 사용하여 여러 서식 옵션과 인쇄 미리 보기 화면 및 마이그레이션 SQL 대화 상자에 쉽게 액세스할 수 있습니다.

  • Tree Style - 보려는 트리 스타일의 유형으로 Outlook 또는 Standard를 선택할 수 있습니다.

  • Group by Object - 또한 이러한 그룹 내의 항목이 유형에 따라 그룹화됩니다. Results(Interactive) 탭을 마우스 오른쪽 단추로 누르고 Group by Object를 선택합니다. 이제 항목이 유형에 따라 그룹화되므로 쉽게 볼 수 있습니다. 각 유형의 항목에는 할당된 아이콘이 있습니다.

개체 형식에 따라 항목을 그룹화한 경우 트리 보기를 확장 및 축소하는 데 사용할 수 있는 단추가 도구 모음에 표시됩니다.

아이콘 | 의미
 | 첫 번째 수준으로 확장
 | 모두 확장
 | 모두 축소

  • Save to Text file - 텍스트 파일에 비교를 저장할 수 있습니다. Results (Interactive) 탭에서 마우스 오른쪽 단추를 누르고 Save to Text file을 선택합니다.

Show Migration SQL

선택한 개체에 대한 마이그레이션 SQL을 표시할 수 있습니다.

  1. 개체를 눌러 선택합니다. <Ctrl> 또는 <Shift> 키를 누른 채로 여러 항목을 선택할 수 있습니다.

  2. 탭의 맨 위에서 Show SQL을 누릅니다. 선택한 항목만 마이그레이션하기 위해 Sql Statement 대화 상자에 SQL이 표시됩니다. 이 SQL을 클립보드에 복사하거나 파일에 직접 저장할 수 있습니다.

주의: 이 SQL은 비교 데이터베이스를 변경하도록 디자인되었습니다. 따라서 이 SQL을 실행하기 전에 중요한 데이터가 손실되지 않는지 확인해야 합니다.

Results (RTF)

이 탭에는 비교가 목록 형식으로 표시됩니다. 도구 모음을 사용하여 다음을 수행할 수 있습니다.

  • 모든 서식이 유지된 상태에서 RTF 파일로 저장

  • 모든 서식이 손실된 상태에서 텍스트 파일로 저장

  • 파일을 프린터에서 인쇄

Results (Summary)

여기에는 부여를 위한 전체 삭제와 같은 다른 요소에 대한 비교 총계가 표시됩니다. 도구 모음을 사용하여 다음을 수행할 수 있습니다.

  • 모든 서식이 유지된 상태에서 RTF 파일로 저장

  • 모든 서식이 손실된 상태에서 텍스트 파일로 저장

  • 파일을 프린터에서 인쇄

Sync Script

비교 소스 데이터베이스를 참조 소스 데이터베이스로 변환하기 위한 스크립트가 제공됩니다.

예를 들어 참조 데이터베이스에 개체가 하나만 있고 비교 데이터베이스에 개체가 여러 개 있는 경우 작성된 마이그레이션 스크립트는 하나를 제외한 모든 개체를 삭제하여 거의 빈 데이터베이스로 둡니다.

또한 도구 모음에서는 다음 옵션이 제공됩니다.

  • 모든 서식이 유지된 상태에서 스크립트를 RTF 파일로 저장

  • 모든 서식이 손실된 상태에서 스크립트를 텍스트 파일로 저장

  • 스크립트 인쇄

  • 스크립트를 편집기 창으로 이동하고 실행하지 않음

  • 스크립트를 편집기 창으로 이동하고 즉시 실행


Compare Schemas

이 창을 사용하면 두 스키마를 비교하고 원본 참조 소스에서 비교 소스로 변경된 사항을 확인할 수 있습니다.

스키마를 비교하려면

  1. Database 메뉴에서 Compare|Compare Schemas를 선택합니다.

  2. Schema 및 Options 탭에서 필요한 사항을 선택한 후 Compare 를 눌러 Results 탭을 표시합니다.

또는 Options 탭에서 Save all settings to file 단추를 누른 후 나중에 명령줄에서 비교를 실행할 수도 있습니다. 명령 프롬프트에서 Compare Schemas 실행 을 참조하십시오.

Schemas 탭

Reference Source와 Comparison Source를 선택합니다.

라디오 단추를 사용하면 Schema 또는 Definition File을 선택할 수 있습니다.

Schema

Schema를 선택한 경우에는 Connection과 Schema를 모두 선택합니다.

Definition File

저장된 정의 파일과 비교하려면 Definition File을 선택합니다. 이 옵션은 변경되지 않는 스키마가 있거나 다양한 스키마를 템플릿에 맞게 하려는 경우에 유용합니다.

주: 정의 파일을 비교하는 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다. 정의 파일 작성에 대한 자세한 내용은 Generate Schema Script를 참조하십시오.

Options 탭

확인란을 사용하면 옵션과 비교할 개체 유형을 선택할 수 있습니다. Options 탭을 마우스 오른쪽 단추로 눌러 모든 개체 유형을 선택하거나 선택 취소할 수 있습니다.

Results in General

스키마 비교 결과에는 두 번째 스키마를 참조 스키마처럼 보이도록 만들기 위해 필요한 변경 사항이 표시됩니다. 따라서 스키마의 순서를 바꾸면 "missing"으로 보고되는 개체의 수가 달라질 수 있습니다.

예:

스키마 A에는 2개의 테이블이 있으며, 그 중 하나에는 PK 제약 조건이 있습니다.

스키마 B에는 1개의 테이블이 있으며, 이 테이블은 A에서 제약 조건이 없는 테이블과 일치합니다.

  • A가 참조 스키마인 경우 마이그레이션 스크립트에서는 B를 A와 같은 형태로 변경하려 합니다. 이 경우에는 테이블 하나와 제약 조건 하나, 즉 두 개체가 필요합니다.

  • 하지만 B가 참조 스키마인 경우 마이그레이션 스크립트에서는 A를 B와 같은 형태로 변경하려 합니다. 이 경우에는 한 개체(테이블)를 삭제해야 합니다. 제약 조건은 테이블과 함께 자동으로 삭제됩니다.

Compare Schema 창 중간에 있는 Switch [image] 단추를 누르면 스키마의 순서를 바꿀 수 있습니다.

Results(Interactive)

목록에는 스키마 사이의 차이가 대화형 형식으로 표시됩니다. 차이는 세 그룹으로 구분할 수 있습니다.

아이콘 | 의미
 | 다른 개체
 | Reference Source에 있고 Comparison Source에는 없는 개체
 | Comparison Source에 있고 Reference Source에는 없는 개체

각 항목 유형에는 한 눈에 쉽게 객체를 파악할 수 있도록 아이콘이 할당됩니다.

마우스 오른쪽 단추 메뉴

마우스 오른쪽 단추 메뉴를 사용하면 여러 서식 옵션, 인쇄 미리 보기 화면 및 마이그레이션 SQL 대화 상자에 쉽게 액세스할 수 있습니다.

  • Tree Style - 보려는 트리 스타일 유형을 Outlook 또는 Standard 중에서 선택할 수 있습니다.

  • Group by Object - 또한 이 그룹에 있는 항목은 유형에 따라 그룹으로 묶을 수 있습니다. Results(Interactive) 탭을 마우스 오른쪽 단추로 누르고 Group by Object를 선택합니다. 이제 항목은 유형별로 그룹에 지정되어 쉽게 볼 수 있습니다. 각 항목 유형에는 아이콘이 할당됩니다.

개체 유형에 따라 항목을 그룹으로 묶으면 도구 모음에 트리 보기를 펼치고 접을 수 있는 단추가 표시됩니다.

아이콘 | 의미
 | 첫 번째 수준까지 펼치기
 | 모두 펼치기
 | 모두 접기
Save to Text file | 비교 결과를 텍스트 파일에 저장할 수 있습니다. Results(Interactive) 탭에서 마우스 오른쪽 단추를 누르고 Save to Text File을 선택합니다.

마이그레이션 SQL을 표시하려면

선택한 개체의 마이그레이션 SQL을 표시할 수 있습니다.

  1. 개체를 눌러 선택합니다. <Ctrl> 또는 <Shift> 키를 누른 상태로 여러 개체를 선택할 수 있습니다.

  2. 탭 맨 위에 있는 Show SQL을 누릅니다. Sql 문 대화 상자에 선택한 항목만 마이그레이션하는 SQL이 표시됩니다. 이 내용을 클립보드에 복사하거나 직접 파일로 저장할 수 있습니다.

주의: 이 SQL은 비교 스키마를 변경하도록 설계되어 있습니다. 실행하기 전에 중요한 데이터가 손실되지 않도록 확인하십시오.

Results(RTF)

이 탭에는 비교 결과가 목록 형식으로 표시됩니다. 도구 모음을 사용하면 다음을 수행할 수 있습니다.

  • 모든 서식을 유지하면서 RTF 파일로 저장

  • 서식을 모두 버리고 텍스트 파일로 저장, 또는

  • 프린터에서 파일 인쇄

Results(Summary)

여기에는 부여를 위한 전체 삭제와 같은 다른 요소에 대한 비교 총계가 표시됩니다. 도구 모음을 사용하면 다음을 수행할 수 있습니다.

  • 모든 서식을 유지하면서 RTF 파일로 저장

  • 서식을 모두 버리고 텍스트 파일로 저장, 또는

  • 프린터에서 파일 인쇄

Sync Script

주: 이 기능으로 복사 또는 저장하려면 Quest DBA Module이 있어야 합니다.

여기서는 비교 소스 스키마를 참조 소스 스키마로 변환하는 스크립트를 제공합니다.

예를 들어 참조 스키마에 한 개체만 있고 비교 스키마에 여러 개체가 있는 경우, 작성된 마이그레이션 스크립트에서는 개체를 하나만 남기고 다 삭제하여 거의 비어 있는 스키마로 만듭니다.

또한 도구 모음에는 다음과 같은 옵션이 있습니다.

  • 모든 서식을 유지하면서 스크립트를 RTF 파일로 저장

  • 서식을 모두 버리고 스크립트를 텍스트 파일로 저장

  • 스크립트 인쇄

  • 스크립트를 Editor 창으로 이동하지만 실행은 안 함

  • 스크립트를 Editor 창으로 이동하고 즉시 실행


데이터 복제본

이 대화상자를 사용하여 사용자 입력에 따른 레코드 복제본을 검토합니다.

레코드 복제본을 보려면

  1. Database|Compare|Data Duplicates를 선택합니다.

  2. 드롭다운 목록에서 Owner, Object Type 및 Object를 선택합니다. 열 목록이 아래에 표시됩니다. 이제 다음을 수행할 수 있습니다.

  • 모든 열에서 복제본 찾기

    • Find duplicates on all columns 옵션 단추를 표시합니다.

    • 목록에서 어떤 열도 선택하지 마십시오.

또는

  • 방금 선택한 열에서 복제본 찾기

    • Find dupes of selected columns 옵션 단추를 표시합니다.

    • 열 목록에서 하나 이상의 열을 선택합니다.

  • Duplicate Data 탭의 하나를 눌러 복제 데이터의 결과 행을 확인합니다. 추가 열이 Occurrences라는 이름의 열 목록의 끝에 있으며 복제 데이터가 표에 존재하는 횟수를 나타냅니다.

복제 데이터를 편집하려면

  1. Table Data Duplicates 창의 드롭다운 목록에서 Owner 및 Table을 선택합니다.

  2. Duplicate Data (Editable) 탭을 누릅니다.

  3. 편집할 셀을 누르고 변경합니다.

  4. Post Edit 단추를 눌러 변경 작업을 마칩니다.


메뉴 작성

기본 메뉴 표시줄의 Database|Create 메뉴를 사용하면 다음과 같은 여러 개의 데이터베이스 개체를 작성할 수 있습니다.

  • 제약 조건

  • DB 링크

  • 색인

  • 작업

  • 개체

  • 시퀀스

  • 동의어

  • 표

  • 사용자

  • 보기

각 화면은 개별 모달 대화상자입니다.

선택 사항인 Quest DBA 모듈에는 다음과 같은 Create 메뉴 항목도 포함됩니다.

  • 디렉토리

  • 라이브러리

  • 정책

  • 프로파일

  • 역할

  • 롤백 세그먼트

  • 스냅샷/M 보기

  • 스냅샷 로그

  • 표 공간

Create 메뉴의 모든 화면은 Schema Browser의 해당 탭을 통해 액세스할 수도 있습니다. 예를 들어, Table 창은 Create|Table 또는 Schema Browser 창|Tables 페이지|Create Table 단추를 통해 액세스할 수 있습니다.


동의어 작성

이 대화상자에서 동의어를 작성하면 동의어 이름에서 원래 개체 이름을 가리키게 됩니다.

동의어를 작성하려면

  1. Database|Create 메뉴에서 Synonym를 선택합니다.

또는

Schema Browser|Synonyms 페이지에서 Create Synonym 단추를 누릅니다.

  2. 드롭다운 목록에서 Table, Procedure, Package, Function, Trigger, Sequence, View, Database Link 또는 Synonym 등의 개체 형식을 선택합니다.

목록을 필터링하려면 상자에 LIKE% 값을 입력하고 FIND 단추를 누릅니다. (필요한 경우 Include Grantable Objects 확인란을 표시할 수 있습니다. 기본값으로 표시되어 있지 않습니다.)

  3. 상단 목록에서 개체를 두 번 누르면 동의어가 하단 목록에 추가됩니다. 확인란에서 Include drop statement 및 Make Public 을 수행할 수 있습니다. 기본값으로 모두 표시되어 있습니다.

  4. 동의어 작성용 개체 선택이 완료되면 Copy Script to Clipboard 단추 또는 Execute Script 단추를 누릅니다.


New Database 마법사

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Toad Database 마법사는 Oracle 데이터베이스를 신속하게 만드는 방법을 DBA에 제공합니다. 이 마법사는 다음과 같은 매개 변수 값을 선택하라는 메시지를 표시하는 5개의 화면으로 구성된 마법사 스타일 인터페이스를 제공합니다.

  • 데이터베이스 매개 변수 파일(INIT.ORA) 생성을 위한 매개 변수 값

  • 마법사에 의해 생성된 배치 파일(Windows) 또는 스크립트(UNIX)에서 나중에 실행할 수 있는 SQL 파일 생성에 사용되는 값에 대한 매개 변수 값

이 마법사는 사용이 편리하며 할당하는 드라이브 성능 등급에 따라 최적화된 사용 가능한 하드 드라이브(또는 볼륨)나 사용 가능한 볼륨 공간에서 테이블 공간을 자동으로 할당하는 기능이 있습니다. 이 마법사는 8.1.x 데이터베이스에 대해 만드는 디렉토리에서 OFA(Optimal Flexible Architecture)를 따릅니다.

New Database 마법사에 액세스하려면

  • Database 메뉴에서 Create|New Database 메뉴 항목을 선택합니다. 1단계가 표시됩니다.

New Database 마법사를 사용하여 만든 데이터베이스는 Instance Manager를 사용하여 시작하고 종료할 수 있습니다.

  • 마법사에서 만드는 .bat/.sh 스크립트는 암호 파일 작성 유틸리티인 orapwd를 호출합니다.

  • 이 유틸리티는 SYSDBA 권한 계정을 사용하여 클라이언트 연결 사용을 허용하기 위해 암호 파일을 만듭니다. SYSDBA 권한 연결을 사용하여 클라이언트에서 시작 및 종료하려면 pfile(INIT.ORA)의 remote_password_login = EXCLUSIVE와 함께 이 암호 파일이 필요합니다(OS 인증만으로는 작동하지 않음).

  • 마법사에서 만드는 INIT.ORA는 이를 지원하도록 remote_password_login을 EXCLUSIVE로 설정합니다.

  • 또한 sysdba 권한이 SYS와 SYSTEM에 모두 부여됩니다.

주: 종료/시작할 데이터베이스를 마법사를 사용하여 만들 필요는 없지만 암호 파일이 필요하고 pfile(일반적으로 INIT.ORA 또는 INIT<sid>.ORA)에서 remote_password_login=EXCLUSIVE가 설정되어야 합니다.

관련 항목

New Database 1단계

New Database 2단계

New Database 3단계

New Database 4단계

New Database 5단계


New Database 1단계

1단계: 기본 정보

New Database 마법사의 1단계에서는 새 데이터베이스의 이름과 위치를 설정할 수 있습니다.

새 데이터베이스를 두 가지 방법으로 만들 수 있습니다. 한 가지 방법은 이전에 저장한 설정을 로드하는 것이고 다른 방법은 순차적으로 단계를 진행하여 필드를 수동으로 채우는 것입니다.

설정을 로드하려면

New Database 마법사의 모든 창에서 설정을 로드할 수 있습니다. 설정을 로드하면 모든 단계에 대한 모든 설정이 대체되고 Finishing the database로 바로 이동할 수 있습니다.

  1. Load…를 누릅니다.

  2. 드롭다운 메뉴에서 이전한 저장한 설정을 선택합니다.

설정을 저장하려면

New Database 마법사의 모든 창에서 설정을 저장할 수 있습니다. 설정을 저장하면 프로세스에서의 현재 위치에 상관없이 모든 단계에 입력한 설정이 저장됩니다.

  1. Save…를 누릅니다.

  2. 드롭다운 메뉴에서 이전한 저장한 설정을 선택하여 새 설정으로 대체합니다.

또는

상자를 누르고 새 설정 집합의 이름을 입력합니다.

데이터베이스를 수동으로 설정하려면

  1. 데이터베이스 이름을 입력합니다. 이 이름은 만들 새 데이터베이스의 이름입니다. 또한 이 이름은 이 데이터베이스에 대한 고유한 SID(시스템 식별자)로 작동합니다. SID의 최대 길이는 8자입니다. 이 필드는 필수이며 비어 있는 경우 Next 단추를 사용할 수 없습니다.

  2. 데이터베이스 위치를 선택합니다. Local은 사용자가 데이터베이스 서버상에 있다는 의미입니다. Remote에서는 Windows와 UNIX 중에서 선택할 수 있습니다. Windows를 선택하면 실제로 Local을 선택할 때와 동일한 파일이 만들어지지만 UNIX를 선택하면 Windows 배치 파일 대신에 UNIX 스타일 스크립트가 만들어집니다. 또한 UNIX를 선택하면 UNIX 환경에 따라 SQL 파일의 경로가 변경됩니다(예: "\" 대신에 "/" 사용).

  3. 마법사가 시작되면 레지스트리 키에서 두 개의 경로 이름이 Directories 영역에 로드됩니다. 이러한 경로 이름이 올바른지 확인합니다.

  4. Oracle base – Oracle 8.1에서는 단일한 C:\Oracle 디렉토리 구조에 아래에 여러 Oracle 홈이 상주할 수 있는 Optimal Flexible Architecture가 도입되었습니다. 이전에는 각 Oracle 홈이 각기 고유한 디렉토리 구조 위에 있었습니다. 8.1 데이터베이스에서 Oracle Base 필드는 새 ORACLE_BASE를 나타내거나 최상위 디렉토리를 나타냅니다(이전 데이터베이스에서는 Oracle home 필드 값과 동일). 마법사가 시작될 때 이 필드는 레지스트리 ORACLE_BASE 키가 데이터베이스 서버에 있을 경우 이 키에서 로드되고 그렇지 않을 경우에는 ORACLE_HOME 키를 로드하고 Oracle home 필드와 동일한 값을 가집니다. 이 필드는 필수입니다.

  5. Oracle home – 8.1 전의 Oracle 데이터베이스에서는 Oracle 홈 또는 최상위 디렉토리입니다. 지정된 8.1 데이터베이스의 경우 앞에서 설명한 것처럼 ORACLE_BASE 아래에서 만들어진 첫 번째 홈입니다. 여러 데이터베이스가 동일한 Oracle 홈 아래에 상주할 수 있습니다. Oracle 8.1 설치의 경우 이 홈을 Ora81이라고 합니다. 이 필드는 마법사가 시작될 때 레지스트리 ORACLE_HOME 키(local machine/software/oracle)에서 채워집니다. 이 필드는 필수입니다.

  4. 적절한 응용 프로그램 종류를 선택합니다. 이 유형은 데이터베이스가 사용되는 방법을 지정합니다. 다음 값에 따라 기본 블록 크기 필드가 설정됩니다.

  5. Web – 4K

  6. Multi-purpose – 8K

  7. Data warehouse – 16K

블록 크기를 수동으로 변경할 경우 응용 프로그램 종류를 변경해도 Default 단추를 누르지 않을 경우 해당 값을 덮어쓰지 않습니다.

  5. 블록 크기를 수동으로 변경할 수도 있습니다. 일반적으로 블록 크기는 응용 프로그램 종류에 의해 결정됩니다. 이 크기는 데이터베이스 블록 크기이며 매개 변수 파일에서 DB_BLOCK_SIZE 매개 변수에 사용됩니다. 블록 크기는 일반적으로 2K 또는 4K이고 기본값은 4K입니다. 이 값은 운영 체제 블록 크기의 배수여야 합니다. 이 필드는 필수입니다. 최소값은 1K이고 최대값은 매우 큰 수입니다. 이 수를 변경했다가 기본값으로 돌아가려면 Use Default를 누릅니다.

  6. 실행 중인 Oracle 버전을 선택합니다.

관련 항목

New Database 마법사

New Database 2단계

New Database 3단계

New Database 4단계

New Database 5단계


New Database 2단계

2단계: INIT.ORA 요소

New Database 마법사의 2단계에서는 INIT.ORA 요소를 설정합니다. 이러한 요소는 데이터베이스를 설명합니다.

  1. 슬라이더를 마우스로 끌어 데이터베이스에서 지원할 사용자 수를 선택합니다. 이 수는 볼륨이 하나만 있는 자동 테이블 공간 레이아웃 도중에 다시 실행 로그 파일의 크기를 계산하고 매개 변수 파일에서 log_buffer 값을 계산하는 데 사용됩니다.

  2. 사용 가능한 CPU 수를 선택합니다. 이 수는 매개 변수 파일에서 cpu_count 값을 계산하는 데 사용됩니다. cpu_count는 해당 값이 1보다 큰 경우에만 포함됩니다.

  3. CPU MHz를 선택합니다. 이 수치는 매개 변수 파일에서 cpu_count 값을 계산하는 데 사용됩니다.

  4. 사용 가능한 RAM을 지정합니다. 이 수치는 매개 변수 파일에서 db_block_buffers 및 shared_pool_size 값을 계산하는 데 사용됩니다.

  5. 캐시 크기를 지정합니다. 이 캐시 크기는 매개 변수 파일에서 cpu_count 값을 계산하는 데 사용됩니다.

  6. 채널/디렉터 수를 지정합니다. 이 수는 매개 변수 파일에서 cpu_count 값을 계산하는 데 사용됩니다.

관련 항목

New Database 마법사

New Database 1단계

New Database 3단계

New Database 4단계

New Database 5단계


New Database 3단계

3단계: 테이블 공간 모드 선택

New Database 마법사의 3단계에서는 Toad에서 테이블 공간을 만드는 방법을 선택할 수 있습니다. 테이블 공간을 만드는 작업은 Toad에서 자동으로 수행하거나 사용자가 수동으로 수행합니다.

  • 하드 드라이브/볼륨과 해당 특성 목록을 Toad에 제공하여 이러한 볼륨에서 테이블 공간의 레이아웃을 자동으로 만들려면 Automatic을 선택합니다. 이렇게 하면 드라이브 속도나 사용 가능한 드라이브 공간에 맞게 레이아웃이 최적화됩니다.

  • Toad에서 제공하는 기본 목록에서 시작하여 데이터 파일 위치를 포함한 모든 테이블 공간 정보를 지정하려면 Manual을 선택합니다.

관련 항목

New Database 마법사

New Database 1단계

New Database 2단계

New Database 4단계

New Database 5단계


New Database 4단계

4단계: 자동화된 테이블 공간 모드 또는 사용자 정의 테이블 공간 모드

4단계 창은 두 가지 방법 중 하나로 표시됩니다. 3단계에서 Automatic을 선택한 경우 자동 테이블 공간 모드에 대한 선택 항목이 표시됩니다. Manual을 선택한 경우 테이블 공간을 수동으로 할당하기 위한 선택 항목이 표시됩니디.

Automatic

Automatic Step 4를 사용하면 Toad에서 고려하게 만들려는 데이터 파일에 사용할 수 있는 볼륨의 목록을 입력할 수 있습니다. 이 목록은 136MB의 기본 C 드라이브에서 시작합니다. 이는 최소 데이터베이스 크기 136에 대한 가장 작은 필수 볼륨입니다.

Add, Edit 및 Delete 단추가 볼륨 목록 그리드에서 작동합니다. (참고 항목: Add/Edit Volume)

  1. 만들려는 데이터베이스의 총 크기를 Total database size (mb) 필드에 지정합니다. 이 크기를 채우도록 테이블 공간이 만들어집니다.

  2. Speed에 맞게 최적화할지 또는 Space에 맞게 최적화할지 선택합니다. Speed 또는 Space에 따라 테이블 공간이 제공된 볼륨에 할당됩니다.

  3. Speed를 선택한 경우 사용자 입력이 제공되었을 때 각 볼륨의 속도를 확인하기 위해 알고리즘이 사용됩니다. 그런 다음 해당 속도 등급, 할당하는 테이블 공간, 하나의 볼륨에 함께 존재할 수 있는 최적의 테이블 공간에 따라 테이블 공간이 볼륨에 할당됩니다.

  4. Space를 선택한 경우 할당되는 테이블에 대해 가장 큰 공간을 가진 볼륨이 선택됩니다.

  5. Preview를 눌러 테이블 공간이 할당되는 방법을 검토합니다.

Manual

Manual Step 4 Tablespace Mode 화면에서는 Toad에서 자동으로 할당하는 대신에 사용자가 테이블 공간 정보를 직접 입력할 수 있습니다. 표준 기본 테이블 공간 및 다시 실행 로그 정보가 사용자에게 제공됩니다.

  • Add/Edit tablespace - 이 단추는 Add/Edit Tablespace 대화 상자를 엽니다. 이 대화 상자에서 테이블 공간 그리드를 변경합니다.

  • Add/Edit redo log - 이 단추는 Add/Edit Redo Log 대화 상자를 엽니다. 이 대화 상자에서 다시 실행 그리드를 변경합니다.

  • Total database size – 입력한 테이블 공간 및 다시 실행 로그의 총 크기를 표시합니다.

설정에는 다음과 같은 제한만 적용됩니다.

  • 최소한 두 개의 다시 실행 로그가 있어야 합니다.

  • SYSTEM, RBS 및 TEMP 테이블 공간은 삭제할 수 없습니다.

관련 항목

New Database 마법사

New Database 1단계

New Database 2단계

New Database 3단계

New Database 5단계


새 데이터베이스: 반복 로그 추가/편집

Add 또는 Edit 단추를 누르면 Add/Edit Redo Log 화면이 표시됩니다. 창의 제목이 선택한 내용에 따라 Add Redo Log 또는 Edit Redo Log를 지정합니다.

  1. 반복 로그의 파일 이름을 입력하거나 변경합니다.

  2. 반복 로그의 크기(MB 단위)를 입력하거나 변경합니다.

  3. OK를 눌러 변경 내용을 저장하고 New Database 마법사로 돌아갑니다.

새 데이터베이스로 돌아가기: 4단계


새 데이터베이스: 표 공간 추가/편집

Add 또는 Edit 단추를 누르면 Add/Edit Tablespace 화면이 표시됩니다. 창의 제목이 선택한 내용에 따라 Add Tablespace 또는 Edit Tablespace를 지정합니다.

이러한 속성은 표 공간을 지정하기 위한 Oracle 요구 사항입니다. 다음과 같이 필드에 정보를 입력 또는 변경합니다.

  • Tablespace name: 이 텍스트 필드에 표 공간 이름을 입력합니다.

  • File name: 파일 이름을 입력합니다.

  • Size (Mb): 표 공간 크기를 입력합니다.

  • % Increase: 원하는 증가 비율을 입력합니다.

  • Initial: 허용되는 첫 번째 범위의 크기를 입력합니다.

  • Next: 첫 번째 다음의 범위 크기를 입력합니다.

  • Max Extents: 허용할 최대 범위 수를 입력합니다.

OK를 눌러 표 공간의 수정 내용을 저장합니다.

새 데이터베이스로 돌아가기: 4단계


New Database: Add/Edit Volume

Add 또는 Edit 단추를 누르면 Add/Edit Volume 화면이 표시됩니다. 선택한 단추에 따라 창 제목은 Add Volume 또는 Edit Volume이 됩니다.

다음과 같이 필드에 정보를 입력합니다.

  • Volume name – 하드 드라이브/볼륨의 이름입니다. 일반적으로 Windows의 경우 드라이브 문자이고 UNIX의 경우 탑재 지점입니다(예: /u01).

  • Datafile directory – 이 볼륨에서 데이터 파일을 저장할 디렉토리입니다.

  • Available space – 이 볼륨에서 마법사가 사용해야 하는 공간 크기입니다.

  • # disks – 이 볼륨에 있는 디스크의 수입니다(속도 등급 계산에서 사용됨).

  • RAID – 이 볼륨의 RAID 유형입니다(있을 경우).

  • Interface – 드라이브 인터페이스 유형입니다(예: IDE, SCSI 등).

  • Transfer rate – 볼륨의 전송 속도입니다.

  • RPM– 드라이브의 RPM 값입니다.

  • Operating System – 이 볼륨에 운영 체제가 있을 경우 선택합니다.

  • Swap – 이 볼륨이 스왑 드라이브로 사용될 경우 선택합니다.

  • Defaults – 선택할 경우 제공된 값이 저장되고 다음에 볼륨이 추가될 때 사용됩니다(현재 세션 도중에).

이러한 대부분의 속성은 드라이브의 속도 등급을 계산하여 테이블 공간이 배치되는 위치를 결정하는 데 사용됩니다.

New Database로 돌아가기: 4단계

관련 항목

New Database 마법사

New Database 1단계

New Database 2단계

New Database 3단계

New Database 4단계

New Database 5단계


New Database 5단계

5단계: 데이터베이스 작성

이 단계는 마법사의 마지막 단계입니다. 이 단계에서는 여러 Oracle 옵션을 선택하고 다양한 SQL 설치 스크립트의 실행을 시작합니다.

  1. 제공된 확인란에서 데이터베이스에 대한 적절한 Oracle 옵션을 선택합니다. Oracle 옵션에 대한 자세한 내용은 Oracle 설명서에서 확인할 수 있습니다.

  2. Generate 옵션에서 적절한 항목을 선택합니다.

  • Create database now – 마법사 정보를 스크립트(제공되지 않은 경우 Windows Temp 디렉토리에 생성됨)에 저장한 다음 스크립트를 실행합니다. 첫 번째 화면에서 Local을 선택한 경우(데이터베이스 서버가 설치된 PC를 사용하는 경우)에만 이 옵션을 사용할 수 있습니다.

  • Save information to a batch/script file – Windows/UNIX에 따라 캡션이 변경될 수 있습니다. 이 필드는 데이터베이스를 만들기 위해 나중에 실행할 수 있는 배치(.BAT) 또는 스크립트(.SH) 파일을 만들도록 지정합니다. 제공된 디렉토리 경로가 없을 경우 디렉토리를 만들 것인지 묻는 메시지가 표시됩니다. 기본적으로 파일은 데이터 파일 디렉토리(지정한 버전에 따라 다름)에 저장되고 "create"와 데이터베이스 이름이 합쳐진 이름을 가집니다.

  • Finish를 누릅니다.

  • 아직 존재하지 않는 배치 파일에 저장하는 경우 해당 파일을 만들 것인지 묻는 메시지가 표시됩니다. Yes를 누릅니다.

  • Create database now를 선택한 경우 대화 상자에서 데이터베이스가 만들어진 것을 알 수 있습니다.

  3. 필요한 경우 데이터베이스 이름을 수정합니다. 다음 조건에 해당할 경우 수정이 필요합니다.

  4. SQLNET.ORA 파일이 Network/Admin 디렉토리에 있는 경우, 또한

  5. 도메인 이름이 데이터베이스 별칭에 사용되는 경우(NAMES.DEFAULT_DOMAIN 값이 있을 경우). 마법사에서는 이 정보를 추출하지 않고 TNSNAMES.ORA의 데이터베이스 이름 항목에 포함합니다. 아래의 올바른 옵션을 선택하고 설명된 대로 적절하게 변경합니다.

배치 또는 스트립트 파일에 저장한 경우:

  • 파일을 실행하기 전에 조정할 수 있습니다. 마법사에서 만든 배치 파일이나 셸 스크립트(.BAT 또는 .SH 파일)를 엽니다.

  • 마지막 섹션은 일련의 ECHO 명령입니다. 이 일련의 명령에서 필요에 따라 첫 번째 줄을 수정합니다. 예를 들면 다음과 같습니다.

"WORLD"라는 이름의 도메인이 사용된다고 가정하고 스크립트를 다음과 같이 수정합니다.

변경 전

echo "TEST = ">>c:orant/network/admin/tnsnames.ora

변경 후

echo "TEST.WORLD= ">>c:orant/network/admin/tnsnames.ora

Create Database Now를 선택한 경우:

  • TNSNAMES.ORA를 수동으로 편집하여 도메인 이름을 데이터베이스 이름의 끝에 추가해야 합니다.

  • 예:

  • SQLNET.ORA 파일이 있고 NAMES.DEFAULT_DOMAIN = world 줄이 포함되어 있습니다.

  • Ora805가 데이터베이스 이름인 경우 TNSNAMES를 편집하여 .WORLD를 끝에 추가합니다. 다음 시나리오를 하나의 예로 들 수 있습니다.

ORA805.WORLD =

(DESCRIPTION =

(ADDRESS = (PROTOCOL = TCP)(Host = ORA804)(Port = 1521))

(CONNECT_DATA =

(SID=ORA805)

)

)

관련 항목

New Database 마법사

New Database 1단계

New Database 2단계

New Database 3단계

New Database 4단계


창: View Extents

View Extents

이 대화 상자를 사용하면 데이터 파일 범위 정보를 볼 수 있습니다.

범위를 보려면

  1. Database|Segment Management|Extents 메뉴 항목을 선택하여 이 대화 상자에 액세스합니다.

  2. 원하는 Object Type( All Objects, Tables, Indexes, Rollback 또는 Cluster)을 선택합니다.

  3. Refresh [image] 단추를 눌러 결과를 반입합니다.

열 제목을 눌러 그리드를 정렬할 수 있습니다. 오름차순으로 정렬된 경우 "sorted by" 열에 위쪽 화살표가 표시되며, 내림차순으로 정렬된 경우에는 아래쪽 화살표가 표시됩니다.

SYS 소유 개체의 범위를 보려면 Owner 드롭다운 목록에서 SYS를 선택합니다.

DBA_ views에 대한 액세스 권한이 있으면 View|Toad Options|Startup|Check for DBA Views 확인란이 선택되어 있는지 확인합니다. 이 확인란이 선택된 경우 Owner 드롭다운 목록이 활성화되고 DBA 사용자가 특정 스키마 소유자를 선택할 수 있습니다. 결과를 반입하려면 GO를 누릅니다.


Identify Space Deficits

Database|Diagnose|Identify Space Deficits 메뉴 항목에서 이 창에 액세스할 수 있습니다.

이 창에서는 다음 익스텐트를 할당하기 위한 충분한 디스크 여유 공간이 없는 테이블이 표시됩니다.

Alter Tablespace 단추를 누르면 선택한 테이블 공간을 수정할 수 있도록 해당 테이블 공간에 대한 Alter Tablespace 창이 열립니다.


Log Switch Frequency Map

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

이 화면에는 데이터베이스가 로그 전환을 수행하는 시점이 표시됩니다. 대부분의 DBA는 시간당 로그 전환이 거의 없도록 다시 실행 로그의 크기를 지정하려고 합니다. 로그 전환이 빈번하면 성능이 크게 저하되고 빈번하지 않으면 데이터베이스 시작 시간이 늘어날 수 있습니다. 이 창을 사용하여 로그 전환이 균형을 이루는지 판단할 수 있습니다.

활성 연결에 대한 데이터베이스 스키마가 그리드에 표시됩니다. 다음과 같이 열에 정보가 표시됩니다.

  • 날짜

  • 해당 날짜의 요일

  • 해당 날짜의 총 로그 전환 수

  • 자정에서 오전 1시까지 시작하여 매일 각 시간마다의 로그 전환 수

해당 시간 동안 로그 전환이 없을 경우 셀은 비어 있으며 로그 전환이 없는 날짜는 그리드에 전혀 표시되지 않습니다. 데이터베이스의 컨트롤 파일에 기록되는 모든 로그 전환이 표시됩니다.

로그 전환 세부 정보를 보려면

  • 세부 정보를 보려면 셀을 두 번 누릅니다.

  • 시간 열을 누르면 누른 시간에 대한 세부 정보만 표시됩니다.

  • 날짜, 요일 또는 총계 열을 누르면 전체 날짜에 대한 세부 정보가 표시됩니다.

그리드를 인쇄하려면

  • 마우스 오른쪽 단추를 누르고 메뉴에서 Print Grid를 선택합니다. 그리드 인쇄에 대한 자세한 내용은 Report Link Designer를 참조하십시오.

그리드를 내보내려면

  • 마우스 오른쪽 단추를 누르고 메뉴에서 Save As를 선택합니다. 그리드 콘텐츠 파일 저장을 참조하십시오.


창: Tablespace Map

Tablespace Map

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

메뉴에서 Database|Diagnose|Tablespace Map을 선택하여 이 창에 액세스합니다.

이 맵은 데이터베이스의 테이블 공간에 있는 개체에 공간이 어떻게 할당되는지 그래픽으로 표시합니다. 이 맵을 사용하면 테이블 공간별로 세그먼트 조각화를 볼 수 있습니다.

맵의 셀 위에서 마우스를 움직이면 해당 셀로 표시되는 데이터 블록을 사용하는 세그먼트가 표시됩니다. 하지만 테이블 공간이 클 경우 해당 셀은 수백 개의 실제 데이터 블록을 나타낼 수 있습니다. 그러므로 데이터 블록은 전혀 겹치지 않습니다. 빨간 색은 실제로는 전체 크기에 대해 블록 사용률이 높은 세그먼트를 나타냅니다. 그러므로 해당 세그먼트는 개체 재구축 대상일 수 있습니다.

테이블 공간을 그래픽으로 보려면

  1. 드롭다운 메뉴에서 테이블 공간을 선택합니다.

  2. Analyze 단추 [image] 를 눌러 맵의 데이터를 반입합니다. 해당 테이블에서 사용하는 맵의 부분이 녹색으로 강조표시됩니다.

  3. View|Toad Options|DBA에 설정된 조각화 비율 제한값보다 높거나 같은 영역은 빨간색으로 표시됩니다. 또한 Toad Options|DBA에서 다른 조각화 제한값을 설정했을 수도 있습니다. Toad Options: DBA를 참조하십시오.

주: Toad에서는 내부 조각화(테이블 공간 내 개체의 조각화 측정값)를 측정합니다. Toad에서 이 측정에 사용하는 실제 SQL은 Toad FAQ의 "How does the Tablespace Map Work?"에 나와 있습니다.

조각화된 차트를 통합하려면

  1. 드롭다운 메뉴에서 테이블 공간을 선택합니다.

  2. Coalesce 단추 [image] 를 눌러 테이블 공간을 통합합니다. 통합 후 Toad에서 분석을 수행하고 테이블 공간 맵이 나타납니다.

세그먼트 및 범위를 보려면

테이블 공간 맵 위에서 마우스를 느리게 움직입니다. Segments가 포인터 옆에 표시됩니다. 그리드 셀을 누르면 첫 번째 셀과 동일한 세그먼트를 포함하는 다른 모든 셀이 노란색으로 표시됩니다. 또는 다음과 같이 수행하여 자세한 내용을 볼 수 있습니다.

  1. 드롭다운 메뉴에서 테이블 공간을 선택합니다.

  2. Analyze [image] 단추를 눌러 맵의 데이터를 반입합니다. 사용 중인 블록을 나타내는 셀이 녹색으로 강조표시됩니다.

  3. Segments and Extents [image] 단추를 누릅니다. Segments 탭이 선택된 Segments 대화 상자가 나타납니다. 테이블 공간 맵 위에서 마우스를 움직일 때 Segments 대화 상자에 각 그리드 셀의 세그먼트가 표시됩니다. 또한 이러한 세그먼트의 조각화 비율이 대화 상자 맨 아래에 나타납니다.

Extents를 표시하려면 Extents 탭을 누릅니다. Extents가 위의 세그먼트에 대한 설명과 동일한 방식으로 표시됩니다.

테이블 공간 맵을 필터링하려면

  1. 드롭다운 메뉴에서 테이블 공간를 선택합니다.

  2. Analyze [image] 단추를 눌러 맵의 데이터를 반입합니다. 사용 중인 블록을 나타내는 셀이 녹색으로 강조표시됩니다.

  3. Filters [image] 단추를 누릅니다. Filters 대화 상자가 나타납니다. 필터가 다음 탭 아래의 범주에 정렬됩니다.

  4. Datafiles

  5. Object Types

  6. Owners

  7. Objects(이 필터 대화 상자에는 그리드가 있습니다. 전체 그리드를 보려면 대화 상자 맨 아래에 있는 스크롤 막대를 사용합니다.)

  4. 표시할 필터를 선택합니다.

  5. <Ctrl> 키를 누른 상태에서 선택하면 여러 필터를 선택할 수 있습니다.

  6. 여러 탭에서 필터를 선택할 수도 있습니다. 선택하는 필터가 적용되는 공간이 Tablespace Map에서 노란색으로 바뀝니다.

주: 선택한 필터가 동일한 탭 또는 여러 탭에 누적됩니다. 이러한 필터는 지울 때까지 유효한 상태로 유지됩니다.

강조표시를 지우려면

  • View segments 또는 Show Filter 단추를 사용하여 테이블 공간 맵의 다른 영역을 강조표시한 경우 Clear Highlighting [image] 단추를 눌러 강조표시를 지웁니다.

창 크기를 복원하려면

  • 창 크기를 원래의 최적 보기 크기로 복원할 수도 있습니다. Restore Form Size [image] 단추를 누릅니다. 창이 원래 크기로 복원됩니다.

테이블 공간 범례를 표시하려면

테이블 공간 맵의 범례를 표시할 수 있습니다.

  • 도구 모음에서 Legend [image] 단추를 누릅니다.

Quest Space Manager를 시작하려면

Quest Space Manager가 컴퓨터에 설치된 경우 Toad 내에서 해당 프로그램을 시작할 수 있습니다.

  • Tablespace Map 도구 모음에서 Launch Quest Space Manager [image] 단추를 누릅니다.


Database Health Check

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Database Health Check는 선택한 데이터베이스에서 일련의 검사를 수행하고 결과를 표시합니다. 결과를 색으로 구분된 RTF 또는 HTML 파일이나 일반 텍스트 파일에 저장할 수 있습니다. 또한 전자 메일을 통해 결과를 다른 주소로 보낼 수 있습니다.

Health Check는 Toad Options|Oracle|Optimizer Hints에 구성된 최적화 프로그램 힌트를 사용합니다.

Health Check에서는 DBA_views 및 일부 V$ 보기에 대한 액세스가 필요합니다. 필요한 V$ 보기 목록은 필요한 V$ 테이블 항목에 나와 있습니다.

주: 선택한 데이터베이스에 대해 열려 있는 연결이 이미 Toad에 있는 경우에도 Database Health Check는 Oracle에 대한 별개의 연결을 연 다음 검사 후에 연결을 닫습니다. 이 연결은 Session Browser에서 별개의 세션으로 표시되고 Toad 연결이 제한된 경우 문제가 될 수 있습니다.

Health Check를 실행하려면

  1. Database 메뉴에서 Diagnose|Health Check를 선택합니다. Database Health Check 창이 나타납니다.

  2. 왼쪽 창에서 검사할 데이터베이스를 선택합니다. <CTRL> 또는 <Shift> 키를 사용하여 여러 항목을 선택할 수 있습니다.

  3. 창의 오른쪽에 있는 Checks and Options 탭에서 실행하려는 미리 정의된 Health Check를 선택합니다. 이러한 각 Health Check에 대한 자세한 내용은 Health Check - Checks and Options를 참조하십시오.

  4. 결과를 전자 메일로 보내려면 Health Check - 결과를 전자 메일로 보내기에 설명된 대로 Email Settings 탭에서 적절한 설정을 지정합니다.

  5. 모든 옵션이 설정되었으면 도구 모음에서 Generate a Report [image] 단추를 누릅니다. 보고서가 생성되고 Report Output 탭에서 결과를 볼 수 있습니다. 또한 Health Check - 결과 저장을 참조하십시오.

또는 설정을 저장하고 나중에 명령줄에서 Health Check를 실행할 수 있습니다.


Health Check - Checks and Options

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Health Check 창의 Checks and Options 탭에서 다양한 미리 설정 조건을 설정할 수 있습니다. 이러한 각 미리 설정 검사는 DBA나 개발자가 자신의 데이터베이스에서 알고 있어야 하는 사항을 나타냅니다. 또한 이러한 조건 중 일부를 조정할 수 있습니다.

특정 검사 찾기

데이터베이스에서 실행할 수 있는 여러 검사가 있습니다. 목록을 살펴보는 것만으로는 수행할 모든 검사를 찾기가 어려울 수 있습니다. Toad에서는 지정된 조건을 충족하는 검사를 강조표시하는 검색 기능이 제공됩니다.

특정 Health Check를 검색하려면

  • Highlight Rows with: 상자에 검색할 단어를 입력합니다.

주:Toad에서는 항목이 입력될 때 검색을 수행합니다. 전체 단어, 여러 단어 또는 단어의 일부분을 입력할 수 있습니다. 예를 들어 data를 입력하면 data, datafile, datatype 등이 포함된 검사를 찾습니다. 그러나 여러 단어를 사용하는 경우 입력한 모든 단어가 하나의 단어로 간주됩니다. 따라서 입력한 순서로 되어 있는 단어만 검색됩니다. 예를 들어 "datafile IO distribution"이 포함된 검사를 찾고 있는 경우 "IO datafile"을 입력하면 원하는 검사가 검색되지 않습니다. "datafile IO"를 입력해야 합니다.

검사의 조건 조정

아래 설명된 조건 중 일부를 조정할 수 있습니다.

조건을 변경하려면

  1. 조건 앞에 있는 Adjust 단어를 누릅니다. 셀이 활성화됩니다.

  2. 드릴다운 [image] 단추를 누릅니다. 변경할 수 있는 조건을 설명하는 조건 상자가 나타내며 이 상자에서 조건을 변경할 수 있습니다.

  3. 조건을 변경하고 OK를 누릅니다.

검사

주: 작업에서 수행하는 작업은 커밋될 때까지 다른 연결에서 볼 수 없습니다. 이는 Database Health Check가 실행된 경우 수행되었지만 커밋되지 않은 작업을 파악하지 않는다는 것을 의미합니다.

다음은 Database Health Check에서 수행할 수 있는 검사 목록입니다.

Show output only for ‘bad’ conditions

이 옵션을 선택할 경우 Health Check에 실패한 항목만 표시됩니다. 일반적으로 데이터베이스가 정상적인 작동 상태이면 보고서 길이가 크게 줄어들 수 있습니다.

Suppress header for a database when the report is empty

이 옵션을 선택할 경우 하나의 보고서에서 여러 데이터베이스에 Health Check가 실행된 경우 Health Check에 실패한 데이터베이스만 해당 보고서에 표시됩니다. 이 경우 보고서 길이가 크게 줄어들 수 있지만 Health Check의 모든 측면을 통과한 데이터베이스의 레코드가 제공되지 않습니다.

List connect time, version info, and a few basic ratios

이 옵션을 선택할 경우 Health Check 보고서에는 다음 항목이 나열됩니다.

  • Toad에서 이 데이터베이스에 연결하는 데 걸린 시간

  • 데이터베이스 버전

  • 데이터베이스가 가동 상태로 유지되고 있는 기간

  • 버퍼 캐시 적중률

  • 라이브러리 캐시 누락률

  • 사전 캐시 누락률

List SGA usage stats

이 옵션을 선택할 경우 보고서에는 SGA 총 크기(MB), 사용된 양, 사용되지 않은 양, 사용 비율이 나열됩니다.

List archive log info

이 옵션은 Health Check 보고서에서 다음 항목의 표시를 제어합니다.

  • 보관이 설정되었는지 여부

  • 일일 평균 로그 전환 수

  • 일 단위 보관 로그를 저장하는 데 필요한 예상 디스크 공간

Alert.Log for Ora-600 errors

각 오류와 세 개의 이전 줄을 표시합니다.

Alert.Log - show summary

600개의 모든 오류 개수, 검사점 완료되지 않은 메시지, 데이터베이스 시작 횟수, 파일에서 발견된 각 ORA 오류의 개수, 보고된 새 추적 파일의 개수 등이 표시됩니다.

Alert.log - Mark file so next Toad Health check against it examines only new items

다음에 alert.log 파일에 대해 Health Check를 실행할 경우 Toad에서 새 항목만 표시하도록 해당 파일에 책갈피 레코드를 배치합니다.

Alert.log - Save local copy in TEMPS directory

Toad for Oracle\Temps 디렉토리에 alert.log 파일의 복사본을 저장합니다.

Check redo log sizing and quantity

최소 로그 그룹 수와 각 그룹이 동일한 크기 구성원을 갖고 있는지 검사합니다.

List rollback segments with a wait ratio > 1%

대기율이 선택한 비율을 초과할 경우 롤백 세그먼트가 보고서에 포함됩니다. 이 비율을 조정할 수 있습니다.

List datafile IO distribution

모든 데이터 파일 및 해당 테이블 공간과 각 데이터 파일의 데이터베이스에서의 총 읽기 및 쓰기 비율을 나열합니다.

데이터 파일이 다른 디스크에 있을 경우 디스크에서 데이터 파일이 제대로 분산되었는지 확인할 수 있습니다. 또한 테이블 공간에서 개체가 제대로 분산되었는지도 확인할 수 있습니다.

List non-system tables with no primary key

기본 키는 데이터베이스의 레코드를 고유하게 정의합니다. 대부분의 테이블에는 기본 키가 있어야 합니다.

이러한 키가 할당되지 않은 테이블에 대한 경고를 받으려면 이 옵션을 선택합니다.

List non-system tables with > 6 indexes

이 검사에 정의된 인덱스 수를 조정할 수 있습니다.

List Redundant Indexes (same leading columns)

동일한 선행 열이 있는 인덱스를 가진 개체를 나열합니다. 동일한 선행 열은 인덱스가 중복된다는 것을 나타냅니다.

List objects with mixed-case names, excluding Sys/System objects

대/소문자가 혼합된 이름을 가진 테이블에 대한 경고를 받으려면 이 옵션을 선택합니다.

List object type counts by owner and tablespace, excluding Sys/System objects

이 옵션을 사용하는 이유 중 하나는 "테이블" 테이블 공간에 인덱스가 있는지 확인하는 것입니다.

이 옵션을 선택하면 개체에 대한 다음 항목이 나열됩니다.

  • 소유자

  • 테이블 공간

  • 각 테이블 공간에 있는 저장소 개체(테이블, 인덱스 등)의 수

List analyzed tables with > 5% chained rows and > 500 total rows

비율과 총 행 수를 모두 조정할 수 있습니다.

주: 정확한 결과를 얻으려면 선택한 데이터베이스의 테이블을 최근에 분석했어야 합니다.

List analyzed table partitions with > 5% chained rows and > 500 total rows

비율과 총 행 수를 모두 조정할 수 있습니다.

주: 정확한 결과를 얻으려면 선택한 데이터베이스의 테이블을 최근에 분석했어야 합니다.

List schemas with unanalyzed tables (excludes system objects)

이 옵션은 분석되지 않았거나 분석 통계가 삭제된 테이블을 나열합니다.

이 옵션은 SYS, SYSTEM 또는 기타 "기본 제공" 스키마가 소유하는 개체를 제외합니다.

List schemas with unanalyzed table partitions (excludes system objects)

이 옵션은 분석되지 않았거나 분석 통계가 삭제된 테이블 파티션을 나열합니다.

이 옵션은 SYS, SYSTEM 또는 기타 "기본 제공" 스키마가 소유하는 개체를 제외합니다.

List schemas with unanalyzed indexes (excludes system objects)

이 옵션은 분석되지 않았거나 분석 통계가 삭제된 인덱스를 나열합니다.

이 옵션은 SYS, SYSTEM 또는 기타 "기본 제공" 스키마가 소유하는 개체를 제외합니다.

List schemas with unanalyzed index partitions (excludes system objects)

이 옵션은 분석되지 않았거나 분석 통계가 삭제된 인덱스 파티션을 나열합니다.

이 옵션은 LOB 인덱스와 SYS, SYSTEM 또는 기타 "기본 제공" 스키마가 소유하는 개체를 제외합니다.

List analyzed SYS and SYSTEM Objects

이 옵션은 분석된 모든 SYS 및 SYSTEM 개체를 나열합니다.

주: 이 옵션을 선택하면 데이터 사전에 대한 질의의 속도가 느려집니다.

List segments with a possible poorly sized next extent

NEXT_EXTENT가 개체 총 크기의 10% 미만이거나 200%를 초과하는 세그먼트를 나열합니다. 이러한 숫자는 조정할 수 없습니다.

NEXT_EXTENT가 작으면 많은 익스텐트를 가진 개체가 얻어지고 NEXT_EXTENT가 크면 필요한 것보다 많은 공간을 차지하는 개체가 얻어질 수 있습니다.

주: 이 Health Check 항목이 반드시 문제를 나타내는 것은 아닙니다.

List segments with < 10% of extents remaining and > 1 maxextents

maxextents에 도달하는 세그먼트를 나열합니다. maxextents의 비율과 수를 조정할 수 있습니다.

List segments with > 100 extents, excluding Sys/System objects

이 수를 조정할 수 있습니다. 이 Health Check 항목을 사용하여 너무 작은 익스텐트 크기로 인한 "런어웨이" 세그먼트를 찾을 수 있습니다.

List segments which can’t extend because there is not enough room in the tablespace, excluding autoextend tablespaces.

선택적으로 Adjust 열 사용에서 자동 확장 테이블 공간의 개체를 포함할 수 있습니다. 이 옵션에서는 자동 확장 데이터 파일에 대한 최대 크기를 고려합니다.

List jobs with broken = Y

오류로 인해 실패한 작업을 나열합니다.

List jobs with Next Date < Sysdate

경고가 없을 경우 다시 실행되지 않는 작업을 나열합니다.

List jobs that have been running longer than 60 minutes

시간(분)을 조정할 수 있습니다.

List public synonyms that point to nonexistent objects

삭제된 개체를 가리키는 공용 동의어를 나열합니다.

List private synonyms that point to nonexistent objects

삭제된 개체를 가리키는 전용 동의어를 나열합니다.

List objects for which there is a granted privilege but no corresponding synonym

이 옵션은 권한이 부여되었지만 동의어가 없는 개체를 표시합니다. 권한과 동의어를 둘 다 부여했는지 또는 둘 다 삭제했는지 확인해야 할 경우 이 옵션이 유용합니다.

List redundant table privileges with conflicting grant options

이 옵션은 두 명의 다른 사용자에 의해 동일한 사용자/역할에 부여된 동일한 권한을 가진 개체를 표시합니다.

List profiles not granted to any user

이 옵션은 역할이나 사용자에 할당되지 않은 모든 프로파일을 표시합니다. 이 옵션을 사용하여 특정 프로파일이 사용되지 않았으며 삭제할 수 있는지 확인할 수 있습니다.

List roles not granted to any role or user

이 옵션은 역할이나 사용자에 할당되지 않은 모든 역할을 표시합니다. 이 옵션을 사용하여 특정 역할이 사용되지 않았으며 삭제할 수 있는지 확인할 수 있습니다.

List DB Links which are inaccessible

이 옵션은 어떠한 이유로든 액세스할 수 없는 모든 DB 링크를 표시합니다.

링크에 액세스할 수 없는 다양한 이유 중에서 몇 가지는 다음과 같습니다.

  • 연결된 데이터베이스가 다운되었습니다.

  • 연결된 데이터베이스를 네트워크를 통해 액세스할 수 있습니다.

  • 링크가 더 이상 유효하지 않습니다.

List users with SYSTEM as a temporary tablespace

이 옵션은 SYSTEM을 임시 테이블 공간으로 사용하고 있는 모든 사용자를 표시합니다.

List users except SYS with SYSTEM as a default tablespace

이 옵션은 SYS 사용자를 제외하고 SYSTEM을 기본 테이블 공간으로 사용하고 있는 모든 사용자를 표시합니다.

List unusable indexes

이 옵션은 다시 작성될 때까지 사용할 수 없는 인덱스를 나열합니다.

List invalid objects

이 옵션은 쉽게 문제를 찾아 수정할 수 있도록 잘못된 개체를 나열합니다.

List package bodies with no associated packages

이 옵션은 연관된 패키지 지정이 없기 때문에 사용할 수 없는 패키지 본문을 나열합니다.

List disabled constraints and triggers

이 옵션은 비활성화된 제약 조건과 트리거를 나열합니다. 적절한 이유로 인해 제약 조건이나 트리거가 비활성화되었을 수 있지만 이 Health Check 항목은 활성화해야 하는 제약 조건이나 트리거를 찾는 데 도움이 될 수 있습니다.

List foreign keys with non-matching column definitions

이 옵션은 다른 유형을 상위 테이블 열을 하위 테이블 열로 가지는 외래 키를 나열합니다. 이 상황에서는 성능이 저하됩니다.

List foreign keys without matching index on child table

해당 인덱스가 없을 경우 트랜잭션이 완료될 때까지 상위 테이블에서의 삭제 및 업데이트로 인해 하위 테이블에서 테이블 수준 잠금이 발생하기 때문이 이 옵션이 나열됩니다.

List tablespaces that are > 30% fragmented having > 50 total extents

이 옵션은 지정한 비율보다 많이 단편화되었으며 또한 선택한 총 익스텐트 수보다 많은 익스텐트를 가진 테이블 공간을 나열합니다.

비율과 익스텐트 수를 모두 조정할 수 있습니다.

List tablespaces with < 10% free space remaining

이 옵션은 채워진 테이블 공간을 나열합니다. 남은 여유 공간의 비율을 조정할 수 있습니다.

For items 27, 45, and 46, exclude objects in ‘SYSTEM’ tablespace(s)

이 옵션은 다음 경우에 적용됩니다.

  • 30%를 초과하여 단편화되었으며 총 익스텐트 수가 50개를 초과하는 테이블 공간을 나열합니다.

  • 남은 여유 공간이 10% 미만인 테이블 공간을 나열합니다.

  • 테이블 공간에 공간이 충분하지 않기 때문에 확장할 수 없는 세그먼트를 나열합니다.

제외되는 테이블 공간을 조정할 수 있습니다. 제외할 테이블 공간을 선택할 수 있으며 선택 창에서 <Ctrl> 및 <Shift> 키를 사용하여 여러 항목을 선택할 수 있습니다.

Play custom script at the end of the health check

이 옵션은 Health Check가 끝날 때 사용자 제공 스크립트를 실행합니다. 스크립트 출력은 Health Check 보고서에 포함됩니다.

실행할 스트립트의 파일 이름을 조정할 수 있습니다.

Store results in table Toad.Toad_HEALTH_CHECK in database being checked

이 옵션을 사용하여 검사하고 있는 각 데이터베이스의 테이블에 결과를 채우거나 리포지토리 데이터베이스의 단일 테이블에 모든 Health Check의 결과를 채울 수 있습니다. 조정 옵션을 사용하여 하나의 데이터베이스나 여러 데이터베이스를 지정합니다.

지정한 테이블이 없을 경우 Toad에서는 Health Check 실행 시에 테이블 작성을 시도합니다.

Save results to file: C:\Program Files\Quest Software\Toad for Oracle\Temps\healthcheck.htm

이 옵션은 Health Check가 끝날 때 Health Check 결과를 자동으로 파일에 저장합니다.

파일 이름을 조정할 수 있으며 파일 형식은 지정한 파일 확장명에 의해 결정됩니다.

  • 파일 확장명이 "HTM"인 경우 파일은 HTML 형식이 됩니다.

  • 파일 확장명이 "RTF"인 경우 파일은 RTF 형식이 됩니다.

  • 다른 파일 확장명을 지정하면 색으로 구분되지 않은 ASCII 텍스트 파일이 됩니다.


Health Check - 결과를 전자 메일로 보내기

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Health Check를 실행할 때 전자 메일을 보내려면 먼저 전자 메일 페이지를 설정해야 합니다. Database Health Check 창에서 Email Settings 탭을 누릅니다. 또한 SMTP 서버에 설정된 전역 전자 메일 옵션과 받는 사람 주소가 있어야 합니다.

When to Send Mail

Health Check 후 전자 메일을 보낼 시점을 선택합니다. 보내는 전자 메일에는 전체 Health Check 보고서가 포함됩니다.

  • Never

  • Always

  • Only When ‘Bad’ Conditions Exist

Send Mail as

전자 메일을 HTML이나 일반 텍스트로 보낼 수 있습니다.

  • HTML 메일을 선택하면 모든 서식을 그대로 유지하는 Health Check 보고서가 보내집니다.

  • 일반 텍스트를 선택하면 Health Check 보고서가 ASCII 일반 텍스트에 포함됩니다. 모든 서식이 손실됩니다.


Health Check - 결과 저장

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Database Health Check 보고서가 실행된 경우 결과를 RTF(.rtf), 웹 페이지(.htm) 또는 일반 텍스트(.txt) 형식으로 파일에 저장할 수 있습니다.

보고서를 저장하려면

  1. Report Output 탭에서 도구 모음의 Save Report [image] 단추를 누르거나 보고서를 저장할 형식을 드롭다운에서 선택합니다.

  2. File name: 상자에 보고서의 이름을 입력합니다.

  3. 드롭다운에서 보고서에 사용할 파일 형식의 유형을 선택합니다.

  • Text files (*.txt)

  • RTF files (*.rtf)

  • HTML files (*.htm)

  4. Save를 누릅니다.


LogMiner 개요

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Oracle LogMiner 패키지 DBMS_LGMNR 및 DBMS_LOGMNR_D는 온라인 또는 보관된 Oracle 다시 실행 로그에서 정보를 추출할 수 있게 합니다. 이 정보를 사용하여 문제가 발생한 위치를 분석할 수 있습니다. LogMiner를 사용하면 SCN(System Change Number)으로 인해 손상 문제가 발생한 경우 데이터베이스를 쉽게 분석하고 손상 전의 트랜잭션으로 복구할 수 있습니다.

이 패키지는 Oracle 8i 이상에서만 사용할 수 있습니다.

주: 이 옵션을 사용하려면 일부 V$ 테이블에 대한 액세스 권한이 필요합니다. 이러한 사용 권한의 목록은 LogMiner에 필요한 V$ 테이블을 참조하십시오.

V$PARAMETER, V$LOGFILE, V$SESSION, V$VERSION에 액세스할 수 없는 경우 화면이 계속 작동하지만 몇 가지 작업(예: utl_file 파일이 설정되지 않은 경우 사용자에게 알리거나 로그 파일이 저장된 위치를 자동으로 확인하는 작업)이 자동으로 수행되지 않습니다.

실제로 필요한 항목(예: dbms_logmnr에 대한 실행 권한)에 액세스할 수 없는 경우 해당 항목이 필요하다는 내용이 화면에 표시되고 누락된 사용 권한이 강조표시됩니다.

LogMiner 인터페이스에 액세스하려면

  • Database 메뉴에서 Diagnose|LogMiner를 선택합니다.

Toad에서는 Oracles LogMiner 패키지를 쉽게 사용할 수 있습니다. 인터페이스는 다음 단계를 포함하여 마법사 형식으로 디자인되었습니다.

1단계: 기존 사전 파일을 지정하거나 새 파일을 만듭니다.

2단계: 조사할 파일을 지정합니다.

3단계: 조사할 날짜와 SCN의 범위를 선택합니다.

4단계: V$LOGMNR_CONTENTS의 내용을 봅니다.

요구 사항

Toad에서는 LogMiner를 시작하기 전에 LogMiner를 사용하기 위한 모든 요구 사항을 충족하는지 확인합니다. 여기에는 다음 항목이 포함됩니다.

  • DBMS_LOGMNR에 대한 실행 권한

  • DBMS_LOGMNR_D에 대한 실행 권한

  • V$LOGMNR_CONTENTS에 대한 선택 권한

  • V$LOGMNR_LOGS에 대한 선택 권한

  • init.ora에 설정된 UTL_FILE_DIR 매개 변수(Oracle 8i의 경우만 필요)

이러한 매개 변수를 충족하지 않을 경우 이를 나열하는 화면이 표시되고 누락된 요구 사항이 빨간색으로 표시됩니다.


LogMiner: 1단계

이 마법사 단계에서는 사전 파일(데이터베이스의 현재 데이터 사전 내용을 포함하는 텍스트 파일)을 지정할 수 있습니다.

DBMS_LOGMNR_D.BUILD를 사용하여 새 사전 파일을 만들거나 기존 파일의 위치를 지정할 수 있습니다.

이 창에서는 해당 설정이 저장됩니다. 경로와 파일 이름을 입력한 경우 마법사를 닫습니다. 경로와 파일 이름은 창을 다시 열 때 채워집니다.

Oracle 8i

Verify UTL_FILE Parameter

이 상자에는 UTL_FILE_DIR의 값이 표시됩니다.

값이 잘못된 경우 init.ora 파일을 편집한 다음 데이터베이스를 종료했다가 다시 시작하여 매개 변수 변경을 적용해야 합니다.

Dictionary File Name 및 Path

이 상자를 사용하면 사전의 파일 이름과 디렉토리 경로를 입력할 수 있습니다. 새 파일을 만드는지 아니면 기존 파일을 사용하는지 여부에 상관없이 이러한 경로를 입력해야 합니다.

사전 파일 경로는 데이터베이스 서버와 UTL_FILE에서 액세스할 수 있는 경로여야 합니다.

Oracle 9i

Dictionary

  • Use Online Data Dictionary - 이 옵션은 파일 작성이 필요하지 않기 때문에 가장 빠릅니다.

  • Use Dictionary in Redo Logs - 이 옵션은 다음 영역인 "Next" 단추 작업을 활성화하므로 새 사전을 작성할지 아니면 기존 사전을 사용할지 선택할 수 있습니다.

Next를 눌러 2단계를 진행합니다.


LogMiner: 2단계

이 단계에서는 조사할 파일을 선택할 수 있습니다.

  1. 여러 방법 중 하나로 Browse 단추에서 파일을 선택합니다. Browse 단추를 눌러 표준 찾아보기 대화 상자를 엽니다.

드롭다운을 채우기 위해 Toad는 ARCHIVE_LOG_DEST 매개 변수가 설정되었는지 확인합니다. 설정된 경우 다음 옵션이 모두 표시됩니다. 설정되지 않은 경우 Browse in Redo Log Directory만 표시됩니다.

  • 드롭다운에서 Browse in Redo Log Directory를 선택하여 다시 실행 로그 디렉토리에서 찾아보기 대화 상자를 엽니다. 서버에 매핑된 네트워크 드라이브가 있는 경우 찾아보기 대화 상자에는 다시 실행 로그 디렉토리가 표식되고 그렇지 않은 경우 마지막으로 탐색한 디렉토리가 표시됩니다.

  • 드롭다운에서 Browse in Archive Log Directory를 선택하여 보관 로그 디렉토리에서 찾아보기 대화 상자를 엽니다. 서버에 매핑된 네트워크 드라이브가 있는 경우 찾아보기 대화 상자에는 보관 로그 디렉토리가 표식되고 그렇지 않은 경우 마지막으로 탐색한 디렉토리가 표시됩니다.

데이터베이스가 Unix 서버에 있는 경우 FTP 스타일 대화 상자가 나타납니다.

Oracle 9i를 실행하는 중이고 다시 실행 로그에 사전을 기록한 경우 사전이 포함된 다시 실행 로드를 파일 선택에 포함해야 합니다.

주: 데이터베이스가 로컬 PC가 아니라 Windows Server에서 실행되는 경우 파일을 선택할 때 드라이브 문자가 서버에 있는 것으로 표시되는지 확인해야 합니다. 예를 들어 Browse 창에서 다음 파일이 파일 목록에 추가된 경우

\\Car004555\d$\oracle\oradata\CARY9I\REDO01A.LOG

이 파일을 다음과 같이 변경할 수 있습니다.

D:\oracle\oradata\CARY9I\REDO01A.LOG

파일 목록 창에서 직접 편집할 수 있습니다.

  2. Next를 눌러 3단계를 진행합니다.


LogMiner: 3단계

LogMiner 인터페이스의 3단계에서는 조사할 날짜 범위와 SCN 범위가 제공됩니다. 이러한 옵션을 그대로 사용하거나 변경할 수 있습니다.

Narrowing the range

SCN 범위 또는 날짜 범위를 좁힐 수 있습니다. 또는 Toad에서 선택한 범위를 조사할 수 있습니다.

Expanding the range

이 화면에서 범위를 확장할 경우 ORA 오류가 제공됩니다. 범위를 확장하려면 Back을 누르고 조사할 추가 파일을 선택합니다.

Oracle 9i

Oracle 9i를 사용하는 중이면 다음을 선택할 수도 있습니다.

Show committed data only

이 옵션을 사용하면 커밋되지 않은 모든 데이터 변경을 무시할 수 있습니다. 이 옵션을 설정한 경우 커밋된 트랜잭션에 해당하는 DML만 반환됩니다.

DDL Dictionary Tracking

다시 실행 로그 파일에 사전을 기록한 경우에만 이 옵션을 사용할 수 있습니다. 온라인 사전을 사용하는 중이면 이 옵션을 사용할 수 없습니다.

이 옵션을 선택할 경우 LogMiner를 위해 다시 실행 로그에 후속 DDL 변경 내용이 기록되므로 올바른 SQL_REDO 및 SQL_UNDO 정보가 유지 관리됩니다.

No Dictionary Reset on Select

이 옵션은 DDL Dictionary Tracking을 선택한 경우에만 활성화됩니다.

이 옵션을 선택할 경우 V$LOGMNR_CONTENTS에서 모든 선택 작업이 수행되기 전에 LogMiner는 해당 내부 사전을 다시 로드하지 않습니다.

계속

  • 범위를 원하는 대로 편집했으면 Next를 눌러 4단계를 진행합니다.


LogMiner: 4단계

이 단계에서는 조사 결과를 볼 수 있습니다. 그리드는 처음 표시될 때 비어 있습니다. 아래 설명된 대로 결과를 여기에서 보거나 편집기 창에서 볼 수 있습니다.

LogMiner 인터페이스 그리드

조사 결과를 확인하는 기본 방법은 LogMiner의 고유한 인터페이스 그리드 내에서 보는 것입니다.

LogMiner 인터페이스 그리드에서 결과를 보려면

  1. 탭의 왼쪽 상단에 있는 Options [image] 단추를 누릅니다. 열 옵션 목록이 나타납니다.

  2. 표시할 열을 선택합니다.

  3. 다음 중 하나를 수행할 수 있습니다.

  4. LogMiner SQL을 즉시 실행: Execute [image] 단추를 누릅니다. 요청한 정보로 그리드가 채워집니다.

  • 나중에 편집, 저장 및 실행하기 위해 SQL을 편집기에 복사: SQL [image] 단추를 누릅니다. SQL이 로드된 새 편집기 창이 열립니다.

  4. 그리드를 마우스 오른쪽 단추로 누르고 다음을 선택합니다.

  • Print Grid – 이 옵션은 그리드 콘텐츠의 서식을 지정하고 인쇄할 수 있는 Report Link Designer를 표시합니다.

  • Save as – 이 옵션을 사용하면 그리드의 콘텐츠를 파일이나 클립보드에 내보낼 수 있습니다.

  • Filter– 이 옵션을 사용하면 사용자의 요구에 더 적합한 형식으로 검색되는 정보를 필터링할 수 있습니다. 부울 필터 조건을 설정하여 그리드에 적용할 수 있습니다. Cancel을 누르거나 대화 상자를 닫고 작업을 계속합니다. 필터 대화 상자를 열고 Clear를 누를 때까지 필터는 그리드에 남아 있습니다.

편집기에서 작업

또는 이 창을 열어 두고 편집기 창을 열어 결과를 볼 수 있습니다. v$logmnr_contents에서 더 정확한 데이터 집합을 검색할 수 있도록 ‘where 절’을 지정하려면 이 작업이 필요할 수 있습니다.

편집기에서 결과를 보려면

  • v$logmnr_contents에서 데이터를 SELECT합니다. 이 데이터는 데이터베이스의 현재 세션에서만 사용할 수 있습니다. LogMiner 인터페이스 창을 닫거나 Back을 누르면 지워집니다.


Segment Advisor

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Oracle 10g 이상에서 활성화되는 이 화면은 Oracle의 Segment Advisor에 대한 인터페이스입니다. 여기서는 테이블, 색인 및 파티션을 검사하여 SHRINK 명령으로 공간을 확보할 수 있는지, 있다면 얼마나 확보할 수 있는지 확인할 수 있습니다.

Segment Advisor는 세 가지 수준에서 조언을 생성합니다.

  • 개체 수준에서는 테이블과 같은 전체 개체에 대해 조언이 생성됩니다. 개체가 파티션으로 분할된 경우에는 개체의 모든 파티션에 대해 조언이 생성됩니다. 색인, LOB 세그먼트 등의 종속 개체까지 계단식으로 조언이 정렬되지는 않습니다.

  • 세그먼트 수준에서는 파티션이 분할되지 않은 테이블, 파티션이 분할된 테이블의 파티션이나 하위 파티션 또는 색인이나 LOB 열과 같은 단일 세그먼트에 대해 조언이 생성됩니다.

  • 테이블 공간 수준에서는 테이블 공간에 있는 모든 세그먼트에 대해 조언이 생성됩니다.

Segment Advisor는 Advisor 작업을 쉽게 수행할 수 있는 세 개의 탭으로 구성됩니다.

  • Examine Objects

  • Advisor Tasks

  • Advisor Recommendations

관련 개체

Examining Objects

Advisor Tasks

Advisor Recommendations

Excel Style Filtering


SA_Examining Objects

Examining Objects

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Segment Advisor의 핵심에는 개체를 검사하고 권장 사항을 제안하는 기능에 있습니다. 소유자, 개체 유형 또는 테이블 공간별로 개체를 본 후 검사할 개체를 선택할 수 있습니다.

개체를 검사하려면

  1. Database 메뉴에서 Diagnose|Segment Advisor를 선택합니다.

  2. Examine Objects 탭을 누릅니다.

  3. Object Owner 드롭다운 메뉴에서 스키마를 선택합니다.

  4. 개체 유형을 선택합니다. 다음과 같은 옵션이 있습니다.

  5. All

  6. Indexes

  7. Tables

  5. Tablespace 드롭다운에서 테이블 공간(또는 모든 테이블 공간)을 선택합니다.

  6. 그리드에서 조언을 얻기 위해 제출할 개체를 선택합니다.

  7. Submit Advisor task for selected objects [image] 단추를 누릅니다.

  8. Segment Advisor options를 선택합니다.

  9. Execute를 누릅니다.

  10. 필요한 경우 연결 정보를 입력하고 Connect를 누릅니다.

관련 개체

Segment Advisor Overview

Advisor Tasks

Advisor Recommendations

Excel Style Filtering


SA_Advisor Tasks

Advisor Tasks

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

개체를 검사하고 나면 Segment Advisor에서 실행하는 작업을 보거나 삭제할 수 있습니다.

작업을 검토하려면

  • Advisor Tasks 탭을 누릅니다.

작업을 삭제하려면

  1. Advisor Tasks 탭을 누릅니다.

  2. 데이터 그리드에서 삭제할 작업을 선택합니다.

  3. Delete Selected Tasks [image] 단추를 누릅니다.

  4. Yes를 눌러 확인합니다.

  5. 필요한 경우 연결 정보를 입력하고 Connect를 누릅니다.

관련 개체

Segment Advisor Overview

Examining Objects

Advisor Recommendations

Excel Style Filtering


SA_Advisor Recommendations

Advisor Recommendations

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Advisor Recommendations는 Segment Advisor 작업의 출력입니다. Toad에서는 Recommendations를 읽기 쉬운 그리드 형식으로 정렬합니다.

사용자가 작성한 작업만 표시할 수도 있고 Toad를 통해 입력된 작업만 표시할 수도 있습니다.

Recommendation 도구 모음

단추 | 명령
 | Recommendation 스크립트 표시
 | Recommendation 스크립트 실행
 | 스크립트 실행 예약
 | 상태(Accept, Ignore, Implemented, Reject) 설정
 | 선택한 작업 삭제
 | 그리드 새로 고침

Recommendations 작업을 수행하려면

  1. 사용할 Recommendation을 선택합니다.

  2. 도구 모음 단추 중 하나를 누릅니다.

  3. 필요한 단계를 완료합니다.

관련 개체

Segment Advisor Overview

Examining Objects

Advisor Tasks

Excel Style Filtering


TKProf Interface 마법사

TKProf Interface 마법사를 사용하여 Oracle의 TKPROF 기능을 쉽게 사용하고 필요한 스크립트를 작성하여 매개 변수 및 옵션을 설정할 수 있습니다.

이 마법사를 액세스하려면

  • Diagnose|TKProf Interface를 선택합니다.

  • 화면 1을 통해 ora.ini에서 관련 매개 변수 정보를 보고 입력 및 출력 파일을 정의할 수 있습니다.

  • 화면 2를 통해 정렬 옵션을 선택할 수 있습니다.

  • 화면 3을 통해 추가 옵션을 선택하고 TKPROF를 실행할 수 있습니다.


TKPROF - 화면 1

Helpful Information

이 섹션은 Ora.ini 매개 변수 정보를 표시합니다. 이 정보를 보려면 v_$parameter에 대한 선택 권한이 필요합니다.

Define Input and Output Files

이 영역에서 TKPROF가 사용하는 다양한 입력 및 출력 파일을 정의할 수 있습니다. 다음과 같이 파일을 선택 또는 취소합니다.

Input Files

추적을 활성화했을 때 Oracle에서 만든 추적 파일입니다. Oracle은 스크립트 USER_DUMP_DEST에서 지정한 디렉토리("udump 디렉토리"라고도 함)에 이 파일을 보관합니다.

입력 파일을 추가하려면

  • 입력 파일 창의 상단에서 드릴다운 단추를 눌러 다음을 선택합니다.

  • Browse Windows files - Windows OS에서 파일을 선택합니다.

  • Open files with FTP - UNIX 기반의 서버 파일을 선택할 수 있습니다.

  • UNIX File name Browse (no file transfer) - 송신하지 않고 UNIX 서버에서 파일을 선택할 수 있습니다. 서버에 계속 남아 있는 추적 파일에 대해 TKProf를 실행할 경우 코드를 복사하고 서버측에 실행해야 합니다. TKProf- 화면 3의 클립보드에 코드 복사를 참조하십시오.

이 필드에 원하는 만큼 입력 파일을 입력합니다. 하지만 최소한 하나는 입력해야 합니다.

Output Files

출력 파일은 입력 파일과 동일한 디렉토리에 보관됩니다. 파일 이름은 동일하지만 확장자는 다릅니다.

필요한 경우 이 확장자를 변경할 수 있습니다.

Insert Files

삽입 파일은 TKPROF에서 만든 스크립트입니다. 데이터베이스 표에 추적 파일의 결과를 삽입합니다.

Record Files

기록 파일은 TKPROF에서 만든 스크립트입니다. 추적한 세션에서 발행한 SQL 구문을 기록합니다.

  • Next를 눌러 계속합니다.


TKPROF - 화면 2

Sort Options

이 화면에서 출력 파일에서 SQL 구문을 정렬하는 방식을 정의할 수 있습니다. 하나 이상의 정렬 옵션을 선택할 수 있으며 정렬 결과는 목록의 위에서 아래로 누적됩니다.

  • 옵션의 왼쪽에 있는 상자를 표시하여 정렬 옵션을 선택합니다.

  • Next를 눌러 계속합니다.


TKPROF - 화면 3

이 화면에서 TKPROF로 SQL 구문을 수집하는 방식 및 TKPROF 실행 방식에 대한 마지막 옵션을 설정할 수 있습니다.

Other Options

TKPROF가 따라야 할 다른 옵션을 설정합니다. 다음과 같습니다.

  • Limit the number of SQL statements in the file to ___

  • Aggregate multiple uses of the same SQL statements

  • Show recursive SQL statements

  • Connect to DB to perform Explain Plan

  • Use this table for Explain Plan (Connect to DB to perform Explain Plan을 선택하여 이 옵션 사용)

Execution Options

Execute Locally

Toad는 컴퓨터에 위치한 TKPROF의 인스턴스를 호출합니다. 데이터베이스에 연결하여 Explain Plan을 수행할 수 있는 옵션을 선택하지 않은 경우 이전 또는 동일 버전의 모든 Oracle 데이터베이스의 파일을 시스템에 복사하여 TKPROF를 실행할 수 있습니다. 이것은 데이터베이스 작동 없이 파일 분석으로 작동합니다. Toad Options|Executables 아래에서 TKPROF의 위치를 정의합니다.

View Output Files When Finished

이 상자를 표시하여 외부 편집기를 자동으로 열고 출력 파일을 봅니다.

기본값으로, 선택한 입력 파일이 하나만 있을 경우 표시되어 있고 선택한 입력 파일이 여러 개가 있을 경우 표시되어 있지 않습니다.

Just copy the commands to the clipboard

이 옵션을 사용하여 생성된 명령을 모두 클립보드에 복사할 수 있습니다. 텔넷으로 Unix 시스템에서 TKPROF를 실행할 경우 이 옵션을 사용할 수 있습니다. Toad의 TKPROF 인터페이스에서 입력할 필요 없이 코드를 붙여 넣을 수 있습니다.

Running TKPROF

마지막 옵션을 선택했으면 Finish를 눌러 TKPROF를 실행합니다.

주: 입력 파일을 한 개라도 선택하지 않았을 경우 Finish를 눌러도 아무 것도 실행되지 않습니다. 관련 옵션을 모두 선택하고 Finish를 누르면 확인 대화상자가 나타납니다.


Undo Advisor

Undo Advisor 개요

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Oracle 버전 10g 이상의 Undo Advisor는 데이터베이스 실행 취소 환경의 구성을 자동화하는 데 대한 조언과 도움말을 제공합니다.

Advisor에서는 전체 또는 지정 시간 범위 내에서의 현재 실행 취소 구성 상태를 알릴 수 있습니다. 이 기준선에서 다음을 수행할 수 있습니다.

  • 실행 취소 테이블 공간 수정

  • 다른 실행 취소 테이블 공간으로 전환

  • 데이터베이스의 보존 시간 조정

  • 정의한 보존 시간에 필요한 실행 취소 공간 프로젝션 작성

Undo Advisor에 액세스하려면

  • DBA 메뉴에서 Undo Advisor를 선택합니다.

Undo Advisor 도구 모음

Undo Advisor 도구 모음은 실행 취소 테이블 공간을 수정하고 실행 취소 환경을 조작하는 데 대한 쉬운 방법을 제공합니다.

단추 | 명령
 | 현재 실행 취소 테이블 공간 변경
 | 실행 취소 보존 변경
 | 현재 테이블 공간 전환
 | 화면에서 날짜 새로 고침

관련 항목

실행 취소 테이블 공간 수정

실행 취소 보존 수정

테이블 공간 전환


실행 취소 테이블 공간 수정

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Undo Advisor를 사용하면 현재 실행 취소 테이블 공간 값을 수정할 수 있습니다.

기본 정보 옵션 중 일부를 변경하고 데이터 파일을 추가, 편집 또는 제거할 수도 있습니다.

실행 취소 테이블 공간을 수정하려면

  1. 현재 테이블 공간이 수정할 테이블 공간인지 확인합니다. 그렇지 않으면 계속하기 전에 올바른 테이블 공간으로 전환합니다.

  2. Undo Advisor 도구 모음에서 Alter tablespace [image] 단추를 누릅니다.

  3. 원하는 대로 tablespace 옵션을 변경합니다.

  4. OK를 누릅니다.

관련 항목

Undo Advisor 개요

실행 취소 보존 수정

테이블 공간 전환


실행 취소 보존 수정

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

실행 취소 보존 시간을 쉽게 변경할 수 있습니다. 이 시간 프레임을 수정하려면 추가 테이블 공간이 필요할 수도 있습니다. 그 때문에 Toad에서는 필요한 공간을 측정할 수 있도록 추정 값을 제공합니다.

필요한 테이블 공간을 추정하려면

  • For this amount of retention 상자에 원하는 보존 값을 입력합니다.

선택한 옵션에 필요한 실행 취소 크기가 아래에 표시됩니다.

실행 취소 보존 값을 수정하려면

  1. Alter Undo Retention [image] 단추를 누릅니다.

  2. 상자에 원하는 보존 기간을 입력합니다.

  3. OK를 누릅니다.

관련 항목

Undo Advisor 개요

실행 취소 테이블 공간 수정

테이블 공간 전환


테이블 공간 전환

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

여러 실행 취소 테이블 공간이 있는 경우 Undo Advisor에서 이러한 테이블 공간 간에 쉽게 전환할 수 있습니다.

테이블 공간 간에 전환하려면

  • Undo Advisor에서 Switch between tablespaces [image] 단추를 누르고 활성화할 테이블 공간을 선택합니다.

관련 항목

Undo Advisor 개요

실행 취소 테이블 공간 변경

실행 취소 유지 변경


부여 내보내기

이 대화상자에서 선택한 부여를 ASCII 파일 또는 클립보드로 내보냅니다. 일부가 손실 또는 삭제되었을 경우 부여를 다시 작성할 때 도움이 됩니다.

부여를 내보내려면

  1. Database|Export|Grants 메뉴 항목을 선택합니다.

  2. 내보낼 부여가 포함된 스키마를 선택합니다.

  3. 필요한 경우 Only include grants issued BY the selected schema를 표시하거나 선택 취소합니다.

  4. 저장할 파일을 선택합니다.

또는

클립보드에 부여를 복사하기로 선택합니다.

  5. OK를 눌러 부여를 내보냅니다.


시퀀스 내보내기

이 대화상자에서 파일 또는 Windows 클립보드에 데이터베이스 시퀀스를 내보냅니다.

시퀀스를 내보내려면

  • Database|Export|Sequences 메뉴 항목을 선택합니다.

주: Start Sequences at NextVal+1의 옵션을 선택하고 시퀀스에 CACHE 값이 있으면 시퀀스가 CACHE value +1로 시작됩니다.

관련 항목

시퀀스

시퀀스 작성

시퀀스 변경


창: Source Code Export

Export Source Code

이 기능을 사용하여 프로시저, 함수, 패키지, 트리거 및/또는 보기를 각 파일에 개체 하나씩 들어 있는 파일로 내보냅니다.

원본 코드를 내보내려면

  1. Database|Export|Source Code 메뉴 항목에서 이 대화상자를 열 수 있습니다.

  2. Export Source Code 대화상자에서 Schema/Owner를 선택합니다.

  3. 내보낼 개체 를 선택합니다. 개체를 하나 또는 모두 선택할 수 있습니다. 내보낼 개체를 하나 이상 선택하려면(모두는 아님) 내보내기를 여러 번 수행해야 합니다.

  4. 파일을 저장할 위치를 선택합니다.

  • Create one File for all objects (specify file below)-Toad가 하나의 파일을 작성합니다. 라디오 단추 아래의 상자에 파일 및 경로 이름을 입력합니다.

  • Each object to a separate file (select path below) -경로 이름을 입력하거나 …을 누른 다음 폴더를 선택합니다. Toad가 각 개체에 선택한 폴더에 원본 코드 파일을 별도로 작성합니다. 파일 이름을 소문자로 선택할 수 있습니다.

  • Group objects in the following files: -- 각 개체 형식의 경로 이름을 입력하거나 [image] 을 누르고 해당 파일을 선택합니다.

  5. Execute 를 눌러 원본 코드를 내보냅니다.

Source Import 창에서 파일의 개체를 분석하고 데이터베이스로 다시 가져옵니다.


동의어 내보내기

이 대화상자에서 파일로 동의어를 내보냅니다.

동의어를 내보내려면

  • Database|Export|Synonyms 메뉴 항목을 선택합니다.

옵션에는 각 동의어의 "DROP SYNONYM" 명령을 추가하는 것도 포함됩니다.

선택한 스키마 소유의 개체 동의어 또는 선택한 스키마 소유의 동의어를 내보낼 수 있습니다.

예제 출력

DROP PUBLIC SYNONYM ALL_ALL_TABLES ;
DROP PUBLIC SYNONYM ALL_ARGUMENTS ;
DROP PUBLIC SYNONYM ALL_CATALOG ;
DROP PUBLIC SYNONYM ALL_CLUSTERS ;
CREATE PUBLIC SYNONYM ALL_ALL_TABLES FORSYS.ALL_ALL_TABLES ;
CREATE PUBLIC SYNONYM ALL_ARGUMENTSFOR SYS.ALL_ARGUMENTS ;
CREATE PUBLIC SYNONYM ALL_CATALOG FORSYS.ALL_CATALOG ;
CREATE PUBLIC SYNONYM ALL_CLUSTERS FORSYS.ALL_CLUSTERS ;


표를 단일 파일로 내보내기

이 기능을 사용하여 값 사이에 <TAB> 문자 또는 "," 쉼표 문자가 들어 있지 않은 단일 파일을 작성합니다.

Database|Export|Table as Flat File 메뉴 항목에서 이 대화상자를 열 수 있습니다.

Options 탭에서 내보낼 표를 선택합니다.

세부 사항 파일을 설정해야 합니다. 이 파일에는 표 이름, 표 소유자, 데이터 레코드 하나로 적용되는 출력 파일의 줄 수, 데이터 열, 표시되는 줄 위치, 시작 열 및 데이터 열 길이 등이 정의되어 있습니다.

예제 세부 사항 파일

TABLENAME=EMPLOYEE

TABLEOWNER=DEMO

LINESPERRECORD=1

COL1=EMPLOYEE_ID,1,1,5

COL2=LAST_NAME,1,6,15

COL3=FIRST_NAME,1,21,15

COL4=MIDDLE_INITIAL,1,36,1

COL5=JOB_ID,1,37,4

COL6=MANAGER_ID,1,41,5

COL7=HIRE_DATE,1,46,22

COL8=SALARY,1,68,10

COL9=COMMISSION,1,78,10

COL10=DEPARTMENT_ID,1,88,3

내보낸 예제 단일 파일

7369 SMITH JOHN Q667 7902 12/17/1984 800 20

7499 ALLEN KEVIN J670 7698 2/20/1985 1600 300 30

7505 DOYLE JEAN K671 7839 4/4/1985 2850 13

7506 DENNIS LYNN S671 7839 5/15/1985 2750 23

7507 BAKER LESLIE D671 7839 6/10/1985 2200 14


창: Data Export

Data Export 창

데이터 내보내기를 액세스하려면

  • Database 메뉴에서 Export 를 선택한 다음 Table Data 메뉴 항목을 선택합니다.

또는

Schema Browser에서 Tables 탭을 선택합니다. 개체 패널에서 표를 선택하고Export Data 단추를 누릅니다. 선택한 내용에 Data Export 창이 나타납니다.

이 대화상자를 사용하여 표 데이터로 만들 표를 선택하면 Toad가 선택한 표 데이터의 "INSERT INTO" SQL 구문이 포함된 파일을 작성합니다.

주: Toad는 LONG 또는 LONG RAW 열을 내보낼 수 없습니다. 그러나 Toad는 새 VARCHAR2(4000) 열을 내보냅니다.

옵션에는 소유자가 있는 표 미리 수정, NULL 열 제외 및 모든 표에 단일 출력 파일 또는 별도 출력 파일 작성 등이 포함됩니다.

Data Export 창은 NUMBER, FLOAT, CHAR, DATE 및 VARCHAR2 개체 형식을 지원합니다.

Schema Browser 창에서 사용할 수 있는 Data Export 기능은 Database > Export > Data Export 기능과는 약간 다릅니다. 데이터 필터링을 위해 클립보드 또는 선택 사항 WHERE 절로 내보낼 수 있도록 허용하기 때문입니다. 이 기능을 사용하여 내보낼 특정 열을 선택하고 Commit 구문 삽입 빈도를 선택할 수 있습니다.

Exclude Primary Key Columns

표시되어 있으면 기본 키 열이 선택 취소됩니다. 기본 키 열을 표시하면 이 상자가 선택 취소됩니다. 기본 키 열이 없으면 이 선택 사항이 활성화되지 않습니다.

관련 항목

삽입 구문 작성

단일 파일로 내보내기


Export File Browser 개요

주: 이 Toad 기능은 Toad for Oracle Professional 또는 선택 사항인 Quest DBA Module에서만 사용할 수 있습니다.

Toad의 Export File Browser를 사용하면 내보내기 파일을 쉽게 탐색하고 다음과 같은 항목에 포함된 파일 정보를 볼 수 있습니다.

  • 스키마

  • DDL

  • 데이터

  • 코드

  • 함수

  • 개체 형식 본문

  • 패키지

  • 패키지 본문

  • 프로시저

  • 트리거

  • 조정 및 구성

  • 그룹 새로 고침

Export File Browser 창

Export File Browser의 왼쪽에는 파일 콘텐츠에 대한 트리 보기가 포함되어 있습니다. 오른쪽에는 왼쪽에서 선택한 항목의 세부 정보가 표시됩니다.

관련 항목

Export File Browser 도구 모음

내보내기 파일 보기

DDL 작업

데이터 집합 작업

DB Compare Mode 개요


Export File Browser 도구 모음

주: 이 Toad 기능은 Toad for Oracle Professional 또는 선택 사항인 Quest DBA Module에서만 사용할 수 있습니다.

Export File Browser 도구 모음을 사용하면 왼쪽의 트리 구조에 대한 작업을 수행할 수 있습니다.

주의: Export File Browser에 의해 생성된 스크립트가 내보내기 파일에 포함된 개체를 파악하는 데 매우 적합하지만 이러한 스크립트는 Oracle의 IMP 유틸리티에서만 실행하도록 되어 있습니다. 추출된 대부분의 DDL이 표준 SQL로 실행되지만 일부는 그렇지 않습니다. Export File Browser에 의해 생성된 스크립트를 실행하기 전에 신중하게 검사하십시오.

단추 | 명령
 | 내보내기 파일 열기
 | 모든 노드 확장
 | 모든 노드 축소
 | 전체 내보내기 파일에서 스크립트 만들기
 | 선택한 노드 및 하위 노드에 대한 DDL 추출
 | 트리 정보를 XML로 저장
 | 데이터베이스 비교 모드 전환
 | 데이터 집합 행 제한 조정

관련 항목

Export File Browser 개요

Export File Browser 도구 모음

내보내기 파일 보기

DDL 작업

데이터 집합 작업

DB Compare Mode 개요

비교 그리드 읽기


내보내기 파일 보기

주: 이 Toad 기능은 Toad for Oracle Professional 또는 선택 사항인 Quest DBA Module에서만 사용할 수 있습니다.

Export File Browser를 사용하여 내보내기 파일을 가져오기 전에 파일의 내용을 볼 수 있습니다.

내보내기 파일을 열려면

  1. Database 메뉴에서 Export를 선택한 다음 Export File Browser를 선택합니다.

  2. Export File Browser 도구 모음에서 Open Export File [image] 단추를 누릅니다.

  3. Open Export File 창에서 열려는 파일을 선택합니다.

  4. 확인을 누릅니다.

주: 이전에 파일이 구문 분석되지 않은 경우 처리하려면몇 분 정도 걸릴 수 있습니다. 창의 맨 아래에 있는 상태 영역에 처리 진행률이 표시됩니다.

관련 항목

Export File Browser 개요

Export File Browser 도구 모음

내보내기 파일 보기

DDL 작업

데이터 집합 작업


내보내기 파일에서 정보 찾기

주: 이 Toad 기능은 Toad for Oracle Professional 또는 선택 사항인 Quest DBA Module에서만 사용할 수 있습니다.

오른쪽 트리 보기를 사용하여 보려는 내보내기 파일의 일부를 선택합니다. 노드는 다음을 기준으로 구성됩니다.

  • 스키마

  • 저장소

  • 보안

  • 코드

  • 조정 및 구성

개체 노드는 괄호로 묶은 해당 형식의 개체 수가 옆에 표시됩니다. 예를 들어 Schemas (6)과 같이 표시됩니다. 이 경우 Schemas 노드를 확장하면 그 아래에서 6개의 스키마를 볼 수 있습니다.

왼쪽에서 DDL 탭을 눌러 코드를 볼 수 있습니다. 선택한 개체에 테이블과 같은 데이터가 있을 경우 Data 탭을 눌러 해당 개체 내의 데이터를 봅니다.

데이터 필터링

Schema Browser에서 작동하는 방식과 동일하게 Quickfilter를 사용할 수 있습니다(Quickfilter 상자 사용 항목 참조). 그러나 트리 보기에서 결과가 약간 다르게 표시됩니다.

트리 보기 읽기

적용된 필터가 없을 경우(Quickfilter 상자에 *) 예를 들어 특정 스키마에 42개의 테이블이 있으면 Tables (42)와 같은 노드가 표시됩니다.

이러한 테이블 중 10개만 표시하는 필터가 적용된 경우 해당 노드는 Tables (? of 42) 또는 Tables (10 of 42)로 표시됩니다.

?는 노드를 아직 확장하지 않았기 때문에 필터를 통과하는 테이블 수가 알려지지 않았다는 것을 나타냅니다.

(10 of 42)는 노드가 확장되었거나 현재 확장된다는 것을 나타냅니다.

모든 테이블이 필터링된 경우 테이블 노드도 숨겨지기 때문에 Tables (0 of 42)는 표시되지 않습니다. 스키마 수준 노드는 아래의 모든 항목이 숨겨지더라도 숨겨지지 않습니다.

원하는 항목을 신속하게 찾으려면

  1. Export File Browser에서 내보내기 파일을 엽니다.

  2. 해당 이름이나 적절한 필터를 Quickedit 상자에 입력합니다.

  3. Expand All [image] 단추를 누릅니다.

관련 항목

Export File Browser 개요

Export File Browser 도구 모음

내보내기 파일 보기

DDL 작업

데이터 집합 작업

Quickfilter 상자 사용


Open Export File 창

주: 이 Toad 기능은 Toad for Oracle Professional 또는 선택 사항인 Quest DBA Module에서만 사용할 수 있습니다.

Open Export File 창은 단순히 파일 선택 화면이 아닙니다. 이 창에서는 기본 파일 정보, 만든 사람, 구문 분석되었는지 여부 등을 포함하여 내보내기 파일에 대한 정보가 제공됩니다.

창 레이아웃

Open Export File 창의 오른쪽에는 디렉토리 트리가 있습니다. 이 트리를 사용하여 열려는 파일을 찾습니다. 이 트리는 Windows 탐색기와 동일한 방식으로 작동합니다.

디렉토리를 선택하면 오른쪽에 파일이 나열됩니다. 기본적으로 디렉토리에 있는 .dmp 파일만 표시됩니다.

디렉토리의 모든 파일을 보려면

  • File Type 상자에서 All Files를 선택합니다.

모든 파일을 선택한 경우 내보내기 파일(확장명 .dmp)이 아닌 파일의 경우에 정보 그리드가 더 엷게 채워집니다. 내보내기 파일이 아닌 파일은 File Name, File Size 및 File Date만 표시됩니다.

구문 분석된 파일 색

Toad에서는 이전에 구문 분석했던 파일의 색을 변경하여 이러한 파일을 추적합니다.

기본적으로 구문 분석되지 않은 모든 파일은 검정으로 표시됩니다. 구문 분석된 파일은 녹색으로 표시됩니다.

구문 분석된 파일의 색을 변경하려면

  1. 화면의 왼쪽 아래에서 Settings 단추를 누릅니다.

  2. Set pre-parsed color를 선택합니다.

  3. 사용할 색을 선택하고 OK를 누릅니다.

선택한 파일의 구문 분석 정보를 제거하려면

  1. 화면의 왼쪽 아래에서 Settings 단추를 누릅니다.

  2. Remove pre-parsed information를 선택합니다.

구문 분석 정보를 완전히 제거하려면

  • Toad Directory|ParsedExportFiles 디렉토리에서 모든 파일을 제거합니다.

관련 항목

Export File Browser 개요

Export File Browser 도구 모음

내보내기 파일 보기


DB Compare Mode 개요

주: 이 Toad 기능은 Toad for Oracle Professional 또는 선택 사항인 Quest DBA Module에서만 사용할 수 있습니다.

Export File Browser를 사용하여 데이터베이스의 개체와 내보내기 파일을 비교할 수 있습니다. 이 비교는 피상적인 작업이며 데이터 수준의 심층적인 차이를 나타내지는 않습니다.

선택한 모든 노드 및 데이터베이스에 대해 개체가 파일이나 데이터베이스에 있는지 아니면 둘 다에 있는지 여부를 나타내는 확인란이 표시됩니다.

파일을 데이터베이스와 비교하려면

  1. 브라우저에서 데이터 내보내기 파일을 엽니다.

  2. DB Compare Mode [image] 단추를 누릅니다.

  3. 오른쪽 비교 화면에 있는 연결 드롭다운에서 파일과 비교할 연결을 선택합니다.

주: 사용할 연결이 드롭다운에 나열되지 않은 경우 다음 중 하나를 수행할 수 있습니다.

  • 연결 드릴다운을 누른 다음 New를 눌러 새 연결을 엽니다.

  • Session menu|New Connection에서 새 연결을 엽니다.

  4. 왼쪽에서 선택한 데이터베이스와 비교할 하나 이상의 노드를 선택합니다.

관련 항목

Export File Browser 개요

Export File Browser 도구 모음

비교 그리드 읽기


비교 그리드 읽기

주: 이 Toad 기능은 Toad for Oracle Professional 또는 선택 사항인 Quest DBA Module에서만 사용할 수 있습니다.

비교 모드 그리드는 데이터베이스와 선택한 노드에 대한 기본 정보를 제공합니다.

Grid|Save As 메뉴 항목에서 비교 그리드를 인쇄하거나 내보낼 수 있습니다.

다음과 같은 열이 있습니다.

  • Type - 선택한 개체의 형식을 나열합니다.

  • Owner - 선택한 개체의 소유자를 나열합니다.

  • Name - 선택한 개체의 이름을 나열합니다.

  • Parent - 선택한 개체에 상위 개체가 있을 경우(예: 제약 조건 또는 인덱스) 상위 개체가 여기에 나열됩니다.

  • Obj in File? - 개체가 파일에 있을 경우 이 상자가 선택됩니다.

  • Obj in Database? - 개체가 데이터베이스에 있을 경우 이 상자가 선택됩니다.

문제 해결

Toad에서 .dmp 파일을 구문 분석하는 방법으로 인해 일부 항목이 데이터베이스에 있지만 파일에는 없는 것으로 나열됩니다. 여기에는 다음 항목이 포함됩니다.

  • 다음과 같이 테이블 ddl과 함께 인라인으로 만들어진 제약 조건:

CREATE TABLE WK$DOC_RELEVANCE

(

URL_ID NUMBER NOT NULL ENABLE,

TERM VARCHAR2(500) NOT NULL ENABLE,

SCORE NUMBER NOT NULL ENABLE,

CONSTRAINT WK$DOC_RELEVANCE_PK PRIMARY KEY ("TERM", "URL_ID") ENABLE

);

  • 시스템에서 이름을 지정한 제약 조건

  • 사용자가 제약 조건을 만들 때 Oracle에 의해 만들어진 인덱스

  • SYS, MDSYS 등의 스키마에 있는 여러 개체. 데이터베이스를 만들 때 자동으로 만들어지는 일부 개체는 사용자가 "전체 데이터베이스 내보내기"를 수행하는 경우에도 내보내기 파일에 포함되지 않습니다.

  • 시스템에서 이름을 지정한 해시 파티션 및 하위 파티션

관련 항목

Export File Browser 개요

Export File Browser 도구 모음

DB Compare Mode 개요

비교 그리드 읽기


비교 그리드 고정

주: 이 Toad 기능은 Toad for Oracle Professional 또는 선택 사항인 Quest DBA Module에서만 사용할 수 있습니다.

수행하는 비교에서 데이터가 손실되지 않고 다른 항목을 볼 수 있도록 비교 그리드를 고정할 수 있습니다.

이렇게 하면 비교 모드를 해제하고 브라우저 모드에서 DDL 또는 데이터를 보는 동안에 비교 그리드가 고정됩니다. DB Compare Mode로 돌아가면 왼쪽에서 선택한 항목에 상관없이 마지막으로 수행했던 비교가 그리드에서 활성 상태가 됩니다.

비교 그리드를 고정하려면

  1. Export File Browser에서 노드를 데이터베이스 연결과 비교합니다(절차는 DB Compare Mode 개요 참조).

  2. Freeze Grid 확인란을 선택하여 그리드를 고정합니다.

관련 항목

Export File Browser 개요

DB Compare Mode 개요

비교 그리드 읽기


DDL 작업

주: 이 Toad 기능은 Toad for Oracle Professional 또는 선택 사항인 Quest DBA Module에서만 사용할 수 있습니다.

Export File Browser에서 DDL을 다양한 방법으로 복사하고 붙여넣을 수 있습니다.

다음을 수행할 수 있습니다.

  • DDL을 클립보드에 복사

  • DDL을 파일로 저장

  • 여러 노드에서 DDL 추출

관련 항목

DDL을 클립보드에 복사

DDL을 파일로 저장

여러 노드에서 DDL 추출

Export File Browser 개요


DDL을 클립보드에 복사

주: 이 Toad 기능은 Toad for Oracle Professional 또는 선택 사항인 Quest DBA Module에서만 사용할 수 있습니다.

오른쪽에 있는 DDL을 클립보드에 복사한 다음 다른 편집기 등의 필요한 장소에 붙여넣을 수 있습니다.

오른쪽의 DDL을 클립보드에 복사하려면

  1. 왼쪽 트리 보기에서 개체를 선택하고 오른쪽의 DDL 탭을 누릅니다.

  2. 일부 또는 모든 DDL을 선택합니다.

  3. <CTRL><C>를 누릅니다.

또는

마우스 오른쪽 단추를 누르고 Copy to clipboard를 선택합니다.

주: 일부 개체의 스크립트는 잘못 표시됩니다. 이는 탐색하는 내보내기 파일이 Oracle의 IMP 유틸리티에만 사용하도록 되어 있기 때문입니다. 이와 같은 이유로 스크립트 형태에서 잘못 표시될 수 있는 개체는 다음과 같습니다.

  • 구체화된 보기 및 구체화된 보기 로그

  • 대기열 테이블

  • "전송 가능한 테이블 공간" 모드에서 내보내기를 수행했을 때 저장소(테이블, 인덱스 등)가 있는 모든 개체

관련 항목

DDL 작업

DDL을 파일로 저장

여러 노드에서 DDL 추출

Export File Browser 개요


DDL을 파일로 저장

주: 이 Toad 기능은 Toad for Oracle Professional 또는 선택 사항인 Quest DBA Module에서만 사용할 수 있습니다.

오른쪽의 DDL을 파일에 저장하려면

  1. 왼쪽 트리 보기에서 개체를 선택하고 오른쪽의 DDL 탭을 누릅니다.

  2. 마우스 오른쪽 단추를 누르고 "Save to File"을 선택합니다.

  3. 파일의 이름을 지정하고 Save를 누릅니다.

주: 이 방법은 개체에 대한 모든 DDL을 파일에 저장합니다. 복사 방법에서와 같이 DDL을 선택할 수는 없습니다.

관련 항목

DDL 작업

DDL을 클립보드에 복사

여러 노드에서 DDL 추출

Export File Browser 개요


여러 노드에서 DDL 추출

주: 이 Toad 기능은 Toad for Oracle Professional 또는 선택 사항인 Quest DBA Module에서만 사용할 수 있습니다.

여러 노드의 DDL을 클립보드에 추출한 다음 다른 편집기 등의 필요한 위치에 붙여넣을 수 있습니다.

여러 노드에서 DDL을 추출하려면

  1. 왼쪽 트리 보기에서 하나 이상의 노드를 선택합니다. 이러한 노드는 개체 또는 개체 그룹이 될 수 있습니다.

  2. 트리를 마우스 오른쪽 단추로 누르고 "Extract DDL For Selected Nodes and SubNodes"를 선택합니다.

  3. 확인 대화 상자에서 OK를 누릅니다.

관련 항목

DDL 작업

DDL을 클립보드에 복사

DDL을 파일로 저장

Export File Browser 개요


데이터 집합 작업

주: 이 Toad 기능은 Toad for Oracle Professional 또는 선택 사항인 Quest DBA Module에서만 사용할 수 있습니다.

테이블과 같은 선택한 개체에서 데이터 집합에 대한 작업을 수행할 수 있습니다.

데이터 집합을 보려면

  1. 왼쪽 트리 보기에서 데이터 집합을 보려는 개체를 선택합니다.

  2. 오른쪽에서 Data 탭을 누릅니다.

관련 항목

데이터 집합 도구 모음

행 번호로 이동

행 개수 가져오기

다른 이름으로 저장

그리드 인쇄


데이터 집합 도구 모음

주: 이 Toad 기능은 Toad for Oracle Professional 또는 선택 사항인 Quest DBA Module에서만 사용할 수 있습니다.

Data 탭의 맨 위에 있는 데이터 집합 도구 모음을 통해 데이터를 보는 방법을 조작할 수 있습니다.

단추 | 명령
 | 그리드 필터링
 | 첫 번째 레코드 찾기
 | 이전 레코드 찾기
 | 다음 레코드 찾기
 | 마지막 레코드 찾기
 | 그리드 형식으로 보기
 | 단일 레코드 형식으로 보기

관련 항목

데이터 집합 작업

행 번호로 이동

행 개수 가져오기

다른 이름으로 저장

그리드 인쇄


행 번호로 이동

주: 이 Toad 기능은 Toad for Oracle Professional 또는 선택 사항인 Quest DBA Module에서만 사용할 수 있습니다.

큰 데이터 집합을 사용하는 경우 데이터 내의 특정 행 번호로 직접 이동하는 것이 유리한 경우가 있습니다.

행 번호로 이동하려면

  1. 데이터 그리드를 마우스 오른쪽 단추로 누른 후 Go to Row #를 선택합니다.

  2. 상자에 행 번호를 입력합니다.

  3. 확인을 누릅니다.

주: 행 번호로 이동하기 전에 행 개수 계산을 수행하지 않은 경우 지금 수행됩니다.

관련 항목

데이터 집합 작업

데이터 집합 도구 모음

행 개수 가져오기

다른 이름으로 저장

그리드 인쇄


행 개수 가져오기

주: 이 Toad 기능은 Toad for Oracle Professional 또는 선택 사항인 Quest DBA Module에서만 사용할 수 있습니다.

Toad에서는 테이블의 행 개수를 계산할 수 있습니다. 테이블에 포함된 데이터 집합의 크기를 알고 싶은 경우 이 기능이 유용합니다.

데이터 집합이 포함된 노드를 처음 열면 그 아래에 아무 것도 나열되지 않습니다. 해당 노드에서 Get Row Count를 수행하면 데이터 집합의 행 수가 노드 옆에 괄호로 묶여 나열됩니다. 예를 들면 다음과 같습니다.

데이터 집합에 대한 행 개수를 가져오려면

  • 데이터 그리드를 마우스 오른쪽 단추로 누르고 Get Rowcount를 선택합니다.

관련 항목

데이터 집합 작업

데이터 집합 도구 모음

행 번호로 이동

다른 이름으로 저장

그리드 인쇄


Export Utility 마법사

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Database|Export|Export Utility Wizard 메뉴 항목에서 이 창에 액세스할 수 있습니다.

이 마법사를 사용하면 Oracle의 내보내기 유틸리티를 통해 Oracle 데이터베이스 간에 데이터 개체를 쉽게 전송할 수 있습니다. 이 유틸리티의 경로는 View|Toad Options|Executables 에서 구성합니다.

첫 번째 단계에서는 라디오 단추를 사용하여 내보낼 항목을 선택할 수 있습니다. 선택 항목은 다음과 같습니다.

  • Tables - 선택한 테이블과 모든 종속 개체를 내보냅니다.

  • Users - 선택한 사용자로부터 모든 개체를 내보냅니다.

  • Database - 전체 데이터베이스를 내보냅니다.

  • Export Tablespaces – 전송 가능한 테이블 공간 집합을 생성합니다. 이 옵션을 선택할 경우 다음 단계에서는 SYSDBA 계정에 대한 사용자 이름과 암호를 묻는 메시지가 표시됩니다.

  • Use Parameter File – 기존 매개 변수 파일을 사용하여 내보내기를 수행합니다. 테이블을 내보낼 경우 모든 파티션이 내보내집니다. 파티션을 내보내면 하위 파티션이 내보내집니다.

항목을 선택한 후 Next 를 누르고 창에 표시되는 지침을 따릅니다.

마법사의 마지막 화면에서 Watch Progress (Feedback = 1000)을 선택한 경우 Export Watch 창이 표시되며 내보내기 결과를 즉시 볼 수 있습니다. 또한 Watches 창의 Log 탭을 사용하여 로그를 프린터에 직접 보낼 수 있습니다.


Import/Export Watch 창

가져오기 또는 내보내기 마법사의 마지막 화면에서 Watch Progress (Feedback = 1000)을 선택한 경우 Export Watch 창에는 작업의 결과가 표시됩니다.

Watches 창에는 세 개의 탭인 Output, Log 및 Parameter file이 표시됩니다.

Output

이 화면에는 가져오기 또는 내보내기에 대한 정보가 표시됩니다. "Export terminated successfully without warnings" 등의 결과와 같은 작업 진행률이 표시됩니다.

Log

Log 화면에서는 가져오기나 내보내기를 실행하기 위해 수행된 단계가 기록됩니다.

로그를 인쇄하려면

  • Print를 누릅니다.

Parameter File

매개 변수 파일 레코드는 작업을 수행하는 데 사용된 매개 변수를 기록합니다. Import/Export Utility 마법사의 마지막 단계에서 "Create Parameter file only"를 누른 경우 이 파일이 만들어집니다.

매개 변수 파일을 편집기에 보내려면

  • Editor를 누릅니다.


데이터베이스 내보내기

첫 번째 마법사에서 Database export 라디오 단추를 선택하면 다음 창은 Object and Parameters selection 창이 됩니다.

데이터베이스를 내보내려면

  1. 내보낼 개체 를 선택합니다. 개체에는 표 행, 제약 조건, 부여, 색인 및 트리거가 포함됩니다.

주: 트리거는 Oracle 8.1 이상이 있을 경우에만 사용할 수 있습니다.

  2. 내보내기 파일에 포함할 추가 매개 변수를 지정합니다.

  3. Next를 누릅니다. Select Parameters 대화상자가 나타납니다.

  4. 해당 상자에서 출력 파일 및 로그 파일 이름을 입력합니다. 기본값으로, 로그 파일 이름은 출력 파일에 지정한 이름과 동일하며 .log 확장자가 있습니다.

  5. 해당 상자에서 매개 변수 파일 이름을 입력합니다. 기본값으로, 매개 변수 파일 이름은 출력 파일에 지정한 이름과 동일하며 .dat 확장자가 있습니다.

  6. 동작의 라디오 단추 목록에서 내보내기 동작을 선택합니다. 선택할 수 있는 내용은 다음과 같습니다.

  • Execute Now - 매개 변수 파일을 저장하고 내보내기 유틸리티를 시작합니다.

    • Compress export file (.zip)을 선택하여 내보낸 파일을 자동으로 압축합니다.

    • Watch Progress (Feedback=1000)를 선택하여 로그 파일(Log 탭) 및 매개 변수 파일(Parameter 탭)뿐만 아니라 한 줄씩 실행(Output 탭)을 표시합니다. Parameter File 페이지의 Editor 단추는 Editor를 열고 Parameter File 텍스트에 붙여 넣습니다.

  • Schedule to run later- Windows 예약된 작업을 설정합니다.

  • Just build the parameter file - Toad가 매개 변수 파일만 구성한 다음 마법사를 닫습니다.


매개 변수 내보내기

Export Utility 마법사에서 Use parameter file을 선택하면 매개 변수 선택 창이 나타납니다.

매개 변수를 내보내려면

주: 출력 파일 및 로그 파일 상자가 비활성화되어 있습니다.

  1. Save As 대화상자에서 드릴다운 단추를 누르고 파일을 선택하여 매개 변수 파일을 선택합니다. 매개 변수 파일 이름에는 .dat 확장자가 있습니다.

  2. 아래에 설명된 대로 동작의 라디오 단추 목록에서 내보내기 동작을 선택합니다.

내보내기 동작

여러 내보내기 동작에서 선택할 수 있습니다.

  • Execute Now - 매개 변수 파일을 저장하고 내보내기 유틸리티를 시작합니다.

  • Compress export file (.zip)을 선택하여 내보낸 파일을 자동으로 압축합니다.

  • Watch Progress (Feedback=1000)를 선택하여 로그 파일(Log 탭) 및 매개 변수 파일(Parameter 탭)뿐만 아니라 한 줄씩 실행(Output 탭)을 표시합니다. Parameter File 페이지의 Editor 단추는 Editor를 열고 Parameter File 텍스트에 붙여 넣습니다.

  • Schedule to run later- Windows 예약된 작업을 설정합니다.

  • Just build the parameter file - 매개 변수 파일 내보내기만 선택했으므로 이 옵션은 비활성화되어 있습니다.


표 내보내기

첫 번째 Export Utility 마법사 창에서 표를 선택하면 다음 창은 표 선택 창이 됩니다.

내보낼 표를 지정하려면

  1. Tables to Export 탭의 드롭다운에서 Schema를 선택하고 스키마 디스플레이에서 내보낼 표를 표시합니다. 내보내기 위해 선택한 표가 Selections 탭에 나열됩니다.

  2. Next를 누릅니다.

  3. 내보낼 개체 를 선택합니다. 개체에는 표 행, 제약 조건, 부여, 색인 및 트리거가 포함됩니다.

주: 트리거는 Oracle 8.1 이상이 있을 경우에만 사용할 수 있습니다. LONG 또는 LONG RAW 열은 내보내지지 않습니다. LONG 및 LONG RAW 지원 항목을 참조하십시오.

  4. 내보내기 파일에 포함할 추가 매개 변수를 지정합니다.

  5. Next 를 누릅니다.

  6. 해당 상자에서 출력 파일 및 로그 파일 이름을 입력합니다. 기본값으로, 로그 파일 이름은 출력 파일에 지정한 이름과 동일하며 .log 확장자가 있습니다.

  7. 해당 상자에서 매개 변수 파일 이름을 입력합니다. 기본값으로, 매개 변수 파일 이름은 출력 파일에 지정한 이름과 동일하며 .dat 확장자가 있습니다.

  8. 동작의 라디오 단추 목록에서 내보내기 동작을 선택합니다. 선택할 수 있는 내용은 다음과 같습니다.

  • Execute Now - 매개 변수 파일을 저장하고 내보내기 유틸리티를 시작합니다.

    • Compress export file (.zip)을 선택하여 내보낸 파일을 자동으로 압축합니다.

    • Watch Progress (Feedback=1000)를 선택하여 로그 파일(Log 탭) 및 매개 변수 파일(Parameter 탭)뿐만 아니라 한 줄씩 실행(Output 탭)을 표시합니다. Parameter File 페이지의 Editor 단추는 Editor를 열고 Parameter File 텍스트에 붙여 넣습니다.

  • Schedule to run later- Windows 예약된 작업을 설정합니다.

  • Just build the parameter file - Toad가 매개 변수 파일만 구성한 다음 마법사를 닫습니다.


표 공간 내보내기

첫 번째 마법사 창에서 Tablespaces export를 선택하면 표 공간 선택 창이 나타납니다.

표 공간을 내보내려면

  1. 표 공간 이름의 왼쪽에 있는 상자를 표시하여 표 공간을 선택합니다. 트리거, 부여 또는 제약 조건을 포함하려면 해당 확인란이 선택되어 있는지 확인합니다. (기본값은 모두 포함하는 것입니다.)

  2. 표 공간을 내보내기 위해 사용할 SYSDBA 계정의 Username을 입력합니다.

  3. SYSDBA 계정의 Password를 입력합니다. 보안 상의 이유로 별표로 나타납니다.

  4. Next를 누릅니다.

  5. 해당 상자에서 출력 파일 및 로그 파일 이름을 입력합니다. 기본값으로, 로그 파일 이름은 출력 파일에 지정한 이름과 동일하며 .log 확장자가 있습니다.

  6. 해당 상자에서 매개 변수 파일 이름을 입력합니다. 기본값으로, 매개 변수 파일 이름은 출력 파일에 지정한 이름과 동일하며 .dat 확장자가 있습니다.

  7. 동작의 라디오 단추 목록에서 내보내기 동작을 선택합니다. 선택할 수 있는 내용은 다음과 같습니다.

  • Execute Now - 매개 변수 파일을 저장하고 내보내기 유틸리티를 시작합니다.

    • Compress export file (.zip)을 선택하여 내보낸 파일을 자동으로 압축합니다.

    • Watch Progress (Feedback=1000)를 선택하여 로그 파일(Log 탭) 및 매개 변수 파일(Parameter 탭)뿐만 아니라 한 줄씩 실행(Output 탭)을 표시합니다. Parameter File 페이지의 Editor 단추는 Editor를 열고 Parameter File 텍스트에 붙여 넣습니다.

  • Schedule to run later - Windows 예약된 작업을 설정합니다.

  • Just build the parameter file - Toad가 매개 변수 파일만 구성한 다음 마법사를 닫습니다.


사용자 내보내기

첫 번째 마법사에서 Users export 라디오 단추를 선택하면 다음 창은 users selection 창이 됩니다.

사용자를 내보내려면

  1. 왼쪽 패널에서 내보낼 사용자를 선택합니다(Selected Users 목록으로 이동).

  2. 사용자 이름 을 두 번 눌러 단일 사용자로 이동합니다.

  3. 사용자 를 선택한 다음 해당 단일 화살표를 누릅니다. 마우스를 누를 때 CTRL 키를 누른 상태에서 여러 사용자를 선택할 수 있습니다.

  4. 이중 화살표를 눌러 패널 간에 전체 목록을 이동합니다.

  2. 내보낼 개체 를 선택합니다. 개체에는 표 행, 제약 조건, 부여, 색인 및 트리거가 포함됩니다.

주: 트리거는 Oracle 8.1 이상이 있을 경우에만 사용할 수 있습니다.

  3. 내보내기 파일에 포함할 추가 매개 변수를 지정합니다.

  4. Next 를 누릅니다.

  5. 해당 상자에서 출력 파일 및 로그 파일 이름을 입력합니다. 기본값으로, 로그 파일 이름은 출력 파일에 지정한 이름과 동일하며 .log 확장자가 있습니다.

  6. 해당 상자에서 매개 변수 파일 이름을 입력합니다. 기본값으로, 매개 변수 파일 이름은 출력 파일에 지정한 이름과 동일하며 .dat 확장자가 있습니다.

  7. 동작의 라디오 단추 목록에서 내보내기 동작을 선택합니다. 선택할 수 있는 내용은 다음과 같습니다.

  • Execute Now - 매개 변수 파일을 저장하고 내보내기 유틸리티를 시작합니다.

    • Compress export file (.zip)을 선택하여 내보낸 파일을 자동으로 압축합니다.

    • Watch Progress (Feedback=1000)를 선택하여 로그 파일(Log 탭) 및 매개 변수 파일(Parameter 탭)뿐만 아니라 한 줄씩 실행(Output 탭)을 표시합니다. Parameter File 페이지의 Editor 단추는 Editor를 열고 Parameter File 텍스트에 붙여 넣습니다.

  • Schedule to run later- Windows 예약된 작업을 설정합니다.

  • Just build the parameter file - Toad가 매개 변수 파일만 구성한 다음 마법사를 닫습니다.


Export Utility 마법사 문제 해결

Export Utility 마법사는 일반적으로 이름이 Exp.exe, Exp73.exe 또는 Exp80.exe이고 Oracle 홈의 bin 폴더에 있는 Oracle 유틸리티의 인터페이스입니다.

Toad에서 이 실행 파일을 찾을 수 없는 경우에는 "The Oracle Export Utility executable must be specified" 오류가 나타납니다.

Oracle Export Utility의 위치를 지정하려면

  1. View|ToadOptions|Executables를 선택합니다.

  2. Export 상자에 경로를 입력합니다.

주: 이 실행 파일이 있는 위치를 모르거나 파일이 컴퓨터에 없는 경우에는 Oracle CD에서 Database Utilities를 설치해야 할 수도 있습니다.


Data Subset 마법사

이 창에서 보다 작은 데이터 집합을 작업할 수 있도록 참조 무결성을 유지하는 동안 데이터의 일부분을 다른 스키마로 복사할 수 있습니다.

마법사는 상위 표에서 시작하는 데이터 또는 제약 조건이 없는 모든 표의 데이터의 특정 비율을 복사하는 스크립트를 작성합니다. 행의 최소 개수를 지정할 수 있습니다. 그런 다음 마법사는 외부 키 제약 조건이 있는 표를 계속 작업하며, 복사된 행은 상위 표로 복사된 상위 행입니다.

INSERT SELECT 구문이 있는 대상 표에 데이터가 삽입됩니다. 이로 인해 LONG 데이터 형식의 열이 포함된 표는 삽입되지 않습니다.

주: Oracle 7.3의 경우 Oracle 버그로 인해 INSERT SELECT 구문이 행에 삽입되지 않는 경우도 있습니다.

스크립트는 대상 스키마가 다른 데이터베이스에 있을 경우 대상 데이터베이스에서 실행되도록 설계되었습니다. 데이터베이스 링크는 원본 스키마에 존재해야 하며 이 링크를 통해 원본 데이터에 대한 SELECT 권한이 있어야 합니다.

Data Subset 마법사를 액세스하려면

  • 기본 메뉴의 Tools|Data Subset Wizard에서 Data Subset 마법사를 액세스합니다.

마법사는 다음과 같이 옵션을 설정하도록 허용하는 4개의 화면으로 구성되어 있습니다.

  • 화면 1: 원본 및 대상 연결/스키마를 선택하고 스크립트를 저장할 위치를 지정합니다.

  • 화면 2: 스크립트에서 작성할 개체를 선택합니다.

  • 화면 3: 삽입 구문 주변의 명령을 설정합니다.

  • 화면 4: 마법사가 개체를 작성하도록 설정되어 있을 경우 모든 범위 또는 표 공간을 설정합니다.


데이터 하위 집합: 화면 1

Data Subset 마법사의 첫 번째 화면에서 원본 및 대상 데이터베이스를 정의할 수 있습니다.

원본 및 대상 데이터베이스를 정의하려면

  1. Source 연결/스키마를 선택합니다.

  2. Target 연결/스키마를 선택합니다. 원본 스키마와 동일할 수는 없지만 원본 스키마에 대한 SELECT 권한을 가지고 있어야 합니다.

대상 스키마 이름이 개체 DDL 및 데이터 삽입에 포함됩니다. Include a Connect Command 옵션이 세 번째 화면에서 표시되어 있으면 대상 연결이 스크립트 시작 부분에 연결 문자열을 추가합니다.

  3. Output 위치를 지정합니다. 이 위치는 Toad가 스크립트를 저장해야 할 위치입니다.

옵션을 표시/선택 취소하여 완료 시 DDL을 보거나 DDL을 Editor에 로드할 수 있습니다.

주: 원본 및 대상 데이터베이스가 다를 경우 원본 스키마를 가리키는 대상 스키마에 DB 링크가 있어야 합니다.


데이터 하위 집합: 화면 2

두 번째 화면은 Select Objects to Create in the Script 및 How much data do you want to copy?의 두 개의 패널로 구성되어 있습니다.

Select Objects to Create in the Script.

라디오 단추에 두 개의 옵션이 제공됩니다.

Do Not Create any objects, just truncate tables and copy data

이 옵션을 선택할 경우 마법사는 개체가 이미 대상 스키마에 존재한다고 가정합니다. 이 옵션을 사용하여 데이터를 새로 고칩니다.

Create these objects and copy the data

주: Data Subset 옵션은 선택 사항인 Quest DBA Module과 함께 Toad의 상용 버전에서만 사용할 수 있습니다. 포함된 삽입 구문으로 스키마 스크립트를 작성하기 때문에 DBA 모듈이 필요합니다. 스키마 스크립트를 생성할 수 있는 대체 방법은 스키마 스크립트 생성을 참조하십시오.

이 옵션은 개체가 대상 스키마에 없고, 스크립트가 선택한 개체를 작성하고 데이터를 삽입하는 것으로 가정합니다.

주: Create Objects 모드에서 클러스터는 제외됩니다. 클러스터가 포함된 스키마의 데이터 집합을 만들려면 우선 개체를 작성한 다음 Do not create any objects, Just truncate tables and copy data 옵션이 선택되어 있는 마법사를 실행해야 합니다.

뿐만 아니라, 클러스터에 속하는 표 또는 색인이 모두 추출되지 않습니다.

How much data do you want to copy?

이 하단 패널에서 Percentage of data가 원본 스키마에서 대상 스키마로 삽입되도록 지정할 수 있습니다.

다음을 통해 이 작업을 지정할 수 있습니다.

  • 슬라이드 막대를 사용하여 백분율 설정

  • 백분율 필드에 백분율 입력

  • 회전자를 사용하여 마우스로 백분율을 올리거나 낮춤.

알고리즘은 특정 백분율 기반의 데이터에 대한 삽입 구문을 작성하는 데 사용합니다.

Minimum number of rows in lookup tables 상자/회전자에서 선택한 백분율이 원하는 최소값보다 낮은 숫자를 나타낼 경우 대상으로 이동할 최소 행 개수를 결정할 수 있습니다.

행의 백분율 또는 최소 개수는 외부 키 관계가 없는 상위 표에서 정확합니다(예외: 긴 열 및 개요에 설명된 Oracle 7.3 버그가 있을 경우). 데이터 무결성은 상위 표에 삽입된 행 기반의 외부 키와 관련된 하위 표에 그대로 보존됩니다. 따라서 하위 표에 복사된 행의 백분율은 각각의 표의 데이터 배포에 따라 달라집니다.


데이터 하위 집합: 화면 3

Data Subset 마법사의 세 번째 화면에서 Control 옵션 및 Script 옵션을 설정할 수 있습니다.

Control 옵션

제어 옵션은 삽입 구문 주변의 명령을 설정합니다.

No Logging

표시되어 있으면 각 개체에 데이터를 삽입하기 전에 이 옵션이 ALTER TABLE 구문을 추가하여 No Logging을 지정합니다.

표시되어 있으면 마법사가 더 빠르게 실행되지만 스크립트 동작(삽입 구문)은 복구할 수 없습니다.

Use Parallel DML

표시되어 있으면 이 옵션이 삽입 구문에 Optimizer 힌트를 추가합니다. 또한 각 개체에 데이터를 삽입하기 전에 ALTER SESSION 구문을 추가하여 Parallel DML을 활성화합니다.

표시되어 있으면 마법사에서 만든 스크립트가 더 빠르게 실행되지만 종료 범위는 조금만 늘어납니다.

Use Rollback Segments

표시되어 있으면 각 개체에 데이터를 삽입하기 전에 SET TRANSACTION 구문을 추가하여 지정된 롤백 세그먼트를 사용합니다. 이 상자를 표시할 경우 사용할 롤백 세그먼트를 드롭다운에서 선택할 수 있습니다.

Script 옵션

Include a Spool command

표시되어 있으면 스크립트에 SPOOL 명령이 포함됩니다. SPOOL 명령 뒤에 SET ECHO ON 명령이 발급됩니다. 스크립트 마지막에 SPOOL OFF 명령이 포함됩니다.

Include a Connect command

표시되어 있으면 스크립트 시작 부분에 CONNECT 명령을 추가하고 첫 번째 마법사 화면에서 지정한 대상 연결 기반의 연결 문자열을 사용합니다.

Make individual Constraint commands

Create Objects 페이지에서 제약 조건을 작성하기로 선택한 경우에만 이 옵션이 나타납니다. 표시되어 있으면 제약 조건이 개별 ALTER TABLE 명령으로 작성됩니다. 제약 조건이 별도로 작성되지 않을 경우 다음과 같은 오류를 일으킬 수 있는 Oracle 버그를 포위할 때 도움이 됩니다. "ORA-01948 식별자 이름 길이가 최대값을 초과했습니다."


데이터 하위 집합: 화면 4

이 화면에서 모든 조정 내용을 선택하여 스크립트에 범위 및 표 공간을 작성합니다. 이 화면의 모든 옵션은 선택 사항입니다.

Extents/Tablespaces

Extents/Tablespaces 탭의 옵션은 마법사가 개체를 작성하기로 설정되어 있을 때 활성화됩니다(마법사의 두 번째 화면에서 Create these objects and copy the data 옵션을 선택할 때).

Extents 탭

Extents 탭에서 생성된 스크립트에 의해 작성된 개체의 범위를 지정할 수 있습니다. PCTINCREASE 매개 변수를 지정하고, 다음 범위와 초기 범위를 동일하게 만든 다음 범위 크기를 조절하여 저장 매개 변수를 허용하도록 작성된 모든 개체에 적용합니다. 화면의 하단에서 IF-THEN 구문을 사용하여 범위 크기를 변경할 수 있습니다.

Tablespaces 탭

Tablespaces 탭에서 표 공간을 지정하여 색인, 표 및 파티션을 작성할 수 있습니다. 표 공간에 모든 개체 형식(표, 표 정의, 색인, 색인 파티션)을 배치하거나 크기에 따라 다른 표 공간에 걸쳐 배포할 수 있습니다.

Build Script

Build Script 단추를 누르면 스크립트가 작성됩니다.

  • 완료 시 View DLL을 선택했으면 스크립트를 클립보드에 복사하거나 파일로 저장합니다.

  • 완료 시 Load in Editor를 선택했으면 새 Editor 창이 열리고 스크립트가 로드됩니다.

주: Oracle 7.3의 경우 Oracle 버그로 인해 INSERT SELECT 구문이 행에 삽입되지 않는 경우도 있습니다.


데이터베이스 스크립트 생성

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Generate Database Script 창을 사용하면 스크립트를 만들어 원본과 비슷한 새 데이터베이스를 쉽게 만들 수 있습니다. 원본 데이터베이스나 이전에 저장한 데이터베이스 정의 파일에서 정의 정보를 추출하여 스크립트를 만들 수 있습니다.

주: 이 스크립트는 단순히 데이터베이스의 개별 개체에 대한 DDL을 리버스 엔지니어링합니다. 따라서 이 DDL의 일부를 고유한 데이터베이스 스크립트에 추가할 수 있습니다. 이 창은 선택한 데이터베이스를 재현하기 위해 전체 스크립트를 만들지는 않으므로 백업 목적에 사용해서는 안 됩니다.

데이터베이스 스크립트를 생성하려면

  1. Database 메뉴에서 Export|Generate Database Script를 선택합니다.

  2. 데이터베이스 스크립트를 생성하는 데 사용할 옵션과 설정을 선택합니다. 이에 대해서는 아래에 설명되어 있습니다.

  3. Execute를 눌러 스크립트를 만듭니다.

Source and Output

Source and Output 탭에서는 Toad에서 스크립트를 작성하기 위해 정보를 가져오는 위치와 완성된 스크립트를 사용하여 수행하는 작업을 정의합니다.

Source:

  • 데이터베이스에서 추출한 다음 드롭다운을 사용하여 열린 연결에서 데이터베이스를 선택하도록 할 수 있습니다.

  • 데이터베이스 정의 파일에서 추출한 다음 이 옵션을 선택했을 때 표시되는 Open 창에서 파일을 선택하도록 할 수 있습니다.

Output

  • View DDL when complete - 기본적으로 선택되어 있습니다.

  • View Object Tree when complete - 기본적으로 선택되어 있지 않습니다.

  • Enter the filename you want to use for the DDL.

  • Enter the Definition filename, if you want to create a database definition file. 이 옵션을 사용하면 나중에 스크립트로 추출하거나 Compare Databases 창에서 사용하기 위해 정보를 저장할 수 있습니다.

  • Create Individual Object DDL Files - 기본적으로 선택되어 있지 않습니다. 이 옵션을 선택한 경우 새 파일의 최상위 수준 디렉토리를 입력해야 합니다. 이는 파일 이름이 아닙니다. Toad에서는 데이터베이스의 각 개체에 대한 개별 DDL 파일을 만듭니다.

Objects and Options

이 탭을 사용하여 만들 개체와 특수 옵션을 정의할 수 있습니다.

포함된 개체

  • Specify Object set

  • Directories

  • Database triggers

  • Initialization Parameters

  • Profiles

  • Redo Logs

  • Resource Consumer Groups

  • Resource Plans

  • Roles

  • Rollback Segs (Public)

  • Rollback Segs (Private)

  • Scheduler Job Classes

  • Scheduler Windows

  • Scheduler Window Groups

  • Tablespaces

  • Users

주: "Initialization Parameters" 아래의 Inc Undoc Parms는 "Include Undocumented Initialization Parameters"를 나타냅니다. 이러한 매개 변수는 이름이 "_"로 시작하고 Oralce 설명서에 표시되지 않는 매개 변수입니다. 이러한 매개 변수를 검색하려면 SYS로 연결되어 있어야 합니다. Oracle 지원부의 지시가 없는 경우 이러한 매개 변수를 변경하지 않는 것이 좋습니다.

포함된 옵션

  • Sort for Creation

주: 이 탭의 Sort for creation은 종속성 문제를 방지하기 위해 개체가 순서대로 만들어지게 합니다.

  • Use a ‘/’ to end SQL statements

  • Include Comments in script

  • List Dependencies


Generate Schema Script

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

이 창에서는 하나 이상의 스키마를 선택하고 선택한 모든 개체에 대한 DDL을 작성할 수 있습니다.

스키마 스크립트를 생성하려면

  • Database 메뉴에서 Export|Generate Schema Script를 선택합니다.

  • 다음 탭에서 적절한 옵션을 선택합니다.

  • Source and Output

  • Object Types

  • Filters

  • Script Options

  3. Create Script를 누릅니다.

  4. Copy to Clipboard 또는 Save to File을 누릅니다.

이렇게 하면 모든 개체를 다시 만들 수 있는 스크립트를 갖게 되므로 데이터베이스에서 충돌이 발생한 경우 등에 도움이 됩니다.

관련 항목

Generate Schema Script

Source and Output

Object Types

Objects

Filters

Script Options


Source and Output

Source and Output 탭을 눌러 스키마 스크립트에 대한 소스 및 출력 옵션을 선택할 수 있습니다.

Extract from Schema

스키마 스크립트를 생성하는 데 사용할 스키마를 선택합니다.

Extract from Schema Definition File

.def 파일을 생성하기 위한 스키마 정의 파일을 선택합니다.

View DDL when complete

만들어진 후에 DDL(Data Description Language)을 보려면 이 옵션을 선택합니다.

View Object Tree when complete

이 옵션을 선택하면 완료 시에 스크립트의 개체 트리를 볼 수 있도록 새 탭이 열립니다.

DDL Filename 상자

DDL Filename의 이름을 입력하거나 드릴다운 [image] 단추를 사용하여 선택합니다.

Make one file named after each schema, in this directory

이 옵션을 사용하려면 DDL Filename 상자에서 디렉토리를 지정하고 이 상자를 선택합니다. Toad에서는 각 스키마에 대한 별개의 파일을 만들어 지정한 디렉토리에 저장합니다.

Definition Filename 상자

Definition Filename의 이름을 입력하거나 드릴다운 [image] 단추를 사용하여 선택합니다.

Def file will be used for HTML schemadoc generation

주: Def 파일은 다른 버전의 Toad 간에 호환되지 않습니다.

이 확인란을 선택한 경우 생성되는 .def 파일은 완전한 HTML 스키마 문서를 만드는 데 필요한 질의를 포함합니다.

이 확인란을 선택 취소할 경우 큰 데이터베이스에서 생성 속도가 빨라지고 .def 파일은 계속해서 HTML 스키마 문서를 생성하는 데 사용될 수 있습니다. 그러나 결과 HTML 파일에서는 다음 항목이 비어 있습니다.

  • Table summary, Index summary 및 Snapshot summary에 있는 Size 및 Number of Extents 열

  • Package Summary에 있는 # of Objects

  • Procedure Summary 및 Function Summary에 있는 # of Arguments

Create Individual Object DDL Files

이 옵션을 선택한 경우 Toad에서는 각 개체에 대한 개별 DDL 파일을 만듭니다. 다음 옵션도 설정해야 합니다.

  • Use SQL extension for all files - 선택할 경우 .spl이 모든 작성된 파일의 확장명으로 사용됩니다.

  • Use extension as configured in TOAD options - 선택할 경우 Toad에서는 Toad Options|Files|General을 검사하고 SQL에 지정된 확장명을 사용합니다.

  • Use relative path in "build all" script - 선택할 경우 상대 경로가 사용됩니다. 이 옵션을 선택하지 않을 경우 경로 이름이 스크립트에 하드코드됩니다.

  • Top Level Directory 상자 - 저장된 파일의 최상위 디렉토리를 지정합니다.

관련 항목

Generate Schema Script

Object Types

Objects

Filters

Script Options


GSS_Object Types

Object Types

Object Types 탭을 사용하여 스키마 스크립트에 포함할 개체 형식을 선택할 수 있습니다.

사용자와 직접적으로 관련된 형식(예: 사용자, 사용자의 역할, 사용자의 개체가 포함된 모든 테이블 공간)이 이 창의 위쪽 부분에 포함됩니다.

고유한 개체 집합을 지정하기 위한 옵션(Objects 탭을 추가하는) 및 휴지통에서 개체를 제외하기 위한 옵션을 포함하여 사용할 수 있는 다른 모든 데이터 형식은 아래쪽 영역에 포함됩니다.

관련 항목

Generate Schema Script

Source and Output

Object Types

Objects

Filters

Script Options


GSS_Objects

GSS 개체

Object Types|Specify Object Set을 선택하면 Objects 탭이 표시됩니다.

개체 집합을 만들려면

  1. Add objects to grid [image] 단추를 누릅니다.

  2. 드롭다운에서 개체 형식을 선택합니다.

  3. 다음 옵션 중에서 선택합니다.

  • 개체를 필터링하려면 Like 확인란을 선택하고 아래 상자에 필터를 입력합니다.

  • 선택한 행을 자동으로 검사하려면 Auto-Check Loaded Rows 확인란을 선택합니다.

  • 선택되는 행을 로드하기 전에 질의를 보거나 편집하려면 실행 전에 Vview/Edit Query를 선택합니다.

  4. Load Rows를 누릅니다.

  5. 원할 경우 추가 개체 형식을 추가합니다.

  6. Close를 누릅니다.

  7. 맨 왼쪽 열을 눌러 개체 집합에 포함할 개체를 선택합니다.

개체 집합을 저장하려면

  1. 개체 집합을 만듭니다.

  2. Save to Text file [image] 단추를 누릅니다.

  3. 파일의 이름을 지정하고 OK를 누릅니다.

텍스트 파일에서 개체 집합을 로드하려면

  4. Load Object Set from Text File 단추를 누릅니다.

또는

Load Object Set from Text File 단추의 최근에 사용한 파일 드롭다운에서 파일을 선택합니다.

  2. 맨 왼쪽 열을 눌러 개체 집합에 포함할 개체를 선택합니다.

관련 항목

Generate Schema Script

Source and Output

Object Types

Objects

Filters

Script Options


GSS_Filters

스키마 스크립트 필터 생성

세 가지 방법으로 스키마 스크립트를 만드는 데 사용할 개체 형식을 필터링할 수 있습니다.

모든 개체

모든 개체에 대한 개체 이름을 필터링하려면 Only Extract Object Names like... 필터를 사용합니다.

테이블

하나의 테이블 공간에서만 테이블을 선택하려면 테이블 공간 드롭다운 상자를 사용합니다. 또한 테이블 공간이 Null로 설정된 모든 테이블을 포함할 수도 있습니다.

인덱스

하나의 테이블 공간에서만 인덱스를 선택하려면 테이블 공간 드롭다운 상자를 사용합니다. 또한 테이블 공간이 Null로 설정된 모든 인덱스를 포함할 수도 있습니다.

관련 항목

Generate Schema Script

Source and Output

Object Types

Objects

Filters

Script Options


GSS Script Options

Script Options

다음 옵션 중에서 선택하여 스키마 스크립트를 사용자 정의합니다.

Sort for Creation

이 옵션을 선택하면 종속성 문제를 방지하기 위해 개체가 순서대로 만들어집니다.

Include "Set Define Off"

이 옵션은 스크립트의 시작 부분에 "set define off" 명령을 추가합니다. 이는 소스 코드에 '&' 문자가 포함된 경우 대체 변수를 묻는 메시지가 표시되지 않는다는 것을 의미합니다.

Include Drop Statements

이 옵션을 선택하면 각 개체를 만들기 직전에 삭제하는 명령이 추가되므로 "object already exists" 오류가 방지됩니다.

Drop Tables with Purge option

이 옵션을 선택하면 테이블이 휴지통에 버려지지 않으므로(Oracle 10g의 경우) 복구할 수 없습니다.

Include "Show Errors" after procs and triggers

스크립트에 SQL*Plus "Prompt" 주석을 포함합니다.

Always use '/' to end SQL statements

선택할 경우 모든 SQL 문이 '/'으로 끝납니다.

One line per statement

선택할 경우 SQL 문에서 모든 줄 바꿈이 제거되어 전체 내용이 한 줄에 표시됩니다.

Comments in Script

선택할 경우 생성된 스키마 스크립트에 주석이 포함됩니다.

List Dependencies

이 옵션은 스키마 스크립트에 포함된 주석에 종속성을 나열합니다.

Include Counts

이 옵션은 생성된 스크립트의 주석에 모든 개수를 포함합니다.

Include Schema Name Prefix for Objects

모든 개체에 대한 스키마 이름 접두사를 포함하려면 이 옵션을 선택합니다.

Substitute this for the Schema Name box

이 옵션은 Include Schema Name Prefix for Objects 옵션을 선택한 경우에만 사용할 수 있습니다. 이 옵션을 선택하고 생성된 스크립트에서 스키마 이름 접두사를 대체할 문자열을 입력합니다.

관련 항목

Generate Schema Script

Source and Output

Object Types

Objects

Filters

Script Options


창: Source Import

Source Import

이 기능을 사용하여 프로시저, 함수, 패키지, 트리거 및 데이터베이스의 파일 보기를 가져옵니다.

Database|Import|Source Files 메뉴 항목에서 이 대화상자를 열 수 있습니다.

가져올 파일을 선택하려면

  • Add 단추를 누르고 목록으로 가져올 여러 개의 파일을 선택한 다음 Open 을 누릅니다. 전체 경로 및 파일 이름이 나열됩니다.

각 파일 내의 내용을 보려면(파일당 하나의 개체만 있어야 함) Parse Files 단추를 누릅니다. 각 파일이 분석되고 개체 형식, 개체 이름 및 상태가 표시됩니다.

눈금 머리글을 눌러 목록을 오름차순 또는 내림차순으로 정렬합니다..

Remove 단추를 누르면 현재 목록의 파일만 삭제됩니다. 하드 드라이브의 파일을 삭제하지 않습니다.

파일 중 하나를 편집하려면 파일을 선택한 다음 Load in Editor 단추를 누릅니다. Procedure Edit/Compile 창이 작성되고 편집할 수 있도록 파일의 내용을 읽습니다.

Execute 단추를 눌러 파일 목록을 가져옵니다. Status 열에 가져오기 결과가 표시되며, 아래 상자의 오류 텍스트를 보면서 오류를 스크롤할 수 있습니다.

Source Code Export 창에서 원본 코드 파일을 작성합니다.


표 데이터 가져오기

표 데이터를 가져올 수 있습니다. 표 작성 기능을 사용하여 가져오기에 대한 표를 새로 작성할 수 있더라도 기존 표에 데이터를 가져와야 합니다.

주: 로드할 데이터 집합의 크기는 메모리에 충분히 맞도록 작아야 합니다. 데이터 집합이 클 경우 텍스트 파일이 아니면 데이터를 텍스트 파일로 변환하고 SQL Loader 마법사를 사용합니다.

표 데이터를 가져오려면

  1. Database 메뉴에서 Import, Table Data를 차례로 선택합니다. Data Importer 창이 나타납니다.

  2. 데이터를 가져올 위치에서 Schema 및 Table을 선택합니다.

  3. 다음 중 선택하십시오.

  • 모든 레코드 후 한 번 실행

  • 각 레코드 후 실행

  • 실행 안 함

  4. 데이터에 적용할 다음과 같은 동작을 선택하십시오.

  5. 데이터베이스 개체의 변경 내용 적용 - 새 데이터가 있는 표에서 INSERT를 수행합니다.

  6. SQL 구문을 파일로 저장 - 마법사의 마지막 단계에서 지정할 파일로 INSERT 구문을 저장합니다.

  7. Show data를 눌러 표에 포함된 데이터를 표시합니다. 표에 데이터가 없을 경우 열 머리글만 눈금에 나타납니다.

주: 데이터가 많이 있다는 것을 알고 있을 경우 단방향 눈금 옵션을 선택할 수 있습니다. 이렇게 하면 필요한 메모리의 양은 보다 적어지지만 눈금에서 백업할 수는 없고 아래로 스크롤만 할 수 있습니다.

  5. 이 지점에서 다음 중 선택하거나 6단계로 이동하십시오.

Truncate the table

Enable/Disable Constraints

Enable/Disable Triggers

  6. 실행 마법사를 눌러 데이터 로드를 시작합니다. Import 마법사가 나타납니다.


Import 마법사

Import 마법사를 통해 여러 가지의 다른 형식의 데이터를 Oracle 표로 가져올 수 있습니다. 마법사에서 어떤 오류도 발견되지 않습니다. 데이터는 다음과 같이 로드됩니다.

  • 열이 잘못 매핑되어 있으면 아무 것도 로드되지 않습니다.

  • 데이터에 잘못된 몇 개의 행을 제외하고 모두 올바를 경우 올바른 행이 로드됩니다.

  • 데이터가 불량인 경우 행은 로드될 수 있지만 열은 모두 로드될 수 없습니다. 예를 들어, 날짜 상자인 경우 형식이 일치하지 않으면 날짜를 변환할 수 없다는 경고 메시지가 나타납니다.

오류로 인해 표에 이상한 결과가 나타날 수 있습니다. 예를 들면 다음과 같습니다.

  • Number 열이 있는 표에 "Name" 등의 문자 기반의 열을 가져오면 데이터가 로드되지 않습니다.

  • 10 크기의 VarChar 열이 있는 표에 "supercalifragilistic"이라고 하는 데이터를 가져오면 데이터가 처음 10개의 문자 또는 "supercalif"로 잘립니다.

마법사의 마지막 단계에서 올바르게 로드한 행 및 발생한 오류 수를 나타내는 오류 메시지가 나타납니다. 오류가 발생하면 표의 데이터를 확인하고 원래의 원본 파일과 비교해야 합니다.

설정 로드 및 저장

마법사를 실행하는 동안 언제든지 설정을 파일로 저장하거나 설정이 들어 있는 파일을 로드할 수 있습니다. 이렇게 하면 모든 설정을 직접 입력하지 않아도 되기 때문에 여러 유사 파일의 데이터를 훨씬 쉽게 가져올 수 있습니다.


Import 마법사 - 파일 형식

원본 데이터의 형식을 선택합니다.

파일 형식을 선택하려면

  1. 다음 원본 중 하나에서 데이터를 가져오기로 선택합니다.

  2. 텍스트 파일

  3. Excel 파일

  4. MS Access 데이터베이스

  2. Next를 누릅니다.


Import 마법사 - 파일 이름

파일 이름 및 원본 데이터의 출처를 선택합니다.

파일 이름 및 출처를 선택하려면

  1. File name 상자에서 전체 경로를 입력합니다.

또는

드릴다운 [image] 단추를 선택하고 파일을 찾아 봅니다.

  2. 파일 출처가 ANSI(Windows) 또는 ASCII(DOS) 형식인지 선택합니다.

  3. Next를 누릅니다.


Import 마법사 - 텍스트 설정

이 단계는 .txt 파일을 가져올 때만 사용할 수 있습니다. 원본 데이터의 텍스트 설정을 선택합니다.

텍스트 설정을 선택하려면

  1. 다음과 같은 필드 구분 방식을 선택합니다.

  2. 구분 기호

  3. 고정 너비

  2. 구분 필드를 선택한 경우 현재 파일이 사용하는 필드 구분 기호를 선택합니다.

  3. 다음과 같은 레코드 분리 기호를 선택합니다.

  4. CRLF 캐리지 리턴 또는 줄 바꿈

  5. CR 캐리지 리턴에만 해당

  6. LF 줄 바꿈에만 해당

  4. 텍스트 한정 기호를 선택합니다. 이것은 동일한 필드에 위치하도록 지정하기 위해 텍스트 주위에 배치한 문자입니다. 큰따옴표, 작은따옴표 또는 없음 중 선택합니다.

  5. 공백을 지우려면 Trim Spaces 드롭다운에서 다음을 선택합니다.

  6. No

  7. Right

  8. Left

  9. Both

  6. Next를 누릅니다.


Import 마법사 - 날짜 형식

원본 데이터 정의를 위해 사용할 추가 옵션을 입력합니다. 이 선택은 필수 사항이 아닙니다.

추가 옵션을 입력하려면

  1. 데이터 시작 부분에서 가져오기를 실행하고 싶지 않으면 가져올 데이터의 첫 행을 입력합니다.

  2. 가져올 마지막 행을 입력합니다. 전체 파일을 가져올 경우 빈 칸으로 둡니다.

  3. 이러한 데이터 형식에 사용할 특수 포맷 문자를 설정합니다.

  4. Next를 누릅니다.


Import 마법사 - 파일 미리 보기

마법사의 이 단계만 적용되며 .txt의 가져오기 파일 형식을 선택하고 고정 너비의 필드를 지정할 때만 나타납니다.

이 단계를 사용하여 열의 고정 너비를 직접 설정할 수 있습니다.

데이터는 눈금 형식으로 표시되며 눈금자에는 여러 문자가 있습니다.

  • 가로 화살표는 열 나누기를 표시합니다.

  • 원하는 위치로 끌어 화살표를 움직입니다.

  • 마우스를 눌러 나누기 행을 새로 만듭니다.

  • 마우스를 두 번 눌러 나누기 행을 삭제합니다.

데이터 열을 표 열에 매핑합니다. 데이터는 눈금으로 표시되어 Oracle 표에 입력됩니다.

눈금 열 크기 조절

가져올 데이터를 보다 쉽게 볼 수 있도록 눈금 열의 크기를 조절할 수 있습니다.

  • Size Cols to Names를 눌러 머리글의 열 크기를 조절합니다.

  • Size Cols to Data를 눌러 데이터 열 크기를 조절합니다.

  • 머리글 사이를 누르고 원하는 크기로 끌어 열의 크기를 수동으로 조절합니다.

자동

자동으로 표의 열에 원본 데이터의 각 열을 매핑할 수 있습니다.

각 열을 자동으로 매핑하려면

  • AutoMap을 눌러 표의 열에 원본 파일의 열을 순서대로 매핑합니다.

원하는 방식대로 매핑되지 않으면 아래 설명대로 수동으로 매핑할 수 있습니다.

수동

수동으로 표의 열에 원본 데이터의 각 열을 매핑할 수 있습니다.

열을 수동으로 매핑하려면

  1. 열 머리글을 누릅니다. 대상 표의 열 이름 목록이 나타납니다. 이동할 데이터 열을 매핑할 위치의 열을 선택합니다. 대상 표의 머리글은 데이터 열 위에 나타납니다.

  2. 열이 모두 매핑될 때까지 이 방법을 계속 사용합니다.

  3. 원하는 위치에 열 나누기가 설정되면 Next를 누릅니다.


Import 마법사 - 매핑

원본 및 대상 필드 간의 대응을 매핑합니다.

대응을 설정하려면

  1. 필드 매핑을 설정합니다.

  2. 업데이트/삭제 동작을 수행하고자 할 경우 키 필드를 선택합니다. 키 필드는 데이터를 고유하게 정의하는 필드입니다. 선택한 필드는 업데이트 및 삭제 작업을 확인하기 위해 사용됩니다.

  3. 매핑 및 키 필드 설정을 완료하면 Next를 누릅니다.


Import 마법사 - 날짜 미리 보기

날짜를 미리 보고 정확한지 확인합니다. Toad에 대상 표의 열 이름이 나열되고 삽입될 위치에 데이터가 채워집니다. 정확하지 않을 경우 다시 이동하여 열 또는 필드 매핑을 확인합니다. 이 위치로 쉽게 다시 이동할 수 있도록 항상 설정을 저장할 수 있습니다.

데이터를 미리 보려면

  1. 데이터를 확인합니다.

  2. 모든 것이 원하는 대로 준비되면 Next를 누릅니다.


Import 마법사 - 가져오기 모드

표에 데이터를 포함시킬 방법을 선택합니다. 다음 작업을 선택할 수 있습니다.

  • Append - 기본 옵션입니다. 대상 표의 끝에 레코드를 쉽게 추가합니다.

  • Update - 대상 표의 모든 레코드를 원본 파일에서 일치하는 레코드로 업데이트합니다.

  • Append/Update - 기존의 레코드를 업데이트하고 새 레코드를 추가합니다.

  • Delete - 원본 파일의 레코드와 일치하는 대상 표의 레코드를 삭제합니다.

  • Copy - 대상 레코드를 모두 삭제한 다음 원본 파일의 표를 다시 채워 넣습니다.

주: 업데이트, 추가/업데이트/삭제는 키 필드가 지정되어 있을 경우에만 사용할 수 있습니다.

데이터 가져오기를 마치려면

  • Finish를 누릅니다. 그러면 데이터를 가져옵니다.


Import Utility Wizard

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Database|Import|Import Utility Wizard 메뉴 항목에서 이 창에 액세스할 수 있습니다.

이 창의 디자인은 Export Utility Wizard와 비슷합니다. 이 마법사를 사용하면 Oracle의 가져오기 유틸리티를 통해 Oracle 데이터베이스 간에 데이터 개체를 쉽게 전송할 수 있습니다. View|Toad Options|Executables에서 이 마법사를 구성할 수 있습니다.

또한 파일을 가져오기 전에 자동으로 압축을 풀 수 있습니다.

첫 번째 단계에서는 라디오 단추를 사용하여 내보낼 항목을 선택할 수 있습니다. 선택 항목은 다음과 같습니다.

  • Tables - 테이블 및 연관된 개체를 가져옵니다.

  • Users - 스키마를 가져옵니다.

  • Database - 전체 내보내기 파일을 가져옵니다.

  • Import Tablespaces – 전송 가능한 테이블 공간 메타데이터를 가져옵니다. 이 옵션을 선택할 경우 다음 단계에서는 SYSDBA 계정에 대한 사용자 이름과 암호를 묻는 메시지가 표시됩니다.

  • Use Parameter file – Export Utility Wizard에서 만든 매개 변수 파일과 같은 기존 매개 변수 파일로 가져오기를 수행합니다.

항목을 선택한 후 Next 를 누릅니다.

Tables

첫 번째 마법사 창에서 테이블을 선택한 경우 다음 창은 테이블 선택 창입니다. 개체를 소유한 사용자만 표시 할 수 있는 확인란이 있습니다. 드롭다운에서 Schema를 선택하고 왼쪽 패널의 스키마 표시에서 테이블을 선택합니다. 그런 다음 두 번 누르거나 한 번 누른 후 해당 단일 화살표를 눌러 가져올 테이블을 선택합니다. 이중 화살표는 전체 목록을 한 패널에서 다른 패널로 이동합니다.

다음 창에서 확인란을 사용하여 가져올 개체를 선택할 수 있습니다. 여러 확인란을 선택할 수 있습니다. 이러한 확인란은 Grants, Indexes, Table rows 및 Constraints(Oracle 8.1 이상에서 활성화됨)입니다.

파일 레코드 길이를 지정하거나 비워둘 수 있습니다(비워둘 경우 기본적으로 플랫폼의 BUFSIZ 값이 사용됨).

또한 이 창에서 추가 옵션을 선택할 수 있습니다. 옵션을 선택한 후 계속하려면 Next를 누릅니다.

다음 창에서는 파일 이름을 입력합니다. 드릴다운 단추를 사용하면 파일을 검색할 수 있습니다.

다음 창에서는 작업의 라디오 단추 목록에서 가져오기 작업을 선택할 수 있습니다. 선택 항목은 다음과 같습니다.

  • Import Now

  • Schedule to run later

  • Just build the parameter file

항목을 선택한 후 Finish 를 누릅니다.

Users

첫 번째 마법사 창에서 Users 가져오기 라디오 단추를 선택한 경우 다음 창은 사용자 선택 창입니다.

개체를 소유한 사용자만 표시 할 수 있는 확인란이 있습니다. From 및 To 드롭다운에서 가져오고 가져갈 사용자를 선택합니다. 이름을 누르고 Remove 단추를 눌러 선택 목록에서 사용자를 제거할 수 있습니다.

다음 창은 매개 변수를 선택하고 파일 이름을 지정하며 가져오기 작업을 선택하는 Database Option의 마지막 세 개 창과 동일합니다.

Database

첫 번째 마법사 창에서 Database 라디오 단추를 선택한 경우 다음 창에는 스키마를 선택하기 위한 라디오 단추가 있습니다. 증분 가져오기의 유형을 선택할 수도 있습니다. 증분 가져오기를 사용하지 않도록 선택할 수 있다는 것에 주의합니다.

이 옵션을 선택할 경우 다음 단계에서는 SYSDBA 계정에 대한 사용자 이름 및 암호와 대상 서버에 있는 데이터베이스 파일의 위치를 묻는 메시지가 표시됩니다.

다음 세 개의 창은 매개 변수를 선택하고 파일 이름을 지정하며 가져오기 작업을 선택하는 Tables Option의 마지막 세 개 창과 동일합니다.

마침

마법사의 마지막 화면에서 Watch Progress (Feedback = 1000)을 선택한 경우 Import Watch 창이 표시되고 가져오기 결과를 즉시 볼 수 있습니다. 또한 Watches 창의 Log 로그 탭에서 로그를 프린터에 직접 보낼 수 있습니다.


SQL*Loader 마법사 개요

Database|Import|SQL*Loader Wizard 메뉴 항목에서 이 창에 액세스할 수 있습니다.

주: SQL*Loader를 실행하는 데 문제가 있을 경우 올바른 버전이 설치되었는지 확인합니다. 명령 프롬프트 창에서 매개 변수 없이 실행 파일을 실행하여 이 작업을 수행할 수 있습니다. 서버에 있는 실행 파일은 서버에서만 실행할 수 있습니다.

Toad SQL*Loader 마법사를 사용하여 다음을 수행할 수 있습니다.

  • 데이터베이스 서버 응용 프로그램인 SQL*Loader과 함께 사용할 컨트롤 파일을 그래픽으로 작성합니다.

  • 나중에 실행하기 위해 SQL*Loader 실행을 Windows 작업으로 예약합니다.

  • 포그라운드 또는 백그라운드에서 실행되는 컨트롤 파일과 함께 SQL*Loader를 실행합니다.

View|Options| Executables에서 유틸리티의 위치를 구성할 수 있습니다.

SQL*Loader 마법사의 사용 방법을 익히는 최선의 방법은 실제로 사용해 보는 것입니다. SQL*Loader 마법사 자습서에서는 가장 일반적인 사용부터 고급 기능에 이르기까지 단계별 방법을 통해 실제 사용을 경험할 수 있습니다.

프로세스 도중에 언제든지 파일에서 설정을 로드하거나 현재 설정을 저장할 수 있습니다.

SQL*Loader 마법사를 열려면

  • Database 메뉴에서 Import|SQL*Loader Wizard를 선택합니다.

SQL*Loader 단계

  • What do you want to do?

새 컨트롤 파일을 생성하거나 기존 컨트롤 파일을 사용할 수 있습니다. 기존 컨트롤 파일을 사용할 경우 마법사는 Specify the control and log files로 바로 이동합니다.

  • Specify the input files

이 대화 상자에서는 입력 파일 정보를 추가, 편집 또는 삭제할 수 있습니다.

  • Delimited

데이터의 구분 기호를 설정합니다.

  • Select destination table and columns

이 대화 상자에서 대상 테이블과 열을 선택하고 각각에 대한 로드 매개 변수를 지정할 수 있습니다. 매개 변수를 설정하기 전에 대상 테이블을 추가해야 합니다. 또한 필드를 열에 매핑할 수 있습니다.

  • Specify global options and default values

이 대화 상자에서는 로드하는 모든 파일에 적용할 다양한 옵션을 지정할 수 있습니다. 옵션을 비워 두면 표준 SQL*Loader 기본값이 사용됩니다.

  • Specify the control and log files

이 대화 상자에 컨트롤 및 로그 파일의 이름을 입력합니다. 기본적으로 로그 파일은 컨트롤 파일과 동일하며 .log 확장명이 추가됩니다. 원할 경우 이름을 변경할 수 있습니다.

  • Schedule or execute your load

이 대화 상자에서는 전체 로그를 지금 실행할지, Windows NT 작업으로 예약할지, 단순히 컨트롤 파일을 작성할지 선택할 수 있습니다. 선택 항목을 실행하려면 Finish를 누릅니다.

주: Windows 2000에서 8.0.x 버전의 SQL*Loader와 함께 "Watch Progress"를 사용하면 CPU 사용량이 100%가 됩니다. SQL*Loader가 Toad 외부에서 시작하도록 SQL*Loader 마법사의 마지막 화면에서 "Watch Progress"의 선택을 취소하는 것이 좋습니다.


SQL*Loader 설정 저장

SQL*Loader 마법사를 사용하는 동안 언제든지 설정을 저장하거나 이전에 저장한 설정을 로드할 수 있습니다.

설정을 저장하려면

  1. 창의 아래에 있는 Save settings 단추를 눌러 설정을 저장합니다.

  2. 설정 파일의 이름을 묻는 메시지가 표시됩니다. 새 이름을 추가하거나 드롭다운 메뉴에서 이름을 선택할 수 있습니다. 드롭다운 메뉴에서 이름을 선택할 경우 새 파일이 이전 파일을 덮어씁니다.

SQL*Loader 마법사는 설정 파일을 추적합니다.

설정을 로드하려면

  1. SQL*Loader 마법사의 아래에 있는 Load settings 단추를 눌러 이전에 저장한 설정 집합을 로드합니다.

  2. 로드할 설정 파일을 선택합니다.

  3. 파일이 완전한 경우 Proceed to finish after loading를 선택한 상태로 두고 OK를 누릅니다. SQL*Loader 마법사의 마지막 화면으로 바로 이동됩니다.

  4. 파일이 완전하지 않은 경우 Proceed to finish after Loading을 선택 취소하고 OK를 누릅니다. SQL*Loader 마법사의 현재 화면에 있으면서 설정을 변경할 수 있습니다.

주: 설정을 로드할 경우 입력 파일과 대상 테이블 파일이 누적됩니다. 이전 설정을 덮어쓰는 대신에 새 정보가 마법사 설정에 추가됩니다.


SQL*Loader 작업 예약

SQL*Loader에는 로드를 Windows 작업으로 예약하는 기능을 제공하는 스케줄러가 포함되어 있습니다.

SQL*Loader 작업을 예약하려면

  1. SQL*Loader Wizard의 마지막 단계에서 Schedule을 선택하고 Finish를 누릅니다. Scheduler 마법사가 열립니다.

  2. SQL*Loader를 실행할 시간과 빈도를 선택합니다.

  3. OK를 누르면 작업이 추가되었다는 알림을 받게 됩니다.

작업이 추가되었는지 보려면

  1. Windows 탐색기를 엽니다. 왼쪽에서 하드 드라이브 및 CD ROM 문자 다음에는 제어판, 프린터 및 예약된 작업이 있습니다(시스템에 따라 다른 항목이 있을 수도 있음). 아래의 스크린 샷은 NT 4.0을 보여 줍니다. Windows 2000에서는 트리 보기에서 "제어판" 아래 "예약된 작업"이 표시됩니다.

  2. 예약된 작업을 누릅니다. 아래 이미지와 같이 오른쪽에는 새로 추가한 작업이 표시됩니다.

  6. 마우스 오른쪽 단추를 누른 다음 속성을 선택하고 실행 필드에서 해당 시점에 발생하는 작업을 확인합니다. 다음과 같은 형태의 항목이 포함되어 있어야 합니다.

D:\ORACLE\ORA81\BIN\SQLLDR.EXE userid=MLERCH/MLERCH@ORA8I control=d:\confile.ctl log=d:\confile.log


SQLLoader 전역 옵션

SQL*Loader 마법사의 전역 옵션 및 기본값 화면을 사용하면 명령줄 옵션과 몇 가지 기본값을 입력할 수 있습니다. Destination Table 또는 Columns 필드에 입력한 값은 이러한 값보다 우선합니다.

이러한 모든 옵션을 비워 둘 수 있습니다. 이렇게 하면 해당 옵션에 대한 기본값이 사용됩니다.

"명령줄" 옵션

Skip

입력 파일의 시작 부분에서 건너뛸 논리 레코드 수를 입력하거나 모든 레코드를 로드하도록 비워 둡니다.

Load

로드할 논리 레코드 수를 입력합니다. 이 수를 초과하는 모든 레코드는 입력되지 않습니다.

Errors

허용할 오류 수를 입력합니다. 기본값은 50입니다. 데이터를 로드할 때 이 오류 수보다 많은 오류가 있을 경우 SQL*Loader는 중지합니다.

Rows

기본 경로 바인드 배열의 행 수나 직접 경로 데이터 저장 사이의 행 수를 입력합니다.

Read size

읽기 버퍼에 사용할 크기(바이트)를 입력합니다.

Bind size

기본 경로 바인드 배열의 크기(바이트)를 입력합니다. 기본값은 시스템에 따라 다릅니다. 이 크기를 지정할 경우 기본 크기 및 ROWS에 의해 결정되는 모든 크기보다 우선합니다.

Resumable timeout

이 로드에 Resumable이 지정될 경우 대기 시간(초)을 입력합니다. 기본값은 7200입니다.

Resumable name

재시작 가능 문을 식별하는 데 도움이 되는 텍스트 문자열을 입력합니다.

Column array rows

직접 경로 열 배열에 대한 행 수를 입력합니다. 기본값은 5000입니다.

Silent

Watch 대화 상자의 Output 및 Log 탭에서 오류 메시지를 표시하지 않으려면 다음과 같이 Silent 옵션을 사용합니다.

Header

Output 탭에 표시되는 SQL*Loader 헤더 메시지를 숨깁니다. 로그 파일과 Log 탭에는 헤더 메시지가 계속 표시됩니다.

Discards

무시 파일에 기록된 각 레코드에 해당하는 로그 파일의 메시지를 숨깁니다.

Feedback

"commit point reached"와 관련된 메시지를 숨깁니다.

Partitions

로그 파일에 파티션별 통계를 기록하는 기능을 비활성화합니다. 이것은 Oracle 8i 옵션입니다.

Errors

로그 파일에서 데이터 오류 메시지를 숨깁니다. 잘못된 파일에 레코드를 기록하는 Oracle 오류가 레코드에서 생성될 경우 이러한 메시지가 발생합니다. 개별 오류 메시지가 표시되지 않더라도 거부된 레코드 개수는 계속 표시됩니다.

All

모든 키워드를 구현합니다.

Direct

이 로드를 직접 경로 로드로 할당하려면 이 상태를 선택합니다.

Parallel

이 로드를 병렬 직접 경로 로드로 할당하려면 이 상자를 선택합니다. 이것은 직접 경로 로드보다 제한적입니다.

Resumable

이 로드에 대해 다시 시작이 가능하게 하려면 이 상자를 선택합니다.

Multithreading

직접 경로에서 다중 스레딩을 사용하려면 이 상자를 선택합니다.

Skip index maintenance

인덱스를 유지 관리하지 않고 영향을 받은 인덱스를 다시 사용할 수 없게 표시하려면 이 상자를 선택합니다.

Skip unusable indexes

사용할 수 없는 인덱스나 인덱스 파티션을 허용하지 않으려면 이 상자를 선택합니다. 이 상자를 선택하지 않을 경우(기본값) 사용할 수 없는 인덱스가 허용됩니다.

Load Statement

Database redo Log

로드가 기록되는지 여부를 지정합니다.

Load Type

LOAD 또는 CONTINUE_LOAD를 선택합니다.

Load Method

로드 방법으로 INSERT, APPEND, REPLACE 또는 TRUNCATE를 선택합니다.

Length

길이 유형으로 CHAR, BYTE 또는 CHARACTER를 지정합니다.

Byte order

바이트 순서로 Little Endian 또는 Big Endian을 지정합니다.

Byte order mark

바이트 순서 표시로 Check 또는 Nocheck를 지정합니다.

Character set

기본값이 아닌 데이터 파일 문자 집합을 지정합니다(예: AL16UTF16 또는 JA16EUCFIXED).

Read buffers

직접 경로 로드 도중에 사용할 버퍼 수를 지정합니다.

Preserve blanks

필요한 경우 선행 및 후행 공백을 유지하려면 이 확인란을 선택합니다.

Combine Physical Records

물리 레코드를 결합하려면 이 옵션을 사용합니다. 다양한 상자에 입력하여 옵션 문을 만듭니다.

Concatenate every ____ records to form logical record

Continue if(확인란)

this record = ___ in cols ___

next record = ___ in cols ___

last non-blank character = _____


SQL Loader Field Mapping

대상 테이블을 지정할 때 필드를 자동으로 매핑할 수 있습니다.

여기에서는 테이블의 열에 데이터가 매핑되는 방법에 대한 그래픽 표시가 제공됩니다.

Field Delimiters

필드 매핑은 Field Delimiters 화면에서 설정한 구분 기호에 기초하여 수행됩니다.

필드 매핑을 설정하려면

  1. 마법사의 첫 번째 화면에서 Build Control File을 선택하고 Specify Fields가 선택되었는지 확인합니다. Next를 누릅니다.

  2. 사용할 구분 방법을 선택합니다.

  3. 창의 아래에서 표시할 데이터의 줄 수를 Number of lines displayed 상자에 지정합니다. 또한 이 수는 Preview Fields 탭에 표시되는 줄 수를 정의합니다.

By Field

Table Destination 화면에서 Field Mapping 그리드는 테이블의 열을 정의하고 필드에 대한 열을 포함합니다. 필드 열은 항목 없이 시작됩니다. Auto Map을 눌러 이 열을 채웁니다.

열이 채워지면 Field Mapping 그리드가 다음과 같이 나타납니다.

필드 열은 데이터를 정의하지 않고 "field1" 및 "field2"로 되어 있습니다.

Preview Fields

데이터를 미리 보고 선택한 열에 데이터가 포함되는 방법을 보려면 Preview fields 탭을 누릅니다. 표시되는 결과는 다음과 비슷합니다.

물론 더 많은 데이터나 열을 가질 수 있습니다. Preview fields 화면에 표시되는 데이터의 양은 위에 설명된 대로 Field Delimiters 화면에서 설정됩니다.


SQLLoaderFiller 열

Filler 열

열을 데이터 파일에 매핑할 경우 사용 가능한 일부 데이터를 로드에 포함하지 않아야 할 경우가 있습니다.

Filler 열을 사용하여 입력 파일의 일부 데이터를 건너뛸 수 있습니다. 또한 Filler 열을 사용하면 테이블의 실제 열에 매핑하지 않고(파일 이름을 "유지"하기 위해) 입력 파일에서 데이터를 읽을 수 있습니다.

Filler 열을 사용하여 데이터를 건너뛰려면

  1. Select the destination columns and specify the load parameters for each screen의 Columns 영역에서 Filler를 누릅니다.

  2. 적절한 필러 유형을 선택합니다.

  3. Filler

  4. Bound Filler

  3. 열 이름을 입력합니다.

  4. 속성이나 위치를 설정합니다.

  5. OK를 누릅니다.

Filler 열이 열 그리드에 추가되고 FILLER로 지정됩니다.

관련 항목

필드 매핑

SQL*Loader 마법사 개요

SQL*Loader 전역 옵션


입력 파일 만들기

이 자습서에서는 데이터가 삽입되는 테이블과 테이블에 삽입할 데이터가 포함된 파일을 만들어야 합니다.

  1. 샘플 테이블을 만들어 채웁니다. 다음 스크립트를 복사하여 Toad의 편집기에 붙여넣습니다.

create table MarksFavoriteFoods (Name varchar2(30), Rank number);

insert into MarksFavoriteFoods values ('Tuna', 1);

insert into MarksFavoriteFoods values ('Salmon', 2);

insert into MarksFavoriteFoods values ('Broccoli', 3);

insert into MarksFavoriteFoods values ('Asparagus', 4);

insert into MarksFavoriteFoods values ('Bell peppers', 5);

insert into MarksFavoriteFoods values ('Chicken', 6);

insert into MarksFavoriteFoods values ('Yogurt', 7);

insert into MarksFavoriteFoods values ('Brown rice', 8);

insert into MarksFavoriteFoods values ('Carrots', 9);

insert into MarksFavoriteFoods values ('Lean ground beef', 10);

  2. 새 테이블을 ASCII 파일로 저장합니다.

  3. Schema Browser를 엽니다. Tables 탭을 누른 다음 MARKSFAVORITEFOODS를 누릅니다.

  4. 오른쪽 패널에서 Data 탭을 선택합니다.

  5. 마우스 오른쪽 단추를 눌러 Save As를 선택하고 ASCII, Comma delimited를 선택한 다음 아래쪽의 Save To File을 선택합니다. C:\MarksDiet.Dat나 사용할 다른 파일 이름을 선택합니다.

  6. OK를 누릅니다.

이제 데이터 또는 입력 파일을 만들었습니다.

  3. 다음 줄을 사용하여 테이블을 비웁니다.

delete from MarksFavoriteFoods;

commit;

Schema Browser에서 테이블이 비어 있는지 확인할 수 있습니다.

  4. 시작 메뉴에서 메모장 응용 프로그램을 열고 방금 만든 데이터 파일을 로드합니다. 첫 번째 줄을 편집하여 "잘못된" 데이터를 의도적으로 만듭니다.

데이터 파일의 처음 두 줄은 다음과 같이 표시됩니다.

Tuna,1

Salmon,2

첫 번째 줄에서 쉼표를 탭으로 대체합니다. 이제 첫 번째 줄은 다음과 같아야 합니다.

Tuna 1

  5. 파일을 저장하고 메모장을 닫습니다.


입력 파일 추가

입력 파일을 추가해야 합니다. 입력 파일은 SQL*Loader 마법사를 사용하여 로드하는 실제 데이터 파일입니다.

입력 파일을 추가하려면

  1. Database 메뉴에서 Import|SQL*Loader Wizard를 선택합니다. "What would you like to do?"라는 첫 번째 창에서는 수행할 작업을 선택할 수 있습니다. Build Control File을 선택합니다. Specify Fields 상자를 선택한 상태로 두고 Next를 누릅니다.

  2. 두 번째 창에서는 하나 이상의 테이블에 로드할 데이터 파일의 목록을 입력합니다. 하나 이상의 입력 파일이 필요합니다. Add를 눌러 파일을 추가합니다.

  3. Add input file 대화 상자에서 다음과 같이 데이터 파일에 대한 정보를 입력합니다.

  • Input file name – 실제 데이터 파일의 이름입니다. 다음 세 가지 형식일 수 있습니다.

Stream -- 기본 형식입니다. 레코드 끝 마커(기본적으로 줄 끝 문자)가 발견될 때가지 줄을 읽습니다.

Fixed -- 각 레코드는 고정된 바이트 수의 길이를 가져야 합니다.

Variable -- 특정 필드(각 레코드의 첫 번째 필드)에 지정된 대로 각 레코드가 다른 길이를 가질 수 있습니다. 사용자는 이 필드의 길이를 지정해야 합니다.

예:

Stream 레코드 형식, 줄 끝 문자 – 기본값: Tuna,1

Stream 레코드 형식, 지정된 ‘|’ 문자: Tuna,1|

Fixed 레코드 형식 - 모든 데이터 레코드의 길이가 동일해야 함

Variable 레코드 형식, 지정자 필드의 길이가 3바이트: 006Tuna,1

  • Bad file name – 이 파일은 거부된 레코드를 포함합니다. 기본적으로 입력 파일과 이름이 같고 .BAD 확장명을 가집니다. 예에서는 지정한 매개 변수를 따르지 않기 때문에 잘못된 Tuna 레코드가 이 파일에 포함되어야 합니다.

  • Discard file name – 무시 파일은 선택 조건과 일치하지 않기 때문에 로드 도중에 삽입된 않은 레코드를 포함합니다. 이후의 예에서는 레코드가 삽입되기 원하는 시점을 SQL*Loader에 실제로 알릴 수 있다는 것을 보여 줍니다. 이 때 레코드는 지정된 조건과 일치해야 합니다.

주: Add Input 대화 상자의 각 필드 위에 포인터를 이동하면 상태 표시줄에 "MicroHelp"가 표시됩니다.

Input filename 옆에 있는 드릴다운 단추를 누르고 데이터 파일을 선택합니다.

  • 잘못된 파일과 무시 파일이 해당 기본 확장명과 함께 자동으로 입력됩니다.

  • 기본적으로 Stream이 선택됩니다. 줄 끝 문자가 기본값이 되도록 "end of record string" 필드를 비워 둡니다.

  • "Discard" 필드는 무시 파일에 포함할 최대 레코드 수를 나타냅니다. 무시된 모든 레코드를 포함하도록 이 필드도 비워 둡니다.

  5. OK를 누릅니다.

이제 여러 다른 입력 파일을 원하는 만큼 선택할 수 있습니다. 단, 이러한 파일은 동일한 레코드 레이아웃을 가져야 합니다(즉, 동일한 필드를 동일한 순서대로 포함해야 함). 그러나 이후의 예에 나온 것처럼 이러한 각 파일이 다른 레코드 형식을 가질 수 없다는 뜻은 아닙니다.

  6. Next를 누릅니다. 마법사는 구분 기호 설정으로 이동합니다.


SQL*Loader 자습서 구분 기호 설정

SQL*Loader 자습서 필드 매핑을 위한 구분 기호 설정

SQL*Loader 마법사의 세 번째 창에서는 데이터 파일에 대한 구분 기호를 설정할 수 있습니다.

주: Add Input File 페이지에서 Specify Fields 상자의 선택을 취소한 경우 이 창이 표시되지 않습니다.

  1. String을 선택하고 쉼표를 구분 기호로 입력합니다(기본값).

  2. 아래 그리드에는 선택한 구분 기호로 구분된 데이터가 나열됩니다. 이 그리드에 표시되는 줄 수를 변경할 수 있습니다.

쉼표를 탭으로 대체한 경우 데이터가 선택 영역에 맞지 않습니다.

  3. Next를 누릅니다. 마법사는 대상 테이블 및 열 선택으로 이동합니다.


Choose Destination Table

SQL*Loader 마법사의 네 번째 창에서는 대상 테이블을 선택할 수 있습니다. 첫 번째 화면에서 Specify Fields를 선택한 경우 필드를 열에 매핑할 수도 있습니다. 이러한 설정은 이 창의 위쪽 및 아래쪽 그리드에 표시됩니다.

  1. 위쪽 영역에서 대상 테이블을 추가합니다. Add를 누릅니다.

  2. 테이블 목록에서 MarksFavoriteFoods를 선택합니다. 확인을 누릅니다.

  3. 아래쪽 영역에서 Auto Map 단추를 누릅니다. 필드 번호가 테이블의 열에 매핑됩니다.

  4. Preview 탭을 눌러 데이터가 열에 매핑되는 방법을 확인합니다. 입력 파일을 만들 때 포함했던 오류가 미리 보기 데이터에 반영되는지 봅니다. 이를 확인하려면 데이터의 맨 위로 스크롤해야 할 수 있습니다.

  5. Next를 눌러 Global options 창으로 이동하고 매개 변수를 설정합니다.


SQL_Loader_Set Parameters

Set Parameters

마법사의 다음 창에서는 전역 옵션과 기본값을 지정할 수 있습니다.

  • 이 자습서에서는 기본값을 사용합니다. Next를 눌러 컨트롤 파일 및 로그 파일 이름을 지정합니다.

컨트롤 파일

이 창을 포함한 모든 이전 창의 아래에는 컨트롤 파일의 미리 보기가 있습니다.

다음과 비슷한 형태여야 합니다.

LOAD DATA

INFILE 'C:\marksdiet.dat'

BADFILE 'C:\marksdiet.bad'

DISCARDFILE 'C:\marksdiet.dsc'

INTO TABLE "MARKSFAVORITEFOODS"

FIELDS TERMINATED BY ','

(NAME,

RANK)


SQL*Loader Specify Control and Log Files

이 창에서는 컨트롤 파일의 이름을 입력할 수 있습니다.

  1. 컨트롤 파일로 사용할 이름을 Control file name 상자에 입력합니다. D:\confile.ctl이 사용되었지만 원할 경우 이름을 변경할 수 있습니다. <Tab> 키를 누릅니다.

  2. 컨트롤 파일 이름은 확장명 .log와 함께 로그 파일 상자에 입력됩니다. 로그 파일에 다른 이름을 사용하려면 지금 변경할 수 있습니다.

  3. Save Settings를 누릅니다. 이러한 설정을 MarksFood로 저장합니다. 이제 언제든지 설정을 로드할 수 있습니다.

  4. Next를 눌러 다음 단계로 이동하고 SQL*Loader를 실행합니다.


SQL*Loader 실행

  1. 마법사의 마지막 창을 사용하면 로드를 실행하는 방법을 선택할 수 있습니다. Execute Now를 선택합니다. Watch progress 옵션이 선택되었는지 확인합니다.

  2. Finish를 누릅니다. 다음과 같이 SQL*Loader Watch 대화 상자가 표시됩니다.

첫 번째 탭은 Output 탭이며 로더 실행의 표준 출력을 제공합니다. 로더 자체를 실행하는 동안 오류가 발생한 경우 해당 오류가 여기에 표시됩니다.

  • Output 탭에서 볼 수 있는 첫 번째 항목은 SQL*Loader 자체에 대한 일부 정보(해당 버전과 실행된 날짜 및 시간)입니다.

  • 마지막 줄에는 테이블에 10개의 행이 삽입되었다는 것이 나타납니다. Schema Browser로 이를 확인할 수 있습니다.

  3. Log 탭을 누릅니다.

Log 탭에는 로그 파일의 텍스트가 있으며 발생한 작업에 대한 자세한 정보가 제공됩니다. SQL*Loader의 실행이 끝난 후에 로그 파일 콘텐츠가 이 탭에 로드됩니다.

로그 파일에는 데이터 로드 시에 발생한 작업에 대한 많은 중요한 데이터가 포함됩니다. 창에서 아래로 약간 스크롤합니다. 1 record was rejected라는 표시를 볼 수 있습니다.

  4. Windows 시작 메뉴에서 Windows 탐색기를 엽니다. "MarksDiet.bad"라는 파일이 데이터 파일과 동일한 디렉토리에 만들어진 것을 볼 수 있습니다. 이 파일을 열면 다음 행 하나가 포함되어 있습니다.

Tuna 1

이 행은 로드에 지정한 조건, 즉 각 레코드가 쉼표로 구분된다는 조건과 일치하지 않았습니다.


채워진 테이블에서 SQL*Loader 실행

마법사의 전역 옵션 화면에서 "로드 방법"으로 Replace, Append 또는 Truncate를 선택하지 않은 경우 테이블이 채워질 때 SQL*Loader를 실행하면 오류가 생성됩니다. 작업 중에 이를 확인하려면 SQL*Loader 자습서를 실행한 후 다음 절차를 수행합니다.

채워진 테이블에 데이터를 로드하려면

  1. SQL Loader Watch 창을 닫습니다.

  2. Database 메뉴에서 Import|SQL*Loader Wizard를 선택합니다. 첫 번째 창에서 Load Settings를 누릅니다.

  3. 드롭다운 메뉴에서 MarksFood를 엽니다. OK를 누릅니다. 마법사가 최종 단계로 이동합니다.

  4. Execute Now를 선택하고 Finish를 누릅니다. Watch 창이 다시 열리고 다음 줄이 포함되어 있습니다.

SQL*Loader-601: For INSERT option, table must be empty. Error on table "MARKSFAVORITEFOODS"

달리 지정되지 않은 경우 SQL*Loader는 INSERT 모드에서 로드를 수행하고 이미 행이 포함된 테이블에 데이터를 로드하지 않습니다.

  5. 로드 방법을 변경하여 이 문제를 해결할 수 있습니다. 위에 설명된 대로 SQL*Loader를 다시 열어 MarksFood를 엽니다. 단, 이번에는 Proceed to Finish after loading을 선택 취소합니다.

  6. Next를 두 번 눌러 Destination table and columns 화면으로 이동합니다. 그리드의 로드 방법 필드에 INSERT가 입력됩니다. 행을 선택하고 Edit를 누릅니다.

  7. Load method 상자의 드롭다운 목록에서 Append를 선택합니다. OK를 누릅니다.

  8. Next|Next|Next, Execute Now 및 Finish를 누릅니다.

  9. Messages와 Log file를 읽거나 단순히 Schema Browser를 확인하면 9개의 레코드(1개는 잘못된 레코드임)가 모두 테이블에 성공적으로 추가되었다는 것을 알 수 있습니다.


논리 레코드를 여러 테이블에 로드

이 자습서에서는 논리 레코드를 사용하여 하나의 데이터 파일에 있는 데이터를 여러 테이블에 로드하는 방법을 보여 줍니다. 이 데이터에서 다른 점은 데이터 파일의 각 줄이 둘 이상의 물리 레코드(테이블 행)에 해당한다는 것입니다. 각 줄에는 두 개의 논리 레코드가 있습니다.

  1. 입력 파일 만들기에 설명된 것과 동일한 입력 파일을 만듭니다. MarksFavoriteFoods 테이블과 동일한 다른 테이블을 만듭니다. 이름을 TESTTHIS로 지정합니다. 두 테이블이 모두 비어 있는지 확인합니다.

  2. 입력 파일을 편집하여 다음과 같이 만듭니다.

데이터가 정확하게 정렬되어야 합니다. 탭이 아니라 공백을 사용합니다. 첫 번째 숫자 열은 14번째 문자로 정렬되어야 합니다. 두 번째 음식 열은 18번째 문자에서 정렬되어야 합니다. 두 번째 숫자 열은 35번째 문자에 있어야 합니다.

  3. SQL*Loader 마법사를 열고 Build control file을 선택합니다. Specify Files 상자의 선택을 취소합니다. Next를 누릅니다.

  4. 새 데이터 파일을 입력 파일로 추가합니다. Next를 누릅니다.

  5. Destination Tables 그리드에서 MarksFavoriteFoods 및 TestThis 테이블을 모두 추가합니다.

  6. 테이블 그리드에서 MARKSFAVORITEFOODS를 선택하고 그 아래의 열 그리드에서 Name 열을 선택합니다.

  7. 열 영역에서 Edit를 누릅니다.

  8. 그리드에서 From/To column 필드에 각각 1과 12를 입력합니다.

이렇게 하면 테이블은 데이터 파일에서 처음 12개의 열을 읽어 Name 필드를 추출합니다.

  8. Rank 열을 누르고 From/To에 14와 14를 입력합니다. 이는 해당 필드에 대해 입력 파일에서 Rank 데이터가 상주하는 위치입니다.

  9. 테이블 그리드에서 TESTTHIS를 선택하고 해당 Name 열을 선택합니다. 이 열에 대한 From/To 값은 18과 33입니다.

  10. 최종적으로 마지막 Rank 열을 선택하고 From/To에 34와 36을 입력합니다. Next를 두 번 누릅니다.

  11. 을 눌러 Open 대화 상자에서 컨트롤 파일을 선택하거나 컨트롤 파일의 새 이름을 입력합니다. OK를 누릅니다.

  12. Next를 누릅니다.

  13. Execute Now 및 Watch Progress를 선택하고 Finish를 누릅니다. Schema Browser를 열고 테이블을 검사할 경우 1, 3, 5, 7 및 9 순위의 음식이 첫 번째 테이블로 이동했으며 2, 4, 6, 8 및 10 순위의 음식이 두 번째 테이블로 이동한 것을 볼 수 있습니다.


파티션으로의 조건부 로드

이 자습서에서는 조건과 함께 파티션에 로드하는 방법을 보여 줍니다.

주: 이 시점에서 테이블을 선택하면 파티션 필드가 테이블의 파티션으로 채워지는 것처럼 하위 파티션 필드가 사용 가능한 하위 파티션으로 채워지지 않습니다. 따라서 이름을 직접 입력해야 합니다.

  1. 범위 파티션이 있는 첫 번째 테이블을 삭제하고 다시 만듭니다. 다음 코드를 실행합니다.

DROP TABLE MARKSFAVORITEFOODS;

CREATETABLE MARKSFAVORITEFOODS (

NAME VARCHAR2 (30),

RANK NUMBER)

PARTITION BYRANGE (RANK)

(PARTITION FoodRank1 VALUES LESS THAN (5),

PARTITION FoodRank2 VALUES LESS THAN (MAXVALUE));

이 테이블에서 첫 번째 자습서를 다시 실행할 경우 4위까지의 음식이 FoodRank1이라는 파티션으로 이동하고 나머지는 모두 FoodRank2라는 파티션으로 이동합니다. 이를 시도해 보고 다음 SQL을 통해 내용을 확인합니다.

SELECT * from MarksFavoriteFoods partition (FoodRank1)

SELECT * from MarksFavoriteFoods partition (FoodRank2)

그러나 이 예에서는 모든 데이터를 FoodRank1 파티션에 로드하는 것을 시도합니다. 첫 번째 자습서를 다시 실행하여 위의 주 부분을 시도한 경우 이제 테이블을 비웁니다.

  2. SQL*Loader Wizard를 엽니다.

  3. Build control file을 선택하고 Next를 누릅니다.

  4. 예 1의 시작 부분에서 쉼표로 구분된 원래 파일을 선택하여 입력 파일 목록에 추가합니다. Next를 누릅니다.

  5. Destination Table로 MarksFavoriteFoods를 다시 선택합니다.

  6. Table Parameters 탭에서 Partition 라디오 단추를 선택합니다. 드롭다운 목록을 누르면 만들어진 두 개의 파티션이 나열된 것을 볼 수 있습니다. FOODRANK1을 선택합니다. 그 아래의 All fields delimited by 필드에 쉼표를 입력합니다.

주: 데이터가 탭으로 구분된 경우 드롭다운에서 TAB을 선택합니다.

  7. Table Parameters 탭의 오른쪽에는 Load rec when이라는 필드가 있습니다. 이는 "다음 조건이 있을 경우 레코드를 테이블에 로드"를 의미합니다. 이 필드에 다음을 입력합니다.

RANK != "1"

이는 RANK 필드가 문자 "1"과 같지 않은 레코드만 원한다는 것을 의미합니다.

주: 모든 문자 데이터는 Oracle에서 자동으로 해석됩니다. 특정 조건에 대한 특정 데이터 형식을 적용하려는 경우 Column Parameters data type 필드를 사용할 수 있습니다.

  8. Next를 누릅니다. 전역 옵션과 기본값을 비워 두고 Next를 누릅니다.

  9. 만들려는 컨트롤 파일 이름을 입력합니다. Next를 누릅니다.

  10. Execute Now 및 Watch progress를 선택한 다음 Finish를 누릅니다. 상태 창이 열립니다.

  11. Log File 탭을 누릅니다. 아래로 스크롤하면 다음 줄이 있어야 합니다.

Record 1: Discarded - failed all WHEN clauses.

Record 5: Rejected - Error on table "MARKSFAVORITEFOODS", partition FOODRANK1.

ORA-14401: inserted partition key is outside specified partition

[and so on for the rest of the records]

이는 첫 번째 레코드가 WHEN 절에서 실패했다는 것을 의미합니다. 앞에서 순위가 1인 모든 레코드를 로드하지 않도록 지정했으며 이 레코드의 순위는 1이었습니다. 나머지 거부 줄에서는 삽입된 파티션 키가 파티션 경계를 벗어난다는 것을 나타냅니다. 이는 순위가 5 이상인 레코드가 FOODRANK1에 대해 선택된 파티션 경계를 초과하기 때문입니다. Schema Browser를 확인하면 데이터에서 2위부터 4위까지의 음식이 표시되어야 합니다.


다른 형식의 여러 파일에서 로드

이 예에서는 세 개의 다른 데이터 파일을 사용하며 지원되는 세 가지 파일 형식인 스트림, 고정 및 가변 형식을 보여 줍니다.

  1. 이전 자습서의 MarksDiet.dat 데이터를 사용합니다. 메모장을 편집기로 사용해야 한다는 것에 주의합니다.

  2. 원래 파일을 분할하여 세 개의 파일인 MarksDiet1.dat, MarksDiet2.dat 및 MarksDiet3.dat를 만듭니다.

  3. 첫 번째 파일(MarksDiet1.dat)을 편집합니다. 다음과 같은 형태여야 합니다.

Tuna,1*Salmon,2*Broccoli,3*

주: 줄의 끝에는 추가 공백이나 새 줄 문자가 없습니다. 이 샘플에서는 별표를 레코드 마커의 끝으로 사용하는 것을 보여 줍니다. 지금까지는 캐리지 리턴/새 줄 문자 조합을 사용하여 물리적 레코드를 지정했습니다.

  4. MarksDiet2.dat를 다음과 같이 편집합니다.

Asparagus, 4,Bell peppers,5,Chicken, 6,

마찬가지로 공백이나 새 줄 문자를 줄의 끝에 사용하지 않습니다. 이 파일은 고정 레코드 길이 파일이 됩니다. 각 레코드는 정확하게 15자로 고정됩니다.

  5. 세 번째 파일은 이름이 MarksDiet3.dat이고 다음과 같은 형태여야 합니다.

0009Yogurt,7,0015Brown rice,8,

0010Carrots,9,0019Lean ground beef,10

주: 8 이전 버전의 SQL*Loader(예: 7.3)에서는 레코드 길이 필드 다음에 공백이 필요합니다.

이 파일은 가변 형식 파일입니다. 각 레코드의 시작 부분은 레코드 길이를 지정하는 필드입니다. 첫 번째 줄에 있는 Brown Rice를 봅니다. 문사 수를 계산하면 13개입니다. 그러나 메모장에서 두 개의 추가 문자(캐리지 리턴/줄 바꿈 쌍)를 추가하므로 이러한 추가 문자도 합계에 더해야 합니다.

주: 다른 편집기에서는 줄 바꿈 문자 하나만 추가할 수도 있습니다.

마찬가지로 두 번째 줄의 끝에 추가 공간이나 캐리지 리턴이 없는지 확인합니다.

  6. SQL*Loader 마법사를 열고 Build control file을 선택합니다. Specify Files 확인란을 선택 취소합니다. Next를 누릅니다.

  7. 다음과 같이 파일을 추가합니다.

  8. MarksDiet1.dat - Stream 형식을 선택하고 레코드 문자열 필드의 끝에 별표를 입력합니다.

  9. MarksDiet2.dat - 길이를 15로 하여 Fixed 형식을 선택합니다.

  10. MarksDiet3.dat - 길이를 4바이트로 하여 Variable 형식을 선택합니다(길이 필드에 4 입력).

이러한 파일을 추가한 후에 Source Files 탭은 다음과 같아야 합니다.

  8. Next를 누릅니다. 동일한 대상 테이블을 선택합니다.

주: 명령 실행을 시도하기 전에 테이블이 비어 있어야 합니다. 테이블이 비어 있지 않은 경우 설정을 저장하고 테이블을 비운 다음 설정을 다시 마법사에 로드합니다.

  9. Next를 누릅니다. 전역 옵션을 비워 둡니다.

  10. Next를 누릅니다. 컨트롤 파일을 추가합니다.

  11. Next를 누릅니다. Execute Now를 선택하고 Finish를 누릅니다.

테이블이 여전히 분할된 경우 다음 줄을 사용하여 각각에 포함된 데이터를 볼 수 있습니다.

select * from MarksFavoriteFoods partition (FoodRank1)

select * from MarksFavoriteFoods partition (FoodRank2)


고급 기능

이 최종 자습서에서는 열 수준에서 입력 데이터 구분 기호를 지정하고 제약 조건 오류를 캡처하는 방법과 사용 가능한 일부 명령줄 옵션을 보여 줍니다.

이 예에서는 모든 음식 순위가 포함된 테이블에 대한 외래 키를 만듭니다.

  1. 편집기에서 다음을 스크립트로 실행합니다. 복사하여 붙여넣을 경우 저작권 표시를 제거해야 합니다.

CREATE TABLE FOODRANK (

  RANK NUMBERPRIMARYKEY);

DECLARE

I INTEGER;

BEGIN

I := 1;

LOOP

INSERT INTO FOODRANK

VALUES (I);

I := I

+ 1;

IF I > 10

THEN

EXIT;

END IF;

END LOOP;

END;

/

CREATE TABLE MARKSFAVORITEFOODS (

  NAME VARCHAR2(20),

  RANK NUMBER

);

CREATE TABLE LOADEREXCEPTIONS(

ROW_ID UROWID,

OWNERVARCHAR2(30),

TABLE_NAMEVARCHAR2(30),

CONSTRAINT VARCHAR2(30)

);

ALTER TABLE MARKSFAVORITEFOODS ADD CONSTRAINT CHECK_RANK FOREIGN KEY (RANK) REFERENCES FOODRANK(RANK)

EXCEPTIONS INTO LOADEREXCEPTIONS;

  2. 다음과 같이 입력 데이터 파일을 만듭니다. 복사하여 편집기에 붙여넣을 때 매우 주의해야 합니다. 끝에 빈 줄이 없는지 확인합니다.

"Grease^#1

"Tuna^#1

"Salmon^#02

"Broccoli^#3

"Asparagus^#4

"Bell peppers^#5

"Chicken^#6

"Yogurt^7

"Brown rice^#8

"Carrots^#9

Lean ground beef#10

"Egg whites^#11

"Congealed Fat^#99

이 입력 파일을 간략하게 살펴봅니다. 첫 번째 필드인 Food Name에서 큰따옴표가 첫 번째 구분 기호입니다. 닫는 구분 기호는 캐럿이고 끝 필드 지정자는 # 문자입니다. Rank 필드는 구분되지 않습니다. 해당 데이터를 복사하여 편집기에 붙여넣습니다. 마찬가지로 숨겨진 문자가 없는지 확인합니다. (Grease와 Congealed Fat는 목록에 어떻게 포함된 것입니까? 나중에 이를 수정할 것입니다.)

  3. 데이터 파일을 저장하고 SQL*Loader 마법사를 실행하여 첫 번째 화면에서 Build control file을 선택합니다. 데이터 파일을 입력 파일로 선택합니다. Next를 누릅니다.

  4. MarksFavoriteFoods를 대상 테이블로 추가합니다.

  5. Table Parameters 탭에서 LOADEREXCEPTIONS를 Exceptions 테이블로 입력하거나 선택합니다.

이는 모든 제약 조건 예외를 LOADEREXCEPTIONS로 이동한다는 것을 나타냅니다. 예외 테이블은 위에 표시된 형식이어야 합니다. 제약 조건을 위반하는 행의 RowID가 이 테이블로 이동합니다.

  6. 예외 테이블의 이름을 입력했을 때 Reenable Constraints가 자동으로 선택됩니다. 이 옵션은 로드가 끝났을 때 제약 조건을 다시 활성화하도록 SQL*Loader에 지시합니다. 제약 조건이 다시 활성화되면 참조 무결성 검사가 실행되어 일부 데이터가 실패하고 행이 예외 테이블에서 표시됩니다.

데이터를 다시 살펴봅니다. 음식 순위가 99인 Congealed Fat는 참조 무결성 제약 조건을 위반한다는 것을 분명하게 알 수 있습니다. FOODRANK 테이블에 1부터 10까지 10개의 순위만 있으므로 나머지는 허용되지 않습니다.

  7. 트리 보기에서 테이블 이름 옆의 + 기호를 눌러 MarksFavoriteFoods에 대한 열을 표시합니다.

  8. Name 열을 선택하고 Column Parameters 탭의 Field is terminated by: 필드에 # 기호를 입력합니다. 필드를 " 및 ^ 기호로 묶으므로 해당 필드에도 이러한 문자를 입력합니다. 모든 음식 이름 필드가 구분되는 것은 아니므로 optionally 확인란을 선택합니다.

  9. Null If 필드로 이동합니다. Null If는 "이 조건에 해당할 경우 문자 열을 null로 설정하고 숫자 열을 0으로 설정"하라고 SQL*Loader에 지시합니다. Null If 필드에 RANK="3"을 입력합니다. 이렇게 하면 Rank가 3일 경우 Food Name 열이 비워집니다. 해당 순위에 대한 음식이 Broccoli이므로 이 음식은 표시되지 않습니다.

  10. Default if 필드로 이동합니다. NAME="Bell peppers"를 입력합니다. 이렇게 하면 Name이 "Bell peppers"일 때마다 Food Name 열이 null로 설정됩니다.

화면은 다음과 같아야 합니다.

  11. NEXT를 누릅니다. 명령줄 옵션은 실행 가능 명령줄에서 지정할 수 있는 옵션입니다. Skip에 1을 입력합니다. 이렇게 하면 1개의 레코드를 건너뛰도록 지정됩니다. Grease 필드를 건너뜁니다.

  12. Load field에 11을 입력합니다. 이렇게 하면 데이터 파일에서 11개의 레코드를 로드하도록 지정됩니다. 따라서 첫 번째 줄을 건너뛰고 다음 11개가 로드됩니다. Congealed Fat 레코드는 로드되지 않습니다. 로드되더라도 Congealed Fat 레코드는 Rank가 99이므로 제약 조건 검사에 실패합니다.

  13. Direct Path Load를 수행하려고 하므로 Direct 확인란을 선택합니다. 전혀 다른 스타일의 이 로드 방법은 표준 SQL 삽입을 수행하지 않고 버퍼를 사용합니다. 이 방법에서는 제약 조건을 해제하는 것이 허용됩니다.

  14. 마지막으로 Silent 아래에서 All 확인란을 선택합니다. 이렇게 하면 로더에서 모든 출력 메시지를 표시하지 않습니다. 로그 파일은 계속 만들어집니다.

주: 이러한 옵션은 함께 사용할 수 있습니다. 예를 들어 Feedback과 Errors를 비활성화하고 Discards는 비활성화하지 않을 수 있습니다.

  15. Next를 누릅니다. 컨트롤 파일 이름을 입력합니다(D:\confile.ctl이 사용되었지만 원할 경우 이름을 변경할 수 있음). Next를 누릅니다.

  16. Save Settings를 눌러 이러한 설정을 저장합니다. 나중에 이러한 설정을 다시 사용할 것입니다.

  17. Execute now 및 Watch progress를 선택합니다. Finish를 누릅니다.

모든 메시지를 표시하지 않도록 지정했으므로 Messages 탭에는 다음 줄만 표시됩니다.

SQL*Loader: Release 8.1.6.0.0 - Production on Fri Oct 27 13:57:14 2000

(c) Copyright 1999 Oracle Corporation. All rights reserved.

  18. 로그 파일에는 10개의 행이 로드되었으며 데이터 오류로 인해 1개의 행이 로드되지 않았다고 되어 있습니다. 1개의 행은 무엇입니까? MarksDiet.bad를 엽니다(또는 지정한 이름에 .bad 확장명이 추가된 데이터 파일). 다음 줄을 볼 수 있습니다.

"Yogurt^7

이 줄에서 잘못된 부분은 무엇입니까? 이 줄에는 필드 종료 문자 #이 없습니다. lean ground beef 줄을 확인합니다.

Lean ground beef#10

이 경우 구분 기호가 없더라도 로드되었습니다. 이는 구분 기호가 선택적이라고 지정했기 때문입니다.

  19. 이제 Schema Browser를 열고 MarksFavoriteFoods의 Data 탭을 확인합니다. 다음과 같은 형태여야 합니다.

Broccoli 및 Bell Peppers는 요청된 대로 비어 있습니다. Grease는 건너뛰었으며 Congealed Fat는 "Loaded" 한도를 벗어나므로 로드되지 않았습니다. Yogurt는 잘못된 데이터로 인해 로드되지 않았습니다. 그렇다면 Egg Whites는 순위가 11인데 제약 조건이 실패하지 않은 이유는 무엇입니까? Salmon의 경우 순위 0은 어떻게 된 것입니까? 이 음식은 순위가 2였습니다.

  20. 확인할 로그 파일을 엽니다. 컨트롤 파일에 지정한 이름과 .LOG 확장명을 가진 로그 파일은 컨트롤 파일과 동일한 디렉토리에 있습니다. 맨 아래 근처에서 다음을 볼 수 있습니다.

Column Name Position Len Term Encl Datatype

-----------------------------------------------------------------------------------------------------

NAME FIRST * # O(")

CHARACTER

O(^)

NULL if RANK = 0X33(character '3')

DEFAULT if NAME = 0X42656c6c2070657070657273(character 'Bell peppers')

RANK NEXT 1

CHARACTER

Len은 길이를 나타냅니다. Name의 길이는 *인데 이는 필드 마커의 끝까지 읽는다는 것을 의미합니다(# - 종료 문자). 그러나 Rank의 길이가 1이므로 1개의 문자만 로드되었습니다. 이는 Rank에 필드 종료자를 지정하지 않았기 때문입니다. Name에는 지정했지만 Rank에는 지정하지 않았습니다.

  21. SQL Edit 창을 열고 다음을 입력하여 MarksFavoriteFoods에서 레코드를 제거합니다.

delete from marksfavoritefoods

  22. SQL*Loader 마법사를 엽니다. 이전에 저장한 설정을 로드합니다(Proceed to finish 상자 선택 취소). Destination Tables로 이동할 때까지 Next를 누릅니다.

  23. Rank를 선택하고 Column Parameters 탭으로 이동합니다. Field is terminated by 필드의 드롭다운에서 WHITESPACE를 선택합니다.

  24. SQL*Loader Wizard를 한 번 더 실행합니다. Schema Browser에서 모든 숫자 데이터가 올바르게 입력되었는지 확인합니다. 로그 파일을 검사하면 제약 조건이 비활성화되었고 레코드가 로드되었으며 제약 조건을 다시 활성화하기 위한 시도가 수행되었다는 것을 알 수 있습니다. 그러나 Egg White라는 고아 레코드가 있기 때문에 사용된 특정 제약 조건(외래 키 제약 조건)은 다시 활성화할 수 없었습니다. LOADEREXCEPTIONS 테이블을 보면 위반 레코드의 RowID를 확인할 수 있습니다.


창: Toad Server Statistics

Toad Server Statistics

Database|Monitor|Server Statistics 메뉴 항목을 선택하면 이 대화 상자가 나타납니다.

이 대화 상자를 사용하면 Oracle 인스턴스의 수행 방법에 대한 정보를 볼 수 있습니다. 이 대화 상자는 다음 탭으로 구성됩니다.

Analysis

경고등 임계값을 설정하려면 Oracle\Temps\toadstats.ini 파일에 대해 Toad를 작성하는 방법 을 참조하십시오.

필요한 권한 목록을 보려면 Server Statistics Analysis를 참조하십시오.

Waits

필요한 권한 목록을 보려면 Server Statistics Waits를 참조하십시오.

Latches

필요한 권한 목록을 보려면 Server Statistics Latches를 참조하십시오.

Sessions

필요한 권한 목록을 보려면 Server Statistics Sessions를 참조하십시오.

Instance Summary

필요한 권한 목록을 보려면 Instance Summary를 참조하십시오.


SQL Monitor

SQL Monitor를 사용하여 데이터베이스에서 작업 중인 SQL 구문을 모니터할 수 있습니다. 이 유틸리티는 Toad와 별도로 제공되며 <F1>을 누르거나 Help|Contents를 선택하여 열면 도움말을 얻을 수 있습니다.


ADDM/AWR

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Oracle 10g ADDM(Automatic Database Diagnostic Monitor)은 완성된 조정 솔루션을 제공합니다. 다음과 같은 요구 사항이 충족되는 한 특정 인스턴스에서 가져온 AWR(Automatic Workload Repository) 스냅숏 한 쌍에서 정의한 기간 동안 ADDM 분석을 수행할 수 있습니다.

  • 스냅숏을 작성하는 동안 어느 쪽에서도 오류가 발생하지 않았고 어느 쪽도 제거되지 않았습니다.

  • 두 스냅숏 사이에 시스템 종료나 시작 작업이 없었습니다.

ADDM 및 AWR 보고에는 문제 영역 및 데이터베이스에서 순조롭게 실행되는 영역을 둘 다 기록할 수 있습니다. ADDM/AWR 보고에 대한 자세한 내용은 Oracle 설명서를 참조하십시오.

Toad의 ADDM/AWR 창을 사용하면 Toad에서 다음을 수행할 수 있습니다.

  • 보고서 생성(ADDM 보고서, AWR 보고서, AWR SQL 보고서, AWR Diff 보고서, ASH 보고서 포함)

  • 클립보드에 보고서 복사

  • 보고서 인쇄

  • 파일에 보고서 저장

  • 스냅숏 관리(통계 보기, 작성, 삭제)

  • 기준선 관리(보기, 작성, 삭제)

ADDM에서는 시스템의 문제가 없는 영역도 기록합니다. 예를 들어 시스템의 성능에 큰 영향을 주지 않는 대기 이벤트 클래스를 초기 단계의 조정 검토에서 식별 및 제거하여 전체적인 시스템 성능에 영향을 주지 않는 항목에 소비될 시간과 노력을 절약할 수 있습니다.

ADDM은 문제를 진단할 뿐 아니라 가능한 솔루션도 제안합니다. 적절한 경우 ADDM은 DBA에서 선택할 수 있는 여러 솔루션을 제안합니다. ADDM에서는 권장 사항을 생성하는 동안 시스템의 다양한 변경 사항을 검토합니다.

ADDM/AWR 창에 액세스하려면

  • Database 메뉴에서 Monitor|ADDM/AWR을 선택합니다.

관련 항목

ADDM Report 생성

ADDM Report 작업

QuickFilter 상자 사용


ADDM Report 생성

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Toad에서는 ADDM Report를 쉽게 생성할 수 있습니다.

ADDM Report를 생성하려면

  1. Database 메뉴에서 Monitor|ADDM/AWR을 선택합니다.

  2. ADDM/AWR Report 탭을 누릅니다.

  3. Instance 드롭다운 상자에서 적절한 인스턴스를 선택합니다.

  4. 드릴다운 [image] 단추를 눌러 다음을 선택합니다.

  • 시작 스냅숏

  • 끝 스냅숏

  • 기준선 범위

주: 스냅숏 목록을 줄이려면 Filter by ID를 선택하고 Quickfilter 상자를 사용하여 목록을 필터링합니다.

  4. OK를 누릅니다.

  5. Report Generator 도구 모음에서 Generate Report [image] 단추를 누릅니다.

  6. ADDM report 탭을 눌러 ADDM 보고서를 봅니다.

관련 항목

ADDM Report Generator

ADDM Report 작업

QuickFilter 상자 사용


ADDM Report 작업

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

ADDM Report가 생성되면 Toad 화면에서 해당 보고서를 읽을 수 있습니다.

또는 다른 형식으로 보고서 작업을 할 수도 있습니다. ADDM Report는 여러 가지 방법으로 이동할 수 있습니다.

ADDM Report를 클립보드에 복사하려면

  • ADDM Report를 실행한 후 Copy to Clipboard [image] 단추를 누릅니다.

ADDM report를 인쇄하려면

  • ADDM report를 실행한 후 Print [image] 단추를 누릅니다.

ADDM report를 파일에 저장하려면

  • ADDM report를 실행한 후 Save to File [image] 단추를 누릅니다.

관련 항목

ADDM Report Generator

ADDM Report 생성

QuickFilter 상자 사용


AWR 보고서 생성

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Toad에서 AWR 보고서를 쉽게 생성할 수 있습니다.

AWR 보고서를 생성하려면

  1. Database 메뉴에서 Monitor|ADDM/AWR을 선택합니다.

  2. ADDM & AWR Reports 탭을 누릅니다.

  3. Instance 드롭다운 상자에서 해당 인스턴스를 선택합니다.

  4. 드릴다운 [image] 단추를 눌러 다음을 선택합니다.

  5. Starting snapshot

  6. Ending snapshot

  7. Baseline range

주: 스냅숏의 목록을 줄이려면 Filter by ID를 선택하고 Quickfilter 상자를 사용하여 목록을 필터링합니다.

  5. 확인을 누릅니다.

  6. Report Generator 도구 모음에서 Generate Report [image] 단추를 누릅니다.

  7. AWR Report - HTML Format 탭 또는 AWR Report - Text Format 탭을 선택하여 이러한 형식 중 하나로 보고서를 봅니다.

관련 항목

ADDM Report Generator

ADDM 보고서 사용

QuickFilter 상자 사용


AWR SQL 보고서 생성

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Oracle 10.2 이상을 사용하는 경우 Toad에서 AWR SQL 보고서를 쉽게 생성할 수 있습니다.

AWR SQL 보고서를 생성하려면

  1. Database 메뉴에서 Monitor|ADDM/AWR을 선택합니다.

  2. AWR SQL Report 탭을 누릅니다.

  3. Instance 드롭다운 상자에서 해당 인스턴스를 선택합니다.

  4. 드릴다운 [image] 단추를 눌러 다음을 선택합니다.

  5. Starting snapshot

  6. Ending snapshot

  7. Baseline range

주: 스냅숏의 목록을 줄이려면 Filter by ID를 선택하고 Quickfilter 상자를 사용하여 목록을 필터링합니다.

  5. 확인을 누릅니다.

  6. 드릴다운 [image] 단추를 눌러 SQL ID를 선택합니다.

  7. AWR Report Generator 도구 모음에서 Run AWR Report [image] 단추를 누릅니다.

  8. HTML 탭 또는 Text 탭을 선택하여 이러한 형식 중 하나로 보고서를 봅니다.

관련 항목

ADDM/AWR

ADDM 보고서 사용

AWR 보고서 생성

QuickFilter 상자 사용


AWR 차이 보고서 생성

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Oracle 10.2 이상을 사용하는 경우 Toad에서 AWR 차이 보고서를 쉽게 생성할 수 있습니다.

AWR 차이 보고서를 생성하려면

  1. Database 메뉴에서 Monitor|ADDM/AWR을 선택합니다.

  2. AWR Diff Report 탭을 누릅니다.

  3. Compare This 영역에서 다음을 수행합니다.

  1. Instance 드롭다운 상자에서 해당 인스턴스를 선택합니다.

  2. 드릴다운 [image] 단추를 눌러 다음을 선택합니다.

  3. Starting snapshot

  4. Ending snapshot

  5. Baseline range

주: 스냅숏의 목록을 줄이려면 Filter by ID를 선택하고 Quickfilter 상자를 사용하여 목록을 필터링합니다.

  3. 확인을 누릅니다.

  4. To This 영역에서 다음을 수행합니다.

  1. Instance 드롭다운 상자에서 해당 인스턴스를 선택합니다.

  2. 드릴다운 [image] 단추를 눌러 다음을 선택합니다.

    1. Starting snapshot

    2. Ending snapshot

    3. Baseline range

주: 스냅숏의 목록을 줄이려면 Filter by ID를 선택하고 Quickfilter 상자를 사용하여 목록을 필터링합니다.

  3. OK를 누릅니다.

  4. AWR Diff Report Generator 도구 모음에서 Run AWR Diff Report [image] 단추를 누릅니다.

  5. HTML 탭 또는 Text 탭을 선택하여 이러한 형식 중 하나로 보고서를 봅니다.

관련 항목

ADDM/AWR

ADDM 보고서 사용

AWR 보고서 생성

QuickFilter 상자 사용


ASH 보고서 생성

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Toad에서 ASH(Active Session History) 보고서를 쉽게 생성할 수 있습니다.

ASH 보고서를 생성하려면

  1. Database 메뉴에서 Monitor|ADDM/AWR을 선택합니다.

  2. ASH Report 탭을 누릅니다.

  3. Instance 드롭다운 상자에서 해당 인스턴스를 선택합니다.

  4. 해당 상자에서 시작 날짜와 시간을 선택합니다.

  5. 해당 상자에서 종료 날짜와 시간을 선택합니다.

  6. ASH Report Generator 도구 모음에서 Run ASH Report [image] 단추를 누릅니다.

  7. HTML 탭 또는 Text 탭을 선택하여 이러한 형식 중 하나로 보고서를 봅니다.

관련 항목

ADDM Report Generator

ADDM 보고서 사용

QuickFilter 상자 사용


Data Select 대화상자

Data select 대화상자를 사용하여 선택한 보고서에 사용할 스냅샷을 선택합니다. 이 대화상자를 사용하여 시작 및 종료 스냅샷 또는 기준선 스냅샷을 선택할 수 있습니다.

데이터 눈금 필터링

대화상자의 아래에서 Quickfilter 상자를 사용하여 데이터 눈금을 필터링할 수 있습니다.

눈금을 필터링하려면

  1. Filter by 확인란을 선택합니다.

  2. 확인란 아래의 Quickfilter 상자에 필터링 조건을 입력합니다.

데이터 선택

데이터 눈금의 행을 눌러 데이터를 선택합니다. 한 번에 하나의 행만 선택할 수 있습니다.

데이터를 선택하려면

  1. 데이터 눈금의 행을 눌러 데이터를 선택합니다.

  2. 필요하면 질의를 편집하거나 변수를 삽입합니다.

  3. OK를 누릅니다.

SELECT 질의 편집

행을 선택했으면 Oracle로 전송하기 전에 질의를 편집할 수 있습니다. WHERE 및 ORDER BY 절 편집으로 제한해야 합니다.

질의를 편집하려면

  1. 데이터를 선택합니다.

  2. Edit Query 단추를 누릅니다.

  3. Where 또는 Order By 절을 편집합니다.

  4. 아니면 Check 단추를 눌러 질의에 구문 오류가 있는지 확인합니다.

  5. OK를 누릅니다.

관련 항목

ADDW_AWR_Baseline_Manager

기준선 작성


ADDM/AWR Snapshot Management

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Snapshot Management 탭을 사용하면 스냅숏을 쉽게 관리할 수 있습니다.

Snapshot Management 탭은 수집 설정과 스냅숏 세부 정보의 두 영역으로 나뉩니다.

수집 설정

수집 설정은 Oracle에서 스냅숏을 취하는 빈도와 유지 기간을 정의하는 일에 사용하는 설정입니다.

형식은 +dd hh:mm:ss:nnnnnnn과 같습니다.

Snapshot Interval

Snapshot Interval은 Oracle에서 스냅숏을 취하는 간격을 지정합니다. 기본값은 1시간: +00 01:00:00:000000입니다.

Retention

Retention은 스냅숏을 유지하는 기간을 지정합니다. 기본값은 7일: +07 00:00:00.000000입니다.

Top N SQL

각 SQL 기준에 플러시할 Top SQL에는 다음을 선택하여 사용할 수 있습니다.

  • Default - Top 30을 통계 수준 TYPICAL에 사용하고 Top 100을 통계 수준 ALL에 사용합니다.

  • Maximum - SQL 집합 전체를 커서 캐시에 캡처합니다.

  • Specify - 다음에서 설명한 대로 지정한 값을 사용합니다.

Specify를 선택한 경우에는 숫자 상자에 값을 입력합니다. 이 값은 통계 또는 플러시 수준에 영향을 받지 않습니다. 이 값은 AWR SQL 수집의 기본 동작을 다시 정의합니다.

스냅숏

스냅숏 영역에서는 다음을 수행할 수 있습니다.

  • View Snapshot Statistics

  • Create a New Snapshot

  • Drop a Snapshot Range

옵션은 선택 사항에 따라 변경됩니다.

관련 항목

ADDM/AWR

ADDM/AWR Create New Snapshot

ADDM/AWR Drop Snapshot Range

ADDM/AWR View Snapshot Statistics

ADDM/AWR Baseline Manager


ADDM/AWR View Snapshot Statistics

View Snapshot Statistics

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Snapshot Management 탭에서는 현재 연결에 있는 스냅숏의 누적 스냅숏 통계를 볼 수 있습니다. 또한 SYS로 연결된 경우에는 사용되지 않는 AWR 공간을 할당 취소하거나 AWR 개체를 축소할 수도 있습니다.

스냅숏 통계를 보려면

  1. ADDM/AWR 창에서 Snapshot Management 탭을 누릅니다.

  2. 스냅숏 영역에서 통계를 볼 스냅숏의 번호를 누릅니다. 스냅숏 번호 목록 오른쪽에 통계가 표시됩니다.

사용되지 않는 AWR 공간의 할당을 취소하려면

  1. ADDM/AWR 창에서 Snapshot Management 탭을 누릅니다.

  2. 스냅숏 영역에서 Deallocate Unused AWR Space [image] 단추를 누릅니다.

주: 이 기능을 수행하려면 SYS로 연결되어 있어야 합니다.

AWR 개체를 축소하려면

  1. ADDM/AWR 창에서 Snapshot Management 탭을 누릅니다.

  2. 스냅숏 영역에서 View Snapshot Statistics를 누릅니다.

  3. Shrink AWR Objects [image] 단추를 누릅니다.

관련 항목

ADDM/AWR

ADDM/AWR Create New Snapshot

ADDM/AWR Drop Snapshot Range

ADDM/AWR Snapshot Management

ADDM/AWR Baseline Manager


ADDM/AWR Create New Snapshot

Create New Snapshot

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

ADDM/AWR 창에서 새 스냅숏을 작성할 수 있습니다.

새 스냅숏을 작성하려면

  1. ADDM/AWR 창에서 Snapshot Management 탭을 누릅니다.

  2. 스냅숏 영역에서 Create New Snapshot [image] 단추를 누릅니다.

  3. Flush Level: Typical

또는

Flush Level: All을 선택합니다.

  4. OK를 눌러 스냅숏을 작성합니다.

새 스냅숏의 스냅숏 ID가 나열된 정보 창이 표시됩니다. 예를 들면 "Snapshot ID 6517 has been created"와 같습니다.

  5. OK를 누릅니다.

관련 항목

ADDM/AWR

ADDM/AWR Drop Snapshot Range

ADDM/AWR Snapshot Management

ADDM/AWR View Snapshot Statistics

ADDM/AWR Baseline Manager


ADDM/AWR Drop Snapshot Range

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

스냅숏 범위를 쉽게 삭제할 수 있습니다.

스냅숏 범위를 삭제하려면

  1. ADDM/AWR 창에서 Snapshot Management 탭을 누릅니다.

  2. 스냅숏 영역에서 Drop Snapshot Range를 누릅니다.

  3. Starting Snapshot 상자 옆의 드릴다운 [image] 단추를 누릅니다.

  4. Data Select 대화 상자에서 시작 스냅숏을 선택하고 OK를 누릅니다.

  5. Ending Snapshot 상자 옆의 드릴다운 [image] 단추를 누릅니다.

  6. Data Select 대화 상자에서 끝 스냅숏을 선택하고 OK를 누릅니다.

  7. Execute를 눌러 범위를 삭제합니다.

관련 항목

ADDM/AWR

ADDM/AWR Create New Snapshot

ADDM/AWR Snapshot Management

ADDM/AWR View Snapshot Statistics

ADDM/AWR Baseline Manager


ADDW/AWR Baseline Manager

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Baseline Manager를 사용하여 다양한 기준선을 보고 제어할 수 있습니다.

창의 왼쪽에 있는 탐색 창에서 설정된 기준선을 볼 수 있습니다. 기준선은 이름별로 나열됩니다.

기준선을 보려면

  • Baselines 탐색 창에서 기준선 이름을 누릅니다.

오른쪽 영역에 다음과 같은 기준선 정보가 표시됩니다.

  • 기준선 ID

  • 기준선 이름

  • 시작 스냅숏 ID

  • 끝 스냅숏 ID

  • 시작 스냅숏 시간

  • 끝 스냅숏 시간

관련 항목

ADDM/AWR

ADDM/AWR Create New Snapshot

ADDM/AWR Drop Snapshot Range

ADDM/AWR Snapshot Management

ADDM/AWR View Snapshot Statistics


기준선 작성

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

ADDM/AWR 창에서 스냅숏의 새 기준선 범위를 쉽게 작성할 수 있습니다.

기준선을 작성하면 기준선 ID, 시작 스냅숏 시간 및 끝 스냅숏 시간이 자동으로 설정됩니다.

새 기준선을 작성하려면

  1. ADDM/AWR 창에서 Baseline Management 탭을 누릅니다.

  2. Create New Baseline [image] 단추를 누릅니다.

  3. Baseline Name 상자에 기준선의 이름을 입력합니다.

  4. 시작 스냅숏 ID를 입력하거나 드릴다운 [image] 단추를 누르고 Data Select 대화 상자에서 하나를 선택합니다.

  5. 끝 스냅숏 ID를 입력하거나 드릴다운 [image] 단추를 누르고 Data Select 대화 상자에서 하나를 선택합니다.

  6. OK를 누릅니다.

관련 항목

ADDM/AWR

Baseline Manager

기준선 삭제


기준선 삭제

주: 이 Toad 기능은 Professional Edition이거나 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Baseline Management 탭에서 기준선을 쉽게 삭제할 수 있습니다.

기준선을 삭제하려면

  1. Baselines 탐색기 패널에서 삭제할 기준선을 선택합니다.

  2. Drop baseline [image] 단추를 누릅니다.

  3. 다음 옵션을 선택할 수 있습니다.

Drop Baseline only

또는

Drop Baseline and all Associated Snapshots

두 옵션 중 하나를 선택합니다.

주: 연관된 모든 스냅숏을 삭제하면 다른 기준선에 영향을 줄 수 있습니다.

  4. 확인을 누릅니다.

관련 항목

Baseline Manager

기준선 만들기


Database Browser

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

이 창을 사용하면 여러 스키마 또는 서버의 정보를 볼 수 있습니다. 여러 스키마 또는 서버를 선택하고 다양한 요약 정보를 보거나, ping 및 tnsping을 수행하거나, 일반 Toad 창을 열 수 있습니다.

주: 이 기능에는 일부 V$ 동의어가 필요합니다. 자세한 내용은 Configuration|V$ Tables Required|Database Browser를 참조하십시오.

Database 메뉴|Monitor|Database Browser를 선택하여 이 창에 액세스합니다.

트리 보기

트리 보기의 왼쪽은 처음에 tnsnames 파일에서 작성된 후 Toad 디렉토리에 있는 DatabaseBrowser.tdb라는 파일에 저장됩니다. 트리를 더 관리하기 쉽게 하기 위해 서버와 스키마 노드를 추가 또는 삭제할 수 있습니다. 노드를 선택하고 마우스 오른쪽 단추로 누른 후 Properties를 선택하여 개별 노드의 속성을 설정할 수도 있습니다. 노드에서 다음 작업을 수행할 수도 있습니다.

  • 연결

  • 연결 끊기

  • 스키마와 연결(스키마 노드에만 해당)

  • 이름 변경

  • 제거

  • 기본 스키마를 포함하고 자동 연결을 선택하면서 속성 보기 및 수정

이 작업은 여러 노드에서 동시에 수행할 수 있습니다. 예를 들어 여러 노드를 선택한 후 Connect를 선택하면 여러 노드에 연결할 수 있습니다. 서버 노드에 있는 동안 Connect를 선택하면 그 서버 아래의 모든 데이터베이스 노드에 대해 연결이 작성됩니다.

요약 정보

트리 보기에서 노드 또는 노드 그룹을 선택합니다. 그러면 창의 오른쪽에 선택한 연결의 요약 정보가 표시됩니다.

경우에 따라 모든 데이터베이스 또는 서버의 "롤업" 정보를 한꺼번에 가져올 수도 있으며 예를 들면 다음과 같습니다.

  • Space Usage 탭에는 Megs Allocated, Used 등의 합계가 표시됩니다.

  • Datafile IO 탭에는선택한 모든 데이터베이스의 Total IO 값이 표시됩니다.

다음과 같은 탭을 사용하여 요약 정보에 액세스할 수 있습니다.

  • Overview

  • Instance

  • Database

  • Options

  • Parameters

  • Sessions

  • Top Sessions

  • Datafile IO

  • RBS Activity

  • Space Usage

Instance 및 Database 탭에는 단일 레코드 보기와 그리드 보기의 두 가지 보기가 있습니다. 표시되는 열 수 때문에 이 탭에서는 단일 레코드 보기가 유용합니다.

Top Sessions 탭의 맨 아래에는 SQL 탭이 있습니다. 이 탭을 사용하면 Grid 탭에서 선택한 현재 레코드의 서식이 지정된 SQL 문 전체를 볼 수 있습니다.


Database Browser 도구 모음

Database Browser 도구 모음을 사용하면 관련된 여러 Toad 기능에 쉽게 액세스할 수 있습니다.

단추 | 명령
 | 새 서버
 | 새 데이터베이스
 | 데이터 새로 변경
 | 선택한 개체에서 Ping 또는 TNS Ping 수행
 | 선택한 데이터베이스의 Schema Browser 열기
 | 선택한 데이터베이스의 Editor 열기
 | 개체 찾기
 | Server Side Object 마법사 열기
 | Database Health check 열기
 | Database Monitor 열기


Toad Database Monitor

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Database|Monitor|Database Monitor 메뉴 항목을 선택하면 이 창이 나타납니다.

DatabaseMonitor를 사용하면 Logical IO, Physical IO, Event Waits, Sessions, Call Rates, Miss Rates, SGA Memory Usage, Shared Pool 및 Indexed Queries %의 아홉 개 차트로 데이터베이스 성능을 모니터할 수 있습니다. 가로 스크롤 막대를 사용하면 차트를 모두 볼 수 있습니다.

DatabaseMonitor가 작동하려면 이 프로그램을 실행해야 합니다. 따라서 아침에 프로그램을 실행하고 창을 최소화해 두면 나중에 임계값을 넘었을 때 경고를 받을 수 있습니다.

주: 이 옵션을 사용하려면 일부 V$ 테이블에 대한 액세스 권한이 필요합니다. 이러한 사용 권한 목록을 보려면 Database Monitor를 참조하십시오.

RAC 연결

Database Monitor 내에서 모든 정보는 하나의 연결에 따라서 제공됩니다. 하지만 이것은 RAC 클러스터를 구성하는 모든 인스턴스에 대해 요약되거나 집계됩니다. 예를 들어 SGA 메모리를 보면, 만약 각 RAC 인스턴스가 150MB이고 두 개의 RAC 인스턴스를 가지고 있다면 해당 열은 300MB로 표시됩니다.

SYS 보기 경고

Database Monitor에 처음 로그인할 때, "SYS view, X_$KSLLT" 보기가 없다는 내용의 경고 대화상자를 볼 수 있습니다. 이 보기가 없으면 Miss Rates에서 Latch Series는 0이 됩니다.

  • 이 대화 상자가 나타나면 왼쪽 아래 부분에서 "Don’t show this message again" 확인란을 선택할 수 있고 그러면 다음부터는 표시되지 않습니다. Latch Series에 관한 데이터를 얻으려면 SYS로 연결하고 다음 SQL을 실행합니다.

CREATE OR REPLACE VIEW x_$ksllt AS SELECT * FROM x$ksllt;

GRANT SELECT ON sys.x_$ksllt TO PUBLIC;

  • Database Monitor를 계속 사용하려면 Close를 클릭합니다.

Monitor 옵션 설정

View|Toad Options|Monitors 페이지에서 다양한 임계값과 경고를 설정할 수 있습니다.

시리즈 목록에 있는 각 항목은 그래프의 한 줄에 해당됩니다. 최소 및 최대 임계값을 입력할 수 있습니다.

확대/축소

그래프를 확대하고 스크롤할 수 있습니다.

그래프를 확대/축소하려면

  • 원하는 그래프를 마우스 오른쪽 단추로 누르고 Zoom을 선택합니다. 그래프가 새 창에 나타납니다. 이 창을 스크롤하여 그래프의 더 많은 부분을 볼 수 있습니다.

인쇄

Monitor에서 그래프를 인쇄할 수 있습니다.

그래프를 인쇄하려면

  • 인쇄할 그래프를 마우스 오른쪽 단추로 누르고 Print를 선택합니다. 작업이 자동으로 프린터로 전송됩니다.

저장

그래프는 다음 세 가지 형식 중 하나로 저장할 수 있습니다.

  • XLS

  • HTML

  • Bitmap

그래프를 저장하려면

  1. 저장할 그래프를 마우스 오른쪽 단추로 누르고 Save를 선택합니다.

마우스 오른쪽 단추로 누른 차트가 선택됩니다.

  2. 파일의 형식을 선택합니다.

  3. 그래프의 파일 이름을 입력하거나 기본값을 사용합니다.

  4. OK를 누릅니다.


Database Monitor 도구 모음

Database Monitor 도구 모음은 Database Monitor 전체의 기능을 쉽게 사용할 수 있는 위치를 제공합니다.

아이콘 | 명령
 | 활성 세션 변경
 | 캐시 플러시
 | 옵션
 | 데이터 새로 변경
 | 경고
 | 차트 저장
Instance | RAC 인스턴스에 연결된 경우에는 이 드롭다운 메뉴를 사용하여 모니터할 인스턴스를 선택합니다.


Database Monitor 전자 메일 경고

전송된 경고를 볼 수 있습니다.

전자 메일 경고를 보려면

  1. Alerts 단추를 누릅니다. 모니터를 열거나 창을 마지막으로 지운 후에 발생한 모든 경고 목록이 Alerts 창에 표시됩니다.

창의 맨 아래에 전송된 모든 전자 메일의 통지가 표시됩니다.

  2. Clear를 눌러 경고를 지우거나 Close를 눌러 창을 닫습니다.

또한 경고 사용 여부를 선택할 수도 있습니다. 전자 메일 경고를 활성화한 경우에는 View|Options| Email 창에서 전자 메일 옵션을 설정해야 합니다.


SGA 캐시 플러시

SGA 또는 버퍼 캐시 플러시

SGA 또는 버퍼 캐시를 쉽게 플러시할 수 있습니다.

  • Flush cache 드롭다운 [image] 단추를 누르고 Flush SGA 또는 Flush Buffer Cache(Oracle 10g에만 해당)를 선택합니다.


Database Monitor 옵션

Refresh rate

그래프 및 모니터를 새로 고치는 간격은 조정할 수 있습니다.

  • 드롭다운 Refresh rate 메뉴에서 적절한 간격을 선택합니다. auto refresh 확인란을 선택하면 선택한 간격으로 창을 자동으로 새로 고칩니다.

Refresh 단추를 눌러 수동으로 창을 새로 고칠 수도 있습니다.

Window

Window 상자를 사용하면 그래프에 표시할 그래프 데이터의 양을 지정할 수 있습니다. 1시간, 2시간, 6시간 및 24시간이 옵션이 포함됩니다.

주: 확대/축소 정도는 선택한 값의 두 배입니다.

TNS Ping 확인란

이 확인란을 선택하면 Toad에서 질의를 실행하여 차트에 있는 데이터를 새로 고치기 전에 Oracle 서버를 ping합니다(TNS ping 사용).

Ping 확인란

이 확인란을 선택하면 Toad에서 질의를 실행하기 전에 Oracle 서버에 대한 TCP/IP ping을 수행합니다.


Database Probe 개요

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Toad Database Probe는 다양한 경고를 제공하는 실시간 모니터링 창입니다. 경고를 직접 작성할 수도 있습니다.

Database Probe는 열 때 자동으로 완전히 새로 고쳐지지 않습니다. 새로 고치려면 Probe 설정을 변경합니다.

Database Probe에 액세스하려면

  • Database 메뉴에서 Monitor|Database Probe를 선택합니다.

주: 이 기능에는 일부 V$ 동의어가 필요합니다. 자세한 내용은 Configuration|V$ Tables Required|Database Probe를 참조하십시오.

Probe 창은 다섯 개의 영역 또는 디스플레이 컨트롤 모음으로 나뉩니다. 이 영역은 창의 배치와 대체로 일치합니다. 설정 항목을 참조하십시오.

Database Probe에는 자체 도구 모음과 상태 표시줄이 있습니다. 경고가 테스트되고 발생하며, 화면의 해당 영역을 아이콘을 표시하는 위치로 선택한 경우 각 데이터 컨트롤의 왼쪽에 경고 [image] 아이콘이 나타날 수 있습니다.

경고가 발생하여 경고 아이콘이 나타나면 아이콘을 눌러 경고에 관한 세부 정보가 포함된 대화 상자를 표시합니다. 이 대화 상자에는 경고의 이름이 표시된 그룹 상자 캡션이 있습니다. 세부 정보 창에는 경고 설명이 표시됩니다. 세부 정보 창 아래에는 경고 식 표시가 있으며 확인란을 통해 이 점의 경고를 끌 수 있습니다.

Database Probe 경고의 정의 및 옵션은 "DatabaseProbe.INI"라는 INI 파일에 보관됩니다.

Probe 정보 읽기

경고에 대해 데이터베이스에서 수집되는 정보는 다음과 같이 표시됩니다.

  • 표시되는 정보는 표준 Oracle 통계를 반영합니다. Database Probe의 영역이 나타내는 것에 대한 자세한 내용은 Oracle 설명서를 참조하십시오.

  • Number/number로 표시된 결과는 사용/최대 값을 나타냅니다.

  • 예를 들어 2/170은 170개 세션을 사용할 수 있는데 총 2개가 사용 중임을 나타냅니다.

  • - NULL 값 또는 "invalid for the current connection version"을 나타냅니다.

정의 및 옵션 업그레이드

Database Probe 경고의 정의 및 옵션은 "DatabaseProbe.INI"라는 INI 파일에 보관됩니다.

Toad의 이후 업그레이드에 업데이트된 DatabaseProbe.ini 파일도 포함되어 있을 수 있습니다. 경고를 변경한 경우에는 별도 파일에 백업해 두는 것이 좋을 수도 있습니다. 새 DatabaseProbe.ini가 제공되면 파일을 비교하고(Compare Files 참조) 새 ini 파일에서 경고에 포함할 부분만 추가합니다.


Database Probe 도구 모음 및 상태 표시줄

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

도구 모음

아이콘 | 명령
 | 활성 연결에 대한 Quest Spotlight(설치되어 있는 경우)를 엽니다.
 | 다른 세션을 선택합니다.
 | 5개의 모든 영역을 새로 고치고 새로 고침 타이머를 다시 설정합니다. 드롭다운에는 각 영역의 목록이 제공됩니다. 개별 영역을 선택하면 해당 영역만 새로 고쳐집니다.
 | Flush SGA 또는 Flush Buffer Cache(Oracle 10g만 해당)입니다.
 | Settings 대화 상자를 표시합니다.

상태 표시줄

상태 표시줄에는 영역 새로 고침 도중에 질의가 실행될 때 질의 이름이 표시됩니다. 또한 활성 창 연결에 대한 연결 문자열이 표시됩니다.


Database Probe 설정

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Database Probe의 Settings 대화 상자에서 Database Probe에 대한 여러 유형의 설정을 변경할 수 있습니다. 여기에는 새로 고침 빈도, 경고 및 여러 기타 설정이 포함됩니다.

Refreshes

Settings 대화 상자의 Refresh 탭을 사용하면 각 영역에 대한 별개의 새로 고침 빈도를 설정하거나 새로 고침이 없도록 설정할 수 있습니다. 사용 가능한 새로 고침 빈도는 15초, 30초, 1분, 5분 및 15분입니다.

사용 가능한 영역은 다음과 같습니다.

  • Sessions, processes, PGA, block gets/mods, efficiency

  • SGA

주: SGA 영역의 Lock 확인란은 Windows가 아닌 서버에서만 적용될 수 있습니다.

  • DBWR, LGWR, ARCH, Phys reads/writes

  • Files

  • Overhead

Active Alerts 열은 관계 영역에 대한 활성 경고 수를 표시합니다. 경고는 활성 또는 비활성일 수 있습니다. 활성 경고만 영역 새로 고침의 성능에 영향을 줄 수 있습니다.

Perform a full refresh upon opening

Database Probe를 열었을 때 새로 고침을 강제하려면 이 상자를 선택합니다. 이 상자는 기본적으로 선택되어 있지 않습니다.

Alerts

Settings 대화 상자의 Alerts 탭은 다음을 포함하여 현재 Probe에 있는 모든 경고를 표시합니다.

  • 이름

  • 설명

  • 활성 또는 비활성(관련 영역 새로 고침 도중에 활성 경고만 테스트됨)

경고는 사용자 정의 이벤트입니다. 경고는 주 창에서 데이터를 읽고 표시 아이콘으로 경고를 나타냅니다. 경고는 수식을 나타내는 식으로 구성됩니다. 그런 다음 경고를 발생시킬지 결정하기 위해 수식이 사용됩니다.

예를 들어 활성 세션 수가 총 세션 수와 일치할 경우 경고를 발생시킬 수 있습니다. 경고는 비활성 상태일 수 있는데 비활성 경고는 피연산자를 새로 고칠 때 테스트되지 않습니다. 경고는 테스트되거나 발생하거나 소멸할 수 있습니다.

경고를 추가하거나 선택한 경고를 편집 또는 삭제하거나 개별적으로 또는 한 번에 모두 활성화 또는 비활성화할 수 있습니다.

Active 열에서 확인란을 눌러 경고를 활성화하거나 비활성화합니다. 또는 경고 그리드의 오른쪽에서 Activate All 또는 Deactivate All 단추를 누릅니다.

테스트됨

경고에 사용되는 피연산자에서 새로 고침이 발생하면 해당 피연산자에 대한 경고가 테스트됩니다. 이는 경고 식이 평가된다는 것을 의미합니다.

평가는 식의 피연산자 식별자가 해당 화면 데이터 값으로 대체되고 식에 포함된 모든 질의가 실행되어 결과 값이 대체되는 과정으로 구성됩니다.

  • 결과 식이 TRUE로 평가되면 경고가 발생합니다.

  • 결과 식이 FALSE로 평가되면 경고가 소멸합니다.

발생함

경고가 테스트되어 TRUE로 평가되면 경고가 발생합니다. 경고가 발생할 경우 해당 경고 표시 아이콘을 볼 수 있게 됩니다.

소멸함

경고가 테스트되어 FALSE로 평가되면 경고가 소멸합니다. 경고가 소멸하면 해당 경고 아이콘이 숨겨집니다.

경고 맵

Show Map 단추를 눌러 경고 맵을 확인할 수 있습니다.

경고 맵은 주 창에서 연관된 경고가 있는 피연산자를를 볼 수 있는 편리한 방법입니다. 커서가 경고 아이콘 위로 이동하면 해당 경고 식이 힌트 텍스트로 표시됩니다.

Misc

Misc 탭을 눌러 게이지 색(두 개의 막대 그래프)과 경고 수준을 설정할 수 있습니다.


경고 추가 및 편집

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

경고를 추가하려면

  1. Database Probe 창에서 도구 모음의 Settings [image] 단추를 누릅니다.

  2. Alerts 탭을 누릅니다.

  3. Add를 누릅니다. 아래 설명된 대로 대화 상자에 정보를 입력하여 경고를 만듭니다.

일반 영역

Name

경고 이름을 입력합니다. 이 이름을 Settings 대화 상자의 Alerts 그리드 내에서 표시 목적을 위해 경고의 이름을 식별하는 데 사용됩니다. 경고 이름은 고유해야 합니다.

Active

관련 영역 새로 고침 도중에 경고가 테스트되는지 여부를 결정합니다.

Alert position

경고가 발생할 때 화면에 표시되는 아이콘의 위치입니다. 가능한 위치의 드롭다운 목록이 제공됩니다. 또는 다음과 같이 그래픽 표시에서 선택할 수 있습니다.

  • 드릴다운 [image] 단추를 눌러 Alert Icon Selection 창에 액세스합니다. 이 창은 주 probe 창과 비슷하지만 사용 가능한 모든 경고 아이콘이 표시됩니다.

  • 사용할 아이콘 위치 중 하나를 누릅니다. 이미 선택한 위치가 있을 경우 해당 위치가 깜박입니다.

아이콘을 누르면 이 대화 상자가 닫히고 Alert position 드롭다운에서 해당 아이콘의 이름이 선택됩니다.

주: 사용하지 않는 경고 위치 또는 비활성 경고 위치만 선택할 수 있습니다.

Description

경고에 대한 설명을 입력합니다.

Refreshes before computing

각 경고는 하나 이상의 영역과 연관됩니다. 경고와 연관된 영역은 Alert Expression에서 사용되는 Probe 피연산자에 의해 결정됩니다. 경고가 둘 이상의 영역과 연관된 경우 가장 빠른 새로 고침 속도를 가진 영역에서 경고가 발생하는 시점을 결정합니다. 이 값은 경고가 테스트되기 전에 해당 영역의 실제 새로 고침이 발생해야 하는 횟수를 결정합니다.

예를 들어 경고가 하나의 영역과 연관되어 있습니다. 이 영역은 15초마다 새로 고쳐지는데 매번 테스트할 경우 새로 고침이 느려질 수 있기 때문에 사용자는 매번 경고를 테스트하지 않을 것입니다. 이 경우에는 2분마다 경고를 테스트하는 것이 더 유용하므로 여기에서 8을 입력합니다.

Expression Builder

식을 통해 경고가 작동합니다. 즉, 식은 경고를 테스트할 때 테스트해야 하는 사항을 Toad에 지시합니다.

경고 식은 하나 이상의 Probe 피연산자, 하나 이상의 질의(큰따옴표로 묶어야 함) 및 나열된 연산자로 구성됩니다. 식의 중앙에 있는 관계형 연산자는 평가가 true인지 확인하기 위해 서로에 대해 식의 양쪽이 비교되는 방법을 결정합니다.

  • 식의 각 피연산자, 질의 및 연산자는 공백으로 구분되어야 합니다.

  • 질의 SELECT 문은 큰따옴표로 묶어야 하고 첫 번째 필드에서 반드시 숫자 값을 반환해야 합니다. 그런 다음 이 값은 식에서 대체 값으로 사용됩니다. "Mismatched Redo Log Size"라는 제공된 경고를 예로 들 수 있습니다.".

Expression Builder를 사용하려면 하나 이상의 Probe 피연산자를 트리 보기서 식의 왼쪽 및/또는 오른쪽으로 끌어서 놓습니다. 피연산자는 영역별로 그룹화됩니다. 연산자를 끌어서 놓거나 직접 입력할 수도 있습니다.

마지막으로 관계형 연산자를 선택합니다. 수학 식 계산기가 수학 형식으로 문자열 식을 반환할 수 있는지 확인하기 위해 Test를 눌러 식을 테스트합니다.


Index Monitoring

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Oracle 버전 9i 이상에서는 인덱스가 사용되고 있는지 여부를 확인하기 위해 인덱스를 모니터링하는 수단을 제공합니다. 따라서 사용하지 않는 인덱스를 삭제하여 불필요한 문 오버헤드를 없앨 수 있습니다.

모니터링 상태, 시작 시간, 종료 시간, 사용량과 같은 정보를 Index Monitoring 그리드에서 사용할 수 있습니다. 모니터링을 활성화할 때마다 Toad에서는 지정된 인덱스에 대해 이러한 상태를 다시 설정합니다.

자신의 인덱스는 항상 볼 수 있습니다. 다른 사용자의 인덱스를 보려면 SYS.OB$, SYS.IND$, SYS.USERS$ 및 SYS.OBJECT_USAGE 보기에 대한 액세스 권한과 ALTER ANY INDEX 권한이 있어야 합니다.

Index Monitoring 도구 모음

단추 | 명령
 | 인덱스를 모니터링합니다. 모든 인덱스를 모니터링할지 아니면 선택한 인덱스를 모니터링할지 선택합니다.
 | 인덱스 모니터링을 끝냅니다. 모든 인덱스를 끝낼지 아니면 선택한 인덱스를 끝낼지 선택합니다.
 | 선택한 인덱스에 대한 작성 스크립트를 표시합니다.
 | 선택한 인덱스를 삭제합니다.
 | 그리드 데이터를 새로 고칩니다.
Indexes Owned By | 보려는 인덱스를 소유한 스키마를 선택합니다.


Index Monitoring 활성화

모든 색인을 모니터할 수도 있고 선택한 색인만 모니터할 수도 있습니다.

모든 색인을 모니터하려면

  1. Database 메뉴에서 Monitor|Index Monitoring을 선택합니다.

  2. Indexes Owned By 드롭다운 메뉴에서 스키마를 선택합니다.

  3. Begin Index Monitoring [image] 드롭다운을 누르고 Begin monitoring all indexes를 선택합니다.

선택한 색인을 모니터하려면

  1. Database 메뉴에서 Monitor|Index Monitoring을 선택합니다.

  2. Indexes Owned By 드롭다운 메뉴에서 스키마를 선택합니다.

  3. 데이터 그리드에서 색인을 하나 이상 선택합니다.

  4. Begin Index Monitoring [image] 드롭다운을 누르고 Begin monitoring selected indexes only를 선택합니다.


인덱스 모니터링 비활성화

특정 기간 동안 모니터링이 완료되었으면 인덱스 모니터링을 해제할 수 있습니다.

모든 인덱스에서 인덱스 모니터링을 비활성화하려면

  1. Database 메뉴에서 Monitor|Index Monitoring을 선택합니다.

  2. Indexes Owned By 드롭다운 메뉴에서 스키마를 선택합니다.

  3. End Index Monitoring [image] 드롭다운을 누르고 End monitoring all indexes를 선택합니다.

선택한 인덱스에서 인덱스 모니터링을 비활성화하려면

  1. DBA 메뉴에서 Index Monitoring을 선택합니다.

  2. Indexes Owned By 드롭다운 메뉴에서 스키마를 선택합니다.

  3. 데이터 그리드에서 하나 이상의 인덱스를 선택합니다.

  4. End Index Monitoring [image] 드롭다운을 누르고 End monitoring selected indexes only를 선택합니다.


Instance Manager

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Instance Manager는 사용자가 액세스할 수 있는 다양한 데이터베이스의 상태를 검사할 수 있도록 디자인되었습니다.

주 창에서는 아래 설명된 대로 Instance Manager에 대한 일반 옵션을 변경할 수 있습니다. 전자 메일 경고 옵션을 포함한 추가 옵션을 Toad Options|Instance Manager 창에서 볼 수 있습니다.

Instance Manager에 액세스하려면

  • Database 메뉴에서 Monitor|Instance Manager를 선택합니다.

Refresh Rate

데이터를 자동으로 새로 고칠 적절한 시간 프레임을 선택합니다. Auto refresh data 확인란을 선택하지 않을 경우 데이터가 새로 고쳐지지 않기 때문에 여기에서 선택한 값이 적용되지 않습니다.

Auto refresh data

이 옵션을 선택할 경우 Refresh Rate 드롭다운에서 설정한 빈도에 따라 데이터가 자동으로 새로 고쳐집니다. 선택하지 않을 경우 데이터를 수동으로 새로 고쳐야 합니다.

Polling Priority

이 드롭다운에서 선택한 운영 체제 우선 순위가 데이터베이스를 순환하는 스레드에 할당됩니다. Idle을 선택할 경우 스레드는 시스템이 유휴 상태일 때만 실행됩니다. Windows에서 다른 스레드를 중단하지 않습니다.

Refresh 단추

자동 새로 고침 전에 데이터베이스에 대한 정보를 새로 고치려면 이 단추를 누릅니다. 또는 자동 새로 고침을 선택하지 않은 경우 이와 무관하게 데이터를 새로 고치려면 Refresh를 누릅니다.

탭

이외에도 상태를 보기 위한 세 가지 탭이 있습니다.

Status 탭에는 Node, Listener 및 Database의 상태가 표시됩니다. 자세한 내용은 Instance Manager - Status 탭을 참조하십시오.

Status change history에는 데이터베이스에 대한 모든 변경 내용이 그리드 형식으로 표시됩니다.

Detail log에는 Server Manager 또는 SQL의 모든 보고서가 표시됩니다.

단추

Status 탭의 아래에 있는 단추를 사용하여 데이터베이스를 시작하거나 데이터베이스를 종료하거나 데이터베이스 상태를 변경할 수 있습니다.

주: 종료/시작할 데이터베이스에는 암호 파일이 필요하고 remote_login_passwordfile=EXCLUSIVE가 pfile(일반적으로 INIT.ORA 또는 INIT<sid>.ORA)에 설정되어 있어야 합니다. New Database 마법사를 사용하여 데이터베이스를 만든 경우 이 파일이 이미 작성되어 있습니다. 다른 방법으로 데이터베이스를 만든 경우 암호 파일이 올바르게 설정되었는지 확인해야 합니다.

또한 다음을 수행할 수 있습니다.

  • Build init.ora... - 이 단추는 현재 선택한 사용자 이름에 대한 init.ora 파일을 작성합니다.

  • Refresh current - 이 단추는 현재 연결 표시를 수동으로 새로 고칩니다.

관련 항목

Instance Manager - Alter

Instance Manager - Shutdown

Instance Manager - Startup

Instance Manager - Status 탭


Instance Manager - Status 탭

Instance Manager - Status Tab

Instance Manager의 Status 탭은 데이터베이스의 상태를 표시합니다.

데이터 상태

Toad에서는 수신기, 노드 및 데이터베이스를 ping하여 다음과 같은 결과를 표시합니다.

아이콘

의미

알 수 없습니다. Toad에서 상태를 확인할 수 없습니다. 예를 들어 데이터베이스 연결 정보가 지정되지 않았으며 Instance Manager에서 데이터베이스의 상태를 테스트할 수 없습니다.

연결할 수 없습니다.

  • 데이터베이스: Oracle 테스트 연결에 실패했습니다.

  • 수신기: tns ping에서 응답을 반환하지 않았습니다.

  • 노드: 서버를 ping할 수 없습니다.

연결되었습니다.

  • 데이터베이스: 데이터베이스가 시작 및 탑재되고 열렸습니다.

  • 수신기: tns ping이 성공적으로 ping했으며 수신기가 작동합니다.

  • 노드: 서버가 성공적으로 ping했으며 노드가 작동합니다.

시작되었습니다. 데이터베이스가 시작되었지만 탑재되거나 열리지 않은 경우에만 이 확인란이 Database 열에 표시됩니다.

탑재되었습니다. 데이터베이스가 시작 및 탑재되었지만 열리지 않은 경우에만 이 확인란이 Database 열에 표시됩니다.

컴퓨터에서 액세스할 수 있는 다양한 데이터베이스 연결 중 하나를 선택하고 인스턴스를 검사하기 위한 시작, 종료 또는 변경 정보를 조정할 수 있습니다.

데이터베이스 검사

특정 데이터베이스에 대한 정보를 검색하려면 해당 데이터베이스에 대한 로그인 정보를 입력해야 합니다. Toad에서는 이 정보를 사용하여 데이터베이스가 작동하는지 검사합니다. 그런 다음 연결이 즉시 닫힙니다.

로그인 정보를 입력하려면

  1. 해당 데이터베이스에 대한 logon info for database test 상자를 누릅니다. 이전 로그인 정보와 함께 드롭다운 메뉴가 나타납니다.

  2. 이전 연결 중 하나를 선택하거나 New를 선택합니다.

  3. New를 선택한 경우 New connection 대화 상자가 나타납니다. Username 및 Password 상자에 적절한 정보를 입력한 다음 OK를 누릅니다. 대화 상자가 닫히고 상자에 연결이 입력됩니다.

  4. Refresh를 눌러 Instance Manager에서 데이터베이스를 즉시 검사하게 합니다.

관련 항목

Instance Manager

Instance Manager - Alter

Instance Manager - Shutdown

Instance Manager - Startup


Instance Manager - Startup

Instance Manager – Startup

Instance Manager에서 여러 다른 모드로 데이터베이스를 시작할 수 있습니다. 그러나 Instance Manager가 SQL*Plus를 사용하여 데이터베이스를 시작 및 종료한다는 것에 주의합니다.

주의: 이러한 이유 때문에 Oracle 8i 이상 클라이언트에서 Oracle 7 데이터베이스를 시작할 수 없습니다. 이는 Oracle 8i 이상 클라이언트에서 데이터베이스를 시작 및 종료하기 위해 SQL*Plus가 사용되지만 SQL*Plus가 Oracle 7 서버를 시작하거나 종료할 수 없기 때문입니다.

데이터베이스를 시작하려면

  1. Instance Manager의 Status 탭에서 원하는 서버/데이터베이스를 선택합니다.

  2. Startup을 누릅니다.

  3. SYSDBA 또는 SYSOPER로 연결할 수 있는 username 및 password를 입력합니다.

주: View|Toad Options|Oracle|Save passwords for Oracle connections를 선택한 경우에만 암호가 저장됩니다.

  4. 드롭다운에서 SYSDBA 또는 SYSOPER를 선택합니다.

  5. 사용할 시작 옵션을 선택합니다. 아래에서 예를 참조하십시오.

  6. 사용할 매개 변수 파일의 전체 경로 이름을 입력하거나 찾아보기를 누르고 찾아보기 창에서 선택합니다.

주: Toad에서 이 데이터베이스를 종료한 경우 Toad 디렉토리에 매개 변수 파일에 저장되어 있습니다. 이 파일은 데이터베이스를 다시 시작할 때의 기본 경로 이름입니다.

  7. OK를 누릅니다. 데이터베이스가 시작됩니다.

시작 옵션

Open

데이터베이스를 완전히 열려면 Open을 선택합니다. 이 선택은 표준 선택이며 권한이 부여된 모든 사용자가 로그인하여 데이터베이스를 사용할 수 있습니다.

Mount

데이터베이스를 탑재하지만 실제로는 열지 않으려면 Mount를 선택합니다. Mount를 선택하면 데이터베이스를 완전히 열었을 때 수행할 수 없는 몇 가지 기본 Oralce 변경을 수행할 수 있습니다.

Nomount

데이터베이스를 시작된 모드로 전환하려면 Nomount를 선택합니다.

Force

이미 실행 중인 데이터베이스 인스턴스를 시작하려고 하면 명령에서 오류가 발생합니다. 그러나 디버깅 도중이나 비정상적인 환경과 같은 경우에는 데이터베이스를 다시 시작하기를 원할 수 있습니다.

이렇게 하려면 Force 상자를 선택합니다. 이 상자를 선택하면 종료 모드 Abort를 사용하여 현재 Oracle 인스턴스를 종료합니다. 그런 다음 Toad에서는 시작 프로시저를 계속합니다.

Exclusive

Exclusive를 선택한 경우 현재 인스턴스에서만 데이터베이스를 탑재하고 열 수 있습니다. 여러 인스턴스에서 데이터베이스를 동시에 열 수 없습니다. Exclusive는 SHARED, PARALLEL 또는 NOMOUNT와 함께 사용할 수 없습니다.

지정된 탑재 옵션이 없을 경우 EXCLUSIVE가 기본적으로 할당됩니다.

선택하지 않을 경우 여러 인스턴스에서 데이터베이스를 동시에 열 수 있으므로 SHARED, PARALLEL 및 NOMOUNT가 가능해집니다.

관련 항목

Instance Manager

Instance Manager - Alter

Instance Manager - Shutdown

Instance Manager - Status 탭


Instance Manager - Shutdown

데이터베이스를 종료하려면 SYSDBA 또는 SYSOPER 권한이 있어야 합니다. 그러나 Instance Manager가 SQL*Plus를 사용하여 데이터베이스를 시작 및 종료한다는 것에 주의합니다.

주의: 이러한 이유 때문에 Oracle 8i 이상 클라이언트에서 Oracle 7 데이터베이스를 종료할 수 없습니다. 이는 Oracle 8i 이상 클라이언트에서 데이터베이스를 시작 및 종료하기 위해 SQL*Plus가 사용되지만 SQL*Plus가 Oracle 7 서버를 시작하거나 종료할 수 없기 때문입니다.

주: 이 옵션을 사용하려면 일부 V$ 테이블에 대한 액세스 권한이 필요합니다. 이러한 사용 권한 목록을 보려면 Instance Manager Shutdown를 참조하십시오.

데이터베이스를 종료하려면

  1. Status 탭에서 종료할 데이터베이스를 선택한 다음 Shutdown을 누릅니다.

  2. 해당 상자에 사용자 이름 및 암호를 입력하고 드롭다운 메뉴에서 SYSDBA 또는 SYSOPER를 선택합니다.

주: View|Toad Options|Oracle|Save passwords for Oracle connections를 선택한 경우에만 암호가 저장됩니다.

  3. 데이터베이스를 종료하는 데 사용할 Oracle 모드로 Normal, Immediate 또는 Abort를 선택합니다.

  4. OK를 누릅니다. 대화 상자가 닫히고 데이터베이스가 종료됩니다. 이 작업이 발생할 때 Instance Manager 창의 오른쪽 하단 모서리에 있는 상태 줄에 해당 내용이 표시됩니다.

데이터베이스가 종료되면 Status change 목록에 항목이 작성되고 Server Manager 또는 SQL 보고서가 Detail Log에 추가됩니다.

데이터베이스를 종료할 경우 Toad 디렉토리에 DBA라는 폴더가 만들어집니다. 이 폴더에는 기본 매개 변수가 아닌 매개 변수에 대한 .ora 파일이 저장됩니다. 또한 startupshutdownlog.txt라는 파일이 만들어지고 Detail 탭의 내용이 포함됩니다.

Instance Manager는 종료를 수행할 때 v$parameter 테이블을 질의하여 후속 시작을 위한 INIT.ORA 파일을 작성합니다. 이 파일은 Toad\DBA에 저장되며 pfile_SID.ora(여기서 SID는 데이터베이스 별칭)라는 이름이 지정됩니다. 이 질의를 수행하기 위해 "shutdown" 대화 상자에서 제공된 종료 연결 정보를 사용하여 임시 데이터베이스 연결이 만들어집니다.

주: 7.3.4 클라이언트에서 데이터베이스가 아직 열려 있지 않은 경우, 즉 분리되거나 탑재된 경우 이 SYSDBA/SYSOPER 임시 연결이 지원되지 않습니다. 따라서 7.3.4 클라이언트에서는 열리지 않은 데이터베이스를 종료할 수 없습니다. 그러나 ALTER 작업은 Server Manager만 사용하고 이 임시 데이터베이스 연결을 작성하려고 시도하지 않으므로 이 작업은 계속 작동합니다.

관련 항목

Instance Manager

Instance Manager - Alter

Instance Manager - Startup

Instance Manager - Status 탭


Instance Manager - Alter

Instance Manager에서 Alter 명령을 사용하면 선택한 데이터베이스의 상태를 변경할 수 있습니다.

데이터베이스의 상태를 변경하려면 SYSDBA 또는 SYSOPER 권한이 있어야 합니다.

Alter 명령을 사용하려면

  1. Status 탭에서 상태를 변경할 데이터베이스를 선택한 다음 Alter를 누릅니다.

  2. 해당 상자에 사용자 이름 및 암호를 입력하고 드롭다운 메뉴에서 SYSDBA 또는 SYSOPER를 선택합니다.

주: View > Options> Oracle > Save passwords for Oracle connections를 선택한 경우에만 암호가 저장됩니다.

  3. 데이터베이스에서 수행할 작업을 선택합니다. 데이터베이스의 Mount 또는 Open을 수행할 수 있습니다.

주: 데이터베이스가 Start 모드인 경우 데이터베이스를 열려면 먼저 수동으로 데이터베이스를 탑재해야 합니다. 데이터베이스를 열려면 탑재한 다음 Status 탭에서 선택하고 Alter를 다시 선택합니다.

관련 항목

Instance Manager

Instance Manager - Shutdown

Instance Manager - Startup

Instance Manager - Status 탭


창: SGA Trace/Optimization

SGA Trace/Optimization

SGA Trace/Optimization 창은 데이터베이스를 쉽게 최적화할 수 있도록 SGA 정보를 표시합니다.

정보를 보고, 눈금의 클라이언트측 필터링을 활용하고, 현재 선택한 질의를 실행하는 세션을 확인할 수 있습니다.

SGA Trace/Optimization을 액세스하려면

  • Database|Monitor|SGA Trace/Optimization 메뉴 항목을 선택합니다.

이 창을 사용하여 SQL 실행 및 수행 방법에 대한 내용을 봅니다.

V$ Oracle Dictionary 보기 액세스가 필요합니다. 필요한 권한 목록은 필요한 V&표 - SGA/Trace를 참조하십시오.

이 대화상자에 다음과 같은 4개의 탭이 있습니다.

  • SQL Shared Pool

  • Execution Stats

  • SQL

  • Explain Plan

통계 영역

통계 영역에서 공유 풀 내의 Execution stats 및 SQL을 볼 수 있습니다. 또한 다음을 수행할 수 있습니다.

  • Search for SQL - 공유 풀 영역을 입력한 문자로 시작하는 SQL로 제한할 SQL의 텍스트를 입력합니다.

  • Hide Zero Stats - 표시되어 있으면 0 값이 있는 통계가 모두 Execution Stats 영역에서 숨겨집니다.

  • Select an Instance - RAC 시스템에 있는 경우 특정 RAC 인스턴스로 디스플레이를 제한할 수 있습니다.

Execution Stats

Execution stats가 왼쪽 패널에 표시됩니다. 이 패널은 SQL Shared Pool 탭에서 선택한 SQL 구문에 대한 정보를 표시합니다.

SQL Shared Pool

Shared Pool SQL은 오른쪽 상단에 표시됩니다. 이 패널은 SQL Shared Pool에 대한 정보를 표시합니다. SGA Trace 도구 모음을 사용하여 보고자 하는 SQL 구문 또한 필터링할 수 있습니다.

SQL 탭

이 탭은 SQL Shared Pool 탭에서 선택한 SQL 구문에 대한 전체 SQL을 표시합니다.

SQL 탭을 누를 때 "SQL Body Unavailable" 메시지가 나타날 경우 SQL은 가장 최근에 사용된 SQL 구문의 풀인 Oracle의 SGA(System Global Area)에 없습니다. 크기가 제한되어 있으므로 모든 SQL 구문을 SGA에 영구적으로 유지할 수 없습니다. 사용 빈도 수가 가장 적은 구문이 새 구문 대신 폐기됩니다.

이 탭의 도구 모음에서 다음을 수행할 수 있습니다.

단추 | 명령
 | 클립보드에 스크립트 복사
 | Editor에 스크립트 로드
 | SQL Tuning/Optimizer를 사용하여 구문 조정

Explain Plan 탭

이 탭은 SQL Shared Pool 탭에서 선택한 SQL 구문에 대한 Explain Plan을 표시합니다. 구문의 총 비용이 Total cost for statement 레이블에 표시됩니다. 규칙 기반의 최적화로 인해 비용 정보를 사용할 수 없으면 이 레이블이 공란으로 남습니다. 마우스 오른쪽 단추를 눌러 Explain Plan에 대한 Explain Plan 옵션을 선택할 수도 있습니다. Explain Plan 옵션을 참조하십시오.

Sessions 탭

Sessions 탭은 SGA 풀에 남아 있는 활성 세션을 모두 표시합니다.

관련 항목

Explain Plan 개요

SGA Trace Explain Plan 옵션


SGA Trace 도구 모음

SGQ Trace 도구 모음에서 일반적으로 사용되는 여러 가지의 명령을 수행할 수 있습니다.

아이콘 | 명령
 | 활성 세션을 변경합니다.
 | 구문 유형, 부여 또는 매개 변수별로 필터링합니다.
 | 사용자 또는 커서별로 필터링합니다.
 | 눈금을 새로 고칩니다.
 | Editor에서 선택한 구문을 로드합니다.
 | SGA를 플러시합니다.


SGA Trace Explain Plan 옵션

SGA Trace 창에 있는 Explain Plan 탭의 마우스 오른쪽 단추 메뉴에 표시되는 Explain Plan을 사용할 수 있는 두 가지 특수한 방법이 있습니다.

Always set session to statement user

이 옵션은 Explain Plan을 실행하기 전에 "ALTER SESSION SET CURRENT_USER=..."를 수행합니다.

Use connected user/schema

이 옵션은 ALTER SESSION 명령을 수행하지 않습니다.

예

사용자 DBAUSER로 로그인하여 Kill/Trace 창에서 SCOTT 사용자에 속하는 세션을 선택합니다. SCOTT가 "Select * from EMP" 문을 실행했다는 것을 알 수 있습니다. Toad Options|Oracle|General|Table name에서 이름을 Toad_PLAN_TABLE로 설정했습니다.

Always set session to statement user

이 옵션을 설정하고 Explain Plan을 수행합니다. Toad에서 Explain Plan을 수행할 때 Oracle은 다음 두 가지 사항을 가정합니다.

  • EMP 테이블이 SCOTT에 속합니다.

  • Toad_PLAN_TABLE이라는 공용 동의어가 있고 SCOTT에 Toad_PLAN_TABLE이 없는 경우가 아니라면 또한 Toad_PLAN_TABLE이 SCOTT에 속합니다. Server Side Objects 마법사는 Explain Plan 개체를 Toad 스키마에 설치할 때 Toad_PLAN_TABLE에 대한 공용 동의어를 만들지만 Explain Plan 개체를 전용 사용자 스키마에 설치할 때는 만들지 않습니다.

Toad_PLAN_TABLE 공용 동의어가 없지만 Oracle이 항상 특정 스키마에서 계획 테이블을 찾도록 하려면 계획 테이블과 함께 사용자 이름을 옵션에 포함할 수 있습니다(예: DBAUSER.Toad_PLAN_TABLE). Use connected user/schema

Use connected user/schema

이 옵션을 설정하고 Explain Plan을 수행합니다. Toad에서 Explain Plan을 수행할 때 또한 Oracle은 다음 두 가지 사항을 가정합니다.

  • EMP 테이블이 사용자(이 예제에서는 DBAUSER)에 속합니다.

  • Toad_PLAN_TABLE이 DBAUSER에 속합니다.

"SELECT * FROM SCOTT.EMP" 문을 설명하는 중이면 Oracle에서는 사용자가 선택한 옵션에 상관없이 EMP 테이블이 SCOTT에 속한다는 것을 알 수 있습니다.


Top Session Finder

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

이 창을 사용하면 데이터베이스에서 자원을 가장 많이 사용하는 세션을 찾을 수 있습니다. Oracle에서는 데이터베이스에 있는 각 세션에 대해 수백 개의 통계를 추적하며 Top Session Finder를 사용하면 모든 매개 변수 조합의 사용량을 기준으로 세션을 쉽게 정렬할 수 있습니다.

Top Session Finder는 Single Parameter Select 모드 또는 Multiple Parameter Select 모드로 사용할 수 있습니다. Single Parameter Select 모드에서는 세션을 자원 사용량에 따라 순서대로 나열합니다. 원하는 자원 이름을 누릅니다. Multiple Parameter Select 모드를 사용하면 두 개 이상의 매개 변수에 가중치를 할당하여 통계의 가중 합계를 기준으로 세션을 정렬할 수 있습니다.

Top Session Finder에 액세스하려면

Database 메뉴에서 Monitor|Top Session Finder를 선택합니다.

옵션

Top Session Finder를 여러 방법으로 구성할 수 있습니다. 창 맨 위에 있는 작은 옵션 패널에서 이 옵션을 제어합니다.

창의 옵션을 표시하려면

  • Top Session Finder Options [image] 단추를 누릅니다.

Single Parameter Select

이 옵션을 선택하면 화면이 Single Parameter Select 모드에 들어갑니다. 매개 변수 이름을 누르면 각 데이터베이스 세션이 선택한 매개 변수의 사용량에 따라 내림차순으로 나열됩니다. 이 모드에서는 매개 변수에 대한 가중치가 사용되지 않습니다.

Multiple Parameter Select

이 옵션을 선택하면 화면이 Multiple Parameter Select 모드에 들어갑니다. Multiple Parameter Select 모드에 대해서는 이 절의 뒷부분에서 자세히 설명합니다.

Short Parameter List

이 옵션을 선택하면 매개 변수 목록이 CPU 및 커서와 같이 더 자주 확인되는 약 35개의 통계로 줄어듭니다. 이 옵션을 사용하면 전체 매개 변수 목록을 살필 필요가 없습니다. 이 옵션을 선택 취소하면 매개 변수 목록에는 v$statname에 있는 모든 내용(Oracle 9.0의 경우 292 항목)이 포함됩니다.

Exclude System Sessions

이 옵션을 선택하면 Oracle의 배경 세션이 목록에 포함되지 않습니다.

Exclude Inactive Sessions

이 옵션을 선택하면 v$session에서 "ACTIVE"로 표시된 세션만 포함됩니다.

Exclude Sessions Inactive for the past ___ Minutes

이 옵션을 선택하면 지정된 기간 동안 활성 상태였던 세션만 포함됩니다. 이 옵션은 "유휴" 연결을 제외하는 데 사용할 수 있습니다.

Multiple Parameter Select 모드

Multiple Parameter Select 모드에서는 parameter 열 옆의 Stored Profile 드롭다운과 Weight 열이 포함됩니다. 두 개 이상의 매개 변수에 가중치를 할당하면 통계의 가중 합계를 기준으로 세션이 정렬됩니다.

가중치는 자원 사용의 실제 모습을 반영하는 일에 도움이 됩니다. 예를 들어 정렬 세션을 실행하는 경우 자원 사용이 많은 디스크 정렬에 가중치 100을 할당하고 메모리 정렬에 가중치 1을 할당할 수 있습니다. 가중치를 할당하거나 변경하려면 Weight 열을 누르고 새 가중치 값을 입력합니다. 창의 맨 위에 있는 List Sessions 녹색 화살표 단추를 누르면 선택한(가중된) 매개 변수의 가중치가 적용된 사용량에 따라 세션이 순서대로 나열됩니다.

마우스 오른쪽 단추 메뉴를 사용하면 모든 가중치를 0으로 재설정(Reset all weights to zero)할 수 있습니다.

Limit Pie Chart to top ___ sessions

이 옵션을 사용하면 세션의 일부만 표시되도록 원형 차트를 제한할 수 있습니다. 원형 차트에서는 최대 1050 세션을 처리할 수 있습니다.

기본값은 50 세션입니다.

Stored Profile 드롭다운

Stored Profile 드롭다운을 사용하면 프로파일을 회수하고 저장할 수 있습니다. 일부 프로파일은 이미 포함되어 있습니다.

Multiple Parameter Select 모드에 처음으로 들어가면 기본적으로 Overall 프로파일이 선택됩니다. 이 프로파일에서는 CPU 사용, 메모리 사용, 세션 논리 읽기, 네트워크 트래픽 및 다시 실행 사용에 가중치가 할당되어 있습니다. 드롭다운에는 CPU, Cursors, Memory, Network Traffic 및 Redo를 포함한 다른 내장 프로파일도 포함되어 있습니다. 이러한 프로파일은 쉽게 수정할 수 있습니다.

Create New Profile 단추를 사용하여 새 프로파일을 작성하고 Save Profile Settings 단추를 사용하여 프로파일 설정을 저장할 수 있습니다. Create New Profile 단추를 누른 후 설정을 새 이름으로 저장하면 새 프로파일에 현재 설정을 저장할 수 있습니다. Delete 단추를 사용하면 선택한 프로파일을 삭제할 수 있습니다. 프로파일은 Topsess.ini라는 파일에 저장되기 때문에 기본 설정으로 되돌리려면 그 파일을 삭제하기만 하면 됩니다.

데이터

데이터는 Dataset(데이터 그리드) 또는 원형 차트에 표시할 수 있습니다.

Dataset 탭

Single Parameter Select 모드에서 목록의 매개 변수를 누르면 그리드에서는 각 데이터베이스 세션을 선택한 매개 변수의 사용량에 따라 내림차순으로 표시합니다. 컴퓨터 이름 및 로그온 시간과 같은 세션별 정보도 표시합니다.

Multiple Parameter Select 모드에서 List Sessions 단추를 누르고 나면 그리드에 데이터베이스 인스턴스에 연결된 SID(System Identifier Names) 목록, 나열된 각 SID의 세션별 정보가 표시되며, 각 통계의 가중치 적용 전 값과 가중치를 적용한 모든 통계의 합도 표시됩니다.

일부 열은 채워지지 않을 수도 있습니다. 예를 들어 Module 열을 채운 경우에는 선택적으로 Action 열을 채울 수 있습니다. 다음에서

dbms_application_info.set_module('abc','def')

"abc"는 Module 열에 표시되고 "def"는 Action 열에 표시됩니다.

마우스 오른쪽 단추 옵션

Dataset 그리드를 마우스 오른쪽 단추로 누른 경우 메뉴에는 다음이 포함됩니다.

  • Print Grid

  • Export Grid

Pie Chart 탭

원형 차트에서 가장 큰 조각은 쉽게 알아볼 수 있도록 원형의 나머지 부분에서 약간 튀어나와 있습니다.

  • Single Parameter Select 모드에서 원형 차트에는 선택한 자원 사용량의 백분율이 표시됩니다.

  • Multiple Parameter Select 모드에서 원형 차트에는 가중치를 적용한 자원의 백분율이 표시됩니다. 조각을 마우스 왼쪽 단추로 누르면 해당 세션의 정보가 표시됩니다.

마우스 오른쪽 단추 옵션

조각을 마우스 오른쪽 단추로 누른 경우 마우스 오른쪽 단추 메뉴에는 다음이 포함됩니다.

  • Print.

  • Save As Bitmap File.

  • Copy image to clipboard.

  • Find selected session in Session Browser.

  • Info on session, info on another session(조각이 너무 작아서 누르기 어려운 경우 유용함)

  • Remove skinny slices.

Remove skinny slices 항목에서는 백분율 값을 입력하라는 메시지가 표시됩니다. 원형 차트의 해당 백분율보다 낮은 비율을 차지하는 세션은 원형 차트에서 제거됩니다. 하지만 데이터 그리드에서 실제로 행이 제거되지는 않습니다.


Top Session Finder 도구 모음

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

아이콘 | 명령
 | Top Session Finder 옵션
 | 세션 나열
 | 새 프로파일
 | 프로파일 저장 옵션
 | 프로파일 삭제
Instance | RAC 인스턴스 선택(RAC 인스턴스에 연결된 경우에만 사용 가능)


특정 세션 찾기

Top Session Finder에서 Session Browser에 있는 특정 세션을 찾을 수 있습니다. 이 작업은 손쉽게 수행할 수 있습니다.

특정 세션을 찾으려면

  1. Top Session Finder에서 찾을 세션을 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Find Selected Session in Session Browser를 선택합니다.

세션이 선택된 Session Browser가 열립니다.

관련 항목

Top Session Finder

Session Browser


Toad UNIX Monitor

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Database|Monitor|UNIX Monitor 메뉴 항목을 선택하여 이 창에 액세스합니다.

UNIX Monitor를 사용하면 세 개의 차트와 하나의 그리드로 데이터베이스 성능을 모니터할 수 있습니다.

  • CPU Usage - 시스템 및 사용자별로 CPU 사용을 추적합니다.

  • Process Queues - 실행 가능한 프로세스와 차단/대기 프로세스(UNIX 시스템별로 다양함. I/O 대기 중에 차단되었을 수도 있고 CPU 사용 할당 시간이 초과되었을 수도 있음)를 모니터합니다.

  • Disk IO(Kb/Sec로 표시됨, 상위 10개 장치에 대한 것)

  • Process 목록 그리드 - 사용자별로 정보를 구분합니다. 프로세스 목록에는 기본적으로 %CPU에 따라 정렬된 상위 20개의 CPU 사용 프로세스가 표시됩니다. 열 헤더를 누르면 해당 열을 정렬할 수 있습니다.

그리드 열을 정렬하고, 확대/축소하고, 인쇄할 수 있습니다. UNIX Monitor는 AIX, HP, Linux 및 Solaris를 완전히 지원합니다. UNIX Monitor는 TRU64를 지원하지만, 이 UNIX 버전에서는 Disk I/O 그래프가 비어 있게 됩니다.

UNIX Monitor의 구성 옵션은 View|Toad Options|Monitors를 참조하십시오.

주: 이 유틸리티를 사용하려면 서버에서 Rexecd를 실행 중이어야 합니다. RExec에 대한 자세한 내용은 Network Utilities | Rexec를 참조하거나 UNIX 관리자에게 문의하십시오.

UNIX Monitor를 사용하려면 이 프로그램을 반드시 실행하고 연결해야 합니다. 따라서 아침에 프로그램을 실행하고 창을 최소화해 두면 나중에 임계값을 넘었을 때 경고를 받을 수 있습니다.

요구 사항

UNIX Monitor를 사용하는 일에 특별한 권한이 필요하지는 않습니다. 하지만 사용자는 방화벽을 통과할 수 있어야 합니다.

다음 명령이 사용되며, UNIX 컴퓨터에서 설치 및 활성화되어 있어야 합니다.

  • RExec 모니터 진행에 사용됩니다.

주: 이 유틸리티를 사용하려면 서버에서 Rexecd를 실행해야 합니다. 또한 일부 UNIX 종류에서는 rexec를 rlogin으로 처리하는 경우가 있습니다. 그러면 ".profile"과 같은 로그인 파일이 자동으로 실행될 수 있습니다. 이 경우 반향된 "motd"(오늘의 메시지) 등의 외부 출력 명령 때문에 Toad의 출력 구문 분석이 방해를 받을 수 있습니다.

  • lostat 디스크 IO 정보를 가져오는 일에 사용됩니다.

  • vmstat CPU 정보 확보에 사용됩니다.

  • ps 대기열 및 목록 처리에 사용됩니다.

Refresh rate

차트에 있는 데이터를 자동으로 새로 고치려면 두 가지를 수행해야 합니다.

자동 새로 고침을 설정하려면

  1. Auto refresh 확인란을 선택합니다.

  2. Refresh rate 드롭다운 메뉴에서 새로 고침 간격을 선택합니다.

Refresh 단추를 눌러 수동으로 데이터를 새로 고칠 수 있습니다.

연결

UNIX Monitor를 사용하려면 모니터할 UNIX 서버에 연결되어 있어야 합니다.

UNIX 서버에 연결하려면

  1. 연결하려면 Connect 단추를 누릅니다.

  2. Server Settings 대화 상자에 해당 정보를 입력합니다.

  3. OK를 눌러 연결합니다.

그래프가 초기화하기 위해서는 선택한 새로 고침 주기가 2회 또는 3회 반복되며, 그 직후 그래프가 채워집니다. 그래프가 채워지면(1시간) 데이터가 화면을 벗어나 스크롤되지만 지워지지는 않습니다. 마우스 오른쪽 단추 누름|Zoom을 사용하여 2시간 동안의 기록을 볼 수 있습니다. (Database Monitor의 경우도 마찬가지입니다.) Zoom을 선택합니다.

UNIX Monitor에 연결하는 중에 문제가 있는 경우, 자세한 내용을 보려면 UNIX Monitor 연결 문제 해결 항목을 참조하십시오.


Unix 모니터 연결 문제 해결

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

UNIX에는 제어할 수 있는 범위를 벗어나는 잠재적 연결 문제가 있습니다.

연결 프로세스의 일부로서 rexecd 데몬에서는 기본적으로 "reverse name lookup" 작업을 수행합니다. 즉, 서버는 rexec 소스 컴퓨터의 IP 주소를 /etc/hosts 파일과 비교한 후 소스 IP 주소를 찾을 수 없으면 연결을 거부합니다. 서버 간 rexecs의 경우에는 서버에 하드 코딩된 잘 알려진 IP 주소가 있는 경우가 많기 때문에 이 기능이 유용합니다. 네트워크 클라이언트의 경우에는 그렇지 않을 수도 있습니다. 각 서버의 /etc/hosts 파일에 모든 PC의 IP 주소를 넣는 수고를 감당할 수 있는 회사는 얼마 되지 않습니다. 많은 회사에서 네트워크 클라이언트에 대해 DHCP를 사용합니다. IP 주소는 잘 알려져 있지 않으며 일정하지 않습니다.

솔루션은 /etc/inetd.conf 파일을 편집하고 rexecd 명령에 –c 매개 변수를 추가하여 "reverse name lookup" 설정을 끄는 것입니다. 그런 다음 서버를 다시 부팅하거나 –s inetd를 새로 고칩니다.


DBMS_REDEFINITION 마법사

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

DBMS_REDEFINITION은 Oracle에서 제공하는 패키지입니다. DBMS_REDEFINITION을 사용하면 테이블을 온라인으로 다시 정의하고 다시 작성할 수 있습니다. 이 패키지에 대한 자세한 내용은 Oracle 설명서를 참조하십시오.

DBMS_REDEFINITION 마법사는 DBMS_REDEFINTION의 인터페이스입니다. 이 Toad 인터페이스를 사용할 수 있는 버전은 Oracle 10 이상으로 제한됩니다.

이 마법사의 모든 부분은 Oracle 패키지와 직접적으로 관련됩니다. 사용자가 제공하는 매개 변수에 대한 자세한 내용은 Oracle 설명서를 참조하십시오.

DBMS_REDEFINITION 마법사를 사용하려면

  1. Database 메뉴에서 Optimize|DBMS_REDEFINITION wizard를 선택합니다.

  2. 테이블을 선택하고 다시 정의하는 방법을 지정합니다.

또는

Select 단추를 눌러 이미 진행 중인 재정의를 선택합니다.

  3. Next를 누릅니다.

  4. 열 매핑을 정의한 후 Next를 누릅니다.

  5. 열을 원하는 순서대로 설정합니다. 선택한 열을 패널 간에 이동하거나 Desired Order 목록에서 위쪽이나 아래쪽으로 이동할 수 있습니다.

  6. Next를 누릅니다.

  7. 화면의 아래에서 Degree of Parallelism을 선택합니다.

  8. Start를 눌러 재정의 프로세스를 시작합니다.

또는

Sync를 눌러 중간 테이블을 동기화합니다.

  9. Next를 누릅니다.

  10. 다음 개체의 자동 복사 및 등록을 선택합니다.

  11. 인덱스

  12. 트리거

  13. 제약 조건

  14. 부여

  15. 통계

Copy and Register checked object types를 누릅니다.

또는

중간 테이블 개체를 수동으로 등록/등록 취소하도록 선택합니다.

또는

복사/등록한 개체를 봅니다.

  11. Next를 누릅니다.

  12. 오류를 검토한 후 Next를 누릅니다.

  13. 재정의 프로세스를 중지합니다.

또는

재정의 프로세스를 마칩니다.

  14. Restart Wizard를 눌러 프로세스를 반복합니다.

또는

Close를 눌러 마법사를 닫고 Toad로 돌아갑니다.


색인 크기 예상

Database|Optimize|Estimate Index Size 메뉴 항목을 사용하여 이 대화상자를 엽니다.

이 대화상자에서 특정 색인이 차지하는 디스크 공간을 예상합니다. 눈금에 색인을 입력한 다음 색인 모두 또는 일부의 크기를 예상하기로 선택합니다.

주: 비트맵 색인에서도 예상할 수 있습니다. 하지만 사용된 열이 비트맵 색인에 도움이 되지 못할 경우 여러 번 예상하지만 크기는 적어집니다. 비트맵 색인 열이 원래보다 크기 때문에 이러한 문제가 발생합니다. 도움이 되는 열을 선택하여 정확한 비트맵 색인 결과를 얻도록 해야 합니다.

색인 로드 및 스캔

dba_indexes에서 색인, avr_row_len 열을 로드하면(색인이 분석된 경우) DDL 행 크기가 눈금에 자동으로 로드됩니다. 색인을 스캔하여 평균치를 얻을 경우 아래의 4단계를 확인해야 합니다. 스캔이 느릴 수도 있으므로 자동으로 수행되지 않습니다.

주: 이러한 예상 값은 색인 데이터가 차지하는 디스크 공간에 따라 달라집니다. EXTENTS가 데이터를 저장하는 컨테이너이므로 이러한 값은 Schema Browser|Indexes 페이지|Stats/Size 탭에 표시되는 EXTENTS 값과 다릅니다. 범위는 특정 컨테이너 크기(예: 1MB)로 작성됩니다. 각 범위는 비어 있거나, 반만 차있거나, 3/4이 차있거나, 꽉 차있습니다. 이러한 모든 경우 EXTENT 크기는 데이터 변경 내용이 차지하는 디스크 공간 1MB로 동일하게 남습니다.

색인을 로드 및 스캔하려면

  1. Estimate Index Size 도구 모음에서 Load indexes [image] 단추의 드롭다운 화살표를 누릅니다.

  2. 다음 중 하나를 선택합니다.

  3. Load my Indexes - 현재 연결된 스키마에서 색인을 모두 로드합니다.

  4. Load Indexes Like - 색인을 선택 및 로드하는 질의에 LIKE 절을 추가할 수 있습니다.

  5. Load Indexes by User - 색인 소유자를 선택하고 해당 스키마에서 색인을 로드할 수 있습니다.

  6. Load Indexes by Tablespace - 표 공간을 선택하고 포함된 색인을 모두 로드할 수 있습니다.

  7. Load Indexes by Table - 표를 선택하고 이 표의 색인을 모두 로드할 수 있습니다.

  8. Import Grid from Text file - 색인을 로드하고 이전에 저장한 눈금을 엽니다.

  3. 색인이 눈금에 있으면 예상할 색인 옆의 상자를 표시합니다.

  4. 도구 모음에서 Scan [image] 단추를 누릅니다. 확인 대화상자가 나타나 필요한 경우 스캔한 행의 비율을 변경할 수 있습니다. 기본값은 10퍼센트입니다. 완료되면 평균 행 길이 및 예상 크기가 눈금에 입력됩니다.

주의: 모든 데이터의 가상 저장 크기의 합계 및 평균을 내므로 다소 시간이 소요될 수 있습니다. 색인에 데이터가 많아질 수록 선택한 비율이 높아지고 더 많은 시간이 소요됩니다.

눈금 사용

스캔한 크기가 있으면 눈금이 스프레드시트처럼 작동합니다. 다음 값을 변경할 수 있습니다.

  • num_rows

  • pct_free

  • ini_trans

  • block_size

예상 색인 크기는 눈금의 해당 행의 바깥쪽을 누르는 대로 바로 업데이트됩니다.

눈금 저장

마치기 전에 종료해야 할 경우 눈금을 텍스트 파일로 저장하고 나중에 다시 열 수 있습니다.

눈금을 텍스트 파일로 저장하려면

Load indexes [image] 단추의 드롭다운 화살표를 누릅니다.

Export grid to text file을 선택합니다.

파일 이름을 입력하고 Save를 누릅니다.


표 크기 예상

이 대화상자에서 특정 표가 차지하는(또는 더 많은 행이 로드된 후 차지하는) 디스크 공간을 예상합니다. 눈금에 표를 입력한 다음 색인 모두 또는 일부의 크기를 예상하기로 선택합니다.

표 크기 예상 도구를 액세스하려면

  • Database|Optimize|Estimate Table Size 메뉴 항목을 선택합니다.

표 로드 및 스캔

dba_tables에서 표, avr_row_len 열을 로드하면(표가 분석된 경우) DDL 행 크기가 눈금에 자동으로 로드됩니다. 표를 스캔하여 평균치를 얻을 경우 아래의 4단계를 확인해야 합니다. 스캔이 느릴 수도 있으므로 자동으로 수행되지 않습니다.

주: 이러한 예상 값은 표 데이터가 차지하는 디스크 공간에 따라 달라집니다. EXTENTS가 데이터를 저장하는 컨테이너이므로 이러한 값은 Schema Browser|Tables 페이지|Stats/Size 탭에 표시되는 EXTENTS 값과 다릅니다. 범위는 특정 컨테이너 크기(예: 1MB)로 작성됩니다. 각 범위는 어디든지 존재할 수 있습니다. 이러한 모든 경우 EXTENT 크기는 데이터 변경 내용이 차지하는 디스크 공간 1MB로 동일하게 남습니다.

표를 로드 및 스캔하려면

  1. Estimate Table Size 도구 모음에서 Load tables [image] 단추의 드롭다운 화살표를 누릅니다.

  2. 다음 중 하나를 선택합니다.

  • Load my tables - 현재 연결된 스키마에서 표를 모두 로드합니다.

  • Load tables Like - 표를 선택 및 로드하는 질의에 LIKE 절을 추가할 수 있습니다.

  • Load tables by User - 표 소유자를 선택하고 이 스키마의 표를 로드할 수 있습니다.

  • Load tables by Tablespace - 표를 선택하고 포함된 표를 모두 로드할 수 있습니다.

  • Import Grid from Text file - 표를 로드하고 이전에 저장한 눈금을 엽니다.

  3. 표가 눈금에 있으면 예상할 표 옆의 상자를 표시합니다.

  4. 도구 모음에서 Scan [image] 단추를 누릅니다. 확인 대화상자가 나타나 필요한 경우 스캔한 행의 비율을 변경할 수 있습니다. 기본값은 10퍼센트입니다. 완료되면 평균 행 길이 및 예상 크기가 눈금에 입력됩니다.

주의: 모든 데이터의 가상 저장 크기의 합계 및 평균을 내므로 다소 시간이 소요될 수 있습니다. 표에 데이터가 많아질 수록 선택한 비율이 높아지고 더 많은 시간이 소요됩니다.

눈금 사용

표 크기를 예상할 수 있는 방법은 4가지가 있습니다. 도구 모음에서 Scan을 누를 때 이 숫자가 정의됩니다.

  • Avg Row Len (Scan)은 현재 표에 있는 데이터에 따라 평균 행 길이를 계산합니다.

  • Avg Row Len (Stats)은 마지막으로 표 통계를 수집할 때(통계를 수집할 당시 표의 데이터에 따라) Oracle에서 저장한 평균 행 길이를 얻습니다.

  • Max Row Len (DDL)은 열의 형식 및 개수에 따라 최대 행 길이를 얻습니다.

  • 이 방법 중 아무 것도 적용할 수 없을 경우 Avg Row Len (User)에 고유한 숫자를 입력할 수 있습니다. 예를 들어, 데이터를 샘플링했지만 필드의 예제 데이터 값이 너무 작을 경우 스캔한 다음 Avg Row Len (User)에 Avg Row Len (Scan)보다 약간 큰 수를 입력합니다.

스캔한 크기가 있으면 눈금이 스프레드시트처럼 작동합니다. 다음 값을 변경할 수 있습니다.

  • Num Rows

  • Pct Free

  • Ini Trans

  • Block Size

  • Avg Row Len (User)

예상 표 크기는 눈금의 해당 행의 바깥쪽을 누르는 대로 바로 업데이트됩니다.

색인 크기 예상

표시된 표에 색인 크기 예상 도구를 쉽게 실행할 수 있습니다. 마우스 오른쪽 단추를 누르고 Launch Index Size Estimator for Indexes on Checked Tables를 선택합니다.

눈금 저장

마치기 전에 종료해야 할 경우 눈금을 텍스트 파일로 저장하고 나중에 다시 열 수 있습니다.

눈금을 텍스트 파일로 저장하려면

  1. Load tables [image] 단추의 드롭다운 화살표를 누릅니다.

  2. Export grid to text file을 선택합니다.

  3. 파일 이름을 입력하고 Save를 누릅니다.


Explain Plan

이전에 실행한 Explain Plan을 쉽게 보고 새 Plan과 비교할 수 있습니다.

이전에 실행한 Explain Plan 기록을 보려면 Options 페이지에 Save previous explain plan results가 선택되어 있어야 합니다.

기록 페이지는 두 개의 패널로 구분됩니다. 상단 영역에 저장된 Explain Plan이 모두 나열됩니다. 이 중 하나를 선택하면 하단 패널에 나타나며 SQL 구문이 바로 위에 표시됩니다.

표시된 Explain Plan은 Editor의 Explain Plan과 동일한 방식으로 보고 조작할 수 있습니다. (자세한 내용은 Explain Plan 개요 및 관련 항목을 참조하십시오.)

Explain Plan 기록을 표시하려면

  • Database 메뉴에서 Optimize|Explain Plan을 선택합니다.

관련 항목

Explain Plan 개요

Explain Plan 옵션

Explain Plan 결과

Explain Plan 비교


창: Pinned Code

Pinned Code

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Oracle SGA를 채울 때 Oracle에서는 버퍼의 일부를 새 데이터로 덮어씁니다. SGA에서 PL/SQL 개체를 고정시키면 Oracle에서 버퍼를 덮어쓰지 못합니다.

데이터베이스에서 로드한 특정 PL/SQL 개체를 자주 사용하는 경우에는 SGA로 고정하면 Oracle 성능이 향상됩니다.

개체를 고정하려면

  1. Database 메뉴에서 Optimize|Pinned Code를 선택합니다.

SQL 캐시의 각 PL/SQL 개체와 소유자 및 고정 여부가 위쪽 그리드에 나열됩니다.

  2. 맨 아래의 트리 보기를 사용하면 드롭다운에 표시된 스키마의 모든 소스 코드를 찾아볼 수 있습니다. 소스 코드를 선택하여 현재 SGA 캐시에 없는 개체를 고정할 수 있습니다.

  3. 개체가 SGA 캐시 안에 있으면 위쪽 그리드에서 개체를 선택합니다.

  4. 개체가 SGA 캐시 안에 없으면 페이지 중간에 있는 드롭다운에서 해당 스키마를 선택한 다음 트리 보기에서 개체를 선택합니다.

  3. 도구 모음에서 Pin [image] 단추를 누릅니다.

개체 고정을 해제하려면

고정된 개체가 SGA 캐시 그리드에 표시됩니다.

  1. SGA 캐시 그리드에서 고정된 개체를 선택합니다.

  2. 도구 모음에서 Unpin [image] 단추를 누릅니다. 개체 고정이 해제됩니다.

SGA 캐시를 플러시하려면

도구 모음에서 Flush the SGA를 수행할 수 있습니다.

  • Flush [image] 단추를 누릅니다.

SGA는 Oracle에서 가장 최근에 실행한 문을 캐시하는 공유 SQL 풀입니다. 따라서 재처리 속도가 더 빨라집니다. Flush the SGA 단추는 SGA 캐시에서 고정되지 않은 모든 개체를 제거합니다.

SGA 캐시 보기 새로 고침

SGA 캐시 보기를 수동 또는 자동으로 새로 고칠 수 있습니다.

수동으로 새로 고치려면

  • Refresh [image] 단추를 눌러 언제라도 SGA 캐시 보기를 새로 고칩니다.

자동으로 새로 고치려면

  1. Pinned Code 도구 모음의 Refresh (secs) 필드에서 새로 고침 간격(초)을 입력합니다. 기본값은 5입니다.

  2. Auto Refresh 상자를 선택합니다. 캐시 보기가 자동으로 새로 고쳐집니다.


창: Rebuild Table

Rebuild Table

이 기능을 사용하여 표를 재구성하고, 열을 삭제하거나(선택 사항) 열 이름을 바꿀 수 있습니다.

이 창은 완전한 스크립트를 작성하여 표를 재구성하며, 필요한 경우 나중에 취향에 맞게 편집할 수 있습니다.

표를 재구성하려면

  1. Database|Optimize|Rebuild Table 메뉴 항목을 선택합니다.

  2. 재구성할 표를 선택합니다. 소유자 드롭다운 목록에서 소유자를 변경할 수 없도록 표 소유자로 로그인해야 합니다.

  3. Options 탭에서 원하는 옵션을 표시합니다.

  4. Table Storage 및 Index Storage 탭에서 Storage 매개 변수를 선택합니다. 원래 저장 매개 변수를 사용하거나 현재 표 크기를 초기 범위로 사용할 수 있으며, 보다 빠른 디스크 성능을 위해 모든 범위를 하나로 통합합니다.

  5. Columns 탭에서 상단 목록의 열을 두 번 눌러 표에서 제외(삭제)합니다. 열 이름을 바꾸려면 눌러서 선택한 다음 마우스를 두 번 누를 수 있을 때까지 기다린 후 다시 누릅니다. 열의 새 이름을 입력합니다.

  6. SQL 탭을 누릅니다. 재구성 표 스크립트가 구성 및 표시됩니다. 이제 스크립트를 파일로 저장하거나 클립보드에 복사할 수 있습니다.

주: 스키마에서 표를 재구성하려면 찾고 있는 스키마를 소유하고 있어야 합니다.


Repair Chained Rows

이 창에서는 체인된 행을 가진 테이블이 표시됩니다.

테이블에 있는 행의 데이터는 단일 데이터 블록에 들어갈 수 없는 경우 데이터 블록 체인(둘 이상의 데이터 블록)에 저장됩니다. 데이터의 원래 행은 새 데이터 블록을 가리킵니다. 체인된 행은 결과적으로 정보를 검색하기 위해 Oracle에서 둘 이상의 데이터 블록을 스캔해야 한다는 것을 나타냅니다. Repair Chained Rows 기능은 기본적으로 둘 이상의 블록에서 분할된 데이터 블록 행을 다시 조인합니다.

Repair Chained Rows 기능을 사용하려면 Oracle에서 설명한 대로 체인된 행 테이블이 정의되어 있어야 합니다.

Repair Chained Rows에 액세스하려면

  • Database|Optimize|Repair Chained Rows 메뉴 항목에서 이 창에 액세스합니다.

Analyze 탭

ADD 단추를 누르면 분석할 스키마를 드롭다운에서 선택하고 분석할 테이블을 스키마의 테이블 목록에서 선택할 수 있는 Select Tables to Analyze 메뉴가 나타납니다. 테이블 앞에 있는 확인란을 눌러 테이블을 선택하거나 선택 취소합니다. Select All 및 Select None 단추는 신속하게 선택하는 데 도움이 됩니다.

주의: Chained Rows table 필드에는 발견한 체인된 행의 행 ID를 저장하도록 Toad에서 Oracle에 지시하는 테이블의 이름이 포함됩니다. 이 테이블은 분석할 테이블이 아닙니다. Toad에서는 목록의 테이블을 분석하기 전에 체인된 행 테이블을 자릅니다.

Data 탭

이 탭에는 스키마, 테이블 이름, 테이블의 체인된 행 수가 표시됩니다.

Repair 탭

이 탭은 중간 테이블을 만들어 체인된 행을 복사하고 기존 테이블에서 체인된 행을 삭제한 다음 행을 다시 기존 테이블에 복사합니다. 체인을 완전히 없애기 위해 기존 테이블의 데이터 블록 크기를 늘려야 할 수 있습니다.

또한 드롭다운에서 롤백 세그먼트를 선택할 수도 있습니다. 체인된 행을 복구하려면 Repair 를 누릅니다.

복구된 각 테이블 아래 결과가 표시됩니다.

Results 탭

Results 탭에는 복구되지 않은 테이블과 이유가 나열됩니다.


Unix Kernel Parms

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Unix 서버에서 데이터베이스를 관리하는 경우 중요 커널 설정 몇 가지를 업데이트하면 데이터베이스 성능을 향상시킬 수 있습니다. 이 화면에서는 UNIX 커널을 수정하는 일에 필요한 단계와 중요 커널 매개 변수를 신속하게 생성하여 Oracle 성능을 대폭 향상시킬 수 있습니다. 이러한 설정에 대한 설명은 "UNIX Installation Guide"의 "Pre-Installation 장"에 있는 "UNIX Configuration 절"에서 찾을 수 있습니다. 이 화면을 사용하면 구성 프로세스를 단순화할 수 있습니다.

이 화면에서는 수행할 작업의 방법과 설정할 매개 변수 값을 생성합니다.

FTP를 통해 출력을 UNIX 서버로 보내고, 매개 변수 값을 필요한 위치에 붙여넣고, 표시된 단계를 수동으로 수행하여 UNIX 커널을 재구성해야 합니다.

UNIX Kernel Parms에 액세스하려면

  1. Database 메뉴에서 Optimize를 선택합니다.

  2. UNIX Kernel Parms를 선택합니다.

옵션

UNIX Type

데이터베이스 서버를 실행하는 UNIX의 종류를 지정합니다. 이 설정은 단계와 매개 변수의 생성을 모두 직접 제어합니다. 예를 들어 UNIX 종류가 다르면 커널 구성도 다른 방식으로 이루어집니다. 마찬가지로, UNIX 종류가 다르면 매개 변수와 권장 설정도 다르게 구현됩니다.

Concurrently Active Databases

해당 데이터베이스 서버에 대해 동시에 실행할 데이터베이스의 수를 지정합니다. 예를 들어 데이터베이스 서버에는 Payroll, Accounting 및 HR의 세 가지 데이터베이스 응용 프로그램에 대한 프로덕션 데이터베이스 인터페이스가 있을 수 있습니다. 이 예에서 데이터베이스 서버에는 세 개의 데이터베이스 인스턴스가 동시에 실행됩니다.

Concurrent Processes Per Database

주어진 시점에서 동시에 활성 상태가 될 프로세스 수의 데이터베이스 당 평균을 지정합니다. 예를 들어 Payroll 응용 프로그램은 동시 사용자가 평균 40명이고, Accounting 응용 프로그램은 동시 사용자가 평균 100명이고, HR 응용 프로그램은 동시 사용자가 평균 100명일 수 있습니다. 이 때 평균 동시 프로세스 수는 80(40 + 100 + 100 = 240 / 3 = 80)이 됩니다.

Average Degree of Parallelism

병렬 작업을 어느 정도로 지원할 것인지 지정합니다. CPU 대역폭이 남거나(예: SMP, MMP, NUMA 아키텍처) 디스크 IO 대역폭이 남는(예: RAID, SAN 및 NAS) 서버에서만 사용해야 합니다. 기본 병렬 처리도가 2 이상이거나 힌트를 갖춘 DML이 있는 테이블 또는 색인이 있어야 합니다. 이러한 조건이 충족된 경우 Oracle은 병렬 작업을 수행하기 위해 추가 프로세스를 생성하기 때문에 자원을 훨씬 많이 소비합니다. 이러한 추가 요구를 지원할 수 있도록 UNIX 커널을 구성해야 합니다.

Calculate

Calculate를 누르면 Toad에서 매개 변수를 수정하여 성능을 최적화합니다.


Windows Registry Parms

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Windows NT/2000/XP 서버에서 데이터베이스를 관리하는 경우 중요 레지스트리 설정을 업데이트하면 전체 데이터베이스 성능을 향상시킬 수 있습니다. 예를 들어 Quest 사의 Benchmark Factory® for Oracle을 사용하여 TPC와 같은 업계 표준 데이터베이스 벤치마크를 실행하면 Windows 서버 및 Oracle 데이터베이스의 원시 점수를 얻을 수 있습니다. 그런 다음 Windows 레지스트리의 설정을 변경하고 벤치마크를 다시 실행하여 새 점수를 얻을 수 있습니다. 이렇게 하면 Oracle 데이터베이스 성능을 50% - 150% 정도 향상시킬 수 있습니다.

REGEDIT를 사용하여 이러한 설정을 수동으로 정의할 수도 있지만 레지스트리 키와 값을 이해하기가 약간 어렵습니다. Windows Registry Parms 창을 사용하면 이러한 설정을 쉽고 빠르게 정의할 수 있습니다. 네 확인란(Memory Management 영역의 두 개와 NTFS fileSystem 영역의 두 개)을 모두 선택한 후 Windows 서버 크기에 가장 적합한 IO Page Lock Limit를 선택하는 것이 좋습니다. 서버 메모리 양이 많을수록 더 높은 값을 설정할 수 있습니다. 확인이 필요하겠지만 대부분의 서버는 8K 이상의 값이면 충분할 것입니다.

Windows Registry Parms에 액세스하려면

  1. Database 메뉴에서 Optimize|Windows Registry Parms를 선택합니다.

Reading Registries

이 화면은 로컬 및 원격 Windows NT/2000/XP 레지스트리 모두에서 작동합니다. 원격 레지스트리는 원격 레지스트리 액세스를 허용하도록 구성해야 합니다.

주: 원격 레지스트리에 액세스하려면 원격 컴퓨터 이름을 \\computername의 형태로 입력해야 합니다. 이중 백슬래시 접두사를 반드시 사용해야 합니다.

Updating Registries

레지스트리를 이 화면에서 변경한 내용으로 업데이트할 수 있습니다.

주: 변경 사항을 적용하려면 컴퓨터를 다시 부팅해야 합니다.

레지스트리 내보내기 파일

이러한 텍스트 파일은 아무 텍스트 편집기나 사용하여 열고 수정할 수 있습니다.

Windows 탐색기 내에서 이러한 파일을 두 번 누르면 로컬 레지스트리가 해당 내용으로 업데이트됩니다. 이 기능은 파일을 로컬로 작성한 후 수동 적용을 위해 원격 서버로 복사하려는 경우에 유용합니다.

레지스트리 내보내기 파일을 작성하려면

  • Create "Reg." file을 눌러 Windows 표준 레지스트리 내보내기 파일을 만듭니다.


Analyze All Objects

Database|Optimize|Analyze All Objects 메뉴 항목에서 이 대화상자를 엽니다.

여러 표, 색인, 파티션을 분석하고 연속 행을 확인하고, 분석 결과로 데이터 Oracle 스토어를 확인할 수 있습니다.

이 대화상자를 사용하여 표 개체 목록에서 선택한 표를 분석하면 COST 기준 질의 최적화가 사용되고 Optimizer가 보다 뛰어난 질의를 실행할 수 있도록 통계가 수집됩니다.

이 창을 처음 열면 탭의 눈금이 비어 있습니다.

표 및 색인 분석

이 화면에서 개체를 쉽게 분석할 수 있습니다.

주: 이러한 기본 분석의 기본 설정 및 분석 사용자 지정 방법에 대한 내용은 아래의 Set Options를 참조하십시오.

표 또는 색인을 분석하려면

  1. 올바른 탭을 누르고, Load 단추를 누르거나 옆의 드롭다운에서 데이터 로드 방법을 선택하여 눈금을 로드합니다.

  2. 확인란을 사용하여 눈금에서 개체를 하나 이상 선택합니다. (아니면 마우스 오른쪽 단추를 누르고 Check All, Uncheck All, Remove 등을 선택합니다.)

  3. 도구 모음에서 Analyze selected objects [image] 단추를 누릅니다.

  4. 눈금이 분석 데이터로 채워집니다.

Columns(Histograms)

이 창에서 다음 작업을 수행할 수 있습니다.

  • dbms_stats를 사용하여 통계 삭제

  • 통계 내보내기/가져오기/복사

Chained Rows

이 창에서 연속 행을 확인할 수 있습니다.

  • 도구 모음에서 Load Data from CHAINED_ROWS Table [image] 단추를 누릅니다.

눈금이 연속 행 정보로 채워집니다.

주: 이 기능을 사용하려면 CHAINED_ROWS에 대한 선택 권한이 있어야 합니다.

정보가 표시되면 Repair Chained Rows 기능으로 이동할 수 있습니다. 도구 모음에서 Go to Repair Chained Rows [image] 단추를 누릅니다.

Set Options

개체 분석을 사용자 정의할 수 있습니다. Options 탭을 눌러 사용자 정의하고 Use Analyze 또는 Use DBMS_STATS를 선택합니다.

동일한 Analyze 또는 DBMS_STATS 명령을 반복하여 실행할 경우 Toad가 이 창에서 설정한 옵션을 저장하므로 매번 옵션을 다시 설정하지 않아도 됩니다. 이러한 옵션에 대한 자세한 내용은 다음 중 하나를 참조하십시오.

  • Analyze 기능

  • DBMS_STATS 기능


Analyze 옵션

Analyze Functions 영역에서 작성할 분석 구문 유형을 선택할 수 있습니다. 일부 기능을 사용하여 "For Clause"를 포함할 수 있지만, 포함을 허용하지 않는 기능도 있습니다.

Compute Statistics

이것은 표를 분석할 수 있는 가장 자세하고 정확한 방법입니다. 통계는 표의 데이터에서 계산됩니다.

Estimate Statistics

Estimate Statistics를 사용하여 계산에 필요한 시간 및 자원을 절약할 수 있습니다. 일부 통계는 계산된 것 보다 약간 다를 수 있습니다.

Oracle이 예상치를 작성하기 위해 사용하는 예제 수를 변경하고 Analyze Functions 영역 아래의 상자에 있는 행 또는 백분율을 참조하는지 변경할 수 있습니다.

이 옵션은 기본 설정입니다.

Delete Statistics

Delete Statistics를 사용하여 표의 분석 통계를 모두 삭제합니다. 이렇게 하면 표가 분석되지 않은 것처럼 남게 됩니다.

List Chained Rows

표에 연속 행이 있을 경우 이 기능을 사용하여 표를 선택 및 분석하여 Chained Rows 탭에 연속 행을 표시합니다.

주: 이 기능을 사용하려면 정의된 Chained Rows 표가 있어야 합니다.

Validate Structure

이 옵션을 선택하여 표 또는 색인 구조의 유효성을 검사합니다. 문제가 없을 경우 분석 명령이 실행되고, 문제가 있을 경우에는 Toad에 ORA- 오류가 표시됩니다.


DBMS_STATS 기능

DBMS_STATS 기능 영역에서 수집할 내용 및 수집한 DBMS_STATS의 정렬 및 구성 방법을 선택할 수 있습니다.

DBMS_STATS를 사용하면 정보를 수집할 때 여러 옵션을 사용할 수 있습니다.

Gather Index Stats When Gathering Table Stats

이 옵션을 사용하여 표에 연결되어 있는 표 및 색인 통계를 수집할 수 있습니다.

Do not invalidate dependent cursors

이 옵션이 표시되어 있지 않으면 Oracle에 분석한 표에 대한 질의 실행 계획이 있으며, 계획이 폐기되고 새 실행 계획이 작성됩니다. 표시되어 있으면 이전 실행 계획을 계속 사용합니다.

Mode

모드를 선택합니다.

Delete

통계를 삭제합니다.

Estimate

표의 데이터 일부분을 사용하여 통계를 예상합니다.

Compute

전체 표(또는 색인)의 모든 데이터를 확인하여 통계를 수집합니다.

Estimate

Estimate 영역에는 통계를 예상할 때만 유효한 옵션이 있습니다.

Block Sample

Oracle이 행과 반대되는 데이터 블럭을 임의로 샘플링합니다. 임의로 블럭을 샘플링하는 것은 보다 효율적이지만 데이터가 디스크에 임의로 배포되지 않으면 예제 값에 약간의 상관 관계가 발생할 수 있습니다. 통계를 예상할 때만 이 옵션이 관련됩니다.

AutoSample

Oracle이 행(또는 블럭)의 비율을 결정하여 통계를 수집할 때 샘플링합니다.

Sample x%

블럭(또는 행)의 비율을 지정하여 샘플링합니다.

Degree of Parallelism

DBMS_STATS는 병렬 프로세스를 사용하여 데이터를 샘플링합니다. 이 영역에서 사용할 프로세스를 선택합니다.

Same as Object

Oracle은 표에 할당된 정도의 값과 동일한 병렬 프로세스 수를 사용합니다.

Init.ora based value

Oracle은 데이터베이스 초기화 매개 변수에서 지정한 기본 병렬 처리를 사용합니다.

Specify

아래 상자에서 병렬 처리의 정도를 할당합니다.

Collect Histograms with Tables

이 상자가 표시되어 있으면 다음 옵션에서 선택합니다.

For all … Hidden … Indexed Columns

  • Indexed columns - 인덱싱된 모든 열의 데이터를 수집합니다.

  • Hidden columns - 표 하나가 최대 1000개의 열을 가질 수 있습니다. 개체 표(또는 개체, 중첩된 표, Varray 또는 REF 형식의 열이 있는 관계형 표)를 작성할 때 Oracle은 사용자 정의 형식의 열을 관계형 열로 매핑합니다. 이렇게 하면 1000개의 열을 제한하는 "hidden columns"의 효과가 만들어집니다.

여기서 Hidden Columns를 선택하면 Toad가 이 열에 대한 데이터를 수집합니다.

Repeat

이미 히스토그램이 있는 열에 대한 히스토그램만 수집합니다.

Auto

Oracle은 사용할 열을 결정하여 열 데이터 배포 및 작업량에 따라 히스토그램을 수집합니다.

Skew Only

Oracle은 사용할 열을 결정하여 열 데이터 배포에 따라 히스토그램을 수집합니다.

Specify

제공된 상자에서 작성할 히스토그램 버킷 수를 지정합니다.

When Deleting Table, Index, or Column Stats, Cascade...

Columns

표 통계가 삭제되면 열 통계도 삭제됩니다.

Indexes

표 통계가 삭제되면 색인 통계도 삭제됩니다.

Partitions

표(또는 색인) 통계가 삭제되면 파티션 통계도 삭제됩니다.

Use Stats Table

통계 표는 하나 이상의 통계 집합을 가질 수 있습니다. 각 집합의 레이블은 통계 ID별로 지정됩니다(공란으로 둘 수도 있음).

For Deleting/Estimating/Computing stats

표시 및 기입되어 있으면 통계가 지정한 통계 표에서 기록 또는 삭제됩니다.

For Importing/Exporting stats

통계를 내보내거나 가져오는 통계 표입니다.

Copying Statistics

통계를 수집하는 데 시간이 소요되는 동일한 스키마가 두 개 이상 있을 경우 두 번째 스키마에서 수집하는 대신 한 스키마에서 다른 스키마로 통계를 복사할 수 있습니다.

On different databases

스키마가 다른 데이터베이스에 있을 경우 Toad는 다음 절차를 사용하여 통계를 복사합니다.

  1. 임시 표를 작성하여 통계를 보관합니다.

  2. 통계를 해당 표에 내보냅니다.

  3. 통계를 다른 데이터베이스에 복사합니다.

  4. 표의 통계를 스키마로 가져옵니다(드롭다운을 사용하여 표 공간 선택).

On the same database

스키마가 동일한 데이터베이스에 있을 경우 Toad는 임시 표를 작성하지 않습니다. PL/SQL 블럭으로 전체 복사를 수행할 수 있습니다.


프로파일러 분석 개요

Oracle8i는 기존 PL/SQL 응용프로그램을 프로파일하고 성능의 병목 현상을 확인하기 위해 Probe Profiler API를 제공합니다. 수집한 프로파일러(성능) 데이터는 성능 향상의 노력 또는 PL/SQL 응용프로그램의 코드 적용 범위를 확인하는 데 사용할 수 있습니다. 응용프로그램 개발자는 코드 적용 범위 데이터를 사용하여 점차 테스팅에 초점을 맞춥니다.

프로파일러 API는 PL/SQL 패키지, DBMS_PROFILER로서 구현되며 PL/SQL 프로파일러 데이터를 수집하고 계속 저장할 수 있도록 서비스를 제공합니다.

주의: Tru64 플랫폼의 Oracle 서버에서 Profiler를 실행 중인 경우 통계를 수집할 수 없습니다.

DBMS_PROFILER 사용

응용프로그램 성능을 향상시키는 것은 반복 프로세스입니다. 반복할 때마다 다음이 포함됩니다.

  • 프로파일러 데이터 수집을 활성화한 상태로 하나 이상의 벤치마크 테스트로 응용프로그램을 연습합니다.

  • 프로파일러 데이터를 분석하고 성능 문제를 확인합니다.

  • 문제를 해결합니다.

이 프로세스를 지원하기 위해 PL/SQL 프로파일러가 실행 부분을 지원합니다. 실행에는 프로파일러 데이터 수집을 활성화한 상태로 벤치마크 테스트를 통해 응용프로그램을 실행하는 것이 포함됩니다. 기본 Toad 도구 모음의 Toggle PL/SQL Profiling 단추를 눌러 실행의 시작과 끝을 제어할 수 있습니다. 단추의 아이콘은 스톱워치입니다.

일반적인 세션에는 다음이 포함됩니다.

  • 세션에서 프로파일러 데이터 수집 시작.

  • 프로파일러/코드 적용 데이터에 필요한 PL/SQL 코드 실행

  • 프로파일러 데이터 수집 중지.

PL/SQL 유닛의 처음 실행 등의 일부 PL/SQL 작업에는 실행 중인 PL/SQL 유닛의 바이트 코드를 로드하기 위해 카탈로그 표 I/O가 포함될 수 있습니다. 패키지 프로시저 또는 함수를 처음 호출할 때 패키지 초기화 코드를 실행하는 데 다소 시간이 걸릴 수도 있습니다. 시간 초과를 막으려면 프로파일 데이터를 수집하기 전에 데이터베이스를 준비해야 합니다. 준비에는 프로파일러 데이터를 수집하지 않고 응용프로그램을 한 번에 실행하는 것이 포함됩니다.

수집된 데이터

Probe Profiler API로 세션에서 실행되는 명명된 라이브러리 유닛 모두 프로파일 정보를 생성할 수 있습니다. 프로파일러는 각 행이 실행되는 횟수, 행을 실행하는 데 소요된 총 시간 및 행의 특정 실행에 소요된 최소 및 최대 횟수 등의 PL/SQL 가상 시스템 레벨에서 정보를 수집합니다.

프로파일 정보는 데이터베이스 표에 저장됩니다. 이렇게 하면 데이터에 ad-hoc 질의를 수행할 수 있으며, 사용자 정의 가능한 보고서(요약 보고서, 최신 행, 코드 적용 데이터 등) 및 분석 기능을 구성할 수 있습니다.

Oracle 8i를 통해 예제 텍스트 보고서 작성기가 PL/SQL 데모 스크립트와 함께 제공됩니다.

Java 디버거와 함께 DBMS_PROFILER 사용

Toad에서 PL/SQL을 디버깅할 때뿐만 아니라 Java 디버거와 Profiler를 함께 사용할 수 있습니다. 그러나 출력은 어렵습니다.

Java 코드를 프로파일할 때 코드가 모두 Anonymous Block으로 보호되고, 그런 다음 해당 블럭이 프로파일됩니다. PL/SQL을 디버깅할 때 구문 당 시간이 부여됩니다. JDWP 디버깅에서 Toad는 전체 프로시저의 시간을 반환합니다.


프로파일러 설정

Toad 스키마 또는 모든 개인 사용자 스키마에서 실행할 수 있도록 프로파일러를 설정할 수 있습니다. 아래 단계에 설명된 대로 경우마다 다른 스크립트가 실행됩니다.

주: PL/SQL Profiler에 필요한 최소 Oracle 데이터베이스 버전은 Oracle8i입니다.

SYS.DBMS_PROFILER 패키지

SYS.DBMS_PROFILER 패키지가 있는지 확인합니다. 이 패키지가 로드되지 않았을 경우 다음과 같이 작성해야 합니다.

  1. SYS로 Toad 를 통해 Oracle에 로그인합니다.

  2. Editor에 Oracle home>\RDBMS\ADMIN\PROFLOAD.SQL 스크립트를 로드합니다.

  3. SQL Editor 메뉴에서 Execute as Script를 선택하거나 F5를 누릅니다.

  4. DBMS_PROFILE 패키지의 GRANT EXECUTE가 PUBLIC 또는 프로파일링 기능을 사용할 사용자에게 부여되었는지 확인합니다.

프로파일러 서버측 개체 설치

프로파일러에 필요한 서버측 개체를 설치하려면 Server Side Objects Install 마법사를 실행합니다.


프로파일러 필터

Profiler Analysis 창에서 Filter toolbar 단추를 누르면 이 창이 나타납니다.

이렇게 하면 사용자가 Oracle 8i Profiler 통계 데이터 내부 또는 외부에서 필터링할 수 있습니다.


프로파일러 사용

이 항목에서는 프로파일러 사용 방법 및 데이터를 필터링 및 삭제하여 사용자 정의 프로파일을 작성하는 데 사용할 수 있는 일부 옵션에 대해 설명합니다. 프로파일러를 아직 설정하지 않은 경우 프로파일러 설정의 항목을 참조하십시오.

Profiler를 사용하려면

  1. Toad를 시작하고 Database|PL/SQL Profiling 메뉴 옵션을 선택하여 프로파일러를 켭니다.

또는

기본 Toad 도구 모음에서 Toggle PL/SQL Profiling [image] 단추를 누릅니다.

  2. Execute(번개 모양) 단추를 사용하여 Schema Browser 또는 Editor에서 프로시저를 실행합니다. 실행 중인 프로시저의 설명을 입력하라는 메시지가 표시됩니다. 결과를 분석 중일 때 Profiler Analysis 창 또는 Editor Profiler 탭에 나타납니다. 프로시저를 여러 번 실행하여 프로파일링 표에 데이터 일부를 가져옵니다.

  3. Toggle PL/SQL Profiling [image] 단추를 눌러 완료하면 프로파일링을 끕니다.

주: 다른 Toad 창으로 전환할 때 프로파일러를 전환한 상태로 두지 마십시오. 그렇지 않으면 Toad가 다른 창을 채우기 위해 실행하는 질의에서 프로파일러 데이터가 수집됩니다.

  4. Database|Profiler Analysis 메뉴 항목을 선택합니다. Profiler Analysis 창이 나타납니다. 제공된 정보를 읽는 방법에 대한 자세한 내용은 프로파일러 분석을 참조하십시오.


프로파일러 분석

데이터의 3가지 레벨이 있습니다. 상위 레벨은 프로파일링이 활성화되어 있는 동안 실행된 각 프로시저의 개별 "Runs"입니다. 개별 실행의 실행 상태에 대해 하나의 항목을 두 번 누릅니다. 이 레벨에서 프로파일하는 도중 마우스를 두 번 눌러 호출한 개별 procs의 라인별 성능을 확인할 수 있습니다.

창의 위쪽 반은 프로시저의 각 구성 요소를 실행하는 데 필요한 시간을 백분율로 표시하는 그래프입니다.

원형 차트의 레이블만 볼 수 있을 경우 창의 크기를 가로로 조절하여 더 많은 그림 공간을 부여하십시오.

또한 차트의 레이블은 가장 빠르고 가장 느린 평균 유닛 또는 코드 행의 실제 실행 시간을 표시합니다.

창의 아래쪽 반에는 Run Number, Procedure, Timestamp, Comment 및 Total Time to execute 등의 실행이 나열됩니다. 열 머리글을 눌러 열을 정렬할 수 있습니다.

실행 세부 사항

실행 열기

실행을 드릴다운하면 Unit Type, Owner, Unit Name 및 Total Time to execute 등의 실행 세부 사항이 나열됩니다.

유닛 열기

F_CALC_COMMISSION 유닛을 드릴다운할 때 실행 및 프로파일된 코드 행도 표시됩니다. 열 머리글이 Line Number, Passes(각 코드 행이 실행된 횟수), Total Time to execute the line, Min Time, Max Time 및 코드 행 자체로 변경됩니다.

분석 도구 모음

창의 위쪽 반과 아래쪽 반 사이에 함수 도구 모음이 있습니다.

단추 | 명령
 | 드릴 다운/드릴 업 -원형의 쐐기 모양을 선택하고 두 번 눌러 드릴 다운합니다. 여기에 프로시저의 각 구문을 실행하는 데 필요한 시간이 표시됩니다. 다시 드릴 업하려면 Profiler Analysis 도구 모음의 Less Detail 왼쪽 화살표 단추를 누릅니다. More Detail 오른쪽 화살표 단추는 드릴 다운하는 데 사용할 수도 있습니다.
 | Editor에서 선택한 프로시저를 엽니다. (선택한 프로시저를 두 번 눌러도 이와 같은 작업을 수행할 수 있습니다.)
 | 데이터 새로 고침 - 다른 창으로 전환하여 프로파일 분석을 위해 프로시저를 실행하고 Profiler Analysis 창으로 다시 전환하면 마우스 단추를 눌러 프로파일러 표를 다시 질의합니다.
 | 특정 프로파일러 분석 데이터, SYS.DBMS_OUTPUT의 모든 호출을 필터링하거나 숨기려면 여기를 누르고 정보를 선택하여 나타나는 대화상자에서 숨깁니다.
 | 프로파일러 표에서 선택한 실행을 삭제합니다.
 | 원형 차트로 표시됩니다.
 | 막대형 차트로 표시됩니다.
 | 차트를 회전합니다.
 | 그래프 속성 - 그래프 및/또는 그룹의 디스플레이를 특정 비율 또는 값 아래로 변경합니다. 작은 쐐기 모양 또는 막대가 여러 개 있을 경우에 유용합니다. Graph Properties 대화상자에서 배경색에 그라데이션 효과를 설정할 수도 있습니다. 예: 왼쪽에서 오른쪽 - 파란색에서 검정색
Procedure 상자 | 하나 이상의 프로시저를 선택하여 눈금에 표시합니다. 다른 프로시저를 선택하거나 드롭 다운 목록에서 프로시저를 모두 선택할 때까지 다른 사항은 필터링됩니다.

프로파일러 데이터 숨김

목록을 마우스 오른쪽 단추로 누르면 남은 데이터를 더 잘 분석할 수 있도록 일부 데이터를 잠깐 숨길 수 있습니다. 예를 들어, 특정 구문이 전체 실행 시간의 95%를 차지할 경우 1% 아래의 남은 구문과 함께 숨기면 그래프의 보다 큰 상대 비율로 증가합니다.


Editor Profiler 탭

Editor에서 Profiler 탭은 루트 노드로 프로파일러 실행을, 하위 노드로 프로파일러 유닛을 표시합니다. 후자는 프로파일러 실행 동안 실행된 실제 코드 유닛입니다. 이러한 유닛에는 프로파일러 실행 데이터가 수집되는 동안 실행된 익명 차단, 프로시저, 함수 및 패키지가 포함됩니다. 하위 노드에는 실제 행 데이터가 포함됩니다.

이 탭에서 데이터 개요를 볼 수 있지만 Profiler Analysis 창의 그래프는 볼 수 없습니다.

Editor로 프로파일러 실행 또는 유닛을 열고 show executable line indicators in gutters 옵션이 선택되어 있으면 실행 파일 행 표시기가 다음과 같이 표시됩니다.

표시기 | 의미
녹색 사각형이 들어간 파란색 점 | 행이 실행되었습니다.
빨간색 원이 들어간 파란색 점 | 행이 실행되지 않았습니다.

Toad가 유닛이 마지막으로 실행된 시기를 확인할 수 없을 경우 표준 파란색 점 행 표시기가 나타납니다.

관련 항목

프로파일러 분석

프로시저 편집기 프로파일러 노드

Procedure Editor Profiler 탭 도구 모음


편집기 프로파일러 노드

노드의 각 레벨에는 열 내용과 약간 다른 의미가 있습니다.

프로파일러 실행

열 | 내용
Run Comment | 루트 노드는 괄호 안의 프로파일러 실행을 수행한 사용자 앞의 프로파일러 실행 설명에 의해 명시됩니다. 예: AA_TEST_1 (MICHAEL)
Total Execution Time (secs) | 실행에 포함된 모든 유닛 실행에 소요되는 총 시간(초)
Run Object | 프로파일러 실행에 해당하는 개체. 실행 [image] 단추가 눌러져 있을 때 편집기에 Editor에 로드되는 개체입니다.
Run Date | 실행이 완료된 날짜 및 시간.

프로파일러 유닛

열 | 내용
Run Comment | 유닛 이름 앞의 유닛 소유자. 유닛 형식은 해당 노드의 아이콘에 의해 식별할 수도 있습니다. 유닛에서 익명 차단이라고 할 경우 데이터베이스에 실제로 나타나는 개체가 아닙니다.
Total Execution Time (secs) | 해당 유닛을 실행하는 데 소요되는 총 시간(초).
Run Object | 이 레벨에는 공백으로 표시됩니다.
Run Date | 마지막 DDL 시간(비 익명 차단에만 해당). 개체가 데이터베이스에서 마지막으로 수정 및 실행된 날짜 및 시간입니다. 마지막 DDL 시간은 ALL_OBJECTS 보기에서 질의가 이루어집니다.

유닛이 빨간색으로 나타나면 프로파일러가 실행된 후 마지막으로 수정된 것이며, Toad는 Editor에서 해당 개체의 프로파일러 행 맵을 표시할 수 없습니다.

프로파일러 데이터 행

열 | 내용
Run Comment | 유닛 원본 코드의 행 번호.
Total Execution Time (secs) | 괄호로 실행한 수 앞의 실행되는 모든 행의 실행 시간. 예를 들어, 문제의 행이 루프 내에 있으면 여러 번 실행되었을 수 있습니다.
Run Object | 행을 한 번 실행하는 데 소요되는 평균 실행 시간.
Run Date | 행의 원본 텍스트.

관련 항목

Procedure Editor Profiler 탭

Procedure Editor Profiler 탭 도구 모음

프로파일러 설정


Editor Profiler 탭 도구 모음

작은 도구 모음이 Editor Profiler 탭에 있습니다. 명령을 사용하여 Profiler 데이터를 보는 방법을 제어할 수 있습니다.

아이콘 | 명령
 | 데이터를 새로 고칩니다.
 | 노드를 모두 펼칩니다.
 | 노드를 모두 접습니다.

관련 항목

Procedure Editor Profiler 탭

프로파일러 설정


여러 개체 재구성 개요

시간이 초과되면 색인이 조각납니다. 원본 표가 증가하거나 줄어들면 색인의 저장 매개 변수가 부적합하게 되는 경우도 있습니다. 이러한 문제가 발생하면 색인은 더 이상 데이터베이스 성능을 향상시킬 수 없습니다. 이러한 이유로 색인을 주기적으로 재구성해야 합니다.

재구성할 색인을 결정하고 해당 색인을 구성하기 위해 Rebuild Multiple Objects 창에서 색인을 분석할 수 있습니다. 필요한 경우 한 번에 여러 표를 재구성할 수도 있습니다.

Rebuild Multiple Objects를 액세스하려면

  • Database|Optimize 메뉴에서 Rebuild Multiple Objects을 선택합니다.

Indexes

이 창의 기능을 기본적으로 검사하고 재구성할 뿐만 아니라 색인에 대한 다음과 같은 작업 또한 수행할 수 있습니다.

  • 범위 크기에 따라 색인을 다양한 표 공간으로 이동합니다.

  • 범위 크기를 조절하여 범위 수를 최소화합니다.

  • 범위 크기를 표준으로 조절하여 범위 수를 최소화하고 표 공간의 조각화를 줄입니다.

  • 분석하기 전에 조건을 지정합니다.

여러 색인을 재구성할 때 일반적으로 다음 순서대로 작업하게 됩니다.

  1. 색인 목록을 로드합니다. 색인 로드 및 지우기를 참조하십시오.

  2. 조건 및 색인을 선택하고 색인을 분석합니다. 색인 검사를 참조하십시오.

  3. 필요한 경우 색인을 재구성합니다. 색인 재구성을 참조하십시오.

Tables

한 번에 여러 표를 쉽게 재구성할 수 있습니다. 뿐만 아니라, Conditional Thresholds를 사용하여 특정 조건에 부합하는 행의 재구성을 제한할 수 있습니다.


전자 메일 알림 - 다중 색인 재구성

전자 메일 알림 - 다중 개체 재구성

색인 재구성을 완료하면 전자 메일 알림을 받을 수 있도록 선택할 수 있습니다. 재구성에 다소 시간이 소요될 경우에 도움이 됩니다. 색인을 설정하여 재구성하면 Toad가 해당 사용자에게 완료 시기를 알립니다.

전자 메일 알림을 설정하려면

  1. Email Notification 탭을 누르고 해당 상자를 표시합니다. 전자 메일로 알림을 받도록 선택한 다음 HTML 결과 또는 일반 텍스트 요약을 확인하여 전자 메일에 포함할 내용을 지정합니다. 기본값은 HTML 전자 메일입니다.

  2. 전자 메일 옵션을 설정합니다. View|Options|Email Settings를 선택하고 전자 메일 설정에 설명된 대로 받는 사람 및 전자 메일 계정에 적합한 옵션을 설정합니다.


색인 로드 및 지우기

Index 목록에 색인을 여러 방법으로 로드할 수 있습니다. 색인 로드는 누적됩니다. 도구 모음에서 다른 Load Indexes 단추를 선택하여 사용자 정의 색인 목록을 구성할 수 있습니다.

Load My Indexes

이 옵션은 활성화된 스키마의 모든 색인을 Index 또는 Table 목록에 로드합니다. 분할된 색인이 있을 경우 각 파티션은 눈금의 별도 행에 배치됩니다.

색인을 로드하려면

  1. Indexes 탭을 누른 다음 도구 모음에서 Load My…를 누릅니다.

  2. 색인을 로드하면 단추가 비활성화됩니다. 아래에 설명된 대로 전체 색인 목록을 지우거나 이 창의 활성화된 세션을 변경하여 단추를 다시 활성화할 수 있습니다.

  3. 이 창에서 활성화된 세션을 변경하면 색인 목록이 바로 지워집니다.

Load Indexes Like

"LIKE" 조건 절에 따라 색인을 로드하기로 선택할 수 있습니다.

LIKE 절을 작성 및 사용하려면

  1. Indexes 탭을 누른 다음 도구 모음에서 Load … Like를 누릅니다. Load… Like 대화상자가 나타납니다.

  2. 드롭다운 메뉴에서 Index Owner를 선택합니다.

  3. 색인 또는 표 이름에 지정할 LIKE 조건을 입력합니다. 입력한 텍스트는 Oracle 질의에 바로 사용됩니다. 이 필드는 대소문자를 구분하며 다음 와일드 카드 문자가 적용됩니다.

  4. 여러 문자의 경우 %

  5. 단일 문자의 경우 _

  4. <CTRL> 또는 <SHIFT> 키를 사용하여 스키마를 선택하거나 여러 스키마를 선택합니다.

  5. OK를 누릅니다. 사용자/스키마에 대한 색인 목록이 눈금에 로드됩니다.

Load Indexes by User

DBA 역할이 있을 경우 하나 이상의 스키마에 속하는 색인을 로드할 수도 있습니다.

사용자별로 색인을 로드하려면

  1. Indexes 탭을 누른 다음 도구 모음에서 Load … by User를 누릅니다. Load… by User 창이 나타납니다.

  2. <CTRL> 또는 <SHIFT> 키를 사용하여 스키마를 선택하거나 여러 스키마를 선택합니다.

  3. OK를 누릅니다. 사용자/스키마에 대한 색인 목록이 눈금에 로드됩니다.

Load Indexes by Tablespace

DBA 역할이 있을 경우 특정 표 공간에 속하는 색인을 로드할 수 있습니다.

표 공간별로 색인을 로드하려면

  1. Indexes 탭을 누른 다음 도구 모음에서 Load … by Tablespace를 누릅니다. Load Indexes by Tablespace 창이 나타납니다.

  2. <CTRL> 또는 <SHIFT> 키를 사용하여 표 공간을 선택하거나 여러 스키마를 선택합니다.

  3. OK를 누릅니다. 선택한 표 공간에 대한 색인 목록이 눈금에 로드됩니다.

Load Indexes by Table

표를 선택하여 색인을 로드할 수 있습니다.

표별로 색인을 로드하려면

  1. Indexes 탭을 누른 다음 도구 모음에서 Load … by Table을 누릅니다.

  2. <CTRL> 또는 <SHIFT> 키를 사용하여 사용자를 선택하거나 여러 사용자를 선택합니다.

  3. 해당하는 하나의 표 여러 개의 표를 선택합니다.

  4. OK를 누릅니다. 선택한 표에 대한 색인 목록이 눈금에 로드됩니다.

Load Indexes of Loaded and Checked Tables

표를 재구성했으면 로드 및 표시한 표의 색인을 바로 로드할 수 있습니다.

  1. Tables 탭을 누르고 표 로드 및 지우기에 설명된 대로 일부 표를 로드합니다.

  2. 표 이름의 왼쪽에 있는 확인란을 눌러 일부를 선택합니다.

  3. Indexes 탭을 누른 다음 도구 모음에서 Load Indexes of Loaded and Checked Tables를 누릅니다.

  4. OK를 누릅니다. 선택한 표에 대한 색인 또는 표 목록이 눈금에 로드됩니다.

Reload Indexes

로드한 색인 및 표에 대한 모든 저장 정보를 다시 로드할 수 있습니다. 텍스트 또는 이진 파일에서 색인을 로드한 후 모든 정보가 최신인지 확인하기 위해 사용할 수 있습니다.

색인을 다시 로드하려면

  1. Indexes 탭을 누른 다음 눈금에서 마우스 오른쪽 단추를 누르고 Reload all을 선택합니다.

  2. 모든 저장 정보가 다시 로드되고 현재 상태로 업데이트됩니다.

Clear Selected Rows

행을 선택한 다음 색인 또는 표 목록에서 지울 수 있습니다.

선택한 행을 지우려면

  1. 표 또는 색인 눈금에서 삭제할 색인을 선택합니다. <CTRL> 또는 <SHIFT> 키를 사용하여 여러 개를 선택합니다.

  2. 눈금에 마우스 오른쪽 단추를 누르고 메뉴에서 Remove Selected Rows를 선택합니다. 확인 상자가 나타납니다.

  3. Yes를 눌러 행을 삭제합니다.

Clear Entire Index List

전체 색인 목록을 지울 수 있습니다.

전체 색인 목록을 지우려면

  • Indexes 탭을 누른 다음 Clear … List [image] 단추를 누릅니다. 색인이 지워지고 Load my … 단추가 비활성화되어 있으면 활성화됩니다.


색인 검사

눈금에서 색인 목록을 선택하면 색인을 검사하여 재구성이 필요한지 확인할 수 있습니다. 표는 검사할 필요가 없지만 Conditional Thresholds를 설정하여 재구성 목적으로 확인할 표의 수를 제한할 수 있습니다.

색인을 검사하려면

  1. 검사할 색인을 선택합니다. 눈금 행을 눌러 색인 소유자의 왼쪽에 있는 상자를 확인합니다.

  2. Thresholds and Performance Options 탭을 누르고 모든 표준 임계값을 설정합니다. 색인을 재구성해야 할 때 정의됩니다. Toad에서 색인에 참조할 매개 변수를 알려줍니다.

  3. 도구 모음에서 Examine Checked Indexes [image] 단추를 누릅니다. 확인 상자가 나타납니다.

  4. Yes를 눌러 계속합니다. Toad는 색인을 검사하여 임계값 조건에 맞는지 확인합니다.

Toad가 색인 검사를 마치면 색인 목록 아래에 있는 행에 색인 목록의 권장 사항을 표시합니다. 이러한 권장 사항은 다음과 같이 나타납니다.

No Rebuild Recommended

Rebuild Recommended - 및 원인 설명

이제 색인을 일부 또는 모두 재구성할 수 있습니다. 색인 재구성을 참조하십시오.


색인 재구성

색인을 검사했거나 재구성할 색인을 이미 알고 있을 경우 색인을 재구성할 수 있습니다. 색인을 재구성할 때 저장 절 매개 변수도 변경할 수 있습니다. 자세한 내용은 저장 절을 참조하십시오.

Rebuild Recommended Indexes

색인 목록의 색인을 검사할 때 일부는 Rebuild Recommended로 표시되어 있을 수 있습니다. 이 색인은 다른 표시 없이 한 번에 재구성할 수 있습니다.

권장 색인을 재구성하려면

  • Indexes 탭 도구 모음에서 Rebuild Recommended Indexes [image] 단추를 누릅니다.

분석되고 재구성으로 표시된 색인이 재구성되고 색인 상태는 눈금의 색인 이름 아래에 표시됩니다.

Create Script to Rebuild Recommended Indexes

즉시 색인을 재구성하지 않아도 됩니다. 스크립트를 작성하여 나중에 재구성해도 됩니다.

스크립트를 작성하여 권장 색인을 재구성하려면

  • Indexes 탭 도구 모음에서 Create Script to Rebuild Recommended indexes [image] 단추를 누릅니다. 스크립트가 클립보드에 복사됩니다. 명령 프롬프트에서 재구성하려면 Editor에 붙여 넣은 다음 나중에 사용할 수 있도록 저장할 수 있습니다.

Rebuild Checked Indexes

재구성할 색인을 수동으로 선택할 수도 있습니다.

표시된 색인을 재구성하려면

  1. Indexes 탭에서 눈금의 왼쪽 열에 있는 확인란을 표시하여 재구성할 색인을 선택합니다.

  2. 도구 모음에서 Rebuild Checked Indexes [image] 단추를 누릅니다.

재구성으로 표시된 색인이 재구성되고 색인 상태는 눈금의 색인 이름 아래에 표시됩니다.

Create Script to Rebuild Checked Indexes

즉시 색인을 재구성하지 않아도 됩니다. 스크립트를 작성하여 나중에 재구성해도 됩니다.

스크립트를 작성하여 표시된 색인을 재구성하려면

  • Indexes 탭 도구 모음에서 Create Script to Rebuild Checked Indexes [image] 단추를 누릅니다. 스크립트가 클립보드에 복사됩니다. 명령 프롬프트에서 재구성하려면 Editor에 붙여 넣은 다음 나중에 사용할 수 있도록 저장할 수 있습니다.


표 로드 및 지우기

Table 목록에 색인을 여러 방법으로 로드할 수 있습니다. 색인 로드는 누적됩니다. 도구 모음에서 다른 Load Tables 단추를 선택하여 사용자 정의 색인 목록을 구성할 수 있습니다.

Load My Tables

이 옵션은 활성화된 스키마의 모든 표를 Table 목록에 로드합니다. 분할된 색인이 있을 경우 각 파티션은 눈금의 별도 행에 배치됩니다.

색인을 로드하려면

  1. Tables 탭을 누른 다음 도구 모음에서 Load My…를 누릅니다.

  2. 색인을 로드하면 단추가 비활성화됩니다. 아래에 설명된 대로 전체 색인 목록을 지우거나 이 창의 활성화된 세션을 변경하여 단추를 다시 활성화할 수 있습니다.

  3. 이 창에서 활성화된 세션을 변경하면 색인 목록이 바로 지워집니다.

Load Tables Like

"LIKE" 조건 절에 따라 표를 로드하기로 선택할 수 있습니다.

LIKE 절을 작성 및 사용하려면

  1. Tables 탭을 누른 다음 도구 모음에서 Load … Like를 누릅니다. Load… Like 대화상자가 나타납니다.

  2. 드롭다운 메뉴에서 Table Owner를 선택합니다.

  3. 색인 또는 표 이름에 지정할 LIKE 조건을 입력합니다. 입력한 텍스트는 Oracle 질의에 바로 사용됩니다. 이 필드는 대소문자를 구분하며 다음 와일드 카드 문자가 적용됩니다.

  4. 여러 문자의 경우 %

  5. 단일 문자의 경우 _

  4. <CTRL> 또는 <SHIFT> 키를 사용하여 스키마를 선택하거나 여러 스키마를 선택합니다.

  5. OK를 누릅니다. 사용자/스키마에 대한 표 목록이 눈금에 로드됩니다.

Load Tables by User

DBA 역할이 있을 경우 하나 이상의 스키마에 속하는 표를 로드할 수도 있습니다.

사용자별로 색인을 로드하려면

  1. Tables 탭을 누른 다음 도구 모음에서 Load … by User를 누릅니다. Load… by User 창이 나타납니다.

  2. <CTRL> 또는 <SHIFT> 키를 사용하여 스키마를 선택하거나 여러 스키마를 선택합니다.

  3. OK를 누릅니다. 사용자/스키마에 대한 표 목록이 눈금에 로드됩니다.

Load Tables by Tablespace

DBA 역할이 있을 경우 특정 표 공간에 속하는 색인을 로드할 수 있습니다.

표 공간별로 색인을 로드하려면

  1. Tables 탭을 누른 다음 도구 모음에서 Load … by Tablespace를 누릅니다. Load Tables by Tablespace 창이 나타납니다.

  2. <CTRL> 또는 <SHIFT> 키를 사용하여 표 공간을 선택하거나 여러 스키마를 선택합니다.

  3. OK를 누릅니다. 선택한 표 공간에 대한 표 목록이 눈금에 로드됩니다.

Reload Tables

로드한 색인 및 표에 대한 모든 저장 정보를 다시 로드할 수 있습니다. 텍스트 또는 이진 파일에서 색인을 로드한 후 모든 정보가 최신인지 확인하기 위해 사용할 수 있습니다.

색인을 다시 로드하려면

  1. Tables 탭을 누릅니다.

  2. 눈금에서 마우스 오른쪽 단추를 누르고 Reload all을 선택합니다.

  3. 모든 저장 정보가 다시 로드되고 현재 상태로 업데이트됩니다.

Clear Selected Rows

행을 선택한 다음 색인 또는 표 목록에서 지울 수 있습니다.

선택한 행을 지우려면

  1. 표 또는 색인 눈금에서 삭제할 색인을 선택합니다. <CTRL> 또는 <SHIFT> 키를 사용하여 여러 개를 선택합니다.

  2. 눈금에 마우스 오른쪽 단추를 누르고 메뉴에서 Remove Selected Rows를 선택합니다. 확인 상자가 나타납니다.

  3. Yes를 눌러 행을 삭제합니다.

Clear Entire Table List

전체 색인 목록을 지울 수 있습니다.

전체 색인 목록을 지우려면

  • Tables 탭을 누른 다음 Clear … List [image] 단추를 누릅니다. 색인이 지워지고 Load my … 단추가 비활성화되어 있으면 활성화됩니다.


표 재구성

표를 로드 및 선택한 후 즉시 재구성하거나 스크립트를 작성하여 나중에 재구성할 수 있습니다.

선택한 표를 재구성하려면

  • 표를 선택한 후 Rebuild Tables [image] 단추를 누릅니다.

완료되면 Toad가 눈금에 상태 보고서를 표시합니다. 성공적으로 재구성된 표 상태는 녹색, 문제가 있을 경우에는 빨간색으로 표시됩니다.

재구성 스크립트를 작성하려면

  • 표를 선택한 후 Create Script to Rebuild Tables [image] 단추를 누릅니다. 스크립트가 클립보드에 복사되고 Editor에 스크립트를 붙여 넣을 수 있습니다.


표준 임계값

검사용 임계값을 설정할 수 있습니다. 표준 및 조건의 두 가지 임계값 종류가 있습니다. 색인 목록을 제한하기 위해 사용하는 조건 임계값에 대한 자세한 내용은 Conditional Thresholds를 참조하십시오.

선택한 색인을 검사하려면 적어도 하나의 표준 임계값이 설정되어 있어야 합니다.

표준 임계값은 Mark Indexes for Rebuild only if:라는 영역의 Thresholds 탭 중간에 있습니다. 기본값으로 세 개의 임계값이 모두 표시되어 있습니다.

Height >

색인에 분할이 있을 경우 높이가 증가합니다. 높이가 높을 경우 이러한 분할을 줄일 수 있도록 색인을 재구성합니다.

이 옵션의 기본값은 4이지만 Toad는 지정한 숫자보다 더 큰 높이를 찾을 수 있습니다.

? Deleted Rows >

데이터베이스의 행을 삭제한 경우 삭제된 행의 표시는 계속 색인의 공간을 차지합니다. 색인을 재구성하여 이러한 표시를 제거하면 사용 속도가 빨라집니다.

기본 백분율은 25입니다. 필요한 경우 이 값을 위 또는 아래로 조정할 수 있습니다.

% Storage used < and % Storage used >

색인에 저장할 정보 양에 비해 공간이 너무 많이 있거나 너무 많은 저장 공간을 사용할 경우에도 데이터베이스 성능이 저하될 수 있습니다. 이 두 가지 옵션을 사용하여 색인에 최적의 저장 공간 범위를 선택하고 재구성에 맞지 않는 색인을 표시합니다.


Conditional Thresholds

Conditional Thresholds에서 분석하기 전에 고려하여 색인 목록의 색인을 제거할 수 있습니다. 이렇게 하면 색인마다 전체 분석하느라 시간을 소비하지 않고도 색인 목록을 즉시 줄일 수 있습니다.

Conditional Thresholds를 사용하려면

  1. Thresholds 탭에서 Conditional Thresholds를 위에서 설명한 대로 설정합니다.

  2. Indexes 또는 Tables 탭을 누르고 눈금에 마우스 오른쪽 단추를 누른 다음 Remove items that fail consideration thresholds를 선택합니다. 실패한 항목은 눈금에서 삭제되며, 분석할 색인만 분석할 수 있습니다(색인 검사 참조).

Conditional Thresholds 설정

"Consider Objects for Rebuild only if:"라는 이름의 Thresholds 탭 영역에서 다음 옵션 중 하나 이상을 선택합니다.

Size is greater than

이 옵션을 사용하여 색인 크기가 특정 양보다 작은 위치에서 모든 표 및 색인을 제거할 수 있습니다. Toad가 지정한 것보다 큰 크기를 분석합니다. 이 숫자를 MB 또는 KB로 지정합니다.

# Extents is greater than

이 옵션을 사용하여 범위의 수가 지정한 양보다 작을 때 색인을 모두 제거할 수 있습니다.

Conditional Thresholds 사용

긴 색인 목록이 있고 전체 목록을 완전히 분석하고 싶지 않을 경우 Conditional Thresholds를 사용합니다.


Performance 옵션

Performance 옵션을 사용하여 개체 재구성 세션의 성능에 영향을 주는 매개 변수를 설정할 수 있습니다. Performance 옵션은 Thresholds and Performance Options 탭의 아래에 있습니다.

Tables and Indexes

Use ‘Online’ option

이 옵션을 표시할 경우 Toad는 사용 중인 동안 표 또는 색인을 재구성하거나 움직일 수 있습니다.

Parallel

이 명령을 표시하여 색인을 재구성할 때 PARALLEL 키워드를 사용합니다. 표시되어 있으면 다음 확인란이 활성화됩니다.

  • Degree - 이 상자를 표시하고 옆의 숫자 필드에서 정도를 설정합니다.

  • Alter indexes to noparallel after rebuild - 표시되어 있으면 색인이 재구성된 후 Toad에서 "alter index … no parallel command"를 발급합니다.

Refresh Index Data

이 라디오 단추를 사용하여 재구성 후 색인을 새로 고치는 방법을 선택할 수 있습니다.

  • Do not refresh index info after rebuilds - 이 옵션은 색인 데이터를 전혀 다시 로드하지 않습니다.

  • Refresh info for each index after each rebuild - 이 옵션은 색인이 재구성된 후 즉시 색인 데이터를 다시 로드합니다.

  • Refresh info for all indexes after all rebuilds are complete - 이 옵션은 선택한 색인이 모두 재구성된 후 재구성된 모든 색인의 데이터를 다시 로드합니다. 이 옵션은 마우스 오른쪽 메뉴에서 "Reload all"을 선택하는 것과 동등합니다.

  • Rebuild associated indexes with tables - 선택한 표와 관련된 색인을 모두 재구성하려면 이 상자를 선택합니다.

Indexes Only

Nologging

이 명령을 표시하여 색인을 재구성할 때 NOLOGGING 키워드를 사용합니다. 표시되어 있으면 다음 확인란이 활성화됩니다.

Alter indexes to logging after rebuild

표시되어 있으면 색인이 재구성된 후 Toad에서 "alter index … logging command"를 발급합니다.

Change Sort Area Size for this session to:

이 명령을 사용하여 재구성 세션에 대한 색인 정렬 영역 크기를 설정할 수 있습니다. 이 값은 KB 또는 MB 단위로 설정할 수 있습니다(1씩 증가). 기본값은 10MB입니다.

After Rebuilds, change sort area size to:

이 확인란에서 세션을 재구성한 후 정렬 영역 크기를 특정 크기로 설정할 수 있습니다.


저장 절

재구성의 권장 또는 수동 여부와 상관 없이 재구성 도중 저장 절 매개 변수를 변경할 수 있습니다. 이를 사용하여 범위 크기를 일정하게 유지하고 크기를 적절히 조절하거나 다른 표 공간으로 색인을 이동합니다.

저장 절을 다음과 같이 조정할 수 있습니다.

  • PCTINCREASE 지정

  • Next 범위 = Initial 범위로 설정

  • 최소 및 최대 크기를 지정하면서 특정 비율로 범위 크기 조절

  • 범위 크기 정의

Change Extent Sizes

또한 범위 크기도 변경할 수 있습니다. 이 기능을 사용할 경우 사용하기 전에 반드시 색인을 검사합니다. %used가 요소이므로 이 값은 색인을 검사하여 얻을 수 있습니다. 이것은 PCTUSED 저장 매개 변수가 아닙니다. 사용 중인 색인의 할당 저장 공간의 실제 비율을 참조합니다.

이 옵션은 창의 상단에 설정되어 있는 모든 옵션을 무시합니다.

범위 크기를 최소한 #로 조정하려면

이 옵션이 선택되어 있으면 각 색인의 새 범위 크기는 다음과 같이 계산됩니다.

  1. 작업 크기=총 크기 * % 사용.

  2. 작업 크기는 설명된 대로 "Make Extent this size" 또는 "Just Round All Extent Sizes to the Nearest Power of..."를 통해 전달됩니다. 결과 값은 새 initial_extent 크기입니다. 또한 새 next_extent 크기입니다. Pctincrease는 0으로 설정되어 있습니다.

  • 알고리즘을 통해 작업 값을 실행하고자 하지 않을 경우 "Just Round"를 선택하고 1에 가장 가깝게 사용할 숫자를 설정합니다. 색인마다 다른 크기가 될 수 있으므로 권장하는 방법은 아니지만 표 공간 조각화에는 좋은 방법입니다.

  • 범위 크기에 따라 표 공간을 조정하기로 구성한 경우 Toad는 원본 크기가 아닌 새로 계산된 크기를 사용합니다.

주의: 인덱싱된 일부 표가 큰 임시 표로 사용되고, 보통 비어 있지만 때때로 채워져 있을 경우 표에 0퍼센트가 사용되었으므로 검사할 때 "재구성 권장"으로 표시될 수 있습니다. 이러한 경우 재구성하는 동안 Adjust Extent Sizes를 사용하면 작은 범위로 색인이 구성되며, 나중에 데이터를 모두 수용하지 못할 수도 있습니다. 이 문제를 피하려면 전체 임시 표를 사용하거나 0퍼센트를 사용하여 색인을 재구성하지 마십시오.

Tablespaces

이 탭에서 다른 표 공간으로 색인을 모두 이동하거나 크기에 따라 선택적으로 이동하기로 선택할 수 있습니다.

  • 색인의 크기에 따라 표 공간으로 색인을 이동하기로 선택하고 Extents 탭에서 "By Index Size"를 선택한 경우 색인의 총 크기에 따라 크기가 달라집니다.

  • 색인의 크기에 따라 표 공간으로 색인을 이동하기로 선택하고 Extents 탭에서 "By Extent Size"를 선택한 경우 NEXT 범위 크기와는 반대로 INITIAL 범위 크기에 따라 크기가 달라집니다.


Road Map 개요

Code Road Map은 데이터베이스 내의 복잡한 PL/SQL 상호 종속 관계를 그래픽으로 표시합니다. Code Road Map을 응용프로그램 코드의 개발자 모델로 간주할 수 있습니다.

Road Map은 Code Only 및 Code Plus Data의 두 개의 다른 레벨을 표시합니다.

Code Only

Code Only 버전에서는 호출 스택 종속 관계를 런타임에서 그래픽으로 볼 수 있습니다. 이 모드에는 다음과 같은 세 가지 추가 옵션이 있습니다.

  • expand packages for calls into them

  • include calls to SYS owned PL/SQL

  • include calls to other schema’s PL/SQL

Code Plus Data

Code Plus Data 다이어그램에서 코드가 참조하는 데이터베이스 개체 및 방식(예: 읽기 대 쓰기)을 눈으로 직접 확인할 수 있습니다. 이 다이어그램에서 관련 트리거 및 보기를 포함시킬 수도 있습니다. 원래 보기는 표로 취급됩니다.


Code Road Map 도구 모음

단추 | 명령
 | 모델로 만들 새 코드를 선택하여 새 맵 을 작성합니다.
 | 모델 창을 지우고 초기 시작 상태로 돌아갑니다.
 | 활성 데이터베이스 세션을 변경합니다.
 | 저장된 맵 파일(.crm 확장자)을 엽니다.
 | 새 이름으로 맵을 저장합니다.
 | 현재 맵을 저장합니다.
 | 텍스트 파일로 다이어그램을 저장 합니다.
 | 코드 맵의 비트맵 버전을 작성합니다.
 | 코드 맵의 모델 부분을 인쇄합니다.
 | Code Road Map Info 단추를 사용하여 저장된 코드 맵에 설명을 추가합니다.
 | Collapse/Expand Package View: Collapse Package View 상태이면 참조되는 모든 하위 유닛이 그래픽 모델의 개체 형식 아래에 포함됩니다. 코드 모델 읽기를 참조하십시오.
 | 다이어그램을 새로 고칩니다.
 | 개체 스크립트를 작성합니다. 이렇게 하면 DDL Script 대화상자가 열리고, 여기서 개체 스크립트 작성에 사용할 옵션을 선택할 수 있습니다. 스크립트가 클립보드에 복사되고 Editor에 스크립트를 붙여 넣을 수 있습니다. 주: Script 대화상자는 선택 사항인 Quest DBA Module과 함께 Toad의 상용 버전에서만 사용할 수 있습니다.
 | 데이터베이스 개체의 색상을 변경합니다.
 | 그래픽 모델을 확대 또는 축소합니다.
 | 이전 자동 레이아웃 / 다음 자동 레이아웃.


모델로 만들 코드 선택

Database|Report|Code Road Map에서 Code Road Map을 액세스합니다.

Code Road Map을 처음 열면 로드된 맵이 없습니다.

아이콘 | 기능
 | 새 맵을 작성하려면 New Map 단추를 누릅니다.
 | 저장된 맵을 열려면 Open Map 단추를 누릅니다. 최근에 연 마지막 맵이 드롭다운에 표시됩니다.

New Map

새 맵을 작성하기로 선택하면 Model Code 대화상자가 나타납니다. 이 대화상자에서 매핑할 코드 및 매핑할 때 사용할 옵션을 선택할 수 있습니다.

Schema

매핑할 코드가 있는 스키마를 선택합니다.

Code Type

코드 유형의 드롭다운 목록에서 선택할 수 있습니다. Toad는 함수, 패키지, 프로시저 및 트리거 매핑을 지원합니다.

Code Unit

위에서 선택한 형식의 개체가 코드 유닛용 드롭다운에 채워집니다. 매핑할 유닛을 선택합니다.

Sub Unit

선택한 코드 유형이 패키지일 경우 해당 패키지의 다양한 부분이 하위 유닛 드롭다운에 포함되며 알파벳 순서로 정렬됩니다. 기본값으로, 첫 번째 하위 유닛이 매핑에 선택됩니다.

Levels to Model

모델로 만들 시작 개체에서 레벨 수를 입력합니다. 기본값은 10입니다.

Display Mode

  • Code Only - 개체가 호출하는 코드만 모델로 만들려면 Code Only를 선택합니다.

  • Code + Data - 개체가 호출하는 코드 및 참조하는 데이터(표, 보기 등) 모두 모델로 만들려면 Code + Data를 선택합니다.

Display Options

이 옵션은 맵의 시각적인 디스플레이에만 영향을 줍니다. 맵의 데이터는 다음 옵션을 선택해도 영향을 받지 않습니다.

  • Expand packages and types for calls

  • Include triggers (for Code + Data)

  • Include views (for Code + Data)

  • Include calls to SYS-owned objects

  • Include calls to other schema PL/SQL


코드 모델 읽기

코드 모델은 SQL Modeler를 사용하여 작성할 수 있는 모델과 유사한 방식으로 설계되어 있습니다.

최종 모델은 창의 왼쪽 패널에 있는 개체 형식에 의해 구성된 계층 구조 트리의 구성 요소 목록으로 구성되어 있습니다. 오른쪽 패널은 코드의 그래픽 모델입니다.

브라우저

창의 왼쪽에 있는 트리 보기 브라우저를 사용하여 맵 크기를 확인할 수 있습니다. 또한 개체 간을 이동할 때도 사용할 수 있습니다.

트리 보기는 개체 형식에 의해 구성됩니다. 예를 들어, Procedures 노드 아래에 모든 프로시저가 나열되고, Tables 노드 아래에 모든 표가 나열됩니다.

  • 트리 보기의 개체 및 해당 개체의 오른쪽 중앙에 있는 그래픽 모델을 누릅니다.

  • 개체에 마우스 오른쪽 단추를 눌러 해당 개체에 대한 Schema Browser의 팝업 메뉴를 표시합니다.

  • Toad가 해당 개체 형식의 설명을 지원할 경우 F4를 눌러 설명을 수행합니다.

  • 설명을 수행하려면 개체를 두 번 누릅니다.

그래픽 모델

각 개체 목록에는 개체 이름, 상주하는 스키마 및 개체 형식이 포함됩니다. 개체가 패키지이고 Collapse Package 보기 상태일 경우 참조하는 모든 하위 유닛이 개체 형식 아래에 포함됩니다. 예를 들면 다음과 같습니다.

줄은 다른 개체에 서로 종속 관계에 있는 두 개의 개체를 모두 연결합니다. 줄에는 손잡이 및 화살표 모양의 끝이 있습니다. 참조하는 개체는 손잡이 모양의 끝에, 참조되는 개체는 화살표 모양의 끝에 상주합니다. 예를 들면 다음과 같습니다.

이 예에서 DISK_UTIL은 특히 GET_DISK_FREE_SPACE 함수에서 NT_KERNEL 라이브러리를 참조합니다. 예제 모델은 Collapse Package 보기 상태입니다.

자체 재귀 참조는 화살표가 다음과 같이 동일한 개체로 돌아간 상태에서 동일한 방식으로 표시됩니다.

그래픽 모델 작업

  • 개체에 마우스 오른쪽 단추를 눌러 해당 개체 형식에 대한 Schema Browser의 팝업 메뉴를 표시합니다.

  • F2를 눌러 전체 화면 모드로 전환합니다.

  • Toad가 해당 개체 형식의 설명을 지원할 경우 F4를 누르거나 개체를 두 번 눌러 설명을 수행합니다.


텍스트 모델 저장

그래픽 효과가 보다 적고 쉽게 인쇄하거나 작업할 수 있는 것을 찾을 때가 있습니다. Toad가 이를 위해 코드 모델을 텍스트 파일로 내보낼 수 있습니다. 이 파일은 개체 및 참조 목록으로 구성되어 있습니다.

예를 들면 다음과 같습니다.

PROCEDURE CRM_TEST EX_PROC_1 ---> PACKAGE CRM_TEST EX_PACK_2

PROCEDURE CRM_TEST EX_PROC_1 ---> PROCEDURE CRM_TEST EX_PROC_2

PROCEDURE CRM_TEST EX_PROC_1 ---> PROCEDURE CRM_TEST EX_PROC_3

PROCEDURE CRM_TEST EX_PROC_1 ---> TABLE CRM_TEST EMP_SNAPSHOT

PROCEDURE CRM_TEST EX_PROC_1 ---> VIEW CRM_TEST SALES

작은 코드 맵의 결과가 될 수 있습니다. 맵은 다음과 같이 나타납니다.

OBJECT-TYPE SCHEMA OBJECT NAME --> OBJECT-tYPE SCHEMA OBJECT NAME

여기서 화살표는 "호출"을 뜻합니다.

텍스트 모델을 저장하려면

  1. 로드 맵을 작성합니다.

  2. Code Road Map 도구 모음에서 Save diagram as text file [image] 단추를 누릅니다. Save As 대화상자가 나타나고 여기서 파일을 저장할 수 있습니다.


코드 모델 복사

코드 모델을 클립보드에 복사한 다음 다른 문서 또는 그래픽 응용프로그램에 붙여 넣을 수 있습니다.

이 작업을 수행하는 방법에는 몇 가지가 있습니다.

코드 모델을 복사하려면

  • 다음 작업 중 하나를 수행하십시오.

  • 모델에 마우스 오른쪽 단추를 누르고 Copy image to clipboard를 선택합니다.

  • Edit 메뉴에서 Copy를 선택합니다.

  • <CTRL> <C> 또는 복사 바로 가기로 설정한 키 입력을 누릅니다.

그래픽 코드 모델의 이미지가 클립보드에 복사되고 필요한 경우 다른 응용프로그램에 붙여 넣을 수 있습니다.


HTML Schema Doc Generator

이 창의 왼쪽 패널에서 스키마를 하나 이상 선택하고 화면 위의 Begin HTML Schema Doc Generation 단추를 사용하여 스키마를 설명하는 HTML 설명서를 작성할 수 있습니다. 마지막 HTML 문서에 걸친 하이퍼링크를 사용하여 설명서의 절 사이를 이동할 수 있습니다.

모든 옵션은 TOAD.INI 파일로 저장되고 이 파일에서 로드됩니다. 스키마 선택 사항은 데이터베이스 기준으로 저장 및 로드됩니다.

이 항목에는 Schema Doc Generator의 다음 부분에 대한 내용이 포함됩니다.

Sources 탭 | Format 탭
Content 탭 | Inclusions and Exclusions 탭
Header/Footer 탭 | Aliases for Schema Names

Sources 탭

설명서에 사용할 수 있는 스키마는 창의 왼쪽에 나열됩니다. 설명서로 만들 스키마를 하나 이상 점검합니다.

스키마 목록에 마우스 오른쪽 단추를 누르고 다음과 같은 여러 기본 선택 사항에서 선택합니다.

  • Check All - 설명서에 필요한 스키마를 모두 표시합니다.

  • Check None - 스키마를 모두 선택 취소합니다.

  • Check My Schema - 현재 연결의 스키마를 점검합니다.

  • Check My Schema Only - 현재 연결의 스키마를 점검하고 모두 선택 취소합니다.

창의 오른쪽 패널에서 .def 파일의 스키마 설명서를 작성할 수 있습니다. 이러한 def 파일은 Generate Schema Script 창에서 작성됩니다.

주: "Def file will be used for HTML Schema Doc generation in Generate Schema script to include all parts of the schema."를 표시해야 합니다.

이 기능을 사용하려면 def 파일 이름이 스키마 이름과 일치해야 합니다. 즉, SCOTT이라는 스키마의 경우 def 파일이 SCOTT.DEF여야 합니다. 이러한 파일을 저장하는 디렉토리는 중요하지 않습니다.

Content 탭

이 탭에는 HTML 문서에 포함할 내용을 선택할 수 있는 확인란이 포함되어 있습니다. 확인란은 Object Summaries 및 Object Descriptions로 구분됩니다. 기본값으로 모든 확인란이 표시되어 있습니다. 이러한 확인란에는 다음 내용도 포함됩니다.

Count of All Objects 확인란

표시되어 있으면 문서에 스키마에서 선택한 형식의 개체 수가 나열됩니다. 또한, 스키마의 표 열 및 표 분할 수 등의 기타 세부 사항도 계산됩니다.

Privileges 확인란

표시되어 있으면 문서에 부여된 권한이 나열됩니다. Object privileges에는 부여 가능 또는 불가능 권한의 이름뿐만 아니라 Object Owner도 포함됩니다. 시스템 권한에는 권한 및 해당 권한의 Admin 옵션이 있는지 여부가 포함됩니다.

Object Summary 확인란

각 Object Summary 확인란(Table Summary, Snapshot Summary 등)이 표시되어 있으면 해당 개체의 특징 목록이 생성됩니다. 대부분의 개체 형식의 경우 마지막 문서의 개체 이름은 보다 자세한 개체 설명의 하이퍼링크입니다.

Object Descriptions 확인란

각 Object Description 확인란(Table Descriptions, View Descriptions 등)은 추가 확인란을 활성화하여 설명에 포함할 내용을 지정할 수 있습니다.

Include Snapshot Tables with Table Listings

표 목록에 스냅샷 표를 포함 또는 제외시킬 수 있습니다. 기본값은 포함하는 것입니다. 제외시키려면 확인란을 선택 취소합니다.

Format 탭

File 옵션 라디오 단추

  • One file per schema - 선택되어 있으면 각 스키마가 자체 파일로 기록됩니다. 스키마가 하나 이상 선택되어 있으면 추가 HTML 페이지가 작성되어 스키마 문서 간의 링크가 됩니다.

  • A few files per schema - 선택되어 있으면 스키마가 몇 개의 파일로 구분되며, 하나의 파일이 주요 섹션이 됩니다.

  • One file per object - 선택되어 있으면 각 개체가 자체 파일로 기록되고 각 개요 섹션이 자체 파일로 기록됩니다.

Background 라디오 단추

보고서에 넣을 배경을 선택합니다. 옵션에는 다음 내용이 포함됩니다.

  • 워터마크 Toad 이미지

  • 회색 종이 질감

  • 단색 선택(색상 패널을 클릭하여 배경색을 단색으로 변경)

  • 사용자 정의 이미지 파일 지정. 이를 선택하면 Custom Image File Name 상자가 활성화됩니다.

Use Existing CSS file 확인란

대부분의 유형 옵션은 CSS(Cascading Style Sheet) 파일로 기록됩니다. CSS 파일의 사용자 정의 버전을 사용하려면 이 옵션을 선택하고 파일 이름 또는 URL을 지정합니다. 이 옵션이 선택되어 있으면 CSS 파일에 기록된 옵션이 비활성화됩니다.

Fonts

Table Headers, Table Rows 또는 Most Other Text를 눌러 HTML 문서의 글꼴 속성(글꼴 크기, 색상 및 텍스트 유형)을 변경합니다.

Links

HTML 문서에서 방문했거나 방문하지 않은 링크 색상 및 마우스를 놓았을 때의 링크 색상을 지정할 수 있습니다. 해당 색상을 눌러 Unvisited, Visited 및 Hover 색상을 변경합니다.

Table 옵션

  • Header background color - 색상 패널을 눌러 표 머리글 배경색을 조정할 수 있습니다.

  • Table border styles - 표 테두리 유형의 라디오 단추를 사용하여 None, Single 또는 Double을 선택할 수 있습니다.

  • Transparent rows

  • 이 옵션이 표시되어 있으면 HTML 문서의 배경색이 모든 표의 배경색이 됩니다.

  • 표시되어 있지 않으면 Row Background Color의 색상 패널을 누르고 표 행에 새로운 색상을 선택할 수 있습니다.

기본값으로 표시되어 있습니다.

Miscellaneous

  • Indent HTML files - 표시되어 있으면 보다 쉽게 읽을 수 있도록 파일의 HTML 코드가 공백으로 들여 써집니다. 옵션이 표시되어 있지 않으면 HTML 코드에 들여쓰기가 이루어지지 않으므로 결과 파일이 보다 작아지고 컴퓨터에서 보다 빠르게 읽을 수 있게 됩니다. 이 옵션은 브라우저를 통한 HTML 문서의 표시 방식을 변경하지 않습니다.

  • Page Breaks before Tables - 표시되어 있으면 Toad가 각 표 앞에 페이지 나누기를 삽입합니다. 이렇게 하면 HTML 파일이 아닌 CSS 파일이 변경되며 HTML 문서가 인쇄되지 않으면 효과가 없습니다.

  • Lowercase Tables - HTML 표 전체를 소문자로 표시합니다. 이 옵션은 HTML 파일이 아닌 CSS 파일을 변경합니다.

Inclusions and Exclusions 탭

이 탭에서 포함 및 제외 파일을 작성 및 선택할 수 있습니다. Where clause 확인란을 표시하고 Where clause에서 입력하여 필터링할 수도 있습니다.

Tables/Views 단추

Table 또는 View 단추를 선택합니다. 옵션은 유사하지만 표 또는 보기에 적용됩니다.

Create ____ List File 단추

이 단추는 스키마의 포함/제외 텍스트 파일을 생성합니다. 여기에 모든 표 또는 보기가 나열됩니다. 그런 다음 파일을 보고 편집할 수 있습니다.

  • Use it as an inclusion file: 나열된 표 또는 보기만 포함됩니다.

  • Use it as an exclusion file: 나열된 표 또는 보기만 제외됩니다.

  • 'A' 문자로 시작하는 표만 얻으려면 다음을 입력합니다.

AND HTML.TABLE_NAME like 'A%'

  • 선택한 스키마 내에서 몇 개의 특정 표를 얻으려면 다음을 입력합니다.

AND HTML.TABLE_NAME in ('MYTABLE','MYOTHERTABLE', 'THISTABLE', 'THATTABLE')

Procs 단추

포함 또는 제외 텍스트 파일을 사용하기로 선택하면 Procs 단추는 Table 및 View 단추 옆에 나타납니다. 이렇게 하면 필터링을 통과하는 표에 따라 procs만 포함하기로 선택할 수 있습니다.

After File creation

파일이 작성되고 나면 필터를 추가할 수 있습니다. 파일을 검토하고 해당 필터 행의 시작 부분에서 설명(#) 표시를 제거합니다. 이러한 표시는 다음과 같습니다.

  • STARTSWITH:<text>

  • ENDSWITH:<text>

  • CONTAINS: <text>

필터를 추가할 때:

  1. 텍스트를 <>에 삽입하지 마십시오.

  2. 각 유형의 필터를 필요한 대로 많이 추가합니다. 필터가 서로 표 이름으로 OR되고 표 이름이 필터를 통과하거나 나열되면 파일 사용 목적에 따라 포함되거나 제외됩니다.

  3. 스냅샷 표가 이 파일에 나열되지만 표를 포함한다는 옵션이 표시되어 있지 않으면 표 목록에서 자동으로 제외됩니다.

Header/Footer 탭

Header/Footer 탭을 눌러 문서에 사용자 정의 머리글 및 바닥글을 추가합니다.

Include 확인란

표시되어 있으면 이 확인란은 HTML Schema Doc Generator를 실행하여 작성한 모든 파일에 설계한 바닥글을 포함합니다.

표시되어 있지 않으면 머리글 및 바닥글이 표시되지 않습니다.

Header/Footer 상자

머리글 또는 바닥글 영역에서 행을 최대 4개까지 입력합니다. 상자당 행을 하나만 입력합니다.

상자 옆의 Font 단추를 눌러 머리글 및 바닥글의 글꼴을 선택할 수 있습니다. 텍스트의 각 행을 다른 방법으로 포맷할 수 있습니다.

Aliases for Schema names 탭

이 탭을 눌러 모든 스키마 이름의 별칭을 입력합니다. 눈금이 Sources 탭에서 선택한 원본을 자동으로 입력합니다. 이 영역을 비워 놓으면 Toad가 생성하는 HTML 문서에 스키마 이름 및 데이터베이스 이름이 포함됩니다.

모든 스키마의 별칭을 입력하면 HTML 문서 전체에서 해당 스키마 이름이 별칭으로 바뀝니다.

다음과 같은 경우 별칭을 사용할 수 있습니다.

  1. 스키마 이름 <> 응용프로그램 이름 및 표시된 응용프로그램 이름을 보고자 할 경우.

  2. 동일한 스키마의 def 파일 하나 이상에서 HTML 문서를 추출하고자 하는 경우. 별칭을 사용하지 않는 경우 이름이 동일하기 때문에 파일 이름이 서로 겹쳐집니다. 별칭을 사용하여 파일 이름이 달라집니다.

  3. HTML 문서의 독자는 스키마 또는 데이터베이스 이름을 모르고 있어야 합니다.


창: Master/Detail Browser

Master/Detail Browser

Master/Detail Browser를 사용하여 외부 키 또는 사용자 정의 마스터 세부 관계에 의해 연결된 여러 표, 스냅샷, 보기 또는 질의 데이터를 보거나 편집할 수 있습니다. Entity/Relationship 다이어그램에서 데이터베이스를 설정하는 일반적인 방법이며, 여기서 표 개체는 필드를 연결하여 다른 표 개체와 연관됩니다.

예를 들어, DEPARTMENT 표를 시작하고 세부 사항을 표시할 수 있습니다. Master 눈금에서 부서 레코드를 선택하면 세부 눈금에 해당 부서에 대한 직원 레코드가 표시됩니다. 여러 표가 외부 키에 의해 연결되어 있으면 첫 번째 아래에 세부 사항을 추가할 수 있습니다.

또한 세부 개체의 하위 세부 사항을 추가할 수도 있습니다.

Master/Detail Browser를 액세스하려면

  • Database|Report|Master/Detail Browser를 선택합니다.

관련 항목

Master/Detail Table Browser 도구 모음

마스터 개체 선택

세부 사항 데이터 집합 추가


Master/Detail Browser 도구 모음

Master/Detail Browser 도구 모음

Master/Detail Browser 도구 모음에서 세부 사항을 추가하고, 마스터/세부 관계를 저장하고, 관계를 열고, 마스터 관계에 사용되는 질의를 편집할 수 있습니다.

단추 | 명령
 | 활성 세션 변경
 | 마스터/세부 관계 열기
 | 현재 마스터/세부 관계 저장
 | 보고서 생성
 | 표 정렬
 | 마스터 데이터 집합 질의 보기/편집
 | 눈금 새로 고침
 | 선택한 데이터 집합에 세부 사항 추가
 | 최대 공간을 위해 도구 모음 최소화

Detail Grid 도구 모음

Detail 패널의 도구 모음은 기본 도구 모음과 유사하지만 다음과 같은 차이가 있습니다.

단추 | 명령
 | 눈금을 보다 작게 만듬
 | 눈금을 보다 크게 만듬
 | 관계에서 이 세부 사항 삭제


마스터 개체 선택

세부 사항을 추가하기 전에 우선 관계 보기에 대한 마스터 개체를 선택해야 합니다.

마스터 개체를 선택하려면

  1. Database|Report 메뉴에서 Master Detail Browser를 선택합니다.

  2. Type 상자에서 사용할 개체의 형식을 선택합니다. 가능한 옵션은 다음과 같습니다.

  3. Table

  4. View

  5. Snapshot

  6. Query

  3. Owner 상자에서 개체를 포함하는 스키마를 선택합니다.

  4. Name 상자에서 개체의 이름을 선택합니다.

선택한 개체의 내용이 눈금에 채워집니다.

관련 항목

세부 사항 데이터 집합 추가


세부 사항 데이터 집합 추가

마스터 눈금 또는 세부 눈금에 세부 사항 데이터 집합을 쉽게 추가할 수 있습니다.

데이터 집합 형식으로 Other를 선택할 경우(Table(FK) 아님) Add detail [image] 단추 드롭다운에 Reverse Foreign Keys가 포함됩니다. 이로 인해 외부 키를 반대로 사용하여 마스터 세부 관계를 정의할 수 있습니다.

데이터 집합을 추가하려면

  1. 마스터 개체를 엽니다.

  2. 마스터 도구 모음에서 Add detail [image] 단추를 누릅니다.

  3. 세부 정의된 외부 키가 하나만 있을 경우 디스플레이에 추가됩니다.

또는

여러 옵션이 있을 경우 세부 사항에 사용하기 위해 사용 가능한 표 목록에서 선택합니다. 선택하고 OK를 누릅니다.

또는

정의된 제약 조건이 없을 경우 Define Master-Detail Relationship 대화상자가 나타납니다. 관계를 정의하고 OK를 누릅니다.

관련 항목

Master/Detail Browser

마스터 개체 선택

마스터/세부 관계 정의


마스터/세부 관계 정의

지정한 외부 키가 없을 경우 직접 마스터/세부 관계를 작성할 수 있습니다.

마스터/세부 관계를 정의하려면

  1. Master/Detail 브라우저에서 마스터 개체를 선택합니다.

  2. Add Detail Dataset [image] 단추를 누릅니다.

정의된 세부 데이터 집합이 없을 경우 Master/Detail Define Relationship 대화상자가 나타납니다.

3단계를 계속 진행합니다.

정의된 세부 데이터 집합이 하나만 있을 경우 표시됩니다.

Type 드롭다운에서 Other를 선택한 다음 Select Detail relationship [image] 단추를 누릅니다.

  3. Master 영역에서 연결할 열을 선택하고 > 화살표를 눌러 Key Columns 목록으로 이동합니다.

  4. Key Columns 눈금에서 연결하지 않을 열을 선택하고 < 화살표를 눌러 삭제합니다.

  5. 세부 영역에서 연결할 데이터 집합이 포함된 개체 형식을 선택합니다. 이 개체 형식은 다음과 같습니다.

  6. 표

  7. 스냅샷

  8. 보기

  6. 데이터 집합이 포함된 스키마를 선택합니다.

  7. 데이터 집합이 포함된 개체 이름을 선택합니다.

  8. Available Columns 눈금에서 Master Table의 선택한 열에 연결할 열을 선택합니다.

주: Master 영역의 Key Columns와 동일한 순서여야 합니다.

  9. OK를 누릅니다.

변경하지 않고 닫으려면

  • Cancel을 누릅니다.

마스터/세부 관계를 삭제하려면

  • Clear and Close를 누릅니다.


Reports Manager

Reports Manager 개요

Reports Manager에서 Toad에서 제공한 여러 보고서를 포함하여 이전에 작성된 보고서를 쉽게 관리할 수 있습니다. 설계 화면을 거치치 않고도 Reports Manager 창에서 보고서를 열고, 실행하고, 인쇄할 수 있습니다. 처음부터 보고서를 작성하려는 경우 이 화면에서 Reports Manager 마법사를 열 수 있습니다.

Reports Manager를 처음 사용하면 사용할 보고서를 가져와야 합니다. 하나의 파일에서 질의 및 fr3 보고서 정의를 가져오는 것이 보고서를 실행할 때마다 질의를 따로 실행하는 것보다 쉽습니다. 하나의 파일을 가지고 있으면 Toad 버전 간의 이동성이 만들어지므로 질의, 설명 및 보고서 레이아웃을 하나의 파일에만 이동하면 됩니다.

Reports Manager에 표시된 질의는 보고서에 데이터를 공급하므로 Reports Manager에서 편집할 수 있습니다.

Editor에서 직접 액세스하지 않고 Reports Manager에서 Report Builder를 액세스할 때 다음과 같은 장점이 있습니다.

  • 하나의 보고서에 두 항목 필요 - 질의 및 보고서 정의 파일(.fr3 파일). Reports Manager를 사용하면 보고서를 쉽게 구성, 복제 및 공유할 수 있습니다. Editor에서 보고서를 다시 실행할 때도 질의(또는 저장한 위치)를 기억해야 합니다.

  • Reports Manager를 사용하여 보고할 마스터/세부 사항 데이터 집합을 작성할 수 있습니다. 이와 같은 작업을 Editor에서 수행할 수 없지만 Master/Detail Browser에서 작성한 다음 보고서를 작성할 수 있습니다.

Reports Manager는 두 개의 영역으로 구분됩니다. 왼쪽에는 로드하기로 선택한 보고서 목록이 포함됩니다. 오른쪽에는 선택한 보고서의 정보(마스터 데이터 집합[질의], 추가한 설명 또는 세부 사항 데이터 집합을 볼 수 있는 옵션 등)가 포함됩니다. 매개 변수는 오른쪽 하단의 눈금에 나열됩니다.

보고서 기록

Reports Manager를 닫았다가 다시 열면 마지막으로 검토한 보고서가 열린 상태로 남아 있습니다.

보고서 영역(왼쪽)

보고서 영역은 여러 카테고리 내의 보고서를 구성합니다. 보고서를 다른 카테고리로 이동할 수 있으며 보고서 파일에서 추가 또는 삭제할 수 있습니다.

카테고리를 확장하고 창을 닫으면 Toad가 그 사실을 기억하고 있다가 다음에 Reports Manager를 사용할 때 동일한 방식으로 엽니다.

보고서 영역에서는 또한 여러 개를 선택할 수도 있습니다. 즉, 목록에서 하나 이상의 보고서를 선택한 다음 한 번에 실행할 수 있습니다. 여러 보고서를 선택했으면 카테고리를 변경하고, 보고서를 내보내고, 인쇄하고, 삭제할 수 있습니다.

보고서 정보 영역

오른쪽 또는 보고서 정보 영역은 선택한 보고서의 기준 질의, 보고서에 입력한 모든 설명, Toad가 질의를 실행하기 전에 입력해야 하는 매개 변수를 표시하고, 해당하는 경우 색인 열을 표시합니다.

보고서 스케줄링

명령줄 인터페이스를 사용하여 보고서를 스케줄링할 수 있습니다. (자세한 내용은 명령줄에서 보고서 인쇄 및 내보내기를 참조하십시오.)

관련 항목

Reports Manager 도구 모음

보고서 복사

보고서 카테고리 변경

보고서 가져오기/내보내기

명령줄에서 보고서 인쇄 및 내보내기


Reports Manager 도구 모음

Reports Manager 도구 모음을 사용하여 관련된 보고서 및 질의를 쉽고 빠르게 관리합니다.

아이콘 | 명령
 | 활성 세션을 변경합니다.
 | 보고서를 내보냅니다(다른 이름으로 보고서 파일 저장).
 | 보고서를 가져옵니다(보고서 파일 열기).
 | 보고서를 복사합니다.
 | 카테고리를 변경합니다.
 | 선택한 보고서를 편집합니다.
 | 보고서를 미리 봅니다.
 | 보고서를 인쇄합니다.
 | 보고서를 작성합니다.
 | 선택한 보고서를 삭제합니다.
 | 선택한 보고서의 내용을 편집합니다.
 | 편집을 게시합니다.
 | 편집을 취소합니다.

관련 항목

Reports Manager 개요

마스터/세부 사항 데이터 집합 작성

보고서 카테고리 변경

보고서 복사

보고서 가져오기/내보내기


RM_Queries

질의

Fast Reports에서 보고서 기본은 질의입니다. Reports Manager의 Create Report 도구 모음 단추에서 Report Builder 마법사를 사용하여 데이터 눈금에서 보고서를 쉽게 생성한 다음 Reports Manager로 가져올 수 있습니다(보고서 가져오기/내보내기 참조). 또는 Reports Manager에서 바로 질의를 작성할 수 있습니다.

질의는 표준 형식의 변수뿐만 아니라 Toad 특정 변수도 포함할 수 있습니다.

다음 변수 중 일부도 포함됩니다.

  • <DA> - <DA>를 사용하면 보고서가 실행되는 현재 연결의 권한에 따라 Reports Manager가 sys.dba_ 또는 sys.all_로 변환합니다.

  • 현재 스키마 - 현재 스키마 형식의 변수를 작성하여 자동으로 현재 활성 스키마 이름으로 대체할 수 있습니다.

  • 데이터 사전의 바로 가기 키 - 자세한 내용은 매개 변수: 특수 매개 변수 형식을 참조하십시오.


RM - 매개 변수

매개 변수

Parameters 영역을 사용하여 작성한 질의에 매개 변수를 포함할 수 있습니다.

Value (Literal)

Value(Literal) 매개 변수는 연결 매개 변수입니다. Date, Number 또는 String 매개 변수 형식에만 적용됩니다. 4, 'hello' 또는 03/23/2006 1:34:25 PM(눈금에 표시되는 동일한 날짜 형식) 등의 리터럴 값을 입력해야 합니다.

Value (Expression)

보다 유용하게 사용할 수 있습니다. 대체 변수와 비슷하지만 보다 포괄적입니다. 질의의 아무 곳에서나 사용할 수 있습니다.

from 절, 선택 목록 또는 where 절 어딘가에서 표 이름의 변수로 사용할 수 있습니다. 하위 질의, 목록 등 무엇이든 될 수 있습니다. Toad는 식을 질의와 대체합니다. 대체 변수이므로 매개 변수 형식을 사용해도 좋습니다. "특수" 매개 변수 형식(목록 아래의 "클러스터" 매개 변수 형식)은 제외됩니다.

특수 매개 변수 형식

클러스터 매개 변수 형식 및 남은 매개 변수 목록은 데이터 사전의 바로 가기 키입니다. "목록"으로 분류된 형식은 여러 값을 반환하도록 설계되었으며, 다른 형식은 하나의 값만 반환합니다.

String 매개 변수

예를 들어 다음과 같은 질의 모양입니다.

select *

from user_tables

where table_name = :tn

표에 STRING 매개 변수 형식을 지정할 수 있지만 표 이름은 직접 입력해야 합니다. 목록에서 선택할 경우 매개 변수 형식을 "Table"로 변경합니다. 그런 다음 "Value (Expression)"에서 "..." 단추를 누르면 표 목록이 나타납니다.

Table List 매개 변수

여러 표에 보고하려면 다음과 같은 질의를 사용합니다.

select *

from user_tables

where table_name in (:tn)

매개 변수 형식을 Table List로 변경하고 [image] 단추를 누르면 여러 표를 선택할 수 있습니다.

기타 매개 변수 형식

기타 매개 변수 형식은 동일하게 적용됩니다.

  • 현재 스키마 - 질의의 현재 활성 스키마를 자동으로 사용합니다.

  • 스키마 - 하나의 사용자 이름을 선택할 수 있습니다.

  • 스키마 목록 - 여러 스키마 이름을 선택할 수 있습니다.

  • 기타 등등


RM - 마스터/세부 사항 데이터 집합 작성

마스터/세부 사항 데이터 집합 작성

마스터 데이터 집합을 작성한 후 세부 사항 데이터 집합을 추가할 수 있습니다. 이렇게 하면 보고서에 정보가 추가됩니다.

동일한 보고서, 특히 Tables and Index Reports 및 Stored Program Reports 카테고리에 마스터 세부 사항 데이터 집합의 여러 예가 있습니다.

마스터 세부 사항 데이터 집합을 작성하려면

  1. 보고서를 추가하고 마스터 질의(예: SELECT * from SCOTT.DEPT)를 입력합니다.

  2. Add detail dataset 단추를 누릅니다.

세부 사항 데이터 집합에 대한 SQL을 입력할 수 있는 위치에 새 탭이 나타납니다.

  3. 세부 사항 데이터 집합(예: SELECT * FROM SCOTT.EMP)에 대한 SQL을 입력합니다.

  4. 원하는 경우 세부 사항 데이터 집합의 이름을 바꿉니다.

  5. 세부 사항 데이터 집합 탭의 드릴 다운 [image] 단추를 사용하여 마스터 및 세부 사항 데이터 집합을 연결하는 키 필드를 정의합니다.

관련 항목

Reports Manager 개요

Reports Manager 도구 모음

보고서 카테고리 변경

보고서 복사

보고서 가져오기/내보내기


RM - 보고서 복사

보고서 복사

보고서를 쉽게 복사(복제)할 수 있습니다. 동일한 질의 및 .fr3(보고서 정의) 파일을 작성합니다. 이 방법을 사용하여 유사한 보고서를 빠르고 쉽게 작성할 수 있습니다.

보고서를 복사하려면

  1. Report Name 영역에서 복사할 보고서를 선택합니다.

  2. Copy Report Definition [image] 단추를 누릅니다.

  3. 새 보고서를 다른 카테고리에 넣으려면 New Category 드롭다운에서 새 카테고리를 선택합니다.

  4. New Report Name 상자에 보고서의 새 이름을 입력합니다.

  5. New Report Definition File Name 상자에 보고서 정의 파일의 새 파일 이름을 입력합니다.

  6. OK를 누릅니다.

관련 항목

Reports Manager 개요

Reports Manager 도구 모음

보고서 카테고리 변경

보고서 가져오기/내보내기


RM - 보고서에 RunInfo 데이터 추가

보고서에 RunInfo 데이터 추가

이제 모든 보고서에 Run Info 데이터 집합을 포함할 수 있습니다. 이 데이터 집합에는 다음이 포함됩니다.

  • 연결 정보

  • 사용자 이름(Windows 및 Oracle)

  • 타임스탬프

  • 날짜

  • 기타 등등

보고서에 RunInfo 데이터를 추가하려면

  1. RunInfo를 추가할 위치에서 보고서를 선택합니다.

  2. Design Selected Report [image] 단추를 누릅니다.

  3. 메뉴에서 Report|Data를 선택합니다.

  4. Select Report Datasets 대화상자에서 RunInfo 상자를 표시합니다.


RM - 보고서 카테고리 변경

보고서 카테고리 변경

하나 이상의 보고서를 파일로 만든 위치에서 카테고리를 변경할 수 있습니다. 카테고리를 변경 중이거나 가져온 보고서를 잘못 파일로 만들었을 경우 유용합니다.

보고서 카테고리를 변경하려면

  1. 변경할 보고서를 선택합니다. 카테고리를 여러 개 선택할 수 있지만 모든 보고서는 동일한 카테고리로 변경됩니다.

  2. Change Category for Selected Reports [image] 단추를 누릅니다.

  3. Category 드롭다운에서 새 카테고리를 선택합니다.

또는

카테고리를 하나 선택하는 대신 Category 상자에 새 카테고리 이름을 입력합니다.

  4. OK를 눌러 카테고리를 변경합니다.

관련 항목

Reports Manager 개요

Reports Manager 도구 모음

보고서 복사

보고서 카테고리 변경

보고서 가져오기/내보내기


RM - 보고서 가져오기/내보내기

보고서 가져오기/내보내기

Reports Manager 파일에서 보고서를 가져오거나 내보낼 수 있습니다. 이렇게 하면 제공된 예제에 새 보고서를 쉽게 추가할 수 있고 다른 사용자와 공유할 수 있는 파일로 보고서를 내보낼 수 있습니다.

한 번에 하나 이상의 보고서를 가져오거나 내보낼 수 있습니다.

파일을 가져오려면

  1. Import Report Definition [image] 단추를 누릅니다.

  2. 다음 중 하나를 선택합니다.

Import Report Definition file(s).

또는

Import all Report Definition Files in a Directory (includes subdirectories).

  3. Open file 대화상자에서 찾아 보고 파일 또는 폴더를 선택합니다.

  4. OK를 눌러 파일 또는 폴더를 가져옵니다.

파일 내보내기

하나 이상의 파일을 내보낼 수 있습니다.

파일을 내보내려면

  1. 내보낼 파일을 선택합니다.

  2. Export File [image] 단추를 누릅니다. 다음 중 하나를 선택합니다.

  3. Export Selected Reports

  4. Export All Reports

  5. Export All Reports in Current Category

  6. 파일의 이름을 지정하고 저장 위치를 지정합니다.

  7. Save를 누릅니다.

관련 항목

Reports Manager 개요

Reports Manager 도구 모음

보고서 복사

보고서 카테고리 변경

보고서 가져오기/내보내기


창: Toad Control Files

Toad Control Files

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

주 메뉴 표시줄에서 Database|Control Files를 선택하여 데이터베이스의 제어 파일 레코드 섹션에 대한 정보를 볼 수 있습니다. Control Files 창이 나타납니다.

컨트롤 파일에는 시작할 때와 정상적인 작업 동안 인스턴스에서 액세스하는 데이터베이스에 필요한 연관된 데이터베이스에 대한 정보가 있습니다. 컨트롤 파일의 정보는 Oracle에서만 수정할 수 있으며, 데이터베이스 관리자나 최종 사용자는 데이터베이스의 컨트롤 파일을 편집할 수 없습니다.

제어 파일에는 다음과 같은 정보가 들어 있습니다.

  • 데이터베이스 이름

  • 데이터베이스 작성 타임스탬프

  • 관련 데이터 파일 및 온라인 다시 실행 로그 파일의 이름 및 위치

  • 테이블 공간 정보

  • 데이터파일 오프라인 범위

  • 로그 기록

  • 보관된 로그 정보

  • 백업 세트 및 백업 조각 정보

  • 백업 데이터 파일 및 다시 실행 로그 정보

  • 데이터 파일 복사 정보

  • 현재 로그 순서 번호

  • 검사점 정보

데이터베이스를 작성할 때 Oracle에서는 데이터베이스 이름 및 타임스탬프를 작성합니다. 데이터베이스 이름은 초기화 매개 변수 DB_NAME에 지정된 이름 또는 CREATE DATABASE 문에 사용된 이름에서 가져옵니다.

데이터 파일 또는 온라인 다시 실행 로그 파일이 데이터베이스에 추가되거나 이름이 변경되거나 데이터베이스에서 삭제될 때마다 제어 파일이 업데이트되어 이러한 물리적 구조 변화가 반영됩니다. 다음 목적으로 이러한 변경 사항이 기록됩니다.

  • Oracle에서 데이터베이스 시작 중에 열어야 할 데이터 파일 및 온라인 다시 실행 로그 파일을 식별할 수 있습니다.

  • Oracle에서 데이터베이스 복구가 필요할 때 사용할 수 있거나 필요한 파일을 식별할 수 있습니다.

따라서 데이터베이스의 물리적 구조를 변경하는 경우에는 즉시 제어 파일의 백업을 만들어야 합니다.

제어 파일은 검사점에 대한 정보도 기록합니다. 3초마다 검사점 프로세스(CKPT)에서 온라인 다시 실행 로그의 검사점 위치에 대한 정보를 제어 파일에 기록합니다. 이 정보는 데이터베이스 복구 중에 사용됩니다. 이 정보는 데이터 파일에 이미 기록되었기 때문에 데이터베이스 복구에 필요하지 않은 항목을 표시합니다.


창: View Dependencies

종속 관계

이 기능을 사용하여 다음 작업을 수행할 수 있습니다.

  • 선택한 데이터베이스 개체를 참조하는 데이터베이스 개체를 보거나

  • 선택한 개체가 종속된 데이터베이스 개체를 봅니다.

Dependencies 기능은 Toad_DEP_TEMP 표를 의존하지 않습니다.

트리 보기는 <CTRL><SPACE>에 의해 완전히 확장할 수 있습니다.

모든 개체의 종속 관계를 볼 수 있는 탭도 있습니다. 들여 쓴 개체는 외부 개체에 종속됩니다.


ER 다이어그램

ER 다이어그램에서 표를 빠르게 모델로 만들고 종속 관계를 그래픽으로 볼 수 있으며, 다른 표에 참가할 수도 있습니다.

ER 다이어그램을 액세스하려면

  • Database|Report 메뉴|ER Diagram을 선택합니다.

또는

Schema Browser의 Tables 페이지에서 표에 마우스 오른쪽 단추를 누르고 ER Diagram을 선택합니다.

새 다이어그램 작성

새 다이어그램을 작성하려면

  1. 도구 모음에서 New Diagram [image] 단추를 선택합니다. Create ER Diagram 대화상자가 나타납니다.

  2. 드롭다운 스키마 메뉴에서 표가 상주하는 Schema를 입력합니다.

  3. 다이어그램으로 작성할 Table을 입력합니다.

  4. 로드할 참조 표의 레벨 수를 선택합니다.

주: 더 많은 레벨의 참조 표를 로드할 수록 다이어그램이 더 복잡해지고 Toad가 다이어그램을 작성하는 데 시간이 보다 더 소요됩니다.

  5. 디스플레이 옵션을 선택합니다. 다음을 수행할 수 있습니다.

  6. Show primary keys

  7. Show foreign keys

  8. Show unique keys

  9. Show data type

  10. Show not nullable

  11. Show indexes

디스플레이 옵션에 관련 아이콘이 있을 경우 아이콘은 옵션의 오른쪽에 표시됩니다. 다이어그램에서는 해당 아이콘이 표 이름의 왼쪽에 나타납니다.

  6. OK를 눌러 다이어그램을 생성합니다.

몇 개의 표 사용

창의 왼쪽 아래에 표 목록이 표시됩니다. 표 이름을 두 번 눌러 다이어그램에 표를 따로 추가할 수 있습니다.

  1. 다이어그램에 여러 표를 추가합니다.

  2. 도구 모음에서 Find Dependencies [image] 단추를 누릅니다. 이 표 간의 모든 조인이 나타납니다.

주: 이 기능을 사용하면 다이어그램에 새 개체가 추가되지 않습니다. 이미 표시된 개체 간의 조인만 발견됩니다.

하나의 표 사용

하나의 표로 전체 다이어그램을 작성할 수 있습니다.

  1. 왼쪽 아래 패널에서 다이어그램으로 작성할 표를 선택합니다.

  2. 도구 모음에서 New Diagram [image] 단추를 누릅니다. Create ER Diagram 대화상자가 나타나며, 표가 이미 선택되어 있습니다. 위의 From a New Diagram 부분의 4단계를 계속합니다.

다이어그램 읽기

각 개체 목록에는 표 이름, 표가 상주하는 스키마(제목 표시줄), 표 열, 열 형식, 열 인덱싱 여부 및 다이어그램이 작성될 때 Display Options 영역에서 선택한 모든 아이콘이 포함됩니다.

줄은 다른 표에 서로 종속 관계에 있는 두 개의 표를 모두 연결합니다. 줄에는 손잡이 및 화살표 모양의 끝이 있습니다. 참조하는 표는 손잡이 모양의 끝에, 참조되는 표는 화살표 모양의 끝에 상주합니다.

그래픽 모델 작업

  • 개체에 마우스 오른쪽 단추를 눌러 Schema Browser의 팝업 메뉴를 표시합니다.

  • F2를 눌러 전체 화면 모드로 전환합니다.

  • Toad가 해당 개체 형식의 설명을 지원할 경우 F4를 누르거나 마우스를 두 번 눌러 설명을 수행합니다.

모델에 새 표 추가

다이어그램을 작성한 후 다른 표를 추가해야 할 수도 있습니다. 예를 들어, 데이터베이스에서 여러 표가 사용되는 생산 시스템의 경우 일부는 시스템의 다른 표에 연결되지 않을 수도 있습니다. 하지만 동일한 시스템의 일부이므로 다이어그램에서 사용할 수 있습니다. 왼쪽 아래의 표 목록을 사용하여 추가합니다. 다이어그램에 추가할 표를 두 번만 누르면 나타납니다.


Spool SQL

Database|Spool SQL 명령은 화면의 메시지 상자에 모든 SQL을 표시하거나 메뉴 선택에 따라 파일(\temps\debug.sql)로 전송합니다.

SQL을 효과적으로 스풀링하려면

  1. Database|Spool SQL 및 코드를 전송할 위치(Screen 또는 File)를 선택합니다.

  2. Toad에서 기능을 선택합니다. 해당 작업 수행에 사용한 SQL Toad가 화면 또는 특정 파일로 스풀링됩니다. Spool SQL to Screen에 대한 자세한 내용은 Output 창을 참조하십시오.


코드 조각

도킹 가능한 창을 사용하여 Oracle SQL 함수를 참조하거나 Toad 내의 편집기에 복사합니다.

항목의 관련 텍스트 파일은 Toad의 Oracle\Temps 폴더에 있습니다. 파일을 수정할 수 있습니다.

코드 조각을 사용하려면

  1. View 메뉴에서 Code Snippets를 선택합니다. 이 창이 도킹되어 자동으로 화면의 오른쪽에 표시됩니다.

  2. 창의 상단에서 category of code를 선택합니다.

  3. 목록에서 해당 코드를 선택합니다. 다음을 수행할 수 있습니다.

  4. 코드 목록 아래의 영역에서 해당 코드의 설명을 봅니다.

  5. 코드를 두 번 눌러 편집기로 삽입합니다.

  6. 코드를 편집기로 끌어다 놓습니다.

코드 카테고리

템플릿 | 파일 이름
단일 행 문자 함수 | STRFUNCS.TXT
단일 행 숫자 함수 | NUMFUNCS.TXT
그룹 함수 | GRPFUNCS.TXT
날짜 함수 | DATFUNCS.TXT
날짜 형식 옵션 | DATEFMTS.TXT
데이터 변환 함수 | CNVFUNCS.TXT
기타 함수 | MSCFUNCS.TXT
숫자 형식 옵션 | NMBRFMTS.TXT
Oracle 의사 열 | PSEUDO.TXT
SQL Optimizer 힌트 | OPTHINTS.TXT
정의된 예외 | PREDFXCP.TXT
사용자 제공 함수 목록 | USRFUNCS.TXT


Object Palette

Object Palette는 Toad 창에서 사용할 수 있도록 기본 Toad 창으로 도킹할 수 있습니다.

활성 연결이 변경되면 Object Palette가 자동으로 새로 고쳐져서 새 활성 연결을 반영합니다. 또는 새로 고침 단추를 사용하여 목록을 새로 고칠 수 있습니다. 이 방법은 데이터베이스를 질의합니다.

Object Palette에서 다음을 수행할 수 있습니다.

  • 다양한 스키마의 개체 보기

  • 개체 나열 유형 변경

  • 개체에 설명 수행

  • Editor에 선택한 개체 삽입

  • 팔레트의 열 보기 또는 숨기기

  • 팔레트 숨기기

  • 팔레트의 항목을 Toad의 다른 창으로 끌어다 놓습니다.

다른 스키마의 개체를 보려면

Object Palette가 처음으로 열리면 연결된 스키마의 개체가 표시됩니다. 이 방식을 쉽게 변경할 수 있습니다.

  1. Object Palette의 위에서 Schema dropdown을 누릅니다.

  2. 목록에서 새 스키마를 선택합니다. 그러면 해당 스키마의 개체가 개체 목록에 나타납니다.

개체 나열 유형을 변경하려면

  1. Options [image] 단추 옆의 드롭다운 화살표를 누릅니다.

  2. 개체를 표시할 유형을 선택합니다.

  3. Drop Down(기본값) - 드롭다운 메뉴에서 선택한 개체 형식.

  4. Tabbed - 별도의 탭에 있는 각 개체 형식.

  5. Tree view - 개체가 아래에 위치한 별도의 노드의 각 개체 형식.

Editor에 개체를 삽입하려면

  1. Editor에서 개체를 삽입할 위치에 커서를 둡니다.

  2. Object Palette에서 삽입할 개체를 두 번 누릅니다. Toad가 자동으로 코드에 개체를 삽입합니다.

개체에 DESCRIBE를 수행하려면

  1. Object Palette에서 설명할 개체를 선택합니다.

  2. <F4>를 눌러 DESCRIBE 창을 표시합니다.

열을 보려면

  • Object Palette에서 Show Columns [image] 단추를 누릅니다. 팔레트 아래에 선택한 개체에 대한 열이 표시됩니다.


Output 창

동작의 결과가 있을 경우에는 항상 Output 창이 나타납니다. 기본값으로 이 창은 화면 아래에 도킹되어 있습니다. 하지만 Output 창의 크기를 원하는 대로 조절할 수 있습니다. 기본값으로 화면 아래에 도킹되어 있지만 원하는 대로 움직이고 도킹할 수 있습니다.

Output 창의 도킹을 해제하려면

  • Output 창에 마우스 오른쪽 단추를 누르고 Docked 확인란의 선택을 취소합니다.

게다가 Output 창은 오류 메시지 및 Toad에서 작성하는 기타 일반 정보를 표시합니다. 필요한 경우 Output은 여러 탭으로 전달됩니다. 팝업 메뉴를 사용하여 Output 창에 표시되는 메시지를 작업할 수 있습니다.

여러 탭

필요한 경우 Output은 이 창의 여러 탭으로 전달됩니다.

탭 | 내용
General 탭 | 이 탭은 일반 정보를 제공합니다.
<connection> 탭 | 이 탭은 연결 도중 작업한 내용에 대한 정보를 제공합니다. 예를 들어, 특정 연결에 디버거 세션을 시작 또는 종료할 경우 이 기록이 여기에 표시됩니다.
Formatting Results 탭 | 이 탭은 Project Manager의 Format Files 명령 결과를 표시합니다.
Syntax Check Results 탭 | 이 탭은 Project Manager의 Check Syntax 명령 결과를 표시합니다.
Spool SQL 탭 | Spool SQL 명령에서 SQL이 표시됩니다. SQL Toad 사용자가 여러 기능을 수행하기 위해 사용합니다.

팝업 메뉴

마우스 오른쪽 단추 메뉴에서 여러 작업을 수행할 수 있습니다.

명령 | 결과
Find in Files | Find in Files 대화상자를 열어 특정 정보를 찾습니다.
Clear | 현재 Output 탭의 메시지를 모두 지웁니다.
View Messages | 대화상자에 선택한 메시지를 표시합니다. 메시지가 너무 길어 Output 창에서 볼 수 없거나 줄 바꿈이 포함된 경우에 도움이 됩니다.
Copy | Output 창의 내용을 클립보드에 복사합니다.
Print | Output 창의 내용을 인쇄합니다.
Save to File | Output 창의 내용을 텍스트 파일로 저장합니다.
Spool SQL to Screen | 스풀링 전환


Toad Options

View 메뉴에서 Toad Options를 선택합니다.

옵션을 사용하려면

  • 왼쪽의 목록에서 범주를 선택합니다. 선택한 해당 탭의 옵션이 오른쪽 detail 패널에 나열됩니다.

옵션 설정은 TOAD.INI기 저장되고 다음에 Toad를 열 때 복원됩니다. 이러한 옵션 중 일부는 TOAD.INI 파일을 처음 작성할 때(Toad를 처음 열 때) 설정됩니다.

옵션 검색에 설명된 대로 옵션을 검색할 수도 있습니다.


DBMS Output 창

Oracle은 DBMS_OUTPUT이라는 패키지를 제공하며 이 패키지는 특히 PL/SQL 코드 디버깅용 함수로 설계되었습니다. PL/SQL 코드가 쓰는 버퍼를 사용하며 별도의 프로세스로 버퍼를 질의로 출력하여 해당 내용을 표시합니다.

해당 코드를 통해 하나의 단계를 실행하는 동안이 아니라 프로시저 실행이 완료된 후에만 출력이 나타납니다. 중첩된 프로시저 호출에서 모든 프로시저는 DBMS Output 내용이 표시되기 전에 실행을 완료해야 합니다.

DBMS Output 창을 액세스하려면

  • View 메뉴에서 DBMS Output을 선택합니다.

관련 항목

DBMS 출력 생성

출력 폴링

DBMS 출력 디스플레이 편집

디버깅을 위해 DBMS Output 창 사용


DBMS Output 생성

Editor에는 강조표시된 변수에 대한 DBMS_OUTPUT 문을 생성하는 마우스 오른쪽 단추 메뉴 옵션이 있습니다. 빈 DBMS_OUTPUT 문을 만들기 위한 옵션도 같은 메뉴에 있습니다.

다음은 DBMS Output의 예입니다.

DECLARE

t_owner varchar2(30) := 'MYNAME';

CURSOR all_tables_cur IS

SELECT table_name

FROM all_tables

WHERE owner = UPPER (t_owner);

dcursor INTEGER;

out_str VARCHAR2(1000);

BEGIN

DBMS_OUTPUT.PUT_LINE ( 'Inside Procedure ' );

FOR obj_rec IN all_tables_cur

LOOP

dcursor := DBMS_SQL.OPEN_CURSOR;

out_str := 'ALTER TABLE ' || obj_rec.table_name ||

' ENABLE ALL TRIGGERS';

DBMS_OUTPUT.PUT_LINE ( 'Table_name=' || obj_rec.table_name );

DBMS_SQL.PARSE (dcursor, out_str, DBMS_SQL.V7);

DBMS_SQL.CLOSE_CURSOR (dcursor);

END LOOP;

END;

관련 항목

DBMS Output 창

출력 폴링

DBMS Output 표시 편집

DBMS Output 창을 디버깅에 사용


출력 폴링

응용 프로그램은 Oracle에서 출력 결과를 폴링해야 하고 폴링 옵션이 설정된 경우(Toad Options|Editor|Execute/Compile|Poll for DBMS if detected 참조) Toad의 Output 창은 5초마다 폴링됩니다. 창의 오른쪽 상단에 있는 슬라이더를 사용하여 폴링 빈도를 늘리거나 줄일 수 있습니다.

관련 항목

DBMS Output 창

DBMS Output 생성

DBMS Output 표시 편집

DBMS Output 창을 디버깅에 사용


DBMS Output 표시 편집

DBMS Output 창에는 출력 표시를 편집하는 기능이 있습니다.

예를 들어 단일 숫자 매개 변수가 필요한 MyProc라는 프로시저를 디버깅할 경우 다음 문을 사용하여 Editor 창에서 프로시저를 실행할 수 있습니다.

begin MYPROC(1); end;

그러나 위 문을 실행하기 전에 다음과 같은 주석을 사용하여 DBMS Output에서 호출을 문서화할 수 있습니다.

Calling MyProc with 1

그런 다은 출력을 ON으로 설정하고 MyProc를 실행합니다. 호출에 대한 메모 다음에 DBMS_OUTPUT 문이 표시됩니다.

관련 항목

DBMS Output 창

DBMS Output 생성

출력 폴링

DBMS Output 창을 디버깅에 사용


DBMS Output 창을 디버깅에 사용

Editor 창과 함께 사용할 경우 DBMS Output 창은 저장 프로시저 코드를 개발 및 디버깅하는 데 효과적입니다.

코드를 편집, 테스트, 조정 및 반복할 수 있습니다.

DBMS Output 상자에서는 표준 복사, 잘라내기 및 붙여넣기 키가 작동합니다.

관련 항목

DBMS Output 창

DBMS Output 생성

출력 폴링

DBMS Output 표시 편집


Query Viewer

Query Viewer는 현재 실행 중인 배경 질의, 실행 중인 데이터베이스, 현재 실행 시간 및 SQL을 표시합니다. 질의가 실행 순서로 자동으로 표시됩니다. 이 창에서 질의를 취소하거나 실행 중인 Editor 페이지를 표시하고 자세히 검토할 수 있습니다.

Query Viewer는 Toad 내의 개별 창으로 사용할 수 있거나 Editor의 도킹 가능한 패널에서 액세스할 수 있습니다.

Query Viewer를 액세스하려면

  • View 메뉴에서 Query Viewer를 선택합니다.

또는

Editor에서 마우스 오른쪽 단추를 누르고 Editor Desktop을 선택한 다음 Query Viewer를 선택합니다.

질의 도구 모음

단추 | 명령
 | 질의 취소
 | 구문에서 질의 찾기
 | Query Viewer 필터 적용
 | 비활성 질의(활성 데이터 집합이 없는 질의) 지우기
 | 눈금을 수동으로 새로 고침
 | 새로 고침 시간(초) 설정
 | 자동 새로 고침

관련 항목

구문에서 질의 찾기

Query Viewer 필터

Query Viewer 사용


컨텍스트에서 질의 찾기

컨텍스트에서 질의를 찾으면 질의가 실힝 중인 Editor 탭으로 이동하여 해당 질의를 볼 수 있습니다.

컨텍스트에서 질의를 찾으려면

  1. query viewer 그리드에서 찾으려는 질의를 선택합니다.

  2. Find Query in Context [image] 단추를 누릅니다.

관련 항목

Query Viewer

컨텍스트에서 질의 찾기

Query Viewer 사용


Query Viewer 필터

특정 질의를 찾기 위해 Viewer 눈금을 쉽게 필터링할 수 있습니다.

Viewer 눈금을 필터링하려면

  1. Query Viewer 도구 모음에서 Filter [image] 단추를 누릅니다.

  2. 눈금 필터링에 사용할 방법을 선택합니다.

  3. SQL 포함.

  4. n분보다 긴 실행 시간.

  5. 최근 n시간에 시작.

  3. OK를 누릅니다.


Query Viewer 사용

Query Viewer는 실행이 있거나 현재 실행 중인 질의를 눈금 형식으로 표시합니다.

눈금 보기에는 다음 내용을 표시하는 열이 포함됩니다.

  • 데이터베이스

  • 상태

  • 시작 시간

  • 중지 시간

  • 실행 시간

  • 유형

  • SQL

눈금 아래의 패널에는 두 가지 탭이 포함됩니다. 하나는 눈금에서 선택한 SQL을 표시합니다. 다른 하나는 해당 SQL을 실행하는 동안 발생한 모든 오류를 표시합니다.

SQL을 보려면

  1. Query Viewer의 눈금 영역에서 보고자 하는 SQL 항목을 누릅니다.

  2. Query Viewer의 아래쪽 창에서 SQL 탭을 누릅니다.

오류를 보려면

  1. Query Viewer의 눈금 영역에서 보고자 하는 SQL 항목을 누릅니다.

  2. Query Viewer의 아래쪽 창에서 Errors 탭을 누릅니다.

관련 항목

Query Viewer

구문에서 질의 찾기

Query Viewer 사용


Window: SQL Statement Recall (Personal)

SQL Statement Recall (Personal)

이 명령은 SQL Statement Recall 창을 열고 Personal SQL 탭을 활성화합니다.

개인 SQL을 회수하려면

  • View|SQL Command Recall|Recall Personal SQL 메뉴 항목을 선택합니다.

주: Editor|Add to Personal SQLs에서 이 목록에 문을 추가할 수 있습니다.

Toad 세션 사이에서 이 목록에 있는 모든 문은 PERSSQLS.DAT라는 파일에 저장됩니다.

관련 항목

SQL Statement Recall (Named)

Add to Personal SQLs


창: 명명된 SQL 구문 회수

명명된 SQL 구문 회수

이 대화상자의 명명된 SQL 목록에서 SQL 구문을 선택한 다음 Editor 창으로 다시 복사하여 실행합니다.

명명된 SQL을 회수하려면


보관 파일

Main Menu|Utilities|Archive에서 이 창을 액세스합니다.

Archive 창을 통해 Toad 내에서 zip 파일을 만들 수 있습니다.

단추 | 명령
 | New archive
 | Open archive - 드롭다운이 최근에 연 보관 파일이 나열됩니다.
 | Add to archive - 이 명령을 사용하여 현재 열려 있는 보관 파일에 파일을 추가합니다.
 | Extract from archive - 압축을 풀 파일을 강조표시한 다음 이 단추를 눌러 압축을 풉니다. 강조표시된 파일이 없을 경우 어떤 파일도 압축이 풀리지 않습니다.
 | Delete from archive - 열려 있는 보관 파일에서 강조표시된 파일을 삭제합니다.
 | Create Project Manager Reference - 해당 보관 파일의 항목 링크를 작성하여 Project Manager로 배치합니다. 이렇게 하면 보관 파일을 열고, 파일을 찾거나 대상 폴더에 복사하지 않고도 Project Manager 내에 참조를 끌어다 놓을 수 있습니다. Project Manager에서 파일을 사용하는 방법에 대한 자세한 내용은 Project Manager 항목을 참조하십시오.


Script Manager

Script Manager는 자주 사용하는 스크립트를 관리할 수 있는 Toad의 중앙 위치입니다. Script Manager를 사용하여 스크립트를 다양한 범주로 구성한 다음 Script Manager 창에서 쉽게 액세스할 수 있습니다.

Script Manager에 대한 자세한 내용은 Script Manager 개요를 참조하십시오.


Wrap Code

Wrap Code 명령은 Oracle의 Wrap Code 유틸리티를 쉽게 액세스할 수 있는 방법을 제공합니다. 이 창은 따로 연결되어 있으므로 사용하기 위해 데이터베이스 세션을 열지 않아도 됩니다.

코드를 래핑하려면

  1. Utilities 메뉴에서 Wrap Code를 선택합니다. Wrap Code 창이 나타납니다.

  2. Input file 상자에서 전체 경로를 포함하여 래핑할 파일(PL/SQL 코드)을 입력하거나 드릴다운 [image] 단추를 눌러 해당 파일을 찾습니다.

  3. 파일을 선택했으면 해당 파일의 텍스트가 Input File Text 영역에 나타납니다.

  4. 기본값으로 출력 파일은 입력 파일과 동일하게 이름이 지정되지만 확장자는 .plb가 됩니다.

  3. Wrap Code를 누릅니다. 래핑한 코드가 Output File Text 영역에 나타나고 지정한 출력 파일로 자동으로 저장됩니다.

텍스트 영역에 마우스 오른쪽 단추를 눌러 해당 코드를 클립보드에 복사할 수도 있습니다.

문제 해결

Toad의 Wrap Code 인터페이스를 사용하려면 Oracle Wrap Code 유틸리티를 찾을 수 있어야 합니다. Toad가 유틸리티를 찾을 수 있도록 하려면 다음 중 하나에 해당되는지 확인합니다.

  • Wrap Code 유틸리티는 인식된 Windows 경로에 있습니다.

  • View|Toad Options|Executables 페이지에서 Toad의 목록에 경로를 추가했습니다.


Difference Viewer 옵션

이 대화상자에서 색상 및 기타 시각적 특징을 설정하여 Differences Viewer의 다음 요소를 강조표시할 수 있습니다.

  • 일치하는 텍스트

  • 유사한 텍스트

  • 다른 텍스트

  • 누락된 텍스트

  • 일치하지 않는 텍스트 사이의 수평선

또한 Find Next의 차이를 설정하여 위치만 사용하거나(모호한 색상 코드 지정 방지를 위해) 일반 선을 선택할 수 있습니다.

옵션을 액세스하려면

  • Options [image] 단추를 누릅니다. Options 대화상자가 나타납니다.

관련 항목

파일 비교 개요

파일 차이 보기

파일 비교 규칙


Toad 구성 도구

Toad를 구성하여 외부 도구를 연 다음 기본 도구 모음에서 실행할 수 있습니다(Toad 실행 도구 참조).

구성 도구 목록

Auto Add를 사용하려면

Toad 내에서 외부 도구를 열려면 우선 도구 목록에 추가해야 합니다. Toad를 사용하면 일부 기본 응용프로그램에 이 작업을 자동으로 수행할 수 있습니다. Auto Add에서 지원되는 응용프로그램은 다음과 같습니다.

Windows 메모장 | Quest DataFactory
Windows 워드패드 | Quest Instant Messages
Windows 그림판 | Quest Knowledge Base

  1. 기본 도구 모음에서 Configure/Execute External Tools [image] 단추의 arrow를 누릅니다. 드롭다운 메뉴에서 Configure를 선택합니다. Toad Tool Options 대화상자가 나타납니다.

주: 이 아이콘에서 응용프로그램을 실행한 적이 있는 경우 위의 아이콘이 표시되지 않습니다. 대신, 실행한 응용프로그램의 아이콘이 표시됩니다.

  2. Auto Add를 누릅니다. Select programs to add 대화상자가 나타납니다.

  3. 추가할 응용프로그램을 선택합니다. 누를 때 <Ctrl> 키를 눌러 여러 개를 선택할 수 있습니다.

  4. OK를 누릅니다. Toad Tool Options 대화상자의 목록에 해당 응용프로그램이 추가됩니다.

  5. Close를 눌러 자동으로 생성된 목록을 사용하거나 아래 절에 설명된 대로 목록의 도구를 편집 및 이동합니다.

도구를 수동으로 추가하려면

Toad 내에서 외부 도구를 열려면 우선 도구 목록에 추가해야 합니다.

주: 도구를 수동으로 추가하는 것은 바로 가기를 추가하는 것과 동일합니다. 도구가 Auto Add 기능에 포함되어 있으면 외부 도구에 추가하여 올바르게 작동하는지 확인해야 합니다.

  1. 기본 도구 모음에서 Configure/Execute External Tools [image] 단추의 arrow를 누릅니다. 드롭다운 메뉴에서 Configure를 선택합니다. Toad Tool Options 대화상자가 나타납니다.

주: 이 아이콘에서 응용프로그램을 실행한 적이 있는 경우 위의 아이콘이 표시되지 않습니다. 대신, 실행한 응용프로그램의 아이콘이 표시됩니다.

  2. Add를 누릅니다. Toad Tool Properties 대화상자가 나타납니다.

  3. 도구의 Title을 입력합니다. 도구 목록에 표시될 이름이므로 인식할 수 있는 이름을 선택하는 것이 좋습니다. 예를 들어, Notepad를 입력합니다.

  4. Program 상자에서 실행 파일의 전체 경로 이름을 입력합니다. 경로를 직접 입력하거나 전체 경로 이름을 눌러서 찾아볼 수 있습니다. 예를 들어, Notepad의 경로 이름 입력은 다음과 같습니다. C:\WINNT\system32\notepad.exe.

주: 실제 시스템에서는 올바른 경로 이름이 아닐 수도 있습니다.

  5. 해당 도구의 Working Directory를 입력합니다. 이 상자를 누르면 Toad가 도구가 있는 디렉토리를 자동으로 입력합니다. 필요하면 이 디렉토리를 변경할 수 있습니다.

  6. Parameters를 임의로 입력합니다. 이렇게 하면 도구의 구성이 지정되어 결합될 수 있습니다. 일부 표준 매개 변수는 창의 아래에 있는 매크로 상자에 나열되어 있습니다.

  7. $UID - 현재 Toad User ID 입력

  8. $UPW - 현재 Toad User 암호 입력

  9. $SID - 현재 Toad 데이터베이스 ID 입력

  10. $CWD - 현재 Toad 작업 디렉토리 입력

  11. $TMP - Windows 임시 디렉토리 입력

  12. $FIL - 활성 편집기의 파일 입력

이러한 매개 변수는 개별로, 또는 결합하여 사용할 수 있습니다. 예를 들어, Notepad가 활성 편집기의 현재 파일로 자동으로 열리도록 하려면 위의 내용대로 Notepad를 열기 위한 정보를 입력하고 Parameters 상자에 $FIL을 입력합니다.

또한 다음과 같은 명령을 사용할 수도 있습니다. sqlplusw.exe $UID/$UPW@$SID 현재 Toad 연결로 SQL Plus를 시작합니다.

  7. Run 드롭다운에서 일반 창, 최소화 또는 최대화된 창의 도구를 실행할 수 있습니다.

  8. 해당 도구에 사용할 Shortcut 키 입력을 입력합니다. 키 입력이 상자에 나타납니다.

  9. 예를 들어, <Ctrl><Alt><F>를 입력하면 상자에 Ctrl + Alt + F가 표시됩니다.

  10. 아이콘을 아직 선택하지 않은 경우 arrow를 누릅니다. 드롭다운 메뉴에서 아이콘을 선택합니다.

도구를 삭제하려면

  1. 기본 도구 모음에서 Configure/Execute External Tools button ( [image]) 단추의 arrow를 누릅니다. 드롭다운 메뉴에서 Configure를 선택합니다. Toad Tool Options 대화상자가 나타납니다.

주: 이 아이콘에서 응용프로그램을 실행한 적이 있는 경우 위의 아이콘이 표시되지 않습니다. 대신, 실행한 응용프로그램의 아이콘이 표시됩니다.

  2. 삭제할 도구의 name을 누릅니다.

  3. Delete를 누릅니다. 확인 상자가 나타납니다. Yes를 눌러 도구를 삭제합니다.

도구를 편집하려면

목록에 입력한 모든 도구의 설정을 편집할 수 있습니다.

  1. 기본 도구 모음에서 Configure/Execute External Tools button ( [image]) 단추의 arrow를 누릅니다. 드롭다운 메뉴에서 Configure를 선택합니다. Toad Tool Options 대화상자가 나타납니다.

주: 이 아이콘에서 응용프로그램을 실행한 적이 있는 경우 위의 아이콘이 표시되지 않습니다. 대신, 실행한 응용프로그램의 아이콘이 표시됩니다.

  2. 편집할 tool을 선택한 다음 Edit를 누릅니다. Toad Tool Properties 대화상자가 나타납니다.

  3. 설정을 원하는 대로 변경한 다음(도구를 수동으로 추가하려면의 위에 설명된 대로) OK를 누릅니다.

목록의 순서를 변경하려면

목록에서 도구를 위 또는 아래로 이동할 수 있습니다. 도구는 Tool Options 대화상자에 나열된 순서대로 드롭다운 목록에 표시됩니다.

  1. 기본 도구 모음에서 Configure/Execute External Tools button ( [image]) 단추의 arrow를 누릅니다. 드롭다운 메뉴에서 Configure를 선택합니다. Toad Tool Options 대화상자가 나타납니다.

주: 이 아이콘에서 응용프로그램을 실행한 적이 있는 경우 위의 아이콘이 표시되지 않습니다. 대신, 실행한 응용프로그램의 아이콘이 표시됩니다.

  2. 이름을 눌러 이동할 tool을 선택합니다.

  3. 오른쪽 패널에서 녹색의 위쪽 화살표를 눌러 도구를 목록의 위로 이동하거나 아래쪽 화살표를 눌러 목록의 아래로 이동합니다. 목록이 원하는 순서대로 있으면 Close를 누릅니다.


Toad 도구 실행

Toad는 사용자를 위해 외부 도구를 연 다음 기본 도구 모음에서 도구를 실행할 수 있습니다. (Toad 도구 구성을 참조하십시오.)

도구를 실행하려면

  1. 기본 도구 모음에서 Configure/Execute Toad Tools [image] 단추의 dropdown arrow를 누릅니다.

주: 이 아이콘에서 응용프로그램을 실행한 적이 있는 경우 위의 아이콘이 표시되지 않습니다. 대신, 실행한 응용프로그램의 아이콘이 표시됩니다(아래 참조).

  2. 실행할 도구를 선택합니다. 도구가 새 창에서 열립니다.

도구 모음의 외부 도구를 실행하면 Toad Tools 단추가 마지막에 실행한 도구의 아이콘으로 변경됩니다. 그런 다음 드롭다운 목록에서 선택하는 대신 단추를 직접 눌러 도구를 다시 열 수 있습니다.


FTP

이 창에서 FTP 또는 Secure FTP를 사용하여 파일을 전송할 수 있습니다.

FTP(File Transfer Protocol)는 인터넷에서 파일을 송신하는 가장 일반적인 수단입니다. Toad는 Oracle 스크립트가 TCP/IP 연결로 전송될 수 있도록 FTP 지원을 기본으로 포함시켰습니다. Toad FTP는 파일 크기를 최대한 4GB까지 지원할 수 있습니다.

FTP 기능을 액세스하려면

  • Utilities|FTP 메뉴 항목을 선택합니다.

연결

Connect [image] 단추는 FTP 로그온 화면을 표시하며 이 화면은 FTP 서버에 연결하는 데 사용됩니다. 자세한 내용은 서버 설정을 참조하십시오.

Toad가 연결할 수 없으면 Messages 영역에 이 효과에 대한 메시지가 표시됩니다.

연결되면 Disconnect [image] 단추가 활성화됩니다.

다시 연결

Reconnect [image] 단추를 누르면 마지막에 연결한 서버에 다시 연결하고 이전 연결 도중 방문한 마지막 경로로 다시 이동할 수 있습니다.

로컬 패널

왼쪽 패널에는 로컬 컴퓨터용 파일 브라우저가 포함됩니다.

  • 드롭다운 을 사용하여 파일 경로를 입력하거나 이전에 입력한 경로를 선택할 수 있습니다.

  • folder 단추를 누르면 디렉토리 계층에서 한 단계 위로 이동할 수 있습니다.

  • Explore 단추를 누르면 Windows 탐색기와 같은 대화상자가 열리고 로컬 또는 네트워크 디렉토리를 선택할 수 있습니다. 목록 보기 컨트롤에 현재 디렉토리의 폴더 및 파일이 나열됩니다.

  • Compare -

  • Delete - 선택한 파일 또는 디렉토리를 삭제합니다.

주의: Toad는 FTP의 재귀 삭제를 제공합니다. 비어 있지 않은 디렉토리를 삭제하기로 선택하면 파일 또한 삭제됩니다.

  • Exec - 선택한 파일을 실행합니다.

  • Home - 패널을 기본 디렉토리로 재설정합니다.

  • Mkdir - 새 디렉토리를 생성합니다.

  • Refresh - 파일 목록을 새로 고칩니다. 메뉴에서 Refresh를 마우스 오른쪽 단추로 눌러 선택하여 파일 목록을 새로 고칠 수도 있습니다.

  • Rename 단추 - Rename 창이 열리고 FTP 인터페이스에서 선택한 파일의 이름을 바꿀 수 있습니다.

  • View- 선택한 파일을 봅니다.

원격 패널

오른쪽 패널은 원격 FTP 서버용 파일 브라우저를 표시합니다. T

  • 드롭다운을 사용하여 파일 경로를 입력하거나 이전에 입력한 경로를 선택할 수 있습니다.

  • folder 단추를 누르면 디렉토리 계층에서 한 단계 위로 이동할 수 있습니다.

  • Explore 단추를 누르면 Windows 탐색기와 같은 대화상자가 열리고 로컬 또는 네트워크 디렉토리를 선택할 수 있습니다. 목록 보기 컨트롤에 현재 디렉토리의 폴더 및 파일이 나열됩니다.

  • Compare -

  • Delete- 선택한 파일 또는 디렉토리를 삭제합니다.

주의: Toad는 FTP의 재귀 삭제를 제공합니다. 비어 있지 않은 디렉토리를 삭제하기로 선택하면 파일 또한 삭제됩니다.

  • Exec - 선택한 파일을 실행합니다.

  • Home- 이 연결의 Toad Options|Network Utilities에서 지정한 디렉토리로 이동합니다.

  • MkDir - 새 디렉토리를 생성합니다.

  • Refresh - 파일 목록을 새로 고칩니다. 메뉴에서 Refresh를 마우스 오른쪽 단추로 눌러 선택하여 파일 목록을 새로 고칠 수도 있습니다.

  • Rename - Rename 창이 열리고 FTP 인터페이스에서 선택한 파일의 이름을 바꿀 수 있습니다.

  • View - 선택한 파일을 봅니다.

아래 패널

File Transfer Mode 라디오 단추

  • Default - 선택되어 있으면 FTP 서버의 기본 모드가 사용됩니다.

  • ASCII - ASCII 파일 전송(텍스트만 있는 파일은 보다 빨리 전송).

  • Binary - 이진 파일 전송에 사용됩니다.

메시지 패널

연결 및 FTP 서버 메시지가 메시지 패널에 표시됩니다.

파일 전송

로컬 및 원격 컴퓨터 간에 파일을 전송할 수 있습니다. 로컬 또는 원격 패널에서 파일을 선택하여 두 개의 창([<] 또는 [>]) 간에 위치한 방향 단추를 눌러 다른 시스템으로 송신할 수 있습니다. 끌어서 놓기를 사용하여 두 창 간에 파일을 송신할 수도 있습니다. 파일을 두 번 누르면 연결의 다른 쪽으로 송신됩니다.

주: FTP 구성 요소 Toad는 최대 4GB의 파일 크기를 처리할 수 있습니다.


서버 설정

Server Settings 대화상자는 여러 위치에서 사용할 수 있습니다.

Server Settings 대화상자를 열려면

  • 다음 위치에서 Server Settings 대화상자를 엽니다.

  • FTP 창에서 Connect to an FTP server 단추를 누릅니다.

  • Project Manager에서 FTP 폴더를 추가합니다.

  • Unix Monitor에서 Connect를 누릅니다.

  • Unix Job Scheduler에서 서버를 추가합니다.

연결 형식

사용할 연결 형식을 선택할 수 있습니다.

FTP/RExec

안전하지 않은 표준 연결입니다.

Secure FTP/SSH

SSH 연결을 사용하여 클라이언트와 서버 간을 이동하는 데이터를 암호화합니다.

Use Default Port

이 옵션이 선택되어 있으면 Toad는 기본 연결 포트를 사용합니다. 기본값은 다음과 같습니다.

  • FTP/Rexec 연결: 21

  • SSH 연결: 22

Host dropdown

연결할 FTP 서버의 주소를 위한 것입니다. 여러 개의 연결이 드롭다운 제어를 통해 저장 및 회수됩니다.

Port

Use Default Port가 선택되어 있지 않으면 이 상자에서 포트 번호를 지정해야 합니다.

User

FTP 연결용 사용자 ID입니다.

Password

FTP 연결용 암호입니다.

Passive (for firewalls)

표시되어 있으면 바로 서버를 수동 모드로 전환합니다. 서버가 방화벽 안에 있을 경우 이 기능이 특히 도움이 됩니다. 여러 방화벽에서는 FTP 클라이언트 제어가 예상하는 위치에서 FTP 서버가 외부 연결을 더 높은 포트로 열 수 없습니다. 따라서 이 상자가 표시되어 있으면 Toad가 PORT 명령 대신 PASV 명령을 사용합니다. 이렇게 하면 서버가 즉시 수동 모드로 전환되며, 클라이언트만 연결을 초기화합니다.

이 상자가 표시되어 있지 않으면 PORT 명령이 사용됩니다.

Default Local Directory

Toad가 연결에 기본값으로 사용할 로컬 시스템의 디렉토리입니다.

Default FTP Directory

이 영역에서 기본값으로 사용할 FTP 서버의 디렉토리를 지정합니다. 지정된 디렉토리가 없으면 Toad는 서버의 루트 디렉토리를 사용합니다.

Private Key File

Secure FTP/SSH 연결을 선택한 경우 이 상자에 개인 키를 입력합니다. 드릴다운 단추를 사용하여 개인 키 파일로 이동할 수도 있습니다.

Project Manager Items

Project Manager 항목은 Project Manager에서 FTP 폴더를 설정할 때만 사용할 수 있습니다.

Client Directory

클라이언트 디렉토리는 파일 다운로드가 필요한 FTP 작업 도중 다운로드된 파일이 배치되는 디렉토리입니다. 예를 들어, FTP 서버에서 파일을 볼 때 우선 파일이 다운로드된 다음 편집기가 열립니다. 클라이언트 디렉토리가 지정되어 있지 않으면 Windows 임시 파일 디렉토리가 사용됩니다.

Filter

서버측 파일에 적용할 모든 필터를 입력합니다. 이러한 필터는 표준 Windows 필터입니다. 예를 들면, *.doc 또는 *.*입니다.

Overwrite Existing Profile

이 옵션이 선택되어 있으면 Toad가 저장한 FTP 프로파일을 겹쳐 쓴 다음 기본 연결로 만듭니다. 설정한 모든 설정은 새 설정으로 교체됩니다.

OK

이 옵션을 사용하여 FTP 창에서 직접 연결할 경우 OK를 누르면 연결 과정이 시작됩니다. Toad가 연결할 수 없을 경우 Host not Found 메시지가 표시됩니다.

Project Manager 창에서 이 대화상자를 사용할 경우 OK를 누르면 FTP 폴더 작성이 완료됩니다. Project Manager>FTP Folders 항목에 설명된 대로 폴더를 두 번 눌러 연결해야 할 수 있습니다.


창: FTP Messages

FTP Messages

FTP 창 에서 이 창을 열 수 있습니다.

이 창에는 파일 전송 상태 메시지가 표시됩니다.

FTP에 대한 자세한 내용은 FTP를 참조하십시오.


Java Manager 개요

Oracle 8i 이상 버전을 실행 중인 경우 Toad의 Java Manager를 사용하면 LOADJAVA 및 DROPJAVA 유틸리티를 쉽게 액세스할 수 있습니다. Java Manager는 Load Objects 및 Unload Objects의 두 가지 탭으로 구성되어 있습니다.

이를 통해 Java 클래스와 자원 파일을 데이터베이스에서 쉽게 로드 및 언로드할 수 있습니다. LOADJAVA 유틸리티는 사용한 개체 및 옵션을 추적하는 데 사용하는 여러 표를 작성합니다. DROPJAVA는 이러한 표를 정리하고 데이터베이스에서 코드를 언로드합니다.

Java Manager를 액세스하려면

  • Utilities 메뉴에서 Java Manager를 선택합니다.

관련 항목

Java 개체 삭제

Java 개체 로드


개체 로드

Java Manager 창의 Load Objects 탭에서 옵션을 쉽게 설정하고 Oracle의 LOADJAVA 유틸리티를 사용하여 개체를 쉽게 로드할 수 있습니다.

개체를 로드하려면

  1. 로드할 파일을 선택합니다.

  2. 로드 옵션을 선택합니다.

  3. Load를 누릅니다. Oracle의 loadjava.bat 유틸리티 파일을 사용하여 파일이 로드됩니다.

주: Java 개체를 로드하려면 Oracle 8i 이상 버전을 실행해야 하며 Oracle 유틸리티 파일 loadjava.bat를 Oracle 홈 디렉토리에 설치해야 합니다.

로드할 파일 선택

Java 파일 로드의 첫 번째 단계는 데이터베이스에 추가할 파일 목록을 작성하는 것입니다. 로드하기 전에 이 목록에 파일을 추가하거나 기존의 파일을 삭제할 수 있습니다.

주: 이 목록에 파일을 추가하거나 기존 파일을 로드하기 전에 Java Manager를 닫으면 목록이 없어집니다.

파일을 추가하려면

  1. Add를 누릅니다. Select files to load 대화상자가 나타납니다. 디렉토리를 탐색하고 이 대화상자에서 한 번에 하나의 디렉토리에서 파일을 여러 개 선택할 수 있습니다.

  2. 목록에 추가할 파일을 선택하고 Open을 누릅니다.

  3. 다른 디렉토리에 파일이 있을 경우 Load Objects 탭의 Files to load: 영역에 모두 나열될 때까지 이 단계를 반복합니다.

파일을 삭제하려면

로드하지 말아야 할 파일을 Files to load 목록에 추가한 경우 해당 파일을 이번에 삭제할 수 있습니다.

  • 파일을 선택하고 Remove를 누릅니다. 그러면 파일이 목록에서 삭제됩니다.

로드 옵션 선택

탭 아래의 옵션 영역에서 선택한 파일 로드를 위해 옵션을 설정할 수 있습니다. 이러한 옵션은 선택된 파일 모두에 적용됩니다.

Create public synonym

이 옵션이 선택되어 있으면 Java 코드를 로드할 때 공개 동의어가 작성됩니다. Schema Browser의 Synonyms 페이지를 보고 이를 표시할 수 있습니다.

Resolve

Resolve 옵션은 로드한 개체의 모든 외부 참조를 Oracle이 해결하도록 합니다. 이렇게 하면 참조가 해결될 경우 Oracle이 해당 개체를 유효한 것으로 표시합니다. Resolve 옵션은 Resolver에 정의된 사양을 통해 참조를 찾습니다. Resolver 상자가 비어 있으면 Oracle이 우선 스키마를 찾은 다음 공개 동의어를 찾습니다.

Definer

Definer 옵션은 클래스를 작성하여 클래스 소유자의 권한 대신 로그인한 사용자의 권한으로 실행합니다. 이것은 LOADJAVA의 "-definer" 옵션과 동등합니다.

Force loading of classes whether or not they were previously loaded

Java Manager를 사용하여 클래스를 로드한 다음 DROP JAVA 구문을 사용하거나 Schema Browser에서 클래스를 삭제할 경우 클래스를 다시 로드할 때 이 옵션을 선택해야 합니다. Java Manager를 사용하지 않고 클래스를 삭제하면 Oracle이 작성한 표에 항목이 남기 때문입니다. Oracle은 이러한 항목을 확인하고 클래스가 이미 로드되었다고 인식하게 됩니다.

Resolver

이 상자에서 로드 중인 개체에 대한 외부 참조를 해결할 때 Oracle이 참조할 위치에 대한 사양을 입력할 수 있습니다. Resolver 사양은 다음 양식이어야 합니다.

"((name_spec schema_spec) [(name_spec schema_spec)]…)"

Encoding

이 옵션을 사용하여 Java Compiler에 로드 중인 원본 파일에 사용된 인코딩 유형을 제공할 수 있습니다. 드롭다운에서 해당하는 인코딩 유형을 선택합니다. 이 옵션이 비어 있으면 Oracle은 latin1을 사용 중인 것으로 가정합니다.

Schema

이 옵션을 사용하여 로드할 개체를 소유할 스키마를 지정할 수 있습니다. 이 옵션이 비어 있으면 개체가 연결된 사용자 스키마에 배치됩니다. 소유하고 있는 스키마로 로드하려면 Create Table 및 Create Procedure 권한이 있어야 합니다. 다른 사용자의 스키마로 로드하려면 Create Any Table 및 Create Any Procedure 권한이 있어야 합니다.

Grant access to other users

스키마 소유자가 아닌 사용자에게 로드한 개체에 대한 실행 권한을 부여하려면 이 목록에 개체를 포함시킵니다. 쉼표로 구분된 목록으로 사용자를 입력합니다.

관련 항목

Java 개체 삭제

Java Manager 개요

Java


개체 삭제

Java 개체 삭제

Java Manager를 사용하여 개체를 삭제합니다. Java Manager를 사용하여 Java를 로드한 경우 Java 개체를 삭제할 때도 사용하는 것이 좋습니다. 왜냐하면 Oracle의 LOADJAVA 유틸리티가 실행될 때 여러 표가 작성되기 때문입니다. Java Manager를 사용하여 DROPJAVA 유틸리티를 실행하면 이러한 표가 정리되고 데이터베이스의 효율성이 보다 증가합니다.

Java 개체를 삭제하려면

  1. 삭제할 파일을 선택합니다.

  2. 삭제 옵션을 선택합니다.

  3. Drop을 누릅니다. Oracle의 dropjava.bat 유틸리티 파일을 사용하여 파일이 로드됩니다.

주: Java 개체를 삭제하려면 Oracle 8i 이상 버전을 실행해야 하며 Oracle 유틸리티 파일 dropjava.bat를 Oracle 홈 디렉토리에 설치해야 합니다.

삭제할 파일 선택

Java 파일 삭제의 첫 번째 단계는 데이터베이스에서 삭제할 파일 목록을 작성하는 것입니다. 삭제하기 전에 이 목록에 파일을 추가하거나 기존의 파일을 삭제할 수 있습니다.

주: 이 목록에 파일을 추가하거나 기존 파일을 삭제하기 전에 Java Manager를 닫으면 목록이 없어집니다.

파일을 추가하려면

  1. Add를 누릅니다. Select files to drop 대화상자가 나타납니다. 디렉토리를 탐색하고 이 대화상자에서 한 번에 하나의 디렉토리에서 파일을 여러 개 선택할 수 있습니다.

  2. 목록에 추가할 파일을 선택하고 Open을 누릅니다.

  3. 다른 디렉토리에 파일이 있을 경우 Drop Objects 탭의 Objects to drop: 영역에 모두 나열될 때까지 이 단계를 반복합니다.

파일을 삭제하려면

삭제하지 말아야 할 파일을 Files to load 목록에 추가한 경우 해당 파일을 이번에 삭제할 수 있습니다.

  • 파일을 선택하고 Remove를 누릅니다. 그러면 파일이 목록에서 삭제됩니다.

삭제 옵션 선택

탭 아래의 옵션 영역에서 선택한 파일 삭제를 위해 옵션을 설정할 수 있습니다. 이러한 옵션은 Objects to drop 목록의 모든 파일에 적용됩니다.

Drop synonym

이 옵션이 선택되어 있으면 Java 개체와 관련된 모든 공개 동의어 또한 삭제됩니다. Schema Browser의 Synonyms 페이지를 보고 이 문제가 발생했음을 표시할 수 있습니다.

Encoding

이 옵션을 사용하여 Java Compiler에 삭제 중인 원본 파일에 사용된 인코딩 유형을 제공할 수 있습니다. 드롭다운에서 해당하는 인코딩 유형을 선택합니다. 이 옵션이 비어 있으면 Oracle은 latin1을 사용 중인 것으로 가정합니다.

Schema

이 옵션을 사용하여 삭제 중인 개체를 소유하는 스키마를 지정할 수 있습니다. 이 옵션이 비어 있으면 연결된 사용자 스키마에서 개체가 삭제됩니다.


네트워크

Network Utilities 명령을 사용하여 Network Utilities 창을 액세스할 수 있습니다. 이 창에서 IP 주소로 작업하고, 다른 계정으로 Telnet 작업도 하고, RExec 명령을 사용하거나 다양한 탭에서 서버를 ping할 수 있습니다.

Network Utilities 옵션을 액세스하려면

  1. Utilities 메뉴에서 Network Utilities를 선택합니다. 그러면 Network Utilities 창이 나타납니다.

  2. 탭에서 사용할 유틸리티를 선택합니다.

  3. 모든 필수 입력 필드를 채우고 적절한 명령 단추를 누릅니다.

관련 항목

FTP

IP 주소

Ping

RExec

Telnet

TNS Ping


Telnet

Telnet(Telecommunications Network)은 다른 컴퓨터에 연결하여 명령을 수행할 수 있는 세션을 구축하는 프로토콜입니다. 이 프로토콜은 Internet RFC 854에 지정되어 있습니다.

Telnet 탭은 Telnet 프로토콜을 구현하는 서버와 통신하는 데 사용됩니다. 간단한 인터페이스를 통해 telnet 기능을 제공합니다. 이번에는 표시할 수 있는 문자 및 <Enter> 키만 지원되지만(백스페이스 등의 제어 문자는 현재 지원 안됨) 터미널 에뮬레이터와 같이 작동합니다.

telnet을 사용하려면

  1. Telnet tab은 Network Utilities 메뉴 항목에서 액세스할 수 있습니다.

  2. 드롭다운 상자에서 호스트 이름 또는 IP 주소를 입력하고 Connect를 누릅니다.

  3. Toad는 호스트 컴퓨터에 연결됩니다. 창에서 로그인 정보가 나타납니다. "Login:" 다음에 로그인 이름을 입력하고 <Enter>를 누릅니다. 그런 다음 원격 시스템이 암호를 요청합니다. 암호를 입력한 다음 <Enter>를 누릅니다.

호스트 컴퓨터에 연결되어 있으면 Toad의 상단 패널이 콘솔이 되어 서버 및 입력한 명령의 메시지를 표시합니다. 하단 패널은 프로토콜의 일부로 송/수신한 Telnet 명령을 표시합니다.

마우스 오른쪽 단추 메뉴에서 화면을 지우거나 클립보드에 정보를 복사할 수 있습니다..

Save Output 단추를 누르면 Save As 창을 사용하여 정보를 저장할 수 있습니다.

관련 항목

FTP

IP 주소

네트워크

Ping

RExec

TNS Ping


RExec

RExec 명령을 사용하여 UNIX 서버에서 한 번에 하나의 UNIX 명령만 실행할 수 있습니다. Telnet을 사용하여 확장된 기간 동안 로그온하는 대신 RExec 탭에 해당 정보를 입력하고 Toad를 통해 하나의 명령을 실행합니다. Toad는 해당 명령을 실행하고, 결과를 제공하고, 연결을 닫습니다.

주: 이 유틸리티를 사용하려면 서버가 RExecd를 실행 중이어야 합니다. 또한 UNIX의 일부 변형은 RExec를 rlogin으로 처리할 수 있으며 ".profile" 등의 로그인 파일을 자동으로 실행할 수 있습니다. 이러한 경우 관련 없는 출력 명령, "motd"(message of the day)으로 인해 Toad의 출력 분석이 방해받을 수 있습니다.

RExec를 사용하려면

  1. RExec는 Network Utilities 메뉴 항목에서 액세스할 수 있습니다. RExec 탭을 누릅니다. RExec 정보가 나타납니다.

  2. Host/IP 필드를 누릅니다. 호스트 이름 또는 IP 주소를 입력합니다.

  3. <Tab> 또는 Username 필드를 누릅니다. 연결에 사용할 사용자 이름을 입력합니다.

  4. <Tab> 또는 Password 필드를 누릅니다. 암호를 입력합니다.

  5. <Tab> 또는 Command 필드를 누릅니다. LS 또는 WHO 등의 UNIX 명령을 입력합니다.

  6. Execute를 누릅니다. Toad가 로그인하고, 명령을 실행하고, 로그 아웃하고 기본 패널에 결과를 표시합니다.

주: 입력한 명령("bc" 등)에 추가 정보가 필요할 경우 결과 창에 정보를 입력하거나 <ENTER>를 눌러 결과를 확인해야 합니다.

마우스 오른쪽 단추 메뉴에서 화면을 지우거나 클립보드에 정보를 복사할 수 있습니다..

RExec 상자의 큰 명령

RExec 명령 상자에 입력할 명령이 매우 클 경우 상자를 두 번 누를 수 있습니다. 이렇게 하면 작은 텍스트 Editor에서 입력하는 명령의 전체를 확인할 수 있습니다.

관련 항목

FTP

IP 주소

네트워크

Ping

Telnet

TNS Ping


Ping

Ping 탭에서 서버의 가용성을 확인할 수 있습니다. ICMP를 사용하여 네트워크상의 다른 시스템에 연결하여 연결 완료 여부를 알려줍니다.

Ping 탭은 Network Utilities 메뉴 항목에서 액세스할 수 있습니다.

서버를 ping하려면

  1. Host name/IP field에 호스트 이름 또는 IP 주소를 입력합니다.

  2. Interval을 선택하여 서버를 확인합니다. 이 간격의 단위는 밀리초입니다.

  3. Start를 누릅니다. Stop을 누를 때까지 지정한 서버를 Toad가 특정 간격으로 반복하여 ping합니다. 창의 아래 부분에 결과가 표시됩니다.

마우스 오른쪽 단추 메뉴에서 화면을 지우거나 클립보드에 정보를 복사할 수 있습니다..

관련 항목

FTP

IP 주소

네트워크

RExec

Telnet

TNS Ping


TNS Ping

TNS Ping은 TNS Listener가 tnsnames.ora 파일의 연결 문자열 중 하나를 위해 실행 중인지 확인하는 Oracle 유틸리티입니다. TNS Ping은 제공된 연결 문자열을 사용하여 tnsnames.ora 파일을 참조하여 Oracle을 실행 중인 시스템의 이름 또는 IP 주소를 확인하고, Listener를 연결 및 점검합니다. TNS Ping 탭에서 TNS Ping 유틸리티를 사용하는 서버의 이용 여부를 확인할 수 있습니다.

TNS Ping을 사용하려면

  1. 이 유틸리티를 사용하려면 TNS Ping 탭을 엽니다. TNS Ping 탭은 Network Utilities 메뉴 항목에서 액세스할 수 있습니다.

  2. 드롭다운 메뉴에서 호스트 이름을 선택합니다.

  3. TNS Ping을 누릅니다. Toad는 Listener에 ping을 실행하게 되고 결과가 창에 표시됩니다.

Listener를 찾을 경우 결과 영역에 Attempting 및 OK가 나타납니다. Listener를 찾을 수 없는 경우 No Listener가 나타납니다.

마우스 오른쪽 단추 메뉴에서 화면을 지우거나 클립보드에 정보를 복사할 수 있습니다..

관련 항목

FTP

IP 주소

네트워크

Ping

RExec

Telnet


IP 주소

IP Addresses 탭을 사용하여 호스트 이름/URL의 IP 주소를 확인합니다. 아니면 특정 IP 주소의 호스트 이름을 확인할 수 있습니다.

IP 주소를 찾으려면

  1. IP Addresses 탭은 Network Utilities 메뉴 항목에서 액세스할 수 있습니다.

  2. IP Addresses 탭을 선택합니다.

  3. 탭의 위에 로컬 호스트 이름 및 IP 주소가 표시됩니다. 이 내용은 변경할 수 없습니다.

  4. 화면의 아래 부분의 Host/IP/URL 상자에 호스트 이름, IP 주소 또는 URL을 입력합니다.

  5. Find를 누릅니다. 서버의 IP 주소가 상자 아래의 표에 표시됩니다. IP 주소를 입력하면 동일한 방식으로 표시됩니다.

마우스 오른쪽 단추 메뉴

상자 아무 곳에서나 마우스 오른쪽 단추를 눌러 자주 사용하는 명령을 액세스할 수 있습니다.

  • 결과를 지우려면 Clear를 선택합니다.

  • 상자의 내용을 클립보드에 복사하려면 Clipboard를 선택합니다. 그런 다음 Toad의 다른 부분 또는 기타 응용프로그램에 붙여 넣을 수 있습니다.

관련 항목

FTP

네트워크

Ping

RExec

Telnet

TNS Ping


SSH

Secure Shell을 사용하면 암호/ID 및 데이터 암호화를 사용하여 네트워크 상의 다른 컴퓨터에 로그인하고, 원격 시스템에서 명령을 실행하고, 시스템 간에 파일을 이동할 수 있습니다. 또한 안전하지 않은 채널에 강력한 인증 및 안전한 통신 기능을 제공하며, TELNET, RLOGIN, RSH 및 RCP의 안전한 대체 방식입니다.

Secure Shell은 다음 중 하나 이상을 사용하여 인증합니다.

  • 암호(UNIX의 /etc/passwd 또는 /etc/shadow)

  • 사용자 개인 키(릴리즈에 따라 RSA 또는 DSA)

SSHv1 및 SSHv2의 두 개의 사용 가능한 Secure Shell 버전이 있습니다. 이 버전은 완전히 다른 두 개의 프로토콜이며, 패킷의 다른 부분에서 암호화되므로 호환되지 않습니다.

SSHv2는 보다 안전하므로 현재 개발 표준입니다.

SSH 탭은 Network Utilities 창에 있습니다. 이 탭에는 설정 영역뿐만 아니라 3개의 패널이 있습니다. 상단 패널은 서버의 메시지(SSH 명령 아님)를 사용자에게 표시합니다. 두 번째 패널은 입력한 명령의 Send 단추뿐만 아니라 입력한 명령도 표시합니다. 하단 패널은 프로토콜의 일부로 송/수신한 SSH 명령을 표시합니다.

SSH로 연결하려면

  1. Utilities 메뉴에서 Network Utilities를 선택합니다.

  2. SSH 탭을 누릅니다.

  3. Connection Properties 영역에서 다음을 입력합니다.

  4. 호스트 이름

  5. 포트(기본값: 22)

  4. SSH 버전 1 또는 버전 2 중 하나를 선택합니다.

  5. Authentication Properties 영역에서 다음을 입력합니다.

  6. 사용자 이름

  7. 암호

  8. PUBLICKEY 인증 유형의 개인 키 파일

  6. Connect를 누릅니다.


Service Manager

Utilities 메뉴를 선택한 다음 Service Manager를 선택하여 이 창에 액세스합니다.

Service Manager는 일괄 처리 시작/중지를 쉽게 수행할 수 있는 로컬 컴퓨터 및 다른 네트워크 컴퓨터에 있는 서비스의 정적 목록을 유지 관리합니다. 이 목록은 Services.ini 파일에 저장됩니다.

서비스 추가

새 서비스를 Service Manager 목록에 추가할 수 있습니다.

로컬 컴퓨터에서 추가하려면

  1. Add를 누릅니다.

  2. Computer Name 상자에 아무 것도 입력하지 않고 Search를 누릅니다. 가능한 서비스 목록이 표시됩니다.

  3. Toad Service Manager에 추가할 서비스를 선택합니다. <Shift> 및 <Ctrl> 키를 눌러 여러 항목을 선택할 수 있습니다.

  4. OK를 눌러 선택한 서비스를 서비스 목록에 추가합니다.

네트워크 컴퓨터에서 추가하려면

  1. Add를 누릅니다.

  2. Computer Name 상자에 컴퓨터 이름(예: testmachine 또는 \\testmachine)을 입력하고 Search를 누릅니다. 가능한 서비스 목록이 표시됩니다.

주: 서비스를 표시하려면 원격 컴퓨터에 대한 관리자 권한이 있어야 합니다.

  3. Toad Service Manager에 추가할 서비스를 선택합니다. <Shift> 및 <Ctrl> 키를 눌러 여러 항목을 선택할 수 있습니다.

  4. OK를 눌러 선택한 서비스를 서비스 목록에 추가합니다.

서비스 제거

서비스를 제거하려면

  • 서비스 목록에서 서비스를 선택하고 Remove를 누릅니다.

새로 고침

서비스 목록을 새로 고치려면

  • 서비스 목록을 새로 고치하려면 Refresh를 누릅니다. 서비스 상태에 변경이 있을 경우(예: 실행 중인 서비스가 중지된 경우) 상태 열이 업데이트됩니다.

서비스 시작 및 중지

서비스가 서비스 목록에 포함되고 나면 서비스를 쉽게 시작 및 중지할 수 있습니다.

서비스를 시작하려면

  • 시작할 서비스를 선택한 다음 Start를 누릅니다. 서비스는 목록에 표시된 순서대로 시작됩니다.

서비스를 중지하려면

  • 끝낼 서비스를 선택한 다음 Stop을 누릅니다. 서비스는 목록에 표시된 순서대로 중지됩니다.


작업 스케줄러

Toad Task Scheduler는 Windows Task Scheduler에서 사용하기 쉬운 인터페이스입니다. 이 인터페이스를 사용하여 작업을 작성, 편집 및 실행할 수 있습니다.

Windows Task Scheduler에 대한 자세한 내용은 Windows 설명서를 참조하십시오.

작업 도구 모음

단추 | 명령
 | New Task - Windows 작업 마법사를 열고 새 Windows 작업을 작성합니다.
 | Delete Task - Task Scheduler에서 선택한 작업을 삭제합니다.
 | Run Task - 예약된 시간에 관계 없이 작업을 즉시 실행합니다.
 | Task Properties - 선택한 작업의 Windows 속성을 표시합니다. 그런 다음 편집 또는 추가할 수 있습니다.
 | 이전 작업을 삭제합니다.
 | 작업 목록을 새로 고칩니다.

관련 항목

작업 추가 마법사

작업 속성 보기

작업 스케줄링


추가 작업 마법사

추가 작업 마법사를 사용하여 여러 매개 변수로 Windows Task Scheduler에 작업을 쉽게 추가할 수 있습니다.

Windows Task Scheduler에 작업을 추가하려면

  1. File 메뉴에서 Task Scheduler를 선택합니다.

  2. 스케줄러 도구 모음에서 Add Task [image] 단추를 누릅니다.

  3. Application 상자에서 응용프로그램 실행 파일의 전체 경로 이름을 입력합니다.

또는

드릴다운 단추를 누르고 응용프로그램 실행 파일을 선택합니다.

  4. Parameters 상자에서 아무 매개 변수나 입력합니다.

주: 매개 변수는 시작할 때 응용프로그램에 전달할 명령줄 인수입니다.

  4. Working Dir 상자에서 사용할 작업 디렉토리의 경로를 입력합니다. 작업 디렉토리를 입력하지 않으면 Windows에서 해당 응용프로그램 실행 파일이 들어 있는 디렉토리를 사용하게 됩니다.

  5. 설명을 입력합니다. 이러한 설명은 작업 속성 대화상자에서 사용할 수 있습니다.

  6. Next를 누릅니다.

  7. 해당 작업에 사용할 이름을 입력하고 작업을 실행할 빈도수를 선택합니다.

  8. Next를 누릅니다.

  9. 해당 작업의 스케줄을 입력합니다.

  10. Next를 누릅니다.

  11. 해당 작업의 사용자 정보를 입력합니다.

주: 사용자 계정은 Oracle 사용자 정보가 아닌 Windows 운영 체제용 계정입니다.

  12. Next를 누릅니다.

  13. 작업을 작성하려면 Finish를 누릅니다.

관련 항목

작업 스케줄러

작업 속성 보기

작업 스케줄링


작업 속성 보기

작업을 예약한 후 해당 작업의 속성을 보거나 편집해야 할 수도 있습니다. Toad의 Task Scheduler 화면에서 이 작업을 수행할 수 있습니다.

작업 속성

Properties 대화상자에 표시되는 속성은 여러 종류가 있습니다. 탭은 다음과 같이 구분됩니다.

Task

여기에는 다음을 포함한 작업의 가장 기본적인 정보가 나열됩니다.

  • 응용프로그램

  • 매개 변수

  • 작업 디렉토리

Schedule

Schedule 화면에는 작업이 사용하는 일정과 마지막 실행 시간 및 다음 실행 시간이 모두 나열됩니다. 일정을 편집할 수도 있습니다. (작업 스케줄링 참조)

Settings

Settings 화면에서 작업의 유휴 시간 및 우선 순위를 조정할 뿐만 아니라 작업에 다양한 플래그를 설정할 수 있습니다.

Custom

Custom 화면에서 작업에 설명을 추가하거나 추가할 수 없는 이진 데이터를 추가할 수 있습니다.

작업 속성을 보려면

  1. File 메뉴에서 Task Scheduler를 선택합니다.

  2. 작업 눈금에서 작업을 선택합니다.

  3. Task Properties [image] 단추를 누릅니다.

또는

마우스 오른쪽 단추를 누르고 Properties를 선택합니다.

  4. 보고자 하는 속성의 탭을 누릅니다.

  5. 마치면 OK를 누릅니다.

관련 항목

작업 스케줄러

작업 추가 마법사

작업 스케줄링


작업 스케줄링

이미 작성한 작업의 일정을 편집할 수 있습니다.

작업 일정을 편집하려면

  1. File 메뉴에서 Task Scheduler를 선택합니다.

  2. 작업 눈금에서 편집할 작업을 선택합니다.

  3. Task Properties [image] 단추를 누릅니다.

또는

마우스 오른쪽 단추를 누르고 Properties를 선택합니다.

  4. Schedule 탭을 누릅니다.

  5. Edit 단추를 누릅니다.

  6. 일정을 변경한 다음 OK를 누릅니다.

  7. OK를 눌러 변경 내용을 저장합니다.

관련 항목

작업 스케줄러

추가 작업 마법사

작업 속성 보기


TNSNames Editor의 제한 사항

TNSNames Editor는 여러 표준 Oracle 구문을 지원합니다. 하지만 이전 기능 또는 고급 기능을 지원하지 않습니다.

Toad TNSNames Editor가 지원하지 않는 기능은 다음과 같습니다.

  • BEQ 프로토콜

  • Oracle 7 COMMUNITY 키워드

  • 여러 설명 목록

  • 여러 주소 목록

  • ADDRESS_LIST 키워드 없음(Editor가 올바르게 분석하지만 ADDRESS_LIST 매개 변수를 항목에 다시 추가하며 이 매개 변수로 인해 동등한 구성이 만들어집니다.)

  • TNSNames Editor에서 생성한 조합을 제외하고 FAILOVER, SOURCE_ROUTE 및 LOAD_BALANCE.

이러한 모든 경우 사용자가 특정 항목을 편집하기로 선택하지 않는 한 TNSNames Editor가 항목을 변경하지 않습니다. 지원되지 않는 항목을 변경하지 않으면 파일은 사용할 수 없는 상태로 남습니다.

이와 같이 지원되지 않는 기능 중 하나를 사용하여 서비스 이름을 편집하지 않으면 Editor가 Edit Service 대화상자에서 항목을 최대한 분석합니다. Edit Service 상자에서 OK를 누른 다음 파일을 저장하면 지원하는 구조에 항목을 기록합니다.

TNSNames Editor가 파일을 겹쳐 쓸 때마다 우선 동일한 디렉토리에 해당 파일의 백업을 만듭니다. 실수로 파일에 문제가 발생할 경우 백업 파일을 사용하면 됩니다.


클립보드의 서비스 붙여넣기

TNSNames 파일에 추가해야 할 다른 매체에 서비스 목록이 있으면 복사하고 파일에 직접 붙여 넣을 수 있습니다.

클립보드의 서비스를 붙여 넣으려면

  1. 클립보드로 내용을 복사합니다.

  2. 내용을 붙여 넣을 TNS 파일을 선택합니다. (TNSNames Editor에 두 개의 파일을 로드한 경우 이동할 파일의 패널을 누릅니다.)

  3. TNS Names Editor에서 Paste Service from Clipboard [image] 단추를 누릅니다.


Unix Scheduler 개요

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Toad UNIX Job Scheduler를 사용하면 DBA가 cron을 사용하여 UNIX 데이터베이스 서버에 있는 작업을 예약 및 실행하면서 설치를 편리하게 관리할 수 있습니다.

스케줄러에서 서버 및 데이터베이스를 정의하고 나면 작업을 할당하고 예약할 수 있습니다. 그런 다음 모든 데이터베이스의 모든 작업을 여러 서버에 배포할 수 있습니다. crontab 파일이 작성되고 각 서버로 전송되어 작업을 시작합니다.

스케줄러에서는 각 서버에서 관리할 수 있는 로그 파일을 통해 각 작업의 성공을 추적할 수 있는 기능도 제공합니다. 마지막으로 이 프로그램을 사용하면 사용자가 클라이언트에서 cron을 시작 또는 중지하고 crontab 파일을 볼 수 있습니다.

Toad UNIX Scheduler에는 UNIX 셸 스크립트에서 사용되는 여러 작업이 포함되어 있습니다. 이러한 작업은 데이터베이스 백업, 일반 DBA, 색인 유지관리, 테이블 유지관리의 네 범주로 구성되어 있습니다. 직접 작업 파일을 쓸 수도 있으며, Scheduler가 이 작업을 돕기 위한 샘플 템플릿을 생성할 수도 있습니다.

주: 일부 서버에서 UNIX Scheduler가 제대로 작동하려면 사용자가 cron.allow 파일에 포함되어 있어야 합니다. 자세한 내용은 cron.allow 및 cron.deny에 대한 서버 도움말을 참조하십시오.

주의: 배포할 때 이 사용자의 다른 모든 cron 작업을 덮어씁니다. 기존 UNIX 계정을 사용하는 경우에는 이미 crontab 파일이 있기 때문에 Toad를 사용하여 db 작업을 예약하려면 UNIX 서버에 crontab 구성 파일을 백업해야 합니다.

UNIX Scheduler에 액세스하려면

  • Utilities 메뉴에서 UNIX Job Scheduler를 선택합니다.

UNIX Scheduler 창

UNIX Scheduler는 두 패널로 구성됩니다. 왼쪽 패널에는 서버 및 사용 가능한 작업 범주의 트리 구조가 있습니다. 오른쪽 패널에는 왼쪽 패널에서 선택한 항목을 다시 참조하는 세부 정보가 다음과 같이 표시됩니다.

Available tasks(SID에 할당되지 않은 작업)

오른쪽에 작업 파일의 내용을 표시합니다.

Available tasks node or a sub node under it("범주")

오른쪽에 해당 범주에 대한 작업과 작업 설명을 표시합니다(파일 헤더에서 구문 분석). 오른쪽에서 작업을 선택하고 마우스 오른쪽 단추를 누르면 "Find/View"를 선택할 수 있습니다. 이 항목을 선택하면 작업을 찾아 왼쪽의 트리 보기로 이동할 수 있습니다.

Server node

오른쪽에 SID 정보를 표시합니다. 오른쪽에 있는 "Log" 탭에는 cron 로그 파일 관리에 사용되는 인터페이스가 표시됩니다.

SID 노드

할당된 모든 작업이 수행 시기를 좁게 나타낸 오른쪽에 표시되고(이 보기는 cron에서 예정을 보는 방법에 해당) 매개 변수 값이 할당됩니다.

Assigned task 노드

오른쪽에 할당된 작업 속성 정보를 표시합니다.


Unix Scheduler 문제 해결

Unix Scheduler에 문제가 발생한 경우 문제 해결을 위해 두 가지를 시도할 수 있습니다.

  • FTP 와 RExec 액세스를 제대로 구성해야 합니다. 연결 테스트에 대한 자세한 내용은 FTP 및 RExec를 참조하십시오.

  • 일부 서버에서 UNIX Scheduler가 제대로 작동하려면 사용자가 cron.allow 파일에 포함되어 있어야 합니다. 자세한 내용은 cron.allow 및 cron.deny에 대한 서버 도움말을 참조하십시오.


서버 및 SID 작성

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

스케줄러를 사용하는 첫 단계에서는 일반적으로 사용자별 환경에서 서버와 데이터베이스를 한 번 설정해야 합니다. 스케줄러에서는 Windows 클라이언트 호스트 파일과 기본 tnsnames.ora 파일을 읽고 이 프로세스를 약간 단순화합니다. 스케줄러는 호스트 파일에 있는 각 호스트에 대해 tnsnames.ora 파일에서 HOST 항목을 찾습니다. 항목을 찾으면 왼쪽 트리 보기를 그에 맞게 미리 채웁니다.

Windows 호스트 파일에서 항목을 찾을 수 없는 경우에는 시작할 때 왼쪽의 트리 보기에 "All available tasks" 노드 하나만 표시됩니다. 이 노드의 내용에 대해서는 나중에 설명합니다.

주의: 이 기능은 보안 클라이언트에서만 사용해야 합니다. UNIX 서버의 암호는 Toad 옵션에서 암호 저장 옵션이 어떻게 설정되었는지에 관계 없이 클라이언트에 암호화되어 저장됩니다. 또한 데이터베이스 암호는 작업 데이터 파일에 암호화되어 저장되지만 Toad가 서버에 배포하는 실제 파일에서는 암호화가 해제됩니다. 이 파일은 클라이언트와 서버 모두에 나타납니다. Toad를 네트워크로 설치한 경우에는 이 파일이 Toad 서버에 나타나지 않습니다.

서버 추가

새 서버를 작성하려면

  • 트리 보기를 마우스 오른쪽 단추로 누르고 Add server를 선택합니다. 기본값이 일부 표시된 Server Settings 대화 상자가 나타납니다.

  • Server 상자에는 새 서버의 이름이 있고, 드롭다운에는 Windows 클라이언트 호스트 파일에서 찾을 수 있는 모든 호스트의 이름이 있습니다.

미리 정의된 서버를 실수로 삭제한 경우에는 드롭다운을 사용하여 다시 작성할 수 있습니다.

  • IP 상자에는 서버의 IP 주소가 포함되어 있습니다. 이 상자는 rexec 및 ftp 명령의 배포 프로세스 중에 사용됩니다.

  • UNIX 사용자 ID와 암호는 서버 계정 정보를 포함하며 rexec 및 ftp 명령의 배포 프로세스 중에 사용됩니다.

  • 서버에 있는 Toad 디렉토리의 경로를 지정합니다.

모든 필드는 필수 필드입니다.

SID 추가

서버를 정의한 후 서버에 작업을 예약하려면 서버에 최소한 하나 이상의 데이터베이스를 정의해야 합니다.

SID를 추가하려면

  • 트리 보기에서 해당 서버를 마우스 오른쪽 단추로 누르고 Add SID를 선택합니다. 다음 정보를 입력합니다.

  • SID - 데이터베이스의 SID 이름이 포함됩니다. 이 이름을 tnsnames 파일에 있는 서버 이름과 혼동하면 안 됩니다. 이 값은 tnsnames 파일의 SID = 또는 Service_Name =으로 시작하는 줄에서 찾을 수 있습니다. 이 값은 데이터베이스의 db_name 값입니다.

주: Toad는 SID에서 점 기호를 지원하지 않습니다.

  • Oracle home - 데이터베이스 인스턴스의 "Oracle 홈"에 대한, 서버 상의 정규화된 디렉토리를 포함합니다. 예를 들어 기본 9i 홈은 /home/oracle/product/9.0.1일 수 있습니다.

  • DBA user id and password - 작업을 수행하려면 유효한 DBA 계정 정보를 포함해야 합니다.

SID 매개 변수 그룹 상자에 있는 모든 필드는 필수 필드입니다.

  • Toad user id and password - Toad 스키마에 액세스하는 작업에서만 사용됩니다. 그런 작업을 예약하는 경우에만 필수입니다.

  • SYSDBA user id and password boxes - 데이터베이스 시작 및 종료와 같이 SYSDBA 수준의 액세스가 필요한 특정 작업에서만 사용됩니다. 그런 작업을 예약하는 경우에만 필수입니다.


UNIX Job Scheduler에서 작업 할당

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

서버와 SID를 정의하고 나면 SID에 작업을 할당할 수 있습니다. SID에 작업을 할당하는 방법에는 여러 가지가 있습니다. 새 작업을 할당할 수도 있고 한 SID에서 다른 SID로 복사할 수도 있습니다. 다양한 SID에 작업을 할당하고 나면 작업 속성을 설정해야 합니다.

새 작업 할당

특정 SID에 한 작업을 할당하려면

  1. 왼쪽 패널의 트리 보기에서 All available tasks를 선택하거나 해당 노드 아래에 있는 하위 범주를 선택합니다. 오른쪽 패널에 작업 목록이 표시됩니다.

주: 트리 구조에서 특정 작업을 선택한 경우에는 스크립트 자체가 오른쪽 패널에 표시됩니다.

  2. 오른쪽 패널에서 작업을 하나 이상 선택하고 왼쪽에 있는 SID로 끌어 놓습니다. SID가 강조표시되면 마우스 단추를 놓습니다. 작업이 할당됩니다.

동시에 여러 SID에 작업을 할당하려면

하나 이상의 작업을 특정 호스트에 있는 모든 SID에 할당할 수도 있습니다.

  1. 왼쪽 패널의 트리 보기에서 All available tasks를 선택하거나 해당 노드 아래에 있는 하위 범주를 선택합니다. 오른쪽 패널에 작업 목록이 표시됩니다.

  2. 오른쪽 패널에서 작업을 하나 이상 선택하고 왼쪽에 있는 호스트로 끌어 놓습니다. 호스트 이름이 강조표시되면 마우스 단추를 놓습니다. 작업이 호스트에 있는 모든 SID에 할당됩니다.

또한 왼쪽 트리 보기에서 끌어서 놓아 작업을 할당할 수도 있습니다.

할당된 작업을 복사하려면

SID에 이미 할당된 작업을 다른 SID에 복사할 수 있습니다.

  • SID를 눌러 그 아래에 할당된 작업을 봅니다. 복사할 작업을 선택하여 다른 SID로 끌어 놓습니다.

  • 작업이 할당된 SID를 끌어서 다른 SID에 놓으면 SID에 있는 모든 작업을 다른 SID로 복사할 수 있습니다. 소스 SID에 할당된 모든 작업이 대상 SID에 복사됩니다. 그러나 이 작업에서 이미 정의된 작업을 덮어쓰지는 않습니다.


작업을 서버에 배포

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

하나 이상의 작업이 할당되고 매개 변수에 값이 제공된 후에 서버에 배포할 수 있습니다. 배포 프로세스는 빠르고 효율적인 일련의 rexec 및 ftp 명령입니다. 이 프로세스에서는 rexec 및 ftp 모두에 대해 계정 정보와 서버가 올바르게 구성되었다고 가정합니다. 서버가 적절하게 구성되지 않은 경우 배포 프로세스를 완료할 수 없거나 오류가 반환될 수 있습니다.

주의: 배포를 수행할 경우 이 사용자에 대한 다른 모든 cron 작업을 덮어씁니다. 이미 crontab 파일이 있는 기존 UNIX 계정을 사용하는 중이면 Toad를 사용하여 db 작업을 예약하려는 경우 UNIX 서버에서 crontab 구성 파일을 백업해야 합니다.

작업을 서버에 배포하려면

  1. Deploy 단추를 누릅니다.

이 대화 상자의 그리드는 할당된 작업이 있는 서버 목록으로 채워집니다.

  2. 배포하려는 작업이 포함된 서버를 선택합니다. "Remove" 확인란을 선택하여 이전의 스케줄러 배포 데이터를 덮어쓸지 여부를 선택합니다.

주의: 배포를 수행할 경우 이 사용자에 대한 다른 모든 cron 작업을 덮어씁니다.

  3. Deploy 단추를 누릅니다.

상태 창이 열리고 서버 배포의 진행률이 표시됩니다.

이 상태 창에는 배포 도중에 수행된 작업이 정확하게 표시됩니다.

  • 필요한 서버 디렉토리가 RExec를 사용하여 만들어집니다. 여기에는 서버 속성에 지정된 스케줄러 루트 디렉토리와 4개의 하위 디렉토리인 dmp, log, shell 및 tmp가 포함됩니다.

  • shell 하위 디렉토리는 모든 작업 파일이 복사되는 위치입니다.

  • log 하위 디렉토리에는 로그 파일이 포함됩니다.

  • dmp 및 tmp 하위 디렉토리는 작업 자체에 사용됩니다(내보내기를 위한 dmp, 임시 파일을 만드는 작업을 위한 tmp).

  • 스케줄러 시스템 파일은 서버의 루트 스케줄러 디렉토리에 복사됩니다. 이러한 파일은 작업을 실행하는 데 사용되는 "tjs_run_job.sh" 스크립트 엔진뿐만 아니라 로그 파일을 만드는 데 사용되는 "tjs_start_log.sh" 및 "tjs_stop_log.sh" 스크립트로 구성됩니다.

  • 할당된 작업 파일이 ftp로 서버에 보내지고 해당 실행 가능 비트가 설정됩니다.

  • 그런 다음 crontab 파일이 생성되어 서버로 보내집니다. Cron은 새 crontab 파일을 사용하라는 지시를 받게 됩니다.


작업 속성 설정

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Unix Job Scheduler에서 작업이 SID에 할당된 후에 해당 속성을 설정해야 합니다. 일정 정보와 모든 매개 변수 값 설정이 여기에 포함됩니다.

속성을 보고 설정하려면

  • SID 아래에서 할당된 작업을 누릅니다. 속성이 오른쪽 패널에 표시됩니다.


작업 예약

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Unix Job Scheduler에 대한 일정 정보를 오른쪽 세부 정보 패널의 Perform task 영역에서 볼 수 있습니다.

스케줄러와 함께 제공되는 각 작업에는 해당 헤더에 기본 일정 정보가 포함되어 있습니다. 사용자가 해당 작업을 선택하면 이 일정 정보는 구문 분석되어 자동으로 일정 필드에 할당됩니다. 예를 들어 다음은 하나의 인덱스를 할당 취소하는 작업에 대한 헤더입니다.

#-------------------------------------------------------

# File: deallocate_index_one_index.sh

# Desc: Perform Index Deallocate - Single Index

# Runs: Four Times per Month = 0 0 1,8,15,22 * *

# Parm: 1 - Index Owner

# Parm: 2 - Index to Analyze

# Parm: 3 - Megabytes to Keep (default 4)

#-------------------------------------------------------

주: "Runs:" 필드에서 필드는 구문 분석되어 일정 필드에 자동으로 할당됩니다.

이 작업을 선택할 경우 Toad에서는 헤더를 구문 분석하고 세부 정보 패널의 해당 필드에 기본 일정 정보를 입력합니다. 모든 필드를 변경할 수 있으며 값이 나열되지 않은 매개 변수 목록에는 올바른 매개 변수가 추가되어야 합니다.

아래 일정은 기본 제공된 .sh 파일 execute_stored_procedure.sh에서 제공된 것입니다. 아래 설명된 대로 일정을 모두 변경할 수 있습니다. 또한 이 셸에 대한 매개 변수 그리드에 매개 변수 값이 추가되어야 합니다.

Pre-defined Schedules

더 편리한 작업을 위해 Pre-defined Schedules 드롭다운에 일반적으로 사용되는 날짜와 시간이 제공됩니다. 미리 정의된 일정을 선택하면 선택한 시간 샘플에 대한 적절한 값으로 필드가 채워집니다.

이러한 미리 정의된 일정을 구성할 수 있습니다. 정기적으로 사용하는 일정이 목록에 아직 없을 경우 해당 일정을 추가할 수 있습니다. 목록을 편집하려면 드릴다운 단추( [image])를 누릅니다. 레코드를 추가하거나 레코드를 삭제하거나 미리 설정된 시간을 변경하는 등의 작업을 수행할 수 있습니다. 이 창의 변경 내용은 TOAD.INI 파일에 저장됩니다. 변경 내용을 삭제해야 할 경우 Restore Defaults를 누르면 원래의 Toad 기본값이 복원됩니다.

일정 옵션

일정 세부 정보는 5개의 필드인 Minute, Hour, Day of Month, Month of Year 및 Day of Week로 구성됩니다. 이러한 필드는 함께 사용되어 작업을 예약하는 데 사용할 수 있는 광범위한 날짜/시간 범위를 표현합니다. 또한 이러한 필드는 Crontab 파일 항목에서 사용되는 필드를 직접 나타냅니다.

각 Crontab 항목은 이러한 6개의 필드가 공백으로 구분되어 한 줄로 되어 있습니다.

  • Minute - 0에서 59까지의 숫자를 사용하여 지정

  • Hour - 0에서 23까지의 숫자를 사용하여 지정(0은 자정이고 23은 오후 11시)

  • Day of the month - 1에서 31까지의 숫자를 사용하여 지정

  • Month of the year - 1에서 12까지의 숫자를 사용하여 지정

  • Day of the week - 1에서 6까지의 숫자를 사용하여 지정

다른 "날짜" 필드(Day of Month 및 Day of Week)를 통해 다른 일정 알고리즘을 사용할 수 있습니다. 예를 들어 매주 화요일마다 데이터베이스를 백업하거나 매월 15일에 인덱스 유지 관리를 수행할 수 있습니다.

  • 사용하지 않는 날짜 필드에 별표(*)를 입력합니다.

매월 15일 뿐만 아니라 매주 화요일에 작업을 실행하려는 경우 등에는 두 날짜 필드를 모두 사용합니다.

범위

대시를 사용하여 범위를 지정합니다. 8일부터 15일까지 지정하려면 Day of the month 필드에 8-15를 입력합니다.

비연속 항목

필드에서 비연속 항목을 쉼표로 구분합니다. 예를 들어 Day of the month 필드에 입력한1,15는 1일과 15일을 의미합니다.

모든 값

필드에서 별표(*)를 사용하여 해당 필드에 모든 값을 지정합니다(예: 1년 12달).

주: 모든 날짜를 지정하려면 두 날짜 필드 모두에 *을 입력해야 합니다.

다른 일정 추가

추가 일정 탭을 작업에 추가할 수 있습니다. 동일한 작업에 대한 추가 일정이 있을 경우 해당 작업을 다른 매개 변수로 실행하거나 완전히 다른 간격으로 실행할 수 있습니다.

  • 일정 탭 위에 있는 Add 단추( [image])를 누릅니다. 다른 탭이 추가됩니다. 이 일정을 위에 설명된 것처럼 원하는 대로 변경합니다. 이제 작업이 두 일정 모두에서 실행됩니다.

  • 일정 탭을 제거할 수도 있습니다. 제거할 탭을 선택하고 탭 위의 Remove 단추( [image])를 누르면 됩니다. 탭은 확인 메시지 없이 제거됩니다.


매개 변수 정보 설정

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

Unix Job Scheduler에서 일부 작업을 예약하려면 매개 변수가 필요합니다. 이러한 매개 변수는 작업 파일의 헤더에 설명되어 있습니다. 예를 들어 다음은 하나의 인덱스를 할당 취소하는 작업에 대한 헤더입니다.

#-------------------------------------------------------

# File: deallocate_index_one_index.sh

# Desc: Perform Index Deallocate - Single Index

# Runs: Four Times per Month = 0 0 1,8,15,22 * *

# Parm: 1 - Index Owner

# Parm: 2 - Index to Analyze

# Parm: 3 - Megabytes to Keep (default 4)

#-------------------------------------------------------

여기에는 세 가지 매개 변수가 정의되어 있습니다. 첫 번째는 인덱스 소유자를 지정하는 데 사용되고 두 번째는 분석할 인덱스를 설명하며 세 번째는 유지할 MB 수를 지정합니다.

이러한 매개 변수는 Assigned Task Properties 패널에 구문 분석됩니다. 할당된 각 작업에 대한 각 매개 변수에는 오른쪽의 assigned task properties 패널 아래에 있는 매개 변수 그리드의 값이 할당되어야 합니다.

매개 변수에 기본값이 있을 경우 헤더에서 기본값이 구문 분석되어 자동으로 그리드에 배치됩니다. 값 열을 누르고 해당 값을 입력하여 이러한 값을 변경할 수 있습니다.


필요한 요소 검사

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

작업을 서버에 성공적으로 배포하려면 필요한 여러 요소를 모아야 합니다. 여기에는 사용자 ID, 암호, 작업 매개 변수 값 등이 포함됩니다.

배포를 실행하기 전에 이 모든 요소에 대한 자동 검사가 수행됩니다. 이 검사를 수동으로 수행할 수도 있습니다.

필요한 요소를 수동으로 검사하려면

  • 도구 모음에서 Check required elements [image] 단추를 누릅니다. 해결되지 않은 문제의 목록이 표시되며 배포 전에 이 문제를 해결해야 합니다. 이 문제를 해결하지 않으면 배포를 선택했을 때 목록이 다시 나타납니다.


새 UNIX 작업 파일 작성

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

정기적으로 예약할 작업에 새 작업 파일을 작성할 수 있습니다.

UNIX 셸 스크립트에 익숙한 경우에는 "New task template" 단추를 사용하여 시작 셸 템플릿을 가져올 수 있습니다. 또는 기존 작업 파일을 새 스크립트의 기반으로 사용할 수 있습니다.

Toad Unix Scheduler를 사용하려면 작업 파일 헤더가 형식에 맞아야 합니다. 그러면 스케줄러에서 코드를 구문 분석하고 창의 세부 정보 패널에 있는 상자에 적절히 입력할 수 있습니다.

헤더

Toad Scheduler를 사용하려면 헤더에 특정 정보가 특정 형식으로 포함되어 있어야 합니다. 헤더는 Toad에서 기본값의 세부 정보를 채울 정보를 얻는 위치입니다. 헤더는 서식이 다음과 같이 지정되어야 합니다.

#-------------------------------------------------------

# File: deallocate_index_one_index.sh

# Desc: Perform Index Deallocate - Single Index

# Runs: Four Times per Month = 0 0 1,8,15,22 * *

# Parm: 1 - Index Owner

# Parm: 2 - Index to Analyze

# Parm: 3 - Megabytes to Keep (default 4)

#-------------------------------------------------------

작업 파일 저장

Toad Scheduler에서는 Toad 실행 파일 디렉토리 아래에 있는 \UnixJobs\Base\Shell 하위 디렉토리에서 계층을 구성합니다.

스케줄러에서 새 작업을 찾을 수 있도록 이 디렉토리에 저장해야 합니다. 또는 Shell 디렉토리 아래의 하위 디렉토리에 저장할 수도 있습니다. Scheduler는 Shell 하위 디렉토리와 그 아래에 있는 하위 디렉토리에서 "*.sh" 파일을 찾습니다.

하위 디렉토리는 "All available tasks" 노드 아래에 별도의 노드로 나열됩니다. Shell 디렉토리에 새 디렉토리를 작성하면 Toad에서 인식됩니다.


여러 작업 데이터 파일 작업

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

스케줄러의 서버, 데이터베이스 및 할당된 작업에 대해 정의된 모든 데이터는 "Scheduler.jdf"라는 INI 파일에 저장됩니다. 이 파일은 \UnixJobs 하위 디렉터리에 저장됩니다.

일반적으로 하나의 구성 데이터 파일만 작업할 수 있습니다. 하지만 작업이 예약된 완전히 다른 둘 이상의 환경을 설정하려는 경우도 있을 수 있습니다. 다른 스케줄러 데이터 파일을 열어서 배치하여 서로 다른 구성 간을 쉽게 이동할 수 있습니다.

이 기능을 지원하는 세 가지 도구 모음 단추가 있습니다.

  • Load job datafile…

  • Save job datafile as…

  • Save job datafile

새 데이터 파일을 작성하려면

  • 기본 데이터 파일에서 시작하여 Save job datafile as…를 선택합니다. 이제 방금 적용한 이름을 가진 새 데이터 파일에서 작업을 수행할 수 있습니다.

데이터 파일을 로드하려면

  • 다음 작업 중 하나를 수행하십시오.

  • 새 데이터 파일을 만든 경우 다른 데이터 파일을 로드하려면 Load job datafile 단추를 누르면 됩니다.

  • 다른 데이터 파일을 열기 전에 현재 작업을 저장하려면 먼저 Save job datafile 단추를 누릅니다.

상태 표시줄의 맨 오른쪽 섹션에 현재 열려 있는 데이터 파일의 이름이 표시됩니다.


Scheduler Logger 개요

주: 이 Toad 기능은 선택 사항인 Quest DBA Module이 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

서버에서 실행되는 작업을 성공적으로 시작한 경우 스케줄러 로깅 기능을 사용하여 이러한 작업의 결과를 볼 수 있습니다.

스케줄러 로깅 기능에 액세스하려면

  1. 오른쪽에서 Server를 선택합니다.

  2. 오른쪽에서 Log 탭을 선택합니다.

로그 파일 목록 반입

최신 로그 파일을 보고 있는지 확인하려면 Refresh 단추를 누릅니다. 서버에 있는 로그 파일의 목록이 표시됩니다. 선택한 표시 모드에 따라 이 목록은 모든 로그 파일이거나 하위 집합입니다. 기본적으로 마지막 실행에 대한 로그 파일만 표시됩니다. Refresh 드롭다운을 누르면 다음 옵션이 표시됩니다.

  • All log files(기본값)

  • Last execution

  • Failures only

  • Failures only, for last execution

모든 로그 파일의 목록을 검색하는 첫 번째 옵션은 매우 오래 걸릴 수 있습니다. Last execution은 각 작업에 대해 만들어진 마지막 로그 파일을 표시합니다. Failures only는 실패 상태를 가진 모든 로그 파일의 목록을 표시합니다. Failures only, for last execution은 실패한 각 작업에 대해 만들어진 마지막 로그 파일을 표시합니다.

로그 파일 보기

로그 파일 중 하나의 내용을 보려면 그리드 항목을 두 번 누르거나 "View log file" 단추를 누릅니다. 이렇게 하면 선택한 로그 파일이 ftp로 전송되어 Toad 기본 편집기에서 열립니다.

로그 파일 삭제

선택한 로그 파일을 삭제하려면 그리드에서 해당 파일을 선택 또는 다중 선택합니다. "Delete selected log files" 단추를 누릅니다. 확인이 요청되지 않습니다. 모든 로그 파일을 삭제하려면 "Delete all log files" 단추를 누릅니다. 이 경우에는 확인 요청이 제공됩니다.

Crontab 파일 보기

Cron 프로그램의 Crontab 파일 형식을 알고 있는 경우 특정 서버에 대한 Crontab 파일을 볼 수 있습니다. "View crontab file" 단추를 누르면 crontab_file.txt라는 Crontab 파일이 서버의 Scheduler 디렉토리에서 ftp로 전송되어 Toad의 기본 편집기에서 열립니다.

Cron 프로그램 시작 및 중지

지정된 서버에서 cron 프로그램을 수동으로 시작 및 중지할 수 있습니다. 도구 모음에서 Start/Stop cron scheduling [image] 단추를 누릅니다. 각각 "cron crontab_file.txt" 또는 "crontab –r" RExec 명령이 실행됩니다. 명령의 성공이 확인되지 않는 경우에도 확인 프롬프트가 제공됩니다.


eBiz Module 개요

주: 이 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Toad용 Quest E-Biz Module은 개발자와 관리자에게 친숙한 Toad 사용자 인터페이스는 물론, E-Business 관련 개체 브라우저 기능, 구성 가능한 보고서, 활동 모니터 및 고유의 Lookup Finder를 제공합니다. Oracle E-Business 개체 및 활동에 대한 이러한 기능을 활용하면 특히 새로운 동시 프로그램을 개발하고 메뉴를 조정하며 Flex 필드를 검사하는 데 드는 조사 시간을 크게 줄일 수 있습니다.

네 가지 부분으로 구성됩니다.

  • eBiz Browser

  • eBiz Monitor

  • eBiz Reports

  • eBiz Lookup Finder

관련 항목

eBiz Module 사용과 관련된 권한 요구 사항


eBiz 사용과 관련된 권한 요구 사항

eBiz Module을 사용하려면 아래 나열된 보기 및 테이블에 대한 SELECT 권한이 필요합니다.

APPLSYS.AD_APPL_TOPS

APPLSYS.AD_APPLIED_PATCHES

APPLSYS.AD_BUGS

APPLSYS.AD_FILE_VERSIONS

APPLSYS.AD_FILES

APPLSYS.AD_PATCH_COMMON_ACTIONS

APPLSYS.AD_PATCH_DRIVERS

APPLSYS.AD_PATCH_RUN_BUG_ACTIONS

APPLSYS.AD_PATCH_RUN_BUGS

APPLSYS.AD_PATCH_RUNS

APPLSYS.FND_APPL_SESSIONS

APPLSYS.FND_APPLICATION

APPLSYS.FND_APPLICATION_TL

APPLSYS.FND_CONCURRENT_PROCESSES

APPLSYS.FND_CONCURRENT_PROGRAM_SERIAL

APPLSYS.FND_CONCURRENT_PROGRAMS

APPLSYS.FND_CONCURRENT_PROGRAMS_TL

APPLSYS.FND_CONCURRENT_QUEUES

APPLSYS.FND_CONCURRENT_QUEUES_TL

APPLSYS.FND_CONCURRENT_REQUEST_CLASS

APPLSYS.FND_CONCURRENT_REQUESTS

APPLSYS.FND_DATA_GROUPS

APPLSYS.FND_DESCR_FLEX_COL_USAGE_TL

APPLSYS.FND_DESCR_FLEX_COLUMN_USAGES

APPLSYS.FND_DESCR_FLEX_CONTEXTS

APPLSYS.FND_DESCR_FLEX_CONTEXTS_TL

APPLSYS.FND_DESCRIPTIVE_FLEXS

APPLSYS.FND_EXECUTABLES

APPLSYS.FND_FLEX_VALUE_SETS

APPLSYS.FND_FORM

APPLSYS.FND_FORM_FUNCTIONS

APPLSYS.FND_FORM_FUNCTIONS_TL

APPLSYS.FND_FORM_TL

APPLSYS.FND_ID_FLEX_SEGMENTS

APPLSYS.FND_ID_FLEX_SEGMENTS_TL

APPLSYS.FND_ID_FLEX_STRUCTURES

APPLSYS.FND_ID_FLEX_STRUCTURES_TL

APPLSYS.FND_ID_FLEXS

APPLSYS.FND_LOGIN_RESP_FORMS

APPLSYS.FND_LOGIN_RESPONSIBILITIES

APPLSYS.FND_LOGINS

APPLSYS.FND_LOOKUP_TYPES

APPLSYS.FND_LOOKUP_TYPES_TL

APPLSYS.FND_LOOKUP_VALUES

APPLSYS.FND_MENU_ENTRIES

APPLSYS.FND_MENU_ENTRIES_TL

APPLSYS.FND_MENUS

APPLSYS.FND_MENUS_TL

APPLSYS.FND_ORACLE_USERID

APPLSYS.FND_PRINTER

APPLSYS.FND_PRINTER_DRIVERS

APPLSYS.FND_PRINTER_INFORMATION

APPLSYS.FND_PRINTER_STYLES

APPLSYS.FND_PRINTER_STYLES_TL

APPLSYS.FND_PRINTER_TL

APPLSYS.FND_PRINTER_TYPES

APPLSYS.FND_PRODUCT_GROUPS

APPLSYS.FND_PRODUCT_INSTALLATIONS

APPLSYS.FND_PROFILE_OPTION_VALUES

APPLSYS.FND_PROFILE_OPTIONS

APPLSYS.FND_PROFILE_OPTIONS_TL

APPLSYS.FND_REQUEST_GROUP_UNITS

APPLSYS.FND_REQUEST_GROUPS

APPLSYS.FND_REQUEST_SET_PROGRAMS

APPLSYS.FND_REQUEST_SET_STAGES

APPLSYS.FND_REQUEST_SET_STAGES_TL

APPLSYS.FND_REQUEST_SETS

APPLSYS.FND_REQUEST_SETS_TL

APPLSYS.FND_RESPONSIBILITY

APPLSYS.FND_RESPONSIBILITY_TL

APPLSYS.FND_UNSUCCESSFUL_LOGINS

APPLSYS.FND_USER

APPLSYS.FND_USER_RESP_GROUPS -- 이 항목은 환경에 따라 APPS가 소유할 수도 있습니다.

APPLSYS.WF_ACTIVITIES_TL

APPLSYS.WF_ITEM_ACTIVITY_STATUSES

APPLSYS.WF_ITEM_ATTRIBUTE_VALUES

APPLSYS.WF_ITEM_ATTRIBUTES

APPLSYS.WF_ITEM_ATTRIBUTES_TL

APPLSYS.WF_ITEM_TYPES

APPLSYS.WF_ITEM_TYPES_TL

APPLSYS.WF_MESSAGES_TL

APPLSYS.WF_NOTIFICATIONS

APPLSYS.WF_PROCESS_ACTIVITIES

APPS.FND_APPLICATION

APPS.FND_CONCURRENT_WORKER_REQUESTS

APPS.FND_DATA_GROUP_UNITS

APPS.FND_DATA_GROUPS

APPS.FND_FORM_FUNCTIONS_TL

APPS.FND_FORM_TL

APPS.FND_LOGIN_RESP_FORMS

APPS.FND_LOGIN_RESPONSIBILITIES

APPS.FND_LOGINS

APPS.FND_LOOKUPS

APPS.FND_ORACLE_USERID

APPS.FND_RESPONSIBILITY_TL

APPS.FND_USER

APPS.FND_V$PROCESS

APPS.ICX_SESSIONS

APPS.ORG_ORGANIZATION_DEFINITIONS

APPS.WF_ITEM_ACTIVITY_STATUSES_V

APPS.WF_NOTIFICATIONS_VIEW

APPS.WF_USERS

AR.HZ_PARTIES

HR.PER_ALL_PEOPLE_F

ICX.ICX_SESSIONS

PO.PO_VENDOR_CONTACTS

SYS.ALL_OBJECTS 또는 SYS.DBA_OBJECTS

SYS.ALL_VIEWS or SYS.DBA_VIEWS

SYS.OBJ$ -- 브라우저의 Activity 탭에서만 사용됩니다.

SYS.USER$ -- 브라우저의 Activity 탭에서만 사용됩니다.

V$INSTANCE --브라우저의 Activity 및 'User' 탭에서만 사용됩니다.

V$LOCK -- 브라우저의 Activity 탭에서만 사용됩니다.

V$PROCESS -- 브라우저의 Activity 탭에서만 사용됩니다.

V$SESS_IO -- 브라우저의 Activity 탭에서만 사용됩니다.

V$SESSION -- 브라우저의 Activity 탭에서만 사용됩니다.


eBiz Browser 개요

주: 이 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

업계 최고의 Toad 개체 브라우저 사용자 인터페이스를 사용하는 eBiz Browser를 통해 관리자와 개발자는 가장 일반적인 Oracle E-Business 데이터 유형(활동, 응용 프로그램, 감사, 동시 프로그램, 요청 집합, 사용자, 워크플로, 프린터, 프로파일 옵션, Key Flex 필드, Descriptive Flex 필드, 조회, 메뉴, 패치, 데이터 그룹 및 잘못된 개체) 중 몇 가지를 신속하게 탐색할 수 있습니다. 이러한 각 개체 유형은 개발자에게 메뉴 ID, 응용 프로그램 ID, 책임 ID, 작성한 날짜, 업데이트 날짜, 값 및 개체 유형과 관련된 기타 정보 등 주요 정보를 표시하는 세부 정보 화면에 나타납니다.

eBiz Browser에서는 eBiz 개체를 쉽고 빠르게 찾아볼 수 있습니다.

탭 드롭다운 목록 형태로 개체 유형을 나열하도록 왼쪽 패널을 구성할 수 있습니다. 예를 들어 응용 프로그램 유형이 선택되면 왼쪽 패널에 모든 응용 프로그램이 표시되며, 동시 프로그램 유형이 선택되면 왼쪽 창에 모든 동시 프로그램이 표시됩니다.

개체를 선택할 때 해당 개체의 세부 정보가 오른쪽 패널에 표시됩니다. 따라서 원하는 데이터를 찾기 위해 계층 구조를 드릴다운할 필요가 없습니다. 또한 마우스를 한 번 눌러 같은 유형의 개체 간에 세부 정보를 비교할 수 있습니다. 키보드 사용자는 스크롤 키를 사용하여 이와 동일한 작업을 쉽게 수행할 수 있습니다.


eBiz: Browser 필터링

주: 이 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Quickfilter Edit 상자는 탭 및 드롭다운 목록으로 구성된 Schema Browser 보기의 Schema 드롭다운 목록 아래에 있습니다. Quickfilter를 사용하면 데이터베이스를 다시 질의하지 않고 개체 목록을 필터링할 수 있습니다. 이렇게 하면 Browser 필터를 사용할 때보다 더 빠른 방법으로 목록을 필터링할 수 있습니다.

Quickfilter는 클라이언트 필터이므로 데이터베이스를 다시 질의하지 않고 모든 Browser 개체를 필터링합니다. 이 필터는 기존 Browser 필터와 함께 작동합니다.

기본적으로 이 필터에는 "select all" 와일드카드 문자(*)가 포함됩니다. 이 상자의 내용을 변경하여 개체 목록을 빠르고 쉽게 필터링할 수 있습니다.

Quickfilter 상자를 사용하려면

  • 필터 정보를 입력합니다. 필터에서 언제라도 와일드카드 문자를 사용할 수 있습니다.

주: Quickfilter에서는 최대 25개 항목으로 된 기록을 제공하며 최근 항목이 첫번째로 표시됩니다. Quickfilter를 마우스 오른쪽 단추로 누르면 이 목록에 액세스할 수 있습니다.


eBiz: Object 패널 구성

주: 이 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

eBiz Browser에서 개체 유형을 표시하는 방식을 변경할 수 있습니다.

eBiz Browser 내에서 디스플레이를 변경하려면

  1. 오른쪽 도구 모음에서 Browser Style [image] 단추를 누릅니다.

  2. 드롭다운 메뉴에서 사용할 디스플레이 유형을 선택합니다.


Activity Objects 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Activity Objects 패널은 전체적인 응용 프로그램 활동을 한 번에 보여 줍니다.

제공되는 정보는 9개 항목으로 구성됩니다.

  • Managers

  • Request Activity

  • Full Service Activity

  • Self Service Activity

  • Sessions

  • Application Locks

  • Time Slip

  • Point in time

  • Performance

주: 성능 옵션에서는 Oracle OAM 수집 동시 프로그램(FNDOAMCOL)의 데이터를 사용합니다. 이 프로그램을 실행한 적이 없으면 이 옵션이 표시되지 않습니다.

시간 의존형 항목

Objects 패널의 항목 수는 시간에 의존하며 자동으로 새로 고쳐지지 않습니다. 마지막 새로 고침 날짜 및 시간이 패널 위에 표시됩니다.

시간 의존형 응용 프로그램 활동 정보는 다음 개체에 제공됩니다.

항목 | 확장 설명
Managers (22-Jun-05 07:10) | 관리자가 마지막으로 다시 시작된 날짜 및 시간입니다.
Request Activity -R- (0) P( 0) | R = 실행 중인 요청 수입니다. R = 보류 중인 요청 수입니다. 대기 중인 요청 수에는 예약된 요청 수나 보류 중인 요청 수가 포함되지 않습니다.
Full Service Activity (1) | 전체 서비스 연결 수입니다. 주: 하나의(기본값) 필터가 Full Service Activity 카운터에 적용되었습니다. 필터가 모든 “Dead” 전체 서비스 세션을 제거했습니다.
Self Service Activity (3) | 자체 서비스 연결 수입니다. 주: 자체 서비스 세션에서 30분 이상 아무 활동이 없는 경우에는 닫힌 세션으로 간주합니다.
Sessions (35) | 데이터베이스 세션 수(Oracle Background 프로세스 제외)입니다.
Application Locks (0) | 60초 이상 보류된 응용 프로그램 잠금 차단이 있는 경우 1로 변경됩니다.
ICM Locks (0) | 동시 관리자가 잠겨 있는 경우 1로 변경됩니다.

주: OAM(Oracle Application Manager)을 실행 중인 경우 OAM 수집 프로세스가 실행될 때마다 하나의 자체 서비스 세션이 생성됩니다. 세션이 제대로 닫히지 않은 경우 세션이 TOAD 30분 제한 시간 동안 활성화된 상태로 표시됩니다. OAM 수집기가 10분(기본값)마다 실행되는 경우 이 자체 서비스 개수에 일반적으로 OAM 수집기 프로세스와 관련된 3개의 세션이 포함됩니다.

주의: Object 패널(왼쪽) 및 Details 패널(오른쪽)을 개별적으로 새로 고칠 수 있습니다. 시간 의존형 기능의 경우 이 새로 고침으로 값이 일치되지 않을 수도 있습니다.


Activity Managers Details 패널

Activity - Managers Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Managers Detail 패널은 모든 동시 관리자와 현재 상태의 목록을 표시합니다. 내부 관리자 로그 파일의 위치 및 이름이 Details 그리드 위에 표시됩니다.

열 제목 | 설명
Manager | 관리자의 간단한 이름입니다.
Queue Name | 관리자의 전체 이름입니다.
Application ID | 관리자의 응용 프로그램 ID입니다.
Queue ID | 관리자의 내부 대기열 ID입니다.
Target | 관리자에서 실행 중인 호스트입니다.
Max Processes | 관리자에서 실행 중이어야 하는 프로세스 수입니다.
Running Processes | 실행 중인 관리자 프로세스의 실제 개수입니다.
Sleep (sec) | 관리자 일시 중지 시간입니다.
Cache size | 관리자 캐시 값입니다.
Status | 관리자의 상태입니다.
Running | 실행 중인 요청 수입니다.
Pending | 대기 중인 요청 수입니다.
On-hold | 보류 중인 요청 수입니다.
Scheduled | 예약된 요청 수입니다.
Paused | 일시 중지된 요청 수입니다.

주: 부적절하게 구성된 전문화 규칙으로 인해 일부 요청이 여러 대기열에 모두 포함될 수 있습니다.

필터 예

실행 중인 활성 요청만 보려면

  • 값이 ”Is Greater Than” 및 0인 경우에는 “Custom” 필터를 Running Processes 열에 추가합니다.


Activity - Request Activity Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Request Activity를 선택한 경우 Details 패널에 다음 탭이 표시됩니다.

  • Running/Pending - 실행 중인 요청과 대기 중인 모든 요청을 나열합니다.

  • Scheduled - 예약 세부 정보를 포함하여 예약된 모든 요청을 나열합니다.

  • On-Hold - 보류 중 상태로 있던 총 시간을 포함하여 모든 보류 중 요청을 나열합니다.

  • Completed - 모든 완료 요청(기본값: Today)이 나열되며 Normal, Error, Warning, Cancelled, Terminated와 같은 모든 완료 상태가 포함됩니다.


Activity - Request Activity - Running/Pending

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Request Activity 탭은 모든 실행 중인 요청과 대기 중인 요청을 나열합니다.

열 제목 | 설명
Request ID | 동시 요청 ID입니다.
Requestor | 요청을 전송한 사용자입니다.
Program Name | 동시 프로그램 이름입니다.
Prog Appn ID | 내부 응용 프로그램의 프로그램 ID입니다.
Program ID | 내부 프로그램 ID입니다.
Manager | 프로그램을 실행 중이거나 실행할 관리자입니다.
Parameters | 프로그램의 런타임 매개 변수입니다.
Priority | 프로그램 우선 순위입니다.
Req/Actual Start Date | 요청이 대기 중인 경우 요청 시작 날짜이며, 요청이 실행 중인 경우에는 실제 시작 날짜입니다.
Status | 요청의 현재 상태입니다.
Run/Pending Time | 요청이 대기 중인 경우 대기 시간이며, 요청이 실행 중인 경우에는 현재 실행 시간입니다.
Request Set | 요청이 요청 세트에 포함되어 있는지 여부를 나타냅니다.
Printer | 요청이 전송될 프린터와 매수입니다.

주: 충돌 해결 관리자에서 프로그램 실행 전에 충돌을 해결해야 하는 경우 프로그램이 요청을 실행하는 관리자와 FNDCRM 관리자 모두에 표시됩니다.

전문화 규칙 구성에 문제가 있으면 프로그램이 여러 관리자(FNDCRM 제외)에 나타납니다.


Activity - Request Activity - Scheduled

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Scheduled 탭은 예약 세부 정보를 포함하여 모든 예약 요청을 나열합니다.

주: 예약 요청은 미래 시점의 요청 시작 날짜 및 시간을 가진 모든 요청입니다.

열 제목 | 설명
Request ID | 동시 요청 ID입니다.
Requestor | 요청을 전송한 사용자입니다.
Program Name | 동시 프로그램 이름입니다.
Prog Appn ID | 내부 응용 프로그램의 프로그램 ID입니다.
Program ID | 내부 프로그램 ID입니다.
Manager | 프로그램을 실행 중이거나 실행할 관리자입니다.
Parameters | 프로그램의 런타임 매개 변수입니다.
Priority | 프로그램 우선 순위입니다.
Requested Start Date | 요청을 실행할 날짜 및 시간입니다.
Time Until Start | 요청이 실행되는 시점(HH:MM:SS)을 보여주는 카운트다운 타이머입니다.
Resubmit Interval | 요청을 재전송할 재전송 단위의 개수입니다.
Resubmit Unit | 간격 단위입니다.
Resubmit From | 요청을 사전 요청의 시작 또는 종료로부터 재전송해야 하는지 여부를 나타냅니다.
Resubmit Time | 요청을 실행해야 하는 시간입니다.
Resubmit End | 요청을 재전송할 마지막 날짜입니다.
Printer | 요청이 전송될 프린터와 매수입니다.

주: 충돌 해결 관리자에서 프로그램 실행 전에 충돌을 해결해야 하는 경우 프로그램이 요청을 실행하는 관리자와 FNDCRM 관리자 모두에 표시됩니다.


Activity - Request Activity - On-Hold

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

On-hold 탭은 보류 중 상태로 있던 총 시간을 포함하여 모든 보류 중 요청을 나열합니다. 너무 오랜 시간 동안 보류 중 상태였던 요청을 찾을 때 주로 사용합니다. 이 그리드를 사용하면 더 이상 필요하지 않은 요청을 찾을 수 있습니다.

열 제목 | 설명
Request ID | 동시 요청 ID입니다.
Requestor | 요청을 전송한 사용자입니다.
Program Name | 동시 프로그램 이름입니다.
Prog Appn ID | 내부 응용 프로그램의 프로그램 ID입니다.
Program ID | 내부 프로그램 ID입니다.
Manager | 프로그램을 실행 중이거나 실행할 관리자입니다.
Parameters | 프로그램의 런타임 매개 변수입니다.
Priority | 프로그램 우선 순위입니다.
Requested Start Date | 요청 시작 날짜입니다.
Est. time on Hold | 요청이 보류 상태로 있던 시간(HH:MM:SS)입니다.
Resubmit Details | 전송 세부 정보(요청이 예약-재전송 요청일 경우)입니다.
Printer | 요청이 전송될 프린터와 매수입니다.


Activity - Request Activity - Completed

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Competed 탭에는 모든 완료 요청(기본값: Today)이 나열되며 Normal, Error, Warning, Cancelled, Terminated와 같은 모든 완료 상태가 포함됩니다.

열 제목 | 설명
Request ID | 동시 요청 ID입니다.
Requestor | 요청을 전송한 사용자입니다.
Program Name | 동시 프로그램의 전체 이름입니다.
Program App’n ID | 동시 프로그램과 관련된 내부 응용 프로그램 ID입니다.
Program ID | 내부 동시 프로그램 식별자입니다.
Manager Name | 요청을 실행한 동시 실행 관리자입니다.
Parameters | 요청에 대한 런타임 매개 변수입니다.
Priority | 요청 우선 순위입니다.
Requested Start Date | 요청이 시작되도록 요청된 날짜 및 시간입니다.
Actual Start Date | 요청 처리가 시작된 날짜 및 시간입니다.
Actual Completion Date | 요청이 완료된 날짜 및 시간입니다.
Completion Status | 요청의 완료 상태입니다.
Time in Queue | 요청의 총 대기 시간입니다.
Run Time | 요청의 총 실행 시간입니다.
Printer | 매수를 포함한 요청이 전송된 프린터입니다.
Completion Text | 요청에 대한 완료 텍스트입니다.
Log File Node | 로그 파일이 저장된 호스트 컴퓨터입니다.
Log File Name | 로그 파일 위치 및 이름입니다.
Out File Node | 출력 파일이 저장된 호스트 컴퓨터입니다.
Out File Name | 출력 파일 위치 및 이름입니다.


Activity - Full Service Activity Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Full Service Activity Details 패널은 두 부분으로 된 하나의 탭으로 구성됩니다.

  • Full Service Sessions - 현재 활동을 비롯하여 응용 프로그램에 현재 연결된 전체 서비스 사용자를 나열합니다.

  • Activity for the selected session - 이 하위 그리드는 선택한 전체 서비스 세션에 대한 전체 세션 활동을 표시합니다.

Full Service Sessions

이 영역에서는 현재 활동을 비롯하여 응용 프로그램에 현재 연결된 전체 서비스 사용자를 나열합니다.

열 제목 | 설명
Login ID | 내부 로그인 ID 순서 번호입니다.
User ID | 응용 프로그램 사용자 계정의 고유한 내부 식별자입니다.
User Name | 응용 프로그램 사용자의 로그인 이름입니다.
Description | 사용자에 대한 설명입니다.
Email Address | 사용자 전자 메일 주소입니다.
Responsibility | 현재 응용 프로그램 사용자의 책임 수준입니다. 책임 수준에서 Sign-on 감사를 사용할 수 있는 경우에만 표시됩니다.
Form | 사용자의 양식입니다. 양식 수준에서 Sign-on 감사를 사용할 수 있는 경우에만 표시됩니다.
Login Name | 사용자 세션의 로그인 이름입니다.
Program Name | 사용자가 실행 중인 프로그램입니다.
Connected Time | 사용자가 응용 프로그램에 연결한 시간(HH:MM:SS)입니다.
Dead Session | 세션이 “Dead” 세션인지 여부를 나타냅니다. 이 경우 dead 세션은 시작 날짜가 마지막 데이터베이스 다시 시작 시간보다 이전인 모든 세션입니다.
Oracle PID | 사용자의 Oracle 프로세스입니다.
PID | 사용자의 운영 체제 프로세스입니다.
Terminal | 사용자가 작업 중인 터미널입니다. 주: 응용 프로그램에서 터미널 ID를 항상 자동으로 입력하지는 않습니다.

그리드 아래 상태 표시줄에 Sign-on 감사 수준이 표시됩니다.

주: 11.5.9 및 11.5.10 CU1과 같은 몇몇 최근 릴리스에서는 아무런 정보도 표시되지 않을 수 있습니다. Oracle 패치 4201122를 참조하십시오.

Activity for the selected session

이 하위 그리드에는 선택한 전체 서비스 세션에 대한 전체 세션 활동이 표시됩니다. 이 정보를 사용하면 응용 프로그램 내에서 사용자 작업 방법(Full Service Activity만 해당)을 볼 수 있습니다.

주: Sign-on 감사 수준은 이 그리드에서 볼 수 있는 정보 양을 결정합니다. Sign-on 감사 수준이 오른쪽 측면 그리드의 아래쪽 상태 표시줄에 나타날 수 있습니다.

열 제목

설명

Login ID

Activity

이 열은 다음 중 하나를 포함합니다.

  • 연결 - 세션 시작을 나타냄

  • 세션의 책임 이름

  • 세션의 양식 이름

Session Start

활동이 시작된 날짜 및 시간입니다.

Session End

활동이 종료된 날짜 및 시간입니다.

Session Time

활동 기간(HH:MM:SS)입니다.

  • 총 세션 시간

  • 책임에 소요된 시간

  • 양식에 소요된 시간


Activity - Self Service Activity Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Self Service Activity Details 패널에는 다음과 같은 모든 자체 서비스 세션이 나열됩니다.

  • Self Service Sessions - 현재 활동을 비롯하여 응용 프로그램에 현재 연결된 자체 서비스 사용자를 나열합니다.

세션에서 30분 이상 세션 활동이 없으면 해당 세션을 종료된 세션으로 간주합니다.

OAM(Oracle Application Manager)을 실행 중인 경우 OAM 수집 프로세스가 실행될 때마다 하나의 자체 서비스 세션이 생성됩니다. 세션이 제대로 종료되지 않은 경우 세션이 TOAD 30분 제한 시간 동안 활성화된 상태로 표시됩니다. OAM 수집기가 10분(기본값)마다 실행되는 경우 이 그리드에 일반적으로 OAM 수집기 프로세스와 관련된 3개의 세션이 포함됩니다.

열 제목 | 설명
Session ID | Self Service Web Apps 세션의 내부 세션 ID입니다.
User ID | 응용 프로그램 사용자 계정의 고유한 내부 식별자입니다.
User Name | 응용 프로그램 사용자의 로그인 이름입니다.
Description | 사용자에 대한 설명입니다.
Session Mode | 자체 서비스 세션 모드입니다.
Resp ID | 책임에 대한 내부 응용 프로그램 참조 번호입니다.
Responsibility | 사용자의 마지막 활동과 관련된 응용 프로그램 책임입니다.
Org ID | 조직에 대한 내부 응용 프로그램 참조 번호입니다.
Org Name | 사용자의 마지막 활동과 관련된 조직입니다.
Function ID | 기능에 대한 내부 응용 프로그램 참조 번호입니다.
Function | 사용자의 마지막 활동과 관련된 기능입니다.
Session start | 세션이 시작된 날짜 및 시간입니다.
Last Connect | 사용자 마지막 페이지 요청 날짜 및 시간입니다.
Last Activity Age | 마지막 세션 페이지 요청 시간(HH:MM:SS)입니다.
Connect Time | 총 세션 연결 시간(HH:MM:SS)입니다.
Session Limit | 세션의 활동 시간 제한(HH:MM:SS)(프로파일 옵션을 통해 설정됨)입니다.
Activity Count | 세션 중에 사용자가 만든 페이지 요청 수입니다.
Activity Limit | 세션에 대한 페이지 요청 제한(프로파일 옵션을 통해 설정됨)입니다.


Activity - Sessions Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Sessions Details 탭은 응용 프로그램 관련 데이터베이스 세션에 대한 정보를 나열합니다.

주: Oracle 백그라운 프로세스는 포함되지 않습니다.

열 제목 | 설명
SID | Oracle 세션 식별자입니다.
Serial # | 지정된 데이터베이스 세션의 일련 번호입니다.
Machine | 세션을 시작한 컴퓨터의 이름입니다.
Module | 지정된 세션의 내부 모듈 이름입니다.
User Name | 지정된 세션이 응용 프로그램 사용자 세션인 경우 사용자의 로그온 이름이 표시됩니다. 세션이 응용 프로그램 사용자가 아니면 OS 사용자 이름이 표시됩니다.
Apps Module | 모듈이 응용 프로그램 양식인 경우 양식의 이름이 표시됩니다. 모듈이 동시 요청인 경우 전체 동시 프로그램 이름이 표시됩니다.
Process Name | 세션에서 현재 실행 중인 프로세스의 이름입니다.
OS User | 세션의 운영 체제 사용자 ID입니다.
Process ID | 세션의 운영 체제 프로세스 ID입니다.
Logon Date | 세션이 시작된 날짜 및 시간입니다.
Session I/O | 세션에서 생성한 총 I/O입니다. 주: I/O는 세션의 consistent_gets 및 block_gets의 합계입니다.
Client PID | 세션과 관련된 클라이언트 프로세스의 식별자입니다.
Server PID | 세션과 관련된 서버 프로세스의 식별자입니다.

Session Browser에서 세션 찾기

Session Browser에서 세션을 찾을 수도 있습니다.

세션을 찾으려면

  1. Ebiz browser의 개체 목록에서 Sessions를 누릅니다.

  2. Objects 패널에서 세션을 선택합니다.

  3. Find in Session Browser [image] 단추를 누릅니다.


Activity - Application Locks Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Application Locks Details 패널은 모든 응용 프로그램 관련 잠금을 표시합니다.

열 제목 | 설명
Oracle SID | Oracle 세션 식별자입니다.
Oracle PID | Oracle 프로세스 번호입니다.
Status | 잠금 상태입니다.
Lock/Wait Time | 잠금 대기 시간입니다.
Lock Type | 잠금 유형입니다.
Locked Object | 잠금 상태인 개체입니다.
Apps User | 잠금을 소유한 응용 프로그램 사용자입니다.
Description | 응용 프로그램 사용자에 대한 설명입니다.
Oracle User | Oracle 사용자입니다.
OS User | OS 시스템 사용자입니다.
Client Program | 잠금 소유자가 실행 중인 프로그램입니다.
Machine | 프로그램을 실행 중인 호스트입니다.
Terminal | 프로그램을 실행 중인 터미널입니다.


Activity - Time Shift Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Time Shift Details 패널은 다음 탭으로 구성됩니다. 각 탭은 선택한 날짜(기본값: 오늘)에 대해 자정부터 10분 간격으로 있었던 작업을 보여주는 선 그래프입니다.

이 차트 집합을 사용하면 상대 활동 루프백 시간을 볼 수 있습니다.

  • Concurrent Request – 실행 및 대기 중인 요청

  • Full Service Activity – 전체 서비스 연결

  • Self Service Activity – 자체 서비스 연결

주: 사용 가능한 기록의 양은 사이트 제거 정책에 따라 다릅니다.

각 그래프마다 추가 조사 및/또는 그래프 작성을 위해 원시 데이터 추출 기능을 제공하는 관련 “Grid” 탭이 있습니다.


Activity - Time Shift - Concurrent Request 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

이 차트는 선택한 날짜의 자정부터 10분 간격으로 실행 중이거나 대기 중인 실행 중 및 대기 중 요청의 수를 표시합니다.

보류 중인 요청과 이후에 해제된 요청은 보류된 전체 기간과 실제 대기 시간에 대해 대기 중으로 표시됩니다.

주: 대기 중 요청 수에는 예약된 요청이 포함되지 않습니다.


Activity - Time Shift - Full Service Connections

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

이 차트는 선택한 날짜의 자정부터 10분 간격으로 활성화된 전체 서비스 세션의 수를 표시합니다.

주: Dead 세션은 활성 세션으로 표시됩니다.


Activity - Time Shift - Self Service Connections

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

이 차트는 선택한 날짜의 자정부터 10분 간격으로 활성화된 자체 서비스 세션의 수를 표시합니다. 세션에서 30분 이상 세션 활동이 없으면 해당 세션을 종료된 세션으로 간주합니다.

OAM(Oracle Application Manager)을 실행 중인 경우 OAM 수집 프로세스가 실행될 때마다 하나의 자체 서비스 세션이 생성됩니다. 세션이 제대로 종료되지 않은 경우 세션이 TOAD 30분 제한 시간 동안 활성화된 상태로 표시됩니다. OAM 수집기가 10분(기본값)마다 실행되는 경우 이 그리드에 일반적으로 OAM 수집기 프로세스와 관련된 3개의 세션이 포함됩니다.


Activity - Point in Time Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Point in Time Details 패널은 다음 탭으로 구성됩니다. 각 탭은 선택한 날짜 및 시간에 발생 중이던 활동을 표시합니다.

  • Concurrent Request – 선택한 시간에 실행 중이거나 대기 중이던 동시 요청을 나열합니다.

  • Full Service Activity – 선택한 시간에 활성화된 상태이던 전체 서비스 세션을 나열합니다.

  • Self Service Activity – 선택한 시간에 활성화된 상태이던 자체 서비스 세션을 나열합니다.

주: 사용 가능한 기록의 양은 사이트 제거 정책에 따라 다릅니다.


Activity - Point in Time - Concurrent Requests 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Concurrent Request 탭은 선택한 시간에 실행 중이거나 대기 중이었던 동시 요청을 나열합니다.

열 제목 | 설명
Status | 실행 중 또는 대기 중입니다.
Request ID | 동시 요청 ID입니다.
Manager | 요청을 실행한 동시 실행 관리자입니다.
User | 요청을 전송한 사용자입니다.
Program | 동시 프로그램의 전체 이름입니다.
Parameters | 요청에 대한 런타임 매개 변수입니다.
Priority | 요청 우선 순위입니다.
Request Start | 요청이 시작되도록 설정된 날짜 및 시간입니다.
Actual Start | 요청 처리가 시작된 날짜 및 시간입니다.
Actual Completion | 요청 처리가 완료된 날짜 및 시간입니다.
Pending Time | 요청이 대기 중 상태로 있던 총 시간(HH:MM:SS)입니다.
Running Time | 요청에 대한 총 실행 시간(HH:MM:SS)입니다.
Printer | 매수를 포함한 요청이 전송된 프린터입니다.

주: 보류 중이었다가 해제된 요청이나 이전 요청의 복사본으로 전송된 요청은 “normal” 대기 시간보다 더 많은 시간으로 표시될 수 있습니다.


Activity - Point in Time - Full Service 탭

Activity - Point in Time - Full Service Activity 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Full Service Activity 탭은 선택한 시간에 활성화된 상태이던 전체 서비스 세션을 나열합니다.

열 제목 | 설명
User Name | 응용 프로그램 사용자의 로그인 이름입니다.
Description | 사용자에 대한 설명입니다.
Email Address | 사용자 전자 메일 주소입니다.
Responsibility | 현재 응용 프로그램 사용자의 책임 수준입니다. 책임 수준에서 Sign-on 감사를 사용할 수 있는 경우에만 표시됩니다.
Form | 사용자의 양식입니다. 양식 수준에서 Sign-on 감사를 사용할 수 있는 경우에만 표시됩니다.
Login Name | 사용자 세션의 로그인 이름입니다.
Login Time | 사용자가 세션을 시작한 시간입니다.
Connection Time | 사용자가 선택한 시간까지 연결되어 있던 총 시간입니다.
Terminal ID | 연결이 시작된 터미널입니다.


Activity - Performance Details

성능 정보는 Oracle에서 OAM(Oracle Application Administration) 응용 프로그램에 대한 정보를 수집하기 위해 제공한 프로그램의 존재 여부를 기초로 합니다. Oracle에서는 OAM 프로세스의 일부로 5-10분 마다 동시 프로그램을 실행하여 모니터할 정보를 수집합니다. 이 프로그램의 주요 기능은 많은 조회 및 업데이트를 수행하여 OAM 제품 정보를 입력하는 것입니다. 본질적으로 이 프로그램은 실행될 때마다 동일한 활동을 수행합니다. 따라서 프로그램 실행 시간에 발생하는 모든 지연은 프로그램 활동이 아니라 데이터베이스 성능과 관련이 있으므로 실행될 때마다 프로그램 실행 시간을 그래프로 작성하면 전체 응용 프로그램 성능을 파악할 수 있습니다.

주: 이 옵션은 OAM COLLECTOR 프로그램이 실행 중인 경우 LHS에서만 사용할 수 있습니다.

Details 패널의 차트는 OAM 수집 프로그램이 실행될 때마다 이 프로그램의 총 실행 시간을 보여 줍니다. Grid 탭은 추가 조사 또는 그래프 작성을 위한 원시 정보를 제공합니다.


Activity - Point in Time - Self Service Activity 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

이 탭은 선택한 시간에 활성화된 상태이던 자체 서비스 세션을 나열합니다.

열 제목 | 설명
Session ID | Self Service Web Apps 세션의 내부 세션 ID입니다.
User ID | 응용 프로그램 사용자 계정의 고유한 내부 식별자입니다.
User Name | 응용 프로그램 사용자의 로그인 이름입니다.
Description | 사용자에 대한 설명입니다.
Mode | 자체 서비스 세션 모드입니다.
Last Responsibility | 세션에 대한 사용자의 마지막 활동과 관련된 응용 프로그램 책임입니다.
Org Name | 세션에 대한 사용자의 마지막 활동과 관련된 조직입니다.
Last Function | 세션에 대한 사용자의 마지막 활동과 관련된 기능입니다.
Session Start | 세션이 시작된 날짜 및 시간입니다.
Session End | 사용자의 마지막 페이지 요청 날짜 및 시간입니다.

주: 서비스 세션에서는 이전 세션 활동은 저장하지 않으므로 세션의 마지막 활동만 사용할 수 있습니다.


Applications Object 패널

Applications Objects 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

브라우저 왼쪽에 응용 프로그램 및 응용 프로그램 책임이 트리 구조로 표시됩니다.

응용 프로그램을 선택하면 오른쪽에 응용 프로그램 정보가 표시됩니다. 책임을 선택하면 오른쪽에 책임 정보가 표시됩니다.

트리 구조는 다음과 같이 표시됩니다.

쉽게 알 수 있도록 응용 프로그램 이름 뒤에 간단한 응용 프로그램 이름이 추가되었습니다.

책임 끝에 붙은 번호는 사용자에게 책임이 할당된 횟수를 의미합니다. 횟수에는 활성 사용자와 사용자에 대한 활성 책임만 포함됩니다.

책임에 종료 날짜가 지정된 경우 종료 날짜가 책임 이름 뒤에 추가되고 책임 이름 앞에 글자 하나가 표시됩니다.

책임 상태 | 계정 상태 코드
Active Responsibility | null
Future End Date | F
End Dated Account | E

예

책임에 종료 날짜를 지정하려고 하는 중이며, 종료 날짜의 영향을 받으며 해당 책임이 할당되는 사용자가 있는지 알아 보려 합니다.

  1. 책임 응용 프로그램을 선택합니다.

  2. 책임 끝에 추가된 번호를 확인합니다.

  • (0)이면 이 책임이 할당된 사용자가 없습니다.

  • 값이 (0)보다 크면 책임을 선택한 후 오른쪽에서 users 탭을 선택하여 책임이 할당된 사용자 목록을 가져옵니다.


Applications Details 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

eBiz Browser의 오른쪽에는 선택한 개체에 대한 자세한 정보가 표시됩니다.

Applications Details

응용 프로그램이나 응용 프로그램 책임을 선택할 수 있습니다. Applications Details 탭에는 다음이 포함됩니다.

탭

제공되는 정보

Info

선택한 응용 프로그램에 대한 응용 프로그램 정보를 표시합니다.

Profile Options

선택한 응용 프로그램의 응용 프로그램 수준에서 설정된 모든 프로파일 옵션을 나열합니다.

Users

하나 이상의 응용 프로그램 책임에 대한 액세스 권한이 있는 사용자를 나열합니다.

Patches

다음 세 섹션에서 패치 정보를 나열합니다.

  • 적용된 패치 중에서 하나 이상의 선택한 응용 프로그램 구성 요소에 영향을 주었을 수 있는 패치를 나열합니다.

  • 선택한 경로에 대한 “Patch Bugs”를 나열합니다.

  • 선택한 버그에 대한 모든 “Patch Bug Details”를 나열합니다.

Application Responsibilities Details

응용 프로그램이나 응용 프로그램 책임을 선택할 수 있습니다. Applications Responsibility Details 탭에는 다음이 포함됩니다.

탭 | 표시 정보
Info | 선택한 응용 프로그램에 대한 응용 프로그램 정보를 표시합니다.
Profile Options | 선택한 응용 프로그램의 응용 프로그램 수준에서 설정된 모든 프로파일 옵션을 나열합니다.
Users | 하나 이상의 응용 프로그램 책임에 대한 액세스 권한이 있는 사용자를 나열합니다.
Menu | 선택한 책임의 메뉴 구조를 표시합니다.


Applications Info 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

속성 | 설명
Application ID | 내부 응용 프로그램 ID입니다.
Application Short Name | 응용 프로그램의 간단한 이름입니다.
Applciation Description | 응용 프로그램의 전체 이름입니다.
Base path | 응용 프로그램 소스의 기본 경로 이름입니다.
Account Information |
Created Date | 응용 프로그램을 작성한 날짜입니다.
Created By | 응용 프로그램을 작성한 응용 프로그램 사용자입니다.
Last Updated Date | 응용 프로그램이 마지막으로 업데이트된 날짜입니다.
Last Updated By | 응용 프로그램을 마지막으로 업데이트한 응용 프로그램 사용자입니다.
Status and Version Information |
Install Status | 응용 프로그램의 설치 상태 - installed(설치됨), shared install(설치 공유됨) 등
Version | 설치된 모듈의 버전입니다.
Patch level | 설치된 응용 프로그램의 패치 수준입니다. 주: 패치 수준은 Oracle 11i 초기 릴리스에서는 사용하지 못할 수도 있습니다.
Database Information |
Tablespace (Data) | 설치 중 사용되는 기본 테이블 공간입니다.
Tablespace (Index) | 설치 중 사용되는 기본 색인 테이블 공간입니다.
Tablespace (Temporary) | 설치 중 사용되는 기본 임시 테이블 공간입니다.
Oracle ID | 응용 프로그램이 설치된 Oracle 계정입니다.
Oracle User Name | Oracle 계정의 사용자 이름입니다.
Oracle User Description | Oracle 계정 사용자에 대한 설명입니다.


Applications Profile Options 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

선택한 응용 프로그램의 응용 프로그램 수준에서 설정된 모든 프로파일 옵션을 나열합니다.

열 제목 | 설명
Option ID | 프로파일 옵션 ID입니다.
Option name (internal) | 내부 프로파일 옵션 이름입니다.
Option Name | 사용자 프로파일 옵션 이름입니다.
Option Value | 프로파일 옵션 값입니다.
Site Level Value | 선택한 프로파일 옵션의 사이트 수준 값입니다.


Applications Users

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

하나 이상의 응용 프로그램 책임에 대한 액세스 권한이 있는 사용자를 나열합니다.

열 제목 | 설명
User ID | 응용 프로그램 사용자 계정의 고유한 내부 식별자입니다.
User Name | 응용 프로그램 사용자의 로그인 이름입니다.
Description | 사용자에 대한 설명입니다.
Email Address | 사용자의 전자 메일 주소입니다.
Employee | 사용자가 직원으로 구성되었는지 여부를 나타냅니다.
Supplier | 사용자가 공급자로 구성되었는지 여부를 나타냅니다.
Customer | 사용자가 고객으로 구성되었는지 여부를 나타냅니다.
Resp Name | 사용자에게 부여된 책임입니다.
Resp Start Date | 사용자에 대해 책임이 활성화된 날짜입니다.
Resp End Date | 사용자에 대해 책임이 종료되었거나 종료될 날짜입니다.


Applications Patches

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Applied Patches

적용된 패치 중에서 하나 이상의 선택한 응용 프로그램 구성 요소에 영향을 주었을 수 있는 패치를 나열합니다.

열 제목 | 설명
Database Name | 패치가 적용된 데이터베이스의 SID입니다.
Server | 패치가 적용된 서버입니다.
Name | 패치 번호입니다.
Patch ID | 응용 프로그램 패치의 내부 ID입니다.
Type | 패치가 단일 패치인지 또는 패치 집합인지를 나타냅니다.
Rapid Install | Rapid Install 데이터베이스 작성 중에 Oracle에서 적용한 패치임을 나타냅니다(Yes/No).
Source | 패치가 applptch.txt 파일에서 업로드되었는지 또는 패치 드라이버(DRV) 파일 적용 결과로 작성되었는지를 나타냅니다.
Driver Name | 패치 드라이버의 이름입니다.
Top | 패치가 있는 폴더입니다.
Actions | Autopatch를 호출한 경우 "options"의 인수입니다.
Start Date | Autopatch에서 패치 적용을 시작한 날짜 및 시간입니다.
End Date | Autopatch에서 패치 적용을 완료한 날짜 및 시간입니다.
Patch Run Time | Autopatch에서 패치를 적용하는 데 소요된 시간(HH:MM:SS)입니다.
Patch Run ID | 패치 실행의 고유 ID입니다.
Platform | 패치가 작성된 플랫폼입니다.
Node | 패치가 적용된 서버가 동시 처리를 실행하는지 여부를 나타냅니다(Yes/No).
Admin | 패치가 적용된 서버가 관리 작업을 실행하는지 여부를 나타냅니다(Yes/No).
Forms | 패치가 적용된 서버가 양식 서버를 실행하는지 여부를 나타냅니다(Yes/No).
Web | 패치가 적용된 서버가 응용 프로그램 서버를 실행하는지 여부를 나타냅니다(Yes/No).
Imported From DB | 이 행을 가져온 데이터베이스의 ORACLE_SID입니다.
Imported ID | 소스 데이터베이스의 패치 실행 ID입니다.

Patch Bugs

Applied Patches 영역에서 선택한 패치에 대한 “Patch Bugs”를 나열합니다.

열 제목 | 설명
Bug Number | 버그 번호입니다.
Orig Bug Number | 버그의 원래 번호입니다.
Patch Run Bug ID | 버그의 ID입니다.
Bug Status | 적용된 버그 수정의 상태입니다.
Applied | Autopatch에서 이 버그 수정을 적용하려 했는지 여부를 나타냅니다(Yes/No).
Reason Not Applied | 버그 수정이 적용되지 않은 이유입니다.
Success | 패치 적용의 성공 여부를 나타냅니다(Yes/No).
Failure Comments | 패치 적용 실패에 관한 설명입니다.

Patch Bug Details

Patch Bugs 영역에서 선택한 패치 버그에 대한 모든 “Patch Bugs Details”를 나열합니다.

열 제목 | 설명
Orig Bug Number | 버그의 원래 번호입니다.
Action Code | 패치 드라이버의 작업 코드입니다.
Action Phase | 패치 드라이버에 있는 작업 문의 단계 구성 요소입니다.
Appn Short Name | 응용 프로그램의 간단한 이름입니다.
Sub Directory | 파일이 있는 하위 디렉토리입니다.
File Name | 파일의 이름입니다.
Version | 구성 요소의 버전입니다.


Application Responsibilities Info 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Info 탭은 선택한 책임의 일반적인 책임 정보를 표시합니다.

열 제목

설명

Appln ID

책임의 내부 응용 프로그램 ID입니다.

Resp ID

내부 책임 ID입니다.

Responsibility Name

전체 책임 이름입니다.

Start Date

사용자 책임이 활성화된 날짜입니다.

End Date

계정이 종료된 또는 종료될 날짜입니다.

Menu ID

메뉴 진입점입니다.

Menu Name

책임에서 호출하는 메뉴의 이름입니다.

Available From

메뉴가 다음 중 어느 위치에서 호출되었는지를 나타냅니다.

  • Oracle Applications

  • Oracle Self Service Web Applications

  • Oracle Mobile Applications

Creation Information

Created Date

책임을 작성한 날짜입니다.

Created By

책임을 작성한 응용 프로그램 사용자입니다.

Last Update Date

책임이 마지막으로 업데이트된 날짜입니다.

Last Updated by

책임을 마지막으로 업데이트한 응용 프로그램 사용자입니다.

Request Group Information

Request Group

책임에 할당된 보고서 요청 그룹입니다.

Request Group Application

요청 그룹 응용 프로그램의 전체 응용 프로그램 이름입니다.

Data Group Information

Data Group

책임과 관련된 데이터 그룹입니다.

Data Group Application

데이터 그룹 응용 프로그램의 전체 응용 프로그램 이름입니다.


Application Responsibility Profile 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

선택한 책임의 책임 수준에서 설정된 모든 프로파일 옵션을 나열합니다.

열 제목 | 설명
Option ID | 프로파일 옵션 ID입니다.
Option Name (internal) | 내부 프로파일 옵션 이름입니다.
Option Name | 사용자 프로파일 옵션 이름입니다.
Option Value | 프로파일 옵션 값입니다.
Site Level Value | 선택한 프로파일 옵션의 사이트 수준 값입니다.


Application Responsibility Users 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

선택한 책임에 대한 액세스 권한이 부여된 모든 사용자를 나열합니다.

열 제목 | 설명
User ID | 응용 프로그램 사용자 계정의 고유한 내부 식별자입니다.
User Name | 응용 프로그램 사용자의 로그인 이름입니다.
Description | 사용자에 대한 설명입니다.
E-Mail Address | 사용자 전자 메일 주소입니다.
Employee | 사용자가 직원으로 구성된 경우를 나타냅니다.
Customer | 사용자가 고객으로 구성된 경우를 나타냅니다.
Supplier | 사용자가 공급자로 구성된 경우를 나타냅니다.
Start Date | 사용자에 대해 사용자 책임이 활성화된 날짜입니다.
End Date | 사용자에 대해 책임이 종료되었거나 종료될 날짜입니다.


Application Responsibility Menu 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

이 탭의 내용은 선택한 책임의 메뉴 구조를 보여 줍니다.

마우스 오른쪽 단추 메뉴에서 구조를 클립보드로 출력하거나 복사하도록 선택할 수 있습니다.


Audit - Objects 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Audit 기능은 암호 구성 및 활동, 책임 사용 및 실패한 로그인 시도와 관련된 기본적인 몇 가지 감사 기능을 제공합니다. 이 영역을 사용하여 몇 가지 기본적인 월별 응용 프로그램 감사 보고서를 생성할 수 있습니다.

Audit Objects 패널에는 네 가지 옵션이 표시됩니다.

  • PWD Profile 옵션

  • Responsibilities

  • Unsuccessful Logins

  • User Accounts


Audit - Password Profile Options Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Password Profiles Options Detail 패널은 응용 프로그램 암호와 직접적으로 관련된 응용 프로그램 프로파일 옵션을 나열합니다.

옵션 이름

설명

Sign-On:Notification

계정에 대한 로그온 시도가 실패한 경우 사용자에게 알립니다.

Signon Password Length

최소 암호 길이(기본값 = 5)입니다.

Signon Password Hard to Guess

이 옵션이 설정되면 암호가 다음 조건에 맞아야 합니다.

  • 최소한 하나의 영문자와 숫자 하나를 포함해야 합니다.

  • 사용자 이름과 달라야 합니다.

  • 반복 문자를 포함하지 않아야 합니다.

Signon Password No

암호를 다시 사용하기 전에 경과되어야 할 최소 일 수입니다.

Signon Password Failure Limit

X(기본값 = 3)번 이상 로그인에 실패할 경우 계정이 잠깁니다.

주:

  • 일부 프로파일 옵션은 특정 릴리스에서만 사용할 수 있습니다.

  • 위의 모든 프로파일 옵션은 사이트 수준에서만 설정됩니다.


Audit - Responsibilities Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Responsibilities Details 패널은 다음 탭으로 구성됩니다.

  • Usage - 모든 활성 응용 프로그램 책임과 책임에 대한 액세스 권한이 부여된 사용자 수를 나열합니다.

  • Usage - 선택한 책임에 대한 액세스 권한이 부여된 모든 활성 사용자를 나열합니다.

  • Special Resp - 시스템 관리자 또는 응용 프로그램 개발자 책임이 부여된 모든 사용자를 나열합니다.

  • Special Resp Usage - 사용자별 “Special” 책임 사용을 나열합니다.

  • User Resp Added - 지난 한 달 동안 사용자에게 할당된 책임을 나열합니다.


Audit - Responisbilities - Usage 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

모든 활성 응용 프로그램 책임과 책임에 대한 액세스 권한이 부여된 사용자 수를 나열합니다.

위쪽 그리드

위쪽 그리드에서는 모든 활성 응용 프로그램 책임을 나열합니다. 사용자 지정 필터(“Greater Than” 및 0)를 User count 열에 추가하여 사용 중인 책임만 나열할 수도 있습니다.

열 제목 | 설명
Application | 책임 응용 프로그램 이름입니다.
Application ID | 책임 응용 프로그램 ID입니다.
Responsibility ID | 내부 책임 참조 번호입니다.
Responsibility | 책임의 전체 이름입니다.
End Date | 사용자에게 부여된 책임에 대한 액세스 권한이 만료되는 날짜입니다.
User Count | 책임에 대한 액세스 권한이 부여된 사용자 수입니다.

Lower grid

아래쪽 그리드는 선택한 책임에 대한 액세스 권한이 부여된 모든 활성 사용자를 나열합니다.

열 제목 | 설명
User Name | 응용 프로그램 사용자 계정의 고유한 내부 식별자입니다.
User ID | 응용 프로그램 사용자의 로그인 이름입니다.
Description | 사용자에 대한 설명입니다.
Email Address | 사용자 전자 메일 주소입니다.
Start Date | 사용자에 대해 책임이 활성화된 날짜입니다.
End Date | 책임이 종료된 또는 종료될 날짜입니다.


Audit - Responsibilities - Special Resp 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Special Resp 탭은 시스템 관리자 또는 응용 프로그램 개발자 책임이 부여된 사용자를 모두 나열합니다.

예를 들어 이 그리드를 사용하면 책임이 부여되었지만 X일 동안 이 책임을 사용하지 않은 사용자 또는 이 액세스 수준이 부여되지 않은 사용자를 식별할 수 있습니다.

열 제목 | 설명
Responsibility | 책임 이름입니다.
User Name | 응용 프로그램 사용자의 로그인 이름입니다.
Description | 사용자에 대한 설명입니다.
Email Address | 사용자의 전자 메일 주소입니다.
End Date | 사용자에게 부여된 책임에 대한 액세스 권한이 만료되는 날짜입니다.
Last Logon | 사용자가 응용 프로그램(모든 책임)에 마지막으로 연결한 날짜 및 시간입니다.
Days Since Last Connect | 사용자가 응용 프로그램에 마지막으로 연결한 이후에 경과된 일 수입니다.


Audit - Responsibilities - Special Resp Usage 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

이 탭은 사용자별 특수 책임 사용을 나열합니다. 사용 가능한 기록의 양은 사이트의 Sign-On 감사 제거 정책에 따라 다릅니다.

예를 들면, 이 정보를 사용하여 액세스 권한이 없는 책임을 사용 중인 사용자를 식별할 수 있습니다. 또한 이 정보를 사용하여 호환되지 않는(기업 지배구조) 책임을 가진 사용자를 식별할 수도 있습니다.

주: 이 그리드는 %SUPER%, %ADMIN%, %DEVOP% 문자열을 포함하는 책임만 나열합니다.

이 그리드는 응용 프로그램 언어가 영어(또는 영어의 다양한 형태 중 하나)인 관련 정보만 제공합니다.

열 제목 | 설명
Responsibility | 책임 이름입니다.
Resp End Date | 책임 종료 날짜입니다.
User Name | 응용 프로그램 사용자의 로그인 이름입니다.
Description | 사용자에 대한 설명입니다.
User End Date | 사용자 계정이 종료될 날짜입니다.
Times Used | 책임이 사용된 횟수입니다.
First Time | 책임을 처음 사용한 날짜 및 시간입니다.
Last Time | 책임을 마지막으로 사용한 날짜 및 시간입니다.


Audit - Responsibilities - User Resp Added 탭

Audit - Responsibilities - User Resp Added tab

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

User Resp Added 탭은 지난 한 달 동안 사용자에게 할당된 책임을 나열합니다.

열 제목 | 설명
Application | 책임 응용 프로그램 ID입니다.
Responsibility | 부여된 책임입니다.
Start Date | 사용자에게 책임이 할당된 날짜입니다.
End Date | 사용자에게 부여된 책임에 대한 액세스 권한이 만료되는 날짜입니다.
User Name | 책임이 부여된 사용자입니다.
Description | 사용자에 대한 설명입니다.
Created By | 책임을 부여한 응용 프로그램 사용자입니다.
Created Date | 책임이 부여된 날짜입니다.


Audit - Unsuccessful Logins Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Unsuccessful Logins Details 탭은 지난 달에 한 번 이상 실패한 로그온 시도가 있었던 계정을 표시하고 선택한 사용자에 대한 실패한 로그인 시도를 모두 나열합니다.

실패한 로그인 시도는 전체 서비스 세션으로만 제한됩니다. 사용 가능한 기록의 양은 사이트의 Sign-On 감사 제거 정책에 따라 다릅니다.


Audit - Unsuccessful Logins - Full Service

Audit - Unsuccessful Logins - Full Service 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Full Service 탭은 지난 달에 한 번 이상 실패한 로그온 시도가 있었던 계정을 표시하고 선택한 사용자에 대한 실패한 로그인 시도를 모두 나열합니다.

예를 들면, 이 정보를 사용하여 계정에 대한 부적절한 액세스를 식별하거나 암호를 지속적으로 잊어버리는 사용자를 식별할 수 있습니다.

위쪽 영역

Full service 탭의 기본 영역인 이 영역에서는 지난 달에 한 번 이상 실패한 로그인 시도가 있었던 계정을 나열합니다.

열 제목 | 설명
User ID | 응용 프로그램 사용자 계정의 고유한 내부 식별자입니다.
User Name | 응용 프로그램 사용자의 로그인 이름입니다.
Description | 사용자에 대한 설명입니다.
Email Address | 사용자 전자 메일 주소입니다.
Attempts | 지난 달에 있었던 로그인 실패 시도 횟수입니다.

아래쪽 영역

위쪽 영역의 선택된 사용자 계정에 대한 실패한 개별 로그인 시도를 나열합니다.

열 제목 | 설명
Terminal ID | 로그인 시도가 있었던 터미널 ID입니다. 주: 응용 프로그램에서 터미널 ID를 항상 자동으로 입력하지는 않습니다.
Attempt Time | 로그인 실패 시도가 있었던 날짜 및 시간입니다.


Audit - User Accounts Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

User Accounts Details 패널은 다음 탭으로 구성됩니다.

  • PWD Aging - 암호 만료일 정보를 포함하는 모든 활성 사용자 계정을 나열합니다.

  • No PWD Aging - 암호 만료일을 설정하지 않은 모든 활성 사용자 계정을 나열합니다.

  • Aged Users - 마지막 연결 이후 경과된 일 수를 포함하는 모든 활성 사용자 계정을 나열합니다.

  • Accounts Created - 지난 한 달 동안 작성된 모든 사용자 계정을 나열합니다.

  • End Dated - 종료 날짜가 지정되어 있으며 지난 한 달 내에 종료 날짜가 경과된 모든 사용자를 나열합니다.

  • Will End Date - 종료 날짜가 지정되어 있으며 다음 한 달 내에 종료될 모든 사용자 계정을 나열합니다.


Audit - User Accounts - PWD Aging 탭

Audit - User Accounts - PWD Aging tab

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

암호 만료일 정보를 포함하는 모든 활성 사용자 계정을 나열합니다.

열 제목 | 설명
User Name | 응용 프로그램 사용자 이름입니다.
Description | 사용자에 대한 설명입니다.
End Date | 계정이 종료될 날짜입니다.
Last Logon Date | 계정에 마지막으로 연결한 날짜 및 시간입니다.
Days Since Last Logon | 사용자가 응용 프로그램에 마지막으로 연결한 이후에 경과된 일 수입니다.
PWD Last Changed | 암호가 마지막으로 변경된 날짜 및 시간입니다. null 값은 암호가 한 번도 변경되지 않았음을 의미합니다.
Password Lifespan Days | 암호 변경 간의 일 수를 나타냅니다.
Days Remaining | 암호의 수명을 설정한 경우 암호를 변경해야 할 때까지 남은 일 수입니다. 값이 0이면 계정에 다시 액세스할 때 암호를 변경해야 합니다.
Password Lifespan Accesses | 암호를 변경해야 할 때까지 허용되는 응용 프로그램 액세스 횟수입니다.
Lifespan Access Left | 암호 수명 액세스를 설정한 경우 암호를 변경해야 할 때까지 남은 액세스 횟수입니다.


Audit - User Accounts - No PWD Aging 탭

Audit - User Accounts - No PWD Aging tab

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

이 탭은 암호 만료일을 설정하지 않은 모든 활성 사용자 계정을 나열합니다.

열 제목 | 설명
User Name | 응용 프로그램 사용자 이름입니다.
Description | 사용자에 대한 설명입니다.
End Date | 계정이 종료되었거나 종료될 날짜입니다.
Last Logon Date | 계정에 마지막으로 연결한 날짜 및 시간입니다.
Days Since Last Connect | 사용자가 응용 프로그램에 마지막으로 연결한 이후에 경과된 일 수입니다.
Admin Changed | 암호를 변경한 마지막 사용자가 관리자였는지를 나타냅니다.
Password Lifespan Days | 암호 변경 간의 일 수를 나타냅니다.
Days Remaining | 암호의 수명을 설정한 경우 암호를 변경해야 할 때까지 남은 일 수입니다. 값이 0이면 계정에 다시 액세스할 때 암호를 변경해야 합니다.
Password Lifespan Accesses | 암호를 변경해야 할 때까지 허용되는 응용 프로그램 액세스 횟수입니다.
Lifespan Access left | 암호 수명 액세스를 설정한 경우 암호를 변경해야 할 때까지 남은 액세스 횟수입니다.


Audit - User Accounts - Aged Users

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

이 탭은 마지막 연결 이후 경과된 일 수를 비롯하여 모든 활성 사용자 계정을 나열합니다.

열 제목 | 설명
User Name | 응용 프로그램 사용자 이름입니다.
Description | 사용자에 대한 설명입니다.
Email Address | 사용자의 전자 메일 주소입니다.
Last Logon Date | 계정에 마지막으로 연결한 날짜 및 시간입니다.
Days Since Last Connect | 사용자가 응용 프로그램에 마지막으로 연결한 이후에 경과된 일 수입니다. null 값은 계정이 한 번도 사용되지 않았음을 의미합니다. 0 값은 계정이 오늘 액세스되었음을 의미합니다.
End Date | 계정이 종료되었거나 종료될 날짜입니다.

예 - 날짜 지정 종료 대상 사용자 목록 작성

  1. 그리드 내에서 마우스 오른쪽 단추를 눌러 그리드를 쉼표로 구분된 텍스트 파일로 저장한 후 Excel로 가져옵니다. 이 때 제목도 반드시 저장해야 합니다.

  2. Excel 파일을 편집하여 최근 120일 내에 연결되었던 사용자와 특수 사용자를 모두 제거합니다.


Audit - User Accounts - Accounts Created 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

이 탭은 지난 달에 작성된 모든 사용자 계정을 나열합니다.

열 제목 | 설명
User Name | 응용 프로그램 사용자 이름입니다.
Description | 사용자에 대한 설명입니다.
Email Address | 사용자 전자 메일 주소입니다.
Created Date | 사용자 계정이 작성된 날짜입니다.
Last Logon Date | 계정에 마지막으로 연결한 날짜 및 시간입니다.
Days Since Last Connect | 사용자가 응용 프로그램에 마지막으로 연결한 이후에 경과된 일 수입니다. null 값은 계정이 한 번도 사용되지 않았음을 의미합니다.
End Date | 계정이 종료되었거나 종료될 날짜입니다.
Last Updated Date | 계정이 마지막으로 업데이트된 날짜 및 시간입니다.
Last Updated By | 계정을 마지막으로 업데이트한 사용자 계정입니다.


Audit - User Accounts - End Dated

이 탭은 종료 날짜가 지정되어 있으며 지난 한 달 내에 종료 날짜가 경과된 모든 사용자를 나열합니다.

열 제목 | 설명
User Name | 응용 프로그램 사용자 이름입니다.
Description | 사용자에 대한 설명입니다.
Email Address | 사용자 전자 메일 주소입니다.
Created Date | 사용자 계정이 작성된 날짜입니다.
Last Logon Date | 계정에 마지막으로 연결한 날짜 및 시간입니다.
Days Since Last Connect | 사용자가 응용 프로그램에 마지막으로 연결한 이후에 경과된 일 수입니다. null 값은 계정이 한 번도 사용되지 않았음을 의미합니다.
End Date | 계정이 종료된 날짜입니다.
Last Updated Date | 사용자 계정이 마지막으로 업데이트된 날짜입니다.
Last Updated By | 사용자 계정을 마지막으로 업데이트한 응용 프로그램 사용자입니다.


Audit - User Accounts - Will End Date 탭

Audit - User Accounts - Will End Date tab

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

종료 날짜가 지정되어 있으며 지난 한 달 내에 닫힐(종료 날짜가 경과될) 모든 사용자 계정을 나열합니다.

열 제목 | 설명
User Name | 응용 프로그램 사용자 이름입니다.
Description | 사용자에 대한 설명입니다.
Email Address | 사용자의 전자 메일 주소입니다.
Created Date | 사용자 계정이 작성된 날짜입니다.
Last Logon Date | 계정에 마지막으로 연결한 날짜 및 시간입니다.
Days Since Last Connect | 사용자가 응용 프로그램에 마지막으로 연결한 이후에 경과된 일 수입니다. null 값은 계정이 한 번도 사용되지 않았음을 의미합니다.
End Date | 계정이 종료되었거나 종료될 날짜입니다.
Days Remaining | 계정이 종료될 때까지 남은 일 수입니다.
Last Updated Date | 사용자 계정을 마지막으로 업데이트한 날짜입니다.
Last Updated By | 사용자 계정을 마지막으로 업데이트한 응용 프로그램 사용자입니다.

예를 들어 이 정보를 사용하여 인사 관리부에 계정 종료가 임박했음을 알릴 수 있습니다.

종료 날짜가 임박했고 마지막 연결 이후 7일이 경과되지 않은 계정은 여전히 사용 중일 가능성이 높습니다.


eBiz Concurrent Programs Objects 패널

Concurrent Programs Objects 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

브라우저의 Object 패널은 프로그램이 등록되어 있는 응용 프로그램과 선택한 응용 프로그램에 대한 프로그램만 보여주는 두 가지 수준의 트리 구조를 표시합니다.

예 형식:

동시 프로그램을 사용할 수 없는 경우 프로그램 이름 앞에 [image] 가 표시됩니다.


eBiz Concurrent Programs Details 패널

Concurrent Programs Details 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

eBiz Browser의 오른쪽에는 선택한 개체에 대한 자세한 정보가 표시됩니다.

Application Details

응용 프로그램이나 프로그램을 선택할 수 있습니다. Application Details에는 응용 프로그램에 대한 정보를 표시하는 하나의 탭만 포함되어 있습니다.

Program Details

응용 프로그램이나 프로그램을 선택할 수 있습니다. 프로그램을 선택하면 Programs Details가 다음 탭으로 구성됩니다.

  • Info - 선택한 프로그램에 대한 일반 동시 프로그램 정보를 표시합니다.

  • Accessed By - 선택한 프로그램에 액세스할 수 있는 요청 그룹 등 모든 책임을 나열합니다.

  • Users - 프로그램에 액세스하는 데 사용되는 책임 및 요청 그룹 등 선택한 프로그램에 액세스할 수 있는 모든 사용자를 나열합니다.

  • Incompatibilities - 선택한 프로그램과 호환되지 않는 모든 프로그램을 나열합니다.

  • Parameters - 선택한 프로그램에 대한 모든 런타임 매개 변수를 나열합니다.

  • Activity By User - 두 통계로 나뉩니다.

  • Overall Run Stats of the Selected Concurrent Program - 선택한 동시 프로그램에 대한 응용 프로그램 사용자의 전체 활동을 나열합니다.

  • Runs of the Selected Program by the Selected User - 선택한 프로그램에 대한 선택한 사용자의 개별 실행을 나열합니다.

  • Run Times - 선택한 프로그램의 런타임을 나열합니다.

Runtime Values

프로그램에 이전 실행이 있는 경우 오른쪽(Details 패널) 그리드 아래에 있는 상태 표시줄에 선택한 프로그램의 런타임 통계가 다음 형식으로 표시됩니다.

Run Stats: Runs = 92; Min Time = 00:00:01; Avg Time = 00:00:07; Max Time = 00:03:56

상태 표시줄은 다음과 같이 해석됩니다.

샘플 크기 = 92

  • 최소 런타임 = 1초

  • 평균 런타임 = 7초

  • 최대 런타임 = 3분 56초

주: 통계는 선택한 프로그램에 대한 fnd_concurrent_requests의 모든 사용 가능한 런타임 기록을 기초로 합니다. 통계에는 런타임 매개 변수와 관계 없이 선택한 프로그램의 완료된 실행이 포함됩니다.

런타임 값은 다음 탭에서 표시합니다.

  • Run Times

  • Activity by User


eBiz Concurrent Programs Applications Info 탭

Concurrent Programs - Applications Info 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Info 탭은 선택한 응용 프로그램의 일반적인 응용 프로그램 정보를 표시합니다.

열 제목 | 설명
Application ID | 내부 응용 프로그램 ID입니다.
Application Short Name | 응용 프로그램의 간단한 이름입니다.
Application Name | 응용 프로그램 이름입니다.
Application Description | 응용 프로그램의 전체 이름입니다.
Base Path | 응용 프로그램 소스의 기본 경로 이름입니다.
Creation Information |
Created Date | 응용 프로그램을 작성한 날짜입니다.
Created By | 응용 프로그램을 작성한 응용 프로그램 사용자입니다.
Last Updated Date | 응용 프로그램이 마지막으로 업데이트된 날짜입니다.
Last Updated By | 응용 프로그램을 마지막으로 업데이트한 응용 프로그램 사용자입니다.
Status and Version Information |
Install Status | 응용 프로그램의 설치 상태 - Installed(설치됨), shared install(설치 공유됨) 등
Version | 설치된 모듈의 버전입니다.
Patch Level | 설치된 응용 프로그램의 패치 수준입니다. 주: 패치 수준은 11i 초기 릴리스에서는 사용하지 못할 수도 있습니다.
Database Information |
Tablespace (Data) | 설치 중 사용되는 기본 테이블 공간입니다.
Tablespace (Index) | 설치 중 사용되는 기본 색인 테이블 공간입니다.
Tablespace (Temporary) | 설치 중 사용되는 기본 임시 테이블 공간입니다.
Oracle ID | 응용 프로그램이 설치된 Oracle 계정입니다.
Oracle User Name | Oracle 계정의 사용자 이름입니다.
Oracle User Description | Oracle 계정 사용자에 대한 설명입니다.


eBiz Concurrent Programs Programs Info 탭

Concurrent Programs - Programs - Info 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Objects 패널에서 프로그램을 선택하면 선택한 프로그램에 대한 일반적인 동시 프로그램 정보가 Info 탭에 표시됩니다.

열 제목 | 설명
Application ID | 내부 프로그램의 응용 프로그램 ID입니다.
Application | 응용 프로그램의 간단한 이름입니다.
Program ID | 내부 프로그램 ID입니다.
Program Status | 프로그램의 활성화 여부를 나타냅니다.
Program Name (Internal) | 프로그램의 간단한 이름입니다.
Program Name | 프로그램의 전체 이름입니다.
Program Description | 프로그램에 대한 설명입니다.
Execution Information |
Executable Name | 프로그램의 실행 파일 이름입니다.
Execution Method | 프로그램 실행에 사용되는 메서드입니다.
Execution Options | Oracle Report 실행 옵션입니다.
Request Priority | 프로그램 런타임 우선 순위입니다.
Queue Information |
Argument Method | 프로그램에 프로그램 인수를 전달하는 방식을 나타냅니다.
Queue Control | 프로그램이 동시 관리자를 제어하는 특수 프로그램인지 여부를 나타냅니다.
Queue Method | 프로그램이 제약되어 있는지 여부를 나타냅니다.
Request Set | 프로그램이 보고서 집합의 상위인지 여부를 나타냅니다.
Request Type |
Request Type | 전문화 규칙 - 요청 유형입니다.
Runtime Information |
Increment Proc | Oracle 응용 프로그램 내부 개발자 전용입니다. 여기에는 증분자 함수가 표시됩니다.
MLS executable Application ID | 다국어 지원 실행 파일 응용 프로그램 ID입니다.
MLS executable ID | 다국어 지원 실행 파일 ID입니다.
MLS executable name | 다국어 지원 실행 파일 이름입니다.
SRS | 요청을 표준 보고서 제출 양식에서 제출할 수 있는지 여부를 나타냅니다.
Run Alone | 프로그램을 단독 실행 요청으로 실행해야 하는지 여부를 나타냅니다.
Enable Trace | 프로그램에 추적 기능을 사용하는지 여부를 나타냅니다.
Restart on System Failure | 프로그램이 실패한 경우 다시 시작되는지 여부를 나타냅니다.
NLS Compliant | 프로그램이 NLS 규격인지 여부를 나타냅니다.
Output Information |
Output File Type | 출력 파일 형식입니다.
Save Output | 출력을 저장해야 하는지 여부를 나타냅니다.
Printer Information |
Default Printer |
Print Output | 출력을 인쇄해야 하는지 여부를 나타냅니다.
Required Style | 프로그램에 인쇄 스타일이 필수적인지 여부를 나타냅니다.
Output Print Style | 출력의 인쇄 스타일입니다.
Minimum Width | 최소 열 개수입니다.
Minimum Length | 최소 행 개수입니다.
Session Information |
Rollback Segment | 프로그램에서 사용할 롤백 세그먼트입니다.
Optimizer Mode | 프로그램에서 사용할 Optimizer 모드입니다.
Resource Consumer Group | 프로그램의 리소스 소비자 그룹입니다.


eBiz Concurrent Programs Programs Accessed By 탭

Concurrent Programs - Programs - Accessed By 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Accessed By 탭은 선택한 프로그램에 액세스할 수 있는 요청 그룹 등 모든 책임을 나열합니다.

열 제목 | 설명
Appn ID | 내부 응용 프로그램 ID입니다.
Application | 응용 프로그램의 간단한 이름입니다.
Application Name | 응용 프로그램의 전체 이름입니다.
Resp ID | 내부 책임 ID입니다.
Responsibility | 전체 책임 이름입니다.
Resp End Date | 책임이 종료될 날짜입니다.
Request Group Appn ID | 책임 요청 그룹 응용 프로그램의 응용 프로그램 ID입니다.
Request Group ID | 책임 요청 그룹의 요청 그룹 ID입니다.
Request Group | 책임 보고서 요청 그룹 이름입니다.


eBiz Concurrent Programs Programs Users 탭

Concurrent Programs - Programs - Users 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Users 탭은 프로그램에 액세스하는 데 사용되는 책임 및 요청 그룹 등 선택한 프로그램에 액세스할 수 있는 모든 사용자를 나열합니다.

열 제목 | 설명
User ID | 응용 프로그램 사용자 계정의 고유한 내부 식별자입니다.
User Name | 응용 프로그램 사용자의 로그인 이름입니다.
Description | 사용자에 대한 설명입니다.
Email Address | 사용자 전자 메일 주소입니다.
Employee | 사용자가 직원으로 구성되었는지 여부를 나타냅니다.
Supplier | 사용자가 공급자로 구성되었는지 여부를 나타냅니다.
Customer | 사용자가 고객으로 구성되었는지 여부를 나타냅니다.
Resp Start Date | 사용자 계정에 책임이 추가된 날짜입니다.
Resp End Date | 사용자에 대해 책임이 종료될 날짜입니다.
Responsibility | 사용자가 프로그램에 액세스하는 데 사용할 수 있는 책임입니다.
Request Group | 프로그램과 관련된 요청 그룹입니다.


eBiz Concurrent Programs Programs Incompatibilities 탭

Concurrent Programs - Programs - Incompatibilities 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Incompatibilities 탭은 선택한 프로그램과 호환되지 않는 모든 프로그램을 나열합니다.

열 제목 | 설명
Appn ID | 내부 프로그램의 응용 프로그램 ID입니다.
Application | 응용 프로그램의 간단한 이름입니다.
Application Name | 응용 프로그램의 전체 이름입니다.
Program ID | 내부 동시 프로그램 식별자입니다.
Program Name Internal | 동시 프로그램의 전체 간단한 이름입니다.
Program Name | 동시 프로그램의 전체 이름입니다.
Program Status | 프로그램의 활성화 여부를 나타냅니다.
Scope | 호환되지 않는 프로그램이 단일 프로그램인지 요청 집합인지를 나타냅니다.
Type | 프로그램이 단일 프로그램인지 요청 집합인지를 나타냅니다.

주: 선택한 프로그램이 목록에 표시되면 호환되지 않는 프로그램임을 나타냅니다.


eBiz Concurrent Programs Programs Parameters 탭

Concurrent Programs - Programs - Parameters 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Parameters 탭은 선택한 프로그램에 대한 모든 기존 런타임 매개 변수를 나열합니다.

열 제목 | 설명
Appn ID | 내부 응용 프로그램 ID입니다.
Desc Flex Name | Descriptive Flex 이름입니다.
Desc Flex Context Code | Descriptive Flex 구조 이름입니다.
Appn Column Name | Descriptive Flex 세그먼트 이름입니다.
Column Seq Number | Descriptive Flex 순서 번호입니다.
User Column Name | 전체 열 이름입니다.
Description | 열에 대한 설명입니다.
Enabled | Flex 필드 활성화 여부를 나타냅니다.
Display | 세그먼트 표시 여부를 나타냅니다.
Max Description Len | Flex 필드 창에서 세그먼트 값 설명의 최대 크기입니다.
Value Set ID | Flex 필드 값 집합 ID입니다.
Value Set Name | Flex 필드 값 집합 이름입니다.
Default Type | 참조 필드의 기본 유형입니다.
Default Value | 참조 필드의 기본값입니다.


Concurrent Programs - Programs - Activity by User

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Activity by User 탭은 선택한 기간(기본값 1일) 동안 응용 프로그램 사용자가 선택한 프로그램에 대해 수행한 전체 활동을 나열한 다음 선택한 프로그램에 대한 선택한 사용자의 개별 실행을 나열합니다.

전체 실행

열 제목 | 설명
User Name | 요청을 전송한 응용 프로그램 사용자입니다.
Description | 사용자에 대한 설명입니다.
Total Requests | 프로그램이 전송된 총 횟수입니다.
Completed Normal | 프로그램이 정상 완료된 총 횟수입니다.
Completed Error | 프로그램이 오류 상태로 완료된 총 횟수입니다.
Completed Warning | 프로그램이 경고 상태로 완료된 총 횟수입니다.
Completed Cancelled | 프로그램이 취소된 총 횟수입니다.
Completed Terminated | 프로그램이 종료된 총 횟수입니다.

개별 실행

선택한 프로그램에 대한 선택한 사용자의 개별 실행을 나열합니다.

열 제목 | 설명
Request ID | 동시 요청 ID입니다.
Manager Name | 요청을 실행한 동시 실행 관리자입니다.
Argument Text | 요청에 대한 런타임 인수입니다.
Priority | 요청 우선 순위입니다.
Status | 요청의 완료 상태입니다.
Req Start | 요청의 날짜 및 시간입니다.
Actual Start | 요청 처리가 시작된 날짜 및 시간입니다.
Completed | 요청 처리가 완료된 날짜 및 시간입니다.
Pending Time | 요청이 대기 중 상태로 있던 총 시간(HH:MM:SS)입니다.
Running Time | 요청에 대한 총 실행 시간(HH:MM:SS)입니다.
Printer | 매수를 포함한 요청이 전송된 프린터입니다.
Completion Text | 요청에 대한 완료 텍스트입니다.
Log File Node | 로그 파일이 저장된 호스트 컴퓨터입니다.
Log File Name | 로그 파일 위치 및 이름입니다.
Out File Node | 출력 파일이 저장된 호스트 컴퓨터입니다.
Out File Name | 출력 파일 위치 및 이름입니다.


eBiz Concurrent Programs Programs Run Times

Concurrent Programs - Programs - Run Times

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Run Times 탭은 선택한 프로그램의 런타임을 나열합니다.

열 제목 | 설명
Request ID | 동시 요청 ID입니다.
Manager Name | 요청을 실행한 동시 실행 관리자입니다.
Program App’n ID | 동시 프로그램과 관련된 내부 응용 프로그램 ID입니다.
Program ID | 내부 동시 프로그램 식별자입니다.
Program Name | 동시 프로그램의 전체 이름입니다.
Argument Text | 요청에 대한 런타임 인수입니다.
Priority | 요청 우선 순위입니다.
Status | 요청의 완료 상태입니다.
Req Start | 요청의 날짜 및 시간입니다.
Actual Start | 요청 처리가 시작된 날짜 및 시간입니다.
Completed | 요청 처리가 완료된 날짜 및 시간입니다.
Pending Time | 요청이 대기 중 상태로 있던 총 시간(HH:MM:SS)입니다.
Running Time | 요청에 대한 총 실행 시간(HH:MM:SS)입니다.
Printer | 매수를 포함한 요청이 전송된 프린터입니다.
Completion Text | 요청에 대한 완료 텍스트입니다.
Log File Node | 로그 파일이 저장된 호스트 컴퓨터입니다.
Log File Name | 로그 파일 위치 및 이름입니다.
Out File Node | 출력 파일이 저장된 호스트 컴퓨터입니다.
Out File Name | 출력 파일 위치 및 이름입니다.


Data Groups Object 패널

Data Groups Objects 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

브라우저의 Object 패널(왼쪽)은 등록된 모든 데이터 그룹을 나열합니다. 기본 데이터 그룹 앞에는 D 기호가 붙습니다.

예를 들면 다음과 같습니다.

D Standard

Multiple Reporting Currencies

Details 패널에서 세부 정보를 보려면 등록된 데이터 그룹을 누릅니다.


Data Groups Details 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

브라우저 오른쪽의 Details 패널은 다음 탭으로 구성됩니다.

탭 | 목차
Info | 선택한 데이터 그룹에 대한 일반 정보를 표시합니다.
Oracle Accounts | 선택한 데이터 그룹과 관련된 Oracle 계정을 나열합니다.
Responsibilities | 선택한 데이터 그룹 단위와 관련된 응용 프로그램 책임을 나열합니다.


Data Groups Info 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Info 탭은 선택한 데이터 그룹에 대한 일반 정보를 표시합니다.

열 제목 | 설명
Data Group ID | 내부 데이터 그룹 ID입니다.
Data Group Name | 데이터 그룹 이름입니다.
Default Data Group | 데이터 그룹이 기본 데이터 그룹인지 여부를 나타냅니다.
Security Group ID | 데이터 그룹의 보안 그룹 ID입니다.
Creation Information |
Created By | 데이터 그룹을 작성한 날짜입니다.
Creation Date | 데이터 그룹을 작성한 응용 프로그램 사용자입니다.
Last Updated by | 데이터 그룹을 마지막으로 업데이트한 날짜입니다.
Last Updated Date | 데이터 그룹을 마지막으로 업데이트한 응용 프로그램 사용자입니다.


Data Groups Oracle Accounts 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Oracle Accounts 탭은 선택한 데이터 그룹과 관련된 Oracle 계정을 표시합니다. 이러한 계정 중 하나를 선택하는 경우 아래쪽 영역에 해당 계정에 대한 책임이 표시됩니다.

열 제목 | 설명
Data Group ID | 내부 데이터 그룹 ID입니다.
Appn ID | 데이터 그룹 단위 응용 프로그램 ID입니다.
Application | 데이터 그룹 단위 응용 프로그램의 간단한 이름입니다.
Description | 데이터 그룹 단위에 대한 설명입니다.
Oracle ID | Oracle 계정 ID입니다.
Oracle User Name | Oracle 계정 사용자 이름입니다.
Oracle User Description | Oracle 계정에 대한 설명입니다.

Responsibilities

Responsibilities 영역은 Oracle Accounts 영역에서 선택한 데이터 그룹 단위와 관련된 응용 프로그램 책임을 나열합니다.

열 제목 | 설명
Resp Appl ID | 책임의 내부 응용 프로그램 ID입니다.
Application | 응용 프로그램의 간단한 이름입니다.
Resp ID | 내부 책임 ID입니다.
Responsibility Name | 전체 책임 이름입니다.
Description | 책임에 대한 설명입니다.
Start Date | 책임이 활성화된 날짜입니다.
End Date | 계정이 종료되었거나 종료될 날짜입니다.


Descriptive Flex - Objects 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Descriptive flex를 선택하면 브라우저의 왼쪽(Objects 패널)에는 각 응용 프로그램 및 해당 Descriptive flex 필드가 계층 형식으로 표시됩니다.

이 구조에는 네 가지 수준이 있습니다.

  • Descriptive Flex 응용 프로그램

  • Descriptive Flex 테이블 응용 프로그램

  • Descriptive Flex 테이블

  • Descriptive Flex 열

각 수준마다 자세한 정보가 표시됩니다.

Objects 패널은 Application Object Library (FND) 형식으로 나타납니다.

주: 가변 설명은 한 번 작성되고 나면 찾기가 어렵습니다. 개발자에게 테이블 및 열에 기반을 둔 간단하면서도 정서적인 Descriptive flex 조회를 제공하려고 했습니다.


Descriptive Flex 응용 프로그램 세부 정보

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Descriptive Flex 응용 프로그램을 선택하는 경우 Details 패널은 선택한 Descriptive Flex 응용 프로그램의 일반 응용 프로그램 정보를 표시합니다.

속성 | 설명
Application ID | 내부 응용 프로그램 ID입니다.
Application Short Name | 응용 프로그램의 간단한 이름입니다.
Application Name | 응용 프로그램 이름입니다.
Application Description | 응용 프로그램의 전체 이름입니다.
Base Path | 응용 프로그램 소스의 기본 경로 이름입니다.
Creation Information |
Created Date | 응용 프로그램을 작성한 날짜입니다.
Created By | 응용 프로그램을 작성한 응용 프로그램 사용자입니다.
Last Updated Date | 응용 프로그램을 마지막으로 업데이트한 날짜입니다.
Last Updated By | 응용 프로그램을 마지막으로 업데이트한 응용 프로그램 사용자입니다.
Status and Version Information |
Install Status | 응용 프로그램의 설치 상태 - Installed(설치됨), shared install(설치 공유됨) 등...
Version | 설치된 모듈의 버전입니다.
Patch Level | 설치된 응용 프로그램의 패치 수준입니다.
Database Information |
Tablespace (Data) | 설치 중 사용되는 기본 테이블 공간입니다.
Tablespace (Index) | 설치 중 사용되는 기본 색인 테이블 공간입니다.
Tablespace (Temporary) | 설치 중 사용되는 기본 임시 테이블 공간입니다.
Oracle ID | 응용 프로그램이 설치된 Oracle 계정입니다.
Oracle User Name | Oracle 계정의 사용자 이름입니다.
Oracle User Description | Oracle 계정 사용자에 대한 설명입니다.


Descriptive Flex 테이블 응용 프로그램 세부 정보

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Descriptive Flex 응용 프로그램을 선택하는 경우 Details 패널은 선택한 Descriptive Flex 응용 프로그램의 일반 Flex 테이블 응용 프로그램 정보를 표시합니다.

속성 | 설명
Application ID | 내부 응용 프로그램 ID입니다.
Application Short Name | 응용 프로그램의 간단한 이름입니다.
Application Name | 응용 프로그램 이름입니다.
Application Description | 응용 프로그램의 전체 이름입니다.
Base Path | 응용 프로그램 소스의 기본 경로 이름입니다.
Creation Information |
Created Date | 응용 프로그램을 작성한 날짜입니다.
Created By | 응용 프로그램을 작성한 응용 프로그램 사용자입니다.
Last Updated Date | 응용 프로그램을 마지막으로 업데이트한 날짜입니다.
Last Updated By | 응용 프로그램을 마지막으로 업데이트한 응용 프로그램 사용자입니다.
Status and Version Information |
Install Status | 응용 프로그램의 설치 상태 - Installed(설치됨), shared install(설치 공유됨) 등...
Version | 설치된 모듈의 버전입니다.
Patch Level | 설치된 응용 프로그램의 패치 수준입니다.
Database Information |
Tablespace (Data) | 설치 중 사용되는 기본 테이블 공간입니다.
Tablespace (Index) | 설치 중 사용되는 기본 색인 테이블 공간입니다.
Tablespace (Temporary) | 설치 중 사용되는 기본 임시 테이블 공간입니다.
Oracle ID | 응용 프로그램이 설치된 Oracle 계정입니다.
Oracle User Name | Oracle 계정의 사용자 이름입니다.
Oracle User Description | Oracle 계정 사용자에 대한 설명입니다.


Descriptive Flex 테이블 세부 정보

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Objects 패널에서 Descriptive Flex 테이블을 선택하면 Details 패널에 모든 Descriptive Flex 열과 내용에 대한 정보가 표시됩니다.

이 정보는 두 그리드 영역으로 나뉩니다.

  • Table Columns - 정의된 모든 Descriptive Flex 열과 컨텍스트를 나열합니다.

  • Context Info - 선택한 Descriptive Flex 열과 컨텍스트에 대한 컨텍스트 정보를 나열합니다.

테이블 열

이 영역은 테이블에서 정의된 모든 Descriptive Flex 열과 컨텍스트를 나열합니다.

열 제목 | 설명
Column Name | 테이블의 열 이름입니다.
User Column Name | 세그먼트 이름입니다.
Flex Context Code | Descriptive Flex 필드 컨텍스트 코드입니다.
Flexfield Name | Descriptive Flex 필드 이름입니다.
Value Set ID | 내부 값 집합 ID입니다.
Value Set Name | 값 집합 이름입니다.

Context Info

선택한 Descriptive Flex 열 및 컨텍스트에 대한 컨텍스트 정보를 나열합니다.

열 제목 | 설명
Context Enabled | 컨텍스트의 활성화 여부를 나타냅니다.
Global Context | 컨텍스트가 전역 컨텍스트인지 여부를 나타냅니다.
Context Name | 컨텍스트 이름입니다.
Description | 컨텍스트에 대한 설명입니다.
Created By | 컨텍스트를 작성한 날짜입니다.
Creation Date | 컨텍스트를 작성한 응용 프로그램 사용자입니다.
Last Updated By | 컨텍스트를 마지막으로 업데이트한 날짜입니다.
Last Updated Date | 컨텍스트를 마지막으로 업데이트한 응용 프로그램 사용자입니다.


Descriptive Flex 열 세부 정보

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Descriptive Flex 열을 선택하면 Details 패널에 세 가지 수준의 정보가 표시됩니다.

  • Column Usage - 선택한 Descriptive Flex 열에 대한 모든 컨텍스트 및 값 집합 정보를 나열합니다.

  • Context Info - 선택한 Descriptive Flex 열 컨텍스트에 대한 컨텍스트 정보를 나열합니다.

  • Value Set Info - 선택한 Descriptive Flex 열 및 컨텍스트에 대한 값 집합 정보를 나열합니다.

Column Usage

선택한 Descriptive Flex 열에 대한 모든 컨텍스트 및 값 집합 정보를 나열합니다.

열 제목 | 설명
User Column Name | 사용자의 열 이름입니다.
Flex Context Code | Descriptive Flex 필드 컨텍스트 코드입니다.
Flex Name | Descriptive Flex 필드 이름입니다.
Column Seq | Attribute1과 같이 열에 대한 세그먼트 번호입니다.
Status | Descriptive Flex 세그먼트 활성화 여부를 나타냅니다.
Form Left Prompt | Flexfield 창에서 세그먼트 왼쪽에 표시되는 프롬프트입니다.
Form Above Prompt | Flexfield 창에서 세그먼트 위에 표시되는 프롬프트입니다.
Value Set | Required - 유효성 검사 필요 여부를 나타냅니다.
Value Set ID | Flex 필드 값 집합 식별자입니다.
Value Set Name | 전체 값 집합 이름입니다.
Security Enabled | 보안 필요 여부를 나타냅니다.
Displayed | 세그먼트 표시 여부를 나타냅니다.
Display Size | 세그먼트 표시 크기입니다.
Range Code | 범위 코드(High, Low 또는 Paired)를 나타냅니다.
Default Type | 기본값 유형입니다.
Default Value | 세그먼트의 기본값입니다.
SRW Param | Oracle Reports 매개 변수입니다.

Context Info

이 영역은 선택한 Descriptive Flex 열 컨텍스트에 대한 컨텍스트 정보를 나열합니다.

열 제목 | 설명
Context Enabled | 컨텍스트의 활성화 여부를 나타냅니다.
Global Context | 컨텍스트가 전역 컨텍스트인지 여부를 나타냅니다.
Context Name | 컨텍스트 이름입니다.
Description | 컨텍스트 설명입니다.
Created By | 컨텍스트를 작성한 날짜입니다.
Creation Date | 컨텍스트를 작성한 응용 프로그램 사용자입니다.
Last Updated By | 컨텍스트를 마지막으로 업데이트한 날짜입니다.
Last Updated Date | 컨텍스트를 마지막으로 업데이트한 응용 프로그램 사용자입니다.

Value Set Info

이 영역은 선택한 Descriptive Flex 열 및 컨텍스트에 대한 값 집합 정보를 나열합니다.

속성 | 설명
Description | 값 집합에 대한 설명입니다.
Value Set | Protected - 값 집합이 보호되어 있음을 의미합니다.
Security Rules Enabled | 값 집합 보안 규칙의 활성화 여부를 나타냅니다.
LOV Long list Enabled | LOV 긴 목록의 활성화 여부를 나타냅니다.
Format Type | 형식 유형입니다.
Maximum Size | 값 집합에서 값의 최대 크기입니다.
Number Precision | 숫자 항목의 정밀도입니다.
Numbers Only (0-9) | 값 집합에서 영숫자로 된 값을 사용할 수 있는지 여부를 나타냅니다.
Uppercase Only | 값 집합의 모든 값을 대문자로만 지정해야 하는지 여부를 나타냅니다.
Right Justify and Zero Fill Numbers | 값을 오른쪽에 맞추고 0으로 채워야 하는지 여부를 나타냅니다.
Minimum Value | 세그먼트의 최소 값입니다.
Maximum Value | 세그먼트의 최대 값입니다.
Validation Type | 세그먼트 검증 유형입니다.
Dependant Default Value | 종속 값 집합의 기본값입니다.
Dependant Default Value Description | 기본값에 대한 설명입니다.
Dependant Value Set ID | 종속 값 집합이 종속되어 있는 독립 값 집합 ID입니다.
Created By | 값 집합을 작성한 응용 프로그램 사용자입니다.
Creation Date | 값 집합을 작성한 날짜입니다.
Last Updated By | 값 집합을 마지막으로 업데이트한 응용 프로그램 사용자입니다.
Last Update Date | 값 집합을 마지막으로 업데이트한 날짜입니다.


Invalid Objects - Objects 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

TOAD for Oracle Schema Browser는 스키마와 개체 유형에 기반하여 모든 개체를 표시합니다. 개체가 표시될 때만 잘못된 개체를 볼 수 있습니다. Schema Browser에서 "새로운" 잘못된 개체를 식별하려면 잘못된 개체의 스키마 소유자와 개체 유형을 알아야 합니다.

E-Business 환경의 일반적인 문제 중 하나는 개체 간의 다양한 관계와 복잡성 및 많은 개체 수입니다. 개체가 어떤 이유로든 유효하지 않게 되는 경우가 많이 발생합니다. E-Business Suite 환경에서는 이러한 개체를 찾아내는 것이 중요합니다.

TOAD E-Business Suite 플러그 인의 잘못된 개체 함수는 스키마에서만 시작하는 모든 응용 프로그램의 잘못된 개체를 나열하고 지난 한 달 동안 개체가 유효하지 않게 된 경우를 강조표시합니다.

잘못된 개체를 트리 보기 또는 그리드 보기 형태로 표시할 수 있습니다.

트리 보기

Object 패널은 잘못된 개체를 찾기 위한 트리 보기 방법(기본값)을 제공합니다.

  • 수준 1 - 개체 소유자

  • 수준 2 - 개체 유형

  • 수준 3 - 개체

그룹 내 개체가 지난 한 달 동안에 유효하지 않게 된 경우를 명확하게 식별하기 위해 각각의 처음 두 수준 앞에 잘못된 개체 [image] 아이콘이 표시됩니다.

세 번째 수준의 항목은 지난 한 달 동안 유효하지 않게 된 실제 개체를 식별하기 위해 잘못된 개체 아이콘을 표시합니다.

예를 들면 다음과 같습니다.

위의 예는 스키마 APPS에서 소유하는 149개의 잘못된 개체가 있음을 표시합니다. 은 이 스키마 내에 지난 한 달 동안 유효하지 않게 된 하나 이상의 개체가 있음을 의미합니다.

개체 소유자를 확장하면 개체 유형이 표시됩니다.

Apps Schema 내에는 패키지 본문 78개와 트리거 6개를 비롯하여 최근의 몇 가지 잘못된 개체가 있습니다. 은 지난 한 달 동안 하나 이상의 트리거가 유효하지 않게 되었음을 의미합니다.

Trigger 노드를 확장하면 잘못된 개체가 모두 표시됩니다. 은 지난 한 달 동안 유효하지 않게 된 개체를 의미합니다.

그리드 형식

그리드 형식 [image] 단추를 누르면 잘못된 개체가 그리드 형식으로 표시됩니다. 이 형식에서는 지난 한 달 동안 유효하지 않게 되었음을 의미하는 잘못된 개체 아이콘이 개체 이름 앞에 표시됩니다.

열 이름 | 열 상태 | 설명
Name | 표시됨 | 잘못된 개체의 이름입니다.
Owner | 숨김 | 잘못된 개체의 스키마 소유자입니다.
Type | 숨김 | 개체 유형입니다.
Invalid since | 숨김 | 개체가 유효하지 않게 된 시점의 타임스탬프입니다.


Invalid Objects Details 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Invalid Objects Details 패널은 해당 개체에 대한 Toad for Oracle Schema Browser 페이지를 표시합니다. 자세한 내용은 개체를 선택한 후 Details 패널을 누르고 <F1>을 누릅니다. 또는 Schema Browser 도움말 파일에서 보려는 개체 유형에 대한 설명을 참조하십시오.


Key Flex Objects 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Key Flex를 선택하면 브라우저의 왼쪽(Objects 패널)에는 각 응용 프로그램 및 해당 Key Flex 필드가 계층 구조 형식으로 표시됩니다.

이 트리 구조에는 네 가지 수준이 있으며, 각 수준마다 Details 패널에 고유한 세부 정보가 표시됩니다.

  • 수준 1 - 응용 프로그램

  • 수준 2 - ID Flex

  • 수준 3 - Flex 구조

  • 수준 4 - Flex 세그먼트

트리 구조는 다음과 같이 표시됩니다.

수준 3(Flex 구조)의 [image] 기호는 Flex 구조가 비활성화되었음을 의미합니다.

수준 4(Flex 세그먼트)의 [image] 기호는 구조 내에서 Flex 세그먼트가 비활성화되었음을 의미합니다.


Key Flex - Application Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Applications Details 패널(브라우저 오른쪽)에는 선택한 응용 프로그램에 대한 다음과 같은 일반 정보가 표시됩니다.

속성 | 설명
Application ID | 내부 응용 프로그램 ID입니다.
Application Short Name | 응용 프로그램의 간단한 이름입니다.
Application Name | 응용 프로그램 이름입니다.
Application Description | 응용 프로그램의 전체 이름입니다.
Base Path | 응용 프로그램 소스의 기본 경로 이름입니다.
Creation Information |
Created Date | 응용 프로그램을 작성한 날짜입니다.
Created By | 응용 프로그램을 작성한 응용 프로그램 사용자입니다.
Last Updated Date | 응용 프로그램을 마지막으로 업데이트한 날짜입니다.
Last Updated By | 응용 프로그램을 마지막으로 업데이트한 응용 프로그램 사용자입니다.
Status and Version Information |
Install Status | 응용 프로그램의 설치 상태 - Installed(설치됨), shared install(설치 공유됨) 등.
Version | 설치된 모듈의 버전입니다.
Patch Level | 설치된 응용 프로그램의 패치 수준입니다.
Database Information |
Tablespace (Data) | 설치 중 사용되는 기본 테이블 공간입니다.
Tablespace (Index) | 설치 중 사용되는 기본 색인 테이블 공간입니다.
Tablespace (Temporary) | 설치 중 사용되는 기본 임시 테이블 공간입니다.
Oracle ID | 응용 프로그램이 설치된 Oracle 계정입니다.
Oracle User Name | Oracle 계정의 사용자 이름입니다.
Oracle User Description | Oracle 계정 사용자에 대한 설명입니다.


Key Flex - ID Flex Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

ID Flex Details 패널에는 선택한 ID Flex에 대한 일반 정보가 표시됩니다.

속성 | 설명
Flex Application ID | 내부 응용 프로그램 ID입니다.
Flex Application | 응용 프로그램의 간단한 이름입니다.
Flex Code | Key Flex 필드 코드입니다.
Flex Name | Key Flex 필드 구조 식별자입니다.
Description | Key Flex 필드 구조에 대한 설명입니다.
Table and Column Information |
Application Table Name | 조합 테이블의 이름입니다.
Application Table Type | 테이블 조합 유형(Generic/Specific)을 나타냅니다.
Set Defining Column Name | 테이블의 열 이름입니다.
General Information |
Allow Value Sets | ID 유형 값 집합을 허용합니다.
Dynamic Inserts Feasible | 동적 삽입을 허용합니다.
Indexed | 삽입을 수행하기 전에 단독 모드에서 코드 조합 테이블을 잠급니다.
Max Concatenation Length | 연결된 Flex 필드 조합의 최대 길이입니다.
Concatenation Warning Length | 연결된 세그먼트 길이가 이 값보다 크면 경고를 표시합니다.
Creation Information |
Created by | ID Flex를 작성한 날짜입니다.
Creation Date | Flex ID를 작성한 응용 프로그램 사용자입니다.
Last Updated by | Flex ID를 마지막으로 업데이트한 응용 프로그램 사용자입니다.
Last Update Date | Flex ID를 마지막으로 업데이트한 날짜입니다.


Key Flex - Flex Structure

Key Flex - Flex Structure Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Flex 구조를 선택하면 Flex Structure Details 패널에 다음 탭이 표시됩니다.

  • Info – 선택한 Flex 구조에 대한 일반 Flex 구조 정보를 표시합니다.

  • Segments – Flex 구조 내 Flex 세그먼트 목록을 표시합니다.


Key Flex - Flex Structure - Info 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Info 탭은 선택한 Flex 구조의 일반 Flex 구조 정보를 표시합니다.

속성 | 설명
Structure Application ID | 구조의 내부 응용 프로그램 ID입니다.
ID Flex Code | Key Flex 필드 코드입니다.
ID Flex Number | Key Flex 필드 구조 번호입니다.
ID Flex Structure Code | Key Flex 필드 구조입니다.
ID Flex User Structure View Name | Key Flex 필드 구조 보기 이름입니다.
Structure View Name | 사용자 구조 보기 이름입니다.
General Information |
Enabled | 구조 활성화 여부를 나타냅니다.
Freeze Flex field | Flex 필드 고정 여부를 나타냅니다.
Segment Separator | Flex 필드 세그먼트 구분 기호입니다.
Cross Segment Validation | 교차 유효성 검사 규칙을 통해 Flex 필드를 확인해야 하는지 여부를 나타냅니다.
Freeze Rollup Groups | Flex 필드 롤업 그룹의 고정 여부를 나타냅니다.
Dynamic Inserts Allowed | Flex 필드 조합을 동적으로 삽입할 수 있는지 여부를 나타냅니다.
Shorthand Aliases enabled | Flex 필드에 대한 줄임 별칭 활성화 여부를 나타냅니다.
Shorthand Alias Field Length | 줄임 별칭 표시 길이입니다.
Creation Information |
Created by | Flex 구조를 작성한 날짜입니다.
Creation Date | Flex 구조를 작성한 응용 프로그램 사용자입니다.
Last Updated by | Flex 구조를 마지막으로 업데이트한 응용 프로그램 사용자입니다.
Last Update Date | Flex 구조를 마지막으로 업데이트한 날짜입니다.


Key Flex - Flex Structure - Segment 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Segments 탭은 Flex 구조 내 Flex 세그먼트 목록을 표시합니다.

열 제목 | 설명
Segment Number | 세그먼트 순서 번호입니다.
Segment Name | Flex 세그먼트 이름입니다.
Application Column Name | Flex 필드 열 이름입니다.
Enabled | 세그먼트 활성화 여부를 나타냅니다.
Displayed | 세그먼트 표시 여부를 나타냅니다.
Indexed | 열을 인덱싱해야 하는지 여부를 나타냅니다.
Security | 보안 필요 여부를 나타냅니다.
Validation | 유효성 검사 필요 여부를 나타냅니다.


Key Flex - Flex Segment Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Flex 세그먼트를 선택하면 Details 패널에 다음 탭이 표시됩니다.

  • Info – 선택한 Flex 세그먼트에 대한 일반 Flex 세그먼트 정보를 표시합니다.

  • Value Set – 선택한 Flex 세그먼트에 대한 값 집합 정보를 표시합니다.


Key Flex - Flex Segment - Info 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

선택한 Flex 세그먼트에 대한 일반 Flex 세그먼트 정보를 표시합니다.

속성 | 설명
Segment Application ID | Flex 세그먼트 응용 프로그램 ID입니다.
Key Flex Field Code | Key Flex 필드 구조입니다.
Key Flex Field Structure Number | Key Flex 필드 구조 번호입니다.
Segment Number | 세그먼트 순서 번호입니다.
Segment Name | Flex 세그먼트 이름입니다.
Application Column Name | Flex 필드 열 이름입니다.
Enabled | 세그먼트 활성화 여부를 나타냅니다.
Displayed | 세그먼트 표시 여부를 나타냅니다.
Column Indexed | 열을 인덱싱해야 하는지 여부를 나타냅니다.
Security Enabled | 보안 필요 여부를 나타냅니다.
Validation |
Validation Required | 유효성 검사 필요 여부를 나타냅니다.
Flex Value Set ID | Flex 필드 값 집합 식별자입니다.
Flex Value Set Name | 전체 값 집합 이름입니다.
Description | 값 집합 설명입니다.
Default Type | 기본값 유형입니다.
Default Value | 세그먼트의 기본값입니다.
Range Code | 범위 코드(High, Low 또는 Paired)를 나타냅니다.
Size |
Display Size | 세그먼트 표시 크기입니다.
Max Description Length | 세그먼트의 최대 설명 크기입니다.
Concatenated Description Length | 연결된 Flex 필드 설명 크기입니다.
Prompts |
Form Above Prompt | Flexfield 창에서 세그먼트 위에 표시되는 프롬프트입니다.
Form Left Prompt | Flexfield 창에서 세그먼트 왼쪽에 표시되는 프롬프트입니다.
Runtime property Function | Flex 세그먼트의 런타임 속성 함수입니다.
Creation Information |
Created By | Flex 세그먼트를 작성한 날짜입니다.
Creation Date | Flex 세그먼트를 작성한 응용 프로그램 사용자입니다.
Last Updated By | Flex 세그먼트를 마지막으로 업데이트한 응용 프로그램 사용자입니다.
Last Update Date | Flex 세그먼트를 마지막으로 업데이트한 날짜입니다.


Key Flex - Flex Segment - Value Set 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Value Set 탭은 선택한 Flex 세그먼트에 대한 값 집합 정보를 표시합니다.

속성 | 설명
Flex Value Set ID | 내부 Flex 필드 값 집합 식별자입니다.
Flex Value Set Name | 값 집합 이름입니다.
Description | 값 집합에 대한 설명입니다.
Value Set Protected | 값 집합이 보호되어 있는지 여부를 나타냅니다.
Security Rules Enabled | 값 집합 보안 규칙의 활성화 여부를 나타냅니다.
LOV Long list Enabled | LOV 긴 목록의 활성화 여부를 나타냅니다.
Format |
Format Type | 형식 유형입니다.
Maximum Size | 값 집합에서 값의 최대 크기입니다.
Number Precision | 숫자 항목의 정밀도입니다.
Numbers Only (0-9) | 값 집합에서 영숫자로 된 값을 사용할 수 있는지 여부를 나타냅니다.
Uppercase Only | 값 집합의 모든 값을 대문자로만 지정해야 하는지 여부를 나타냅니다.
Right Justify and Zero Fill Numbers | 값을 오른쪽에 맞추고 0으로 채워야 하는지 여부를 나타냅니다.
Minimum Value | 세그먼트의 최소 값입니다.
Maximum Value | 세그먼트의 최대 값입니다.
Value Validation |
Validation Type | 세그먼트 검증 유형입니다.
Dependant Default Value | 종속 값 집합의 기본값입니다.
Dependant Default Value Description | 기본값에 대한 설명입니다.
Dependant Value Set ID | 종속 값 집합이 종속되어 있는 독립 값 집합 ID입니다.
Creation Information |
Created By | 값 집합을 작성한 날짜입니다.
Creation Date | 값 집합을 작성한 응용 프로그램 사용자입니다.
Last Updated By | 값 집합을 마지막으로 업데이트한 응용 프로그램 사용자입니다.
Last Update Date | 값 집합을 마지막으로 업데이트한 날짜입니다.


Lookups Object 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Oracle에서는 개별 기능 조회 테이블(예: GL_LOOKUPS)을 Applsys에서 소유하는 중앙 조회 테이블로 마이그레이션하는 프로세스를 진행하고 있습니다. 이 작업이 끝나면 기존 기능 모듈 조회 테이블을 대체하는 중앙 테이블에 기반을 둔 일련의 기능 수준 보기를 작성합니다. 이 TOAD 기능은 Applsys에서 소유하고 중앙 테이블에 기반을 둔 값만 표시하며 나머지 모듈 테이블의 값은 표시하지 않습니다.

주: 물리 테이블이 모두 다 중앙 보기로 변환되지 않습니다.

경우에 따라 물리 조회 테이블이 중앙 APPLSYS 조회 테이블에 중복됩니다.

브라우저의 Object 패널에 보기 이름과 조회 유형의 개수가 표시됩니다. 두 번째 수준의 노드는 조회 유형과 해당 유형의 조회 코드 개수를 표시합니다.

예

조회 유형 앞에 붙는 [image] 기호는 보기가 아직 실제로 존재하지 않음을 의미합니다. 없는 보기의 수는 다음 Oracle 릴리스에서는 줄어들 것입니다.

주: 기능 모듈에 대한 물리 조회 테이블이 없을 수도 있습니다.


Lookups Details 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Lookups Object 패널에서 노드를 선택하는 경우 Lookup View 또는 Lookup Type을 선택하게 됩니다. Lookup View와 Lookup Type은 각각 Details 패널에 조금 다른 정보를 표시합니다.

Lookup View

Lookup View를 선택하는 경우 Details 패널에서 Info 탭만 사용할 수 있습니다. 여기에 제공된 정보는 선택한 조회 유형에 대한 조회 보기의 일반 정보를 표시합니다.

속성 | 설명
View Owner | 보기의 스키마 소유자입니다.
View Name | 조회 보기의 이름입니다.
Database Object ID | 내부 데이터베이스 개체 ID입니다.
Created Date | 보기를 작성한 날짜입니다.
Last DDL Date | 보기를 마지막으로 업데이트했거나 다시 작성한 날짜입니다.
View Status | 보기의 현재 상태 – Valid / Invalid / Does not Exist
Time Stamp | 개체 데이터베이스 타임스탬프입니다.

Lookups Type

Lookup Type을 선택하는 경우 Details 패널에 다음 탭이 표시됩니다.

  • Info – 선택한 조회 유형에 대한 조회 유형의 일반 정보를 표시합니다.

  • Lookup Codes - 선택한 조회 유형의 조회 코드 및 의미를 나열합니다.

Info

Info 탭은 선택한 조회 유형에 대한 조회 유형의 일반 정보를 표시합니다.

속성 | 설명
Application ID | 내부 응용 프로그램 ID입니다.
Application | 응용 프로그램의 간단한 이름입니다.
Application Name | 응용 프로그램의 전체 이름입니다.
Lookup Type | 조회 유형 이름입니다.
Customization Level | 조회 유형 사용자 지정 수준입니다.
Creation Information |
Creation Date | 조회 유형을 작성한 날짜입니다.
Created By | 조회 유형을 작성한 응용 프로그램 사용자입니다.
Last Updated Date | 조회 유형을 마지막으로 업데이트한 날짜입니다.
Last Updated By | 조회 유형을 마지막으로 업데이트한 응용 프로그램 사용자입니다.
View Information |
View Appn ID | 조회 보기의 응용 프로그램 ID입니다.
View Application | 조회 보기의 응용 프로그램 이름입니다.
View Name | 조회 보기 이름입니다.
View Status | 보기의 현재 상태입니다.

Lookup Codes

Lookup Codes 탭은 선택한 조회 유형의 조회 코드 및 의미를 나열합니다.

열 제목 | 설명
Lookup Code | 조회 코드입니다.
Enabled | 조회 코드의 상태입니다.
Meaning | 조회 코드의 의미입니다.
Description | 조회 코드에 대한 설명입니다.
Start Date | 조회 코드가 활성화되었거나 활성화될 날짜입니다.
End Date | 조회 코드가 비활성화되었거나 비활성화될 날짜입니다.
Territory | 조회 코드 영역입니다.
Attribute Category | 조회 코드 특성 범주입니다.
Tag | 조회 코드 태그입니다.
Created By | 조회 코드를 작성한 날짜입니다.
Creation Date | 조회 코드를 작성한 응용 프로그램 사용자입니다.
Last Updated By | 조회 코드를 마지막으로 업데이트한 날짜입니다.
Last Updated Date | 조회 코드를 마지막으로 업데이트한 응용 프로그램 사용자입니다.


Menus - Object 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Menus 개체를 보려고 선택하는 경우 브라우저의 Object 패널(왼쪽)에 등록된 모든 응용 프로그램 메뉴가 다음 형식으로 표시됩니다.

R = 책임에 메뉴가 할당되어 있음을 의미합니다.

U = 하나 이상의 사용자에게 할당된 책임에 메뉴가 할당되어 있음을 의미합니다.

A = 한 명 이상의 사용자에게 할당된 책임에 메뉴가 할당되어 있으며, 지난 한 달 동안 해당 메뉴가 사용되었음을 의미합니다.

주: Sign-on 감사 수준은 표시할 “A” 표시기에 대한 책임으로 설정되어야 합니다.

표시할 수 있는 숨겨진 열도 있습니다.

특성 | 열 상태 | 설명
User Menu Name | 활성 | 사용자 메뉴 이름입니다.
Menu Name | 숨김 | 내부 메뉴 이름입니다.
Menu ID | 숨김 | 내부 메뉴 ID입니다.
Menu Type | 숨김 | 위에 표시된 메뉴 표시기( R – U – A )입니다.


Menus Details 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

메뉴를 선택하면 브라우저의 오른쪽(Objects 패널)은 다음 탭으로 구성됩니다.

  • Info – 선택한 응용 프로그램의 응용 프로그램 정보를 표시합니다.

  • Entries - 선택한 메뉴의 메뉴 항목을 나열합니다.

  • 기능 ID를 가진 메뉴 항목을 선택하면 그리드에 기능 정보가 표시됩니다.

  • Structure - 선택한 메뉴에 대한 메뉴 구조를 계층 구조 형식으로 표시합니다.

  • Responsibilities - 선택한 메뉴를 호출하는 책임을 나열합니다.

  • Users - 책임을 통해 메뉴에 액세스할 수 있는 사용자를 나열합니다.

  • Accessed - 지난 한 달 동안 책임을 통해 메뉴에 액세스한 사용자를 나열합니다.


Menus - Info 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Info 탭은 선택한 메뉴에 대한 일반적인 책임 정보를 표시합니다.

속성 | 설명
Menu ID | 내부 메뉴 ID입니다.
Menu Name | 메뉴 이름입니다.
User Menu Name | 사용자 메뉴 이름입니다.
Type | 메뉴 유형입니다.
Menu Creation Information |
Created By | 메뉴를 작성한 날짜입니다.
Creation Date | 메뉴를 작성한 응용 프로그램 사용자입니다.
Last Updated By | 메뉴를 마지막으로 업데이트한 응용 프로그램 사용자입니다.
Last Update Date | 메뉴를 마지막으로 업데이트한 날짜입니다.
User Menu Creation Information |
Created By | 메뉴 변환 정보를 작성한 날짜입니다.
Creation Date | 메뉴 변환 정보를 작성한 응용 프로그램 사용자입니다.
Last Updated By | 메뉴 변환 정보를 마지막으로 업데이트한 날짜입니다.
Last Update Date | 메뉴 변환 정보를 마지막으로 업데이트한 응용 프로그램 사용자입니다.


Menus - Entries 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Entries 탭은 두 부분으로 나뉩니다. 위쪽 영역은 선택한 메뉴에 대한 메뉴 항목을 나열하며 아래쪽 영역은 선택한 메뉴 항목에 대한 기능 정보를 표시합니다.

위쪽 영역

위쪽 영역은 선택한 메뉴에 대한 메뉴 항목을 표시합니다.

열 제목 | 설명
Sequence | 메뉴 입력 순서입니다.
Prompt | 메뉴 프롬프트입니다.
Description | 메뉴에 대한 설명입니다.
Sub Menu ID | 하위 메뉴 ID입니다.
Sub Menu Name | 하위 메뉴 이름입니다.
Function ID | 메뉴 항목이 호출하는 기능 ID입니다.
Grant | 이 기능이 사용자에 대해 자동으로 활성화됨을 나타냅니다. 이 기능이 활성화되지 않으면 추가 데이터 보안 규칙을 사용하여 기능을 활성화해야 합니다.
Created By | 메뉴 항목을 작성한 날짜입니다.
Creation Date | 메뉴 항목을 작성한 응용 프로그램 사용자입니다.
Last Updated By | 메뉴 항목을 마지막으로 업데이트한 날짜입니다.
Last Update Date | 메뉴 항목을 마지막으로 업데이트한 응용 프로그램 사용자입니다.

아래쪽 영역

기능 ID를 가진 메뉴 항목을 선택하면 아래쪽 영역의 그리드에 기능 정보가 표시됩니다.

속성 | 설명
Function ID | 기능 ID입니다.
Function Name | 기능 이름입니다.
User Function Name | 기능에 대한 설명입니다.
Form Application ID | 양식 응용 프로그램 ID입니다.
Form Application | 양식 응용 프로그램에 대한 간단한 이름입니다.
Form ID | 양식 ID입니다.
Form Name (Internal) | 내부 양식 이름입니다.
User Form Name | 전체 양식 이름입니다.
Parameters | 양식 매개 변수입니다.
Type | 기능 유형입니다.
Web Host Name | 웹 서버 호스트의 IP 또는 별칭 - 기본값은 마지막으로 사용한 IP 또는 별칭입니다.
Web Agent Name | 웹 에이전트 이름 – 기본값은 마지막으로 사용한 이름입니다.
Web HTML | URL을 호출하여 기능을 활성화합니다.


Menus - Structure 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Structure 탭은 선택한 메뉴에 대한 메뉴 구조를 계층 구조 형식으로 표시합니다.


Menus - Responsibilities 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Responsibilities 탭은 선택한 메뉴를 호출하는 책임을 나열합니다.

열 제목 | 설명
Resp Appn ID | 책임 응용 프로그램 ID입니다.
Resp Appn | 책임 응용 프로그램에 대한 간단한 설명입니다.
Resp ID | 내부 책임 참조 번호입니다.
Responsibility Name | 책임의 전체 이름입니다.
Resp Start Date | 책임을 사용할 수 있게 된 날짜입니다.
Resp End Date | 책임 사용이 중지되었거나 중지될 날짜입니다.


Menus - Users 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Users 탭은 책임을 통해 메뉴에 액세스할 수 있는 사용자를 나열합니다.

열 제목 | 설명
User ID | 응용 프로그램 사용자 계정의 고유한 내부 식별자입니다.
User Name | 응용 프로그램 사용자의 로그인 이름입니다.
Description | 사용자에 대한 설명입니다.
User Start Date | 사용자 계정이 활성화된 날짜 및 시간입니다.
User End Date | 계정이 종료되었거나 종료될 날짜입니다.
Resp Appn ID | 책임 응용 프로그램 ID입니다.
Resp Appn | 책임 응용 프로그램에 대한 간단한 설명입니다.
Resp ID | 내부 책임 참조 번호입니다.
Responsibility Name | 책임의 전체 이름입니다.
Resp Start Date | 책임을 사용할 수 있게 된 날짜입니다.
Resp End Date | 책임 사용이 중지되었거나 중지될 날짜입니다.


Menus - Accessed 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Accessed 탭은 지난 한 달 동안 책임을 통해 메뉴에 액세스한 사용자를 표시합니다.

열 제목 | 설명
User ID | 응용 프로그램 사용자 계정의 고유한 내부 식별자입니다.
User Name | 응용 프로그램 사용자의 로그인 이름입니다.
Description | 사용자에 대한 설명입니다.
Responsibility | 책임의 전체 이름입니다.
Accesses | 지난 한 달 동안 사용자가 책임에 액세스한 횟수입니다.


Patches Objects 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

브라우저의 Objects 패널에는 대상 시스템과 적용된 날짜 및 시간이 있는 각 패치 이름이 표시됩니다. 격리된 패치 이름은 상대적으로 의미가 없기 때문에 이 정보가 이러한 방식으로 제공됩니다.

주: 패치가 실패한 경우 패치가 몇 번 적용되었을 수도 있습니다. 따라서 날짜 및 시간을 고려해야 합니다.

또한 Objects 패널에는 숨겨져 있는 추가 열 4개가 있습니다.

  • Patch ID

  • Patch Name

  • App Name

  • Patch Date

주: 패치의 기본값은 패치 이름 : 응용 프로그램 이름(패치 날짜)의 조합입니다.

숨겨진 열을 보려면

  • Objects 패널의 열 제목을 마우스 오른쪽 단추로 누른 다음 표시할 열을 선택합니다.

주: 모든 패치가 다 응용 프로그램 패치 테이블에 기록되지는 않으며, 일부 11i 이전 릴리스 및 응용 프로그램 패치 테이블을 인식하지 못하는 일부 이전 패치도 이에 포함됩니다.


Patches Details 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

패치가 선택될 때 Details 패널 브라우저에 정보가 표시됩니다.

  • Info – 선택한 패치에 대한 일반 정보를 표시합니다.

  • Patch Details - 선택한 패치에 대한 “Patch Bugs”를 나열합니다.

  • Patch Bug Details - 선택한 버그에 대한 “Patch Bug Details”를 나열합니다.


eBiz_Patches Info 탭

Patches Info 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Info 탭은 선택한 패치에 대한 일반적인 정보를 나열합니다. 표시 영역은 세 부분으로 나뉩니다.

Applied Patches

열 제목 | 설명
Database Name | 패치가 적용된 데이터베이스의 SID입니다.
Server | 패치가 적용된 서버입니다.
Name | 패치 번호입니다.
Patch ID | 응용 프로그램 패치의 내부 ID입니다.
Type | 패치가 단일 패치인지 패치 집합인지를 나타냅니다.
Rapid Install | Rapid Install 데이터베이스 작성 중에 Oracle에서 적용한 패치임을 나타냅니다(Yes/No).
Source | 패치가 applptch.txt 파일에서 업로드되었는지 또는 패치 드라이버(DRV) 파일 적용 결과로 작성되었는지를 나타냅니다.
Driver Name | 패치 드라이버의 이름입니다.
Top | 패치가 있는 폴더입니다.
Actions | Autopatch를 호출한 경우 "options"의 인수입니다.
Start Date | Autopatch에서 패치 적용을 시작한 날짜 및 시간입니다.
End Date | Autopatch에서 패치 적용을 완료한 날짜 및 시간입니다.
Patch Run time | Autopatch에서 패치를 적용하는 데 소요된 시간(HH:MM:SS)입니다.
Patch Run ID | 패치 실행 고유 ID입니다.
Platform | 패치가 생성된 플랫폼입니다.
Node | 패치가 적용된 서버가 동시 처리를 실행하는지 여부를 나타냅니다(Yes/No).
Admin | 패치가 적용된 서버가 관리 작업을 실행하는지 여부를 나타냅니다(Yes/No).
Forms | 패치가 적용된 서버가 양식 서버를 실행하는지 여부를 나타냅니다(Yes/No).
Web | 패치가 적용된 서버가 응용 프로그램 서버를 실행하는지 여부를 나타냅니다(Yes/No).
Imported From | 이 행을 가져온 데이터베이스의 DB ORACLE_SID입니다.
Imported ID | 소스 데이터베이스의 패치 실행 ID입니다.

Patch Details

이 영역은 선택한 패치에 대한 패치 버그를 나열합니다.

열 제목 | 설명
Bug Number | 버그 번호입니다.
Orig Bug Number | 버그의 원래 번호입니다.
Patch Run Bug ID | 패치 실행 버그 ID입니다.
Bug Status | 적용된 버그 수정의 상태입니다.
Applied | Autopatch에서 이 버그 수정을 적용하려 했는지 여부를 나타냅니다(Yes/No).
Reason Not Applied | 버그 수정이 적용되지 않은 이유입니다.
Success | 패치 적용의 성공 여부를 나타냅니다(Yes/No).
Failure Comments | 패치 적용 실패에 관한 설명입니다.

Patch Bug Details

이 영역은 Patch Details 영역에서 선택한 버그에 대한 모든 Patch Bug Details를 나열합니다.

열 제목 | 설명
Orig Bug Number | 버그의 원래 번호입니다.
Action Code | 패치 드라이버의 작업 코드입니다.
Action Phase | 패치 드라이버에 있는 작업 문의 단계 구성 요소입니다.
App Short Name | 응용 프로그램의 간단한 이름입니다.
Sub Directory | 파일이 있는 하위 디렉토리입니다.
File Name | 파일의 이름입니다.
Version | 구성 요소의 버전입니다.


Printers Objects 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Printers Objects 패널은 프린터 이름별로 등록된 모든 프린터를 나열합니다.

또한 Printer Type 열이 숨겨져 있습니다.

숨겨진 열을 보려면

  • Objects 패널의 열 제목을 마우스 오른쪽 단추로 누른 다음 표시할 열을 선택합니다.


Printers Details 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Printers Details 패널은 다음 탭으로 구성됩니다.

  • Info – 선택한 프로파일 옵션에 대한 전체 프로파일 옵션 정보를 표시합니다.

  • Styles - 선택한 프린터에 대한 모든 인쇄 등록 스타일을 나열합니다.

  • 선택한 스타일에 대한 드라이버 정보 – 수준 2

  • Programs - 선택한 프린터가 동시 프로그램 수준에 설정되어 있는 동시 프로그램을 나열합니다.

  • Usage - 선택한 프린터로 인쇄 요청을 보낸 사용자를 나열합니다.

  • Concurrent Programs for the Selected User sent to the Printer - 선택한 사용자가 선택한 프린터로 전송한 모든 동시 프로그램을 나열합니다.

  • Profile Options - 프로파일 옵션 "Printer"를 통해 선택한 프린터가 할당된 응용 프로그램, 책임 및 사용자를 나열합니다.


Printers - Info 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

선택한 프로파일 옵션에 대한 계정 정보를 표시합니다.

속성 | 설명
Printer Name | 프린터 이름입니다.
Description | 프린터에 대한 설명입니다.
Printer Type | 프린터 유형입니다.
Type Description | 프린터 유형에 대한 설명입니다.
Reset String | 프린터를 재설정하기 위해 프린터로 보낸 문자열입니다.


Printers - Styles 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Styles 탭은 두 영역으로 나뉩니다. 위쪽 영역에는 선택한 프린터에 대한 모든 인쇄 등록 스타일이 나열되고 아래쪽 영역에는 위쪽 영역에서 선택한 스타일에 대한 드라이버 정보가 표시됩니다.

위쪽 영역

위쪽 영역에는 선택한 프린터에 대한 모든 인쇄 등록 스타일이 나열됩니다.

열 제목 | 설명
Style | 프린터 스타일입니다.
Style Name | 프린터 스타일의 전체 이름입니다.
Driver | 프린터 드라이버입니다.
Description | 프린터 드라이버 설명입니다.
Orientation | 페이지 방향입니다.
Width | 페이지 너비입니다.
Length | 페이지 길이입니다.
SRW Driver | Oracle Reports 프린터 드라이버의 이름입니다.

아래쪽 영역

아래쪽 영역에는 선택한 프린터 스타일의 프린터 드라이버 정보가 나열됩니다.

열 제목 | 설명
Printer Driver Name | 프린터 드라이버의 이름입니다.
User Printer Driver Name | 프린터 드라이버의 전체 이름입니다.
Platform | 드라이버 플랫폼(선택 사항)입니다.
Driver Method Code | 드라이버 호출 방법입니다.
Header | 페이지 제목을 숨깁니다.
Spool | 드라이버에서 고유의 스풀 파일을 작성하는지 여부를 지정합니다.
Stdin | 프린터 드라이버에서 표준 입력을 사용합니다.
Description | 드라이버에 대한 설명입니다.
Command Name | 드라이버에서 호출해야 하는 프로그램의 이름입니다.
Arguments | 동시 관리자 인쇄 인수입니다.
Initialization | 프린터를 초기화하는 데 사용되는 문자열입니다.
Reset String | 프린터를 다시 설정하는 데 사용되는 문자열입니다.
Attribute Category | 특성 범주입니다.


Printers - Programs 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

이 탭은 선택한 프린터가 동시 프로그램 수준에 설정되어 있는 동시 프로그램을 나열합니다.

열 제목 | 설명
Appn ID | 내부 응용 프로그램 ID입니다.
Application | 응용 프로그램의 간단한 이름입니다.
Program ID | 동시 프로그램 ID입니다.
Program Name (Internal) | 프로그램의 간단한 이름입니다.
Program Name | 프로그램의 전체 이름입니다.
Program Status | 프로그램의 활성화 여부를 나타냅니다.
Print? | 출력을 인쇄해야 하는지 여부를 나타냅니다.
Required Style | 프로그램에 인쇄 스타일이 필수적인지 여부를 나타냅니다.
Output Print Style | 출력의 인쇄 스타일입니다.
Min Width | 최소 열 개수입니다.
Min Length | 최소 행 개수입니다.


Printers - Usage 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

위쪽 영역

위쪽 영역에서 이 탭은 선택한 프린터로 인쇄 요청을 보낸 사용자를 나열합니다.

열 제목 | 설명
User ID | 각 응용 프로그램 사용자 계정의 고유한 내부 식별자입니다.
User Name | 사용자 계정 이름입니다.
Description | 사용자에 대한 설명입니다.
E-mail Address | 사용자의 전자 메일 주소입니다.
Total Requests | 프린터로 보낸 총 요청 수입니다.
Total Copies | 프린터로 보낸 총 매수입니다.

아래쪽 영역

아래쪽 그리드에는 선택한 사용자가 선택한 프린터로 보낸 모든 동시 프로그램이 나열됩니다.

열 제목 | 설명
Request ID | 동시 요청 ID입니다.
Program Appn ID | 내부 응용 프로그램 ID입니다.
Application | 응용 프로그램의 간단한 이름입니다.
Program ID | 동시 프로그램 ID입니다.
Program Name (Internal) | 프로그램의 간단한 이름입니다.
Program Name | 프로그램의 전체 이름입니다.
Completion Date | 요청이 완료된 날짜 및 시간입니다.
Completion Status | 요청의 완료 상태입니다.
# of Copies | 프린터로 보낸 매수입니다.
Argument Text | 요청의 전체 인수 텍스트입니다.


Printers - Profile Options 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

이 탭은 프로파일 옵션 "Printer"를 통해 선택한 프린터가 할당된 응용 프로그램, 책임 및 사용자를 나열합니다.

열 제목 | 설명
Option Level | 응용 프로그램 / 책임 / 사용자입니다.
Level Value | 프로파일 옵션 값입니다.
Last Updated Date | 프로파일 옵션을 마지막으로 업데이트한 날짜입니다.
Last Updated By | 프로파일 옵션을 마지막으로 업데이트한 응용 프로그램 사용자입니다.


Profile Options Objects 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

프로파일 옵션 개체가 프로파일 옵션 이름 순으로 나열됩니다.

표시할 수 있는 숨겨진 열이 있습니다.

특성 열 | 상태 | 설명
Profile Option Name | 활성 | 응용 프로그램 프로파일 옵션 정의 화면에 표시되는 프로파일 옵션의 전체 이름입니다.
Option ID | 숨김 | 프로파일 옵션 ID입니다.
App ID | 숨김 | 프로파일 옵션과 관련된 응용 프로그램 ID입니다.
Apps Levels | 숨김 | 프로파일 옵션 수가 응용 프로그램 수준에서 변경됩니다.
Resp Levels | 숨김 | 프로파일 옵션 수가 책임 수준에서 변경됩니다.
User Levels | 숨김 | 프로파일 옵션 수가 사용자 수준에서 변경됩니다.

예를 들어 유지 관리를 위해 프린터를 오프라인 상태로 설정하려고 합니다. 프로파일 옵션 Printer를 선택합니다. 이제 Details 패널 그리드에 프린터 유지 관리가 적용될 모든 응용 프로그램, 책임 및 사용자가 나열됩니다.

프로파일 옵션의 우선 순위는 User – Responsibility – Application – Site 순입니다. 예를 들어 사용자 수준에서 설정된 프로파일 옵션이 다른 모든 수준보다 우선합니다.


Profile Options Details 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Profile Options Details 패널은 다음 탭으로 구성됩니다.

  • Info – 선택한 프로파일 옵션에 대한 전체 프로파일 옵션 정보를 표시합니다.

  • Application - 선택한 프로파일 옵션의 응용 프로그램 수준에서 설정된 모든 프로파일 옵션을 나열합니다.

  • Reponsibility - 선택한 프로파일 옵션의 책임 수준에서 설정된 모든 프로파일 옵션을 나열합니다.

  • User - 선택한 프로파일 옵션의 사용자 수준에서 설정된 모든 프로파일 옵션을 나열합니다.

주: 프로파일 옵션 수준과 관계 없이 프로파일 옵션을 선택하면 프로파일 옵션 사이트 값이 Details 패널 캡션 영역에 표시됩니다.


Profile Options - Info 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Info 탭은 선택한 프로파일 옵션에 대한 계정 정보를 표시합니다.

속성 | 설명
Application ID | 프로파일 옵션 응용 프로그램 ID입니다.
Application Short Name | 프로파일 옵션 응용 프로그램의 간단한 이름입니다.
Application Name | 프로파일 옵션 응용 프로그램의 전체 이름입니다.
Profile Option ID | 프로파일 옵션 ID입니다.
Profile Option Name | 내부 프로파일 옵션 이름입니다.
User Profile Option Name | 사용자 프로파일 옵션 이름입니다.
Start Date | 프로파일 옵션이 유효한 시작 날짜입니다.
End Date | 프로파일 옵션이 유효한 종료 날짜입니다.
Option Status | 프로파일 옵션의 현재 상태(Active / Inactive)입니다.
Update Options |
Write Allowed | 프로파일 옵션을 모든 수준에서 쓰기 활성화했는지 여부를 나타냅니다.
Read Allowed | 프로파일 옵션을 모든 수준에서 읽기 활성화했는지 여부를 나타냅니다.
User Changeable | 프로파일 옵션을 모든 수준에서 변경할 수 있는지 여부를 나타냅니다.
Site Level Enabled | 프로파일 옵션을 사이트 수준에서 활성화했는지 여부를 나타냅니다.
Site Update Allowed | 프로파일 옵션을 사이트 수준에서 업데이트할 수 있는지 여부를 나타냅니다.
Application Level Enabled | 프로파일 옵션을 응용 프로그램 수준에서 활성화했는지 여부를 나타냅니다.
Application Level Update Allowed | 프로파일 옵션을 응용 프로그램 수준에서 업데이트할 수 있는지 여부를 나타냅니다.
Responsibility Level Enabled | 프로파일 옵션을 책임 수준에서 활성화했는지 여부를 나타냅니다.
Responsibility Level Update Allowed | 프로파일 옵션을 책임 수준에서 업데이트할 수 있는지 여부를 나타냅니다.
User Level Enabled | 프로파일 옵션을 사용자 수준에서 활성화했는지 여부를 나타냅니다.
User Level Update Allowed | 프로파일 옵션을 사용자 수준에서 업데이트할 수 있는지 여부를 나타냅니다.
Creation Information |
Creation Date | 프로파일 옵션을 작성한 날짜입니다.
Created By | 프로파일 옵션을 작성한 응용 프로그램 사용자입니다.
Last Updated Date | 프로파일 옵션을 마지막으로 업데이트한 날짜입니다.
Last Updated By | 프로파일 옵션을 마지막으로 업데이트한 응용 프로그램 사용자입니다.
SQL Validation |
SQL Validation Code | 프로파일 옵션 값을 확인하는 데 사용되는 SQL 코드입니다.


Profile Options - Application 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Application 탭은 선택한 프로파일 옵션의 응용 프로그램 수준에서 설정된 모든 프로파일 옵션을 나열합니다.

열 제목 | 설명
Application Name | 프로파일 옵션과 관련된 전체 응용 프로그램 이름입니다.
Option Value | 프로파일 옵션 값입니다.
Last Updated Date | 프로파일 옵션을 마지막으로 업데이트한 날짜입니다.
Last Updated By | 프로파일 옵션을 마지막으로 업데이트한 응용 프로그램 사용자입니다.


Profile Options - Responsibility 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Responsibility 탭은 선택한 프로파일 옵션의 책임 수준에서 설정된 모든 프로파일 옵션을 나열합니다.

열 제목 | 설명
Responsibility Name | 프로파일 옵션과 관련된 전체 책임 이름입니다.
Option Value | 프로파일 옵션 값입니다.
Last Updated Date | 프로파일 옵션을 마지막으로 업데이트한 날짜입니다.
Last Updated By | 프로파일 옵션을 마지막으로 업데이트한 응용 프로그램 사용자입니다.


Profile Options - User 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

User 탭은 선택한 프로파일 옵션의 사용자 수준에서 설정된 모든 프로파일 옵션을 나열합니다.

열 제목 | 설명
User Name | 응용 프로그램 사용자 이름입니다.
Description | 응용 프로그램 사용자에 대한 설명입니다.
Option Value | 프로파일 옵션 값입니다.
Last Updated Date | 프로파일 옵션을 마지막으로 업데이트한 날짜입니다.
Last Updated By | 프로파일 옵션을 마지막으로 업데이트한 응용 프로그램 사용자입니다.


Request Sets Object 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

요청 집합을 선택하면 브라우저의 Objects 창(왼쪽)에 각 요청 집합과 단계 및 프로그램이 계층 구조 형식으로 표시됩니다.

이 구조에는 세 가지 수준이 있습니다.

  • 요청 집합

  • 요청 집합 단계

  • 동시 프로그램

주: 응용 프로그램 모듈 내에서 쉽게 정렬할 수 있도록 응용 프로그램의 간단한 이름이 요청 집합 이름에 추가되었습니다.

트리 구조는 다음과 같이 표시됩니다.

기호의 동시 프로그램 수준은 프로그램이 해당 프로그램 수준에서 비활성화되었음을 의미합니다.


Request Set - Request Set Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Objects 패널에서 요청 집합을 선택하면 Details 패널(오른쪽)에 다음 탭에 대한 정보가 표시됩니다.

  • Info – 선택한 요청 집합에 대한 응용 프로그램 정보를 표시합니다.

  • Requests - 선택한 요청 집합에 대한 모든 요청 집합 실행을 나열합니다.


Request Set - Request Set - Info 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Info 탭은 선택한 요청 집합에 대한 일반적인 응용 프로그램 정보를 표시합니다.

속성 | 값
Appn ID | 내부 응용 프로그램 ID입니다.
Application | 응용 프로그램의 간단한 이름입니다.
Application Name | 응용 프로그램 이름입니다.
Request Set ID | 내부 요청 집합 ID입니다.
Request Set Name (Internal) | 요청 집합 내부 이름입니다.
Request Set Name | 전체 요청 집합 이름입니다.
Description | 요청 집합입니다.
Set Information |
Owner | 요청 집합을 소유하는 응용 프로그램 사용자 계정입니다.
Start Date | 요청 집합을 사용할 수 있게 되었거나 사용할 수 있게 될 날짜입니다.
End Date | 요청 집합을 사용할 수 없게 되었거나 사용할 수 없게 될 날짜입니다.
Start Stage | 요청 집합 시작 단계 ID입니다.
Start Stage Name | 시작 단계의 전체 이름입니다.
Allow Constraints | 비호환성을 허용하는지 여부를 나타냅니다.
Print Together | 집합이 완료된 후 인쇄가 실행되는지 여부를 나타냅니다.
Creation Information |
Created By | 요청 집합을 작성한 날짜입니다.
Created Date | 요청 집합을 작성한 응용 프로그램 사용자입니다.
Last Updated By | 요청 집합을 마지막으로 업데이트한 날짜입니다.
Last Update Date | 요청 집합을 마지막으로 업데이트한 응용 프로그램 사용자입니다.


Request Set - Request Set - Requests 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Requests 탭은 선택한 요청 집합에 대한 모든 요청 집합 실행을 나열합니다.

열 제목 | 설명
Request ID | 동시 요청 ID입니다.
User Name | 요청을 전송한 사용자입니다.
Description | 사용자에 대한 설명입니다.
Req Start Date | 요청에 대한 실행 요청을 받은 날짜 및 시간입니다.
Actual Start Date | 요청 처리가 시작된 날짜 및 시간입니다.
Completed Date | 요청 처리가 완료된 날짜 및 시간입니다.
Pending | 요청이 대기 중 상태로 있던 총 시간(HH:MM:SS)입니다.
Running | 요청에 대한 총 실행 시간(HH:MM:SS)입니다.
Completion Status | 요청의 완료 상태입니다.
Completion Text | 요청에 대한 완료 텍스트입니다.


Request Set - Request Set Stage Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

요청 집합 단계를 선택하면 Details 패널(오른쪽)에 다음 탭이 표시됩니다.

  • Info - 선택한 요청 집합에 대한 응용 프로그램 정보를 표시합니다.

  • Programs - 요청 집합 단계를 구성하는 모든 동시 프로그램을 나열합니다.


Request Set - Request Set Stage - Info 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Info 탭은 선택한 요청 집합에 대한 일반적인 응용 프로그램 정보를 표시합니다.

속성 | 설명
Display Seq | 요청 집합 표시 순서 번호입니다.
Request Set Application ID |
Request Set ID | 상위 요청 집합 ID입니다.
Request Set Stage ID | 요청 집합 단계 ID입니다.
Stage Name | 요청 집합 단계 내부 이름입니다.
User Stage Name | 전체 요청 집합 단계 이름입니다.
Description | 전체 요청 집합 단계에 대한 설명입니다.
Stage Information |
Critical | 중요 단계인지 여부를 나타냅니다.
Allow Constraints | 비호환성을 허용하는지 여부를 나타냅니다.
Stage Links |
Success Stage ID | 성공 시 처리할 요청 집합 단계 ID입니다.
Success Stage Name | 성공 시 처리할 전체 요청 집합 단계 이름입니다.
Warning Stage ID | 경고 시 처리할 요청 집합 단계 ID입니다.
Warning Stage Name | 경고 시 처리할 전체 요청 집합 단계 이름입니다.
Error Stage ID | 오류 시 처리할 요청 집합 단계 ID입니다.
Error Stage Name | 오류 시 처리할 전체 요청 집합 단계 이름입니다.
Creation Information |
Created By | 요청 집합 단계를 작성한 응용 프로그램 사용자입니다.
Creation Date | 요청 집합을 작성한 날짜입니다.
Last Updated By | 요청 집합 단계를 마지막으로 업데이트한 응용 프로그램 사용자입니다.
Last Updated Date | 요청 집합 단계를 마지막으로 업데이트한 날짜입니다.


Request Set - Request Set Stage - Programs 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Programs 탭은 요청 집합 단계를 구성하는 모든 동시 프로그램을 나열합니다.

열 제목 | 설명
Display Seq | 프로그램 실행 순서 번호입니다.
Appn ID | 내부 프로그램의 응용 프로그램 ID입니다.
Prog ID | 내부 프로그램 ID입니다.
Application | 프로그램 응용 프로그램의 간단한 이름입니다.
Program Name (Internal) | 프로그램의 간단한 이름입니다.
Program Name | 프로그램의 전체 이름입니다.
Status | 동시 프로그램의 활성화 여부를 나타냅니다.
Critical | 중요 단계인지 여부를 나타냅니다.
Printer | 집합 단계에 할당된 프린터입니다.
Print Style | 집합 단계에 할당된 인쇄 스타일입니다.
Save Output | 출력을 저장해야 하는지 여부를 나타냅니다.


Request Set - Concurrent Program Details

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

동시 프로그램을 선택하면 RHS 브라우저가 다음 탭으로 구성됩니다.

  • Info – 선택한 요청 집합 프로그램에 대한 프로그램 정보를 표시합니다.

  • Parameters - 선택한 요청 집합 프로그램에 대한 모든 런타임 매개 변수(있는 경우)를 나열합니다.


Request Set - Concurrent Program - Info 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Info 탭은 선택한 요청 집합 프로그램에 대한 프로그램 정보를 표시합니다.

속성 | 값
Set Application ID | 요청 집합 응용 프로그램 ID입니다.
Set Application | 요청 집합 응용 프로그램입니다.
Set ID | 요청 집합 내부 ID입니다.
Set Stage ID | 상위 요청 집합 ID입니다.
Set Program ID | 요청 집합 단계 ID입니다.
Set Program Sequence | 집합 내 프로그램의 순서입니다.
Program Information |
Program Application ID | 내부 프로그램의 응용 프로그램 ID입니다.
Program Application | 응용 프로그램의 간단한 이름입니다.
Program ID | 내부 프로그램 ID입니다.
Program Name (Internal) | 프로그램의 간단한 이름입니다.
Program Name | 프로그램의 전체 이름입니다.
Status | 동시 프로그램의 활성화 여부를 나타냅니다.
Critical | 집합에서 중요 프로그램인지 여부를 나타냅니다.
Printer Information |
Printer | 프로그램에 할당된 프린터입니다.
Printer Style | 출력의 인쇄 스타일입니다.
Save Output | 출력을 파일에 저장할지 여부를 나타냅니다.
Creation Information |
Created by | 요청 집합 프로그램을 작성한 날짜입니다.
Creation Date | 요청 집합 프로그램을 작성한 응용 프로그램 사용자입니다.
Last Updated By | 요청 집합 프로그램을 마지막으로 업데이트한 날짜입니다.
Last Updated Date | 요청 집합 프로그램을 마지막으로 업데이트한 응용 프로그램 사용자입니다.


Request Set - Concurrent Program Details - Parameter 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Parameters 탭은 선택한 요청 집합 프로그램에 대한 모든 런타임 매개 변수(있는 경우)를 나열합니다.

열 제목 | 설명
Appn ID | 내부 응용 프로그램 ID입니다.
Desc Flex Name | Descriptive Flex 이름입니다.
Desc Flex Context Code | Descriptive Flex 구조 이름입니다.
Column Seq Number | Descriptive Flex 순서 번호입니다.
Appn Column Name | Descriptive Flex 세그먼트 이름입니다.
User Column Name | 전체 열 이름입니다.
Description | 열에 대한 설명입니다.
Enabled | Flex 필드 활성화 여부를 나타냅니다.
표시 | 세그먼트 표시 여부를 나타냅니다.
Max Description Len | Flex 필드 창에서 세그먼트 값 설명의 최대 크기입니다.
Value Set ID | Flex 필드 값 집합 ID입니다.
Value Set Name | Flex 필드 값 집합 이름입니다.
Default Type | 참조 필드의 기본 유형입니다.
Default Value | 참조 필드의 기본값입니다.


Users Objects 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

개체 정보는 다음 형식으로 표시됩니다.

상태 코드 - 사용자 이름

상태는 다음과 같이 정의됩니다.

또한 표시할 수 있는 몇 개의 숨겨진 열이 있습니다. 사용할 수 있는 열은 다음과 같습니다.

특성 | 열 상태 | 설명
Status Code | 활성 | Null – 활성 계정 F- 향후 종료 날짜가 지정될 계정 E - 종료 날짜가 지정된 계정
User Name | 활성 | 사용자 계정 이름입니다.
User ID | 숨김 | 각 응용 프로그램 사용자 계정의 고유한 내부 식별자입니다.
Description | 숨김 | 사용자에 대한 설명입니다.
Email Address | 숨김 | 사용자의 전자 메일 주소입니다.
End Date | 숨김 | 계정이 종료되었거나 종료될 날짜입니다.
Last Logon | 숨김 | 계정에 마지막으로 액세스한 날짜 및 시간입니다.
Days Since last Connect | 숨김 | 사용자가 응용 프로그램에 마지막으로 연결한 이후에 경과된 일 수입니다. 이 값은 응용 프로그램을 더 이상 사용하지 않는 사용자를 식별하는 데 사용할 수 있습니다.
User ID | 숨김 | 응용 프로그램 사용자 계정의 고유한 내부 식별자입니다.

숨겨진 열을 보려면

  • Objects 패널의 열 제목을 마우스 오른쪽 단추로 누른 다음 표시할 열을 선택합니다.


Users Details 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

User Details 패널은 다음 탭으로 구성됩니다.

  • Info - 선택한 사용자에 대한 계정 정보를 표시합니다.

  • Responsibilities - 선택한 응용 프로그램 사용자에게 부여된 모든 책임을 나열합니다.

  • Menu for the Selected Responsibility - 선택한 책임에 대한 전체 메뉴 구조를 표시합니다.

  • Profile Options – 선택한 사용자에 대한 사용자 수준에서 설정된 모든 프로파일 옵션을 나열합니다.

  • Reference Info – 사용자 계정의 직원, 고객 및 공급자 참조 정보를 표시합니다.

  • Usage CR – 선택한 사용자 요청 활동을 표시합니다.

  • Usage FS – 선택한 사용자에 대한 전체 서비스 세션을 표시합니다.

  • Usage FS Audit - 선택한 전체 서비스 세션에 대한 전체 세션 활동입니다.

  • Usage SS - 선택한 사용자에 대한 자체 서비스 세션을 표시합니다. 기본값은 오늘의 활동입니다.


eBiz Users Info 탭

Users - Info 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Info 탭은 선택한 사용자에 대한 계정 정보를 표시합니다.

열 제목 | 설명
User ID | 응용 프로그램 사용자 계정의 고유한 내부 식별자입니다.
User Name | 응용 프로그램 사용자의 로그인 이름입니다.
Description | 사용자에 대한 설명입니다.
E-mail Address | 사용자의 전자 메일 주소입니다.
Start Date | 사용자 계정이 활성화된 날짜입니다.
End Date | 계정이 종료되었거나 종료될 날짜입니다.
Last Connected | 계정에 마지막으로 액세스한 날짜 및 시간입니다.
Days Since Last Connect | 사용자가 응용 프로그램에 마지막으로 연결한 이후에 경과된 일 수입니다. 이 값은 응용 프로그램을 더 이상 사용하지 않는 사용자를 식별하는 데 사용할 수 있습니다.
Account Information |
Account Created | 사용자 계정이 작성된 날짜입니다.
Created By | 사용자 계정을 작성한 응용 프로그램 사용자입니다.
Last Updated | 사용자 계정을 마지막으로 업데이트한 날짜입니다.
Last Updated By | 사용자 계정을 마지막으로 업데이트한 응용 프로그램 사용자입니다.
Account Reference Information |
Employee | 사용자가 직원으로 구성되었는지 여부를 나타냅니다.
Customer | 사용자가 고객으로 구성되었는지 여부를 나타냅니다.
Supplier | 사용자가 공급자로 구성되었는지 여부를 나타냅니다.
Account Password Information |
Password Last Changed | 암호가 마지막으로 변경된 날짜 및 시간입니다.
Password Aging (Days) | 암호를 변경해야 할 때까지 허용되는 일 수입니다.
Days Remaining | 암호를 변경해야 할 때까지 남은 일 수입니다.
Password lifespan (Accesses) | 암호를 변경해야 할 때까지 허용되는 액세스 횟수입니다.
Accesses Remaining | 암호를 변경해야 할 때까지 남은 액세스 횟수입니다.


eBiz Users Responsibilities

Users - Responsibilities

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Responsibilities 탭은 선택한 응용 프로그램 사용자에 대해 부여된 모든 책임을 나열합니다.

열 제목 | 설명
Appn ID | 책임 응용 프로그램 ID입니다.
Application Name | 응용 프로그램에 대한 간단한 설명입니다.
Resp ID | 내부 책임 참조 번호입니다.
Responsibility Name | 책임의 전체 이름입니다.
Status | 책임의 상태입니다. 비활성 상태는 책임에 대한 사용자 액세스의 종료 날짜가 지정되어 있으며 종료 날짜가 만료되었음을 의미합니다.
Start Date | 사용자에게 책임이 할당된 날짜입니다.
End Date | 사용자에게 부여된 책임에 대한 액세스 권한이 만료되는 날짜입니다.

Menu for the Selected Application

이 영역에는 선택한 책임의 전체 메뉴 구조가 트리 형태로 표시됩니다.


Users - Profile Options

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Profile Options 탭은 선택한 사용자에 대한 사용자 수준에서 설정된 모든 프로파일 옵션을 나열합니다.

열 제목 | 설명
App’n ID | 프로파일 옵션 응용 프로그램 ID입니다.
Application Name | 응용 프로그램에 대한 간단한 설명입니다.
Option ID | 프로파일 옵션 ID입니다.
Option Name (internal) | 내부 프로파일 옵션 이름입니다.
Option Name | 사용자 프로파일 옵션 이름입니다.
Option Value | 사용자 프로파일 옵션 값입니다.
Site Level Value | 사이트 수준 값입니다.


Users Reference Info

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

응용 프로그램은 종종 여러 위치에 사용자 정보를 보관합니다. 이 정보는 일반적으로 기능 팀에서 입력하므로 일관성이 없는 경우가 많습니다. 이 그리드를 사용하면 하나의 위치에서 사용자 참조 정보를 볼 수 있어 일관성 및 품질을 쉽게 비교할 수 있습니다.

사용자 참조 정보는 다음 응용 프로그램 개체에 나타날 수 있습니다.

  • 사용자 계정 정보 – APPLSYS.FND_USERS

  • 직원 세부 정보 – HR.PER_ALL_PEOPLE_F

  • 고객 정보 - AR.HZ_PARTIES

  • 공급자 세부 정보 - PO.PO_VENDOR_CONTACTS

매개 변수 | 설명
User Name | 자유 형식의 사용자 이름입니다. 사용자가 응용 프로그램에 로그온할 때 사용하는 이름입니다.
Description | 사용자 계정 설명입니다.
E-mail Address | 사용자의 전자 메일 주소입니다.
Employee Details (HR) |
First Name | 직원의 이름입니다.
Last Name | 직원의 성입니다.
E-mail Address | 직원의 전자 메일 주소입니다.
Customer Details (AR) |
First Name | 고객의 이름입니다.
Last Name | 고객의 성입니다.
E-mail Address | 고객의 전자 메일 주소입니다.
Supplier Details (PO) |
First Name | 공급자의 이름입니다.
Last Name | 공급자의 성입니다.


Users - Usage CR 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

이 그리드는 선택한 사용자에 대한 동시 요청 활동을 나열합니다.

기본적으로 정보는 지난 31일 동안에 생성된 활동으로 제한됩니다. 추가 필터를 사용하면 표시된 정보 범위를 확장할 수 있습니다.

주: 사용 가능한 기록의 양은 사이트 동시 요청 제거 정책에 따라 다릅니다.

열 제목 | 설명
Request ID | 동시 요청 ID입니다.
Concurrent Queue Name | 요청을 실행한 동시 관리자입니다.
Requestor | 요청을 전송한 사용자입니다.
Program Appn ID | 동시 프로그램의 내부 응용 프로그램 ID입니다.
Program ID | 내부 동시 프로그램 식별자입니다.
Program Name | 동시 프로그램의 전체 이름입니다.
Argument Text | 요청에 대한 런타임 인수입니다.
Priority | 요청 우선 순위입니다.
Status | 요청의 완료 상태입니다.
Req Start | 요청이 시작되도록 설정된 날짜 및 시간입니다.
Actual Start | 요청 처리가 시작된 날짜 및 시간입니다.
Completed | 요청 처리가 완료된 날짜 및 시간입니다.
Pending Time | 요청이 대기 중 상태로 있던 총 시간(HH:MM:SS)입니다.
Running Time | 요청에 대한 총 실행 시간(HH:MM:SS)입니다.
Printer | 매수를 포함한 요청이 전송된 프린터입니다.
Completion | 요청에 대한 텍스트 완료 텍스트입니다.
Log File Node | 로그 파일이 저장된 호스트 컴퓨터입니다.
Log File Name | 로그 파일 위치 및 이름입니다.
Out File Node | 출력 파일이 저장되는 호스트 컴퓨터입니다.
Out File Name | 출력 파일 위치 및 이름입니다.


Users - Usage FS

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Uage FS 탭은 선택한 사용자의 전체 서비스 세션 활동을 표시합니다. 사용 가능한 기록의 양은 사이트의 Sign-On 감사 제거 정책에 따라 다릅니다.

주: Sign-on 감사 수준은 이 그리드에서 볼 수 있는 정보 양을 결정합니다. Sign-on 감사 수준이 오른쪽 측면 그리드의 아래쪽 상태 표시줄에 나타날 수 있습니다.

열 제목

설명

Login ID

사용자 세션의 내부 로그인 ID입니다.

Session Start Date

사용자 세션이 시작된 날짜 및 시간입니다.

Session End Date

사용자 세션이 완료된 날짜 및 시간입니다.1

Connect Time

총 세션 시간(DD:HH:MM:SS)입니다.

Status

사용자 세션의 현재 상태입니다.

  • Connected

  • Closed

  • Dead2

Resp Used

세션 중에 사용된 책임 수입니다.3

Forms Used

세션 중에 사용된 양식 수입니다.4

1 null 값은 세션이 여전히 활성화되어 있는지 아니면 “Dead” 세션인지를 나타냅니다.

2 마지막 데이터베이스 시작 시간보다 시작 시간이 짧은 세션은 "Dead"로 표시됩니다.

3 책임 A를 선택하는 경우 책임 B로 전환한 다음 책임 A로 다시 전환하면 책임 A는 두 개의 책임이 사용된 것으로 계산됩니다.

4 양식 A를 선택한 후 양식 B로 전환한 다음 양식 A로 다시 전환하면 양식 A는 두 개의 양식이 사용된 것으로 계산됩니다.

Usage FS – Sessions Audit

이 하위 그리드에는 선택한 전체 서비스 세션에 대한 전체 세션 활동이 표시됩니다.

예를 들어 이 정보를 사용하면 응용 프로그램 내에서 사용자 작업 방법(Full Service Activity만 해당)을 볼 수 있습니다.

주: Sign-on 감사 수준은 이 그리드에서 볼 수 있는 정보 양을 결정합니다. Sign-on 감사 수준이 오른쪽 측면 그리드의 아래쪽 상태 표시줄에 나타날 수 있습니다.

열 제목

설명

Activity

이 열은 다음 중 하나를 포함합니다.

  • 연결 - 세션 시작을 나타냄

  • 세션의 책임 이름

  • 세션의 양식 이름

Session Start

활동이 시작된 날짜 및 시간입니다.

Session End

활동이 종료된 날짜 및 시간입니다.

Session Time

활동 기간(HH:MM:SS)입니다.

  • 총 세션 시간

  • 책임에 소요된 시간

  • 양식에 소요된 시간


Users - Usage SS

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Usage SS 탭은 선택한 사용자에 대한 자체 서비스 세션을 표시합니다. 기본값은 오늘의 활동입니다. 사용 가능한 기록의 양은 사이트의 자체 서비스(ICX) 제거 정책에 따라 다릅니다.

주: 자체 서비스 활동 테이블에서는 세션에 대한 마지막 활동만 저장하므로 전체 활동 감사가 불가능합니다.

열 제목 | 설명
Session ID | Self Service Web Apps 세션의 내부 세션 ID입니다.
Session Status | 세션 상태: Active / Inactive1
Mode Code | 자체 서비스 세션 모드입니다.
Responsibility ID | 책임에 대한 내부 응용 프로그램 참조 번호입니다.
Responsibility | 사용자의 마지막 활동과 관련된 응용 프로그램 책임입니다.
Org ID | 조직에 대한 내부 응용 프로그램 참조 번호입니다.
Org Name | 사용자의 마지막 활동과 관련된 조직입니다.
Function ID | 기능에 대한 내부 응용 프로그램 참조 번호입니다.
Function Name | 사용자의 마지막 활동과 관련된 기능입니다.
First Connect | 세션이 시작된 날짜 및 시간입니다.
Last Connect | 사용자 마지막 페이지 요청 날짜 및 시간입니다.
Session Time | 총 세션 시간(HH:MM:SS)입니다.
Session Time Limit | 세션의 활동 시간 제한(HH:MM:SS)(프로파일 옵션을 통해 설정됨)입니다.
Session Pages | 세션 중에 사용자가 만든 페이지 요청 수입니다.
Limit Pages | 세션에 대한 활동 페이지 요청 제한(프로파일 옵션을 통해 설정됨)입니다.

1 세션이 닫혀 있거나 30분 이상 세션 활동이 없으면 세션을 “Inactive”로 표시합니다.


Workflow Objects 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

워크플로를 선택하는 경우 Objects 패널(브라우저의 왼쪽)에는 두 개 수준이 포함됩니다.

예를 들면 다음과 같습니다.

Active Workflow Types

첫 번째 수준에는 현재 활성 상태인 모든 워크플로 유형의 목록이 다음 형식으로 표시됩니다.

워크플로 항목 유형: 표시 이름(n)

여기서 n은 워크플로 테이블에서 해당 유형의 워크플로 개수입니다.

주: 성능을 위해 각 워크플로 유형의 워크플로 수는 기본적으로 표시되지 않습니다. 워크플로 목록 위에 있는 (…) 옵션을 선택하면 이러한 값이 채워집니다.

Active Workflows by Item Key

두 번째 수준에는 항목 유형에 대한 모든 활성 워크플로의 목록이 항목 키별로 다음 형식으로 표시됩니다.

항목 키(워크플로의 시작 날짜 및 시간)


Workflow Type Details 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Object 패널에서 워크플로 유형을 선택하면 왼쪽 Details 패널에 다음 탭이 표시됩니다.

  • Info - 선택한 프로파일 옵션에 대한 전체 프로파일 옵션 정보를 표시합니다.

  • Activity 1 - 선택한 워크플로 항목에 대해 상태별로 현재 워크플로 항목 활동을 그래픽으로 표시합니다(Active - Complete - Other).

  • Activity 2 - 선택한 워크플로 항목에 대해 상태별로 현재 워크플로 항목 활동을 그래픽으로 표시합니다(Error. Suspended, deferred 등…).

  • Purgable (Est) - 선택한 워크플로 항목에 대한 모든 "Purgable" 활동을 나열합니다.

  • Deferred - 선택한 워크플로 항목에 대한 모든 “Deferred” 활동을 나열합니다.

  • Stuck - 선택한 워크플로 항목에 대한 모든 “Stuck” 활동을 나열합니다.

  • Waiting - 선택한 워크플로 항목에 대한 모든 “Waiting" 활동을 나열합니다.

  • Suspended - 선택한 워크플로 항목에 대한 모든 “Suspended” 활동을 나열합니다.

  • Error - 선택한 워크플로 항목에 대한 모든 “Error” 활동을 나열합니다.

  • Nitified - 선택한 워크플로 항목에 대한 모든 “Notified" 활동을 나열합니다.

  • Notifications - 선택한 워크플로 항목에 대한 모든 알림을 나열합니다.


Workflow Type - Info 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Info 탭은 선택한 워크플로 유형의 워크플로 유형 정보를 표시합니다.

속성 | 설명
Item Type | 항목 유형 이름(내부)입니다.
Display Name | 항목 유형 표시 이름입니다.
Description | 항목 유형에 대한 설명입니다.
Persistence |
Persistence Type | 지속성 유형(PERM / TEMP)입니다.
Persistence Days | 지속성 일 수입니다.
Levels | 보호 수준 - 항목 유형의 보호 수준입니다.
Custom Level | 마지막으로 항목 유형을 업데이트한 사용자의 수준입니다.
Access |
Read Role | 현재는 사용되지 않습니다.
Write Role | 현재는 사용되지 않습니다.
Execute Role | 현재는 사용되지 않습니다.


Workflow Type - Activity 1 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Activity 1 탭은 선택한 워크플로 항목에 대해 상태별로 현재 워크플로 항목의 활동을 그래픽으로 표시합니다.

  • Active

  • Complete

  • Other

Other는 Error. Suspended, deferred 등 다른 모든 항목 상태를 의미합니다. 이러한 상태는 Activity 2 탭을 선택하여 볼 수 있습니다.

주: Active 1에서 확인할 수 있는 Active 및 Complete 개수가 Other 상태 유형을 압도하므로 상태별 워크플로 활동은 Activity 1과 Activity 2라는 두 탭으로 나뉩니다.


Workflow Type - Activity 2 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Activity 2 탭은 선택한 워크플로 항목에 대해 상태별로 현재 워크플로 항목의 활동을 그래픽으로 표시합니다.

  • Error

  • Suspended

  • Deferred

  • 등

Active와 Completed 두 상태에 해당하는 활동의 개수는 Activity 1 탭에 표시됩니다.

주: Active 1에서 확인할 수 있는 Active 및 Complete 개수가 Other 상태 유형을 압도하므로 상태별 워크플로 활동은 Activity 1과 Activity 2라는 두 탭으로 나뉩니다.


Workflow Type - Purgable (Est) 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Purgable (Est) 탭은 지속성 유형 및 제거 프로그램에 사용된 기간(일) 등 선택한 워크플로 항목에 대한 제거할 수 있는 워크플로 항목을 표시합니다.

열 제목 | 설명
Item Key | 워크플로 항목의 고유 참조 키입니다.
Last Activity Date | 워크플로 항목에서 마지막 활동이 발생한 날짜 및 시간입니다.
Persistence Type | 지속성 유형(PERM / TEMP)입니다.
Persistence Days | 지속성 일 수입니다.
Est Rows | wf_item_activitiy_statuses 테이블에서 제거될 예상 행 개수입니다.


Workflow Type - Deferred 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Deferred 탭은 선택한 워크플로 항목에 대한 모든 연기된 활동을 나열합니다.

열 제목 | 설명
Item Type | 항목 유형 이름(내부)입니다.
Item Key | 워크플로 항목의 고유 참조 키입니다.
Process Activity ID | 워크플로의 프로세스 활동 번호입니다.
Display Name | 항목 유형 표시 이름입니다.
Item Type Description | 항목 유형에 대한 설명입니다.
Activity Status | 워크플로 항목의 현재 상태입니다.
Assigned User | 작업을 완료하도록 할당된 사용자입니다.
Begin Date | 항목 활동이 시작된 날짜 및 시간입니다.
Age (Days) | 활동 기간(일)입니다.


Workflow Type - Stuck 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Stuck 탭은 선택한 워크플로 항목에 대한 모든 "Stuck" 활동을 나열합니다.

열 제목 | 설명
Item Type | 항목 유형 이름(내부)입니다.
Item Key | 워크플로 항목의 고유 참조 키입니다.
Process Activity ID | 워크플로의 프로세스 활동 번호입니다.
Display Name | 항목 유형 표시 이름입니다.
Item Type Description | 항목 유형에 대한 설명입니다.
Activity Status | 워크플로 항목의 현재 상태입니다.
Assigned User | 작업을 완료하도록 할당된 사용자입니다.
Begin Date | 항목 활동이 시작된 날짜 및 시간입니다.
Age (Days) | 활동 기간(일)입니다.


Workflow Type - Waiting 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Waiting 탭은 선택한 워크플로 항목에 대한 모든 대기 활동을 나열합니다.

열 제목 | 설명
Item Type | 항목 유형 이름(내부)입니다.
Item Key | 워크플로 항목의 고유 참조 키입니다.
Process Activity ID | 워크플로의 프로세스 활동 번호입니다.
Display Name | 항목 유형 표시 이름입니다.
Item Type Description | 항목 유형에 대한 설명입니다.
Activity Status | 워크플로 항목의 현재 상태입니다.
Assigned User | 작업을 완료하도록 할당된 사용자입니다.
Begin Date | 항목 활동이 시작된 날짜 및 시간입니다.
Age (Days) | 활동 기간(일)입니다.


Workflow Type - Suspended 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Syspended 탭은 선택한 워크플로 항목에 대한 모든 일시 중단된 활동을 나열합니다.

열 제목 | 설명
Item Type | 항목 유형 이름(내부)입니다.
Item Key | 워크플로 항목의 고유 참조 키입니다.
Process Activity ID | 워크플로의 프로세스 활동 번호입니다.
Display Name | 항목 유형 표시 이름입니다.
Item Type Description | 항목 유형에 대한 설명입니다.
Activity Status | 워크플로 항목의 현재 상태입니다.
Assigned User | 작업을 완료하도록 할당된 사용자입니다.
Begin Date | 항목 활동이 시작된 날짜 및 시간입니다.
Age (Days) | 활동 기간(일)입니다.


Workflow Type - Error 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Error 탭은 선택한 워크플로 항목에 대한 모든 오류 활동을 표시합니다.

열 제목 | 설명
Item Type | 항목 유형 이름(내부)입니다.
Item Key | 워크플로 항목의 고유 참조 키입니다.
Process Activity ID | 워크플로의 프로세스 활동 번호입니다.
Display Name | 항목 유형 표시 이름입니다.
Item Type Description | 항목 유형에 대한 설명입니다.
Activity Status | 워크플로 항목의 현재 상태입니다.
Assigned User | 작업을 완료하도록 할당된 사용자입니다.
Begin Date | 항목 활동이 시작된 날짜 및 시간입니다.
Age (Days) | 활동 기간(일)입니다.
Error Name | 내부 오류 이름입니다.
Error Message | 오류 메시지 텍스트입니다.
Error Stack | 오류 메시지 호출 스택입니다.


Workflow Type - Notified 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Notified 탭은 선택한 워크플로 항목에 대해 알림이 전송된 활동을 모두 나열합니다. 전체 알림 세부 정보는 선택한 워크플로의 Notifications 탭에 표시됩니다.

열 제목 | 설명
Item Type | 항목 유형 이름(내부)입니다.
Item Key | 워크플로 항목의 고유 참조 키입니다.
Process Activity ID | 워크플로의 프로세스 활동 번호입니다.
Display Name | 항목 유형 표시 이름입니다.
Item Type Description | 항목 유형에 대한 설명입니다.
Activity Status | 워크플로 항목의 현재 상태입니다.
Assigned User | 작업을 완료하도록 할당된 사용자입니다.
Begin Date | 항목 활동이 시작된 날짜 및 시간입니다.
Age (Days) | 활동 기간(일)입니다.
Notification ID | 워크플로 항목 알림 ID입니다.


Workflow Type - Notifications 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Notifications 탭은 선택한 워크플로 항목에 대한 모든 전송된 알림을 표시합니다.

이 그리드를 사용하면 워크플로 작업을 계속해서 늦게 확인하는 워크플로 사용자가 누구인지 식별할 수 있습니다.

열 제목 | 설명
ID | 알림 ID입니다.
Display Name | 알림 표시 이름입니다.
Subject | 알림 제목입니다.
Recipient Role | 알림의 역할/수신자입니다.
Recipient | 알림의 수신자입니다.
Responder | 알림에 응답한 역할/사용자입니다.
Status | 알림의 현재 상태입니다.
Mail Status | 알림의 메일 상태입니다.
Begin Date | 알림을 작성한 날짜입니다.
Due Date | 알림에 대한 조치를 수행해야 하는 기한 날짜입니다.
End Date | 알림 프로세스를 완료한 날짜입니다.
Response Time (Days) | 응답자가 알림에 대한 조치를 수행하는 데 소요된 시간(일)입니다.
Over Due (Days) | 알림 기한 만료 후 경과된 일 수입니다.


Workflow Details 패널

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

개별 워크플로를 선택하면 Details 패널(오른쪽)에 다음 탭이 표시됩니다.

  • Info - 선택한 워크플로를 작성하는 데 사용된 일반적인 정보를 표시합니다.

  • Activity - 최근까지 발생했던 선택한 워크플로에 대한 활동을 나열합니다.

  • Notifications - 선택한 워크플로에 대한 알림을 표시합니다.


Workflow - Info 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Info 탭은 선택한 워크플로를 작성하는 데 사용된 일반적인 정보를 표시합니다.

속성 | 설명
Activity Name | 활동 이름(내부)입니다.
Display Name | 활동 표시 이름입니다.
Value | 워크플로 항목의 활동 값입니다.


Workflow - Activity 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Activity 탭은 최근까지 발생했던 선택한 워크플로에 대한 활동을 나열합니다.

열 제목 | 설명
Activity ID | 내부 활동 ID입니다.
Activity Name | 활동 표시 이름입니다.
Execution Time (Internal) | 실행 중에 활동 순서를 지정하는 데 사용됩니다.
Status | 워크플로 활동의 상태입니다.
Results | 완료된 활동 항목의 결과입니다.
Notification ID | 알림 ID입니다.
Begin Date | 활동을 작성한 날짜입니다.
End Date | 활동을 완료한 날짜입니다.
Activity Time (Days) | 활동을 완료하는 데 소요된 시간(일)입니다.
Error Name | 내부 오류 이름입니다.
Error Message | 오류 메시지 텍스트입니다.
Error Stack | 오류 메시지 호출 스택입니다.


Workflow - Notifications 탭

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

이 탭은 선택한 워크플로에 대한 알림을 표시합니다.

열 제목 | 설명
ID | 알림 ID입니다.
Display Name | 알림 표시 이름입니다.
Subject | 알림 제목입니다.
Recipient Role | 알림의 역할/수신자입니다.
Recipient | 알림의 수신자입니다.
Responder | 알림에 응답한 역할/사용자입니다.
Status | 알림의 현재 상태입니다.
Mail Status | 알림의 메일 상태입니다.
Begin Date | 알림을 작성한 날짜입니다.
Due Date | 알림에 대한 조치를 수행해야 하는 기한 날짜입니다.
End Date | 알림 프로세스를 완료한 날짜입니다.
Response Time (Days) | 응답자가 알림에 대한 조치를 수행하는 데 소요된 시간(일)입니다.
Over Due (Days) | 알림 기한 만료 후 경과된 일 수입니다.
Message | 알림 메시지입니다.


eBiz Monitor 개요

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

응용 프로그램 관리자는 Toad E-Business Monitor를 사용하여 응용 프로그램의 활동을 모니터링할 수 있습니다. eBiz Monitor에서는 각각 시간별로 볼 수 있는 9개의 차트를 사용하여 응용 프로그램의 활동을 모니터링할 수 있습니다. 이러한 차트를 다음과 같이 사용할 수 있습니다.

  • Running and pending concurrent requests – 병렬로 실행 중인 프로그램이나 과다한 대기 중인 작업의 최대 시간을 식별합니다.

  • Concurrent requests completed (today) – 동시 관리자에서의 활동량을 평균 기간과 비교하여 한 번에 볼 수 있습니다.

  • Concurrent requests completed with errors or warnings – 여러 작업의 실패 여부를 확인할 수 있습니다.

  • Full service (forms) user connections – 양식 사용자의 동시 사용 및 볼륨을 표시합니다.

  • Self service (web) user connections – 웹 또는 자체 서비스 응용 프로그램 사용자의 동시 사용 및 볼륨을 표시합니다.

  • Self service page requests – 자체 서비스 응용 프로그램에 대한 요청의 볼륨을 표시합니다.

  • Workflow mail items waiting to be sent – 워크플로에 대한 메일 배달 문제가 있는지 여부를 식별합니다.

  • Workflows which are stuck, deferred or timed out – 완료되지 않고 있는 워크플로의 볼륨을 식별합니다.

  • Workflow errors – 오류가 발생한 워크플로 트랜잭션의 볼륨을 식별합니다.

또한 Monitor 도구 모음을 사용하여 이러한 차트를 보는 방식을 선택할 수 있습니다.


eBiz Monitor 도구 모음

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

몇 가지 서로 다른 구성으로 eBiz Monitor의 차트를 볼 수 있습니다. 도구 모음을 사용하여 차트를 표시할 방식을 지정합니다.

단추 | 명령
 | 활성 세션 변경
 | 새로 고침 간격 변경 - 각 차트의 새로 고침 간격을 변경할 수 있도록 하는 대화 상자를 표시합니다. 완료되면 Done을 누릅니다.
 | 차트를 즉시 새로 고칩니다.
 | 모니터 차트 배열을 선택합니다. 기본값은 세 행 및 세 열이지만 몇 가지 옵션 중에서 선택할 수 있습니다.

차트 보기를 확대/축소하려면

  • 차트를 두 번 눌러 전체 화면으로 볼 수 있습니다.


eBiz Reports 개요

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

개발자 및 관리자는 Toad E-Business 보고서 작성기를 사용하여 저장한 후 곧바로 실행할 수 있는 중요 응용 프로그램 데이터에 대한 보고서를 신속하게 설계하고 형식을 지정할 수 있습니다.

Toad에서는 보고서 페이지에서 실행 및 인쇄할 수 있는 미리 작성된 몇 개의 보고서를 제공합니다. 또한 FastReports 시스템을 사용하여 사용자 정의 보고서를 설계할 수도 있습니다.

제공된 보고서 사용

eBiz module의 보고서 기능은 Toad의 Reports Manager를 통해 제공됩니다. 창 왼쪽에 있는 Reports 목록에서 제공된 보고서를 선택할 수 있습니다. SELECT 문과 보고서 정의 파일 이름이 오른쪽에서 변경됩니다.

미리 생성된 보고서 사용에 대한 자세한 내용은 Reports Manager 항목을 참조하십시오.

보고서를 열려면

  • Database 메뉴에서 Report|Reports Manager를 선택합니다.

보고서 직접 설계

Fast Report 도구를 사용하여 보고서를 직접 설계할 수 있습니다.

보고서를 작성하려면

  1. eBiz 메뉴에서 eBiz Reports를 선택합니다.

  2. 보고서에 데이터를 제공할 질의를 입력합니다.

  3. Design [image] 단추를 누릅니다.

Design을 선택하면 이미 선택한 준비된 보고서가 Design 창에 열립니다.

  3. Fast Report를 사용하여 보고서를 작성합니다.

보고서 도구 사용에 대한 도움말은 Fast Report 온라인 사용 설명서를 참조하십시오. 이 파일을 보려면 인터넷에 연결해야 합니다.


eBiz Lookup Finder 개요

주: 이러한 eBiz 기능은 선택 사항인 Quest Ebiz Module이 있는 Toad for Oracle 버전에서만 사용할 수 있습니다.

Quest eBiz Module의 Lookup Finder는 조회 작업에 대한 다른 접근 방식을 제공합니다. eBiz Browser에서 모든 조회 및 해당 값을 표시하지만 사용 가능한 값을 확인하려면 조회의 이름을 알아야 합니다. 개발자는 Lookup Finder를 사용하여 표시된 의미(또는 조회 코드나 조회 유형)를 기준으로 조회를 검색할 수 있습니다. 이렇게 하면 새 양식을 작성하거나 동시 프로그램 매개 변수를 구성할 때 적절한 조회를 찾는 데 드는 시간을 줄일 수 있습니다.

eBiz Lookup Finder 도구 모음

단추

명령

활성 세션 변경

검색

질의 보기/편집

Lookup Type

조회 유형을 기준으로 필터링합니다.

  • 대소문자 구분 여부를 선택합니다.

  • 아래 상자에 필터를 입력합니다.

Lookup Code

조회 코드를 기준으로 필터링합니다.

  • 대소문자 구분 여부를 선택합니다.

  • 아래 상자에 필터를 입력합니다.

Meaning

의미를 기준으로 필터링합니다.

  • 대소문자 구분 여부를 선택합니다.

  • 아래 상자에 필터를 입력합니다.

User Query

view/edit query 단추를 사용하여 질의를 변경하는 경우 이 확인란이 활성화됩니다.

활성화된 이 확인란을 선택하고 나서 view/edit query 단추를 다시 누를 경우 입력한 질의가 입력한 위치에 그대로 있습니다. 선택을 취소할 경우 질의가 편집 상자의 내용에 따라 다시 채워집니다.


Help About

이 대화상자는 몇 가지 유용한 연락 정보를 표시합니다.

  • Toad의 현재 버전 번호를 기록합니다. 고객 기술 지원부에 문의할 경우 사용 중인 버전을 알려줘야 합니다.

  • "www.quest.com"을 누르면 기본 웹 브라우저가 열리고 Quest Software, Inc. 사이트로 바로 이동합니다.

  • "info@quest.com"을 누르면 기본 전자 메일 클라이언트 소프트웨어가 열리고 Quest에 자세한 내용을 문의하기 위해 새 전자 메일을 작성합니다. 전자 메일에 사용하는 Toad의 버전 번호를 기록합니다.

Help About 대화상자를 액세스하려면

  • 메뉴에서 Help|About을 선택합니다,


도움말 파일 힌트

도움말은 상황에 맞는 도움말을 보기 위해 <F1>을 눌러 Toad 전반에 걸쳐 사용할 수 있습니다.

도움말 문제 해결

Microsoft의 보안 패치로 인해 보안 패치가 내부 브라우저 창에서의 이동을 활성화하기 위해 도움말 파일에서 사용되는 ActiveX 컨트롤을 비활성화하면 Toad를 네트워크로 설치할 때 도움말을 사용하지 못할 수 있습니다.

Toad 해결 방법

  1. 클라이언트 시스템에 도움말 파일을 설치합니다.

  2. TOAD.INI [Settings]에서 다음과 같은 항목을 생성합니다.

HelpFileDir = location of helpfile

네트워크에서 도움말 파일을 사용하려면 Microsoft에 해결 방법을 문의해야 합니다.


온라인 리소스

Toad와 함께 도움말을 사용할 수 있도록 도와주는 여러 가지의 온라인 리소스가 있습니다. 여기에는 메일 그룹, 다운로드 사이트, QuestSupport 및 사용자 실행 기반의 기술 자료가 포함됩니다.

온라인 리소스를 액세스하려면

  • Help 메뉴에서 Online Resources를 선택한 다음 액세스할 리소스를 선택합니다.

AskToad.com

AskToad는 Wiki 기술로 실행되는 사용자 기반의 기술 자료입니다. Toad for Oracle 사용에 대한 해답, 팁 및 힌트를 제공하도록 설계되었습니다.

메일 그룹 가입

이 대화상자에서 Toad 및 Toad 베타 메일 그룹에 쉽게 가입할 수 있습니다. 단추 중 하나를 누르면 전자 메일 편집기에 해당하는 상자에 내용이 기입된 상태로 새 전자 메일이 열립니다. 그런 다음 메시지를 보내면 메일 그룹에 가입됩니다.

주: 메일 그룹에 게시된 해답의 정확도는 Quest 기술 지원 서비스에서 모니터하지 않습니다. 이러한 목록은 P2P 지원만 제공합니다.

Toadsoft.com

Toadsoft.com은 Toad에 대한 다음과 같은 정보를 찾기 위해 검색할 수 있는 웹 사이트입니다.

  • Toad 다운로드

  • 질문과 대답(FAQ)

  • Quest 리소스 링크

  • 기타 정보

Toadsoft를 액세스하려면 http://toadsoft.com을 방문하십시오.

Quest 기술 지원 서비스

Quest 제품의 평가판을 가지고 있거나 상용 버전을 구입하고 유효한 유지관리 계약서를 가지고 있는 고객은 Quest 기술 지원 서비스를 이용할 수 있습니다. Quest 기술 지원 서비스는 서비스 지역에 24시간 웹 자체 서비스인 SupportLink를 제공합니다. http://support.quest.com의 SupportLink를 방문하십시오.

SupportLink에서 다음 작업을 수행할 수 있습니다.

  • 수천 개의 솔루션(기술 자료/문서)을 빨리 찾습니다.

  • 패치 및 업그레이드를 다운로드합니다.

  • 기술 지원 엔지니어의 도움을 구합니다.

  • 사용자의 사례를 기록 및 업데이트하고 상태를 확인합니다.

지원 프로그램, 온라인 서비스, 연락처 정보, 정책 및 절차에 대한 자세한 설명은 전세계 지원 안내서를 참조하십시오. 안내서는 다음 웹 사이트에서 사용할 수 있습니다. http://support.quest.com/pdfs/Global Support Guide.pdf


번들 지원

번들 지원 개요

사용 설명서나 도움말 파일에서 궁금증을 해결할 수 없었다면 자사에 직접 문의하십시오. Help|Support Bundle을 선택하여 쉽게 문의할 수 있습니다.

Support Bundle 창에 Oracle 및 Toad 설정의 여러 측면에 대한 내용이 표시됩니다. 이 내용은 모든 문제 해결 향상에 사용할 수 있습니다. 이 내용에는 다음이 포함됩니다.

  • 응용프로그램 정보

  • Toad 버전

  • Toad 등록 정보

  • Toad Editions 옵션(디버거, DBA, Xpert 등)

  • 설치 유형(네트워크 또는 로컬)

  • EXE 및 클라이언트 디렉토리. 클라이언트 디렉토리는 네트워크 설치에만 적용됩니다.

  • Knowledge Xpert 버전 및 위치

  • SPServer.dll 버전 및 위치

  • Team Coding 정보

  • Team Coding 설치 여부

  • Team Coding 설정

  • Oracle 클라이언트 정보

  • 클라이언트 위치

  • TNSNAMES.ORA 위치

  • Oracle Server 정보

  • 서버 버전

  • Server NLS_CHARACTERSET

  • Server NLS_NCHAR_CHARACTERSET

  • 연결된 사용자 및 연결 계정(기본, SYSDBA, SYSOPER)

  • 시스템 정보

  • 운영 체제 버전

  • 총 사용 가능한 메모리(물리적, 가상 및 스왑)

  • PATH 환경 매개 변수

  • TNS_ADMIN 환경 매개 변수

  • Oracle 홈 레지스트리 데이터

  • 설치된 홈의 모든 레지스트리 정보가 표시됩니다. 이 정보는 HKEY_LOCAL_MACHINE\Software\Oracle 아래에 있습니다.

또한, Support Bundle에서 P2P 메일 그룹 또는 Quest 기술 지원부에 직접 문제를 쉽게 보고할 수 있습니다. 자세한 내용은 번들 지원 도구 모음을 참조하십시오.


지원 번들 도구 모음

지원 번들의 도구 모음에서 여러 작업을 수행할 수 있습니다.

단추 | 명령
 | 지원 번들을 클립보드에 복사
 | 지원 번들을 파일로 저장
 | 지원 번들 정보 새로 고침
Toad Mailing List | 이렇게 하면 P2P Toad 메일 그룹으로 보낼 전자 메일과 함께 전자 메일 응용프로그램이 열립니다. Toad 목록에 대한 자세한 내용은 메일 그룹 가입을 참조하십시오.
Quest Support | 이렇게 하면 고객 지원부로 보낼 전자 메일과 함께 전자 메일 응용프로그램이 열립니다.
Attach TOAD.INI to email | 표시되어 있으면 P2P Toad 목록 또는 Quest 기술 지원 서비스로 지원 번들을 통해 전송된 모든 전자 메일에 TOAD.INI가 첨부됩니다.
Use this information in body of email | 표시되어 있으면 Toad가 P2P Toad 목록 또는 Quest 기술 지원 서비스에 전송된 전자 메일의 내용에 지원 번들 정보를 포함시킵니다.


서식 옵션

Formatting Tools를 선택한 경우 Toad에서 코드의 서식을 지정하는 방법을 설정할 수 있습니다.

서식 옵션을 설정하려면

  1. View 메뉴에서 Formatting Options를 선택합니다.

  2. 왼쪽 패널에서 설정할 대상에 해당하는 노드를 선택합니다.

  3. 상위 수준 노드를 선택할 경우 해당 노드 아래에 포함된 서식 종류에 대한 설명이 오른쪽 패널에 표시됩니다. 세부 정보 노드를 선택할 경우 오른쪽 패널에 설정이 표시됩니다.

  4. 변경을 수행합니다. 변경된 옵션 노드는 굵게 표시됩니다.

  5. Save [image] 단추를 누릅니다.

  6. 창을 닫습니다.

서식 옵션의 변경 내용을 지우려면

  • 옵션을 저장하기 전에 Undo Option Changes [image] 단추를 누릅니다.

모든 옵션을 기본 설정으로 재설정하려면

  • Reset all Options [image] 단추를 누릅니다.

관련 항목

Formatting Tools

파일 서식 지정


옵션 검색

옵션 목록에서 원하는 옵션을 검색할 수 있습니다. 기본 옵션은 알고 있지만 어떠한 범주에 속하는지 모를 경우 이 기능이 유용할 수 있습니다.

옵션을 검색하려면

  1. View 메뉴에서 Options를 선택합니다.

  2. Options 창의 아래에는 Find 상자가 있습니다. 키워드의 여러 문자를 이 상자에 입력합니다.

  3. Search를 누릅니다.

  4. 검색 결과를 누르거나 결과를 선택하고 <ENTER> 키를 누르면 굵게 표시된 해당 옵션이 있는 페이지가 options 창에 표시됩니다. Option Window search 대화 상자가 계속 열려 있으므로 계속하기 전에 모든 결과를 볼 수 있습니다.

  5. 원할 경우 Search 단추 옆에 있는 화살표를 눌러 search results 영역을 닫을 수 있습니다.

예

암호를 기본적으로 사용자 이름으로 만드는 옵션이 있다는 것을 알고 있습니다. 그러나 이 옵션이 Options 창에서 어디에 있는지 모릅니다.

  1. Find 상자에 pass를 입력합니다. <Enter> 키를 누르거나 Search를 누릅니다.

  2. search results 창에 다음 옵션이 표시됩니다.

  3. Save passwords for Oracle connections

  4. Encrypt saved passwords

  5. Default passwords to User name

  3. 적절한 옵션을 선택합니다(이 경우에는 Default Passwords to User name). <Enter> 키를 누르거나 옵션을 누릅니다. Options 창에 옵션이 표시됩니다.


Data Grids - Data

주: 날짜는 mm/dd/yy 또는 mm/dd/yyyy 형식이나 Windows 제어판, 국가별 설정, 날짜, 간단한 날짜 스타일 형식으로만 입력할 수 있습니다. 예를 들어 프랑스에서는 dd/mm/yy 또는 dd/mm/yyyy 날짜 입력이 허용됩니다. dd-mon-yy 형식으로 입력한 날짜는 거부됩니다.

Behavior

Use Read-Only Queries

이 옵션은 업데이트 가능한 결과 집합을 Schema Browser 및 Master/Detail Browser 창에 반입하는 기능을 제어합니다.

이 옵션을 선택하지 않으면 편집 가능한 그리드를 Schema Browser 및 Master/Detail Browser로 자동으로 가져옵니다.

이 옵션을 선택하면 Schema Browser 및 Master/Detail Browser에서 그리드를 편집할 수 없습니다.

주: ROWID를 질의에 포함하거나 EDIT 문을 실행할 경우에만 Editor의 그리드를 편집할 수 있습니다. 자세한 내용은 편집 가능한 결과 집합을 참조하십시오.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Confirm record deletions

이 옵션을 선택하면 레코드를 삭제하기 전에 각 레코드 삭제를 확인합니다. 또한 이 옵션은 Schema Browser "Data" 탭에서 Data 그리드에 영향을 줍니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Warn of cascading constraints on deletions

이 옵션은 Schema Browser에만 적용됩니다. 이 옵션을 선택하면 그리드에서 행을 삭제하려고 할 때 Toad는 "ON CASCADE DELETE" 외래 키 제약 조건을 검사합니다. 이 제약 조건으로 인해 다른 테이블의 행도 삭제될 수 있습니다. 이 제약 조건이 있을 경우 삭제 전에 경고가 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Stop data fetches when available memory becomes less than nMB

Toad에서 데이터 반입 중지를 트리거하는 MB 수를 변경할 수 있습니다. 이 수에는 사용 가능한 모든 메모리(물리적 및 페이지 파일 모두)가 포함됩니다.

Display

Use legacy Print Grid

이 옵션을 선택하면 이전 Toad print 그리드 대화 상자를 사용하도록 Toad에 지시합니다.

이 옵션을 선택하지 않으면 최신 Report Link Designer가 인쇄 기본값이 됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Font

이 옵션을 사용하면 레거시 Print 그리드를 사용할 경우 사용되는 글꼴을 변경할 수 있습니다.

Show RowID in editable grids

이 옵션을 선택하면 행 id가 Data 그리드에 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Trim string data in CHAR and NCHAR columns

이 옵션을 선택하면 Oracle에서 데이터가 검색될 경우 CHAR 및 NCHAR 열에서 모든 후행 공백이 잘리기 때문에 실제 데이터만 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Display large numbers in scientific notation

이 옵션을 선택하면 15자리를 초과하는 숫자는 Data 그리드에서 지수 표시법으로 표시되고 소수 자릿수가 15개를 초과하는 숫자는 16번째 자릿수로 반올림되어 표시됩니다.

이 옵션을 선택하지 않으면 data 그리드의 모든 숫자가 완전히 표시되고 숫자 셀에서 Calculator 드롭다운이 비활성화됩니다.

이 옵션은 Toad에서 연결을 설정할 때 설정되므로 이 옵션을 변경할 경우에는 로그오프한 다음 새 연결을 설정해야 변경 내용이 적용됩니다.

이 옵션은 기본적으로 선택되어 있습니다. 이 기본값을 유지하는 것이 좋습니다.

Date format: (드롭다운 목록)

일반적으로 Toad에서 date 열에 대한 데이터는 Windows 제어판에서 선택한 형식으로 표시됩니다. 다른 형식을 선택하면 Windows 제어판 설정이 무시됩니다.

기본값은 Windows 제어판, 국가별 설정, 간단한 날짜 스타일 형식입니다.

Time format: (드롭다운 목록)

원할 경우 다른 시간 형식을 선택합니다.

기본값은 h:mm:ss AMPM입니다.

Sliding window for entering two digit years

이 옵션을 사용하면 현재 세기를 2자리 숫자 날짜로 사용하기 위한 슬라이드 창 값을 변경할 수 있습니다. 이는 현재 시스템 날짜에서 sliding window 옵션에 지정된 연도 수를 뺀 값입니다. 선택 범위는 0부터 49입니다.

예를 들어 30년 창(Toad 기본값)을 지정하고 1/1/87을 입력할 경우 생성되는 날짜는 1987년 1월 1일입니다. 30년 창을 벗어나는 1/1/57을 입력할 경우 생성되는 날짜는 2057년 1월 1일입니다.

Single Record View

Sort columns

이 옵션을 선택하면 열이 알파벳 순서대로 표시됩니다. 이 옵션을 선택하지 않으면 열은 작성된 순서대로 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Left align column names

이 옵션을 선택하면 모든 필드 이름이 왼쪽 맞춤됩니다. 이 옵션을 선택하지 않으면 모든 필드 이름이 오른쪽 맞춤됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

관련 항목

Data Grids - Visual


Data Grids - Visual

Data Grid – Visual 옵션은 그리드가 표시되고 시각적으로 작동하는 방법을 제어합니다.

Behavior

Tabs

이 옵션을 선택하면 tabs 옵션에서 Tab 키로 레코드를 하나씩 이동할 수 있습니다.

이 옵션은 기본적으로 선택되어 있습니다.

주: Tab Through도 함께 선택하지 않은 경우 여러 레코드를 Tab 키로 이동할 수 없습니다.

Tab Through

이 옵션을 선택하면 Tab 키로 둘 이상의 레코드를 이동할 수 있습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

주: Tab 키로 레코드를 이동하려면 Tabs도 선택해야 합니다.

Row Select

Row Select 옵션을 선택하면 Data 그리드에서 셀을 누를 경우 하나의 셀이 아니라 전체 행이 선택됩니다.

이 옵션을 선택하지 않으면 셀을 누를 경우 하나의 셀만 선택됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Multi Select

Multi Select 상자를 선택하면 row select가 자동으로 적용됩니다. Multi select를 사용하면 <shift> 또는 <ctrl> 키를 누른 채로 행을 눌러서 한 번에 여러 개의 행을 선택할 수 있습니다.

이 옵션을 선택하지 않으면 한 번에 하나의 행만 선택할 수 있습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Immediate Edit

이 옵션을 선택하면 그리드에서 데이터 셀을 누르자마자 그리드가 편집 모드로 들어갑니다. 이 옵션을 선택하지 않은 경우 그리드를 편집 모드로 만들려면 셀을 두 번 선택해야 합니다.

data 그리드를 편집할 수 없고 이 옵션이 선택된 경우 그리드는 여전히 편집 모드로 들어간 것처럼 보이지만 데이터를 편집할 수 없습니다.

이 옵션을 선택하지 않은 경우 데이터 셀을 편집 가능하게 만들려면 두 번 눌러야 합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Confirm sorts when clicking on column header

이 옵션을 선택하면 열 머리글을 눌렀을 때 Sort Options 상자가 나타납니다. 이 상자에서는 해당 열의 데이터를 정렬하는 방법을 선택할 수 있습니다.

이 옵션을 선택하지 않으면 어떠한 옵션도 표시되지 않고 열이 즉시 정렬됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Default to Excel style filtering headers

이 옵션을 선택하면 Excel 워크시트를 필터링할 때와 같은 방법으로 각 열 머리글의 드롭다운 필터링 화살표를 사용하여 Data 그리드를 필터링할 수 있습니다. Excel 스타일 필터링에 대한 자세한 내용은 결과 필터링 항목을 참조하십시오.

주: 그리드에 대해 Excel 스타일 필터링이 활성화된 경우 Grid|Filter Data가 비활성화됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Keep Focused Column in View

이 옵션을 선택하면 스크롤 막대를 사용하여 가로로 스크롤할 경우 원래 열이 시야에서 벗어나 스크롤되더라도 화면에 있는 열에 계속해서 포커스가 유지됩니다. 이 방식에서는 위로 또는 아래로 스크롤할 경우 가로 이동이 발생하지 않고 Data 그리드가 해당 위치를 유지합니다.

이 옵션을 선택하지 않으면 스크롤 막대를 사용하여 가로로 스크롤할 경우 포커스를 가진 열이 시야에서 벗어납니다. 위로 또는 아래로 스크롤할 경우 그리드가 가로로 이동하므로 포커스를 가진 열이 다시 보입니다.

이 옵션은 기본적으로 선택되어 있습니다.

Column Sizing

Size to header

이 옵션을 선택하면 모든 열의 크기가 열 머리글 너비에 맞게 조정됩니다. 따라서 데이터가 머리글보다 넓은 경우 잘립니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Size to data

이 옵션을 선택하면 모든 열의 크기는 열 머리글의 크기가 아니라 포함된 데이터의 너비에 맞게 조정됩니다. 따라서 테이블에서 가장 넓은 데이터도 볼 수 있습니다.

"Allow columns to be less than the header width"를 선택하지 않으면(아래 참조) 열은 열 머리글보다 좁아지지 않습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Allow columns narrower than header width

이 옵션을 선택하면 열을 열 머리글 너비보다 좁게 만들 수 있습니다. 따라서 화면에서 더 많은 데이터를 포함할 수 있습니다. 이 옵션을 선택하지 않으면 열은 포함된 데이터보다 좁혀질 수 있는 경우에도 열 머리글보다 좁혀지지 않습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Preview column height n

Preview 열에 포함된 줄 수를 변경합니다. 0부터 5 사이에서 추가 줄 수를 선택합니다.

기본값은 1입니다.

Display

Show Focus Rectangle

이 옵션을 선택하면 Data 그리드에서 항목을 선택한 다음 그리드 외부를 누를 경우 선택한 항목에 검정색 직사각형이 표시됩니다.

이 옵션을 선택하지 않으면 그리드 외부를 눌렀을 때 선택한 항목은 더 이상 선택되지 않거나 어떤 방식의 표시도 되지 않습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Show grid selection

이 옵션을 선택하면 Data 그리드에서 항목을 선택한 다음 그리드 외부를 누를 경우 항목이 강조표시된 상태로 유지됩니다.

이 옵션을 선택하지 않으면 그리드 외부를 누를 경우 선택한 항목이 더 이상 선택되지 않습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Show grid lines

이 옵션을 선택하면 results 그리드에서 데이터 주위에 그리드가 표시됩니다. 즉, 행과 열이 줄로 구분됩니다. 이 옵션을 선택하지 않으면 그리드 줄이 표시되지 않습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Grid line width n

이 옵션은 Data 그리드에서 행 사이의 줄 두께를 제어합니다. 측정 단위는 포인트입니다.

기본값은 1입니다.

Show row numbers

이 옵션을 선택하면 행 번호를 포함하는 열이 Data 그리드의 첫 번째 열로 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Use grid border color

이 옵션을 선택하면 행 번호는 그리드의 줄과 동일한 색으로 음영 처리됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Null columns

null 열이 표시되는 방법을 선택할 수 있습니다. 다음과 같은 옵션이 있습니다.

  • Blank - null 열이 빈 셀로 표시됩니다. 이 옵션이 기본값입니다.

  • {null} - null 열에 {null}이라는 단어가 포함됩니다.

  • Yellow - null 열이 노란색으로 표시됩니다.

Data font

이 영역에서 Grid를 누르면 Font Selection 대화 상자가 표시됩니다. 여기에서 글꼴을 변경하면 Preview 열 및 머리글을 제외한 전체 Data 그리드에 영향을 줍니다. 모든 Data 그리드는 동일한 글꼴을 가집니다. 기본값은 MS Sands Serif 8포인트입니다.

Data Background

드롭다운 메뉴에서 데이터의 배경색을 선택합니다. 이 선택 항목은 Toad 내의 모든 Data 그리드에 영향을 줍니다.

Header font

이 영역에서 Header를 누르면 Font Selection 대화 상자가 표시됩니다. 여기에서 글꼴을 변경하면 Data 그리드의 머리글에 표시되는 글꼴에만 영향을 줍니다. 기본값은 MS Sands Serif 8포인트입니다.

Header Background

드롭다운 메뉴에서 머리글의 배경색을 선택합니다. 이 선택 항목은 Toad 내의 모든 Data 그리드에 영향을 줍니다.

Preview Column font

이 영역에서 Font를 누르면 Font Selection 대화 상자가 표시됩니다. 여기에서 글꼴을 변경하면 Preview 열에 표시된 글꼴에만 영향을 줍니다.

기본값은 MS Sands Serif 8포인트입니다.

관련 항목

Data Grids - Data


데이터 형식

Data Types Options 페이지는 View|Toad Options|Data Types 항목을 통해 액세스합니다. 선택한 옵션은 Create Table 및 Alter Table 창에서 Data Types 드롭다운의 항목으로 표시됩니다.

형식은 Native Oracle Types 패널과 ANSI Types 패널에 나열됩니다. 각 패널에는 Select All 및 Select None 단추가 있습니다. 개별 형식을 선택하거나 선택 취소할 수 있습니다. 선택한 형식만 Table Data Types 드롭다운에 포함됩니다.

또한 다음에 대한 확인란이 있습니다.

Include Object Types (Oracle 8)

이 옵션은 Oracle 8 데이터베이스 이상에서 사용할 수 있습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Cache Object Type list per Connection

개체 유형 목록을 캐싱하면 create/alter table(또는 index) 화면을 열 때마다 Toad는 질의를 수행하여 DBA_TYPES에서 모든 항목을 로드할 필요가 없습니다. 이 캐시의 메모리 사용량이 크지 않아야 합니다. 약간의 새 개체 유형을 작성했으며 create table 화면에서 해당 형식을 사용하려는 경우 캐시를 수동으로 지울 수 있습니다. 세션이 끝나면 캐시가 자동으로 지워집니다.

Include Timestamp/Interval Types (Oracle 9i)

이 옵션은 Oracle 9i 데이터베이스 이상에서 사용할 수 있습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Include Byte/Char spec when creating DDL scripts from 9i databases

이 옵션은 Oracle 9i 데이터베이스 이상에서 사용할 수 있습니다. 예를 들어 SCOTT.EMP에서 생성된 스크립트는 다음과 같은 차이가 있습니다.

선택 | 선택 안 함
CREATE TABLE EMP ( EMPNO NUMBER(4), ENAME VARCHAR2(10 BYTE), JOB VARCHAR2(9 BYTE), MGR NUMBER(4), HIREDATE DATE, SAL NUMBER(7,2), COMM NUMBER(7,2), DEPTNO NUMBER(2) ) | CREATE TABLE EMP ( EMPNO NUMBER(4), ENAME VARCHAR2(10), JOB VARCHAR2(9), MGR NUMBER(4), HIREDATE DATE, SAL NUMBER(7,2), COMM NUMBER(7,2), DEPTNO NUMBER(2) )

이 옵션은 기본적으로 선택되어 있습니다.


DBA

View|Toad Options|DBA 메뉴 항목을 통해 이 창에 액세스합니다.

Tablespace Map

이 영역에서는 Tablespace Map 에서 사용되는 색을 수정하고 조각화 수준을 설정할 수 있습니다. 여러 조각화 수준을 추가할 수 있습니다.

새 조각화 수준을 추가하려면

  1. Add 를 눌러 새 조각화 수준을 추가합니다.

  2. fragmentation percentage 을 선택합니다. 상자에 숫자를 입력하거나 올바른 숫자가 나타날 때까지 위쪽 및 아래쪽 화살표를 눌러 선택할 수 있습니다. 세그먼트가 이 조각화 수준을 초과하거나 같은 셀은 선택한 색으로 표시됩니다.

  3. 드릴다운 [image] 단추를 눌러 세그먼트가 설정한 조각화 수준을 초과하거나 같은 셀을 강조표시할 색을 선택합니다. color selection 대화 상자가 나타납니다. 사용할 색을 누르고 OK를 누릅니다.

  4. OK 를 눌러 수준을 추가하고 Add Level 대화 상자를 닫습니다.

색 또는 조각화 수준을 편집하려면

  1. 색 선택 또는 조각화 수준을 편집하려면 변경할 항목을 누르고 Edit를 누릅니다.

  2. 조각화 수준을 선택한 경우 Add Level 대화 상자가 나타납니다.

  3. 다른 옵션을 선택한 경우 Color Selection 대화 상자가 표시됩니다.

  4. 원하는 대로 변경하고 OK를 누릅니다.

Delete

추가한 조각화 수준을 삭제할 수 있습니다. 최소한 하나 이상의 조각화 수준을 유지해야 합니다. 마지막 조각화 수준은 삭제할 수 없습니다.

조각화 수준을 삭제하려면

  • 삭제할 수준을 선택하고 Delete를 누릅니다.

경고가 표시되지 않고 조각화 수준이 목록에서 제거됩니다.

Show segment names on grid hint

이 상자를 선택하면 Tablespace Map 위에서 마우스를 실행할 경우 세그먼트 이름이 표시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Remember legend window state

Tablespace Map을 닫을 때 범례 창의 상태를 기억하려면 이 상자를 선택합니다. 이 상자를 선택하면 맵을 다시 열 때 범례가 마지막이었던 상태를 유지합니다(표시되거나 숨겨짐).

이 옵션은 기본적으로 선택되어 있습니다.

Remember segments window state

Tablespace Map을 닫을 때 세그먼트 창의 상태를 기억하려면 이 상자를 선택합니다. 이 상자를 선택하면 맵을 다시 열 때 세그먼트 창이 마지막이었던 상태를 유지합니다(표시되거나 숨겨짐).

이 옵션은 기본적으로 선택되어 있습니다.

Remember filters window state

Tablespace Map을 닫을 때 필터 창의 상태를 기억하려면 이 상자를 선택합니다. 이 상자를 선택하면 맵을 다시 열 때 필터 창이 마지막이었던 상태를 유지합니다(표시되거나 숨겨짐).

이 옵션은 기본적으로 선택되어 있습니다.

Confirm before overwriting Export/Import Files

이 옵션을 선택하면 Export 또는 Import를 수행할 때 파일을 덮어쓸지 묻는 메시지가 표시됩니다.

이 옵션을 선택하지 않으면 메시지가 표시되지 않고 파일을 덮어씁니다.

이 옵션은 기본적으로 선택되어 있습니다.

Refresh Instance Manager database version during every poll

이 옵션은 Instance Manager에서 데이터베이스를 폴링할 때마다 데이터베이스 버전을 질의하는지 여부를 결정합니다. 일반적으로 데이터베이스의 데이터베이스 버전이 변경되지 않으므로 검색된 후에 새로 고칠 필요가 없습니다. 그러나 이 옵션을 사용하면 데이터베이스 업그레이드 시에 데이터베이스 버전을 새로 고칠 수 있습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Chained row Schema Tablename

이 옵션을 사용하면 체인된 행의 테이블 이름을 상자에 입력하여 선택할 수 있습니다.

기본 테이블 이름은 CHAINED_ROWS입니다. 또한 체인된 행 복구를 참조하십시오.

주의: Chained Rows 테이블에서 Toad는 발견한 체인된 행의 행 ID를 저장하도록 Oracle에 지시합니다. 이 테이블은 분석해야 하는 테이블이 아닙니다. Toad에서는 목록의 테이블을 분석하기 전에 체인된 행 테이블을 자릅니다.


Debugger

주: 이 기능은 선택 사항인 Toad 기능이므로 선택 사항인 PL/SQL Debugger가 있는 상용 버전의 Toad에서만 사용할 수 있습니다.

모든 옵션 설정은 TOAD.INI가 저장되고 다음에 Toad를 열 때 복원됩니다.

Allow watches on package variables

패키지 변수를 조사하기 위한 Oracle Probe API 호출이 Oracle7 및 Oracle8 데이터베이스에서 다르게 작동하기 때문에 제공됩니다. Oracle7 데이터베이스에서는 패키지 변수에서 조사식을 추가하기 전에 프로시저를 한 단계씩 실행해야 합니다. Oracle8에서는 프로시저를 한 단계씩 실행하기 전이나 후에 패키지 변수에서 조사식을 설정할 수 있습니다. 패키지 변수를 검사하지 않으려면 이 옵션을 선택 취소합니다.

이 옵션은 기본적으로 선택되어 있습니다.

Enable Trace Output while debugging

Debugger가 실행되는 동안 추적 정보를 작성하므로 데이터베이스와의 Debugger 상호 작용을 디버깅하는 데 도움이 됩니다. 이 옵션은 일반적으로 선택되지 않으며 기술 지원 또는 DBA를 위해 사용됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Enable DBMS_OUTPUT before debug session

이 상자를 선택하면 DBMS_OUTPUT을 디버그 세션에 사용할 수 있게 됩니다. DBMS_OUTPUT 창을 볼 수 없고 DBMS output 데이터가 있을 경우 출력을 보려면 이 창을 열어야 합니다.

이 상자를 선택하지 않으면 DBMS_OUTPUT이 표시되지 않습니다.

이 옵션은 기본적으로 선택되어 있습니다.

또한 Debugger의 DBMS Output 창에서 이 옵션을 활성화/비활성화할 수 있습니다.

Break on exceptions

이 옵션을 선택하면 프로시저 예외(예: 0으로 나누기)가 발견될 경우 Debugger가 중지되고 메시지가 표시됩니다. 이 경우 예외 처리기 코드의 디버깅을 계속하거나 중지할 수 있습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Step through package initialization

패키지 변수가 포함된 패키지가 있을 경우 패키지에서 프로시저를 처음 실행하면 변수가 초기화됩니다. 이 옵션을 선택하면 Debugger는 변수가 선언 및 초기화된 코드 줄을 한 단계씩 실행합니다. 이 옵션을 선택하지 않으면 Debugger는 패키지 초기화를 한 단계씩 실행하지 않습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Step through SYS/SYSTEM procs

이 옵션을 선택하면 Debugger는 다른 스키마가 소유하는 PL/SQL 개체의 경우처럼 SYS 또는 SYSTEM이 소유하는 PL/SQL 개체를 한 단계씩 실행합니다.

이 옵션을 선택하지 않으면 Debugger는 항상 SYS 또는 SYSTEM이 소유하는 프로시저, 패키지 및 함수를 절차 단위로 실행합니다.

주: 사용자가 디버깅하는 주 프로시저가 아닌 경우 Oracle 8i Debugger에서는 SYS 또는 SYSTEM 프로시저를 한 단계씩 실행하지 않습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Notify when debugging terminated

이 옵션을 선택하면 디버깅 실행이 종료할 경우 실행이 종료되었다는 확인 메시지 상자가 표시됩니다. 이 옵션을 선택하지 않으면 디버깅 실행이 끝날 때 메시지가 표시되지 않습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Debugger

DBMS

이 옵션을 선택하면 Toad에서는 DBMS 디버깅 패키지를 사용합니다.

JDWP

이 옵션을 선택하면 Toad에서는 JDWP 디버깅 패키지를 사용합니다.

  • Host- JDWP에 사용되는 호스트를 입력합니다.

  • Port - Java 디버깅에 사용할 포트를 선택합니다.

  • Allow stepping into Java Source - 이 옵션을 선택하면 Java 소스를 한 단계씩 실행할 수 있습니다. 이 옵션을 선택하지 않으면 Java 소스가 실행되지만 한 단계씩 실행되지는 않습니다.

Script

이 옵션을 선택하면 Toad에서는 내부 스크립트 디버깅 기능을 사용합니다.

Transaction Control

다음 단추를 사용하면 Toad가 Editor에서 트랜잭션을 처리하는 방법을 선택할 수 있습니다.

  • Commit – Debugger에서 코드를 실행하거나 디버깅하는 데 사용되는 익명 블록에 COMMIT 문이 추가됩니다. 트리거는 기본적으로 롤백되지 않으며 이 옵션의 설정을 따릅니다.

  • Rollback – Debugger에서 코드를 실행하거나 디버깅하는 데 사용되는 익명 블록에 ROLLBACK 문이 추가됩니다.

  • Prompt – Debugger에서 코드 실행/디버깅이 끝나면 "Commit changes to debug session?"라는 질문이 표시됩니다. 커밋하려면 Yes를, 롤백하려면 No를 선택합니다.

기본값은 Commit입니다.

주: 개체에 고유한 롤백/커밋이 있을 경우 Debugger는 마지막 커밋이 수행된 후에 수행된 작업만 롤백하거나 커밋할 수 있습니다.

Compile Dependencies Yes/No/Prompt

디버깅이 시작되기 직전에 디버그 정보를 사용하여 사용자의 프로시저에 의해 호출된 프로시저를 조건부로 컴파일합니다.

  • YES이면 디버그 정보를 사용하여 프로시저에서 호출하는 모든 프로시저를 컴파일합니다.

  • NO이면 디버그 정보를 사용하여 이러한 프로시저를 컴파일하지 않습니다.

  • PROMPT이면 매번 디버깅하기 전에 메시지를 표시합니다.

기본값은 Prompt입니다.

Enable DBMS_JAVA Output while debugging

Default Buffer size

DBMS_Java 출력이 활성화된 경우 버퍼 크기를 선택합니다. 기본값은 20000입니다.

Display

이 영역을 사용하여 디버깅 항목이 표시되는 방법을 지정할 수 있습니다. 왼쪽의 상자에서 항목을 선택한 다음 해당 개체의 전경색과 배경색을 지정합니다.

Debug session timeout (in seconds) 상자

이 옵션은 디버그 정보를 사용하여 Debugger에서 데이터베이스가 응답하기를 기다리는 시간을 제한합니다. 초 단위로 입력할 수 있습니다.

느린 데이터베이스, 느린 네트워크 또는 모뎀 연결의 경우에는 시간을 늘립니다.

기본값은 180초입니다.

Date format for Watches 드롭다운 목록

조사된 변수에 대한 날짜 형식을 선택할 수 있습니다. 옵션은 DD/MON/YY, MON/DD/YY 및 MON/DD/YYYY입니다.

기본값은 DD/MON/YY입니다.

주: 날짜 형식은 Toad 세션/연결에 대한 NLS DATE FORMAT에 영향을 주지 않습니다. Debugger 세션에만 영향을 줍니다.


Editor - Behavior

General

Apply commit/rollback to all tabs (threaded queries)

이 옵션을 선택하면 Editor의 모든 커밋 또는 롤백 선택 항목이 활성 탭뿐만 아니라 모든 탭에 적용됩니다. 이 옵션을 선택하지 않으면 커밋과 롤백이 활성 탭에만 적용됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Auto Indent

이 옵션을 선택하면 첫 번째 줄을 들여쓸 경우 이후 줄이 자동으로 들여쓰기됩니다. Optimal fill 및 Tab Stop 설정과 함께 이 옵션을 사용하여 들여쓰기를 작성하는 방법을 지정할 수 있습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Backspace Unindent

이 옵션을 선택하면 백스페이스를 사용하여 선택 항목을 내어쓰기할 수 있습니다. 이 옵션을 선택하지 않으면 백스페이스 키를 누를 경우 선택한 텍스트가 삭제됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Block Select

이 옵션을 선택하면 마우스로 주위에 상자를 끌어 화면에서 텍스트 블록을 선택할 수 있습니다.

이 옵션을 선택하지 않으면 텍스트 선택은 표준 방식으로 작동합니다.

이 옵션은 기본적으로 선택되어 있습니다.

Clear Grid on editor clear

이 옵션을 선택하면 Edit 메뉴 또는 <F7> 키를 사용하여 그리드를 지울 경우 query 그리드도 지워집니다.

주: 모든 텍스트를 선택하고 DELETE 또는 BACKSPACE 키를 누르거나 CUT 작업을 수행할 경우 그리드가 지워지지 않습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Collapse empty lines

이 옵션을 선택하면 화면 공간을 절약하기 위해 빈 텍스트인 모든 줄이 축소됩니다. 이 옵션을 선택하지 않으면 이러한 빈 줄이 표시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Confirm Clear All Text

이 옵션을 선택하지 않으면 F7 키를 눌러 Editor 창에서 확인 대화 상자 없이 모든 텍스트를 지울 수 있습니다.

이 옵션을 선택하면 F7 키와 Edit 메뉴에서 Clear All은 확인 메시지를 표시합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Copy text in rich text format

이 옵션을 선택하면 텍스트를 복사할 때 서식이 유지되고 텍스트가 RTF 형식으로 붙여넣기됩니다. 이 옵션을 선택하지 않으면 모든 서식이 제거되고 선택한 코드가 일반 텍스트로 붙여넣기됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Cursor beyond end of line

이 옵션을 선택하면 커서는 줄 끝을 지나 확장될 수 있습니다. 블록을 원하는 대로 크게 만들 수 있으므로 이 기능은 특히 block select 옵션을 사용할 때 유용합니다. 이 옵션을 선택하지 않으면 선택한 첫 번째 섹션의 끝을 지나 선택 항목이 확장되지 않습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Double click line select

이 옵션을 선택하면 줄을 두 번 눌러 선택할 수 있습니다. 이 옵션을 선택하지 않으면 마우스를 끌어 전체 줄을 선택해야 합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Enable code folding

이 옵션을 선택하면 코드 폴딩이 활성화됩니다. 그런 다음 코드를 원하는 대로 쉽게 축소하거나 확장할 수 있도록 코드의 측면에 노드가 표시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Find text at cursor

이 옵션을 선택하면 Find and Replace 대화 상자를 열었을 때 현재 커서 아래에 있는 단어를 자동으로 찾습니다. 이 옵션을 선택하지 않으면 최근에 검색한 단어가 기본값이 됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Group redo/undo

이 옵션을 선택하면 키 입력 그룹에서 텍스트 변경 내용이 다시 실행되거나 실행 취소됩니다. 그룹은 캐리지 리턴으로 표시되거나 입력에서 백스페이스로의 변경을 통해 표시됩니다.

이 옵션을 선택하지 않으면 항목은 한 번에 하나씩 다시 실행되거나 실행 취소됩니다.

이 두 옵션은 기본적으로 선택되어 있지 않습니다.

Hide cursor when typing

이 옵션을 선택하면 입력할 때 커서가 숨겨집니다. 입력을 중지하고 마우스를 움직이면 커서가 다시 나타납니다.

이 옵션을 선택하지 않으면 커서를 항상 볼 수 있습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Load Snippets/MakeCode from network server

이 옵션을 선택하면 사용자 파일이 아니라 네트워크 서버에서 코드 조각이 로드됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Scroll past last line

이 옵션을 선택하면 editor의 마지막 줄이 editor의 맨 위가 될 때까지 스크롤할 수 있습니다.

이 옵션을 선택하지 않으면 editor에서 마지막 줄이 보일 때 스크롤이 중지됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Preload objects on "Load Object from DB" window

이 옵션을 선택하면 Object Type 필터를 무시하고 모든 개체 유형의 모든 개체가 바로 표시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Treat underscore char as part of object name

이 옵션을 선택하면 모든 "_" 밑줄 문자가 개체 이름의 일부로 간주됩니다. 개체 이름을 자주 두 번 누를 경우 이 기능이 유용할 수 있습니다. 이 옵션을 선택하면 ALL_TAB_COLUMNS와 같은 이름이 강조표시됩니다. 이 옵션을 선택하지 않으면 누른 단어만 강조표시됩니다(예: COLUMNS).

이 옵션은 기본적으로 선택되어 있지 않습니다.

Use lower case object names from select windows

이 옵션을 선택하면 선택한 열 이름이 editor에서 소문자로 반환됩니다. 이 옵션을 선택하지 않으면 대문자로 반환됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

주: 대문자 개체 이름만 이 옵션을 따릅니다. 이 옵션에 상관없이 대/소문자 혼합 및 소문자 개체 이름은 대/소문자가 변경되지 않습니다.

  • 물론 소문자 개체 이름은 이미 소문자로 되어 있습니다.

  • 대문자 이름이 소문자로 Oracle에 제출되어 대문자로 자동 해석되는 것과는 달리 대/소문자 혼합 이름은 큰따옴표로 묶고 대/소문자가 정확해야 합니다.

Use lower case object names from select windows

이 옵션을 선택하면 select 창에서 반환되는 개체 이름이 소문자로 표시됩니다(개체 이름에 대/소문자가 혼합되지 않은 경우).

이 옵션을 선택하지 않으면 개체 이름이 개체에 입력한 대로 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Use single Editor instance for PL/SQL if possible

Toad는 Editor 외부에서 PL/SQL이 로드될 경우 PL/SQL이 포함된 Editor를 찾으려고 시도할 수 있습니다.

이 경우 열려 있는 모든 Editor를 순환하여 PL/SQL이 포함된 Editor를 찾습니다. Editor가 발견되면 해당 Editor가 사용됩니다. 포함되어 있는 프로시저, 함수, 패키지, 패키지 본문, 형식, 형식 본문, 트리거 또는 Java 소스 개체를 파서에서 성공적으로 식별한 경우 Editor에 PL/SQL이 존재하는 것으로 확인됩니다. 여러 Editor 창에 PL/SQL이 포함된 경우 처음 발견된 창이 선택됩니다. Editor가 발견되지 않은 경우 새 Editor 창이 열립니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Word wrap

이 옵션을 선택하면 editor는 긴 줄에서 자동 줄 바꿈을 사용하므로 텍스트가 다음 줄로 줄 바꿈됩니다.

이 옵션을 선택하지 않으면 editor에서 모든 텍스트가 하나의 긴 줄로 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Word break on right margin

word wrap을 선택한 상태에서 이 옵션을 선택하면 줄이 너무 길면 오른쪽 여백(editor에서 연한 회색 줄)에서 줄 바꿈됩니다. 이 옵션을 선택하지 않으면 줄은 editor의 끝에서 줄 바꿈됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Tabs

Mode

탭에 사용할 모드를 선택합니다(spaces, tabs 또는 smart tab).

기본값은 Spaces입니다.

Tab Stops

사용할 탭 정지 수를 선택합니다.

기본값은 4입니다.

Optimal fill

이 옵션을 선택하면 필요에 따라 탭과 공백을 사용하여 가능한 최소한의 문자 수로 모든 자동 들여쓰기된 줄을 시작합니다.

이 옵션을 선택하지 않으면 필요한 위치에 커서를 이동할 수 있도록 충분한 공백을 사용하여 모든 자동 들여쓰기된 줄을 시작합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Block indent

block indent 명령을 사용할 경우 들여쓰기에 사용할 공백 수를 입력합니다. 기본값은 3입니다.

Code Templates Shortcut

Code Templates에 액세스하는 데 사용할 바로 가기를 입력합니다.

Languages

Languages 영역에서는 Toad editor의 언어 파서를 변경할 수 있는 language management 창에 액세스할 수 있습니다. Language Management 개요를 참조하십시오.

Key Mapping

다양한 editor 명령에 대한 바로 가기 키를 선택하려면 Key Mapping 단추를 누릅니다.

Auto Replace

자동 바꾸기의 옵션을 설정하려면 Auto Replace 단추를 누릅니다. 제공된 그리드를 사용하면 키 입력과 해당 키 입력이 대체되는 텍스트를 지정할 수 있습니다. 예를 들어 모든 "teh"를 "the"로 자동으로 대체하도록 선택할 수 있습니다. 변경과 추가가 끝나면 OK를 눌러 options 페이지로 돌아갑니다.


Editor - Code Assist

Make Code

도구 모음에서 Make Code를 선택할 경우 사용되는 언어를 변경할 수 있습니다. 또한 Editor에서 사용하기 위한 고유한 언어 템플릿을 작성할 수 있습니다.

MakeCode format 목록

이 목록에서는 Toad에서 SQL 문을 언어 구문으로 변환(Make Code Statement 기능)하거나 언어 구문에서 변환(Strip Code Statement 기능)할 때의 언어 구문을 선택할 수 있습니다. 현재는 Delphi, VB, C++, Java 및 Perl이 자동으로 지원됩니다.

기본값은 VB입니다.

MakeCode Variable Name

MakeCode 명령에 사용할 변수 이름을 입력합니다. 기본값은 SQL입니다.

MakeCode 언어 작성 및 편집

Toad에서 자동으로 제공하는 것보다 많은 언어 사이를 전환할 수 있도록 고유한 템플릿을 작성하거나 Make Code 명령으로 고유한 템플릿을 변경할 수 있습니다. 템플릿은 Code Snippets 옵션과 함께 templates.xml 파일에 저장됩니다. Make Code 언어의 예는 Creating_Make_Code_Templates를 참조하십시오.

고유한 언어 템플릿을 작성하려면

  1. Options 페이지에서 Editor|Make Code를 선택합니다.

  2. Add를 누릅니다.

  3. Name 상자에 템플릿의 이름을 입력합니다.

주: Toad에서는 이 이름에 기본 언어 이름을 사용하지만 동일한 언어에 대한 약간 다른 템플릿을 만들려면 원하는 이름을 지정할 수 있습니다.

  4. 사용할 이스케이프 문자(있을 경우)를 입력합니다.

  5. 사용하는 언어에 필요한 구분 기호를 입력합니다.

  6. Make Code 템플릿 작성에 설명된 대로 언어 템플릿에 대한 코드를 입력합니다.

언어 템플릿을 편집하려면

  1. Options 페이지에서 Editor|Make Code를 선택합니다.

  2. Edit를 누릅니다.

  3. 변경을 수행하고 OK를 누릅니다.

Select Statement based on cursor position

이 옵션을 선택하면 코드가 구문 분석되고 커서 위치에 있는 문이 선택됩니다.

Strip Code copies to clipboard

이 옵션을 선택하면 코드를 제거하도록 선택할 경우 제거하는 코드가 클립보드에 복사되므로 작업을 쉽게 실행 취소할 수 있습니다. 추가 문을 제거하거나 클립보드에 데이터를 복사하는 다른 작업을 수행할 경우 코드를 덮어씁니다. 즉, 최신 작업만 저장됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Code Snippets

Code Snippets 영역을 사용하여 코드 조각을 추가, 편집 또는 제거할 수 있습니다.

코드 조각을 유지 관리하는 방법에 대한 자세한 내용은 Editors|Code Snippets를 참조하십시오.

Toad Insight

Ctrl-Click package/type procedure jumps to body

이 옵션을 사용하면 패키지 또는 형식 스펙에서 <CTRL><Click> 기능을 활성화할 수 있습니다. 이 바로 가기 키를 사용하면 선택한 패키지, 형식 또는 프로시저의 본문으로 직접 이동할 수 있습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Display parameter hints after typing open paren "("

이 옵션을 선택하면 코드에 매개 변수를 입력할 때 첫 번째 괄호 "("를 입력할 경우 설명된 대로 매개 변수에 대한 힌트가 표시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Display pick list after typing object name followed by a period

이 옵션을 선택하면 columns 드롭다운 목록이 표시됩니다. 이 옵션을 선택하지 않으면 columns 드롭다운 목록이 표시되지 않습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Sort alphabetically

이 옵션을 선택하면 columns 팝업이 알파벳 순서대로 정렬됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Delay for popups ... milliseconds

이 옵션을 사용하여 팝업 힌트가 표시되기 전에 기다려야 하는 시간(밀리초)을 선택할 수 있습니다.

기본값은 1500밀리초입니다.

SQL Recall

Save only valid statements

이 옵션을 선택하면 유효한 SQL 문만 SQL Recall 영역에 저장됩니다. 이 옵션을 선택하지 않으면 유효하거나 유효하지 않은 모든 SQL 문이 저장됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Statements to save:

Toad에서 SQL Recall에 저장해야 하는 문 수를 입력합니다. 문 수가 이 숫자를 초과할 경우 새 문이 추가되면 가장 오래된 문이 삭제됩니다.

기본값은 100입니다.

Write statements to disk prior to execution

이 옵션을 선택하면 SQL 문을 실행하기 전에 디스크에 SQL 문이 기록됩니다. 따라서 SQL 문을 유지할 수 있으며 실행에 문제가 있을 경우 SQL 문을 회수할 수 있습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.


Editor - Display

General

Highlight execution line when not debugging

이 옵션을 선택하면 실행할 줄이 실행될 때 강조표시됩니다. 코드를 한 단계씩 실행할 때 이 기능이 매우 유용합니다. 이 옵션을 선택하지 않으면 전체 줄을 강조표시하지 않고 실행이 발생합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Lock results tab

이 옵션을 선택하면 editor 탭 사이에서 활성 results 탭이 활성 상태로 유지됩니다.

이 옵션을 선택하지 않으면 각 editor 탭은 다른 활성 results 탭을 가질 수 있습니다.

예를 들면 다음과 같습니다.

두 개의 탭이 있는 Editor를 열었습니다. 탭 1에서 Data Grid results 탭을 활성화하고 탭 2로 전환하여 DBMS Output results 탭을 활성화합니다.

  • Lock Results Tab을 선택한 경우 탭 1로 전환하면 DBMS Output results 탭이 포커스가 있는 탭으로 잠겨 있으므로 활성 상태를 유지합니다.

  • Lock Results Tab을 선택하지 않은 경우 탭 1로 전환하면 Data Grid 탭이 마지막 사용한 탭 1의 results 탭이기 때문에 활성 상태가 됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Persist display of execution time

이 옵션을 선택하면 상태 표시줄의 맨 왼쪽 영역에 마지막 실행한 질의의 실행 시간이 표시됩니다. 이 옵션을 선택 취소하면 editor에서 캐럿 위치가 변경될 때까지 실행 시간이 표시됩니다. 이 때 표시는 실행 시간에서 캐럿의 LINE:COL 위치로 변경됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Persist dynamic highlighting when not focused

이 옵션을 선택하면 Toad 내에서 다른 패널이나 창으로 포커스를 이동할 때 동적 강조표시가 유지됩니다.

이 옵션을 선택하지 않으면 강조표시된 코드를 적극적으로 사용하지 않을 때 동적 강조표시가 적용되지 않습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Persist selection when not focused

이 옵션을 선택하면 Toad 내에서 다른 패널이나 창으로 포커스를 이동할 때 선택한 코드가 강조표시된 상태로 유지됩니다.

이 옵션을 선택하지 않으면 코드를 적극적으로 사용하지 않을 때 선택한 코드가 강조표시되지 않습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Persist selection when using navigation keys

이 옵션을 선택하면 화살표 키를 사용하여 탐색할 때 선택한 코드가 강조표시된 상태로 유지됩니다.

이 옵션을 선택하지 않으면 화살표 키를 사용하여 탐색할 때 선택한 코드가 강조표시되지 않습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Show word wrap indicator

이 옵션을 선택하면 editor에서 다음 줄로 줄 바꿈된 줄의 끝에 시각적 표시기(화살표)가 표시됩니다.

이 옵션을 선택하지 않으면 표시기가 없습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Show control characters

이 옵션을 선택하면 제어 문자(예: 공백, 탭, 캐리지 리턴 등)가 코드 내에서 표시됩니다.

이 옵션을 선택하지 않으면 제어 문자가 표시되지 않습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Show current line focus rectangle

이 옵션을 선택하면 PL/SQL 탭에서 포커스가 있는 코드 줄의 주위에 직사각형이 표시됩니다.

이 옵션을 선택하지 않으면 직사각형이 표시되지 않습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Show executable line indicators in gutter

이 옵션을 선택하면 실행 가능 코드가 있는 줄의 거터에 파란색 점이 표시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Show line numbers

이 옵션을 선택하면 코드의 왼쪽에 줄 번호가 표시됩니다. 이 옵션을 선택하지 않으면 줄 번호가 표시되지 않습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Show results tab toolbars

이 옵션을 선택하면 results 탭에 있는 모든 도구 모음이 표시됩니다. 이 옵션을 선택하지 않으면 이러한 도구 모음이 표시되지 않습니다.

이 옵션을 선택하면 Debug 창에 도구 모음이 표시됩니다. Debug 창에서 도구 모음을 숨기려면 이 옵션을 선택 취소합니다.

예를 들어 Editor Data Grid 탭에는 VCR 스타일 탐색 모음이 있는 도구 모음이 있으며 이 옵션이 따라 이 도구 모음이 표시되거나 숨겨집니다.

이 옵션은 기본적으로 선택되어 있습니다.

Use multi-line editor tabs

이 옵션을 사용하면 모든 탭이 하나의 줄에 표시되는지(선택하지 않은 경우) 아니면 탭 목록이 너무 넓어서 창에 맞지 않는 경우 여러 행에 표시되는지(선택한 경우) 여부를 선택할 수 있습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Syntax Highlighting

Highlight table names

이 옵션을 선택하면 구문 강조표시 기능을 사용하여 테이블 이름을 Editor 창과 다른 editor에서 표시합니다. 이 옵션을 선택하지 않으면 테이블 이름은 검정색 텍스트로 표시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Highlight view names

이 옵션을 선택하면 보기 이름이 강조표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Highlight stored procedure names

이 옵션을 선택하면 저장 프로시저 이름이 강조표시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Use when printing

이 옵션을 선택하면 구문 강조표시가 인쇄됩니다.

이 옵션을 선택하지 않으면 코드가 일반 텍스트로 인쇄됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Fonts

Line number

줄 번호 표시의 글꼴을 설정하려면 이 옵션을 사용합니다.

Hex font

hex editor에서 가운데(hex) 열의 글꼴을 설정하려면 이 옵션을 사용합니다.

Offset font

hex editor에서 맨 왼쪽(offset) 열의 글꼴을 설정하려면 이 옵션을 사용합니다.

Text font

hex editor에서 맨 오른쪽(text) 열의 글꼴을 설정하려면 이 옵션을 사용합니다.

Gutter and Margin

표시되는 거터와 오른쪽 여백의 너비와 위치를 설정하려면 이 옵션을 사용합니다.

Visible gutter width:

표시되는 거터에서 코드 왼쪽까지의 너비를 지정합니다. 기본값은 50입니다.

Visible right margin position:

코딩 영역을 더 넓게 또는 좁게 만들기 위해 화면의 오른쪽 여백 위치를 지정합니다.

기본값은 80입니다.

Background Color

editor에서 창의 배경색을 설정합니다. 기본 Windows 설정 중에서 선택하거나 고유한 색 구성표를 지정할 수 있습니다.

기본값은 Windows의 창 배경 설정에 해당하는 창 배경입니다.

Hex Editor Bytes per line: n

각 줄마다 표시되는 바이트 수를 지정하려면 이 옵션을 사용합니다.

기본값은 20입니다.


Editor - Open/Save

Opening Files

파일 분할은 하나의 파일에 여러 PL/SQL 개체를 가진 사용자를 고려하여 설계되었습니다. 이 기능을 사용하면 하나의 파일에서 여러 개체를 로드하고 패키지 스펙과 본문을 하나의 파일에 저장할 수 있습니다.

파일이 로드될 경우 procedure editor는 둘 이상의 PL/SQL 개체가 파일에서 작성되는지 확인합니다. 둘 이상의 PL/SQL 개체가 작성될 경우 procedure editor는 아래 나열된 옵션 중에서 설정된 옵션에 따라 작업을 수행합니다.

기본값은 Prompt to split files입니다.

Automatically split files when multiple objects separated by "/"

이 옵션은 "/"가 있을 경우 파일을 자동으로 분할합니다. Toad에서는 사용자가 다른 개체를 다른 탭으로 분할하기를 원한다고 가정합니다.

슬래시로 구분된 각 섹션이 별개의 탭에 놓입니다. 패키지가 아닌 파일을 로드하여 편집할 경우(예: Syntax Highlighting에 설명된 대로 editor를 사용하여 HTML 파일을 편집할 경우) 이 작업이 어려울 수 있습니다.

Toad에서 분할한 파일을 저장하는 방법에 대한 자세한 내용은 아래의 Save to separate files after splitting을 참조하십시오.

Prompt to split files

이 옵션을 선택하면 파일을 별개의 탭으로 분할할지 묻는 메시지가 표시됩니다. 파일을 분할하는 것이 권장되지만 파일을 하나로 유지하도록 프롬프트에서 선택할 수 있습니다.

주: 파일을 분할하지 않을 경우 컴파일이 비활성화됩니다.

Never split files

이 옵션을 선택하면 파일이 항상 하나의 탭에 로드되고 본문과 스펙으로 분할되지 않습니다.

주: 이 옵션은 컴파일을 비활성화합니다.

Saving Files

패키지 스펙 및 본문이 둘 다 데이터베이스에서 procedure editor로 로드될 경우 사용자가 파일에 저장하도록 선택하면 Toad의 동작은 다음 옵션에 따라 달라집니다.

스펙 또는 본문 중 하나만 로드될 경우 로드되는 개체만 파일에 저장됩니다.

기본값은 Never combine spec/body입니다.

Automatically combine spec/body when saving object to file

스펙과 본문을 동일한 파일에 저장합니다.

Prompt to combine spec/body

파일을 닫을 때마다 메시지를 표시합니다.

Never combine spec/body

현재 탭에 있는 개체만 저장합니다.

Use file splitting tags "/* <toad_file_chunk */"

이 옵션을 사용하면 분할된 파일을 하나의 파일에 다시 저장할 수 있습니다. 파일이 분할된 위치에 태그가 remark로 삽입되므로 나중에 별개의 탭에 파일을 쉽게 다시 분할할 수 있습니다. 따라서 파일을 단일 파일로 저장할 수 있지만 여전히 Toad 내에서 컴파일하고 별개의 탭으로 작업할 수 있습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Save to separate files after splitting

파일을 여러 탭으로 분할하도록 선택한 경우 Toad에서 파일을 처리하는 방법은 분할 후 파일을 분리하는 이 옵션에 따라 달라집니다.

  • 선택하지 않을 경우: 원래 파일 이름을 유지하고 파일 내용을 별개의 탭에 로드하므로 개체당 하나의 탭이 존재합니다. 그런 다음 Toad에서는 모든 탭이 동일한 파일과 연관된다는 사실을 추적합니다. "Toad file splitting tags(위 옵션 참조)"를 사용할지 여부를 선택할 수 있습니다. "Toad file splitting tags"를 사용하지 않을 경우 줄에 있는 모든 단일 "/" 자체가 개체를 구분하는 것으로 간주됩니다.

  • 선택할 경우: 파일 내용을 별개의 탭으로 분할하므로 개체당 하나의 탭이 존재하지만 탭을 파일 이름과 연관시키지 않습니다. 따라서 사용자가 탭을 저장할 때 파일 이름을 지정할 수 있습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

File Loading/saving

Prompt for reload on activation if timestamp has changed

이 옵션을 선택하면 외부 편집기에서 편집이 허용됩니다. 파일이 포함된 Editor 창이 다시 활성화될 경우(포커스를 가질 경우) Toad에서는 파일의 날짜 스탬프를 검사하여 외부 프로그램에 의해 수정되었는지 확인합니다. 파일이 수정된 경우 파일 날짜/시간이 변경되었다는 것을 알리고 파일을 다시 로드할지 묻는 프롬프트 대화 상자가 표시됩니다. Yes를 선택하면 파일이 다시 로드됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Prompt to save on editor close

이 옵션을 선택하면 editor에서 입력한 모든 텍스트를 저장할지 묻는 메시지가 표시됩니다.

주: 이 옵션을 선택 취소한 경우에도 로드 및 수정된 파일은 항상 내용을 저장할지 묻는 메시지를 표시합니다.

이 옵션은 기본적으로 선택되어 있습니다.

Format files when opened

이 옵션을 선택하면 Toad의 기본 제공 서식 기능을 사용하여 Editor에서 열린 모든 파일의 형식을 자동으로 지정합니다. View|Formatting Options 창을 사용하여 형식을 사용자 정의할 수 있습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Object Loading

Owner Name

개체를 나열할 때 소유자 이름을 포함하려면 선택합니다.

  • Always include - 소유자 이름을 항상 자동으로 포함합니다(예: JSMITH.TABLENAME). 기본값입니다.

  • Never include - 소유자 이름을 자동으로 포함하지 않습니다(예: TABLENAME).

  • Include on loads from other schemas - 개체를 다른 스키마에서 로드할 경우에만 소유자 이름을 자동으로 포함합니다.

Packages/Types

Load Spec and Body as pair (Package or User Type)

이 옵션을 선택하면 패키지 또는 형식 스펙이나 본문을 Editor에 로드할 경우 연관된 스펙 또는 본문도 로드됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Separate Tabs

이 옵션을 선택하면 스펙과 본문이 별개의 탭에 로드됩니다. 이 옵션을 선택하지 않으면 연관된 스펙이나 본문이 동일한 탭에 로드됩니다.

이 옵션은 기본적으로 선택되어 있습니다.


Editor - Printing

Printing 옵션을 사용하여 Editor 내용이 인쇄되는 방법을 지정할 수 있습니다.

옵션

Word wrap

이 옵션을 선택하면 Editor에 입력한 텍스트가 여백에 도달했을 때 다음 줄로 줄 바꿈됩니다.

이 옵션을 선택하지 않으면 텍스트가 줄 바꿈되지 않지만 줄 코드의 끝(줄 바꿈, 캐리지 리턴 등)에 도달할 때까지 동일한 줄에 있습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Hide collapsed

이 옵션을 선택하면 축소된(폴딩된) 텍스트가 인쇄되지 않습니다.

이 옵션을 선택하지 않으면 모든 텍스트가 인쇄됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Transparent

이 옵션을 선택하면 Language Management|Highlighting에서 줄 강조표시를 선택한 경우 강조표시가 인쇄되지 않습니다.

이 옵션을 선택하지 않으면 줄 강조표시가 인쇄됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Colors

인쇄하는 데 사용할 색 구성표로 RGB (color), Gray-scale 또는 black and white를 선택합니다.

기본값은 RGB입니다.

Line Numbers

줄 번호를 인쇄할지 여부와 줄 번호를 배치해야 하는 위치를 선택합니다.

기본값은 None입니다.

Fonts

Fonts 영역을 사용하여 Editor 인쇄물의 특정 부분에 대한 인쇄 글꼴을 설정할 수 있습니다.

  • Header - 머리글 인쇄를 위한 글꼴을 설정합니다.

  • Footer - 바닥글 인쇄를 위한 글꼴을 설정합니다.

  • Line Numbers - 줄 번호 인쇄를 위한 글꼴을 설정합니다.

Header and footer

이 영역을 사용하여 Editor 내용을 인쇄할 때 인쇄할 머리글 또는 바닥글을 설정할 수 있습니다. 태그를 포함하여 특정 항목을 포함해야 한다는 것을 지정할 수 있습니다.

이러한 태그는 다음과 같습니다.

  • #page# - 페이지 번호를 포함합니다.

  • #title# - 파일 이름을 포함합니다.

  • #date# - 날짜를 포함합니다.

  • #time# - 시간을 포함합니다.

  • #datetime# - 날짜와 시간을 모두 포함합니다.

머리글과 바닥글은 모두 여러 줄을 포함할 수 있으며 \User Files 폴더의 EditorHeader.txt 및 EditorFooter.txt에 저장됩니다.

기본적으로 머리글은 #title#을 포함하고 바닥글 #datetime# 및 페이지 #page#를 포함합니다.


전자 메일

Email Settings

이 옵션 페이지에서 전자 메일 알림을 허용하는 다양한 Toad 도구 및 관리자에 대한 전자 메일 옵션을 전역적으로 설정합니다. 이러한 도구와 관리자는 다음과 같습니다.

  • Instance Manager

  • Database Health Check

  • Database Monitor

  • Rebuild Multiple Indexes

  • Compare Schemas

Global Settings

이러한 설정은 모든 전자 메일 창에 적용할 수 있습니다. 여기에 SMTP 서버 정보와 사용자 이름을 입력합니다. 기본 포트 번호는 25입니다. 사용하는 포트가 표준 포트와 다른 경우 변경할 수 있습니다. 암호가 필요한 경우 해당 사항을 선택한 후 암호를 입력할 수도 있습니다.

또한 구성한 설정을 테스트하기 위해 테스트 전자 메일을 보낼 수 있습니다.

테스트 메일을 보내려면

  1. 전자 메일 설정을 입력합니다. 모든 필수 필드(*)를 입력해야 합니다.

  2. Send Test Mail 단추를 누릅니다. Toad는 테스트 메일을 보내거나 보낼 수 없었던 이유를 알려줍니다.

Window Settings

설정을 선택하려면

  1. Windows 상자에서 조정할 Toad 창을 누릅니다. 예를 들어 Health Check을 누릅니다. Health check이 강조표시되고 나머지 상자에는 Health Check 창에 대한 옵션이 표시됩니다.

  2. Subject 및 From Name 상자에는 기본 항목이 있습니다. 이러한 항목을 변경할 수 있습니다.

  3. Reply To 주소와 From Address를 입력해야 합니다.

  4. Normal에서 우선 순위를 변경할 수도 있습니다.

받는 사람을 추가하려면

전자 메일 주소를 To, CC 또는 BCC 상자에 추가할 수 있습니다..

  1. "+"(더하기) 단추를 누릅니다.

또는

키보드에서 <Insert> 키를 누릅니다. Add Recipient 대화 상자가 나타납니다.

  2. 주소를 입력하고 OK를 누릅니다. 주소가 나타납니다.

받는 사람을 삭제하려면

  1. To, CC 또는 BCC 상자에서 하나 이상의 전자 메일 주소를 강조표시하고 "-"(빼기) 단추를 누릅니다.

또는

키보드에서 Delete 키를 누릅니다. 확인 대화 상자가 나타납니다.

  2. Yes를 누르면 주소가 제거됩니다.

설정을 복사하려면

하나의 창에서 다른 창으로 모든 설정을 복사할 수 있습니다.

  1. Window 상자에서 해당 설정이 있는 창 이름을 선택합니다.

  2. 이러한 설정을 할당할 창 이름으로 끕니다. 확인 대화 상자가 나타납니다.

  3. 창이 올바른 경우 Yes를 눌러 설정을 복사합니다. 이렇게 하면 제목 줄을 제외한 모든 설정이 복사됩니다.

또한 To:, CC: 또는 BCC: 상자 사이에서 받는 사람 주소를 누른 다음 끌어서 복사할 수 있습니다.

설정을 복제하려면

하나의 창에서 전자 메일 설정이 필요한 다른 모든 창으로 제목을 제외한 모든 설정을 복사할 수 있습니다.

  • Toad Options|Email Settings 페이지에서 Clone Settings를 누릅니다. 확인 대화 상자가 나타납니다.


Executables

이 페이지는 View|Toad Options|Executables 메뉴 항목에서 액세스합니다.

이 페이지에는 다음 실행 파일의 경로에 대한 상자가 포함되어 있습니다.

  • SQL*Plus

  • SQL*Loader

  • Import(Import Utility 마법사에서 사용됨)

  • Export(Export Utility 마법사에서 사용됨)

  • TKProf

  • TNS Ping(Database Monitor 창에서 사용됨)

  • Wrap

  • Export Pump

  • Import Pump

  • Ping(Database Monitor 창에서 사용됨)

  • Editor(외부 편집기)

find 아이콘을 눌러 autofind 기능을 사용해 실행 파일 위치를 채우거나 드릴다운 단추를 눌러 디렉토리를 검색할 수 있습니다.


Execute/Compile

Behavior

Poll for DBMS Output when detected

이 옵션을 선택하면 Toad에서는 스크립트를 실행할 때 출력이 감지되면 DBMS Output을 자동으로 폴링합니다. 이 옵션을 선택하지 않으면 DBMS Output을 폴링하도록 Toad에 지시해야 합니다.

이 옵션은 기본적으로 선택되어 있습니다.

Prompt for substitution variables

이 옵션을 선택하면 실행할 SQL에서 대체 변수가 발견될 경우 Editor에서는 변수 값을 묻는 메시지를 표시합니다. 변수 형식은 &VAR, &&VAR 및 :VAR입니다.

이 옵션은 기본적으로 선택되어 있습니다.

Save proc parameters between sessions

이 옵션을 선택하면 디버깅을 위한 매개 변수를 설정할 때 PL/SQL 개체에 대해 입력하는 매개 변수가 ToadParams.ini 파일에 저장되며 다음 디버깅 세션을 위해 ToadParams.ini 파일에서 복원됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Compiling

Allow compiling when source is loaded from database

이 옵션을 선택하면 데이터베이스에서 소스가 로드될 때 코드를 즉시 컴파일할 수 있습니다.

이 옵션을 선택하지 않으면 재컴파일하기 전에 코드를 디스크에 저장해야 하고 "You may not recompile directly from database"라는 대화 상자가 표시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Compile Spec and Body as pair (Package or User Type)

스펙과 본문이 모두 editor에 로드된 경우 Compile(<F9> 키)을 누르면 이 옵션은 스펙을 컴파일한 다음 본문을 컴파일합니다.

패키지에 파일 분할을 사용하고 있으며 두 개체를 동시에 컴파일하려는 경우 이 옵션이 특히 유용합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Default to "Compile with Debug"

이 옵션을 선택하면 각 세션에 Toggle 단추가 on 위치에서 시작합니다.

이 옵션은 기본적으로 선택되어 있습니다.

Use "CREATE" instead of "CREATE OR REPLACE" when loading database objects

이 옵션을 선택하면 Create Procedure는 기존 개체를 덮어쓰지 않습니다. PL/SQL을 Editor에 로드할 경우 Create 절은 "Create Procedure/Function/Package ..."가 됩니다. 이 프로시저를 컴파일할 때 같은 이름의 다른 개체가 데이터베이스에 이미 있는 경우 이 옵션이 유용하며 개체를 덮어쓰는 대신에 컴파일 오류가 발생하게 됩니다.

이 옵션을 선택하지 않으면 Create 절은 "Create or Replace Procedure/Function/Package"가 되고 같은 이름을 가진 모든 기존 개체를 덮어씁니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Notification when compile process is complete

이 옵션을 선택하면 프로시저 컴파일이 완료된 경우 ToadLOAD.WAV(개구리 울음 소리)가 재생됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Set optimizing compiler value (10g only)

상자에 0, 1 또는 2를 입력합니다. 이 옵션을 선택하면 새 연결에서 뿐만 아니라 모든 10g 연결에 대해 options 창 옵션이 적용될 경우 다음 질의가 실행됩니다.

ALTER SESSION SET plsql_optimize_level=X

여기서 X는 드롭다운에 입력된 값입니다.

값은 PL/SQL 라이브러리 단위를 컴파일하기 위해 Oracle에서 사용하는 최적화 수준을 설정합니다. 자세한 내용은 Oracle 설명서를 참조하십시오.

Oracle 기본값은 2입니다.

Set Modified Flag off after compiling source database

이 옵션을 선택하면 데이터베이스에서 소스를 컴파일할 때마다 Modified 플래그가 전환되므로 소스가 수정된 시점을 알 수 있습니다.

주: Team Coding 기능을 사용할 경우 이 옵션을 선택한 상태로 두는 것이 좋습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Login Scripts

Glogin.sql(일반적으로 그룹 로그인 설정용) 및 login.sql(사용자의 개인 로그인 설정)은 Oracle 표준이며 SQL Plus뿐만 아니라 다른 응용 프로그램에 사용됩니다. TOAD에서는 Editor 스크립트 실행을 위해 이러한 파일을 지원합니다. 해당 상자는 읽기 전용입니다. Toad에서는 SQL Plus 알고리즘을 사용하여 이러한 파일을 찾습니다.

주: glogin.sql이 먼저 실행된 다음 login.sql이 실행됩니다. 따라서 login.sql의 모든 설정이 glogin.sql에 있는 모든 설정보다 우선합니다.

예를 들어 SET LINESIZE 100;이 glogin.sql에 있고 SET LINESIZE 150;이 login.sql에 있을 경우 150이 INESIZE에 사용됩니다.

glogin.sql

glogin.sql은 일반적으로 ORACLE_HOME\sqlplus\admin 폴더에 있습니다.

Edit File 단추를 눌러 이 파일을 편집할 수 있습니다. 이 파일은 선택한 텍스트 편집기에서 열립니다.

login.sql

login.sql을 사용하여 스크립트 실행 세션에 대한 초기 설정을 저장할 수 있습니다. Toad에서는 시작 시에 Toad의 초기 작업 디렉토리를 검색하여 login.sql을 찾습니다. 이 폴더는 일반적으로 설치 폴더이지만 시작 위치를 변경한 경우 다른 폴더일 수 있습니다.

해당 위치에서 login.sql을 찾을 수 없는 경우 Toad는 SQLPATH에서 활성 홈을 검색합니다. PC의 PATH 변수와 같은 SQLPATH는 세미콜론으로 구분된 여러 디렉토리를 포함할 수 있습니다. 예를 들면 다음과 같습니다.

'C:\Oracle\dbs;C:\MyPersonalOracleScripts;C:\TOAD\User Files'

이 예에서는 먼저 C:\Oracle\dbs에서 login.sql을 검색한 다음 계속해서 C:\MyPersonalOracleScripts를 검색합니다. login.sql이 발견되면 검색이 중지되고 해당 login.sql이 사용됩니다.

Execute login scripts

이 옵션을 선택하면 로그인 스크립트가 실행됩니다. 이 옵션을 선택하지 않으면 로그인 스크립트가 무시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Restore SET defaults prior to script execution

이 옵션을 선택하면 Editor에서 스크립트가 실행되기 전에 기본 설정 파일의 설정이 복원됩니다. 이 옵션을 선택하지 않으면 Editor 시작 시에 설정이 로드되고 이후의 모든 실행에서 변경 내용이 유지됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Script Output

Limit results to

이 옵션을 선택하고 상자에 숫자를 입력하면 SELECT는 해당 행 수로 제한됩니다. 해당 행 수를 초과하는 모든 결과는 잘립니다. 상자에 0을 입력하면 모든 행이 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Warn when available memory becomes less than n MB

이 옵션을 선택하면 결과 집합이 너무 많은 메모리를 차지할 경우 경고가 표시되고 질의를 계속할지 아니면 끝낼지 선택할 수 있는 옵션이 제공됩니다.

기본적으로 이 옵션은 선택되어 있고 50MB입니다.

Show Script Grids

이 옵션을 선택하면 행 결과를 반환하는 스크립트 질의(예: Select * from

MyTable)가 결과를 Script output 탭과 그리드에 보냅니다.

그리드 출력을 비활성화하려면 이 확인란을 선택 취소합니다.

이 옵션은 기본적으로 선택되어 있습니다.

Maintain Script History

이 옵션을 선택하면 스크립트 기록이 유지 관리됩니다. 이 옵션을 선택하지 않으면 스크립트 기록이 유지 관리되지 않습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Show Script Start/End times

이 옵션을 선택하면 스크립트의 시작 및 끝 시간이 출력 영역에 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Font

스크립트 출력에 사용할 글꼴을 선택합니다. 기본값은 Courier입니다.


Files - General

File Types:

Toad를 통해 표시되는 File Open, File Save 및 Export file 대화 상자 창의 거의 대부분은 SQL 파일을 조작하는 용도로 사용됩니다. Grid 대화 상자를 사용하면 시스템 대화 상자 창에 표시되는 파일 확장명을 사용자 정의할 수 있습니다. 또 다른 필터를 추가하려면 빈 행에 입력합니다. 필터를 삭제하려면 텍스트를 강조표시하고 <DELETE> 키를 누릅니다.

기본 필터는 다음과 같습니다.

파일 형식 | 필터
함수 | *.fnc
HTML | *.html, *.htm, *.asp, *.xml, *.xsl, *.xsd
Ini | *.ini
Java 소스 | *.jvs
Java | *.java, *.jvs
패키지 본문 | *.pkb
패키지 | *.pks
PL/SQL | *.sql, *.prc, *.fnc, *.pks, *.trg, *.vw, *.tps, *.tpb
프로시저 | *.prc
SQL | *.sql
텍스트 파일 | *.txt
텍스트 | *.txt
트리거 | *.trg
형식 본문 | *.tpb
형식 | *.tps
보기 | *.vw
모든 파일 | *.*

파일 연결을 작성하려면

  1. Add를 누릅니다.

  2. Type 상자에 설명을 입력합니다.

  3. 해당 형식과 연결할 확장명을 Extensions 상자에 입력합니다.

  4. 창 수준에서 Toad와 연결되도록 하려면 "Open with Toad" 확인란을 선택합니다.

이렇게 하면 지정된 파일 확장명에 대한 창 파일 연결이 작성됩니다. 예를 들어 파일 탐색기에서 *.SQL 파일을 두 번 누르면 Toad가 자동으로 시작됩니다.

  5. OK를 누릅니다.

Save source files in Unix format

이 옵션을 선택하면 CR-LF 문자 쌍이 LF로 저장되므로 소스가 Unix와 호환됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Number of files to save in recently used file lists

이 옵션은 파일 목록에서 유지 관리할 최근에 사용된 파일 수를 지정합니다. 최근에 사용된 파일 중에서 이 파일 수를 초과하는 파일은 오래된 순서대로 목록에서 삭제됩니다.

기본값은 10입니다.


Files - Open/Save 대화상자

이 화면은 open/save 대화상자의 "Favorites" 상자를 제어합니다. Open/Save 대화상자뿐만 아니라 여기서도 목록에서 즐겨찾기를 지정하거나 삭제할 수 있습니다.

즐겨찾기

이 옵션 창에서 즐겨찾는 디렉토리를 관리합니다.

항목을 추가, 편집 또는 삭제할 수 있습니다. Sort alphabetically가 표시되어 있지 않으면 디렉토리를 선택하고 목록에서 위나 아래로 이동할 수 있습니다.

Sort Alphabetically

이 확인란이 표시되어 있으면 모든 디렉토리가 알파벳 순으로 나열됩니다. 이렇게 하면 더욱 구성하기가 쉬워집니다. 표시되어 있지 않으면 추가된 순서대로 항목이 나열되어 순서를 다시 정렬할 수 있습니다.

기본값으로 표시되어 있습니다.


General

Confirm before closing Toad

이 옵션을 선택하면 Toad 응용 프로그램을 닫기 위한 제어 상자를 누르거나 File|Exit 메뉴 항목을 선택했을 때 <YES> 또는 <NO> 단추가 표시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Flash TOAD when inactive and messages are written to the output window

이 옵션을 선택하면 Toad가 비활성 상태에서 출력 메시지가 기록될 때 Toad의 작업 표시줄 아이콘이 깜박입니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Flash the output window when messages are written to it

이 옵션을 선택하면 Toad가 활성 응용 프로그램인 상태에서 메시지가 기록될 때 출력 창이 깜박입니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Display units for extents

익스텐트를 표시하는 데 사용할 단위 유형을 선택합니다(Bytes, Kilobytes, Megabytes).

기본값은 Kilobytes입니다.

Save Settings every n minutes

이 옵션을 선택하면 사용자가 설정한 간격으로 설정이 저장됩니다. 설정을 저장할 분 값을 선택합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

이 옵션을 선택하면 기본값은 3분입니다.

Exception Logging

Log File

로그 파일의 전체 경로와 파일 이름을 입력합니다. 비워 둘 경우 로그 파일은 주 TOAD.EXE 디렉토리로 보내집니다.

Number of errors to log

로그 파일에서 유지 관리할 오류 수를 지정합니다. 마지막 n개의 오류가 저장됩니다. 기본값은 10입니다.

Numeric characters

표시 목적을 위한 소수 구분 기호 및 1000 단위 구분 기호를 설정하려면 이 옵션을 사용합니다. 둘 다 설정해야 하고 서로 다른 구분 기호를 사용해야 합니다. 드롭다운에서 제공되는 옵션은 다음과 같습니다.

  • ,(쉼표)

  • .(마침표)

  • (공백)

User Files Directory

사용자 파일을 로드하는 데 사용되는 디렉토리를 설정하려면 이 옵션을 사용합니다. 기본값은 Toad\User Files 디렉토리입니다. 사용할 디렉토리의 경로 이름을 입력합니다.

관련 항목

Toad Options|Oracle|Transactions


Instance Manager

Instance Manager 옵션을 사용하여 폴링할 서버와 다운되었을 때 경고를 표시해야 하는 서버를 선택할 수 있습니다.

Servers to Poll

Servers to poll 영역에서 세 가지 방법 중 하나로 서버를 선택할 수 있습니다.

  • 모든 서버를 선택하려면 All을 누릅니다.

  • 전체 서버 목록을 선택 취소하려면 None을 누릅니다.

  • 개별 서버를 선택하거나 선택 취소하려면 서버 이름 옆의 확인란을 누릅니다.

Alert when down on

Alert when down on 영역에서 Servers to Poll의 경우와 같은 방식으로 서버를 선택할 수 있습니다.

  • 모든 서버를 선택하려면 All을 누릅니다.

  • 전체 서버 목록을 선택 취소하려면 None을 누릅니다.

  • 개별 서버를 선택하거나 선택 취소하려면 서버 이름 옆의 확인란을 누릅니다.

주: Enable Alerts(아래 참조)를 선택하지 않을 경우 이 영역에서 선택한 서버에 상관없이 경고가 보내지지 않습니다.

Enable Email Alerts

서버 중 하나가 다운될 경우 경고를 받으려면 이 확인란을 선택합니다. 이 확인란을 선택하지 않으면 경고가 보내지지 않습니다.

Toad에서 서버, 리스너, 노드 또는 데이터베이스를 폴링하여 다운되었거나 액세스할 수 없다는 것을 발견할 때마다 경고가 보내집니다.

전자 메일 경고를 활성화하도록 선택할 경우 전자 메일 설정을 지정해야 합니다. Toad Options|Email을 참조하십시오.

이 옵션은 기본적으로 선택되어 있습니다.

Use Tray Icon

경고에 대한 트레이 아이콘을 열려면 이 상자를 선택합니다. 이 상자를 선택하면 시스템 트레이에서 Toad의 아이콘이 표시됩니다. Instance Manager가 열려 있는 동안 아이콘은 계속 표시됩니다.

Enable Alerts 확인란이 선택되었고(위 참조) instance manager가 백그라운드에 있을 경우 경고가 발생하면 Toad가 깜박이면서 서버, 데이터베이스 또는 리스너 오류를 알립니다.

이 옵션은 기본적으로 선택되어 있습니다.

Poll upon Opening

이 옵션을 선택하면 Instance Manager가 처음 열릴 때 Toad에서는 선택한 서버를 즉시 폴링합니다.

이 옵션은 기본적으로 선택되어 있습니다.


Monitors

Database Monitor

이 옵션을 사용하여 수많은 임계값과 경고를 설정할 수 있습니다. 시리즈 목록의 각 항목은 그래프에 있는 한 줄에 해당합니다. 최소 및 최대 임계값을 입력할 수 있습니다.

Enable alerts

Enable alerts 를 선택하면 임계값을 초과할 경우 경고가 발생합니다. 경고를 활성화하려면 Database Monitor 창이 열려 있어야 합니다. Windows NT에서는 깜박이는 Toad를 누르면 Database Monitor 창이 맨 앞에 표시됩니다. 또한 경고를 전자 메일로 받거나 파일에 저장할 수 있습니다(아래 참조).

Enable Scripts

Enable scripts를 선택하면 데이터 시리즈에서 경고가 트리거될 경우 해당 데이터 시리즈에 대해 나열되는 스크립트가 Editor에 로드되어 실행됩니다.

Use Tray Icon

경고가 활성화된 상태에서 경고가 발생하면 Use Tray Icon 은 시스템 트레이에서 깜박이는 Toad 아이콘을 표시합니다.

Alert file

경고를 명명된 파일에 보내려면 이 상자에 경로와 파일 이름을 입력합니다. 새 경고가 파일에 추가되어 수신된 경고 로그가 만들어집니다.

Clear

그리드에서 설정한 모든 경고를 지우려면 clear 단추를 누릅니다.

Unix Monitor

Unix Monitor 창의 옵션을 사용하면 열의 다양한 크기 및 위치뿐만 아니라 창 크기를 저장할 수 있으므로 원하는 보기를 더 쉽게 설정하고 나중에 되돌아갈 수 있습니다.

Save process list column sizes

이 상자를 선택하면 프로세스 목록 열 크기를 설정할 수 있으며 세션 간에 해당 크기가 기억됩니다.

이 상자를 선택하지 않으면 Unix Monitor 창을 닫을 경우 프로세스 목록 열이 기본 크기로 복원됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Save process list column positions

이 상자를 선택하면 프로세스 목록 열을 이동할 수 있으며 세션 간에 해당 위치가 기억됩니다.

이 상자를 선택하지 않으면 Unix Monitor 창을 닫을 경우 열이 기본 위치로 복원됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.


Network Utilities

Network Utilities 옵션을 사용하면 Network Utilities 창에서 제공되는 도구를 사용하기 위한 일부 매개 변수를 설정할 수 있습니다.

Adding and Amending Host , User names, and Default Directories

여러 창에서 사용할 호스트 및 사용자 이름을 추가, 편집 및 삭제할 수 있습니다. 이러한 이름은 Telnet, Rexec 및 Ping의 드롭다운 메뉴에 표시됩니다. 각 호스트의 기본 디렉토리를 설정할 수 있습니다.

  • Add를 눌러 새 호스트 정보를 추가합니다. 호스트, 사용자 이름 및 디렉토리를 추가한 다음 OK를 누릅니다. 서버 호스트당 여러 사용자를 가질 수 있습니다.

  • 기존 호스트 이름을 선택하고 Edit를 눌러 변경합니다. Host Information 대화 상자가 나타납니다. 변경을 수행하고 OK를 누릅니다.

  • 기존 호스트 이름을 선택하고 Delete를 눌러 삭제합니다. 이름이 삭제됩니다.

주의: 기존 호스트 및 사용자 이름을 삭제할 경우 경고가 표시되지 않습니다. Delete를 누를 경우 선택한 이름이 즉시 삭제됩니다.

FTP ASCII Extensions

ASCII 파일에 대한 FTP 확장을 정의하여 FTP를 사용하는 동안 전송 모드를 제어할 수 있습니다. ASCII 아래에 확장을 나열한 경우 해당 형식의 파일은 기본적으로 ASCII를 사용하여 보내집니다. 이 상자에 나열되지 않은 모든 확장은 이진을 사용하여 보내집니다.

Setting the Telnet Font

텔넷 유틸리티에 사용되는 글꼴을 변경할 수 있습니다.

  1. Sample Telnet font 옆의 [image] 을 누릅니다.

  2. 텔넷 유틸리티를 사용할 때 사용할 글꼴 형식을 선택합니다. OK를 누릅니다. Sample Telnet font가 선택한 글꼴로 변경되고 다음에 텔넷 사용 시에 이 글꼴이 사용됩니다.


Oracle

Oracle - General

Passwords

Save passwords for all Oracle connections

일반적으로 각각의 새 Oracle 연결에 대해 스키마와 데이터베이스만 TOAD.INI 파일에 저장됩니다. 이 옵션을 선택하면 암호도 저장됩니다. TOAD.INI 파일이 잘못된 사람에게 넘어가지 않도록 보안된 환경에서 작업해야 합니다. Toad에서 모든 암호는 AES 암호화를 사용하여 암호화됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Remember passwords for Oracle reconnects

이 옵션을 선택하면 File|Test Connections에서 암호를 묻는 메시지가 표시되지 않고 Toad를 열어둔 동안에 Server Login 창에서는 이전 연결의 암호를 기억합니다. Toad를 닫을 때 암호를 기억하려면 위의 Save passwords for Oracle connections를 참조하십시오.

이 옵션을 선택하지 않으면 File|Test Connections는 암호를 묻는 메시지를 표시하고 Save passwords for Oracle connections를 선택하지 않은 경우 Server Login 창에서는 사용자가 연결할 때마다 암호를 묻는 메시지가 표시됩니다.

이 옵션을 선택하면 연결이 끊어진 경우 Toad의 메모리에서 암호가 유지됩니다. 따라서 보안 위험을 초래할 수 있습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Newline format for character data

다음 옵션은 Data 그리드에서 Popup Text Editor에 적용됩니다.

Windows style (convert all newlines to CR/LF)

이 옵션을 선택하면 Toad는 Oracle에서 Data 그리드로 데이터를 읽을 때 LF 또는 CRLF를 변환하지 않고 데이터를 검색합니다. 그러나 열의 텍스트가 popup text editor에서 열릴 경우 텍스트에서 발견된 모든 줄 바꿈은 CRLF로 변환되며 데이터가 변경된 경우 해당 데이터에서 발견된 모든 CRLF 또는 LF는 CRLF로 게시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Unix style (convert all newlines to LF)

이 옵션을 선택하면 Toad는 Oracle에서 Data 그리드 및 popup text editor로 데이터를 읽을 때 줄 바꿈(LF)을 캐리지 리턴-줄 바꿈 쌍(CRLF)으로 읽습니다. 그런 다음 텍스트 열의 데이터가 변경될 경우 해당 데이터에서 발견된 모든 CRLF 또는 LF는 LF로 게시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Explain plan

Schema

Explain Plan 데이터를 기록하고 반입할 때 사용되는 스키마 이름입니다.

기본값은 Windows 로그온 이름입니다.

Table Name

Explain Plan 결과를 저장할 때 Toad에서 사용하게 하려는 테이블 이름입니다. 자세한 내용은 Server Side Install 마법사 항목을 참조하십시오.

기본값은 "Toad_PLAN_TABLE"입니다.

Save previous Explain Plan results (requires Toad tables)

이 옵션을 선택하면 Explain Plan 출력을 Toad 테이블에 저장하여 "View|Explain Plan" 창에서 볼 수 있게 됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

DBMS Output

DBMS Buffer Size

여기에서 DBMS 버퍼의 크기를 설정합니다. 버퍼가 이 크기를 초과할 경우 버퍼 오버플로 오류가 발생합니다. Oracle 10g를 사용하는 중이면 이 버퍼 크기가 무제한으로 자동 설정되고 변경할 수 없게 됩니다.

DBMS Output Font

DBMS output을 표시하는 글꼴을 설정하려면 이 단추를 누릅니다.

Default Schema

Default schema for connections to: current connection

이 상자에 기본 스키마를 입력할 수 있습니다. 데이터베이스에 대한 연결이 설정되면 이 기본 스키마가 데이터베이스에 있을 경우 Schema Browser는 이 스키마로 열립니다.

연결된 데이터베이스에 스키마가 없을 경우 Schema Browser는 연결된 스키마로 열립니다.

또한 Schema Browser 팝업 메뉴|Set current schema as default 또는 Clear default schema를 사용하여 이 옵션을 변경할 수 있습니다.

기본적으로 스키마가 선택되지 않습니다.

Default schema for connections to: current schema@current connection

이 상자에 기본 스키마를 입력할 수 있습니다. 데이터베이스에 대한 연결이 설정되면 지정된 스키마가 데이터베이스에 있을 경우 Schema Browser는 이 스키마로 열립니다.

연결된 데이터베이스에 스키마가 없을 경우 Schema Browser는 연결된 스키마로 열립니다.

또한 Schema Browser 팝업 메뉴|Set current schema as default 또는 Clear default schema를 사용하여 이 옵션을 변경할 수 있습니다.

기본적으로 스키마가 선택되지 않습니다.

Used in

기본 스키마 옵션을 따르는 창을 지정하려면 Used in 단추를 누릅니다. Schema Browser를 제외하고 모든 경우에 기본값이 OFF입니다.

OCI Array Buffer size number box

이 옵션을 사용하면 OCI Array 버퍼의 크기를 설정할 수 있습니다.

SELECT 질의가 실행될 경우 Oracle 서버에서 행이 검색됩니다. 행은 블록으로 검색됩니다. 각 블록의 검색된 행 수는 OCI Array Buffer Size 옵션을 사용하여 지정하는 행 수입니다.

버퍼를 최대 999 값까지 설정할 수 있습니다. OCI Array Buffer Size를 높게 설정할 경우 각 반입 전에 지정된 다수의 행을 보유하기 위한 메모리를 Toad에서 할당해야 한다는 단점이 있습니다. 지정된 수만큼 많은 행이 실제로 반입될 경우 손실이 없습니다. 반면, 지정된 수만큼 행이 검색되지 않을 경우 할당된 일부 메모리는 커서를 놓을 때까지 해제되지 않습니다. 일반적으로 이 할당된 메모리 크기는 별로 크지 않습니다.

기본값은 500입니다.

Single-step when spooling SQL to screen

이 옵션을 선택하면 Toad에서 사용하는 각 SQL 단계가 별개의 Debug Output 창에 포함됩니다. 계속하려면 한 번에 하나씩 각 출력 대화 상자를 닫아야 합니다. 이 옵션을 사용하면 Toad에서 작성하는 코드를 한 단계씩 실행하여 Toad의 작업을 더 자세히 볼 수 있습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

관련 항목

Oracle Optimizer Hints


CR/LF 예

새 줄 옵션을 설명하기 위해 다음 스크립트를 사용할 수 있습니다.

CREATE TABLE crlf_comp

(textcol VARCHAR2(20));

INSERT INTO crlf_comp VALUES ('crlf'||CHR(13)||CHR(10)||'char'); /*Carriage return linefeed combo*/

INSERT INTO crlf_comp VALUES ('line'||CHR(10)||'feed'); /*Linefeed only*/

COMMIT;

Windows style

  • 그리드의 셀에는 CrLF에 대한 두 개의 검정색 문자 및 LF에 대한 하나의 검정색 문자가 표시됩니다.

  • memo editor는 CrLF가 발견된 경우 새 줄을 시작하지만 LF가 발견된 경우에는 단순히 검정색 문자를 표시합니다.

  • memo editor에서 데이터를 게시할 경우 줄 구분 기호는 캐리지 리턴 + 줄 바꿈이 됩니다.

Unix style

이 옵션을 선택하면 다음 작업이 수행됩니다.

  • 그리드의 셀에는 CrLF 또는 LF에 대한 두 개의 검정색 문자가 표시됩니다.

  • memo editor는 CrLF 또는 LF가 발견될 경우 새 줄로 이동합니다.

  • memo editor에서 데이터를 게시할 경우 줄 구분 기호는 단순히 줄 바꿈이 됩니다.


Oracle Optimizer Hints

이 옵션 화면을 사용하면 Toad에서 실행하는 DDL 질의에 대한 최적의 optimizer 힌트를 선택할 수 있습니다. Default, /*+ CHOOSE */, /*+ RULE */ 및 /*+ FIRST_ROWS */ 중에서 선택할 수 있습니다.

여러 DDL에 대한 optimizer 힌트가 Toad에서 기본 제공됩니다. 필요한 경우 이러한 힌트를 편집하거나 다른 힌트를 추가할 수 있습니다.

화면은 DDL, Oracle 버전 및 규칙과 함께 그리드 형식으로 구성됩니다.

All Others

창의 맨 아래에 드롭다운 필드가 있습니다. 이 드롭다운 필드를 사용하여 주 Optimizer 힌트 그리드에 지정되지 않은 모든 보기에 사용할 optimizer 힌트를 선택할 수 있습니다. 예를 들면 다음과 같습니다.

  • Toad는 Oracle 8i에서 DBA_TABLES에 대한 질의를 실행하려고 합니다.

  • Toad는 먼저 그리드를 확인합니다. 8i에 대한 dba_tables가 그리드에 지정된 경우 해당 위치에 지정된 힌트가 사용됩니다.

  • 8i에 대한 dba_tables가 지정되지 않은 경우 "all others" 콤보 상자에 지정된 힌트가 사용됩니다.

optimizer 힌트를 편집하려면

  1. 편집할 레코드의 Optimizer Hint 열을 누릅니다.

  2. 드롭다운에서 사용할 힌트를 선택합니다.

optimizer 힌트를 추가하려면

  1. 창의 맨 아래에서 Edit 확인란을 선택하여 그리드를 Edit 모드로 만듭니다.

  2. 창의 맨 위에서 Insert Record [image] 단추를 누릅니다. 그리드에서 커서 위치 위에 새 레코드가 삽입됩니다.

  3. 새 레코드의 View Name 열을 누른 다음 드롭다운 목록에서 보기 이름을 선택합니다.

  4. 새 레코드의 Oracle Version 열을 누른 다음 드롭다운 목록에서 Oracle 버전을 선택합니다.

  5. 새 레코드의 Optimizer Hint 열을 누른 다음 드롭다운에서 사용할 optimizer 힌트를 선택합니다.

  6. 창의 맨 위에서 Post Edit [image] 단추를 눌러 편집을 완료합니다.

관련 항목

Oracle 옵션


Oracle - Transactions

Execute queries in threads (Creates a separate session)

이 옵션을 선택하면 특별히 질의를 실행하기 위한 별개의 세션이 작성됩니다. Editor, Schema Browser 또는 Object Search 창에서 실행되는 각 질의에 대한 새 세션이 작성됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Commit after every statement

이 옵션을 선택하면 문이 실행될 때마다, 그리드에서 편집 내용이 게시된 후, 그리고 그리드에서 행이 삭제된 후 커밋이 발생합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Use a separate connection when Toad itself is generating transactions

Toad에서 데이터를 Explain Plan 테이블에 저장하고 있는 경우 이 설정은 별개의 연결을 사용하도록 강제합니다.

주: 이 옵션을 사용하면서 RAC 인스턴스에 연결하는 경우 서버가 트랜잭션을 보낸 인스턴스에 대한 TNSNAMES 항목을 갖고 있어야 합니다. 또는 서버에서 인스턴스를 할당하게 하지 않고 클러스터의 인스턴스에 직접 연결해야 합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

When Closing Connections

Commit

이 옵션을 선택하면 연결을 닫을 때 자동으로 커밋이 수행됩니다.

Rollback

이 옵션을 선택하면 연결을 닫기 전에 모든 변경 내용이 자동으로 롤백됩니다.

Prompt For Commit/Rollback when changes detected, or detection is not possible due to lack of privileges on dbms_transaction

이 옵션을 선택하면 변경 내용이 감지되거나 감지가 불가능한 경우 연결을 닫을 때 항상 메시지가 표시됩니다.

이 옵션은 기본적으로 선택됩니다.

주의: Oracle에서는 모든 DDL 수정 후에 커밋을 수행합니다.


Proc Templates

이 옵션을 사용하면 템플릿을 추가 및 제거할 수 있습니다. 템플릿을 필요한 만큼 많이 또는 적게 추가할 수 있습니다.

proc templates에 액세스하려면

  • View|Toad Options|Proc Templates에서 이 옵션에 액세스합니다.

템플릿을 추가하려면

  1. Add를 누릅니다. "Choose a DB Option File" 대화 상자에는 SQL 파일만 표시됩니다.

  2. 템플릿이 포함된 SQL 파일을 선택한 다음 Open을 누릅니다. 파일이 새 줄에 포함됩니다.

  3. 새 템플릿에 대한 Display Name 필드를 누르고 설명과 같은 형태가 되도록 이름을 편집합니다.

템플릿을 추가하기 전에 작성해야 합니다. CREATE OR REPLACE 문을 포함합니다. 새 트리거가 작성될 때 %TriggerOpts% 매크로는 사용자가 선택한 트리거 옵션을 가집니다.

주: 패키지 내에서만 사용할 수 있는 두 가지 템플릿 유형이 있습니다. 이러한 두 가지 유형은 패키지 함수 및 패키지 프로시저입니다. Toad Options|Proc Templates 페이지에서 이러한 템플릿을 작성 및 편집할 수 있지만 Create PL/SQL Object 창에서 액세스할 수는 없습니다. 자세한 내용은 패키지 내에서 템플릿 사용을 참조하십시오.

템플릿을 삭제하려면

  1. 제거할 템플릿을 눌러 선택합니다.

  2. Delete를 누릅니다. 확인 대화 상자가 나타납니다.

  3. OK를 눌러 템플릿을 제거합니다.

템플릿을 편집하려면

외부 편집기(Toad Options|Proc Templates에서 구성)를 통해 템플릿을 쉽게 편집할 수 있습니다.

  1. 해당 이름을 눌러 편집할 템플릿을 선택합니다.

  2. Edit File을 누릅니다. 템플릿이 로드된 상태로 외부 편집기가 열립니다.

주: 편집 기능을 사용하려면 Toad Options|Executables에 외부 편집기가 지정되어 있어야 합니다.

  3. 템플릿을 편집하고 저장합니다.

Template substitution variables

이 옵션을 사용하여 템플릿 대체 변수를 추가 및 제거할 수 있습니다. 이러한 변수는 기본값이나 Toad에서 정의한 변수 외의 값(예: %DATE%, %TIME%)으로 새 프로시저 템플릿을 채우는 데 사용됩니다. 원하는 모든 대체 문자열과 해당 문자열에 대한 기본값을 추가할 수 있습니다.

Value for %username% variable

새 프로시저 템플릿을 Editor로 읽을 때 %USERNAME%은 이 상자에 입력한 값으로 자동 대체됩니다.

이 옵션은 기본적으로 비어 있습니다.

관련 항목

Create New PL/SQL Object

패키지 내에서 템플릿 사용


Query Builder - General

Query Builder

Behavior

Automatic AutoJoin

이 옵션을 선택하면 자동으로 외래 키 제약 조건을 검사하고 모델에 포함되는 테이블을 다른 테이블과 조인합니다. 이 옵션을 선택하지 않으면 테이블 팝업 메뉴를 사용하여 테이블을 수동으로 조인할 수 있습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Include schema in generated SQL

이 옵션을 선택하면 생성된 SQL에서 테이블 이름 앞에 항상 스키마 이름이 옵니다(예: myschema.mytable). 테이블이 다른 로그인에 속할 경우 항상 스키마 이름이 사용됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Automatically Select All Columns

이 옵션을 선택하면 테이블이 Query Builder에 추가될 때 모든 열이 자동으로 선택됩니다. 이 옵션을 선택하지 않으면 열이 선택되지 않으므로 수동으로 선택해야 합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Allow Cartesian Joins

이 옵션을 선택하면 테이블 사이에서 카티션 조인이 허용됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Warn

이 옵션을 선택하면 카티션 조인을 작성한 경우 경고가 표시됩니다.

이 옵션은 기본적으로 선택되어 있지만 Allow Cartesian Joins가 선택된 경우에만 유효합니다.

Use ANSI Syntax

이 옵션을 선택하면 데이터베이스가 9i 이상인 경우 조인 구문은 ANSI가 됩니다.

9i 전 버전에서는 ANSI 구문이 지원되지 않으므로 9i 전 데이터베이스의 경우 ANSI 구문이 사용되지 않습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Open full screen from Schema Browser

이 옵션을 선택하면 Schema Browser에서 열었을 때 Modeler는 최소화된 상태가 아니라 전체 화면 모드로 열립니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Limit visible columns to n when adding tables to the model area

이 옵션을 선택하면 테이블 모델에서 한 번에 표시되는 열 수가 제한됩니다. 스크롤을 수행하여 다른 열을 사용할 수 있습니다. 많은 수의 테이블을 모델링하려는 경우 이 옵션이 유용합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Display

다음 드롭다운 상자를 사용하여 모델에 있는 조인의 색을 변경할 수 있습니다. 이 방법으로 조인 유형을 쉽게 볼 수 있습니다.

  • Inner join

  • Outer join

  • Auto join

Object Font

개체 이름을 표시하기 위해 Query Builder에서 사용되는 글꼴을 변경하려면 이 옵션을 누릅니다.

Functions

Field Definition 대화 상자에 표시되는 함수 목록입니다.

  • 목록에 함수를 추가하려면 상자에 함수를 입력하고 Add 단추를 누릅니다. 추가한 함수는 목록 아래 표시됩니다.

  • 목록에서 함수를 제거하려면 함수를 선택하고 Remove 단추를 누릅니다.

주의: 함수는 경고 없이 즉시 제거됩니다. 그러나 상자에 텍스트가 남아 있습니다. 함수를 제거한 직후 ADD를 누르면 함수를 복원할 수 있습니다.

관련 항목

Query Builder - Functions


Schema Browser 옵션

Schema Browser - Data

Refresh Schema Browser

After an object is created

이 옵션을 선택하면 Schema Browser 창에서 새 개체를 작성할 경우 Toad는 개체가 작성된 후에 창을 새로 고쳐 Object 패널에 개체를 나열합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

After an object is altered

이 옵션을 선택하면 Schema Browser 창에서 새 개체를 작성할 경우 Toad는 개체가 작성된 후에 창을 새로 고쳐 Object 패널에서 변경 내용과 함께 개체를 나열합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

User/Schema Lists

Show All Users

이 옵션이 기본값입니다. 모든 사용자가 사용자 목록에 표시됩니다.

Only Show Users That Own Objects

이 옵션을 선택하면 개체를 소유하는 사용자만 표시됩니다. 이 옵션은 Oracle 사용자 목록 선택 프로세스의 대체 항목입니다. 예를 들어 보안상의 이유 때문에 수백 개의 스키마 이름에 부여된 개체를 소유하는 약간의 스키마만 환경에 포함되는 경우 이 옵션을 선택하면 모든 스키마의 긴 목록 대신에 개체를 소유하는 약간의 스키마만 나열됩니다. 따라서 이 필터는 목록을 더 쉽게 관리할 수 있도록 합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Only show users that own objects excluding Synonyms

이 옵션을 선택하면 개체를 소유하는 사용자만 표시되지만 동의어는 제외됩니다. 따라서 사용자가 동의어를 소유하지만 다른 것은 소유하지 않을 경우 해당 사용자는 표시되지 않습니다.

Only show users that own objects excluding Synonyms and Temporary Tables

이 옵션을 선택하면 개체를 소유하는 사용자만 표시되지만 동의어 및 임시 테이블은 제외됩니다. 따라서 사용자가 동의어 및/또는 임시 테이블을 소유하지만 다른 것은 소유하지 않을 경우 해당 사용자는 표시되지 않습니다.

기본값은 Show All Users입니다.

Left side Copy to Clipboard mode

왼쪽에서 여러 개체를 선택하고 <CTRL><C>를 누르면 목록이 클립보드에 복사되므로 Editor 등에 붙여넣을 수 있습니다.

Items separated by commas

이 옵션을 선택하면 개체 목록을 쉼표로 구분하여 모두 한 줄에 붙여넣습니다.

One item per line

이 옵션을 선택하면 한 줄에 개체 하나씩, 여러 줄에 개체 목록을 붙여넣습니다. 이 옵션이 기본값입니다.

Right side Copy to clipboard mode

오른쪽에서 여러 개체를 선택하고 <CTRL><C>를 누르면 목록이 클립보드에 복사되므로 Editor 등에 붙여넣을 수 있습니다.

Items separated by commas

이 옵션을 선택하면 개체 목록을 쉼표로 구분하여 모두 한 줄에 붙여넣습니다.

One item per line

이 옵션을 선택하면 한 줄에 개체 하나씩, 여러 줄에 개체 목록을 붙여넣습니다. 이 옵션이 기본 동작입니다.

Other options

Use same schema after changing sessions

이 옵션을 선택하면 세션을 변경할 때 스키마가 동일합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Omit SYS objects from the Procedure Dependencies List

이 옵션을 선택하면 표준 패키지, DBMS_STANDARD, DBMS_UTILITY 등과 같은 SYS 소유 개체가 Procedure Dependencies 목록에서 생략됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Show Body when Package Name is Selected

이 옵션을 선택하면 본문 또는 스펙 노드가 아니라 Objects 목록에 있는 패키지 이름을 선택할 경우 패키지 본문이 Details 패널에 표시됩니다. 이 옵션을 선택하지 않으면 스펙이 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Show Filter dialog before refreshing

이 옵션을 선택하면 Schema Browser 창을 로드하기 전에 Filter 대화 상자가 나타납니다. 필터 조건을 입력하면 필터와 일치하는 개체만 포함하여 Schema Browser가 로드됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Save Filters for lists

이 옵션을 선택하면 브라우저 필터가 디스크에서 \Toad for Oracle\Temps 폴더의 SCHEMA.FLT 파일에 저장됩니다.

Toad를 닫았다가 열 때마다 Schema Browser 필터를 재설정하려면 이 옵션을 선택 취소합니다.

이 옵션은 기본적으로 선택되어 있습니다.

Auto refresh detail tabs

이 옵션을 선택하면 Objects 패널에서 개체를 선택할 경우 Details 패널에서 세부 정보가 자동으로 새로 고쳐집니다. 이 옵션을 선택하지 않으면 수동으로 새로 고칠 때까지 세부 정보가 새로 고쳐지지 않습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Fetch table names from Oracle as needed

이 옵션을 선택하면 세부 정보를 변경할 경우 Object 목록에서 테이블 이름 목록이 자동으로 새로 고쳐집니다. 이 옵션을 선택하지 않으면 수동으로 새로 고칠 때까지 테이블 이름 목록이 새로 고쳐지지 않습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Include "Set Define Off" in scripts

이 옵션을 선택했으며 Team Coding이 활성화되지 않은 경우 Schema Browser에서 생성된 스크립트의 시작 부분에 SET DEFINE OFF가 표시됩니다.

이 옵션을 선택하지 않았거나 Team Coding이 활성화된 경우 Schema Browser에서 스크립트의 시작 부분에 SET DEFINE OFF가 표시되지 않습니다.

SET DEFINE OFF를 스크립트의 시작 부분에 추가할 경우 스크립트에 앰퍼샌드가 있으면 대체 변수를 묻는 메시지가 표시되지 않습니다. 스크립트에 앰퍼샌드가 없으면 메시지가 표시됩니다. SET DEFINE OFF 명령을 사용하면 Team Coding에 문제가 발생할 수 있습니다.

Milliseconds for list search timer on LHS lists

이 스피너에 입력하는 숫자는 개체 이름을 입력할 때 키 입력 사이에서 대기하는 시간을 설정하며 이 시간이 지나면 왼쪽으로 이동합니다. 개체의 다중 선택이 허용되고 트리 보기가 아닌 탭에 이 옵션이 적용됩니다.

기본값은 900밀리초입니다.


Schema Browser - Data and Grids

data 그리드

Save layouts

이 항목을 선택하면 Toad에서 열 순서와 제외할 열에 따라 Data 탭 그리드 배치를 자동으로 저장합니다.

주: 정렬과 필터링은 데이터 필터의 기능이며 이 옵션의 선택 여부에 관계 없이 자동으로 저장됩니다.

기본적으로 선택되어 있지 않습니다.

Wrap INSERT statements when exporting table data

이 항목을 선택하면 테이블 데이터를 내보낼 때 Toad에서 insert 문을 래핑합니다.

기본적으로 선택됩니다.

Set focus to table data grid after selecting table

이 옵션을 선택한 경우 오른쪽에서 Data 탭을 선택하면 Schema Browser에서 테이블을 변경할 때 포커스가 테이블 data 그리드에 남습니다.

기본적으로 선택되어 있지 않습니다.

Limit grid fetch ____ fetches (500 records)

이 옵션은 data 그리드에서 Toad가 반입하는 레코드 수를 제한합니다. 따라서 매우 큰 데이터 집합의 끝으로 스크롤 막대를 끄는 경우 중지 옵션이 제공됩니다. 값을 입력하면 Toad는 한 번에 그 수에 OCI Array Buffer size(기본값 500)를 곱한 만큼의 결과만 SQL 결과 그리드에 반입합니다. 이 옵션은 Tables|Data 탭, Snapshots|Data 탭, Views|Data 탭 및 Editor data 그리드에 적용됩니다.

주: 그리드 반입 제한 값은 항상 OCI Array Buffer Size의 배수입니다.

예를 들어 "2"를 입력한 경우 OCI Array Buffer size가 기본값이면 Toad에서 1000개의 레코드를 반입하고 더 반입할 것인지 묻는 메시지를 표시합니다.

Yes로 응답하면 Toad에서 n 행을 더 반입한 후 다시 프롬프트를 표시합니다. No를 누를 때까지는 결과가 표시되지 않습니다.

이 옵션은 SQL Editor 창의 SQL 결과 그리드에 영향을 주지 않습니다.

기본값은 1(500개 레코드)입니다.

Use NOPARALLEL hint

병렬 처리가 있는 테이블(처리도 또는 인스턴스 <> 1)에서 질의를 수행하면 Oracle에서 여러 프로세스를 실행합니다. 이 경우 커서를 닫을 때까지(즉 Schema Browser를 닫거나 다른 테이블로 이동할 때까지) 프로세스가 제거되지 않습니다. Schema Browser Tables Data 페이지에서는 많은 처리가 이루어지지 않기 때문에 이 프로세스를 다른 곳에서 사용하는 것이 좋습니다.

이 항목을 선택하면 Toad에서 data 그리드에 NOPARALLEL 힌트를 사용하여 질의가 Oracle 자원을 덜 사용하게 만듭니다.

기본적으로 선택되어 있지 않습니다.

Don't select BLOB/CLOB fields in data grids

이 항목을 선택하면 data 그리드의 데이터 패널에 BLOB 또는 CLOB 필드를 표시되지 않습니다. 이 방법으로 로드 시간을 절약할 수 있습니다. 이 항목을 선택하지 않으면 필드가 선택되어 표시됩니다.

기본적으로 선택되어 있지 않습니다.

Enable FK Lookup

이 항목을 선택하면 data 그리드에서 Foreign Key를 조회할 수 있습니다.

기본적으로 선택됩니다.

Include disabled FK constraints

이 옵션은 Enable FK lookup을 선택한 경우에만 사용할 수 있습니다.

이 옵션을 선택하면 data grid lookup 창에 비활성화된 Foreign Key 제약 조건이 포함됩니다. 이 옵션을 선택하지 않으면 조회를 수행했을 때 활성화된 제약 조건만 표시됩니다.

기본적으로 선택됩니다.

정보 그리드

Allow extra lines for column comments

이 항목을 선택하면 주석이 그리드에 표시되고 주석 텍스트 전체를 볼 수 있도록 래핑됩니다. 전체 열 주석이 표시되도록 그리드 행 크기가 조정됩니다.

이 항목을 선택하지 않으면 열이 각각 한 행씩을 차지하며 더 이상 래핑되지 않기 때문에 한 행에 맞는 내용만 표시됩니다.

기본적으로 선택됩니다.

Only show top-level grants for Users, Roles, Sys Privs, and Resource Groups tabs

이 항목을 선택하지 않으면 수준에 관계 없이 모든 부여 권한에 대해 종속 관계의 전체 계층이 표시됩니다. 예를 들어 DBA 역할이 부여된 경우에는 그 역할을 펼쳐서 이 역할에서 간접적으로 제공하는 부여 권한(예: CONNECT)을 확인할 수 있습니다.

이 옵션이 선택되어 있으면 사용자에게 직접 부여된 권한만 표시됩니다. 이 옵션을 선택하면 Schema Browser 탭의 로드 시간을 대폭 절약할 수 있지만, 선택하지 않으면 사용자/역할에 지정된 권한을 자세히 볼 수 있습니다.

기본적으로 선택되어 있지 않습니다.

Auto-size columns

이 항목을 선택하면 Toad에서 텍스트의 너비에 맞게 자동으로 열 목록의 너비를 조정합니다.

기본적으로 선택됩니다.

Show Column length info with Column data type

이 항목을 선택하면 Columns 탭에서 열이 최대 길이, 배율, 정밀도를 포함한 "VARCHAR2(20)" 형식으로 표시됩니다(적용되는 경우). 선택하지 않으면 길이, 배율, 정밀도가 그리드에서 별도 열에 표시됩니다.

기본적으로 선택됩니다.

Show Table Stats (Tables -> Stats/Size 탭)

이 항목을 선택하면 테이블 통계 정보가 표시됩니다. Stats/Size 탭에 있는 확인란을 사용하여 이 항목을 켜거나 끌 수도 있습니다.

기본적으로 선택됩니다.


Schema Browser 옵션 - Visual

Schema Browser - Visual

Behavior

Sort package procedures

이 옵션을 선택하면 Schema Browser에서 패키지의 계층 보기를 확장할 경우 스펙 및 본문의 프로시저와 함수가 알파벳 순서대로 표시됩니다

이 옵션을 선택하지 않으면 코드에 표시된 순서대로 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Enable DROP-ALL 단추

Schema Browser의 각 개체 목록 탭에는 데이터베이스 개체를 빠르게 끌 수 있는 Drop 단추가 있습니다. 이 옵션을 선택하지 않을 경우 Drop-All 단추가 활성화되지 않습니다. Toad에서는 이 옵션을 저장하지 않고 비활성화된 Drop-All 단추로 되돌아갑니다. 따라서 이 옵션을 선택하면 현재 Toad 세션에만 일시적으로 적용됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Compile Mode…

이 단추를 눌러 다음 옵션으로 컴파일 모드를 설정할 수 있습니다.

Display

Left side

다음 옵션 중에서 선택할 수 있습니다.

Toolbars above object lists

이 옵션을 선택하면 Schema Browser의 왼쪽에 있는 개체 목록 위에 명령 도구 모음이 나타납니다.

이 옵션을 선택하지 않으면 도구 모음이 숨겨집니다. 이 옵션은 기본적으로 선택되어 있습니다.

Tab/Drop-Down Icons

이 옵션을 선택하면 해당 개체와 연관된 아이콘이 개체 탭이나 드롭다운 개체 목록의 이름 옆에 표시됩니다.

이 옵션을 선택하지 않으면 그래픽이 숨겨집니다. 이 옵션은 기본적으로 선택되어 있습니다.

Item Hints

이 옵션을 선택하면 왼쪽의 개체 위에 포인터를 올려 놓을 경우 개체를 설명하는 팝업 힌트가 제공됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Font & Color

Font 및 Color 단추를 사용하여 왼쪽의 Schema Browser에 대한 글꼴을 변경하고 배경색을 설정할 수 있습니다.

Right side

Object Create/alter dates

이 옵션을 선택하면 Schema Browser의 왼쪽 패널에서 선택한 개체에 대한 작성 및 업데이트 날짜가 오른쪽 패널의 맨 위에 표시됩니다. 이 옵션을 선택하지 않으면 이러한 날짜가 표시되지 않습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Primary Key columns for tables

이 옵션을 선택하면 Show Comments 드롭다운 목록의 오른쪽에 있는 Tables/Columns 탭에 Primary Key 열 목록이 표시됩니다. 복합 기본 키 및/또는 긴 열 이름을 가진 일부 테이블의 경우 이 레이블의 길이가 충분하지 않을 수 있습니다. 이제 Toad에서는 Primary Key 열인 열 목록의 각 열 옆에 작은 검정색 삼각형이 표시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Include hidden columns for tables

이 옵션을 선택하면 숨겨진 열도 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Font & Color

Font 및 Color 단추를 사용하여 왼쪽의 Schema Browser에 대한 글꼴을 변경하고 배경색을 설정할 수 있습니다.

Browser Style

Tabbed Object Type Selection

이 옵션을 선택하면 Schema Browser 개체 유형이 탭 인터페이스에 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Drop-down Object Type Selection

이 옵션을 선택하면 Schema Browser 개체 유형이 드롭다운 상자에 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Tree View

이 옵션을 선택하면 Schema Browser 개체 유형이 왼쪽 패널의 트리 보기에 표시됩니다. 이 보기에서 마우스 오른쪽 단추를 누르고 노드를 선택하여 표시되는 노드를 구성할 수 있습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Multi-line tabs

이 옵션을 선택하면 Schema Browser 왼쪽(Objects 패널)의 탭이 패널 너비에 맞게 크기가 조정되어 여러 줄에 표시됩니다.

이 옵션을 선택하지 않으면 Schema Browser 왼쪽의 탭이 하나의 행에 표시되며 사용자가 가로로 스크롤할 수 있습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

History

Limit to nn Items

이 상자를 사용하여 브라우저 기록에서 기억하는 항목 수를 선택할 수 있습니다. 브라우저 기록에 대한 자세한 내용은 Schema Browser Toolbars | Details Panel Toolbars를 참조하십시오.

기본 항목 수는 25입니다.

Restore History on connection

이 옵션을 선택하면 연결을 끊었다가 다시 연결할 경우 Toad에서 브라우저 기록을 기억합니다. 이 옵션을 선택하지 않으면 연결을 끝낼 경우 브라우저 기록이 손실됩니다.

이 옵션은 기본적으로 선택되어 있습니다.


Schema Browser - Types 탭

Capitalize keywords during code generation

이 옵션을 선택하면 개체를 작성하기 위해 코드가 생성될 때 키워드가 대문자로 표시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Autoload Tables Based On Object

이 옵션을 선택하면 선택한 개체에 기초하여 테이블을 자동으로 로드 및 표시하고 Properties 탭에 표시합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Autoload Columns Implementing Object

이 옵션을 선택하면 Properties 탭에서 선택한 개체를 구현하는 열이 자동으로 로드 및 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Autoload Dependencies

이 옵션을 선택하면 선택한 개체가 종속하는 개체가 자동으로 로드 및 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Name New Objects

더 의미 있는 이름으로 바꿀 때까지 새 개체에 제공되는 이름입니다. 연속된 각 개체의 경우 NEWOBJECT1, NEWOBJECT2 등과 같이 이 이름에 번호가 추가됩니다.

Name New Attributes

더 의미 있는 이름으로 바꿀 때까지 지정된 개체 내의 새 특성에 제공되는 이름입니다. 연속된 각 특성의 경우 NEWATTRIB1, NEWATTRIB2 등과 같이 이 이름에 번호가 추가됩니다.

Name New Methods

더 의미 있는 이름으로 바꿀 때까지 지정된 개체 내의 새 메서드에 제공되는 이름입니다. 연속된 각 메서드의 경우 NEWMETHOD1, NEWMETHOD2 등과 같이 이 이름에 번호가 추가됩니다.

Name New Collections

더 의미 있는 이름으로 바꿀 때까지 새 개체 컬렉션에 제공되는 이름입니다. 연속된 각 컬렉션의 경우 NEWCOLLECTION1, NEWCOLLECTION2 등과 같이 이 이름에 번호가 추가됩니다.

Default Method Restrictions

원하는 메서드 제한으로 WNDS, WNPS, RNDS 및/또는 RNPS를 선택합니다.

기본적으로 모든 항목이 선택되어 있지 않습니다.

Default Attribute Type

새 특성의 기본 데이터 형식입니다.

기본값은 VARCHAR2입니다.

Default Method Type

New Method 단추를 눌렀을 때 새 메서드의 기본 메서드 형식입니다. 드롭다운 메뉴에서 대체 메서드 형식을 선택할 수 있습니다.

기본값은 Procedure입니다.

Default Function type

새 함수의 기본 함수 형식입니다.

기본값은 INTEGER입니다.


Startup

Show login window

이 옵션을 선택하면 Oracle 인스턴스에 로그인할 수 있도록 시작 시에 로그인 창이 표시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Show Splash Screen

이 옵션을 선택하면 Toad를 처음 열 때 Toad 시작 화면이 표시되고 선택하지 않으면 표시되지 않습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Allow multiple copies of TOAD to be loaded

이 옵션을 선택하면 한 번에 여러 Toad 사본을 열 수 있습니다.

이 옵션을 선택하지 않으면 바탕 화면에서 한 번에 하나의 Toad 사본만 열 수 있습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Check for Access to DBA Views

DBA_TAB_COLUMNS와 같은 DBA 보기에 액세스할 수 있는 경우 이 옵션을 선택합니다. 세션 시작 시에 Toad는 해당 특정 사용자 스키마에 DBA 보기를 사용할 수 있는지 확인합니다. DBA 보기를 사용할 수 있는 경우 ALL_TAB_COLUMNS와 같은 ALL 보기 대신에 DBA 보기를 사용하여 Oracle Dictionary를 질의합니다. DBA 보기는 보안 검사가 없기 때문에 ALL 보기보다 훨씬 더 빠릅니다. 보안 검사가 없다는 것은 질의가 더 빠르다는 것을 의미합니다.

주: Quest DBA Module을 실행하는 중이면 Toad에서는 사용자가 DBA 역할, SELECT ANY TABLE 또는 DBA 보기에 대한 특정 액세스 권한이 있는지 확인하기 위해 항상 질의를 수행합니다.

이 옵션은 기본적으로 선택되어 있습니다.

Play Toad Wave File

이 옵션을 선택하면 Toad는 시작 시에 "개구리 울음 소리"를 재생합니다. 사운드 카드 문제가 있을 경우 이 옵션을 선택 취소합니다.

이 옵션은 기본적으로 선택되어 있습니다.

File To AutoLoad on startup

이 파일은 데이터베이스 로그인 다음에 표시되는 첫 번째 Editor 창에 자동으로 로드됩니다. 을 눌러 파일을 선택합니다.

이 옵션은 기본적으로 비어 있습니다(파일 표시 안 함).

File to AutoExecute on new connections

이 옵션을 사용하면 시작 시의 응용 프로그램 정보를 설정할 수 있습니다. 각 새 연결 후에 선택한 스크립트 파일이 실행되고 일반 "do you want to see output" 프롬프트 다음에 출력이 표시됩니다.

관련 항목

Windows


Source Control Options

Team Coding/Source Control Options

View|Toad Options|Team Coding에서 이 창에 액세스합니다. 이 창에서는 Team Coding을 Toad와 함께 사용하기 위한 사용자 매개 변수를 설정합니다. 또한 Toad의 레거시 소스 제어 기능에만 관련되는 일부 옵션이 있습니다.

Team Coding

Disable login prompt on connection

이 옵션은 Team Coding이 타사 제공자와 함께 작동하도록 구성된 경우에만 적용됩니다. 이 옵션을 선택하면 Team Coding 사용 가능 데이터베이스에 연결할 때 VCS 제공자 로그인이 표시되지 않습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Automatic Check-Out

개발자가 항목을 열 때 항목을 체크아웃하도록 강제하려면 Automatic Check-Out을 선택합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Automatic Check-In

개발자가 항목을 닫을 때 항목을 체크인하도록 강제하려면 Automatic Check-In을 선택합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Prompt for Check Out Comment

이 옵션은 기본적으로 선택되어 있습니다.

Prompt for Check In Comment

이 옵션은 기본적으로 선택되어 있습니다.

Prompt for Check In All on Exit

이 옵션은 기본적으로 선택되어 있습니다.

Schema Replacement for Stored Code, Triggers and Views

이 옵션은 두 가지 방식으로 작동합니다. 선택한 경우 다음과 같습니다.

  1. 원래 스키마의 이름이 코드에 표시되는 Code Control Groups 창에서 Import to database 기능을 사용하여 한 스키마에 있는 코드를 다른 스키마로 가져올 경우 대상 스키마로 대체됩니다.

  2. 마스터 소유자의 스키마가 코드에 표시되는 코드 제어 그룹에 매핑되는 사용자가 있을 경우 매핑된 사용자의 스키마에 있는 매핑된 사용자의 스키마 이름으로 대체됩니다.

예를 들어 개체를 매핑된 사용자의 스키마에 체크아웃하고 변경한 다음 체크인할 경우 버전 제어 리포지토리에 있는 복사본은 매핑된 사용자의 스키마 대신에 마스터 사용자의 스키마로 업데이트됩니다.

스키마 대체 기본값은 다음과 같습니다.

  • Schema Replacement for Stored Code - 이 옵션은 기본적으로 선택되어 있습니다.

  • Schema Replacement for Triggers - 이 옵션은 기본적으로 선택되어 있습니다.

  • Schema Replacement for Views - 이 옵션은 기본적으로 선택되어 있습니다.

Enable Actions in Schema Browser & Project Manager

이 옵션은 기본적으로 선택되어 있지 않습니다.

Simultaneously Check Out/In Spec and Body

이 옵션은 기본적으로 선택되어 있지 않습니다.

Default: Force New Revision on Check-In

변경되었는지 여부에 상관없이 체크인되는 개체를 새 수정 버전으로 자동 저장하려면 이 옵션을 선택합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Default Working Directory

작업 디렉토리의 경로를 입력하거나 찾아보기 [image] 단추를 눌러 browse 창에서 선택합니다.

VCS Provider Options

이러한 옵션에 대한 자세한 내용은 CVS 구성 옵션을 참조하십시오.

Legacy Source Control

Source Control Provider

드롭다운 메뉴에서 소스 제어 제공자를 선택합니다. 소스 제어 제공자가 설치되지 않은 경우 이 메뉴에는 <none>이라는 단어만 포함됩니다. 제공자가 설치되지 않은 경우 Toad에서 소스 제어를 사용할 수 없습니다. Toad에서 테스트된 제공자 목록은 소스 제어를 참조하십시오.

Prompt for Check Out comment

파일을 체크아웃할 때 주석을 입력하라는 메시지를 표시하려면 이 상자를 선택합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Prompt for Check In comment

파일을 체크인할 때 주석을 입력하라는 메시지를 표시하려면 이 상자를 선택합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Prompt for Add File comment

소스 제어에 새 파일을 추가할 때 주석을 입력하라는 메시지를 표시하려면 이 상자를 선택합니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.


Toolbars

Toolbars/Menus

Behavior

Allow docking and hiding of read-only toolbars

이 옵션을 사용하면 읽기 전용 도구 모음/메뉴 구성에서 도구 모음을 이동하고 숨길 수 있습니다.

이 옵션은 기본적으로 선택되어 있습니다.

Lock all Toolbars

이 옵션을 사용하면 도구 모음을 현재 위치에서 끌어 다른 위치에 도킹할 수 없습니다. 도구 모음은 임의 위치에서 잠기거나 도킹되거나 부동 상태일 수 있습니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Auto-save current desktop

이 옵션을 선택하면 현재 바탕 화면이 저장됩니다. Toad를 닫을 때, 탭을 변경할 때, 그리고 바탕 화면 레이아웃을 변경할 때의 세 가지 시점에 바탕 화면이 저장됩니다. 여러 바탕 화면이 열린 경우 마지막 활성 바탕 화면이 저장됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Display

Show window titles on Window Bar

이 옵션을 선택하면 창 제목(예: "Editor")이 창 캡션에 표시됩니다. 이 옵션을 선택하지 않으면 해당 창 유형에 대한 아이콘만 표시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Show connect strings on Window Bar

이 옵션을 선택하면 스키마 사용자 이름, "@" 기호 및 데이터베이스 별칭이 적용 가능한 창의 창 캡션에 표시됩니다. 이 옵션을 선택하지 않으면 스키마 사용자 이름만 표시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Use Vertical Text when Toolbars are Vertical

이 옵션은 세로로 도킹할 경우 도구 모음 텍스트의 가로/세로 방향을 제어합니다. 이 옵션을 선택하면 도구 모음의 텍스트가 세로로 표시됩니다. 이 옵션을 선택하지 않으면 텍스트가 가로로 표시되고 도구 모음이 넓어집니다.

이 옵션은 기본적으로 선택되어 있습니다.

Multi-Line Window Bar

이 옵션을 선택하면 여러 창이 열려 있는 경우 첫 번째 줄에서 공간이 부족하면 창 표시줄이 여러 줄로 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Multi-Line Connection Bar

이 옵션을 선택하면 여러 연결이 열려 있는 경우 첫 번째 줄에서 공간이 부족하면 연결 표시줄이 여러 줄로 표시됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Connection Bar and Window Bar Fonts

여기에서 연결 표시줄 및 창 표시줄 설명의 글꼴을 설정합니다. 설명이 단추에 맞거나 더 쉽게 읽을 수 있도록 글꼴 또는 글꼴 크기를 변경할 수 있습니다.

Visual Style

Toad의 표시에서 사용할 시각적 스타일을 선택합니다. 다음과 같은 옵션이 있습니다.

  • Standard

  • Enhanced

  • Flat

  • Office 2003

  • XP

기본값은 Enhanced입니다.

Configurations

Toad에서는 도구 모음 구성을 위한 두 가지 옵션이 제공됩니다. 이러한 옵션은 도구 모음 및 메뉴 표시줄 구성에만 적용됩니다. 구입한 버전에 있는 모든 명령을 구성에 추가할 수 있습니다. 이러한 구성은 단지 다양한 역할에 대한 편리한 시작 위치를 제공하기 위한 것입니다.

User default

User default 구성을 사용하면 도구 모음에 포함할 항목을 선택할 수 있습니다. 업그레이드 시에 새 항목이 메뉴와 도구 모음에 포함되지 않지만 사용자의 구성은 유지됩니다.

Toad default (all items)

Toad default는 가능한 모든 명령을 도구 모음에 포함합니다.


Toolbars/Menus - Shortcuts

이 창을 사용하여 다양한 명령의 바로 가기를 변경할 수 있습니다.

명령 바로 가기 변경에 대한 자세한 내용은 Configure_Menu_Shortcuts를 참조하십시오.


Windows

Behavior

창 옵션을 사용하면 각 주 창에 대해 저장해야 할 설정을 지정할 수 있습니다. 개별 창에 대해 다음을 선택할 수 있습니다.

  • 크기 저장

  • 위치 저장

  • Toad 시작 시 자동 열기

  • One/connection - 각 연결마다 해당 창 중 하나만 열기

  • One/Toad - 각 Toad 인스턴스마다 해당 창 중 하나만 열기

Auto-open bring to front

자동 열기를 위한 여러 창을 선택한 경우 Toad를 열었을 때 활성화할 창을 선택할 수 있습니다.

Describe windows

Describe 창의 작동 방법을 선택합니다. 가본값은 Stay on Top입니다.

MDI

이 옵션을 선택하면 F4 팝업 Object Describe 창은 MDI 하위 창으로 작성됩니다. 이는 Windows 메뉴에서 이러한 창을 액세스할 수 있고 개수에 상관없이 원하는 만큼 열 수 있으며 주 Toad 창 뒤에서 손실되지 않는다는 것을 의미합니다.

주: MDI는 다중 문서 인터페이스를 나타냅니다. MDI 응용 프로그램에서는 둘 이상의 문서 또는 하위 창을 단일 상위 창 내에서 열 수 있습니다. 이는 스프레드시트 또는 워드 프로세서와 같은 응용 프로그램에서 일반적입니다. MDI 부모 또는 MDI 컨테이너라고 하는 하나의 창이 하위 폼이라고 하는 여러 다른 창을 포함합니다.

Stay on top

이 옵션을 선택하면 DESCRIBE 창은 사용자가 닫을 때까지 Toad에서 다른 모든 창 위에 있습니다. 이 옵션이 기본값입니다.

Scroll pinned windows at n millisecs

이 옵션을 선택하면 지정된 속도에 포인터로 롤오버할 경우 고정된 창이 밖으로 스크롤되고 열립니다.

고정된 창이 열리는 속도를 지정할 수 있습니다. 기본값은 300밀리초입니다.

표시

Show USER@DATABASE in captions

이 옵션을 선택하면 사용자와 데이터베이스가 창 캡션에 표시됩니다. 이 옵션을 선택하지 않으면 창 제목만 표시됩니다.

이 옵션은 기본적으로 선택되어 있습니다.

Show spec and body in package describes

이 옵션을 선택하면 스펙과 본문이 설명에 모두 포함됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.


Language Management 개요

Toad Editor는 매우 강력한 기능을 제공하는 편집기이며 언어 사용을 관리하는 기능이 이러한 강력한 기능 중 하나에 해당합니다. Editor에서 PL/SQL, Java, C++, HTML 또는 사용자 정의 언어를 포함하는 다양한 언어로 구문 분석하도록 선택할 수 있습니다.

Toad에서는 소스를 가져와 사용자가 설정한 범주에 따라 구문 분석하고 토큰으로 분할합니다. 그런 다음 구문 강조표시, 코드 폴딩 등을 적용하기 위해 사용자가 설정한 규칙을 적용합니다.

이러한 언어를 관리하는 작업은 Toad의 여러 영역에 영향을 줍니다. 구문 강조표시는 코드 폴딩 및 Make Code 기능과 마찬가지로 정의된 명령 단어에 기초합니다. 하위 언어를 설정하는 기능은 포함된 java, perl 또는 다른 언어가 아니라 PL/SQL 코드에만 적용되는 대문자 표시 효과를 정의할 수 있다는 것을 의미합니다.

Toad Options의 Language Management 영역은 언어 및 강조표시 규칙을 설정하고 토큰(문, 주석 및 기타 정의된 영역 포함)을 정의하며 여러 항목 중에서도 특히 코드 템플릿과 하위 언어를 설정할 수 있는 기능을 제공합니다.

Language Management 창에 액세스하려면

  1. View|Toad Options에서 Editor - Behavior 노드를 선택합니다.

  2. Language Management 영역에서 편집할 언어를 선택하고 Edit를 누릅니다. 또는 Add나 Clone를 눌러 새 언어를 추가합니다.

Language Management 탭

Language Management 영역의 여러 탭에서 언어의 구성 요소 부분을 편집할 수 있습니다. 이러한 탭의 정보는 상호 관련되므로 하나의 탭에 있는 설정이 다른 탭의 설정에 영향을 줄 수 있습니다. 따라서 구성 가능한 매우 강력한 구문 분석 기능이 제공됩니다.

다음과 같은 탭이 있습니다.

  • General

  • Highlighting

  • Tokens

  • Parser

  • Rules

  • Sub Languages

  • Code templates

  • Grammar


구문 강조표시

Editor에서는 유연한 구문 강조표시가 지원됩니다. 강조표시는 언어별로 다르게 적용되며 Toad Options의 Language Management 영역에서 구성할 수 있습니다.

각 언어에서 사용되는 예약어 목록을 사용자 정의할 수도 있습니다. Toad 세션 도중에 활성 Oracle 세션에 대한 테이블 이름을 검색하는 창이나 함수를 사용한 경우 테이블 이름도 색으로 구분되어 표시됩니다.

구문 강조표시는 선택한 언어에 기초합니다. Options 창이나 Editor 자체에서 언어를 선택할 수 있습니다.

강조표시를 위한 언어를 선택하려면

  • Toad Options|Editor - Behavior 페이지의 Language Management 영역에서 적용할 언어를 선택한 다음 OK를 누릅니다.

또는

  • Editor에서 마우스 오른쪽 단추를 누르고 Language를 선택합니다. 제공된 메뉴에서 사용할 언어를 선택합니다.

테이블 이름, 보기 및 프로시저 구문 강조표시

Toad에서는 현재 스키마에 있는 테이블 이름, 보기 및 프로시저에 구문 강조표시를 수행할 수 있습니다.

테이블 이름, 보기 또는 프로시저 강조표시 옵션을 선택하면 스키마에서 이러한 개체가 자동으로 로드되고 강조표시됩니다. 연결을 설정할 때 이 옵션을 선택하지 않았지만 작업 도중에 이 옵션을 선택하면 개체 팔레트를 열거나 <CTRL><.> 등을 눌러 이름을 로드하자마자 이름이 강조표시됩니다. 이 옵션을 선택하지 않으면 개체 팔레트가 Schema Browser에 로드되는 등의 경우에도 이름이 강조표시되지 않습니다.

테이블 이름을 강조표시하려면

  • View|Toad Options|Editor - Display의 Syntax Highlighting 영역에서 Highlight Table names를 선택합니다.

테이블 이름 색을 사용자 정의하려면

  1. View|Toad Options|Editor - Behavior의 Language Management 영역에서 사용할 언어를 선택합니다.

  2. Edit를 누릅니다.

  3. Highlighting 탭을 누르고 Styles 목록에서 아래의 Toad_UserTables로 스크롤합니다.

  4. Highlighting 탭 항목에 설명된 대로 스타일을 변경합니다.

  5. OK를 누릅니다.

SYS 보기 이름 구문 강조표시

Toad에서는 SYS 보기 이름(예: ALL_TABLES)을 구문 강조표시할 수도 있습니다.

처음에 SYS 보기 이름을 채우려면

  • SYS 스키마 또는 DBA 역할이 있는 스키마를 사용하여 Schema Browser 창에서 Views 탭을 열고 필요한 경우 사용자 이름 드롭다운 목록에서 SYS를 선택합니다.

Toad는 모든 SYS 보기를 질의하고 Toad for Oracle\Temps\DATABASE_ALIAS\SYSVIEW.TXT에 목록을 캐시합니다.

목록을 다시 로드하려면 해당 SYSVIEWS.TXT 파일을 삭제하고 위 단계를 반복하면 됩니다. 데이터베이스가 다르면 SYS 보기 목록이 다릅니다(예: Oracle7, Oracle 8.0.5, Oracle 8i, Personal Oracle 등).

테이블 이름 색을 사용자 정의하려면

  1. View|Toad Options|Editor - Behavior의 Language Management 영역에서 사용할 언어를 선택합니다.

  2. Edit를 누릅니다.

  3. Highlighting 탭을 누르고 Styles 목록에서 아래의 Toad_SYSViews로 스크롤합니다.

  4. Highlighting 탭 항목에 설명된 대로 스타일을 변경합니다.

  5. OK를 누릅니다.

파서 스크립트

Toad에서 구문 분석 및 강조표시를 위한 기본 구성은 런타임에 로드되는 파서 스크립트 파일에서 제공됩니다. 이 파일은 lexer.lib 파일이며 Language Management 옵션 사용 시에 편집할 수 있습니다.

예약어 목록을 수정할 수 있습니다.

예약어/키워드를 수정하려면

  1. Language Management|Rules tab|Keywords에서 Conditions 탭을 누릅니다.

  2. Tokens 패널에서 키워드를 수정합니다. 단어를 삭제하거나 새 단어를 추가하거나 단어의 대/소문자를 구분할 수 있습니다.

예약어 규칙으로 이동해야 한다는 것을 추가하고(정확하게 호출되는지 확인하는 것이 아니라 해당 이름을 확인) Conditions 탭으로 가서 단어 목록을 수정할 수 있습니다.

예약어 및 키워드 제거

구문 강조표시된 Oracle SQL 예약어, PL/SQL 예약어 또는 Oracle 키워드를 목록에서 추가하거나 제거하려면 Language Management|Rules 탭을 사용합니다. Language Management|Highlighting 탭에서 강조표시 옵션을 변경할 수 있습니다.

언어 유형

언어 유형은 Toad Options|Editor - Behavior|Language Management 영역에서 정의됩니다. 새 언어를 제공된 언어 중 하나를 복제하여 작성하거나 수동으로 작성할 수 있습니다. General 탭은 어떤 언어에서 어떤 파일 확장명이 사용되는지 지정합니다.


LM - General

General 탭

general 탭에서는 편집하고 있는 언어의 기본 영역을 정의합니다. 이 탭에서는 열었을 때 이 언어를 자동으로 사용하는 파일 확장명, 텍스트의 기본 블록 주석 및 스타일, 사용할 줄 스타일을 지정할 수 있습니다.

Name

name 상자에는 이 파서에 사용할 이름이 포함됩니다. 예를 들어 PL/SQL로 코딩하는 경우 PL/SQL 언어가 정의되어 있습니다.

File extensions

이 상자에 입력한 모든 파일 확장명은 사용자가 여는 코드를 Toad에서 구문 분석하는 방법에 영향을 줍니다. 예를 들어 다르게 지정하지 않은 경우 SQL, FNC, PKB 파일 확장명은 항상 PL/SQL 언어로 열리고 구문 분석됩니다.

Block comment

블록 주석을 작성하기 위한 기본 마커를 입력합니다. Toad에서는 이 마커를 사용하여 다음 텍스트를 주석으로 간주합니다.

Default Style

이 언어로 작업할 때 텍스트에 사용할 기본 텍스트 스타일입니다. 대부분의 경우 이 스타일을 식별하는 토큰이 기본값이어야 합니다.

Line Style

editor에서 줄이 활성 상태인 경우(커서가 줄에 있는 경우) 이 스타일이 적용됩니다.

관련 항목

General 탭

Highlighting 탭

Tokens 탭

Parser 탭

Rules 탭

Sub Languages 탭

Code Templates 탭

Grammar 탭


LM - Highlighting 탭

Highlighting 탭

Highlighting 탭을 사용하여 지정한 스타일에 대한 강조표시 설정을 구성할 수 있습니다. 그런 다음 이러한 스타일을 필요에 따라 토큰이나 규칙에 적용할 수 있습니다.

스타일 목록에서 스타일을 추가, 편집, 삭제, 복사(복제) 또는 비활성화할 수 있습니다.

Style Settings

코드에 적용할 여러 스타일 설정 중에서 선택할 수 있습니다.

Style type

이 스타일 설정에 대한 스타일 유형을 선택합니다. 기본값은 default이며 이는 기본 스타일에 설정된 스타일로 되돌아간다는 것을 의미합니다. 아래 설명된 대로 모든 글꼴 설정을 변경할 수 있는 사용자 정의 글꼴을 선택하거나 배경/전경과 같은 제한된 사용자 정의 글꼴(배경색과 전경색만 설정할 수 있는)을 선택할 수 있습니다.

Background

텍스트의 배경색을 선택합니다.

Font color

텍스트 자체의 색을 선택합니다.

Capitalization effect

텍스트에 사용할 대문자 표시 형식을 선택합니다.

  • Unchanged

  • Uppercase

  • Lowercase

  • Initial Caps

Custom Font

Style 유형 아래에서 Custom Font를 선택한 경우 Custom Font 단추를 눌러 글꼴을 설정합니다.

Font Style

다음 스타일 중 하나 이상을 선택합니다.

  • Bold

  • Italic

  • Underline

  • Strike Out

Borders

텍스트 측면 중 하나 이상에 선택한 스타일로 테두리를 표시하도록 선택할 수 있습니다. 이 영역에서 각 테두리(왼쪽, 오른쪽, 위쪽 또는 아래쪽)의 줄 유형과 두께를 선택하고 테두리에 적용할 색을 선택합니다.

관련 항목

General 탭

Tokens 탭

Parser 탭

Rules 탭

Sub Languages 탭

Code Templates 탭

Grammar 탭


LM - Tokens 탭

Tokens 탭

Tokens 탭을 사용하여 규칙 및 파서 지정 내에서 사용할 수 있는 토큰을 정의할 수 있습니다. 이러한 토큰은 특정 언어 구성입니다. 예를 들어 PL/SQL은 Strings, Integers, Comments 등을 가집니다.

관련 항목

General 탭

Highlighting 탭

Parser 탭

Rules 탭

Sub Languages 탭

Code Templates 탭

Grammar 탭


LM - Parser 탭

Parser 탭

parser 탭을 사용하여 코드에서 토큰을 찾는 방법을 정의할 수 있습니다. 이 창은 세 개의 영역인 Categories, Parse 및 Advanced로 구분됩니다.

Toad에서는 정규식을 사용하여 토큰이 시작 및 끝나는 위치를 정의합니다. 토큰을 범주에 적용할 수 있으려면 먼저 Token 탭에서 토큰을 정의해야 합니다.

Categories 영역

범주 목록에는 정의에 사용할 수 있는 범주가 포함됩니다. 이러한 범주는 나열된 순서대로 구문 분석됩니다. 코드를 통해 작업하면서 규칙 중 하나가 충족되면 정의와 일치시키는 시도가 중단됩니다.

이 영역에서 다음을 수행할 수 있습니다.

  • Add new categories - 원하는 대로 정의할 수 있는 새 범주를 작성합니다.

  • Edit a category - 범주의 이름을 바꿀 수 있도록 edit 대화 상자를 표시합니다.

  • Delete a category - 선택한 범주를 삭제합니다. 경고가 발생하지 않습니다.

  • Copy from a category - copy from 대화 상자를 표시합니다. 정의에 포함할 언어와 범주를 선택합니다. 여러 범주를 선택할 수 있습니다.

  • Disable a category - 사용자가 활성화할 때까지 선택한 범주를 비활성화합니다.

  • Move categories up or down in the list - 선택한 범주의 우선 순위를 변경합니다.

Parse 탭

parse 탭을 사용하여 선택한 범주에 대한 정규식 테스트를 지정하고 토큰 유형과 기본 강조표시 스타일을 설정할 수 있습니다.

범주를 선택하면 해당 범주에 대한 세부 정보가 여기에 표시됩니다.

Regular expression test

이 상자에서 정규식을 편집하거나 추가합니다. 이 식은 범주를 코드에 적용할 때 Toad에서 찾는 항목을 정의합니다.

Evaluates to token type

드롭다운 목록에서 토큰 유형을 선택합니다. 이러한 토큰은 Tokens 탭에 정의된 토큰입니다.

Default Highlighting style

이 코드 범주에서 사용할 기본 강조표시 스타일을 선택합니다. 코드에서 또한 Rules 탭에 정의된 규칙을 충족하지 않을 경우에만 기본 강조표시 스타일이 적용됩니다.

Advanced 탭

Parse 탭의 설정은 간단한 토큰을 찾기 위한 충분한 정보를 제공하지만 사용자는 범위를 더욱 좁히는 것이 필요할 수 있습니다. advanced 탭에서는 특정 상위 항목을 요구하거나 특정 문자 위치 내에서만 활성화할 수 있는 방법이 제공됩니다.

Parent block

parent block 상자를 사용하여 상위 제한의 범위를 설정할 수 있습니다. 이 범위를 설정할 경우 범주는 선택한 범위로 시작하는 코드 섹션에만 적용됩니다. 기본적으로 코드가 상위 범위를 그대로 따르거나 해당 상위 범위 내에 중첩된 다른 범위에 포함된 경우에 코드에 영향을 줍니다.

또한 다음 수정 사항을 지정할 수 있습니다.

Strict

Parse 탭에 정의된 정규식을 충족하고 상위 범위를 그대로 따르는 코드만 포함합니다. 예를 들어 "CREATE OR REPLACE procedure" 정의 안에 직접 존재하고 CREATE 범주 내의 IF 절에 존재하지 않는 경우가 해당됩니다.

Not a parent

Parse 탭에 정의된 정규식을 충족하고 지정된 parent block의 일부가 아닌 코드만 포함합니다.

Enabled from character position: _____ to ______

문자 위치의 범위가 포함된 경우 정의된 정규식과 상위 규칙(있을 경우)을 충족하고 이러한 문자 위치 사이에 있는 코드만 범주에 포함됩니다.

관련 항목

General 탭

Highlighting 탭

Tokens 탭

Parser 탭

Rules 탭

Sub Languages 탭

Code Templates 탭

Grammar 탭


LM - Rules 탭

Rules 탭

rules 탭에는 구문 분석이 완료된 후 토큰에 적용되는 모든 규칙이 포함됩니다. 이러한 규칙은 이전에 지정된 모든 범주, 기본값 또는 토큰을 대체합니다. 따라서 대부분의 구문 강조표시 지정과 마찬가지로 코드 폴딩이 이러한 규칙에 의해 결정됩니다.

규칙은 조건을 여러 개 가지거나 하나만 가질 수 있습니다. 모든 조건은 숫자 순서(예: 1 다음에 2)대로 적용됩니다.

Parser categories와 같은 규칙은 Rules Names 목록에 나열된 순서대로 적용됩니다. 더 높은 우선 순위 규칙을 충족할 경우 이후 규칙은 적용되지 않습니다.

Conditions 탭

conditions 탭은 규칙 목록에서 선택한 규칙을 정의하기 위한 조건을 지정할 수 있는 영역을 제공합니다. 조건을 원하는 수만큼 지정할 수 있습니다.

새 조건을 추가하려면

  1. Condition: 영역에서 + 단추를 누릅니다.

  2. 조건을 적용해야 하는 하나 이상의 토큰 유형을 선택합니다.

  3. 연산자를 선택합니다.

  4. 조건을 적용할 토큰을 선택합니다.

  5. 설정할 모든 조건이 추가될 때까지 반복합니다.

조건을 삭제하려면

  1. 조건 목록에서 삭제할 조건을 선택합니다.

  2. - 단추를 누릅니다.

Properties 탭

properties 탭은 기본적으로 활성 탭입니다. 이 탭에서는 규칙을 충족할 경우 적용할 규칙 유형, 스타일 및 강조표시를 지정합니다.

Rule type

규칙 유형을 지정합니다. 태그 검색기, 줄 구분 기호, 범위 시작 또는 범위 끝이 포함될 수 있습니다.

Change token type

이 옵션을 사용하여 식별자를 다른 토큰 유형으로 변경할 수 있습니다. 예를 들어 구문 강조표시 목적을 위해 "IF" 토큰을 가져와 "SELECT" 강조표시를 적용할 수 있습니다.

Style

이 규칙과 일치하는 코드에 적용할 스타일을 선택합니다. 스타일은 Highlighting 탭에서 정의합니다.

Range Highlighting

이 코드에 적용할 범위 강조표시를 선택합니다. 범위 강조표시는 Highlighting 탭에서 스타일에 의해 정의됩니다.

Collapsed text string

코드 폴딩을 위해 텍스트를 축소한 경우 작성된 노드는 식별을 위해 축소한 텍스트 문자열이 자체에 표시될 수 있습니다. 이 문자열을 여기에 입력합니다. 다음 구문을 사용하여 첫 번째 토큰을 표시하거나 그 이후의 임의 토큰을 표시하도록 할 수 있습니다.

%s0%s-1

여기서 0은 첫 번째 토큰, -1은 다음 토큰, -2는 세 번째 토큰과 같은 순서로 토큰을 나타냅니다. 마지막 숫자 다음의 모든 토큰이 전부 표시됩니다.

예를 들어 ,"IF"로 시작하는 범위가 있을 경우 코드를 폴딩할 때 %s0woo!는 "IF woo!"로 표시됩니다.

Active Highlighting

Toad에서는 활성 상태인 범위를 강조표시할 수 있습니다. 이 기능이 활성화되면 캐럿이 지정된 위치에 있을 때마다 강조표시가 발생합니다.

Caret position 상자

Toad에서 코드를 활성으로 강조표시하는 시점인 캐럿 위치를 지정합니다. 코드를 항상 활성으로 표시할지, 캐럿이 범위에 있을 때 활성으로 표시할지, 캐럿이 특정 토큰 내에 있을 때 활성으로 표시할지 선택할 수 있습니다. 이 드롭다운을 사용하여 원하는 캐럿 위치를 선택합니다.

Select minimal range

이 옵션을 선택하면 범위가 중첩된 경우 캐럿이 있는 첫 번째 범위만 강조표시되고 모든 상위 범위는 무시됩니다. 이 옵션을 선택하지 않으면 모든 상위 범위를 포함하여 전체 범위가 강조표시됩니다.

Draw block staple

이 옵션을 선택하면 폴딩할 수 있는 코드 범위 주위에 회색 스테이플이 그려집니다. 이 옵션을 선택하지 않으면 스테이플이 표시되지 않습니다. 이 옵션은 기본적으로 선택되어 있습니다.

Self Closing Range

범위 마커의 일관된 끝 부분이 없는 범위 유형이 있을 경우 self closing range가 유용합니다.

이 옵션을 선택하면 Toad에서는 범위를 닫기 위해 범위 닫기 규칙을 찾지 않습니다. 대신에 다음 범위의 시작 부분에 의해 범위 닫기가 정의됩니다.

이 옵션은 기본적으로 선택되어 있지 않습니다.

Advanced 탭

Parse 탭의 설정은 간단한 토큰을 찾기 위한 충분한 정보를 제공하지만 사용자는 범위를 더욱 좁히는 것이 필요할 수 있습니다. advanced 탭에서는 특정 상위 항목을 요구하거나 특정 문자 위치 내에서만 활성화할 수 있는 방법이 제공됩니다.

Parent block

parent block 상자를 사용하여 상위 제한의 범위를 설정할 수 있습니다. 이 범위를 설정할 경우 범주는 선택한 범위로 시작하는 코드 섹션에만 적용됩니다. 기본적으로 코드가 상위 범위를 그대로 따르거나 해당 상위 범위 내에 중첩된 다른 범위에 포함된 경우에 코드에 영향을 줍니다.

또한 다음 수정 사항을 지정할 수 있습니다.

Strict

Parse 탭에 정의된 정규식을 충족하고 상위 범위를 그대로 따르는 코드만 포함합니다. 예를 들어 "CREATE OR REPLACE procedure" 정의 안에 직접 존재하고 CREATE 범주 내의 IF 절에 존재하지 않는 경우가 해당됩니다.

Not a parent

Parse 탭에 정의된 정규식을 충족하고 지정된 parent block의 일부가 아닌 코드만 포함합니다.

Gramma

특정 문법을 작성한 경우 개별 문법을 규칙에 추가할 수 있습니다. 드롭다운 목록에서 사용할 문법을 선택합니다.

Range Offset

범위 오프셋은 코드 폴딩 목적을 위해 Toad에서 범위의 시작 또는 끝으로 고려하는 사항을 변경합니다. 범위는 시작 및 끝 토큰에 의해 정의됩니다.

예를 들어 다음과 같은 토큰 문자열이 있을 수 있습니다.

토큰 | A | B | C | D | E | F
범위 위치 | 2 | 1 | 0 | -1 | -2 | -3
토큰 | G | H | I | J | K | L
범위 위치 | 3 | 2 | 1 | 0 | -1 | -2

범위가 "C"에서 시작하고 토큰 유형 C가 범위 시작의 위치 0입니다.

범위가 "J"에서 끝나고 토큰 유형 J가 범위 끝의 위치 0입니다.

B에서 시작 범위 오프셋을 설정한 경우 코드를 폴딩할 때 오른쪽에 있는 모든 토큰이 숨겨집니다.

Cancel next rules

이 옵션을 설정하면 조건을 충족할 경우 규칙 조건의 추가 처리가 취소됩니다. 이 옵션을 선택하지 않으면 모든 규칙이 순서대로 처리됩니다.

Relative to end of condition

조건의 끝을 기준으로 구문 분석을 설정합니다. 예를 들어 조건에서 "CREATE OR REPLACE FUNCTION"을 지정할 경우 이 옵션을 선택하면 FUNCTION(조건의 끝)에 0 위치가 설정됩니다. 이 옵션을 선택하지 않으면 CREATE(조건의 시작)에 0 위치가 설정됩니다.

관련 항목

General 탭

Highlighting 탭

Tokens 탭

Parser 탭

Rules 탭

Sub Languages 탭

Code Templates 탭

Grammar 탭


LM - Sub Languages 탭

Sub Languages 탭

Sub Languages 탭에서는 기본 언어 내에서 사용할 모든 언어를 정의합니다. 예를 들어 PL/SQL는 포함된 Java를 가질 수 있습니다. Java에서는 대/소문자를 구분하기 때문에 PL/SQL의 대문자 표시를 변경하는 스타일과 규칙이 정의되어 있는 경우 사용자는 이러한 정의가 Java에 동일하게 영향을 주는 것을 원하지 않을 것입니다. 이 경우 Toad에서 두 가지를 구별하여 다른 강조표시 및 코드 폴딩 규칙을 적절하게 사용하도록 사용자는 Java의 하위 언어를 설정할 수 있습니다.

하위 언어를 설정하려면

  1. 주 언어의 편집 화면에서 Sub Languages 탭을 선택합니다.

  2. Sub Language 상자에서 포함할 언어를 선택합니다.

  3. 하위 언어의 기본 스타일을 선택합니다. 이 스타일은 Highlighting 탭에 정의된 모든 스타일이나 <none>이 될 수 있습니다.

  4. parent block 상자를 사용하여 상위 제한의 범위를 설정할 수 있습니다. 이 범위를 설정할 경우 범주는 선택한 범위로 시작하는 코드 섹션에만 적용됩니다. 기본적으로 코드가 상위 범위를 그대로 따르거나 해당 상위 범위 내에 중첩된 다른 범위에 포함된 경우에 코드에 영향을 줍니다.

  1. 상위 범위를 그대로 따르는 코드만 포함하려면 Strict를 선택합니다. 예를 들어 "CREATE OR REPLACE procedure" 정의 안에 직접 존재하고 CREATE 범주 내의 IF 절에 존재하지 않는 경우가 해당됩니다.

  2. 지정한 parent block의 일부가 아닌 코드만 포함하려면 Not a parent를 선택합니다.

  5. 텍스트의 시작 부분에서 시작할지 이나면 끝 부분에서 시작할지 선택합니다.

  6. start 및 end 조건을 설정합니다.

주: 이러한 조건은 포함할 언어의 시작 마커 및 끝 마커를 정의하는 정규식이어야 합니다.

관련 항목

General 탭

Highlighting 탭

Tokens 탭

Parser 탭

Rules 탭

Sub Languages 탭

Code Templates 탭

Grammar 탭


LM - Code Templates

Code Templates 탭

이 탭에서 코드 템플릿을 설정하고 삭제할 수 있습니다. 다른 언어에 대한 다른 코드 템플릿을 개발할 수 있습니다.

템플릿을 추가하려면

  1. Toad Options|Editor - Behavior 페이지에서 코드 템플릿을 추가할 언어를 선택하고 Edit를 누릅니다.

  2. Code Templates 탭을 누릅니다.

  3. Add를 누릅니다.

  4. 바로 가기 이름과 설명을 입력합니다. OK를 누릅니다.

  5. 템플릿 목록 아래의 editor 창을 누르고 포함할 텍스트를 입력합니다. 코드 완성 템플릿에 설명된 대로 대체 변수와 커서 배치를 포함할 수 있습니다.

  6. OK를 누릅니다.

템플릿을 편집하려면

  1. Toad Options|Editor - Behavior 페이지에서 코드 템플릿을 추가할 언어를 선택하고 Edit를 누릅니다.

  2. Code Templates 탭을 누릅니다.

  3. 완성 템플릿을 선택한 다음 Edit를 누릅니다.

  4. 바로 가기 이름과 설명을 변경합니다. OK를 누릅니다.

  5. 템플릿 목록 아래의 editor 창을 누르고 코드 템플릿을 편집합니다.

  6. OK 또는 Apply를 누릅니다.

관련 항목

General 탭

Highlighting 탭

Tokens 탭

Parser 탭

Rules 탭

Sub Languages 탭

Grammar 탭

코드 완성 템플릿


LM - Grammar

Grammar

grammar 탭은 rules 탭에서 쉽게 만들 수 있는 것보다 자세한 지정을 제공하는 데 사용됩니다.

실제로 조건 없는 규칙을 작성하고 Advanced 탭에서 목록의 문법을 선택하여 고유한 규칙으로 만들 수 있습니다.

문법 데모에 액세스하려면

  1. Toad Options|Editor|Behavior의 Language Management 영역에서 Pascal을 선택합니다.

  2. Edit를 누릅니다.

  3. Grammar 탭을 누릅니다.

관련 항목

General 탭

Highlighting 탭

Tokens 탭

Parser 탭

Rules 탭

Sub Languages 탭

Code Templates 탭

Grammar 탭


코드 완성 템플릿

코드 완성 템플릿은 수동 키 입력(<CTRL><SPACE>)을 사용하여 대체를 수행합니다. 코드 템플릿은 단순히 하나의 구가 아니라 줄 바꿈, 대체 변수 및 커서 위치 표시기를 포함할 수 있습니다.

Language Management, Code Templates 탭에서 코드 완성 템플릿을 직접 편집할 수 있습니다. 또한 별칭 항목을 참조하십시오.

예

Language Management에 정의된 코드 템플릿 중 하나는 다음과 같습니다.

entire cursor block (crbl)

DECLARE

CURSOR c1 IS

SELECT | FROM WHERE;

c1rec IS c1%ROWTYPE;

BEGIN

OPEN c1;

LOOP

FETCH c1 INTO c1rec;

EXIT WHEN c1%NOTFOUND;

END LOOP;

CLOSE c1;

END;

Where:

  • "crbl"은 템플릿에 대한 매크로입니다(사용자가 입력하는 텍스트).

  • "entire cursor block"은 템플릿에 대한 설명입니다.

  • 뒤이어서 다음 템플릿까지 오는 모든 내용은 템플릿의 본문입니다.

주: 템플릿 설명의 끝과 마지막 오른쪽 대괄호 사이에 공백을 두지 마십시오. 프로파일 문자열을 관리하기 위한 NT4.0 API 호출에는 템플릿 파일 읽기가 실패하는 버그가 존재합니다.

코드 템플릿을 사용하려면

  • 매크로(예: <crbl>)를 입력한 다음 <CTRL><SPACE>를 눌러 템플릿 본문을 로드하고 세로 파이프 문자의 위치에 커서를 놓습니다. 커서 아래의 단어나 구가 기존 매크로와 정확하게 일치하지 않을 경우 모든 매크로의 드롭다운 목록이 표시됩니다.

커서 배치

템플릿 본문에서 단일 파이프( | )가 발견될 경우 템플릿 대체가 완료되면 커서는 코드의 해당 위치에 배치됩니다. 파이프는 커서 위치에 대한 마커로만 사용되기 때문에 제거됩니다. 코드 템플릿에서는 하나의 파이프만 이 방법으로 사용할 수 있습니다.

대체 변수

또한 코드 완성 템플릿은 대체 변수를 지원합니다. 앰퍼샌드 다음에 간단하고 유효한 Oracle 식별자가 오는 형태로 대체 변수를 입력합니다. 예를 들어 &1은 대체 변수가 아니지만 &a는 대체 변수입니다.

대체 변수가 포함된 템플릿이 선택될 경우 값을 입력하라는 메시지가 표시됩니다. 값을 입력하면 모든 대체 변수가 입력된 값으로 바뀝니다.

바로 가기 키

코드 완성 템플릿의 기본 바로 가기 키는 <CTRL><SPACE>입니다. 템플릿 이름(예: crbl)을 입력하고 바로 가기를 눌러 확장합니다.

템플릿 사용

템플릿 이름을 입력하고 바로 가기 키를 입력할 경우 Toad에서는 다음 절차를 따릅니다.

  • 입력한 이름이 코드 템플릿 목록의 이름과 일치하지 않을 경우 사용 가능한 코드 템플릿의 드롭다운 목록이 표시되므로 올바른 템플릿을 선택할 수 있습니다.

  • 대체 변수가 나열되고 값을 입력하라는 메시지가 표시되는 대화 상자가 나타납니다.

  • 코드를 확장하고 변수를 대체합니다.

  • 커서 배치 마커를 제거하고 커서를 해당 위치에 배치합니다.

코드 템플릿 목록 편집

Toad에서는 기본 템플릿 목록이 제공됩니다. 그러나 이 기능을 사용하면 목적에 더 적합한 템플릿을 만들고 기본 템플릿을 편집할 수 있습니다.

Language Management 창에서 요구에 맞게 템플릿을 편집하고 추가할 수 있습니다.

관련 항목

별칭

Auto Replace 대체 항목


Auto Replace 대체 항목

대체 항목은 대체 텍스트에 해당하는 텍스트 구입니다. 예를 들면 다음과 같습니다.

  • ACT = ACTIVITY_CENTERS의 대체 쌍을 지정할 경우 ACT를 입력하고 공백(또는 단어 구분 기호)을 누르면 ACT가 ACTIVITY_CENTERS로 자동으로 바뀝니다.

  • NDF = NO_DATA_FOUND의 대체 쌍을 지정하고 NDF를 입력한 다음 구분 기호를 누를 경우 NDF는 NO_DATA_FOUND로 자동으로 바뀝니다.

Auto Replace 항목을 편집하려면

  • Toad Options|Editor - Behavior 페이지에서 Auto Replace를 누릅니다.

대체 항목 사용

자동 바꾸기가 활성화된 경우 Toad에서는 여러 문자를 자동 바꾸기 활성화 키로 사용합니다. Toad에서는 공백 키와 같은 종료자에 도달하면 활성 키를 자동으로 대체 값으로 바꿉니다. 예를 들어 Editor에서 "teh"는 기본적으로 "the"로 바뀌도록 설정됩니다. 또는 "pack"을 입력할 경우 "package"로 확장됩니다.

활성화 키는 커서 바로 앞에 있는 일치하는 "replace" 문자열을 "with" 대체 값으로 바꾸게 합니다. 예를 들어 자동 바꾸기 파일에 dept = DEPARTMENT가 있는 경우 다음을 수행할 수 있습니다.

dept[space]를 입력할 수 있으며 이 경우 editor에서는 DEPARTMENT로 확장됩니다.

또는 dept:를 입력할 수 있으며 이 경우 Editor에서는 DEPARTMENT:로 확장됩니다.

또는 dept;를 입력할 수 있는 이 경우 Editor에서는 DEPARTMENT;로 확장됩니다.

주: 활성화 키는 항상 확장된 대체 항목에 포함됩니다.

다른 요구 사항에 맞게 상자에서 이 키 목록을 편집할 수 있습니다.

파일 가져오기 및 내보내기

또한 Editing options 창에서 자동 대체 파일을 가져오고 내보낼 수 있습니다.

Toad에서는 여러 유용한 대체 쌍이 제공됩니다. Auto Replace 대화 상자에서 이 목록을 편집하여 항목을 추가할 수 있습니다. 그런 다음 설정을 텍스트 파일에 내보낼 수 있습니다. 또는 대체 파일을 수동으로 작성하거나 편집한 다음 가져올 수 있습니다. 대체 파일 편집을 참조하십시오.

Export

자동 바꾸기 설정을 별개의 텍스트 파일에 저장할 수 있습니다. 자동 바꾸기 설정을 많이 변경할 경우 백업을 위해 정기적으로 내보내는 것이 좋습니다.

주: 파일을 가져오기 전에 설정을 파일에 내보내지 않은 경우 설정이 손실됩니다.

Import

텍스트 파일을 Toad로 가져올 수 있습니다. 이 파일을 독립적으로 작성하거나 Toad에서 작성한 설정을 내보내서 작성할 수 있습니다.

파일을 가져오면 현재 설정을 덮어씁니다.

대체 파일 편집

인터페이스에서 많은 양의 정보를 대체 파일에 직접 추가하는 것은 지루할 수 있으므로 텍스트 파일을 직접 편집하거나 만들 수 있습니다.

문자열=대체 문자열 형식을 사용합니다. 예를 들면 다음과 같습니다.

aax=AAX_ACCESSGROUP_APPLICATION

aca=ACA_ACTIVITY_ACTION

acc=ACC_ACTIVITY_CATEGORY

acd=ACD_ACTION_DESCRIPTION

acp=ACP_ACTIVITY_CONTACT_PARTIC

관련 항목

별칭

코드 완성 템플릿


인쇄

Toad에서 여러 가지 방법으로 프린터에 데이터를 전송할 수 있습니다. Editor의 텍스트 또는 코드를 인쇄할 수 있고, 데이터 눈금의 데이터를 인쇄할 수 있으며, Reports Manager를 사용하여 보고서를 인쇄할 수 있습니다.

Editor 내용 인쇄

Editor 텍스트 또는 Editor 코드를 인쇄하면 Toad가 기본값으로 컬러로 인쇄합니다. View|Toad Options|Editor -Display|Syntax Highlighting|Use when printing을 선택 취소하면 코드가 표준값인 흑백으로 인쇄됩니다.

Editor 텍스트 또는 Editor 코드를 인쇄하려면

  • File 메뉴에서 Print를 선택합니다.

데이터 눈금 인쇄

아래 절차에 따라 데이터 눈금을 쉽게 인쇄할 수 있습니다. 인쇄된 눈금을 사용자 정의하려면 인쇄 옵션에 대한 자세한 내용은 눈금 인쇄 및 Report Link Designer 항목을 참조하십시오.

데이터 눈금을 인쇄하려면

  • Grid 메뉴에서 Print Grid를 선택합니다.

또는

데이터 눈금에서 마우스 오른쪽 단추를 누르고 Print Grid를 선택합니다.

관련 항목

눈금 인쇄

Report Link Designer

Reports Manager


Print Grid

results 그리드를 인쇄하려는 경우 두 가지 인쇄 방법 중 하나를 선택할 수 있습니다. 그리드 내용(질의 결과)만 인쇄하거나 이러한 결과를 반환한 질의를 포함할 수 있습니다.

다음 작업을 처음 수행할 때 print 대화 상자가 나타납니다.

그리드 질의를 포함하려면

  1. File 메뉴, Grid 메뉴 또는 마우스 오른쪽 단추 메뉴에서 Print Grid 메뉴 항목을 선택합니다.

  2. Query 영역에서 Print 상자를 선택합니다. 질의를 결과 앞에 인쇄할지 아니면 뒤에 인쇄할지 선택합니다.

  3. 데이터를 프린터로 보내기 전에 Print Preview를 눌러 추가 옵션을 위한 Report Link Designer 대화 상자에 액세스합니다.

그리드 결과를 인쇄하려면

  1. File 메뉴, Grid 메뉴 또는 마우스 오른쪽 단추 메뉴에서 Print Grid 메뉴 항목을 선택합니다.

  2. Query 영역에서 필요한 경우 Print 상자를 선택 취소합니다.

  3. 데이터를 프린터로 보내기 전에 Print Preview를 눌러 추가 옵션을 위한 Report Link Designer 대화 상자에 액세스합니다.

원래 print grid 대화 상자를 사용하려면

  • View|Toad Options|Data Grid - Data|Use legacy print grid에서 옵션을 설정합니다.

관련 항목

Print Grid

Report Link Designer

Report Manager


Report Link Designer

Report Link Designer의 데이터 눈금에서 인쇄할 방식을 변경할 수 있습니다.

주: 이 버전의 인쇄 눈금을 사용하려면 Toad Options|Data Grids|Data|Use legacy Print grid를 선택 취소해야 합니다.

Report Link Designer를 액세스하려면

  1. Grid 메뉴에서 Print Grid를 선택합니다.

또는

마우스 오른쪽 단추 메뉴에서 Print Grid를 선택합니다.

  2. Print Preview를 누릅니다.

  3. Design [image] 단추를 누릅니다.

또는

마우스 오른쪽 단추를 누르고 Design을 선택합니다.

ReportLink Designer 사용

이 대화상자를 사용하여 눈금 인쇄 옵션을 선택한 다음 눈금 내용을 종이로 인쇄합니다.

이 화면에는 다음과 같은 5개의 탭이 있습니다. Options , Colors , Fonts , Behaviors 및 Miscellaneous .

이 탭에서 변경한 내용은 모두 오른쪽 패널에 미리 보여집니다.

Title Properties

Title Properties를 누르면 대화상자가 열리고, 여기서 보고서의 제목을 설정하고 인쇄 위치(모든 페이지의 상단 등)를 지정할 수 있습니다. Properties 탭을 눌러 글꼴, 색상 및 제목의 정렬 방식을 설정합니다.

Options 탭

Show

  • Bands

표시되어 있으면 Toad가 눈금 상단에 빈 막대를 추가합니다. 기본값으로 표시되어 있지 않습니다.

  • Header

표시되어 있으면 열 머리글이 인쇄물에 포함됩니다. 표시되어 있지 않으면 열 머리글이 포함되지 않습니다. 기본값으로 표시되어 있습니다.

  • Footers - 데이터 눈금에 적용 불가능

  • Group Footers - 데이터 눈금에 적용 불가능

Preview

표시되어 있고 Preview Current Column을 활성화한 경우 미리 보기 열이 인쇄됩니다.

표시되어 있지 않거나 표시되어 있고 Preview Current Column을 활성화하지 않은 경우 미리 보기 열이 인쇄되지 않습니다.

기본값으로 표시되어 있지 않습니다.

Grid

  • NodeGrid

표시되어 있으면 데이터 눈금의 열 줄이 인쇄됩니다. 표시되어 있지 않으면 데이터 눈금의 열 줄이 인쇄되지 않습니다. 기본값으로 표시되어 있습니다.

  • Grid

표시되어 있으면 눈금 줄(행과 열 사이의 줄)이 인쇄됩니다. 표시되어 있지 않으면 눈금 줄이 인쇄되지 않습니다. 기본값으로 표시되어 있습니다.

Colors 탭

Colors 탭에서 색상을 설정할 수 있습니다. 눈금 배경, 미리 보기 열, 밴드, 머리글 및 눈금 줄의 색상을 설정할 수 있습니다. Transparent 확인란을 표시하면 색상이 제거되고 관련 색상 드롭다운이 비활성화됩니다.

  • Group Node 및 Group Footers(및 색상 선택)는 데이터 눈금에 적용할 수 없습니다.

  • Extended Management by Colors- 이번에는 구현되지 않습니다.

Fonts 탭

Change Font 단추를 누르면 선택한 눈금 영역의 글꼴을 변경할 수 있습니다. 밴드, 글꼴, 머리글 및 미리 보기가 여기에 포함됩니다.

Behaviors 탭

Behaviors 탭에서 밴드 및 머리글의 배치 위치, 선택 인쇄 양, 노드의 자동 확장 여부를 변경할 수 있습니다. 또한 3차원 효과를 선택할 수 있습니다. Graphics 영역은 현재 Toad에서 인쇄 가능한 모든 눈금에 적용할 수 없습니다.

Miscellaneous 탭

Miscellaneous 탭에서 트리 보기 눈금 및 확인 표시에 대한 효과를 선택할 수 있습니다.

관련 항목

눈금 인쇄

눈금 내용 인쇄

Reports Manager


Toad와 함께 SQL Optimization 사용

Toad와 함께 SQL Optimizer 사용

Toad와 함께 SQL을 조정하는 방법은 두 가지가 있습니다. Oracle 10g 이상을 사용할 경우 Oracle Tuning Advisor를, SQL Optimizer 모듈이 있을 경우 Quest의 SQL Optimization을 사용할 수 있습니다.

Oracle Tuning Advisor

이 기능은 Toad professional 버전에서만 사용할 수 있습니다.

SQL 구문을 Oracle Tuning Advisor로 전송할 수 있습니다. 그런 다음 결과가 Editor 창에 전송됩니다. 이 결과의 형식 및 내용은 Oracle에서 제공합니다. 이 기능은 다음에서 액세스할 수 있습니다.

  • Editor 창

  • Create/alter 창

  • 보기

  • 트리거

  • 스냅샷

  • Schema Browser

  • 보기

  • 트리거

  • 스냅샷

Oracle Tuning Advisor를 사용하려면

  1. 조정할 구문 내에 커서를 두거나 조정할 코드를 강조표시합니다.

  2. 도구 모음에서 SQL Optimizer [image] 드롭다운을 누릅니다.

  3. SQL Tuner (Oracle)를 선택합니다.

Quest SQL Optimization

이 기능은 SQL Optimizer 모듈이 포함된 Toad 버전에서만 사용할 수 있습니다.

Toad 내의 여러 영역에서 SQL을 조정할 수 있습니다. SQL Optimizer는 다음에서 액세스할 수 있습니다.

  • Editor - Editor 도구 모음의 SQL Optimizer 단추를 누릅니다.

  • Create/Alter 창

  • 보기

  • 트리거

  • 스냅샷

  • Query Builder - Generated Query 탭 도구 모음.

  • Session Browser - Current Statement Details 탭.

  • SGA Trace/Optimization 창 - SQL 탭.

  • Schema Browser 탭:

  • Views|보기 선택|마우스 오른쪽 단추를 누르고 Optimize View's SQL을 선택합니다.

  • Snapshots|보기 선택|마우스 오른쪽 단추를 누르고 Optimize Snapshot's SQL을 선택합니다.

  • Procs|Details|Code 탭|조정할 SQL 강조표시|탭의 도구 모음에서 Optimize SQL 단추를 누릅니다.

  • Triggers|Details|Code 탭|조정할 SQL 강조표시|탭의 도구 모음에서 Optimize SQL 단추를 누릅니다.


힌트 및 팁: 자동 실행 및 트랜잭션 처리

Auto Commit이 비활성화되어 있으면 Toad를 구성하여 Auto Commit을 수행하거나 종료 시 실행할 수 있습니다.

활성화되어 있으면 Toad는 현재 사용자의 DBMS_TRANSACTION 액세스를 점검합니다. 사용자에게 액세스 권한이 있으면 Toad는 보류 중인 실제 트랜잭션이 있는지 확인하고 필요할 경우 종료 시에만 나타날 수 있습니다. 사용자에게 액세스 권한이 없으면 다른 "Prompt on exit" 옵션이 수반됩니다.

로그인할 때 액세스 점검을 위해 필요한 추가 시간이 있으므로 시스템 보기 점검은 선택 사항입니다. 일부 사용자는 필요할 경우 직접 실행하는 것을 선호하며 종료할 때마다 질문하는 소프트웨어가 없습니다.


힌트 및 팁: Personal Oracle에 연결

Personal Oracle에 연결하거나 PO7 또는 PO8용으로 SQL*Net 별칭을 작성하는 과정에서 문제가 발생하는 경우에는 Toad 로그인 창에서 데이터베이스 이름으로 다음 네 가지 항목 중 하나를 입력해 보십시오.

2:

BEQ-LOCAL

LOCAL

TCP-LOOPBACK

Schema/Passwords에는 다음 쌍 중 하나를 입력해 보십시오.

DEMO/DEMO

SCOTT/TIGER

SYS/CHANGE_ON_INSTALL

SYSTEM/MANAGER


힌트 및 팁: Explain Plan 표

Toad는 열이 있는 Explain Plan 표를 찾아 Oracle에서 가장 최근의 사양과 일치하는지 확인합니다.

Explain Plan을 실행할 때 "Invalid Column" 오류가 발생하면 Server Side Install 마법사를 사용하여 Explain Plan 표를 다시 작성할 수 있습니다.

Plan 표는 View|Toad Options|Oracle 탭의 Explain Plan Table Name: 상자에서 설정할 수 있습니다.


힌트 및 팁: 데이터 내보내기

Toad에서 데이터를 내보내는 여러 가지 방법이 있습니다. 이 방법은 다음과 같습니다.

  • Create Insert Statements - 표 데이터는 Schema Browser에서 "INSERT INTO..." 구문으로 내보낼 수 있습니다.

  • Save as - Editor Grid 상에 있을 때 마우스 오른쪽 단추 메뉴를 사용하여 SQL Edit 눈금의 내용을 여러 형식으로 저장할 수 있습니다.

  • Export Table Data - Database|Export|Table Data를 선택하여 데이터를 내보냅니다.

  • Export Wizard - Quest DBA 모듈에는 Oracle의 내보내기 유틸리티 인터페이스가 있습니다.

  • Export to Flat file - 데이터를 단일 파일 형식으로 내보냅니다.


힌트 및 팁: 파일 확장자 연결

탐색기 및 메모장에서 .TXT 파일을 두 번 누르면 TXT 확장자 및 NOTEPAD.EXE 간에 연결이 존재하므로 메모장이 로드됩니다.

.SQL(또는 .PKG 등) 확장자 및 View|Toad Options|Files 탭의 Toad 간에 유사한 연결을 작성할 수 있습니다. (자세한 내용은 옵션: 파일을 참조하십시오.)

주: 확장자를 만들고 네트워크 경로에서 Toad를 실행하려면 파일 확장자의 OPEN 명령을 직접 변경하여 PATH 인수를 포함해야 합니다.

예:

H:\toad\Toad.exe "%1" "PATH=C:\MYToadDIR"

선택 사항인 Path 인수가 없으면 OPEN 명령은 다음과 같이 나타납니다.

C:\toad\Toad.exe "%1"


힌트 및 팁: OCI DLL을 찾을 수 없음

Oracle에 연결하려고 할 때 이 오류 또는 유사한 오류가 발생하면 Oracle BIN 디렉토리가 시스템 경로에 있는지 확인하십시오. 이 디렉토리는 ORAWIN\BIN 또는 ORANT\BIN과 유사한 디렉토리가 됩니다. 경로를 확인할 방법을 모를 경우 DOS 프롬프트에서 PATH를 입력하고 ENTER를 누릅니다.


힌트 및 팁: 네트워크에서 Toad 실행

네트워크 드라이브에서 Toad를 실행할 수 있으며, 이를 통해 명령줄에 선택 사항으로 인수를 배치하여 Toad에서 기록하는 사용자 지정 파일 위치를 제공할 수도 있습니다. 이는 사용자가 INI 파일, SQL 파일 등을 겹쳐 쓰지 않도록 하는 데 필요합니다.

Windows NT 바로 가기의 경우 바로 가기에 마우스 오른쪽 단추를 누르고 Properties 메뉴 옵션을 선택한 다음 Shortcut Tab을 선택합니다. Toad 실행 파일 이름에 다음을 추가하십시오.

PATH=C:\MYToadPATH

여기서 C:\MYToadPATH는 실행 파일 및 도움말 파일이 아닌 Toad 파일이 대부분 포함되어 있는 경로를 참조합니다. 즉, 각각의 사용자는 필요한 파일이 제 위치에 있는 toaddir\TEMPS 디렉토리를 가지게 됩니다.

Toad Commercial installation 스크립트에는 전체 클라이언트 또는 클라이언트와 서버를 설치할 수 있는 옵션이 있습니다. 자세한 내용은 시작 안내서를 참조하십시오.


힌트 및 팁: 표 및 열

Oracle은 표, 표 열, 보기, 보기 열, 스냅샷 및 스냅샷 열의 설명을 최대 2000개의 문자까지 저장할 수 있는 기능을 제공합니다. 이 기능은 훌륭하지만 사용되지 않는 방법으로, 개발자뿐만 아니라 보고서 작성자, QA 및 데이터베이스를 액세스해야 하는 다른 사용자에게 DDL 설계를 설명할 수 있습니다.

Schema Browser에 설명 추가

Schema Browser 창은 선택한 표에 표 및/또는 열 설명을 쉽게 입력할 수 있는 방법을 제공합니다. 설명의 변경 내용은 데이터베이스에 자동으로 게시됩니다.

  • 표를 선택합니다.

  • 드롭다운 목록에서 설명 유형을 선택합니다.

  • 설명 영역에 입력합니다.

  • 편집 후 및 Schema Browser 창을 닫기 전에 데이터베이스에 전송하기 위해 편집 중인 설명에 다른 표를 선택해야 합니다.

Schema Browser에서 설명 보기

Schema Browser의 Tables 페이지에서 세부 사항 패널의 표 설명을 표시하거나 숨기기로 선택할 수 있습니다.

설명을 표시하거나 숨기려면

  1. 검토할 표를 선택합니다.

  2. 마우스 오른쪽 단추를 누르고 Show column comments in list를 선택합니다. 이 옵션이 표시되어 있으면 설명이 눈금의 마지막 열에 표시되고 표시되어 있지 않으면 설명이 표시되지 않습니다.

Editor에 설명 추가

표, 보기, 보기 열, 스냅샷 또는 스냅샷 열에 설명을 추가하려면 Editor 창에서 다음과 같은 SQL 구문을 수행할 수 있습니다.

comment on table schema.table_name is 'text'

comment on table schema.view_name is 'text'

comment on table schema.snapshot_name is 'text'

comment on column schema.view.column is 'text'

comment on column schema.snapshot.column is 'text'

설명을 삭제하려면 'text'를 ''(즉, 따옴표 안의 텍스트를 모두 삭제)로 설정합니다.


힌트 및 팁: 표가 없습니다 오류

Toad 표는 이전 Explain Plan 결과, Profiler, Team Coding 및 Toad 보안 회수에 필요합니다. Toad를 사용하기 위해 이러한 표를 작성할 필요는 없지만 위에 나열된 기능에 필요할 것입니다. 이러한 표를 작성하려면 Server Side Object Install 마법사를 실행합니다.

또한, 여러 V$ 표가 다른 화면에 필요합니다. 화면에 필요한 표 목록을 화면별로 보려면 필수 V$ 표를 참조하십시오.


힌트 및 팁: 오른쪽 마우스 단추

오른쪽 마우스 단추를 눌러 구문 지정 메뉴를 활성화하며 기본 메뉴에서 사용할 수 없는 기능을 종종 액세스할 수 있습니다. 마우스 오른쪽 단추 메뉴는 <F10> 키를 눌러 액세스할 수도 있습니다. 일부 항목은 다른 위치에서 찾을 수 있는 명령 또는 창의 바로 가기입니다. 다른 항목은 메뉴에 고유하며 Toad에서 찾을 수 없습니다.


힌트 및 팁: TNS 이름 해결할 수 없음

SQL*Net의 32비트 버전이 전체 설치되어 있어야 합니다. SQL*Plus로 연결하면 SQL*Net가 설치되어 있는지 확인할 수 없습니다. Toad를 사용하여 Oracle에 연결할 수 없으면 Oracle 클라이언트 소프트웨어가 올바르게 설치되지 않습니다. Oracle 설치 디스크 또는 CD ROM에서 SQL*Net 클라이언트를 다시 설치합니다. 또는 OEM, NetAssist, Oracle Lite 또는 기타 Oracle 소프트웨어가 최근에 설치되어 있으면 해당 소프트웨어를 제거하고 Toad를 사용하여 연결할 수 있는지 확인합니다. Oracle의 자체 소프트웨어는 SQL*Net 설정을 억제하는 데 있어 최악의 원인이 됩니다.

또한 SQL*Net이 다음 레지스트리 설정을 확인하여 올바른 TNSNames 파일을 사용하려고 하는지 확인합니다.

HKEY_LOCAL_MACHINE\Software\Oracle\TNS_ADMIN

TNSNAMES.ORA 파일이 위치한 올바른 폴더를 지정합니다.

관련 항목

설치 메모: SQL_Net 및 Net8

Oracle Home Editor

SQLNet Editor


질문과 대답(FAQ)

알아야 할 내용이 이 도움말 파일에 없으면 웹에 있는 사용자 기반의 FAQ 데이터베이스를 참조하십시오.

이 사이트에서 Toad 전자 메일 목록을 검색할 수도 있습니다.

자세한 내용은 Toad 지원 사이트를 참조하십시오.


Call Rates

Call Rates 차트는 Parse, Execute, Commit 및 Rollback 이벤트에 해당하는 초당 호출을 그래프로 표시합니다.


CRON

지정된 시간 또는 날짜에 자동으로 명령이나 스크립트를 실행하는 표준 UNIX 프로그램입니다.


Crontab 파일

실행할 스크립트와 실행 시기를 정의하기 위해 CRON에서 사용하는 파일입니다. 스케줄러에서는 crontab 파일을 작성하여 사용자가 서버 속성의 "Toad directory on server" 필드에 정의한 디렉토리에 넣습니다.


Database Probe 피연산자

피연산자는 주 창에서 경고 식을 구성하는 데 사용할 수 있는 데이터 항목입니다. 예를 들어 화면의 왼쪽 위 모퉁이에 있는 Total Sessions는 다른 모든 데이터 디스플레이 레이블 및 확인란과 마찬가지로 피연산자입니다.


Database Probe 영역

주 창의 특정 영역입니다. 레이블 및 확인란과 같은 데이터 출력 표시 컨트롤의 모음으로 구성됩니다. 영역은 표시되는 정보에 따라 구성됩니다.


Event Waits

Event Waits 차트는 특정 사용에서 초당 대기한 밀리초를 그래프로 표시합니다. 가로 막대는 이러한 기능에서 데이터가 수집된 시간을 나타내고 세로 막대는 초당 대기한 밀리초를 나타냅니다.

주: "Other"에는 control file sequential read, control file single write, control file parallel write, db file sequential read, db file scattered read, direct path read, file identify, file open, SQL*Net message to client, SQL*Net message to dblink, SQL*Net more data to client, SQL*Net more data to dblink, SQL*Net break/reset to client, SQL*Net break/reset to dblink, log file single write 및 log file parallel write 대기 이벤트만 포함됩니다.


Indexed Queries %

Indexed Queries % 차트는 인덱싱된 질의와 인덱싱되지 않은 질의에 사용된 메모리를 그래프로 표시합니다. 세로 막대는 수행된 총 질의의 비율을 나타냅니다.


작업

서버에 배포되었으며 특정 시간에 실행되는 서버의 crontab 파일에 항목이 있는 작업 파일입니다.


Logical IO

Logical IO 차트는 논리 입/출력 사용을 그래프로 표시합니다. 그래프의 가로 막대는 경과된 시간을 나타내고 세로 막대는 Block Changes, Current Reads 및 Consistent reads에 대한 초당 블록 수를 나타냅니다.


일치하지 않는 다시 실행 로그 크기

" select bytes from v$log where group# = Redo_Log_Files_Current " <> " select avg(bytes) from v$log where group# != Redo_Log_Files_Current "


Miss Rates

Miss Rates 차트는 버퍼 캐시, SQL 영역 및 래치에 대한 누락된 비율을 그래프로 표시합니다.


Physical IO

Physical IO 차트는 실제 입/출력 사용을 그래프로 표시합니다. 가로 막대는 데이터가 수집된 시간을 나타내고 세로 막대는 데이터 파일 읽기, 데이터 파일 쓰기 및 다시 실행 쓰기로 구분하여 초당 IO를 나타냅니다.


원시 디스크

OS 파일 시스템에 할당되지 않은 디스크입니다. 자세한 내용은 Oracle 설명서를 참조하십시오.


Sessions

Sessions 차트는 모니터링된 시간 동안 사용된 세션을 그래프로 표시합니다. 세로 막대는 세션을 나타내며 Idle, Active 및 System 세션으로 구분되어 있습니다. 가로 막대는 데이터가 수집된 시간을 나타냅니다.


SGA Memory Usage

SGA Memory Usage 차트는 Fixed SGA, Log Buffer, Buffer Cache, Shared Pool, Large Pool 및 Java Pool에 대한 메모리 사용을 그래프로 표시합니다. 세로 막대는 사용된 KB를 나타냅니다.


Shared Pool

Shared Pool Usage 차트는 SGA Memory Usage 차트보다 자세하게 공유 풀의 메모리 사용을 그래프로 표시합니다. 여기에는 Miscellaneous, Dictionary Cache, Library Cache, Free memory 및 SQL Area에 대한 사용이 포함됩니다. 세로 막대는 사용된 KB를 나타냅니다.


Windows hosts 파일

Windows 시스템 디렉터리(일반적으로 C:\WINNT\system32\drivers\etc)에 들어 있는 "hosts"라는 파일입니다. 이 파일은 TCP/IP에서 IP 주소를 호스트 이름으로 매핑하는 데 사용됩니다.


Java 소스 코드 작성

Oracle에서 Java 코드를 작성하는 방법에는 두 가지가 있습니다.

  • LOADJAVA를 사용하여 외부 파일에서 로드

자세한 내용은 Java Manager - 개체 로드를 참조하십시오.

  • CREATE OR REPLACE AND RESOLVE JAVA SOURCE Oracle 문 실행

이 명령은 Procedure Editor에 입력하여 Toad 내에서 컴파일할 수 있습니다.


중단점 편집

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

기존 중단점을 변경할 수 있습니다.

중단점을 편집하려면

  1. Breakpoints 창이 열려 있지 않은 경우 엽니다. Desktops 도구 모음에서 Breakpoints를 선택합니다.

  2. 중단점을 선택하고 Properties 대화 상자를 엽니다.

  3. 다음 작업 중 하나를 수행하십시오.

  4. 중단점을 한 번 눌러 선택하고 도구 모음에 있는 Edit Breakpoint [image] 아이콘을 누릅니다.

  5. Breakpoints 창에서 중단점을 두 번 누릅니다.

  6. 중단점을 한 번 눌러 선택하고 마우스 오른쪽 단추를 눌러 메뉴를 표시한 후 Edit Breakpoint를 선택합니다.

  7. <CTRL>E를 누릅니다.

Breakpoint Properties 대화 상자가 나타납니다.

  4. 원하는 속성을 변경하고 OK를 누릅니다.


변수 정보 입력

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

SQL에는 코드를 실행하기 전에 설정해야 하는 매개 변수가 있을 수 있습니다. 이 매개 변수 값은 코드를 실행하기 전에 설정해야 합니다.

Execute 단추를 누르거나 코드를 단계별로 실행하면 이 매개 변수를 입력하라는 메시지가 표시됩니다.

매개 변수를 입력하려면

  1. 코드를 단계별로 실행하거나 실행하기 시작합니다.

  2. Script Debugger가 매개 변수를 설정해야 하는 각 문에 도달하면 Input 창이 표시되며 매개 변수 값을 입력하라는 메시지가 표시됩니다.

매개 변수가 스키마나 테이블 공간 이름으로 구성된 경우에는 매개 변수 상자 옆에 드릴다운 [image] 단추가 표시됩니다. 이 단추를 사용하여 전체 테이블 공간 또는 스키마 목록을 표시하고 목록에서 항목을 선택할 수 있습니다.

관련 항목

Script Debugger 개요

Script Debugger 도구 모음

Quest 확장


JD 중단점 설정

중단점 설정

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Java Debugger에서는 PL/SQL 디버깅의 경우와 같은 방법으로 중단점을 설정할 수 있습니다.

중단점을 설정하려면

  • 중단점을 설정할 줄의 거터를 누릅니다.

또는

Breakpoints 창에서 Add Breakpoint [image] 단추를 누릅니다.

관련 항목

Java Debugger 개요

Java Debugger 시작

조사식 설정

한 단계씩 Java 코드 실행

Java 디버깅 문제 해결

Breakpoint 창

중단점 속성 설정

중단점 활성화/비활성화

중단점 편집

중단점 삭제


JD_조사식 설정

조사식 설정

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Java Debugger에서는 PL/SQL 디버깅의 경우와 같은 방법으로 조사식을 설정할 수 있습니다.

Editor에서 조사식을 추가하려면

  1. Editor에서 Variable을 누릅니다.

  2. 도구 모음에서 Add Watch [image] 단추를 누릅니다. 변수가 조사식 목록에 추가됩니다. Watches 창이 열려 있지 않은 경우 이 창을 열어 조사식을 봐야 합니다.

또는

Editor 안쪽을 마우스 오른쪽 단추로 누르고 Debug를 선택한 다음 Add Watch at Cursor를 선택합니다.

Watches 창에서 조사식을 추가하려면

  • 마우스 오른쪽 단추를 누르고 Add Watch 메뉴 항목을 선택합니다. Watch Properties 대화 상자가 나타납니다.

또는

<CTRL>F5를 눌러 커서 위치에 있는 변수를 조사식 목록에 추가합니다. 조사식이 추가되지만 Watch Properties 대화 상자는 표시되지 않습니다.

Debug 메뉴에서 조사식을 추가하려면

  1. 감시할 Variable을 누릅니다.

  2. Debug 메뉴에서 Add Watch at cursor를 선택합니다.

관련 항목

Java Debugger 개요

Java Debugger 시작

중단점 설정

한 단계씩 Java 코드 실행

Java 디버깅 문제 해결

Watch 창

Watch Properties 설정

조사식 활성화/비활성화

조사식 편집

조사식 삭제


SD_문 실행

문 실행

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Script Debugger를 사용하여 전체 스크립트, 선택한 지점까지의 스크립트 또는 단일 문을 실행할 수 있습니다.

스크립트를 실행하려면

  1. 스크립트가 활성화되어 있지 않은 경우에는 Script Debugger 맨 위에 있는 적절한 탭을 누릅니다.

  2. Run script [image] 단추를 누릅니다.

커서까지 실행하려면

  1. 스크립트가 활성화되어 있지 않은 경우에는 Script Debugger 맨 위에 있는 적절한 탭을 누릅니다.

  2. Run to cursor [image] 단추를 누릅니다.

단일 문을 실행하려면

  1. 스크립트가 활성화되어 있지 않은 경우에는 Script Debugger 맨 위에 있는 적절한 탭을 누릅니다.

  2. 실행할 문을 누릅니다.

  3. <CTRL><Enter>를 누릅니다.

선택한 문을 실행하려면

  1. 스크립트의 실행할 영역을 선택합니다.

  2. 다음 중 하나:

  3. Run [image] 단추를 누릅니다.

또는

<F11> 키를 누릅니다.

관련 항목

Script Debugger 개요

Script Debugger 도구 모음

Quest 확장

Navigator 패널

Script Output 탭

Script Debugger 탭

Source Control 사용


상위 종속 관계

B가 C를 호출하면, B는 C를 참조합니다. B가 상위 종속 관계입니다.

B가 A를 호출하고, A가 원래 B를 호출했다면 A가 상위 종속 관계입니다.

하위 종속 관계를 컴파일하면 Oracle 사전에서 상위 종속 관계를 무효로 표시합니다. 이 작업을 알리는 시각적인 표시는 없지만, 상위 종속 관계를 실행하려 하면 거부됩니다.


Script Debugger에서 Source Control 사용

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

Source Control 도구 모음은 Script Debugger 창의 맨 위에 있습니다. 표준 Source Control은 Script Debugger와 완전히 통합됩니다. 출입하는 항목을 확인하고, Source Control 프로젝트를 변경하고, 체크 아웃을 취소할 수 있습니다.

주: 이 때에는 Script Debugger에서 Team Coding을 사용할 수 없습니다.

관련 항목

Source Control

Team Coding

Script Debugger 개요

Script Debugger 도구 모음

Quest 확장

문 실행

Navigator 패널

Script Output 탭

Script Debugger 탭


Java 코드 배치

PL/SQL에서 Java 코드를 호출하려면 먼저 배치해야 합니다.

Publish Java to PL/SQL Wizard를 사용하여 코드를 배치하거나 Editor를 통해 수동으로 배치할 수 있습니다.


Execute 도구 모음

표준 도구 모음

표준 도구 모음에서는 저장, 다른 이름으로 저장, 데이터베이스에서 로드 등과 같은 표준 파일 조작 명령에 액세스할 수 있습니다.

아이콘 | 명령
 | 연결을 변경합니다.
 | 새 editor 탭을 엽니다.
 | editor 탭을 닫습니다.
 | 파일에서 로드합니다.
 | 데이터베이스에서 로드합니다.
 | 파일을 디스크에 저장합니다.
 | 파일을 새 이름으로 저장합니다.
 | 모든 파일을 저장합니다.
 | 디스크에서 개체를 다시 로드합니다.
 | 데이터베이스에서 개체를 다시 로드합니다.
 | 파일을 인쇄합니다.
 | SQL Tuning 기능입니다.
 | 코드의 프로파일을 작성합니다.
 | 선택한 코드에서 SQL이 아닌 코드 문을 만듭니다(코드 만들기).
 | 선택한 코드에서 SQL이 아닌 코드를 제거합니다(코드 제거).


Script Debugger 바로 가기 키

주: 이 확장된 Toad 기능은 디버깅 기능이 포함된 Toad for Oracle 버전에서만 사용할 수 있습니다.

아래 목록은 Debugger에서 사용되는 바로 가기 키입니다. 다른 영역의 바로 가기 키에 대한 자세한 내용은 일반 바로 가기 키를 참조하십시오.

바로 가기 키 | 기능
<SHIFT>F5 | 현재 줄에서 중단점을 설정하거나 삭제
<CTRL>F5 | 커서 위치에 조사식 추가
<SHIFT>F7 | 단계별 추적
<SHIFT>F8 | 절차 단위 실행
<SHIFT>F10 | 전체 추적
F9 | 컴파일
<SHIFT>F9 | 현재 소스 실행
<SHIFT><CTRL>F9 | 매개 변수 설정
F10 | 마우스 오른쪽 단추 메뉴 표시
F11 | 실행(실행 계속)
F12 | 커서까지 실행
<CTRL><ALT>B | 중단점 표시
<CTRL><ALT>D | DBMS_Output 표시
<CTRL><ALT>E | 평가/수정
<CTRL><ALT>S | 호출 스택 표시
<CTRL><ALT>W | 조사식 표시
<CTRL><Pg Up> | Navigator 트리에서 위로 이동
<CTRL><Pg Down> | Navigator 트리에서 아래로 이동
<ALT><Pg Up> | 왼쪽의 다음 탭으로 전환
<ALT><Pg Down> | 오른쪽의 다음 탭으로 전환
<CTRL>MouseClick | 선택한 패키지 프로시저로 이동


SD_스크립트 단계별 추적

스크립트 단계별 추적

스크립트를 단계별로 추적하여 호출된 모든 스크립트를 열고 디버깅할 수 있습니다.

예를 들어 다음 스크립트를 단계별로 추적한다고 가정해 봅니다.

REM Script1.sql

SELECT * FROM USER_TABLES;

@SCRIPTB.sql

SELECT 'Done' FROM DUAL;

이 경우 첫 번째 select가 실행되고 Script Output 그리드가 채워집니다. ScriptB에 대한 참조에 도달하면 editor의 새 탭에 스크립트가 로드되고 해당 위치로 디버깅이 이동합니다. 그런 다음 사용자는 ScriptB.sql을 단계별로 추적하거나 Script b의 각 명령을 절차 단위로 실행할 수 있습니다.

ScriptB에 있는 동안 Execute 단추를 누르면 ScriptA의 끝이나 중단점에 도달할 때까지 실행이 계속됩니다.

editor에 로드된 스크립트는 Debugger 탭의 Call Stack 패널에 나열됩니다.

관련 항목

Debugger 탭

Script Debugger 도구 모음


Window: Date/Time

Date/Time

이 창은 mm/dd/yy를 입력하는 대신에 달력 선택에서 날짜를 선택하는 데 사용됩니다.

달력에서 날짜를 선택하려면

  • SQL Results 그리드에서 DATE datatype column을 두 번 누릅니다.

자세한 내용은 Date_Editor를 참조하십시오.


XMLTYPE 데이터

Toad에서는 Oracle 9.0용 XMLTYPE이 지원되지 않습니다. Oracle 9.2 이상이 필요합니다.

주: 10g 클라이언트를 사용하여 Oracle 9.2 데이터베이스의 XMLTYPE 데이터를 볼 수 없습니다. 데이터는 긴 물음표 문자열로 표시됩니다.

문서 유형 정의가 없거나 등록된 XMLSchema가 있거나 인라인 문서 유형 정의가 있는 XMLType 데이터를 편집할 수 있습니다.

Toad에서는 외부 문서 유형 정의를 가리키는 XMLType 데이터를 편집할 수 없습니다.


TO, CC, BCC

TO: 메시지를 받는 사람에게 직접 보냅니다.

CC: 참조입니다. 메시지의 사본을 여기에 입력된 전자 메일 주소로 보냅니다. 모든 받는 사람이 이러한 주소를 볼 수 있습니다.

BCC: 숨은 참조입니다. 메시지의 사본을 여기에 입력된 전자 메일 주소로 보내지만 다른 받는 사람이 이 이름을 볼 수 없습니다.


Details 패널

Schema Browser에서 Details 패널은 창의 오른쪽에 있는 패널입니다. 여기에는 왼쪽 패널의 개체 목록에서 선택된 개체의 세부 정보가 포함됩니다. 개체 유형에 따라 이 정보는 탭, 그리도 또는 목록 양식으로 구성될 수 있습니다.


Objects 패널

Schema Browser에서 Objects 패널은 창의 왼쪽에 있는 패널입니다. 그 위에는 개체 유형을 선택할 수 있는 탭 또는 드롭다운이 있습니다. 왼쪽 패널에 표시되는 개체 유형은 사용 중인 데이터베이스 버전에 따라 결정됩니다.


자원 소비자 그룹

자원 소비자 그룹을 사용하여 자원 요구 사항에 따라 사용자 세션을 그룹으로 묶을 수 있습니다. 한 사용자에게 서로 다른 자원 소비자 그룹에 할당된 여러 세션이 있을 수 있기 때문에, 역할과는 다릅니다.


자원 계획

자원 계획은 각 그룹에 제공할 자원을 지정하는 지시문을 사용하여 처리 자원을 제어하며 하위 계획을 사용하여 계층 형식으로 지정할 수 있습니다.


Update Saved Objects List

Update Saved Objects List 대화 상자는 Schema Browser의 Views 페이지나 Synonyms 페이지에서 Save list to file for syntax highlighting을 선택한 경우에 표시됩니다.

새 목록을 이전 목록에 추가하거나 이전 목록을 대체할 수 있습니다. 다른 스키마에서 저장한 보기 또는 동의어가 있는 경우 새 목록을 추가하여 이러한 설정에 저장합니다. 자세한 내용은 구문 강조표시를 참조하십시오.


Category 드롭다운

Script Manager 창의 맨 위에는 Category 드롭다운 상자가 있습니다. 화살표를 누른 다음 목록에서 원하는 범주를 선택합니다.


Criteria

개별 열을 선택하면 해당 열이 Criteria 그리드에 표시됩니다. Criteria 그리드의 여기에서 많은 열 속성을 편집할 수 있습니다. Table alias, Table 및 Schema는 여기서 편집할 수 없습니다.

Only fetch unique records 확인란

질의에 DISTINCT 명령을 적용합니다.

Null Value Subst.

이 확인란을 두 번 눌러 null 값을 대체할 값을 입력할 수 있습니다. 셀을 지우려면 해당 셀을 강조표시하고 Delete를 누릅니다.

Aggregate F.

이 확인란을 두 번 눌러 Average, Count, Max, Min, Sum 등과 같은 집계 열 함수를 선택할 수 있습니다. 셀을 지우려면 해당 셀을 강조표시하고 Delete를 누릅니다.

Where Cond.

Condition을 두 번 눌러 Input the WHERE Definition 대화 상자를 표시할 수 있습니다. 여기서 열이 상수 또는 다른 필드와 같은지(또는 <, >, <=, >=, <>, LIKE, BETWEEN) 여부를 테스트하는 조건을 설정할 수 있습니다. _또는_ 선택된 필드가 하위 질의에 포함되는 조건을 설정할 수 있습니다.

WHERE 정의를 제거하려면

  • 대화 상자를 열고 Remove Condition 단추를 누르거나, 해당 셀을 강조표시한 다음 Delete를 누릅니다.

대화 상자를 재설정하고 WHERE 조건을 다시 시작하려면

  • Clear Form을 누릅니다.

또는

이 확인란을 두 번 눌러 다른 WHERE 기준을 입력할 수 있습니다. 입력된 기준은 위 WHERE 기준과 함께 OR로 결합됩니다. 여러 열 기준을 AND 접속사로 결합하려면 Input the WHERE Definition 대화 상자에서 전문가 모드로 전환합니다. Where 기준에 대한 자세한 내용과 예는 Where 절 채우기 를 참조하십시오.

Group By

이 확인란을 두 번 눌러 GROUP BY 열로 선택할 수 있습니다. 괄호 안의 숫자는 GROUP BY 절에 있는 열의 순서를 나타냅니다. 셀을 지우려면 해당 셀을 강조표시하고 Delete 를 누릅니다.

Having Aggregate

이 확인란을 두 번 눌러 HAVING 절에 대한 집계 열 함수(예: Average, Count, Max, Min, Sum)를 선택할 수 있습니다. 다음과 같은 유형의 질의가 가능합니다.

SELECT emp.job_id

FROM employee emp

GROUP BY emp.job_id

HAVING ((AVG (emp.salary) > 1500))

셀을 지우려면 해당 셀을 강조표시하고 Delete 를 누릅니다.

Having Cond.

이 확인란을 두 번 눌러 GROUP BY 조건을 입력할 수 있는 GROUP BY Definition 창을 열 수 있습니다. 셀을 지우려면 해당 셀을 강조표시하고 Delete를 누릅니다.

Sort

Sort 행을 두 번 눌러 이 열을 Ascending sort, Descending sort 또는 no sort로 선택할 수 있습니다. 셀을 지우려면 해당 셀을 강조표시하고 Delete 를 누릅니다.

Visible

Visible 을 두 번 눌러 이 열이 열 목록에 반환되는지 여부(Show 또는 Not Shown)를 토글할 수 있습니다.

Field Alias

이 확인란을 두 번 눌러 선택된 필드에 대한 필드 이름 별칭을 변경할 수 있습니다.

Table Alias

이 확인란을 두 번 눌러 선택된 필드에 대한 테이블 이름 별칭을 변경할 수 있습니다.

Ordering Columns

열의 순서를 다시 정렬하려면 해당 열을 왼쪽 또는 오른쪽으로 끌어다 놓습니다.

마우스 오른쪽 단추로 Criteria 그리드 누름:

Suppress Current Column

질의에서 이 열을 제거합니다.

Best Fit(All Columns)

모든 텍스트가 표시되도록 Criteria 그리드의 열 너비를 설정합니다.

Default Width(All Columns)

Criteria 그리드의 열 너비를 기본 너비로 설정합니다.

Copy Query Grid Image to Clipboard

Criteria 그리드를 클립보드에 복사합니다.

Execute as SQL*Plus Report

질의를 실행하고 사용자 정의 열 너비, 열 양쪽 맞춤 등을 사용하여 보고서를 작성합니다.


VCS

VCS(Version Control System)는 타사 소스 제어 소프트웨어 제공자입니다.


Version Control System

Version Control System은 프로젝트에 대한 소스 제어 아카이브입니다. Version Control Browser 항목에서 설명한 대로 Team Coding Archive 또는 타사 소스 제어 제품을 사용할 수 있습니다.


Working Directory

작업 디렉토리 값을 지정하지 않으면 Team Coding 옵션에서 Default Working 디렉토리에 대해 지정된 값이 사용됩니다. 여기에서 값을 지정하면 해당 값은 기본 작업 디렉토리를 다시 정의합니다.

이 상자에서 작업 디렉토리를 지정하는 것이 좋습니다. Toad에서는 사용자가 가장 최근에 사용한 최대 10개의 CVSROOT에 대해 지정된 작업 디렉토리를 기억합니다.


전경 또는 배경에서 실행

Execute Statement in Foreground 및 Execute Statement in Background 명령은 Editor 메뉴에 있습니다. 이러한 메뉴 항목은 커서 아래의 구문을 실행하며, 해당 옵션을 변경하지 않고 Editor 옵션에서 선택한 내용을 모두 무시합니다.

예를 들어, Editor 옵션이 Process PL/SQL statements in the Background로 설정되어 있으면 Execute statement in Foreground를 선택하여 전경에서 해당 구문을 실행할 수 있습니다. 다음에 표준 명령을 사용하여 구문을 실행할 때 배경에서 다시 실행됩니다.


눈금: 행 높이

행 높이

눈금의 행 높이를 조절할 수 있습니다.

행 높이를 조절하려면

  1. 눈금의 왼쪽에서 아이콘이 변경될 때까지 눈금 구분 선 위에서 마우스 포인터를 움직입니다.

  2. 포인터를 위 또는 아래로 끕니다. 그러면 행 높이가 조절됩니다.


대체

Substitutions 단추를 눌러 실제 값 대신 열에 저장하도록 상수 값 또는 식을 지정합니다.

예를 들어, 실제 ID 대신 ID 열의 대체로 INSERT 구문에 SEQ.NEXTVAL을 삽입하거나 데이터를 HTML로 저장할 때 열의 값을 숨기고자 할 경우 이 기능을 사용합니다.