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I. Database Connection 
 

TOAD 를 시작하면 로그인 화면이 표시됩니다. 이 화면에서는 서버, 사용자, 연결 날짜/시간 등과 같은, 

이전의 연결 상태를 볼 수 있습니다. 

Oracle 과의 새 연결을 만들 수도 있고 이전 연결 목록에서 선택할 수도 있습니다.  

TOAD 에서는 이전 세션의 이름과 tnsnames.ora  에서의 별칭이 데이터베이스 드롭다운으로 

표시됩니다. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 View > Options > Oracle >  Save passwords for Oracle Connections Option 

 

II. Schema Preparation 
 

설치할 때 Server Side Objects Installation 마법사를 통해 TOAD 용 서버측 오브젝트를 설치할 수 

있습니다.   

이 마법사에서는 오브젝트를 제거하거나 업데이트 할 수도 있습니다.  

마법사는 TOAD의 Tools 메뉴에서 액세스할 수 있습니다.  

서버측 오브젝트를 설치하려면 TOAD를 설치하는 스키마에 대한 계정인 TOAD 사용자 계정이나 DBA 

역할을 가진 계정에 액세스 권한이 있어야 합니다.  
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 Toad Schema 생성시 사용할 수 있는 Toad 기능 

    1. Toad Security 기능 

        -> restricts users' access to features of TOAD 

    2. Explain plan 기능 

        -> for displaying formatted plan info and saving previous plans 

    3. Profiler 기능 

        -> interface to DBMS_PROFILER 

    4. Team Coding 기능 

        -> lets users check in and check out PL/SQL objects 

 

 Private User 생성시 사용할 수 있는 Toad 기능 

    1. Explain plan 기능 

    2. Profiler 기능 
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III. Toad Basic 
 

 Toad Basic Toolbar 
 

 
현재 활성 연결로 새 SQL Edit 창을 엽니다. 

 
현재 활성 연결로 새 Schema Browser 창을 엽니다. 

 
현재 활성 연결로 새 Procedure Edit 창을 엽니다. 

 
현재 활성 연결로 SQL Modeler 창을 엽니다. 

 
현재 활성 연결로 새 Explain Plan 창을 엽니다. 

 
현재 활성 연결로 새 DBMS Output 창을 엽니다. 

 
현재 활성 연결로 새 Object Search 창을 엽니다. 

 
Save all Options은 대개 TOAD 종료 시 저장됩니다. 

 
TOAD Reports를 엽니다. 

 
새로운 Offline Text Editor 창을 엽니다(Oracle 연결이 필요하지 않습니다) 

 
Toggle PL/SQL Profiling On/Off 

 
Toggle Compiling with Debug 

 
Configure TOAD Options 

 
Integrated Tools 

 
Run Script 

 
Configure/Execute External Tools 

 
Project Manager 창을 엽니다. 

 
이 스키마에 대한 모든 변경 사항을 커밋합니다. 

 
이 스키마에 대한 모든 변경 사항을 롤백합니다. 

 

Show windows by connection는 선택되지 않은 MDI 자식 창을(child window) 최

소화하고 선택된 Oracle 연결에 대한 MDI 자식 창을 저장합니다.  

 
데이터베이스에 대한 Oracle 연결을 새로 엽니다. 
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 SQL Editor 바로가기 키 

 

키 입력 기능 

F1 TOAD 도움말 파일에서 SQL Editor 부분을 보여줍니다. 

F2 
전체 스크린 Editor와 Editor/Results Panel 표시 장치 사이를 토

글합니다. 

<SHIFT>F2 전체 스크린 그리드를 토글합니다. 

F3 다음 어커런스를 찾습니다. 

<SHIFT>F3 이전 어커런스를 찾습니다. 

F4 
팝업 창에서 테이블, 뷰, 프로시저, 함수, 또는 패키지를 보여줍

니다. 

F5 스크립트로 실행합니다. 

F6 Editor와 Results Panel 사이에 커서를 토글합니다. 

F7 모든 텍스트를 지웁니다. 

F8 
이전의 SQL 실행문을 재호출합니다.(SQL Statement Recall 창을 

불러옵니다) 

F9 실행문을 실행합니다. 

<CTRL>F9 실행 없이(구문 분석) 실행문을 검사합니다. 

<SHIFT>F9 커서에서 현재 실행문을 실행합니다. 

F10 오른쪽 클릭 메뉴를 표시합니다. 

F12 편집기 내용을 특정한 외부 편집기로 전달합니다. 

<CTRL>A 모든 텍스트 선택 

<CTRL>C 복사 

<CTRL>D Procedure Arguments를 보여줍니다. 

<CTRL>E 현재 실행문에서 Execute Explain Plan을 실행합니다. 

<CTRL>F 텍스트를 찾아줍니다.(Find Text 창을 불러옵니다) 

<CTRL>G 라인으로 이동합니다.(Goto Line 창을 불러옵니다) 

<CTRL>L 텍스트를 소문자로 변환합니다. 

<CTRL>M 코드 실행문(Code Statement)을 만듭니다. 

<CTRL>N 
Named SQL Statement를 재호출합니다.(SQL Statement Recall 

창을 불러옵니다) 

<CTRL>O 텍스트 파일을 열어줍니다. 

<CTRL>P 코드 실행문을 스트립합니다. 

<CTRL>R 검색과 대체(Find and Replace Text 창을 불러옵니다) 

<CTRL>S 파일 저장 

<SHIFT><CTRL>S 다른 이름으로 저장 

<CTRL>T 행 드롭다운을 표시합니다. 
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<CTRL>U 텍스트를 대문자로 변환합니다. 

<CTRL>V 붙이기 

<CTRL>X 자르기 

<SHIFT><CTRL>Z 마지막으로 취소한 작업을 재실행합니다. 

<ALT><UP> 이전 실행문을 표시합니다. 

<ALT><DOWN> 다음 실행문을 표시합니다(<ALT><UP> 사용) 

<CTRL><HOME> 

데이터 그리드에서는 맨 위의 레코드셋으로 이동하며, 결과 그리

드에서는 커서가 위치한 행의 첫 번째 열로 이동하고, 편집기에

서는 텍스트의 첫 번째 열과 첫 번째 행으로 이동합니다. 

<CTRL><END> 

데이터 그리드에서는 레코드셋의 맨 끝으로 이동하며, 편집기에

서는 텍스트의 마지막 열과 마지막 행으로 이동합니다. 

이 절의 40페이지에서 주의 사항을 참조하십시오. 

<CTRL><SPACE> 코드 완성 템플릿을 활성화합니다. 

<CTRL><TAB> MDI Child 창의 콜렉션을 순환합니다. 

<CTRL><ENTER> 커서에 있는 현재 SQL 실행문을 실행합니다. 

<CTRL>. (마침표) 테이블 이름을 자동으로 완성합니다. 

 

 
IV. SQL Editor 
 

Editor 창에는 SQL 실행문이나 스크립트를 작성하는 편집기와 SELECT SQL 실행문의 결과를 표시해주

는 결과 그리드가 포함되어 있습니다. 

Editor 창에서 입력과 편집, 실행과 튜닝을 할 수 있습니다. 

 

 SQL Edit 창을 불러오는 3가지 방법 

_ TOAD의 기본 툴바에서 버튼을 클릭합니다.  

_ Database > SQL Editor의 메뉴 항목을 선택합니다.  

_ View > Options > SQL Editor 대화 상자에서 Option을 설정합니다. 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Editor Panel 

Result Panel 
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 Output Panel Tab 

1. Data 

2. Explain plan 

3. Autotrace 

4. DBMS Output 

5. Code Statistics - PL/Formatter Option 을 선택했을 때 활성화 

6. Script Output 

 QSR(Quest Script Runner)  

 

 Show Table Name Window 

 Show Column Name Window 

 Show SQL Templates Window 

 

 SQL Editor 에서 편집이 가능하려면 

1. Query 문에서 ROWID 를 포함시켜야 한다 

 View > Options > Data Grids – Data > Show ROWID in Data Grids 

2. edit 명령 수행 

 사용중 정확한 table 명을 모를때는 알고 있는 table 명까지만 기입하고 “Ctrl+ .” 을 

사용하면 table list 에서 일치하는 table 을 찾아준다. 

 

 Add/Recall SQL 

1. Recall Previously Executed(F8) 

이전에 실행된 SQL실행문의 목록을 작성하여 나중에 이를 다시 입력할 필요 없이 재호출

하기 위해 사용하며 Default로 100개까지 저장이 가능하며, 사용하는 모든 문장은 Toad 

Home₩sqls.dat 에 저장된다. 

 View > Options > SQL Editor > #of SQL Statements to save TextBox 

2. Recall Personal SQL 

자기만의 특정 SQL문장만을 선택해서 List에 저장하여 Recall할 수 있으며, 사용하는 모든 

문장은 Toad Home₩perssqls.dat 에 저장된다. 

3. Recall Named SQL 

자주 사용하는 SQL문장에 이름을 지정하여 List에 저장하여 Recall할 수 있으며, 지정된 모

든 문장은 Toad Home₩temps₩namedsql.dat 에 저장된다. 

 Toad Option 

1. View > Option 

2. Edit > Edit Option 

3. View > Formatting Option 
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V. Schema Browser 
 

Schema Browser는 데이터베이스 오브젝트를 타입에 따라 분류합니다. 오브젝트에 대한 세부 사항은 

탭으로 구분됩니다. 예를 들어, Table 타입을 선택했을 때에는 모든 테이블은 왼쪽 패널에, View 타입이 

선택되면, 모든 뷰는 왼쪽 패널에 표시됩니다. 사용자가 오브젝트를 선택하면, 이에 대한 세부 사항이나 

DDL 구조는 오른쪽 패널에 표시됩니다. 이는 원하는 데이터를 검색하기 위해 계층 구조를 탐색할 필요

성을 줄여줍니다. 또한 한번의 클릭만으로 같은 타입의 오브젝트들의 세부 사항을 비교해줍니다.  

 

 

 Schema Browser 창을 불러오는 방법 

- TOAD의 기본 툴바에서 버튼을 클릭합니다.  

- 메뉴 항목의 Database > Schema Browser를 선택합니다. 

- View > Options > Schema Browser에서 Option을 설정합니다. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 View > Options > Schema Browser > Visual > Browser Style 

 

 Objects Panel에서 Rclick하면 사용자가 원하는 Object List를 선택할 수 있다. 

 

 

 

 

 

 

 

 

Objects Panel Detail Panel 
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VI. Procedure Editor 
 

  Procedure Editor에서는 프로시저, 함수, 패키지, 트리거, 타입등을 작성하고 수정할 수 있으며, 

Compile, Execute 할 수 있습니다. 

또한 Option인 PL/SQL Debugger 기능을 이용할 수 있으며, 브라우저 스타일의 Backward/Forward 

Button을 이용하여 코드탐색에 사용할 수 있습니다. 

       

      ■ Procedure Editor 창을 불러오는 방법 

 

- TOAD의 기본 툴바 버튼을 클릭합니다.   

- Database > Procedure Editor 메뉴 항목을 선택합니다. 

- Schema Browser > Procedure Editor 페이지에서 Procedure Editor 버튼을 클릭합니다. 

- View > Options > Procedure Editor에서 Option을 설정합니다. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Navigator Panel 

Editor Panel 

Debugger Panel 
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 PL/SQL Editor 바로가기 키 

 

바로 가기 키 기능 

F1 Window 도움말 파일 표시 

F2 오류 패널 표시/숨기기 

F3 다음 어커런스 찾기 

F4 팝업 창에 테이블, 뷰, 프로시저, 함수, 패키지를 기술 

F7 모든 텍스트 지우기 

F9 컴파일 

F10 팝업 메뉴 표시 

F12 SQL 또는 저장된 Procedure Editor 내용을 특정한 외부 편집기에 전달 

<CTRL>A 모든 텍스트 선택 

<CTRL>C 복사 

<CTRL><SHIFT>C 
코드 컴파일(패키지 또는 오브젝트 유형에 대해)을 수행하고, 사양의 새 

프로시저를 발견하고 본문에 대한 스텁을 작성 

<CTRL>D 함수가 사용자에게 반환 데이터 타입을 알려주므로 프로시저 인자 표시 

<CTRL>F 텍스트 찾기 

<CTRL>G 라인으로 이동 

<CTRL>L 텍스트를 소문자로 변환 

<CTRL>O 텍스트 파일 열기 

<CTRL>R 찾기와 바꾸기 

<CTRL>S 파일 저장 

<SHIFT><CTRL> S 다른 이름으로 저장 

<CTRL>T 행 드롭다운 표시 

<CTRL>U 텍스트를 대문자로 변환 

<CTRL>V 붙이기 

<CTRL>X 자르기 

<CTRL>Z 마지막 변경 작업 취소 

<CTRL><SHIFT>Z 마지막 취소 작업 재실행 

<CTRL><SHIFT><DOWN> 본문의 프로시저 구현으로 이동 

<CTRL><SHIFT><UP> 사양의 프로시저 선언으로 이동 

<CTRL><HOME> 편집기의 1행, 1행으로 이동 
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<CTRL><END> 버퍼의 마지막 라인으로 이동 

<CTRL><SPACE> 
디스플레이 코드 템플릿을(키 조합+<CTRL> <SPACE>) 적용 가능한 템

플릿에 표시 

<CTRL><TAB> MDI Child 창의 콜렉션을 순환 

<CTRL><ENTER> 컴파일 

<CTRL><PAGE UP> 이전 패키지 프로시저로 이동 

<CTRL><PAGE DOWN> 다음 패키지 프로시저로 이동 

<CTRL>. (마침표) 테이블 이름 자동완성 

<ALT><DOWN> 현재 단어 하이퍼링크 이동 

<ALT><LEFT> 뒤로 탐색 

<ALT><RIGHT> 앞으로 탐색 

 

 

 DBMS_OUTPUT 은 View > DBMS Output에서 작성 

 

 

1.  PL/SQL 디버거 
 

PL/SQL Debugger는 Procedure Editor 창에서 실행되며 사용자가 코드를 한 단계식 실행하여 

라인 단위, 실행문 단위로 실행할 수 있습니다. 

프로시저를 실행한 후에는 서버에서 DBMS_OUTPUT을 볼 수 있습니다. 

모든 데이터베이스에서 TOAD를 사용하여 PL/SQL을 디버그하려면, Oracle Probe API를 반드시 

설치해야 합니다. 

       

■ 디버그할 수 있는 오브젝트 

 상위 계층 함수(Top-level Functions) 

 상위 계층 프로시저(Top-level Procedures) 

 패키지 함수(Package Functions) 

 패키지 프로시저(Package Procedures) 

 트리거(Triggers) 

 

      ■ 디버그할 수 없는 오브젝트 

 자바 클래스(Java classes) 

 Oracle 8 오브젝트 메소드 

 Anonymous PL/SQL blocks 

 

 View > Options > Procedure Editor > Debugging Option 
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 Debugger 메뉴 

 

Run 
현재 인수 셋팅과 함께 디버깅을 시작하고 다음 정지점 또

는 프로시저의 끝까지 실행한다. 

Set Parameters 

IN 인수값을 설정하기 위한 대화상자를 제공한다. 패키지의 

경우에는, 디버그할 패키지 프로시저와 패키지 함수를 선택

할 수 있다. 

Run to Cursor 
한번 디버깅을 시작하면, 마치 정지점을 설정한 것처럼 커서

위치까지 실행하고 정지한다. 

Step Over 
한 번에 한 라인씩 실행하고, 프로시저나 함수 호출을 지나

친다. 

Trace Into 
한 번에 한 라인씩 실행하지만, 호출된 경우에는 다른 프로

시저로 진행한다. 

Trace Out 
호출된 프로시저의 끝까지 실행하고, 호출한 프로시저에서 

디버깅을 계속하기 위해 되돌아온다. 

Halt Execution 
와치와 정지점 셋팅을 유지하면서, 코드 전체에 대해 진행하

는 것을 정지한다. 

Add Breakpoint at cursor 커서위치에서 정지점을 추가하거나 제거한다. 

Evaluate/ Modify 
곧 변수값을 검사하거나 변경하기 위한 윈도우를 오픈하고, 

새로운 값으로 실행을 계속한다. 

Breakpoints 

현재 정지점을 셋팅할 도킹 가능한 윈도우를 오픈하고, 정지

점을 추가, 편집, 삭제하거나, 사용가능 또는 사용불능 상태

로 만들 수 있다. 

Call Stack 

어떤 프로시저가 다른 프로시저를 호출하는지, 프로시저나 함

수 콜 스택을 볼 수 있는 도킹 가능한 윈도우를 오픈한다. 상

태 판넬에서 실행상태만이 의미가 있다. 

Watches 

현재 와치하고 있는 변수에 대한 도깅 가능한 윈도우를 오픈

하고, 와치를 추가, 편집, 삭제와 사용가능 또는 사용불능 상

태로 만들 수 있다. 

DBMS Output 
프로시저 코드로부터 생성된 DBMS Output을 디스플레이 하

기 위해서 도킹 가능한 윈도우를 오픈한다. 
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 Debugger 바로 가기 키 

 

바로 가기 키 기능 

F5 현재 라인상에 정지점을 설정하거나 해지 

F7 Trace Into 

F8 Step Over 

<Shift> F8 Trace Out 

F9 Compile without Debug information 

<Shift> F9 Execute Current Source 

<Ctrl> F9 Set Parameters 

F10 Display mouse right-click popup menu 

F11 Run (Continue execution) 

F12 Run to Cursor 

<Ctrl><Alt>B Display Breakpoints 

<Ctrl><Alt>D Display DBMS Output 

<Ctrl><Alt>E Evaluate/ Modify 

<Ctrl><Alt>S Display Call Stack 

<Ctrl><Alt>W Display Watches 

 

2.  PL/SQL Profiler Analysis 

PL/SQL Application을 실행함에 있어 Performance Bottlenects 이 발생하는 PL/SQL을 식별하고, 그에 

영향을 주는 Data들을 Collection해서 Graphic하게 보여준다. 

Application 개발자들은 Resource를 많이 사용하는 PL/SQL Source를 식별할 수 있다. 

Profiler Data들을 저장할 수 있는 dbms_profiler Package가 필요하다. 

 

■ Using DBMS_PROFILER 

1. Database > PL/SQL Profiling을 선택해서 Profiler를 Enable시킨다(Stopwatch). 

2. Schema Browser나 PL/SQL Editor에서 특정 PL/SQL을 실행시킨다. 

3. Database > Profiler Analysis를 선택해서 실행시킨 PL/SQL의 통계정보를 확인한다. 

 

 제약사항 

1. Oracle8i 이상의 Database에서 구현 가능 

2. DBMS_PROFILER Package가 필요 

 $ORACLE_HOME/rdbms/admin/profload.sql



Page 14 

 

TOAD 교육                                                                 비쥬얼데이타 

 

 

 

 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
VII. Toad DBA Module 
 

1.  Database Monitor 
Graphic하게 Database Performance정보를 Monitoring하고 Option에서 check한 Thresholds값에 

의해 Alert을 Check하면 Message를 확인할 수 있다. 

 View > Options > Monitors > Database  

 Logical I/O 

 Physical I/O 

 Event Waits 

 Sessions 

 Call Rates 

 Miss Rates 

 SGA Memory Usage 

 Shared Pool 

 Indexed Queries % 
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 ■ Database Monitoring의 Chart는 다음의 Dictionary 정보를 나타낸다 

 v$sysstat 

 v$system_event 

 v$session 

 v$librarycache 

 x$ksllt 

 v$sgastat 

 

2.  Instance Manager 
Access할 수 있는 Database의 상태를 검사한다. Instance가 Shutdown되면 Alert정보를 보여준

다. 

단, Sysdba and sysoper 권한을 가지는 User로 접속해야 한다. 

 View > Options > Instance Manager 

 

3.  Database Health Check 

선택한 Database에서 Check할 Item들을 지정하여 핵심 DB통계 정보를 Online상에서 수집하여 

Rich Text Format (.rtf), Web page (.htm) or Plain text (.txt) format으로 결과를 저장한다.  

Adjust라는 부분은 임의로 Setting이 가능하다. 

■ 다음의 Dictionary 정보를 나타낸다 

 v$version 

 v$instance 

 v$sysstat 

 v$librarycache 

 v$rowcache 

 v$sgastat 

 v$parameter  

 v$database  

 v$log_history  

 v$filestat 

 v$datafile   

 v$tablespace 
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4.  Top Session Finder 
Database에서 System Resource를 많이 사용하는 Session정보를 찾고자 할 때 사용하며, 해당 

Session의 System 정보들을 Pie Chart나 Data로 보여준다.  

Stored Profile이라는 부분은 연관된 Parameter를 Grouping하여 Profile을 생성한다.  

■ Option 

1. Single Parameter Select 

선택된 Parameter에 대해 Resource Usage를 기준으로 Desc Sort를 수행하여 Top 

Session을 찾는다. 

2. Multiple Parameter Select 

Stored Profile에서 선택된 여러 개의 Profile 정보들에 대한 통계들을 Sum해서 

Weight를 구하고 이를 토대로 Desc Sort 해서 Top Session을 찾는다.  

 
5.  OS Utility 

 Unix Monitor  

 Unix Job Scheduler 

 Unix Kernel Params 

 Windows Registry Params 

 Service Manager 

 

6.  Database Probe 

Database의 상태를 Real-Time Monitoring하는 것이며, Database에서 오류가 발생하는지 주기적

으로 확인하고 Database의 특정 Zone에 이상이 있으면 Warning을 보여준다.  

각 Data Control의 왼쪽 부분에 Warning Icon이 나타나는데, 이를 Click하면 좀더 Detail한 정보

를 볼 수 있다. 

■ 5 Zone 

1. Sessions, Processes,PGA, Block gets and mods, Efficiency 

2. SGA 

3. DBWR,LGWR,ARCH,Physical reads and writes 

4. Files 

5. Overhead 
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7.  Database Browser 
Multiple Server에 대한 모든 Database에 대한 정보를 요약해서 한번에 표시한다. 

해당 Server로 SQL Editor, Schema Browser, PL/SQL Editor등에 직접 Access해서 작업이 가능하다.  

해당 Server의 Network 상태를 check할 수 있도록 Ping, Tnsping 명령이 존재한다. 

해당 Server에서 특정 Object를 Find할 수 있으며, Health Check, Database Monitoring도 가능하다. 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

■ 다음의 Dictionary 정보를 나타낸다 

 V$DATABASE, v$datafile 

 v$filestat, V$INSTANCE 

 v$latch, v$librarycache 

 V$OPTION, V$PARAMETER 

 v$rollname, v$rollstat 

 v$sess_io,v$session 

 v$sesstat, v$sgastat 

 v$sqlarea, v$statname 

 v$sysstat, v$system_event 

 v$tablespace 
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8.  Kill/Trace Session 

다양한 Session의 정보를 Detail하게 Monitoring 할 수 있으며, Session에서 진행중인 작업에 대해 

Monitoring 과 Trace를 할 수 있다. 

특정 Session의 Session정보, All Locks, Blocking Locks, Access, RBS Usage등의 정보를 확인할 수 있

다. 또한 각 Session의 현재 Current Statement, Open Cursors, Explain plan, DML Process정보도 확인 

할 수 있다. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

9.  Tablespace and Extent 
 

현재 DB에 생성된 Tablespace와 Extent에 대한 정보를 확인할 수 있으며, 수정도 가능하다. 
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10.  Tablespace Map 

 

Tablespace에서 존재하는 Object들의 Usage정보와 Segment Fragmentation정보를 Graphic하게 확인

할 수 있다. 

또한 Tablespace단위로 Segement 와 Extent정보를 Graphic하게 View할 수 있다. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

11.  Server Statistics 

 

Oracle Instance가 얼마나 사용되고 있는지를 확인할 수 있다. 

Instance의 분석정보, Latch, Wait, Session, Instance Summary정보를 보여준다. 
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12.  SGA Trace 

 

Instance에서 실행되었던 SQL문장들에 대해 SGA의 Shared Pool에서 Trace한다. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
13.  기타 DBA Module의 기능 

 

 Oracle Parameters – 파라미터를 변경합니다. 

 NLS(National Language Support) Parameters – 세션, 인스턴스 및 데이터베이스 파라미

터 설정을 표시하고 파라미터를 변경합니다. 

 TOAD Control Files – 컨트롤 파일을 표시합니다. 

 Pinned Code – 코드를 메모리 버퍼에 넣습니다. 

 New Database Wizard – 새 데이터베이스를 만듭니다. 

 Identify Space Deficits – 다음 범위를 할당할 디스크 공간이 부족한 테이블을 표시합니

다. 

 Redo Log Manager – 데이터베이스의 실행 취소 로그를 유지 관리합니다. 

 Log Switch Frequency Map – 데이터베이스가 로그 전환을 수행할 때 표시됩니다. 

 LogMiner – 데이터베이스에서 문제를 유발한 시스템 변경 번호(SCN)를 분석하여 문제 

발생 이전 상태로 복원합니다. 

 Export Utility Wizard – Virtual DBA 루틴을 사용하여 스키마 스크립트를 내보냅니다. 

 Import Utility Wizard – Virtual DBA 루틴을 사용하여 스키마 스크립트를 가져옵니다. 

 Generate Schema Script – 선택한 스키마 또는 정의 파일을 사용하여 선택한 모든 오브

젝트에 대한 DDL 및 정의 파일을 생성합니다. 

 Compare Schemas – 이 기능의 DBA 버전은 def 파일을 로드하고 마이그레이션/동기화 

보고서를 스크립트 파일에 저장합니다. 
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 Compare Databases - 두 개의 데이터베이스를 비교합니다. 

 Generate Database Script - 테이블스페이스, 다시 실행 로그 및 역할 등의 다양한 데이

터베이스 레벨 오브젝트에 대한 스크립트를 생성합니다. 

 

VIII. 기타 Tools 
 

1. Project Manager 
 

하나의 중앙 창을 통해 일반적인 DB 작업을 수행할 수 있습니다. 

Settings 버튼을 누르면 Configuration window가 열리는데, 여기에서는 한 파일을 다른 파일이나 노

드로 드래그했을 때 TOAD가 실행할 명령을 지정하고, 더블 클릭 동작을 사용자 정의하며, 팝업(오

른쪽 클릭) 메뉴를 사용자 정의할 수 있습니다. 

외부 조합과 DDL 스크립트 포함(inclusions)을 구성할 수 있습니다. 

프로젝트 노드에서는 폴더, 연결 링크 및 데이터베이스 오브젝트에 대한 링크를 저장할 수 있습니다. 

       

      ■ 프로젝트 노드 추가하기 

- 오른쪽 클릭하고 Add > Project를 선택하거나 Add Item 드롭다운에서 Project를 선택합

니다. 

 

      ■ 폴더 추가하기 

- 프로젝트에 폴더를 추가하려면 폴더가 사용자의 하드 드라이브에 있어야 합니다. 

- Rclick  Add > Folder 또는 Add Item 드롭다운에서 Folder를 선택합니다. 

 

      ■ 노드 복사하기 

-  복사하려는 노드를 선택합니다.  

-  오른쪽 클릭하고 메뉴에서 Copy를 선택합니다. Destination Projects 창이 표시됩니다. 

-  복사할 프로젝트를 선택합니다. 

-  Ok를 클릭합니다. 

 

      ■ 사용가능한 노드 타입 

 

Project Folder 
조직 유니트를 오버레핑한다. 다른 프로젝트, 다른 타입의 폴더, 다른 내용을 포함할 수 있

다. 

File Folder 로컬이나 네트워크 디스크상의 폴더를 나타낸다. 

File 로컬이나 네트워크 디스크상의 파일을 나타낸다. 

FTP Folder FTP 서버상의 폴더를 나타낸다. FTP 파일을 포함한다. 

FTP File FTP 서버상의 파일을 나타낸다. 

DB Schema 
데이터베이스상의 스키마에 대한 연결을 나타낸다. 데이터베이스 오브젝트를 포함할 수 있

다. 

DB Object 데이터베이스상에 존재하는 오브젝트를 나타낸다. 반드시 DB 스키마 노드안에 있어야 한다.

URL URL을 나타내며, 해당 사이트에 대한 바로 가기 키처럼 실행할 수 있다. 
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2. SQL Modeler 
 

SQL Modeler를 사용하면 Select, Insert, Update, Delete 문의 프레임워크를 빠르게 작성할 수 있습

니다. 테이블, 뷰, 동의어와 조인 열, 선택 열을 선택할 수 있으며 원하는 실행문 타입을 작성할 수 

있습니다.  

 

 SQL Modeler를 여는 방법 

_ 기본 툴바에서 Open a new SQL Modeler 버튼을 클릭합니다.  

_ Database > SQL Modeler 메뉴 항목을 선택합니다.  

 

3. Code Road Map 

 

Code Road map에는 각 오브젝트가 참조하는 오브젝트를 나타내는 화살표 다이어그램이 표시됩니다. 

화살표 끝의 오브젝트는 선의 검은 점 끝에 있는 오브젝트가 참조합니다.  

 

 Code Road Map을 여는 방법 

_ 기본 툴바에서 Tools > Code Road Map 버튼을 클릭합니다.  

_ Schema Browser - Procedures 페이지 > Right-click menu에서 선택합니다. 

 

4. ER Diagram 

 

ER(entity relationship) Diagram은 Code Road Map과 비슷한 방식으로 작동합니다. 여기에는 종속성

과 선택된 세부 사항이 표시됩니다. 선의 화살표 쪽에 있는 오브젝트를 선의 검은 점 쪽에 있는 오

브젝트가 참조합니다. 왼쪽에는 트리뷰 오브젝트 브라우저 목록이 포함됩니다. 오브젝트 브라우저 

목록이나 다이어그램을 오른쪽 클릭하면 해당 오브젝트에 대한 연관된 Schema Browser 오른쪽 클

릭 메뉴가 표시됩니다.  

 

 ER Diagram을 여는 방법 

_ 기본 툴바에서 Tools > ER Diagram 버튼을 클릭합니다.  

_ Schema Browser - Tables 페이지 > Right-click menu에서 선택합니다. 

 

5. Toad Report 
 

TOAD Reports에서는 미리 서식이 지정된 다양한 보고서를 출력할 수 있습니다. 

 

 Toad Report 를 여는 방법 

_ 기본 툴바에서 View > Reports 버튼을 클릭합니다.  
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6. Network Utility 

 

특정 Host와 Database의 Telnet, RExec, Ping, Tnsping 등의 Network Utility를 지원한다.  

 

 Network Utility를 여는 방법 

_ Menu에서 View > Options > Network Utilities 를 선택합니다.  

_ Menu에서 File > Network Utilities 를 선택합니다. 

 

7. Master/Detail Browser 
 

Master/Detail 레코드 브라우저는 포린 키 제약 조건을 기반으로 합니다. 이 브라우저에서는 테이블

이 외래 키에 의래 링크된 데이터베이스에서 테이블 데이터를 탐색하거나, 편집할 수 있습니다. 이

것은 한 테이블의 오브젝트가 필드 링크나 필드에 의해 다른 테이블의 오브젝트에 연결되는 

Entity/Relationship 다이어그램의 데이터베이스 설정과 비슷합니다. 

 

 Master/Detail Browser 를 여는 방법 

_ Tools > Master Detail Browser 를 선택합니다.  

 

8.  기타  

 

 Estimate Table Size and Estimate Index Size 

 Analyze All Objects – All Objects들을 대상으로 Analyzing 수행 

 Rebuild Table and Rebuild Multiple Objects 

 Object Search 

 Tkprof Interface 

 


