JScript 런타임 라이브러리 참조

Microsoft® JScript®
JScript 언어 참조 		JScript 자습서
버전 정보

기능 정보

키워드 목록(사전순)

오류

함수

메서드

개체

연산자

속성

문

JScript 언어 참조 시작

여기에 요약된 내용들을 활용하면 Scripting 런타임 라이브러리의 여러 부분을 쉽게 찾아볼 수 있습니다.

키워드 목록(사전순)에서는 Scripting 런타임 라이브러리의 모든 부분을 사전순으로 볼 수 있고, 개체 등 개별 항목에 대한 자세한 내용을 보려면 해당 범주를 선택하면 됩니다.

왼쪽에 있는 항목 중 하나를 누르면 해당 범주에 포함된 항목의 목록이 나타납니다. 그 목록에서 원하는 항목을 선택하십시오. 항목을 열면 관련된 다른 영역으로 쉽게 이동할 수 있습니다.

계속 살펴보면서 각 문의 사용법을 익히고, 메서드를 연구하고, 함수를 풀어 나가면 Scripting 런타임 라이브러리의 다양한 기능을 경험할 수 있을 것입니다.

기능 | 설명
버전 정보 | 호스트 응용 프로그램별 JScript 버전 및 버전별 기능 목록
JScript 기능(ECMA) | JScript의 ECMA 최신 기능 목록
JScript 기능(비ECMA) | JScript의 비ECMA 최신 기능 목록
Microsoft Scripting 런타임 기능 | JScript의 Scripting 런타임 최신 기능 목록
언어 요소 | 설명
$1...$9 속성 | 패턴 일치 과정에서 찾아 저장된 최근 9개 부분을 반환합니다.
/*..*/(여러 줄 주석문) | JScript 구문 분석기에서 여러 줄로 된 주석문을 무시하도록 합니다.
//(한 줄 주석문) | JScript 구문 분석기에서 한 줄로 된 주석문을 무시하도록 합니다.
@cc_on 문 | 조건부 컴파일 지원 기능을 활성화합니다.
@if 문 | 식의 값에 따라 조건에 맞는 문 그룹을 실행합니다.
@set 문 | 조건부 컴파일 문에 사용할 변수들을 만듭니다.
?: 연산자(삼함) | 조건에 따라 두 식 중 하나를 수행합니다.
-- 연산자 | 변수를 1씩 감소시킵니다.
== 연산자 | 두 식을 비교하여 서로 같은 값을 갖는지 판단합니다.
!= 연산자 | 두 식을 비교하여 서로 다른 값을 갖는지 판단합니다.
* 연산자 | 두 수를 곱합니다.
! 연산자 | 한 식에 논리 부정을 수행합니다.
|| 연산자 | 두 식에 논리합을 수행합니다.
&& 연산자 | 두 식에 논리곱을 수행합니다.
/ 연산자 | 두 수를 나눈 결과를 반환합니다.
% 연산자 | 두 수를 나눈 후 나머지를 반환합니다.
- 연산자 | 수식의 음수 값을 나타냅니다.
+ 연산자 | 두 숫자를 더하거나 문자열을 연결합니다.
=== 연산자 | 두 식을 비교하여 서로 값과 데이터 형식이 같은지 판단합니다.
< 연산자 | 두 식을 비교하여 어느 쪽이 더 작은지 판단합니다.
<= 연산자 | 두 식을 비교하여 어느 쪽이 더 작거나 같은지 판단합니다.
>= 연산자 | 두 식을 비교하여 어느 쪽이 더 크거나 같은지 판단합니다.
> 연산자 | 두 식을 비교하여 어느 쪽이 더 큰지 판단합니다.
!== 연산자 | 두 식을 비교하여 서로 값과 데이터 형식이 다른지 판단합니다.
| 연산자 | 두 식에 비트 논리합을 수행합니다.
& 연산자 | 두 식에 비트 논리곱을 수행합니다.
^ 연산자 | 두 식에 비트 배타적 논리합 연산을 수행합니다.
~ 연산자 | 식에 비트 부정 연산을 수행합니다.
>> 연산자 | 부호를 바꾸지 않고 식을 비트 단위로 오른쪽으로 옮깁니다.
<< 연산자 | 식을 비트 단위로 왼쪽으로 옮깁니다.
- 연산자 | 두 식을 뺍니다.
, 연산자 | 두 식을 순차적으로 수행합니다.
>>> 연산자 | 부호 없이 식을 비트 단위로 오른쪽으로 옮깁니다.
++ 연산자 | 변수를 1씩 증가시킵니다.
= 연산자 | 변수에 값을 지정합니다.
abs 메서드 | 절대값을 반환합니다.
acos 메서드 | 아크코사인 값을 반환합니다.
ActiveXObject 개체 | 자동화 개체에 대한 참조를 사용하여 반환합니다.
anchor 메서드 | 개체의 특정 텍스트 양 끝에 NAME 특성을 가진 HTML 앵커를 넣습니다.
arguments 속성 | 현재 실행 중인 함수에 전달된 각 인수를 포함하는 배열을 반환합니다.
Array 개체 | 모든 데이터 형식의 배열을 만들 수 있도록 지원합니다.
asin 메서드 | 아크사인 값을 반환합니다.
atan 메서드 | 아크탄젠트 값을 반환합니다.
atan2 메서드 | X축과 점(y,x) 사이의 각을 라디안값으로 반환합니다.
atEnd 메서드 | 열거자가 컬렉션의 끝에 있는지 여부를 나타내는 부울값을 반환합니다.
big 메서드 | String 개체의 텍스트 양 끝에 <BIG> HTML 태그를 삽입합니다.
blink 메서드 | String 개체의 텍스트 양 끝에 <BLINK> HTML 태그를 삽입합니다.
bold 메서드 | String 개체의 텍스트 양 끝에 <B> HTML 태그를 삽입합니다.
Boolean 개체 | 새 부울값을 만듭니다.
break 문 | 현재 루프를 종료하거나 label로 연결된 경우에는 연결된 문을 종료합니다.
caller 속성 | 현재 함수를 불러온 함수에 대한 참조를 반환합니다.
catch 문 | try 블록 안의 코드에 오류가 발생하면 실행할 문을 포함시킵니다.
ceil 메서드 | 숫자 인수보다 크거나 같은 가장 작은 정수를 반환합니다.
charAt 메서드 | 지정한 인덱스에 해당하는 문자를 반환합니다.
charCodeAt 메서드 | 지정한 문자의 유니코드 인코딩을 반환합니다.
compile 메서드 | 정규식을 내부 형식으로 컴파일합니다.
concat 메서드(Array) | 두 배열의 조합으로 구성된 새 배열을 반환합니다.
concat 메서드(String) | 주어진 두 문자열의 연결을 포함하는 String 개체를 반환합니다.
constructor 속성 | 개체를 만드는 함수를 지정합니다.
continue 문 | 현재 루프 반복을 중지하고 새로 반복을 시작합니다.
cos 메서드 | 코사인 값을 반환합니다.
Date 개체 | 날짜와 시간을 기본으로 저장하거나 가져올 수 있습니다.
delete 연산자 | 개체에서 속성을 삭제하거나 배열에서 요소를 제거합니다.
description 속성 | 특정 오류와 관련된 설명적인 문자열을 반환하거나 설정합니다.
Dictionary 개체 | 데이터 키-항목 쌍을 저장하는 개체입니다.
dimensions 메서드 | VBArray의 차원 수를 반환합니다.
do...while 문 | 문 블록을 한번 실행한 후 조건식이 false가 될 때까지 루프를 반복 실행합니다.
E 속성 | 자연 로그의 밑인 오일러 상수를 반환합니다.
Enumerator 개체 | 컬렉션에 있는 항목들을 열거할 수 있습니다.
Error 개체 | JScript 코드 실행 중 발생하는 오류에 대한 정보를 포함하는 개체입니다.
escape 메서드 | String 개체를 모든 컴퓨터에서 읽을 수 있도록 인코딩합니다.
eval 메서드 | JScript 코드를 검증하고 실행합니다.
exec 메서드 | 지정한 문자열에서 일치하는 부분을 검색합니다.
exp 메서드 | 자연 로그의 밑인 e의 거듭제곱 값을 반환합니다.
FileSystemObject 개체 | 컴퓨터 파일 시스템에 액세스할 수 있습니다.
fixed 메서드 | String 개체의 텍스트 양 끝에 <TT> HTML 태그를 삽입합니다.
floor 메서드 | 숫자 인수보다 작거나 같은 가장 큰 정수를 반환합니다.
fontcolor 메서드 | String 개체의 텍스트 양 끝에 COLOR 특성을 가진 <FONT> HTML 태그를 삽입합니다.
fontsize 메서드 | String 개체의 텍스트 양 끝에 SIZE 특성을 가진 <FONT> HTML 태그를 삽입합니다.
for 문 | 지정한 조건이 true인 동안 문 블록을 실행합니다.
for...in 문 | 개체나 배열의 각 요소에 대해 하나 이상의 문을 실행합니다.
fromCharCode 메서드 | 여러 유니코드 문자 값 중에서 문자열을 반환합니다.
Function 개체 | 새 함수를 만듭니다.
function 문 | 새 함수를 선언합니다.
getDate 메서드 | 로컬 시간을 사용하여 Date 개체의 날짜 값을 반환합니다.
getDay 메서드 | 로컬 시간을 사용하여 Date 개체의 요일 값을 반환합니다.
getFullYear 메서드 | 로컬 시간을 사용하여 Date 개체의 연도 값을 반환합니다.
getHours 메서드 | 로컬 시간을 사용하여 Date 개체의 시 값을 반환합니다.
getItem 메서드 | 지정한 위치에 있는 항목을 반환합니다.
getMilliseconds 메서드 | 로컬 시간을 사용하여 Date 개체의 밀리초 값을 반환합니다.
getMinutes 메서드 | 로컬 시간을 사용하여 Date 개체의 분 값을 반환합니다.
getMonth 메서드 | 로컬 시간을 사용하여 Date 개체의 월 값을 반환합니다.
GetObject 함수 | 파일에서 자동화 개체에 대한 참조를 반환합니다.
getSeconds 메서드 | 로컬 시간을 사용하여 Date 개체에 저장된 초 값을 반환합니다.
getTime 메서드 | Date 개체의 시 값을 반환합니다.
getTimezoneOffset 메서드 | 호스트 컴퓨터와 협정 세계 표준시(UTC) 사이의 시간차를 분으로 반환합니다.
getUTCDate 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 날짜 값을 반환합니다.
getUTCDay 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 요일 값을 반환합니다.
getUTCFullYear 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 연도 값을 반환합니다.
getUTCHours 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 시 값을 반환합니다.
getUTCMilliseconds 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 밀리초 값을 반환합니다.
getUTCMinutes 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 분 값을 반환합니다.
getUTCMonth 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 월 값을 반환합니다.
getUTCSeconds 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 초 값을 반환합니다.
getVarDate 메서드 | Date 개체의 VT_DATE 값을 반환합니다.
getYear 메서드 | Date 개체의 연도 값을 반환합니다.
Global 개체 | Global 메서드들을 하나의 개체로 모으는 내부 개체입니다.
if...else 문 | 식의 값에 따라 조건에 맞는 문 그룹을 실행합니다.
index 속성 | 검색한 문자열에서 처음으로 일치하는 부분이 시작하는 문자 위치를 반환합니다.
indexOf 메서드 | String 개체 안에서 부분 문자열이 처음 나오는 문자 위치를 반환합니다.
Infinity 속성 | Number.POSITIVE_INFINITY의 초기 값을 반환합니다.
input 속성 | 검색하는 데 사용한 문자열을 반환합니다.
instanceof 연산자 | 개체가 특정 클래스의 인스턴스인지 여부를 나타내는 부울값을 반환합니다.
isFinite 메서드 | 주어진 수가 유한한지 여부를 나타내는 부울값을 반환합니다.
isNaN 메서드 | 어떤 값이 예약값인 NaN(숫자 아님)인지 여부를 나타내는 부울값을 반환합니다.
italics 메서드 | String 개체의 텍스트 양 끝에 <I> HTML 태그를 삽입합니다.
item 메서드 | 컬렉션의 현재 항목을 반환합니다.
join 메서드 | 배열 하나에 함께 연결된 모든 요소들로 구성된 String 개체를 반환합니다.
Labeled 문 | 문에 식별자를 제공합니다.
lastIndex 속성 | 검색한 문자열에서 마지막으로 일치하는 부분이 시작하는 문자 위치를 반환합니다.
lastIndexOf 메서드 | String 개체 안에서 부분 문자열이 마지막으로 나오는 경우를 반환합니다.
lbound 메서드 | 차원이 지정된 VBArray에서 사용하는 최저 인덱스 값을 반환합니다.
length 속성(Array) | 배열에 정의된 요소의 최고값보다 하나 큰 정수값을 반환합니다.
length 속성(Function) | 함수에 정의된 인수의 개수를 반환합니다.
length 속성(String) | String 개체의 길이를 반환합니다.
link 메서드 | String 개체의 텍스트 양 끝에 HREF 특성을 가진 HTML 앵커를 삽입합니다.
LN2 속성 | 자연 로그 2를 반환합니다.
LN10 속성 | 자연 로그 10을 반환합니다.
log 메서드 | 자연 로그 값을 반환합니다.
LOG2E 속성 | 밑이 2인 로그 e(오일러 상수)를 반환합니다.
LOG10E 속성 | 밑이 10인 로그 e(오일러 상수)를 반환합니다.
match 메서드 | 주어진 Regular Expression 개체를 사용하여 문자열을 검색한 결과를 배열로 반환합니다.
Math 개체 | 기본적인 계산 기능과 상수를 제공하는 내부 개체입니다.
max 메서드 | 주어진 두 수식 중 큰 값을 반환합니다.
MAX_VALUE 속성 | JScript에서 나타낼 수 있는 가장 큰 수를 반환합니다.
min 메서드 | 주어진 두 수 중 작은 값을 반환합니다.
MIN_VALUE 속성 | JScript에서 나타낼 수 있는 0에 가장 가까운 수를 반환합니다.
moveFirst 메서드 | 컬렉션에서 현재 항목을 첫번째 항목으로 다시 설정합니다.
moveNext 메서드 | 컬렉션에서 현재 항목을 다음 항목으로 옮깁니다.
NaN 속성(Global) | 식이 숫자가 아님을 나타내는 특수 값 NaN을 반환합니다.
NaN 속성(Number) | 식이 숫자가 아님을 나타내는 특수 값(NaN)을 반환합니다.
NEGATIVE_INFINITY 속성 | JScript에서 나타낼 수 있는 가장 큰 음수(-Number.MAX_VALUE)보다 큰 음수 값을 반환합니다.
new 연산자 | 새 개체를 만듭니다.
Number 개체 | 숫자 상수의 Number 데이터 형식과 자리 표시자를 나타내는 개체입니다.
number 속성 | 특정 오류와 관련된 숫자 값을 반환하거나 설정합니다.
Object 개체 | 모든 JScript 개체에 공통적인 기능을 제공합니다.
parse 메서드 | 날짜를 포함한 문자열 구문을 분석하여 1970년 1월 1일 자정부터 해당 날짜 사이의 시간을 밀리초로 반환합니다.
parseFloat 메서드 | 문자열에서 변환된 부동 소수점 숫자를 반환합니다.
parseInt 메서드 | 문자열에서 변환된 정수를 반환합니다.
PI 속성 | 원주율의 근사치 3.141592653589793을 반환합니다.
POSITIVE_INFINITY 속성 | JScript에서 나타낼 수 있는 가장 큰 양수(Number.MAX_VALUE)보다 큰 값을 반환합니다.
pow 메서드 | 밑을 지정한 지수만큼 거듭제곱한 값을 반환합니다.
prototype 속성 | 개체 클래스의 초기 설정에 대한 참조를 반환합니다.
random 메서드 | 0과 1 사이의 의사 난수 값을 반환합니다.
RegExp 개체 | 정규식 패턴 검색에 관한 정보를 저장합니다.
Regular Expression 개체 | 정규식 패턴을 포함합니다.
replace 메서드 | 정규식을 사용하여 텍스트를 바꾼 문자열의 복사본을 반환합니다.
return 문 | 현재 함수를 종료하고 그 함수에서 구한 값을 반환합니다.
reverse 메서드 | 요소들이 역으로 나열된 Array 개체를 반환합니다.
round 메서드 | 주어진 수식을 반올림하여 가장 가까운 정수를 반환합니다.
ScriptEngine 함수 | 사용 중인 스크립팅 언어를 나타내는 문자열을 반환합니다.
ScriptEngineBuildVersion 함수 | 사용 중인 스크립팅 엔진의 작성 버전 번호를 반환합니다.
ScriptEngineMajorVersion 함수 | 사용 중인 스크립팅 엔진의 주 버전 번호를 반환합니다.
런타임 오류 | JScript 런타임 오류 목록
ScriptEngineMinorVersion 함수 | 사용 중인 스크립팅 엔진의 보조 버전 번호를 반환합니다.
search 메서드 | 정규식 검색에서 첫번째로 일치하는 부분 문자열의 위치를 반환합니다.
setDate 메서드 | 로컬 시간을 사용하여 Date 개체의 날짜 값을 설정합니다.
setFullYear 메서드 | 로컬 시간을 사용하여 Date 개체의 연도 값을 설정합니다.
setHours 메서드 | 로컬 시간을 사용하여 Date 개체의 시 값을 설정합니다.
setMilliseconds 메서드 | 로컬 시간을 사용하여 Date 개체의 밀리초 값을 설정합니다.
setMinutes 메서드 | 로컬 시간을 사용하여 Date 개체의 분 값을 설정합니다.
setMonth 메서드 | 로컬 시간을 사용하여 Date 개체의 월 값을 설정합니다.
setSeconds 메서드 | 로컬 시간을 사용하여 Date 개체의 초 값을 설정합니다.
setTime 메서드 | Date 개체의 날짜와 시간 값을 설정합니다.
setUTCDate 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 날짜 값을 설정합니다.
setUTCFullYear 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 연도 값을 설정합니다.
setUTCHours 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 시 값을 설정합니다.
setUTCMilliseconds 메서드 | 협정 세계 표준시(UTC)을 사용하여 Date 개체의 밀리초 값을 설정합니다.
setUTCMinutes 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 분 값을 설정합니다.
setUTCMonth 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 월 값을 설정합니다.
setUTCSeconds 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 초 값을 설정합니다.
setYear 메서드 | Date 개체의 연도 값을 설정합니다.
sin 메서드 | 사인 값을 반환합니다.
slice 메서드(Array) | 배열의 일정 부분을 반환합니다.
slice 메서드(String) | 문자열의 일정 부분을 반환합니다.
small 메서드 | String 개체의 텍스트 양 끝에 <SMALL> HTML 태그를 삽입합니다.
sort 메서드 | 요소가 정렬된 Array 개체를 반환합니다.
source 속성 | 정규식 패턴의 텍스트 복사본을 반환합니다.
split 메서드 | 문자열을 여러 개의 부분 문자열로 분리할 때 만들어지는 문자열의 배열을 반환합니다.
sqrt 메서드 | 제곱근 값을 반환합니다.
SQRT1_2 속성 | 0.5의 제곱근 또는 1을 2의 제곱근으로 나눈 값을 반환합니다.
SQRT2 속성 | 2의 제곱근을 반환합니다.
strike 메서드 | String 개체의 텍스트 양 끝에 <STRIKE> HTML 태그를 삽입합니다.
String 개체 | 텍스트 문자열을 조작하고 서식을 지정하거나 문자열 안에서 부분 문자열을 결정하고 위치를 지정할 수 있습니다.
sub 메서드 | String 개체의 텍스트 양 끝에 <SUB> HTML 태그를 삽입합니다.
substr 메서드 | 지정한 위치에서 시작하고 지정한 길이를 갖는 부분 문자열을 반환합니다.
substring 메서드 | String 개체 안의 지정된 위치에 있는 부분 문자열을 반환합니다.
sup 메서드 | String 개체의 텍스트 양 끝에 <SUP> HTML 태그를 삽입합니다.
switch 문 | 지정한 식의 값이 레이블과 일치하면 하나 이상의 문을 실행할 수 있습니다.
tan 메서드 | 탄젠트 값을 반환합니다.
test 메서드 | 검색한 문자열에 패턴이 있는지 여부를 나타내는 부울값을 반환합니다.
this 문 | 현재 개체를 참조합니다.
throw 문 | try...catch 문에서 처리할 수 있는 오류 조건을 만듭니다.
toArray 메서드 | VBArray에서 변환된 JScript 표준 배열을 반환합니다.
구문 오류 | JScript 구문 오류 목록
toGMTString 메서드 | 그리니치 표준시(GMT)를 사용하여 문자열로 변환된 날짜를 반환합니다.
toLocaleString 메서드 | 현재 로케일을 사용하여 문자열로 변환된 날짜를 반환합니다.
toLowerCase 메서드 | 모든 영문자가 소문자로 변환된 문자열을 반환합니다.
toString 메서드 | 개체를 나타내는 문자열을 반환합니다.
toUpperCase 메서드 | 모든 영문자가 대문자로 변환된 문자열을 반환합니다.
toUTCString 메서드 | 협정 세계 표준시(UTC)를 사용하여 문자열로 변환된 날짜를 반환합니다.
try 문 | JScript 오류를 처리합니다.
typeof 연산자 | 식의 데이터 형식을 나타내는 문자열을 반환합니다.
ubound 메서드 | 차원이 지정된 VBArray에서 사용하는 최고 인덱스 값을 반환합니다.
unescape 메서드 | escape 메서드로 인코딩한 String 개체를 디코딩합니다.
UTC 메서드 | 협정 세계 표준시(UTC)또는 그리니치 표준시(GMT) 1970년 1월 1일 자정부터 주어진 날짜 사이의 시간을 밀리초로 반환합니다.
valueOf 메서드 | 지정한 개체의 원시 값을 반환합니다.
var 문 | 변수를 선언합니다.
VBArray 개체 | Visual Basic 안전 배열에 액세스할 수 있습니다.
void 연산자 | 식이 값을 반환하지 않도록 합니다.
while 문 | 지정한 조건이 false가 될 때까지 문을 실행합니다.
with 문 | 문의 기본 개체를 설정합니다.
데이터 형식 변환 | JScript의 데이터 형식 자동 변환에 대한 설명입니다.
복합 지정 연산자 | 복합 지정 연산자 목록
비교 연산자 | 비교 결과를 나타내는 부울값을 반환합니다.
연산자 우선 순위 | JScript 연산자 실행 우선 순서에 대한 정보 목록입니다.
정규식 구문 | 정규식 패턴을 지정할 때 사용하는 특수 문자 및 시퀀스의 목록입니다.
조건부 컴파일 | JScript의 새로운 기능들을 지원하지 않는 브라우저와도 호환성을 유지하며 새로운 기능들을 사용할 수 있습니다.
조건부 컴파일 변수 | 조건부 컴파일에 사용되는 사전 정의된 변수 목록입니다.
언어 요소 | 설명
GetObject 함수 | 파일에서 자동화 개체에 대한 참조를 반환합니다.
ScriptEngine 함수 | 사용 중인 스크립팅 언어를 나타내는 문자열을 반환합니다.
ScriptEngineBuildVersion 함수 | 사용 중인 스크립팅 엔진의 작성 버전 번호를 반환합니다.
ScriptEngineMajorVersion 함수 | 사용 중인 스크립팅 엔진의 주 버전 번호를 반환합니다.
ScriptEngineMinorVersion 함수 | 사용 중인 스크립팅 엔진의 보조 버전 번호를 반환합니다.
언어 요소 | 설명
abs 메서드 | 절대값을 반환합니다.
acos 메서드 | 아크코사인 값을 반환합니다.
anchor 메서드 | 개체의 특정 텍스트 양 끝에 NAME 특성을 가진 HTML 앵커를 삽입합니다.
asin 메서드 | 아크사인 값을 반환합니다.
atan 메서드 | 아크탄젠트 값을 반환합니다.
atan2 메서드 | X축과 점(y,x) 사이의 각을 라디안 값으로 반환합니다.
atEnd 메서드 | 열거자가 컬렉션의 끝에 있는지 여부를 나타내는 부울값을 반환합니다.
big 메서드 | String 개체의 텍스트 양 끝에 <BIG> HTML 태그를 삽입합니다.
blink 메서드 | String 개체의 텍스트 양 끝에 <BLINK> HTML 태그를 삽입합니다.
bold 메서드 | String 개체의 텍스트 양 끝에 <B> HTML 태그를 삽입합니다.
ceil 메서드 | 숫자 인수보다 크거나 같은 가장 작은 정수를 반환합니다.
charAt 메서드 | 지정한 인덱스에 해당하는 문자를 반환합니다.
charCodeAt 메서드 | 지정한 문자의 유니코드 인코딩을 반환합니다.
compile 메서드 | 정규식을 내부 형식으로 컴파일합니다.
concat 메서드(Array) | 두 배열의 조합으로 구성된 새 배열을 반환합니다.
concat 메서드(String) | 주어진 두 문자열의 연결을 포함하는 String 개체를 반환합니다.
cos 메서드 | 코사인 값을 반환합니다.
dimensions 메서드 | VBArray의 차원 수를 반환합니다.
escape 메서드 | String 개체를 모든 컴퓨터에서 읽을 수 있도록 인코딩합니다.
eval 메서드 | JScript 코드를 검증하고 실행합니다.
exec 메서드 | 지정한 문자열에서 일치하는 부분을 검색합니다.
exp 메서드 | 자연 로그의 밑인 e의 거듭제곱 값을 반환합니다.
fixed 메서드 | String 개체의 텍스트 양 끝에 <TT> HTML 태그를 삽입합니다.
floor 메서드 | 숫자 인수보다 작거나 같은 가장 큰 정수를 반환합니다.
fontcolor 메서드 | String 개체의 텍스트 양 끝에 COLOR 특성을 가진 <FONT> HTML 태그를 삽입합니다.
fontsize 메서드 | String 개체의 텍스트 양 끝에 SIZE 특성을 가진 <FONT> HTML 태그를 삽입합니다.
fromCharCode 메서드 | 여러 유니코드 문자 값 중에서 문자열을 반환합니다.
getDate 메서드 | 로컬 시간을 사용하여 Date 개체의 날짜 값을 반환합니다.
getDay 메서드 | 로컬 시간을 사용하여 Date 개체의 요일 값을 반환합니다.
getFullYear 메서드 | 로컬 시간을 사용하여 Date 개체의 연도 값을 반환합니다.
getHours 메서드 | 로컬 시간을 사용하여 Date 개체의 시 값을 반환합니다.
getItem 메서드 | 지정한 위치에 있는 항목을 반환합니다.
getMilliseconds 메서드 | 로컬 시간을 사용하여 Date 개체의 밀리초 값을 반환합니다.
getMinutes 메서드 | 로컬 시간을 사용하여 Date 개체의 분 값을 반환합니다.
getMonth 메서드 | 로컬 시간을 사용하여 Date 개체의 월 값을 반환합니다.
getSeconds 메서드 | 로컬 시간을 사용하여 Date 개체의 초 값을 반환합니다.
getTime 메서드 | Date 개체의 시 값을 반환합니다.
getTimezoneOffset 메서드 | 호스트 컴퓨터의 시간과 협정 세계 표준시(UTC) 사이의 시간차를 분으로 반환합니다.
getUTCDate 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 날짜 값을 반환합니다.
getUTCDay 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 요일 값을 반환합니다.
getUTCFullYear 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 연도 값을 반환합니다.
getUTCHours 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 시 값을 반환합니다.
getUTCMilliseconds 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 밀리초 값을 반환합니다.
getUTCMinutes 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 분 값을 반환합니다.
getUTCMonth 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 월 값을 반환합니다.
getUTCSeconds 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 초 값을 반환합니다.
getVarDate 메서드 | Date 개체의 VT_DATE 값을 반환합니다.
getYear 메서드 | Date 개체의 연도 값을 반환합니다.
indexOf 메서드 | String 개체 안에서 부분 문자열이 처음 나오는 문자 위치를 반환합니다.
isFinite 메서드 | 주어진 수가 유한한지 여부를 나타내는 부울값을 반환합니다.
isNaN 메서드 | 어떤 값이 예약값인 NaN(숫자 아님)인지 여부를 나타내는 부울값을 반환합니다.
italics 메서드 | String 개체의 텍스트 양 끝에 <I> HTML 태그를 삽입합니다.
item 메서드 | 컬렉션의 현재 항목을 반환합니다.
join 메서드 | 배열 하나에 함께 연결된 모든 요소들로 구성된 String 개체를 반환합니다.
lastIndexOf 메서드 | String 개체 안에서 부분 문자열이 마지막으로 나오는 경우를 반환합니다.
lbound 메서드 | 차원이 지정된 VBArray에서 사용하는 최저 인덱스 값을 반환합니다.
link 메서드 | String 개체의 텍스트 양 끝에 HREF 특성을 가진 HTML 앵커를 삽입합니다.
log 메서드 | 자연 로그 값을 반환합니다.
match 메서드 | 주어진 Regular Expression 개체를 사용하여 문자열을 검색한 결과를 배열로 반환합니다.
max 메서드 | 주어진 두 수식 중 큰 값을 반환합니다.
min 메서드 | 주어진 두 수 중 작은 값을 반환합니다.
moveFirst 메서드 | 컬렉션에서 현재 항목을 첫번째 항목으로 다시 설정합니다.
moveNext 메서드 | 컬렉션에서 현재 항목을 다음 항목으로 옮깁니다.
parse 메서드 | 날짜를 포함한 문자열 구문을 분석하여 1970년 1월 1일 자정부터 해당 날짜 사이의 시간을 밀리초로 반환합니다.
parseFloat 메서드 | 문자열에서 변환된 부동 소수점 숫자를 반환합니다.
parseInt 메서드 | 문자열에서 변환된 정수를 반환합니다.
pow 메서드 | 밑을 지정한 지수만큼 거듭제곱한 값을 반환합니다.
random 메서드 | 0과 1 사이의 의사 난수 값을 반환합니다.
replace 메서드 | 정규식을 사용하여 텍스트를 바꾼 문자열의 복사본을 반환합니다.
reverse 메서드 | 요소들이 역으로 나열된 Array 개체를 반환합니다.
round 메서드 | 주어진 수식을 반올림하여 가장 가까운 정수를 반환합니다.
search 메서드 | 정규식 검색에서 첫번째로 일치하는 부분 문자열의 위치를 반환합니다.
setDate 메서드 | 로컬 시간을 사용하여 Date 개체의 날짜 값을 설정합니다.
setFullYear 메서드 | 로컬 시간을 사용하여 Date 개체의 연도 값을 설정합니다.
setHours 메서드 | 로컬 시간을 사용하여 Date 개체의 시 값을 설정합니다.
setMilliseconds 메서드 | 로컬 시간을 사용하여 Date 개체의 밀리초 값을 설정합니다.
setMinutes 메서드 | 로컬 시간을 사용하여 Date 개체의 분 값을 설정합니다.
setMonth 메서드 | 로컬 시간을 사용하여 Date 개체의 월 값을 설정합니다.
setSeconds 메서드 | 로컬 시간을 사용하여 Date 개체의 초 값을 설정합니다.
setTime 메서드 | Date 개체의 날짜와 시간 값을 설정합니다.
setUTCDate 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 날짜 값을 설정합니다.
setUTCFullYear 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 연도 값을 설정합니다.
setUTCHours 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 시 값을 설정합니다.
setUTCMilliseconds 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 밀리초 값을 설정합니다.
setUTCMinutes 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 분 값을 설정합니다.
setUTCMonth 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 월 값을 설정합니다.
setUTCSeconds 메서드 | 협정 세계 표준시(UTC)를 사용하여 Date 개체의 초 값을 설정합니다.
setYear 메서드 | Date 개체의 연도 값을 설정합니다.
sin 메서드 | 사인 값을 반환합니다.
slice 메서드(Array) | 배열의 일정 부분을 반환합니다.
slice 메서드(String) | 문자열의 일정 부분을 반환합니다.
small 메서드 | String 개체의 텍스트 양 끝에 <SMALL> HTML 태그를 삽입합니다.
sort 메서드 | 요소들이 정렬된 Array 개체를 반환합니다.
split 메서드 | 문자열을 여러 개의 부분 문자열로 분리할 때 만들어지는 문자열의 배열을 반환합니다.
sqrt 메서드 | 제곱근 값을 반환합니다.
strike 메서드 | String 개체의 텍스트 양 끝에 <STRIKE> HTML 태그를 삽입합니다.
sub 메서드 | String 개체의 텍스트 양 끝에 <SUB> HTML 태그를 삽입합니다.
substr 메서드 | 지정한 위치에서 시작하고 지정한 길이를 갖는 부분 문자열을 반환합니다.
substring 메서드 | String 개체 안의 지정된 위치에 있는 부분 문자열을 반환합니다.
sup 메서드 | String 개체의 텍스트 양 끝에 <SUP> HTML 태그를 삽입합니다.
tan 메서드 | 탄젠트 값을 반환합니다.
test 메서드 | 검색한 문자열에 패턴이 있는지 여부를 나타내는 부울값을 반환합니다.
toArray 메서드 | VBArray에서 변환된 JScript 표준 배열을 반환합니다.
toGMTString 메서드 | 그리니치 표준시(GMT)를 사용하여 문자열로 변환된 날짜를 반환합니다.
toLocaleString 메서드 | 현재 로케일을 사용하여 문자열로 변환된 날짜를 반환합니다.
toLowerCase 메서드 | 모든 영문자가 소문자로 변환된 문자열을 반환합니다.
toString 메서드 | 개체를 나타내는 문자열을 반환합니다.
toUpperCase 메서드 | 모든 영문자가 대문자로 변환된 문자열을 반환합니다.
toUTCString 메서드 | 협정 세계 표준시(UTC)를 사용하여 문자열로 변환된 날짜를 반환합니다.
ubound 메서드 | 차원이 지정된 VBArray에서 사용하는 최고 인덱스 값을 반환합니다.
unescape 메서드 | escape 메서드로 인코딩한 String 개체를 디코딩합니다.
UTC 메서드 | 협정 세계 표준시(UTC)또는 그리니치 표준시(GMT) 1970년 1월 1일 자정부터 주어진 날짜 사이의 시간을 밀리초로 반환합니다.
valueOf 메서드 | 지정한 개체의 원시 값을 반환합니다.
언어 요소 | 설명
ActiveXObject 개체 | 자동화 개체에 대한 참조를 사용하여 반환합니다.
Array 개체 | 모든 데이터 형식의 배열을 만들 수 있도록 지원합니다.
Boolean 개체 | 새 부울값을 만듭니다.
Date 개체 | 날짜와 시간을 기본으로 저장하거나 가져올 수 있습니다.
Dictionary 개체 | 데이터 키-항목 쌍을 저장하는 개체입니다.
Enumerator 개체 | 컬렉션에 있는 항목들을 열거할 수 있습니다.
Error 개체 | JScript 코드 실행 중 발생하는 오류에 대한 정보를 포함하는 개체입니다.
FileSystemObject 개체 | 컴퓨터의 파일 시스템에 액세스할 수 있습니다.
Function 개체 | 새 함수를 만듭니다.
Global 개체 | 전역 메서드들을 하나의 개체로 모으는 내부 개체입니다.
Math 개체 | 기본적인 계산 기능과 상수를 제공하는 내부 개체입니다.
Number 개체 | 숫자 상수의 Number 데이터 형식과 자리 표시자를 나타내는 개체입니다.
Object 개체 | 모든 JScript 개체에 공통적인 기능을 제공합니다.
RegExp 개체 | 정규식 패턴 검색에 관한 정보를 저장합니다.
Regular Expression 개체 | 정규식 패턴을 포함합니다.
String 개체 | 텍스트 문자열을 조작하고 서식을 지정하거나 문자열 안에서 부분 문자열을 결정하고 위치를 지정할 수 있습니다.
VBArray 개체 | Visual Basic 안전 배열에 액세스할 수 있습니다.
언어 요소 | 설명
?: 연산자(삼항) | 조건에 따라 두 식 중 하나를 실행합니다.
-- 연산자 | 변수를 1씩 감소시킵니다.
!= 연산자 | 두 식을 비교하여 서로 다른 값을 갖는지 판단합니다.
== 연산자 | 두 식을 비교하여 서로 같은 값을 갖는지 판단합니다.
* 연산자 | 두 수를 곱합니다.
/ 연산자 | 두 수를 나눈 결과를 반환합니다.
% 연산자 | 두 수를 나눈 후 나머지를 반환합니다.
! 연산자 | 한 식에 논리 부정을 수행합니다.
|| 연산자 | 두 식에 논리합을 수행합니다.
&& 연산자 | 두 식에 논리곱을 수행합니다.
- 연산자 | 수식의 음수 값을 나타냅니다.
+ 연산자 | 두 숫자를 더하거나 문자열을 연결합니다.
=== 연산자 | 두 식을 비교하여 값과 데이터 형식이 서로 같은지 판단합니다.
<= 연산자 | 두 식을 비교하여 어느 쪽이 더 작거나 같은지 판단합니다.
< 연산자 | 두 식을 비교하여 어느 쪽이 작은지 판단합니다.
>= 연산자 | 두 식을 비교하여 어느 쪽이 더 크거나 같은지 판단합니다.
> 연산자 | 두 식을 비교하여 어느 쪽이 더 큰지 판단합니다.
!== 연산자 | 두 식을 비교하여 값과 데이터 형식이 서로 다른지 판단합니다.
& 연산자 | 두 식에 비트 논리곱을 수행합니다.
^ 연산자 | 두 식에 비트 배타적 논리합을 수행합니다.
~ 연산자 | 식에 비트 부정 연산을 수행합니다.
>> 연산자 | 부호를 바꾸지 않고 식을 비트 단위로 오른쪽으로 옮깁니다.
<< 연산자 | 식을 비트 단위로 왼쪽으로 옮깁니다.
| 연산자 | 두 식에 비트 논리합을 수행합니다.
- 연산자 | 두 식을 뺍니다.
, 연산자 | 두 식을 순차적으로 실행합니다.
>>> 연산자 | 부호 없이 식을 비트 단위로 오른쪽으로 옮깁니다.
++ 연산자 | 변수를 1씩 증가시킵니다.
= 연산자 | 변수에 값을 지정합니다.
delete 연산자 | 개체에서 속성을 삭제하거나 배열에서 요소를 제거합니다.
instanceof 연산자 | 개체가 특정 클래스의 인스턴스인지 여부를 나타내는 부울값을 반환합니다.
new 연산자 | 새 개체를 만듭니다.
typeof 연산자 | 식의 데이터 형식을 나타내는 문자열을 반환합니다.
void 연산자 | 식이 값을 반환하지 않도록 합니다.
복합 지정 연산자 | 복합 지정 연산자 목록
비교 연산자 | 비교 결과를 나타내는 부울값을 반환합니다.
연산자 우선 순위 | JScript 연산자 실행 우선 순위에 대한 정보 목록입니다.
언어 요소 | 설명
$1...$9 속성 | 패턴 일치 과정에서 찾아 저장된 최근 9개 부분을 반환합니다.
arguments 속성 | 현재 실행 중인 함수에 전달된 각 인수를 포함하는 배열을 반환합니다.
caller 속성 | 현재 함수를 불러온 함수에 대한 참조를 반환합니다.
constructor 속성 | 개체를 만드는 함수를 지정합니다.
description 속성 | 특정 오류와 관련된 설명적인 문자열을 반환하거나 설정합니다.
E 속성 | 자연 로그의 밑인 오일러 상수를 반환합니다.
index 속성 | 검색한 문자열에서 처음으로 일치하는 부분이 시작하는 문자 위치를 반환합니다.
Infinity 속성 | Number.POSITIVE_INFINITY의 초기 값을 반환합니다.
input 속성 | 검색하는 데 사용한 문자열을 반환합니다.
lastIndex 속성 | 검색한 문자열에서 마지막으로 일치하는 부분이 시작하는 문자 위치를 반환합니다.
length 속성(Array) | 배열에 정의된 요소의 최고값보다 하나 큰 정수값을 반환합니다.
length 속성(Function) | 함수에 정의된 인수의 개수를 반환합니다.
length 속성(String) | String 개체의 길이를 반환합니다.
LN2 속성 | 자연 로그 2를 반환합니다.
LN10 속성 | 자연 로그 10을 반환합니다.
LOG2E 속성 | 밑이 2인 로그 e(오일러 상수)를 반환합니다.
LOG10E 속성 | 밑이 10인 로그 e(오일러 상수)를 반환합니다.
MAX_VALUE 속성 | JScript에서 나타낼 수 있는 가장 큰 수를 반환합니다.
MIN_VALUE 속성 | JScript에서 나타낼 수 있는 0에 가장 가까운 수를 반환합니다.
NaN 속성(Global) | 식이 숫자가 아님을 표시하는 특수 값 NaN을 반환합니다.
NaN 속성(Number) | 식이 숫자가 아님을 표시하는 특수 값(NaN)을 반환합니다.
NEGATIVE_INFINITY 속성 | JScript에서 나타낼 수 있는 가장 큰 음수(-Number.MAX_VALUE)보다 큰 음수 값을 반환합니다.
number 속성 | 특정 오류와 관련된 숫자 값을 반환하거나 설정합니다.
PI 속성 | 원주율의 근사치 3.141592653589793을 반환합니다.
POSITIVE_INFINITY 속성 | JScript에서 나타낼 수 있는 가장 큰 양수(Number.MAX_VALUE)보다 큰 값을 반환합니다.
prototype 속성 | 개체 클래스의 초기 설정에 대한 참조를 반환합니다.
source 속성 | 정규식 패턴의 텍스트 복사본을 반환합니다.
SQRT1_2 속성 | 0.5의 제곱근 또는 1을 2의 제곱근으로 나눈 값을 반환합니다.
SQRT2 속성 | 2의 제곱근을 반환합니다.
언어 요소 | 설명
@cc_on 문 | 조건부 컴파일 지원 기능을 활성화합니다.
//(한 줄 주석문) | JScript 구문 분석기에서 한 줄로 된 주석문을 무시하도록 합니다.
/*..*/(여러 줄 주석문) | JScript 구문 분석기에서 여러 줄로 된 주석문을 무시하도록 합니다.
@if 문 | 식의 값에 따라 조건에 맞는 문 그룹을 실행합니다.
@set 문 | 조건부 컴파일 문에 사용할 변수들을 만듭니다.
break 문 | 현재 루프를 종료하거나 label로 연결된 경우에는 연결된 문을 종료합니다.
catch 문 | try 블록 안의 코드에 오류가 발생하면 실행할 문을 포함시킵니다 .
continue 문 | 현재 루프 반복을 중지하고 새로 반복을 시작합니다.
do...while 문 | 문 블록을 한 번 실행한 후 조건식이 false가 될 때까지 루프를 반복 실행합니다.
for 문 | 지정한 조건이 true인 동안 문 블록을 실행합니다.
for...in 문 | 개체나 배열의 각 요소에 대해 하나 이상의 문을 실행합니다.
function 문 | 새 함수를 선언합니다.
if...else 문 | 식의 값에 따라 조건에 맞는 문 그룹을 실행합니다.
Labeled 문 | 문에 식별자를 제공합니다.
return 문 | 현재 함수를 종료하고 그 함수에서 구한 값을 반환합니다.
switch 문 | 지정한 식의 값이 레이블과 일치하면 하나 이상의 문을 실행할 수 있습니다.
this 문 | 현재 개체를 참조합니다.
throw 문 | try...catch 문에서 처리할 수 있는 오류 조건을 만듭니다.
try 문 | JScript 오류를 처리합니다.
var 문 | 변수를 선언합니다.
while 문 | 지정한 조건이 false가 될 때까지 문을 실행합니다.
with 문 | 문의 기본 개체를 설정합니다.
언어 요소 | 설명
런타임 오류 | JScript 런타임 오류 목록
구문 오류 | JScript 구문 오류 목록

©1999 Microsoft Corporation. All rights reserved.


기능 정보

기능 정보 		JScript 언어 참조
버전 정보

JScript 기능 - ECMA
JScript 기능 - 비ECMA
Microsoft Scripting 런타임 기능


키워드 목록(사전순)

키워드 목록(사전순) 		JScript 언어 참조
버전 정보

$1...$9 속성
/*..*/(여러 줄 주석 문)
//(한 줄 주석 문)
@cc_on 문
@if 문
@set 문
-- 연산자
== 연산자
!= 연산자
* 연산자
% 연산자
/ 연산자
! 연산자
|| 연산자
&& 연산자
- 연산자
+ 연산자
=== 연산자
!== 연산자
< 연산자
> 연산자
| 연산자
& 연산자
^ 연산자
~ 연산자
>> 연산자
<< 연산자
- 연산자
, 연산자
>>> 연산자
<= 연산자
?: 연산자(삼항)
++ 연산자
= 연산자
>= 연산자
abs 메서드
acos 메서드
ActiveXObject 개체
anchor 메서드
arguments 속성
Array 개체
asin 메서드
atan 메서드
atan2 메서드
atEnd 메서드
big 메서드
blink 메서드
bold 메서드
Boolean 개체
break 문
caller 속성
catch 문
ceil 메서드
charAt 메서드
charCodeAt 메서드
compile 메서드
concat 메서드(Array)
concat 메서드(String)
constructor 속성
continue 문
cos 메서드
Date 개체
delete 연산자
description 속성
Dictionary 개체
dimensions 메서드
do...while 문
E 속성
Enumerator 개체
Error 개체
escape 메서드
eval 메서드
exec 메서드
exp 메서드
FileSystemObject 개체
fixed 메서드
floor 메서드
fontcolor 메서드
fontsize 메서드
for 문
for...in 문
fromCharCode 메서드
Function 개체
function 문
getDate 메서드
getDay 메서드
getFullYear 메서드
getHours 메서드
getItem 메서드
getMilliseconds 메서드
getMinutes 메서드
getMonth 메서드
GetObject 함수
getSeconds 메서드
getTime 메서드
getTimezoneOffset 메서드
getUTCDate 메서드
getUTCDay 메서드
getUTCFullYear 메서드
getUTCHours 메서드
getUTCMilliseconds 메서드
getUTCMinutes 메서드
getUTCMonth 메서드
getUTCSeconds 메서드
getVarDate 메서드
getYear 메서드
Global 개체
if...else 문
index 속성
indexOf 메서드
Infinity 속성
input 속성
instanceof 연산자
isFinite 메서드
isNaN 메서드
italics 메서드
item 메서드
join 메서드
Labeled 문
lastIndex 속성
lastIndexOf 메서드
lbound 메서드
length 속성(Array)
length 속성(Function)
length 속성(String)
link 메서드
LN2 속성
LN10 속성
log 메서드
LOG2E 속성
LOG10E 속성
match 메서드
Math 개체
max 메서드
MAX_VALUE 속성
min 메서드
MIN_VALUE 속성
moveFirst 메서드
moveNext 메서드
NaN 속성(Global)
NaN 속성(Number)
NEGATIVE_INFINITY 속성
new 연산자
Number 개체
number 속성
Object 개체
parse 메서드
parseFloat 메서드
parseInt 메서드
PI 속성
POSITIVE_INFINITY 속성
pow 메서드
prototype 속성
random 메서드
RegExp 개체
Regular expression 개체
replace 메서드
return 문
reverse 메서드
round 메서드
ScriptEngine 함수
ScriptEngineBuildVersion 함수
ScriptEngineMajorVersion 함수
ScriptEngineMinorVersion 함수
search 메서드
setDate 메서드
setFullYear 메서드
setHours 메서드
setMilliseconds 메서드
setMinutes 메서드
setMonth 메서드
setSeconds 메서드
setTime 메서드
setUTCDate 메서드
setUTCFullYear 메서드
setUTCHours 메서드
setUTCMilliseconds 메서드
setUTCMinutes 메서드
setUTCMonth 메서드
setUTCSeconds 메서드
setYear 메서드
sin 메서드
slice 메서드(Array)
slice 메서드(String)
small 메서드
sort 메서드
source 속성
split 메서드
sqrt 메서드
SQRT1_2 속성
SQRT2 속성
strike 메서드
String 개체
sub 메서드
substr 메서드
substring 메서드
sup 메서드
switch 문
tan 메서드
test 메서드
this 문
throw 문
toArray 메서드
toGMTString 메서드
toLocaleString 메서드
toLowerCase 메서드
toString 메서드
toUpperCase 메서드
toUTCString 메서드
try 문
typeof 연산자
ubound 메서드
unescape 메서드
UTC 메서드
valueOf 메서드
var 문
VBArray 개체
void 연산자
while 문
with 문
데이터 형식 변환
복합 지정 연산자
비교 연산자
연산자 우선 순위
정규식 구문
조건부 컴파일
조건부 컴파일 변수


오류

오류 		JScript 언어 참조
버전 정보

런타임 오류
구문 오류


함수

함수 		JScript 언어 참조
버전 정보

GetObject 함수
ScriptEngine 함수
ScriptEngineBuildVersion 함수
ScriptEngineMajorVersion 함수
ScriptEngineMinorVersion 함수


메서드

메서드 		JScript 언어 참조
버전 정보

abs 메서드
acos 메서드
anchor 메서드
asin 메서드
atan 메서드
atan2 메서드
AtEnd 메서드
big 메서드
blink 메서드
bold 메서드
ceil 메서드
charAt 메서드
charCodeAt 메서드
compile 메서드
concat 메서드(Array)
concat 메서드(String)
cos 메서드
dimensions 메서드
escape 메서드
eval 메서드
exec 메서드
exp 메서드
fixed 메서드
floor 메서드
fontcolor 메서드
fontsize 메서드
fromCharCode 메서드
getDate 메서드
getDay 메서드
getFullYear 메서드
getHours 메서드
getItem 메서드
getMilliseconds 메서드
getMinutes 메서드
getMonth 메서드
getSeconds 메서드
getTime 메서드
getTimezoneOffset 메서드
getUTCDate 메서드
getUTCDay 메서드
getUTCFullYear 메서드
getUTCHours 메서드
getUTCMilliseconds 메서드
getUTCMinutes 메서드
getUTCMonth 메서드
getUTCSeconds 메서드
getVarDate 메서드
getYear 메서드
indexOf 메서드
isFinite 메서드
isNaN 메서드
italics 메서드
item 메서드
join 메서드
lastIndexOf 메서드
lbound 메서드
link 메서드
log 메서드
match 메서드
max 메서드
min 메서드
moveFirst 메서드
moveNext 메서드
parse 메서드
parseFloat 메서드
parseInt 메서드
pow 메서드
random 메서드
replace 메서드
reverse 메서드
round 메서드
search 메서드
setDate 메서드
setFullYear 메서드
setHours 메서드
setMilliseconds 메서드
setMinutes 메서드
setMonth 메서드
setSeconds 메서드
setTime 메서드
setUTCDate 메서드
setUTCFullYear 메서드
setUTCHours 메서드
setUTCMilliseconds 메서드
setUTCMinutes 메서드
setUTCMonth 메서드
setUTCSeconds 메서드
setYear 메서드
sin 메서드
slice 메서드(Array)
slice 메서드(String)
small 메서드
sort 메서드
split 메서드
sqrt 메서드
strike 메서드
sub 메서드
substr 메서드
substring 메서드
sup 메서드
tan 메서드
test 메서드
toArray 메서드
toGMTString 메서드
toLocaleString 메서드
toLowerCase 메서드
toString 메서드
toUpperCase 메서드
toUTCString 메서드
ubound 메서드
unescape 메서드
UTC 메서드
valueOf 메서드


개체

개체 		JScript 언어 참조
버전 정보

ActiveXObject 개체
Array 개체
Boolean 개체
Date 개체
Dictionary 개체
Enumerator 개체
Error 개체
FileSystemObject 개체
Function 개체
Global 개체
Math 개체
Number 개체
Object 개체
RegExp 개체
Regular Expression 개체
String 개체
VBArray 개체


연산자

연산자 		JScript 언어 참조
버전 정보

+ 연산자
= 연산자
& 연산자
<< 연산자
~ 연산자
| 연산자
>> 연산자
^ 연산자
, 연산자
?: 연산자(삼항)
-- 연산자
/ 연산자
== 연산자
> 연산자
>= 연산자
=== 연산자
++ 연산자
!= 연산자
< 연산자
<= 연산자
&& 연산자
! 연산자
|| 연산자
% 연산자
* 연산자
!== 연산자
- 연산자
- 연산자
>>> 연산자
delete 연산자
instanceof 연산자
new 연산자
typeof 연산자
void 연산자
복합 지정 연산자
비교 연산자
연산자 우선 순위


속성

속성 		JScript 언어 참조
버전 정보

$1...$9 속성
arguments 속성
caller 속성
constructor 속성
description 속성
E 속성
index 속성
Infinity 속성
input 속성
lastIndex 속성(RegExp)
length 속성(Array)
length 속성(Function)
length 속성(String)
LN2 속성
LN10 속성
LOG2E 속성
LOG10E 속성
MAX_VALUE 속성
MIN_VALUE 속성
Nan 속성(Global)
NaN 속성(Number)
NEGATIVE_INFINITY 속성
number 속성
PI 속성
POSITIVE_INFINITY 속성
prototype 속성
source 속성
SQRT1_2 속성
SQRT2 속성


문

문 		JScript 언어 참조
버전 정보

break 문
catch 문
@cc_on 문
Comment 문
continue 문
do...while 문
for 문
for...in 문
function 문
@if 문
if...else 문
Labeled 문
return 문
@set 문
switch 문
this 문
throw 문
try 문
var 문
while 문
with 문


JScript 자습서

JScript 자습서
 JScript 언어 참조

JScript 정보
JScript 기초 학습
JScript 고급 학습
Internet Explorer에서 JScript 사용


JScript 정보

JScript 정보
 JScript 자습서
다음

JScript는 Microsoft사가 ECMA 262 언어 규칙을 구현한 결과물입니다. JScript는 Microsoft Internet Explorer를 이용할 수 있는 기능을 추가시킨 우수한 언어입니다. 이 자습서는 JScript를 사용할 수 있도록 도와주기 위한 것입니다.
쉬운 사용, 쉬운 학습
JScript는 해석된 개체 기반의 스크립트 언어입니다. 비록 JScript가 C++이나 Java와 같은 개체 지향 언어보다 기능은 적지만, 의도했던 목적 이상의 작업을 수행할 수 있는 매우 강력한 언어입니다.

JScript는 다른 언어의 축소판도 아니며(Java와 간접적으로만 관련되어 있음), 어떤 다른 언어를 간소화한 것도 아닙니다. 그러나 JScript는 제한적입니다. 예를 들어 독립적인 응용 프로그램을 쓸 수 없고 파일을 읽거나 쓸 수 있는 기능이 거의 없습니다. 게다가 JScript의 스크립트는 해석기가 있어야만 웹 서버나 웹 브라우저에서 작동할 수 있습니다.

JScript는 비교적 자유롭게 사용할 수 있는 언어입니다. 이것은 변수의 데이터 형식을 명확하게 선언할 필요가 없다는 것을 뜻합니다. 게다가 많은 경우 JScript는 필요할 때마다 자동으로 변환합니다. 사실 JScript에서는 데이터 형식을 명확하게 선언할 수 없습니다. 예를 들어 텍스트(문자열)를 구성하는 항목에 하나의 숫자를 삽입하면 그 숫자는 텍스트로 변환됩니다.

이 자습서의 나머지 부분에는 JScript의 특징이 개괄적으로 설명되어 있습니다. 언어 수행에 대한 자세한 내용은 언어 참조를 참고하십시오.

메모 이 자습서에 있는 대부분의 예제에 나오는 코드는 실제로 웹 페이지에서 볼 수 있는 코드보다 더 명확하고 덜 복잡한 편입니다. 대부분의 코드는 아주 간단합니다. 여기서 의도하는 것은 코딩의 간결함과 스타일을 보여 주려고 하는 것이 아니라 개념을 명확하게 전달하기 위한 것입니다. 작성한 지 6개월이 지난 후에도 쉽게 읽고 이해할 수 있는 코드를 쓴다는 것은 결코 부끄러운 일이 아닙니다.


JScript 코드 작성

JScript 코드 작성
 JScript 자습서
이전
다음

많은 다른 종류의 프로그래밍 언어와 같이 Microsoft JScript는 텍스트 형식으로 작성되며, 문, 상호 관련이 있는 문으로 이루어진 블록 및 주석으로 구성됩니다. 사용자는 문 내에서 변수, 문자열과 숫자와 같은 직접 실행 데이터, 식을 사용할 수 있습니다.
문
JScript 코드 문은 한 줄에 한 개 이상의 항목과 기호로 이루어져 있습니다. 새 줄은 새 문으로 시작하지만 문을 명확히 종결짓는 것이 좋습니다. 즉, JScript 종결 문자인 세미콜론(;)을 사용하여 문을 종결할 수 있습니다.
aBird = "로빈";
var today = new Date();
중괄호({})로 둘러 싸인 여러 줄의 JScript 문을 블록이라고 합니다. 예를 들어 블록은 함수나 조건문에 사용됩니다.

다음 예에서 첫째 문은 함수의 정의를 시작하는 문으로, 이 함수는 5개의 문으로 이루어진 블록으로 구성되어 있습니다. 중괄호를 사용하지 않은 마지막 3개 문은 블록이 아니며 함수의 일부분도 아닙니다.

function convert(inches)  {
    feet = inches / 12;  //  이 5개의 문은 하나의 블록입니다.
    miles = feet / 5280;
    nauticalMiles = feet / 6080;
    cm = inches * 2.54;
    meters = inches / 39.37;
}
km = meters / 1000;  //  이 3개의 문은 블록이 아닙니다.
kradius = km;
mradius = miles;
주석
한 줄의 JScript 주석은 슬래시 두 개로 시작합니다(//). 여러 줄 주석은 슬래시와 별표의 조합(/*)으로 시작하며 시작 표시와는 반대 순서인 별표와 슬래시(*/)로 끝납니다.
aGoodIdea = "주석을 완전히 다십시오";  //  이것은 한 줄 주석입니다.

/*
이것은 코드 문을 설명하는 여러 줄 주석입니다.

이 문은 aGoodIdea 변수에 값을 지정합니다. 따옴표 사이의 값을 리터럴이라고
합니다. 리터럴은 명시적이고 직접적인 정보를 가지고 있습니다. 다시 말해
정보를 간접적으로 참조하지 않습니다. 따옴표는 리터럴의 일부분이 아닙니다.
*/

//  이것은 또다른 여러 줄 주석입니다. 한 줄 주석을 여러 개 썼습니다.
//  문이 실행된 후 다음 문에서와 같이 변수 이름을 사용하여 aGoodIdea 변수의
//  내용을 참조할 수 있습니다. 여기서 문자열 리터럴은
//  연결에 의해 aGoodIdea 변수에 추가되어 새 변수를 만들어 냅니다.

var extendedIdea = aGoodIdea + " 무엇을 하는지를 알아낼 때까지는 절대로 모를 것입니다.";
지정과 같음
JScript에서 등호(=)는 값을 지정하는 동작을 가리킬 때 사용됩니다. 즉, JScript 코드 문을 다음과 같이 쓸 수 있습니다.
anInteger = 3;
이 코드 문은 "3이라는 값을 anInteger 변수에 지정하십시오." 또는 "anInteger가 3이라는 값을 갖습니다."라는 의미입니다. 두 값이 같은지 비교할 때 사용하는 기호로는 등호 두 개(==)를 사용합니다. 이 점에 대해서는 프로그램 흐름 제어에 자세히 설명되어 있습니다.
식
JScript 식은 부울식이나 숫자식으로 읽을 수 있는 것 입니다. 식에는 "더하기"와 같은 단어가 아니라 "+"와 같은 기호 문자가 포함됩니다. 값, 변수, 연산자 및 식이 적절하게 결합되어 식을 구성하게 됩니다.
var anExpression = "3 * (4 / 5)";
var aSecondExpression = "Math.PI * radius * 2";
var aThirdExpression = aSecondExpression + "%" + anExpression;
var aFourthExpression = "(" + aSecondExpression + ") % (" + anExpression + ")";


JScript 변수

JScript 변수
JScript 자습서
이전
다음

Microsoft JScript에서 변수는 스크립트 내에 값을 저장하는 데 사용됩니다. 변수를 사용하면 이름으로 값을 읽고 조작할 수 있습니다. 변수를 효과적으로 사용하면 스크립트를 이해하는 데 도움을 줍니다.
변수 선언
변수를 사용하기 전에 반드시 변수를 먼저 선언해야 할 필요는 없지만 이렇게 하는 것이 좋습니다. 변수 선언에는 var 문을 사용합니다. var 문을 반드시 사용해야 하는 경우는 함수에 대해 지역 변수를 선언할 때 뿐입니다. 지역 변수란 함수 내에서만 사용되는 변수를 말합니다. 다른 경우에는 var 문을 사용하여 변수를 선언해도 특별히 달라지는 것이 없습니다.

다음 코드는 변수 선언을 보여주는 예제입니다.

var mim = "사람, 계획, 운하, 파나마!";  // mim에 저장되는 값은 String 형식입니다.
// mim에 지정된 따옴표 안의 문장은 문자열 리터럴입니다.

var ror = 3;        // ror에 저장되는 값은 Number 형식입니다.
var nen = true;        // nen에 저장되는 값은 Boolean 형식입니다.
var fif = 2.718281828        // fif에 저장되는 값은 Number 형식입니다.
변수 명명
JScript에서는 대/소문자를 구분하기 때문에 myCounter 와 MYCounter란 변수 이름은 서로 다른 이름입니다. 또한 길이에는 제한이 없지만 변수 이름은 다음 규칙을 따라야 합니다.
  • 처음 문자로는 영문자(대문자 또는 소문자)나 밑줄(_), 달러 기호($) 중 하나를 사용해야 합니다.
  • 이어지는 문자로는 영문자, 숫자, 밑줄, 달러 기호를 사용할 수 있습니다.
  • 예약어와 같은 이름은 변수에 지정할 수 없습니다.
유효한 변수 이름에 대한 예는 다음과 같습니다.
  • _pagecount
  • Part9
  • Number_Items
잘못된 변수 이름에 대한 예는 다음과 같습니다.
  • 99Balloons // 숫자로 시작합니다.
  • Smith&Wesson // 앰퍼샌드(&)는 변수 이름에 사용할 수 없습니다.
특정한 값을 지정하지 않고 변수를 선언하여 초기화할 때는 특정 값으로 null을 지정할 수 있습니다.
var zaz = null;
var notalot = 3 * zaz;        // 여기에서 notalot은 0이 됩니다.
아무런 값도 지정하지 않고 변수를 선언하면 해당 변수는 존재하기는 하지만 undefined 상태가 됩니다.
var godot;
var waitingFor = 1 * godot;  // godot 값이 정의되어 있지 않으므로 waitingFor에 NaN 값을 지정합니다.
변수에 값을 지정하여 변수를 함축적으로 선언(var를 사용하지 않음)할 수 있습니다. 하지만 선언되지 않은 변수를 사용할 수는 없습니다. 선언하지 않은 변수를 사용하면 런타임 오류가 발생합니다.
lel = "";  // 변수 lel을 함축적으로 선언합니다.

var aMess = vyv + zez;  // vyv와 zez가 존재하지 않기 때문에 오류가 발생합니다.
강제 변환
JScript는 느슨한 형식의 언어이기 때문에 JScript 내의 변수는 기술적으로 고정된 형식이 없습니다. 변수의 형식은 변수에 포함되어 있는 값의 형식과 같습니다. 변수 또는 데이터의 일부를 다른 형식으로 자동 변환(강제)하는 경우도 있을 수 있습니다. 숫자는 문자열에 쉽게 포함될 수 있지만, 문자열은 직접 숫자에 포함될 수 없기 때문에 명시적 변환 함수 parseInt()와 parseFloat()를 사용합니다.
var theFrom = 1;
var theTo = 10;
var doWhat = "계산은 ";
doWhat += theFrom + "에서 " + theTo + "까지 입니다.";
이 코드를 실행하면 doWhat 변수에 "계산은 1에서 10까지 입니다"가 포함됩니다. 숫자 데이터가 문자열 형식에 강제로 포함된 것입니다.
var nowWhat = 0;
nowWhat += 1 + "10";  // 이 경우 "10"이 문자열이기 때문에
            // "+=" 연산자는 두 문자열을 연결합니다.
이 코드를 실행하면 nowWhat 변수에 "0110"이 포함됩니다. 이러한 결과가 나오려면 다음와 같은 단계를 거칩니다.
  1. 1과 "10"의 형식을 봅니다. "10"은 문자열이고 1은 숫자이기 때문에 숫자를 문자열로 변환합니다.
  2. + 연산자 양쪽에 모두 문자열이 있으므로 문자열을 결합합니다. 결과값은 "110"입니다.
  3. += 연산자 양쪽에 있는 값의 형식을 봅니다. nowWhat에는 숫자가 포함되어 있고, "110"은 문자열이기 때문에 숫자를 문자열로 변환합니다.
  4. += 연산자 양쪽에 모두 문자열이 있으므로 문자열을 결합합니다. 결과값은 "0110"입니다.
  5. 이 결과를 nowWhat에 저장합니다.
var nowThen = 0;
nowThen += 1 + parseInt("10");        // 이 경우 "+="은 덧셈을 실행합니다.
이 코드를 실행하면 nowThen 변수에 정수값 11이 포함됩니다.


JScript 데이터 형식

JScript 데이터 형식
 JScript 자습서
이전
다음

JScript 데이터 형식의 종류
Microsoft JScript에는 6가지 데이터 형식이 있습니다. 그 중 중요한 형식으로는 Number, String, Object, Boolean이 있으며, 나머지 두 형식은 null과 undefined입니다.
.
String 데이터 형식
문자열은 작은따옴표나 큰따옴표를 사용하여 표현됩니다. 따옴표를 포함한 문자열을 표현하려면 작은따옴표를 사용하십시오. JScript에서는 문자열도 개체인데 특별한 속성을 가지고 있으며 특별한 경우에 사용합니다. 문자열에 대한 예는 다음과 같습니다.
"암소가 달을 뛰어 넘었습니다."
'"얘들아, 그만!"하고 기술자가 소리쳤습니다.'
"42"
문자열은 0개 이상의 유니코드 문자를 포함할 수 있습니다. 문자열이 유니코드 문자를 전혀 포함하고 있지 않을 때 이를 빈 문자열("")이라고 합니다.
Number 데이터 형식
JScript는 정수와 부동 소수점 숫자를 지원합니다. 정수는 양수, 0, 또는 음수이며, 부동 소수점 숫자는 소수점 또는 과학적 표기법에서 10의 거듭제곱을 나타내는 "e"(대문자 또는 소문자) 중 하나를 포함하거나 둘 다 포함할 수 있습니다. 이러한 숫자들은 숫자 표현에서 IEEE 754 표준을 따릅니다. 마지막으로 다음과 같은 특별한 숫자 값들도 있습니다.
  • NaN, 숫자가 아님(not a Number)
  • Positive Infinity
  • Negative Infinity
  • Positive 0
  • Negative 0
정수는 10진수, 8진수 및 16진수로 표현될 수 있습니다.

8진수 정수는 "0"으로 시작하며 0부터 7까지의 숫자를 사용합니다. 숫자가 "0"으로 시작되고 숫자 "8" 및/또는 "9"를 포함한다면 그 숫자는 10진수입니다. 8진수이면서 문자 "e"(또는 "E")를 포함하는 숫자는 오류를 일으킵니다.

16진수("hex") 정수는 "0x"("X"는 소문자 또는 대문자)로 시작하며 0부터 9까지의 숫자와 A부터 F(소문자 또는 대문자)까지의 문자를 사용합니다. 16진수 표기법에서는 "e" 문자가 허용되지만 지수를 의미하지는 않습니다. A부터 F까지의 문자는 10진수의 10부터 15까지의 숫자를 나타내기 위하여 사용됩니다. 예를 들어 0xF는 15이고 0x10은 16을 의미합니다.

8진수와 16진수는 음수가 될 수는 있지만 분수가 될 수는 없습니다. "0"으로 시작하고 소수점을 포함하는 숫자는 부동 소수점 숫자입니다. "0x" 또는 "00"으로 시작하는 숫자가 소수점을 포함한다면 소수점 오른쪽에 있는 내용은 무시됩니다.

숫자에 관한 예

.0001, 0.0001, 1e-4, 1.0e-4  // 네 개의 부동 소수점 숫자, 모두 같은 숫자입니다.
3.45e2                       // 부동 소수점 숫자, 345를 의미합니다.
42                           // 정수
0377                         // 8진수, 255를 의미합니다.
00.0001                      // 8진수는 소수 부분을 가질 수 없습니다. 0을 의미합니다.
0378                         // 정수, 378을 의미합니다.
0Xff                         // 16진수, 255를 의미합니다.
0x37CF                       // 16진수, 14287을 의미합니다.
0x3e7                        // 16진수, 999를 의미합니다.
0x3.45e2                     // 16진수는 소수 부분을 가질 수 없습니다. 3을 의미합니다.
Boolean
부울값은 true이거나 false입니다. 부울값은 특별한 값이며 1과 0으로 사용하지 않습니다.

메모 비교문에서 값이 0인 표현식은 false로 간주되고, 0이 아닌 숫자로 평가되는 문장은 true로 간주됩니다. 따라서 다음식은 true입니다.

(false == 0)

비교에 대한 자세한 내용은 프로그램 흐름 제어를 참조하십시오.

undefined 데이터 형식
undefined 값은 변수가 작성된 후 변수에 값이 지정되기 전에 단순히 변수에 지정되는 값입니다.
null 데이터 형식
null 값은 아무런 값도 가지지 않으며 의미가 없습니다.


JScript 연산자

JScript 연산자 		JScript 자습서
이전
다음

JScript에서는 산술, 논리, 비트 및 지정 연산자와 같은 모든 범위의 연산자 뿐만 아니라 기타 연산자들도 사용할 수 있습니다.

산술 연산자 | 논리 연산자 | 비트 연산자 | 지정 연산자 | 기타 연산자
설명 | 기호 | 설명 | 기호 | 설명 | 기호 | 설명 | 기호 | 설명 | 기호
단항 부정 - 논리 부정 ! 비트 부정 ~ 지정 = 삭제 delete
증가 ++ 보다 작다 < 비트 왼쪽 이동 << 복합 지정 OP= 형식 typeof
감소 -- 보다 크다 > 비트 오른쪽 이동 >> 반환값 없음 void
곱셈 * 작거나 같다 <= 부호 없이 오른쪽으로 이동 >>>
나눗셈 / 크거나 같다 >= 비트 논리곱 &
나머지 연산 % 같음 == 비트 배타적 논리합 ^
덧셈 + 같지 않음 != 비트 논리합 |
뺄셈 - 논리곱 &&
논리합 ||
조건부(삼항) ?:
쉼표 ,
동치 ===
동치가 아님 !==

연산자 우선 순위
JScript에서 사용되는 연산자들은 일정한 순서에 의해 실행되는데 이러한 순서를 연산자 우선 순위라고 합니다. 아래 표는 우선 순위가 가장 높은 연산자부터 우선 순위가 가장 낮은 연산자까지를 정리한 것이며 같은 줄에 있는 연산자들은 왼쪽에서 오른쪽 순서로 계산됩니다.

연산자 | 설명
. [] () 필드 액세스, 배열 인덱스, 함수 호출
++ -- - ~ ! typeof new void delete | 단일 연산자, 데이터 형식 반환, 개체 작성, 정의되지 않은 값
* / % 곱셈, 나눗셈, 나머지 연산
+ - + 덧셈, 뺄셈, 문자열 연결
<< >> >>> 비트 이동
< <= > >= 보다 작다, 작거나 같다, 보다 크다, 크거나 같다
== != === !== 같음, 같지 않음, 동치, 동치가 아님
& 비트 논리곱
^ 비트 배타적 논리합
| 비트 논리합
&& 논리곱
|| 논리합
?: 조건
= OP= | 지정, 복합 지정
, 다중 연산

괄호는 계산 순서를 바꾸기 위해 사용합니다. 괄호 안에 있는 식은 완전히 계산된 다음에 문의 다른 부분에서 사용됩니다.

우선 순위가 높은 연산자들은 우선 순위가 낮은 연산자들보다 먼저 계산됩니다. 예를 들어 다음과 같습니다.

z = 78 * (96 + 3 + 45)
이 식에는 =, *, (), +, +라는 다섯 개의 연산자가 존재합니다. 이 연산자들은 연산자 우선 순위에 따라 (), *, +, +, =의 순서로 계산됩니다.
  1. 괄호 안에 있는 연산자가 먼저 계산됩니다. 괄호 안에 있는 두 개의 덧셈 연산자는 동일한 우선 순위를 가지므로 먼저 96에 3을 더하고 그 값에 다시 45가 더해져서 값은 144가 됩니다.
  2. 그 다음에 곱셈 연산이 수행됩니다. 즉, 78과 144가 곱해져서 11232가 됩니다.
  3. 마지막으로 지정 연산이 수행되어 11232라는 값이 z에 지정됩니다.


프로그램 흐름 제어

프로그램 흐름 제어
JScript 자습서
이전
다음

실행 흐름을 제어하는 이유
조건이 다르면 다른 작업을 수행하는 스크립트가 필요한 경우가 많이 있습니다. 예를 들어 매시간마다 시간을 확인하고 그 날의 일정동안 적절하게 일부 매개 변수를 변경하는 스크립트가 필요할 수도 있을 것이며, 모종의 입력을 받아들여 그에 맞게 작동할 수 있는 스크립트가 필요할 수도 있을 것입니다. 또는 지정한 동작을 반복하는 스크립트가 필요할 수도 있을 것입니다.

사용자들이 테스트할 수 있는 여러 종류의 조건들이 있습니다. Microsoft JScript에서 할 수 있는 모든 조건 테스트는 Boolean입니다. 따라서 모든 테스트의 결과는 true이거나 false입니다. 사용자는 Boolean, Number, 또는 String 형식의 값들을 자유롭게 테스트할 수 있습니다.

JScript는 다양한 가능성을 지닌 제어 구조를 제공합니다. 가장 간단한 제어 구조는 조건문입니다.

조건문 사용
JScript는 if 조건문과 if...else 조건문을 지원합니다. if 문에서는 한 조건이 테스트되고 해당 조건이 테스트를 만족시키면 사용자가 만든 JScript 코드가 실행됩니다. if...else 문에서는 조건이 테스트를 만족시키지 못하면 다른 코드가 실행됩니다. 가장 간단한 형태의 if 문은 한 줄로도 완벽하게 쓸 수 있지만 여러 줄로 된 if 문과 if...else 문이 훨씬 더 일반적입니다.

다음 예제들은 if 문과 if...else 문에서 사용할 수 있는 구문을 보여주고 있습니다. 첫째 예제는 가장 간단한 Boolean 테스트를 보여줍니다. 괄호 안의 항목이 true이면, if 뒤의 문이나 문 블록이 실행됩니다.

// smash() 함수는 코드의 다른 곳에 정의되어 있습니다.
if (newShip)
   smash(champagneBottle,bow);  // newShip가 true인지 여부를 가리는 Boolean 테스트

// 이 예제에서는 두 조건이 모두 true가 아니면 테스트는 실패입니다.
if (rind.color == "진한 노랑" && rind.texture == "크고 작은 주름")
{
        theResponse = ("이것이 크렌쇼 멜론인가요?<br> ");
}

// 이 예제에서는 두 조건 중 하나만 true이어도 테스트는 성공입니다.
var theReaction = "";
if ((lbsWeight > 15) || (lbsWeight > 45))
{
    theReaction = ("오, 귀여운 새끼 고양이! <br>");
}
else
    theReaction = ("거기에 있는 고양이는 덩치가 큽니다! <br>");
조건 연산자
JScript는 또한 함축적인 조건 형식을 지원합니다. JScript에서는 조건 앞에 if라는 단어를 사용하지 않고 테스트할 조건 뒤에 물음표를 사용하고, 두 개의 대안을 지정하는데, 하나는 조건이 만족될 경우에 사용될 대안이고 다른 하나는 조건이 만족되지 못할 경우에 사용될 대안입니다. 두 대안은 콜론으로 구분됩니다.
var hours = "";

// 시간이 theHour 또는 theHour - 12의 의미를 포함한다는 것을 나타내는 코드

hours += (theHour >= 12) ? " 오후" : " 오전";

팁 여러 개의 조건을 함께 테스트해야 하고 테스트가 OR(||)로 연결되는지 또는 AND(&&)로 연결되는지에 따라 한 조건이 다른 나머지 조건보다 실패 또는 성공할 가능성이 높다는 것을 알고 있는 경우, 해당 조건을 조건문의 처음에 두면 스크립트 실행 속도가 빨라질 수 있습니다. 예를 들어, 3가지 조건이 모두 true이어야 할 경우(&& 연산자 사용) 둘째 테스트에 실패하면 셋째 조건은 테스트되지 않습니다.

이와 유사하게 여러 조건 중의 한 조건이 true이어야 할 경우(|| 연산자 사용), 어느 하나의 조건이 테스트를 통과하게 되면 테스트는 멈추게 됩니다. 이것은 테스트할 조건에 함수 호출 또는 다른 코드의 실행을 포함하고 있을 경우에 특히 효과적입니다.

짧은 길이로 문을 구성하는 데 따른 부작용은 아래 예제에서 runfirst()가 0 또는 false를 반환하면 runsecond가 실행되지 않는다는 것입니다.

if ((runfirst() == 0) || (runsecond() == 0))
// 일부 코드
반복 사용 또는 루프
문이나 문 블록을 반복 실행하는 데는 몇 가지 방법이 있습니다. 일반적으로 반복적인 실행을 루핑이라고 합니다. 루핑은 전형적으로 몇 가지 변수의 테스트에 의해 제어되는데, 변수의 값은 루프가 실행될 때마다 달라집니다. Microsoft JScript는 for 루프, for...in 루프, while 루프, do...while 루프 및 switch 루프와 같은 다양한 종류의 루프를 지원합니다.
for 루프 사용
for 문은 카운터 변수, 테스트 조건 및 카운터를 업데이트하는 동작을 지정합니다. 매번 루프가 실행되기 직전에(이것을 한 주기 또는 루프 일회 반복이라고 함) 조건이 테스트됩니다. 루프가 실행된 후 카운터 변수는 다음 반복이 시작되기 전에 업데이트됩니다.

루핑 조건이 단 한 번도 만족되지 않으면 루프는 전혀 실행되지 않습니다. 테스트 조건이 항상 만족되면 무한 루프가 발생됩니다. 루프가 전혀 실행되지 않는 경우가 일부 바람직하지만 무한 루프가 발생하는 경우는 바람직하지 않으므로 루프 조건을 만들 때 주의하십시오.

/*
업데이트 식(아래 예제의 "icount++")은 루프의 끝에서 실행되는데, 루프의 본문을 형성하는 문 블록이 실행된 후 조건이 테스트되기 전에 실행됩니다.
*/

var howFar = 11;  // 루프의 반복 횟수를 11로 제한합니다.

var sum = new Array(howFar);  // 11개의 구성원(0부터 10까지)을 가진 sum이라는 배열을 만듭니다.
var theSum = 0;
sum[0] = 0;

for(var icount = 1; icount < howFar; icount++)  {        // 이 경우 1부터 10까지 셉니다.
theSum += icount;
sum[icount] = theSum;
}

var newSum = 0;
for(var icount = 1; icount > howFar; icount++)  {        // 전혀 실행되지 않습니다.
newSum += icount;
}

var sum = 0;
for(var icount = 1; icount > 0; icount++)  {        // 무한 루프입니다.
sum += icount;
}
for...in 루프 사용
JScript는 개체의 모든 속성을 통하여 단계적으로 작업할 수 있는 특별한 종류의 루프를 제공합니다. for...in 루프의 루프 카운터는 배열의 모든 인덱스를 단계적으로 작업합니다. 그런데 이것은 숫자가 아니라 문자열입니다.
for (j in tagliatelleVerde)  // tagliatelleVerde는 몇 가지 속성을 가진 개체입니다.
{
// 다양한 JScript 코드 문
}
while 루프 사용
while 루프는 for 루프와 매우 유사합니다. 두 루프의 차이점이라면 while 루프에는 내부 카운터 변수나 업데이트 식이 없다는 것입니다. 이미 변수에 지정된 값에 반영되는 몇 가지 변경 조건이 있고 그 조건을 이용하여 문이나 문 블록의 반복 실행을 제어하려면 while 루프를 사용하십시오.
var theMoments = "";
var theCount = 42;        // 카운터 변수를 초기화합니다.
while (theCount >= 1)  {
    if (theCount > 1)  {
        theMoments = theCount + "요소만" + "남았습니다.";
}
    else  {
        theMoments = "한 요소만 남았습니다.";
    }
theCount--;        // 카운터 변수를 업데이트합니다.
}
theMoments = "BLASTOFF!";

메모 while 루프가 명시적인 내부 카운터 변수를 가지지 않기 때문에 다른 루프 형식보다 무한 루프에 빠지기 쉽습니다. 게다가 루프 조건이 언제 어디에서 업데이트되는지를 알아내는 것이 쉽다고만 볼 수는 없으므로 조건이 업데이트되지 않는 while 루프를 작성하기 쉽습니다. 따라서 while 루프를 설계할 때는 상당한 주의를 기울여야 합니다.

break 문과 continue 문 사용
Microsoft JScript는 루프의 실행을 중단하는 문을 제공합니다. break 문은 아마도 어떤 특별한 조건이 만족될 때 실행을 멈추기 위하여 사용됩니다. 그리고 continue 문은 다음 반복 계산으로 즉시 이동하는 데 사용되며, 코드 블록의 나머지 부분은 건너뛰지만 for 루프 또는 for...in 루프처럼 카운터 변수는 업데이트됩니다.
var theComment = "";
var theRemainder = 0;
var theEscape = 3;
var checkMe = 27;
for (kcount = 1; kcount <= 10; kcount++)
{
    theRemainder = checkMe % kcount;
    if (theRemainder == theEscape)
      {
            break;  // 나머지가 중지값과 같은 값이 처음 나오면 루프를 빠져 나갑니다.
}
theComment = checkMe + " /(나누기) " + kcount + "의 나머지는 " + theRemainder +" 입니다.";
}

for (kcount = 1; kcount <= 10; kcount++)
{
   theRemainder = checkMe % kcount;
   if (theRemainder != theEscape)

   {
      continue;  // 나머지와 중지값이 동일한 경우만을 선택하고 다른 경우는 모두 무시합니다.
}
// 선택한 나머지를 사용하는 JScript 코드
}

var theMoments = "";
var theCount = 42;  // 카운터가 초기화됩니다.
while (theCount >= 1)  {
if (theCount < 10)  {  // 경고!
// 다음과 같이 continue를 사용하면 무한 루프에 빠집니다.
// continue;
// }
    if (theCount > 1)  {
        theMoments = theCount + "번 남았습니다!";
}
    else  {
        theMoments = "한 번 남았습니다!";
    }
theCount--;  // 카운터가 업데이트됩니다.
}
theCount = "BLASTOFF!";


JScript 함수

JScript 함수
 JScript 자습서
이전
다음

함수 개요
Microsoft JScript 함수는 동작을 수행합니다. 또한 함수는 결과를 반환하기도 합니다. 때때로 함수는 연산이나 비교의 결과입니다.

함수는 하나의 이름으로 여러 개의 연산을 결합시킵니다. 이렇게 하면 코드를 단정하게 정리할 수 있습니다. 일련의 문을 쓸 수도 있고, 함수에 이름을 지정할 수도 있으며, 원할 때마다 함수를 호출하여 함수에 필요한 정보를 함수에 전달함으로써 전체 집합을 실행할 수 있습니다.

함수에 정보를 전달하려면 함수 이름 뒤에 나오는 괄호 안에 정보를 넣으면 됩니다. 함수로 전달되는 정보들은 인수 또는 매개 변수라고 합니다. 어떤 함수는 인수를 전혀 사용하지 않고, 어떤 함수는 인수를 한 개 사용하며, 어떤 함수는 인수를 여러 개 사용합니다. 함수 중에는 함수를 사용하는 방법에 따라 사용하는 인수의 수가 달라지는 함수도 있습니다.

JScript는 두 종류의 함수를 지원합니다. 즉, 언어에 기본적으로 제공되는 함수와 사용자가 스스로 만드는 함수를 지원합니다.

특수 기본 제공 함수
JScript 언어에는 여러 개의 기본 제공 함수가 포함되어 있습니다. 사용자는 기본 제공 함수의 일부를 사용하여 식과 특수 문자를 처리할 수 있으며, 문자열을 숫자 값으로 변환할 수도 있습니다.

예를 들어 escape() 함수와 unescape() 함수는 HTML 코드에서 특수한 의미를 지니는 문자, 즉 직접 텍스트로 입력할 수 없는 문자를 변환하는 데 사용됩니다. "<"와 ">" 꺾쇠 괄호는 HTML 태그를 표시합니다.

escape 함수는 모든 특수 문자를 인수로 사용하며, 해당 특수 문자에 대한 제어 코드를 반환합니다. 각각의 제어 코드는 백분율 기호(%)와 그 뒤에 오는 두 자릿수로 구성됩니다. unescape 함수는 escape 함수와 정반대입니다. 이 함수는 백분율 기호와 두 자리수로 구성된 문자열을 인수로 사용하여, 문자를 반환합니다.

JScript가 기본적으로 제공하는 또 다른 유용한 함수로는 eval() 함수를 들 수 있습니다. 이 함수는 문자열 형식으로 표시되는 모든 유효한 수학식을 계산합니다. eval() 함수는 인수를 한 개 사용하며 그 인수는 계산할 식입니다.

var anExpression = "6 * 9 % 7";
var total = eval(anExpression);        // total 변수에 값 5를 지정합니다.
var yetAnotherExpression = "6 * (9 % 7)";
total = eval(yetAnotherExpression)        // total 변수에 값 12를 지정합니다.

var totality = eval("많은 조개에 둘러싸인...");        // 오류가 발생합니다.
여기에 설명되어 있는 기본 제공 함수와 여기에서 설명하지 않은 기본 제공 함수에 대한 자세한 내용은 언어 참조를 참조하십시오.
함수 직접 만들기
자기만의 함수를 만들어 필요할 때마다 사용할 수 있습니다. 함수 정의는 함수 문과 JScript 문 블록으로 구성됩니다.

아래 예제에 나오는 checkTriplet 함수는 삼각형의 세 변의 길이를 인수로 사용하고, 세 숫자가 피타코라스 정리(직각 삼각형의 빗변을 제곱한 값은 다른 두 변의 제곱을 합한 값과 같음)를 구성하는지를 확인하여 삼각형이 직각 삼각형인지를 계산합니다. checkTriplet 함수는 두 개의 다른 함수 중 하나를 호출하여 실질적인 테스트를 합니다.

부동 소수점 테스트에서 테스트 변수로 아주 작은 숫자("엡실론")를 사용합니다. 부동 소수점 계산의 불확실성 오류와 반올림 오류 때문에 논의되고 있는 세 값이 정수가 아니면 빗변을 제곱한 값이 다른 두 변의 제곱을 합한 값과 같은지를 직접 테스트한다는 것은 현실적이지 못합니다. 직접적인 테스트가 더 정확하므로, 아래 예제의 코드는 정수가 적절한지를 결정하고, 만일 정수가 적절하다면 그것을 사용합니다.

var epsilon = 0.0000000000001;  // 테스트할 매우 작은 숫자입니다.
var triplet = false;

function integerCheck(a, b, c)  {  // 정수 테스트 함수입니다.
    if ( (a*a) == ((b*b) + (c*c)) )  {  // 테스트
    triplet = true;
    }
}  // 정수 검사 함수의 끝

function floatCheck(a, b, c)  {  // 부동 소수점 숫자 테스트 함수입니다.
var theCheck = ((a*a) - ((b*b) + (c*c)))  // 테스트 숫자를 만듭니다.
    if (theCheck < 0)  {  // 테스트에는 절대값이 필요하므로, 음수일 경우에는 theCheck를 양수로 만듭니다.
    theCheck *= -1;
    }
    if (epsilon > theCheck)  {  // theCheck가 엡실론에 가깝다면 매우 가깝습니다.
    triplet = true;
    }
}  // 부동 소수점 검사 함수의 끝

function checkTriplet(a, b, c)  {  // triplet 검사기. 먼저 가장 긴 변을 "a" 위치로 옮깁니다.
var d = 0;  // 임시 저장소를 만듭니다.
    if (c > b)  {  // c > b이면 교환합니다.
    d = c;
    c = b;
    b = d;
    }  // 아니면 무시합니다.
    if (b > a)  {  // b > a이면 교환합니다.
    d = b;
    b = a;
    a = d;
    }  // 아니면 무시합니다.

// 한 변이 있을 경우 "a" 변은 이제 빗변입니다.

    if (((a%1) == 0) && ((b%1) == 0) && ((c%1) == 0))  {  // 세 값을 모두 테스트합니다. 모두 정수입니까?
    integerCheck(a, b, c);  // 정수라면 정밀한 검사를 사용합니다.
    }
    else
        floatCheck(a, b, c);  // 아니면 합리적으로 가능한 근사치를 가져옵니다.
}  // triplet 검사 함수의 끝

// 아래의 세 문은 테스트용으로 예제 값을 지정합니다.
var sideA = 5;
var sideB = 5;
var sideC = Math.sqrt(50);

checkTriplet(sideA, sideB, sideC);  // 함수를 호출합니다. 호출 후에 triplet에는 결과가 포함됩니다.


JScript 개체

JScript 개체
 JScript 자습서
이전
다음

개체 정의
Microsoft JScript에서 개체란 본질적으로 속성과 메서드의 컬렉션입니다. 메서드는 개체의 한 구성원인 함수이고, 속성은 개체의 한 구성원인 하나의 값 또는 여러 값들의 집합(하나의 배열이나 개체의 폼에서)입니다. JScript는 내부 개체, 사용자 정의 개체, 브라우저 개체라는 3종류의 개체를 지원합니다. 브라우저 개체들은 다른 곳에서도 설명됩니다.
배열로 사용되는 개체
JScript에서는 개체와 배열을 동일한 것으로 취급합니다. 개체의 각 구성원(속성과 메서드)을 참조하려면 이름(개체명, 마침표(.), 속성명의 순서로 입력) 또는 배열 아래 첨자 인덱스를 사용하면 됩니다. JScript에서 아래 첨자는 0부터 번호를 매기기 시작합니다. 또한 사용자 편의를 위해 아래 첨자는 아래 첨자의 이름으로도 참조할 수 있습니다.

따라서 여러 가지 방법으로 속성을 참조할 수 있기 때문에 아래의 문은 동일한 효과를 나타냅니다.

theWidth = spaghetti.width;
theWidth = spaghetti[3];  // [3]은 "width" 인덱스입니다.
theWidth = spaghetti["width"];
숫자 인덱스로 속성을 참조할 경우 대괄호는 사용할 수 있지만 점(.)은 사용할 수 없습니다. 아래 문은 오류를 일으킵니다.
theWidth = spaghetti.3;
한 개체가 다른 개체를 속성으로 사용할 경우 기존 명명 규칙을 그대로 적용합니다.
var init4 = toDoToday.shoppingList[3].substring(0,1);  // 배열인 shoppingList는 toDoToday의 속성입니다.
개체를 다른 개체의 속성으로 사용할 수 있다는 사실은 직접 지원되지 않는 둘 이상의 아래 첨자를 가진 배열을 만들 수 있다는 것을 의미합니다. 아래 코드는 0 X 0부터 16 X 16까지의 곱셈표를 만듭니다.
var multTable = new Array(17);  // 표가 될 셸을 만듭니다.
for (var j = 0; j < multTable.length; j++)  {  // 행을 설정합니다.
    var aRow = new Array(17);  // 행을 하나 만듭니다.
    for (var i = 0; i < aRow.length; i++)  {  // 만든 행에 들어갈 값을 설정합니다.
    aRow[i] = (i + " times " + j + " = " + i*j);  // 값 하나를 만들어 대입합니다.
    }
multTable[j] = aRow;  // 값들로 채워진 행을 표에 배열합니다.
}
이런 종류의 배열 요소 중 하나를 참조하려면 대괄호를 여러 개 사용하십시오.
var multiply3x7 = multTable[3][7];
다음 문은 오류를 일으킵니다.
var multiply3x7 = multTable[3, 7];


JScript 예약어

JScript 예약어
 JScript 자습서
이전
다음

JScript에는 여러 개의 예약어가 있습니다. 이들 단어는 JScript 예약어, 예비 예약어, 그리고 피해야 할 단어 등 세 종류로 나뉩니다.

JScript 키워드
break | false | in | this | void
continue | for | new | true | while
delete | function | null | typeof | with
else | if | return | var

JScript 예비 키워드
case | debugger | export | super
catch | default | extends | switch
class | do | finally | throw
const | enum | import | try

JScript 내부 개체나 함수의 이름 등 이미 있는 이름은 모두 피해야 할 단어에 속합니다. String이나 parseInt와 같은 단어도 여기에 해당합니다.

처음 두 가지 범주에서 키워드를 사용하면 스크립트를 처음 로드할 때 컴파일 오류가 발생합니다. 셋째 범주에 해당하는 예약어를 사용하면 같은 스크립트에서 이름이 같은 변수와 원래 항목을 모두 사용하려고 할 때 동작에 이상을 일으킬 수 있습니다. 예를 들어 다음과 같은 스크립트는 예기치 못한 결과를 나타냅니다.

var String;
var text = new String("문자열 개체입니다.");
이 경우에는 String이 개체가 아니라는 내용의 오류 메시지가 표시됩니다. 대부분의 경우 기존의 식별자를 사용하면 이와 같이 명확하지 않습니다.


재귀

재귀
 JScript 자습서
이전
다음

재귀는 중요한 프로그래밍 테크닉으로서 이것을 사용하여 함수 자체 내에서 그 함수를 다시 호출합니다. 쉬운 예는 팩토리얼(계승)의 계산입니다. 0 과 1의 계승은 특별히 1로 정의되어 있습니다. 그 이상의 수에 대한 계승은 1 * 2 *... 와 같은 식으로, 계산하려는 숫자에 도달할 때까지 1씩 증가시켜서 곱합니다.

아래 단락은 계승 계산에 대한 기능 설명입니다.

"수가 0보다 작으면 계산을 거부하고 정수가 아니면 소수점 이하를 버린 후의 정수를 사용니다. 계승 수가 0 또는 1이면 그 계승값은 1이고, 1보다 크면 그것보다 1 작은 수가 될 때까지 계승값을 곱합니다."

1보다 큰 수의 계승을 계산하려면 최소한 하나의 다른 수에 대한 계승값을 구해야 합니다. 그 계산을 하기 위해 사용하려고 하는 함수는 현재 사용하고 있는 바로 그 함수입니다. 따라서 현재 수를 실행하기 전에 먼저 자신을 호출해서 바로 이전의 작은 수에 대한 계산을 해야 합니다. 이것이 재귀의 한 예입니다.

물론 곤경에 처할 수도 있습니다. 최종 결과값을 구하지도 못하고 종료 지점에 이르지도 못하는 재귀 함수를 아주 쉽게 만들 수 있습니다. 이러한 재귀 함수는 컴퓨터로 하여금 소위 "무한" 루프라는 것을 실행하도록 만듭니다. 예를 들어, 계승 계산 설명에 있는 첫번째 규칙(음수 처리 방법)을 무시하고 임의 음수에 대한 계승 계산을 시도해 봅니다. 그러면 실패하게 되는데 그 이유는 예를 들어 -24의 계승을 계산하려면 그전에 -25에 대한 것을 계산해야 하지만 또 그것을 계산하려면 마찬가지로 그전에 -26에 대한 것을 계산해야 합니다. 따라서 이것은 영원히 종료 지점에 이르지 못하게 됩니다.

그러므로 재귀 함수를 만들 때는 매우 신중히 설계하는 것이 무엇보다도 중요합니다. 만일 무한 재귀의 가능성이 있다고 의심되면 자기 자신을 호출하는 횟수를 집계하는 함수를 설정하면 됩니다. 그 횟수가 지정한 것보다 많으면 함수를 자동으로 종료시키도록 합니다.

아래는 계승 함수의 또 다른 예로서 JScript 코드로 만든 것입니다.

function factorial(aNumber)  {
aNumber = Math.floor(aNumber);  // 정수가 아니면 소수 이하를 버립니다.
if (aNumber < 0)  {  // 0보다 작으면 거부합니다.
    return "not a defined quantity";
    }
      if ((anumber == 0) || (anumber == 1))  {  // 0 또는 1 이면 그 계승값은 1 입니다.
      return 1;
      }
        else return (anumber * factorial(anumber - 1));  // 그렇지 않으면 종료 지점에 이를 때까지 재귀합니다.
}


변수 범위

변수 범위
 JScript 자습서
이전
다음

Microsoft JScript에는 두 가지 범위, 즉 전역과 지역이 있습니다. 함수 정의의 외부에 변수를 선언하면 전역 변수가 되고, 그 값은 프로그램 전체에서 액세스하거나 수정할 수 있습니다. 함수 정의의 내부에 변수를 정의하면 이 변수는 지역 변수가 됩니다. 이 변수는 함수가 실행될 때마다 생성되고 소멸됩니다. 다시 말해 함수 외부에서는 액세스할 수 없습니다.

지역 변수는 전역 변수와 동일한 이름을 가질 수 있지만, 지역 변수는 전역 변수와 완전하게 구별되며 별개의 것입니다. 결론적으로 말해 한 변수의 값을 변경해도 다른 변수에 영향을 미치지 않습니다. 지역 변수가 정의된 함수 내부에는 오직 지역 변수만이 의미를 갖습니다.

var aCentaur = "기수가 탄 말";  // aCentaur의 전역 정의

// JScript 코드, 간결함을 위해 생락했습니다.
function antiquities()  // 지역 aCentaur 변수가 이 함수에서 선언됩니다.
{

// JScript 코드, 간결함을 위해 생락했습니다.
var aCentaur = "켄타우로스는 말을 탄 스키타이 전사일 것입니다.";

// JScript 코드, 간결함을 위해 생락했습니다.
  aCentaur += ", 다음과 같이 잘못 보고되었습니다.";  // 지역 변수에 추가합니다.

// JScript 코드, 간결함을 위해 생락했습니다.
}  // 함수의 끝입니다.

var nothinginparticular = antiquities();
aCentaur += "순진하게 멀리서 보는 것처럼";

/*
함수 내부의 변수에는 "켄타우로스는 말을 탄 스키타이 전사일 것입니다. 다음과 같이 잘못 보고했습니다."가 들어있습니다. 함수 외부의 변수에는 나머지 문장이 들어있습니다.
"기수가 탄 말, 순진하게 멀리서 보는 것처럼."
*/
변수는 변수가 존재하는 범위가 무엇이든 그 범위의 시작 부분에서 선언된 것처럼 동작합니다. 그 결과 가끔씩 예상치 못한 동작을 합니다.
var aNumber = 100;
var withAdditive = 0;

withAdditive += aNumber;  // withAdditive는 현재 100입니다.
tweak();
withAdditive += aNumber;  // withAdditive는 현재 200입니다.

function tweak()  {
var newThing = 0;  // newThing 변수의 명시적인 선언입니다.
// 주석이 없을 경우 다음 문은 오류를 일으킵니다.
// newThing = aNumber;
// 다음 문은 42라는 값을 aNumber 지역 변수에 지정하며, 함축적으로 aNumber 지역 변수를 선언합니다.
aNumber = 42;
if (false)  {
    var aNumber;  // 이 문은 실행되지 않습니다.
    aNumber = "안녕하십니까!";  // 이 문은 실행되지 않습니다.
    }  // 조건문의 끝입니다.
}  // 함수 정의의 끝입니다.
주석이 있는 이 문은 지역 변수 aNumber의 값을 지역 변수 newThing에 지정하려고 합니다. 이런 경우 지역 변수 aNumber가 함수의 다른 곳에서 정의되어 전체에 존재함에도 불구하고 실패합니다. aNumber 변수는 이 문이 코드에서 발생하는 시점에서 어떤 값도 지정받지 못하여 undefined가 됩니다.


데이터 복사, 전달, 비교

데이터 복사, 전달, 비교
 JScript 자습서
이전
다음

Microsoft JScript에서 데이터를 처리하는 방법은 데이터 형식에 따라 다릅니다.

값에 의한 전달과 참조에 의한 전달
숫자와 부울값(true와 false)는 값에 의한 전달로 복사, 전달, 비교됩니다. 값에 의한 전달로 복사 또는 전달하면 컴퓨터 메모리에 공간을 지정한 후 원래 값을 그 공간 안에 넣습니다. 그러고 나서 원본을 변경하더라도 두 항목은 별개의 것이기 때문에 복사본은 영향을 받지 않습니다. 반대의 경우도 마찬가지입니다.

대부분의 경우 개체, 배열 및 함수는 참조에 의한 전달로 복사, 전달, 비교됩니다. 값에 의한 전달로 복사 또는 전달하면 원래 항목에 대한 포인터를 만들어 그 포인터를 복사본처럼 사용합니다. 그러고 나서 원본을 변경하면 원본과 복사본이 모두 바뀝니다. 반대의 경우도 마찬가지입니다. 실제로 항목은 하나만 존재합니다. 즉 "복사본"은 실제로 복사본이 아니라 항목에 대한 또다른 참조일 뿐입니다.

참고 assign( ) 메서드를 사용하면 개체와 배열의 이런 동작을 변경할 수 있습니다.

마지막으로 문자열을 복사, 전달할 때는 참조에 의한 전달을 사용하지만 비교할 때는 값에 의한 전달을 사용합니다.

참고 ASCII와 ANSI 문자 집합의 구성 방식 때문에 대문자는 시퀀스 순서에서 소문자보다 앞에 옵니다. 예를 들어, "Zoo"는 "aardvark"보다 앞에 옵니다.

함수로 매개 변수 전달
값에 의한 전달로 함수에 매개 변수를 전달하면 함수 안에서만 존재하는 별도의 매개 변수 복사본을 만들게 됩니다. 이와는 달리 참조에 의한 전달로 함수에 매개 변수를 전달한 후 함수에서 해당 매개 변수의 값을 변경하면 스크립트 내의 모든 부분에서 해당 매개 변수의 값이 변경됩니다.
데이터 테스트
값에 의한 전달로 테스트를 수행할 때는 별개의 두 항목을 비교하여 서로 같은지 봅니다. 보통, 이 비교는 바이트를 단위로 하여 이루어집니다. 참조에 의한 전달로 비교할 때에는 두 항목이 한 원본 항목에 대한 포인터인지 봅니다. 두 항목이 한 원본 항목에 대한 포인터인 경우에는 두 항목이 같은 것으로 보고, 그렇지 않은 경우에는 비록 두 값이 바이트 단위로 비교하여 완전히 일치한다고 해도 서로 다른 것으로 봅니다.

문자열을 참조에 의한 전달로 복사, 전달하면 메모리를 절약할 수 있습니다. 그러나 일단 만든 문자열을 변경할 수 없기 때문에 값에 의한 전달로 문자열을 비교할 수 있습니다. 이렇게 하면 서로 완전히 독립적으로 생성된 두 문자열의 내용이 일치하는지 테스트할 수 있습니다.


배열 사용

배열 사용
         JScript 자습서
이전
다음

배열 인덱스
JScript의 배열은 융통성 이 있습니다. 즉, 어떤 배열의 요소가 세 개이고 인덱스 번호가 각각 0,1,2일 때 3에서 49까지 요소를 추가할 필요없이 인덱스 번호가 50인 요소를 만들 수 있다는 의미입니다. 이 배열에 자동 길이 변수가 있으면 그 길이 변수는 4가 아닌 51로 설정됩니다. 배열 길이 자동 조정에 대한 내용은 내부 개체를 참조하십시오. 물론 요소 번호를 지정할 때 건너뛰는 번호가 없는 배열을 만들 수 있지만 반드시 그렇게 해야 하는 것은 아닙니다. 실제로 JScript에서는 배열의 아래 첨자에 번호를 지정하지 않아도 됩니다.

JScript에서는 개체와 배열이 본질적으로 서로 동일합니다. 실질적인 차이점은 데이터에 있는 것이 아니라 배열의 구성원 또는 개체의 속성과 메서드에 주소를 지정하는 방식에 있습니다.

배열 주소 지정
배열 구성원의 주소를 지정하는 방식에는 크게 두 가지가 있습니다. 첫째, 대괄호를 사용하여 배열에 주소를 지정하는 방식을 많이 사용합니다. 대괄호 안에는 숫자 값이나 음수가 아닌 정수를 산출하는 식을 입력할 수 있습니다. 아래 예제는 entryNum 변수를 정의하고 스크립트의 다른 곳에서 그 값을 지정한 것을 전제로 하고 있습니다.
theListing = addressBook[entryNum];
theFirstLine = theListing[1];
이 방식은 개체의 주소를 지정하는 방식과 동일합니다. 단, 개체 주소를 지정할 때는 마침표 다음에 실제 속성 이름을 입력해야 합니다. 입력한 속성이 없을 경우 코드는 오류를 일으킵니다.

배열의 주소를 지정하는 둘째 방식은 번호가 지정되어 있는 속성을 가진 개체/배열을 만든 후 루프에서 그 번호를 생성하는 방식입니다. 아래 예제는 두 개의 배열을 생성합니다. 하나는 이름용이고 다른 하나는 주소용으로 이것은 주소록의 목록을 이용합니다. 각 배열에는 4가지 속성이 있습니다. 예를 들어 theListing의 [Name1]에서 [Name4]까지의 속성에 작성된 theName의 인스턴스는 "G." "Edward" "Heatherington" "IV" 또는 "George" "" "Sand" ""를 포함할 수 있습니다.

theListing = addressBook[entryNum];
for (i = 1; i < 4; i++)  {
theName[i] = theListing["Name" + i];
theAddress[i] = theListing["Address" + i];
}
이런 특정한 인스턴스는 짧기 때문에 "점"을 사용하는 표기법으로 쓸 수 있습니다.즉, theListing, theName, theAddress를 배열이 아닌 개체로 주소 지정) 을 할 수 있지만 이것이 항상 가능한 것은 아닙니다. 때로는 런타임 때까지 특정 속성이 존재하지 않을 수도 있으며 특정 속성이 어떤 속성이 될 것인지를 미리 알 수 없기도 합니다. 예를 들어, addressBook 배열을 번호가 지정되어 있는 목록 대신에 성으로 정렬하면 스크립트를 실행하면서 사람을 찾기 위해 "진행 중에" 이름을 입력할 수 있습니다.. 아래 예제는 스크립트 내의 어딘가에 적절한 함수 정의가 있다는 것을 전제합니다.
theListing = addressBook[getName()];
theIndivListing = theListing[getFirstName()];
이것은 연상식 주소 지정입니다. 즉 임의의 문자열을 사용하여 주소를 지정하는 것입니다. 실질적으로 JScript의 개체는 연상식 배열입니다. "점"을 사용하여 주소 지정을 할 수 있고, 또 그렇게 자주 지정하고 있음에도 불구하고 반드시 그 방식을 사용할 필요는 없습니다. 배열 표시로 JScript 개체의 구성원에 액세스할 수 있으므로 JScript 개체를 연상식 배열로 사용할 수 있습니다.

아래 코드는 가장 많이 사용되는 형식의 배열을 만들고 초기화합니다.

var myArray = new Array("Athens", "Belgrade", "Cairo");
이 배열의 각 요소는 요소 번호를 사용하여 주소가 지정됩니다(이 경우에는 0,1,2임). 이 배열은 for...in 문을 사용하여 0에서 시작하여 2에서 끝나는 반복을 수행할 수 있습니다. 예를 들어 다음과 같습니다.

for (key in myArray)
  response.write("Element value is " + MyArray[key] + "<BR>);
아래 코드는 요소 3개를 포함하는 연상식 배열을 만들고 초기화합니다.
var MyArray = {"a" : "Athens", "b" : "Belgrade", "c" : "Cairo" };
이 배열에서는 배열 요소 번호(0,1, 또는 2) 대신 키 문자열("a", "b", "c")을 사용하여 요소의 주소가 지정됩니다. 이것은 좀 더 직관적인 주소 지정 구성표를 지닌 배열을 만들어 사용할 수 있게 해줍니다. 위에서 예시한 for...in 문 코드 또한 이 배열을 반복 수행하는 데 사용할 수 있습니다.


고급 개체 만들기

고급 개체 작성
 JScript 자습서
이전
다음

구성자를 사용하여 개체 작성
Microsoft JScript에서는 구성자를 사용하여 개체 클래스를 만들 수 있습니다. new 문으로 구성자를 불러오며, 구성자는 문이 구성하는 모든 것을 반환합니다.

특별한 Function 구성자를 사용하면 익명의 함수를 만들 수 있습니다. 익명 함수는 이름이 없는 함수입니다. 예를 들어 다른 함수 내부에 있는 지시자의 하나로 Function 구성자를 사용하여 함수를 "진행 중에" 만들 수 있습니다. 이러한 함수는 한 위치에서만 사용되므로 이름이 필요없습니다.

아래 예제에서는 그러한 익명 함수가 "name-and-email-address" 목록을 한 줄로 작성합니다. 익명 함수는 firstNameFirst 변수 값을 검사하여 성과 이름 중에서 어느 것을 처음에 쓸 것인지 결정하고, emailNameFirst 변수 값을 검사하여 전자 메일 주소와 이름 중에서 어느 것을 먼저 쓸 것인지 결정합니다. 이 예제에서는 firstNameFirst 값과 emailNameFirst 값이 이미 다른 곳에서 설정되었다고 가정합니다.

for (j = 1; j < addressList[length]; j++)
{
oneListingLine = new Function(emailNameFirst, firstNameFirst, addressList, j, theName = new Function(firstNameFirst, addressList, j, var theName=(addressList[j].firstName + addressList[j].lastName);
if(firstNameFirst)
      {
      theName=(addressList[j].firstName + addressList[j].lastName);
      },) ;
if (emailNameFirst)
      {
theListing = addressList[j].emailName+ ":\t" + theName
      } else theListing = theName + ":\t" + addressList[j].emailName; return theListing;)
document.write(oneListingLine + "<br>");
}
구성자 쓰기
구성자를 직접 쓰려면 구성자 내에서 this 키워드를 사용하여 새로 만들어진 개체를 참조해야 합니다. 구성자는 개체를 초기화합니다.

다음 예제에서 구성자는 인덱스를 0에서 지정하지만 반드시 0에서 시작할 필요는 없습니다. 예를 들어 배열 인덱스나 개체 인덱스의 실제 번호를 가리키는 매개 변수를 원한다면 첫째 인덱스를 1로 지정할 수 있습니다. 이 예제에서는 내부 Array( ) 개체의 자동 유지 길이 매개 변수와 구별하기 위하여 이 매개 변수를 extent라고 합니다. 배열에 속성을 추가하는 코드를 쓰고 있다면 extent 매개 변수(또는 상당어구)를 업데이트해야 합니다. 왜냐하면 JScript에서는 이러한 매개 변수를 지원하지 않기 때문입니다. 이와 같이 매우 간단한 예제도 현재 개체를 참조하기 위하여 개체(점)와 배열(대괄호) 표시법을 사용합니다.

function MakeStringArray(length) {
this.extent = length;
for (iNum = 0; iNum < length; i++) {
this[iNum] = "";
}
}

// 구성자를 사용하여 배열을 만들고 초기화합니다.
myStringArray = new MakeStringArray(63);
초기 설정을 사용하여 개체 작성
개체를 정의할 때 prototype 속성을 사용하면 정의에 의해 만들어지는 모든 개체에 공통으로 유효한 속성을 만들 수 있습니다. prototype 속성들은 참조용으로 클래스의 각 개체로 복사됩니다. 따라서 prototype 속성들은 클래스의 모든 개체에 대해 같은 값을 가집니다. 그러나 사용자는 한 개체에서 prototype 속성 값을 변경할 수 있으며, 변경된 새로운 값은 기본값을 재정의합니다. 그러나 이러한 변경 사항은 해당 인스턴스에만 적용되므로 클래스의 구성원인 다른 개체는 변경으로 인한 영향을 받지 않습니다.

이러한 원칙을 사용하면 JScript 언어의 일부분인 개체, 즉 초기 설정을 가지고 있는 모든 개체에 대한 속성을 추가로 정의할 수 있습니다. 예를 들어 계산을 하기 위한 특별한 상수를 원하지만 Math 개체와 Number 개체에서 그 상수가 제공되지 않을 경우, 사용자는 스스로 상수를 정의하여 각각의 개체 초기 설정 또는 개체 클래스의 초기 설정 속성에 할당할 수 있습니다.

Math.prototype.Avogadro = 6.0232E23;
function howManyMolecules(wtGrams,molWt) {
return ((wtGrams/molWt)*Math.prototype.Avogadro);
}
document.write("There are " + howManyMolecules(window.prompt("How many grams?",0),window.prompt
("What's the molecular weight?",0)) +
 " molecules in that amount.");
좀 더 구체적으로 설명하면 사용자는 함수를 정의하여 해당 함수를 String.prototype에 메서드로 지정할 수 있으며 스크립트의 어떤 문자열에도 함수를 사용할 수 있습니다. 아래 예제에서는 스크립트의 다른 곳에서 정의된 "theElements"라는 주기율표 배열이 있다고 가정합니다. 물론 이러한 주기율표에는 원소 기호, 원소 이름, 원자량 및 기타 원소 관련 정보가 포함되어 있습니다.

function atomName(theSymbol) {
return(theElements[theSymbol].fullName);
}

String.prototype.atomName = atomName;

function decodeFormula(theFormula) {
var theCurrentPiece = "";
var theDecodedFormula = "";
for (i = 1; i = theFormula.length ; i++);
if (theFormtheCurrentPiece
// 수식 문자열을 기호와 숫자의 배열로 분리하는 코드문
// 수식 배열을 통한 루프와 해독 문자열 조립입니다. 각 항목은 다음과 같습니다.
theDecodedFormula += formula[n].number
theDecodedFormula += " ";
theDecodedFormula += formula[n].symbol.prototype.atomName;
theDecodedFormula += " "
//루프의 끝

return theDecodedFormula;
}

decodeFormula(window.prompt("수식?","Al2O3"));


특수 문자
 JScript 자습서
이전
다음

특수 문자
JScript는 특수 직접 입력할 수 없는 일부 문자를 문자열에 포함시킬 수 있는 특수 문자를 제공합니다. 각 특수 문자는 백슬래시로 시작합니다. 백슬래시는 다음 문자가 특수 문자임을 JScript 해석기에 알려주는 데 사용되는 제어 문자입니다.

제어 시퀀스 | 문자
\b | 백스페이스
\f | 용지 공급
\n | 줄 바꿈
\r | 캐리지 리턴
\t | 수평 탭(Ctrl-I)
\' 작은따옴표
\" 큰따옴표
\\ 백슬래시

백슬래시 자체는 제어 문자로 사용되므로 스크립트에서 직접 입력할 수 없습니다. 백슬래시를 사용하려면 두 번 입력해야 합니다(\\).

document.write('이미지 경로는 C:\\webstuff\\mypage\\gifs\\garden.gif입니다.');
document.write('캡션은 "After the snow of \'. Grandma\'s house is covered."입니다.');
이들 제어 시퀀스를 사용하면 <PRE> 태그와 <XMP> 태그 내부의 텍스트 서식을 제어할 수 있으며 내부 경고, 프롬프트 및 확인 메시지 상자 내부의 텍스트 서식도 어느 정도 제어할 수 있습니다.


스크립트 문제 해결

스크립트 문제 해결
 JScript 자습서
이전
다음

어떤 프로그래밍 언어에서나 주의하지 않으면 문제가 발생하는 경우가 반드시 있고, 언어마다 이런 경우가 다릅니다. null 값의 경우에도 Microsoft JScript에서 null 값은 C 또는 C++ 언어에서의 null 값과 다르게 작용합니다.

다음에 설명되어 있는 사항들은 JScript 스크립트를 작성하면서 겪게 되는 문제들입니다.

구문 오류
프로그래밍 언어의 구문은 일반 언어의 구문보다 훨씬 더 엄격하기 때문에 스크립트를 쓸 때는 세부 사항에도 주의를 기울이는 것이 중요합니다. 예를 들어 특정 매개 변수를 문자열로 만들려고 할 경우 매개 변수를 입력한 다음 해당 매개 변수를 따옴표로 묶는 것을 잊어버리면 구문 오류가 발생합니다.
스크립트 해석 순서
JScript 해석은 웹 브라우저가 수행하는 HTML 구문 분석 과정의 일부분입니다. 그러므로 문서의 <HEAD> 태그 내부에 스크립트를 두면 스크립트는 어떤 <BODY> 태그보다도 먼저 해석됩니다. <BODY> 태그에서 만들어진 개체들이 있을 경우 그러한 개체들은 <HEAD>가 구문 분석되고 있는 시간에는 존재하지 않으며 스크립트에 의해 다루어질 수 없습니다.
자동 형식 강제 변환
JScript는 자동적인 강제 변환이 가능한 비교적 자유로운 형식의 언어입니다. 따라서 아래 예제의 식에서 다른 형식을 가진 값들이 같지 않지만 결과는 true입니다.
"100" == 100
false == 0
연산자 우선 순위
특정 연산을 수행할 때 식 계산은 식의 위치보다 연산자 우선 순위와 더 깊은 관련이 있습니다. 따라서 아래 예제에서 뺄셈이 먼저 나와있지만 연산자 우선 순위에 따라 곱셈이 뺄셈보다 먼저 수행됩니다.
theRadius = aPerimeterPoint - theCenterpoint * theCorrectionFactor;
개체와 for...in 루프를 함께 사용
for...in 루프를 사용하여 개체의 속성을 단계적으로 작업할 경우 개체 필드가 루프 카운터 변수에 지정되는 순서를 예상하거나 제어할 필요는 없습니다. 게다가 다른 언어 구현에서는 그 순서가 달라질 수도 있습니다.
with 키워드
with 문은 지정된 개체에 이미 존재하는 속성을 처리하는 데는 편리하지만, 속성을 개체에 추가하는 데 사용할 수 는 없습니다. 개체에서 새로운 속성을 만들려면 개체를 구체적으로 참조해야 합니다.
this 키워드
개체 자체를 참조하기 위하여 개체 정의의 내부에서 this 키워드를 사용할 수 있지만, 해당 함수가 개체 정의가 아닐 경우 일반적으로 this 키워드 또는 이와 유사한 키워드를 사용하여 현재 실행되고 있는 함수를 참조할 수 없습니다. 함수를 하나의 메서드로 개체에 지정하면 개체를 참조하기 위하여 this 키워드를 함수 내부에서 사용할 수 있습니다.
스크립트를 작성하는 스크립트 쓰기
"해석기가 </SCRIPT> 태그와 마주치게 되면 이 태그는 현재의 스크립트를 종료시킵니다. </SCRIPT> 자체를 나타내려면 이것을 "</SCR"과 "IPT>"와 같이 2개 이상의 문자열로 다시 쓰십시오. 그러면 이 문자열을 사용하는 문에서 2개의 문자열 "</SCR"과 "IPT>"을 연결할 수 있습니다.
함축적인 창 참조
창은 동시에 두 개 이상 열릴 수 있기 때문에 명시적으로 창 참조를 나타내지 않는 한 모두 현재의 창을 가리키게 됩니다. 현재의 창이 아닌 다른 창에 대해서는 명시적 참조를 사용해야 합니다.


브라우저에 정보 표시

브라우저에 정보 표시
JScript 자습서
이전
다음

Microsoft JScript에는 브라우저에 데이터를 직접 표시하는 방법이 두 가지 있습니다. 사용자는 document 개체의 write( )와 writeln( ) 메서드를 사용할 수 있습니다. 또한 형식을 갖춘 정보를 브라우저 안의 폼에 표시할 수 있을 뿐만 아니라 경고, 프롬프트, 확인 메시지 상자에도 표시할 수 있습니다.
document.write( )와 document.writeln( ) 사용
정보를 표시하는 데 가장 많이 사용하는 방법은 document 개체의 write( ) 메서드를 사용하는 것입니다. 여기에는 브라우저에 표시할 인수 한 개, 즉 문자열 한 개가 필요합니다. 이 문자열은 일반 텍스트이거나 HTML입니다.

문자열은 작은따옴표나 큰따옴표로 묶을 수 있습니다. 이렇게 하면 따옴표나 아포스트로피를 포함하는 내용을 인용할 수 있습니다.

document.write("파이 값은 약 " + Math.PI);
document.write( );

팁 아래 나오는 간단한 함수는 브라우저 창에 표시할 내용이 있을 때마다 "document.write"를 입력해야 하는 방법을 보여줍니다. 이 함수는 사용자가 쓰려는 것이 정의되지 않았는지 여부를 알려주지는 않지만 "w();" 명령을 수행할 수는 있습니다. "w();" 명령은 빈 줄을 표시합니다.
function w(m)  {		// 함수를 씁니다.
m = "" + m + "";        //  m 변수가 문자열임을 확인합니다.
if ("undefined" != m)  {        //  빈 내용이나 정의되지 않은 항목을 테스트합니다.
    document.write(m);
    }
document.write("<br>");
}

w('<IMG SRC="horse.gif">');
w();
w("이것은 말을 새긴 것입니다.");
w();

writeln( ) 메서드는 write( ) 메서드와 거의 동일하지만 모든 문자열에 줄 바꿈 문자를 추가한다는 점이 write( ) 메서드와 다릅니다. HTML에서는 일반적으로 항목 뒤에 공백이 생길 뿐이지만 <PRE> 태그와 <XMP> 태그를 사용하는 경우에는 줄 바꿈 문자를 그대로 해석하여 브라우저에 표시합니다.

write( ) 메서드를 호출할 경우 문서가 열려서 구문 분석되고 있지 않으면 write( ) 메서드는 문서를 열고 내용을 지우기 때문에 위험합니다. 아래 예제는 1분마다 시간을 표시하려고 만들었지만 처리 도중에 지워져 처음에만 실행되는 스크립트입니다.

<HTML>
<HEAD>
<SCRIPT LANGUAGE="JScript">
function singOut()  {
var theMoment = new Date();
var theHour = theMoment.getHours();
var theMinute = theMoment.getMinutes();
var theDisplacement = (theMoment.getTimezoneOffset() / 60);
theHour -= theDisplacement;
if (theHour > 23)  {
theHour -= 24
}
document.write(theHour + " hours, " + theMinute + " minutes, Coordinated Universal Time.");
window.setTimeout("singOut();", 60000);
}
</SCRIPT>
</HEAD>
<BODY>
<SCRIPT>
singOut();
</SCRIPT>
</BODY>
</HTML>
document.write() 대신 창 개체의 alert() 메서드를 사용할 경우 이 스크립트는 정상적으로 사용됩니다.
window.alert(theHour + " hours, " + theMinute + " minutes, Coordinated Universal Time.");
window.setTimeout("singOut();", 60000);
}
현재 문서 지우기
document 개체의 clear() 메서드는 현재 문서를 지웁니다. 이 메서드는 문서의 나머지 부분과 함께 스크립트도 지우기 때문에 주의를 기울여 사용해야 합니다.
document.clear();


메시지 상자 사용

메시지 상자 사용
 JScript 자습서
이전

경고, 프롬프트 및 확인 메시지 상자 사용
사용자가 입력한 값을 받아들이기 위하여 경고, 확인 및 프롬프트 메시지 상자를 사용합니다. 이 상자들은 인터페이스 window 개체의 메서드들입니다. window 개체는 개체 계층 구조의 맨 위에 있으므로 실제로 "window.alert()"처럼 이 메시지 상자들의 전체 이름을 사용할 필요는 없습니다. 그러나 메시지 상자가 어느 개체에 속하는지를 기억하는 데 도움이 되므로 전체 이름을 사용하는 것이 좋습니다.

경고 메시지 상자
경고 메서드는 한 개의 인수를 가집니다. 이 인수는 사용자에게 보여주려는 텍스트 문자열이며, HTML이 아닙니다. 경고 메시지 상자에는 확인 단추가 있어 사용자가 메시지 상자를 닫을 수 있습니다. 그리고 이 상자는 모달이므로 작업을 계속하려면 메시지 상자를 닫아야 합니다.
window.alert("환영합니다! 계속하려면 확인을 누르십시오.");
확인 메시지 상자
확인 메시지 상자는 사용자가 "예 또는 아니오"로 대답할 수 있도록 질문하고 사용자는 확인 단추 또는 취소 단추를 누르면 됩니다. confirm 메서드는 true 또는 false 중 하나를 반환합니다. 이 메시지 상자 역시 모달입니다. 사용자는 반드시 메시지 상자에 응답해야 하며(어느 단추든 눌러야 함), 상자를 닫은 후에야 작업을 계속할 수 있습니다.
var truthBeTold = window.confirm("계속하려면 확인을 누르고 중지하려면 취소를 누르십시오.");
if (truthBeTold) {
window.alert("웹 페이지에 오신 것을 환영합니다!");
}  else  window.alert("안녕히 계십시오!");
프롬프트 메시지 상자
프롬프트 메시지 상자는 프롬프트에 대한 답변을 입력할 수 있는 텍스트 필드를 제공합니다. 이 메시지 상자에는 확인 단추와 취소 단추가 있습니다. 사용자가 둘째 문자열 인수를 입력하면 프롬프트 메시지 상자는 텍스트 필드에 둘째 문자열을 기본 응답으로 표시합니다. 그렇지 않으면 기본 텍스트는 "<undefined>"입니다.

alert( ) 메서드 및 confirm( ) 메서드와 같이 prompt 메서드는 모달이므로, 작업을 계속하려면 프롬프트 메시지 상자를 닫아야 합니다.

var theResponse = window.prompt("환영합니다!" "여기에 이름을 입력하십시오.");


Scripting 런타임 라이브러리 참조

Scripting 런타임 라이브러리 참조 		언어 참조
버전 정보

기능 정보

키워드 목록(사전순)

메서드

개체

속성

Scripting 런타임 라이브러리 참조 시작

여기에 요약된 내용들을 활용하면 Scripting 런타임 라이브러리의 여러 부분을 쉽게 찾아볼 수 있습니다.

키워드 목록(사전순)에서는 Scripting 런타임 라이브러리의 모든 부분을 사전순으로 볼 수 있고, 개체 등 개별 항목에 대한 자세한 내용을 보려면 해당 범주를 선택하면 됩니다.

왼쪽에 있는 항목 중 하나를 누르면 해당 범주에 포함된 항목의 목록이 나타납니다. 그 목록에서 원하는 항목을 선택하십시오. 항목을 열면 관련된 다른 영역으로 쉽게 이동할 수 있습니다.

계속 살펴보면서 각 문의 사용법을 익히고, 메서드를 연구하고, 함수를 풀어 나가면 Scripting 런타임 라이브러리의 다양한 기능을 경험할 수 있을 것입니다.

기능 | 설명
Microsoft Scripting 런타임 기능 | Microsoft Scripting 런타임 라이브러리의 최신 기능 목록
언어 요소 | 설명
Add 메서드(Dictionary) | Dictionary 개체에 키-항목 쌍을 추가합니다.
Add 메서드(Folders) | Folders 컬렉션에 새 Folder를 추가합니다.
AtEndOfLine 속성 | TextStream 파일의 줄 끝 표식 바로 앞에 파일 포인터가 있으면 true를, 그렇지 않으면 false를 반환합니다.
AtEndOfStream 속성 | TextStream 파일의 끝에 파일 포인터가 있으면 true를, 그렇지 않으면 false를 반환합니다.
Attributes 속성 | 파일이나 폴더의 특성을 설정하거나 반환합니다.
AvailableSpace 속성 | 지정한 드라이브나 네트워크 공유 영역에서 사용자가 사용할 수 있는 공간의 크기를 반환합니다.
BuildPath 메서드 | 기존 경로에 이름을 추가합니다.
Close 메서드 | 열려있는 TextStream 파일을 닫습니다.
Column 속성 | TextStream 파일에서 현재 문자가 있는 위치의 열 번호를 반환합니다.
CompareMode 속성 | Dictionary 개체의 문자열 키를 비교하기 위한 비교 모드를 설정하고 반환합니다.
Copy 메서드 | 지정한 파일이나 폴더를 기존 위치에서 다른 위치로 복사합니다.
CopyFile 메서드 | 하나 이상의 파일을 기존 위치에서 다른 위치로 복사합니다.
CopyFolder 메서드 | 폴더를 기존 위치에서 다른 위치로 반복 복사합니다.
Count 속성 | 컬렉션이나 Dictionary 개체의 항목 수를 반환합니다.
CreateFolder 메서드 | 폴더를 만듭니다.
CreateTextFile 메서드 | 지정한 파일 이름을 만들고 그 파일을 읽거나 쓰는 데 사용할 수 있는 TextStream 개체를 반환합니다.
DateCreated 속성 | 지정한 파일이나 폴더가 만들어진 날짜와 시간을 반환합니다.
DateLastAccessed 속성 | 지정한 파일이나 폴더에 마지막으로 액세스한 날짜와 시간을 반환합니다.
DateLastModified 속성 | 지정한 파일이나 폴더를 마지막으로 수정한 날짜와 시간을 반환합니다.
Delete 메서드 | 지정한 파일이나 폴더를 삭제합니다.
DeleteFile 메서드 | 지정한 파일을 삭제합니다.
DeleteFolder 메서드 | 지정한 폴더와 그 내용을 삭제합니다.
Dictionary 개체 | 데이터 키-항목 쌍을 저장하는 개체입니다.
Drive 개체 | 특정 디스크 드라이브나 네트워크 공유 속성에 액세스할 수 있습니다.
Drive 속성 | 지정한 파일이나 폴더가 있는 드라이브의 드라이브 문자를 반환합니다.
DriveExists 메서드 | 지정한 드라이브가 있으면 true를, 그렇지 않으면 false를 반환합니다.
DriveLetter 속성 | 실제 로컬 드라이브나 네트워크 공유 영역의 드라이브 문자를 반환합니다.
Drives 컬렉션 | 사용할 수 있는 모든 드라이브의 읽기 전용 컬렉션입니다.
Drives 속성 | 로컬 컴퓨터에서 사용할 수 있는 모든 Drive 개체로 구성된 Drives 컬렉션을 반환합니다.
DriveType 속성 | 지정한 드라이브의 형식을 나타내는 값을 반환합니다.
Exists 메서드 | Dictionary 개체에 지정한 키가 있으면 true를, 그렇지 않으면 false를 반환합니다.
File 개체 | 파일의 모든 속성에 액세스할 수 있습니다.
FileExists 메서드 | 지정한 파일이 있으면 true를, 그렇지 않으면 false를 반환합니다.
Files 컬렉션 | 폴더 안에 있는 모든 File 개체의 컬렉션입니다.
Files 속성 | 지정한 폴더에 포함되어 있는 모든 File 개체(숨김 특성과 시스템 파일 속성이 설정되어 있는 것 포함)로 구성된 Files 컬렉션을 반환합니다.
FileSystemObject 개체 | 컴퓨터의 파일 시스템에 액세스할 수 있습니다.
FileSystem 속성 | 지정한 드라이브에서 사용하는 파일 시스템의 형식을 반환합니다.
Folder 개체 | 폴더의 모든 속성에 액세스할 수 있습니다.
Folders 컬렉션 | Folder 안에 있는 모든 Folder 개체의 컬렉션입니다.
FolderExists 메서드 | 지정한 폴더가 있으면 true를, 그렇지 않으면 false를 반환합니다.
FreeSpace 속성 | 지정한 드라이브나 네트워크 공유 영역에서 사용할 수 있는 사용 가능한 공간의 크기를 반환합니다.
GetAbsolutePathName 메서드 | 주어진 경로에서 정확한 전체 경로를 반환합니다.
GetBaseName 메서드 | 주어진 경로에서 파일의 기본 이름(모든 파일 확장명 제외)이나 폴더를 포함한 문자열을 반환합니다.
GetDrive 메서드 | 지정한 경로에서 드라이브에 해당하는 Drive 개체를 반환합니다.
GetDriveName 메서드 | 지정한 경로에서 드라이브 이름을 포함한 문자열을 반환합니다.
GetExtensionName 메서드 | 경로의 마지막 구성 요소에 해당하는 확장명 이름을 포함한 문자열을 반환합니다.
GetFile 메서드 | 지정한 경로에서 파일에 해당하는 File 개체를 반환합니다.
GetFileName 메서드 | 드라이브 정보의 일부분이 아닌 지정한 경로에서 마지막 파일 이름이나 폴더를 반환합니다.
GetFileVersion 메서드 | 지정한 파일의 버전 번호를 반환합니다.
GetFolder 메서드 | 지정한 경로에서 폴더에 해당하는 Folder 개체를 반환합니다.
GetParentFolderName 메서드 | 지정한 경로에서 마지막 파일이나 폴더의 상위 폴더 이름을 포함한 문자열을 반환합니다.
GetSpecialFolder 메서드 | 지정한 특정 폴더를 반환합니다.
GetTempName 메서드 | 임의로 만든 임시 파일이나 폴더 이름을 반환합니다.
IsReady 속성 | 지정한 드라이브가 준비되면 true를, 그렇지 않으면 false를 반환합니다.
IsRootFolder 속성 | 지정한 폴더가 루트 폴더이면 true를, 그렇지 않으면 false를 반환합니다.
Item 속성 | Dictionary 개체에서 지정한 key에 해당하는 item을 설정하거나 반환합니다.
Items 메서드 | Dictionary 개체의 항목을 모두 포함한 배열을 반환합니다.
Key 속성 | Dictionary 개체에 key를 설정합니다.
Keys 메서드 | Dictionary 개체의 기존 키를 모두 포함한 배열을 반환합니다.
Line 속성 | TextStream 파일에서 현재 줄 번호를 반환합니다.
Move 메서드 | 지정한 파일이나 폴더를 기존 위치에서 다른 위치로 옮깁니다.
MoveFile 메서드 | 하나 이상의 파일을 기존 위치에서 다른 위치로 옮깁니다.
MoveFolder 메서드 | 하나 이상의 폴더를 기존 위치에서 다른 위치로 옮깁니다.
Name 속성 | 지정한 파일이나 폴더의 이름을 설정하거나 반환합니다.
OpenAsTextStream 메서드 | 지정한 파일을 열고 그 파일을 읽거나, 쓰거나, 추가하는 데 사용할 수 있는 TextStream 개체를 반환합니다.
OpenTextFile 메서드 | 지정한 파일을 열고 그 파일에서 읽거나, 쓰거나, 추가하는 데 사용할 수 있는 TextStream 개체를 반환합니다.
ParentFolder 속성 | 지정한 파일이나 폴더의 상위 폴더에 해당하는 Folder 개체를 반환합니다.
Path 속성 | 지정한 파일, 폴더, 또는 드라이브의 경로를 반환합니다.
Read 메서드 | TextStream 파일에서 지정한 수만큼 문자를 읽고 결과로 나오는 문자열을 반환합니다.
ReadAll 메서드 | TextStream 파일 전체를 읽고 결과로 나오는 문자열을 반환합니다.
ReadLine 메서드 | TextStream 파일에서 줄 전체(줄 바꿈 문자 앞까지, 줄 바꿈 문자는 제외)를 읽고 결과로 나오는 문자열을 반환합니다.
Remove 메서드 | Dictionary 개체에서 키-항목 쌍을 하나 제거합니다.
RemoveAll 메서드 | Dictionary 개체에서 키-항목 쌍을 모두 제거합니다.
RootFolder 속성 | 지정한 드라이브의 루트 폴더를 나타내는 Folder 개체를 반환합니다.
SerialNumber 속성 | 디스크 볼륨을 고유하게 나타내는 데 사용하는 일련 번호를 십진수로 반환합니다.
ShareName 속성 | 지정한 드라이브의 네트워크 공유 이름을 반환합니다.
ShortName 속성 | 예전 8.3 명명 규칙을 따르는 프로그램에서 사용되는 짧은 이름을 반환합니다.
ShortPath 속성 | 예전 8.3 파일 명명 규칙을 따르는 프로그램에서 사용되는 짧은 경로를 반환합니다.
Size 속성 | 지정한 파일이나 폴더의 크기를 바이트 단위로 반환합니다.
Skip 메서드 | TextStream 파일을 읽을 때 지정한 문자 수만큼 건너뜁니다.
SkipLine 메서드 | TextStream 파일을 읽을 때 다음 줄을 건너뜁니다.
SubFolders 속성 | 지정한 폴더에 포함되어 있는 모든 폴더(숨김 특성과 시스템 파일 특성이 설정되어 있는 것 포함)로 구성된 Folders 컬렉션을 반환합니다.
TextStream 개체 | 파일에 순차적으로 쉽게 액세스합니다.
TotalSize 속성 | 드라이브나 네트워크 공유 영역의 전체 공간을 바이트 단위로 반환합니다.
Type 속성 | 파일이나 폴더의 형식에 관한 정보를 반환합니다.
VolumeName 속성 | 지정한 드라이브의 볼륨 이름을 설정하거나 반환합니다.
Write 메서드 | TextStream 파일에 지정한 문자열을 씁니다.
WriteBlankLines 메서드 | TextStream 파일에 지정한 수만큼 줄 바꿈 문자를 씁니다.
WriteLine 메서드 | TextStream 파일에 지정한 문자열과 줄 바꿈 문자를 씁니다.
언어 요소 | 설명
Add 메서드(Dictionary) | Dictionary 개체에 키-항목 쌍을 추가합니다.
Add 메서드(Folders) | Folders 컬렉션에 새 Folder를 추가합니다.
BuildPath 메서드 | 기존 경로에 이름을 추가합니다.
Close 메서드 | 열려있는 TextStream 파일을 닫습니다.
Copy 메서드 | 지정한 파일이나 폴더를 기존 위치에서 다른 위치로 복사합니다.
CopyFile 메서드 | 하나 이상의 파일을 기존 위치에서 다른 위치로 복사합니다.
CopyFolder 메서드 | 폴더를 기존 위치에서 다른 위치로 반복 복사합니다.
CreateFolder 메서드 | 폴더를 만듭니다.
CreateTextFile 메서드 | 지정한 파일 이름을 만들고 그 파일을 읽거나 쓰는 데 사용할 수 있는 TextStream 개체를 반환합니다.
Delete 메서드 | 지정한 파일이나 폴더를 삭제합니다.
DeleteFile 메서드 | 지정한 파일을 삭제합니다.
DeleteFolder 메서드 | 지정한 폴더와 그 내용을 삭제합니다.
DriveExists 메서드 | 지정한 드라이브가 있으면 true를, 그렇지 않으면 false를 반환합니다.
Exists 메서드 | Dictionary 개체에 지정한 키가 있으면 true를, 없으면 false를 반환합니다.
FileExists 메서드 | 지정한 파일이 있으면 true를, 그렇지 않으면 false를 반환합니다.
FolderExists 메서드 | 지정한 폴더가 있으면 true를, 그렇지 않으면 false를 반환합니다.
GetAbsolutePathName 메서드 | 주어진 경로에서 정확한 전체 경로를 반환합니다.
GetBaseName 메서드 | 주어진 경로에서 파일의 기본 이름(모든 파일 확장명 제외)이나 폴더를 포함한 문자열을 반환합니다.
GetDrive 메서드 | 지정한 경로에서 드라이브에 해당하는 Drive 개체를 반환합니다.
GetDriveName 메서드 | 지정한 경로에서 드라이브 이름을 포함한 문자열을 반환합니다.
GetExtensionName 메서드 | 경로의 마지막 구성 요소에 해당하는 확장명 이름을 포함한 문자열을 반환합니다.
GetFile 메서드 | 지정한 경로에서 파일에 해당하는 File 개체를 반환합니다.
GetFileName 메서드 | 드라이브 정보의 일부분이 아닌 지정한 경로에서 마지막 파일 이름이나 폴더를 반환합니다.
GetFileVersion 메서드 | 지정한 파일의 버전 번호를 반환합니다.
GetFolder 메서드 | 지정한 경로에서 폴더에 해당하는 Folder 개체를 반환합니다.
GetParentFolderName 메서드 | 지정한 경로에서 마지막 파일이나 폴더의 상위 폴더 이름을 포함한 문자열을 반환합니다.
GetSpecialFolder 메서드 | 지정한 특정 폴더를 반환합니다.
GetTempName 메서드 | 임의로 만든 임시 파일이나 폴더 이름을 반환합니다.
Items 메서드 | Dictionary 개체의 항목을 모두 포함한 배열을 반환합니다.
Keys 메서드 | Dictionary 개체의 기존 키를 모두 포함한 배열을 반환합니다.
Move 메서드 | 지정한 파일이나 폴더를 기존 위치에서 다른 위치로 옮깁니다.
MoveFile 메서드 | 하나 이상의 파일을 기존 위치에서 다른 위치로 옮깁니다.
MoveFolder 메서드 | 하나 이상의 폴더를 기존 위치에서 다른 위치로 옮깁니다.
OpenAsTextStream 메서드 | 지정한 파일을 열고 그 파일을 읽거나, 쓰거나, 추가하는 데 사용할 수 있는 TextStream 개체를 반환합니다.
OpenTextFile 메서드 | 지정한 파일을 열고 그 파일에서 읽거나, 쓰거나, 추가하는 데 사용할 수 있는 TextStream 개체를 반환합니다.
Read 메서드 | TextStream 파일에서 지정한 수만큼 문자를 읽고 결과로 나오는 문자열을 반환합니다.
ReadAll 메서드 | TextStream 파일 전체를 읽고 결과로 나오는 문자열을 반환합니다.
ReadLine 메서드 | TextStream 파일에서 줄 전체(줄 바꿈 문자 앞까지, 줄 바꿈 문자는 제외)를 읽고 결과로 나오는 문자열을 반환합니다.
Remove 메서드 | Dictionary 개체에서 키-항목 쌍을 하나 제거합니다.
RemoveAll 메서드 | Dictionary 개체에서 키-항목 쌍을 모두 제거합니다.
Skip 메서드 | TextStream 파일을 읽을 때 지정한 문자 수만큼 건너뜁니다.
SkipLine 메서드 | TextStream 파일을 읽을 때 다음 줄을 건너뜁니다.
Write 메서드 | TextStream 파일에 지정한 문자열을 씁니다.
WriteBlankLines 메서드 | TextStream 파일에 지정한 수만큼 줄 바꿈 문자를 씁니다.
WriteLine 메서드 | TextStream 파일에 지정한 문자열과 줄 바꿈 문자를 씁니다.
언어 요소 | 설명
Dictionary 개체 | 데이터 키-항목 쌍을 저장하는 개체입니다.
Drive 개체 | 특정 디스크 드라이브나 네트워크 공유 속성에 액세스할 수 있습니다.
Drives 컬렉션 | 사용할 수 있는 모든 드라이브의 읽기 전용 컬렉션입니다.
File 개체 | 파일의 모든 속성에 액세스할 수 있습니다.
Files 컬렉션 | 폴더 안에 있는 모든 File 개체의 컬렉션입니다.
FileSystemObject 개체 | 컴퓨터의 파일 시스템에 액세스할 수 있습니다.
Folder 개체 | 폴더의 모든 속성에 액세스할 수 있습니다.
Folders 컬렉션 | Folder 안에 있는 모든 Folder 개체의 컬렉션입니다.
TextStream 개체 | 파일에 순차적으로 쉽게 액세스합니다.
언어 요소 | 설명
AtEndOfLine 속성 | TextStream 파일의 줄 끝 표식 바로 앞에 파일 포인터가 있으면 true를, 그렇지 않으면 false를 반환합니다.
AtEndOfStream 속성 | TextStream 파일의 끝에 파일 포인터가 있으면 true를, 그렇지 않으면 false를 반환합니다.
Attributes 속성 | 파일이나 폴더의 특성을 설정하거나 반환합니다.
AvailableSpace 속성 | 지정한 드라이브나 네트워크 공유 영역에서 사용자가 사용할 수 있는 공간의 크기를 반환합니다.
Column 속성 | TextStream 파일에서 현재 문자가 있는 위치의 열 번호를 반환합니다.
CompareMode 속성 | Dictionary 개체의 문자열 키를 비교하기 위한 비교 모드를 설정하고 반환합니다.
Count 속성 | 컬렉션이나 Dictionary 개체의 항목 수를 반환합니다.
DateCreated 속성 | 지정한 파일이나 폴더가 만들어진 날짜와 시간을 반환합니다.
DateLastAccessed 속성 | 지정한 파일이나 폴더에 마지막으로 액세스한 날짜와 시간을 반환합니다.
DateLastModified 속성 | 지정한 파일이나 폴더를 마지막으로 수정한 날짜와 시간을 반환합니다.
Drive 속성 | 지정한 파일이나 폴더가 있는 드라이브의 드라이브 문자를 반환합니다.
DriveLetter 속성 | 실제 로컬 드라이브나 네트워크 공유 영역의 드라이브 문자를 반환합니다.
Drives 속성 | 로컬 컴퓨터에서 사용할 수 있는 모든 Drive 개체로 구성된 Drives 컬렉션을 반환합니다.
DriveType 속성 | 지정한 드라이브의 형식을 나타내는 값을 반환합니다.
Files 속성 | 지정한 폴더에 포함되어 있는 모든 File 개체(숨김 특성과 시스템 파일 특성이 설정되어 있는 것 포함)로 구성된 Files 컬렉션을 반환합니다.
FileSystem 속성 | 지정한 드라이브에서 사용하는 파일 시스템의 형식을 반환합니다.
FreeSpace 속성 | 지정한 드라이브나 네트워크 공유 영역에서 사용자가 사용할 수 있는 사용 가능한 공간의 크기를 반환합니다.
IsReady 속성 | 지정한 드라이브가 준비되면 true를, 그렇지 않으면 false를 반환합니다.
IsRootFolder 속성 | 지정한 폴더가 루트 폴더이면 true를, 그렇지 않으면 false를 반환합니다.
Item 속성 | Dictionary 개체에서 지정한 key에 해당하는 item을 설정하거나 반환합니다.
Key 속성 | Dictionary 개체에 key를 설정합니다.
Line 속성 | TextStream 파일에서 현재 줄 번호를 반환합니다.
Name 속성 | 지정한 파일이나 폴더의 이름을 설정하거나 반환합니다.
ParentFolder 속성 | 지정한 파일이나 폴더의 상위 폴더에 해당하는 Folder 개체를 반환합니다.
Path 속성 | 지정한 파일, 폴더, 또는 드라이브의 경로를 반환합니다.
RootFolder 속성 | 지정한 드라이브의 루트 폴더를 나타내는 Folder 개체를 반환합니다.
SerialNumber 속성 | 디스크 볼륨을 고유하게 나타내는 데 사용하는 일련 번호를 십진수로 반환합니다.
ShareName 속성 | 지정한 드라이브의 네트워크 공유 이름을 반환합니다.
ShortName 속성 | 예전 8.3 명명 규칙을 따르는 프로그램에서 사용되는 짧은 이름을 반환합니다.
ShortPath 속성 | 예전 8.3 파일 명명 규칙을 따르는 프로그램에서 사용되는 짧은 경로를 반환합니다.
Size 속성 | 지정한 파일이나 폴더의 크기를 바이트 단위로 반환합니다.
SubFolders 속성 | 지정한 폴더에 포함되어 있는 모든 폴더(숨김 특성과 시스템 파일 특성이 설정되어 있는 것 포함)로 구성된 Folders 컬렉션을 반환합니다.
TotalSize 속성 | 드라이브나 네트워크 공유 영역의 전체 공간을 바이트 단위로 반환합니다.
Type 속성 | 파일이나 폴더의 형식에 관한 정보를 반환합니다.
VolumeName 속성 | 지정한 드라이브의 볼륨 이름을 설정하거나 반환합니다.

©1999 Microsoft Corporation. All rights reserved.


기능 정보

기능 정보 		Scripting 런타임 라이브러리 참조
버전 정보

Microsoft Scripting 런타임 기능


키워드 목록(사전순)

키워드 목록(사전순) 		Scripting 런타임 라이브러리 참조
버전 정보

Add 메서드(Dictionary)
Add 메서드(Folders)
AtEndOfLine 속성
AtEndOfStream 속성
Attributes 속성
AvailableSpace 속성
BuildPath 메서드
Close 메서드
Column 속성
CompareMode 속성
Copy 메서드
CopyFile 메서드
CopyFolder 메서드
Count 속성
CreateFolder 메서드
CreateTextFile 메서드
DateCreated 속성
DateLastAccessed 속성
DateLastModified 속성
Delete 메서드
DeleteFile 메서드
DeleteFolder 메서드
Dictionary 개체
Drive 개체
Drive 속성
DriveExists 메서드
DriveLetter 속성
Drives 컬렉션
Drives 속성
DriveType 속성
Exists 메서드
File 개체
FileExists 메서드
Files 컬렉션
Files 속성
FileSystem 속성
FileSystemObject 개체
Folder 개체
FolderExists 메서드
Folders 컬렉션
FreeSpace 속성
GetAbsolutePathName 메서드
GetBaseName 메서드
GetDrive 메서드
GetDriveName 메서드
GetExtensionName 메서드
GetFile 메서드
GetFileName 메서드
GetFolder 메서드
GetParentFolderName 메서드
GetSpecialFolder 메서드
GetTempName 메서드
IsReady 속성
IsRootFolder 속성
Item 속성
Items 메서드
Key 속성
Keys 메서드
Line 속성
Move 메서드
MoveFile 메서드
MoveFolder 메서드
Name 속성
OpenAsTextStream 메서드
OpenTextFile 메서드
ParentFolder 속성
Path 속성
Read 메서드
ReadAll 메서드
ReadLine 메서드
Remove 메서드
RemoveAll 메서드
RootFolder 속성
SerialNumber 속성
ShareName 속성
ShortName 속성
ShortPath 속성
Size 속성
Skip 메서드
SkipLine 메서드
SubFolders 속성
TextStream 개체
TotalSize 속성
Type 속성
VolumeName 속성
Write 메서드
WriteBlankLines 메서드
WriteLine 메서드


메서드

메서드 		Scripting 런타임 라이브러리 참조
버전 정보

Add 메서드(Dictionary)
Add 메서드(Folders)
BuildPath 메서드
Close 메서드
Copy 메서드
CopyFile 메서드
CopyFolder 메서드
CreateFolder 메서드
CreateTextFile 메서드
Delete 메서드
DeleteFile 메서드
DeleteFolder 메서드
DriveExists 메서드
Exists 메서드
FileExists 메서드
FolderExists 메서드
GetAbsolutePathName 메서드
GetBaseName 메서드
GetDrive 메서드
GetDriveName 메서드
GetExtensionName 메서드
GetFile 메서드
GetFileName 메서드
GetFolder 메서드
GetParentFolderName 메서드
GetSpecialFolder 메서드
GetTempName 메서드
Items 메서드
Keys 메서드
Move 메서드
MoveFile 메서드
MoveFolder 메서드
OpenAsTextStream 메서드
OpenTextFile 메서드
Read 메서드
ReadAll 메서드
ReadLine 메서드
Remove 메서드
RemoveAll 메서드
Skip 메서드
SkipLine 메서드
Write 메서드
WriteBlankLines 메서드
WriteLine 메서드


개체

개체 		Scripting 런타임 라이브러리 참조
버전 정보

Dictionary 개체
Drive 개체
Drives 컬렉션
File 개체
Files 컬렉션
FileSystemObject 개체
Folder 개체
Folders 컬렉션
TextStream 개체


속성

속성 		Scripting 런타임 라이브러리 참조
버전 정보

AtEndOfLine 속성
AtEndOfStream 속성
Attributes 속성
AvailableSpace 속성
Column 속성
CompareMode 속성
Count 속성
DateCreated 속성
DateLastAccessed 속성
DateLastModified 속성
Drive 속성
DriveLetter 속성
Drives 속성
DriveType 속성
Files 속성
FileSystem 속성
FreeSpace 속성
IsReady 속성
IsRootFolder 속성
Item 속성
Key 속성
Line 속성
Name 속성
ParentFolder 속성
Path 속성
RootFolder 속성
SerialNumber 속성
ShareName 속성
ShortName 속성
ShortPath 속성
Size 속성
SubFolders 속성
TotalSize 속성
Type 속성
VolumeName 속성


JScript 자습서

Microsoft® JScript™
FileSystemObject 개체 자습서
 Scripting 런타임 라이브러리 참조


Microsoft® Scripting 라이브러리 - FileSystemObject 개체

Microsoft® Scripting Library - FileSystemObject
FileSystemObject 개체 모델
 다음

Active Server Pages, Windows Scripting Host, 또는 스크립팅을 사용할 수 있는 다른 응용 프로그램에서 스크립트를 쓸 경우 웹 서버 상에서 폴더(디렉터리)와 파일을 추가, 이동, 변경, 작성, 삭제하는 일이 중요합니다. 웹 서버에 연결된 드라이브에 관한 정보를 보고 해당 드라이브를 조작하는 일이 필요한 경우도 있습니다.

스크립팅으로 아래 부분에 설명되어 있는 FileSystemObject(FSO) 개체 모델을 사용하여 드라이브, 폴더, 파일을 처리할 수 있습니다.

  • FileSystemObject와
    Scripting 런타임 라이브러리 참조 개요

  • FileSystemObject 개체

  • FileSystemObject 프로그래밍

  • 드라이브와 폴더 작업

  • 파일 작업

  • FileSystemObject 예제 코드


Microsoft® Scripting 라이브러리- FileSystemObject와 Scripting 런타임 라이브러리 참조 개요

Microsoft® Scripting Library - FileSystemObject
FileSystemObject와
Scripting 런타임 라이브러리
참조
 이전
다음

FileSystemObject(FSO) 개체 모델을 사용하면 폴더와 파일을 처리하는 데 사용할 수 있는 풍부한 속성, 메서드, 이벤트와 더불어 잘 알고 있는 object.method 구문을 사용할 수 있습니다.

이 개체 기반 도구는 아래의 도구들과 함께 사용합니다.

  • 웹 페이지를 만드는 HTML

  • Microsoft Windows용 일괄 처리 파일을 만드는 Windows Scripting Host

  • 다른 언어로 개발한 응용 프로그램에 스크립팅 기능을 제공하는 Script Control

클라이언트 측에서 FSO를 사용하면 클라이언트의 로컬 파일 시스템에 원하지 않는 액세스가 이루어지는 심각한 보안 문제가 발생할 수 있기 때문에 이 설명서에서는 인터넷 웹 페이지에서 실행되는 스크립트를 만드는 FSO 개체 모델을 서버 측에서 사용하는 것으로 가정합니다. 서버 측에서 사용되기 때문에 Internet Explorer 기본 보안 설정에서는 FileSystemObject 개체의 클라이언트 측 사용을 허용하지 않습니다. 이런 기본값을 무시하면 로컬 컴퓨터가 파일 시스템에 원치 않는 액세스를 할 수 있어서 결국 파일 시스템 무결성이 전체적으로 손상되거나 데이터가 손실될 수 있습니다.

FSO 개체 모델을 사용하면 서버 측 응용 프로그램에서 폴더를 작성, 변경, 이동, 삭제하거나 특정 폴더의 존재 여부와 위치를 검색할 수 있습니다. 또한, 폴더 이름이나 만든 날짜, 마지막으로 수정한 날짜 등 폴더에 관한 정보를 찾을 수도 있습니다.

FSO 개체 모델을 사용하면 파일을 더 쉽게 처리할 수 있습니다. 파일을 처리할 때의 주된 목표는 공간과 리소스를 효율적으로 사용하며 액세스하기 쉬운 형식으로 데이터를 저장하는 것입니다. 사용자는 파일을 만들고, 데이터를 삽입, 변경, 출력할 수 있어야 합니다. 데이터를 Access나 SQL Server 등의 데이터베이스에 저장하면 응용 프로그램에 상당한 양의 오버헤드를 추가하기 때문에 데이터는 이진 형식이나 텍스트 형식으로 저장하는 것이 가장 효율적입니다. 사용자가 이런 오버헤드를 피할 수도 있고, 데이터 액세스 요건에 기능을 모두 갖춘 데이터베이스에 연결된 추가 기능을 요청하지 않을 수도 있습니다.

Scripting 형식 라이브러리(Scrrun.dll)에 포함되어 있는 FSO 개체 모델은 TextStream 개체를 통해 텍스트 파일 작성과 조작 기능을 지원합니다. 아직까지 이진 파일 작성과 조작 기능을 지원하지 않지만, 이진 파일 지원이 계획되어 있습니다.


FileSystemObject 개체

Microsoft® Scripting Library - FileSystemObject
FileSystemObject 개체
 이전
다음

FileSystemObject(FSO) 개체 모델에는 아래 개체와 컬렉션이 포함됩니다.

개체/컬렉션 | 설명
FileSystemObject | 기본 개체입니다. 드라이브, 폴더 및 파일에 관한 정보를 만들고, 삭제하고, 확보할 수 있을 뿐만 아니라 일반적으로 이를 조작할 수 있는 메서드와 속성이 포함되어 있습니다. 이 개체와 연결된 많은 메서드들은 다른 FSO 개체에 이들 메서드를 복사합니다. 이런 메서드는 편의를 위해 마련된 것입니다.
Drive | 개체입니다. 드라이브 공유 이름과 사용할 수 있는 공간 크기 등 시스템에 연결된 드라이브에 관한 정보를 볼 수 있는 메서드와 속성이 포함되어 있습니다. "드라이브"가 꼭 하드 디스크를 의미하는 것은 아니고, CD-ROM이나 RAM 디스크 등도 드라이브에 해당될 수 있습니다. 드라이브가 실제로 시스템에 연결되어 있을 필요는 없습니다. 네트워크를 통해 논리적으로 연결되어 있어도 좋습니다.
Drives | 컬렉션입니다. 실제로 또는 논리적으로 시스템에 연결되어 있는 드라이브 목록을 제공합니다. Drives 컬렉션에는 형식에 관계없이 모든 드라이브가 포함됩니다. 이동식 매체 드라이브는 매체가 삽입되어 있지 않아도 이 컬렉션에 나타납니다.
File | 개체입니다. 파일을 만들거나, 삭제하거나, 이동하는 데 사용할 수 있는 메서드와 속성이 포함되어 있습니다. 또한 시스템 쿼리를 통해 파일 이름, 경로, 기타 다양한 속성을 가져올 수 있습니다.
Files | 컬렉션입니다. 폴더에 포함되어 있는 모든 파일 목록을 제공합니다.
Folder | 개체입니다. 폴더를 만들거나, 삭제하거나, 이동하는 데 사용할 수 있는 메서드와 속성이 포함되어 있습니다. 또한 시스템 쿼리를 통해 폴더 이름, 경로, 기타 다양한 속성을 가져올 수 있습니다.
Folders | 컬렉션입니다. Folder에 있는 모든 폴더 목록을 제공합니다.
TextStream | 개체입니다. 텍스트 파일을 읽고 쓸 수 있습니다.


FileSystemObject 프로그래밍

Microsoft® Scripting Library - FileSystemObject
FileSystemObject 프로그래밍
 이전
다음

FileSystemObject(FSO) 개체 모델로 프로그래밍하려면

  • CreateObject 메서드를 사용하여 FileSystemObject 개체를 만듭니다.
  • 새로 만든 개체에 적절한 메서드를 사용합니다.
  • 개체 속성에 액세스합니다.
FSO 개체 모델은 Scrrun.dll 파일에 있는 Scripting 형식 라이브러리에 포함되어 있습니다. 따라서 FSO 개체 모델을 사용하려면 웹 서버의 적절한 시스템 디렉터리에 Scrrun.dll이 있어야 합니다.

FileSystemObject 개체 작성
먼저, CreateObject 메서드를 사용하여 FileSystemObject 개체를 만듭니다. VBScript에서는 아래 코드를 사용하여 FileSystemObject 인스턴스를 만듭니다.

Dim fso
Set fso = CreateObject("Scripting.FileSystemObject")
예제 코드를 보면 FileSystemObject 인스턴스를 만드는 방법을 알 수 있습니다.

JScript에서는 아래 코드를 사용하여 같은 결과가 나옵니다.

var fso;
fso = new ActiveXObject("Scripting.FileSystemObject");
두 예제 모두에서 Scripting은 형식 라이브러리의 이름이고 FileSystemObject는 만들려는 개체의 이름입니다. 다른 개체를 만드는 횟수와는 관계없이 FileSystemObject 개체 인스턴스는 하나만 만들 수 있습니다.

적절한 메서드 사용
둘째, FileSystemObject 개체의 적절한 메서드를 사용합니다. 예를 들어, 새 개체를 만들려면 CreateTextFile이나 CreateFolder를 사용합니다(FSO 개체 모델은 드라이브를 만들거나 삭제하는 기능은 지원하지 않음).

개체를 삭제하려면 FileSystemObject 개체의 DeleteFile 메서드와 DeleteFolder 메서드 또는 File 개체와 Folder 개체의 Delete 메서드를 사용하십시오. 적절한 메서드를 사용하면 파일을 복사하거나 이동할 수도 있습니다.

메모 FileSystemObject 개체 모델 기능 중 일부는 중복됩니다. 예를 들어, 파일을 복사할 때 FileSystemObject 개체의 CopyFile 메서드를 사용할 수도 있고 File 개체의 Copy 메서드를 사용할 수도 있습니다. 두 메서드는 사용 방식이 똑같으며 프로그래밍의 융통성을 위해 제공됩니다.

기존 드라이브, 파일, 폴더 액세스
기존 드라이브, 파일, 폴더에 액세스하려면 FileSystemObject 개체의 "get" 메서드를 사용하십시오.

  • GetDrive
  • GetFolder
  • GetFile
VBScript에서 기존 파일에 액세스하려면 아래와 같이 합니다.

Dim fso, f1
Set fso = CreateObject("Scripting.FileSystemObject")
Set f1 = fso.GetFile("c:\test.txt")
JScript에서 기존 파일에 액세스하려면 아래 코드를 사용합니다.

var fso, f1;
fso = new ActiveXObject("Scripting.FileSystemObject");
f1 = fso.GetFile("c:\\test.txt");
"create" 함수는 개체에 대한 핸들을 반환하기 때문에 새로 만든 개체에는 "get" 메서드를 사용해서는 안됩니다. 예를 들어, CreateFolder 메서드로 새 폴더를 만든 경우에는 Name, Path, Size 등의 속성에 액세스하기 위해 GetFolder 메서드를 사용해서는 안됩니다. 새로 만든 폴더에 대한 핸들을 가져오려면 CreateFolder 함수에 변수를 설정한 후 속성, 메서드, 이벤트 등에 액세스해야 합니다. VBScript에서 이 작업을 하려면 아래 코드를 사용합니다.

Sub CreateFolder
  Dim fso, fldr
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set fldr = fso.CreateFolder("C:\MyTest")
  Response.Write "만든 폴더: " & fldr.Name
End Sub
JScript에서 CreateFolder 함수에 변수를 설정하려면 아래 구문을 사용합니다.

function CreateFolder()
{
  var fso, fldr;
  fso = ActiveXObject("Scripting.FileSystemObject");
  fldr = fso.CreateFolder("C:\\MyTest");
  Response.Write("만든 폴더: " + fldr.Name);
}
개체 속성 액세스
개체에 대한 핸들이 있으면 개체의 속성에 액세스할 수 있습니다. 예를 들어, 특정 폴더의 이름을 가져오려면 먼저 개체 인스턴스를 만든 후 적절한 메서드로(이 경우에는 폴더가 이미 존재하기 때문에 GetFolder 메서드임) 핸들을 가져옵니다.

VBScript에서 GetFolder 메서드에 대한 핸들을 가져오려면 아래 코드를 사용합니다.

Set fldr = fso.GetFolder("c:\")

JScript에서 같은 결과를 내려면 아래 코드를 사용합니다.

var fldr = fso.GetFolder("c:\\");
이제 Folder 개체에 대한 핸들을 가져왔기 때문에 Name 속성을 확인할 수 있습니다. VBScript에서 이 속성을 확인하려면 아래 코드를 사용합니다.

Response.Write "폴더 이름: " & fldr.Name
JScript에서 Name 속성을 확인하려면 아래 구문을 사용합니다.

Response.Write("폴더 이름: " + fldr.Name);
VBScript에서 파일을 마지막으로 수정한 시간을 찾으려면 아래 구문을 사용합니다.

Dim fso, f1
Set fso = CreateObject("Scripting.FileSystemObject")
' 쿼리에 사용할 File 개체를 가져옵니다.
Set f1 = fso.GetFile("c:\detlog.txt")
' 정보를 인쇄합니다.
Response.Write "마지막으로 파일을 수정한 시간: " & f1.DateLastModified
JScript에서 같은 내용을 찾으려면 아래 코드를 사용합니다.

var fso, f1;
fso = new ActiveXObject("Scripting.FileSystemObject");
// 쿼리에 사용할 File 개체를 가져옵니다.
f1 = fso.GetFile("c:\\detlog.txt");
// 정보를 인쇄합니다.
Response.Write("마지막으로 파일을 수정한 시간: " + f1.DateLastModified);


드라이브와 폴더 작업

Microsoft® Scripting Library - FileSystemObject
드라이브와 폴더 작업
 이전
다음

FileSystemObject(FSO) 개체 모델을 사용하면 Windows 탐색기에서 대화형으로 할 수 있는 작업을 프로그램에서 드라이브와 폴더로 할 수 있습니다.

드라이브 정보 보기
Drive 개체를 사용하면 실제로 또는 네트워크를 통해 시스템에 연결되어 있는 다양한 드라이브에 관한 정보를 볼 수 있습니다. 이 개체의 속성을 사용하면 아래와 같은 정보를 볼 수 있습니다.

  • 바이트 단위로 나타낸 드라이브 전체 크기(TotalSize 속성)
  • 바이트 단위로 나타낸 사용 가능한 드라이브 공간 크기(AvailableSpace 또는 FreeSpace 속성)
  • 드라이브에 지정한 문자(DriveLetter 속성)
  • 이동식, 고정식, 네트워크, CD-ROM, RAM 디스크 등의 드라이브 형식(DriveType 속성)
  • 드라이브 일련 번호(SerialNumber 속성)
  • FAT, FAT32, NTFS 등 드라이브에서 사용하는 파일 시스템 형식(FileSystem 속성)
  • 드라이브 사용 가능 여부(IsReady 속성)
  • 공유 이름 또는 볼륨 이름(ShareName과 VolumeName 속성)
  • 드라이브의 경로 또는 루트 폴더(Path와 RootFolder 속성)
예제 코드를 보면 FileSystemObject에서 이런 속성을 사용하는 방법을 알 수 있습니다.

Drive 개체 사용 예제
Drive 개체는 드라이브에 관한 정보를 모으는 데 사용합니다. 아래 코드에서는 실제 Drive 개체에 대한 참조가 없는 대신 GetDrive 메서드를 사용하여 기존 Drive 개체(이 경우에는 drv)에 대한 참조를 가져옵니다.

아래 예제는 VBScript에서 Drive 개체를 사용하는 방법을 보여줍니다.

Sub ShowDriveInfo(drvPath)
  Dim fso, drv, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set drv = fso.GetDrive(fso.GetDriveName(drvPath))
  s = "드라이브 " & UCase(drvPath) & " - "
  s = s & drv.VolumeName & "<br>"
  s = s & "전체 공간: " & FormatNumber(drv.TotalSize / 1024, 0)
  s = s & " KB" & "<br>"
  s = s & "사용 가능한 공간: " & FormatNumber(drv.FreeSpace / 1024, 0)
  s = s & " KB" & "<br>"
  Response.Write s
End Sub
아래 코드는 JScript의 같은 기능을 보여줍니다.
function ShowDriveInfo1(drvPath)
{
  var fso, drv, s ="";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  drv = fso.GetDrive(fso.GetDriveName(drvPath));
  s += "드라이브 " + drvPath.toUpperCase()+ " - ";
  s += drv.VolumeName + "<br>";
  s += "전체 공간: " + drv.TotalSize / 1024;
  s += " KB" + "<br>";
  s += "사용 가능한 공간: " + drv.FreeSpace / 1024;
  s += " KB" + "<br>";
  Response.Write(s);
}
폴더 작업
아래 표에는 일반적인 폴더 작업과 이런 작업에 사용되는 메서드가 설명되어 있습니다.

작업 | 메서드
폴더를 만듭니다. | FileSystemObject.CreateFolder
폴더를 삭제합니다. | Folder.Delete 또는 FileSystemObject.DeleteFolder
폴더를 이동합니다. | Folder.Move 또는 FileSystemObject.MoveFolder
폴더를 복사합니다. | Folder.Copy 또는 FileSystemObject.CopyFolder
폴더 이름을 검색합니다. | Folder.Name
드라이브에서 폴더의 존재를 찾습니다. | FileSystemObject.FolderExists
기존 Folder 개체의 인스턴스를 가져옵니다. | FileSystemObject.GetFolder
폴더의 상위 폴더 이름을 찾습니다. | FileSystemObject.GetParentFolderName
시스템 폴더의 경로를 찾습니다. | FileSystemObject.GetSpecialFolder

예제 코드를 보면 FileSystemObject에서 사용되는 메서드 수와 속성 수를 알 수 있습니다.

아래 예제는 VBScript에서 폴더를 조작하고 정보를 보는 데 사용되는 Folder 개체와 FileSystemObject 개체의 사용법을 보여줍니다.

Sub ShowFolderInfo()
  Dim fso, fldr, s
  ' FileSystemObject의 인스턴스를 가져옵니다.
  Set fso = CreateObject("Scripting.FileSystemObject")
  ' Drive 개체를 가져옵니다.
  Set fldr = fso.GetFolder("c:")
  ' 상위 폴더 이름을 인쇄합니다.
  Response.Write "상위 폴더 이름: " & fldr & "<br>"
  ' 드라이브 이름을 인쇄합니다.
  Response.Write "드라이브 이름: " & fldr.Drive & "<br>"
  ' 루트 파일 이름을 인쇄합니다.
  If fldr.IsRootFolder = true Then
    Response.Write "루트 폴더입니다." & ""<br>"<br>"
  Else
    Response.Write "루트 폴더가 아닙니다." & "<br><br>"
  End If
  ' FileSystemObject 개체로 새 폴더를 만듭니다.
  fso.CreateFolder ("C:\Bogus")
  Response.Write "만든 폴더 C:\Bogus" & "<br>"
  ' 폴더의 기본 이름을 인쇄합니다.
  Response.Write "기본 이름 = " & fso.GetBaseName("c:\bogus") & "<br>"
  ' 새로 만든 폴더를 삭제합니다.
  fso.DeleteFolder ("C:\Bogus")
  Response.Write "삭제한 폴더 C:\Bogus" & "<br>"
End Sub
아래 예제는 JScript에서 Folder 개체와 FileSystemObject 개체의 사용법을 보여줍니다.
function ShowFolderInfo()
{
  var fso, fldr, s = "";
  // FileSystemObject의 인스턴스를 가져옵니다.
  fso = new ActiveXObject("Scripting.FileSystemObject");
  // Drive 개체를 가져옵니다.
  fldr = fso.GetFolder("c:");
  // 상위 폴더 이름을 인쇄합니다.
  Response.Write(+"상위 폴더 이름: " + fldr  "<br>");
  // 드라이브 이름을 인쇄합니다.
  Response.Write("드라이브 이름: " + fldr.Drive + "<br>");
  // 루트 파일 이름을 인쇄합니다.
  if (fldr.IsRootFolder)
    Response.Write("루트 폴더입니다.");
  else
    Response.Write("루트 폴더가 아닙니다.");
  Response.Write("<br><br>");
  // FileSystemObject 개체에 새 폴더를 만듭니다.
  fso.CreateFolder ("C:\\Bogus");
  Response.Write("만든 폴더 C:\\Bogus" + "<br>");
  // 폴더의 기본 이름을 인쇄합니다.
  Response.Write("기본 이름 = " + fso.GetBaseName("c:\\bogus") + "<br>");
  // 새로 만든 폴더를 삭제합니다.
  fso.DeleteFolder ("C:\\Bogus");
  Response.Write("삭제한 폴더 C:\\Bogus" + "<br>");
}


파일 작업

Microsoft® Scripting Library - FileSystemObject
파일 작업
 이전
다음

파일 작업은 크게 두 범주로 구분됩니다.

  • 파일 만들기, 데이터 추가와 삭제, 파일 읽기
  • 파일 이동, 복사, 삭제
파일 만들기
빈 텍스트 파일("텍스트 스트림"이라고도 함)을 만드는 방법에는 세 가지가 있습니다.

하나는 CreateTextFile 메서드를 사용하는 것입니다. 아래 예제는 VBScript에서 이 메서드를 사용하여 텍스트 파일을 작성하는 방법을 보여줍니다.

Dim fso, f1
Set fso = CreateObject("Scripting.FileSystemObject")
Set f1 = fso.CreateTextFile("c:\testfile.txt", true)
JScript에서 이 메서드를 사용하려면 아래 코드를 사용합니다.

var fso, f1;
fso = new ActiveXObject("Scripting.FileSystemObject");
f1 = fso.CreateTextFile("c:\\testfile.txt", true);
예제 코드를 보면 CreateTextFile 메서드를 FileSystemObject에서 사용하는 방법을 알 수 있습니다.

텍스트 파일을 만드는 둘째 방법은 ForWriting 플래그를 설정하고 FileSystemObject 개체의 OpenTextFile 메서드를 사용하는 것입니다. VBScript에서 사용하는 코드는 아래 예제와 같습니다.

Dim fso, ts
Const ForWriting = 2
Set fso = CreateObject("Scripting. FileSystemObject")
Set ts = fso.OpenTextFile("c:\test.txt", ForWriting, true)
JScript에서 이 메서드를 사용하여 텍스트 파일을 만들려면 아래 코드를 사용합니다.

var fso, ts;
var ForWriting= 2;
fso = new ActiveXObject("Scripting.FileSystemObject");
ts = fso.OpenTextFile("c:\\test.txt", ForWriting, true);
텍스트 파일을 만드는 세째 방법은 ForWriting 플래그를 설정하고 OpenAsTextStream 메서드를 사용하는 것입니다. VBScript에서 이 메서드를 사용하려면 아래 코드를 사용합니다.

Dim fso, f1, ts
Const ForWriting = 2
Set fso = CreateObject("Scripting.FileSystemObject")
fso.CreateTextFile ("c:\test1.txt")
Set f1 = fso.GetFile("c:\test1.txt")
Set ts = f1.OpenAsTextStream(ForWriting, true)
JScript에서는 아래 예제와 같은 코드를 사용합니다.

var fso, f1, ts;
var ForWriting = 2;
fso = new ActiveXObject("Scripting.FileSystemObject");
fso.CreateTextFile ("c:\\test1.txt");
f1 = fso.GetFile("c:\\test1.txt");
ts = f1.OpenAsTextStream(ForWriting, true);
파일에 데이터 추가
텍스트 파일을 만든 후 아래와 같은 세 단계를 따라 데이터를 파일에 추가합니다.

  1. 텍스트 파일을 엽니다.
  2. 데이터를 씁니다.
  3. 파일을 닫습니다.
기존 파일을 열려면 FileSystemObject 개체의 OpenTextFile 메서드나 File 개체의 OpenAsTextStream 메서드를 사용하십시오.

열린 텍스트 파일에 데이터를 쓰려면 아래 표에 설명되어 있는 작업에 따라 TextStream 개체의 Write, WriteLine 또는 WriteBlankLines 메서드를 사용하십시오.

작업 | 메서드
열린 텍스트 파일에 뒤에 오는 줄 바꿈 문자 없이 데이터를 씁니다. | Write
열린 텍스트 파일에 데이터와 뒤에 오는 줄 바꿈 문자를 씁니다. | WriteLine
열린 텍스트 파일에 빈 줄을 하나 이상 씁니다. | WriteBlankLines

예제 코드를 보면 FileSystemObject에서 Write, WriteLine, WriteBlankLines 메서드를 사용하는 방법을 알 수 있습니다.

열린 파일을 닫으려면 TextStream 개체의 Close 메서드를 사용하십시오.

예제 코드를 보면 FileSystemObject에서 Close 메서드를 사용하는 방법을 알 수 있습니다.

메모 줄 바꿈 문자에는 커서를 다음 줄의 시작 부분으로 넘기는 문자(운영 체제에 따라 다름)가 있습니다(캐리지 리턴/줄 바꿈). 일부 문자열의 끝에는 이미 그런 인쇄되지 않는 문자가 있는 것도 있습니다.

아래 VBScript 예제는 파일을 열고, 세 가지 쓰기 방법을 모두 사용하여 파일에 데이터를 추가하고, 파일을 닫는 방법을 보여줍니다.

Sub CreateFile()
  Dim fso, tf
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set tf = fso.CreateTextFile("c:\testfile.txt", true)
  ' 줄 바꿈 문자가 있는 줄을 씁니다.
  tf.WriteLine("테스트 중 1, 2, 3.")
  ' 파일에 줄 바꿈 문자를 세 개 씁니다.
  tf.WriteBlankLines(3)
  ' 줄을 씁니다.
  tf.Write ("테스트입니다.")
  tf.Close
End Sub
아래 예제는 JScript에서 세 가지 메서드의 사용법을 보여줍니다.

function CreateFile()
{
  var fso, tf;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  tf = fso.CreateTextFile("c:\\testfile.txt", true);
  // 줄 바꿈 문자가 있는 줄을 씁니다.
  tf.WriteLine("테스트 중 1, 2, 3.") ;
  // 파일에 줄 바꿈 문자를 세 개 씁니다.
  tf.WriteBlankLines(3) ;
  // 줄을 씁니다.
  tf.Write ("테스트입니다.");
  tf.Close();
}
파일 읽기
텍스트 파일에서 데이터를 읽으려면 TextStream 개체의 Read, ReadLine, 또는 ReadAll 메서드를 사용하십시오. 아래 표에는 여러 작업에 사용할 수 있는 메서드가 설명되어 있습니다.

작업 | 메서드
파일에서 지정한 수의 문자를 읽습니다. | Read
한 줄 전체를 읽습니다(줄 바꿈 문자는 제외하고 줄 바꿈 문자까지). | ReadLine
텍스트 파일의 전체 내용을 읽습니다. | ReadAll

예제 코드를 보면 FileSystemObject에서 ReadAll 메서드와 ReadLine 메서드를 사용하는 방법을 알 수 있습니다.

Read 메서드나 ReadLine 메서드를 사용하면서 데이터의 특정 부분을 건너뛰려면 Skip 메서드 또는 SkipLine 메서드를 사용하십시오. 읽기 메서드의 결과로 나오는 텍스트는 문자열로 저장되며 컨트롤에 표시하거나, 문자열 함수(Left, Right, Mid)로 구문을 분석하거나, 연결하는 등의 조작을 할 수 있습니다.

아래 VBScript 예제는 파일을 열고, 내용을 쓰고, 다시 읽는 방법을 보여줍니다.

Sub ReadFiles
  Dim fso, f1, ts, s
  Const ForReading = 1
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f1 = fso.CreateTextFile("c:\testfile.txt", true)
  ' 줄을 씁니다.
  Response.Write "파일 쓰는 중 <br>"
  f1.WriteLine "안녕하십니까?"
  f1.WriteBlankLines(1)
  f1.Close
  ' 파일 내용을 읽습니다.
  Response.Write "파일 읽는 중 <br>"
  Set ts = fso.OpenTextFile("c:\testfile.txt", ForReading)
  s = ts.ReadLine
  Response.Write "파일 내용 = '" & s & "'"
  ts.Close
End Sub
아래 코드는 JScript에서 같은 작업을 하는 방법을 보여줍니다.

function ReadFiles()
{
  var fso, f1, ts, s;
  var ForReading = 1;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f1 = fso.CreateTextFile("c:\\testfile.txt", true);
  // 줄을 씁니다.
  Response.Write("파일 쓰는 중 <br>");
  f1.WriteLine("안녕하십니까?");
  f1.WriteBlankLines(1);
  f1.Close();
  // 파일 내용을 읽습니다.
  Response.Write("파일 읽는 중 <br>");
  ts = fso.OpenTextFile("c:\\testfile.txt", ForReading);
  s = ts.ReadLine();
  Response.Write("파일 내용 = '" + s + "'");
  ts.Close();
}
파일 이동, 복사, 삭제
FSO 개체 모델에는 아래 표에 설명되어 있는 것처럼 파일 이동, 복사, 삭제에 대해 각각 두 가지 메서드가 있습니다.

작업 | 메서드
파일을 이동합니다. | File.Move 또는 FileSystemObject.MoveFile
파일을 복사합니다. | File.Copy 또는 FileSystemObject.CopyFile
파일을 삭제합니다. | File.Delete 또는 FileSystemObject.DeleteFile

예제 코드를 보면 FileSystemObject에서 파일을 삭제하는 두 가지 방법을 알 수 있습니다.

아래 VBScript 예제에서는 C 드라이브의 루트 디렉터리에 텍스트 파일을 만들고, 파일에 정보를 쓰고, 파일을 \tmp라는 디렉터리로 이동하고, \temp라는 디렉터리에 복사본을 만든 후에 두 디렉터리 모두에서 복사본을 삭제합니다.

아래 예제를 실행하려면 먼저 C 드라이브의 루트 디렉터리에 \tmp와 \temp 디렉터리를 만듭니다.

Sub ManipFiles
  Dim fso, f1, f2, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f1 = fso.CreateTextFile("c:\testfile.txt", true)
  Response.Write "파일 쓰는 중 <br>"
  ' 줄을 씁니다.
  f1.Write ("테스트입니다.")
  ' 파일을 닫습니다.
  f1.Close
  Response.Write "파일을 c:\tmp로 이동하는 중 <br>"
  ' C:\ 루트에 있는 파일에 대한 핸들을 가져옵니다.
  Set f2 = fso.GetFile("c:\testfile.txt")
  ' 파일을 \tmp 디렉터리로 이동합니다.
  f2.Move ("c:\tmp\testfile.txt")
  Response.Write "파일을 c:\temp로 복사하는 중 <br>"
  ' 파일을 \temp로 복사합니다.
  f2.Copy ("c:\temp\testfile.txt")
  Response.Write "파일 삭제 중 <br>"
  ' 파일의 현재 위치에 대한 핸들을 가져옵니다.
  Set f2 = fso.GetFile("c:\tmp\testfile.txt")
  Set f3 = fso.GetFile("c:\temp\testfile.txt")
  ' 파일을 삭제합니다.
  f2.Delete
  f3.Delete
  Response.Write "완료되었습니다!"
End Sub
아래 코드는 JScript에서 같은 작업을 하는 방법을 보여줍니다.

function ManipFiles()
{
  var fso, f1, f2, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f1 = fso.CreateTextFile("c:\\testfile.txt", true);
  Response.Write("파일 쓰는 중 <br>");
  // 줄을 씁니다.
  f1.Write("텍스트입니다.");
  // 파일을 닫습니다.
  f1.Close();
  Response.Write("파일을 c:\\tmp로 이동하는 중 <br>");
  // C:\ 루트에 있는 파일에 대한 핸들을 가져옵니다.
  f2 = fso.GetFile("c:\\testfile.txt");
  // 파일을 \tmp 디렉터리로 옮깁니다.
  f2.Move ("c:\\tmp\\testfile.txt");
  Response.Write("파일을 c:\\temp로 복사하는 중 <br>");
  // 파일을 \temp로 복사합니다.
  f2.Copy ("c:\\temp\\testfile.txt");
  Response.Write("파일 삭제 중 <br>");
  // 파일의 현재 위치에 대한 핸들을 가져옵니다.
  f2 = fso.GetFile("c:\\tmp\\testfile.txt");
  f3 = fso.GetFile("c:\\temp\\testfile.txt");
  // 파일을 삭제합니다.
  f2.Delete();
  f3.Delete();
  Response.Write("완료되었습니다!");
}


FileSystemObject 예제 코드

Microsoft® Scripting Library - FileSystemObject
FileSystemObject
예제 코드
 이전

이 부분에 나와 있는 예제 코드는 FileSystemObject 개체 모델에서 사용할 수 있는 여러 기능을 실제로 적용한 예입니다. 이 코드에서는 개체 모델의 모든 기능을 함께 사용하여 작업하는 방법과 이러한 기능을 코드에서 효율적으로 사용하는 방법을 보여줍니다.

여기에 있는 코드는 포괄적으로 만들었기 때문에 이 코드를 컴퓨터에서 실제로 실행하려면 다른 코드를 추가하고 일부를 변경해야 합니다. Active Server Pages와 Windows Scripting Host 사이에는 사용자에 대한 입력 및 출력 방법이 다양하기 때문에 이런 변경은 필수적입니다.

Active Server Pages에서 이 코드를 실행하려면 아래 단계를 사용하십시오.

  1. .asp 확장명을 사용하여 표준 웹 페이지를 만듭니다.
  2. 아래 예제 코드를 파일의 <BODY>...</BODY> 태그 사이에 복사합니다.
  3. 코드 전체를 <%...%> 태그로 묶습니다.
  4. Option Explicit 문을 코드의 현재 위치에서 HTML 페이지의 맨 위 즉, <HTML> 태그보다 위쪽에 놓습니다.
  5. Option Explicit 문 앞뒤에 <%...%> 태그를 추가하여 이 내용이 서버 측에서 실행되도록 합니다.
  6. 아래 코드를 예제 코드 끝에 추가합니다.
Sub Print(x)
  Response.Write "<PRE><FONT FACE=""Courier New"" SIZE=""1"">"
  Response.Write x
  Response.Write "</FONT></PRE>"
End Sub
Main
위의 코드는 서버 측에서 실행한 후 결과를 클라이언트 측에 표시하는 인쇄 프로시저를 추가합니다. 이 코드를 Windows Scripting Host에서 실행하려면 예제 코드 끝에 아래 코드를 추가하십시오.
Sub Print(x)
    WScript.Echo x
End Sub
Main
코드에는 다음 부분이 포함되어 있습니다.

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' FileSystemObject 예제 코드
'
' Copyright 1998 Microsoft Corporation.  All Rights Reserved.
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Option Explicit

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' 코드 품질 관련 사항
'
' 1) 아래 코드에서는 "&" 연산자로 짧은 문자열을 연결하여 문자열을 조작하는 일이 많습니다.
'    문자열 연결은 리소스가 많이 필요한 작업이기 때문에 문자열 연결을 사용하여 코드를 쓰는 것은
'    비효율적인 방법입니다. 하지만 코드 쓰기를 관리하는 데는 적절합니다. 이 프로그램에서는
'    디스크 작업을 많이 수행할 뿐만 아니라 디스크가 문자열 연결에 필요한 메모리 작업보다는
'    훨씬 느리기 때문에 문자열 연결을 사용했습니다. 이 코드는 설명용 코드이지 제품용 코드가 아닙니다.
'
' 2) 선언된 변수 액세스가 선언되지 않은 변수 액세스보다 약간 빠르기 때문에 "Option Explicit"을
'    사용했습니다. 이렇게 하면 DriveTypeCDROM을 DriveTypeCDORM으로 잘못 입력하는 것처럼 코드에
     버그가 포함되는 것도 방지할 수도 있습니다.
'
' 3) 코드를 읽기 쉽도록 하기 위해 이 코드에는 오류 처리 부분이 없습니다.
'    코드가 일반적인 상황에서 오류를 일으키지 않도록 미리 주의를 기울이기는 했지만 파일 시스템이
'    예기치 않은 결과를 보일 수도 있습니다. 제품 코드에서는 On Error Resume Next와
'    Err 개체를 사용하여 발생할 수 있는 오류를 잡아야 합니다.
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' 편리한 전역 변수
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Dim TabStop
Dim NewLine

Const TestDrive = "C"
Const TestFilePath = "C:\Test"

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' Drive.DriveType에서 반환하는 상수
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Const DriveTypeRemovable = 1
Const DriveTypeFixed = 2
Const DriveTypeNetwork = 3
Const DriveTypeCDROM = 4
Const DriveTypeRAMDisk = 5

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' File.Attributes에서 반환하는 상수
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Const FileAttrNormal  = 0
Const FileAttrReadOnly = 1
Const FileAttrHidden = 2
Const FileAttrSystem = 4
Const FileAttrVolume = 8
Const FileAttrDirectory = 16
Const FileAttrArchive = 32
Const FileAttrAlias = 64
Const FileAttrCompressed = 128

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' 파일을 여는 데 필요한 상수
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Const OpenFileForReading = 1
Const OpenFileForWriting = 2
Const OpenFileForAppending = 8

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' ShowDriveType
'
' 목적:
'
' 주어진 Drive 개체의 드라이브 형식을 설명하는 문자열을 만듭니다.
'
' 다음을 보여줍니다.
'
' - Drive.DriveType
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function ShowDriveType(Drive)

    Dim S

    Select Case Drive.DriveType
    Case DriveTypeRemovable
        S = "이동식"
    Case DriveTypeFixed
        S = "고정식"
    Case DriveTypeNetwork
        S = "네트워크"
    Case DriveTypeCDROM
        S = "CD-ROM"
    Case DriveTypeRAMDisk
        S = "RAM 디스크"
    Case Else
        S = "알 수 없음"
    End Select

    ShowDriveType = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' ShowFileAttr
'
' 목적:
'
' 파일이나 폴더의 특성을 설명하는 문자열을 만듭니다.
'
' 다음을 보여줍니다.
'
' - File.Attributes
' - Folder.Attributes
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function ShowFileAttr(File) ' File은 파일 또는 폴더입니다.

    Dim S
      Dim Attr

    Attr = File.Attributes

    If Attr = 0 Then
        ShowFileAttr = "일반"
        Exit Function
    End If

    If Attr And FileAttrDirectory  Then S = S & "디렉터리 "
    If Attr And FileAttrReadOnly   Then S = S & "읽기 전용 "
    If Attr And FileAttrHidden     Then S = S & "숨김 "
    If Attr And FileAttrSystem     Then S = S & "시스템 "
    If Attr And FileAttrVolume     Then S = S & "볼륨 "
    If Attr And FileAttrArchive    Then S = S & "보관 "
    If Attr And FileAttrAlias      Then S = S & "별칭 "
    If Attr And FileAttrCompressed Then S = S & "압축 "

    ShowFileAttr = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' GenerateDriveInformation
'
' 목적:
'
' 사용할 수 있는 드라이브의 현재 상태를 설명하는 문자열을 만듭니다.
'
' 다음을 보여줍니다.
'
' - FileSystemObject.Drives
' - Drives 컬렉션 반복
' - Drives.Count
' - Drive.AvailableSpace
' - Drive.DriveLetter
' - Drive.DriveType
' - Drive.FileSystem
' - Drive.FreeSpace
' - Drive.IsReady
' - Drive.Path
' - Drive.SerialNumber
' - Drive.ShareName
' - Drive.TotalSize
' - Drive.VolumeName
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function GenerateDriveInformation(FSO)

    Dim Drives
    Dim Drive
    Dim S

    Set Drives = FSO.Drives

    S = "드라이브 수:" & TabStop & Drives.Count & NewLine & NewLine

    ' 보고서의 첫째 줄을 구성합니다.
    S = S & String(2, TabStop) & "드라이브"
    S = S & String(2, TabStop) & "파일"
    S = S & TabStop & "전체"
    S = S & TabStop & "전체"
    S = S & TabStop & "전체"
    S = S & TabStop & "전체"

    ' 보고서의 둘째 줄을 구성합니다.
    S = S & "문자"
    S = S & TabStop & "경로"
    S = S & TabStop & "형식"
    S = S & TabStop & "준비?"
    S = S & TabStop & "이름"
    S = S & TabStop & "시스템"
    S = S & TabStop & "공간"
    S = S & TabStop & "공간"
    S = S & TabStop & "공간"
    S = S & String(2, TabStop) & "번호" & NewLine

    ' 구분용 줄입니다.
    S = S & String(125, "-") & NewLine

    For Each Drive In Drives

        S = S & Drive.DriveLetter
        S = S & TabStop & Drive.Path
        S = S & TabStop & ShowDriveType(Drive)
        S = S & TabStop & Drive.IsReady

        If Drive.IsReady Then
            If DriveTypeNetwork = Drive.DriveType Then
                S = S & TabStop & Drive.ShareName
            Else
                S = S & TabStop & Drive.VolumeName
            End If

            S = S & TabStop & Drive.FileSystem
            S = S & TabStop & Drive.TotalSize
            S = S & TabStop & Drive.FreeSpace
            S = S & TabStop & Drive.AvailableSpace
            S = S & TabStop & Hex(Drive.SerialNumber)

        End If

        S = S & NewLine

    Next

    GenerateDriveInformation = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' GenerateFileInformation
'
' 목적:
'
' 파일의 현재 상태를 설명하는 문자열을 만듭니다.
'
' 다음을 보여줍니다.
'
' - File.Path
' - File.Name
' - File.Type
' - File.DateCreated
' - File.DateLastAccessed
' - File.DateLastModified
' - File.Size
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function GenerateFileInformation(File)

    Dim S

    S = NewLine & "경로:" & TabStop & File.Path
    S = S & NewLine & "이름:" & TabStop & File.Name
    S = S & NewLine & "형식:" & TabStop & File.Type
    S = S & NewLine & "특성:" & TabStop & ShowFileAttr(File)
    S = S & NewLine & "작성:" & TabStop & File.DateCreated
    S = S & NewLine & "액세스:" & TabStop & File.DateLastAccessed
    S = S & NewLine & "수정:" & TabStop & File.DateLastModified
    S = S & NewLine & "크기" & TabStop & File.Size & NewLine

    GenerateFileInformation = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' GenerateFolderInformation
'
' 목적:
'
' 폴더의 현재 상태를 설명하는 문자열을 만듭니다.
'
' 다음을 보여줍니다.
'
' - Folder.Path
' - Folder.Name
' - Folder.DateCreated
' - Folder.DateLastAccessed
' - Folder.DateLastModified
' - Folder.Size
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function GenerateFolderInformation(Folder)

    Dim S

    S = "경로:" & TabStop & Folder.Path
    S = S & NewLine & "이름:" & TabStop & Folder.Name
    S = S & NewLine & "특성:" & TabStop & ShowFileAttr(Folder)
    S = S & NewLine & "작성:" & TabStop & Folder.DateCreated
    S = S & NewLine & "액세스:" & TabStop & Folder.DateLastAccessed
    S = S & NewLine & "수정:" & TabStop & Folder.DateLastModified
    S = S & NewLine & "크기:" & TabStop & Folder.Size & NewLine

    GenerateFolderInformation = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' GenerateAllFolderInformation
'
' 목적:
'
' 폴더와 모든 파일, 하위 폴더의 현재 상태를
' 설명하는 문자열을 만듭니다.
'
' 다음을 보여줍니다.
'
' - Folder.Path
' - Folder.SubFolders
' - Folders.Count
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function GenerateAllFolderInformation(Folder)

    Dim S
    Dim SubFolders
    Dim SubFolder
    Dim Files
    Dim File

    S = "폴더:" & TabStop & Folder.Path & NewLine & NewLine

    Set Files = Folder.Files

    If 1 = Files.Count Then
        S = S & "파일이 하나 있습니다." & NewLine
    Else
        S = S & "파일이 " & Files.Count & "개 있습니다." & NewLine
    End If

    If Files.Count <> 0 Then

        For Each File In Files
            S = S & GenerateFileInformation(File)
        Next

    End If

    Set SubFolders = Folder.SubFolders

    If 1 = SubFolders.Count Then
        S = S & NewLine & "하위 폴더가 하나 있습니다." & NewLine & NewLine
    Else
        S = S & NewLine & "하위 폴더가 " & SubFolders.Count & "개 있습니다." & NewLine & NewLine
    End If

    If SubFolders.Count <> 0 Then

        For Each SubFolder In SubFolders
            S = S & GenerateFolderInformation(SubFolder)
        Next

        S = S & NewLine

        For Each SubFolder In SubFolders
            S = S & GenerateAllFolderInformation(SubFolder)
        Next

    End If

    GenerateAllFolderInformation = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' GenerateTestInformation
'
' 목적:
'
' C:\Test 폴더와 모든 파일, 하위 폴더의 현재
' 상태를 설명하는 문자열을 만듭니다.
'
' 다음을 보여줍니다.
'
' - FileSystemObject.DriveExists
' - FileSystemObject.FolderExists
' - FileSystemObject.GetFolder
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function GenerateTestInformation(FSO)

    Dim TestFolder
    Dim S

    If Not FSO.DriveExists(TestDrive) Then Exit Function
    If Not FSO.FolderExists(TestFilePath) Then Exit Function

    Set TestFolder = FSO.GetFolder(TestFilePath)

    GenerateTestInformation = GenerateAllFolderInformation(TestFolder)

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' DeleteTestDirectory
'
' 목적:
'
' test 디렉터리를 삭제합니다.
'
' 다음을 보여줍니다.
'
' - FileSystemObject.GetFolder
' - FileSystemObject.DeleteFile
' - FileSystemObject.DeleteFolder
' - Folder.Delete
' - File.Delete
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Sub DeleteTestDirectory(FSO)

    Dim TestFolder
    Dim SubFolder
    Dim File

    ' 파일을 삭제하는 두 가지 방법:

    FSO.DeleteFile(TestFilePath & "\Beatles\OctopusGarden.txt")

    Set File = FSO.GetFile(TestFilePath & "\Beatles\BathroomWindow.txt")
    File.Delete

    ' 폴더를 삭제하는 두 가지 방법:

    FSO.DeleteFolder(TestFilePath & "\Beatles")

    FSO.DeleteFile(TestFilePath & "\ReadMe.txt")

    Set TestFolder = FSO.GetFolder(TestFilePath)
    TestFolder.Delete

End Sub

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' CreateLyrics
'
' 목적:
'
' 한 폴더에 텍스트 파일 두 개를 작성합니다.
'
'
' 다음을 보여줍니다.
'
' - FileSystemObject.CreateTextFile
' - TextStream.WriteLine
' - TextStream.Write
' - TextStream.WriteBlankLines
' - TextStream.Close
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Sub CreateLyrics(Folder)

    Dim TextStream

    Set TextStream = Folder.CreateTextFile("OctopusGarden.txt")

    TextStream.Write("문어의 정원 ") ' 파일에 줄 바꿈이 추가되지 않습니다.
    TextStream.WriteLine("(노래: 링고 스타)")
    TextStream.WriteBlankLines(1)
    TextStream.WriteLine("심해의 어두운 곳에 있는 문어의 정원에 있고 싶습니다.")
    TextStream.WriteLine("그는 우리를 들여보내 줄 것이며, 우리가 어디에 있었는가를 압니다. -- 그 곳은 어두운 곳에 있는 문어의 정원입니다.")
    TextStream.WriteBlankLines(2)

    TextStream.Close

    Set TextStream = Folder.CreateTextFile("BathroomWindow.txt")
    TextStream.WriteLine("그녀는 욕실 창문으로 들어 왔습니다(레논/메카트니).")
    TextStream.WriteLine("")
    TextStream.WriteLine("그녀는 은 숟가락으로 보호 장치를 한 욕실 창문을 통하여 들어 왔습니다.")
    TextStream.WriteLine("그러나 그녀는 지금 엄지손가락을 빨며 그녀만의 호수 언덕에서 거닐고 있습니다.")
    TextStream.WriteBlankLines(2)
    TextStream.Close

End Sub

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' GetLyrics
'
' 목적:
'
' lyrics 파일의 내용을 표시합니다.
'
'
' 다음을 보여줍니다.
'
' - FileSystemObject.OpenTextFile
' - FileSystemObject.GetFile
' - TextStream.ReadAll
' - TextStream.Close
' - File.OpenAsTextStream
' - TextStream.AtEndOfStream
' - TextStream.ReadLine
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function GetLyrics(FSO)

    Dim TextStream
    Dim S
    Dim File

    ' 텍스트 파일을 여는 방법은 여러 가지이고, 파일에서 데이터를 읽는 방법도
    ' 여러 가지입니다. 다음에는 각각에 대해 두 가지 방법이 나와 있습니다.

    Set TextStream = FSO.OpenTextFile(TestFilePath & "\Beatles\OctopusGarden.txt", OpenFileForReading)

    S = TextStream.ReadAll & NewLine & NewLine
    TextStream.Close

    Set File = FSO.GetFile(TestFilePath & "\Beatles\BathroomWindow.txt")
    Set TextStream = File.OpenAsTextStream(OpenFileForReading)
    Do 	While Not TextStream.AtEndOfStream
        S = S & TextStream.ReadLine & NewLine
    Loop
    TextStream.Close

    GetLyrics = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' BuildTestDirectory
'
' 목적:
'
' FileSystemObject를 보여주는 디렉터리 계층을 구성합니다.
'
' 아래와 같은 순서로 계층을 구성합니다.
'
' C:\Test
' C:\Test\ReadMe.txt
' C:\Test\Beatles
' C:\Test\Beatles\OctopusGarden.txt
' C:\Test\Beatles\BathroomWindow.txt
'
'
' 다음을 보여줍니다.
'
' - FileSystemObject.DriveExists
' - FileSystemObject.FolderExists
' - FileSystemObject.CreateFolder
' - FileSystemObject.CreateTextFile
' - Folders.Add
' - Folder.CreateTextFile
' - TextStream.WriteLine
' - TextStream.Close
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function BuildTestDirectory(FSO)

    Dim TestFolder
    Dim SubFolders
    Dim SubFolder
    Dim TextStream

    ' (a) 드라이브가 존재하지 않거나 (b) 구성할 디렉터리가 이미 존재하면
    ' 빠져 나옵니다.

    If Not FSO.DriveExists(TestDrive) Then
        BuildTestDirectory = false
        Exit Function
    End If

    If FSO.FolderExists(TestFilePath) Then
        BuildTestDirectory = false
        Exit Function
    End If

    Set TestFolder = FSO.CreateFolder(TestFilePath)

    Set TextStream = FSO.CreateTextFile(TestFilePath & "\ReadMe.txt")
    TextStream.WriteLine("나의 서정 가요 모음")
    TextStream.Close

    Set SubFolders = TestFolder.SubFolders

    Set SubFolder = SubFolders.Add("Beatles")

    CreateLyrics SubFolder

    BuildTestDirectory = true

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' 기본 루틴
'
' 먼저 test 디렉터리, 하위 폴더, 파일을 만듭니다.
' 그런 다음 사용할 수 있는 디스크 드라이브와 test 디렉터리에
' 관한 정보를 넣고 다시 모든 것을 지웁니다.
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Sub Main

    Dim FSO

    ' 전역 데이터를 설정합니다.
    TabStop = Chr(9)
    NewLine = Chr(10)

    Set FSO = CreateObject("Scripting.FileSystemObject")

    If Not BuildTestDirectory(FSO) Then
        Print "Test 디렉터리가 이미 존재하거나 만들 수 없습니다. 작업을 계속할 수 없습니다."
        Exit Sub
    End If

    Print GenerateDriveInformation(FSO) & NewLine & NewLine

    Print GenerateTestInformation(FSO) & NewLine & NewLine

    Print GetLyrics(FSO) & NewLine & NewLine

    DeleteTestDirectory(FSO)

End Sub


내부 개체

내부 개체
 JScript 자습서
이전

Microsoft JScript는 9가지 내부(또는 "기본 제공") 개체를 제공합니다. 9가지 내부 개체란 구체적으로 Array, Boolean, Date, Function, Global, Math, Number, Object 및 String 개체를 말합니다. 각 내부 개체는 연관되어 있는 메서드와 속성을 가지고 있으며, 이러한 메서드와 속성들은 언어 참조에 상세히 설명되어 있습니다. 일부 개체를 설명하면 다음과 같습니다.
Array 개체
JScript에서 개체는 배열로 다루고 배열은 개체로 다룹니다. 개체의 속성과 완전히 일치하는 배열의 아래 첨자는 숫자에 의해 참조될 수 있으며, 이름을 배열의 아래 첨자에 지정하면 이름에 의해 참조될 수 있습니다. 새 배열을 만들려면 아래 예제와 같이 new 연산자와 Array() 구성자를 사용합니다.
var theMonths = new Array(12)  {
theMonths[0] = "Jan";
theMonths[1] = "Feb";
theMonths[2] = "Mar";
theMonths[3] = "Apr";
theMonths[4] = "May";
theMonths[5] = "Jun";
theMonths[6] = "Jul";
theMonths[7] = "Aug";
theMonths[8] = "Sep";
theMonths[9] = "Oct";
theMonths[10] = "Nov";
theMonths[11] = "Dec";
}
Array 키워드를 사용하여 배열을 만들 때 JScript는 배열에 있는 항목의 수를 기록하는 쓰기 전용 length 속성을 배열에 포함합니다. 숫자를 지정하지 않으면 길이는 0으로 설정되며 배열은 어떤 항목도 가지지 않습니다. 숫자를 지정하면 길이는 지정한 숫자로 지정됩니다. 두 개 이상의 매개 변수를 지정할 경우 매개 변수는 배열에서 항목으로 사용되며 매개 변수의 수는 아래 예제와 같이 length 속성에 지정되며 이것은 앞의 코드와 같습니다.
var theMonths = new Array("Jan", "Feb", "Mar", "Apr", "May", "Jun",
"Jul", "Aug", "Sep", "Oct", "Nov", "Dec");
Array 키워드로 만든 배열에 요소를 추가하면 JScript는 length 값을 자동으로 변경합니다.
String 개체
JScript에서 문자열은 개체입니다. 이것은 문자열 변수를 선언하거나 문자열 리터럴을 사용할 때마다 실제로 사용자가 하고 있는 일은 새 문자열 개체를 만들고 있다는 의미입니다. String 개체는 문자열과 함께 사용할 수 있는 내부 메서드를 가지고 있습니다. 이 중 하나가 문자열의 일부분을 반환하는 substring 메서드입니다. 이 메서드는 숫자 두 개를 메서드의 인수로 사용합니다.
aString = "0123456789";
var aChunk = aString.substring(4, 7);  // aChunk를 "456"에 지정합니다.
var aNotherChunk = aString.substring(7, 4);  // aNotherChunk를 "456"에 지정합니다.

// 앞에 나온 배열 만들기 예제 사용
firstLetter = theMonths [5].substring(0,1);  // firstLetter 변수를 "J"에 지정합니다.
String 개체의 다른 속성은 length 속성입니다. 이 속성은 문자열에서 문자 수를 포함하는데, 0은 빈 문자열을 의미합니다. 이것은 숫자 값이며 계산에 직접 사용할 수 있습니다.
var howLong = "Hello World".length  // howLong 변수를 11에 지정합니다.
Math 개체
Math 개체는 모두 미리 정의된 속성과 메서드를 가지고 있습니다. 속성은 특정 숫자이며, 이 중의 하나가 pi 값(약 3.14159...)입니다. 다음 예제에서 알 수 있는 것처럼 이것은 Math.PI 속성입니다.
// radius 변수가 숫자 값으로 선언되고 지정됩니다.
var circleArea = Math.PI * radius * radius;  // Math와 PI 글자의 첫자는 대문자입니다.
Math 개체의 내부 메서드 중 하나는 지수 메서드, 즉, 어떤 숫자에 거듭제곱을 위첨자로 올려 놓는 pow입니다. 아래 예제에서는 pi와 지수를 사용하고 있습니다.
// 이 공식은 주어진 반지름으로 구의 부피를 계산합니다.
volume = (4/3)*(Math.PI*Math.pow(radius,3));
Date 개체
오늘 날짜를 표시하거나 날짜들 사이의 차이를 계산하기 위하여 Date 개체를 사용합니다. 이 개체는 모두 미리 정의되어 있는 많은 속성과 메서드를 가지고 있습니다. 일반적으로 Date 개체는 요일, 일, 월, 연도, 시, 분, 초를 제공합니다. 그리고 이 정보는 1970년 1월 1일, 00:00:00.000 GMT를 기준으로 하여 밀리초 단위까지 제공됩니다. 여기서 GMT는 "그리니치 표준시(Greenwich Mean Time)"를 의미합니다. 이 표현보다 좀 더 많이 사용하는 용어는 UTC 또는 "협정 세계 표준시"로, 이 시간은 WTS(World Time Standard-세계 시간 표준)에서 나오는 신호를 말합니다.

메모 JScript의 경우 시간은 1970년 1월 1일 자정부터 시작합니다. JScript는 그보다 더 이른 시간을 나타내는 Date 개체는 만들 수 없습니다. 더 이른 시간을 나타내려면 사용자 자신이 코드를 만들어야만 하는데 그것은 만만찮은 일입니다.

새로운 Date 개체를 만들려면 new 연산자를 사용해야 합니다. 아래 예제에서는 현재 연도의 지나간 날짜 수와 남은 날짜 수를 계산합니다.

/*
이 예제에서는 이전에 정의한 월 이름의 배열을 사용합니다.
첫째 문에서는 오늘 날짜를 thisIsToday 변수에 "Day Month Date 00:00:00 Year" 형식으로 지정합니다.
*/
var thisIsToday = new Date();

var toDay = new Date();  // 오늘 날짜로 변환합니다.

// 연도, 월, 일을 추출합니다.
var thisYear = toDay.getYear() + 1900;
var thisMonth = theMonths[toDay.getMonth()];
var thisDay = thisMonth  + " " + toDay.getDate() + "," + (parseInt(toDay.getYear()) + 1900);

// 시작일부터 날짜 수를 구합니다.
thisDay = Math.round(Date.parse(thisDay)/8.64e7);

// 한 해의 시작일에 대해 동일한 작업을 수행합니다.
var firstDay = "1월 1일, " + thisYear;
firstDay = Math.floor(Date.parse(firstDay)/8.64e7);

// 윤년이 될 경우를 대비하여 한 해의 마지막 날에 대하여 동일한 작업을 다시 합니다.
var lastDay = "12월 31일, " + thisYear;
lastDay = Math.floor(Date.parse(lastDay)/8.64e7);

// 해당 연도의 날짜 수를 계산합니다.
var daysInYear = (lastDay - firstDay) + 1;

// 경과한 날과 남은 날을 구합니다.
var daysElapsed = thisDay - firstDay;
var daysLeft = daysInYear - daysElapsed;

// 대부분의 연도에 대한 주석을 설정합니다.
var comment1 = daysElapsed+ "일이 경과했습니다.";
var comment2 = "이것은 " + thisYear + "년에 " + daysLeft + "일이 남았음을 의미합니다" + ".";

// 특별한 경우도 포함합니다: 한 해의 시작과 마지막, 하루
if (daysElapsed == 0)  {
comment1 = "1월 1일, " + thisYear + "입니다.";
}
if (daysElapsed == 1) {
comment1 = "지금까지 하루만 지났습니다.";
}
if(daysElapsed == daysInYear) {
comment1 = thisYear + "년은 방금 지나갔습니다.";
}

if (daysLeft == 0)  {
comment2 = "새해에는 좋은 일만 생기기를 바랍니다!";
}
if (daysLeft == 1)  {
comment2 = thisYear + "년은 하루만 남았습니다" + ".";
}
if (daysLeft == daysInYear)  {
comment2 = "희망찬 새해를 기원합니다!";
}
Number 개체
Microsoft JScript는 Math 개체에서 사용할 수 있는 특별한 숫자 속성(예: PI)뿐만 아니라 Number 개체를 통하여 몇 가지 다른 속성들을 제공합니다.

속성 | 설명
MAX_VALUE 가능한 가장 큰 숫자이며, 약 1.79E+308입니다. 양수일 수도 있고 음수일 수도 있습니다. 이 값은 시스템마다 약간씩 다릅니다.
MIN_VALUE | 가능한 가장 작은 숫자이며, 약 2.22E-308입니다. 양수일 수도 있고 음수일 수도 있습니다. 이 값은 시스템마다 약간씩 다릅니다.
NaN | 숫자가 아닌 특별한 값입니다.
POSITIVE_INFINITY | Number. MAX_VALUE보다 큰 양수는 모두 자동으로 이 값으로 변환됩니다. "Inf"로 표시됩니다.
NEGATIVE_INFINITY | -Number.MAX_VALUE보다 큰 음수는 모두 자동으로 이 값으로 변환됩니다. "-Inf"로 표시됩니다.

Number.NaN은 "NaN(숫자 아님)"으로 정의되는 특별한 속성입니다. 예를 들어 0으로 나누면 NaN을 반환합니다. 숫자로 구문 분석할 수 없는 문자열을 구문 분석할 때도 Number.NaN을 반환합니다. NaN은 어떤 숫자와도 다르며 그 자신과도 다릅니다. NaN 결과를 검사하려면 Number.NaN과 비교하지 말고 isNaN() 함수를 사용하십시오.


개체 직접 만들기

개체 직접 만들기
 JScript 자습서
이전

개체의 인스턴스를 만들려면 개체에 속성과 필요에 따라 메서드를 지정하여 개체를 정의해야 합니다. 아래 예제에서는 pasta 개체를 정의합니다. this 키워드는 현재 개체를 지칭하기 위해 사용합니다.
function pasta( grain, grain2, width, shape, shapenum, extent, egg )
{
  this.length = 7;   // 이 개체의 속성 수. length는 속성 수에 포함되지 않습니다.
  this.grain = grain;   // 파스타는 어떤 곡물로 만듭니까?(문자열)
  this.grain2 = grain2;   // 파스타에는 다른 곡물이 들어갑니까?(문자열)
  this.width = width;     // 파스타의 굵기는 얼마입니까?(숫자)
  this.shape = shape;   // 교차단면의 모양은 어떻습니까? (문자열)
  this.shapenum = shapenum;  // 파스타는 등록된 모양 중 하나입니까?(숫자)
  this.extent = extent;    // 파스타의 길이는 얼마입니까?(숫자)
  this.egg = egg;  // 파스타를 반죽할 때 달걀 노른자위를 넣습니까?(부울)
}
일단 개체를 정의하면 new 연산자를 사용하여 개체의 인스턴스를 만듭니다.
var spaghetti = new pasta("밀", "", 0.2, "원형", 9, 30, true);
var linguine = new pasta("밀", "", 0.3, "타원형", 17, 30, true);
개체의 한 인스턴스에 속성을 추가하면 해당 인스턴스를 변경할 수 있습니다. 그러나 이러한 속성은 개체 정의의 일부분이 될 수 않으며 속성을 특별히 추가하지 않는 한 다른 인스턴스에는 이러한 속성이 나타나지 않습니다. 개체의 모든 인스턴스에 추가 속성이 나타나도록 하려면 이들 속성을 개체 정의에 추가해야 합니다.
// 스파게티에 대한 추가 속성
spaghetti.color = "옅은 밀짚색";
spaghetti.drycook = 7;
spaghetti.freshcook = 0.5;

var chowFun = new pasta("쌀", "", 3, "기본", , 12, false);
/*
chowFun 개체, linguine 개체, pasta 개체 정의에는 spaghetti 개체에 지정되어 있는 세 가지 추가 속성이 없습니다.
*/
정의에 메서드 포함하기
메서드를 개체 정의에 포함시킬 수 있습니다. 아래 예제에서는 문자열 배열과 메서드로 구성된 개체를 만듭니다. 메서드는 문자열을 배열에 추가시키는데, 이 때 크기를 증가시킵니다. 이렇게 하면 개체의 인스턴스를 무한대로 확장시킬 수 있습니다.
function addItem(newItem)  // 목록을 확장시킬 함수를 정의합니다.
{
    this.length += 1;  // 배열의 길이를 늘입니다.
    this[(this.length-1)] = newItem;  // 새 항목을 추가하고 항목에 번호를 매깁니다
}

function shoppingList(firstItem) // "shopping list" 개체를 정의합니다.
{
    this.length = 2;  // 개체의 속성 수. length는 속성 수에 포함되지 않습니다.
    this.addItem = addItem;   // 메서드로 addItem 함수를 포함합니다.
    this[(this.length-1)] = firstItem;  // 첫째 항목은 1입니다.
}

var myList = new shoppingList("우유");
myList.addItem("달갈");  // 메서드를 사용하여 달걀을 추가하고 이것은 항목 2가 됩니다.
myList.addItem("빵나무");  // 빵나무는 항목 3이 됩니다.
여기서 배열의 내용은 다음과 같습니다.
  • myList[length]는 4입니다
  • myList[addItem]는 addItem 함수입니다
  • myList[1]는 우유입니다
  • myList[2]는 달걀입니다
  • myList[3]는 빵나무입니다
인덱스는 엄격하게 숫자 방식으로 처리된다 하더라도 기대만큼 정확하지 않습니다. 이 배열에 for...in 루프를 실행하면 루프는 여기에 주어진 순서대로 루프를 반복하고 루프 변수는 초기 값으로 0이 아니라 "length"를 가지게 됩니다.


FileSystemObject 용어

Microsoft® Scripting Library - FileSystemObject
FileSystemObject 용어 		Scripting 런타임 참조

런타임 오류(run-time error)
코드 실행 중 발생하는 오류입니다. 런타임 오류는 잘못된 연산을 수행하는 문이 있을 경우 발생합니다.

문자식(string expression)
일련의 연속적인 문자로 평가되는 모든 식입니다. 문자식의 요소에는 문자열, 문자열 리터럴, 문자열 상수, 또는 문자열 변수를 반환하는 함수를 사용할 수 있습니다.

배열(array)
데이터 형식이 같은 요소를 순차적인 인덱스로 묶은 집합입니다. 각 배열 요소에는 고유한 확인 인덱스 번호가 있습니다. 배열 안에 있는 한 요소를 변경해도 다른 요소들은 영향을 받지 않습니다.

컬렉션(collection)
관련된 개체 집합이 들어있는 개체입니다. 컬렉션에 변경 사항이 있을 때마다 컬렉션에 있는 개체의 위치가 바뀌므로 컬렉션에 있는 특정 개체의 위치는 매번 달라질 수 있습니다.

형식 라이브러리(type library)
노출된 개체, 속성, 메서드에 대한 표준 설명이 들어있는 다른 파일 안의 파일이나 구성 요소입니다.


JScript 용어

JScript 용어 		언어 참조

구성자(constructor)
다음 2가지 특별한 기능을 가진 Jscript 함수입니다.
  • Jscript 함수는 new 연산자에 의해 호출됩니다.
  • Jscript 함수는 this 키워드를 통해 새로 작성된 개체의 주소를 전달합니다.
새 개체를 초기화할 때 구성자를 사용합니다.

내부 개체(intrinsic object)
표준 Jscript 언어의 일부인 개체로, 모든 스크립트에서 사용할 수 있습니다. JScript 내부 개체에는 Array, Boolean, Date, Function, Global, Math, Number, Object, RegExp, Regular Expression, String이 있습니다.

래퍼(wrapper)
일부 다른 데이터 형식에 개체 스타일 인터페이스를 제공하기 위해 만든 개체입니다. 래퍼 개체에는 Number 개체와 Boolean 개체가 있습니다.

로컬 시간(local time)
스크립트를 실행하는 클라이언트나 서버의 시스템 시간입니다.

로케일(locale)
제공되는 언어와 국가/지역에 해당하는 일단의 정보입니다. 로케일은 사전에 정의되는 프로그래밍 용어의 언어와 로케일 특정의 설정에 영향을 미칩니다. 로케일 정보가 중요한 두 가지 상황이 있습니다.
  • 코드 로케일은 키워드와 같은 용어의 언어에 영향을 미쳐 소수점과 목록 구분 기호, 날짜 형식 및 문자 정렬 순서 등의 로케일 특정의 설정을 정의합니다.
  • 시스템 로케일은 로케일 인식 기능을 작동시키는 방식에 영향을 미칩니다. 예를 들어, 숫자를 표시하거나 문자열을 날짜로 변환하는 경우입니다. 운영 체제에서 제공하는 제어판 유틸리티를 사용하여 시스템 로케일을 설정합니다.

런타임 오류(run-time error)
코드 실행 중 발생하는 오류입니다. 프로그램의 문이 잘못된 연산을 시도할 때 발생합니다.

문자식(string expression)
일련의 연속적인 문자열을 평가하는 식입니다. 문자식의 요소에는 문자열, 문자열 리터럴, String 개체 또는 문자열 변수를 반환하는 함수를 사용할 수 있습니다.

문자열 비교(string comparison)
2개의 문자열을 비교합니다. 비교를 수행하는 함수에 지정하지 않으면 모든 문자열 비교는 이진으로 합니다. 영어의 경우 이진 비교는 대/소문자를 구분하지만 텍스트 비교는 대/소문자를 구분하지 않습니다.

문자 코드(character code)
ASCII 문자 집합과 같이 특정 문자 집합을 나타내는 일련의 숫자입니다.

범위(scope)
변수, 프로시저, 또는 개체의 가시성을 정의합니다. 함수에서 선언된 변수들은 해당 함수 내에서만 볼 수 있고 호출과 호출 사이에는 값들을 잃습니다.

변수(variable)
이름으로 값을 저장하고 조정하는 데 사용하는 위치입니다. JScript는 형식 제한이 적어서 스크립트 전체를 통해 변수 하나에 여러 종류의 데이터 형식을 사용할 수 있습니다.

복합문(compound statement)
중괄호({})로 묶이는 일련의 문입니다. 문 하나를 써서 여러 작업을 수행해야 할 때 사용할 수 있습니다.

부울식(Boolean expression)
true 또는 false로 평가되는 식입니다. 부울식이 아닌 식은 필요하면 다음 규칙에 따라 부울값으로 변환됩니다.
  • 모든 개체는 true로 간주합니다.
  • 문자열은 비어있는 경우에만 false로 간주합니다.
  • null 및 undefined는 false로 간주합니다.
  • 숫자가 있거나 0인 경우에는 false로 간주합니다.

비교 연산자(comparison operator)
둘 이상의 값이나 식 사이의 관계를 나타내는 문자나 기호입니다. 비교 연산자에는 보다 작다(<), 작거나 같다(<=), 보다 크다(>), 크거나 같다(>=), 같지 않다(!=), 같다(==)가 있습니다.

비트 비교(Bitwise comparison)
두 수식에서 같은 위치에 있는 비트를 비트별로 비교합니다.

사용자 정의 개체(user-defined object)
원본 코드에서 사용자가 만드는 개체입니다.

속성(property)
이름이 정해진 개체 특성입니다. 속성은 크기, 색, 화면 위치, 사용 또는 사용 안함과 같은 개체의 상태 등 개체의 특성을 정의합니다.

수식(numeric expression)
숫자로 평가될 수 있는 식입니다. 식의 요소에는 숫자를 산출하는 키워드, 변수, 리터럴, 연산자의 조합이 포함됩니다. 경우에 따라 문자열도 가능하면 숫자로 변환됩니다.

식(expression)
문자열, 숫자, 또는 개체를 만드는 키워드, 연산자, 변수, 리터럴의 조합입니다. 계산을 하거나, 문자를 조정하거나, 함수를 호출하거나, 데이터를 테스트합니다.

원시(primitive)
Jscript 언어의 일부이며 값에 따라 조정되는 데이터 형식입니다. JScript에서 원시로 간주하는 데이터 형식에는 Number, Boolean, String, Function이 있습니다. 개체와 배열은 원시 데이터 형식이 아닙니다.

자동화 개체(Automation object)
자동화 인터페이스를 통해 다른 응용 프로그램이나 프로그래밍 도구에 노출되는 개체입니다.

주석(comment)
코드 사용법을 설명하기 위해 프로그래머가 코드에 추가하는 텍스트입니다. JScript에서 주석줄은 보통 //로 시작합니다. 여러 줄로 된 주석문을 만들려면 /*와 */ 구분 기호를 사용합니다.

클래스(class)
개체의 형식을 정의합니다. 런타임 시 개체의 인스턴스를 만드는 템플릿 역할을 합니다. 클래스는 개체의 속성과 그 개체의 동작을 제어하는 데 사용하는 메서드를 정의합니다.

협정 세계 표준시(UTC: Universal Coordinated Time)
협정 세계 표준시는 WTS(세계 시간 표준)이 설정한 시간을 말하며, 그리니치 표준시(GMT)라고도 합니다.

ASCII 문자 집합(ASCII Character set)
ASCII(정보 교환용 미국 표준 코드)로 표준 영문 키보드에 있는 문자와 기호를 나타내는 데 사용하는 7비트 문자 집합입니다. ASCII 문자 집합은 ANSI 문자 집합의 앞 부분에 나오는 128자(0-127)와 같습니다.

Undefined
변수를 만든 후 변수에 값을 지정하기 전에 주어진 특별한 값입니다.


연산자 동작

연산자 동작 		언어 참조
버전 1

아래 표에는 대부분의 Microsoft JScript 연산자들의 동작이 설명되어 있습니다. 각 열과 행은 JScript 연산자 중 어느 쪽에서든 사용 가능한 서로 다른 형식의 식을 나타내며, 각 표의 항목은 동작에 대한 설명을 나타냅니다.

E는 런타임 오류를 나타냅니다. N은 숫자 결과나 논리 연산자로 사용된 경우에는 부울 결과를 나타냅니다.

obj | as | ns | num | bool | undef | null
obj | N | E | N | N | N | E | E
as | E | E | E | E | E | E | E
ns | N | E | N | N | N | E | E
num | N | E | N | N | N | E | E
bool | N | E | N | N | N | E | E
undef | E | E | E | E | E | E | E
null | E | E | E | E | E | E | E

obj = 개체, as = 영숫자 문자열, ns = 숫자 문자열, num = 숫자, bool = 부울, undef = undefined, null = null 값


concat 메서드(Array)

concat 메서드(Array) 		언어 참조
버전 3

참고 적용 대상

설명
두 배열의 조합으로 구성된 새 배열을 반환합니다.
구문
array1.concat(array2)

concat 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
array1 | 필수적인 요소. array2와 연결할 Array 개체입니다.
array2 | 필수적인 요소. array1의 끝에 연결할 Array 개체입니다.

참고
concat 메서드는 array1과 array2의 조합으로 구성된 Array 개체를 반환합니다.

array1이나 array2에서 결과로 나오는 배열로 개체 참조를 복사한 경우, 결과로 나오는 배열에 있는 개체 참조는 같은 개체를 가리킵니다. 해당 개체의 변경 내용은 두 배열 모두에 반영됩니다.

아래 예제는 concat 메서드의 사용법을 보여줍니다.

function ConcatArrayDemo()
{
  var a, b, c;
  a = new Array(0,1,2,3,4);
  b = new Array(5,6,7,8,9);
  c = a.concat(b);
  return(c);
}


concat 메서드(Array)

concat 메서드(Array)
적용 대상 		언어 참조

Array 개체
String 개체


concat 메서드(Array)

concat 메서드(Array)
참고 		언어 참조

concat 메서드(String)
join 메서드


join 메서드

join 메서드 		언어 참조
버전 2

참고 적용 대상

설명
배열 하나에 함께 연결된 모든 요소로 구성된 String 개체를 반환합니다.
구문

arrayobj.join(separator)

separator 인수는 배열 요소와 결과로 나오는 String 개체의 다음 요소를 구분하는 데 사용하는 String 개체입니다. 생략하면 배열 요소들은 빈 문자열로 구분됩니다.

참고
join 메서드는 문자열로 변환되어 함께 결합된 각 요소를 포함하는 String 개체를 반환합니다.

아래 예제는 join 메서드의 사용법을 보여줍니다.

function JoinDemo()
{
  var a, b;
  a = new Array(0,1,2,3,4);
  b = a.join("-");
  return(b);
}


join 메서드

join 메서드
적용 대상 		언어 참조

Array 개체


join 메서드

join 메서드
참고 		언어 참조

Array 개체 메서드
String 개체


length 속성(Array)

length 속성(Array) 		언어 참조
버전 2

참고 적용 대상

설명
배열에 정의된 요소의 최고값보다 하나 큰 정수 값을 반환합니다.
구문

numVar = arrayObj.length

참고
배열의 요소가 항상 연속적인 것은 아니기 때문에 length 속성도 항상 배열의 요소 수를 정확히 나타내는 것은 아닙니다. 예를 들어, 다음과 같은 배열 정의에서 my_array.length에는 2가 아닌 7이 포함됩니다.
var my_array = new Array( );
my_array[0] = "Test";
my_array[6] = "Another Test";
이전 값보다 작은 값을 length 속성에 지정하면 배열이 잘리고, 새로운 length 속성 값과 같거나 큰 배열 인덱스를 갖고 있는 요소들이 손실됩니다.

이전 값보다 큰 값을 length 속성에 지정하면 배열이 확장되고 새로 작성된 요소는 undefined 값을 갖게 됩니다.

아래 예제는 length 속성의 사용법을 보여줍니다.

function LengthDemo()
{
  var a, l;
  a = new Array(0,1,2,3,4);
  l = a.length;
  return(l);
}


length 속성(Array)

length 속성(Array)
적용 대상 		언어 참조

Array 개체


length 속성(Array)

length 속성(Array)
참고 		언어 참조

length 속성(Function)
length 속성(String)


reverse 메서드

reverse 메서드 		언어 참조
버전 2

참고 적용 대상

설명
요소들이 역으로 나열된 Array 개체를 반환합니다.
구문
arrayobj.reverse( )
참고
reverse 메서드는 Array 개체의 요소들을 역으로 나열합니다. 실행 도중에 새 Array 개체를 작성하지는 않습니다.

배열이 연속적이지 않은 경우 reverse 메서드는 배열 내의 틈을 채우는 요소를 작성합니다. 이렇게 작성한 요소들은 undefined 값을 갖습니다.

아래 예제는 reverse 메서드의 사용법을 보여줍니다.

function ReverseDemo()
{
  var a, l;
  a = new Array(0,1,2,3,4);
  l = a.reverse();
  return(l);
}


reverse 메서드

reverse 메서드
적용 대상 		언어 참조

Array 개체


reverse 메서드

reverse 메서드
참고 		언어 참조

Array 개체 메서드


slice 메서드(Array)

slice 메서드(Array) 		언어 참조
버전 3

참고 적용 대상

설명
배열의 일정 부분을 반환합니다.
구문
arrayObj.slice(start, [end])

slice 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
arrayObj | 필수적인 요소. Array 개체입니다.
start | 필수적인 요소. arrayObj에 지정된 부분의 시작을 0에서 시작하여 나타내는 인덱스입니다.
end | 선택적인 요소. arrayObj에 지정된 부분의 끝을 0에서 시작하여 나타내는 인덱스입니다.

참고
slice 메서드는 arrayObj에 지정된 부분을 포함하는 Array 개체를 반환합니다.

slice 메서드는 end로 표시된 요소 앞까지만 복사하고 요소 부분은 포함하지 않습니다. 만일 음수가 사용되면 end는 arrayObj 끝에서 오프셋을 나타냅니다. 또한 이 값은 0에서 시작하는 값이 아닙니다. 생략하면 arrayObj의 끝까지 계속 추출됩니다.

아래 예제에서는 myArray의 마지막 요소를 제외한 모든 부분을 newArray로 복사합니다.

newArray = myArray.slice(0, -1)
만일 개체 참조를 arrayObj에서 결과 배열로 복사해도 결과 배열에 있는 개체 참조는 전과 동일한 개체를 가리킵니다. 해당 개체의 변경 내용은 두 배열에 모두 반영됩니다.


slice 메서드

slice 메서드
적용 대상 		언어 참조

Array 개체
String 개체


slice 메서드

slice 메서드
참고 		언어 참조

slice 메서드(String)


sort 메서드

sort 메서드 		언어 참조
버전 2

참고 적용 대상

설명

요소들이 정렬된 Array 개체를 반환합니다.

구문
arrayobj.sort(sortfunction)

sortfunction 인수는 요소 순서를 결정하는 데 사용되는 함수의 이름입니다. 생략하면 요소는 ASCII 문자 순서에 따라 오름차순으로 정렬됩니다.

참고
sort 메서드는 Array 개체를 정렬하여 반환합니다. 실행 도중에 새로운 Array 개체를 생성하지는 않습니다.

sortfunction 인수에 함수를 지정하면 다음 값들 중 하나가 반환되어야 합니다.

  • 처음 전달된 인수가 둘째 인수보다 작으면 음수값
  • 두 인수가 같으면 0
  • 처음 전달된 인수가 둘째 인수보다 크면 양수값

아래 예제는 sort 메서드의 사용법을 보여줍니다.

function SortDemo()
{
  var a, l;
  a = new Array("X" ,"y" ,"d", "Z", "v","m","r");
  l = a.sort();
  return(l);
}


sort 메서드

sort 메서드
적용 대상 		언어 참조

Array 개체


sort 메서드

sort 메서드
참고 		언어 참조

Array 개체 메서드


Drives 컬렉션

Drives 컬렉션 		Scripting 런타임 참조
버전 3

참고 속성 메서드

설명
사용할 수 있는 모든 드라이브의 읽기 전용 컬렉션입니다.
참고
Drives 컬렉션에 이동식 매체 드라이브를 표시하기 위해 그 드라이브에 매체를 삽입할 필요는 없습니다.

아래 코드에서는 Drives 속성을 사용하는 Drives 컬렉션을 가져와서 Enumerator 개체를 사용하는 컬렉션을 반복 실행하는 방법을 보여줍니다.

function ShowDriveList()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  for (; !e.atEnd(); e.moveNext())
  {
    x = e.item();
    s = s + x.DriveLetter;
    s += " - ";
    if (x.DriveType == 3)
      n = x.ShareName;
    else if (x.IsReady)
      n = x.VolumeName;
    else
      n = "[드라이브가 준비되지 않았습니다.]";
    s +=  n + "<br>";
  }
  return(s);
}


Drives 컬렉션

Drives 컬렉션
참고 		Scripting 런타임 참조

Drive 개체
Drives 속성
File 개체
Files 컬렉션
Folder 개체
Folders 컬렉션


Drives 컬렉션

Drives 컬렉션
메서드 		Scripting 런타임 참조

Drives 컬렉션에는 메서드가 없습니다.


Drives 컬렉션

Drives 컬렉션
속성 		Scripting 런타임 참조

Count 속성
Item 속성


Files 컬렉션

Files 컬렉션 		Scripting 런타임 참조
버전 3

참고 속성 메서드

설명
폴더 안에 있는 모든 File 개체의 컬렉션입니다.
참고
아래 코드에서는 Files 컬렉션을 가져와서 Enumerator 개체와 for 문을 사용하여 그 컬렉션을 반복 실행하는 방법을 보여줍니다.
function ShowFolderFileList(folderspec)
{
  var fso, f, f1, fc, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(folderspec);
  fc = new Enumerator(f.files);
  s = "";
  for (; !fc.atEnd(); fc.moveNext())
  {
      s += fc.item();
      s += "<br>";
  }
  return(s);
}


Files 컬렉션

Files 컬렉션
참고 		Scripting 런타임 참조

Drive 개체
Drives 컬렉션
File 개체
Folder 개체
Folders 컬렉션


Files 컬렉션

Files 컬렉션
메서드 		Scripting 런타임 참조

Files 컬렉션에는 메서드가 없습니다.


Files 컬렉션

Files 컬렉션
속성 		Scripting 런타임 참조

Count 속성
Item 속성


Folders 컬렉션

Folders 컬렉션 		Scripting 런타임 참조
버전 3

참고 속성 메서드

설명
Folder 안에 있는 모든 Folder 개체의 컬렉션입니다.
참고
아래 코드에서는 Folders 컬렉션을 가져와서 Enumerator 개체와 for 문을 사용하여 그 컬렉션을 반복 실행하는 방법을 보여줍니다.
function ShowFolderList(folderspec)
{
  var fso, f, fc, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(folderspec);
  fc = new Enumerator(f.SubFolders);
  s = "";
  for (; !fc.atEnd(); fc.moveNext())
  {
    s += fc.item();
    s += "<br>";
  }
  return(s);
}


Folders 컬렉션

Folders 컬렉션
참고 		Scripting 런타임 참조

Drive 개체
Drives 컬렉션
File 개체
Files 컬렉션
Folder 개체
SubFolders 속성


Folders 컬렉션

Folders 컬렉션
메서드 		Scripting 런타임 참조

Add 메서드(Folders)


Folders 컬렉션

Folders 컬렉션
속성 		Scripting 런타임 참조

Count 속성
Item 속성


조건부 컴파일

조건부 컴파일 		언어 참조
버전 3

참고

설명
새로운 JScript 언어 기능을 사용할 수 있도록 하면서 동시에 해당 기능을 지원하지 않는 브라우저들과의 호환성을 유지시켜 줍니다.
참고
조건부 컴파일 기능은 @cc_on 문을 사용하거나 주석 외부에 @if 또는 @set 문을 사용하여 활성화됩니다. 조건부 컴파일은 보통 JScript의 새 기능을 사용하거나, 스크립트에 디버깅 지원을 포함하거나, 코드 실행을 추적할 때 주로 사용합니다.

조건부 컴파일 코드는 가능한 한 주석 내부에 두는 것이 좋습니다.

/*@cc_on @*/
/*@if (@_jscript_version == 4)
   alert("JScript 버전 4");
   @else @*/
   alert("최신 스크립팅 엔진을 사용하십시오.");
/*@end @*/
이 예제에서는 @cc_on 문으로 조건부 컴파일 기능이 활성화된 경우에만 사용되는 특수한 주석 구분 기호를 사용하고 있습니다. 조건부 컴파일을 이해하지 못하는 스크립팅 엔진에서는 새 스크립팅 엔진이 필요하다는 내용의 메시지만 나옵니다.


조건부 컴파일

조건부 컴파일
참고 		언어 참조

조건부 컴파일
@cc_on 문
@if 문
@set 문


조건부 컴파일 변수

조건부 컴파일 변수 		언어 참조
버전 3

참고

조건부 컴파일에 아래와 같이 미리 정의된 변수를 사용할 수 있습니다. true가 아닌 변수는 정의된 것이 아니며 액세스하면 NaN으로 작용합니다.

변수 | 설명
@_win32 | Win32 시스템에서 실행하면 true입니다.
@_win16 | Win16 시스템에서 실행하면 true입니다.
@_mac | Apple Macintosh 시스템에서 실행하면 true입니다.
@_alpha | DEC Alpha 프로세서에서 실행하면 true입니다.
@_x86 | Intel 프로세서에서 실행하면 true입니다.
@_mc680x0 | Motorola 680x0 프로세서에서 실행하면 true입니다.
@_PowerPC | Motorola PowerPC 프로세서에서 실행하면 true입니다.
@_jscript | 항상 true입니다.
@_jscript_build | JScript 스크립팅 엔진 작성 번호를 포함합니다.
@_jscript_version | 주 번호.보조 번호 형식의 JScript 버전 번호를 포함합니다.


조건부 컴파일 변수

조건부 컴파일 변수
참고 		언어 참조

조건부 컴파일
@cc_on 문
@if 문
@set 문


jscopy

저작권

이 설명서의 내용은 예고 없이 변경될 수 있습니다. 별도 설명이 없는 한 여기에 인용된 회사, 제품, 사람 및 캐릭터의 이름 및/또는 데이터는 실제 데이터가 아니며 어떠한 실제 회사, 제품, 사람, 또는 이벤트를 나타낼 의도가 전혀 없습니다. 해당 저작권법을 준수하는 것은 사용자의 책임입니다. 이 설명서의 어떠한 부분도 Microsoft의 명시적인 서면 승인 없이는 어떠한 형식이나 수단(전기적, 기계적) 또는 목적으로도 복제되거나, 전송될 수 없습니다.

Microsoft가 이 설명서 본안에 관련된 특허권, 상표권, 저작권, 또는 기타 지적 소유권 등을 보유할 수도 있습니다. 서면 사용권 계약에 따라 마이크로소프트로부터 귀하에게 명시적으로 제공된 권리 이외에, 이 설명서의 제공은 귀하에게 이러한 특허권, 상표권, 저작권, 또는 기타 지적 소유권 등에 대한 어떠한 사용권도 허여하지 않습니다.

© 1991-1999 Microsoft Corporation. All rights reserved.

Microsoft, MS, MS-DOS, ActiveX, JScript, Microsoft Press, Visual Basic, Windows, Windows NT, Win32, Win32s는 미국, 대한민국, 및/또는 기타 국가에서의 Microsoft Corporation의 등록 상표 또는 상표입니다.

여기에 인용된 실제 회사와 제품 이름은 해당 소유자의 상표일 수 있습니다.


getDate 메서드

getDate 메서드 		언어 참조
버전 1

참고 적용 대상

설명

로컬 시간을 사용하여 Date 개체의 날짜 값을 반환합니다.

구문
objDate.getDate()
참고
협정 세계 표준시(UTC)를 사용하여 날짜 값을 가져오려면 getUTCDate 메서드를 사용하십시오.

반환값은 Date 개체의 날짜 값을 나타내는 1부터 31까지의 정수입니다.

아래 예제는 getDate 메서드의 사용법을 보여줍니다.

function DateDemo()
{
  var d, s = "오늘 날짜: ";
  d = new Date();
  s += (d.getMonth() + 1) + "/";
  s += d.getDate() + "/";
  s += d.getYear();
  return(s);
}


getDate 메서드

getDate 메서드
적용 대상 		언어 참조

Date 개체


getDate 메서드

getDate 메서드
참고 		언어 참조

Date 개체 메서드
getUTCDate 메서드
setDate 메서드
setUTCDate 메서드


getDay 메서드

getDay 메서드 		언어 참조
버전 1

참고 적용 대상

설명
로컬 시간을 사용하여 Date 개체의 요일 값을 반환합니다.
구문
objDate.getDay()
참고
협정 세계 표준시(UTC)를 사용하여 요일 값을 가져오려면 getUTCDay 메서드를 사용하십시오.

getDay 메서드에서 반환되는 값은 아래와 같이 요일을 나타내는 0부터 6까지의 정수입니다.

0 = 일요일
1 = 월요일
2 = 화요일
3 = 수요일
4 = 목요일
5 = 금요일
6 = 토요일

아래 예제는 getDay 메서드의 사용법을 보여줍니다.

function DateDemo()
{
  var d, day, x, s = "오늘은: ";
  var x = new Array("일요일", "월요일", "화요일");
  var x = x.concat("수요일","목요일", "금요일");
  var x = x.concat("토요일");
  d = new Date();
  day = d.getDay();
  return(s += x[day]);
}


getDay 메서드

getDay 메서드
적용 대상 		언어 참조

Date 개체


getDay 메서드

getDay 메서드
참고 		언어 참조

Date 개체 메서드
getUTCDay 메서드


getFullYear 메서드

getFullYear 메서드 		언어 참조
버전 3

참고 적용 대상

설명
로컬 시간을 사용하여 Date 개체의 연도 값을 반환합니다.
구문
objDate.getFullYear()
참고
협정 세계 표준시(UTC)를 사용하여 연도 값을 가져오려면 getUTCFullYear 메서드를 사용하십시오.

getFullYear 메서드는 연도를 네 자릿수 전체로 반환합니다. 예를 들어, 1976년은 1976으로 반환합니다. 이렇게 하면 20세기가 끝날 무렵에 생기는 날짜 문제를 피할 수 있습니다.

아래 예제는 GetFullYear 메서드의 사용법을 보여줍니다.

function DateDemo()
{
  var d, s = "오늘의 UTC 날짜: ";
  d = new Date();
  s += (d.getMonth() + 1) + "/";
  s += d.getDate() + "/";
  s += d.getFullYear();
  return(s);
}


getFullYear 메서드

getFullYear 메서드
적용 대상 		언어 참조

Date 개체


getFullYear 메서드

getFullYear 메서드
참고 		언어 참조

Date 개체 메서드
getUTCFullYear 메서드
setFullYear 메서드
setUTCFullYear 메서드


getHours 메서드

getHours 메서드 		언어 참조
버전 1

참고 적용 대상

설명
로컬 시간을 사용하여 Date 개체의 시 값을 반환합니다.
구문
objDate.getHours()
참고
협정 세계 표준시(UTC)를 사용하여 시 값을 가져오려면 getUTCHours 메서드를 사용하십시오.

getHours 메서드는 자정을 기점으로 시간 값을 0부터 23까지의 정수로 반환합니다. 0이 반환되는 경우는 시간이 오전 1:00:00 전이거나 Date 개체가 만들어 졌는데 이 개체에 시간이 저장되지 않은 경우 두 가지입니다. 어는 경우에 해당하는지 알아내는 방법은 분과 초 값 역시 0인지 확인하는 것 뿐입니다. 두 값이 모두 0이면 Date 개체에 시간이 저장되지 않은 것으로 볼 수 있습니다.

아래 예제는 getHours 메서드의 사용법을 보여줍니다.

function TimeDemo()
{
  var d, s = "현재 로컬 시간: ";
  var c = ":";
  d = new Date();
  s += d.getHours() + c;
  s += d.getMinutes() + c;
  s += d.getSeconds() + c;
  s += d.getMilliseconds();
  return(s);
}


getHours 메서드

getHours 메서드
적용 대상 		언어 참조

Date 개체


getHours 메서드

getHours 메서드
참고 		언어 참조

Date 개체 메서드
getUTCHours 메서드
setHours 메서드
setUTCHours 메서드


getMilliseconds 메서드

getMilliseconds 메서드 		언어 참조
버전 3

참고 적용 대상

설명
로컬 시간을 사용하여 Date 개체의 밀리초 값을 반환합니다.
구문
objDate.getMilliseconds()
참고
협정 세계 표준시(UTC)를 사용하여 밀리초 값을 가져오려면 getUTCMilliseconds 메서드를 사용하십시오.

반환되는 밀리초 값의 범위는 0부터 999까지입니다.

아래 예제는 getMilliseconds 메서드의 사용법을 보여줍니다.

function TimeDemo()
{
  var d, s = "현재 로컬 시간: ";
  var c = ":";
  d = new Date();
  s += d.getHours() + c;
  s += d.getMinutes() + c;
  s += d.getSeconds() + c;
  s += d.getMilliseconds();
  return(s);
}


getMilliseconds 메서드

getMilliseconds 메서드
적용 대상 		언어 참조

Date 개체


getMilliseconds 메서드

getMilliseconds 메서드
참고 		언어 참조

Date 개체 메서드
getUTCMilliseconds 메서드
setMilliseconds 메서드
setUTCMilliseconds 메서드


getMinutes 메서드

getMinutes 메서드 		언어 참조
버전 1

참고 적용 대상

설명
로컬 시간을 사용하여 Date 개체의 분 값을 반환합니다.
구문
objDate.getMinutes()
참고
협정 세계 표준시(UTC)를 사용하여 분 값을 가져오려면 getUTCMinutes 메서드를 사용하십시오.

getMinutes 메서드는 Date 개체에 저장된 분에 해당하는 0부터 59까지의 정수를 반환합니다. 0이 반환되는 경우는 정각에서 1분이 지나지 않았거나 Date 개체가 만들어 졌는데 이 개체에 시간이 저장되지 않은 경우 두 가지입니다. 어느 경우에 해당하는지 알아내는 방법은 시와 초 값 역시 0인지 확인하는 것 뿐입니다. 두 값이 모두 0이면 Date 개체에 시간이 저장되지 않은 것으로 볼 수 있습니다.

아래 예제는 getMinutes 메서드의 사용법을 보여줍니다.

function TimeDemo()
{
  var d, s = "현재 로컬 시간: ";
  var c = ":";
  d = new Date();
  s += d.getHours() + c;
  s += d.getMinutes() + c;
  s += d.getSeconds() + c;
  s += d.getMilliseconds();
  return(s);
}


getMinutes 메서드

getMinutes 메서드
적용 대상 		언어 참조

Date 개체


getMinutes 메서드

getMinutes 메서드
참고 		언어 참조

Date 개체 메서드
getUTCMinutes 메서드
setMinutes 메서드
setUTCMinutes 메서드


getMonth 메서드

getMonth 메서드 		언어 참조
버전 1

참고 적용 대상

설명
로컬 시간을 사용하여 Date 개체의 월 값을 반환합니다.
구문
objDate.getMonth()
참고
협정 세계 표준시(UTC)를 사용하여 월 값을 가져오려면 getUTCMonth 메서드를 사용하십시오.

getMonth 메서드는 Date 개체의 월 값을 나타내는 0부터 11까지의 정수를 반환합니다. 반환값은 실제 월 값보다 1이 작습니다. Date 개체에 "Jan 5, 1996 08:47:00"이 저장되어 있으면 getMonth 메서드는 0을 반환합니다.

아래 예제는 getMonth 메서드의 사용법을 보여줍니다.

function DateDemo()
{
  var d, s = "오늘 날짜: ";
  d = new Date();
  s += (d.getMonth() + 1) + "/";
  s += d.getDate() + "/";
  s += d.getYear();
  return(s);
}


getMonth 메서드

getMonth 메서드
적용 대상 		언어 참조

Date 개체


getMonth 메서드

getMonth 메서드
참고 		언어 참조

Date 개체 메서드
getUTCMonth 메서드
setMonth 메서드
setUTCMonth 메서드


getSeconds 메서드

getSeconds 메서드 		언어 참조
버전 1

참고 적용 대상

설명
로컬 시간을 사용하여 Date 개체의 초 값을 반환합니다.
구문
objDate.getSeconds()
참고
협정 세계 표준시(UTC)를 사용하여 초 값을 가져오려면 getUTCSeconds 메서드를 사용하십시오.

getSeconds 메서드는 Date 개체의 초 값을 나타내는 0부터 59까지의 정수를 반환합니다. 0이 반환되는 경우는 현재 분에서 1초가 지나기 전이거나 Date 개체가 만들어 졌는데 이 개체에 저장되지 않은 경우 두 가지입니다. 어느 경우에 해당하는지 알아내는 방법은 시와 분 값 역시 0인지 확인하는 것뿐입니다. 이 값이 모두 0이면 Date 개체에 시간이 저장되지 않은 것으로 볼 수 있습니다.

아래 예제는 getSeconds 메서드의 사용법을 보여줍니다.

function TimeDemo()
{
  var d, s = "현재 로컬 시간: ";
  var c = ":";
  d = new Date();
  s += d.getHours() + c;
  s += d.getMinutes() + c;
  s += d.getSeconds() + c;
  s += d.getMilliseconds();
  return(s);
}


getSeconds 메서드

getSeconds 메서드
적용 대상 		언어 참조

Date 개체


getSeconds 메서드

getSeconds 메서드
참고 		언어 참조

Date 개체 메서드
getUTCSeconds 메서드
setSeconds 메서드
setUTCSeconds 메서드


getTime 메서드

getTime 메서드 		언어 참조
버전 1

참고 적용 대상

설명
Date 개체의 시 값을 반환합니다.
구문
objDate.getTime()
참고
getTime 메서드는 1970년 1월 1일 자정과 Date 개체의 시간 값 사이의 시간을 밀리초 단위로 나타내는 정수 값을 반환합니다. 나타낼 수 있는 날짜 범위는 1970년 1월 1일 자정을 전후로 약 285,616년입니다. 음수는 해당 날짜가 1970년 이전임을 나타냅니다.

날짜와 시간을 여러 번 계산할 때는 밀리초 값에 해당하는 변수를 아래 예제와 같이 일, 시, 분으로 정의하는 것이 좋습니다.

var MinMilli = 1000 * 60
var HrMilli = MinMilli * 60
var DyMilli = HrMilli * 24
아래 예제는 getTime 메서드의 사용법을 보여줍니다.
function GetTimeTest()
{
  var d, s, t;
  var MinMilli = 1000 * 60;
  var HrMilli = MinMilli * 60;
  var DyMilli = HrMilli * 24;
  d = new Date();
  t = d.getTime();
  s = "70/1/1 이후로 "
  s += Math.round(t / DyMilli) + "일이 지났습니다.";
  return(s);
}


getTime 메서드

getTime 메서드
적용 대상 		언어 참조

Date 개체


getTime 메서드

getTime 메서드
참고 		언어 참조

Date 개체 메서드
setTime 메서드


getTimezoneOffset 메서드

getTimezoneOffset 메서드 		언어 참조
버전 1

참고 적용 대상

설명

호스트 컴퓨터의 시간과 협정 세계 표준시(UTC) 사이의 시간차를 분으로 반환합니다.

구문
objDate.getTimezoneOffset()
참고
getTimezoneOffset 메서드는 현재 컴퓨터와 UTC 사이의 시간을 분 단위로 나타내는 정수 값을 반환합니다. 이 값들은 스크립트를 실행하는 컴퓨터에 적절합니다. 서버 스크립트에서 이 메서드를 호출하면 반환값은 서버에 적절하고 클라이언트 스크립트에서 이 메서드를 호출하면 반환값은 클라이언트에 적절합니다.

이 값은 현재 위치가 태평양 날짜 변경선처럼 UTC 뒤에 있으면 양수이고, 일본처럼 UTC 앞에 있으면 음수입니다.

예를 들어, 12월 1일에 LA에 있는 클라이언트에서 뉴욕에 있는 서버에 접속하는 경우 getTimezoneOffset을 클라이언트에서 실행하면 480이 반환되고, 서버에서 실행하면 300이 반환됩니다.

아래 예제는 getTimezoneOffset 메서드의 사용법을 보여줍니다.

function TZDemo()
{
  var d, tz, s = "현재 로컬 시간은 GMT보다";
  d = new Date();
  tz = d.getTimezoneOffset();
  if (tz < 0)
    s += tz / 60 + "시간 전입니다.";
  else if (tz == 0)
    s += "GMT";
  else
    s += tz / 60 + "시간 후입니다.";
  return(s);
}


getTimezoneOffset 메서드

getTimezoneOffset 메서드
적용 대상 		언어 참조

Date 개체


getTimezoneOffset 메서드

getTimezoneOffset 메서드
참고 		언어 참조

Date 개체 메서드


getUTCDate 메서드

getUTCDate 메서드 		언어 참조
버전 3

참고 적용 대상

설명
협정 세계 표준시(UTC)를 사용하여 Date 개체의 날짜 값을 반환합니다.
구문
objDate.getUTCDate()
참고
로컬 시간을 사용하여 날짜 값을 가져오려면 getDate 메서드를 사용하십시오.

반환값은 Date 개체의 날짜 값을 나타내는 1에서 31까지의 정수입니다.

아래 예제는 getUTCDate 메서드의 사용법을 보여줍니다.

function UTCDateDemo()
{
  var d, s = "오늘의 UTC 날짜: ";
  d = new Date();
  s += (d.getUTCMonth() + 1) + "/";
  s += d.getUTCDate() + "/";
  s += d.getUTCFullYear();
  return(s);
}


getUTCDate 메서드

getUTCDate 메서드
적용 대상 		언어 참조

Date 개체


getUTCDate 메서드

getUTCDate 메서드
참고 		언어 참조

Date 개체 메서드
getDate 메서드
setDate 메서드
setUTCDate 메서드


getUTCDay 메서드

getUTCDay 메서드 		언어 참조
버전 3

참고 적용 대상

설명
협정 세계 표준시(UTC)를 사용하여 Date 개체의 요일 값을 반환합니다.
구문
objDate.getUTCDay()
참고
로컬 시간을 사용하여 요일 값을 가져오려면 getDate 메서드를 사용하십시오.

getUTCDay 메서드에 의해 반환되는 값은 아래와 같이 요일을 나타내는 0부터 6까지의 정수입니다.

0 = 일요일
1 = 월요일
2 = 화요일
3 = 수요일
4 = 목요일
5 = 금요일
6 = 토요일
아래 예제는 getUTCDay 메서드의 사용법을 보여줍니다.
function DateDemo()
{
  var d, day, x, s = "오늘은 ";
  var x = new Array("일요일", "월요일", "화요일");
  x = x.concat("수요일","목요일", "금요일");
  x = x.concat("토요일");
  d = new Date();
  day = d.getUTCDay();
  return(s += x[day]);
}


getUTCDay 메서드

getUTCDay 메서드
적용 대상 		언어 참조

Date 개체


getUTCDay 메서드

getUTCDay 메서드
참고 		언어 참조

Date 개체 메서드
getDay 메서드


getUTCFullYear 메서드

getUTCFullYear 메서드 		언어 참조
버전 3

참고 적용 대상

설명
협정 세계 표준시(UTC)를 사용하여 Date 개체의 연도 값을 반환합니다.
구문
objDate.getUTCFullYear()
참고
로컬 시간을 사용하여 연도 값을 가져오려면 getFullYear 메서드를 사용하십시오.

getUTCFullYear 메서드는 연도를 네 자릿수 전체로 반환합니다. 이렇게 하면 20세기가 끝날 무렵에 생기는 날짜 문제를 피할 수 있습니다.

아래 예제는 getUTCFullYear 메서드의 사용법을 보여줍니다.

function UTCDateDemo()
{
  var d, s = "오늘의 UTC 날짜: ";
  d = new Date();
  s += (d.getUTCMonth() + 1) + "/";
  s += d.getUTCDate() + "/";
  s += d.getUTCFullYear();
  return(s);
}


getUTCFullYear 메서드

getUTCFullYear 메서드
적용 대상 		언어 참조

Date 개체


getUTCFullYear 메서드

getUTCFullYear 메서드
참고 		언어 참조

Date 개체 메서드
getFullYear 메서드
setFullYear 메서드
setUTCFullYear 메서드


getUTCHours 메서드

getUTCHours 메서드 		언어 참조
버전 3

참고 적용 대상

설명
협정 세계 표준시(UTC)를 사용하여 Date 개체의 시 값을 반환합니다.
구문
objDate.getUTCHours()
참고
로컬 시간을 사용하여 자정부터 경과된 시 값을 가져오려면 getHours 메서드를 사용하십시오.

getUTCHours 메서드는 자정에서 시작하는 시 값을 0부터 23까지의 정수로 반환합니다. 0이 반환되는 경우는 오전 1:00:00 전이거나 Date 개체가 만들어 졌는데 이 개체에 시간이 저장되지 않은 경우 두 가지입니다. 어느 경우에 해당하는지 알아내는 방법은 분과 초 값 역시 0인지 확인하는 것뿐입니다. 두 값이 모두 0이면 Date 개체에 시간이 지정되지 않은 것으로 볼 수 있습니다.

아래 예제는 getUTCHours 메서드의 사용법을 보여줍니다.

function UTCTimeDemo()
{
  var d, s = "현재 협정 세계 표준시(UTC): ";
  var c = ":";
  d = new Date();
  s += d.getUTCHours() + c;
  s += d.getUTCMinutes() + c;
  s += d.getUTCSeconds() + c;
  s += d.getUTCMilliseconds();
  return(s);
}


getUTCHours 메서드

getUTCHours 메서드
적용 대상 		언어 참조

Date 개체


getUTCHours 메서드

getUTCHours 메서드
참고 		언어 참조

Date 개체 메서드
getHours 메서드
setHours 메서드
setUTCHours 메서드


getUTCMilliseconds 메서드

getUTCMilliseconds 메서드 		언어 참조
버전 3

참고 적용 대상

설명
협정 세계 표준시(UTC)를 사용하여 Date 개체의 밀리초 값을 반환합니다.
구문
objDate.getUTCMilliseconds()
참고
로컬 시간으로 밀리초 값을 가져오려면 getMilliseconds 메서드를 사용하십시오.

반환되는 밀리초 값의 범위는 0부터 999까지 입니다.

아래 예제는 getUTCMilliseconds 메서드의 사용법을 보여줍니다.

function UTCTimeDemo()
{
  var d, s = "현재 협정 세계 표준시(UTC): ";
  var c = ":";
  d = new Date();
  s += d.getUTCHours() + c;
  s += d.getUTCMinutes() + c;
  s += d.getUTCSeconds() + c;
  s += d.getUTCMilliseconds();
  return(s);
}


getUTCMilliseconds 메서드

getUTCMilliseconds 메서드
적용 대상 		언어 참조

Date 개체


getUTCMilliseconds 메서드

getUTCMilliseconds 메서드
참고 		언어 참조

Date 개체 메서드
getMilliseconds 메서드
setMilliseconds 메서드
setUTCMilliseconds 메서드


getUTCMinutes 메서드

getUTCMinutes 메서드 		언어 참조
버전 3

참고 적용 대상

설명
협정 세계 표준시(UTC)를 사용하여 Date 개체의 분 값을 반환합니다.
구문
objDate.getUTCMinutes()
참고
로컬 시간을 사용하여 저장된 분 값을 가져오려면 getMinutes 메서드를 사용하십시오.

getUTCMinutes 메서드는 Date 개체에 저장된 분에 해당하는 0부터 59까지의 정수를 반환합니다. 0이 반환되는 경우는 정각에서 1분이 지나지 않았거나 Date 개체가 만들어 졌는데 이 개체에 시간이 저장되지 않은 경우 두 가지입니다. 어디 경우에 해당하는지 알아내는 방법은 시와 초 값 역시 0인지 확인하는 것뿐입니다. 이 값이 모두 0이면 Date 개체에 시간이 저장되지 않은 것으로 볼 수 있습니다.

아래 예제는 getUTCMinutes 메서드의 사용법을 보여줍니다.

function UTCTimeDemo()
{
  var d, s = "현재 협정 세계 표준시(UTC): ";
  var c = ":";
  d = new Date();
  s += d.getUTCHours() + c;
  s += d.getUTCMinutes() + c;
  s += d.getUTCSeconds() + c;
  s += d.getUTCMilliseconds();
  return(s);
}


getUTCMinutes 메서드

getUTCMinutes 메서드
적용 대상 		언어 참조

Date 개체


getUTCMinutes 메서드

getUTCMinutes 메서드
참고 		언어 참조

Date 개체 메서드
getMinutes 메서드
setMinutes 메서드
setUTCMinutes 메서드


getUTCMonth 메서드

getUTCMonth 메서드 		언어 참조
버전 3

참고 적용 대상

설명
협정 세계 표준시(UTC)를 사용하여 Date 개체의 월 값을 반환합니다.
구문
objDate.getUTCMonth()
참고
로컬 시간을 사용하여 월 값을 가져오려면 getMonth 메서드를 사용하십시오.

getUTCMonth 메서드는 Date 개체의 월 값을 나타내는 0부터 11까지의 정수를 반환합니다. 반환값은 실제 월 값보다 1이 작습니다. Date 개체에 "Jan 5, 1996 08:47:00.0"이 저장되어 있으면 getUTCMonth메서드는 0을 반환합니다.

아래 예제는 getUTCMonth 메서드의 사용법을 보여줍니다.

function UTCDateDemo()
{
  var d, s = "오늘의 UTC 날짜: ";
  d = new Date();
  s += (d.getUTCMonth() + 1) + "/";
  s += d.getUTCDate() + "/";
  s += d.getUTCFullYear();
  return(s);
}


getUTCMonth 메서드

getUTCMonth 메서드
적용 대상 		언어 참조

Date 개체


getUTCMonth 메서드

getUTCMonth 메서드
참고 		언어 참조

Date 개체 메서드
getMonth 메서드
setMonth 메서드
setUTCMonth 메서드


getUTCSeconds 메서드

getUTCSeconds 메서드 		언어 참조
버전 3

참고 적용 대상

설명
협정 세계 표준시(UTC)를 사용하여 Date 개체의 초 값을 반환합니다.
구문
objDate.getUTCSeconds()
참고
로컬 시간을 사용하여 초 값을 가져오려면 getSeconds 메서드를 사용하십시오.

getUTCSeconds 메서드는 Date 개체의 초 값을 나타내는 0부터 59까지의 정수를 반환합니다. 0이 반환되는 경우는 현재 분에서 1초가 지나지 않았거나 Date 개체가 만들어 졌는데 개체에 시간이 저장되지 않은 경우 두 가지입니다. 어느 경우에 해당하는지 알아내는 방법은 시와 분 값 역시 0인지 확인하는 것뿐입니다. 이 값이 모두 0이면 Date 개체에 시간이 저장되지 않은 것으로 볼 수 있습니다.

아래 예제는 getUTCSeconds 메서드의 사용법을 보여줍니다.

function UTCTimeDemo()
{
  var d, s = "현재 협정 세계 표준시(UTC): ";
  var c = ":";
  d = new Date();
  s += d.getUTCHours() + c;
  s += d.getUTCMinutes() + c;
  s += d.getUTCSeconds() + c;
  s += d.getUTCMilliseconds();
  return(s);
}


getUTCSeconds 메서드

getUTCSeconds 메서드
적용 대상 		언어 참조

Date 개체


getUTCSeconds 메서드

getUTCSeconds 메서드
참고 		언어 참조

Date 개체 메서드
getSeconds 메서드
setSeconds 메서드
setUTCSeconds 메서드


getVarDate 메서드

getVarDate 메서드 		언어 참조
버전 3

참고 적용 대상

설명
Date 개체의 VT_DATE 값을 반환합니다.
구문
dateobj.getVarDate( )

dateobj 인수는 Date 개체입니다.

참고
getVarDate 메서드는 ActiveX® 개체나 VT_DATE 형식으로 날짜 값을 적용하고 반환할 수 있는 다른 개체와 상호 작용할 때 사용됩니다.


getVarDate 메서드

getVarDate 메서드
적용 대상 		언어 참조

Date 개체


getVarDate 메서드

getVarDate 메서드
참고 		언어 참조

getDate 메서드
parse 메서드


getYear 메서드

getYear 메서드 		언어 참조
버전 1

참고 적용 대상

설명

Date 개체의 연도 값을 반환합니다.

구문

objDate.getYear( )
참고
이 메서드는 이전 방식이고 단지 이전 버전과의 호환성을 유지하기 위해서만 사용합니다. 대신 getFullYear 메서드를 사용하십시오.

1900년에서 1999년까지의 연도는 1900년과 저장된 연도와의 차이로 반환된 두 자리 정수 값입니다. 이 외의 연도는 네 자릿수로 반환됩니다. 예를 들어, 1996년은 96으로 반환되고, 1825년이나 2025년은 네 자릿수 그대로 반환됩니다.

아래 예제는 getYear 메서드의 사용법을 보여줍니다.

function DateDemo()
{
  var d, s = "오늘 날짜: ";
  d = new Date();
  s += (d.getMonth() + 1) + "/";
  s += d.getDate() + "/";
  s += d.getYear();
  return(s);
}


getYear 메서드

getYear 메서드
적용 대상 		언어 참조

Date 개체


getYear 메서드

getYear 메서드
참고 		언어 참조

Date 개체 메서드
getFullYear 메서드
getUTCFullYear 메서드
setFullYear 메서드
setUTCFullYear 메서드
setYear 메서드


parse 메서드

parse 메서드 		언어 참조
버전 1

참고 적용 대상

설명

날짜를 포함한 문자열 구문을 분석하여 1970년 1월 1일 자정부터 해당 날짜 사이의 시간을 밀리초로 반환합니다.

구문
Date.parse(dateVal)

dateVal 인수는 "Jan 5, 1996 08:47:00"와 같은 형식의 날짜를 포함한 문자열이거나 ActiveX® 개체 또는 다른 개체에서 검색한 VT_DATE 값입니다.

참고
parse 메서드는 1970년 1월 1일 자정과 dateVal에 주어진 날짜 사이의 밀리초를 정수 값으로 반환합니다.

parse 메서드는 Date 개체의 정적 메서드입니다. 그렇기 때문에 parse 메서드는 일반적으로 만들어진 Date 개체의 메서드와는 달리 아래 예제처럼 호출됩니다.

var datestring = "November 1, 1997 10:15 AM";
Date.parse(datestring)
다음 규칙은 parse 메서드로 구문을 분석하기 위해 지켜야 할 규칙들입니다.
  • 간단한 날짜 표기에는 "/" 또는 "-" 날짜 구분 기호를 사용할 수 있지만 예를 들어 "7/20/96"과 같이 월/일/연도 형식을 지켜야만 합니다.
  • "July 10 1995"와 같이 자세한 날짜 표기에는 연도, 월, 일의 순서를 마음대로 쓸 수 있으며 연도는 2자리나 4자리 형식을 사용할 수 있습니다. 하지만 2자리 형식을 사용하려면 연도가 반드시 70 이상이어야 합니다.
  • 괄호 안의 모든 텍스트는 주석으로 처리되며 괄호는 중첩해서 사용할 수 있습니다.
  • 쉼표와 공백은 모두 구분 기호로 처리되며 여러 개를 사용할 수도 있습니다.
  • 월과 요일 명은 반드시 2자 이상이어야 합니다. 예를 들어 "Ju"처럼 June과 July 둘 다 가능한 이름일 경우 뒤에 나오는 것으로 간주되므로 이 경우에는 June이 아니라 July입니다.
  • 주어진 요일이 주어진 날짜의 나머지 요소 즉, 연도, 월, 일과 일치하지 않으면 주어진 요일은 무시됩니다. 예를 들어 "Tuesday November 9 1996"의 실제 요일이 금요일이어도 이 날짜를 적용하여 구문을 분석하므로, 결과적으로 Date 개체의 값은 "Friday November 9 1996"이 됩니다.
  • JScript에서는 협정 세계 표준시(UTC)와 그리니치 표준시(GMT)는 물론 모든 기준 시간대들을 사용할 수 있습니다.
  • 시, 분, 초는 콜론으로 구분하지만 모두 지정할 필요는 없습니다. "10:", "10:11", "10:11:12" 모두 유효합니다.
  • 24시로 표시되는 시계를 사용하는 경우 정오 12시 이후의 시간에 "PM"을 지정하는 것은 오류입니다. 예를 들어 "23:15 PM"은 오류입니다.
  • 유효하지 않은 날짜를 포함한 문자열은 오류입니다. 예를 들어 하나의 문자열에 연도 두 개나 월 두 개가 포함되면 오류입니다.
아래 예제는 parse 메서드의 사용법을 보여줍니다.
function GetTimeTest(testdate)
{
  var d, s, t;
  var MinMilli = 1000 * 60;
  var HrMilli = MinMilli * 60;
  var DyMilli = HrMilli * 24;
  d = new Date();
  t = Date.parse(testdate);
  s += testdate + "와 1/1/70" + " 사이는 "
  s += Math.round(Math.abs(t / DyMilli)) + " 밀리초"
  s = "입니다.";
  return(s);
}


parse 메서드

parse 메서드
적용 대상 		언어 참조

Date 개체


parse 메서드

parse 메서드
참고 		언어 참조

Date 개체 메서드


setDate 메서드

setDate 메서드 		언어 참조
버전 1

참고 적용 대상

설명
로컬 시간을 사용하여 Date 개체의 날짜 값을 설정합니다.
구문
objDate.setDate(numDate)

numDate 인수는 날짜 값에 해당하는 숫자 값입니다.

참고
협정 세계 표준시(UTC)로 날짜 값을 설정하려면 setUTCDate 메서드를 사용하십시오.

numDate의 값이 Date 개체에 저장된 날짜 값보다 크거나 음수이면 numDate의 값에서 저장된 날짜 값을 뺀 값을 날짜로 설정합니다. 예를 들어 저장된 날짜가 January 5, 1996이고 setDate(32)를 호출하면 날짜가 February 1, 1996으로 바뀝니다. 음수값도 같은 방법으로 처리됩니다.

아래 예제는 setDate 메서드의 사용법을 보여줍니다.

function SetDateDemo(newdate)
{
  var d, s;
  d = new Date();
  d.setDate(newdate);
  s = "현재 설정은 ";
  s += d.toLocaleString() + "입니다.";
  return(s);
}


setDate 메서드

setDate 메서드
적용 대상 		언어 참조

Date 개체


setDate 메서드

setDate 메서드
참고 		언어 참조

Date 개체 메서드
getDate 메서드
getUTCDate 메서드
setUTCDate 메서드


setFullYear 메서드

setFullYear 메서드 		언어 참조
버전 3

참고 적용 대상

설명
로컬 시간을 사용하여 Date 개체의 연도 값을 설정합니다.
구문
objDate.setFullYear(numYear[, numMonth[, numDate]])

setFullYear 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
numYear | 필수적인 요소. 연도 값에 해당하는 숫자 값입니다.
numMonth | 선택적인 요소. 월 값에 해당하는 숫자 값입니다. numDate를 사용하면 반드시 사용해야 합니다.
numDate | 선택적인 요소. 일 값에 해당하는 숫자 값입니다.

참고
선택적인 인수를 갖는 모든 set 메서드들은 선택적인 인수를 지정하지 않으면 이에 해당하는 get 메서드에서 반환된 값을 사용합니다. 예를 들어, 만일 numMonth 인수가 선택적인 요소이고 이를 지정하지 않으면 JScript는 getMonth 메서드에서 반환된 값을 사용합니다.

또한 인수 값이 범위를 초과하였거나 음수이면 이에 따라 저장된 다른 값들도 수정됩니다.

협정 세계 표준시(UTC)를 사용하는 연도 값을 설정하려면 setUTCFullYear 메서드를 사용하십시오.

날짜 개체가 지원하는 연도 범위는 1970년을 전후로 약 285,616년까지입니다.

아래 예제는 setFullYear 메서드의 사용법을 보여줍니다.

function SetFullYearDemo(newyear)
{
  var d, s;
  d = new Date();
  d.setFullYear(newyear);
  s = "현재 설정값은 ";
  s += d.toLocaleString() + "입니다.";
  return(s);
}


setFullYear 메서드

setFullYear 메서드
적용 대상 		언어 참조

Date 개체


setFullYear 메서드

setFullYear 메서드
참고 		언어 참조

Date 개체 메서드
getFullYear 메서드
getUTCFullYear 메서드
setUTCFullYear 메서드


setHours 메서드

setHours 메서드 		언어 참조
버전 1

참고 적용 대상

설명
로컬 시간을 사용하여 Date 개체의 시 값을 설정합니다.
구문
objDate.setHours(numHours[, numMin[, numSec[, numMilli]]])

setHours 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
numHours | 필수적인 요소. 시 값에 해당하는 숫자 값입니다.
numMin | 선택적인 요소. 분 값에 해당하는 숫자 값입니다. 아래 인수 중 하나를 사용하면 반드시 사용해야 합니다.
numSec | 선택적인 요소. 초 값에 해당하는 숫자 값입니다. 아래 인수를 사용하면 반드시 사용해야 합니다.
numMilli | 선택적인 요소. 밀리초 값에 해당하는 숫자 값입니다.

참고
선택적인 인수를 갖는 모든 set 메서드들은 만일 선택적인 인수를 지정하지 않으면 이에 해당하는 get 메서드에서 반환된 값을 사용합니다. 예를 들어, 만일 numMonth 인수가 선택적인 요소이고 이를 지정하지 않으면 JScript는 getMonth 메서드에서 반환된 값을 사용합니다.

협정 세계 표준시(UTC)를 사용하는 시간 값을 설정하려면 setUTCHours 메서드를 사용하십시오.

인수의 값이 범위를 초과하였거나 음수이면 이에 따라 저장된 다른 값들도 수정됩니다. 예를 들어 저장된 날짜가 "Jan 5, 1996 00:00:00"이고 setHours(30)이 호출되면 날짜는 "Jan 6, 1996 06:00:00"로 바뀝니다. 음수값도 같은 방법으로 처리됩니다.

아래 예제는 setHours 메서드의 사용법을 보여줍니다.

function SetHoursDemo(nhr, nmin, nsec)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setHours(nhr, nmin, nsec);
  s = "현재 설정값은 " + d.toLocaleString() + "입니다."
  return(s);
}


setHours 메서드

setHours 메서드
적용 대상 		언어 참조

Date 개체


setHours 메서드

setHours 메서드
참고 		언어 참조

Date 개체 메서드
getHours 메서드
getUTCHours 메서드
setUTCHours 메서드


setMilliseconds 메서드

setMilliseconds 메서드 		언어 참조
버전 3

참고 적용 대상

설명
로컬 시간을 사용하여 Date 개체의 밀리초 값을 설정합니다.
구문
objDate.setMilliseconds(numMilli)

numMilli 인수는 밀리초 값에 해당하는 숫자 값입니다.

참고
선택적인 인수를 갖는 모든 set 메서드들은 만일 선택적인 인수를 지정하지 않으면 이에 해당하는 get 메서드에서 반환된 값을 사용합니다. 예를 들어 numMonth 인수가 선택적인 요소이고 이를 지정하지 않으면 getMonth 메서드에서 반환된 값을 사용합니다.

협정 세계 표준시(UTC)를 사용하는 밀리초 값을 설정하려면 setUTCMilliseconds 메서드를 사용하십시오.

numMilli 값이 999보다 크거나 음수이면 저장된 초(분, 시, 기타 필요한 것) 값은 이에 따라 적당한 양만큼 증감합니다.

아래 예제는 setMilliseconds 메서드의 사용법을 보여줍니다.

function SetMSecDemo(nmsec)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setMilliseconds(nmsec);
  s = "현재 설정값은 ";
  s += d.toLocaleString() + sep + d.getMilliseconds() + "입니다.";
  return(s);
}


getMilliseconds 메서드

setMilliseconds 메서드
적용 대상 		언어 참조

Date 개체


setMilliseconds 메서드

setMilliseconds 메서드
참고 		언어 참조

Date 개체 메서드
getMilliseconds 메서드
getUTCMilliseconds 메서드
setUTCMilliseconds 메서드


setMinutes 메서드

setMinutes 메서드 		언어 참조
버전 1

참고 적용 대상

설명
로컬 시간을 사용하여 Date 개체의 분 값을 설정합니다.
구문
objDate.setMinutes(numMinutes[, numSeconds[, numMilli]])

setMinutes 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
numMinutes | 필수적인 요소. 분 값에 해당하는 숫자 값입니다.
numSeconds | 선택적인 요소. 초 값에 해당하는 숫자 값입니다. numMilli 인수를 사용하면 반드시 사용해야 합니다.
numMilli | 선택적인 요소. 밀리초 값에 해당하는 숫자 값입니다.

참고
선택적인 인수를 갖는 모든 set 메서드들은 만일 선택적인 인수를 지정하지 않으면 이에 해당하는 get 메서드에서 반환된 값을 사용합니다. 예를 들어, 만일 numMonth 인수가 선택적인 요소이고 이를 지정하지 않으면 JScript는 getMonth 메서드에서 반환된 값을 사용합니다.

협정 세계 표준시(UTC)를 사용하는 분 값을 설정하려면 setUTCMinutes 메서드를 사용하십시오.

인수의 값이 범위를 초과하였거나 음수이면 이에 따라 저장된 다른 값들도 수정됩니다. 예를 들어, 저장된 날짜가 "Jan 5, 1996 00:00:00"이고 setMinutes(90)가 호출되면 날짜는 "Jan 5, 1996 01:30:00"로 바뀝니다. 음수값도 같은 방법으로 처리됩니다.

아래 예제는 setMinutes 메서드의 사용법을 보여줍니다.

function SetMinutesDemo(nmin, nsec)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setMinutes(nmin, nsec);
  s = "현재 설정값은 " + d.toLocaleString() + "입니다."
  return(s);
}


setMinutes 메서드

setMinutes 메서드
적용 대상 		언어 참조

Date 개체


setMinutes 메서드

setMinutes 메서드
참고 		언어 참조

Date 개체 메서드
getMinutes 메서드
getUTCMinutes 메서드
setUTCMinutes 메서드


setMonth 메서드

setMonth 메서드 		언어 참조
버전 1

참고 적용 대상

설명
로컬 시간을 사용하여 Date 개체의 월 값을 설정합니다.
구문
objDate.setMonth(numMonth[, dateVal])

setMonth 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
numMonth | 필수적인 요소. 월에 해당하는 숫자 값입니다.
dateVal | 선택적인 요소. 일에 해당하는 숫자 값입니다. 값을 부여하지 않으면 getDate 메서드를 호출하여 받은 값을 사용합니다.

참고
협정 세계 표준시(UTC)를 사용하는 월 값을 설정하려면 setUTCMonth 메서드를 사용하십시오.

numMonth의 값이 11보다 크거나(January가 0임) 음수이면 이에 따라 저장된 다른 값들도 변경됩니다. 예를 들어, 저장된 날짜가 "Jan 5, 1996"이고 setMonth(14)가 호출되면 날짜는 "Mar 5, 1997"로 바뀝니다.

아래 예제는 setMonth 메서드의 사용법을 보여줍니다.

function SetMonthDemo(newmonth)
{
  var d, s;
  d = new Date();
  d.setMonth(newmonth);
  s = "현재 설정값은 ";
  s += d.toLocaleString() + "입니다.";
  return(s);
}


setMonth 메서드

setMonth 메서드
적용 대상 		언어 참조

Date 개체


setMonth 메서드

setMonth 메서드
참고 		언어 참조

Date 개체 메서드
getMonth 메서드
getUTCMonth 메서드
setUTCMonth 메서드


setSeconds 메서드

setSeconds 메서드 		언어 참조
버전 1

참고 적용 대상

설명
로컬 시간을 사용하여 Date 개체의 초 값을 설정합니다.
구문
objDate.setSeconds(numSeconds[, numMilli])

setSeconds 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
numSeconds | 필수적인 요소. 초 값에 해당하는 숫자 값입니다.
numMilli | 선택적인 요소. 밀리초 값에 해당하는 숫자 값입니다.

참고
선택적인 인수를 갖는 모든 set 메서드들은 만일 선택적인 인수를 지정하지 않으면 이에 해당하는 get 메서드에서 반환된 값을 사용합니다. 예를 들어 numMonth 인수가 선택적인 요소이고 이를 지정하지 않으면 JScript는 getMonth 메서드에서 반환된 값을 사용합니다.

협정 세계 표준시(UTC)를 사용하는 초 값을 설정하려면 setUTCSeconds 메서드를 사용하십시오.

인수의 값이 범위를 초과하거나 음수이면 이에 따라 저장된 다른 값들도 수정됩니다. 예를 들어, 저장된 날짜가 "Jan 5, 1996 00:00:00"이고 setSeconds(150)가 호출되면 날짜는 "Jan 5, 1996 00:02:30"로 바뀝니다.

아래 예제는 setSeconds 메서드의 사용법을 보여줍니다.

function SetSecondsDemo(nsec, nmsec)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setSeconds(nsec, nmsec);
  s = "현재 설정값은 ";
  s += d.toLocaleString() + sep + d.getMilliseconds() + "입니다.";
  return(s);
}


setSeconds 메서드

setSeconds 메서드
적용 대상 		언어 참조

Date 개체


setSeconds 메서드

setSeconds 메서드
참고 		언어 참조

Date 개체 메서드
getSeconds 메서드
getUTCSeconds 메서드
setUTCSeconds 메서드


setTime 메서드

setTime 메서드 		언어 참조
버전 1

참고 적용 대상

설명
Date 개체의 날짜와 시간 값을 설정합니다.
구문
objDate.setTime(milliseconds)

milliseconds 인수는 GMT 1970년 1월 1일 자정부터 경과된 시간을 초로 나타낸 정수값입니다.

참고
milliseconds가 음수이면 1970년 이전의 날짜를 나타냅니다. 사용 가능한 날짜 범위는 1970년을 전후로 약 285,616년까지입니다.

setTime 메서드로 설정한 날짜와 시간은 기준 시간대와는 별개의 것입니다.

아래 예제는 setTime 메서드의 사용법을 보여줍니다.

function SetTimeTest(newtime)
{
  var d, s;
  d = new Date();
  d.setTime(newtime);
  s = "현재 설정값은 ";
  s += d.toUTCString() + "입니다.";
  return(s);
}


setTime 메서드

setTime 메서드
적용 대상 		언어 참조

Date 개체


setTime 메서드

setTime 메서드
참고 		언어 참조

Date 개체 메서드
getTime 메서드


setUTCDate 메서드

setUTCDate 메서드 		언어 참조
버전 3

참고 적용 대상

설명
협정 세계 표준시(UTC)를 사용하여 Date 개체의 날짜 값을 설정합니다.
구문
objDate.setUTCDate(numDate)

numDate 인수는 날짜 값에 해당하는 숫자 값입니다.

참고
로컬 시간을 사용하는 날짜를 설정하려면 setDate 메서드를 사용하십시오.

numDate의 값이 Date 개체에 저장된 날짜 값보다 크거나 음수이면 numDate의 값에서 저장된 날짜 값을 뺀 수를 날짜로 설정합니다. 예를 들어, 저장된 날짜가 January 5, 1996이고 setUTCDate(32)가 호출되면 날짜는 February 1, 1996으로 바뀝니다. 음수값도 같은 방법으로 처리됩니다.

아래 예제는 setUTCDate 메서드의 사용법을 보여줍니다.

function SetUTCDateDemo(newdate)
{
  var d, s;
  d = new Date();
  d.setUTCDate(newdate);
  s = "현재 설정값은 ";
  s += d.toUTCString() + "입니다.";
  return(s);
}


setUTCDate 메서드

setUTCDate 메서드
적용 대상 		언어 참조

Date 개체


setUTCDate 메서드

setUTCDate 메서드
참고 		언어 참조

Date 개체 메서드
getDate 메서드
getUTCDate 메서드
setDate 메서드


setUTCFullYear 메서드

setUTCFullYear 메서드 		언어 참조
버전 3

참고 적용 대상

설명
협정 세계 표준시(UTC)를 사용하여 Date 개체의 연도 값을 설정합니다.
구문
objDate.setUTCFullYear(numYear[, numMonth[, numDate]])

setUTCFullYear 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
numYear | 필수적인 요소. 연도에 해당하는 숫자 값입니다.
numMonth | 선택적인 요소. 월에 해당하는 숫자 값입니다. numDate를 사용하면 반드시 사용해야 합니다.
numDate | 선택적인 요소. 일에 해당하는 숫자 값입니다.

참고
선택적인 인수를 갖는 모든 set 메서드들은 만일 선택적인 인수를 지정하지 않으면 이에 해당하는 get 메서드에서 반환된 값을 사용합니다. 예를 들어, numMonth 인수가 선택적인 요소이고 이를 지정하지 않으면 JScript는 getMonth 메서드에서 반환된 값을 사용합니다.

또한 인수 값이 범위를 초과하거나 음수이면 이에 따라 저장된 다른 값들도 수정됩니다.

로컬 시간을 사용하는 연도 값을 설정하려면 setFullYear 메서드를 사용하십시오.

Date 개체가 지원하는 연도 범위는 1970년을 전후로 약 285,616년까지입니다.

아래 예제는 setUTCFullYear 메서드의 사용법을 보여줍니다.

function SetUTCFullYearDemo(newyear)
{
  var d, s;
  d = new Date();
  d.setUTCFullYear(newyear);
  s = "현재 설정값은 ";
  s += d.toUTCString() + "입니다.";
  return(s);
}


setUTCFullYear 메서드

setUTCFullYear 메서드
적용 대상 		언어 참조

Date 개체


setUTCFullYear 메서드

setUTCFullYear 메서드
참고 		언어 참조

Date 개체 메서드
getFullYear 메서드
getUTCFullYear 메서드
setFullYear 메서드


setUTCHours 메서드

setUTCHours 메서드 		언어 참조
버전 3

참고 적용 대상

설명
협정 세계 표준시(UTC)를 사용하여 Date 개체의 시 값을 설정합니다.
구문
objDate.setUTCHours(numHours[, numMin[, numSec[, numMilli]]])

setUTCHours 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
numHours | 필수적인 요소. 시 값에 해당하는 숫자 값입니다.
numMin | 선택적인 요소. 분 값에 해당하는 숫자 값입니다. numSec 또는 numMilli를 사용하면 반드시 사용해야 합니다.
numSec | 선택적인 요소. 초 값에 해당하는는 숫자 값입니다. numMilli를 사용하면 반드시 사용해야 합니다.
numMilli | 선택적인 요소. 밀리초 값에 해당하는 숫자 값입니다.

참고
선택적인 인수를 갖는 모든 set 메서드들은 만일 선택적인 인수를 지정하지 않으면 이에 해당하는 get 메서드에서 반환된 값을 사용합니다. 예를 들어 numMonth 인수가 선택적인 요소이고 이를 지정하지 않으면 JScript는 getMonth 메서드에서 반환된 값을 사용합니다.

로컬 시간을 사용하는 시간 값을 설정하려면 setHours 메서드를 사용하십시오.

인수의 값이 범위를 초과하거나 음수이면 이에 따라 저장된 다른 값들도 수정됩니다. 예를 들어, 저장된 날짜가 "Jan 5, 1996 00:00:00.00"이고 setUTCHours(30)가 호출되면 날짜는 "Jan 6, 1996 06:00:00.00"으로 바뀝니다.

아래 예제는 setUTCHours 메서드의 사용법을 보여줍니다.

function SetUTCHoursDemo(nhr, nmin, nsec)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setUTCHours(nhr, nmin, nsec);
  s = "현재 설정값은 " + d.toUTCString() + "입니다."
  return(s);
}


setUTCHours 메서드

setUTCHours 메서드
적용 대상 		언어 참조

Date 개체


setUTCHours 메서드

setUTCHours 메서드
참고 		언어 참조

Date 개체 메서드
getHours 메서드
getUTCHours 메서드
setHours 메서드


setUTCMilliseconds 메서드

setUTCMilliseconds 메서드 		언어 참조
버전 3

참고 적용 대상

설명
협정 세계 표준시(UTC)를 사용하여 Date 개체의 밀리초 값을 설정합니다.
구문
objDate.setUTCMilliseconds(numMilli)

numMilli 인수는 밀리초 값에 해당하는 숫자 값입니다.

참고
로컬 시간을 사용하는 밀리초를 설정하려면 setMilliseconds 메서드를 사용하십시오.

numMilli 값이 999보다 크거나 음수이면, 저장된 초 값(분, 시, 기타 필요한 것)은 적당한 양만큼 증감합니다.

아래 예제는 setUTCMilliseconds 메서드의 사용법을 보여줍니다.

function SetUTCMSecDemo(nmsec)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setUTCMilliseconds(nmsec);
  s = "현재 설정값은 ";
  s += d.toUTCString() + sep + d.getUTCMilliseconds() + "입니다.";
  return(s);
}


setUTCMilliseconds 메서드

setUTCMilliseconds 메서드
적용 대상 		언어 참조

Date 개체


setUTCMilliseconds 메서드

setUTCMilliseconds 메서드
참고 		언어 참조

Date 개체 메서드
getMilliseconds 메서드
getUTCMilliseconds 메서드
setMilliseconds 메서드


setUTCMinutes 메서드

setUTCMinutes 메서드 		언어 참조
버전 3

참고 적용 대상

설명
협정 세계 표준시(UTC)를 사용하여 Date 개체의 분 값을 설정합니다.
구문
objDate.setUTCMinutes(numMinutes[, numSeconds[, numMilli]])

setUTCMinutes 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
numMinutes | 필수적인 요소. 분 값에 해당하는 숫자 값입니다.
numSeconds | 선택적인 요소. 초 값에 해당하는 숫자 값입니다. numMilli를 사용하면 반드시 사용해야 합니다.
numMilli | 선택적인 요소. 밀리초 값에 해당하는 숫자 값입니다.

참고
선택적인 인수를 갖는 모든 set 메서드들은 만일 선택적인 인수를 지정하지 않으면 이에 해당하는 get 메서드에서 반환된 값을 사용합니다. 예를 들어 numMonth 인수가 선택적인 요소이고 이를 지정하지 않으면 JScript는 getMonth 메서드에서 반환된 값을 사용합니다.

로컬 시간을 사용하는 분 값을 수정하려면 setMinutes 메서드를 사용하십시오.

인수 값이 범위를 초과하거나 음수이면 이에 따라 저장된 다른 값들도 수정됩니다. 예를 들어, 저장된 날짜가 "Jan 5, 1996 00:00:00.00"이고 setUTCMinutes(70)가 호출되면 날짜는 "Jan 5, 1996 01:10:00.00"으로 바뀝니다.

아래 예제는 setUTCMinutes 메서드의 사용법을 보여줍니다.

function SetUTCMinutesDemo(nmin, nsec)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setUTCMinutes(nmin,nsec);
  s = "현재 설정값은 " + d.toUTCString() + "입니다."
  return(s);
}


setUTCMinutes 메서드

setUTCMinutes 메서드
적용 대상 		언어 참조

Date 개체


setUTCMinutes 메서드

setUTCMinutes 메서드
참고 		언어 참조

Date 개체 메서드
getMinutes 메서드
getUTCMinutes 메서드
setMinutes 메서드


setUTCMonth 메서드

setUTCMonth 메서드 		언어 참조
버전 3

참고 적용 대상

설명
협정 세계 표준시(UTC)를 사용하여 Date 개체의 월 값을 설정합니다.
구문
objDate.setUTCMonth(numMonth[, dateVal])

setUTCMonth 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
numMonth | 필수적인 요소. 월에 해당하는 숫자 값입니다.
dateVal | 선택적인 요소. 일을 나타내는 숫자 값입니다. 값을 부여하지 않으면 getUTCDate 메서드를 호출하여 받은 값을 사용합니다.

참고
로컬 시간을 사용하는 월 값을 설정하려면 setMonth 메서드를 사용하십시오.

numMonth의 값이 11보다 크거나(January가 0임) 음수이면 이에 따라 저장된 연도도 증감합니다. 예를 들어, 저장된 날짜가 "Jan 5, 1996 00:00:00.00"이고 setUTCMonth(14)가 호출되면 날짜는 "Mar 5, 1997 00:00:00.00"으로 바뀝니다.

아래 예제는 setUTCMonth 메서드의 사용법을 보여줍니다.

function SetUTCMonthDemo(newmonth)
{
  var d, s;
  d = new Date();
  d.setUTCMonth(newmonth);
  s = "현재 설정값은 ";
  s += d.toUTCString() + "입니다.";
  return(s);
}


setUTCMonth 메서드

setUTCMonth 메서드
적용 대상 		언어 참조

Date 개체


setUTCMonth 메서드

setUTCMonth 메서드
참고 		언어 참조

Date 개체 메서드
getMonth 메서드
getUTCMonth 메서드
setMonth 메서드


setUTCSeconds 메서드

setUTCSeconds 메서드 		언어 참조
버전 3

참고 적용 대상

설명
협정 세계 표준시(UTC)를 사용하여 Date 개체의 초 값을 설정합니다.
구문
objDate.setUTCSeconds(numSeconds[, numMilli])

setUTCSeconds 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
numSeconds | 필수적인 요소. 초 값에 해당하는 숫자 값입니다.
numMilli | 선택적인 요소. 밀리초 값에 해당하는 숫자 값입니다.

참고
선택적인 인수를 갖는 모든 set 메서드가 만일 선택적인 인수를 지정하지 않으면 이에 해당하는 get 메서드에서 반환된 값을 사용합니다. 예를 들어 numMonth 인수가 선택적인 요소이고 이를 지정하지 않으면 JScript는 getMonth 메서드에서 반환된 값을 사용합니다.

로컬 시간을 사용하는 초 값을 설정하려면 setSeconds 메서드를 사용하십시오.

인수 값이 범위를 초과하거나 음수이면 이에 따라 저장된 다른 값들도 수정됩니다. 예를 들어, 저장된 날짜가 "Jan 5, 1996 00:00:00.00"이고 setSeconds(150)가 호출되면 날짜는 "Jan 5, 1996 00:02:30.00"으로 바뀝니다.

아래 예제는 setSeconds 메서드의 사용법을 보여줍니다.

function SetUTCSecondsDemo(nsec, nmsec)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setUTCSeconds(nsec, nmsec);
  s = "현재 설정값은 ";
  s += d.toUTCString() + sep + d.getUTCMilliseconds() + "입니다.";
  return(s);
}


setUTCSeconds 메서드

setUTCSeconds 메서드
적용 대상 		언어 참조

Date 개체


setUTCSeconds 메서드

setUTCSeconds 메서드
참고 		언어 참조

Date 개체 메서드
getSeconds 메서드
getUTCSeconds 메서드
setSeconds 메서드


setYear 메서드

setYear 메서드 		언어 참조
버전 1

참고 적용 대상

설명
Date 개체의 연도 값을 설정합니다.
구문
objDate.setYear(numYear)

numYear 인수는 현재 연도에서 1900을 뺀 숫자 값입니다.

참고
이 메서드는 이전 방식이고 단지 이전 버전과의 호환성을 유지하기 위해서만 사용되고 있습니다. 그 대신 setFullYear 메서드를 사용하십시오.

Date 개체의 연도를 1997년으로 설정하려면 setYear(97)를 호출하십시오. 2010년으로 설정하려면 setYear(2010)를 호출하십시오. 끝으로 연도를 0부터 99 사이의 값으로 설정하려면 setFullYear 메서드를 사용하십시오.

아래 예제는 setYear 메서드의 사용법을 보여줍니다.

function SetYearDemo(newyear)
{
  var d, s;
  d = new Date();
  d.setYear(newyear);
  s = "현재 설정값은 ";
  s += d.toLocaleString() + "입니다.";
  return(s);
}


setYear 메서드

setYear 메서드
적용 대상 		언어 참조

Date 개체


setYear 메서드

setYear 메서드
참고 		언어 참조

Date 개체 메서드
getFullYear 메서드
getUTCFullYear 메서드
getYear 메서드
setFullYear 메서드
setUTCFullYear 메서드


toGMTString 메서드

toGMTString 메서드 		언어 참조
버전 1

참고 적용 대상

설명
그리니치 표준시(GMT)를 사용하여 문자열로 변환된 날짜를 반환합니다.
구문
objDate.toGMTString()
참고
toGMTString 메서드는 이전 방식이고 단지 이전 버전과의 호환성을 유지하기 위해서만 사용합니다. 그 대신 toUTCString 메서드를 사용하십시오.

toGMTString 메서드는 GMT 규칙을 사용하여 서식을 지정한 날짜를 포함하는 String 개체를 반환합니다. 반환된 값의 형식은 "05 Jan 1996 00:00:00 GMT"와 같습니다.

아래 예제는 toGMTString 메서드의 사용법을 보여줍니다.

function toGMTStrDemo()
{
  var d, s;
  d = new Date();
  s = "현재 설정값은 ";
  s += d.toGMTString() + "입니다.";
  return(s);
}


toGMTString 메서드

toGMTString 메서드
적용 대상 		언어 참조

Date 개체


toGMTString 메서드

toGMTString 메서드
참고 		언어 참조

Date 개체 메서드
toUTCString 메서드


toLocaleString 메서드

toLocaleString 메서드 		언어 참조
버전 1

참고 적용 대상

설명
현재 로케일을 사용하여 문자열로 변환된 날짜를 반환합니다.
구문
dateObj.toLocaleString( )
참고
toLocaleString 메서드는 현재 로케일의 기본 형식으로 쓰여진 날짜를 포함한 String 개체를 반환합니다. 반환된 값의 형식은 현재 로케일 설정에 따라 다릅니다. 예를 들어, 1996년 1월 5일을 반환하는 방법에 있어 미국에서는 toLocaleString 메서드가 "01/05/96 00:00:00"으로 반환되지만 유럽 규칙에 따르면 월 앞에 날짜를 쓰기 때문에 "05/01/96 00:00:00"으로 반환됩니다.

아래 예제는 toLocaleString 메서드의 사용법을 보여줍니다.

function toLocaleStrDemo()
{
  var d, s;
  d = new Date();
  s = "현재 설정값은 ";
  s += d.toLocaleString() + "입니다.";
  return(s);
}


toLocaleString 메서드

toLocaleString 메서드
적용 대상 		언어 참조

Date 개체


toLocaleString 메서드

toLocaleString 메서드
참고 		언어 참조

Date 개체 메서드


toUTCString 메서드

toUTCString 메서드 		언어 참조
버전 3

참고 적용 대상

설명
협정 세계 표준시(UTC)를 사용하여 문자열로 변환된 날짜를 반환합니다.
구문
objDate.toUTCString()
참고
toUTCString 메서드는 UTC 규칙을 사용하는 날짜 형식을 가진 String 개체를 편리하고 읽기 쉬운 형식으로 반환합니다.

아래 예제는 toUTCString 메서드의 사용법을 보여줍니다.

function toUTCStrDemo()
{
  var d, s;
  d = new Date();
  s = "현재 설정값은 ";
  s += d.toUTCString() + "입니다.";
  return(s);
}


toUTCString 메서드

toUTCString 메서드
적용 대상 		언어 참조

Date 개체


toUTCString 메서드

toUTCString 메서드
참고 		언어 참조

Date 개체 메서드
toGMTString 메서드


UTC 메서드

UTC 메서드 		언어 참조
버전 1

참고 적용 대상

설명

협정 세계 표준시(UTC) 또는 그리니치 표준시(GMT) 1970년 1월 1일 자정부터 주어진 날짜 사이의 시간을 밀리초 값으로 반환합니다.

구문
Date.UTC(year, month, day[, hours[, minutes[, seconds[,ms]]]])

UTC 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
year | 필수적인 요소. 다른 세기의 날짜를 정확히 동시에 나타내기 위해 연도를 네 자릿수로 표기해야 합니다. 만일 year에 0부터 99까지의 숫자가 사용되면 year는 1900 + year인 것으로 간주됩니다 .
month | 필수적인 요소. 0부터 11까지의 정수로 월을 지정합니다(1월~12월).
date | 필수적인 요소. 0부터 31까지의 정수로 일을 지정합니다.
hours | 선택적인 요소. minutes를 사용하면 반드시 사용해야 합니다. 시를 지정하는 0부터 23까지의 정수입니다(자정부터 오후 11시까지).
minutes | 선택적인 요소. seconds를 사용하면 반드시 사용해야 합니다. 분을 지정하는 0부터 59까지의 정수입니다.
seconds | 선택적인 요소. milliseconds를 사용하면 반드시 사용해야 합니다. 초를 지정하는 0부터 59까지의 정수입니다.
ms | 선택적인 요소. 밀리초를 지정하는 0부터 999까지의 정수입니다.

참고

UTC 메서드는 UTC 1970년 1월 1일 자정과 주어진 날짜 사이의 시간을 밀리초로 반환합니다. 이 반환된 값은 setTime 메서드와 Date 개체 구성자에서 사용할 수 있습니다. 인수 값이 범위를 초과하거나 음수이면 이에 따라 저장된 다른 값들도 수정됩니다. 예를 들어 150초를 지정하면 JScript는 그 값을 2분 30초로 변환합니다.

UTC 메서드와 날짜를 받아들이는 Date 개체 구성자 사이의 차이점은 UTC 메서드는 UTC로 간주하고 Date 개체 구성자는 로컬 시간으로 간주한다는 것입니다.

UTC 메서드는 정적 메서드입니다. 따라서 Date 개체를 사용하기 전에는 만들 필요가 없습니다. UTC 메서드는 다음과 같이 호출합니다.

var datestring = "November 1, 1997 10:15 AM";
Date.UTC(datestring)
메모 만일 year가 0부터 99까지의 값이면 1900 + year를 연도로 사용합니다.

아래 예제는 UTC 메서드의 사용법을 보여줍니다.

function DaysBetweenDateAndNow(yr, mo, dy)
{
  var d, r, t1, t2, t3;
  var MinMilli = 1000 * 60
  var HrMilli = MinMilli * 60
  var DyMilli = HrMilli * 24
  t1 = Date.UTC(yr, mo, dy)
  d = new Date();
  t2 = d.getTime();
  if (t2 >= t1)
    t3 = t2 - t1;
  else
    t3 = t1 - t2;
  r = Math.round(t3 / DyMilli);
  return(r);
}


UTC 메서드

UTC 메서드
적용 대상 		언어 참조

Date 개체


UTC 메서드

UTC 메서드
참고 		언어 참조

Date 개체 메서드
setTime 메서드


Add 메서드(사전)

Add 메서드(Dictionary) 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
Dictionary 개체에 키-항목 쌍을 추가합니다.
구문
object.Add (key, item)

Add 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 Dictionary 개체의 이름입니다.
key | 필수적인 요소. 추가할 item과 연결된 key입니다.
item | 필수적인 요소. 추가할 key와 연결된 item입니다.

참고
key가 이미 존재하는 경우에는 오류가 발생합니다.

아래 예제는 Add 메서드의 사용법을 보여줍니다.

var d;
d = new ActiveXObject("Scripting.Dictionary");
d.Add("a", "Athens");
d.Add("b", "Belgrade");
d.Add("c", "Cairo");


Add 메서드(Dictionary)

Add 메서드(Dictionary)
적용 대상 		Scripting 런타임 참조

Dictionary 개체


Add 메서드(Dictionary)

Add 메서드(Dictionary)
참고 		Scripting 런타임 참조

Add 메서드(Folders)
Exists 메서드
Items 메서드
Keys 메서드
Remove 메서드
RemoveAll 메서드


CompareMode 속성

CompareMode 속성 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
Dictionary 개체의 문자열 키를 비교하기 위한 비교 모드를 설정하고 반환합니다.
구문
object.CompareMode[ = compare]

CompareMode 속성은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 Dictionary 개체의 이름입니다.
compare | 선택적인 요소. 사용하면 compare는 비교 모드를 나타내는 값입니다. 사용할 수 있는 값은 0(이진), 1(텍스트), 2(데이터베이스)가 있습니다. 2보다 큰 값은 특정 로케일 ID(LCID)를 참조하는 데 사용할 수 있습니다.

참고
이미 데이터가 들어있는 Dictionary 개체의 비교 모드를 바꾸면 오류가 발생합니다.

아래 예제는 CompareMode 속성의 사용법을 보여줍니다.

function TestCompareMode(key)
{
  // 변수를 만듭니다.
  var a, d;
  var BinaryCompare = 0, TextCompare = 1;
  d = new ActiveXObject("Scripting.Dictionary");
  // 비교 모드를 텍스트로 설정합니다.
  d.CompareMode = TextCompare;
  // 키와 항목을 추가합니다.
  d.Add("a", "Athens");
  d.Add("b", "Belgrade");
  d.Add("c", "Ciro");
  return(d.Item(key));
}


CompareMode 속성

CompareMode 속성
적용 대상 		Scripting 런타임 참조

Dictionary 개체


CompareMode 속성

CompareMode 속성
참고 		Scripting 런타임 참조

Key 속성


Count 속성

Count 속성 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
컬렉션이나 Dictionary 개체의 항목 수를 반환합니다. 읽기 전용입니다.
구문
object.Count

object는 항상 적용 대상 목록에 있는 항목 이름 중 하나입니다.

참고
아래 코드는 Count 속성의 사용법을 보여줍니다.
function CountDemo()
{
  var a, d, i, s;                 // 변수를 만듭니다.
  d = new ActiveXObject("Scripting.Dictionary");
  d.Add ("a", "Athens");          // 키와 항목을 추가합니다.
  d.Add ("b", "Belgrade");
  d.Add ("c", "Cairo");
  a = (new VBArray(d.Keys()));    // 키를 가져옵니다.
  s = "";
  for (i = 0; i < d.Count; i++)   //dictionary를 반복합니다.
  {
    s += a.getItem(i) + " - " + d(a.getItem(i)) + "<br>";
  }
  return(s);     		         // 결과를 반환합니다.
}


Count 속성

Count 속성
적용 대상 		Scripting 런타임 참조

Dictionary 개체
Drives 컬렉션
Files 컬렉션
Folders 컬렉션


Count 속성

Count 속성
참고 		Scripting 런타임 참조

CompareMode 속성
Item 속성
Key 속성


Exists 메서드

Exists 메서드 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
Dictionary 개체에 지정한 키가 있으면 true를, 그렇지 않으면 false를 반환합니다.
구문
object.Exists(key)

Exists 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 Dictionary 개체의 이름입니다.
key | 필수적인 요소. Dictionary 개체에서 검색할 Key 값입니다.

아래 예제는 Exists 메서드의 사용법을 보여줍니다.

function keyExists(k)
{
  var fso, s = "";
  d = new ActiveXObject("Scripting.Dictionary");
  d.Add("a", "Athens");
  d.Add("b", "Belgrade");
  d.Add("c", "Cairo");
  if (d.Exists(k))
    s += "지정한 키가 있습니다.";
  else
    s += "지정한 키가 없습니다.";
  return(s);
}


Exists 메서드

Exists 메서드
적용 대상 		Scripting 런타임 참조

Dictionary 개체


Exists 메서드

Exists 메서드
참고 		Scripting 런타임 참조

Add 메서드(Dictionary)
Items 메서드
Keys 메서드
Remove 메서드
RemoveAll 메서드


Item 속성

Item 속성 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
Dictionary 개체에서 지정한 key에 해당하는 item을 설정하거나 반환합니다. 컬렉션에서는 지정한 key를 기반으로 하는 item을 반환합니다. 읽기/쓰기가 가능합니다.
구문
object.Item(key)[ = newitem]

Item 속성은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 컬렉션이나 Dictionary 개체의 이름입니다.
key | 필수적인 요소. 검색하거나 추가할 item과 연결된 Key입니다.
newitem | 선택적인 요소. Dictionary 개체에만 사용하고, 컬렉션에 대해서는 사용하지 않습니다. 사용하면 newitem은 지정한 key와 연결된 새 값입니다.

참고
item을 변경할 때 key를 찾을 수 없으면 지정한 newitem에 새 key를 만듭니다. 기존 항목을 반환하려고 할 때 key를 찾을 수 없으면 새 key를 만들고 해당 항목은 비워둡니다.

아래 예제는 Item 속성의 사용법을 보여줍니다.

function DicTest(keyword)
{
  var a, d;
  d = new ActiveXObject("Scripting.Dictionary");
  d.Add("a", "Athens");
  d.Add("b", "Belgrade");
  d.Add("c", "Cairo");
  a = d.Item(keyword);
  return(a);
}


Item 속성

Item 속성
적용 대상 		Scripting 런타임 참조

Dictionary 개체
Drives 컬렉션
Files 컬렉션
Folders 컬렉션


Item 속성

Item 속성
참고 		Scripting 런타임 참조

CompareMode 속성
Count 속성
Key 속성


Items 메서드

Items 메서드 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
Dictionary 개체의 항목을 모두 포함한 배열을 반환합니다.
구문
object.Items( )

object는 항상 Dictionary 개체의 이름입니다.

참고
아래 코드는 Items 메서드의 사용법을 보여줍니다.
function ItemsDemo()
{
  var a, d, i, s;					// 변수를 만듭니다.
  d = new ActiveXObject("Scripting.Dictionary");
  d.Add ("a", "Athens");				// 키와 항목을 추가합니다.
  d.Add ("b", "Belgrade");
  d.Add ("c", "Cairo");
  a = (new VBArray(d.Items())).toArray();	// 항목을 가져옵니다.
  s = "";
  for (i in a)					// dictionary를 반복합니다.
  {
    s += a[i] + "<br>";
  }
  return(s);						// 결과를 반환합니다.
}


Items 메서드

Items 메서드
적용 대상 		Scripting 런타임 참조

Dictionary 개체


Items 메서드

Items 메서드
참고 		Scripting 런타임 참조

Add 메서드(Dictionary)
Exists 메서드
Keys 메서드
Remove 메서드
RemoveAll 메서드


Key 속성

Key 속성 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
Dictionary 개체에 key를 설정합니다.
구문
object.Key(key) = newkey

Key 속성은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 Dictionary 개체의 이름입니다.
key | 필수적인 요소. 변경될 Key 값입니다.
newkey | 필수적인 요소. 지정한 key를 대체할 새 값입니다.

참고
key를 변경할 때 key를 찾을 수 없으면 새 key값을 만들고 해당 item은 비워둡니다.

아래 예제는 Key 속성의 사용법을 보여줍니다.

var d;
d = new ActiveXObject("Scripting.Dictionary");

function AddStuff()
{
  var a;
  d.Add("a", "Athens");
  d.Add("b", "Belgrade");
  d.Add("c", "Cairo");
}

function ChangeKey(oldkey, newkey)
{
  var s;
  d.Key("c") = "Ca";
  s = oldkey + "키가 " + newkey + "(으)로 변경되었습니다. ";
  return(s);
}


Key 속성

Key 속성
적용 대상 		Scripting 런타임 참조

Dictionary 개체


Key 속성

Key 속성
참고 		Scripting 런타임 참조

CompareMode 속성
Count 속성
Item 속성


Keys 메서드

Keys 메서드 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
Dictionary 개체의 기존 키를 모두 포함한 배열을 반환합니다.
구문
object.Keys( )

object는 항상 Dictionary 개체의 이름입니다.

참고
아래 코드는 Keys 메서드의 사용법을 보여줍니다.
function KeysDemo()
{
  var a, d, i, s;					// 변수를 작성합니다.
  d = new ActiveXObject("Scripting.Dictionary");
  d.Add ("a", "Athens");				// 키와 항목을 추가합니다.
  d.Add ("b", "Belgrade");
  d.Add ("c", "Cairo");
  a = (new VBArray(d.Keys())).toArray();	// 키를 가져옵니다.
  s = "";
  for (i in a)					// dictionary를 반복합니다.
  {
    s += a[i] + " - " + d(a[i]) + "<br>";
  }
  return(s);						// 결과를 반환합니다.
}


Keys 메서드

Keys 메서드
적용 대상 		Scripting 런타임 참조

Dictionary 개체


Keys 메서드

Keys 메서드
참고 		Scripting 런타임 참조

Add 메서드(Dictionary)
Exists 메서드
Items 메서드
Remove 메서드
RemoveAll 메서드


Remove 메서드

Remove 메서드 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
Dictionary 개체에서 키-항목 쌍을 하나 제거합니다.
구문
object.Remove(key)

Remove 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 Dictionary 개체의 이름입니다.
key | 필수적인 요소. Dictionary 개체에서 제거하려는 키-항목 쌍과 연결된 Key입니다.

참고
지정한 키-항목 쌍이 없으면 오류가 발생합니다.

아래 코드는 Remove 메서드의 사용법을 보여줍니다.

var a, d, i, s;              // 변수를 만듭니다.
d = new ActiveXObject("Scripting.Dictionary");
d.Add ("a", "Athens");       // 키와 항목을 추가합니다.
d.Add ("b", "Belgrade");
d.Add ("c", "Cairo");
...
d.Remove("b");               // 두 번째 쌍을 제거합니다.


Remove 메서드

Remove 메서드
적용 대상 		Scripting 런타임 참조

Dictionary 개체


RemoveAll 메서드

RemoveAll 메서드 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
RemoveAll 메서드는 Dictionary 개체에서 키-항목 쌍을 모두 제거합니다.
구문
object.RemoveAll( )

object는 항상 Dictionary 개체의 이름입니다.

참고
아래 코드는 RemoveAll 메서드의 사용법을 보여줍니다.
var a, d, i;             // 변수를 만듭니다.
d = new ActiveXObject("Scripting.Dictionary");
d.Add ("a", "Athens");   // 키와 항목을 추가합니다.
d.Add ("b", "Belgrade");
d.Add ("c", "Cairo");
...
d.RemoveAll( );		// dictionary를 지웁니다.


RemoveAll 메서드

RemoveAll 메서드
적용 대상 		Scripting 런타임 참조

Dictionary 개체


RemoveAll 메서드

RemoveAll 메서드
참고 		Scripting 런타임 참조

Add 메서드(Dictionary)
Exists 메서드
Items 메서드
Keys 메서드
Remove 메서드


Remove 메서드

Remove 메서드
참고 		Scripting 런타임 참조

Add 메서드(Dictionary)
Exists 메서드
Items 메서드
Keys 메서드
RemoveAll 메서드


AvailableSpace 속성

AvailableSpace 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 드라이브나 네트워크 공유 영역에서 사용자가 사용할 수 있는 공간의 크기를 반환합니다.
구문
object.AvailableSpace

object는 항상 Drive 개체입니다.

참고
AvailableSpace 속성이 반환하는 값은 보통 FreeSpace 속성이 반환하는 값과 같습니다. 할당량을 지원하는 컴퓨터 시스템에서는 두 값이 서로 다를 수도 있습니다.

아래 코드는 AvailableSpace 속성의 사용법을 보여줍니다.

function ShowAvailableSpace(drvPath)
{
  var fso, d, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(fso.GetDriveName(drvPath));
  s = "드라이브 " + drvPath.toUpperCase() + " - ";
  s += d.VolumeName + "<br>";
  s += "사용 가능한 공간: " + d.AvailableSpace/1024 + " KB";
  return(s);
}


AvailableSpace 속성

AvailableSpace 속성
적용 대상 		Scripting 런타임 참조

Drive 개체


AvailableSpace 속성

AvailableSpace 속성
참고 		Scripting 런타임 참조

DriveLetter 속성
DriveType 속성
FileSystem 속성
FreeSpace 속성
IsReady 속성
Path 속성
RootFolder 속성
SerialNumber 속성
ShareName 속성
TotalSize 속성
VolumeName 속성


DriveLetter 속성

DriveLetter 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
실제 로컬 드라이브이나 네트워크 공유 영역의 드라이브 문자를 반환합니다. 읽기 전용입니다.
구문
object.DriveLetter

object는 항상 Drive 개체입니다.

참고
네트워크 공유 영역이 드라이브 문자에 연결되지 않는 경우와 같이 지정한 드라이브가 드라이브 문자에 연결되지 않으면 DriveLetter 속성은 빈 문자열("")을 반환합니다.

아래 코드는 DriveLetter 속성의 사용법을 보여줍니다.

function ShowDriveLetter(drvPath)
{
  var fso, d, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(fso.GetDriveName(drvPath));
  s = "드라이브 " + d.DriveLetter.toUpperCase( ) + ": - ";
  s += d.VolumeName + "<br>";
  s += "사용 가능한 공간: " + d.AvailableSpace/1024 + " KB";
  return(s);
}


DriveLetter 속성

DriveLetter 속성
적용 대상 		Scripting 런타임 참조

Drive 개체


DriveLetter 속성

DriveLetter 속성
참고 		Scripting 런타임 참조

AvailableSpace 속성
DriveType 속성
FileSystem 속성
FreeSpace 속성
IsReady 속성
Path 속성
RootFolder 속성
SerialNumber 속성
ShareName 속성
TotalSize 속성
VolumeName 속성


DriveType 속성

DriveType 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 드라이브의 형식을 나타내는 값을 반환합니다.
구문
object.DriveType

object는 항상 Drive 개체입니다.

참고
아래 코드는 DriveType 속성의 사용법을 보여줍니다.
function ShowDriveType(drvpath)
{
  var fso, d, s, t;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(drvpath);
  switch (d.DriveType)
  {
    case 0: t = "알 수 없음"; break;
    case 1: t = "이동식"; break;
    case 2: t = "고정"; break;
    case 3: t = "네트워크"; break;
    case 4: t = "CD-ROM"; break;
    case 5: t = "RAM 디스크"; break;
  }
  s = "드라이브 " + d.DriveLetter + ": - " + t;
  return(s);
}


DriveType 속성

DriveType 속성
적용 대상 		Scripting 런타임 참조

Drive 개체


DriveType 속성

DriveType 속성
참고 		Scripting 런타임 참조

AvailableSpace 속성
DriveLetter 속성
FileSystem 속성
FreeSpace 속성
IsReady 속성
Path 속성
RootFolder 속성
SerialNumber 속성
ShareName 속성
TotalSize 속성
VolumeName 속성


FileSystem 속성

FileSystem 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 드라이브에서 사용하는 파일 시스템의 형식을 반환합니다.
구문
object.FileSystem

object는 항상 Drive 개체입니다.

참고
사용할 수 있는 반환 형식에는 FAT, NTFS, CDFS 등이 포함됩니다.

아래 코드는 FileSystem 속성의 사용법을 보여줍니다.

function ShowFileSystemType(drvPath)
{
  var fso,d, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(drvPath);
  s = d.FileSystem;
  return(s);
}


FileSystem 속성

FileSystem 속성
적용 대상 		Scripting 런타임 참조

Drive 개체


FileSystem 속성

FileSystem 속성
참고 		Scripting 런타임 참조

AvailableSpace 속성
DriveLetter 속성
DriveType 속성
FreeSpace 속성
IsReady 속성
Path 속성
RootFolder 속성
SerialNumber 속성
ShareName 속성
TotalSize 속성
VolumeName 속성


FreeSpace 속성

FreeSpace 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 드라이브나 네트워크 공유 영역에서 사용할 수 있는 사용 가능한 공간의 크기를 반환합니다. 읽기 전용입니다.
구문
object.FreeSpace

object는 항상 Drive 개체입니다.

참고
FreeSpace 속성이 반환하는 값은 보통 AvailableSpace 속성이 반환하는 값과 같습니다. 할당량을 지원하는 컴퓨터 시스템에서는 두 값이 서로 다를 수도 있습니다.

아래 코드는 FreeSpace 속성의 사용법을 보여줍니다.

function ShowFreeSpace(drvPath)
{
  var fso, d, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(fso.GetDriveName(drvPath));
  s = "드라이브 " + drvPath.toUpperCase( ) + " - ";
  s += d.VolumeName + "<br>";
  s += "사용 가능한 공간: " + d.FreeSpace/1024 + " KB";
  return(s);
}


FreeSpace 속성

FreeSpace 속성
적용 대상 		Scripting 런타임 참조

Drive 개체


FreeSpace 속성

FreeSpace 속성
참고 		Scripting 런타임 참조

AvailableSpace 속성
DriveLetter 속성
DriveType 속성
FileSystem 속성
IsReady 속성
Path 속성
RootFolder 속성
SerialNumber 속성
ShareName 속성
TotalSize 속성
VolumeName 속성


IsReady 속성

IsReady 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 드라이브가 준비되면 true를, 그렇지 않으면 false를 반환합니다.
구문
object.IsReady

object는 항상 Drive 개체입니다.

참고
이동식 매체 드라이브와 CD-ROM 드라이브의 경우에는 적합한 매체가 삽입되고 액세스 준비가 끝난 경우에만 IsReady가 true를 반환합니다.

아래 코드는 IsReady 속성의 사용법을 보여줍니다.

function ShowDriveInfo(drvpath)
{
  var fso, d, s, t;
  fso = new ActiveXObject("Scripting.FileSystemObject")
  d = fso.GetDrive(drvpath)
  switch (d.DriveType)
  {
    case 0: t = "알 수 없음"; break;
    case 1: t = "이동식"; break;
    case 2: t = "고정"; break;
    case 3: t = "네트워크"; break;
    case 4: t = "CD-ROM"; break;
    case 5: t = "RAM 디스크"; break;
  }
  s = "드라이브 " + d.DriveLetter + ": - " + t;
  if (d.IsReady)
    s += "<br>" + "드라이브가 준비되었습니다.";
  else
    s += "<br>" + "드라이브가 준비되지 않았습니다.";
  return(s);
}


IsReady 속성

IsReady 속성
적용 대상 		Scripting 런타임 참조

Drive 개체


IsReady 속성

IsReady 속성
참고 		Scripting 런타임 참조

AvailableSpace 속성
DriveLetter 속성
DriveType 속성
FileSystem 속성
FreeSpace 속성
Path 속성
RootFolder 속성
SerialNumber 속성
ShareName 속성
TotalSize 속성
VolumeName 속성


Path 속성

Path 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 파일, 폴더, 또는 드라이브의 경로를 반환합니다.
구문
object.Path

object는 항상 File, Folder, 또는 Drive 개체입니다.

참고
드라이브 문자에 루트 드라이브는 포함되지 않습니다. 예를 들어, C 드라이브의 경로는 C:\가 아니라 C:입니다.

아래 코드는 File 개체에서 Path 속성의 사용법을 보여줍니다.

function ShowFileAccessInfo(filespec)
{
  var fso, d, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(filespec);
  s = f.Path.toUpperCase() + "<br>";
  s += "만든 날짜: " + f.DateCreated + "<br>";
  s += "마지막으로 액세스한 날짜: " + f.DateLastAccessed + "<br>";
  s += "마지막으로 수정한 날짜: " + f.DateLastModified
  return(s);
}


Path 속성

Path 속성
적용 대상 		Scripting 런타임 참조

Drive 개체
File 개체
Folder 개체


Path 속성

Path 속성
참고 		Scripting 런타임 참조

Attributes 속성
AvailableSpace 속성
DateCreated 속성
DateLastAccessed 속성
DateLastModified 속성
Drive 속성
DriveLetter 속성
DriveType 속성
Files 속성
FileSystem 속성
FreeSpace 속성
IsReady 속성
IsRootFolder 속성
Name 속성
ParentFolder 속성
RootFolder 속성
SerialNumber 속성
ShareName 속성
ShortName 속성
ShortPath 속성
Size 속성
SubFolders 속성
TotalSize 속성
Type 속성
VolumeName 속성


RootFolder 속성

RootFolder 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 드라이브의 루트 폴더를 나타내는 Folder 개체를 반환합니다. 읽기 전용입니다.
구문
object.RootFolder

object는 항상 Drive 개체입니다.

참고
반환한 Folder 개체를 사용하면 드라이브에 들어있는 모든 파일과 폴더에 액세스할 수 있습니다.

아래 예제는 RootFolder 속성의 사용법을 보여줍니다.

function GetRootFolder(drv)
{
  var fso,d;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  if (fso.DriveExists(drv))
    {
      d = fso.GetDrive(drv);
      return(d.RootFolder);
    }
  else
    return(false);
}


RootFolder 속성

RootFolder 속성
적용 대상 		Scripting 런타임 참조

Drive 개체


RootFolder 속성

RootFolder 속성
참고 		Scripting 런타임 참조

AvailableSpace 속성
DriveLetter 속성
DriveType 속성
FileSystem 속성
FreeSpace 속성
IsReady 속성
Path 속성
SerialNumber 속성
ShareName 속성
TotalSize 속성
VolumeName 속성


SerialNumber 속성

SerialNumber 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
디스크 볼륨을 고유하게 나타내는 데 사용하는 일련 번호를 십진수로 반환합니다.
구문
object.SerialNumber

object는 항상 Drive 개체입니다.

참고
이동식 매체를 사용하는 경우에는 SerialNumber 속성을 사용하여 드라이브에 적합한 디스크가 삽입되었는지 확인할 수 있습니다.

아래 코드는 SerialNumber 속성의 사용법을 보여줍니다.

function ShowDriveInfo(drvpath)
{
  var fso, d, s, t;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(fso.GetDriveName(fso.GetAbsolutePathName(drvpath)));
  switch (d.DriveType)
  {
    case 0: t = "알 수 없음"; break;
    case 1: t = "이동식"; break;
    case 2: t = "고정"; break;
    case 3: t = "네트워크"; break;
    case 4: t = "CD-ROM"; break;
    case 5: t = "RAM 디스크"; break;
  }
  s = "드라이브 " + d.DriveLetter + ": - " + t;
  s += "<br>" + "SN: " + d.SerialNumber;
  return(s);
}


SerialNumber 속성

SerialNumber 속성
적용 대상 		Scripting 런타임 참조

Drive 개체


SerialNumber 속성

SerialNumber 속성
참고 		Scripting 런타임 참조

AvailableSpace 속성
DriveLetter 속성
DriveType 속성
FileSystem 속성
FreeSpace 속성
IsReady 속성
Path 속성
RootFolder 속성
ShareName 속성
TotalSize 속성
VolumeName 속성


ShareName 속성

ShareName 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 드라이브의 네트워크 공유 이름을 반환합니다.
구문
object.ShareName

object는 항상 Drive 개체입니다.

참고
object가 네트워크 드라이브가 아니면 ShareName 속성이 빈 문자열("")을 반환합니다.

아래 코드는 ShareName 속성의 사용법을 보여줍니다.

function ShowDriveInfo(drvpath)
{
  var fso, d, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(fso.GetDriveName(fso.GetAbsolutePathName(drvpath)));
  s = "드라이브 " + d.DriveLetter + ": - " + d.ShareName;
  return(s);
}


ShareName 속성

ShareName 속성
적용 대상 		Scripting 런타임 참조

Drive 개체


ShareName 속성

ShareName 속성
참고 		Scripting 런타임 참조

AvailableSpace 속성
DriveLetter 속성
DriveType 속성
FileSystem 속성
FreeSpace 속성
IsReady 속성
Path 속성
RootFolder 속성
SerialNumber 속성
TotalSize 속성
VolumeName 속성


TotalSize 속성

TotalSize 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
드라이브나 네트워크 공유 영역의 전체 공간을 바이트 단위로 반환합니다.
구문
object.TotalSize

object는 항상 Drive 개체입니다.

참고
아래 코드는 TotalSize 속성의 사용법을 보여줍니다.
function SpaceReport(drvPath)
{
  var fso, d, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(fso.GetDriveName(drvPath));
  s = "드라이브 " + drvPath + " - ";
  s += d.VolumeName + "<br>";
  s += "전체 공간: "+ d.TotalSize/1024 + " KB <br>";
  s += "사용 가능한 공간:  " + d.FreeSpace/1024 + " KB";
  return(s);
}


TotalSize 속성

TotalSize 속성
적용 대상 		Scripting 런타임 참조

Drive 개체


TotalSize 속성

TotalSize 속성
참고 		Scripting 런타임 참조

AvailableSpace 속성
DriveLetter 속성
DriveType 속성
FileSystem 속성
FreeSpace 속성
IsReady 속성
Path 속성
RootFolder 속성
SerialNumber 속성
ShareName 속성
VolumeName 속성


VolumeName 속성

VolumeName 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 드라이브의 볼륨 이름을 설정하거나 반환합니다. 읽기/쓰기가 가능합니다.
구문
object.VolumeName [= newname]

VolumeName 속성은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 Drive 개체의 이름입니다.
newname | 선택적인 요소. 사용하면 newname은 지정한 object의 새 이름입니다.

참고
아래 코드는 VolumeName 속성의 사용법을 보여줍니다.
function SpaceReport(drvPath)
{
  var fso, d, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(fso.GetDriveName(drvPath));
  s = "드라이브 " + drvPath + " - ";
  s += d.VolumeName + "<br>";
  s += "전체 공간: "+ d.TotalSize/1024 + " KB <br>";
  s += "사용 가능한 공간:  " + d.FreeSpace/1024 + " KB";
  return(s);
}


VolumeName 속성

VolumeName 속성
적용 대상 		Scripting 런타임 참조

Drive 개체


VolumeName 속성

VolumeName 속성
참고 		Scripting 런타임 참조

AvailableSpace 속성
DriveLetter 속성
DriveType 속성
FileSystem 속성
FreeSpace 속성
IsReady 속성
Path 속성
RootFolder 속성
SerialNumber 속성
ShareName 속성
TotalSize 속성


atEnd 메서드

atEnd 메서드 		언어 참조
버전 3

참고 적용 대상

설명
열거자가 컬렉션 끝에 있는지 여부를 나타내는 부울값을 반환합니다.
구문
myEnum.atEnd( )

myEnum 인수는 Enumerator 개체이면 됩니다.

반환값
현재 항목이 컬렉션에 있는 마지막 항목이거나, 컬렉션이 비었거나, 현재 항목이 정의되어 있지 않으면 atEnd 메서드는 true를 반환합니다. 그렇지 않으면 false를 반환합니다.
참고
아래 코드에서 atEnd 메서드는 드라이브 목록의 마지막에 도달했는지를 확인하는 데 사용됩니다.
function ShowDriveList()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  for (; !e.atEnd(); e.moveNext())
  {
    x = e.item();
    s = s + x.DriveLetter;
    s += " - ";
    if (x.DriveType == 3)
      n = x.ShareName;
    else if (x.IsReady)
      n = x.VolumeName;
    else
      n = "[드라이브가 준비되지 않았습니다.]";
    s +=  n + "<br>";
  }
  return(s);
}


atEnd 메서드

atEnd 메서드
적용 대상 		언어 참조

Enumerator 개체


atEnd 메서드

atEnd 메서드
참고 		언어 참조

item 메서드
moveFirst 메서드
moveNext 메서드


item 메서드

item 메서드 		언어 참조
버전 3

참고 적용 대상

설명
컬렉션의 현재 항목을 반환합니다.
구문
myEnum.item( )

myEnum 인수는 Enumerator 개체이면 됩니다.

반환값
item 메서드는 현재 항목을 반환합니다. 컬렉션이 비었거나 현재 항목이 정의되어 있지 않으면 undefined 값을 반환합니다.
참고

아래 코드에서는 Drives 컬렉션의 구성원을 반환하는 데 item 메서드를 사용하였습니다.

function ShowDriveList()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  for (; !e.atEnd(); e.moveNext())
  {
    x = e.item();
    s = s + x.DriveLetter;
    s += " - ";
    if (x.DriveType == 3)
      n = x.ShareName;
    else if (x.IsReady)
      n = x.VolumeName;
    else
      n = "[드라이브가 준비되지 않았습니다.]";
    s +=  n + "<br>";
  }
  return(s);
}


item 메서드

item 메서드
적용 대상 		언어 참조

Enumerator 개체


item 메서드

item 메서드
참고 		언어 참조

atEnd 메서드
moveFirst 메서드
moveNext 메서드


moveFirst 메서드

moveFirst 메서드 		언어 참조
버전 3

참고 적용 대상

설명
컬렉션에서 현재 항목을 첫번째 항목으로 다시 설정합니다.
구문
myEnum.moveFirst( )

myEnum 인수는 Enumerator 개체이면 됩니다.

참고
컬렉션에 항목이 없으면 현재 항목은 undefined로 설정됩니다.

아래 예제에서는 Drives 컬렉션의 구성원을 목록의 처음부터 평가하기 위해 moveFirst 메서드를 사용하였습니다.

function ShowFirstAvailableDrive()
{
  var fso, s, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  e.moveFirst();
  s = "";
  do
  {
     x = e.item();
     if (x.IsReady)
     {
       s = x.DriveLetter + ":";
       break;
     }
     else
       if (e.atEnd())
       {
         s = "드라이브를 사용할 수 없습니다.";
         break;
       }
     e.moveNext();
  }
  while (!e.atEnd());
  return(s);
}


moveFirst 메서드

moveFirst 메서드
적용 대상 		언어 참조

Enumerator 개체


moveFirst 메서드

moveFirst 메서드
참고 		언어 참조

atEnd 메서드
item 메서드
moveNext 메서드


moveNext 메서드

moveNext 메서드 		언어 참조
버전 3

참고 적용 대상

설명
컬렉션에서 현재 항목을 다음 항목으로 옮깁니다.
구문
myEnum.moveNext( )

myEnum 인수는 Enumerator 개체이면 됩니다.

참고
열거자가 컬렉션 끝에 있거나 혹은 컬렉션이 비어있을 경우 현재 항목은 undefined로 설정됩니다.

다음 예제에서는 Drives 컬렉션에서 다음 드라이브로 항목을 이동하는 데 moveNext 메서드를 사용하였습니다.

function ShowDriveList()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  for (; !e.atEnd(); e.moveNext())
  {
    x = e.item();
    s = s + x.DriveLetter;
    s += " - ";
    if (x.DriveType == 3)
      n = x.ShareName;
    else if (x.IsReady)
      n = x.VolumeName;
    else
      n = "[드라이브가 준비되지 않았습니다.]";
    s +=  n + "<br>";
  }
  return(s);
}


moveNext 메서드

moveNext 메서드
적용 대상 		언어 참조

Enumerator 개체


moveNext 메서드

moveNext 메서드
참고 		언어 참조

atEnd 메서드
item 메서드
moveFirst 메서드


Attributes 속성

Attributes 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
파일이나 폴더의 특성을 설정하거나 반환합니다. 특성에 따라 읽기/쓰기가 가능하거나 읽기 전용입니다.
구문
object.Attributes [= newattributes]

Attributes 속성은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 File이나 Folder 개체의 이름입니다.
newattributes | 선택적인 요소. 사용하면 newattributes는 지정한 object의 특성에 해당하는 새 값입니다.

설정
newattributes 인수는 아래 값이나 아래 값의 논리 조합을 가질 수 있습니다.

상수 | 값 | 설명
Normal | 0 | 일반 파일. 설정된 특성이 없습니다.
ReadOnly | 1 | 읽기 전용 파일. 특성은 읽기/쓰기가 가능합니다.
Hidden | 2 | 숨겨진 파일. 특성은 읽기/쓰기가 가능합니다.
System | 4 | 시스템 파일. 특성은 읽기/쓰기가 가능합니다.
Volume | 8 | 디스크 드라이브 볼륨 레이블. 특성은 읽기 전용입니다.
Directory | 16 | 폴더 또는 디렉터리. 특성은 읽기 전용입니다.
Archive | 32 | 마지막으로 백업한 후 파일이 변경되었습니다. 특성은 읽기/쓰기가 가능합니다.
Alias | 64 | 연결 또는 바로 가기. 특성은 읽기 전용입니다.
Compressed | 128 | 압축 파일. 특성은 읽기 전용입니다.

참고
아래 코드는 파일에서 Attributes 속성의 사용법을 보여줍니다.
function ToggleArchiveBit(filespec)
{
  var fso, f, r, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(filespec)
  if (f.attributes && 32)
  {
    f.attributes = f.attributes - 32;
    s = "Archive 비트를 지웠습니다.";
  }
  else
  {
    f.attributes = f.attributes + 32;
    s =  "Archive 비트를 설정했습니다.";
  }
  return(s);
}


Attributes 속성

Attributes 속성
적용 대상 		Scripting 런타임 참조

File 개체
Folder 개체


Attributes 속성

Attributes 속성
참고 		Scripting 런타임 참조

DateCreated 속성
DateLastAccessed 속성
DateLastModified 속성
Drive 속성
Files 속성
IsRootFolder 속성
Name 속성
ParentFolder 속성
Path 속성
ShortName 속성
ShortPath 속성
Size 속성
SubFolders 속성
Type 속성


Copy 메서드

Copy 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 파일이나 폴더를 기존 위치에서 다른 위치로 복사합니다.
구문
object.Copy( destination[, overwrite] );

Copy 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 File 또는 Folder 개체의 이름입니다.
destination | 필수적인 요소. 파일 또는 폴더를 복사할 위치입니다. 와일드카드 문자는 사용할 수 없습니다.
overwrite | 선택적인 요소. true(기본값)이면 기존 파일이나 폴더를 덮어쓰고 false이면 덮어쓰지 않는 부울값입니다.

참고
File이나 Folder에 Copy 메서드를 사용하면 object에 의해 참조되는 파일이나 폴더를 인수로 전달하는 FileSystemObject.CopyFile이나 FileSystemObject.CopyFolder를 사용한 결과와 동일합니다. 그러나 이런 대체 메서드를 사용하면 파일이나 폴더를 한번에 여러 개 복사할 수 있습니다.

아래 예제는 Copy 메서드의 사용법을 보여줍니다.

var fso, f;
fso = new ActiveXObject("Scripting.FileSystemObject");
f = fso.CreateTextFile("c:\\testfile.txt", true);
f.WriteLine("테스트입니다.");
f.Close();
f = fso.GetFile("c:\\testfile.txt");
f.Copy("c:\\windows\\desktop\\test2.txt");


Copy 메서드

Copy 메서드
적용 대상 		Scripting 런타임 참조

File 개체
Folder 개체


Copy 메서드

Copy 메서드
참고 		Scripting 런타임 참조

CopyFile 메서드
CopyFolder 메서드
Delete 메서드
Move 메서드
OpenAsTextStream 메서드


CreateTextFile 메서드

CreateTextFile 메서드 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
지정된 파일 이름을 만들고 그 파일을 읽거나 쓰는 데 사용할 수 있는 TextStream 개체를 반환합니다.
구문
object.CreateTextFile(filename[, overwrite[, unicode]])

CreateTextFile 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject 또는 Folder 개체의 이름입니다.
filename | 필수적인 요소. 만들 파일을 나타내는 문자식입니다.
overwrite | 선택적인 요소. 기존 파일을 덮어쓸지 여부를 나타내는 부울값입니다. true이면 파일을 덮어쓰고, false이면 덮어쓰지 않습니다. 생략하면 기존 파일을 덮어쓸 수 없습니다.
unicode | 선택적인 요소. 파일을 유니코드와 ASCII 중 어느 것으로 만들지를 나타내는 부울값입니다. true이면 유니코드 파일을, false이면 ASCII 파일을 만듭니다. 생략하면 ASCII 파일인 것으로 간주합니다.

참고
아래 코드는 CreateTextFile 메서드를 사용하여 텍스트 파일을 만들고 여는 방법을 보여줍니다.
var fso = new ActiveXObject("Scripting.FileSystemObject");
var a = fso.CreateTextFile("c:\\testfile.txt", true);
a.WriteLine("테스트입니다.");
a.Close();
이미 존재하는 filename에 overwrite 인수가 false이거나 지정되어 있지 않으면 오류가 발생합니다.


CreateTextFile 메서드

CreateTextFile 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체
Folder 개체


CreateTextFile 메서드

CreateTextFile 메서드
참고 		Scripting 런타임 참조

CreateFolder 메서드
OpenAsTextStream 메서드
OpenTextFile 메서드


DateCreated 속성

DateCreated 속성 		Scripting 런타임 참조
버전 3

참고 적용

설명
지정한 파일이나 폴더가 만들어진 날짜와 시간을 반환합니다. 읽기 전용입니다.
구문
object.DateCreated

object는 항상 File 또는 Folder 개체입니다.

참고
아래 코드는 파일에서 DateCreated 속성의 사용법을 보여줍니다.
function ShowFileInfo(filespec)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(filespec);
  s = "만든 날짜: " + f.DateCreated;
  return(s);
}


DateCreated 속성

DateCreated 속성
적용 대상 		Scripting 런타임 참조

File 개체
Folder 개체


DateCreated 속성

DateCreated 속성
참고 		Scripting 런타임 참조

Attributes 속성
DateLastAccessed 속성
DateLastModified 속성
Drive 속성
Files 속성
IsRootFolder 속성
Name 속성
ParentFolder 속성
Path 속성
ShortName 속성
ShortPath 속성
Size 속성
SubFolders 속성
Type 속성


DateLastAccessed 속성

DateLastAccessed 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 파일이나 폴더에 마지막으로 액세스한 날짜와 시간을 반환합니다. 읽기 전용입니다.
구문
object.DateLastAccessed

object는 항상 File 또는 Folder 개체입니다.

참고
아래 코드는 파일에서 DateLastAccessed 속성의 사용법을 보여줍니다.
function ShowFileAccessInfo(filespec)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(filespec);
  s = filespec.toUpperCase() + "<br>";
  s += "만든 날짜: " + f.DateCreated + "<br>";
  s += "마지막으로 액세스한 날짜: " + f.DateLastAccessed + "<br>";
  s += "마지막으로 수정한 날짜: " + f.DateLastModified;
  return(s);
}
중요 이 메서드는 사용하는 운영 체제에 따라 동작이 달라집니다. 운영 체제에서 시간 정보 제공 기능을 지원하지 않으면 아무런 값도 반환되지 않습니다.


DateLastAccessed 속성

DateLastAccessed 속성
적용 대상 		Scripting 런타임 참조

File 개체
Folder 개체


DateLastAccessed 속성

DateLastAccessed 속성
참고 		Scripting 런타임 참조

Attributes 속성
DateCreated 속성
DateLastModified 속성
Drive 속성
Files 속성
IsRootFolder 속성
Name 속성
ParentFolder 속성
Path 속성
ShortName 속성
ShortPath 속성
Size 속성
SubFolders 속성
Type 속성


DateLastModified 속성

DateLastModified 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 파일이나 폴더를 마지막으로 수정한 날짜와 시간을 반환합니다. 읽기 전용입니다.
구문
object.DateLastModified

object는 항상 File 또는 Folder 개체입니다.

참고
아래 코드는 파일에서 DateLastModified 속성의 사용법을 보여줍니다.
function ShowFileAccessInfo(filespec)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(filespec);
  s = filespec.toUpperCase() + "<br>";
  s += "만든 날짜: " + f.DateCreated + "<br>";
  s += "마지막으로 액세스한 날짜: " + f.DateLastAccessed + "<br>";
  s += "마지막으로 수정한 날짜: " + f.DateLastModified;
  return(s);
}


DateLastModified 속성

DateLastModified 속성
적용 대상 		Scripting 런타임 참조

File 개체
Folder 개체


DateLastModified 속성

DateLastModified 속성
참고 		Scripting 런타임 참조

Attributes 속성
DateCreated 속성
DateLastAccessed 속성
Drive 속성
Files 속성
IsRootFolder 속성
Name 속성
ParentFolder 속성
Path 속성
ShortName 속성
ShortPath 속성
Size 속성
SubFolders 속성
Type 속성


Delete 메서드

Delete 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 파일이나 폴더를 삭제합니다.
구문
object.Delete( force );

Delete 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 File 또는 Folder 개체의 이름입니다.
force | 선택적인 요소. true이면 읽기 전용 특성 집합을 가진 파일이나 폴더를 삭제하고 false(기본값)이면 삭제하지 않는 부울값입니다.

참고
지정한 파일이나 폴더가 없으면 오류가 발생합니다.

File이나 Folder에 Delete 메서드를 사용하면 FileSystemObject.DeleteFile이나 FileSystemObject.DeleteFolder를 사용하는 것과 동일한 결과가 나올 수 있습니다.

Delete 메서드는 내용이 있는 폴더와 내용이 없는 폴더를 구분하지 않습니다. 지정한 폴더는 내용이 있든 없든 삭제됩니다.

아래 예제는 Delete 메서드의 사용법을 보여줍니다.

var fso, f;
fso = new ActiveXObject("Scripting.FileSystemObject");
f = fso.CreateTextFile("c:\\testfile.txt", true);
f.WriteLine("테스트입니다.");
f.Close();
f = fso.GetFile("c:\\testfile.txt");
f.Delete();


Delete 메서드

Delete 메서드
적용 대상 		Scripting 런타임 참조

File 개체
Folder 개체


Delete 메서드

Delete 메서드
참고 		Scripting 런타임 참조

Copy 메서드
DeleteFile 메서드
DeleteFolder 메서드
Move 메서드
OpenAsTextStream 메서드


Drive 속성

Drive 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 파일이나 폴더가 있는 드라이브의 드라이브 문자를 반환합니다. 읽기 전용입니다.
구문
object.Drive

object는 항상 File 또는 Folder 개체입니다.

참고
아래 코드는 Drive 속성의 사용법을 보여줍니다.
function ShowFileAccessInfo(filespec)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(filespec);
  s = f.Name + " on Drive " + f.Drive + "<br>";
  s += "만든 날짜: " + f.DateCreated + "<br>";
  s += "마지막으로 액세스한 날짜: " + f.DateLastAccessed + "<br>";
  s += "마지막으로 수정한 날짜: " + f.DateLastModified;
  return(s);
}


Drive 속성

Drive 속성
적용 대상 		Scripting 런타임 참조

File 개체
Folder 개체


Drive 속성

Drive 속성
참고 		Scripting 런타임 참조

Attributes 속성
DateCreated 속성
DateLastAccessed 속성
DateLastModified 속성
Files 속성
IsRootFolder 속성
Name 속성
ParentFolder 속성
Path 속성
ShortName 속성
ShortPath 속성
Size 속성
SubFolders 속성
Type 속성


Move 메서드

Move 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 파일이나 폴더를 기존 위치에서 다른 위치로 옮깁니다.
구문
object.Move( destination );

Move 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 File이나 Folder 개체의 이름입니다.
destination | 필수적인 요소. 파일이나 폴더를 옮길 대상입니다. 와일드카드 문자는 사용할 수 없습니다.

참고
File이나 Folder에 Move 메서드를 사용하면 FileSystemObject.MoveFile이나 FileSystemObject.MoveFolder를 사용한 결과와 동일합니다. 그러나 이런 대체 메서드를 사용하면 파일이나 폴더를 한번에 여러 개 옮길 수 있습니다.


Move 메서드

Move 메서드
적용 대상 		Scripting 런타임 참조

File 개체
Folder 개체


Move 메서드

Move 메서드
참고 		Scripting 런타임 참조

Copy 메서드
Delete 메서드
MoveFile 메서드
MoveFolder 메서드
OpenAsTextStream 메서드


Name 속성

Name 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 파일이나 폴더의 이름을 설정하거나 반환합니다. 읽기/쓰기가 가능합니다.
구문
object.Name [= newname]

Name 속성은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. File이나 Folder 개체의 이름입니다.
newname | 선택적인 요소. 사용하면 newname은 지정한 object의 새 이름입니다.

참고
아래 코드는 Name 속성의 사용법을 보여줍니다.
function ShowFileAccessInfo(filespec)
{
    var fso, f, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    f = fso.GetFile(filespec);
    s = f.Name + " on Drive " + f.Drive + "<br>";
    s += "만든 날짜: " + f.DateCreated + "<br>";
    s += "마지막으로 액세스한 날짜: " + f.DateLastAccessed + "<br>";
    s += "마지막으로 수정한 날짜: " + f.DateLastModified;
    return(s);
}


Name 속성

Name 속성
적용 대상 		Scripting 런타임 참조

File 개체
Folder 개체


Name 속성

Name 속성
참고 		Scripting 런타임 참조

Attributes 속성
DateCreated 속성
DateLastAccessed 속성
DateLastModified 속성
Drive 속성
Files 속성
IsRootFolder 속성
ParentFolder 속성
Path 속성
ShortName 속성
ShortPath 속성
Size 속성
SubFolders 속성
Type 속성


OpenAsTextStream 메서드

OpenAsTextStream 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 파일을 열고 그 파일을 읽거나, 쓰거나, 추가하는 데 사용할 수 있는 TextStream 개체를 반환합니다.
구문
object.OpenAsTextStream([iomode, [format]])

OpenAsTextStream 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 File 개체의 이름입니다.
iomode | 선택적인 요소. 입출력 모드를 표시합니다. 세 가지 상수, 즉 ForReading, ForWriting, ForAppending 중 하나이면 됩니다.
format | 선택적인 요소. 열려있는 파일의 형식을 나타내는 데 사용되는 세 가지 Tristate 값 중 하나입니다. 생략하면 파일은 ASCII 형식으로 열립니다.

설정
iomode 인수는 다음 설정값을 가질 수 있습니다.

상수 | 값 | 설명
ForReading | 1 | 읽기 전용 모드로 파일을 엽니다. 이 파일에는 쓸 수 없습니다.
ForWriting | 2 | 쓰기 모드로 파일을 엽니다. 같은 이름의 파일이 있으면 기존 내용을 덮어씁니다.
ForAppending | 8 | 파일을 열고 파일의 끝에 씁니다.

format 인수는 아래의 설정값을 가질 수 있습니다.

상수 | 값 | 설명
TristateUseDefault | -2 | 시스템 기본값으로 파일을 엽니다.
Tristatetrue | -1 | 유니코드 형식으로 파일을 엽니다.
Tristatefalse | 0 | ASCII 형식으로 파일을 엽니다.

참고
OpenAsTextStream 메서드는 FileSystemObject의 OpenTextFile 메서드와 같은 기능을 제공합니다. 또한 OpenAsTextStream 메서드는 파일에 쓰는 데 사용할 수도 있습니다.

아래 코드는 OpenAsTextStream 메서드의 사용법을 보여줍니다.

function TextStreamTest( )
{
    var fso, f, ts, s;
    var ForReading = 1, ForWriting = 2, ForAppending = 8;
    var TristateUseDefault = -2, Tristatetrue = -1, Tristatefalse = 0;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    fso.CreateTextFile( "test1.txt" );           // 파일을 만듭니다.
    f = fso.GetFile("test1.txt");
    ts = f.OpenAsTextStream(ForWriting, TristateUseDefault);
    ts.Write( "안녕하십니까?" );
    ts.Close( );
    ts = f.OpenAsTextStream(ForReading, TristateUseDefault);
    s = ts.ReadLine( );
    ts.Close( );
    return(s);
}


OpenAsTextStream 메서드

OpenAsTextStream 메서드
적용 대상 		Scripting 런타임 참조

File 개체


OpenAsTextStream 메서드

OpenAsTextStream 메서드
참고 		Scripting 런타임 참조

Copy 메서드
CreateTextFile 메서드
Delete 메서드
Move 메서드
OpenTextFile 메서드


OpenTextFile 메서드

OpenTextFile 메서드 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
지정한 파일을 열고 그 파일을 읽거나, 쓰거나, 추가하는 데 사용할 수 있는 TextStream 개체를 반환합니다.
구문
object.OpenTextFile(filename[, iomode[, create[, format]]])

OpenTextFile 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. object는 항상 FileSystemObject의 이름입니다.
filename | 필수적인 요소. 열려 있는 파일을 나타내는 문자식입니다.
iomode | 선택적인 요소. 세 가지 상수 즉, ForReading, ForWriting, 또는 ForAppending 중 하나이면 됩니다.
create | 선택적인 요소. 지정한 filename이 없을 경우 새 파일을 만들지 여부를 나타내는 부울값입니다. 이 값이 true이면 새 파일을 만들고 false이면 새 파일을 만들지 않습니다. 이 값을 생략해도 새 파일을 만들지 않습니다.
format | 선택적인 요소. 열려있는 파일의 형식을 나타내기 위해 사용되는 세 가지 Tristate 값 중 하나입니다. 생략하면 파일은 ASCII 형식으로 열립니다.

설정
iomode 인수는 아래 설정값을 가질 수 있습니다:

상수 | 값 | 설명
ForReading | 1 | 읽기 전용 모드로 파일을 엽니다. 이 파일에는 쓸 수 없습니다.
ForWriting | 2 | 쓰기 모드로 파일을 엽니다.
ForAppending | 8 | 파일을 열고 파일의 끝에 쓸 수 있습니다.

format 인수는 아래 설정값을 가질 수 있습니다.

값 | 설명
Tristatetrue | 유니코드 형식으로 파일을 엽니다.
Tristatefalse | ASCII 형식으로 파일을 엽니다.
TristateUseDefault | 시스템 기본값으로 파일을 엽니다.

참고
아래 코드는 OpenTextFile 메서드를 사용하여 텍스트를 추가할 파일을 여는 방법을 보여줍니다.
var fs, a, ForAppending;
ForAppending = 8;
fs = new ActiveXObject("Scripting.FileSystemObject");
a = fs.OpenTextFile("c:\\testfile.txt", ForAppending, false);
...
a.Close();


OpenTextFile 메서드

OpenTextFile 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


OpenTextFile 메서드

OpenTextFile 메서드
참고 		Scripting 런타임 참조

CreateTextFile 메서드
OpenAsTextStream 메서드


ParentFolder 속성

ParentFolder 속성 		Scripting 런타임 제어
버전 3

참고 적용 대상

설명
지정한 파일이나 폴더의 상위 폴더에 해당하는 폴더 개체를 반환합니다. 읽기 전용입니다.
구문
object.ParentFolder

object는 항상 File 또는 Folder 개체입니다.

참고
아래 코드는 파일에서 ParentFolder 속성의 사용법을 보여줍니다.
function ShowFileAccessInfo(filespec)
{
    var fso, f, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    f = fso.GetFile(filespec);
    s = f.Name + " in " + f.ParentFolder + "<br>";
    s += "만든 날짜: " + f.DateCreated + "<br>";
    s += "마지막으로 액세스한 날짜: " + f.DateLastAccessed + "<br>";
    s += "마지막으로 수정한 날짜: " + f.DateLastModified;
    return(s);
}


ParentFolder 속성

ParentFolder 속성
적용 대상 		Scripting 런타임 참조

File 개체
Folder 개체


ParentFolder 속성

ParentFolder 속성
참고 		Scripting 런타임 참조

Attributes 속성
DateCreated 속성
DateLastAccessed 속성
DateLastModified 속성
Drive 속성
Files 속성
IsRootFolder 속성
Name 속성
Path 속성
ShortName 속성
ShortPath 속성
Size 속성
SubFolders 속성
Type 속성


ShortName 속성

ShortName 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
예전 8.3 명명 규칙을 따르는 프로그램에서 사용되는 짧은 이름을 반환합니다.
구문
object.ShortName

object는 항상 File 또는 Folder 개체입니다.

설명
아래 코드는 File 개체에서 ShortName 속성의 사용법을 보여줍니다.
function ShowShortName(filespec)
{
    var fso, f, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    f = fso.GetFile(filespec);
    s = "" + f.Name;
    s += "" + "의 짧은 이름:" + "<br>";
    s += "" + f.ShortName + "";
    return(s);
}


ShortName 속성

ShortName 속성
적용 대상 		Scripting 런타임 참조

File 개체
Folder 개체


ShortName 속성

ShortName 속성
참고 		Scripting 런타임 참조

Attributes 속성
DateCreated 속성
DateLastAccessed 속성
DateLastModified 속성
Drive 속성
Files 속성
IsRootFolder 속성
Name 속성
ParentFolder 속성
Path 속성
ShortPath 속성
Size 속성
SubFolders 속성
Type 속성


ShortPath 속성

ShortPath 속성 		Scripting 런타임 참조
Version 3

참고 적용 대상

설명
예전 8.3 명명 규칙을 따르는 프로그램에서 사용되는 짧은 경로를 반환합니다.
구문
object.ShortPath

object는 항상 File 또는 Folder 개체입니다.

참고
아래 코드는 File 개체에서 ShortPath 속성의 사용법을 보여줍니다.
function ShowShortPath(filespec)
{
    var fso, f, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    f = fso.GetFile(filespec);
    s = "" + f.Name;
    s += "" + "의 짧은 경로:" + "<br>";
    s += "" + f.ShortPath + "";
    return(s);
}


ShortPath 속성

ShortPath 속성
적용 대상 		Scripting 런타임 참조

File 개체
Folder 개체


ShortPath 속성

ShortPath 속성
참고 		Scripting 런타임 참조

Attributes 속성
DateCreated 속성
DateLastAccessed 속성
DateLastModified 속성
Drive 속성
Files 속성
IsRootFolder 속성
Name 속성
ParentFolder 속성
Path 속성
ShortName 속성
Size 속성
SubFolders 속성
Type 속성


Size 속성

Size 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
파일에서는 지정한 파일의 크기를 바이트 단위로 반환하고 폴더에서는 지정한 폴더에 들어있는 모든 파일과 하위 폴더의 크기를 바이트 단위로 반환합니다.
구문
object.Size

object는 File 또는 Folder 개체입니다.

설명
아래 코드는 Folder 개체에서 Size 속성의 사용법을 보여줍니다.
function ShowFolderSize(filespec)
{
    var fso, f, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    f = fso.GetFolder(filespec);
    s = f.Name + "은(는) " + f.size + "바이트 사용합니다.";
    return(s);
}


Size 속성

Size 속성
적용 대상 		Scripting 런타임 참조

File 개체
Folder 개체


Size 속성

Size 속성
참고 		Scripting 런타임 참조

Attributes 속성
DateCreated 속성
DateLastAccessed 속성
DateLastModified 속성
Drive 속성
Files 속성
IsRootFolder 속성
Name 속성
ParentFolder 속성
Path 속성
ShortName 속성
ShortPath 속성
SubFolders 속성
Type 속성


BuildPath 메서드

BuildPath 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
기존 경로에 이름을 추가합니다.
구문
object.BuildPath(path, name)

BuildPath 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
path | 필수적인 요소. name이 추가되는 기존 경로입니다. 경로는 절대 경로나 상대 경로 모두 될 수 있으며 기존 폴더를 지정할 필요도 없습니다.
name | 필수적인 요소. 기존 path에 추가할 이름입니다.

참고
필요할 경우 BuildPath 메서드는 기존 경로와 이름 사이에 경로 구분 기호를 추가합니다.

아래 예제는 BuildPath 메서드의 사용법을 보여줍니다.

function GetBuildPath(path)
{
  var fso, newpath;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  newpath = fso.BuildPath(path, "새 폴더");
  return(newpath);
}


BuildPath 메서드

BuildPath 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


BuildPath 메서드

BuildPath 메서드
참고 		Scripting 런타임 참조

GetAbsolutePathName 메서드
GetBaseName 메서드
GetDriveName 메서드
GetExtensionName 메서드
GetFileName 메서드
GetParentFolderName 메서드
GetTempName 메서드


CopyFile 메서드

CopyFile 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
하나 이상의 파일을 기존 위치에서 다른 위치로 복사합니다.
구문
object.CopyFile ( source, destination:[, overwrite] )

CopyFile 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. object는 항상 FileSystemObject의 이름입니다.
source | 필수적인 요소. 복사할 하나 이상의 파일에 대한 문자열 파일입니다. 와일드카드 문자를 사용할 수 있습니다.
destination | 필수적인 요소. source의 파일을 복사할 문자열 대상입니다. 와일드카드 문자는 사용할 수 없습니다.
overwrite | 선택적인 요소. 기존 파일을 덮어쓸지 여부를 나타내는 부울값입니다. 부울값이 true이면 파일을 덮어쓰고, false이면 덮어쓰지 않습니다. 기본값은 true입니다. overwrite 값에 관계없이 destination이 읽기 전용 특성 집합을 가지면 CopyFile은 수행할 수 없습니다.

참고
와일드카드 문자는 source 인수의 마지막 경로 구성 요소에만 사용할 수 있습니다. 예를 들어, 다음과 같이 사용할 수 있습니다.
fso = new ActiveXObject("Scripting.FileSystemObject");
fso.CopyFile ("c:\\mydocuments\\letters\\*.doc", "c:\\tempfolder\\")
그러나 다음과 같이 사용할 수는 없습니다.
fso = new ActiveXObject("Scripting.FileSystemObject");
fso.CopyFile ("c:\\mydocuments\\*\\R1???97.xls", "c:\\tempfolder")
source에 와일드카드 문자를 사용하거나 destination이 경로 구분 기호(\)로 끝나면 destination은 일치하는 파일을 복사할 기존 폴더를 나타냅니다. 그렇지 않으면 destination은 만들려는 파일의 이름을 나타냅니다. 둘 중 어느 경우라도 개별 파일을 복사할 때 아래 세 가지 중 하나가 일어날 수 있습니다.
  • destination이 없으면 source가 복사됩니다. 일반적인 경우입니다.
  • destination이 기존 파일이고 overwrite가 false이면 오류가 발생합니다. 그렇지 않으면 source는 기존 파일을 덮어씁니다.
  • destination이 디렉터리면 오류가 발생합니다.
와일드카드 문자를 사용한 source와 일치하는 파일이 없으면 오류가 발생합니다. CopyFile 메서드는 첫 번째 오류가 발생하면 그 상태로 중지합니다. 이때 오류가 발생하기 전에 변경된 사항은 되돌릴 수 없습니다.


CopyFile 메서드

CopyFile 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


CopyFile 메서드

CopyFile 메서드
참고 		Scripting 런타임 참조

Copy 메서드
CopyFolder 메서드
CreateTextFile 메서드
DeleteFile 메서드
MoveFile 메서드


CopyFolder 메서드

CopyFolder 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
폴더를 기존 위치에서 다른 위치로 반복 복사합니다.
구문
object.CopyFolder ( source, destination[, overwrite] );

CopyFolder 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
source | 필수적인 요소. 복사할 하나 이상의 폴더에 대한 문자열 폴더입니다. 와일드카드 문자를 사용할 수 있습니다.
destination | 필수적인 요소. 폴더와 source의 하위 폴더를 복사할 문자열 대상입니다. 와일드카드 문자는 사용할 수 없습니다.
overwrite | 선택적인 요소. 기존 폴더를 덮어쓸지 여부를 나타내는 부울값입니다. 부울값이 true이면 파일을 덮어쓰고, false이면 덮어쓰지 않습니다. 기본값은 true입니다.

참고
와일드카드 문자는 source 인수의 마지막 경로 구성 요소에만 사용할 수 있습니다. 예를 들어, 다음과 같이 사용할 수 있습니다.
fso = new ActiveXObject("Scripting.FileSystemObject");
fso.CopyFolder ("c:\\mydocuments\\letters\\*", "c:\\tempfolder\\")
그러나 다음과 같이 사용할 수는 없습니다.
fso = new ActiveXObject("Scripting.FileSystemObject");
fso.CopyFolder ("c:\\mydocuments\\*\\*", "c:\\tempfolder\\")
source에 와일드카드 문자를 사용하거나 destination이 경로 구분 기호(\)로 끝나면 destination은 일치하는 폴더와 하위 폴더를 복사할 기존 폴더를 나타냅니다. 그렇지 않으면 destination은 만들려는 폴더의 이름을 나타냅니다. 둘 중 어느 경우라도 개별 폴더를 복사할 때 아래 네 가지 경우가 일어날 수 있습니다.
  • source가 없으면 source 폴더와 그 내용이 모두 복사됩니다. 일반적인 경우입니다.
  • destination이 기존 파일이면 오류가 발생합니다.
  • destination이 디렉터리이면 폴더와 그 내용이 모두 복사됩니다. source가 이미 destination에 있고, overwrite가 false이면 오류가 발생합니다. 그렇지 않으면 기존 파일을 덮어쓰게 됩니다.
  • destination이 읽기 전용 디렉터리이고 기존의 읽기 전용 파일을 그 디렉터리로 복사하려고 할 때 overwrite가 false이면 오류가 발생합니다.
와일드카드 문자를 사용한 source와 일치하는 폴더가 없으면 오류가 발생합니다.

CopyFolder 메서드는 첫 번째 오류가 발생하면 그 상태로 중지합니다. 이때 오류가 발생하기 전에 변경된 사항은 되돌릴 수 없습니다.


CopyFolder 메서드

CopyFolder 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


CopyFolder 메서드

CopyFolder 메서드
참고 		Scripting 런타임 참조

CopyFile 메서드
Copy 메서드
CreateFolder 메서드
DeleteFolder 메서드
MoveFolder 메서드


CreateFolder 메서드

CreateFolder 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
폴더를 만듭니다.
구문
object.CreateFolder(foldername)

CreateFolder 메서드는 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
foldername | 필수적인 요소. 만들 폴더를 나타내는 문자식입니다.

참고
지정한 폴더가 이미 있으면 오류가 발생합니다.

아래 코드는 CreateFolder 메서드를 사용하여 폴더를 만드는 법을 보여줍니다.

var fso = new ActiveXObject("Scripting.FileSystemObject");
var a = fso.CreateFolder("c:\\new folder");


CreateFolder 메서드

CreateFolder 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


CreateFolder 메서드

CreateFolder 메서드
참고 		Scripting 런타임 참조

CopyFolder 메서드
DeleteFolder 메서드
MoveFolder 메서드


DeleteFile 메서드

DeleteFile 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 파일을 삭제합니다.
구문
object.DeleteFile ( filespec[, force] );

DeleteFile 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
filespec | 필수적인 요소. 삭제할 파일의 이름입니다. filespec은 마지막 경로 구성 요소에 와일드카드 문자를 사용할 수 있습니다.
force | 선택적인 요소. true이면 읽기 전용 특성 집합을 가진 파일을 삭제하고, false이면 삭제하지 않는 부울값입니다.

참고
일치하는 파일이 없으면 오류가 발생합니다. DeleteFile 메서드는 첫 번째 오류가 발생하면 그 상태로 중지합니다. 이때 오류가 발생하기 전에 변경된 사항은 되돌릴 수 없습니다.

아래 예제는 DeleteFile 메서드의 사용법을 보여줍니다.

function DeleteFile(filespec)
{
  var fso;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  fso.DeleteFile(filespec);
}


DeleteFile 메서드

DeleteFile 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


DeleteFile 메서드

DeleteFile 메서드
참고 		Scripting 런타임 참조

CopyFile 메서드
CreateTextFile 메서드
Delete 메서드
DeleteFolder 메서드
MoveFile 메서드


DeleteFolder 메서드

DeleteFolder 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 폴더와 폴더의 내용을 삭제합니다.
구문
object.DeleteFolder ( folderspec[, force] );

DeleteFolder 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
folderspec | 필수적인 요소. 삭제할 폴더의 이름입니다. folderspec은 마지막 경로 구성 요소에 와일드카드 문자를 사용할 수 있습니다.
force | 선택적인 요소. true이면 읽기 전용 특성 집합을 가진 폴더를 삭제하고, false(기본값)이면 삭제하지 않는 부울값입니다.

참고
DeleteFolder 메서드는 내용이 있는 폴더와 내용이 없는 폴더를 구별하지 않습니다. 지정한 폴더는 내용이 있든 없든 삭제됩니다.

일치하는 폴더가 없으면 오류가 발생합니다. DeleteFolder 메서드는 첫 번째 오류가 발생하면 그 상태로 중지합니다. 이때 오류가 발생하기 전에 변경된 사항은 되돌릴 수 없습니다.

아래 예제는 DeleteFolder 메서드의 사용법을 보여줍니다.

function DeleteFolder(folderspec)
{
  var fso;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  fso.DeleteFolder(folderspec);
}


DeleteFolder 메서드

DeleteFolder 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


DeleteFolder 메서드

DeleteFolder 메서드
참고 		Scripting 런타임 참조

CopyFolder 메서드
CreateFolder 메서드
Delete 메서드
DeleteFile 메서드
MoveFolder 메서드


DriveExists 메서드

DriveExists 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 드라이브가 있으면 true를, 그렇지 않으면 false를 반환합니다.
구문
object.DriveExists(drivespec)

DriveExists 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
drivespec | 필수적인 요소. 드라이브 문자나 전체 경로입니다.

참고
이동식 매체가 있는 드라이브에서는 현재 매체가 없어도 DriveExists 메서드가 true 값을 반환합니다. 드라이브가 준비되었는지의 여부를 확인하려면 Drive 개체의 IsReady 속성을 사용하십시오.

아래 예제는 DriveExists 메서드의 사용법을 보여줍니다.

function ReportDriveStatus(drv)
{
  var fso, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  if (fso.DriveExists(drv))
    s += "드라이브 " + drv + "가 있습니다.";
  else
    s += "드라이브 " + drv + "가 없습니다.";
  return(s);
}


DriveExists 메서드

DriveExists 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


DriveExists 메서드

DriveExists 메서드
참고 		Scripting 런타임 참조

Drive 개체
Drives 컬렉션
FileExists 메서드
FolderExists 메서드
GetDrive 메서드
GetDriveName 메서드
IsReady 속성


Drives 속성

Drives 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
로컬 컴퓨터에 사용할 수 있는 모든 Drive 개체로 구성된 Drives 컬렉션을 반환합니다.
구문
object.Drives

object는 항상 FileSystemObject입니다.

참고
이동식 매체 드라이브를 Drives 컬렉션에 나타내기 위하여 이동식 매체 드라이브에 매체를 삽입할 필요는 없습니다.

Enumerator 개체와 for 문을 사용하여 Drives 컬렉션의 구성원들을 반복 실행시킬 수 있습니다.

function ShowDriveList()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  for (; !e.atEnd(); e.moveNext())
  {
    x = e.item();
    s = s + x.DriveLetter;
    s += " - ";
    if (x.DriveType == 3)
      n = x.ShareName;
    else if (x.IsReady)
      n = x.VolumeName;
    else
      n = "[드라이브가 준비되지 않았습니다.]";
    s +=  n + "<br>";
  }
  return(s);
}


Drives 속성

Drives 속성
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


Drives 속성

Drives 속성
참고 		Scripting 런타임 참조

Drives 컬렉션
Files 속성
SubFolders 속성


FileExists 메서드

FileExists 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 파일이 있으면 true를, 그렇지 않으면 false를 반환합니다.
구문
object.FileExists(filespec)

FileExists 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
filespec | 필수적인 요소. 파일이 있는지 여부를 확인할 파일 이름입니다. 파일이 현재 폴더에 없으면 전체 경로(절대 경로 또는 상대 경로)를 제공해야 합니다.

아래 예제는 FileExists 메서드의 사용법을 보여줍니다.

function ReportFileStatus(filespec)
{
  var fso, s = filespec;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  if (fso.FileExists(filespec))
    s += " 있습니다.";
  else
    s += " 없습니다.";
  return(s);
}


FileExists 메서드

FileExists 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


FileExists 메서드

FileExists 메서드
참고 		Scripting 런타임 참조

DriveExists 메서드
FolderExists 메서드
GetFile 메서드
GetFileName 메서드


FolderExists 메서드

FolderExists 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 폴더가 있으면 true를, 그렇지 않으면 false를 반환합니다.
구문
object.FolderExists(folderspec)

FolderExists 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
folderspec | 필수적인 요소. 폴더가 있는지 여부를 확인할 폴더 이름입니다. 폴더가 현재 폴더에 없으면 전체 경로(절대 경로 또는 상대 경로)를 제공해야 합니다.

아래 예제는 FileExists 메서드의 사용법을 보여줍니다.

function ReportFolderStatus(fldr)
{
  var fso, s = fldr;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  if (fso.FolderExists(fldr))
    s += " 있습니다.";
  else
    s += " 없습니다.";
  return(s);
}


FolderExists 메서드

FolderExists 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


FolderExists 메서드

FolderExists 메서드
참고 		Scripting 런타임 참조

DriveExists 메서드
FileExists 메서드
GetFolder 메서드
GetParentFolderName 메서드


GetAbsolutePathName 메서드

GetAbsolutePathName 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
주어진 경로에서 정확한 전체 경로를 반환합니다.
구문
object.GetAbsolutePathName(pathspec)

GetAbsolutePathName 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
pathspec | 필수적인 요소. 정확한 전체 경로로 바꿀 경로입니다.

참고
경로를 지정한 드라이브의 루트에서 전체를 참조하면 그 경로가 정확한 전체 경로가 됩니다. 전체 경로가 연결된 드라이브의 루트 폴더를 지정하면 전체 경로는 경로 구분 기호(\)로 끝나야 합니다.

현재 디렉터리를 c:\mydocuments\reports라고 가정했을 때 아래 표는 GetAbsolutePathName 메서드의 동작을 보여줍니다.

pathspec | 반환된 경로
"c:" | "c:\mydocuments\reports"
"c:.." | "c:\mydocuments"
"c:\\" | "c:\"
"c:*.*\\may97" | "c:\mydocuments\reports\*.*\may97"
"region1" | "c:\mydocuments\reports\region1"
"c:\\..\\..\\mydocuments" | "c:\mydocuments"

아래 예제는 GetAbsolutePathName 메서드의 사용법을 보여줍니다.

function ShowAbsolutePath(path)
{
  var fso, s= "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  s += fso.GetAbsolutePathName(path);
  return(s);
}


GetAbsolutePathName 메서드

GetAbsolutePathName 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


GetAbsolutePathName 메서드

GetAbsolutePathName 메서드
참고 		Scripting 런타임 참조

GetBaseName 메서드
GetDrive 메서드
GetDriveName 메서드
GetExtensionName 메서드
GetFile 메서드
GetFileName 메서드
GetFileVersion Method
GetFolder 메서드
GetParentFolderName 메서드
GetSpecialFolder 메서드
GetTempName 메서드


GetBaseName 메서드

GetBaseName 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
확장명이 없는 경로에서 마지막 구성 요소의 기본 이름을 포함한 문자열을 반환합니다.
구문
object.GetBaseName(path)

GetBaseName 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
path | 필수적인 요소. 기본 이름을 반환할 구성 요소의 경로입니다.

참고
path 인수와 일치하는 구성 요소가 없으면 GetBaseName 메서드는 빈 문자열("")을 반환합니다.
메모 GetBaseName 메서드는 주어진 path 문자열에만 사용합니다. 경로를 결정하지도 않고 지정한 경로가 있는지도 검사하지 않습니다.

아래 예제는 GetBaseName 메서드의 사용법을 보여줍니다.

function ShowBaseName(filespec)
{
  var fso, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  s += fso.GetBaseName(filespec);
  return(s);
}


GetBaseName 메서드

GetBaseName 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


GetBaseName 메서드

GetBaseName 메서드
참고 		Scripting 런타임 참조

GetAbsolutePathName 메서드
GetDrive 메서드
GetDriveName 메서드
GetExtensionName 메서드
GetFile 메서드
GetFileName 메서드
GetFileVersion Method
GetFolder 메서드
GetParentFolderName 메서드
GetSpecialFolder 메서드
GetTempName 메서드


GetDrive 메서드

GetDrive 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 경로에서 드라이브에 해당하는 Drive 개체를 반환합니다.
구문
object.GetDrive ( drivespec );

GetDrive 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
drivespec | 필수적인 요소. drivespec 인수는 드라이브 문자(c), 콜론이 추가된 드라이브 문자(c:), 콜론과 경로 구분 기호가 추가된 드라이브 문자(c:\), 또는 네트워크 공유 영역(\\computer2\share1)입니다.

참고
네트워크 공유에서는 네트워크 공유 영역이 있어야 합니다.

drivespec이 허용된 양식과 일치하지 않거나 drivespec이 없으면 오류가 발생합니다.

일반 경로 문자열에 GetDrive 메서드를 호출하려면 아래 시퀀스를 사용하여 drivespec으로 사용하기에 적절한 문자열을 가져옵니다.

DriveSpec = GetDriveName(GetAbsolutePathName(Path))
아래 예제는 GetDrive 메서드의 사용법을 보여줍니다.
function ShowFreeSpace(drvPath)
{
  var fso, d, s ="";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(fso.GetDriveName(drvPath));
  s = "드라이브 " + drvPath.toUpperCase( ) + " - ";
  s += d.VolumeName + "<br>";
  s += "사용 가능한 공간: " + d.FreeSpace/1024 + " KB";
  return(s);
}


GetDrive 메서드

GetDrive 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


GetDrive 메서드

GetDrive 메서드
참고 		Scripting 런타임 참조

GetAbsolutePathName 메서드
GetBaseName 메서드
GetDriveName 메서드
GetExtensionName 메서드
GetFile 메서드
GetFileName 메서드
GetFileVersion Method
GetFolder 메서드
GetParentFolderName 메서드
GetSpecialFolder 메서드
GetTempName 메서드


GetDriveName 메서드

GetDriveName 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 경로에서 드라이브 이름을 포함하는 문자열을 반환합니다.
구문
object.GetDriveName(path)

GetDriveName 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. FileSystemObject의 이름입니다.
path | 필수적인 요소. 드라이브 이름을 반환할 구성 요소의 경로입니다.

참고
드라이브를 확인할 수 없으면 GetDriveName 메서드는 빈 문자열("")을 반환합니다.
메모 GetDriveName 메서드는 제공된 path 문자열에만 사용합니다. 경로를 결정하지도 않고 지정한 경로가 있는지도 검사하지 않습니다.

아래 예제는 GetDriveName 메서드의 사용법을 보여줍니다.

function GetDriveLetter(path)
{
  var fso, s ="";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  s += fso.GetDrive(fso.GetDriveName(fso.GetAbsolutePathName(path)));
  return(s);
}


GetDriveName 메서드

GetDriveName 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


GetDriveName 메서드

GetDriveName 메서드
참고 		Scripting 런타임 참조

GetAbsolutePathName 메서드
GetBaseName 메서드
GetDrive 메서드
GetExtensionName 메서드
GetFile 메서드
GetFileName 메서드
GetFileVersion Method
GetFolder 메서드
GetParentFolderName 메서드
GetSpecialFolder 메서드
GetTempName 메서드


GetExtensionName 메서드

GetExtensionName 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
경로의 마지막 구성 요소에 해당하는 확장명 이름을 포함한 문자열을 반환합니다.
구문
object.GetExtensionName(path)

GetExtensionName 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
path | 필수적인 요소. 확장명을 반환할 구성 요소의 경로입니다.

참고
네트워크 드라이브의 경우 루트 디렉터리(\)는 하나의 구성 요소입니다.

path 인수와 일치하는 구성 요소가 없으면 GetExtensionName 메서드는 빈 문자열("")을 반환합니다.

아래 예제는 GetExtensionName 메서드의 사용법을 보여줍니다.

function ShowExtensionName(filespec)
{
  var fso, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  s += fso.GetExtensionName(filespec);
  return(s);
}


GetExtensionName 메서드

GetExtensionName 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


GetExtensionName 메서드

GetExtensionName 메서드
참고 		Scripting 런타임 참조

GetAbsolutePathName 메서드
GetBaseName 메서드
GetDrive 메서드
GetDriveName 메서드
GetFile 메서드
GetFileName 메서드
GetFileVersion Method
GetFolder 메서드
GetParentFolderName 메서드
GetSpecialFolder 메서드
GetTempName 메서드


GetFile 메서드

GetFile 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 경로에서 특정 파일에 해당하는 File 개체를 반환합니다.
구문
object.GetFile(filespec)

GetFile 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
filespec | 필수적인 요소. filespec은 특정 파일의 경로(절대 경로 또는 상대 경로)입니다.

참고
지정한 파일이 없으면 오류가 발생합니다.

아래 예제는 GetFile 메서드의 사용법을 보여줍니다.

function ShowFileAccessInfo(filespec)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(filespec);
  s = f.Path.toUpperCase() + "<br>";
  s += "만든 날짜: " + f.DateCreated + "<br>";
  s += "마지막으로 액세스한 날짜: " + f.DateLastAccessed + "<br>";
  s += "마지막으로 수정한 날짜: " + f.DateLastModified
  return(s);
}


GetFile 메서드

GetFile 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


GetFile 메서드

GetFile 메서드
참고 		Scripting 런타임 참조

GetAbsolutePathName 메서드
GetBaseName 메서드
GetDrive 메서드
GetDriveName 메서드
GetExtensionName 메서드
GetFileName 메서드
GetFileVersion Method
GetFolder 메서드
GetParentFolderName 메서드
GetSpecialFolder 메서드
GetTempName 메서드


GetFileName 메서드

GetFileName 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
드라이브의 일부분이 아닌 지정한 경로의 마지막 구성 요소를 반환합니다.
구문
object.GetFileName(pathspec)

GetFileName 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
pathspec | 필수적인 요소. 지정한 파일의 경로(절대 경로 또는 상대 경로)입니다.

참고
pathspec이 명명된 구성 요소로 끝나지 않으면 GetFileName 메서드는 빈 문자열("")을 반환합니다.
메모 GetFileName 메서드는 주어진 경로 문자열에만 사용합니다. 경로를 결정하지도 않고 지정한 경로가 있는지도 검사하지 않습니다.

아래 예제는 GetFileName 메서드의 사용법을 보여줍니다.

function ShowFileName(filespec)
{
  var fso, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  s += fso.GetFileName(filespec);
  return(s);
}


GetFileName 메서드

GetFileName 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


GetFileName 메서드

GetFileName 메서드
참고 		Scripting 런타임 참조

GetAbsolutePathName 메서드
GetBaseName 메서드
GetDrive 메서드
GetDriveName 메서드
GetExtensionName 메서드
GetFile 메서드
GetFileVersion Method
GetFolder 메서드
GetParentFolderName 메서드
GetSpecialFolder 메서드
GetTempName 메서드


GetFileVersion 메서드

GetFileVersion 메서드 		Scripting 런타임 참조
버전 5

참고 적용 대상

설명
지정한 파일의 버전 번호를 반환합니다.
구문
object.GetFileVersion(pathspec)

GetFileVersion 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
pathspec | 필수적인 요소. 지정한 파일의 절대 또는 상대 경로입니다.

참고
pathspec가 지정된 파일로 끝나지 않거나 파일에 버전 정보가 없을 경우 GetFileVersion 메서드는 빈 문자열("")을 반환합니다.
메모 GetFileVersion 메서드 지정한 경로의 문자열에서만 수행되며 경로를 확인하거나 지정한 경로가 있는지 확인하지는 않습니다.

아래 예제는 GetFileVersion 메서드의 사용법을 보여줍니다.

function ShowFileVersion(pathspec)
{
  var fso, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  s += fso.GetFileVersion(pathspec);
  if (s == "")
    s = "버전 정보가 없습니다.";
  return(s);
}


GetFileVersion 메서드

GetFileVersion 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


GetFileVersion 메서드

GetFileVersion 메서드
참고 		Scripting 런타임 참조

GetAbsolutePathName 메서드
GetBaseName 메서드
GetDrive 메서드
GetDriveName 메서드
GetExtensionName 메서드
GetFile 메서드
GetFileName 메서드
GetFolder 메서드
GetParentFolderName 메서드
GetSpecialFolder 메서드
GetTempName 메서드


GetFolder 메서드

GetFolder 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 경로에서 폴더에 해당하는 Folder 개체를 반환합니다.
구문
object.GetFolder(folderspec)

GetFolder 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
folderspec | 필수적인 요소. folderspec은 특정 폴더의 경로(절대 경로 또는 상대 경로)입니다.

참고
지정한 폴더가 없으면 오류가 발생합니다.

아래 예제는 GetFolder 메서드의 사용법을 보여줍니다.

function ShowFolderList(folderspec)
{
  var fso, f, fc, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(folderspec);
  fc = new Enumerator(f.SubFolders);
  s = "";
  for (; !fc.atEnd(); fc.moveNext())
  {
    s += fc.item();
    s += "<br>";
  }
  return(s);
}


GetFolder 메서드

GetFolder 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


GetFolder 메서드

GetFolder 메서드
참고 		Scripting 런타임 참조

GetAbsolutePathName 메서드
GetBaseName 메서드
GetDrive 메서드
GetDriveName 메서드
GetExtensionName 메서드
GetFile 메서드
GetFileName 메서드
GetFileVersion Method
GetParentFolderName 메서드
GetSpecialFolder 메서드
GetTempName 메서드


GetParentFolderName 메서드

GetParentFolderName 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 경로에서 마지막 구성 요소의 상위 폴더 이름을 포함한 문자열을 반환합니다.
구문
object.GetParentFolderName(path)

GetParentFolderName 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject 이름입니다.
path | 필수적인 요소. 상위 폴더 이름을 반환할 구성 요소의 경로입니다.

참고
path 인수에 지정한 구성 요소의 상위 폴더가 없으면 GetParentFolderName 메서드는 빈 문자열("")을 반환합니다.
메모 GetParentFolderName 메서드는 주어진 path 문자열에만 사용합니다. 경로를 결정하지도 않고 지정한 경로가 있는지도 검사하지도 않습니다.

아래 예제는 GetParentFolderName 메서드의 사용법을 보여줍니다.

function ShowParentFolderName(filespec)
{
 var fso, s = "";
 fso = new ActiveXObject("Scripting.FileSystemObject");
 s += fso.GetParentFolderName(filespec);
 return(s);
}


GetParentFolderName 메서드

GetParentFolderName 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


GetParentFolderName 메서드

GetParentFolderName 메서드
참고 		Scripting 런타임 참조

GetAbsolutePathName 메서드
GetBaseName 메서드
GetDrive 메서드
GetDriveName 메서드
GetExtensionName 메서드
GetFile 메서드
GetFileName 메서드
GetFileVersion Method
GetFolder 메서드
GetSpecialFolder 메서드
GetTempName 메서드


GetSpecialFolder 메서드

GetSpecialFolder 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 특정 폴더 개체를 반환합니다.
구문
object.GetSpecialFolder(folderspec)

GetSpecialFolder 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
folderspec | 필수적인 요소. 특정 폴더의 이름을 반환합니다. 아래 설정에 있는 상수이면 됩니다.

설정
folderspec 인수는 아래 설정 값을 가질 수 있습니다.

상수 | 값 | 설명
WindowsFolder | 0 | Windows 폴더에는 Windows 운영 체제로 설치된 파일이 들어있습니다.
SystemFolder | 1 | System 폴더에는 라이브러리, 글꼴, 장치 드라이브가 들어있습니다.
TemporaryFolder | 2 | Temp 폴더는 임시 파일들을 저장하는 데 사용됩니다. 그 경로는 TMP 환경 변수에 있습니다.

아래 예제는 GetSpecialFolder 메서드의 사용법을 보여줍니다.

var fso, tempfile;
fso = new ActiveXObject("Scripting.FileSystemObject");

function CreateTempFile()
{
  var tfolder, tfile, tname, fname, TemporaryFolder = 2;
  tfolder = fso.GetSpecialFolder(TemporaryFolder);
  tname = fso.GetTempName();
  tfile = tfolder.CreateTextFile(tname);
  return(tfile);
}
tempfile = CreateTempFile();
tempfile.writeline("안녕하십니까?");
tempfile.close();


GetSpecialFolder 메서드

GetSpecialFolder 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


GetSpecialFolder 메서드

GetSpecialFolder 메서드
참고 		Scripting 런타임 참조

GetAbsolutePathName 메서드
GetBaseName 메서드
GetDrive 메서드
GetDriveName 메서드
GetExtensionName 메서드
GetFile 메서드
GetFileName 메서드
GetFileVersion Method
GetFolder 메서드
GetParentFolderName 메서드
GetTempName 메서드


GetTempName 메서드

GetTempName 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
임시 파일이나 폴더가 필요한 연산을 수행하는 데 유용한 임으로 만든 임시 파일이나 폴더 이름을 반환합니다.
구문
object.GetTempName ( );

선택적인 요소인 object는 항상 FileSystemObject의 이름입니다.

참고
GetTempName 메서드는 파일을 만들지는 않습니다. 단지 파일을 만들기 위해 CreateTextFile과 함께 사용되는 임시 파일 이름만 제공합니다.

아래 예제는 GetTempName 메서드의 사용법을 보여줍니다.

var fso, tempfile;
fso = new ActiveXObject("Scripting.FileSystemObject");

function CreateTempFile()
{
  var tfolder, tfile, tname, fname, TemporaryFolder = 2;
  tfolder = fso.GetSpecialFolder(TemporaryFolder);
  tname = fso.GetTempName();
  tfile = tfolder.CreateTextFile(tname);
  return(tfile);
}
tempfile = CreateTempFile();
tempfile.writeline("안녕하십니까?");
tempfile.close();


GetTempName 메서드

GetTempName 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


GetTempName 메서드

GetTempName 메서드
참고 		Scripting 런타임 참조

GetAbsolutePathName 메서드
GetBaseName 메서드
GetDrive 메서드
GetDriveName 메서드
GetExtensionName 메서드
GetFile 메서드
GetFileName 메서드
GetFileVersion Method
GetFolder 메서드
GetParentFolderName 메서드
GetSpecialFolder 메서드


MoveFile 메서드

MoveFile 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
하나 이상의 파일을 기존 위치에서 다른 위치로 옮깁니다.
구문
object.MoveFile ( source, destination );

MoveFile 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
source | 필수적인 요소. 옮길 파일 경로입니다. source 인수 문자열에는 마지막 경로 구성 요소에만 와일드카드 문자를 사용할 수 있습니다.
destination | 필수적인 요소. 파일을 옮길 경로입니다. destination 인수에는 와일드카드 문자를 사용할 수 없습니다.

참고
source에 와일드카드를 사용하거나 destination이 경로 구분 기호(\)로 끝나면 destination이 일치하는 파일을 옮길 기존 폴더를 나타냅니다. 그렇지 않으면 destination은 만들 대상 파일의 이름을 나타냅니다. 둘 중 어느 경우라도 개별 파일을 옮길 때 아래 세 가지 중 하나가 일어날 수 있습니다.
  • destination이 없으면 파일을 옮깁니다. 일반적인 경우입니다.
  • destination이 기존 파일이면 오류가 발생합니다.
  • destination이 디렉터리이면 오류가 발생합니다.
source에 사용한 와일드카드 문자와 일치하는 파일이 없으면 오류가 발생합니다. MoveFile 메서드는 첫 번째 오류가 발생하면 그 상태로 중지합니다. 오류가 발생하고 나면 이전에 변경된 사항은 되돌릴 수 없습니다.
중요 운영 체제가 지원하는 경우에만 이 메서드를 사용하여 볼륨들 간에 파일을 옮길 수 있습니다.

아래 예제는 MoveFile 메서드의 사용법을 보여줍니다.

function MoveFile2Desktop(filespec)
{
  var fso;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  fso.MoveFile(filespec, "c:\\windows\\desktop\\");
}


MoveFile 메서드

MoveFile 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


MoveFile 메서드

MoveFile 메서드
참고 		Scripting 런타임 참조

CopyFile 메서드
DeleteFile 메서드
GetFile 메서드
GetFileName 메서드
Move 메서드
MoveFolder 메서드
OpenTextFile 메서드


MoveFolder 메서드

MoveFolder 메서드 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
하나 이상의 폴더를 기존 위치에서 다른 위치로 옮깁니다.
구문
object.MoveFolder ( source, destination );

MoveFolder 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 FileSystemObject의 이름입니다.
source | 필수적인 요소. 옮길 폴더 경로입니다. source 인수 문자열에는 마지막 경로 구성 요소에만 와일드카드 문자를 사용할 수 있습니다.
destination | 필수적인 요소. 폴더를 옮길 경로입니다. destination 인수에는 와일드카드 문자를 사용할 수 없습니다.

참고
source에 와일드카드 문자를 사용하거나 destination이 경로 구분 기호(\)로 끝나면 destination은 일치하는 파일을 이동할 기존 폴더를 나타냅니다. 그렇지 않으면 destination은 만들 대상 폴더의 이름을 나타냅니다. 둘 중 어느 경우라도 개별 폴더를 이동할 때 아래 세 가지 중 하나가 일어날 수 있습니다.
  • destination이 없으면 폴더를 옮깁니다. 일반적인 경우입니다.
  • destination이 기존 파일이면 오류가 발생합니다.
  • destination이 디렉터리이면 오류가 발생합니다.
source에 사용한 와일드카드 문자와 일치하는 폴더가 없어도 오류가 발생합니다. MoveFolder 메서드는 첫 번째 오류가 발생하면 그 상태로 중지합니다. 오류가 발생하고 나면 이전에 변경된 사항은 되돌릴 수 없습니다.
중요 운영 체제가 지원하는 경우에만 이 메서드를 사용하여 볼륨들 간에 폴더를 옮길 수 있습니다.

아래 예제는 MoveFolder 메서드의 사용법을 보여줍니다.

function MoveFldr2Desktop(fldrspec)
{
  var fso;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  fso.MoveFolder(fldrspec, "c:\\windows\\desktop\\");
}


MoveFolder 메서드

MoveFolder 메서드
적용 대상 		Scripting 런타임 참조

FileSystemObject 개체


MoveFolder 메서드

MoveFolder 메서드
참고 		Scripting 런타임 참조

CopyFile 메서드
DeleteFile 메서드
GetFile 메서드
GetFileName 메서드
Move 메서드
MoveFile 메서드
OpenTextFile 메서드


Type 속성

Type 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
파일이나 폴더의 형식에 관한 정보를 반환합니다. 예를 들어, .TXT로 끝나는 파일에 대해서는 "텍스트 문서"가 반환됩니다.
구문
object.Type

object는 항상 File 또는 Folder 개체입니다.

참고
아래 코드는 폴더 형식을 반환하는 Type 속성의 사용법을 보여줍니다. 이 예제에서는 프로시저에 휴지통이나 다른 고유한 폴더의 경로를 사용해 봅니다.
function ShowFileType(filespec)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  if (fso.FolderExists(filespec))
    f = fso.GetFolder(filespec);
  else if (fso.FileExists(filespec))
    f = fso.GetFile(filespec);
  else
    s = "파일 또는 폴더가 없습니다.";
  s = f.Name + "은(는) " + f.Type + "입니다.";
  return(s);
}


Type 속성

Type 속성
적용 대상 		Scripting 런타임 참조

File 개체
Folder 개체


Type 속성

Type 속성
참고 		Scripting 런타임 참조

Attributes 속성
DateCreated 속성
DateLastAccessed 속성
DateLastModified 속성
Drive 속성
Files 속성
IsRootFolder 속성
Name 속성
ParentFolder 속성
Path 속성
ShortName 속성
ShortPath 속성
Size 속성
SubFolders 속성


GetObject 함수

GetObject 함수 		언어 참조
버전 3

참고

설명
파일에서 자동화 개체에 대한 참조를 반환합니다.
구문
GetObject([pathname] [, class])

GetObject 함수 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
pathname | 선택적인 요소. 검색할 개체를 포함하는 파일의 전체 경로와 이름입니다. pathname을 생략하면 class를 사용해야 합니다.
class | 선택적인 요소. 개체의 클래스입니다.

class 인수는 appname.objectype 구문을 사용하며 아래 요소로 구성됩니다.

구성 요소 | 설명
appname | 필수적인 요소. 개체를 제공하는 응용 프로그램의 이름입니다.
objectype | 필수적인 요소. 만들려는 개체의 형식이나 클래스입니다.

참고
GetObject 함수를 사용하여 파일에서 자동화 개체에 액세스합니다. GetObject가 반환하는 개체를 개체 변수에 지정합니다. 예를 들어 다음과 같습니다.
var CADObject;
CADObject = GetObject("C:\\CAD\\SCHEMA.CAD");
이 코드를 실행하면 지정된 pathname과 연결된 응용 프로그램이 시작되고, 지정된 파일에 있는 개체가 활성화됩니다. pathname이 빈 문자열("")이면 GetObject는 지정된 형식의 새 개체 인스턴스를 반환합니다. 만일 pathname 인수를 생략하면 GetObject는 현재 지정된 형식의 활성 개체를 반환합니다. 지정된 형식의 개체가 없으면 오류가 발생합니다.

응용 프로그램에 따라서는 파일 일부만을 활성화할 수도 있습니다. 이 경우에는 파일 이름 끝에 느낌표(!)와 활성화할 부분을 나타내는 문자열을 추가합니다. 이 문자열을 작성하는 방법에 대한 자세한 내용은 개체를 만든 응용 프로그램의 설명서를 참조하십시오.

예를 들어, 그리기 응용 프로그램을 사용하는 경우 파일에 저장된 그림에 여러 계층이 있을 수 있습니다. 아래 코드를 사용하면 SCHEMA.CAD라는 그림에서 계층 하나를 활성화할 수 있습니다.

var LayerObject = GetObject("C:\\CAD\\SCHEMA.CAD!Layer3");
개체 클래스를 지정하지 않으면 자동화는 주어진 파일 이름을 기준으로 시작할 응용 프로그램과 활성화할 개체를 결정합니다. 파일 중에는 개체 클래스를 두 개 이상 지원하는 것도 있습니다. 예를 들어 그림은 Application 개체와 Drawing 개체, Toolbar 개체 등 세 가지 개체를 지원할 수 있으며, 이 개체는 모두 같은 파일의 일부입니다. 이런 경우 파일 내에서 활성화할 개체를 지정하려면 선택적인 요소인 class 인수를 사용하십시오. 예를 들어 다음과 같습니다.
var MyObject;
MyObject = GetObject("C:\\DRAWINGS\\SAMPLE.DRW", "FIGMENT.DRAWING");
앞의 예제에서 FIGMENT는 그리기 응용 프로그램의 이름이고 DRAWING은 지원되는 개체 형식 중 하나입니다. 개체가 활성화되면 사용자가 정의한 개체 변수를 사용하여 코드 내에서 개체를 참조할 수 있습니다. 앞의 예제에서는 MyObject라는 개체 변수를 사용하여 새 개체의 속성과 메서드에 액세스합니다. 예를 들어 다음과 같습니다.
MyObject.Line(9, 90);
MyObject.InsertText(9, 100, "Hello, world.");
MyObject.SaveAs("C:\\DRAWINGS\\SAMPLE.DRW");
메모 GetObject 함수는 현재 개체 인스턴스가 있거나 이미 로드된 파일에 개체를 만들 경우에 사용합니다. 현재 인스턴스도 없고 로드된 파일에서 개체를 시작하고 싶지 않은 경우에는 ActiveXObject 개체를 사용하십시오.

개체가 단일 인스턴스 개체로 등록되어 있는 경우에는 ActiveXObject 실행 횟수에 관계없이 개체 인스턴스는 하나만 만들어집니다. 단일 인스턴스 개체의 경우 GetObject를 빈 문자열("") 구문으로 호출하면 항상 같은 인스턴스를 반환하고, pathname 인수를 생략하면 오류가 발생합니다.


GetObject 함수

GetObject 함수
참고 		언어 참조

ActiveXObject 개체


ScriptEngine 함수

ScriptEngine 함수 		언어 참조
버전 2

참고

설명
사용 중인 스크립트 언어를 나타내는 문자열을 반환합니다.
구문
ScriptEngine( )
반환값
ScriptEngine 함수는 아래 문자열 중 하나를 반환합니다.

문자열 | 설명
JScript | 현재 스크립팅 엔진이 Microsoft JScript임을 나타냅니다.
VBA | 현재 스크립팅 엔진이 Microsoft Visual Basic® for Applications임을 나타냅니다.
VBScript | 현재 스크립팅 엔진이 Microsoft Visual Basic Scripting Edition임을 나타냅니다.

참고
아래 코드는 ScriptEngine 함수의 사용법을 보여줍니다.
function GetScriptEngineInfo()
{
    var s;
    s = ""; // 필요한 정보를 포함한 문자열을 작성합니다.
    s += ScriptEngine() + " 버전 ";
    s += ScriptEngineMajorVersion() + ".";
    s += ScriptEngineMinorVersion() + ".";
    s += ScriptEngineBuildVersion();
    return(s);
}


ScriptEngineBuildVersion 함수

ScriptEngineBuildVersion 함수 		언어 참조
버전 2

참고

설명
사용 중인 스크립팅 엔진의 작성 버전 번호를 반환합니다.
구문
ScriptEngineBuildVersion( )
반환값
반환값은 사용 중인 스크립트 언어의 동적 연결 라이브러리(DLL)에 포함된 버전 정보와 일치합니다.
참고
아래 코드는 ScriptEngineBuildVersion 함수의 사용법을 보여줍니다.
function GetScriptEngineInfo()
{
    var s;
    s = ""; // 필요한 정보를 포함한 문자열을 작성합니다.
    s += ScriptEngine() + " 버전 ";
    s += ScriptEngineMajorVersion() + ".";
    s += ScriptEngineMinorVersion() + ".";
    s += ScriptEngineBuildVersion();
    return(s);
}


ScriptEngineBuildVersion 함수

ScriptEngineBuildVersion 함수
참고 		언어 참조

ScriptEngine 함수
ScriptEngineMajorVersion 함수
ScriptEngineMinorVersion 함수


ScriptEngine 함수

ScriptEngine 함수
참고 		언어 참조

ScriptEngineBuildVersion 함수
ScriptEngineMajorVersion 함수
ScriptEngineMinorVersion 함수


ScriptEngineMajorVersion 함수

ScriptEngineMajorVersion 함수 		언어 참조
버전 2

참고

설명
사용 중인 스크립팅 엔진의 주 버전 번호를 반환합니다.
구문
ScriptEngineMajorVersion( )
반환값
반환값은 사용 중인 스크립트 언어의 동적 연결 라이브러리(DLL)에 포함된 버전 정보와 일치합니다.
참고
아래 코드는 ScriptEngineMajorVersion 함수의 사용법을 보여줍니다.
function GetScriptEngineInfo()
{
    var s;
    s = ""; // 필요한 정보를 포함한 문자열을 작성합니다.
    s += ScriptEngine() + " 버전 ";
    s += ScriptEngineMajorVersion() + ".";
    s += ScriptEngineMinorVersion() + ".";
    s += ScriptEngineBuildVersion();
    return(s);
}


ScriptEngineMajorVersion 함수

ScriptEngineMajorVersion 함수
참고 		언어 참조

ScriptEngine 함수
ScriptEngineBuildVersion 함수
ScriptEngineMinorVersion 함수


ScriptEngineMinorVersion 함수

ScriptEngineMinorVersion 함수 		언어 참조
버전 2

참고

설명
사용 중인 스크립팅 엔진의 보조 버전 번호를 반환합니다.
구문
ScriptEngineMinorVersion( )
반환값
반환값은 사용 중인 스크립트 언어의 동적 연결 라이브러리(DLL)에 포함된 버전 정보와 일치합니다.
참고
아래 코드는 ScriptEngineMinorVersion 함수의 사용법을 보여줍니다.
function GetScriptEngineInfo()
{
    var s;
    s = ""; // 필요한 정보를 포함한 문자열을 작성합니다.
    s += ScriptEngine() + " 버전 ";
    s += ScriptEngineMajorVersion() + ".";
    s += ScriptEngineMinorVersion() + ".";
    s += ScriptEngineBuildVersion();
    return(s);
}


ScriptEngineMinorVersion 함수

ScriptEngineMinorVersion 함수
참고 		언어 참조

ScriptEngine 함수
ScriptEngineBuildVersion 함수
ScriptEngineMajorVersion 함수


Add 메서드(Folders)

Add 메서드(Folders) 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
Folders 컬렉션에 새 Folder를 추가합니다.
구문
object.Add (folderName)

Add 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 Folders 컬렉션의 이름입니다.
folderName | 필수적인 요소. 추가할 새 Folder의 이름입니다.

참고
아래 예제에서는 Add 메서드를 사용한 새 폴더 작성법을 보여줍니다.
function AddNewFolder(path,folderName)
{
  var fso, f, fc, nf;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(path);
  fc = f.SubFolders;
  if (folderName != "" )
    nf = fc.Add(folderName);
  else
    nf = fc.Add("새 폴더");
}
folderName이 이미 존재하면 오류가 발생합니다.


Add 메서드(Folders)

Add 메서드(Folders)
적용 대상 		Scripting 런타임 참조

Folders 컬렉션


Add 메서드(Folders)

Add 메서드(Folders)
참고 		Scripting 런타임 참조

Add 메서드(Dictionary)


Files 속성

Files 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 폴더에 포함되어 있는 모든 File 개체(숨김 특성과 시스템 파일 특성이 설정되어 있는 것 포함)로 구성된 Files 컬렉션을 반환합니다.
구문
object.Files

object는 항상 Folder 개체입니다.

참고
아래 코드는 Files 속성의 사용법을 보여줍니다.
function ShowFolderFileList(folderspec)
{
  var fso, f, fc, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(folderspec);
  fc = new Enumerator(f.files);
  s = "";
  for (; !fc.atEnd(); fc.moveNext())
  {
    s += fc.item();
    s += "<br>";
  }
  return(s);
}


Files 속성

Files 속성
적용 대상 		Scripting 런타임 참조

Folder 개체


Files 속성

Files 속성
참고 		Scripting 런타임 참조

Attributes 속성
DateCreated 속성
DateLastAccessed 속성
DateLastModified 속성
Drive 속성
IsRootFolder 속성
Name 속성
ParentFolder 속성
Path 속성
ShortName 속성
ShortPath 속성
Size 속성
SubFolders 속성
Type 속성


IsRootFolder 속성

IsRootFolder 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정된 폴더가 루트 폴더이면 true를, 그렇지 않으면 false를 반환합니다.
구문
object.IsRootFolder

object는 항상 Folder 개체입니다.

참고
아래 코드는 IsRootFolder 속성의 사용법을 보여줍니다.
function DisplayLevelDepth(pathspec)
{
  var fso, f, n, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(pathspec);
  n = 0;
  if (f.IsRootFolder)
      s = "지정한 폴더는 루트 폴더입니다."
  else
  {
    do
    {
      f = f.ParentFolder;
      n++;
    }
    while (!f.IsRootFolder)
    s = "지정한 폴더는 루트 폴더로부터" + n + " 번째에 위치하고 있습니다."
  }
  return(s);
}


IsRootFolder 속성

IsRootFolder 속성
적용 대상 		Scripting 런타임 참조

Folder 개체


IsRootFolder 속성

IsRootFolder 속성
참고 		Scripting 런타임 참조

Attributes 속성
DateCreated 속성
DateLastAccessed 속성
DateLastModified 속성
Drive 속성
Files 속성
Name 속성
ParentFolder 속성
Path 속성
ShortName 속성
ShortPath 속성
Size 속성
SubFolders 속성
Type 속성


SubFolders 속성

SubFolders 속성 		Scripting 런타임 참조
버전 3

참고 적용 대상

설명
지정한 폴더에 포함되어 있는 모든 폴더(숨김 특성과 시스템 파일 특성이 설정되어 있는 것 포함)로 구성된 Folders 컬렉션을 반환합니다.
구문
object.SubFolders

object는 항상 Folder 개체입니다.

참고
아래 코드는 SubFolders 속성의 사용법을 보여줍니다.
function ShowFolderList(folderspec)
{
  var fso, f, fc, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(folderspec);
  fc = new Enumerator(f.SubFolders);
  s = "";
  for (;!fc.atEnd(); fc.moveNext())
    {
      s += fc.item();
      s += "<br>";
    }
    return(s);
}


SubFolders 속성

SubFolders 속성
적용 대상 		Scripting 런타임 참조

Folder 개체


SubFolders 속성

SubFolders 속성
참고 		Scripting 런타임 참조

Attributes 속성
DateCreated 속성
DateLastAccessed 속성
DateLastModified 속성
Drive 속성
Files 속성
IsRootFolder 속성
Name 속성
ParentFolder 속성
Path 속성
ShortName 속성
ShortPath 속성
Size 속성
Type 속성


Microsoft® Scripting 런타임 라이브러리 참조

Scripting
런타임 라이브러리 참조 		언어 참조
버전 정보

기능
정보
키워드 목록
(사전순)
메서드
개체
속성
©1999 Microsoft Corporation. All rights reserved.


arguments 속성

arguments 속성 		언어 참조
버전 2

참고 적용 대상

설명
현재 실행 중인 함수에 전달된 각 인수를 포함하는 배열을 반환합니다.
구문
function.arguments[ ]

function 인수는 현재 실행 중인 함수의 이름입니다.

참고
arguments 속성을 사용하면 함수로 여러 개의 인수를 처리할 수 있습니다. 배열의 length 속성은 함수로 전달되는 인수의 수를 포함합니다.

아래 예제는 arguments 속성의 사용법을 보여줍니다.

function ArgTest()
{
   var i, s, numargs = ArgTest.arguments.length;
   s = numargs;
   if (numargs < 2)
     s += " ArgTest로 인수 하나가 전달되었습니다. 인수의 내용: ";
   else
     s += " ArgTest로 여러 인수가 전달되었습니다. 인수의 내용: " ;

   for (i = 0; i < numargs; i++)
     {
       s += ArgTest.arguments[i] + " ";
     }
   return(s);
}


arguments 속성

arguments 속성
적용 대상 		언어 참조

Function 개체


인수 속성

arguments 속성
참고 		언어 참조

Function 문
length 속성(Array)


caller 속성

caller 속성 		언어 참조
버전 2

참고 적용 대상

설명
현재 함수를 불러온 함수에 대한 참조를 반환합니다.
구문
functionname.caller
참고
caller 속성은 함수가 실행 중인 경우에만 정의할 수 있습니다. JScript 프로그램의 맨 위 수준에서 함수를 호출하면 caller는 null을 포함합니다.

caller 속성을 문자열 컨텍스트에 사용하면 functionname.toString과 같은 결과가 나옵니다. 즉, 함수에서 역컴파일된 텍스트가 표시됩니다.

아래 예제는 caller 속성의 사용법을 보여줍니다.

function CallLevel()
{
  if (CallLevel.caller == null)
    return("CallLevel은 맨 위 수준에서 호출되었습니다.");
  else
    return("CallLevel은 다른 함수에서 호출되었습니다.");
}


caller 속성

caller 속성
적용 대상 		언어 참조

Function 개체


caller 속성

caller 속성
참고 		언어 참조

Function 문


length 속성(Function)

length 속성(Function) 		언어 참조
버전 2

참고 적용 대상

설명
함수에 정의된 인수 수를 반환합니다.
구문
functionname.length

functionname 인수는 필수적인 요소이며 해당 함수의 이름입니다.

참고
함수의 length 속성은 함수 인스턴스를 만들 때 스크립팅 엔진에 의해 함수 정의에 있는 인수 수로 초기화됩니다.

함수의 length 속성 값과 다른 인수 수로 함수를 호출하면 함수에 따라 그 결과가 달라집니다.

아래 예제는 length 속성의 사용법을 보여줍니다.

function ArgTest(a, b)
{
   var i, s = "ArgTest 함수 기대값: ";
   var numargs = ArgTest.arguments.length;
   var expargs = ArgTest.length;
   if (expargs < 2)
     s += "인수" + expargs + "개 ";
   else
     s += "인수" + expargs + "개 ";
   if (numargs < 2)
     s += numargs + "개가 전달되었습니다.";
   else
     s += numargs + "개가 전달되었습니다.";
   return(s);
}


length 속성

length 속성(Function)
적용 대상 		언어 참조

Function 개체


length 속성(Function)

length 속성(Function)
참고 		언어 참조

arguments 속성
length 속성(Array)
length 속성(String)


escape 메서드

escape 메서드 		언어 참조
버전 1

참고 적용 대상

설명
String 개체를 모든 컴퓨터에서 읽을 수 있도록 인코딩합니다.
구문
escape(charstring)

charstring 인수는 인코딩할 String 개체입니다.

참고
escape 메서드는 charstring의 내용을 포함한 새 String 개체(유니코드 형식)를 반환합니다. 공백과 문장 부호, 악센트 부호가 있는 문자, 그외 비ASCII 문자는 모두 %xx 인코딩으로 바뀝니다. 여기서 xx는 해당 문자를 나타내는 16진수입니다. 예를 들어 공백은 "%20"으로 반환됩니다.

값이 255보다 큰 문자는 %u xxxx 형식으로 저장됩니다.


escape 메서드

escape 메서드
적용 대상 		언어 참조

Global 개체


escape 메서드

escape 메서드
참고 		언어 참조

String 개체
unescape 메서드


eval 메서드

eval 메서드 		언어 참조
버전 1

참고 적용 대상

설명
JScript 코드를 검증하고 실행합니다.
구문
eval(codestring)

codestring 인수는 유효한 JScript 코드를 포함하고 있는 String 개체입니다. 이 문자열은 JScript 구문 분석기에서 구문이 분석되고 실행됩니다.

참고
eval 함수를 사용하면 JScript 원본 코드를 동적으로 실행할 수 있습니다. 예를 들어, 아래 코드는 Date 개체를 포함하는 mydate 변수를 새로 만듭니다.
eval("var mydate = new Date();");
eval 메서드에 전달된 코드는 eval 메서드 호출과 같은 컨텍스트에서 실행됩니다.


eval 메서드

eval 메서드
적용 대상 		언어 참조

Global 개체


eval 메서드

eval 메서드
참고 		언어 참조

String 개체


Infinity 속성

Infinity 속성 		언어 참조
버전 3

참고 적용 대상

설명
Number.POSITIVE_INFINITY의 초기 값을 반환합니다.
구문
Infinity
참고
Infinity 속성은 Global 개체의 구성원이며 스크립팅 엔진을 초기화하면 사용할 수 있습니다.


Infinity 속성

Infinity 속성
적용 대상 		언어 참조

Global 개체


Infinity 속성

Infinity 속성
참고 		언어 참조

POSITIVE_INFINITY 속성
NEGATIVE_INFINITY 속성


isFinite 메서드

isFinite 메서드 		언어 참조
버전 3

참고 적용 대상

설명
주어진 수가 유한한지 여부를 나타내는 부울값입니다.
구문
isFinite(number)

number 인수는 필수적인 숫자 값입니다.

참고
isFinite 메서드는 number가 NaN, Negative Infinity, 또는 Positive Infinity 이외의 값이면 true를 반환하고 이 세 경우에는 false를 반환합니다.


isFinite 메서드

isFinite 메서드
적용 대상 		언어 참조

Global 개체


isFinite 메서드

isFinite 메서드
참고 		언어 참조

isNaN 메서드


isNaN 메서드

isNaN 메서드 		언어 참조
버전 1

참고 적용 대상

설명
어떤 값이 예약값인 NaN(숫자 아님)인지 여부를 나타내는 부울값을 반환합니다.
구문
isNaN(numvalue)

numvalue 인수는 NaN 여부를 테스트하기 위한 값입니다.

참고
isNaN 함수는 값이 NaN이면 true를, 그렇지 않으면 false를 반환합니다. 이 함수는 보통 parseInt와 parseFloat 메서드의 반환값 테스트에 사용합니다.

다른 방법으로, 변수를 자신과 비교할 수도 있습니다. 비교 결과값이 서로 같지 않으면 NaN입니다. 자신과 같지 않은 값은 NaN 뿐이기 때문입니다.


isNaN 메서드

isNaN 메서드
적용 대상 		언어 참조

Global 개체


isNaN 메서드

isNaN 메서드
참고 		언어 참조

isFinite 메서드
NaN 속성(Global)
parseFloat 메서드
parseInt 메서드


NaN 속성(Global)

NaN 속성 		언어 참조
버전 3

참고 적용 대상

설명
식이 숫자가 아님을 나타내는 특수 값 NaN을 반환합니다.
구문
NaN
참고
NaN 속성(숫자 아님)은 Global 개체의 구성원이며 스크립팅 엔진을 초기화하면 사용할 수 있습니다.


NaN 속성

NaN 속성
적용 대상 		언어 참조

Global 개체


NaN 속성

NaN 속성
참고 		언어 참조

isNaN 메서드


parseFloat 메서드

parseFloat 메서드 		언어 참조
버전 1

참고 적용 대상

설명
문자열에서 변환된 부동 소수점 숫자를 반환합니다.
구문
parseFloat(numstring)

numstring 인수는 부동 소수점 숫자를 포함한 문자열입니다.

참고
parseFloat 메서드는 numstring에 포함되어 있는 숫자에 해당하는 숫자 값을 반환합니다. numstring의 접두사를 부동 소수점 숫자로 구문 분석할 수 없으면 NaN(숫자 아님)이 반환됩니다.
parseFloat("abc")    // NaN을 반환합니다.
parseFloat("1.2abc") // 1.2를 반환합니다.
isNaN 메서드를 사용하면 NaN 여부를 테스트할 수 있습니다.


parseFloat 메서드

parseFloat 메서드
적용 대상 		언어 참조

Global 개체


parseFloat 메서드

parseFloat 메서드
참고 		언어 참조

isNaN 메서드
parseInt 메서드
String 개체
valueOf 메서드


parseInt 메서드

parseInt 메서드 		언어 참조
버전 1

참고 적용 대상

설명
문자열에서 변환된 정수를 반환합니다.
구문
parseInt(numstring, [radix])

parseInt 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
numstring | 필수적인 요소. 숫자로 변환할 문자열입니다.
radix | 선택적인 요소. numstring에 포함된 숫자의 밑을 나타내는 2부터 36까지의 값입니다. 이 요소를 생략하면 '0x'로 시작하는 문자열은 16진수로, '0'으로 시작하는 문자열은 8진수로 인식됩니다. 다른 문자열은 모두 십진수로 인식됩니다.

참고
parseInt 메서드는 numstring에 포함되어 있는 숫자에 해당하는 숫자 값을 반환합니다. numstring 접두사를 정수로 구문 분석할 수 없으면 NaN(숫자 아님)이 반환됩니다.
parseInt("abc")    // NaN을 반환합니다.
parseInt("12abc")  // 12를 반환합니다.
isNaN 메서드를 사용하면 NaN 여부를 테스트할 수 있습니다.


parseInt 메서드

parseInt 메서드
적용 대상 		언어 참조

Global 개체


parseInt 메서드

parseInt 메서드
참고 		언어 참조

isNaN 메서드
parseFloat 메서드
String 개체
valueOf 메서드


unescape 메서드

unescape 메서드 		언어 참조
버전 1

참고 적용 대상

설명
escape 메서드로 인코딩한 String 개체를 디코딩합니다.
구문
unescape(charstring)

charstring 인수는 디코딩할 String 개체입니다.

참고
unescape 메서드는 charstring의 내용을 포함하는 새 String 개체를 반환합니다. %xx 16진수 형식으로 인코딩된 문자는 모두 해당 ASCII 문자 집합으로 바뀝니다.

%u xxxx 형식(유니코드 문자)으로 인코딩된 문자는 16진수 인코딩 형식이 xxxx인 유니코드 문자로 바뀝니다.


unescape 메서드

unescape 메서드
적용 대상 		언어 참조

Global 개체


unescape 메서드

unescape 메서드
참고 		언어 참조

escape 메서드
String 개체


JScript 비교 연산자

비교 연산자 		언어 참조
버전 1

참고

설명
비교 결과를 나타내는 부울값을 반환합니다.
구문
expression1 comparisonoperator expression2

비교 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
expression1 | 임의의 식
comparisonoperator | 임의의 비교 연산자
expression2 | 임의의 식

참고
JScript에서 문자열을 비교할 때는 해당 문자식의 유니코드 문자 값을 사용합니다.

아래에는 expression1과 expression2의 형식 및 값에 따라 서로 다른 연산자 그룹이 작용하는 방식이 설명되어 있습니다.

관계(<, >, <=, >=)

  • expression1과 expression2를 모두 숫자로 변환합니다.
  • 두 식이 모두 문자열이면 사전순으로 문자열을 비교합니다.
  • 두 식이 모두 NaN이면 false를 반환합니다.
  • Negative 0은 Positive 0과 같습니다.
  • Negative Infinity는 자신을 포함한 모든 것보다 작습니다.
  • Positive Infinity는 자신을 포함한 모든 것보다 큽니다.
같음(==, !=)
  • 두 식의 형식이 다르면 문자열이나 숫자 또는 부울값으로 변환합니다.
  • NaN은 자신을 포함한 모든 것과 같지 않습니다.
  • Negative 0은 Positive 0과 같습니다.
  • null은 null 및 undefined와 같습니다.
  • 문자열이 서로 같거나, 숫자의 크기가 같거나, 개체가 같거나, 부울값이 일치하거나, 형식이 다른 경우 이들 상황 중 하나로 강제 변환할 수 있으면 두 값은 같은 것으로 간주됩니다.
  • 그 외의 다른 경우에는 두 값이 다른 것으로 간주됩니다.
동치(===. !==)
이 연산자는 형식 변환이 되지 않는 점을 제외하면 기본적으로 같음 연산자와 동일하게 작용하지만 두 식이 같은 것으로 간주되려면 형식도 일치해야 합니다.


Comparison 연산자

Comparison 연산자
참고 		언어 참조

연산자 동작
연산자 우선 순위
연산자 요약


Microsoft JScript 기능- ECMA

Microsoft JScript 기능
ECMA 		언어 참조

범주 | 기능/키워드
배열 처리 Array
join, length, reverse, sort
지정 =
OP=
부울 Boolean
주석 | /*...*/ 또는 //
상수/리터럴 NaN
null
true, false
Infinity
undefined
흐름 제어 break
continue
for
for...in
if...else
return
while
날짜와 시간 Date
getDate, getDay, getFullYear, getHours, getMilliseconds, getMinutes, getMonth, getSeconds, getTime, getTimezoneOffset, getYear,
getUTCDate, getUTCDay, getUTCFullYear, getUTCHours, getUTCMilliseconds, getUTCMinutes, getUTCMonth, getUTCSeconds,
setDate, setFullYear, setHours, setMilliseconds, setMinutes, setMonth, setSeconds, setTime, setYear,
setUTCDate, setUTCFullYear, setUTCHours, setUTCMilliseconds, setUTCMinutes, setUTCMonth, setUTCSeconds,
toGMTString, toLocaleString, toUTCString, parse, UTC
선언 function
new
this
var
with
함수 작성 Function
arguments, length
전역 메서드 Global
escape, unescape
eval
isFinite, isNaN
parseInt, parseFloat
연산 Math
abs, acos, asin, atan, atan2, ceil, cos, exp, floor, log, max, min, pow, random, round, sin, sqrt, tan,
E, LN2, LN10, LOG2E, LOG10E, PI, SQRT1_2, SQRT2
숫자 Number
MAX_VALUE, MIN_VALUE
NaN
NEGATIVE_INFINITY, POSITIVE_INFINITY
개체 작성 Object
new
constructor, prototype, toString, valueOf
연산자 +, -
%
*, /
-
==, !=
<, <=
>
>=
&&, ||, !
&, |, ~, ^
<<<, >>
>>>
?:
,
delete, typeof, void
--, ++
개체 Array
Boolean
Date
Function
Global
Math
Number
Object
String
문자열 String
charAt, charCodeAt, fromCharCode
indexOf, lastIndexOf
split
toLowerCase, toUpperCase
length


Microsoft JScript 기능 - 비ECMA

Microsoft JScript 기능
비ECMA 		언어 참조

범주 | 기능/키워드
배열 처리 concat, slice
VBArray
dimensions, getItem, lbound, toArray, ubound
조건부 컴파일 @cc_on
@if 문
@set 문
조건부 컴파일 변수
흐름 제어 do...while
Labeled
switch
날짜와 시간 getVarDate
열거 Enumerator
atEnd, item, moveFirst, moveNext
오류 처리 Error
description, number
throw, try...catch
함수 작성 | caller
연산자 ===, !==
개체 Enumerator
RegExp
Regular Expression
VBArray
ActiveXObject
GetObject
정규식과 패턴 일치 RegExp
index, input, lastIndex, $1...$9, source, compile, exec, test
정규식 구문
스크립팅 엔진 확인 ScriptEngine
ScriptEngineBuildVersion
ScriptEngineMajorVersion
ScriptEngineMinorVersion
문자열 concat, slice
match, replace, search
anchor, big, blink, bold, fixed, fontcolor, fontsize, italics, link, small, strike, sub, sup


Microsoft Scripting 런타임 기능

Microsoft Scripting
런타임 기능 		언어 참조

범주 기능/키워드
컬렉션 Drives
Files
Folders
데이터 저장소 Dictionary
사전 Add
Exists
Items, Keys
Remove, RemoveAll
Count
Item, Key
파일 시스템 Drive
File
FileSystemObject
Folder
TextStream
FileSystemObject BuildPath
CopyFile, CopyFolder
CreateFolder, CreateTextFile
DeleteFile, DeleteFolder
DriveExists, FileExists, FolderExists
GetAbsolutePathName, GetBaseName
GetDrive, GetDriveName
GetFile, GetExtensionName GetFileName
GetFolder, GetParentFolderName
GetSpecialFolder
GetTempName
MoveFile, MoveFolder
OpenTextFile
Drives
드라이브 AvailableSpace
Count
DriveLetter
DriveType
FileSystem
FreeSpace
IsReady
Item
RootFolder
SerialNumber
ShareName
TotalSize
VolumeName
파일
폴더 		Add
Attributes
Copy, Delete, Move
Count
OpenAsTextStream
DateCreated, DateLastAccessed, DateLastModified
Drive
Item
ParentFolder
Name, Path
ShortName, ShortPath
Size
TextStream Close
Read, ReadAll, ReadLine
Skip, SkipLine
Write, WriteBlankLines, WriteLine
AtEndOfLine, AtEndOfStream
Column, Line


abs 메서드

abs 메서드 		언어 참조
버전 1

참고 적용 대상

설명
숫자의 절대값을 반환합니다.
구문
Math.abs(number)

number 인수는 절대값을 찾는 수식입니다.

참고
반환값은 number 인수의 절대값입니다.

아래 예제는 abs 메서드의 사용법을 보여줍니다.

function ComparePosNegVal(n)
{
  var s;
  var v1 = Math.abs(n);
  var v2 = Math.abs(-n);
  if (v1 == v2)
    s = "두 값 " + n + "와(과) "
    s += -n + "의 절대값은 같습니다.";
  return(s);
}


abs 메서드

abs 메서드
적용 대상 		언어 참조

Math 개체


abs 메서드

abs 메서드
참고 		언어 참조

Math 개체 메서드


acos 메서드

acos 메서드 		언어 참조
버전 1

참고 적용 대상

설명
아크코사인 값을 반환합니다.
구문
Math.acos(number)

number 인수는 아크코사인 값을 찾는 수식입니다.

참고
반환값은 number 인수의 아크코사인 값입니다.


acos 메서드

acos 메서드
적용 대상 		언어 참조

Math 개체


acos 메서드

acos 메서드
참고 		언어 참조

asin 메서드
atan 메서드
cos 메서드
Math 개체 메서드
sin 메서드
tan 메서드


asin 메서드

asin 메서드 		언어 참조
버전 1

참고 적용 대상

설명
아크사인 값을 반환합니다.
구문
Math.asin(number)

number 인수는 아크사인 값을 찾는 수식입니다.

참고
반환값은 숫자 인수의 아크사인 값입니다.


asin 메서드

asin 메서드
적용 대상 		언어 참조

Math 개체


asin 메서드

asin 메서드
참고 		언어 참조

acos 메서드
atan 메서드
cos 메서드
Math 개체 메서드
sin 메서드
tan 메서드


atan 메서드

atan 메서드 		언어 참조
버전 1

참고 적용 대상

설명
아크탄젠트 값을 반환합니다.
구문
Math.atan(number)

number 인수는 아크탄젠트 값을 찾는 수식입니다.

참고
반환값은 숫자 인수의 아크탄젠트 값입니다.


atan2 메서드

atan2 메서드 		언어 참조
버전 2

참고 적용 대상

설명
X축과 점(y,x) 사이의 각을 라디안 값으로 반환합니다.
구문
Math.atan2(y, x)

atan2 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
Math | 필수적인 요소. 내부 Math 개체를 불러옵니다.
x | 필수적인 요소. x 좌표(데카르트식)를 나타내는 수식입니다.
y | 필수적인 요소. y 좌표(데카르트식)를 나타내는 수식입니다.

참고
반환값은 주어진 점(y,x)의 각도를 나타내는 -pi와 pi 사이의 값입니다.


atan2 메서드

atan2 메서드
적용 대상 		언어 참조

Math 개체


atan2 메서드

atan2 메서드
참고 		언어 참조

atan 메서드
Math 개체 메서드
tan 메서드


atan 메서드

atan 메서드
적용 대상 		언어 참조

Math 개체


atan 메서드

atan 메서드
참고 		언어 참조

acos 메서드
asin 메서드
atan2 메서드
cos 메서드
Math 개체 메서드
sin 메서드
tan 메서드


ceil 메서드

ceil 메서드 		언어 참조
버전 1

참고 적용 대상

설명
숫자 인수보다 크거나 같은 가장 작은 정수를 반환합니다.
구문
Math.ceil(number)

number 인수는 수식입니다.

참고
반환값은 숫자 인수보다 크거나 같은 가장 작은 정수 값입니다.


ceil 메서드

ceil 메서드
적용 대상 		언어 참조

Math 개체


ceil 메서드

ceil 메서드
참고 		언어 참조

floor 메서드
Math 개체 메서드


cos 메서드

cos 메서드 		언어 참조
버전 1

참고 적용 대상

설명
코사인 값을 반환합니다.
구문
Math.cos(number)

number 인수는 코사인 값을 찾는 수식입니다.

참고
반환값은 숫자 인수의 코사인 값입니다.


cos 메서드

cos 메서드
적용 대상 		언어 참조

Math 개체


cos 메서드

cos 메서드
참고 		언어 참조

acos 메서드
asin 메서드
atan 메서드
Math 개체 메서드
sin 메서드
tan 메서드


E 속성

E 속성 		언어 참조
버전 1

참고 적용 대상

설명
자연 로그의 밑인 오일러 상수를 반환합니다. E 속성은 약 2.718입니다.
구문
var numVar
numVar = Math.E


E 속성

E 속성
적용 대상 		언어 참조

Math 개체


E 속성

E 속성
참고 		언어 참조

exp 메서드
Math 개체 속성


exp 메서드

exp 메서드 		언어 참조
버전 1

참고 적용 대상

설명
자연 로그의 밑인 e의 거듭제곱 값을 반환합니다.
구문
Math.exp(number)

number 인수는 e의 거듭제곱을 나타내는 수식입니다.

참고
반환값은 enumber입니다. 상수 e는 오일러 상수로 약 2.178에 해당하며 number는 주어진 인수입니다.


exp 메서드

exp 메서드
적용 대상 		언어 참조

Math 개체


exp 메서드

exp 메서드
참고 		언어 참조

E 속성
Math 개체 메서드


floor 메서드

floor 메서드 		언어 참조
버전 1

참고 적용 대상

설명
숫자 인수보다 작거나 같은 가장 큰 정수를 반환합니다.
구문
Math.floor(number)

number 인수는 수식입니다.

참고
반환값은 숫자 인수보다 작거나 같은 가장 큰 정수 값입니다.


floor 메서드

floor 메서드
적용 대상 		언어 참조

Math 개체


floor 메서드

floor 메서드
참고 		언어 참조

ceil 메서드
Math 개체 메서드


LN2 속성

LN2 속성 		언어 참조
버전 1

참고 적용 대상

설명
자연 로그 2를 반환합니다.
구문
var numVar
numVar = Math.LN2
구문
LN2 속성은 약 0.693에 해당합니다.


LN2 속성

LN2 속성
적용 대상 		언어 참조

Math 개체


LN2 속성

LN2 속성
참고 		언어 참조

Math 개체 속성


LN10 속성

LN10 속성 		언어 참조
버전 1

참고 적용 대상

설명
자연 로그 10을 반환합니다.
구문
var numVar
numVar = Math.LN10
참고
LN10 속성은 약 2.302에 해당합니다.


LN10 속성

LN10 속성
적용 대상 		언어 참조

Math 개체


LN10 속성

LN10 속성
참고 		언어 참조

Math 개체 속성


log 메서드

log 메서드 		언어 참조
버전 1

참고 적용 대상

설명
자연 로그 값을 반환합니다.
구문
Math.log(number)

number 인수는 자연 로그 값을 찾는 수식입니다.

반환값
반환값은 number의 자연 로그 값입니다. 밑은 e입니다.


LOG2E 속성

LOG2E 속성 		언어 참조
버전 1

참고 적용 대상

설명
밑이 2인 로그 e(오일러 상수)를 반환합니다.
구문
var varName
varName = objName.LOG2E
참고
LOG2E 속성은 상수이며 약 1.442에 해당합니다.


LOG2E 속성

LOG2E 속성
적용 대상 		언어 참조

Math 개체


LOG2E 속성

LOG2E 속성
참고 		언어 참조

Math 개체 속성


LOG10E 속성

LOG10E 속성 		언어 참조
버전 1

참고 적용 대상

설명
밑이 10인 로그 e(오일러 상수)를 반환합니다.
구문
var varName
varName = objName.LOG10E
참고
LOG10E 속성은 상수이며 약 0.434에 해당합니다.


LOG10E 속성

Log10E 속성
적용 대상 		언어 참조

Math 개체


LOG10E 속성

LOG10E 속성
참고 		언어 참조

Math 개체 속성


log 메서드

log 메서드
적용 대상 		언어 참조

Math 개체


log 메서드

log 메서드
참고 		언어 참조

Math 개체 메서드


max 메서드

max 메서드 		언어 참조
버전 1

참고 적용 대상

설명
주어진 두 수식 중 큰 값을 반환합니다.
구문
retVal = Math.max(number1, number2)

max 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
retVal | number1과 number2 중 큰 값입니다.
number1 | number2와 비교할 수식입니다.
number2 | number1과 비교할 숫자 값입니다.


max 메서드

max 메서드
적용 대상 		언어 참조

Math 개체


max 메서드

max 메서드
참고 		언어 참조

Math 개체 메서드
min 메서드


min 메서드

min 메서드 		언어 참조
버전 1

참고 적용 대상

설명
주어진 두 수 중 작은 값을 반환합니다.
구문
retVal = Math.min(number1, number2)

min 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
retVal | number1과 number2 중 작은 값입니다.
number1 | number2와 비교할 수식입니다.
number2 | number1과 비교할 숫자 값입니다.


min 메서드

min 메서드
적용 대상 		언어 참조

Math 개체


min 메서드

min 메서드
참고 		언어 참조

Math 개체 메서드
max 메서드


PI 속성

PI 속성 		언어 참조
버전 1

참조 적용 대상

설명
원주율의 근사치 3.141592653589793을 반환합니다.
구문
var numVar
numVar = Math.PI
참고
PI 속성은 상수이며 약 3.14159에 해당합니다.


PI 속성

PI 속성
적용 대상 		언어 참조

Math 개체


PI 속성

PI 속성
참고 		언어 참조

Math 개체 속성


pow 메서드

pow 메서드 		언어 참조
버전 1

참고 적용 대상

설명
밑을 지정한 지수만큼 거듭제곱한 값을 반환합니다.
구문
Math.pow(base, exponent)

pow 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
base | 밑에 해당하는 값입니다.
exponent | 지수에 해당하는 값입니다.

참고
아래 예제에서는 baseexponent에 해당하는 수식이 1000을 반환합니다.
Math.pow(10,3);


pow 메서드

pow 메서드
적용 대상 		언어 참조

Math 개체


pow 메서드

pow 메서드
참고 		언어 참조

Math 개체 메서드


random 메서드

random 메서드 		언어 참조
버전 1

참고 적용 대상

설명
0과 1 사이의 의사 난수 값을 반환합니다.
구문
Math.random( )
참고
발생하는 의사 난수 값은 0과 1 사이입니다(0, 1 포함). 난수 발생기는 JScript를 처음으로 로드할 때 자동으로 마련됩니다.


random 메서드

random 메서드
적용 대상 		언어 참조

Math 개체


random 메서드

random 메서드
참고 		언어 참조

Math 개체 메서드


round 메서드

round 메서드 		언어 참조
버전 1

참고 적용 대상

설명
주어진 수식을 반올림하여 가장 가까운 정수를 반환합니다.
구문
Math.round(number)

number 인수는 가장 가까운 정수로 반올림할 값입니다.

참고
number의 소수 첫째 자리가 0.5 이상이면 반환값은 number보다 큰 정수 중 가장 작은 값입니다. 그 외의 경우에는 round에서 number 이하의 정수 중 가장 큰 값을 반환합니다.


round 메서드

round 메서드
적용 대상 		언어 참조

Math 개체


round 메서드

round 메서드
참고 		언어 참조

Math 개체 메서드


sin 메서드

sin 메서드 		언어 참조
버전 1

참고 적용 대상

설명
사인 값을 반환합니다.
구문
Math.sin(number)

number 인수는 사인 값을 찾는 수식입니다.

참고
반환값은 숫자 인수의 사인 값입니다.


sin 메서드

sin 메서드
적용 대상 		언어 참조

Math 개체


sin 메서드

sin 메서드
참고 		언어 참조

acos 메서드
asin 메서드
atan 메서드
cos 메서드
Math 개체 메서드
tan 메서드


sqrt 메서드

sqrt 메서드 		언어 참조
버전 1

참고 적용 대상

설명
제곱근 값을 반환합니다.
구문
Math.sqrt(number)

number 인수는 수식입니다.

참고
number가 음수이면 반환값은 0입니다.


SQRT1_2 속성

SQRT1_2 속성 		언어 참조
버전 1

참고 적용 대상

설명
0.5의 제곱근 값 또는 1을 2의 제곱근으로 나눈 값을 반환합니다.
구문
var numVar
numVar = Math.SQRT1_2
참고
SQRT1_2 속성은 상수이며 약 0.707에 해당합니다.


SQRT1_2 속성

SQRT1_2 속성
적용 대상 		언어 참조

Math 개체


SQRT1_2 속성

SQRT1_2 속성
참고 		언어 참조

Math 개체 속성
sqrt 메서드
SQRT2 속성


SQRT2 속성

SQRT2 속성 		언어 참조
버전 1

참고 적용 대상

설명
2의 제곱근을 반환합니다.
구문
var numVar
numVar = Math.SQRT2
참고
SQRT2 속성은 상수이며 약 1.414에 해당합니다.


SQRT2 속성

SQRT2 속성
적용 대상 		언어 참조

Math 개체


SQRT2 속성

SQRT2 속성
참고 		언어 참조

Math 개체 속성
sqrt 메서드
SQRT1_2 속성


sqrt 메서드

sqrt 메서드
적용 대상 		언어 참조

Math 개체


sqrt 메서드

sqrt 메서드
참고 		언어 참조

Math 개체 메서드
SQRT1_2 속성
SQRT2 속성


tan 메서드

tan 메서드 		언어 참조
버전 1

참고 적용 대상

설명
탄젠트 값을 반환합니다.
구문
Math.tan(number)

number 인수는 탄젠트 값을 찾는 수식입니다.

참고
반환값은 number의 탄젠트 값입니다.


tan 메서드

tan 메서드
적용 대상 		언어 참조

Math 개체


tan 메서드

tan 메서드
참고 		언어 참조

acos 메서드
asin 메서드
atan 메서드
atan2 메서드
cos 메서드
Math 개체 메서드
sin 메서드


JScript 런타임 오류

JScript 런타임 오류 		언어 참조
버전 1

JScript 구문 오류

오류 번호 | 설명
5 | 프로시저 호출 또는 인수가 잘못되었습니다.
6 | 숫자가 너무 큽니다.
7 | 메모리가 부족합니다.
9 | 첨자 사용이 잘못되었습니다.
10 | 배열이 고정되었거나 일시적으로 잠금 상태입니다.
11 | 0으로 나누었습니다.
13 | 형식이 일치하지 않습니다.
14 | 문자열 공간이 부족합니다.
17 | 요청한 작업을 수행할 수 없습니다.
28 | 스택 공간이 부족합니다.
35 | Sub 또는 Function이 정의되지 않았습니다.
48 | DLL 로드 중 오류가 발생하였습니다.
51 | 내부 오류입니다.
52 | 파일 이름 또는 번호가 잘못되었습니다.
53 | 파일이 없습니다.
54 | 파일 모드가 잘못되었습니다.
55 | 파일이 이미 열려 있습니다.
57 | 장치 입/출력 오류입니다.
58 | 파일이 이미 존재합니다.
61 | 디스크에 여유 공간이 없습니다.
62 | 파일 끝을 넘는 입력(값)입니다.
67 | 파일이 너무 많습니다.
68 | 사용할 수 없는 장치입니다.
70 | 사용 권한이 없습니다.
71 | 디스크가 준비되지 않았습니다.
74 | 다른 드라이브로 이름을 바꿀 수 없습니다.
75 | 경로/파일 액세스 오류입니다.
76 | 경로를 찾을 수 없습니다.
91 | Object 변수나 With 변수가 설정되어 있지 않습니다.
92 | For 루프를 초기화하지 않았습니다.
94 | null의 사용이 잘못되었습니다.
322 | 필요한 임시 파일을 만들 수 없습니다.
424 | 개체가 필요합니다.
429 | 자동화 서버는 개체를 만들 수 없습니다.
430 | 클래스가 자동화를 지원하지 않습니다.
432 | 자동화 실행 중 파일 이름이나 클래스 이름을 찾을 수 없습니다.
438 | 개체가 이 속성 또는 메서드를 지원하지 않습니다.
440 | 자동화 오류가 발생하였습니다.
445 | 개체가 이 동작을 지원하지 않습니다.
446 | 개체가 명명된 인수를 지원하지 않습니다.
447 | 개체가 현재의 로케일 설정을 지원하지 않습니다.
448 | 명명된 인수를 찾을 수 없습니다.
449 | 선택적인 인수가 아닙니다.
450 | 인수의 개수나 속성 지정이 잘못되었습니다.
451 | 컬렉션이 아닌 개체입니다.
453 | 지정한 DLL 함수를 찾을 수 없습니다.
458 | 변수가 JScript에서 지원하지 않는 자동화 형식을 사용하고 있습니다.
462 | 원격 서버 시스템이 없거나 사용할 수 없습니다.
501 | 변수를 지정할 수 없습니다.
502 | 개체를 스크립트하는 데 잘못되었습니다.
503 | 개체를 초기화하는 데 잘못되었습니다.
504 | 개체를 만드는 데 잘못되었습니다.
507 | 예외가 발생하였습니다.
5000 | '여기'에 정의할 수 없습니다.
5001 | 숫자가 필요합니다.
5002 | 함수가 필요합니다.
5003 | 함수 결과에 지정할 수 없습니다.
5004 | 개체 인덱스 작업을 할 수 없습니다.
5005 | 문자열이 필요합니다.
5006 | Date 개체가 필요합니다.
5007 | 개체가 필요합니다.
5008 | 지정이 잘못되었습니다.
5009 | 식별자가 정의되지 않았습니다.
5010 | Boolean이 필요합니다.
5011 | 지워진 스크립트에서 코드를 실행할 수 없습니다.
5012 | 개체 구성원이 필요합니다.
5013 | VBArray가 필요합니다.
5014 | JScript 개체가 필요합니다.
5015 | Enumerator 개체가 필요합니다.
5016 | 정규식 개체가 필요합니다.
5017 | 정규식에 구문 오류가 있습니다.
5018 | 예기치 않은 한정 기호입니다.
5019 | 정규식에 ']'가 필요합니다.
5020 | 정규식에 ')'가 필요합니다.
5021 | 문자 집합의 범위가 틀립니다.
5022 | 예외가 발생하여 해결할 수 없습니다.
5023 | 함수에 유효한 프로토타입 개체가 없습니다.


JScript 구문 오류

JScript 구문 오류 		언어 참조
버전 1

JScript 런타임 오류

오류 번호 | 설명
1001 | 메모리가 부족합니다.
1002 | 구문 오류입니다.
1003 | ':'이 필요합니다.
1004 | ';'이 필요합니다.
1005 | '('가 필요합니다.
1006 | ')'가 필요합니다.
1007 | ']'가 필요합니다.
1008 | '{'가 필요합니다.
1009 | '}'가 필요합니다.
1010 | 식별자가 필요합니다.
1011 | '='가 필요합니다.
1012 | '/'가 필요합니다.
1013 | 유효하지 않은 숫자입니다.
1014 | 유효하지 않은 문자입니다.
1015 | 종료되지 않은 문자열 상수입니다.
1016 | 종료되지 않은 주석입니다.
1018 | 'return' 문이 함수 밖에 있습니다.
1019 | '루프 밖에서는 break'를 사용할 수 없습니다.
1020 | 루프 밖에서는 'continue'를 사용할 수 없습니다.
1023 | 16진수가 필요합니다.
1024 | 'while'이 필요합니다.
1025 | 레이블이 다시 정의되었습니다.
1026 | 레이블이 없습니다.
1027 | 'switch'문에서 'default'는 한 번만 사용할 수 있습니다.
1028 | 식별자나 문자열이 필요합니다.
1029 | '@end'가 필요합니다.
1030 | 조건부 컴파일이 해제되었습니다.
1031 | 상수가 필요합니다.
1032 | '@'이 필요합니다.
1033 | 'catch'가 필요합니다.
1034 | 'var'가 필요합니다.
1035 | 'throw' 다음에 동일한 원본 줄에 있는 식이 있어야 합니다.


MAX_VALUE 속성

MAX_VALUE 속성 		언어 참조
버전 2

참고 적용 대상

설명
JScript에서 나타낼 수 있는 가장 큰 수를 반환합니다. 약 1.79E+308에 해당합니다.
구문
Number.MAX_VALUE

number 인수는 Number 개체입니다.

참고
Number 개체를 MAX_VALUE 속성에 액세스하기 전에 만들 필요는 없습니다.


MAX_VALUE 속성

MAX_VALUE 속성
적용 대상 		언어 참조

Number 개체


MAX_VALUE 속성

MAX_VALUE 속성
참고 		언어 참조

MIN_VALUE 속성
NaN 속성
NEGATIVE_INFINITY 속성
POSITIVE_INFINITY 속성
toString 메서드


MIN_VALUE 속성

MIN_VALUE 속성 		언어 참조
버전 2

참고 적용 대상

설명
JScript에서 나타낼 수 있는 0에 가장 가까운 수를 반환합니다. 약 2.22E-308에 해당합니다.
구문
Number.MIN_VALUE

number 인수는 Number 개체입니다.

참고
Number 개체를 MIN_VALUE 속성에 액세스하기 전에 만들 필요는 없습니다.


MIN_VALUE 속성

MIN_VALUE 속성
적용 대상 		언어 참조

Number 개체


MIN_VALUE 속성

MIN_VALUE 속성
참고 		언어 참조

MAX_VALUE 속성
NaN 속성
NEGATIVE_INFINITY 속성
POSITIVE_INFINITY 속성
toString 메서드


NaN 속성

NaN 속성 		언어 참조
버전 2

참고 적용 대상

설명
숫자가 아닌 값을 반환한 산술식을 나타내는 특수 값입니다.
구문
Number.NaN

number 인수는 Number 개체입니다.

참고
Number 개체를 NaN 속성에 액세스하기 전에 만들 필요는 없습니다.

NaN은 자신을 포함한 어느 값과도 같지 않습니다. 값이 NaN과 같은지를 테스트하려면 isNaN 함수를 사용하십시오.


NaN 속성

NaN 속성
적용 대상 		언어 참조

Number 개체


NaN 속성

NaN 속성
참고 		언어 참조

isNaN 메서드
MAX_VALUE 속성
MIN_VALUE 속성
NEGATIVE_INFINITY 속성
POSITIVE_INFINITY 속성
toString 메서드


NEGATIVE_INFINITY 속성

NEGATIVE_INFINITY 속성 		언어 참조
버전 2

참고 적용 대상

설명
JScript에서 나타낼 수 있는 가장 작은 음수(-Number.MAX_VALUE)보다 작은 값을 반환합니다.
구문
Number.NEGATIVE_INFINITY

number 인수는 Number 개체입니다.

참고
Number 개체를 NEGATIVE_INFINITY 속성에 액세스하기 전에 만들 필요는 없습니다.

JScript는 NEGATIVE_INFINITY 값을 -infinity로 표시합니다. 이 값은 수학적으로 무한대처럼 작용합니다.


NEGATIVE_INFINITY 속성

NEGATIVE_INFINITY 속성
적용 대상 		언어 참조

Number 개체


NEGATIVE_INFINITY 속성

NEGATIVE_INFINITY 속성
참고 		언어 참조

MAX_VALUE 속성
MIN_VALUE 속성
NaN 속성
POSITIVE_INFINITY 속성
toString 메서드


POSITIVE_INFINITY 속성

POSITIVE_INFINITY 속성 		언어 참조
버전 2

참고 적용 대상

설명
JScript에서 나타낼 수 있는 가장 큰 수(Number.MAX_VALUE)보다 더 큰 값을 반환합니다.
구문
Number.POSITIVE_INFINITY

number 인수는 Number 개체입니다.

참고
Number 개체를 POSITIVE_INFINITY 속성에 액세스하기 전에 만들 필요는 없습니다.

JScript는 POSITIVE_INFINITY 값을 +infinity로 표시합니다. 이 값은 수학적으로 무한대처럼 작용합니다.


POSITIVE_INFINITY 속성

POSITIVE_INFINITY 속성
적용 대상 		언어 참조

Number 개체


POSITIVE_INFINITY 속성

POSITIVE_INFINITY 속성
참고 		언어 참조

MAX_VALUE 속성
MIN_VALUE 속성
NaN 속성
NEGATIVE_INFINITY 속성
toString 메서드


ActiveXObject 개체

ActiveXObject 개체 		언어 참조
버전 3

참고

설명
자동화 개체에 대한 참조를 사용하여 반환합니다.
구문
var newObject = new ActiveXObject("servername.typename"[, "location"])

ActiveXObject 개체 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
servername | 필수적인 요소. 개체를 제공하는 응용 프로그램의 이름입니다.
typename | 필수적인 요소. 만들 개체의 종류나 클래스입니다.
location | 선택적인 요소. 개체가 만들어질 네트워크 서버의 이름입니다.

참고
자동화 서버는 최소한 한 종류의 개체를 제공합니다. 예를 들어, 워드 프로세싱 응용 프로그램은 응용 프로그램 개체, 문서 개체 및 도구 모음 개체를 제공합니다.

자동화 개체를 만들려면 개체 변수에 새 ActiveXObject를 아래과 같이 지정하십시오.

var ExcelSheet;
ExcelSheet = new ActiveXObject("Excel.Sheet");
이 코드는 개체를 만드는 응용 프로그램을 만듭니다(여기에서는 Microsoft Excel 워크시트). 개체가 만들어지면 정의한 개체 변수를 사용하여 코드에서 해당 개체를 참조합니다. 아래 예제에서는 응용 프로그램 개체 및 ActiveSheet.Cells 컬렉션을 포함하는 개체 변수 ExcelSheet 및 기타 Excel 개체를 사용하여 새 개체의 속성과 메서드에 액세스합니다.

// Application 개체를 통하여 Excel을 보이게 합니다.
ExcelSheet.Application.Visible = true;
// 일부 텍스트를 시트의 첫번째 셀에 놓습니다.
ExcelSheet.ActiveSheet.Cells(1,1).Value = "이 셀은 A열, 1행입니다.";
// 시트를 저장합니다.
ExcelSheet.SaveAs("C:\\TEST.XLS");
// Application 개체의 Quit 메서드를 사용하여 Excel을 닫습니다.
ExcelSheet.Application.Quit();
// 개체 변수를 해제합니다.
ExcelSheet = "";
원격 서버에서는 인터넷 보안 설정이 해제된 경우에만 개체를 만들 수 있습니다. ActiveXObject의 servername 인수에 컴퓨터 이름을 보내면 네트워크에 연결되어 있는 원격 컴퓨터에서 개체를 만들 수 있습니다. 컴퓨터 이름은 공유 영역 이름의 시스템 이름 부분과 같습니다. 네트워크 공유 영역 이름이 "\\myserver\public"인 경우 servername은 "myserver"입니다. 또한 DNS 형식이나 IP 주소를 사용하여 servername을 지정할 수 있습니다.

아래 코드는 "myserver"라는 원격 네트워크 컴퓨터에서 실행 중인 Excel 인스턴스의 버전 번호를 반환합니다.

Function GetVersion {
  var XLApp = CreateObject("Excel.Application", "MyServer");
  return(XLApp.Version);
}
지정한 원격 서버가 없거나 찾을 수 없을 경우에는 오류가 발생합니다.


ActiveXObject 개체

ActiveXObject 개체
참고 		언어 참조

GetObject 함수


Array 개체

Array 개체
 언어 참조
버전 2

참고 메서드 속성

설명
모든 데이터 형식의 배열을 만들 수 있도록 지원합니다.
구문
new Array()
new Array(size)
new Array(element0, element1, ..., elementn)

Array 개체 작성 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
size | 배열의 크기입니다. 배열이 0에서 시작하므로 만들어진 요소는 0에서 size - 1까지의 인덱스를 가집니다.
element0,...,elementn | 배열에 사용되는 요소들입니다. 이 구성 요소는 n + 1 개의 요소로 length가 n인 배열을 만듭니다.

참고
배열이 만들어진 후 배열을 구성하는 각 요소는 [ ] 표시로 액세스할 수 있습니다. 예를 들어 다음과 같습니다.
var my_array = new Array();
for (i = 0; i < 10; i++)
    {
    my_array[i] = i;
    }
x = my_array[4];
Microsoft JScript에서는 배열이 0에서 시작하므로 위 예제의 마지막 문은 배열의 5번째 요소를 액세스하고, 그 값은 4입니다.

인수 하나만 Array 구성자로 전달되고 그 인수가 숫자라면 부호 없는 정수로 강제 변환되어 배열의 크기로 사용됩니다. 그렇지 않으면 전달된 매개 변수는 배열의 요소로만 사용됩니다.


Array 개체

Array 개체
참고 		언어 참조

new 연산자


Array 개체 메서드

Array 개체
메서드 		언어 참조

Array.prototype의 구성원
concat 메서드
join 메서드
reverse 메서드
slice 메서드
sort 메서드

toString 메서드
valueOf 메서드

Array.prototype의 비구성원
Array 개체에는 초기 설정의 구성 요소가 아닌 메서드는 없습니다.


Array 개체 속성

Array 개체
속성 		언어 참조

Array.prototype의 구성원
constructor 속성
Array.prototype의 비구성원
length 속성
prototype 속성


Boolean 개체

Boolean 개체 		언어 참조
버전 2

참고 메서드 속성

설명
새 부울값을 만듭니다.
구문
var variablename = new Boolean(boolvalue)

선택적인 요소인 boolvalue 인수는 새 개체의 초기 부울값입니다. 이 값이 생략되거나, false, 0, null, NaN, 또는 빈 문자열이라면 Boolean 개체의 초기 값은 false입니다. 그렇지 않으면 초기 값은 true입니다.

참고
Boolean 개체는 Boolean 데이터 형식의 래퍼입니다. JScript는 Boolean 데이터 형식이 Boolean 개체로 변환될 때마다 Boolean 개체를 함축적으로 사용합니다.

Boolean 개체를 명시적으로 사용할 경우는 거의 없습니다.


Boolean 개체

Boolean 개체
참고 		언어 참조

new 연산자
var 문


Boolean 개체 메서드

Boolean 개체
메서드 		언어 참조

Boolean.prototype의 구성원
toString 메서드
valueOf 메서드
Boolean.prototype의 비구성원
Boolean 개체에는 초기 설정의 구성 요소가 아닌 메서드는 없습니다.


Boolean 개체 속성

Boolean 개체
속성 		언어 참조

Boolean.prototype의 구성원
constructor 속성
Boolean.prototype의 비구성원
prototype 속성


Date 개체

Date 개체 		언어 참조
버전 1

참고 메서드 속성

설명
날짜와 시간을 기본으로 저장하거나 가져올 수 있습니다.
구문
var newDateObj = new Date()
var newDateObj = new Date(dateVal)
var newDateObj = new Date(year, month, date[, hours[, minutes[, seconds[,ms]]]])

Date 개체 구성자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
dateVal | 숫자 값이면 dateVal은 1970년 1월 1일 자정부터 주어진 날짜 사이의 시간을 협정 세계 표준시(UTC)로 밀리초까지 나타내고, 문자열이면 dateVal은 parse 메서드의 규칙에 따라 구문 분석됩니다. dateVal 인수는 일부 ActiveX® 개체에서 반환된 VT_DATE 값일 수도 있습니다.
year | 필수적인 요소. 예를 들어 76이 아니라 1976처럼 전체 연도로 나타냅니다.
month | 필수적인 요소. 월은 0부터 11까지의 정수(1월부터 12월)로 나타냅니다.
date | 필수적인 요소. 날짜는 1부터 31까지의 정수로 나타냅니다.
hours | 선택적인 요소. minutes를 사용하면 반드시 입력해야 합니다. 시간은 0부터 23까지(자정부터 오후 11시)의 정수로 나타냅니다.
minutes | 선택적인 요소. seconds를 사용하면 반드시 입력해야 합니다. 분은 0부터 59까지의 정수로 나타냅니다.
seconds | 선택적인 요소. milliseconds를 사용하면 반드시 입력해야 합니다. 초는 0부터 59까지의 정수로 나타냅니다.
ms | 선택적인 요소. 밀리초는 0부터 999까지의 정수로 나타냅니다.

참고
Date 개체는 밀리초 단위까지 특정 시간을 나타내는 숫자로 되어있습니다. 인수값이 정해진 인수값의 범위보다 크거나 음수이면 저장된 다른 값은 그에 따라 자동적으로 수정됩니다. 예를 들어 150초가 지정된다면 JScript는 2분 30초로 재정의합니다.

해당 숫자가 NaN이면 그 개체가 특정 시간을 표시하지 못한다는 것을 나타냅니다. Date 개체에 매개 변수를 전달하지 않으면 현재 시간(UTC)으로 초기화됩니다. 먼저 개체에 값을 지정해야 개체를 사용할 수 있습니다.

Date 개체에 나타낼 수 있는 날짜 범위는 1970년 1월 1일부터 전후로 약 285,616년입니다.

Date 개체는 Date 개체를 만들지 않고 호출되는 두 개의 정적 메서드를 가집니다. 이 두 정적 메서드는 parse와 UTC입니다.


Date 개체

Date 개체
참고 		언어 참조

new 연산자
var 문


Date 개체 메서드

Date 개체
메서드 		언어 참조

Date.prototype의 구성원
getDate 메서드
getDay 메서드
getFullYear 메서드
getHours 메서드
getMilliseconds 메서드
getMinutes 메서드
getMonth 메서드
getSeconds 메서드
getTime 메서드
getTimezoneOffset 메서드
getUTCDate 메서드
getUTCDay 메서드
getUTCFullYear 메서드
getUTCHours 메서드
getUTCMilliseconds 메서드
getUTCMinutes 메서드
getUTCMonth 메서드
getUTCSeconds 메서드
getVarDate 메서드
getYear 메서드
setDate 메서드
setFullYear 메서드
setHours 메서드
setMilliseconds 메서드
setMinutes 메서드
setMonth 메서드
setSeconds 메서드
setTime 메서드
setUTCDate 메서드
setUTCFullYear 메서드
setUTCHours 메서드
setUTCMilliseconds 메서드
setUTCMinutes 메서드
setUTCMonth 메서드
setUTCSeconds 메서드
setYear 메서드
toGMTString 메서드
toLocaleString 메서드
toUTCString 메서드

toString 메서드
valueOf 메서드

Date.prototype의 비구성원
parse 메서드
UTC 메서드


Date 개체 속성

Date 개체
속성 		언어 참조

constructor 속성
prototype 속성


Dictionary 개체

Dictionary 개체 		Scripting 런타임 참조
버전 2

참고 메서드 속성

설명
데이터 키-항목 쌍을 저장하는 개체입니다.
구문
y = new ActiveXObject("Scripting.Dictionary")
참고
Dictionary 개체는 PERL 관련 배열과 같습니다. 항목들은 모든 형식의 데이터일 수 있으며, 이 배열에 저장됩니다. 각 항목은 고유한 키와 연결됩니다. 이 키는 개별 항목을 검색하는 데 사용되며 대개 배열이 아닌 모든 정수 또는 문자열일 수 있습니다.

아래 코드는 Dictionary 개체의 작성 방법을 보여줍니다.

var y = new ActiveXObject("Scripting.Dictionary");
y.add ("a", "test");
if (y.Exists("a"))
  document.write("true");
...


Dictionary 개체

Dictionary 개체
참고 		Scripting 런타임 참조

FileSystemObject 개체
TextStream 개체


Dictionary 개체 메서드

Dictionary 개체
메서드 		Scripting 런타임 참조

Add 메서드(Dictionary)
Exists 메서드
Items 메서드
Keys 메서드
Remove 메서드
RemoveAll 메서드


Dictionary 개체 속성

Dictionary 개체
속성 		Scripting 런타임 참조

Count 속성
Item 속성
Key 속성


Drive 개체

Drive 개체 		Scripting 런타임 참조
버전 3

참고 속성 메서드

설명
특정 디스크 드라이브나 네트워크 공유 속성에 액세스할 수 있습니다.
참고
아래 코드에서는 Drive 개체를 사용하여 드라이브 속성에 액세스하는 방법을 보여줍니다.
function ShowFreeSpace(drvPath)
{
    var fso, d, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    d = fso.GetDrive(fso.GetDriveName(drvPath));
    s = "드라이브 " + drvPath + " - " ;
    s += d.VolumeName + "<br>";
    s += "사용 가능한 공간: " + d.FreeSpace/1024 + " KB";
    return(s);
}


Drive 개체

Drive 개체
참고 		Scripting 런타임 참조

Drives 컬렉션
File 개체
Files 컬렉션
Folder 개체
Folders 컬렉션
GetDrive 메서드


Drive 개체

Drive 개체
메서드 		Scripting 런타임 참조

Drive 개체에는 메서드가 없습니다.


Drive 개체

Drive 개체
속성 		Scripting 런타임 참조

AvailableSpace 속성
DriveLetter 속성
DriveType 속성
FileSystem 속성
FreeSpace 속성
IsReady 속성
Path 속성
RootFolder 속성
SerialNumber 속성
ShareName 속성
TotalSize 속성
VolumeName 속성


constructor 속성

constructor 속성 		언어 참조
버전 2

참고 적용 대상

설명
개체를 만드는 함수를 지정합니다.
구문
object.constructor

object 인수는 필수적인 요소이며 개체 또는 함수 이름입니다.

참고
constructor 속성은 초기 설정을 가지는 모든 초기 설정 개체의 구성원입니다. 이 속성은 Global 개체와 Math 개체를 제외한 모든 JScript 내부 개체를 포함합니다. 그리고 constructor 속성은 특정 개체의 인스턴스를 구성하는 함수에 대한 참조를 포함합니다. 예를 들어 다음과 같습니다.
x = new String("Hi");
if (x.constructor == String)
       // 필요한 일을 합니다(조건은 true입니다).
또는
function MyFunc {
    // 함수의 본문입니다.
}

y = new MyFunc;
if (y.constructor == MyFunc)
       // 필요한 일을 합니다(조건은 true입니다).


constructor 속성

constructor 속성
적용 대상 		언어 참조

Array 개체
Boolean 개체
Date 개체
Function 개체
Math 개체
Number 개체
Object 개체
String 개체


constructor 속성

constructor 속성
참고 		언어 참조

prototype 속성


prototype 속성

prototype 속성 		언어 참조
버전 2

참고 적용 대상

설명
개체 클래스의 초기 설정에 대한 참조를 반환합니다.
구문
objectname.prototype

objectname 인수는 개체의 이름입니다.

참고
개체 클래스에 기본적인 함수 집합을 제공하기 위해 prototype 속성을 사용합니다. 개체의 새로운 인스턴스는 해당 개체에 지정된 초기 설정의 동작을 "상속" 받습니다.

예를 들어 가장 큰 배열 요소의 값을 반환하는 Array 개체에 메서드를 추가하려면 함수를 선언하고 Array.prototype에 해당 함수를 추가한 다음 사용하십시오.

function array_max( )
{
  var i, max = this[0];
  for (i = 1; i < this.length; i++)
  {
     if (max < this[i])
         max = this[i];
  }
  return max;
}
Array.prototype.max = array_max;
var x = new Array(1, 2, 3, 4, 5, 6);
var y = x.max( );
이 코드가 실행된 후 y는 x 배열에서 가장 큰 값이나 6을 포함합니다.

모든 JScript 내부 개체는 읽기 전용의 prototype 속성을 가집니다. 예제와 같이 해당 초기 설정에 기능이 추가될 수도 있지만 그 개체에 다른 초기 설정을 지정할 수는 없습니다. 그러나 사용자 정의 개체에는 새로운 초기 설정을 지정할 수 있습니다.

언어 참조에서 각 내부 개체에 대한 메서드와 속성 목록은 어느 것이 개체의 초기 설정이고 어느 것이 아닌지를 표시합니다.


prototype 속성

prototype 속성
적용 대상 		언어 참조

Array 개체
Boolean 개체
Date 개체
Function 개체
Number 개체
Object 개체
String 개체


prototype 속성

prototype 속성
참고 		언어 참조

constructor 속성


toString 메서드

toString 메서드 		언어 참조
버전 2

참고 적용 대상

설명
개체를 나타내는 문자열을 반환합니다.
구문
objectname.toString([radix])

toString 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
objectname | 필수적인 요소. 문자열 표시를 찾는 개체입니다.
radix | 선택적인 요소. 숫자 값을 문자열로 변환하기 위한 기수를 지정합니다.

참고
toString 메서드는 모든 기본 제공 JScript 개체들의 구성원 중 하나입니다. 그러나 메서드는 아래 개체 형식에 따라 다르게 작용합니다.

개체 | 동작
Array | Array의 요소들은 문자열로 변환됩니다. 결과로 나온 문자열은 쉼표로 연결되고 구분됩니다.
Boolean | 부울값이 true이면 "true"를 반환합니다. 그렇지 않으면 "false"를 반환합니다.
Function 아래 형식으로 반환된 문자열을 반환합니다. 여기서 functionname은 toString 메서드를 호출하는 함수의 이름입니다.
function functionname( ) { [native code] }
Number | 숫자에 대한 원문 표시를 반환합니다.
String | String 개체의 값을 반환합니다.
Default | "[object objectname]"을 반환합니다. 여기서 objectname은 개체 형식의 이름입니다.

아래 예제는 기수 인수를 가진 toString 메서드의 사용법을 보여줍니다.

function CreateRadixTable ()
{
  var s1, s2, s3, x;
  document.write("Hex    Dec   Bin<BR>");
  for (x = 0; x < 16; x++)
  {
    switch(x)
    {
      case 0 :
        s1 = "      ";
        s2 = "    ";
        s3 = "   ";
        break;
      case 1 :
        s1 = "      ";
        s2 = "    ";
        s3 = "   ";
        break;
      case 2 :
        s3 = "  ";
        break;
      case 3 :
        s3 = "  ";
        break;
      case 4 :
        s3 = " ";
        break;
      case 5 :
        s3 = " ";
        break;
      case 6 :
        s3 = " ";
        break;
      case 7 :
        s3 = " ";
        break;
      case 8 :
        s3 = "" ;
        break;
      case 9 :
        s3 = "";
        break;
      default:
        s1 = "     ";
        s2 = "";
        s3 = "    ";
    }
    document.write(" ", x.toString(16), s1, x.toString(10), s2, s3, x.toString(2), "<BR>");
  }
}


toString 메서드

toString 메서드
적용 대상 		언어 참조

Array 개체
Boolean 개체
Function 개체
Number 개체
Object 개체
String 개체


toString 메서드

toString 메서드
참고 		언어 참조

Function 문


valueOf 메서드

valueOf 메서드 		언어 참조
버전 2

참고 적용 대상

설명
지정한 개체의 원시 값을 반환합니다.
구문
object.valueOf( )

object 인수는 JScript 개체입니다.

참고
valueOf 메서드는 각 JScript 내부 개체에 다르게 정의됩니다.

개체 | 반환값
Array | 배열 요소는 문자열로 변환되고 문자열은 쉼표로 연결하고 구분합니다. 이것은 Array.toString과 Array.join 메서드처럼 작용합니다.
Boolean | 부울값입니다.
Date | UTC 1970년 1월 1일 자정부터 밀리초 단위로 저장된 시간 값입니다.
Function | 함수 그 자체입니다.
Number | 숫자 값입니다.
Object | 개체 그 자체입니다. 기본값입니다.
String | 문자열 값입니다.

Math 개체는 valueOf 메서드를 갖지 않습니다.


valueOf 메서드

valueOf 메서드
적용 대상 		언어 참조

Array 개체
Boolean 개체
Date 개체
Function 개체
Number 개체
Object 개체
String 개체


valueOf 메서드

valueOf 메서드
참고 		언어 참조

toString 메서드


Enumerator 개체

Enumerator 개체 		언어 참조
버전 3

참고 메서드 속성

설명
컬렉션에 있는 항목들을 열거할 수 있습니다.
구문
new Enumerator(collection)

collection 인수는 임의의 컬렉션 개체입니다.

참고
컬렉션은 컬렉션의 구성원을 직접 액세스할 수 없는 배열과는 다릅니다. 배열할 때 인덱스를 사용하는 대신 현재 항목 포인터를 컬렉션의 첫째 항목이나 다음 항목으로 옮길 수 있습니다.

Enumerator 개체는 컬렉션의 임의의 구성원에 액세스하는 방법을 제공하고 VBScirpt의 For...Each 문과 유사하게 작용합니다.

아래 코드는 Enumerator 개체의 사용법을 보여줍니다.

function ShowDriveList()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  for (;!e.atEnd();e.moveNext())
    {
      x = e.item();
      s = s + x.DriveLetter;
      s += " - ";
      if (x.DriveType == 3)
        n = x.ShareName;
      else if (x.IsReady)
        n = x.VolumeName;
      else
        n = "[드라이브가 준비되지 않았습니다.]";
      s +=  n + "<br>";
    }
  return(s);
}


Enumerator 개체

Enumerator 개체
참고 		언어 참조

Drives 컬렉션
Files 컬렉션
Folders 컬렉션


Enumerator 개체

Enumerator 개체
메서드 		언어 참조

atEnd 메서드
item 메서드
moveFirst 메서드
moveNext 메서드


Enumerator 개체

Enumerator 개체
속성 		언어 참조

Enumerator 개체에는 속성이 없습니다.


Error 개체

Error 개체 		언어 참조
버전 5

참고 속성

설명
오류에 대한 정보를 포함합니다.
구문
var newErrorObj = new Error()
var newErrorObj = new Error(number)
var newErrorObj = new Error(number, description)

Error 개체 구성자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
number | 오류에 지정되는 숫자 값입니다. 생략하면 0이 지정됩니다.
description | 오류를 설명하는 짧은 문자열입니다. 생략하면 빈 문자열이 지정됩니다.

참고
런타임 오류가 발생할 때마다 Error 개체의 인스턴스가 만들어져 오류를 설명합니다. 이 인스턴스는 오류에 대한 설명(description 속성)과 오류 번호(number 속성)의 두 가지 내부 속성을 가집니다.

오류 번호는 32비트 값입니다. 상위 16비트 단어는 장치 코드이며, 하위 16비트 단어가 실제 오류 코드입니다.

Error 개체는 위에 표시된 구문을 사용해서 명시적으로 만들어지거나 또는 throw 문을 사용해서 가져올 수 있습니다. 두 경우 모두 Error 개체의 기능을 확장하기 위하여 원하는 속성을 추가할 수 있습니다.

일반적으로 try...catch 문에서 만들어지는 지역 변수는 함축적으로 만들어진 Error 개체를 참조합니다. 그 결과 원하는 방법으로 오류 번호와 설명을 사용할 수 있습니다.

아래 예제는 함축적으로 만들어진 Error 개체의 사용법을 보여줍니다.

try {
x = y                		     // 오류가 발생합니다.
}
catch(e) {                           // 지역 변수 e를 만듭니다.
  response.write(e)                  // "[개체 오류]"를 인쇄합니다.
  response.write(e.number & 0xFFFF)  // 5009를 인쇄합니다.
  response.write(e.description)      // "'y'가 정의되지 않았습니다."를 인쇄합니다.
}


Error 개체

Error 개체
참고 		언어 참조

new 연산자
throw 문
try...catch 문
var 문


Error 개체

Error 개체
속성 		언어 참조

Description 속성
number 속성


File 개체

File 개체 		Scripting 런타임 참조
버전 3

참고 속성 메서드

설명
파일의 모든 속성에 액세스할 수 있습니다.
참고
아래 코드에서는 File 개체를 가져오는 방법과 그 속성 중 하나를 보는 방법을 보여줍니다.
function ShowFileInfo(filespec)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(filespec);
  s = f.DateCreated;
  return(s);
}


File 개체

File 개체
참고 		Scripting 런타임 참조

Drive 개체
Drives 컬렉션
Files 컬렉션
Folder 개체
Folders 컬렉션


File 개체

File 개체
메서드 		Scripting 런타임 참조

Copy 메서드
Delete 메서드
Move 메서드
OpenAsTextStream 메서드


File 개체

File 개체
속성 		Scripting 런타임 참조

Attributes 속성
DateCreated 속성
DateLastAccessed 속성
DateLastModified 속성
Drive 속성
Name 속성
ParentFolder 속성
Path 속성
ShortName 속성
ShortPath 속성
Size 속성
Type 속성


FileSystemObject 개체

FileSystemObject 개체 		Scripting 런타임 참조
버전 2

참고 메서드 속성

설명
컴퓨터의 파일 시스템에 액세스할 수 있습니다.
구문
y = new ActiveXObject("Scripting.FileSystemObject")
참고
아래 코드에서는 FileSystemObject를 사용하여 읽거나 쓸 수 있는 TextStream 개체를 반환하는 방법을 보여줍니다.
var fso = new ActiveXObject("Scripting.FileSystemObject");
var a = fso.CreateTextFile("c:\\testfile.txt", true);
a.WriteLine("테스트입니다.");
a.Close();
예제 코드에서는 ActiveXObject 개체를 FileSystemObject(fso)로 지정한 다음 CreateTextFile 메서드는 파일을 TextStream 개체(a)로 만들고, WriteLine 메서드는 만들어진 텍스트 파일에 텍스트 한 줄을 씁니다. 끝으로 Close 메서드는 버퍼를 비운 다음 해당 파일을 닫습니다.


FileSystemObject 개체

FileSystemObject 개체
참고 		Scripting 런타임 참조

Dictionary 개체
Drive 개체
Drives 컬렉션
File 개체
Files 컬렉션
Folder 개체
Folders 컬렉션
TextStream 개체


FileSystemObject 개체 메서드

FileSystemObject 개체
메서드 		Scripting 런타임 참조

BuildPath 메서드
CopyFile 메서드
CopyFolder 메서드
CreateFolder 메서드
CreateTextFile 메서드
DeleteFile 메서드
DeleteFolder 메서드
DriveExists 메서드
FileExists 메서드
FolderExists 메서드
GetAbsolutePathName 메서드
GetBaseName 메서드
GetDrive 메서드
GetDriveName 메서드
GetExtensionName 메서드
GetFile 메서드
GetFileName 메서드
GetFolder 메서드
GetParentFolderName 메서드
GetSpecialFolder 메서드
GetTempName 메서드
MoveFile 메서드
MoveFolder 메서드
OpenTextFile 메서드


FileSystemObject 개체 속성

FileSystemObject 개체
속성 		Scripting 런타임 참조

Drives 속성


Folder 개체

Folder 개체 		Scripting 런타임 참조
버전 3

참고 속성 메서드

설명
폴더의 모든 속성에 액세스할 수 있습니다.
참고
아래 코드에서는 Folder 개체를 가져오는 방법과 그 속성 중 하나를 반환하는 방법을 보여줍니다.
function ShowFolderInfo(folderspec)
{
  var fso, folder, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  folder = fso.GetFolder(folderspec);
  s = folder.DateCreated;
  return(s);
}


Folder 개체

Folder 개체
참고 		Scripting 런타임 참조

Drive 개체
Drives 컬렉션
File 개체
Files 컬렉션
Folders 컬렉션


Folder 개체

Folder 개체
메서드 		Scripting 런타임 참조

Copy 메서드
Delete 메서드
Move 메서드
OpenAsTextStream 메서드


Folder 개체

Folder 개체
속성 		Scripting 런타임 참조

Attributes 속성
DateCreated 속성
DateLastAccessed 속성
DateLastModified 속성
Drive 속성
Files 속성
IsRootFolder 속성
Name 속성
ParentFolder 속성
Path 속성
ShortName 속성
ShortPath 속성
Size 속성
SubFolders 속성
Type 속성


Function 개체

Function 개체 		언어 참조
버전 2

참고 메서드 속성

설명
새 함수를 만듭니다.
구문 1
function functionname( [argname1 [, ... argnameN]] )
{
body
}
구문 2
var functionname = new Function( [argname1, [... argnameN,]] body );

Function 개체 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
functionname | 새로 만들 함수 이름입니다.
argname1...argnameN | 함수에 사용하는 선택적인 인수 목록입니다.
body | 함수를 호출하면 실행되는 JScript 코드 블록을 포함한 문자열입니다.

참고
JScript에서 function은 기본적인 데이터 형식입니다. 구문 1을 사용하면 JScript에서 필요에 따라 Function 개체로 변환하는 함수값을 만듭니다. 함수를 호출하면 JScript에서 구문 2로 만든 Function 개체를 함수값으로 변환합니다.

구문 1은 JScript에서 새 함수를 만드는 표준 방법이고, 구문 2는 함수 개체들을 명시적으로 만들 경우 사용하는 대체 형식입니다.

예를 들어 함수에 전달되는 두 인수를 추가하는 함수를 만드는 방법은 다음과 같이 두 가지입니다.

예제 1
function add(x, y)
{
   return(x + y);
}
예제 2
var add = new Function("x", "y", "return(x+y)");
두 경우 모두 함수는 다음과 같이 한 줄로 된 코드로 호출합니다.
add(2, 3);
메모 함수를 호출할 때는 반드시 괄호와 필수적인 인수가 있어야 합니다. 괄호 없이 함수를 호출하면 함수 결과 대신 함수 텍스트가 반환됩니다.


Function 개체

Function 개체
참고 		언어 참조

Function 문
new 연산자
var 문


Function 개체 메서드

Function 개체
메서드 		언어 참조

Function.prototype의 구성원
toString 메서드
valueOf 메서드
Function.prototype의 비구성원
Function 개체에는 초기 설정의 구성 요소가 아닌 메서드는 없습니다.


Function 개체 속성

Function 개체
속성 		언어 참조

Function.prototype의 구성원
arguments 속성
caller 속성

constructor 속성

Function.prototype의 비구성원
prototype 속성


Global 개체

Global 개체 		언어 참조
버전 3

참고 메서드 속성

설명
전역 메서드들을 하나의 개체로 모으는 내부 개체입니다.
구문
Global 메서드는 구문이 없습니다. Global 메서드는 직접 호출해야 합니다.
참고
Global 개체는 직접 사용할 수 없고 new 연산자를 사용해서 만들 수도 없습니다. 이 개체는 스크립팅 엔진이 초기화되면 만들어지므로 이 개체의 메서드와 속성을 만들면 즉시 사용할 수 있습니다.


Global 개체

Global 개체
참고 		언어 참조

Object 개체


Global 개체

Global 개체
메서드 		언어 참조

escape 메서드
eval 메서드
isFinite 메서드
isNaN 메서드
parseFloat 메서드
parseInt 메서드
unescape 메서드


Global 개체

Global 개체
속성 		언어 참조

Infinity 속성
NaN 속성


Math 개체

Math 개체 		언어 참조
버전 1

참고 메서드 속성

설명
기본적인 계산 기능과 상수를 제공하는 내부 개체입니다.
구문
Math[.{property | method}]
참고
Math 개체는 new 연산자를 사용하여 만들 수 없으며, 만약 그렇게 하면 오류가 발생합니다. Math 개체는 엔진을 로드하면 스크립팅 엔진에 의해 만들어집니다. 이 개체의 모든 메서드와 속성은 항상 스크립트에 사용할 수 있습니다.


Math 개체

Math 개체
참고 		언어 참조

Number 개체


Math 개체 메서드

Math 개체
메서드 		언어 참조

Math.prototype의 구성원
Math 개체에는 초기 설정의 구성 요소가 아닌 메서드는 없습니다.
Math.prototype의 비구성원
abs 메서드
acos 메서드
asin 메서드
atan 메서드
atan2 메서드
ceil 메서드
cos 메서드
exp 메서드
floor 메서드
log 메서드
max 메서드
min 메서드
pow 메서드
random 메서드
round 메서드
sin 메서드
sqrt 메서드
tan 메서드


Math 개체 속성

Math 개체
속성 		언어 참조

E 속성
LN2 속성
LN10 속성
LOG2E 속성
LOG10E 속성
PI 속성
SQRT1_2 속성
SQRT2 속성


Number 개체

Number 개체 		언어 참조
버전 2

참고 메서드 속성

설명
숫자 상수의 Number 데이터 형식과 자리 표시자를 나타내는 개체입니다.
구문
new Number( value )

value 인수는 개체에서 찾으려는 숫자 값입니다.

참고
JScript는 필요하면 숫자 값에 Number 개체를 만듭니다. Number 개체를 명시적으로 만들 필요는 없습니다.

Number 개체의 가장 중요한 용도는 속성을 하나의 개체로 모으고 toString 메서드를 통해 숫자를 문자열로 변환하는 것입니다.


Number 개체

Number 개체
참고 		언어 참조

Math 개체
new 연산자


Number 개체 메서드

Number 개체
메서드 		언어 참조

Number.prototype의 구성원
toString 메서드
valueOf 메서드
Number.prototype의 비구성원
Number 개체에는 초기 설정의 구성 요소가 아닌 메서드는 없습니다.


Number 개체 속성

Number 개체
속성 		언어 참조

Number.prototype의 구성원
MAX_VALUE 속성
MIN_VALUE 속성
NaN 속성
NEGATIVE_INFINITY 속성
POSITIVE_INFINITY 속성

constructor 속성

Number.prototype의 비구성원
prototype 속성


Object 개체

Object 개체 		언어 참조
버전 3

참고 메서드 속성

설명
모든 Jscript 개체에 공통적인 기능을 제공합니다.
구문
new Object([value])

선택적인 요소인 value 인수는 원시 데이터 형식(Number, Boolean, String, 또는 Function)을 개체로 변환하는 데 사용됩니다. 생략하면 내용이 없는 개체가 만들어집니다.

참고
Object 개체는 모든 다른 JScript 개체에 들어있습니다. 이 개체의 모든 메서드와 속성은 다른 모든 개체에서 사용할 수 있습니다. 메서드는 사용자 정의 개체에 다시 정의될 수 있고 Jscript에 의해 적절한 시간에 호출됩니다. toString 메서드는 자주 다시 정의되는 Object 메서드의 한 예입니다.

언어 참조의 각 Object 메서드에 대한 설명에서 JScript 내부 개체에 대한 기본값과 개체별 실행 정보가 모두 설명됩니다.


Object 개체

Object 개체
참고 		언어 참조

Function 개체
Global 개체


Object 개체

Object 개체
메서드 		언어 참조

Object.prototype의 구성원
toString 메서드
valueOf 메서드

Object.prototype의 비구성원
Object 개체에는 초기 설정의 구성 요소가 아닌 메서드는 없습니다.


Object 개체

Object 개체
속성 		언어 참조

Object.prototype의 구성원
prototype 속성
constructor 속성

Object.prototype의 비구성원
Object 개체에는 초기 설정의 구성 요소가 아닌 속성은 없습니다.


RegExp 개체

RegExp 개체 		언어 참조
버전 3

참고 메서드 속성

설명
정규식 패턴 검색에 관한 정보를 저장합니다.
구문
RegExp.propertyname

propertyname 인수는 RegExp 개체 속성 중 하나입니다.

참고
RegExp 개체를 직접 만들 수는 없지만 항상 사용할 수는 있습니다. 이 개체의 속성은 정규식 검색을 성공적으로 완료할 때까지 undefined 값을 갖습니다.

아래 예제는 RegExp 개체의 사용법을 보여줍니다.

function matchDemo()
{
  var s;
  var re = new RegExp("d(b+)(d)","ig");
  var str = "cdbBdbsbdbdz";
  var arr = re.exec(str);
  s = "$1 내용: " + RegExp.$1 + "<BR>";
  s += "$2 내용: " + RegExp.$2 + "<BR>";
  s += "$3 내용: " + RegExp.$3;
  return(s);
}


RegExp 개체

RegExp 개체
참고 		언어 참조

정규식 구문
Regular Expression 개체
String 개체


RegExp 개체

RegExp 개체
메서드 		언어 참조

RegExp 개체에는 메서드가 없습니다.


RegExp 개체

RegExp 개체
속성 		언어 참조

$1...$9 속성
index 속성
input 소성
lastIndex 속성


Regular Expression 개체

Regular Expression 개체 		언어 참조
버전 3

참고 메서드 속성

설명
정규식 패턴을 포함합니다.
구문 1
var regularexpression = /pattern/[switch]
구문 2
var regularexpression = new RegExp("pattern",["switch"])

Regular expression 개체 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
pattern | 필수적인 요소. 사용할 정규식 패턴입니다. 구문 1을 사용하면 "/" 문자로 패턴을 구분하고, 구문 2를 사용하면 인용 부호로 패턴을 묶습니다.
switch 선택적인 요소. 구문 2를 사용하면 인용 부호로 스위치를 묶습니다. 사용할 수 있는 스위치는 다음과 같습니다.
  • i(대/소문자를 구분하지 않음)
  • g(발생할 모든 패턴에 대한 전역 검색)
  • gi(전역 검색, 대/소문자를 구분하지 않음)

    • 참고
    Regular Expression 개체는 문자가 혼합된 문자열을 검색할 때 사용되는 패턴을 저장합니다. Regular Expression 개체가 만들어진 후, 그 개체는 문자열 메서드로 전달되거나 문자열이 정규식 메서드 중 하나로 전달됩니다. 가장 최근에 검색한 정보는 RegExp 개체에 저장됩니다.

    이미 검색할 문자열을 알고 있으면 구문 1을 사용하십시오. 검색할 문자열이 사용자가 입력한 문자열처럼 자주 변경되거나 알 수 없을 경우에는 구문 2를 사용하십시오.

    pattern 인수는 사용하기 전에 내부 서식으로 컴파일됩니다. 구문 1의 경우 pattern은 스크립트가 로드되면 컴파일됩니다. 구문 2의 경우 pattern은 사용하기 직전에 컴파일되거나 compile 메서드가 호출되면 컴파일됩니다.


Regular Expression 개체

Regular Expression 개체
참고 		언어 참조

RegExp 개체
Regular Expression 구문
String 개체


Regular Expression 개체

Regular Expression 개체
메서드 		언어 참조

compile 메서드
exec 메서드
test 메서드


Regular Expression 개체

Regular Expression 개체
속성 		언어 참조

lastIndex 속성
source 속성


String 개체

String 개체 		언어 참조
버전 1

참고 메서드 속성

설명
텍스트 문자열을 조작하고 서식을 지정하거나 문자열 안에서 부분 문자열을 결정하고 위치를 지정할 수 있습니다.
구문
StringObj[.method]
"String Literal"[.method]
참고
String 개체는 문자열 리터럴을 사용하여 함축적으로 만들 수 있습니다. 이런 방법으로 만든 String 개체는(표준 문자열이라고도 함) new 연산자를 사용하여 만든 String 개체와는 다르게 취급합니다. 모든 문자열 리터럴은 공통의 전역 문자열 개체를 공유합니다. 따라서 문자열 리터럴에 속성을 추가하면 모든 표준 문자열 개체에 해당 속성을 사용할 수 있습니다.
var alpha, beta;
alpha = "문자열입니다.";
beta = "문자열입니다.";

alpha.test = 10;

위 예제에서는 test가 beta와 앞으로 나올 모든 문자열 리터럴에 대해 정의됩니다. 하지만 아래 예제에서는 추가한 속성이 다르게 취급됩니다.

var gamma, delta;
gamma = new String("문자열입니다.");
delta = new String("문자열입니다.");

gamma.test = 10;
이 경우 test는 delta에 대해 정의되지 않습니다. new String 개체로 선언한 각 String 개체는 해당 구성원을 가집니다. 이 경우에만 String 개체와 문자열 리터럴이 다르게 취급됩니다.


String 개체

String 개체
참고 		언어 참조

new 연산자


String 개체 메서드

String 개체
메서드 		언어 참조

String.prototype의 구성원
anchor 메서드
big 메서드
blink 메서드
bold 메서드
charAt 메서드
charCodeAt 메서드
concat 메서드
fixed 메서드
fontcolor 메서드
fontsize 메서드
fromCharCode 메서드
indexOf 메서드
italics 메서드
lastIndexOf 메서드
link 메서드
match 메서드
replace 메서드
search 메서드
slice 메서드
small 메서드
split 메서드
strike 메서드
sub 메서드
substr 메서드
substring 메서드
sup 메서드
toLowerCase 메서드
toUpperCase 메서드
toString 메서드
valueOf 메서드

toString Method
valueOf Method

String.prototype의 비구성원
String 개체에는 초기 설정의 구성 요소가 아닌 메서드는 없습니다.


String 개체 속성

String 개체
속성 		언어 참조

String.prototype의 구성원
constructor 속성
String.prototype의 비구성원
length 속성
prototype 속성


TextStream 개체

TextStream 개체 		Scripting 런타임 참조
버전 2

참고 메서드 속성

설명
파일에 순차적으로 쉽게 액세스합니다.
구문
TextStream.{property | method( )}

property 인수와 method 인수는 TextStream 개체와 연결된 모든 속성과 메서드입니다. 실제로 사용할 때는 TextStream은 FileSystemObject에서 반환된 TextStream 개체를 나타내는 변수 자리 표시자로 바뀝니다.

참고
아래 코드에서 a는 FileSystemObject에 있는 CreateTextFile 메서드로 반환된 TextStream 개체입니다.
var fso = new ActiveXObject("Scripting.FileSystemObject");
var a = fso.CreateTextFile("c:\\testfile.txt", true);
a.WriteLine("테스트입니다.");
a.Close();
WriteLine과 Close는 TextStream 개체에 사용되는 두 메서드입니다.


TextStream 개체

TextStream 개체
참고 		Scripting 런타임 참조

Dictionary 개체
FileSystemObject 개체


TextStream 개체

TextStream 개체
메서드 		Scripting 런타임 참조

Close 메서드
Read 메서드
ReadAll 메서드
ReadLine 메서드
Skip 메서드
SkipLine 메서드
Write 메서드
WriteBlankLines 메서드
WriteLine 메서드


TextStream 개체

TextStream 개체
속성 		Scripting 런타임 참조

AtEndOfLine 속성
AtEndOfStream 속성
Column 속성
Line 속성


VBArray 개체

VBArray 개체 		언어 참조
버전 3

참고 메서드 속성

설명
Visual Basic 안전 배열에 액세스할 수 있습니다.
구문
new VBArray(safeArray)

safeArray는 VBArray 값입니다.

참고
VBArrays는 읽기 전용이고 직접 만들 수 없습니다. safeArray 인수를 VBArray 구성자에 전달하기 전에 VBArray 값을 구해야 합니다. 그러려면 기존 ActiveX나 다른 개체에서 값을 찾아와야 합니다.

VBArrays는 여러 차원을 가질 수 있습니다. 각 차원에 대한 인덱스는 다를 수 있습니다. dimensions 메서드는 배열에서 차원을 나타내는 숫자를 찾아옵니다. lbound와 ubound 메서드는 각 차원에 사용된 인덱스 범위를 찾아옵니다.

아래 예제는 세 부분으로 구성됩니다. 첫째 부분은 Visual Basic 안전 배열을 만드는 VBScript 코드이고, 둘째 부분은 VB 안전 배열을 JScript 배열로 변환하는 JScript 코드입니다. 이 부분들 모두 HTML 페이지의 <HEAD> 영역에 입력합니다. 셋째 부분은 <BODY> 영역에 입력하여 다른 두 부분을 실행시키는 JScript 코드입니다.

<HEAD>
<SCRIPT LANGUAGE="VBScript">
<!--
Function CreateVBArray()
  Dim i, j, k
  Dim a(2, 2)
  k = 1
  For i = 0 To 2
    For j = 0 To 2
      a(j, i) = k
      document.writeln(k)
      k = k + 1
    Next
    document.writeln("<BR>")
  Next
  CreateVBArray = a
End Function
-->
</SCRIPT>
<SCRIPT LANGUAGE="JScript">
<!--
function VBArrayTest(vbarray)
{
  var a = new VBArray(vbarray);
  var b = a.toArray();
  var i;
  for (i = 0; i < 9; i++)
  {
    document.writeln(b[i]);
  }
}
-->
</SCRIPT>
</HEAD>
<BODY>
<SCRIPT LANGUAGE="JScript">
<!--
  VBArrayTest(CreateVBArray());
-->
</SCRIPT>
</BODY>


VBArray 개체

VBArray 개체
참고 		언어 참조

Array 개체


VBArray 개체

VBArray 개체
메서드 		언어 참조

dimensions 메서드
getItem 메서드
lbound 메서드
toArray 메서드
ubound 메서드


VBArray 개체

VBArray 개체
속성 		언어 참조

VBArray 개체에는 속성이 없습니다.


연산자 우선 순위

연산자 우선 순위 		언어 참조
버전 1

JScript에서 연산자는 특정 순서로 계산됩니다. 이 순서를 연산자 우선 순위라고 합니다. 아래 표는 우선 순위가 가장 높은 연산자부터 가장 낮은 연산자까지를 나타낸 목록입니다. 우선 순위가 같은 연산자는 식의 왼쪽에서 오른쪽의 순서로 계산됩니다.

연산자 | 설명
. [] () 필드 액세스, 배열 인덱스, 함수 호출
++ -- - ~ ! delete new typeof void | 단일 연산자, 반환 데이터 형식, 개체 만들기, 정의 되지 않은 값
* / % 곱셈, 나눗셈, 나머지 연산
+ - + 덧셈, 뺄셈, 문자열 연결
<< >> >>> 비트 이동
< <= > >= instanceof | 보다 작다, 작거나 같다, 보다 크다, 크거나 같다, 인스턴스 여부
== != === !== 같음, 같지 않음, 동치, 동치가 아님
& 비트 논리곱
^ 비트 배타적 논리합
| 비트 논리합
&& 논리곱
|| 논리합
?: 조건
= OP= | 지정, 복합 지정
, 다중 연산

괄호는 계산 순서를 바꾸기 위해 사용됩니다. 괄호 안에 있는 식을 먼저 완전하게 계산한 후 문의 나머지 부분에 그 값을 사용합니다.

우선 순위가 높은 연산자들은 우선 순위가 낮은 연산자들보다 먼저 계산됩니다. 예를 들어 다음과 같습니다.

z = 78 * (96 + 3 + 45)

이 식에는 =, *, (), +, +라는 다섯 개의 연산자가 있습니다. 이 연산자들은 연산자 우선 순위에 따라 (), *, +, +, =의 순서로 계산됩니다.

  1. 괄호 안에 있는 연산자가 먼저 계산됩니다. 괄호 안에 있는 두 개의 덧셈 연산자는 같은 우선 순위를 가지므로 먼저 96에 3을 더하고 그 값에 다시 45가 더해져서 값은 144가 됩니다.
  2. 그 다음은 곱셈으로 78과 144가 곱해져서 11232가 됩니다.
  3. 마지막으로 지정 연산이 수행되어 11232라는 값이 z에 지정됩니다.


덧셈 연산자(+)

+ 연산자 		언어 참조
버전 1

참고

설명
두 숫자를 더하거나 문자열을 연결합니다.
구문
result = expression1 + expression2

+ 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression1 | 임의의 식
expression2 | 임의의 식

참고
식의 기본 하위 형식에 따라 + 연산자의 동작은 아래와 같이 결정됩니다.

경우 | 동작
두 식이 모두 수식이거나 부울식인 경우 | 덧셈
두 식이 모두 문자식인 경우 | 문자열 연결
각각 수식과 문자식인 경우 | 문자열 연결

+ 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


덧셈 연산자(+)

+ 연산자
참고 		언어 참조

+= 연산자
연산자 동작
연산자 우선 순위
연산자 요약


+= 연산자

+= 연산자 		언어 참조
버전 1

참고

설명
변수를 지정한 양만큼 증가시킵니다.
구문
result += expression

+= 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression | 임의의 식

참고
이 연산자를 사용하면 아래 연산과 똑같은 결과가 나옵니다.
result = result + expression
식의 기본 하위 형식은 += 연산자의 동작을 결정합니다.

경우 | 동작
두 식이 모두 수식이거나 부울식인 경우 | 더합니다.
두 식이 모두 문자식인 경우 | 연결합니다.
각각 수식과 문자식인 경우 | 연결합니다.

+= 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


덧셈 지정 연산자(+=)

+= 연산자
참고 		언어 참조

+ 연산자
연산자 동작
연산자 우선 순위
연산자 요약


복합 지정 연산자

복합 지정 연산자 		언어 참조

+= 연산자
&= 연산자
|= 연산자
^= 연산자
/= 연산자
<<= 연산자
%= 연산자
*= 연산자
>>= 연산자
-= 연산자
>>>= 연산자


논리곱 연산자(&&)

&& 연산자 		언어 참조
버전 1

참고

설명
두 식에 논리곱을 수행합니다.
구문
result = expression1 && expression2

&& 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression1 | 임의의 식
expression2 | 임의의 식

참고
두 식이 모두 true인 경우에만 result가 true이며, 두 식 중 어느 하나가 false인 경우 result는 false가 됩니다.

&& 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.

JScript에서는 아래와 같은 규칙을 사용하여 부울값이 아닌 값을 부울값으로 변환합니다.

  • 모든 개체는 true인 것으로 간주합니다.
  • 문자열은 비어 있는 경우에만 false로 간주합니다.
  • null과 undefined는 false로 간주합니다.
  • 숫자는 0인 경우에만 false로 간주합니다.


논리곱 연산자(&&)

&& 연산자
참고 		언어 참조

연산자 동작
연산자 우선 순위
연산자 요약


= 연산자

= 연산자 		언어 참조
버전 1

참고

설명
변수에 값을 지정합니다.
구문
result = expression

= 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression | 임의의 수식

참고
= 연산자는 다른 연산자처럼 작용하므로 = 연산자를 사용하는 식은 변수에 값을 지정하고 그 값을 가집니다. 이것은 다음과 같이 지정 연산자들을 연결할 수 있다는 것을 의미합니다.
j = k = l = 0;
j, k, l은 예제문을 실행하면 0이 됩니다.


지정 연산자(=)

= 연산자
참고 		언어 참고

복합 지정 연산자
연산자 동작
연산자 우선 순위
연산자 요약


&= 연산자

&= 연산자 		언어 참조
버전 1

참고

설명
식에 비트 논리곱 연산을 수행합니다.
구문
result &= expression

&= 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression | 임의의 식

참고
이 연산자는 아래 연산과 똑같은 결과가 나옵니다.
result = result & expression
&= 연산자는 result와 expression 값에 대한 이진 표현에 주의하여 비트 논리곱 연산을 수행합니다. 이 연산 결과는 다음과 같습니다.
0101    (result)
1100    (expression)
----
0100    (output)
두 식 모두 같은 자리 숫자가 1이면 그 자리 숫자는 1이 됩니다.

+= 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


비트 논리곱 지정 연산자(&=)

&= 연산자
참고 		언어 참조

& 연산자
연산자 동작
연산자 우선 순위
연산자 요약


|= 연산자

|= 연산자 		언어 참조
버전 1

참고

설명
식에 비트 논리합 연산을 수행합니다.
구문
result |= expression

|= 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression | 임의의 식

참고
이 연산자를 사용하면 아래 연산과 똑같은 결과가 나옵니다.
result = result | expression
|= 연산자는 result와 expression의 값에 대한 이진 표현에 주의하여 비트 논리합 연산을 수행합니다. 이 연산 결과는 다음과 같습니다.
0101    (result)
1100    (expression)
----
1101    (output)
두 식에서 같은 자리 숫자 중 하나가 1이면 그 자리 숫자는 1이 됩니다. 그렇지 않으면 그 자리 숫자는 0이 됩니다.

|= 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


비트 OR 지정 연산자(|=)

|= 연산자
참고 		언어 참조

| 연산자
연산자 동작
연산자 우선 순위
연산자 요약


비트 논리곱 연산자(&)

& 연산자 		언어 참조
버전 1

참고

설명
두 식에 비트 논리곱을 수행합니다.
구문
result = expression1 & expression2

& 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression1 | 임의의 식
expression2 | 임의의 식

참고
& 연산자는 두 식의 값에 대한 이진 표현을 찾아 비트 논리곱 연산을 수행합니다. 이 연산의 결과는 다음과 같습니다.
0101    (expression1)
1100    (expression2)
----
0100    (result)
같은 자리 숫자가 두 식 모두 1이면 그 자리 숫자는 1이 됩니다. 그렇지 않으면 그 자리 숫자는 0이 됩니다.

& 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


비트 논리곱 연산자(&)

& 연산자
참고 		언어 참조

&= 연산자
연산자 동작
연산자 우선 순위
연산자 요약


비트 부정 연산자(~)

~ 연산자 		언어 참조
버전 1

참고

설명
식에 비트 부정 연산을 수행합니다.
구문
result = ~ expression

~ 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression | 임의의 식

참고
~ 연산자와 같은 모든 단일 연산자는 다음과 같이 식을 연산합니다.
  • undefined 식 또는 null 식에 적용되면 런타임 오류가 일어납니다.
  • 개체는 문자열로 변환됩니다.
  • 가능하면 문자열은 숫자로 변환됩니다. 그렇지 않으면 런타임 오류가 일어납니다.
  • 부울값은 숫자로 처리됩니다(false이면 0, true이면 1).
이 연산자는 위의 결과로 나온 숫자에 적용됩니다.

~ 연산자는 식의 값에 대한 이진 표현을 찾아 비트 부정 연산을 수행합니다. 이 연산의 결과는 다음과 같습니다.

0101    (expression)
----
1010    (result)
식에서 1인 자리 숫자는 모두 0이 됩니다. 식에서 0인 자리 슛자는 모두 1이 됩니다.


비트 부정 연산자(~)

~ 연산자
참고 		언어 참조

! 연산자
연산자 동작
연산자 우선 순위
연산자 요약


비트 논리합 연산자(|)

| 연산자 		언어 참조
버전 1

참고

설명
두 식에 비트 논리합을 수행합니다.
구문
result = expression1 | expression2

| 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression1 | 임의의 식
expression2 | 임의의 식

참고
| 연산자는 두 식의 값에 대한 이진 표현을 찾아 비트 논리합 연산을 수행합니다. 이 연산의 결과는 다음과 같습니다.
0101    (expression1)
1100    (expression2)
----
1101    (result)
두 식중 같은 자리 숫자 하나가 1이면 그 자리 숫자는 1이 됩니다. 그렇지 않으면 그 자리 숫자는 0이 됩니다.

| 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


비트 논리합 연산자(|)

| 연산자
참고 		언어 참조

|= 연산자
연산자 동작
연산자 우선 순위
연산자 요약


쉼표 연산자(,)

, 연산자 		언어 참조
버전 1

참고

설명
두 식을 순차적으로 실행합니다.
구문
expression1, expression2

, 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
expression1 | 임의의 식
expression2 | 임의의 식

참고
, 연산자는 양 쪽에 있는 식을 왼쪽에서 오른쪽 순서로 실행하고 오른쪽에 있는 식의 값을 가집니다. , 연산자는 for 루프에 대한 증분식에 가장 일반적으로 사용됩니다. 예를 들어 다음과 같습니다.
for (i = 0; i < 10; i++, j++)
{
  k = i + j;
}
for 문은 매번 루프를 통과하는 끝 부분에서 한 개의 식을 실행할 수 있습니다. , 연산자는 한 개의 식으로 표현하는 데 한계가 있기 때문에 여러 개의 식을 한 개의 식처럼 사용할 수 있습니다.


쉼표 연산자(,)

, 연산자
참고 		언어 참조

for 문
연산자 동작
연산자 우선 순위
연산자 요약


?: 연산자(삼항)

?: 연산자 		언어 참조
버전 1

참고

설명
조건에 따라 두 식 중 하나를 실행합니다.
구문
test ? expression1 : expression2

?: 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
test | 임의의 부울식
expression1 | 테스트가 true이면 실행됩니다. 복합문일 수도 있습니다.
expression2 | 테스트가 false이면 실행됩니다. 복합문일 수도 있습니다.

참고
?: 연산자는 if...else 문의 단축문입니다. 일반적으로 if...else 문은 더 크고 복잡한 식에서 사용됩니다. 예를 들어 다음과 같습니다.
var now = new Date();
var greeting = "Good" + ((now.getHours() > 17) ? " evening." : " day.");
오후 6시 이후라면 예제에서는 "좋은 저녁입니다."를 포함하는 문자열을 만듭니다. if...else 문을 사용한 동등한 코드는 다음과 같습니다.
var now = new Date();
var greeting = "좋은";
if (now.getHours() > 17)
   greeting += " 저녁입니다.";
else
   greeting += " 날입니다.";


?: 연산자(삼항)

?: 연산자
참고 		언어 참조

if...else 문
연산자 동작
연산자 우선 순위
연산자 요약


delete 연산자

delete 연산자 		언어 참조
버전 3

참고

설명
개체에서 속성을 삭제하거나 배열에서 요소를 제거합니다.
구문
delete expression

여기서 expression은 반드시 그렇지는 않지만 주로 그 결과가 속성 이름이나 배열 요소인 유효한 JScript 식입니다.

참고
expression의 결과가 개체이고, expression에 지정된 속성이 있으며, 개체가 그 속성을 삭제할 수 없으면 false가 반환됩니다.

다른 모든 경우에는 true가 반환됩니다.


delete 연산자

delete 연산자
참고 		언어 참조

연산자 동작
연산자 우선 순위
연산자 요약


/= 연산자

/= 연산자 		언어 참조
버전 1

참고

설명
식으로 변수를 나눕니다.
구문
result /= expression

/= 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 숫자 변수
expression | 임의의 수식

참고
/= 연산자를 사용하면 아래 연산과 똑같은 결과가 나옵니다.
result = result / expression
/= 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


나눗셈 지정 연산자(/=)

/= 연산자
참고 		언어 참조

/ 연산자
연산자 동작
연산자 우선 순위
연산자 요약


나눗셈 연산자(/)

/ 연산자 		언어 참조
버전 1

참고

설명
두 수를 나눈 결과를 반환합니다.
구문
result = number1 / number2

/ 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 숫자 변수
number1 | 임의의 수식
number2 | 임의의 수식

참고
/ 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


나눗셈 연산자(/)

/ 연산자
참고 		언어 참조

/= 연산자
연산자 동작
연산자 우선 순위
연산자 요약


증가(++) 및 감소(--) 연산자

++ 및 -- 연산자 		언어 참조
버전 1

참고

설명
변수를 1씩 증가시키거나 감소시키는 데 사용합니다.
구문 1
result = ++variable
result = --variable
result = variable++
result = variable--
구문 2
++variable
--variable
variable++
variable--

++ 및 -- 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
variable | 임의의 변수

참고
증가와 감소 연산자는 단축문으로 사용되어 변수에 저장된 값을 수정합니다. 이들 연산자 중 하나를 포함하는 식의 값은 연산자가 변수 앞에 있는지, 뒤에 있는지에 따라 달라집니다.
var j, k;
k = 2;
j = ++k;
식이 평가되기 전에 증가되었기 때문에 j에 3이 지정됩니다.

다음 예제와 비교해 보십시오.

var j, k;
k = 2;
j = k++;
여기서는 식이 평가된 후 증가되었기 때문에 j에 2가 지정됩니다.


증가(++) 및 감소(--) 연산자

++ 및 -- 연산자
참고 		언어 참조

연산자 동작
연산자 우선 순위
연산자 요약


instanceof 연산자

instanceof 연산자 		언어 참조
버전 5

참고

설명
개체가 특정 클래스의 인스턴스인지 여부를 나타내는 부울값을 반환합니다.
구문
result = object instanceof class

instanceof 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
object | 임의의 개체 식
class | 정의된 개체 클래스

참고
instanceof 연산자는 만약 object가 class의 인스턴스이면 true를 반환합니다. object가 지정된 클래스의 인스턴스가 아니거나 object가 null이면 false를 반환합니다.

아래 예제는 instanceof 연산자의 사용법을 보여줍니다.

function objTest(obj)
{
  var i, t, s = "";            // 변수를 만듭니다.
  t = new Array();             // 배열을 만듭니다.
  t["Date"] = Date;            // 배열을 채웁니다.
  t["Object"] = Object;
  t["Array"] = Array;
    for (i in t)
    {
      if (obj instanceof t[i]) // obj 클래스를 검사합니다.
      {
        s += "obj is an instance of " + i + "\n";
      }
      else
      {
        s += "obj is not an instance of " + i + "\n";
      }
  }
  return(s);                   // 문자열을 반환합니다.
}

var obj = new Date();
response.write(objTest(obj));


instanceof 연산자

instanceof 연산자
참고 		언어 참조

연산자 우선 순위
연산자 요약


연산자 요약

연산자 요약 		언어 참조
버전 1

산술 연산자
감소(--)
곱셈(*)
나눗셈(/)
나머지(%)
단항 부정(-)
덧셈(+)
뺄셈(-)
증가(++)
논리 연산자
같음(==)
같지 않음(!=)
논리곱(&&)
논리합(||)
논리 부정(!)
동치(===)
동치가 아님(!==) 보다 작다(<)
보다 크다(>)
쉼표(,)
작거나 같다(<=)
크거나 같다(>=)
(삼항) 조건부(?:)
비트 연산자
부호 없이 오른쪽으로 이동(>>>) 비트 논리곱(&)
비트 부정(~)
비트 논리합(|)
비트 배타적 논리합(^)
비트 오른쪽 이동(>>)
비트 왼쪽 이동(<<)
지정 연산자
복합 지정 연산자
지정(=)
기타
delete
instanceof
new
typeof
void


<<= 연산자

<<= 연산자 		언어 참조
버전 1

참고

설명
식을 비트 단위로 왼쪽으로 옮깁니다.
구문
result <<= expression

<<= 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression | 임의의 식

참고
<<= 연산자는 아래 연산과 똑같은 결과가 나옵니다.
result = result << expression
<<= 연산자는 expression에 지정한 비트 수만큼 result를 왼쪽으로 옮깁니다. 예를 들어 다음과 같습니다.
var temp
temp = 14
temp <<= 2
14(이진수 00001110)를 왼쪽으로 두 비트 옮기면 56(이진수 00111000)이 되므로 temp 변수는 56이 됩니다. 왼쪽에 생긴 공간에는 0을 채웁니다.

<<= 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


왼쪽 이동 지정 연산자(<<=)

<<= 연산자
참고 		언어 참조

<< 연산자
>> 연산자
>>> 연산자
연산자 동작
연산자 우선 순위
연산자 요약


<< 연산자

<< 연산자 		언어 참조
버전 1

참고

설명
식을 비트 단위로 왼쪽으로 옮깁니다.
구문
result = expression1 << expression2

<< 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression1 | 임의의 식
expression2 | 임의의 식

참고
<< 연산자는 expression2에 지정한 비트 수만큼 expression1을 왼쪽으로 옮깁니다. 예를 들어 다음과 같습니다.
var temp
temp = 14 << 2
14(이진수 00001110)를 왼쪽으로 두 비트 옮기면 56(이진수 00111000)이 되므로 temp 변수는 56이 됩니다.

<< 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


<< 연산자

<< 연산자
참고 		언어 참고

<<= 연산자
>> 연산자
>>> 연산자
연산자 동작
연산자 우선 순위
연산자 요약


나머지 연산자(%)

% 연산자 		언어 참조
버전 1

참고

설명
두 수를 나눈 후 나머지를 반환합니다.
구문
result = number1 % number2

% 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
number1 | 임의의 수식
number2 | 임의의 수식

참고
나머지 연산자는 각각 부동 소수점 숫자를 정수로 반올림한 다음 number1을 number2로 나누어 그 나머지만 result로 반환합니다. 예를 들어, 아래 식에서 A(result 값)는 5입니다.
A = 19 % 6.7
% 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


나머지 연산자(%)

% 연산자
참고 		언어 참조

%= 연산자
연산자 동작
연산자 우선 순위
연산자 요약


%= 연산자

%= 연산자 		언어 참조
버전 1

참고

설명
두 수를 나눈 후 나머지만 반환합니다.
구문
result %= expression

%= 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression | 임의의 수식

참고
%= 연산자를 사용하면 아래 연산과 똑같은 결과가 나옵니다.
result = result % expression
%= 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


나머지 지정 연산자(%=)

%= 연산자
참고 		언어 참조

% 연산자
연산자 동작
연산자 우선 순위
연산자 요약


*= 연산자

*= 연산자 		언어 참조
버전 1

참고

설명
임의의 수를 다른 수에 곱합니다.
구문
result *= expression

*= 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression | 임의의 식

참고
*= 연산자를 사용하면 아래 연산과 똑같은 결과가 나옵니다.
result = result * expression
*= 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


곱셈 지정 연산자(*=)

*= 연산자
참고 		언어 참조

* 연산자
연산자 동작
연산자 우선 순위
연산자 요약


곱셈 연산자(*)

* 연산자 		언어 참조
버전 1

참고

설명
두 수를 곱합니다.
구문
result = number1*number2

* 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
number1 | 임의의 식
number2 | 임의의 식

참고
* 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


곱셈 연산자(*)

* 연산자
참고 		언어 참조

*= 연산자
연산자 동작
연산자 우선 순위
연산자 요약


new 연산자

new 연산자
 언어 참조
버전 1

참고

설명
새 개체를 만듭니다.
구문

new constructor[(arguments)]

constructor 인수는 개체의 구성자를 호출합니다. 구성자가 인수를 가지지 않으면 괄호를 생략할 수 있습니다.

참고
new 연산자는 다음 작업을 수행합니다.
  1. 구성원이 없는 개체를 만듭니다.
  2. this 포인터로 새롭게 생성된 개체에 포인터를 전달하면서 그 개체에 대한 구성자를 호출합니다.
그런 다음 구성자는 구성자로 전달된 인수에 따라 개체를 초기화합니다.

아래 예제는 new 연산자의 사용법을 보여줍니다.

my_object = new Object;
my_array = new Array();
my_date = new Date("1996년 1월 5일");


new 연산자

new 연산자
참고 		언어 참조

function 문


논리 부정 연산자(!)

! 연산자 		언어 참조
버전 1

참고

설명
한 식에 논리 부정을 수행합니다.
구문
result = !expression

! 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression | 임의의 식

참고
아래 표는 result를 확인하는 방법을 보여줍니다.

expression 값 | result 값
true | false
false | true

! 연산자와 같은 모든 단일 연산자는 다음과 같이 식을 평가합니다.

  • undefined 식 또는 null 식에 적용하면 런타임 오류가 일어납니다.
  • 개체를 문자열로 변환합니다.
  • 문자열을 가능하면 숫자로 변환합니다. 변환할 수 없으면 런타임 오류가 일어납니다.
  • 부울값은 숫자로 취급합니다(false이면 0, true이면 1).
결과로 나오는 숫자에 연산자를 적용합니다.

! 연산자의 경우 expression이 0이 아니면 result는 0입니다. expression이 0이면 result는 1입니다.


논리 부정 연산자(!)

! 연산자
참고 		언어 참조

~ 연산자
연산자 동작
연산자 우선 순위
연산자 요약


논리합 연산자(||)

|| 연산자 		언어 참조
버전 1

참고

설명
두 식에 논리합을 수행합니다.
구문
result = expression1 || expression2

|| 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression1 | 임의의 식
expression2 | 임의의 식

참고
두 식 중 하나 이상이 true이면 result는 true입니다. 아래 표는 result 확인 방법을 보여줍니다.

expression1 값 | expression2 값 | result 값
true | true | true
true | false | true
false | true | true
false | false | false

&& 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.

JScript에서는 아래와 같은 규칙을 사용하여 부울값이 아닌 값을 부울값으로 변환합니다.

  • 모든 개체는 true인 것으로 간주합니다.
  • 문자열은 비어 있는 경우에만 false로 간주합니다.
  • null과 undefined는 false로 간주합니다.
  • 숫자는 0인 경우에만 false로 간주합니다.


논리합 연산자(||)

|| 연산자
참고 		언어 참조

연산자 동작
연산자 우선 순위
연산자 요약


>>= 연산자

>>= 연산자 		언어 참조
버전 1

참고

설명
부호를 바꾸지 않고 식을 비트 단위로 오른쪽으로 옮깁니다.
구문
result >>= expression

>>= 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression | 임의의 식

참고
>>= 연산자는 아래 연산과 똑같은 결과가 나옵니다.
result = result >> expression
>>= 연산자는 expression에 지정된 비트 수만큼 오른쪽으로 result를 옮깁니다. result의 부호 비트는 왼쪽에서부터 숫자를 채우는 데 사용됩니다. 오른쪽으로 밀려난 숫자는 버립니다. 예를 들어 아래 코드에서는 14(이진수 11110010)를 오른쪽으로 두 비트 옮기면 -4(이진수 11111100)가 되므로 temp 값은 -4가 됩니다.
var temp
temp = -14
temp >>= 2
>>= 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


오른쪽 이동 지정 연산자(>>=)

>>= 연산자
참고 		언어 참조

<< 연산자
>> 연산자
>>> 연산자
연산자 동작
연산자 우선 순위
연산자 요약


비트 오른쪽 이동 연산자(>>)

>> 연산자 		언어 참조
버전 1

참고

설명
부호를 바꾸지 않고 식을 비트 단위로 오른쪽으로 옮깁니다.
구문
result = expression1 >> expression2

>> 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression1 | 임의의 식
expression2 | 임의의 식

참고
>> 연산자는 expression2에 지정한 비트 수만큼 expression1을 오른쪽으로 옮깁니다. expression1의 부호 비트는 왼쪽에서 숫자를 채웁니다. 오른쪽으로 밀려난 숫자는 버립니다. 예를 들어, 아래 코드를 연산하면 14(이진수 11110010)를 오른쪽으로 두 비트 옮겨 -4(이진수 11111100)가 되므로 temp 값은 -4가 됩니다.
var temp
temp = -14 >> 2
>> 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


>> 연산자

>> 연산자
참고 		언어 참조

<< 연산자
>>= 연산자
>>> 연산자
연산자 동작
연산자 우선 순위
연산자 요약


-= 연산자

-= 연산자 		언어 참조
버전 1

참고

설명
변수에서 식의 값을 뺍니다.
구문
result -= expression

-= 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 숫자 변수
expression | 임의의 수식

참고
-= 연산자를 사용하면 다음 연산과 똑같은 결과가 나옵니다.
result = result - expression

- 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


뺄셈 지정 연산자(-=)

-= 연산자
참고 		언어 참조

- 연산자
연산자 동작
연산자 우선 순위
연산자 요약


뺄셈 연산자(-)

- 연산자 		언어 참조
버전 1

참고

설명
두 수를 빼거나 수식의 음수 값을 나타내는 데 사용합니다.

구문 1
result = number1 - number2
구문 2
-number

- 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 숫자 변수
number | 임의의 수식
number1 | 임의의 수식
number2 | 임의의 수식

참고
구문 1에서는 - 연산자가 두 수의 차이를 구하는 산술 뺄셈 연산자로 사용되었습니다. 구문 2에서는 - 연산자가 식의 음수값을 나타내는 단항 부정 연산자로 사용되었습니다.

구문 1에 의해 생성된 런타임 오류에 관한 자세한 정보는 연산자 동작 표를 참조하십시오.

구문 2는 다른 단항 연산자와 마찬가지로 다음과 같이 평가됩니다.

  • undefined 식이나 null 식에 적용하면 런타임 오류가 일어납니다.
  • 개체를 문자열로 변환합니다.
  • 문자열을 가능하면 숫자로 변환합니다. 그렇지 않으면 런타임 오류가 일어납니다.
  • 부울값은 숫자로 취급합니다(false이면 0, true이면 1).
결과로 나오는 숫자에 연산자를 적용합니다. 구문 2에서 결과 값이 0이 아니면 result는 결과 값의 부호를 반대로 바꾼 것과 같습니다. 결과 값이 0이면 result도 0입니다.


뺄셈 연산자(-)

- 연산자
참고 		언어 참조

-= 연산자
연산자 동작
연산자 우선 순위
연산자 요약


typeof 연산자

typeof 연산자 		언어 참조
버전 1

참고

설명
식의 데이터 형식을 나타내는 문자열을 반환합니다.
구문
typeof [ ( ] expression [ ) ] ;

expression 인수는 형식 정보를 찾는 식입니다.

참고
typeof 연산자는 형식 정보를 문자열로 반환합니다. typeof는 "Number", "String", "Boolean", "Object", "Function", "undefined"라는 6가지 형식을 반환할 수 있습니다.

선택적인 요소로 typeof 구문에 괄호를 사용할 수도 있습니다.


typeof 연산자

typeof 연산자
참고 		언어 참조

연산자 동작
연산자 우선 순위
연산자 요약


>>>= 연산자

>>>= 연산자 		언어 참조
버전 1

참고

설명
부호 없이 변수를 비트 단위로 오른쪽으로 옮깁니다.
구문
result >>>= expression

>>>= 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression | 임의의 식

참고
>>>= 연산자를 사용하면 아래 연산과 똑같은 결과가 나옵니다.
result = result >>> expression
>>>= 연산자는 expression에서 지정한 비트 수만큼 result를 오른쪽으로 옮깁니다. 왼쪽에 생긴 공간에는 0을 채웁니다. 오른쪽으로 밀려난 숫자는 버립니다. 예를 들어 다음과 같습니다.
var temp
temp = -14
temp >>>= 2
-14(이진수 11111111 11111111 11111111 11110010)를 오른쪽으로 두 비트 옮기면 1073741820(이진수 00111111 11111111 11111111 11111100)이 되므로 temp 변수 값은 1073741820이 됩니다.

>>>= 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


부호 없는 오른쪽 이동 지정 연산자(>>>=)

>>>= 연산자
참고 		언어 참조

>>> 연산자
<< 연산자
>> 연산자
연산자 동작
연산자 우선 순위
연산자 요약


>>> 연산자

>>> 연산자 		언어 참조
버전 1

참고

설명
부호 없이 식을 비트 단위로 오른쪽으로 옮깁니다.
구문
result = expression1 >>> expression2

>>> 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 변수
expression1 | 식
expression2 | 식

참고
>>> 연산자는 expression2에 지정한 비트 수만큼 expression1을 오른쪽으로 옮깁니다. 왼쪽에 생긴 공간에는 0을 채웁니다. 오른쪽으로 밀려난 숫자는 버립니다. 예를 들어 다음과 같습니다.
var temp
temp = -14 >>> 2
-14(이진수 11111111 11111111 11111111 11110010)를 오른쪽으로 두 비트 옮기면 1073741820(이진수 00111111 11111111 11111111 11111100)이 되므로 temp 변수 값은 1073741820이 됩니다.

>>> 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


>>> 연산자

>>> 연산자
참고 		언어 참조

>>>= 연산자
<< 연산자
>> 연산자
연산자 동작
연산자 우선 순위
연산자 요약


void 연산자

void 연산자 		언어 참조
버전 2

참고

설명
식이 값을 반환하지 않도록 합니다.
구문
void expression

expression 인수는 유효한 JScript 식입니다.

참고
void 연산자는 식을 평가한 후 undefined를 반환합니다. 이 연산자는 식을 평가한 후 결과가 나머지 스크립트에서 보이지 않도록 할 경우에 매우 유용합니다.


void 연산자

void 연산자
참고 		언어 참조

연산자 동작
연산자 우선 순위
연산자 요약


비트 배타적 논리합 연산자(^)

^ 연산자 		언어 참조
버전 1

참고

설명
두 식에 비트 배타적 논리합을 수행합니다.
구문
result = expression1 ^ expression2

^ 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression1 | 임의의 식
expression2 | 임의의 식

참고
^ 연산자는 두 식의 이진 표현을 찾아 비트 배타적 논리합을 수행합니다. 이 연산의 결과는 다음과 같습니다.
0101    (expression1)
1100    (expression2)
----
1001    (result)
같은 자리 숫자 중 하나만 1이면 그 자리 숫자는 1이 됩니다. 그렇지 않으면 그 자리 숫자는 0이 됩니다.

^ 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


비트 배타적 논리합 연산자(^)

^ 연산자
참고 		언어 참조

^= 연산자
연산자 동작
연산자 우선 순위
연산자 요약


^= 연산자

^= 연산자 		언어 참조
버전 1

참고

설명
식에 비트 배타적 논리합 연산을 수행합니다.
구문
result ^= expression

^= 연산자 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
result | 임의의 변수
expression | 임의의 식

참고
^= 연산자를 사용하면 아래 연산과 똑같은 결과가 나옵니다.
result = result ^ expression
^= 연산자는 두 식의 이진 표현에 주의하여 비트 배타적 논리합 연산을 수행합니다. 이 연산 결과는 다음과 같습니다.
0101    (result)
1100    (expression)
----
1001    (result)
두 식에서 같은 자리 숫자 중 하나만 1이면 그 자리 슛자는 1입니다. 그렇지 않으면 그 자리 숫자는 0입니다.

^= 연산자에 의해 생성된 런타임 오류에 관한 자세한 내용은 연산자 동작 표를 참조하십시오.


비트 배타적 논리합 지정 연산자(^=)

^= 연산자
참고 		언어 참조

^ 연산자
연산자 동작
연산자 우선 순위
연산자 요약


description 속성

description 속성 		언어 참조
버전 5

참고 적용 대상

설명
특정 오류와 관련해 설명하는 문자열을 반환하거나 설정합니다.
구문
object.description [= stringexpression]

description 속성 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | Error 개체의 인스턴스입니다.
stringexpression | 오류 설명을 포함한 문자식입니다.

참고
description 속성은 특정 오류와 관련된 오류 메시지 문자열을 포함합니다. 이 속성에 들어있는 값을 사용하여 처리할 수 없거나 처리하지 않을 오류를 사용자에게 경고합니다.

아래 예제는 description 속성의 사용법을 보여줍니다.

try {
  x = y		            // 오류가 발생합니다.
}
catch(var e) {    		     // 지역 변수 e를 만듭니다.
  document.write(e)                                // "[개체 오류]"를 인쇄합니다.
  document.write((e.number & 0xFFFF))// 5009를 인쇄합니다.
  document.write(e.description)      // "'y'가 정의되지 않았습니다"를 인쇄합니다.
}


description 속성

description 속성
적용 대상 		언어 참조

Error 개체


description 속성

description 속성
참고 		언어 참조

number 속성


number 속성

number 속성 		언어 참조
버전 5

참고 적용 대상

설명
특정 오류와 관련된 숫자 값을 반환하거나 설정합니다. Error 개체의 기본 속성은 number입니다.
구문
object.number [= errornumber]

number 속성 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | Error 개체의 인스턴스입니다.
errornumber | 오류를 나타내는 정수입니다.

참고
오류 번호는 32비트 값입니다. 상위 16비트 단어는 장치 코드이며, 하위 16비트 단어가 실제 오류 코드입니다.

아래 예제는 number 속성의 사용법을 보여줍니다.

try {
  x = y        		              // 오류가 발생합니다.
}
catch(var e) {				// 지역 변수 e를 만듭니다.
  document.write(e)                    // "[개체 오류]"를 인쇄합니다.
  document.write(e.number>>16 & 0x1FFF)// 장치 코드인 10을 인쇄합니다.
  document.write(e.number & 0xFFFF)    // 오류 코드인 5009를 인쇄합니다.
  document.write(e.description)        // "'y'가 정의되지 않았습니다."를 인쇄합니다.
}


number 속성

number 속성
적용 대상 		언어 참조

Error 개체


number 속성

number 속성
참고 		언어 참조

description 속성


index 속성

index 속성 		언어 참조
버전 3

참고 적용 대상

설명
검색한 문자열에서 처음으로 일치하는 부분이 시작하는 문자 위치를 반환합니다.
구문
RegExp.index
참고
index 속성은 0에서 시작합니다. 이 값은 일치하는 부분을 찾을 때마다 수정됩니다.


index 속성

index 속성
적용 대상 		언어 참조

RegExp 개체


index 속성

index 속성
참고 		언어 참조

RegExp 개체 속성
정규식 구문


input 속성

input 속성 		언어 참조
버전 3

참고 적용 대상

설명
검색하는 데 사용한 문자열을 반환합니다. 읽기 전용입니다.
구문
RegExp.input
참고
input 속성 값은 검색한 문자열이 바뀔 때마다 수정됩니다.

아래 예제는 input 속성의 사용법을 보여줍니다.

function inputDemo()
{
  var s;
  var re = new RegExp("d(b+)(d)","ig");
  var str = "cdbBdbsbdbdz";
  var arr = re.exec(str);
  s = "검색에 사용한 문자열은 " + RegExp.input;
  return(s) + "입니다.";
}


input 속성

input 속성
적용 대상 		언어 참조

RegExp 개체


input 속성

input 속성
참고 		언어 참조

RegExp 개체 속성
정규식 구문


lastIndex 속성

lastIndex 속성 		언어 참조
버전 3

참고 적용 대상

설명
검색한 문자열에서 마지막으로 일치하는 부분이 시작하는 문자 위치를 반환합니다.
구문
RegExp.lastIndex
참고
lastIndex 속성은 0에서 시작합니다. 즉, 첫째 문자의 인덱스는 0입니다. 이 값은 일치하는 부분을 찾을 때마다 수정됩니다.

lastIndex 속성은 RegExp 개체의 exec와 test 메서드, 그리고 String 개체의 match, replace, split 메서드에 의해 수정됩니다.

lastIndex 값에는 다음과 같은 규칙이 적용됩니다.

  • 일치하는 부분이 없으면 lastIndex 값이 -1로 설정됩니다.
  • lastIndex가 문자열 길이보다 크고 test와 exec가 수행되지 않으면 lastIndex 값이 -1로 설정됩니다.
  • lastIndex가 문자열 길이와 같은 경우, 패턴이 빈 문자열과 일치하면 정규식이 일치합니다. 그렇지 않으면 일치하는 부분이 없고 lastIndex가 -1로 다시 설정됩니다.
  • 그 외의 경우에는 lastIndex 값이 가장 최근에 일치한 부분의 바로 다음 위치로 설정됩니다.


lastIndex 속성

lastIndex속성
적용 대상 		언어 참조

RegExp 속성


lastIndex 속성

lastIndex 속성
참고 		언어 참조

RegExp 개체 속성
정규식 구문


$1...$9 속성

$1...$9 속성 		언어 참조
버전 3

참고 적용 대상

설명
패턴 일치 과정에서 찾아 저장된 최근 9개 부분을 반환합니다. 읽기 전용입니다.
구문
RegExp.$n

n 인수는 1부터 9까지의 숫자입니다.

참고
$1...$9 속성 값은 괄호 안에서 일치하는 내용을 찾을 때마다 수정됩니다. 정규식 패턴에 지정할 수 있는 괄호 안의 부분 문자열 수에는 제한이 없지만 저장되는 것은 최근 9개 뿐입니다.

아래 예제는 $1...$9 속성의 사용법을 보여줍니다.

function matchDemo()
{
  var s;
  var re = new RegExp("d(b+)(d)","ig");
  var str = "cdbBdbsbdbdz";
  var arr = re.exec(str);
  s = "$1 내용: " + RegExp.$1 + "<BR>";
  s += "$2 내용: " + RegExp.$2 + "<BR>";
  s += "$3 내용: " + RegExp.$3;
  return(s);
}


$1..$9 속성

$1..$9 속성
적용 대상 		언어 참조

RegExp 개체


$1...$9 속성

$1...$9 속성
참고 		언어 참조

RegExp 개체 속성
정규식 구문


compile 메서드

compile 메서드 		언어 참조
버전 3

참고 적용 대상

설명
정규식을 내부 형식으로 컴파일합니다.
구문
rgexp.compile(pattern)

compile 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
rgexp | 필수적인 요소. Regular Expression 개체입니다. 변수 이름이나 리터럴입니다.
pattern | 필수적인 요소. 컴파일할 정규식 패턴을 포함한 문자식입니다.

참고
compile 메서드는 보다 빠르게 실행하기 위해 pattern을 내부 형식으로 변환합니다. 이렇게 하면 루프의 정규식을 더 효율적으로 사용할 수 있습니다.

아래 예제는 compile 메서드의 사용법을 보여줍니다.

function CompileDemo()
{
  var s = "AaBbCcDdEeFfGgHhIiJjKkLlMmNnOoPp"
                  // 대문자에 대해서만 정규식을 만듭니다.
  var r = new RegExp("[A-Z]", "g");
  var a = s.match(r)	// 일치하는 부분을 찾습니다.
  document.write(a);
                  // 소문자에 대해서만 정규식을 컴파일합니다.
  r.compile("[a-z]", "g");
  var a = s.match(r)	// 일치하는 부분을 찾습니다.
  document.write(a);
}


compile 메서드

compile 메서드
적용 대상 		언어 참조

Regular Expression 개체


compile 메서드

compile 메서드
참고 		언어 참조

Regular Expression 개체 메서드
Regular Expression 개체 속성
정규식 구문


exec 메서드

exec 메서드 		언어 참조
버전 3

참고 적용 대상

설명
지정한 문자열에서 일치하는 부분을 검색합니다.
구문
rgexp.exec(str)

exec 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
rgexp | 필수적인 요소. Regular Expression 개체입니다. 변수 이름이나 리터럴입니다.
str | 필수적인 요소. 검색할 문자열입니다.

참고
exec 메서드를 이용한 검색 결과는 배열에 놓입니다.

exec 메서드가 일치하는 부분을 찾지 못하면 null을 반환합니다. 일치하는 부분을 하나 이상 찾으면 exec 메서드는 배열을 반환하고, 검색 결과를 반영하도록 RegExp 개체가 업데이트됩니다.

아래 예제는 exec 메서드의 사용법을 보여줍니다.

function ExecDemo()
{
  var s = "AaBbCcDdEeFfGgHhIiJjKkLlMmNnOoPp"
  var r = new RegExp("g", "i");
  var a = r.exec(s);
  document.write(a);
  r.compile("g");
  var a = r.exec(s);
  document.write(a);
}


exec 메서드

exec 메서드
적용 대상 		언어 참조

Regular Expression 개체


exec 메서드

exec 메서드
참고 		언어 참조

RegExp 개체
Regular Expression 개체 메서드
Regular Expression 개체 속성
정규식 구문


lastIndex 속성(정규식)

lastIndex 속성(정규식) 		언어 참조
버전 3

참조 적용 대상

설명
다음 검색을 시작할 인덱스를 지정합니다.
구문
rgexp.lastIndex [= index]

lastIndex 속성 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
rgexp | 필수적인 요소. Regular Expression 개체입니다. 변수 이름이나 리터럴입니다.
index | 다음 검색을 시작할 인덱스입니다.

참고
lastIndex 속성은 String 개체의 exec, match, replace, split 메서드에 의해 수정됩니다.

lastIndex 값에는 다음과 같은 규칙이 적용됩니다.

  • lastIndex 값이 문자열 길이보다 크면 test와 exec 메서드가 수행되지 않고 lastIndex 값은 0으로 설정됩니다.
  • lastIndex 값이 문자열 길이와 같으면 패턴이 빈 문자열과 일치할 경우 정규식이 일치합니다. 그렇지 않으면 일치하는 부분이 없고 lastIndex 값이 0으로 다시 설정됩니다.
  • 그 외의 경우에는 lastIndex가 가장 최근에 일치한 부분의 바로 다음 위치로 설정됩니다.


lastIndex 속성(정규식)

lastIndex 속성(정규식)
적용 대상 		언어 참조

Regular Expression 개체


lastIndex 속성(정규식)

lastIndex 속성(정규식)
참고 		언어 참조

match 메서드
Regular Expression 개체 메서드
Regular Expression 개체 속성
replace 메서드
split 메서드
String 개체


source 속성

source 속성 		언어 참조
버전 3

참고 적용 대상

설명
정규식 패턴의 텍스트 사본을 반환합니다. 읽기 전용 속성입니다.
구문
rgexp.source

rgexp 인수는 Regular expression 개체입니다. 변수 이름이나 리터럴입니다.

아래 예제는 source 속성의 사용법을 보여줍니다.

function SourceDemo(re, s)
{
  var s1;
  // 정규식 존재 여부를 알기 위한 테스트 문자열입니다.
  if (re.test(s))
    s1 = " 포함 ";
  else
    s1 = " 포함 안됨 ";
  // 정규식 자체의 텍스트를 가져옵니다.
  return(s + s1 + re.source);
}


source 속성

source 속성
적용 대상 		언어 참조

Regular Expression 개체


source 속성

source 속성
참고 		언어 참조

Regular Expression 개체 메서드
Regular Expression 개체 속성
정규식 구문


test 메서드

test 메서드 		언어 참조
버전 3

참고 적용 대상

설명
검색한 문자열에 패턴이 있는지 여부를 나타내는 부울값을 반환합니다.
구문
rgexp.test(str)

test 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
rgexp | 필수적인 요소. Regular Expression 개체입니다. 변수 이름이나 리터럴입니다.
str | 필수적인 요소. 검색을 테스트할 문자열입니다.

참고
test 메서드는 문자열 안에 패턴이 있는지 확인하여 있으면 true를, 없으면 false를 반환합니다.

RegExp 개체는 test 메서드에 의해 수정되지 않습니다.

아래 예제는 test 메서드의 사용법을 보여줍니다.

function TestDemo(re, s)
{
  var s1;
  // 정규식 존재 여부를 알기 위한 테스트 문자열입니다.
  if (re.test(s))
    s1 = " 포함 ";
  else
    s1 = " 포함 안됨 ";
  // 정규식 자체의 텍스트를 가져옵니다.
  return(s + s1 + re.source);
}


test 메서드

test 메서드
적용 대상 		언어 참조

Regular Expression 개체


test 메서드

test 메서드
참고 		언어 참조

RegExp 개체
Regular Expression 개체 메서드
Regular Expression 개체 속성
정규식 구문


정규식 구문

정규식 구문 		언어 참조
버전 3

참고 적용 대상

설명
정규식에 패턴을 쓸 때는 특수 문자와 시퀀스를 사용합니다. 아래 표에 이런 문자와 문자 사용법에 대해 간략히 설명되어 있습니다.

문자 | 설명
\ 다음에 오는 문자를 특수 문자나 리터럴로 표시합니다. 예를 들어, "n"은 문자 "n"과 일치합니다. "\n"은 줄 바꿈 문자와 일치합니다. 시퀀스 "\\"은 "\"와 같고, "\("는 "("와 같습니다.
^ 입력의 시작 부분을 찾습니다.
$ 입력의 끝 부분을 찾습니다.
* 앞에 오는 문자를 0번 이상 찾습니다. 예를 들어, "zo*"를 입력하면 "z" 또는 "zoo"를 찾습니다.
+ 앞에 오는 문자를 1번 이상 찾습니다. 예를 들어, "zo+"를 입력하면 "zoo"를 찾지만 "z"는 여기에 포함되지 않습니다.
? 앞에 오는 문자를 0번 이상 찾습니다. 예를 들어, "a?ve?"를 입력하면 "never"에 있는 "ve"를 찾습니다.
. 줄 바꿈 문자를 제외한 단일 문자를 찾습니다.
(pattern) | pattern을 찾고 일치하는 내용을 기억합니다. 일치하는 부분 문자열은 Item [0]...[n]을 사용하여 결과로 나오는 Matches 컬렉션에서 검색할 수 있습니다. 괄호 문자 ( )를 찾으려면 "\(" 또는 "\)"를 사용합니다.
x|y | x 또는 y를 찾습니다. 예를 들어, "z|food"는 "z" 또는 "food"를 찾습니다. "(z|f)ood"로는 "zoo"나 "food"를 찾을 수 있습니다.
{n} | n은 음이 아닌 정수입니다. 정확하게 n번 일치하는 부분을 찾습니다. 예를 들어, "o{2}"는 "Bob"의 "o"를 찾지 않지만 "foooood"의 처음 두 o를 찾습니다.
{n,} | n은 음이 아닌 정수입니다. 적어도 n번 일치하는 부분을 찾습니다. 예를 들어, "o{2,}"는 "Bob"의 "o"를 찾지 않지만 "foooood"의 o는 모두 찾습니다. "o{1,}"은 "o+"와 같습니다. "o{0,}"은 "o*"과 같습니다.
{n,m} | m과 n은 음이 아닌 정수입니다. 최소 n번, 최대 m번 일치하는 부분을 찾습니다. 예를 들어, "o{1,3}"은 "fooooood"의 처음 세 o를 찾습니다. "o{0,1}"은 "o?"와 같습니다.
[xyz] | 문자 집합입니다. 괄호 안의 문자 중 하나를 찾습니다. 예를 들어, "[abc]"는 "plain"의 "a"를 찾습니다.
[^xyz] | 문자 집합에 없는 문자를 찾습니다. 괄호 안에 있지 않은 문자 중 하나를 찾습니다. 예를 들어, "[^abc]"는 "plain"의 "p"를 찾습니다.
[a-z] | 문자 범위입니다. 지정한 범위에 있는 문자 중 하나를 찾습니다. 예를 들어, "[a-z]"는 "a"에서 "z"까지의 알파벳 소문자를 찾습니다.
[^m-z] | 지정한 문자 범위가 아닌 집합입니다. 지정한 범위에 있지 않은 문자 중 하나를 찾습니다. 예를 들어, "[m-z]"는 "m"에서 "z"까지에 없는 문자를 찾습니다.
\b | 단어의 경계, 즉 단어와 공백 사이의 위치를 찾습니다. 예를 들어, "er\b"는 "never"의 "er"를 찾지만 "verb"의 "er"는 찾지 않습니다.
\B | 단어의 경계에 있지 않은 문자를 찾습니다. "ea*r\B"는 "never early"의 "ear"을 찾습니다.
\d | 숫자를 찾습니다. [0-9]와 같습니다.
\D | 숫자가 아닌 문자를 찾습니다. [^0-9]와 같습니다.
\f | 용지 공급 문자를 찾습니다.
\n | 줄 바꿈 문자를 찾습니다.
\r | 캐리지 리턴 문자를 찾습니다.
\s | 공백, 탭, 용지 공급 등 모든 종류의 공백 문자를 찾습니다. "[ \f\n\r\t\v]"와 같습니다.
\S | 공백 문자가 아닌 문자를 찾습니다. "[^ \f\n\r\t\v]"와 같습니다.
\t | 탭 문자를 찾습니다.
\v | 세로 탭 문자를 찾습니다.
\w | 밑줄을 포함한 모든 단어 문자를 찾습니다. "[A-Za-z0-9_]"와 같습니다.
\W | 단어가 아닌 문자를 찾습니다. "[^A-Za-z0-9_]"와 같습니다.
\num | num을 찾습니다. 여기서 num은 양의 정수입니다. 이전에 참조한 값을 다시 참조합니다. 예를 들어, "(.)\1"은 연속적으로 같은 문자가 두 번 나오는 것을 찾습니다.
\n | n을 찾습니다. 여기서 n은 8진 제어 값입니다. 8진 제어 값은 1, 2, 3 자리 중 하나라야 합니다. 예를 들어, "\11"과 "\011"은 모두 탭 문자를 나타내지만 "\0011"은 "\001" & "1"과 같습니다. 8진 제어 값은 256을 넘을 수 없습니다. 이 값이 256을 넘는 경우에는 처음 두 자릿수 만이 식을 구성합니다. 정규식에 ASCII 코드를 사용할 수 있습니다.
\x n | n을 찾습니다. 여기서 n은 16진 제어 값입니다. 16진 제어 값은 정확히 두 자리이어야 합니다. 예를 들어, "\x41"은 "A"에 해당하지만 "\x041"은 "\x04" & "1"과 같습니다. 정규식에 ASCII 코드를 사용할 수 있습니다.


정규식 구문

정규식 구문
적용 대상 		언어 참조

RegExp 개체
Regular Expression 개체


정규식 구문

정규식 구문
참고 		언어 참조

String 개체


break 문

break 문
 언어 참조
버전 1

참고

설명
현재 루프를 종료하거나 label로 연결된 경우에는 연결된 명령문을 종료합니다.
구문
break [label];

선택적인 요소인 label 인수는 중단할 문의 레이블을 지정합니다.

참고
break 문은 보통 switch 문이나 while, for, for...in, do...while 루프 등에서 사용합니다. label 인수는 주로 switch 문에서 가장 많이 사용하지만 단순문이나 복합문을 포함하여 어떤 문에서나 사용할 수 있습니다.

break 문을 실행하면 현재 루프나 문에서 빠져나와 바로 다음 문으로 스크립트를 실행하기 시작합니다.

아래 예제는 break 문의 사용법을 보여줍니다.

function BreakTest(breakpoint)
{
   var i = 0;
   while (i < 100)
   {
   if (i == breakpoint)
     break;
     i++;
   }
   return(i);
}


break 문

break 문
참고 		언어 참조

continue 문
do...while 문
for 문
for...in 문
Labeled 문
while 문


@cc_on 문

@cc_on 문 		언어 참조
버전 3

참고

설명
조건부 컴파일 지원 기능을 활성화합니다.
구문
@cc_on
참고
@cc_on 문은 스크립팅 엔진에서 조건부 컴파일을 활성화합니다.

주석에 @cc_on 문을 사용해야 조건부 컴파일을 지원하지 않는 브라우저에서 스크립트를 유효한 구문으로 받아들일 수 있습니다.

/*@cc_on*/
...
(스크립트의 나머지 부분)
또한, 주석 외부에 @if 문이나 @set 문을 사용해도 조건부 컴파일을 활성화할 수 있습니다.


@cc_on 문

@cc_on 문
참고 		언어 참조

조건부 컴파일
조건부 컴파일 변수
@if 문
@set 문


Comment 문

Comment 문
 언어 참조
버전 1

설명
JScript 구문 분석기에서 주석을 무시하도록 합니다.
구문 1
한 줄 주석
// comment
구문 2
여러 줄 주석
/*
comment
*/

comment 인수는 스크립트에 포함하려는 주석에 해당하는 텍스트입니다.

구문 3
//@CondStatement
구문 4
/*@
CondStatement
@*/

CondStatement 인수는 조건부 컴파일이 활성화될 경우 사용할 조건부 컴파일 코드입니다. 구문 3을 사용하는 경우에는 "//"와 "@" 문자 사이에 공백이 없어야 합니다.

참고
주석을 사용하면 스크립트의 일부를 JScript 구문 분석기에서 읽지 못하도록 합니다. 프로그램에 관한 참고 설명을 포함하기 위해 주석을 사용할 수 있습니다.

구문 1을 사용하면 구문 분석기는 주석 표식과 그 줄 끝 사이에 있는 텍스트를 모두 무시합니다. 구문 2를 사용하면 시작 표식과 끝 표식 사이에 있는 텍스트를 무시합니다.

구문 3과 구문 4는 조건부 컴파일 기능을 지원하지 않는 브라우저와의 호환성을 유지하면서 조건부 컴파일을 지원하는 데 사용됩니다. 해당 기능을 지원하지 않는 브라우저는 이 주석을 각각 구문 1과 구문 2에 해당하는 것으로 취급합니다.

아래 예제는 comment 문의 가장 일반적인 사용법을 보여줍니다.

function myfunction(arg1, arg2)
{
  /* 필요에 따라 여러 줄로 확장할 수 있는 여러
     줄 주석입니다. */
  var r;
  // 한 줄 주석입니다.
  r = arg1 + arg2; // 두 인수를 더합니다.
  return(r);
}


@if 문

@if 문
 언어 참조
버전 3

참고

설명
식의 값에 따라 조건에 맞는 문 그룹을 실행합니다.
구문
@if (condition1)
text1
[@elif (condition2)
text2]
[@else
text3]
@end

@if 문 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
condition1, condition2 | 부울식으로 강제로 변환할 수 있는 식입니다.
text1 | condition1이 true일 경우 구문 분석되는 텍스트입니다.
text2 | condition1이 false이고, condition2가 true일 경우 구문 분석되는 텍스트입니다.
text3 | condition1과 condition2가 모두 false일 경우 구문 분석되는 텍스트입니다.

참고
@if 문을 쓸 때 각 절을 다른 줄에 둘 필요는 없습니다. @elif 절은 여러 개를 사용할 수 있지만 @elif 절은 모두 @else 절 앞에 두어야 합니다.

보통 @if 문을 사용하여 여러 옵션 중 어떤 텍스트를 텍스트 출력에 사용할 것인지 결정합니다. 사용 예는 다음과 같습니다.

alert(@if (@_win32) "Windows NT 또는 Windows 95 사용" @else "Windows 3.1 사용" @end)


@if 문

@if 문
참고 		언어 참조

조건부 컴파일
조건부 컴파일 변수
@cc_on 문
@set 문


continue 문

continue 문
 언어 참조
버전 1

참고

설명
현재 루프 반복을 중지하고 새로 반복을 시작합니다.
구문
continue [label];

선택적인 요소인 label 인수는 continue를 적용할 문을 지정합니다.

참고
continue 문은 while, do...while, for, for...in 루프 안에서만 사용할 수 있습니다. continue 문을 실행하면 현재의 루프 반복을 중지하고 루프 시작 부분으로 가서 프로그램 흐름을 계속 진행합니다. 이 때 다른 형식을 가지고 있는 루프에 다음과 같은 영향을 줍니다.
  • while과 do...while 루프는 조건을 테스트하고 값이 true이면 루프를 다시 실행합니다.
  • for 루프는 증가식을 실행하고 테스트식이 true이면 루프를 다시 실행합니다.
  • for...in 루프는 지정한 변수의 다음 필드로 진행한 후 루프를 다시 실행합니다.

아래 예제는 continue 문의 사용법을 보여줍니다.

function skip5()
{
  var s = "", i=0;
  while (i < 10)
  {
    i++;
    // 5를 건너뜁니다.
    if (i==5)
    {
      continue;
    }
   s += i;
  }
  return(s);
}


continue 문

continue 문
참고 		언어 참조

break 문
do...while 문
for 문
for...in 문
Labeled 문
while 문


do...while 문

do...while 문 		언어 참조
버전 3

참고

설명
문 블록을 한 번 실행한 후 조건식이 false가 될 때까지 루프를 반복 실행합니다.
구문
do
statement
while (expression) ;

do...while 문 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
statement | expression이 true일 때 실행될 문입니다. 복합문일 수도 있습니다.
expression | true나 false에 해당하는 부울값으로 강제 변환할 수 있는 식입니다. expression이 true이면 루프가 다시 실행됩니다. expression이 false이면 루프가 종료됩니다.

참고
expression 값은 루프의 처음 반복 실행이 끝나기 전에는 확인되지 않기 때문에 루프가 적어도 한 번은 실행되도록 해야 합니다. 그 다음부터는 연속된 루프 반복 작업을 실행할 때마다 이 값을 확인합니다.

아래 코드에서는 do...while 문을 사용하여 Drives 컬렉션을 반복 계산합니다.

function GetDriveList()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  do
  {
    x = e.item();
    s = s + x.DriveLetter;
    s += " - ";
    if (x.DriveType == 3)
      n = x.ShareName;
    else if (x.IsReady)
      n = x.VolumeName;
    else
      n = "[드라이브가 준비되지 않았습니다.]";
    s +=  n + "<br>";
    e.moveNext();
  }
  while (!e.atEnd());
  return(s);
}


do...while 문

do...while 문
참고 		언어 참조

break 문
continue 문
for 문
for...in 문
while 문
Labeled 문


for 문

for 문
 언어 참조
버전 1

참고

설명
지정한 조건이 true인 동안 문 블록을 실행합니다.
구문
for (initialization; test; increment)
statement

for 문 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
initialization | 식. 이 식은 루프가 실행되기 전에 한 번만 실행됩니다.
test | 부울식. test가 true이면 statement를 실행합니다. test가 false이면 루프를 종료합니다.
increment | 식. 증가식은 모든 루프의 끝에서 실행됩니다.
statement | test가 true일 때 실행될 문입니다. 복합문일 수도 있습니다.

참고
for 루프는 보통 루프를 지정한 수만큼 실행할 경우에 사용합니다. 아래 예제는 for 루프의 사용법을 보여줍니다.
/* 시작할 때 i는 0으로 설정되고 루프 반복이 한 번 끝날 때마다 1씩 증가됩니다. 루프를 반복하기 전에 i가 10이 되면 루프는 종료됩니다. */
var myarray = new Array();
for (i = 0; i < 10; i++)
{
  myarray[i] = i;
}


for 문

for 문
참고 		언어 참조

for...in 문
while 문


for...in 문

for...in 문
 언어 참조
버전 5

참고

설명
개체의 각 속성이나 배열의 각 요소에 대해 하나 이상의 문을 실행합니다.
구문
for (variable in [object | array])
statement

for 문 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
variable | object의 속성이나 array의 요소가 될 수 있는 변수입니다.
object, array | 반복 계산할 개체 또는 배열입니다.
statement | 각 object 속성이나 각 array 요소에 대해 실행될 문입니다. 복합문일 수도 있습니다.

참고
루프를 반복 계산하기 전에 object의 다음 속성이나 array의 다음 요소에 variable를 지정합니다. 이렇게 하면 object 속성이나 array 요소를 사용하는 것처럼 루프 안에 있는 문에서 그 값을 사용할 수 있습니다.

개체에서 반복 계산할 때는 개체 구성원을 variable에 지정하는 순서를 결정하거나 조정할 방법이 없습니다. 배열에서 반복 계산할 때에는 요소 순서 즉 0, 1, 2, ...에 따라 수행 순서가 결정됩니다.

아래 예제는 연결 배열로 사용할 개체에 대한 for ... in 문의 사용법을 보여줍니다.

function ForInDemo()
{
  // 변수를 만듭니다.
  var a, key, s = "";
  // 개체를 초기화합니다.
  a = {"a" : "Athens" , "b" : "Belgrade", "c" : "Cairo"}
  // 속성을 반복 계산합니다.
  for (key in a)
  {
     s += a[key] + "<BR>";
  }
  return(s);
}
참고 컬렉션 구성원을 반복 계산하려면 enumerator 개체를 사용합니다.


for...in 문

for...in 문
참고 		언어 참조

for 문
while 문


function 문

function 문
 언어 참조
버전 1

참고

설명
새 함수를 선언합니다.
구문
function functionname([argument1 [, argument2 [, ...argumentn]]])
{
statements
}

function 문 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
functionname | 함수의 이름입니다.
argument1...argumentn | 선택적인 요소이며 함수가 이해할 수 있는 인수 목록으로, 쉼표로 구분됩니다.
statements | 하나 이상의 JScript 문입니다.

참고
function 문은 나중에 사용할 함수를 선언합니다. statements에 포함된 코드는 스크립트의 다른 부분에서 함수를 호출할 때까지 실행되지 않습니다.

아래 예제는 function 문의 사용법을 보여줍니다.

function myfunction(arg1, arg2)
{
  var r;
  r = arg1 * arg2;
  return(r);
}
메모 함수를 호출할 때는 괄호와 필수적인 인수가 항상 포함되어 있는지 확인합니다. 괄호 없이 함수를 호출하면 함수의 결과 대신 함수의 텍스트가 반환됩니다.


function 문

function 문
참고 		언어 참조

new 연산자


if...else 문

if...else 문
 언어 참조
버전 1

참고

설명
식의 값에 따라 조건에 맞는 문 그룹을 실행합니다.
구문
if (condition)
statement1
[else
statement2]

if...else 문 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
condition | 부울식입니다. condition이 null이나 undefined일 경우 condition은 false로 처리됩니다.
statement1 | condition이 true일 경우 실행되는 문입니다. 복합문일 수도 있습니다.
statement2 | condition이 false일 경우 실행되는 문입니다. 복합문일 수도 있습니다.

참고
statement1과 statement2는 중괄호({})로 묶으면 더 명확해 보이고 부주의로 인한 오류도 막을 수 있습니다. 아래 예제에서는 else를 첫째 if 문과 함께 사용하려고 했을 수도 있었지만 결과적으로는 둘째 if 문과 함께 사용되었습니다.
if (x == 5)
  if (y == 6)
     z = 17;
else
  z = 20;
코드를 아래와 같이 변경하면 이러한 문제를 막을 수 있습니다.
if (x == 5)
  {
  if (y == 6)
     z = 17;
  }
else
  z = 20;
마찬가지로 statement1에 문을 추가하려는 경우 중괄호를 사용하지 않으면 부주으로 인해 오류가 일어날 수 있습니다.
if (x == 5)
  z = 7;
  q = 42;
else
  z = 19;
이 경우에는 if와 else 문 사이에 문이 두 개 이상있기 때문에 구문 오류가 발생하므로 if와 else 사이의 문을 중괄호로 묶어야 합니다.


if...else 문

if...else 문
참고 		언어 참조

?: 연산자


Labeled 문

Labeled 문 		언어 참조
버전 3

참고

설명
문에 식별자를 제공합니다.
구문
label :
statement

Labeled 문 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
label | labled 문을 참조할 때 사용하는 고유 식별자입니다.
statement | label로 연결된 문입니다. 복합문일 수도 있습니다.

참고
레이블은 break와 continue 문에 의해 사용되어 break와 continue를 적용할 문을 지정합니다.

아래 문에서 continue 문은 labeled 문을 사용하여 각 열의 세째 행이 포함된 배열과 정의되지 않은 값을 만듭니다.

function labelDemo()
{
    var a = new Array();
    var i, j, s = "", s1 = "";
  Outer:
    for (i = 0; i < 5; i++)
    {
      Inner:
        for (j = 0; j < 5; j++)
        {
          if (j == 2)
            continue Inner;
          else
            a[i,j] = j + 1;
        }
    }

    for (i = 0;i < 5; i++)
    {
      s = ""
      for (j = 0; j < 5; j++)
      {
        s += a[i,j];
      }
      s1 += s + "\n";
    }
    return(s1)
}


Labeled 문

Labeled 문
참고 		언어 참조

break 문
continue 문


return 문

return 문
 언어 참조
버전 1

참고

설명
현재 함수를 종료하고 그 함수에서 구한 값을 반환합니다.
구문

return [expression];

expression 인수는 함수에서 반환되는 값입니다. 생략하면 함수는 값을 반환하지 않습니다.

참고
return 문을 사용하면 함수 실행을 중지하고 expression 값을 반환할 수 있습니다. expression을 생략하거나 함수 내에서 return 문이 실행되지 않으면 현재 함수를 호출한 식에 undefined 값이 지정됩니다.

아래 예제는 return 문의 사용법을 보여줍니다.

function myfunction(arg1, arg2)
{
  var r;
  r = arg1 * arg2;
  return(r);
}


return 문

return 문
참고 		언어 참조

function 문


@set 문

@set 문 		언어 참조
버전 3

참고

설명
조건부 컴파일 문에 사용할 변수들을 만듭니다.
구문
@set @varname = term

@set 문 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
varname | 유효한 JScript 변수 이름입니다. 항상 앞에 "@" 문자가 나와야 합니다.
term | 0개 이상의 단일 연산자이며, 상수, 조건부 컴파일 변수, 괄호로 묶인 식 등이 뒤에 나옵니다.

참고
조건부 컴파일에는 number 변수와 Boolean 변수가 지원됩니다. 문자열은 지원되지 않습니다. @set으로 만든 변수는 보통 조건부 컴파일 문에서 사용하지만 JScript 코드 어디에서나 사용할 수 있습니다.

변수 선언 예제는 다음과 같습니다.

@set @myvar1 = 12
@set @myvar2 = (@myvar1 * 20)
@set @myvar3 = @_jscript_version
다음 연산자는 괄호로 묶인 식에서 사용할 수 있습니다.
  • ! ~
  • * / %
  • + -
  • << >> >>>
  • < <= > >=
  • == != === !==
  • & ^ |
  • && ||
변수를 정의하지 않고 사용하면 변수 값이 NaN이 됩니다. NaN은 @if 문으로 확인할 수 있습니다.
@if (@newVar != @newVar)
  ...
NaN이 자기 자신과 같지 않은 유일한 값이므로 이 방법을 사용합니다.


@set 문

@set 문
참고 		언어 참조

조건부 컴파일
조건부 컴파일 변수
@cc_on 문
@if 문


switch 문

switch 문 		언어 참조
버전 3

참고

설명
지정한 식의 값이 레이블과 일치하면 문을 하나 이상 실행할 수 있습니다.
구문
switch (expression) {
case label :
statementlist
case label :
statementlist
...
default :
statementlist
}

switch 문 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
expression | 평가할 식입니다.
label | expression과 일치하는 식별자입니다. 만일 label === expression이면 콜론 바로 뒤에 있는 statementlist부터 실행하여 선택적인 요소인 break 문이나 switch 문의 끝에 올 때까지 계속 실행합니다.
statementlist | 실행할 하나 이상의 문입니다.

참고
expression과 일치하는 레이블 값이 없을 경우 default 절을 사용하여 실행할 문을 제공합니다. 이 절은 switch 코드 블록 내의 어디에나 올 수 있습니다.

label 블록은 0개 이상 지정할 수 있습니다. expression 값과 일치하는 label도 없고 default도 제공되지 않으면 어떤 문도 실행되지 않습니다.

switch 문은 다음과 같이 실행됩니다.

  1. 일치하는 것을 찾을 때까지 expression을 평가한 후 label을 살펴봅니다.
  2. label 값이 expression과 같으면 동반하고 있는 statementlist를 실행합니다.
    break 문을 만나거나 switch 문이 끝날 때까지 실행을 계속합니다. 따라서 break 문을 사용하지 않으면 여러 label 블록이 실행됩니다.
  3. expression과 일치하는 label이 없으면 default로 갑니다. default도 없으면 마지막 단계로 갑니다.
  4. switch 코드 블록의 끝 다음에 나오는 문을 계속 실행합니다.
아래 예제에서는 개체 형식을 테스트합니다.
function MyObject() {
...}
switch (object.constructor){
    case Date:
    ...
    case Number:
    ...
    case String:
    ...
    case MyObject:
    ...
    default:
    ...
}


switch 문

switch 문
참고 		언어 참조

break 문
if...else 문


this 문

this 문
 언어 참조
버전 1

참고

설명
현재 개체를 참조합니다.
구문
this.property
참고
this 키워드는 보통 개체 구성자에서 현재 개체를 참조할 때 사용합니다. 아래 예제에서 this는 새로 만든 Car 개체를 참조하고 세 가지 속성에 값을 지정합니다.
function Car(color, make, model)
{
  this.color = color;
  this.make = make;
  this.model = model;
}
JScript 클라이언트 버전의 경우 this는 다른 개체의 컨텍스트 외부에서 사용하면 window 개체를 참조합니다.


this 문

this 문
참고 		언어 참조

new 연산자


throw 문

throw 문
 언어 참조
버전 5

참고

설명
try...catch 문에서 처리할 수 있는 오류 조건을 만듭니다.
구문
throw exception

exception 인수는 식입니다.

참고
아래 예제에서는 전달된 값을 기준으로 오류를 넘긴 후 try...catch 문 계층 구조에서 오류를 처리하는 방법을 보여줍니다.
function TryCatchDemo(x)
{
  try {
    try {
    if (x == 0)					// 인수를 평가합니다.
      throw "x equals zero";			// 오류를 넘깁니다.
    else
      throw "x does not equal zero";		// 다른 오류를 넘깁니다.
    }
    catch(e) {					// "x = 0" 오류를 여기에서 처리합니다.
      if (e == "x equals zero")			// 처리한 오류를 여기에서 확인합니다.
        return(e + " handled locally.");	// 개체 오류 메시지를 반환합니다.
      else					// 여기에서는 오류를 처리할 수 없습니다.
        throw e;					// 다음 오류 처리기로 오류를
    }							// 다시 넘깁니다.
  }
  catch(e) {                    	   	// 다른 오류를 여기에서 처리합니다.
    return(e + " handled higher up.");		// 오류 메시지를 반환합니다.
  }
}
document.write(TryCatchDemo(0));
document.write(TryCatchDemo(1));


throw 문

throw 문
참고 		언어 참조

try...catch 문


try...catch 문

try...catch 문
 언어 참조
버전 5

참고

설명
JScript 오류를 처리합니다.
구문
try
tryStatement
catch(exception)
catchStatement

try...catch 문 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
tryStatement | 오류가 발생할 수 있는 문입니다. 복합문일 수도 있습니다.
exception | 변수 이름입니다. exception의 초기 값은 발생 오류 값입니다.
catchStatement | 연결된 tryStatement에서 발생하는 오류를 처리하는 문입니다. 복합문일 수도 있습니다.

참고
try...catch 문을 사용하면 코드를 실행하면서도 코드 블록에서 발생할 수 있는 오류의 일부 또는 전부를 처리할 수 있습니다. 프로그래머가 처리하지 않은 오류가 발생하면 JScript는 마치 오류를 처리하지 않은 것처럼 사용자에게 보통의 오류 메시지를 전달합니다.

tryStatement 인수는 오류가 발생할 수 있는 코드를 포함하고, catchStatement는 실제로 발생하는 오류를 처리하는 코드를 포함합니다. tryStatement에 오류가 발생하면 프로그램 제어는 catchStatement로 넘어가 처리됩니다. exception의 초기 값은 tryStatement에서 발생한 오류 값입니다.

오류가 발생한 tryStatement에 연결된 catchStatement에서 오류를 처리할 수 없는 경우에는 throw 문을 사용하여 보다 수준 높은 오류 처리기로 보내거나 다시 넘깁니다.

아래 예제에서는 전달된 값을 기준으로 오류를 넘깁니다. 그리고 try...catch 문의 계층 구조에서 오류를 처리하는 방법을 보여줍니다.

function TryCatchDemo(x)
{
  try {
    try {
    if (x == 0)					// 인수를 평가합니다.
      throw "x equals zero";			// 오류를 넘깁니다.
    else
      throw "x does not equal zero";		// 다른 오류를 넘깁니다.
    }
    catch(e) {					// "x = 0" 오류를 여기에서 처리합니다.
      if (e == "x equals zero")			// 처리된 오류를 여기에서 확인합니다.
        return(e + " handled locally.");	// 개체 오류 메시지를 반환합니다.
      else					// 여기에서는 오류를 처리할 수 없습니다.
        throw e;					// 다음 오류 처리기로 오류를
    }							// 다시 넘깁니다.
  }
  catch(e) {						// 여기에서 다른 오류를 처리합니다.
    return(e + " handled higher up.");		// 오류 메시지를 반환합니다.
  }
}
document.write(TryCatchDemo(0));
document.write(TryCatchDemo(1));


try...catch 문

try...catch 문
참고 		언어 참조

throw 문


var 문

var 문
 언어 참조
버전 1

참고

설명
변수를 선언합니다.
구문
var variable [ = value ] [, variable2 [ = value2], ...]

var 문 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
variable, variable2 | 선언할 변수의 이름입니다.
value, value2 | 변수에 지정된 초기 값입니다.

참고
var 문을 사용하여 변수를 선언합니다. 이들 변수는 선언할 때 값을 지정할 수도 있고, 나중에 스크립트에서 지정할 수도 있습니다. 선언 예는 다음과 같습니다.
var index;
var name = "Thomas Jefferson";
var answer = 42, counter, numpages = 10;


var 문

var 문
참고 		언어 참조

function 문
new 연산자


while 문

while 문
 언어 참조
버전 1

참고

설명
지정한 조건이 false가 될 때까지 문을 실행합니다.
구문
while (expression)
statement

while 문 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
expression 루프를 반복할 때마다 그 전에 확인하는 부울식입니다. expression이 true이면 루프가 실행됩니다. expression이 false이면 루프가 종료됩니다.
statement | expression이 true이면 실행되는 명령문입니다. 복합문일 수도 있습니다.

참고
while 문은 루프가 처음 실행되기 전에 expression을 확인합니다. 이 때 expression이 false이면 루프는 실행되지 않습니다.

아래 예제는 while 문의 사용법을 보여줍니다.

function BreakTest(breakpoint)
{
   var i = 0;
   while (i < 100)
   {
   if (i == breakpoint)
     break;
     i++;
   }
   return(i);
}


while 문

while 문
참고 		언어 참조

break 문
continue 문
do...while 문
for 문
for...in 문


with 문

with 문
 언어 참조
버전 1

참고

설명
문의 기본 개체를 설정합니다.
구문
with (object)
statement

with 문 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object

새로운 기본 개체입니다.

statement | object가 기본 개체인 문입니다. 복합문일 수도 있습니다.

참고
with 문은 특정 조건에서 써야 할 코드의 양을 줄이는 데 보통 사용합니다. 아래 예제에서는 Math가 반복적으로 사용되었습니다.
x = Math.cos(3 * Math.PI) + Math.sin(Math.LN10)
y = Math.tan(14 * Math.E)
with 문을 사용하면 코드를 더 짧고 읽기 쉽게 바꿀 수 있습니다.
with (Math)
{
  x = cos(3 * PI) + sin (LN10)
  y = tan(14 * E)
}


with 문

with 문
참고 		언어 참조

this 문


anchor 메서드

anchor 메서드 		언어 참조
버전 1

참고 적용 대상

설명

개체의 특정 텍스트 양 끝에 NAME 특성을 가진 HTML 앵커를 삽입합니다.
구문
strVariable.anchor(anchorstring)
"String Literal".anchor(anchorstring)

anchorstring 인수는 HTML 앵커의 NAME 특성에 넣을 텍스트입니다.

참고
String 개체에서 명명된 앵커를 만들려면 anchor 메서드를 호출하십시오. 아래 예제는 anchor 메서드의 사용법을 보여줍니다.
var strVariable = "앵커입니다." ;
strVariable = strVariable.anchor("Anchor1");
마지막 문을 실행한 후의 strVariable 값은 다음과 같습니다.
<A NAME="Anchor1">앵커입니다.</A>
문자열에 이미 태그를 적용했는지 확인하는 과정은 포함되어 있지 않습니다.


anchor 메서드

anchor 메서드
적용 대상 		언어 참조

String 개체


anchor 메서드

anchor 메서드
참고 		언어 참조

link 메서드
String 개체 메서드
String 개체 속성


big 메서드

big 메서드 		언어 참조
버전 1

참고 적용 대상

설명
String 개체의 텍스트 양 끝에 <BIG> HTML 태그를 삽입합니다.
구문
strVariable.big( )
"String Literal".big( )
참고
아래 예제는 big 메서드의 사용법을 보여줍니다.
var strVariable = "문자열 개체입니다.";
strVariable = strVariable.big( );
마지막 문을 실행한 후의 strVariable 값은 다음과 같습니다.
<BIG>문자열입니다.</BIG>
문자열에 이미 태그를 적용했는지 확인하는 과정은 포함되어 있지 않습니다.


big 메서드

big 메서드
적용 대상 		언어 참조

String 개체


big 메서드

big 메서드
참고 		언어 참조

small 메서드
String 개체 메서드
String 개체 속성


blink 메서드

blink 메서드 		언어 참조
버전 1

참고 적용 대상

설명
String 개체의 텍스트 양 끝에 <BLINK> HTML 태그를 삽입합니다.
구문
strVariable.blink( )
"String Literal".blink( )
참고
아래 예제는 blink 메서드의 사용법을 보여줍니다.
var strVariable = "문자열 개체입니다.";
strVariable = strVariable.blink( );
마지막 문을 실행한 후의 strVariable 값은 다음과 같습니다.
<BLINK>문자열 개체입니다.</BLINK>
문자열에 이미 태그를 적용했는지 확인하는 과정은 포함되어 있지 않습니다.

<BLINK> 태그는 Microsoft Internet Explorer에서는 지원되지 않습니다.


blink 메서드

blink 메서드
적용 대상 		언어 참조

String 개체


blink 메서드

blink 메서드
참고 		언어 참조

String 개체 메서드
String 개체 속성


bold 메서드

bold 메서드 		언어 참조
버전 1

참고 적용 대상

설명
String 개체의 텍스트 양 끝에 <B> HTML 태그를 삽입합니다.
구문
strVariable.bold( )
"String Literal".bold( )
참고
아래 예제는 bold 메서드의 사용법을 보여줍니다.
var strVariable = "문자열 개체입니다.";
strVariable = strVariable.bold( );
마지막 문을 실행한 후의 strVariable 값은 다음과 같습니다.
<B>문자열 개체입니다.</B>
문자열에 이미 태그를 적용했는지 확인하는 과정은 포함되어 있지 않습니다.


bold 메서드

bold 메서드
적용 대상 		언어 참조

String 개체


bold 메서드

bold 메서드
참고 		언어 참조

italics 메서드
String 개체 메서드
String 개체 속성


charAt 메서드

charAt 메서드 		언어 참조
버전 1

참고 적용 대상

설명
지정한 인덱스에 해당하는 문자를 반환합니다.
구문
strVariable.charAt(index)
"String Literal".charAt(index)

index 인수는 원하는 문자에 0부터 인덱스를 지정합니다. 유효한 값은 0부터 문자열 길이에서 1을 뺀 값까지입니다.

참고
charAt 메서드는 지정한 인덱스에 해당하는 문자 값을 반환합니다. 문자열의 첫쨰 문자는 인덱스가 0이고, 둘째 문자는 인덱스가 1이며 이와 같은 방법으로 계속 이어집니다. 유효한 범위를 넘는 인덱스 값은 undefined를 반환합니다.

아래 예제는 charAt 메서드의 사용법을 보여줍니다.

function charAtTest(n)
{
  var str = "ABCDEFGHIJKLMNOPQRSTUVWXYZ";
  var s;
  s = str.charAt(n - 1);
  return(s);
}


charAt 메서드

charAt 메서드
적용 대상 		언어 참조

String 개체


charAt 메서드

charAt 메서드
참고 		언어 참조

String 개체 메서드
String 개체 속성


charCodeAt 메서드

charCodeAt 메서드 		언어 참조
버전 3

참고 적용 대상

설명
지정한 문자의 유니코드 인코딩을 반환합니다.
구문
stringObj.charCodeAt(index)

charCodeAt 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
stringObj | 필수적인 요소. String 개체나 리터럴입니다.
index | 필수적인 요소. 지정된 문자의 0부터 인덱스를 지정합니다.

참고
지정한 index에 문자가 없으면 NaN을 반환합니다.

아래 예제는 charCodeAt 메서드의 사용법을 보여줍니다.

function charCodeAtTest(n)
{
  var str = "ABCDEFGHIJKLMNOPQRSTUVWXYZ";
  var s;
  s = str.charCodeAt(n - 1);
  // 유니코드 문자 코드를 반환합니다.
  return(s);
}


charCodeAt 메서드

charCodeAt 메서드
적용 대상 		언어 참조

String 개체


charCodeAt 메서드

charCodeAt 메서드
참고 		언어 참조

fromCharCode 메서드
String 개체 메서드


concat 메서드(String)

concat 메서드(String) 		언어 참조
버전 3

참고 적용 대상

설명
주어진 두 문자열의 연결을 포함하는 String 개체를 반환합니다.
구문
string1.concat(string2)

concat 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
string1 | 필수적인 요소. string2와 연결할 String 개체나 리터럴입니다.
string2 | 필수적인 요소. string1의 끝에 연결할 String 개체나 리터럴입니다.

참고
concat 메서드를 사용한 결과는 다음과 같습니다.

result = string1 + string2

function concatDemo()
{
  var str1 = "ABCDEFGHIJKLM"
  var str2 = "NOPQRSTUVWXYZ";
  var s = str1.concat(str2);
  // 연결된 문자열을 반환합니다.
  return(s);
}


concat 메서드(String)

concat 메서드(String)
적용 대상 		언어 참조

Array 개체
String 개체


concat 메서드(String)

concat 메서드(String)
참고 		언어 참조

+ 연산자
concat 메서드(Array)
String 개체 메서드


fixed 메서드

fixed 메서드 		언어 참조
버전 1

참고 적용 대상

설명
String 개체의 텍스트 양 끝에 <TT> HTML 태그를 삽입합니다.
구문
strVariable.fixed( )
"String Literal".fixed( )
참고
아래 예제는 fixed 메서드의 사용법을 보여줍니다.
var strVariable = "문자열 개체입니다.";
strVariable = strVariable.fixed( );
마지막 문을 실행한 후의 strVariable 값은 다음과 같습니다.
<TT>문자열 개체입니다.</TT>
문자열에 이미 태그를 적용했는지 확인하는 과정은 포함되어 있지 않습니다.


fixed 메서드

fixed 메서드
적용 대상 		언어 참조

String 개체


fixed 메서드

fixed 메서드
참고 		언어 참조

String 개체 메서드
String 개체 속성


fontcolor 메서드

fontcolor 메서드 		언어 참조
버전 1

참고 적용 대상

설명
String 개체의 텍스트 양 끝에 COLOR 특성을 가진 <FONT> HTML 태그를 삽입합니다.
구문
strVariable.fontcolor(colorval)
"String Literal".fontcolor(colorval)

colorval 인수는 색상 값을 포함한 문자열입니다. 이 값은 색에 해당하는 16진수 값일 수도 있고, 미리 정의된 색 이름일 수도 있습니다.

참고
아래 예제는 fontcolor 메서드 사용법을 보여줍니다.
var strVariable = "문자열입니다.";
strVariable = strVariable.fontcolor("red");
마지막 문을 실행한 후의 strVariable 값은 다음와 같습니다.
<FONT COLOR="RED">문자열입니다.</FONT>
미리 정의된 유효한 색 이름은 JScript 호스트(브라우저, 서버 등)에 따라 달라집니다. 같은 호스트에서도 버전에 따라 달라질 수 있습니다. 자세한 정보는 호스트 설명서를 참조하십시오.

문자열에 이미 태그를 적용했는지 확인하는 과정은 포함되어 있지 않습니다.


fontcolor 메서드

fontcolor 메서드
적용 대상 		언어 참조

String 개체


fontcolor 메서드

fontcolor 메서드
참고 		언어 참조

fontsize 메서드
String 개체 메서드
String 개체 속성


fontsize 메서드

fontsize 메서드 		언어 참조
버전 1

참고 적용 대상

설명
String 개체의 텍스트 양 끝에 SIZE 특성을 가진 <FONT> HTML 태그를 삽입합니다.
구문
strVariable.fontsize(intSize)
"String Literal".fontsize(intSize)

intSize 인수는 텍스트의 크기를 결정하는 정수 값입니다.

참고
아래 예제는 fontsize 메서드의 사용법을 보여줍니다.
var strVariable = "문자열입니다.";
strVariable = strVariable.fontsize(-1);
마지막 문을 실행한 후의 strVariable 값은 다음과 같습니다.
<FONT SIZE="-1">문자열입니다.</FONT>
유효한 정수 값은 Microsoft JScript 호스트에 따라 달라집니다. 자세한 정보는 호스트 설명서를 참조하십시오.

문자열에 이미 태그를 적용했는지 확인하는 과정은 포함되어 있지 않습니다.


fontsize 메서드

fontsize 메서드
적용 대상 		언어 참조

String 개체


fontsize 메서드

fontsize 메서드
참고 		언어 참조

fontcolor 메서드
String 개체 메서드
String 개체 속성


fromCharCode 메서드

fromCharCode 메서드 		언어 참조
버전 3

참고 적용 대상

설명
여러 유니코드 문자 값 중에서 문자열을 반환합니다.
구문
String.fromCharCode(code1, code2, ..., coden)

code 인수는 문자열로 변환할 일련의 유니코드 문자 값입니다.

참고
fromCharCode를 호출하기 전에 String 개체를 만들 필요는 없습니다.

아래 예제에서는 test에 "plain"이라는 문자열이 포함됩니다.

var test = String.fromCharCode(112, 108, 97, 105, 110);


fromCharCode 메서드

fromCharCode 메서드
적용 대상 		언어 참조

String 개체


fromCharCode 메서드

fromCharCode 메서드
참고 		언어 참조

charCodeAt 메서드
String 개체 메서드


indexOf 메서드

indexOf 메서드 		언어 참조
버전 1

참고 적용 대상

설명
String 개체 안에서 부분 문자열이 처음 나오는 문자 위치를 반환합니다.
구문
strVariable.indexOf(substring, startindex)
"String Literal".indexOf(substring, startindex)

indexOf 메서드 구문은 아래 인수로 구성됩니다.

구성 요소 | 설명
substring | String 개체 안에서 검색하려는 부분 문자열입니다.
startindex | String 개체 안에서 검색을 시작할 인덱스를 지정하는 선택적인 정수 값입니다. 생략하면 문자열의 처음부터 검색을 시작합니다.

참고
indexOf 메서드는 String 개체 안에 있는 부분 문자열의 시작점을 나타내는 정수값을 반환합니다. 부분 문자열이 없으면 -1이 반환됩니다.

startindex 값이 음수이면 startindex는 0으로 처리됩니다. 이 값이 가장 큰 문자 위치 인덱스보다 더 크면 사용할 수 있는 가장 큰 인덱스로 처리됩니다.

검색은 왼쪽에서 오른쪽으로 수행됩니다. 이 점을 제외하면 이 메서드는 lastIndexOf와 같습니다.

아래 예제는 indexOf 메서드의 사용법을 보여줍니다.

function IndexDemo(str2)
{
  var str1 = "BABEBIBOBUBABEBIBOBU"
  var s = str1.indexOf(str2);
  return(s);
}


indexOf 메서드

indexOf 메서드
적용 대상 		언어 참조

String 개체


indexOf 메서드

indexOf 메서드
참고 		언어 참조

lastIndexOf 메서드
String 개체 메서드
String 개체 속성


italics 메서드

italics 메서드 		언어 참조
버전 1

참고 적용 대상

설명
String 개체의 텍스트 양 끝에 <I> HTML 태그를 삽입합니다.
구문
strVariable.italics( )
"String Literal".italics( )
참고
아래 예제는 italics 메서드의 사용법을 보여줍니다.
var strVariable = "문자열입니다.";
strVariable = strVariable.italics( );
마지막 문을 실행한 후의 strVariable 값은 다음과 같습니다.
<I> 문자열입니다.</I>
문자열에 이미 태그를 적용했는지 확인하는 과정은 포함되어 있지 않습니다.


italics 메서드

italics 메서드
적용 대상 		언어 참조

String 개체


italics 메서드

italics 메서드
참고 		언어 참조

bold 메서드
String 개체 메서드
String 개체 속성


lastIndexOf 메서드

lastIndexOf 메서드 		언어 참조
버전 1

참고 적용 대상

설명
String 개체 안에서 부분 문자열이 마지막으로 나오는 경우를 반환합니다.
구문
strVariable.lastIndexOf(substring, startindex)
"String Literal".lastIndexOf(substring, startindex)

lastIndexOf 메서드 구문은 아래 인수로 구성됩니다.

인수 | 설명
substring | String 개체 안에서 검색하려는 부분 문자열입니다.
startindex | String 개체 안에서 검색을 시작할 인덱스를 지정하는 선택적인 정수값입니다. 생략하면 문자열의 끝에서 검색을 시작합니다.

참고
lastIndexOf 메서드는 String 개체 안에서 부분 문자열의 시작점을 나타내는 정수 값을 반환합니다. 부분 문자열이 없으면 a -1이 반환됩니다.

startindex가 음수이면 startindex는 0으로 처리됩니다. startindex가 가장 큰 문자 위치 인덱스보다 더 크면 사용할 수 있는 가장 큰 인덱스로 처리됩니다.

검색은 오른쪽에서 왼쪽으로 수행됩니다. 이 점을 제외하면 이 메서드는 indexOf와 같습니다.

아래 예제는 lastIndexOf 메서드의 사용법을 보여줍니다.

function lastIndexDemo(str2)
{
  var str1 = "BABEBIBOBUBABEBIBOBU"
  var s = str1.lastIndexOf(str2);
  return(s);
}


lastIndexOf 메서드

lastIndexOf 메서드
적용 대상 		언어 참조

String 개체


lastIndexOf 메서드

lastIndexOf 메서드
참고 		언어 참조

indexOf 메서드
String 개체 메서드
String 개체 속성


length 속성(String)

length 속성(String) 		언어 참조
버전 1

참고 적용 대상

설명
String 개체의 길이를 반환합니다.
구문
strVariable.length
"String Literal".length
참고
length 속성에는 String 개체의 문자 수를 나타내는 정수 값이 들어있습니다. String 개체의 마지막 문자의 인덱스는 length - 1입니다.


length 속성(String)

length 속성(String)
적용 대상 		언어 참조

String 개체


length 속성(String)

length 속성(String)
참고 		언어 참조

length 속성(Array)
length 속성(Function)
String 개체 메서드
String 개체 속성


link 메서드

link 메서드 		언어 참조
버전 1

참고 적용 대상

설명
String 개체의 텍스트 양 끝에 HREF 특성을 가진 HTML 앵커를 삽입합니다.
구문
strVariable.link(linkstring)
"String Literal".link(linkstring)

linkstring 인수는 HTML 앵커의 HREF 특성에 삽입할 텍스트입니다.

참고
link 메서드를 호출하여 String 개체에서 하이퍼링크를 만듭니다. 아래 예제는 link 메서드의 사용법을 보여줍니다.
var strVariable = "하이퍼링크입니다.";
strVariable = strVariable.link("http://www.microsoft.com");
마지막 문을 실행한 후의 strVariable 값은 다음과 같습니다.
<A HREF="http://www.microsoft.com">하이퍼링크입니다.</A>
문자열에 이미 태그를 적용했는지 확인하는 과정은 포함되어 있지 않습니다.


link 메서드

link 메서드
적용 대상 		언어 참조

String 개체


link 메서드

link 메서드
참고 		언어 참조

anchor 메서드
String 개체 메서드
String 개체 속성


match 메서드

match 메서드 		언어 참조
버전 3

참고 적용 대상

설명
주어진 Regular Expression 개체를 사용하여 문자열을 검색한 결과를 배열로 반환합니다.
구문
stringObj.match(rgExp)

match 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
stringObj | 필수적인 요소. 검색을 수행할 String 개체나 리터럴입니다.
rgExp | 필수적인 요소. 검색에 사용할 정규식입니다.

참고
exec 메서드처럼 작용하는 match 메서드는 여러 값을 묶은 하나의 배열을 반환합니다. 배열의 0 요소에는 마지막으로 일치하는 문자가 들어있습니다. 1...n 요소들은 정규식에서 괄호 안에 있는 모든 부분 문자열과 일치합니다.

match 메서드는 RegExp 개체의 내용을 업데이트합니다.

아래 예제는 match 메서드의 사용법을 보여줍니다.

function MatchDemo()
{
  var r, re;
  var s = "재빠른 갈색 여우가 느린 황색 개를 덮쳤습니다.";
  re = /여우/i;
  r = s.match(re);
  return(r);
}


match 메서드

match 메서드
적용 대상 		언어 참조

String 개체


match 메서드

match 메서드
참고 		언어 참조

exec 메서드
RegExp 개체
replace 메서드
search 메서드
String 개체 메서드
test 메서드


replace 메서드

replace 메서드 		언어 참조
버전 3

참고 적용 대상

설명
정규식을 사용하여 텍스트를 바꾼 문자열의 복사본을 반환합니다.
구문
stringObj.replace(rgExp, replaceText)

replace 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
stringObj | 필수적인 요소. 바꾸려는 String 개체나 리터럴입니다. 이 개체는 replace 메서드로 수정할 수 없습니다.
rgExp | 필수적인 요소. 검색할 부분을 설명하는 Regular Expression 개체입니다.
replaceText | 필수적인 요소. stringObj에서 rgExp와 일치하는 것으로 바꿀 텍스트를 포함하는 String 개체나 리터럴입니다.

참고
replace 메서드의 결과는 모두 바꾼 후의 stringObj 복사본입니다.

이 메서드는 RegExp 개체의 내용을 업데이트합니다.

아래 예제는 replace 메서드의 사용법을 보여줍니다.

function ReplaceDemo()
{
  var r, re;
  var s = "재빠른 갈색 여우가 느린 황색 개를 덮쳤습니다.";
  re = /여우/i;
  r = s.replace(re, "돼지");
  return(r);
}
이 외에도 replace 메서드는 패턴을 가지고 부분식을 바꿀 수 있습니다. 아래 예제는 문자열에서 각 쌍의 단어를 맞바꾸는 방법을 보여줍니다.
function ReplaceDemo()
{
  var r, re;
  var s = "재빠른 갈색 여우가 느린 황색 개를 덮쳤습니다.";
  r = s.replace(re, "$3$2$1");	// 각 단어의 쌍을 맞바꿉니다.
  return(r);
}


replace 메서드

replace 메서드
적용 대상 		언어 참조

String 개체


replace 메서드

replace 메서드
참고 		언어 참조

exec 메서드
match 메서드
RegExp 개체
search 메서드
String 개체 메서드
test 메서드


search 메서드

search 메서드 		언어 참조
버전 3

참고 적용 대상

설명
정규식 검색에서 첫번째로 일치하는 부분 문자열의 위치를 반환합니다.
구문
stringObj.search(rgexp)

search 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
stringObj | 필수적인 요소. 검색할 String 개체나 리터럴입니다.
rgexp | 필수적인 요소. 검색할 패턴이 있는 Regular Expression 개체입니다.

참고
search 메서드는 일치하는 부분이 있는지 여부를 나타냅니다. 일치하는 부분이 있으면 search 메서드는 일치하는 문자열의 시작 부분에서 오프셋을 나타내는 정수 값을 반환합니다. 일치하는 부분이 없으면 -1을 반환합니다. 자세한 정보는 match 메서드를 참조하십시오.

아래 예제는 search 메서드의 사용법을 보여줍니다.

function SearchDemo()
{
  var r, re;
  var s = "재빠른 여우가 느린 황색 개를 덮쳤습니다.";
  re = /여우/i;
  r = s.search(re);
  return(r);
}


search 메서드

search 메서드
적용 대상 		언어 참조

String 개체


search 메서드

search 메서드
참고 		언어 참조

exec 메서드
match 메서드
replace 메서드
String 개체 메서드
test메서드


slice 메서드(String)

slice 메서드(String) 		언어 참조
버전 3

참고 적용 대상

설명
문자열의 일정 부분을 반환합니다.
구문
stringObj.slice(start, [end])

slice 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
stringObj | 필수적인 요소. String 개체나 리터럴입니다.
start | 필수적인 요소. stringObj에 지정된 부분의 시작을 0에서 시작하여 나타내는 인덱스입니다.
end | 선택적인 요소. stringObj에 지정된 부분의 끝을 0에서 시작하여 나타내는 인덱스입니다.

참고
slice 메서드는 stringObj에 지정된 부분을 포함하는 String 개체를 반환합니다.

음수를 사용하면 end는 stringObj의 끝에서 오프셋을 나타냅니다. 또한 이 값은 0에서 시작하지 않습니다. 생략하면 stringObj의 끝까지 계속 추출됩니다.

아래 예제에서 두 slice 메서드는 동일한 결과를 반환합니다. 둘째 예제에서 음수는 str1의 마지막 문자가 끝나는 점을 가리킵니다.

str1.slice(0)
str2.slice(0,-1)


slice 메서드(String)

slice 메서드(String)
적용 대상 		언어 참조

Array 개체
String 개체


slice 메서드(String)

slice 메서드(String)
참고 		언어 참조

slice 메서드(Array)
String 개체 메서드


small 메서드

small 메서드 		언어 참조
버전 1

참고 적용 대상

설명
String 개체의 텍스트 양 끝에 HTML <SMALL> 태그를 삽입합니다.
구문
strVariable.small( )
"String Literal".small( )
참고
아래 예제는 small 메서드의 사용법을 보여줍니다.
var strVariable = "문자열입니다.";
strVariable = strVariable.small( );
마지막 문을 실행한 후의 strVariable 값은 다음과 같습니다.
<SMALL>문자열입니다.</SMALL>
문자열에 이미 태그를 적용했는지 확인하는 과정은 포함되어 있지 않습니다.


small 메서드

small 메서드
적용 대상 		언어 참조

String 개체


small 메서드

small 메서드
참고 		언어 참조

big 메서드
String 개체 메서드
String 개체 속성


split 메서드

split 메서드 		언어 참조
버전 3

참고 적용 대상

설명
문자열을 여러 개의 부분 문자열로 분리할 때 만들어지는 문자열의 배열을 반환합니다.
구문
stringObj.split(str)

split 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
stringObj | 필수적인 요소. 분할할 String 개체나 리터럴입니다. 이 개체는 split 메서드에 의해 수정되지 않습니다.
str | 필수적인 요소. 분할할 곳을 정의하는 데 사용되는 문자를 설명하는 문자열 또는 Regular Expression 개체입니다.

참고
split 메서드의 결과는 stingObj에서 str이 발생한 각 지점에서 분할된 문자열의 배열입니다.

아래 예제는 split 메서드의 사용법을 보여줍니다.

function SplitDemo()
{
  var s, ss;
  var s = "재빠른 갈색 여우가 느린 황색 개를 덮쳤습니다.";
  // 각 공백 문자를 분할합니다.
  ss = s.split(" ");
  return(ss);
}


split 메서드

split 메서드
적용 대상 		언어 참조

String 개체


split 메서드

split 메서드
참고 		언어 참조

concat 메서드
RegExp 개체
정규식 구문
String 개체 메서드


strike 메서드

strike 메서드 		언어 참조
버전 1

참고 적용 대상

설명
String 개체의 텍스트 양 끝에 <STRIKE> HTML 태그를 삽입합니다.
구문
strVariable.strike( )
"String Literal".strike( )
참고
아래 예제는 strike 메서드의 사용법을 보여줍니다.
var strVariable = "문자열 개체입니다.";
strVariable = strVariable.strike( );
마지막 문을 실행한 후의 strVariable 값은 다음과 같습니다.
<STRIKE>문자열 개체입니다.</STRIKE>
문자열에 이미 태그를 적용했는지 확인하는 과정은 포함되어 있지 않습니다.


strike 메서드

strike 메서드
적용 대상 		언어 참조

String 개체


strike 메서드

strike 메서드
참고 		언어 참조

String 개체 메서드
String 개체 속성


sub 메서드

sub 메서드 		언어 참조
버전 1

참고 적용 대상

설명
String 개체의 텍스트 양 끝에 <SUB> HTML 태그를 삽입합니다.
구문
strVariable.sub( )
"String Literal".sub( )
참고
아래 예제는 sub 메서드의 사용법을 보여줍니다.
var strVariable = "문자열 개체입니다."
strVariable = strVariable.sub( );
마지막 문을 실행한 후의 strVariable 값은 다음과 같습니다.
<SUB>문자열 개체입니다.</SUB>
문자열에 이미 태그를 적용했는지 확인하는 과정은 포함되어 있지 않습니다.


sub 메서드

sub 메서드
적용 대상 		언어 참조

String 개체


sub 메서드

sub 메서드
참고 		언어 참조

String 개체 메서드
String 개체 속성
sup 메서드


substr 메서드

substr 메서드 		언어 참조
버전 3

참고 적용 대상

설명
지정한 위치에서 시작하고 지정한 길이를 갖는 부분 문자열을 반환합니다.
구문
stringvar.substr(start [, length ])

substr 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
stringvar | 필수적인 요소. 부분 문자열을 추출하는 문자열 리터럴이나 String 개체입니다.
start | 필수적인 요소. 원하는 부분 문자열의 시작 위치입니다. 문자열에서 첫 번째 문자의 인덱스는 0입니다.
length | 선택적인 요소. 반환된 부분 문자열에 속해 있는 문자 수입니다.

참고
length가 0이거나 음수이면 빈 문자열이 반환됩니다. 지정하지 않으면 부분 문자열은 stringvar에 지정된 값이 끝날 때까지 계속됩니다.

아래 예제는 substr 메서드의 사용법을 보여줍니다.

function SubstrDemo()
{
  var s, ss;
  var s = "재빠른 갈색 여우가 느린 황색 개를 덮쳤습니다.";
  ss = s.substr(16, 3);
  // "개를"을 반환합니다.
  return(ss);
}


substr 메서드

substr 메서드
적용 대상 		언어 참조

String 개체


substr 메서드

substr 메서드
참고 		언어 참조

String 개체 메서드
String 개체 속성
substring 메서드


substring 메서드

substring 메서드 		언어 참조
버전 1

참고 적용 대상

설명
String 개체 안의 지정된 위치에 있는 부분 문자열을 반환합니다.
구문
strVariable.substring(start, end)
"String Literal".substring(start, end)

substring 메서드 구문은 아래 인수로 구성됩니다.

구성 요소 | 설명
start | 부분 문자열의 시작을 0에서 시작하여 나타내는 인덱스입니다.
end | 부분 문자열의 끝을 0에서 시작하여 나타내는 인덱스입니다.

참고
substring 메서드는 원래 개체에서 파생된 부분 문자열을 포함하는 String 개체를 반환합니다.

substring 메서드는 부분 문자열의 시작점으로 start와 end 중 낮은 값을 사용합니다. 예를 들어 strvar.substring(0, 3)과 strvar.substring(3, 0)은 같은 부분 문자열을 반환합니다.

이에 대한 유일한 예외는 매개 변수가 음수인 경우입니다. 첫 번째 매개 변수가 0보다 작으면 0으로 처리됩니다. 두 번째 매개 변수가 음수이면 첫 번째 매개 변수의 값으로 설정됩니다.

부분 문자열의 길이는 start과 end 사이의 차이에 대한 절대값과 같습니다. 예를 들어, strvar.substring(0, 3)과 strvar.substring(3, 0)에서 반환되는 부분 문자열의 길이는 3입니다.

마지막으로 start와 end는 문자열일 수도 있습니다. 그렇다면 이러한 문자열은 가능하면 정수로 강제 변환되고 그렇지 않다면 매개 변수의 값은 0으로 처리됩니다.

아래 예제는 substring 메서드의 사용법을 보여줍니다.

function SubstringDemo()
{
  var s, ss;
  var s = "재빠른 갈색 여우가 느린 황색 개를 덮쳤습니다.";
  ss = s.substring(16, 19);
  return(ss);
}


substring 메서드

substring 메서드
적용 대상 		언어 참조

String 개체


substring 메서드

substring 메서드
참고 		언어 참조

String 개체 메서드
String 개체 속성
substr 메서드


sup 메서드

sup 메서드 		언어 참조
버전 1

참고 적용 대상

설명
String 개체의 텍스트 양 끝에 <SUP> HTML 태그를 삽입합니다.
구문
strVariable.sup( )
"String Literal".sup( )
참고
아래 예제는 sup 메서드의 사용법을 보여줍니다.
var strVariable = "문자열 개체입니다.";
strVariable = strVariable.sup( );
마지막 문이 실행된 후 strVariable 값은 다음과 같습니다.
<SUP>문자열 개체입니다.</SUP>
문자열에 이미 태그를 적용했는지 확인하는 과정은 포함되어 있지 않습니다.


sup 메서드

sup 메서드
적용 대상 		언어 참조

String 개체


sup 메서드

sup 메서드
참고 		언어 참조

String 개체 메서드
String 개체 속성
sub 메서드


toLowerCase 메서드

toLowerCase 메서드 		언어 참조
버전 1

참고 적용 대상

설명
모든 영문자가 소문자로 변환된 문자열을 반환합니다.
구문
strVariable.toLowerCase( )
"String Literal".toLowerCase( )
참고
toLowerCase 메서드는 영문자가 아닌 문자에는 효과가 없습니다.

아래 예제는 toLowerCase 메서드의 효과를 보여줍니다.

var strVariable = "This is a STRING object";
strVariable = strVariable.toLowerCase( );
마지막 문이 실행된 후 strVariable 값은 다음과 같습니다.
this is a string object


toLowerCase 메서드

toLowerCase 메서드
적용 대상 		언어 참조

String 개체


toLowerCase 메서드

toLowerCase 메서드
참고 		언어 참조

String 개체 메서드
String 개체 속성
toUpperCase 메서드


toUpperCase 메서드

toUpperCase 메서드 		언어 참조
버전 1

참고 적용 대상

설명
모든 영문자가 대문자로 변환된 문자열을 반환합니다.
구문
strVariable.toUpperCase( )
"String Literal".toUpperCase( )
참고
toUpperCase 메서드는 영문자가 아닌 문자에는 효과가 없습니다.

아래 예제는 toUpperCase 메서드의 효과를 보여줍니다.

var strVariable = "This is a STRING object";
strVariable = strVariable.toUpperCase( );
마지막 문이 실행된 후 strVariable 값은 다음과 같습니다.
THIS IS A STRING OBJECT


toUpperCase 메서드

toUpperCase 메서드
적용 대상 		언어 참조

String 개체


toUpperCase 메서드

toUpperCase 메서드
참고 		언어 참조

String 개체 메서드
String 개체 속성
toLowerCase 메서드


AtEndOfLine 속성

AtEndOfLine 속성 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
파일 포인터가 TextStream 파일의 줄 끝 표식 바로 앞에 파일 포인터가 있으면 true를, 그렇지 않으면 false를 반환합니다. 읽기 전용입니다.
구문
object.AtEndOfLine

object는 항상 TextStream 개체의 이름입니다.

참고
AtEndOfLine 속성은 읽기 전용으로 열려있는 TextStream 파일에만 적용됩니다. 그렇지 않으면 오류가 발생합니다.

아래 코드는 AtEndOfLine 속성의 사용법을 보여줍니다.

function GetALine(filespec)
{
  var fso, a, s, ForReading;
  ForReading = 1, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  a = fso.OpenTextFile(filespec, ForReading, false);
  while (!a.AtEndOfLine)
  {
    s += a.Read(1);
  }
  a.Close( );
  return(s);
}


AtEndOfLine 속성

AtEndOfLine 속성
적용 대상 		스크립팅 런타임 참조

TextStream 개체


AtEndOfLine 속성

AtEndOfLine 속성
참고 		스크립팅 런타임 참조

AtEndOfStream 속성


AtEndOfStream 속성

AtEndOfStream 속성 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
TextStream 파일의 끝에 파일 포인터가 있으면 true를, 그렇지 않으면 false를 반환합니다. 읽기 전용입니다.
구문
object.AtEndOfStream

object는 항상 TextStream 개체의 이름입니다.

참고
AtEndOfStream 속성은 읽기 전용으로 열려있는 TextStream 파일에만 적용됩니다. 그렇지 않으면 오류가 발생합니다.

아래 코드는 AtEndOfStream 속성의 사용법을 보여줍니다.

function GetALine(filespec)
{
  var fso, f, s, ForReading;
  ForReading = 1, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.OpenTextFile(filespec, ForReading, false);
  while (!f.AtEndOfStream)
    s += f.ReadLine( );
  f.Close( );
  return(s);
}


AtEndOfStream 속성

AtEndOfStream 속성
적용 대상 		스크립팅 런타임 참조

TextStream 개체


AtEndOfStream 속성

AtEndOfStream 속성
참고 		스크립팅 런타임 참조

AtEndOfLine 속성


Close 메서드

Close 메서드 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
열려있는 TextStream 파일을 닫습니다.

구문
object.Close( );

object는 항상 TextStream 개체의 이름입니다.

참고
아래 예제는 Close 메서드의 사용법을 보여줍니다.

var fso;
fso = new ActiveXObject("Scripting.FileSystemObject");
a = fso.CreateTextFile("c:\\testfile.txt", true);
a.WriteLine("테스트입니다.");
a.Close();


Close 메서드

Close 메서드
적용 대상 		스크립팅 런타임 참조

TextStream 개체


Close 메서드

Close 메서드
참고 		스크립팅 런타임 참조

Read 메서드
Write 메서드


Column 속성

Column 속성 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
TextStream 파일에서 현재 문자가 있는 위치의 열 번호를 반환하는 읽기 전용 속성입니다.

구문
object.Column

object는 항상 TextStream 개체의 이름입니다.

참고
줄 바꿈 문자를 쓴 다음 다른 문자는 쓰지 않았다면 Column은 1입니다.

아래 예제는 Column 속성의 사용법을 보여줍니다.

function GetColumn()
{
  var fso, f, m;
  var ForReading = 1, ForWriting = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.OpenTextFile("c:\\testfile.txt", ForWriting, true);
  f.Write("안녕하십니까?");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ForReading);
  m = f.ReadLine();
  return(f.Column);
}


Column 속성

Column 속성
적용 대상 		스크립팅 런타임 참조

TextStream 개체


Column 속성

Column 속성
참고 		스크립팅 런타임 참조

Line 속성


Line 속성

Line 속성 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
TextStream 파일에서 현재 줄 번호를 반환하는 읽기 전용 속성입니다.

구문
object.Line

object는 항상 TextStream 개체의 이름입니다.

참고
처음 파일을 연 다음 아무 내용도 쓰지 않았다면 Line은 1입니다.

아래 예제는 Line 속성의 사용법을 보여줍니다.

function GetLine()
{
  var fso, f, r
  var ForReading = 1, ForWriting = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject")
  f = fso.OpenTextFile("c:\\textfile.txt", ForWriting, true)
  f.WriteLine("안녕하십니까?");
  f.WriteLine("JScript는 재미있습니다.");
  f.Close();
  f = fso.OpenTextFile("c:\\textfile.txt", ForReading);
  r =  f.ReadAll();
  return(f.Line);
}


Line 속성

Line 속성
적용 대상 		스크립팅 런타임 참조

TextStream 개체


Line 속성

Line 속성
참고 		스크립팅 런타임 참조

Column 속성


Read 메서드

Read 메서드 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
TextStream파일에서 지정한 수만큼 문자를 읽고 결과로 나오는 문자열을 반환합니다.

구문
object.Read(characters)

Read 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 TextStream 개체의 이름입니다.
characters | 필수적인 요소. 파일에서 읽을 문자 수입니다.

아래 예제는 Read 메서드를 사용하여 파일에서 'header'라는 여섯 문자를 읽고 결과로 나오는 문자열을 반환하는 방법을 보여줍니다.

function GetHeader()
{
  var fso, f;
  var ForReading = 1, ForWriting = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.OpenTextFile("c:\\testfile.txt", ForWriting, true);
  f.Write("Header");
  f.Write("1234567890987654321");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ForReading);
  return(f.Read(6));
}


Read 메서드

Read 메서드
적용 대상 		스크립팅 런타임 참조

TextStream 개체


ReadAll 메서드

ReadAll 메서드 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
TextStream 파일 전체를 읽고 결과로 나오는 문자열을 반환합니다.

구문
object.ReadAll( );

object는 항상 TextStream 개체의 이름입니다.

참고
용량이 큰 파일에서 ReadAll 메서드를 사용하면 메모리 리소스를 낭비하게 됩니다. 한 줄씩 파일 읽기와 같은 다른 기술을 사용하여 파일을 입력해야 합니다.

아래 예제는 ReadAll 메서드의 사용법을 보여줍니다.

function GetEverything()
{
  var fso, f;
  var ForReading = 1, ForWriting = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.OpenTextFile("c:\\testfile.txt", ForWriting, true);
  f.Write("Header");
  f.Write("1234567890987654321");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ForReading);
  return(f.ReadAll());
}


ReadAll 메서드

ReadAll 메서드
적용 대상 		스크립팅 런타임 참조

TextStream 개체


ReadAll 메서드

ReadAll 메서드
참고 		스크립팅 런타임 참조

Read 메서드
ReadLine 메서드
Skip 메서드
SkipLine 메서드


Read 메서드

Read 메서드
참고 		스크립팅 런타임 참조

ReadAll 메서드
ReadLine 메서드
Skip 메서드
SkipLine 메서드


ReadLine 메서드

ReadLine 메서드 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
TextStream 파일에서 줄 전체(줄 바꿈 문자 앞까지, 줄 바꿈 문자는 제외)를 읽고 결과로 나오는 문자열을 반환합니다.

구문
object.ReadLine( )

object 인수는 항상 TextStream 개체의 이름입니다.

참고
아래 예제는 Line 속성의 사용법을 보여줍니다.

function GetLine()
{
  var fso, f, r;
  var ForReading = 1, ForWriting = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.OpenTextFile("c:\\testfile.txt", ForWriting, true);
  f.WriteLine("안녕하십니까?");
  f.WriteLine("JScript는 재미있습니다.");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ForReading);
  r =  f.ReadLine();
  return(r);
}


ReadLine 메서드

ReadLine 메서드
적용 대상 		스크립팅 런타임 참조

TextStream 개체


ReadLine 메서드

ReadLine 메서드
참고 		스크립팅 런타임 참조

Read 메서드
ReadAll 메서드
Skip 메서드
SkipLine 메서드


Skip 메서드

Skip 메서드 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
TextStream 파일을 읽을 때 지정한 문자 수만큼 건너뜁니다.

구문
object.Skip(characters)

Skip 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 TextStream 개체의 이름입니다.
characters | 필수적인 요소. 파일을 읽을 때 건너뛸 문자 수입니다.

참고
건너뛴 문자는 버립니다.

아래 예제는 Skip 메서드의 사용법을 보여줍니다.

function SkipDemo()
{
  var fso, f, r;
  var ForReading = 1, ForWriting = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject")
  f = fso.OpenTextFile("c:\\testfile.txt", ForWriting, true);
  f.WriteLine("안녕하십니까?");
  f.WriteLine("JScript는 재미있습니다.");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ForReading);
  f.Skip(6);
  r = f.ReadLine();
  return(r);
}


Skip 메서드

Skip 메서드
적용 대상 		스크립팅 런타임 참조

TextStream 개체


Skip 메서드

Skip 메서드
참고 		스크립팅 런타임 참조

Close 메서드
Read 메서드
ReadAll 메서드
ReadLine 메서드
SkipLine 메서드
Write 메서드
WriteLine 메서드
WriteBlankLines 메서드


SkipLine 메서드

SkipLine 메서드 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
TextStream 파일을 읽을 때 다음 줄을 건너뜁니다.

구문
object.SkipLine( )

object는 항상 TextStream 개체의 이름입니다.

참고
아래 예제는 SkipLine 메서드의 사용법을 보여줍니다.

function SkipLineDemo()
{
  var fso, f, r
  var ForReading = 1, ForWriting = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject")
  f = fso.OpenTextFile("c:\\testfile.txt", ForWriting, true)
  f.WriteLine("안녕하십니까?");
  f.WriteLine("JScript는 재미있습니다.");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ForReading);
  f.SkipLine();
  r = f.ReadLine();
  return(r);
}


SkipLine 메서드

SkipLine 메서드
적용 대상 		스크립팅 런타임 참조

TextStream 개체


SkipLine 메서드

SkipLine 메서드
참고 		스크립팅 런타임 참조

Read 메서드
ReadAll 메서드
ReadLine 메서드
Skip 메서드


Write 메서드

Write 메서드 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
TextStream 파일에 지정한 문자열을 씁니다.

구문
object.Write(string)

Write 메서드는 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 TextStream 개체의 이름입니다.
string | 필수적인 요소. 파일에 쓸 텍스트입니다.

참고
파일에 지정한 문자열을 각 문자열 사이에 공백이나 문자없이 씁니다. WriteLine 메서드를 사용하여 줄 바꿈 문자나 줄 바꿈 문자로 끝나는 문자열을 씁니다.

아래 예제는 Write 메서드의 사용법을 보여줍니다.

function WriteDemo()
{
  var fso, f, r
  var ForReading = 1, ForWriting = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject")
  f = fso.OpenTextFile("c:\\testfile.txt", ForWriting, true)
  f.Write("안녕하십니까?");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ForReading);
  r = f.ReadLine();
  return(r);
}


Write 메서드

Write 메서드
적용 대상 		스크립팅 런타임 참조

TextStream 개체


WriteBlankLines 메서드

WriteBlankLines 메서드 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
TextStream 파일에 지정한 수만큼 줄 바꿈 문자를 씁니다.

구문
object.WriteBlankLines(lines)

WriteBlankLines 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 TextStream 개체의 이름입니다.
lines | 필수적인 요소. 파일에 쓸 줄 바꿈 문자의 수입니다.

참고
아래 예제는 WriteBlankLines 메서드의 사용법을 보여줍니다.

function WriteBlanksDemo()
{
  var fso, f, r;
  var ForReading = 1, ForWriting = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.OpenTextFile("c:\\testfile.txt", ForWriting, true);
  f.Write("안녕하십니까?");
  f.WriteBlankLines(2);
  f.Write("JScript는 재미있습니다!");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ForReading);
  r = f.ReadAll();
  return(r);
}


WriteBlankLines 메서드

WriteBlankLines 메서드
적용 대상 		스크립팅 런타임 참조

TextStream 개체


WriteBlankLines 메서드

WriteBlankLines 메서드
참고 		스크립팅 런타임 참조

Write 메서드
WriteLine 메서드


Write 메서드

Write 메서드
참고 		스크립팅 런타임 참조

WriteBlankLines 메서드
WriteLine 메서드


WriteLine 메서드

WriteLine 메서드 		Scripting 런타임 참조
버전 2

참고 적용 대상

설명
TextStream 파일에 지정한 문자열과 줄 바꿈 문자를 씁니다.

구문
object.WriteLine([string])

WriteLine 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
object | 필수적인 요소. 항상 TextStream 개체의 이름입니다.
string | 선택적인 요소. 파일에 쓸 텍스트입니다. 생략하면 줄 바꿈 문자를 파일에 씁니다.

참고
아래 예제는 WriteLine 메서드의 사용법을 보여줍니다.

var fso, f;
fso = new ActiveXObject("Scripting.FileSystemObject");
f = fso.CreateTextFile("c:\\testfile.txt", true);
f.WriteLine("테스트입니다.");
f.Close();


WriteLine 메서드

WriteLine 메서드
적용 대상 		스크립팅 런타임 참조

TextStream 개체


WriteLine 메서드

WriteLine 메서드
참고 		스크립팅 런타임 참조

Write 메서드
WriteBlankLines 메서드


Microsoft® JScript 언어 참조

JScript 언어 참조 		JScript 자습서
버전 정보

기능 설명
키워드 목록
(사전순)
오류
함수
메서드
개체
연산자
속성
문
ⓒ 1999 Microsoft Corporation. All rights reserved.


JScript 자습서

Microsoft® JScript™
JScript 자습서
 JScript 언어 참조

JScript 정보
JScript 기초 학습
JScript 고급 학습


데이터 형식 변환

데이터 형식 변환 		언어 참조
버전 3

설명
Microsoft JScript는 컨텍스트에 필요하면 자동 형식 변환 기능을 제공합니다. 예를 들어, 컨텍스트의 값에 문자열이 와야 하는 경우 JScript는 이 값을 문자열로 변환하려고 합니다.

언어에서 사용하는 데이터 형식은 모두 6가지이며 모든 값은 다음 중 한 가지 형식을 가집니다.

undefined
undefined 형식은 undefined라는 한 가지 값만을 가집니다.
null
null 형식은 null이라는 한 가지 값만을 가집니다.
Boolean
Boolean 형식은 두 가지 논리값 true와 false를 나타냅니다.
String
작은따옴표 또는 큰따옴표 사이의 문자열은 0개 이상의 유니코드 문자를 갖습니다. 빈 문자열("")의 문자와 길이는 0입니다.
Number
숫자는 IEEE 754 규칙에 따라 정수 또는 부동 소수점 숫자입니다. 또한 다음과 같은 특수 값들도 있습니다.
  • NaN, 숫자가 아님(not a Nmuber)
  • Positive Infinity
  • Negative Infinity
  • Positive 0
  • Negative 0
Object
개체 형식은 개체의 속성과 메서드를 설정한 개체 정의입니다.
아래 표는 컨텍스트가 JScript에 어떤 데이터 형식을 다른 형식으로 변환하도록 요구했을 때 어떤 일이 발생하는지를 정의한 것입니다.

출력 데이터 형식 | 입력 데이터 형식
Undefined | null | Boolean | Number | String | Object
boolean | false | false | 변환 안됨 | +0, -0, NaN 중 하나이면 false, 그렇지 않으면 true | 빈 문자열("")이면 false, 그렇지 않으면 true | true
number | NaN | NaN | true이면 1, false이면 +0 | 변환 안됨 | 숫자로 해석될 수 없으며 NaN으로 해석됨NaN | Number 개체
string "undefined" "null" "true" 또는 "false" 부호를 포함한 숫자의 절대값이며 아래 사항은 예외입니다.
  • NaN은 "NaN"을 반환합니다.
  • +0 또는 -0은 "0"을 반환합니다.
  • + 무한대는 "Infinity"를 반환합니다.
  • - 무한대는 "-Infinity"를 반환합니다.
            • 변환 안됨 String 개체
    object | 런타임 오류 | 런타임 오류 | 새 Boolean 개체 | 새 Number 개체 | 새 String 개체 | 변환 안됨


dimensions 메서드

dimensions 메서드 		언어 참조
버전 3

참고 적용 대상

설명
VBArray의 차원 수를 반환합니다.
구문
array.dimensions( )

array 인수는 VBArray 개체입니다.

참고
dimensions 메서드는 지정한 VBArray의 차원 수를 검색하는 방법을 제공합니다.

아래 예제는 세 부분으로 구성되어 있습니다. 첫째 부분은 Visual Basic 안전 배열을 만드는 VBScript 코드이고, 둘째 부분은 안전 배열의 차원 수와 각 차원의 상한값을 결정하는 JScript 코드입니다. 이 두 부분은 모두 HTML 페이지의 <HEAD> 섹션에 들어갑니다. 셋째 부분은 <BODY> 섹션에 들어가서 다른 두 부분을 실행합니다.

<HEAD>
<SCRIPT LANGUAGE="VBScript">
<!--
Function CreateVBArray()
  Dim i, j, k
  Dim a(2, 2)
  k = 1
  For i = 0 To 2
    For j = 0 To 2
      a(j, i) = k
      k = k + 1
    Next
  Next
  CreateVBArray = a
End Function
-->
</SCRIPT>

<SCRIPT LANGUAGE="JScript">
<!--
function VBArrayTest(vba)
{
  var i, s;
  var a = new VBArray(vba);
  for (i = 1; i <= a.dimensions(); i++)
  {
    s = i + "차원의 상한값";
    s += "은 ";
    s += a.ubound(i)+ "입니다.<BR>";
  }
  return(s);
}
-->
</SCRIPT>
</HEAD>

<BODY>
<SCRIPT language="jscript">
  document.write(VBArrayTest(CreateVBArray()));
</SCRIPT>
</BODY>


dimensions 메서드

dimensions 메서드
적용 대상 		언어 참조

VBArray 개체


dimensions 메서드

dimensions 메서드
참고 		언어 참조

getItem 메서드
lbound 메서드
toArray 메서드
ubound 메서드


getItem 메서드

getItem 메서드 		언어 참조
버전 3

참고 적용 대상

설명
지정한 위치에 있는 항목을 반환합니다.
구문
safeArray.getItem(dimension1[, dimension2, ...], dimensionn)

getItem 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
safeArray | 필수적인 요소. VBArray 개체입니다.
dimension1, ..., dimensionn | 원하는 VBArray 요소의 위치를 정확하게 지정합니다. n은 VBArray의 차원 수에 해당합니다.

아래 예제는 세 부분으로 구성되어 있습니다. 첫째 부분은 Visual Basic 안전 배열을 만드는 VBScript 코드이고, 둘째 부분은 VB 안전 배열을 반복 계산하여 각 요소의 내용을 인쇄하는 JScript 코드입니다. 이 두 부분은 모두 HTML 페이지의 <HEAD> 섹션에 들어갑니다. 셋째 부분은 <BODY> 섹션에 들어가서 다른 두 부분을 실행합니다.

<HEAD>
<SCRIPT LANGUAGE="VBScript">
<!--
Function CreateVBArray()
  Dim i, j, k
  Dim a(2, 2)
  k = 1
  For i = 0 To 2
    For j = 0 To 2
      a(i, j) = k
      document.writeln(k)
      k = k + 1
    Next
    document.writeln("<BR>")
  Next
  CreateVBArray = a
End Function
-->
</SCRIPT>
<SCRIPT LANGUAGE="JScript">
<!--
function GetItemTest(vbarray)
{
  var i, j;
  var a = new VBArray(vbarray);
  for (i = 0; i <= 2; i++)
  {
    for (j =0; j <= 2; j++)
    {
      document.writeln(a.getItem(i, j));
    }
  }
}-->
</SCRIPT>
</HEAD>
<BODY>
<SCRIPT LANGUAGE="JScript">
<!--
  GetItemTest(CreateVBArray());
-->
</SCRIPT>
</BODY>


getItem 메서드

getItem 메서드
적용 대상 		언어 참조

VBArray 개체


getItem 메서드

getItem 메서드
참고 		언어 참조

dimensions 메서드
lbound 메서드
toArray 메서드
ubound 메서드


lbound 메서드

lbound 메서드 		언어 참조
버전 3

참고 적용 대상

설명
차원이 지정된 VBArray에서 사용하는 최저 인덱스 값을 반환합니다.
구문
safeArray.lbound(dimension)

lbound 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
safeArray | 필수적인 요소. VBArray 개체입니다.
dimension | 선택적인 요소. 하한 인덱스 값을 구하는 VBArray의 차원입니다. 생략하면 lbound는 1이 전달된 것처럼 작용합니다.

참고
VBArray가 비어있으면 lbound 메서드는 undefined를 반환합니다. dimension이 VBArray의 차원 수보다 크거나 음수이면 메서드는 "아래 첨자 범위 초과" 오류를 발생시킵니다.

아래 예제는 세 부분으로 구성되어 있습니다. 첫째 부분은 Visual Basic 안전 배열을 만드는 VBScript 코드이고, 둘째 부분은 안전 배열의 차원 수와 각 차원의 하한값을 결정하는 JScript 코드입니다. 안전 배열은 Visual Basic보다는 VBScript에서 많이 만들기 때문에 하한값은 항상 0입니다. 이 두 부분은 모두 HTML 페이지의 <HEAD> 섹션에 들어갑니다. 셋째 부분은 <BODY> 섹션에 들어가서 다른 두 부분을 실행합니다.

<HEAD>
<SCRIPT LANGUAGE="VBScript">
<!--
Function CreateVBArray()
  Dim i, j, k
  Dim a(2, 2)
  k = 1
  For i = 0 To 2
    For j = 0 To 2
      a(j, i) = k
      k = k + 1
    Next
  Next
  CreateVBArray = a
End Function
-->
</SCRIPT>

<SCRIPT LANGUAGE="JScript">
<!--
function VBArrayTest(vba)
{
  var i, s;
  var a = new VBArray(vba);
  for (i = 1; i <= a.dimensions(); i++)
  {
    s = i + "차원의 하한값";
    s += "은 ";
    s += a.lbound(i)+ "입니다.<BR>";
    return(s);
  }
}
-->
</SCRIPT>
</HEAD>

<BODY>
<SCRIPT language="jscript">
  document.write(VBArrayTest(CreateVBArray()));
</SCRIPT>
</BODY>


lbound 메서드

lbound 메서드
적용 대상 		언어 참조

VBArray 개체


lbound 메서드

lbound 메서드
참고 		언어 참조

dimensions 메서드
getItem 메서드
toArray 메서드
ubound 메서드


toArray 메서드

toArray 메서드 		언어 참조
버전 3

참고 적용 대상

설명
VBArray에서 변환된 JScript 표준 배열을 반환합니다.
구문
safeArray.toArray( )

safeArray 인수는 VBArray 개체입니다.

참고
다차원 VBArray를 1차원 JScript 배열로 변환합니다. 각 차원들은 순서대로 연이어 추가됩니다. 예를 들어, 각 차원의 요소가 3개인 3차원 VBArray는 다음과 같이 JScript 배열로 변환됩니다.

다음과 같은 VBArray를 가정합니다: (1, 2, 3), (4, 5, 6), (7, 8, 9). 변환 후 JScript 배열은 다음과 같습니다: 1, 2, 3, 4, 5, 6, 7, 8, 9.

아직까지는 JScript를 VBArray로 변환하는 방법은 없습니다.

아래 예제는 세 부분으로 구성되어 있습니다. 첫째 부분은 Visual Basic 안전 배열을 만드는 VBScript 코드이고, 둘째 부분은 VB 안전 배열을 JScript 배열로 변환하는 JScript 코드입니다. 이 두 부분은 모두 HTML 페이지의 <HEAD> 섹션에 들어갑니다. 셋째 부분은 <BODY> 섹션에 들어가 다른 두 부분을 실행합니다.

<HEAD>
<SCRIPT LANGUAGE="VBScript">
<!--
Function CreateVBArray()
  Dim i, j, k
  Dim a(2, 2)
  k = 1
  For i = 0 To 2
    For j = 0 To 2
      a(j, i) = k
      document.writeln(k)
      k = k + 1
    Next
    document.writeln("<BR>")
  Next
  CreateVBArray = a
End Function
-->
</SCRIPT>
<SCRIPT LANGUAGE="JScript">
<!--
function VBArrayTest(vbarray)
{
  var a = new VBArray(vbarray);
  var b = a.toArray();
  var i;
  for (i = 0; i < 9; i++)
  {
    document.writeln(b[i]);
  }
}
-->
</SCRIPT>
</HEAD>
<BODY>
<SCRIPT LANGUAGE="JScript">
<!--
  VBArrayTest(CreateVBArray());
-->
</SCRIPT>
</BODY>


toArray 메서드

toArray 메서드
적용 대상 		언어 참조

VBArray 개체


toArray 메서드

toArray 메서드
참고 		언어 참조

dimensions 메서드
getItem 메서드
lbound 메서드
ubound 메서드


ubound 메서드

ubound 메서드 		언어 참조
버전 3

참고 적용 대상

설명
차원이 지정된 VBArray에서 사용하는 최고 인덱스 값을 반환합니다.
구문
safeArray.ubound(차원)

ubound 메서드 구문은 아래 요소로 구성됩니다.

구성 요소 | 설명
safeArray | 필수적인 요소. VBArray 개체입니다.
차원 | 선택적인 요소. 상한 인덱스 값을 구하는 VBArray 차원입니다. 생략하면 ubound는 1이 전달된 것처럼 작용합니다.

참고
VBArray가 비어있으면 ubound 메서드는 undefined를 반환합니다. dim이 VBArray의 차원 수보다 크거나 음수이면 메서드는 "아래 첨자 범위 초과" 오류를 발생시킵니다.

아래 예제는 세 부분으로 구성되어 있습니다. 첫째 부분은 Visual Basic 안전 배열을 만드는 VBScript 코드이고, 둘째 부분은 안전 배열의 차원 수와 각 차원의 상한값을 결정하는 JScript 코드입니다. 이 두 부분은 모두 HTML 페이지의 <HEAD> 섹션에 들어갑니다. 셋째 부분은 <BODY> 세션에 들어가서 다른 두 부분을 실행합니다.

<HEAD>
<SCRIPT LANGUAGE="VBScript">
<!--
Function CreateVBArray()
  Dim i, j, k
  Dim a(2, 2)
  k = 1
  For i = 0 To 2
    For j = 0 To 2
      a(j, i) = k
      k = k + 1
    Next
  Next
  CreateVBArray = a
End Function
-->
</SCRIPT>

<SCRIPT LANGUAGE="JScript">
<!--
function VBArrayTest(vba)
{
  var i, s;
  var a = new VBArray(vba);
  for (i = 1; i <= a.dimensions(); i++)
  {
    s = i + "차원의 상한값";
    s += "은 ";
    s += a.ubound(i)+ "입니다.<BR>";
    return(s);
  }
}
-->
</SCRIPT>
</HEAD>

<BODY>
<SCRIPT language="jscript">
  document.write(VBArrayTest(CreateVBArray()));
</SCRIPT>
</BODY>


ubound 메서드

ubound 메서드
적용 대상 		언어 참조

VBArray 개체


ubound 메서드

ubound 메서드
참고 		언어 참조

dimensions 메서드
getItem 메서드
lbound 메서드
toArray 메서드


버전 정보

버전 정보 		언어 참조

아래 표는 호스트 응용 프로그램에 의해 구현되는 Microsoft JScript 버전을 보여줍니다.

호스트 응용 프로그램 | JScript 버전
1.0 | 2.0 | 3.0 | 4.0 | 5.0
Microsoft Internet Explorer 3.0 | x
Microsoft Internet Information Server 1.0 | x
Microsoft Internet Explorer 4.0 | x
Microsoft Internet Information Server 4.0 | x
Microsoft Windows Scripting Host 1.0 | x
Microsoft Visual Studio 6.0 | x
Microsoft Internet Explorer 5.0 | x
Microsoft Internet Information Services 5.0 | x

아래 표는 JScript 언어의 기능과 처음 도입된 버전을 보여줍니다.

언어 요소 | 처음 도입된 버전
1.0 | 2.0 | 3.0 | 4.0 | 5.0
$1...$9 속성 | x
abs 메서드 | x
acos 메서드 | x
ActiveXObject 개체 | x
+ 연산자 | x
anchor 메서드 | x
arguments 속성 | x
Array 개체 | x
asin 메서드 | x
= 연산자 | x
atan 메서드 | x
atan2 메서드 | x
atEnd 메서드 | x
big 메서드 | x
& 연산자 | x
<< 연산자 | x
~ 연산자 | x
| 연산자 | x
>> 연산자 | x
^ 연산자 | x
blink 메서드 | x
bold 메서드 | x
Boolean 개체 | x
break 문 | x
caller 속성 | x
catch 문 | x
@cc_on 문 | x
ceil 메서드 | x
charAt 메서드 | x
charCodeAt 메서드 | x
, 연산자 | x
//(한 줄 주석 문) | x
/*..*/(여러 줄 주석 문) | x
비교 연산자 | x
compile 메서드 | x
concat 메서드(Array) | x
concat 메서드(String) | x
조건부 컴파일 | x
조건부 컴파일 변수 | x
?: 연산자(삼항) | x
constructor 속성 | x
continue 문 | x
cos 메서드 | x
데이터 형식 변환 | x
Date 개체 | x
-- 연산자 | x
delete 연산자 | x
description 속성 | x
dimensions 메서드 | x
/ 연산자 | x
do...while 문 | x
E 속성 | x
Enumerator 개체 | x
== 연산자 | x
Error 개체 | x
escape 메서드 | x
eval 메서드 | x
exec 메서드 | x
exp 메서드 | x
fixed 메서드 | x
floor 메서드 | x
fontcolor 메서드 | x
fontsize 메서드 | x
for 문 | x
for...in 문 | x
fromCharCode 메서드 | x
Function 개체 | x
Function 문 | x
getDate 메서드 | x
getDay 메서드 | x
getFullYear 메서드 | x
getHours 메서드 | x
getItem 메서드 | x
getMilliseconds 메서드 | x
getMinutes 메서드 | x
getMonth 메서드 | x
GetObject 함수 | x
getSeconds 메서드 | x
getTime 메서드 | x
getTimezoneOffset 메서드 | x
getUTCDate 메서드 | x
getUTCDay 메서드 | x
getUTCFullYear 메서드 | x
getUTCHours 메서드 | x
getUTCMilliseconds 메서드 | x
getUTCMinutes 메서드 | x
getUTCMonth 메서드 | x
getUTCSeconds 메서드 | x
getVarDate 메서드 | x
getYear 메서드 | x
Global 개체 | x
> 연산자 | x
>= 연산자 | x
=== 연산자 | x
@if 문 | x
if...else 문 | x
++ 연산자 | x
index 속성 | x
indexOf 메서드 | x
!= 연산자 | x
Infinity 속성 | x
input 속성 | x
instanceof 연산자 | x
isFinite 메서드 | x
isNaN 메서드 | x
italics 메서드 | x
item 메서드 | x
join 메서드 | x
Labeled 문 | x
lastIndex 속성 | x
lastIndexOf 메서드 | x
lbound 메서드 | x
length 속성(Array) | x
length 속성(Function) | x
length 속성(String) | x
< 연산자 | x
<= 연산자 | x
link 메서드 | x
LN2 속성 | x
LN10 속성 | x
log 메서드 | x
LOG2E 속성 | x
LOG10E 속성 | x
&& 연산자 | x
! 연산자 | x
|| 연산자 | x
match 메서드 | x
Math 개체 | x
max 메서드 | x
MAX_VALUE 속성 | x
min 메서드 | x
MIN_VALUE 속성 | x
% 연산자 | x
moveFirst 메서드 | x
moveNext 메서드 | x
* 연산자 | x
NaN 속성(Global) | x
NaN 속성(Number) | x
NEGATIVE_INFINITY 속성 | x
new 연산자 | x
!== 연산자 | x
Number 개체 | x
number 속성 | x
Object 개체 | x
연산자 우선 순위 | x
parse 메서드 | x
parseFloat 메서드 | x
parseInt 메서드 | x
PI 속성 | x
POSITIVE_INFINITY 속성 | x
pow 메서드 | x
prototype 속성 | x
random 메서드 | x
RegExp 개체 | x
Regular Expression 개체 | x
정규식 구문 | x
replace 메서드 | x
return 문 | x
reverse 메서드 | x
round 메서드 | x
ScriptEngine 함수 | x
ScriptEngineBuildVersion 함수 | x
ScriptEngineMajorVersion 함수 | x
ScriptEngineMinorVersion 함수 | x
search 메서드 | x
@set 문 | x
setDate 메서드 | x
setFullYear 메서드 | x
setHours 메서드 | x
setMilliseconds 메서드 | x
setMinutes 메서드 | x
setMonth 메서드 | x
setSeconds 메서드 | x
setTime 메서드 | x
setUTCDate 메서드 | x
setUTCFullYear 메서드 | x
setUTCHours 메서드 | x
setUTCMilliseconds 메서드 | x
setUTCMinutes 메서드 | x
setUTCMonth 메서드 | x
setUTCSeconds 메서드 | x
setYear 메서드 | x
sin 메서드 | x
slice 메서드(Array) | x
slice 메서드(String) | x
small 메서드 | x
sort 메서드 | x
source 속성 | x
split 메서드 | x
sqrt 메서드 | x
SQRT1_2 속성 | x
SQRT2 속성 | x
strike 메서드 | x
String 개체 | x
sub 메서드 | x
substr 메서드 | x
substring 메서드 | x
- 연산자 | x
sup 메서드 | x
switch 문 | x
tan 메서드 | x
test 메서드 | x
this 문 | x
throw 문 | x
toArray 메서드 | x
toGMTString 메서드 | x
toLocaleString 메서드 | x
toLowerCase 메서드 | x
toString 메서드 | x
toUpperCase 메서드 | x
toUTCString 메서드 | x
try 문 | x
typeof 연산자 | x
ubound 메서드 | x
- 연산자 | x
unescape 메서드 | x
>>> 연산자 | x
UTC 메서드 | x
valueOf 메서드 | x
var 문 | x
VBArray 개체 | x
void 연산자 | x
while 문 | x
with 문 | x