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Learning the PADS User Interface 
 

 

What you will learn: 

• Modeless Commands 

• Panning & Zooming 

• Object Selection Methods 

Note: This tutorial will use PADS Layout to demonstrate the user interface.  Unless otherwise 

noted, the techniques shown below also apply to PADS Logic. 

 

1.  Begin by opening a sample PCB Design. 

 

1.1   Start PADS Layout.  Select  Start > Programs > Mentor Graphics SDD > 
PADS2005 SP2 > PCB Layout > PADS Layout.  The PADS Layout welcome screen 

should appear. 

 

 
 

1.2   Open a sample PCB Design.  Select File > Open.  Browse to C:\PADS 
Projects\Samples and open preview.pcb.  You should see a PCB layout similar to the 

one below... 
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1.3   You can use this sample PCB file to test the user interface features described in this 

tutorial. 

2.   Modeless Commands 

Modeless commands are simple shortcut keys that can be used to change settings or 

perform a given action at any time.  To enter a modeless command, simply type the 

specified shortcut key(s) followed by any necessary parameters and press enter.  When you 

begin typing a modeless command, the Modeless Command window will appear.  In 

addition to displaying the user's input, the Modeless Command window will also provide 

realtime help for the command currently being entered.   

 

A few of the available modeless commands are listed below.  For a complete list, select 

Help > Modeless Commands. 

Shortcut key Description 

 UN <n>   Multiple undo command. <n> is the number of operations to undo 

 RE <n>  Multiple redo command. <n> is the number of operations to redo. 

 S <s>  Part search. <s> is the reference designator. 

 G <n>  Set the design grid spacing to <n>.   

 GD <n>  Set the display grid spacing to <n> 

 M  Display the shortcut menu for the current mode. 

Note: In PADS Layout, the grid commands use the design units specified in Tools > 
Options > Global > Design Units.  Although this setting will default to mils, the 



4 
 

preview PCB file is set to inches. 

 

As an example, try searching for the part labeled D2: 

Enter the search shortcut key, s, followed by the part reference, d2. 

 
This will bring component D2 into view and center the mouse pointer over it. 

3.   Panning & Zooming 

There are several methods available to move about a design and adjust the magnification 

level. 

 

3.1   Using Zoom Mode.   

You can enter zoom mode by selecting View > Zoom, pressing Ctrl + W, or by clicking 

the   button on the toolbar. 

While in zoom mode, the following features are available: 

• Zoom in one level - Left Click. 

• Zoom out one level - Right Click.  

• Zoom in by a specific amount - Click and hold the left mouse button in the center of 

the area you wish to view and drag the mouse up.  Release the left mouse button 

when the desired zoom level is shown. 

• Zoom out by a specific amount - Click and hold the left mouse button in the center 

of the area you wish to view and drag the mouse down.  Release the left mouse 

button when the desired zoom level is shown. 

When you are finished zooming, you can exit zoom mode by pressing escape. 

 

3.2   Panning 

 

You can pan around the design by using any of the following methods: 

• Scrollbars - You can use the scrollbars at the right edge and bottom of the design 

window to pan vertically and horizontally. 

• Mouse Scroll Wheel - If your mouse is equipped with a scroll wheel, you can use it 

to pan vertically. 

• Insert Key - To center the design view on the mouse pointer, press the insert key. 

3.3   View Sheet / Board 

 

To view the entire sheet (PADS Logic) or board (PADS Layout) press the Home key. 

 

3.4    Middle Mouse Button 

 

If your mouse has a scroll wheel or middle mouse button, the following features will be 

available: 

• Center View - Click and release the middle mouse button to center the view on the 

mouse pointer. 
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• Zoom In - Click and hold the middle mouse button in the center of the area you wish 

to view and drag the mouse up.  Release the middle mouse button when the desired 

zoom level is shown. 

• Zoom Out - Click and hold the middle mouse button in the center of the area you 

wish to view and drag the mouse down.  Release the middle mouse button when the 

desired zoom level is shown. 

 

4.   Object Selection Methods 

 

4.1   Selection Filter 

 

The selection filter will allow you to 'filter out' the object types that you are not interested in, 

making it easier to select specific components. 

To access the selection filter, select Edit > Filter... or press Ctrl+Alt+F.  The 

selection filter window for PADS Layout is shown below. 

 

 
 

Checked objects are able to be selected, unchecked objects are filtered out.  In PADS 

Layout it is also possible to filter out specific layers of the pcb by using the Layer tab. 

 

As an example, open the selection filter and press the Nothing button.  Then select the Vias 

check box and close the selection filter window.  You will now only be able to select 

vias.  If you press Ctrl+A, all of the vias will be selected.  This could be useful if, for 

instance, you wanted to quickly change the size or type of all of the vias.  Press escape or 

click in an empty area to unselect the vias. 

 

4.2   Selection Filter Shortcuts 

 

There is a faster method of changing the filter options.  With nothing in the design view 

selected, right click to display the shortcut menu.  The top portion of this menu consists of 

selection filter presets and is shown below. 
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Selecting a filter preset is the same as making the corresponding changes in the selection 

filter window.  For example, selecting the Select Components preset is the same as only 

checking Parts and Glued Parts in the filter window. 

 

Return the selection filter to it's default state by right clicking and selecting Select 
Anything from the top of the menu. 

 

4.3   Selection Cycle (PADS Layout Only) 

 

In crowded pcb designs it may become difficult to select a particular object, even with the 

use of the selection filter.  To overcome this problem you can cycle through all the nearby 

objects by using the Tab key. 

 

To demonstrate this feature, select the top left pin of part U3.  (Hint: Use the modeless 

search command, S, to locate U3 quickly.)  Now repeatedly press the tab key to cycle 

between nearby parts and traces. 

This completes the user interface tutorial.
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Creating a new Part Type using the 
PCB & CAE Decal Wizards 

 
 

What you will learn: 

• Creating and Managing User Libraries 

• Creating a PCB Decal 

• Creating a CAE Decal 

• Creating a Complete Part 

1.   Create a custom user library 

 

Before creating your first new part type, you will need to setup a user library.  This library 

will be saved to your network shared drive, allowing you to access it from any computer in 

the VCU School of Engineering. 

 

1.1   Start PADS Layout.  Select  Start > Programs > Mentor Graphics SDD > 
PADS2005 SP2 > PCB Layout > PADS Layout.  The PADS Layout welcome screen 

should appear. 

 

 
 

1.2   Open the Library Manager.  Select  File > Library...    
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1.3   Press the Create New Lib... button.  Browse to the H: Drive and create a new 

folder named Pads Library.  Open this folder and type user.pt4 in the file name 

field.  Then press the Save button. 

 

 
 

1.4    Once you have created the new library, close the library manager. 

 

Note:  To access this library in future windows sessions: open the library manager and 

press the Manage Lib List... button.  Then press Add..., browse to H:\Pads 
Library and select the user.pt4 file. 

 

2.   Create a PCB footprint using the PCB Decal Wizard 

 

We will now create a PCB footprint for the National Semiconductor LM2675M-3.3 voltage 

regulator chip.  The relevant datasheet can be found here.  (Page 24 contains information 

on the part's physical dimensions). 

 

2.1   Open the PCB Decal Editor.  In PADS Layout, select Tools > PCB Decal 
Editor.  The PADS Layout window should now look similar to the image below. 
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2.2   Start the PCB Decal Wizard.  Enable the Drafting Toolbar by pressing the  

button.  From the Drafting Toolbar press the Wizard button: .  The Pin Wizards window 

will now appear. 

 

 
 

2.3   We will be creating a decal for the 8-pin Small Outline Package, so select the SOIC 

tab. 
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2.4   Make the following changes: 

In the Decal area, select Horizontal and type 8 in the Pin Count box. 

In the Silk Screen area, type 55 in the Spacing from Pin Center box. 

In the Pins area, type 24 in the Width box, 90 in the Length box and 50 in the Pin Pitch box. 

In the Pin Shape area, choose Rectangle. 

In the Row Pitch area, type 200 in the Value box, and select Center to Center. 

 
 

2.5    When the Pin Wizards window looks like the one above, press OK.  You will now 

return to the PCB Decal Editor which should look like the image below. 
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2.6   Save the PCB footprint to your user library.  Select  File > Save Decal.  In the 

Save PCB Decal to Library dialog, select  H:\Pads Library\user for the library and type 

LM2675 in the Name of PCB Decal field. 

 

 
 

2.7   Press OK.  When it asks if you want to create a new Part Type, say yes, then press 

OK in the Save Part Type to Library dialog box. 

 

 
 

2.8   Exit the PCB Decal Editor and PADS Layout.  Select  File > Exit Decal Editor 

to return to PADS Layout.  Then select  File > Exit to close PADS Layout. 

3.   Create a schematic symbol using the Part Editor & CAE Decal Wizard. 

 

We will now create a schematic symbol for the National Semiconductor LM2675M-3.3 

voltage regulator chip. 
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3.1    Open PADS Logic.  Select  Start > Programs > Mentor Graphics SDD > 
PADS2005 SP2 > System Design > PADS Logic.  The PADS Logic welcome screen 

should appear. 

 

 
 

3.2   Add your user library to the Library List.  Select File > Library... 

 

 
 

Then press the Manage Lib List... button. 
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Press Add..., browse to H:\Pads Library and select user.pt4. 

After adding your user library, press OK and then close the library manager. 

 

3.3   Open the Part Editor.  Select Tools > Part Editor.  The PADS Logic window 

should now look similar to the image below. 

 

 
 

3.4   Open the LM2675 part type that you created in part 2 of this tutorial.  Select File > 
Open...  On the Select type of editing item dialog, choose Part Type and press OK. 
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The Get Part Type from Library dialog will appear.  In the filter area, select the H:\Pads 
Library\user library and type * in the items box.  Press Apply.  Now select LM2675 from 

the Part-Types list and press OK. 

 

 
 

3.5   Edit the part's electrical properties.  Press the  button on the toolbar to open the 

Part Information window. 

 

 
 

Under Logic Family, select ANA. 

 

3.6   Specify the (not yet created) schematic decal.   

 

Select the Gates tab. 
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Press the Add button.  Click in the CAE Decal 1 field, type LM2675 and press Enter.  Then 

press the OK button. 

 

 
 

3.7   Open the CAE Decal Editor.  Press the  button on the toolbar to open the CAE 

Decal Editor.  The Select Gate Decal dialog will pop up. 

 

 
 

Press OK to continue.  PADS Logic will display a warning stating that the selected decal 

doesn't exist and will be created.  Press OK. 
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The CAE Decal Editor should now appear. 

 

 
 

3.8   Start the CAE Decal Wizard.  Press the  button on the Decal Editing toolbar to 

launch the Decal Wizard. 

 

 
 

3.9   Make the following changes: 

In the Pin Spacing area, type 300 in the Horizontal box and 200 in the Vertical box. 

In the Left Pins area and Upper Pins area, set the Pin Count to 1. 

In the Right Pins area and Lower Pins area, set the Pin Count to 2. 
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When the specified values have been entered, press OK.  The CAE Decal window should 

now look similar to the one below. 

 

 
 

Note: You may wish to zoom in on the decal while making changes to the pins.  To enter 

zoom mode, press Ctrl + W.  Use the left mouse button to zoom in and the right mouse 

button to zoom out.  Press Esc to exit zoom mode. 

 

3.10   Name and Number the pins.  Right-click in an empty area and select the Select 
Terminals menu item.  Double click on the leftmost pin.  The Terminal properties dialog 

will open. 
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Select File > Save.  Then Select File > Exit Part Editor. 

 

You can now use the LM2675 part type in your PADS Logic and PADS Layout designs. 
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Creating a simple 3.3V Regulator 
Circuit using PADS 

 
 

What you will learn: 

• Creating a Circuit Schematic with PADS Logic 

• Creating a PCB Design with PADS Layout 

• Routing a PCB Design with PADS Router 

• Linking PADS Logic to PADS Layout & PADS Router 

• Generating Gerber Files with PADS Layout 

Note: This tutorial assumes that you've completed the PADS User Interface tutorial and the 

New Part Type tutorial. 

 

1.   Creating a Circuit Schematic using PADS Logic 

 

1.1   Begin by opening PADS Logic.  Select  Start > Programs > Mentor Graphics 
SDD > PADS2005 SP2 > System Design > PADS Logic. 

 

 
 

1.2    Ensure that your user library is loaded by using the library manager - File > 
Library.  (Refer to section 3 of the New Part Tutorial for step-by-step instructions). 
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1.3   Start a new design by selecting File > New.  Your PADS Logic window should look 

something like this. 

 

 
 

1.4   Use the Add Part window to add an LM2675 voltage regulator to your design. 

To add a part to your design, click on the  button on the design toolbar.  This will open 

the Add Part from Library window as shown below. 
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To locate the LM2675 part, you will need to select your custom library from the Library 

dropdown list in the filter.  Select H:\Pads Library\user.  Ensure that the Items field 

contains a single asterisk * and then press Apply.  This will filter the results, displaying only 

the parts in your user library.  The window should look like the one below. 

 

 
 

Press the Add button.  An outline of the LM2675 part will appear below the mouse pointer 

while it is within the design window.  Close the Add Part window and click somewhere near 

the center of the sheet to add an instance of the LM2675 part.  Press escape to exit add 

part mode.  You schematic window should look similar to the one below. 
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Note:  You may wish to zoom in on the LM2675 before completing the following 

steps.  (Refer to the User Interface Tutorial if necessary). 

 

1.5   Add capacitors to your design. 

Open the add part window by clicking the  button on the toolbar.  In the library dropdown 

list, choose the misc library 

(C:₩MentorGraphics₩2005PADS₩SDD_HOME₩Libraries₩misc).  In the Items menu, type 

CAP* and then press Apply.  This will filter the results to display only the parts starting with 

'CAP' that exist in the 'misc' library. 

 

 
 

Select the part named CAP7343 from the list and press Add.  Move the Add Part window so 

that most or all of the design area is visible.  Your screen should look similar to the one 

below. 
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Place the CAP7343 capacitor to the left of the LM2675 as shown above.  Place a second 

CAP7343 to the far right as shown in the schematic below. 
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Now select CAP1206 from the Add Part window, press Add and close the window.  Before 

adding the capacitor to your design, press Ctrl + R to rotate it 90 degrees.  Place the 

capacitor to the right of the LM2675 as shown below. 
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1.6   Add additional circuit components to your design. 

 

Add an inductor and diode to your design as shown in the image below.  Use the IND-

MOLDED part for the inductor and the DIODE part for the diode.  Both of these parts are 

found in the 'misc' library. 
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1.7   Assign values to your components. 

 

Ensure that part selection is enabled by right clicking in an empty area and selecting the 

Select Gates option.  This can also be achieved by pressing the  button on the filter 

toolbar. 

Double click on the left-most capacitor.  This will open the Part Properties window as 

shown below. 

 

 
 

Click on the Attributes button to open the Part Attributes window. 
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Scroll down to the Value field, double click and enter 100uF in the text box. 

 

 
 

Press OK to close the Part Attributes window and return to the Part Properties window.  By 

default, the CAP7343 part will not display its value in the schematic.  To change this, click 

the Visibility button to open the Part Text Visibility window. 

 

 
 

Check the Value checkbox on the right side to enable display of the capacitor's 

value.  Press OK to close the Part Text Visibility window and then press Close to close the 

Part Properties window.  Your schematic should now look like the one below. 
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Repeat this process for the other components, assigning the values listed below: 

• Right Capacitor - 100uF 

• Middle Capacitor - 0.01uF 

• Inductor - 33uH 
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1.8   Change the PCB footprints assigned to the inductor and diode. 

 

The IND-MOLDED and DIODE parts both default to using through-hole footprints.  We will 

change these parts to use surface mount footprints.   

Double click the inductor to open the Part Properties window.  Click on the PCB Decals 

button to open the PCB Decals Assignment window. 

 

 
 

Click Browse...  The Get PCB Decal from Library window will appear.  This window 

functions almost identically to the Add Part window. 
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The footprint we will be using for the inductor is named IND7 and is found in the 'common' 

library. 

 

 
 

Select this decal and press OK.  Then press OK in the PCB Decal Assignment window and 

close the Part Properties window. 

 

Repeat this process for the diode, selecting the DIODE2 footprint from the 'common' library. 

 

 
 

1.9   Adding Header Pins to your design. 

 

We will now add a pair of 2-pin headers to the schematic.  One 2-pin header will be used 

for the input voltage source (12V), and the other will be used for the 3.3V output. 

Open the Add Part window.  Select the 'connect' library from the dropdown list and enter 

HEADER* in the Items filter.  Press Apply and select HEADER02 from the list of parts. 
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Note: PADS implements connectors as if they were multi-gate IC's.  In this case, each pin 

is treated as a separate gate and must be added individually. 

 

Add two header pins to the left of the schematic, and two to the right (Use Ctrl+F to mirror 

a part horizontally).  Your schematic should look similar to the one below. 

 

 
 

1.10   Connecting your parts. 

 

Press the button on the design toolbar.  This will activate Add Connection Mode.  Place 

the cursor on pin 7 of the LM2675 and click once to begin adding a connection.  Move the 

cursor to the left until it is horizontally aligned with the left capacitor.  Click once.  This will 

add a vertex / pivot point to your connection.  Move the cursor down and click on the top 

terminal of the left capacitor to complete the connection.  Your schematic should look like 

the image below. 
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Continue adding connections until your schematic is fully connected as shown below. 
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Note: To remove a misplaced connection, ensure that the selection filter allows selecting 

connections.  Then click on the connection you wish to remove and press delete.  You can 

also activate Delete Mode by pressing the  button on the design toolbar.  This will allow 

you to remove objects with a single click. 

 

1.11   Adding Power and Ground Connections 

 

To add a ground connection to your design, enter Connection Mode.  Begin by starting a 

new connection from the bottom-most net and moving down 2 or 3 spaces.  Then right 

click and select Ground from the context menu. 

 

 
 

Position the ground symbol at the desired location and click once to place it. 

 



35 
 

 
 

Adding a power connection is done in a similar manner.  Begin by starting a new 

connection from the net connected to pin 7 of the LM2675 and moving up.  Right click and 

select Power from the context menu.  Position the power symbol and click once to place 

it.  Repeat this process for the net connected to the top right header pin.  Your schematic 

should look like the one below. 
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By default, all power connections are automatically connected to a net named +5V.  We will 

need to change this for our design. 

Double click on the left power symbol.  This will open the Net Properties window shown 

below. 

 

 
 

Change the Net Name field to +12V and select the Net Name Label check box.  Press OK. 

Repeat this process for the right power symbol, setting the Net Name to +3.3V.  The 

completed schematic should look similar to the image shown below. 
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1.12   Save your schematic.  Select File > Save and save the schematic to H:\PADS 
Tutorial\Tutorial.sch. 

2.   Creating a PCB Design using PADS Layout 

2.1   Linking PADS Logic to PADS Layout 

 

Before you can begin laying out your PCB, you must transfer the schematic netlist to PADS 

Logic.  The recommended way of doing this is to create an application link between PADS 

Logic and PADS Layout.  In addition to allowing automatic synchronization of the schematic 

and layout information, linking also enables a feature known as cross-probing.  This 

basically allows the selection of a part or net in PADS Logic to result in the selection of the 

corresponding PCB footprint or trace in PADS Layout, and vice versa. 

 

To connect PADS Logic to PADS Layout, select Tools > PADS Layout.  The Connect to 

PADS Layout dialog will appear. 

 

 
 

Since we have not yet created a PCB Design file, click the New button.  A new PADS Layout 

window should appear as shown below. 

Note: On subsequent connections to PADS Layout or PADS Router, you will click Open and 

select your existing design file. 
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Note: If you have the available screen real estate, it is recommended that you resize the 

PADS Logic and PADS Layout windows so that both are visible simultaneously.  A multi-

monitor setup is especially useful for this. 

 

2.2   Transferring the Netlist from PADS Logic to PADS Layout 

 

Note: Before transferring the netlist, ensure that your custom user library has be added to 

Layout's Library List.  Refer to the New Part Tutorial if necessary. 

 

While PADS Layout is still open, switch back to PADS Logic.  The PADS Layout Link window 

should be visible. 

 

 
 

Click on the Preferences Tab and select the Compare PCB Decal Assignments 

checkbox.  This will ensure that the modified inductor and diode footprints are properly sent 

to PADS Layout. 
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Now click on the Design Tab.  Press the Send Netlist button to transfer your design to PADS 

Layout. 

 

 
 

Switch back to the PADS Layout window.  You should now see a cluster of parts located at 

the origin (Location 0,0). 

 

 
 

2.3   Creating the board outline. 

After transferring the netlist, you will need to create a board outline.  Press the  button to 

enable the Drafting Toolbar.   

On the Drafting Toolbar, click on the  button to enter board outline mode. 
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Since our circuit is extremely simple, a 1.0 inch by 0.7 inch PCB should be large enough. 

Note: For the following steps, refer to the location indicator at the bottom-right corner of the 

window.  Locations are given assuming that design units are in mils. 

 

Place the cursor at the origin (location 0, 0) and click once to begin drawing the outline. 

Move the cursor up to location 0, 700 and click once to form the left edge of the PCB. 

Move the cursor right to location 1000, 700 and click once to form the top edge of the PCB. 

Move the cursor down to location 1000, 0 and double click to complete the PCB outline 

(forming the right edge and bottom edge of the PCB). 

 

Your PADS Layout window should look similar to the one shown below. 

 

 
 

2.4   Setup the Board Layers 

 

Before placing the components on the board, you should modify the board's Layer 

Definitions.  Select Setup > Layer Definition... to open the Layers Setup dialog. 
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Our board will only need two electrical layers.  If more than two electrical layers are 

assigned, press the Modify... button and enter 2 in the popup window to fix this. 

It is also recommended that you disable any unused layers.  Click on the 

Enable/Disable... button to display the Enable/Disable Layers window. 

 

 
 

Uncheck layers 3 to 20 and layer 25.  Press OK to return to the Layer Setup window and 

then press OK again to confirm your changes. 

 

2.5   Positioning circuit components 

 

To make it easier to select individual parts, select Tools > Disperse Components.  This 

will reposition the components around the perimeter of the board, as shown below. 
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With nothing selected, right-click in an empty area and select the Select Components option 

from the context menu. 

You can now begin placing the components within the board outline using drag and drop.   

To rotate components, press Ctrl + R.   

To flip a component to the opposite side of the board, press Ctrl + F. 

One possible layout is shown below. 

 



43 
 

 
 

Note: You may need to resize the placement grid to fit all of the parts on the board.  Use 

the modeless grid command, G, to resize the grid.  Ex: type g 50 to set the grid interval to 

50 mils. 

 

2.6   Position the Reference Designators 

 

You should now take the time to reposition the reference designators for your design.  With 

nothing selected, right-click and choose Select Documentation from the context 

menu.  You can now click and drag the reference designators to reposition them as shown 

below. 
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2.7   Save your PCB Layout.   

 

Select File > Save and save the file as H:\PADS Tutorial\Tutorial.pcb. 

Close PADS Layout and restore the PADS Logic window.  Close the PADS Layout Link 

window if it is still open. 

3.   Routing your design using PADS Router 

 

3.1   Linking PADS Logic to PADS Router 

 

You will now connect PADS Logic to PADS Router in the same way that you connected to 

PADS Layout.  Select Tools > PADS Router.  The Connect to PADS Router window will 

appear. 

 

 
 

Since we already have a PCB file, select Open...  Then browse to H:\PADS Tutorial and 

open Tutorial.pcb.  The PADS Router program should open as shown below. 
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3.2   View/Modify the Design Properties 

 

To view the current design properties, right-click and select Properties from the context 

menu.  This will open the Design Properties window shown below. 

 

 
 

From this window you can adjust a plethora of attributes that affect your design.  Select the 

various tabs to get an idea of all the options available.  Now select the Routing tab. 
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From this tab you can control, among other things, the default width of your PCB's traces.   

Change the Recommended value to 15 and the Maximum value to 20.  Then press OK to 

confirm your changes. 

 

3.3   Use the PADS AutoRouter to route your design. 

 

We will now use the built-in autorouter to route the pcb design.  Select Tools > 
Autoroute > Start to begin the autoroute process.  After a few seconds, the design 

should be fully routed as shown below. 

 

 
 

3.4   Verify your design 
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You should now run a design check to ensure there are no routing errors with your 

design.  Select Tools > Verify Design.  The results of the test will appear in the Output 

Window located at the bottom right corner of the screen. 

 

 
 

3.5   Save your design.  Select File > Save and then close PADS Router, returning to 

PADS Logic.  Close the PADS Router Link dialog if it is still open. 

4.   Finishing your design in PADS Layout 

4.1   Linking PADS Logic to PADS Layout. 

 

You will now connect to PADS Layout again and complete the final steps in your 

design.  Select Tools > PADS Layout to open the Connect to PADS Layout window.  Select 

Open..., browse to H:\PADS Tutorial and open Tutorial.pcb.  PADS Layout should 

open, displaying your fully routed design. 
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4.2   Adding Copper Pours to your PCB 

You will now add a copper pour to each side of your PCB.  Enable the drafting toolbar by 

pressing the  button.  Now press the  button to enter Copper Pour Mode. 

 

Move the cursor over the origin and click once to start drawing the outline of the copper pour. 

Move the cursor to location 0,700 and click to draw the left edge. 

Move the cursor to location 1000,700 and click to draw the top edge. 

Move the cursor to location 1000, 0 and double click to complete the copper pour outline. 

 

The Add Drafting should appear as shown below. 
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Select Top from the Layer dropdown list and select GND from the Net dropdown list.  Press 

OK. 

Repeat this process using the same coordinates and choosing Bottom for the Layer.  Select 

GND for the Net. 

 

After the copper pours have been added, the design window should appear as shown below. 

 

 
 

Note:  If you need to re-route your design, you will need to remove the copper pours and 
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save your file before opening it in PADS Router.  If you fail to do this, PADS Router may not 

correctly route your PCB. 

 

4.3   Flooding your design. 

 

You will now flood your design, filling in the copper pours with copper.  Select Tools > 
Pour Manager to open the Pour Manager window. 

 

 
 

Press Start to begin the flood process.  If there were no errors, close the Pour 

Manager.  Your design window should now look similar to the image below. 

 

 
 

If there were any errors, press the Setup button to open the Options > Thermals window.   
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Any copper pour errors can often be corrected by changing the type or width of the thermal 

spokes.  Changing the type to 'Flood Over' should always prevent the 'too few spokes 

generated' error.  This, of course, changes the method used to connect the copper pour to 

vias and pads of the same net.  Note: Not all copper pour errors are critical, it may not be 

deemed necessary to modify the Thermals parameters. 

 

4.4   Verify Design 

 

You should now check your completed design for errors.  Select Tools > Verify Design 

to open the Verify Design window. 

 

 
 

Select Clearance from the Check list and press start.  If there are no errors, the following 

dialog will be displayed. 

 

 
 

Press OK and select Connectivity from the Check list.  Press Start to run the check.  If there 

were no errors, close the Verify Design window.  If any errors were detected, you should 
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locate the error image on your design and correct the problem. 

 

Note:  If you need to re-route your design, you will need to remove the copper pours and 

save your file before opening it in PADS Router.  If you fail to do this, PADS Router may not 

correctly route your PCB. 

 

4.5   Save your design.  Select File > Save to save your completed PCB design. 

5.   Generating Gerber Files 

The steps needed to generate the appropriate gerber files will vary depending on the number 

of layers used and the PCB service that will be creating the board.  This section will show 

the steps needed to create gerber files for a PCBExpress E2 2-Layer Board. 

 

5.1    Select File > CAM to open the Define CAM Documents window. 

 

 
 

5.2   Top Layer 

 

Press the Add... button to display the Add Document window. 

 

 
 

Type Top in the Document Name field. 

Select Routing/Split Plane from the Document Type dropdown list and select Top from 

the popup window. 
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Press the Layers button to open the Select Items window. 

 

 
 

Check the Board Outline checkbox and press OK.  The Add Document window should 

look like the one below. 

 

 
 

Press the Device Setup button to display the Photo Plotter Setup window. 
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Press the Regenerate button and click yes.  Press OK. 

 

Press the Options button to display the Plot Options window. 

 

 
 

Change the Justification setting to Scale to Fit and press OK. 

 

Press the Preview Selections button on the Add Document window to verify your settings. 
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If everything looks correct, close the preview window and then press OK to add the Top 

document. 

 

 
 

5.3   Bottom Layer 

 

Repeat part 5.2, substituting the Bottom Layer for the Top Layer in each step. 
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5.4   Silkscreen Top 

 

Press the Add... button. 

Type Silkscreen Top for the Document Name. 

Select Silkscreen from the Document Type list and then select Top from the popup 

window. 

Press the Layers button to open the Select Items window.  Select Top from the Selected 

List and uncheck Part Type.  Press OK. 

Press the Options button and set the Justification to Scale to Fit.  Press OK. 

Press the Preview Selections button to verify your design. 

 

 
 

Close the preview and press OK to add the Silkscreen Top document. 
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5.5   Silkscreen Bottom 

 

Repeat Section 5.4, substituting Silkscreen Bottom for Silkscreen Top. 

 

 
 

5.6   Solder Mask Top 

 

Press the Add... button. 

Type Solder Mask Top for the Document Name. 

Select Solder Mask from the Document Type dropdown list and then select Top from the 

popup list. 

Press the Options button and set the Justification to Scale to Fit.  Press OK. 

Press the Preview Selections button to verify your design. 
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Close the preview and press OK to add the Solder Mask Top document. 

 

 
 

5.7   Solder Mask Bottom. 

 

Repeat Section 5.6, substituting Solder Mask Bottom for Solder Mask Top. 
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5.8   Drill Drawing 

 

Press the Add... button. 

Type Drill Drawing for the Document Name. 

Select Drill Drawing from the Document Type dropdown list and then select Top from 

the popup list. 

Press the Options button and set the Justification to Scale to Fit. 

Press the Drill Symbols button and enter 1000 for Location X. 

 

 
 

Press OK to close the Drill Drawing Options and Press OK again to return to the Add 

Document window. 

 

Press the Preview Selections button to verify your design. 
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Close the preview and press OK to add the Drill Drawing document. 

 

 
 

5.9   NC Drill Document 

 

Press the Add... button. 

Type NC Drill for the Document Name. 

Select NC Drill from the Document Type dropdown list. 

Press the Preview Selections button to verify your design. 
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Close the preview and press OK to add the NC Drill document. 

 

 
 

5.10   Generate the Gerber Files 

 

Click on the CAM Directory dropdown and select <Create>.  Enter H:\PADS 
Tutorial\Cam\ for the CAM Subdirectory.  Press OK. 

Highlight all of the documents and press Run. 
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Click Yes to generate the Gerber Files. 

 

After the files have been successfully generated, press Save and then close the CAM 

Documents window. 

 

5.11   Verify Gerber Files 

 

Before sending your Gerber Files to the PCB Company, it is recommended that you verify 

them with an external tool. 

PCBExpress recommends using the PentaLogix ViewMate Gerber Viewer. 

http://www.pentalogix.com/Download/download.html 

 

You have now completed the Mentor Graphics PADS Tutorial. 
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