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기본화면 구성 

OrCAD Capture 기본 화면 
 

 
 

1. Toolbar 

 
Capture Toolbar 

(Create Document) - 새 프로젝트를 만든다. 

(Open Document) - 기존 프로젝트를 연다. 

(Save Document) - 현재 프로젝트 파일이나 도면을 저장한다. 

(Print) - 현재 도면을 출력한다. 

(Cut to clipboard) - 선택된 개체를 잘라내기 한다. 

(Copy to clipboard) - 선택된 개체를 클립보드로 복사한다. 
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(Paste from clipboard) - 클립보드에 있는 내용을 붙여넣기한다. 

(Undo) - 이전 작업을 취소한다. 

(Redo) - 취소된 작업을 다시 실행한다. 

(Zoom In : I) - 현재 화면을 확대한다. 

(Zoom out : O) - 현재 화면을 축소한다. 

(Zoom to region) - 특정 영역만큼 확대한다. 

(Zoom to all) - 도면 전체를 작업창 안에 표시한다. 

(Annotate) - 부품 참조자에 대한 정렬작업을 한다. 

(Back annotate) - 보드에서 변경된 내용을 디자인에 재적용한다. 

(Design Rules Check) - 현재 도면에 Design Rules Check를 한다. 

(Create netlist) - 도면에 대한 Netlist를 생성한다. 

(Cross reference parts) - 도면에 사용된 부품심볼의 경로 목록을 생성한다. 

(Bill of materials) - 부품 목록을 생성한다. 

(Snap To grid) - Grid 기반 작업 선택 여부를 설정한다. 

(Area Select) - 부품 선택시 부분선택 또는 전체 선택에 대한 설정을 한다. 

(Drag connected object) - 부품 간 연결방법에 대한 설정을 한다. 

(Project manager) - 프로젝트 매니저 창을 선택한다. 

(Help) - 도움말을 볼 수 있다. 

 

Tool Palette 

(Select) - 개체 선택 시 사용한다. 

(Place part : P) - 도면에 사용할 부품 선택 시 사용한다. 

(Place wire : w) - 부품 간 Net 연결에 사용한다. 

(Place net alias : N) - Net에 이름을 붙여주는데 사용한다. 

(Place bus : B) - Bus line을 표시하는데 사용한다. 

(Place junction : J) - Net의 접점을 표시하는데 사용한다. 

(Place bus entry : E) - Bus와 Net을 연결하는데 사용한다. 

(Place power : F) - Power Symbol을 표시하는데 사용한다. 

(Place ground : G) - Ground Symbol을 표시하는데 사용한다. 

(Place hierarchical block) - 계층 블록 구조를 그리는데 사용한다. 

(Place port) - 입출력 등 다양한 포트를 표시하는데 사용한다. 
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(Place pin) - 계층 블록의 Pin을 정의하는데 사용한다. 

(Place off-page connector) - 페이지간 Net 연결에 사용한다. 

(Place no connect : X) - 사용하지 않는 Pin을 표시하는데 사용한다. 

(Place line) - 도면에 Line을 그리는데 사용한다. 

(Place polyline : L) - 도면에 다각형을 그리는데 사용한다. 

(Place rectangle) - 도면에 사각형을 그리는데 사용한다. 

(Place ellipse) - 도면에 타원을 그리는데 사용한다. 

(Place arc) - 도면에 호를 그리는데 사용한다. 

(Place text : T) - 도면에 글자를 나타내는데 사용한다. 

 (MRU : Place Part) : 가장 최근에 사용되어진 부품 리스트를 표시 

 

OrCAD PCB Editor 기본 화면 

 
 

 File Toolbars 

(New) - 새 작업을 한다. 

(Open) - 기존 작업을 연다. 

(Save) - 현재 작업을 저장한다. 
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 Edit Toolbars 

(Move) - 개체를 이동시킬 수 있다. 

(Copy) - 개체를 원하는 형태로 복사할 수 있다. 

(Delete) - 선택된 개체를 지울 수 있다. 

(Undo) - 현재 작업을 취소한다. 

(Redo) - Undo된 작업을 다시 실행한다. 

(Fix) - 개체에 고정속성을 준다. 

(Unfix) - 고정속성이 설정된 개체의 Fix 속성을 해제시켜 준다. 

 

 View Toolbars 

(Unrats All) - 모든 Ratsnest를 숨겨준다. 

(Rats All) - 모든 Ratsnest를 보여준다. 

(Zoom Points) - 클릭하고 확대할 영역을 지정한다. 

(Zoom Fit) - 보드 전체 크기를 작업창에 보여준다. 

(Zoom In) - 화면을 확대한다. 

(Zoom Out) - 화면을 축소한다. 

(Zoom Previous) - 이전 크기로 설정한다. 

(Zoom Selection) - 드래그하여 그린 부분만큼 확대를 한다. 

(Redraw) - 화면을 다시 그린다. 

 

 Setup Toolbars 

(Grid Toggle) - Grid를 On/Off 할 수 있다. 

(Color192) - Color 설정을 할 수 있다. 

(Shadow Toggle) - Shadow 모드를 On/Off 할 수 있다. 

(Xsection) - 적층(Stackup)구조를 편집할 수 있다. 

(Cmgr) - Constraints Manager 창을 활용할 수 있다. 

(Keepin Router) - Router Keepin 영역을 생성한다. 
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(Keepin Package) - Package Keepin 영역을 생성한다. 

 

 AppMode Toolbars 

(GeneralEdit) - 일반 편집모드(Place, Route, Copy, Move 등)로 실행한다. 

(EtchEdit) - Etch 편집모드(Sliding, Delay tuning, Smoothing Cline 등)로 실행한다. 

 

 Manufacture Toolbars 

(Artwork) - Gerber 파일을 생성할 수 있다. 

(Ncdrill Param) - Drill 파일을 생성을 위한 파라미터를 설정할 수 있다. 

(Ncdrill Legend) - Drill 파일의 범례(차트)를 생성할 수 있다. 

(Odb_Out) - Allegro Board 파일을 Odb 파일로 Export 할 수 있다. 

 

 Misc Toolbars 

(Reports) - 다양한 Reports를 생성할 수 있다. 

(Drc Update) - DRC를 업데이트한다. 

(Help) - 도움말을 볼 수 있다. 

 

 Display Toolbars 

(Show Element) - 구성요소의 속성을 볼 수 있다. 

(Cns Show) - 선택된 개체의 Constraints 속성을 볼 수 있다. 

(Show Measure) - 지정한 지점의 길이 측정을 할 수 있다. 

(Hilight) - 선택된 개체를 하이라이트 시켜 볼 수 있다. 

(Dehilight) - 하이라이트 속성을 없앨 수 있다. 

(Waive Drc) - DRC Marker를 제거한다. 

 

 Shape Toolbars 

(Shape Add) - Shape(Copper)를 새로 생성한다. 
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(Shape Add Rect) - 사각형모양의 Shape(Copper)를 생성한다. 

(Shape Add Circle) - 원모양의 Shape(Copper)를 생성한다. 

(Shape Select) - Shape(Copper)를 선택할 수 있다. 

(Shape Void Element) - Positive Shape에서 Pin, Via에 자동으로 Void를 생성한다. 

(Shape Void Polygon) - 다각형모양의 Void(Anti-Copper)를 만들 수 있다. 

(Shape Void Rectangle) - 사각형모양의 Void(Anti-Copper)를 만들 수 있다. 

(Shape Void Circle) - 원모양의 Void(Anti-Copper)를 만들 수 있다. 

(Shape Edit Boundary) - 기존 Shape의 경계를 수정할 수 있다. 

(Island_Delete) - 불필요한 Shape(Copper)를 제거할 수 있다. 

 

 Dimension Toolbars 

(Create Detail) - 디자인에서 선택한 영역을 설정비율에 따라 생성해 준다. 

(Linefont) - Line의 속성(Dot, Solid, Phantom 등)을 설정한다. 

(Dimension Linear) - 선택한 지점의 길이를 표시해 준다. 

(Dimension Datum) - 선택한 개체의 Datum에 대한 Dimension을 표시해 준다. 

(Dimension Angular) - 다른 Segment 간 Dimension을 표시해 준다. 

(Leader Only) - Leader만 표시해 준다. 

(Leader Diametral) - 직경 Leader를 표시해 준다. 

(Leader Radial) - 곡선에 대한 Leader를 표시해 준다. 

(Leader Ballon) - 풍선 모양의 Leader를 표시해 준다. 

(Leader Chamfer) - Chamfer 된 부분의 Leader를 표시해 준다. 

 

 Place Toolbars 

(Place Manual) - 부품배치 상자에서 부품을 수동 선택해서 배치할 수 있다. 

(Place Manual - H) - 부품배치 상자를 숨길 수 있다. 
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 Route Toolbars 

(Add Connect) - 핀간 라우팅을 새로 그릴 수 있다. 

(Slide) - 기존 라우팅된 Etch를 슬라이드시킬 수 있다. 

(Custom Smooth) - 곡선이나 꺾인 Etch를 직선으로 바꿀 수 있다. 

(Vertex) - 기존 Etch에 꼭짓점을 추가해 수정할 수 있다. 

(Create Fanout) - SMD용 소자의 핀에 대해 Fanout을 생성한다. 

 

 Add Toolbars 

(Add Line) - Non-Etch 라인을 추가할 수 있다. 

(Add Rect) - Non-Etch 사각형을 그릴 수 있다. 

(Add Text) - 텍스트를 입력할 수 있다. 

(Text Edit) – 입력 되어진 텍스트를 수정할 수 있다. 

 

 Command Window 

 
명령어의 실행과 상태를 표시하며 직접 명령어를 작성할 수 있다. 

 

 Control Panel Windows 
 

- 마우스 포인터를 가까이 가져가면 나타나고 멀어지면 사라지는 Fold-away 창 

- Visibilitity : 현재작업화면의 컬러 설정 

- Find : 선택시 대상물 선정 

- Options : 속성을 지정 
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User Preference(작업을 유용하게 해주는 사용자 환경설정) 
 

Setup > User Preference 선택시 
 

Input > no_dragpopup 

 

 
CTRL 키를 누르지 않고 마우스 오른쪽 버튼으로 Stroke를 그릴 수 있다. 

 

Ui > pcb_cursor 

 

 
Cursor를 십자 포인트나 풀스크린 커서로 설정할 수 있다. 

 

Shape > new_shape_fill_nt 

 

 
점 형태로 면을 표시할 수 있다. 

 

Opengl > draw_etch_outline 

 

 
Etch의 Outline 선을 표시할 수 있다. 

 

Etch > allegro_etch_length_on 

 

 
Routing시 현재 길이를 표시해 준다. 
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Drawing > db_tier_nomsg 

 

 
DB Warning 메시지 경고창이 나타나지 않도록 설정한다. 

 

Autosave > 속성 

 

 
Autosave 폴더를 선택한다. 10 분 간격으로 Backup이란 이름으로 저장된다. 

 

Display > display_drcfill 

 

 
DRC Marker의 내부를 채워서 표시해 준다. 

 

Design_paths > padpath, psmpath 

 

 
Pad(*.pad)와 Package Symbol(*.psm, *.fsm, *.ssm, *.osm, *.bsm)의 경로를 추가해 준다. 

 

 

점선 사각형을 눌러 새로 한 줄을 추가할 수 있다.  

경로는 Browse 버튼을 눌러 왼쪽처럼 추가해 준다. 

 

 

 



                                       

 

12 

 

Part Ⅰ. Digital Clock  

- Capture를 이용하여 새로운 도면을 작성할 수 있다. 

- 새로운 라이브러리를 생성, 수정할 수 있다. 

- 도면의 구조를 이해하고 활용할 수 있다. 

- PCB Editor를 이용하여 설계를 할 수 있다. 

- 전체적인 설계과정을 이해한다. 

- 새로운 Footprint를 생성할 수 있다. 

- 설계의 기본 기능을 숙지한다. 

-  

Ⅰ. Capture를 이용한 회로도 작성 

1. 환경설정 
- 메뉴 File의 New를 선택한다. 

 

 
- 파일명과 저장위치를 설정 후 ok를 선택한다. 

 

- 새로운 작업화면이 생성되면 기본적인 설정을 한다. 
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- 메뉴 Option의 Autobackup 과 Schematic page Properties를 설정한다.  

 

 
  

- AutoBackup의 설정은 저장위치와 저장시간, 백업파일의 수를 설정한다. 

  

         
 

- 도면의 사이즈는 인쇄를 목적으로 하는 도면이면 mm 기준으로 설정한다 
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- option의 preference를 선택한다. 

- Miscellaneous 탭을 선택하여 Auto Recovery 항목을 선택한다. 

 (정전이나 컴퓨터의 이상 발생시 작업 중이던 데이터를 복원해주는 기능이다) 

 

 
- 설정을 마치고 난 후 도면을 작성한다. 

 

2. 새로운 Part 생성하기  
 

[ FND 만들기 ] 

- 메뉴 File > New를 선택하여 Library를 선택한다. 

- 프로젝트 매니저창에 보면 Library 폴더 아래에 Library1.olb라는 새로운 라이브러리가 

 생성된 것이 보인다. 
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- datasheet에서 핀번호를 확인한다. 

[PIN 배치도] 

- 새로 생성된 library1.olb를 클릭하고 메뉴 Design > New Part를 선택하거나 마우스 

오른쪽 버튼을 누르면 뜨는 팝업메뉴에서 New Part를 선택한다. 

 

                     
 

- 속성입력창이 뜨면 Name [FND5160] Part Reference Prefix [FND]로 입력한다.  

 

 
 

• Part Reference Prefix : 부품 참조번호로 FND1, FND2..로 증가한다. 

• Part per Pkg : 패키지 부품을 만들 때 내부에 만들어지는 게이트 수 

• Package Type  : Homogeneous: 동일한 모양의 부품으로 구성. 

: Heterogeneous: 다른 모양으로 구성 

• Part Numbering : 각 부품이 숫자나 영문으로 표기 
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- Part Editor가 열리면 바탕화면에 점선의 사각형이 보인다. 점선의 사각형 안쪽 영역은 

그림정보와 핀네임이 들어갈 부분이고, 바깥영역은 핀이 배치되어질 영역이다.  

이 영역은 마우스로 꼭지점을 클릭한 상태로 드래그해서 크거나 작게 할 수 있다. 

 

 
 

-  메뉴 Place > Pin 또는 툴팔레트 Place Pin 아이콘을 선택한다. 

Name과 Number에 핀 배치도를 보고 기입한다. 

A : 7 , B : 6 , C : 4 , D : 2 , E : 1 , F : 9 , G : 10 , COM1 : 3 , COM2 : 8 , DOT 

POINT(점) : 5 

 
 

- name이 같으면 경고창이 뜬다. 이름을 다르게 표기한다. 

 

• Line: 3눈금길이.  

• Short : 1눈금 길이 

• Zero Length: 길이 없음. 
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• 주로 Passive 타입 

• Power를 선택시 Pin Visiable 속성을 바꿀 수 있으며 Pin name이  

Net Alias로 적용되므로 조심해야 한다.  

 

 

 

 

- 파란색 사각형 바깥쪽으로 차례대로 핀을 배치시킨다.  

 

 
 

- 배치를 하면서 파란색 점선 사각형의 크기를 조절한다. 

- 핀네임은 보이지 않도록 설정한다. (대신 그림을 삽입시킨다.) 

- 메뉴 Option > Properties 또는 화면의 빈 공간을 더블 클릭한다. 

- Pin Names Visible 항목을 False로 설정한다. 

- OK를 누르면 화면에서 Pin Name이 사라진다. 
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- Part의 그림 정보를 작성한다. 

-  메뉴 Place > Line 또는 Rectangle을 선택하거나 툴팔레트에서 Place Line 아이콘  

또는 Place Rectangle 아이콘 을 누른다. 

- 화면의 파란색 점선을 따라 사각형을 그린다. 

-  메뉴 Place > Line 또는 툴팔레트에서 Place Line 아이콘을 선택하여, 그림과 같이  

  그린 후 그려진 선을 더블 클릭하여 속성을 굵은 선으로 바꾼다. 

 

 
 

- 하나의 선을 굵게 했으면 마우스 오른쪽 버튼의 Copy를 이용하여 복사, Paste로 붙여

넣기를 한다. 

- Dot Point를 그릴 때는 먼저 툴바의 Snap Grid On/Off 아이콘 를 눌러 Snap Grid를 

해제시킨다. 

- 메뉴 Place > Ellipse 또는 툴팔레트 Place Ellipse를 선택한다. Shift 키를 누르고 클릭 

후 드래그하면 그리드에 관계없이 원형이 그려진다. 

 

 
 

- 그린 후에는 반드시 Snap Grid를 On시킨다. 

- 메뉴 File > Save를 눌러 현재 작업 폴더에 저장시킨다. 

- 메뉴 File > Close를 눌러 Part Editor를 종료한다. 
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새로운 라이브러리 불러오기 

- 새로 생성된 Part는 자동으로 라이브러리에 추가되지 않는다. 

-  툴팔레트 Place part 아이콘을 누르거나 , 단축키 [ P ]를 누른다. 

- Add Library 버튼을 눌러 작성한 라이브러리가 있는 폴더로 이동 후 라이브러리를 추

가한다. 

 
 

- Libraries 선택창의 라이브러리중 파란색으로 선택되어진 부분만을 검색한다. 

다른 부품을 검색할 때는 라이브러리창을 한번 클릭한 후 모두 드래그하거나 Ctrl + 

A(전체선택)을 실행한다.  

- FND를 회로도에 배치시킨다. 

 

3. 부품배치 및 배선 
 Project Manager 창으로 이동한다. 

New page를 추가한다.  

Rename으로 [Display 와 main으로 이름을 변경한다.] 
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 - Main Sheet를 열고 회로도를 작성한다. 

   

U1

AT90S8515

RST9

XTAL218 XTAL119

GND 20

OC1B 29ALE 30

ICP
31

VCC40

PC0/A8 21

PC1/A9
22

PC2/A10
23

PC3/A11 24

PC4/A12 25

PC5/A13 26

PC6/A14 27

PC7/A15 28

PD0/RXD
10

PD1/TXD 11

PD2/INT0 12

PD3/INT1 13

PD4 14

PD5/OC1A
15

PD6/WR
16

PD7/RD 17

PB0/T0
1

PB1/T12

PB2/AIN03

PB3/AIN14

PB4/SS5

PB5/MOSI
6

PB6/MISO
7

PB7/SCK8

PA0/AD039

PA1/AD1
38

PA2/AD2
37

PA3/AD336

PA4/AD435

PA5/AD534

PA6/AD633

PA7/AD732

Y1
40Mhz

C1

104
C2

104

D0
D1
D2
D3
D4
D5
D6
D7

J1

CON2

1
2

VCC

MINUTE-LED
HOUR_LED

X1

X2

X1
X2

D[0..7]

SECOND_SELECT
MINUTE_SELECT
HOUR_SELECT

D[0..7]

BLOCK

SWITCH_IN

H/M_SEL

MANU_IN

OPERATION

ADJUST
VCC

 
 

• 부품 : AT90S8515 / CRYSTAL / CAP NP / CON2  

• 심벌 : GND / VCC_ARROW / Off-page connector / port 

• 계층도면 블록 : Block 

 

- 부품을 불러와 배치한다. 

- Place Wire : 핀과 핀사이의 연결 

- Place Bus :  bus 작성 

- Place Net Alias : net에 이름을 부여 

- Place Power / Place Ground : 전원이나 그라운드 심벌을 불러옴 

- Place off-page connector : [평면도면] 다른 도면의 net에 연결됨 

- Place port : [단일도면] 도면에서 같은 이름을 가진 net에 연결됨 

- Place Hierarchical Block : [계층도면] 계층구조 도면으로 연결하는 블록 

- Place pin : 계층 도면과 연결될 포트 

- Place no connect : 사용하지 않는 핀 
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- Net alias 작성 

작성 문법은 영문문자 + 숫자로 이루어지며, wire상에만 배치된다. 

버스에 작성시에는 영문문자 [숫자..숫자]의 형식을 가지며 버스상에만 배치가 된다. 

Net alias는 1씩 증가된 값으로 연속적인 배치가 이루어진다.  

  

- 계층구조 블록 작성 

 Place Hierarchical Block을 선택한다. 

 

 
 

그림과 같이 작성을 하고 OK를 선택한다. 

계층블록이 놓일 위치에 사각형박스를 그린다. 

Place pin을 선택한다. Place pin은 계층블록이 선택되어 있어야 활성화된다. 

 

 
 

블록 내부에 4개의 핀을 놓는다. 
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- Place off-page connector 접속 

아이콘을 선택하고 신호의 방향을 맞춘다. 

Wire에는 바로 접속이 되나 버스에는 Net alias부터 작성해야 연결이 된다. 

 

- Place port 작성 

아이콘을 선택하고 wire에 배치한 후 Net alias를 부여한다. 

 

- AT90S8515 부품의 GND 핀 보이게 수정하기 

부품을 선택한 후 마우스 오른쪽 버튼을 눌러 popup 메뉴 중 edit part를 선택한다. 

부품 수정창이 열리면 부품 하단에 보이는 GND 핀을 더블 클릭한다. 

핀의 속성창이 열리면 pin type를 Zero Length에서 line으로 바꾸고 하단의 Pin Visible을 

선택한다. 

 

  
 

- OK를 선택한 후 메뉴 File > Close를 선택한다. 

- Update Current를 선택한다. 
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4. 계층도면 작성하기 

 
- 계층블록을 선택한 후 마우스 오른쪽 버튼을 눌러 Pop-up메뉴 중 Descend hierarchy

를 선택한다. 

16.0 버전부터는 더블 클릭을 하면 하위도면으로 이동한다. 

 

 
 

- 새로운 페이지의 이름을 작성하는 창이 뜨면 이름을 준 다음 OK를 선택한다. 

 

 
포트만 4개가 있는 페이지가 생성되어 있다. 

 

- 도면 사이즈를 설정한다. [ A4 ] 

포트를 적당한 위치로 이동 후 도면을 작성한다.  
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ADJUST
OPERATION

MANU_INH/M_SEL

SW1

hour/min_select

SW2

manual_increase

C1
104

C2
104

D1

LED

R1
330

SW3

Adjust/Operation

D2

LED

R2
330

R3
1k

R4
10k

R5
10k

VCC
VCC

VCC

 
 

• 부품 : SW PUSHBUTTON / SW PUSHWHEEL SPDT / CAP NP / R / LED  

• 심벌 : VCC_ARROW / GND  

 

5. 평면도면 작성하기 
- Project Manager창으로 이동한다. 

- DISPLAY 도면을 연다. 

Off-page connect에 주의하며 도면을 작성한다. 

 

FND2

FND5160

7
6
4
2
1
9

10

3

8

5

 부품의 핀위치를 

FND1

FND51607 6 4 2 1 9 10

3 8 5

모양으로 수정한다. 
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D[0..7]

R1
330

R2
330

HOUR_SELECT

D
0

D
1

D
2

D
3

D
4

D
5

HOUR_LED

D
6

D
7

VCC VCC MINUTE_LED

D2

LED

R8
330

VCC VCC

D[0..7]

R3
330

R4
330

MINUTE_SELECT

D
0

D
2

D
1

D
5

D
4

D
3

D
7

D
6

VCC
VCC

VCC VCC

FND3

FND5160

7 6 4 2 1 9 10

3 8 5 FND4

FND5160

7 6 4 2 1 9 10

3 8 5

U5

74LS47

D
0

7

D
1

1

D
2

2

D
3

6

B
I/R

B
O

4
R

B
I

5
LT

3

A
13

B
12

C
11

D
10

E
9

F
15

G
14

U6

74LS47
D

0
7

D
1

1

D
2

2

D
3

6

B
I/R

B
O

4
R

B
I

5
LT

3

A
13

B
12

C
11

D
10

E
9

F
15

G
14

U7

74HC573D
0

2

D
1

3

D
2

4

D
3

5

D
4

6

D
5

7

D
6

8

D
7

9

LE
11

O
E

1

Q
0

19

Q
1

18

Q
2

17

Q
3

16

Q
4

15

Q
5

14

Q
6

13

Q
7

12

R5
330

SECOND_SELECT

R6
330

D
1

D
0

D
4

D
3

D
2

D
6

D
5

D
7

VCC
VCC

VCC VCC

FND5

FND5160

7 6 4 2 1 9 10

3 8 5 FND6

FND5160

7 6 4 2 1 9 10

3 8 5

U8

74LS47

D
0

7

D
1

1

D
2

2

D
3

6

B
I/R

B
O

4
R

B
I

5
LT

3

A
13

B
12

C
11

D
10

E
9

F
15

G
14

U9

74LS47

D
0

7

D
1

1

D
2

2

D
3

6

B
I/R

B
O

4
R

B
I

5
LT

3

A
13

B
12

C
11

D
10

E
9

F
15

G
14

U10

74HC573D
0

2
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1

3

D
2

4

D
3

5

D
4

6

D
5

7

D
6

8

D
7

9

LE
11

O
E

1

Q
0

19

Q
1

18

Q
2

17

Q
3

16

Q
4

15

Q
5

14

Q
6

13

Q
7

12

D1

LED

R7
330

FND1

FND5160

7 6 4 2 1 9 10

3 8 5 FND2

FND5160

7 6 4 2 1 9 10

3 8 5

U2

74LS47

D
0

7

D
1

1

D
2

2

D
3

6

B
I/R

B
O

4
R

B
I

5
LT

3
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13
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12
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11

D
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F
15
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14

U3

74LS47

D
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7

D
1

1

D
2

2

D
3

6
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I/R

B
O

4
R

B
I

5
LT

3

A
13

B
12

C
11

D
10

E
9

F
15

G
14

U4

74HC573D
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2

D
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3

D
2

4

D
3

5

D
4

6

D
5

7

D
6

8

D
7
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0
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• 부품 : 74LS47 / 74HC573 / LED / R / FND5160 

• 심벌 : VCC_ARROW / GND / Off-page connector 

 
 

6. 회로도 마무리 
- Project  Manager창에서 Reference 정리, DRC, BOM을 실행한다. 

 

 
 

e 
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- Annotate 아이콘을 선택한다. 

 

 
 

- Reset part reference to “?” 를 선택하고 확인을 클릭한다.  

- 다시 Annotate 아이콘을 선택한다. 

- Incremental reference update 를 선택하고 확인을 클릭한다.  

- 다시 Annotate 아이콘을 선택한다. 

- Add intersheet reference를 선택하고 확인을 클릭한다. 

- 설정창이 뜨면 Format 항목에서 Prefix와 suffix를 기입한다. 
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- OK를 선택한다. 

 

회로도를 확인해 본다.  

모든 Reference번호가 정렬이 되었는지와 Off-page connector에 Page가 표시되어 있는지 

확인한다. 
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- DRC 아이콘을 선택한다. 

- 기본 설정으로 검사를 실행한다. 

- 확인을 클릭한다.  

- BOM 아이콘을 선택한다. 

- 기본 설정을 그대로 두고 확인을 클릭한다. 

 

Project Manager 창에서 Output 폴더 아래에 drc 파일과 bom 파일이 생성된 것을 확인

할 수 있다. 

 

 
 

 

 

 

 

 

 

 

 

 



                                       

 

29 

 

Ⅱ. Footprint 생성 및 검색 

 

1. Footprint 선정 
- Capture에서 생성한 BOM 파일을 확인한다. 

 

  Bill Of Materials  

 

Item  Quantity Reference   Part 

___________________________________________________________ 

 

1 4 C1,C2,C3,C4   104 

2 4 D1,D2,D3,D4   LED 

3 6 FND1,FND2,FND3,FND4,FND5, FND5160 

  FND6 

4 1 J1    CON2 

5 10 R1,R2,R3,R4,R5,R6,R7,R8, 330 

   R12,R13 

6 2 R9,R10    10k 

7 1 R11    1k 

8 1 SW1    Adjust/Operation 

9 1 SW2    hour/min_select 

10 1 SW3    manual_increase 

11 6 U1,U2,U3,U4,U5,U6  74LS47 

12 3 U7,U8,U9   74HC573 

13 1 U10    AT90S8515 

14 1 Y1    40Mhz 

 

- BOM 파일을 통해 검색해야 할 Footprint를 설정한다. 

 

PCB Editor 제공 Footprint 생성할 Footprint 

LED  

JUMPER2 

SOIC16 

SOIC20 

DIP40_6 

D1…D4  

J1 

74LS47 

74HC573 

AT90S8515 

SM_3216  

FND510 

SW_SLIDE_3P 

TACT_SW2 

HC49 

R1..13 / C1..4  

FND1..6 

SW1 

SW2 / SW3 

Y1 
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2. TACT_SW2 생성 
- 기본 조건 : 2 pin, 기판형 

 

       
- 위의 그림에서 필요한 정보를 수집한다. 

• 부품 크기 : 6.0 X 3.5 mm 

• Hole 크기 : Ø1.25 ± 0.05 [mm]  

• Pin pitch (pin to pin) : 6.5 ± 0.1 [mm] 

 

- 심벌을 생성하는 순서는 아래와 같이 이루어진다. 

1. 핀 생성 (확장자 *.pad로 저장된다) 

2. 핀 배치 및 외형치수, 기타 정보(확장자 *.dra로 저장) 

3. 저장을 하면 이 두 가지가 합해진 심벌이 자동 생성된다(확장자 *.psm) 

 

1) PIN 생성하기  

시작 > 프로그램 > OrCAD > OrCAD PCB Editor Utilities > Pad Designer의 경로로 이

동한다. 

① Type  

- Through : 기판의 윗면에서 아랫면까지 관통하는 일반적인 핀. 부품 핀이나 비아(via)에  

쓰인다. 

- Blind/Buried : 다층기판에 쓰이는 핀(via) 

- Single : SMD(Surface Mounted Devices 표면 실장 부품용 핀) 

② Internal Layer : Gerber 생성시 unconnect 되어진 내부의 Internal Pad를 억제할 것인

지를 선택합니다. 

- Fixed : Internal pad의 사용을 억제하여 layer를 고정 

- Optional : Internal pad의 사용에 있어서 제약이 없음 

③ Unit : mils / inch / millimeter / centimeter / micron 이 있다.  

기본이 mils로 되어 있다.  

④ Multiple drill : 주어진 padstack에 대해 한 개 이상의 drill hole을 정의 
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⑤ Drill/Slot hole : Drill size를 설정해주는 창으로 실제 삽입될 부품의 크기보다 0.3∼0.4 

mm정도 크게 설정한다. Plating이란 관통된 홀의 내부를 도금시킬 것인가를 결정하는 

것이다. 

- 1mm 는 39.37mil 약 40mil 가량으로 계산해서 1.25 X 40 = 50 mil로 설정한다. 

 

 
 

- 상단의 Layers 탭을 선택한다. 

 

 
- Layers 에서는 Land(납이 묻는 부분)의 설정이 이루어진다. 
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• Bgn(Begin: 시작레이어 Top Layer) 

• Default Internal : 내층  

• END (END Layer : Bottom Layer) 

• Soldermask : 납이 묻을 부분에 적용될 Mask로 Top, Bottom이 있다. 

• Regular Pad : 일반적으로 납이 묻을 패드 

• Thermal Relief : Same net에 copper 적용 시 단열판 생성 

• Anti Pad : Difference Net에 copper(카파)적용 시 copper와 pad 사이에 이격 되는 

크기와 모양 

- 먼저 Begin layer를 설정한다.  

• Regular : Circle 80 / Thermal, Anti Pad : Circle 90 

- 나머지도 입력을 해도 무관하나 동일한 값이라면  Copy / Paste 방법을 이용한다. 

Bgn이라고 표시된 셀을 선택 후 마우스 오른쪽 버튼을 눌러 copy to all 을 선택한다. 

- OK 하게 되면 Internal 과 END Layer 까지 동일한 값이 입력된다. 

 

        
 

- Internal(내층)은 수치를 Begin layer보다 10mil 크게 설정해 준다. 

 

 
- SolderMask는 일반적으로 Begin layer보다 10mil 크게 설정해 준다. 

- 설정이 완료되었으면 File > Save as...로 저장한다. 



                                       

 

33 

 

- 이름을 PAD80CIR50D로 하고 저장위치를 현재 작업폴더로 설정한다. 

 

 
 

- Save로 하면 Unnamed.pad로 저장되므로 주의한다. 

- 저장 후에는 PAD Designer를 종료한다. 

 

2) Package Symbol 만들기 

- PCB Editor를 열고 File > New를 선택한다. 

- Browse를 눌러 저장경로를 선택한다. 

- 이름은 TACT_SW2로 저장한다. 

- TYPE는 Package Symbol로 설정한다. 

 

 
 

Tool Bar -마우스 포인터를 아이콘 위에 올려놓으면 이름 및 단축키가 나타난다. 
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- Control Panel – 마우스 포인터를 가까이 이동하면 자동으로 나타난다. 
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① 그리드 간격 설정을 한다. 

- 메뉴바 Setup > Grid 

 

 
 

- Non-Etch : X : 128 Y : 128 

- Define Grid에서 Non-Etch란 전기적 성질이 없는 부분으로 SilkScreen, Reference, Pin 

등이 해당된다. Etch란 전기적 성질이 있는 Pattern, Copper(Shape)등이 해당된다.  

- Define Grid의 상단에 Grid On을 켜면 화면에 그리드가 보인다. 

 툴바의 Grid On/Off 아이콘 을 눌러도 같은 결과이다. 

 

 
 

- 마우스 오른쪽버튼을 클릭하면 메뉴들이 나오는데 Quick utilities 메뉴의 Grid를 선택하

여도 된다. 
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② 메뉴바의 Layout > Pin 또는 Add Pin 아이콘 을 선택한다. 

아이콘을 선택해도 아무 변화가 없다. 

화면 오른쪽의 Control Panel에서 설정을 해야 한다. 

 

- Padstack 설정하기 [ PAD80CIR50D ] 

 

 
 

③ 핀 배치하기 

- 마우스 포인터 끝에 핀이 따라다닌다. 핀의 배치방법은 두 가지이다. 

 

• 좌표 입력을 이용한 배치 

* Drawing Size 설정 

- 화면하단의 command 창에 수치를 적어 넣는다. 

1번핀 : x -128 0 E 

2번핀 : x 128 0 E  [절대좌표형식] 또는 ix 256 E  [상대좌표형식]  

U* 소문자를 써야 하며 x 다음에 반드시 한 칸을 띄워야 한다. 

* 1번 핀은 절대 좌표로 설정해야 하고, 2번 핀은 절대좌표 또는 상대좌표로 가능하다. 

 

• 마우스로 좌표를 찾아가서 하는 배치 

Grid를 Non-Etch X : 128, Y : 128을 선택해 놓았으므로 마우스로 좌표를 찾아간다.  

화면하단에 좌표값을 확인한다. 

 
 

- 핀배치가 끝났으면 마우스 오른쪽버튼을 눌러 Done이나 키보드의 ^을 선택한다. 
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④ Silkscreen Outline, Assembly Outline, Place Bound TOP 설정하기. 

• Silkscreen Outline 작성하기. 

- 부품의 size가 6 x 3.5 [mm]이므로 mil로 환산하면 240 x 140 이다. 

- Grid의 Non-Etch 부분을 X : 120, Y : 10으로 설정한다.  

(RMB[Right Mouse Button] > Quick Utilities > Grid) 

- 화면 오른쪽 하단의 툴바에서 line 또는 메뉴바 Add > Line을 선택한다. 

- Control Panel의 Option창에서 설정을 한다. 

 

• Class : Package Geometry 

• Subclass : Silkscreen_Top 

• Line width : 8mil (0.2mm) 

 

 

 

 

- 화면에서 좌표를 확인하면서 그린다. 

 

 
- 항상 작업이 끝난 후에는 Done 또는 ^을 눌러 작업을 완료한다. 

 

• Assembly Outline 작성하기 

- Grid의 Non-Etch X : 50, Y : 10으로 설정한다. 

- 화면 오른쪽 하단의 툴바에서 line  또는 메뉴바 Add > Line을 선택한다. 
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• Control Panel의 Option창에서 설정을 한다. 

• Class : Package Geometry 

• Subclass : Assembly_top 

• Line width : 8mil (0.2mm) 

 

 

 

 

- 설정 후 아래와 같이 그린다. 

 

 
 

- 완료가 되면 Done (^)을 누른다. 

 

• Place Boundary 그리기 

- 부품이 보드상에서 차지하는 고유한 영역이며, 이 부분이 겹칠 시 에러를 유발한다. 

- 화면 오른쪽 하단 툴바에서 Add Rect  또는 메뉴바 Add > Rectangle을 선택한다. 

 

- Control Panel의 Option창에서 설정을 한다. 

- Class : Package Geometry 

- Subclass : Place_Bound_Top 

- Line width : 8mil (0.2mm) 

- 양면 실장의 경우 Bottom도 설정하여야 한다. 

 

 

- 설정 후 Assembly Top과 동일한 크기로 그린다. 
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- 완료 후 Done 또는 ^을 누른다. 

 

 

 

 

• Reference 작성하기 

- Reference는 Silkscreen Top과 Assembly Top에 각각 준다. 

- 메뉴 Layout > Labels > RefDes 또는 상단 툴바에서 Label RefDes 를 선택한다. 

 

• Control Panel의 Option창에서 설정을 한다. 

• Subclass를 Assembly_Top으로 맞춘다.  

• Text Block은 글씨의 크기를 나타낸다. (1~16) 

• Text just는 입력되는 문자의 정렬방법이다. (Left, Center,  

Right) 

 

 

- 아래그림과 같이 박스 가운데 클릭 후 SW?라고 적는다.  

 

 
 

- 메뉴 Layout > Labels > RefDes 또는 상단 툴바에서 Label RefDes 를 선택한다. 

- Subclass를 Silkscreen_Top 으로 맞춘다.  
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- Reference를 작성하였으면 기본적인 심벌생성이 완료되었다. 

- 메뉴 File > Save 를 클릭하면 저장된다. 

- 저장된 경로의 폴더를 열어보면 파일이 생성되어 있다. 

 

3. FND510 생성 
- 데이터시트를 확인한다. 

Padstack : Pad65sq35d(1번핀) 

Pad65cir35d(2~10번핀)  

-  Pin to Pin : 2.54mm (0.100 inch) 

15.24mm (0.600 inch) 

- 부품 Size : 12.25 X 17.5 [mm] 

0.482 X 0.689 [inch] 

 

 

- 부품 사이즈는 U500 X 700 [mil]U로 한다. 

- 필요한 부품 정보를 확인하였으므로 FND Footprint를 새로 만든다. 

- 메뉴 File > New를 선택한다. 
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- 저장경로는 기본 라이브러리 그대로 사용한다. 

- Drawing Name : FND510 

- Drawing Type : Package symbol 

 

1) 기본 설정하기 

- 메뉴 Setup > Design Parameteries..을 선택한다. 

- Display Tab에서 Grid를 설정한다. 

Non-Etch : X : 25, Y : 25 [mil] 

Design Tab에서 Unit과 Sheet Size를 선택한다. 

Unit : mils 

Size : A  

 

2) Pin 배치하기 

- 메뉴 Layout > Pin 또는 툴바 Add Pin 아이콘 을 선택한다. 

- Control Panel에서 Option Tab을 선택한다. 

Padstack : Pad65sq35d 

 
- Command 창에 x 0 0을 입력하고 E. 

- ^ 키나 마우스 오른쪽 버튼을 눌러 Done을 선택. 

- 1번 핀 배치 완료. 

- 2번 핀 부터 10번 핀까지는 같은 타입의 핀을 배치. 

- Add Pin을 실행한다. 

- Option Tab을 열어 설정을 변경한다. 

Padstack : Pad65c35d 

X축으로 4개의 핀을 100mil 간격으로 오른쪽으로  

연속배치. 

Pin # 2번부터 1 씩 증가  

- 설정이 완료되면 X 100 0 에 놓으면 자동으로 5번 핀까지 배치가 된다. 
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- X축으로 5개의 핀을 100mil 간격으로 왼쪽으로 연속배치  

- 6 번핀을 X 400 600에 놓으면 자동으로 10번 핀까지 배치된다. 

 

 

 

* Pin 배치 규칙 

- 항상 왼쪽이 기준이 된다. 

- 연속된 핀 배열로 보았을 때 좌측 상단이 1번 핀이 된다.  

- 반 시계 방향으로 핀 번호가 부여된다. 

- 1번 핀은 사각형 패드를 배치한다. 

 

 

3) Drawing 정보 작성하기 

- Silkscreen_Top, Assembly_top, Place_Bound_Top, Silkscreen_Ref, Assembly_Ref 

 

• Silkscreen_Top 

- 메뉴 Add > Rectangle 또는 좌측 툴바 Add Rectangle 아이콘 을 선택한다. 

- Option Tab을 열어 Package Geometry / Silkscreen_Top을 선택한다. 

- Command 창에 x -50 -50 E 

 ix 500 700 E 를 입력하고 

 ^ 또는 마우스 오른쪽 버튼 메뉴의 Done을 선택한다.  

[ x a , b : 절대좌표] 

[ ix a , b : 절대좌표로 표기된 포인트에서 x축으로 a만큼, y축으로 b만큼 이동, 상대좌표] 

② 같은 방법으로 Assembly_top에 x -50 -50 E  ix 500 700 E. 

③ Place_Bound_Top도 동일한 방법으로 그린다. 

 

* 메뉴 Edit > Z-Copy Shape를 선택한다. 

 옵션탭에서 Package Geometry / Place_Bound_Top을 선택한 

 후 이미 그려진 사각형을 클릭하면 같은 위치에 Copy 된다.  
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④ Silkscreen_Ref 

- 메뉴 Layout > Labels > Refdes 또는 툴바 Label Refdes 아이콘 을 선택한다. 

- Option Tab을 열어 Package / Silkscreen_Top을 선택한다. 

- Text Block을 3으로 선택한다.  

- Text just : center 

- 사각형의 위쪽에 클릭 후 FND*를 입력 후 ^ 키. 

 

   
 

⑤ Assembly_Ref 

- 메뉴 Layout > Labels > Refdes 또는 툴바 Label Refdes 아이콘 을 선택한다. 

- Option Tab을 열어 Package / Assembly_Top을 선택한다. 

- Text Block을 3으로 선택한다.  

- Text just : center 

- 사각형의 안쪽에 클릭하고 FND*를 입력 후 ^ 키. 

- Save를 눌러 저장한다. 
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4. HC49 생성  

 
 

 
 

① Footprint에 필요한 정보를 수집한다. 

 

② Package Wizard 로 생성하기 

- File > New 를 선택한다. 

- Name을 hc49 로 지정하고 Type를 Package wizard로 맞춘다. 

 

 
 

- Package type를 TH DISCRETE로 설정한다. 
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- Load Template을 누른 뒤 next를 선택한다. 

 

 
 

- Reference 지정 창에 OSC*를 입력한다. 또는 Y*를 입력한다. 

 

 
 

- 설정 창에 [e1] 192, [E] 450, [D] 190을 입력한다. 

 

 
 

- Padstack을 pad45cir22d를 선택한다. 
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- Symbol origin을 1번 핀에 주고 완성되지 않는 상태를 선택한다. 

 

 
psm은 만들어지지 않고 dra만 만들어 진다. 

 

- Finish를 눌러 Wizard를 종료한다. 

- 화면에 자동 생성된 symbol이 보인다. 

 

 
 

③ Silkscreen 수정하기 

- 툴바 Color 아이콘을 눌러 컬러를 조정한다.  

- Global visibility의 Off를 선택한다.  

- Stack-Up의 Top - Pin 항목을 체크한다. 

 

 
 

- Package Geometry의 Silkscreen_Top을 체크한다. 
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- OK를 눌러 설정을 종료한다. 

- Control Panel에서 Class를 설정한다. 

Sub class : Package Geometry / Class : Silkscreen_Top 

 

 
 

- 메뉴 Add > 3pt Arc를 선택한다. 

- Command창에 좌표를 입력한다. 

x -49 95 E / x -49 -95 E / x -129 0 E 

x 251 95 E / x 251 -95 E  / x 321 0 E , ^ 

 

           

 
 

- 완성된 hc49 symbol이다. 

 

 
- File > Save를 선택한다. 

hc49.psm과 hc49.dra가 생성된다. 
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5. [실습] SW_SLIDE_3P 
 

 
[단위: mm] 

 PIN : PAD60CIR35D  

[완성된 모습] 
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6. SM_3216 
 (1) Padstack 생성 

 

- 3216 Type 은 mm 표이며 1206 Type(inch)으로도 표기한다. 

 

 

 

- 실제 부품 크기 : 3.2 X 1.6 mm [ 125 X 65 mil ] 

- Land size : 1.3 X 1.5 mm [ 50 X 60 mil ] 

- pin to pin(pin pitch) : 1.9 mm [ 75 mil ] 

- Soldermask : 1.5 X 1.7 mm [ 60 X 70 mil ]  

- Pastemask[metal mask] : 1.3 X 1.5 mm [ 50 X 60 mil ] 

- Silkscreen(assembly)_Top & Place_bound_Top : 3.4 X 1.7 mm [ 140 X 70 mil ] 
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① PADSTACK 만들기 

- PAD Designer 를 실행한다. 

 

 

- File > new 를 선택한다. 

저장 경로를 [ C\Orcad16.0\Share\PCB\PCB_lib\Symbol ]로 하고 새 이름을 s50rec60 

으로 한다. 

• Type 을 Single 

• Unit 을 Mils  

• Drill diameter : 0  

 

 

 

 

 

 

 

 



                                       

 

51 

 

- Layer Tab 를 선택한다. 

• BEGIN LAYER : Rectangle  

Width : 50 Height : 60  

• SOLDERMASK_TOP : Rectangle  

Width : 60 Height : 70  

• PASTEMASK_TOP : Rectangle  

Width : 60 Height : 70  

 

 

- Save 로 저장한 후 종료한다. 

 

② PACKAGE 만들기. [ Wizard 로 생성하기 ] 

- Package 는 Footprint 정보와 핀 정보가 합쳐진 데이터이다. 

하나의 PCB Footprint 사용을 위해서는 핀 정보가 담긴 *.pad 와 Footprint 정보가 담긴 

*.dra 가 합쳐진 *.psm 데이터를 사용.  

- Package 를 생성하는 방법에는 직접 PCB Editor 에서 작성하는 방법과 Package Wizard 

를 사용하여 만드는 방법이 있다.  

- PCB Editor 를 실행한다. 

- File > New 를 선택한다. 

Name 에 SM_3216 또는 SM_1206 를 기입하고 Format 을 Package Wizard 를 선택한다. 
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- Package Type 을 선택한다. 

SMD DISCRETE 를 선택한다. 

 

 

- Template drawing file 창이 뜨면 Load Template 를 선택한다. 
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- Unit(단위)와 Reference 를 묻는 창이 뜬다. Mils, SM 를 선택한다. 

 

- SM3216 의 치수를 입력한다. 

• Terminal pin spacing : 75 mils 

• Package width : 140 mils 

• Package length : 70 mils 

 

 

- Default Padstack 을 선택하는 창이 뜨면 Browse 아이콘을 눌러 s50rec60 을 선택한다. 
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- 부품의 Origin 을 묻는 창이 뜨면 Center 를 선택한다. 

 부품 이동시 마우스가 잡는 부품의 기준점을 Symbol Origin 이라 한다. 

Through-hole 부품의 경우는 1 번핀에 설정, SMD 부품의 경우 가운데에 주로 설정한다. 

- Create a compiled symbol 을 선택하면 Silk screen, Place_bound, Assembly, Ref 를 

자동으로 생성해준다. 

 

- dra 파일과 psm 파일을 생성함을 나타낸다. finish 를 선택하면 생성이 완료된다. 

 

- 화면에 완성된 Symbol 이 보인다. 
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7. LED 
- File > Open을 선택한다. 

- 경로를 C:\OrCAD\OrCAD_16.0\share\pcb\pcb_lib\symbol을 선택한다. 

- 포맷을 dra로 선택한 후 cap196.dra를 연다. 

- 다른 이름으로 저장을 선택하고 LED로 저장한다. 

 

 
 

8. [실습]VIA 생성 
 - SIGNAL VIA 생성 

  V24D12 

  Drill 12mil 

  Pad 24mil 

  

- POWER VIA 생성 

  V32D16 

  Drill 16mil 

  Pad 32mil 
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Ⅲ. CREATE NETLIST  
 

1. Capture를 실행한다. 

  생성된 bom 파일을 열어 아래와 같이 수정한다. 

 

"{Value}"   "PCB Footprint" 

 "104"    "SM_3216"  또는  “SM_1206” 

 "LED"    "LED" 

 "FND5160"   "FND510" 

 "CON2"    "JUMPER2" 

 "330"    "SM_3216" 또는  “SM_1206” 

 "10k"    "SM_3216" 또는  “SM_1206” 

 "1k"    "SM_3216" 또는  “SM_1206” 

 "Adjust/Operation"  “SW_SLIDE_3P" 

 "hour/min_select"  “TACT_SW2" 

 "manual_increase"  "TACT_SW2" 

 "74LS47"   "SOIC16" 

 "74HC573"   "SOIC20" 

 "AT90S8515"   "DIP40_6" 

 "40Mhz"   "HC49" 

 

Save as로 저장한다. 저장시 확장자 이름을 UPD로 변경한다. 

 

- Project  Manager 화면에서  schematic1 폴더를 선택한 후 메뉴 Tool > Update 

properties를 선택한다. 
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- Upd 파일을 불러올 위치를 지정한 후 OK를 선택한다. 

 

 
 

 

- UUnconditionally update the properties visibilityU 체크 

  기본적으로 비어있는 셀에만 속성의 갱신이 이루어지나, 설정을 하게 되면 새로운 

비어있는 것에 관계없이 모든 속성들을 갱신  

  

 

- SCHEMATIC폴더를 선택한 후 마우스 오른쪽 버튼의 팝업메뉴 중 Edit Object 

Properties를 선택한다. 
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속성창이 열리면 모든 부품의 Footprint가 update 되었는지 확인한다. 

 

 

 
 

 

- Create Netlist 아이콘을 선택한다. 

- 설정을 그림과 같이 맞춘 후 확인을 선택한다. 
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- 에러가 발생한다. NETLIST가 전송은 되나 제대로 전송된 NETLIST가 아니다. 

- capture의 Session.log를 확인한다. 

회로도에서 3pin 스위치를 edit Part로 수정한다. 

NC의 핀 넘버를 8에서 2로 수정 후 update 시킨다. 

  

 
 

다시 Create Netlist를 실행한다. 

PCB editor가 열리고 정상적으로 전송된 netlist가 보인다 
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Ⅳ. PCB Design (ARTWORK) 

 

1. 기본 환경설정 
- 메뉴 Setup > Design Parameters..를 선택한다. 

- Design Tab에서 그림과 같이 설정한다. 

 

 
 

- Text Tab에서 그림과 같이 설정한다. 
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- Shapes Tab에서 그림과 같이 설정한다. 
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- Setup > Define Grid를 설정한다. 

 

 
 

 

 - Stroke Editor 설정 [실습] 

 

 

 

 - PAD 및 PSM 설정 [실습] 
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2. Board Outline  
- Setup > Outline > Board Outline을 선택한다. 

- 그림과 같이 설정을 한다.  

 

 
 

- OK나 Apply를 누르면 창이 닫기며 layer만 설정이 된다.  

- 창을 화면의 가장자리로 이동시킨 후 그린다. 

좌표를 찾아서 마우스로 그려도 되고 화면하단의 command창에 입력하는 방법으로 그

려도 된다. 

 

 
 

Board Size : 5500 X 5000 [mils] 
 

- ^ 키나 마우스 오른쪽 버튼의 팝업메뉴 중 Done을 선택하면 완성된다. 

Boaed Outline 과 Route Keepin, Package Keepin 영역까지 나타난다. 

 

- Route Keepin 영역과 Package Keepin 영역은 동일한 위치이다. 
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Package Keepin 영역을 수정할 경우 

- Setup > Area > Package Keepin을 선택한다. 

- 메뉴 Add > Rectangle 또는 좌측 툴바 Add Rectangle 아이콘 을 선택한다. 

- Command 창에 좌표를 입력한다. 

x 200 200  E 

x 5300 4800 E 

- ^ 또는 Done 선택한다. 

 

Dimension을 작성 

- 메뉴 Manufacture > Dimension/Draft > Liner Dim을 선택한다. 

 보드 외곽선을 클릭한 후 적당한 위치에 치수를 위치시킨다. 

Package Keepin 
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- 보드의 고정홀을 배치한다. 

MGT125 를 선택하여 네 귀퉁이에서 50mil 떨어진 지점에 배치한다. 

 

- File > Save as 로 저장한다. 

 파일명 _ board 
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3. constraint 설정 
 

- 메뉴 setup > constraint > constraint manager를 선택한다. 

- Physical Constraint set에서 설정을 한다. 

 

 
 

Default 의 설정을 한다. Via 타입을 선택한다. 

 

- 메뉴 Object > Create > physical Set을 선택한다. 

- 이름을 VCC로 기입하고 OK를 선택한다. Via 타입을 선택한다. 

 

- Net폴더에서 gnd / vcc / x1 / x2 항목의 pcs를 vcc로 선택한다. 

 

 
 

- spacing폴더에서 Default 항목을 모두 10으로 설정한다. 

- Create로 새로운 set을 만든다. gnd로 이름을 기입하고 shape에 해당되는 항목을 모두 

20으로 설정한다. 

- gnd와 x1 / x2 항목을 gnd로 선택한다. 

 

 
 

- 메뉴 File > Close를 선택한다. 
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4. Placement Component 
 

- 메뉴 Place > Manually..를 선택한다. 

- 모든 부품을 선택한 후 하단의 Hide를 선택한다. 

 

 
 

- 신호의 흐름과 방향을 고려하면서 적절하게 배치한다. 

- 메뉴 Display > Highlight를 선택한다. 

- Option Tab에서 컬러를 설정한 후 Find Tab에서 net을 선택한다.  

• Red – VCC 

• Green – GND 

- 전원라인을 고려하며 배치를 한다. 

 

- 메뉴 Display > Color/Visiblity를 선택한다. 

- All off로 모든 컬러설정을 해제한다. 

필요한 컬러만 보이게끔 설정한다. 
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- 컬러 설정 후  
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 5. Routing 
  

- 배치가 완료되면 배선을 시작한다. 

- 메뉴 Route > Connect를 선택한다. 

- TOP Layer와 Bottom Layer에 배선을 한다. 

 배선 중 더블클릭을 실행하면 via가 발생하며 layer가 바뀐다. 

 

- 메뉴 Route > Create Fanout 을 실행한다. 

- Option 과 Find 설정을 한다. 

 

             
 

- 설정 후 SMD 핀을 선택한다. [ Mouse Drag ] 
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- Fanout이 설정된 모습 

 

 
 

- 전원라인을 고려하며 Routing을 한다. 

- GND라인은 Copper를 씌우므로 배선을 하지 않는다. 

(단, 배선시 GND핀을 고립시키지 않는다. ) 
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SMD부품의 GND핀에 via생성 

- 메뉴 Route > Create Fanout를 선택한다. 

- Find Tab에서 Pin만을 선택한다. 

- GND핀을 선택하면 via가 생성된다. 
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6. Copper  
 

- 메뉴 Shape > Rectangular를 선택한다. 

- Option Tab에서 레이어와 Net을 선택한다. 

 

    
 

- 보드의 Top 레이어 전체에 씌워준다. 

- Option Tab에서 레이어를 Bottom으로 설정 후 Bottom 레이어 전체에 씌워준다. 
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보드에 씌우고 나면 Copper의 Island가 생기게 된다. 
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- 메뉴 Shape > delete Island를 선택한다. 

- Option Tab의 메뉴를 이용하여 제거한다. 

- 레이어를 TOP으로 하고 Delete all on Layer를 선택한다. 

 

    
 

 

7. 설계검사 
메뉴 Display > Status를 선택한다. 모든 항목이 녹색이면 정상적으로 설계가 되었다. 

 

 
 

 - 노란색이나 붉은색이 뜨면 수정 후 다시 확인한다. 
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8. 실크스크린 정리 
 

- 메뉴 Display > Color/Visiblity를 선택한다. 

- Etch 폴더의 Top 에서 PIN 과 Via를 남기고 모두 해제한다. 

- 메뉴 Edit > Change 선택한다. 

- Option Tab에서 설정을 한다. 

• Sub Class : Ref Des 

• Class : Silkscreen_top 

• Text block : 5 

- Find Tab에서 Text만 선택한다. 

- 보드 전체를 드래그한다. (Text의 크기가 일괄 5사이즈로 커진다.) 

 

            
 

- 메뉴 Edit  > move를 선택한다. 

- Find Tab에서 Text만 선택한다. 

- 방향과 위치를 고려해서 조정한다. 
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- 보드에 필요한 정보(Text)를 기입한다. 

- 컬러 설정 창을 열어 Board Geometry 폴더의 Silkscreen_top을 선택한다. 
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- 메뉴 Add > Text를 선택한다. 

- Option Tab에서 설정 한다. 

• Sub Class : Board Geometry 

• Class : Silkscreen_Top 

  • Text block : 5 ( 적절히 ) 

 

 
 

- 보드 내에 필요한 정보를 기입한다. 
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9. Drill Legend 작성하기 
 

- Color 설정을 Board Geometry의 Dimension을 추가 선택한다. 

- 메뉴 Manufacture > NC > Drill Customization을 선택한다. 

- Table 하단의 Auto generate symbols를 선택한다. 
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- 툴바 Drill Legend를 선택한다.  

- OK를 선택하여 화면의 Board 하단에 배치시킨다. 
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Ⅴ. Create Gerber (Artwork) 
Gerber Data라고 불려지는 Artwork Film Data를 생성한다. 

 

- 메뉴 Manufacture > Artwork을 선택한다. 

- General Parameters Tab을 선택한다. 

- Device type을 Gerber RS274X로 설정한다. 
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- Film control Tab으로 이동해보면 top과 bottom에 대한 거버는 생성되어 있다. 

 

 
 

- Ok를 선택한다. 

 

- 추가로 생성해야 할 거버는  

• Soldermask-top, 

• Soldermask-bottom,  

• Pastemask-top (metal mask) 

• Silkscreen-top (assembly-top)  

• Drill drawing 

• NC-Drill [ 수치 데이터 ] 
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① Soldermask_TOP  

- Color 설정을 변경한다. 

- Global Off를 선택해서 모든 설정을 해제한다. 

- Stack Up > Soldermask_Top의 Pin 과 Via를 선택한다. 

 

 
 

- OK를 선택한다. 

- Artwork 아이콘을 선택한다. 

- Film Control Tab을 선택한다. 

 

 
 

- TOP 폴더를 선택하고 마우스오른쪽 버튼의 팝업메뉴 중 Add를 선택한다. 

- 이름을 SM_TOP으로 기입한다. 

- OK를 선택한다. 

 

② Soldermask_Bottom 

- Color 설정을 변경한다. 

- Global Off를 선택해서 모든 설정을 해제한다. 

- Stack Up > Soldermask_Bottom의 Pin 과 Via를 선택 후 OK. 
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- Artwork 아이콘을 선택한다. 

- Film Control Tab을 선택한다. 

- Bottom 폴더를 선택하고 마우스오른쪽 버튼의 팝업메뉴 중 Add를 선택한다. 

- 이름을 SM_BOT으로 기입한다. 

- OK를 선택한다. 

 

③ Pastemask_Top 

- Color 설정을 변경한다. 

- Global Off를 선택해서 모든 설정을 해제한다. 

- Stack Up > Pastemask_Top의 Pin을 선택한다. 

- OK를 선택한다. 

 

 
 

- Artwork 아이콘을 선택한다. 

- Film Control Tab을 선택한다. 

- Bottom 폴더를 선택하고 마우스오른쪽 버튼의 팝업메뉴 중 Add를 선택한다. 

- 이름을 PASTE_TOP으로 기입한다. 

- OK를 선택한다. 

 

④ Silkscreen_Top 

- Color 설정을 변경한다. 

- Global Off를 선택해서 모든 설정을 해제한다. 

- Package Geometry > Silkscreen_Top을 선택한다. 
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- Component Geometry > RefDes 의 Silkscreen_Top을 선택한다. 

 

 
 

- Board Geometry의 Silkscreen_Top을 선택한다. 

 

 
 

- OK를 선택한다.  

- Artwork 아이콘을 선택한다. 

- Film Control Tab을 선택한다. 

- Bottom 폴더를 선택하고 마우스 오른쪽 버튼의 팝업 메뉴 중 Add를 선택한다. 

이름을 SILK_TOP으로 기입한다. 

- Undefined line width : 10 기입한다. 
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- OK를 선택한다. 

 

⑤ Drill_Draw 

- Color 설정을 변경한다. 

- Global Off를 선택해서 모든 설정을 해제한다. 

- Board Geometry > Outline을 선택한다. 

- Dimension을 선택한다. 

 

 
 



                                       

 

87 

 

- Manufacturing > Legend1-2를 선택한다. 

 

 
- OK를 선택한다.  

- Artwork 아이콘을 선택한다. 

- Film Control Tab을 선택한다. 

- Bottom 폴더를 선택하고 마우스 오른쪽 버튼의 팝업 메뉴 중 Add를 선택한다. 

- 이름을 DRILL_DRAW으로 기입한다. 

- Undefined line width : 10 기입한다. 

 

⑥ 생성하기 

- Select all을 눌러 모두 선택한다. 

- Create Artwork을 눌러 파일을 생성한다. 
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⑦ NC Drill 

- 툴바 NCdrill Param 아이콘을 선택한다 .  

- Excellon format을 설정한다. 

 

 
 

- 설정 후 Close를 선택한다. 

 

- 메뉴 Manufacture > NC > NC Drill..을 선택한다. 
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- Option을 모두 선택한 다음 오른쪽의 Drill 버튼을 누른다. 

 

 
 

- Close를 눌러 종료한다. 

- Gerber File의 생성이 완료되었다. 

 

⑧ Report  

- 메뉴 Tool > Report 또는 Quick Report를 선택한다. 

- 필요한 Report를 선택한 후 생성한다. 
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Ⅵ. Artwork film 확인 
- 만들어진 거버파일을 불러와서 프린터로 출력한다. 

- 출력할 거버파일은 확장자가 art로 끝난다. NC-Drill 데이터는 출력되지 않는다. 

 

1. 거버파일까지 생성 완료한 작업파일을 연다. 

2. 메뉴 Setup > Subclasses 를 선택한다. 

 

 
 

3. DRAWING FORMAT를 선택한다. 

 

 
 

4. New Subclass 항목에 

- TOP 

- BOTTOM 

- SOLDERMASK_TOP 

- SOLDERMASK_BOTTOM 

- SILKSCREEN_TOP 

- DRILL_DRAW를 입력한다. 

- 한 항목씩 입력 후 E를 누른다. 입력 후에는 를 눌러 창을 닫는다. 

Define Subclasses창을 OK를 눌러 닫는다. 
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5. Color 설정하기 

- 모든 레이어의 Color를 보이지 않게 설정한다. 

- Drawing Format 항목의 방금 추가한 레이어만 보이게 설정한다. 

 

 
 

6. 거버 불러오기 

- 메뉴 File > Import > Artwork을 선택한다. 
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- Load Cadence Artwork창이 열리면 Filename 의 Browse 아이콘을 눌러 TOP.art를 연다. 

 

 
• Class : Drawing Format  

• Subclass : TOP 

- Load file을 선택한다. [OK를 선택하면 창이 닫힌다.] 

 

 
 

- Load file를 누르면 마우스 끝에 TOP.art(거버) 파일이 따라 다니고 화면 중앙쯤에 놓는

다.  

화면에 배치하고 나면 다시 Load Cadence Artwork창이 열린다. 

• Filename : BOTTOM.art 

• Class : Drawing Format 

• Subclass : BOTTOM 

- 설정 후 Load file을 눌러 겹쳐지게 배치한다. 
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• Filename : Silkscreen_TOP.art 

• Class : Drawing Format 

• Subclass : SILKSCREEN_TOP 

- 설정 후 Load file을 눌러 겹쳐지게 배치한다. 

 

• Filename : SOLDERMASK_TOP.art 

• Class : Drawing Format 

• Subclass : SOLDERMASK_TOP 

- 설정 후 Load file을 눌러 겹쳐지게 배치한다. 

 

• Filename : SOLDERMASK_BOTTOM.art 

• Class : Drawing Format 

• Subclass : SOLDERMASK_BOTTOM 

- 설정 후 Load file을 눌러 겹쳐지게 배치한다. 

 

• Filename : DRILL_DRAW.art 

• Class : Drawing Format 

• Subclass : DRILL_DRAW 

- 설정 후 Load file을 눌러 겹쳐지게 배치한다. 

- OK를 눌러 Load Cadence Artwork창을 닫는다. 

 

7. 프린터로 출력하기 

- Color 설정 창을 열어 Drawing Format / TOP만 

 보이게 설정한다. 

- 메뉴 File > Plot Setup을 선택한다. 

- 설계한 데이터를 그대로 확인한다. 

- Auto center를 선택하여 출력물 가운데 위치하도록     

한다. 

- Mirror : 반대로 보이게 하는 옵션으로 Bottom,  

Soldermask_bottom에 적용한다. 

- Color 또는 흑백모드를 선택한다. OK를 눌러 설정 

을 마친다. 
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- 메뉴 File > Plot..을 선택한다.  

- Setup를 눌러 프린터, 용지 및 방향을 선택한다. OK를 누르면 출력이 된다. 

- 위의 과정을 반복하여 출력한다.  

 

 
 

- 모든 데이터를 저장한다. 

 

 

 

 

 

 

 

 

 

 

 

- 수고하셨습니다.- 
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---------- 부   록 ---------- 

1. PCB 관련용어 
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Silkscreen 

Soldermask 

Etch & PTH 
Blind Via

Buried Via 
Inner Layer 

Prepreg 
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2. Via 의 종류 

           

               

 

3. 기판 Sample 
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4. Gerber Format 의 이해 

1.GERBER FORMAT의 소개 

어떠한 CAD SOFTWARE를 사용하든지, PCB를 만들기 위해서는 

GERBER FORMAT으로 OUTPUT하여 FILM출력 과정을 거쳐야 가능합

니다. 따라서 Photoplot file의 이해는 문제의 소지를 줄일 수 있는 최

선의 방법입니다.  CAD(PCB designer)와 CAM(photoplot editor)사이

의 이해 부족은 생각보다 많은 부분을 차지하나, 이에 대한 자료가 

부족한 실정입니다. 

2. GERBER FORMAT 을 위한 Photoplotter 의 이해 

GERBER FORMAT 을 이해하기 위해서는 초기 Photoplotter 의 작동 

원리를 이해해야, GERBER FORMAT 의 file 내용을 파악할 수 있습니다. 

초기 Photoplotter 는 수치제어가 가능한 X-Y table 이 있으며, 

shutter 조절이 가능한 광원 과 원본 film 에 제도가 가능한 Aperture 

wheel 로 구성되어 있습니다. 

Gerber commands 에 의한 controller 는 table 이동과 shutter 의 개폐, 

aperture tool 변경 등을 제어하며, 원본 film 에 제도를 합니다. 

Shutter 가 Open 이 되면 형태와 크기를 가진 Aperture 에 노광이 되어 Film 에 Image 가 

감광된다. Shutter 가 Open and Close 되면 Flash(Pad)가 되고, Shutter 가 Open 이 되고 table 이 

이동을 하면 Line(Trace)가 된다. 이와 같이 Command 에 의해 Aperture 의 선택과 광원의 이동은 

원하는 형태의 Pattern 을 Film 상에 얻을 수 있다. Photoplotter 는 정밀한 수치를 가지는 

Pattern 을 생산할 수 있으나, 다음과 같은 단점을 가지고 있었다. 

 

1) Vector Plotter 로써 제도 시간이 많이 걸린다. (IC Pin 간 2Line,100*100mm 기준으로 Layer 당 

4~6 시간) 따라서, Data 의 용량에 매우 민감하다. 

 

2) Aperture Wheel 은 Wheel 당 24 개의 Aperture 로 Plotting 을 해야 하므로,설계의 시작 단계서 

부터 특별 관리를 해야 한다. D-code 10~19 는 일반 Aperture(circle, square), 70, 71 은 

특수 Aperture(rectangle, target 등),20~29 는 일반 Aperture(circle, square), 72, 73 은 

특수 Aperture(rectangle, target 등)로 이루어진 Wheel 입니다. 

3. GERBER FORMAT 의 기초 및 어원 

1) GERBER FORMAT 이 맞나요? RS-274D/X 가 맞나요? 

초창기 GERBER 사(GSC)가 PLOTTER 제작을 하고 생산을 하여, 여기에 사용한 FORMAT 이므로 
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GERBER FORMAT 이라 해야 합니다. 그러나,이 회사는 몇번의 병합을 거치며, 지금은 MANIA 사로 

넘어갔고, 현재 GERBER SCIENTIFIC INC.가 재봉 분야에서 사업을 하고 있어 지금은 사용할 수가 

없습니다. 또, EIA(미국전자협회)에서 권장하는 규격(Recomended Standard)이 있어 이를 따라 RS-

274D/X 로 써야 맞습니다. 

2) 왜 RS-274D/X 인가요? 

EIA(미국전자협회)에서 권장하는 규격(Recomended Standard)이 부분마다 있습니다. 예를 들어 

RS-232C 도 여기에 해당됩니다. RS-274 는 G Code 와 M Code 를 주로 사용하는 NC Code 

계열입니다. 또 뒷자리 D 와 X 를 추가하여 Code 를 분리하였습니다. RS-274D 는 GERBER FILE 과 

APERTURE LIST 가 분리된 반면,RS-274X 는 GERBER FILE 과 APERTURE LIST 가 한 FILE 로 되어 

있어 사용이 편리하게 되었으며,특수 APERTURE 의 형태 및 크기를 APERTURE 상태로 정의 

사용할수 있고,POLYGON 기능으로 DATA 를 효율적으로 다룰 수 있게 되었습니다. 참고로 

Excellon Format 은 RS-274C 입니다. 

3) Aperture List 가 무엇인가요? 

Aperture 는 카메라로 보면 조리개입니다. 카메라에서는 조리개 조절로 원형의 크기를 조절하여 

노광을 시키지만 ,초기 PHOTO PLOTTER 는 Aperture 에 원하는 형태,크기를 갖춘 고정형 

Aperture 를 사용하고 있습니다. 따라서, Wheel 에 지정된 Aperture 를 넣기 위한 List 가 필요하게 

되었습니다. Aperture No.는 1 번부터 일련 No.로 부여되지만 실제는 D-Code Command 과 병행 

사용합니다.  

4)그럼 D-code 는 무엇인가요? 

EIA(미국전자협회)에서 권장하는 규격(Recomended Standard)이 RS-274 라고 하였습니다. 여기는 

주로 G Code 와 M Code 를 사용합니다. GERBER FORMAT 에서는 추가로 Draft Code 즉 D-

Code 를 사용하게 되었습니다. D01~09 는 Command Code 로 D10 이상은 Aperture No 지정으로 

할당되었다. 

5)절대좌표와 상대좌표에 대한 유의점을 알고 싶어요? 

절대 좌표는 기준점이 원점(0,0)가 되어 지정된 좌표에 의해 직각으로 만나는 두 좌표축(X 축과 

Y 축)을 사용해서 X 축에 내린 수선의 눈금이 x, Y 축에 내린 수선의 눈금이 y 에 해당하는 점 P 의 

위치를 p(x,y)로 나타내며, 상대좌표는 기준점이 절대 좌표의 원점이 아닌 주어진 

시작점으로부터의 거리 개념에서 정의된 좌표 예를 들면 화면상의 어느 시작점으로부터 상대 

좌표로 정의된 사각형은 사각형의 각 선분으로부터 거리 및 방향 그대로 변위된 일련의 선분들로 

그려진다 시작점의 좌표를 변경해서 다른 위치에서 사각형을 다시 그릴 수 있습니다. 

이론상은 두 개의 절대 위치 표시 방법은 차이가 없습니다만, 소수점 이하 표시 자리수가 mm 의 

경우 3 째자리(1um 의 오차), inch 의 경우 4 째자리(2.54um 의 오차)까지 보통 관리하는 관계로 

상대 좌표인 경우 Block 이 많을 경우 오차가 점점 커지게 됩니다. 또, 부품의 설계 치수 unit 도 

mm 계와 inch 계가 혼용이 되고 있어 Format 지정 시 유의해야 하며,절대좌표를 권장합니다. 
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4. GERBER FORMAT 의 Command 

U1) G-Code(초기 조건의 Setting)U 

Gxx Command는 준비Code라고 할 수 있다. 이 Code는 가공을 하기 전 기계 상태의 준비 

조건을 Setting하는데 사용됩니다. 

  

 (1) G90/G91 : 상대 좌표/절대 좌표 지정 

대부분 상대 좌표 사용의 문제로 주로 절대 좌표를 사용하나, 국부적인 별도의 제도시     

부분적으로 상대 좌표를 사용합니다. 

  

 (2) G70/G71 : INCH/MM 지정 

CAD 제작 및 부품의 설계가 주로 INCH 를 사용하는 미국계가 주도하고 있어, Default 는 

Inch 입니다.그러나 최근 SMD 등 MM 계가 많이 나오고 있어 정밀을 요하는 부품을 고려하여 

UNIT 를 정하는 것이 좋다. 유의할 것은 GERBER OUTPUT 시 NC DATA 도 함께 OUTPUT 해야 

하기 때문에 두종류의 FILE 은 가급적 같은 UNIT 를 사용 권장합니다. 

 

 (3) G54 : TOOL(D-CODE) 선택 

D-CODE 를 변경하기 위하여 사용하기 때문에 가장 많이 사용하나, OPTION 이기 때문에  

어떤 CAD 는 생략하는 경우도 있다. 

 (4) G02/G03 와 G75 : 원,호 지정 기능 

    EX) G02X40Y30150J0D01* 

      G02 : 시계방향으로 호를 그림 

      G03 : 반시계방향으로 호를 그림 

      G75 : 360 도 원을 그림 

   (I,J)좌표 : ARC 를 그리기 위한 ARC 중심 좌표(주로,FLEXIBLE PCB 및 ANALOG PCB 에 사용한다.) 

U2) D-Code(Draw와 Flash기능 지정)U 

  (1) D01 : 지정 좌표로 이동 후 Shutter Open 

       Film상에 제도를 하지 않고 지정된 좌표로 이동 후 Shutter Open(DRAW) 

  (2) D02 : 지정 좌표로 이동 후 Shutter Close 

       Film상에 제도를 하며 지정된 좌표로 이동 후 Shutter Close(DRAW) 
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  (3) D03 : 지정 좌표에서 Shutter Open&Close 

       Film상에 지정된 좌표로 이동하여 제도하고  Shutter Close(Flash) 

  (4) 좌표만 있고 D-CODE가 없는 경우는 상위 Command를 Default로 인식한다. 

  (5) D10 ~D999 : Aperture 지정 

      Aperture No.지정을 초기 Plotter는 24 개만 지정하였으나,Laser Plotter의 등장으로  

D999 까지 확장되었다.이 D999 는 상징적인 수치이며,사실 무한대로 사용 가능하다. 

  (6) D04~D09 : 향후 사용을 위해 할당하였으나 지금은 사용하지 않는 CODE 입니다. 

 

U3) M-Code의 다양한 기능U 

   (1)    M30       End of Program           FILE의 종료 표시.이것이 없으면 완전한 DATA로 안봄 

   (2)    M00       End of Program  

   (3)    M25       Beginning of Pattern          Pattern의 반복 시작 위치.REPEAT기능 

   (4)    M31       Beginning of Pattern  

   (5)    M01       End of Pattern  

   (6)    M02 X#Y#  Repeat Pattern  

   (7)    M02 X#Y#  M70 Swap Axis  

   (8)    M02 X#Y#  M80 Mirror Image X Axis  

   (9)    M02 X#Y#  M90 Mirror Image Y Axis  

   (10)    M08       End of Step and Repeat        M02 의 종료 기능 

   (11)    M48       Program Header to first "%"  

   (12)    M47       Operator Message CRT Display  

   (13)    M71       Metric Mode  

   (14)    M72       English-Imperial Mode 

U4) 기타 CommandU  

  (1) % : file의 설명 부분과 구분하는 기능 

  (2) * : 각command의 종료 표시 기능 

5. FORMAT 의 표기 방법 이해 

  (1) 좌표의 표기 : Data 의 표기는 초기에 data 량에 따라 처리 속도가 좌우 된 것이 정형화  

되어 오늘에 이르고 있다. Data 는 

                            - 약정에 의해 소수점 생략 

                            - 약정에 의해 앞 또는 뒤에 있는 "0" 삭제 (leading or the trailing zero) 

                            - 반복되는 Command 및 좌표 등 생략 

                           등으로 인해 사전에 상호 이에 대한 약정 또는 통보를 해야 한다. 
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  (2) 소숫점의 생략 

      X00560Y00320D02* 

      X00670Y00305D01* 

      X00700Y00305D01* 

     예를 들면 X00560Y00320 에서 자릿수가 2.3 이면 X0.56Y0.32 로 읽고, 자릿수가 3.2 이면  

X5.6Y3.2 로 읽는다. 

     읽는 방법에 따라 DATA 의 크기는 10 배씩 커지거나 작아짐을 유의한다. 

     * INCH/MM 의 변경은 2.54 배 또는 1/2.54 배씩 변함을 알면 DATA 의 Format 을 유추할 수  

있다. 

 

U  (3) Leading and Trailing Zero Suppression 

                  No Zero                 Leading Zero                Trailing Zero 

                 Suppression               Suppression                Suppression 

            X00560Y00320D02*       X560Y230D2*                X0056Y0032D2* 

            X00670Y00305D01*       X670Y305D1*                X0067Y00305D1* 

            X00700Y00305D01*       X700Y305D1*                X007Y00305D1* 

예를 들면 X00560Y00320D02* 에서 Leading Zero Suppression(앞에 오는 "0" 생략)이면 

X560Y230D2*이 되고 Trailing Zero Suppression(뒤에 오는 "0" 생략)이면 X0056Y0032D2* 이 된다. 

U  (4) Modal Data Coordinates 

       All Coordinates   Modal Coordinates 

       X560Y230D2*          X560Y230D2* 

       X670Y305D1*          X670Y305D1* 

       X700Y305D1*          X700D1*     

  예를 들면 X700Y305D1*에서 위의 좌표 중 "Y305"가 반복이 되면 생략할 수 있는 기능이 있다. 

U  (5) Modal Commands 

       D1 modal 이 아닌 경우          D1 modal 인 경우 

       X560Y230D2*                      X560Y230D2* 

       X670Y305D1*                      X670Y305D1* 
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       X700D1*                             X700* 

       X730D1*                             X730* 

       X760D1*                             X760*   

       Y335D1*                             Y335* 

       예를 들면 X700D1*등이 상기 "D1" COMMAND 가 같으면 생략될 수 있다.  

6. GERBER FORMAT 의 APERTURE 다양성 

RS-274D 에 따르는 GERBER FILE 은 어느 정도 표준화되어 있으나, APERTURE LIST 는 OrCAD 

Layout, Altium Designer, Mentor Expedition, Cadence Allegro, CadSoft EAGLE, TARGET 3001, 

Zuken Cadstar 또는 Zuken CR5000 과 같은 Electronic Design Automation (EDA) software 만큼 

다양하다. 

APERTURE LIST 는 표준화가 안되어 가장 문제였다. 이를 해결하기 위해 GERBER FILE 에 

APERTURE LIST 가 포함된 EXTENDED GERBER FORMAT RS-274X 를 제안하였으나, 이번에는 

PLOTTER 제조업체마다 제각기의 FORMAT 을 제안하고 사용하고 있어 이 부분은 아직 표준화가 

덜되어 있다. 

     Header for MDA's FIRE 9000 Photoplotter 

     G04%PAR.%* 

     G04%MODE=ABSOLUTE;%* 

     G04%ZERO=LEADING;%* 

     G04%FORM=4.4;%* 

     G04%EOP.%* 

     G04%APR,10000.%* 

     G04%A010:CIR,250.%* 

     G04%A011:CIR,300.%* 

     G04%A012:CIR;-CIR,100.%* 

     G04%A013:SQR,300.%* 

     G04%A014:REC,300,1000.%* 

     G04%A017:POL,X200,Y83,STR,X83,Y200,STR,X-83,Y200,STR,X-200,Y83.%* 

     G04%STR,X-200,Y-83,STR,X-83,Y-200,STR,X83,-Y200.STR%* 

     G04%X200, 7-83, STR, X200, Y83.%* 

     G04%EOA.%* 

 

     Header for Gerber Model 4X00  

     % 

     FSLAX44Y44*                          
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     ADD10C,.025*                         

     ADD11C,.030*                         

     ADD12C,.030X.010*                   

     ADD13R,.030X.030*                    

     ADD14R,.020X.100*                    

     ADD17P,.040X8*                      

     % 

     상기 각 FORMAT 의 APERTURE LIST 의 동일 내용 

     Leading Zero Suppression, Absolute, 4.4 

     D10 Round 0.025 diameter 

     D11 Round .030 diameter  

     D12 Donut OD=.030 ID  

     D13 Square Side=.030  

     D14 Rectangle X=.030 Y=.100  

     D17 Octagon Dia=.040 

 

 


