PHP 매뉴얼

Stig Sæther Bakken
Alexander Aulbach
Egon Schmid
Jim Winstead
Lars Torben Wilson
Rasmus Lerdorf
Andrei Zmievski
Jouni Ahto

Edited by

Stig Sæther Bakken

Egon Schmid

Translated by PHP Manual Korean Translators

이 파일은 Tue Apr 27 01:59:13 2004에 생성하였습니다.
최신 버전은 http://www.php.net/docs.php에서 얻을 수 있습니다.

Copyright © 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004 the PHP Documentation Group


PHP 매뉴얼

Sæther BakkenStig
AulbachAlexander
SchmidEgon
WinsteadJim
WilsonLars Torben
LerdorfRasmus
ZmievskiAndrei
AhtoJouni

엮은이

Sæther BakkenStig
SchmidEgon
Korean Translators (한글 번역)
Jin Tae-young (진태영)
Lee Yun-young (이윤영)
Byon Jaemin (변재민)
Choi Joong-yeon (최중연)
Hwang Won-hee (황원희)
Kim Younsoo (김윤수)
Kwon Jeongha (권정하)
Lee Gwangjong (이광종)
Lee SeungHwan (이승환)
Shim Seungjoon (심승준)
Song Jungmin (송정민)
Suk Bong-woon (석봉운)

27-04-2004

저작권 © 1997-2004 the PHP Documentation Group (PHP 문서 그룹)

서문
I. 시작하기
1. 소개
2. 간단한 튜토리얼
3. 설치
4. 실행 환경 설정
II. 언어 레퍼런스
5. 기본 문법
6. 변수형
7. 변수
8. 상수
9. 표현식
10. 연산자
11. 제어 구조
12. 함수
13. 클래스와 객체
14. 참조 표현
III. 보안
15. 보안
IV. 기능
16. PHP로 HTTP 인증하기
17. 쿠키
18. 파일 업로드 다루기
19. 원격 파일 사용하기
20. 연결 제어
21. 영구적인 데이터베이스 접속
22. 안전 모드
23. 커맨드 라인에서 PHP 사용하기
V. 함수 레퍼런스
I. 아파치 함수
II. 배열함수
III. Aspell 함수 [deprecated]
IV. BCMath 임의 정확도 수치연산 함수
V. Bzip2 압축 함수
VI. 달력 함수
VII. CCVS API Functions [deprecated]
VIII. COM support functions for Windows
IX. 클래스/객체 함수
X. ClibPDF Functions
XI. Crack Functions
XII. CURL, Client URL Library Functions
XIII. Cybercash Payment Functions
XIV. Cyrus IMAP administration Functions
XV. Character Type Functions
XVI. Database (dbm-style) Abstraction Layer Functions
XVII. 날짜와 시간 함수
XVIII. dBase Functions
XIX. DBM Functions [deprecated]
XX. dbx Functions
XXI. DB++ Functions
XXII. Direct IO Functions
XXIII. 디렉토리 함수
XXIV. DOM XML Functions
XXV. .NET Functions
XXVI. Error Handling and Logging Functions
XXVII. File Alteration Monitor Functions
XXVIII. FrontBase Functions
XXIX. filePro Functions
XXX. 파일시스템 함수
XXXI. Forms Data Format Functions
XXXII. FriBiDi Functions
XXXIII. FTP Functions
XXXIV. Function Handling Functions
XXXV. Gettext
XXXVI. GMP Functions
XXXVII. HTTP 함수
XXXVIII. Hyperwave Functions
XXXIX. Hyperwave API Functions
XL. iconv 함수
XLI. Image Functions
XLII. IMAP, POP3 그리고 NNTP 함수
XLIII. Informix Functions
XLIV. InterBase Functions
XLV. Ingres II Functions
XLVI. IRC Gateway Functions
XLVII. PHP / Java Integration
XLVIII. LDAP Functions
XLIX. LZF Functions
L. 메일 함수
LI. mailparse Functions
LII. 수학 함수
LIII. Multibyte String Functions
LIV. MCAL Functions
LV. Mcrypt Encryption Functions
LVI. MCVE Payment Functions
LVII. Mhash Functions
LVIII. Mimetype Functions
LIX. Microsoft SQL Server Functions
LX. Ming functions for Flash
LXI. Miscellaneous Functions
LXII. mnoGoSearch Functions
LXIII. mSQL Functions
LXIV. MySQL 함수
LXV. Improved MySQL Extension
LXVI. Mohawk Software Session Handler Functions
LXVII. muscat Functions
LXVIII. 네트워크 관련 함수
LXIX. Ncurses Terminal Screen Control Functions
LXX. Lotus Notes Functions
LXXI. NSAPI-specific Functions
LXXII. Unified ODBC Functions
LXXIII. Object Aggregation/Composition Functions
LXXIV. 오라클 8 함수
LXXV. OpenSSL Functions
LXXVI. Oracle Functions
LXXVII. Ovrimos SQL Functions
LXXVIII. 출력 제어 함수
LXXIX. Object property and method call overloading
LXXX. PDF functions
LXXXI. Verisign Payflow Pro Functions
LXXXII. PHP 옵션&정보
LXXXIII. POSIX Functions
LXXXIV. PostgreSQL 함수
LXXXV. Process Control Functions
LXXXVI. Program Execution Functions
LXXXVII. Printer Functions
LXXXVIII. Pspell 함수
LXXXIX. GNU Readline
XC. GNU Recode Functions
XCI. 정규표현식 함수 (펄-호환)
XCII. qtdom Functions
XCIII. Regular Expression Functions (POSIX Extended)
XCIV. 세마포어(semaphore)와 공유 메모리(shared memory) 함수
XCV. SESAM Database Functions
XCVI. Session Handling Functions
XCVII. 공유 메모리 함수
XCVIII. SimpleXML functions
XCIX. SOAP Functions
C. SQLite
CI. Shockwave Flash Functions
CII. SNMP Functions
CIII. Socket Functions
CIV. Standard PHP Library (SPL) Functions
CV. Stream Functions
CVI. 문자열 함수
CVII. Sybase Functions
CVIII. TCP Wrappers Functions
CIX. Tidy Functions
CX. Tokenizer Functions
CXI. URL 함수
CXII. 변수 관련 함수
CXIII. vpopmail Functions
CXIV. W32api Functions
CXV. WDDX Functions
CXVI. XML 해석기 함수
CXVII. XML-RPC Functions
CXVIII. xdiff Functions
CXIX. XSL functions
CXX. XSLT Functions
CXXI. YAZ functions
CXXII. YP/NIS 관련 함수
CXXIII. Zip File Functions (Read Only Access)
CXXIV. Zlib 압축 함수
VI. Zend API
24. Overview
25. Extension Possibilities
26. Source Layout
27. PHP's Automatic Build System
28. Creating Extensions
29. Using Extensions
30. Troubleshooting
31. Source Discussion
32. Accepting Arguments
33. Creating Variables
34. Duplicating Variable Contents: The Copy Constructor
35. Returning Values
36. Printing Information
37. Startup and Shutdown Functions
38. Calling User Functions
39. Initialization File Support
40. Where to Go from Here
41. Reference: Some Configuration Macros
42. API Macros
VII. PHP API: 확장 모듈 제작자를 위한 인터페이스
43. Streams API for PHP Extension Authors
VIII. FAQ: 자주 물어보는 질문들
44. 일반적인 정보
45. 메일링리스트
46. PHP 구하기
47. 데이터베이스와 관련된 문제
48. 설치
49. 빌드(build)시의 문제
50. PHP 사용하기
51. PHP와 HTML
52. PHP와 COM
53. PHP와 다른 프로그래밍 언어
54. PHP 2 에서 PHP 3로 마이그레이션 하기
55. PHP 3에서 PHP 4로의 마이그레이션
56. 기타 문제들
IX. 부록
A. PHP와 PHP 관련 프로젝트의 역사
B. PHP 4에서 PHP 5로 이행
C. PHP 3 에서 PHP 4로 이주
D. PHP/FI 2 에서 PHP 3로 이주하기
E. PHP 디버깅하기
F. PHP 3 확장
G. 함수 별칭 목록
H. 예약어 목록
I. 리소스 타입 목록
J. 지원 프로토콜/래퍼 목록
K. List of Available Filters
L. 지원되는 소켓 전송 목록
M. PHP 타입 비교 테이블
N. 해석기 토큰 목록
O. 이 매뉴얼에 관하여
P. Open Publication License
Q. 함수 인덱스
X. HTML 도움말 에디션
57. About This Edition
58. Using PHP Manual CHM Edition
59. The Full Text Search
60. Specialities of this Edition
61. Integrating the PHP Manual
62. Skin development
63. CHM Edition Credits

다음
서문


서문

PHP 는 하이퍼텍스트 전처리기 ( "PHP: Hypertext Preprocessor")를 뜻하는 이름으로써 널리쓰이는 오픈 소스 베이스의 일반 스크립팅 언어입니다. 특히 웹 개발에 알맞고 HTML에 삽입하는 형식으로 사용합니다. 문법은 C, Java, Perl과 흡사하여 배우기 쉽습니다. 언어의 목표는 웹 개발자들이 동적인 웹 페이지를 아주 빨리 개발할 수 있도록 하는데 있지만 PHP로 할 수 있는 일은 그것 보다 훨신 많습니다.

이 메뉴얼의 대부분은 함수 레퍼런스이지만 문법 레퍼런스 및 PHP의 주요 기능(Features)들과 다른 정보(Appendixes)들도 수록하고 있습니다.

다양한 형태의 매뉴얼을 http://www.php.net/docs.php에서 다운로드 할 수 있습니다. 매뉴얼이 어떻게 개발되는지에 관한 정보는 부록 '메뉴얼에 관하여'에서 찾을 수 있습니다.

참고: PHP의 역사(PHP History)

이전 | 처음으로 | 다음
PHP 매뉴얼 |  | 시작하기


시작하기

PHP 매뉴얼
이전 다음

I. 시작하기

차례
1. 소개
2. 간단한 튜토리얼
3. 설치
4. 실행 환경 설정

이전 | 처음으로 | 다음
서문 |  | 소개


소개

PHP 매뉴얼
이전 다음

1. 장. 소개

차례
PHP란?
PHP로 할 수 있는 것들

PHP란?

PHP(정식 명칭 "PHP: Hypertext Preprocessor")는 범용성을 지닌 널리 사용되는 오픈 소스 스크립트 언어입니다. 특히, 웹 개발 및 HTML에 포함하기에 적합합니다.

간단한 답이지만, 무엇을 의미할까요? 다음 예제를 봅시다:

예 1-1. 소개용 예제

<html>
    <head>
        <title>예제</title>
    </head>
    <body>

        <?php
        echo "안녕, 나는 PHP 스크립트야!";
        ?>

    </body>
</html>

Perl이나 C와 같은 다른 언어로 쓰여진 스크립트와 다른점을 알아봅시다 -- HTML을 출력하기 위해서 많은 프로그램 명령어를 쓰는 대신, 무언가를 하기 위해 몇가지 추가 코드가 포함된 HTML 스크립트를 작성하면 됩니다. (여기서는, 약간의 텍스트를 출력합니다) PHP코드는 "PHP 모드"로 들어가고 나올 수 있는 특별한 시작과 끝 태그에 포함되어 있습니다.

PHP가 클라이언트측 자바스크립트 등과 구별되는 점은 이 코드는 서버에서 실행된다는 점입니다. 위와 같은 스크립트가 서버에서 실행되면, 클라이언트는 스크립트의 결과만을 받을 뿐이며, 그 코드가 어떤 모습인지는 알 수가 없습니다. 심지어 모든 HTML 파일을 PHP로 실행되도록 웹 서버를 설정할 수 있으며, 그러면 유저들은 당신이 무슨 일을 하는지 전혀 알 수가 없습니다.

PHP를 사용하는 가장 큰 이득은 초보에게는 매우 쉽고, 전문가에게는 많은 고급 기능을 제공한다는 점입니다. PHP 기능의 긴 리스트를 읽는 것을 두려워하지 마십시오. 그저 시작해 보면 짧은 시간 안에 간단한 스크립트를 작성할 수 있을 것입니다.

PHP의 개발은 서버측 스크립팅에 초점이 맞추어져 있지만, 그보다 더 많은 것들을 할 수 있습니다. PHP로 할 수 있는 것들 섹션을 읽으면 더 많은 정보를 얻을 수 있습니다.

이전 | 처음으로 | 다음
시작하기 | 위로 | PHP로 할 수 있는 것들


PHP로 할 수 있는 것들

PHP로 무엇이든지 할 수 있습니다. PHP는 서버측 스크립팅에 중점을 두고 있어, 다른 종류의 CGI 프로그램이 하는 모든 것을 할 수 있습니다. 예를 들면, 폼 데이터를 수집하거나, 동적인 페이지 콘텐츠를 만들거나 쿠키를 보내고 받을 수 있습니다. 그리고 PHP는 더 많은 것들을 할 수 있습니다.

PHP 스크립트가 사용되는 세가지 중점적인 영역이 있습니다.

  • 서버측 스크립팅. 이것은 PHP에서 가장 오래되고, 중점적인 영역입니다. 이 일을 위해서는 세가지가 필요합니다. PHP 파서 (CGI나 서버 모듈), 웹서버, 그리고 웹 브라우저. PHP가 설치된 웹서버를 실행시킬 필요가 있습니다. 웹 브라우저로 서버에 있는 PHP 페이지를 보는 것으로 PHP 프로그램 출력에 접근하게 됩니다. 더 많은 정보를 위해서는 설치 안내 섹션을 참고하십시오.

  • 커맨드 라인 스크립팅. 어떠한 서버나 브라우저 없이 PHP 스크립트를 실행하게 할 수 있습니다. 이 때에는 PHP 파서만 있으면 됩니다. 이런 사용법은 스크립트를 cron(*nix나 Linux에서)이나 작업 관리자(Windows에서)를 사용해 실행하는 것과 동일합니다. 이런 스크립트들은 간단한 텍스트 처리 작업에 사용될 수도 있습니다. 더 많은 정보를 위해서는 PHP의 커맨드 라인 사용법 섹션을 참고하십시오.

  • 클라이언트측 GUI 어플리케이션의 작성. PHP는 그래픽 어플리케이션 작성을 위한 최고의 언어는 아닐것이지만, PHP를 매우 잘 이해하고 있고, 클리이언트측 어플리케이션에 PHP의 고급 기능을 이용하고 싶다면 PHP-GTK를 이용해서 그러한 프로그램을 작성할 수 있습니다. 이 방법으로 플래폼에 관계 없이 작동하는 어플리케이션을 작성할 수도 있습니다. PHP-GTK는 PHP의 확장으로써 배포판에는 포함되어 있지 않습니다. PHP-GTK에 흥미가 있다면, PHP-GTK 웹사이트를 방문해 보십시오.

PHP는 리눅스, 많은 유닉스 계열 (HP-UX, Solaris와 OpenBSD를 포함), Microsoft Windows, 맥 OS X, RISC OS 등과 같은 모든 유명한 OS에서 사용할 수 있습니다. 또한, PHP는 오늘날의 대부분의 웹 서버를 지원합니다. 이것에는 아파치, Microsoft Internet Information Server, Personal Web Server, Netscape and iPlanet servers, Oreilly, Website Pro server, Caudium, Xitami, OmniHTTPd, 그 외의 많은 서버들을 포함합니다. 유명한 서버에 대해서는 PHP 모듈이 있으며, 다른 것에 대해서는 CGI 표준을 지원한다면, PHP는 CGI 프로세서로 동작할 수 있습니다.

그러므로 PHP라면, OS와 웹서버를 선택하는 것에서 자유로워 질 수 있습니다. 추가로, 함수 지향형이나 객체 지향형, 또는 그 둘을 섞은 형태로 프로그램을 할 수 있습니다. 비록 현재 버전의 PHP에서는 표준 OOP 기능을 모두 포함하고 있지는 않지만, 많은 코드 라이브러리와 커다란 애플리케이션들(PEAR 라이브러리를 포함하여)이 OOP 코드만을 이용하여 작성되고 있습니다.

PHP는 HTML을 출력하는 것에만 제한되지 않습니다. PHP의 능력은 이미지, PDF 파일, 심지어 플래쉬 무비(libswf와 Ming를 사용하여)까지 만들어서 출력할 수 있습니다. 또한 XHTML이나 다른 종류의 XML 파일과 같은 어떠한 텍스트 파일이라도 쉽게 출력할 수 있습니다. PHP로 출력을 하는 대신, 자동적으로 만들어진 파일들을 파일 시스템에 저장하여 동적 컨텐츠에 대한 서버측 캐쉬를 구현할 수도 있습니다.

PHP의 가장 강력하고 인상적인 기능 중 하나는 넓은 범위의 데이터베이스에 대한 지원입니다. 데이터베이스를 이용하는 웹 페이지를 작성하는것은 매우 간단합니다. 현재 다음과 같은 데이터베이스를 지원하고 있습니다:

Adabas D | Ingres | Oracle (OCI7 and OCI8)
dBase | InterBase | Ovrimos
Empress | FrontBase | PostgreSQL
FilePro (read-only) | mSQL | Solid
Hyperwave | Direct MS-SQL | Sybase
IBM DB2 | MySQL | Velocis
Informix | ODBC | Unix dbm

또한 DBX database abstraction 확장은 이 확장이 지원하는 어떠한 데이터베이스라도 명백히 사용할 수 있게 합니다. 추가로 PHP는 ODBC(Open Database Connection 표준)를 지원하기 때문에, 이 세계 표준을 지원하는 어떤 데이터베이스라도 연결할 수 있습니다.

또한 PHP는 LDAP, IMAP, SNMP, NNTP, POP3, HTTP, COM (Windows에서), 그리고 셀 수 없는 여러가지 프로토콜들을 이용해서 다른 서비스와 연계할 수 있도록 지원합니다. 또한 비어있는 네트워크 소켓을 열수도 있기에 어떤 프로토콜과도 연계해서 실행할 수 있습니다. PHP는 WDDX complex data exchange between virtually all Web programming languages를 지원합니다. 이를 통한 연계로, PHP는 자바 객체를 그대로 PHP 객체로 옮겨서 이용할 수 있습니다. 또한 원거리 객체 접근을 위해 CORBA 익스텐션을 이용할 수도 있습니다.

PHP는 POSIX 확장이나 펄 정규 표현부터 XML 문서 파싱까지 가능한, 극도로 유용한 텍스트 프로세싱 기능을 가지고 있습니다. XML 문서를 파싱하고 접근하기 위해서, SAX와 DOM 표준을 지원합니다. 또한, XML 문서를 변환하기 위해서 XSLT 확장을 이용할 수도 있습니다.

PHP를 전자 상거래 부분에 사용한다면, Cybercash payment, CyberMUT, VeriSign Payflow Pro와 CCVS 함수가 온라인 지불 프로그램에 매우 유용할 것입니다.

마지막으로, 하지만 적지 않게 (At last but not least), 많은 또다른 재미있는 확장들이 있습니다. mnoGoSearch 검색 엔진 함수, IRC 게이트웨이 함수, 많은 압축 유틸리티 (gzip, bz2), 달력 변환, 번역...

이 페이지만을 보는 것으로는 PHP가 제공할 수 있는 모든 기능과 이득을 알기에는 충분하지 않습니다. PHP 설치하기 섹션을 읽어보고, 이곳에 언급된 확장들에 대한 함수 레퍼런스를 참고하십시오.

이전 | 처음으로 | 다음
소개 | 위로 | 간단한 튜토리얼


간단한 튜토리얼

PHP 매뉴얼
이전 다음

2. 장. 간단한 튜토리얼

차례
무엇이 필요한가?
첫번째 PHP 실행 페이지
유용한 무언가
폼 다루기
XForms 다루기
새 버전의 PHP에서 예전의 코드를 사용하기
다음은?

짧고 간단한 튜토리얼로 PHP의 가장 기초가 되는 부분을 보여드립니다. PHP는 웹페이지를 만들 때만 사용하는 것은 아니지만, 여기서는 PHP로 동적 웹페이지를 만드는 내용에 대해서만 다룹니다. PHP로 할 수 있는 것들 섹션에서 더 많은 정보를 얻을 수 있습니다.

PHP를 포함한 웹 페이지는 보통의 HTML 페이지와 같이 취급합니다. 그러므로, 보통의 HTML 페이지를 만드는 것과 같은 방법으로 작성할 수 있습니다.

무엇이 필요한가?

이 튜토리얼은 서버가 PHP를 지원하고, .php 확장자를 가지는 모든 파일을 PHP로 다루고 있다고 가정합니다. 대부분의 서버에서 이는 PHP의 기본 확장자입니다만, 확인하기 위해서 서버 관리자에게 문의해보십시오. 서버가 PHP를 지원하고 있다면, 더 이상 준비할 것은 없습니다. 단순히 .php 파일을 만들어서 웹 디렉토리에 넣으면, 서버가 자동적으로 처리합니다. 컴파일할 필요도 없고, 별도의 툴을 설치할 필요도 없습니다. PHP를 포함한 파일을, 모든 일을 할 수 있는 마법의 태그를 가진 단순한 HTML 파일이라고 생각하십시오. 대부분의 웹 호스트는 PHP를 지원하지만, 지원하지 않을 경우에는 PHP Links 섹션에서 PHP를 지원하는 웹 호스트에 대한 정보를 얻을 수 있습니다.

대역폭을 보존하기 위해 로컬 영역에서 개발하고 싶을 수도 있습니다. 이 경우에는, 아파치 등의 웹 서버와 함께 PHP를 설치할 수 있습니다. 원한다면 MySQL 등의 데이터베이스를 설치할 수도 있습니다. 이들은 개별적으로 설치하거나, 보다 간단한 방법을 이용할 수 있습니다. Locate a pre-configured package는 몇번의 마우스 클릭으로 이 모든 것을 자동적으로 설치합니다. 리눅스와 Windows를 포함한 어떠한 OS에서라도 PHP를 지원하도록 웹 서버를 간단히 설치할 수 있습니다. 리눅스에서라면 rpmfind와 PBone이 RPM을 찾을 때 유용할 것입니다. apt-get에서 데비안 패키지를 찾을 수 있습니다.

이전 | 처음으로 | 다음
PHP로 할 수 있는 것들 | 위로 | 첫번째 PHP 실행 페이지


첫번째 PHP 실행 페이지

다음에 쓰여진 내용으로 hello.php를 만들고, 웹서버의 루트 디렉토리(DOCUMENT_ROOT)에 놓습니다.

예 2-1. 첫번째 PHP 스크립트: hello.php

<html>
<head>
  <title>PHP 테스트</title>
</head>
<body>
<?php echo '<p>Hello World</p>'; ?>
 </body>
</html>

웹 브라우저를 이용해서 "/hello.php"에 접근합니다. 로컬에서 개발한다면 URL은 보통 http://localhost/hello.php이나 http://127.0.0.1/hello.php일 것입니다. URL은 웹 서버 설정에 따라 달리집니다만, 이 튜토리얼에서 다룰 내용은 아닙니다. 웹 서버 설정에 대해서는 웹 서버 설정 파일(아파치에서는 httpd.conf)의 DocumentRoot와 ServerName 부분을 참고하십시오. 모든 것이 제대로 설정되었다면 이 파일은 PHP에 의해 처리되어 브라우저에 다음과 같은 출력을 합니다:

<html>
 <head>
  <title>PHP 테스트</title>
 </head>
 <body>
 <p>Hello World</p>
 </body>
</html>

CGI 스크립트와 다른 점에 주의하십시오. 파일에 대해 실행 권한을 주거나 특별한 조치는 필요가 없습니다. 많은 재미있는 일들을 할 수 있는 특별한 태그를 지닌 보통의 HTML 파일로 생각하십시오.

이 프로그램은 매우 간단해서, 실제로 이런 페이지를 만들기 위해서 PHP를 사용할 필요는 없습니다. 이 프로그램은 Hello World를 PHP echo() 표현으로 보여주기만 할 뿐입니다.

이 예제를 실행했을 때, 아무것도 출력하지 않거나, 다운로드 할 것인지 묻거나, 모든 내용이 텍스트 문서처럼 보였다면, 그 서버에서 PHP가 작동하지 않는 것입니다. 서버 관리자에게 매뉴얼의 설치 챕터를 참고해서 PHP를 사용할 수 있게 해달라고 요청하십시오. 로컬에서 개발할 경우에도, 설치 챕터를 읽어보고 모든 것을 제대로 설정하였나 확인해보십시오. 문제가 계속된다면, 망설이지 말고 PHP 지원을 이용하십시오.

예제의 초점은 특별한 PHP 태그를 보여주는 것입니다. 이 예제에서 <?php가 PHP 태그의 시작을 알립니다. 그러면 PHP 상태로 돌입하게 되고, 종료 태그인 ?>에 의해 PHP 모드를 떠나게 됩니다. HTML 파일 어디에서라도 이런 방법으로 PHP 모드로 들어가고, 나올 수 있습니다. 더 자세한 내용은 매뉴얼에서 기초 PHP 문법 섹션을 읽어보십시오.

텍스트 편집기 참고: PHP를 만들고, 수정하고, 관리할 수 있는 많은 텍스트 편집기와 IDE가 있습니다. 이러한 도구에 대한 부분적인 목록은 PHP 편집기 목록에서 관리하고 있습니다. 편집기를 추천하려면, 위 페이지를 방문해서 페이지 관리자에게 그 편집기를 목록에 추가해달라고 하십시오. 구문 하이라이팅이 있는 편집기는 도움이 될 것입니다.

워드 프로세서 주의: StarOffice Writer, Microsoft Word, Abiword 등의 워드 프로세서는 PHP 파일을 수정하는데에는 최적화되어 있지 않습니다. 이들을 텍스트 스크립트에 이용하기 위해서는, 꼭 PLAIN TEXT로 저장해야만 하며, 그렇지 않으면 PHP는 그 스크립트를 읽을 수 없고 실행하지 못할 것입니다.

Windows 메모장 주의: PHP 스크립트를 Windows 메모장을 이용해서 작성할때는, 파일이 .php 확장자를 가지도록 주의해야합니다. (메모장은 다음과 같은 절차를 거치지 않으면 자동적으로 .txt 확장자를 붙입니다) 파일을 저장할 때, 파일 이름을 묻는 부분에서 파일 이름을 따옴표로 감싸줘야 합니다. (예: "hello.php") 또는, '저장' 창에서 '텍스트 문서' 드롭다운 메뉴를 클릭해서 "모든 파일"로 설정을 바꿀 수 있습니다. 이 경우에는 따옴표를 쓰지 않아도 됩니다.

작동하는 PHP 스크립트를 성공적으로 만들었다면, 가장 유명한 PHP 스크립트를 작성할 차례입니다! phpinfo() 함수를 호출하여, 사용 가능한 예약 정의 변수, 불러진 PHP 모듈들, 설정 등 시스템과 설정에 관련한 수많은 유용한 정보를 볼 수 있습니다. 잠깐의 시간을 들여서 중요한 정보들을 확인해보십시오.

이전 | 처음으로 | 다음
간단한 튜토리얼 | 위로 | 유용한 무언가


유용한 무언가

이제 더 유용한 무언가를 해봅시다. 방문자가 사용하는 브라우저의 종류를 확인할 것입니다. 이를 위해서, 브라우저가 HTTP 요청의 부분으로 보내는 user agent 문자열을 확인합니다. 이 정보는 변수에 기록되어 있습니다. PHP에서 변수는 항상 달러표시($)로 시작합니다. 여기서 다룰 변수는 $_SERVER['HTTP_USER_AGENT']입니다.

참고: $_SERVER는 모든 웹 서버 정보를 포함하기 위해 특별히 예약된 PHP 변수입니다. 이것은 자동전역이라고 부릅니다. 더 많은 정보는 자동전역과 관련한 매뉴얼 페이지를 참고하십시오. 이 특별한 변수들은 PHP 4.1.0에서 소개되었습니다. 이전에는 $HTTP_SERVER_VARS 등의 $HTTP_*_VARS 배열을 이용하였습니다. 배제되었지만, 이 구형의 변수들은 아직 존재합니다. (예전의 코드에 관한 노트를 참고하십시오)

이 변수를 표시하기 위해서는, 간단히 다음과 같이 하면 됩니다:

예 2-2. 변수 출력하기 (배열 원소)

<?php echo $_SERVER['HTTP_USER_AGENT']; ?>

이 스크립트의 출력 예제는 다음과 같습니다:

Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

PHP에는 많은 변수의 형이 존재합니다. 위 예제에서는 배열 원소를 출력했습니다. 배열은 매우 유용합니다.

$_SERVER는 PHP가 자동적으로 생성하는 변수 중의 하나에 불과합니다. 매뉴얼의 예약 정의 변수를 보거나, 다음과 같은 파일을 작성하여 모든 목록을 확인할 수 있습니다:

예 2-3. phpinfo()로 모든 예약 정의 변수 보기

<?php phpinfo(); ?>

이 파일을 브라우저로 읽으면, PHP에 대한 정보와 함께 사용 가능한 모든 변수들을 확인할 수 있습니다.

PHP 태그 안쪽으로 하나의 echo뿐이 아닌 여러개의 PHP문을 넣어서 작은 코드 블럭을 만들 수 있습니다. 예를 들면, Internet Explorer를 체크하고 싶다면 다음과 같이 할 수 있습니다:

예 2-4. 제어문과 함수를 사용하는 예제

<?php
if (strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE') !== false) {
    echo 'Internet Explorer를 사용하고 있습니다<br />';
}
?>

이 스크립트의 출력 예제:

Internet Explorer를 사용하고 있습니다.<br />

여기서 두가지 새로운 컨셉을 소개합니다. PHP에는 if문이 있습니다. C 언어에서 사용하는 기본 문법에 친숙하다면, 이것은 매우 논리적으로 보일 것입니다. 그렇지 않으면, PHP 소개서를 구해서 첫부분을 읽어보거나, 매뉴얼의 언어 레퍼런스 부분을 읽어보십시오. PHP에 관한 책의 목록은 http://www.php.net/books.php에서 찾아볼 수 있습니다.

두번째 컨셉은 strpos() 함수 호출입니다. strpos()는 하나의 문자열을 다른 문자열에서 찾아내는 PHP 내장 함수입니다. 여기서는 $_SERVER['HTTP_USER_AGENT'](haystack이라고 합니다) 안에서 'MSIE'(needle이라고 합니다)를 찾아봅시다. haystack 안에서 needle을 발견하면, 이 함수는 haystack의 첫번째 문자로부터 needle의 위치를 반환합니다. 발견하지 못했다면 FALSE를 반환합니다. FALSE를 반환하지 않았다면, if문은 TRUE로 판단하고 {중괄호} 안에 있는 코드를 실행합니다. 그렇지 않으면, 코드를 실행하지 않습니다. if, else, 그리고 strtoupper()나 strlen() 등의 함수를 사용하는 비슷한 예제도 쉽게 작성할 수 있습니다. 관련된 매뉴얼 페이지들은 예제를 포함하고 있습니다. 어떻게 함수를 사용하는지를 모르겠다면, 매뉴얼의 함수 정의를 읽는 방법과 PHP 함수 섹션을 읽어보십시오.

한걸음 더 나아가서, PHP 블록 안에서 어떻게 PHP 모드를 드나드는지 알아봅시다:

예 2-5. HTML과 PHP 모드 섞기

<?php
if (strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE') !== false) {
?>
<h3>strpos는 false가 아닌 것을 반환했습니다.</h3>
<center><b>Internet Explorer를 사용하고 있습니다.</b></center>
<?php
} else {
?>
<h3>strpos는 false를 반환했습니다.</h3>
<center><b>Internet Explorer를 사용하고 있지 않습니다.</b></center>
<?php
}
?>

이 스크립트의 출력 예제:

<h3>strstr은 true를 반환했습니다.</h3>
<center><b>Internet Explorer를 사용하고 있습니다.</b></center>

PHP echo문을 이용한 출력 방법 대신, PHP 모드를 빠져나가서 직접 HTML을 전송할 수 있습니다. 여기서 주의해야할 중요하고 강력한 점은 스크립트의 논리적 흐름이 유지되고 있는 점입니다. strpos()의 결과값에 따라서 오직 하나의 HTML 블록만이 보여지게 됩니다. 즉, MSIE의 발견 여부에 따르게 됩니다.

이전 | 처음으로 | 다음
첫번째 PHP 실행 페이지 | 위로 | 폼 다루기


폼 다루기

PHP의 매우 강력한 기능의 하나는 HTML 폼을 다루는 방법입니다. 이를 이해하는데에 중요한 기본적인 컨셉은 어떤 폼 요소라도 자동적으로 PHP 스크립트에서 사용 가능하다는 점입니다. PHP로 폼을 이용하는 많은 정보와 예제를 위해서 매뉴얼의 PHP 외부에서 들어오는 변수 섹션을 읽어보십시오. 다음은 HTML 폼의 예제입니다:

예 2-6. 간단한 HTML 폼

<form action="action.php" method="post">
 이름: <input type="text" name="name" />
 연령: <input type="text" name="age" />
 <input type="submit" />
</form>

이 폼에는 특별한 것은 아무것도 없습니다. 어떠한 특별한 태그도 가지지 않는 단순한 HTML 폼입니다. 유저가 이 폼을 채우고 submit 버튼을 누르면, action.php 페이지가 호출됩니다. 이 파일은 다음처럼 작성할 수 있습니다:

예 2-7. 폼으로부터의 데이터 출력하기

<?php echo $_POST['name']; ?>씨 안녕하세요.
당신은 <?php echo $_POST['age']; ?>세입니다.

이 스크립트의 출력 예제:

Joe씨 안녕하세요. 당신은 22세입니다.

이것이 무엇을 하는지는 명백합니다. 더 이상 할 일은 없습니다. $_POST['name']와 $_POST['age'] 변수는 PHP가 자동적으로 사용할수 있도록 설정합니다. 위에서 자동전역 $_SERVER를 사용했듯이, 이번에는 모든 POST 데이터를 포함하는 $_POST 자동전역을 소개합니다. 폼에서 method를 POST로 설정한 점에 주의하십시오. 폼에서 GET method로 지정하면, 폼 정보는 $_GET 자동전역이 포함합니다. 요청한 데이터가 어떤 소스인지를 신경쓰지 않을 때는 $_REQUEST 자동전역을 사용할 수 있습니다. 이는 GET, POST, COOKIE 데이터를 포함합니다. import_request_variables() 함수를 참고하십시오.

이전 | 처음으로 | 다음
유용한 무언가 | 위로 | XForms 다루기


XForms 다루기

XForms는 전통적인 웹 폼에 다양성을 부여합니다. 다양한 플랫폼과 브라우저, 심지어 비전통적인 매체인 PDF 문서에서도 사용할 수 있습니다.

XForms의 첫번째 차이는 클라이언트에 폼을 전송하는 방법입니다. HTML 저작자를 위한 XForms에 XForms를 작성하는 자세한 설명이 있습니다. 이 튜토리얼에서는 간단한 예제만을 살펴봅니다.

예 2-8. 간단한 XForms 검색폼

<h:html xmlns:h="http://www.w3.org/1999/xhtml"
        xmlns="http://www.w3.org/2002/xforms">
<h:head>
    <h:title>검색</h:title>
    <model>
        <submission action="http://example.com/search"
                    method="post" id="s"/>
    </mode>
</h:head>
<h:body>
    <h:p>
        <input ref="q"><label>찾기</label></input>
        <submit submission="s"></label>Go</label></submit>
    </h:p>
</h:body>
</h:html>

위 폼은 (q로 이름 붙여진) 텍스트 입력 상자와 제출 버튼을 표시합니다. 제출 버튼을 클릭하면, 폼은 action에 지정한 페이지로 넘어갑니다.

여기서부터 웹 어플리케이션의 시점에서 차이가 납니다. 일반 HTML 폼에서는 데이터가 application/x-www-form-urlencoded로 전송되지만, XForms에서는 이 정보가 XML 형식의 데이터로 전송됩니다.

XML 데이터를 위해서 XForms를 선택한다면, 이 경우 브라우저가 생성한 XML 데이터는 $HTTP_RAW_POST_DATA에서 찾을 수 있고, 이를 선호하는 XSLT 엔진이나 문서 처리기로 넘길 수 있습니다.

형식화에 관심이 없고, 데이터를 전통적인 $_POST 변수로 읽고 싶다면, method 속성을 urlencoded-post로 변경하여 클라이언트 브라우저가 application/x-www-form-urlencoded로 보내도록 할 수 있습니다.

예 2-9. XForms가 $_POST를 만들도록 사용하기

<h:html xmlns:h="http://www.w3.org/1999/xhtml"
        xmlns="http://www.w3.org/2002/xforms">
<h:head>
    <h:title>검색</h:title>
    <model>
        <submission action="http://example.com/search"
                    method="urlencoded-post" id="s"/>
    </mode>
</h:head>
<h:body>
    <h:p>
        <input ref="q"><label>찾기</label></input>
        <submit submission="s"></label>Go</label></submit>
    </h:p>
</h:body>
</h:html>

참고: 이 글이 쓰여진 시점에서, 많은 브라우저가 XForms를 지원하지 않습니다. 위 예제가 실패한다면, 브라우저의 버전을 확인해 보십시오.

이전 | 처음으로 | 다음
폼 다루기 | 위로 | 새 버전의 PHP에서 예전의 코드를 사용하기


새 버전의 PHP에서 예전의 코드를 사용하기

PHP는 유명한 스크립트 언어로 성장했고, 재사용 할 수 있는 많은 양의 저장소/라이브러리 코드 자원이 존재합니다. PHP 개발자는 하위 호환을 유지하기 위해 많이 노력했기 때문에, 이전 버전에서 작성한 스크립트라도 아무런 변경 없이 새버전의 PHP에서 (완벽하게) 작동합니다. 그렇지만, 실제 상황에선 몇가지 변경이 필요할 수도 있습니다.

예전의 코드에 영향을 주는 최근의 중요한 두가지 변경점:

  • (함수나 메쏘드 안에서 사용할 때 global 선언을 필요로 하는) 이전의 $HTTP_*_VARS 배열의 배제. PHP 4.1.0에서 소개한 자동전역 배열을 사용하십시오. 그 종류는 $_GET, $_POST, $_COOKIE, $_SERVER, $_FILES, $_ENV, $_REQUEST, $_SESSION입니다. $HTTP_POST_VARS 등, 이전 형태의 $HTTP_*_VARS 배열은 PHP 3에서부터 계속 사용할 수 있습니다. PHP 5.0.0부터, 긴 형태의 PHP 예약 변수 배열을 register_long_arrays 지시어로 비활성화할 수 있습니다.

  • 기본값으로, 외부 변수를 더 이상 전역 변수로 등록하지 않습니다. 즉, PHP 4.2.0부터 php.ini에서의 PHP 설정 register_globals의 기본값이 off가 되었습니다. 이 값들에의 접근은 위에서 언급한 자동전역 배열을 이용하는 것을 권장합니다. 예전의 스크립트, 책, 그리고 튜토리얼은 이 설정을 on이라고 생각합니다. 예를 들어, 이 설정이 on이라면 누군가가 $id를 URL http://www.example.com/foo.php?id=42처럼 사용할 수 있습니다. on/off에 관계 없이, $_GET['id']는 사용할 수 있습니다.

이 변화에 대한 자세한 내용은 예약 정의 변수 섹션과 그 안의 링크들을 참고하십시오.

이전 | 처음으로 | 다음
XForms 다루기 | 위로 | 다음은?


다음은?

새로운 지식으로 매뉴얼과 예제 아카이브의 수많은 예제 스크립트의 대부분을 이해할 수 있을 것입니다. php.net 사이트의 또다른 예제들을 다음 링크 섹션에서 찾아볼 수 있습니다: http://www.php.net/links.php.

PHP로 할 수 있는 많은 일들에 대한 다양한 슬라이드 프리젠테이션을 PHP Conference Material 사이트에서 볼 수 있습니다: http://conf.php.net/, http://talks.php.net/

이전 | 처음으로 | 다음
새 버전의 PHP에서 예전의 코드를 사용하기 | 위로 | 설치


설치

PHP 매뉴얼
이전 다음

3. 장. 설치

차례
General Installation Considerations
Unix/HP-UX installs
Unix/Linux installs
Unix/Mac OS X installs
Unix/OpenBSD installs
Unix/Solaris installs
유닉스 시스템에 설치
Installation on Windows systems
Servers-CGI/Commandline
서버-아파치
서버-아파치 2.0
Servers-Caudium
Servers-fhttpd
Servers-IIS/PWS
Servers-Netscape, iPlanet and SunONE
Servers-OmniHTTPd Server
Servers-Oreilly Website Pro
Servers-Sambar
Servers-Xitami
Servers-Other web servers
Problems?
Miscellaneous configure options

General Installation Considerations

Before installing first, you need to know what do you want to use PHP for. There are three main fields you can use PHP, as described in the What can PHP do? section:

  • Server-side scripting

  • Command line scripting

  • Client-side GUI applications

For the first and most common form, you need three things: PHP itself, a web server and a web browser. You probably already have a web browser, and depending on your operating system setup, you may also have a web server (e.g. Apache on Linux or IIS on Windows). You may also rent webspace at a company. This way, you don't need to set up anything on your own, only write your PHP scripts, upload it to the server you rent, and see the results in your browser.

While setting up the server and PHP on your own, you have two choices for the method of connecting PHP to the server. For many servers PHP has a direct module interface (also called SAPI). These servers include Apache, Microsoft Internet Information Server, Netscape and iPlanet servers. Many other servers have support for ISAPI, the Microsoft module interface (OmniHTTPd for example). If PHP has no module support for your web server, you can always use it as a CGI processor. This means you set up your server to use the command line executable of PHP (php.exe on Windows) to process all PHP file requests on the server.

If you are also interested to use PHP for command line scripting (e.g. write scripts autogenerating some images for you offline, or processing text files depending on some arguments you pass to them), you always need the command line executable. For more information, read the section about writing command line PHP applications. In this case, you need no server and no browser.

With PHP you can also write client side GUI applications using the PHP-GTK extension. This is a completely different approach than writing web pages, as you do not output any HTML, but manage windows and objects within them. For more information about PHP-GTK, please visit the site dedicated to this extension. PHP-GTK is not included in the official PHP distribution.

From now on, this section deals with setting up PHP for web servers on Unix and Windows with server module interfaces and CGI executables.

Downloading PHP, the source code, and binary distributions for Windows can be found at http://www.php.net/downloads.php. We recommend you to choose a mirror nearest to you for downloading the distributions.

이전 | 처음으로 | 다음
다음은? | 위로 | Unix/HP-UX installs


Unix/HP-UX installs

This section contains notes and hints specific to installing PHP on HP-UX systems. (Contributed by paul_mckay at clearwater-it dot co dot uk).

참고: These tips were written for PHP 4.0.4 and Apache 1.3.9.

  1. You need gzip, download a binary distribution from http://hpux.connect.org.uk/ftp/hpux/Gnu/gzip-1.2.4a/gzip-1.2.4a-sd-10.20.depot.Z uncompress the file and install using swinstall.

  2. You need gcc, download a binary distribution from http://gatekeep.cs.utah.edu/ftp/hpux/Gnu/gcc-2.95.2/gcc-2.95.2-sd-10.20.depot.gz. uncompress this file and install gcc using swinstall.

  3. You need the GNU binutils, you can download a binary distribution from http://hpux.connect.org.uk/ftp/hpux/Gnu/binutils-2.9.1/binutils-2.9.1-sd-10.20.depot.gz. uncompress this file and install binutils using swinstall.

  4. You now need bison, you can download a binary distribution from http://hpux.connect.org.uk/ftp/hpux/Gnu/bison-1.28/bison-1.28-sd-10.20.depot.gz, install as above.

  5. You now need flex, you need to download the source from one of the http://www.gnu.org mirrors. It is in the non-gnu directory of the ftp site. Download the file, gunzip, then tar -xvf it. Go into the newly created flex directory and run ./configure, followed by make, and then make install.

    If you have errors here, it's probably because gcc etc. are not in your PATH so add them to your PATH.

  6. Download the PHP and apache sources.

  7. gunzip and tar -xvf them. We need to hack a couple of files so that they can compile OK.

  8. Firstly the configure file needs to be hacked because it seems to lose track of the fact that you are a hpux machine, there will be a better way of doing this but a cheap and cheerful hack is to put lt_target=hpux10.20 on line 47286 of the configure script.

  9. Next, the Apache GuessOS file needs to be hacked. Under apache_1.3.9/src/helpers change line 89 from echo "hp${HPUXMACH}-hpux${HPUXVER}"; exit 0 to: echo "hp${HPUXMACH}-hp-hpux${HPUXVER}"; exit 0

  10. You cannot install PHP as a shared object under HP-UX so you must compile it as a static, just follow the instructions at the Apache page.

  11. PHP and Apache should have compiled OK, but Apache won't start. you need to create a new user for Apache, e.g. www, or apache. You then change lines 252 and 253 of the conf/httpd.conf in Apache so that instead of

    User nobody
Group nogroup

    you have something like

    User www
Group sys

    This is because you can't run Apache as nobody under hp-ux. Apache and PHP should then work.

이전 | 처음으로 | 다음
설치 | 위로 | Unix/Linux installs


Unix/Linux installs

This section contains notes and hints specific to installing PHP on Linux distributions.

Using Packages

Many Linux distributions have some sort of package installation system, such as RPM. This can assist in setting up a standard configuration, but if you need to have a different set of features (such as a secure server, or a different database driver), you may need to build PHP and/or your webserver. If you are unfamiliar with building and compiling your own software, it is worth checking to see whether somebody has already built a packaged version of PHP with the features you need.

이전 | 처음으로 | 다음
Unix/HP-UX installs | 위로 | Unix/Mac OS X installs


Unix/Mac OS X installs

This section contains notes and hints specific to installing PHP on Mac OS X Server.

Using Packages

There are a few pre-packaged and pre-compiled versions of PHP for Mac OS X. This can help in setting up a standard configuration, but if you need to have a different set of features (such as a secure server, or a different database driver), you may need to build PHP and/or your web server yourself. If you are unfamiliar with building and compiling your own software, it's worth checking whether somebody has already built a packaged version of PHP with the features you need.

Compiling for OS X server

There are two slightly different versions of Mac OS X, client and server. The following is for OS X Server.

Mac OS X server install.

  1. Get the latest distributions of Apache and PHP.

  2. Untar them, and run the configure program on Apache like so.
    ./configure --exec-prefix=/usr \
--localstatedir=/var \
--mandir=/usr/share/man \
--libexecdir=/System/Library/Apache/Modules \
--iconsdir=/System/Library/Apache/Icons \
--includedir=/System/Library/Frameworks/Apache.framework/Versions/1.3/Headers \
--enable-shared=max \
--enable-module=most \
--target=apache

  3. If you want the compiler to do some optimization., you may also want to add this line:
    setenv OPTIM=-O2

  4. Next, go to the PHP 4 source directory and configure it.
    ./configure --prefix=/usr \
    --sysconfdir=/etc \
    --localstatedir=/var \
    --mandir=/usr/share/man \
    --with-xml \
    --with-apache=/src/apache_1.3.12
    If you have any other additions (MySQL, GD, etc.), be sure to add them here. For the --with-apache string, put in the path to your apache source directory, for example /src/apache_1.3.12.

  5. Type make and make install. This will add a directory to your Apache source directory under src/modules/php4.

  6. Now, reconfigure Apache to build in PHP 4.
    ./configure --exec-prefix=/usr \
--localstatedir=/var \
--mandir=/usr/share/man \
--libexecdir=/System/Library/Apache/Modules \
--iconsdir=/System/Library/Apache/Icons \
--includedir=/System/Library/Frameworks/Apache.framework/Versions/1.3/Headers \
--enable-shared=max \
--enable-module=most \
--target=apache \
--activate-module=src/modules/php4/libphp4.a
    You may get a message telling you that libmodphp4.a is out of date. If so, go to the src/modules/php4 directory inside your apache source directory and run this command: ranlib libmodphp4.a. Then go back to the root of the apache source directory and run the above configure command again. That'll bring the link table up to date. Run make and make install again.

  7. Copy and rename the php.ini-dist file to your bin directory from your PHP 4 source directory: cp php.ini-dist /usr/local/bin/php.ini or (if your don't have a local directory) cp php.ini-dist /usr/bin/php.ini.

Compiling for MacOS X client

Those tips are graciously provided by Marc Liyanage.

The PHP module for the Apache web server included in Mac OS X. This version includes support for the MySQL and PostgreSQL databases.

NOTE: Be careful when you do this, you could screw up your Apache web server!

Do this to install:

  1. Open a terminal window.

  2. Type wget http://www.diax.ch/users/liyanage/software/macosx/libphp4.so.gz, wait for the download to finish.

  3. Type gunzip libphp4.so.gz.

  4. Type sudo apxs -i -a -n php4 libphp4.so

  5. Now type sudo open -a TextEdit /etc/httpd/httpd.conf. TextEdit will open with the web server configuration file. Locate these two lines towards the end of the file: (Use the Find command)
    #AddType application/x-httpd-php .php
#AddType application/x-httpd-php-source .phps
    Remove the two hash marks (#), then save the file and quit TextEdit.

  6. Finally, type sudo apachectl graceful to restart the web server.

PHP should now be up and running. You can test it by dropping a file into your Sites folder which is called test.php. Into that file, write this line: <?php phpinfo() ?>.

Now open up 127.0.0.1/~your_username/test.php in your web browser. You should see a status table with information about the PHP module.

이전 | 처음으로 | 다음
Unix/Linux installs | 위로 | Unix/OpenBSD installs


Unix/OpenBSD installs

This section contains notes and hints specific to installing PHP on OpenBSD 3.4.

Using Binary Packages

Using binary packages to install PHP on OpenBSD is the recommended and simplest method. The core package has been separated from the various modules, and each can be installed and removed independently from the others. The files you need can be found on your OpenBSD CD or on the FTP site.

The main package you need to install is php4-core-4.3.3.tgz, which contains the basic engine (plus gettext and iconv). Next, take a look at the module packages, such as php4-mysql-4.3.3.tgz or php4-imap-4.3.3.tgz. You need to use the phpxs command to activate and deactivate these modules in your php.ini.

예 3-1. OpenBSD Package Install Example

# pkg_add php4-core-4.3.3.tgz
# /usr/local/sbin/phpxs -s
# cp /usr/local/share/doc/php4/php.ini-recommended /var/www/conf/php.ini
  (add in mysql)
# pkg_add php4-mysql-4.3.3.tgz
# /usr/local/sbin/phpxs -a mysql
  (add in imap)
# pkg_add php4-imap-4.3.3.tgz
# /usr/local/sbin/phpxs -a imap
  (remove mysql as a test)
# pkg_delete php4-mysql-4.3.3
# /usr/local/sbin/phpxs -r mysql
  (install the PEAR libraries)
# pkg_add php4-pear-4.3.3.tgz

Read the packages(7) manual page for more information about binary packages on OpenBSD.

Using Ports

You can also compile up PHP from source using the ports tree. However, this is only recommended for users familiar with OpenBSD. The PHP 4 port is split into two sub-directories: core and extensions. The extensions directory generates sub-packages for all of the supported PHP modules. If you find you do not want to create some of these modules, use the no_* FLAVOR. For example, to skip building the imap module, set the FLAVOR to no_imap.

Common Problems

  • The default install of Apache runs inside a chroot(2) jail, which will restrict PHP scripts to accessing files under /var/www. You will therefore need to create a /var/www/tmp directory for PHP session files to be stored, or use an alternative session backend. In addition, database sockets need to be placed inside the jail or listen on the localhost interface. If you use network functions, some files from /etc such as /etc/resolv.conf and /etc/services will need to be moved into /var/www/etc. The OpenBSD PEAR package automatically installs into the correct chroot directories, so no special modification is needed there. More information on the OpenBSD Apache is available in the OpenBSD FAQ.

  • The OpenBSD 3.4 package for the gd extension requires XFree86 to be installed. If you do not wish to use some of the font features that require X11, install the php4-gd-4.3.3-no_x11.tgz package instead.

Older Releases

Older releases of OpenBSD used the FLAVORS system to compile up a statically linked PHP. Since it is hard to generate binary packages using this method, it is now deprecated. You can still use the old stable ports trees if you wish, but they are unsupported by the OpenBSD team. If you have any comments about this, the current maintainer for the port is Anil Madhavapeddy (avsm at openbsd dot org).

이전 | 처음으로 | 다음
Unix/Mac OS X installs | 위로 | Unix/Solaris installs


Unix/Solaris installs

This section contains notes and hints specific to installing PHP on Solaris systems.

Required software

Solaris installs often lack C compilers and their related tools. Read this FAQ for information on why using GNU versions for some of these tools is necessary. The required software is as follows:

  • gcc (recommended, other C compilers may work)

  • make

  • flex

  • bison

  • m4

  • autoconf

  • automake

  • perl

  • gzip

  • tar

  • GNU sed

In addition, you will need to install (and possibly compile) any additional software specific to your configuration, such as Oracle or MySQL.

Using Packages

You can simplify the Solaris install process by using pkgadd to install most of your needed components.

이전 | 처음으로 | 다음
Unix/OpenBSD installs | 위로 | 유닉스 시스템에 설치


유닉스 시스템에 설치

이 섹션은 PHP를 유닉스 시스템에 설치하는 일반적인 설정과 방법을 안내합니다. 작업을 시작하기 전에 사용하는 플랫폼이나 웹 서버에 특화한 섹션이 존재하는지 살펴보십시오.

필요한 사전 지식과 소프트웨어:

  • 기본 유닉스 기술 (컴파일할 때, "make"와 C 컴파일러를 실행 가능)

  • ANSI C 컴파일러 (컴파일할 때)

  • flex (컴파일을 위해)

  • bison (컴파일을 위해)

  • 웹 서버

  • 특정한 모듈 컴포넌트 (gd, pdf libs 등등)

유닉스 플랫폼에 PHP 설치는 여러가지 방법이 존재합니다. 컴파일과 설정을 할 수도 있고, 다양한 패키지를 사용할 수도 있습니다. 이 문서는 주로 PHP를 컴파일하고 설정하는 방법을 다룹니다.

PHP 설치의 첫 단계는 configure 스크립트를 통한 명령줄 옵션의 설정입니다. 이 페이지에서는 가장 일반적인 옵션을 설명하지만, 사용할 수 있는 다른 많은 옵션이 존재합니다. 철저히 하기 위해서는 설정 옵션의 전체 목록을 확인하십시오. PHP를 인스톨하는 여러가지 방법이 존재합니다:

  • 아파치 1.x 모듈이나 아파치 2.x 모듈

  • Caudium의 Pike 모듈

  • AOL서버, NSAPI, phttpd, Pi3Web, Roxen, thttpd, Zeus와 함께 사용

  • CGI 실행

아파치 모듈 퀵 레퍼런스

PHP는 여러 방법으로 컴파일 할 수 있지만, 가장 많이 사용하는 것은 아파치 모듈입니다. 다음은 빠른 설치를 위한 개요입니다.

예 3-2. PHP 4의 빠른 설치 순서 (아파치 모듈 버전)

1.  gunzip apache_1.3.x.tar.gz
2.  tar xvf apache_1.3.x.tar
3.  gunzip php-x.x.x.tar.gz
4.  tar xvf php-x.x.x.tar
5.  cd apache_1.3.x
6.  ./configure --prefix=/www
7.  cd ../php-x.x.x
8.  ./configure --with-mysql --with-apache=../apache_1.3.x --enable-ftp
9.  make
10. make install
11. cd ../apache_1.3.x
12. ./configure --activate-module=src/modules/php4/libphp4.a
13. make
14. make install
15. cd ../php-x.x.x
16. cp php.ini-dist /usr/local/lib/php.ini
17. httpd.conf나 srm.conf 파일을 수정하고 다음을 추가:
      AddType application/x-httpd-php .php

18. 아파치 서버를 재시작하는 보통의 처리. (HUP나 USR1 시그널로 리로드하는게
    아닌, 서버 중지 및 재시작을 해야 합니다)

빌딩

PHP를 설정하면, CGI 실행 파일을 빌드할 수 있습니다. make가 이를 처리해줍니다. 실패하고 어째서인지를 파악할 수 없으면, 문제 섹션을 읽어보십시오.

이전 | 처음으로 | 다음
Unix/Solaris installs | 위로 | Installation on Windows systems


Installation on Windows systems

This section applies to Windows 98/Me and Windows NT/2000/XP. PHP will not work on 16 bit platforms such as Windows 3.1 and sometimes we refer to the supported Windows platforms as Win32. Windows 95 is no longer supported as of PHP 4.3.0.

There are two main ways to install PHP for Windows: either manually or by using the InstallShield installer.

If you have Microsoft Visual Studio, you can also build PHP from the original source code.

Once you have PHP installed on your Windows system, you may also want to load various extensions for added functionality.

Windows InstallShield

The Windows PHP installer is available from the downloads page at http://www.php.net/downloads.php. This installs the CGI version of PHP and, for IIS, PWS, and Xitami, configures the web server as well.

참고: While the InstallShield installer is an easy way to make PHP work, it is restricted in many aspects, as automatic setup of extensions for example is not supported. The whole set of supported extensions is only available by downloading the zip binary distribution.

Install your selected HTTP server on your system and make sure that it works.

Run the executable installer and follow the instructions provided by the installation wizard. Two types of installation are supported - standard, which provides sensible defaults for all the settings it can, and advanced, which asks questions as it goes along.

The installation wizard gathers enough information to set up the php.ini file and configure the web server to use PHP. For IIS and also PWS on NT Workstation, a list of all the nodes on the server with script map settings is displayed, and you can choose those nodes to which you wish to add the PHP script mappings.

Once the installation has completed the installer will inform you if you need to restart your system, restart the server, or just start using PHP.

주의

Be aware, that this setup of PHP is not secure. If you would like to have a secure PHP setup, you'd better go on the manual way, and set every option carefully. This automatically working setup gives you an instantly working PHP installation, but it is not meant to be used on online servers.

Manual Installation Steps

This install guide will help you manually install and configure PHP on your Windows webserver. The original version of this guide was compiled by Bob Silva, and can be found at http://www.umesd.k12.or.us/php/win32install.html. You need to download the zip binary distribution from the downloads page at http://www.php.net/downloads.php.

PHP 4 for Windows comes in three flavours - a CGI executable (php.exe), a CLI executable (sapi/php.exe) and some other SAPI modules:

php4apache.dll - Apache 1.3.x module
php4apache2.dll - Apache 2.0.x module
php4isapi.dll - ISAPI Module for ISAPI compliant webservers like IIS 4.0/PWS 4.0 or newer.
php4nsapi.dll - Netscape/iPlanet module

The latter form is new to PHP 4, and provides significantly improved performance and some new functionality. The CLI version is designed to use PHP for command line scripting. More information about CLI is available in the chapter about using PHP from the command line

주의

The SAPI modules have been significantly improved in the 4.1 release, however, you may find that you encounter possible server errors or other server modules such as ASP failing, in older systems.

DCOM and MDAC requirements: If you choose one of the SAPI modules and use Windows 95, be sure to download and install the DCOM update from the Microsoft DCOM pages. If you use Microsoft Windows 9x/NT4 download the latest version of the Microsoft Data Access Components (MDAC) for your platform. MDAC is available at http://msdn.microsoft.com/data/.

The following steps should be performed on all installations before any server specific instructions.

  • Extract the distribution file to a directory of your choice, c:\ is a good start. The zip package expands to a foldername like php-4.3.1-Win32 which is assumed to be renamed to php. For the sake of convenience and to be version independent the following steps assume your extracted version of PHP lives in c:\php. You might choose any other location but you probably do not want to use a path in which spaces are included (for example: C:\Program Files\PHP is not a good idea). Some web servers will crash if you do. The structure of your directory you extracted the zip file will look like:

c:\php
   |
   +--cli
   |  |
   |  |-php.exe           -- CLI executable - ONLY for commandline scripting
   |
   |
   +--dlls                -- support dlls for extensions --> Windows system directory
   |  |
   |  |-expat.dll
   |  |
   |  |-fdftk.dll
   |  |
   |  |-...
   |
   +--extensions          -- extension dlls for PHP
   |  |
   |  |-php_bz2.dll
   |  |
   |  |-php_cpdf.dll
   |  |
   |  |-..
   |
   +--mibs                -- support files for SNMP
   |
   |
   +--openssl             -- support files for Openssl
   |
   |
   +--pdf-related         -- support files for PDF
   |
   |
   +--sapi                -- SAPI dlls
   |  |
   |  |-php4apache.dll
   |  |
   |  |-php4apache2.dll
   |  |
   |  |-php4isapi.dll
   |  |
   |  |-..
   |
   |-install.txt
   |
   |-..
   |
   |-php.exe              -- CGI executable
   |
   |-..
   |
   |-php.ini-dist
   |
   |-php.ini-recommended
   |
   |-php4ts.dll           -- main dll --> Windows system directory
   |
   |-...

The CGI binary - c:\php\php.exe -, the CLI binary - c:\php\cli\php.exe -, and the SAPI modules - c:\php\sapi\*.dll - rely on the main dll c:\php\php4ts.dll. You have to make sure, that this dll can be found by your PHP installation. The search order for this dll is as follows:

The same directory from where php.exe is called. In case you use a SAPI module the same directory from where your webserver loads the dll (e.g. php4apache.dll).
Any directory in your Windows PATH environment variable.

  • The best bet is to make php4ts.dll available, regardless which interface (CGI or SAPI module) you plan to use. To do so, you have to copy this dll to a directory on your Windows path. The best place is your Windows system directory:

    C:\Windows\System for Windows 9x/ME
    C:\WINNT\System32 for Windows NT/2000 or C:\WINNT40\System32 for NT/2000 server
    C:\Windows\System32 for Windows XP

    If you plan to use a SAPI module from c:\php\sapi and do not like to copy dlls to your Windows system directory, you have the alternative choice to simply copy php4ts.dll to the sapi folder of your extracted zip package, c:\php\sapi.

  • The next step is to set up a valid configuration file for PHP, php.ini. There are two ini files distributed in the zip file, php.ini-dist and php.ini-recommended. We advise you to use php.ini-recommended, because we optimized the default settings in this file for performance, and security. Read this well documented file carefully and in addition study the ini settings and set every element manually yourself. If you would like to achieve the best security, then this is the way for you, although PHP works fine with these default ini files. Copy your chosen ini-file to a directory where PHP is able to find and rename it to php.ini. By default PHP searches php.ini in your Windows directory:

    On Windows 9x/ME/XP copy your chosen ini file to your %WINDIR%, which is typically C:\Windows.
    On Windows NT/2000 copy your chosen ini file to your %WINDIR% or %SYSTEMROOT%, which is typically C:\WINNT or C:\WINNT40 for NT/2000 servers.

  • If you're using NTFS on Windows NT, 2000 or XP, make sure that the user running the webserver has read permissions to your php.ini (e.g. make it readable by Everyone).

The following steps are optional.

  • Edit your new php.ini file. If you plan to use OmniHTTPd, do not follow the next step. Set the doc_root to point to your webservers document_root. For example:

    doc_root = c:\inetpub        // for IIS/PWS

doc_root = c:\apache\htdocs // for Apache

  • Choose which extensions you would like to load when PHP starts. See the section about Windows extensions, about how to set up one, and what is already built in. Note that on a new installation it is advisable to first get PHP working and tested without any extensions before enabling them in php.ini.

  • On PWS and IIS, you can set the browscap configuration setting to point to: c:\windows\system\inetsrv\browscap.ini on Windows 9x/Me, c:\winnt\system32\inetsrv\browscap.ini on NT/2000, and c:\windows\system32\inetsrv\browscap.ini on XP.

Following this instructions you are done with the basic steps to setup PHP on Windows. The next step is to choose a webserver and enable it to run PHP. Installation instructions for the following webservers are available:

  • .. the Windows server family, Personal Web server (PWS) 3 and 4 or newer; Internet Information Server (IIS) 3 and 4 or newer.

  • .. the Apache servers Apache 1.3.x, and Apache 2.x.

  • .. the Netscape/iPlanet servers.

  • .. the OmniHTTPd server.

  • .. the Oreilly Website Pro server.

  • .. the Sambar server.

  • .. the Xitami server.

Building from source

Before getting started, it is worthwhile answering the question: "Why is building on Windows so hard?" Two reasons come to mind:

  1. Windows does not (yet) enjoy a large community of developers who are willing to freely share their source. As a direct result, the necessary investment in infrastructure required to support such development hasn't been made. By and large, what is available has been made possible by the porting of necessary utilities from Unix. Don't be surprised if some of this heritage shows through from time to time.

  2. Pretty much all of the instructions that follow are of the "set and forget" variety. So sit back and try follow the instructions below as faithfully as you can.

요구 사항

To compile and build PHP you need a Microsoft Development Environment. Microsoft Visual C++ 6.0 is recommended. To extract the downloaded files you need a extraction utility (e.g.: Winzip). If you don't already have an unzip utility, you can get a free version from InfoZip.

Before you get started, you have to download...

  • ..the win32 buildtools from the PHP site at http://www.php.net/extra/win32build.zip.

  • ..the source code for the DNS name resolver used by PHP from http://www.php.net/extra/bindlib_w32.zip. This is a replacement for the resolv.lib library included in win32build.zip.

  • If you plan to compile PHP as a Apache module you will also need the Apache sources.

Finally, you are going to need the source to PHP 4 itself. You can get the latest development version using anonymous CVS, a snapshot or the most recent released source tarball.

Putting it all together

After downloading the required packages you have to extract them in a proper place.

  • Create a working directory where all files end up after extracting, e.g: C:\work.

  • Create the directory win32build under your working directory (C:\work) and unzip win32build.zip into it.

  • Create the directory bindlib_w32 under your working directory (C:\work) and unzip bindlib_w32.zip into it.

  • Extract the downloaded PHP source code into your working directory (C:\work).

Following this steps your directory structure looks like this:

+--c:\work
|  |
|  +--bindlib_w32
|  |  |
|  |  +--arpa
|  |  |
|  |  +--conf
|  |  |
|  |  +--...
|  |
|  +--php-4.x.x
|  |  |
|  |  +--build
|  |  |
|  |  +--...
|  |  |
|  |  +--win32
|  |  |
|  |  +--...
|  |
|  +--win32build
|  |  |
|  |  +--bin
|  |  |
|  |  +--include
|  |  |
|  |  +--lib

Create the directories c:\usr\local\lib. Copy bison.simple from c:\work\win32build\bin to c:\usr\local\lib.

참고: Cygwin users may omit the last step. A properly installed Cygwin environment provides the mandatory files bison.simple and bison.exe.

Configure MVC ++

The next step is to configure MVC ++ to prepare for compiling. Launch Microsoft Visual C++, and from the menu select Tools => Options. In the dialog, select the directories tab. Sequentially change the dropdown to Executables, Includes, and Library files. Your entries should look like this:

  • Executable files: c:\work\win32build\bin, Cygwin users: cygwin\bin

  • Include files: c:\work\win32build\include

  • Library files: c:\work\win32build\lib

Build resolv.lib

You must build the resolv.lib library. Decide whether you want to have debug symbols available (bindlib - Win32 Debug) or not (bindlib - Win32 Release). Build the appropriate configuration:

  • For GUI users, launch VC++, and then select File => Open Workspace, navigate to c:\work\bindlib_w32 and select bindlib.dsw. Then select Build=>Set Active Configuration and select the desired configuration. Finally select Build=>Rebuild All.

  • For command line users, make sure that you either have the C++ environment variables registered, or have run vcvars.bat, and then execute one of the following commands:

    • msdev bindlib.dsp /MAKE "bindlib - Win32 Debug"

    • msdev bindlib.dsp /MAKE "bindlib - Win32 Release"

At this point, you should have a usable resolv.lib in either your c:\work\bindlib_w32\Debug or Release subdirectories. Copy this file into your c:\work\win32build\lib directory over the file by the same name found in there.

Compiling

The best way to get started is to build the CGI version.

  • For GUI users, launch VC++, and then select File => Open Workspace and select c:\work\php-4.x.x\win32\php4ts.dsw . Then select Build=>Set Active Configuration and select the desired configuration, either php4ts - Win32 Debug_TS or php4ts - Win32 Release_TS. Finally select Build=>Rebuild All.

  • For command line users, make sure that you either have the C++ environment variables registered, or have run vcvars.bat, and then execute one of the following commands from the c:\work\php-4.x.x\win32 directory:

    • msdev php4ts.dsp /MAKE "php4ts - Win32 Debug_TS"

    • msdev php4ts.dsp /MAKE "php4ts - Win32 Release_TS"

    • At this point, you should have a usable php.exe in either your c:\work\php-4.x.x.\Debug_TS or Release_TS subdirectories.

It is possible to do minor customization to the build process by editing the main/config.win32.h file. For example you can change the default location of php.ini, the built-in extensions, and the default location for your extensions.

Next you may want to build the CLI version which is designed to use PHP from the command line. The steps are the same as for building the CGI version, except you have to select the php4ts_cli - Win32 Debug_TS or php4ts_cli - Win32 Release_TS project file. After a successful compiling run you will find the php.exe in either the directory Release_TS\cli\ or Debug_TS\cli\.

참고: If you want to use PEAR and the comfortable command line installer, the CLI-SAPI is mandatory. For more information about PEAR and the installer read the documentation at the PEAR website.

In order to build the SAPI module (php4isapi.dll) for integrating PHP with Microsoft IIS, set your active configuration to php4isapi-whatever-config and build the desired dll.

Installation of Windows extensions

After installing PHP and a webserver on Windows, you will probably want to install some extensions for added functionality. You can choose which extensions you would like to load when PHP starts by modifying your php.ini. You can also load a module dynamically in your script using dl().

The DLLs for PHP extensions are prefixed with 'php_' in PHP 4 (and 'php3_' in PHP 3). This prevents confusion between PHP extensions and their supporting libraries.

참고: In PHP 4.3.1 BCMath, Calendar, COM, Ctype, FTP, MySQL, ODBC, Overload, PCRE, Session, Tokenizer, WDDX, XML and Zlib support is built in. You don't need to load any additional extensions in order to use these functions. See your distributions README.txt or install.txt or this table for a list of built in modules.

The default location PHP searches for extensions is c:\php4\extensions. To change this setting to reflect your setup of PHP edit your php.ini file:

  • You will need to change the extension_dir setting to point to the directory where your extensions lives, or where you have placed your php_*.dll files. Please do not forget the last backslash. For example:

    extension_dir = c:/php/extensions/

  • Enable the extension(s) in php.ini you want to use by uncommenting the extension=php_*.dll lines in php.ini. This is done by deleting the leading ; form the extension you want to load.

    예 3-3. Enable Bzip2 extension for PHP-Windows

    // change the following line from ...
;extension=php_bz2.dll

// ... to
extension=php_bz2.dll

  • Some of the extensions need extra DLLs to work. Couple of them can be found in the distribution package, in the c:\php\dlls\ folder but some, for example Oracle (php_oci8.dll) require DLLs which are not bundled with the distribution package. Copy the bundled DLLs from c:\php\dlls folder to your Windows PATH, safe places are:

    c:\windows\system for Windows 9x/Me
    c:\winnt\system32 for Windows NT/2000
    c:\windows\system32 for Windows XP

    If you have them already installed on your system, overwrite them only if something doesn't work correctly (Before overwriting them, it is a good idea to make a backup of them, or move them to another folder - just in case something goes wrong).

참고: If you are running a server module version of PHP remember to restart your webserver to reflect your changes to php.ini.

The following table describes some of the extensions available and required additional dlls.

표 3-1. PHP Extensions

Extension | Description | Notes
php_bz2.dll | bzip2 compression functions | None
php_calendar.dll | Calendar conversion functions | Built in since PHP 4.0.3
php_cpdf.dll | ClibPDF functions | None
php_crack.dll | Crack functions | None
php3_crypt.dll | Crypt functions | unknown
php_ctype.dll | ctype family functions | Built in since PHP 4.3.0
php_curl.dll | CURL, Client URL library functions | Requires: libeay32.dll, ssleay32.dll (bundled)
php_cybercash.dll | Cybercash payment functions | PHP <= 4.2.0
php_db.dll | DBM functions | Deprecated. Use DBA instead (php_dba.dll)
php_dba.dll | DBA: DataBase (dbm-style) Abstraction layer functions | None
php_dbase.dll | dBase functions | None
php3_dbm.dll | Berkeley DB2 library | unknown
php_dbx.dll | dbx functions |
php_domxml.dll | DOM XML functions | PHP <= 4.2.0 requires: libxml2.dll (bundled) PHP >= 4.3.0 requires: iconv.dll (bundled)
php_dotnet.dll | .NET functions | PHP <= 4.1.1
php_exif.dll | Read EXIF headers from JPEG | None
php_fbsql.dll | FrontBase functions | PHP <= 4.2.0
php_fdf.dll | FDF: Forms Data Format functions. | Requires: fdftk.dll (bundled)
php_filepro.dll | filePro functions | Read-only access
php_ftp.dll | FTP functions | Built-in since PHP 4.0.3
php_gd.dll | GD library image functions | Removed in PHP 4.3.2. Also note that truecolor functions are not available in GD1, instead, use php_gd2.dll.
php_gd2.dll | GD library image functions | GD2
php_gettext.dll | Gettext functions | PHP <= 4.2.0 requires gnu_gettext.dll (bundled), PHP >= 4.2.3 requires libintl-1.dll, iconv.dll (bundled).
php_hyperwave.dll | HyperWave functions | None
php_iconv.dll | ICONV characterset conversion | Requires: iconv-1.3.dll (bundled), PHP >=4.2.1 iconv.dll
php_ifx.dll | Informix functions | Requires: Informix libraries
php_iisfunc.dll | IIS management functions | None
php_imap.dll | IMAP POP3 and NNTP functions | PHP 3: php3_imap4r1.dll
php_ingres.dll | Ingres II functions | Requires: Ingres II libraries
php_interbase.dll | InterBase functions | Requires: gds32.dll (bundled)
php_java.dll | Java functions | PHP <= 4.0.6 requires: jvm.dll (bundled)
php_ldap.dll | LDAP functions | PHP <= 4.2.0 requires libsasl.dll (bundled), PHP >= 4.3.0 requires libeay32.dll, ssleay32.dll (bundled)
php_mbstring.dll | Multi-Byte String functions | None
php_mcrypt.dll | Mcrypt Encryption functions | Requires: libmcrypt.dll
php_mhash.dll | Mhash functions | PHP >= 4.3.0 requires: libmhash.dll (bundled)
php_mime_magic.dll | Mimetype functions | Requires: magic.mime (bundled)
php_ming.dll | Ming functions for Flash | None
php_msql.dll | mSQL functions | Requires: msql.dll (bundled)
php3_msql1.dll | mSQL 1 client | unknown
php3_msql2.dll | mSQL 2 client | unknown
php_mssql.dll | MSSQL functions | Requires: ntwdblib.dll (bundled)
php3_mysql.dll | MySQL functions | Built-in in PHP 4
php3_nsmail.dll | Netscape mail functions | unknown
php3_oci73.dll | Oracle functions | unknown
php_oci8.dll | Oracle 8 functions | Requires: Oracle 8.1+ client libraries
php_openssl.dll | OpenSSL functions | Requires: libeay32.dll (bundled)
php_oracle.dll | Oracle functions | Requires: Oracle 7 client libraries
php_overload.dll | Object overloading functions | Built in since PHP 4.3.0
php_pdf.dll | PDF functions | None
php_pgsql.dll | PostgreSQL functions | None
php_printer.dll | Printer functions | None
php_shmop.dll | Shared Memory functions | None
php_snmp.dll | SNMP get and walk functions | NT only!
php_sockets.dll | Socket functions | None
php_sybase_ct.dll | Sybase functions | Requires: Sybase client libraries
php_tokenizer.dll | Tokenizer functions | Built in since PHP 4.3.0
php_w32api.dll | W32api functions | None
php_xmlrpc.dll | XML-RPC functions | PHP >= 4.2.1 requires: iconv.dll (bundled)
php_xslt.dll | XSLT functions | PHP <= 4.2.0 requires sablot.dll, expat.dll (bundled). PHP >= 4.2.1 requires sablot.dll, expat.dll, iconv.dll (bundled).
php_yaz.dll | YAZ functions | Requires: yaz.dll (bundled)
php_zip.dll | Zip File functions | Read only access
php_zlib.dll | ZLib compression functions | Built in since PHP 4.3.0

이전 | 처음으로 | 다음
유닉스 시스템에 설치 | 위로 | Servers-CGI/Commandline


Servers-CGI/Commandline

The default is to build PHP as a CGI program. This creates a commandline interpreter, which can be used for CGI processing, or for non-web-related PHP scripting. If you are running a web server PHP has module support for, you should generally go for that solution for performance reasons. However, the CGI version enables Apache users to run different PHP-enabled pages under different user-ids. Please make sure you read through the Security chapter if you are going to run PHP as a CGI.

As of PHP 4.3.0, some important additions have happened to PHP. A new SAPI named CLI also exists and it has the same name as the CGI binary. What is installed at {PREFIX}/bin/php depends on your configure line and this is described in detail in the manual section named Using PHP from the command line. For further details please read that section of the manual.

Testing

If you have built PHP as a CGI program, you may test your build by typing make test. It is always a good idea to test your build. This way you may catch a problem with PHP on your platform early instead of having to struggle with it later.

Benchmarking

If you have built PHP 3 as a CGI program, you may benchmark your build by typing make bench. Note that if 안전 모드 is on by default, the benchmark may not be able to finish if it takes longer then the 30 seconds allowed. This is because the set_time_limit() can not be used in 안전 모드. Use the max_execution_time configuration setting to control this time for your own scripts. make bench ignores the configuration file.

참고: make bench is only available for PHP 3.

Using Variables

Some server supplied environment variables are not defined in the current CGI/1.1 specification. Only the following variables are defined there; everything else should be treated as 'vendor extensions': AUTH_TYPE, CONTENT_LENGTH, CONTENT_TYPE, GATEWAY_INTERFACE, PATH_INFO, PATH_TRANSLATED, QUERY_STRING, REMOTE_ADDR, REMOTE_HOST, REMOTE_IDENT, REMOTE_USER, REQUEST_METHOD, SCRIPT_NAME, SERVER_NAME, SERVER_PORT, SERVER_PROTOCOL and SERVER_SOFTWARE

이전 | 처음으로 | 다음
Installation on Windows systems | 위로 | 서버-아파치


서버-아파치

이 섹션은 PHP의 아파치 인스톨에 관한 주의와 힌트를 포함하고 있습니다. 유닉스와 윈도우즈 버전 양쪽 모두 대응합니다. 아파치 2에 대한 안내와 주의는 별도의 페이지에 존재합니다.

유닉스 아파치에 PHP 설치하기 상세

아래 10번째 줄의 configure에 설정 옵션의 완전 목록의 인수들을 선택할 수 있습니다. 안내가 적합하게 하기 위해서, 버전 번호는 제거되어 있습니다. 'xxx'를 파일에 따라 적합한 값으로 변경해야 합니다.

예 3-4. PHP 설치 안내 (아파치 공유 모듈 버전)

1.  gunzip apache_xxx.tar.gz
2.  tar -xvf apache_xxx.tar
3.  gunzip php-xxx.tar.gz
4.  tar -xvf php-xxx.tar
5.  cd apache_xxx
6.  ./configure --prefix=/www --enable-module=so
7.  make
8.  make install
9.  cd ../php-xxx

10. 이제, PHP를 설정합니다. 여기에서 PHP가 어떠한 확장을 사용할지
    등에 관한 다양한 옵션을 커스터마이징합니다. 사용할 수 있는 옵션
    목록은 ./configure --help 를 실행해보십시오. 이 예제에서는 간단히
    아파치 1과 MySQL 지원으로 설정합니다. apxs의 경로는 예제와 다를
    수 있습니다.

      ./configure --with-mysql --with-apxs=/www/bin/apxs

11. make
12. make install

    설치 후에 설정 옵션을 바꾸기를 결정했다면, 이 위의 세 단계만을
    반복하면 됩니다. 그리고 아파치를 재시작하면 새 모듈이 영향을
    미칩니다. 아파치의 재컴파일은 필요하지 않습니다.

    특별히 옵션을 지정하지 않는 한, 'make install'은 PEAR와 phpize 등의
    다양한 PHP 툴, PHP CLI 등등을 같이 설치합니다.

13. php.ini 파일 구성하기:

      cp php.ini-dist /usr/local/lib/php.ini

    PHP 옵션을 지정하기 위해 .ini 파일을 수정할 수 있습니다. php.ini를 다른
    위치에 놓기를 원한다면, 10번째 단계에서 --with-config-file-path=/some/path를
    사용하십시오.

    php.ini-recommended를 사용한다면, 안에 있는 변경 목록에 주의하십시오.
    그들은 PHP의 행동에 영향을 미칩니다.

14. PHP 모듈을 읽기 위해 httpd.conf를 수정합니다. LoadModule 구문의 오른쪽에
    있는 경로는 시스템의 PHP 모듈의 경로를 정확히 지정해야합니다. 위쪽의
    make install은 이 구문을 이미 추가했을 수도 있지만, 꼭 확인하십시오.

    PHP 4는:

      LoadModule php4_module libexec/libphp4.so

    PHP 5는:

      LoadModule php5_module libexec/libphp5.so

15. httpd.conf에서 ClearModuleList 아래쪽에 있을 AddModule 섹션에서
    이것을 추가하십시오:

    PHP 4는:

      AddModule mod_php4.c

    PHP 5는:

      AddModule mod_php5.c

16. 아파치에 몇몇 확장자를 PHP가 처리하도록 설정합니다. 예를 들면,
    아파치가 .php 확장자를 PHP가 처리하게 합니다. 스페이스로 구분하여
    확장자를 나열함으로써, 어떠한 확장자라도 PHP가 처리하게 할 수
    있습니다. 예제로 .phtml을 추가했습니다.

      AddType application/x-httpd-php .php .phtml

    .phps 확장자를 하이라이트된 PHP 소스로 보여주는게 일반적입니다.
    다음을 추가하면 됩니다:

      AddType application/x-httpd-php-source .phps

17. 아파치를 시작하는 정상적인 처리를 사용하십시오. (서버를 중지하고
    다시 시작해야 합니다. HUP나 USR1 시그널을 사용한 서버로 재시작은
    안됩니다.)

아파치 설치와 유닉스 종류에 따라서, 서버를 중지하고 재시작하는 많은 방법이 존재합니다. 아래는 각각의 아파치/유닉스 설치에 서버를 재시작하는 일반적인 명령입니다. /path/to/을 시스템에 어플리케이션 경로로 치환해야만 합니다.

예 3-5. 아파치를 재시작하는 예제 명령

1. 대부분의 리눅스와 SysV 계열:
/etc/rc.d/init.d/httpd restart

2. apachectl 스크립트 이용하기:
/path/to/apachectl stop
/path/to/apachectl start

3. httpdctl과 httpsdctl(OpenSSL 사용)은 apachectl과 비슷합니다:
/path/to/httpsdctl stop
/path/to/httpsdctl start

4. mod_ssl이나 기타 SSL 서버를 사용는, 수동 중지와 시작:
/path/to/apachectl stop
/path/to/apachectl startssl

apachectl과 http(s)dctl 바이너리 위치는 다양합니다. 시스템에 locate나 whereis나 which 명령이 있으면, 이들이 서버 제어 프로그램을 찾는 데 도움을 줄 것입니다.

아파치에 PHP를 컴파일하는 다른 예제들:

./configure --with-apxs --with-pgsql

아파치의 httpd.conf 파일에서 LoadModule 명령을 이용하여 아파치에 불러들일 수 있는 libphp4.so 공유 라이브러리를 작성합니다. PostgreSQL 지원은 libphp4.so 라이브러리 안에 포함합니다.

./configure --with-apxs --with-pgsql=shared

아파치를 위한 libphp4.so 공유 라이브러리를 작성하고, php.ini 파일에서 extension 지시어를 사용하거나 스크립트에서 dl() 함수를 이용하여 불러들일 수 있는 pgsql.so 공유 라이브러리를 작성합니다.

./configure --with-apache=/path/to/apache_source --with-pgsql

libmodphp4.a 라이브러리, mod_php4.c과 수반하는 파일들을 작성하고, 아파치 소스 트리의 src/modules/php4 디렉토리에 복사합니다. 그 후에 --activate-module=src/modules/php4/libphp4.a을 사용하여 아파치를 컴파일하면, 아파치 빌드 시스템이 libphp4.a을 만들고 httpd 바이너리에 정적으로 링크합니다. PostgreSQL 지원은 httpd 바이너리에 직접 포함합니다. 최종 결과로 아파치의 모든 요소와 PHP의 모든 요소를 포함하는 하나의 httpd을 만들어냅니다.

./configure --with-apache=/path/to/apache_source --with-pgsql=shared

PostgreSQL 지원을 직접 httpd에 포함하는 대신, php.ini 파일이나 dl()을 이용하여 PHP에 불러들일 수 있는 pgsql.so 공유 라이브러리를 얻는 것을 제외하면, 이전과 동일합니다.

여러 방법으로 PHP를 빌드하는 선택에서, 각 방법의 장단점을 고려해야 합니다. 공유 오브젝트로 빌드하면 아파치와 별도로 컴파일 할 수 있고, PHP에 추가하거나 변화가 있을 때 모든 것을 재컴파일 할 필요가 없어집니다. PHP를 아피치에 넣어서 빌드(정적 방법)하면 PHP는 빨리 읽혀지고 빠르게 작동합니다. 자세한 정보는 DSO 지원에 관한 아파치 웹페이지를 참고하십시오.

참고: 아파치의 기본 httpd.conf는 다음과 같은 섹션으로 배포됩니다:

User nobody
Group "#-1"

이를 "Group nogroup"이나 비슷한 것으로 ("Group daemon"도 일반적입니다) 변경하지 않으면 PHP는 파일을 열 수 없습니다.

참고: --with-apxs=/path/to/apxs을 사용할 때 apxs의 설치된 버전을 지정하십시오. 아파치 소스에 존재하는 apxs버전을 사용해서는 절대 안되며 시스템에 설치된 것이여야 합니다.

윈도우즈 아파치 1.3.x에 PHP 설치하기

윈도우즈 아파치 1.3.x에 PHP를 작동하는 방법은 두가지가 존재합니다. 한가지는 CGI 바이너리(php.exe)를 사용하는 것이고, 다른 방법은 아파치 모듈 DLL을 사용하는 것입니다. 두 경우 모두 아파치 서버를 중지하고, 아파치가 PHP와 작동하도록 httpd.conf를 수정해야 합니다.

윈도우즈에서 SAPI 모듈은 더욱 안정화할 필요가 있기 때문에, 보다 투명하고 안전한 CGI 바이너리를 사용하기를 권장합니다.

아파치에 PHP를 설정하는 일부 변경이 존재할 수 있지만, 이는 초보가 사용하기에도 충분히 간단합니다. 설정 지시어에 대한 내용은 아파치 Docs를 참고하십시오.

매뉴얼 설치 단계에서 설명한 대로 PHP 패키지를 c:\php\에 풀었다면, CGI 바이너리를 설정하기 위해 아파치 설정 파일에 다음의 줄을 추가해야 합니다.

  • ScriptAlias /php/ "c:/php/"

  • AddType application/x-httpd-php .php .phtml

  • Action application/x-httpd-php "/php/php.exe"

위 리스트의 두번째 줄은 httpd.conf 파일에 존재할 수 있지만, 주석으로 되어있습니다. c:/php/을 PHP의 정확한 경로를 지정해야 한다는 것을 기억하십시오.

주의

CGI 설치를 사용하면, 서버는 몇몇 가능한 공격에 노출됩니다. 공격으로부터 보호하기 위해서 CGI 보안섹션을 읽어보십시오.

PHP를 아파치 모듈로 사용할 때는, php4ts.dll을 windows/system(윈도우즈 9x/Me)이나 winnt/system32(윈도우즈 NT/2000)이나 windows/system32(윈도우즈 XP) 디렉토리에 복사하십시오. 이전의 파일은 덮어씌우십시오. 그 후에 다음의 줄을 아파치 httpd.conf 파일에 추가해야 합니다:

  • 좋아하는 편집기로 httpd.conf를 열어서 LoadModule 지시어에 위치시키고, 다음의 줄을 목록의 마지막에 추가하십시오. PHP 4는: LoadModule php4_module "c:/php/sapi/php4apache.dll" PHP 5는: LoadModule php5_module "c:/php/sapi/php5apache.dll"

  • 아파치 윈도우즈 인스톨러를 사용한 후에 mod_php4.c을 AddModule 지시어로 정의해야 합니다. 특히 CrearModuleList 지시어가 정의되어 있으면, 몇줄 아래에 존재할 것입니다. Addmodule 엔트리를 발견하면, 다음 줄을 목록의 마지막에 추가하십시오: AddModule mod_php4.c PHP5는 AddModule mod_php5.c을 사용하십시오.

  • # AddType allows you to tweak mime.types과 비슷한 구문을 찾아보십시오. 몇몇 AddType 엔트리를 발견하면, 다음 줄을 목록의 마지막에 추가하십시오: AddType application/x-httpd-php .php. 여기서 PHP로 처리할 확장자를 선택할 수 있습니다. .php는 단순한 권장 사항입니다. 심지어 .html을 포함할 수도 있고, .php3를 하위 호완을 위해 추가할 수 있습니다.

설정 파일을 변경한 후에는 서버를 재시작해야 합니다. 예를 들어, 아파치를 윈도우 서버로 사용한다면, NET STOP APACHE, NET START APACHE를 순차적으로 사용합니다. 혹은 일반적인 바로가기를 사용할 수 있습니다.

소스 코드 하이라이팅 기능을 사용은 두가지 방법이 있지만, 설치 방법에 의존합니다. 아파치에서 PHP를 SAPI 모듈로 사용하도록 설정했다면, 다음 줄을 httpd.conf(위에서 AddType application/x-httpd-php .php을 추가한 위치에)에 추가해여 이 기능을 사용할 수 있습니다: AddType application/x-httpd-php-source .phps.

아파치에서 PHP를 CGI 바이너리로 사용하도록 설정했다면, show_source() 함수를 사용할 필요가 있습니다. 간단히 PHP 스크립트 파일을 만들어서 이 코드를 추가하십시오: <?php show_source ("original_php_script.php"); ?>. original_php_script.php는 소스를 보고 싶은 파일 이름으로 변경하십시오.

참고: 윈-아파치에서 "c:\directory\file.ext"와 같은 경로 구문의 모든 백슬래쉬는 "c:/directory/file.ext"처럼 슬래쉬로 변경해야만 합니다.

이전 | 처음으로 | 다음
Servers-CGI/Commandline | 위로 | 서버-아파치 2.0


서버-아파치 2.0

이 섹션은 아파치 2.0에 PHP을 설치할 때의 정보와 힌트를 담고 있습니다. 유닉스와 윈도우즈 버전을 모두 다루고 있습니다.

주의

유닉스건 윈도우즈건 아파치 2.0과 PHP를 프로덕션 환경에서 사용하지 마십시오.

아파치 2.0 서버에 대한 기본 지식을 얻기 위해서 아파치 문서를 보는 것을 권장합니다.

PHP와 Apache 2.0 호환 정보

다음 버전의 PHP가 최근 버전의 아파치 2.0에서 작동하는 것으로 알려져 있습니다:

  • http://www.php.net/downloads.php에서 얻을 수 있는 PHP 4.3.0 이후 버전.
  • 최근의 안정 개발 버전. http://snaps.php.net/php4-latestest.tar.gz에서 소스 코드나 http://snaps.php.net/win32/php4-win32-latest.zip에서 윈도우즈 바이너리를 받을 수 있습니다.
  • http://qa.php.net/에서 받을 수 있는 프리릴리즈 버전.
  • 언제나 익명 CVS를 통해서 PHP을 얻을 수 있습니다.
이 버전들의 PHP은 아파치 2.0.40 이후에 호환됩니다.

참고: Apache 2.0 SAPI 지원은 PHP 4.2.0에서 시작되었습니다. PHP 4.2.3은 아파치 2.0.39에서 작동하지만, PHP 4.2.3과 더 이전 버전의 아파치는 사용하지 마십시오. PHP 4.3.0 이후와 가장 최신의 아파치2를 사용하는 것을 권장합니다.

위 모든 버전의 PHP는 여전히 아파치 1.3.x에서도 잘 동작합니다.

리눅스에서 PHP와 아파치 2

가장 최신 버전의 아파치 2.0와 위에서 언급한 적합한 PHP 버전을 받으십시오. 이 퀵가이드는 아파치 2.0에서 PHP를 시작하는 기본 지식만을 제공합니다. 자세한 정보는 아파치 문서를 읽어보십시오. 안내가 틀리지 않도록, 버전 번호는 제거되어 있습니다. 여기에서 'NN'을 파일에 따른 적합한 값으로 교체해야 합니다.

예 3-6. 설치 안내 (아파치 2 공유 모듈 버전)

1.  gzip -d httpd-2_0_NN.tar.gz
2.  tar xvf httpd-2_0_NN.tar
3.  gunzip php-NN.tar.gz
4.  tar -xvf php-NN.tar
5.  cd httpd-2_0_NN
6.  ./configure --enable-so
7.  make
8.  make install

    이제 /usr/local/apache2에 기본 MPM prefork와 동적 모듈 지원을
    설정한 Apache 2.0.NN을 사용할 수 있습니다.
    설치를 확인하기 위해 아파치 서버를 일반 프로시져로 시작해봅니다. 즉:
    /usr/local/apache2/bin/apachectl start
    그리고 PHP 설정을 하기 위해서 서버를 중지합니다:
    /usr/local/apache2/bin/apachectl stop

9.  cd ../php-NN

10. 이제, PHP를 설정합니다. 어떤 확장을 사용할 지 등의 PHP의 많은
    옵션을 지정할 차례입니다. ./configure --help로 사용할 수 있는 옵션
    목록을 얻을 수 있습니다. 예제에서는 간단히 아파치 2와 MySQL 지원을
    설정합니다. apxs의 경로는 시스템에 따라  다를 수 있고, 심지어 이름이
    apxs2일 수도 있습니다.

      ./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql

11. make
12. make install

    설치 후에 설정 옵션을 바꾸길 원한다면, 단지 바로 위의 세 단계만을
    반복하면 됩니다. 아파치를 재시작 하면 새 모듈이 작동합니다. 아파치를
    다시 컴파일할 필요는 없습니다.

    특별히 지정하지 않는 한, 'make install'은 PEAR, phpize 등의 PHP 툴,
    PHP CLI 등등을 함께 설치합니다.

13. php.ini 설정

    cp php.ini-dist /usr/local/lib/php.ini

    PHP 옵션을 설정하기 위해 .ini를 수정할 수 있습니다. php.ini를 다른
    위치에 놓기를 원한다면, 10번째 단계에서
    --with-config-file-path=/some/path를 사용하십시오.

    php.ini-recommended를 선택한다면, 안에 쓰여있는 변경점을 주의깊게
    읽어보십시오. 그 옵션들은 PHP의 작동에 영향을 미칩니다.

14. PHP 모듈을 읽기 위해 httpd.conf를 수정합니다. LoadModule 구문의
    오른쪽에는 시스템에 존재하는 PHP 모듈의 경로를 지정해야만 합니다.
    위쪽의 make install이 이미 이 작업을 마쳤을 수 있지만, 확인을
    해보아야 합니다.

    PHP 4는:

      LoadModule php4_module libexec/libphp4.so

    PHP 5는:

      LoadModule php5_module libexec/libphp5.so

15. 아파치에 PHP가 처리할 확장자들을 알려줍니다. 예를 들어,
    .php 확장자를 PHP가 처리하게 합시다. 공백으로 구분하여 어떠한
    확장자라도 PHP가 처리하도록 추가할 수 있습니다. 예제로
    .phtml을 추가했습니다.

      AddType application/x-httpd-php .php .phtml

    .phps를 하이라이트된 PHP 소스로 보여주는 것이 일반적입니다.
    이렇게 설정합니다:

      AddType application/x-httpd-php-source .phps

16. 아파치를 시작하는 일반 프로시저를 사용합니다. 즉:

      /usr/local/apache2/bin/apachectl start

위 단계를 따라하면 PHP을 SAPI 모듈로 지원하는 아파치 2.0이 설치됩니다. 물론, 아파치와 PHP에는 많은 설정 옵션이 존재합니다. 소스 트리에서 ./configure --help를 사용하여 정보를 얻을 수 있습니다. 멀티쓰레드 버전의 아파치 2.0을 빌드하려면 기본 MPM 모듈 prefork 대신에 worker나 perchild을 사용해야 합니다. 이를 위해서는 6번째 단계의 설정줄에 --with-mpm=workter나 --with-mpm=perchild를 추가해야 합니다. 하려고 하는 일을 이해하고 결과에 주의를 기울이십시오. 자세한 정보는 MPM 모듈에 대한 아파치 문서를 읽어보십시오.

참고: 멀티쓰레드 버전의 아파치를 빌드하려면 시스템이 쓰레드를 지원해야 합니다. 이는 또한 PHP이 실험적인 젠드 쓰레드 안전(ZTS)으로 빌드하게 합니다. 그리하여 모든 확장을 사용할 수 없습니다. 권장하는 설정은 아파치를 기본 prefork MPM 모듈로 빌드하는 것입니다.

윈도우즈에서 PHP와 아파치 2.0

아파치 2.0의 윈도우즈 특정 정보를 읽어보십시오.

주의

아파치 2.0은 윈도우즈 NT 4.0이나 윈도우즈 2000, 윈도우즈 XP에서 작동하도록 설계되었습니다. 현 시점에서 윈도우즈 9x 지원은 완성되지 않았습니다. 아파치 2.0은 현 시점에서 이런 플랫폼에서는 작동하지 않을 것입니다.

가장 최신 버전의 아파치 2.0와 위에서 언급한 적합한 PHP 버전을 받으십시오. 수동 설치 단계를 확인하고 PHP과 아파치의 결합으로 돌아오십시오.

윈도우즈 아파치 2.0에서 PHP를 설치하는 방법은 두가지가 있습니다. 하나는 CGI 바이너리를 사용하는 것이고, 다른 것은 아파치 모듈 DLL을 사용하는 것입니다. 어느 경우에도 아파치 서버를 중지하고, 아파치가 PHP과 작동하도록 httpd.conf를 수정해야 합니다.

CGI 바이너리로 설치할 때, 다음의 세 줄을 아파치 httpd.conf 설정 파일에 추가해야 합니다.

예 3-7. CGI로의 PHP와 아파치 2.0

ScriptAlias /php/ "c:/php/"
AddType application/x-httpd-php .php
Action application/x-httpd-php "/php/php.exe"

PHP을 아파치 2.0에 모듈로 사용하려면 PHP 4의 php4ts.dll이나 PHP 5의 php5ts.dll을 winnt/system32(윈도우즈 NT/2000)이나 windows/system32(윈도우즈 XP)로 옮겨야만 합니다. 파일이 이미 존재할 경우 덮어씌웁니다. 아파치 2.0에 PHP 모듈을 설정하려면 아파치 httpd.conf 설정 파일에 다음의 두 줄을 추가합니다. 아파치 2.0에서 PHP 모듈:

예 3-8. 모듈로의 PHP와 아파치 2.0

; PHP 4는 아래와 같이 합니다:
LoadModule php4_module "c:/php/sapi/php4apache2.dll"
AddType application/x-httpd-php .php

; PHP 5는 아래와 같이 합니다:
LoadModule php5_module "c:/php/sapi/php5apache2.dll"
AddType application/x-httpd-php .php

참고: 위 예제에서 c:/php/을 PHP의 실제 경로로 교체해야 합니다. LoadModule 지시어에서 php4apache2.dll이나 php5apache2.dll을 사용하는 점에 주의하십시오. 아파치 1.3.x와 작동하도록 설계한 php4apache.dll이나 php5apache.dll이 아닙니다.

주의

설치에서 다른 PHP 버전의 dll 파일과 섞이지 않게 하십시오. 다운로드한 PHP 버전에 들어있는 dll과 확장만을 선택해야 합니다.

이전 | 처음으로 | 다음
서버-아파치 | 위로 | Servers-Caudium


Servers-Caudium

PHP 4 can be built as a Pike module for the Caudium webserver. Note that this is not supported with PHP 3. Follow the simple instructions below to install PHP 4 for Caudium.

예 3-9. Caudium Installation Instructions

1.  Make sure you have Caudium installed prior to attempting to
    install PHP 4. For PHP 4 to work correctly, you will need Pike
    7.0.268 or newer. For the sake of this example we assume that
    Caudium is installed in /opt/caudium/server/.
2.  Change directory to php-x.y.z (where x.y.z is the version number).
3.  ./configure --with-caudium=/opt/caudium/server
4.  make
5.  make install
6.  Restart Caudium if it's currently running.
7.  Log into the graphical configuration interface and go to the
    virtual server where you want to add PHP 4 support.
8.  Click Add Module and locate and then add the PHP 4 Script Support module.
9.  If the documentation says that the 'PHP 4 interpreter isn't
    available', make sure that you restarted the server. If you did
    check /opt/caudium/logs/debug/default.1 for any errors related to
    <filename>PHP4.so</filename>. Also make sure that
    <filename>caudium/server/lib/[pike-version]/PHP4.so</filename>
    is present.
10. Configure the PHP Script Support module if needed.

You can of course compile your Caudium module with support for the various extensions available in PHP 4. See the complete list of configure options for an exhaustive rundown.

참고: When compiling PHP 4 with MySQL support you must make sure that the normal MySQL client code is used. Otherwise there might be conflicts if your Pike already has MySQL support. You do this by specifying a MySQL install directory the --with-mysql option.

이전 | 처음으로 | 다음
서버-아파치 2.0 | 위로 | Servers-fhttpd


Servers-fhttpd

To build PHP as an fhttpd module, answer "yes" to "Build as an fhttpd module?" (the --with-fhttpd=DIR option to configure) and specify the fhttpd source base directory. The default directory is /usr/local/src/fhttpd. If you are running fhttpd, building PHP as a module will give better performance, more control and remote execution capability.

참고: Support for fhttpd is no longer available as of PHP 4.3.0.

이전 | 처음으로 | 다음
Servers-Caudium | 위로 | Servers-IIS/PWS


Servers-IIS/PWS

This section contains notes and hints specific to IIS (Microsoft Internet Information Server). Installing PHP for PWS/IIS 3, PWS 4 or newer and IIS 4 or newer versions.

Important for CGI users: Read the faq on cgi.force_redirect for important details. This directive needs to be set to 0.

Windows and PWS/IIS 3

The recommended method for configuring these servers is to use the REG file included with the distribution (pws-php4cgi.reg). You may want to edit this file and make sure the extensions and PHP install directories match your configuration. Or you can follow the steps below to do it manually.

주의

These steps involve working directly with the Windows registry. One error here can leave your system in an unstable state. We highly recommend that you back up your registry first. The PHP Development team will not be held responsible if you damage your registry.

  • Run Regedit.

  • Navigate to: HKEY_LOCAL_MACHINE /System /CurrentControlSet /Services /W3Svc /Parameters /ScriptMap.

  • On the edit menu select: New->String Value.

  • Type in the extension you wish to use for your php scripts. For example .php

  • Double click on the new string value and enter the path to php.exe in the value data field. ex: c:\php\php.exe.

  • Repeat these steps for each extension you wish to associate with PHP scripts.

The following steps do not affect the web server installation and only apply if you want your PHP scripts to be executed when they are run from the command line (ex. run c:\myscripts\test.php) or by double clicking on them in a directory viewer window. You may wish to skip these steps as you might prefer the PHP files to load into a text editor when you double click on them.

  • Navigate to: HKEY_CLASSES_ROOT

  • On the edit menu select: New->Key.

  • Name the key to the extension you setup in the previous section. ex: .php

  • Highlight the new key and in the right side pane, double click the "default value" and enter phpfile.

  • Repeat the last step for each extension you set up in the previous section.

  • Now create another New->Key under HKEY_CLASSES_ROOT and name it phpfile.

  • Highlight the new key phpfile and in the right side pane, double click the "default value" and enter PHP Script.

  • Right click on the phpfile key and select New->Key, name it Shell.

  • Right click on the Shell key and select New->Key, name it open.

  • Right click on the open key and select New->Key, name it command.

  • Highlight the new key command and in the right side pane, double click the "default value" and enter the path to php.exe. ex: c:\php\php.exe -q %1. (don't forget the %1).

  • Exit Regedit.

  • If using PWS on Windows, reboot to reload the registry.

PWS and IIS 3 users now have a fully operational system. IIS 3 users can use a nifty tool from Steven Genusa to configure their script maps.

Windows and PWS 4 or newer

When installing PHP on Windows with PWS 4 or newer version, you have two options. One to set up the PHP CGI binary, the other is to use the ISAPI module DLL.

If you choose the CGI binary, do the following:

  • Edit the enclosed pws-php4cgi.reg file (look into the SAPI dir) to reflect the location of your php.exe. Backslashes should be escaped, for example: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\w3svc\parameters\Script Map] ".php"="c:\\php\\php.exe" Now merge this registery file into your system; you may do this by double-clicking it.

  • In the PWS Manager, right click on a given directory you want to add PHP support to, and select Properties. Check the 'Execute' checkbox, and confirm.

If you choose the ISAPI module, do the following:

  • Edit the enclosed pws-php4isapi.reg file (look into the SAPI dir) to reflect the location of your php4isapi.dll. Backslashes should be escaped, for example: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\w3svc\parameters\Script Map] ".php"="c:\\php\\sapi\\php4isapi.dll" Now merge this registery file into your system; you may do this by double-clicking it.

  • In the PWS Manager, right click on a given directory you want to add PHP support to, and select Properties. Check the 'Execute' checkbox, and confirm.

Windows NT/2000/XP and IIS 4 or newer

To install PHP on an NT/2000/XP Server running IIS 4 or newer, follow these instructions. You have two options to set up PHP, using the CGI binary (php.exe) or with the ISAPI module.

In either case, you need to start the Microsoft Management Console (may appear as 'Internet Services Manager', either in your Windows NT 4.0 Option Pack branch or the Control Panel=>Administrative Tools under Windows 2000/XP). Then right click on your Web server node (this will most probably appear as 'Default Web Server'), and select 'Properties'.

If you want to use the CGI binary, do the following:

  • Under 'Home Directory', 'Virtual Directory', or 'Directory', click on the 'Configuration' button, and then enter the App Mappings tab.

  • Click Add, and in the Executable box, type: c:\php\php.exe (assuming that you have unziped PHP in c:\php\).

  • In the Extension box, type the file name extension you want associated with PHP scripts. Leave 'Method exclusions' blank, and check the Script engine checkbox. You may also like to check the 'check that file exists' box - for a small performance penalty, IIS (or PWS) will check that the script file exists and sort out authentication before firing up php. This means that you will get sensible 404 style error messages instead of cgi errors complaining that PHP did not output any data.

    You must start over from the previous step for each extension you want associated with PHP scripts. .php and .phtml are common, although .php3 may be required for legacy applications.

  • Set up the appropriate security. (This is done in Internet Service Manager), and if your NT Server uses NTFS file system, add execute rights for I_USR_ to the directory that contains php.exe.

To use the ISAPI module, do the following:

  • If you don't want to perform HTTP Authentication using PHP, you can (and should) skip this step. Under ISAPI Filters, add a new ISAPI filter. Use PHP as the filter name, and supply a path to the php4isapi.dll.

  • Under 'Home Directory', click on the 'Configuration' button. Add a new entry to the Application Mappings. Use the path to the php4isapi.dll as the Executable, supply .php as the extension, leave Method exclusions blank, and check the Script engine checkbox.

  • Stop IIS completely (NET STOP iisadmin)

  • Start IIS again (NET START w3svc)

이전 | 처음으로 | 다음
Servers-fhttpd | 위로 | Servers-Netscape, iPlanet and SunONE


Servers-Netscape, iPlanet and SunONE

This section contains notes and hints specific to Netscape, iPlanet and SunONE webserver installs of PHP, both for Sun Solaris and Windows versions.

From PHP 4.3.3 on you can use PHP scripts with the NSAPI module to generate custom directory listings and error pages. Additional functions for Apache compatibility are also available. For support in current webservers read the note about subrequests.

You can find more information about setting up PHP for the Netscape Enterprise Server (NES) here: http://benoit.noss.free.fr/php/install-php4.html

Installing PHP with NES/iPlanet/SunONE Webserver on Sun Solaris

To build PHP with NES/iPlanet/SunONE webservers, enter the proper install directory for the --with-nsapi=[DIR] option. The default directory is usually /opt/netscape/suitespot/. Please also read /php-xxx-version/sapi/nsapi/nsapi-readme.txt.

  1. Install the following packages from http://www.sunfreeware.com/ or another download site:

    autoconf-2.13
    automake-1.4
    bison-1_25-sol26-sparc-local
    flex-2_5_4a-sol26-sparc-local
    gcc-2_95_2-sol26-sparc-local
    gzip-1.2.4-sol26-sparc-local
    m4-1_4-sol26-sparc-local
    make-3_76_1-sol26-sparc-local
    mysql-3.23.24-beta (if you want mysql support)
    perl-5_005_03-sol26-sparc-local
    tar-1.13 (GNU tar)

  2. Make sure your path includes the proper directories PATH=.:/usr/local/bin:/usr/sbin:/usr/bin:/usr/ccs/bin and make it available to your system export PATH.

  3. gunzip php-x.x.x.tar.gz (if you have a .gz dist, otherwise go to 4).

  4. tar xvf php-x.x.x.tar

  5. Change to your extracted PHP directory: cd ../php-x.x.x

  6. For the following step, make sure /opt/netscape/suitespot/ is where your netscape server is installed. Otherwise, change to the correct path and run:
    ./configure --with-mysql=/usr/local/mysql \
--with-nsapi=/opt/netscape/suitespot/ \
--enable-libgcc

  7. Run make followed by make install.

After performing the base install and reading the appropriate readme file, you may need to perform some additional configuration steps.

Configuration Instructions for NES/iPlanet/SunONE. Firstly you may need to add some paths to the LD_LIBRARY_PATH environment for SunONE to find all the shared libs. This can best done in the start script for your SunONE webserver. Windows users can probably skip this step. The start script is often located in: /path/to/server/https-servername/start. You may also need to edit the configuration files that are located in: /path/to/server/https-servername/config/.

  1. Add the following line to mime.types (you can do that by the administration server):
    type=magnus-internal/x-httpd-php exts=php

  2. Edit magnus.conf (for servers >= 6) or obj.conf (for servers < 6) and add the following, shlib will vary depending on your OS, for Unix it will be something like /opt/netscape/suitespot/bin/libphp4.so. You should place the following lines after mime types init.
    Init fn="load-modules" funcs="php4_init,php4_execute,php4_auth_trans" shlib="/opt/netscape/suitespot/bin/libphp4.so"
Init fn="php4_init" LateInit="yes" errorString="Failed to initialize PHP!" [php_ini="/path/to/php.ini"]
    (PHP >= 4.3.3) The php_ini parameter is optional but with it you can place your php.ini in your webserver config directory.

  3. Configure the default object in obj.conf (for virtual server classes [SunONE 6.0+] in their vserver.obj.conf):
    <Object name="default">
.
.
.
.#NOTE this next line should happen after all 'ObjectType' and before all 'AddLog' lines
Service fn="php4_execute" type="magnus-internal/x-httpd-php" [inikey=value inikey=value ...]
.
.
</Object>
    (PHP >= 4.3.3) As additional parameters you can add some special php.ini-values, for example you can set a docroot="/path/to/docroot" specific to the context php4_execute is called. For boolean ini-keys please use 0/1 as value, not "On","Off",... (this will not work correctly), e.g. zlib.output_compression=1 instead of zlib.output_compression="On"

  4. This is only needed if you want to configure a directory that only consists of PHP scripts (same like a cgi-bin directory):
    <Object name="x-httpd-php">
ObjectType fn="force-type" type="magnus-internal/x-httpd-php"
Service fn=php4_execute [inikey=value inikey=value ...]
</Object>
    After that you can configure a directory in the Administration server and assign it the style x-httpd-php. All files in it will get executed as PHP. This is nice to hide PHP usage by renaming files to .html.

  5. Setup of authentication: PHP authentication cannot be used with any other authentication. ALL AUTHENTICATION IS PASSED TO YOUR PHP SCRIPT. To configure PHP Authentication for the entire server, add the following line to your default object:
    <Object name="default">
AuthTrans fn=php4_auth_trans
.
.
.
</Object>

  6. To use PHP Authentication on a single directory, add the following:
    <Object ppath="d:\path\to\authenticated\dir\*">
AuthTrans fn=php4_auth_trans
</Object>

참고: The stacksize that PHP uses depends on the configuration of the webserver. If you get crashes with very large PHP scripts, it is recommended to raise it with the Admin Server (in the section "MAGNUS EDITOR").

Installing PHP with NES/iPlanet/SunONE on Windows

To Install PHP as CGI (for Netscape Enterprise Server, iPlanet, SunONE, perhaps Fastrack), do the following:

  • Copy php4ts.dll to your systemroot (the directory where you installed Windows)

  • Make a file association from the command line. Type the following two lines:
    assoc .php=PHPScript
ftype PHPScript=c:\php\php.exe %1 %*

  • In the Netscape Enterprise Administration Server create a dummy shellcgi directory and remove it just after (this step creates 5 important lines in obj.conf and allow the web server to handle shellcgi scripts).

  • In the Netscape Enterprise Administration Server create a new mime type (Category: type, Content-Type: magnus-internal/shellcgi, File Suffix:php).

  • Do it for each web server instance you want PHP to run

More details about setting up PHP as a CGI executable can be found here: http://benoit.noss.free.fr/php/install-php.html

To Install PHP as NSAPI (for Netscape Enterprise Server, iPlanet, SunONE, perhaps Fastrack), do the following:

  • Copy php4ts.dll to your systemroot (the directory where you installed Windows)

  • Make a file association from the command line. Type the following two lines:
    assoc .php=PHPScript
ftype PHPScript=c:\php\php.exe %1 %*

  • In the Netscape Enterprise Administration Server create a new mime type (Category: type, Content-Type: magnus-internal/x-httpd-php, File Suffix: php).

  • Edit magnus.conf (for servers >= 6) or obj.conf (for servers < 6) and add the following: You should place the lines after mime types init.
    Init fn="load-modules" funcs="php4_init,php4_execute,php4_auth_trans" shlib="c:/php/sapi/php4nsapi.dll"
Init fn="php4_init" LateInit="yes" errorString="Failed to initialise PHP!" [php_ini="c:/path/to/php.ini"]
    (PHP >= 4.3.3) The php_ini parameter is optional but with it you can place your php.ini in your webserver config directory.

  • Configure the default object in obj.conf (for virtual server classes [SunONE 6.0+] in their vserver.obj.conf): In the <Object name="default"> section, place this line necessarily after all 'ObjectType' and before all 'AddLog' lines:
    Service fn="php4_execute" type="magnus-internal/x-httpd-php" [inikey=value inikey=value ...]
    (PHP >= 4.3.3) As additional parameters you can add some special php.ini-values, for example you can set a docroot="/path/to/docroot" specific to the context php4_execute is called. For boolean ini-keys please use 0/1 as value, not "On","Off",... (this will not work correctly), e.g. zlib.output_compression=1 instead of zlib.output_compression="On"

  • This is only needed if you want to configure a directory that only consists of PHP scripts (same like a cgi-bin directory):
    <Object name="x-httpd-php">
ObjectType fn="force-type" type="magnus-internal/x-httpd-php"
Service fn=php4_execute [inikey=value inikey=value ...]
</Object>
    After that you can configure a directory in the Administration server and assign it the style x-httpd-php. All files in it will get executed as PHP. This is nice to hide PHP usage by renaming files to .html.

  • Restart your web service and apply changes

  • Do it for each web server instance you want PHP to run

참고: More details about setting up PHP as an NSAPI filter can be found here: http://benoit.noss.free.fr/php/install-php4.html

참고: The stacksize that PHP uses depends on the configuration of the webserver. If you get crashes with very large PHP scripts, it is recommended to raise it with the Admin Server (in the section "MAGNUS EDITOR").

CGI environment and recommended modifications in php.ini

Important when writing PHP scripts is the fact that iPlanet/SunONE/Netscape is a multithreaded web server. Because of that all requests are running in the same process space (the space of the webserver itsself) and this space has only one environment. If you want to get CGI variables like PATH_INFO, HTTP_HOST etc. it is not the correct way to try this in the old PHP 3.x way with getenv() or a similar way (register globals to environment, $_ENV). You would only get the environment of the running webserver without any valid CGI variables!

참고: Why are there (invalid) CGI variables in the environment?

Answer: This is because you started the webserver process from the admin server which runs the startup script of the webserver, you wanted to start, as a CGI script (a CGI script inside of the admin server!). This is why the environment of the started webserver has some CGI environment variables in it. You can test this by starting the webserver not from the administration server. Use the Unix command line as root user and start it manually - you will see there are no CGI-like environment variables.

Simply change your scripts to get CGI variables in the correct way for PHP 4.x by using the superglobal $_SERVER. If you have older scripts which use $HTTP_HOST,..., you should turn on register_globals in php.ini and change the variable order to (important: remove "E" from it, because you do not need the environment here):
variables_order = "GPCS"
register_globals = On

Special use for error pages or self-made directory listings (PHP >= 4.3.3)

You can use PHP to generate the error pages for "404 Not Found" or similar. Add the following line to the object in obj.conf for every error page you want to overwrite:
Error fn="php4_execute" code=XXX script="/path/to/script.php" [inikey=value inikey=value...]
where XXX is the HTTP error code. Please delete any other Error directives which could interfere with yours. If you want to place a page for all errors that could exist, leave the code parameter out. Your script can get the HTTP status code with $_SERVER['ERROR_TYPE'].

Another possibility is to generate self-made directory listings. Just create a PHP script which displays a directory listing and replace the corresponding default Service line for type="magnus-internal/directory" in obj.conf with the following:
Service fn="php4_execute" type="magnus-internal/directory" script="/path/to/script.php" [inikey=value inikey=value...]
For both error and directory listing pages the original URI and translated URI are in the variables $_SERVER['PATH_INFO'] and $_SERVER['PATH_TRANSLATED'].

Note about nsapi_virtual() and subrequests (PHP >= 4.3.3)

The NSAPI module now supports the nsapi_virtual() function (alias: virtual()) to make subrequests on the webserver and insert the result in the webpage. The problem is, that this function uses some undocumented features from the NSAPI library.

Under Unix this is not a problem, because the module automatically looks for the needed functions and uses them if available. If not, nsapi_virtual() is disabled.

Under Windows limitations in the DLL handling need the use of a automatic detection of the most recent ns-httpdXX.dll file. This is tested for servers till version 6.1. If a newer version of the SunONE server is used, the detection fails and nsapi_virtual() is disabled.

If this is the case, try the following: Add the following parameter to php4_init in magnus.conf/obj.conf:
Init fn=php4_init ... server_lib="ns-httpdXX.dll"
where XX is the correct DLL version number. To get it, look in the server-root for the correct DLL name. The DLL with the biggest filesize is the right one.

You can check the status by using the phpinfo() function.

참고: But be warned: Support for nsapi_virtual() is EXPERIMENTAL!!!

이전 | 처음으로 | 다음
Servers-IIS/PWS | 위로 | Servers-OmniHTTPd Server


Servers-OmniHTTPd Server

This section contains notes and hints specific to OmniHTTPd.

OmniHTTPd 2.0b1 and up for Windows

You need to complete the following steps to make PHP work with OmniHTTPd. This is a CGI executable setup. SAPI is supported by OmniHTTPd, but some tests have shown that it is not so stable to use PHP as an ISAPI module.

Important for CGI users: Read the faq on cgi.force_redirect for important details. This directive needs to be set to 0.

  1. Install OmniHTTPd server.

  2. Right click on the blue OmniHTTPd icon in the system tray and select Properties

  3. Click on Web Server Global Settings

  4. On the 'External' tab, enter: virtual = .php | actual = c:\path-to-php-dir\php.exe, and use the Add button.

  5. On the Mime tab, enter: virtual = wwwserver/stdcgi | actual = .php, and use the Add button.

  6. Click OK

Repeat steps 2 - 6 for each extension you want to associate with PHP.

참고: Some OmniHTTPd packages come with built in PHP support. You can choose at setup time to do a custom setup, and uncheck the PHP component. We recommend you to use the latest PHP binaries. Some OmniHTTPd servers come with PHP 4 beta distributions, so you should choose not to set up the built in support, but install your own. If the server is already on your machine, use the Replace button in Step 4 and 5 to set the new, correct information.

이전 | 처음으로 | 다음
Servers-Netscape, iPlanet and SunONE | 위로 | Servers-Oreilly Website Pro


Servers-Oreilly Website Pro

This section contains notes and hints specific to Oreilly Website Pro.

Oreilly Website Pro 2.5 and up for Windows

This list describes how to set up the PHP CGI binary or the ISAPI module to work with Oreilly Website Pro on Windows.

  • Edit the Server Properties and select the tab "Mapping".

  • From the List select "Associations" and enter the desired extension (.php) and the path to the CGI exe (ex. c:\php\php.exe) or the ISAPI DLL file (ex. c:\php\sapi\php4isapi.dll).

  • Select "Content Types" add the same extension (.php) and enter the content type. If you choose the CGI executable file, enter 'wwwserver/shellcgi', if you choose the ISAPI module, enter 'wwwserver/isapi' (both without quotes).

이전 | 처음으로 | 다음
Servers-OmniHTTPd Server | 위로 | Servers-Sambar


Servers-Sambar

This section contains notes and hints specific to the Sambar server for Windows.

Sambar Windows

This list describes how to set up the ISAPI module to work with the Sambar server on Windows.

  • Find the file called mappings.ini (in the config directory) in the Sambar install directory.

  • Open mappings.ini and add the following line under [ISAPI]:

    *.php = c:\php\php4isapi.dll

    (This line assumes that PHP was installed in c:\php.)

  • Now restart the Sambar server for the changes to take effect.

이전 | 처음으로 | 다음
Servers-Oreilly Website Pro | 위로 | Servers-Xitami


Servers-Xitami

This section contains notes and hints specific to Xitami.

Xitami for Windows

This list describes how to set up the PHP CGI binary to work with Xitami on Windows.

Important for CGI users: Read the faq on cgi.force_redirect for important details. This directive needs to be set to 0.

  • Make sure the webserver is running, and point your browser to xitamis admin console (usually http://127.0.0.1/admin), and click on Configuration.

  • Navigate to the Filters, and put the extension which PHP should parse (i.e. .php) into the field File extensions (.xxx).

  • In Filter command or script put the path and name of your PHP executable i.e. c:\php\php.exe.

  • Press the 'Save' icon.

  • Restart the server to reflect changes.

이전 | 처음으로 | 다음
Servers-Sambar | 위로 | Servers-Other web servers


Servers-Other web servers

PHP can be built to support a large number of web servers. Please see Server-related options for a full list of server-related configure options. The PHP CGI binaries are compatible with almost all webservers supporting the CGI standard.

이전 | 처음으로 | 다음
Servers-Xitami | 위로 | Problems?


Problems?

Read the FAQ

Some problems are more common than others. The most common ones are listed in the PHP FAQ, part of this manual.

Other problems

If you are still stuck, someone on the PHP installation mailing list may be able to help you. You should check out the archive first, in case someone already answered someone else who had the same problem as you. The archives are available from the support page on http://www.php.net/support.php. To subscribe to the PHP installation mailing list, send an empty mail to php-install-subscribe@lists.php.net. The mailing list address is php-install@lists.php.net.

If you want to get help on the mailing list, please try to be precise and give the necessary details about your environment (which operating system, what PHP version, what web server, if you are running PHP as CGI or a server module, 안전 모드, etc...), and preferably enough code to make others able to reproduce and test your problem.

Bug reports

If you think you have found a bug in PHP, please report it. The PHP developers probably don't know about it, and unless you report it, chances are it won't be fixed. You can report bugs using the bug-tracking system at http://bugs.php.net/. Please do not send bug reports in mailing list or personal letters. The bug system is also suitable to submit feature requests.

Read the How to report a bug document before submitting any bug reports!

이전 | 처음으로 | 다음
Servers-Other web servers | 위로 | Miscellaneous configure options


Miscellaneous configure options

Below is a partial list of configure options used by the PHP configure scripts when compiling in Unix-like environments. Most configure options are listed in their appropriate locations and not here. For a complete up-to-date list of configure options, run ./configure --help in your PHP source directory after running autoconf (see also the Installation chapter). You may also be interested in reading the GNU configure documentation for information on additional configure options such as --prefix=PREFIX.

참고: These are only used at compile time. If you want to alter PHP's runtime configuration, please see the chapter on Runtime Configuration.

  • Graphics

  • Miscellaneous

  • PHP Behaviour

  • Server

Configure Options in PHP 4

참고: These options are only used in PHP 4 as of PHP 4.1.0. Some are available in older versions of PHP 4, some even in PHP 3, some only in PHP 4.1.0. If you want to compile an older version, some options will probably not be available.

Graphics options

--with-imagick

The imagick extension has been moved to PECL in PEAR and can be found at http://pear.php.net/imagick. Install instructions for PHP 4 can be found on the PEAR site.

Simply doing --with-imagick is only supported in PHP 3 unless you follow the instructions found on the PEAR site.

Misc options

--enable-debug

Compile with debugging symbols.

--with-layout=TYPE

Sets how installed files will be laid out. Type is one of PHP (default) or GNU.

--with-pear=DIR

Install PEAR in DIR (default PREFIX/lib/php).

--without-pear

Do not install PEAR.

--enable-sigchild

Enable PHP's own SIGCHLD handler.

--disable-rpath

Disable passing additional runtime library search paths.

--enable-libgcc

Enable explicitly linking against libgcc.

--enable-php-streams

Include experimental PHP streams. Do not use unless you are testing the code!

--with-zlib-dir=<DIR>

Define the location of zlib install directory.

--enable-trans-sid

Enable transparent session id propagation. Only valid for PHP 4.1.2 or less. From PHP 4.2.0, trans-sid feature is always compiled.

--with-tsrm-pthreads

Use POSIX threads (default).

--enable-shared[=PKGS]

Build shared libraries [default=yes].

--enable-static[=PKGS]

Build static libraries [default=yes].

--enable-fast-install[=PKGS]

Optimize for fast installation [default=yes].

--with-gnu-ld

Assume the C compiler uses GNU ld [default=no].

--disable-libtool-lock

Avoid locking (might break parallel builds).

--with-pic

Try to use only PIC/non-PIC objects [default=use both].

--enable-memory-limit

Compile with memory limit support.

--disable-url-fopen-wrapper

Disable the URL-aware fopen wrapper that allows accessing files via HTTP or FTP.

--enable-versioning

Export only required symbols. See INSTALL for more information.

--with-imsp[=DIR]

Include IMSp support (DIR is IMSP's include dir and libimsp.a dir). PHP 3 only!

--with-mck[=DIR]

Include Cybercash MCK support. DIR is the cybercash mck build directory, defaults to /usr/src/mck-3.2.0.3-linux for help look in extra/cyberlib. PHP 3 only!

--with-mod-dav=DIR

Include DAV support through Apache's mod_dav, DIR is mod_dav's installation directory (Apache module version only!) PHP 3 only!

--enable-debugger

Compile with remote debugging functions. PHP 3 only!

--enable-versioning

Take advantage of versioning and scoping provided by Solaris 2.x and Linux. PHP 3 only!

PHP options

--enable-maintainer-mode

Enable make rules and dependencies not useful (and sometimes confusing) to the casual installer.

--with-config-file-path=PATH

Sets the path in which to look for php.ini, defaults to PREFIX/lib.

--enable-safe-mode

Enable safe mode by default.

--with-exec-dir[=DIR]

Only allow executables in DIR when in safe mode defaults to /usr/local/php/bin.

--enable-magic-quotes

Enable magic quotes by default.

--disable-short-tags

Disable the short-form <? start tag by default.

SAPI options

The following list contains the available SAPI&s (Server Application Programming Interface) for PHP.

--with-aolserver=DIR

Specify path to the installed AOLserver.

--with-apxs[=FILE]

Build shared Apache module. FILE is the optional pathname to the Apache apxs tool; defaults to apxs. Make sure you specify the version of apxs that is actually installed on your system and NOT the one that is in the apache source tarball.

--with-apache[=DIR]

Build a static Apache module. DIR is the top-level Apache build directory, defaults to /usr/local/apache.

--with-mod_charset

Enable transfer tables for mod_charset (Russian Apache).

--with-apxs2[=FILE]

Build shared Apache 2.0 module. FILE is the optional pathname to the Apache apxs tool; defaults to apxs.

--with-caudium=DIR

Build PHP as a Pike module for use with Caudium. DIR is the Caudium server dir, with the default value /usr/local/caudium/server.

--disable-cli

Available with PHP 4.3.0. Disable building the CLI version of PHP (this forces --without-pear). More information is available in the section about Using PHP from the command line.

--enable-embed[=TYPE]

Enable building of the embedded SAPI library. TYPE is either shared or static, which defaults to shared. Available with PHP 4.3.0.

--with-fhttpd[=DIR]

Build fhttpd module. DIR is the fhttpd sources directory, defaults to /usr/local/src/fhttpd. No longer available as of PHP 4.3.0.

--with-isapi=DIR

Build PHP as an ISAPI module for use with Zeus.

--with-nsapi=DIR

Specify path to the installed Netscape/iPlanet/SunONE Webserver.

--with-phttpd=DIR

No information yet.

--with-pi3web=DIR

Build PHP as a module for use with Pi3Web.

--with-roxen=DIR

Build PHP as a Pike module. DIR is the base Roxen directory, normally /usr/local/roxen/server.

--enable-roxen-zts

Build the Roxen module using Zend Thread Safety.

--with-servlet[=DIR]

Include servlet support. DIR is the base install directory for the JSDK. This SAPI requires the java extension must be built as a shared dl.

--with-thttpd=SRCDIR

Build PHP as thttpd module.

--with-tux=MODULEDIR

Build PHP as a TUX module (Linux only).

--with-webjames=SRCDIR

Build PHP as a WebJames module (RISC OS only)

--disable-cgi

Disable building CGI version of PHP. Available with PHP 4.3.0.

--enable-force-cgi-redirect

Enable the security check for internal server redirects. You should use this if you are running the CGI version with Apache.

--enable-discard-path

If this is enabled, the PHP CGI binary can safely be placed outside of the web tree and people will not be able to circumvent .htaccess security.

--with-fastcgi

Build PHP as FastCGI application. No longer available as of PHP 4.3.0, instead you should use --enable-fastcgi.

--enable-fastcgi

If this is enabled, the CGI module will be built with support for FastCGI also. Available since PHP 4.3.0

--disable-path-info-check

If this is disabled, paths such as /info.php/test?a=b will fail to work. Available since PHP 4.3.0. For more information see the Apache Manual.

이전 | 처음으로 | 다음
Problems? | 위로 | 실행 환경 설정


실행 환경 설정

PHP 매뉴얼
이전 다음

4. 장. 실행 환경 설정

차례
환경 설정 파일
환경 설정을 변경하는 방법
기타 환경 설정 지시자

환경 설정 파일

환경 설정 파일(PHP 3.0에서는 php3.ini, PHP 4.0부터는 간단히 php.ini)은 PHP가 시작될 때 읽혀집니다. PHP의 서버 모듈 버전에서는 웹 서버가 시작될 때 한번만 읽혀집니다. CGI와 CLI 버전에서는 실행될 때마다 읽혀집니다.

php.ini의 기본 위치는 컴파일 시의 옵션입니다. (FAQ 참고) CGI와 CLI 버전에서는 -c 커맨드 라인 스위치를 이용해서 변경할 수 있습니다. 커맨드 라인에서 PHP 사용하기 챕터를 참고하십시오. php.ini를 찾기 위한 추가 경로를 지정하기 위해 PHPRC 환경 변수를 이용할 수도 있습니다.

참고: 아파치 웹 서버는 시작할 때 디렉토리를 루트로 변경하기 때문에, 루트에 php.ini가 존재할 경우, 루트 파일 시스템에서 읽습니다.

모든 PHP 설정이 아래에 쓰여있지는 않습니다. 모든 설정의 목록을 확인하기 위해서는, php.ini 파일의 주석들을 읽어보십시오. CVS에서 최신의 php.ini를 확인할 수도 있습니다.

참고: PHP 4.2.0부터 PHP 설정 register_globals의 기본값이 on에서 off로 변경되었습니다.

예 4-1. php.ini 예제

; 따옴표 밖에서 세미콜론(;)뒤에 오는 그 줄의 텍스트는 무시합니다
[PHP] ; 섹션 마커 (대괄호 안의 텍스트)는 무시합니다
; Boolean 값은 다음과 같이 설정합니다:
;    true, on, yes
; 또는 false, off, no, none
register_globals = off
magic_quotes_gpc = yes

; 문자열은 큰따옴표(")로 묶습니다
include_path = ".:/usr/local/lib/php"

; 백슬래쉬(\)는 보통의 문자로 취급합니다
include_path = ".;c:\php\lib"

이전 | 처음으로 | 다음
Miscellaneous configure options | 위로 | 환경 설정을 변경하는 방법


환경 설정을 변경하는 방법

PHP를 아파치 모듈로 실행

PHP를 아파치 모듈로 사용할 때, 아파치 환경 설정 파일(예. httpd.conf)과 .htaccess 파일("AllowOverride Options"이나 "AllowOverride All" 권한이 필요합니다)을 이용해서 환경 설정을 변경할 수 있습니다.

PHP 4.0에서는, 아파치 환경 설정 파일에서 PHP 설정을 변경할 수 있게 하는 몇가지 아파치 설정이 존재합니다. 가능한 설정 목록은 ini_set() 문서에 있는 테이블의 PHP_INI_ALL, PHP_INI_PERDIR, PHP_INI_SYSTEM을 참고하십시오.

참고: PHP 3.0에서는, php3.ini 이름에 각각 대응하는 "php3_"를 붙여서 사용할 수 있는 아파치 설정이 존재합니다.

php_value 이름 값

특정한 설정값을 설정합니다. PHP_INI_ALL과 PHP_INI_PERDIR형 지시자에만 사용할 수 있습니다. 기존 설정값을 제거하기 위해서는 값을 none로 설정하십시오.

참고: boolean 값을 설정하기 위해서 php_value를 사용하지 마십시오. 대신, php_flag(아래를 참고)를 사용해야만 합니다.

php_flag 이름 on|off

Boolean 환경 설정에 사용합니다. PHP_INI_ALL과 PHP_INI_PERDIR형 지시자에만 사용할 수 있습니다.

php_admin_value 이름 값

특정한 설정값을 설정합니다. .htaccess 파일에서는 사용할 수 없습니다. php_admin_value의 설정값은 .htaccess나 버추얼 호스트 설정으로 바꿀 수 없습니다. 기존 설정값을 제거하기 위해서는 값을 none로 설정하십시오.

php_admin_flag 이름 on|off

Boolean 환경 설정에 사용합니다. php_admin_flag의 설정값은 .htaccess나 버추얼 호스트 설정으로 바꿀 수 없습니다. 기존 설정값을 제거하기 위해서는 값을 none로 설정하십시오.

예 4-2. 아파치 환경 설정 예제

<IfModule mod_php4.c>
  php_value include_path ".:/usr/local/lib/php"
  php_admin_flag safe_mode on
</IfModule>
<IfModule mod_php3.c>
  php3_include_path ".:/usr/local/lib/php"
  php3_safe_mode on
</IfModule>

경고

PHP 상수는 PHP 외부에서는 존재하지 않습니다. 예를 들면, httpd.conf에서는 error_reporting을 설정하기 위해서 E_ALL나 E_NOTICE 등의 PHP 상수를 사용할 수 없으며, 아무런 의미를 가지지 않기에 0으로 처리합니다. 대신 비트마스크 결합값을 사용하십시오. php.ini에서는 상수를 사용할 수 있습니다.

윈도우 레지스트리를 통해 PHP 설정 변경하기

윈도우에서 PHP를 실행할 때, 윈도우 레지스트리를 통해서 디렉토리 단위로 설정값을 변경할 수 있습니다. 레지스트리 키 HKLM\SOFTWARE\PHP\Per Directory Values에 기록된 설정값은, 경로명이 서브키로 연결됩니다. 예를 들면, 디렉토리 c:\inetpub\wwwroot를 위한 설정값은 HKLM\SOFTWARE\PHP\Per Directory Values\c\inetpub\wwwroot에 기록합니다. 디렉토리 단위의 설정은 그 디렉토리와 그 하위 디렉토리에서 실행되는 모든 스크립트에 영향을 줍니다. 키가 가지는 이름은 PHP 설정 지시어이고, 문자열 값을 가집니다. 값에 지정한 PHP 상수는 처리되지 않습니다.

PHP의 다른 인터페이스

PHP의 인터페이스에 상관 없이, ini_set()를 이용하여 스크립트 실행시의 몇가지 값을 변경할 수 있습니다. 아래의 표는 설정값이 어느 레벨에서 변경/지정될 수 있는지 보여줍니다.

표 4-1. PHP_INI_* 상수 정의

상수 | 값 | 의미
PHP_INI_USER | 1 | 유저 스크립트에서 설정 가능한 엔트리
PHP_INI_PERDIR | 2 | php.ini, .htaccess, httpd.conf에서 설정 가능한 엔트리
PHP_INI_SYSTEM | 4 | php.ini나 httpd.conf에서 설정 가능한 엔트리
PHP_INI_ALL | 7 | 어디에서라도 설정 가능한 엔트리

환경 설정의 설정값은 phpinfo() 출력에서
확인할 수 있습니다. ini_get()나
get_cfg_var()을 이용하여 개별 설정값에
접근할 수도 있습니다.

이전 | 처음으로 | 다음
실행 환경 설정 | 위로 | 기타 환경 설정 지시자


기타 환경 설정 지시자

아래는 모든 PHP 지시자 목록이 아닙니다. 지시자 목록은 적합한 위치에 존재합니다. 예를 들어, 세션 지시자에 대한 정보는 세션 챕터에 위치합니다.

Httpd 옵션

표 4-2. Httpd 옵션

이름 | 기본값 | 변경가능성
async_send | "0" | PHP_INI_ALL

언어 옵션

표 4-3. 언어와 기타 환경 설정 옵션

이름 | 기본값 | 변경가능성
short_open_tag | On | PHP_INI_SYSTEM|PHP_INI_PERDIR
asp_tags | Off | PHP_INI_SYSTEM|PHP_INI_PERDIR
precision | "14" | PHP_INI_ALL
y2k_compliance | Off | PHP_INI_ALL
allow_call_time_pass_reference | On | PHP_INI_SYSTEM|PHP_INI_PERDIR
expose_php | On | PHP_INI_SYSTEM

위 설정 지시어에 대한 간단한 설명입니다.

short_open_tag boolean

PHP의 시작 태그로 짧은 형태(<? ?>)를 사용하게 할 지를 결정합니다. PHP를 XML과 결함해서 사용할 때는, 라인에서 <?xml ?>를 사용하기 위해서 이 옵션을 끌 수 있습니다. 또는, PHP를 이용해서 출력해야 합니다. 예: <?php echo '<?xml version="1.0"'; ?>. 옵션을 끌 경우, 긴 형태의 PHP 시작 태그(<?php ?>)를 사용해야만 합니다.

참고: 이 지시자는 <? echo의 짧은 형태인 <?=에도 영향을 미칩니다. 이 짧은 형태를 사용하기 위해서는 short_open_tag를 on으로 해야 합니다.

asp_tags boolean

보통의 <?php ?> 태그에 추가로, ASP형태의 <% %>의 사용을 가능하게 합니다. 변수값 출력의 짧은 형태인 <%= $value %>도 사용 가능해집니다. 추가 정보는 HTML에서 빠져나가기를 참고하십시오.

참고: ASP-형태 태그의 지원은 3.0.4에서 추가하였습니다.

precision integer

부동소수에 표시되는 유효 숫자의 수입니다.

y2k_compliance boolean

2000년 호환을 강제합니다. (비호환 브라우저와 문제가 있을 수 있습니다)

allow_call_time_pass_reference boolean

함수를 호출할 때, 인자를 참조로 넘기는 것의 강제 여부를 결정합니다. 이 방법은 부정되었으며, PHP/Zend의 차후 버전에서는 지원하지 않을 것입니다. 권장하는 방법은 함수 정의시에 어떤 인자가 참조로 넘어갈지를 결정하는 것입니다. 차후 버전에서의 작동성을 보장받기 위해서 이 옵션을 끈 상태에서 스크립트가 제대로 작동하게 하는 것을 권장합니다. (이 기능을 사용할때마다 경고를 받게 되고, 인자는 참조 대신 값으로 넘어가게 될 것입니다)

참조: References Explained.

expose_php boolean

서버에 PHP가 설치 여부를 표출하게 하는 것을 결정합니다. (즉, 웹 서버 헤더에 사인을 추가합니다). 보안 관련에 영향은 없으나, 그 서버에서 PHP의 사용 여부를 확인할 수 있게 합니다.

리소스 제한

표 4-4. 리소스 제한

이름 | 기본값 | 변경가능성
memory_limit | "8M" | PHP_INI_ALL

위 설정 지시어에 대한 간단한 설명입니다.

memory_limit integer

스크립트가 사용할 수 있는 최대 메모리 양을 바이트로 설정합니다. 엉망인 스크립트가 서버의 많은 메모리를 차지하는 것을 방지할 수 있습니다. 이 지시자를 사용하기 위해서는, 컴파일시에 활성화하여야 합니다. 즉, 설정 라인에 다음을 포함되야 합니다: --enable-memory-limit. 메모리 제한을 하지 않으려면 -1로 설정하십시오.

PHP 4.3.2부터, memory_limit를 활성화 했을때, PHP 함수 memory_get_usage()가 사용 가능합니다.

참고: max_execution_time.

데이터 핸들링

표 4-5. 데이터 핸들링 환경 설정 옵션

이름 | 기본값 | 변경가능성
track-vars | "On" | PHP_INI_??
arg_separator.output | "&" | PHP_INI_ALL
arg_separator.input | "&" | PHP_INI_SYSTEM|PHP_INI_PERDIR
variables_order | "EGPCS" | PHP_INI_ALL
register_globals | "Off" | PHP_INI_PERDIR|PHP_INI_SYSTEM
register_argc_argv | "On" | PHP_INI_PERDIR|PHP_INI_SYSTEM
post_max_size | "8M" | PHP_INI_SYSTEM|PHP_INI_PERDIR
gpc_order | "GPC" | PHP_INI_ALL
auto_prepend_file | "" | PHP_INI_SYSTEM|PHP_INI_PERDIR
auto_append_file | "" | PHP_INI_SYSTEM|PHP_INI_PERDIR
default_mimetype | "text/html" | PHP_INI_ALL
default_charset | "iso-8859-1" | PHP_INI_ALL
always_populate_raw_post_data | "0" | PHP_INI_SYSTEM|PHP_INI_PERDIR
allow_webdav_methods | "0" | PHP_INI_SYSTEM|PHP_INI_PERDIR

위 설정 지시어에 대한 간단한 설명입니다.

track_vars boolean

활성화하면, 환경 변수, GET, POST, 쿠키, 서버 변수에 대한 전역 연관 배열 $_ENV, $_GET, $_POST, $_COOKIE, $_SERVER을 사용할 수 있습니다.

PHP 4.3.0부터 track_vars는 항상 on입니다.

arg_separator.output string

PHP가 생성하는 URL의 인자를 구분하는 구분자입니다.

arg_separator.input string

PHP가 URL에서 변수를 분리하는데 사용하는 구분자 목록입니다.

참고: 이 지시자의 모든 문자는 구분자로 인식합니다!

variables_order string

EGPCS(환경변수, GET, POST, 쿠키, 서버) 변수의 파싱 순서를 결정합니다. 이 지시자의 기본값은 "EGPCS"입니다. 예를 들어, "GP"로 설정하면, PHP는 환경 변수, 쿠키, 서버 변수를 무시할 것이고, GET 변수는 같은 이름을 가지는 POST 변수에 의해 덮어씌워질 것입니다.

참고: register_globals.

register_globals boolean

EGPCS(환경, GET, POST, 쿠키, 서버) 변수를 전역 변수로 등록할지를 결정합니다. 예를 들어, register_globals = on 이라면 URL http://www.example.com/test.php?id=3 요청에 $id를 생성합니다. 또는, $_SERVER['DOCUMENT_ROOT']에서 $DOCUMENT_ROOT를 등록합니다. 스크립트의 전역 위치에 유저 데이터로 채워지는것을 원하지 않는다면, 이 옵션을 끄십시오. PHP 4.2.0부터는 이 지시자의 기본값은 off입니다. 자동전역: $_ENV, $_GET, $_POST, $_COOKIE, $_SERVER 등의 PHP 예약 정의 변수를 사용하는 것을 권장합니다. 보안 챕터의 register_globals 사용에 대한 관련 정보를 읽어보십시오.

register_globals는 실행시에 설정(ini_set())할 수 없는 점에 주의하십시오. 그러나, 호스트가 .htaccess를 허용한다면, 그것을 이용할 수 있습니다. 예제 .htaccess 엔트리: php_flag register_globals on

참고: register_globals는 variables_order 지시자의 영향을 받습니다.

register_argc_argv boolean

(GET 정보를 포함하는) argv와 argc 변수 사용 여부를 결정합니다.

참고 : command line. 이 지시자는 PHP 4.0.0부터 사용 가능하며, 이전에는 항상 "on"이였습니다.

register_long_arrays boolean

PHP에서 사용을 권하지 않는 $HTTP_*_VARS 형태의 예약 변수의 등록 여부를 결정합니다. On (기본값)일때, $HTTP_GET_VARS 등의 긴 형태의 PHP 예약 변수가 정의됩니다. 이 형태를 사용하지 않는다면, 성능 향상을 위해 off로 설정하는 것을 권장합니다. 대신, $_GET 등의 자동 전역 배열을 사용하십시오.

이 지시자는 PHP 5.0.0부터 사용 가능합니다.

post_max_size integer

POST 데이터가 허용하는 최대 사이즈를 설정합니다. 이 설정은 파일 업로드에도 관여합니다. 큰 파일을 업로드 하기 위해서는 이 값이 upload_max_filesize보다 커야만 합니다.

환경 설정 스크립트에서 메모리 제한을 활성화하였으면, memory_limit도 파일 업로드에 관여합니다. 일반적으로, memory_limit는 post_max_size보다 커야만 합니다.

gpc_order string

GET/POST/COOKIE 변수 파싱 순서를 설정합니다. 이 지시자의 기본값은 "GPC"입니다. 예를 들어, "GP"로 설정하면 PHP는 쿠키는 무시하고, 같은 이름의 POST 방식 변수로 GET 방식 변수를 덮어씌울 것입니다.

참고: 이 옵션은 PHP 4에서는 사용할 수 없습니다. 대신, variables_order를 사용합니다.

auto_prepend_file string

메인 파일 앞에 자동적으로 붙는 파일의 이름을 정합니다. include() 함수 호출과 동등하게 작동하며, include_path를 사용합니다.

특수값 none은 auto-prepending을 비활성화 합니다.

auto_append_file string

메인 파일 뒤에 자동적으로 붙는 파일의 이름을 정합니다. include() 함수 호출과 동등하게 작동하며, include_path를 사용합니다.

특수값 none은 auto-appending을 비활성화 합니다.

참고: 스크립트가 exit()로 종료되면, auto-append는 작동하지 않습니다.

default_mimetype string

default_charset string

4.0b4부터, PHP는 기본값으로 항상 Content-type: 헤더로 문자 인코딩을 출력합니다. 문자셋의 전송을 하지 않기 위해서는, 간단히 이 설정을 비워두십시오.

always_populate_raw_post_data boolean

항상 $HTTP_RAW_POST_DATA 변수를 선언합니다.

allow_webdav_methods boolean

PHP 스크립트에서 WebDAV http 요청(즉, PROPFIND, PROPPATCH, MOVE, COPY 등등..)을 핸들링할 수 있게 합니다. 이 요청들로부터 포스트 데이터를 얻기 원한다면, always_populate_raw_post_data도 설정해야 합니다.

참고: magic_quotes_gpc, magic-quotes-runtime, magic_quotes_sybase.

경로와 디렉토리

표 4-6. 경로와 디렉토리 환경 설정 옵션

이름 | 기본값 | 변경가능성
include_path | PHP_INCLUDE_PATH | PHP_INI_ALL
doc_root | PHP_INCLUDE_PATH | PHP_INI_SYSTEM
user_dir | NULL | PHP_INI_SYSTEM
extension_dir | PHP_EXTENSION_DIR | PHP_INI_SYSTEM
cgi.fix_pathinfo | "0" | PHP_INI_SYSTEM
cgi.force_redirect | "1" | PHP_INI_SYSTEM
cgi.redirect_status_env | "" | PHP_INI_SYSTEM
fastcgi.impersonate | "0" | PHP_INI_SYSTEM
cgi.rfc2616_headers | "0" | PHP_INI_SYSTEM

위 설정 지시어에 대한 간단한 설명입니다.

include_path string

require(), include(), fopen_with_path() 함수가 파일을 찾는 디렉토리 목록을 지정합니다. 형식은 시스템의 PATH 환경 변수와 같습니다: 디렉토리 목록은 유닉스에서는 콜론으로, 윈도우에서는 세미콜론으로 구분합니다.

예 4-3. 유닉스 include_path

include_path=".:/php/includes"

예 4-4. 윈도우 include_path

include_path=".;c:\php\includes"

상대 경로의 인크루드를 허용하기 위해서, 현재 경로를 의미하는 .을 경로에 사용하십시오.

doc_root string

서버에서 PHP의 "루트 디렉토리"입니다. 비어있지 않은 경우에만 사용합니다. PHP를 안전 모드로 설정하면, 이 디렉토리 밖에 있는 파일은 사용할 수 없습니다. IIS를 제외한 모든 웹 서버에서, PHP를 CGI로 사용하면서 FORCE_REDIRECT를 설정하지 않고 컴파일 했다면, doc_root를 꼭 설정해야 합니다. 아래의 cgi.force_redirect 설정을 대신 사용할 수도 있습니다.

user_dir string

PHP 파일을 사용하는 유저의 홈 디렉토리의 기본 이름입니다. 예를 들면, public_html이 있습니다.

extension_dir string

동적 로드 확장를 찾을 디렉토리를 설정합니다. 참고: enable_dl, dl().

extension string

PHP가 시작할 때 설정한 동적 로드 확장을 읽어옵니다.

cgi.fix_pathinfo boolean

CGI를 위한 실제 PATH_INFO/PATH_TRANSLATED 지원을 제공합니다. PHP의 이전 작동은 PATH_TRANSLATED를 SCRIPT_FILENAME으로 설정했고, and to not grok what PATH_INFO is. PATH_INFO에 관한 정보는, cgi 규격을 참고하십시오. 1로 설정하면 PHP CGI가 규격에 맞게 경로를 수정합니다. 0으로 설정하면 PHP는 이전과 같이 작동합니다. 기본값은 0입니다. PATH_TRANSLATED 대신 SCRIPT_FILENAME을 사용하도록 스크립트를 수정할 필요가 있습니다.

cgi.force_redirect boolean

cgi.force_redirect는 대부분의 웹 서버에서 PHP를 CGI로 사용할 때 보안을 제공하기 위해 필요합니다. 미정의 상태라면, PHP는 기본값으로 on으로 인식합니다. 자신의 책임하에 끌 수 있습니다.

참고: 윈도우 유저: IIS에서는 이것을 꺼도 안전하며, 사실상 꺼야합니다. OmniHTTPD나 Xitami로 작업한다면, 반드시 꺼야 합니다.

cgi.redirect_status_env string

cgi.force_redirect가 켜져있고, 아파치나 넷스케이프(iPlanet) 웹 서버를 사용하지 않는다면, 계속해서 실행하기 위한 OK를 알리기 위한 환경 변수 이름을 설정해야 할 수도 있습니다.

참고: 이 변수를 설정하는건 보안 문제가 될 수도 있습니다. 어떤 일을 하는지 우선적으로 알아보십시오.

fastcgi.impersonate string

IIS(WINNT 기반 OS)에서 FastCGI는 클라이언트 호출에 대한 가상 보안 토큰을 지원합니다. 이 지시자는 IIS에게 요청에 대한 보안 문장을 정의하도록 허용합니다. 아파치의 mod_fastcgi에서는 현재(2002/03/17) 이 기능을 지원하지 않습니다. IIS에서 실행할때는 1로 설정하십시오. 기본값은 0입니다.

cgi.rfc2616_headers int

PHP가 HTTP 응답 코드를 보낼 때 어떤 형식의 헤더를 사용할지를 결정합니다. 0으로 설정하면, PHP는 아파치 및 기타 웹 서버에서 지원하는 Status: 헤더를 이용합니다. 이 옵션을 1로 설정하면, PHP는 RFC 2616 호환 헤더를 전송합니다. 어떤 일을 하는지 알 수 없는 한 0으로 설정해두십시오.

파일 업로드

표 4-7. 파일 업로드 환경 설정 옵션

이름 | 기본값 | 변경가능성
file_uploads | "1" | PHP_INI_SYSTEM
upload_tmp_dir | NULL | PHP_INI_SYSTEM
upload_max_filesize | "2M" | PHP_INI_SYSTEM|PHP_INI_PERDIR

위 설정 지시어에 대한 간단한 설명입니다.

file_uploads boolean

HTTP 파일 업로드 허용 여부를 결정합니다. upload_max_filesize, upload_tmp_dir, post_max_size 지시자를 참고하십시오.

upload_tmp_dir string

파일 업로드 중의 저장을 위한 임시 디렉토리 설정입니다. PHP가 실행되는 유저가 쓰기 권한을 가져야 합니다. 지정하지 않으면 시스템 기본값을 사용합니다.

upload_max_filesize integer

업로드 파일의 최대 크기를 지정합니다.

SQL 일반

표 4-8. SQL 일반 환경설정 옵션

이름 | 기본값 | 변경가능성
sql.safe_mode | "0" | PHP_INI_SYSTEM

위 설정 지시어에 대한 간단한 설명입니다.

sql.safe_mode boolean

디버거 환경 설정 지시자

경고

PHP 3만 기본 디버거를 가지고 있습니다. 추가 정보는 부록 E를 참고하십시오.

debugger.host string

디버거가 사용하는 호스트의 DNS 이름이나 IP.

debugger.port string

디버거가 사용하는 포트 번호.

debugger.enabled boolean

디버거 활성화 여부.

이전 | 처음으로 | 다음
환경 설정을 변경하는 방법 | 위로 | 언어 레퍼런스


언어 레퍼런스

PHP 매뉴얼
이전 다음

II. 언어 레퍼런스

차례
5. 기본 문법
6. 변수형
7. 변수
8. 상수
9. 표현식
10. 연산자
11. 제어 구조
12. 함수
13. 클래스와 객체
14. 참조 표현

이전 | 처음으로 | 다음
기타 환경 설정 지시자 |  | 기본 문법


기본 문법

PHP 매뉴얼
이전 다음

5. 장. 기본 문법

차례
HTML에서 벗어나기
명령 구분 기호
주석

HTML에서 벗어나기

PHP가 파일을 해석할때 PHP코드로 해석하라고 하는 특별한 코드와 만나지 않는다면 단순히 그 파일의 텍스트를 넘겨줄 뿐이다. 해석기(parser)는 PHP 닫기 태그가 있는곳까지 발견된 코드 모두를 수행한다. PHP 닫기 태그 를 만나면 다시 텍스트를 그냥 넘겨주기 시작하는것이다. 이런 메카니즘은 HTML안에 PHP코드를 내장시킬수 있게 해준다: PHP 태그 밖의 모든것은 완전히 단독으로 존재하는것이고, 반면에 PHP 태그 안쪽은 코드로서 해석이 된다.

PHP 코드 블록은 네가지의 태그형태로 표시할수 있다. 이 중에서 두가지 (<?php. . .?> 과 <script language="php">. . .</script>)는 항상 유효한 형태이다. 반면에 다른 형태는 php.ini 설정 파일에서 켜거나 끌 수 있다. 짧은형(short-form)태그와 ASP스타일(ASP-style) 태그는 편하겠지만, 긴 형태 태그만큼 이식성이 뛰어나진 못하다. XML이나 XHTML안에 PHP코드를 내장시키려면 XML과 호환될수 있도록 <?php. . .?>형을 써야한다.

PHP가 지원하는 태그 형태:

예 5-1. HTML에서 벗어나기

1.  <?php echo("XHTML나 XML 문서와 호환시키려면, 이렇게 쓰세요\n"); ?>

2.  <? echo ("이런 형태가 제일간단하다. SGML 처리명령\n"); ?>
    <?= expression ?>는 "<? echo expression ?>"을 간단히 쓴 태그형

3.  <script language="php">
        echo ("어떤 에디터 (프론트페이지같은)는
              처리 명령을 좋아하지 않는다");
    </script>

4.  <% echo ("ASP스타일 태그를 쓸수도 있다"); %>
    <%= $variable; # 이것은 "<% echo . . ." %>을 간단히 쓴 태그형

첫번째 방법 <?php. . .?>을 쓰는것이 가장 좋다. 이런 형태는 XHTML과 같은 XML호환 코드안에 PHP를 쓸수 있게 해주기때문이다.

두번째 방법은 항상 유효하지 않다. 이 짧은 형은 활성화시켰을때만 유효하다. short_tags() 함수 (PHP 3에서만)로, PHP 설정 파일 안의 short_open_tag 설정 값을 활성화시키거나, configure명령 시에 --enable-short-tags옵션을 줘서 PHP를 컴파일함으로써 가용하게 할수있다.

네번째 방법은 asp_tags설정값을 활성화시킴으로써 ASP 스타일 태그형태를 쓸수 있을때만 유효하다.

참고: 3.0.4부터 ASP 스타일 태그에 대한 지원이 추가되었다

참고: 프로그램이나 재사용을 위한 라이브러리를 개발할때, 또는 통제밖의 PHP서버에 배치시킬때는 짧은 형 태그를 쓰는것은 피해야 한다. 왜냐하면 짧은 형 태그는 목표하는 서버에서 지원되지 않을수도 있기 때문이다. 이식성을 위해서, 재사용 코드는 짧은 형 태그로 쓰지 않도록 한다.

블록의 닫기 태그가 하나만 존재한다면 그 뒤에 바로 새줄(newline)이 포함될것이다. 또, 닫기 태그는 자동적으로 세미콜른(;)의 역할도 수행한다. 따라서 PHP블록의 마지막 줄은 세미콜른 으로 끝낼 필요가 없다.

PHP는 다음과 같은 구조도 허용이 된다:

예 5-2. 향상된 회피(escaping)

<?php
if ($expression) {
    ?>
    <strong>이것은 참이다.</strong>
    <?php
} else {
    ?>
    <strong>이것은 거짓이다.</strong>
    <?php
}
?>
이런 구조는 기대하던대로 작동한다. 왜냐하면 PHP는 ?>닫기 태그에 맞닥뜨리고나서 열기 태그를 만나기 전까지의 무엇이든 단순히 출력만 하기 때문이다. 이 예제는 PHP 파싱 모드를 줄임으로써 echo()나 print() 또는 비슷한 함수들이 모든 텍스트를 출력하는것보다 효율적으로 거대한 텍스트 블록 을 출력할수 있게 한다.

이전 | 처음으로 | 다음
언어 레퍼런스 | 위로 | 명령 구분 기호


명령 구분 기호

명령은 C나 펄과 같은 기호를 사용하여 구분한다 - 각 명령은 세미콜른(;) 으로 끝난다.

닫기 태그 (?>)는 또한 문장의 끝이라는 의미를 내포한다. 그래서 다음 문장은 동일하다:

<?php
    echo "This is a test";
?>

<?php echo "This is a test" ?>

이전 | 처음으로 | 다음
기본 문법 | 위로 | 주석


주석

PHP는 'C', 'C++', Unix 셀 스타일(shell-style)의 주석(comment)형태를 지원한다. 예를 들면:

<?php
    echo "This is a test"; // 한줄짜리 c++ 스타일 주석
    /* 여러줄의 주석
       이줄까지 주석처리 된다 */
    echo "This is yet another test";
    echo "One Final Test"; # 셀스타일의 한줄짜리 주석
?>

"한줄짜리" 주석은 그 줄의 끝이나, 처음에 무엇이 오든 해당 PHP코드 블록에 주석을 단다.

<h1>This is an <?php # echo "simple";?> example.</h1>
<p>The header above will say 'This is an example'.

'C' 스타일 주석을 중복 내포하지 않도록 주의해야 한다. 이와 같은 실수는 거대한 블록을 주석처리할 때 일어날수 있다.

<?php
/*
    echo "This is a test"; /* 이 주석은 문제를 일으킬것이다. */
*/
?>

한줄짜리 주석은 그 줄의 끝이나, 처음에 무엇이 오든 해당 PHP코드 블록에 주석을 단다. 이 말의 의미는 // ?>이후에 HTML코드가 출력될것이 라는 것이다: ?> 은 PHP모드를 벗어나서 HTML모드로 돌아오게 하고, //은 이 동작에 영향을 미치지 못한다.

이전 | 처음으로 | 다음
명령 구분 기호 | 위로 | 변수형


변수형

PHP 매뉴얼
이전 다음

6. 장. 변수형

차례
소개
논리값
정수
부동소수점
문자열
배열
객체
자원
NULL
이 문서에서 사용되는 의사 타입
타입 저글링

소개

PHP는 8가지의 기본 변수형을 지원한다.

4가지 스칼라형:

  • boolean

  • integer

  • float (floating-point number, aka 'double')

  • string

2가지 복합 타입:

  • array

  • object

그리고 최종적으로 다음의 2가지 타입:

  • resource

  • NULL

이 매뉴얼에서는 몇가지의 의사(pseudo) 타입도 소개한다. for readability reasons:

  • mixed

  • number

  • callback

"double" 타입과 비슷한 타입을 볼수 있을것이다. double은 float과 같은 타입이다. 두개의 타입이 존재하는 이유는 역사적인 이유일뿐이다.

보통은 프로그래머가 변수의 타입을 결정할수 없다. 대신에, PHP가 변수가 사용되는 환경에 따라 실시간으로 결정하게 된다.

참고: 표현식의 타입과 값을 확인하려한다면, var_dump()을 사용한다.

참고: 디버깅을 위해 타입을 판독하려고 하면, gettype()를 사용한다. 정확히 어떠 타입을 사용하는지 확인하려면 gettype()함수를 사용하지 말고, is_type함수를 사용하도록 한다. 몇가지 예제 코드를 보자:

<?php
$bool = TRUE;   // a boolean
$str  = "foo";  // a string
$int  = 12;     // an integer

echo gettype($bool); // prints out "boolean"
echo gettype($str);  // prints out "string"

// If this is an integer, increment it by four
if (is_int($int)) {
    $int += 4;
}

// If $bool is a string, print it out
// (does not print out anything)
if (is_string($bool)) {
    echo "String: $bool";
}
?>

변수를 다른 타입으로 변경하려한다면 변수를 캐스트하거나 settype()함수를 사용하면 된다.

변수는 특수한 상황에서는 그 당시에 무슨 타입을 쓰는지에 따라 다른 값으로 변경될수 있다는 것에 주의 해야 한다. 자세한 정보는 타입 저글링을 참고. 타입 비교 테이블를 보면, 다양한 타입의 비교의 예제코드를 볼수 있다.

이전 | 처음으로 | 다음
주석 | 위로 | 논리값


논리값

이 타입은 가장 쉬운 타입니다.boolean은 논리값을 표현한다. TRUE 나 FALSE 값이 될수 있다.

참고: boolean 타입은 PHP 4부터 지원되었다.

문법

boolean 을 표현하기 위해서 키워드 TRUE 나 FALSE를 사용한다. 두 가지 모두 대소문자를 구별하지 않는다.

<?php
$foo = True; // assign the value TRUE to $foo
?>

보통은 boolean값을 돌려주는 몇 가지 연산자를 사용해서 그 값을 제어 구조로 전달한다.

<?php
// == is an operator which test
// equality and returns a boolean
if ($action == "show_version") {
    echo "The version is 1.23";
}

// this is not necessary...
if ($show_separators == TRUE) {
    echo "<hr>\n";
}

// ...because you can simply type
if ($show_separators) {
    echo "<hr>\n";
}
?>

boolean으로 변환

명시적으로 boolean 값으로 변경하려면 (bool)이나 (boolean) 캐스트를 사용한다. 하지만, 대부분의 경우 이런 캐스트를 사용할 필요는 없다. 왜냐하면 그 값은 연산자나 함수 또는 제어구조가 boolean인자를 요구하면 자동으로 변환된다.

타입 저글링도 참고.

boolean로 변경할때, 다음값은 FALSE로 본다:

  • boolean FALSE 자체

  • integer 0 (zero)

  • float 0.0 (zero)

  • 비어있는 문자열과 문자열 "0"

  • 아무 구성요소도 갖지 않는 배열

  • 아무 멤버 변수도 갖지 않는 객체

  • 특별한 타입인 NULL (변수를 unset하는 것도 포함)

이 외의 다른 모든 값은 TRUE로 본다 (모든 자원이 포함됨).

주의

모든 0이 아닌 (양수이든 음수이든) TRUE가 되는 것처럼 -1은 TRUE로 본다,

<?php
echo gettype((bool) "");        // bool(false)
echo gettype((bool) 1);         // bool(true)
echo gettype((bool) -2);        // bool(true)
echo gettype((bool) "foo");     // bool(true)
echo gettype((bool) 2.3e5);     // bool(true)
echo gettype((bool) array(12)); // bool(true)
echo gettype((bool) array());   // bool(false)
?>

이전 | 처음으로 | 다음
변수형 | 위로 | 정수


정수

integer는 거대한 집합 Z = {..., -2, -1, 0, 1, 2, ...}이다.

Arbitrary length integer / GMP, 부동 소수점수, Arbitrary precision / BCMath를 참고

문법

정수는 10진수(10-based), 16진수(16-based), 8진수(8-based) 표기법으로 표현 될수 있다. 선택적으로 부호 (- 나 +)를 사용할수 있다.

8진수 표기법을 사용하면, 0 (zero)를 숫자의 앞에 붙여야 하며, 16진수 표기하려면 0x을 숫자 앞에 붙이도록 한다.

예 6-1. 정수 리터럴

<?php
$a = 1234; # decimal number
$a = -123; # a negative number
$a = 0123; # octal number (equivalent to 83 decimal)
$a = 0x1A; # hexadecimal number (equivalent to 26 decimal)
?>
공식적으로 가능한 정수 리터럴의 구조는 다음과 같다:

decimal     : [1-9][0-9]*
            | 0

hexadecimal : 0[xX][0-9a-fA-F]+

octal       : 0[0-7]+

integer     : [+-]?decimal
            | [+-]?hexadecimal
            | [+-]?octal

약 20억을 최대값(부호가 있는 32비트)으로 사용할수 있을지라도, 정수의 크기는 플랫폼에 따라 달라지게 된다. PHP는 부호없는(unsigned) 정수 를 지원하지 않는다.

정수 오버플로우

정수타입의 범위를 넘는 수를 사용하려면 그 값은 대신 float타입으로 해석될 것이다. 또한, 결과값이 integer타입의 범위를 초과하게 되는 작업을 수행되면, 그 값은 대신 float으로 돌려줄것이다.

<?php
$large_number =  2147483647;
var_dump($large_number);
// output: int(2147483647)

$large_number =  2147483648;
var_dump($large_number);
// output: float(2147483648)

// this goes also for hexadecimal specified integers:
var_dump( 0x80000000 );
// output: float(2147483648)

$million = 1000000;
$large_number =  50000 * $million;
var_dump($large_number);
// output: float(50000000000)
?>

주의

불운하게도, PHP는 버그로 인해 음수와 연계될때 정확하게 동작하지 않을수 있다. 예를 들면 -50000 * $million를 수행하면, 결과는 -429496728이 될것이다. 두 피연산자가 모두 양수이면 아무 문제가 없다.

이 문제는 PHP 4.1.0에서 해결되었다.

PHP에는 정수 나누기 연산자가 없다. 1/2는 float 0.5가 된다. 반올림하기 위해 정수로 값을 캐스트하거나, round() 함수를 쓸수 있다.

<?php
var_dump(25/7);         // float(3.5714285714286)
var_dump((int) (25/7)); // int(3)
var_dump(round(25/7));  // float(4)
?>

정수로 변환하기

명시적으로 integer로 변환하려면 (int)나 (integer) 캐스트를 사용한다. 하지만, 대부분의 경우 이런 캐스트를 사용할 필요가 없다. 왜냐하면 연산자 나 함수 또는 제어 구조가 integer 인수를 요구한다면 자동으로 변환되기 때문이다. 또한 intval()함수로 정수값으로 변환할수 있다.

See also type-juggling.

논리값에서

FALSE는 0 (zero), 그리고 TRUE는 1 (one).

부동소수점수에서

float에서 integer로 변환할때, 그 수는 0으로 깍일것이다.

float이 integer범위를 초과하면 (주로 +/- 2.15e+9 = 2^31), 결과는 정의되지않는다. 왜냐하면 float은 정확한 정수값을 돌려주기에 충분한 정밀도를 갖지 않기 때문이다. 이 경우에는 warning이나 notice조차도 나타나지 않는다!

주의

알려지지 않은 소수를 integer로 캐스트하지 말것, 왜냐하면 이렇게 하는경우에 종종 기대하지 않는 결과를 유도할수 있기 때문이다.

<?php
echo (int) ( (0.1+0.7) * 10 ); // echoes 7!
?>

자세한 정보는 부동-정밀도에 관한 경고를 참고.

문자열로부터

문자열을 숫자로 변환하기를 참고

다른 타입으로부터

경고

정수로의 변환은 다른 타입에 대해 정의되지 않는다. 현재까지는 값이 논리값으로 변환될때와 동일하게 동작한다. 하지만, 경고 없이 변할수 있기 때문에 이 동작에 연관짓지 말것

이전 | 처음으로 | 다음
논리값 | 위로 | 부동소수점


부동소수점

부동소수점(AKA "floats", "doubles", "real numbers")은 다음과 같은 문법으로 표현될수 있다.

<?php
$a = 1.234;
$b = 1.2e3;
$c = 7E-10;
?>

공식적으로:

LNUM          [0-9]+
DNUM          ([0-9]*[\.]{LNUM}) | ({LNUM}[\.][0-9]*)
EXPONENT_DNUM ( ({LNUM} | {DNUM}) [eE][+-]? {LNUM})

float의 크기는 십진수 14자리가 일반적인 값(64비트 IEEE 포맷)이 되는 정밀도를 갖는 ~1.8e308까지의 최대값을 갖을지라도 플랫폼에 따라 달라진다.

부동소수점 정밀도

0.1이나 0.7와 같은 단순한 십진수의 분수는 약간의 정밀도의 소실없이 내부적인 이진처리로 변환될 수 없다. 이 사실은 혼란스런 결과를 유도할수 있다: 예를 들면, floor((0.1+0.7)*10)은 기대값 8이 아닌 7을 돌려준다. 내부적인 표현이 7.9999999999...와 같을것이기 때문이다.

이와 같은 이유로 유한값의 십진표기법을 쓰는 몇몇 소수를 정확히 표현할수 없다는 것이다. 예를 들면, 십진표기법의 1/3은 0.3333333. . .이 된다.

결코 부동소수점이 마지막 수를 갖을수 있을것이라고 생각하거나 부동소수점이 동일한지 비교하도록 해서는 안된다. 더 높은 정밀도가 필요하면, 대신 arbitrary precision math functions나 gmp함수를 사용하도록 해야 한다.

float으로 변환하기

문자열이 언제, 어떻게 float으로 변환하는지에 대한 정보는 문자열을 숫자로 변환하기섹션을 참고하라. 다른 타입에 대한 변환은 그 값이 integer나 float으로 변환하는 방식과 동일하다. 더 자세한 정보는 integer로 변환하기를 참고.

이전 | 처음으로 | 다음
정수 | 위로 | 문자열


문자열

string은 일련의 문자들이다. PHP에서 문자는 바이트와 같다. 즉 정확히 서로다른 256개의 문자를 사용할수 있다. 또한 PHP는 기본적으로 유니코드 지원을 갖지않는다. 유니코드에 대한 지원은 utf8_encode()과 utf8_decode()함수를 참고

참고: 문자열이 아무 문제없이 매우 커질수 있다. PHP에서 사용되는 문자열은 실질적으로 범위제한을 갖지 않는다. 그래서 긴 문자열에 대해서 걱정할 이유가 전혀 없다.

문법

문자열 리터럴은 3가지 다른 방식으로 표현될수 있다.

  • 작은 따옴표

  • 큰 따옴표

  • 상속 문법

작은 따옴표

단순한 문자열을 표현하는 가장 간단한 방법이 작은 따옴표 (문자 ')로 문자열을 둘러싸면 된다.

작은따옴표를 리터럴로 표현하려면 역슬래쉬(\)로 회피할 필요가 있다. 다른 많은 언어에서도 이와같은 방식을 사용한다. 작은 따옴표 앞이나 문자열의 끝에서 역슬래쉬가 있을필요가 있으면, 이것은 중복사용할 필요가 있다. 다른 모든 문자를 회피하려하면 역슬래쉬가 출력되어야 할것이란 것에 주의하라! 그래서 보통은 역슬래쉬 자체를 회피할 필요가 없다.

참고: PHP 3에서 이와 같은 일이 발생하면 E_NOTICE레벨의 경고가 출력될것이다.

참고: 이외 다른 두가지 문법과는 달리 작은 따옴표로 둘러싸인 문자열에서 변수와 특별한 문자를 위한 회피는 전개되지 못한다.

<?php
echo 'this is a simple string';

echo 'You can also have embedded newlines in
strings this way as it is
okay to do';

// Outputs: Arnold once said: "I'll be back"
echo 'Arnold once said: "I\'ll be back"';

// Outputs: You deleted C:\*.*?
echo 'You deleted C:\\*.*?';

// Outputs: You deleted C:\*.*?
echo 'You deleted C:\*.*?';

// Outputs: This will not expand: \n a newline
echo 'This will not expand: \n a newline';

// Outputs: Variables do not $expand $either
echo 'Variables do not $expand $either';
?>

큰 따옴표

문자열이 큰따옴표(")로 둘러싸이면, PHP는 특별한 문자의 회피를 더 잘 이해한다.

표 6-1. 회피 문자

sequence | meaning
\n | linefeed (LF or 0x0A (10) in ASCII)
\r | carriage return (CR or 0x0D (13) in ASCII)
\t | horizontal tab (HT or 0x09 (9) in ASCII)
\\ | backslash
\$ | dollar sign
\" | double-quote
\[0-7]{1,3} | 이 정규표현식은 8진표기법의 일련의 문자이다.
\x[0-9A-Fa-f]{1,2} | 이 정규표현식은 16진표기법의 일련의 문자이다.

다시 얘기하면, 다른 어떤 문자를 회피하려한다면, 역슬래쉬도 출력될것이다!

그러나 큰따옴표로 둘러싸인 문자열의 가장 중요한 특징은 변수명이 전개될것이란 사실이다. 더 자세한 사항은 문자열 해석을 참고.

히어닥 문법

문자열을 구분하는 다른 방법은 히어닥 문법("<<<")을 사용하는것이다. <<<이후에 식별자가 와야 하고 그다음에 문자열, 그다음에 인용을 닫는 어떤 식별자가 와야 한다.

닫기 식별자는 그 줄의 첫번째 컬럼에서 시작되어야 한다. 또한, 식별자는 PHP의 다른 라벨과 같은 명명규칙을 따라야 한다: 오직 알파벳 숫자와 밑줄을 포함하고 숫자가 아닌 문자나 밑줄로 시작되어야 한다.

주의

닫기 식별자를 갖는 줄은 가능한 세미콜른(;)를 제외하고 다른 문자를 포함하지 않는다는것에 주의해야 한다. 이말은 특별히 식별자가 줄맞춤이 되지 않을 것이고 어떤 공백이나 탭문자도 세미콜른의 앞이나 뒤에 있지 않을것이란 것이다. 닫기 식별자 전의 첫 문자는 운영체제에서 정의된 새줄이 되어야 한다는 것을 인식해야 한다. 예를 들면 매킨토시에서는 \r이 된다.

이 규칙을 깨고 닫기 식별자가 "확실"하지 않으면, 닫기 식별자로 인식되지 않으며 PHP는 다른 식별자를 계속 찾게 될것이다. 그래서 적절한 닫기 식별자가 발견되지 않으면 스크립트 끝의 줄번호로 해석 에러가 출력될것이다.

히어닥 텍스트는 큰따옴표가 없지만 큰따옴표로 둘러싸인 문자열처럼 동작한다. 히어닥에서는 따옴표를 회피할 필요가 없다는 의미를 갖는다. 그러나 여전히 위에서 열거한 회피 코드를 사용할수 있다. 문자가 전개되면, 히어닥 안의 복합 변수를 문자열로 표현할때 같은 주의가 필요하다.

예 6-2. 히어닥 문자열 인용 예

<?php
$str = <<<EOD
Example of string
spanning multiple lines
using heredoc syntax.
EOD;
/* More complex example, with variables. */
class foo
{
    var $foo;
    var $bar;

    function foo()
    {
        $this->foo = 'Foo';
        $this->bar = array('Bar1', 'Bar2', 'Bar3');
    }
}

$foo = new foo();
$name = 'MyName';

echo <<<EOT
My name is "$name". I am printing some $foo->foo.
Now, I am printing some {$foo->bar[1]}.
This should print a capital 'A': \x41
EOT;?>

참고: 히어닥 지원은 PHP 4에서 추가되었다.

변수 해석

문자열이 큰따옴표나 히어닥으로 표현되면 변수는 그 안에서 해석된다.

두가지 형태의 문법이 존재한다: 단순문법과 복합문법이다. 단순 문법은 가장 일반적이고 가장 편하다. 이 문법은 변수나 array값, object속성을 해석하는 방법을 제공한다.

복합 문법은 PHP 4에서부터 지원되고, 중괄호로 둘러싸는 표현으로 인식된다.

단순 문법

달러사인($)과 만나면, 해석기는 가능한 많은 토큰을 취해서 유효한 변수명을 형성하게 된다. 중괄호로 변수명을 둘러싸면 이름의 끝을 명시적으로 표시하려는 것이다.

<?php
$beer = 'Heineken';
echo "$beer's taste is great"; // works, "'" is an invalid character for varnames
echo "He drank some $beers";   // won't work, 's' is a valid character for varnames
echo "He drank some ${beer}s"; // works
echo "He drank some {$beer}s"; // works
?>

비슷하게, array 인덱스나 해석된 object특성을 보유할수 있다. 배열 인덱스로 닫음 대괄호 (])는 인덱스의 끝을 표시한다. 객체 속성은 변수를 갖는 트릭이 존재하지 않지만, 객체 특성에 대해서 단순한 변수에 적용되는 규칙과 같다.

<?php
// These examples are specific to using arrays inside of strings.
// When outside of a string, always quote your array string keys
// and do not use {braces} when outside of strings either.

// Let's show all errors
error_reporting(E_ALL);

$fruits = array('strawberry' => 'red', 'banana' => 'yellow');

// Works but note that this works differently outside string-quotes
echo "A banana is $fruits[banana].";

// Works
echo "A banana is {$fruits['banana']}.";

// Works but PHP looks for a constant named banana first
// as described below.
echo "A banana is {$fruits[banana]}.";

// Won't work, use braces.  This results in a parse error.
echo "A banana is $fruits['banana'].";

// Works
echo "A banana is " . $fruits['banana'] . ".";

// Works
echo "This square is $square->width meters broad.";

// Won't work. For a solution, see the complex syntax.
echo "This square is $square->width00 centimeters broad.";
?>

좀더 복잡한 변수에 대해서, 복합 문법을 사용해야 한다.

복합(curly) 문법

이 방법은 문법이 복합적이라서 복합이라고 부르는것이 아니다. 대신에 이 방법으로 복합 표현식을 포함할수 있기 때문이다.

사실, 이 문법으로 문자열의 네임스페이스에 존재하는 어떤변수 도 포함할수 있다. 단순히 문자열을 드러내는 방법과 동일한 표현식을 쓸수 있다. 그리고 { 과 } 안에 그것을 포함한다. '{'를 회피할 수 없기 때문에 이 문법은 $가 즉시 {뒤에 올때만 인식된다. ("{$" 리터럴을 쓰려면 "{\$" 이나 "\{$" 을 사용하라). 몇가지 예를 보고 위 설명을 이해해보자:

<?php
// 모든 에러를 보여줍니다.
error_reporting(E_ALL);

$great = 'fantastic';

// 작동하지 않습니다, 출력: This is { fantastic}
echo "This is { $great}";

// 작동합니다, 출력: This is fantastic
echo "This is {$great}";
echo "This is ${great}";

// 작동합니다.
echo "This square is {$square->width}00 centimeters broad.";

// 작동합니다.
echo "This works: {$arr[4][3]}";

// $foo[bar]가 문자열 밖에서 유효하지 않은 것과 마찬가지로,
// 잘못되었습니다. 즉, 이는 작동하지만 PHP는 먼저 상수 이름
// foo를 찾고, E_NOTICE 레벨의 오류(정의되지 않은 상수)를
// 발생합니다.
echo "This is wrong: {$arr[foo][3]}";

// 작동합니다. 문자열 안에서 다차원 배열을 사용할 때는,
// 항상 배열 주위를 중괄호로 감싸주십시오.
echo "This works: {$arr['foo'][3]}";

// 작동합니다.
echo "This works: " . $arr['foo'][3];

echo "You can even write {$obj->values[3]->name}";

echo "This is the value of the var named $name: {${$name}}";
?>

문자열의 문자에 접근 및 변경

문자열 내의 문자들 중 원하는 문자를 중괄호안에 0을 기준으로 한 위치를 표기하여 접근하고, 변경할 수 있습니다.

참고: 하위 버전과의 호환을 위해, 같은 목적으로 대괄호를 사용할 수 있습니다. 하지만, 이 문법은 PHP 4에서 배제되었습니다.

예 6-3. 몇 가지 문자열 예

<?php
// Get the first character of a string
$str = 'This is a test.';
$first = $str{0};

// Get the third character of a string
$third = $str{2};

// Get the last character of a string.
$str = 'This is still a test.';
$last = $str{strlen($str)-1};

// 문자열의 마지막 문자를 변경.
$str = 'Look at the sea';
$str{strlen($str)-1} = 'e';

?>

유용한 함수와 연산자

문자열들은 '.' (점) 연산자를 사용하여 합칠수 있다. '+' (덧셈) 연산자는 이 목적에 부합되지 않는다는 것에 주의해야 한다. 자세한 정보는 문자열 연산자를 참고

문자열 조작을 위한 많은 유용한 함수가 지원된다.

일반적인 기능을 대해서는 문자열 함수 섹션을 참고하고, 향상된 find&replace 기능을 위해 정규표현식 함수를 참고 (두가지 중 선택할수 있다: Perl과 POSIX extended).

URL-문자열을 위한 함수와 문자열을 encrypt/decrypt하는 함수도 지원된다. (mcrypt과 mhash).

그래도 원하는 기능을 찾을수 없다면, 문자 타입 함수로 참고.

문자열로 변환

(string)이나 strval()함수를 사용하여 값을 문자열로 변환할수 있다. 문자열 변환은 문자열이 필요한 표현식의 유효영역 내에서 자동적으로 이루어진다.이런 일은 echo()나 print()함수를 쓸때, 또는 변수값을 문자열과 비교할때 발생한다. 타입과 타입 저글링 매뉴얼 섹션을 읽음으로써 다음에서 설명하는 것을 더욱 명확하게 이해하게 될것이다. settype()함수도 참고.

boolean TRUE값은 문자열 "1"로 변환된다. FALSE 값은 "" (빈 문자열)로 표현된다. 이 원리로 논리값과 문자열값 사이에서 어느 방향으로든 변환이 가능하다.

integer나 부동소수점(float)은 각 자리의 숫자를 문자열로 변환할수 있다 (부동소수점수에 대한 지수부를 포함함).

배열은 항상 문자열 "Array"로 변환된다. 그래서 배열 안에 무엇이 들었는지 보기 위해 echo()나 print()를 쓴다고 해서 array의 내용을 덤프할수 없다. 한 요소를 보기 위해서는 echo $arr['foo']와 같이 써줘야 한다. 전체 내용물을 덤프/보기 위한 팁을 아래글에서 볼수 있다.

객체는 항상 문자열 "Object"로 변환된다. 만약 디버깅 목적으로 object의 멤버 변수를 모두 출력하고 싶으면, 아래 단락을 보라. 특정 객체를 만들어내는 클래스명을 확인하려한다면, get_class()를 사용하라.

자원은 항상 구조체 "Resource id #1"를 갖는 문자열로 변환된다. 1은 실행기간동안 PHP에 의해 설정되는 resource의 유일한 수이다. 자원의 타입을 얻고자 하면, get_resource_type()함수를 사용하라.

NULL 은 항상 빈 문자열로 변환된다.

위글에서 볼수 있듯이, 배열, 객체 또는 자원을 출력하는 것은 배열자체에 대한 어떤 유용한 정보도 제공해주지 않는다. 디버깅을 위해 그 값들을 출력하는 가장 좋은 방법인 print_r()과 var_dump() 함수를 참고할것.

PHP 값을 지속적으로 저장하기 위해 문자열로 변환할수 있다. 이런 방법을 직렬화(serialization)라고 한다. 함수 serialize()를 사용하면 된다. PHP 값을 XML 구조체로 직렬화할수도 있다. PHP 설정시 WDDX 지원 옵션을 추가하면 된다.

문자열을 숫자로 변환하기

문자열을 숫자값으로 취급할때, 결과값과 타입은 다음과 같이 결정된다.

그 값이 '.', 'e', 'E' 중에 어느것이든 포함하고 있으면 float으로 취급될것이다. 그렇지 않으면, 정수로 취급할것이다.

그 값은 문자열의 시작부분에 의해 주어진다. 문자열이 유효한 숫자 데이터로 시작되면, 이것이 사용되는 값이 될것이다. 그렇지 않으면 그 값은 0(zero)로 된다. 유효한 숫자 데이터는 선택적인 부호, 한자리 이상(선택적인 십진 포인트를 포함)의 수, 선택적인 지수가 될수있다. 지수는 한자리 이상의 수가 'e' 이나 'E'의 뒤에 오면 된다.

<?php
$foo = 1 + "10.5";                // $foo is float (11.5)
$foo = 1 + "-1.3e3";              // $foo is float (-1299)
$foo = 1 + "bob-1.3e3";           // $foo is integer (1)
$foo = 1 + "bob3";                // $foo is integer (1)
$foo = 1 + "10 Small Pigs";       // $foo is integer (11)
$foo = 4 + "10.2 Little Piggies"; // $foo is float (14.2)
$foo = "10.0 pigs " + 1;          // $foo is float (11)
$foo = "10.0 pigs " + 1.0;        // $foo is float (11)
?>

이런 종류의 변환에 대한 더 많은 정보는 strtod(3)의 유닉스 매뉴얼 페이지에서 볼수 있다.

이 섹션의 어떤 예제를 테스트하려면, 예제를 복사해서 붙여넣으면 되고 무슨일이 일어나는지 확인하기 위해 다음 줄을 삽입할수 있다.

<?php
echo "\$foo==$foo; type is " . gettype ($foo) . "<br />\n";
?>

정수로 변환하여 한 문자의 코드를 얻을수 있다고 기대하지 마시오 (예를 들면 C에서 하는 것처럼). 캐릭터코드와 문자 사이의 변환을 위해서는 ord()와 chr()함수를 사용할수 있다.

이전 | 처음으로 | 다음
부동소수점 | 위로 | 배열


배열

PHP에서 배열은 실질적으로 순서가 있는 맵이다. 한 맵은 values를 keys로 맵핑하는 타입이다. 이 타입은 몇가지 목적에 의해 옵티마이징될수 있다. 그래서 그 타입을 실제 배열이나 리스트(vector), 해쉬테이블(map의 구현), 딕셔너리(dictionary), 컬렉션(collection), 스택(stack), 큐(queue), 등등으로 사용할수 있다. 다른 PHP 배열을 값으로 갖을수 있기 때문에, 트리(tree)를 아주 쉽게 시뮬레이션할수 있다.

그런 데이터 구조(자료 구조)는 이 매뉴얼의 범위를 벗어난다. 그러나 그들 각각의 예를 최소한 하나는 발견할수 있을것이다. 자세한 정보를 위해 이 광범위한 주제에 대한 참고서적을 제시해줄것이다.

문법

array()함수로 명기

array는 array() 언어-구조에 의해 생성될수 있다. 이 함수는 콤마로 구분되는 몇 개의 key => value쌍을 취할수 있다.

array( [key =>] value
     , ...
     )
// key may be an integer or string
// value may be any value

<?php
$arr = array("foo" => "bar", 12 => true);

echo $arr["foo"]; // bar
echo $arr[12];    // 1
?>

key는 integer나 string타입이 될수 있다. key가 표준적인 integer타입이면, 그 값으로 해석될것이다 (즉, "8"은 8로 해석되는 반면, "08"은 "08"로 해석된다). PHP에서 인덱스 배열과 연관 배열 사이는 아무 차이가 없다; 오직 하나의 배열 타입만이 있는데, 그 배열은 정수나 문자열 인덱스를 모두 포함할수 있다.

값은 모든 종류의 PHP 타입이 될수 있다.

<?php
$arr = array("somearray" => array(6 => 5, 13 => 9, "a" => 42));

echo $arr["somearray"][6];    // 5
echo $arr["somearray"][13];   // 9
echo $arr["somearray"]["a"];  // 42
?>

주어진 값에 대한 key를 표기하지 않으면, 정수 인덱스의 최대값이 취해져서 새로운 key는 최대값 + 1이 될것이다. 이미 값을 보유하고 있는 key를 지정하게 되면, 그 값은 덮어씌어질것이다.

<?php
// This array is the same as ...
array(5 => 43, 32, 56, "b" => 12);

// ...this array
array(5 => 43, 6 => 32, 7 => 56, "b" => 12);
?>

주의

PHP 4.3.0에서는 위에서 설명한 인덱스 생성 동작이 변경되었다. 즉, 현재 최대 key가 음수인 배열에 추가동작이 발생하면, 다음 key는 제로 (0)가 될것이다. 전에는, 새로운 인덱스는 기존의 가장 큰 key + 1로 되었었다. 양수의 인덱스에는 같은 동작을 한다.

key로 TRUE를 사용하는 것은 integer 1 key가 될것이다. key로 FALSE를 사용하면 integer 0 key가 될것이다. key로 NULL을 사용하면 빈 문자열로 취급될것이다. key로 빈문자열을 사용하는 것은 빈 문자열을 갖는 key를 만들고 그 값을 생성 (또는 덮어씀)한다; 빈 대괄호를 사용하는것과는 다르다.

key로 배열이나 객체를 사용할수 없다. 그렇게 하면 다음과 같은 경고가 발생할것이다: Illegal offset type.

대괄호 문법을 사용하여 생성/변경

그 안에 값을 명시적으로 표시함으로써 기존의 배열을 변경할수 있다.

이와 같은 일은 대괄호 안에 key를 표시함으로해서 배열에 값을 지정하여 수행한다. key를 빼먹을수도 있고, 그 경우에 변수명에 빈 대괄호("[]")를 추가한다.
$arr[key] = value;
$arr[] = value;
// key may be an integer or string
// value may be any value
$arr이 아직 존재하지 않으면, 생성될것이다. 그래서 이 방법이 배열을 표현하는 대안이 된다. 어떤 값을 변경하려면, 그 key로 표현되는 요소에 새로운 값을 지정한다. key/value 쌍을 제거하려면, 그것을 unset()할 필요가 있다.

<?php
$arr = array(5 => 1, 12 => 2);

$arr[] = 56;    // This is the same as $arr[13] = 56;
                // at this point of the script

$arr["x"] = 42; // This adds a new element to
                // the array with key "x"

unset($arr[5]); // This removes the element from the array

unset($arr);    // This deletes the whole array
?>

참고: 위에서 설명한바와 같이, key가 없는 대괄호를 사용한다면, 존재하는 정수 인덱스의 최대값이 취해질것이고, 새로운 key는 최대값의 + 1이 될것이다. 정수 인덱스가 아직 존재하지 않으면, key는 0(제로)가 될것이다. 이미 값을 보유하고 있는 key로 지정하면, 그 값은 덮어 씌어질것이다.

주의

PHP 4.3.0에서는 위에서 설명한 인덱스 생성 동작이 변경되었다. 즉, 현재 최대 key가 음수인 배열에 추가동작이 발생하면, 다음 key는 제로 (0)가 될것이다. 전에는, 새로운 인덱스는 기존의 가장 큰 key + 1로 되었었다. 양수의 인덱스에는 같은 동작을 한다.

이 목적을 위한 최대 정수 key는 현재까지는 배열 안에 존재할 필요가 없다. 단순히 배열을 마지막으로 인덱스 한 이후 어떤 시간내에 배열 안에 존재해야 한다. 다음 예를 보면:

<?php
// Create a simple array.
$array = array(1, 2, 3, 4, 5);
print_r($array);

// Now delete every item, but leave the array itself intact:
foreach ($array as $i => $value) {
    unset($array[$i]);
}
print_r($array);

// Append an item (note that the new key is 5, instead of 0 as you
// might expect).
$array[] = 6;
print_r($array);

// Re-index:
$array = array_values($array);
$array[] = 7;
print_r($array);
?>

위 예제 코드는 다음을 출력할것이다:
Array
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)
Array
(
)
Array
(
    [5] => 6
)
Array
(
    [0] => 6
    [1] => 7
)

유용한 함수

배열을 위한 유용한 함수가 지원된다. 배열 함수 섹션을 볼것.

참고: unset()함수는 항상 배열의 key를 unset한다. 배열이 다시 인덱스되지 않을것이라는것에 주의한다. 오직 "가용한 정수 인덱스"를 사용한다면(제로에서 시작해서, 하나씩 증가), array_values()를 사용하여 재인덱싱 효과를 수행할수 있다.

<?php
$a = array(1 => 'one', 2 => 'two', 3 => 'three');
unset($a[2]);
/* will produce an array that would have been defined as
   $a = array(1 => 'one', 3 => 'three');
   and NOT
   $a = array(1 => 'one', 2 =>'three');
*/

$b = array_values($a);
// Now b is array(0 => 'one', 1 =>'three')
?>

foreach 제어 구조는 배열을 위해 특별히 지원되는것이다. 배열 안을 이동하는 가장 빠른 방법을 제공한다.

배열이 하는것과 하지 않는것

왜 $foo[bar]이 잘못인가?

항상 문자열 리터럴 배열 인덱스 주위에는 따옴표를 사용해야 한다. 예를 들면, $foo['bar']을 사용하고 $foo[bar]은 사용하지 말라. 그러나 왜 $foo[bar]이 잘못인가? 오래된 스크립트에서 다음 문법을 볼수 있을것이다:

<?php
$foo[bar] = 'enemy';
echo $foo[bar];
// etc
?>

이것은 잘못된것이지만, 동작하다. 그렇다면, 왜 잘못인가? 그 이유는 이 코드가 문자열('bar' - 따옴표 사용) 보다는 정의되지 않은 상수 (bar)를 갖는다는것이다. 그리고 PHP는 미래에 상수를 정의할수 있는데, 불운하게도 이 코드에서, 같은 이름을 갖을수도 있다. 이것은 잘 작동하는 이유는 PHP가 자동으로 bare string(알려진 심벌과 대응되지 않는 따옴표 없는 문자열)을 bare string을 포함하는 문자열로 변환하기 때문이다. bar라는 이름으로 정의된 상수가 없으면, PHP는 그것을 'bar'로 대치시켜서 사용할것이다.

참고: 위 말은 항상 key를 따옴표 처리하라는 것이 아니다. 상수나 변수가 PHP에서 해석되는것을 방지하기 위해 key에서 이들을 따옴표처리하지 않을수 있다.

<?php
error_reporting(E_ALL);
ini_set('display_errors', true);
ini_set('html_errors', false);
// Simple array:
$array = array(1, 2);
$count = count($array);
for ($i = 0; $i < $count; $i++) {
    echo "\nChecking $i: \n";
    echo "Bad: " . $array['$i'] . "\n";
    echo "Good: " . $array[$i] . "\n";
    echo "Bad: {$array['$i']}\n";
    echo "Good: {$array[$i]}\n";
}
?>

참고: 위 예제코드의 출력은 다음과 같다:
Checking 0:
Notice: Undefined index:  $i in /path/to/script.html on line 9
Bad:
Good: 1
Notice: Undefined index:  $i in /path/to/script.html on line 11
Bad:
Good: 1

Checking 1:
Notice: Undefined index:  $i in /path/to/script.html on line 9
Bad:
Good: 2
Notice: Undefined index:  $i in /path/to/script.html on line 11
Bad:
Good: 2

위 사실을 설명하는 몇가지 예제 코드:

<?php
// Let's show all errors
error_reporting(E_ALL);

$arr = array('fruit' => 'apple', 'veggie' => 'carrot');

// Correct
print $arr['fruit'];  // apple
print $arr['veggie']; // carrot

// Incorrect.  This works but also throws a PHP error of
// level E_NOTICE because of an undefined constant named fruit
//
// Notice: Use of undefined constant fruit - assumed 'fruit' in...
print $arr[fruit];    // apple

// Let's define a constant to demonstrate what's going on.  We
// will assign value 'veggie' to a constant named fruit.
define('fruit', 'veggie');

// Notice the difference now
print $arr['fruit'];  // apple
print $arr[fruit];    // carrot

// The following is okay as it's inside a string.  Constants are not
// looked for within strings so no E_NOTICE error here
print "Hello $arr[fruit]";      // Hello apple

// With one exception, braces surrounding arrays within strings
// allows constants to be looked for
print "Hello {$arr[fruit]}";    // Hello carrot
print "Hello {$arr['fruit']}";  // Hello apple

// This will not work, results in a parse error such as:
// Parse error: parse error, expecting T_STRING' or T_VARIABLE' or T_NUM_STRING'
// This of course applies to using autoglobals in strings as well
print "Hello $arr['fruit']";
print "Hello $_GET['foo']";

// Concatenation is another option
print "Hello " . $arr['fruit']; // Hello apple
?>

E_NOTICE 레벨 에러(E_ALL로 설정) 를 보이기 위해 error_reporting()함수를 쓸때, 다음과 같은 에러를 보게 될것이다. 기본값으로, error_reporting은 그들을 보여주지 않는다.

문법 섹션에서 설명한대로, 대괄호('[' 과 ']') 사이에 표현식이 존재해야 한다. 이 말의 의미는 다음과 같은 코드를 쓸수 있다는 뜻이다:

<?php
echo $arr[somefunc($bar)];
?>

배열 인덱스로 값을 돌려주는 함수를 사용하는 예를 보인다. 전에 E_*와 같은 것을 보았듯이, PHP는 상수들을 알고 있다.

<?php
$error_descriptions[E_ERROR]   = "A fatal error has occured";
$error_descriptions[E_WARNING] = "PHP issued a warning";
$error_descriptions[E_NOTICE]  = "This is just an informal notice";
?>

첫번째 예의bar처럼, E_ERROR는 유효한 식별자라는것에 주의한다. 그러나 위 예는 다음과 같다:

<?php
$error_descriptions[1] = "A fatal error has occured";
$error_descriptions[2] = "PHP issued a warning";
$error_descriptions[8] = "This is just an informal notice";
?>

왜냐하면 E_ERROR는 1과 같기때문이다 etc.

위 예에서 이미 설명했듯이, $foo[bar]은 작동하지만 잘못되었다. 이 코드는 작동한다. 왜냐하면 이 문법에서 bar는 상수 표현으로 인식될수도 있기 때문이다. 하지만, 이 경우에 bar란 이름을 갖는 상수는 존재하지 않는다. PHP는 문자그대로 bar를 표시했다고 인식해서 문자열 "bar"으로 보기 때문이다. 따옴표 쓰는것을 잊었다고 인식한다.

그래서 그것이 왜 나쁜가?

미래의 어떤 시점에서, PHP 팀은 또다른 상수나 키워드를 추가할수도 있거나, 애플리케이션안에 또다른 상수를 사용할수도 있다. 그러면 이 경우에 어려움에 빠지게 된다. 예를 들면, empty와 default워드는 이런 이유로 사용할수 없다. 왜냐하면 그들은 특별한 예약 키워드이기 때문이다.

참고: 배반복하지만, 큰따옴표로 둘러싼 string안에서 "$foo[bar]"이 유효하도록 따옴표를 배열 인덱스에 둘러싸지 않는것이 유효한다. 그 이유에 대한 상세 설명을 위해 위 예제코드를 보는 것은 물론 문자열 안에서 해석되는 변수에 관한 섹션도 참고할것.

배열로 변환

다른 타입을 갖는: integer, float, string, boolean, resource, 어떤 값을 array로 변환한다면, 한개의 요소를 갖는 (인덱스 0) 배열을 얻을수 있다. 그 구성요소는 스칼라 값이다.

object를 배열로 변환하면, 각 객체의 속성(멤버 변수)를 배열의 구성요소로서 취할수 있다. key는 멤버 변수명이 된다.

NULL값을 배열로 변환하면, 빈 배열을 얻을수 있다.

비교하기

array_diff()와 배열 연산자를 사용하여 배열을 비교할 수 있습니다.

예제 코드

PHP에서 배열 타입은 다용도로 쓰인다. 그래서 여기서 배열의 완벽한 능력을 보이기 위해 몇가지 예제 코드를 보일것이다.

<?php
// this
$a = array( 'color' => 'red',
            'taste' => 'sweet',
            'shape' => 'round',
            'name'  => 'apple',
                       4        // key will be 0
          );

// is completely equivalent with
$a['color'] = 'red';
$a['taste'] = 'sweet';
$a['shape'] = 'round';
$a['name']  = 'apple';
$a[]        = 4;        // key will be 0

$b[] = 'a';
$b[] = 'b';
$b[] = 'c';
// will result in the array array(0 => 'a' , 1 => 'b' , 2 => 'c'),
// or simply array('a', 'b', 'c')
?>

예 6-4. array() 사용하기

<?php
// Array as (property-)map
$map = array( 'version'    => 4,
              'OS'         => 'Linux',
              'lang'       => 'english',
              'short_tags' => true
            );

// strictly numerical keys
$array = array( 7,
                8,
                0,
                156,
                -10
              );
// this is the same as array(0 => 7, 1 => 8, ...)

$switching = array(         10, // key = 0
                    5    =>  6,
                    3    =>  7,
                    'a'  =>  4,
                            11, // key = 6 (maximum of integer-indices was 5)
                    '8'  =>  2, // key = 8 (integer!)
                    '02' => 77, // key = '02'
                    0    => 12  // the value 10 will be overwritten by 12
                  );

// empty array
$empty = array();
?>

예 6-5. 컬렉션

<?php
$colors = array('red', 'blue', 'green', 'yellow');

foreach ($colors as $color) {
    echo "Do you like $color?\n";
}
?>

출력은:

Do you like red?
Do you like blue?
Do you like green?
Do you like yellow?

현재까지 배열의 값을 이런 루프 안에서 직접 변경하는 것은 불가능하다는 것에 주의해야 한다. 다음과 같은 편법이 있다:

예 6-6. 컬렉션

<?php
foreach ($colors as $key => $color) {
    // won't work:
    //$color = strtoupper($color);

    // works:
    $colors[$key] = strtoupper($color);
}
print_r($colors);
?>

출력은:

Array
(
    [0] => RED
    [1] => BLUE
    [2] => GREEN
    [3] => YELLOW
)

이 예제 코드는 one-based 배열을 생성한다.

예 6-7. One-based index

<?php
$firstquarter  = array(1 => 'January', 'February', 'March');
print_r($firstquarter);
?>

출력은:

Array
(
    [1] => 'January'
    [2] => 'February'
    [3] => 'March'
)

예 6-8. 배열 채우기

<?php
// fill an array with all items from a directory
$handle = opendir('.');
while (false !== ($file = readdir($handle))) {
    $files[] = $file;
}
closedir($handle);
?>

배열은 순서가 있다. 다양한 정력함수를 사용하여 그 순서를 변경할수도 있다. 더 자세한 정보는 배열 함수섹션을 참고. count()함수를 사용하여 배열 내의 아이템 수를 셀수 있다.

예 6-9. 배열 정렬하기

<?php
sort($files);
print_r($files);
?>

배열의 값은 어느것이든 될수 있기 때문에, 또한 다른 배열이 될수 있다. 이 방식으로 재귀적이고 다차원인 배열을 만들수 있다.

예 6-10. 재귀적이고 다차원인 배열

<?php
$fruits = array ( "fruits"  => array ( "a" => "orange",
                                       "b" => "banana",
                                       "c" => "apple"
                                     ),
                  "numbers" => array ( 1,
                                       2,
                                       3,
                                       4,
                                       5,
                                       6
                                     ),
                  "holes"   => array (      "first",
                                       5 => "second",
                                            "third"
                                     )
                );

// Some examples to address values in the array above
echo $fruits["holes"][5];    // prints "second"
echo $fruits["fruits"]["a"]; // prints "orange"
unset($fruits["holes"][0]);  // remove "first"

// Create a new multi-dimensional array
$juices["apple"]["green"] = "good";
?>

배열 지정은 항상 값 복사에 관련되어 있다는 것을 알고 있어야 한다. 참조에 의해 배열을 복사하려면 참조 연산자를 사용하여야 한다.

<?php
$arr1 = array(2, 3);
$arr2 = $arr1;
$arr2[] = 4; // $arr2 is changed,
             // $arr1 is still array(2, 3)

$arr3 = &$arr1;
$arr3[] = 4; // now $arr1 and $arr3 are the same
?>

이전 | 처음으로 | 다음
문자열 | 위로 | 객체


객체

객체 초기화

객체를 초기화하기 위해서는 변수로 객체를 인스턴스화하는 new문을 사용하라.

<?php
class foo
{
    function do_foo()
    {
        echo "Doing foo.";
    }
}

$bar = new foo;
$bar->do_foo();
?>

더 자세한 사항은 클래스와 객체 섹션을 참고한다.

객체로 변환하기

객체가 객체로 변환되면, 그것은 변경되지 않는다. 다른 타입의 값이 객체로 변환되면, stdClass내장 클래스의 새로운 인스턴스가 생성된다. 그 값이 null이면, 새로운 인스턴스는 텅빌것이다. 다른 값은 scalar라는 멤버 변수명이 포함할것이다.

<?php
$obj = (object) 'ciao';
echo $obj->scalar;  // outputs 'ciao'
?>

이전 | 처음으로 | 다음
배열 | 위로 | 자원


자원

resource는 특별한 변수이고, 특별한 자원에 대한 참조를 포함한다. 자원은 특별한 함수에 의해 생성되고 사용된다. 이런 모든 함수의 목록과 대응하는 자원 타입에 대해서는 부록 섹션을 참고한다.

참고: resource 타입은 PHP 4에서부터 지원된다.

resource로 변환하기

resource 타입은 파일이나 데이터베이스 접속, 이미지 캔버스 영역 등을 열기위한 특별한 핸들러를 보유하기 때문에, 어떤값도 resource로 변환될수 없다.

Freeing resources

PHP 4의 젠드 엔진에서 참조-카운팅(reference-counting) 시스템이 추가되어, resource가 더이상 참조되지 않을때가 자동적으로 탐지된다(자바처럼). 이 경우에, 이 자원을 위해 사용중인 모든 자원은 가비지 컬렉터에 의해 자동으로 해제된다. 이런 이유로, free_result같은 함수를 사용하여 수동으로 메모리를 해제할 필요는 어의 없다.

참고: 영구적인 데이터베이스 접속은 특별하다. 그것은 가비지 컬렉터에 의해 파괴되지 않는다. 영구적인 접속를 참고.

이전 | 처음으로 | 다음
객체 | 위로 | NULL


NULL

특별한 값인 NULL은 아무 값을 갖지 않는 변수를 표현한다. NULL은 유일한 NULL타입의 값이다.

참고: null 타입은 PHP 4에서 소개되었다

다음과 같은 경우에 변수는 NULL로 취급된다

  • 상수를 NULL로 할당했을 때.

  • 아직 아무 값도 할당하지 않았을 때.

  • unset()을 사용했을 때.

문법

타입은 유일한 값 NULL을 갖는다. NULL은 대소문자를 구별하지 않는다.

<?php
$var = NULL;
?>

is_null()과 unset()을 참고

이전 | 처음으로 | 다음
자원 | 위로 | 이 문서에서 사용되는 의사 타입


이 문서에서 사용되는 의사 타입

mixed

mixed는 인자가 여러 타입을 허용한다는 것을 가리킨다 (모든 변수형일 필요는 없다)

gettype()은 모든 PHP 타입을 다루고, 반면에 str_replace()은 문자열과 배열만을 다룬다.

number

number는 인자가 integer나 float일수 있음을 가리킨다.

callback

call_user_func()나 usort()와 같은 함수는 인자로 사용자선언 콜백 함수를 취급한다. 콜백 함수는 단순한 함수 뿐만 아니라 정적 클래스 메소드를 포함하는 객체 메소드가 될수 있다.

PHP 함수는 단순히 그 이름을 문자열로 전달한다. 다음 함수를 제외하고
내장 함수나 유저 선언 함수를 전달할수 있다.
array(),
echo(),
empty(),
eval(),
exit(),
isset(),
list(),
print(),
unset().

인스턴스화된 객체의 메소드는 인덱스 0의 요소인 객체와 인덱스 1의 요소인 메소드명을 포함하는 배열로 전달된다.

정적 클래스 메소드는 인덱스 0의 요소인 객체 대신 클래스명을 전달함으로써 그 클래스의 객체를 인스턴스화하지 않고도 전달될수 있다.

예 6-11. 콜백 함수 예제코드

<?php

// simple callback example
function my_callback_function() {
    echo 'hello world!';
}
+call_user_func('my_callback_function');

// method callback examples
class MyClass {
    function myCallbackMethod() {
        echo 'Hello World!';
    }
}

// static class method call without instantiating an object
call_user_func(array('MyClass', 'myCallbackMethod'));

// object method call
$obj = new MyClass();
call_user_func(array(&$obj, 'myCallbackMethod'));

?>

이전 | 처음으로 | 다음
NULL | 위로 | 타입 저글링


타입 저글링

PHP는 변수 선언부의 명시적인 타입 정의를 요구하지않는다(지원하지않는다) 변수의 타입은 변수가 사용되는 환경에서 결정된다. 즉, 문자열 값을 변수 $var에 지정하면,$var는 문자열이 된다. integer값이 $var에 지정되면, integer가 된다.

PHP의 자동적인 타입 변환의 예로는 덧셈 연산자 '+'를 들수 있다. 피연산자 중 어느 하나가 float이라면, 모든 피연산자는 float으로 취급된다. 그렇지 않으면, 피연산자는 정수로 해석될것이고, 결과값도 정수가 될것이다. 이런일이 피연산자 자신의 타입을 바꾸지 않는다는 것에 주의하라; 피연산자가 어떻게 평가되느냐에 따라서만 변환이 이루어진다.

<?php
$foo = "0";  // $foo is string (ASCII 48)
$foo += 2;   // $foo is now an integer (2)
$foo = $foo + 1.3;  // $foo is now a float (3.3)
$foo = 5 + "10 Little Piggies"; // $foo is integer (15)
$foo = 5 + "10 Small Pigs";     // $foo is integer (15)
?>

위 예제코드중 마지막 두가지가 이상해 보인다면, 문자열을 수로 변환을 참고.

어떤 변수를 특정 타입으로 취급하고자 한다면, 타입 캐스트 매뉴얼 섹션을 참고할것. 변수의 타입을 변환하려고 하면, settype()를 볼것.

이 섹션에서 다른 에제를 테스트하기 위해 var_dump() 함수를 사용할수 있다.

참고: 배열의 자동적인 변환 방식은 현재까지 정의되지 않았다.

<?php
$a = "1";     // $a is a string
$a[0] = "f";  // What about string offsets? What happens?
?>

PHP는 배열 인덱싱과 같은 문법을 사용하여 오프셋을 통하여 문자열 안의 인덱싱을 지원하기 때문에(역사적인이유로), 위 예제코드는 문제가 될 소지가 있다: $a는 그 첫번째 요소가 "f"를 갖는 배열이 되는가? "f"가 문자열 $a 문자열의 첫번째 문자가 되는가?

현재 버전 PHP는 두번째 할당문을 문자열 오프셋 인식으로 해석한다. 그래서 $a는 "f"가 되고, 자동 변환의 결과는 정의되지 않은것으로 여겨진다. PHP 4는 스트링 내의 문자에 접근하기 위한 중괄호 문법을 새로이 제공한다. 위에서 제시한것 대신 이문법을 사용하도록 한다

<?php
$a    = "abc"; // $a is a string
$a{1} = "f";   // $a is now "afc"
?>

자세한 정보는 문자열의 문자 접근과 변경섹션을 참고.

타입 캐스트

PHP에서 타입 캐스느는 C에서 동작하는 것과 유사하게 동작한다. 원하는 타입의 이름을 변수 앞 괄호안에 사용하여 캐스트될수 있다.

<?php
$foo = 10;   // $foo is an integer
$bar = (boolean) $foo;   // $bar is a boolean
?>

허용되는 캐스트는 다음과 같다:

  • (int), (integer) - cast to integer

  • (bool), (boolean) - cast to boolean

  • (float), (double), (real) - cast to float

  • (string) - cast to string

  • (array) - cast to array

  • (object) - cast to object

탭과 빈칸이 괄호안에서 허용된다는것에 주의한다. 그래서 다음 예는 기능적으로 동일하다:

<?php
$foo = (int) $bar;
$foo = ( int ) $bar;
?>

참고: 변수를 문자열로 캐스트하는 대신에, 큰 따옴표 안에 변수를 넣어줄수도 있다.

<?php
$foo = 10;            // $foo is an integer
$str = "$foo";        // $str is a string
$fst = (string) $foo; // $fst is also a string

// This prints out that "they are the same"
if ($fst === $str) {
    echo "they are the same";
}
?>

특정 타입간의 캐스트가 될때 무슨일이 일어날지 여기서 명확하지 않으면 자세한 정보를 보기 위해 아래 섹션을 참고.

  • 논리값으로 변환하기

  • 정수로 변환하기

  • float으로 변환하기

  • 문자열로 변환하기

  • 배열로 변환하기

  • 객체로 변환하기

  • resource로 변환하기

  • 타입 비교 테이블

이전 | 처음으로 | 다음
이 문서에서 사용되는 의사 타입 | 위로 | 변수


변수

PHP 매뉴얼
이전 다음

7. 장. 변수

차례
기본문법
미리 선언된 변수
변수 유효영역
가변 변수
PHP 외부 출신의 변수들

기본문법

PHP에서 변수는 변수명 앞에 달러사인을 덧붙여 표현된다. 변수명은 대소문자를 구별한다.

PHP에서 변수명은 다음 규칙을 따른다. 유효한 변수명은 문자나 밑줄로 시작하고, 그 뒤에 문자, 숫자, 밑줄이 붙을수 있다. 정규표현식으로 표현하면 다음과 같다: '[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*'

참고: 여기서, 문자는 a-z, A-Z, 그리고 아스키문자(ASCII) 127에서 255까지(0x7f-0xff).

<?php
$var = "Bob";
$Var = "Joe";
echo "$var, $Var";      // outputs "Bob, Joe"

$4site = 'not yet';     // invalid; starts with a number
$_4site = 'not yet';    // valid; starts with an underscore
$t?yte = 'mansikka';    // valid; '?' is ASCII 228.
?>

PHP 3에서 변수는 항상 값에 의해 지정되야 한다(assinged by value). 변수를 표현식으로 지정할때에 원래 표현식의 모든 값이 목표 변수로 복사된다. 이 말의 의미는 예를 들면, 어떤 변수값을 다른 변수로 지정한 후에, 그 변수중 어떤 하나를 변경하는것이 다른 변수에 영향을 미치지 않는다는 의미를 갖는다. 이런 종류의 지정에 대해서 표현식을 참고.

PHP 4에서는 이와 다른 방법으로 변수에 값이 지정된다: 참조에 의한 지정. 이 용어의 의미는 새로운 변수가 원래 변수를 참조한다는 것이다.(즉, "원래 변수의 별명이 되는것" 이나 "가리키는 것") 새 변수의 변경은 원래 변수에 영향을 미치고, 그 반대도 가능하다. 이것은 복사가 수행되지 않는다는 것을 의미한다. 따라서, 지정은 매우 신속하게 이루어진다. 하지만, 속도향상은 견고한 루프나 거대한 배열이나 객체를 지정할때만 효과가 있을것이다.

참조에 의한 지정을 위해서는, 단순히 지정되는(소스 변수) 변수의 시작부분에 엠퍼센트(&)를 덧붙이면 된다. 예를 들면 다음 코드 예는 'My name is Bob'이 두번 출력된다.

<?php
$foo = 'Bob';              // Assign the value 'Bob' to $foo
$bar = &$foo;              // Reference $foo via $bar.
$bar = "My name is $bar";  // Alter $bar...
echo $bar;
echo $foo;                 // $foo is altered too.
?>

주의할 것은 오직 이름이 부여된 변수만이 참조에 의해 지정된다는 것이다.

<?php
$foo = 25;
$bar = &$foo;      // This is a valid assignment.
$bar = &(24 * 7);  // Invalid; references an unnamed expression.

function test()
{
   return 25;
}

$bar = &test();    // Invalid.
?>

이전 | 처음으로 | 다음
타입 저글링 | 위로 | 미리 선언된 변수


미리 선언된 변수

PHP는 실행되는 스크립트에 적용이되는 상당량의 미리 선언된 변수를 제공한다. 하지만, 이 변수의 대부분은 운영되는 서버, 서버의 버전, 서버의 설정, 다른 팩터와 관련되어 있어서 완벽하게 문서화되지 않았다. 이 중 몇개의 변수는 커맨드 라인에서 실행되는 PHP에서는 유효하지 않다. 예약된 미리 선언된 변수의 섹션을 참고.

주의

PHP 4.2.0 이후 버전부터, PHP 디렉티브 register_globals의 기본값은 off가 되었다. register_globals를 off로 놓으면, 전역 유효영역안의 미리 선언된 변수 집합들에 영향을 미친다. 예를 들면, DOCUMENT_ROOT값을 얻기 위해서는 $DOCUMENT_ROOT 대신에 $_SERVER['DOCUMENT_ROOT']를, http://www.example.com/test.php?id=3에서 $id 대신에 $_GET['id']를, $HOME 대신에 $_ENV['HOME']을 사용해야 한다.

이와 관련된 변경사항은 register_globals의 설정 엔트리를 읽거나, 전역 등록 사용하기에 관한 보안 챕터는 물론, 4.1.0과 4.2.0 Release Announcements도 참고하기 바란다.

superglobal arrays와 같은 가용한 PHP의 예약된 미리 선언된 변수를 사용하는 것을 추천한다.

4.1.0 버전 이후에, PHP는 웹서버, 환경, 유저 입력과 관련된 미리 선언된 배열 변수 집합을 추가적으로 제공한다. 이 새로운 배열은 자동적으로 전역화되기 때문에 더 특별해진다. 즉, 자동적으로 모든 유효영역안에서 적용이 가능하다. 이런 이유로, 이런 변수를 '자동전역변수' 또는 '슈퍼전역변수' 이라고 불리기도 한다. (PHP에서는 사용자-선언 슈퍼전역변수가 허용되지 않는다.) 슈퍼전역변수는 아래에 열거한다. 하지만, 이 변수 목록과 논의는 예약된 미리선언된 변수섹션을 참고한다. 또한 구버전의 미리선언된 변수($HTTP_*_VARS)가 아직도 존재한다는 것에 주의한다. PHP 5.0.0부터, 긴 형태의 PHP 예약 변수 배열을 register_long_arrays 지시어로 비활성화할 수 있습니다.

가변 변수: 슈퍼전역변수는 가변 변수로는 쓰일수 없다.

variables_order내의 특정 변수들이 설정되어있지 않으면, 적합한 PHP의 미리선언된 배열도 비워있게 된다.

PHP 슈퍼전역변수

$GLOBALS

스트립트의 전역 유효영역에서 쓸수있는 모든 변수에 대한 참조를 포함한다. 이 배열의 key는 전역 변수들의 이름이다. PHP 3 이래로 $GLOBALS가 존재해왔다.

$_SERVER

웹서버나, 현재 스크립트의 실행환경에 직접적으로 관련되어 설정되는 변수이다. 구버전의 $HTTP_SERVER_VARS 배열과 동일하다. (이 변수는 현재 유효하지만, 추천하지는 않는다)

$_GET

HTTP GET에 의해 스크립트로 제공되는 변수이다. 구버전의 $HTTP_GET_VARS 배열과 동일하다. (이 변수는 현재 유효하지만, 추천하지는 않는다)

$_POST

HTTP POST에 의해 스크립트로 제공되는 변수이다. 구버전의 $HTTP_POST_VARS 배열과 동일하다. (이 변수는 현재 유효하지만, 추천하지는 않는다)

$_COOKIE

HTTP 쿠키에 의해 스크립트로 제공되는 변수이다. 구버전의 $HTTP_COOKIE_VARS 배열과 동일하다. (이 변수는 현재 유효하지만, 추천하지는 않는다)

$_FILES

HTTP post 파일 업로드에 의해 스크립트로 제공되는 변수이다. 구버전의 $HTTP_POST_FILES 배열과 동일하다. (이 변수는 현재 유효하지만, 추천하지는 않는다). 더 자세한 정보는 POST 메소드 업로드를 참고하도록 한다.

$_ENV

환경에 의해 스크립트로 제공되는 변수이다. 구버전의 $HTTP_ENV_VARS 배열과 동일하다. (이 변수는 현재 유효하지만, 추천하지는 않는다)

$_REQUEST

GET, POST, COOKIE 입력 메카니즘을 통해 스크립트로 제공되는 변수이다. 이 메카니즘은 신용될수는 없다. 이 배열 안에 포함된 존재하는 변수와 변수의 나열 순서는 PHP variables_order 설정 디렉티브에 의해 정의된다. 이 배열은 PHP 4.1.0 이전 버전에서 동일한 변수가 존재하지 않는다. import_request_variables()도 참고.

경고

PHP 4.3.0이후, $_REQUEST 안에 FILE 정보를 갖는 $_FILES 변수가 존재하지 않게 되었다.

참고: 커맨드 라인에서 수행될때, 이 변수는 argv와 argc 엔트리에 포함되지 않는다; 이 변수들은 $_SERVER 배열에 존재한다.

$_SESSION

스크립트의 세션에 등록되는 변수이다. 구버전의 $HTTP_SESSION_VARS 배열과 동일하다. (이 변수는 현재 유효하지만, 추천하지는 않는다). 더 자세한 정보는 Session handling functions섹션을 참고.

이전 | 처음으로 | 다음
변수 | 위로 | 변수 유효영역


변수 유효영역

변수의 유효영역은 변수가 정의된 환경을 말한다. 대부분의 경우 모든 PHP 변수는 한군데의 유효영역만을 갖는다. 이 한군데의 유효영역은 include되거나 require된 파일로도 확장된다. 예를 들면:

<?php
$a = 1;
include "b.inc";
?>

위 예제코드에서는 include된 b.inc 스크립트안에서도 $a 변수가 사용가능하다. 하지만, 사용자-선언 함수에서는 로컬 함수 유효영역이 적용된다. 함수내에서 사용되는 모든 변수는 기본값으로 로컬 변수 유효영역 안으로 제한된다. 예를 들면:

<?php
$a = 1; /* global scope */

function Test()
{
    echo $a; /* reference to local scope variable */
}

Test();
?>

위 스크립트에서 echo문이 $a의 로컬 버전을 참조하고, 이 영역 안에서 값을 지정되지 않았기 때문에 아무것도 출력되지 않는다. C에서 전역변수는 특별히 로컬 선언으로 덮어쓰지 않는이상은 자동적으로 함수안에서 사용가능하다는 점에서 C 언어와 약간 차이가 있다는 것에 주의해야 할것이다. 이런 생각으로 부주의하게 전역변수를 변경하려한다면 문제가 될것이다. PHP에서 전역변수가 함수내에서 계속적으로 사용이 된다면 함수안에서 global로 선언해야 합니다.

global 키워드

우선, global의 사용 예제입니다:

예 7-1. global 사용하기

<?php
$a = 1;
$b = 2;

function Sum()
{
    global $a, $b;

    $b = $a + $b;
}

Sum();
echo $b;
?>

위 스크립느는 "3"를 출력할것이다. $a와 $b를 함수내에서 global로 선언함으로써, 각 변수에 대한 모든 참조는 전역 버전으로 참조될것이다. 함순에서 조작되는 전역변수의 수는 제한이 없다.

전역 유효영역의 변수에 접근할수 있는 두번째 방법이 특별 PHP-선언 $GLOBALS 배열을 사용하는 것이다. 이전 예제코드는 다음과 같이 다시 작성할 수 있습니다:

예 7-2. global 대신 $GLOBALS 사용하기

<?php
$a = 1;
$b = 2;

function Sum()
{
    $GLOBALS["b"] = $GLOBALS["a"] + $GLOBALS["b"];
}

Sum();
echo $b;
?>

$GLOBALS 배열은 전역변수명이 key가 되는 연관배열이고 배열의 요소 값이 그 변수의 내용이 된다. $GLOBALS이 어떻게 모든 유효영역에서 존재하는지 주의하라. 이유는 $GLOBALS이 슈퍼전역변수이기 때문이다. 아래에 슈퍼전역변수의 파워를 설명하는 예제코드를 보였다:

예 7-3. 자동 전역과 영역을 보여주는 예제

<?php
function test_global()
{
    // 대부분의 예약 변수는 "자동 전역"이 아니기에,
    // 함수 내부 영역에서 사용하려면 'global'이 필요합니다.
    global $HTTP_POST_VARS;

    echo $HTTP_POST_VARS['name'];

    // 자동 전역은 어떠한 영역에서도 사용할 수 있고,
    // 'global'이 필요하지 않습니다. 자동 전역은
    // PHP 4.1.0부터 사용할 수 있습니다.
    echo $_POST['name'];
}
?>

정적 변수 사용하기

변수 유효영역의 또 다른 중요한 기능이 static 변수이다. 정적(static) 변수는 로컬 함수 영역에서만 존재한다. 그러나 프로그램이 그 영역을 떠나지 않으면 그 값을 잃지 않는다. 다음 예제를 생각해 봅시다:

예 7-4. 정적 변수의 필요성을 보여주는 예제

<?php
function Test ()
{
    $a = 0;
    echo $a;
    $a++;
}
?>

이 함수는 매번 호출될때마다 $a를 0으로 설정하고 "0"를 출력한다. $a++ 는 변수를 증가시키지만 함수에서 빠져나가면 $a 변수는 사라지게되므로 아무 가치가 없다. 현재 카운트 값을 잃지 않는 유용한 카운트 함수를 만들려면, $a 변수를 static으로 선언한다.

예 7-5. 정적 변수의 사용 예제

<?php
function Test()
{
    static $a = 0;
    echo $a;
    $a++;
}
?>

이제 Test() 함수가 호출될 때마다 $a 값이 출력되고 그 값을 증가시킬것이다.

정적 변수는 또한 재귀함수를 다루는 한 방법을 제공한다. 재귀함수는 자기 자신을 호출하는 함수를 말한다. 재귀함수는 무한히 실행될수 있기 때문에 재귀함수를 작성할때는 주의가 필요하다. 재귀를 벗어나는 방법을 반드시 갖고 있어야 한다. 다음과 같은 단순 재귀함수는 10까지 카운트한다. 정적 변수 $count는 멈춰야 할 때는 안다.

예 7-6. 재귀 함수에서 정적 변수

<?php
function Test()
{
    static $count = 0;

    $count++;
    echo $count;
    if ($count < 10) {
        Test ();
    }
    $count--;
}
?>

참고: 정적 변수는 위 예제처럼 선언해야 합니다. 이 변수에 표현식의 결과를 할당하려 할 경우는 해석 오류를 발생합니다.

예 7-7. 정적 변수 선언하기

<?php
function foo() {
    static $int = 0;          // 적합
    static $int = 1+2;        // 오류 (표현식이기에)
    static $int = sqrt(121);  // 오류 (역시 표현식이기에)

    $int++;
    echo $int;
}
?>

전역 변수와 정적 변수의 참조

PHP 4를 작동하는 Zend Engine 1은 static과 global을 참조를 통한 변수 변경자로 구현합니다. 예를 들어, 실제 전역 변수를 global 키워드를 사용하여 함수 영역 내부로 가져올 경우, 그 전역 변수의 참조를 생성합니다. 이로 인해 다음 예제에서 처럼 원하지 않은 동작을 할 수 있습니다:

<?php
function test_global_ref() {
    global $obj;
    $obj = &new stdclass;
}

function test_global_noref() {
    global $obj;
    $obj = new stdclass;
}

test_global_ref();
var_dump($obj);
test_global_noref();
var_dump($obj);
?>

위 예제코드를 실행하면 다음과 같은 결과가 유도된다.

NULL
object(stdClass)(0) {
}

이와 비슷한 동작이 static 절에서도 발생한다. 참조가 정적으로 저장되지 않는것이다:

<?php
function &get_instance_ref() {
    static $obj;

    echo "Static object: ";
    var_dump($obj);
    if (!isset($obj)) {
        // Assign a reference to the static variable
        $obj = &new stdclass;
    }
    $obj->property++;
    return $obj;
}

function &get_instance_noref() {
    static $obj;

    echo "Static object: ";
    var_dump($obj);
    if (!isset($obj)) {
        // Assign the object to the static variable
        $obj = new stdclass;
    }
    $obj->property++;
    return $obj;
}

$obj1 = get_instance_ref();
$still_obj1 = get_instance_ref();
echo "\n";
$obj2 = get_instance_noref();
$still_obj2 = get_instance_noref();
?>

위 예제코드를 실행하면 다음과 같은 결과가 유도된다.

Static object: NULL
Static object: NULL

Static object: NULL
Static object: object(stdClass)(1) {
  ["property"]=>
  int(1)
}

위 예제 코드는 정적 변수에 대한 참조를 지정할때, &get_instance_ref()함수가 두번째로 호출되는 때에 기억되지 않는다는 것을 보여준다.

이전 | 처음으로 | 다음
미리 선언된 변수 | 위로 | 가변 변수


가변 변수

때때로 가변 변수명을 갖을수 있는것다는 것은 편리함을 준다. 즉, 변수명이 유동적으로 설정되거나 사용될수 있다. 일반적인 변수는 다음과 같은 구문에 의해 설정된다:

<?php
$a = "hello";
?>

가변변수는 변수값을 취해서 변수명으로 취급한다. 위 예제코드는, hello를 두개의 달러사인을 사용하여 변수명으로 사용할수 있다.

<?php
$$a = "world";
?>

이 지점에서 두 변수가 선언되었고 PHP 심볼 트리에 저장된다: $a는 "hello" 값을 갖고 $hello는 "world" 값을 갖게 된다. 따라서, 이 구문:

<?php
echo "$a ${$a}";
?>

다음과 완전히 똑같이 출력된다:

<?php
echo "$a $hello";
?>

즉, 둘다 hello world를 출력한다.

배열을 갖는 가변변수를 사용하기 위해서는 애매한 문제를 해결해야 한다. 즉 $$a[1]를 쓴다면 해석기는 $a[1]가 변수를 의미하는지 알수 있어야 한다. 또는 $$a가 변수이기를 바라고, [1]가 그 변수의 인덱스인지 알수 있어야 한다. 이런 애매한 문제를 해결하기 위한 문법: 첫번째 목적을 위해 ${$a[1]}과 두번째 목적을 위해 ${$a}[1]을 들수 있다.

주의

가변 변수가 PHP의 슈퍼전역 배열로 사용될수 없음을 주의해야 한다. ${$_GET}와 같은 변수를 사용할수 없음을 의미한다. 슈퍼전역변수의 유효성과 구버전의 HTTP_*_VARS를 제어하는 방법을 원한다면, 그 변수들을 참조하려 할것이다.

이전 | 처음으로 | 다음
변수 유효영역 | 위로 | PHP 외부 출신의 변수들


PHP 외부 출신의 변수들

HTML 폼 (GET과 POST)

폼이 PHP 스크립트로 전달될때, 그 폼안의 정보가 스크립트내에서 자동적으로 유효해진다. 이 정보에 접근할 수 있는 많은 방법이 제공된다. 예를 들면:

예 7-8. 단순한 HTML 폼

<form action="foo.php" method="post">
    이름:  <input type="text" name="username" /><br />
    메일: <input type="text" name="email" /><br />
    <input type="submit" name="submit" value="전송합니다!" />
</form>

특별한 설정과 개인적인 선호에 의해, HTML 폼으로부터 데이터를 접근할수 있는 많은 방법이 존재한다. 몇가지르 예를 들면:

예 7-9. 단순한 POST HTML 폼으로 부터 데이터에 접근하기

<?php
// PHP 4.1.0부터 사용 가능

   echo $_POST['username'];
   echo $_REQUEST['username'];

   import_request_variables('p', 'p_');
   echo $p_username;

// PHP 3부터 사용 가능. PHP 5.0.0부터, 이러한 긴 예약 변수는
// register_long_arrays 지시어로 비활성화 할 수 있습니다.

   echo $HTTP_POST_VARS['username'];

// PHP 지시어 register_globals = on 일 경우에 사용할 수 있습니다.
// PHP 4.2.0부터 기본값은 register_globals = off 입니다.
// 이 방법을 사용하는 것은 권장되지 않습니다.

   echo $username;
?>

GET 폼을 사용하는 것은 적절한 GET 기선언 변수를 대신 사용할때를 제외하면 동일하다. GET은 QUERY_STRING (URL에서 '?'이후의 값)에도 적용이 된다. 따라서, 예를 들면 http://www.example.com/test.php?id=3는 $_GET['id']으로 접근할수 있는 GET 데이터를 포함한다. 또한 $_REQUEST와 import_request_variables()를 참고.

참고: $_POST 와 $_GET 같은 슈퍼전역 배열은 PHP 4.1.0 이후버전부터 사용되기 시작했다.

전에 설명한대로, PHP 4.2.0 이전에는 register_globals의 기본값이 on이었고, PHP 3에서는 항상 on이었다. PHP 커뮤니티는 그 디렉티브 값이 off가 되어있다고 가정하고 적절하게 코딩하는 것을 추천하기 때문에 이 디렉티브값에 연연할 필요가 없다.

참고: magic_quotes_gpc 설정 디렉티브는 Get, Post, Cookie 값에 영향을 준다. 이 값이 켜져있으면, 그 값(It's "PHP!")은 자동적으로 (It\'s \"PHP!\")이 될것이다. 이 회피는 DB 입력을 위해 필요하다. 또한 addslashes(), stripslashes()과 magic_quotes_sybase를 참고한다.

PHP는 폼 변수가 쓰이는 환경안의 배열도 이해한다. (관련 faq를 참고) 예를 들면, 관련 변수를 함께 그룹화하거나, 다중 select 입력으로부터 값을 끄집어내기위해 이 기능을 사용할수 있다. 예로써, 자신에게 폼을 post하고 그 데이터를 출력해보자:

예 7-10. 좀더 복잡해진 폼 변수들

<?php
if (isset($_POST['action']) && $_POST['action'] == 'submitted') {
    echo '<pre>';
    print_r($_POST);
    echo '<a href="'. $_SERVER['PHP_SELF'] .'">다시 시도하십시오.</a>';

    echo '</pre>';
} else {
?>
<form action="<?php echo $_SERVER['PHP_SELF']; ?>" method="post">
    이름: <input type="text" name="personal[name]" /><br />
    메일: <input type="text" name="personal[email]" /><br />
    맥주: <br />
    <select multiple name="beer[]">
        <option value="warthog">Warthog</option>
        <option value="guinness">Guinness</option>
        <option value="stuttgarter">Stuttgarter Schwabenbr?u</option>
    </select><br />
    <input type="hidden" name="action" value="submitted" />
    <input type="submit" name="submit" value="전송합니다!" />
</form>
<?php
}
?>

PHP 3에서, 배열 폼 변수의 사용은 1차원 배열로만 제한된다. PHP 4에서는 이런 제약이 적용되지 않는다.

변수명으로 IMAGE SUBMIT

form을 전달할때, 표준적인 submit 버튼 태그 대신 다음과 같이 image 태그를 사용할수 있다.

<input type="image" src="image.gif" name="sub" />

유저가 image의 어느곳에서 클릭하더라도 수행 폼은 두가지 추가적인 변수를 서버로 전송할것이다. sub_x와 sub_y. 이 변수는 image안에서 유저가 클릭하는 좌표를 갖는다. 실제로 브라우저에 의해 보내지는 변수명은 밑줄(_)이 아니라 마침표(.)를 포함한다. 그러나 PHP는 자동으로 마침표를 밑줄로 변환한다.

HTTP 쿠키

PHP는 Netscape's Spec에 의해 정의된 HTTP 쿠키를 투명하게 지원한다. 쿠키는 원격 브라우저안에 데이터를 저장하는 메카니즘이고 따라서 복귀하는 유저를 추적하거나 식별하게 해준다. setcookie() 함수를 사용하여 쿠키를 설정할수 있다. 쿠키는 HTTP 헤더의 일부분이고, 그래서 SetCookie함수는 브라우저에 출력이 생기기전에 호출되어야 한다. 이 제약은 header() 함수에도 같이 적용된다. 쿠키 데이터는 적절한 쿠키 데이터 배열에 존재하게 된다. $_COOKIE, $HTTP_COOKIE_VARS는 물론 $_REQUEST 배열에 존재한다. 더 자세한 정보와 예제를 보기 위해 setcookie() 매뉴얼 페이지를 참고.

단일 쿠키 변수에 여러값을 지정하려한다면, 배열로 그 값을 지정할수 있다. 예를 들면:

<?php
  setcookie("MyCookie[foo]", "Testing 1", time()+3600);
  setcookie("MyCookie[bar]", "Testing 2", time()+3600);
?>

위 예제코드는 MyCookie가 스크립트내에서 단일 배열이 될지라도 두개의 분리된 쿠키를 생성할수 있다. 여러값을 갖는 단일 쿠키를 설정하려면, 첫번째로 그 값에 serialize()나 explode()를 사용할것을 고려하도록 한다.

쿠키는 경로나 도메인이 다르지 않으면 브라우저안에서 같은 이름을 갖는 이전 쿠키를 교체한다는 것에 주의해야 한다. 따라서, 쇼핑 카트 애플리케이션을 위해서는 카운터를 유지하고 이 카운터를 전달하기를 원할것이다.

예 7-11. setcookie()예제 코드

<?php
if (isset($_COOKIE['count'])) {
    $count = $_COOKIE['count'] + 1;
} else {
    $count++;
}
setcookie("count", $count, time()+3600);
setcookie("Cart[$count]", $item, time()+3600);
?>

유입되는 변수명에 존재하는 점(dot)

표준적으로, PHP는 스크립트내로 변수를 전달할때 변수명을 변경하지 않는다. 하지만, 점(마침표, full stop)은 PHP 변수명안에서 유효한 문자가 될수 없다는것에 주의해야 할것이다. 이에 유의하여 다음 코드를 보자:
<?php
$varname.ext;  /* invalid variable name */
?>
현재, 해석기가 보게되는 것은 $varname이라는 변수와 그 뒤에 문자열 결합 연산자, 그 뒤에 벌거벗은 문자열(barestring) 'ext'이다. (즉, 따옴표로 둘러싸지 않은 문자열은 key나 예약된 단어와 일치하지 않음) 확실하게 이 결과는 원치 않은것이다.

이러한 이유로, PHP는 유입되는 변수명안의 점(.)을 밑줄(_)로 변경한다는것을 명심해야 한다.

변수 타입 결정하기

PHP는 변수 타입을 결정하고 변수를(보통) 필요한 타입으로 변환하기 때문에, 어느 시간에 변수가 무슨 타입인지 알수가 없다. PHP는 변수가 무슨 타입인지 확인할수 있는 몇가지 함수를 제공한다. 그 함수들은 다음과 같다: gettype(), is_array(), is_float(), is_int(), is_object(), is_string(). 타입 챕터를 참고.

이전 | 처음으로 | 다음
가변 변수 | 위로 | 상수


상수

PHP 매뉴얼
이전 다음

8. 장. 상수

차례
문법
미리 정의된 상수

상수는 단순한 값을 위한 식별자(이름)이다. 이름이 제시하는것과 같이, 이 값은 스크립트 실행중에는 변경될수 없다. (실질적으로 상수가 아닌 magic constants 을 제외하고) 상수는 기본적으로 대소문자를 구별한다. 관례상, 상수 식별자는 항상 대문자이다.

PHP에서 상수명은 같은 규칙을 따른다. 유효한 상수명은 문자나 밑줄(underscore) 로 시작하고 다른 문자나 숫자, 밑줄이 뒤를 따른다. 정규식으로는 다음처럼 표현할수 있다: [a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*

참고: 여기서 문자는 a-z, A-Z와 아스키(ASCII)문자 127에서 255까지이다 (0x7f-0xff).

superglobals처럼 상수의 유효범위(scope)는 전역적이다. 유효범위에 상관없이 스크립트의 어느곳에서도 상수를 참조할수 있다. 상수에 관한 더 자세한 정보를 위해 변수 유효범위(variable scope) 매뉴얼 섹션을 참고합니다.

문법

define()함수를 써서 상수를 정의(define)할수 있다. 상수는 한번 정의되면 절대 변경하거나 해제(undefine)할수 없다.

스칼라 데이터(boolean, integer, float 과 string)만 상수의 값으로 쓸수있다.

단순히 상수명을 써서 상수값을 얻을 수 있다. 변수와는 달리 $가 상수명 앞으로 오면 안된다 동적으로 상수명을 취하려한다면 constant()함수로 상수값을 가져올수 있다. 정의된 모든 상수 목록을 구하려면 get_defined_constants() 함수를 쓴다.

참고: 상수와 (전역)변수는 서로 다른 네임스페이스(namespace)상에 있다. 이말의 의미는 예를 들면 TRUE와 $TRUE은 일반적으로 다르다는것이다.

해제된 상수를 사용한다면, PHP는 상수명 자체를 쓴것이라고 가정할것이다 즉,string으로 인식할것이다. (CONSTANT vs "CONSTANT") E_NOTICE로 이런 일이 발생했는지 알수 있다. 왜 $foo[bar]가 잘못됐는지 (bar를 상수로 define() 하지않았다면) 매뉴얼을 참고한다. 단순히 상수가 설정되었는지만 확인하려 한다면 defined()함수를 쓰면 됩니다.

다음은 상수와 변수의 차이점이다:

  • 상수는 이름 앞에 달러표시($)가 없다.

  • 상수는 단순 지정(assingment)이 아니라 define() 함수로만 정의될수 있다.

  • 상수는 변수의 유효범위 규칙과는 상관없이 어느곳에서든 정의되거나 값을 취할수 있다.

  • 상수는 한번 설정되면 재정의하거나 해제할수 없을것이다; 그리고

  • 상수는 스칼라 값만 쓸수 있다.

예 8-1. 상수 정의하기

<?php
define("CONSTANT", "Hello world.");
echo CONSTANT; // "Hello world."을 출력한다
echo Constant; // "Constant"를 출력하고 경고가 뜬다.
?>

이전 | 처음으로 | 다음
PHP 외부 출신의 변수들 | 위로 | 미리 정의된 상수


미리 정의된 상수

PHP는 어떤스크립트에서도 유효한 많은 수의 미리 정의된 상수를 제공한다. 하지만 이 상수의 대부분은 다양한 확장(extension)에 의해 생성된다. 그래서 그 확장이 같이 컴파일되어 유효하거나 동적인 로딩이 되어있어야 이런 상수가 존재하게 된다.

네가지 마법 상수(magical constant)가 존재한다. 이 상수들은 어디에서 쓰느냐에 따라 용도가 변경된다. 예를 들면, __LINE__상수의 값은 스크립트의 해당 줄과 관련이 있다. 이 특별한 상수들은 대소문자 구별이 없고 다음과 같다:

표 8-1. 약간의 "마법" PHP 상수

이름 | 설명
__LINE__ | 파일의 현재 줄 번호
__FILE__ | 파일의 전체경로와 파일명
__FUNCTION__ | 함수 이름 (PHP 4.3.0에서 추가됨)
__CLASS__ | 클래스 이름 (PHP 4.3.0에서 추가됨)
__METHOD__ | 클래스 메소드 이름 (PHP 5.0.0에서 추가됨)

미리 정의된 상수 목록은 예약된 미리 정의된 상수 섹션에서 볼 수 있다.

이전 | 처음으로 | 다음
상수 | 위로 | 표현식


표현식

PHP 매뉴얼
이전 다음

9. 장. 표현식

표현식은 PHP에서 가장 중요한 구성요소다. PHP에서 쓰는 거의 대부분이 표현식이다. 표현식을 정의한 가장 단순하고 가장 정확한 말은 "모든것이 값을 갖는다"는 것이다.

표현식의 가장 기본적인 형태가 상수와 변수이다. "$a = 5"라고 쓰면, $a에 '5'를 지정하는것이다.'5'는 확실히 5란 값을 갖는다. 다르게 표현하면 '5'는 5란 값을 갖는 표현식이 된다 (이경우에, '5'는 정수형 상수이다)

이렇게 지정하고 나면 $a의 값은 5가 될것이란 것도 기대할수 있을것이다. 그래서 $b = $a라고 쓴다면, $b = 5를 쓴것과 같이 동작할것이라고 기대할수 있을것이다. 다른말로, $a는 또한 5란 값을 갖는 표현식이다. 모든것이 제대로 작동한다면, 기대하던대로 될것이다.

표현식의 약간 더 복잡한 예가 함수이다. 다음 함수를 예로 들어보자.

<?php
function foo ()
{
    return 5;
}
?>

함수의 개념에 익숙하다면 (그렇지 않으면, 함수에 관한 장을 참고) $c = foo()로 쓰는것이 $c = 5와 같을것이라고 생각할것이다. 옳은 생각이다. 함수는 반환된 값을 갖는 표현식이다. foo()가 5를 반환하기때문에 'foo()'표현식의 값은 5가 된다. 함수는 대체로 정적인 값보다는 계산값을 반환한다.

물론, PHP에서 값은 정수가 되어야 하는것은 아니다. PHP에서는 3가지 스칼라 값 형을 지원한다: 정수값, 부동소수점값, 문자열값 (스칼라값은 배열같이 더작게 쪼갤수없는 값을 말한다). PHP는 두가지 조합형 (스칼라값이 아닌)을 지원한다: 배열과 객체. 이 두가지 값형은 변수나 함수에서 넘기는 값으로 지정될수 있다.

여기서 PHP/FI 2 사용자들은 달라진것이 없다는것을 알게되었을것이다. 하지만, PHP는 다른 언어들처럼 더 많은 표현식을 쓸수 있다. PHP는 거의 모든것이 표현식이라는 관점에 입각하면 표현식-지향 언어이다. 전술했던 예제 '$a = 5'를 보자. 이 식과 연관된 값은 '5'라는 정수상수 두개라는것과 $a는 5로 수정이 된다는 것을 알수 있다. 그러나 진실은 여기에 연관되어있는 것이 하나의 추가값이라는것이고, 이 추가된 값이 지정되어지는 값 자체라는 것이다. 지정 자체는 지정값 5만 적용된다. 실제로, '$a = 5'라는 식은 그것이 무엇을 하든 5라는 값을 갖는 표현식이라는 것이다. 따라서, '$b = ($a = 5)'라는 식은 '$a = 5; $b = 5'를 쓰는것과 같다 (세미콜른은 구문의 끝을 표시한다). 지정연산은 오른쪽에서 왼쪽방향으로 해석되므로 '$b = $a = 5'라고 쓸수 있다.

표현식-지향의 또다른 좋은 예는 전처리(pre)/후처리(post)되는 증가와 감소 연산이다. PHP/FI 2 사용자와 다른 언어사용자는 변수++과 변수--의 부호표시에 익숙할것이다. 이런 부호표시는 증가와 감소 연산자이다. PHP/FI 2에서 '$a++'문은 값을 갖지않는다 (즉, 표현식이 아니다), 그래서 어떤수단으로도 특정값을 지정하거나 사용할수 없다. PHP는 C처럼 이런 표현식을 사용할수 있어서 증가/감소 연산 능력을 확장시켰다. PHP는 C처럼 두가지 연산형이 존재한다 - 전처리-증가 와 후처리-증가. 전처리 증가와 후처리 증가 모두 변수를 증가시키고 변수에 적용시킨다. 차이점은 증가 표현식에 값이 있는지에 달려있다. 전처리-증가, 즉 '++$변수' 는 값을 증가시켜 적용시킨다 (PHP는 처음 값을 읽기 전에 값을 증가시킨다, 따라서 이름이 '전처리-증가'가 되는것이다) 후처리-연산, '$변수++'는 값을 증가시키기 전의 $변수의 처음값이 적용된다. (PHP는 그 값을 읽은 후에 그 값을 증가시킨다, 그래서 '후처리-증가'가 되는것이다)

표현식 중 가장 흔한 형태가 비교 연산 표현식이다. 이런 표현식은 0 이나 1 (각각 FALSE 나 TRUE)로 평가된다. PHP는 > (더크다), >= (크거나 같다), == (같다), != (같지 않다), < (더작다) and <= (작거나 같다)와 같은 연산자 를 지원한다. 이런 연산자는 if와 같은 조건절 수행시에 가장 많이 쓰인다.

이 장에서 취급할 제일 마지막 표현식의 예는 조합된 연산자-지정 표현식이다. $a를 1만큼 증가시키고자 한다면 단순히 '$a++'이나 '++$a'로 쓸수 있다는것을 이미 알고 있을것이다. 그러나 하나 이상의 값을 증가시키고자 한다면, 예를 들어 3을 증가시키고자 한다면 어떻게 해야 할까? '$a++'을 여러번 쓸수도 있다. 그러나 이런 식으로 쓰는것은 효과적이거나 편한 방법이 아니라는것을 쉽게 알수 있다. 좀더 평범하게 표현하면 '$a = $a + 3'이다. '$a + 3'은 $a에 3을 더한 값이 계산 되고 $a로 그 값이 지정된다. 그래서 $a에 3을 증가시킨 결과가 된다. PHP에서는 C와 같은 다른 언어처럼 더 짧은 형태로 쓸수있다. 그래서, 좀더 이해하기 쉽고 좀더 빨리 이해할수있다. $a의 현재 값에 3을 더하는 것은 '$a += 3'으로 쓸수 있다. 이 표현식의 의미는 정확히 '$a값을 취해 그 값에 3을 더하고 다시 $a에 계산된값을 지정하라'이다. 좀더 짧고 명확할 뿐만 아니라, 좀더 빠른 수행이 이루어진다. 일반적인 표현식의 값처럼 '$a += 3'의 값은 지정값이다. 3이 아니라, $a에 3을 더한 값이라는 것에 주의하라 (이값은 $a에 지정되는 값이다) 어떠한 두개연속의 연산자도 이런 연산자-지정 방식으로 사용될수 있다. 예를 들면, '$a -= 5' ($a의 값에서 5를 뺀것), '$b *= 7' ($b의 값에 7을 곱한것) 등등이 쓰일수 있다.

다른 언어에서 본적이 없다면 이상하게 보이는 표현식이 있다. 3중 조건적 연산자이다:

<?php
$first ? $second : $third
?>

first 에 속하는 표현식의 값이 TRUE (non-zero)이면 second 에 속하는 표현식이 적용되고, 이것이 조건적 표현식의 결과가 된다. 이 경우가 아니면, third 에 속하는 표현식이 적용되고, 그 값이 된다.

다음 예제 코드는 좀더 일반적으로 사용된 전처리/후처리-증가와 표현식을 이해하는데 도움이 될것이다.

<?php
function double($i)
{
    return $i*2;
}
$b = $a = 5;        /* $a와 $b에 5라는 값을 지정함 */
$c = $a++;          /* 후처리-증가, $a 의 원래값을 적용함
                       $c는 (5)가 됨 */
$e = $d = ++$b;     /* 전처리-증가, $b가 증가된 값이 적용됨
                       $d와 $e는 (6)이 됨 */

/* 여기서, $d와 $e는 6과 같다 */

$f = double($d++);  /* 증가되기 전의 $d값의 두배가 적용됨
                       $f는  2*6 = 12가 됨 */
$g = double(++$e);  /* 증가된 후의 $e값의 두배가 적용됨
                       $g는  2*7 = 14가 됨 */
$h = $g += 10;      /* 우선, $g는 10만큼 증가되어 24가 됨.
                       지정된 값 (24)가 $h로 지정된다.
                       $h도 24값으로 지정된다 */
?>

이 장의 시작부분에서 다양한 구문형들을 설명할것이라고 했다. 약속대로, 표현식은 구문이 될수 있다. 그러나 모든 표현식이 구문이 될수는 없다. 이런 경우는 구문이 'expr' ';'의 형태를 갖는다. 즉, 세미콜른이 표현식 뒤에 온다. '$b=$a=5;'에서 $a=5는 유효한 표현식이다. 그러나 그자체가 구문이 되지는 않는다. 하지만, '$b=$a=5;'는 유효한 구문이다

마지막으로 언급할 만큼 가치있는것이 표현식의 진리값이다. 많은 사건중, 주로 조건적 수행과 루프에서, 표현식의 특정 값에 흥미있지는 않을것이다. 그러나 그 값이 TRUE인지 FALSE인지는 중요하다. 상수 TRUE와 FALSE (대소문자를 구별하지 않음)는 두가지 논리값이다. 필요하면, 표현식은 자동적으로 논리값으로 변환된다. 더자세한 정보는 형-캐스트 섹션을 참고할것.

PHP는 표현식의 완벽하고도 강력한 구현방법을 제공한다. 그런 방법을 완전히 문서화하는 것은 이 매뉴얼의 범위를 넘는다. 위 예제 코드들은 표현식이 무엇인지에 대한것과 유용한 표현식을 구축할수 있는 방법에 대한 아이디어를 줄것이다. 이후 매뉴얼에서는 유효한 PHP 표현식을 expr라고 쓰겠다.

이전 | 처음으로 | 다음
미리 정의된 상수 | 위로 | 연산자


연산자

PHP 매뉴얼
이전 다음

10. 장. 연산자

차례
연산자 우선순위
산술 연산자
지정 연산자
비트 연산자
비교 연산자
에러 제어 연산자
실행 연산자
증가/감소 연산자
논리 연산자
문자열 연산자
배열 연산자

연산자 우선순위

연산자 우선순위는 두개의 표현식을 연산자로 얼마나 더 단단하게 연결할 것인지를 명시한다 . 예를 들면, 1 + 5 * 3의 결과는 18이 아니라 16이 된다. 왜냐하면 곱셈 ("*") 연산자가 덧셈 ("+") 연산자보다 우선순위가 높기 때문이다. 필요한 경우, 괄호를 사용해서 우선순위를 높일수 있다. 예를 들면, (1 + 5) * 3의 결과는 18이 된다.

다음 테이블은 낮은 우선순위를 갖는 연산자부터 연산자 우선순위 목록을 보였다.

표 10-1. 연산자 우선순위

Associativity | Operators
left | ,
left | or
left | xor
left | and
right | print
right | = += -= *= /= .= %= &= |= ^= <<= >>=
left | ? :
left | ||
left | &&
left | |
left | ^
left | &
non-associative | == != === !==
non-associative | < <= > >=
left | << >>
left | + - .
left | * / %
right | ! ~ ++ -- (int) (float) (string) (array) (object) @
right | [
non-associative | new

참고: !이 =보다 높은 우선 순위를 갖지만, PHP는 여전히 다음과 같은 표현식을 허용한다: if (!$a = foo()) 즉, $a에 입력되는 foo()의 결과에 대한 조건문

이전 | 처음으로 | 다음
표현식 | 위로 | 산술 연산자


산술 연산자

학교에서 배운 기본적인 산수를 기억는가? 이 연산자들은 그런 연산자 와 똑같이 동작한다.

표 10-2. 산술 연산자

예 | 이름 | 결과
$a + $b | 덧셈 | $a와 $b의 합
$a - $b | 뺄셈 | $a와 $b의 차
$a * $b | 곱셈 | $a와 $b의 곱
$a / $b | 나눗셈 | $a를 $b로 나눈 몫
$a % $b | 나머지 | $a를 $b로 나눈 나머지

두 피연산자가 정수(또는 정수로 변환되는 문자열)일지라도 나눗셈 연산자 ("/")는 부동소수점 값을 돌려준다.

수학 함수의 매뉴얼 페이지를 참고.

이전 | 처음으로 | 다음
연산자 | 위로 | 지정 연산자


지정 연산자

기본적인 지정 연산자는 "="이다. 이 연산자를 "같다"라고 생각할수 있느나, 그렇지 않다. 이 연산자는 좌측 피연산자에 우측의 표현식 값을 지정한다. (즉, "지정한다").

지정 표현식의 값이 지정된다. 즉, "$a = 3"의 값은 3이다. 이런 규칙으로 인해 몇가지의 교묘한(tricky) 일을 할수 있다.

$a = ($b = 4) + 5; // $a is equal to 9 now, and $b has been set to 4.

기본적인 지정 연산자 외에 이진 산술과 문자열 연산자와 같은 "복합 연산자" 가 지원된다. 이런 연산자는 표현식의 값을 사용하여 그 표현식의 결과를 그 값으로 사용할수 있다. 예를 들면:

$a = 3;
$a += 5; // sets $a to 8, as if we had said: $a = $a + 5;
$b = "Hello ";
$b .= "There!"; // sets $b to "Hello There!", just like $b = $b . "There!";

지정은 원래 변수에 새로운 변수(값으로 지정된)를 복사한다. 그래서 어떤 변수를 변경하는것은 다른 변수에 아무 영향을 주지 못한다. 견고한 루프안에 큰 배열같은 것을 복사한다면 이 주제와 밀접한 관련이 있다. PHP 4는 $var = &$othervar;같은 문법으로 참조에 의한 지정을 지원한다. 그러나 PHP 3에서는 지원되지 않는다. '참조에 의한 지정'은 두 변수가 같은 데이터를 가리키도록 하고 아무것도 복사하지 않는다는 것을 의미한다. 참조에 관한 자세한 정보는 참조 표현을 참고.

이전 | 처음으로 | 다음
산술 연산자 | 위로 | 비트 연산자


비트 연산자

비트 연산자는 특정 비트를 정수로 on이나 off로 전환하도록 한다. 좌측과 우측 인자가 문자열이면, 비트 연산자는 이 문자열안의 문자에 대해 계산하게 된다.

<?php
    echo 12 ^ 9; // Outputs '5'

    echo "12" ^ "9"; // Outputs the Backspace character (ascii 8)
                     // ('1' (ascii 49)) ^ ('9' (ascii 57)) = #8

    echo "hallo" ^ "hello"; // Outputs the ascii values #0 #4 #0 #0 #0
                            // 'a' ^ 'e' = #4
?>

표 10-3. 비트 연산자

Example | Name | Result
$a & $b | And | Bits that are set in both $a and $b are set.
$a | $b | Or | Bits that are set in either $a or $b are set.
$a ^ $b | Xor | Bits that are set in $a or $b but not both are set.
~ $a | Not | Bits that are set in $a are not set, and vice versa.
$a << $b | Shift left | Shift the bits of $a $b steps to the left (each step means "multiply by two")
$a >> $b | Shift right | Shift the bits of $a $b steps to the right (each step means "divide by two")

이전 | 처음으로 | 다음
지정 연산자 | 위로 | 비교 연산자


비교 연산자

비교 연산자는 그 이름에서 알수 있듯이, 두 값을 비교한다. 또 타입 비교 테이블을 보고, 다양한 타입을 비교하는 예제 코드를 볼수 있다.

표 10-4. 비교 연산자

Example | Name | Result
$a == $b | Equal | TRUE if $a is equal to $b.
$a === $b | Identical | TRUE $a와 $b가 같으려면, 둘 모두 같은 타입이어야 함 (PHP 4에서만)
$a != $b | Not equal | TRUE if $a is not equal to $b.
$a <> $b | Not equal | TRUE if $a is not equal to $b.
$a !== $b | Not identical | TRUE $a가 $b와 같지 않다면, 둘 모두 같은 타입이 아니다 (PHP 4에서만)
$a < $b | Less than | TRUE if $a is strictly less than $b.
$a > $b | Greater than | TRUE if $a is strictly greater than $b.
$a <= $b | Less than or equal to | TRUE if $a is less than or equal to $b.
$a >= $b | Greater than or equal to | TRUE if $a is greater than or equal to $b.

다른 조건 연산자에는 C나 다른 많은 언어와 같은 동작을 하는 "?:" (삼중) 연산자가 있다.

<?php
// Example usage for: Ternary Operator
$action = (empty($_POST['action'])) ? 'default' : $_POST['action'];

// The above is identical to this if/else statement
if (empty($_POST['action'])) {
    $action = 'default';
} else {
    $action = $_POST['action'];
}
?>

(expr1) ? (expr2) : (expr3)표현식은 expr1가 TRUE이면 expr2이 적용되고, expr1가 FALSE이면 expr3으로 적용된다.

strcasecmp(), strcmp()과 타입에 관한 매뉴얼 섹션을 참고

이전 | 처음으로 | 다음
비트 연산자 | 위로 | 에러 제어 연산자


에러 제어 연산자

PHP는 에러 제어 연산자를 지원한다: 앳 부호 (@). PHP에서 표현식의 앞에 덧붙이면, 그 표현식에서 발생할수 있는 에러 메시지가 출력되지 않도록 한다. track_errors 기능은 활성화되어있으면, 표현식에서 발생하는 모든 에러는 $php_errormsg변수에 저장될것이다. 이 변수는 에러가 발생할 때마다 덮어씌어질것이고, 그래서 이 변수를 사용하려면 바로바로 확인해야 한다.

<?php
/* Intentional file error */
$my_file = @file ('non_existent_file') or
    die ("Failed opening file: error was '$php_errormsg'");

// this works for any expression, not just functions:
$value = @$cache[$key];
// will not issue a notice if the index $key doesn't exist.

?>

참고: @-연산자는 표현식에서만 동작한다. 단순한 규칙: 표현식의 값을 취할수 있으면, 그 표현식 앞에 @ 연산자를 덧붙일수 있다. 예를 들면, 변수, 함수, include()호출, 상수 등의 앞에 덧붙일수 있다. 그러나 함수나 클래스 선언부, if같은 조건문, foreach 등에 이 부호를 덧붙일수는 없다.

error_reporting()함수와 Error Handling and Logging functions에 관한 매뉴얼 섹션을 참고.

참고: "@" 에러-제어 연산자는 해석 에러로 인한 에러 메시지를 가릴수는 없을것이다.

주의

현재 "@" 에러-제어 연산자는 스크립트 수행을 멈출수 있는 심각한 에러에 대한 에러 메시지들도 보이지 않게 할것이다. 이말의 의미는 어떤 함수에서 에러 메시지를 보이지 않게 하려하려고 "@"을 사용했고 그 함수가 가용하지 않거나 오타를 쓴것일지라도 이 스크립트는 에러 원인에 대한 메시지 없이 그자리에서 즉시 멈추게 될것이다.

이전 | 처음으로 | 다음
비교 연산자 | 위로 | 실행 연산자


실행 연산자

PHP는 실행 연산자를 지원한다 (``). 이 연산자는 작은 따옴표가 아니라는 것에 주의하라! PHP는 백틱(``)안에 묶인 내용을 셀 명령으로서 실행하려 할 것이다; 출력이 돌려질것이다 (출력을 단순히 덤프하려 하지 않는다; 출력을 변수로 지정할 수 있다) 백틱 연산자는 shell_exec() 함수를 쓰는것과 동일한다.

$output = `ls -al`;
echo "<pre>$output</pre>";

참고: 안전 모드가 활성화되었거나 shell_exec()가 비활성화되어 있을때는 백틱 연산자는 비활성화된다.

Program Execution functions, popen() proc_open(), Using PHP from the commandline에 관한 매뉴얼 섹션을 참고

이전 | 처음으로 | 다음
에러 제어 연산자 | 위로 | 증가/감소 연산자


증가/감소 연산자

PHP는 C-스타일의 전처리와 후처리 증가/감소 연산자를 지원한다.

표 10-5. 증가/감소 연산자

Example | Name | Effect
++$a | Pre-increment | Increments $a by one, then returns $a.
$a++ | Post-increment | Returns $a, then increments $a by one.
--$a | Pre-decrement | Decrements $a by one, then returns $a.
$a-- | Post-decrement | Returns $a, then decrements $a by one.

단순한 예제 스크립트:

<?php
echo "<h3>Postincrement</h3>";
$a = 5;
echo "Should be 5: " . $a++ . "<br />\n";
echo "Should be 6: " . $a . "<br />\n";

echo "<h3>Preincrement</h3>";
$a = 5;
echo "Should be 6: " . ++$a . "<br />\n";
echo "Should be 6: " . $a . "<br />\n";

echo "<h3>Postdecrement</h3>";
$a = 5;
echo "Should be 5: " . $a-- . "<br />\n";
echo "Should be 4: " . $a . "<br />\n";

echo "<h3>Predecrement</h3>";
$a = 5;
echo "Should be 4: " . --$a . "<br />\n";
echo "Should be 4: " . $a . "<br />\n";
?>

PHP는 문자 변수에 관한 산술 연산을 할때 C 방식이 아니라 펄 방식을 따른다. 예를 들면, 펄에서 'Z'+1은 'AA'를 전환되는 반면, C에서 'Z'+1은 '[' ( ord('Z') == 90, ord('[') == 91 )으로 전환된다. 문자 변수는 증가될수는 있으나 감소될수는 없다는 것에 주의해야 한다.

예 10-1. 문자 변수에 대한 산술 연산

<?php
$i = 'W';
for($n=0; $n<6; $n++)
  echo ++$i . "\n";

/*
  Produces the output similar to the following:

X
Y
Z
AA
AB
AC

*/
?>

이전 | 처음으로 | 다음
실행 연산자 | 위로 | 논리 연산자


논리 연산자

표 10-6. 논리 연산자

Example | Name | Result
$a and $b | And | TRUE if both $a and $b are TRUE.
$a or $b | Or | TRUE if either $a or $b is TRUE.
$a xor $b | Xor | TRUE if either $a or $b is TRUE, but not both.
! $a | Not | TRUE if $a is not TRUE.
$a && $b | And | TRUE if both $a and $b are TRUE.
$a || $b | Or | TRUE if either $a or $b is TRUE.

두개의 다른 "and"와 "or" 연산자를 쓰는 이유는 그들이 다른 우선순위를 가지고 있기 때문이다. (연산자 우선순위를 참고)

이전 | 처음으로 | 다음
증가/감소 연산자 | 위로 | 문자열 연산자


문자열 연산자

두개의 문자열 연산자가 지원된다. 첫번째것은 결합연산자 ('.')이고 좌측과 우측의 피연산자를 결합한 값을 돌려준다. 두번째것은 결합 지정 연산자('.=')이다. 이런 연산자는 좌측 인자로 우측 인자를 추가한다. 자세한 정보는 지정 연산자를 참고

$a = "Hello ";
$b = $a . "World!"; // now $b contains "Hello World!"

$a = "Hello ";
$a .= "World!";     // now $a contains "Hello World!"

String type, String functions에 관한 매뉴얼 섹션을 참고

이전 | 처음으로 | 다음
논리 연산자 | 위로 | 배열 연산자


배열 연산자

PHP에서 배열 연산자는 +연산자만 지원된다. 이 연산자는 좌측 배열에 우측 배열을 추가한다. 그리고 중복된 키는 덮어 씌어지지 않는다.

$a = array("a" => "apple", "b" => "banana");
$b = array("a" =>"pear", "b" => "strawberry", "c" => "cherry");

$c = $a + $b;

var_dump($c);

위 스크립트가 수행되면, 다음과 같이 출력될것이다:
array(3) {
  ["a"]=>
  string(5) "apple"
  ["b"]=>
  string(6) "banana"
  ["c"]=>
  string(6) "cherry"
}

Array type과 Array functions 매뉴얼 섹션을 참고

이전 | 처음으로 | 다음
문자열 연산자 | 위로 | 제어 구조


제어 구조

PHP 매뉴얼
이전 다음

11. 장. 제어 구조

차례
if
else
elseif
제어 구조의 대체 문법
while
do..while
for
foreach
break
continue
switch
declare
return
require()
include()
require_once()
include_once()

모든 PHP 스크립트는 연속적인 구문으로 이루어진다. 하나의 구문은 지정문 이 될수도 있고, 함수 호출, 반복문, 조건문이 될수 있으며 심지어는 아무 내용이 없는 빈 문장일수도 있다. 한 구문은 보통 세미콜른(;)으로 끝난다. 또한 여러개의 구문을 중괄호({,})를 사용하여 하나의 그룹으로 만들어 사용할 수도 있다. 이 구문 그룹은 그 그룹의 모든 구문들이 하나의 구문인 것처럼 인식된다. 이 장에서는 여러 가지 구문형태에 대해 알아본다.

if

if문은 PHP를 포함해서 모든 언어에 있어서 가장 중요한 기능(feature) 중 하나이다. 이 제어문으로 각각 다른 코드에 대해 조건적인 수행을 가능케한다. if문의 기능은 C와 비슷하다:

if (expr)
    statement

표현식에 관한 섹션에서 설명된것처럼 expr은 논리(Boolean)값으로 취급된다. expr이 TRUE와 같다면 PHP는 statement를 수행할것이고, FALSE라면 무시될것이다. 무슨값이 FALSE인지 알려면 '논리값으로 변환하기' 섹션을 참고한다.

다음 예는 $a가 $b보다 크다면 a는 b보다 크다를 출력할 것이다.

<?php
if ($a > $b)
    echo "a는 b보다 크다";
?>

종종 하나 이상의 구문을 조건적으로 수행시켜야 하는 때가 있다. 물론 if절로 각 구문을 감싸줄 필요는 없다. 대신, 구문 그룹안에 몇개의 구문을 그룹화할 수 있다. 예를 들면, 이코드는 $a가 $b보다 크다면 a는 b보다 크다라고 출력할것이고, $a의 값을 $b로 지정하게 될것이다.

<?php
if ($a > $b) {
    echo "a는 b보다 크다";
    $b = $a;
}
?>

If문은 다른 if문안에 무한정으로 내포될수 있다. 이와 같은 기능은 프로그램의 여러부분을 조건적으로 수행하기 위한 유연성을 제공한다.

이전 | 처음으로 | 다음
배열 연산자 | 위로 | else


제어 구조의 대체 문법

PHP는 제어 구조를 위해 대체 문법을 제공한다; 즉 if, while, for, foreach, 그리고 switch. 각 경우에 대체 문법의 기본형태는 괄호열기를 콜른 (:)으로 대체하고 괄호닫기는 각각 endif;, endwhile;, endfor;, endforeach;, 또는 endswitch;으로 대체한다.

<?php if ($a == 5): ?>
A는 5와 같다
<?php endif; ?>

위 예에서는 대체 문법으로 쓰여진 if구문안에 "A는 5와 같다" HTML 블록이 포함되어있다. 이 HTML 블록은 $a가 5와 같을때만 출력될것이다.

대체 문법은 else와 elseif문에도 적용이 된다. 다음은 elseif와 else문 과 같이 있는 if문 절의 대체 형태이다:

<?php
if ($a == 5):
    echo "a는 5와 같다";
    echo "...";
elseif ($a == 6):
    echo "a는 6과 같다";
    echo "!!!";
else:
    echo "a는 5도 아니고 6도 아니다";
endif;
?>

더 많은 예는while, for와 if섹션에 있다.

이전 | 처음으로 | 다음
elseif | 위로 | while


return

return()문이 함수안에서 호출된다면, 현재 함수의 수행을 즉시 끝내고, 함수 호출 결과값으로 return의 인자값을 넘겨준다. return()문은 eval()함수나 스크립트 파일의 수행을 종료시킨다.

전역 유효범위에서 호출된다면, 현재 스크립트 파일의 수행을 끝마친다. 현재 스크립트가 include()나 require()되었다면, 호출하고 있는 파일로 제어를 넘긴다. 더욱이, 현재 스크립트 파일이 include()되어있는것이면, return()에 주어지는 값은 include()호출에 대한 값으로 넘겨줄것이다. return()이 주 스크립트 파일에서 호출되면, 스크립트의 수행이 종료된다. 현재 스크립트 파일이 php.ini의 auto_prepend_file이나 auto_append_file 옵션에 의해 명명되었다면, 스크립트 파일의 수행은 중단된다.

좀더 자세한 정보는 Returning values 을 참고하세요.

참고: return()은 언어 구조로, 함수가 아닌 점에 주의하십시오. 인자를 괄호로 감싸는 것은 인자가 표현을 포함하고 있을 경우에만 필요합니다. 변수를 반환할 때는 괄호 없이 쓰는 것이 일반적입니다.

이전 | 처음으로 | 다음
declare | 위로 | require()


함수

PHP 매뉴얼
이전 다음

12. 장. 함수

차례
사용자 선언 함수
함수 인자
값 돌려주기
가변 함수
내부 (내장) 함수

사용자 선언 함수

다음과 같은 문법을 사용하여 함수를 선언한다:

예 12-1. 함수 사용을 설명하기 위한 가상 코드

<?php
function foo ($arg_1, $arg_2, /* ..., */ $arg_n)
{
    echo "예제 함수.\n";
    return $retval;
}
?>

모든 유효 PHP코드는 특정 함수 내에서 뿐만 아니라, 여러 다른 함수나 class정의 안에서도 나타날수있다.

PHP 3에서는 함수가 참조되기 전에 선언되어야 한다. 다음 두 예제 코드와 같이 함수가 조건적으로 선언되는 경우를 제외하고 PHP 4는 이런 제약이 없다.

아래 예제 코드와 같이 함수가 조건적으로 선언되면 그 함수가 호출되기 전에 함수를 선언해야 한다.

예 12-2. 조건적인 함수

<?php

$makefoo = true;

/* We can't call foo() from here
   since it doesn't exist yet,
   but we can call bar() */

bar();

if ($makefoo) {
  function foo ()
  {
    echo "I don't exist until program execution reaches me.\n";
  }
}

/* Now we can safely call foo()
   since $makefoo evaluated to true */

if ($makefoo) foo();

function bar()
{
  echo "I exist immediately upon program start.\n";
}

?>

예 12-3. 함수 안의 함수

<?php
function foo()
{
  function bar()
  {
    echo "foo()를 호출하기 전까지는 존재하지 않습니다.\n";
  }
}

/* bar()를 호출할 수 없습니다.
   아직 존재하지 않습니다. */

foo();

/* 이제 bar()를  호출할 수
   있습니다. foo()를 실행하여
   접근할 수 있게 되었습니다. */

bar();

?>

PHP는 함수 오버로딩(overloading)을 지원하지 않으며, 함수 정의를 해제하거나 이미 선언된 함수를 다시 선언할수 없다.

참고: 함수명은 선언시에 그 함수를 호출하기 편하게 만들겠지만, 대소문자 구별을 하지 않는다.

PHP 3에서 함수는 기본 인자(default argument)를 지원되지만, 가변 인자 갯수(variable-length argument)를 지원하지 않는다. (자세한 정보는 기본 인자섹션을 참고). PHP 4는 둘 다 지원된다: 자세한 정보는 가변 인자 목록섹션과 func_num_args(), func_get_arg(), func_get_args()함수 레퍼런스를 참고.

이전 | 처음으로 | 다음
include_once() | 위로 | 함수 인자


함수 인자

함수 인자를 통해서 함수에 정보를 넘겨줄수 있다. 이런 함수 인자는 콤마(,)로 구별되는 변수나 상수의 목록이다.

PHP는 값에 의한 인자 전달(passing by value) (기본값), 참조에 의한 전달(passing by reference), 기본 인자 값(default argument value)기능 을 지원한다. 가변 인자 목록(variable-length argument)은 PHP 4이후 버전에서만 지원된다; 더 자세한 정보는 가변 인자 목록섹션과 func_num_args(), func_get_arg(), func_get_args()함수 레퍼런스를 참고. PHP 3에서는 함수에 인자 배열을 넘겨줌으로써 비슷한 효과를 낼수있다:

예 12-4. 함수에 배열 넘겨주기

<?php
function takes_array($input)
{
    echo "$input[0] + $input[1] = ", $input[0]+$input[1];
}
?>

참조에 의한 인자 전달하기

기본적으로, 함수 인자는 값에 의해 전달된다 (그래서 함수내의 인자값 이 변경되도 함수 밖에서는 바뀌지 않는다). 함수가 그 인자까지 변경가능하게 하려면, 참조에 의해 인자를 전달해야 한다.

함수의 인자를 참조로 전달하려면, 함수 선언시에 엠퍼센트(&)를 인자명 앞에 덧붙이면 된다:

예 12-5. 참조에 의해 함수 인자 전달하기

<?php
function add_some_extra(&$string)
{
    $string .= 'and something extra.';
}
$str = 'This is a string, ';
add_some_extra($str);
echo $str;    // outputs 'This is a string, and something extra.'
?>

기본 인수 값

함수는 다음과 같이 스칼라 인자에 대해 C++스타일 기본값으로 지정할수있다:

예 12-6. 함수에 기본 인자 사용하기

<?php
function makecoffee ($type = "cappuccino")
{
    return "Making a cup of $type.\n";
}
echo makecoffee ();
echo makecoffee ("espresso");
?>

위 예제 코드의 출력은 다음과 같다:

Making a cup of cappuccino.
Making a cup of espresso.

기본값은 상수 표현식이 될수 있으나 (예를 들면) 변수나 클래스 멤버가 될수는 없다.

기본 인자를 사용할때에는 모든 기본값은 기본값을 쓰지 않는 인자의 오른쪽으로 가야 한다; 그렇지 않으면, 기대하던대로 작동하지 않을것이다. 다음 예제 코드를 참고:

예 12-7. 기본 함수 인자가 잘못 사용된 예

<?php
function makeyogurt ($type = "acidophilus", $flavour)
{
    return "Making a bowl of $type $flavour.\n";
}

echo makeyogurt ("raspberry");   // won't work as expected
?>

위 예제 코드의 출력은 다음과 같다:

Warning: Missing argument 2 in call to makeyogurt() in
/usr/local/etc/httpd/htdocs/php3test/functest.html on line 41
Making a bowl of raspberry .

위 코드를 아래 코드와 비교하라:

예 12-8. 기본 함수 인자의 정확한 사용예

<?php
function makeyogurt ($flavour, $type = "acidophilus")
{
    return "Making a bowl of $type $flavour.\n";
}

echo makeyogurt ("raspberry");   // works as expected
?>

이 예제코드의 출력은 다음과 같다:

Making a bowl of acidophilus raspberry.

가변 인자 목록

PHP 4는 사용자 선언 함수에서 가변 변수 목록 기능을 지원한다.
이런 기능은 func_num_args(),
func_get_arg(),
func_get_args()함수를 사용하여 손쉽게 사용가능하다.

특별한 문법이 필요하지 않다. 인자 목록은 함수선언부에서 밝혀야하고 일반 인자와 동일하게 작동할것이다.

이전 | 처음으로 | 다음
함수 | 위로 | 값 돌려주기


값 돌려주기

선택적인 return문을 사용하여 값을 돌려준다. 리스트나 객체를 포함하여 모든 타입을 돌려줄수있다. 이 구문에서 함수의 수행이 즉시 중단되고 현재 함수를 호출한 코드줄로 제어를 되돌린다. 자세한 정보는 return()섹션을 참고할것.

예 12-9. return()의 사용예

<?php
function square ($num)
{
    return $num * $num;
}
echo square (4);   // outputs '16'.
?>

함수는 여러 값을 돌려줄수 없다. 그러나 리스트를 돌려줌으로서 비슷한 효과를 볼수있다.

예 12-10. 여러 값을 취하기 위해 배열을 돌려줌

<?php
function small_numbers()
{
    return array (0, 1, 2);
}
list ($zero, $one, $two) = small_numbers();
?>

함수에서 참조를 돌려주기위해서는, 함수 선언부와 돌려주는 변수값을 지정하는 곳에서 참조 연산자 & 를 사용해야 한다.

예 12-11. 함수에서 참조 돌려주기

<?php
function &returns_reference()
{
    return $someref;
}

$newref =& returns_reference();
?>

참조에 관한 자세한 정보는, 참조 표현섹션을 참고.

이전 | 처음으로 | 다음
함수 인자 | 위로 | 가변 함수


가변 함수

PHP는 가변 함수에 대한 개념을 지원한다. 이 용어의 의미는 어떤 변수 뒤에 괄호가 따라온다면, PHP는 그 변수의 값을 갖는 함수를 찾아서 실행하려 할것이란 것이다. 이런 개념은 이기능 외에도 콜백과 함수 테이블 등등을 구현할수 있게 해준다.

가변 함수는 echo(), print(), unset(), isset(), empty(), include(), require()와 같은 언어 구조와 함께 작동하지 않을것이다. 이런 구조를 가변 변수로 사용하기 위해서는 보호 함수(wrapper function)를 사용할 필요가 있다.

예 12-12. 가변 변수 사용예

<?php
function foo() {
    echo "foo() 안입니다.<br />\n";
}

function bar($arg = '')
{
    echo "bar() 안입니다; 인수는 '$arg'입니다.<br />\n";
}

// echo를 감싸는 래퍼 함수입니다.
function echoit($string)
{
    echo $string;
}

$func = 'foo';
$func();        // foo()를 호출합니다.

$func = 'bar';
$func('test');  // bar()를 호출합니다.

$func = 'echoit';
$func('test');  // echoit()을 호출합니다.
?>

가변 함수 기능을 사용하여 객체의 메소드를 호출할수 있다.

예 12-13. 가변 메소드 사용예

<?php
class Foo
{
    function Variable()
    {
        $name = 'Bar';
        $this->$name(); // Bar() 메쏘드를 호출합니다.
    }

    function Bar()
    {
        echo "This is Bar";
    }
}

$foo = new Foo();
$funcname = "Variable";
$foo->$funcname();  // $foo->Var()를 호출합니다.

?>

또 call_user_func(), variable variables, function_exists()섹션을 참고

이전 | 처음으로 | 다음
값 돌려주기 | 위로 | 내부 (내장) 함수


내부 (내장) 함수

PHP는 많은 함수와 상수로 표준화되었다. 그리고 특정 PHP확장 컴파일이 요구하는 함수 도 제공한다. 이런 함수는 확장을 컴파일하지 않으면 "undefined function"같은 치명적 에러 메시지를 출력할 것이다. 예를 들면, image함수 를 사용하기 위해서는 GD 지원이 가능하게 컴파일해야 한다.mysql_connect() 함수를 사용하려면 MySQL을 지원하도록 컴파일해야 한다. 문자열과 변수 관련 함수와 같이 PHP의 모든 버전에 포함되어있는 많은 핵심 함수가 존재한다. phpinfo()나 get_loaded_extensions()함수 를 호출하면 현재 PHP에 올라간 확장에 어떤것인지 확인할수 있다. 많은 확장이 기본값으로 활성화되어있고, PHP 매뉴얼은 여러 확장에 의해 분할되어있다는 것에 주의해야 한다. PHP를 셋업하는 방법을 알고 싶다면, 설정, 설치, 각 확장에 대한 챕터를 보라.

함수의 원형(prototype) 읽기와 이해는 함수 선언 읽는 법 이라는 매뉴얼 섹션에서 설명한다. 함수가 돌려주는 것이나 함수가 값으로 직접 전달하는지 이해하는것이 중요하다. 예를 들면, str_replace()함수는 변경된 문자열을 돌려주는 반면에 usort()함수는 실질적으로 변수 자체에 전달하도록 동작한다. 각 매뉴얼 페이지는 각함수에 대해서 함수 인자와 동작 변경,성공과 실패시 돌려주는 값과 유용한 정보에 대해서 나와있다. 이런 중요한 차이점(아직은 희박) 을 아는 것은 PHP 코드를 정확하게 쓰는데 있어서 매우 결정적인 역할을 한다.

더불어 function_exists(), the function reference, get_extension_funcs(), dl()섹션을 참고할것.

이전 | 처음으로 | 다음
가변 함수 | 위로 | 클래스와 객체


클래스와 객체

PHP 매뉴얼
이전 다음

13. 장. 클래스와 객체

차례
class
extends
생성자
::
parent
객체 일렬화 - 세션 내의 객체
매직함수 __sleep와 __wakeup
생성자의 재참조
PHP 4에서 객체 비교
PHP 5에서 객체 비교

class

클래스(class)는 특정 변수들 그리고 이 변수들과 같이 동작하는 함수의 집합체이다. 다음 예제코드처럼 클래스를 선언할수 있다:

<?php
class Cart
{
    var $items;  // Items in our shopping cart

    // Add $num articles of $artnr to the cart

    function add_item ($artnr, $num)
    {
        $this->items[$artnr] += $num;
    }

    // Take $num articles of $artnr out of the cart

    function remove_item ($artnr, $num)
    {
        if ($this->items[$artnr] > $num) {
            $this->items[$artnr] -= $num;
            return true;
        } else {
            return false;
        }
    }
}
?>

위 코드에서 Cart라는 이름을 갖는 클래스는 카트(cart)를 위한 품목의 연관 배열, 그리고 카트에 아이템을 추가하거나 제거하는 두 개의 함수로 구성되어있다.

주의

클래스 선언부를 여러 파일이나 여러 PHP블록으로 분리할수 없다 다음 코드는 작동하지 않을것이다:

<?php
class test {
?>
<?php
    function test() {
        print 'OK';
    }
}
?>

PHP 4에서는 다음 사항에 주의해야 한다.

경고

Zend에서는 stdClass같은 명칭을 내부적으로 사용하며 이 명칭은 예약되어있다. 따라서 PHP에서 stdClass라는 클래스명을 만들수 없다.

경고

__sleep과 __wakeup함수는 PHP 클래스에서 중요한 역할을 수행한다. 이들과 결합된 매직 기능을 원 하지 않는다면 이런 이름을 클래스내에서 사용할수 없다. 다음 글에서 자세하게 설명할것이다.

경고

PHP에서 __으로 시작하는 함수명은 매직 기능을 수행하도록 예약되어있다. 문서화된 매직 기능을 원하지 않는다면 PHP에서 __를 갖는 함수명을 사용하지 않도록 한다.

PHP 4에서 var로 변수를 선언할때는 상수로만 초기화될수 있다. 상수가 아닌 값으로 초기화하려면, 클래스로부터 객체를 생성할때 자동적 으로 호출되는 함수에서 초기화할 필요가 있다. 이런 함수를 생성자(constructor) 라고 부른다. (다음글을 보세요)

<?php
/* PHP 4에서 이 코드는 작동하지 않을것이다 */
class Cart
{
    var $todays_date = date("Y-m-d");
    var $name = $firstname;
    var $owner = 'Fred ' . 'Jones';
    var $items = array("VCR", "TV");
}

/* 이와 같이 해야 한다 */
class Cart
{
    var $todays_date;
    var $name;
    var $owner;
    var $items;

    function Cart()
    {
        $this->todays_date = date("Y-m-d");
        $this->name = $GLOBALS['firstname'];
        /* etc. . . */
    }
}
?>

class는 타입이다. 즉, 실제 변수를 위한 청사진이다. new 연산자를 사용하여 원하는 이런 타입의 변수를 생성할 수 있다.

<?php
$cart = new Cart;
$cart->add_item("10", 1);

$another_cart = new Cart;
$another_cart->add_item("0815", 3);
?>

위 예제 코드는 Cart클래스의 $cart, $another_cart 객체를 생성한다. $cart의 add_item() 함수는 $cart 에 품목 번호가 10인 아이템 1개를 추가하고, $another_cart에 품목 번호가 0815인 아이템 3개를 추가한다.

$cart와 $another_cart 둘다 add_item(), remove_item() 함수와 items변수를 갖는다. 이들 모두 서로 다른 함수와 변수들이다. 이런 객체는 파일시스템의 디렉토리에 비유될수 있다. 파일시스템에서는 서로 다른 디렉토리에 있으면 두개의 다른 README.TXT파일을 저장할수 있다. 이 파일 각각에 접근하기 위해서는 최상위 디렉토리에서 각 파일로의 경로를 지정해 줘야 하듯이, 이런 각 함수를 호출하고자 한다면 각 함수의 완전한 이름을 지정해야 한다: PHP에서 최상위 디렉토리는 전역 네임스페이스를 갖고, 경로 구분자로 ->를 사용할수 있다. 따라서, $cart->items과 $another_cart->items 은 서로 다른 변수를 지칭하는 것이다. 변수는 $cart->$items이 아니라, $cart->items 로 지정해야 한다는 것에 주의해야 한다. 즉, PHP에서 변수명은 오직 한개의 달러사인($) 기호만 허용된다.

<?php
// correct, single $
$cart->items = array("10" => 1);

// invalid, because $cart->$items becomes $cart->""
$cart->$items = array("10" => 1);

// correct, but may or may not be what was intended:
// $cart->$myvar becomes $cart->items
$myvar = 'items';
$cart->$myvar = array("10" => 1);
?>

클래스의 선언부에서는 프로그램이 객체에 접근할때 어느 객체명 밑에 속해있을지 알수 없다: Cart 클래스가 선언된 후에 그 객체가 $cart나 $another_cart 객체명을 갖을지 알수 없는것이다. 따라서, Cart 클래스 선언부 안에서 $cart->items라고 쓸수 없다. 대신에, 클래스내의 함수나 변수에 접근할 수 있게 하려면 '내 소유'나 '현재 객체'라고 해석할수 있는 $this라는 의사-변수를 사용할수 있다. 따라서, '$this->items[$artnr] += $num' 이라는 코드는 '내 소유의 items 배열의 $artnr카운터를 $num만큼 더하라' 또는 '현재 객체의 items 배열의 $artnr 카운터를 $num만큼 더하라'고 해석할 수 있다.

참고: 클래스와 객체를 제어할 수 있는 몇가지의 유용한 함수가 제공된다. 클래스/객체 함수에서 확인할수 있다.

이전 | 처음으로 | 다음
내부 (내장) 함수 | 위로 | extends


객체 일렬화 - 세션 내의 객체

참고: PHP 3에서 객체는 일렬화(serialization)와 비일렬화(unserialization)처리 과정에서 클래스의 구성요소를 잃게 된다. 처리후 이 변수는 더이상 객체 타입 이 아니다. 그래서 클래스와 메소드를 갖지 않는다. 결국은 거의 쓸모 없게 되는것이다 (웃기는 문법을 갖는 배열처럼 바뀌게 된다)

경고

다음 설명은 PHP 4로만 한정되는 내용이다.

serialize()함수는 PHP에 저장할수 있는 값은 뭐든지 바이트-스트림(byte-stream) 대표성을 내포하는 문자열로 돌려준다. unserialize()함수는 이런 문자열을 원래 변수값으로 되돌려준다. serialize를 사용하여 객체를 저장하면 객체 내의 모든 변수 를 저장할 수 있다. 객체 내의 함수들을 저장할 수는 없고, 오직 클래스의 이름만 저장될것이다.

객체를 unserialize()하기 위해서는, 그 객체의 클래스가 선언되어 있어야 한다. 즉, page1.php에서 클래스 A의 객체 $a 가 있고 이것을 일렬화하면, 클래스 A를 참조하는 문자열을 얻게 되고, 이 문자열은 $a에 속해있는 모든 변수값을 포함하게 될것이다. Page2.php에서 이 문자열을 비일렬화하려면, 클래스 A의 $a를 재생성하고, 클래스 A의 선언이 page2.php에 존재해야 한다. 예를 들면 인클루드 파일 안에 클래스 A의 클래스 선언부를 저장하고 page1.php와 page2.php 에서 이 파일을 인클루드 하면 된다.

<?php
// classa.inc:

  class A
  {
      var $one = 1;

      function show_one()
      {
          echo $this->one;
      }
  }

// page1.php:

  include("classa.inc");

  $a = new A;
  $s = serialize($a);
  // store $s somewhere where page2.php can find it.
  $fp = fopen("store", "w");
  fputs($fp, $s);
  fclose($fp);

// page2.php:

  // this is needed for the unserialize to work properly.
  include("classa.inc");

  $s = implode("", @file("store"));
  $a = unserialize($s);

  // now use the function show_one() of the $a object.
  $a->show_one();
?>

세션을 사용해서 객체를 등록하기 위해 session_register()함수를 사용한다면, 이 객체들은 각 PHP 페이지의 끝에서 자동으로 일렬화되고, 다음 페이지들 각각에서 자동으로 비일렬화된다. 이 객체들이 일단 세션의 일부분이 되면 페이지의 어느 부분에서도 이런 객체가 나타날 수 있다는것을 의미한다.

모든 페이지에서 실제로 이런 클래스를 사용하지 않더라도, 모든 페이지에 등록된 모든 객체의 클래스 선언을 인클루드하도록 한다. 이렇게 하지 않고, 존재하는 클래스 선언부없이 객체가 일렬화되면, 그 객체는 클래스 구성원을 잃게 될것이고 어떤 함수도 갖지 않는 stdClass클래스의 객체가 될것이다. 즉, 그 객체는 쓸모없게 될것이다.

그래서 위 예제코드에서 $a가 session_register("a") 수행하여 세션의 일부분이 되면, page1.php와 page2.php뿐만 아니라 사용중인 모든 페이지에 classa.inc파일을 인클루드해야 한다.

이전 | 처음으로 | 다음
parent | 위로 | 매직함수 __sleep와 __wakeup


생성자의 재참조

생성자 내로 참조를 만드는 것은 혼란스런 결과를 유도할수 있다. 이런 튜토리얼같은 섹션이 문제를 회피하도록 도와준다.

<?php
class Foo
{
    function Foo($name)
    {
        // 전역 배열 $globalref 안에 참조를 만든다
        global $globalref;
        $globalref[] = &$this;
        // 값을 전달하기 위해 이름을 부여한다
        $this->setName($name);
        // 그리고 그것을 출력한다
        $this->echoName();
    }

    function echoName()
    {
        echo "<br>",$this->name;
    }

    function setName($name)
    {
        $this->name = $name;
    }
}
?>

= 복사 연산자를 사용하여 만들어지는 $bar1과 =& 참조 연산자를 사용하여 만들어지는 $bar2 사이에 차이점이 있는지 확인해보자...

<?php
$bar1 = new Foo('set in constructor');
$bar1->echoName();
$globalref[0]->echoName();

/* output:
set in constructor
set in constructor
set in constructor */

$bar2 =& new Foo('set in constructor');
$bar2->echoName();
$globalref[1]->echoName();

/* output:
set in constructor
set in constructor
set in constructor */
?>

외관상으로 둘 사이에는 아무 차이점도 없다. 그러나 실제로 매우 중요한 사실이 하나 있다: $bar1과 $globalref[0]은 참조되지 않는다. 그들은 같은 변수가 아니다. 이것은 "new"가 기본적으로 참조를 돌려주지 않기 때문이다. 대신 그것은 복사본을 돌려준다.

참고: 참조 대신 복사본을 돌려주는것 (PHP 4이상의 버전은 참조 카운팅을 사용한다) 때문에 퍼포먼스가 나빠지지는 않는다. 반대로 참조 대신에 복사본을 사용하는 것이 대부분 더 낫다. 왜냐하면 참조를 생성하는 것은 가상적으로 복사본을 만드는 데 약간의 시간이 걸리기 때문이다 (그것들이 거대한 배열이나 객체이고 그들 중 하나만 바뀌고 다른것들이 연속적으로 존재한다면, 그리고 동시에 그들 모두를 변경하려한다면 참조를 쓰는것이 더 현명할것이다)

위에서 서술한 것을 검증하기 위해 아래 예제 코드를 보자.

<?php
// now we will change the name. what do you expect?
// you could expect that both $bar1 and $globalref[0] change their names...
$bar1->setName('set from outside');

// as mentioned before this is not the case.
$bar1->echoName();
$globalref[0]->echoName();

/* output:
set from outside
set in constructor */

// let us see what is different with $bar2 and $globalref[1]
$bar2->setName('set from outside');

// luckily they are not only equal, they are the same variable
// thus $bar2->name and $globalref[1]->name are the same too
$bar2->echoName();
$globalref[1]->echoName();

/* output:
set from outside
set from outside */
?>

마지막으로 다음 예제를 보고 이해하도록 하자.

<?php
class A
{
    function A($i)
    {
        $this->value = $i;
        // try to figure out why we do not need a reference here
        $this->b = new B($this);
    }

    function createRef()
    {
        $this->c = new B($this);
    }

    function echoValue()
    {
        echo "<br>","class ",get_class($this),': ',$this->value;
    }
}

class B
{
    function B(&$a)
    {
        $this->a = &$a;
    }

    function echoValue()
    {
        echo "<br>","class ",get_class($this),': ',$this->a->value;
    }
}

// try to undestand why using a simple copy here would yield
// in an undesired result in the *-marked line
$a =& new A(10);
$a->createRef();

$a->echoValue();
$a->b->echoValue();
$a->c->echoValue();

$a->value = 11;

$a->echoValue();
$a->b->echoValue(); // *
$a->c->echoValue();

/*
output:
class A: 10
class B: 10
class B: 10
class A: 11
class B: 11
class B: 11
*/
?>

이전 | 처음으로 | 다음
매직함수 __sleep와 __wakeup | 위로 | PHP 4에서 객체 비교


PHP 4에서 객체 비교

PHP 4에서 객체는 매우 단순한 방식으로 비교된다. 즉: 두 객체 인스턴스 가 같은 속성과 값을 갖고, 같은 클래스의 인스턴스라면 두 객체는 동일하다. 식별 연산자 (===)를 사용하여 두 객체를 비교할때에도 비슷한 규칙이 적용된다.

아래 예제 코드를 실행해보면:

예 13-1. PHP 4에서 객체 비교를 위한 예제코드

<?php
function bool2str($bool) {
    if ($bool === false) {
            return 'FALSE';
    } else {
            return 'TRUE';
    }
}

function compareObjects(&$o1, &$o2) {
    echo 'o1 == o2 : '.bool2str($o1 == $o2)."\n";
    echo 'o1 != o2 : '.bool2str($o1 != $o2)."\n";
    echo 'o1 === o2 : '.bool2str($o1 === $o2)."\n";
    echo 'o1 !== o2 : '.bool2str($o1 !== $o2)."\n";
}

class Flag {
    var $flag;

    function Flag($flag=true) {
            $this->flag = $flag;
    }
}

class SwitchableFlag extends Flag {

    function turnOn() {
        $this->flag = true;
    }

    function turnOff() {
        $this->flag = false;
    }
}

$o = new Flag();
$p = new Flag(false);
$q = new Flag();

$r = new SwitchableFlag();

echo "Compare instances created with the same parameters\n";
compareObjects($o, $q);

echo "\nCompare instances created with different parameters\n";
compareObjects($o, $p);

echo "\nCompare an instance of a parent class with one from a subclass\n";
compareObjects($o, $r);
?>
결과는 다음과 같다:
Compare instances created with the same parameters
o1 == o2 : TRUE
o1 != o2 : FALSE
o1 === o2 : TRUE
o1 !== o2 : FALSE

Compare instances created with different parameters
o1 == o2 : FALSE
o1 != o2 : TRUE
o1 === o2 : FALSE
o1 !== o2 : TRUE

Compare an instance of a parent class with one from a subclass
o1 == o2 : FALSE
o1 != o2 : TRUE
o1 === o2 : FALSE
o1 !== o2 : TRUE
위 출력중 어떤것은 위에서 설명한 비교 규칙이 적용된다는 것을 알수 있다. 같은 속성에 대해 같은 값을 갖고, 같은 클래스에서 파생된 인스턴스만 동일 하고 동치로 판단한다.

복합 객체를 갖는 경우에도 같은 비교 규칙이 적용된다. 아래 예제 코드에서는 컨테이너 클래스를 만들어서 Flag 객체의 결합 배열을 저장한다.

예 13-2. PHP 4에서 복합 객체 비교

<?php
class FlagSet {
    var $set;

    function FlagSet($flagArr = array()) {
        $this->set = $flagArr;
    }

    function addFlag($name, $flag) {
        $this->set[$name] = $flag;
    }

    function removeFlag($name) {
        if (array_key_exists($name, $this->set)) {
            unset($this->set[$name]);
        }
    }
}

$u = new FlagSet();
$u->addFlag('flag1', $o);
$u->addFlag('flag2', $p);
$v = new FlagSet(array('flag1'=>$q, 'flag2'=>$p));
$w = new FlagSet(array('flag1'=>$q));

echo "\nComposite objects u(o,p) and v(q,p)\n";
compareObjects($u, $v);

echo "\nu(o,p) and w(q)\n";
compareObjects($u, $w);
?>
이 코드의 결과는 다음과 같은 출력이 기대된다:
Composite objects u(o,p) and v(q,p)
o1 == o2 : TRUE
o1 != o2 : FALSE
o1 === o2 : TRUE
o1 !== o2 : FALSE

u(o,p) and w(q)
o1 == o2 : FALSE
o1 != o2 : TRUE
o1 === o2 : FALSE
o1 !== o2 : TRUE

이전 | 처음으로 | 다음
생성자의 재참조 | 위로 | PHP 5에서 객체 비교


PHP 5에서 객체 비교

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

PHP 5에서 객체 비교는 PHP 4보다 좀더 복잡하고 객체 지향 언어 (PHP 5는 그런 언어가 아니다)에서 기대할수 있는 특성에 더 가깝다.

비교 연산자 (==)를 사용할 때에는 객체 변수는 단순 한 방식으로 비교된다. 즉: 두 객체 인스턴스가 같은 속성과 값을 갖고, 같은 클래스에서 파생된 인스턴스이고, 같은 네임스페이스에서 선언되었 다면 동일한 객체라고 본다.

하지만, 식별 연산자 (===)를 사용하면 객체 변수는 오직 같은 클래스(특별한 네임스페이스에서)의 같은 인스턴스로 참조될때만 동일한 객체라고 본다.

다음 예제 코드를 보고 이런 규칙을 음미해보자.

예 13-3. PHP 5에서의 객체 비교에 대한 예제 코드

<?php
function bool2str($bool) {
    if ($bool === false) {
            return 'FALSE';
    } else {
            return 'TRUE';
    }
}

function compareObjects(&$o1, &$o2) {
    echo 'o1 == o2 : '.bool2str($o1 == $o2)."\n";
    echo 'o1 != o2 : '.bool2str($o1 != $o2)."\n";
    echo 'o1 === o2 : '.bool2str($o1 === $o2)."\n";
    echo 'o1 !== o2 : '.bool2str($o1 !== $o2)."\n";
}

class Flag {
    var $flag;

    function Flag($flag=true) {
            $this->flag = $flag;
    }
}

namespace Other {

    class Flag {
        var $flag;

        function Flag($flag=true) {
                $this->flag = $flag;
        }
    }

}

$o = new Flag();
$p = new Flag();
$q = $o;
$r = new Other::Flag();

echo "Two instances of the same class\n";
compareObjects($o, $p);

echo "\nTwo references to the same instance\n";
compareObjects($o, $q);

echo "\nInstances of similarly named classes in different namespaces\n";
compareObjects($o, $r);
?>
이 예제 코드는 다음과 같이 출력한다:
Two instances of the same class
o1 == o2 : TRUE
o1 != o2 : FALSE
o1 === o2 : FALSE
o1 !== o2 : TRUE

Two references to the same instance
o1 == o2 : TRUE
o1 != o2 : FALSE
o1 === o2 : TRUE
o1 !== o2 : FALSE

Instances of similarly named classes in different namespaces
o1 == o2 : FALSE
o1 != o2 : TRUE
o1 === o2 : FALSE
o1 !== o2 : TRUE

이전 | 처음으로 | 다음
PHP 4에서 객체 비교 | 위로 | 참조 표현


참조 표현

PHP 매뉴얼
이전 다음

14. 장. 참조 표현

차례
참조란 무엇인가
참조는 무엇을 하는가
참조가 아닌것
참조에 의한 전달
참조 돌려받기
참조 해제
참조로 볼수 있는것

참조란 무엇인가

PHP에서 참조란 다른 이름으로 같은 변수의 내용에 접근한다는 것을 의미한다. C 포인터와 비슷한 개념은 아니며, 심볼 테이블이라고 볼수 있다. PHP에서 변수명과 변수의 내용은 다르다. 그래서 같은 내용이 다른 이름을 갖을수 있다. 유닉스 파일명과 파일에 가장 가까운 개념이다 - 변수명은 디렉토리 엔트리이고, 변수 내용은 파일 자체라고 볼수 있다. 참조는 유닉스 파일시스템의 하드 링크(hardlinking)와 유사하다.

이전 | 처음으로 | 다음
PHP 5에서 객체 비교 | 위로 | 참조는 무엇을 하는가


참조는 무엇을 하는가

PHP 참조는 두 변수가 같은 내용을 참조할수 있게 한다. 다음과 같은 일을 한다:

<?php
$a =& $b
?>

$a와 $b는 같은 변수를 가리킨다는 것을 의미이다.

참고: 여기서 $a와 $b는 완전히 같다. $a는 $b를 가리키고, 그 반대일수도 있다. $a와 $b는 같은 곳을 가리키고 있다.

같은 문법은 함수에도 적용된다. 참조를 돌려받고, new연산자와도 함께 쓸수 있다 (PHP 4.0.4 이후 버전부터 유효):

<?php
$bar =& new fooclass();
$foo =& find_var ($bar);
?>

참고: & 연산자를 사용하지않으면 생성된 객체의 복사본을 돌려받는다. 그 클래스에서 $this를 사용한다면 그것은 클래스의 현재 인스턴스에만 영향을 미친다. &가 없는 지정은 인스턴스(즉, 객체)를 복사할것이고 $this는 복사본에만 영향을 미칠것이다. 이와 같은 것은 퍼포먼스와 메모리의 효율적인 사용을 위해 오직 하나의 인스턴스만 취급하기를 원할 경우에 사용된다.

@new처럼 생성자에서 발생하는 모든 에러 메시지를 보이지 않게 하기 위해서 @연산자를 사용할수 있지만, &new구문을 사용할때는 이 연산자는 작동하지 않는다. 이것은 젠드 엔진(Zend Engine)의 한계이고 이런 표현을 쓰면 파싱 에러가 발생한다.

참조가 하는 두번째 일은 참조에 의해 변수를 전달하는 것이다. 이와 같은 것은 함수에서 지역 변수를 만들거나 같은 내용을 참조하는 호출을 사용하는 변수를 생성함으로써 가능해진다. 예를 들면:

<?php
function foo (&$var)
{
    $var++;
}

$a=5;
foo ($a);
?>

위 코드는 $a를 6으로 만들것이다. 이렇게 되는 이유는 foo함수 안의 변수 $var가 $a와 같은 내용을 가리키기 때문이다. 더 자세한 설명을 참조에 의한 전달 섹션에서 볼수 있다.

참조가 하는 세번째 일은 참조에 의해 돌려받기이다.

이전 | 처음으로 | 다음
참조 표현 | 위로 | 참조가 아닌것


참조가 아닌것

전에 설명했듯이, 참조는 포인터가 아니다. 이말의 의미는 다음 구문이 기대하던대로 작업을 수행하지 않을것이란 의미이다:

<?php
function foo (&$var)
{
    $var =& $GLOBALS["baz"];
}
foo($bar);
?>

위 예제코드에서 foo안의 $var변수는 호출자 안의 $bar와 연결될것이다. 그리고 이 변수는 $GLOBALS["baz"]과 다시 연결될것이다. 참조 메카니즘을 사용하여 다른 호출 영역안의 $bar를 연결할수 있는 방법이 존재하지는 않는다. 왜냐하면 $bar는 함수 foo에서 유효하지 않기 때문이다 (그것은 $var에 의해 표현되는 것이 아니고, $var는 오직 변수 내용만을 소유하고 호출 심볼 테이블 내에서 이름이 값으로 변환되어 연결되지는 않는다).

이전 | 처음으로 | 다음
참조는 무엇을 하는가 | 위로 | 참조에 의한 전달


참조에 의한 전달

참조에 의해 함수로 변수를 전달할수 있다. 이런 기법은 함수의 인수를 변경할수 있도록 한다. 문법은 다음과 같다:

<?php
function foo (&$var)
{
    $var++;
}

$a=5;
foo ($a);
// $a is 6 here
?>

함수 호출에 대해 참조 표시를 할수 없다는 것에 주의해야 한다. - 함수선언에서만 참조표시를 할수 있다 함수 선언만으로도 충분히 참조에 의해 인수를 정확하게 전달할수 있다.

다음과 같은 것들은 참조에 의해 전달될수 있다:

  • 변수, i.e. foo($a)

  • New 구문, i.e. foo(new foobar())

  • 참조, 함수에서 돌려받기, i.e.:

    <?php
    function &bar()
    {
            $a = 5;
        return     $a;
    }
    foo(bar());
    ?>

    참조로 돌려받기에서도 이 주제와 관련된 내용을 볼수 있다.

결과가 정의되어 있지 않기 때문에, 어떤 표현식들은 참조에 의해 전달되어서는 안된다. 예를 들어, 다음과 같은 참조에 의한 전달의 예제코드는 유효하지 않다.

<?php
function bar() // Note the missing &
{
    $a = 5;
    return $a;
}
foo(bar());

foo($a = 5) // Expression, not variable
foo(5) // Constant, not variable
?>

이런 조건은 PHP 4.0.4 이후 버전에서만 요구된다.

이전 | 처음으로 | 다음
참조가 아닌것 | 위로 | 참조 돌려받기


참조 돌려받기

참조에 의한 돌려받기는 참조에 연결되어 있는 변수를 확인하기 위해 함수를 사용할 때 유용하다. 참조 돌려받기는 다음과 같은 문법을 사용한다:

<?php
function &find_var ($param)
{
    ...code...
    return $found_var;
}

$foo =& find_var ($bar);
$foo->x = 2;
?>

위 예제 코드는 함수 find_var에 의해 돌려받는 객체의 속성을 설정하지만, 참조 문법을 사용하지 않을 때와 같은 복사가 아니다.

참고: 인자가 전달되는것과 달리, 여기서는 두 근데에서 &을 사용해야 한다 - 보통의 복사가 아니라, 참조에 의해 돌려받는다는것을 가리킬때, 그리고 일반적인 지정이 아닌 참조 연결이라는 것을 가리킬때, $foo변수에 대해 사용해야 한다.

이전 | 처음으로 | 다음
참조에 의한 전달 | 위로 | 참조 해제


참조 해제

참조 unset하면 변수 명과 변수 내용 사이의 연결만을 끊는다. 이 말의 의미는 변수 내용이 사라질것이라는 것을 의미하지 않는다. 예를 들면:

<?php
$a = 1;
$b =& $a;
unset ($a);
?>

위 예제 코드는 $a만 해제되고 $b를 해제(unset)하지는 않을것이다.

다시 말하면, 유닉스의 unlink 호출에 비유할수 있을것이다.

이전 | 처음으로 | 다음
참조 돌려받기 | 위로 | 참조로 볼수 있는것


참조로 볼수 있는것

PHP내의 많은 문법 구조가 참조 메카니즘에 의해 구현된다. 그래서 위에서 설명한 모든 참조 연결이 이런 구조에 적용된다. 위에서 참조에 의한 전달과 참조에 의한 돌려주기 같은 몇몇 구조문을 설명했다. 다음과 같은 구조는 참조를 사용한다:

global 참조

global $var처럼 변수를 선언하면 전역 변수에 대한 참조를 생성하게 된다. 즉, 다음과 같은 의미를 갖는다:

<?php
$var =& $GLOBALS["var"];
?>

이것은 $var를 해체하는 것이 전역 변수를 해제하지 않는다는 것을 의미한다.

$this

객체 메소드에서,$this는 호출 객체로의 참조를 하게 된다.

이전 | 처음으로 | 다음
참조 해제 | 위로 | 보안


보안

PHP 매뉴얼
이전 다음

III. 보안

차례
15. 보안

이전 | 처음으로 | 다음
참조로 볼수 있는것 |  | 보안


보안

PHP 매뉴얼
이전 다음

15. 장. 보안

차례
도입
일반적인 고려 사항
CGI 바이너리로 설치
Installed as an Apache module
Filesystem Security
Database Security
Error Reporting
Using Register Globals
User Submitted Data
Hiding PHP
Keeping Current

도입

PHP는 강력한 언어와 인터프리터입니다. 웹서버 모듈로 포함하거나 별도의 CGI 바이너리로 실행해서, 서버에서 파일에 접근하거나, 명령을 실행하거나, 네트워크 연결을 열 수 있게 해줍니다. 기본적으로 이러한 기능은 웹서버의 보안을 위협합니다. PHP는 펄이나 C로 쓰여진 CGI 프로그램에 비해서 더욱 안전한 언어로 설계되었습니다. 컴파일 시와 실행시 환경 설정 옵션의 적절한 선택과 충분한 코딩 능력은 자유와 보안의 조합을 얻을 수 있을 것입니다.

PHP를 이용하는 다른 방법들에 따라, 실행을 조절하는 많은 환경 설정 옵션이 존재합니다. 많은 옵션의 선택은 PHP를 여러 목적으로 사용할 수 있게 보장해주지만, 이러한 옵션과 서버 환경 설정의 조합에 따라서는 보안을 위협하는 결과를 가져올 수도 있습니다.

PHP 환경 설정의 유연성은 코드의 유연성과 상대적이 됩니다. PHP는 쉘 유저의 모든 권한을 가지는 완벽한 서버 어플리케이션을 작성할 수도 있고, 강력히 제어된 환경에서 적은 위험으로 단순한 서버측 포함으로 사용할 수도 있습니다. 어떻게 환경을 구축하고, 어떻게 보안을 유지하는 지는, 많은 부분이 PHP 개발자에 의존하고 있습니다.

이 챕터에서는 몇가지 일반적인 보안 조언으로 시작해서, 서로 다른 환경 설정 옵션의 조합과 안전하게 사용할 수 있는 상황, 그리고 보안 단계에 따라 코딩에서 고려할 점에 대해서 설명합니다.

이전 | 처음으로 | 다음
보안 | 위로 | 일반적인 고려 사항


일반적인 고려 사항

완벽한 보안 시스템은 불가능에 가깝기에, 보안 대책의 지향점은 보통 위험성과 사용성의 조화점입니다. 유저가 송신하는 모든 변수가 두가지 형태의 생물학적 인증(망막 스캔이나 지문 등)이 필요하다면, 매우 높은 수준의 보안을 얻을 수 있습니다. 그러나 이 방법은 매우 복잡한 폼을 채우기 위해 30여분의 시간을 필요로 할 것이며, 유저가 보안을 그냥 넘어갈 수 있는 방법을 찾도록 노력하게 할 것입니다.

필요 이상의 엄중한 보안은 종종 사용자가 작업을 하는 것을 방해하거나, 지나친 복잡함으로 코드 작성자에게 부담을 줍니다. 사실, 몇몇 보안 공격은 지나친 보안으로 인한 약점을 노리며, 시간을 들여 손상시키는 경향이 있습니다.

기억할만한 문구입니다: 시스템은 체인의 가장 약한 부분 정도에 불과하다. 모든 작업을 시간, 장소, 작업 종류 등으로 자세하게 기록을 한다고 하여도, 사용자 인증을 하나의 쿠키로만 처리한다면, 사용자에 대한 작업 기록은 매우 약해질 것입니다.

테스트를 할 때, 가장 간단한 페이지라 할지라도 모든 가능성을 테스트할 수는 없다는 것을 명심하십시오. 화가 난 고용인이나, 엄청난 시간을 가진 크랙커, 혹은 키보드 위를 걸어가는 고양이 등에 의해 기대했던 입력값과는 완전히 무관하게 될 수도 있습니다. 이것이 기대하지 않는 데이터를 분별하고, 그 뒤에 어떻게 변경하고, 줄이고, 늘릴지에 대해 논리적 관점에서 코드를 바라보아야 할 이유입니다.

인터넷은 당신의 코드를 부수고, 사이트를 파괴하고, 부적절한 내용을 게시하는 등 당신을 바쁘게 하는 사람들로 가득 차 있습니다. 사이트의 크기에 관계 없이, 온라인인 서버를 가지고 있다면 간단히 목표가 됩니다. 많은 크래킹 프로그램은 크기를 고려하지 않으며, 단지 IP 블럭에서 희생자를 찾을 뿐입니다. 희생자가 되지 마십시오.

이전 | 처음으로 | 다음
보안 | 위로 | CGI 바이너리로 설치


CGI 바이너리로 설치

가능한 공격

몇가지 이유로 인해 PHP를 서버 소프트웨어(아파치 등)의 모듈로 사용하지 않거나, 다른 종류의 CGI wrappers로 스크립트에 대해 안전한 chroot와 setuid 환경을 제공하기 위해 CGI 바이너리로 PHP를 사용하는 것을 선택할 수 있습니다. 이 설치는 보통 실행 가능한 PHP 바이너리를 웹서버 cgi-bin 디렉토리에 두는 것입니다. CERT 권고 CA-96.11는 어떠한 인터프리터도 cgi-bin에 두지 않을 것을 권장합니다. PHP 바이너리는 독립 인터프리터로 사용할 수 있지만, 이러한 방법의 설치가 가능하도록 하는 몇가지 공격을 방지하도록 설계되어 있습니다.

  • 시스템 파일에의 접근: http://my.host/cgi-bin/php?/etc/passwd

    URL 후의 물음표(?)에 존재하는 질의 정보는 CGI 인터페이스에 의해 인터프리터에 명령줄 인자로 전해집니다. 보통 인터프리터는 명령줄의 첫 인자에 지정한 파일을 열고 실행합니다.

    CGI 바이너리로 호출할 때, PHP는 명령줄 인자를 해석하는 것을 거절합니다.

  • 서버의 어떠한 웹 문서로의 접근: http://my.host/cgi-bin/php/secret/doc.html

    PHP 바이너리 이름 뒤의 URL의 경로 정보 부분, /secret/doc.html는 일반적으로 CGI 프로그램에 의해 그 이름의 파일을 열고 해석하도록 사용합니다. 보통 몇몇 웹 서버 환경 설정 지시자(아파치: Action)는 PHP 인터프리터에 http://my.host/secret/script.php 등의 요청으로 리다이렉트하도록 합니다. 이러한 설치로는, 웹 서버는 우선 디렉토리 /secret에 대해 접근 권한을 확인하고, 리다이렉트된 요청 http://my.host/cgi-bin/php/secret/script.php을 생성합니다. 불행하게도, 이러한 형식으로 요청이 주어지면, /secret/script.php에 대한 접근 확인은 이루어지지 않고, 단순히 /cgi-bin/php 파일만을 확인합니다. 이 방법으로 /cgi-bin/php에 접근할 수 있는 어떠한 유저라도 웹 서버로 보호된 어떠한 문서라도 접근할 수 있습니다.

    PHP에서는, 서버 문서 트리에 접근 제한을 가진 어떠한 디렉토리가 존재한다면, 컴파일시의 환경설정 옵션 --enable-force-cgi-redirect, 실행시 환경설정 지시자 doc_root와 user_dir를 사용하여 이 공격을 방지할 수 있습니다. 여러가지 조합에 관한 자세한 설명은 아래쪽을 참고하십시오.

방법 1: 공개 파일만을 제공

서버가 패스워드나 IP 기반 접근 컨트롤로 제한하는 콘텐츠를 가지고 있지 않다면, 이러한 환경 설정 옵션을 사용할 필요가 없습니다. 웹 서버가 리다이렉트를 허용하지 않거나, 안전하게 리다이렉트된 요청에 대해서 PHP 바이너리와 통신할 방법을 가지고 있지 않다면, 설정 스크립트에 --enable-force-cgi-redirect 옵션을 지정할 수 있습니다. 하지만, 여전히 PHP 스크립트를 호출하는 방법으로 직접 호출 http://my.host/cgi-bin/php/dir/script.php이나 리다이렉션 호출 http://my.host/dir/script.php에 의존하고 있지 않음을 확인해야 할 것입니다.

아파치에서 리다이렉션은 AddHandler와 Action 지시자를 통해서 설정할 수 있습니다. (아래 참조)

방법 2: --enable-force-cgi-redirect 사용

이 컴파일시의 옵션은 누구라도 http://my.host/cgi-bin/php/secretdir/script.php와 같은 URL을 통해서 PHP를 직접 호출할 수 없게 합니다. 대신, 이 모드에서 PHP는 웹서버의 리다이렉트 규칙에 따를 때만 해석을 시도할 것입니다.

아파치에서 리다이렉션의 설정은 다음과 같은 지시자로 설정합니다:

Action php-script /cgi-bin/php
AddHandler php-script .php

이 옵션은 아파치 웹 서버에만 테스트되었고, 리다이렉트된 요청에 대해 아파치가 비표준 CGI 환경 변수 REDIRECT_STATUS를 설정하게 합니다. 웹 서버가 요청이 직접적인지 리다이렉트된 것인지의 구분을 제공하지 않는다면, 이 옵션을 사용할 수 없고, 이 문서에 제시된 다른 방법의 CGI 실행 방법을 이용해야 합니다.

방법 3: doc_root나 user_dir을 설정

스크립트나 실행 파일과 같은 활동적인 콘텐츠를 웹서버 디렉토리에 놓는 것은 때때로 비보안적인 행동으로 생각됩니다. 몇몇 환경 설정의 실수로 스크립트가 실행되지 않고 보통의 HTML 문서로 보여진다면, 지적 재산이나 패스워드와 같은 보안 정보를 노출시키는 결과를 가져올 수 있습니다. 그러므로 많은 시스템 관리자는 파일이 항상 해석이 되고 어떤 방법으로도 표시되어지지 않도록, PHP CGI를 통해서만 접근할 수 있는 스크립트를 위한 또 다른 디렉토리 구조를 만드는 것을 선호합니다.

또한, 앞의 섹션에서 설명한 방법으로 요청을 리다이렉트하지 않게 만드는게 불가능하다면, doc_root를 웹 문서 루트와 다른 장소로 설정할 필요가 있습니다.

PHP 스크립트 문서 루트를 설정 파일에서 지시어 doc_root나, 환경 변수 PHP_DOCUMENT_ROOT로 설정할 수 있습니다. 이를 설정하면, PHP의 CGI 버전은 항상 열 파일 이름 및 요청의 경로 정보를 doc_root와 결합하여, 이 디렉토리 밖에서는 어떠한 스크립트도 실행하지 못하게 합니다. (아래의 user_dir를 제외하고)

Another option usable here is user_dir. When user_dir is unset, only thing controlling the opened file name is doc_root. Opening an URL like http://my.host/~user/doc.php does not result in opening a file under users home directory, but a file called ~user/doc.php under doc_root (yes, a directory name starting with a tilde [~]).

If user_dir is set to for example public_php, a request like http://my.host/~user/doc.php will open a file called doc.php under the directory named public_php under the home directory of the user. If the home of the user is /home/user, the file executed is /home/user/public_php/doc.php.

user_dir expansion happens regardless of the doc_root setting, so you can control the document root and user directory access separately.

방법 4: 웹 트리 외부의 PHP 파서

매우 안전한 옵션은 PHP 파서 바이너리를 웹트리 밖에 위치시키는 것입니다. 예를 들면, /usr/local/bin 안에. 이 방법의 단 한가지 단점은 다음과 같은 줄을 PHP 태그를 포함하는 모든 파일의 첫번째 줄에 넣어야 한다는 점입니다:

#!/usr/local/bin/php

또한 파일을 실행 가능하게 해 둘 필요가 있습니다. 이것은 정확하게 실행을 위해서 #! 쉘 이스케이핑 메카니즘을 사용하는 펄이나 sh, 혹은 다른 일반적인 스크립팅 언어로 쓰여진 CGI 스크립트와 동일하게 취급합니다.

이 방법을 사용할 때, PHP가 PATH_INFO와 PATH_TRANSLATED를 올바르게 다룰 수 있게 하기 위해서는 PHP 파서를 컴파일 할 때, --enable-discard-path 옵션을 주어야 합니다.

이전 | 처음으로 | 다음
일반적인 고려 사항 | 위로 | Installed as an Apache module


Installed as an Apache module

When PHP is used as an Apache module it inherits Apache's user permissions (typically those of the "nobody" user). This has several impacts on security and authorization. For example, if you are using PHP to access a database, unless that database has built-in access control, you will have to make the database accessible to the "nobody" user. This means a malicious script could access and modify the database, even without a username and password. It's entirely possible that a web spider could stumble across a database administrator's web page, and drop all of your databases. You can protect against this with Apache authorization, or you can design your own access model using LDAP, .htaccess files, etc. and include that code as part of your PHP scripts.

Often, once security is established to the point where the PHP user (in this case, the apache user) has very little risk attached to it, it is discovered that PHP is now prevented from writing any files to user directories. Or perhaps it has been prevented from accessing or changing databases. It has equally been secured from writing good and bad files, or entering good and bad database transactions.

A frequent security mistake made at this point is to allow apache root permissions, or to escalate apache's abilitites in some other way.

Escalating the Apache user's permissions to root is extremely dangerous and may compromise the entire system, so sudo'ing, chroot'ing, or otherwise running as root should not be considered by those who are not security professionals.

There are some simpler solutions. By using open_basedir you can control and restrict what directories are allowed to be used for PHP. You can also set up apache-only areas, to restrict all web based activity to non-user, or non-system, files.

이전 | 처음으로 | 다음
CGI 바이너리로 설치 | 위로 | Filesystem Security


Filesystem Security

PHP is subject to the security built into most server systems with respect to permissions on a file and directory basis. This allows you to control which files in the filesystem may be read. Care should be taken with any files which are world readable to ensure that they are safe for reading by all users who have access to that filesystem.

Since PHP was designed to allow user level access to the filesystem, it's entirely possible to write a PHP script that will allow you to read system files such as /etc/passwd, modify your ethernet connections, send massive printer jobs out, etc. This has some obvious implications, in that you need to ensure that the files that you read from and write to are the appropriate ones.

Consider the following script, where a user indicates that they'd like to delete a file in their home directory. This assumes a situation where a PHP web interface is regularly used for file management, so the Apache user is allowed to delete files in the user home directories.

예 15-1. Poor variable checking leads to....

<?php
// remove a file from the user's home directory
$username = $_POST['user_submitted_name'];
$homedir = "/home/$username";
$file_to_delete = "$userfile";
unlink ("$homedir/$userfile");
echo "$file_to_delete has been deleted!";
?>
Since the username is postable from a user form, they can submit a username and file belonging to someone else, and delete files. In this case, you'd want to use some other form of authentication. Consider what could happen if the variables submitted were "../etc/" and "passwd". The code would then effectively read:

예 15-2. ... A filesystem attack

<?php
// removes a file from anywhere on the hard drive that
// the PHP user has access to. If PHP has root access:
$username = "../etc/";
$homedir = "/home/../etc/";
$file_to_delete = "passwd";
unlink ("/home/../etc/passwd");
echo "/home/../etc/passwd has been deleted!";
?>
There are two important measures you should take to prevent these issues.

  • Only allow limited permissions to the PHP web user binary.

  • Check all variables which are submitted.

Here is an improved script:

예 15-3. More secure file name checking

<?php
// removes a file from the hard drive that
// the PHP user has access to.
$username = $_SERVER['REMOTE_USER']; // using an authentication mechanisim

$homedir = "/home/$username";

$file_to_delete = basename("$userfile"); // strip paths
unlink ($homedir/$file_to_delete);

$fp = fopen("/home/logging/filedelete.log","+a"); //log the deletion
$logstring = "$username $homedir $file_to_delete";
fwrite ($fp, $logstring);
fclose($fp);

echo "$file_to_delete has been deleted!";
?>
However, even this is not without it's flaws. If your authentication system allowed users to create their own user logins, and a user chose the login "../etc/", the system is once again exposed. For this reason, you may prefer to write a more customized check:

예 15-4. More secure file name checking

<?php
$username = $_SERVER['REMOTE_USER']; // using an authentication mechanisim
$homedir = "/home/$username";

if (!ereg('^[^./][^/]*$', $userfile))
     die('bad filename'); //die, do not process

if (!ereg('^[^./][^/]*$', $username))
     die('bad username'); //die, do not process
//etc...
?>

Depending on your operating system, there are a wide variety of files which you should be concerned about, including device entries (/dev/ or COM1), configuration files (/etc/ files and the .ini files), well known file storage areas (/home/, My Documents), etc. For this reason, it's usually easier to create a policy where you forbid everything except for what you explicitly allow.

이전 | 처음으로 | 다음
Installed as an Apache module | 위로 | Database Security


Database Security

Nowadays, databases are cardinal components of any web based application by enabling websites to provide varying dynamic content. Since very sensitive or secret information can be stored in a database, you should strongly consider protecting your databases.

To retrieve or to store any information you need to connect to the database, send a legitimate query, fetch the result, and close the connection. Nowadays, the commonly used query language in this interaction is the Structured Query Language (SQL). See how an attacker can tamper with an SQL query.

As you can surmise, PHP cannot protect your database by itself. The following sections aim to be an introduction into the very basics of how to access and manipulate databases within PHP scripts.

Keep in mind this simple rule: defense in depth. The more places you take action to increase the protection of your database, the less probability of an attacker succeeding in exposing or abusing any stored information. Good design of the database schema and the application deals with your greatest fears.

Designing Databases

The first step is always to create the database, unless you want to use one from a third party. When a database is created, it is assigned to an owner, who executed the creation statement. Usually, only the owner (or a superuser) can do anything with the objects in that database, and in order to allow other users to use it, privileges must be granted.

Applications should never connect to the database as its owner or a superuser, because these users can execute any query at will, for example, modifying the schema (e.g. dropping tables) or deleting its entire content.

You may create different database users for every aspect of your application with very limited rights to database objects. The most required privileges should be granted only, and avoid that the same user can interact with the database in different use cases. This means that if intruders gain access to your database using your applications credentials, they can only effect as many changes as your application can.

You are encouraged not to implement all the business logic in the web application (i.e. your script), instead do it in the database schema using views, triggers or rules. If the system evolves, new ports will be intended to open to the database, and you have to re-implement the logic in each separate database client. Over and above, triggers can be used to transparently and automatically handle fields, which often provides insight when debugging problems with your application or tracing back transactions.

Connecting to Database

You may want to estabilish the connections over SSL to encrypt client/server communications for increased security, or you can use ssh to encrypt the network connection between clients and the database server. If either of these is used, then monitoring your traffic and gaining information about your database will be difficult for a would-be attacker.

Encrypted Storage Model

SSL/SSH protects data travelling from the client to the server, SSL/SSH does not protect the persistent data stored in a database. SSL is an on-the-wire protocol.

Once an attacker gains access to your database directly (bypassing the webserver), the stored sensitive data may be exposed or misused, unless the information is protected by the database itself. Encrypting the data is a good way to mitigate this threat, but very few databases offer this type of data encryption.

The easiest way to work around this problem is to first create your own encryption package, and then use it from within your PHP scripts. PHP can assist you in this with several extensions, such as Mcrypt and Mhash, covering a wide variety of encryption algorithms. The script encrypts the data before inserting it into the database, and decrypts it when retrieving. See the references for further examples of how encryption works.

In case of truly hidden data, if its raw representation is not needed (i.e. not be displayed), hashing may also be taken into consideration. The well-known example for the hashing is storing the MD5 hash of a password in a database, instead of the password itself. See also crypt() and md5().

예 15-5. Using hashed password field

<?php

// storing password hash
$query  = sprintf("INSERT INTO users(name,pwd) VALUES('%s','%s');",
            addslashes($username), md5($password));
$result = pg_exec($connection, $query);

// querying if user submitted the right password
$query = sprintf("SELECT 1 FROM users WHERE name='%s' AND pwd='%s';",
            addslashes($username), md5($password));
$result = pg_exec($connection, $query);

if (pg_numrows($result) > 0) {
    echo "Welcome, $username!";
}
else {
    echo "Authentication failed for $username.";
}

?>

SQL Injection

Many web developers are unaware of how SQL queries can be tampered with, and assume that an SQL query is a trusted command. It means that SQL queries are able to circumvent access controls, thereby bypassing standard authentication and authorization checks, and sometimes SQL queries even may allow access to host operating system level commands.

Direct SQL Command Injection is a technique where an attacker creates or alters existing SQL commands to expose hidden data, or to override valuable ones, or even to execute dangerous system level commands on the database host. This is accomplished by the application taking user input and combining it with static parameters to build a SQL query. The following examples are based on true stories, unfortunately.

Owing to the lack of input validation and connecting to the database on behalf of a superuser or the one who can create users, the attacker may create a superuser in your database.

예 15-6. Splitting the result set into pages ... and making superusers (PostgreSQL and MySQL)

<?php

$offset = argv[0]; // beware, no input validation!
$query  = "SELECT id, name FROM products ORDER BY name LIMIT 20 OFFSET $offset;";
// with PostgreSQL
$result = pg_exec($conn, $query);
// with MySQL
$result = mysql_query($query);

?>
Normal users click on the 'next', 'prev' links where the $offset is encoded into the URL. The script expects that the incoming $offset is a decimal number. However, what if someone tries to break in by appending a urlencode()'d form of the following to the URL

// in case of PostgreSQL
0;
insert into pg_shadow(usename,usesysid,usesuper,usecatupd,passwd)
    select 'crack', usesysid, 't','t','crack'
    from pg_shadow where usename='postgres';
--

// in case of MySQL
0;
UPDATE user SET Password=PASSWORD('crack') WHERE user='root';
FLUSH PRIVILEGES;

If it happened, then the script would present a superuser access to him. Note that 0; is to supply a valid offset to the original query and to terminate it.

참고: It is common technique to force the SQL parser to ignore the rest of the query written by the developer with -- which is the comment sign in SQL.

A feasible way to gain passwords is to circumvent your search result pages. The only thing the attacker needs to do is to see if there are any submitted variables used in SQL statements which are not handled properly. These filters can be set commonly in a preceding form to customize WHERE, ORDER BY, LIMIT and OFFSET clauses in SELECT statements. If your database supports the UNION construct, the attacker may try to append an entire query to the original one to list passwords from an arbitrary table. Using encrypted password fields is strongly encouraged.

예 15-7. Listing out articles ... and some passwords (any database server)

<?php

$query  = "SELECT id, name, inserted, size FROM products
                  WHERE size = '$size'
                  ORDER BY $order LIMIT $limit, $offset;";
$result = odbc_exec($conn, $query);

?>
The static part of the query can be combined with another SELECT statement which reveals all passwords:

'
union select '1', concat(uname||'-'||passwd) as name, '1971-01-01', '0' from usertable;
--

If this query (playing with the ' and --) were assigned to one of the variables used in $query, the query beast awakened.

SQL UPDATE's are also susceptible to attack. These queries are also threatened by chopping and appending an entirely new query to it. But the attacker might fiddle with the SET clause. In this case some schema information must be possessed to manipulate the query successfully. This can be acquired by examining the form variable names, or just simply brute forcing. There are not so many naming conventions for fields storing passwords or usernames.

예 15-8. From resetting a password ... to gaining more privileges (any database server)

<?php
$query = "UPDATE usertable SET pwd='$pwd' WHERE uid='$uid';";
?>
But a malicious user sumbits the value ' or uid like'%admin%'; -- to $uid to change the admin's password, or simply sets $pwd to "hehehe', admin='yes', trusted=100 " (with a trailing space) to gain more privileges. Then, the query will be twisted:

<?php

// $uid == ' or uid like'%admin%'; --
$query = "UPDATE usertable SET pwd='...' WHERE uid='' or uid like '%admin%'; --";

// $pwd == "hehehe', admin='yes', trusted=100 "
$query = "UPDATE usertable SET pwd='hehehe', admin='yes', trusted=100 WHERE
...;";

?>

A frightening example how operating system level commands can be accessed on some database hosts.

예 15-9. Attacking the database hosts operating system (MSSQL Server)

<?php

$query  = "SELECT * FROM products WHERE id LIKE '%$prod%'";
$result = mssql_query($query);

?>
If attacker submits the value a%' exec master..xp_cmdshell 'net user test testpass /ADD' -- to $prod, then the $query will be:

<?php

$query  = "SELECT * FROM products
                    WHERE id LIKE '%a%'
                    exec master..xp_cmdshell 'net user test testpass /ADD'--";
$result = mssql_query($query);

?>

MSSQL Server executes the SQL statements in the batch including a command to add a new user to the local accounts database. If this application were running as sa and the MSSQLSERVER service is running with sufficient privileges, the attacker would now have an account with which to access this machine.

참고: Some of the examples above is tied to a specific database server. This does not mean that a similar attack is impossible against other products. Your database server may be similarly vulnerable in another manner.

Avoiding techniques

You may plead that the attacker must possess a piece of information about the database schema in most examples. You are right, but you never know when and how it can be taken out, and if it happens, your database may be exposed. If you are using an open source, or publicly available database handling package, which may belong to a content management system or forum, the intruders easily produce a copy of a piece of your code. It may be also a security risk if it is a poorly designed one.

These attacks are mainly based on exploiting the code not being written with security in mind. Never trust any kind of input, especially that which comes from the client side, even though it comes from a select box, a hidden input field or a cookie. The first example shows that such a blameless query can cause disasters.

  • Never connect to the database as a superuser or as the database owner. Use always customized users with very limited privileges.

  • Check if the given input has the expected data type. PHP has a wide range of input validating functions, from the simplest ones found in Variable Functions and in Character Type Functions (e.g. is_numeric(), ctype_digit() respectively) and onwards to the Perl compatible Regular Expressions support.

  • If the application waits for numerical input, consider verifying data with is_numeric(), or silently change its type using settype(), or use its numeric representation by sprintf().

    예 15-10. A more secure way to compose a query for paging

    <?php

    settype    ($offset, 'integer');
    $query = "SELECT id, name FROM products ORDER BY name LIMIT 20 OFFSET $offset;";

    // please note %d in the format string, using %s would be meaningless
    $query = sprintf("SELECT id, name FROM products ORDER BY name LIMIT 20 OFFSET %d;",
                         $offset);

    ?>

  • Quote each non numeric user input which is passed to the database with addslashes() or addcslashes(). See the first example. As the examples shows, quotes burnt into the static part of the query is not enough, and can be easily cracked.

  • Do not print out any database specific information, especially about the schema, by fair means or foul. See also Error Reporting and Error Handling and Logging Functions.

  • You may use stored procedures and previously defined cursors to abstract data access so that users do not directly access tables or views, but this solution has another impacts.

Besides these, you benefit from logging queries either within your script or by the database itself, if it supports logging. Obviously, the logging is unable to prevent any harmful attempt, but it can be helpful to trace back which application has been circumvented. The log is not useful by itself, but through the information it contains. More detail is generally better than less.

이전 | 처음으로 | 다음
Filesystem Security | 위로 | Error Reporting


Error Reporting

With PHP security, there are two sides to error reporting. One is beneficial to increasing security, the other is detrimental.

A standard attack tactic involves profiling a system by feeding it improper data, and checking for the kinds, and contexts, of the errors which are returned. This allows the system cracker to probe for information about the server, to determine possible weaknesses. For example, if an attacker had gleaned information about a page based on a prior form submission, they may attempt to override variables, or modify them:

예 15-11. Attacking Variables with a custom HTML page

<form method="post" action="attacktarget?username=badfoo&amp;password=badfoo">
<input type="hidden" name="username" value="badfoo" />
<input type="hidden" name="password" value="badfoo" />
</form>

The PHP errors which are normally returned can be quite helpful to a developer who is trying to debug a script, indicating such things as the function or file that failed, the PHP file it failed in, and the line number which the failure occured in. This is all information that can be exploited. It is not uncommon for a php developer to use show_source(), highlight_string(), or highlight_file() as a debugging measure, but in a live site, this can expose hidden variables, unchecked syntax, and other dangerous information. Especially dangerous is running code from known sources with built-in debugging handlers, or using common debugging techniques. If the attacker can determine what general technique you are using, they may try to brute-force a page, by sending various common debugging strings:

예 15-12. Exploiting common debugging variables

<form method="post" action="attacktarget?errors=Y&amp;showerrors=1&amp;debug=1">
<input type="hidden" name="errors" value="Y" />
<input type="hidden" name="showerrors" value="1" />
<input type="hidden" name="debug" value="1" />
</form>

Regardless of the method of error handling, the ability to probe a system for errors leads to providing an attacker with more information.

For example, the very style of a generic PHP error indicates a system is running PHP. If the attacker was looking at an .html page, and wanted to probe for the back-end (to look for known weaknesses in the system), by feeding it the wrong data they may be able to determine that a system was built with PHP.

A function error can indicate whether a system may be running a specific database engine, or give clues as to how a web page or programmed or designed. This allows for deeper investigation into open database ports, or to look for specific bugs or weaknesses in a web page. By feeding different pieces of bad data, for example, an attacker can determine the order of authentication in a script, (from the line number errors) as well as probe for exploits that may be exploited in different locations in the script.

A filesystem or general PHP error can indicate what permissions the webserver has, as well as the structure and organization of files on the web server. Developer written error code can aggravate this problem, leading to easy exploitation of formerly "hidden" information.

There are three major solutions to this issue. The first is to scrutinize all functions, and attempt to compensate for the bulk of the errors. The second is to disable error reporting entirely on the running code. The third is to use PHP's custom error handling functions to create your own error handler. Depending on your security policy, you may find all three to be applicable to your situation.

One way of catching this issue ahead of time is to make use of PHP's own error_reporting(), to help you secure your code and find variable usage that may be dangerous. By testing your code, prior to deployment, with E_ALL, you can quickly find areas where your variables may be open to poisoning or modification in other ways. Once you are ready for deployment, by using E_NONE, you insulate your code from probing.

예 15-13. Finding dangerous variables with E_ALL

<?php
if ($username) {  // Not initialized or checked before usage
    $good_login = 1;
}
if ($good_login == 1) { // If above test fails, not initialized or checked before usage
    readfile ("/highly/sensitive/data/index.html");
}
?>

이전 | 처음으로 | 다음
Database Security | 위로 | Using Register Globals


Using Register Globals

Perhaps the most controversial change in PHP is when the default value for the PHP directive register_globals went from ON to OFF in PHP 4.2.0. Reliance on this directive was quite common and many people didn't even know it existed and assumed it's just how PHP works. This page will explain how one can write insecure code with this directive but keep in mind that the directive itself isn't insecure but rather it's the misuse of it.

When on, register_globals will inject (poison) your scripts will all sorts of variables, like request variables from HTML forms. This coupled with the fact that PHP doesn't require variable initialization means writing insecure code is that much easier. It was a difficult decision, but the PHP community decided to disable this directive by default. When on, people use variables yet really don't know for sure where they come from and can only assume. Internal variables that are defined in the script itself get mixed up with request data sent by users and disabling register_globals changes this. Let's demonstrate with an example misuse of register_globals:

예 15-14. Example misuse with register_globals = on

<?php
// define $authorized = true only if user is authenticated
if (authenticated_user()) {
    $authorized = true;
}

// Because we didn't first initialize $authorized as false, this might be
// defined through register_globals, like from GET auth.php?authorized=1
// So, anyone can be seen as authenticated!
if ($authorized) {
    include "/highly/sensitive/data.php";
}
?>

When register_globals = on, our logic above may be compromised. When off, $authorized can't be set via request so it'll be fine, although it really is generally a good programming practice to initialize variables first. For example, in our example above we might have first done $authorized = false. Doing this first means our above code would work with register_globals on or off as users by default would be unauthorized.

Another example is that of sessions. When register_globals = on, we could also use $username in our example below but again you must realize that $username could also come from other means, such as GET (through the URL).

예 15-15. Example use of sessions with register_globals on or off

<?php
// We wouldn't know where $username came from but do know $_SESSION is
// for session data
if (isset($_SESSION['username'])) {

    echo "Hello <b>{$_SESSION['username']}</b>";

} else {

    echo "Hello <b>Guest</b><br />";
    echo "Would you like to login?";

}
?>

It's even possible to take preventative measures to warn when forging is being attempted. If you know ahead of time exactly where a variable should be coming from, you can check to see if the submitted data is coming from an inappropriate kind of submission. While it doesn't guarantee that data has not been forged, it does require an attacker to guess the right kind of forging. If you don't care where the request data comes from, you can use $_REQUEST as it contains a mix of GET, POST and COOKIE data. See also the manual section on using variables from outside of PHP.

예 15-16. Detecting simple variable poisoning

<?php
if (isset($_COOKIE['MAGIC_COOKIE'])) {

    // MAGIC_COOKIE comes from a cookie.
    // Be sure to validate the cookie data!

} elseif (isset($_GET['MAGIC_COOKIE']) || isset($_POST['MAGIC_COOKIE'])) {

   mail("admin@example.com", "Possible breakin attempt", $_SERVER['REMOTE_ADDR']);
   echo "Security violation, admin has been alerted.";
   exit;

} else {

   // MAGIC_COOKIE isn't set through this REQUEST

}
?>

Of course, simply turning off register_globals does not mean your code is secure. For every piece of data that is submitted, it should also be checked in other ways. Always validate your user data and initialize your variables! To check for unitialized variables you may turn up error_reporting() to show E_NOTICE level errors.

자동 전역: 사용상 주의: PHP 4.1.0부터, $_GET, $_POST, $_SERVER 등의 자동 전역 배열을 사용할 수 있습니다. 더 자세한 내용은 매뉴얼 superglobals 섹션을 읽어보십시오.

이전 | 처음으로 | 다음
Error Reporting | 위로 | User Submitted Data


User Submitted Data

The greatest weakness in many PHP programs is not inherent in the language itself, but merely an issue of code not being written with security in mind. For this reason, you should always take the time to consider the implications of a given piece of code, to ascertain the possible damage if an unexpected variable is submitted to it.

예 15-17. Dangerous Variable Usage

<?php
// remove a file from the user's home directory... or maybe
// somebody else's?
unlink ($evil_var);

// Write logging of their access... or maybe an /etc/passwd entry?
fwrite ($fp, $evil_var);

// Execute something trivial.. or rm -rf *?
system ($evil_var);
exec ($evil_var);

?>
You should always carefully examine your code to make sure that any variables being submitted from a web browser are being properly checked, and ask yourself the following questions:

  • Will this script only affect the intended files?

  • Can unusual or undesirable data be acted upon?

  • Can this script be used in unintended ways?

  • Can this be used in conjunction with other scripts in a negative manner?

  • Will any transactions be adequately logged?

By adequately asking these questions while writing the script, rather than later, you prevent an unfortunate re-write when you need to increase your security. By starting out with this mindset, you won't guarantee the security of your system, but you can help improve it.

You may also want to consider turning off register_globals, magic_quotes, or other convenience settings which may confuse you as to the validity, source, or value of a given variable. Working with PHP in error_reporting(E_ALL) mode can also help warn you about variables being used before they are checked or initialized (so you can prevent unusual data from being operated upon).

이전 | 처음으로 | 다음
Using Register Globals | 위로 | Hiding PHP


Hiding PHP

In general, security by obscurity is one of the weakest forms of security. But in some cases, every little bit of extra security is desirable.

A few simple techniques can help to hide PHP, possibly slowing down an attacker who is attempting to discover weaknesses in your system. By setting expose_php = off in your php.ini file, you reduce the amount of information available to them.

Another tactic is to configure web servers such as apache to parse different filetypes through PHP, either with an .htaccess directive, or in the apache configuration file itself. You can then use misleading file extensions:

예 15-18. Hiding PHP as another language

# Make PHP code look like other code types
AddType application/x-httpd-php .asp .py .pl
Or obscure it completely:

예 15-19. Using unknown types for PHP extensions

# Make PHP code look like unknown types
AddType application/x-httpd-php .bop .foo .133t
Or hide it as HTML code, which has a slight performance hit because all HTML will be parsed through the PHP engine:

예 15-20. Using HTML types for PHP extensions

# Make all PHP code look like HTML
AddType application/x-httpd-php .htm .html
For this to work effectively, you must rename your PHP files with the above extensions. While it is a form of security through obscurity, it's a minor preventative measure with few drawbacks.

이전 | 처음으로 | 다음
User Submitted Data | 위로 | Keeping Current


Keeping Current

PHP, like any other large system, is under constant scrutiny and improvement. Each new version will often include both major and minor changes to enhance and repair security flaws, configuration mishaps, and other issues that will affect the overall security and stability of your system.

Like other system-level scripting languages and programs, the best approach is to update often, and maintain awareness of the latest versions and their changes.

이전 | 처음으로 | 다음
Hiding PHP | 위로 | 기능


기능

PHP 매뉴얼
이전 다음

IV. 기능

차례
16. PHP로 HTTP 인증하기
17. 쿠키
18. 파일 업로드 다루기
19. 원격 파일 사용하기
20. 연결 제어
21. 영구적인 데이터베이스 접속
22. 안전 모드
23. 커맨드 라인에서 PHP 사용하기

이전 | 처음으로 | 다음
Keeping Current |  | PHP로 HTTP 인증하기


PHP로 HTTP 인증하기

PHP 매뉴얼
이전 다음

16. 장. PHP로 HTTP 인증하기

PHP를 이용한 HTTP 인증은 아파치 모듈로 실행할때만 사용할 수 있으며, CGI 버전에서는 사용할 수 없습니다. 아파치 모듈에서 PHP 스크립트가 header() 함수를 이용하여 "인증 요구" 메세지를 클라이언트 브라우저에 전송함으로써, 사용자명/패스워드 입력창을 띄울 수 있습니다. 사용자가 사용자명과 패스워드를 입력하면, PHP 스크립트의 URL이 다시 호출하고, 예약 정의 변수 PHP_AUTH_USER, PHP_AUTH_PW, AUTH_TYPE에 사용자명, 패스워드, 인증 형식이 들어갑니다. 이 예약 정의 변수들은 $_SERVER와 $HTTP_SERVER_VARS 배열로 확인할 수 있습니다. 현재는 "Basic" 인증만을 지원합니다. 자세한 정보는 header() 함수를 참고하십시오.

PHP 버전 주의: $_SERVER 등의 자동 전역 변수는 PHP 4.1.0부터 사용할 수 있습니다. $HTTP_SERVER_VARS는 PHP 3부터 사용할 수 있습니다.

다음은 페이지에 대해 클라이언트 인증을 강제하는 예제 스크립트입니다:

예 16-1. HTTP 인증 예제

<?php
  if (!isset($_SERVER['PHP_AUTH_USER'])) {
    header('WWW-Authenticate: Basic realm="My Realm"');
    header('HTTP/1.0 401 Unauthorized');
    echo '사용자가 취소 버튼을 눌렀을 때 전송되는 텍스트';
    exit;
  } else {
    echo "<p>안녕하세요, {$_SERVER['PHP_AUTH_USER']}.</p>";
    echo "<p>{$_SERVER['PHP_AUTH_PW']}를 패스워드로 접속했습니다.</p>";
  }
?>

호환성 주의: HTTP 헤더열을 코딩할때는 주의를 기울이십시오. 모든 클라이언트에 대해 최대의 호환성을 보장받기 위해서는, 키워드 "Basic"은 대문자 "B"로 쓰여져야하고, 렐름 메세지는 이중 인용 부호(")로 감싸져야하며, HTTP/1.0 401 헤더열에서 401 코드는 정확히 하나의 스페이스를 가져야합니다.

위 예제와 같이 단순히 PHP_AUTH_USER와 PHP_AUTH_PW를 출력하는 대신, 유저네임과 패스워드를 확인해서 인증을 할 수 있습니다. 데이터베이스에 요구를 하거나, dbm 파일에서 유저를 찾아낼 수 있습니다.

인터넷 익스플로러 브라우저의 버그에 주의하십시오. 헤더의 순서에 매우 까다롭습니다. WWW-Authenticate 헤더를 HTTP/1.0 401 헤더 전에 전송하는 것이 현재 사용 가능한 방법입니다.

PHP 4.3.0부터, 전통적인 외부 메카니즘을 통해서 인증된 페이지의 패스워드를 누출하는 스크립트의 작성을 방지하기 위해서, 각각의 페이지에 대한 외부 인증과 안전 모드가 활성화되었을때, PHP_AUTH 변수를 설정하지 않습니다. 대신, 외부 인증 유저를 확인하기 위해서 REMOTE_USER를 사용할 수 있습니다. 그러므로, $_SERVER['REMOTE_USER']를 사용하십시오.

설정 주의: PHP는 외부 인증을 검증할 때 AuthType 지시어의 존재를 확인합니다.

이 방식은 비인증 URL을 조작해서 같은 서버의 인증 URL의 패스워드를 훔치는 것은 방지할 수 없다는 점에 주의하십시오.

넷스케이프 네비게이터와 인터넷 익스플로러는 서버 응답 401을 받았을 때, 로컬 브라우저창의 인증 캐쉬를 클리어합니다. 이것은 강제로 유저네임과 패스워드를 재입력하게 함으로써, 사용자를 '로그 아웃'하는 효과를 가집니다. 몇몇 사람들은 이것을 "시간 제한" 로그인이나, "로그 아웃" 버튼을 제공을 통해 사용합니다.

예 16-2. 새 이름/패스워드를 강제하는 HTTP 인증 예제

<?php
  function authenticate() {
    header('WWW-Authenticate: Basic realm="테스트 인증 시스템"');
    header('HTTP/1.0 401 Unauthorized');
    echo "이 자원에 접근하기 위해서는 유효한 로그인 ID와 패스워드를 입력해야 합니다.\n";
    exit;
  }

  if (!isset($_SERVER['PHP_AUTH_USER']) ||
      ($_POST['SeenBefore'] == 1 && $_POST['OldAuth'] == $_SERVER['PHP_AUTH_USER'])) {
   authenticate();
  }
  else {
   echo "<p>어서오십시오: {$_SERVER['PHP_AUTH_USER']}<br />";
   echo "이전: {$_REQUEST['OldAuth']}";
   echo "<form action='{$_SERVER['PHP_SELF']}' METHOD='post'>\n";
   echo "<input type='hidden' name='SeenBefore' value='1' />\n";
   echo "<input type='hidden' name='OldAuth' value='{$_SERVER['PHP_AUTH_USER']}' />\n";
   echo "<input type='submit' value='재인증' />\n";
   echo "</form></p>\n";
  }
?>

이 행동은 HTTP Basic 인증 표준에 필요하지 않기 때문에, 이것에 의존해서는 안됩니다. Lynx로 테스트 했을때, Lynx는 401 서버 응답에 인증 정보를 클리어하지 않기에, 이전의 인증 정보를 그대로 이용해서 자원을 얻으려고 시도합니다. 대신, 사용자가 '_' 키를 누름으로써 인증 정보를 삭제할 수 있습니다.

PHP 4.3.3까지, 마이크로소프트의 IIS 서버를 CGI 버전의 PHP로 사용할 때, IIS의 제약으로 인하여 HTTP 인증은 작동하지 않습니다. PHP 4.3.3 이상에서 작동하게 하려면, IIS 환경 설정 "디렉토리 보안"을 수정해야 합니다. "수정"을 클릭하고, "익명 접근"만을 체크하고, 다른 모든 필드는 체크를 해제하십시오.

IIS 모듈(ISAPI)를 사용할 때 다른 제약은, PHP_AUTH_* 변수를 사용할 수 없는 대신, HTTP_AUTHORIZATION 변수를 사용하게 됩니다. 즉, 다음의 코드를 고려해야합니다. list($user, $pw) = explode(':', base64_decode(substr($_SERVER['HTTP_AUTHORIZATION'], 6)));

IIS 주의:: IIS에서 HTTP 인증을 작동하게 하려면, PHP 지시자 cgi.rfc2616_headers를 0(초기값)으로 설정해야 합니다.

참고: 안전 모드에서는 스크립트의 uid가 WWW-Authenticate 헤더의 realm 부분에 추가됩니다.

이전 | 처음으로 | 다음
기능 | 위로 | 쿠키


쿠키

PHP 매뉴얼
이전 다음

17. 장. 쿠키

PHP는 HTTP 쿠키를 투명하게 지원합니다. 쿠키는 원격 브라우저에 데이터를 저장하여 다시 온 사용자를 추적하거나 식별하는 메카니즘입니다. setcookie()나 setrawcookie() 함수를 사용하여 쿠키를 설정할 수 있습니다. 쿠키는 HTTP 헤더의 일부분이기에, setcookie()는 브라우저에 어떠한 출력이 이루어지기 전에 호출해야 합니다. 이는 header()가 가지고 있는 것과 동일한 제약입니다. 출력 버퍼링 함수를 사용하여 쿠키 설정이나 헤더 전송을 결정할때까지 스크립트 출력을 지연할 수 있습니다.

클라이언트로부터 전송된 어떠한 쿠키 데이터라도 GET과 POST 방식의 데이터와 마찬가지로, register_globals와 variables_order 환경 설정 변수에 의존하여 자동적으로 PHP 변수로 변환됩니다. 하나의 쿠키 이름에 여러 변수를 지정하고 싶을때는, 단순히 쿠키 이름에 []를 추가하면 됩니다.

PHP 4.1.0과 이후에는, 어떠한 쿠키라도 클라이언트로부터 전송받았을 때, $_COOKIE 자동 전역 배열이 항상 설정됩니다. 이전의 PHP 버전에서는 track_vars 환경 설정 변수가 설정되었을 때, (이 설정은 PHP 4.0.3부터는 항상 on 입니다) $HTTP_COOKIE_VARS가 항상 설정됩니다.

브라우저 버그에 대한 정보를 포함한 더 자세한 내용은 setcookie()나 setrawcookie() 함수를 참고하십시오.

이전 | 처음으로 | 다음
PHP로 HTTP 인증하기 | 위로 | 파일 업로드 다루기


파일 업로드 다루기

PHP 매뉴얼
이전 다음

18. 장. 파일 업로드 다루기

차례
POST 방식 업로드
에러 메세지 설명
일반적인 문제
복수 파일 전송하기
PUT 방식 지원

POST 방식 업로드

PHP는 RFC-1867 호환 브라우저(넷스케이프 네비게이터 3 이상, 마이크로소프트 인터넷 익스플로러 3 이상을 포함)로부터 파일 업로드를 받을 수 있습니다. 이 기능은 사람들이 텍스트와 바이너리 파일을 동시에 업로드 할 수 있게 합니다. PHP의 인증 및 파일 관리 함수를 이용해서, 업로드를 할 수 있는 사람 및 업로드한 파일의 처리를 완전히 제어할 수 있습니다.

관련 환경설정: php.ini의 file_uploads, upload_max_filesize, upload_tmp_dir, post_max_size 지시어를 참고하십시오.

PHP는 넷스케이프 컴포저와 W3C의 Amaya 클라이언트가 사용하는 PUT 방식 파일 업로드도 지원합니다. 자세한 내용은 PUT 방식 지원을 참고하십시오.

파일 업로드 화면은 다음과 같은 특별한 폼으로 만들어집니다:

예 18-1. 파일 업로드 폼

<form enctype="multipart/form-data" action="_URL_" method="post">
 <input type="hidden" name="MAX_FILE_SIZE" value="30000" />
 이 파일을 전송합니다: <input name="userfile" type="file" />
 <input type="submit" value="파일 전송" />
</form>

위 예제의 "_URL_"을 변경하여, PHP 파일을 지시하도록 해야합니다. MAX_FILE_SIZE 히든 필드는 파일 입력 필드 앞에 위치해야 하며, 최대 파일크기(바이트로 지시)를 값으로 가집니다. 또한, 파일 업로드 폼은 enctype="multipart/form-data"을 가지고 있어야 하며, 그렇지 않으면 파일 업로드는 작동하지 않습니다.

주의

MAX_FILE_SIZE는 PHP가 확인하기도 하지만, 브라우저에 대한 권고입니다. 이 값을 변경하는건 매우 간단하기에, 크기가 큰 파일을 막기 위해서는 이 기능에 의존해서는 안됩니다. 대신, 최대 크기에 관한 PHP 설정은 속일 수 없습니다. 그러나 MAX_FILE_SIZE 폼 변수는 사용자가 파일이 너무 크다는 것을 파악하기 위해서 실제 전송을 하는 동안 기다릴 필요를 없애줍니다.

업로드한 파일을 정의하는 변수는 PHP 버전과 환경 설정에 따라 달라집니다. 자동 전역 $_FILES가 PHP 4.1.0부터 존재합니다. $HTTP_POST_FILES 배열은 PHP 4.1.0 이전에도 존재합니다. 이 배열들은 업로드 된 파일의 모든 정보를 가지고 있습니다. $_FILES를 사용하는 편을 권장합니다. PHP 지시어 register_globals가 on일때는, 관련된 변수명도 존재합니다. register_globals의 기본값은 PHP 4.2.0부터 off입니다.

예제 스크립트에서 $_FILES의 내용은 다음과 같습니다. 위 예제 스크립트에서 사용한 파일 업로드 이름 userfile로 표현함에 주의하십시오. 어떠한 이름이라도 가질 수 있습니다.

$_FILES['userfile']['name']

클라이언트 머신에 존재하는 파일의 원래 이름.

$_FILES['userfile']['type']

브라우저가 이 정보를 제공할 경우에, 파일의 mime 형식. 예를 들면 "image/gif".

$_FILES['userfile']['size']

업로드된 파일의 바이트로 표현한 크기.

$_FILES['userfile']['tmp_name']

서버에 저장된 업로드된 파일의 임시 파일 이름.

$_FILES['userfile']['error']

파일 업로드에 관련한 에러 코드. ['error']는 PHP 4.2.0에서 추가되었습니다.

참고: PHP 4.1.0 이전 버전에서는 $HTTP_POST_FILES이고, $_FILES와 같은 자동 전역 변수는 존재하지 않습니다. PHP 3는 $HTTP_POST_FILES를 지원하지 않습니다.

php.ini에서 register_globals가 on일때, 변수가 추가로 사용 가능합니다. 예를 들면, $userfile_name은 $_FILES['userfile']['name']과 동일하고, $userfile_type은 $_FILES['userfile']['type']과 동일합니다. PHP 4.2.0부터 register_globals의 기본값이 off임에 주의하십시오. 이 지시어에 의존하지 않는 방법을 권장합니다.

php.ini에서 upload_tmp_dir을 이용하여 다른 위치를 지정하지 않는 한, 파일은 서버의 기본 임시 디렉토리에 저장됩니다. 서버의 기본 디렉토리는 PHP를 실행하는 환경의 환경 변수 TMPDIR을 통해서 변경할 수 있습니다. PHP 스크립트 내부에서 putenv()를 통해서 설정하는 것은 작동하지 않습니다. 물론, 이 환경 변수는 업로드된 파일에 다른 작업을 할 때 사용할 수 있습니다.

예 18-2. 파일 업로드 확인하기

추가 정보는 is_uploaded_file()와 move_uploaded_file()에 대한 함수 정보를 참고하십시오. 다음 예제는 폼에서 전송된 파일 업로드를 처리합니다.

<?php
// 4.1.0 이전의 PHP에서는, $_FILES 대신에 $HTTP_POST_FILES를
// 사용해야 합니다.

$uploaddir = '/var/www/uploads/';
$uploadfile = $uploaddir . $_FILES['userfile']['name'];

print "<pre>";
if (move_uploaded_file($_FILES['userfile']['tmp_name'], $uploadfile)) {
    print "파일이 존재하고, 성공적으로 업로드 되었습니다.";
    print "추가 디버깅 정보입니다:\n";
    print_r($_FILES);
} else {
    print "파일 업로드 공격의 가능성이 있습니다! 디버깅 정보입니다:\n";
    print_r($_FILES);
}
print "</pre>";

?>

업로드된 파일을 받는 PHP 스크립트는 업로드된 파일로 무엇을 할 지 결정하는 로직을 포함하고 있어야 합니다. 예를 들면, $_FILES['userfile']['size'] 변수는 너무 작거나 큰 파일을 처리하는데 이용할 수 있습니다. $_FILES['userfile']['type'] 변수는 형식 기준에 맞지 않는 파일을 처리하는데 이용할 수 있습니다. PHP 4.2.0부터, $_FILES['userfile']['error']를 이용하여 에러 코드에 따라서 처리하게 할 수 있습니다. 어떠한 로직이건 간에, 임시 디렉토리로부터 파일을 지우거나 다른 곳으로 이동해야 합니다.

폼에서 어떠한 파일도 선택하지 않으면, PHP는 $_FILES['userfile']['size']를 0으로, $_FILES['userfile']['tmp_name']을 none으로 반환합니다.

요청이 끝날 때, 이동하거나 이름을 변경하지 않은 임시 디렉토리의 파일은 삭제됩니다.

이전 | 처음으로 | 다음
쿠키 | 위로 | 에러 메세지 설명


에러 메세지 설명

PHP 4.2.0부터, PHP는 파일 배열에 적절한 에러 코드를 반환합니다. 에러 코드는 PHP로 파일을 업로드 했을때 만들어지는 파일 배열의 ['error'] 세그먼트에서 확인할 수 있습니다. 예를 들면, $_FILES['userfile']['error']에서 확인할 수 있을겁니다.

UPLOAD_ERR_OK

값: 0; 오류 없이 파일 업로드가 성공했습니다.

UPLOAD_ERR_INI_SIZE

값: 1; 업로드한 파일이 php.ini upload_max_filesize 지시어보다 큽니다.

UPLOAD_ERR_FORM_SIZE

값: 2; 업로드한 파일이 HTML 폼에서 지정한 MAX_FILE_SIZE 지시어보다 큽니다.

UPLOAD_ERR_PARTIAL

값: 3; 파일이 일부분만 전송되었습니다.

UPLOAD_ERR_NO_FILE

값: 4; 파일이 전송되지 않았습니다.

참고: 이들은 PHP 4.3.0에서 PHP 상수가 되었습니다.

이전 | 처음으로 | 다음
파일 업로드 다루기 | 위로 | 일반적인 문제


일반적인 문제

MAX_FILE_SIZE는 ini 설정 upload_max_filesize보다 큰 파일 크기를 지정할 수 없습니다. 기본값은 2 메가바이트입니다.

메모리 제한을 활성화하면, 큰 값의 memory_limit가 필요합니다. memory_limit를 충분히 크게 설정했는지 확인하십시오.

max_execution_time을 너무 작게 설정하면, 스크립트 실행 시간이 이 값을 초과합니다. max_execution_time을 충분히 크게 설정했는지 확인하십시오.

참고: max_execution_time은 스크립트 자신의 실행 시간에만 영향을 미칩니다. system(), sleep() 함수 등의 시스템 호출, 데이터베이스 쿼리, 파일 업로드 과정에 걸리는 시간 등 스크립트 외부 실행에 소모하는 시간은 스크립트 최대 실행 시간을 측정할 때 포함하지 않습니다.

max_input_time은 스크립트가 입력을 받아들이는 최대 시간을 초 단위로 지정합니다; 이는 파일 업로드를 포함합니다. 커다란 파일이나 여러 개의 파일을 전송하거나, 사용자가 느린 회선을 사용한다면 기본값인 60초를 초과할 수 있습니다.

post_max_size을 너무 작게 설정하면, 큰 파일은 업로드할 수 없습니다. post_max_size을 충분히 크게 설정했는지 확인해보십시오.

파일에 대한 검증을 하지 않으면, 사용자가 다른 디렉토리의 중요한 정보에 접근할 수 있습니다.

CERN httpd는 클라이언트에서 보내지는 content-type 마임 헤더의 첫번째 공백을 제거하는 것에 주의하십시오. 이 문제로 인해서, CERN httpd는 파일 업로드 기능을 지원하지 않습니다.

많은 양의 디렉토리 목록 형식으로 인해, 확장 형식의 이름(공백을 포함하는 등의)을 가지는 파일을 정상적으로 다룰 수 있는 보장은 없습니다.

하나의 폼 변수에 (입력 이름으로 foo[] 등을 사용하여) 보통의 입력 필드와 파일 업로드 필드를 섞어서는 안됩니다.

이전 | 처음으로 | 다음
에러 메세지 설명 | 위로 | 복수 파일 전송하기


복수 파일 전송하기

복수 파일은 input에서 다른 name을 사용해서 업로드 할 수 있습니다.

동시에 복수 파일을 업로드하고 배열로 조직화한 정보를 얻을 수 있습니다. 이를 위해서는, HTML 폼에 복수 선택이나 체크박스와 동일한 방식으로 동일한 이름의 배열형 구문을 갖추면 됩니다:

참고: 복수 파일 업로드 지원은 PHP 3.0.10에서 추가되었습니다.

예 18-3. 복수 파일 전송하기

<form action="file-upload.php" method="post" enctype="multipart/form-data">
  이 파일들을 전송합니다:<br />
  <input name="userfile[]" type="file" /><br />
  <input name="userfile[]" type="file" /><br />
  <input type="submit" value="파일 전송" />
</form>

위 폼을 전송하면, 배열 $_FILES['userfile'], $_FILES['userfile']['name'], $_FILES['userfile']['size']가 초기화됩니다. (버전 4.1.0 이전에는 $HTTP_POST_FILES) register_globals가 on이라면, 전송된 파일들에 대한 전역 변수도 초기화됩니다. 이 각각에 대해서 전송된 파일에 따른 숫자로 정렬된 배열을 가지게 됩니다.

예를 들어, /home/test/review.html와 /home/test/xwp.out가 전송되었다고 합시다. 이 경우에, $_FILES['userfile']['name'][0]의 값은 review.html이고, $_FILES['userfile']['name'][1]의 값은 xwp.out가 됩니다. 동일하게, $_FILES['userfile']['size'][0]는 review.html의 크기를 가지게 되며, 나머지도 마찬가지입니다.

$_FILES['userfile']['name'][0], $_FILES['userfile']['tmp_name'][0], $_FILES['userfile']['size'][0], $_FILES['userfile']['type'][0]이 설정됩니다.

이전 | 처음으로 | 다음
일반적인 문제 | 위로 | PUT 방식 지원


PUT 방식 지원

PUT 방식 지원은 PHP 3와 PHP 4에서 차이가 있습니다. PHP 4에서는, 표준 입력 스트림으로 HTTP PUT의 내용을 읽어야 합니다.

예 18-4. PHP 4로 HTTP PUT 파일을 저장하기

<?php
/* PUT 데이터는 stdin 스트림으로 들어옵니다. */
$putdata = fopen("php://stdin", "r");

/* 쓰기 위한 파일을 엽니다. */
$fp = fopen("myputfile.ext", "w");

/* 한번에 1kb씩 읽어서 파일에 씁니다. */
while ($data = fread($putdata, 1024))
  fwrite($fp, $data);

/* 스트림을 닫습니다. */
fclose($fp);
fclose($putdata);
?>

참고: 아래의 문서는 PHP 3에만 해당합니다.

PHP는 Netscape Composer나 W3C Amaya 등의 클라이언트에서 사용하는 HTTP PUT 방식에 대한 지원을 제공합니다. PUT 요청은 파일 업로드보다 단순하고 다음과 같은 식으로 이루어집니다.

PUT /path/filename.html HTTP/1.1

일반적으로 원격 클라이언트가 웹 트리의 /path/filename.html에 내용을 저장하는걸 의미합니다. 아파치나 PHP가 웹 트리의 모든 파일에 누구나 자동적으로 덮어쓰게 하는 것은 좋은 생각이 아닙니다. 그래서, 웹 서버에 이러한 요청이 들어왔을때, PHP 스크립트를 통해서 다루도록 할 수 있습니다. 아파치에서는 Script 지시자를 통해 지정할 수 있습니다. 아파치 환경 설정 파일의 거의 모든 곳에서 지정할 수 있습니다. 일반적으로는 <Directory> 블록이나 <Virtualhost> 블록의 내부에 위치하게 됩니다. 다음 줄을 추가하면 됩니다:

Script PUT /put.php

이는 아파치가 이 줄이 들어가 있는 URI에 해당하는 모든 PUT 요청을 put.php 스크립트에 전달하게 합니다. 물론, .php 확장자에 대해 PHP가 사용 가능한 상태여야 합니다.

put.php 파일 안에서는 다음과 같은 작업을 해야 합니다:

<?php copy($PHP_UPLOADED_FILE_NAME, $DOCUMENT_ROOT . $REQUEST_URI); ?>

파일을 원격 클라이언트에서 요청한 위치로 복사합니다. 파일 복사가 이루어지기 전에 몇가지 체크나 사용자 인증을 할 수 있습니다. 여기서 보였듯이 PHP는 PUT 방식 요청을 POST 방식을 다루는 것과 마찬가지로 임시 파일로 저장합니다. 요청이 끝날 때, 임시 파일은 삭제됩니다. 그러므로, PUT을 다루는 PHP 스크립트는 파일을 어딘가로 복사해야합니다. 임시 파일의 파일명은 $PHP_PUT_FILENAME 변수에 들어있고, 대상 파일명의 지정은 $REQUEST_URI에서 확인할 수 있습니다. (아파치가 아닌 경우 다를 수 있습니다) 대상 파일 이름은 원격 클라이언트가 지정합니다. 이 클라이언트로부터의 지정을 무시할 수 있습니다. 예를 들면, 모든 전송 파일을 특별한 업로드 디렉토리로 복사할 수 있습니다.

이전 | 처음으로 | 다음
복수 파일 전송하기 | 위로 | 원격 파일 사용하기


원격 파일 사용하기

PHP 매뉴얼
이전 다음

19. 장. 원격 파일 사용하기

php.ini에서 allow_url_fopen을 활성화시키면, 대부분의 함수에 파일명의 인자로 HTTP와 FTP URL을 사용할수 있다. 이와 더불어 URL을 include(), include_once(), require(), require_once() 구문에서 사용할수 있다. PHP에 의해 지원되는 프로토콜에 대한 정보는 부록 J를 참고한다.

참고: PHP 4.0.3 이하에서 URL 래퍼(wrapper)를 사용하기 위해서는 configure 옵션으로 --enable-url-fopen-wrapper을 명시할 필요가 있다.

참고: PHP 4.3 이하 버전의 PHP의 윈도우 버전은 다음 함수에서 원격 파일 접근을 지원하지 않는다: include(), include_once(), require(), require_once(), 그리고 참고문헌 XLI, Image Functions 내의 imagecreatefromXXX 함수.

예를 들어, 이 기능을 사용하여 원격 웹 서버가 출력하는 내용을 파일로 열고, 그 출력 내용에서 원하는 데이타를 분석하여, 이 원하는 데이타로 데이타베이스 질의에 사용하거나, 웹 사이트에 맞는 모양으로 변형 시켜 출력할 수 있다

예 19-1. 원격 페이지의 제목을 가져오기

<?php
$file = fopen ("http://www.php.net/", "r");
if (!$file) {
    echo "<p>Unable to open remote file.\n";
    exit;
}
while (!feof ($file)) {
    $line = fgets ($file, 1024);
    /* This only works if the title and its tags are on one line */
    if (eregi ("<title>(.*)</title>", $line, $out)) {
        $title = $out[1];
        break;
    }
}
fclose($file);
?>

해당 서버에 권한이 있는 사용자로 접속할수 있다면 FTP를 이용해 파일에 작성할 수도 있다. 이 방법으로 새로운 파일만 생성할수 있다. 기존의 파일을 덮어쓰려고 하면, fopen() 호출시에 실패하게 될것이다.

'anonymous'가 아닌 사용자로 접속하려면, URL내에 username을 (필요하다면 password도) 다음과 같이 명시해야 한다 : 'ftp://user:password@ftp.example.com/path/to/file'. (또한 HTTP에서 Basic authentication을 사용한 인증을 요구하는 경우에도 이와 같은 문법을 사용할 수 있다.)

예 19-2. 원격 서버에 데이터 저장하기

<?php
$file = fopen ("ftp://ftp.php.net/incoming/outputfile", "w");
if (!$file) {
    echo "<p>Unable to open remote file for writing.\n";
    exit;
}
/* Write the data here. */
fputs ($file, "$HTTP_USER_AGENT\n");
fclose ($file);
?>

참고: 위의 예제를 보고, 이 테크닉을 사용하여 remote log를 작성할 수 있겠다고 생각할 수도 있다. 그러나 불행하게도 원격 파일이 이미 존재하면 fopen() 호출은 실패할것이기 때문에 동작하지 않을것이다. 그와 같은 분산 log를 수행하려면 syslog()를 참고하도록 한다.

이전 | 처음으로 | 다음
PUT 방식 지원 | 위로 | 연결 제어


연결 제어

PHP 매뉴얼
이전 다음

20. 장. 연결 제어

참고: 이 기능은 PHP version 3.0.7 이후부터 적용된 것들이다.

내부적으로 PHP는 연결의 상태를 다음 3가지중 하나로 설정한다. :

  • 0 - NORMAL

  • 1 - ABORTED

  • 2 - TIMEOUT

PHP 스크립트가 일반적으로 실행되고 있을 때는 NORMAL 상태가 active된다. 만약 원격 클라이언트가 연결을 끊게되면 ABORTED 상태 flag가 켜지게 된다. 보통 클라이언트가 연결을 끊는 것은 사용자가 STOP 버튼을 눌렀을 때 일어난다. 만약 PHP가 설정한 시간 제한에 (set_time_limit()을 보라) 걸리게 되면 TIMEOUT 상태 flag가 켜지게 된다.

클라이언트가 연결을 끊었을 때 스크립트가 수행을 중단할 것인가 아닌가를 결정하여야 한다. 때때로 원격 브라우저가 어떤 결과도 받아들이지 않더라도 스크립트를 끝까지 실행하는 것이 편리할 때가 많다. 기본 동작은 클라이언트가 연결을 끊으면 스크립트도 중단되는 것이다. 이 동작은 ignore_user_abort라는 php3.ini 지시자(directive)나, php3_ignore_user_abort라는 Apache의 .conf의 지시자로 설정이 가능하고, ignore_user_abort() 함수를 사용하여 설정할 수도 있다. 만약 PHP에게 사용자가 내린 중지 명령을 무시하라고 말해주지 않았다면, 사용자의 중지 신호는 여러분의 스크립트를 종료시킨다. 단, register_shutdown_function()을 사용하여 shutdown 함수를 등록해 놓은 경우는 예외가 된다. shutdown 함수를 사용하면, 사용자가 STOP버튼을 눌렀을 때, 여러분의 스크립트는 남은 출력을 하려고 하고, PHP는 연결이 중단되었음을 인지하여 shutdown 함수를 호출하게 된다. shutdown 함수는 여러분의 스크립트가 정상적으로 종료되었을 때도 호출 된다. 만약 여기서 클라이언트의 연결 중단시에 다른 동작을 원한다면 connection_aborted() 함수를 사용하면 된다. 이 함수는 연결이 중단되었다면 TRUE를 반환한다.

스크립트는 내장된 스크립트 타이머에 의해 종료될 수 있다. 기본 timeout 시간은 30초로 되어 있다. 이 시간을 max_execution_time이라는 php3.ini 지시자(directive)나, 동일한 내용의 php3_max_execution_time이라는 Apache의 .conf 지시자에 의해 다르게 설정이 가능하고 set_time_limit() 함수를 사용하여 설정할 수도 있다. 설정한 시간이 경과하면 스크립트는 자동으로 중단되고, 이 스크립트는 위에 설명한 클라이언트와의 연결이 종료된 것처럼 동작한다. 따라서 shutdown 함수가 등록되어 있다면 이 함수가 실행된다. shutdown 함수내에서 이 함수가 timeout에 의해 호출된 것인가를 판단하려면 connection_timeout() 함수를 사용하면 된다. 이 함수는 timeout에 의해 shutdown 함수가 호출되었다면 TRUE를 반환한다.

한가지 유의할 사항은 ABORTED와 TIMEOUT 상태는 두 개가 동시에 active될 수 있다는 것이다. 이것은 PHP가 사용자 중단을 무시하도록 설정해 놓았을 때 생길 수 있다. 사용자가 연결을 끊었지만, 스크립트는 계속 실행되고, 시간 제한에 걸려 스크립트의 수행이 중단되고 shutdown 함수가 호출되면, connection_timeout()과 connection_aborted()함수 모두 TRUE를 반환하게 된다. connection_status()함수를 사용하여 두가지 상태 모두를 검사할 수 있다. 이 함수는 각 상태에 대한 active 정보를 bit 단위로 반환한다. 예를들어 위와같이 ABORT와 TIMEOUT 두 개의 상태가 모두 active되어 있다면 이 함수는 3을 반환한다.

이전 | 처음으로 | 다음
원격 파일 사용하기 | 위로 | 영구적인 데이터베이스 접속


영구적인 데이터베이스 접속

PHP 매뉴얼
이전 다음

21. 장. 영구적인 데이터베이스 접속

영구적인 접속(Persistent connection)은 스크립트 수행이 종료되어도 SQL 연결을 끊지 않는 접속을 말한다. 영구적인 접속이 요청되면, PHP는 기존의 (이전에 열어 두었던) 동일한(identical) 영구적인 접속이 있는지 검사한다. 만약 있다면 기존의 것을 사용하고, 없다면 새로운 연결을 생성한다. '동일한' 접속이란 같은 호스트에 같은 사용자명과 같은 암호를 사용하여 열린 접속을 말한다.

참고: IMAP extension는 영구적인 접속을 지원하는 확장이다.

가끔 웹서버의 작동과 작업의 할당에 대해 잘 알고 있지 못하는 사람들은 영구적인 접속이 사실은 별 것 아니라고 오해하기도 한다. 특히, 영구적인 접속이 동일한 SQL 연결에서 'user sessions'를 여는데 별 나을 것도 없다라던가, transaction을 효율적으로 처리하는 것도 아니다라던가, 혹은 다른 어떤 특별한 것을 하는 것도 아니라고 한다. 사실, 이런 말들에 대해 명백히 말하자면, 영구적인 접속은 비영구적인 접속에 비해 어떠한 기능적인 향상도 주지 못한다.

왜?

이것은 웹서버의 동작 방식에 따라 다른 효과를 낸다. 여러분의 웹서버가 웹 페이지를 만들기위해 PHP를 이용하는데는 3가지 방법이 있다.

첫 번째 방법은 PHP를 CGI "래퍼(wrapper)"의 형태로 사용하는 것이다. 이 방법의 경우, 웹서버에 매 PHP 페이지가 요구될 때 마다, PHP 인터프리터의 실행이 만들어지고 사리진다. 따라서 매 요구가 종료될 때마다 인터프리터의 실행이 종료되므로, 실행 중 만들었던(SQL 연결를 포함) 모든 자원은 실행 종료와 함께 해제된다. 이 경우 영구적인 접속을 사용하여 어떤 이득도 얻을 수 없다. 다르게 말하면 이 경우는 영구적인 접속을 해도 영구적이지 않다.

두 번째 방법은 가장 대중적인 방법인데, PHP를 다중프로세스(multiprocess) 웹서버의 모듈로 사용하는 것이다. (현재는 아파치가 유일하다.) 다중프로세스 서버는 보통 한 개의 부모(parent) 프로세스와, 이와 유기적으로 연결되어 웹 페이지를 실제로 만드는 작업을 하는 여러개의 자식(child) 프로세스들을 가지고 있다. 클라이언트로부터 들어오는 개별 요구는 다른 클라이언트의 요구를 처리하고 있지 않고 놀고있는 자식 프로세스로 넘겨진다. 이것은 동일한 클라이언트가 서버에 두 번째 요구를 보낼 때, 보통 처음과 다른 자식 프로세스에서 처리된다는 것을 의미한다. 이 경우 영구적인 접속을 사용하면 각각의 자식 프로세스들은 자신이 처음 요구받았을 때 SQL 서버에 접속하게 된다. 다른 페이지에서 SQL 서버에 접속 요구시는 이전에 만들어진 접속을 다시 사용하게 된다.

마지막 방법은 PHP를 멀티쓰레드(multithreaded) 웹서버의 플러그-인의 형태로 작동시키는 것이다. 현재 PHP4는 windows 환경에서 ISAPI 혹은 WSAPI, NSAPI의 방법을 사용하여 Netscape FastTrack, Microsoft's Internet Information Server (IIS), O'Reilly's WebSite Pro 등의 멀티쓰레드 웹서버에서 플러그-인으로 동작한다. 이 경우 기본 동작은 위에서 언급한 다중프로세스 모델과 동일하게 동작한다. 단, PHP3는 이와 같은 SAPI 형태를 지원하지 않는다.

영구적인 접속이 실제로 어떠한 기능적인 향상도 주지 못한다면, 이것을 사용해 어떤 이점이 있나요?

이것에 대한 간단한 답은 효율성이다. 영구적인 접속은 SQL 서버와의 연결을 만드는 것에 따른 overhead가 클 경우에 유용하다. 이 overhead는 많은 요인에 따라 커지기도 하고 작아지기도 한다. 어떤 종류의 데이터베이스인가? 웹서버와 같은 컴퓨터에 데이터베이스 서버가 있는가? SQL 서버가 어떻게 사용되고 있는가? 등에 따라 크게 달라진다. 접속에 따른 overhead가 클 경우에 영구적인 접속은 적지 않은 도움을 줄 것이다. 이것은 자식 process에서 SQL 서버에 접속을 요청할 때 마다 접속을 만드는 대신, 이 프로세스가 종료될 때 까지 살아있는 한 개의 접속 만을 사용한다. 이것은 모든 영구적인 접속을 사용한 프로세스는, 그에 해당하는 한 개의 영구적인 접속을 가지고 있다는 것을 의미한다. 예를 들어 SQL 서버에 대하여 영구적인 접속을 사용하는 스크립트를 실행하였던 20개의 다른 자식 프로세스가 있다면, 아마도 각각의 자식 프로세스에 대해 1개씩, 20개의 SQL 접속이 있을 것이다.

이 방법은 영구적인 접속의 개수가 데이타베이스 서버가 허용하는 접속수를 초과해서 설정되어 있는 경우 문제가 될 수 있다. 만약 데이타베이스가 16개의 동시 접속을 허용하고, 이 서버 세션들이 모두 사용중이면, 17번째 thread는 연결을 시도하다가 실패할 것이다. 만약 여러분이 만든 스크립트에 이런 경우에 대비한 특별한 대책이 없이 재시도를 반복하다보면 가능한 모든 connection을 사용하여 복구할 수 없게 된다. 이런 abandoned 혹은 idle connection을 다루는 자세한 설명은 데이타베이스 문서를 참조하기 바란다.

주의

영구적인 접속을 사용할때 두가지 추가적인 경고를 염두에 두고 있어야 한다 한가지는 영구적인 접속에서 테이블 락킹(locking)을 사용할때이다. 스크립트가 어떤 이유로 락을 풀수 없을때, 같은 접속을 사용하는 다음 스크립트는 무한정 block될것이고 이 경우에는 httpd 서버나 데이터베이스 서버를 재시작시켜야 할수도 있다. 다른 한가지는 트랜잭션을 사용할때이다. 트랜잭션 블록은 그 트랜잭션 블록이 수행되기 전에 스크립트가 수행을 종료하면 그 접속을 사용하는 다음 스크립트에 이월하게 된다. 각각의 경우에, register_shutdown_function()을 사용하여 테이블 unlock하거나 트랜잭션을 롤백하는 해제 함수를 등록 할수 있다. 이런 문제를 완전히 회피하기 위한 더 좋은 방법은 영구적인 접속을 사용하는 스크립트에서 테이블 락이나 트랜젝션을 사용하지 않는 것이다 (어느 곳에서는 그것을 사용할수 있다)

중요한 언급 한가지! 영구적인 접속은 일반적인 접속에 일대일로 대응되도록 설계되었다. 이것은 스크립트의 다른 부분은 그대로 두고, 언제라도 비영구적인 접속을 영구적인 접속으로 대치할 수 있다는 것을 의미한다. 이기능으로 아마도 스크립트의 동작이 아니라 효율을 향상시킬 수도 있을 것이다.

fbsql_pconnect(),
ibase_pconnect(), ifx_pconnect(),
imap_popen(), ingres_pconnect(),
msql_pconnect(), mssql_pconnect(),
mysql_pconnect(), ociplogon(),
odbc_pconnect(), ora_plogon(),
pfsockopen(), pg_pconnect(),
sybase_pconnect() 참고.

이전 | 처음으로 | 다음
연결 제어 | 위로 | 안전 모드


안전 모드

PHP 매뉴얼
이전 다음

22. 장. 안전 모드

차례
보안과 안전 모드
안전 모드에 의해 제한되는/비활성화되는 함수들

PHP 안전 모드(safe mode)는 공유-서버 보안 문제를 풀려는 시도이다. 이 문제를 PHP 수준에서 풀려고 하는것은 구조적으로 올바르지 않다. 그러나 웹서버와 OS 수준에서의 차선책이 아주 현실적이지는 않기 때문에, 많은 사람, 특히 ISP, 들이 현재 안전 모드를 사용한다.

보안과 안전 모드

표 22-1. 보안과 안전 모드 설정 지시자(directive)

지시자명 | 기본값 | 변경값
safe_mode | "0" | PHP_INI_SYSTEM
safe_mode_gid | "0" | PHP_INI_SYSTEM
safe_mode_include_dir | NULL | PHP_INI_SYSTEM
safe_mode_exec_dir | "" | PHP_INI_SYSTEM
safe_mode_allowed_env_vars | PHP_ | PHP_INI_SYSTEM
safe_mode_protected_env_vars | LD_LIBRARY_PATH | PHP_INI_SYSTEM
open_basedir | NULL | PHP_INI_SYSTEM
disable_functions | "" | PHP_INI_SYSTEM
disable_classes | "" | PHP_INI_SYSTEM
PHP_INI_* 상수에 대한 좀 더 자세한 설명과 정의를 보기 위해서는 ini_set() 참조.

위 설정 지시어에 대한 간단한 설명입니다.

safe_mode boolean

PHP의 안전 모드가 활성화되어있는지 여부. 더 자세한 정보는 보안장을 참고.

safe_mode_gid boolean

기본값, 안전 모드는 파일이 열릴 때 UID 비교 검사를 수행한다. 이 설정을 GID 비교로 완화하려면, safe_mode_gid을 켜도록 한다. 파일 접근에 대해 UID (FALSE) 검사를 하는지, GID (TRUE) 검사를 하는지의 여부.

safe_mode_include_dir string

이 디렉토리와 하위디렉토리에서 파일을 include할 때에는 UID/GID 검사가 무시된다 (디렉토리는 include_path나 include되는 전체 경로가 되어야 한다).

PHP 4.2.0부터 이 지시자(directive)는 단지 하나의 디렉토리보다는 include_path 지시자와 비슷한 방식으로 세미-콜른으로 구분된 경로를 취할수 있다.

설정 제한은 실질적으로 디렉토리명이 아닌 앞첨자(prefix)가 된다. 이말의 의미는 "safe_mode_include_dir = /dir/incl"는 "/dir/include"와 "/dir/incls"가 존재하기만 한다면 그 디렉토리도 접근이 허용된 다는 것이다. 특정 디렉토리만으로 접근을 제한하고자 하면, 슬래시로 끝내면 된다. For example: "safe_mode_include_dir = /dir/incl/"

safe_mode_exec_dir string

PHP가 안전 모드를 사용중이라면, system()과 그 외의 시스템 프로그램을 실행하는 함수는 이 디렉토리에 있지 않으면 프로그램 시작이 거부된다.

safe_mode_allowed_env_vars string

특정 환경 변수를 설정하는것은 잠재적인 보안 구멍이 될수 있다. 이 지시자는 콤마-구분자 리스트의 앞첨자(prefix)를 포함한다. 안전 모드에서, 유저는 여기서 제공되는 앞첨자로 시작하는 이름을 갖는 환경변수만 변경할수 있을것이다. 기본값으로, 유저는 PHP_로 시작하는 환경 변수만 설정할수 있다. (e.g. PHP_FOO=BAR).

참고: 이 지시자가 비어있으면, PHP는 유저가 모든 환경 변수를 변경할수 없게 할것이다!

safe_mode_protected_env_vars string

이 지시자는 엔드 유저가 putenv()를 사용하여 변경할수 없는 콤마-구분자 리스트의 환경 변수를 포함한다. 이 변수들은 safe_mode_allowed_env_vars가 그들을 변경할수 있도록 설정되어있을지라도 보호될것이다.

open_basedir string

PHP가 열수 있는 파일을 특정 디렉토리-트리로 제한한다. 이 지시자는 안전 모드가 켜졌는지 꺼졌는지와는 상관이 없다.

스크립트가 예를 들면, fopen() 이나 gzopen()으로 파일을 열려고 시도할때, 파일의 위치를 검사한다. 파일이 설정된 디렉토리-트리의 밖에 있다면, PHP는 그 파일을 여는것을 거부할것이다. 모든 심볼릭 링크가 검사되기 때문에, symlink로 이 제한을 회피할수 없다.

특수한 값 .는 스크립트가 저장되어 있는 디렉토리를 기본-디렉토리(base-directory)로 사용한다는 것을 가리킨다.

윈도우에서는 세미콜른으로 디렉토리를 구분한다. 그외 모든 시스템은, 콜른으로 디렉토리를 구분한다. 아파치 모듈에서, 부모 디렉토리부터의 open_basedir 경로는 현재 자동적으로 상속된다.

open_basedir로 설정된 제한은 실질적으로 디렉토리명이 아닌, 앞첨자(prefix)가 된다. 이 말의 의미는 "open_basedir = /dir/incl"는 "/dir/include" 과 "/dir/incls" 디렉토리가 존재한다면 그 두 디렉토리로의 접근도 허용한다는것이다. 특정 디렉토리로만 접근을 제한하고자 한다면, 슬래쉬로 끝내면 된다. For example: "open_basedir = /dir/incl/"

참고: 다중 디렉토리에 대한 지원은 3.0.7에서 추가되었다.

기본값은 모든 파일이 열릴수 있도록 허용되어 있다.

disable_functions string

이 지시자는 보안 때문에 특정 함수를 비활성화시켜준다. 컴마로 구분된 함수명의 리스트를 취한다. disable_functions는 안전 모드에 의해 영향을 받지 않는다.

이 지시자는 php.ini에서 설정되어야 한다. 예를 들면, 이 값을 httpd.conf에서 설정할수 없다.

disable_classes string

이 지시자는 보안적인 측면때문에 특정 클래스를 비활성화시켜준다. 컴마로 구분된 클래스명의 리스트를 취한다. disable_classes는 안전 모드에 의해 영향을 받지 않는다.

이 지시자는 php.ini에서 설정되어야 한다. 예를 들면, 이 값을 httpd.conf에서 설정할수 없다.

Availability note: 이 지시자는 PHP 4.3.2부터 사용가능하게 되었다.

참고: register_globals, display_errors, log_errors

safe_mode가 켜져 있으면, PHP는 현재 스크립트의 소유자(owner)가 파일 함수에 의해 제어되는 파일의 소유자(owner)와 일치하는지 검사한다. 예를 들면:
-rw-rw-r--    1 rasmus   rasmus       33 Jul  1 19:20 script.php
-rw-r--r--    1 root     root       1116 May 26 18:01 /etc/passwd
이 script.php를 실행
<?php
readfile('/etc/passwd');
?>
안전 모드가 활성화되어 있으면 다음 에러가 보여진다.
Warning: SAFE MODE Restriction in effect. The script whose uid is 500 is not
allowed to access /etc/passwd owned by uid 0 in /docroot/script.php on line 2

엄격한 UID 검사가 적절하지 않고, 완화된 GID 검사가 효율적인 환경일수 있다. 이런 경우는 safe_mode_gid 스위치 방식으로 지원된다. On으로 설정하면 완화된 GID 검사가 수행되고, Off (기본값)로 설정되면 UID 검사가 수행된다.

safe_mode 대신에, open_basedir 디렉토리를 설정하면, 모든 파일 제어가 특정 디렉토리 밑의 파일로만 제한될것이다. 예를 들면(아파치 httpd.conf 예):
<Directory /docroot>
  php_admin_value open_basedir /docroot
</Directory>
이 open_basedir 설정으로 동일한 script.php를 실행하면 결과는 다음과 같다:
Warning: open_basedir restriction in effect. File is in wrong directory in
/docroot/script.php on line 2

또한 각각의 함수들을 비활성화시킬수 있다. disable_functions 지시자는 php.ini 파일 밖에서 사용될수 없다. 그래서 httpd.conf 파일의 per-virtualhost 나 per-directory 기반의 함수를 비활성화시킬수 없다. 이 지시자를 php.ini에 추가하면:
disable_functions readfile,system
다음의 결과가 나온다:
Warning: readfile() has been disabled for security reasons in
/docroot/script.php on line 2

이전 | 처음으로 | 다음
영구적인 데이터베이스 접속 | 위로 | 안전 모드에 의해 제한되는/비활성화되는 함수들


안전 모드에 의해 제한되는/비활성화되는 함수들

다음은 아직 완전하지 않고 부정확할 수도 있는 안전 모드에 의해 제한되는 함수 목록이다.

표 22-2. 안전 모드 제한 함수들

함수 | 제한점
dbmopen() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다.
dbase_open() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다.
filepro() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다.
filepro_rowcount() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다.
filepro_retrieve() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다.
ifx_* | sql_safe_mode 제한, (!= safe mode)
ingres_* | sql_safe_mode 제한, (!= safe mode)
mysql_* | sql_safe_mode 제한, (!= safe mode)
pg_loimport() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다.
posix_mkfifo() | 작업하려는 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다.
putenv() | safe_mode_protected_env_vars 와 safe_mode_allowed_env_vars ini-지시자에 따름. putenv() 문서 참고.
move_uploaded_file() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다.
chdir() | 작업하려는 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다.
dl() | 이 함수는 안전 모드에서 사용할 수 없습니다.
backtick operator | 이 함수는 안전 모드에서 사용할 수 없습니다.
shell_exec() (functional equivalent of backticks) | 이 함수는 안전 모드에서 사용할 수 없습니다.
exec() | safe_mode_exec_dir안의 실행파일만 실행할수 있다. 실무적인 이유로 현재는 실행파일에 대한 경로에 ..을 허용하지 않는다.
system() | safe_mode_exec_dir안의 실행파일만 실행할수 있다. 실무적인 이유로 현재는 실행파일에 대한 경로에 ..을 허용하지 않는다.
passthru() | safe_mode_exec_dir안의 실행파일만 실행할수 있다. 실무적인 이유로 현재는 실행파일에 대한 경로에 ..을 허용하지 않는다.
popen() | safe_mode_exec_dir안의 실행파일만 실행할수 있다. 실무적인 이유로 현재는 실행파일에 대한 경로에 ..을 허용하지 않는다.
mkdir() | 작업하려는 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다.
rmdir() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다.
rename() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다. 작업하려는 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다.
unlink() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다. 작업하려는 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다.
copy() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다. 작업하려는 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다. ( source 와 target 에서)
chgrp() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다.
chown() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다.
chmod() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다. 추가적으로, SUID, SGID와 sticky 비트를 설정할수 없다
touch() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다. 작업하려는 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다.
symlink() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다. 작업하려는 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다. (주의: 타겟만 검사됨)
link() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다. 작업하려는 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다. (주의: 타겟만 검사됨)
getallheaders() | 안전 모드에서, 'authorization' (대소문자 구별안함)로 시작되는 헤더는 반환되지 않을것이다. 경고: 이 함수는 aol-server의 getallheaders() 구현에서 잘못 작동된다!
header() | 안전 모드에서, WWW-Authenticate(HTTP 인증에서 사용됨)를 설정하면, 이 헤더의 realm부분에 스크립트의 uid가 추가된다.
PHP_AUTH variables | 안전 모드에서는, 변수 PHP_AUTH_USER와, PHP_AUTH_PW, AUTH_TYPE이 $_SERVER 안에서 사용될수 없다. 그와 상관 없이, USER에 대해서 REMOTE_USER을 사용할수 있다 (주의: PHP 4.3.0 이후에서만 적용됨)
highlight_file(), show_source() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다. 작업하려는 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다. (주의: PHP 4.2.1 이후에서만 적용됨)
parse_ini_file() | 작업하려는 파일이나 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다. 작업하려는 디렉토리가 실행 중인 스크립트와 같은 UID (owner)를 가지고 있는지 확인합니다. (note: PHP 4.2.1 이후에서만 적용됨)
set_time_limit() | PHP가 안전 모드에서 실행되면 아무 효과가 없음.
max_execution_time | PHP가 안전 모드에서 실행되면 아무 효과가 없음.
php4/main/fopen_wrappers.c를 사용하는 모든 함수 | ??

이전 | 처음으로 | 다음
안전 모드 | 위로 | 커맨드 라인에서 PHP 사용하기


커맨드 라인에서 PHP 사용하기

PHP 매뉴얼
이전 다음

23. 장. 커맨드 라인에서 PHP 사용하기

버전 4.3.0부터 PHP는 Command Line Interface를 의미하는 CLI라는 이름의 새로운 SAPI 타입 (Server Application Programming Interface)을 지원한다. SAPI는 이름에서 내포하듯이, 핵심 용도는 셀(또는 데스크탑) 응용프로그램을 PHP로 개발하는것에 맞춰져있다. 이 장에서 설명하는 CLI SAPI와 SAPI사이에는 많은 차이가 있다. CLI와 CGI는 많은 부분에 있어서 같은 동작을 하지만, 서로 다른 SAPI들이라는 것이다.

CLI SAPI는 PHP 4.2.0에서 처음으로 릴리즈되었다. 그러나 아직 실험적이었고 ./configure를 실행할때 --enable-cli을 명시해 주어야 했다. PHP 4.3.0 이후부터 CLI SAPI는 더이상 실험적이지 않고 기본값으로 --enable-cli가 활성화되어있다. 그리고 --disable-cli로 비활성화시킬수 있다.

PHP 4.3.0부터, CLI/CGI 바이너리의 이름과 위치, 존재여부는 PHP가 시스템에 어떻게 설치되느냐에 따라 달라질 것이다. 기본값으로 make를 수행할때, CGI와 CLI 모두 빌드되고 각각 sapi/cgi/php와 sapi/cli/php에 위치하게 된다. 둘 다 php라는 이름이 붙는다는것에 주의해야 할것이다. configure 줄에 따라 make install 시에 무슨일이 일어날까. configure 시에 모듈로 SAPI를 선택했다면, 즉 apxs를 사용하거나, 또는 --disable-cgi 옵션을 사용하면 CLI는 make install시에 {PREFIX}/bin/php에 복사된다. 예를 들면, --with-apxs가 configure 줄에 포함되면 make install시에 CLI는 {PREFIX}/bin/php에 복사된다. CGI 바이너리 설치를 오버라이드하고 싶다면 make install 이후에 make install-cli를 사용한다. 차선책으로 configure 줄에 --disable-cgi를 설정할수 있다.

참고: --enable-cli와 --enable-cgi는 모두 기본값으로 되어있기 때문에, 단순히 configure줄에 --enable-cli를 넣는것이 make install시에 {PREFIX}/bin/php 에 CLI를 복사할것이라는 것을 의미하지 않는다.

PHP 4.2.0 과 PHP 4.2.3 사이의 윈도우 패키지는 CLI를 php-cli.exe로 제공한다. CGI인 php.exe와 같은 폴더에 존재한다. PHP 4.3.0부터의 윈도우 패키지는 CLI를 cli라는 다른 폴더에 php.exe파일로 제공한다. 그래서 cli/php.exe가 된다.

현재 사용중인 SAPI는 무엇인가?: 셀에서, php -v를 쳐넣으면 php가 CGI인지 CLI인지 알수 있을것이다. php_sapi_name()과 상수PHP_SAPI도 참고.

참고: PHP 4.3.2에서 유닉스 manual 페이지가 추가되었다. 셀 환경에서 man php를 쳐넣음으로써 이 페이지를 볼수 있을것이다.

다른 SAPI와 비교한 CLI SAPI의 현저한 차이점:

  • CGI SAPI와는 달리, 출력에 헤더를 쓰지 않는다.

    CGI SAPI가 HTTP 헤더를 제거하는 방법을 제공하지만, CLI SAPI에서는 헤더를 활성화시킬수 있는 스위치(switch)가 존재하지 않는다.

    CLI는 기본적으로 정숙모드(quiet mode)로 시작된다. 그러나 구버전의 CGI 스크립트와의 호환성을 위해 -q 스위치를 유지하고 있다.

    작업 디렉토리가 스크립트의 디렉토리로 변경되지 않는다 (-C스위치는 호환성을 유지됨)

    일반 텍스트 에러 메시지 (HTML 포맷이 아님)

  • 셀 환경에 맞지 않는 것들 때문에 CLI SAPI에 의해 오버로드되는 php.ini 지시자(directive)가 몇가지 존재한다.

    표 23-1. php.ini 지시자(directive) 오버로드

    지시자(directive) | CLI SAPI 기본값 | 주석
    html_errors | FALSE | 셀에서 에러메시지를 읽을때 의미없는 HTML태그로 뒤범벅이 되면 에러메시지를 읽기가 매우 어려울수 있다. 따라서 이 지시자(directive)의 기본값은 FALSE다.
    implicit_flush | TRUE | print(), echo() 와 비슷한 함수들의 출력은 모두 즉시 출력으로 쓰기 되고 버퍼에 캐시되지 않는다. 표준 출력을 지연시키거나 조작하고 싶다면 output buffering을 사용할수도 있다.
    max_execution_time | 0 (unlimited) | 셀 환경에서 PHP를 무한 사용할 가능성때문에, maximum execution time은 unlimited로 설정된다. 웹 응용프로그램은 대부분 매우 빨리 실행이 끝나는 반면에 셀 응용프로그램은 더 많은 시간이 필요한 경우가 많다.
    register_argc_argv TRUE

    이 설정은 TRUE이기 때문에 CLI SAPI에서는 항상 argc (응용프로그램에 전달되는 인자의 수) 와 argv (응용프로그램에 전단되는 인자의 배열)을 사용할수 있을것이다.

    PHP 4.3.0에서부터, CLI SAPI는 PHP변수 $argc와 $argv가 등록되고 적절한 값으로 채워지게 된다. 이 변수의 생성은 CGI와 MODULE 버전과 같이 register_globals가 on되어 있어야 한다. 버전이나 register_globals의 설정에 관계없이, $_SERVER나 $HTTP_SERVER_VARS로 그 값에 접근할수 있다. Example: $_SERVER['argv']

    참고: 이 지시자(directive)는 설정 파일 php.ini나 사용자 설정으로부터 온 다른 값으로 초기화될수 없다. 모든 설정 파일이 해석되고 난 후에 기본값이 적용되기 때문에 이 것은 제한이 된다. 하지만, 각 값은 런타임동안에 변경될수 있다. (위 지시자(directive) 중 환경과 맞지 않는것 e.g. register_argc_argv).

  • 셀 환경에서의 작업을 편하게 하기 위해, 다음 상수가 정의되었다:

    표 23-2. CLI 전용 상수

    상수 설명
    STDIN stdin에 이미 열려진 스트림. 이 상수는 다음처럼 여는것을 간단하게 해준다.
    $stdin = fopen('php://stdin', 'r');
    STDOUT stdout에 이미 열려진 스트림. 이 상수는 다음처럼 여는것을 간단하게 해준다.
    $stdout = fopen('php://stdout', 'w');
    STDERR stderr에 이미 열려진 스트림. 이 상수는 다음처럼 여는것을 간단하게 해준다.
    $stderr = fopen('php://stderr', 'w');

    위에서 설명한대로 예를 들면 stderr에 대한 스트림을 직업 열필요가 없다. 스트림 자원 대신 단순하게 상수를 사용하면 된다.
    php -r 'fwrite(STDERR, "stderr\n");'
    이 스트림을 명시적으로 닫을 필요가 없다. 스크립트가 끝날때 PHP에 의해 자동적으로 닫히기 때문이다.

  • CLI SAPI는 현재 디렉토리를 실행중인 스크립트의 디렉토리로 변경 하지않는다!

    다음예는 CGI SAPI와의 차이점을 보여준다:
    <?php
            /* Our simple test application named test.php*/
            echo getcwd(), "\n";
    ?>

    CGI 버전을 사용할때, 출력은:
    $ pwd
/tmp

$ php -q another_directory/test.php
/tmp/another_directory
    이 예제코드는 PHP가 현재 디렉토리를 실행스크립트의 디렉토리로 변경하는것을 보여준다.

    CLI SAPI를 사용할때는 다음과 같다:
    $ pwd
/tmp

$ php -f another_directory/test.php
/tmp
    이것은 PHP에서 셀 툴을 제작할때 좀더 많은 유연성을 허용한다.

    참고: CGI SAPI 는 커맨드 라인에서 실행할때 -C 스위치를 사용하여 CLI SAPI의 동작을 지원한다.

PHP 바이너리에 의해 제공되는 커맨드 라인 옵션의 리스트는 PHP를 -h스위치와 함게 실행하므로써 어느때든 질의를 할수 있다.
Usage: php [options] [-f] <file> [args...]
       php [options] -r <code> [args...]
       php [options] [-- args...]
  -s               Display colour syntax highlighted source.
  -w               Display source with stripped comments and whitespace.
  -f <file>        Parse <file>.
  -v               Version number
  -c <path>|<file> Look for php.ini file in this directory
  -a               Run interactively
  -d foo[=bar]     Define INI entry foo with value 'bar'
  -e               Generate extended information for debugger/profiler
  -z <file>        Load Zend extension <file>.
  -l               Syntax check only (lint)
  -m               Show compiled in modules
  -i               PHP information
  -r <code>        Run PHP <code> without using script tags <?..?>
  -h               This help

  args...          Arguments passed to script. Use -- args when first argument
                   starts with - or script is read from stdin

CLI SAPI는 실행하고자 하는 PHP코드를 취하는 3가지의 방법을 사용한다.

  1. PHP에게 특정 파일을 실행하도록 지정함.

    php my_script.php

php -f my_script.php
    두 방법 (-f 스위치를 사용하거나 안하는것)은 모두 my_script.php을 실행한다. 실행하고자하는 파일을 선택할수 있다 - PHP 스크립트는 .php확장자 로 끝날필요없이 어떤 이름이나 원하는 확장자를 갖을수 있다.

  2. 커맨드 라인에서 실행하고자 하는 PHP 코드를 직접 전달함.

    php -r 'print_r(get_defined_constants());'
    셀 변수 변환과 따옴표 사용에 있어서 특별한 주의가 필요하다.

    참고: 예제 코드를 주의깊에 읽으면, 시작과 끝 태그가 존재하지 않는다! -r 스위치는 그 태그들이 필요하지 않다. 그 태그들을 사용하면 해석 에러가 발생할것이다.

  3. 표준 입력(stdin)을 통해 수행되는 PHP 코드를 제공함

    이 방식은 동적인 PHP 코드를 생성할수 있는 강력한 기능을 부여하고 바이너리에 그 코드를 넘겨준다. 다음 (가상의) 예제코드에서 보여주는 바와 같다.
    $ some_application | some_filter | php | sort -u >final_output.txt

코드를 수행하기 위한 세 가지 방법의 어떤것도 조합할수 없다.

모든 셀 응용 프로그램처럼, PHP 바이너리는 많은수의 인자를 허용하고 PHP 스크립트도 인자를 받을수 있다. 스크립트로 전달할수 있는 인자의 갯수는 PHP에 의해 제한받지 않는다. (셀은 전달할수 있는 문자 갯수의 제한을 갖는다; 보통 이 제한을 넘지 않을것이다) 스크립트로 전달할수 있는 인자는 전역 배열 $argv에 존재한다. 제로 인덱스는 항상 스크립트 명을 포함한다 (PHP 코드가 표준 입력이나 커맨드 라인 스위치 -r로부터 온 경우에는 - ). 두번째로 등록된 전역 변수는 $argv배열의 구성요소 수를 갖는 $argc이다 (스크립트로 전달되는 인자의 수가 아니다)

스크립트로 전달하려는 인자가 -문자로 시작되지 않는한, 특별하게 조심할 필요는 없다. -로 시작하는 인자를 스크립트에 전달하면 문제가 발생할 소지가 있다 왜냐하면 PHP는 그 인자를 PHP가 제어해야 한다고 생각하기 때문이다. 이런일이 발생하지 않기 위해서는, -- 구분자의 인자 리스트를 사용한다. 이 구분자가 PHP에 의해 해석된 후에, 그 뒤의 모든 인자가 스크립트로 온전히 전달된다.

# This will not execute the given code but will show the PHP usage
$ php -r 'var_dump($argv);' -h
Usage: php [options] [-f] <file> [args...]
[...]

# This will pass the '-h' argument to your script and prevent PHP from showing it's usage
$ php -r 'var_dump($argv);' -- -h
array(2) {
  [0]=>
  string(1) "-"
  [1]=>
  string(2) "-h"
}

하지만, 셀 스크립트에서 PHP를 사용하는 다른 방법이 있다. 첫번째 줄을 #!/usr/bin/php로 시작하는 스크립트를 작성할수 있다. 이 줄 뒤에는 PHP의 시작과 끝 태그 안에 포함된 일반적인 PHP코드를 놓을수 있다. 이 파일에 적절하게 실행 속성을 설정하면 (e.g. chmod +x test) 스크립트는 보통의 셀이나 펄 스크립트처럼 실행될수 있다:
#!/usr/bin/php
<?php
    var_dump($argv);
?>
이 파일이 현재 디렉토리에서 test라는 이름을 가졌다고 가정하면 다음과 같이 할수 있다.
$ chmod 755 test
$ ./test -h -- foo
array(4) {
  [0]=>
  string(6) "./test"
  [1]=>
  string(2) "-h"
  [2]=>
  string(2) "--"
  [3]=>
  string(3) "foo"
}
위와 같은 경우에 -로 시작하는 인자를 스크립트로 전달할때에도 주의할 필요가 없다.

표 23-3. 커맨드 라인 옵션

옵션 | 설명
-s

색상으로 문법 강조된 소스를 보임.

이 옵션은 파일을 해석하여 HTML 강조된 버전을 만드는 내부적 메카니즘을 사용하여 표준출력에 그것을 쓰도록 한다. 주의할점은 이 옵션이 하는 일은 <code> [...] </code>블록의 HTML 태그를 생성하고, HTML 헤더는 생성하지 않는다는 것이다.

참고: 이 옵션은 -r 옵션과 함께 사용할수 없다.

-w

주석과 공백을 제거한 소스를 보임.

참고: 이 옵션은 -r 옵션과 함께 사용할수 없다.

-f

-f 옵션으로 주어진 파일명을 해석하고 실행함. 이 스위치는 선택적이고 생략가능하다. 파일명만 제공함으로써 실행이 가능하다.

-v

PHP, PHP SAPI, Zend 버전을 표준 출력에 출력함, e.g.
$ php -v
PHP 4.3.0 (cli), Copyright (c) 1997-2002 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2002 Zend Technologies

-c

이 옵션으로 php.ini 가 위치한 디렉토리를 찾거나 , 사용자 정의의 INI 파일 디렉토리(php.ini라고 이름붙일 필요가 없다)를 설정할수 있슴. e.g.
$ php -c /custom/directory/ my_script.php

$ php -c /custom/directory/custom-file.ini my_script.php

-a

PHP를 대화식으로 실행함.

-d

이 옵션은 php.ini에서 허용된 설정 지시자(directive)에 대해서 사용자정의 값을 설정하도록 해줌. 문법은 다음과 같다:
-d configuration_directive[=value]

Examples (lines are wrapped for layout reasons):
# Omitting the value part will set the given configuration directive to "1"
$ php -d max_execution_time
        -r '$foo = ini_get("max_execution_time"); var_dump($foo);'
string(1) "1"

# Passing an empty value part will set the configuration directive to ""
php -d max_execution_time=
        -r '$foo = ini_get("max_execution_time"); var_dump($foo);'
string(0) ""

# The configuration directive will be set to anything passed after the '=' character
$  php -d max_execution_time=20
        -r '$foo = ini_get("max_execution_time"); var_dump($foo);'
string(2) "20"
$  php
        -d max_execution_time=doesntmakesense
        -r '$foo = ini_get("max_execution_time"); var_dump($foo);'
string(15) "doesntmakesense"

-e

디버거/분석표를 위한 확장 정보를 생성함.

-z

젠드 확장을 로드함. 파일명만 주어지면, PHP는 시스템의 현재 기본 라이브러리 경로에서 이 확장을 로드하려고 함(리눅스 시스템에서는 보통 /etc/ld.so.conf로 설정되어 있슴) 절대 결로 정보를 갖는 파일명을 전달하면 시스템 라이브러리 검색 경로를 사용하지 않을것이다. 디렉토리 정보를 갖는 상대경로의 파일명은 PHP에게 현재 디렉토리에서 상대경로의 확장만 로드하도록 한다.

-l

이 옵션은 주어진 PHP코드의 문법 검사만 수행하게 하는 편리한 방법을 제공함. 성공하면, No syntax errors detected in <filename>라는 메시지가 표준 출력으로 쓰여지고 셀의 리턴 코드는 0이다. 실패하면, 내부적인 해석기 에러와 함께 Errors parsing <filename>라는 메시지가 표준 출력으로 쓰여지고 셀의 리턴 코드는 255가 된다.

이 옵션은 치명적인 에러를 발견할수 없을것이다 (undefined functions 같은). -f 옵션을 사용하면 치명적인 에러도 함께 찾을수 있을것이다.

참고: 이 옵션은 -r 옵션과 함께 사용할수 없다.

-m

이 옵션을 사용하여, PHP는 내장(로드된)된 PHP 모듈과 Zend 모듈을 출력한다.
$ php -m
[PHP Modules]
xml
tokenizer
standard
session
posix
pcre
overload
mysql
mbstring
ctype

[Zend Modules]

-i | 이 커맨드 라인 옵션은 phpinfo()를 호출하고, 결과값을 출력한다. PHP가 정확하게 동작하지 않으면, php -i를 사용하여 정보 테이블이나 그 테이블 이전에 어떤 에러 메시지가 출력되는지 보도록 지도될수 있다. 출력은 HTML내에 존재하고 따라서 꽤 많다는 것에 주의한다.
-r

이 옵션은 커맨드 라인에서 직접 PHP를 수행하도록 해줌. PHP의 시작과 끝 태그 (<?php 과 ?>)는 필요하지 않다. 만약 존재한다면 해석 에러가 발생할것이다.

참고: 이런 형태의 PHP를 사용할때 셀에 의해 수행되는 커맨드라인의 변수 치환과 충돌하지 않도록 주의가 필요하다.

Example showing a parser error
$ php -r "$foo = get_defined_constants();"
Command line code(1) : Parse error - parse error, unexpected '='
여기서의 문제점은 sh/bash는 큰따옴표 "를 사용할지라도 변수 치환을 수행한다는것이다. 변수 $foo는 정의되지 않았기 때문에, 실질적인 읽기를 수행하는데 있어서 PHP로 전달되는 코드가 아무것도 없다.
$ php -r " = get_defined_constants();"
확실한 방법은 작은 따옴표 '를 사용하는 것이다. 작은 따옴표로 둘러싼 문자열안의 변수는 sh/bash에 의해 치환되지 않는다.
$ php -r '$foo = get_defined_constants(); var_dump($foo);'
array(370) {
  ["E_ERROR"]=>
  int(1)
  ["E_WARNING"]=>
  int(2)
  ["E_PARSE"]=>
  int(4)
  ["E_NOTICE"]=>
  int(8)
  ["E_CORE_ERROR"]=>
  [...]
sh/bash가 아닌 다른 셀을 사용 중이라면, 좀더 많은 다른 경험을 했을수 있다. 편하게 버그 보고를 열거나 phpdoc@lists.php.net에 메일을 보내도록 한다. 아직도 코드내로 셀변수를 취하려고 하거나 회피를 위한 역슬래쉬를 사용해서 어려움을 격기 쉽다. 분명히 경고했다.

참고: -r는 CLI SAPI에서만 사용가능하다. CGI SAPI 에서는 사용할수 없다.

-h | 이 옵션으로 커맨드 라인의 실질적인 옵션 리스트에 관한 정보와 그들이 수행하는 작업에 대한 한줄의 설명을 볼수 있다.

PHP 실행 파일은 웹서버와 절대적으로 독립적인 PHP 스크립트를 실행하기 위해 사용될수 있다. 유닉스 시스템에 있다면, PHP 스크립트의 첫번째 줄에 특별한 것을 추가해야 하고, 실행가능하게 해서, 무슨 프로그램이 스크립트를 수행시킬지 시스템이 알수 있도록 한다. 윈도우 플랫폼에서는 .php파일의 더블 클릭 옵션을 갖는 php.exe와 연관시킬수 있거나, PHP를 통해 그 스크립트를 수행하도록 배치 파일을 만들수 있다. 유닉스에서 실행시키기위해 추가된 첫번째 줄은 윈도우에 아무런 해가 없을것이다. 그래서 이 방법을 사용하여 플랫폼 프로그램을 번갈아 작성할수 있다. 커맨드 라인 PHP 프로그램을 작성하는 단순한 에제 코드를 아래에서 볼수 있다.

예 23-1. 커맨드 라인에서 실행되도록 의도된 스크립트(script.php)

#!/usr/bin/php
<?php

if ($argc != 2 || in_array($argv[1], array('--help', '-help', '-h', '-?'))) {
?>

This is a command line PHP script with one option.

  Usage:
  <?php echo $argv[0]; ?> <option>

  <option> can be some word you would like
  to print out. With the --help, -help, -h,
  or -? options, you can get this help.

<?php
} else {
    echo $argv[1];
}
?>

위 스크립트에서, 특별한 첫번째 줄을 사용하여 이 파일이 PHP에 의해 실행되어야 한다는 것을 가리킨다. CLI 버전을 사용한다면, HTTP 헤더가 존재하지 않을것이다. PHP 의 커맨드라인 응용프로그램을 작성할때 사용할수 있는 두개의 변수가 존재한다:$argc와 $argv. 첫번째 변수는 인자 갯수에 하나(스크립트명)가 추가된 값이다. 두번째 변수는 인자들를 포함하는 배열인데, 이 배열은 제로 ($argv[0])에 스크립트명을 갖으면 시작된다.

위 프로그램에서는 인자가 하나 이하인가 이상인가를 체크한다. 인자가 --help나, -help, -h, -?이면, help 메시지르 출력하고, 스크립트명을 동적으로 출력한다. 다른 인자를 받게 되면, 그 인자를 출력한다.

유닉스에서 위 스크립트를 수행하려 하면, 그 파일을 실행가능하게 해서 단순히 script.php echothis 나 script.php -h를 호출하면 된다. 윈도우에서는, 이 작업을 위해 배치 파일을 만들수 있다.

예 23-2. 커맨드 라인의 PHP 스크립트를 수행하기 위한 배치 파일(script.bat)

@c:\php\cli\php.exe script.php %1 %2 %3 %4

위 프로그램이 script.php이란 이름을 갖고, c:\php\cli\php.exe 안에 CLI php.exe를 갖는다면 이 배치 파일은 추가된 옵션과 함께 실행이 될것이다: script.bat echothis 나 script.bat -h.

PHP의 커맨드 라인 응용 프로그램의 기능을 확장하기 위한 좀더 많은 함수를 보기위해 Readline 확장에 대한 문서도 참고한다.

이전 | 처음으로 | 다음
안전 모드에 의해 제한되는/비활성화되는 함수들 | 위로 | 함수 레퍼런스


함수 레퍼런스

PHP 매뉴얼
이전 다음

V. 함수 레퍼런스

차례
I. 아파치 함수
II. 배열함수
III. Aspell 함수 [deprecated]
IV. BCMath 임의 정확도 수치연산 함수
V. Bzip2 압축 함수
VI. 달력 함수
VII. CCVS API Functions [deprecated]
VIII. COM support functions for Windows
IX. 클래스/객체 함수
X. ClibPDF Functions
XI. Crack Functions
XII. CURL, Client URL Library Functions
XIII. Cybercash Payment Functions
XIV. Cyrus IMAP administration Functions
XV. Character Type Functions
XVI. Database (dbm-style) Abstraction Layer Functions
XVII. 날짜와 시간 함수
XVIII. dBase Functions
XIX. DBM Functions [deprecated]
XX. dbx Functions
XXI. DB++ Functions
XXII. Direct IO Functions
XXIII. 디렉토리 함수
XXIV. DOM XML Functions
XXV. .NET Functions
XXVI. Error Handling and Logging Functions
XXVII. File Alteration Monitor Functions
XXVIII. FrontBase Functions
XXIX. filePro Functions
XXX. 파일시스템 함수
XXXI. Forms Data Format Functions
XXXII. FriBiDi Functions
XXXIII. FTP Functions
XXXIV. Function Handling Functions
XXXV. Gettext
XXXVI. GMP Functions
XXXVII. HTTP 함수
XXXVIII. Hyperwave Functions
XXXIX. Hyperwave API Functions
XL. iconv 함수
XLI. Image Functions
XLII. IMAP, POP3 그리고 NNTP 함수
XLIII. Informix Functions
XLIV. InterBase Functions
XLV. Ingres II Functions
XLVI. IRC Gateway Functions
XLVII. PHP / Java Integration
XLVIII. LDAP Functions
XLIX. LZF Functions
L. 메일 함수
LI. mailparse Functions
LII. 수학 함수
LIII. Multibyte String Functions
LIV. MCAL Functions
LV. Mcrypt Encryption Functions
LVI. MCVE Payment Functions
LVII. Mhash Functions
LVIII. Mimetype Functions
LIX. Microsoft SQL Server Functions
LX. Ming functions for Flash
LXI. Miscellaneous Functions
LXII. mnoGoSearch Functions
LXIII. mSQL Functions
LXIV. MySQL 함수
LXV. Improved MySQL Extension
LXVI. Mohawk Software Session Handler Functions
LXVII. muscat Functions
LXVIII. 네트워크 관련 함수
LXIX. Ncurses Terminal Screen Control Functions
LXX. Lotus Notes Functions
LXXI. NSAPI-specific Functions
LXXII. Unified ODBC Functions
LXXIII. Object Aggregation/Composition Functions
LXXIV. 오라클 8 함수
LXXV. OpenSSL Functions
LXXVI. Oracle Functions
LXXVII. Ovrimos SQL Functions
LXXVIII. 출력 제어 함수
LXXIX. Object property and method call overloading
LXXX. PDF functions
LXXXI. Verisign Payflow Pro Functions
LXXXII. PHP 옵션&정보
LXXXIII. POSIX Functions
LXXXIV. PostgreSQL 함수
LXXXV. Process Control Functions
LXXXVI. Program Execution Functions
LXXXVII. Printer Functions
LXXXVIII. Pspell 함수
LXXXIX. GNU Readline
XC. GNU Recode Functions
XCI. 정규표현식 함수 (펄-호환)
XCII. qtdom Functions
XCIII. Regular Expression Functions (POSIX Extended)
XCIV. 세마포어(semaphore)와 공유 메모리(shared memory) 함수
XCV. SESAM Database Functions
XCVI. Session Handling Functions
XCVII. 공유 메모리 함수
XCVIII. SimpleXML functions
XCIX. SOAP Functions
C. SQLite
CI. Shockwave Flash Functions
CII. SNMP Functions
CIII. Socket Functions
CIV. Standard PHP Library (SPL) Functions
CV. Stream Functions
CVI. 문자열 함수
CVII. Sybase Functions
CVIII. TCP Wrappers Functions
CIX. Tidy Functions
CX. Tokenizer Functions
CXI. URL 함수
CXII. 변수 관련 함수
CXIII. vpopmail Functions
CXIV. W32api Functions
CXV. WDDX Functions
CXVI. XML 해석기 함수
CXVII. XML-RPC Functions
CXVIII. xdiff Functions
CXIX. XSL functions
CXX. XSLT Functions
CXXI. YAZ functions
CXXII. YP/NIS 관련 함수
CXXIII. Zip File Functions (Read Only Access)
CXXIV. Zlib 압축 함수

이전 | 처음으로 | 다음
커맨드 라인에서 PHP 사용하기 |  | 아파치 함수


아파치 함수

PHP 매뉴얼
이전 다음

I. 아파치 함수

소개

이 함수들은 PHP를 아파치 모듈로 실행할때만 사용할 수 있습니다.

설치

아파치에 PHP를 설치하기 위해서는 설치 챕터의 아파치 섹션을 참고하십시오.

런타임 설정

아파치 PHP 모듈의 동작은 php.ini의 설정에 영향을 받습니다. php.ini의 환결 설정은 서버 환경 설정 파일이나 .htaccess 파일의 php_flag 설정을 통하여 변경할 수 있습니다.

예 1. .htaccess를 이용해서 PHP 파싱을 끄기

php_flag engine off

표 1. 아파치 환경 설정 옵션

이름 | 기본값 | 변경가능성 | 기능
engine | On | PHP_INI_ALL | PHP 파싱을 on, 또는 off 합니다.
child_terminate | Off | PHP_INI_ALL | 요청의 마지막에 자식 프로세스에 대한 종료 요청을 할 수 있는 PHP 스크립트를 지정합니다. apache_child_terminate()를 참고하십시오.
last_modified | Off | PHP_INI_ALL | 요청에 대한 PHP 스크립트의 변경일을 Last-Modified: 헤더로 전송합니다.
xbithack | Off | PHP_INI_ALL | 실행 비트가 설정되어 있는 파일에 대해서 PHP가 파일 끝을 인식하지 않게 합니다.

위 설정 지시어에 대한 간단한 설명입니다.

engine boolean

이 지시어는 PHP의 아파치 모듈에 유용합니다. PHP 파싱을 사이트의 디렉토리 단위나 버추얼 서버 단위로 켜거나 끌 수 있습니다. engine off를 httpd.conf 파일의 적절한 위치에 놓음으로써, PHP의 사용 여부를 결정할 수 있습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
apache_child_terminate -- 이 요청 후에 아파치 프로세스를 종료한다.
apache_get_modules -- 불러진 아파치 모듈의 목록을 얻습니다.
apache_get_version -- 아파치 버전을 가져옵니다.
apache_getenv -- 아파치 부프로세스의 환경 변수를 얻습니다.
apache_lookup_uri -- 특정한 URI에 대한 부분 요청을 실행하고 그에 대한 모든 정보를 반환한다.
apache_note -- 아파치의 요청 노트를 얻거나 설정한다.
apache_request_headers -- 모든 HTTP 요청 헤더를 가져옵니다.
apache_response_headers -- 모든 HTTP 응답 헤더를 가져옵니다.
apache_setenv -- 아파치의 subprocess_env 변수를 설정한다.
ascii2ebcdic -- 문자열을 ASCII에서 EBCDIC로 변환한다.
ebcdic2ascii -- 문자열을 EBCDIC에서 ASCII로 변환한다.
getallheaders -- 모든 HTTP 요청 헤더를 가져옵니다.
virtual -- 아파치 하위 요청을 실행합니다.

이전 | 처음으로 | 다음
함수 레퍼런스 | 위로 | apache_child_terminate


apache_child_terminate

(PHP 4 >= 4.0.5, PHP 5)

apache_child_terminate -- 이 요청 후에 아파치 프로세스를 종료한다.

설명

bool apache_child_terminate ( void )

apache_child_terminate()는 PHP 코드의 실행이 끝났을 때 프로세스를 종료시키기 위하여 현재 PHP 요청을 실행하는 아파치 프로세스를 등록합니다. 보통 메모리는 내부적으로 사용할 수 있게 해제되지만, 운영 체계에 반환되지 않기 때문에 많은 메모리를 소모하는 스크립트를 실행한 후에 프로세스를 종료시키기 위해서 사용됩니다.

참고: 이 기능은 php.ini에서 지시어 apache.child_terminate를 통해서 유효화 할 수 있습니다. 기본값은 off입니다.

이 기능은 아파치의 win32 버전 같은 멀티쓰레드(multithread) 버전에서는 사용할 수 없습니다.

참고: exit().

이전 | 처음으로 | 다음
아파치 함수 | 위로 | apache_get_modules


apache_get_modules

(PHP 4 >= 4.3.2, PHP 5)

apache_get_modules -- 불러진 아파치 모듈의 목록을 얻습니다.

설명

array apache_get_modules ( void )

이 함수는 불러진 아파치 모듈을 나타내는 배열을 반환합니다.

예 1. apache_get_modules() example

<?php
print_r(apache_get_modules());
?>

위 예제는 다음과 비슷한 출력을 합니다:

Array
(
    [0] => core
    [1] => http_core
    [2] => mod_so
    [3] => sapi_apache2
    [4] => mod_mime
    [5] => mod_rewrite
)

이전 | 처음으로 | 다음
apache_child_terminate | 위로 | apache_get_version


apache_get_version

(PHP 4 >= 4.3.2, PHP 5)

apache_get_version -- 아파치 버전을 가져옵니다.

설명

string apache_get_version ( void )

apache_get_version()은 아파치 버전을 문자열로 반환하거나, 실패시에 FALSE를 반환합니다.

예 1. apache_get_version() 예제

<?php
$version = apache_get_version();
echo "$version\n";
?>

위 프로그램의 출력은 다음과 비슷할 것입니다:

Apache/1.3.29 (Unix) PHP/4.3.4

참고: phpinfo().

이전 | 처음으로 | 다음
apache_get_modules | 위로 | apache_getenv


apache_getenv

(PHP 4 >= 4.3.0, PHP 5)

apache_getenv -- 아파치 부프로세스의 환경 변수를 얻습니다.

설명

string apache_getenv ( string variable [, bool walk_to_top])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
apache_get_version | 위로 | apache_lookup_uri


apache_lookup_uri

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

apache_lookup_uri -- 특정한 URI에 대한 부분 요청을 실행하고 그에 대한 모든 정보를 반환한다.

설명

object apache_lookup_uri ( string filename)

URI에 대한 부분 요청을 실행합니다. 주어진 자원에 대하여 모든 중요한 정보를 포함하여 많은 정보를 클래스로 반환합니다. 반환하는 클래스의 속성은 다음과 같습니다:

status
the_request
status_line
method
content_type
handler
uri
filename
path_info
args
boundary
no_cache
no_local_copy
allowed
send_bodyct
bytes_sent
byterange
clength
unparsed_uri
mtime
request_time

예 1. apache_lookup_uri() 예제

<?php
$info = apache_lookup_uri('index.php?var=value');
print_r($info);

if (file_exists($info->filename)) {
    echo '파일이 존재합니다!';
}
?>

위 예제의 출력 예는:

stdClass Object
(
    [status] => 200
    [the_request] => GET /dir/file.php HTTP/1.1
    [method] => GET
    [mtime] => 0
    [clength] => 0
    [chunked] => 0
    [content_type] => application/x-httpd-php
    [no_cache] => 0
    [no_local_copy] => 1
    [unparsed_uri] => /dir/index.php?var=value
    [uri] => /dir/index.php
    [filename] => /home/htdocs/dir/index.php
    [args] => var=value
    [allowed] => 0
    [sent_bodyct] => 0
    [bytes_sent] => 0
    [request_time] => 1074282764
)
파일이 존재합니다!

참고: apache_lookup_uri()는 PHP를 아파치 모듈로 설치했을 경우에만 작동합니다.

이전 | 처음으로 | 다음
apache_getenv | 위로 | apache_note


apache_note

(PHP 3>= 3.0.2, PHP 4 , PHP 5)

apache_note -- 아파치의 요청 노트를 얻거나 설정한다.

설명

string apache_note ( string note_name [, string note_value])

apache_note()는 요청의 notes 테이블에 존재하는 값을 얻거나 설정하는 아파치 전용 함수입니다. 하나의 인자로 호출하면, note_name의 현재 노트값을 반환합니다. 두개의 인자로 호출하면, note_name의 노트값을 note_value로 설정하고, note_name의 이전 노트값을 반환합니다.

이전 | 처음으로 | 다음
apache_lookup_uri | 위로 | apache_request_headers


apache_request_headers

(PHP 4 >= 4.3.0, PHP 5)

apache_request_headers -- 모든 HTTP 요청 헤더를 가져옵니다.

설명

array apache_request_headers ( void )

apache_request_headers()는 현재 요청의 모든 HTTP 헤더를 연합 배열로 반환합니다. PHP를 Apache 모듈로 사용할때만 지원합니다.

예 1. apache_request_headers() 예제

<?php
$headers = apache_request_headers();

foreach ($headers as $header => $value) {
    echo "$header: $value <br />\n";
}
?>

참고:
      PHP 4.3.0 이전에, apache_request_headers()는
      getallheaders()로 불리워졌습니다. PHP 4.3.0 이후의
      getallheaders()는 apache_request_headers()의
      단축형입니다.

참고: 환경 변수에서 일반 CGI 변수를 읽어서, PHP를 Apache 모듈로 사용하고 있는지를 확인할 수 있습니다. 모든 사용 가능한 환경 변수 목록은 phpinfo()를 이용해서 볼 수 있습니다.

참고: PHP 4.3.3부터 이 함수를 넷스케이프/iPlanet/SunONE 웹서버의 NSAPI 서버 모듈에서도 사용할 수 있습니다.

참고: apache_response_headers().

이전 | 처음으로 | 다음
apache_note | 위로 | apache_response_headers


apache_response_headers

(PHP 4 >= 4.3.0, PHP 5)

apache_response_headers -- 모든 HTTP 응답 헤더를 가져옵니다.

설명

array apache_response_headers ( void )

모든 아파치 응답 헤더의 배열을 반환합니다. 이 기능은 PHP 4.3.0 이상에서만 사용할 수 있습니다.

참고: PHP 4.3.3부터 이 함수를 넷스케이프/iPlanet/SunONE 웹서버의 NSAPI 서버 모듈에서도 사용할 수 있습니다.

참고: apache_request_headers(), headers_sent().

이전 | 처음으로 | 다음
apache_request_headers | 위로 | apache_setenv


apache_setenv

(PHP 4 >= 4.2.0, PHP 5)

apache_setenv -- 아파치의 subprocess_env 변수를 설정한다.

설명

int apache_setenv ( string variable, string value [, bool walk_to_top])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
apache_response_headers | 위로 | ascii2ebcdic


ascii2ebcdic

(PHP 3>= 3.0.17)

ascii2ebcdic -- 문자열을 ASCII에서 EBCDIC로 변환한다.

설명

int ascii2ebcdic ( string ascii_str)

ascii2ebcdic()는 EBCDIC 기반 운영체계(OS/390, BS2000)에서만 사용할 수 있는 아파치 전용 함수입니다. ASCII로 인코드된 문자열 ascii_str을 EBCDIC 표현으로 변환하고 그 결과를 반환합니다. (binary safe)

참조: 역함수 ebcdic2ascii().

이전 | 처음으로 | 다음
apache_setenv | 위로 | ebcdic2ascii


ebcdic2ascii

(PHP 3>= 3.0.17)

ebcdic2ascii -- 문자열을 EBCDIC에서 ASCII로 변환한다.

설명

int ebcdic2ascii ( string ebcdic_str)

ebcdic2ascii()는 EBCDIC 기반 운영체계(OS/390, BS2000)에서만 사용할 수 있는 아파치 전용 함수입니다. EBCDIC로 인코드된 문자열 ebcdic_str을 ASCII 표현으로 변환하고 그 결과를 반환합니다. (binary safe)

참조: 역함수 ascii2ebcdic().

이전 | 처음으로 | 다음
ascii2ebcdic | 위로 | getallheaders


getallheaders

(PHP 3, PHP 4 , PHP 5)

getallheaders -- 모든 HTTP 요청 헤더를 가져옵니다.

설명

array getallheaders ( void )

getallheaders()는 apache_request_headers()의 별칭입니다. 현재 요청의 모든 HTTP 헤더를 연합 배열로 반환합니다. 이 함수의 작동에 대한 정보는 apache_request_headers() 문서를 읽어보십시오.

참고: PHP 4.3.0에서, getallheaders()는 apache_request_headers()의 별칭이 되었습니다. 정확히는 이름이 바뀌었습니다. 이는 이 함수가 Apache 모듈로 컴파일했을 때만 작동하기 때문입니다.

참고: PHP 4.3.3부터 이 함수를 넷스케이프/iPlanet/SunONE 웹서버의 NSAPI 서버 모듈에서도 사용할 수 있습니다.

참고: apache_request_headers().

이전 | 처음으로 | 다음
ebcdic2ascii | 위로 | virtual


virtual

(PHP 3, PHP 4 , PHP 5)

virtual -- 아파치 하위 요청을 실행합니다.

설명

int virtual ( string filename)

virtual()은 mod_include의 <!--#include virtual...-->과 동일한 아파치 전용 함수입니다. 이것은 아파치 하위 요청을 실행합니다. CGI 스크립트나 .shtml 파일 등 아파치를 통해서 실행 가능한 무엇이든 가능합니다. CGI 스크립트의 경우, 그 스크립트가 유효한 CGI 헤더를 생성해야 함에 주의하십시오. 최소한 Content-type 헤더가 필요합니다.

하위 요청을 실행할 때, 헤더를 포함한 모든 버퍼를 종료하고 브라우저에 출력합니다.

PHP 4.0.6부터, PHP 파일에 virtual()을 사용할 수 있습니다. 그러나, 다른 PHP 파일을 포함할때는 include()나 require()를 사용하는 편이 좋습니다.

참고: PHP 4.3.3부터 이 함수를 넷스케이프/iPlanet/SunONE 웹서버의 NSAPI 서버 모듈에서도 사용할 수 있습니다.

이전 | 처음으로 | 다음
getallheaders | 위로 | 배열함수


배열함수

PHP 매뉴얼
이전 다음

II. 배열함수

소개

이 함수는 다양한 방법으로 배열에 접근하고 배열을 조작할 수 있게 해 준다. 배열은 변수들의 집합을 저장, 관리, 처리하는데 있어서 핵심적이다.

일차원 뿐만 아니라 다차원 배열이 지원되고 있고, 사용자나 다른 함수에 의해 생성될 수 있다. 데이터베이스 질의문으로부터 배열을 생성하는 전용 데이터베이스 제어 함수와 배열을 반환하는 함수를 제공한다.

PHP에서의 배열 구현과 사용법에 대한 자세한 설명은 매뉴얼의 배열 섹션을 참고.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

아래 상수들은 PHP 코어의 일부로, 항상 사용할 수 있습니다.

CASE_LOWER (integer)

CASE_LOWER는 array_change_key_case() 함수에서 배열 키를 소문자로 변환하는데 사용된다. 또한 이 상수는 array_change_key_case()의 기본값이다.

CASE_UPPER (integer)

CASE_UPPER는 array_change_key_case() 함수에서 배열 키를 대문자로 변환하는데 사용된다.

정렬 순서 플래그:

SORT_ASC (integer)

SORT_ASC는 array_multisort() 함수에서 오름차순 정렬에 사용된다.

SORT_DESC (integer)

SORT_DESC는 array_multisort() 함수에서 내림차순 정렬에 사용된다.

정렬 형태 플래그: 여러 정렬함수에 의해 사용됨.

SORT_REGULAR (integer)

SORT_REGULAR는 아이템들을 통상적인 방법으로 비교하는데 사용됨.

SORT_NUMERIC (integer)

SORT_NUMERIC는 아이템들을 수치로서 비교하는데 사용됨.

SORT_STRING (integer)

SORT_STRING는 아이템들을 문자열로서 비교하는데 사용됨.

COUNT_NORMAL (integer)

COUNT_RECURSIVE (integer)

EXTR_OVERWRITE (integer)

EXTR_SKIP (integer)

EXTR_PREFIX_SAME (integer)

EXTR_PREFIX_ALL (integer)

EXTR_PREFIX_INVALID (integer)

EXTR_PREFIX_IF_EXISTS (integer)

EXTR_IF_EXISTS (integer)

EXTR_REFS (integer)

참고

is_array(), explode(),
implode(), split(),
preg_split(), unset() 참고.

차례
array_change_key_case -- 모두 대문자나 소문자화된 문자열 키를 갖는 배열로 반환한다
array_chunk -- 배열을 여러 덩어리로 분산시킨다
array_combine -- 키를 위한 배열과 값을 위한 배열을 각각 사용하여 배열을 생성한다
array_count_values -- 배열 값의 수를 센다
array_diff_assoc -- 인덱스 검사와 함께 배열간의 차이를 계산한다
array_diff_uassoc -- Computes the difference of arrays with additional index check which is performed by a user supplied callback function.
array_diff -- 배열간의 차이를 계산한다
array_fill -- 배열을 특정값으로 채운다
array_filter -- 콜백함수를 사용하여 배열의 원소를 필터한다
array_flip -- 배열안의 모든 키를 각 키의 연관값으로 바꾼다.
array_intersect_assoc -- 인덱스 검사과 함께 배열의 중복을 계산한다
array_intersect -- 배열의 중복을 계산한다
array_key_exists -- 주어진 키와 인덱스가 배열에 존재하는지 확인한다
array_keys -- 배열의 모든 키를 반환한다
array_map -- Applies the callback to the elements of the given arrays
array_merge_recursive -- 두개 이상의 배열을 재귀적으로 병합한다
array_merge -- 두개 이상의 배열을 병합한다
array_multisort -- 여러개의 배열 또는 다차원 배열을 정렬한다
array_pad -- 설정된 길이만큼 특정 값으로 배열을 채운다
array_pop -- 배열 끝의 요소를 뽑아낸다
array_push -- 배열의 끝에 하나 이상의 원소를 넣는다.
array_rand -- 배열안에서 하나 이상의 임의 원소를 뽑아낸다
array_reduce -- 콜백 함수를 사용하여 배열을 반복적으로 단일 값으로 축소시킨다
array_reverse -- 배열 원소를 역순으로 반환한다
array_search -- 배열에서 주어진 값을 검색하고 성공하면 해당 키를 반환한다
array_shift -- 배열의 맨 앞에 있는 원소를 옆으로 이동시킨다
array_slice -- 배열의 일부를 추출한다
array_splice -- 배열의 일부를 삭제하고, 그 위치에 다른 내용을 대체한다
array_sum -- 배열내의 값들의 합을 계산한다
array_udiff_assoc -- Computes the difference of arrays with additional index check. The data is compared by using a callback function.
array_udiff_uassoc -- Computes the difference of arrays with additional index check. The data is compared by using a callback function. The index check is done by a callback function also
array_udiff -- Computes the difference of arrays by using a callback function for data comparison.
array_unique -- 배열에서 중복된 값을 제거한다
array_unshift -- 배열의 맨 앞에 하나 이상의 원소를 첨가한다
array_values -- 배열의 모든 값들을 반환한다
array_walk -- 배열의 개개의 원소에 대해서 특정 함수를 적용하여 수행한다
array -- 배열을 생성한다
arsort -- 배열을 내림차순 정렬하고 인덱스의 상관관계를 유지한다.
asort -- 배열을 정렬하고 인덱스 상관 관계를 유지한다
compact -- 여러 변수들과 값을 갖는 배열을 생성한다
count -- 변수의 원소 갯수를 구한다
current -- 배열의 현재 원소를 반환한다
each -- 배열에서 현재의 키와 값 쌍을 반환하고 배열 커서를 전진시킨다
end -- 내부 배열 포인터를 마지막 원소를 가리키게 한다
extract -- 배열의 현재 심볼 테이블로 변수들을 입력한다
in_array -- 배열에서 값이 존재하는지 점검한다
key -- 연관배열에서 키를 꺼낸다
krsort -- 역순으로 키에 의해 배열을 정렬한다
ksort -- 키에 의해 배열을 정렬한다
list -- 배열처럼 변수들을 지정한다
natcasesort -- 대소문자를 구별하지 않고 "natural order" 알고리즘을 사용하여 배열을 정렬한다
natsort -- "natural order" 알고리즘을 사용하여 배열을 정렬한다
next -- 배열의 내부 배열 포인터를 전진시킨다
pos -- 배열에서 현재 원소를 꺼내온다
prev -- 내부 배열 포인터를 앞으로 돌린다
range -- 특정 범위의 원소를 갖는 배열을 생성한다
reset -- 배열의 내부 포인터가 배열의 첫번째 원소를 가리키게 한다
rsort -- 역순으로 배열을 정렬한다
shuffle -- 배열을 뒤섞는다
sizeof -- count()의 별칭
sort -- 배열을 정렬한다
uasort -- 사용자-정의 비교함수로 배열을 정렬하고 인덱스 연관성을 유지한다
uksort -- 사용자-정의된 비교함수를 사용하여 키에 의해 배열을 정렬한다
usort -- 사용자-정의된 비교함수를 사용하여 값들에 의해 배열을 정렬한다

이전 | 처음으로 | 다음
virtual | 위로 | array_change_key_case


array_change_key_case

(PHP 4 >= 4.2.0, PHP 5)

array_change_key_case -- 모두 대문자나 소문자화된 문자열 키를 갖는 배열로 반환한다

설명

array array_change_key_case ( array input [, int case])

array_change_key_case()는 input 배열 안의 키를 모두 소문자나 대문자로 변경한다. 변경은 마지막 선택적인 case 매개변수에 의해 결정된다. 그 매개변수에 CASE_UPPER 와 CASE_LOWER 두 가지 상수를 전달할수 있다. 기본값은 CASE_LOWER 이다. 이 함수는 숫자키는 그대로 두게 된다.

예 1. array_change_key_case() 예제코드

<?php
$input_array = array("FirSt" => 1, "SecOnd" => 4);
print_r(array_change_key_case($input_array, CASE_UPPER));
?>

위 프로그램의 출력은 다음과 같다:

Array
(
    [FIRST] => 1
    [SECOND] => 4
)

배열이 이 함수가 실행된후 같은 인덱스를 갖는다면(예 "keY"와 "kEY"), 배열에서 나중에 오는 값이 다른 인덱스를 덮어쓰게 된다.

이전 | 처음으로 | 다음
배열함수 | 위로 | array_chunk


array_chunk

(PHP 4 >= 4.2.0, PHP 5)

array_chunk -- 배열을 여러 덩어리로 분산시킨다

설명

array array_chunk ( array input, int size [, bool preserve_keys])

array_chunk() 는 size 값으로 여러개의 배열안에 배열을 분산시킨다. 마지막 배열에서는 그 값보다 적은수의 값들을 갖는 배열을 갖을 수 있다. 0부터 시작되는 인덱스를 갖는 다차원 배열의 구성원으로서의 배열을 얻는다.

선택적인 preserve_keys 매개변수를 TRUE로 설정함으로써, PHP가 입력 배열로부터의 원래 키를 유지할수 있게 한다. FALSE를 설정하면, 새로운 숫자 키가 사용될것이고 각 결과 배열들은 0부터 시작된다. 기본값은 FALSE이다.

예 1. array_chunk() 예제코드

<?php
$input_array = array('a', 'b', 'c', 'd', 'e');
print_r(array_chunk($input_array, 2));
print_r(array_chunk($input_array, 2, TRUE));
?>

위 프로그램의 출력은 다음과 같을것이다:

Array
(
    [0] => Array
        (
            [0] => a
            [1] => b
        )

    [1] => Array
        (
            [0] => c
            [1] => d
        )

    [2] => Array
        (
            [0] => e
        )

)
Array
(
    [0] => Array
        (
            [0] => a
            [1] => b
        )

    [1] => Array
        (
            [2] => c
            [3] => d
        )

    [2] => Array
        (
            [4] => e
        )

)

이전 | 처음으로 | 다음
array_change_key_case | 위로 | array_combine


array_combine

(PHP 5)

array_combine -- 키를 위한 배열과 값을 위한 배열을 각각 사용하여 배열을 생성한다

설명

array array_combine ( array keys, array values)

keys 배열에서의 값들을 키로 사용하고 values 배열에서의 값들을 해당 값들로 사용하여 array 를 반환한다.

각각의 배열 원소의 수가 같지 않거나 그 배열들이 비어있으면 FALSE를 반환한다.

예 1. 단순한 array_combine() 예제코드

<?php
$a = array('green','red','yellow');
$b = array('avocado','apple','banana');
$c = array_combine($a, $b);

print_r($c);

/* Outputs:
Array
(
    [green]  => avocado
    [red]    => apple
    [yellow] => banana
)
*/
?>

array_merge(),
array_walk(),
array_values() 참고.

이전 | 처음으로 | 다음
array_chunk | 위로 | array_count_values


array_count_values

(PHP 4 , PHP 5)

array_count_values -- 배열 값의 수를 센다

설명

array array_count_values ( array input)

array_count_values()는 input 배열값을 키로 사용하고 input 배열의 각 값의 빈도수를 값으로 갖는 배열을 반환한다.

예 1. array_count_values() 예제코드

<?php
$array = array (1, "hello", 1, "world", "hello");
print_r(array_count_values ($array));
?>

The printout of the above program will be:

Array
(
    [1] => 2
    [hello] => 2
    [world] => 1
)

count(),
array_unique(),
array_values(),
count_chars() 참고.

이전 | 처음으로 | 다음
array_combine | 위로 | array_diff_assoc


array_diff_assoc

(PHP 4 >= 4.3.0, PHP 5)

array_diff_assoc -- 인덱스 검사와 함께 배열간의 차이를 계산한다

설명

array array_diff_assoc ( array array1, array array2 [, array ...])

array_diff_assoc()는 array1 중에서 다른 인자에서 존재하지 않는 모든 값들을 포함하는 배열을 반환한다. 이 함수는 array_diff()과 달리 비교시에 키가 사용된다는것에 주의한다.

예 1. array_diff_assoc() 예제코드

<?php
$array1 = array ("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array ("a" => "green", "yellow", "red");
$result = array_diff_assoc ($array1, $array2);

/* The result is:
Array
(
    [b] => brown
    [c] => blue
    [0] => red
)
*/
?>

위 예제코드에서 "a" => "green" 쌍은 두 배열에 모두 존재하기 때문에 이 함수의 출력에서 존재하지 않는다. 이와 달리, 0 => "red" 쌍은 출력에 보이는데 그 이유는 두번째 인자에서 "red" 가 1 이라는 키를 갖기 때문이다.

key => value 쌍에서 두 구성요소가 동치라고 볼수 있는 때는 (string) $elem1 === (string) $elem2 일때 만이다. 달리 말하면 엄격한 타입 검사는 문자열 대표성이 동일해야 한다는것이다.

참고: 이 함수는 n-차원 배열의 한개 차원만 검사한다는것에 주의한다. 물론 array_diff_assoc($array1[0], $array2[0]);와 같은 방법으로 내부 차원을 검사할수 있다.

array_diff(),
array_intersect(),
array_intersect_assoc() 참고.

이전 | 처음으로 | 다음
array_count_values | 위로 | array_diff_uassoc


array_diff_uassoc

(PHP 5)

array_diff_uassoc -- Computes the difference of arrays with additional index check which is performed by a user supplied callback function.

Description

array array_diff_assoc ( array array1, array array2 [, array ..., callback key_compare_func])

array_diff_uassoc() returns an array containing all the values from array1 that are not present in any of the other arguments. Note that the keys are used in the comparison unlike array_diff(). This comparison is done by a user supplied callback function. It must return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second. This is unlike array_diff_assoc() where an internal function for comparing the indices is used.

예 1. array_diff_uassoc() example

<?php
function key_compare_func($a, $b)
{
    if ($a === $b) {
        return 0;
    }
    return ($a > $b)? 1:-1;
}

$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "green", "yellow", "red");
$result = array_diff_uassoc($array1, $array2, "key_compare_func");
?>

The result is:

Array
(
    [b] => brown
    [c] => blue
    [0] => red
)

In our example above you see the "a" => "green" pair is present in both arrays and thus it is not in the ouput from the function. Unlike this, the pair 0 => "red" is in the ouput because in the second argument "red" has key which is 1.

The equality of 2 indices is checked by the user supplied callback function.

참고: Please note that this function only checks one dimension of a n-dimensional array. Of course you can check deeper dimensions by using, for example, array_diff_uassoc($array1[0], $array2[0], "key_compare_func");.

See also
array_diff(),
array_diff_assoc(),
array_udiff(),
array_udiff_assoc(),
array_udiff_uassoc(),
array_intersect(),
array_intersect_assoc(),
array_uintersect(),
array_uintersect_assoc() and
array_uintersect_uassoc().

이전 | 처음으로 | 다음
array_diff_assoc | 위로 | array_diff


array_diff

(PHP 4 >= 4.0.1, PHP 5)

array_diff -- 배열간의 차이를 계산한다

설명

array array_diff ( array array1, array array2 [, array ...])

array_diff()는 array1 중에서 다른 인자에서 존재하지 않는 모든 값들을 포함하는 배열을 반환한다. 키는 보존된다는 것에 주의.

예 1. array_diff() 예제코드

<?php
$array1 = array ("a" => "green", "red", "blue", "red");
$array2 = array ("b" => "green", "yellow", "red");
$result = array_diff ($array1, $array2);
?>

위 코드는 $result 가 array ("blue"); 값을 갖게 한다. $array1 안에서 여러값들의 차이가 발생한다면 모두 같은 방식으로 처리된다.

참고: 두 구성요소가 동치라고 볼수 있는 때는 (string) $elem1 === (string) $elem2 일때 만이다. In words: when the string representation is the same.

참고: 이 함수는 n-차원의 배열 중 한 차원만 검사한다는 것에 주의한다. 물론 array_diff($array1[0], $array2[0]); 을 사용하여 더 깊은 차원들을 검사할수 있다.

주의

이 함수는 PHP 4.0.4에서 제대로 동작하지 않았다!

array_diff_assoc(),
array_intersect(),
array_intersect_assoc() 참고.

이전 | 처음으로 | 다음
array_diff_uassoc | 위로 | array_fill


array_fill

(PHP 4 >= 4.2.0, PHP 5)

array_fill -- 배열을 특정값으로 채운다

설명

array array_fill ( int start_index, int num, mixed value)

array_fill()은 배열은 value 매개변수의 값, start_index로 시작되는 키의 num 엔트리들로 채운다. num 는 0보다 큰 수가 되어야 하고, 그렇지 않으면 PHP 는 경고를 보여준다.

예 1. array_fill() 예제코드

<?php
$a = array_fill(5, 6, 'banana');
print_r($a);
?>

$a 는 현재 다음과 같다:

Array
(
    [5]  => banana
    [6]  => banana
    [7]  => banana
    [8]  => banana
    [9]  => banana
    [10] => banana
)

str_repeat(), range() 참고.

이전 | 처음으로 | 다음
array_diff | 위로 | array_filter


array_filter

(PHP 4 >= 4.0.6, PHP 5)

array_filter -- 콜백함수를 사용하여 배열의 원소를 필터한다

설명

array array_filter ( array input [, callback function])

array_filter()는 input 배열안의 각값에 callback 함수에 전달하는 작업을 반복한다. callback 함수가 true를 반환하면, input의 현재값이 결과 배열로 반환된다. 배열 키들은 보존된다.

예 1. array_filter() 예제코드

<?php
function odd($var) {
    return ($var % 2 == 1);
}

function even($var) {
    return ($var % 2 == 0);
}

$array1 = array ("a"=>1, "b"=>2, "c"=>3, "d"=>4, "e"=>5);
$array2 = array (6, 7, 8, 9, 10, 11, 12);

echo "Odd :\n";
print_r(array_filter($array1, "odd"));
echo "Even:\n";
print_r(array_filter($array2, "even"));
?>

위 예제코드는 다음과 같이 출력된다:

Odd :
Array
(
    [a] => 1
    [c] => 3
    [e] => 5
)
Even:
Array
(
    [0] => 6
    [2] => 8
    [4] => 10
    [6] => 12
)

유저는 콜백 함수에서 배열 자체를 변경할수 없다. 즉 원소를 추가/삭제, array_filter()가 적용되는 배열을 unset시킬수없다. 배열이 변경되면 이 함수의 동작은 예상할수 없게된다.

array_map(), array_reduce(), array_walk() 참고.

이전 | 처음으로 | 다음
array_fill | 위로 | array_flip


array_flip

(PHP 4 , PHP 5)

array_flip -- 배열안의 모든 키를 각 키의 연관값으로 바꾼다.

설명

array array_flip ( array trans)

array_flip()은 뒤집힌 순서의 array를 반환한다. 즉, trans의 키는 값이 되고, trans의 값은 키가 된다.

trans의 값들은 유효한 키가 되어야 한다는 것에 주의한다. 즉, 그 값들은 integer나 string이 될 필요가 있다. 어떤 값이 잘못된 타입을 갖으면 경고메시지가 보일것이다. 그리고 결과적으로 키/값 쌍은 뒤집히지 않을것이다.

같은 값이 여러번 출현하면, 그 값의 제일 마지막 키를 사용할것이고, 나머지 모두 사라지게 될것이다.

실패하면, array_flip() 는 FALSE를 반환한다.

예 1. array_flip() 예제코드

<?php
$trans = array_flip ($trans);
$original = strtr ($str, $trans);
?>

예 2. array_flip() 예제코드 : 충돌

<?php
$trans = array ("a" => 1, "b" => 1, "c" => 2);
$trans = array_flip ($trans);
print_r($trans);
?>

now $trans is:

Array
(
    [1] => b
    [2] => c
)

array_values(),
array_keys(),
array_reverse() 참고.

이전 | 처음으로 | 다음
array_filter | 위로 | array_intersect_assoc


array_intersect_assoc

(PHP 4 >= 4.3.0, PHP 5)

array_intersect_assoc -- 인덱스 검사과 함께 배열의 중복을 계산한다

설명

array array_intersect_assoc ( array array1, array array2 [, array ...])

array_intersect_assoc()는 모든 인자에 존재하는 array1의 모든 값을 포함하는 배열을 반환한다. 이 함수는 array_intersect()과 달리 비교시에 키가 사용된다는것에 주의한다.

예 1. array_intersect_assoc() 예제코드

<?php
$array1 = array ("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array ("a" => "green", "yellow", "red");
$result_array = array_intersect_assoc ($array1, $array2);

/* $result_array will look like:

Array
(
    [a] => green
)

*/
?>

위 예제에서 "a" => "green" 쌍만 두 배열 안에서 존재하고 그 값들만 반환한다는것을 확인할수 있다. "red" 값은 $array1안에서 그 키가 2이고 $array2안에서는 1이기 때문에 반환하지 않는다.

key => value 쌍의 두 값이 동치라고 볼수 있는 때는 (string) $elem1 === (string) $elem2 일때 만이다. 달리 말하면 엄격한 타입 검사는 문자열 대표성이 동일해야 한다는것이다.

See also array_intersect(),
array_diff() and
array_diff_assoc().

이전 | 처음으로 | 다음
array_flip | 위로 | array_intersect


array_intersect

(PHP 4 >= 4.0.1, PHP 5)

array_intersect -- 배열의 중복을 계산한다

설명

array array_intersect ( array array1, array array2 [, array ...])

array_intersect()는 모든 인자에 존재하는 array1의 모든 값을 포함하는 배열을 반환한다. 키는 보존된다는 것에 주의할것.

예 1. array_intersect() 예제코드

<?php
$array1 = array ("a" => "green", "red", "blue");
$array2 = array ("b" => "green", "yellow", "red");
$result = array_intersect ($array1, $array2);
?>

위 예제코드는 $result가 다음 값을 갖게 한다.

Array
(
    [a] => green
    [0] => red
)

참고: 두 구성요소가 동치라고 볼수 있는 때는 (string) $elem1 === (string) $elem2 일때 만이다. In words: when the string representation is the same.

array_intersect_assoc(),
array_diff(),
array_diff_assoc() 참고.

이전 | 처음으로 | 다음
array_intersect_assoc | 위로 | array_key_exists


array_key_exists

(PHP 4 >= 4.1.0, PHP 5)

array_key_exists -- 주어진 키와 인덱스가 배열에 존재하는지 확인한다

설명

bool array_key_exists ( mixed key, array search)

array_key_exists() 는 주어진 key가 배열 안에서 설정되어 있으면 TRUE를 반환한다. key는 배열 인덱스로 사용할수 있는 어떤값이든 될수 있다.

예 1. array_key_exists() 예제코드

<?php
$search_array = array("first" => 1, "second" => 4);
if (array_key_exists("first", $search_array)) {
    echo "The 'first' element is in the array";
}
?>

참고: PHP 버전 4.0.6에서는 이 함수의 이름은 key_exists()이다.

isset(),
array_keys(),
in_array() 참고.

이전 | 처음으로 | 다음
array_intersect | 위로 | array_keys


array_keys

(PHP 4 , PHP 5)

array_keys -- 배열의 모든 키를 반환한다

설명

array array_keys ( array input [, mixed search_value])

array_keys()는 input 배열에서 숫자와 문자열의 키를 반환한다.

선택 인자 search_value가 지정되면, 그 값에 대한 키만 반환한다. 그렇지 않으면, input의 모든 키를 반환한다.

예 1. array_keys() 예제코드

<?php
$array = array (0 => 100, "color" => "red");
print_r(array_keys ($array));

$array = array ("blue", "red", "green", "blue", "blue");
print_r(array_keys ($array, "blue"));

$array = array ("color" => array("blue", "red", "green"),
                "size" => array("small", "medium", "large"));
print_r(array_keys ($array));
?>

위 프로그램의 결과값은 다음과 같을것이다:

Array
(
    [0] => 0
    [1] => color
)
Array
(
    [0] => 0
    [1] => 3
    [2] => 4
)
Array
(
    [0] => color
    [1] => size
)

array_values(), array_key_exists() 참고.

이전 | 처음으로 | 다음
array_key_exists | 위로 | array_map


array_map

(PHP 4 >= 4.0.6, PHP 5)

array_map -- Applies the callback to the elements of the given arrays

Description

array array_map ( mixed callback, array arr1 [, array ...])

array_map() returns an array containing all the elements of arr1 after applying the callback function to each one. The number of parameters that the callback function accepts should match the number of arrays passed to the array_map()

예 1. array_map() example

<?php
function cube($n)
{
    return($n * $n * $n);
}

$a = array(1, 2, 3, 4, 5);
$b = array_map("cube", $a);
print_r($b);
?>

This makes $b have:

Array
(
    [0] => 1
    [1] => 8
    [2] => 27
    [3] => 64
    [4] => 125
)

예 2. array_map() - using more arrays

<?php
function show_Spanish($n, $m)
{
    return("The number $n is called $m in Spanish");
}

function map_Spanish($n, $m)
{
    return(array($n => $m));
}

$a = array(1, 2, 3, 4, 5);
$b = array("uno", "dos", "tres", "cuatro", "cinco");

$c = array_map("show_Spanish", $a, $b);
print_r($c);

$d = array_map("map_Spanish", $a , $b);
print_r($d);
?>

This results:

// printout of $c
Array
(
    [0] => The number 1 is called uno in Spanish
    [1] => The number 2 is called dos in Spanish
    [2] => The number 3 is called tres in Spanish
    [3] => The number 4 is called cuatro in Spanish
    [4] => The number 5 is called cinco in Spanish
)

// printout of $d
Array
(
    [0] => Array
        (
            [1] => uno
        )

    [1] => Array
        (
            [2] => dos
        )

    [2] => Array
        (
            [3] => tres
        )

    [3] => Array
        (
            [4] => cuatro
        )

    [4] => Array
        (
            [5] => cinco
        )

)

Usually when using two or more arrays, they should be of equal length because the callback function is applied in parallel to the corresponding elements. If the arrays are of unequal length, the shortest one will be extended with empty elements.

An interesting use of this function is to construct an array of arrays, which can be easily performed by using NULL as the name of the callback function

예 3. Creating an array of arrays

<?php
$a = array(1, 2, 3, 4, 5);
$b = array("one", "two", "three", "four", "five");
$c = array("uno", "dos", "tres", "cuatro", "cinco");

$d = array_map(null, $a, $b, $c);
print_r($d);
?>

The printout of the program above will be:

Array
(
    [0] => Array
        (
            [0] => 1
            [1] => one
            [2] => uno
        )

    [1] => Array
        (
            [0] => 2
            [1] => two
            [2] => dos
        )

    [2] => Array
        (
            [0] => 3
            [1] => three
            [2] => tres
        )

    [3] => Array
        (
            [0] => 4
            [1] => four
            [2] => cuatro
        )

    [4] => Array
        (
            [0] => 5
            [1] => five
            [2] => cinco
        )

)

See also array_filter(),
array_reduce(), and
array_walk().

이전 | 처음으로 | 다음
array_keys | 위로 | array_merge_recursive


array_merge_recursive

(PHP 4 >= 4.0.1, PHP 5)

array_merge_recursive -- 두개 이상의 배열을 재귀적으로 병합한다

설명

array array_merge_recursive ( array array1, array array2 [, array ...])

array_merge_recursive()는 두개 이상의 배열 요소들을 병합하여 이전 배열의 끝에 다른 배열값들을 추가하고 이 배열을 반환한다.

입력되는 배열에 같은 문자열 키가 있으면, 이 키에 대한 값을 배열에 같이 병합시키고, 그리고 배열을 값으로 갖는 경우 다른 배열 안의 같은 이름의 배열에 그 값들을 병합할 수 있도록 이 동작을 재귀적으로 수행해 나간다. 하지만, 배열이 같은 숫자 키를 갖는다면, 뒤에 오는 값은 원래 값을 덮어쓰지 않고 추가될것이다.

예 1. array_merge_recursive() 예제코드

<?php
$ar1 = array ("color" => array ("favorite" => "red"), 5);
$ar2 = array (10, "color" => array ("favorite" => "green", "blue"));
$result = array_merge_recursive ($ar1, $ar2);
?>

The $result will be:

Array
(
    [color] => Array
        (
            [favorite] => Array
                (
                    [0] => red
                    [1] => green
                )

            [0] => blue
        )

    [0] => 5
    [1] => 10
)

array_merge() 참고.

이전 | 처음으로 | 다음
array_map | 위로 | array_merge


array_merge

(PHP 4 , PHP 5)

array_merge -- 두개 이상의 배열을 병합한다

설명

array array_merge ( array array1, array array2 [, array ...])

array_merge()는 두개이상의 배열의 요소들을 병합하고 앞의 배열의 끝에 배열값들을 추가한다. 그 결과 배열을 반환한다.

입력되는 배열이 같은 문자열 키를 갖는다면, 그 키에 대해서 나중에 온 값이 이전에 오는 키에 대한 값을 덮어쓸것이다. 하지만, 그 배열이 숫자 키를 포함하면, 나중 값은 원래 값을 덮어쓰지 않고, 뒤에 추가될것이다. appended.

예 1. array_merge() 예제코드

<?php
$array1 = array ("color" => "red", 2, 4);
$array2 = array ("a", "b", "color" => "green", "shape" => "trapezoid", 4);
$result = array_merge ($array1, $array2);
print_r($result);
?>

$result 는:

Array
(
    [color] => green
    [0] => 2
    [1] => 4
    [2] => a
    [3] => b
    [shape] => trapezoid
    [4] => 4
)

예 2. 단순한 array_merge() 예제코드

<?php
$array1 = array();
$array2 = array(1 => "data");
$result = array_merge($array1, $array2);
?>

숫자 키는 다른 숫자로 재부여된다는것을 잊지 말것!

Array
(
    [0] => data
)

배열을 온전히 보존하기를 원하고 그들 배열에 서로를 추가하고자 한다면, + 연산자를 사용한다:

<?php
$array1 = array();
$array2 = array(1 => "data");
$result = $array1 + $array2;
?>

숫자 키는 보존될것이고 따라서 그 조합이 남겨진다.

Array
(
    [1] => data
)

참고: 먼저 온사람이 먼저 대접받는다(first-come first-served) 기반에서 공유 키들이 덮어쓰여질것이다.

array_merge_recursive(), array_combine() 참고.

이전 | 처음으로 | 다음
array_merge_recursive | 위로 | array_multisort


array_multisort

(PHP 4 , PHP 5)

array_multisort -- 여러개의 배열 또는 다차원 배열을 정렬한다

설명

bool array_multisort ( array ar1 [, mixed arg [, mixed ... [, array ...]]])

array_multisort()는 한번에 여러개의 배열을 정렬하거나 다차원 배열은 내부에 포함되는 각 차원 중 한가지 배열을 정렬하는데 사용될수 있다. 정렬시에 키 조합은 유지된다.

입력되는 배열은 행(rows)에 의해 정렬되도록 테이블의 열(column)로 취급된다 - SQL ORDER BY 절의 기능과 비슷하다. 첫번째 배열은 정렬을 위한 기본(primary) 배열이다. 같은 배열과 배교되는 그 배열의 행(rows)(값)은 다음에 입력되는 배열들에 의해 정렬된다.

이 함수의 매개변수 구조는 약간 독특하면서도 유연하다. 제일 처음에 오는 매개변수는 배열이어야 하며, 다음에 오는 각각의 매개변수는 배열일수도 있고 다음 리스트의 정렬 플래그도 될수 있다.

정렬 방법 플래그:

  • SORT_ASC - 오름차순으로 정렬

  • SORT_DESC - 내림차순으로 정렬

정렬 형태 플래그:

  • SORT_REGULAR - 통상적으로 아이템을 비교

  • SORT_NUMERIC - 수치로서 아이템을 정렬

  • SORT_STRING - 문자열로서 아이템을 정렬

각 배열 뒤에 같은 타입의 두가지 정렬 플래그를 모두 지정할 수 없다. 하나의 배열 매개변수 뒤에 지정되는 정렬 플래그는 오직 그 배열에만 적용된다 - 이는 새로운 배열 매개변수가 오기 전에 기본값인 SORT_ASC 와 SORT_REGULAR 로 리셋된다.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. 여러 배열 정렬

<?php
$ar1 = array ("10", 100, 100, "a");
$ar2 = array (1, 3, "2", 1);
array_multisort ($ar1, $ar2);
?>

위 예제코드에서, 정렬후에는, 첫번째 배열은 10, "a", 100, 100을 포함할 것이다. 두번째 배열은 1, 1, "2", 3을 포함할 것이다. 첫번째 배열의 동일한 엔트리 (100과 100)와 대응되는 두번째의 엔트리도 정렬될것이다.

예 2. 다차원 배열 정렬

<?php
$ar = array (array ("10", 100, 100, "a"), array (1, 3, "2", 1));
array_multisort ($ar[0], SORT_ASC, SORT_STRING,
                 $ar[1], SORT_NUMERIC, SORT_DESC);
?>

위 예제코드에서, 정렬후에는, 첫번째 배열은 10, 100, 100, "a"를 포함 (오름차순으로 문자열을 정렬)하고, 두번째 배열은 1, 3, "2", 1 (내림차순으로 숫자로 정렬)을 포함할 것이다.

이전 | 처음으로 | 다음
array_merge | 위로 | array_pad


array_pad

(PHP 4 , PHP 5)

array_pad -- 설정된 길이만큼 특정 값으로 배열을 채운다

설명

array array_pad ( array input, int pad_size, mixed pad_value)

array_pad()는 pad_value 값을 pad_size 로 설정된 길이만큼을 채워넣은 input의 복사본을 반환한다. pad_size가 양수이면 배열의 오른쪽에 채워지고, 음수이면 왼쪽에 채워지게 된다. pad_size의 절대값이 input의 길이보다 작거나 같으면 패딩(padding)은 일어나지 않는다.

예 1. array_pad() 예제코드

<?php
$input = array (12, 10, 9);

$result = array_pad ($input, 5, 0);
// result is array (12, 10, 9, 0, 0)

$result = array_pad ($input, -7, -1);
// result is array (-1, -1, -1, -1, 12, 10, 9)

$result = array_pad ($input, 2, "noop");
// not padded
?>

array_fill(), range() 참고.

이전 | 처음으로 | 다음
array_multisort | 위로 | array_pop


array_pop

(PHP 4 , PHP 5)

array_pop -- 배열 끝의 요소를 뽑아낸다

설명

mixed array_pop ( array array)

array_pop()은 array의 마지막값을 뽑아 내고 그 값을 반환하며, array의 길이를 원소 하나 만큼 줄인다. array가 비어있으면 (또는 배열이 아니면) NULL을 반환한다.

참고: 이 함수는 사용 후에 array 포인터를 reset()합니다.

예 1. array_pop() 예제코드

<?php
$stack = array ("orange", "banana", "apple", "raspberry");
$fruit = array_pop ($stack);
print_r($stack);
?>

이 코드 수행후, $stack은 3개의 원소를 갖게될것이다:

Array
(
    [0] => orange
    [1] => banana
    [2] => apple
)

그리고 raspberry는 $fruit값이 된다.

주의

이 함수는 Boolean FALSE를 반환하지만, 0이나 ""와 같은 FALSE로 취급하는 Boolean이 아닌 값을 반환할 수도 있습니다. Booleans 섹션에서 자세한 정보를 얻을 수 있습니다. 이 함수의 반환값을 테스트하기 위해서 === 연산자를 이용하십시오.

array_push(),
array_shift(),
array_unshift() 참고.

이전 | 처음으로 | 다음
array_pad | 위로 | array_push


array_push

(PHP 4 , PHP 5)

array_push -- 배열의 끝에 하나 이상의 원소를 넣는다.

설명

int array_push ( array array, mixed var [, mixed ...])

array_push()는 array를 스택으로 취급하고, array 끝에 전달되어진 변수를 집어 넣는다. array의 길이는 집어넣은 변수의 수만큼 증가한다. 다음과 같은 효과를 갖는다:
<?php
$array[] = $var;
?>
각 var에 대해 반복된다.

배열에 새로 추가된 원소의 수를 반환한다.

예 1. array_push() 예제코드

<?php
$stack = array ("orange", "banana");
array_push ($stack, "apple", "raspberry");
print_r($stack);
?>

위 예제코드는 다음 원소를 갖는 $stack의 결과가 될것이다:

Array
(
    [0] => orange
    [1] => banana
    [2] => apple
    [3] => raspberry
)

array_pop(),
array_shift(),
array_unshift() 참고.

이전 | 처음으로 | 다음
array_pop | 위로 | array_rand


array_rand

(PHP 4 , PHP 5)

array_rand -- 배열안에서 하나 이상의 임의 원소를 뽑아낸다

설명

mixed array_rand ( array input [, int num_req])

array_rand()은 배열안에서 하나이상의 임의 원소를 꺼내 올때 가장 유용하다. input 배열과 꺼내고 싶은 원소 수를 설정하는 num_req 선택 인자를 취한다. 이 선택인자가 설정되지 않으면 기본값 1이 된다.

오직 한개의 원소만 꺼낼때에는 array_rand()는 임의 원소의 키를 반환하며, 여러 원소를 꺼낼때에는 임의 원소들의 키에 대한 배열을 반환한다. 이 함수는 배열에서 임의 키는 물론 값들을 꺼낼수 있다.

참고: PHP 4.2.0부터 srand()나 mt_srand()를 이용해서 난수값 생성기를 초기화 할 필요가 없습니다. 자동적으로 이루어집니다.

예 1. array_rand() 예제코드

<?php
srand ((float) microtime() * 10000000);
$input = array ("Neo", "Morpheus", "Trinity", "Cypher", "Tank");
$rand_keys = array_rand ($input, 2);
print $input[$rand_keys[0]]."\n";
print $input[$rand_keys[1]]."\n";
?>

shuffle 참고().

이전 | 처음으로 | 다음
array_push | 위로 | array_reduce


array_reduce

(PHP 4 >= 4.0.5, PHP 5)

array_reduce -- 콜백 함수를 사용하여 배열을 반복적으로 단일 값으로 축소시킨다

설명

mixed array_reduce ( array input, callback function [, int initial])

array_reduce()는 input 배열의 원소들에게 function 함수를 반복적으로 적용하여, 그 배열을 단일 값으로 축소시킨다. 선택적인 initial가 설정되면, 처리의 시작부분에서 그 값이 사용되거나, 배열이 비어있는경우에 최종 결과값으로 사용될것이다.

예 1. array_reduce() 예제코드

<?php
function rsum($v, $w) {
    $v += $w;
    return $v;
}

function rmul($v, $w) {
    $v *= $w;
    return $v;
}

$a = array(1, 2, 3, 4, 5);
$x = array();
$b = array_reduce($a, "rsum");
$c = array_reduce($a, "rmul", 10);
$d = array_reduce($x, "rsum", 1);
?>

위 코드는 $b가 15를 포함하고, $c는 1200 (= 1*2*3*4*5*10)을 포함하고, $d는 1을 포함하게 한다.

array_filter(),
array_map(),
array_unique(),
array_count_values() 참고.

이전 | 처음으로 | 다음
array_rand | 위로 | array_reverse


array_reverse

(PHP 4 , PHP 5)

array_reverse -- 배열 원소를 역순으로 반환한다

설명

array array_reverse ( array array [, bool preserve_keys])

array_reverse()는 array를 취해서 역순의 원소를 갖는 새로운 배열을 반환하고, preserve_keys가 TRUE이면 키를 보존한다.

예 1. array_reverse() 예제코드

<?php
$input  = array ("php", 4.0, array ("green", "red"));
$result = array_reverse ($input);
$result_keyed = array_reverse ($input, TRUE);
?>

이 함수는 같은 원소들을 갖는 $result와 $result_keyed 를 만들지만,두 배열의 키가 차이가 있다는것에 주의한다. $result와 $result_keyed의 결과는 다음과 같을것이다:

Array
(
    [0] => Array
        (
            [0] => green
            [1] => red
        )

    [1] => 4
    [2] => php
)
Array
(
    [2] => Array
        (
            [0] => green
            [1] => red
        )

    [1] => 4
    [0] => php
)

참고: PHP 4.0.3에서 두번째 매개변수가 추가되었슴.

array_flip() 참고.

이전 | 처음으로 | 다음
array_reduce | 위로 | array_search


array_search

(PHP 4 >= 4.0.5, PHP 5)

array_search -- 배열에서 주어진 값을 검색하고 성공하면 해당 키를 반환한다

설명

mixed array_search ( mixed needle, array haystack [, bool strict])

haystack에서 needle을 검색하고 배열에서 그 값이 발견되면 그 키를 반환하고, 그렇지 않으면 FALSE를 반환한다.

참고: PHP 4.2.0 이전에서는, array_search()는 실패시 FALSE 대신 NULL을 반환한다.

선택적인 세번째 매개변수인 strict가 TRUE로 설정되면 array_search()는 haystack에서 needle의 타입도 함께 검사할것이다.

주의

이 함수는 Boolean FALSE를 반환하지만, 0이나 ""와 같은 FALSE로 취급하는 Boolean이 아닌 값을 반환할 수도 있습니다. Booleans 섹션에서 자세한 정보를 얻을 수 있습니다. 이 함수의 반환값을 테스트하기 위해서 === 연산자를 이용하십시오.

array_keys(),
array_values(),
array_key_exists(),
in_array() 참고.

이전 | 처음으로 | 다음
array_reverse | 위로 | array_shift


array_shift

(PHP 4 , PHP 5)

array_shift -- 배열의 맨 앞에 있는 원소를 옆으로 이동시킨다

설명

mixed array_shift ( array array)

array_shift()는 array의 첫번째 값을 이동시키고 그 값을 반환하고, array를 한 원소만큼 줄이고 모든 원소를 아래로 이동시킨다. 모든 숫자 배열 키는 리터럴 키가 접근되지 않은 동안 영(0)부터 카운트하기 위해 변경된다. array가 비어있으면(또는 배열이 아니면), NULL을 반환한다.

참고: 이 함수는 사용 후에 array 포인터를 reset()합니다.

예 1. array_shift() 예제코드

<?php
$stack = array ("orange", "banana", "apple", "raspberry");
$fruit = array_shift ($stack);
print_r($stack);
?>

위 코드는 3개의 원소가 남겨진 $stack을 만들것이다:

Array
(
    [0] => banana
    [1] => apple
    [2] => raspberry
)

그리고 orange가 $fruit에 지정될것이다.

array_unshift(),
array_push(),
array_pop() 참고.

이전 | 처음으로 | 다음
array_search | 위로 | array_slice


array_slice

(PHP 4 , PHP 5)

array_slice -- 배열의 일부를 추출한다

설명

array array_slice ( array array, int offset [, int length])

array_slice()는 offset 과 length 매개변수에 따라 array로부터 일련의 배열 원소를 반환한다.

offset이 양수이면, 일련의 값은 array의 그 offset 수부터 시작할것이다. offset이 음수이면, 일련의 값은 array의 끝에서부터 그 수만큼 떨어진 곳에서부터 시작한다.

length가 주어지고 양수이면, 일련의 값은 그 수만큼의 배열 원소가 될것이다. length가 주어지고 음수이면, 배열의 끝에서부터 그 수만큼의 배열원소가 될것이다. 이 매개변수가 생략되면, 일련의 값은 offset에서부터 array 끝까지의 모든 원소를 가지게 된다.

array_slice()는 배열 키를 무시하고, 배열내 원소의 실질적인 위치에 따라 옵셋과 길이를 계산한다는것에 주의한다.

예 1. array_slice() 예제코드

<?php
$input = array ("a", "b", "c", "d", "e");

$output = array_slice ($input, 2);      // returns "c", "d", and "e"
$output = array_slice ($input, 2, -1);  // returns "c", "d"
$output = array_slice ($input, -2, 1);  // returns "d"
$output = array_slice ($input, 0, 3);   // returns "a", "b", and "c"
?>

array_splice(), unset() 참고.

이전 | 처음으로 | 다음
array_shift | 위로 | array_splice


array_splice

(PHP 4 , PHP 5)

array_splice -- 배열의 일부를 삭제하고, 그 위치에 다른 내용을 대체한다

설명

array array_splice ( array input, int offset [, int length [, array replacement]])

array_splice()는 input 배열로부터 offset 과 length 에 정해진대로 배열원소를 제거하고, 매개변수가 주어진다면 replacement 배열의 배열원소로 그부분을 대체한다. 그리고 확장된 배열원소를 포함하는 배열을 반환한다.

offset이 양수이면 삭제될 부분의 시작은 input 배열의 시작에서부터의 offset에서 시작된다. offset이 음수이면 input 배열의 끝에서부터의 옵셋 수에서 시작된다.

length가 생략되면, offset에서 배열의 끝까지의 모든 원소를 삭제된다. length가 주어지고 양수이면, 그 수만큼의 원소가 삭제될것이다. length가 주어지고 음수이면, 삭제되는 부분의 끝은 배열의 끝에서부터 그 수만큼의 원소가 될것이다. 팁: replacement가 주어져있고 offset에서 배열 끝까지의 모든 원소를 삭제하려면 length 매개변수에 count($input)을 사용하도록 한다.

replacement 배열이 주어지면, 제거된 원소들은 이 배열의 원소들로 대체된다. offset과 length가 아무것도 삭제되지 않도록 주어지면, replacement 배열의 원소들을 offset에 의해 설정된 위치에 끼워넣는다. 팁: 한개의 원소만 대체되는 경우이고 그 원소가 배열자체가 아니라면 array()를 넣을 필요는 없다.

다음은 동일한 결과를 낸다:

표 1. array_splice() 동치

array_push($input, $x, $y) | array_splice($input, count($input), 0, array($x, $y))
array_pop($input) | array_splice($input, -1)
array_shift($input) | array_splice($input, -1)
array_unshift($input, $x, $y) | array_splice($input, 0, 0, array($x, $y))
$a[$x] = $y | array_splice($input, $x, 1, $y)

제거된 원소로 구성된 배열을 반환한다.

예 1. array_splice() 예제코드

<?php
$input = array ("red", "green", "blue", "yellow");
array_splice ($input, 2);
// $input is now array ("red", "green")

$input = array ("red", "green", "blue", "yellow");
array_splice ($input, 1, -1);
// $input is now array ("red", "yellow")

$input = array ("red", "green", "blue", "yellow");
array_splice ($input, 1, count($input), "orange");
// $input is now array ("red", "orange")

$input = array ("red", "green", "blue", "yellow");
array_splice ($input, -1, 1, array("black", "maroon"));
// $input is now array ("red", "green",
//          "blue", "black", "maroon")

$input = array ("red", "green", "blue", "yellow");
array_splice ($input, 3, 0, "purple");
// $input is now array ("red", "green",
//          "blue", "purple", "yellow");
?>

array_slice(),
unset(),
array_merge() 참고.

이전 | 처음으로 | 다음
array_slice | 위로 | array_sum


array_sum

(PHP 4 >= 4.0.4, PHP 5)

array_sum -- 배열내의 값들의 합을 계산한다

설명

mixed array_sum ( array array)

array_sum()은 배열안의 값들의 합을 정수나 부동소수점수로 반환한다.

예 1. array_sum() 예제코드

<?php
$a = array(2, 4, 6, 8);
echo "sum(a) = ".array_sum($a)."\n";

$b = array("a"=>1.2,"b"=>2.3,"c"=>3.4);
echo "sum(b) = ".array_sum($b)."\n";
?>

위 프로그램의 결과는 다음과 같다:

sum(a) = 20
sum(b) = 6.9

참고: PHP 4.2.1 이전 버전에서는 전달되는 배열자체를 변경해버려서 문자열을 숫자로 변경했었다 (그값에 따라 대부분 0으로 변환된다).

이전 | 처음으로 | 다음
array_splice | 위로 | array_udiff_assoc


array_udiff_assoc

(PHP 5)

array_udiff_assoc -- Computes the difference of arrays with additional index check. The data is compared by using a callback function.

Description

array array_udiff_assoc ( array array1, array array2 [, array ..., callback data_compare_func])

array_udiff_assoc() returns an array containing all the values from array1 that are not present in any of the other arguments. Note that the keys are used in the comparison unlike array_diff() and array_udiff(). The comparison of arrays' data is performed by using an user-supplied callback. In this aspect the behaviour is opposite to the behaviour of array_diff_assoc() which uses internal function for comparison.

예 1. array_udiff_assoc() example

<?php
class cr {
    private $priv_member;
    function cr($val)
    {
        $this->priv_member = $val;
    }

    function comp_func_cr($a, $b)
    {
        if ($a->priv_member === $b->priv_member) return 0;
        return ($a->priv_member > $b->priv_member)? 1:-1;
    }
}

$a = array("0.1" => new cr(9), "0.5" => new cr(12), 0 => new cr(23), 1=> new cr(4), 2 => new cr(-15),);
$b = array("0.2" => new cr(9), "0.5" => new cr(22), 0 => new cr(3), 1=> new cr(4), 2 => new cr(-15),);

$result = array_udiff_assoc($a, $b, array("cr", "comp_func_cr"));
print_r($result);
?>

The result is:

Array
(
    [0.1] => cr Object
        (
            [priv_member:private] => 9
        )

    [0.5] => cr Object
        (
            [priv_member:private] => 12
        )

    [0] => cr Object
        (
            [priv_member:private] => 23
        )
)

In our example above you see the "1" => new cr(4) pair is present in both arrays and thus it is not in the ouput from the function.

For comparison is used the user supplied callback function. It must return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second.

참고: Please note that this function only checks one dimension of a n-dimensional array. Of course you can check deeper dimensions by using, for example, array_udiff_assoc($array1[0], $array2[0], "some_comparison_func");.

See also
array_diff(),
array_diff_assoc(),
array_diff_uassoc(),
array_udiff(),
array_udiff_uassoc(),
array_intersect(),
array_intersect_assoc(),
array_uintersect(),
array_uintersect_assoc() and
array_uintersect_uassoc().

이전 | 처음으로 | 다음
array_sum | 위로 | array_udiff_uassoc


array_udiff_uassoc

(PHP 5)

array_udiff_uassoc -- Computes the difference of arrays with additional index check. The data is compared by using a callback function. The index check is done by a callback function also

Description

array array_udiff_uassoc ( array array1, array array2 [, array ..., callback data_compare_func, callback key_compare_func])

array_udiff_uassoc() returns an array containing all the values from array1 that are not present in any of the other arguments. Note that the keys are used in the comparison unlike array_diff() and array_udiff(). The comparison of arrays' data is performed by using an user-supplied callback : data_compare_func. In this aspect the behaviour is opposite to the behaviour of array_diff_assoc() which uses internal function for comparison. The comparison of keys (indices) is done also by the callback function key_compare_func. This behaviour is unlike what array_udiff_assoc() does, since the latter compares the indices by using an internal function.

예 1. array_udiff_uassoc() example

<?php
class cr {
    private $priv_member;
    function cr($val)
    {
        $this->priv_member = $val;
    }

    function comp_func_cr($a, $b)
    {
        if ($a->priv_member === $b->priv_member) return 0;
        return ($a->priv_member > $b->priv_member)? 1:-1;
    }

    function comp_func_key($a, $b)
    {
        if ($a === $b) return 0;
        return ($a > $b)? 1:-1;
    }
}
$a = array("0.1" => new cr(9), "0.5" => new cr(12), 0 => new cr(23), 1=> new cr(4), 2 => new cr(-15),);
$b = array("0.2" => new cr(9), "0.5" => new cr(22), 0 => new cr(3), 1=> new cr(4), 2 => new cr(-15),);

$result = array_udiff_uassoc($a, $b, array("cr", "comp_func_cr"), array("cr", "comp_func_key"));
print_r($result);
?>

The result is:

Array
(
    [0.1] => cr Object
        (
            [priv_member:private] => 9
        )

    [0.5] => cr Object
        (
            [priv_member:private] => 12
        )

    [0] => cr Object
        (
            [priv_member:private] => 23
        )
)

In our example above you see the "1" => new cr(4) pair is present in both arrays and thus it is not in the ouput from the function. Keep in mind that you have to supply 2 callback functions.

For comparison is used the user supplied callback function. It must return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second.

참고: Please note that this function only checks one dimension of a n-dimensional array. Of course you can check deeper dimensions by using, for example, array_udiff_uassoc($array1[0], $array2[0], "data_compare_func", "key_compare_func");.

See also
array_diff(),
array_diff_assoc(),
array_diff_uassoc(),
array_udiff(),
array_udiff_assoc(),
array_intersect(),
array_intersect_assoc(),
array_uintersect(),
array_uintersect_assoc() and
array_uintersect_uassoc().

이전 | 처음으로 | 다음
array_udiff_assoc | 위로 | array_udiff


array_udiff

(PHP 5)

array_udiff -- Computes the difference of arrays by using a callback function for data comparison.

Description

array array_udiff ( array array1, array array2 [, array ..., callback data_compare_func])

array_udiff() returns an array containing all the values of array1 that are not present in any of the other arguments. Note that keys are preserved. For the comparison of the data data_compare_func is used. It must return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second. This is unlike array_diff() which uses an internal function for comparing the data.

예 1. array_udiff() example

<?php
class cr {
    private $priv_member;
    function cr($val)
    {
        $this->priv_member = $val;
    }

    function comp_func_cr($a, $b)
    {
        if ($a->priv_member === $b->priv_member) return 0;
        return ($a->priv_member > $b->priv_member)? 1:-1;
    }
}
$a = array("0.1" => new cr(9), "0.5" => new cr(12), 0 => new cr(23), 1=> new cr(4), 2 => new cr(-15),);
$b = array("0.2" => new cr(9), "0.5" => new cr(22), 0 => new cr(3), 1=> new cr(4), 2 => new cr(-15),);

$result = array_udiff($a, $b, array("cr", "comp_func_cr"));
print_r($result);
?>

The result is:

Array
(
    [0.5] => cr Object
        (
            [priv_member:private] => 12
        )

    [0] => cr Object
        (
            [priv_member:private] => 23
        )

)

참고: Two elements are considered equal if and only if (string) $elem1 === (string) $elem2. In words: when the string representation is the same.

참고: Please note that this function only checks one dimension of a n-dimensional array. Of course you can check deeper dimensions by using array_udiff($array1[0], $array2[0], "data_compare_func");.

See also
array_diff(),
array_diff_assoc(),
array_diff_uassoc(),
array_udiff_assoc(),
array_udiff_uassoc(),
array_intersect(),
array_intersect_assoc(),
array_uintersect(),
array_uintersect_assoc() and
array_uintersect_uassoc().

이전 | 처음으로 | 다음
array_udiff_uassoc | 위로 | array_unique


array_unique

(PHP 4 >= 4.0.1, PHP 5)

array_unique -- 배열에서 중복된 값을 제거한다

설명

array array_unique ( array array)

array_unique()는 입력 array를 취해서 중복값이 없는 새로운 배열을 반환한다.

키는 보존된다는 것에 유의한다. array_unique()는 우선 문자열로 취급되는 값들을 정렬하고, 모든 값중 첫번째로 만나는 키를 보유하게 될것이고, 다음의 모든 키들은 무시될것이다. 이 말의 의미는 정렬되지 않은 array 의 첫번째 관련 값의 키가 유지된다는 것이 아니다.

참고: 두 구성요소가 동치라고 볼수 있는 때는 (string) $elem1 === (string) $elem2 일때 만이다. In words: when the string representation is the same.

첫번째 원소가 사용될것이다.

예 1. array_unique() 예제코드

<?php
$input = array ("a" => "green", "red", "b" => "green", "blue", "red");
$result = array_unique ($input);
print_r($result);
?>

위 코드의 결과는 다음과 같다:

Array
(
    [a] => green
    [0] => red
    [1] => blue
)

예 2. array_unique() 과 타입

<?php
$input = array (4,"4","3",4,3,"3");
$result = array_unique ($input);
var_dump($result);
?>

위 스크립트의 결과는 다음과 같다:

array(2) {
  [0] => int(4)
  [2] => string(1) "3"
}

이전 | 처음으로 | 다음
array_udiff | 위로 | array_unshift


array_unshift

(PHP 4 , PHP 5)

array_unshift -- 배열의 맨 앞에 하나 이상의 원소를 첨가한다

설명

int array_unshift ( array array, mixed var [, mixed ...])

array_unshift()는 전달된 원소들을 array의 앞에 첨가한다. 원소 목록이 모두 첨가되면, 첨가된 원소들은 같은 순서로 남아있게 된다는 것에 유의한다. 모든 숫자 배열 키들은 리터럴 키들이 건드러지지 않는 동안에는 제로부터 카운트를 시작할수 있도록 변경될것이다.

array안의 새로운 원소의 수를 반환한다.

예 1. array_unshift() 예제코드

<?php
$queue = array ("orange", "banana");
array_unshift ($queue, "apple", "raspberry");
?>

위 코드는 다음 원소를 갖는 $queue 결과를 갖는다:

Array
(
    [0] => apple
    [1] => raspberry
    [2] => orange
    [3] => banana
)

array_shift(),
array_push(),
array_pop() 참고.

이전 | 처음으로 | 다음
array_unique | 위로 | array_values


array_values

(PHP 4 , PHP 5)

array_values -- 배열의 모든 값들을 반환한다

설명

array array_values ( array input)

array_values()는 input 배열에서 모든 값들과 숫자로된 인덱스의 배열을 반환한다.

예 1. array_values() 예제코드

<?php
$array = array ("size" => "XL", "color" => "gold");
print_r(array_values ($array));
?>

이 코드의 결과는 다음과 같다:

Array
(
    [0] => XL
    [1] => gold
)

array_keys() 참고.

이전 | 처음으로 | 다음
array_unshift | 위로 | array_walk


array_walk

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

array_walk -- 배열의 개개의 원소에 대해서 특정 함수를 적용하여 수행한다

설명

bool array_walk ( array array, callback function [, mixed userdata])

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

array 배열의 각 원소에 사용자 정의 함수 function을 적용한다. 표준적으로 function는 두개의 매개변수를 갖는다. array 매개변수의 값이 첫번째가 되고, key/index가 두번째가 된다. 선택적인 userdata 매개변수가 적용되면, 콜백 function에 세번째 매개변수가 전달될것이다.

함수 function이 주어진 것보다 더 많은 매개변수를 요구하면 array_walk()가 function을 호출할때마다 E_WARNING 레벨의 에러를 발생한다. 이런 경고는 array_walk()에 @ 기호를 덧붙이거나, error_reporting()을 사용함으로써 은폐시킬 수 있다.

참고: function은 배열의 실제 값들과 동작할 필요가 있다면, function의 첫번째 매개변수에 reference를 설정한다. 그러면 원래 배열 자체에 그 원소들을 변경할수 있다.

참고: function에 key와 userdata를 전달하는 기능이 4.0.0에서 추가되었다.

array_walk()는 array의 내부적인 배열 포인터에 의해 영향을 받지 않는다. array_walk()는 포인터 위치에 상관없이 전체 배열를 가로지를것이다. 포인터를 초기화(reset)시키려면, reset()을 사용하도록 한다. PHP 3에서 array_walk()는 포인터를 초기화시킨다.

유저가 콜백 함수에서 배열자체를 변경하지 않는다. 즉, 원소를 추가/삭제, 원소를 unset 하는등. array_walk()에 적용된 배열이 변경되면, 이 함수의 동작은 정의되지 않고, 원하는대로 되지 않는다.

예 1. array_walk() 예제코드

<?php
$fruits = array ("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");

function test_alter (&$item1, $key, $prefix) {
    $item1 = "$prefix: $item1";
}

function test_print ($item2, $key) {
    echo "$key. $item2<br>\n";
}

echo "Before ...:\n";
array_walk ($fruits, 'test_print');

array_walk ($fruits, 'test_alter', 'fruit');
echo "... and after:\n";

array_walk ($fruits, 'test_print');
?>

위 프로그램의 출력정보는 다음과 같다:

Before ...:
d. lemon
a. orange
b. banana
c. apple
... and after:
d. fruit: lemon
a. fruit: orange
b. fruit: banana
c. fruit: apple

list(), foreach, each(), call_user_func_array() 참고.

이전 | 처음으로 | 다음
array_values | 위로 | array


array

(PHP 3, PHP 4, PHP 5 )

array -- 배열을 생성한다

설명

array array ( [mixed ...])

매개변수의 배열을 반환한다. 매개변수는 => 연산자를 통해 인덱스가 주어질수 있다. 배열이 무엇인지에 대한 더 자세한 정보는 배열 타입에 관한 섹션을 참고한다.

참고: array()는 리터럴 배열을 표현하기 위해 사용되는 언어 구조이지, 일반적인 함수가 아니다.

"index => values" 구문은 콤마(,)로 구분되고, 인덱스와 값을 정의한다. 인덱스는 문자열이나 숫자형이 될수 있다. 인덱스가 생략되면, 0부터 시작되는 정수 인덱스가 자동적으로 생성된다. 인덱스가 정수이면, 다음에 생성되는 인덱스는 더 큰 정수 index + 1 이 될것이다. 두개의 동일한 인덱스가 생성되었을 경우, 마지막 값이 처음 값을 덮어쓰게 된다는 것에 주의한다.

다음 예제 코드는 2차원 배열을 생성하는 방법, 연관배열에 대한 키를 설정하는 방법, 일반적인 배열의 숫자 인덱스를 건너뛰는 방법을 보여준다.

예 1. array() 예제코드

<?php
$fruits = array (
    "fruits"  => array ("a"=>"orange", "b"=>"banana", "c"=>"apple"),
    "numbers" => array (1, 2, 3, 4, 5, 6),
    "holes"   => array ("first", 5 => "second", "third")
)
?>

예 2. array()의 자동적인 인덱스

<?php
$array = array( 1, 1, 1, 1,  1, 8=>1,  4=>1, 19, 3=>13);
print_r($array);
?>

다음을 보여준다:

Array
(
    [0] => 1
    [1] => 1
    [2] => 1
    [3] => 13
    [4] => 1
    [8] => 1
    [9] => 19
)

인덱스 '3'이 두번 정의되었고, 마지막 값인 13이 유지된다는 것에 유의한다. 인덱스 4는 인덱스 8 이후에 정의되었고, 더 큰 인덱스가 8이기 때문에, 다음에 생성된 인덱스( 값 19)는 9가 된다.

This example creates a 1-based array. 이 예제코드는 1-베이스 배열을 생성한다.

예 3. array()의 1-베이스 인덱스

<?php
$firstquarter  = array(1 => 'January', 'February', 'March');
print_r($firstquarter);
?>

다음을 보여준다:

Array
(
    [1] => January
    [2] => February
    [3] => March
)

array_pad(), list(), foreach, range() 참고.

이전 | 처음으로 | 다음
array_walk | 위로 | arsort


arsort

(PHP 3, PHP 4 , PHP 5)

arsort -- 배열을 내림차순 정렬하고 인덱스의 상관관계를 유지한다.

설명

void arsort ( array array [, int sort_flags])

이 함수는 배열 인덱스가 그 배열의 원소와 상관관계를 유지할수 있도록 배열을 정렬한다. 이 함수는 주로 실제 원소의 정렬이 중요한 연관 배열을 정렬할 때 이용한다.

예 1. arsort() 예제코드

<?php
$fruits = array ("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");
arsort ($fruits);
reset ($fruits);
while (list ($key, $val) = each ($fruits)) {
    echo "$key = $val\n";
}
?>

이 예제코드는 다음을 출력할것이다:

a = orange
d = lemon
b = banana
c = apple

fruits는 알파벳 내림 차순으로 정렬되었고, 각 원소와 연관된 인덱스가 유지되었다.

선택적인 매개변수 sort_flags를 사용하여 정렬 동작을 변경할 수 있다. 더 자세한 것은 sort()를 참고.

asort(), rsort(), ksort(), sort() 참고.

이전 | 처음으로 | 다음
array | 위로 | asort


asort

(PHP 3, PHP 4 , PHP 5)

asort -- 배열을 정렬하고 인덱스 상관 관계를 유지한다

설명

void asort ( array array [, int sort_flags])

이 함수는 배열의 인덱스가 그 배열의 원소와 상관관계를 유지할수 있도록 배열을 정렬한다. 이 함수는 주로 실제 원소의 정렬이 중요한 연관 배열을 정렬할 경우 사용된다.

예 1. asort() 예제코드

<?php
$fruits = array ("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");
asort ($fruits);
reset ($fruits);
while (list ($key, $val) = each ($fruits)) {
    echo "$key = $val\n";
}
?>

이 예제코드는 다음을 보여준다:

c = apple
b = banana
d = lemon
a = orange

fruits는 알파벳 순으로 정렬하고, 각 원소와 연관된 인덱스가 유지된다.

선택적인 매개변수 sort_flags 를 사용하여 정렬 방식을 변경할수 있다. 더 자세한 것은 sort()를 참고.

arsort(), rsort(), ksort(), sort() 참고.

이전 | 처음으로 | 다음
arsort | 위로 | compact


compact

(PHP 4 , PHP 5)

compact -- 여러 변수들과 값을 갖는 배열을 생성한다

설명

array compact ( mixed varname [, mixed ...])

compact()는 가변적인 수의 매개변수를 갖는다. 각 매개변수는 변수명을 포함하는 문자열이거나, 변수명의 배열이 될수 있다. 그 배열은 그 안쪽에 다른 변수명의 배열을 포함할수 있다; compact()는 재귀적으로 제어된다.

이들 각각에 대해, compact() 는 현재 심볼 테이블에서 그 이름을 갖는 변수를 찾고, 그 변수명이 키가 되고 변수의 내용은 그 키에 대한 값이 될수 있도록 출력 배열에 추가한다. 짧게 말해서, 이 함수는 extract()과 반대이다. 이 함수는 그 배열에 추가된 모든 변수들을 갖는 출력 배열을 반환한다.

지정되지 않은 모든 문자열은 단순히 무시된다.

예 1. compact() 예제코드

<?php
$city = "San Francisco";
$state = "CA";
$event = "SIGGRAPH";

$location_vars = array ("city", "state");

$result = compact ("event", "nothing_here", $location_vars);
?>

이 코드 수행후, $result 는 다음과 같이 된다:

Array
(
    [event] => SIGGRAPH
    [city] => San Francisco
    [state] => CA
)

extract() 참고.

이전 | 처음으로 | 다음
asort | 위로 | count


count

(PHP 3, PHP 4 , PHP 5)

count -- 변수의 원소 갯수를 구한다

설명

int count ( mixed var [, int mode])

일반적으로 array 인 var 안의 원소 갯수를 반환한다. (그외의 것은 한개의 원소를 갖기 때문이다)

var 가 배열이 아니면, 1 을 반환한다 (예외: count(NULL) 는 0과 같다).

참고: 선택적인 mode 매개변수는 PHP 4.2.0부터 사용가능하다.

선택적인 mode 매개변수가 COUNT_RECURSIVE (또는 1)으로 설정되면, count() 는 재귀적으로 배열을 카운트한다. 이 매개변수는 특별히 다차원 배열의 모든 원소를 셀때 유용하다. mode의 기본값은 0이다.

경고

count()는 설정되지 않은 배열에 대해서 0을 반환할것이나, 빈 배열로 초기화된 변수에 대해서도 0을 반환할것이다. 변수가 설정되었는지 확인하기 위해서 isset()을 사용한다.

PHP에서 배열이 어떻게 구현되고 어떻게 사용되는지에 대한 자세한 설명을 보기 위해서 배열 섹션을 참고한다.

예 1. count() 예제코드

<?php
$a[0] = 1;
$a[1] = 3;
$a[2] = 5;
$result = count ($a);
// $result == 3

$b[0] = 7;
$b[5] = 9;
$b[10] = 11;
$result = count ($b);
// $result == 3;
?>

예 2. 재귀적인 count() 예제코드(PHP >= 4.2.0)

<?php
$food = array( 'fruits'  => array('orange', 'banana', 'apple'),
               'veggie'  => array('carrot', 'collard','pea'));

// recursive count
echo count($food,COUNT_RECURSIVE);  // output 8

// normal count
echo count($food);                  // output 2

?>

참고: sizeof() 함수는 count()에 대한 별칭 이다.

is_array(),
isset(),
strlen() 참고.

이전 | 처음으로 | 다음
compact | 위로 | current


current

(PHP 3, PHP 4 , PHP 5)

current -- 배열의 현재 원소를 반환한다

설명

mixed current ( array array)

모든 배열은 "현재" 원소를 가리키는 내부 포인터를 갖는데, 이 내부 포인터는 배열에 삽입되어진 첫번째 원소로 초기화된다.

current() 함수는 단순히 현재 내부 포인터에서 가리키고 있는 배열 원소의 값을 반환한다. 어떤 방법으로든 그 포인터를 움직이지 않는다. 내부 포인터가 원소 목록의 끝에서 벗어난 곳을 가리키면, current()는 FALSE를 반환한다.

주의

배열이 빈 원소를 포함하면(0 이나 "", 빈 문자열) 이 함수는 이 원소들에 대해서도 FALSE를 반환한다. current()를 사용하여 그 배열 안의 목록 끝인지 확인할수 없게 만든다. 빈 원소를 포함할수도 있는 배열을 적절하게 거닐기 위해서는, each() 함수를 이용한다.

예 1. current()의 사용예와 관련 함수

<?php
$transport = array('foot', 'bike', 'car', 'plane');
$mode = current($transport); // $mode = 'foot';
$mode = next($transport);    // $mode = 'bike';
$mode = current($transport); // $mode = 'bike';
$mode = prev($transport);    // $mode = 'foot';
$mode = end($transport);     // $mode = 'plane';
$mode = current($transport); // $mode = 'plane';
?>

end(), key(),
next(), prev(),
reset() 참고.

이전 | 처음으로 | 다음
count | 위로 | each


each

(PHP 3, PHP 4 , PHP 5)

each -- 배열에서 현재의 키와 값 쌍을 반환하고 배열 커서를 전진시킨다

설명

array each ( array array)

array 배열에서 현재의 키와 값 쌍을 반환하고 배열 커서를 전진시킨다. 이 키/값 쌍은 4개 원소를 갖는 배열을 반환한다. 0, 1, key, value 이다. 원소 0과 key는 배열 원소의 키 이름을 포함하고, 1과 value는 데이터를 포함한다.

배열의 내부 포인터가 배열의 끝을 벗어나면, each()는 FALSE를 반환한다.

예 1. each() 예제코드

<?php
$foo = array ("bob", "fred", "jussi", "jouni", "egon", "marliese");
$bar = each ($foo);
print_r($bar);
?>

$bar는 현재 다음과 같은 key/value 쌍을 포함한다:

Array
(
    [1] => bob
    [value] => bob
    [0] => 0
    [key] => 0
)

<?php
$foo = array ("Robert" => "Bob", "Seppo" => "Sepi");
$bar = each ($foo);
print_r($bar);
?>

$bar는 현재 다음과 같은 key/value 쌍을 포함한다:

Array
(
    [1] => Bob
    [value] => Bob
    [0] => Robert
    [key] => Robert
)

each()는 배열을 사용하기 위해 일반적으로 list()와 같이 사용한다. 예제코드는 다음과 같다:

예 2. each()로 배열 사용하기

<?php
$fruit = array('a' => 'apple', 'b' => 'banana', 'c' => 'cranberry');

reset ($fruit);
while (list ($key, $val) = each ($fruit)) {
    echo "$key => $val\n";
}

/* Outputs:

a => apple
b => banana
c => cranberry

*/
?>

each()가 수행되면, 배열 커서는 배열의 다음 원소로 옮겨지거나, 배열의 끝인 경우에는 마지막 원소를 통과한다. each를 사용하여 다시 배열을 사용하려면 reset()을 사용해야 한다.

경고

배열을 다른 변수로 지정하는 것은 원래의 배열 포인터를 초기화 하는것이기 때문에, 위 예제코드는 루프안에서 $fruit를 다른 변수로 지정하게 되면 무한 루프를 유발할수 있다.

key(), list(),
current(), reset(),
next(), prev(),
foreach 참고.

이전 | 처음으로 | 다음
current | 위로 | end


end

(PHP 3, PHP 4 , PHP 5)

end -- 내부 배열 포인터를 마지막 원소를 가리키게 한다

설명

mixed end ( array array)

end()는 array의 내부 포인터를 마지막원소로 이동시키고 마지막 원소의 값을 반환한다.

예 1. 단순한 end() 예제코드

<?php

  $fruits = array('apple','banana','cranberry');

  print end($fruits); // cranberry

?>

current(),
each(),
next(), reset() 참고.

이전 | 처음으로 | 다음
each | 위로 | extract


extract

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

extract -- 배열의 현재 심볼 테이블로 변수들을 입력한다

설명

int extract ( array var_array [, int extract_type [, string prefix]])

이 함수는 배열의 값들을 현재 심볼 테이블에 입력하는데 사용된다. 연관 배열 var_array를 취해서 변수명을 키로, 변수값을 값으로 취급한다. extract_type과 prefix 에 따라 각 키/값 쌍에 대해서 현재 심볼 테이블안에 변수를 생성한다.

참고: 버전 4.0.5에 시작하여, 이 함수는 추출된 변수의 수를 반환한다.

참고: EXTR_IF_EXISTS과 EXTR_PREFIX_IF_EXISTS는 버전 4.2.0에서부터 지원된다.

참고: EXTR_REFS 버전 4.3.0부터 지원된다.

extract()는 각 키가 유효한 변수명을 갖을수 있는지 검사 한다. 또한 심볼 테이블에 존재하는 변수들과의 충돌도 검사한다. 유효하지않은/숫자 키와 충돌인 경우를 취급하는 방법은 extract_type에 의해 결정된다. 다음 값들 중 하나가 될 수 있다:

EXTR_OVERWRITE

충돌이 발생하면, 기존 변수를 덮어쓴다.

EXTR_SKIP

충돌이 발생하면, 기존 변수를 덮어쓰지 않는다. variable.

EXTR_PREFIX_SAME

충돌이 발생하면, prefix를 변수명 앞에 첨가한다.

EXTR_PREFIX_ALL

prefix를 모든 변수명 앞에 첨가한다. PHP 4.0.5에서 시작하여, 이 플래그는 숫자 변수도 적용된다.

EXTR_PREFIX_INVALID

유효하지 않은/숫자 변수명 앞에만 prefix를 첨가한다. 이 플래그는 PHP 4.0.5에서 추가되었다.

EXTR_IF_EXISTS

현재 심볼 테이블에 이미 존재하는 변수만 덮어쓴다. 그렇지 않으면 아무것도 하지 않는다. 이 플래그는 유효한 변수 목록을 정의하고 이 변수들만 추출하는데 유용하다. 예를 들어, 이런 변수는 $_REQUEST에서 정의된 변수들이다. 이 플래그는 PHP 4.2.0에서 추가되었다.

EXTR_PREFIX_IF_EXISTS

현재 심볼 테이블에 앞첨가된 버전의 같은 변수가 존재할때만 앞첨가된 변수명을 생성한다. 이 플래그는 PHP 4.2.0에서 추가되었다.

EXTR_REFS

변수를 참조로써 추출한다. 입력된 변수 값이 var_array 매개변수의 값을 참조한다는 의미를 갖는다. 이 플래그는 그 자체로나 다른 플래그와 OR 연산하여 extract_type에서 사용할수 있다. 이 플래그는 PHP 4.3.0에서 추가되었다.

extract_type가 설정되지 않으면, EXTR_OVERWRITE가 설정되 있다고 가정한다.

prefix는 extract_type이 EXTR_PREFIX_SAME, EXTR_PREFIX_ALL,EXTR_PREFIX_INVALID 또는, EXTR_PREFIX_IF_EXISTS 일때만 요구된다. 앞 첨가된 변수가 유효한 변수명이 아니면, 심볼테이블에 입력되지 않는다.

extract()는 심볼 테이블에 성공적으로 입력된 변수의 수를 반환한다.

extract()가 사용가능한 경우는 wddx_deserialize()에서 반환한 연관배열에 포함되어있는 심볼 테이블 변수들 안에 입력하는것이다.

예 1. extract() 예제코드

<?php

/* Suppose that $var_array is an array returned from
   wddx_deserialize */

$size = "large";
$var_array = array ("color" => "blue",
                    "size"  => "medium",
                    "shape" => "sphere");
extract ($var_array, EXTR_PREFIX_SAME, "wddx");

print "$color, $size, $shape, $wddx_size\n";

?>

위 예제코드는 다음을 출력할것이다:

blue, large, sphere, medium

$size는 덮어씌어지지 않았다, 왜냐하면 EXTR_PREFIX_SAME를 설정했기 때문이다. 결과적으로 $wddx_size가 생성되었다. EXTR_SKIP가 설정되어 있으면, EXTR_OVERWRITE 는 $size가 "medium" 값을 갖게 하고 EXTR_PREFIX_ALL는 새로운 변수인 $wddx_color, $wddx_size, $wddx_shape를 갖게한다.

연관 배열을 사용해야 한다. EXTR_PREFIX_ALL 나 EXTR_PREFIX_INVALID를 사용하지 않으면 숫자로 인덱스된 배열은 결과를 도출할수 없다.

compact() 참고.

이전 | 처음으로 | 다음
end | 위로 | in_array


in_array

(PHP 4 , PHP 5)

in_array -- 배열에서 값이 존재하는지 점검한다

설명

bool in_array ( mixed needle, array haystack [, bool strict])

haystack에서 needle을 검색해서 배열안에서 발견되면 TRUE를 반환하고 그렇지 않으면 FALSE를 반환한다.

세번째 매개변수 strict가 TRUE로 설정되면, in_array() 함수는 haystack 안의 needle의 타입도 점검할것이다.

참고: needle이 문자열이면, 대소문자를 구별하여 비교가 수행된다.

참고: PHP 4.2.0 이전 버전에서는 needle은 배열에서 허용되지 않았다.

예 1. in_array() 예제코드

<?php
$os = array ("Mac", "NT", "Irix", "Linux");
if (in_array ("Irix", $os)) {
    print "Got Irix";
}
if (in_array ("mac", $os)) {
    print "Got mac";
}
?>

in_array()는 대소문자를 구별하기 때문에 두번째 조건은 실패한다. 그래서 위 프로그램은 다음과 같이 출력된다:

Got Irix

예 2. in_array()의 엄격한 예제코드

<?php
$a = array('1.10', 12.4, 1.13);

if (in_array('12.4', $a, TRUE)) {
    echo "'12.4' found with strict check\n";
}

if (in_array(1.13, $a, TRUE)) {
    echo "1.13 found with strict check\n";
}
?>

위 코드는 다음과 같이 출력된다:

1.13 found with strict check

예 3. needle 이 배열인 in_array()

<?php
$a = array(array('p', 'h'), array('p', 'r'), 'o');

if (in_array(array ('p', 'h'), $a)) {
    echo "'ph' was found\n";
}

if (in_array(array ('f', 'i'), $a)) {
    echo "'fi' was found\n";
}

if (in_array('o', $a)) {
    echo "'o' was found\n";
}

/* Outputs:
  'ph' was found
  'o' was found
*/
?>

array_search(),
array_key_exists(),
isset() 참고.

이전 | 처음으로 | 다음
extract | 위로 | key


key

(PHP 3, PHP 4 , PHP 5)

key -- 연관배열에서 키를 꺼낸다

설명

mixed key ( array array)

key()는 현재 배열 위치에 있는 원소의 인덱스를 반환한다.

current(), next() 참고.

이전 | 처음으로 | 다음
in_array | 위로 | krsort


krsort

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

krsort -- 역순으로 키에 의해 배열을 정렬한다

설명

int krsort ( array array [, int sort_flags])

역순으로 키에 의해 배열을 정렬하고, 키와 데이터의 연관성을 유지한다. 이 함수는 주로 연관배열에 유용하다.

예 1. krsort() 예제코드

<?php
$fruits = array ("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");
krsort ($fruits);
reset ($fruits);
while (list ($key, $val) = each ($fruits)) {
    echo "$key = $val\n";
}
?>

위 예제코드는 다음을 출력한다:

d = lemon
c = apple
b = banana
a = orange

선택적인 매개변수 sort_flags를 사용하여 정렬 방법을 변경할수 있다. 자세한 정보는 sort()를 참고.

asort(), arsort(),
ksort(), sort(),
natsort(), rsort() 예제코드.

이전 | 처음으로 | 다음
key | 위로 | ksort


ksort

(PHP 3, PHP 4 , PHP 5)

ksort -- 키에 의해 배열을 정렬한다

설명

int ksort ( array array [, int sort_flags])

키에 의해 배열을 정렬하고, 키와 데이터의 연관성을 유지한다. 이 함수는 주로 연관 배열에 유용하다.

예 1. ksort() 예제코드

<?php
$fruits = array ("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");
ksort ($fruits);
reset ($fruits);
while (list ($key, $val) = each ($fruits)) {
    echo "$key = $val\n";
}
?>

이 예제코드는 다음을 출력할것이다:

a = orange
b = banana
c = apple
d = lemon

선택적인 매개변수 sort_flags를 사용하여 정렬 방법을 변경할수 있다. 자세한 정보는 sort()를 참고.

asort(), arsort(),
krsort(), uksort(),
sort(), natsort(),
rsort() 참고.

참고: The second parameter was added in PHP 4.

이전 | 처음으로 | 다음
krsort | 위로 | list


list

(PHP 3, PHP 4, PHP 5 )

list -- 배열처럼 변수들을 지정한다

설명

void list ( mixed ...)

array()처럼, 이 함수는 실제 함수가 아니고 언어 구조이다. list()는 한번의 조작으로 배열 목록을 지정하기 위해 사용된다.

참고: list()는 숫자 배열에서만 작동하고 0부터 시작하는 숫자 인덱스로 가정한다.

예 1. list() 예제코드

<?php

$info = array('coffee', 'brown', 'caffeine');

// 모든 변수를 목록화한다
list($drink, $color, $power) = $info;
print "$drink is $color and $power makes it special.\n";

// 그들중 일부를 목록화한다
list($drink, , $power) = $info;
print "$drink has $power.\n";

// 또는 세번째 값으로만 건너띈다
list( , , $power) = $info;
print "I need $power!\n";

?>

예 2. list()의 사용예

<table>
<tr>
  <th>Employee name</th>
  <th>Salary</th>
</tr>

<?php

$result = mysql_query ("SELECT id, name, salary FROM employees",$conn);
while (list ($id, $name, $salary) = mysql_fetch_row ($result)) {
    print (" <tr>\n".
           "  <td><a href=\"info.php?id=$id\">$name</a></td>\n".
           "  <td>$salary</td>\n".
           " </tr>\n");
}

?>

</table>

주의

list()는 가장 우측 매개변수에서 시작하는 값들을 지정한다. 일반적인 변수들을 사용하면, 이 동작에 대해서 신경 쓸 필요가 없다. 그러나 인덱스를 갖는 배열에서 사용한다면 왼쪽에서 오른쪽으로 list()에서 쓰여진것과 같이 배열안의 인덱스 순서로 되는것이라고 보통 기대할수 있으나, 그렇지 않다. 역순으로 지정이 된다.

예 3. 배열 인덱스를 사용하는 list() 사용예

<?php

$info = array('coffee', 'brown', 'caffeine');

list($a[0], $a[1], $a[2]) = $info;

var_dump($a);

?>

다음과 같이 출력된다 (이 원소들의 순서는 list() 문법안에서 쓰여진 순서와 대비된다는 것에 주의.):

array(3) {
  [2]=>
  string(8) "caffeine"
  [1]=>
  string(5) "brown"
  [0]=>
  string(6) "coffee"
}

each(), array() extract() 참고.

이전 | 처음으로 | 다음
ksort | 위로 | natcasesort


natcasesort

(PHP 4 , PHP 5)

natcasesort -- 대소문자를 구별하지 않고 "natural order" 알고리즘을 사용하여 배열을 정렬한다

설명

void natcasesort ( array array)

이 함수는 인간의 방식으로 문자숫자 조합된 문자열을 정렬하는 알고리즘으로 구현되었다. 이 알고리즘을 "natural ordering"이라고 한다.

natcasesort()는 natsort()의 대소문자를 구별하지 않는 버전이다. 이 알고리즘과 일반적인 컴퓨터 문자열 정렬 알고리즘 (sort()를 사용) 사이의 차이점의 예는 natsort()의 예제코드에서 확인할수 있다:

추가 정보: Martin Pool의 Natural Order String Comparison 페이지.

sort(),
natsort(),
strnatcmp(),
strnatcasecmp() 참고.

이전 | 처음으로 | 다음
list | 위로 | natsort


natsort

(PHP 4 , PHP 5)

natsort -- "natural order" 알고리즘을 사용하여 배열을 정렬한다

설명

void natsort ( array array)

이 함수는 인간의 방식으로 문자숫자 조합된 문자열을 정렬하는 알고리즘으로 구현되었다. 이 알고리즘을 "natural ordering"이라고 한다. 이 알고리즘과 일반적인 컴퓨터 문자열 정렬 알고리즘 (sort()를 사용) 사이의 차이점의 예는 다음 예제코드에서 확인할수 있다:

예 1. natsort() 예제코드

<?php
$array1 = $array2 = array ("img12.png", "img10.png", "img2.png", "img1.png");

sort($array1);
echo "Standard sorting\n";
print_r($array1);

natsort($array2);
echo "\nNatural order sorting\n";
print_r($array2);
?>

위 코드는 다음의 출력을 생성할것이다:

Standard sorting
Array
(
    [0] => img1.png
    [1] => img10.png
    [2] => img12.png
    [3] => img2.png
)

Natural order sorting
Array
(
    [3] => img1.png
    [2] => img2.png
    [1] => img10.png
    [0] => img12.png
)

추가 정보: Martin Pool의 Natural Order String Comparison 페이지.

참고: index/value 연관을 유지시키려면, uasort($arr, 'strnatcmp') 사용을 고려하도록 한다.

natcasesort(),
strnatcmp(),
strnatcasecmp() 참고.

이전 | 처음으로 | 다음
natcasesort | 위로 | next


next

(PHP 3, PHP 4 , PHP 5)

next -- 배열의 내부 배열 포인터를 전진시킨다

설명

mixed next ( array array)

내부 배열 포인터에 의해 가리켜진 다음 위치의 배열 값을 반환하거나, 더이상 원소가 존재하지 않으면 FALSE를 반환한다.

next()는 current()와 비슷하게 동작하지만 한가지 차이를 갖고 있다. 원소값을 반환하기 전에 내부 배열 포인터를 한칸 다음으로 전진시킨다. 이 말은 다음 배열 값을 반환하고 내부 배열 포인터를 한칸 전진시킨다는 뜻이다. 내부 배열 포인터를 전진시켜서 원소 목록의 끝을 벗어나면 next()는 FALSE를 반환한다.

주의

배열의 비어있는 원소를 갖고 있거나, 0의 키값을 갖는 원소를 갖고 있으면, 이 함수는 이 원소들에 대해서도 FALSE를 반환한다. 비어있는 원소나 0의 키값을 갖을지도 모르는 배열을 효율적으로 사용하려면 each() 함수를 사용하도록 한다.

예 1. next()의 사용예와 관련 함수

<?php
$transport = array('foot', 'bike', 'car', 'plane');
$mode = current($transport); // $mode = 'foot';
$mode = next($transport);    // $mode = 'bike';
$mode = next($transport);    // $mode = 'car';
$mode = prev($transport);    // $mode = 'bike';
$mode = end($transport);     // $mode = 'plane';
?>

current(), end(), prev(), reset() 참고.

이전 | 처음으로 | 다음
natsort | 위로 | pos


pos

(PHP 3, PHP 4 , PHP 5)

pos -- 배열에서 현재 원소를 꺼내온다

설명

mixed pos ( array array)

이 함수는 current()의 별칭 이다.

end(), next(), prev(), reset() 참고.

이전 | 처음으로 | 다음
next | 위로 | prev


prev

(PHP 3, PHP 4 , PHP 5)

prev -- 내부 배열 포인터를 앞으로 돌린다

설명

mixed prev ( array array)

내부 배열 포인터에 의해 가리켜지는 이전 위치의 배열 값을 반환하거나, 더이상의 원소가 없으면, FALSE를 반환한다.

주의

배열이 비어있는 원소를 갖는다면 이 함수는 이 원소들에 대해서도 FALSE를 반환할것이다. 빈 원소를 포함할수도 있는 배열을 효율적으로 사용하기 위해서는 each() 함수를 참고하도록 한다.

prev()는 내부 배열 포인터가 앞으로 전진하는 대신에 뒤로 돌린다는 것을 제외하고 next()와 비슷하게 동작한다.

예 1. prev()의 사용예와 관련 함수

<?php
$transport = array('foot', 'bike', 'car', 'plane');
$mode = current($transport); // $mode = 'foot';
$mode = next($transport);    // $mode = 'bike';
$mode = next($transport);    // $mode = 'car';
$mode = prev($transport);    // $mode = 'bike';
$mode = end($transport);     // $mode = 'plane';
?>

current(), end(), next(), reset() 참고.

이전 | 처음으로 | 다음
pos | 위로 | range


range

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

range -- 특정 범위의 원소를 갖는 배열을 생성한다

설명

array range ( int low, int high [, int step])

range()는 low에서 high(포함하여)까지의 원소를 갖는 배열을 반환한다, low > high 일 경우에는 일련값은 high에서 low까지가 될것이다.

새로운 매개변수: 선택적인 step 매개변수가 5.0.0에서 추가되었다.

step 값이 주어지면, 연속적인 원소들의 증가값으로 사용될것이다. step은 양수로 주어져야 한다. 이 값이 주어지지 않으면, step의 기본값은 1이다.

예 1. range() 예제코드

<?php
// array(0,1,2,3,4,5,6,7,8,9,10,11,12)
foreach(range(0, 12) as $number) {
    echo $number;
}

// 5.0.0 부터 stemp 매개변수가 추가되었다
// array(0,10,20,30,40,50,60,70,80,90,100)
foreach(range(0, 100, 10) as $number) {
    echo $number;
}

// 4.1.0 부터 문자 연속값들이 지원된다
// array('a','b','c','d','e','f','g','h','i');
foreach(range('a', 'i') as $letter) {
    echo $letter;
}
// array('c','b','a');
foreach(range('c', 'a') as $letter) {
    echo $letter;
}
?>

참고: PHP 4.1.0 이전 버전에서, range()는 증가하는 정수 배열만 생성했었다. 문자 연속값과 감소 배열의 지원이 4.1.0에 추가되었다. 문자 연속 값은 한 문자로 제한된다. 1보다 큰값이 들어가면, 첫번째 문자만 사용된다.

경고

PHP 4.1.0부터 4.3.2버전까지, range() 는 숫자형의 문자열을 숫자형이 아닌 문자열로 본다. 그래서, 그 값들은 문자 연속값으로 사용될것이다. 예를 들면, "4242" 는 "4"로 취급된다.

shuffle(), array_fill(), foreach 참고.

이전 | 처음으로 | 다음
prev | 위로 | reset


reset

(PHP 3, PHP 4 , PHP 5)

reset -- 배열의 내부 포인터가 배열의 첫번째 원소를 가리키게 한다

설명

mixed reset ( array array)

reset()은 array의 내부 포인터를 첫번째 원소를 가리키도록 되감고 배열의 첫번째 원소의 값을 반환한다.

current(),
each(), next(),
prev() 참고.

이전 | 처음으로 | 다음
range | 위로 | rsort


rsort

(PHP 3, PHP 4 , PHP 5)

rsort -- 역순으로 배열을 정렬한다

설명

void rsort ( array array [, int sort_flags])

이 함수는 역순으로 배열을 정렬한다 (높은곳에서 낮은곳으로).

예 1. rsort() 예제코드

<?php
$fruits = array ("lemon", "orange", "banana", "apple");
rsort ($fruits);
reset ($fruits);
while (list ($key, $val) = each ($fruits)) {
    echo "$key = $val\n";
}
?>

위 예제코드는 다음을 출력한다:

0 = orange
1 = lemon
2 = banana
3 = apple

fruits 는 알파벳 역순으로 정렬되었다.

선택적인 매개변수 sort_flags를 사용하여 정렬 방법을 변경할수 있다. 더 자세한것은 sort() 를 참고.

arsort(),
asort(), ksort(),
sort(), usort() 참고.

이전 | 처음으로 | 다음
reset | 위로 | shuffle


shuffle

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

shuffle -- 배열을 뒤섞는다

설명

void shuffle ( array array)

이 함수는 배열을 (배열 안의 원소를 임의의 순서로) 뒤섞는다. srand()를 사용하여 이 함수를 초기화해야 한다.

예 1. shuffle() 예제코드

<?php
$numbers = range (1,20);
srand ((float)microtime()*1000000);
shuffle ($numbers);
while (list (, $number) = each ($numbers)) {
    echo "$number ";
}
?>

참고: PHP 4.2.0부터 srand()나 mt_srand()를 이용해서 난수값 생성기를 초기화 할 필요가 없습니다. 자동적으로 이루어집니다.

arsort(), asort(),
ksort(), rsort(),
sort(), usort() 참고.

이전 | 처음으로 | 다음
rsort | 위로 | sizeof


sizeof

sizeof -- count()의 별칭

설명

이 함수는 count()의 별칭이다.

이전 | 처음으로 | 다음
shuffle | 위로 | sort


sort

(PHP 3, PHP 4 , PHP 5)

sort -- 배열을 정렬한다

설명

void sort ( array array [, int sort_flags])

이 함수는 배열을 정렬한다. 이 함수가 수행되면 원소들은 작은 값에서 큰 값으로 정렬될것이다.

예 1. sort() 예제코드

<?php

$fruits = array ("lemon", "orange", "banana", "apple");
sort ($fruits);
reset ($fruits);
while (list ($key, $val) = each ($fruits)) {
    echo "fruits[".$key."] = ".$val."\n";
}

?>

위 예제코드는 다음을 출력한다:

fruits[0] = apple
fruits[1] = banana
fruits[2] = lemon
fruits[3] = orange

fruits 는 알파벳순으로 정렬되었다.

선택적인 두번째 sort_flags 매개변수는 이 값들을 사용하여 정렬방법을 변경하는데 사용된다:

정렬 방법 플래그:

  • SORT_REGULAR - 통상적인 방법으로 원소를 비교

  • SORT_NUMERIC - 수치적으로 원소를 비교

  • SORT_STRING - 문자열로 원소를 비교

참고: 두번째 매개변수는 PHP 4에서 추가되었다.

arsort(),
asort(), ksort(),
natsort(), natcasesort(),
rsort(), usort(),
array_multisort(),
uksort() 참고.

이전 | 처음으로 | 다음
sizeof | 위로 | uasort


uasort

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

uasort -- 사용자-정의 비교함수로 배열을 정렬하고 인덱스 연관성을 유지한다

설명

void uasort ( array array, callback cmp_function)

이 함수는 배열 인덱스가 그와 관련되어있는 배열 원소들과의 연관성을 유지하면서 배열을 정렬한다. 이 함수는 실제 원소 순서가 중요한 연관 배열을 정렬할 때 주로 쓰인다. 비교함수는 사용자-정의된다.

참고: 사용자-정의 비교함수의 예제코드를 위해 usort() 와 uksort() 를 참고.

usort(), uksort(),
sort(), asort(),
arsort(), ksort(),
rsort() 참고.

이전 | 처음으로 | 다음
sort | 위로 | uksort


uksort

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

uksort -- 사용자-정의된 비교함수를 사용하여 키에 의해 배열을 정렬한다

설명

void uksort ( array array, callback cmp_function)

이 함수는 사용자-지원 비교 함수를 사용하여 키들에 의해 배열을 정렬할 것이다. 정렬하고자 하는 배열이 흔히 사용되지 않는 방법에 의해 정렬할 필요가 있으면, 이 함수를 사용해야 한다.

예 1. uksort() 예제코드

<?php
function cmp ($a, $b) {
    if ($a == $b) return 0;
    return ($a > $b) ? -1 : 1;
}

$a = array (4 => "four", 3 => "three", 20 => "twenty", 10 => "ten");

uksort ($a, "cmp");

while (list ($key, $value) = each ($a)) {
    echo "$key: $value\n";
}
?>

위 예제코드는 다음을 출력한다:

20: twenty
10: ten
4: four
3: three

usort(), uasort(),
sort(), asort(),
arsort(), ksort(),
natsort(), rsort() 참고.

이전 | 처음으로 | 다음
uasort | 위로 | usort


usort

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

usort -- 사용자-정의된 비교함수를 사용하여 값들에 의해 배열을 정렬한다

설명

void usort ( array array, callback cmp_function)

이 함수는 사용자-지원 비교 함수를 사용하여 값들에 의해 배열을 정렬할 것이다. 정렬하고자 하는 배열이 흔히 사용되지 않는 방법에 의해 정렬할 필요가 있으면, 이 함수를 사용해야 한다.

비교 함수는 첫번째 인자가 두번째 인자보다 작거나, 같거나, 크다고 판단되면 0 보다 작거나, 같거나, 큰 정수를 반환해야 한다.

참고: 두 인자들이 같다면, 정렬된 배열에서 그들 순서는 알 수 없다. PHP 4.0.6 까지 사용자 정의 함수는 그들 원소에 대해서 원래의 순서를 유지할것이다. 그러나 4.1.0부터 사용되는 새로운 정렬 알고리즘에서는 더이상 그런 경우에 효율적인 방법의 그런 동작을 하는 해결책이 존재하지않는다.

예 1. usort() 예제코드

<?php
function cmp ($a, $b) {
    if ($a == $b) return 0;
    return ($a < $b) ? -1 : 1;
}

$a = array (3, 2, 5, 6, 1);

usort ($a, "cmp");

while (list ($key, $value) = each ($a)) {
    echo "$key: $value\n";
}
?>

위 예제코드는 다음을 출력할것이다:

0: 1
1: 2
2: 3
3: 5
4: 6

참고: 명백히 이런 흔한 경우에는 sort() 함수는 더욱 적절할것이다.

예 2. 다차원 배열을 사용하는 usort() 예제코드

<?php
function cmp ($a, $b) {
    return strcmp($a["fruit"], $b["fruit"]);
}

$fruits[0]["fruit"] = "lemons";
$fruits[1]["fruit"] = "apples";
$fruits[2]["fruit"] = "grapes";

usort($fruits, "cmp");

while (list ($key, $value) = each ($fruits)) {
    echo "\$fruits[$key]: " . $value["fruit"] . "\n";
}
?>

다차원 배열을 정렬할 때에는, $a와 $b는 배열의 첫번째 인덱스의 참조를 포함한다.

위 예제코드는 다음을 출력할것이다:

$fruits[0]: apples
$fruits[1]: grapes
$fruits[2]: lemons

예 3. 객체의 멤버 함수를 사용하는 usort() 예제코드

<?php
class TestObj {
    var $name;

    function TestObj($name)
    {
        $this->name = $name;
    }

    /* This is the static comparing function: */
    function cmp_obj($a, $b)
    {
        $al = strtolower($a->name);
        $bl = strtolower($b->name);
        if ($al == $bl) return 0;
        return ($al > $bl) ? +1 : -1;
    }
}

$a[] = new TestObj("c");
$a[] = new TestObj("b");
$a[] = new TestObj("d");

uasort($a, array ("TestObj", "cmp_obj"));

foreach ($a as $item) {
    print $item->name."\n";
}
?>

위 예제코드는 다음을 출력한다:

b
c
d

uasort(),
uksort(), sort(),
asort(),
arsort(),ksort(),
natsort(), rsort() 참고.

이전 | 처음으로 | 다음
uksort | 위로 | Aspell 함수 [deprecated]


Aspell 함수 [deprecated]

PHP 매뉴얼
이전 다음

III. Aspell 함수 [deprecated]

소개

aspell() 함수는 단어의 철자를 검사하고 틀린 경우 연상되는 단어를 제시한다.

참고: 이 확장은 PHP에서 제거되었고 PHP 4.3.0에서 더이상 사용할수 없다. PHP 에서 단어 검사를 원할 경우에는 대신 pspell를 사용하도록 한다. pspell함수는 pspell 라이브러리를 사용하고 최신버전의 aspell과 함께 실행된다.

요구 사항

aspell은 구버전( .27.* 까지 )의 aspell 라이브러리에서만 동작한다. 이 모듈과 그런 버전의 aspell 라이브러리는 더이상 지원되지 않는다. aspell 라이브러리가 필요하면, http://aspell.sourceforge.net/ 에서 구할수 있다.

설치

In PHP 4, these functions are only available if PHP was configured with --with-aspell=[DIR].

참고

pspell 참고.

차례
aspell_check_raw -- 단어의 철자가 올바른지만 검사한다 [deprecated]
aspell_check -- 단어 검사 [deprecated]
aspell_new -- 새 사전을 연다 [deprecated]
aspell_suggest -- 추천 단어를 제시한다 [deprecated]

이전 | 처음으로 | 다음
usort | 위로 | aspell_check_raw


aspell_check_raw

(PHP 3>= 3.0.7, PHP 4 <= 4.2.3)

aspell_check_raw -- 단어의 철자가 올바른지만 검사한다 [deprecated]

설명

bool aspell_check_raw ( int dictionary_link, string word)

aspell_check_raw()는 단어의 철자를 검사하기만 하고, 대소문자를 변경하거나 trim 하지 않고 올바르기만 하면, TRUE를 틀리면 FALSE를 반환한다.

예 1. aspell_check_raw()

<?php

$aspell_link = aspell_new("english");

if (aspell_check_raw($aspell_link, "test")) {
    echo "This is a valid spelling";
} else {
    echo "Sorry, wrong spelling";
}

?>

이전 | 처음으로 | 다음
Aspell 함수 [deprecated] | 위로 | aspell_check


aspell_check

(PHP 3>= 3.0.7, PHP 4 <= 4.2.3)

aspell_check -- 단어 검사 [deprecated]

설명

bool aspell_check ( int dictionary_link, string word)

aspell_check()는 단어의 철자를 검사하고, 올바르면 TRUE를 틀리면 FALSE를 반환한다.

예 1. aspell_check()

<?php

$aspell_link = aspell_new("english");

if (aspell_check($aspell_link, "testt")) {
    echo "This is a valid spelling";
} else {
    echo "Sorry, wrong spelling";
}

?>

이전 | 처음으로 | 다음
aspell_check_raw | 위로 | aspell_new


aspell_new

(PHP 3>= 3.0.7, PHP 4 <= 4.2.3)

aspell_new -- 새 사전을 연다 [deprecated]

설명

int aspell_new ( string master [, string personal])

aspell_new()는 새 사전을 열고 다른 aspell 함수에서 쓸수 있도록 연결용 사전 식별자를 반환한다. 에러가 발생하면 FALSE를 반환한다.

예 1. aspell_new()

<?php
$aspell_link = aspell_new("english");
?>

이전 | 처음으로 | 다음
aspell_check | 위로 | aspell_suggest


aspell_suggest

(PHP 3>= 3.0.7, PHP 4 <= 4.2.3)

aspell_suggest -- 추천 단어를 제시한다 [deprecated]

Description

array aspell_suggest ( int dictionary_link, string word)

aspell_suggest()는 주어진 단어에 대한 추천 단어들의 배열을 반환한다.

예 1. aspell_suggest()

<?php

$aspell_link = aspell_new("english");

if (!aspell_check($aspell_link, "test")) {
    $suggestions = aspell_suggest($aspell_link, "test");

    foreach ($suggestions as $suggestion) {
        echo "Possible spelling: $suggestion<br>\n";
    }
}

?>

이전 | 처음으로 | 다음
aspell_new | 위로 | BCMath 임의 정확도 수치연산 함수


BCMath 임의 정확도 수치연산 함수

PHP 매뉴얼
이전 다음

IV. BCMath 임의 정확도 수치연산 함수

소개

임의의 정확도를 갖는 수치연산을 위해 PHP는 이진 계산기를 제공한다. 이 이진 계산기(Binary Calculator)는 가능한 모든 크기와 정확도를 갖는 수들을 지원하고, 문자열로 표현된다.

요구 사항

PHP 4.0.4 이후부터 libbcmath가 PHP에서 같이 제공된다. 이 확장에 대해 외부적인 라이브러리가 필요치 않다.

설치

PHP 4에서, 이 함수를 사용하려면 PHP가 --enable-bcmath 옵션으로 설정되어야 한다. PHP 3에서, 이 함수를 사용하려면 PHP가 --disable-bcmath 옵션으로 설정되면 안된다.

PHP 윈도우 버전에서는 이 확장 모듈에 대한 지원이 포함되어 있습니다. 이 함수들을 이용하기 위해서 추가로 확장 모듈을 읽어들일 필요가 없습니다.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. BC math configuration options

Name | Default | Changeable
bcmath.scale | 0 | PHP_INI_ALL
For further details and definition of the PHP_INI_* constants see ini_set().

위 설정 지시어에 대한 간단한 설명입니다.

bcmath.scale integer

Number of decimal digits for all bcmath functions. See also bcscale().

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
bcadd -- 두개의 임의 정확도 수를 더한다
bccomp -- 두개의 임의 정확도 수를 비교한다
bcdiv -- 두개의 임의 정확도 수를 나눈다
bcmod -- 임의 정확도 수의 나머지를 구한다
bcmul -- 두개의 임의 정확도 수를 곱한다
bcpow -- 임의 정밀도 수를 제곱한다
bcpowmod -- Raise an arbitrary precision number to another, reduced by a specified modulus. 임의 정밀도 수를 계수에 의해 감소하는 다른 수로 제곱한다.
bcscale -- 모든 bc 수치계산 함수의 scale 매개변수의 기본값을 설정한다
bcsqrt -- 임의 정확도 수의 제곱근을 구한다
bcsub -- 임의 정확도 수를 다른 임의 정확도 수에서 뺀다

이전 | 처음으로 | 다음
aspell_suggest | 위로 | bcadd


bcadd

(PHP 3, PHP 4 , PHP 5)

bcadd -- 두개의 임의 정확도 수를 더한다

설명

string bcadd ( string left_operand, string right_operand [, int scale])

left_operand를 right_operand와 더하고 결과를 문자열로 반환한다. 선택적인 scale 매개변수는 결과값에서 소수점 이하의 자릿수를 정하는데 사용된다.

bcsub() 참고.

이전 | 처음으로 | 다음
BCMath 임의 정확도 수치연산 함수 | 위로 | bccomp


bccomp

(PHP 3, PHP 4 , PHP 5)

bccomp -- 두개의 임의 정확도 수를 비교한다

설명

int bccomp ( string left_operand, string right_operand [, int scale])

left_operand를 right_operand와 비교하고 결과값을 정수로 반환한다. 선택적인 scale 매개변수는 비교시 사용되는 소수점 이하 자릿수를 설정하는데 사용된다. 두 수가 같으면 0의 결과값을 반환한다. left_operand가 right_operand 보다 크면 +1을 반환하고, left_operand가 right_operand 보다 작으면 -1을 반환한다.

이전 | 처음으로 | 다음
bcadd | 위로 | bcdiv


bcdiv

(PHP 3, PHP 4 , PHP 5)

bcdiv -- 두개의 임의 정확도 수를 나눈다

설명

string bcdiv ( string left_operand, string right_operand [, int scale])

left_operand를 right_operand로 나누고 결과값을 반환한다. 선택적인 scale 매개변수는 결과값의 소수점 이하 자릿수를 결정하는데 사용된다.

bcmul() 참고.

이전 | 처음으로 | 다음
bccomp | 위로 | bcmod


bcmod

(PHP 3, PHP 4 , PHP 5)

bcmod -- 임의 정확도 수의 나머지를 구한다

설명

string bcmod ( string left_operand, string modulus)

modulus로 left_operand를 나눈 나머지를 구한다.

bcdiv() 참고.

이전 | 처음으로 | 다음
bcdiv | 위로 | bcmul


bcmul

(PHP 3, PHP 4 , PHP 5)

bcmul -- 두개의 임의 정확도 수를 곱한다

설명

string bcmul ( string left_operand, string right_operand [, int scale])

left_operand를 right_operand와 곱하고 결과값을 반환한다. 선택적인 scale 매개변수는 결과값의 소수점이하 자릿수를 결정한다.

bcdiv() 참고.

이전 | 처음으로 | 다음
bcmod | 위로 | bcpow


bcpow

(PHP 3, PHP 4 , PHP 5)

bcpow -- 임의 정밀도 수를 제곱한다

설명

string bcpow ( string x, int y [, int scale])

x를 y 제곱한다 선택적인 scale 매개변수는 소수점 이하 자릿수를 결정하는데 사용한다.

bcpowmod(), bcsqrt() 참고.

이전 | 처음으로 | 다음
bcmul | 위로 | bcpowmod


bcpowmod

(PHP 5)

bcpowmod -- Raise an arbitrary precision number to another, reduced by a specified modulus. 임의 정밀도 수를 계수에 의해 감소하는 다른 수로 제곱한다.

설명

string bcpowmod ( string x, string y, string modulus [, int scale])

x 를 계수 modulus와 관련된 y 제곱하기 위한 고속-멱법(fast-exponentiation) 기법을 사용한다. 선택적인 scale 매개변수는 소수점 이하 자릿수를 설정하는데 사용된다.

다음 두 구문은 기능상 동일하다. 하지만 bcpowmod() 버전은 좀더 짧은 시간에 수행되고 더 긴 매개변수를 허용한다.

<?php
$a = bcpowmod($x,$y,$mod);

$b = bcmod(bcpow($x,$y),$mod);

/* $a and $b are equal to each other. */
?>

참고: 이 방식은 계수 연산을 사용하기 때문에, 자연수가 아닌 수를 사용하면 기대하지 않은 결과를 낼수 있다. 자연수는 0이 아닌 양의 정수이다.

bcpow(), bcmod() 참고.

이전 | 처음으로 | 다음
bcpow | 위로 | bcscale


bcscale

(PHP 3, PHP 4 , PHP 5)

bcscale -- 모든 bc 수치계산 함수의 scale 매개변수의 기본값을 설정한다

설명

string bcscale ( int scale)

이 함수는 scale 매개변수를 명시하지 않은 모든 bc 수치계산 함수의 의 scale 매개변수의 기본값을 설정한다.

이전 | 처음으로 | 다음
bcpowmod | 위로 | bcsqrt


bcsqrt

(PHP 3, PHP 4 , PHP 5)

bcsqrt -- 임의 정확도 수의 제곱근을 구한다

설명

string bcsqrt ( string operand [, int scale])

operand의 제곱근을 반환한다. 선택적인 scale 매개변수는 결과값의 소수점 이하 자릿수를 설정한다.

bcpow() 참고.

이전 | 처음으로 | 다음
bcscale | 위로 | bcsub


bcsub

(PHP 3, PHP 4 , PHP 5)

bcsub -- 임의 정확도 수를 다른 임의 정확도 수에서 뺀다

설명

string bcsub ( string left_operand, string right_operand [, int scale])

right_operand를 left_operand에서 빼고 결과값을 문자열로 반환한다. 선택적인 scale 매개변수는 소수점 이하 자릿수를 설정하는데 사용된다.

bcadd() 참고.

이전 | 처음으로 | 다음
bcsqrt | 위로 | Bzip2 압축 함수


Bzip2 압축 함수

PHP 매뉴얼
이전 다음

V. Bzip2 압축 함수

소개

bzip2 함수는 손쉽게 bzip2 (.bz2) 압축 파일을 읽고 쓸수 있도록 해준다.

요구 사항

이 모듈은 Julian Seward 의 bzip2 라이브러리 함수를 사용한다. 이 모듈은 bzip2/libbzip2 버전 >= 1.0.x 을 요구한다..

설치

Bzip2 는 PHP 에서 기본적으로 활성화되지 않는다. bzip2 지원을 활성화시키고 PHP 를 컴파일하기 위해서는 --with-bz2[=DIR] 설정 옵션을 사용해야 한다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장은 한가지 리소스 타입을 정의한다: 작동중인 bz2 파일 식별 파일 포인터

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

예제

다음 예제코드는 임의의 파일을 열고 그 파일에 테스트 문자열을 쓰고나서, 그 파일의 내용을 출력한다.

예 1. 간단한 bzip2 예제코드

<?php

$filename = "/tmp/testfile.bz2";
$str = "This is a test string.\n";

// 쓰기전용으로 파일을 연다
$bz = bzopen($filename, "w");

// 파일에 문자열을 쓴다
bzwrite($bz, $str);

// 파일을 닫는다
bzclose($bz);

// 읽기전용으로 파일을 연다
$bz = bzopen($filename, "r");

// 10 문자를 읽는다
print bzread($bz, 10);

// 파일의 끝까지 출력( 또는 다음 1024 문자) 하고 나서 파일을 닫는다.
print bzread($bz);

bzclose($bz);

?>
차례
bzclose -- bzip2 파일 포인터를 닫는다
bzcompress -- 문자열을 bzip2 인코딩 데이터로 압축한다
bzdecompress -- bzip2 인코딩 데이터의 압축을 해제한다
bzerrno -- bzip2 에러 번호를 반환한다
bzerror -- bzip2 에러 번호와 에러 문자열을 배열로 반환한다
bzerrstr -- bzip2 에러 문자열을 반환한다
bzflush -- 버퍼에 담긴 모든 데이터를 강제로 기록한다
bzopen -- bzip2 압축 파일을 연다
bzread -- bzip2 파일을 바이너리 형태로 판독
bzwrite -- bzip2 파일을 바이너리 형태로 기록

이전 | 처음으로 | 다음
bcsub | 위로 | bzclose


bzclose

(PHP 4 >= 4.0.4, PHP 5)

bzclose -- bzip2 파일 포인터를 닫는다

설명

int bzclose ( resource bz)

포인터 bz에 의해 참조되는 bzip2 파일을 닫는다.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이 파일 포인터는 유효해야하고, bzopen()에 의해 성공적으로 열린 파일을 가리키고 있어야 한다.

bzopen() 참고.

이전 | 처음으로 | 다음
Bzip2 압축 함수 | 위로 | bzcompress


bzcompress

(PHP 4 >= 4.0.4, PHP 5)

bzcompress -- 문자열을 bzip2 인코딩 데이터로 압축한다

설명

string bzcompress ( string source [, int blocksize [, int workfactor]])

bzcompress()는 source 문자열을 압축하고 bzip2 인코딩 데이터로 반환한다

선택적인 매개변수 blocksize 는 압축중에 사용할 blocksize를 설정하고 1에서 9까지의 숫자가 되어야 하고 여기서 9는 가장 압축률이 높지만 자원을 더 많이 사용하게 된다. blocksize의 기본값은 4이다.

선택적인 매개변수 workfactor 는 반복이 많은 입력 데이터와 같은 최악의 경우에 압축이 어떻게 동작할지에 대해 제어한다. 이 값은 0부터 250이 될수 있고 0은 특수한 상황에서 쓰이고, 30은 기본값이 된다. 이 workfactor에 관계없이, 동일한 출력값이 나온다.

예 1. bzcompress() 예제코드

<?php
$str = "sample data";
$bzstr = bzcompress($str, 9);
print( $bzstr );
?>

bzdecompress() 참고.

이전 | 처음으로 | 다음
bzclose | 위로 | bzdecompress


bzdecompress

(PHP 4 >= 4.0.4, PHP 5)

bzdecompress -- bzip2 인코딩 데이터의 압축을 해제한다

설명

string bzdecompress ( string source [, int small])

bzdecompress()는 bzip2 인코딩 데이터를 포함하는 source 문자열의 압축을 해제하고 반환한다. 선택적인 매개변수 small 이 TRUE이면, 메모리를 더 적게 사용하는 대체 압축 해제 알고리즘이 사용될것이다 (최대 메모리 요구량은 2300K 이하이다). 그러나 속도는 반으로 줄게 된다.이 기능에 대해 더많은 정보를 얻으려면 bzip2 문서를 참고한다.

예 1. bzdecompress()

<?php
$start_str = "This is not an honest face?";
$bzstr = bzcompress($start_str);

print( "압축 문자열: " );
print( $bzstr );
print( "\n<br>\n" );

$str = bzdecompress($bzstr);
print( "압축 해제된 문자열: " );
print( $str );
print( "\n<br>\n" );
?>

bzcompress() 참고.

이전 | 처음으로 | 다음
bzcompress | 위로 | bzerrno


bzerrno

(PHP 4 >= 4.0.4, PHP 5)

bzerrno -- bzip2 에러 번호를 반환한다

설명

int bzerrno ( resource bz)

파일 포인터 bz 에서 반환하는 bzip2 에러의 에러 번호를 반환한다.

bzerror() 과 bzerrstr() 참고.

이전 | 처음으로 | 다음
bzdecompress | 위로 | bzerror


bzerror

(PHP 4 >= 4.0.4, PHP 5)

bzerror -- bzip2 에러 번호와 에러 문자열을 배열로 반환한다

설명

array bzerror ( resource bz)

파일 포인터 bz에 의해 반환되는 bzip2 에러의 에러 번호와 에러 문자열을 연관 배열로 반환한다.

예 1. bzerror() 예제코드

<?php
$error = bzerror($bz);

echo $error["errno"];
echo $error["errstr"];
?>

bzerrno() 과 bzerrstr() 참고.

이전 | 처음으로 | 다음
bzerrno | 위로 | bzerrstr


bzerrstr

(PHP 4 >= 4.0.4, PHP 5)

bzerrstr -- bzip2 에러 문자열을 반환한다

설명

string bzerrstr ( resource bz)

파일 포인터 bz에 의해 반환하는 bzip2 에러의 에러 문자열을 반환한다.

bzerrno() 과 bzerror() 참고.

이전 | 처음으로 | 다음
bzerror | 위로 | bzflush


bzflush

(PHP 4 >= 4.0.4, PHP 5)

bzflush -- 버퍼에 담긴 모든 데이터를 강제로 기록한다

설명

int bzflush ( resource bz)

파일 포인터 bz를 위해 버퍼에 담긴 bzip2의 모든 데이터를 강제로 기록한다.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

bzread() 과 bzwrite() 참고.

이전 | 처음으로 | 다음
bzerrstr | 위로 | bzopen


bzopen

(PHP 4 >= 4.0.4, PHP 5)

bzopen -- bzip2 압축 파일을 연다

설명

resource bzopen ( string filename, string mode)

읽거나 쓰기 위해 bzip2 (.bz2) 파일을 연다. filename은 열기위한 파일명이다. mode는 fopen()(읽기용의 `r' , 쓰기용의 `w', 등등 )과 유사하다.

열기를 실패하면, 이 함수는 FALSE를 반환하고, 그렇지 않으면 새롭게 열린 파일의 포인터를 반환한다.

예 1. bzopen() 예제코드

<?php
$bz = bzopen("/tmp/foo.bz2", "r");

$decompressed_file = '';
while (!feof($bz)) {
    $decompressed_file .= bzread($bz, 4096);
}
bzclose($bz);

print( "The contents of /tmp/foo.bz2 are: " );
print( "\n<br>\n" );
print( $decompressed_file );
?>

bzclose() 참고.

이전 | 처음으로 | 다음
bzflush | 위로 | bzread


bzread

(PHP 4 >= 4.0.4, PHP 5)

bzread -- bzip2 파일을 바이너리 형태로 판독

설명

string bzread ( resource bz [, int length])

bzread()는 bz에 의해 참조되는 bzip2 파일 포인터에서 length 바이트만큼을 읽어 온다. length (압축되지 않은 상태의) 바이트만큼 읽혀지거나 EOF 에 도달하면 읽기를 멈춘다. 선택적인 매개변수 length가 설정되지 않으면, bzread()는 한번에 1024 (압축되지 않은 상태의) 바이트만큼 읽어올것이다.

예 1. bzread() 예제코드

<?php
$bz = bzopen("/tmp/foo.bz2", "r");
$str = bzread($bz, 2048);
print( $str );
?>

bzwrite() 과 bzopen() 참고.

이전 | 처음으로 | 다음
bzopen | 위로 | bzwrite


bzwrite

(PHP 4 >= 4.0.4, PHP 5)

bzwrite -- bzip2 파일을 바이너리 형태로 기록

설명

int bzwrite ( resource bz, string data [, int length])

bzwrite()는 bz에 의해 참조되는 bzip2 파일 스트림으로 data 문자열의 내용을 기록한다. 선택적인 length 인자가 주어지면, 이 length (압축되지 않은 상태의) 바이트만큼이나 문자열의 끝에 도달했을때 기록을 멈춘다.

예 1. bzwrite() 예제코드

<?php
$str = "uncompressed data";
$bz = bzopen("/tmp/foo.bz2", "w");
bzwrite($bz, $str, strlen($str));
bzclose($bz);
?>

See also bzread() and bzopen().

이전 | 처음으로 | 다음
bzread | 위로 | 달력 함수


달력 함수

PHP 매뉴얼
이전 다음

VI. 달력 함수

소개

이 달력(calendar) 확장은 서로 다른 달력 형태를 변환시켜 주는 함수들을 제공한다. 율리우스 날짜수(Julian Day Count)에 기반하여 변환이 된다. 율리우스 날짜수은 율리우스 1세, 4713 B.C. 부터 지난 날짜수가 된다. 달력 시스템 사이의 변환을 위해서는, 먼저 율리우스 날짜수으로 변환해야 하고, 그 다음에 원하는 달력 시스템으로 변환하는것이다. 율리우스 날짜수는 율리우스력(Julian Calendar)와는 매우 다른것이다! 율리우스 날짜수(Julian Day Count)에 대해 더 많은 정보를 얻고 싶으면 http://www.hermetic.ch/cal_stud/jdn.htm를 방문한다. 날짜 시스템에 관한 더 많은 정보를 원하면 http://www.boogle.com/info/cal-overview.html를 방문한다. 이 설명서중에서는 위의 페이지에서 발취한 내용을 ""로 둘러 싸고 있다.

설치

이 함수들를 작동시키기 위해서는, PHP를 컴파일할때 --enable-calendar 옵션을 써야 한다.

PHP 윈도우 버전에서는 이 확장 모듈에 대한 지원이 포함되어 있습니다. 이 함수들을 이용하기 위해서 추가로 확장 모듈을 읽어들일 필요가 없습니다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

CAL_GREGORIAN (integer)

CAL_JULIAN (integer)

CAL_JEWISH (integer)

CAL_FRENCH (integer)

CAL_NUM_CALS (integer)

CAL_DOW_DAYNO (integer)

CAL_DOW_SHORT (integer)

CAL_DOW_LONG (integer)

CAL_MONTH_GREGORIAN_SHORT (integer)

CAL_MONTH_GREGORIAN_LONG (integer)

CAL_MONTH_JULIAN_SHORT (integer)

CAL_MONTH_JULIAN_LONG (integer)

CAL_MONTH_JEWISH (integer)

CAL_MONTH_FRENCH (integer)

The following constants are available since PHP 4.3.0 :

CAL_EASTER_DEFAULT (integer)

CAL_EASTER_ROMAN (integer)

CAL_EASTER_ALWAYS_GREGORIAN (integer)

CAL_EASTER_ALWAYS_JULIAN (integer)

The following constants are available since PHP 5.0.0 :

CAL_JEWISH_ADD_ALAFIM_GERESH (integer)

CAL_JEWISH_ADD_ALAFIM (integer)

CAL_JEWISH_ADD_GERESHAYIM (integer)

차례
cal_days_in_month -- Return the number of days in a month for a given year and calendar
cal_from_jd -- Converts from Julian Day Count to a supported calendar
cal_info -- Returns information about a particular calendar
cal_to_jd -- Converts from a supported calendar to Julian Day Count
easter_date -- Get Unix timestamp for midnight on Easter of a given year
easter_days -- Get number of days after March 21 on which Easter falls for a given year
FrenchToJD -- Converts a date from the French Republican Calendar to a Julian Day Count
GregorianToJD -- Converts a Gregorian date to Julian Day Count
JDDayOfWeek -- Returns the day of the week
JDMonthName -- Returns a month name
JDToFrench -- Converts a Julian Day Count to the French Republican Calendar
JDToGregorian -- Converts Julian Day Count to Gregorian date
jdtojewish -- Converts a Julian day count to a Jewish calendar date
JDToJulian -- Converts a Julian Day Count to a Julian Calendar Date
jdtounix -- Convert Julian Day to Unix timestamp
JewishToJD -- Converts a date in the Jewish Calendar to Julian Day Count
JulianToJD -- Converts a Julian Calendar date to Julian Day Count
unixtojd -- Convert Unix timestamp to Julian Day

이전 | 처음으로 | 다음
bzwrite | 위로 | cal_days_in_month


cal_days_in_month

(PHP 4 >= 4.1.0, PHP 5)

cal_days_in_month -- Return the number of days in a month for a given year and calendar

Description

int cal_days_in_month ( int calendar, int month, int year)

This function will return the number of days in the month of year for the specified calendar.

예 1. cal_days_in_month() example

<?php
$num = cal_days_in_month(CAL_GREGORIAN, 8, 2003); // 31
echo "There was $num days in August 2003";
?>

See also jdtounix().

이전 | 처음으로 | 다음
달력 함수 | 위로 | cal_from_jd


cal_from_jd

(PHP 4 >= 4.1.0, PHP 5)

cal_from_jd -- Converts from Julian Day Count to a supported calendar

Description

array cal_from_jd ( int jd, int calendar)

cal_from_jd() converts the Julian day given in jd into a date of the specified calendar. Supported calendar values are CAL_GREGORIAN, CAL_JULIAN, CAL_JEWISH and CAL_FRENCH.

예 1. cal_from_jd() example

<?php
$today = unixtojd(mktime(0, 0, 0, 8, 16, 2003));
print_r(cal_from_jd($today, CAL_GREGORIAN));
?>

This will output :

Array
(
    [date] => 8/16/2003
    [month] => 8
    [day] => 16
    [year] => 2003
    [dow] => 6
    [abbrevdayname] => Sat
    [dayname] => Saturday
    [abbrevmonth] => Aug
    [monthname] => August
)

See also cal_to_jd().

이전 | 처음으로 | 다음
cal_days_in_month | 위로 | cal_info


cal_info

(PHP 4 >= 4.1.0, PHP 5)

cal_info -- Returns information about a particular calendar

Description

array cal_info ( [int calendar])

cal_info() returns information on the specified calendar or on all supported calendars if no calendar is specified.

Calendar information is returned as an array containing the elements calname, calsymbol, month, abbrevmonth and maxdaysinmonth.

If no calendar is specified information on all supported calendars is returned as an array. This functionality will be available beginning with PHP 5.

이전 | 처음으로 | 다음
cal_from_jd | 위로 | cal_to_jd


cal_to_jd

(PHP 4 >= 4.1.0, PHP 5)

cal_to_jd -- Converts from a supported calendar to Julian Day Count

Description

int cal_to_jd ( int calendar, int month, int day, int year)

cal_to_jd() calculates the Julian day count for a date in the specified calendar. Supported calendars are CAL_GREGORIAN, CAL_JULIAN, CAL_JEWISH and CAL_FRENCH.

See also cal_to_jd().

이전 | 처음으로 | 다음
cal_info | 위로 | easter_date


easter_date

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

easter_date -- Get Unix timestamp for midnight on Easter of a given year

Description

int easter_date ( [int year])

Returns the Unix timestamp corresponding to midnight on Easter of the given year.

Since PHP 4.3.0, the year parameter is optional and defaults to the current year according to the localtime if omitted.

예 1. easter_date() example

<?php

echo date("M-d-Y", easter_date(1999));        // Apr-04-1999
echo date("M-d-Y", easter_date(2000));        // Apr-23-2000
echo date("M-d-Y", easter_date(2001));        // Apr-15-2001

?>

주의

This function will generate a warning if the year is outside of the range for Unix timestamps (i.e. before 1970 or after 2037).

The date of Easter Day was defined by the Council of Nicaea in AD325 as the Sunday after the first full moon which falls on or after the Spring Equinox. The Equinox is assumed to always fall on 21st March, so the calculation reduces to determining the date of the full moon and the date of the following Sunday. The algorithm used here was introduced around the year 532 by Dionysius Exiguus. Under the Julian Calendar (for years before 1753) a simple 19-year cycle is used to track the phases of the Moon. Under the Gregorian Calendar (for years after 1753 - devised by Clavius and Lilius, and introduced by Pope Gregory XIII in October 1582, and into Britain and its then colonies in September 1752) two correction factors are added to make the cycle more accurate.

(The code is based on a C program by Simon Kershaw, <webmaster at ely.anglican dot org>)

See easter_days() for calculating Easter before 1970 or after 2037.

이전 | 처음으로 | 다음
cal_to_jd | 위로 | easter_days


easter_days

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

easter_days -- Get number of days after March 21 on which Easter falls for a given year

Description

int easter_days ( [int year [, int method]])

Returns the number of days after March 21 on which Easter falls for a given year. If no year is specified, the current year is assumed.

Since PHP 4.3.0, the year parameter is optional and defaults to the current year according to the localtime if omitted.

The method parameter was also introduced in PHP 4.3.0 and allows to calculate easter dates based on the Gregorian calendar during the years 1582 - 1752 when set to CAL_EASTER_ROMAN. See the calendar constants for more valid constants.

This function can be used instead of easter_date() to calculate Easter for years which fall outside the range of Unix timestamps (i.e. before 1970 or after 2037).

예 1. easter_days() example

<?php

echo easter_days(1999);        // 14, i.e. April 4
echo easter_days(1492);        // 32, i.e. April 22
echo easter_days(1913);        //  2, i.e. March 23

?>

The date of Easter Day was defined by the Council of Nicaea in AD325 as the Sunday after the first full moon which falls on or after the Spring Equinox. The Equinox is assumed to always fall on 21st March, so the calculation reduces to determining the date of the full moon and the date of the following Sunday. The algorithm used here was introduced around the year 532 by Dionysius Exiguus. Under the Julian Calendar (for years before 1753) a simple 19-year cycle is used to track the phases of the Moon. Under the Gregorian Calendar (for years after 1753 - devised by Clavius and Lilius, and introduced by Pope Gregory XIII in October 1582, and into Britain and its then colonies in September 1752) two correction factors are added to make the cycle more accurate.

(The code is based on a C program by Simon Kershaw, <webmaster at ely.anglican dot org>)

See also easter_date().

이전 | 처음으로 | 다음
easter_date | 위로 | FrenchToJD


FrenchToJD

(PHP 3, PHP 4 , PHP 5)

FrenchToJD -- Converts a date from the French Republican Calendar to a Julian Day Count

Description

int frenchtojd ( int month, int day, int year)

Converts a date from the French Republican Calendar to a Julian Day Count.

These routines only convert dates in years 1 through 14 (Gregorian dates 22 September 1792 through 22 September 1806). This more than covers the period when the calendar was in use.

이전 | 처음으로 | 다음
easter_days | 위로 | GregorianToJD


GregorianToJD

(PHP 3, PHP 4 , PHP 5)

GregorianToJD -- Converts a Gregorian date to Julian Day Count

Description

int gregoriantojd ( int month, int day, int year)

Valid Range for Gregorian Calendar 4714 B.C. to 9999 A.D.

Although this function can handle dates all the way back to 4714 B.C., such use may not be meaningful. The Gregorian calendar was not instituted until October 15, 1582 (or October 5, 1582 in the Julian calendar). Some countries did not accept it until much later. For example, Britain converted in 1752, The USSR in 1918 and Greece in 1923. Most European countries used the Julian calendar prior to the Gregorian.

예 1. Calendar functions

<?php
$jd = GregorianToJD(10, 11, 1970);
echo "$jd\n";
$gregorian = JDToGregorian($jd);
echo "$gregorian\n";
?>

이전 | 처음으로 | 다음
FrenchToJD | 위로 | JDDayOfWeek


JDDayOfWeek

(PHP 3, PHP 4 , PHP 5)

JDDayOfWeek -- Returns the day of the week

Description

mixed jddayofweek ( int julianday, int mode)

Returns the day of the week. Can return a string or an integer depending on the mode.

표 1. Calendar week modes

Mode | Meaning
0 | Returns the day number as an int (0=Sunday, 1=Monday, etc)
1 | Returns string containing the day of week (English-Gregorian)
2 | Returns a string containing the abbreviated day of week (English-Gregorian)

이전 | 처음으로 | 다음
GregorianToJD | 위로 | JDMonthName


JDMonthName

(PHP 3, PHP 4 , PHP 5)

JDMonthName -- Returns a month name

Description

string jdmonthname ( int julianday, int mode)

Returns a string containing a month name. mode tells this function which calendar to convert the Julian Day Count to, and what type of month names are to be returned.

표 1. Calendar modes

Mode | Meaning | Values
0 | Gregorian - abbreviated | Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec
1 | Gregorian | January, February, March, April, May, June, July, August, September, October, November, December
2 | Julian - abbreviated | Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec
3 | Julian | January, February, March, April, May, June, July, August, September, October, November, December
4 | Jewish | Tishri, Heshvan, Kislev, Tevet, Shevat, AdarI, AdarII, Nisan, Iyyar, Sivan, Tammuz, Av, Elul
5 | French Republican | Vendemiaire, Brumaire, Frimaire, Nivose, Pluviose, Ventose, Germinal, Floreal, Prairial, Messidor, Thermidor, Fructidor, Extra

이전 | 처음으로 | 다음
JDDayOfWeek | 위로 | JDToFrench


JDToFrench

(PHP 3, PHP 4 , PHP 5)

JDToFrench -- Converts a Julian Day Count to the French Republican Calendar

Description

string jdtofrench ( int juliandaycount)

Converts a Julian Day Count to the French Republican Calendar.

이전 | 처음으로 | 다음
JDMonthName | 위로 | JDToGregorian


JDToGregorian

(PHP 3, PHP 4 , PHP 5)

JDToGregorian -- Converts Julian Day Count to Gregorian date

Description

string jdtogregorian ( int julianday)

Converts Julian Day Count to a string containing the Gregorian date in the format of "month/day/year".

이전 | 처음으로 | 다음
JDToFrench | 위로 | jdtojewish


jdtojewish

(PHP 3, PHP 4 , PHP 5)

jdtojewish -- Converts a Julian day count to a Jewish calendar date

Description

string jdtojewish ( int juliandaycount [, bool hebrew [, int fl]])

Converts a Julian Day Count to the Jewish Calendar.

The optional hebrew and fl parameters became available in PHP 5.0.0

If the hebrew parameter is set to TRUE, the fl parameter is used for Hebrew, string based, output format. The available formats are: CAL_JEWISH_ADD_ALAFIM_GERESH, CAL_JEWISH_ADD_ALAFIM, CAL_JEWISH_ADD_GERESHAYIM.

예 1. jdtojewish() Example

<?php
echo jdtojewish(gregoriantojd(10, 8, 2002), true,
       CAL_JEWISH_ADD_GERESHAYIM + CAL_JEWISH_ADD_ALAFIM + CAL_JEWISH_ADD_ALAFIM_GERESH);
?>

이전 | 처음으로 | 다음
JDToGregorian | 위로 | JDToJulian


JDToJulian

(PHP 3, PHP 4 , PHP 5)

JDToJulian -- Converts a Julian Day Count to a Julian Calendar Date

Description

string jdtojulian ( int julianday)

Converts Julian Day Count to a string containing the Julian Calendar Date in the format of "month/day/year".

이전 | 처음으로 | 다음
jdtojewish | 위로 | jdtounix


jdtounix

(PHP 4 , PHP 5)

jdtounix -- Convert Julian Day to Unix timestamp

Description

int jdtounix ( int jday)

This function will return a Unix timestamp corresponding to the Julian Day given in jday or FALSE if jday is not inside the Unix epoch (Gregorian years between 1970 and 2037 or 2440588 <= jday <= 2465342 ). The time returned is localtime (and not GMT).

See also unixtojd().

이전 | 처음으로 | 다음
JDToJulian | 위로 | JewishToJD


JewishToJD

(PHP 3, PHP 4 , PHP 5)

JewishToJD -- Converts a date in the Jewish Calendar to Julian Day Count

Description

int jewishtojd ( int month, int day, int year)

Although this function can handle dates all the way back to the year 1 (3761 B.C.), such use may not be meaningful. The Jewish calendar has been in use for several thousand years, but in the early days there was no formula to determine the start of a month. A new month was started when the new moon was first observed.

이전 | 처음으로 | 다음
jdtounix | 위로 | JulianToJD


JulianToJD

(PHP 3, PHP 4 , PHP 5)

JulianToJD -- Converts a Julian Calendar date to Julian Day Count

Description

int juliantojd ( int month, int day, int year)

Valid Range for Julian Calendar 4713 B.C. to 9999 A.D.

Although this function can handle dates all the way back to 4713 B.C., such use may not be meaningful. The calendar was created in 46 B.C., but the details did not stabilize until at least 8 A.D., and perhaps as late at the 4th century. Also, the beginning of a year varied from one culture to another - not all accepted January as the first month.

경고

Remember, the current calendar system being used worldwide is the Gregorian calendar. gregoriantojd() can be used to convert such dates to their Julian Day count.

이전 | 처음으로 | 다음
JewishToJD | 위로 | unixtojd


unixtojd

(PHP 4 , PHP 5)

unixtojd -- Convert Unix timestamp to Julian Day

Description

int unixtojd ( [int timestamp])

Return the Julian Day for a Unix timestamp (seconds since 1.1.1970), or for the current day if no timestamp is given.

See also jdtounix().

이전 | 처음으로 | 다음
JulianToJD | 위로 | CCVS API Functions [deprecated]


CCVS API Functions [deprecated]

PHP 매뉴얼
이전 다음

VII. CCVS API Functions [deprecated]

소개

These functions interface the CCVS API, allowing you to work directly with CCVS from your PHP scripts. CCVS is RedHat's solution to the "middle-man" in credit card processing. It lets you directly address the credit card clearing houses via your *nix box and a modem. Using the CCVS module for PHP, you can process credit cards directly through CCVS via your PHP Scripts. The following references will outline the process.

참고: CCVS has been discontinued by Red Hat and there are no plans to issue further keys or support contracts. Those looking for a replacement can consider MCVE by Main Street Softworks as a potential replacement. It is similar in design and has documented PHP support!

This extension has been removed from PHP and is no longer available as of PHP 4.3.0. If you want to use credit card processing features you can use MCVE instead.

설치

To enable CCVS Support in PHP, first verify your CCVS installation directory. You will then need to configure PHP with the --with-ccvs option. If you use this option without specifying the path to your CCVS installation, PHP will attempt to look in the default CCVS Install location (/usr/local/ccvs). If CCVS is in a non-standard location, run configure with: --with-ccvs=[DIR], where DIR is the path to your CCVS installation. Please note that CCVS support requires that DIR/lib and DIR/include exist, and include cv_api.h under the include directory and libccvs.a under the lib directory.

Additionally, a ccvsd process will need to be running for the configurations you intend to use in your PHP scripts. You will also need to make sure the PHP Processes are running under the same user as your CCVS was installed as (e.g. if you installed CCVS as user 'ccvs', your PHP processes must run as 'ccvs' as well.)

참고

RedHat has discontinued support for CCVS; however, a slightly outdated manual is still available at http://redhat.com/docs/manuals/ccvs/.

차례
ccvs_add -- Add data to a transaction
ccvs_auth -- Perform credit authorization test on a transaction
ccvs_command -- Performs a command which is peculiar to a single protocol, and thus is not available in the general CCVS API
ccvs_count -- Find out how many transactions of a given type are stored in the system
ccvs_delete -- Delete a transaction
ccvs_done -- Terminate CCVS engine and do cleanup work
ccvs_init -- Initialize CCVS for use
ccvs_lookup -- Look up an item of a particular type in the database #
ccvs_new -- Create a new, blank transaction
ccvs_report -- Return the status of the background communication process
ccvs_return -- Transfer funds from the merchant to the credit card holder
ccvs_reverse -- Perform a full reversal on an already-processed authorization
ccvs_sale -- Transfer funds from the credit card holder to the merchant
ccvs_status -- Check the status of an invoice
ccvs_textvalue -- Get text return value for previous function call
ccvs_void -- Perform a full reversal on a completed transaction

이전 | 처음으로 | 다음
unixtojd | 위로 | ccvs_add


ccvs_add

(4.0.2 - 4.2.3 only)

ccvs_add -- Add data to a transaction

Description

string ccvs_add ( string session, string invoice, string argtype, string argval)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
CCVS API Functions [deprecated] | 위로 | ccvs_auth


ccvs_auth

(4.0.2 - 4.2.3 only)

ccvs_auth -- Perform credit authorization test on a transaction

Description

string ccvs_auth ( string session, string invoice)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ccvs_add | 위로 | ccvs_command


ccvs_command

(4.0.2 - 4.2.3 only)

ccvs_command -- Performs a command which is peculiar to a single protocol, and thus is not available in the general CCVS API

Description

string ccvs_command ( string session, string type, string argval)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ccvs_auth | 위로 | ccvs_count


ccvs_count

(4.0.2 - 4.2.3 only)

ccvs_count -- Find out how many transactions of a given type are stored in the system

Description

int ccvs_count ( string session, string type)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ccvs_command | 위로 | ccvs_delete


ccvs_delete

(4.0.2 - 4.2.3 only)

ccvs_delete -- Delete a transaction

Description

string ccvs_delete ( string session, string invoice)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ccvs_count | 위로 | ccvs_done


ccvs_done

(4.0.2 - 4.2.3 only)

ccvs_done -- Terminate CCVS engine and do cleanup work

Description

string ccvs_done ( string sess)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ccvs_delete | 위로 | ccvs_init


ccvs_init

(4.0.2 - 4.2.3 only)

ccvs_init -- Initialize CCVS for use

Description

string ccvs_init ( string name)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ccvs_done | 위로 | ccvs_lookup


ccvs_lookup

(4.0.2 - 4.2.3 only)

ccvs_lookup -- Look up an item of a particular type in the database #

Description

string ccvs_lookup ( string session, string invoice, int inum)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ccvs_init | 위로 | ccvs_new


ccvs_new

(4.0.2 - 4.2.3 only)

ccvs_new -- Create a new, blank transaction

Description

string ccvs_new ( string session, string invoice)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ccvs_lookup | 위로 | ccvs_report


ccvs_report

(4.0.2 - 4.2.3 only)

ccvs_report -- Return the status of the background communication process

Description

string ccvs_report ( string session, string type)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ccvs_new | 위로 | ccvs_return


ccvs_return

(4.0.2 - 4.2.3 only)

ccvs_return -- Transfer funds from the merchant to the credit card holder

Description

string ccvs_return ( string session, string invoice)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ccvs_report | 위로 | ccvs_reverse


ccvs_reverse

(4.0.2 - 4.2.3 only)

ccvs_reverse -- Perform a full reversal on an already-processed authorization

Description

string ccvs_reverse ( string session, string invoice)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ccvs_return | 위로 | ccvs_sale


ccvs_sale

(4.0.2 - 4.2.3 only)

ccvs_sale -- Transfer funds from the credit card holder to the merchant

Description

string ccvs_sale ( string session, string invoice)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ccvs_reverse | 위로 | ccvs_status


ccvs_status

(4.0.2 - 4.2.3 only)

ccvs_status -- Check the status of an invoice

Description

string ccvs_status ( string session, string invoice)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ccvs_sale | 위로 | ccvs_textvalue


ccvs_textvalue

(4.0.2 - 4.2.3 only)

ccvs_textvalue -- Get text return value for previous function call

Description

string ccvs_textvalue ( string session)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ccvs_status | 위로 | ccvs_void


ccvs_void

(4.0.2 - 4.2.3 only)

ccvs_void -- Perform a full reversal on a completed transaction

Description

string ccvs_void ( string session, string invoice)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ccvs_textvalue | 위로 | COM support functions for Windows


COM support functions for Windows

PHP 매뉴얼
이전 다음

VIII. COM support functions for Windows

소개

COM is a technology which allows the reuse of code written in any language (by any language) using a standard calling convention and hiding behind APIs the implementation details such as what machine the Component is stored on and the executable which houses it. It can be thought of as a super Remote Procedure Call (RPC) mechanism with some basic object roots. It separates implementation from interface.

COM encourages versioning, separation of implementation from interface and hiding the implementation details such as executable location and the language it was written in.

요구 사항

COM functions are only available on the Windows version of PHP.

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

PHP 윈도우 버전에서는 이 확장 모듈에 대한 지원이 포함되어 있습니다. 이 함수들을 이용하기 위해서 추가로 확장 모듈을 읽어들일 필요가 없습니다.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. Com configuration options

Name | Default | Changeable
com.allow_dcom | "0" | PHP_INI_SYSTEM
com.autoregister_typelib | "0" | PHP_INI_SYSTEM
com.autoregister_verbose | "0" | PHP_INI_SYSTEM
com.autoregister_casesensitive | "1" | PHP_INI_SYSTEM
com.typelib_file | "" | PHP_INI_SYSTEM
For further details and definition of the PHP_INI_* constants see ini_set().

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

CLSCTX_INPROC_SERVER (integer)

CLSCTX_INPROC_HANDLER (integer)

CLSCTX_LOCAL_SERVER (integer)

CLSCTX_REMOTE_SERVER (integer)

CLSCTX_SERVER (integer)

CLSCTX_ALL (integer)

VT_NULL (integer)

VT_EMPTY (integer)

VT_UI1 (integer)

VT_I2 (integer)

VT_I4 (integer)

VT_R4 (integer)

VT_R8 (integer)

VT_BOOL (integer)

VT_ERROR (integer)

VT_CY (integer)

VT_DATE (integer)

VT_BSTR (integer)

VT_DECIMAL (integer)

VT_UNKNOWN (integer)

VT_DISPATCH (integer)

VT_VARIANT (integer)

VT_I1 (integer)

VT_UI2 (integer)

VT_UI4 (integer)

VT_INT (integer)

VT_UINT (integer)

VT_ARRAY (integer)

VT_BYREF (integer)

CP_ACP (integer)

CP_MACCP (integer)

CP_OEMCP (integer)

CP_UTF7 (integer)

CP_UTF8 (integer)

CP_SYMBOL (integer)

CP_THREAD_ACP (integer)

참고

For further information on COM read the COM specification or perhaps take a look at Don Box's Yet Another COM Library (YACL)

차례
COM -- COM class
VARIANT -- VARIANT class
com_addref -- Increases the components reference counter.
com_get -- Gets the value of a COM Component's property
com_invoke -- Calls a COM component's method.
com_isenum -- Grabs an IEnumVariant
com_load_typelib -- Loads a Typelib
com_load -- Creates a new reference to a COM component
com_propget -- Alias of com_get()
com_propput -- Alias of com_set()
com_propset -- Alias of com_set()
com_release -- Decreases the components reference counter.
com_set -- Assigns a value to a COM component's property

이전 | 처음으로 | 다음
ccvs_void | 위로 | COM


COM

(no version information, might be only in CVS)

COM -- COM class

요약

$obj = new COM("server.object")

Description

The COM class provides a framework to integrate (D)COM components into your PHP scripts.

Methods

string COM::COM ( string module_name [, string server_name [, int codepage]])

COM class constructor. Parameters:

module_name

name or class-id of the requested component.

server_name

name of the DCOM server from which the component should be fetched. If NULL, localhost is assumed. To allow DCOM com.allow_dcom has to be set to TRUE in php.ini.

codepage

specifies the codepage that is used to convert php-strings to unicode-strings and vice versa. Possible values are CP_ACP, CP_MACCP, CP_OEMCP, CP_SYMBOL, CP_THREAD_ACP, CP_UTF7 and CP_UTF8.

예 1. COM example (1)

<?php
// starting word
$word = new COM("word.application") or die("Unable to instanciate Word");
echo "Loaded Word, version {$word->Version}\n";

//bring it to front
$word->Visible = 1;

//open an empty document
$word->Documents->Add();

//do some weird stuff
$word->Selection->TypeText("This is a test...");
$word->Documents[1]->SaveAs("Useless test.doc");

//closing word
$word->Quit();

//free the object
$word->Release();
$word = null;
?>

예 2. COM example (2)

<?php

$conn = new COM("ADODB.Connection") or die("Cannot start ADO");
$conn->Open("Provider=SQLOLEDB; Data Source=localhost;
Initial Catalog=database; User ID=user; Password=password");

$rs = $conn->Execute("SELECT * FROM sometable");    // Recordset

$num_columns = $rs->Fields->Count();
echo $num_columns . "\n";

for ($i=0; $i < $num_columns; $i++) {
    $fld[$i] = $rs->Fields($i);
}

$rowcount = 0;
while (!$rs->EOF) {
    for ($i=0; $i < $num_columns; $i++) {
        echo $fld[$i]->value . "\t";
    }
    echo "\n";
    $rowcount++;            // increments rowcount
    $rs->MoveNext();
}

$rs->Close();
$conn->Close();

$rs->Release();
$conn->Release();

$rs = null;
$conn = null;

?>

이전 | 처음으로 | 다음
COM support functions for Windows | 위로 | VARIANT


VARIANT

(no version information, might be only in CVS)

VARIANT -- VARIANT class

요약

$vVar = new VARIANT($var)

Description

A simple container to wrap variables into VARIANT structures.

Methods

string VARIANT::VARIANT ( [mixed value [, int type [, int codepage]]])

VARIANT class constructor. Parameters:

value

initial value. if omitted an VT_EMPTY object is created.

type

specifies the content type of the VARIANT object. Possible values are VT_UI1, VT_UI2, VT_UI4, VT_I1, VT_I2, VT_I4, VT_R4, VT_R8, VT_INT, VT_UINT, VT_BOOL, VT_ERROR, VT_CY, VT_DATE, VT_BSTR, VT_DECIMAL, VT_UNKNOWN, VT_DISPATCH and VT_VARIANT. These values are mutual exclusive, but they can be combined with VT_BYREF to specify being a value. If omitted, the type of value is used. Consult the MSDN library for additional information.

codepage

specifies the codepage that is used to convert php-strings to unicode-strings and vice versa. Possible values are CP_ACP, CP_MACCP, CP_OEMCP, CP_SYMBOL, CP_THREAD_ACP, CP_UTF7 and CP_UTF8.

이전 | 처음으로 | 다음
COM | 위로 | com_addref


com_addref

(PHP 4 >= 4.1.0)

com_addref -- Increases the components reference counter.

Description

void com_addref ( void )

Increases the components reference counter.

이전 | 처음으로 | 다음
VARIANT | 위로 | com_get


com_get

(PHP 3>= 3.0.3, PHP 4 >= 4.0.5)

com_get -- Gets the value of a COM Component's property

Description

mixed com_get ( resource com_object, string property)

Returns the value of the property of the COM component referenced by com_object. Returns FALSE on error.

이전 | 처음으로 | 다음
com_addref | 위로 | com_invoke


com_invoke

(PHP 3>= 3.0.3)

com_invoke -- Calls a COM component's method.

Description

mixed com_invoke ( resource com_object, string function_name [, mixed function parameters, ...])

com_invoke() invokes a method of the COM component referenced by com_object. Returns FALSE on error, returns the function_name's return value on success.

이전 | 처음으로 | 다음
com_get | 위로 | com_isenum


com_isenum

(PHP 4 >= 4.1.0)

com_isenum -- Grabs an IEnumVariant

Description

void com_isenum ( object com_module)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
com_invoke | 위로 | com_load_typelib


com_load_typelib

(PHP 4 >= 4.1.0, PHP 5)

com_load_typelib -- Loads a Typelib

Description

void com_load_typelib ( string typelib_name [, int case_insensitive])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
com_isenum | 위로 | com_load


com_load

(PHP 3>= 3.0.3)

com_load -- Creates a new reference to a COM component

Description

string com_load ( string module_name [, string server_name [, int codepage]])

com_load() creates a new COM component and returns a reference to it. Returns FALSE on failure. Possible values for codepage are: CP_ACP, CP_MACCP, CP_OEMCP, CP_SYMBOL, CP_THREAD_ACP, CP_UTF7, and CP_UTF8.

이전 | 처음으로 | 다음
com_load_typelib | 위로 | com_propget


com_propget

com_propget -- Alias of com_get()

Description

This function is an alias for com_get().

이전 | 처음으로 | 다음
com_load | 위로 | com_propput


com_propput

com_propput -- Alias of com_set()

Description

This function is an alias for com_set().

이전 | 처음으로 | 다음
com_propget | 위로 | com_propset


com_propset

com_propset -- Alias of com_set()

Description

This function is an alias for com_set().

이전 | 처음으로 | 다음
com_propput | 위로 | com_release


com_release

(PHP 4 >= 4.1.0)

com_release -- Decreases the components reference counter.

Description

void com_release ( void )

Decreases the components reference counter.

이전 | 처음으로 | 다음
com_propset | 위로 | com_set


com_set

(PHP 3>= 3.0.3, PHP 4 >= 4.0.5)

com_set -- Assigns a value to a COM component's property

Description

void com_set ( resource com_object, string property, mixed value)

Sets the value of the property of the COM component referenced by com_object. Returns the newly set value if succeeded, FALSE on error.

이전 | 처음으로 | 다음
com_release | 위로 | 클래스/객체 함수


클래스/객체 함수

PHP 매뉴얼
이전 다음

IX. 클래스/객체 함수

소개

이 함수들은 클래스와 객체에 대한 정보를 얻을수 있게 해준다. 특정 객체가 속한 클래스명은 물론 그 객체의 멤버 속성과 메소드를 찾을수 있다. 이 함수들을 사용함으로써, 특정 객체의 클래스 멤버들 뿐만 아니라, 그 객체의 혈통(즉, 그 객체 클래스가 상속하는 클래스) 도 알아낼수 있다.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

예제

다음 예제코드를 보면, 먼저 기본 클래스를 선언하고, 그 클래스를 상속받는 클래스를 선언한다. 기본 클래스는 일반적인 야채에 대한 클래스로, 야채가 먹을수 있는지 아닌지 그리고 그 야채의 색깔이 무엇인지를 정의한다. 하위클래스 Spinach 는 그 야채를 요리하는 메소드와 요리되었는지 알아낼수 있는 메소드를 추가한다.

예 1. classes.inc

<?php

// 멤버 속성과 메소드를 갖는 기본 클래스
class Vegetable {

    var $edible;
    var $color;

    function Vegetable( $edible, $color="green" ) {
        $this->edible = $edible;
        $this->color = $color;
    }

    function is_edible() {
        return $this->edible;
    }

    function what_color() {
        return $this->color;
    }

} // end of class Vegetable

// 기본 클래스를 확장
class Spinach extends Vegetable {

    var $cooked = false;

    function Spinach() {
        $this->Vegetable( true, "green" );
    }

    function cook_it() {
        $this->cooked = true;
    }

    function is_cooked() {
        return $this->cooked;
    }

} // end of class Spinach

?>

이 클래스들로부터 2개의 객체를 생성하고, 그 클래스들의 혈통을 포함한 클래스들의 정보를 출력한다. 또한 변수의 깔끔한 출력을 위한 몇개의 유용한 함수들도 선언한다.

예 2. test_script.php

<pre>
<?php

include "classes.inc";

// 유용한 함수들

function print_vars($obj) {
    $arr = get_object_vars($obj);
    while (list($prop, $val) = each($arr))
        echo "\t$prop = $val\n";
}

function print_methods($obj) {
    $arr = get_class_methods(get_class($obj));
    foreach ($arr as $method)
        echo "\tfunction $method()\n";
}

function class_parentage($obj, $class) {
    global $$obj;
    if (is_subclass_of($$obj, $class)) {
        echo "Object $obj belongs to class ".get_class($$obj);
        echo " a subclass of $class\n";
    } else {
        echo "Object $obj does not belong to a subclass of $class\n";
    }
}

// 2개의 객체 생성

$veggie = new Vegetable(true,"blue");
$leafy = new Spinach();

// 객체 정보를 출력
echo "veggie: CLASS ".get_class($veggie)."\n";
echo "leafy: CLASS ".get_class($leafy);
echo ", PARENT ".get_parent_class($leafy)."\n";

// veggie 속성을 보임
echo "\nveggie: Properties\n";
print_vars($veggie);

// leafy 메소드를 보임
echo "\nleafy: Methods\n";
print_methods($leafy);

echo "\nParentage:\n";
class_parentage("leafy", "Spinach");
class_parentage("leafy", "Vegetable");
?>
</pre>

위 예제코드에서 가장 유의 해야 할 사항은 객체 $leafy 가 클래스 Spinach 의 인스턴스이고, 이 클래스는 Vegetable 의 하위 클래스라는 것이다. 따라서 위 스크립트의 제일 아래 부분에서는 다음과 같이 출력될것이다:

[...]
Parentage:
Object leafy does not belong to a subclass of Spinach
Object leafy belongs to class spinach a subclass of Vegetable

차례
call_user_method_array -- 배열 매개변수와 함께 사용자 메소드를 호출한다 [낡았음]
call_user_method -- 특정 객체의 사용자 메소드를 호출한다 [낡았음]
class_exists -- 클래스가 선언되었는지 검사한다
get_class_methods -- 클래스의 메소드명에 대한 배열을 반환한다
get_class_vars -- 클래스의 기본 속성에 대한 배열을 반환한다
get_class -- 객체의 클래스명을 반환한다
get_declared_classes -- 선언된 클래스명을 배열로 반환한다
get_declared_interfaces -- Returns an array of all declared interfaces.
get_object_vars -- 객체 속성의 연관 배열을 반환한다
get_parent_class -- 객체나 클래스의 부모 클래스명을 가져온다
is_a -- 객체가 이 클래스에 속해있거나 부모 클래스의 하나가 이 클래스이면, TRUE를 반환한다
is_subclass_of -- 객체가 이 클래스를 부모 클래스로 갖는다면 TRUE를 반환한다
method_exists -- 클래스 메소드가 존재하는지 검사한다

이전 | 처음으로 | 다음
com_set | 위로 | call_user_method_array


call_user_method_array

(PHP 4 >= 4.0.5, PHP 5)

call_user_method_array -- 배열 매개변수와 함께 사용자 메소드를 호출한다 [낡았음]

설명

mixed call_user_method_array ( string method_name, object obj [, array paramarr])

주의

이 call_user_method_array() 함수는 PHP 4.1.0 부터 낡은 함수가 되었다. 대신 array(&$obj, "method_name") 문법을 갖는 call_user_func_array() 변종(variety)을 사용하도록 한다.

paramarr 매개변수를 사용하여, 사용자 선언된 obj 객체에서 method_name으로 참조되는 메소드를 호출한다.

call_user_func_array(),
call_user_func(),
call_user_method() 참고.

참고: 이 함수는 PHP 4.0.4pl1 릴리즈 이후의 CVS 코드에 추가되었다.

이전 | 처음으로 | 다음
클래스/객체 함수 | 위로 | call_user_method


call_user_method

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

call_user_method -- 특정 객체의 사용자 메소드를 호출한다 [낡았음]

설명

mixed call_user_method ( string method_name, object obj [, mixed parameter [, mixed ...]])

주의

이 call_user_method() 함수는 PHP 4.1.0 부터 낡은 함수가 되었다. 대신 array(&$obj, "method_name") 문법을 갖는 call_user_func_array() 변종(variety)을 사용하도록 한다.

사용자 선언된 obj 객체에서 method_name으로 참조되는 메소드를 호출한다. 아래 예제코드를 보면, 클래스를 선언하고 객체를 생성하고 print_info 메소드를 간접적으로 호출하기 위해 call_user_method() 함수를 사용하는 것을 볼수 있다.

<?php
class Country {
    var $NAME;
    var $TLD;

    function Country($name, $tld) {
        $this->NAME = $name;
        $this->TLD = $tld;
    }

    function print_info($prestr="") {
        echo $prestr."Country: ".$this->NAME."\n";
        echo $prestr."Top Level Domain: ".$this->TLD."\n";
    }
}

$cntry = new Country("Peru","pe");

echo "* Calling the object method directly\n";
$cntry->print_info();

echo "\n* Calling the same method indirectly\n";
call_user_method ("print_info", $cntry, "\t");
?>

call_user_func_array(),
call_user_func(),
call_user_method_array() 참고.

이전 | 처음으로 | 다음
call_user_method_array | 위로 | class_exists


class_exists

(PHP 4 , PHP 5)

class_exists -- 클래스가 선언되었는지 검사한다

설명

bool class_exists ( string class_name)

이 함수는 class_name 이라는 클래스가 선언되어있으면, TRUE를 반환하고, 그렇지 않으면 FALSE를 반환한다.

get_declared_classes() 참고.

이전 | 처음으로 | 다음
call_user_method | 위로 | get_class_methods


get_class_methods

(PHP 4 , PHP 5)

get_class_methods -- 클래스의 메소드명에 대한 배열을 반환한다

설명

array get_class_methods ( mixed class_name)

이 함수는 class_name의 클래스에서 선언된 메소드명의 배열을 반환한다.

참고: PHP 4.0.6 부터 class_name 대신 객체 자신을 설정할수 있다. 예를 들면:

<?php
$class_methods = get_class_methods($my_class); // see below the full example
?>

예 1. get_class_methods() 예제코드

<?php

class myclass {
    // constructor
    function myclass() {
        return(TRUE);
    }

    // method 1
    function myfunc1() {
        return(TRUE);
    }

    // method 2
    function myfunc2() {
        return(TRUE);
    }
}

$my_object = new myclass();

$class_methods = get_class_methods(get_class($my_object));

foreach ($class_methods as $method_name) {
    echo "$method_name\n";
}

?>

Will produce:

myclass
myfunc1
myfunc2

get_class_vars(), get_object_vars() 참고.

이전 | 처음으로 | 다음
class_exists | 위로 | get_class_vars


get_class_vars

(PHP 4 , PHP 5)

get_class_vars -- 클래스의 기본 속성에 대한 배열을 반환한다

설명

array get_class_vars ( string class_name)

이 함수는 클래스의 기본 속성에 대한 연관 배열을 반환할것이다. 결과 배열 원소들은 varname => value 형태가 된다.

참고: PHP 4.2.0 이전 버전에서는, 초기화되지 않은 클래스 변수들은 get_class_vars()에 의해 보고되지 않을것이다.

예 1. get_class_vars() 예제코드

<?php

class myclass {

    var $var1; // this has no default value...
    var $var2 = "xyz";
    var $var3 = 100;

    // constructor
    function myclass() {
        return(TRUE);
    }

}

$my_class = new myclass();

$class_vars = get_class_vars(get_class($my_class));

foreach ($class_vars as $name => $value) {
    echo "$name : $value\n";
}

?>

다음을 생성할것이다:

// Before PHP 4.2.0
var2 : xyz
var3 : 100

// As of PHP 4.2.0
var1 :
var2 : xyz
var3 : 100

get_class_methods(), get_object_vars() 참고

이전 | 처음으로 | 다음
get_class_methods | 위로 | get_class


get_class

(PHP 4 , PHP 5)

get_class -- 객체의 클래스명을 반환한다

설명

string get_class ( object obj)

이 함수는 생성된 객체 obj의 클래스명을 반환한다. obj이 객체가 아니면, FALSE 를 반환한다.

참고: get_class()는 사용자 선언된 클래스명을 소문자로 반환한다. PHP 확장에서 선언된 클래스는 선언명 그대로를 반환한다.

예 1. get_class() 사용예

<?php

class foo {
    function foo() {
    // 일부 로직을 구현
    }

    function name() {
        echo "My name is " , get_class($this) , "\n";
    }
}

// 객체를 생성
$bar = new foo();

// 외부 호출
echo "Its name is " , get_class($bar) , "\n";

// 내부 호출
$bar->name();

?>

출력은 다음과 같다:

Its name is foo
My name is foo

get_parent_class(),
gettype(),
is_subclass_of() 참고.

이전 | 처음으로 | 다음
get_class_vars | 위로 | get_declared_classes


get_declared_classes

(PHP 4 , PHP 5)

get_declared_classes -- 선언된 클래스명을 배열로 반환한다

설명

array get_declared_classes ( void )

이 함수는 현재 스크립트에서 선언된 클래스명을 배열로 반환한다.

참고: PHP 4.0.1pl2에서는 배열의 첫부분에 세개의 클래스들이 들어가 있다: stdClass (Zend/zend.c에 정의되어있는 클래스), OverloadedTestClass (ext/standard/basic_functions.c에 정의되어있는 클래스), Directory (ext/standard/dir.c에 정의되어있는 클래스)

추가적인 클래스가 존재할수 있는 라이브러리가 PHP 로 컴파일 될수 있다는것에 주의해야 한다. 이말의 의미는 그 이름을 사용하는 사용자 선언 클래스를 선언할수 없다는 것이다. 부록의 기선언된 클래스 섹션에서 미리선언된 클래스명 이 있다.

class_exists() 참고.

이전 | 처음으로 | 다음
get_class | 위로 | get_declared_interfaces


get_declared_interfaces

(PHP 5)

get_declared_interfaces -- Returns an array of all declared interfaces.

Description

array get_declared_interfaces ( void )

This function returns an array of the names of the declared interfaces in the current script.

예 1. get_declared_interfaces() example

<?php
print_r(get_declared_interfaces());
?>

The above example will output something similar to: :

Array
(
    [0] => Traversable
    [1] => IteratorAggregate
    [2] => Iterator
    [3] => ArrayAccess
    [4] => reflector
    [5] => RecursiveIterator
    [6] => SeekableIterator
)

이전 | 처음으로 | 다음
get_declared_classes | 위로 | get_object_vars


get_object_vars

(PHP 4 , PHP 5)

get_object_vars -- 객체 속성의 연관 배열을 반환한다

설명

array get_object_vars ( object obj)

이 함수는 주어진 객체 obj 에서 선언된 객체 속성의 연관 배열을 반환한다.

참고: PHP 4.2.0 이전버전에서는, obj를 초기화시킨 클래스에서 선언된 변수가 어떤 값으로도 설정되어있지 않으면, 그 변수들은 배열로 반환되지 않을것이다. PHP 4.2.0 이후버전부터 그런 키는 NULL 값으로 설정된다.

예 1. get_object_vars() 사용예

<?php
class Point2D {
    var $x, $y;
    var $label;

    function Point2D($x, $y) {
        $this->x = $x;
        $this->y = $y;
    }

    function setLabel($label) {
        $this->label = $label;
    }

    function getPoint() {
        return array("x" => $this->x,
                     "y" => $this->y,
                     "label" => $this->label);
    }
}

// "$label" is declared but not defined
$p1 = new Point2D(1.233, 3.445);
print_r(get_object_vars($p1));

$p1->setLabel("point #1");
print_r(get_object_vars($p1));

?>

위 프로그램의 출력은 다음과 같을것이다:

Array
 (
     [x] => 1.233
     [y] => 3.445
     [label] =>
 )

 Array
 (
     [x] => 1.233
     [y] => 3.445
     [label] => point #1
 )

get_class_methods(), get_class_vars() 참고!

이전 | 처음으로 | 다음
get_declared_interfaces | 위로 | get_parent_class


get_parent_class

(PHP 4 , PHP 5)

get_parent_class -- 객체나 클래스의 부모 클래스명을 가져온다

설명

string get_parent_class ( mixed obj)

obj가 객체이면, obj를 초기화시킨 클래스의 부모 클래스명을 반환한다.

obj가 문자열이면, 그 이름을 갖는 클래스의 부모 클래스명을 반환한다. 이 기능은 PHP 4.0.5에서 추가되었다.

예 1. get_parent_class() 사용예

<?php

class dad {
    function dad() {
    // implements some logic
    }
}

class child extends dad {
    function child() {
        echo "I'm " , get_parent_class($this) , "'s son\n";
    }
}

class child2 extends dad {
    function child2() {
        echo "I'm " , get_parent_class('child2') , "'s son too\n";
    }
}

$foo = new child();
$bar = new child2();

?>

출력은 다음과 같다:

I'm dad's son
I'm dad's son too

get_class(), is_subclass_of() 참고.

이전 | 처음으로 | 다음
get_object_vars | 위로 | is_a


is_a

(PHP 4 >= 4.2.0, PHP 5)

is_a -- 객체가 이 클래스에 속해있거나 부모 클래스의 하나가 이 클래스이면, TRUE를 반환한다

설명

bool is_a ( object object, string class_name)

이 함수는 특정 객체가 이 클래스에 속해있거나 부모 클래스의 하나가 이 클래스이면, TRUE를 반환하고, 그렇지 않으면, FALSE를 반환한다.

get_class(),
get_parent_class(),
is_subclass_of() 참고.

이전 | 처음으로 | 다음
get_parent_class | 위로 | is_subclass_of


is_subclass_of

(PHP 4 , PHP 5)

is_subclass_of -- 객체가 이 클래스를 부모 클래스로 갖는다면 TRUE를 반환한다

설명

bool is_subclass_of ( object object, string class_name)

객체 object가 class_name의 하위클래스에 속하면 TRUE를 반환하고, 그렇지 않으면, FALSE를 반환한다.

get_class(),
get_parent_class(),
is_a() 참고.

이전 | 처음으로 | 다음
is_a | 위로 | method_exists


method_exists

(PHP 4 , PHP 5)

method_exists -- 클래스 메소드가 존재하는지 검사한다

설명

bool method_exists ( object object, string method_name)

이 함수는 method_name에 의해 주어진 메소드가 주어진 object에 대해서 선언되어있으면, TRUE를 반환하고, 그렇지 않으면 FALSE를 반환한다.

이전 | 처음으로 | 다음
is_subclass_of | 위로 | ClibPDF Functions


ClibPDF Functions

PHP 매뉴얼
이전 다음

X. ClibPDF Functions

소개

ClibPDF lets you create PDF documents with PHP. ClibPDF functionality and API are similar to PDFlib. This documentation should be read alongside the ClibPDF manual since it explains the library in much greater detail.

Many functions in the native ClibPDF and the PHP module, as well as in PDFlib, have the same name. All functions except for cpdf_open() take the handle for the document as their first parameter.

Currently this handle is not used internally since ClibPDF does not support the creation of several PDF documents at the same time. Actually, you should not even try it, the results are unpredictable. I can't oversee what the consequences in a multi threaded environment are. According to the author of ClibPDF this will change in one of the next releases (current version when this was written is 1.10). If you need this functionality use the pdflib module.

A nice feature of ClibPDF (and PDFlib) is the ability to create the pdf document completely in memory without using temporary files. It also provides the ability to pass coordinates in a predefined unit length. (This feature can also be simulated by pdf_translate() when using the PDFlib functions.)

Another nice feature of ClibPDF is the fact that any page can be modified at any time even if a new page has been already opened. The function cpdf_set_current_page() allows to leave the current page and presume modifying an other page.

Most of the functions are fairly easy to use. The most difficult part is probably creating a very simple PDF document at all. The following example should help you to get started. It creates a document with one page. The page contains the text "Times-Roman" in an outlined 30pt font. The text is underlined.

참고: If you're interested in alternative free PDF generators that do not utilize external PDF libraries, see this related FAQ.

요구 사항

In order to use the ClibPDF functions you need to install the ClibPDF package. It is available for download from FastIO, but requires that you purchase a license for commercial use. PHP requires that you use cpdflib >= 2.

설치

To get these functions to work, you have to compile PHP with --with-cpdflib[=DIR]. DIR is the cpdflib install directory, defaults to /usr. In addition you can specify the jpeg library and the tiff library for ClibPDF to use. To do so add to your configure line the options --with-jpeg-dir[=DIR] --with-tiff-dir[=DIR].

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

CPDF_PM_NONE (integer)

CPDF_PM_OUTLINES (integer)

CPDF_PM_THUMBS (integer)

CPDF_PM_FULLSCREEN (integer)

CPDF_PL_SINGLE (integer)

CPDF_PL_1COLUMN (integer)

CPDF_PL_2LCOLUMN (integer)

CPDF_PL_2RCOLUMN (integer)

예제

예 1. Simple ClibPDF Example

<?php
$cpdf = cpdf_open(0);
cpdf_page_init($cpdf, 1, 0, 595, 842, 1.0);
cpdf_add_outline($cpdf, 0, 0, 0, 1, "Page 1");
cpdf_begin_text($cpdf);
cpdf_set_font($cpdf, "Times-Roman", 30, "WinAnsiEncoding");
cpdf_set_text_rendering($cpdf, 1);
cpdf_text($cpdf, "Times Roman outlined", 50, 750);
cpdf_end_text($cpdf);
cpdf_moveto($cpdf, 50, 740);
cpdf_lineto($cpdf, 330, 740);
cpdf_stroke($cpdf);
cpdf_finalize($cpdf);
Header("Content-type: application/pdf");
cpdf_output_buffer($cpdf);
cpdf_close($cpdf);
?>

The pdflib distribution contains a more complex example which creates a series of pages with an analog clock. Here is that example converted into PHP using the ClibPDF extension:

예 2. pdfclock example from pdflib 2.0 distribution

<?php
$radius = 200;
$margin = 20;
$pagecount = 40;

$pdf = cpdf_open(0);
cpdf_set_creator($pdf, "pdf_clock.php");
cpdf_set_title($pdf, "Analog Clock");

while ($pagecount-- > 0) {
  cpdf_page_init($pdf, $pagecount+1, 0, 2 * ($radius + $margin), 2 * ($radius + $margin), 1.0);

  cpdf_set_page_animation($pdf, 4, 0.5, 0, 0, 0);  /* wipe */

  cpdf_translate($pdf, $radius + $margin, $radius + $margin);
  cpdf_save($pdf);
  cpdf_setrgbcolor($pdf, 0.0, 0.0, 1.0);

  /* minute strokes */
  cpdf_setlinewidth($pdf, 2.0);
  for ($alpha = 0; $alpha < 360; $alpha += 6) {
    cpdf_rotate($pdf, 6.0);
    cpdf_moveto($pdf, $radius, 0.0);
    cpdf_lineto($pdf, $radius-$margin/3, 0.0);
    cpdf_stroke($pdf);
  }

  cpdf_restore($pdf);
  cpdf_save($pdf);

  /* 5 minute strokes */
  cpdf_setlinewidth($pdf, 3.0);
  for ($alpha = 0; $alpha < 360; $alpha += 30) {
    cpdf_rotate($pdf, 30.0);
    cpdf_moveto($pdf, $radius, 0.0);
    cpdf_lineto($pdf, $radius-$margin, 0.0);
    cpdf_stroke($pdf);
  }

  $ltime = getdate();

  /* draw hour hand */
  cpdf_save($pdf);
  cpdf_rotate($pdf, -(($ltime['minutes']/60.0) + $ltime['hours'] - 3.0) * 30.0);
  cpdf_moveto($pdf, -$radius/10, -$radius/20);
  cpdf_lineto($pdf, $radius/2, 0.0);
  cpdf_lineto($pdf, -$radius/10, $radius/20);
  cpdf_closepath($pdf);
  cpdf_fill($pdf);
  cpdf_restore($pdf);

  /* draw minute hand */
  cpdf_save($pdf);
  cpdf_rotate($pdf, -(($ltime['seconds']/60.0) + $ltime['minutes'] - 15.0) * 6.0);
  cpdf_moveto($pdf, -$radius/10, -$radius/20);
  cpdf_lineto($pdf, $radius * 0.8, 0.0);
  cpdf_lineto($pdf, -$radius/10, $radius/20);
  cpdf_closepath($pdf);
  cpdf_fill($pdf);
  cpdf_restore($pdf);

  /* draw second hand */
  cpdf_setrgbcolor($pdf, 1.0, 0.0, 0.0);
  cpdf_setlinewidth($pdf, 2);
  cpdf_save($pdf);
  cpdf_rotate($pdf, -(($ltime['seconds'] - 15.0) * 6.0));
  cpdf_moveto($pdf, -$radius/5, 0.0);
  cpdf_lineto($pdf, $radius, 0.0);
  cpdf_stroke($pdf);
  cpdf_restore($pdf);

  /* draw little circle at center */
  cpdf_circle($pdf, 0, 0, $radius/30);
  cpdf_fill($pdf);

  cpdf_restore($pdf);

  cpdf_finalize_page($pdf, $pagecount+1);
}

cpdf_finalize($pdf);
Header("Content-type: application/pdf");
cpdf_output_buffer($pdf);
cpdf_close($pdf);
?>

참고

See also the PDFlib extension documentation.

차례
cpdf_add_annotation -- Adds annotation
cpdf_add_outline -- Adds bookmark for current page
cpdf_arc -- Draws an arc
cpdf_begin_text -- Starts text section
cpdf_circle -- Draw a circle
cpdf_clip -- Clips to current path
cpdf_close -- Closes the pdf document
cpdf_closepath_fill_stroke -- Close, fill and stroke current path
cpdf_closepath_stroke -- Close path and draw line along path
cpdf_closepath -- Close path
cpdf_continue_text -- Output text in next line
cpdf_curveto -- Draws a curve
cpdf_end_text -- Ends text section
cpdf_fill_stroke -- Fill and stroke current path
cpdf_fill -- Fill current path
cpdf_finalize_page -- Ends page
cpdf_finalize -- Ends document
cpdf_global_set_document_limits -- Sets document limits for any pdf document
cpdf_import_jpeg -- Opens a JPEG image
cpdf_lineto -- Draws a line
cpdf_moveto -- Sets current point
cpdf_newpath -- Starts a new path
cpdf_open -- Opens a new pdf document
cpdf_output_buffer -- Outputs the pdf document in memory buffer
cpdf_page_init -- Starts new page
cpdf_place_inline_image -- Places an image on the page
cpdf_rect -- Draw a rectangle
cpdf_restore -- Restores formerly saved environment
cpdf_rlineto -- Draws a line
cpdf_rmoveto -- Sets current point
cpdf_rotate_text -- Sets text rotation angle
cpdf_rotate -- Sets rotation
cpdf_save_to_file -- Writes the pdf document into a file
cpdf_save -- Saves current environment
cpdf_scale -- Sets scaling
cpdf_set_action_url -- Sets hyperlink
cpdf_set_char_spacing -- Sets character spacing
cpdf_set_creator -- Sets the creator field in the pdf document
cpdf_set_current_page -- Sets current page
cpdf_set_font_directories -- Sets directories to search when using external fonts
cpdf_set_font_map_file -- Sets fontname to filename translation map when using external fonts
cpdf_set_font -- Select the current font face and size
cpdf_set_horiz_scaling -- Sets horizontal scaling of text
cpdf_set_keywords -- Sets the keywords field of the pdf document
cpdf_set_leading -- Sets distance between text lines
cpdf_set_page_animation -- Sets duration between pages
cpdf_set_subject -- Sets the subject field of the pdf document
cpdf_set_text_matrix -- Sets the text matrix
cpdf_set_text_pos -- Sets text position
cpdf_set_text_rendering -- Determines how text is rendered
cpdf_set_text_rise -- Sets the text rise
cpdf_set_title -- Sets the title field of the pdf document
cpdf_set_viewer_preferences -- How to show the document in the viewer
cpdf_set_word_spacing -- Sets spacing between words
cpdf_setdash -- Sets dash pattern
cpdf_setflat -- Sets flatness
cpdf_setgray_fill -- Sets filling color to gray value
cpdf_setgray_stroke -- Sets drawing color to gray value
cpdf_setgray -- Sets drawing and filling color to gray value
cpdf_setlinecap -- Sets linecap parameter
cpdf_setlinejoin -- Sets linejoin parameter
cpdf_setlinewidth -- Sets line width
cpdf_setmiterlimit -- Sets miter limit
cpdf_setrgbcolor_fill -- Sets filling color to rgb color value
cpdf_setrgbcolor_stroke -- Sets drawing color to rgb color value
cpdf_setrgbcolor -- Sets drawing and filling color to rgb color value
cpdf_show_xy -- Output text at position
cpdf_show -- Output text at current position
cpdf_stringwidth -- Returns width of text in current font
cpdf_stroke -- Draw line along path
cpdf_text -- Output text with parameters
cpdf_translate -- Sets origin of coordinate system

이전 | 처음으로 | 다음
method_exists | 위로 | cpdf_add_annotation


cpdf_add_annotation

(PHP 3>= 3.0.12, PHP 4 , PHP 5)

cpdf_add_annotation -- Adds annotation

Description

bool cpdf_add_annotation ( int pdf_document, float llx, float lly, float urx, float ury, string title, string content [, int mode])

The cpdf_add_annotation() adds a note with the lower left corner at (llx, lly) and the upper right corner at (urx, ury). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

선택 인자 mode는 유니트 길이를 결정합니다. 0이나 없을 경우에는 페이지를 위한 특정값을 기본 유니트로 사용합니다. 그렇지 않으면 현재 유니트를 무시하고 포스트스크립트 상에서 좌표를 측정합니다.

이전 | 처음으로 | 다음
ClibPDF Functions | 위로 | cpdf_add_outline


cpdf_add_outline

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

cpdf_add_outline -- Adds bookmark for current page

Description

int cpdf_add_outline ( int pdf_document, int lastoutline, int sublevel, int open, int pagenr, string text)

The cpdf_add_outline() function adds a bookmark with text text that points to the current page.

예 1. Adding a page outline

<?php
$cpdf = cpdf_open(0);
cpdf_page_init($cpdf, 1, 0, 595, 842);
cpdf_add_outline($cpdf, 0, 0, 0, 1, "Page 1");
// ...
// some drawing
// ...
cpdf_finalize($cpdf);
Header("Content-type: application/pdf");
cpdf_output_buffer($cpdf);
cpdf_close($cpdf);
?>

이전 | 처음으로 | 다음
cpdf_add_annotation | 위로 | cpdf_arc


cpdf_arc

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_arc -- Draws an arc

Description

bool cpdf_arc ( int pdf_document, float x-coor, float y-coor, float radius, float start, float end [, int mode])

The cpdf_arc() function draws an arc with center at point (x-coor, y-coor) and radius radius, starting at angle start and ending at angle end. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

선택 인자 mode는 유니트 길이를 결정합니다. 0이나 없을 경우에는 페이지를 위한 특정값을 기본 유니트로 사용합니다. 그렇지 않으면 현재 유니트를 무시하고 포스트스크립트 상에서 좌표를 측정합니다.

See also cpdf_circle().

이전 | 처음으로 | 다음
cpdf_add_outline | 위로 | cpdf_begin_text


cpdf_begin_text

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_begin_text -- Starts text section

Description

bool cpdf_begin_text ( int pdf_document)

The cpdf_begin_text() function starts a text section. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. The created text section must be ended with cpdf_end_text().

예 1. Text output

<?php
cpdf_begin_text($pdf);
cpdf_set_font($pdf, 16, "Helvetica", "WinAnsiEncoding");
cpdf_text($pdf, 100, 100, "Some text");
cpdf_end_text($pdf)
?>

See also cpdf_end_text().

이전 | 처음으로 | 다음
cpdf_arc | 위로 | cpdf_circle


cpdf_circle

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_circle -- Draw a circle

Description

bool cpdf_circle ( int pdf_document, float x-coor, float y-coor, float radius [, int mode])

The cpdf_circle() function draws a circle with center at point (x-coor, y-coor) and radius radius. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

선택 인자 mode는 유니트 길이를 결정합니다. 0이나 없을 경우에는 페이지를 위한 특정값을 기본 유니트로 사용합니다. 그렇지 않으면 현재 유니트를 무시하고 포스트스크립트 상에서 좌표를 측정합니다.

See also cpdf_arc().

이전 | 처음으로 | 다음
cpdf_begin_text | 위로 | cpdf_clip


cpdf_clip

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_clip -- Clips to current path

Description

bool cpdf_clip ( int pdf_document)

The cpdf_clip() function clips all drawing to the current path. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
cpdf_circle | 위로 | cpdf_close


cpdf_close

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_close -- Closes the pdf document

Description

bool cpdf_close ( int pdf_document)

The cpdf_close() function closes the pdf document. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. This should be the last function even after cpdf_finalize(), cpdf_output_buffer() and cpdf_save_to_file().

See also cpdf_open().

이전 | 처음으로 | 다음
cpdf_clip | 위로 | cpdf_closepath_fill_stroke


cpdf_closepath_fill_stroke

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_closepath_fill_stroke -- Close, fill and stroke current path

Description

bool cpdf_closepath_fill_stroke ( int pdf_document)

The cpdf_closepath_fill_stroke() function closes, fills the interior of the current path with the current fill color and draws current path. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_closepath(),
cpdf_stroke(),
cpdf_fill(),
cpdf_setgray_fill(),
cpdf_setgray(),
cpdf_setrgbcolor_fill() and
cpdf_setrgbcolor().

이전 | 처음으로 | 다음
cpdf_close | 위로 | cpdf_closepath_stroke


cpdf_closepath_stroke

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_closepath_stroke -- Close path and draw line along path

Description

bool cpdf_closepath_stroke ( int pdf_document)

The cpdf_closepath_stroke() function is a
combination of cpdf_closepath() and
cpdf_stroke(). Then clears the path.
성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_closepath() and cpdf_stroke().

이전 | 처음으로 | 다음
cpdf_closepath_fill_stroke | 위로 | cpdf_closepath


cpdf_closepath

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_closepath -- Close path

Description

bool cpdf_closepath ( int pdf_document)

The cpdf_closepath() function closes the current path. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
cpdf_closepath_stroke | 위로 | cpdf_continue_text


cpdf_continue_text

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_continue_text -- Output text in next line

Description

bool cpdf_continue_text ( int pdf_document, string text)

The cpdf_continue_text() function outputs the string in text in the next line. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_show_xy(),
cpdf_text(),
cpdf_set_leading() and
cpdf_set_text_pos().

이전 | 처음으로 | 다음
cpdf_closepath | 위로 | cpdf_curveto


cpdf_curveto

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_curveto -- Draws a curve

Description

bool cpdf_curveto ( int pdf_document, float x1, float y1, float x2, float y2, float x3, float y3 [, int mode])

The cpdf_curveto() function draws a Bezier curve from the current point to the point (x3, y3) using (x1, y1) and (x2, y2) as control points. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

선택 인자 mode는 유니트 길이를 결정합니다. 0이나 없을 경우에는 페이지를 위한 특정값을 기본 유니트로 사용합니다. 그렇지 않으면 현재 유니트를 무시하고 포스트스크립트 상에서 좌표를 측정합니다.

See also cpdf_moveto(),
cpdf_rmoveto(),
cpdf_rlineto() and
cpdf_lineto().

이전 | 처음으로 | 다음
cpdf_continue_text | 위로 | cpdf_end_text


cpdf_end_text

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_end_text -- Ends text section

Description

bool cpdf_end_text ( int pdf_document)

The cpdf_end_text() function ends a text section which was started with cpdf_begin_text(). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. Text output

<?php
cpdf_begin_text($pdf);
cpdf_set_font($pdf, 16, "Helvetica", "WinAnsiEncoding");
cpdf_text($pdf, 100, 100, "Some text");
cpdf_end_text($pdf)
?>

See also cpdf_begin_text().

이전 | 처음으로 | 다음
cpdf_curveto | 위로 | cpdf_fill_stroke


cpdf_fill_stroke

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_fill_stroke -- Fill and stroke current path

Description

bool cpdf_fill_stroke ( int pdf_document)

The cpdf_fill_stroke() function fills the interior of the current path with the current fill color and draws current path. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_closepath(),
cpdf_stroke(),
cpdf_fill(),
cpdf_setgray_fill(),
cpdf_setgray(),
cpdf_setrgbcolor_fill() and
cpdf_setrgbcolor().

이전 | 처음으로 | 다음
cpdf_end_text | 위로 | cpdf_fill


cpdf_fill

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_fill -- Fill current path

Description

bool cpdf_fill ( int pdf_document)

The cpdf_fill() function fills the interior of the current path with the current fill color. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_closepath(),
cpdf_stroke(),
cpdf_setgray_fill(),
cpdf_setgray(),
cpdf_setrgbcolor_fill() and
cpdf_setrgbcolor().

이전 | 처음으로 | 다음
cpdf_fill_stroke | 위로 | cpdf_finalize_page


cpdf_finalize_page

(PHP 3>= 3.0.10, PHP 4 , PHP 5)

cpdf_finalize_page -- Ends page

Description

bool cpdf_finalize_page ( int pdf_document, int page_number)

The cpdf_finalize_page() function ends the page with page number page_number. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

This function is only for saving memory. A finalized page takes less memory but cannot be modified anymore.

See also cpdf_page_init().

이전 | 처음으로 | 다음
cpdf_fill | 위로 | cpdf_finalize


cpdf_finalize

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_finalize -- Ends document

Description

bool cpdf_finalize ( int pdf_document)

The cpdf_finalize() function ends the document. You still have to call cpdf_close(). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_close().

이전 | 처음으로 | 다음
cpdf_finalize_page | 위로 | cpdf_global_set_document_limits


cpdf_global_set_document_limits

(PHP 4 , PHP 5)

cpdf_global_set_document_limits -- Sets document limits for any pdf document

Description

bool cpdf_global_set_document_limits ( int maxpages, int maxfonts, int maximages, int maxannotations, int maxobjects)

The cpdf_global_set_document_limits() function sets several document limits. This function has to be called before cpdf_open() to take effect. It sets the limits for any document open afterwards. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_open().

이전 | 처음으로 | 다음
cpdf_finalize | 위로 | cpdf_import_jpeg


cpdf_import_jpeg

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

cpdf_import_jpeg -- Opens a JPEG image

Description

int cpdf_import_jpeg ( int pdf_document, string file_name, float x-coor, float y-coor, float angle, float width, float height, float x-scale, float y-scale, int gsave [, int mode])

The cpdf_import_jpeg() function opens an image stored in the file with the name file_name. The format of the image has to be jpeg. The image is placed on the current page at position (x-coor, y-coor). The image is rotated by angle degrees. gsave should be non-zero to allow this function to operate correctly.

선택 인자 mode는 유니트 길이를 결정합니다. 0이나 없을 경우에는 페이지를 위한 특정값을 기본 유니트로 사용합니다. 그렇지 않으면 현재 유니트를 무시하고 포스트스크립트 상에서 좌표를 측정합니다.

See also cpdf_place_inline_image().

이전 | 처음으로 | 다음
cpdf_global_set_document_limits | 위로 | cpdf_lineto


cpdf_lineto

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_lineto -- Draws a line

Description

bool cpdf_lineto ( int pdf_document, float x-coor, float y-coor [, int mode])

The cpdf_lineto() function draws a line from the current point to the point with coordinates (x-coor, y-coor). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

선택 인자 mode는 유니트 길이를 결정합니다. 0이나 없을 경우에는 페이지를 위한 특정값을 기본 유니트로 사용합니다. 그렇지 않으면 현재 유니트를 무시하고 포스트스크립트 상에서 좌표를 측정합니다.

See also cpdf_moveto(),
cpdf_rmoveto() and
cpdf_curveto().

이전 | 처음으로 | 다음
cpdf_import_jpeg | 위로 | cpdf_moveto


cpdf_moveto

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_moveto -- Sets current point

Description

bool cpdf_moveto ( int pdf_document, float x-coor, float y-coor [, int mode])

The cpdf_moveto() function set the current point to the coordinates x-coor and y-coor. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

선택 인자 mode는 유니트 길이를 결정합니다. 0이나 없을 경우에는 페이지를 위한 특정값을 기본 유니트로 사용합니다. 그렇지 않으면 현재 유니트를 무시하고 포스트스크립트 상에서 좌표를 측정합니다.

이전 | 처음으로 | 다음
cpdf_lineto | 위로 | cpdf_newpath


cpdf_newpath

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

cpdf_newpath -- Starts a new path

Description

bool cpdf_newpath ( int pdf_document)

The cpdf_newpath() starts a new path on the document given by the pdf_document parameter. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
cpdf_moveto | 위로 | cpdf_open


cpdf_open

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_open -- Opens a new pdf document

Description

int cpdf_open ( int compression [, string filename])

The cpdf_open() function opens a new pdf document. The first parameter turns document compression on if it is unequal to 0. The second optional parameter sets the file in which the document is written. If it is omitted the document is created in memory and can either be written into a file with the cpdf_save_to_file() or written to standard output with cpdf_output_buffer().

참고: The return value will be needed in further versions of ClibPDF as the first parameter in all other functions which are writing to the pdf document.

The ClibPDF library takes the filename "-" as a synonym for stdout. If PHP is compiled as an apache module this will not work because the way ClibPDF outputs to stdout does not work with apache. You can solve this problem by skipping the filename and using cpdf_output_buffer() to output the pdf document.

See also cpdf_close() and cpdf_output_buffer().

이전 | 처음으로 | 다음
cpdf_newpath | 위로 | cpdf_output_buffer


cpdf_output_buffer

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

cpdf_output_buffer -- Outputs the pdf document in memory buffer

Description

bool cpdf_output_buffer ( int pdf_document)

The cpdf_output_buffer() function outputs the pdf document to stdout. The document has to be created in memory which is the case if cpdf_open() has been called with no filename parameter. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_open().

이전 | 처음으로 | 다음
cpdf_open | 위로 | cpdf_page_init


cpdf_page_init

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_page_init -- Starts new page

Description

bool cpdf_page_init ( int pdf_document, int page_number, int orientation, float height, float width [, float unit])

The cpdf_page_init() function starts a new page with height height and width width. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. The page has number page_number and orientation orientation. orientation can be 0 for portrait and 1 for landscape. The last optional parameter unit sets the unit for the coordinate system. The value should be the number of postscript points per unit. Since one inch is equal to 72 points, a value of 72 would set the unit to one inch. The default is also 72.

See also cpdf_set_current_page().

이전 | 처음으로 | 다음
cpdf_output_buffer | 위로 | cpdf_place_inline_image


cpdf_place_inline_image

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

cpdf_place_inline_image -- Places an image on the page

Description

bool cpdf_place_inline_image ( int pdf_document, int image, float x-coor, float y-coor, float angle, float width, float height [, int mode])

The cpdf_place_inline_image() function places an image created with the PHP image functions on the page at position (x-coor, y-coor). The image can be scaled at the same time. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

선택 인자 mode는 유니트 길이를 결정합니다. 0이나 없을 경우에는 페이지를 위한 특정값을 기본 유니트로 사용합니다. 그렇지 않으면 현재 유니트를 무시하고 포스트스크립트 상에서 좌표를 측정합니다.

See also cpdf_import_jpeg().

이전 | 처음으로 | 다음
cpdf_page_init | 위로 | cpdf_rect


cpdf_rect

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_rect -- Draw a rectangle

Description

bool cpdf_rect ( int pdf_document, float x-coor, float y-coor, float width, float height [, int mode])

The cpdf_rect() function draws a rectangle with its lower left corner at point (x-coor, y-coor). This width is set to width. This height is set to height. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

선택 인자 mode는 유니트 길이를 결정합니다. 0이나 없을 경우에는 페이지를 위한 특정값을 기본 유니트로 사용합니다. 그렇지 않으면 현재 유니트를 무시하고 포스트스크립트 상에서 좌표를 측정합니다.

예 1. Drawing a rectangle

<?php

$cpdf = cpdf_open(0);
cpdf_page_init($cpdf, 1, 0, 595, 842, 1.0);

// set the fill color to red
cpdf_setrgbcolor($cpdf, 1, 0, 0);

// draw a (180 * 100) rectangle
cpdf_rect($cpdf, 645, 400, 180, 100);

// fill the rectangle
cpdf_fill($cpdf);

cpdf_finalize($cpdf);
Header("Content-type: application/pdf");
cpdf_output_buffer($cpdf);
cpdf_close($cpdf);

?>

이전 | 처음으로 | 다음
cpdf_place_inline_image | 위로 | cpdf_restore


cpdf_restore

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_restore -- Restores formerly saved environment

Description

bool cpdf_restore ( int pdf_document)

The cpdf_restore() function restores the environment saved with cpdf_save(). It works like the postscript command grestore. Very useful if you want to translate or rotate an object without effecting other objects. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. Save/Restore

<?php
cpdf_save($pdf);
// do all kinds of rotations, transformations, ...
cpdf_restore($pdf)
?>

See also cpdf_save().

이전 | 처음으로 | 다음
cpdf_rect | 위로 | cpdf_rlineto


cpdf_rlineto

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

cpdf_rlineto -- Draws a line

Description

bool cpdf_rlineto ( int pdf_document, float x-coor, float y-coor [, int mode])

The cpdf_rlineto() function draws a line from the current point to the relative point with coordinates (x-coor, y-coor). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

선택 인자 mode는 유니트 길이를 결정합니다. 0이나 없을 경우에는 페이지를 위한 특정값을 기본 유니트로 사용합니다. 그렇지 않으면 현재 유니트를 무시하고 포스트스크립트 상에서 좌표를 측정합니다.

See also cpdf_moveto(),
cpdf_rmoveto() and
cpdf_curveto().

이전 | 처음으로 | 다음
cpdf_restore | 위로 | cpdf_rmoveto


cpdf_rmoveto

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

cpdf_rmoveto -- Sets current point

Description

bool cpdf_rmoveto ( int pdf_document, float x-coor, float y-coor [, int mode])

The cpdf_rmoveto() function set the current point relative to the coordinates x-coor and y-coor. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

선택 인자 mode는 유니트 길이를 결정합니다. 0이나 없을 경우에는 페이지를 위한 특정값을 기본 유니트로 사용합니다. 그렇지 않으면 현재 유니트를 무시하고 포스트스크립트 상에서 좌표를 측정합니다.

See also cpdf_moveto().

이전 | 처음으로 | 다음
cpdf_rlineto | 위로 | cpdf_rotate_text


cpdf_rotate_text

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

cpdf_rotate_text -- Sets text rotation angle

Description

bool cpdf_rotate_text ( int pdfdoc, float angle)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
cpdf_rmoveto | 위로 | cpdf_rotate


cpdf_rotate

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_rotate -- Sets rotation

Description

bool cpdf_rotate ( int pdf_document, float angle)

The cpdf_rotate() function set the rotation in degrees to angle. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
cpdf_rotate_text | 위로 | cpdf_save_to_file


cpdf_save_to_file

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_save_to_file -- Writes the pdf document into a file

Description

bool cpdf_save_to_file ( int pdf_document, string filename)

The cpdf_save_to_file() function outputs the pdf document into a file if it has been created in memory. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

This function is not needed if the pdf document has been open by specifying a filename as a parameter of cpdf_open().

See also cpdf_output_buffer() and cpdf_open().

이전 | 처음으로 | 다음
cpdf_rotate | 위로 | cpdf_save


cpdf_save

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_save -- Saves current environment

Description

bool cpdf_save ( int pdf_document)

The cpdf_save() function saves the current environment. It works like the postscript command gsave. Very useful if you want to translate or rotate an object without effecting other objects. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_restore().

이전 | 처음으로 | 다음
cpdf_save_to_file | 위로 | cpdf_scale


cpdf_scale

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_scale -- Sets scaling

Description

bool cpdf_scale ( int pdf_document, float x-scale, float y-scale)

The cpdf_scale() function set the scaling factor in both directions. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
cpdf_save | 위로 | cpdf_set_action_url


cpdf_set_action_url

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

cpdf_set_action_url -- Sets hyperlink

Description

bool cpdf_set_action_url ( int pdfdoc, float xll, float yll, float xur, float xur, string url [, int mode])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
cpdf_scale | 위로 | cpdf_set_char_spacing


cpdf_set_char_spacing

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_set_char_spacing -- Sets character spacing

Description

bool cpdf_set_char_spacing ( int pdf_document, float space)

The cpdf_set_char_spacing() function sets the spacing between characters. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_set_word_spacing() and cpdf_set_leading().

이전 | 처음으로 | 다음
cpdf_set_action_url | 위로 | cpdf_set_creator


cpdf_set_creator

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_set_creator -- Sets the creator field in the pdf document

Description

bool cpdf_set_creator ( int pdf_document, string creator)

The cpdf_set_creator() function sets the creator of a pdf document. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_set_subject(),
cpdf_set_title() and
cpdf_set_keywords().

이전 | 처음으로 | 다음
cpdf_set_char_spacing | 위로 | cpdf_set_current_page


cpdf_set_current_page

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

cpdf_set_current_page -- Sets current page

Description

bool cpdf_set_current_page ( int pdf_document, int page_number)

The cpdf_set_current_page() function set the page on which all operations are performed. One can switch between pages until a page is finished with cpdf_finalize_page(). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_finalize_page().

이전 | 처음으로 | 다음
cpdf_set_creator | 위로 | cpdf_set_font_directories


cpdf_set_font_directories

(PHP 4 >= 4.0.6, PHP 5)

cpdf_set_font_directories -- Sets directories to search when using external fonts

Description

bool cpdf_set_font_directories ( int pdfdoc, string pfmdir, string pfbdir)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
cpdf_set_current_page | 위로 | cpdf_set_font_map_file


cpdf_set_font_map_file

(PHP 4 >= 4.0.6, PHP 5)

cpdf_set_font_map_file -- Sets fontname to filename translation map when using external fonts

Description

bool cpdf_set_font_map_file ( int pdfdoc, string filename)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
cpdf_set_font_directories | 위로 | cpdf_set_font


cpdf_set_font

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_set_font -- Select the current font face and size

Description

bool cpdf_set_font ( int pdf_document, string font_name, float size, string encoding)

The cpdf_set_font() function sets the current font face, font size and encoding. Currently only the standard postscript fonts are supported. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

The last parameter encoding can take the following values: "MacRomanEncoding", "MacExpertEncoding", "WinAnsiEncoding", and "NULL". "NULL" stands for the font's built-in encoding.

See the ClibPDF Manual for more information, especially how to support Asian fonts.

이전 | 처음으로 | 다음
cpdf_set_font_map_file | 위로 | cpdf_set_horiz_scaling


cpdf_set_horiz_scaling

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_set_horiz_scaling -- Sets horizontal scaling of text

Description

bool cpdf_set_horiz_scaling ( int pdf_document, float scale)

The cpdf_set_horiz_scaling() function sets the horizontal scaling to scale percent. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
cpdf_set_font | 위로 | cpdf_set_keywords


cpdf_set_keywords

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_set_keywords -- Sets the keywords field of the pdf document

Description

bool cpdf_set_keywords ( int pdf_document, string keywords)

The cpdf_set_keywords() function sets the keywords of a pdf document. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_set_title(),
cpdf_set_creator() and
cpdf_set_subject().

이전 | 처음으로 | 다음
cpdf_set_horiz_scaling | 위로 | cpdf_set_leading


cpdf_set_leading

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_set_leading -- Sets distance between text lines

Description

bool cpdf_set_leading ( int pdf_document, float distance)

The cpdf_set_leading() function sets the distance between text lines. This will be used if text is output by cpdf_continue_text(). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_continue_text().

이전 | 처음으로 | 다음
cpdf_set_keywords | 위로 | cpdf_set_page_animation


cpdf_set_page_animation

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

cpdf_set_page_animation -- Sets duration between pages

Description

bool cpdf_set_page_animation ( int pdf_document, int transition, float duration)

The cpdf_set_page_animation() function set the transition between following pages. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

The value of transition can be

0 for none,
1 for two lines sweeping across the screen reveal the page,
2 for multiple lines sweeping across the screen reveal the page,
3 for a box reveals the page,
4 for a single line sweeping across the screen reveals the page,
5 for the old page dissolves to reveal the page,
6 for the dissolve effect moves from one screen edge to another,
7 for the old page is simply replaced by the new page (default)

The value of duration is the number of seconds between page flipping.

이전 | 처음으로 | 다음
cpdf_set_leading | 위로 | cpdf_set_subject


cpdf_set_subject

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_set_subject -- Sets the subject field of the pdf document

Description

bool cpdf_set_subject ( int pdf_document, string subject)

The cpdf_set_subject() function sets the subject of a pdf document. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_set_title(),
cpdf_set_creator() and
cpdf_set_keywords().

이전 | 처음으로 | 다음
cpdf_set_page_animation | 위로 | cpdf_set_text_matrix


cpdf_set_text_matrix

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_set_text_matrix -- Sets the text matrix

Description

bool cpdf_set_text_matrix ( int pdf_document, array matrix)

The cpdf_set_text_matrix() function sets a matrix which describes a transformation applied on the current text font. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
cpdf_set_subject | 위로 | cpdf_set_text_pos


cpdf_set_text_pos

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_set_text_pos -- Sets text position

Description

bool cpdf_set_text_pos ( int pdf_document, float x-coor, float y-coor [, int mode])

The cpdf_set_text_pos() function sets the position of text for the next cpdf_show() function call. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

선택 인자 mode는 유니트 길이를 결정합니다. 0이나 없을 경우에는 페이지를 위한 특정값을 기본 유니트로 사용합니다. 그렇지 않으면 현재 유니트를 무시하고 포스트스크립트 상에서 좌표를 측정합니다.

See also cpdf_show() and cpdf_text().

이전 | 처음으로 | 다음
cpdf_set_text_matrix | 위로 | cpdf_set_text_rendering


cpdf_set_text_rendering

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_set_text_rendering -- Determines how text is rendered

Description

bool cpdf_set_text_rendering ( int pdf_document, int rendermode)

The cpdf_set_text_rendering() function determines how text is rendered. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

The possible values for rendermode are 0=fill text, 1=stroke text, 2=fill and stroke text, 3=invisible, 4=fill text and add it to clipping path, 5=stroke text and add it to clipping path, 6=fill and stroke text and add it to clipping path, 7=add it to clipping path.

이전 | 처음으로 | 다음
cpdf_set_text_pos | 위로 | cpdf_set_text_rise


cpdf_set_text_rise

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_set_text_rise -- Sets the text rise

Description

bool cpdf_set_text_rise ( int pdf_document, float value)

The cpdf_set_text_rise() function sets the text rising to value units. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
cpdf_set_text_rendering | 위로 | cpdf_set_title


cpdf_set_title

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_set_title -- Sets the title field of the pdf document

Description

bool cpdf_set_title ( int pdf_document, string title)

The cpdf_set_title() function sets the title of a pdf document. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_set_subject(),
cpdf_set_creator() and
cpdf_set_keywords().

이전 | 처음으로 | 다음
cpdf_set_text_rise | 위로 | cpdf_set_viewer_preferences


cpdf_set_viewer_preferences

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

cpdf_set_viewer_preferences -- How to show the document in the viewer

Description

bool cpdf_set_viewer_preferences ( int pdfdoc, array preferences)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
cpdf_set_title | 위로 | cpdf_set_word_spacing


cpdf_set_word_spacing

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_set_word_spacing -- Sets spacing between words

Description

bool cpdf_set_word_spacing ( int pdf_document, float space)

The cpdf_set_word_spacing() function sets the spacing between words. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_set_char_spacing() and cpdf_set_leading().

이전 | 처음으로 | 다음
cpdf_set_viewer_preferences | 위로 | cpdf_setdash


cpdf_setdash

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_setdash -- Sets dash pattern

Description

bool cpdf_setdash ( int pdf_document, float white, float black)

The cpdf_setdash() function set the dash pattern white white units and black black units. If both are 0 a solid line is set. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
cpdf_set_word_spacing | 위로 | cpdf_setflat


cpdf_setflat

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_setflat -- Sets flatness

Description

bool cpdf_setflat ( int pdf_document, float value)

The cpdf_setflat() function set the flatness to a value between 0 and 100. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
cpdf_setdash | 위로 | cpdf_setgray_fill


cpdf_setgray_fill

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_setgray_fill -- Sets filling color to gray value

Description

bool cpdf_setgray_fill ( int pdf_document, float value)

The cpdf_setgray_fill() function sets the current gray value to fill a path. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_setrgbcolor_fill().

이전 | 처음으로 | 다음
cpdf_setflat | 위로 | cpdf_setgray_stroke


cpdf_setgray_stroke

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_setgray_stroke -- Sets drawing color to gray value

Description

bool cpdf_setgray_stroke ( int pdf_document, float gray_value)

The cpdf_setgray_stroke() function sets the current drawing color to the given gray value. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_setrgbcolor_stroke().

이전 | 처음으로 | 다음
cpdf_setgray_fill | 위로 | cpdf_setgray


cpdf_setgray

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_setgray -- Sets drawing and filling color to gray value

Description

bool cpdf_setgray ( int pdf_document, float gray_value)

The cpdf_setgray() function sets the current drawing and filling color to the given gray value. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_setrgbcolor_stroke() and cpdf_setrgbcolor_fill().

이전 | 처음으로 | 다음
cpdf_setgray_stroke | 위로 | cpdf_setlinecap


cpdf_setlinecap

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_setlinecap -- Sets linecap parameter

Description

bool cpdf_setlinecap ( int pdf_document, int value)

The cpdf_setlinecap() function set the linecap parameter between a value of 0 and 2. 0 = butt end, 1 = round, 2 = projecting square. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
cpdf_setgray | 위로 | cpdf_setlinejoin


cpdf_setlinejoin

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_setlinejoin -- Sets linejoin parameter

Description

bool cpdf_setlinejoin ( int pdf_document, int value)

The cpdf_setlinejoin() function set the linejoin parameter between a value of 0 and 2. 0 = miter, 1 = round, 2 = bevel. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
cpdf_setlinecap | 위로 | cpdf_setlinewidth


cpdf_setlinewidth

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_setlinewidth -- Sets line width

Description

bool cpdf_setlinewidth ( int pdf_document, float width)

The cpdf_setlinewidth() function set the line width to width. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
cpdf_setlinejoin | 위로 | cpdf_setmiterlimit


cpdf_setmiterlimit

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_setmiterlimit -- Sets miter limit

Description

bool cpdf_setmiterlimit ( int pdf_document, float value)

The cpdf_setmiterlimit() function set the miter limit to a value greater or equal than 1. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
cpdf_setlinewidth | 위로 | cpdf_setrgbcolor_fill


cpdf_setrgbcolor_fill

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_setrgbcolor_fill -- Sets filling color to rgb color value

Description

bool cpdf_setrgbcolor_fill ( int pdf_document, float red_value, float green_value, float blue_value)

The cpdf_setrgbcolor_fill() function sets the current rgb color value to fill a path. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: The values are expected to be floating point values between 0.0 and 1.0. (i.e black is (0.0, 0.0, 0.0) and white is (1.0, 1.0, 1.0)).

See also cpdf_setrgbcolor_stroke() and cpdf_setrgbcolor().

이전 | 처음으로 | 다음
cpdf_setmiterlimit | 위로 | cpdf_setrgbcolor_stroke


cpdf_setrgbcolor_stroke

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_setrgbcolor_stroke -- Sets drawing color to rgb color value

Description

bool cpdf_setrgbcolor_stroke ( int pdf_document, float red_value, float green_value, float blue_value)

The cpdf_setrgbcolor_stroke() function sets the current drawing color to the given rgb color value. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: The values are expected to be floating point values between 0.0 and 1.0. (i.e black is (0.0, 0.0, 0.0) and white is (1.0, 1.0, 1.0)).

See also cpdf_setrgbcolor_fill() and cpdf_setrgbcolor().

이전 | 처음으로 | 다음
cpdf_setrgbcolor_fill | 위로 | cpdf_setrgbcolor


cpdf_setrgbcolor

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_setrgbcolor -- Sets drawing and filling color to rgb color value

Description

bool cpdf_setrgbcolor ( int pdf_document, float red_value, float green_value, float blue_value)

The cpdf_setrgbcolor() function sets the current drawing and filling color to the given rgb color value. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: The values are expected to be floating point values between 0.0 and 1.0. (i.e black is (0.0, 0.0, 0.0) and white is (1.0, 1.0, 1.0)).

See also cpdf_setrgbcolor_stroke() and cpdf_setrgbcolor_fill().

이전 | 처음으로 | 다음
cpdf_setrgbcolor_stroke | 위로 | cpdf_show_xy


cpdf_show_xy

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_show_xy -- Output text at position

Description

bool cpdf_show_xy ( int pdf_document, string text, float x-coor, float y-coor [, int mode])

The cpdf_show_xy() function outputs the string text at position with coordinates (x-coor, y-coor). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

선택 인자 mode는 유니트 길이를 결정합니다. 0이나 없을 경우에는 페이지를 위한 특정값을 기본 유니트로 사용합니다. 그렇지 않으면 현재 유니트를 무시하고 포스트스크립트 상에서 좌표를 측정합니다.

참고: The function cpdf_show_xy() is identical to cpdf_text() without the optional parameters.

See also cpdf_text().

이전 | 처음으로 | 다음
cpdf_setrgbcolor | 위로 | cpdf_show


cpdf_show

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_show -- Output text at current position

Description

bool cpdf_show ( int pdf_document, string text)

The cpdf_show() function outputs the string in text at the current position. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_text(),
cpdf_begin_text() and
cpdf_end_text().

이전 | 처음으로 | 다음
cpdf_show_xy | 위로 | cpdf_stringwidth


cpdf_stringwidth

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_stringwidth -- Returns width of text in current font

Description

float cpdf_stringwidth ( int pdf_document, string text)

The cpdf_stringwidth() function returns the width of the string in text. It requires a font to be set before.

See also cpdf_set_font().

이전 | 처음으로 | 다음
cpdf_show | 위로 | cpdf_stroke


cpdf_stroke

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_stroke -- Draw line along path

Description

bool cpdf_stroke ( int pdf_document)

The cpdf_stroke() function draws a line along current path. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also cpdf_closepath() and cpdf_closepath_stroke().

이전 | 처음으로 | 다음
cpdf_stringwidth | 위로 | cpdf_text


cpdf_text

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_text -- Output text with parameters

Description

bool cpdf_text ( int pdf_document, string text, float x-coor, float y-coor [, int mode [, float orientation [, int alignmode]]])

The cpdf_text() function outputs the string text at position with coordinates (x-coor, y-coor). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

선택 인자 mode는 유니트 길이를 결정합니다. 0이나 없을 경우에는 페이지를 위한 특정값을 기본 유니트로 사용합니다. 그렇지 않으면 현재 유니트를 무시하고 포스트스크립트 상에서 좌표를 측정합니다.

The optional parameter orientation is the rotation of the text in degree.

The optional parameter alignmode determines how the text is aligned.

See the ClibPDF documentation for possible values.

See also cpdf_show_xy().

이전 | 처음으로 | 다음
cpdf_stroke | 위로 | cpdf_translate


cpdf_translate

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

cpdf_translate -- Sets origin of coordinate system

Description

bool cpdf_translate ( int pdf_document, float x-coor, float y-coor [, int mode])

The cpdf_translate() function set the origin of coordinate system to the point (x-coor, y-coor). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

선택 인자 mode는 유니트 길이를 결정합니다. 0이나 없을 경우에는 페이지를 위한 특정값을 기본 유니트로 사용합니다. 그렇지 않으면 현재 유니트를 무시하고 포스트스크립트 상에서 좌표를 측정합니다.

이전 | 처음으로 | 다음
cpdf_text | 위로 | Crack Functions


Crack Functions

PHP 매뉴얼
이전 다음

XI. Crack Functions

소개

These functions allow you to use the CrackLib library to test the 'strength' of a password. The 'strength' of a password is tested by that checks length, use of upper and lower case and checked against the specified CrackLib dictionary. CrackLib will also give helpful diagnostic messages that will help 'strengthen' the password.

참고: 이 확장 모듈은 PHP 5에서 제거되어, PECL로 이동되었습니다.

요구 사항

More information regarding CrackLib along with the library can be found at http://www.crypticide.org/users/alecm/.

설치

In order to use these functions, you must compile PHP with Crack support by using the --with-crack[=DIR] option.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. Crack configuration options

Name | Default | Changeable
crack.default_dictionary | NULL | PHP_INI_SYSTEM
For further details and definition of the PHP_INI_* constants see ini_set().

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

예제

This example shows how to open a CrackLib dictionary, test a given password, retrieve any diagnostic messages, and close the dictionary.

예 1. CrackLib example

<?php
// Open CrackLib Dictionary
$dictionary = crack_opendict('/usr/local/lib/pw_dict')
     or die('Unable to open CrackLib dictionary');

// Perform password check
$check = crack_check($dictionary, 'gx9A2s0x');

// Retrieve messages
$diag = crack_getlastmessage();
echo $diag; // 'strong password'

// Close dictionary
crack_closedict($dictionary);
?>

참고: If crack_check() returns TRUE, crack_getlastmessage() will return 'strong password'.

차례
crack_check -- Performs an obscure check with the given password
crack_closedict -- Closes an open CrackLib dictionary
crack_getlastmessage -- Returns the message from the last obscure check
crack_opendict -- Opens a new CrackLib dictionary

이전 | 처음으로 | 다음
cpdf_translate | 위로 | crack_check


crack_check

(PHP 4 >= 4.0.5)

crack_check -- Performs an obscure check with the given password

Description

bool crack_check ( [resource dictionary, string password])

Returns TRUE if password is strong, or FALSE otherwise.

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

crack_check() performs an obscure check with the given password on the specified dictionary . If dictionary is not specified, the last opened dictionary is used.

이전 | 처음으로 | 다음
Crack Functions | 위로 | crack_closedict


crack_closedict

(PHP 4 >= 4.0.5)

crack_closedict -- Closes an open CrackLib dictionary

Description

bool crack_closedict ( [resource dictionary])

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

crack_closedict() closes the specified dictionary identifier. If dictionary is not specified, the current dictionary is closed.

이전 | 처음으로 | 다음
crack_check | 위로 | crack_getlastmessage


crack_getlastmessage

(PHP 4 >= 4.0.5)

crack_getlastmessage -- Returns the message from the last obscure check

Description

string crack_getlastmessage ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

crack_getlastmessage() returns the message from the last obscure check.

이전 | 처음으로 | 다음
crack_closedict | 위로 | crack_opendict


crack_opendict

(PHP 4 >= 4.0.5)

crack_opendict -- Opens a new CrackLib dictionary

Description

resource crack_opendict ( string dictionary)

Returns a dictionary resource identifier on success, or FALSE on failure.

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

crack_opendict() opens the specified CrackLib dictionary for use with crack_check().

참고: Only one dictionary may be open at a time.

See also: crack_check(), and crack_closedict().

이전 | 처음으로 | 다음
crack_getlastmessage | 위로 | CURL, Client URL Library Functions


CURL, Client URL Library Functions

PHP 매뉴얼
이전 다음

XII. CURL, Client URL Library Functions

소개

PHP supports libcurl, a library created by Daniel Stenberg, that allows you to connect and communicate to many different types of servers with many different types of protocols. libcurl currently supports the http, https, ftp, gopher, telnet, dict, file, and ldap protocols. libcurl also supports HTTPS certificates, HTTP POST, HTTP PUT, FTP uploading (this can also be done with PHP's ftp extension), HTTP form based upload, proxies, cookies, and user+password authentication.

These functions have been added in PHP 4.0.2.

요구 사항

In order to use the CURL functions you need to install the CURL package. PHP requires that you use CURL 7.0.2-beta or higher. PHP will not work with any version of CURL below version 7.0.2-beta. In PHP 4.2.3, you will need CURL version 7.9.0 or higher. From PHP 4.3.0, you will need a CURL version that's 7.9.8 or higher. PHP 5.0.0 will most likely require a CURL version greater than 7.10.5

설치

To use PHP's CURL support you must also compile PHP --with-curl[=DIR] where DIR is the location of the directory containing the lib and include directories. In the "include" directory there should be a folder named "curl" which should contain the easy.h and curl.h files. There should be a file named libcurl.a located in the "lib" directory. Beginning with PHP 4.3.0 you can configure PHP to use CURL for URL streams --with-curlwrappers.

Note to Win32 Users: In order to enable this module on a Windows environment, you must copy libeay32.dll and ssleay32.dll from the DLL folder of the PHP/Win32 binary package to the SYSTEM folder of your Windows machine. (Ex: C:\WINNT\SYSTEM32 or C:\WINDOWS\SYSTEM)

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

CURLOPT_PORT (integer)

CURLOPT_FILE (integer)

CURLOPT_INFILE (integer)

CURLOPT_INFILESIZE (integer)

CURLOPT_URL (integer)

CURLOPT_PROXY (integer)

CURLOPT_VERBOSE (integer)

CURLOPT_HEADER (integer)

CURLOPT_HTTPHEADER (integer)

CURLOPT_NOPROGRESS (integer)

CURLOPT_NOBODY (integer)

CURLOPT_FAILONERROR (integer)

CURLOPT_UPLOAD (integer)

CURLOPT_POST (integer)

CURLOPT_FTPLISTONLY (integer)

CURLOPT_FTPAPPEND (integer)

CURLOPT_NETRC (integer)

CURLOPT_FOLLOWLOCATION (integer)

CURLOPT_FTPASCII (integer)

CURLOPT_PUT (integer)

CURLOPT_MUTE (integer)

CURLOPT_USERPWD (integer)

CURLOPT_PROXYUSERPWD (integer)

CURLOPT_RANGE (integer)

CURLOPT_TIMEOUT (integer)

CURLOPT_POSTFIELDS (integer)

CURLOPT_REFERER (integer)

CURLOPT_USERAGENT (integer)

CURLOPT_FTPPORT (integer)

CURLOPT_LOW_SPEED_LIMIT (integer)

CURLOPT_LOW_SPEED_TIME (integer)

CURLOPT_RESUME_FROM (integer)

CURLOPT_COOKIE (integer)

CURLOPT_SSLCERT (integer)

CURLOPT_SSLCERTPASSWD (integer)

CURLOPT_WRITEHEADER (integer)

CURLOPT_SSL_VERIFYHOST (integer)

CURLOPT_COOKIEFILE (integer)

CURLOPT_SSLVERSION (integer)

CURLOPT_TIMECONDITION (integer)

CURLOPT_TIMEVALUE (integer)

CURLOPT_CUSTOMREQUEST (integer)

CURLOPT_STDERR (integer)

CURLOPT_TRANSFERTEXT (integer)

CURLOPT_RETURNTRANSFER (integer)

CURLOPT_QUOTE (integer)

CURLOPT_POSTQUOTE (integer)

CURLOPT_INTERFACE (integer)

CURLOPT_KRB4LEVEL (integer)

CURLOPT_HTTPPROXYTUNNEL (integer)

CURLOPT_FILETIME (integer)

CURLOPT_WRITEFUNCTION (integer)

CURLOPT_READFUNCTION (integer)

CURLOPT_PASSWDFUNCTION (integer)

CURLOPT_HEADERFUNCTION (integer)

CURLOPT_MAXREDIRS (integer)

CURLOPT_MAXCONNECTS (integer)

CURLOPT_CLOSEPOLICY (integer)

CURLOPT_FRESH_CONNECT (integer)

CURLOPT_FORBID_REUSE (integer)

CURLOPT_RANDOM_FILE (integer)

CURLOPT_EGDSOCKET (integer)

CURLOPT_CONNECTTIMEOUT (integer)

CURLOPT_SSL_VERIFYPEER (integer)

CURLOPT_CAINFO (integer)

CURLOPT_COOKIEJAR (integer)

CURLOPT_SSL_CIPHER_LIST (integer)

CURLOPT_BINARYTRANSFER (integer)

CURLCLOSEPOLICY_LEAST_RECENTLY_USED (integer)

CURLCLOSEPOLICY_LEAST_TRAFFIC (integer)

CURLCLOSEPOLICY_SLOWEST (integer)

CURLCLOSEPOLICY_CALLBACK (integer)

CURLCLOSEPOLICY_OLDEST (integer)

CURLINFO_EFFECTIVE_URL (integer)

CURLINFO_HTTP_CODE (integer)

CURLINFO_HEADER_SIZE (integer)

CURLINFO_REQUEST_SIZE (integer)

CURLINFO_TOTAL_TIME (integer)

CURLINFO_NAMELOOKUP_TIME (integer)

CURLINFO_CONNECT_TIME (integer)

CURLINFO_PRETRANSFER_TIME (integer)

CURLINFO_SIZE_UPLOAD (integer)

CURLINFO_SIZE_DOWNLOAD (integer)

CURLINFO_SPEED_DOWNLOAD (integer)

CURLINFO_SPEED_UPLOAD (integer)

CURLINFO_FILETIME (integer)

CURLINFO_SSL_VERIFYRESULT (integer)

CURLINFO_CONTENT_LENGTH_DOWNLOAD (integer)

CURLINFO_CONTENT_LENGTH_UPLOAD (integer)

CURLE_OK (integer)

CURLE_UNSUPPORTED_PROTOCOL (integer)

CURLE_FAILED_INIT (integer)

CURLE_URL_MALFORMAT (integer)

CURLE_URL_MALFORMAT_USER (integer)

CURLE_COULDNT_RESOLVE_PROXY (integer)

CURLE_COULDNT_RESOLVE_HOST (integer)

CURLE_COULDNT_CONNECT (integer)

CURLE_FTP_WEIRD_SERVER_REPLY (integer)

CURLE_FTP_ACCESS_DENIED (integer)

CURLE_FTP_USER_PASSWORD_INCORRECT (integer)

CURLE_FTP_WEIRD_PASS_REPLY (integer)

CURLE_FTP_WEIRD_USER_REPLY (integer)

CURLE_FTP_WEIRD_PASV_REPLY (integer)

CURLE_FTP_WEIRD_227_FORMAT (integer)

CURLE_FTP_CANT_GET_HOST (integer)

CURLE_FTP_CANT_RECONNECT (integer)

CURLE_FTP_COULDNT_SET_BINARY (integer)

CURLE_PARTIAL_FILE (integer)

CURLE_FTP_COULDNT_RETR_FILE (integer)

CURLE_FTP_WRITE_ERROR (integer)

CURLE_FTP_QUOTE_ERROR (integer)

CURLE_HTTP_NOT_FOUND (integer)

CURLE_WRITE_ERROR (integer)

CURLE_MALFORMAT_USER (integer)

CURLE_FTP_COULDNT_STOR_FILE (integer)

CURLE_READ_ERROR (integer)

CURLE_OUT_OF_MEMORY (integer)

CURLE_OPERATION_TIMEOUTED (integer)

CURLE_FTP_COULDNT_SET_ASCII (integer)

CURLE_FTP_PORT_FAILED (integer)

CURLE_FTP_COULDNT_USE_REST (integer)

CURLE_FTP_COULDNT_GET_SIZE (integer)

CURLE_HTTP_RANGE_ERROR (integer)

CURLE_HTTP_POST_ERROR (integer)

CURLE_SSL_CONNECT_ERROR (integer)

CURLE_FTP_BAD_DOWNLOAD_RESUME (integer)

CURLE_FILE_COULDNT_READ_FILE (integer)

CURLE_LDAP_CANNOT_BIND (integer)

CURLE_LDAP_SEARCH_FAILED (integer)

CURLE_LIBRARY_NOT_FOUND (integer)

CURLE_FUNCTION_NOT_FOUND (integer)

CURLE_ABORTED_BY_CALLBACK (integer)

CURLE_BAD_FUNCTION_ARGUMENT (integer)

CURLE_BAD_CALLING_ORDER (integer)

CURLE_HTTP_PORT_FAILED (integer)

CURLE_BAD_PASSWORD_ENTERED (integer)

CURLE_TOO_MANY_REDIRECTS (integer)

CURLE_UNKNOWN_TELNET_OPTION (integer)

CURLE_TELNET_OPTION_SYNTAX (integer)

CURLE_OBSOLETE (integer)

CURLE_SSL_PEER_CERTIFICATE (integer)

예제

Once you've compiled PHP with CURL support, you can begin using the CURL functions. The basic idea behind the CURL functions is that you initialize a CURL session using the curl_init(), then you can set all your options for the transfer via the curl_setopt(), then you can execute the session with the curl_exec() and then you finish off your session using the curl_close(). Here is an example that uses the CURL functions to fetch the example.com homepage into a file:

예 1. Using PHP's CURL module to fetch the example.com homepage

<?php

$ch = curl_init("http://www.example.com/");
$fp = fopen("example_homepage.txt", "w");

curl_setopt($ch, CURLOPT_FILE, $fp);
curl_setopt($ch, CURLOPT_HEADER, 0);

curl_exec($ch);
curl_close($ch);
fclose($fp);
?>

차례
curl_close -- Close a CURL session
curl_errno -- Return the last error number
curl_error -- Return a string containing the last error for the current session
curl_exec -- Perform a CURL session
curl_getinfo -- Get information regarding a specific transfer
curl_init -- Initialize a CURL session
curl_multi_add_handle -- Add a normal cURL handle to a cURL multi handle
curl_multi_close -- Close a set of cURL handles
curl_multi_exec -- Run the sub-connections of the current cURL handle
curl_multi_getcontent -- Return the content of a cURL handle if CURLOPT_RETURNTRANSFER is set
curl_multi_info_read -- Get information about the current transfers
curl_multi_init -- Returns a new cURL multi handle
curl_multi_remove_handle -- Remove a multi handle from a set of cURL handles
curl_multi_select -- Get all the sockets associated with the cURL extension, which can then be "selected"
curl_setopt -- Set an option for a CURL transfer
curl_version -- Return the current CURL version

이전 | 처음으로 | 다음
crack_opendict | 위로 | curl_close


curl_close

(PHP 4 >= 4.0.2, PHP 5)

curl_close -- Close a CURL session

Description

void curl_close ( resource ch)

This function closes a CURL session and frees all resources. The CURL handle, ch, is also deleted.

예 1. Initializing a new CURL session and fetching a webpage

<?php
// create a new curl resource
$ch = curl_init();

// set URL and other appropriate options
curl_setopt($ch, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch, CURLOPT_HEADER, 0);

// grab URL and pass it to the browser
curl_exec($ch);

// close curl resource, and free up system resources
curl_close($ch);
?>

See also: curl_init().

이전 | 처음으로 | 다음
CURL, Client URL Library Functions | 위로 | curl_errno


curl_errno

(PHP 4 >= 4.0.3, PHP 5)

curl_errno -- Return the last error number

Description

int curl_errno ( resource ch)

Returns the error number for the last cURL operation on the resource ch, or 0 (zero) if no error occurred.

See also curl_error() and Curl error codes.

이전 | 처음으로 | 다음
curl_close | 위로 | curl_error


curl_error

(PHP 4 >= 4.0.3, PHP 5)

curl_error -- Return a string containing the last error for the current session

Description

string curl_error ( resource ch)

Returns a clear text error message for the last cURL operation on the resource ch, or '' (the empty string) if no error occurred.

See also curl_errno() and Curl error codes.

이전 | 처음으로 | 다음
curl_errno | 위로 | curl_exec


curl_exec

(PHP 4 >= 4.0.2, PHP 5)

curl_exec -- Perform a CURL session

Description

mixed curl_exec ( resource ch)

This function should be called after you initialize a CURL session and all the options for the session are set. Its purpose is simply to execute the predefined CURL session (given by the ch).

예 1. Initializing a new CURL session and fetching a webpage

<?php
// create a new curl resource
$ch = curl_init();

// set URL and other appropriate options
curl_setopt($ch, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch, CURLOPT_HEADER, 0);

// grab URL and pass it to the browser
curl_exec($ch);

// close curl resource, and free up system resources
curl_close($ch);
?>

참고: If you want to have the result returned instead of it being printed to the browser directly, use the CURLOPT_RETURNTRANSFER option of curl_setopt().

이전 | 처음으로 | 다음
curl_error | 위로 | curl_getinfo


curl_getinfo

(PHP 4 >= 4.0.4, PHP 5)

curl_getinfo -- Get information regarding a specific transfer

Description

string curl_getinfo ( resource ch [, int opt])

Returns information about the last transfer, opt may be one of the following:

  • "CURLINFO_EFFECTIVE_URL" - Last effective URL

  • "CURLINFO_HTTP_CODE" - Last received HTTP code

  • "CURLINFO_FILETIME" - Remote time of the retrieved document, if -1 is returned the time of the document is unknown

  • "CURLINFO_TOTAL_TIME" - Total transaction time in seconds for last transfer

  • "CURLINFO_NAMELOOKUP_TIME" - Time in seconds until name resolving was complete

  • "CURLINFO_CONNECT_TIME" - Time in seconds it took to establish the connection

  • "CURLINFO_PRETRANSFER_TIME" - Time in seconds from start until just before file transfer begins

  • "CURLINFO_STARTTRANSFER_TIME" - Time in seconds until the first byte is about to be transferred

  • "CURLINFO_REDIRECT_TIME" - Time in seconds of all redirection steps before final transaction was started

  • "CURLINFO_SIZE_UPLOAD" - Total number of bytes uploaded

  • "CURLINFO_SIZE_DOWNLOAD" - Total number of bytes downloaded

  • "CURLINFO_SPEED_DOWNLOAD" - Average download speed

  • "CURLINFO_SPEED_UPLOAD" - Average upload speed

  • "CURLINFO_HEADER_SIZE" - Total size of all headers received

  • "CURLINFO_REQUEST_SIZE" - Total size of issued requests, currently only for HTTP requests

  • "CURLINFO_SSL_VERIFYRESULT" - Result of SSL certification verification requested by setting CURLOPT_SSL_VERIFYPEER

  • "CURLINFO_CONTENT_LENGTH_DOWNLOAD" - content-length of download, read from Content-Length: field

  • "CURLINFO_CONTENT_LENGTH_UPLOAD" - Specified size of upload

  • "CURLINFO_CONTENT_TYPE" - Content-type of downloaded object, NULL indicates server did not send valid Content-Type: header

If called without the optional parameter opt an associative array is returned with the following array elements which correspond to opt options:

  • "url"

  • "content_type"

  • "http_encode"

  • "header_size"

  • "request_size"

  • "filetime"

  • "ssl_verify_result"

  • "redirect_count"

  • "total_time"

  • "namelookup_time"

  • "connect_time"

  • "pretransfer_time"

  • "size_upload"

  • "size_download"

  • "speed_download"

  • "speed_upload"

  • "download_content_length"

  • "upload_content_length"

  • "starttransfer_time"

  • "redirect_time"

이전 | 처음으로 | 다음
curl_exec | 위로 | curl_init


curl_init

(PHP 4 >= 4.0.2, PHP 5)

curl_init -- Initialize a CURL session

Description

resource curl_init ( [string url])

The curl_init() will initialize a new session and return a CURL handle for use with the curl_setopt(), curl_exec(), and curl_close() functions. If the optional url parameter is supplied then the CURLOPT_URL option will be set to the value of the parameter. You can manually set this using the curl_setopt() function.

예 1. Initializing a new CURL session and fetching a webpage

<?php
// create a new curl resource
$ch = curl_init();

// set URL and other appropriate options
curl_setopt($ch, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch, CURLOPT_HEADER, 0);

// grab URL and pass it to the browser
curl_exec($ch);

// close curl resource, and free up system resources
curl_close($ch);
?>

See also: curl_close(), curl_setopt()

이전 | 처음으로 | 다음
curl_getinfo | 위로 | curl_multi_add_handle


curl_multi_add_handle

(PHP 5)

curl_multi_add_handle -- Add a normal cURL handle to a cURL multi handle

Description

int curl_multi_add_handle ( resource mh, resource ch)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also
curl_multi_init(),
curl_init(), and
curl_multi_remove_handle().

이전 | 처음으로 | 다음
curl_init | 위로 | curl_multi_close


curl_multi_close

(PHP 5)

curl_multi_close -- Close a set of cURL handles

Description

void curl_multi_close ( resource mh)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also curl_multi_init() and curl_close().

이전 | 처음으로 | 다음
curl_multi_add_handle | 위로 | curl_multi_exec


curl_multi_exec

(PHP 5)

curl_multi_exec -- Run the sub-connections of the current cURL handle

Description

int curl_multi_exec ( resource mh)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also curl_multi_init() and curl_exec().

이전 | 처음으로 | 다음
curl_multi_close | 위로 | curl_multi_getcontent


curl_multi_getcontent

(PHP 5)

curl_multi_getcontent -- Return the content of a cURL handle if CURLOPT_RETURNTRANSFER is set

Description

string curl_multi_getcontent ( resource ch)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also curl_multi_init().

이전 | 처음으로 | 다음
curl_multi_exec | 위로 | curl_multi_info_read


curl_multi_info_read

(PHP 5)

curl_multi_info_read -- Get information about the current transfers

Description

array curl_multi_info_read ( resource mh)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also curl_multi_init().

이전 | 처음으로 | 다음
curl_multi_getcontent | 위로 | curl_multi_init


curl_multi_init

(PHP 5)

curl_multi_init -- Returns a new cURL multi handle

Description

resource curl_multi_init ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also curl_init() and curl_multi_close().

이전 | 처음으로 | 다음
curl_multi_info_read | 위로 | curl_multi_remove_handle


curl_multi_remove_handle

(PHP 5)

curl_multi_remove_handle -- Remove a multi handle from a set of cURL handles

Description

int curl_multi_remove_handle ( resource mh, resource ch)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also
curl_multi_init(),
curl_init(), and
curl_multi_add_handle().

이전 | 처음으로 | 다음
curl_multi_init | 위로 | curl_multi_select


curl_multi_select

(PHP 5)

curl_multi_select -- Get all the sockets associated with the cURL extension, which can then be "selected"

Description

int curl_multi_select ( resource mh [, float timeout])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also curl_multi_init().

이전 | 처음으로 | 다음
curl_multi_remove_handle | 위로 | curl_setopt


curl_setopt

(PHP 4 >= 4.0.2, PHP 5)

curl_setopt -- Set an option for a CURL transfer

Description

bool curl_setopt ( resource ch, string option, mixed value)

The curl_setopt() function will set options for a CURL session identified by the ch parameter. The option parameter is the option you want to set, and the value is the value of the option given by the option.

The value should be a long for the following options (specified in the option parameter):

  • CURLOPT_INFILESIZE: When you are uploading a file to a remote site, this option should be used to tell PHP what the expected size of the infile will be.

  • CURLOPT_VERBOSE: Set this option to a non-zero value if you want CURL to report everything that is happening.

  • CURLOPT_HEADER: Set this option to a non-zero value if you want the header to be included in the output.

  • CURLOPT_NOPROGRESS: Set this option to a non-zero value if you don't want PHP to display a progress meter for CURL transfers.

    참고: PHP automatically sets this option to a non-zero parameter, this should only be changed for debugging purposes.

  • CURLOPT_NOBODY: Set this option to a non-zero value if you don't want the body included with the output.

  • CURLOPT_FAILONERROR: Set this option to a non-zero value if you want PHP to fail silently if the HTTP code returned is greater than 300. The default behavior is to return the page normally, ignoring the code.

  • CURLOPT_UPLOAD: Set this option to a non-zero value if you want PHP to prepare for an upload.

  • CURLOPT_POST: Set this option to a non-zero value if you want PHP to do a regular HTTP POST. This POST is a normal application/x-www-form-urlencoded kind, most commonly used by HTML forms.

  • CURLOPT_FTPLISTONLY: Set this option to a non-zero value and PHP will just list the names of an FTP directory.

  • CURLOPT_FTPAPPEND: Set this option to a non-zero value and PHP will append to the remote file instead of overwriting it.

  • CURLOPT_NETRC: Set this option to a non-zero value and PHP will scan your ~./netrc file to find your username and password for the remote site that you're establishing a connection with.

  • CURLOPT_FOLLOWLOCATION: Set this option to a non-zero value to follow any "Location: " header that the server sends as a part of the HTTP header (note this is recursive, PHP will follow as many "Location: " headers that it is sent.)

  • CURLOPT_PUT: Set this option to a non-zero value to HTTP PUT a file. The file to PUT must be set with the CURLOPT_INFILE and CURLOPT_INFILESIZE.

  • CURLOPT_MUTE: Set this option to a non-zero value and PHP will be completely silent with regards to the CURL functions.

  • CURLOPT_TIMEOUT: Pass a long as a parameter that contains the maximum time, in seconds, that you'll allow the CURL functions to take.

  • CURLOPT_LOW_SPEED_LIMIT: Pass a long as a parameter that contains the transfer speed in bytes per second that the transfer should be below during CURLOPT_LOW_SPEED_TIME seconds for PHP to consider too slow and abort.

  • CURLOPT_LOW_SPEED_TIME: Pass a long as a parameter that contains the time in seconds that the transfer should be below the CURLOPT_LOW_SPEED_LIMIT for PHP to consider it too slow and abort.

  • CURLOPT_RESUME_FROM: Pass a long as a parameter that contains the offset, in bytes, that you want the transfer to start from.

  • CURLOPT_CAINFO: Pass a filename of a file holding one or more certificates to verify the peer with. This only makes sense when used in combination with the CURLOPT_SSL_VERIFYPEER option.

  • CURLOPT_SSL_VERIFYPEER: Pass a long that is set to a zero value to stop curl from verifying the peer's certificate (curl 7.10 starting setting this option to TRUE by default). Alternate certificates to verify against can be specified with the CURLOPT_CAINFO option (added in curl 7.9.8) or a certificate directory can be specified with the CURLOPT_CAPATH option. As of curl 7.10, curl installs a default bundle. CURLOPT_SSL_VERIFYHOST may also need to be set to 1 or 0 if CURLOPT_SSL_VERIFYPEER is disabled (it defaults to 2).

  • CURLOPT_SSLVERSION: Pass a long as a parameter that contains the SSL version (2 or 3) to use. By default PHP will try and determine this by itself, although, in some cases you must set this manually.

  • CURLOPT_SSL_VERIFYHOST: Pass a long if CURL should verify the Common name of the peer certificate in the SSL handshake. A value of 1 denotes that we should check for the existence of the common name, a value of 2 denotes that we should make sure it matches the provided hostname.

  • CURLOPT_TIMECONDITION: Pass a long as a parameter that defines how the CURLOPT_TIMEVALUE is treated. You can set this parameter to TIMECOND_IFMODSINCE or TIMECOND_ISUNMODSINCE. This is a HTTP-only feature.

  • CURLOPT_TIMEVALUE: Pass a long as a parameter that is the time in seconds since January 1st, 1970. The time will be used as specified by the CURLOPT_TIMECONDITION option, or by default the TIMECOND_IFMODSINCE will be used.

  • CURLOPT_RETURNTRANSFER: Pass a non-zero value if you want CURL to directly return the transfer instead of printing it out directly.

The value parameter should be a string for the following values of the option parameter:

  • CURLOPT_URL: This is the URL that you want PHP to fetch. You can also set this option when initializing a session with the curl_init() function.

  • CURLOPT_USERPWD: Pass a string formatted in the [username]:[password] manner, for PHP to use for the connection.

  • CURLOPT_PROXYUSERPWD: Pass a string formatted in the [username]:[password] format for connection to the HTTP proxy.

  • CURLOPT_RANGE: Pass the specified range you want. It should be in the "X-Y" format, where X or Y may be left out. The HTTP transfers also support several intervals, separated with commas as in X-Y,N-M.

  • CURLOPT_POSTFIELDS: Pass a string containing the full data to post in an HTTP "POST" operation.

  • CURLOPT_REFERER: Pass a string containing the "referer" header to be used in an HTTP request.

  • CURLOPT_USERAGENT: Pass a string containing the "user-agent" header to be used in an HTTP request.

  • CURLOPT_FTPPORT: Pass a string containing the value which will be used to get the IP address to use for the ftp "POST" instruction. The POST instruction tells the remote server to connect to our specified IP address. The string may be a plain IP address, a hostname, a network interface name (under Unix), or just a plain '-' to use the systems default IP address.

  • CURLOPT_COOKIE: Pass a string containing the content of the cookie to be set in the HTTP header.

  • CURLOPT_SSLCERT: Pass a string containing the filename of PEM formatted certificate.

  • CURLOPT_SSLCERTPASSWD: Pass a string containing the password required to use the CURLOPT_SSLCERT certificate.

  • CURLOPT_COOKIEFILE: Pass a string containing the name of the file containing the cookie data. The cookie file can be in Netscape format, or just plain HTTP-style headers dumped into a file.

  • CURLOPT_CUSTOMREQUEST: Pass a string to be used instead of GET or HEAD when doing an HTTP request. This is useful for doing DELETE or other, more obscure, HTTP requests. Valid values are things like GET, POST, and so on; i.e. do not enter a whole HTTP request line here. For instance, entering 'GET /index.html HTTP/1.0\r\n\r\n' would be incorrect.

    참고: Don't do this without making sure your server supports the command first.

  • CURLOPT_PROXY: Give the name of the HTTP proxy to tunnel requests through.

  • CURLOPT_INTERFACE: Pass the name of the outgoing network interface to use. This can be an interface name, an IP address or a host name.

  • CURLOPT_KRB4LEVEL: Pass the KRB4 (Kerberos 4) security level. Any of the following values (in order from least to most powerful) are valid: 'clear', 'safe', 'confidential', 'private'. If the string does not match one of these, then 'private' is used. Setting this Option to NULL, will disable KRB4 security. Currently KRB4 security only works with FTP transactions.

  • CURLOPT_HTTPHEADER: Pass an array of HTTP header fields to set.

  • CURLOPT_QUOTE: Pass an array of FTP commands to perform on the server prior to the FTP request.

  • CURLOPT_POSTQUOTE: Pass an array of FTP commands to execute on the server, after the FTP request has been performed.

The following options expect a file descriptor that is obtained by using the fopen() function:

  • CURLOPT_FILE: The file where the output of your transfer should be placed, the default is STDOUT.

  • CURLOPT_INFILE: The file where the input of your transfer comes from.

  • CURLOPT_WRITEHEADER: The file to write the header part of the output into.

  • CURLOPT_STDERR: The file to write errors to instead of stderr.

예 1. Initializing a new CURL session and fetching a webpage

<?php
// create a new curl resource
$ch = curl_init();

// set URL and other appropriate options
curl_setopt($ch, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch, CURLOPT_HEADER, 0);

// grab URL and pass it to the browser
curl_exec($ch);

// close curl resource, and free up system resources
curl_close($ch);
?>

이전 | 처음으로 | 다음
curl_multi_select | 위로 | curl_version


curl_version

(PHP 4 >= 4.0.2, PHP 5)

curl_version -- Return the current CURL version

Description

string curl_version ( void )

The curl_version() function returns a string containing the current CURL version.

이전 | 처음으로 | 다음
curl_setopt | 위로 | Cybercash Payment Functions


Cybercash Payment Functions

PHP 매뉴얼
이전 다음

XIII. Cybercash Payment Functions

설치

These functions are only available if the interpreter has been compiled with the --with-cybercash=[DIR].

This extension has been moved from PHP as of PHP 4.3.0 and now CyberCash lives in PECL.

If you have questions as to the latest status of CyberCash then the following CyberCash Faq will be helpful. In short, CyberCash was bought out by VeriSign and although the CyberCash service continues to exist, VeriSign encourages users to switch. See the above faq and PECL link for details.

차례
cybercash_base64_decode -- base64 decode data for Cybercash
cybercash_base64_encode -- base64 encode data for Cybercash
cybercash_decr -- Cybercash decrypt
cybercash_encr -- Cybercash encrypt

이전 | 처음으로 | 다음
curl_version | 위로 | cybercash_base64_decode


cybercash_base64_decode

(PHP 4 <= 4.2.3)

cybercash_base64_decode -- base64 decode data for Cybercash

Description

string cybercash_base64_decode ( string inbuff)

이전 | 처음으로 | 다음
Cybercash Payment Functions | 위로 | cybercash_base64_encode


cybercash_base64_encode

(PHP 4 <= 4.2.3)

cybercash_base64_encode -- base64 encode data for Cybercash

Description

string cybercash_base64_encode ( string inbuff)

이전 | 처음으로 | 다음
cybercash_base64_decode | 위로 | cybercash_decr


cybercash_decr

(PHP 4 <= 4.2.3)

cybercash_decr -- Cybercash decrypt

Description

array cybercash_decr ( string wmk, string sk, string inbuff)

The function returns an associative array with the elements "errcode" and, if "errcode" is FALSE, "outbuff" (string), "outLth" (long) and "macbuff" (string).

이전 | 처음으로 | 다음
cybercash_base64_encode | 위로 | cybercash_encr


cybercash_encr

(PHP 4 <= 4.2.3)

cybercash_encr -- Cybercash encrypt

Description

array cybercash_encr ( string wmk, string sk, string inbuff)

The function returns an associative array with the elements "errcode" and, if "errcode" is FALSE, "outbuff" (string), "outLth" (long) and "macbuff" (string).

이전 | 처음으로 | 다음
cybercash_decr | 위로 | Cyrus IMAP administration Functions


Cyrus IMAP administration Functions

PHP 매뉴얼
이전 다음

XIV. Cyrus IMAP administration Functions

소개

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: 이 확장 모듈은 윈도우 플랫폼에서는 사용할 수 없습니다.

설치

To enable Cyrus IMAP support and to use these functions you have to compile PHP with the --with-cyrus option.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

CYRUS_CONN_NONSYNCLITERAL (integer)

CYRUS_CONN_INITIALRESPONSE (integer)

CYRUS_CALLBACK_NUMBERED (integer)

CYRUS_CALLBACK_NOLITERAL (integer)

차례
cyrus_authenticate -- Authenticate against a Cyrus IMAP server
cyrus_bind -- Bind callbacks to a Cyrus IMAP connection
cyrus_close -- Close connection to a Cyrus IMAP server
cyrus_connect -- Connect to a Cyrus IMAP server
cyrus_query -- Send a query to a Cyrus IMAP server
cyrus_unbind -- Unbind ...

이전 | 처음으로 | 다음
cybercash_encr | 위로 | cyrus_authenticate


cyrus_authenticate

(PHP 4 >= 4.1.0)

cyrus_authenticate -- Authenticate against a Cyrus IMAP server

Description

bool cyrus_authenticate ( resource connection [, string mechlist [, string service [, string user [, int minssf [, int maxssf]]]]])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
Cyrus IMAP administration Functions | 위로 | cyrus_bind


cyrus_bind

(PHP 4 >= 4.1.0)

cyrus_bind -- Bind callbacks to a Cyrus IMAP connection

Description

bool cyrus_bind ( resource connection, array callbacks)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
cyrus_authenticate | 위로 | cyrus_close


cyrus_close

(PHP 4 >= 4.1.0)

cyrus_close -- Close connection to a Cyrus IMAP server

Description

bool cyrus_close ( resource connection)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
cyrus_bind | 위로 | cyrus_connect


cyrus_connect

(PHP 4 >= 4.1.0)

cyrus_connect -- Connect to a Cyrus IMAP server

Description

resource cyrus_connect ( [string host [, string port [, int flags]]])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
cyrus_close | 위로 | cyrus_query


cyrus_query

(PHP 4 >= 4.1.0)

cyrus_query -- Send a query to a Cyrus IMAP server

Description

bool cyrus_query ( resource connection, string query)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
cyrus_connect | 위로 | cyrus_unbind


cyrus_unbind

(PHP 4 >= 4.1.0)

cyrus_unbind -- Unbind ...

Description

bool cyrus_unbind ( resource connection, string trigger_name)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
cyrus_query | 위로 | Character Type Functions


Character Type Functions

PHP 매뉴얼
이전 다음

XV. Character Type Functions

소개

The functions provided by this extension check whether a character or string falls into a certain character class according to the current locale (see also setlocale()).

When called with an integer argument these functions behave exactly like their C counterparts from ctype.h.

When called with a string argument they will check every character in the string and will only return TRUE if every character in the string matches the requested criteria. When called with an empty string the result will always be TRUE.

Passing anything else but a string or integer will return FALSE immediately.

요구 사항

None besides functions from the standard C library which are always available.

설치

Beginning with PHP 4.2.0 these functions are enabled by default. For older versions you have to configure and compile PHP with --enable-ctype. You can disable ctype support with --disable-ctype.

PHP 윈도우 버전에서는 이 확장 모듈에 대한 지원이 포함되어 있습니다. 이 함수들을 이용하기 위해서 추가로 확장 모듈을 읽어들일 필요가 없습니다.

참고: Builtin support for ctype is available with PHP 4.3.0.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
ctype_alnum -- Check for alphanumeric character(s)
ctype_alpha -- Check for alphabetic character(s)
ctype_cntrl -- Check for control character(s)
ctype_digit -- Check for numeric character(s)
ctype_graph -- Check for any printable character(s) except space
ctype_lower -- Check for lowercase character(s)
ctype_print -- Check for printable character(s)
ctype_punct -- Check for any printable character which is not whitespace or an alphanumeric character
ctype_space -- Check for whitespace character(s)
ctype_upper -- Check for uppercase character(s)
ctype_xdigit -- Check for character(s) representing a hexadecimal digit

이전 | 처음으로 | 다음
cyrus_unbind | 위로 | ctype_alnum


ctype_alnum

(PHP 4 >= 4.0.4, PHP 5)

ctype_alnum -- Check for alphanumeric character(s)

Description

bool ctype_alnum ( string text)

Returns TRUE if every character in text is either a letter or a digit, FALSE otherwise. In the standard C locale letters are just [A-Za-z] and the function is equivalent to preg_match('/^[a-z0-9]*$/i', $text).

예 1. A ctype_alnum() example (using the default locale)

<?php
$strings = array('AbCd1zyZ9', 'foo!#$bar');
foreach ($strings as $testcase) {
    if (ctype_alnum($testcase)) {
        echo "The string $testcase consists of all letters or digits.\n";
    } else {
        echo "The string $testcase does not consist of all letters or digits.\n";
    }
}
?>

This example will output :

The string AbCd1zyZ9 consists of all letters or digits.
The string foo!#$bar does not consists of all letters or digits.

See also ctype_alpha(), ctype_digit(), and setlocale().

이전 | 처음으로 | 다음
Character Type Functions | 위로 | ctype_alpha


ctype_alpha

(PHP 4 >= 4.0.4, PHP 5)

ctype_alpha -- Check for alphabetic character(s)

Description

bool ctype_alpha ( string text)

Returns TRUE if every character in text is a letter from the current locale, FALSE otherwise. In the standard C locale letters are just [A-Za-z] and ctype_alpha() is equivalent to (ctype_upper($text) || ctype_lower($text)) if $text is just a single character, but other languages have letters that are considered neither upper nor lower case.

예 1. A ctype_alpha() example (using the default locale)

<?php
$strings = array('KjgWZC', 'arf12');
foreach ($strings as $testcase) {
    if (ctype_alpha($testcase)) {
        echo "The string $testcase consists of all letters.\n";
    } else {
        echo "The string $testcase does not consist of all letters.\n";
    }
}
?>

This example will output :

The string KjgWZC consists of all letters.
The string arf12 does not consists of all letters.

See also ctype_upper(),
ctype_lower(), and
setlocale().

이전 | 처음으로 | 다음
ctype_alnum | 위로 | ctype_cntrl


ctype_cntrl

(PHP 4 >= 4.0.4, PHP 5)

ctype_cntrl -- Check for control character(s)

Description

bool ctype_cntrl ( string text)

Returns TRUE if every character in text has a special control function, FALSE otherwise. Control characters are e.g. line feed, tab, esc.

예 1. A ctype_cntrl() example

<?php
$strings = array('string1' => "\n\r\t", 'string2' => 'arf12');
foreach ($strings as $name => $testcase) {
    if (ctype_cntrl($testcase)) {
        echo "The string '$name' consists of all control characters.\n";
    } else {
        echo "The string '$name' does not consist of all control characters.\n";
    }
}
?>

This example will output :

The string 'string1' consists of all control characters.
The string 'string2' does not consists of all control characters.

이전 | 처음으로 | 다음
ctype_alpha | 위로 | ctype_digit


ctype_digit

(PHP 4 >= 4.0.4, PHP 5)

ctype_digit -- Check for numeric character(s)

Description

bool ctype_digit ( string text)

Returns TRUE if every character in text is a decimal digit, FALSE otherwise.

예 1. A ctype_digit() example

<?php
$strings = array('1820.20', '10002', 'wsl!12');
foreach ($strings as $testcase) {
    if (ctype_digit($testcase)) {
        echo "The string $testcase consists of all digits.\n";
    } else {
        echo "The string $testcase does not consist of all digits.\n";
    }
}
?>

This example will output :

The string 1820.20 does not consists of all digits.
The string 10002 consists of all digits.
The string wsl!12 does not consists of all digits.

See also ctype_alnum() and ctype_xdigit().

이전 | 처음으로 | 다음
ctype_cntrl | 위로 | ctype_graph


ctype_graph

(PHP 4 >= 4.0.4, PHP 5)

ctype_graph -- Check for any printable character(s) except space

Description

bool ctype_graph ( string text)

Returns TRUE if every character in text is printable and actually creates visible output (no white space), FALSE otherwise.

예 1. A ctype_graph() example

<?php
$strings = array('string1' => "asdf\n\r\t", 'string2' => 'arf12', 'string3' => 'LKA#@%.54');
foreach ($strings as $name => $testcase) {
    if (ctype_graph($testcase)) {
        echo "The string '$name' consists of all (visibly) printable characters.\n";
    } else {
        echo "The string '$name' does not consist of all (visibly) printable characters.\n";
    }
}
?>

This example will output :

The string 'string1' does not consist of all printable characters.
The string 'string2' consists of all printable characters.
The string 'string3' consists of all printable characters.

See also ctype_alnum(), ctype_print(), and ctype_punct().

이전 | 처음으로 | 다음
ctype_digit | 위로 | ctype_lower


ctype_lower

(PHP 4 >= 4.0.4, PHP 5)

ctype_lower -- Check for lowercase character(s)

Description

bool ctype_lower ( string text)

Returns TRUE if every character in text is a lowercase letter in the current locale.

예 1. A ctype_lower() example (using the default locale)

<?php
$strings = array('aac123', 'qiutoas', 'QASsdks');
foreach ($strings as $testcase) {
    if (ctype_lower($testcase)) {
        echo "The string $testcase consists of all lowercase letters.\n";
    } else {
        echo "The string $testcase does not consist of all lowercase letters.\n";
    }
}
?>

This example will output :

The string aac123 does not consist of all lowercase letters.
The string qiutoas consists of all lowercase letters.
The string QASsdks does not consist of all lowercase letters.

See also ctype_alpha(), ctype_upper(), and setlocale().

이전 | 처음으로 | 다음
ctype_graph | 위로 | ctype_print


ctype_print

(PHP 4 >= 4.0.4, PHP 5)

ctype_print -- Check for printable character(s)

Description

bool ctype_print ( string text)

Returns TRUE if every character in text will actually create output (including blanks). Returns FALSE if text contains control characters or characters that do not have any output or control function at all.

예 1. A ctype_print() example

<?php
$strings = array('string1' => "asdf\n\r\t", 'string2' => 'arf12', 'string3' => 'LKA#@%.54');
foreach ($strings as $name => $testcase) {
    if (ctype_print($testcase)) {
        echo "The string '$name' consists of all printable characters.\n";
    } else {
        echo "The string '$name' does not consist of all printable characters.\n";
    }
}
?>

This example will output :

The string 'string1' does not consist of all printable characters.
The string 'string2' consists of all printable characters.
The string 'string3' consists of all printable characters.

See also ctype_cntrl(), ctype_graph(), and ctype_punct().

이전 | 처음으로 | 다음
ctype_lower | 위로 | ctype_punct


ctype_punct

(PHP 4 >= 4.0.4, PHP 5)

ctype_punct -- Check for any printable character which is not whitespace or an alphanumeric character

Description

bool ctype_punct ( string text)

Returns TRUE if every character in text is printable, but neither letter, digit or blank, FALSE otherwise.

예 1. A ctype_punct() example

<?php
$strings = array('ABasdk!@!$#', '!@ # $', '*&$()');
foreach ($strings as $testcase) {
    if (ctype_punct($testcase)) {
        echo "The string $testcase consists of all punctuation.\n";
    } else {
        echo "The string $testcase does not consist of all punctuation.\n";
    }
}
?>

This example will output :

The string ABasdk!@!$# does not consist of all punctuation.
The string !@ # $ does not consist of all punctuation.
The string *&$() consists of all punctuation.

See also ctype_cntrl() and ctype_graph().

이전 | 처음으로 | 다음
ctype_print | 위로 | ctype_space


ctype_space

(PHP 4 >= 4.0.4, PHP 5)

ctype_space -- Check for whitespace character(s)

Description

bool ctype_space ( string text)

Returns TRUE if every character in text creates some sort of white space, FALSE otherwise. Besides the blank character this also includes tab, vertical tab, line feed, carriage return and form feed characters.

예 1. A ctype_space() example

<?php
$strings = array('string1' => "\n\r\t", 'string2' => "\narf12", 'string3' => '\n\r\t');
foreach ($strings as $name => $testcase) {
    if (ctype_space($testcase)) {
        echo "The string '$name' consists of all whitespace characters.\n";
    } else {
        echo "The string '$name' does not consist of all whitespace characters.\n";
    }
}
?>

This example will output :

The string 'string1' consists of all whitespace characters.
The string 'string2' does not consist of all whitespace characters.
The string 'string3' does not consist of all whitespace characters.

See also ctype_cntrl(), ctype_graph(), and ctype_punct().

이전 | 처음으로 | 다음
ctype_punct | 위로 | ctype_upper


ctype_upper

(PHP 4 >= 4.0.4, PHP 5)

ctype_upper -- Check for uppercase character(s)

Description

bool ctype_upper ( string text)

Returns TRUE if every character in text is an uppercase letter in the current locale.

예 1. A ctype_upper() example (using the default locale)

<?php
$strings = array('AKLWC139', 'LMNSDO', 'akwSKWsm');
foreach ($strings as $testcase) {
    if (ctype_upper($testcase)) {
        echo "The string $testcase consists of all uppercase letters.\n";
    } else {
        echo "The string $testcase does not consist of all uppercase letters.\n";
    }
}
?>

This example will output :

The string AKLWC139 does not consist of all uppercase letters.
The string LMNSDO consists of all uppercase letters.
The string akwSKWsm does not consist of all uppercase letters.

See also ctype_alpha(), ctype_lower(), and setlocale().

이전 | 처음으로 | 다음
ctype_space | 위로 | ctype_xdigit


ctype_xdigit

(PHP 4 >= 4.0.4, PHP 5)

ctype_xdigit -- Check for character(s) representing a hexadecimal digit

Description

bool ctype_xdigit ( string text)

Returns TRUE if every character in text is a hexadecimal 'digit', that is a decimal digit or a character from [A-Fa-f] , FALSE otherwise.

예 1. A ctype_xdigit() example

<?php
$strings = array('AB10BC99', 'AR1012', 'ab12bc99');
foreach ($strings as $testcase) {
    if (ctype_xdigit($testcase)) {
        echo "The string $testcase consists of all hexadecimal digits.\n";
    } else {
        echo "The string $testcase does not consist of all hexadecimal digits.\n";
    }
}
?>

This example will output :

The string AB10BC99 consists of all hexadecimal digits.
The string AR1012 does not consist of all hexadecimal digits.
The string ab12bc99 consists of all hexadecimal digits.

See also ctype_digit().

이전 | 처음으로 | 다음
ctype_upper | 위로 | Database (dbm-style) Abstraction Layer Functions


Database (dbm-style) Abstraction Layer Functions

PHP 매뉴얼
이전 다음

XVI. Database (dbm-style) Abstraction Layer Functions

소개

These functions build the foundation for accessing Berkeley DB style databases.

This is a general abstraction layer for several file-based databases. As such, functionality is limited to a common subset of features supported by modern databases such as Sleepycat Software's DB2. (This is not to be confused with IBM's DB2 software, which is supported through the ODBC functions.)

요구 사항

The behaviour of various aspects depends on the implementation of the underlying database. Functions such as dba_optimize() and dba_sync() will do what they promise for one database and will do nothing for others. You have to download and install supported dba-Handlers.

표 1. List of DBA handlers

Handler | Notes
dbm | Dbm is the oldest (original) type of Berkeley DB style databases. You should avoid it, if possible. We do not support the compatibility functions built into DB2 and gdbm, because they are only compatible on the source code level, but cannot handle the original dbm format.
ndbm | Ndbm is a newer type and more flexible than dbm. It still has most of the arbitrary limits of dbm (therefore it is deprecated).
gdbm | Gdbm is the GNU database manager.
db2 | DB2 is Sleepycat Software's DB2. It is described as "a programmatic toolkit that provides high-performance built-in database support for both standalone and client/server applications.
db3 | DB3 is Sleepycat Software's DB3.
db4 | DB4 is Sleepycat Software's DB4. This is available since PHP 4.3.2.
cdb | Cdb is "a fast, reliable, lightweight package for creating and reading constant databases." It is from the author of qmail and can be found at http://cr.yp.to/cdb.html. Since it is constant, we support only reading operations. And since PHP 4.3.0 we support writing (not updating) through the internal cdb library.
cdb_make | Since PHP 4.3.0 we support creation (not updating) of cdb files when the bundled cdb library is used.
flatfile | This is available since PHP 4.3.0 for compatibility with the deprecated dbm extension only and should be avoided. However you may use this where files were created in this format. That happens when configure could not find any external library.
inifile | This is available since PHP 4.3.3 to be able to modify php.ini files from within PHP scripts. When working with ini files you can pass arrays of the form array(0=>group,1=>value_name) or strings of the form "[group]value_name" where group is optional. As the functions dba_firstkey() and dba_nextkey() return string representations of the key there is a new function dba_key_split() available since PHP 5 which allows to convert the string keys into array keys without loosing FALSE.
qdbm | This is available since PHP 5.0.0. The qdbm library can be loaded from http://qdbm.sourceforge.net.

When invoking the dba_open() or dba_popen() functions, one of the handler names must be supplied as an argument. The actually available list of handlers is displayed by invoking phpinfo() or dba_handlers().

설치

By using the --enable-dba=shared configuration option you can build a dynamic loadable module to enable PHP for basic support of dbm-style databases. You also have to add support for at least one of the following handlers by specifying the --with-XXXX configure switch to your PHP configure line.

주의

After configuring and compiling PHP you must execute the following test from commandline: php run-tests.php ext/dba. This shows whether your combination of handlers works. Most problematic are dbm and ndbm which conflict with many installations. The reason for this is that on several systems these libraries are part of more than one other library. The configuration test only prevents you from configuring malfaunctioning single handlers but not combinations.

표 2. Supported DBA handlers

Handler | Configure Switch
dbm To enable support for dbm add --with-dbm[=DIR].

참고: dbm normally is a wrapper which often results in failures. This means you should only use dbm if you are sure it works and if you really need this format.

ndbm To enable support for ndbm add --with-ndbm[=DIR].

참고: ndbm normally is a wrapper which often results in failures. This means you should only use ndbm if you are sure it works and if you really need this format.

gdbm | To enable support for gdbm add --with-gdbm[=DIR].
db2 To enable support for db2 add --with-db2[=DIR].

참고: db2 conflicts with db3 and db4.

db3 To enable support for db3 add --with-db3[=DIR].

참고: db3 conflicts with db2 and db4.

db4 To enable support for db4 add --with-db4[=DIR].

참고: db4 conflicts with db2 and db3.

참고: This was added in PHP 4.3.2. In earlier versions of PHP you need to use --with-db3=DIR with DIR being the path to db4 library. It is not possible to use db versions starting from 4.1 with PHP prior to version 4.3.0. Also, the db libraries with versions 4.1 through 4.1.24 cannot be used in any PHP version.

cdb To enable support for cdb add --with-cdb[=DIR].

참고: Since PHP 4.3.0 you can omit DIR to use the bundled cdb library that adds the cdb_make handler which allows creation of cdb files and allows to access cdb files on the network using PHP's streams.

flatfile To enable support for flatfile add --with-flatfile.

참고: This was added in PHP 4.3.0 to add compatibility with deprecated dbm extension. Use this handler only when you cannot install one of the libraries required by the other handlers and when you cannot use bundled cdb handler.

inifile To enable support for inifile add --with-inifile.

참고: This was added in PHP 5.0.0 and allows to read and set microsoft style ini files (like the php.ini file).

qdbm To enable support for qdbm add --with-qdbm[=DIR].

참고: qdbm conflicts with dbm and gdbm.

참고: This was added in PHP 5.0.0. The qdbm library can be loaded from http://qdbm.sourceforge.net.

참고: Up to PHP 4.3.0 you are able to add both db2 and db3 handler but only one of them can be used internally. That means that you cannot have both file formats. Starting with PHP 5.0.0 there is a configuration check avoid such missconfigurations.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

The functions dba_open() and dba_popen() return a handle to the specified database file to access which is used by all other dba-function calls.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

예제

예 1. DBA example

<?php

$id = dba_open("/tmp/test.db", "n", "db2");

if (!$id) {
    echo "dba_open failed\n";
    exit;
}

dba_replace("key", "This is an example!", $id);

if (dba_exists("key", $id)) {
    echo dba_fetch("key", $id);
    dba_delete("key", $id);
}

dba_close($id);
?>

DBA is binary safe and does not have any arbitrary limits. However, it inherits all limits set by the underlying database implementation.

All file-based databases must provide a way of setting the file mode of a new created database, if that is possible at all. The file mode is commonly passed as the fourth argument to dba_open() or dba_popen().

You can access all entries of a database in a linear way by using the dba_firstkey() and dba_nextkey() functions. You may not change the database while traversing it.

예 2. Traversing a database

<?php

// ...open database...

$key = dba_firstkey($id);

while ($key != false) {
    if (true) {          // remember the key to perform some action later
        $handle_later[] = $key;
    }
    $key = dba_nextkey($id);
}

for ($i = 0; $i < count($handle_later); $i++) {
    dba_delete($handle_later[$i], $id);
}

?>

차례
dba_close -- Close database
dba_delete -- Delete entry specified by key
dba_exists -- Check whether key exists
dba_fetch -- Fetch data specified by key
dba_firstkey -- Fetch first key
dba_handlers -- List handlers available
dba_insert -- Insert entry
dba_key_split -- Splits a key in string representation into array representation
dba_list -- List all open database files
dba_nextkey -- Fetch next key
dba_open -- Open database
dba_optimize -- Optimize database
dba_popen -- Open database persistently
dba_replace -- Replace or insert entry
dba_sync -- Synchronize database

이전 | 처음으로 | 다음
ctype_xdigit | 위로 | dba_close


dba_close

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

dba_close -- Close database

Description

void dba_close ( resource handle)

dba_close() closes the established database and frees all resources specified by handle.

handle is a database handle returned by dba_open().

dba_close() does not return any value.

See also: dba_open() and dba_popen()

이전 | 처음으로 | 다음
Database (dbm-style) Abstraction Layer Functions | 위로 | dba_delete


dba_delete

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

dba_delete -- Delete entry specified by key

Description

bool dba_delete ( string key, resource handle)

dba_delete() deletes the entry specified by key from the database specified with handle.

key is the key of the entry which is deleted.

handle is a database handle returned by dba_open().

dba_delete() returns TRUE or FALSE, if the entry is deleted or not deleted, respectively.

See also: dba_exists(),
dba_fetch(), dba_insert(),
and dba_replace().

이전 | 처음으로 | 다음
dba_close | 위로 | dba_exists


dba_exists

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

dba_exists -- Check whether key exists

Description

bool dba_exists ( string key, resource handle)

dba_exists() checks whether the specified key exists in the database specified by handle.

Key is the key the check is performed for.

Handle is a database handle returned by dba_open().

dba_exists() returns TRUE or FALSE, if the key is found or not found, respectively.

See also: dba_fetch(),
dba_delete(), dba_insert(),
and dba_replace().

이전 | 처음으로 | 다음
dba_delete | 위로 | dba_fetch


dba_fetch

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

dba_fetch -- Fetch data specified by key

Description

string dba_fetch ( string key, resource handle)

string dba_fetch ( string key, int skip, resource handle)

dba_fetch() fetches the data specified by key from the database specified with handle.

Key is the key the data is specified by.

Skip is the number of key-value pairs to ignore when using cdb databases. This value is ignored for all other databases which do not support multiple keys with the same name.

Handle is a database handle returned by dba_open().

dba_fetch() returns the associated string or FALSE, if the key/data pair is found or not found, respectively.

See also: dba_exists(),
dba_delete(), dba_insert(),
dba_replace() and dba_key_split().

참고: The skip parameter is available since PHP 4.3 to support cdb's capability of multiple keys having the same name.

참고: When working with inifiles this function accepts arrays as keys where index 0 is the group and index 1 is the value name. See: dba_key_split().

이전 | 처음으로 | 다음
dba_exists | 위로 | dba_firstkey


dba_firstkey

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

dba_firstkey -- Fetch first key

Description

string dba_firstkey ( resource handle)

dba_firstkey() returns the first key of the database specified by handle and resets the internal key pointer. This permits a linear search through the whole database.

Handle is a database handle returned by dba_open().

dba_firstkey() returns the key or FALSE depending on whether it succeeds or fails, respectively.

See also: dba_firstkey(), dba_key_split() and example 2 in the DBA examples

이전 | 처음으로 | 다음
dba_fetch | 위로 | dba_handlers


dba_handlers

(PHP 4 >= 4.3.0, PHP 5)

dba_handlers -- List handlers available

Description

array dba_handlers ( void )

dba_handlers() returns an array with all handlers supported by this extension.

When the internal cdb library is used you will see 'cdb' and 'cdb_make'.

이전 | 처음으로 | 다음
dba_firstkey | 위로 | dba_insert


dba_insert

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

dba_insert -- Insert entry

Description

bool dba_insert ( string key, string value, resource handle)

dba_insert() inserts the entry described with key and value into the database specified by handle. It fails, if an entry with the same key already exists.

key is the key of the entry to be inserted.

value is the value to be inserted.

handle is a database handle returned by dba_open().

dba_insert() returns TRUE or FALSE, depending on whether it succeeds of fails, respectively.

See also:
dba_exists()
dba_delete()
dba_fetch()
dba_replace()

이전 | 처음으로 | 다음
dba_handlers | 위로 | dba_key_split


dba_key_split

(PHP 5)

dba_key_split -- Splits a key in string representation into array representation

Description

mixed dba_key_split ( mixed key)

dba_key_split() returns an array of the form array(0=>group,1=>value_name). This function will return FALSE if key is NULL or FALSE.

key is the key in string representation.

See also
dba_firstkey(),
dba_nextkey() and
dba_fetch().

이전 | 처음으로 | 다음
dba_insert | 위로 | dba_list


dba_list

(PHP 4 >= 4.3.0, PHP 5)

dba_list -- List all open database files

Description

array dba_list ( void )

dba_list() returns an associative array with all open database files. This array is in the form: resourceid=>filename.

이전 | 처음으로 | 다음
dba_key_split | 위로 | dba_nextkey


dba_nextkey

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

dba_nextkey -- Fetch next key

Description

string dba_nextkey ( resource handle)

dba_nextkey() returns the next key of the database specified by handle and advances the internal key pointer.

handle is a database handle returned by dba_open().

dba_nextkey() returns the key or FALSE depending on whether it succeeds or fails, respectively.

See also: dba_firstkey(), dba_key_split() and example 2 in the DBA examples

이전 | 처음으로 | 다음
dba_list | 위로 | dba_open


dba_open

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

dba_open -- Open database

Description

resource dba_open ( string path, string mode, string handler [, ...])

dba_open() establishes a database instance for path with mode using handler.

path is commonly a regular path in your filesystem.

mode is "r" for read access, "w" for read/write access to an already existing database, "c" for read/write access and database creation if it doesn't currently exist, and "n" for create, truncate and read/write access. Additional you can set the database lock method with the next char. Use "l" to lock the database with an .lck file or "d" to lock the databasefile itself. It is important that all of your applications do this consistently. If you want to test the access and do not want to wait for the lock you can add "t" as third character. When you are absolutely sure that you do not require database locking you can do so by using "-" instead of "l" or "d". When none of "d", "l" or "-" is used dba will lock on the database file as it would with "d".

handler is the name of the handler which shall be used for accessing path. It is passed all optional parameters given to dba_open() and can act on behalf of them.

dba_open() returns a positive handle or FALSE, in the case the database was opened successfull or fails, respectively.

참고: There can only be one writer for one database file. When you use dba on a webserver and more than one request requires write operations they can only be done one after another. Also read during write is not allowed. The dba extension uses locks to prevent this. See the following table:

표 1. DBA locking

already open | mode = "rl" | mode = "rlt" | mode = "wl" | mode = "wlt" | mode = "rd" | mode = "rdt" | mode = "wd" | mode = "wdt"
not open | ok | ok | ok | ok | ok | ok | ok | ok
mode = "rl" | ok | ok | wait | false | illegal | illegal | illegal | illegal
mode = "wl" | wait | false | wait | false | illegal | illegal | illegal | illegal
mode = "rd" | illegal | illegal | illegal | illegal | ok | ok | wait | false
mode = "wd" | illegal | illegal | illegal | illegal | wait | false | wait | false

ok: the second call will be successfull.
wait: the second call waits until dba_close() is called for the first.
false: the second call returns false.
illegal: you must not mix "l" and "d" modifiers for mode parameter.

참고: Since PHP 4.3.0 it is possible to open database files over network connection. However in cases a socket connection will be used (as with http or ftp) the connection will be locked instead of the resource itself. This is important to know since in such cases locking is simply ignored on the resource and other solutions have to be found.

참고: Locking and the mode modifiers "l", "d", "-" and "t" were added in PHP 4.3.0. In PHP versions before PHP 4.3.0 you must use semaphores to guard against simultaneous database access for any database handler with the exception of GDBM. See System V semaphore support.

참고: Up to PHP 4.3.5 open mode 'c' is broken for several internal handlers and truncates the database instead of appending data to an existant database. Also dbm and ndbm fail on mode 'c' in typical configurations (this cannot be fixed).

See also: dba_popen() dba_close()

이전 | 처음으로 | 다음
dba_nextkey | 위로 | dba_optimize


dba_optimize

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

dba_optimize -- Optimize database

Description

bool dba_optimize ( resource handle)

dba_optimize() optimizes the underlying database specified by handle.

handle is a database handle returned by dba_open().

dba_optimize() returns TRUE or FALSE, if the optimization succeeds or fails, respectively.

See also: dba_sync()

이전 | 처음으로 | 다음
dba_open | 위로 | dba_popen


dba_popen

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

dba_popen -- Open database persistently

Description

resource dba_popen ( string path, string mode, string handler [, ...])

dba_popen() establishes a persistent database instance for path with mode using handler.

path is commonly a regular path in your filesystem.

mode is "r" for read access, "w" for read/write access to an already existing database, "c" for read/write access and database creation if it doesn't currently exist, and "n" for create, truncate and read/write access.

handler is the name of the handler which shall be used for accessing path. It is passed all optional parameters given to dba_popen() and can act on behalf of them.

dba_popen() returns a positive handle or FALSE, in the case the open is successful or fails, respectively.

See also: dba_open() dba_close()

이전 | 처음으로 | 다음
dba_optimize | 위로 | dba_replace


dba_replace

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

dba_replace -- Replace or insert entry

Description

bool dba_replace ( string key, string value, resource handle)

dba_replace() replaces or inserts the entry described with key and value into the database specified by handle.

key is the key of the entry to be inserted.

value is the value to be inserted.

handle is a database handle returned by dba_open().

dba_replace() returns TRUE or FALSE, depending on whether it succeeds of fails, respectively.

See also: dba_exists(),
dba_delete(), dba_fetch(),
and dba_insert().

이전 | 처음으로 | 다음
dba_popen | 위로 | dba_sync


dba_sync

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

dba_sync -- Synchronize database

Description

bool dba_sync ( resource handle)

dba_sync() synchronizes the database specified by handle. This will probably trigger a physical write to disk, if supported.

handle is a database handle returned by dba_open().

dba_sync() returns TRUE or FALSE, if the synchronization succeeds or fails, respectively.

See also: dba_optimize()

이전 | 처음으로 | 다음
dba_replace | 위로 | 날짜와 시간 함수


날짜와 시간 함수

PHP 매뉴얼
이전 다음

XVII. 날짜와 시간 함수

소개

이 함수들은 PHP가 실행되고 있는 서버로부터 날짜와 시간을 얻을 수 있게 합니다. 여러가지 다른 방법으로 날짜와 시간 출력을 형식화할 수 있습니다.

참고: 이 함수들은 서버의 지역설정에 의존한다는 점을 명심하십시오. 특히 윤년과 일광 절약 시간을 생각해서 작업하십시오.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
checkdate -- 그레고리안력 날짜를 확인합니다.
date -- 로컬 날짜/시간을 형식화합니다.
getdate -- 날짜/시간 정보를 가져온다
gettimeofday -- Get current time
gmdate -- Format a GMT/UTC date/time
gmmktime -- Get Unix timestamp for a GMT date
gmstrftime -- Format a GMT/UTC time/date according to locale settings
localtime -- Get the local time
microtime -- Return current Unix timestamp with microseconds
mktime -- Get Unix timestamp for a date
strftime -- Format a local time/date according to locale settings
strtotime -- Parse about any English textual datetime description into a Unix timestamp
time -- Return current Unix timestamp

이전 | 처음으로 | 다음
dba_sync | 위로 | checkdate


checkdate

(PHP 3, PHP 4 , PHP 5)

checkdate -- 그레고리안력 날짜를 확인합니다.

설명

bool checkdate ( int month, int day, int year)

주어진 날짜가 유효하면 TRUE를, 유효하지 않으면 FALSE를 반환합니다. 각 인자가 구성하는 날짜의 유효성을 확인합니다. 다음과 같은 날짜가 유효합니다.

  • year는 1 이상 32767 이하

  • month는 1 이상 12 이하

  • Day는 주어진 month가 허용하는 일수입니다. 윤년 (Leaf year)도 고려합니다.

예 1. checkdate() 예제

<?php
var_dump(checkdate(12, 31, 2000));
var_dump(checkdate(2, 29, 2001));
?>

위 예제의 출력:

bool(true);
bool(false);

참고: mktime(), strtotime().

이전 | 처음으로 | 다음
날짜와 시간 함수 | 위로 | date


date

(PHP 3, PHP 4 , PHP 5)

date -- 로컬 날짜/시간을 형식화합니다.

설명

string date ( string format [, int timestamp])

정수형으로 주어지는 timestamp나, timestamp가 주어지지 않았을 경우에는 현재 로컬 시간을 사용하여, 주어진 포맷 문자열에 따라 형식화한 문자열을 반환합니다. 즉 timestamp는 선택적이고, 기본값은 time()의 값입니다.

참고: 전형적인 timestamp의 유효 범위는 1901년 12월 13일 금요일 20:45:54 GMT부터 2038년 1월 19일 화요일 03:14:07 GMT입니다. (이것은 부호 있는 32비트 정수형의 최소와 최대값에 대응합니다. 윈도우즈에서는 이 값은 1970-01-01부터 2038-01-19로 제한됩니다)

참고: 날짜를 표시하는 문자열로부터 timestamp를 생성하기 위해서, strtotime()을 사용할 수 있습니다. 또한, 몇몇 데이터베이스는 각자의 날짜 형식으로에서 timestamp로 변환하는 함수를 가지고 있습니다. (예: MySQL의 UNIX_TIMESTAMP 함수)

표 1. 다음 문자들은 format 인자 문자열로 인식합니다.

format 문자 | 설명 | 반환값 예
a | 오전과 오후, 소문자 | am, pm
A | 오전과 오후, 대문자 | AM, PM
B | 스왓치 인터넷 시간 | 000부터 999
c | ISO 8601 날짜 (PHP 5에서 추가) | 2004-02-12T15:19:21+00:00
d | 일, 앞에 0이 붙는 2자리 | 01부터 31
D | 요일, 3글자 문자 | Mon부터 Sun
F | 월, January, March 등의 완전한 문자 표현 | January부터 December
g | 시, 0이 붙지 않는 12시간 형식 | 1부터 12
G | 시, 0이 붙지 않는 24시간 형식 | 0부터 23
h | 시, 0이 붙는 12시간 형식 | 01부터 12
H | 시, 0이 붙는 24시간 형식 | 00부터 23
i | 분, 0이 붙는 형식 | 00부터 59
I (대문자 i) | 일광 절약 시간 여부 | 일광 절약 시간이면 1, 아니면 0
j | 일, 0이 붙지 않는 형식 | 1부터 31
l (소문자 'L') | 요일, 완전한 문자 표현 | Sunday부터 Saturday
L | 윤년인지 여부 | 윤년이면 1, 아니면 0
m | 월, 숫자 표현, 0이 붙는 형식 | 01부터 12
M | 월, 짧은 문자 표현, 3문자 | Jan부터 Dec
n | 월, 숫자 표현, 0이 붙지 않는 형식 | 1부터 12
O | 그리니치 시간(GMT)과의 차이 | 예: +0200
r | RFC 2822 형식 날짜 | 예: Thu, 21 Dec 2000 16:01:07 +0200
s | 초, 0이 붙는 형식 | 00 부터 59
S | 일 표현을 위한 영어 서수 접미어, 2문자 | st, nd, rd나 th. j와 잘 작동합니다.
t | 주어진 월의 일수 | 28부터 31
T | 이 기계의 표준 시간대 설정 | 예: EST, MDT ...
U | 유닉스 Epoch(January 1 1970 00:00:00 GMT)로부터의 초 | time() 참고
w | 요일, 숫자형 | 0(일요일)부터 6(토요일)
W | ISO-8601 연도의 주차, 주는 월요일에 시작 (PHP 4.1.0에서 추가) | 예: 42 (연도의 42번째 주)
Y | 연도, 4 자리수 표현 | 예: 1999, 2003
y | 연도, 2 자리수 표현 | 예: 99, 03
z | 연도의 일차 (0부터 시작) | 0부터 365
Z | 표준 시간대의 오프셋 초. UTC로부터 서쪽의 오프셋은 항상 음수이고, UTC로부터 동쪽의 오프셋은 항상 양수. | -43200부터 43200

format 문자열로 인식되지 않는 문자는 그대로 출력합니다. Z 형식은 gmdate()를 이용할 때는 항상 0을 반환합니다.

예 1. date() 예제코드

<?php
// 다음의 출력: Wednesday
echo date("l");

// 다음의 출력: Wednesday 15th of January 2003 05:51:38 AM
echo date("l dS of F Y h:i:s A");

// 출력: July 1, 2000 is on a Saturday
echo "July 1, 2000 is on a " . date("l", mktime(0, 0, 0, 7, 1, 2000));
?>

format 문자열로 인식하는 문자 바로 앞에 백슬래쉬를 붙여서 이스케이프를 함으로써, 인식하는 것 막을 수 있습니다. 백슬래쉬가 붙는 문자가 이미 특별한 의미를 가지고 있다면, 백슬래쉬를 이스케이프해야 합니다.

예 2. date()의 회피 문자

<?php
// 다음의 출력: Wednesday the 15th
echo date("l \\t\h\e jS");
?>

date()와 mktime()을 함께 사용함으로써 미래나 과거의 시간을 얻을 수 있습니다.

예 3. date() 와 mktime() 예제코드

<?php
$tomorrow  = mktime (0,0,0,date("m")  , date("d")+1, date("Y"));
$lastmonth = mktime (0,0,0,date("m")-1, date("d"),   date("Y"));
$nextyear  = mktime (0,0,0,date("m"),   date("d"),   date("Y")+1);
?>

참고: 이는 일광 절약 시간을 고려하기 때문에, 단순히 timestamp에 하루나 한달에 해당하는 초를 더하는 것보다 신뢰할 수 있습니다.

date() 형식화의 몇몇 예제. 모든 다른 문자들도 이스케이프 해야함에 주의하십시오. 현재 특별한 의미를 가진 어떤 것이 바람직하지 못한 결과를 가져올 수 있고, 앞으로의 PHP 버전에서는 다른 문자들도 지정될 수가 있습니다. 이스케이프 할 때는, \n이 줄바꿈으로 인식 되는 것과 같은 예을 피하기 위해서는 작은 따옴표를 사용해야만 합니다.

예 4. date() 형식화

<?php
// Assuming today is: March 10th, 2001, 5:16:18 pm

$today = date("F j, Y, g:i a");                 // March 10, 2001, 5:16 pm
$today = date("m.d.y");                         // 03.10.01
$today = date("j, n, Y");                       // 10, 3, 2001
$today = date("Ymd");                           // 20010310
$today = date('h-i-s, j-m-y, it is w Day z ');  // 05-16-17, 10-03-01, 1631 1618 6 Fripm01
$today = date('\i\t \i\s \t\h\e jS \d\a\y.');   // It is the 10th day.
$today = date("D M j G:i:s T Y");               // Sat Mar 10 15:16:08 MST 2001
$today = date('H:m:s \m \i\s\ \m\o\n\t\h');     // 17:03:17 m is month
$today = date("H:i:s");                         // 17:16:17
?>

다른 언어로 날짜를 형식화 하기 위해서는, setlocale()과 strftime() 함수를 사용해야 합니다.

참고: getlastmod(), gmdate(),
mktime(), strftime(),
time().

이전 | 처음으로 | 다음
checkdate | 위로 | getdate


getdate

(PHP 3, PHP 4 , PHP 5)

getdate -- 날짜/시간 정보를 가져온다

설명

array getdate ( [int timestamp])

timestamp의 날짜 정보를 포함하는 연관 배열이나, timestamp가 주어지지 않는다면 현재 로컬 시간를 반환한다. 다음과 같은 배열 원소로 반환된다.

표 1. 반환되는 연관 배열의 키 원소들

키 | 설명 | Example returned values
"seconds" | 초의 숫자 표현 | 0 부터 59
"minutes" | 분의 숫자 표현 | 0 부터 59
"hours" | 시간의 숫자 표현 | 0 부터 23
"mday" | 일의 숫자 표현 | 1 부터 31
"wday" | 요일의 숫자 표현 | 0 (일요일) 부터 6 (토요일)
"mon" | 월의 숫자 표현 | 1 부터 12
"year" | 연도의 숫자표현, 4 자리 | Examples: 1999 또는 2003
"yday" | 연도의 일차 | 0 부터 366
"weekday" | 요일, 완전한 문자 | Sunday 부터 Saturday
"month" | 월, 완전한 문자, January 나 March | January 부터 December
0 | 유닉스 Epoch (January 1 1970 00:00:00 GMT)로부터의 초, time()에 의해 반환되는 값과 유사하고, date()에 의해서 사용된다. | 시스템 의존적이다, 일반적으로 -2147483648 부터 2147483647.

예 1. getdate() 예제코드

<?php
$today = getdate();
print_r($today);
?>

출력은 다음과 같을것이다:

Array
(
    [seconds] => 40
    [minutes] => 58
    [hours]   => 21
    [mday]    => 17
    [wday]    => 2
    [mon]     => 6
    [year]    => 2003
    [yday]    => 167
    [weekday] => Tuesday
    [month]   => June
    [0]       => 1055901520
)

참고: date(),
time(),
setlocale().

이전 | 처음으로 | 다음
date | 위로 | gettimeofday


gettimeofday

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

gettimeofday -- Get current time

Description

array gettimeofday ( void )

This is an interface to gettimeofday(2). It returns an associative array containing the data returned from the system call.

  • "sec" - seconds

  • "usec" - microseconds

  • "minuteswest" - minutes west of Greenwich

  • "dsttime" - type of dst correction

예 1. gettimeofday() example

<?php
print_r(gettimeofday());
?>

The output will look similar to:

Array
(
    [sec] => 1073504408
    [usec] => 238215
    [minuteswest] => 0
    [dsttime] => 1
)

이전 | 처음으로 | 다음
getdate | 위로 | gmdate


gmdate

(PHP 3, PHP 4 , PHP 5)

gmdate -- Format a GMT/UTC date/time

Description

string gmdate ( string format [, int timestamp])

Identical to the date() function except that the time returned is Greenwich Mean Time (GMT). For example, when run in Finland (GMT +0200), the first line below prints "Jan 01 1998 00:00:00", while the second prints "Dec 31 1997 22:00:00".

예 1. gmdate() example

<?php
echo date("M d Y H:i:s", mktime(0, 0, 0, 1, 1, 1998));
echo gmdate("M d Y H:i:s", mktime(0, 0, 0, 1, 1, 1998));
?>

참고: In the Microsoft Windows series of Operating Systems the system libraries implementing this function are broken, so gmdate() does not support negative values for the timestamp. For details see bug reports: #22620, #22457, and #14391.

This problem does not occur in Unix/Linux Operating Systems, as the system libraries behave as expected.

PHP cannot fix broken system libraries. Contact your OS vendor for a fix to this and similar problems.

See also date(), mktime(), gmmktime() and strftime().

이전 | 처음으로 | 다음
gettimeofday | 위로 | gmmktime


gmmktime

(PHP 3, PHP 4 , PHP 5)

gmmktime -- Get Unix timestamp for a GMT date

Description

int gmmktime ( [int hour [, int minute [, int second [, int month [, int day [, int year [, int is_dst]]]]]]])

Identical to mktime() except the passed parameters represents a GMT date.

Like mktime(), arguments may be left out in order from right to left, with any omitted arguments being set to the current corresponding GMT value.

이전 | 처음으로 | 다음
gmdate | 위로 | gmstrftime


gmstrftime

(PHP 3>= 3.0.12, PHP 4 , PHP 5)

gmstrftime -- Format a GMT/UTC time/date according to locale settings

Description

string gmstrftime ( string format [, int timestamp])

Behaves the same as strftime() except that the time returned is Greenwich Mean Time (GMT). For example, when run in Eastern Standard Time (GMT -0500), the first line below prints "Dec 31 1998 20:00:00", while the second prints "Jan 01 1999 01:00:00".

예 1. gmstrftime() example

<?php
setlocale(LC_TIME, 'en_US');
echo strftime("%b %d %Y %H:%M:%S", mktime(20, 0, 0, 12, 31, 98)) . "\n";
echo gmstrftime("%b %d %Y %H:%M:%S", mktime(20, 0, 0, 12, 31, 98)) . "\n";
?>

See also strftime().

이전 | 처음으로 | 다음
gmmktime | 위로 | localtime


localtime

(PHP 4 , PHP 5)

localtime -- Get the local time

Description

array localtime ( [int timestamp [, bool is_associative]])

The localtime() function returns an array identical to that of the structure returned by the C function call. The first argument to localtime() is the timestamp, if this is not given the current time as returned from time() is used. The second argument to the localtime() is the is_associative, if this is set to 0 or not supplied than the array is returned as a regular, numerically indexed array. If the argument is set to 1 then localtime() is an associative array containing all the different elements of the structure returned by the C function call to localtime. The names of the different keys of the associative array are as follows:

  • "tm_sec" - seconds

  • "tm_min" - minutes

  • "tm_hour" - hour

  • "tm_mday" - day of the month

  • "tm_mon" - month of the year, starting with 0 for January

  • "tm_year" - Years since 1900

  • "tm_wday" - Day of the week

  • "tm_yday" - Day of the year

  • "tm_isdst" - Is daylight savings time in effect

이전 | 처음으로 | 다음
gmstrftime | 위로 | microtime


microtime

(PHP 3, PHP 4 , PHP 5)

microtime -- Return current Unix timestamp with microseconds

Description

mixed microtime ( [bool get_as_float])

microtime() returns the current Unix timestamp with microseconds. This function is only available on operating systems that support the gettimeofday() system call.

When called without the optional argument, this function returns the string "msec sec" where sec is the current time measured in the number of seconds since the Unix Epoch (0:00:00 January 1, 1970 GMT), and msec is the microseconds part. Both portions of the string are returned in units of seconds.

When get_as_float is given, and evaluates to TRUE, microtime() will return a float.

참고: The get_as_float parameter was added as of PHP 5.0.0.

예 1. microtime() example

<?php

function getmicrotime()
{
    list($usec, $sec) = explode(" ", microtime());
    return ((float)$usec + (float)$sec);
}

$time_start = getmicrotime();

for ($i=0; $i < 1000; $i++) {
    // do nothing, 1000 times
}

$time_end = getmicrotime();
$time = $time_end - $time_start;

echo "Did nothing in $time seconds\n";

// with PHP 5 you can do the same this way:

$time_start = microtime(1);

for ($i=0; $i < 1000; $i++) {
     // do nothing, 1000 times
}

$time_end = microtime(1);
$time = $time_end - $time_start;

echo "Did nothing in $time seconds\n";

?>

See also time().

이전 | 처음으로 | 다음
localtime | 위로 | mktime


mktime

(PHP 3, PHP 4 , PHP 5)

mktime -- Get Unix timestamp for a date

Description

int mktime ( [int hour [, int minute [, int second [, int month [, int day [, int year [, int is_dst]]]]]]])

Warning: Note the strange order of arguments, which differs from the order of arguments in a regular Unix mktime() call and which does not lend itself well to leaving out parameters from right to left (see below). It is a common error to mix these values up in a script.

Returns the Unix timestamp corresponding to the arguments given. This timestamp is a long integer containing the number of seconds between the Unix Epoch (January 1 1970) and the time specified.

Arguments may be left out in order from right to left; any arguments thus omitted will be set to the current value according to the local date and time.

is_dst can be set to 1 if the time is during daylight savings time, 0 if it is not, or -1 (the default) if it is unknown whether the time is within daylight savings time or not. If it's unknown, PHP tries to figure it out itself. This can cause unexpected (but not incorrect) results.

참고: is_dst was added in 3.0.10.

mktime() is useful for doing date arithmetic and validation, as it will automatically calculate the correct value for out-of-range input. For example, each of the following lines produces the string "Jan-01-1998".

예 1. mktime() example

<?php
echo date("M-d-Y", mktime(0, 0, 0, 12, 32, 1997));
echo date("M-d-Y", mktime(0, 0, 0, 13, 1, 1997));
echo date("M-d-Y", mktime(0, 0, 0, 1, 1, 1998));
echo date("M-d-Y", mktime(0, 0, 0, 1, 1, 98));
?>
Year may be a two or four digit value, with values between 0-69 mapping to 2000-2069 and 70-99 to 1970-1999 (on systems where time_t is a 32bit signed integer, as most common today, the valid range for year is somewhere between 1901 and 2038).

Windows: Negative timestamps are not supported under any known version of Windows. Therefore the range of valid years includes only 1970 through 2038.

The last day of any given month can be expressed as the "0" day of the next month, not the -1 day. Both of the following examples will produce the string "The last day in Feb 2000 is: 29".

예 2. Last day of next month

<?php
$lastday = mktime(0, 0, 0, 3, 0, 2000);
echo strftime("Last day in Feb 2000 is: %d", $lastday);

$lastday = mktime(0, 0, 0, 4, -31, 2000);
echo strftime("Last day in Feb 2000 is: %d", $lastday);
?>

Date with year, month and day equal to zero is considered illegal (otherwise it what be regarded as 30.11.1999, which would be strange behavior).

See also date() and time().

이전 | 처음으로 | 다음
microtime | 위로 | strftime


strftime

(PHP 3, PHP 4 , PHP 5)

strftime -- Format a local time/date according to locale settings

Description

string strftime ( string format [, int timestamp])

Returns a string formatted according to the given format string using the given timestamp or the current local time if no timestamp is given. Month and weekday names and other language dependent strings respect the current locale set with setlocale().

The following conversion specifiers are recognized in the format string:

  • %a - abbreviated weekday name according to the current locale

  • %A - full weekday name according to the current locale

  • %b - abbreviated month name according to the current locale

  • %B - full month name according to the current locale

  • %c - preferred date and time representation for the current locale

  • %C - century number (the year divided by 100 and truncated to an integer, range 00 to 99)

  • %d - day of the month as a decimal number (range 01 to 31)

  • %D - same as %m/%d/%y

  • %e - day of the month as a decimal number, a single digit is preceded by a space (range ' 1' to '31')

  • %g - like %G, but without the century.

  • %G - The 4-digit year corresponding to the ISO week number (see %V). This has the same format and value as %Y, except that if the ISO week number belongs to the previous or next year, that year is used instead.

  • %h - same as %b

  • %H - hour as a decimal number using a 24-hour clock (range 00 to 23)

  • %I - hour as a decimal number using a 12-hour clock (range 01 to 12)

  • %j - day of the year as a decimal number (range 001 to 366)

  • %m - month as a decimal number (range 01 to 12)

  • %M - minute as a decimal number

  • %n - newline character

  • %p - either `am' or `pm' according to the given time value, or the corresponding strings for the current locale

  • %r - time in a.m. and p.m. notation

  • %R - time in 24 hour notation

  • %S - second as a decimal number

  • %t - tab character

  • %T - current time, equal to %H:%M:%S

  • %u - weekday as a decimal number [1,7], with 1 representing Monday

    주의

    Sun Solaris seems to start with Sunday as 1 although ISO 9889:1999 (the current C standard) clearly specifies that it should be Monday.

  • %U - week number of the current year as a decimal number, starting with the first Sunday as the first day of the first week

  • %V - The ISO 8601:1988 week number of the current year as a decimal number, range 01 to 53, where week 1 is the first week that has at least 4 days in the current year, and with Monday as the first day of the week. (Use %G or %g for the year component that corresponds to the week number for the specified timestamp.)

  • %W - week number of the current year as a decimal number, starting with the first Monday as the first day of the first week

  • %w - day of the week as a decimal, Sunday being 0

  • %x - preferred date representation for the current locale without the time

  • %X - preferred time representation for the current locale without the date

  • %y - year as a decimal number without a century (range 00 to 99)

  • %Y - year as a decimal number including the century

  • %Z - time zone or name or abbreviation

  • %% - a literal `%' character

참고: Not all conversion specifiers may be supported by your C library, in which case they will not be supported by PHP's strftime(). Additionally, not all platforms support negative timestamps, therefore your date range may be limited to no earlier than the Unix epoch. This means that e.g. %e, %T, %R and %D (there might be more) and dates prior to Jan 1, 1970 will not work on Windows, some Linux distributions, and a few other operating systems. For Windows systems a complete overview of supported conversion specifiers can be found at this MSDN website.

예 1. strftime() locale examples

<?php
setlocale(LC_TIME, "C");
echo strftime("%A");
setlocale(LC_TIME, "fi_FI");
echo strftime(" in Finnish is %A,");
setlocale(LC_TIME, "fr_FR");
echo strftime(" in French %A and");
setlocale(LC_TIME, "de_DE");
echo strftime(" in German %A.\n");
?>
This example works if you have the respective locales installed in your system.

참고: %G and %V, which are based on ISO 8601:1988 week numbers can give unexpected (albeit correct) results if the numbering system is not thoroughly understood. See %V above and example below.

예 2. ISO 8601:1988 week number example

<?php
/*     December 2002 / January 2003
ISOWk  M   Tu  W   Thu F   Sa  Su
----- ----------------------------
51     16  17  18  19  20  21  22
52     23  24  25  26  27  28  29
1      30  31   1   2   3   4   5
2       6   7   8   9  10  11  12
3      13  14  15  16  17  18  19   */

// Outputs: 12/28/2002 - %V,%G,%Y = 52,2002,2002
echo "12/28/2002 - %V,%G,%Y = " . strftime("%V,%G,%Y", strtotime("12/28/2002")) . "\n";

// Outputs: 12/30/2002 - %V,%G,%Y = 1,2003,2002
echo "12/30/2002 - %V,%G,%Y = " . strftime("%V,%G,%Y", strtotime("12/30/2002")) . "\n";

// Outputs: 1/3/2003 - %V,%G,%Y = 1,2003,2003
echo "1/3/2003 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/3/2003")) . "\n";

// Outputs: 1/10/2003 - %V,%G,%Y = 2,2003,2003
echo "1/10/2003 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/10/2003")) . "\n";

/*     December 2004 / January 2005
ISOWk  M   Tu  W   Thu F   Sa  Su
----- ----------------------------
51     13  14  15  16  17  18  19
52     20  21  22  23  24  25  26
53     27  28  29  30  31   1   2
1       3   4   5   6   7   8   9
2      10  11  12  13  14  15  16   */

// Outputs: 12/23/2004 - %V,%G,%Y = 52,2004,2004
echo "12/23/2004 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("12/23/2004")) . "\n";

// Outputs: 12/31/2004 - %V,%G,%Y = 53,2004,2004
echo "12/31/2004 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("12/31/2004")) . "\n";

// Outputs: 1/2/2005 - %V,%G,%Y = 53,2004,2005
echo "1/2/2005 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/2/2005")) . "\n";

// Outputs: 1/3/2005 - %V,%G,%Y = 1,2005,2005
echo "1/3/2005 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/3/2005")) . "\n";

?>

See also setlocale(), mktime(), and the Open Group specification of strftime().

이전 | 처음으로 | 다음
mktime | 위로 | strtotime


strtotime

(PHP 3>= 3.0.12, PHP 4 , PHP 5)

strtotime -- Parse about any English textual datetime description into a Unix timestamp

Description

int strtotime ( string time [, int now])

The function expects to be given a string containing an English date format and will try to parse that format into a Unix timestamp relative to the timestamp given in now, or the current time if none is supplied. Upon failure, -1 is returned.

Because strtotime() behaves according to GNU date syntax, have a look at the GNU manual page titled Date Input Formats. Described there is valid syntax for the time parameter.

예 1. strtotime() examples

<?php
echo strtotime("now"), "\n";
echo strtotime("10 September 2000"), "\n";
echo strtotime("+1 day"), "\n";
echo strtotime("+1 week"), "\n";
echo strtotime("+1 week 2 days 4 hours 2 seconds"), "\n";
echo strtotime("next Thursday"), "\n";
echo strtotime("last Monday"), "\n";
?>

예 2. Checking for failure

<?php
$str = 'Not Good';
if (($timestamp = strtotime($str)) === -1) {
    echo "The string ($str) is bogus";
} else {
    echo "$str == " . date('l dS of F Y h:i:s A', $timestamp);
}
?>

참고: The valid range of a timestamp is typically from Fri, 13 Dec 1901 20:45:54 GMT to Tue, 19 Jan 2038 03:14:07 GMT. (These are the dates that correspond to the minimum and maximum values for a 32-bit signed integer.) Additionally, not all platforms support negative timestamps, therefore your date range may be limited to no earlier than the Unix epoch. This means that e.g. dates prior to Jan 1, 1970 will not work on Windows, some Linux distributions, and a few other operating systems.

이전 | 처음으로 | 다음
strftime | 위로 | time


time

(PHP 3, PHP 4 , PHP 5)

time -- Return current Unix timestamp

Description

int time ( void )

Returns the current time measured in the number of seconds since the Unix Epoch (January 1 1970 00:00:00 GMT).

See also date() and microtime().

이전 | 처음으로 | 다음
strtotime | 위로 | dBase Functions


dBase Functions

PHP 매뉴얼
이전 다음

XVIII. dBase Functions

소개

These functions allow you to access records stored in dBase-format (dbf) databases.

There is no support for indexes or memo fields. There is no support for locking, too. Two concurrent webserver processes modifying the same dBase file will very likely ruin your database.

dBase files are simple sequential files of fixed length records. Records are appended to the end of the file and delete records are kept until you call dbase_pack().

We recommend that you do not use dBase files as your production database. Choose any real SQL server instead; MySQL or Postgres are common choices with PHP. dBase support is here to allow you to import and export data to and from your web database, because the file format is commonly understood by Windows spreadsheets and organizers.

설치

In order to enable the bundled dbase library and to use these functions, you must compile PHP with the --enable-dbase option.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
dbase_add_record -- Add a record to a dBase database
dbase_close -- Close a dBase database
dbase_create -- Creates a dBase database
dbase_delete_record -- Deletes a record from a dBase database
dbase_get_header_info -- Get the header info of a dBase database
dbase_get_record_with_names -- Gets a record from a dBase database as an associative array
dbase_get_record -- Gets a record from a dBase database
dbase_numfields -- Find out how many fields are in a dBase database
dbase_numrecords -- Find out how many records are in a dBase database
dbase_open -- Opens a dBase database
dbase_pack -- Packs a dBase database
dbase_replace_record -- Replace a record in a dBase database

이전 | 처음으로 | 다음
time | 위로 | dbase_add_record


dbase_add_record

(PHP 3, PHP 4 , PHP 5)

dbase_add_record -- Add a record to a dBase database

Description

bool dbase_add_record ( int dbase_identifier, array record)

Adds the data in the record to the database. If the number of items in the supplied record isn't equal to the number of fields in the database, the operation will fail and FALSE will be returned.

이전 | 처음으로 | 다음
dBase Functions | 위로 | dbase_close


dbase_close

(PHP 3, PHP 4 , PHP 5)

dbase_close -- Close a dBase database

Description

bool dbase_close ( int dbase_identifier)

Closes the database associated with dbase_identifier.

이전 | 처음으로 | 다음
dbase_add_record | 위로 | dbase_create


dbase_create

(PHP 3, PHP 4 , PHP 5)

dbase_create -- Creates a dBase database

Description

int dbase_create ( string filename, array fields)

dbase_create() creates a dBase database in the file filename, with the fields fields.

The fields parameter is an array of arrays, each array describing the format of one field in the database. Each field consists of a name, a character indicating the field type, a length, and a precision.

The types of fields available are:

L

Boolean. These do not have a length or precision.

M

Memo. (Note that these aren't supported by PHP.) These do not have a length or precision.

D

Date (stored as YYYYMMDD). These do not have a length or precision.

N

Number. These have both a length and a precision (the number of digits after the decimal point).

C

String.

참고: The fieldnames are limited in length and must not exceed 10 chars, 0 < chars <= 10.

If the database is successfully created, a dbase_identifier is returned, otherwise FALSE is returned.

예 1. Creating a dBase database file

<?php

// "database" name
$dbname = "/tmp/test.dbf";

// database "definition"
$def =
    array(
        array("date",     "D"),
        array("name",     "C",  50),
        array("age",      "N",   3, 0),
        array("email",    "C", 128),
        array("ismember", "L")
    );

// creation
if (!dbase_create($dbname, $def))
    echo "<strong>Error!</strong>";

?>

이전 | 처음으로 | 다음
dbase_close | 위로 | dbase_delete_record


dbase_delete_record

(PHP 3, PHP 4 , PHP 5)

dbase_delete_record -- Deletes a record from a dBase database

Description

bool dbase_delete_record ( int dbase_identifier, int record)

Marks record to be deleted from the database. To actually remove the record from the database, you must also call dbase_pack().

이전 | 처음으로 | 다음
dbase_create | 위로 | dbase_get_header_info


dbase_get_header_info

(PHP 5)

dbase_get_header_info -- Get the header info of a dBase database

Description

array dbase_get_header_info ( int dbase_identifier)

Returns information on the column structure of the database referenced by dbase_identifier. For each column in the database, there is an entry in a numerically-indexed array. The array index starts at 0. Each array element contains an associative array of column information. If the database header information cannot be read, FALSE is returned.

The array elements are:

name

The name of the column

type

The human-readable name for the dbase type of the column (i.e. date, boolean, etc)

length

The number of bytes this column can hold

precision

The number of digits of decimal precision for the column

format

A suggested printf() format specifier for the column

offset

The byte offset of the column from the start of the row

예 1. Showing header information for a dBase database file

<?php
// Path to dbase file
$db_path = "/tmp/test.dbf";

// Open dbase file
$dbh = dbase_open($db_path)
    or die("Error! Could not open dbase database file '$db_path'.");

// Get column information
$column_info = dbase_get_header_info($dbh);

// Display information
print_r($column_info);
?>

이전 | 처음으로 | 다음
dbase_delete_record | 위로 | dbase_get_record_with_names


dbase_get_record_with_names

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

dbase_get_record_with_names -- Gets a record from a dBase database as an associative array

Description

array dbase_get_record_with_names ( int dbase_identifier, int record)

Returns the data from record in an associative array. The array also includes an associative member named 'deleted' which is set to 1 if the record has been marked for deletion (see dbase_delete_record()).

Each field is converted to the appropriate PHP type, except:

  • Dates are left as strings

  • Integers that would have caused an overflow (> 32 bits) are returned as strings

이전 | 처음으로 | 다음
dbase_get_header_info | 위로 | dbase_get_record


dbase_get_record

(PHP 3, PHP 4 , PHP 5)

dbase_get_record -- Gets a record from a dBase database

Description

array dbase_get_record ( int dbase_identifier, int record)

Returns the data from record in an array. The array is indexed starting at 0, and includes an associative member named 'deleted' which is set to 1 if the record has been marked for deletion (see dbase_delete_record().

Each field is converted to the appropriate PHP type, except:

  • Dates are left as strings

  • Integers that would have caused an overflow (> 32 bits) are returned as strings

이전 | 처음으로 | 다음
dbase_get_record_with_names | 위로 | dbase_numfields


dbase_numfields

(PHP 3, PHP 4 , PHP 5)

dbase_numfields -- Find out how many fields are in a dBase database

Description

int dbase_numfields ( int dbase_identifier)

Returns the number of fields (columns) in the specified database. Field numbers are between 0 and dbase_numfields($db)-1, while record numbers are between 1 and dbase_numrecords($db).

예 1. Using dbase_numfields()

<?php

$rec = dbase_get_record($db, $recno);
$nf  = dbase_numfields($db);
for ($i=0; $i < $nf; $i++) {
    echo $rec[$i]."<br />\n";
}

?>

이전 | 처음으로 | 다음
dbase_get_record | 위로 | dbase_numrecords


dbase_numrecords

(PHP 3, PHP 4 , PHP 5)

dbase_numrecords -- Find out how many records are in a dBase database

Description

int dbase_numrecords ( int dbase_identifier)

Returns the number of records (rows) in the specified database. Record numbers are between 1 and dbase_numrecords($db), while field numbers are between 0 and dbase_numfields($db)-1.

이전 | 처음으로 | 다음
dbase_numfields | 위로 | dbase_open


dbase_open

(PHP 3, PHP 4 , PHP 5)

dbase_open -- Opens a dBase database

Description

int dbase_open ( string filename, int flags)

Returns a dbase_identifier for the opened database, or FALSE if the database couldn't be opened.

Parameter flags correspond to those for the open() system call (Typically 0 means read-only, 1 means write-only, and 2 means read and write).

참고: 안전 모드일때, PHP는 조작하려는 파일이나 디렉토리가 같은 UID(owner)인지 확인한 후에 실행합니다.

이전 | 처음으로 | 다음
dbase_numrecords | 위로 | dbase_pack


dbase_pack

(PHP 3, PHP 4 , PHP 5)

dbase_pack -- Packs a dBase database

Description

bool dbase_pack ( int dbase_identifier)

Packs the specified database (permanently deleting all records marked for deletion using dbase_delete_record()).

이전 | 처음으로 | 다음
dbase_open | 위로 | dbase_replace_record


dbase_replace_record

(PHP 3>= 3.0.11, PHP 4 , PHP 5)

dbase_replace_record -- Replace a record in a dBase database

Description

bool dbase_replace_record ( int dbase_identifier, array record, int dbase_record_number)

Replaces the data associated with the record record_number with the data in the record in the database. If the number of items in the supplied record is not equal to the number of fields in the database, the operation will fail and FALSE will be returned.

dbase_record_number is an integer which spans from 1 to the number of records in the database (as returned by dbase_numrecords()).

이전 | 처음으로 | 다음
dbase_pack | 위로 | DBM Functions [deprecated]


DBM Functions [deprecated]

PHP 매뉴얼
이전 다음

XIX. DBM Functions [deprecated]

소개

These functions allow you to store records stored in a dbm-style database. This type of database (supported by the Berkeley DB, GDBM, and some system libraries, as well as a built-in flatfile library) stores key/value pairs (as opposed to the full-blown records supported by relational databases).

참고: However, dbm support is deprecated and you are encouraged to use the Database (dbm-style) abstraction layer functions instead.

참고: 이 확장 모듈은 PHP 5에서 제거되어, PECL로 이동되었습니다.

요구 사항

To use this functions you have to compile PHP with support for an underlying database. See the list of supported Databases.

설치

In order to use these functions, you must compile PHP with dbm support by using the --with-db option. In addition you must ensure support for an underlying database or you can use some system libraries.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

The function dbmopen() returns an database identifier which is used by the other dbm-functions.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

예제

예 1. DBM example

<?php

$dbm = dbmopen("lastseen", "w");
if (dbmexists($dbm, $userid)) {
    $last_seen = dbmfetch($dbm, $userid);
} else {
    dbminsert($dbm, $userid, time());
}
do_stuff();
dbmreplace($dbm, $userid, time());
dbmclose($dbm);

?>

차례
dblist -- Describes the DBM-compatible library being used
dbmclose -- Closes a dbm database
dbmdelete -- Deletes the value for a key from a DBM database
dbmexists -- Tells if a value exists for a key in a DBM database
dbmfetch -- Fetches a value for a key from a DBM database
dbmfirstkey -- Retrieves the first key from a DBM database
dbminsert -- Inserts a value for a key in a DBM database
dbmnextkey -- Retrieves the next key from a DBM database
dbmopen -- Opens a DBM database
dbmreplace -- Replaces the value for a key in a DBM database

이전 | 처음으로 | 다음
dbase_replace_record | 위로 | dblist


dblist

(PHP 3, PHP 4 )

dblist -- Describes the DBM-compatible library being used

Description

string dblist ( void )

예 1. Getting the information on the command line

[marcus@zaphod marcus]$ php -r 'echo dblist();'
This is GDBM version 1.8.0, as of May 19, 1999.

이전 | 처음으로 | 다음
DBM Functions [deprecated] | 위로 | dbmclose


dbmclose

(PHP 3, PHP 4 )

dbmclose -- Closes a dbm database

Description

bool dbmclose ( resource dbm_identifier)

Unlocks and closes the specified database.

이전 | 처음으로 | 다음
dblist | 위로 | dbmdelete


dbmdelete

(PHP 3, PHP 4 )

dbmdelete -- Deletes the value for a key from a DBM database

Description

bool dbmdelete ( resource dbm_identifier, string key)

Deletes the value for key in the database.

Returns FALSE if the key didn't exist in the database.

이전 | 처음으로 | 다음
dbmclose | 위로 | dbmexists


dbmexists

(PHP 3, PHP 4 )

dbmexists -- Tells if a value exists for a key in a DBM database

Description

bool dbmexists ( resource dbm_identifier, string key)

Returns TRUE if there is a value associated with the key.

이전 | 처음으로 | 다음
dbmdelete | 위로 | dbmfetch


dbmfetch

(PHP 3, PHP 4 )

dbmfetch -- Fetches a value for a key from a DBM database

Description

string dbmfetch ( resource dbm_identifier, string key)

Returns the value associated with key.

이전 | 처음으로 | 다음
dbmexists | 위로 | dbmfirstkey


dbmfirstkey

(PHP 3, PHP 4 )

dbmfirstkey -- Retrieves the first key from a DBM database

Description

string dbmfirstkey ( resource dbm_identifier)

Returns the first key in the database. Note that no particular order is guaranteed since the database may be built using a hash-table, which doesn't guarantee any ordering.

이전 | 처음으로 | 다음
dbmfetch | 위로 | dbminsert


dbminsert

(PHP 3, PHP 4 )

dbminsert -- Inserts a value for a key in a DBM database

Description

int dbminsert ( resource dbm_identifier, string key, string value)

Adds the value to the database with the specified key.

Returns -1 if the database was opened read-only, 0 if the insert was successful, and 1 if the specified key already exists. (To replace the value, use dbmreplace().)

이전 | 처음으로 | 다음
dbmfirstkey | 위로 | dbmnextkey


dbmnextkey

(PHP 3, PHP 4 )

dbmnextkey -- Retrieves the next key from a DBM database

Description

string dbmnextkey ( resource dbm_identifier, string key)

Returns the next key after key. By calling dbmfirstkey() followed by successive calls to dbmnextkey() it is possible to visit every key/value pair in the dbm database. For example:

예 1. Visiting every key/value pair in a DBM database

<?php

$key = dbmfirstkey($dbm_id);
while ($key) {
    echo "$key = " . dbmfetch($dbm_id, $key) . "\n";
    $key = dbmnextkey($dbm_id, $key);
}

?>

이전 | 처음으로 | 다음
dbminsert | 위로 | dbmopen


dbmopen

(PHP 3, PHP 4 )

dbmopen -- Opens a DBM database

Description

resource dbmopen ( string filename, string flags)

The first argument is the full-path filename of the DBM file to be opened and the second is the file open mode which is one of "r", "n", "c" or "w" for read-only, new (implies read-write, and most likely will truncate an already-existing database of the same name), create (implies read-write, and will not truncate an already-existing database of the same name) and read-write respectively.

Returns an identifier to be passed to the other DBM functions on success, or FALSE on failure.

If NDBM support is used, NDBM will actually create filename.dir and filename.pag files. GDBM only uses one file, as does the internal flat-file support, and Berkeley DB creates a filename.db file. Note that PHP does its own file locking in addition to any file locking that may be done by the DBM library itself. PHP does not delete the .lck files it creates. It uses these files simply as fixed inodes on which to do the file locking. For more information on DBM files, see your Unix man pages, or obtain GNU's GDBM.

참고: 안전 모드일때, PHP는 조작하려는 파일이나 디렉토리가 같은 UID(owner)인지 확인한 후에 실행합니다.

이전 | 처음으로 | 다음
dbmnextkey | 위로 | dbmreplace


dbmreplace

(PHP 3, PHP 4 )

dbmreplace -- Replaces the value for a key in a DBM database

Description

int dbmreplace ( resource dbm_identifier, string key, string value)

Replaces the value for the specified key in the database.

This will also add the key to the database if it didn't already exist.

이전 | 처음으로 | 다음
dbmopen | 위로 | dbx Functions


dbx Functions

PHP 매뉴얼
이전 다음

XX. dbx Functions

소개

The dbx module is a database abstraction layer (db 'X', where 'X' is a supported database). The dbx functions allow you to access all supported databases using a single calling convention. The dbx-functions themselves do not interface directly to the databases, but interface to the modules that are used to support these databases.

요구 사항

To be able to use a database with the dbx-module, the module must be either linked or loaded into PHP, and the database module must be supported by the dbx-module. Currently, the following databases are supported, but others will follow:

  • FrontBase (available from PHP 4.1.0).

  • Microsoft SQL Server

  • MySQL

  • ODBC

  • PostgreSQL

  • Sybase-CT (available from PHP 4.2.0).

  • Oracle (oci8) (available from PHP 4.3.0).

  • SQLite (CVS only).

Documentation for adding additional database support to dbx can be found at http://www.guidance.nl/php/dbx/doc/.

설치

In order to have these functions available, you must compile PHP with dbx support by using the --enable-dbx option and all options for the databases that will be used, e.g. for MySQL you must also specify --with-mysql=[DIR]. To get other supported databases to work with the dbx-module refer to their specific documentation.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. DBX Configuration Options

Name | Default | Changeable
dbx.colnames_case | "unchanged" | PHP_INI_SYSTEM
For further details and definition of the PHP_INI_* constants see ini_set().

참고: This ini-option is available available from PHP 4.3.0.

위 설정 지시어에 대한 간단한 설명입니다.

dbx.colnames_case string

Columns names can be returned "unchanged" or converted to "uppercase" or "lowercase". This directive can be overridden with a flag to dbx_query().

리소스 종류

There are two resource types used in the dbx module. The first one is the link-object for a database connection, the second a result-object which holds the result of a query.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

DBX_MYSQL (integer)

DBX_ODBC (integer)

DBX_PGSQL (integer)

DBX_MSSQL (integer)

DBX_FBSQL (integer)

DBX_OCI8 (integer) (available from PHP 4.3.0)

DBX_SYBASECT (integer)

DBX_SQLITE (integer) (CVS only)

DBX_PERSISTENT (integer)

DBX_RESULT_INFO (integer)

DBX_RESULT_INDEX (integer)

DBX_RESULT_ASSOC (integer)

DBX_RESULT_UNBUFFERED (integer) (CVS only)

DBX_COLNAMES_UNCHANGED (integer) (available from PHP 4.3.0)

DBX_COLNAMES_UPPERCASE (integer) (available from PHP 4.3.0)

DBX_COLNAMES_LOWERCASE (integer) (available from PHP 4.3.0)

DBX_CMP_NATIVE (integer)

DBX_CMP_TEXT (integer)

DBX_CMP_NUMBER (integer)

DBX_CMP_ASC (integer)

DBX_CMP_DESC (integer)

차례
dbx_close -- Close an open connection/database
dbx_compare -- Compare two rows for sorting purposes
dbx_connect -- Open a connection/database
dbx_error -- Report the error message of the latest function call in the module (not just in the connection)
dbx_escape_string -- Escape a string so it can safely be used in an sql-statement.
dbx_fetch_row -- Fetches rows from a query-result that had the DBX_RESULT_UNBUFFERED flag set
dbx_query -- Send a query and fetch all results (if any)
dbx_sort -- Sort a result from a dbx_query by a custom sort function

이전 | 처음으로 | 다음
dbmreplace | 위로 | dbx_close


dbx_close

(PHP 4 >= 4.0.6, PHP 5)

dbx_close -- Close an open connection/database

Description

bool dbx_close ( object link_identifier)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. dbx_close() example

<?php
$link = dbx_connect(DBX_MYSQL, "localhost", "db", "username", "password")
    or die("Could not connect");

echo "Connected successfully";
dbx_close($link);
?>

참고: Always refer to the module-specific documentation as well.

See also dbx_connect().

이전 | 처음으로 | 다음
dbx Functions | 위로 | dbx_compare


dbx_compare

(PHP 4 >= 4.1.0, PHP 5)

dbx_compare -- Compare two rows for sorting purposes

Description

int dbx_compare ( array row_a, array row_b, string column_key [, int flags])

dbx_compare() returns 0 if the row_a[$column_key] is equal to row_b[$column_key], and 1 or -1 if the former is greater or is smaller than the latter one, respectively, or vice versa if the flag is set to DBX_CMP_DESC. dbx_compare() is a helper function for dbx_sort() to ease the make and use of the custom sorting function.

The flags can be set to specify comparison direction:

  • DBX_CMP_ASC - ascending order

  • DBX_CMP_DESC - descending order

and the preferred comparison type:

  • DBX_CMP_NATIVE - no type conversion

  • DBX_CMP_TEXT - compare items as strings

  • DBX_CMP_NUMBER - compare items numerically

One of the direction and one of the type constant can be combined with bitwise OR operator (|). The default value for the flags parameter is DBX_CMP_ASC | DBX_CMP_NATIVE.

예 1. dbx_compare() example

<?php
function user_re_order($a, $b)
{
    $rv = dbx_compare($a, $b, "parentid", DBX_CMP_DESC);
    if (!$rv) {
        $rv = dbx_compare($a, $b, "id", DBX_CMP_NUMBER);
    }
    return $rv;
}

$link   = dbx_connect(DBX_ODBC, "", "db", "username", "password")
    or die("Could not connect");

$result = dbx_query($link, "SELECT id, parentid, description FROM table ORDER BY id");
    // data in $result is now ordered by id

dbx_sort($result, "user_re_order");
    // date in $result is now ordered by parentid (descending), then by id

dbx_close($link);
?>

See also dbx_sort().

이전 | 처음으로 | 다음
dbx_close | 위로 | dbx_connect


dbx_connect

(PHP 4 >= 4.0.6, PHP 5)

dbx_connect -- Open a connection/database

Description

object dbx_connect ( mixed module, string host, string database, string username, string password [, int persistent])

dbx_connect() returns an object on success, FALSE on error. If a connection has been made but the database could not be selected, the connection is closed and FALSE is returned. The persistent parameter can be set to DBX_PERSISTENT, if so, a persistent connection will be created.

The module parameter can be either a string or a constant, though the latter form is preferred. The possible values are given below, but keep in mind that they only work if the module is actually loaded.

  • DBX_MYSQL or "mysql"

  • DBX_ODBC or "odbc"

  • DBX_PGSQL or "pgsql"

  • DBX_MSSQL or "mssql"

  • DBX_FBSQL or "fbsql" (available from PHP 4.1.0)

  • DBX_SYBASECT or "sybase_ct" (available from PHP 4.2.0)

  • DBX_OCI8 or "oci8" (available from PHP 4.3.0)

  • DBX_SQLITE or "sqlite" (CVS only)

The host, database, username and password parameters are expected, but not always used depending on the connect functions for the abstracted module.

The returned object has three properties:

database

It is the name of the currently selected database.

handle

It is a valid handle for the connected database, and as such it can be used in module-specific functions (if required).

<?php
$link = dbx_connect(DBX_MYSQL, "localhost", "db", "username", "password");
mysql_close($link->handle); // dbx_close($link) would be better here
?>

module

It is used internally by dbx only, and is actually the module number mentioned above.

예 1. dbx_connect() example

<?php
$link = dbx_connect(DBX_ODBC, "", "db", "username", "password", DBX_PERSISTENT)
    or die("Could not connect");

echo "Connected successfully";
dbx_close($link);
?>

참고: Always refer to the module-specific documentation as well.

See also dbx_close().

이전 | 처음으로 | 다음
dbx_compare | 위로 | dbx_error


dbx_error

(PHP 4 >= 4.0.6, PHP 5)

dbx_error -- Report the error message of the latest function call in the module (not just in the connection)

Description

string dbx_error ( object link_identifier)

dbx_error() returns a string containing the error message from the last function call of the abstracted module (e.g. mysql module). If there are multiple connections in the same module, just the last error is given. If there are connections on different modules, the latest error is returned for the module specified by the link_identifier parameter.

예 1. dbx_error() example

<?php
$link   = dbx_connect(DBX_MYSQL, "localhost", "db", "username", "password")
    or die("Could not connect");

$result = dbx_query($link, "select id from non_existing_table");
if ($result == 0) {
    echo dbx_error($link);
}
dbx_close($link);
?>

참고: Always refer to the module-specific documentation as well.

The error message for Microsoft SQL Server is actually the result of the mssql_get_last_message() function.

The error message for Oracle (oci8) is not implemented (yet).

이전 | 처음으로 | 다음
dbx_connect | 위로 | dbx_escape_string


dbx_escape_string

(PHP 4 >= 4.3.0, PHP 5)

dbx_escape_string -- Escape a string so it can safely be used in an sql-statement.

Description

string dbx_escape_string ( object link_identifier, string text)

dbx_escape_string() returns the text, escaped where necessary (such as quotes, backslashes etc). It returns NULL on error.

예 1. dbx_escape_string() example

<?php
$link   = dbx_connect(DBX_MYSQL, "localhost", "db", "username", "password")
    or die("Could not connect");

$text = dbx_escape_string($link, "It\'s quoted and backslashed (\\).");
$result = dbx_query($link, "insert into tbl (txt) values ('" . $text . "')");
if ($result == 0) {
    echo dbx_error($link);
}
dbx_close($link);
?>

See also dbx_query().

이전 | 처음으로 | 다음
dbx_error | 위로 | dbx_fetch_row


dbx_fetch_row

(PHP 5)

dbx_fetch_row -- Fetches rows from a query-result that had the DBX_RESULT_UNBUFFERED flag set

Description

object dbx_fetch_row ( object result_identifier)

dbx_fetch_row() returns a row on success, and 0 on failure (e.g. when no more rows are available). When the DBX_RESULT_UNBUFFERED is not set in the query, dbx_fetch_row() will fail as all rows have already been fetched into the results data property.

As a side effect, the rows property of the query-result object is incremented for each successful call to dbx_fetch_row().

예 1. How to handle the returned value

<?php
$result = dbx_query($link, 'SELECT id, parentid, description FROM table', DBX_RESULT_UNBUFFERED);

echo "<table>\n";
while ($row = dbx_fetch_row($result)) {
    echo "<tr>\n";
    foreach ($row as $field) {
        echo "<td>$field</td>";
    }
    echo "</tr>\n";
}
echo "</table>\n";
?>

The result_identifier parameter is the result object returned by a call to dbx_query().

The returned array contains the same information as any row would have in the dbx_query result data property, including columns accessible by index or fieldname when the flags for dbx_guery were set that way.

See also dbx_query().

이전 | 처음으로 | 다음
dbx_escape_string | 위로 | dbx_query


dbx_query

(PHP 4 >= 4.0.6, PHP 5)

dbx_query -- Send a query and fetch all results (if any)

Description

object dbx_query ( object link_identifier, string sql_statement [, int flags])

dbx_query() returns an object or 1 on success, and 0 on failure. The result object is returned only if the query given in sql_statement produces a result set (i.e. a SELECT query, even if the result set is empty).

예 1. How to handle the returned value

<?php
$link   = dbx_connect(DBX_ODBC, "", "db", "username", "password")
    or die("Could not connect");

$result = dbx_query($link, 'SELECT id, parentid, description FROM table');

if (is_object($result) ) {
    // ... do some stuff here, see detailed examples below ...
    // first, print out field names and types
    // then, draw a table filled with the returned field values
} else {
    exit("Query failed");
}

dbx_close($link);
?>

The flags parameter is used to control the amount of information that is returned. It may be any combination of the following constants with the bitwise OR operator (|). The DBX_COLNAMES_* flags override the dbx.colnames_case setting from php.ini.

DBX_RESULT_INDEX

It is always set, that is, the returned object has a data property which is a 2 dimensional array indexed numerically. For example, in the expression data[2][3] 2 stands for the row (or record) number and 3 stands for the column (or field) number. The first row and column are indexed at 0.

If DBX_RESULT_ASSOC is also specified, the returning object contains the information related to DBX_RESULT_INFO too, even if it was not specified.

DBX_RESULT_INFO

It provides info about columns, such as field names and field types.

DBX_RESULT_ASSOC

It effects that the field values can be accessed with the respective column names used as keys to the returned object's data property.

Associated results are actually references to the numerically indexed data, so modifying data[0][0] causes that data[0]['field_name_for_first_column'] is modified as well.

DBX_RESULT_UNBUFFERED (CVS only)

This flag will not create the data property, and the rows property will initially be 0. Use this flag for large datasets, and use dbx_fetch_row() to retrieve the results row by row.

The dbx_fetch_row() function will return rows that are conformant to the flags set with this query. Incidentally, it will also update the rows each time it is called.

DBX_COLNAMES_UNCHANGED (available from PHP 4.3.0)

The case of the returned column names will not be changed.

DBX_COLNAMES_UPPERCASE (available from PHP 4.3.0)

The case of the returned column names will be changed to uppercase.

DBX_COLNAMES_LOWERCASE (available from PHP 4.3.0)

The case of the returned column names will be changed to lowercase.

Note that DBX_RESULT_INDEX is always used, regardless of the actual value of flags parameter. This means that only the following combinations are effective:

  • DBX_RESULT_INDEX

  • DBX_RESULT_INDEX | DBX_RESULT_INFO

  • DBX_RESULT_INDEX | DBX_RESULT_INFO | DBX_RESULT_ASSOC - this is the default, if flags is not specified.

The returned object has four or five properties depending on flags:

handle

It is a valid handle for the connected database, and as such it can be used in module specific functions (if required).

<?php
$result = dbx_query($link, "SELECT id FROM table");
mysql_field_len($result->handle, 0);
?>

cols and rows

These contain the number of columns (or fields) and rows (or records) respectively.

<?php
$result = dbx_query($link, 'SELECT id FROM table');
echo $result->rows; // number of records
echo $result->cols; // number of fields
?>

info (optional)

It is returned only if either DBX_RESULT_INFO or DBX_RESULT_ASSOC is specified in the flags parameter. It is a 2 dimensional array, that has two named rows (name and type) to retrieve column information.

예 2. lists each field's name and type

<?php
$result = dbx_query($link, 'SELECT id FROM table',
                     DBX_RESULT_INDEX | DBX_RESULT_INFO);

for ($i = 0; $i < $result->cols; $i++ ) {
    echo $result->info['name'][$i] . "\n";
    echo $result->info['type'][$i] . "\n";
}
?>
data

This property contains the actual resulting data, possibly associated with column names as well depending on flags. If DBX_RESULT_ASSOC is set, it is possible to use $result->data[2]["field_name"].

예 3. outputs the content of data property into HTML table

<?php
$result = dbx_query($link, 'SELECT id, parentid, description FROM table');

echo "<table>\n";
foreach ($result->data as $row) {
    echo "<tr>\n";
    foreach ($row as $field) {
        echo "<td>$field</td>";
    }
    echo "</tr>\n";
}
echo "</table>\n";
?>

예 4. How to handle UNBUFFERED queries

<?php

$result = dbx_query ($link, 'SELECT id, parentid, description FROM table', DBX_RESULT_UNBUFFERED);

echo "<table>\n";
while ($row = dbx_fetch_row($result)) {
    echo "<tr>\n";
    foreach ($row as $field) {
        echo "<td>$field</td>";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

참고: Always refer to the module-specific documentation as well.

Column names for queries on an Oracle database are returned in lowercase.

See also dbx_escape_string(),
dbx_fetch_row() and
dbx_connect().

이전 | 처음으로 | 다음
dbx_fetch_row | 위로 | dbx_sort


dbx_sort

(PHP 4 >= 4.0.6, PHP 5)

dbx_sort -- Sort a result from a dbx_query by a custom sort function

Description

bool dbx_sort ( object result, string user_compare_function)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: It is always better to use ORDER BY SQL clause instead of dbx_sort(), if possible.

예 1. dbx_sort() example

<?php
function user_re_order($a, $b)
{
    $rv = dbx_compare($a, $b, "parentid", DBX_CMP_DESC);
    if (!$rv) {
        $rv = dbx_compare($a, $b, "id", DBX_CMP_NUMBER);
    }
    return $rv;
}

$link   = dbx_connect(DBX_ODBC, "", "db", "username", "password")
    or die("Could not connect");

$result = dbx_query($link, "SELECT id, parentid, description FROM tbl ORDER BY id");
    // data in $result is now ordered by id

dbx_sort($result, "user_re_order");
    // data in $result is now ordered by parentid (descending), then by id

dbx_close($link);
?>

See also dbx_compare().

이전 | 처음으로 | 다음
dbx_query | 위로 | DB++ Functions


DB++ Functions

PHP 매뉴얼
이전 다음

XXI. DB++ Functions

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

소개

db++, made by the German company Concept asa, is a relational database system with high performance and low memory and disk usage in mind. While providing SQL as an additional language interface, it is not really a SQL database in the first place but provides its own AQL query language which is much more influenced by the relational algebra then SQL is.

Concept asa always had an interest in supporting open source languages, db++ has had Perl and Tcl call interfaces for years now and uses Tcl as its internal stored procedure language.

요구 사항

This extension relies on external client libraries so you have to have a db++ client installed on the system you want to use this extension on.

Concept asa provides db++ Demo versions and documentation for Linux, some other Unix versions. There is also a Windows version of db++, but this extension doesn't support it (yet).

설치

In order to build this extension yourself you need the db++ client libraries and header files to be installed on your system (these are included in the db++ installation archives by default). You have to run configure with option --with-dbplus to build this extension.

configure looks for the client libraries and header files under the default paths /usr/dbplus, /usr/local/dbplus and /opt/dblus. If you have installed db++ in a different place you have add the installation path to the configure option like this: --with-dbplus=/your/installation/path.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

dbplus_relation

Most db++ functions operate on or return dbplus_relation resources. A dbplus_relation is a handle to a stored relation or a relation generated as the result of a query.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

db++ error codes

표 1. DB++ Error Codes

PHP Constant | db++ constant | meaning
DBPLUS_ERR_NOERR (integer) | ERR_NOERR | Null error condition
DBPLUS_ERR_DUPLICATE (integer) | ERR_DUPLICATE | Tried to insert a duplicate tuple
DBPLUS_ERR_EOSCAN (integer) | ERR_EOSCAN | End of scan from rget()
DBPLUS_ERR_EMPTY (integer) | ERR_EMPTY | Relation is empty (server)
DBPLUS_ERR_CLOSE (integer) | ERR_CLOSE | The server can't close
DBPLUS_ERR_WLOCKED (integer) | ERR_WLOCKED | The record is write locked
DBPLUS_ERR_LOCKED (integer) | ERR_LOCKED | Relation was already locked
DBPLUS_ERR_NOLOCK (integer) | ERR_NOLOCK | Relation cannot be locked
DBPLUS_ERR_READ (integer) | ERR_READ | Read error on relation
DBPLUS_ERR_WRITE (integer) | ERR_WRITE | Write error on relation
DBPLUS_ERR_CREATE (integer) | ERR_CREATE | Create() system call failed
DBPLUS_ERR_LSEEK (integer) | ERR_LSEEK | Lseek() system call failed
DBPLUS_ERR_LENGTH (integer) | ERR_LENGTH | Tuple exceeds maximum length
DBPLUS_ERR_OPEN (integer) | ERR_OPEN | Open() system call failed
DBPLUS_ERR_WOPEN (integer) | ERR_WOPEN | Relation already opened for writing
DBPLUS_ERR_MAGIC (integer) | ERR_MAGIC | File is not a relation
DBPLUS_ERR_VERSION (integer) | ERR_VERSION | File is a very old relation
DBPLUS_ERR_PGSIZE (integer) | ERR_PGSIZE | Relation uses a different page size
DBPLUS_ERR_CRC (integer) | ERR_CRC | Invalid crc in the superpage
DBPLUS_ERR_PIPE (integer) | ERR_PIPE | Piped relation requires lseek()
DBPLUS_ERR_NIDX (integer) | ERR_NIDX | Too many secondary indices
DBPLUS_ERR_MALLOC (integer) | ERR_MALLOC | Malloc() call failed
DBPLUS_ERR_NUSERS (integer) | ERR_NUSERS | Error use of max users
DBPLUS_ERR_PREEXIT (integer) | ERR_PREEXIT | Caused by invalid usage
DBPLUS_ERR_ONTRAP (integer) | ERR_ONTRAP | Caused by a signal
DBPLUS_ERR_PREPROC (integer) | ERR_PREPROC | Error in the preprocessor
DBPLUS_ERR_DBPARSE (integer) | ERR_DBPARSE | Error in the parser
DBPLUS_ERR_DBRUNERR (integer) | ERR_DBRUNERR | Run error in db
DBPLUS_ERR_DBPREEXIT (integer) | ERR_DBPREEXIT | Exit condition caused by prexit() * procedure
DBPLUS_ERR_WAIT (integer) | ERR_WAIT | Wait a little (Simple only)
DBPLUS_ERR_CORRUPT_TUPLE (integer) | ERR_CORRUPT_TUPLE | A client sent a corrupt tuple
DBPLUS_ERR_WARNING0 (integer) | ERR_WARNING0 | The Simple routines encountered a non fatal error which was corrected
DBPLUS_ERR_PANIC (integer) | ERR_PANIC | The server should not really die but after a disaster send ERR_PANIC to all its clients
DBPLUS_ERR_FIFO (integer) | ERR_FIFO | Can't create a fifo
DBPLUS_ERR_PERM (integer) | ERR_PERM | Permission denied
DBPLUS_ERR_TCL (integer) | ERR_TCL | TCL_error
DBPLUS_ERR_RESTRICTED (integer) | ERR_RESTRICTED | Only two users
DBPLUS_ERR_USER (integer) | ERR_USER | An error in the use of the library by an application programmer
DBPLUS_ERR_UNKNOWN (integer) | ERR_UNKNOWN |

차례
dbplus_add -- Add a tuple to a relation
dbplus_aql -- Perform AQL query
dbplus_chdir -- Get/Set database virtual current directory
dbplus_close -- Close a relation
dbplus_curr -- Get current tuple from relation
dbplus_errcode -- Get error string for given errorcode or last error
dbplus_errno -- Get error code for last operation
dbplus_find -- Set a constraint on a relation
dbplus_first -- Get first tuple from relation
dbplus_flush -- Flush all changes made on a relation
dbplus_freealllocks -- Free all locks held by this client
dbplus_freelock -- Release write lock on tuple
dbplus_freerlocks -- Free all tuple locks on given relation
dbplus_getlock -- Get a write lock on a tuple
dbplus_getunique -- Get an id number unique to a relation
dbplus_info -- ???
dbplus_last -- Get last tuple from relation
dbplus_lockrel -- Request write lock on relation
dbplus_next -- Get next tuple from relation
dbplus_open -- Open relation file
dbplus_prev -- Get previous tuple from relation
dbplus_rchperm -- Change relation permissions
dbplus_rcreate -- Creates a new DB++ relation
dbplus_rcrtexact -- Creates an exact but empty copy of a relation including indices
dbplus_rcrtlike -- Creates an empty copy of a relation with default indices
dbplus_resolve -- Resolve host information for relation
dbplus_restorepos -- ???
dbplus_rkeys -- Specify new primary key for a relation
dbplus_ropen -- Open relation file local
dbplus_rquery -- Perform local (raw) AQL query
dbplus_rrename -- Rename a relation
dbplus_rsecindex -- Create a new secondary index for a relation
dbplus_runlink -- Remove relation from filesystem
dbplus_rzap -- Remove all tuples from relation
dbplus_savepos -- ???
dbplus_setindex -- ???
dbplus_setindexbynumber -- ???
dbplus_sql -- Perform SQL query
dbplus_tcl -- Execute TCL code on server side
dbplus_tremove -- Remove tuple and return new current tuple
dbplus_undo -- ???
dbplus_undoprepare -- ???
dbplus_unlockrel -- Give up write lock on relation
dbplus_unselect -- Remove a constraint from relation
dbplus_update -- Update specified tuple in relation
dbplus_xlockrel -- Request exclusive lock on relation
dbplus_xunlockrel -- Free exclusive lock on relation

이전 | 처음으로 | 다음
dbx_sort | 위로 | dbplus_add


dbplus_add

(4.1.0 - 4.2.3 only)

dbplus_add -- Add a tuple to a relation

Description

int dbplus_add ( resource relation, array tuple)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

This function will add a tuple to a relation. The tuple data is an array of attribute/value pairs to be inserted into the given relation. After successful execution the tuple array will contain the complete data of the newly created tuple, including all implicitly set domain fields like sequences.

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure. See dbplus_errcode() or the introduction to this chapter for more information on db++ error codes.

이전 | 처음으로 | 다음
DB++ Functions | 위로 | dbplus_aql


dbplus_aql

(4.1.0 - 4.2.3 only)

dbplus_aql -- Perform AQL query

Description

resource dbplus_aql ( string query [, string server [, string dbpath]])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_aql() will execute an AQL query on the given server and dbpath.

On success it will return a relation handle. The result data may be fetched from this relation by calling dbplus_next() and dbplus_current(). Other relation access functions will not work on a result relation.

Further information on the AQL A... Query Language is provided in the original db++ manual.

이전 | 처음으로 | 다음
dbplus_add | 위로 | dbplus_chdir


dbplus_chdir

(4.1.0 - 4.2.3 only)

dbplus_chdir -- Get/Set database virtual current directory

Description

string dbplus_chdir ( [string newdir])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_chdir() will change the virtual current directory where relation files will be looked for by dbplus_open(). dbplus_chdir() will return the absolute path of the current directory. Calling dbplus_chdir() without giving any newdir may be used to query the current working directory.

이전 | 처음으로 | 다음
dbplus_aql | 위로 | dbplus_close


dbplus_close

(4.1.0 - 4.2.3 only)

dbplus_close -- Close a relation

Description

int dbplus_close ( resource relation)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Calling dbplus_close() will close a relation previously opened by dbplus_open().

이전 | 처음으로 | 다음
dbplus_chdir | 위로 | dbplus_curr


dbplus_curr

(4.1.0 - 4.2.3 only)

dbplus_curr -- Get current tuple from relation

Description

int dbplus_curr ( resource relation, array tuple)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_curr() will read the data for the current tuple for the given relation and will pass it back as an associative array in tuple.

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure. See dbplus_errcode() or the introduction to this chapter for more information on db++ error codes.

See also dbplus_first(),
dbplus_prev(),
dbplus_next(), and
dbplus_last().

이전 | 처음으로 | 다음
dbplus_close | 위로 | dbplus_errcode


dbplus_errcode

(4.1.0 - 4.2.3 only)

dbplus_errcode -- Get error string for given errorcode or last error

Description

string dbplus_errcode ( int errno)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_errcode() returns a cleartext error string for the error code passed as errno of for the result code of the last db++ operation if no parameter is given.

이전 | 처음으로 | 다음
dbplus_curr | 위로 | dbplus_errno


dbplus_errno

(4.1.0 - 4.2.3 only)

dbplus_errno -- Get error code for last operation

Description

int dbplus_errno ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_errno() will return the error code returned by the last db++ operation.

See also dbplus_errcode().

이전 | 처음으로 | 다음
dbplus_errcode | 위로 | dbplus_find


dbplus_find

(4.1.0 - 4.2.3 only)

dbplus_find -- Set a constraint on a relation

Description

int dbplus_find ( resource relation, array constraints, mixed tuple)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_find() will place a constraint on the given relation. Further calls to functions like dbplus_curr() or dbplus_next() will only return tuples matching the given constraints.

Constraints are triplets of strings containing of a domain name, a comparison operator and a comparison value. The constraints parameter array may consist of a collection of string arrays, each of which contains a domain, an operator and a value, or of a single string array containing a multiple of three elements.

The comparison operator may be one of the following strings: '==', '>', '>=', '<', '<=', '!=', '~' for a regular expression match and 'BAND' or 'BOR' for bitwise operations.

See also dbplus_unselect().

이전 | 처음으로 | 다음
dbplus_errno | 위로 | dbplus_first


dbplus_first

(4.1.0 - 4.2.3 only)

dbplus_first -- Get first tuple from relation

Description

int dbplus_first ( resource relation, array tuple)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_curr() will read the data for the first tuple for the given relation, make it the current tuple and pass it back as an associative array in tuple.

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure. See dbplus_errcode() or the introduction to this chapter for more information on db++ error codes.

See also dbplus_curr(),
dbplus_prev(),
dbplus_next(), and
dbplus_last().

이전 | 처음으로 | 다음
dbplus_find | 위로 | dbplus_flush


dbplus_flush

(4.1.0 - 4.2.3 only)

dbplus_flush -- Flush all changes made on a relation

Description

int dbplus_flush ( resource relation)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_flush() will write all changes applied to relation since the last flush to disk.

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure. See dbplus_errcode() or the introduction to this chapter for more information on db++ error codes.

이전 | 처음으로 | 다음
dbplus_first | 위로 | dbplus_freealllocks


dbplus_freealllocks

(4.1.0 - 4.2.3 only)

dbplus_freealllocks -- Free all locks held by this client

Description

int dbplus_freealllocks ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_freealllocks() will free all tuple locks held by this client.

See also dbplus_getlock(),
dbplus_freelock(), and
dbplus_freerlocks().

이전 | 처음으로 | 다음
dbplus_flush | 위로 | dbplus_freelock


dbplus_freelock

(4.1.0 - 4.2.3 only)

dbplus_freelock -- Release write lock on tuple

Description

int dbplus_freelock ( resource relation, string tname)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_freelock() will release a write lock on the given tuple previously obtained by dbplus_getlock().

See also dbplus_getlock(),
dbplus_freerlocks(), and
dbplus_freealllocks().

이전 | 처음으로 | 다음
dbplus_freealllocks | 위로 | dbplus_freerlocks


dbplus_freerlocks

(4.1.0 - 4.2.3 only)

dbplus_freerlocks -- Free all tuple locks on given relation

Description

int dbplus_freerlocks ( resource relation)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_freerlocks() will free all tuple locks held on the given relation.

See also dbplus_getlock(),
dbplus_freelock(), and
dbplus_freealllocks().

이전 | 처음으로 | 다음
dbplus_freelock | 위로 | dbplus_getlock


dbplus_getlock

(4.1.0 - 4.2.3 only)

dbplus_getlock -- Get a write lock on a tuple

Description

int dbplus_getlock ( resource relation, string tname)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_getlock() will request a write lock on the specified tuple. It will return zero on success or a non-zero error code, especially DBPLUS_ERR_WLOCKED, on failure.

See also dbplus_freelock(),
dbplus_freerlocks(), and
dbplus_freealllocks().

이전 | 처음으로 | 다음
dbplus_freerlocks | 위로 | dbplus_getunique


dbplus_getunique

(4.1.0 - 4.2.3 only)

dbplus_getunique -- Get an id number unique to a relation

Description

int dbplus_getunique ( resource relation, int uniqueid)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_getunique() will obtain a number guaranteed to be unique for the given relation and will pass it back in the variable given as uniqueid.

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure. See dbplus_errcode() or the introduction to this chapter for more information on db++ error codes.

이전 | 처음으로 | 다음
dbplus_getlock | 위로 | dbplus_info


dbplus_info

(4.1.0 - 4.2.3 only)

dbplus_info -- ???

Description

int dbplus_info ( resource relation, string key, array &result)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Not implemented yet.

이전 | 처음으로 | 다음
dbplus_getunique | 위로 | dbplus_last


dbplus_last

(4.1.0 - 4.2.3 only)

dbplus_last -- Get last tuple from relation

Description

int dbplus_last ( resource relation, array tuple)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_curr() will read the data for the last tuple for the given relation, make it the current tuple and pass it back as an associative array in tuple.

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure. See dbplus_errcode() or the introduction to this chapter for more information on db++ error codes.

See also dbplus_first(),
dbplus_curr(),
dbplus_prev(), and
dbplus_next().

이전 | 처음으로 | 다음
dbplus_info | 위로 | dbplus_lockrel


dbplus_lockrel

(no version information, might be only in CVS)

dbplus_lockrel -- Request write lock on relation

Description

int dbplus_lockrel ( resource relation)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_lockrel() will request a write lock on the given relation. Other clients may still query the relation, but can't alter it while it is locked.

이전 | 처음으로 | 다음
dbplus_last | 위로 | dbplus_next


dbplus_next

(4.1.0 - 4.2.3 only)

dbplus_next -- Get next tuple from relation

Description

int dbplus_next ( resource relation, array &tuple)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_curr() will read the data for the next tuple for the given relation, will make it the current tuple and will pass it back as an associative array in tuple.

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure. See dbplus_errcode() or the introduction to this chapter for more information on db++ error codes.

See also dbplus_first(),
dbplus_curr(),
dbplus_prev(), and
dbplus_last().

이전 | 처음으로 | 다음
dbplus_lockrel | 위로 | dbplus_open


dbplus_open

(4.1.0 - 4.2.3 only)

dbplus_open -- Open relation file

Description

resource dbplus_open ( string name)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

The relation file name will be opened. name can be either a file name or a relative or absolute path name. This will be mapped in any case to an absolute relation file path on a specific host machine and server.

On success a relation file resource (cursor) is returned which must be used in any subsequent commands referencing the relation. Failure leads to a zero return value, the actual error code may be asked for by calling dbplus_errno().

이전 | 처음으로 | 다음
dbplus_next | 위로 | dbplus_prev


dbplus_prev

(4.1.0 - 4.2.3 only)

dbplus_prev -- Get previous tuple from relation

Description

int dbplus_prev ( resource relation, array tuple)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_curr() will read the data for the previous tuple for the given relation, will make it the current tuple and will pass it back as an associative array in tuple.

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure. See dbplus_errcode() or the introduction to this chapter for more information on db++ error codes.

See also dbplus_first(),
dbplus_curr(),
dbplus_next(), and
dbplus_last().

이전 | 처음으로 | 다음
dbplus_open | 위로 | dbplus_rchperm


dbplus_rchperm

(4.1.0 - 4.2.3 only)

dbplus_rchperm -- Change relation permissions

Description

int dbplus_rchperm ( resource relation, int mask, string user, string group)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_rchperm() will change access permissions as specified by mask, user and group. The values for these are operating system specific.

이전 | 처음으로 | 다음
dbplus_prev | 위로 | dbplus_rcreate


dbplus_rcreate

(4.1.0 - 4.2.3 only)

dbplus_rcreate -- Creates a new DB++ relation

Description

resource dbplus_rcreate ( string name, mixed domlist [, bool overwrite])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_rcreate() will create a new relation named name. An existing relation by the same name will only be overwritten if the relation is currently not in use and overwrite is set to TRUE.

domlist should contain the domain specification for the new relation within an array of domain description strings. ( dbplus_rcreate() will also accept a string with space delimited domain description strings, but it is recommended to use an array). A domain description string consists of a domain name unique to this relation, a slash and a type specification character. See the db++ documentation, especially the dbcreate(1) manpage, for a description of available type specifiers and their meanings.

이전 | 처음으로 | 다음
dbplus_rchperm | 위로 | dbplus_rcrtexact


dbplus_rcrtexact

(4.1.0 - 4.2.3 only)

dbplus_rcrtexact -- Creates an exact but empty copy of a relation including indices

Description

resource dbplus_rcrtexact ( string name, resource relation, bool overwrite)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_rcrtexact() will create an exact but empty copy of the given relation under a new name. An existing relation by the same name will only be overwritten if overwrite is TRUE and no other process is currently using the relation.

이전 | 처음으로 | 다음
dbplus_rcreate | 위로 | dbplus_rcrtlike


dbplus_rcrtlike

(4.1.0 - 4.2.3 only)

dbplus_rcrtlike -- Creates an empty copy of a relation with default indices

Description

resource dbplus_rcrtlike ( string name, resource relation, int flag)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_rcrtexact() will create an empty copy of the given relation under a new name, but with default indices. An existing relation by the same name will only be overwritten if overwrite is TRUE and no other process is currently using the relation.

이전 | 처음으로 | 다음
dbplus_rcrtexact | 위로 | dbplus_resolve


dbplus_resolve

(4.1.0 - 4.2.3 only)

dbplus_resolve -- Resolve host information for relation

Description

int dbplus_resolve ( string relation_name)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_resolve() will try to resolve the given relation_name and find out internal server id, real hostname and the database path on this host. The function will return an array containing these values under the keys 'sid', 'host' and 'host_path' or FALSE on error.

See also dbplus_tcl().

이전 | 처음으로 | 다음
dbplus_rcrtlike | 위로 | dbplus_restorepos


dbplus_restorepos

(4.1.0 - 4.2.3 only)

dbplus_restorepos -- ???

Description

int dbplus_restorepos ( resource relation, array tuple)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Not implemented yet.

이전 | 처음으로 | 다음
dbplus_resolve | 위로 | dbplus_rkeys


dbplus_rkeys

(4.1.0 - 4.2.3 only)

dbplus_rkeys -- Specify new primary key for a relation

Description

resource dbplus_rkeys ( resource relation, mixed domlist)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_rkeys() will replace the current primary key for relation with the combination of domains specified by domlist.

domlist may be passed as a single domain name string or as an array of domain names.

이전 | 처음으로 | 다음
dbplus_restorepos | 위로 | dbplus_ropen


dbplus_ropen

(4.1.0 - 4.2.3 only)

dbplus_ropen -- Open relation file local

Description

resource dbplus_ropen ( string name)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_ropen() will open the relation file locally for quick access without any client/server overhead. Access is read only and only dbplus_current() and dbplus_next() may be applied to the returned relation.

이전 | 처음으로 | 다음
dbplus_rkeys | 위로 | dbplus_rquery


dbplus_rquery

(4.1.0 - 4.2.3 only)

dbplus_rquery -- Perform local (raw) AQL query

Description

int dbplus_rquery ( string query, string dbpath)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_rquery() performs a local (raw) AQL query using an AQL interpreter embedded into the db++ client library. dbplus_rquery() is faster than dbplus_aql() but will work on local data only.

이전 | 처음으로 | 다음
dbplus_ropen | 위로 | dbplus_rrename


dbplus_rrename

(4.1.0 - 4.2.3 only)

dbplus_rrename -- Rename a relation

Description

int dbplus_rrename ( resource relation, string name)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_rrename() will change the name of relation to name.

이전 | 처음으로 | 다음
dbplus_rquery | 위로 | dbplus_rsecindex


dbplus_rsecindex

(4.1.0 - 4.2.3 only)

dbplus_rsecindex -- Create a new secondary index for a relation

Description

resource dbplus_rsecindex ( resource relation, mixed domlist, int type)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_rsecindex() will create a new secondary index for relation with consists of the domains specified by domlist and is of type type

domlist may be passed as a single domain name string or as an array of domain names.

이전 | 처음으로 | 다음
dbplus_rrename | 위로 | dbplus_runlink


dbplus_runlink

(4.1.0 - 4.2.3 only)

dbplus_runlink -- Remove relation from filesystem

Description

int dbplus_runlink ( resource relation)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_unlink() will close and remove the relation.

이전 | 처음으로 | 다음
dbplus_rsecindex | 위로 | dbplus_rzap


dbplus_rzap

(4.1.0 - 4.2.3 only)

dbplus_rzap -- Remove all tuples from relation

Description

int dbplus_rzap ( resource relation)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_rzap() will remove all tuples from relation.

이전 | 처음으로 | 다음
dbplus_runlink | 위로 | dbplus_savepos


dbplus_savepos

(4.1.0 - 4.2.3 only)

dbplus_savepos -- ???

Description

int dbplus_savepos ( resource relation)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Not implemented yet.

이전 | 처음으로 | 다음
dbplus_rzap | 위로 | dbplus_setindex


dbplus_setindex

(4.1.0 - 4.2.3 only)

dbplus_setindex -- ???

Description

int dbplus_setindex ( resource relation, string idx_name)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Not implemented yet.

이전 | 처음으로 | 다음
dbplus_savepos | 위로 | dbplus_setindexbynumber


dbplus_setindexbynumber

(4.1.0 - 4.2.3 only)

dbplus_setindexbynumber -- ???

Description

int dbplus_setindexbynumber ( resource relation, int idx_number)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Not implemented yet.

이전 | 처음으로 | 다음
dbplus_setindex | 위로 | dbplus_sql


dbplus_sql

(4.1.0 - 4.2.3 only)

dbplus_sql -- Perform SQL query

Description

resource dbplus_sql ( string query, string server, string dbpath)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Not implemented yet.

이전 | 처음으로 | 다음
dbplus_setindexbynumber | 위로 | dbplus_tcl


dbplus_tcl

(4.1.0 - 4.2.3 only)

dbplus_tcl -- Execute TCL code on server side

Description

int dbplus_tcl ( int sid, string script)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

A db++ server will prepare a TCL interpreter for each client connection. This interpreter will enable the server to execute TCL code provided by the client as a sort of stored procedures to improve the performance of database operations by avoiding client/server data transfers and context switches.

dbplus_tcl() needs to pass the client connection id the TCL script code should be executed by. dbplus_resolve() will provide this connection id. The function will return whatever the TCL code returns or a TCL error message if the TCL code fails.

See also dbplus_resolve().

이전 | 처음으로 | 다음
dbplus_sql | 위로 | dbplus_tremove


dbplus_tremove

(4.1.0 - 4.2.3 only)

dbplus_tremove -- Remove tuple and return new current tuple

Description

int dbplus_tremove ( resource relation, array tuple [, array current])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_tremove() removes tuple from relation if it perfectly matches a tuple within the relation. current, if given, will contain the data of the new current tuple after calling dbplus_tremove().

이전 | 처음으로 | 다음
dbplus_tcl | 위로 | dbplus_undo


dbplus_undo

(4.1.0 - 4.2.3 only)

dbplus_undo -- ???

Description

int dbplus_undo ( resource relation)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Not implemented yet.

이전 | 처음으로 | 다음
dbplus_tremove | 위로 | dbplus_undoprepare


dbplus_undoprepare

(4.1.0 - 4.2.3 only)

dbplus_undoprepare -- ???

Description

int dbplus_undoprepare ( resource relation)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Not implemented yet.

이전 | 처음으로 | 다음
dbplus_undo | 위로 | dbplus_unlockrel


dbplus_unlockrel

(4.1.0 - 4.2.3 only)

dbplus_unlockrel -- Give up write lock on relation

Description

int dbplus_unlockrel ( resource relation)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_unlockrel() will release a write lock previously obtained by dbplus_lockrel().

이전 | 처음으로 | 다음
dbplus_undoprepare | 위로 | dbplus_unselect


dbplus_unselect

(4.1.0 - 4.2.3 only)

dbplus_unselect -- Remove a constraint from relation

Description

int dbplus_unselect ( resource relation)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Calling dbplus_unselect() will remove a constraint previously set by dbplus_find() on relation.

이전 | 처음으로 | 다음
dbplus_unlockrel | 위로 | dbplus_update


dbplus_update

(4.1.0 - 4.2.3 only)

dbplus_update -- Update specified tuple in relation

Description

int dbplus_update ( resource relation, array old, array new)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_update() replaces the tuple given by old with the data from new if and only if old completely matches a tuple within relation.

이전 | 처음으로 | 다음
dbplus_unselect | 위로 | dbplus_xlockrel


dbplus_xlockrel

(4.1.0 - 4.2.3 only)

dbplus_xlockrel -- Request exclusive lock on relation

Description

int dbplus_xlockrel ( resource relation)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_xlockrel() will request an exclusive lock on relation preventing even read access from other clients.

See also dbplus_xunlockrel().

이전 | 처음으로 | 다음
dbplus_update | 위로 | dbplus_xunlockrel


dbplus_xunlockrel

(4.1.0 - 4.2.3 only)

dbplus_xunlockrel -- Free exclusive lock on relation

Description

int dbplus_xunlockrel ( resource relation)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

dbplus_xunlockrel() will release an exclusive lock on relation previously obtained by dbplus_xlockrel().

이전 | 처음으로 | 다음
dbplus_xlockrel | 위로 | Direct IO Functions


Direct IO Functions

PHP 매뉴얼
이전 다음

XXII. Direct IO Functions

소개

PHP supports the direct io functions as described in the Posix Standard (Section 6) for performing I/O functions at a lower level than the C-Language stream I/O functions (fopen(), fread(),..). The use of the DIO functions should be considered only when direct control of a device is needed. In all other cases, the standard filesystem functions are more than adequate.

참고: 이 확장 모듈은 윈도우 플랫폼에서는 사용할 수 없습니다.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

To get these functions to work, you have to configure PHP with --enable-dio.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

One resource type is defined by this extension: a file descriptor returned by dio_open().

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
dio_close -- Closes the file descriptor given by fd
dio_fcntl -- Performs a c library fcntl on fd
dio_open -- Opens a new filename with specified permissions of flags and creation permissions of mode
dio_read -- Reads n bytes from fd and returns them, if n is not specified, reads 1k block
dio_seek -- Seeks to pos on fd from whence
dio_stat -- Gets stat information about the file descriptor fd
dio_tcsetattr -- Sets terminal attributes and baud rate for a serial port
dio_truncate -- Truncates file descriptor fd to offset bytes
dio_write -- Writes data to fd with optional truncation at length

이전 | 처음으로 | 다음
dbplus_xunlockrel | 위로 | dio_close


dio_close

(PHP 4 >= 4.2.0, PHP 5)

dio_close -- Closes the file descriptor given by fd

Description

void dio_close ( resource fd)

The function dio_close() closes the file descriptor fd.

See also dio_open().

이전 | 처음으로 | 다음
Direct IO Functions | 위로 | dio_fcntl


dio_fcntl

(PHP 4 >= 4.2.0, PHP 5)

dio_fcntl -- Performs a c library fcntl on fd

Description

mixed dio_fcntl ( resource fd, int cmd [, mixed args])

The dio_fcntl() function performs the operation specified by cmd on the file descriptor fd. Some commands require additional arguments args to be supplied.

args is an associative array, when cmd is F_SETLK or F_SETLLW, with the following keys:

  • "start" - offset where lock begins

  • "length" - size of locked area. zero means to end of file

  • "wenth" - Where l_start is relative to: can be SEEK_SET, SEEK_END and SEEK_CUR

  • "type" - type of lock: can be F_RDLCK (read lock), F_WRLCK (write lock) or F_UNLCK (unlock)

cmd can be one of the following operations:

  • F_SETLK - Lock is set or cleared. If the lock is held by someone else dio_fcntl() returns -1.

  • F_SETLKW - like F_SETLK, but in case the lock is held by someone else, dio_fcntl() waits until the lock is released.

  • F_GETLK - dio_fcntl() returns an associative array (as described above) if someone else prevents lock. If there is no obstruction key "type" will set to F_UNLCK.

  • F_DUPFD - finds the lowest numbered available file descriptor greater or equal than args and returns them.

  • F_SETFL - Sets the file descriptors flags to the value specified by args, which can be O_APPEND,O_NONBLOCK or O_ASYNC. To use O_ASYNC you will need to use the PCNTL extension.

이전 | 처음으로 | 다음
dio_close | 위로 | dio_open


dio_open

(PHP 4 >= 4.2.0, PHP 5)

dio_open -- Opens a new filename with specified permissions of flags and creation permissions of mode

Description

resource dio_open ( string filename, int flags [, int mode])

dio_open() opens a file and returns a new file descriptor for it, or FALSE if any error occurred. If flags is O_CREAT, the optional third parameter mode will set the mode of the file (creation permissions). The flags parameter can be one of the following options:

  • O_RDONLY - opens the file for read access.

  • O_WRONLY - opens the file for write access.

  • O_RDWR - opens the file for both reading and writing.

The flags parameter can also include any combination of the following flags:

  • O_CREAT - creates the file, if it doesn't already exist.

  • O_EXCL - if both, O_CREAT and O_EXCL are set, dio_open() fails, if the file already exists.

  • O_TRUNC - if the file exists, and its opened for write access, the file will be truncated to zero length.

  • O_APPEND - write operations write data at the end of the file.

  • O_NONBLOCK - sets non blocking mode.

See also: dio_close().

이전 | 처음으로 | 다음
dio_fcntl | 위로 | dio_read


dio_read

(PHP 4 >= 4.2.0, PHP 5)

dio_read -- Reads n bytes from fd and returns them, if n is not specified, reads 1k block

Description

string dio_read ( resource fd [, int n])

The function dio_read() reads and returns n bytes from file with descriptor fd. If n is not specified, dio_read() reads 1K sized block and returns them.

See also: dio_write().

이전 | 처음으로 | 다음
dio_open | 위로 | dio_seek


dio_seek

(PHP 4 >= 4.2.0, PHP 5)

dio_seek -- Seeks to pos on fd from whence

Description

int dio_seek ( resource fd, int pos, int whence)

The function dio_seek() is used to change the file position of the file with descriptor fd. The parameter whence specifies how the position pos should be interpreted:

  • SEEK_SET - specifies that pos is specified from the beginning of the file.

  • SEEK_CUR - Specifies that pos is a count of characters from the current file position. This count may be positive or negative.

  • SEEK_END - Specifies that pos is a count of characters from the end of the file. A negative count specifies a position within the current extent of the file; a positive count specifies a position past the current end. If you set the position past the current end, and actually write data, you will extend the file with zeros up to that position.

이전 | 처음으로 | 다음
dio_read | 위로 | dio_stat


dio_stat

(PHP 4 >= 4.2.0, PHP 5)

dio_stat -- Gets stat information about the file descriptor fd

Description

array dio_stat ( resource fd)

Function dio_stat() returns information about the file with file descriptor fd. dio_stat() returns an associative array with the following keys:

  • "device" - device

  • "inode" - inode

  • "mode" - mode

  • "nlink" - number of hard links

  • "uid" - user id

  • "gid" - group id

  • "device_type" - device type (if inode device)

  • "size" - total size in bytes

  • "blocksize" - blocksize

  • "blocks" - number of blocks allocated

  • "atime" - time of last access

  • "mtime" - time of last modification

  • "ctime" - time of last change

On error dio_stat() returns NULL.

이전 | 처음으로 | 다음
dio_seek | 위로 | dio_tcsetattr


dio_tcsetattr

(PHP 4 >= 4.3.0, PHP 5)

dio_tcsetattr -- Sets terminal attributes and baud rate for a serial port

Description

void dio_tcsetattr ( resource fd, array options)

The function dio_tcsetattr() sets the terminal attributes and baud rate of the open resource. The currently available options are

  • 'baud' - baud rate of the port - can be 38400,19200,9600,4800,2400,1800, 1200,600,300,200,150,134,110,75 or 50, default value is 9600.

  • 'bits' - data bits - can be 8,7,6 or 5. Default value is 8.

  • 'stop' - stop bits - can be 1 or 2. Default value is 1.

  • 'parity' - can be 0,1 or 2. Default value is 0.

예 1. Setting the baud rate on a serial port

<?php

$fd = dio_open('/dev/ttyS0', O_RDWR | O_NOCTTY | O_NONBLOCK);

dio_fcntl($fd, F_SETFL, O_SYNC);

dio_tcsetattr($fd, array(
  'baud' => 9600,
  'bits' => 8,
  'stop'  => 1,
  'parity' => 0
));

while (1) {

  $data = dio_read($fd, 256);

  if ($data) {
      echo $data;
  }
}

?>

이전 | 처음으로 | 다음
dio_stat | 위로 | dio_truncate


dio_truncate

(PHP 4 >= 4.2.0, PHP 5)

dio_truncate -- Truncates file descriptor fd to offset bytes

Description

bool dio_truncate ( resource fd, int offset)

Function dio_truncate() causes the file referenced by fd to be truncated to at most offset bytes in size. If the file previously was larger than this size, the extra data is lost. If the file previously was shorter, it is unspecified whether the file is left unchanged or is extended. In the latter case the extended part reads as zero bytes. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다..

이전 | 처음으로 | 다음
dio_tcsetattr | 위로 | dio_write


dio_write

(PHP 4 >= 4.2.0, PHP 5)

dio_write -- Writes data to fd with optional truncation at length

Description

int dio_write ( resource fd, string data [, int len])

The function dio_write() writes up to len bytes from data to file fd. If len is not specified, dio_write() writes all data to the specified file. dio_write() returns the number of bytes written to fd.

See also dio_read().

이전 | 처음으로 | 다음
dio_truncate | 위로 | 디렉토리 함수


디렉토리 함수

PHP 매뉴얼
이전 다음

XXIII. 디렉토리 함수

소개

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

DIRECTORY_SEPARATOR (string)

PATH_SEPARATOR (string)

참고: PATH_SEPARATOR는 PHP 4.3.0-RC2에서 추가되었습니다.

참고

dirname(), is_dir(), mkdir(), rmdir() 등의 관련 함수에 대해서, 파일시스템 섹션을 참고하십시오.

차례
chdir -- 디렉토리를 변경합니다.
chroot -- 루트 디렉토리를 변경합니다.
dir -- 디렉토리 클래스
closedir -- 디렉토리 핸들을 닫습니다.
getcwd -- 현재 작업 디렉토리를 구합니다.
opendir -- 디렉토리 핸들을 엽니다.
readdir -- 디렉토리 핸들에서 엔트리를 읽습니다.
rewinddir -- 디렉토리 핸들을 되감습니다.
scandir -- 지정 경로 안의 파일과 디렉토리 목록

이전 | 처음으로 | 다음
dio_write | 위로 | chdir


chdir

(PHP 3, PHP 4 , PHP 5)

chdir -- 디렉토리를 변경합니다.

설명

bool chdir ( string directory)

PHP의 현재 디렉토리를 directory로 변경합니다. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. chdir() 예제

<?php

// 현재 디렉토리
echo getcwd() . "\n";

chdir('public_html');

// 현재 디렉토리
echo getcwd() . "\n";

?>

출력 예는:

/home/vincent
/home/vincent/public_html

참고: 안전 모드를 활성화했을 경우, PHP는 작업하려는 디렉토리가 실행중인 스크립트와 같은 UID(owner)를 가지고 있는지 확인합니다.

참고: getcwd().

이전 | 처음으로 | 다음
디렉토리 함수 | 위로 | chroot


chroot

(PHP 4 >= 4.0.5, PHP 5)

chroot -- 루트 디렉토리를 변경합니다.

설명

bool chroot ( string directory)

현재 프로세스의 루트 디렉토리를 directory로 변경합니다. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이 함수는 시스템이 지원하고, CLI, CGI, Embed SAPI를 사용할 때만 사용할 수 있습니다.

참고: chroot()는 루트 권한이 필요합니다.

참고: 이 함수는 윈도우 플랫폼에서는 작동하지 않습니다.

이전 | 처음으로 | 다음
chdir | 위로 | dir


dir

dir -- 디렉토리 클래스

설명

class dir {

dir ( string directory)

string path

resource handle

string read ( void )

void rewind ( void )

void close ( void )

}

디렉토리를 읽는 모조-객체 기반 방법입니다. 주어진 directory를 엽니다. 열려진 디렉토리에 사용할 수 있는 두가지 속성이 존재합니다. handle 속성은 readdir(), rewinddir(), closedir() 등의 다른 디렉토리 함수에 사용할 수 있습니다. path 속성에은 열려진 디렉토리의 경로가 지정됩니다. 세가지 메쏘드를 사용할 수 있습니다: read, rewind, close.

dir()의 반환값은 아래 예제처럼 확인해야 하는 점에 주의하십시오. 반환값이 FALSE와 완전히 동일한지 (형까지 같게--자세한 정보는 비교 연산자를 참고하십시오) 확인하고 있습니다. 이렇게 하지 않으면, FALSE로 판단할 수 있는 이름을 가진 디렉토리 엔트리에서 루프가 멈춥니다.

예 1. dir() 예제

<?php
$d = dir("/etc");
echo "Handle: " . $d->handle . "<br />\n";
echo "Path: " . $d->path . "<br />\n";
while (false !== ($entry = $d->read())) {
   echo $entry."<br />\n";
}
$d->close();
?>

참고: read 메쏘드가 반환하는 디렉토리 엔트리의 순서는 시스템 의존적입니다.

참고: 이는 내부적으로 Directory 클래스를 정의하기에, 이 이름을 가지는 클래스를 정의할 수 없습니다. PHP에 미리 정의된 클래스의 전체 목록은 미리 정의된 클래스를 참고하십시오.

이전 | 처음으로 | 다음
chroot | 위로 | closedir


closedir

(PHP 3, PHP 4 , PHP 5)

closedir -- 디렉토리 핸들을 닫습니다.

설명

void closedir ( resource dir_handle)

dir_handle가 지시하는 디렉토리 스트림을 닫습니다. 스트림은 opendir()로 열려 있는 것이여야 합니다.

이전 | 처음으로 | 다음
dir | 위로 | getcwd


getcwd

(PHP 4 , PHP 5)

getcwd -- 현재 작업 디렉토리를 구합니다.

설명

string getcwd ( void )

현재 작업 디렉토리를 반환합니다.

예 1. getcwd() 예제

<?php

// 현재 디렉토리
echo getcwd() . "\n";

chdir('cvs');

// 현재 디렉토리
echo getcwd() . "\n";

?>

다음과 비슷한 출력을 합니다:

/home/didou
/home/didou/cvs

참고: chdir().

이전 | 처음으로 | 다음
closedir | 위로 | opendir


opendir

(PHP 3, PHP 4 , PHP 5)

opendir -- 디렉토리 핸들을 엽니다.

설명

resource opendir ( string path)

closedir(), readdir(), rewinddir() 호출에서 사용하는 디렉토리 핸들을 반환합니다.

path가 유효하지 않은 디렉토리이거나, 권한 제한이나 파일시스템 에러로 인해 디렉토리를 열 수 없는 경우, opendir()은 FALSE를 반환하고 E_WARNING 레벨의 PHP 에러를 발생합니다. opendir() 앞에 '@'를 붙여 에러 출력을 없앨 수 있습니다.

예 1. opendir() 예제

<?php
$dir = "/tmp/";

// 알고 있는 디렉토리를 열어서, 내용을 읽어들이는 작업입니다.
if (is_dir($dir)) {
    if ($dh = opendir($dir)) {
        while (($file = readdir($dh)) !== false) {
            echo "filename: $file : filetype: " . filetype($dir . $file) . "\n";
        }
        closedir($dh);
    }
}
?>

PHP 4.3.0부터 path는 디렉토리 목록을 지원하는 URL일 수 있지만, PHP 4.3에서는 file:// URL 래퍼만 지원합니다. PHP 5.0.0부터는 ftp:// URL 래퍼도 지원합니다.

참고: is_dir(), readdir(), Dir

이전 | 처음으로 | 다음
getcwd | 위로 | readdir


readdir

(PHP 3, PHP 4 , PHP 5)

readdir -- 디렉토리 핸들에서 엔트리를 읽습니다.

설명

string readdir ( resource dir_handle)

디렉토리에서 다음 파일의 파일명을 반환합니다. 반환하는 파일명의 순서는 파일시스템에 저장한 순서입니다.

readdir()의 반환값은 아래 예제체럼 확인해야 하는 점에 주의하십시오. 반환값이 FALSE와 완전히 동일한지 (형까지 일치--자세한 정보는 비교 연산자를 참고하십시오) 확인하고 있습니다. 이렇게 하지 않으면, FALSE로 인식하는 디렉토리 엔트리에서 루프가 멈춥니다. (예. 디렉토리 이름이 "0")

예 1. 디렉토리 안의 모든 파일 목록

<?php
// !== 은 4.0.0-RC2까지 존재하지 않았던 점에 주의하십시오.

if ($handle = opendir('/path/to/files')) {
    echo "Directory handle: $handle\n";
    echo "Files:\n";

    /* 디렉토리 안을 루프하는 올바른 방법입니다. */
    while (false !== ($file = readdir($handle))) {
        echo "$file\n";
    }

    /* 디렉토리 안을 루프하는 *틀린* 방법입니다. */
    while ($file = readdir($handle)) {
        echo "$file\n";
    }

    closedir($handle);
}
?>

readdir()이 .과 ..을 반환하는 점에 주의하십시오. 이들이 필요하지 않으면 간단히 제거할 수 있습니다:

예 2. .과 ..을 제외한 현재 디렉토리의 모든 파일 목록

<?php
if ($handle = opendir('.')) {
    while (false !== ($file = readdir($handle))) {
        if ($file != "." && $file != "..") {
            echo "$file\n";
        }
    }
    closedir($handle);
}
?>

참고: is_dir(), glob().

이전 | 처음으로 | 다음
opendir | 위로 | rewinddir


rewinddir

(PHP 3, PHP 4 , PHP 5)

rewinddir -- 디렉토리 핸들을 되감습니다.

설명

void rewinddir ( resource dir_handle)

dir_handle에 지정한 디렉토리 핸들을 디렉토리의 처음 위치로 되돌립니다.

이전 | 처음으로 | 다음
readdir | 위로 | scandir


scandir

(PHP 5)

scandir -- 지정 경로 안의 파일과 디렉토리 목록

설명

array scandir ( string directory [, int sorting_order [, resource context]])

directory에서 파일과 디렉토리의 array를 반환합니다. directory가 디렉토리가 아닐 경우, 불린 FALSE를 반환하고, 에러 레벨 E_WARNING를 생생합니다.

기본값으로, 정렬 순서는 알파벳 오름 차순입니다. 선택적인 sorting_order를 사용하면(1로 설정), 정렬 순서는 알파벳 내림 차순입니다.

예 1. 간단한 scandir() 예제

<?php
$dir    = '/tmp';
$files1 = scandir($dir);
$files2 = scandir($dir, 1);

print_r($files1);
print_r($files2);
?>

출력 예는:

Array
(
    [0] => .
    [1] => ..
    [2] => bar.php
    [3] => foo.txt
    [4] => somedir
)
Array
(
    [0] => somedir
    [1] => foo.txt
    [2] => bar.php
    [3] => ..
    [4] => .
)

예 2. scandir()과 동일한 PHP 4 방법

<?php
$dir = "/tmp";
$dh  = opendir($dir);
while (false !== ($filename = readdir($dh))) {
    $files[] = $filename;
}

sort($files);

print_r($files);

rsort($files);

print_r($files);

?>

출력 예는:

Array
(
    [0] => .
    [1] => ..
    [2] => bar.php
    [3] => foo.txt
    [4] => somedir
)
Array
(
    [0] => somedir
    [1] => foo.txt
    [2] => bar.php
    [3] => ..
    [4] => .
)

작은 정보: fopen wrappers를 설정하면, 이 함수의 파일 이름으로 URL을 사용할 수 있습니다. 파일 이름을 지정하는 방법은 fopen()을 참고하고, 지원하는 URL 프로토콜 목록은 부록 J를 참고하십시오.

참고: opendir(),
readdir(),
glob(),
is_dir(),
sort().

이전 | 처음으로 | 다음
rewinddir | 위로 | DOM XML Functions


DOM XML Functions

PHP 매뉴얼
이전 다음

XXIV. DOM XML Functions

소개

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

The DOM XML extension has been overhauled in PHP 4.3.0 to better comply with the DOM standard. The extension still contains many old functions, but they should no longer be used. In particular, functions that are not object-oriented should be avoided.

The extension allows you to operate on an XML document with the DOM API. It also provides a function domxml_xmltree() to turn the complete XML document into a tree of PHP objects. Currently, this tree should be considered read-only - you can modify it, but this would not make any sense since DomDocument_dump_mem() cannot be applied to it. Therefore, if you want to read an XML file and write a modified version, use DomDocument_create_element(), DomDocument_create_text_node(), set_attribute(), etc. and finally the DomDocument_dump_mem() function.

요구 사항

This extension makes use of the GNOME XML library. Download and install this library. You will need at least libxml-2.4.14. To use DOM XSLT features you can use the libxslt library and EXSLT enhancements from http://www.exslt.org/. Download and install these libraries if you plan to use (enhanced) XSLT features. You will need at least libxslt-1.0.18.

설치

This extension is only available if PHP was configured with --with-dom[=DIR]. Add --with-dom-xslt[=DIR] to include DOM XSLT support. DIR is the libxslt install directory. Add --with-dom-exslt[=DIR] to include DOM EXSLT support, where DIR is the libexslt install directory.

Note to Win32 Users: In order to enable this module on a Windows environment, you must copy one additional file from the DLL folder of the PHP/Win32 binary package to the SYSTEM32 folder of your Windows machine (Ex: C:\WINNT\SYSTEM32 or C:\WINDOWS\SYSTEM32). For PHP <= 4.2.0 copy libxml2.dll, for PHP >= 4.3.0 copy iconv.dll from the DLL folder to your SYSTEM32 folder.

Deprecated functions

There are quite a few functions that do not fit into the DOM standard and should no longer be used. These functions are listed in the following table. The function DomNode_append_child() has changed its behaviour. It now adds a child and not a sibling. If this breaks your application, use the non-DOM function DomNode_append_sibling().

표 1. Deprecated functions and their replacements

Old function | New function
xmldoc | domxml_open_mem()
xmldocfile | domxml_open_file()
domxml_new_xmldoc | domxml_new_doc()
domxml_dump_mem | DomDocument_dump_mem()
domxml_dump_mem_file | DomDocument_dump_file()
DomDocument_dump_mem_file | DomDocument_dump_file()
DomDocument_add_root | DomDocument_create_element() followed by DomNode_append_child()
DomDocument_dtd | DomDocument_doctype()
DomDocument_root | DomDocument_document_element()
DomDocument_children | DomNode_child_nodes()
DomDocument_imported_node | No replacement.
DomNode_add_child | Create a new node with e.g. DomDocument_create_element() and add it with DomNode_append_child().
DomNode_children | DomNode_child_nodes()
DomNode_parent | DomNode_parent_node()
DomNode_new_child | Create a new node with e.g. DomDocument_create_element() and add it with DomNode_append_child().
DomNode_set_content | Create a new node with e.g. DomDocument_create_text_node() and add it with DomNode_append_child().
DomNode_get_content | Content is just a text node and can be accessed with DomNode_child_nodes().
DomNode_set_content | Content is just a text node and can be added with DomNode_append_child().

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

표 2. XML constants

Constant | Value | Description
XML_ELEMENT_NODE (integer) | 1 | Node is an element
XML_ATTRIBUTE_NODE (integer) | 2 | Node is an attribute
XML_TEXT_NODE (integer) | 3 | Node is a piece of text
XML_CDATA_SECTION_NODE (integer) | 4 |
XML_ENTITY_REF_NODE (integer) | 5 |
XML_ENTITY_NODE (integer) | 6 | Node is an entity like &nbsp;
XML_PI_NODE (integer) | 7 | Node is a processing instruction
XML_COMMENT_NODE (integer) | 8 | Node is a comment
XML_DOCUMENT_NODE (integer) | 9 | Node is a document
XML_DOCUMENT_TYPE_NODE (integer) | 10 |
XML_DOCUMENT_FRAG_NODE (integer) | 11 |
XML_NOTATION_NODE (integer) | 12 |
XML_GLOBAL_NAMESPACE (integer) | 1 |
XML_LOCAL_NAMESPACE (integer) | 2 |
XML_HTML_DOCUMENT_NODE (integer) |  |
XML_DTD_NODE (integer) |  |
XML_ELEMENT_DECL_NODE (integer) |  |
XML_ATTRIBUTE_DECL_NODE (integer) |  |
XML_ENTITY_DECL_NODE (integer) |  |
XML_NAMESPACE_DECL_NODE (integer) |  |
XML_ATTRIBUTE_CDATA (integer) |  |
XML_ATTRIBUTE_ID (integer) |  |
XML_ATTRIBUTE_IDREF (integer) |  |
XML_ATTRIBUTE_IDREFS (integer) |  |
XML_ATTRIBUTE_ENTITY (integer) |  |
XML_ATTRIBUTE_NMTOKEN (integer) |  |
XML_ATTRIBUTE_NMTOKENS (integer) |  |
XML_ATTRIBUTE_ENUMERATION (integer) |  |
XML_ATTRIBUTE_NOTATION (integer) |  |
XPATH_UNDEFINED (integer) |  |
XPATH_NODESET (integer) |  |
XPATH_BOOLEAN (integer) |  |
XPATH_NUMBER (integer) |  |
XPATH_STRING (integer) |  |
XPATH_POINT (integer) |  |
XPATH_RANGE (integer) |  |
XPATH_LOCATIONSET (integer) |  |
XPATH_USERS (integer) |  |
XPATH_NUMBER (integer) |  |

Classes

The API of the module follows the DOM Level 2 standard as closely as possible. Consequently, the API is fully object-oriented. It is a good idea to have the DOM standard available when using this module. Though the API is object-oriented, there are many functions which can be called in a non-object-oriented way by passing the object to operate on as the first argument. These functions are mainly to retain compatibility to older versions of the extension, and should not be used when creating new scripts.

This API differs from the official DOM API in two ways. First, all class attributes are implemented as functions with the same name. Secondly, the function names follow the PHP naming convention. This means that a DOM function lastChild() will be written as last_child().

This module defines a number of classes, which are listed - including their method - in the following tables. Classes with an equivalent in the DOM standard are named DOMxxx.

표 3. List of classes

Class name | Parent classes
DomAttribute | DomNode
DomCData | DomNode
DomComment | DomCData : DomNode
DomDocument | DomNode
DomDocumentType | DomNode
DomElement | DomNode
DomEntity | DomNode
DomEntityReference | DomNode
DomProcessingInstruction | DomNode
DomText | DomCData : DomNode
Parser | Currently still called DomParser
XPathContext |

표 4. DomDocument class (DomDocument : DomNode)

Method name | Function name | Remark
doctype | DomDocument_doctype() |
document_element | DomDocument_document_element() |
create_element | DomDocument_create_element() |
create_text_node | DomDocument_create_text_node() |
create_comment | DomDocument_create_comment() |
create_cdata_section | DomDocument_create_cdata_section() |
create_processing_instruction | DomDocument_create_processing_instruction() |
create_attribute | DomDocument_create_attribute() |
create_entity_reference | DomDocument_create_entity_reference() |
get_elements_by_tagname | DomDocument_get_elements_by_tagname() |
get_element_by_id | DomDocument_get_element_by_id() |
dump_mem | DomDocument_dump_mem() | not DOM standard
dump_file | DomDocument_dump_file() | not DOM standard
html_dump_mem | DomDocument_html_dump_mem() | not DOM standard
xpath_init | xpath_init | not DOM standard
xpath_new_context | xpath_new_context | not DOM standard
xptr_new_context | xptr_new_context | not DOM standard

표 5. DomElement class (DomElement : DomNode)

Method name | Function name | Remark
tagname | DomElement_tagname() |
get_attribute | DomElement_get_attribute() |
set_attribute | DomElement_set_attribute() |
remove_attribute | DomElement_remove_attribute() |
get_attribute_node | DomElement_get_attribute_node() |
get_elements_by_tagname | DomElement_get_elements_by_tagname() |
has_attribute | DomElement_has_attribute() |

표 6. DomNode class

Method name | Remark
DomNode_node_name() |
DomNode_node_value() |
DomNode_node_type() |
DomNode_last_child() |
DomNode_first_child() |
DomNode_child_nodes() |
DomNode_previous_sibling() |
DomNode_next_sibling() |
DomNode_parent_node() |
DomNode_owner_document() |
DomNode_insert_before() |
DomNode_append_child() |
DomNode_append_sibling() | Not in DOM standard. This function emulates the former behaviour of DomNode_append_child().
DomNode_remove_child() |
DomNode_has_child_nodes() |
DomNode_has_attributes() |
DomNode_clone_node() |
DomNode_attributes() |
DomNode_unlink_node() | Not in DOM standard
DomNode_replace_node() | Not in DOM standard
DomNode_set_content() | Not in DOM standard, deprecated
DomNode_get_content() | Not in DOM standard, deprecated
DomNode_dump_node() | Not in DOM standard
DomNode_is_blank_node() | Not in DOM standard

표 7. DomAttribute class (DomAttribute : DomNode)

Method name |  | Remark
name | DomAttribute_name() |
value | DomAttribute_value() |
specified | DomAttribute_specified() |

표 8. DomProcessingInstruction class (DomProcessingInstruction : DomNode)

Method name | Function name | Remark
target | DomProcessingInstruction_target() |
data | DomProcessingInstruction_data() |

표 9. Parser class

Method name | Function name | Remark
add_chunk | Parser_add_chunk() |
end | Parser_end() |

표 10. XPathContext class

Method name | Function name | Remark
eval | XPathContext_eval() |
eval_expression | XPathContext_eval_expression() |
register_ns | XPathContext_register_ns() |

표 11. DomDocumentType class (DomDocumentType : DomNode)

Method name | Function name | Remark
name | DomDocumentType_name() |
entities | DomDocumentType_entities() |
notations | DomDocumentType_notations() |
public_id | DomDocumentType_public_id() |
system_id | DomDocumentType_system_id() |
internal_subset | DomDocumentType_internal_subset() |

The classes DomDtd is derived from DomNode. DomComment is derived from DomCData.

예제

Many examples in this reference require an XML string. Instead of repeating this string in every example, it will be put into a file which will be included by each example. This include file is shown in the following example section. Alternatively, you could create an XML document and read it with DomDocument_open_file().

예 1. Include file example.inc with XML string

<?php
$xmlstr = "<?xml version='1.0' standalone='yes'?>
<!DOCTYPE chapter SYSTEM '/share/sgml/Norman_Walsh/db3xml10/db3xml10.dtd'
[ <!ENTITY sp \"spanish\">
]>
<!-- lsfj  -->
<chapter language='en'><title language='en'>Title</title>
<para language='ge'>
  &amp;sp;
  <!-- comment -->
  <informaltable ID='findme' language='&amp;sp;'>
   <tgroup cols='3'>
    <tbody>
     <row><entry>a1</entry><entry
morerows='1'>b1</entry><entry>c1</entry></row>
<row><entry>a2</entry><entry>c2</entry></row>
     <row><entry>a3</entry><entry>b3</entry><entry>c3</entry></row>
    </tbody>
   </tgroup>
  </informaltable>
</para>
</chapter>";
?>

차례
DomAttribute->name -- Returns name of attribute
DomAttribute->specified -- Checks if attribute is specified
DomAttribute->value -- Returns value of attribute
DomDocument->add_root -- Adds a root node [deprecated]
DomDocument->create_attribute -- Create new attribute
DomDocument->create_cdata_section -- Create new cdata node
DomDocument->create_comment -- Create new comment node
DomDocument->create_element_ns -- Create new element node with an associated namespace
DomDocument->create_element -- Create new element node
DomDocument->create_entity_reference --
DomDocument->create_processing_instruction -- Creates new PI node
DomDocument->create_text_node -- Create new text node
DomDocument->doctype -- Returns the document type
DomDocument->document_element -- Returns root element node
DomDocument->dump_file -- Dumps the internal XML tree back into a file
DomDocument->dump_mem -- Dumps the internal XML tree back into a string
DomDocument->get_element_by_id -- Searches for an element with a certain id
DomDocument->get_elements_by_tagname --
DomDocument->html_dump_mem -- Dumps the internal XML tree back into a string as HTML
DomDocument->xinclude -- Substitutes XIncludes in a DomDocument Object.
DomDocumentType->entities -- Returns list of entities
DomDocumentType->internal_subset -- Returns internal subset
DomDocumentType->name -- Returns name of document type
DomDocumentType->notations -- Returns list of notations
DomDocumentType->public_id -- Returns public id of document type
DomDocumentType->system_id -- Returns system id of document type
DomElement->get_attribute_node -- Returns value of attribute
DomElement->get_attribute -- Returns value of attribute
DomElement->get_elements_by_tagname -- Gets elements by tagname
DomElement->has_attribute -- Checks to see if attribute exists
DomElement->remove_attribute -- Removes attribute
DomElement->set_attribute -- Adds new attribute
DomElement->tagname -- Returns name of element
DomNode->add_namespace -- Adds a namespace declaration to a node.
DomNode->append_child -- Adds new child at the end of the children
DomNode->append_sibling -- Adds new sibling to a node
DomNode->attributes -- Returns list of attributes
DomNode->child_nodes -- Returns children of node
DomNode->clone_node -- Clones a node
DomNode->dump_node -- Dumps a single node
DomNode->first_child -- Returns first child of node
DomNode->get_content -- Gets content of node
DomNode->has_attributes -- Checks if node has attributes
DomNode->has_child_nodes -- Checks if node has children
DomNode->insert_before -- Inserts new node as child
DomNode->is_blank_node -- Checks if node is blank
DomNode->last_child -- Returns last child of node
DomNode->next_sibling -- Returns the next sibling of node
DomNode->node_name -- Returns name of node
DomNode->node_type -- Returns type of node
DomNode->node_value -- Returns value of a node
DomNode->owner_document -- Returns the document this node belongs to
DomNode->parent_node -- Returns the parent of the node
DomNode->prefix -- Returns name space prefix of node
DomNode->previous_sibling -- Returns the previous sibling of node
DomNode->remove_child -- Removes child from list of children
DomNode->replace_child -- Replaces a child
DomNode->replace_node -- Replaces node
DomNode->set_content -- Sets content of node
DomNode->set_name -- Sets name of node
DomNode->set_namespace -- Sets namespace of a node.
DomNode->unlink_node -- Deletes node
DomProcessingInstruction->data -- Returns data of pi node
DomProcessingInstruction->target -- Returns target of pi node
DomXsltStylesheet->process -- Applies the XSLT-Transformation on a DomDocument Object.
DomXsltStylesheet->result_dump_file -- Dumps the result from a XSLT-Transformation into a file
DomXsltStylesheet->result_dump_mem -- Dumps the result from a XSLT-Transformation back into a string
domxml_new_doc -- Creates new empty XML document
domxml_open_file -- Creates a DOM object from XML file
domxml_open_mem -- Creates a DOM object of an XML document
domxml_version -- Get XML library version
domxml_xmltree -- Creates a tree of PHP objects from an XML document
domxml_xslt_stylesheet_doc -- Creates a DomXsltStylesheet Object from a DomDocument Object.
domxml_xslt_stylesheet_file -- Creates a DomXsltStylesheet Object from an XSL document in a file.
domxml_xslt_stylesheet -- Creates a DomXsltStylesheet Object from an XML document in a string.
xpath_eval_expression -- Evaluates the XPath Location Path in the given string
xpath_eval -- Evaluates the XPath Location Path in the given string
xpath_new_context -- Creates new xpath context
xptr_eval -- Evaluate the XPtr Location Path in the given string
xptr_new_context -- Create new XPath Context

이전 | 처음으로 | 다음
scandir | 위로 | DomAttribute->name


DomAttribute->name

(no version information, might be only in CVS)

DomAttribute->name -- Returns name of attribute

Description

bool DomAttribute->name ( void )

This function returns the name of the attribute.

See also domattribute_value().

이전 | 처음으로 | 다음
DOM XML Functions | 위로 | DomAttribute->specified


DomAttribute->specified

(no version information, might be only in CVS)

DomAttribute->specified -- Checks if attribute is specified

Description

bool DomAttribute->specified ( void )

Check DOM standard for a detailed explanation.

이전 | 처음으로 | 다음
DomAttribute->name | 위로 | DomAttribute->value


DomAttribute->value

(no version information, might be only in CVS)

DomAttribute->value -- Returns value of attribute

Description

bool DomAttribute->value ( void )

This function returns the value of the attribute.

See also domattribute_name().

이전 | 처음으로 | 다음
DomAttribute->specified | 위로 | DomDocument->add_root


DomDocument->add_root

(no version information, might be only in CVS)

DomDocument->add_root -- Adds a root node [deprecated]

Description

resource DomDocument->add_root ( string name)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Adds a root element node to a dom document and returns the new node. The element name is given in the passed parameter.

예 1. Creating a simple HTML document header

<?php
$doc = domxml_new_doc("1.0");
$root = $doc->add_root("HTML");
$head = $root->new_child("HEAD", "");
$head->new_child("TITLE", "Hier der Titel");
echo htmlentities($doc->dump_mem());
?>

이전 | 처음으로 | 다음
DomAttribute->value | 위로 | DomDocument->create_attribute


DomDocument->create_attribute

(no version information, might be only in CVS)

DomDocument->create_attribute -- Create new attribute

Description

object DomDocument->create_attribute ( string name, string value)

This function returns a new instance of class DomAttribute. The name of the attribute is the value of the first parameter. The value of the attribute is the value of the second parameter. This node will not show up in the document unless it is inserted with e.g. domnode_append_child().

The return value is FALSE if an error occurred.

See also domnode_append_child(),
         domdocument_create_element(),
         domdocument_create_text(),
         domdocument_create_cdata_section(),
         domdocument_create_processing_instruction(),
         domdocument_create_entity_reference(), and
         domnode_insert_before().

이전 | 처음으로 | 다음
DomDocument->add_root | 위로 | DomDocument->create_cdata_section


DomDocument->create_cdata_section

(no version information, might be only in CVS)

DomDocument->create_cdata_section -- Create new cdata node

Description

string DomDocument->create_cdata_section ( string content)

This function returns a new instance of class DomCData. The content of the cdata is the value of the passed parameter. This node will not show up in the document unless it is inserted with e.g. domnode_append_child().

The return value is FALSE if an error occurred.

See also domnode_append_child(),
         domdocument_create_element(),
         domdocument_create_text(),
         domdocument_create_attribute(),
         domdocument_create_processing_instruction(),
         domdocument_create_entity_reference(), and
         domnode_insert_before().

이전 | 처음으로 | 다음
DomDocument->create_attribute | 위로 | DomDocument->create_comment


DomDocument->create_comment

(no version information, might be only in CVS)

DomDocument->create_comment -- Create new comment node

Description

object DomDocument->create_comment ( string content)

This function returns a new instance of class DomComment. The content of the comment is the value of the passed parameter. This node will not show up in the document unless it is inserted with e.g. domnode_append_child().

The return value is FALSE if an error occurred.

See also domnode_append_child(),
         domdocument_create_element(),
         domdocument_create_text(),
         domdocument_create_attribute(),
         domdocument_create_processing_instruction(),
         domdocument_create_entity_reference() and
         domnode_insert_before().

이전 | 처음으로 | 다음
DomDocument->create_cdata_section | 위로 | DomDocument->create_element_ns


DomDocument->create_element_ns

(no version information, might be only in CVS)

DomDocument->create_element_ns -- Create new element node with an associated namespace

Description

object DomDocument->create_element_ns ( string uri, string name [, string prefix])

This function returns a new instance of class DomElement. The tag name of the element is the value of the passed parameter name. The URI of the namespace is the value of the passed parameter uri. If there is already a namespace declaration with the same uri in the root-node of the document, the prefix of this is taken, otherwise it will take the one provided in the optional parameter prefix or generate a random one. This node will not show up in the document unless it is inserted with e.g. domnode_append_child().

The return value is FALSE if an error occurred.

See also domdocument_create_element_ns(),
         domnode_add_namespace(),
         domnode_set_namespace(),
         domnode_append_child(),
         domdocument_create_text(),
         domdocument_create_comment(),
         domdocument_create_attribute(),
         domdocument_create_processing_instruction(),
         domdocument_create_entity_reference(), and
         domnode_insert_before().

이전 | 처음으로 | 다음
DomDocument->create_comment | 위로 | DomDocument->create_element


DomDocument->create_element

(no version information, might be only in CVS)

DomDocument->create_element -- Create new element node

Description

object DomDocument->create_element ( string name)

This function returns a new instance of class DomElement. The tag name of the element is the value of the passed parameter. This node will not show up in the document unless it is inserted with e.g. domnode_append_child().

The return value is FALSE if an error occurred.

See also domdocument_create_element_ns(),
         domnode_append_child(),
         domdocument_create_text(),
         domdocument_create_comment(),
         domdocument_create_attribute(),
         domdocument_create_processing_instruction(),
         domdocument_create_entity_reference(), and
         domnode_insert_before().

이전 | 처음으로 | 다음
DomDocument->create_element_ns | 위로 | DomDocument->create_entity_reference


DomDocument->create_entity_reference

(no version information, might be only in CVS)

DomDocument->create_entity_reference --

Description

object DomDocument->create_entity_reference ( string content)

This function returns a new instance of class DomEntityReference. The content of the entity reference is the value of the passed parameter. This node will not show up in the document unless it is inserted with e.g. domnode_append_child().

The return value is FALSE if an error occurred.

See also domnode_append_child(),
         domdocument_create_element(),
         domdocument_create_text(),
         domdocument_create_cdata_section(),
         domdocument_create_processing_instruction(),
         domdocument_create_attribute(), and
         domnode_insert_before().

이전 | 처음으로 | 다음
DomDocument->create_element | 위로 | DomDocument->create_processing_instruction


DomDocument->create_processing_instruction

(no version information, might be only in CVS)

DomDocument->create_processing_instruction -- Creates new PI node

Description

string DomDocument->create_processing_instruction ( string content)

This function returns a new instance of class DomCData. The content of the pi is the value of the passed parameter. This node will not show up in the document unless it is inserted with e.g. domnode_append_child().

The return value is FALSE if an error occurred.

See also domnode_append_child(),
         domdocument_create_element(),
         domdocument_create_text(),
         domdocument_create_cdata_section(),
         domdocument_create_attribute(),
         domdocument_create_entity_reference(), and
         domnode_insert_before().

이전 | 처음으로 | 다음
DomDocument->create_entity_reference | 위로 | DomDocument->create_text_node


DomDocument->create_text_node

(no version information, might be only in CVS)

DomDocument->create_text_node -- Create new text node

Description

object DomDocument->create_text_node ( string content)

This function returns a new instance of class DomText. The content of the text is the value of the passed parameter. This node will not show up in the document unless it is inserted with e.g. domnode_append_child().

The return value is FALSE if an error occurred.

See also domnode_append_child(),
         domdocument_create_element(),
         domdocument_create_comment(),
         domdocument_create_text(),
         domdocument_create_attribute(),
         domdocument_create_processing_instruction(),
         domdocument_create_entity_reference(), and
         domnode_insert_before().

이전 | 처음으로 | 다음
DomDocument->create_processing_instruction | 위로 | DomDocument->doctype


DomDocument->doctype

(no version information, might be only in CVS)

DomDocument->doctype -- Returns the document type

Description

object DomDocument->doctype ( void )

This function returns an object of class DomDocumentType. In versions of PHP before 4.3 this has been the class Dtd, but the DOM Standard does not know such a class.

See also the methods of class DomDocumentType.

이전 | 처음으로 | 다음
DomDocument->create_text_node | 위로 | DomDocument->document_element


DomDocument->document_element

(no version information, might be only in CVS)

DomDocument->document_element -- Returns root element node

Description

object DomDocument->document_element ( void )

This function returns the root element node of a document.

The following example returns just the element with name CHAPTER and prints it. The other node -- the comment -- is not returned.

예 1. Retrieving root element

<?php
include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$root = $dom->document_element();
print_r($root);
?>

이전 | 처음으로 | 다음
DomDocument->doctype | 위로 | DomDocument->dump_file


DomDocument->dump_file

(no version information, might be only in CVS)

DomDocument->dump_file -- Dumps the internal XML tree back into a file

Description

string DomDocument->dump_file ( string filename [, bool compressionmode [, bool format]])

Creates an XML document from the dom representation. This function usually is called after building a new dom document from scratch as in the example below. The format specifies whether the output should be neatly formatted, or not. The first parameter specifies the name of the filename and the second parameter, whether it should be compressed or not.

예 1. Creating a simple HTML document header

<?php
$doc = domxml_new_doc("1.0");
$root = $doc->create_element("HTML");
$root = $doc->append_child($root);
$head = $doc->create_element("HEAD");
$head = $root->append_child($head);
$title = $doc->create_element("TITLE");
$title = $head->append_child($title);
$text = $doc->create_text_node("This is the title");
$text = $title->append_child($text);
$doc->dump_file("/tmp/test.xml", false, true);
?>

See also domdocument_dump_mem() domdocument_html_dump_mem().

이전 | 처음으로 | 다음
DomDocument->document_element | 위로 | DomDocument->dump_mem


DomDocument->dump_mem

(no version information, might be only in CVS)

DomDocument->dump_mem -- Dumps the internal XML tree back into a string

Description

string DomDocument->dump_mem ( [bool format [, string encoding]])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Creates an XML document from the dom representation. This function usually is called after building a new dom document from scratch as in the example below. The format specifies whether the output should be neatly formatted, or not.

예 1. Creating a simple HTML document header

<?php
$doc = domxml_new_doc("1.0");
$root = $doc->create_element("HTML");
$root = $doc->append_child($root);
$head = $doc->create_element("HEAD");
$head = $root->append_child($head);
$title = $doc->create_element("TITLE");
$title = $head->append_child($title);
$text = $doc->create_text_node("This is the title");
$text = $title->append_child($text);
echo "<PRE>";
echo htmlentities($doc->dump_mem(true));
echo "</PRE>";
?>

참고: The first parameter was added in PHP 4.3.0.

See also domdocument_dump_file(), domdocument_html_dump_mem().

이전 | 처음으로 | 다음
DomDocument->dump_file | 위로 | DomDocument->get_element_by_id


DomDocument->get_element_by_id

(no version information, might be only in CVS)

DomDocument->get_element_by_id -- Searches for an element with a certain id

Description

object DomDocument->get_element_by_id ( string id)

This function is similar to domdocument_get_elements_by_tagname() but searches for an element with a given id. According to the DOM standard this requires a DTD which defines the attribute ID to be of type ID, though the current implementation simply does an xpath search for "//*[@ID = '%s']". This does not comply to the DOM standard which requires to return null if it is not known which attribute is of type id. This behaviour is likely to be fixed, so do not rely on the current behaviour.

See also domdocument_get_elements_by_tagname()

이전 | 처음으로 | 다음
DomDocument->dump_mem | 위로 | DomDocument->get_elements_by_tagname


DomDocument->get_elements_by_tagname

(no version information, might be only in CVS)

DomDocument->get_elements_by_tagname --

Description

array DomDocument->get_elements_by_tagname ( string name)

See also domdocument_add_root()

이전 | 처음으로 | 다음
DomDocument->get_element_by_id | 위로 | DomDocument->html_dump_mem


DomDocument->html_dump_mem

(no version information, might be only in CVS)

DomDocument->html_dump_mem -- Dumps the internal XML tree back into a string as HTML

Description

string DomDocument->html_dump_mem ( void )

Creates an HTML document from the dom representation. This function usually is called after building a new dom document from scratch as in the example below.

예 1. Creating a simple HTML document header

<?php
$doc = domxml_new_doc("1.0");
$root = $doc->create_element("HTML");
$root = $doc->append_child($root);
$head = $doc->create_element("HEAD");
$head = $root->append_child($head);
$title = $doc->create_element("TITLE");
$title = $head->append_child($title);
$text = $doc->create_text_node("This is the title");
$text = $title->append_child($text);
echo "<PRE>";
echo htmlentities($doc->html_dump_mem());
echo "</PRE>";
?>

See also domdocument_dump_file(), domdocument_html_dump_mem().

이전 | 처음으로 | 다음
DomDocument->get_elements_by_tagname | 위로 | DomDocument->xinclude


DomDocument->xinclude

(no version information, might be only in CVS)

DomDocument->xinclude -- Substitutes XIncludes in a DomDocument Object.

Description

int DomDocument->xinclude ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DomDocument->html_dump_mem | 위로 | DomDocumentType->entities


DomDocumentType->entities

(no version information, might be only in CVS)

DomDocumentType->entities -- Returns list of entities

Description

array DomDocumentType->entities ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DomDocument->xinclude | 위로 | DomDocumentType->internal_subset


DomDocumentType->internal_subset

(no version information, might be only in CVS)

DomDocumentType->internal_subset -- Returns internal subset

Description

bool DomDocumentType->internal_subset ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DomDocumentType->entities | 위로 | DomDocumentType->name


DomDocumentType->name

(no version information, might be only in CVS)

DomDocumentType->name -- Returns name of document type

Description

string DomDocumentType->name ( void )

This function returns the name of the document type.

이전 | 처음으로 | 다음
DomDocumentType->internal_subset | 위로 | DomDocumentType->notations


DomDocumentType->notations

(no version information, might be only in CVS)

DomDocumentType->notations -- Returns list of notations

Description

array DomDocumentType->notations ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DomDocumentType->name | 위로 | DomDocumentType->public_id


DomDocumentType->public_id

(no version information, might be only in CVS)

DomDocumentType->public_id -- Returns public id of document type

Description

string DomDocumentType->public_id ( void )

This function returns the public id of the document type.

The following example echos nothing.

예 1. Retrieving the public id

<?php
include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$doctype = $dom->doctype();
echo $doctype->public_id();
?>

이전 | 처음으로 | 다음
DomDocumentType->notations | 위로 | DomDocumentType->system_id


DomDocumentType->system_id

(no version information, might be only in CVS)

DomDocumentType->system_id -- Returns system id of document type

Description

string DomDocumentType->system_id ( void )

Returns the system id of the document type.

The following example echos '/share/sgml/Norman_Walsh/db3xml10/db3xml10.dtd'.

예 1. Retrieving the system id

<?php
include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$doctype = $dom->doctype();
echo $doctype->system_id();
?>

이전 | 처음으로 | 다음
DomDocumentType->public_id | 위로 | DomElement->get_attribute_node


DomElement->get_attribute_node

(no version information, might be only in CVS)

DomElement->get_attribute_node -- Returns value of attribute

Description

object DomElement->get_attribute_node ( object attr)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DomDocumentType->system_id | 위로 | DomElement->get_attribute


DomElement->get_attribute

(no version information, might be only in CVS)

DomElement->get_attribute -- Returns value of attribute

Description

object DomElement->get_attribute ( string name)

Returns the attribute with name name of the current node.

(PHP >= 4.3 only) If no attribute with given name is found, an empty string is returned.

See also domelement_set_attribute()

이전 | 처음으로 | 다음
DomElement->get_attribute_node | 위로 | DomElement->get_elements_by_tagname


DomElement->get_elements_by_tagname

(no version information, might be only in CVS)

DomElement->get_elements_by_tagname -- Gets elements by tagname

Description

bool DomElement->get_elements_by_tagname ( string name)

This function returns an array with all the elements which has name as his tagname. Every element of the array is an DomElement.

예 1. Getting a content

<?php
if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$root = $dom->document_element();

$node_array = $root->get_elements_by_tagname("element");

for ($i = 0; $i<count($node_array); $i++) {
    $node = $node_array[$i];
    echo "The element[$i] is: " . $node->get_content();
}

?>

이전 | 처음으로 | 다음
DomElement->get_attribute | 위로 | DomElement->has_attribute


DomElement->has_attribute

(no version information, might be only in CVS)

DomElement->has_attribute -- Checks to see if attribute exists

Description

bool DomElement->has_attribute ( string name)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DomElement->get_elements_by_tagname | 위로 | DomElement->remove_attribute


DomElement->remove_attribute

(no version information, might be only in CVS)

DomElement->remove_attribute -- Removes attribute

Description

bool DomElement->remove_attribute ( string name)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DomElement->has_attribute | 위로 | DomElement->set_attribute


DomElement->set_attribute

(no version information, might be only in CVS)

DomElement->set_attribute -- Adds new attribute

Description

bool DomElement->set_attribute ( string name, string value)

Sets an attribute with name name to the given value. If the attribute does not exist, it will be created.

예 1. Setting an attribute

<?php
$doc = domxml_new_doc("1.0");
$node = $doc->create_element("para");
$newnode = $doc->append_child($node);
$newnode->set_attribute("align", "left");
?>

See also domelement_get_attribute()

이전 | 처음으로 | 다음
DomElement->remove_attribute | 위로 | DomElement->tagname


DomElement->tagname

(no version information, might be only in CVS)

DomElement->tagname -- Returns name of element

Description

string DomElement->tagname ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DomElement->set_attribute | 위로 | DomNode->add_namespace


DomNode->add_namespace

(no version information, might be only in CVS)

DomNode->add_namespace -- Adds a namespace declaration to a node.

Description

bool DomNode->add_namespace ( string uri, string prefix)

See also domdocument_create_element_ns(), domnode_set_namespace()

이전 | 처음으로 | 다음
DomElement->tagname | 위로 | DomNode->append_child


DomNode->append_child

(no version information, might be only in CVS)

DomNode->append_child -- Adds new child at the end of the children

Description

object DomNode->append_child ( object newnode)

This functions appends a child to an existing list of children or creates a new list of children. The child can be created with e.g. domdocument_create_element(), domdocument_create_text() etc. or simply by using any other node.

(PHP < 4.3) Before a new child is appended it is first duplicated. Therefore the new child is a completely new copy which can be modified without changing the node which was passed to this function. If the node passed has children itself, they will be duplicated as well, which makes it quite easy to duplicate large parts of an XML document. The return value is the appended child. If you plan to do further modifications on the appended child you must use the returned node.

(PHP 4.3.0/4.3.1) The new child newnode is first unlinked from its existing context, if it's already a child of DomNode. Therefore the node is moved and not copies anymore.

(PHP >= 4.3.2) The new child newnode is first unlinked from its existing context, if it's already in the tree. Therefore the node is moved and not copied. This is the behaviour according to the W3C specifications. If you want to duplicate large parts of an XML document, use DomNode->clone_node() before appending.

The following example will add a new element node to a fresh document and sets the attribute "align" to "left".

예 1. Adding a child

<?php
$doc = domxml_new_doc("1.0");
$node = $doc->create_element("para");
$newnode = $doc->append_child($node);
$newnode->set_attribute("align", "left");
?>
The above example could also be written as the following:

예 2. Adding a child

<?php
$doc = domxml_new_doc("1.0");
$node = $doc->create_element("para");
$node->set_attribute("align", "left");
$newnode = $doc->append_child($node);
?>
A more complex example is the one below. It first searches for a certain element, duplicates it including its children and adds it as a sibling. Finally a new attribute is added to one of the children of the new sibling and the whole document is dumped.

예 3. Adding a child

<?php
include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$elements = $dom->get_elements_by_tagname("informaltable");
print_r($elements);
$element = $elements[0];

$parent = $element->parent_node();
$newnode = $parent->append_child($element);
$children = $newnode->children();
$attr = $children[1]->set_attribute("align", "left");

echo "<pre>";
$xmlfile = $dom->dump_mem();
echo htmlentities($xmlfile);
echo "</pre>";
?>
The above example could also be done with domnode_insert_before() instead of domnode_append_child().

See also domnode_insert_before(), domnode_clone_node().

이전 | 처음으로 | 다음
DomNode->add_namespace | 위로 | DomNode->append_sibling


DomNode->append_sibling

(no version information, might be only in CVS)

DomNode->append_sibling -- Adds new sibling to a node

Description

object DomNode->append_sibling ( object newnode)

This functions appends a sibling to an existing node. The child can be created with e.g. domdocument_create_element(), domdocument_create_text() etc. or simply by using any other node.

Before a new sibling is added it is first duplicated. Therefore the new child is a completely new copy which can be modified without changing the node which was passed to this function. If the node passed has children itself, they will be duplicated as well, which makes it quite easy to duplicate large parts of an XML document. The return value is the added sibling. If you plan to do further modifications on the added sibling you must use the returned node.

This function has been added to provide the behaviour of domnode_append_child() as it works till PHP 4.2.

See also domnode_append_before().

이전 | 처음으로 | 다음
DomNode->append_child | 위로 | DomNode->attributes


DomNode->attributes

(no version information, might be only in CVS)

DomNode->attributes -- Returns list of attributes

Description

array DomNode->attributes ( void )

This function only returns an array of attributes if the node is of type XML_ELEMENT_NODE.

(PHP >= 4.3 only) If no attributes are found, NULL is returned.

이전 | 처음으로 | 다음
DomNode->append_sibling | 위로 | DomNode->child_nodes


DomNode->child_nodes

(no version information, might be only in CVS)

DomNode->child_nodes -- Returns children of node

Description

array DomNode->child_nodes ( void )

Returns all children of the node.

See also domnode_next_sibling(), domnode_previous_sibling().

이전 | 처음으로 | 다음
DomNode->attributes | 위로 | DomNode->clone_node


DomNode->clone_node

(no version information, might be only in CVS)

DomNode->clone_node -- Clones a node

Description

object DomNode->clone_node ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DomNode->child_nodes | 위로 | DomNode->dump_node


DomNode->dump_node

(no version information, might be only in CVS)

DomNode->dump_node -- Dumps a single node

Description

string DomNode->dump_node ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also domdocument_dump_mem().

이전 | 처음으로 | 다음
DomNode->clone_node | 위로 | DomNode->first_child


DomNode->first_child

(no version information, might be only in CVS)

DomNode->first_child -- Returns first child of node

Description

object DomNode->first_child ( void )

Returns the first child of the node.

(PHP >= 4.3 only) If no first child is found, NULL is returned.

See also domnode_last_child(),
         domnode_next_sibling(),
         domnode_previous_sibling().

이전 | 처음으로 | 다음
DomNode->dump_node | 위로 | DomNode->get_content


DomNode->get_content

(no version information, might be only in CVS)

DomNode->get_content -- Gets content of node

Description

string DomNode->get_content ( void )

This function returns the content of the actual node.

예 1. Getting a content

<?php
if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$root = $dom->document_element();

$node_array = $root->get_elements_by_tagname("element");

for ($i = 0; $i<count($node_array); $i++) {
    $node = $node_array[$i];
    echo "The element[$i] is: " . $node->get_content();
}

?>

이전 | 처음으로 | 다음
DomNode->first_child | 위로 | DomNode->has_attributes


DomNode->has_attributes

(no version information, might be only in CVS)

DomNode->has_attributes -- Checks if node has attributes

Description

bool DomNode->has_attributes ( void )

This function checks if the node has attributes.

See also domnode_has_child_nodes().

이전 | 처음으로 | 다음
DomNode->get_content | 위로 | DomNode->has_child_nodes


DomNode->has_child_nodes

(no version information, might be only in CVS)

DomNode->has_child_nodes -- Checks if node has children

Description

bool DomNode->has_child_nodes ( void )

This function checks if the node has children.

See also domnode_child_nodes().

이전 | 처음으로 | 다음
DomNode->has_attributes | 위로 | DomNode->insert_before


DomNode->insert_before

(no version information, might be only in CVS)

DomNode->insert_before -- Inserts new node as child

Description

object DomNode->insert_before ( object newnode, object refnode)

This function inserts the new node newnode right before the node refnode. The return value is the inserted node. If you plan to do further modifications on the appended child you must use the returned node.

(PHP >= 4.3 only) If newnode already is part of a document, it will be first unlinked from its existing context. If refnode is NULL, then newnode will be inserted at the end of the list of children.

domnode_insert_before() is very similar to domnode_append_child() as the following example shows which does the same as the example at domnode_append_child().

예 1. Adding a child

<?php
include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$elements = $dom->get_elements_by_tagname("informaltable");
print_r($elements);
$element = $elements[0];

$newnode = $element->insert_before($element, $element);
$children = $newnode->children();
$attr = $children[1]->set_attribute("align", "left");

echo "<PRE>";
$xmlfile = $dom->dump_mem();
echo htmlentities($xmlfile);
echo "</PRE>";
?>

See also domnode_append_child().

이전 | 처음으로 | 다음
DomNode->has_child_nodes | 위로 | DomNode->is_blank_node


DomNode->is_blank_node

(no version information, might be only in CVS)

DomNode->is_blank_node -- Checks if node is blank

Description

bool DomNode->is_blank_node ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DomNode->insert_before | 위로 | DomNode->last_child


DomNode->last_child

(no version information, might be only in CVS)

DomNode->last_child -- Returns last child of node

Description

object DomNode->last_child ( void )

Returns the last child of the node.

(PHP >= 4.3 only) If no last child is found, NULL is returned.

See also domnode_first_child(),
         domnode_next_sibling(),
         domnode_previous_sibling().

이전 | 처음으로 | 다음
DomNode->is_blank_node | 위로 | DomNode->next_sibling


DomNode->next_sibling

(no version information, might be only in CVS)

DomNode->next_sibling -- Returns the next sibling of node

Description

object DomNode->next_sibling ( void )

This function returns the next sibling of the current node. If there is no next sibling it returns FALSE (< 4.3) or null (>= 4.3). You can use this function to iterate over all children of a node as shown in the example.

예 1. Iterate over children

<?php
include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$elements = $dom->get_elements_by_tagname("tbody");
$element = $elements[0];
$child = $element->first_child();

while ($child) {
   print_r($child);
   $child = $child->next_sibling();
}
?>

See also domnode_previous_sibling().

이전 | 처음으로 | 다음
DomNode->last_child | 위로 | DomNode->node_name


DomNode->node_name

(no version information, might be only in CVS)

DomNode->node_name -- Returns name of node

Description

string DomNode->node_name ( void )

Returns name of the node. The name has different meanings for the different types of nodes as illustrated in the following table.

표 1. Meaning of value

Type | Meaning
DomAttribute | value of attribute
DomAttribute |
DomCDataSection | #cdata-section
DomComment | #comment
DomDocument | #document
DomDocumentType | document type name
DomElement | tag name
DomEntity | name of entity
DomEntityReference | name of entity reference
DomNotation | notation name
DomProcessingInstruction | target
DomText | #text

이전 | 처음으로 | 다음
DomNode->next_sibling | 위로 | DomNode->node_type


DomNode->node_type

(no version information, might be only in CVS)

DomNode->node_type -- Returns type of node

Description

int DomNode->node_type ( void )

Returns the type of the node. All possible types are listed in the table in the introduction.

이전 | 처음으로 | 다음
DomNode->node_name | 위로 | DomNode->node_value


DomNode->node_value

(no version information, might be only in CVS)

DomNode->node_value -- Returns value of a node

Description

string DomNode->node_value ( void )

Returns value of the node. The value has different meanings for the different types of nodes as illustrated in the following table.

표 1. Meaning of value

Type | Meaning
DomAttribute | value of attribute
DomAttribute |
DomCDataSection | content
DomComment | content of comment
DomDocument | null
DomDocumentType | null
DomElement | null
DomEntity | null
DomEntityReference | null
DomNotation | null
DomProcessingInstruction | entire content without target
DomText | content of text

이전 | 처음으로 | 다음
DomNode->node_type | 위로 | DomNode->owner_document


DomNode->owner_document

(no version information, might be only in CVS)

DomNode->owner_document -- Returns the document this node belongs to

Description

object DomNode->owner_document ( void )

This function returns the document the current node belongs to.

The following example will create two identical lists of children.

예 1. Finding the document of a node

<?php
$doc = domxml_new_doc("1.0");
$node = $doc->create_element("para");
$node = $doc->append_child($node);
$children = $doc->children();
print_r($children);

$doc2 = $node->owner_document();
$children = $doc2->children();
print_r($children);
?>

See also domnode_insert_before().

이전 | 처음으로 | 다음
DomNode->node_value | 위로 | DomNode->parent_node


DomNode->parent_node

(no version information, might be only in CVS)

DomNode->parent_node -- Returns the parent of the node

Description

object DomNode->parent_node ( void )

This function returns the parent node.

(PHP >= 4.3 only) If no parent is found, NULL is returned.

The following example will show two identical lists of children.

예 1. Finding the document of a node

<?php
$doc = domxml_new_doc("1.0");
$node = $doc->create_element("para");
$node = $doc->append_child($node);
$children = $doc->children();
print_r($children);

$doc2 = $node->parent_node();
$children = $doc2->children();
print_r($children);
?>

이전 | 처음으로 | 다음
DomNode->owner_document | 위로 | DomNode->prefix


DomNode->prefix

(no version information, might be only in CVS)

DomNode->prefix -- Returns name space prefix of node

Description

string DomNode->prefix ( void )

Returns the name space prefix of the node.

이전 | 처음으로 | 다음
DomNode->parent_node | 위로 | DomNode->previous_sibling


DomNode->previous_sibling

(no version information, might be only in CVS)

DomNode->previous_sibling -- Returns the previous sibling of node

Description

object DomNode->previous_sibling ( void )

This function returns the previous sibling of the current node. If there is no previous sibling it returns FALSE (< 4.3) or NULL (>= 4.3). You can use this function to iterate over all children of a node as shown in the example.

See also domnode_next_sibling().

이전 | 처음으로 | 다음
DomNode->prefix | 위로 | DomNode->remove_child


DomNode->remove_child

(no version information, might be only in CVS)

DomNode->remove_child -- Removes child from list of children

Description

object DomNode->remove_child ( object oldchild)

This functions removes a child from a list of children. If child cannot be removed or is not a child the function will return FALSE. If the child could be removed the functions returns the old child.

예 1. Removing a child

<?php
include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$elements = $dom->get_elements_by_tagname("tbody");
$element = $elements[0];
$children = $element->child_nodes();
$child = $element->remove_child($children[0]);

echo "<PRE>";
$xmlfile = $dom->dump_mem(true);
echo htmlentities($xmlfile);
echo "</PRE>";
?>

See also domnode_append_child().

이전 | 처음으로 | 다음
DomNode->previous_sibling | 위로 | DomNode->replace_child


DomNode->replace_child

(no version information, might be only in CVS)

DomNode->replace_child -- Replaces a child

Description

object DomNode->replace_child ( object oldnode, object newnode)

(PHP 4.2) This function replaces the child oldnode with the passed new node. If the new node is already a child it will not be added a second time. If the old node cannot be found the function returns FALSE. If the replacement succeeds the old node is returned.

(PHP 4.3) This function replaces the child oldnode with the passed newnode, even if the new node already is a child of the DomNode. If newnode was already inserted in the document it is first unlinked from its existing context. If the old node cannot be found the function returns FALSE. If the replacement succeeds the old node is returned. (This behaviour is according to the W3C specs).

See also domnode_append_child()

이전 | 처음으로 | 다음
DomNode->remove_child | 위로 | DomNode->replace_node


DomNode->replace_node

(no version information, might be only in CVS)

DomNode->replace_node -- Replaces node

Description

object DomNode->replace_node ( object newnode)

(PHP 4.2) This function replaces an existing node with the passed new node. Before the replacement newnode is copied if it has a parent to make sure a node which is already in the document will not be inserted a second time. This behaviour enforces doing all modifications on the node before the replacement or to refetch the inserted node afterwards with functions like domnode_first_child(), domnode_child_nodes() etc..

(PHP 4.3) This function replaces an existing node with the passed new node. It is not copied anymore. If newnode was already inserted in the document it is first unlinked from its existing context. If the replacement succeeds the old node is returned.

See also domnode_append_child()

이전 | 처음으로 | 다음
DomNode->replace_child | 위로 | DomNode->set_content


DomNode->set_content

(no version information, might be only in CVS)

DomNode->set_content -- Sets content of node

Description

bool DomNode->set_content ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DomNode->replace_node | 위로 | DomNode->set_name


DomNode->set_name

(no version information, might be only in CVS)

DomNode->set_name -- Sets name of node

Description

bool DomNode->set_name ( void )

Sets name of node.

See also domnode_node_name().

이전 | 처음으로 | 다음
DomNode->set_content | 위로 | DomNode->set_namespace


DomNode->set_namespace

(no version information, might be only in CVS)

DomNode->set_namespace -- Sets namespace of a node.

Description

void DomNode->set_namespace ( string uri [, string prefix])

Sets the namespace of a node to uri. If there is already a namespace declaration with the same uri in one of the parent nodes of the node, the prefix of this is taken, otherwise it will take the one provided in the optional parameter prefix or generate a random one.

See also domdocument_create_element_ns(), domnode_add_namespace()

이전 | 처음으로 | 다음
DomNode->set_name | 위로 | DomNode->unlink_node


DomNode->unlink_node

(no version information, might be only in CVS)

DomNode->unlink_node -- Deletes node

Description

object DomNode->unlink_node ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DomNode->set_namespace | 위로 | DomProcessingInstruction->data


DomProcessingInstruction->data

(no version information, might be only in CVS)

DomProcessingInstruction->data -- Returns data of pi node

Description

string DomProcessingInstruction->data ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DomNode->unlink_node | 위로 | DomProcessingInstruction->target


DomProcessingInstruction->target

(no version information, might be only in CVS)

DomProcessingInstruction->target -- Returns target of pi node

Description

string DomProcessingInstruction->target ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DomProcessingInstruction->data | 위로 | DomXsltStylesheet->process


DomXsltStylesheet->process

(no version information, might be only in CVS)

DomXsltStylesheet->process -- Applies the XSLT-Transformation on a DomDocument Object.

Description

object DomXsltStylesheet->process ( object DomDocument [, array xslt_parameters [, bool param_is_xpath]])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also domxml_xslt_stylesheet(), domxml_xslt_stylesheet_file(), domxml_xslt_stylesheet_doc()

이전 | 처음으로 | 다음
DomProcessingInstruction->target | 위로 | DomXsltStylesheet->result_dump_file


DomXsltStylesheet->result_dump_file

(no version information, might be only in CVS)

DomXsltStylesheet->result_dump_file -- Dumps the result from a XSLT-Transformation into a file

Description

string DomXsltStylesheet->result_dump_file ( object DomDocument, string filename)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

This function is only available since PHP 4.3

Since DomXsltStylesheet->process() always returns a well-formed XML DomDocument, no matter what output method was declared in <xsl:output> and similar attributes/elements, it's of not much use, if you want to output HTML 4 or text data. This function on the contrary honors <xsl:output method="html|text"> and other output control directives. See the example for instruction of how to use it.

예 1. Saving the result of a XSLT transformation in a file

<?php
$filename = "stylesheet.xsl";
$xmldoc = domxml_open_file("data.xml");
$xsldoc = domxml_xslt_stylesheet_file($filename);
$result =  $xsldoc->process($xmldoc);
echo $xsldoc->result_dump_file($result, "filename");
?>

See also domxml_xslt_result_dump_mem(), domxml_xslt_process()

이전 | 처음으로 | 다음
DomXsltStylesheet->process | 위로 | DomXsltStylesheet->result_dump_mem


DomXsltStylesheet->result_dump_mem

(no version information, might be only in CVS)

DomXsltStylesheet->result_dump_mem -- Dumps the result from a XSLT-Transformation back into a string

Description

string DomXsltStylesheet->result_dump_mem ( object DomDocument)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

This function is only available since PHP 4.3

Since DomXsltStylesheet->process() always returns a well-formed XML DomDocument, no matter what output method was declared in <xsl:output> and similar attributes/elements, it's of not much use, if you want to output HTML 4 or text data. This function on the contrary honors <xsl:output method="html|text"> and other output control directives. See the example for instruction of how to use it.

예 1. Outputting the result of a XSLT transformation

<?php
$filename = "stylesheet.xsl";
$xmldoc = domxml_open_file("data.xml");
$xsldoc = domxml_xslt_stylesheet_file($filename);
$result =  $xsldoc->process($xmldoc);
echo $xsldoc->result_dump_mem($result);
?>

See also domxml_xslt_result_dump_file(), domxml_xslt_process()

이전 | 처음으로 | 다음
DomXsltStylesheet->result_dump_file | 위로 | domxml_new_doc


domxml_new_doc

(PHP 4 >= 4.2.1)

domxml_new_doc -- Creates new empty XML document

Description

object domxml_new_doc ( string version)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Creates a new dom document from scratch and returns it.

See also domdocument_add_root()

이전 | 처음으로 | 다음
DomXsltStylesheet->result_dump_mem | 위로 | domxml_open_file


domxml_open_file

(PHP 4 >= 4.2.1)

domxml_open_file -- Creates a DOM object from XML file

Description

object domxml_open_file ( string filename)

The function parses the XML document in the file named filename and returns an object of class "Dom document", having the properties as listed above. The file is accessed read-only.

예 1. Opening an XML document from a file

<?php

if (!$dom = domxml_open_file("example.xml")) {
  echo "Error while parsing the document\n";
  exit;
}

$root = $dom->document_element();
?>

See also domxml_open_mem(), domxml_new_doc().

이전 | 처음으로 | 다음
domxml_new_doc | 위로 | domxml_open_mem


domxml_open_mem

(PHP 4 >= 4.2.1)

domxml_open_mem -- Creates a DOM object of an XML document

Description

object domxml_open_mem ( string str)

The function parses the XML document in str and returns an object of class "Dom document", having the properties as listed above. This function, domxml_open_file() or domxml_new_doc() must be called before any other function calls.

예 1. Opening an XML document in a string

<?php
include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$root = $dom->document_element();
?>

See also domxml_open_file(), domxml_new_doc().

이전 | 처음으로 | 다음
domxml_open_file | 위로 | domxml_version


domxml_version

(PHP 4 >= 4.1.0)

domxml_version -- Get XML library version

Description

string domxml_version ( void )

This function returns the version of the XML library version currently used.

이전 | 처음으로 | 다음
domxml_open_mem | 위로 | domxml_xmltree


domxml_xmltree

(PHP 4 >= 4.2.1)

domxml_xmltree -- Creates a tree of PHP objects from an XML document

Description

object domxml_xmltree ( string str)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

The function parses the XML document in str and returns a tree PHP objects as the parsed document. This function is isolated from the other functions, which means you cannot access the tree with any of the other functions. Modifying it, for example by adding nodes, makes no sense since there is currently no way to dump it as an XML file. However this function may be valuable if you want to read a file and investigate the content.

이전 | 처음으로 | 다음
domxml_version | 위로 | domxml_xslt_stylesheet_doc


domxml_xslt_stylesheet_doc

(PHP 4 >= 4.2.0)

domxml_xslt_stylesheet_doc -- Creates a DomXsltStylesheet Object from a DomDocument Object.

Description

object domxml_xslt_stylesheet_doc ( object DocDocument Object)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also domxsltstylesheet->process(), domxml_xslt_stylesheet(), domxml_xslt_stylesheet_file()

이전 | 처음으로 | 다음
domxml_xmltree | 위로 | domxml_xslt_stylesheet_file


domxml_xslt_stylesheet_file

(PHP 4 >= 4.2.0)

domxml_xslt_stylesheet_file -- Creates a DomXsltStylesheet Object from an XSL document in a file.

Description

object domxml_xslt_stylesheet_file ( string xsl file)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also domxsltstylesheet->process(), domxml_xslt_stylesheet(), domxml_xslt_stylesheet_doc()

이전 | 처음으로 | 다음
domxml_xslt_stylesheet_doc | 위로 | domxml_xslt_stylesheet


domxml_xslt_stylesheet

(PHP 4 >= 4.2.0)

domxml_xslt_stylesheet -- Creates a DomXsltStylesheet Object from an XML document in a string.

Description

object domxml_xslt_stylesheet ( string xsl document)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also domxsltstylesheet->process(), domxml_xslt_stylesheet_file(), domxml_xslt_stylesheet_doc()

이전 | 처음으로 | 다음
domxml_xslt_stylesheet_file | 위로 | xpath_eval_expression


xpath_eval_expression

(PHP 4 >= 4.0.4)

xpath_eval_expression -- Evaluates the XPath Location Path in the given string

Description

array xpath_eval_expression ( object xpath_context)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

See also xpath_eval()

이전 | 처음으로 | 다음
domxml_xslt_stylesheet | 위로 | xpath_eval


xpath_eval

(PHP 4 >= 4.0.4)

xpath_eval -- Evaluates the XPath Location Path in the given string

Description

array xpath_eval ( object xpath context, string xpath expression [, object contextnode])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

The optional contextnode can be specified for doing relative XPath queries.

See also xpath_new_context()

이전 | 처음으로 | 다음
xpath_eval_expression | 위로 | xpath_new_context


xpath_new_context

(PHP 4 >= 4.0.4)

xpath_new_context -- Creates new xpath context

Description

object xpath_new_context ( object dom document)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

See also xpath_eval()

이전 | 처음으로 | 다음
xpath_eval | 위로 | xptr_eval


xptr_eval

(PHP 4 >= 4.0.4)

xptr_eval -- Evaluate the XPtr Location Path in the given string

Description

int xptr_eval ( [object xpath_context, string eval_str])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xpath_new_context | 위로 | xptr_new_context


xptr_new_context

(PHP 4 >= 4.0.4)

xptr_new_context -- Create new XPath Context

Description

string xptr_new_context ( [object doc_handle])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xptr_eval | 위로 | .NET Functions


.NET Functions

PHP 매뉴얼
이전 다음

XXV. .NET Functions

소개

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

차례
dotnet_load -- Loads a DOTNET module

이전 | 처음으로 | 다음
xptr_new_context | 위로 | dotnet_load


dotnet_load

(no version information, might be only in CVS)

dotnet_load -- Loads a DOTNET module

Description

int dotnet_load ( string assembly_name [, string datatype_name [, int codepage]])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
.NET Functions | 위로 | Error Handling and Logging Functions


Error Handling and Logging Functions

PHP 매뉴얼
이전 다음

XXVI. Error Handling and Logging Functions

소개

These are functions dealing with error handling and logging. They allow you to define your own error handling rules, as well as modify the way the errors can be logged. This allows you to change and enhance error reporting to suit your needs.

With the logging functions, you can send messages directly to other machines, to an email (or email to pager gateway!), to system logs, etc., so you can selectively log and monitor the most important parts of your applications and websites.

The error reporting functions allow you to customize what level and kind of error feedback is given, ranging from simple notices to customized functions returned during errors.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. Errors and Logging Configuration Options

Name | Default | Changeable
error_reporting | E_ALL & ~E_NOTICE | PHP_INI_ALL
display_errors | "1" | PHP_INI_ALL
display_startup_errors | "0" | PHP_INI_ALL
log_errors | "0" | PHP_INI_ALL
log_errors_max_len | "1024" | PHP_INI_ALL
ignore_repeated_errors | "0" | PHP_INI_ALL
ignore_repeated_source | "0" | PHP_INI_ALL
report_memleaks | "1" | PHP_INI_ALL
track_errors | "0" | PHP_INI_ALL
html_errors | "1" | PHP_INI_ALL
docref_root | "" | PHP_INI_ALL
docref_ext | "" | PHP_INI_ALL
error_prepend_string | NULL | PHP_INI_ALL
error_append_string | NULL | PHP_INI_ALL
error_log | NULL | PHP_INI_ALL
warn_plus_overloading | NULL | PHP_INI??
For further details and definition of the PHP_INI_* constants see ini_set().

위 설정 지시어에 대한 간단한 설명입니다.

error_reporting integer

Set the error reporting level. The parameter is either an integer representing a bit field, or named constants. The error_reporting levels and constants are described in Predefined Constants, and in php.ini. To set at runtime, use the error_reporting() function. See also the display_errors directive.

In PHP 4 and PHP 5 the default value is E_ALL & ~E_NOTICE. This setting does not show E_NOTICE level errors. You may want to show them during development.

참고: Enabling E_NOTICE during development has some benefits. For debugging purposes: NOTICE messages will warn you about possible bugs in your code. For example, use of unassigned values is warned. It is extremely useful to find typos and to save time for debugging. NOTICE messages will warn you about bad style. For example, $arr[item] is better to be written as $arr['item'] since PHP tries to treat "item" as constant. If it is not a constant, PHP assumes it is a string index for the array.

참고: In PHP 5 a new error level E_STRICT is available. As E_STRICT is not included within E_ALL you have to explicitly enable this kind of error level. Enabling E_STRICT during development has some benefits. STRICT messages will help you to use the latest and greatest suggested method of coding, for example warn you about using deprecated functions.

In PHP 3, the default setting is (E_ERROR | E_WARNING | E_PARSE), meaning the same thing. Note, however, that since constants are not supported in PHP 3's php3.ini, the error_reporting setting there must be numeric; hence, it is 7.

display_errors boolean

This determines whether errors should be printed to the screen as part of the output or if they should be hidden from the user.

참고: This is a feature to support your development and should never be used on production systems (e.g. systems connected to the internet).

display_startup_errors boolean

Even when display_errors is on, errors that occur during PHP's startup sequence are not displayed. It's strongly recommended to keep display_startup_errors off, except for debugging.

log_errors boolean

Tells whether script error messages should be logged to the server's error log or error_log. This option is thus server-specific.

참고: You're strongly advised to use error logging in place of error displaying on production web sites.

log_errors_max_len integer

Set the maximum length of log_errors in bytes. In error_log information about the source is added. The default is 1024 and 0 allows to not apply any maximum length at all.

ignore_repeated_errors boolean

Do not log repeated messages. Repeated errors must occur in the same file on the same line until ignore_repeated_source is set true.

ignore_repeated_source boolean

Ignore source of message when ignoring repeated messages. When this setting is On you will not log errors with repeated messages from different files or sourcelines.

report_memleaks boolean

If this parameter is set to Off, then memory leaks will not be shown (on stdout or in the log). This has only effect in a debug compile, and if error_reporting includes E_WARNING in the allowed list

track_errors boolean

If enabled, the last error message will always be present in the variable $php_errormsg.

html_errors boolean

Turn off HTML tags in error messages. The new format for HTML errors produces clickable messages that direct the user to a page describing the error or function in causing the error. These references are affected by docref_root and docref_ext.

docref_root string

The new error format contains a reference to a page describing the error or function causing the error. In case of manual pages you can download the manual in your language and set this ini directive to the URL of your local copy. If your local copy of the manual can be reached by '/manual/' you can simply use docref_root=/manual/. Additional you have to set docref_ext to match the fileextensions of your copy docref_ext=.html. It is possible to use external references. For example you can use docref_root=http://manual/en/ or docref_root="http://landonize.it/?how=url&theme=classic&filter=Landon &url=http%3A%2F%2Fwww.php.net%2F"

Most of the time you want the docref_root value to end with a slash '/'. But see the second example above which does not have nor need it.

참고: This is a feature to support your development since it makes it easy to lookup a function description. However it should never be used on production systems (e.g. systems connected to the internet).

docref_ext string

See docref_root.

참고: The value of docref_ext must begin with a dot '.'.

error_prepend_string string

String to output before an error message.

error_append_string string

String to output after an error message.

error_log string

Name of the file where script errors should be logged. If the special value syslog is used, the errors are sent to the system logger instead. On Unix, this means syslog(3) and on Windows NT it means the event log. The system logger is not supported on Windows 95. See also: syslog().

warn_plus_overloading boolean

If enabled, this option makes PHP output a warning when the plus (+) operator is used on strings. This is to make it easier to find scripts that need to be rewritten to using the string concatenator instead (.).

상수 정의

아래 상수들은 PHP 코어의 일부로, 항상 사용할 수 있습니다.

참고: You may use these constant names in php.ini but not outside of PHP, like in httpd.conf, where you'd use the bitmask values instead.

표 2. Errors and Logging

Value | Constant | Description | Note
1 | E_ERROR (integer) | Fatal run-time errors. These indicate errors that can not be recovered from, such as a memory allocation problem. Execution of the script is halted. |
2 | E_WARNING (integer) | Run-time warnings (non-fatal errors). Execution of the script is not halted. |
4 | E_PARSE (integer) | Compile-time parse errors. Parse errors should only be generated by the parser. |
8 | E_NOTICE (integer) | Run-time notices. Indicate that the script encountered something that could indicate an error, but could also happen in the normal course of running a script. |
16 | E_CORE_ERROR (integer) | Fatal errors that occur during PHP's initial startup. This is like an E_ERROR, except it is generated by the core of PHP. | since PHP 4
32 | E_CORE_WARNING (integer) | Warnings (non-fatal errors) that occur during PHP's initial startup. This is like an E_WARNING, except it is generated by the core of PHP. | since PHP 4
64 | E_COMPILE_ERROR (integer) | Fatal compile-time errors. This is like an E_ERROR, except it is generated by the Zend Scripting Engine. | since PHP 4
128 | E_COMPILE_WARNING (integer) | Compile-time warnings (non-fatal errors). This is like an E_WARNING, except it is generated by the Zend Scripting Engine. | since PHP 4
256 | E_USER_ERROR (integer) | User-generated error message. This is like an E_ERROR, except it is generated in PHP code by using the PHP function trigger_error(). | since PHP 4
512 | E_USER_WARNING (integer) | User-generated warning message. This is like an E_WARNING, except it is generated in PHP code by using the PHP function trigger_error(). | since PHP 4
1024 | E_USER_NOTICE (integer) | User-generated notice message. This is like an E_NOTICE, except it is generated in PHP code by using the PHP function trigger_error(). | since PHP 4
2047 | E_ALL (integer) | All errors and warnings, as supported, except of level E_STRICT. |
2048 | E_STRICT (integer) | Run-time notices. Enable to have PHP suggest changes to your code which will ensure the best interoperability and forward compatibility of your code. | since PHP 5

The above values (either numerical or symbolic) are used to build up a bitmask that specifies which errors to report. You can use the bitwise operators to combine these values or mask out certain types of errors. Note that only '|', '~', '!', '^' and '&' will be understood within php.ini, however, and that no bitwise operators will be understood within php3.ini.

예제

Below we can see an example of using the error handling capabilities in PHP. We define an error handling function which logs the information into a file (using an XML format), and e-mails the developer in case a critical error in the logic happens.

예 1. Using error handling in a script

<?php
// we will do our own error handling
error_reporting(0);

// user defined error handling function
function userErrorHandler($errno, $errmsg, $filename, $linenum, $vars)
{
    // timestamp for the error entry
    $dt = date("Y-m-d H:i:s (T)");

    // define an assoc array of error string
    // in reality the only entries we should
    // consider are E_WARNING, E_NOTICE, E_USER_ERROR,
    // E_USER_WARNING and E_USER_NOTICE
    $errortype = array (
                E_ERROR           => "Error",
                E_WARNING         => "Warning",
                E_PARSE           => "Parsing Error",
                E_NOTICE          => "Notice",
                E_CORE_ERROR      => "Core Error",
                E_CORE_WARNING    => "Core Warning",
                E_COMPILE_ERROR   => "Compile Error",
                E_COMPILE_WARNING => "Compile Warning",
                E_USER_ERROR      => "User Error",
                E_USER_WARNING    => "User Warning",
                E_USER_NOTICE     => "User Notice",
                E_STRICT          => "Runtime Notice"
                );
    // set of errors for which a var trace will be saved
    $user_errors = array(E_USER_ERROR, E_USER_WARNING, E_USER_NOTICE);

    $err = "<errorentry>\n";
    $err .= "\t<datetime>" . $dt . "</datetime>\n";
    $err .= "\t<errornum>" . $errno . "</errornum>\n";
    $err .= "\t<errortype>" . $errortype[$errno] . "</errortype>\n";
    $err .= "\t<errormsg>" . $errmsg . "</errormsg>\n";
    $err .= "\t<scriptname>" . $filename . "</scriptname>\n";
    $err .= "\t<scriptlinenum>" . $linenum . "</scriptlinenum>\n";

    if (in_array($errno, $user_errors))
        $err .= "\t<vartrace>" . wddx_serialize_value($vars, "Variables") . "</vartrace>\n";
    $err .= "</errorentry>\n\n";

    // for testing
    // echo $err;

    // save to the error log, and e-mail me if there is a critical user error
    error_log($err, 3, "/usr/local/php4/error.log");
    if ($errno == E_USER_ERROR) {
        mail("phpdev@example.com", "Critical User Error", $err);
    }
}

function distance($vect1, $vect2)
{
    if (!is_array($vect1) || !is_array($vect2)) {
        trigger_error("Incorrect parameters, arrays expected", E_USER_ERROR);
        return NULL;
    }

    if (count($vect1) != count($vect2)) {
        trigger_error("Vectors need to be of the same size", E_USER_ERROR);
        return NULL;
    }

    for ($i=0; $i<count($vect1); $i++) {
        $c1 = $vect1[$i]; $c2 = $vect2[$i];
        $d = 0.0;
        if (!is_numeric($c1)) {
            trigger_error("Coordinate $i in vector 1 is not a number, using zero",
                            E_USER_WARNING);
            $c1 = 0.0;
        }
        if (!is_numeric($c2)) {
            trigger_error("Coordinate $i in vector 2 is not a number, using zero",
                            E_USER_WARNING);
            $c2 = 0.0;
        }
        $d += $c2*$c2 - $c1*$c1;
    }
    return sqrt($d);
}

$old_error_handler = set_error_handler("userErrorHandler");

// undefined constant, generates a warning
$t = I_AM_NOT_DEFINED;

// define some "vectors"
$a = array(2, 3, "foo");
$b = array(5.5, 4.3, -1.6);
$c = array(1, -3);

// generate a user error
$t1 = distance($c, $b) . "\n";

// generate another user error
$t2 = distance($b, "i am not an array") . "\n";

// generate a warning
$t3 = distance($a, $b) . "\n";

?>

참고

See also syslog().

차례
debug_backtrace -- Generates a backtrace
debug_print_backtrace -- Prints a backtrace
error_log -- Send an error message somewhere
error_reporting -- Sets which PHP errors are reported
restore_error_handler -- Restores the previous error handler function
set_error_handler -- Sets a user-defined error handler function.
trigger_error -- Generates a user-level error/warning/notice message
user_error -- Alias of trigger_error()

이전 | 처음으로 | 다음
dotnet_load | 위로 | debug_backtrace


debug_backtrace

(PHP 4 >= 4.3.0, PHP 5)

debug_backtrace -- Generates a backtrace

Description

array debug_backtrace ( void )

debug_backtrace() generates a PHP backtrace and returns this information as an associative array. The possible returned elements are listed in the following table:

표 1. Possible returned elements from debug_backtrace()

Name | Type | Description
function | string | The current function name. See also __FUNCTION__.
line | integer | The current line number. See also __LINE__.
file | string | The current file name. See also __FILE__.
class | string | The current class name. See also __CLASS__
type | string | The current call type. If a method call, "->" is returned. If a static method call, "::" is returned. If a function call, nothing is returned.
args | array | If inside a function, this lists the functions arguments. If inside an included file, this lists the included file name(s).

The following is a simple example.

예 1. debug_backtrace() example

<?php
// filename: a.php

function a_test($str)
{
    echo "\nHi: $str";
    var_dump(debug_backtrace());
}

a_test('friend');
?>

<?php
// filename: b.php
include_once '/tmp/a.php';
?>

Results when executing /tmp/b.php:

Hi: friend
array(2) {
  [0]=>
  array(4) {
    ["file"] => string(10) "/tmp/a.php"
    ["line"] => int(10)
    ["function"] => string(6) "a_test"
    ["args"]=>
    array(1) {
      [0] => &string(6) "friend"
    }
  }
  [1]=>
  array(4) {
    ["file"] => string(10) "/tmp/b.php"
    ["line"] => int(2)
    ["args"] =>
    array(1) {
      [0] => string(10) "/tmp/a.php"
    }
    ["function"] => string(12) "include_once"
  }
}

See also trigger_error() and debug_print_backtrace().

이전 | 처음으로 | 다음
Error Handling and Logging Functions | 위로 | debug_print_backtrace


debug_print_backtrace

(PHP 5)

debug_print_backtrace -- Prints a backtrace

Description

void debug_print_backtrace ( void )

debug_print_backtrace() prints a PHP backtrace.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also debug_backtrace().

이전 | 처음으로 | 다음
debug_backtrace | 위로 | error_log


error_log

(PHP 3, PHP 4 , PHP 5)

error_log -- Send an error message somewhere

Description

int error_log ( string message [, int message_type [, string destination [, string extra_headers]]])

Sends an error message to the web server's error log, a TCP port or to a file. The first parameter, message, is the error message that should be logged. The second parameter, message_type says where the message should go:

표 1. error_log() log types

0 | message is sent to PHP's system logger, using the Operating System's system logging mechanism or a file, depending on what the error_log configuration directive is set to. This is the default option.
1 | message is sent by email to the address in the destination parameter. This is the only message type where the fourth parameter, extra_headers is used. This message type uses the same internal function as mail() does.
2 | message is sent through the PHP debugging connection. This option is only available if remote debugging has been enabled. In this case, the destination parameter specifies the host name or IP address and optionally, port number, of the socket receiving the debug information.
3 | message is appended to the file destination.

참고: When explicitly specifying the message_type as 3, a newline is not automatically added to the end of the message string.

주의

Remote debugging via TCP/IP is a PHP 3 feature that is not available in PHP 4.

예 1. error_log() examples

<?php
// Send notification through the server log if we can not
// connect to the database.
if (!Ora_Logon($username, $password)) {
    error_log("Oracle database not available!", 0);
}

// Notify administrator by email if we run out of FOO
if (!($foo = allocate_new_foo())) {
    error_log("Big trouble, we're all out of FOOs!", 1,
               "operator@example.com");
}

// other ways of calling error_log():
error_log("You messed up!", 2, "127.0.0.1:7000");
error_log("You messed up!", 2, "loghost");
error_log("You messed up!", 3, "/var/tmp/my-errors.log");
?>

이전 | 처음으로 | 다음
debug_print_backtrace | 위로 | error_reporting


error_reporting

(PHP 3, PHP 4 , PHP 5)

error_reporting -- Sets which PHP errors are reported

Description

int error_reporting ( [int level])

The error_reporting() function sets the error_reporting directive at runtime. PHP has many levels of errors, using this function sets that level for the duration (runtime) of your script.

error_reporting() sets PHP's error reporting level, and returns the old level. The level parameter takes on either a bitmask, or named constants. Using named constants is strongly encouraged to ensure compatibility for future versions. As error levels are added, the range of integers increases, so older integer-based error levels will not always behave as expected.

예 1. error_reporting() examples

<?php

// Turn off all error reporting
error_reporting(0);

// Report simple running errors
error_reporting(E_ERROR | E_WARNING | E_PARSE);

// Reporting E_NOTICE can be good too (to report uninitialized
// variables or catch variable name misspellings ...)
error_reporting(E_ERROR | E_WARNING | E_PARSE | E_NOTICE);

// Report all errors except E_NOTICE
// This is the default value set in php.ini
error_reporting(E_ALL ^ E_NOTICE);

// Report all PHP errors (bitwise 63 may be used in PHP 3)
error_reporting(E_ALL);

// Same as error_reporting(E_ALL);
ini_set('error_reporting', E_ALL);

?>

The available error level constants are listed below. The actual meanings of these error levels are described in the predefined constants.

표 1. error_reporting() level constants and bit values

value | constant
1 | E_ERROR
2 | E_WARNING
4 | E_PARSE
8 | E_NOTICE
16 | E_CORE_ERROR
32 | E_CORE_WARNING
64 | E_COMPILE_ERROR
128 | E_COMPILE_WARNING
256 | E_USER_ERROR
512 | E_USER_WARNING
1024 | E_USER_NOTICE
2047 | E_ALL
2048 | E_STRICT

주의

With PHP > 5.0.0 E_STRICT with value 2048 is available. E_ALL does NOT include error levelE_STRICT.

See also the display_errors directive and ini_set().

이전 | 처음으로 | 다음
error_log | 위로 | restore_error_handler


restore_error_handler

(PHP 4 >= 4.0.1, PHP 5)

restore_error_handler -- Restores the previous error handler function

Description

void restore_error_handler ( void )

Used after changing the error handler function using set_error_handler(), to revert to the previous error handler (which could be the built-in or a user defined function)

See also error_reporting(),
set_error_handler(),
trigger_error().

이전 | 처음으로 | 다음
error_reporting | 위로 | set_error_handler


set_error_handler

(PHP 4 >= 4.0.1, PHP 5)

set_error_handler -- Sets a user-defined error handler function.

Description

string set_error_handler ( callback error_handler [, int error_types])

Sets a user function (error_handler) to handle errors in a script. Returns the previously defined error handler (if any), or FALSE on error. This function can be used for defining your own way of handling errors during runtime, for example in applications in which you need to do cleanup of data/files when a critical error happens, or when you need to trigger an error under certain conditions (using trigger_error()).

The second parameter error_types was introduced in PHP 5 and can be used to mask the triggering of the error_handler function just like the error_reporting ini setting controls which errors are shown. Without this mask set the error_handler will be called for every error regardless to the setting of the error_reporting setting.

The user function needs to accept two parameters: the error code, and a string describing the error. From PHP 4.0.2, three optional parameters are supplied: the filename in which the error occurred, the line number in which the error occurred, and the context in which the error occurred (an array that points to the active symbol table at the point the error occurred). The function can be shown as: handler ( int errno, string errstr [, string errfile [, int errline [, array errcontext]]])

errno

The first parameter, errno, contains the level of the error raised, as an integer.

errstr

The second parameter, errstr, contains the error message, as a string.

errfile

The third parameter is optional, errfile, which contains the filename that the error was raised in, as a string.

errline

The fourth parameter is optional, errline, which contains the line number the error was raised at, as an integer.

errcontext

The fifth parameter is optional, errcontext, which is an array that points to the active symbol table at the point the error occurred. In other words, errcontext will contain an array of every variable that existed in the scope the error was triggered in.

참고: Instead of a function name, an array containing an object reference and a method name can also be supplied. (Since PHP 4.3.0)

참고: The following error types cannot be handled with a user defined function: E_ERROR, E_PARSE, E_CORE_ERROR, E_CORE_WARNING, E_COMPILE_ERROR and E_COMPILE_WARNING.

The example below shows the handling of internal exceptions by triggering errors and handling them with a user defined function:

예 1. Error handling with set_error_handler() and trigger_error()

<?php

// redefine the user error constants - PHP 4 only
define("FATAL", E_USER_ERROR);
define("ERROR", E_USER_WARNING);
define("WARNING", E_USER_NOTICE);

// set the error reporting level for this script
error_reporting(FATAL | ERROR | WARNING);

// error handler function
function myErrorHandler($errno, $errstr, $errfile, $errline)
{
  switch ($errno) {
  case FATAL:
    echo "<b>FATAL</b> [$errno] $errstr<br />\n";
    echo "  Fatal error in line $errline of file $errfile";
    echo ", PHP " . PHP_VERSION . " (" . PHP_OS . ")<br />\n";
    echo "Aborting...<br />\n";
    exit(1);
    break;
  case ERROR:
    echo "<b>ERROR</b> [$errno] $errstr<br />\n";
    break;
  case WARNING:
    echo "<b>WARNING</b> [$errno] $errstr<br />\n";
    break;
  default:
    echo "Unkown error type: [$errno] $errstr<br />\n";
    break;
  }
}

// function to test the error handling
function scale_by_log($vect, $scale)
{
  if (!is_numeric($scale) || $scale <= 0) {
    trigger_error("log(x) for x <= 0 is undefined, you used: scale = $scale",
      FATAL);
  }

  if (!is_array($vect)) {
    trigger_error("Incorrect input vector, array of values expected", ERROR);
    return null;
  }

  for ($i=0; $i<count($vect); $i++) {
    if (!is_numeric($vect[$i]))
      trigger_error("Value at position $i is not a number, using 0 (zero)",
        WARNING);
    $temp[$i] = log($scale) * $vect[$i];
  }
  return $temp;
}

// set to the user defined error handler
$old_error_handler = set_error_handler("myErrorHandler");

// trigger some errors, first define a mixed array with a non-numeric item
echo "vector a\n";
$a = array(2,3, "foo", 5.5, 43.3, 21.11);
print_r($a);

// now generate second array, generating a warning
echo "----\nvector b - a warning (b = log(PI) * a)\n";
$b = scale_by_log($a, M_PI);
print_r($b);

// this is trouble, we pass a string instead of an array
echo "----\nvector c - an error\n";
$c = scale_by_log("not array", 2.3);
var_dump($c);

// this is a critical error, log of zero or negative number is undefined
echo "----\nvector d - fatal error\n";
$d = scale_by_log($a, -2.5);

?>

And when you run this sample script, the output will be:

vector a
Array
(
    [0] => 2
    [1] => 3
    [2] => foo
    [3] => 5.5
    [4] => 43.3
    [5] => 21.11
)
----
vector b - a warning (b = log(PI) * a)
<b>WARNING</b> [1024] Value at position 2 is not a number, using 0 (zero)<br />
Array
(
    [0] => 2.2894597716988
    [1] => 3.4341896575482
    [2] => 0
    [3] => 6.2960143721717
    [4] => 49.566804057279
    [5] => 24.165247890281
)
----
vector c - an error
<b>ERROR</b> [512] Incorrect input vector, array of values expected<br />
NULL
----
vector d - fatal error
<b>FATAL</b> [256] log(x) for x <= 0 is undefined, you used: scale = -2.5<br />
  Fatal error in line 36 of file trigger_error.php, PHP 4.0.2 (Linux)<br />
Aborting...<br />

It is important to remember that the standard PHP error handler is completely bypassed. error_reporting() settings will have no effect and your error handler will be called regardless - however you are still able to read the current value of error_reporting and act appropriately. Of particular note is that this value will be 0 if the statement that caused the error was prepended by the @ error-control operator.

Also note that it is your responsibility to die() if necessary. If the error-handler function returns, script execution will continue with the next statement after the one that caused an error.

참고: If errors occur before the script is executed (e.g. on file uploads) the custom error handler cannot be called since it is not registered at that time.

참고: The second parameter error_types was introduced in PHP 5.

See also error_reporting(),
restore_error_handler(),
trigger_error(), and
error level constants.

이전 | 처음으로 | 다음
restore_error_handler | 위로 | trigger_error


trigger_error

(PHP 4 >= 4.0.1, PHP 5)

trigger_error -- Generates a user-level error/warning/notice message

Description

void trigger_error ( string error_msg [, int error_type])

Used to trigger a user error condition, it can be used by in conjunction with the built-in error handler, or with a user defined function that has been set as the new error handler (set_error_handler()). It only works with the E_USER family of constants, and will default to E_USER_NOTICE.

This function is useful when you need to generate a particular response to an exception at runtime. For example:

<?php
if (assert($divisor == 0)) {
  trigger_error("Cannot divide by zero", E_USER_ERROR);
}
?>

참고: See set_error_handler() for a more extensive example.

참고: error_msg is limited to 1024 characters in length. Any additional characters beyond 1024 will be truncated.

See also error_reporting(),
set_error_handler(),
restore_error_handler(), and
error level constants.

이전 | 처음으로 | 다음
set_error_handler | 위로 | user_error


user_error

user_error -- Alias of trigger_error()

Description

This function is an alias of trigger_error().

이전 | 처음으로 | 다음
trigger_error | 위로 | File Alteration Monitor Functions


File Alteration Monitor Functions

PHP 매뉴얼
이전 다음

XXVII. File Alteration Monitor Functions

소개

FAM monitors files and directories, notifying interested applications of changes. More information about FAM is available at http://oss.sgi.com/projects/fam/.

A PHP script may specify a list of files for FAM to monitor using the functions provided by this extension.

The FAM process is started when the first connection from any application to it is opened. It exits after all connections to it have been closed.

참고: 이 확장 모듈은 윈도우 플랫폼에서는 사용할 수 없습니다.

요구 사항

This extension uses the functions of the FAM library, devoloped by SGI. Therefore you have to download and install the FAM library.

설치

To use PHP's FAM support you must compile PHP --with-fam[=DIR] where DIR is the location of the directory containing the lib and include directories.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

FAM resource

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

표 1. FAM event constants

Constant | Description
FAMChanged (integer) | Some value which can be obtained with fstat(1) changed for a file or directory.
FAMDeleted (integer) | A file or directory was deleted or renamed.
FAMStartExecuting (integer) | An executable file started executing.
FAMStopExecuting (integer) | An executable file that was running finished.
FAMCreated (integer) | A file was created in a directory.
FAMMoved (integer) | This event never occurs.
FAMAcknowledge (integer) | An event in response to fam_cancel_monitor().
FAMExists (integer) | An event upon request to monitor a file or directory. When a directory is monitored, an event for that directory and every file contained in that directory is issued.
FAMEndExist (integer) | Event after the last FAMEExists event.
차례
fam_cancel_monitor -- Terminate monitoring
fam_close -- Close FAM connection
fam_monitor_collection -- Monitor a collection of files in a directory for changes
fam_monitor_directory -- Monitor a directory for changes
fam_monitor_file -- Monitor a regular file for changes
fam_next_event -- Get next pending FAM event
fam_open -- Open connection to FAM daemon
fam_pending -- Check for pending FAM events
fam_resume_monitor -- Resume suspended monitoring
fam_suspend_monitor -- Temporarily suspend monitoring

이전 | 처음으로 | 다음
user_error | 위로 | fam_cancel_monitor


fam_cancel_monitor

(PHP 5)

fam_cancel_monitor -- Terminate monitoring

Description

bool fam_cancel_monitor ( resource fam, resource fam_monitor)

fam_cancel_monitor() terminates monitoring on a resource previously requested using one of the fam_monitor_...(). In addition an FAMAcknowledge event occurs.

See also fam_monitor_file(),
fam_monitor_directory(),
fam_monitor_collection(), and
fam_suspend_monitor()

이전 | 처음으로 | 다음
File Alteration Monitor Functions | 위로 | fam_close


fam_close

(PHP 5)

fam_close -- Close FAM connection

Description

void fam_close ( resource fam)

fam_close() closes a connection to the FAM service previously opened using fam_open().

이전 | 처음으로 | 다음
fam_cancel_monitor | 위로 | fam_monitor_collection


fam_monitor_collection

(PHP 5)

fam_monitor_collection -- Monitor a collection of files in a directory for changes

Description

resource fam_monitor_collection ( resource fam, string dirname, int depth, string mask)

fam_monitor_collection() requests monitoring for a collection of files within a directory. The actual files to be monitored are specified by a directory path in dirname, the maximum search depth starting from this directory and a shell pattern mask restricting the file names to look for.

A FAM event will be generated whenever the status of the files change. The possible event codes are described in detail in the constants part of this section.

See also fam_monitor_file(),
fam_monitor_directory(),
fam_cancel_monitor(),
fam_suspend_monitor(), and
fam_resume_monitor().

이전 | 처음으로 | 다음
fam_close | 위로 | fam_monitor_directory


fam_monitor_directory

(PHP 5)

fam_monitor_directory -- Monitor a directory for changes

Description

resource fam_monitor_directory ( resource fam, string dirname)

fam_monitor_directory() requests monitoring for a directory and all contained files. A FAM event will be generated whenever the status of the directory (i.e. the result of function stat() on that directory) or its content (i.e. the results of readdir()) change.

The possible event codes are described in detail in the constants part of this section.

See also fam_monitor_file(),
fam_monitor_collection(),
fam_cancel_monitor(),
fam_suspend_monitor(), and
fam_resume_monitor().

이전 | 처음으로 | 다음
fam_monitor_collection | 위로 | fam_monitor_file


fam_monitor_file

(PHP 5)

fam_monitor_file -- Monitor a regular file for changes

Description

resource fam_monitor_file ( resource fam, string filename)

fam_monitor_file() requests monitoring for a single file. A FAM event will be generated whenever the file status (i.e. the result of function stat() on that file) changes.

The possible event codes are described in detail in the constants part of this section.

See also fam_monitor_directory(),
fam_monitor_collection(),
fam_cancel_monitor(),
fam_suspend_monitor(), and
fam_resume_monitor().

이전 | 처음으로 | 다음
fam_monitor_directory | 위로 | fam_next_event


fam_next_event

(PHP 5)

fam_next_event -- Get next pending FAM event

Description

array fam_next_event ( resource fam)

fam_next_event() returns the next pending FAM event. The function will block until an event is available which can be checked for using fam_pending().

fam_next_event() will return an array that contains a FAM event code in element 'code', the path of the file this event applies to in element 'filename' and optionally a hostname in element 'hostname'.

The possible event codes are described in detail in the constants part of this section.

See also fam_pending().

이전 | 처음으로 | 다음
fam_monitor_file | 위로 | fam_open


fam_open

(PHP 5)

fam_open -- Open connection to FAM daemon

Description

resource fam_open ( [string appname])

fam_open() opens a connection to the FAM service daemon. The optional parameter appname should be set to a string identifying the application for logging reasons.

See also fam_close().

이전 | 처음으로 | 다음
fam_next_event | 위로 | fam_pending


fam_pending

(PHP 5)

fam_pending -- Check for pending FAM events

Description

bool fam_pending ( resource fam)

fam_pending() returns TRUE if events are available to be fetched using fam_next_event().

See also fam_next_event().

이전 | 처음으로 | 다음
fam_open | 위로 | fam_resume_monitor


fam_resume_monitor

(PHP 5)

fam_resume_monitor -- Resume suspended monitoring

Description

bool fam_resume_monitor ( resource fam, resource fam_monitor)

fam_resume_monitor() resumes monitoring of a resource previously suspend using fam_suspend_monitor().

See also fam_suspend_monitor().

이전 | 처음으로 | 다음
fam_pending | 위로 | fam_suspend_monitor


fam_suspend_monitor

(PHP 5)

fam_suspend_monitor -- Temporarily suspend monitoring

Description

bool fam_suspend_monitor ( resource fam, resource fam_monitor)

fam_suspend_monitor() temporarily suspend monitoring of a resource previously requested using one of the fam_monitor_...() functions. Monitoring can later be continued using fam_resume_monitor() without the need of requesting a complete new monitor.

See also fam_resume_monitor(), and fam_cancel_monitor().

이전 | 처음으로 | 다음
fam_resume_monitor | 위로 | FrontBase Functions


FrontBase Functions

PHP 매뉴얼
이전 다음

XXVIII. FrontBase Functions

소개

These functions allow you to access FrontBase database servers. More information about FrontBase can be found at http://www.frontbase.com/.

Documentation for FrontBase can be found at http://www.frontbase.com/cgi-bin/WebObjects/FrontBase.woa/wa/productsPage?currentPage=Documentation.

Frontbase support has been added to PHP 4.0.6.

요구 사항

You must install the FrontBase database server or at least the fbsql client libraries to use this functions. You can get FrontBase from http://www.frontbase.com/.

설치

In order to have these functions available, you must compile PHP with fbsql support by using the --with-fbsql[=DIR] option. If you use this option without specifying the path to fbsql, PHP will search for the fbsql client libraries in the default installation location for the platform. Users who installed FrontBase in a non standard directory should always specify the path to fbsql: --with-fbsql=/path/to/fbsql. This will force PHP to use the client libraries installed by FrontBase, avoiding any conflicts.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. FrontBase configuration options

Name | Default | Changeable
fbsql.allow_persistent | "1" | PHP_INI_SYSTEM
fbsql.generate_warnings | "0" | PHP_INI_SYSTEM
fbsql.autocommit | "1" | PHP_INI_SYSTEM
fbsql.max_persistent | "-1" | PHP_INI_SYSTEM
fbsql.max_links | "128" | PHP_INI_SYSTEM
fbsql.max_connections | "128" | PHP_INI_SYSTEM
fbsql.max_results | "128" | PHP_INI_SYSTEM
fbsql.batchSize | "1000" | PHP_INI_SYSTEM
fbsql.default_host | NULL | PHP_INI_SYSTEM
fbsql.default_user | "_SYSTEM" | PHP_INI_SYSTEM
fbsql.default_password | "" | PHP_INI_SYSTEM
fbsql.default_database | "" | PHP_INI_SYSTEM
fbsql.default_database_password | "" | PHP_INI_SYSTEM
For further details and definition of the PHP_INI_* constants see ini_set().

리소스 종류

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

FBSQL_ASSOC (integer)

FBSQL_NUM (integer)

FBSQL_BOTH (integer)

FBSQL_LOCK_DEFERRED (integer)

FBSQL_LOCK_OPTIMISTIC (integer)

FBSQL_LOCK_PESSIMISTIC (integer)

FBSQL_ISO_READ_UNCOMMITTED (integer)

FBSQL_ISO_READ_COMMITTED (integer)

FBSQL_ISO_REPEATABLE_READ (integer)

FBSQL_ISO_SERIALIZABLE (integer)

FBSQL_ISO_VERSIONED (integer)

FBSQL_UNKNOWN (integer)

FBSQL_STOPPED (integer)

FBSQL_STARTING (integer)

FBSQL_RUNNING (integer)

FBSQL_STOPPING (integer)

FBSQL_NOEXEC (integer)

FBSQL_LOB_DIRECT (integer)

FBSQL_LOB_HANDLE (integer)

차례
fbsql_affected_rows -- Get number of affected rows in previous FrontBase operation
fbsql_autocommit -- Enable or disable autocommit
fbsql_blob_size -- Get the size of a BLOB
fbsql_change_user -- Change logged in user of the active connection
fbsql_clob_size -- Get the size of a CLOB
fbsql_close -- Close FrontBase connection
fbsql_commit -- Commits a transaction to the database
fbsql_connect -- Open a connection to a FrontBase Server
fbsql_create_blob -- Create a BLOB
fbsql_create_clob -- Create a CLOB
fbsql_create_db -- Create a FrontBase database
fbsql_data_seek -- Move internal result pointer
fbsql_database_password -- Sets or retrieves the password for a FrontBase database
fbsql_database -- Get or set the database name used with a connection
fbsql_db_query -- Send a FrontBase query
fbsql_db_status -- Get the status for a given database
fbsql_drop_db -- Drop (delete) a FrontBase database
fbsql_errno -- Returns the numerical value of the error message from previous FrontBase operation
fbsql_error -- Returns the text of the error message from previous FrontBase operation
fbsql_fetch_array -- Fetch a result row as an associative array, a numeric array, or both
fbsql_fetch_assoc -- Fetch a result row as an associative array
fbsql_fetch_field -- Get column information from a result and return as an object
fbsql_fetch_lengths -- Get the length of each output in a result
fbsql_fetch_object -- Fetch a result row as an object
fbsql_fetch_row -- Get a result row as an enumerated array
fbsql_field_flags -- Get the flags associated with the specified field in a result
fbsql_field_len -- Returns the length of the specified field
fbsql_field_name -- Get the name of the specified field in a result
fbsql_field_seek -- Set result pointer to a specified field offset
fbsql_field_table -- Get name of the table the specified field is in
fbsql_field_type -- Get the type of the specified field in a result
fbsql_free_result -- Free result memory
fbsql_get_autostart_info -- No description given yet
fbsql_hostname -- Get or set the host name used with a connection
fbsql_insert_id -- Get the id generated from the previous INSERT operation
fbsql_list_dbs -- List databases available on a FrontBase server
fbsql_list_fields -- List FrontBase result fields
fbsql_list_tables -- List tables in a FrontBase database
fbsql_next_result -- Move the internal result pointer to the next result
fbsql_num_fields -- Get number of fields in result
fbsql_num_rows -- Get number of rows in result
fbsql_password -- Get or set the user password used with a connection
fbsql_pconnect -- Open a persistent connection to a FrontBase Server
fbsql_query -- Send a FrontBase query
fbsql_read_blob -- Read a BLOB from the database
fbsql_read_clob -- Read a CLOB from the database
fbsql_result -- Get result data
fbsql_rollback -- Rollback a transaction to the database
fbsql_select_db -- Select a FrontBase database
fbsql_set_lob_mode -- Set the LOB retrieve mode for a FrontBase result set
fbsql_set_password -- Change the password for a given user
fbsql_set_transaction -- Set the transaction locking and isolation
fbsql_start_db -- Start a database on local or remote server
fbsql_stop_db -- Stop a database on local or remote server
fbsql_tablename -- Get table name of field
fbsql_username -- Get or set the host user used with a connection
fbsql_warnings -- Enable or disable FrontBase warnings

이전 | 처음으로 | 다음
fam_suspend_monitor | 위로 | fbsql_affected_rows


fbsql_affected_rows

(PHP 4 >= 4.0.6, PHP 5)

fbsql_affected_rows -- Get number of affected rows in previous FrontBase operation

Description

int fbsql_affected_rows ( [resource link_identifier])

fbsql_affected_rows() returns the number of rows affected by the last INSERT, UPDATE or DELETE query associated with link_identifier. If the link identifier isn't specified, the last link opened by fbsql_connect() is assumed.

참고: If you are using transactions, you need to call fbsql_affected_rows() after your INSERT, UPDATE, or DELETE query, not after the commit.

If the last query was a DELETE query with no WHERE clause, all of the records will have been deleted from the table but this function will return zero.

참고: When using UPDATE, FrontBase will not update columns where the new value is the same as the old value. This creates the possibility that fbsql_affected_rows() may not actually equal the number of rows matched, only the number of rows that were literally affected by the query.

If the last query failed, this function will return -1.

See also: fbsql_num_rows().

이전 | 처음으로 | 다음
FrontBase Functions | 위로 | fbsql_autocommit


fbsql_autocommit

(PHP 4 >= 4.0.6, PHP 5)

fbsql_autocommit -- Enable or disable autocommit

Description

bool fbsql_autocommit ( resource link_identifier [, bool OnOff])

fbsql_autocommit() returns the current autocommit status. If the optional OnOff parameter is given the auto commit status will be changed. With OnOff set to TRUE each statement will be committed automatically, if no errors was found. With OnOff set to FALSE the user must commit or rollback the transaction using either fbsql_commit() or fbsql_rollback().

See also: fbsql_commit() and fbsql_rollback()

이전 | 처음으로 | 다음
fbsql_affected_rows | 위로 | fbsql_blob_size


fbsql_blob_size

(PHP 4 >= 4.2.0, PHP 5)

fbsql_blob_size -- Get the size of a BLOB

Description

int fbsql_blob_size ( string blob_handle [, resource link_identifier])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
fbsql_autocommit | 위로 | fbsql_change_user


fbsql_change_user

(no version information, might be only in CVS)

fbsql_change_user -- Change logged in user of the active connection

Description

resource fbsql_change_user ( string user, string password [, string database [, resource link_identifier]])

fbsql_change_user() changes the logged in user of the current active connection, or the connection given by the optional parameter link_identifier. If a database is specified, this will default or current database after the user has been changed. If the new user and password authorization fails, the current connected user stays active.

이전 | 처음으로 | 다음
fbsql_blob_size | 위로 | fbsql_clob_size


fbsql_clob_size

(PHP 4 >= 4.2.0, PHP 5)

fbsql_clob_size -- Get the size of a CLOB

Description

int fbsql_clob_size ( string clob_handle [, resource link_identifier])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
fbsql_change_user | 위로 | fbsql_close


fbsql_close

(PHP 4 >= 4.0.6, PHP 5)

fbsql_close -- Close FrontBase connection

Description

bool fbsql_close ( [resource link_identifier])

Returns: TRUE on success, FALSE on error.

fbsql_close() closes the connection to the FrontBase server that's associated with the specified link identifier. If link_identifier isn't specified, the last opened link is used.

Using fbsql_close() isn't usually necessary, as non-persistent open links are automatically closed at the end of the script's execution.

예 1. fbsql_close() example

<?php
    $link = fbsql_connect("localhost", "_SYSTEM", "secret")
        or die("Could not connect");
    echo "Connected successfully";
    fbsql_close($link);
?>

See also: fbsql_connect() and fbsql_pconnect().

이전 | 처음으로 | 다음
fbsql_clob_size | 위로 | fbsql_commit


fbsql_commit

(PHP 4 >= 4.0.6, PHP 5)

fbsql_commit -- Commits a transaction to the database

Description

bool fbsql_commit ( [resource link_identifier])

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

fbsql_commit() ends the current transaction by writing all inserts, updates and deletes to the disk and unlocking all row and table locks held by the transaction. This command is only needed if autocommit is set to false.

See also: fbsql_autocommit() and fbsql_rollback()

이전 | 처음으로 | 다음
fbsql_close | 위로 | fbsql_connect


fbsql_connect

(PHP 4 >= 4.0.6, PHP 5)

fbsql_connect -- Open a connection to a FrontBase Server

Description

resource fbsql_connect ( [string hostname [, string username [, string password]]])

Returns a positive FrontBase link identifier on success, or an error message on failure.

fbsql_connect() establishes a connection to a
FrontBase server.  The following defaults are assumed for missing
optional parameters: hostname = 'NULL',
username = '_SYSTEM' and
password = empty password.

If a second call is made to fbsql_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned.

The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling fbsql_close().

예 1. fbsql_connect() example

<?php

    $link = fbsql_connect("localhost", "_SYSTEM", "secret")
        or die("Could not connect");
    echo "Connected successfully";
    fbsql_close($link);

?>

See also fbsql_pconnect() and fbsql_close().

이전 | 처음으로 | 다음
fbsql_commit | 위로 | fbsql_create_blob


fbsql_create_blob

(PHP 4 >= 4.2.0, PHP 5)

fbsql_create_blob -- Create a BLOB

Description

string fbsql_create_blob ( string blob_data [, resource link_identifier])

Returns: A resource handle to the newly created blob.

fbsql_create_blob() creates a blob from blob_data. The returned resource handle can be used with insert and update commands to store the blob in the database.

예 1. fbsql_create_blob() example

<?php
    $link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
        or die("Could not connect");
    $filename = "blobfile.bin";
    $fp = fopen($filename, "rb");
    $blobdata = fread($fp, filesize($filename));
    fclose($fp);

    $blobHandle = fbsql_create_blob($blobdata, $link);

    $sql = "INSERT INTO BLOB_TABLE (BLOB_COLUMN) VALUES ($blobHandle);";
    $rs = fbsql_query($sql, $link);
?>

See also: fbsql_create_clob(),
fbsql_read_blob(),
fbsql_read_clob(), and
fbsql_set_lob_mode().

이전 | 처음으로 | 다음
fbsql_connect | 위로 | fbsql_create_clob


fbsql_create_clob

(PHP 4 >= 4.2.0, PHP 5)

fbsql_create_clob -- Create a CLOB

Description

string fbsql_create_clob ( string clob_data [, resource link_identifier])

Returns: A resource handle to the newly created CLOB.

fbsql_create_clob() creates a clob from clob_data. The returned resource handle can be used with insert and update commands to store the clob in the database.

예 1. fbsql_create_clob() example

<?php
    $link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
        or die("Could not connect");
    $filename = "clob_file.txt";
    $fp = fopen($filename, "rb");
    $clobdata = fread($fp, filesize($filename));
    fclose($fp);

    $clobHandle = fbsql_create_clob($clobdata, $link);

    $sql = "INSERT INTO CLOB_TABLE (CLOB_COLUMN) VALUES ($clobHandle);";
    $rs = fbsql_query($sql, $link);
?>

See also: fbsql_create_blob(),
fbsql_read_blob(),
fbsql_read_clob(), and
fbsql_set_lob_mode().

이전 | 처음으로 | 다음
fbsql_create_blob | 위로 | fbsql_create_db


fbsql_create_db

(PHP 4 >= 4.0.6, PHP 5)

fbsql_create_db -- Create a FrontBase database

Description

bool fbsql_create_db ( string database_name [, resource link_identifier])

fbsql_create_db() attempts to create a new database named database_name on the server associated with the specified connection link_identifier.

예 1. fbsql_create_db() example

<?php
    $link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
        or die("Could not connect");
    if (fbsql_create_db("my_db")) {
        echo "Database created successfully\n";
    } else {
        printf("Error creating database: %s\n", fbsql_error());
    }
?>

See also: fbsql_drop_db().

이전 | 처음으로 | 다음
fbsql_create_clob | 위로 | fbsql_data_seek


fbsql_data_seek

(PHP 4 >= 4.0.6, PHP 5)

fbsql_data_seek -- Move internal result pointer

Description

bool fbsql_data_seek ( resource result_identifier, int row_number)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

fbsql_data_seek() moves the internal row pointer of the FrontBase result associated with the specified result identifier to point to the specified row number. The next call to fbsql_fetch_row() would return that row.

Row_number starts at 0.

예 1. fbsql_data_seek() example

<?php
    $link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
        or die("Could not connect");

    fbsql_select_db("samp_db")
        or die("Could not select database");

    $query = "SELECT last_name, first_name FROM friends;";
    $result = fbsql_query($query)
        or die("Query failed");

    // fetch rows in reverse order

    for ($i = fbsql_num_rows($result) - 1; $i >=0; $i--) {
        if (!fbsql_data_seek($result, $i)) {
            printf("Cannot seek to row %d\n", $i);
            continue;
        }

        if (!($row = fbsql_fetch_object($result)))
            continue;

        echo $row->last_name . $row->first_name . "<br />\n";
    }

    fbsql_free_result($result);
?>

이전 | 처음으로 | 다음
fbsql_create_db | 위로 | fbsql_database_password


fbsql_database_password

(PHP 4 >= 4.0.6, PHP 5)

fbsql_database_password -- Sets or retrieves the password for a FrontBase database

Description

string fbsql_database_password ( resource link_identifier [, string database_password])

Returns: The database password associated with the link identifier.

fbsql_database_password() sets and retrieves the database password used by the connection. if a database is protected by a database password, the user must call this function before calling fbsql_select_db(). if the second optional parameter is given the function sets the database password for the specified link identifier. If no link identifier is specified, the last opened link is assumed. If no link is open, the function will try to establish a link as if fbsql_connect() was called, and use it.

This function does not change the database password in the database nor can it be used to retrieve the database password for a database.

예 1. fbsql_create_clob() example

<?php
    $link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
        or die("Could not connect");
    fbsql_database_password($link, "secret db password");
    fbsql_select_db($database, $link);
?>

See also: fbsql_connect(),
fbsql_pconnect() and
fbsql_select_db().

이전 | 처음으로 | 다음
fbsql_data_seek | 위로 | fbsql_database


fbsql_database

(PHP 4 >= 4.0.6, PHP 5)

fbsql_database -- Get or set the database name used with a connection

Description

string fbsql_database ( resource link_identifier [, string database])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
fbsql_database_password | 위로 | fbsql_db_query


fbsql_db_query

(PHP 4 >= 4.0.6, PHP 5)

fbsql_db_query -- Send a FrontBase query

Description

resource fbsql_db_query ( string database, string query [, resource link_identifier])

Returns: A positive FrontBase result identifier to the query result, or FALSE on error.

fbsql_db_query() selects a database and executes a query on it. If the optional link identifier isn't specified, the function will try to find an open link to the FrontBase server and if no such link is found it'll try to create one as if fbsql_connect() was called with no arguments

See also fbsql_connect().

이전 | 처음으로 | 다음
fbsql_database | 위로 | fbsql_db_status


fbsql_db_status

(PHP 4 >= 4.1.0, PHP 5)

fbsql_db_status -- Get the status for a given database

Description

int fbsql_db_status ( string database_name [, resource link_identifier])

Returns: An integer value with the current status.

fbsql_db_status() requests the current status of the database specified by database_name. If the link_identifier is omitted the default link_identifier will be used.

The return value can be one of the following constants:

  • FALSE - The exec handler for the host was invalid. This error will occur when the link_identifier connects directly to a database by using a port number. FBExec can be available on the server but no connection has been made for it.

  • FBSQL_UNKNOWN - The Status is unknown.

  • FBSQL_STOPPED - The database is not running. Use fbsql_start_db() to start the database.

  • FBSQL_STARTING - The database is starting.

  • FBSQL_RUNNING - The database is running and can be used to perform SQL operations.

  • FBSQL_STOPPING - The database is stopping.

  • FBSQL_NOEXEC - FBExec is not running on the server and it is not possible to get the status of the database.

See also: fbsql_start_db() and fbsql_stop_db().

이전 | 처음으로 | 다음
fbsql_db_query | 위로 | fbsql_drop_db


fbsql_drop_db

(PHP 4 >= 4.0.6, PHP 5)

fbsql_drop_db -- Drop (delete) a FrontBase database

Description

bool fbsql_drop_db ( string database_name [, resource link_identifier])

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

fbsql_drop_db() attempts to drop (remove) an entire database from the server associated with the specified link identifier.

이전 | 처음으로 | 다음
fbsql_db_status | 위로 | fbsql_errno


fbsql_errno

(PHP 4 >= 4.0.6, PHP 5)

fbsql_errno -- Returns the numerical value of the error message from previous FrontBase operation

Description

int fbsql_errno ( [resource link_identifier])

Returns the error number from the last fbsql function, or 0 (zero) if no error occurred.

Errors coming back from the fbsql database backend don't issue warnings. Instead, use fbsql_errno() to retrieve the error code. Note that this function only returns the error code from the most recently executed fbsql function (not including fbsql_error() and fbsql_errno()), so if you want to use it, make sure you check the value before calling another fbsql function.

<?php
fbsql_connect("marliesle");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
fbsql_select_db("nonexistentdb");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
$conn = fbsql_query("SELECT * FROM nonexistenttable;");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
?>

See also: fbsql_error() and fbsql_warnings().

이전 | 처음으로 | 다음
fbsql_drop_db | 위로 | fbsql_error


fbsql_error

(PHP 4 >= 4.0.6, PHP 5)

fbsql_error -- Returns the text of the error message from previous FrontBase operation

Description

string fbsql_error ( [resource link_identifier])

Returns the error text from the last fbsql function, or '' (the empty string) if no error occurred.

Errors coming back from the fbsql database backend don't issue warnings. Instead, use fbsql_error() to retrieve the error text. Note that this function only returns the error text from the most recently executed fbsql function (not including fbsql_error() and fbsql_errno()), so if you want to use it, make sure you check the value before calling another fbsql function.

<?php
fbsql_connect("marliesle");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
fbsql_select_db("nonexistentdb");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
$conn = fbsql_query("SELECT * FROM nonexistenttable;");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
?>

See also: fbsql_errno() and fbsql_warnings().

이전 | 처음으로 | 다음
fbsql_errno | 위로 | fbsql_fetch_array


fbsql_fetch_array

(PHP 4 >= 4.0.6, PHP 5)

fbsql_fetch_array -- Fetch a result row as an associative array, a numeric array, or both

Description

array fbsql_fetch_array ( resource result [, int result_type])

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

fbsql_fetch_array() is an extended version of fbsql_fetch_row(). In addition to storing the data in the numeric indices of the result array, it also stores the data in associative indices, using the field names as keys.

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you must the numeric index of the column or make an alias for the column.

select t1.f1 as foo t2.f1 as bar from t1, t2

An important thing to note is that using fbsql_fetch_array() is NOT significantly slower than using fbsql_fetch_row(), while it provides a significant added value.

The optional second argument result_type in fbsql_fetch_array() is a constant and can take the following values: FBSQL_ASSOC, FBSQL_NUM, and FBSQL_BOTH.

For further details, see also fbsql_fetch_row() and fbsql_fetch_assoc().

예 1. fbsql_fetch_array() example

<?php
fbsql_connect($host, $user, $password);
$result = fbsql_db_query("database", "select user_id, fullname from table");
while ($row = fbsql_fetch_array($result)) {
    echo "user_id: " . $row["user_id"] . "<br />\n";
    echo "user_id: " . $row[0] . "<br />\n";
    echo "fullname: " . $row["fullname"] . "<br />\n";
    echo "fullname: " . $row[1] . "<br />\n";
}
fbsql_free_result($result);
?>

이전 | 처음으로 | 다음
fbsql_error | 위로 | fbsql_fetch_assoc


fbsql_fetch_assoc

(PHP 4 >= 4.0.6, PHP 5)

fbsql_fetch_assoc -- Fetch a result row as an associative array

Description

array fbsql_fetch_assoc ( resource result)

Returns an associative array that corresponds to the fetched row, or FALSE if there are no more rows.

fbsql_fetch_assoc() is equivalent to calling fbsql_fetch_array() with FBSQL_ASSOC for the optional second parameter. It only returns an associative array. This is the way fbsql_fetch_array() originally worked. If you need the numeric indices as well as the associative, use fbsql_fetch_array().

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you must use fbsql_fetch_array() and have it return the numeric indices as well.

An important thing to note is that using fbsql_fetch_assoc() is NOT significantly slower than using fbsql_fetch_row(), while it provides a significant added value.

For further details, see also fbsql_fetch_row() and fbsql_fetch_array().

예 1. fbsql_fetch_assoc() example

<?php
fbsql_connect($host, $user, $password);
$result = fbsql_db_query("database", "select * from table");
while ($row = fbsql_fetch_assoc($result)) {
    echo $row["user_id"];
    echo $row["fullname"];
}
fbsql_free_result($result);
?>

이전 | 처음으로 | 다음
fbsql_fetch_array | 위로 | fbsql_fetch_field


fbsql_fetch_field

(PHP 4 >= 4.0.6, PHP 5)

fbsql_fetch_field -- Get column information from a result and return as an object

Description

object fbsql_fetch_field ( resource result [, int field_offset])

Returns an object containing field information.

fbsql_fetch_field() can be used in order to obtain information about fields in a certain query result. If the field offset isn't specified, the next field that wasn't yet retrieved by fbsql_fetch_field() is retrieved.

The properties of the object are:

  • name - column name

  • table - name of the table the column belongs to

  • max_length - maximum length of the column

  • not_null - 1 if the column cannot be NULL

  • type - the type of the column

예 1. fbsql_fetch_field() example

<?php
fbsql_connect($host, $user, $password)
    or die("Could not connect");
$result = fbsql_db_query("database", "select * from table")
    or die("Query failed");
# get column metadata
$i = 0;
while ($i < fbsql_num_fields($result)) {
    echo "Information for column $i:<br />\n";
    $meta = fbsql_fetch_field($result);
    if (!$meta) {
        echo "No information available<br />\n";
    }
    echo "<pre>
max_length:   $meta->max_length
name:         $meta->name
not_null:     $meta->not_null
table:        $meta->table
type:         $meta->type
</pre>";
    $i++;
}
fbsql_free_result($result);
?>

See also fbsql_field_seek().

이전 | 처음으로 | 다음
fbsql_fetch_assoc | 위로 | fbsql_fetch_lengths


fbsql_fetch_lengths

(PHP 4 >= 4.0.6, PHP 5)

fbsql_fetch_lengths -- Get the length of each output in a result

Description

array fbsql_fetch_lengths ( [resource result])

Returns: An array that corresponds to the lengths of each field in the last row fetched by fbsql_fetch_row(), or FALSE on error.

fbsql_fetch_lengths() stores the lengths of
each result column in the last row returned by
fbsql_fetch_row(),
fbsql_fetch_array() and
fbsql_fetch_object() in an array, starting at
offset 0.

See also: fbsql_fetch_row().

이전 | 처음으로 | 다음
fbsql_fetch_field | 위로 | fbsql_fetch_object


fbsql_fetch_object

(PHP 4 >= 4.0.6, PHP 5)

fbsql_fetch_object -- Fetch a result row as an object

Description

object fbsql_fetch_object ( resource result [, int result_type])

Returns an object with properties that correspond to the fetched row, or FALSE if there are no more rows.

fbsql_fetch_object() is similar to fbsql_fetch_array(), with one difference - an object is returned, instead of an array. Indirectly, that means that you can only access the data by the field names, and not by their offsets (numbers are illegal property names).

The optional argument result_type is a constant and can take the following values: FBSQL_ASSOC, FBSQL_NUM, and FBSQL_BOTH.

Speed-wise, the function is identical to fbsql_fetch_array(), and almost as quick as fbsql_fetch_row() (the difference is insignificant).

예 1. fbsql_fetch_object() example

<?php
fbsql_connect($host, $user, $password);
$result = fbsql_db_query("database", "select * from table");
while ($row = fbsql_fetch_object($result)) {
    echo $row->user_id;
    echo $row->fullname;
}
fbsql_free_result($result);
?>

See also: fbsql_fetch_array() and fbsql_fetch_row().

이전 | 처음으로 | 다음
fbsql_fetch_lengths | 위로 | fbsql_fetch_row


fbsql_fetch_row

(PHP 4 >= 4.0.6, PHP 5)

fbsql_fetch_row -- Get a result row as an enumerated array

Description

array fbsql_fetch_row ( resource result)

Returns: An array that corresponds to the fetched row, or FALSE if there are no more rows.

fbsql_fetch_row() fetches one row of data from the result associated with the specified result identifier. The row is returned as an array. Each result column is stored in an array offset, starting at offset 0.

Subsequent call to fbsql_fetch_row() would return the next row in the result set, or FALSE if there are no more rows.

See also: fbsql_fetch_array(),
fbsql_fetch_object(),
fbsql_data_seek(),
fbsql_fetch_lengths(), and
fbsql_result().

이전 | 처음으로 | 다음
fbsql_fetch_object | 위로 | fbsql_field_flags


fbsql_field_flags

(PHP 4 >= 4.0.6, PHP 5)

fbsql_field_flags -- Get the flags associated with the specified field in a result

Description

string fbsql_field_flags ( resource result, int field_offset)

fbsql_field_flags() returns the field flags of the specified field. The flags are reported as a single word per flag separated by a single space, so that you can split the returned value using explode().

이전 | 처음으로 | 다음
fbsql_fetch_row | 위로 | fbsql_field_len


fbsql_field_len

(PHP 4 >= 4.0.6, PHP 5)

fbsql_field_len -- Returns the length of the specified field

Description

int fbsql_field_len ( resource result, int field_offset)

fbsql_field_len() returns the length of the specified field.

이전 | 처음으로 | 다음
fbsql_field_flags | 위로 | fbsql_field_name


fbsql_field_name

(PHP 4 >= 4.0.6, PHP 5)

fbsql_field_name -- Get the name of the specified field in a result

Description

string fbsql_field_name ( resource result, int field_index)

fbsql_field_name() returns the name of the specified field index. result must be a valid result identifier and field_index is the numerical offset of the field.

참고: field_index starts at 0.

e.g. The index of the third field would actually be 2, the index of the fourth field would be 3 and so on.

예 1. fbsql_field_name() example

<?php
// The users table consists of three fields:
//   user_id
//   username
//   password.

$res = fbsql_db_query("users", "select * from users", $link);

echo fbsql_field_name($res, 0) . "\n";
echo fbsql_field_name($res, 2);
?>

The above example would produce the following output:

user_id
password

이전 | 처음으로 | 다음
fbsql_field_len | 위로 | fbsql_field_seek


fbsql_field_seek

(PHP 4 >= 4.0.6, PHP 5)

fbsql_field_seek -- Set result pointer to a specified field offset

Description

bool fbsql_field_seek ( resource result, int field_offset)

Seeks to the specified field offset. If the next call to fbsql_fetch_field() doesn't include a field offset, the field offset specified in fbsql_field_seek() will be returned.

See also: fbsql_fetch_field().

이전 | 처음으로 | 다음
fbsql_field_name | 위로 | fbsql_field_table


fbsql_field_table

(PHP 4 >= 4.0.6, PHP 5)

fbsql_field_table -- Get name of the table the specified field is in

Description

string fbsql_field_table ( resource result, int field_offset)

Returns the name of the table that the specified field is in.

이전 | 처음으로 | 다음
fbsql_field_seek | 위로 | fbsql_field_type


fbsql_field_type

(PHP 4 >= 4.0.6, PHP 5)

fbsql_field_type -- Get the type of the specified field in a result

Description

string fbsql_field_type ( resource result, int field_offset)

fbsql_field_type() is similar to the fbsql_field_name() function. The arguments are identical, but the field type is returned instead. The field type will be one of "int", "real", "string", "blob", and others as detailed in the FrontBase documentation.

예 1. fbsql_field_type() example

<?php

fbsql_connect("localhost", "_SYSTEM", "");
fbsql_select_db("wisconsin");
$result = fbsql_query("SELECT * FROM onek;");
$fields = fbsql_num_fields($result);
$rows   = fbsql_num_rows($result);
$i = 0;
$table = fbsql_field_table($result, $i);
echo "Your '" . $table . "' table has " . $fields . " fields and " . $rows . " records <br />";
echo "The table has the following fields <br />";
while ($i < $fields) {
    $type  = fbsql_field_type($result, $i);
    $name  = fbsql_field_name($result, $i);
    $len   = fbsql_field_len($result, $i);
    $flags = fbsql_field_flags($result, $i);
    echo $type . " " . $name . " " . $len . " " . $flags . "<br />";
    $i++;
}
fbsql_close();

?>

이전 | 처음으로 | 다음
fbsql_field_table | 위로 | fbsql_free_result


fbsql_free_result

(PHP 4 >= 4.0.6, PHP 5)

fbsql_free_result -- Free result memory

Description

bool fbsql_free_result ( resource result)

fbsql_free_result() will free all memory associated with the result identifier result.

fbsql_free_result() only needs to be called if you are concerned about how much memory is being used for queries that return large result sets. All associated result memory is automatically freed at the end of the script's execution.

이전 | 처음으로 | 다음
fbsql_field_type | 위로 | fbsql_get_autostart_info


fbsql_get_autostart_info

(PHP 4 >= 4.1.0, PHP 5)

fbsql_get_autostart_info -- No description given yet

Description

array fbsql_get_autostart_info ( [resource link_identifier])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
fbsql_free_result | 위로 | fbsql_hostname


fbsql_hostname

(PHP 4 >= 4.0.6, PHP 5)

fbsql_hostname -- Get or set the host name used with a connection

Description

string fbsql_hostname ( resource link_identifier [, string host_name])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
fbsql_get_autostart_info | 위로 | fbsql_insert_id


fbsql_insert_id

(PHP 4 >= 4.0.6, PHP 5)

fbsql_insert_id -- Get the id generated from the previous INSERT operation

Description

int fbsql_insert_id ( [resource link_identifier])

fbsql_insert_id() returns the ID generated for an column defined as DEFAULT UNIQUE by the previous INSERT query using the given link_identifier. If link_identifier isn't specified, the last opened link is assumed.

fbsql_insert_id() returns 0 if the previous query does not generate an DEFAULT UNIQUE value. If you need to save the value for later, be sure to call fbsql_insert_id() immediately after the query that generates the value.

참고: The value of the FrontBase SQL function fbsql_insert_id() always contains the most recently generated DEFAULT UNIQUE value, and is not reset between queries.

이전 | 처음으로 | 다음
fbsql_hostname | 위로 | fbsql_list_dbs


fbsql_list_dbs

(PHP 4 >= 4.0.6, PHP 5)

fbsql_list_dbs -- List databases available on a FrontBase server

Description

resource fbsql_list_dbs ( [resource link_identifier])

fbsql_list_dbs() will return a result pointer containing the databases available from the current fbsql daemon. Use the fbsql_tablename() function to traverse this result pointer.

예 1. fbsql_list_dbs() example

$link = fbsql_connect('localhost', 'myname', 'secret');
$db_list = fbsql_list_dbs($link);

while ($row = fbsql_fetch_object($db_list)) {
    echo $row->Database . "\n";
}

The above example would produce the following output:

database1
database2
database3
...

참고: The above code would just as easily work with fbsql_fetch_row() or other similar functions.

이전 | 처음으로 | 다음
fbsql_insert_id | 위로 | fbsql_list_fields


fbsql_list_fields

(PHP 4 >= 4.0.6, PHP 5)

fbsql_list_fields -- List FrontBase result fields

Description

resource fbsql_list_fields ( string database_name, string table_name [, resource link_identifier])

fbsql_list_fields() retrieves information
about the given tablename. Arguments are the database name and
the table name. A result pointer is returned which can be used
with fbsql_field_flags(),
fbsql_field_len(),
fbsql_field_name(), and
fbsql_field_type().

A result identifier is a positive integer. The function returns FALSE if an error occurs. A string describing the error will be placed in $phperrmsg, and unless the function was called as @fbsql() then this error string will also be printed out.

예 1. fbsql_list_fields() example

<?php
$link = fbsql_connect('localhost', 'myname', 'secret');

$fields = fbsql_list_fields("database1", "table1", $link);
$columns = fbsql_num_fields($fields);

for ($i = 0; $i < $columns; $i++) {
    echo fbsql_field_name($fields, $i) . "\n";;
}
?>

The above example would produce the following output:

field1
field2
field3
...

이전 | 처음으로 | 다음
fbsql_list_dbs | 위로 | fbsql_list_tables


fbsql_list_tables

(PHP 4 >= 4.0.6, PHP 5)

fbsql_list_tables -- List tables in a FrontBase database

Description

resource fbsql_list_tables ( string database [, resource link_identifier])

fbsql_list_tables() takes a database name and returns a result pointer much like the fbsql_db_query() function. The fbsql_tablename() function should be used to extract the actual table names from the result pointer.

이전 | 처음으로 | 다음
fbsql_list_fields | 위로 | fbsql_next_result


fbsql_next_result

(PHP 4 >= 4.0.6, PHP 5)

fbsql_next_result -- Move the internal result pointer to the next result

Description

bool fbsql_next_result ( resource result_id)

When sending more than one SQL statement to the server or executing a stored procedure with multiple results will cause the server to return multiple result sets. This function will test for additional results available form the server. If an additional result set exists it will free the existing result set and prepare to fetch the words from the new result set. The function will return TRUE if an additional result set was available or FALSE otherwise.

예 1. fbsql_next_result() example

<?php
    $link = fbsql_connect("localhost", "_SYSTEM", "secret");
    fbsql_select_db("MyDB", $link);
    $SQL = "Select * from table1; select * from table2;";
    $rs = fbsql_query($SQL, $link);
    do {
        while ($row = fbsql_fetch_row($rs)) {
        }
    } while (fbsql_next_result($rs));
    fbsql_free_result($rs);
    fbsql_close($link);
?>

이전 | 처음으로 | 다음
fbsql_list_tables | 위로 | fbsql_num_fields


fbsql_num_fields

(PHP 4 >= 4.0.6, PHP 5)

fbsql_num_fields -- Get number of fields in result

Description

int fbsql_num_fields ( resource result)

fbsql_num_fields() returns the number of fields in a result set.

See also:
fbsql_db_query(),
fbsql_query(),
fbsql_fetch_field(), and
fbsql_num_rows().

이전 | 처음으로 | 다음
fbsql_next_result | 위로 | fbsql_num_rows


fbsql_num_rows

(PHP 4 >= 4.0.6, PHP 5)

fbsql_num_rows -- Get number of rows in result

Description

int fbsql_num_rows ( resource result)

fbsql_num_rows() returns the number of rows in a result set. This command is only valid for SELECT statements. To retrieve the number of rows returned from a INSERT, UPDATE or DELETE query, use fbsql_affected_rows().

예 1. fbsql_num_rows() example

<?php

$link = fbsql_connect("localhost", "username", "password");
fbsql_select_db("database", $link);

$result = fbsql_query("SELECT * FROM table1;", $link);
$num_rows = fbsql_num_rows($result);

echo "$num_rows Rows\n";

?>

See also: fbsql_affected_rows(),
fbsql_connect(),
fbsql_select_db(), and
fbsql_query().

이전 | 처음으로 | 다음
fbsql_num_fields | 위로 | fbsql_password


fbsql_password

(PHP 4 >= 4.0.6, PHP 5)

fbsql_password -- Get or set the user password used with a connection

Description

string fbsql_password ( resource link_identifier [, string password])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
fbsql_num_rows | 위로 | fbsql_pconnect


fbsql_pconnect

(PHP 4 >= 4.0.6, PHP 5)

fbsql_pconnect -- Open a persistent connection to a FrontBase Server

Description

resource fbsql_pconnect ( [string hostname [, string username [, string password]]])

Returns: A positive FrontBase persistent link identifier on success, or FALSE on error.

fbsql_pconnect() establishes a connection to a FrontBase server. The following defaults are assumed for missing optional parameters: host = 'localhost', username = "_SYSTEM" and password = empty password.

To set Frontbase server port number, use fbsql_select_db().

fbsql_pconnect() acts very much like fbsql_connect() with two major differences.

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host, username and password. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use.

This type of links is therefore called 'persistent'.

이전 | 처음으로 | 다음
fbsql_password | 위로 | fbsql_query


fbsql_query

(PHP 4 >= 4.0.6, PHP 5)

fbsql_query -- Send a FrontBase query

Description

resource fbsql_query ( string query [, resource link_identifier])

fbsql_query() sends a query to the currently active database on the server that's associated with the specified link identifier. If link_identifier isn't specified, the last opened link is assumed. If no link is open, the function tries to establish a link as if fbsql_connect() was called with no arguments, and use it.

참고: The query string shall always end with a semicolon.

fbsql_query() returns TRUE (non-zero) or FALSE to indicate whether or not the query succeeded. A return value of TRUE means that the query was legal and could be executed by the server. It does not indicate anything about the number of rows affected or returned. It is perfectly possible for a query to succeed but affect no rows or return no rows.

The following query is syntactically invalid, so fbsql_query() fails and returns FALSE:

예 1. fbsql_query() example

<?php
$result = fbsql_query("SELECT * WHERE 1=1")
    or die ("Invalid query");
?>

The following query is semantically invalid if my_col is not a column in the table my_tbl, so fbsql_query() fails and returns FALSE:

예 2. fbsql_query() example

<?php
$result = fbsql_query ("SELECT my_col FROM my_tbl")
    or die ("Invalid query");
?>

fbsql_query() will also fail and return FALSE if you don't have permission to access the table(s) referenced by the query.

Assuming the query succeeds, you can call fbsql_num_rows() to find out how many rows were returned for a SELECT statement or fbsql_affected_rows() to find out how many rows were affected by a DELETE, INSERT, REPLACE, or UPDATE statement.

For SELECT statements, fbsql_query() returns a new result identifier that you can pass to fbsql_result(). When you are done with the result set, you can free the resources associated with it by calling fbsql_free_result(). Although, the memory will automatically be freed at the end of the script's execution.

See also: fbsql_affected_rows(),
fbsql_db_query(),
fbsql_free_result(),
fbsql_result(),
fbsql_select_db(), and
fbsql_connect().

이전 | 처음으로 | 다음
fbsql_pconnect | 위로 | fbsql_read_blob


fbsql_read_blob

(PHP 4 >= 4.2.0, PHP 5)

fbsql_read_blob -- Read a BLOB from the database

Description

string fbsql_read_blob ( string blob_handle [, resource link_identifier])

Returns: A string containing the BLOB specified by blob_handle.

fbsql_read_blob() reads BLOB data from the database. If a select statement contains BLOB and/or CLOB columns FrontBase will return the data directly when data is fetched. This default behavior can be changed with fbsql_set_lob_mode() so the fetch functions will return handles to BLOB and CLOB data. If a handle is fetched a user must call fbsql_read_blob() to get the actual BLOB data from the database.

예 1. fbsql_read_blob() example

<?php
    $link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
        or die("Could not connect");
    $sql = "SELECT BLOB_COLUMN FROM BLOB_TABLE;";
    $rs = fbsql_query($sql, $link);
    $row_data = fbsql_fetch_row($rs);
    // $row_data[0] will now contain the blob data for the first row
    fbsql_free_result($rs);

    $rs = fbsql_query($sql, $link);
    fbsql_set_lob_mode($rs, FBSQL_LOB_HANDLE);
    $row_data = fbsql_fetch_row($rs);
    // $row_data[0] will now contain a handle to the BLOB data in the first row
    $blob_data = fbsql_read_blob($row_data[0]);
    fbsql_free_result($rs);

?>

See also: fbsql_create_blob(),
fbsql_read_blob(),
fbsql_read_clob(), and
fbsql_set_lob_mode().

이전 | 처음으로 | 다음
fbsql_query | 위로 | fbsql_read_clob


fbsql_read_clob

(PHP 4 >= 4.2.0, PHP 5)

fbsql_read_clob -- Read a CLOB from the database

Description

string fbsql_read_clob ( string clob_handle [, resource link_identifier])

Returns: A string containing the CLOB specified by clob_handle.

fbsql_read_clob() reads CLOB data from the database. If a select statement contains BLOB and/or CLOB columns FrontBase will return the data directly when data is fetched. This default behavior can be changed with fbsql_set_lob_mode() so the fetch functions will return handles to BLOB and CLOB data. If a handle is fetched a user must call fbsql_read_clob() to get the actual CLOB data from the database.

예 1. fbsql_read_clob() example

<?php
    $link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
        or die("Could not connect");
    $sql = "SELECT CLOB_COLUMN FROM CLOB_TABLE;";
    $rs = fbsql_query($sql, $link);
    $row_data = fbsql_fetch_row($rs);
    // $row_data[0] will now contain the clob data for the first row
    fbsql_free_result($rs);

    $rs = fbsql_query($sql, $link);
    fbsql_set_lob_mode($rs, FBSQL_LOB_HANDLE);
    $row_data = fbsql_fetch_row($rs);
    // $row_data[0] will now contain a handle to the CLOB data in the first row
    $clob_data = fbsql_read_clob($row_data[0]);
    fbsql_free_result($rs);

?>

See also: fbsql_create_blob(),
fbsql_read_blob(),
fbsql_read_clob(), and
fbsql_set_lob_mode().

이전 | 처음으로 | 다음
fbsql_read_blob | 위로 | fbsql_result


fbsql_result

(PHP 4 >= 4.0.6, PHP 5)

fbsql_result -- Get result data

Description

mixed fbsql_result ( resource result, int row [, mixed field])

fbsql_result() returns the contents of one cell from a FrontBase result set. The field argument can be the field's offset, or the field's name, or the field's table dot field's name (tabledname.fieldname). If the column name has been aliased ('select foo as bar from...'), use the alias instead of the column name.

When working on large result sets, you should consider using one of the functions that fetch an entire row (specified below). As these functions return the contents of multiple cells in one function call, they're MUCH quicker than fbsql_result(). Also, note that specifying a numeric offset for the field argument is much quicker than specifying a fieldname or tablename.fieldname argument.

Calls to fbsql_result() should not be mixed with calls to other functions that deal with the result set.

Recommended high-performance alternatives:
fbsql_fetch_row(),
fbsql_fetch_array(), and
fbsql_fetch_object().

이전 | 처음으로 | 다음
fbsql_read_clob | 위로 | fbsql_rollback


fbsql_rollback

(PHP 4 >= 4.0.6, PHP 5)

fbsql_rollback -- Rollback a transaction to the database

Description

bool fbsql_rollback ( [resource link_identifier])

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

fbsql_rollback() ends the current transaction by rolling back all statements issued since last commit. This command is only needed if autocommit is set to false.

See also: fbsql_autocommit() and fbsql_commit()

이전 | 처음으로 | 다음
fbsql_result | 위로 | fbsql_select_db


fbsql_select_db

(PHP 4 >= 4.0.6, PHP 5)

fbsql_select_db -- Select a FrontBase database

Description

bool fbsql_select_db ( string database_name [, resource link_identifier])

fbsql_select_db() sets the current active database on the server that's associated with the specified link identifier. If no link identifier is specified, the last opened link is assumed. If no link is open, the function will try to establish a link as if fbsql_connect() was called, and use it.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

The client contacts FBExec to obtain the port number to use for the connection to the database. If the database name is a number the system will use that as a port number and it will not ask FBExec for the port number. The FrontBase server can be stared as FRontBase -FBExec=No -port=<port number> <database name>.

Every subsequent call to fbsql_query() will be made on the active database.

if the database is protected with a database password, the user must call fbsql_database_password() before selecting the database.

See also
fbsql_connect(),
fbsql_pconnect(),
fbsql_database_password(), and
fbsql_query().

이전 | 처음으로 | 다음
fbsql_rollback | 위로 | fbsql_set_lob_mode


fbsql_set_lob_mode

(PHP 4 >= 4.2.0, PHP 5)

fbsql_set_lob_mode -- Set the LOB retrieve mode for a FrontBase result set

Description

bool fbsql_set_lob_mode ( resource result, string database_name)

Returns: TRUE on success, FALSE on error.

fbsql_set_lob_mode() sets the mode for retrieving LOB data from the database. When BLOB and CLOB data is stored in FrontBase it can be stored direct or indirect. Direct stored LOB data will always be fetched no matter the setting of the lob mode. If the LOB data is less than 512 bytes it will always be stored directly.

  • FBSQL_LOB_DIRECT - LOB data is retrieved directly. When data is fetched from the database with fbsql_fetch_row(), and other fetch functions, all CLOB and BLOB columns will be returned as ordinary columns. This is the default value on a new FrontBase result.

  • FBSQL_LOB_HANDLE - LOB data is retrieved as handles to the data. When data is fetched from the database with fbsql_fetch_row (), and other fetch functions, LOB data will be returned as a handle to the data if the data is stored indirect or the data if it is stored direct. If a handle is returned it will be a 27 byte string formatted as "@'000000000000000000000000'".

See also:
    fbsql_create_blob(),
    fbsql_create_clob(),
    fbsql_read_blob(), and
    fbsql_read_clob().

이전 | 처음으로 | 다음
fbsql_select_db | 위로 | fbsql_set_password


fbsql_set_password

(PHP 5)

fbsql_set_password -- Change the password for a given user

Description

bool fbsql_set_password ( resource link_identifier, string user, string password, string old_password)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
fbsql_set_lob_mode | 위로 | fbsql_set_transaction


fbsql_set_transaction

(PHP 4 >= 4.2.0, PHP 5)

fbsql_set_transaction -- Set the transaction locking and isolation

Description

void fbsql_set_transaction ( resource link_identifier, int Locking, int Isolation)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
fbsql_set_password | 위로 | fbsql_start_db


fbsql_start_db

(PHP 4 >= 4.0.6, PHP 5)

fbsql_start_db -- Start a database on local or remote server

Description

bool fbsql_start_db ( string database_name [, resource link_identifier])

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

fbsql_start_db()

See also: fbsql_db_status() and fbsql_stop_db().

이전 | 처음으로 | 다음
fbsql_set_transaction | 위로 | fbsql_stop_db


fbsql_stop_db

(PHP 4 >= 4.0.6, PHP 5)

fbsql_stop_db -- Stop a database on local or remote server

Description

bool fbsql_stop_db ( string database_name [, resource link_identifier])

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

fbsql_stop_db()

See also: fbsql_db_status() and fbsql_start_db().

이전 | 처음으로 | 다음
fbsql_start_db | 위로 | fbsql_tablename


fbsql_tablename

(PHP 4 >= 4.2.0, PHP 5)

fbsql_tablename -- Get table name of field

Description

string fbsql_tablename ( resource result, int i)

fbsql_tablename() takes a result pointer returned by the fbsql_list_tables() function as well as an integer index and returns the name of a table. The fbsql_num_rows() function may be used to determine the number of tables in the result pointer.

예 1. fbsql_tablename() example

<?php
fbsql_connect("localhost", "_SYSTEM", "");
$result = fbsql_list_tables("wisconsin");
$i = 0;
while ($i < fbsql_num_rows($result)) {
    $tb_names[$i] = fbsql_tablename($result, $i);
    echo $tb_names[$i] . "<br />";
    $i++;
}
?>

이전 | 처음으로 | 다음
fbsql_stop_db | 위로 | fbsql_username


fbsql_username

(PHP 4 >= 4.0.6, PHP 5)

fbsql_username -- Get or set the host user used with a connection

Description

string fbsql_username ( resource link_identifier [, string username])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
fbsql_tablename | 위로 | fbsql_warnings


fbsql_warnings

(PHP 4 >= 4.0.6, PHP 5)

fbsql_warnings -- Enable or disable FrontBase warnings

Description

bool fbsql_warnings ( [bool OnOff])

Returns TRUE if warnings is turned on otherwise FALSE.

fbsql_warnings() enables or disables FrontBase warnings.

이전 | 처음으로 | 다음
fbsql_username | 위로 | filePro Functions


filePro Functions

PHP 매뉴얼
이전 다음

XXIX. filePro Functions

소개

These functions allow read-only access to data stored in filePro databases.

filePro is a registered trademark of fP Technologies, Inc. You can find more information about filePro at http://www.fptech.com/.

설치

filePro support in PHP is not enabled by default. To enable the bundled read-only filePro support you need to use the--enable-filepro configuration option when compiling PHP.

차례
filepro_fieldcount -- Find out how many fields are in a filePro database
filepro_fieldname -- Gets the name of a field
filepro_fieldtype -- Gets the type of a field
filepro_fieldwidth -- Gets the width of a field
filepro_retrieve -- Retrieves data from a filePro database
filepro_rowcount -- Find out how many rows are in a filePro database
filepro -- Read and verify the map file

이전 | 처음으로 | 다음
fbsql_warnings | 위로 | filepro_fieldcount


filepro_fieldcount

(PHP 3, PHP 4 , PHP 5)

filepro_fieldcount -- Find out how many fields are in a filePro database

Description

int filepro_fieldcount ( void )

Returns the number of fields (columns) in the opened filePro database.

See also filepro().

이전 | 처음으로 | 다음
filePro Functions | 위로 | filepro_fieldname


filepro_fieldname

(PHP 3, PHP 4 , PHP 5)

filepro_fieldname -- Gets the name of a field

Description

string filepro_fieldname ( int field_number)

Returns the name of the field corresponding to field_number.

이전 | 처음으로 | 다음
filepro_fieldcount | 위로 | filepro_fieldtype


filepro_fieldtype

(PHP 3, PHP 4 , PHP 5)

filepro_fieldtype -- Gets the type of a field

Description

string filepro_fieldtype ( int field_number)

Returns the edit type of the field corresponding to field_number.

이전 | 처음으로 | 다음
filepro_fieldname | 위로 | filepro_fieldwidth


filepro_fieldwidth

(PHP 3, PHP 4 , PHP 5)

filepro_fieldwidth -- Gets the width of a field

Description

int filepro_fieldwidth ( int field_number)

Returns the width of the field corresponding to field_number.

이전 | 처음으로 | 다음
filepro_fieldtype | 위로 | filepro_retrieve


filepro_retrieve

(PHP 3, PHP 4 , PHP 5)

filepro_retrieve -- Retrieves data from a filePro database

Description

string filepro_retrieve ( int row_number, int field_number)

Returns the data from the specified location in the database. The row_number parameter must be between zero and the total number of rows minus one (0..filepro_rowcount() - 1). Likewise, field_number accepts values between zero and the total number of fields minus one (0..filepro_fieldcount() - 1)

참고: 안전 모드일때, PHP는 조작하려는 파일이나 디렉토리가 같은 UID(owner)인지 확인한 후에 실행합니다.

이전 | 처음으로 | 다음
filepro_fieldwidth | 위로 | filepro_rowcount


filepro_rowcount

(PHP 3, PHP 4 , PHP 5)

filepro_rowcount -- Find out how many rows are in a filePro database

Description

int filepro_rowcount ( void )

Returns the number of rows in the opened filePro database.

참고: 안전 모드일때, PHP는 조작하려는 파일이나 디렉토리가 같은 UID(owner)인지 확인한 후에 실행합니다.

See also filepro().

이전 | 처음으로 | 다음
filepro_retrieve | 위로 | filepro


filepro

(PHP 3, PHP 4 , PHP 5)

filepro -- Read and verify the map file

Description

bool filepro ( string directory)

This reads and verifies the map file, storing the field count and info.

No locking is done, so you should avoid modifying your filePro database while it may be opened in PHP.

참고: 안전 모드일때, PHP는 조작하려는 파일이나 디렉토리가 같은 UID(owner)인지 확인한 후에 실행합니다.

이전 | 처음으로 | 다음
filepro_rowcount | 위로 | 파일시스템 함수


파일시스템 함수

PHP 매뉴얼
이전 다음

XXX. 파일시스템 함수

소개

요구 사항

이 확장을 빌드하기 위해서 외부 라이브러리가 필요하지 않습니다. 그러나 리눅스에서 PHP가 LFS(large files)를 지원하려면, 최근의 glibc를 사용하고, PHP에 다음 플래그를 지정하여 컴파일해야 합니다: -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. 파일시스템과 스트림 설정 옵션

이름 | 기본값 | 변경가능성
allow_url_fopen | "1" | PHP_INI_ALL
user_agent | NULL | PHP_INI_ALL
default_socket_timeout | "60" | PHP_INI_ALL
from | NULL | ??
auto_detect_line_endings | "Off" | PHP_INI_ALL

위 설정 지시어에 대한 간단한 설명입니다.

allow_url_fopen boolean

이 옵션은 URL 객체에 파일처럼 접근할 수 있는 URL-판단 fopen 랩퍼를 활성화합니다. 기본 랩퍼는 ftp나 http 프로토콜을 사용하여 원격 파일의 접근을 제공하며, zlib 등의 몇몇 확장은 추가 랩퍼를 등록합니다.

참고: 이 옵션은 버전 4.0.3 릴리즈 후에 추가되었습니다. 버전 4.0.3과 이전 버전에서 이 기능을 무효화 하려면 설정 스위치 --disable-url-fopen-wrapper를 사용하여 컴파일해야만 했습니다.

주의

윈도우즈 버전 PHP 4.3.0 이전에는, 다음 함수는 원격 파일 접근을
허용하지 않습니다: include(),
include_once(), require(),
require_once(), 그리고 참고문헌 XLI, Image Functions
확장의 imagecreatefromXXX 함수.

user_agent string

PHP가 전송하는 유저 에이전트를 지정합니다.

default_socket_timeout integer

소켓 기반 스트림의 기본 시간 제한(초단위).

참고: 이 설정 옵션은 PHP 4.3.0에서 추가되었습니다.

from="joe@example.com" string

익명 ftp 패스워드(email 주소)를 지정합니다.

auto_detect_line_endings boolean

on일 때, PHP는 fgets()과 file()으로 읽혀지는 데이터가 줄바꿈 방식으로 유닉스, MS-DOS, 매킨토시 방식 중 어느걸 사용하는지 검사합니다.

이는 PHP가 매킨토시 시스템과 작업을 할 수 있게 하지만, 첫째 줄에서 EOL 방식을 검출하기 위해서 아주 작은 성능에 페널티가 존재하고, 유닉스 시스템에서 사람들이 아이템 구분자로 캐리지-리턴을 사용해왔었기에, 하위 호환성이 사라질 수 있는 이유로 인해, 기본값은 Off입니다.

참고: 이 설정 옵션은 PHP 4.3.0에서 추가되었습니다.

리소스 종류

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

GLOB_BRACE (integer)

GLOB_ONLYDIR (integer)

GLOB_MARK (integer)

GLOB_NOSORT (integer)

GLOB_NOCHECK (integer)

GLOB_NOESCAPE (integer)

PATHINFO_DIRNAME (integer)

PATHINFO_BASENAME (integer)

PATHINFO_EXTENSION (integer)

FILE_USE_INCLUDE_PATH (integer)

FILE_APPEND (integer)

FILE_IGNORE_NEW_LINES (integer)

FILE_SKIP_EMPTY_LINES (integer)

참고

관련있는 함수인, 디렉토리와 프로그램 실행 섹션을 참고하십시오.

원격 파일처럼 사용할 수 있는 여러가지 URL 랩퍼의 목록과 설명은 부록 J를 참고하십시오.

차례
basename -- 경로명에서 파일이름만 반환합니다
chgrp -- 파일의 그룹을 변환합니다
chmod -- 파일의 모드 변경
chown -- 파일의 소유자 변경
clearstatcache -- 파일의 통계(stat) 캐시를 삭제합니다.
copy -- 파일을 복사합니다
delete -- 실제로는 없는 명령
dirname -- 경로의 구성요소중에서 디렉토리 이름만 반환합니다.
disk_free_space -- Returns available space in directory
disk_total_space -- Returns the total size of a directory
diskfreespace -- 디렉토리의 사용가능한 공간을 반환합니다.
fclose -- 열려있는 파일 포인터를 닫습니다.
feof -- 파일의 끝이 파일포인터에 있는지 테스트합니다.
fflush -- 출력결과를 파일로 보냅니다.
fgetc -- 파일포인터로부터 문자 가져오기
fgetcsv -- 파일포인터에서 라인을 가져오고 CVS 에 맞게 변환합니다.
fgets -- 파일 포인터에서 라인 가져오기
fgetss -- 파일포인터에서 라인을 가져오고 HTML 태그를 없애기
file_exists -- 파일이 있는지 체크
file_get_contents -- Reads entire file into a string
file_put_contents -- Write a string to a file
file -- 파일전체를 배열로 읽어들임
fileatime -- 최근에 파일에 접근한 시간을 가져옴
filectime -- 파일의 아이노드 변경시간을 가져옵니다
filegroup -- 파일의 그룹을 가져옵니다
fileinode -- 파일의 아이노드를 가져옵니다
filemtime -- 파일이 수정된 시간을 가져옵니다
fileowner -- 파일의 소유자를 가져옵니다
fileperms -- 파일의 권한을 가져옵니다
filesize -- 파일의 크기를 가져옵니다
filetype -- 파일의 형식을 가져옵니다
flock -- 파일 잠김에 관한 간단한 도움말
fnmatch -- Match filename against a pattern
fopen -- 파일이나 URL을 엽니다
fpassthru -- 파일 포인터에 남아있는 모든 데이타를 출력합니다
fputs -- 파일 포인터에 기록하기
fread -- Binary-safe 파일 읽기
fscanf -- 형식에 따라서 파일로 부터 분석하여 입력하기
fseek -- 파일 포인터에서 찾기
fstat -- 오픈 파일 포인터를 사용하는 파일에 대한 정보 가져오기
ftell -- 파일포인터의 읽기/쓰기 위치 말하기
ftruncate -- 주어진 길이로 잘라내기
fwrite -- Binary-safe 파일 쓰기
glob -- Find pathnames matching a pattern
is_dir -- filename 이 디렉토리인지 아닌지 이야기하기
is_executable -- filename이 실행가능한 것인지 아닌지 이야기하기
is_file -- filename이 보통 파일인지 아닌지 이야기하기
is_link -- filename이 심볼릭 링크인지 아닌지 이야기하기
is_readable -- filename이 읽기 가능한 것인지 아닌지 이야기하기
is_uploaded_file -- file이 HTTP POST를 통해 업로드된 것인지 아닌지 이야기하기
is_writable -- filename이 쓰기가능한 것인지 아닌지 이야기하기
is_writeable -- Alias of is_writable()
link -- hard link 만들기
linkinfo -- 링크 정보 가져오기
lstat -- 파일이나 심볼릭 링크에 관한 정보를 제공
mkdir -- 디렉토리 만들기
move_uploaded_file -- 업로드된 파일을 다른곳으로 이동하기
parse_ini_file -- Parse a configuration file
pathinfo -- Returns information about a file path
pclose -- 진행되는 파일 포인터 닫기
popen -- 진행되는 파일 포인터를 열기
readfile -- 파일을 출력합니다
readlink -- symbolic link의 target 반환
realpath -- 표준화된 절대 경로명을 반환합니다
rename -- 파일을 새 이름으로 고치기
rewind -- 파일포인터의 위치를 되돌립니다(rewind).
rmdir -- 디렉토리 제거하기
set_file_buffer -- 주어진 파일 포인터에 파일 버퍼링 설정하기
stat -- file에 대한 정보 제공
symlink -- 심볼릭 링크 만들기
tempnam -- 유일한 파일 이름 만들기
tmpfile -- 임시 파일 만들기
touch -- 파일의 수정시간을 설정합니다
umask -- 현재의 umask를 변경하기
unlink -- 파일을 삭제하기

이전 | 처음으로 | 다음
filepro | 위로 | basename


basename

(PHP 3, PHP 4 , PHP 5)

basename -- 경로명에서 파일이름만 반환합니다

Description

string basename ( string path [, string suffix])

이 함수는 경로가 포함된 파일이름이 주어졌을때 파일의 이름부분만 반환합니다. 만약 파일이름에 suffix (두번째 인자)가 붙어 있으면 이 역시 잘라집니다

윈도우즈에서는 슬래시와 (/) 백슬래시(\) 모두 경로구분자로 사용됩니다. 그 외의 환경에서는 슬래시(/)만 사용됩니다 .

예 1. basename() example

$path = "/home/httpd/html/index.php";
$file = basename ($path);        // $file 은 "index.php" 로 설정된다
$file = basename ($path,".php"); // $file 은 "index" 로 설정된다

참조: dirname()

이전 | 처음으로 | 다음
파일시스템 함수 | 위로 | chgrp


chgrp

(PHP 3, PHP 4 , PHP 5)

chgrp -- 파일의 그룹을 변환합니다

Description

int chgrp ( string filename, mixed group)

파일의 그룹을 filename에서 group으로 바꾸고자 할때 수퍼유저만이 파일의 그룹을 임으로 변경할 수 있고 그 외의 사용자들은 멤버로 있을때만 어떤 파일의 그룹을 변경할 수 있습니다.

성공하면 TRUE, 실패하면 FALSE를 반환합니다.

참조: chown() 그리고 chmod().

참고: 이 함수는 윈도우즈에서는 동작하지 않습니다.

이전 | 처음으로 | 다음
basename | 위로 | chmod


chmod

(PHP 3, PHP 4 , PHP 5)

chmod -- 파일의 모드 변경

Description

int chmod ( string filename, int mode)

filename에 정의된 파일의 모드를 주어진 mode로 변경하고자 할때 사용합니다.

주의할 점은 mode가 자동으로 8진수로 바뀌지 않는다는 것입니다. 그래서 만약에 문자열("g+w")를 사용한다면 정확하게 동작하지 않을 수 있습니다. 그래서 확실히 동작하는 구문을 사용하려면 0을 이용해서 mode의 형태를 미리 정의해 주어야 합니다:

chmod ("/somedir/somefile", 755);   // 10진수 : 정확하게 동작하지 않을 것임
chmod ("/somedir/somefile", "u+rwx,go+rx"); // 문자열 :  잘못된 구문
chmod ("/somedir/somefile", 0755);  // 8진수 : 정확한 모드 값

성공하면 TRUE, 실패하면 FALSE를 반환합니다.

참조: chown() 그리고 chgrp().

참고: 이 함수는 윈도우즈에서는 동작하지 않습니다.

이전 | 처음으로 | 다음
chgrp | 위로 | chown


chown

(PHP 3, PHP 4 , PHP 5)

chown -- 파일의 소유자 변경

Description

int chown ( string filename, mixed user)

어떤 파일의 소유자를 변경하고자 할때 수퍼유저만이 파일의 소유자를 바꿀 수 있습니다.

성공하면 TRUE, 그렇지 않으면 FALSE를 반환합니다.

참조: chown() 그리고 chmod().

참고: 이 함수는 윈도우즈에서는 동작하지 않습니다.

이전 | 처음으로 | 다음
chmod | 위로 | clearstatcache


clearstatcache

(PHP 3, PHP 4 , PHP 5)

clearstatcache -- 파일의 통계(stat) 캐시를 삭제합니다.

Description

void clearstatcache ( void )

대부분의 운영체제에서stat나lstat등의 시스템호출을 사용해서 일을하는 것은 꽤 자원을 많이 소모합니다. 그렇기 때문에 최종적으로 사용된 상태를 나타내는 함수(아래에 나열된)의 결과는 다음번에 같은 파일이름을 사용하여 그런 호출을 할 경우를 위하여 저장이 됩니다. 만약에 파일이 여러번 체크가 되었고 파일이 바뀌거나 파일이 없어졌을 경우등에 상태를 강제로 다시 체크하고자 한다면 이 함수를 사용하여 저장되어있는 최종결과를 메모리에서 삭제할 수 있습니다.

이 값은 어떤 단일 요청(request)이 유효할 때까지만 캐시된 값입니다.

stat()을 포함하여
 lstat(),
 file_exists(),
 is_writable(),
 is_readable(),
 is_executable(),
 is_file(),
 is_dir(),
 is_link(),
 filectime(),
 fileatime(),
 filemtime(),
 fileinode(),
 filegroup(),
 fileowner(),
 filesize(),
 filetype() 그리고
 fileperms()이 이 함수의 영향을 받게 되는 함수입니다.

이전 | 처음으로 | 다음
chown | 위로 | copy


copy

(PHP 3, PHP 4 , PHP 5)

copy -- 파일을 복사합니다

Description설명

int copy ( string source, string dest)

파일의 복사본을 만듭니다. 복사가 되면 TRUE, 그렇지 않으면 FALSE를 반환합니다.

예 1. copy()예문

if (!copy($file, $file.'.bak')) {
    print ("$file을 복사하는데 실패했습니다...<br>\n");
}

참조: rename().

이전 | 처음으로 | 다음
clearstatcache | 위로 | delete


delete

(no version information, might be only in CVS)

delete -- 실제로는 없는 명령

Description

void delete ( string file)

이것은 unlink()나 unset()의 함수를 잘못된 장소에서 사람들이 찾을까봐 목록에 끼워넣은 것입니다.

참조: unlink()는 파일을 삭제하고자 할때, unset()는 변수를 삭제하고자 할 때.

이전 | 처음으로 | 다음
copy | 위로 | dirname


dirname

(PHP 3, PHP 4 , PHP 5)

dirname -- 경로의 구성요소중에서 디렉토리 이름만 반환합니다.

Description

string dirname ( string path)

이 함수는 어떤 파일을 지정하는 경로가 주어졌을때 디렉토리의 이름을 반환합니다

윈도우즈에서는 슬래시(/) 와 역슬래시 (\) 모두 경로명을 구분하는 구분자로 사용되지만 기타의 운영체제에서는 슬래시(/)만 사용됩니다.

예 1. dirname() 예문

$path = "/etc/passwd";
$file = dirname ($path); // $file 은 "/etc" 로 설정됩니다.

참조: basename()

이전 | 처음으로 | 다음
delete | 위로 | disk_free_space


disk_free_space

(PHP 4 >= 4.1.0, PHP 5)

disk_free_space -- Returns available space in directory

Description

float disk_free_space ( string directory)

Given a string containing a directory, this function will return the number of bytes available on the corresponding filesystem or disk partition.

예 1. disk_free_space() example

<?php
// $df contains the number of bytes available on "/"
$df = disk_free_space("/");

// On Windows:
disk_free_space("C:");
disk_free_space("D:");
?>

참고: 이 함수는 원격 파일을 다루지 못합니다. 파일은 서버 파일시스템을 통해서 사용 가능해야만 합니다.

See also disk_total_space()

이전 | 처음으로 | 다음
dirname | 위로 | disk_total_space


disk_total_space

(PHP 4 >= 4.1.0, PHP 5)

disk_total_space -- Returns the total size of a directory

Description

float disk_total_space ( string directory)

Given a string containing a directory, this function will return the total number of bytes on the corresponding filesystem or disk partition.

예 1. disk_total_space() example

<?php
// $df contains the total number of bytes available on "/"
$df = disk_total_space("/");

// On Windows:
disk_total_space("C:");
disk_total_space("D:");
?>

참고: 이 함수는 원격 파일을 다루지 못합니다. 파일은 서버 파일시스템을 통해서 사용 가능해야만 합니다.

See also disk_free_space()

이전 | 처음으로 | 다음
disk_free_space | 위로 | diskfreespace


diskfreespace

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

diskfreespace -- 디렉토리의 사용가능한 공간을 반환합니다.

Description

float diskfreespace ( string directory)

이 함수는 디렉토리를 포함한 문자열이 주어졌을때 파일시스템이나 디스크파티션의 사용가능한 공간을 바이트로 반환합니다.

예 1. diskfreespace()예문

$df = diskfreespace("/"); // $df 는 "/"에서 사용가능한 공간의 바이트 크기를 보여줍니다.

이전 | 처음으로 | 다음
disk_total_space | 위로 | fclose


fclose

(PHP 3, PHP 4 , PHP 5)

fclose -- 열려있는 파일 포인터를 닫습니다.

Description

int fclose ( int fp)

이 파일은 fp가 닫힐때 지정됩니다.

성공하면 TRUE, 실패하면 FALSE를 반환합니다.

파일포인터는 반드시 유효한 것이어야 하고,fopen() 이나 fsockopen()등에의해 성공적으로 열려진 파일을 지정해야 합니다.

이전 | 처음으로 | 다음
diskfreespace | 위로 | feof


feof

(PHP 3, PHP 4 , PHP 5)

feof -- 파일의 끝이 파일포인터에 있는지 테스트합니다.

Description

int feof ( int fp)

파일 포인터가 파일의 끝에 있거나 에러가 발생하면 TRUE, 그렇지 않으면 FALSE를 반환합니다.

파일포인터는 반드시 유효한 것이어야하고,fopen() 이나 popen() 또는 fsockopen()에 의해 성공적으로 열려진 파일을 지정해야 합니다.

이전 | 처음으로 | 다음
fclose | 위로 | fflush


fflush

(PHP 4 >= 4.0.1, PHP 5)

fflush -- 출력결과를 파일로 보냅니다.

Description

int fflush ( int fp)

이 함수는모든 버퍼에 저장되어있던 출력을 파일핸들에 의해 지정된 자원에 강제로 쓰기합니다. fp. 성공하면 TRUE, 실패하면 FALSE를 반환.

이 파일포인터는 반드시 유효한 것이어야 하고,fopen()이나 popen()또는 fsockopen()에 의해 성공적으로 열려진 파일을 가리켜야 합니다.

이전 | 처음으로 | 다음
feof | 위로 | fgetc


fgetc

(PHP 3, PHP 4 , PHP 5)

fgetc -- 파일포인터로부터 문자 가져오기

Description

string fgetc ( int fp)

fp에 의해 가리켜진 파일로부터 한개의 문자를 포함한 문자열을 반환합니다. FALSE 나 EOF를 반환합니다.

이 파일포인터는 반드시 유효한 것이어야 하고,fopen()이나 popen() 또는 fsockopen()에 의해 성공적으로 열려진 파일을 가리켜야 합니다.

참조: fread(), fopen(), popen(), fsockopen(), 그리고 fgets().

이전 | 처음으로 | 다음
fflush | 위로 | fgetcsv


fgetcsv

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

fgetcsv -- 파일포인터에서 라인을 가져오고 CVS 에 맞게 변환합니다.

Description

array fgetcsv ( int fp, int length [, string delimiter])

fgetcsv()가 CSV형식으로 필드를 읽어와서 변환하고 읽은 필드를 포함하는 배열로 반환하는 것을 제외하고는 fgets()와 비슷합니다. 세번째 매개변수로 특정한 구분문자를 지정하지 않는다면 필드의 구분문자는 콤마가 됩니다.

Fp는 fopen(),popen() 이나fsockopen()에 의해 성공적으로 열려진 파일에 대한 유효한 파일 포인터여야 합니다.

CSV 파일에서 가장 긴 라인보다 더 길어야 합니다.(마지막 문자 찾기가 허용되었을 때)

fgetcsv()는 파일의 끝이거나 실패시 FALSE를 반환합니다.

주의-- CSV 파일에서 비어있는 라인은 NULL 필드를 배열로 만들어서 반환하고 에러로 처리되지 않습니다.

예 1. fgetcsv()예문 - CSV 파일의 전체 내용을 읽고 프린트하기

$row = 1;
$fp = fopen ("test.csv","r");
while ($data = fgetcsv ($fp, 1000, ",")) {
    $num = count ($data);
    print "<p> $row 라인에 $num 개의 필드: <br>";
    $row++;
    for ($c=0; $c<$num; $c++) {
        print $data[$c] . "<br>";
    }
}
fclose ($fp);

이전 | 처음으로 | 다음
fgetc | 위로 | fgets


fgets

(PHP 3, PHP 4 , PHP 5)

fgets -- 파일 포인터에서 라인 가져오기

Description

string fgets ( int fp, int length)

리턴값을 포함한 새로운 문자열이거나 파일의 끝중에서 먼저 도달되는 것에서 1 바이트를 읽어들인후 length만큼 증가되는 문자열 - fp에 의해 가리켜진 파일로부터 1 바이트를 읽습니다. length일때 끝을 읽습니다. - 을 반환합니다.

에러가 발생하면 FALSE를 반환합니다.

일반적인 함정:

fgets의 'C' 구조를 자주 사용하는 사람들은 EOF 가 반환되는 방법이 다르다는 것을 주의해야 합니다.

파일 포인터는 유효한 것이어야 하고 포인터가 가리키는 것은 성공적으로 열려진 fopen(),popen() 또는 fsockopen()에 의해 성공적으로 열려진 파일이어야 한다.

단순한 예문

예 1. 파일을 한 라인씩 읽어들이기

$fd = fopen ("/tmp/inputfile.txt", "r");
while (!feof ($fd)) {
    $buffer = fgets($fd, 4096);
    echo $buffer;
}
fclose ($fd);

참조: fread(), fopen(),
popen(), fgetc(),
fsockopen(), 그리고
socket_set_timeout().

이전 | 처음으로 | 다음
fgetcsv | 위로 | fgetss


fgetss

(PHP 3, PHP 4 , PHP 5)

fgetss -- 파일포인터에서 라인을 가져오고 HTML 태그를 없애기

Description

string fgetss ( int fp, int length [, string allowable_tags])

fgetss가 읽어들인 텍스트에서 HTML과 PHP 태그를 없애는 것을 제외하고는 fgets()와 같습니다.

세번째 매개변수로 옵션을 사용해서 특정한 태그를 제외시킬 수가 있습니다.

참고: allowable_tags가 PHP 3.0.13, PHP4B3 에 추가되었습니다.

참조: fgets(), fopen(),
fsockopen(), popen(), 그리고
strip_tags().

이전 | 처음으로 | 다음
fgets | 위로 | file_exists


file_exists

(PHP 3, PHP 4 , PHP 5)

file_exists -- 파일이 있는지 체크

Description

bool file_exists ( string filename)

Returns TRUE if the file specified by filename에 의해 지정된 파일이 있으면 TRUE, 없으면 FALSE를 반환합니다.

file_exists()는 원격 파일에는 동작하지 않습니다.; 서버의 파일시스템을 통해 파일에 접근한 것인지 검사됩니다.

이 함수의 실행결과는 캐시가 됩니다. 좀 더 자세한 내용을 알고 싶다면 clearstatcache()를 보십시오.

이전 | 처음으로 | 다음
fgetss | 위로 | file_get_contents


file_get_contents

(PHP 4 >= 4.3.0, PHP 5)

file_get_contents -- Reads entire file into a string

Description

string file_get_contents ( string filename [, bool use_include_path [, resource context]])

Identical to file(), except that file_get_contents() returns the file in a string. On failure, file_get_contents() will return FALSE.

file_get_contents() is the preferred way to read the contents of a file into a string. It will use memory mapping techniques if supported by your OS to enhance performance.

참고: 이 함수는 바이너리 호환(binary-safe)입니다.

작은 정보: fopen wrappers를 설정하면, 이 함수의 파일 이름으로 URL을 사용할 수 있습니다. 파일 이름을 지정하는 방법은 fopen()을 참고하고, 지원하는 URL 프로토콜 목록은 부록 J를 참고하십시오.

참고: Context 지원은 PHP 5.0.0에서 추가되었습니다.

주의

IIS 등의 표준과 호환되지 않는 일부 웹서버에서는 이 방법으로 데이터를 전송할 때 PHP가 경고를 발생합니다. 이러한 웹서버에서 사용할 때는 error_reporting 레벨을 낮춰서, 경고를 포함하지 않도록 하십시오.

See also: fgets(), file(),
fread(), include(),
and readfile().

이전 | 처음으로 | 다음
file_exists | 위로 | file_put_contents


file_put_contents

(PHP 5)

file_put_contents -- Write a string to a file

Description

int file_put_contents ( string filename, string data [, int flags [, resource context]])

Identical to calling fopen(), fwrite(), and fclose() successively. The function returns the amount of bytes that were written to the file.

flags can take FILE_USE_INCLUDE_PATH and/or FILE_APPEND, however the FILE_USE_INCLUDE_PATH option should be used with caution.

참고: 이 함수는 바이너리 호환(binary-safe)입니다.

작은 정보: fopen wrappers를 설정하면, 이 함수의 파일 이름으로 URL을 사용할 수 있습니다. 파일 이름을 지정하는 방법은 fopen()을 참고하고, 지원하는 URL 프로토콜 목록은 부록 J를 참고하십시오.

See also:
fopen(),
fwrite(),
fclose(), and
file_get_contents().

이전 | 처음으로 | 다음
file_get_contents | 위로 | file


file

(PHP 3, PHP 4 , PHP 5)

file -- 파일전체를 배열로 읽어들임

Description

array file ( string filename [, int use_include_path])

file()이 파일을 배열로 반환하는 것을 제외하고는 readfile()과 같습니다. 새로운 라인이 연결되는 것을 포함해서 배열의 매 요소는 파일의 라인과 비슷합니다.

파일에서 include_path에서 파일을 찾고 싶다면 두번째 매개변수로 "1"을 사용하면 됩니다.

<?php
// 배열로 웹 페이지를 가져오고 출력함
$fcontents = file ('http://www.php.net');
while (list ($line_num, $line) = each ($fcontents)) {
    echo "<b>Line $line_num:</b> " . htmlspecialchars ($line) . "<br>\n";
}

//문자열로 웹 페이지를 가져옴
$fcontents = join ('', file ('http://www.php.net'));
?>

참조: readfile(), fopen(), fsockopen(), 그리고 popen().

이전 | 처음으로 | 다음
file_put_contents | 위로 | fileatime


fileatime

(PHP 3, PHP 4 , PHP 5)

fileatime -- 최근에 파일에 접근한 시간을 가져옴

Description

int fileatime ( string filename)

파일에 최종 접근 시간을 반환하며 에러가 발생할 경우에는 FALSE를 반환합니다. 반환되는 시간은 유닉스형식입니다.

이 함수의 실행결과는 캐시가 됩니다. 좀 더 자세한 내용을 알고 싶다면 clearstatcache()를 보십시오.

주의: 파일에 접근한 시간은 파일을 읽어들인후에 접근이 막혔을 때마다 바뀌는 것이 지원됩니다.이렇게 하는 것은 정기적으로 매우 많은 파일이나 디렉토리에 어플리케이션에서 접근할 때 꽤 많은 자원을 요구합니다.몇몇 유닉스 시스템에서는 그런 어플리케이션의 퍼포먼스 증가를 막기 위해서 접근시간 업데이트 설정을 꺼놓고 마운트 하기도 합니다. USENET 뉴스 스풀이 일반적인 예입니다. 그런 파일시스템에는 이 함수는 별로 쓸모 없을것입니다.

이전 | 처음으로 | 다음
file | 위로 | filectime


filectime

(PHP 3, PHP 4 , PHP 5)

filectime -- 파일의 아이노드 변경시간을 가져옵니다

Description

int filectime ( string filename)

파일이 마지막으로 변경된 시간을 반환합니다. 에러가 발생하면 FALSE를 반환합니다. 반환되는 시간은 유닉스 형식입니다.

이 함수의 실행결과는 캐쉬가 됩니다. 좀 더 자세한 내용은 clearstatcache()를 참조하세요.

주의: 대부분의 유닉스 파일시스템에서는 아이노드의 데이타(권한, 소유자, 그룹이나 다른 요소)가 변경되었을 때 파일이 바뀌는 것이 허용됩니다. 참조: filemtime() (이것은 웹 페이지의 하단에 "마지막 수정시간"을 붙이고 싶을 때 사용합니다. ) 그리고 fileatime().

주의: 몇 몇 유닉스 텍스트에서 파일의 ctime이 파일이 만들어진 시간으로 사용하고자 하는 경우가 있는데 이것은 잘못된 것입니다. 대부분의 유닉스 파일시스템에는 파일이 만들어진 시간이라는 것이 없습니다.

이전 | 처음으로 | 다음
fileatime | 위로 | filegroup


filegroup

(PHP 3, PHP 4 , PHP 5)

filegroup -- 파일의 그룹을 가져옵니다

Description

int filegroup ( string filename)

파일의 소유자나 그룹의 ID를 반환합니다. 에러가 발생하면 FALSE를 반환합니다. 그룹 ID는 숫자형식으로 반환이 됩니다. 그룹의 이름으로 바꾸기 위해서 posix_getgrgid()함수가 사용됩니다.

이 함수의 실행결과는 캐시가 됩니다. 좀 더 자세한 내용을 알고 싶을 때는 clearstatcache()를 보십시오.

참고: 이 함수는 윈도우즈에서는 동작하지 않습니다.

이전 | 처음으로 | 다음
filectime | 위로 | fileinode


fileinode

(PHP 3, PHP 4 , PHP 5)

fileinode -- 파일의 아이노드를 가져옵니다

Description

int fileinode ( string filename)

파일의 아이노드 숫자를 반환하거나 에러일 경우에는 FALSE를 반환합니다.

이 함수의 실행결과는 캐시가 됩니다. 좀 더 자세한 내용을 알고 싶을 때는 clearstatcache()를 보십시오.

참고: 이 함수는 윈도우즈에서는 동작하지 않습니다

이전 | 처음으로 | 다음
filegroup | 위로 | filemtime


filemtime

(PHP 3, PHP 4 , PHP 5)

filemtime -- 파일이 수정된 시간을 가져옵니다

Description

int filemtime ( string filename)

파일이 마지막으로 수정이 된 시간을 반환하거나 실패할 경우에는 FALSE를 반환합니다. 반환되는 시간은 유닉스 형식입니다

이 함수의 실행결과는 캐시가 됩니다. 좀 더 자세한 내용을 알고 싶을 때는 clearstatcache()를 보십시오.

주의: 이 함수는 파일의 내용이 수정되는 도중에 접근을 막은 시간이 기록이 됩니다. 이 함수의 실행결과와 함께 date()를 사용하면 페이지의 하단에 출력가능한 수정일자를 표시할 수 있습니다.

이전 | 처음으로 | 다음
fileinode | 위로 | fileowner


fileowner

(PHP 3, PHP 4 , PHP 5)

fileowner -- 파일의 소유자를 가져옵니다

Description

int fileowner ( string filename)

파일 소유자의 ID를 숫자형식으로 반환하거나 실패할 경우에는 FALSE를 반환합니다. ID를 사용자의 이름으로 바꾸기 위해서 posix_getpwuid()를 사용합니다.

이 함수의 실행결과는 캐시가 됩니다. 좀 더 자세한 내용을 알고 싶을 때는 clearstatcache()를 보십시오.

참고: 이 함수는 윈도우즈에서는 동작하지 않습니다.

이전 | 처음으로 | 다음
filemtime | 위로 | fileperms


fileperms

(PHP 3, PHP 4 , PHP 5)

fileperms -- 파일의 권한을 가져옵니다

Description

int fileperms ( string filename)

파일의 권한을 반환하거나 실패할 경우에는 FALSE를 반환합니다.

이 함수의 실행결과는 캐시가 됩니다. 좀 더 자세한 내용을 알고 싶을때는 clearstatcache()를 참조하세요

이전 | 처음으로 | 다음
fileowner | 위로 | filesize


filesize

(PHP 3, PHP 4 , PHP 5)

filesize -- 파일의 크기를 가져옵니다

Description

int filesize ( string filename)

파일의 크기나 FALSE를 반환합니다.

이 함수의 실행결과는 캐시가 됩니다. 좀 더 자세한 내용을 알고 싶을때는 clearstatcache()를 참조하세요.

이전 | 처음으로 | 다음
fileperms | 위로 | filetype


filetype

(PHP 3, PHP 4 , PHP 5)

filetype -- 파일의 형식을 가져옵니다

Description

string filetype ( string filename)

반환되는 파일의 형식은 fifo, char, dir, block, link, file, 그리고 unknown 입니다.

에러가 발생하면 FALSE를 반환합니다.

이 함수의 실행결과는 캐시가 됩니다. 좀 더 자세한 내용을 알고 싶을때는 clearstatcache()를 참조하세요.

이전 | 처음으로 | 다음
filesize | 위로 | flock


flock

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

flock -- 파일 잠김에 관한 간단한 도움말

Description

bool flock ( int fp, int operation [, int wouldblock])

PHP는 파일에 대한 접근을 막는데 간단한 방법을 제공합니다. 이것은 모든 접근하는 프로그램이 파일을 잠그는데 같은 방법을 사용해야 하며 그렇지 않으면 동작하지 않습니다.

flock()은 fp가 열려진 파일에 대한 포인터일때 이것위에서 동작합니다 operation은 산출되는 값중에 하나입니다:

  • 공동으로 접근을 막고자 할때(읽는 사람) operation을 LOCK_SH로 설정합니다 (PHP 4.0.1 이전버전은 1로 설정합니다).

  • 단독으로 접근을 막는 것이 필요할때(쓰는 사람) operation을 LOCK_EX로 설정합니다 (PHP 4.0.1이전버전은 2로 설정합니다).

  • 파일에 대한 접근을 풀어줄때 (공동 또는 단독) operation을 LOCK_UN으로 설정합니다. (PHP 4.0.1이전 버전은 3으로 설정합니다).

  • 파일에 대한 접근을 막는데 flock()을 사용하고 싶지않으면 LOCK_NB을 추가 하세요 (PHP 4.0.1 이전버젼에서는) operation을 4로 설정하세요.

flock()은 실제로 모든 환경에서 간단한 읽기/쓰기 예를 수행할 수 있게 만들어줍니다 reader/writer model which can be used on virtually every platform (대부분의 유닉스와 윈도우즈 환경에서도). 접근을 막을 수가 없다면 세번째 매개변수가 TRUE로 설정되어 있는 것입니다.(EWOULDBLOCK errno condition)

flock()은 성공하면 TRUE를 반환하고 실패하면 FALSE를 반환합니다. (예를 들면 파일 접근을 막는것이 요청되지 못할 때).

주의

flock()은 대부분의 운영체제에서 프로세스 단계에서 실행됩니다 . ISAPI같은 멀티쓰레드된 서버 API를 사용하고자 할 경우에 flock()이 같은 서버의 인스턴스의 병렬 쓰레드로서 다른 PHP스크립트가 진행될때 파일을 보호할 것을 기대하지 마십시오

이전 | 처음으로 | 다음
filetype | 위로 | fnmatch


fnmatch

(PHP 4 >= 4.3.0, PHP 5)

fnmatch -- Match filename against a pattern

Description

array fnmatch ( string pattern, string string [, int flags])

fnmatch() checks if the passed string would match the given shell wildcard pattern.

This is especially useful for filenames, but may also be used on regular strings. The average user may be used to shell patterns or at least in their simplest form to '?' and '*' wildcards so using fnmatch() instead of ereg() or preg_match() for frontend search expression input may be way more convenient for non-programming users.

예 1. Checking a color name against a shell wildcard pattern.

<?php
if (fnmatch("*gr[ae]y", $color)) {
  echo "some form of gray ...";
}
?>

주의

For now this function is not available on Windows or other non-POSIX compliant systems.

See also glob(),
ereg(),
preg_match()
and the Unix manpage on fnmatch(3) for flag names
(as long as they are not documented here ).

이전 | 처음으로 | 다음
flock | 위로 | fopen


fopen

(PHP 3, PHP 4 , PHP 5)

fopen -- 파일이나 URL을 엽니다

Description

int fopen ( string filename, string mode [, int use_include_path])

만약filename이 "http://"로 시작하면 (sensitive 하지 않은 경우에), HTTP 1.0 연결이 지정된 서버를 열어줍니다.그리고 파일 포인터는 응답텍스트의 시작부분으로 돌려집니다.. A '호스트:' 헤더부분은 name-based virtual hosts를 핸들링하기 위해서 요청과 함께 보내집니다.

HTTP 리다이렉트를 건드리지 마십시오. 반드시 디렉토리뒤에 따르는 슬래쉬를 포함시켜야 합니다.

만약에 filename이 "ftp://"로 시작이 되면 (sensitive 하지 않은 경우에), 지정된 서버가 ftp연결에 의해 열려집니다. 그리로 요청된 파일에 대한 포인터가 반환됩니다. 만약에 서버의 ftp가 받을 수 있는 모드를 지원하지 않으면, 이것은 실행될 수 없습니다. ftp를 통해서 파일을 읽거나 쓸수도 있습니다.ftp (동시에 할 수는 없습니다).

만약에filename이 "php://stdin", "php://stdout", "php://stderr",중의 하나라면 일치하는 표준입출력 스트림이 열리게 됩니다 (PHP 3.0.13에 소개가 되어 있습니다; 이전 버전에서 표준입출력 스트림에 접근하려면 filename이 "/dev/stdin" 이나 "/dev/fd/0" 이어야 합니다.)

filename이 다른 것으로 시작되면 그 파일은 파일 시스템에서 열려집니다. 그리고, 파일에 대한 파일 포인터가 열려서 반환됩니다.

열수가 없다면 FALSE를 반환합니다.

mode다음의 어느것이라도 될 수가 있습니다:

  • 'r' - 읽기전용으로 열립니다; 파일포인터를 파일의 맨 앞에 놓습니다.

  • 'r+' - 읽기 쓰기가 가능합니다.; 파일 포인터를 파일의 맨 앞에 놓습니다.

  • 'w' - 쓰기 전용으로 열립니다; 파일 포인터를 파일의 맨 앞에 놓습니다 그리고 파일의 크기를 0으로 만듭니다. 파일이 없으면 만듭니다.

  • 'w+' - 읽기 쓰기가 가능합니다; 파일포인터를 파일의 맨 앞에 놓습니다. 그리고 파일의 크기를0으로 만듭니다. 파일이 없으면 만듭니다.

  • 'a' - 쓰기 전용으로 열립니다; 파일 포인터를 파일의 끝에 놓습니다. 파일이 없으면 만듭니다.

  • 'a+' - 읽기 쓰기가 가능합니다; 파일 포인터를 파일의 끝에 놓습니다. 파일이 없으면 만듭니다.

mode가 문자'b'를 포함할 수도 있습니다. 이것은 시스템상에서 바이너리와 텍스트 파일을 구별짓는데 쓸모가 있습니다 (다시 말하면 유닉스에서는 쓸모가 없습니다).필요가 없으면 사용하지 마세요.

세번째 매개변수를 사용할 수 있는데 include_path가운데서 파일을 찾고 싶으면 "1"로 설정하세요.

예 1. fopen() example

$fp = fopen ("/home/rasmus/file.txt", "r");
$fp = fopen ("/home/rasmus/file.gif", "wb");
$fp = fopen ("http://www.php.net/", "r");
$fp = fopen ("ftp://user:password@example.com/", "w");

PHP의 서버 모듈 버전을 사용하는데 파일을 읽고 쓰는데 문제를 겪었다면 파일과 디렉토리를 서버 프로세스가 접근이 가능하게 했는지 확인해보세요

윈도우즈에서는, 파일의 경로에서 백슬래시를 사용했는지 슬래시를 사용했는지 주의하세요.

$fp = fopen ("c:\\data\\info.txt", "r");

참조 fclose(),
fsockopen(),
socket_set_timeout(), and
popen().

이전 | 처음으로 | 다음
fnmatch | 위로 | fpassthru


fpassthru

(PHP 3, PHP 4 , PHP 5)

fpassthru -- 파일 포인터에 남아있는 모든 데이타를 출력합니다

Description

int fpassthru ( int fp)

주어진 파일포인터를 끝까지 읽고 일반 출력으로 결과를 씁니다.

에러가 발생하면fpassthru()는 FALSE를 반환합니다.

파일포인터는 유효한 것이어야 합니다. 그리고 fopen(), popen(), or fsockopen()에 의해 성공적으로 열려진 파일을 가리켜야 합니다. fpassthru()가 파일읽기를 마치면 파일이 닫힙니다. (남겨진 fp는 쓸모가 없습니다).

파일의 내용을 일반출력으로 보내기 위한 것이라면, fopen()을 호출하는 것보다 readfile()을 사용하고 싶어할 것입니다

참조readfile(), fopen(), popen(), 그리고 fsockopen()

이전 | 처음으로 | 다음
fopen | 위로 | fputs


fputs

(PHP 3, PHP 4 , PHP 5)

fputs -- 파일 포인터에 기록하기

Description

int fputs ( int fp, string str [, int length])

fputs()는 fwrite()로 언제나 앨리어스 됩니다. length매개변수는 선택이 가능하고 전체 문자열이 나열되지 않으면 쓰여진다는 것을 주의하세요.

이전 | 처음으로 | 다음
fpassthru | 위로 | fread


fread

(PHP 3, PHP 4 , PHP 5)

fread -- Binary-safe 파일 읽기

Description

string fread ( int fp, int length)

fread()는 fp에 의해 참조가 되는 파일 포인터로부터 length를 바이트로 증가시키며 읽습니다. length바이트가 읽혔거나 파일의 끝에 도달되거나 둘중에 먼저 끝나는 것이 있으면 읽기가 종료됩니다..

// 파일의 내용을 문자열로 가져오기
$filename = "/usr/local/something.txt";
$fd = fopen ($filename, "r");
$contents = fread ($fd, 파일의크기 ($filename));
fclose ($fd);

참조 fwrite(), fopen(),
fsockopen(), popen(),
fgets(), fgetss(),
fscanf(), file(), and
fpassthru().

이전 | 처음으로 | 다음
fputs | 위로 | fscanf


fscanf

(PHP 4 >= 4.0.1, PHP 5)

fscanf -- 형식에 따라서 파일로 부터 분석하여 입력하기

Description

mixed fscanf ( int handle, string format [, string var1])

fscanf()는 sscanf()과 비슷하지만, 내용을 파일로부터 가져온다는 것이 다릅니다. handle과 함께 일련의 format으로 입력내용을 바꾸어 줍니다. 이 함수에 두개의 매개변수만 사용된다면 배열 형식의 값으로 변환되어 반환됩니다. 그렇지 않은 경우에는 선택적인 매개변수를 사용하지 않으면 이 함수는 할당된 값을 숫자로 반환합니다. 선택적인 매개변수는 반드시 passed by reference여야 합니다.

예 1. fscanf()예

$fp = fopen ("users.txt","r");
while ($userinfo = fscanf ($fp, "%s\t%s\t%s\n")) {
    list ($name, $profession, $countrycode) = $userinfo;
    //... do something with the values
}
fclose($fp);

예 2. users.txt

javier  argonaut        pe
hiroshi sculptor        jp
robert  slacker us
luigi   florist it

참조 fread(), fgets(),
fgetss(), sscanf(),
printf(), and sprintf().

이전 | 처음으로 | 다음
fread | 위로 | fseek


fseek

(PHP 3, PHP 4 , PHP 5)

fseek -- 파일 포인터에서 찾기

Description

int fseek ( int fp, int offset [, int whence])

fp에 의해 참조되는 파일을 파일 위치 측정자로 설정합니다. 파일의 시작위치에서부터 바이트단위로 측정되는 새로운위치는 아래와 같이 정의된 whence로부터 나열이 된 위치에 offset을 추가하여 얻어집니다

SEEK_SET - 위치를 offset바이트와 같게 합니다.
SEEK_CUR - 현재 위치에 offset을 더하여 위치를 정합니다.
SEEK_END - 파일의 끝에 offset을 더하여 위치를 정합니다.

만약에whence 가 정해지지 않았다면 SEEK_SET으로 가정이 됩니다.

성공하면 0을 반환하고 그렇지 않으면 1을 반환합니다. 이전에 EOF를 찾은 것은 에러에 영향을 주지 않습니다

만약에 "http://" or "ftp://" 형식을 사용한다면 fopen()에 의해 반환되는 파일포인터 상에서 사용되지 않을 것입니다

참고: whence인수는 PHP 4.0 RC1 이후에 추가되었습니다.

참조 ftell() and rewind().

이전 | 처음으로 | 다음
fscanf | 위로 | fstat


fstat

(PHP 4 , PHP 5)

fstat -- 오픈 파일 포인터를 사용하는 파일에 대한 정보 가져오기

Description

array fstat ( int fp)

파일 포인터 fp에 의해서 열려진 파일의 정보를 모읍니다.Gathers the statistics of the file opened by the file 이 함수는 filename대신에 오픈 파일 포인터위에서 동작한다는 것을 제외하고는 stat()과 비슷합니다.

다음의 요소들과 함께 파일의 통계자료를 배열로 반환합니다:

  1. 장치(device)

  2. 아이노드

  3. 링크의 갯수

  4. 소유자의 user id

  5. 소유자의 group id

  6. 아이노드 장치(device)가 있으면 장치(device) 형태*

  7. 바이트단위 크기

  8. 마지막 접근시간

  9. 마지막 수정된 시간

  10. 마지막 바뀐 시간

  11. 파일 시스템 입출력(I/O) blocksize*

  12. 할당된 block의 수

* - st_blksize 형태를 지원하는 시스템에만 유효합니다--다른 시스템 (다시 말해서 윈도우즈같은)은 -1을 반환합니다

이 함수의 실행결과는 캐시가 됩니다. 좀 더 자세히 알고 싶으면 clearstatcache()참조하세요

이전 | 처음으로 | 다음
fseek | 위로 | ftell


ftell

(PHP 3, PHP 4 , PHP 5)

ftell -- 파일포인터의 읽기/쓰기 위치 말하기

Description

int ftell ( int fp)

fp에 의해 참조되는 파일의 위치를 반환합니다. 다시 말해서 상쇄된 결과가 파일 스트림안으로 들어갑니다

에러가 발생하면 FALSE를 반환합니다.

파일 포인터는 반드시 유효한 것이어야 하고 fopen()이나 popen()에 의해 성공적으로 열려진 파일을 가리켜야 합니다.

참조fopen(), popen(), fseek() and rewind().

이전 | 처음으로 | 다음
fstat | 위로 | ftruncate


ftruncate

(PHP 4 , PHP 5)

ftruncate -- 주어진 길이로 잘라내기

Description

int ftruncate ( int fp, int size)

파일포인터와 fp를 가져옵니다. 그리고 파일을 길이, 크기로 잘라냅니다. 이 함수는 성공하면 TRUE, 실패하면 FALSE를 반환합니다

이전 | 처음으로 | 다음
ftell | 위로 | fwrite


fwrite

(PHP 3, PHP 4 , PHP 5)

fwrite -- Binary-safe 파일 쓰기

Description

int fwrite ( int fp, string string [, int length])

fwrite()는 fp에 의해 지정이 되는 파일 스트림에 string의 내용을 기록합니다. length인수가 주어지면 length바이트가 기록이 되거나 string의 끝에 도달하거나 먼저 끝나는 것에 의해 기록하는 것을 멈춥니다.

주의할 것은 length인수가 주어지면, magic_quotes_runtime설정옵션은 무시가 되고 슬래시는 string에서 제거되지 않게됩니다.

참조fread(), fopen(),
fsockopen(), popen(), and
fputs().

이전 | 처음으로 | 다음
ftruncate | 위로 | glob


glob

(PHP 4 >= 4.3.0, PHP 5)

glob -- Find pathnames matching a pattern

Description

array glob ( string pattern [, int flags])

The glob() function searches for all the pathnames matching pattern according to the rules used by the shell. No tilde expansion or parameter substitution is done.

Returns an array containing the matched files/directories or FALSE on error.

Valid flags:

  • GLOB_MARK - Adds a slash to each item returned

  • GLOB_NOSORT - Return files as they appear in the directory (no sorting)

  • GLOB_NOCHECK - Return the search pattern if no files matching it were found

  • GLOB_NOESCAPE - Backslashes do not quote metacharacters

  • GLOB_BRACE - Expands {a,b,c} to match 'a', 'b', or 'c'

  • GLOB_ONLYDIR - Return only directory entries which match the pattern

참고: Before PHP 4.3.3 GLOB_ONLYDIR was not available on Windows and other systems not using the GNU C library.

예 1. Convenient way how glob() can replace opendir() and friends.

<?php
foreach (glob("*.txt") as $filename) {
    echo "$filename size " . filesize($filename) . "\n";
}
?>

Output will look something like:

funclist.txt size 44686
funcsummary.txt size 267625
quickref.txt size 137820

참고: 이 함수는 원격 파일을 다루지 못합니다. 파일은 서버 파일시스템을 통해서 사용 가능해야만 합니다.

See also opendir(),
readdir(),
closedir(), and fnmatch().

이전 | 처음으로 | 다음
fwrite | 위로 | is_dir


is_dir

(PHP 3, PHP 4 , PHP 5)

is_dir -- filename 이 디렉토리인지 아닌지 이야기하기

Description

bool is_dir ( string filename)

filename이 존재하고 디렉토리이면 TRUE를 반환합니다.

이 함수의 실행결과는 캐시가 됩니다. 좀더 자세한 내용을 알고 싶으면 clearstatcache()를 보세요

참조is_file()그리고 is_link().

이전 | 처음으로 | 다음
glob | 위로 | is_executable


is_executable

(PHP 3, PHP 4 , PHP 5)

is_executable -- filename이 실행가능한 것인지 아닌지 이야기하기

Description

bool is_executable ( string filename)

filename이 존재하고, 실행가능한 것이면 TRUE를 반환합니다

이 함수의 실행결과는 캐시가 됩니다. 좀 더 자세한 내용을 알고 싶으면 clearstatcache()를 보세요

참조 is_file() 그리고 is_link().

이전 | 처음으로 | 다음
is_dir | 위로 | is_file


is_file

(PHP 3, PHP 4 , PHP 5)

is_file -- filename이 보통 파일인지 아닌지 이야기하기

Description

bool is_file ( string filename)

filename이 존재하고, 정상적인 보통의 파일이라면(regular) TRUE를 반환

이 함수의 실행결과는 캐시가 됩니다. 좀 더 자세한 내용을 알고 싶으면 clearstatcache()를 보세요.

참조is_dir() 그리고 is_link().

이전 | 처음으로 | 다음
is_executable | 위로 | is_link


is_link

(PHP 3, PHP 4 , PHP 5)

is_link -- filename이 심볼릭 링크인지 아닌지 이야기하기

Description

bool is_link ( string filename)

filename이 존재하고 심볼릭링크된 파일이라면 TRUE

이 함수의 실행결과는 캐시가 됩니다. 좀 더 자세한 내용을 알고 싶으면 clearstatcache()를 보세요.

참조 is_dir() 그리고 is_file().

참고: 이 함수는 윈도우즈에서는 동작하지 않습니다.

이전 | 처음으로 | 다음
is_file | 위로 | is_readable


is_readable

(PHP 3, PHP 4 , PHP 5)

is_readable -- filename이 읽기 가능한 것인지 아닌지 이야기하기

Description

bool is_readable ( string filename)

filename이 존재하고 읽기 가능한 것이면 TRUE를 반환합니다

웹 서버가 자주 'nobody' 등으로 실행될 때 PHP는 파일에 접근할 때 사용자 아이디로 접근할 수가 있다는 것을 명심하세요.. 안전모드의 한계는 계정으로 받아들여지지 않는다는 것입니다.

이 함수의 실행결과는 캐시가 됩니다. 좀 더 자세한 내용을 알고 싶으면 clearstatcache() 를 보세요

참조is_writable().

이전 | 처음으로 | 다음
is_link | 위로 | is_uploaded_file


is_uploaded_file

(PHP 3>= 3.0.17, PHP 4 >= 4.0.3, PHP 5)

is_uploaded_file -- file이 HTTP POST를 통해 업로드된 것인지 아닌지 이야기하기

Description

bool is_uploaded_file ( string filename)

이 함수는 PHP 3 에서는 3.0.16 이후, PHP 4 에서는 4.0.2 이후 버전부터 사용이 가능합니다..

HTTP POST를 통해 업로드되어 파일의 이름이 filename에 의해 붙여진 것이면 TRUE를 반환합니다. 악의적인 사용자가 동작하지 말아야할 파일에서 동작하는 스크립트를 사용하려는 트릭을 쓰지 못하도록 하는데 유용합니다.--예를 들자면, /etc/passwd같은 것입니다.

업로드된 파일에 전혀 손대지 않고 사용자나 같은 시스템내의 다른 사람에게 조차도 업로드된 파일의 내용을 감출수가 있는 어떤 기회라도 있다면 이런식으로 체크하는것은 특히 중요합니다.

참조move_uploaded_file(), 그리고 단순한 사용예를 위해서 Handling file uploads부분

이전 | 처음으로 | 다음
is_readable | 위로 | is_writable


is_writable

(PHP 4 , PHP 5)

is_writable -- filename이 쓰기가능한 것인지 아닌지 이야기하기

Description

bool is_writable ( string filename)

filename이 존재하고 쓰기가능한 것이면 TRUE를 반환합니다. filename의 인수는 디렉토리가 쓰기가능한 것일때 디렉토리이름인지 체크할 수 있도록 합니다.

웹 서버가 'nobody' 등으로 실행이 될때 PHP는 사용자 아이디로 파일에 접근하려고 할 수 있다는 것을 명심하세요. 안전모드의 한계는 계정이 받아들여지지 않는다는 것입니다.

이 함수의 실행결과는 캐시가 됩니다. 좀 더 자세한 내용을 알고 싶으면 clearstatcache()를 보세요

참조is_readable().

이전 | 처음으로 | 다음
is_uploaded_file | 위로 | is_writeable


is_writeable

is_writeable -- Alias of is_writable()

Description

This function is an alias of is_writable().

이전 | 처음으로 | 다음
is_writable | 위로 | link


link

(PHP 3, PHP 4 , PHP 5)

link -- hard link 만들기

Description

int link ( string target, string link)

link() hard link를 만듭니다.

참조 symlink()soft links를 만듭니다. 그리고linkinfo()와 함께 수행되는readlink()

참고: 이 함수는 윈도우즈에서 동작하지 않습니다.

이전 | 처음으로 | 다음
is_writeable | 위로 | linkinfo


linkinfo

(PHP 3, PHP 4 , PHP 5)

linkinfo -- 링크 정보 가져오기

Description

int linkinfo ( string path)

linkinfo()는 마지막 시스템 호출에 의해서 반환이 되는 유닉스 C stat 구조체입니다. 이 함수는 링크(path에 의해 지정된)가 실제로 있는지 검증하는데 사용이 되곤 합니다. (stat.h에 매크로 정의된 S_ISLINK 와 같은 방법을 사용합니다.) This 0을 반환하거나 실패시 FALSE를 반환합니다.

참조symlink(), link(), 그리고readlink().

참고: 이 함수는 윈도우즈에서 동작하지 않습니다.

이전 | 처음으로 | 다음
link | 위로 | lstat


lstat

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

lstat -- 파일이나 심볼릭 링크에 관한 정보를 제공

Description

array lstat ( string filename)

Gathers the statistics of the file or symbolic link named by filename에 의해 이름이 붙은 파일이나 심볼릭 링크에 관한 통계자료를 모읍니다. 이 함수는 filename매개변수가 심볼릭 링크면 심볼릭 링크가 가리키는 파일의 상태가 아니라 심볼릭 링크의 상태가 반환되는 것을 제외하면 stat()함수와 같습니다.

파일의 통계자료가 아래와 같은 요소들로 배열로 반환됩니다:

  1. 장치(device)

  2. 아이노드(inode)

  3. 아이노드 보호 모드(inode protection mode)

  4. 링크의 갯수

  5. 소유자의 사용자 아이디

  6. 소유자의 그룹 아이디

  7. 아이노드 장치(inode device)라면 장치의 타입(device type) *

  8. 바이트단위의 크기

  9. 최종 접속 시간

  10. 최종 수정 시간

  11. 최종 변경 시간

  12. 파일시스템 입출력(filesystem I/O)시의 블록 크기 *

  13. 할당된 블록의 수

* - st_blksize type을 지원하는 시스템에만 유효합니다 -- 다른 시스템들(예를 들어 윈도우즈 같은) 시스템에서는 -1 을 반환합니다.

이 함수의 실행결과는 캐시가 됩니다. 좀 더 자세한 내용을 알고 싶다면 clearstatcache()을 보십시오.

이전 | 처음으로 | 다음
linkinfo | 위로 | mkdir


mkdir

(PHP 3, PHP 4 , PHP 5)

mkdir -- 디렉토리 만들기

Description

int mkdir ( string pathname, int mode)

pathname에 명기된 이름으로 디렉토리 만들기

모드를 명기하는데 8진수를 사용하려고 할 경우에 주의할 것은 앞에 0이 붙어야 한다는 것입니다.

mkdir ("/path/to/my/dir", 0700);

성공하면 TRUE, 실패하면 FALSE를 반환합니다.

참조rmdir().

이전 | 처음으로 | 다음
lstat | 위로 | move_uploaded_file


move_uploaded_file

(PHP 4 >= 4.0.3, PHP 5)

move_uploaded_file -- 업로드된 파일을 다른곳으로 이동하기

Description

bool move_uploaded_file ( string filename, string destination)

이 함수는 PHP 3 에서는 3.0.16 이후, PHP 4 에서는 4.0.2 이후 버전부터 사용할 수 있습니다.

이 함수는 filename에 의해서 지정된 파일이 PHP의 HTTP POST 파일 업로드 메카니즘을 통해서 업로드된 파일인지 확인합니다. 파일이 유효한 것일때 destination에 주어진 filename으로 이동이 됩니다

filename이 유효한 것이 아니면 아무 일도 발생하지 않습니다. 그리고 move_uploaded_file()는 FALSE를 반환합니다.

filename은 유효하나 어떤 이유가 있어서 이동할 수가 없을 때 아무런 일도 발생하지 않습니다. 그리고 move_uploaded_file()은 FALSE를 반환합니다. 덧붙여서 경고문이 보여집니다.

이런 체크방법은 파일의내용을 이용자, 같은 시스템내의 다른 사람에게 파일을 손대지 않고 파일의 내용을 감출 수 있는 어떤 기회가 있다면 특별히 더욱 중요합니다.

참조 is_uploaded_file(), 그리고 간단한 사용법 예를 위한 Handling file uploads부분.

이전 | 처음으로 | 다음
mkdir | 위로 | parse_ini_file


parse_ini_file

(PHP 4 , PHP 5)

parse_ini_file -- Parse a configuration file

Description

array parse_ini_file ( string filename [, bool process_sections])

parse_ini_file() loads in the ini file specified in filename, and returns the settings in it in an associative array. By setting the last process_sections parameter to TRUE, you get a multidimensional array, with the section names and settings included. The default for process_sections is FALSE

참고: This function has nothing to do with the php.ini file. It is already processed, the time you run your script. This function can be used to read in your own application's configuration files.

참고: If a value in the ini file contains any non-alphanumeric characters it needs to be enclosed in double-quotes (").

참고: Since PHP 4.2.1 this function is also affected by 안전 모드 and open_basedir.

참고: There are reserved words which must not be used as keys for ini files. These include: null, yes, no, true, and false.

The structure of the ini file is similar to that of the php.ini's.

Constants may also be parsed in the ini file so if you define a constant as an ini value before running parse_ini_file(), it will be integrated into the results. Only ini values are evaluated. For example:

예 1. Contents of sample.ini

; This is a sample configuration file
; Comments start with ';', as in php.ini

[first_section]
one = 1
five = 5
animal = BIRD

[second_section]
path = /usr/local/bin
URL = "http://www.example.com/~username"

예 2. parse_ini_file() example

<?php

define('BIRD', 'Dodo bird');

// Parse without sections
$ini_array = parse_ini_file("sample.ini");
print_r($ini_array);

// Parse with sections
$ini_array = parse_ini_file("sample.ini", true);
print_r($ini_array);

?>

Would produce:

Array
(
    [one] => 1
    [five] => 5
    [animal] => Dodo bird
    [path] => /usr/local/bin
    [URL] => http://www.example.com/~username
)
Array
(
    [first_section] => Array
        (
            [one] => 1
            [five] => 5
            [animal] = Dodo bird
        )

    [second_section] => Array
        (
            [path] => /usr/local/bin
            [URL] => http://www.example.com/~username
        )

)

이전 | 처음으로 | 다음
move_uploaded_file | 위로 | pathinfo


pathinfo

(PHP 4 >= 4.0.3, PHP 5)

pathinfo -- Returns information about a file path

Description

array pathinfo ( string path)

pathinfo() returns an associative array containing information about path. The following array elements are returned: dirname, basename and extension.

예 1. pathinfo() Example

<?php

$path_parts = pathinfo("/www/htdocs/index.html");

echo $path_parts["dirname"] . "\n";
echo $path_parts["basename"] . "\n";
echo $path_parts["extension"] . "\n";

?>

Would produce:

/www/htdocs
index.html
html

참고: For information on retrieving the current path info, read the section on predefined reserved variables.

See also dirname(),
basename(), parse_url()
and realpath().

이전 | 처음으로 | 다음
parse_ini_file | 위로 | pclose


pclose

(PHP 3, PHP 4 , PHP 5)

pclose -- 진행되는 파일 포인터 닫기

Description

int pclose ( int fp)

popen()에 의해 열려진 파일 포인터를 파이프로 닫기.

파일 포인터는 유효한 것이어야 하고 popen()으로 성공적으로 호출되어 반환된 것이어야 합니다.

실행된 프로세스의 결과통계를 반환합니다.

참조popen().

이전 | 처음으로 | 다음
pathinfo | 위로 | popen


popen

(PHP 3, PHP 4 , PHP 5)

popen -- 진행되는 파일 포인터를 열기

Description

int popen ( string command, string mode)

파이프를 주어진 명령으로 명령을 포크함으로 실행되는 프로세스로 열어줍니다.

fopen()에 의해 반환되는 파일 포인터와 같지만, 단방향(읽기나 쓰기 둘중에 하나만 사용할 수 있는)이고 pclose()로 닫혀야만 한다는 점이 다릅니다. 이 포인터는 fgets(), fgetss(), fputs()과 함께 사용할 수 있습니다.

에러가 발생하면 FALSE를 반환합니다.

$fp = popen ("/bin/ls", "r");

참조pclose().

이전 | 처음으로 | 다음
pclose | 위로 | readfile


readfile

(PHP 3, PHP 4 , PHP 5)

readfile -- 파일을 출력합니다

Description

int readfile ( string filename [, int use_include_path])

파일을 읽어서 일반출력으로 내보냅니다.

파일에서 읽은 바이트수를 반환합니다. 에러가 발생하면 FALSE를 반환하고 함수가 @readfile로 반환되지 않는 한 에러 메시지가 프린트 됩니다

filename이 "http://"로 시작이 되면 (자동반응이 아닌 경우에), HTTP 1.0 은 지정된 서버로 연결이 됩니다. 응답된 텍스트는 표준 출력으로 쓰여집니다.

디렉토리에 슬래쉬를 포함시켜서 HTTP가 리다이렉트 되지 않도록 하세요.

filename이 "ftp://"로 시작이 되면 (자동반응이 아닌 경우에), ftp는 지정된 서버로 연결이 되고 요청된 파일은 표준 출력으로 쓰여집니다. 서버가 Passive 모드를 지원하지 않으면 이것은 실행될 수 없습니다.

filename이 이와 같은 문자열로 시작이 되지 않는다면 파일이 파일 시스템에서 열리고 내용은 표준 출력으로 쓰여집니다.

include_path에서 파일을 찾고 싶으면 두번째 매개변수를 "1"로 설정할 수 도 있습니다.

참조fpassthru(), file(), fopen(), include(), require(), virtual().

이전 | 처음으로 | 다음
popen | 위로 | readlink


readlink

(PHP 3, PHP 4 , PHP 5)

readlink -- symbolic link의 target 반환

Description

string readlink ( string path)

readlink()는 C에서의 readlink 함수와 같은 일을 수행합니다. symbolic link의 경로를 반환하거나 실패시 0 을 반환합니다.

참조symlink(), readlink() 그리고linkinfo().

참고: 윈도우즈에서 동작하지 않습니다.

이전 | 처음으로 | 다음
readfile | 위로 | realpath


realpath

(PHP 4 , PHP 5)

realpath -- 표준화된 절대 경로명을 반환합니다

Description

string realpath ( string path)

realpath()는 path로 입력된 경로에서 모든 심볼릭 링크와 '/./', '/../'로 참조된 경로 그리고 그 외의 '/' 을 확장해서 표준화된 절대 경로명을 반환합니다. 이렇게 해서 나온 경로명은 심볼릭 일크와 '/./' 또는 '/../' 등을 포함하고 있지 않습니다.

예 1. realpath()예문

$real_path = realpath ("../../index.php");

이전 | 처음으로 | 다음
readlink | 위로 | rename


rename

(PHP 3, PHP 4 , PHP 5)

rename -- 파일을 새 이름으로 고치기

Description

int rename ( string oldname, string newname)

oldname을 newname으로 다시 이름 붙이고자 할 때.

성공하면 TRUE, 실패하면 FALSE를 반환합니다.

이전 | 처음으로 | 다음
realpath | 위로 | rewind


rewind

(PHP 3, PHP 4 , PHP 5)

rewind -- 파일포인터의 위치를 되돌립니다(rewind).

Description

int rewind ( int fp)

fp의 파일 위치 측정자를 파일 스트림의 시작부분에 위치하도록 설정합니다.

에러가 발생하면 0을 반환합니다.

파일 포인터는 유효한 것이어야 하고 fopen()에 의해 성공적으로 열려진 파일을 가리켜야 합니다.

참조fseek()그리고ftell().

이전 | 처음으로 | 다음
rename | 위로 | rmdir


rmdir

(PHP 3, PHP 4 , PHP 5)

rmdir -- 디렉토리 제거하기

Description

int rmdir ( string dirname)

pathname에 의해 이름이 붙은 디렉토리를 제거하려고 할때 디렉토리는 비어 있어야 하고 관련 퍼미션은 이것이 실행될 수 있도록 허가 되어 있어야 합니다 .

에러가 발생하면 0을 반환합니다.

참조: mkdir().

이전 | 처음으로 | 다음
rewind | 위로 | set_file_buffer


set_file_buffer

(PHP 3>= 3.0.8, PHP 4 >= 4.0.1, PHP 5)

set_file_buffer -- 주어진 파일 포인터에 파일 버퍼링 설정하기

Description

int set_file_buffer ( int fp, int buffer)

출력시에 사용되는fwrite()는 보통 8K로 버퍼링 됩니다. 이것은 하나의 파일에 같은 출력 스트림에 쓰려고 하는 두개의 프로세스가 존재한다면, 각각은 8K의 데이터를 버퍼에 저장한후 다른 하나가 쓸 수 있도록 잠시 멈춘다는 의미입니다. set_file_buffer()는 fp가 주어진 파일 포인터 상에 buffer바이트 버퍼링 쓰기작업을 수행할 수 있도록 설정합니다 만약에 buffer가 0 이면 쓰기작업은 버퍼에 저장되지 않습니다. 이것은fwrite()로 수행하는 모든 쓰기가 다른 프로세스에서 출력 스트림에 기록하려는 것을 허용하기 전에 완료되도록 합니다.

The function returns 0 on success, or EOF if the request cannot be honored.

아래의 예는 어떻게 set_file_buffer()를 사용해서 버퍼되지 않는 스트림을 만드는 지 보여줍니다.

예 1. set_file_buffer()예

$fp=fopen($file, "w");
if($fp){
  set_file_buffer($fp, 0);
  fputs($fp, $output);
  fclose($fp);
}

참조fopen(), fwrite().

이전 | 처음으로 | 다음
rmdir | 위로 | stat


stat

(PHP 3, PHP 4 , PHP 5)

stat -- file에 대한 정보 제공

Description

array stat ( string filename)

filename에 의해 이름이 붙은 파일에 대한 통계자료 모으기.

다음의 요소대로 파일에 대한 통계를 배열로 반환합니다.:

  1. 장치(device)

  2. 아이노드(inode)

  3. 아이노드 보호 모드(inode protection mode)

  4. 링크의 갯수

  5. 소유자의 사용자 아이디

  6. 소유자의 그룹 아이디

  7. 아이노드 장치(inode device)이면 장치 타입(device type) *

  8. 바이트 단위 크기

  9. 최종 접속 시간

  10. 최종 수정 시간

  11. 최종 변경 시간

  12. 파일시스템 입출력(filesystem I/O)시의 블록크기 *

  13. 할당된 블록의 수

* - st_blksize type을 지원하는 시스템에만 유효합니다--다른 시스템 (예를 들어 윈도우즈 같은)에서는 -1 을 반환합니다

이 함수의 실행결과는 캐시가 됩니다. 좀 더 자세한 내용을 알고 싶다면 clearstatcache()을 보십시오.

이전 | 처음으로 | 다음
set_file_buffer | 위로 | symlink


symlink

(PHP 3, PHP 4 , PHP 5)

symlink -- 심볼릭 링크 만들기

Description

int symlink ( string target, string link)

symlink()는 특정한 이름의 link로 있는 target에서 심볼릭 링크를 만듭니다.

참조 하드링크를 만드는link(), 그리고 linkinfo()와 같이 있는readlink().

참고: 이 함수는 윈도우즈에서는 동작하지 않습니다.

이전 | 처음으로 | 다음
stat | 위로 | tempnam


tempnam

(PHP 3, PHP 4 , PHP 5)

tempnam -- 유일한 파일 이름 만들기

Description

string tempnam ( string dir, string prefix)

특정 디렉토리에서 유일한 임시 파일이름을 만듭니다. 디렉토리가 존재하지 않으면 tempnam()은 시스템의 임시 디렉토리안에 파일 이름을 만듭니다.

tempnam()함수의 하는 일은 시스템 의존적입니다. 윈도우즈에서 TMP 환경변수는 dir매개변수를 뛰어넘고, 리눅스에서 TMPDIR 환경변수가 존재하고 있는 것을 가리키고 있다면 SVR4가 항상 dir 매개변수를 사용하려고 하는 동안에 앞서서 TMPDIR 환경변수가 실행됩니다. 미심쩍은 부분이 있다면 tempnam(3) 함수부분의 시스템 문서를 참고 하십시오.

새로운 임시 파일이름이나 널 문자열을 반환합니다.

예 1. tempnam()예문

$tmpfname = tempnam ("/tmp", "FOO");

참고: 이 함수는 4.0.3에서 동작이 변경되었습닏. 임시 파일은 문자열이 만들어지고 그 문자열이 파일을 생성하려고 하는 중간에 파일이 파일 시스템에 보여져야 하는 위치에서 진행상태를 나타내지 않습니다.

참조 tmpfile().

이전 | 처음으로 | 다음
symlink | 위로 | tmpfile


tmpfile

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

tmpfile -- 임시 파일 만들기

Description

int tmpfile ( void )

Creates a temporary file with an unique name in write mode, returning a file handle similar to the one returned by fopen()에 의해 반환된것과 비슷한 파일핸들을 반환하며 쓰기모드에서 유일한 임시파일을 생성합니다. 이 파일은 스크립트가 종료되거나 닫혔을때 (fclose()을 사용합니다) 자동으로 제거됩니다.

자세히 알아보려면 stdio.h 헤더파일 같은 tmpfile(3)함수의 시스템 문서를 살펴 보십시오

참조 tempnam().

이전 | 처음으로 | 다음
tempnam | 위로 | touch


touch

(PHP 3, PHP 4 , PHP 5)

touch -- 파일의 수정시간을 설정합니다

Description

int touch ( string filename [, int time])

filename 에 의해 이름붙여진 file의 수정시간을 주어진 시간으로 설정하려고 할때 사용합니다. 시간을 옵션으로 설정하지 않으면 현재 시간을 사용합니다.

파일이 존재하지 않으면 파일을 만듭니다.

성공하면 TRUE 를 반환하고 그렇지 않으면 FALSE를 반환합니다.

예 1. touch()예문

if (touch ($FileName)) {
    print "$FileName 은 오늘 날짜와 시간으로 변경되었습니다.";
} else {
    print "죄송합니다. $FileName의 수정시간을 바꾸지 못했습니다.";
}

이전 | 처음으로 | 다음
tmpfile | 위로 | umask


umask

(PHP 3, PHP 4 , PHP 5)

umask -- 현재의 umask를 변경하기

Description

int umask ( int mask)

umask()는 PHP의 umask를 mask & 0777로 바꾸고 이전의 umask를 반환합니다. PHP가 서버 모듈로 사용될 때 umask는 매 요청(request)가 끝날때 마다 저장이 됩니다.

인수가 없는 umask()는 단순히 현재의 umask를 반환합니다.

참고: 이 함수는 윈도우즈에서는 동작하지 않습니다.

이전 | 처음으로 | 다음
touch | 위로 | unlink


unlink

(PHP 3, PHP 4 , PHP 5)

unlink -- 파일을 삭제하기

Description

int unlink ( string filename)

filename을 삭제합니다. Unix C의 unlink() 함수와 비슷합니다.

0 이나 FALSE를 반환합니다.

참조 디렉토리를 제거하는데 rmdir()

참고: 이 함수는 윈도우즈에서는 동작하지 않습니다.

이전 | 처음으로 | 다음
umask | 위로 | Forms Data Format Functions


Forms Data Format Functions

PHP 매뉴얼
이전 다음

XXXI. Forms Data Format Functions

소개

Forms Data Format (FDF) is a format for handling forms within PDF documents. You should read the documentation at http://partners.adobe.com/asn/acrobat/forms.jsp for more information on what FDF is and how it is used in general.

The general idea of FDF is similar to HTML forms. The difference is basically the format how data is transmitted to the server when the submit button is pressed (this is actually the Form Data Format) and the format of the form itself (which is the Portable Document Format, PDF). Processing the FDF data is one of the features provided by the fdf functions. But there is more. One may as well take an existing PDF form and populated the input fields with data without modifying the form itself. In such a case one would create a FDF document (fdf_create()) set the values of each input field (fdf_set_value()) and associate it with a PDF form (fdf_set_file()). Finally it has to be sent to the browser with MimeType application/vnd.fdf. The Acrobat reader plugin of your browser recognizes the MimeType, reads the associated PDF form and fills in the data from the FDF document.

If you look at an FDF-document with a text editor you will find a catalogue object with the name FDF. Such an object may contain a number of entries like Fields, F, Status etc.. The most commonly used entries are Fields which points to a list of input fields, and F which contains the filename of the PDF-document this data belongs to. Those entries are referred to in the FDF documentation as /F-Key or /Status-Key. Modifying this entries is done by functions like fdf_set_file() and fdf_set_status(). Fields are modified with fdf_set_value(), fdf_set_opt() etc..

요구 사항

You need the FDF toolkit SDK available from http://partners.adobe.com/asn/acrobat/forms.jsp. As of PHP 4.3 you need at least SDK version 5.0. The FDF toolkit library is available in binary form only, platforms supported by Adobe are Win32, Linux, Solaris and AIX.

설치

You must compile PHP with --with-fdftk[=DIR].

참고: If you run into problems configuring PHP with fdftk support, check whether the header file fdftk.h and the library libfdftk.so are at the right place. The configure script supports both the directory structure of the FDF SDK distribution and the usual DIR/include / DIR/lib layout, so you can point it either directly to the unpacked distribution directory or put the header file and the appropriate library for your platform into e.g. /usr/local/include and /usr/local/lib and configure with --with-fdftk=/usr/local.

Note to Win32 Users: In order to enable this module on a Windows environment, you must copy fdftk.dll from the DLL folder of the PHP/Win32 binary package to the SYSTEM32 folder of your windows machine. (Ex: C:\WINNT\SYSTEM32 or C:\WINDOWS\SYSTEM32)

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

fdf

Most fdf functions require a fdf resource as their first parameter. A fdf resource is a handle to an opened fdf file. fdf resources may be obtained using fdf_create(), fdf_open() and fdf_open_string().

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

FDFValue (integer)

FDFStatus (integer)

FDFFile (integer)

FDFID (integer)

FDFFf (integer)

FDFSetFf (integer)

FDFClearFf (integer)

FDFFlags (integer)

FDFSetF (integer)

FDFClrF (integer)

FDFAP (integer)

FDFAS (integer)

FDFAction (integer)

FDFAA (integer)

FDFAPRef (integer)

FDFIF (integer)

FDFEnter (integer)

FDFExit (integer)

FDFDown (integer)

FDFUp (integer)

FDFFormat (integer)

FDFValidate (integer)

FDFKeystroke (integer)

FDFCalculate (integer)

FDFNormalAP (integer)

FDFRolloverAP (integer)

FDFDownAP (integer)

예제

The following examples shows just the evaluation of form data.

예 1. Evaluating a FDF document

<?php
// Open fdf from input string provided by the extension
// The pdf form contained several input text fields with the names
// volume, date, comment, publisher, preparer, and two checkboxes
// show_publisher and show_preparer.
$fdf = fdf_open_string($HTTP_FDF_DATA);
$volume = fdf_get_value($fdf, "volume");
echo "The volume field has the value '<b>$volume</b>'<br />";

$date = fdf_get_value($fdf, "date");
echo "The date field has the value '<b>$date</b>'<br />";

$comment = fdf_get_value($fdf, "comment");
echo "The comment field has the value '<b>$comment</b>'<br />";

if (fdf_get_value($fdf, "show_publisher") == "On") {
  $publisher = fdf_get_value($fdf, "publisher");
  echo "The publisher field has the value '<b>$publisher</b>'<br />";
} else
  echo "Publisher shall not be shown.<br />";

if (fdf_get_value($fdf, "show_preparer") == "On") {
  $preparer = fdf_get_value($fdf, "preparer");
  echo "The preparer field has the value '<b>$preparer</b>'<br />";
} else
  echo "Preparer shall not be shown.<br />";
fdf_close($fdf);
?>

차례
fdf_add_doc_javascript -- Adds javascript code to the FDF document
fdf_add_template -- Adds a template into the FDF document
fdf_close -- Close an FDF document
fdf_create -- Create a new FDF document
fdf_enum_values -- Call a user defined function for each document value
fdf_errno -- Return error code for last fdf operation
fdf_error -- Return error description for fdf error code
fdf_get_ap -- Get the appearance of a field
fdf_get_attachment -- Extracts uploaded file embedded in the FDF
fdf_get_encoding -- Get the value of the /Encoding key
fdf_get_file -- Get the value of the /F key
fdf_get_flags -- Gets the flags of a field
fdf_get_opt -- Gets a value from the opt array of a field
fdf_get_status -- Get the value of the /STATUS key
fdf_get_value -- Get the value of a field
fdf_get_version -- Gets version number for FDF API or file
fdf_header -- Sets FDF-specific output headers
fdf_next_field_name -- Get the next field name
fdf_open_string -- Read a FDF document from a string
fdf_open -- Open a FDF document
fdf_remove_item -- Sets target frame for form
fdf_save_string -- Returns the FDF document as a string
fdf_save -- Save a FDF document
fdf_set_ap -- Set the appearance of a field
fdf_set_encoding -- Sets FDF character encoding
fdf_set_file -- Set PDF document to display FDF data in
fdf_set_flags -- Sets a flag of a field
fdf_set_javascript_action -- Sets an javascript action of a field
fdf_set_opt -- Sets an option of a field
fdf_set_status -- Set the value of the /STATUS key
fdf_set_submit_form_action -- Sets a submit form action of a field
fdf_set_target_frame -- Set target frame for form display
fdf_set_value -- Set the value of a field
fdf_set_version -- Sets version number for a FDF file

이전 | 처음으로 | 다음
unlink | 위로 | fdf_add_doc_javascript


fdf_add_doc_javascript

(PHP 4 >= 4.3.0, PHP 5)

fdf_add_doc_javascript -- Adds javascript code to the FDF document

Description

bool fdf_add_doc_javascript ( resource fdfdoc, string script_name, string script_code)

Adds a script to the FDF, which Acrobat then adds to the doc-level scripts of a document, once the FDF is imported into it. It is strongly suggested to use '\r' for linebreaks within script_code.

예 1. Adding JavaScript code to a FDF

<?php
$fdf = fdf_create();
fdf_add_doc_javascript($fdf, "PlusOne", "function PlusOne(x)\r{\r  return x+1;\r}\r");
fdf_save($fdf);
?>

will create a FDF like this:

%FDF-1.2
%????
1 0 obj
<<
/FDF << /JavaScript << /Doc [ (PlusOne)(function PlusOne\(x\)\r{\r  return x+1;\r}\r)] >> >>
>>
endobj
trailer
<<
/Root 1 0 R

>>
%%EOF

이전 | 처음으로 | 다음
Forms Data Format Functions | 위로 | fdf_add_template


fdf_add_template

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

fdf_add_template -- Adds a template into the FDF document

Description

bool fdf_add_template ( resource fdfdoc, int newpage, string filename, string template, int rename)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
fdf_add_doc_javascript | 위로 | fdf_close


fdf_close

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

fdf_close -- Close an FDF document

Description

bool fdf_close ( resource fdf_document)

The fdf_close() function closes the FDF document.

See also fdf_open().

이전 | 처음으로 | 다음
fdf_add_template | 위로 | fdf_create


fdf_create

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

fdf_create -- Create a new FDF document

Description

resource fdf_create ( void )

The fdf_create() creates a new FDF document. This function is needed if one would like to populate input fields in a PDF document with data.

예 1. Populating a PDF document

<?php
$outfdf = fdf_create();
fdf_set_value($outfdf, "volume", $volume, 0);

fdf_set_file($outfdf, "http:/testfdf/resultlabel.pdf");
fdf_save($outfdf, "outtest.fdf");
fdf_close($outfdf);
Header("Content-type: application/vnd.fdf");
$fp = fopen("outtest.fdf", "r");
fpassthru($fp);
unlink("outtest.fdf");
?>

See also fdf_close(),
         fdf_save(),
         fdf_open().

이전 | 처음으로 | 다음
fdf_close | 위로 | fdf_enum_values


fdf_enum_values

(PHP 4 >= 4.3.0, PHP 5)

fdf_enum_values -- Call a user defined function for each document value

Description

bool fdf_enum_values ( resource fdfdoc, callback function [, mixed userdata])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
fdf_create | 위로 | fdf_errno


fdf_errno

(PHP 4 >= 4.3.0, PHP 5)

fdf_errno -- Return error code for last fdf operation

Description

int fdf_errno ( void )

fdf_errno() returns the error code set by the last fdf_...() function call. This is zero for a successfull operation or a non-zero error code on failure. A textual description may be obtained using the fdf_error() function.

See also fdf_error().

이전 | 처음으로 | 다음
fdf_enum_values | 위로 | fdf_error


fdf_error

(PHP 4 >= 4.3.0, PHP 5)

fdf_error -- Return error description for fdf error code

Description

string fdf_error ( [int error_code])

fdf_error() returns a textual description for the fdf error code given in error_code. The function uses the internal error code set by the last operation if no error_code is given, so fdf_error() is a convenient shortcut for fdf_error(fdf_errno()).

See also fdf_errno().

이전 | 처음으로 | 다음
fdf_errno | 위로 | fdf_get_ap


fdf_get_ap

(PHP 4 >= 4.3.0, PHP 5)

fdf_get_ap -- Get the appearance of a field

Description

bool fdf_get_ap ( resource fdf_document, string field, int face, string filename)

The fdf_get_ap() function gets the appearance of a field (i.e. the value of the /AP key) and stores it in a file. The possible values of face are FDFNormalAP, FDFRolloverAP and FDFDownAP. The appearance is stored in filename.

이전 | 처음으로 | 다음
fdf_error | 위로 | fdf_get_attachment


fdf_get_attachment

(PHP 4 >= 4.3.0, PHP 5)

fdf_get_attachment -- Extracts uploaded file embedded in the FDF

Description

array fdf_get_attachment ( resource fdf_document, string fieldname, string savepath)

Extracts a file uploaded by means of the "file selection" field fieldname and stores it under savepath. savepath may be the name of a plain file or an existing directory in which the file is to be created under its original name. Any existing file under the same name will be overwritten.

참고: There seems to be no other way to find out the original filename but to store the file using a directory as savepath and check for the basename it was stored under.

The returned array contains the following fields:

  • path - path were the file got stored

    size - size of the stored file in bytes

    type - mimetype if given in the FDF

예 1. Storing an uploaded file

<?php
  $fdf = fdf_open_string($HTTP_FDF_DATA);
  $data = fdf_get_attachment($fdf, "filename", "/tmpdir");
  echo "The uploaded file is stored in $data[path]";
?>

이전 | 처음으로 | 다음
fdf_get_ap | 위로 | fdf_get_encoding


fdf_get_encoding

(PHP 4 >= 4.3.0, PHP 5)

fdf_get_encoding -- Get the value of the /Encoding key

Description

string fdf_get_encoding ( resource fdf_document)

The fdf_get_encoding() returns the value of the /Encoding key. An empty string is returned if the default PDFDocEncoding/Unicode scheme is used.

See also fdf_set_encoding().

이전 | 처음으로 | 다음
fdf_get_attachment | 위로 | fdf_get_file


fdf_get_file

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

fdf_get_file -- Get the value of the /F key

Description

string fdf_get_file ( resource fdf_document)

The fdf_set_file() returns the value of the /F key.

See also fdf_set_file().

이전 | 처음으로 | 다음
fdf_get_encoding | 위로 | fdf_get_flags


fdf_get_flags

(PHP 4 >= 4.3.0, PHP 5)

fdf_get_flags -- Gets the flags of a field

Description

fdf_get_flags ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
fdf_get_file | 위로 | fdf_get_opt


fdf_get_opt

(PHP 4 >= 4.3.0, PHP 5)

fdf_get_opt -- Gets a value from the opt array of a field

Description

mixed fdf_get_opt ( resource fdfdof, string fieldname [, int element])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
fdf_get_flags | 위로 | fdf_get_status


fdf_get_status

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

fdf_get_status -- Get the value of the /STATUS key

Description

string fdf_get_status ( resource fdf_document)

The fdf_get_status() returns the value of the /STATUS key.

See also fdf_set_status().

이전 | 처음으로 | 다음
fdf_get_opt | 위로 | fdf_get_value


fdf_get_value

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

fdf_get_value -- Get the value of a field

Description

string fdf_get_value ( resource fdf_document, string fieldname [, int which])

The fdf_get_value() function returns the value for the requested fieldname.

Elements of an array field can be retrieved by passing the optional which, starting at zero. For non-array fields the optional parameter which will be ignored.

참고: Array support and optional which parameter were added in PHP 4.3.

See also fdf_set_value().

이전 | 처음으로 | 다음
fdf_get_status | 위로 | fdf_get_version


fdf_get_version

(PHP 4 >= 4.3.0, PHP 5)

fdf_get_version -- Gets version number for FDF API or file

Description

string fdf_get_version ( [resource fdf_document])

This function will return the fdf version for the given fdf_document, or the toolkit API version number if no parameter is given.

For the current FDF toolkit 5.0 the API version number is '5.0' and the document version number is either '1.2', '1.3' or '1.4'.

See also fdf_set_version().

이전 | 처음으로 | 다음
fdf_get_value | 위로 | fdf_header


fdf_header

(PHP 4 >= 4.3.0, PHP 5)

fdf_header -- Sets FDF-specific output headers

Description

bool fdf_header ( void )

This is a convenience function to set appropriate HTTP headers for FDF output. It sets the Content-type: to application/vnd.fdf.

이전 | 처음으로 | 다음
fdf_get_version | 위로 | fdf_next_field_name


fdf_next_field_name

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

fdf_next_field_name -- Get the next field name

Description

string fdf_next_field_name ( resource fdf_document [, string fieldname])

The fdf_next_field_name() function returns the name of the field after the field in fieldname or the field name of the first field if the second parameter is NULL.

예 1. Detecting all fieldnames in a FDF

<?php
$fdf = fdf_open($HTTP_FDF_DATA);
for ($field = fdf_next_field_name($fdf);
    $field != "";
    $field = fdf_next_field_name($fdf, $field)) {
  echo "field: $field\n";
}
?>

See also fdf_enum_fields() and fdf_get_value().

이전 | 처음으로 | 다음
fdf_header | 위로 | fdf_open_string


fdf_open_string

(PHP 4 >= 4.3.0, PHP 5)

fdf_open_string -- Read a FDF document from a string

Description

resource fdf_open_string ( string fdf_data)

The fdf_open_string() function reads form data from a string. fdf_data must contain the data as returned from a PDF form or created using fdf_create() and fdf_save_string().

You can fdf_open_string() together with $HTTP_FDF_DATA to process fdf form input from a remote client.

예 1. Accessing the form data

<?php
$fdf = fdf_open_string($HTTP_FDF_DATA);
/* ... */
fdf_close($fdf);
?>

See also
fdf_open(),
fdf_close(),
fdf_create() and
fdf_save_string().

이전 | 처음으로 | 다음
fdf_next_field_name | 위로 | fdf_open


fdf_open

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

fdf_open -- Open a FDF document

Description

resource fdf_open ( string filename)

The fdf_open() function opens a file with form data. This file must contain the data as returned from a PDF form or created using fdf_create() and fdf_save().

You can process the results of a PDF form POST request by writing the data received in $HTTP_FDF_DATA to a file and open it using fdf_open(). Starting with PHP 4.3 you can also use fdf_open_string() which handles temporary file creation and cleanup for you.

예 1. Accessing the form data

<?php
// Save the FDF data into a temp file
$fdffp = fopen("test.fdf", "w");
fwrite($fdffp, $HTTP_FDF_DATA, strlen($HTTP_FDF_DATA));
fclose($fdffp);

// Open temp file and evaluate data
$fdf = fdf_open("test.fdf");
/* ... */
fdf_close($fdf);
?>

See also
fdf_open_string(),
fdf_close(),
fdf_create() and
fdf_save().

이전 | 처음으로 | 다음
fdf_open_string | 위로 | fdf_remove_item


fdf_remove_item

(PHP 4 >= 4.3.0, PHP 5)

fdf_remove_item -- Sets target frame for form

Description

bool fdf_remove_item ( resource fdfdoc, string fieldname, int item)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
fdf_open | 위로 | fdf_save_string


fdf_save_string

(PHP 4 >= 4.3.0, PHP 5)

fdf_save_string -- Returns the FDF document as a string

Description

string fdf_save_string ( resource fdf_document)

The fdf_save_string() function returns the FDF document as a string.

예 1. Retrieving FDF as a string

<?php
$fdf = fdf_create();
fdf_set_value($fdf, "foo", "bar");
$str = fdf_save_string($fdf);
fdf_close($fdf);
echo $str;
?>

will output something like

%FDF-1.2
%????
1 0 obj
<<
/FDF << /Fields 2 0 R >>
>>
endobj
2 0 obj
[
<< /T (foo)/V (bar)>>
]
endobj
trailer
<<
/Root 1 0 R

>>
%%EOF

See also fdf_save(),
fdf_open_string(),
fdf_create() and
fdf_close().

이전 | 처음으로 | 다음
fdf_remove_item | 위로 | fdf_save


fdf_save

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

fdf_save -- Save a FDF document

Description

bool fdf_save ( resource fdf_document [, string filename])

The fdf_save() function saves a FDF document. The resulting FDF will be written to filename. Without a filename fdf_save() will write the FDF to the default PHP output stream.

See also fdf_save_string(),
fdf_create() and
fdf_close().

이전 | 처음으로 | 다음
fdf_save_string | 위로 | fdf_set_ap


fdf_set_ap

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

fdf_set_ap -- Set the appearance of a field

Description

bool fdf_set_ap ( resource fdf_document, string field_name, int face, string filename, int page_number)

The fdf_set_ap() function sets the appearance of a field (i.e. the value of the /AP key). The possible values of face are FDFNormalAP, FDFRolloverAP and FDFDownAP.

이전 | 처음으로 | 다음
fdf_save | 위로 | fdf_set_encoding


fdf_set_encoding

(PHP 4 >= 4.1.0, PHP 5)

fdf_set_encoding -- Sets FDF character encoding

Description

bool fdf_set_encoding ( resource fdf_document, string encoding)

fdf_set_encoding() sets the character encoding in FDF document fdf_document. encoding should be the valid encoding name. Currently the following values are supported: "Shift-JIS", "UHC", "GBK","BigFive". An empty string resets the encoding to the default PDFDocEncoding/Unicode scheme.

이전 | 처음으로 | 다음
fdf_set_ap | 위로 | fdf_set_file


fdf_set_file

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

fdf_set_file -- Set PDF document to display FDF data in

Description

bool fdf_set_file ( resource fdf_document, string url [, string target_frame])

The fdf_set_file() selects a different PDF document to display the form results in then the form it originated from. The url needs to be given as an absolute URL.

The frame to display the document in may be selected using the optional parameter target_frame or the function fdf_set_target_frame().

예 1. Passing FDF data to a second form

<?php
  /* set content type for Adobe FDF */
  fdf_header();

  /* start new fdf */
  $fdf = fdf_create();

  /* set field "foo" to value "bar" */
  $fdf_set_value($fdf, "foo", "bar");

  /* tell client to display FDF data using "fdf_form.pdf" */
  fdf_set_file($fdf, "http://www.example.com/fdf_form.pdf");

  /* output fdf */
  fdf_save();

  /* clean up */
  fdf_close();
?>

See also fdf_get_file() and fdf_set_target_frame().

이전 | 처음으로 | 다음
fdf_set_encoding | 위로 | fdf_set_flags


fdf_set_flags

(PHP 4 >= 4.0.2, PHP 5)

fdf_set_flags -- Sets a flag of a field

Description

bool fdf_set_flags ( resource fdf_document, string fieldname, int whichFlags, int newFlags)

The fdf_set_flags() sets certain flags of the given field fieldname.

See also fdf_set_opt().

이전 | 처음으로 | 다음
fdf_set_file | 위로 | fdf_set_javascript_action


fdf_set_javascript_action

(PHP 4 >= 4.0.2, PHP 5)

fdf_set_javascript_action -- Sets an javascript action of a field

Description

bool fdf_set_javascript_action ( resource fdf_document, string fieldname, int trigger, string script)

fdf_set_javascript_action() sets a javascript action for the given field fieldname.

See also fdf_set_submit_form_action().

이전 | 처음으로 | 다음
fdf_set_flags | 위로 | fdf_set_opt


fdf_set_opt

(PHP 4 >= 4.0.2, PHP 5)

fdf_set_opt -- Sets an option of a field

Description

bool fdf_set_opt ( resource fdf_document, string fieldname, int element, string str1, string str2)

The fdf_set_opt() sets options of the given field fieldname.

See also fdf_set_flags().

이전 | 처음으로 | 다음
fdf_set_javascript_action | 위로 | fdf_set_status


fdf_set_status

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

fdf_set_status -- Set the value of the /STATUS key

Description

bool fdf_set_status ( resource fdf_document, string status)

The fdf_set_status() sets the value of the /STATUS key. When a client receives a FDF with a status set it will present the value in an alert box.

See also fdf_get_status().

이전 | 처음으로 | 다음
fdf_set_opt | 위로 | fdf_set_submit_form_action


fdf_set_submit_form_action

(PHP 4 >= 4.0.2, PHP 5)

fdf_set_submit_form_action -- Sets a submit form action of a field

Description

bool fdf_set_submit_form_action ( resource fdf_document, string fieldname, int trigger, string script, int flags)

The fdf_set_submit_form_action() sets a submit form action for the given field fieldname.

See also fdf_set_javascript_action().

이전 | 처음으로 | 다음
fdf_set_status | 위로 | fdf_set_target_frame


fdf_set_target_frame

(PHP 4 >= 4.3.0, PHP 5)

fdf_set_target_frame -- Set target frame for form display

Description

bool fdf_set_target_frame ( resource fdf_document, string frame_name)

Sets the target frame to display a result PDF defined with fdf_save_file() in.

See also fdf_save_file().

이전 | 처음으로 | 다음
fdf_set_submit_form_action | 위로 | fdf_set_value


fdf_set_value

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

fdf_set_value -- Set the value of a field

Description

bool fdf_set_value ( resource fdf_document, string fieldname, mixed value [, int isName])

The fdf_set_value() function sets the value for a field named fieldname. The value will be stored as a string unless it is an array. In this case all array elements will be stored as a value array.

참고: In older versions of the fdf toolkit last parameter determined if the field value was to be converted to a PDF Name (isName = 1) or set to a PDF String (isName = 0). The value is no longer used in the current toolkit version 5.0. For compatibility reasons it is still supported as an optional parameter beginning with PHP 4.3, but ignored internally.

Support for value arrays was added in PHP 4.3.

See also fdf_get_value() and fdf_remove_item().

이전 | 처음으로 | 다음
fdf_set_target_frame | 위로 | fdf_set_version


fdf_set_version

(PHP 4 >= 4.3.0, PHP 5)

fdf_set_version -- Sets version number for a FDF file

Description

string fdf_set_version ( resource fdf_document, string version)

This function will set the fdf version for the given fdf_document. Some features supported by this extension are only available in newer fdf versions. For the current FDF toolkit 5.0 version may be either '1.2', '1.3' or '1.4'.

See also fdf_get_version().

이전 | 처음으로 | 다음
fdf_set_value | 위로 | FriBiDi Functions


FriBiDi Functions

PHP 매뉴얼
이전 다음

XXXII. FriBiDi Functions

소개

FriBiDi is a free implementation of the Unicode Bidirectional Algorithm.

요구 사항

You must download and install the FriBiDi package.

설치

To enable FriBiDi support in PHP you must compile --with-fribidi[=DIR] where DIR is the FriBiDi install directory.

런타임 설정

리소스 종류

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

FRIBIDI_CHARSET_UTF8 (integer)

FRIBIDI_CHARSET_8859_6 (integer)

FRIBIDI_CHARSET_8859_8 (integer)

FRIBIDI_CHARSET_CP1255 (integer)

FRIBIDI_CHARSET_CP1256 (integer)

FRIBIDI_CHARSET_ISIRI_3342 (integer)

차례
fribidi_log2vis -- Convert a logical string to a visual one

이전 | 처음으로 | 다음
fdf_set_version | 위로 | fribidi_log2vis


fribidi_log2vis

(PHP 4 >= 4.0.4)

fribidi_log2vis -- Convert a logical string to a visual one

Description

string fribidi_log2vis ( string str, string direction, int charset)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
FriBiDi Functions | 위로 | FTP Functions


FTP Functions

PHP 매뉴얼
이전 다음

XXXIII. FTP Functions

소개

The functions in this extension implement client access to file servers speaking the File Transfer Protocol (FTP) as defined in http://www.faqs.org/rfcs/rfc959. This extension is meant for detailed access to an FTP server providing a wide range of control to the executing script. If you only wish to read from or write to a file on an FTP server, consider using the ftp:// wrapper with the filesystem functions which provide a simpler and more intuitive interface.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

In order to use FTP functions with your PHP configuration, you should add the --enable-ftp option when installing PHP 4 or --with-ftp when using PHP 3.

PHP 윈도우 버전에서는 이 확장 모듈에 대한 지원이 포함되어 있습니다. 이 함수들을 이용하기 위해서 추가로 확장 모듈을 읽어들일 필요가 없습니다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

This extension uses one resource type, which is the link identifier of the FTP connection, returned by ftp_connect().

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

FTP_ASCII (integer)

FTP_TEXT (integer)

FTP_BINARY (integer)

FTP_IMAGE (integer)

FTP_TIMEOUT_SEC (integer)

See ftp_set_option() for information.

The following constants were introduced in PHP 4.3.0.

FTP_AUTOSEEK (integer)

See ftp_set_option() for information.

FTP_AUTORESUME (integer)

Automatically determine resume position and start position for GET and PUT requests (only works if FTP_AUTOSEEK is enabled)

FTP_FAILED (integer)

Asynchronous transfer has failed

FTP_FINISHED (integer)

Asynchronous transfer has finished

FTP_MOREDATA (integer)

Asynchronous transfer is still active

예제

예 1. FTP example

<?php
// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// check connection
if ((!$conn_id) || (!$login_result)) {
        echo "FTP connection has failed!";
        echo "Attempted to connect to $ftp_server for user $ftp_user_name";
        exit;
    } else {
        echo "Connected to $ftp_server, for user $ftp_user_name";
    }

// upload the file
$upload = ftp_put($conn_id, $destination_file, $source_file, FTP_BINARY);

// check upload status
if (!$upload) {
        echo "FTP upload has failed!";
    } else {
        echo "Uploaded $source_file to $ftp_server as $destination_file";
    }

// close the FTP stream
ftp_close($conn_id);
?>

차례
ftp_alloc -- Allocates space for a file to be uploaded.
ftp_cdup -- Changes to the parent directory
ftp_chdir -- Changes directories on a FTP server
ftp_chmod -- Set permissions on a file via FTP
ftp_close -- Closes an FTP connection
ftp_connect -- Opens an FTP connection
ftp_delete -- Deletes a file on the FTP server
ftp_exec -- Requests execution of a program on the FTP server
ftp_fget -- Downloads a file from the FTP server and saves to an open file
ftp_fput -- Uploads from an open file to the FTP server
ftp_get_option -- Retrieves various runtime behaviours of the current FTP stream
ftp_get -- Downloads a file from the FTP server
ftp_login -- Logs in to an FTP connection
ftp_mdtm -- Returns the last modified time of the given file
ftp_mkdir -- Creates a directory
ftp_nb_continue -- Continues retrieving/sending a file (non-blocking)
ftp_nb_fget -- Retrieves a file from the FTP server and writes it to an open file (non-blocking)
ftp_nb_fput -- Stores a file from an open file to the FTP server (non-blocking)
ftp_nb_get -- Retrieves a file from the FTP server and writes it to a local file (non-blocking)
ftp_nb_put -- Stores a file on the FTP server (non-blocking)
ftp_nlist -- Returns a list of files in the given directory
ftp_pasv -- Turns passive mode on or off
ftp_put -- Uploads a file to the FTP server
ftp_pwd -- Returns the current directory name
ftp_quit -- Alias of ftp_close()
ftp_raw -- Sends an arbitrary command to an FTP server
ftp_rawlist -- Returns a detailed list of files in the given directory
ftp_rename -- Renames a file on the FTP server
ftp_rmdir -- Removes a directory
ftp_set_option -- Set miscellaneous runtime FTP options
ftp_site -- Sends a SITE command to the server
ftp_size -- Returns the size of the given file
ftp_ssl_connect -- Opens an Secure SSL-FTP connection
ftp_systype -- Returns the system type identifier of the remote FTP server

이전 | 처음으로 | 다음
fribidi_log2vis | 위로 | ftp_alloc


ftp_alloc

(PHP 5)

ftp_alloc -- Allocates space for a file to be uploaded.

Description

bool ftp_alloc ( resource ftp_stream, int filesize [, string &result])

Sends an ALLO command to the remote FTP server to allocate filesize bytes of space. Returns TRUE on success, or FALSE on failure.

참고: Many FTP servers do not support this command. These servers may return a failure code (FALSE) indicating the command is not supported or a success code (TRUE) to indicate that pre-allocation is not necessary and the client should continue as though the operation were successful. Because of this, it may be best to reserve this function for servers which explicitly require preallocation.

A textual representation of the servers response will be returned by reference in result is a variable is provided.

예 1. ftp_alloc() example

<?php

$file = "/home/user/myfile";

/* connect to the server */
$conn_id = ftp_connect('ftp.example.com');
$login_result = ftp_login($conn_id, 'anonymous', 'user@example.com');

if (ftp_alloc($conn_id, filesize($file), $result)) {
  echo "Space successfully allocated on server.  Sending $file.\n";
  ftp_put($conn_id, '/incomming/myfile', $file, FTP_BINARY);
} else {
  echo "Unable to allocate space on server.  Server said: $result\n";
}

ftp_close($conn_id);

?>

See also: ftp_put(), and ftp_fput().

이전 | 처음으로 | 다음
FTP Functions | 위로 | ftp_cdup


ftp_cdup

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_cdup -- Changes to the parent directory

Description

bool ftp_cdup ( resource ftp_stream)

Changes to the parent directory.

예 1. ftp_cdup() example

<?php
// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// change the current directory to html
ftp_chdir($conn_id, 'html');

echo ftp_pwd($conn_id); // /html

// return to the parent directory
if (ftp_cdup($conn_id)) {
  echo "cdup successful\n";
} else {
  echo "cdup not successful\n";
}

echo ftp_pwd($conn_id); // /

ftp_close($conn_id);
?>

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also ftp_chdir().

이전 | 처음으로 | 다음
ftp_alloc | 위로 | ftp_chdir


ftp_chdir

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_chdir -- Changes directories on a FTP server

Description

bool ftp_chdir ( resource ftp_stream, string directory)

Changes the current directory to the specified directory.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. ftp_chdir() example

<?php

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// check connection
if ((!$conn_id) || (!$login_result)) {
    die("FTP connection has failed !");
}

echo "Current directory: " . ftp_pwd($conn_id) . "\n";

// try to change the directory to somedir
if (ftp_chdir($conn_id, "somedir")) {
    echo "Current directory is now: " . ftp_pwd($conn_id) . "\n";
} else {
    echo "Couldn't change directory\n";
}

// close the connection
ftp_close($conn_id);
?>

See also ftp_cdup().

이전 | 처음으로 | 다음
ftp_cdup | 위로 | ftp_chmod


ftp_chmod

(PHP 5)

ftp_chmod -- Set permissions on a file via FTP

Description

string ftp_chmod ( resource ftp_stream, int mode, string filename)

Sets the permissions on the remote file specified by filename to mode given as an octal value.

예 1. ftp_chmod() example

<?php
$file = 'public_html/index.php';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to chmod $file to 644
if (ftp_chmod($conn_id, 0644, $file)) {
echo "$file cdmoded successfully to 644\n";
} else {
echo "could not chmod $file\n";
}

// close the connection
ftp_close($conn_id);
?>

Returns the new file permissions on success or FALSE on error.

See also chmod().

이전 | 처음으로 | 다음
ftp_chdir | 위로 | ftp_close


ftp_close

(PHP 4 >= 4.2.0, PHP 5)

ftp_close -- Closes an FTP connection

Description

void ftp_close ( resource ftp_stream)

ftp_close() closes ftp_stream and releases the resource. After calling this function, you can no longer use the FTP connection and must create a new one with ftp_connect().

예 1. ftp_close() example

<?php

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// print the current directory
echo ftp_pwd($conn_id); // /

// close this connection
ftp_close($conn_id);
?>

See also ftp_connect()

이전 | 처음으로 | 다음
ftp_chmod | 위로 | ftp_connect


ftp_connect

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_connect -- Opens an FTP connection

Description

resource ftp_connect ( string host [, int port [, int timeout]])

Returns a FTP stream on success or FALSE on error.

ftp_connect() opens an FTP connection to the specified host. host shouldn't have any trailing slashes and shouldn't be prefixed with ftp://. The port parameter specifies an alternate port to connect to. If it is omitted or set to zero, then the default FTP port, 21, will be used.

The timeout parameter specifies the timeout for all subsequent network operations. If omitted, the default value is 90 seconds. The timeout can be changed and queried at any time with ftp_set_option() and ftp_get_option().

참고: The timeout parameter became available in PHP 4.2.0.

예 1. ftp_connect() example

<?php

$ftp_server = "ftp.example.com";

// set up a connection or die
$conn_id = ftp_connect($ftp_server) or die("Couldn't connect to $ftp_server");

?>

See also ftp_close(), and ftp_ssl_connect().

이전 | 처음으로 | 다음
ftp_close | 위로 | ftp_delete


ftp_delete

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_delete -- Deletes a file on the FTP server

Description

bool ftp_delete ( resource ftp_stream, string path)

ftp_delete() deletes the file specified by path from the FTP server.

예 1. ftp_delete() example

<?php
$file = 'public_html/old.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to delete $file
if (ftp_delete($conn_id, $file)) {
echo "$file deleted successful\n";
} else {
echo "could not delete $file\n";
}

// close the connection
ftp_close($conn_id);
?>

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ftp_connect | 위로 | ftp_exec


ftp_exec

(PHP 4 >= 4.0.3, PHP 5)

ftp_exec -- Requests execution of a program on the FTP server

Description

bool ftp_exec ( resource ftp_stream, string command)

Sends a SITE EXEC command request to the FTP server. Returns TRUE if the command was successful (server sent response code: 200); otherwise returns FALSE.

예 1. ftp_exec() example

<?php

$command = 'ls -al';

$conn_id = ftp_connect($ftp_server);

$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

if ($res = ftp_exec($conn_id, $command)) {
    echo "$command executed successfully<br />\n";
    echo nl2br($res);
} else {
    echo 'could not execute ' . $command;
}

?>

See also ftp_raw().

이전 | 처음으로 | 다음
ftp_delete | 위로 | ftp_fget


ftp_fget

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_fget -- Downloads a file from the FTP server and saves to an open file

Description

bool ftp_fget ( resource ftp_stream, resource handle, string remote_file, int mode [, int resumepos])

ftp_fget() retrieves remote_file from the FTP server, and writes it to the given file pointer, handle. The transfer mode specified must be either FTP_ASCII or FTP_BINARY.

예 1. ftp_fget() example

<?php

// open some file for reading
$file = 'somefile.txt';
$fp = fopen($file, 'w');

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to download $file
if (ftp_fget($conn_id, $fp, $file, FTP_ASCII, 1)) {
echo "successfully written to $file\n";
} else {
echo "There was a problem with $file\n";
}

// close the connection and the file handler
ftp_close($conn_id);
fclose($fp);
?>

참고: The resumepos parameter was added in PHP 4.3.0.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also ftp_get(), ftp_nb_get() and ftp_nb_fget().

이전 | 처음으로 | 다음
ftp_exec | 위로 | ftp_fput


ftp_fput

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_fput -- Uploads from an open file to the FTP server

Description

bool ftp_fput ( resource ftp_stream, string remote_file, resource handle, int mode [, int startpos])

ftp_fput() uploads the data from the file pointer handle until the end of the file is reached. The results are stored in remote_file on the FTP server. The transfer mode specified must be either FTP_ASCII or FTP_BINARY.

예 1. ftp_fput() example

<?php

// open some file for reading
$file = 'somefile.txt';
$fp = fopen($file, 'r');

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to upload $file
if (ftp_fput($conn_id, $file, $fp, FTP_ASCII)) {
    echo "Successfully uploaded $file\n";
} else {
    echo "There was a problem while uploading $file\n";
}

// close the connection and the file handler
ftp_close($conn_id);
fclose($fp);

?>

참고: The startpos parameter was added in PHP 4.3.0.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also ftp_put(), ftp_nb_fput(), and ftp_nb_put().

이전 | 처음으로 | 다음
ftp_fget | 위로 | ftp_get_option


ftp_get_option

(PHP 4 >= 4.2.0, PHP 5)

ftp_get_option -- Retrieves various runtime behaviours of the current FTP stream

Description

mixed ftp_get_option ( resource ftp_stream, int option)

Returns the value on success or FALSE if the given option is not supported. In the latter case, a warning message is also thrown.

This function returns the value for the requested option from the specified ftp_stream . Currently, the following options are supported:

표 1. Supported runtime FTP options

FTP_TIMEOUT_SEC Returns the current timeout used for network related operations.

예 1. ftp_get_option() example

<?php
// Get the timeout of the given FTP stream
$timeout = ftp_get_option($conn_id, FTP_TIMEOUT_SEC);
?>

See also ftp_set_option().

이전 | 처음으로 | 다음
ftp_fput | 위로 | ftp_get


ftp_get

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_get -- Downloads a file from the FTP server

Description

bool ftp_get ( resource ftp_stream, string local_file, string remote_file, int mode [, int resumepos])

ftp_get() retrieves remote_file from the FTP server, and saves it to local_file locally. The transfer mode specified must be either FTP_ASCII or FTP_BINARY.

참고: The resumepos parameter was added in PHP 4.3.0.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. ftp_get() example

<?php

// define some variables
$local_file = 'local.zip';
$server_file = 'server.zip';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to download $server_file and save to $local_file
if (ftp_get($conn_id, $local_file, $server_file, FTP_BINARY)) {
    echo "Successfully written to $local_file\n";
} else {
    echo "There was a problem\n";
}

// close the connection
ftp_close($conn_id);

?>

See also ftp_fget(), ftp_nb_get() and ftp_nb_fget().

이전 | 처음으로 | 다음
ftp_get_option | 위로 | ftp_login


ftp_login

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_login -- Logs in to an FTP connection

Description

bool ftp_login ( resource ftp_stream, string username, string password)

Logs in to the given FTP stream.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. ftp_login() example

<?php

$ftp_server = "ftp.example.com";
$ftp_user = "foo";
$ftp_pass = "bar";

// set up a connection or die
$conn_id = ftp_connect($ftp_server) or die("Couldn't connect to $ftp_server");

// try to login
if (@ftp_login($conn_id, $ftp_user, $ftp_pass)) {
    echo "Connected as $ftp_user@$ftp_server\n";
} else {
    echo "Couldn't connect as $ftp_user\n";
}

// close the connection
ftp_close($conn_id);
?>

이전 | 처음으로 | 다음
ftp_get | 위로 | ftp_mdtm


ftp_mdtm

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_mdtm -- Returns the last modified time of the given file

Description

int ftp_mdtm ( resource ftp_stream, string remote_file)

ftp_mdtm() checks the last modified time for a file, and returns it as a Unix timestamp. If an error occurs, or the file does not exist, -1 is returned.

Returns a Unix timestamp on success, or -1 on error.

예 1. ftp_mdtm() example

<?php

$file = 'somefile.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

//  get the last modified time
$buff = ftp_mdtm($conn_id, $file);

if ($buff != -1) {
    // somefile.txt was last modified on: March 26 2003 14:16:41.
    echo "$file was last modified on : " . date("F d Y H:i:s.", $buff);
} else {
    echo "Couldn't get mdtime";
}

// close the connection
ftp_close($conn_id);

?>

참고: Not all servers support this feature!

참고: ftp_mdtm() does not work with directories.

이전 | 처음으로 | 다음
ftp_login | 위로 | ftp_mkdir


ftp_mkdir

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_mkdir -- Creates a directory

Description

string ftp_mkdir ( resource ftp_stream, string directory)

Creates the specified directory on the FTP server.

Returns the newly created directory name on success or FALSE on error.

예 1. ftp_mkdir() example

<?php

$dir = 'www';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to create the directory $dir
if (ftp_mkdir($conn_id, $dir)) {
echo "successfully created $dir\n";
} else {
echo "There was a problem while creating $dir\n";
}

// close the connection
ftp_close($conn_id);
?>

See also ftp_rmdir().

이전 | 처음으로 | 다음
ftp_mdtm | 위로 | ftp_nb_continue


ftp_nb_continue

(PHP 4 >= 4.3.0, PHP 5)

ftp_nb_continue -- Continues retrieving/sending a file (non-blocking)

Description

int ftp_nb_continue ( resource ftp_stream)

Continues retrieving/sending a file non-blocking.

예 1. ftp_nb_continue() example

<?php

// Initate the download
$ret = ftp_nb_get($my_connection, "test", "README", FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Continue downloading...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "There was an error downloading the file...";
   exit(1);
}
?>

Returns FTP_FAILED or FTP_FINISHED or FTP_MOREDATA.

이전 | 처음으로 | 다음
ftp_mkdir | 위로 | ftp_nb_fget


ftp_nb_fget

(PHP 4 >= 4.3.0, PHP 5)

ftp_nb_fget -- Retrieves a file from the FTP server and writes it to an open file (non-blocking)

Description

int ftp_nb_fget ( resource ftp_stream, resource handle, string remote_file, int mode [, int resumepos])

ftp_nb_fget() retrieves remote_file from the FTP server, and writes it to the given file pointer, handle. The transfer mode specified must be either FTP_ASCII or FTP_BINARY. The difference between this function and the ftp_fget() is that this function retrieves the file asynchronously, so your program can perform other operations while the file is being downloaded.

예 1. ftp_nb_fget() example

<?php

// open some file for reading
$file = 'index.php';
$fp = fopen($file, 'w');

$conn_id = ftp_connect($ftp_server);

$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// Initate the download
$ret = ftp_nb_fget($conn_id, $fp, $file, FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Do whatever you want
   echo ".";

   // Continue downloading...
   $ret = ftp_nb_continue($conn_id);
}
if ($ret != FTP_FINISHED) {
   echo "There was an error downloading the file...";
   exit(1);
}

// close filepointer
fclose($fp);
?>

Returns FTP_FAILED, FTP_FINISHED, or FTP_MOREDATA.

See also ftp_nb_get(),
ftp_nb_continue(), ftp_fget(), and
ftp_get().

이전 | 처음으로 | 다음
ftp_nb_continue | 위로 | ftp_nb_fput


ftp_nb_fput

(PHP 4 >= 4.3.0, PHP 5)

ftp_nb_fput -- Stores a file from an open file to the FTP server (non-blocking)

Description

int ftp_nb_fput ( resource ftp_stream, string remote_file, resource handle, int mode [, int startpos])

ftp_nb_fput() uploads the data from the file pointer handle until it reaches the end of the file. The results are stored in remote_file on the FTP server. The transfer mode specified must be either FTP_ASCII or FTP_BINARY. The difference between this function and the ftp_fput() is that this function uploads the file asynchronously, so your program can perform other operations while the file is being uploaded.

예 1. ftp_nb_fput() example

<?php

$file = 'index.php';

$fp = fopen($file, 'r');

$conn_id = ftp_connect($ftp_server);

$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// Initate the upload
$ret = ftp_nb_fput($conn_id, $file, $fp, FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Do whatever you want
   echo ".";

   // Continue upload...
   $ret = ftp_nb_continue($conn_id);
}
if ($ret != FTP_FINISHED) {
   echo "There was an error uploading the file...";
   exit(1);
}

fclose($fp);
?>

Returns FTP_FAILED, FTP_FINISHED, or FTP_MOREDATA.

See also ftp_nb_put(),
ftp_nb_continue(), ftp_put()
and ftp_fput().

이전 | 처음으로 | 다음
ftp_nb_fget | 위로 | ftp_nb_get


ftp_nb_get

(PHP 4 >= 4.3.0, PHP 5)

ftp_nb_get -- Retrieves a file from the FTP server and writes it to a local file (non-blocking)

Description

int ftp_nb_get ( resource ftp_stream, string local_file, string remote_file, int mode [, int resumepos])

ftp_nb_get() retrieves remote_file from the FTP server, and saves it to local_file locally. The transfer mode specified must be either FTP_ASCII or FTP_BINARY. The difference between this function and the ftp_get() is that this function retrieves the file asynchronously, so your program can perform other operations while the file is being downloaded.

Returns FTP_FAILED, FTP_FINISHED, or FTP_MOREDATA.

예 1. ftp_nb_get() example

<?php

// Initate the download
$ret = ftp_nb_get($my_connection, "test", "README", FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Do whatever you want
   echo ".";

   // Continue downloading...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "There was an error downloading the file...";
   exit(1);
}
?>

예 2. Resuming a download with ftp_nb_get()

<?php

// Initate
$ret = ftp_nb_get($my_connection, "test", "README", FTP_BINARY,
                      filesize("test"));
// OR: $ret = ftp_nb_get($my_connection, "test", "README",
//                           FTP_BINARY, FTP_AUTORESUME);
while ($ret == FTP_MOREDATA) {

   // Do whatever you want
   echo ".";

   // Continue downloading...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "There was an error downloading the file...";
   exit(1);
}
?>

예 3. Resuming a download at position 100 to a new file with ftp_nb_get()

<?php

// Disable Autoseek
ftp_set_option($my_connection, FTP_AUTOSEEK, false);

// Initiate
$ret = ftp_nb_get($my_connection, "newfile", "README", FTP_BINARY, 100);
while ($ret == FTP_MOREDATA) {

   /* ... */

   // Continue downloading...
   $ret = ftp_nb_continue($my_connection);
}
?>

In the example above, "newfile" is 100 bytes smaller than "README" on the FTP server because we started reading at offset 100. If we have not have disabled FTP_AUTOSEEK, the first 100 bytes of "newfile" will be '\0'.

See also ftp_nb_fget(),
ftp_nb_continue(),
ftp_get(), and ftp_fget().

이전 | 처음으로 | 다음
ftp_nb_fput | 위로 | ftp_nb_put


ftp_nb_put

(PHP 4 >= 4.3.0, PHP 5)

ftp_nb_put -- Stores a file on the FTP server (non-blocking)

Description

int ftp_nb_put ( resource ftp_stream, string remote_file, string local_file, int mode [, int startpos])

ftp_nb_put() stores local_file on the FTP server, as remote_file. The transfer mode specified must be either FTP_ASCII or FTP_BINARY. The difference between this function and the ftp_put() is that this function uploads the file asynchronously, so your program can perform other operations while the file is being uploaded.

Returns FTP_FAILED, FTP_FINISHED, or FTP_MOREDATA.

예 1. ftp_nb_put() example

<?php

// Initiate the Upload
$ret = ftp_nb_put($my_connection, "test.remote", "test.local", FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Do whatever you want
   echo ".";

   // Continue uploading...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "There was an error uploading the file...";
   exit(1);
}
?>

예 2. Resuming an upload with ftp_nb_put()

<?php

// Initiate
$ret = ftp_nb_put($my_connection, "test.remote", "test.local",
                      FTP_BINARY, ftp_size("test.remote"));
// OR: $ret = ftp_nb_put($my_connection, "test.remote", "test.local",
//                           FTP_BINARY, FTP_AUTORESUME);

while ($ret == FTP_MOREDATA) {

   // Do whatever you want
   echo ".";

   // Continue uploading...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "There was an error uploading the file...";
   exit(1);
}
?>

See also ftp_nb_fput(),
ftp_nb_continue(), ftp_put(),
and ftp_fput().

이전 | 처음으로 | 다음
ftp_nb_get | 위로 | ftp_nlist


ftp_nlist

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_nlist -- Returns a list of files in the given directory

Description

array ftp_nlist ( resource ftp_stream, string directory)

Returns an array of filenames from the specified directory on success or FALSE on error.

예 1. ftp_nlist() example

<?php

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// get contents of the current directory
$contents = ftp_nlist($conn_id, ".");

// output $contents
var_dump($contents);

?>

? ? The above example will output something similar to:

array(3) {
  [0]=>
  string(11) "public_html"
  [1]=>
  string(10) "public_ftp"
  [2]=>
  string(3) "www"

? ?

See also ftp_rawlist().

이전 | 처음으로 | 다음
ftp_nb_put | 위로 | ftp_pasv


ftp_pasv

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_pasv -- Turns passive mode on or off

Description

bool ftp_pasv ( resource ftp_stream, bool pasv)

ftp_pasv() turns on passive mode if the pasv parameter is TRUE. It turns off passive mode if pasv is FALSE. In passive mode, data connections are initiated by the client, rather than by the server.

예 1. ftp_pasv() example

<?php
$file = 'somefile.txt';
$remote_file = 'readme.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// turn passive mode on
ftp_pasv($conn_id, true);

// upload a file
if (ftp_put($conn_id, $remote_file, $file, FTP_ASCII)) {
echo "successfully uploaded $file\n";
} else {
echo "There was a problem while uploading $file\n";
}

// close the connection
ftp_close($conn_id);
?>

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ftp_nlist | 위로 | ftp_put


ftp_put

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_put -- Uploads a file to the FTP server

Description

bool ftp_put ( resource ftp_stream, string remote_file, string local_file, int mode [, int startpos])

ftp_put() stores local_file on the FTP server, as remote_file. The transfer mode specified must be either FTP_ASCII or FTP_BINARY.

참고: The startpos parameter was added in PHP 4.3.0.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. ftp_put() example

<?php
$file = 'somefile.txt';
$remote_file = 'readme.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// upload a file
if (ftp_put($conn_id, $remote_file, $file, FTP_ASCII)) {
echo "successfully uploaded $file\n";
} else {
echo "There was a problem while uploading $file\n";
}

// close the connection
ftp_close($conn_id);
?>

See also ftp_fput(), ftp_nb_fput(), and ftp_nb_put().

이전 | 처음으로 | 다음
ftp_pasv | 위로 | ftp_pwd


ftp_pwd

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_pwd -- Returns the current directory name

Description

string ftp_pwd ( resource ftp_stream)

Returns the current directory or FALSE on error.

예 1. ftp_pwd() example

<?php

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// change directory to public_html
ftp_chdir($conn_id, 'public_html');

// print current directory
echo ftp_pwd($conn_id); // /public_html

// close the connection
ftp_close($conn_id);
?>

이전 | 처음으로 | 다음
ftp_put | 위로 | ftp_quit


ftp_quit

ftp_quit -- Alias of ftp_close()

Description

This function is an alias of ftp_close().

이전 | 처음으로 | 다음
ftp_pwd | 위로 | ftp_raw


ftp_raw

(PHP 5)

ftp_raw -- Sends an arbitrary command to an FTP server

Description

array ftp_raw ( resource ftp_stream, string command)

Sends an arbitrary command to the FTP server. Returns the server's response as an array of strings. No parsing is performed on the response string, nor does ftp_raw() determine if the command succeeded.

예 1. Using ftp_raw() to login to an FTP server manually.

<?php
$fp = ftp_connect("ftp.example.com");

/* This is the same as:
   ftp_login($fp, "joeblow", "secret"); */
ftp_raw($fp, "USER joeblow");
ftp_raw($fp, "PASS secret");
?>

See Also: ftp_exec()

이전 | 처음으로 | 다음
ftp_quit | 위로 | ftp_rawlist


ftp_rawlist

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_rawlist -- Returns a detailed list of files in the given directory

Description

array ftp_rawlist ( resource ftp_stream, string directory)

ftp_rawlist() executes the FTP LIST command, and returns the result as an array. Each array element corresponds to one line of text. The output is not parsed in any way. The system type identifier returned by ftp_systype() can be used to determine how the results should be interpreted.

예 1. ftp_rawlist() example

<?php

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// get the file list for /
$buff = ftp_rawlist($conn_id, '/');

// close the connection
ftp_close($conn_id);

// output the buffer
var_dump($buff);
?>

? ? The above example will output something similar to: ? ?

array(3) {
  [0]=>
  string(65) "drwxr-x---   3 vincent  vincent      4096 Jul 12 12:16 public_ftp"
  [1]=>
  string(66) "drwxr-x---  15 vincent  vincent      4096 Nov  3 21:31 public_html"
  [2]=>
  string(73) "lrwxrwxrwx   1 vincent  vincent        11 Jul 12 12:16 www -> public_html"
}

? ?

See also ftp_nlist().

이전 | 처음으로 | 다음
ftp_raw | 위로 | ftp_rename


ftp_rename

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_rename -- Renames a file on the FTP server

Description

bool ftp_rename ( resource ftp_stream, string from, string to)

ftp_rename() renames the file or directory that is currently named from to the new name to, using the FTP stream ftp_stream.

예 1. ftp_rename() example

<?php
$old_file = 'somefile.txt.bak';
$new_file = 'somefile.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to rename $olf_file to $new_file
if (ftp_rename($conn_id, $old_file, $new_file)) {
echo "successfully renamed $old_file to $new_file\n";
} else {
echo "There was a problem while renaming $old_file to $new_file\n";
}

// close the connection
ftp_close($conn_id);
?>

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ftp_rawlist | 위로 | ftp_rmdir


ftp_rmdir

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_rmdir -- Removes a directory

Description

bool ftp_rmdir ( resource ftp_stream, string directory)

Removes the specified directory. directory must be either an absolute or relative path to an empty directory.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. ftp_rmdir() example

<?php

$dir = 'www/';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to delete the directory $dir
if (ftp_rmdir($conn_id, $dir)) {
    echo "Successfully deleted $dir\n";
} else {
    echo "There was a problem while deleting $dir\n";
}

ftp_close($conn_id);

?>

See also ftp_mkdir().

이전 | 처음으로 | 다음
ftp_rename | 위로 | ftp_set_option


ftp_set_option

(PHP 4 >= 4.2.0, PHP 5)

ftp_set_option -- Set miscellaneous runtime FTP options

Description

bool ftp_set_option ( resource ftp_stream, int option, mixed value)

Returns TRUE if the option could be set; FALSE if not. A warning message will be thrown if the option is not supported or the passed value doesn't match the expected value for the given option.

This function controls various runtime options for the specified FTP stream. The value parameter depends on which option parameter is chosen to be altered. Currently, the following options are supported:

표 1. Supported runtime FTP options

FTP_TIMEOUT_SEC | Changes the timeout in seconds used for all network related functions. value must be an integer that is greater than 0. The default timeout is 90 seconds.
FTP_AUTOSEEK | When enabled, GET or PUT requests with a resumepos or startpos parameter will first seek to the requested position within the file. This is enabled by default.

예 1. ftp_set_option() example

<?php
// Set the network timeout to 10 seconds
ftp_set_option($conn_id, FTP_TIMEOUT_SEC, 10);
?>

See also ftp_get_option().

이전 | 처음으로 | 다음
ftp_rmdir | 위로 | ftp_site


ftp_site

(PHP 3>= 3.0.15, PHP 4 , PHP 5)

ftp_site -- Sends a SITE command to the server

Description

bool ftp_site ( resource ftp_stream, string cmd)

ftp_site() sends the command specified by cmd to the FTP server. SITE commands are not standardized, and vary from server to server. They are useful for handling such things as file permissions and group membership.

예 1. Sending a SITE command to an ftp server

<?php
/* Connect to FTP server */
$conn = ftp_connect('ftp.example.com');
if (!$conn) die('Unable to connect to ftp.example.com');

/* Login as "user" with password "pass" */
if (!ftp_login($conn, 'user', 'pass')) die('Error logging into ftp.example.com');

/* Issue: "SITE CHMOD 0600 /home/user/privatefile" command to ftp server */
if (ftp_site($conn, 'CHMOD 0600 /home/user/privatefile')) {
   echo "Command executed successfully.\n";
} else {
   die('Command failed.');
}
?>

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See Also: ftp_raw()

이전 | 처음으로 | 다음
ftp_set_option | 위로 | ftp_size


ftp_size

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_size -- Returns the size of the given file

Description

int ftp_size ( resource ftp_stream, string remote_file)

ftp_size() returns the size of a remote_file in bytes. If an error occurs, or if the given file does not exist, or is a directory, -1 is returned. Not all servers support this feature.

Returns the file size on success, or -1 on error.

예 1. ftp_size() example

<?php

$file = 'somefile.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// get the size of $file
$res = ftp_size($conn_id, $file);

if ($res != -1) {
    echo "size of $file is $res bytes";
} else {
    echo "couldn't get the size";
}

// close the connection
ftp_close($conn_id);

?>

See also ftp_rawlist().

이전 | 처음으로 | 다음
ftp_site | 위로 | ftp_ssl_connect


ftp_ssl_connect

(PHP 4 >= 4.3.0, PHP 5)

ftp_ssl_connect -- Opens an Secure SSL-FTP connection

Description

resource ftp_ssl_connect ( string host [, int port [, int timeout]])

Returns a SSL-FTP stream on success or FALSE on error.

ftp_ssl_connect() opens a SSL-FTP connection to the specified host. The port parameter specifies an alternate port to connect to. If it's omitted or set to zero then the default FTP port 21 will be used.

The timeout parameter specifies the timeout for all subsequent network operations. If omitted, the default value is 90 seconds. The timeout can be changed and queried at any time with ftp_set_option() and ftp_get_option().

예 1. ftp_ssl_connect() example

<?php

// set up basic ssl connection
$conn_id = ftp_ssl_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

echo ftp_pwd($conn_id); // /

// close the ssl connection
ftp_close($conn_id);
?>

Why this function may not exist: ftp_ssl_connect() is only available if OpenSSL support is enabled into your version of PHP. If it's undefined and you've compiled FTP support then this is why.

See also ftp_connect().

이전 | 처음으로 | 다음
ftp_size | 위로 | ftp_systype


ftp_systype

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ftp_systype -- Returns the system type identifier of the remote FTP server

Description

string ftp_systype ( resource ftp_stream)

Returns the remote system type, or FALSE on error.

예 1. ftp_systype() example

<?php

// ftp connection
$ftp = ftp_connect('ftp.example.com');
ftp_login($ftp, 'user', 'password');

// get the system type
if ($type = ftp_systype($ftp)) {
    echo "Example.com is powered by $type\n";
} else {
    echo "Couldn't get the systype";
}

?>

The above example will output something similar to:

Example.com is powered by UNIX

이전 | 처음으로 | 다음
ftp_ssl_connect | 위로 | Function Handling Functions


Function Handling Functions

PHP 매뉴얼
이전 다음

XXXIV. Function Handling Functions

소개

These functions all handle various operations involved in working with functions.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
call_user_func_array -- Call a user function given with an array of parameters
call_user_func -- Call a user function given by the first parameter
create_function -- Create an anonymous (lambda-style) function
func_get_arg -- Return an item from the argument list
func_get_args -- Returns an array comprising a function's argument list
func_num_args -- Returns the number of arguments passed to the function
function_exists -- Return TRUE if the given function has been defined
get_defined_functions -- Returns an array of all defined functions
register_shutdown_function -- Register a function for execution on shutdown
register_tick_function -- Register a function for execution on each tick
unregister_tick_function -- De-register a function for execution on each tick

이전 | 처음으로 | 다음
ftp_systype | 위로 | call_user_func_array


call_user_func_array

(PHP 4 >= 4.0.4, PHP 5)

call_user_func_array -- Call a user function given with an array of parameters

Description

mixed call_user_func_array ( callback function [, array param_arr])

Call a user defined function given by function, with the parameters in param_arr. For example:

예 1. call_user_func_array() example

<?php
function debug($var, $val)
{
    echo "***DEBUGGING\nVARIABLE: $var\nVALUE:";
    if (is_array($val) || is_object($val) || is_resource($val)) {
        print_r($val);
    } else {
        echo "\n$val\n";
    }
    echo "***\n";
}

$c = mysql_connect();
$host = $_SERVER["SERVER_NAME"];

call_user_func_array('debug', array("host", $host));
call_user_func_array('debug', array("c", $c));
call_user_func_array('debug', array("_POST", $_POST));
?>

See also call_user_func().

이전 | 처음으로 | 다음
Function Handling Functions | 위로 | call_user_func


call_user_func

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

call_user_func -- Call a user function given by the first parameter

Description

mixed call_user_func ( callback function [, mixed parameter [, mixed ...]])

Call a user defined function given by the function parameter. Take the following:

<?php
function barber($type)
{
    echo "You wanted a $type haircut, no problem";
}
call_user_func('barber', "mushroom");
call_user_func('barber', "shave");
?>

Object methods may also be invoked statically using this function by passing array($objectname, $methodname) to the function parameter.

<?php
class myclass {
  function say_hello()
  {
    echo "Hello!\n";
  }
}

$classname = "myclass";

call_user_func(array($classname, 'say_hello'));
?>

See also: is_callable(), and call_user_func_array()

이전 | 처음으로 | 다음
call_user_func_array | 위로 | create_function


create_function

(PHP 4 >= 4.0.1, PHP 5)

create_function -- Create an anonymous (lambda-style) function

Description

string create_function ( string args, string code)

Creates an anonymous function from the parameters passed, and returns a unique name for it. Usually the args will be passed as a single quote delimited string, and this is also recommended for the code. The reason for using single quoted strings, is to protect the variable names from parsing, otherwise, if you use double quotes there will be a need to escape the variable names, e.g. \$avar.

You can use this function, to (for example) create a function from information gathered at run time:

예 1. Creating an anonymous function with create_function()

<?php
$newfunc = create_function('$a,$b', 'return "ln($a) + ln($b) = " . log($a * $b);');
echo "New anonymous function: $newfunc\n";
echo $newfunc(2, M_E) . "\n";
// outputs
// New anonymous function: lambda_1
// ln(2) + ln(2.718281828459) = 1.6931471805599
?>

Or, perhaps to have general handler function that can apply a set of operations to a list of parameters:

예 2. Making a general processing function with create_function()

<?php
function process($var1, $var2, $farr)
{
    for ($f=0; $f < count($farr); $f++) {
        echo $farr[$f]($var1, $var2) . "\n";
    }
}

// create a bunch of math functions
$f1 = 'if ($a >=0) {return "b*a^2 = ".$b*sqrt($a);} else {return false;}';
$f2 = "return \"min(b^2+a, a^2,b) = \".min(\$a*\$a+\$b,\$b*\$b+\$a);";
$f3 = 'if ($a > 0 && $b != 0) {return "ln(a)/b = ".log($a)/$b; } else { return false; }';
$farr = array(
    create_function('$x,$y', 'return "some trig: ".(sin($x) + $x*cos($y));'),
    create_function('$x,$y', 'return "a hypotenuse: ".sqrt($x*$x + $y*$y);'),
    create_function('$a,$b', $f1),
    create_function('$a,$b', $f2),
    create_function('$a,$b', $f3)
    );

echo "\nUsing the first array of anonymous functions\n";
echo "parameters: 2.3445, M_PI\n";
process(2.3445, M_PI, $farr);

// now make a bunch of string processing functions
$garr = array(
    create_function('$b,$a', 'if (strncmp($a, $b, 3) == 0) return "** \"$a\" '.
    'and \"$b\"\n** Look the same to me! (looking at the first 3 chars)";'),
    create_function('$a,$b', '; return "CRCs: " . crc32($a) . " , ".crc32(b);'),
    create_function('$a,$b', '; return "similar(a,b) = " . similar_text($a, $b, &$p) . "($p%)";')
    );
echo "\nUsing the second array of anonymous functions\n";
process("Twas brilling and the slithy toves", "Twas the night", $garr);
?>

and when you run the code above, the output will be:

Using the first array of anonymous functions
parameters: 2.3445, M_PI
some trig: -1.6291725057799
a hypotenuse: 3.9199852871011
b*a^2 = 4.8103313314525
min(b^2+a, a^2,b) = 8.6382729035898
ln(a/b) = 0.27122299212594

Using the second array of anonymous functions
** "Twas the night" and "Twas brilling and the slithy toves"
** Look the same to me! (looking at the first 3 chars)
CRCs: -725381282 , 1908338681
similar(a,b) = 11(45.833333333333%)

But perhaps the most common use for of lambda-style (anonymous) functions is to create callback functions, for example when using array_walk() or usort()

예 3. Using anonymous functions as callback functions

<?php
$av = array("the ", "a ", "that ", "this ");
array_walk($av, create_function('&$v,$k', '$v = $v . "mango";'));
print_r($av);
?>

outputs:

Array
(
  [0] => the mango
  [1] => a mango
  [2] => that mango
  [3] => this mango
)

an array of strings ordered from shorter to longer

<?php

$sv = array("small", "larger", "a big string", "it is a string thing");
print_r($sv);

?>

outputs:

Array
(
  [0] => small
  [1] => larger
  [2] => a big string
  [3] => it is a string thing
)

sort it from longer to shorter

<?php

usort($sv, create_function('$a,$b','return strlen($b) - strlen($a);'));
print_r($sv);

?>

outputs:

Array
(
  [0] => it is a string thing
  [1] => a big string
  [2] => larger
  [3] => small
)

이전 | 처음으로 | 다음
call_user_func | 위로 | func_get_arg


func_get_arg

(PHP 4 , PHP 5)

func_get_arg -- Return an item from the argument list

Description

mixed func_get_arg ( int arg_num)

Returns the argument which is at the arg_num'th offset into a user-defined function's argument list. Function arguments are counted starting from zero. func_get_arg() will generate a warning if called from outside of a function definition.

If arg_num is greater than the number of arguments actually passed, a warning will be generated and func_get_arg() will return FALSE.

<?php
function foo()
{
     $numargs = func_num_args();
     echo "Number of arguments: $numargs<br />\n";
     if ($numargs >= 2) {
     echo "Second argument is: " . func_get_arg(1) . "<br />\n";
     }
}

foo (1, 2, 3);
?>

func_get_arg() may be used in conjunction with func_num_args() and func_get_args() to allow user-defined functions to accept variable-length argument lists.

참고: This function was added in PHP 4.

이전 | 처음으로 | 다음
create_function | 위로 | func_get_args


func_get_args

(PHP 4 , PHP 5)

func_get_args -- Returns an array comprising a function's argument list

Description

array func_get_args ( void )

Returns an array in which each element is the corresponding member of the current user-defined function's argument list. func_get_args() will generate a warning if called from outside of a function definition.

<?php
function foo()
{
    $numargs = func_num_args();
    echo "Number of arguments: $numargs<br />\n";
    if ($numargs >= 2) {
        echo "Second argument is: " . func_get_arg(1) . "<br />\n";
    }
    $arg_list = func_get_args();
    for ($i = 0; $i < $numargs; $i++) {
        echo "Argument $i is: " . $arg_list[$i] . "<br />\n";
    }
}

foo(1, 2, 3);
?>

func_get_args() may be used in conjunction
with func_num_args() and
func_get_arg() to allow user-defined functions
to accept variable-length argument lists.

참고: This function was added in PHP 4.

이전 | 처음으로 | 다음
func_get_arg | 위로 | func_num_args


func_num_args

(PHP 4 , PHP 5)

func_num_args -- Returns the number of arguments passed to the function

Description

int func_num_args ( void )

Returns the number of arguments passed into the current user-defined function. func_num_args() will generate a warning if called from outside of a user-defined function.

<?php
function foo()
{
    $numargs = func_num_args();
    echo "Number of arguments: $numargs\n";
}

foo(1, 2, 3);    // Prints 'Number of arguments: 3'
?>

func_num_args() may be used in conjunction
with func_get_arg() and
func_get_args() to allow user-defined
functions to accept variable-length argument lists.

이전 | 처음으로 | 다음
func_get_args | 위로 | function_exists


function_exists

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

function_exists -- Return TRUE if the given function has been defined

Description

bool function_exists ( string function_name)

Checks the list of defined functions, both built-in (internal) and user-defined, for function_name. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

<?php
if (function_exists('imap_open')) {
    echo "IMAP functions are available.<br />\n";
} else {
    echo "IMAP functions are not available.<br />\n";
}
?>

Note that a function name may exist even if the function itself is unusable due to configuration or compiling options (with the image functions being an example). Also note that function_exists() will return FALSE for constructs, such as include_once() and echo().

See also method_exists() and get_defined_functions().

이전 | 처음으로 | 다음
func_num_args | 위로 | get_defined_functions


get_defined_functions

(PHP 4 >= 4.0.4, PHP 5)

get_defined_functions -- Returns an array of all defined functions

Description

array get_defined_functions ( void )

This function returns an multidimensional array containing a list of all defined functions, both built-in (internal) and user-defined. The internal functions will be accessible via $arr["internal"], and the user defined ones using $arr["user"] (see example below).

<?php
function myrow($id, $data)
{
    return "<tr><th>$id</th><td>$data</td></tr>\n";
}

$arr = get_defined_functions();

print_r($arr);
?>

Will output something along the lines of:

Array
(
    [internal] => Array
        (
            [0] => zend_version
            [1] => func_num_args
            [2] => func_get_arg
            [3] => func_get_args
            [4] => strlen
            [5] => strcmp
            [6] => strncmp
            ...
            [750] => bcscale
            [751] => bccomp
        )

    [user] => Array
        (
            [0] => myrow
        )

)

See also get_defined_vars() and get_defined_constants().

이전 | 처음으로 | 다음
function_exists | 위로 | register_shutdown_function


register_shutdown_function

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

register_shutdown_function -- Register a function for execution on shutdown

Description

void register_shutdown_function ( callback function)

Registers the function named by function to be executed when script processing is complete.

Multiple calls to register_shutdown_function() can be made, and each will be called in the same order as they were registered. If you call exit() within one registered shutdown function, processing will stop completely and no other registered shutdown functions will be called.

The registered shutdown functions are called after the request has been completed (including sending any output buffers), so it is not possible to send output to the browser using echo() or print(), or retrieve the contents of any output buffers using ob_get_contents().

참고: Typically undefined functions cause fatal errors in PHP, but when the function called with register_shutdown_function() is undefined, an error of level E_WARNING is generated instead. Also, for reasons internal to PHP, this error will refer to Unknown() at line #0.

See also auto_append_file, exit(), and the section on connection handling.

이전 | 처음으로 | 다음
get_defined_functions | 위로 | register_tick_function


register_tick_function

(PHP 4 >= 4.0.3, PHP 5)

register_tick_function -- Register a function for execution on each tick

Description

void register_tick_function ( callback function [, mixed arg])

Registers the function named by func to be executed when a tick is called. Also, you may pass an array consisting of an object and a method as the func.

예 1. register_tick_function() example

<?php
// using a function as the callback
register_tick_function('my_function', true);

// using an object->method
$object = new my_class();
register_tick_function(array(&$object, 'my_method'), true);
?>

See also declare() and unregister_tick_function().

이전 | 처음으로 | 다음
register_shutdown_function | 위로 | unregister_tick_function


unregister_tick_function

(PHP 4 >= 4.0.3, PHP 5)

unregister_tick_function -- De-register a function for execution on each tick

Description

void unregister_tick_function ( string function_name)

De-registers the function named by function_name so it is no longer executed when a tick is called.

이전 | 처음으로 | 다음
register_tick_function | 위로 | Gettext


Gettext

PHP 매뉴얼
이전 다음

XXXV. Gettext

소개

The gettext functions implement an NLS (Native Language Support) API which can be used to internationalize your PHP applications. Please see the gettext documentation for your system for a thorough explanation of these functions or view the docs at http://www.gnu.org/software/gettext/manual/index.html.

요구 사항

To use these functions you must download and install the GNU gettext package from http://www.gnu.org/software/gettext/gettext.html

설치

To include GNU gettext support in your PHP build you must add the option --with-gettext[=DIR] where DIR is the gettext install directory, defaults to /usr/local.

Note to Win32 Users: In order to enable this module on a Windows environment, you must copy gnu_gettext.dll from the DLL folder of the PHP/Win32 binary package to the SYSTEM32 folder of your windows machine. (Ex: C:\WINNT\SYSTEM32 or C:\WINDOWS\SYSTEM32). Starting with PHP 4.2.3 the name changed to libintl-1.dll, this requires also iconv.dll to be copied.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
bind_textdomain_codeset -- Specify the character encoding in which the messages from the DOMAIN message catalog will be returned
bindtextdomain -- Sets the path for a domain
dcgettext -- Overrides the domain for a single lookup
dcngettext -- Plural version of dcgettext
dgettext -- Override the current domain
dngettext -- Plural version of dgettext
gettext -- Lookup a message in the current domain
ngettext -- Plural version of gettext
textdomain -- Sets the default domain

이전 | 처음으로 | 다음
unregister_tick_function | 위로 | bind_textdomain_codeset


bind_textdomain_codeset

(PHP 4 >= 4.2.0, PHP 5)

bind_textdomain_codeset -- Specify the character encoding in which the messages from the DOMAIN message catalog will be returned

Description

string bind_textdomain_codeset ( string domain, string codeset)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
Gettext | 위로 | bindtextdomain


bindtextdomain

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

bindtextdomain -- Sets the path for a domain

Description

string bindtextdomain ( string domain, string directory)

The bindtextdomain() function sets the path for a domain. It returns the full pathname for the domain currently being set.

예 1. bindtextdomain() example

<?php

$domain = 'myapp';
echo bindtextdomain($domain, '/usr/share/myapp/locale');

?>

This will output :

/usr/share/myapp/locale

이전 | 처음으로 | 다음
bind_textdomain_codeset | 위로 | dcgettext


dcgettext

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

dcgettext -- Overrides the domain for a single lookup

Description

string dcgettext ( string domain, string message, int category)

This function allows you to override the current domain for a single message lookup. It also allows you to specify a category.

이전 | 처음으로 | 다음
bindtextdomain | 위로 | dcngettext


dcngettext

(PHP 4 >= 4.2.0, PHP 5)

dcngettext -- Plural version of dcgettext

Description

string dcngettext ( string domain, string msgid1, string msgid2, int n, int category)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
dcgettext | 위로 | dgettext


dgettext

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

dgettext -- Override the current domain

Description

string dgettext ( string domain, string message)

The dgettext() function allows you to override the current domain for a single message lookup.

이전 | 처음으로 | 다음
dcngettext | 위로 | dngettext


dngettext

(PHP 4 >= 4.2.0, PHP 5)

dngettext -- Plural version of dgettext

Description

string dngettext ( string domain, string msgid1, string msgid2, int n)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
dgettext | 위로 | gettext


gettext

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

gettext -- Lookup a message in the current domain

Description

string gettext ( string message)

This function returns a translated string if one is found in the translation table, or the submitted message if not found. You may use the underscore character '_' as an alias to this function.

예 1. gettext()-check

<?php
// Set language to German
setlocale(LC_ALL, 'de_DE');

// Specify location of translation tables
bindtextdomain("myPHPApp", "./locale");

// Choose domain
textdomain("myPHPApp");

// Translation is looking for in ./locale/de_DE/LC_MESSAGES/myPHPApp.mo now

// Print a test message
echo gettext("Welcome to My PHP Application");

// Or use the alias _() for gettext()
echo _("Have a nice day");
?>

See also setlocale().

이전 | 처음으로 | 다음
dngettext | 위로 | ngettext


ngettext

(PHP 4 >= 4.2.0, PHP 5)

ngettext -- Plural version of gettext

Description

string ngettext ( string msgid1, string msgid2, int n)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
gettext | 위로 | textdomain


textdomain

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

textdomain -- Sets the default domain

Description

string textdomain ( string text_domain)

This function sets the domain to search within when calls are made to gettext(), usually the named after an application. The previous default domain is returned. Call it with NULL as parameter to get the current setting without changing it.

이전 | 처음으로 | 다음
ngettext | 위로 | GMP Functions


GMP Functions

PHP 매뉴얼
이전 다음

XXXVI. GMP Functions

소개

These functions allow you to work with arbitrary-length integers using the GNU MP library.

These functions have been added in PHP 4.0.4.

참고: Most GMP functions accept GMP number arguments, defined as resource below. However, most of these functions will also accept numeric and string arguments, given that it is possible to convert the latter to a number. Also, if there is a faster function that can operate on integer arguments, it would be used instead of the slower function when the supplied arguments are integers. This is done transparently, so the bottom line is that you can use integers in every function that expects GMP number. See also the gmp_init() function.

주의

If you want to explicitly specify a large integer, specify it as a string. If you don't do that, PHP will interpret the integer-literal first, possibly resulting in loss of precision, even before GMP comes into play.

참고: 이 확장 모듈은 윈도우 플랫폼에서는 사용할 수 없습니다.

요구 사항

You can download the GMP library from http://www.swox.com/gmp/. This site also has the GMP manual available.

You will need GMP version 2 or better to use these functions. Some functions may require more recent version of the GMP library.

설치

In order to have these functions available, you must compile PHP with GMP support by using the --with-gmp option.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

GMP_ROUND_ZERO (integer)

GMP_ROUND_PLUSINF (integer)

GMP_ROUND_MINUSINF (integer)

예제

예 1. Factorial function using GMP

<?php
function fact($x)
{
    if ($x <= 1) {
        return 1;
    } else {
        return gmp_mul($x, fact($x-1));
    }
}

echo gmp_strval(fact(1000)) . "\n";
?>

This will calculate factorial of 1000 (pretty big number) very fast.

참고

More mathematical functions can be found in the sections BCMath Arbitrary Precision Mathematics Functions and Mathematical Functions.

차례
gmp_abs -- Absolute value
gmp_add -- Add numbers
gmp_and -- Logical AND
gmp_clrbit -- Clear bit
gmp_cmp -- Compare numbers
gmp_com -- Calculates one's complement
gmp_div_q -- Divide numbers
gmp_div_qr -- Divide numbers and get quotient and remainder
gmp_div_r -- Remainder of the division of numbers
gmp_div -- Alias of gmp_div_q()
gmp_divexact -- Exact division of numbers
gmp_fact -- Factorial
gmp_gcd -- Calculate GCD
gmp_gcdext -- Calculate GCD and multipliers
gmp_hamdist -- Hamming distance
gmp_init -- Create GMP number
gmp_intval -- Convert GMP number to integer
gmp_invert -- Inverse by modulo
gmp_jacobi -- Jacobi symbol
gmp_legendre -- Legendre symbol
gmp_mod -- Modulo operation
gmp_mul -- Multiply numbers
gmp_neg -- Negate number
gmp_or -- Logical OR
gmp_perfect_square -- Perfect square check
gmp_popcount -- Population count
gmp_pow -- Raise number into power
gmp_powm -- Raise number into power with modulo
gmp_prob_prime -- Check if number is "probably prime"
gmp_random -- Random number
gmp_scan0 -- Scan for 0
gmp_scan1 -- Scan for 1
gmp_setbit -- Set bit
gmp_sign -- Sign of number
gmp_sqrt -- Calculate square root
gmp_sqrtrem -- Square root with remainder
gmp_strval -- Convert GMP number to string
gmp_sub -- Subtract numbers
gmp_xor -- Logical XOR

이전 | 처음으로 | 다음
textdomain | 위로 | gmp_abs


gmp_abs

(PHP 4 >= 4.0.4, PHP 5)

gmp_abs -- Absolute value

Description

resource gmp_abs ( resource a)

Returns absolute value of a.

예 1. gmp_abs() example

<?php
$abs1 = gmp_abs("274982683358");
$abs2 = gmp_abs("-274982683358");

echo gmp_strval($abs1) . "\n";
echo gmp_strval($abs2) . "\n";
?>

The printout of the above program will be:

274982683358
274982683358

이전 | 처음으로 | 다음
GMP Functions | 위로 | gmp_add


gmp_add

(PHP 4 >= 4.0.4, PHP 5)

gmp_add -- Add numbers

Description

resource gmp_add ( resource a, resource b)

Add two GMP numbers. The result will be a GMP number representing the sum of the arguments.

예 1. gmp_add() example

<?php
$sum = gmp_add("123456789012345", "76543210987655");
echo gmp_strval($sum) . "\n";
?>

The printout of the above program will be:

200000000000000

이전 | 처음으로 | 다음
gmp_abs | 위로 | gmp_and


gmp_and

(PHP 4 >= 4.0.4, PHP 5)

gmp_and -- Logical AND

Description

resource gmp_and ( resource a, resource b)

Calculates logical AND of two GMP numbers.

예 1. gmp_and() example

<?php
$and1 = gmp_and("0xfffffffff4", "0x4");
$and2 = gmp_and("0xfffffffff4", "0x8");
echo gmp_strval($and1) . "\n";
echo gmp_strval($and2) . "\n";
?>

The printout of the above program will be:

4
0

이전 | 처음으로 | 다음
gmp_add | 위로 | gmp_clrbit


gmp_clrbit

(PHP 4 >= 4.0.4, PHP 5)

gmp_clrbit -- Clear bit

Description

void gmp_clrbit ( resource &a, int index)

Clears (sets to 0) bit index in a. The index starts at 0.

참고: Unlike most of the other GMP functions, gmp_clrbit() must be called with a GMP resource that already exists (using gmp_init() for example). One will not be automatically created.

예 1. gmp_clrbit() example

<?php
$a = gmp_init("0xff");
gmp_clrbit($a, 0); // index starts at 0, least significant bit
echo gmp_strval($a) . "\n";
?>

The printout of the above program will be:

254

See also gmp_setbit().

이전 | 처음으로 | 다음
gmp_and | 위로 | gmp_cmp


gmp_cmp

(PHP 4 >= 4.0.4, PHP 5)

gmp_cmp -- Compare numbers

Description

int gmp_cmp ( resource a, resource b)

Returns a positive value if a > b, zero if a = b and a negative value if a < b.

예 1. gmp_cmp() example

<?php
$cmp1 = gmp_cmp("1234", "1000"); // greater than
$cmp2 = gmp_cmp("1000", "1234"); // less than
$cmp3 = gmp_cmp("1234", "1234"); // equal to

echo "$cmp1 $cmp2 $cmp3\n";
?>

The printout of the above program will be:

1 -1 0

이전 | 처음으로 | 다음
gmp_clrbit | 위로 | gmp_com


gmp_com

(PHP 4 >= 4.0.4, PHP 5)

gmp_com -- Calculates one's complement

Description

resource gmp_com ( resource a)

Returns the one's complement of a.

예 1. gmp_com() example

<?php
$com = gmp_com("1234");
echo gmp_strval($com) . "\n";
?>

The printout of the above program will be:

-1235

이전 | 처음으로 | 다음
gmp_cmp | 위로 | gmp_div_q


gmp_div_q

(PHP 4 >= 4.0.4, PHP 5)

gmp_div_q -- Divide numbers

Description

resource gmp_div_q ( resource a, resource b [, int round])

Divides a by b and returns the integer result. The result rounding is defined by the round, which can have the following values:

  • GMP_ROUND_ZERO: The result is truncated towards 0.

  • GMP_ROUND_PLUSINF: The result is rounded towards +infinity.

  • GMP_ROUND_MINUSINF: The result is rounded towards -infinity.

This function can also be called as gmp_div().

예 1. gmp_div_q() example

<?php
$div1 = gmp_div_q("100", "5");
echo gmp_strval($div1) . "\n";

$div2 = gmp_div_q("1", "3");
echo gmp_strval($div2) . "\n";

$div3 = gmp_div_q("1", "3", GMP_ROUND_PLUSINF);
echo gmp_strval($div3) . "\n";

$div4 = gmp_div_q("-1", "4", GMP_ROUND_PLUSINF);
echo gmp_strval($div4) . "\n";

$div5 = gmp_div_q("-1", "4", GMP_ROUND_MINUSINF);
echo gmp_strval($div5) . "\n";
?>

The printout of the above program will be:

20
0
1
0
1

See also gmp_div_r(), gmp_div_qr()

이전 | 처음으로 | 다음
gmp_com | 위로 | gmp_div_qr


gmp_div_qr

(PHP 4 >= 4.0.4, PHP 5)

gmp_div_qr -- Divide numbers and get quotient and remainder

Description

array gmp_div_qr ( resource n, resource d [, int round])

The function divides n by d and returns array, with the first element being [n/d] (the integer result of the division) and the second being (n - [n/d] * d) (the remainder of the division).

See the gmp_div_q() function for description of the round argument.

예 1. Division of GMP numbers

<?php
$a = gmp_init("0x41682179fbf5");
$res = gmp_div_qr($a, "0xDEFE75");
printf("Result is: q - %s, r - %s",
       gmp_strval($res[0]), gmp_strval($res[1]));
?>

See also gmp_div_q(), gmp_div_r().

이전 | 처음으로 | 다음
gmp_div_q | 위로 | gmp_div_r


gmp_div_r

(PHP 4 >= 4.0.4, PHP 5)

gmp_div_r -- Remainder of the division of numbers

Description

resource gmp_div_r ( resource n, resource d [, int round])

Calculates remainder of the integer division of n by d. The remainder has the sign of the n argument, if not zero.

예 1. gmp_div_r() example

<?php
$div = gmp_div_r("105", "20");
echo gmp_strval($div) . "\n";
?>

The printout of the above program will be:

5

See the gmp_div_q() function for description of the round argument.

See also gmp_div_q(), gmp_div_qr()

이전 | 처음으로 | 다음
gmp_div_qr | 위로 | gmp_div


gmp_div

gmp_div -- Alias of gmp_div_q()

Description

This function is an alias of gmp_div_q().

이전 | 처음으로 | 다음
gmp_div_r | 위로 | gmp_divexact


gmp_divexact

(PHP 4 >= 4.0.4, PHP 5)

gmp_divexact -- Exact division of numbers

Description

resource gmp_divexact ( resource n, resource d)

Divides n by d, using fast "exact division" algorithm. This function produces correct results only when it is known in advance that d divides n.

예 1. gmp_divexact() example

<?php
$div1 = gmp_divexact("10", "2");
echo gmp_strval($div1) . "\n";

$div2 = gmp_divexact("10", "3"); // bogus result
echo gmp_strval($div2) . "\n";
?>

The printout of the above program will be:

5
2863311534

이전 | 처음으로 | 다음
gmp_div | 위로 | gmp_fact


gmp_fact

(PHP 4 >= 4.0.4, PHP 5)

gmp_fact -- Factorial

Description

resource gmp_fact ( int a)

Calculates factorial (a!) of a.

예 1. gmp_fact() example

<?php
$fact1 = gmp_fact(5); // 5 * 4 * 3 * 2 * 1
echo gmp_strval($fact1) . "\n";

$fact2 = gmp_fact(50); // 50 * 49 * 48, ... etc
echo gmp_strval($fact2) . "\n";
?>

The printout of the above program will be:

120
30414093201713378043612608166064768844377641568960512000000000000

이전 | 처음으로 | 다음
gmp_divexact | 위로 | gmp_gcd


gmp_gcd

(PHP 4 >= 4.0.4, PHP 5)

gmp_gcd -- Calculate GCD

Description

resource gmp_gcd ( resource a, resource b)

Calculate greatest common divisor of a and b. The result is always positive even if either of, or both, input operands are negative.

예 1. gmp_gcd() example

<?php
$gcd = gmp_gcd("12", "21");
echo gmp_strval($gcd) . "\n";
?>

The printout of the above program will be:

3

이전 | 처음으로 | 다음
gmp_fact | 위로 | gmp_gcdext


gmp_gcdext

(PHP 4 >= 4.0.4, PHP 5)

gmp_gcdext -- Calculate GCD and multipliers

Description

array gmp_gcdext ( resource a, resource b)

Calculates g, s, and t, such that a*s + b*t = g = gcd(a,b), where gcd is the greatest common divisor. Returns an array with respective elements g, s and t.

This function can be used to solve linear Diophantine equations in two variables. These are equations that allow only integer solutions and have the form: a*x + b*y = c. For more information, go to the "Diophantine Equation" page at MathWorld

예 1. Solving a linear Diophantine equation

<?php
// Solve the equation a*s + b*t = g
// where a = 12, b = 21, g = gcd(12, 21) = 3
$a = gmp_init(12);
$b = gmp_init(21);
$g = gmp_gcd($a, $b);
$r = gmp_gcdext($a, $b);

$check_gcd = (gmp_strval($g) == gmp_strval($r['g']));
$eq_res = gmp_add(gmp_mul($a, $r['s']), gmp_mul($b, $r['t']));
$check_res = (gmp_strval($g) == gmp_strval($eq_res));

if ($check_gcd && $check_res) {
    $fmt = "Solution: %d*%d + %d*%d = %d\n";
    printf($fmt, gmp_strval($a), gmp_strval($r['s']), gmp_strval($b),
    gmp_strval($r['t']), gmp_strval($r['g']));
} else {
    echo "Error while solving the equation\n";
}

// output: Solution: 12*2 + 21*-1 = 3
?>

이전 | 처음으로 | 다음
gmp_gcd | 위로 | gmp_hamdist


gmp_hamdist

(PHP 4 >= 4.0.4, PHP 5)

gmp_hamdist -- Hamming distance

Description

int gmp_hamdist ( resource a, resource b)

Returns the hamming distance between a and b. Both operands should be non-negative.

예 1. gmp_hamdist() example

<?php
$ham1 = gmp_init("1001010011", 2);
$ham2 = gmp_init("1011111100", 2);
echo gmp_hamdist($ham1, $ham2) . "\n";

/* hamdist is equivilent to: */
echo gmp_popcount(gmp_xor($ham1, $ham2)) . "\n";
?>

The printout of the above program will be:

6
6

See also gmp_popcount(), gmp_xor()

이전 | 처음으로 | 다음
gmp_gcdext | 위로 | gmp_init


gmp_init

(PHP 4 >= 4.0.4, PHP 5)

gmp_init -- Create GMP number

Description

resource gmp_init ( mixed number)

Creates a GMP number from an integer or string. String representation can be decimal or hexadecimal. In the latter case, the string should start with 0x.

예 1. Creating GMP number

<?php
$a = gmp_init(123456);
$b = gmp_init("0xFFFFDEBACDFEDF7200");
?>

참고: It is not necessary to call this function if you want to use integer or string in place of GMP number in GMP functions, like gmp_add(). Function arguments are automatically converted to GMP numbers, if such conversion is possible and needed, using the same rules as gmp_init().

이전 | 처음으로 | 다음
gmp_hamdist | 위로 | gmp_intval


gmp_intval

(PHP 4 >= 4.0.4, PHP 5)

gmp_intval -- Convert GMP number to integer

Description

int gmp_intval ( resource gmpnumber)

This function allows to convert GMP number to integer.

주의

This function returns a useful result only if the number actually fits the PHP integer (i.e., signed long type). If you want just to print the GMP number, use gmp_strval().

예 1. gmp_intval() example

<?php
// displays correct result
echo gmp_intval("2147483647") . "\n";

// displays wrong result, above PHP integer limit
echo gmp_intval("2147483648") . "\n";

// displays correct result
echo gmp_strval("2147483648") . "\n";
?>

The printout of the above program will be:

2147483647
2147483647
2147483648

이전 | 처음으로 | 다음
gmp_init | 위로 | gmp_invert


gmp_invert

(PHP 4 >= 4.0.4, PHP 5)

gmp_invert -- Inverse by modulo

Description

resource gmp_invert ( resource a, resource b)

Computes the inverse of a modulo b. Returns FALSE if an inverse does not exist.

예 1. gmp_invert() example

<?php
echo gmp_invert("5", "10"); // no inverse, outputs nothing, result is FALSE
$invert = gmp_invert("5", "11");
echo gmp_strval($invert) . "\n";
?>

The printout of the above program will be:

9

이전 | 처음으로 | 다음
gmp_intval | 위로 | gmp_jacobi


gmp_jacobi

(PHP 4 >= 4.0.4, PHP 5)

gmp_jacobi -- Jacobi symbol

Description

int gmp_jacobi ( resource a, resource p)

Computes Jacobi symbol of a and p. p should be odd and must be positive.

예 1. gmp_jacobi() example

<?php
echo gmp_jacobi("1", "3") . "\n";
echo gmp_jacobi("2", "3") . "\n";
?>

The printout of the above program will be:

1
0

이전 | 처음으로 | 다음
gmp_invert | 위로 | gmp_legendre


gmp_legendre

(PHP 4 >= 4.0.4, PHP 5)

gmp_legendre -- Legendre symbol

Description

int gmp_legendre ( resource a, resource p)

Compute the Legendre symbol of a and p. p should be odd and must be positive.

예 1. gmp_legendre() example

<?php
echo gmp_legendre("1", "3") . "\n";
echo gmp_legendre("2", "3") . "\n";
?>

The printout of the above program will be:

1
0

이전 | 처음으로 | 다음
gmp_jacobi | 위로 | gmp_mod


gmp_mod

(PHP 4 >= 4.0.4, PHP 5)

gmp_mod -- Modulo operation

Description

resource gmp_mod ( resource n, resource d)

Calculates n modulo d. The result is always non-negative, the sign of d is ignored.

예 1. gmp_mod() example

<?php
$mod = gmp_mod("8", "3");
echo gmp_strval($mod) . "\n";
?>

The printout of the above program will be:

2

이전 | 처음으로 | 다음
gmp_legendre | 위로 | gmp_mul


gmp_mul

(PHP 4 >= 4.0.4, PHP 5)

gmp_mul -- Multiply numbers

Description

resource gmp_mul ( resource a, resource b)

Multiplies a by b and returns the result.

예 1. gmp_mul() example

<?php
$mul = gmp_mul("12345678", "2000");
echo gmp_strval($mul) . "\n";
?>

The printout of the above program will be:

24691356000

이전 | 처음으로 | 다음
gmp_mod | 위로 | gmp_neg


gmp_neg

(PHP 4 >= 4.0.4, PHP 5)

gmp_neg -- Negate number

Description

resource gmp_neg ( resource a)

Returns -a.

예 1. gmp_neg() example

<?php
$neg1 = gmp_neg("1");
echo gmp_strval($neg1) . "\n";
$neg2 = gmp_neg("-1");
echo gmp_strval($neg2) . "\n";
?>

The printout of the above program will be:

-1
1

이전 | 처음으로 | 다음
gmp_mul | 위로 | gmp_or


gmp_or

(PHP 4 >= 4.0.4, PHP 5)

gmp_or -- Logical OR

Description

resource gmp_or ( resource a, resource b)

Calculates logical inclusive OR of two GMP numbers.

예 1. gmp_or() example

<?php
$or1 = gmp_or("0xfffffff2", "4");
echo gmp_strval($or1, 16) . "\n";
$or2 = gmp_or("0xfffffff2", "2");
echo gmp_strval($or2, 16) . "\n";
?>

The printout of the above program will be:

fffffff6
fffffff2

이전 | 처음으로 | 다음
gmp_neg | 위로 | gmp_perfect_square


gmp_perfect_square

(PHP 4 >= 4.0.4, PHP 5)

gmp_perfect_square -- Perfect square check

Description

bool gmp_perfect_square ( resource a)

Returns TRUE if a is a perfect square, FALSE otherwise.

예 1. gmp_perfect_square() example

<?php
// 3 * 3, perfect square
var_dump(gmp_perfect_square("9"));

// not a perfect square
var_dump(gmp_perfect_square("7"));

// 1234567890 * 1234567890, perfect square
var_dump(gmp_perfect_square("1524157875019052100"));
?>

The printout of the above program will be:

bool(true)
bool(false)
bool(true)

See also: gmp_sqrt(), gmp_sqrtrm().

이전 | 처음으로 | 다음
gmp_or | 위로 | gmp_popcount


gmp_popcount

(PHP 4 >= 4.0.4, PHP 5)

gmp_popcount -- Population count

Description

int gmp_popcount ( resource a)

Return the population count of a.

예 1. gmp_popcount() example

<?php
$pop1 = gmp_init("10000101", 2); // 3 1's
echo gmp_popcount($pop1) . "\n";
$pop2 = gmp_init("11111110", 2); // 7 1's
echo gmp_popcount($pop2) . "\n";
?>

The printout of the above program will be:

3
7

이전 | 처음으로 | 다음
gmp_perfect_square | 위로 | gmp_pow


gmp_pow

(PHP 4 >= 4.0.4, PHP 5)

gmp_pow -- Raise number into power

Description

resource gmp_pow ( resource base, int exp)

Raise base into power exp. The case of 0^0 yields 1. exp cannot be negative.

예 1. gmp_pow() example

<?php
$pow1 = gmp_pow("2", 31);
echo gmp_strval($pow1) . "\n";
$pow2 = gmp_pow("0", 0);
echo gmp_strval($pow2) . "\n";
$pow3 = gmp_pow("2", -1); // Negative exp, generates warning
echo gmp_strval($pow3) . "\n";
?>

The printout of the above program will be:

2147483648
1

이전 | 처음으로 | 다음
gmp_popcount | 위로 | gmp_powm


gmp_powm

(PHP 4 >= 4.0.4, PHP 5)

gmp_powm -- Raise number into power with modulo

Description

resource gmp_powm ( resource base, resource exp, resource mod)

Calculate (base raised into power exp) modulo mod. If exp is negative, result is undefined.

예 1. gmp_powm() example

<?php
$pow1 = gmp_powm("2", "31", "2147483649");
echo gmp_strval($pow1) . "\n";
?>

The printout of the above program will be:

2147483648

이전 | 처음으로 | 다음
gmp_pow | 위로 | gmp_prob_prime


gmp_prob_prime

(PHP 4 >= 4.0.4, PHP 5)

gmp_prob_prime -- Check if number is "probably prime"

Description

int gmp_prob_prime ( resource a [, int reps])

If this function returns 0, a is definitely not prime. If it returns 1, then a is "probably" prime. If it returns 2, then a is surely prime. Reasonable values of reps vary from 5 to 10 (default being 10); a higher value lowers the probability for a non-prime to pass as a "probable" prime.

The function uses Miller-Rabin's probabilistic test.

예 1. gmp_prob_prime() example

<?php
// definitely not a prime
echo gmp_prob_prime("6") . "\n";

// probably a prime
echo gmp_prob_prime("1111111111111111111") . "\n";

// definitely a prime
echo gmp_prob_prime("11") . "\n";
?>

The printout of the above program will be:

0
1
2

이전 | 처음으로 | 다음
gmp_powm | 위로 | gmp_random


gmp_random

(PHP 4 >= 4.0.4, PHP 5)

gmp_random -- Random number

Description

resource gmp_random ( int limiter)

Generate a random number. The number will be between zero and the number of bits per limb multiplied by limiter. If limiter is negative, negative numbers are generated.

A limb is an internal GMP mechanism. The number of bits in a limb is not static, and can vary from system to system. Generally, the number of bits in a limb is either 16 or 32, but this is not guaranteed.

예 1. gmp_random() example

<?php
$rand1 = gmp_random(1); // random number from 0 to 1 * bits per limb
$rand2 = gmp_random(2); // random number from 0 to 2 * bits per limb

echo gmp_strval($rand1) . "\n";
echo gmp_strval($rand2) . "\n";
?>

The printout of the above program might be:

1915834968
8642564075890328087

이전 | 처음으로 | 다음
gmp_prob_prime | 위로 | gmp_scan0


gmp_scan0

(PHP 4 >= 4.0.4, PHP 5)

gmp_scan0 -- Scan for 0

Description

int gmp_scan0 ( resource a, int start)

Scans a, starting with bit start, towards more significant bits, until the first clear bit is found. Returns the index of the found bit. The index starts from 0.

예 1. gmp_scan0() example

<?php
// "0" bit is found at position 3. index starts at 0
$s1 = gmp_init("10111", 2);
echo gmp_scan0($s1, 0) . "\n";

// "0" bit is found at position 7. index starts at 5
$s2 = gmp_init("101110000", 2);
echo gmp_scan0($s2, 5) . "\n";
?>

The printout of the above program will be:

3
7

이전 | 처음으로 | 다음
gmp_random | 위로 | gmp_scan1


gmp_scan1

(PHP 4 >= 4.0.4, PHP 5)

gmp_scan1 -- Scan for 1

Description

int gmp_scan1 ( resource a, int start)

Scans a, starting with bit start, towards more significant bits, until the first set bit is found. Returns the index of the found bit. If no set bit is found, -1 is returned.

예 1. gmp_scan1() example

<?php
// "1" bit is found at position 3. index starts at 0
$s1 = gmp_init("01000", 2);
echo gmp_scan1($s1, 0) . "\n";

// "1" bit is found at position 9. index starts at 5
$s2 = gmp_init("01000001111", 2);
echo gmp_scan1($s2, 5) . "\n";
?>

The printout of the above program will be:

3
9

이전 | 처음으로 | 다음
gmp_scan0 | 위로 | gmp_setbit


gmp_setbit

(PHP 4 >= 4.0.4, PHP 5)

gmp_setbit -- Set bit

Description

void gmp_setbit ( resource &a, int index [, bool set_clear])

Sets bit index in a. set_clear defines if the bit is set to 0 or 1. By default the bit is set to 1. Index starts at 0.

참고: Unlike most of the other GMP functions, gmp_setbit() must be called with a GMP resource that already exists (using gmp_init() for example). One will not be automatically created.

예 1. gmp_setbit() example

<?php
$a = gmp_init("0xfd");
gmp_setbit($a, 1); // index starts at 0
echo gmp_strval($a) . "\n";
?>

The printout of the above program will be:

255

See also gmp_clrbit().

이전 | 처음으로 | 다음
gmp_scan1 | 위로 | gmp_sign


gmp_sign

(PHP 4 >= 4.0.4, PHP 5)

gmp_sign -- Sign of number

Description

int gmp_sign ( resource a)

Returns 1 if a is positive, -1 if a is negative, and 0 if a is zero.

예 1. gmp_sign() example

<?php
// positive
echo gmp_sign("500") . "\n";

// negative
echo gmp_sign("-500") . "\n";

// zero
echo gmp_sign("0") . "\n";
?>

The printout of the above program will be:

1
-1
0

이전 | 처음으로 | 다음
gmp_setbit | 위로 | gmp_sqrt


gmp_sqrt

(PHP 4 >= 4.0.4, PHP 5)

gmp_sqrt -- Calculate square root

Description

resource gmp_sqrt ( resource a)

Calculates square root of a and returns the integer portion of the result.

예 1. gmp_sqrt() example

<?php
$sqrt1 = gmp_sqrt("9");
$sqrt2 = gmp_sqrt("7");
$sqrt3 = gmp_sqrt("1524157875019052100");

echo gmp_strval($sqrt1) . "\n";
echo gmp_strval($sqrt2) . "\n";
echo gmp_strval($sqrt3) . "\n";
?>

The printout of the above program will be:

3
2
1234567890

이전 | 처음으로 | 다음
gmp_sign | 위로 | gmp_sqrtrem


gmp_sqrtrem

(PHP 4 >= 4.0.4, PHP 5)

gmp_sqrtrem -- Square root with remainder

Description

array gmp_sqrtrem ( resource a)

Returns array where first element is the integer square root of a (see also gmp_sqrt()), and the second is the remainder (i.e., the difference between a and the first element squared).

예 1. gmp_sqrtrem() example

<?php
list($sqrt1, $sqrt1rem) = gmp_sqrtrem("9");
list($sqrt2, $sqrt2rem) = gmp_sqrtrem("7");
list($sqrt3, $sqrt3rem) = gmp_sqrtrem("1048576");

echo gmp_strval($sqrt1) . ", " . gmp_strval($sqrt1rem) . "\n";
echo gmp_strval($sqrt2) . ", " . gmp_strval($sqrt2rem) . "\n";
echo gmp_strval($sqrt3) . ", " . gmp_strval($sqrt3rem) . "\n";
?>

The printout of the above program will be:

3, 0
2, 3
1024, 0

이전 | 처음으로 | 다음
gmp_sqrt | 위로 | gmp_strval


gmp_strval

(PHP 4 >= 4.0.4, PHP 5)

gmp_strval -- Convert GMP number to string

Description

string gmp_strval ( resource gmpnumber [, int base])

Convert GMP number to string representation in base base. The default base is 10. Allowed values for the base are from 2 to 36.

예 1. Converting a GMP number to a string

<?php
$a = gmp_init("0x41682179fbf5");
printf("Decimal: %s, 36-based: %s", gmp_strval($a), gmp_strval($a,36));
?>

이전 | 처음으로 | 다음
gmp_sqrtrem | 위로 | gmp_sub


gmp_sub

(PHP 4 >= 4.0.4, PHP 5)

gmp_sub -- Subtract numbers

Description

resource gmp_sub ( resource a, resource b)

Subtracts b from a and returns the result.

예 1. gmp_sub() example

<?php
$sub = gmp_sub("281474976710656", "4294967296"); // 2^48 - 2^32
echo gmp_strval($sub) . "\n";
?>

The printout of the above program will be:

281470681743360

이전 | 처음으로 | 다음
gmp_strval | 위로 | gmp_xor


gmp_xor

(PHP 4 >= 4.0.4, PHP 5)

gmp_xor -- Logical XOR

Description

resource gmp_xor ( resource a, resource b)

Calculates logical exclusive OR (XOR) of two GMP numbers.

예 1. gmp_xor() example

<?php
$xor1 = gmp_init("1101101110011101", 2);
$xor2 = gmp_init("0110011001011001", 2);

$xor3 = gmp_xor($xor1, $xor2);

echo gmp_strval($xor3, 2) . "\n";
?>

The printout of the above program will be:

1011110111000100

이전 | 처음으로 | 다음
gmp_sub | 위로 | HTTP 함수


HTTP 함수

PHP 매뉴얼
이전 다음

XXXVII. HTTP 함수

소개

이 함수들은 HTTP 프로토콜 단계에서 원격 브라우저로 출력을 다루게 합니다.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
header -- raw HTTP 헤더를 전송합니다.
headers_list -- 전송한 (혹은 대기중의) 응답 헤더 목록을 반환합니다.
headers_sent -- 헤더 전송 여부를 확인합니다.
setcookie -- 쿠키를 전송합니다.
setrawcookie -- Send a cookie without urlencoding the cookie value

이전 | 처음으로 | 다음
gmp_xor | 위로 | header


header

(PHP 3, PHP 4 , PHP 5)

header -- raw HTTP 헤더를 전송합니다.

설명

void header ( string string [, bool replace [, int http_response_code]])

header()은 raw HTTP 헤더를 전송하기 위해 사용합니다. HTTP 헤더에 관한 자세한 정보는 HTTP/1.1 규격을 참고하십시오.

선택적인 replace 인자는 이전의 동일한 헤더를 교체할지, 혹은 같은 형의 두번째 헤더로 덧붙일 것일지를 지시합니다. 기본값은 교체이지만, 두번째 인자로 FALSE를 넘겨서 같은 형을 가지는 복수의 헤더를 지시할 수 있습니다. 예를 들면:

<?php
header('WWW-Authenticate: Negotiate');
header('WWW-Authenticate: NTLM', false);
?>

두번째 선택적인 http_resopnse_code는 HTTP 응답 코드를 지정한 값으로 강제합니다. (이 인자는 PHP 4.3.0 이상에서 사용할 수 있습니다)

두가지 특별한 헤더 호출이 존재합니다. 첫번째는 문자열 "HTTP/"(대소문자 구별 없음)으로 시작하는, HTTP 상태 코드를 출력하기 위해 사용하는 헤더입니다. 예를 들어, 아파치에서 존재하지 않는 파일들에 대한 요청을 (ErrorDocument 지시어를 사용하여) PHP 스크립트로 처리하게 했다면, 스크립트가 정확한 상태 코드를 출력하도록 할 수 있습니다.

<?php
header("HTTP/1.0 404 Not Found");
?>

참고: header() 호출이 처음이건 아니건에 관계 없이, HTTP 상태 헤더줄은 클라이언트에게 항상 처음으로 전송해야 합니다. HTTP 헤더가 전송되기 전에는 어떤 때라도 header()을 호출하여 상태를 덮어쓸 수 있습니다.

참고: PHP 3에서, 이 방법은 PHP를 아파치 모듈로 컴파일 했을 때만 작동했습니다. Status 헤더를 이용하여 같은 효과를 얻을 수 있습니다.

<?php
header("Status: 404 Not Found");
?>

두번째 특별한 경우는 "Location:" 헤더입니다. 이 헤더만을 전송할 뿐이 아니라, 이전에 3xx 상태 코드를 설정하지 않았다면 REDIERCT (302) 상태 코드를 브라우저에 반환합니다.

<?php
header("Location: http://www.example.com/"); /* 브라우저 리다이렉트 */

/* 이 아래의 코드는 리다이렉트 되었을때는 실행되지 않습니다. */
exit;
?>

참고: HTTP/1.1은 Location:의 인자로 scheme, hostname, 절대 경로를 포함하는 절대 URI를 요구하고 있지만, 일부 클라이언트는 상대 URI도 받아들입니다. 일반적으로 $_SERVER['HTTP_HOST'], $_SERVER['PHP_SELF'], dirname()을 사용하여 상대 경로에서 절대 경로를 만들 수 있습니다:

<?php
header("Location: http://".$_SERVER['HTTP_HOST']
                      . dirname($_SERVER['PHP_SELF'])
                      . "/" . $relative_url);
?>

PHP 스크립트는 종종 서버와 클라이언트 브라우저 사이에서 어떠한 프록시, 혹은 클라이언트 브라우가 캐쉬를 해서는 안되는 동적인 내용을 생성합니다. 이 함수로 여러 프록시와 클라이언트에서 캐쉬를 비활성화할 수 있습니다:

<?php
// 과거의 날짜
header("Expires: Mon, 26 Jul 1997 05:00:00 GMT");

// 항상 변경됨
header("Last-Modified: " . gmdate("D, d M Y H:i:s") . " GMT");

// HTTP/1.1
header("Cache-Control: no-store, no-cache, must-revalidate");
header("Cache-Control: post-check=0, pre-check=0", false);

// HTTP/1.0
header("Pragma: no-cache");
?>

참고: 페이지가 위의 모든 헤더를 출력하지 않아도 캐쉬가 되지 않을 수는 있습니다. 사용자 브라우저의 기본 캐쉬 방침을 바꿀 수 있는 수많은 옵션이 존재합니다. 위의 헤더들을 전송해서, 모든 설정을 덮어씌울 필요가 있습니다. 그렇지 않으면, 스크립트의 출력을 캐쉬할 수도 있습니다.

추가적으로, session_cache_limiter()와 session.cache_limiter 설정으로 세션을 사용할 때 자동적으로 적합한 캐쉬 관련 헤더를 생성할 수 있습니다.

header()는 보통의 HTML 태그, 파일의 빈 줄, PHP 생성을 포함한 모든 출력을 전송하기 전에 호출해야 합니다. header() 호출이 이루어지기 전에 include(), require(), 혹은 다른 파일 접근 함수를 이용할 때, 공백이나 빈 줄을 출력하는 것은 매우 자주 발생하는 오류입니다. 이와 같은 문제는 하나의 PHP/HTML 파일을 사용할 때도 존재합니다.

<html>
<?php
/* 에러가 납니다. header() 호출 전에
* 위의 출력이 있는 점에 주의하십시오. */
header('Location: http://www.example.com/');
?>

참고: PHP 4에서, 전송하기 전까지 브라우저에 대한 모든 출력 오버헤드를 서버 버퍼에 넣는 출력 버퍼링을 사용하여 이 함수를 호출 하기 전에 출력을 보낼 수 있습니다. 스크립트에서 ob_start()와 ob_end_flush()를 호출하거나, php.ini나 서버 설정 파일에서 output_buffering을 설정해서 이를 사용할 수 있습니다.

사용자에게 생성한 PDF 파일 등의 전송한 데이터를 저장할지 묻도록 하려면, Content-Disposition 헤더로 권장하는 파일명을 제공하여 브라우저가 저장 다이얼로그를 표시하도록 할 수 있습니다.

<?php
// PDF를 출력합니다.
header('Content-type: application/pdf');

// download.pdf로 불립니다.
header('Content-Disposition: attachment; filename="downloaded.pdf"');

// PDF 소스는 original.pdf
readfile('original.pdf');
?>

참고: Microsoft Internet Explorer 4.01은 버그로 인해 작동하지 않습니다. 해결책은 없습니다. Microsoft Internet Explorer 5.5 역시 이를 다루는 부분에 버그가 존재하며, 서비스팩 2 이후로 업그레이드해서 해결할 수 있습니다.

참고: 안전모드에서 WWW-Authenticate 헤더(HTTP 인증에 사용)를 설정하면 스크립트의 uid가 realm 부분에 추가됩니다.

참고: headers_sent(), setcookie(), HTTP 인증 섹션.

이전 | 처음으로 | 다음
HTTP 함수 | 위로 | headers_list


headers_list

(PHP 5)

headers_list -- 전송한 (혹은 대기중의) 응답 헤더 목록을 반환합니다.

설명

array headers_list ( void )

headers_list()는 브라우저/클라이언트에 전송한 헤더를 숫자 인덱스 배열로 반환합니다. 헤더가 이미 전송되었는지를 확인하려면, headers_send()를 사용하십시오.

예 1. headers_list() 사용 예제

<?php

/* setcookie()는 자신의 응답 헤더를 추가합니다. */
setcookie('foo', 'bar');

/* 사용자 응답 헤더를 정의합니다.
   이는 대부분의 클라이언트에서 무시됩니다. */
header("X-Sample-Test: foo");

/* 응답은 평문 내용임을 지정합니다. */
header('Content-type: text/plain');

/* 어떤 헤더를 전송하였을까요? */
var_dump(headers_list());
?>

/* 출력
   ====

출력은:

array(4) {
  [0]=>
  string(29) "X-Powered-By: PHP/5.0.0"
  [1]=>
  string(19) "Set-Cookie: foo=bar"
  [2]=>
  string(18) "X-Sample-Test: foo"
  [3]=>
  string(24) "Content-type: text/plain"
}

참고:
headers_sent(),
header(),
setcookie().

이전 | 처음으로 | 다음
header | 위로 | headers_sent


headers_sent

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

headers_sent -- 헤더 전송 여부를 확인합니다.

설명

bool headers_sent ( [string &file [, int &line]])

headers_sent()는 어떠한 HTTP 헤더도 전송하지 않았다면 FALSE를 반환하고, 그 외의 경우에는 TRUE를 반환합니다. 선택적인 file과 line 인자를 설정하면, headers_sent()는 file과 line 변수에 출력을 시작한 PHP 소스 파일 이름과 줄 번호를 넣습니다.

헤더 블록이 한번 전송되면 더 이상 header() 함수를 사용하여 헤더를 추가할 수 없습니다. 이 함수를 사용하여 HTTP 헤더 관련 에러 메세지를 방지할 수 있습니다. 다른 옵션은 출력 버퍼링을 사용하는 것입니다.

참고: 선택적인 file과 line 인자는 PHP 4.3.0에서 추가되었습니다.

예 1. headers_sent() 사용 예제

<?php

// 헤더가 전송되지 않았으면, 하나를 보냅니다.
if (!headers_sent()) {
    header('Location: http://www.example.com/');
    exit;
}

// PHP 4.3.0부터의 선택적인 file과 line 인자 사용 예제.
// $filename과 $linenum은 이후의 사용하는 점에 주의하십시오.
// 그에 앞서 값을 지정하지 마십시오.
if (!headers_sent($filename, $linenum)) {
    header('Location: http://www.example.com/');
    exit;

// 여기에서 에러 처리를 할 수 있습니다.
} else {

    echo "헤더는 이미 $filename의 $linenum줄에서 보내졌습니다.\n" .
         "리다이렉트 할 수 없습니다, 대신 이 <a " .
         "href=\"http://www.example.com\">링크</a>를 클릭하십시오.\n";
    exit;
}

?>

참고: 위 문제에 대한 더욱 자세한 내용은 ob_start(), trigger_error(), header()에 존재합니다.

이전 | 처음으로 | 다음
headers_list | 위로 | setcookie


setcookie

(PHP 3, PHP 4 , PHP 5)

setcookie -- 쿠키를 전송합니다.

설명

bool setcookie ( string name [, string value [, int expire [, string path [, string domain [, int secure]]]]])

setcookie()는 HTTP 헤더에 쿠키를 전송하도록 설정합니다. 다른 헤더와 마찬가지로, 쿠키는 스크립트의 다른 출력에 앞서서 보내져야 합니다. (이는 프로토콜 제한입니다) <html>, <head> 태그뿐이 아니라, 공백을 포함한 어떠한 출력보다 앞서서 호출할 필요가 있습니다. 이 함수를 호출하기 전에 출력이 존재하면, setcookie()는 실패하고 FALSE를 반환합니다. setcookie()이 성공적으로 작동하면, TRUE를 반환합니다. 이는 사용자가 쿠키를 허용했는가를 의미하는 것은 아닙니다.

참고: PHP 4에서, 전송하기 전까지 브라우저에 대한 모든 출력 오버헤드를 서버 버퍼에 넣는 출력 버퍼링을 사용하여 이 함수를 호출 하기 전에 출력을 보낼 수 있습니다. 스크립트에서 ob_start()와 ob_end_flush()를 호출하거나, php.ini나 서버 설정 파일에서 output_buffering을 설정해서 이를 사용할 수 있습니다.

name 인자를 제외한 모든 인자는 선택적입니다. 어떠한 인자를 교체할 때, 빈 문자열("")을 사용하여 다른 인자들을 넘어갈 수 있습니다. expire와 secure 인자는 정수형이기 때문에, 빈 문자열로 넘어갈 수 없고, 대신 제로(0를 사용합니다. 다음 표는 setcookie() 함수의 각 인자를 설명합니다. 각각의 setcookie() 인자가 어떻게 작동하는지에 대한 정의는 넷스케이프 쿠키 규격를 읽어보고, HTTP 쿠키 작동에 대한 추가 정보는 RFC 2965를 읽어보십시오.

표 1. setcookie() 인자 설명

인자 | 설명 | 예제
name | 쿠키의 이름. | 'cookiename'은 $_COOKIE['cookiename']으로 호출합니다.
value | 쿠키의 값. 이 값은 클라이언트 컴퓨터에 저장됩니다; 민감한 정보를 저장하지 마십시오. | name이 'cookiename'이라면, 이 값은 $_COOKIE['cookiename']을 통해서 얻어집니다.
expire | 쿠키 만료 시간. 에포치로부터의 초수를 나타내는 유닉스 타임스탬프입니다. 보통, time() 함수에 원하는 만료 시간을 더해서 설정합니다. 혹은 mktime()을 사용할 수 있습니다. | time()+60*60*24*30은 쿠키가 30일 후에 만료하도록 합니다. 지정하지 않으면, 쿠키는 세션 종료시(브라우저를 닫을 때)에 만료됩니다.
path | 이 쿠키를 사용할 수 있는 서버 경로. | '/'로 지정하면, 이 쿠키는 domain 전체에서 사용할 수 있습니다. '/foo/'로 설정하면, domain의 /foo/ 디렉토리 안과 /foo/bar/ 등의 서브 디렉토리 안에서 사용할 수 있습니다. 기본값은 쿠키를 설정하는 현재 디렉토리입니다.
domain | 이 쿠키를 사용할 수 있는 도메인. | example.com의 모든 서브도메인에서 이 쿠키를 사용할 수 있게 하려면, '.example.com'로 설정해야 합니다. .은 필수는 아니지만, 많은 브라우저와 호환되게 합니다. www.example.com로 지정하면, 이 쿠키는 www 서브도메인에서만 사용할 수 있습니다. 상세는 규격의 tail matching을 참고하십시오.
secure | 쿠키가 보안 HTTPS 접속에만 허용할 지를 지정합니다. 1로 설정하면, 쿠키는 보안 연결이 존재할 때만 설정됩니다. 기본값은 0입니다. | 0이나 1

쿠키를 한번 설정하면, 다음 페이지 로드에서 $_COOKIE나 $HTTP_COOKIE_VARS 배열을 통해서 접근할 수 있습니다. $_COOKIE과 같은 자동 전역은 PHP 4.1.0부터 사용할 수 있는 점에 주의하십시오. $HTTP_COOKIE_VARS은 PHP 3부터 존재해왔습니다. 쿠키값은 $_REQUEST에도 존재합니다.

참고: PHP 지시어 register_globals를 on으로 설정하면 쿠키값은 변수로도 만들어집니다. 아래의 예제에서, $TextCookie이 존재합니다. $_COOKIE을 사용하기를 권장합니다.

일반적인 함정:

  • 쿠키가 보여져야하는 페이지에서 쿠키는 다음 로딩까지 보여지지 않습니다. 시험해보기 위해서는 쿠키를 성공적으로 설정하면, 쿠키가 만료하기 전에 다음 로딩 페이지에서 쿠키를 확인해보십시오. 만료 시간은 expire로 지정합니다. 쿠키 존재를 디버그하는 좋은 방법은 간단히 print_r($_COOKIE);를 호출해보는 것입니다.

  • 쿠키는 지정할때와 동일한 인자로 삭제해야 합니다. 값 인자가 빈 문자열("")이고, 다른 모든 인자가 이전의 setcookie 호출과 동일하다면, 지정한 이름의 쿠키는 원격 클라이언트에서 삭제됩니다.

  • 쿠키 이름은 배열로 지정할 수 있고 PHP 스크립트에서 배열로 사용할 수 있지만, 각각의 쿠키는 사용자 시스템에 저장됩니다. 복수의 이름과 값을 가지는 쿠키를 지정하기 위해서는 explode()나 serialize()의 사용을 고려하십시오.

PHP 3에서, 동일한 스크립트에서 복수의 setcookie() 호출은 역순으로 실행되었습니다. 하나의 쿠키를 지우고 다른 것을 설정하려면 삭제하기 전에 추가를 놓았어야만 합니다. PHP 4에서는, setcookie()의 복수 호출은 호출한 순서에 따라 처리합니다.

쿠키를 보내는 몇가지 예제:

예 1. setcookie() 전송 예제

<?php
$value = 'something from somewhere';

setcookie("TestCookie", $value);
setcookie("TestCookie", $value,time()+3600);  /* 1시간 뒤에 만료 */
setcookie("TestCookie", $value,time()+3600, "/~rasmus/", ".example.com", 1);
?>

쿠키 값은 쿠키를 전송할때 자동적으로 URL 인코드하고, 받을때 자동적으로 디코드해서 쿠키 이름과 같은 이름을 가지는 변수로 연결되는 점에 주의하십시오. 이 작동을 피하고 싶다면, PHP 5에서 setrawcookie()를 사용할 수 있습니다. 스크립트 안에서 쿠키의 내용을 보려면, 다음 예제 중 하나를 사용하십시오:

<?php
// 개별 쿠키의 출력
echo $_COOKIE["TestCookie"];
echo $HTTP_COOKIE_VARS["TestCookie"];

// 모든 쿠키를 보는 디버그/테스트 방법
print_r($_COOKIE);
?>

쿠키를 삭제할때, 브라우저가 삭제 메카니즘을 작동하도록 만료 날짜를 과거로 지정해야만 합니다. 이전의 예제에서 보낸 쿠키를 삭제하는 예제입니다:

예 2. setcookie() 삭제 예제

<?php
// 만료 날짜를 한시간전으로 설정
setcookie ("TestCookie", "", time() - 3600);
setcookie ("TestCookie", "", time() - 3600, "/~rasmus/", ".example.com", 1);
?>

쿠키 이름에 배열 첨자를 사용해서 배열 쿠키를 설정할 수 있습니다. 배열 요소의 수 만큼의 쿠키를 설정하는 효과를 가지고, 쿠키가 스크립트에 받아들여질때, 값은 쿠키 이름의 배열 안에 위치하게 됩니다:

예 3. setcookie()와 배열

<?php
// 쿠키를 설정
setcookie("cookie[three]", "cookiethree");
setcookie("cookie[two]", "cookietwo");
setcookie("cookie[one]", "cookieone");

// 페이지가 리로드된 뒤에, 출력
if (isset($_COOKIE['cookie'])) {
    foreach ($_COOKIE['cookie'] as $name => $value) {
        echo "$name : $value <br />\n";
    }
}
?>

출력은

three : cookiethree
two : cookietwo
one : cookieone

참고: 쿠키에 관한 상세한 정보는 http://www.netscape.com/newsref/std/cookie_spec.html의 넷스케이프 쿠키 규격과 RFC 2965를 참고하십시오.

참고 문서에 따르면 expire 인자는 유닉스 타임스탬프가 아닌, Wdy, DD-Mon-YYYY HH:MM:SS GMT 날짜 형식이여야 합니다. 이는 PHP가 내부적으로 변환을 하기 때문입니다.

참고: Microsoft Internet Explorer 4 서비스팩 1은 path 인자가 지정되었을 때 쿠키를 정상적으로 처리하지 못합니다.

넷스케이프 커뮤니케이터 4.05와 Microsoft Internet Explorer 3.x는 경로와 시간을 설정하지 않았을 때 쿠키를 비정상적으로 처리합니다.

참고: header(), setrawcookie(), 쿠키 섹션.

이전 | 처음으로 | 다음
headers_sent | 위로 | setrawcookie


setrawcookie

(PHP 5)

setrawcookie -- Send a cookie without urlencoding the cookie value

Description

bool setrawcookie ( string name [, string value [, int expire [, string path [, string domain [, int secure]]]]])

setrawcookie() is exactly the same as setcookie() except that the cookie value will not automaticall be urlencoded when send to the browser.

See also header(), setcookie() and the cookies section.

이전 | 처음으로 | 다음
setcookie | 위로 | Hyperwave Functions


Hyperwave Functions

PHP 매뉴얼
이전 다음

XXXVIII. Hyperwave Functions

소개

Hyperwave has been developed at IICM in Graz. It started with the name Hyper-G and changed to Hyperwave when it was commercialised (in 1996).

Hyperwave is not free software. The current version, 5.5 is available at http://www.hyperwave.com/. A time limited version can be ordered for free (30 days).

See also the Hyperwave API module.

Hyperwave is an information system similar to a database (HIS, Hyperwave Information Server). Its focus is the storage and management of documents. A document can be any possible piece of data that may as well be stored in file. Each document is accompanied by its object record. The object record contains meta data for the document. The meta data is a list of attributes which can be extended by the user. Certain attributes are always set by the Hyperwave server, other may be modified by the user. An attribute is a name/value pair of the form name=value. The complete object record contains as many of those pairs as the user likes. The name of an attribute does not have to be unique, e.g. a title may appear several times within an object record. This makes sense if you want to specify a title in several languages. In such a case there is a convention, that each title value is preceded by the two letter language abbreviation followed by a colon, e.g. 'en:Title in English' or 'ge:Titel in deutsch'. Other attributes like a description or keywords are potential candidates. You may also replace the language abbreviation by any other string as long as it separated by colon from the rest of the attribute value.

Each object record has native a string representation with each name/value pair separated by a newline. The Hyperwave extension also knows a second representation which is an associated array with the attribute name being the key. Multilingual attribute values itself form another associated array with the key being the language abbreviation. Actually any multiple attribute forms an associated array with the string left to the colon in the attribute value being the key. (This is not fully implemented. Only the attributes Title, Description and Keyword are treated properly yet.)

Besides the documents, all hyper links contained in a document are stored as object records as well. Hyper links which are in a document will be removed from it and stored as individual objects, when the document is inserted into the database. The object record of the link contains information about where it starts and where it ends. In order to gain the original document you will have to retrieve the plain document without the links and the list of links and reinsert them. The functions hw_pipedocument() and hw_gettext() do this for you. The advantage of separating links from the document is obvious. Once a document to which a link is pointing to changes its name, the link can easily be modified accordingly. The document containing the link is not affected at all. You may even add a link to a document without modifying the document itself.

Saying that hw_pipedocument() and hw_gettext() do the link insertion automatically is not as simple as it sounds. Inserting links implies a certain hierarchy of the documents. On a web server this is given by the file system, but Hyperwave has its own hierarchy and names do not reflect the position of an object in that hierarchy. Therefore creation of links first of all requires a mapping from the Hyperwave hierarchy and namespace into a web hierarchy respective web namespace. The fundamental difference between Hyperwave and the web is the clear distinction between names and hierarchy in Hyperwave. The name does not contain any information about the objects position in the hierarchy. In the web the name also contains the information on where the object is located in the hierarchy. This leads to two possibles ways of mapping. Either the Hyperwave hierarchy and name of the Hyperwave object is reflected in the URL or the name only. To make things simple the second approach is used. Hyperwave object with name my_object is mapped to http://host/my_object disregarding where it resides in the Hyperwave hierarchy. An object with name parent/my_object could be the child of my_object in the Hyperwave hierarchy, though in a web namespace it appears to be just the opposite and the user might get confused. This can only be prevented by selecting reasonable object names.

Having made this decision a second problem arises. How do you involve PHP? The URL http://host/my_object will not call any PHP script unless you tell your web server to rewrite it to e.g. http://host/php_script/my_object and the script php_script evaluates the $PATH_INFO variable and retrieves the object with name my_object from the Hyperwave server. Their is just one little drawback which can be fixed easily. Rewriting any URL would not allow any access to other document on the web server. A PHP script for searching in the Hyperwave server would be impossible. Therefore you will need at least a second rewriting rule to exclude certain URLs like all e.g. starting with http://host/Hyperwave This is basically sharing of a namespace by the web and Hyperwave server.

Based on the above mechanism links are insert into documents.

It gets more complicated if PHP is not run as a server module or CGI script but as a standalone application e.g. to dump the content of the Hyperwave server on a CD-ROM. In such a case it makes sense to retain the Hyperwave hierarchy and map in onto the file system. This conflicts with the object names if they reflect its own hierarchy (e.g. by choosing names including '/'). Therefore '/' has to be replaced by another character, e.g. '_'.

The network protocol to communicate with the Hyperwave server is called HG-CSP (Hyper-G Client/Server Protocol). It is based on messages to initiate certain actions, e.g. get object record. In early versions of the Hyperwave Server two native clients (Harmony, Amadeus) were provided for communication with the server. Those two disappeared when Hyperwave was commercialised. As a replacement a so called wavemaster was provided. The wavemaster is like a protocol converter from HTTP to HG-CSP. The idea is to do all the administration of the database and visualisation of documents by a web interface. The wavemaster implements a set of placeholders for certain actions to customise the interface. This set of placeholders is called the PLACE Language. PLACE lacks a lot of features of a real programming language and any extension to it only enlarges the list of placeholders. This has led to the use of JavaScript which IMO does not make life easier.

Adding Hyperwave support to PHP should fill in the gap of a missing programming language for interface customisation. It implements all the messages as defined by the HG-CSP but also provides more powerful commands to e.g. retrieve complete documents.

Hyperwave has its own terminology to name certain pieces of information. This has widely been taken over and extended. Almost all functions operate on one of the following data types.

  • object ID: An unique integer value for each object in the Hyperwave server. It is also one of the attributes of the object record (ObjectID). Object ids are often used as an input parameter to specify an object.

  • object record: A string with attribute-value pairs of the form attribute=value. The pairs are separated by a carriage return from each other. An object record can easily be converted into an object array with hw_object2array(). Several functions return object records. The names of those functions end with obj.

  • object array: An associative array with all attributes of an object. The keys are the attribute names. If an attribute occurs more than once in an object record it will result in another indexed or associative array. Attributes which are language depended (like the title, keyword, description) will form an associative array with the keys set to the language abbreviations. All other multiple attributes will form an indexed array. PHP functions never return object arrays.

  • hw_document: This is a complete new data type which holds the actual document, e.g. HTML, PDF etc. It is somewhat optimized for HTML documents but may be used for any format.

Several functions which return an array of object records do also return an associative array with statistical information about them. The array is the last element of the object record array. The statistical array contains the following entries:

Hidden

Number of object records with attribute PresentationHints set to Hidden.

CollectionHead

Number of object records with attribute PresentationHints set to CollectionHead.

FullCollectionHead

Number of object records with attribute PresentationHints set to FullCollectionHead.

CollectionHeadNr

Index in array of object records with attribute PresentationHints set to CollectionHead.

FullCollectionHeadNr

Index in array of object records with attribute PresentationHints set to FullCollectionHead.

Total

Total: Number of object records.

요구 사항

This extension needs a Hyperwave server downloadable from http://www.hyperwave.com/.

설치

To enable Hyperwave support compile PHP --with-hyperwave.

Integration with Apache

The Hyperwave extension is best used when PHP is compiled as an Apache module. In such a case the underlying Hyperwave server can be hidden from users almost completely if Apache uses its rewriting engine. The following instructions will explain this.

Since PHP with Hyperwave support built into Apache is intended to replace the native Hyperwave solution based on Wavemaster, we will assume that the Apache server will only serve as a Hyperwave web interface for these examples. This is not necessary but it simplifies the configuration. The concept is quite simple. First of all you need a PHP script which evaluates the $_ENV['PATH_INFO'] variable and treats its value as the name of a Hyperwave object. Let's call this script 'Hyperwave'. The URL http://your.hostname/Hyperwave/name_of_object would than return the Hyperwave object with the name 'name_of_object'. Depending on the type of the object the script has to react accordingly. If it is a collection, it will probably return a list of children. If it is a document it will return the mime type and the content. A slight improvement can be achieved if the Apache rewriting engine is used. From the users point of view it would be more straight forward if the URL http://your.hostname/name_of_object would return the object. The rewriting rule is quite easy:

RewriteRule ^/(.*) /usr/local/apache/htdocs/HyperWave/$1 [L]

Now every URL relates to an object in the Hyperwave server. This causes a simple to solve problem. There is no way to execute a different script, e.g. for searching, than the 'Hyperwave' script. This can be fixed with another rewriting rule like the following:

RewriteRule ^/hw/(.*) /usr/local/apache/htdocs/hw/$1 [L]

This will reserve the directory /usr/local/apache/htdocs/hw for additional scripts and other files. Just make sure this rule is evaluated before the one above. There is just a little drawback: all Hyperwave objects whose name starts with 'hw/' will be shadowed. So, make sure you don't use such names. If you need more directories, e.g. for images just add more rules or place them all in one directory. Before you put those instructions, don't forget to turn on the rewriting engine with

RewriteEngine on

You will need scripts:

  • to return the object itself

  • to allow searching

  • to identify yourself

  • to set your profile

  • one for each additional function like to show the object attributes, to show information about users, to show the status of the server, etc.

As an alternative to the Rewrite Engine, you can also consider using the Apache ErrorDocument directive, but be aware, that ErrorDocument redirected pages cannot receive POST data.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. Hyperwave configuration options

Name | Default | Changeable
hyperwave.allow_persistent | "0" | PHP_INI_SYSTEM
hyperwave.default_port | "418" | PHP_INI_ALL
For further details and definition of the PHP_INI_* constants see ini_set().

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

HW_ATTR_LANG (integer)

HW_ATTR_NR (integer)

HW_ATTR_NONE (integer)

Todo

There are still some things to do:

  • The hw_InsertDocument has to be split into hw_insertobject() and hw_putdocument().

  • The names of several functions are not fixed, yet.

  • Most functions require the current connection as its first parameter. This leads to a lot of typing, which is quite often not necessary if there is just one open connection. A default connection will improve this.

  • Conversion form object record into object array needs to handle any multiple attribute.

차례
hw_Array2Objrec -- convert attributes from object array to object record
hw_changeobject -- Changes attributes of an object (obsolete)
hw_Children -- object ids of children
hw_ChildrenObj -- object records of children
hw_Close -- closes the Hyperwave connection
hw_Connect -- opens a connection
hw_connection_info -- Prints information about the connection to Hyperwave server
hw_cp -- Copies objects
hw_Deleteobject -- deletes object
hw_DocByAnchor -- object id object belonging to anchor
hw_DocByAnchorObj -- object record object belonging to anchor
hw_Document_Attributes -- object record of hw_document
hw_Document_BodyTag -- body tag of hw_document
hw_Document_Content -- returns content of hw_document
hw_Document_SetContent -- sets/replaces content of hw_document
hw_Document_Size -- size of hw_document
hw_dummy -- Hyperwave dummy function
hw_EditText -- retrieve text document
hw_Error -- error number
hw_ErrorMsg -- returns error message
hw_Free_Document -- frees hw_document
hw_GetAnchors -- object ids of anchors of document
hw_GetAnchorsObj -- object records of anchors of document
hw_GetAndLock -- return object record and lock object
hw_GetChildColl -- object ids of child collections
hw_GetChildCollObj -- object records of child collections
hw_GetChildDocColl -- object ids of child documents of collection
hw_GetChildDocCollObj -- object records of child documents of collection
hw_GetObject -- object record
hw_GetObjectByQuery -- search object
hw_GetObjectByQueryColl -- search object in collection
hw_GetObjectByQueryCollObj -- search object in collection
hw_GetObjectByQueryObj -- search object
hw_GetParents -- object ids of parents
hw_GetParentsObj -- object records of parents
hw_getrellink -- Get link from source to dest relative to rootid
hw_GetRemote -- Gets a remote document
hw_getremotechildren -- Gets children of remote document
hw_GetSrcByDestObj -- Returns anchors pointing at object
hw_GetText -- retrieve text document
hw_getusername -- name of currently logged in user
hw_Identify -- identifies as user
hw_InCollections -- check if object ids in collections
hw_Info -- info about connection
hw_InsColl -- insert collection
hw_InsDoc -- insert document
hw_insertanchors -- Inserts only anchors into text
hw_InsertDocument -- upload any document
hw_InsertObject -- inserts an object record
hw_mapid -- Maps global id on virtual local id
hw_Modifyobject -- modifies object record
hw_mv -- Moves objects
hw_New_Document -- create new document
hw_objrec2array -- Convert attributes from object record to object array
hw_Output_Document -- prints hw_document
hw_pConnect -- make a persistent database connection
hw_PipeDocument -- retrieve any document
hw_Root -- root object id
hw_setlinkroot -- Set the id to which links are calculated
hw_stat -- Returns status string
hw_Unlock -- unlock object
hw_Who -- List of currently logged in users

이전 | 처음으로 | 다음
setrawcookie | 위로 | hw_Array2Objrec


hw_Array2Objrec

(PHP 3>= 3.0.4, PHP 4 )

hw_Array2Objrec -- convert attributes from object array to object record

Description

string hw_array2objrec ( array object_array)

Converts an object_array into an object record. Multiple attributes like 'Title' in different languages are treated properly.

See also hw_objrec2array().

이전 | 처음으로 | 다음
Hyperwave Functions | 위로 | hw_changeobject


hw_changeobject

(PHP 3>= 3.0.3, PHP 4 )

hw_changeobject -- Changes attributes of an object (obsolete)

Description

void hw_changeobject ( int link, int objid, array attributes)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
hw_Array2Objrec | 위로 | hw_Children


hw_Children

(PHP 3>= 3.0.3, PHP 4 )

hw_Children -- object ids of children

Description

array hw_children ( int connection, int objectID)

Returns an array of object ids. Each id belongs to a child of the collection with ID objectID. The array contains all children both documents and collections.

이전 | 처음으로 | 다음
hw_changeobject | 위로 | hw_ChildrenObj


hw_ChildrenObj

(PHP 3>= 3.0.3, PHP 4 )

hw_ChildrenObj -- object records of children

Description

array hw_childrenobj ( int connection, int objectID)

Returns an array of object records. Each object record belongs to a child of the collection with ID objectID. The array contains all children both documents and collections.

이전 | 처음으로 | 다음
hw_Children | 위로 | hw_Close


hw_Close

(PHP 3>= 3.0.3, PHP 4 )

hw_Close -- closes the Hyperwave connection

Description

int hw_close ( int connection)

Returns FALSE if connection is not a valid connection index, otherwise TRUE. Closes down the connection to a Hyperwave server with the given connection index.

이전 | 처음으로 | 다음
hw_ChildrenObj | 위로 | hw_Connect


hw_Connect

(PHP 3>= 3.0.3, PHP 4 )

hw_Connect -- opens a connection

Description

int hw_connect ( string host, int port, string username, string password)

Opens a connection to a Hyperwave server and returns a connection index on success, or FALSE if the connection could not be made. Each of the arguments should be a quoted string, except for the port number. The username and password arguments are optional and can be left out. In such a case no identification with the server will be done. It is similar to identify as user anonymous. This function returns a connection index that is needed by other Hyperwave functions. You can have multiple connections open at once. Keep in mind, that the password is not encrypted.

See also hw_pconnect().

이전 | 처음으로 | 다음
hw_Close | 위로 | hw_connection_info


hw_connection_info

(PHP 3>= 3.0.3, PHP 4 )

hw_connection_info -- Prints information about the connection to Hyperwave server

Description

void hw_connection_info ( int link)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
hw_Connect | 위로 | hw_cp


hw_cp

(PHP 3>= 3.0.3, PHP 4 )

hw_cp -- Copies objects

Description

int hw_cp ( int connection, array object_id_array, int destination_id)

Copies the objects with object ids as specified in the second parameter to the collection with the id destination id.

The value return is the number of copied objects.

See also hw_mv().

이전 | 처음으로 | 다음
hw_connection_info | 위로 | hw_Deleteobject


hw_Deleteobject

(PHP 3>= 3.0.3, PHP 4 )

hw_Deleteobject -- deletes object

Description

int hw_deleteobject ( int connection, int object_to_delete)

Deletes the object with the given object id in the second parameter. It will delete all instances of the object.

Returns TRUE if no error occurs otherwise FALSE.

See also hw_mv().

이전 | 처음으로 | 다음
hw_cp | 위로 | hw_DocByAnchor


hw_DocByAnchor

(PHP 3>= 3.0.3, PHP 4 )

hw_DocByAnchor -- object id object belonging to anchor

Description

int hw_docbyanchor ( int connection, int anchorID)

Returns an th object id of the document to which anchorID belongs.

이전 | 처음으로 | 다음
hw_Deleteobject | 위로 | hw_DocByAnchorObj


hw_DocByAnchorObj

(PHP 3>= 3.0.3, PHP 4 )

hw_DocByAnchorObj -- object record object belonging to anchor

Description

string hw_docbyanchorobj ( int connection, int anchorID)

Returns an th object record of the document to which anchorID belongs.

이전 | 처음으로 | 다음
hw_DocByAnchor | 위로 | hw_Document_Attributes


hw_Document_Attributes

(PHP 3>= 3.0.3, PHP 4 )

hw_Document_Attributes -- object record of hw_document

Description

string hw_document_attributes ( int hw_document)

Returns the object record of the document.

For backward compatibility, hw_documentattributes() is also accepted. This is deprecated, however.

See also hw_document_bodytag(), and hw_document_size().

이전 | 처음으로 | 다음
hw_DocByAnchorObj | 위로 | hw_Document_BodyTag


hw_Document_BodyTag

(PHP 3>= 3.0.3, PHP 4 )

hw_Document_BodyTag -- body tag of hw_document

Description

string hw_document_bodytag ( int hw_document)

Returns the BODY tag of the document. If the document is an HTML document the BODY tag should be printed before the document.

See also hw_document_attributes(), and hw_document_size().

For backward compatibility, hw_documentbodytag() is also accepted. This is deprecated, however.

이전 | 처음으로 | 다음
hw_Document_Attributes | 위로 | hw_Document_Content


hw_Document_Content

(PHP 3>= 3.0.3, PHP 4 )

hw_Document_Content -- returns content of hw_document

Description

string hw_document_content ( int hw_document)

Returns the content of the document. If the document is an HTML document the content is everything after the BODY tag. Information from the HEAD and BODY tag is in the stored in the object record.

See also hw_document_attributes(),
hw_document_size(),
and hw_document_setcontent().

이전 | 처음으로 | 다음
hw_Document_BodyTag | 위로 | hw_Document_SetContent


hw_Document_SetContent

(PHP 4 )

hw_Document_SetContent -- sets/replaces content of hw_document

Description

string hw_document_setcontent ( int hw_document, string content)

Sets or replaces the content of the document. If the document is an HTML document the content is everything after the BODY tag. Information from the HEAD and BODY tag is in the stored in the object record. If you provide this information in the content of the document too, the Hyperwave server will change the object record accordingly when the document is inserted. Probably not a very good idea. If this functions fails the document will retain its old content.

See also hw_document_attributes(),
hw_document_size(),
and hw_document_content().

이전 | 처음으로 | 다음
hw_Document_Content | 위로 | hw_Document_Size


hw_Document_Size

(PHP 3>= 3.0.3, PHP 4 )

hw_Document_Size -- size of hw_document

Description

int hw_document_size ( int hw_document)

Returns the size in bytes of the document.

See also hw_document_bodytag(), and hw_document_attributes().

For backward compatibility, hw_documentsize() is also accepted. This is deprecated, however.

이전 | 처음으로 | 다음
hw_Document_SetContent | 위로 | hw_dummy


hw_dummy

(PHP 3>= 3.0.3, PHP 4 )

hw_dummy -- Hyperwave dummy function

Description

string hw_dummy ( int link, int id, int msgid)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
hw_Document_Size | 위로 | hw_EditText


hw_EditText

(PHP 3>= 3.0.3, PHP 4 )

hw_EditText -- retrieve text document

Description

int hw_edittext ( int connection, int hw_document)

Uploads the text document to the server. The object record of the document may not be modified while the document is edited. This function will only works for pure text documents. It will not open a special data connection and therefore blocks the control connection during the transfer.

See also hw_pipedocument(),
hw_free_document(),
hw_document_bodytag(),
hw_document_size(),
hw_output_document(), and
hw_gettext().

이전 | 처음으로 | 다음
hw_dummy | 위로 | hw_Error


hw_Error

(PHP 3>= 3.0.3, PHP 4 )

hw_Error -- error number

Description

int hw_error ( int connection)

Returns the last error number. If the return value is 0 no error has occurred. The error relates to the last command.

이전 | 처음으로 | 다음
hw_EditText | 위로 | hw_ErrorMsg


hw_ErrorMsg

(PHP 3>= 3.0.3, PHP 4 )

hw_ErrorMsg -- returns error message

Description

string hw_errormsg ( int connection)

Returns a string containing the last error message or 'No Error'. If FALSE is returned, this function failed. The message relates to the last command.

이전 | 처음으로 | 다음
hw_Error | 위로 | hw_Free_Document


hw_Free_Document

(PHP 3>= 3.0.3, PHP 4 )

hw_Free_Document -- frees hw_document

Description

int hw_free_document ( int hw_document)

Frees the memory occupied by the Hyperwave document.

이전 | 처음으로 | 다음
hw_ErrorMsg | 위로 | hw_GetAnchors


hw_GetAnchors

(PHP 3>= 3.0.3, PHP 4 )

hw_GetAnchors -- object ids of anchors of document

Description

array hw_getanchors ( int connection, int objectID)

Returns an array of object ids with anchors of the document with object ID objectID.

이전 | 처음으로 | 다음
hw_Free_Document | 위로 | hw_GetAnchorsObj


hw_GetAnchorsObj

(PHP 3>= 3.0.3, PHP 4 )

hw_GetAnchorsObj -- object records of anchors of document

Description

array hw_getanchorsobj ( int connection, int objectID)

Returns an array of object records with anchors of the document with object ID objectID.

이전 | 처음으로 | 다음
hw_GetAnchors | 위로 | hw_GetAndLock


hw_GetAndLock

(PHP 3>= 3.0.3, PHP 4 )

hw_GetAndLock -- return object record and lock object

Description

string hw_getandlock ( int connection, int objectID)

Returns the object record for the object with ID objectID. It will also lock the object, so other users cannot access it until it is unlocked.

See also hw_unlock(), and hw_getobject().

이전 | 처음으로 | 다음
hw_GetAnchorsObj | 위로 | hw_GetChildColl


hw_GetChildColl

(PHP 3>= 3.0.3, PHP 4 )

hw_GetChildColl -- object ids of child collections

Description

array hw_getchildcoll ( int connection, int objectID)

Returns an array of object ids. Each object ID belongs to a child collection of the collection with ID objectID. The function will not return child documents.

See also hw_children(), and hw_getchilddoccoll().

이전 | 처음으로 | 다음
hw_GetAndLock | 위로 | hw_GetChildCollObj


hw_GetChildCollObj

(PHP 3>= 3.0.3, PHP 4 )

hw_GetChildCollObj -- object records of child collections

Description

array hw_getchildcollobj ( int connection, int objectID)

Returns an array of object records. Each object records belongs to a child collection of the collection with ID objectID. The function will not return child documents.

See also hw_childrenobj(), and hw_getchilddoccollobj().

이전 | 처음으로 | 다음
hw_GetChildColl | 위로 | hw_GetChildDocColl


hw_GetChildDocColl

(PHP 3>= 3.0.3, PHP 4 )

hw_GetChildDocColl -- object ids of child documents of collection

Description

array hw_getchilddoccoll ( int connection, int objectID)

Returns array of object ids for child documents of a collection.

See also hw_children(), and hw_getchildcoll().

이전 | 처음으로 | 다음
hw_GetChildCollObj | 위로 | hw_GetChildDocCollObj


hw_GetChildDocCollObj

(PHP 3>= 3.0.3, PHP 4 )

hw_GetChildDocCollObj -- object records of child documents of collection

Description

array hw_getchilddoccollobj ( int connection, int objectID)

Returns an array of object records for child documents of a collection.

See also hw_childrenobj(), and hw_getchildcollobj().

이전 | 처음으로 | 다음
hw_GetChildDocColl | 위로 | hw_GetObject


hw_GetObject

(PHP 3>= 3.0.3, PHP 4 )

hw_GetObject -- object record

Description

array hw_getobject ( int connection, mixed objectID, string query)

Returns the object record for the object with ID objectID if the second parameter is an integer. If the second parameter is an array of integer the function will return an array of object records. In such a case the last parameter is also evaluated which is a query string.

The query string has the following syntax:

<expr> ::= "(" <expr> ")" |

"!" <expr> | /* NOT */

<expr> "||" <expr> | /* OR */

<expr> "&&" <expr> | /* AND */

<attribute> <operator> <value>

<attribute> ::= /* any attribute name (Title, Author, DocumentType ...) */

<operator> ::= "=" | /* equal */

"<" | /* less than (string compare) */

">" | /* greater than (string compare) */

"~" /* regular expression matching */

The query allows to further select certain objects from the list of given objects. Unlike the other query functions, this query may use not indexed attributes. How many object records are returned depends on the query and if access to the object is allowed.

See also hw_getandlock(), and hw_getobjectbyquery().

이전 | 처음으로 | 다음
hw_GetChildDocCollObj | 위로 | hw_GetObjectByQuery


hw_GetObjectByQuery

(PHP 3>= 3.0.3, PHP 4 )

hw_GetObjectByQuery -- search object

Description

array hw_getobjectbyquery ( int connection, string query, int max_hits)

Searches for objects on the whole server and returns an array of object ids. The maximum number of matches is limited to max_hits. If max_hits is set to -1 the maximum number of matches is unlimited.

The query will only work with indexed attributes.

See also hw_getobjectbyqueryobj().

이전 | 처음으로 | 다음
hw_GetObject | 위로 | hw_GetObjectByQueryColl


hw_GetObjectByQueryColl

(PHP 3>= 3.0.3, PHP 4 )

hw_GetObjectByQueryColl -- search object in collection

Description

array hw_getobjectbyquerycoll ( int connection, int objectID, string query, int max_hits)

Searches for objects in collection with ID objectID and returns an array of object ids. The maximum number of matches is limited to max_hits. If max_hits is set to -1 the maximum number of matches is unlimited.

The query will only work with indexed attributes.

See also hw_getobjectbyquerycollobj().

이전 | 처음으로 | 다음
hw_GetObjectByQuery | 위로 | hw_GetObjectByQueryCollObj


hw_GetObjectByQueryCollObj

(PHP 3>= 3.0.3, PHP 4 )

hw_GetObjectByQueryCollObj -- search object in collection

Description

array hw_getobjectbyquerycollobj ( int connection, int objectID, string query, int max_hits)

Searches for objects in collection with ID objectID and returns an array of object records. The maximum number of matches is limited to max_hits. If max_hits is set to -1 the maximum number of matches is unlimited.

The query will only work with indexed attributes.

See also hw_getobjectbyquerycoll().

이전 | 처음으로 | 다음
hw_GetObjectByQueryColl | 위로 | hw_GetObjectByQueryObj


hw_GetObjectByQueryObj

(PHP 3>= 3.0.3, PHP 4 )

hw_GetObjectByQueryObj -- search object

Description

array hw_getobjectbyqueryobj ( int connection, string query, int max_hits)

Searches for objects on the whole server and returns an array of object records. The maximum number of matches is limited to max_hits. If max_hits is set to -1 the maximum number of matches is unlimited.

The query will only work with indexed attributes.

See also hw_getobjectbyquery().

이전 | 처음으로 | 다음
hw_GetObjectByQueryCollObj | 위로 | hw_GetParents


hw_GetParents

(PHP 3>= 3.0.3, PHP 4 )

hw_GetParents -- object ids of parents

Description

array hw_getparents ( int connection, int objectID)

Returns an indexed array of object ids. Each object id belongs to a parent of the object with ID objectID.

이전 | 처음으로 | 다음
hw_GetObjectByQueryObj | 위로 | hw_GetParentsObj


hw_GetParentsObj

(PHP 3>= 3.0.3, PHP 4 )

hw_GetParentsObj -- object records of parents

Description

array hw_getparentsobj ( int connection, int objectID)

Returns an indexed array of object records plus an associated array with statistical information about the object records. The associated array is the last entry of the returned array. Each object record belongs to a parent of the object with ID objectID.

이전 | 처음으로 | 다음
hw_GetParents | 위로 | hw_getrellink


hw_getrellink

(PHP 3>= 3.0.3, PHP 4 )

hw_getrellink -- Get link from source to dest relative to rootid

Description

string hw_getrellink ( int link, int rootid, int sourceid, int destid)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
hw_GetParentsObj | 위로 | hw_GetRemote


hw_GetRemote

(PHP 3>= 3.0.3, PHP 4 )

hw_GetRemote -- Gets a remote document

Description

int hw_getremote ( int connection, int objectID)

Returns a remote document. Remote documents in Hyperwave notation are documents retrieved from an external source. Common remote documents are for example external web pages or queries in a database. In order to be able to access external sources through remote documents Hyperwave introduces the HGI (Hyperwave Gateway Interface) which is similar to the CGI. Currently, only ftp, http-servers and some databases can be accessed by the HGI. Calling hw_getremote() returns the document from the external source. If you want to use this function you should be very familiar with HGIs. You should also consider to use PHP instead of Hyperwave to access external sources. Adding database support by a Hyperwave gateway should be more difficult than doing it in PHP.

See also hw_getremotechildren().

이전 | 처음으로 | 다음
hw_getrellink | 위로 | hw_getremotechildren


hw_getremotechildren

(PHP 3>= 3.0.3, PHP 4 )

hw_getremotechildren -- Gets children of remote document

Description

int hw_getremotechildren ( int connection, string object_record)

Returns the children of a remote document. Children of a remote document are remote documents itself. This makes sense if a database query has to be narrowed and is explained in Hyperwave Programmers' Guide. If the number of children is 1 the function will return the document itself formated by the Hyperwave Gateway Interface (HGI). If the number of children is greater than 1 it will return an array of object record with each maybe the input value for another call to hw_getremotechildren(). Those object records are virtual and do not exist in the Hyperwave server, therefore they do not have a valid object ID. How exactly such an object record looks like is up to the HGI. If you want to use this function you should be very familiar with HGIs. You should also consider to use PHP instead of Hyperwave to access external sources. Adding database support by a Hyperwave gateway should be more difficult than doing it in PHP.

See also hw_getremote().

이전 | 처음으로 | 다음
hw_GetRemote | 위로 | hw_GetSrcByDestObj


hw_GetSrcByDestObj

(PHP 3>= 3.0.3, PHP 4 )

hw_GetSrcByDestObj -- Returns anchors pointing at object

Description

array hw_getsrcbydestobj ( int connection, int objectID)

Returns the object records of all anchors pointing to the object with ID objectID. The object can either be a document or an anchor of type destination.

See also hw_getanchors().

이전 | 처음으로 | 다음
hw_getremotechildren | 위로 | hw_GetText


hw_GetText

(PHP 3>= 3.0.3, PHP 4 )

hw_GetText -- retrieve text document

Description

int hw_gettext ( int connection, int objectID [, mixed rootID/prefix])

Returns the document with object ID objectID. If the document has anchors which can be inserted, they will be inserted already. The optional parameter rootID/prefix can be a string or an integer. If it is an integer it determines how links are inserted into the document. The default is 0 and will result in links that are constructed from the name of the link's destination object. This is useful for web applications. If a link points to an object with name 'internet_movie' the HTML link will be <A HREF="/internet_movie">. The actual location of the source and destination object in the document hierarchy is disregarded. You will have to set up your web browser, to rewrite that URL to for example '/my_script.php3/internet_movie'. 'my_script.php3' will have to evaluate $PATH_INFO and retrieve the document. All links will have the prefix '/my_script.php3/'. If you do not want this you can set the optional parameter rootID/prefix to any prefix which is used instead. Is this case it has to be a string.

If rootID/prefix is an integer and unequal to 0 the link is constructed from all the names starting at the object with the id rootID/prefix separated by a slash relative to the current object. If for example the above document 'internet_movie' is located at 'a-b-c-internet_movie' with '-' being the separator between hierarchy levels on the Hyperwave server and the source document is located at 'a-b-d-source' the resulting HTML link would be: <A HREF="../c/internet_movie">. This is useful if you want to download the whole server content onto disk and map the document hierarchy onto the file system.

This function will only work for pure text documents. It will not open a special data connection and therefore blocks the control connection during the transfer.

See also hw_pipedocument(),
hw_free_document(),
hw_document_bodytag(),
hw_document_size(),
and hw_output_document().

이전 | 처음으로 | 다음
hw_GetSrcByDestObj | 위로 | hw_getusername


hw_getusername

(PHP 3>= 3.0.3, PHP 4 )

hw_getusername -- name of currently logged in user

Description

string hw_getusername ( int connection)

Returns the username of the connection.

이전 | 처음으로 | 다음
hw_GetText | 위로 | hw_Identify


hw_Identify

(PHP 3>= 3.0.3, PHP 4 )

hw_Identify -- identifies as user

Description

int hw_identify ( string username, string password)

Identifies as user with username and password. Identification is only valid for the current session. I do not thing this function will be needed very often. In most cases it will be easier to identify with the opening of the connection.

See also hw_connect().

이전 | 처음으로 | 다음
hw_getusername | 위로 | hw_InCollections


hw_InCollections

(PHP 3>= 3.0.3, PHP 4 )

hw_InCollections -- check if object ids in collections

Description

array hw_incollections ( int connection, array object_id_array, array collection_id_array, int return_collections)

Checks whether a set of objects (documents or collections) specified by the object_id_array is part of the collections listed in collection_id_array. When the fourth parameter return_collections is 0, the subset of object ids that is part of the collections (i.e., the documents or collections that are children of one or more collections of collection ids or their subcollections, recursively) is returned as an array. When the fourth parameter is 1, however, the set of collections that have one or more objects of this subset as children are returned as an array. This option allows a client to, e.g., highlight the part of the collection hierarchy that contains the matches of a previous query, in a graphical overview.

이전 | 처음으로 | 다음
hw_Identify | 위로 | hw_Info


hw_Info

(PHP 3>= 3.0.3, PHP 4 )

hw_Info -- info about connection

Description

string hw_info ( int connection)

Returns information about the current connection. The returned string has the following format: <Serverstring>, <Host>, <Port>, <Username>, <Port of Client>, <Byte swapping>

이전 | 처음으로 | 다음
hw_InCollections | 위로 | hw_InsColl


hw_InsColl

(PHP 3>= 3.0.3, PHP 4 )

hw_InsColl -- insert collection

Description

int hw_inscoll ( int connection, int objectID, array object_array)

Inserts a new collection with attributes as in object_array into collection with object ID objectID.

이전 | 처음으로 | 다음
hw_Info | 위로 | hw_InsDoc


hw_InsDoc

(PHP 3>= 3.0.3, PHP 4 )

hw_InsDoc -- insert document

Description

int hw_insdoc ( int connection, int parentID, string object_record, string text)

Inserts a new document with attributes as in object_record into collection with object ID parentID. This function inserts either an object record only or an object record and a pure ascii text in text if text is given. If you want to insert a general document of any kind use hw_insertdocument() instead.

See also hw_insertdocument(), and hw_inscoll().

이전 | 처음으로 | 다음
hw_InsColl | 위로 | hw_insertanchors


hw_insertanchors

(PHP 4 >= 4.0.4)

hw_insertanchors -- Inserts only anchors into text

Description

string hw_insertanchors ( int hwdoc, array anchorecs, array dest [, array urlprefixes])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
hw_InsDoc | 위로 | hw_InsertDocument


hw_InsertDocument

(PHP 3>= 3.0.3, PHP 4 )

hw_InsertDocument -- upload any document

Description

int hw_insertdocument ( int connection, int parent_id, int hw_document)

Uploads a document into the collection with parent_id. The document has to be created before with hw_new_document(). Make sure that the object record of the new document contains at least the attributes: Type, DocumentType, Title and Name. Possibly you also want to set the MimeType. The functions returns the object id of the new document or FALSE.

See also hw_pipedocument().

이전 | 처음으로 | 다음
hw_insertanchors | 위로 | hw_InsertObject


hw_InsertObject

(PHP 3>= 3.0.3, PHP 4 )

hw_InsertObject -- inserts an object record

Description

int hw_insertobject ( int connection, string object_rec, string parameter)

Inserts an object into the server. The object can be any valid hyperwave object. See the HG-CSP documentation for a detailed information on how the parameters have to be.

Note: If you want to insert an Anchor, the attribute Position has always been set either to a start/end value or to 'invisible'. Invisible positions are needed if the annotation has no corresponding link in the annotation text.

See also hw_pipedocument(),
hw_insertdocument(),
hw_insdoc(),
and hw_inscoll().

이전 | 처음으로 | 다음
hw_InsertDocument | 위로 | hw_mapid


hw_mapid

(PHP 3>= 3.0.13, PHP 4 )

hw_mapid -- Maps global id on virtual local id

Description

int hw_mapid ( int connection, int server_id, int object_id)

Maps a global object id on any hyperwave server, even those you did not connect to with hw_connect(), onto a virtual object id. This virtual object id can then be used as any other object id, e.g. to obtain the object record with hw_getobject(). The server id is the first part of the global object id (GOid) of the object which is actually the IP number as an integer.

Note: In order to use this function you will have to set the F_DISTRIBUTED flag, which can currently only be set at compile time in hg_comm.c. It is not set by default. Read the comment at the beginning of hg_comm.c

이전 | 처음으로 | 다음
hw_InsertObject | 위로 | hw_Modifyobject


hw_Modifyobject

(PHP 3>= 3.0.7, PHP 4 )

hw_Modifyobject -- modifies object record

Description

int hw_modifyobject ( int connection, int object_to_change, array remove, array add, int mode)

This command allows to remove, add, or modify individual attributes of an object record. The object is specified by the Object ID object_to_change. The first array remove is a list of attributes to remove. The second array add is a list of attributes to add. In order to modify an attribute one will have to remove the old one and add a new one. hw_modifyobject() will always remove the attributes before it adds attributes unless the value of the attribute to remove is not a string or array.

The last parameter determines if the modification is performed recursively. 1 means recursive modification. If some of the objects cannot be modified they will be skipped without notice. hw_error() may not indicate an error though some of the objects could not be modified.

The keys of both arrays are the attributes name. The value of each array element can either be an array, a string or anything else. If it is an array each attribute value is constructed by the key of each element plus a colon and the value of each element. If it is a string it is taken as the attribute value. An empty string will result in a complete removal of that attribute. If the value is neither a string nor an array but something else, e.g. an integer, no operation at all will be performed on the attribute. This is necessary if you want to to add a completely new attribute not just a new value for an existing attribute. If the remove array contained an empty string for that attribute, the attribute would be tried to be removed which would fail since it doesn't exist. The following addition of a new value for that attribute would also fail. Setting the value for that attribute to e.g. 0 would not even try to remove it and the addition will work.

If you would like to change the attribute 'Name' with the current value 'books' into 'articles' you will have to create two arrays and call hw_modifyobject().

예 1. modifying an attribute

<?php
       // $connect is an existing connection to the Hyperwave server
       // $objid is the ID of the object to modify
       $remarr = array("Name" => "books");
       $addarr = array("Name" => "articles");
       $hw_modifyobject($connect, $objid, $remarr, $addarr);
?>
In order to delete/add a name=value pair from/to the object record just pass the remove/add array and set the last/third parameter to an empty array. If the attribute is the first one with that name to add, set attribute value in the remove array to an integer.

예 2. adding a completely new attribute

<?php
       // $connect is an existing connection to the Hyperwave server
       // $objid is the ID of the object to modify
       $remarr = array("Name" => 0);
       $addarr = array("Name" => "articles");
       $hw_modifyobject($connect, $objid, $remarr, $addarr);
?>

참고: Multilingual attributes, e.g. 'Title', can be modified in two ways. Either by providing the attributes value in its native form 'language':'title' or by providing an array with elements for each language as described above. The above example would than be:

예 3. modifying Title attribute

<?php
       $remarr = array("Title" => "en:Books");
       $addarr = array("Title" => "en:Articles");
       $hw_modifyobject($connect, $objid, $remarr, $addarr);
?>
or

예 4. modifying Title attribute

<?php
       $remarr = array("Title" => array("en" => "Books"));
       $addarr = array("Title" => array("en" => "Articles", "ge"=>"Artikel"));
       $hw_modifyobject($connect, $objid, $remarr, $addarr);
?>
This removes the English title 'Books' and adds the English title 'Articles' and the German title 'Artikel'.

예 5. removing attribute

<?php
       $remarr = array("Title" => "");
       $addarr = array("Title" => "en:Articles");
       $hw_modifyobject($connect, $objid, $remarr, $addarr);
?>

참고: This will remove all attributes with the name 'Title' and adds a new 'Title' attribute. This comes in handy if you want to remove attributes recursively.

참고: If you need to delete all attributes with a certain name you will have to pass an empty string as the attribute value.

참고: Only the attributes 'Title', 'Description' and 'Keyword' will properly handle the language prefix. If those attributes don't carry a language prefix, the prefix 'xx' will be assigned.

참고: The 'Name' attribute is somewhat special. In some cases it cannot be complete removed. You will get an error message 'Change of base attribute' (not clear when this happens). Therefore you will always have to add a new Name first and than remove the old one.

참고: You may not surround this function by calls to hw_getandlock() and hw_unlock(). hw_modifyobject() does this internally.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
hw_mapid | 위로 | hw_mv


hw_mv

(PHP 3>= 3.0.3, PHP 4 )

hw_mv -- Moves objects

Description

int hw_mv ( int connection, array object_id_array, int source_id, int destination_id)

Moves the objects with object ids as specified in the second parameter from the collection with id source_id to the collection with the id destination_id. If the destination id is 0 the objects will be unlinked from the source collection. If this is the last instance of that object it will be deleted. If you want to delete all instances at once, use hw_deleteobject().

The value returned is the number of moved objects.

See also hw_cp(), and hw_deleteobject().

이전 | 처음으로 | 다음
hw_Modifyobject | 위로 | hw_New_Document


hw_New_Document

(PHP 3>= 3.0.3, PHP 4 )

hw_New_Document -- create new document

Description

int hw_new_document ( string object_record, string document_data, int document_size)

Returns a new Hyperwave document with document data set to document_data and object record set to object_record. The length of the document_data has to passed in document_sizeThis function does not insert the document into the Hyperwave server.

See also hw_free_document(),
hw_document_size(),
hw_document_bodytag(),
hw_output_document(),
and hw_insertdocument().

이전 | 처음으로 | 다음
hw_mv | 위로 | hw_objrec2array


hw_objrec2array

(PHP 3>= 3.0.3, PHP 4 )

hw_objrec2array -- Convert attributes from object record to object array

Description

array hw_objrec2array ( string object_record [, array format])

Converts an object_record into an object array. The keys of the resulting array are the attributes names. Multi-value attributes like 'Title' in different languages form its own array. The keys of this array are the left part to the colon of the attribute value. This left part must be two characters long. Other multi-value attributes without a prefix form an indexed array. If the optional parameter is missing the attributes 'Title', 'Description' and 'Keyword' are treated as language attributes and the attributes 'Group', 'Parent' and 'HtmlAttr' as non-prefixed multi-value attributes. By passing an array holding the type for each attribute you can alter this behaviour. The array is an associated array with the attribute name as its key and the value being one of HW_ATTR_LANG or HW_ATTR_NONE.

See also hw_array2objrec().

이전 | 처음으로 | 다음
hw_New_Document | 위로 | hw_Output_Document


hw_Output_Document

(PHP 3>= 3.0.3, PHP 4 )

hw_Output_Document -- prints hw_document

Description

int hw_output_document ( int hw_document)

Prints the document without the BODY tag.

For backward compatibility, hw_outputdocument() is also accepted. This is deprecated, however.

이전 | 처음으로 | 다음
hw_objrec2array | 위로 | hw_pConnect


hw_pConnect

(PHP 3>= 3.0.3, PHP 4 )

hw_pConnect -- make a persistent database connection

Description

int hw_pconnect ( string host, int port, string username, string password)

Returns a connection index on success, or FALSE if the connection could not be made. Opens a persistent connection to a Hyperwave server. Each of the arguments should be a quoted string, except for the port number. The username and password arguments are optional and can be left out. In such a case no identification with the server will be done. It is similar to identify as user anonymous. This function returns a connection index that is needed by other Hyperwave functions. You can have multiple persistent connections open at once.

See also hw_connect().

이전 | 처음으로 | 다음
hw_Output_Document | 위로 | hw_PipeDocument


hw_PipeDocument

(PHP 3>= 3.0.3, PHP 4 )

hw_PipeDocument -- retrieve any document

Description

int hw_pipedocument ( int connection, int objectID)

Returns the Hyperwave document with object ID objectID. If the document has anchors which can be inserted, they will have been inserted already. The document will be transferred via a special data connection which does not block the control connection.

See also hw_gettext() for more on link insertion,
hw_free_document(),
hw_document_size(),
hw_document_bodytag(),
and hw_output_document().

이전 | 처음으로 | 다음
hw_pConnect | 위로 | hw_Root


hw_Root

(PHP 3>= 3.0.3, PHP 4 )

hw_Root -- root object id

Description

int hw_root ( )

Returns the object ID of the hyperroot collection. Currently this is always 0. The child collection of the hyperroot is the root collection of the connected server.

이전 | 처음으로 | 다음
hw_PipeDocument | 위로 | hw_setlinkroot


hw_setlinkroot

(PHP 3>= 3.0.3, PHP 4 )

hw_setlinkroot -- Set the id to which links are calculated

Description

void hw_setlinkroot ( int link, int rootid)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
hw_Root | 위로 | hw_stat


hw_stat

(PHP 3>= 3.0.3, PHP 4 )

hw_stat -- Returns status string

Description

string hw_stat ( int link)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
hw_setlinkroot | 위로 | hw_Unlock


hw_Unlock

(PHP 3>= 3.0.3, PHP 4 )

hw_Unlock -- unlock object

Description

int hw_unlock ( int connection, int objectID)

Unlocks a document, so other users regain access.

See also hw_getandlock().

이전 | 처음으로 | 다음
hw_stat | 위로 | hw_Who


hw_Who

(PHP 3>= 3.0.3, PHP 4 )

hw_Who -- List of currently logged in users

Description

int hw_who ( int connection)

Returns an array of users currently logged into the Hyperwave server. Each entry in this array is an array itself containing the elements id, name, system, onSinceDate, onSinceTime, TotalTime and self. 'self' is 1 if this entry belongs to the user who initiated the request.

이전 | 처음으로 | 다음
hw_Unlock | 위로 | Hyperwave API Functions


Hyperwave API Functions

PHP 매뉴얼
이전 다음

XXXIX. Hyperwave API Functions

소개

Hyperwave has been developed at IICM in Graz. It started with the name Hyper-G and changed to Hyperwave when it was commercialised (in 1996).

Hyperwave is not free software. The current version, 5.5, is available at http://www.hyperwave.com/. A time limited version can be ordered for free (30 days).

See also the Hyperwave module.

Hyperwave is an information system similar to a database (HIS, Hyperwave Information Server). Its focus is the storage and management of documents. A document can be any possible piece of data that may as well be stored in file. Each document is accompanied by its object record. The object record contains meta data for the document. The meta data is a list of attributes which can be extended by the user. Certain attributes are always set by the Hyperwave server, other may be modified by the user.

요구 사항

Since 2001 there is a Hyperwave SDK available. It supports Java, JavaScript and C++. This PHP Extension is based on the C++ interface. In order to activate the hwapi support in PHP you will have to install the Hyperwave SDK first.

설치

After installing the Hyperwave SDK, configure PHP with --with-hwapi[=DIR].

Integration with Apache

The integration with Apache and possible other servers is already described in the Hyperwave module which has been the first extension to connect a Hyperwave Server.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. Hyperwave API configuration options

Name | Default | Changeable
hwapi.allow_persistent | "0" | PHP_INI_SYSTEM
For further details and definition of the PHP_INI_* constants see ini_set().

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

Classes

The API provided by the HW_API extension is fully object oriented. It is very similar to the C++ interface of the Hyperwave SDK. It consist of the following classes.

  • HW_API

  • HW_API_Object

  • HW_API_Attribute

  • HW_API_Error

  • HW_API_Content

  • HW_API_Reason

Some basic classes like HW_API_String, HW_API_String_Array, etc., which exist in the Hyperwave SDK have not been implemented since PHP has powerful replacements for them.

Each class has certain method, whose names are identical to its counterparts in the Hyperwave SDK. Passing arguments to this function differs from all the other PHP extensions but is close to the C++ API of the HW SDK. Instead of passing several parameters they are all put into an associated array and passed as one parameter. The names of the keys are identical to those documented in the HW SDK. The common parameters are listed below. If other parameters are required they will be documented if needed.

  • objectIdentifier The name or id of an object, e.g. "rootcollection", "0x873A8768 0x00000002".

  • parentIdentifier The name or id of an object which is considered to be a parent.

  • object An instance of class HW_API_Object.

  • parameters An instance of class HW_API_Object.

  • version The version of an object.

  • mode An integer value determine the way an operation is executed.

  • attributeSelector Any array of strings, each containing a name of an attribute. This is used if you retrieve the object record and want to include certain attributes.

  • objectQuery A query to select certain object out of a list of objects. This is used to reduce the number of objects which was delivered by a function like hw_api->children() or hw_api->find().

차례
hw_api_attribute->key -- Returns key of the attribute
hw_api_attribute->langdepvalue -- Returns value for a given language
hw_api_attribute->value -- Returns value of the attribute
hw_api_attribute->values -- Returns all values of the attribute
hw_api_attribute -- Creates instance of class hw_api_attribute
hw_api->checkin -- Checks in an object
hw_api->checkout -- Checks out an object
hw_api->children -- Returns children of an object
hw_api_content->mimetype -- Returns mimetype
hw_api_content->read -- Read content
hw_api->content -- Returns content of an object
hw_api->copy -- Copies physically
hw_api->dbstat -- Returns statistics about database server
hw_api->dcstat -- Returns statistics about document cache server
hw_api->dstanchors -- Returns a list of all destination anchors
hw_api->dstofsrcanchors -- Returns destination of a source anchor
hw_api_error->count -- Returns number of reasons
hw_api_error->reason -- Returns reason of error
hw_api->find -- Search for objects
hw_api->ftstat -- Returns statistics about fulltext server
hwapi_hgcsp -- Returns object of class hw_api
hw_api->hwstat -- Returns statistics about Hyperwave server
hw_api->identify -- Log into Hyperwave Server
hw_api->info -- Returns information about server configuration
hw_api->insert -- Inserts a new object
hw_api->insertanchor -- Inserts a new object of type anchor
hw_api->insertcollection -- Inserts a new object of type collection
hw_api->insertdocument -- Inserts a new object of type document
hw_api->link -- Creates a link to an object
hw_api->lock -- Locks an object
hw_api->move -- Moves object between collections
hw_api_content -- Create new instance of class hw_api_content
hw_api_object->assign -- Clones object
hw_api_object->attreditable -- Checks whether an attribute is editable
hw_api_object->count -- Returns number of attributes
hw_api_object->insert -- Inserts new attribute
hw_api_object -- Creates a new instance of class hw_api_object
hw_api_object->remove -- Removes attribute
hw_api_object->title -- Returns the title attribute
hw_api_object->value -- Returns value of attribute
hw_api->object -- Retrieve attribute information
hw_api->objectbyanchor -- Returns the object an anchor belongs to
hw_api->parents -- Returns parents of an object
hw_api_reason->description -- Returns description of reason
hw_api_reason->type -- Returns type of reason
hw_api->remove -- Delete an object
hw_api->replace -- Replaces an object
hw_api->setcommitedversion -- Commits version other than last version
hw_api->srcanchors -- Returns a list of all source anchors
hw_api->srcsofdst -- Returns source of a destination object
hw_api->unlock -- Unlocks a locked object
hw_api->user -- Returns the own user object
hw_api->userlist -- Returns a list of all logged in users

이전 | 처음으로 | 다음
hw_Who | 위로 | hw_api_attribute->key


hw_api_attribute->key

(no version information, might be only in CVS)

hw_api_attribute->key -- Returns key of the attribute

Description

string key ( void )

Returns the name of the attribute.

See also hwapi_attribute_value().

이전 | 처음으로 | 다음
Hyperwave API Functions | 위로 | hw_api_attribute->langdepvalue


hw_api_attribute->langdepvalue

(no version information, might be only in CVS)

hw_api_attribute->langdepvalue -- Returns value for a given language

Description

string langdepvalue ( string language)

Returns the value in the given language of the attribute.

See also hwapi_attribute_value().

이전 | 처음으로 | 다음
hw_api_attribute->key | 위로 | hw_api_attribute->value


hw_api_attribute->value

(no version information, might be only in CVS)

hw_api_attribute->value -- Returns value of the attribute

Description

string value ( void )

Returns the value of the attribute.

See also hwapi_attribute_key(), hwapi_attribute_values().

이전 | 처음으로 | 다음
hw_api_attribute->langdepvalue | 위로 | hw_api_attribute->values


hw_api_attribute->values

(no version information, might be only in CVS)

hw_api_attribute->values -- Returns all values of the attribute

Description

array values ( void )

Returns all values of the attribute as an array of strings.

See also hwapi_attribute_value().

이전 | 처음으로 | 다음
hw_api_attribute->value | 위로 | hw_api_attribute


hw_api_attribute

(no version information, might be only in CVS)

hw_api_attribute -- Creates instance of class hw_api_attribute

Description

object attribute ( [string name [, string value]])

Creates a new instance of hw_api_attribute with the given name and value.

이전 | 처음으로 | 다음
hw_api_attribute->values | 위로 | hw_api->checkin


hw_api->checkin

(no version information, might be only in CVS)

hw_api->checkin -- Checks in an object

Description

object checkin ( array parameter)

This function checks in an object or a whole hiearchie of objects. The parameters array contains the required element 'objectIdentifier' and the optional element 'version', 'comment', 'mode' and 'objectQuery'. 'version' sets the version of the object. It consists of the major and minor version separated by a period. If the version is not set, the minor version is incremented. 'mode' can be one of the following values:

HW_API_CHECKIN_NORMAL

Checks in and commits the object. The object must be a document.

HW_API_CHECKIN_RECURSIVE

If the object to check in is a collection, all children will be checked in recursively if they are documents. Trying to check in a collection would result in an error.

HW_API_CHECKIN_FORCE_VERSION_CONTROL

Checks in an object even if it is not under version control.

HW_API_CHECKIN_REVERT_IF_NOT_CHANGED

Check if the new version is different from the last version. Unless this is the case the object will be checked in.

HW_API_CHECKIN_KEEP_TIME_MODIFIED

Keeps the time modified from the most recent object.

HW_API_CHECKIN_NO_AUTO_COMMIT

The object is not automatically committed on check-in.

See also hwapi_checkout().

이전 | 처음으로 | 다음
hw_api_attribute | 위로 | hw_api->checkout


hw_api->checkout

(no version information, might be only in CVS)

hw_api->checkout -- Checks out an object

Description

object checkout ( array parameter)

This function checks out an object or a whole hiearchie of objects. The parameters array contains the required element 'objectIdentifier' and the optional element 'version', 'mode' and 'objectQuery'. 'mode' can be one of the following values:

HW_API_CHECKIN_NORMAL

Checks out an object. The object must be a document.

HW_API_CHECKIN_RECURSIVE

If the object to check out is a collection, all children will be checked out recursively if they are documents. Trying to check out a collection would result in an error.

See also hwapi_checkin().

이전 | 처음으로 | 다음
hw_api->checkin | 위로 | hw_api->children


hw_api->children

(no version information, might be only in CVS)

hw_api->children -- Returns children of an object

Description

array children ( array parameter)

Retrieves the children of a collection or the attributes of a document. The children can be further filtered by specifying an object query. The parameter array contains the required elements 'objectIdentifier' and the optional elements 'attributeSelector' and 'objectQuery'.

The return value is an array of objects of type HW_API_Object or HW_API_Error.

See also hwapi_parents().

이전 | 처음으로 | 다음
hw_api->checkout | 위로 | hw_api_content->mimetype


hw_api_content->mimetype

(no version information, might be only in CVS)

hw_api_content->mimetype -- Returns mimetype

Description

string mimetype ( void )

Returns the mimetype of the content.

이전 | 처음으로 | 다음
hw_api->children | 위로 | hw_api_content->read


hw_api_content->read

(no version information, might be only in CVS)

hw_api_content->read -- Read content

Description

string read ( string buffer, integer len)

Reads len bytes from the content into the given buffer.

이전 | 처음으로 | 다음
hw_api_content->mimetype | 위로 | hw_api->content


hw_api->content

(no version information, might be only in CVS)

hw_api->content -- Returns content of an object

Description

object content ( array parameter)

This function returns the content of a document as an object of type hw_api_content. The parameter array contains the required elements 'objectidentifier' and the optional element 'mode'. The mode can be one of the constants HW_API_CONTENT_ALLLINKS, HW_API_CONTENT_REACHABLELINKS or HW_API_CONTENT_PLAIN. HW_API_CONTENT_ALLLINKS means to insert all anchors even if the destination is not reachable. HW_API_CONTENT_REACHABLELINKS tells hw_api_content() to insert only reachable links and HW_API_CONTENT_PLAIN will lead to document without any links.

이전 | 처음으로 | 다음
hw_api_content->read | 위로 | hw_api->copy


hw_api->copy

(no version information, might be only in CVS)

hw_api->copy -- Copies physically

Description

object copy ( array parameter)

This function will make a physical copy including the content if it exists and returns the new object or an error object. The parameter array contains the required elements 'objectIdentifier' and 'destinationParentIdentifier'. The optional parameter is 'attributeSelector'`

See also hwapi_move(), hwapi_link().

이전 | 처음으로 | 다음
hw_api->content | 위로 | hw_api->dbstat


hw_api->dbstat

(no version information, might be only in CVS)

hw_api->dbstat -- Returns statistics about database server

Description

object dbstat ( array parameter)

See also hwapi_dcstat(),
         hwapi_hwstat(),
         hwapi_ftstat().

이전 | 처음으로 | 다음
hw_api->copy | 위로 | hw_api->dcstat


hw_api->dcstat

(no version information, might be only in CVS)

hw_api->dcstat -- Returns statistics about document cache server

Description

object dcstat ( array parameter)

See also hwapi_hwstat(),
         hwapi_dbstat(),
         hwapi_ftstat().

이전 | 처음으로 | 다음
hw_api->dbstat | 위로 | hw_api->dstanchors


hw_api->dstanchors

(no version information, might be only in CVS)

hw_api->dstanchors -- Returns a list of all destination anchors

Description

object dstanchors ( array parameter)

Retrieves all destination anchors of an object. The parameter array contains the required element 'objectIdentifier' and the optional elements 'attributeSelector' and 'objectQuery'.

See also hwapi_srcanchors().

이전 | 처음으로 | 다음
hw_api->dcstat | 위로 | hw_api->dstofsrcanchors


hw_api->dstofsrcanchors

(no version information, might be only in CVS)

hw_api->dstofsrcanchors -- Returns destination of a source anchor

Description

object dstofsrcanchors ( array parameter)

Retrieves the destination object pointed by the specified source anchors. The destination object can either be a destination anchor or a whole document. The parameters array contains the required element 'objectIdentifier' and the optional element 'attributeSelector'.

See also hwapi_srcanchors(),
         hwapi_dstanchors(),
         hwapi_objectbyanchor().

이전 | 처음으로 | 다음
hw_api->dstanchors | 위로 | hw_api_error->count


hw_api_error->count

(no version information, might be only in CVS)

hw_api_error->count -- Returns number of reasons

Description

int count ( void )

Returns the number of error reasons.

See also hwapi_error_reason().

이전 | 처음으로 | 다음
hw_api->dstofsrcanchors | 위로 | hw_api_error->reason


hw_api_error->reason

(no version information, might be only in CVS)

hw_api_error->reason -- Returns reason of error

Description

object reason ( void )

Returns the first error reason.

See also hwapi_error_count().

이전 | 처음으로 | 다음
hw_api_error->count | 위로 | hw_api->find


hw_api->find

(no version information, might be only in CVS)

hw_api->find -- Search for objects

Description

array find ( array parameter)

This functions searches for objects either by executing a key or/and full text query. The found objects can further be filtered by an optional object query. They are sorted by their importance. The second search operation is relatively slow and its result can be limited to a certain number of hits. This allows to perform an incremental search, each returning just a subset of all found documents, starting at a given index. The parameter array contains the 'keyquery' or/and 'fulltextquery' depending on who you would like to search. Optional parameters are 'objectquery', 'scope', 'languages' and 'attributeselector'. In case of an incremental search the optional parameters 'startIndex', numberOfObjectsToGet' and 'exactMatchUnit' can be passed.

이전 | 처음으로 | 다음
hw_api_error->reason | 위로 | hw_api->ftstat


hw_api->ftstat

(no version information, might be only in CVS)

hw_api->ftstat -- Returns statistics about fulltext server

Description

object ftstat ( array parameter)

See also hwapi_dcstat(),
         hwapi_dbstat(),
         hwapi_hwstat().

이전 | 처음으로 | 다음
hw_api->find | 위로 | hwapi_hgcsp


hwapi_hgcsp

(no version information, might be only in CVS)

hwapi_hgcsp -- Returns object of class hw_api

Description

object hwapi_hgcsp ( string hostname [, int port])

Opens a connection to the Hyperwave server on host hostname. The protocol used is HGCSP. If you do not pass a port number, 418 is used.

See also hwapi_hwtp().

이전 | 처음으로 | 다음
hw_api->ftstat | 위로 | hw_api->hwstat


hw_api->hwstat

(no version information, might be only in CVS)

hw_api->hwstat -- Returns statistics about Hyperwave server

Description

object hwstat ( array parameter)

See also hwapi_dcstat(),
         hwapi_dbstat(),
         hwapi_ftstat().

이전 | 처음으로 | 다음
hwapi_hgcsp | 위로 | hw_api->identify


hw_api->identify

(no version information, might be only in CVS)

hw_api->identify -- Log into Hyperwave Server

Description

object identify ( array parameter)

Logs into the Hyperwave Server. The parameter array must contain the elements 'username' and 'password'.

The return value will be an object of type HW_API_Error if identification failed or TRUE if it was successful.

이전 | 처음으로 | 다음
hw_api->hwstat | 위로 | hw_api->info


hw_api->info

(no version information, might be only in CVS)

hw_api->info -- Returns information about server configuration

Description

object info ( array parameter)

See also hwapi_dcstat(),
         hwapi_dbstat(),
         hwapi_ftstat(),
         hwapi_hwstat().

이전 | 처음으로 | 다음
hw_api->identify | 위로 | hw_api->insert


hw_api->insert

(no version information, might be only in CVS)

hw_api->insert -- Inserts a new object

Description

object insert ( array parameter)

Insert a new object. The object type can be user, group, document or anchor. Depending on the type other object attributes has to be set. The parameter array contains the required elements 'object' and 'content' (if the object is a document) and the optional parameters 'parameters', 'mode' and 'attributeSelector'. The 'object' must contain all attributes of the object. 'parameters' is an object as well holding further attributes like the destination (attribute key is 'Parent'). 'content' is the content of the document. 'mode' can be a combination of the following flags:

HW_API_INSERT_NORMAL

The object in inserted into the server.

HW_API_INSERT_FORCE_VERSION_CONTROL

HW_API_INSERT_AUTOMATIC_CHECKOUT

HW_API_INSERT_PLAIN

HW_API_INSERT_KEEP_TIME_MODIFIED

HW_API_INSERT_DELAY_INDEXING

See also hwapi_replace().

이전 | 처음으로 | 다음
hw_api->info | 위로 | hw_api->insertanchor


hw_api->insertanchor

(no version information, might be only in CVS)

hw_api->insertanchor -- Inserts a new object of type anchor

Description

object insertanchor ( array parameter)

This function is a shortcut for hwapi_insert(). It inserts an object of type anchor and sets some of the attributes required for an anchor. The parameter array contains the required elements 'object' and 'documentIdentifier' and the optional elements 'destinationIdentifier', 'parameter', 'hint' and 'attributeSelector'. The 'documentIdentifier' specifies the document where the anchor shall be inserted. The target of the anchor is set in 'destinationIdentifier' if it already exists. If the target does not exists the element 'hint' has to be set to the name of object which is supposed to be inserted later. Once it is inserted the anchor target is resolved automatically.

See also hwapi_insertdocument(),
         hwapi_insertcollection(),
         hwapi_insert().

이전 | 처음으로 | 다음
hw_api->insert | 위로 | hw_api->insertcollection


hw_api->insertcollection

(no version information, might be only in CVS)

hw_api->insertcollection -- Inserts a new object of type collection

Description

object insertcollection ( array parameter)

This function is a shortcut for hwapi_insert(). It inserts an object of type collection and sets some of the attributes required for a collection. The parameter array contains the required elements 'object' and 'parentIdentifier' and the optional elements 'parameter' and 'attributeSelector'. See hwapi_insert() for the meaning of each element.

See also hwapi_insertdocument(),
         hwapi_insertanchor(),
         hwapi_insert().

이전 | 처음으로 | 다음
hw_api->insertanchor | 위로 | hw_api->insertdocument


hw_api->insertdocument

(no version information, might be only in CVS)

hw_api->insertdocument -- Inserts a new object of type document

Description

object insertdocument ( array parameter)

This function is a shortcut for hwapi_insert(). It inserts an object with content and sets some of the attributes required for a document. The parameter array contains the required elements 'object', 'parentIdentifier' and 'content' and the optional elements 'mode', 'parameter' and 'attributeSelector'. See hwapi_insert() for the meaning of each element.

See also hwapi_insert()
         hwapi_insertanchor(),
         hwapi_insertcollection().

이전 | 처음으로 | 다음
hw_api->insertcollection | 위로 | hw_api->link


hw_api->link

(no version information, might be only in CVS)

hw_api->link -- Creates a link to an object

Description

object link ( array parameter)

Creates a link to an object. Accessing this link is like accessing the object to links points to. The parameter array contains the required elements 'objectIdentifier' and 'destinationParentIdentifier'. 'destinationParentIdentifier' is the target collection.

The function returns TRUE on success or an error object.

See also hwapi_copy().

이전 | 처음으로 | 다음
hw_api->insertdocument | 위로 | hw_api->lock


hw_api->lock

(no version information, might be only in CVS)

hw_api->lock -- Locks an object

Description

object lock ( array parameter)

Locks an object for exclusive editing by the user calling this function. The object can be only unlocked by this user or the system user. The parameter array contains the required element 'objectIdentifier' and the optional parameters 'mode' and 'objectquery'. 'mode' determines how an object is locked. HW_API_LOCK_NORMAL means, an object is locked until it is unlocked. HW_API_LOCK_RECURSIVE is only valid for collection and locks all objects within the collection and possible subcollections. HW_API_LOCK_SESSION means, an object is locked only as long as the session is valid.

See also hwapi_unlock().

이전 | 처음으로 | 다음
hw_api->link | 위로 | hw_api->move


hw_api->move

(no version information, might be only in CVS)

hw_api->move -- Moves object between collections

Description

object move ( array parameter)

See also hw_objrec2array().

이전 | 처음으로 | 다음
hw_api->lock | 위로 | hw_api_content


hw_api_content

(no version information, might be only in CVS)

hw_api_content -- Create new instance of class hw_api_content

Description

string content ( string content, string mimetype)

Creates a new content object from the string content. The mimetype is set to mimetype.

이전 | 처음으로 | 다음
hw_api->move | 위로 | hw_api_object->assign


hw_api_object->assign

(no version information, might be only in CVS)

hw_api_object->assign -- Clones object

Description

object assign ( array parameter)

Clones the attributes of an object.

이전 | 처음으로 | 다음
hw_api_content | 위로 | hw_api_object->attreditable


hw_api_object->attreditable

(no version information, might be only in CVS)

hw_api_object->attreditable -- Checks whether an attribute is editable

Description

bool attreditable ( array parameter)

이전 | 처음으로 | 다음
hw_api_object->assign | 위로 | hw_api_object->count


hw_api_object->count

(no version information, might be only in CVS)

hw_api_object->count -- Returns number of attributes

Description

int count ( array parameter)

이전 | 처음으로 | 다음
hw_api_object->attreditable | 위로 | hw_api_object->insert


hw_api_object->insert

(no version information, might be only in CVS)

hw_api_object->insert -- Inserts new attribute

Description

bool insert ( object attribute)

Adds an attribute to the object. Returns TRUE on success and otherwise FALSE.

See also hwapi_object_remove().

이전 | 처음으로 | 다음
hw_api_object->count | 위로 | hw_api_object


hw_api_object

(no version information, might be only in CVS)

hw_api_object -- Creates a new instance of class hw_api_object

Description

object hw_api_object ( array parameter)

See also hwapi_lock().

이전 | 처음으로 | 다음
hw_api_object->insert | 위로 | hw_api_object->remove


hw_api_object->remove

(no version information, might be only in CVS)

hw_api_object->remove -- Removes attribute

Description

bool remove ( string name)

Removes the attribute with the given name. Returns TRUE on success and otherwise FALSE.

See also hwapi_object_insert().

이전 | 처음으로 | 다음
hw_api_object | 위로 | hw_api_object->title


hw_api_object->title

(no version information, might be only in CVS)

hw_api_object->title -- Returns the title attribute

Description

string title ( array parameter)

이전 | 처음으로 | 다음
hw_api_object->remove | 위로 | hw_api_object->value


hw_api_object->value

(no version information, might be only in CVS)

hw_api_object->value -- Returns value of attribute

Description

string value ( string name)

Returns the value of the attribute with the given name or FALSE if an error occurred.

이전 | 처음으로 | 다음
hw_api_object->title | 위로 | hw_api->object


hw_api->object

(no version information, might be only in CVS)

hw_api->object -- Retrieve attribute information

Description

object hw_api->object ( array parameter)

This function retrieves the attribute information of an object of any version. It will not return the document content. The parameter array contains the required elements 'objectIdentifier' and the optional elements 'attributeSelector' and 'version'.

The returned object is an instance of class HW_API_Object on success or HW_API_Error if an error occurred.

This simple example retrieves an object and checks for errors.

예 1. Retrieve an object

<?php
function handle_error($error)
{
  $reason = $error->reason(0);
  echo "Type: <b>";
  switch ($reason->type()) {
    case 0:
      echo "Error";
      break;
    case 1:
      echo "Warning";
      break;
    case 2:
      echo "Message";
      break;
  }
  echo "</b><br />\n";
  echo "Description: " . $reason->description("en") . "<br />\n";
}

function list_attr($obj)
{
  echo "<table>\n";
  $count = $obj->count();
  for ($i=0; $i<$count; $i++) {
    $attr = $obj->attribute($i);
    printf("<tr><td align=\"right\" bgcolor=\"#c0c0c0\"><b>%s</b></td><td bgcolor=\"#F0F0F0\">%s</td></tr>\n",
             $attr->key(), $attr->value());
  }
  echo "</table>\n";
}

$hwapi = hwapi_hgcsp($g_config[HOSTNAME]);
$parms = array("objectIdentifier"=>"rootcollection", "attributeSelector"=>array("Title", "Name", "DocumentType"));
$root = $hwapi->object($parms);
if (get_class($root) == "HW_API_Error") {
  handle_error($root);
  exit;
}
list_attr($root);
?>

See also hwapi_content().

이전 | 처음으로 | 다음
hw_api_object->value | 위로 | hw_api->objectbyanchor


hw_api->objectbyanchor

(no version information, might be only in CVS)

hw_api->objectbyanchor -- Returns the object an anchor belongs to

Description

object objectbyanchor ( array parameter)

This function retrieves an object the specified anchor belongs to. The parameter array contains the required element 'objectIdentifier' and the optional element 'attributeSelector'.

See also hwapi_dstofsrcanchor(),
         hwapi_srcanchors(),
         hwapi_dstanchors().

이전 | 처음으로 | 다음
hw_api->object | 위로 | hw_api->parents


hw_api->parents

(no version information, might be only in CVS)

hw_api->parents -- Returns parents of an object

Description

array parents ( array parameter)

Retrieves the parents of an object. The parents can be further filtered by specifying an object query. The parameter array contains the required elements 'objectidentifier' and the optional elements 'attributeselector' and 'objectquery'.

The return value is an array of objects of type HW_API_Object or HW_API_Error.

See also hwapi_children().

이전 | 처음으로 | 다음
hw_api->objectbyanchor | 위로 | hw_api_reason->description


hw_api_reason->description

(no version information, might be only in CVS)

hw_api_reason->description -- Returns description of reason

Description

string description ( void )

Returns the description of a reason

이전 | 처음으로 | 다음
hw_api->parents | 위로 | hw_api_reason->type


hw_api_reason->type

(no version information, might be only in CVS)

hw_api_reason->type -- Returns type of reason

Description

object type ( void )

Returns the type of a reason.

이전 | 처음으로 | 다음
hw_api_reason->description | 위로 | hw_api->remove


hw_api->remove

(no version information, might be only in CVS)

hw_api->remove -- Delete an object

Description

object remove ( array parameter)

Removes an object from the specified parent. Collections will be removed recursively. You can pass an optional object query to remove only those objects which match the query. An object will be deleted physically if it is the last instance. The parameter array contains the required elements 'objectidentifier' and 'parentidentifier'. If you want to remove a user or group 'parentidentifier' can be skipped. The optional parameter 'mode' determines how the deletion is performed. In normal mode the object will not be removed physically until all instances are removed. In physical mode all instances of the object will be deleted immediately. In removelinks mode all references to and from the objects will be deleted as well. In nonrecursive the deletion is not performed recursive. Removing a collection which is not empty will cause an error.

See also hwapi_move().

이전 | 처음으로 | 다음
hw_api_reason->type | 위로 | hw_api->replace


hw_api->replace

(no version information, might be only in CVS)

hw_api->replace -- Replaces an object

Description

object replace ( array parameter)

Replaces the attributes and the content of an object The parameter array contains the required elements 'objectIdentifier' and 'object' and the optional parameters 'content', 'parameters', 'mode' and 'attributeSelector'. 'objectIdentifier' contains the object to be replaced. 'object' contains the new object. 'content' contains the new content. 'parameters' contain extra information for HTML documents. HTML_Language is the letter abbreviation of the language of the title. HTML_Base sets the base attribute of the HTML document. 'mode' can be a combination of the following flags:

HW_API_REPLACE_NORMAL

The object on the server is replace with the object passed.

HW_API_REPLACE_FORCE_VERSION_CONTROL

HW_API_REPLACE_AUTOMATIC_CHECKOUT

HW_API_REPLACE_AUTOMATIC_CHECKIN

HW_API_REPLACE_PLAIN

HW_API_REPLACE_REVERT_IF_NOT_CHANGED

HW_API_REPLACE_KEEP_TIME_MODIFIED

See also hwapi_insert().

이전 | 처음으로 | 다음
hw_api->remove | 위로 | hw_api->setcommitedversion


hw_api->setcommitedversion

(no version information, might be only in CVS)

hw_api->setcommitedversion -- Commits version other than last version

Description

object setcommitedversion ( array parameter)

Commits a version of a document. The committed version is the one which is visible to users with read access. By default the last version is the committed version.

See also hwapi_checkin(),
         hwapi_checkout(),
         hwapi_revert().

이전 | 처음으로 | 다음
hw_api->replace | 위로 | hw_api->srcanchors


hw_api->srcanchors

(no version information, might be only in CVS)

hw_api->srcanchors -- Returns a list of all source anchors

Description

object srcanchors ( array parameter)

Retrieves all source anchors of an object. The parameter array contains the required element 'objectIdentifier' and the optional elements 'attributeSelector' and 'objectQuery'.

See also hwapi_dstanchors().

이전 | 처음으로 | 다음
hw_api->setcommitedversion | 위로 | hw_api->srcsofdst


hw_api->srcsofdst

(no version information, might be only in CVS)

hw_api->srcsofdst -- Returns source of a destination object

Description

object srcsofdst ( array parameter)

Retrieves all the source anchors pointing to the specified destination. The destination object can either be a destination anchor or a whole document. The parameters array contains the required element 'objectIdentifier' and the optional element 'attributeSelector' and 'objectQuery'. The function returns an array of objects or an error.

See also hwapi_dstofsrcanchor().

이전 | 처음으로 | 다음
hw_api->srcanchors | 위로 | hw_api->unlock


hw_api->unlock

(no version information, might be only in CVS)

hw_api->unlock -- Unlocks a locked object

Description

object unlock ( array parameter)

Unlocks a locked object. Only the user who has locked the object and the system user may unlock an object. The parameter array contains the required element 'objectIdentifier' and the optional parameters 'mode' and 'objectquery'. The meaning of 'mode' is the same as in function hwapi_lock().

Returns TRUE on success or an object of class HW_API_Error.

See also hwapi_lock().

이전 | 처음으로 | 다음
hw_api->srcsofdst | 위로 | hw_api->user


hw_api->user

(no version information, might be only in CVS)

hw_api->user -- Returns the own user object

Description

object user ( array parameter)

See also hwapi_userlist().

이전 | 처음으로 | 다음
hw_api->unlock | 위로 | hw_api->userlist


hw_api->userlist

(no version information, might be only in CVS)

hw_api->userlist -- Returns a list of all logged in users

Description

object userlist ( array parameter)

See also hwapi_user().

이전 | 처음으로 | 다음
hw_api->user | 위로 | iconv 함수


iconv 함수

PHP 매뉴얼
이전 다음

XL. iconv 함수

소개

이 모듈은 iconv 문자셋 변환 기능을 사용하는 인터페이스를 가지고 있습니다. 이 모듈로, 로컬 문자셋을 유니코드 문자셋 등의 다른 문자셋으로 변환할 수 있습니다. 지원하는 문자셋은 시스템의 iconv 실행에 의존합니다. 몇몇 시스템에서는 iconv가 기대한대로 작동하지 않을 수 있는 점에 주의하십시오. GNU libiconv 라이브러리를 설치하면 대부분의 경우에 좋은 결과를 얻을 수 있습니다.

PHP 5.0.0부터, 이 확장 모듈은 다중 언어 스크립트를 작성할 때 도움을 주는 다양한 실용적인 함수를 제공합니다. 새로운 기능에 대해서 아래의 섹션을 살펴보십시오.

요구 사항

최근의 POSIX 호환 시스템을 사용한다면 iconv 기능을 표준 C 라이브러리에서 지원하기 때문에, 추가로 필요한 것이 없습니다. 그렇지 않다면 libiconv 라이브러리를 얻어서 시스템에 설치해야 합니다.

설치

이 모듈이 제공하는 함수를 사용하려면, 설정 옵션 --with-iconv[=DIR]을 사용하여 PHP 바이너리를 빌드해야 합니다.

Windows® 사용자 주의: Windows® 환경에서 이 모듈을 사용하려면, PHP/Win32 바이너리 패키지에 들어 있는 iconv.dll, 또는 iconv-1.3.dll(4.2.1 이전) DLL 파일을 PATH 환경 변수로 지정한 디렉토리나 Windows®의 시스템 디렉토리에 놓아야 합니다.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. Iconv 설정 옵션

이름 | 기본값 | 변경가능성
iconv.input_encoding | ICONV_INPUT_ENCODING | PHP_INI_ALL
iconv.output_encoding | ICONV_OUTPUT_ENCODING | PHP_INI_ALL
iconv.internal_encoding | ICONV_INTERNAL_ENCODING | PHP_INI_ALL
PHP_INI_* 상수에 대한 자세한 내용 및 정의는 ini_set()을 참고하십시오

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

PHP 4.3.0부터 실행시에 이 확장 모듈에서 어느 iconv implementation을 사용할지 결정할 수 있습니다.

표 2. iconv 상수

이름 | 형 | 설명
ICONV_IMPL | string | implementation 이름
ICONV_VERSION | string | implementation 버전

참고: 이 상수들을 사용하여 implementation 의존적인 스크립트를 작성하는 것은 절대 권장하지 않습니다.

PHP 5.0.0부터, 다음의 상수를 사용할 수 있습니다:

표 3. PHP 5.0.0부터 사용할 수 있는 iconv 상수

이름 | 형 | 설명
ICONV_MIME_DECODE_STRICT | integer | iconv_mime_decode()에서 사용하는 비트마스크
ICONV_MIME_DECODE_CONTINUE_ON_ERROR | integer | iconv_mime_decode()에서 사용하는 비트마스크

참고

참고: GNU Recode 함수.

차례
iconv_get_encoding -- 문자 인코딩 변환을 위한 현재 설정 상태를 문의
iconv_mime_decode_headers -- Decodes multiple MIME header fields at once
iconv_mime_decode -- Decodes a MIME header field
iconv_mime_encode -- Composes a MIME header field
iconv_set_encoding -- 문자 인코딩 변환을 설정 Set current setting for character encoding conversion
iconv_strlen -- Returns the character count of string
iconv_strpos -- Finds position of first occurrence of a needle within a haystack.
iconv_strrpos -- Finds the last occurrence of a needle within the specified range of haystack.
iconv_substr -- Cut out part of a string
iconv -- 원하는 문자 인코딩으로 변환한다
ob_iconv_handler -- 출력 버퍼 핸들러로 문자 엔코딩을 변환한다

이전 | 처음으로 | 다음
hw_api->userlist | 위로 | iconv_get_encoding


iconv_get_encoding

(PHP 4 >= 4.0.5, PHP 5)

iconv_get_encoding -- 문자 인코딩 변환을 위한 현재 설정 상태를 문의

Description

array iconv_get_encoding ( [string type])

배열로서 ob_iconv_handler()함수의 현재 설정을 리턴하고, 실패하면, FALSE을 리턴한다.

See also: iconv_set_encoding() and ob_iconv_handler().

이전 | 처음으로 | 다음
iconv 함수 | 위로 | iconv_mime_decode_headers


iconv_mime_decode_headers

(PHP 5)

iconv_mime_decode_headers -- Decodes multiple MIME header fields at once

Description

array iconv_mime_decode_headers ( string encoded_headers [, int mode [, string charset]])

Returns an associative array that holds a whole set of MIME header fields specified by encoded_headers on success, or FALSE if an error occurs during the decoding.

Each key of the return value represents an individual field name and the corresponding element represents a field value. If more than one field of the same name are present, iconv_mime_decode_headers() automatically incorporates them into a numerically indexed array in the order of occurrence.

mode determines the behaviour in the event iconv_mime_decode_headers() encounters a malformed MIME header field. You can specify any combination of the following bitmasks.

표 1. Bitmasks acceptable to iconv_mime_decode_headers()

Value | Constant | Description
1 | ICONV_MIME_DECODE_STRICT | If set, the given header is decoded in full conformance with the standards defined in RFC2047. This option is disabled by default because there are a lot of broken mail user agents that don't follow the specification and don't produce correct MIME headers.
2 | ICONV_MIME_DECODE_CONTINUE_ON_ERROR | If set, iconv_mime_decode_headers() attempts to ignore any grammatical errors and continue to process a given header.

The optional charset parameter specifies the character set to represent the result by. If omitted, iconv.internal_charset will be used.

예 1. iconv_mime_decode_headers() example

<?php
$headers_string = <<<EOF
Subject: =?UTF-8?B?UHLDvGZ1bmcgUHLDvGZ1bmc=?=
To: example@example.com
Date: Thu, 1 Jan 1970 00:00:00 +0000
Message-Id: <example@example.com>
Received: from localhost (localhost [127.0.0.1]) by localhost
    with SMTP id example for <example@example.com>
    Thu, 1 Jan 1970 00:00:00 +0000 (UTC)
    (envelope-from example-return-0000-example=example.com@example.com)
Received: (qmail 0 invoked by uid 65534); 1 Thu 2003 00:00:00 +0000

EOF;
$headers =  iconv_mime_decode_headers($headers_string, 0, "ISO-8859-1");
print_r($headers);
?>

The output of this script should look like:

Array
(
    [Subject] => Pr?fung Pr?fung
    [To] => example@example.com
    [Date] => Thu, 1 Jan 1970 00:00:00 +0000
    [Message-Id] => <example@example.com>
    [Received] => Array
        (
            [0] => from localhost (localhost [127.0.0.1]) by localhost with SMTP id example for <example@example.com>; Thu, 1 Jan 1970 00:00:00 +0000 (UTC) (envelope-from example-return-0000-example=example.com@example.com)
            [1] => (qmail 0 invoked by uid 65534); 1 Thu 2003 00:00:00 +0000
        )

)

See also iconv_mime_decode(),
mb_decode_mimeheader(),
imap_mime_header_decode(),
imap_base64()
and imap_qprint().

이전 | 처음으로 | 다음
iconv_get_encoding | 위로 | iconv_mime_decode


iconv_mime_decode

(PHP 5)

iconv_mime_decode -- Decodes a MIME header field

Description

string iconv_mime_decode ( string encoded_header [, int mode [, string charset]])

Returns a decoded MIME field on success, or FALSE if an error occurs during the decoding.

mode determines the behaviour in the event iconv_mime_decode() encounters a malformed MIME header field. You can specify any combination of the following bitmasks.

표 1. Bitmasks acceptable to iconv_mime_decode()

Value | Constant | Description
1 | ICONV_MIME_DECODE_STRICT | If set, the given header is decoded in full conformance with the standards defined in RFC2047. This option is disabled by default because there are a lot of broken mail user agents that don't follow the specification and don't produce correct MIME headers.
2 | ICONV_MIME_DECODE_CONTINUE_ON_ERROR | If set, iconv_mime_decode() attempts to continue to process the given header even though an error occurs.

The optional charset parameter specifies the character set to represent the result by. If omitted, iconv.internal_charset will be used.

예 1. iconv_mime_decode() example

<?php
// This yields "Subject: Pr?fung Pr?fung"
echo iconv_mime_decode("Subject: =?UTF-8?B?UHLDvGZ1bmcgUHLDvGZ1bmc=?=",
                       0, "ISO-8859-1");
?>

See also iconv_mime_decode_headers(),
mb_decode_mimeheader(),
imap_mime_header_decode(),
imap_base64()
and imap_qprint().

이전 | 처음으로 | 다음
iconv_mime_decode_headers | 위로 | iconv_mime_encode


iconv_mime_encode

(PHP 5)

iconv_mime_encode -- Composes a MIME header field

Description

string iconv_mime_encode ( string field_name, string field_value [, array preferences])

Composes and returns a string that represents a valid MIME header field, which looks like the following:
Subject: =?ISO-8859-1?Q?Pr=FCfung_f=FCr?= Entwerfen von einer MIME kopfzeile
In the above example, "Subject" is the field name and the portion that begins with "=?ISO-8859-1?..." is the field value.

You can control the behaviour of iconv_mime_encode() by specifying an associative array that contains configuration items to the optional third parameter preferences. The items supported by iconv_mime_encode() are listed below. Note that item names are treated case-sensitive.

표 1. Configuration items supported by iconv_mime_encode()

Item | Type | Description | Default value | Example
scheme | boolean | Specifies the method to encode a field value by. The value of this item may be either "B" or "Q", where "B" stands for base64 encoding scheme and "Q" stands for quoted-printable encoding scheme. | B | B
input-charset | string | Specifies the character set in which the first parameter field_name and the second parameter field_value are presented. If not given, iconv_mime_encode() assumes those parameters are presented to it in the iconv.internal_charset ini setting. | iconv.internal_charset | ISO-8859-1
output-charset | string | Specifies the character set to use to compose the MIME header. If not given, the same value as input-charset will be used. | the same value as input-charset | UTF-8
line-length | integer | Specifies the maximum length of the header lines. The resulting header is "folded" to a set of multiple lines in case the resulting header field would be longer than the value of this parameter, according to RFC2822 - Internet Message Format. If not given, the length will be limited to 76 characters. | 76 | 996
line-break-chars | string | Specifies the sequence of characters to append to each line as an end-of-line sign when "folding" is performed on a long header field. If not given, this defaults to "\r\n" (CR LF). Note that this parameter is always treated as an ASCII string regardless of the value of input-charset. | \r\n | \n

예 1. iconv_mime_encode() example:

<?php
$preferences = array(
    "input-charset" => "ISO-8859-1",
    "output-charset" => "UTF-8",
    "line-length" => 76,
    "line-break-chars" => "\n"
);
$preferences["scheme"] = "Q";
// This yields "Subject: =?UTF-8?Q?Pr=C3=BCfung_Pr=C3=BCfung?="
echo iconv_mime_encode("Subject", "Pr?fung Pr?fung", $preferences);

$preferences["scheme"] = "B";
// This yields "Subject: =?UTF-8?B?UHLDvGZ1bmcgUHLDvGZ1bmc=?="
echo iconv_mime_encode("Subject", "Pr?fung Pr?fung", $preferences);
?>

See also imap_binary(),
mb_encode_mimeheader()
and imap_8bit().

이전 | 처음으로 | 다음
iconv_mime_decode | 위로 | iconv_set_encoding


iconv_set_encoding

(PHP 4 >= 4.0.5, PHP 5)

iconv_set_encoding -- 문자 인코딩 변환을 설정 Set current setting for character encoding conversion

Description

array iconv_set_encoding ( string type, string charset)

type을 charset로 변경하고 성공하면 TRUE를 실패하면 FALSE를 리턴한다.

예 1. iconv_set_encoding() example:

iconv_set_encoding("internal_encoding", "UTF-8");
iconv_set_encoding("output_encoding", "ISO-8859-1");

See also: iconv_get_encoding() and ob_iconv_handler().

이전 | 처음으로 | 다음
iconv_mime_encode | 위로 | iconv_strlen


iconv_strlen

(PHP 5)

iconv_strlen -- Returns the character count of string

Description

int iconv_strlen ( string str [, string charset])

Returns the character count of str.

In contrast to strlen(), iconv_strlen() counts the occurrences of characters in the given byte sequence str on the basis of the specified character set, the result of which is not necessarily identical to the length of the string in byte.

If charset parameter is omitted, str is assumed to be encoded in iconv.internal_charset.

See also strlen() and mb_strlen().

이전 | 처음으로 | 다음
iconv_set_encoding | 위로 | iconv_strpos


iconv_strpos

(PHP 5)

iconv_strpos -- Finds position of first occurrence of a needle within a haystack.

Description

int iconv_strpos ( string haystack, string needle, int offset [, string charset])

Returns the numeric position of the first occurrence of needle in haystack.

The optional offset parameter specifies the position from which the search should be performed.

If needle is not found, iconv_strpos() will return FALSE.

주의

이 함수는 Boolean FALSE를 반환하지만, 0이나 ""와 같은 FALSE로 취급하는 Boolean이 아닌 값을 반환할 수도 있습니다. Booleans 섹션에서 자세한 정보를 얻을 수 있습니다. 이 함수의 반환값을 테스트하기 위해서 === 연산자를 이용하십시오.

If haystack or needle is not a string, it is converted to a string and applied as the ordinal value of a character.

In contrast to strpos(), the return value of iconv_strpos() is the number of characters that appear before the needle, rather than the offset in bytes to the position where the needle has been found. The characters are counted on the basis of the specified character set charset.

If charset parameter is omitted, string are assumed to be encoded in iconv.internal_charset.

See also strpos(), iconv_strrpos() and mb_strpos().

이전 | 처음으로 | 다음
iconv_strlen | 위로 | iconv_strrpos


iconv_strrpos

(PHP 5)

iconv_strrpos -- Finds the last occurrence of a needle within the specified range of haystack.

Description

string iconv_strrpos ( string haystack, string needle [, string charset])

Returns the numeric position of the last occurrence of needle in haystack.

If needle is not found, iconv_strrpos() will return FALSE.

주의

이 함수는 Boolean FALSE를 반환하지만, 0이나 ""와 같은 FALSE로 취급하는 Boolean이 아닌 값을 반환할 수도 있습니다. Booleans 섹션에서 자세한 정보를 얻을 수 있습니다. 이 함수의 반환값을 테스트하기 위해서 === 연산자를 이용하십시오.

If haystack or needle is not a string, it is converted to a string and applied as the ordinal value of a character.

In contrast to strpos(), the return value of iconv_strrpos() is the number of characters that appear before the needle, rather than the offset in bytes to the position where the needle has been found. The characters are counted on the basis of the specified character set charset.

See also strrpos(), iconv_strpos() and mb_strrpos().

이전 | 처음으로 | 다음
iconv_strpos | 위로 | iconv_substr


iconv_substr

(PHP 5)

iconv_substr -- Cut out part of a string

Description

string iconv_substr ( string str, int offset [, int length [, string charset]])

Returns the portion of str specified by the start and length parameters.

If start is non-negative, iconv_substr() cuts the portion out of str beginning at start'th character, counting from zero.

If start is negative, iconv_substr() cuts out the portion beginning at the position, start characters away from the end of str.

If length is given and is positive, the return value will contain at most length characters of the portion that begins at start (depending on the length of string). If str is shorter than start characters long, FALSE will be returned.

If negative length is passed, iconv_substr() cuts the portion out of str from the start'th character up to the character that is length characters away from the end of the string. In case start is also negative, the start position is calculated beforehand according to the rule explained above.

Note that offset and length parameters are always deemed to represent offsets that are calculated on the basis of the character set determined by charset, whilst the counterpart substr() always takes these for byte offsets. If charset is not given, the character set is determined by the iconv.internal_charset ini setting.

See also substr(), mb_substr() and mb_strcut().

이전 | 처음으로 | 다음
iconv_strrpos | 위로 | iconv


iconv

(PHP 4 >= 4.0.5, PHP 5)

iconv -- 원하는 문자 인코딩으로 변환한다

Description

string iconv ( string in_charset, string out_charset, string str)

in_charset으로 인코드된 string을 out_charset으로 인코딩된 string으로 변환한다. 변환된 문자열을 리턴하거나, 실패하면 FALSE을 리턴한다.

예 1. iconv() example:

echo iconv("ISO-8859-1","UTF-8","This is test.");

이전 | 처음으로 | 다음
iconv_substr | 위로 | ob_iconv_handler


ob_iconv_handler

(PHP 4 >= 4.0.5, PHP 5)

ob_iconv_handler -- 출력 버퍼 핸들러로 문자 엔코딩을 변환한다

Description

array ob_iconv_handler ( string contents, int status)

internal_encoding에서 인코딩된 문자열을 output_encoding로 변환한다.

internal_encoding과 output_encoding는 iconv_set_encoding()함수나 설정파일에서 정의되어있어야 한다.

예 1. ob_iconv_handler() example:

ob_start("ob_iconv_handler"); // start output buffering

See also: iconv_get_encoding() and iconv_set_encoding().

이전 | 처음으로 | 다음
iconv | 위로 | Image Functions


Image Functions

PHP 매뉴얼
이전 다음

XLI. Image Functions

소개

PHP is not limited to creating just HTML output. It can also be used to create and manipulate image files in a variety of different image formats, including gif, png, jpg, wbmp, and xpm. Even more convenient, PHP can output image streams directly to a browser. You will need to compile PHP with the GD library of image functions for this to work. GD and PHP may also require other libraries, depending on which image formats you want to work with.

You can use the image functions in PHP to get the size of JPEG, GIF, PNG, SWF, TIFF and JPEG2000 images.

참고: Read requirements section about how to expand image capabilities to read, write and modify images and to read meta data of pictures taken by digital cameras.

요구 사항

If you have the GD library (available at http://www.boutell.com/gd/) you will also be able to create and manipulate images.

The format of images you are able to manipulate depend on the version of GD you install, and any other libraries GD might need to access those image formats. Versions of GD older than gd-1.6 support GIF format images, and do not support PNG, where versions greater than gd-1.6 support PNG, not GIF.

참고: Since PHP 4.3 there is a bundled version of the GD lib. This bundled version has some additional features like alpha blending, and should be used in preference to the external library since its codebase is better maintained and more stable.

You may wish to enhance GD to handle more image formats.

표 1. Supported image formats

Image format | Library to download | Notes
gif |  | Only supported in GD versions older than gd-1.6. Read-only GIF support is available with PHP 4.3.0 and the bundled GD-library.
jpeg-6b | ftp://ftp.uu.net/graphics/jpeg/ |
png | http://www.libpng.org/pub/png/libpng.html | Only supported in GD versions greater than gd-1.6.
xpm | ftp://metalab.unc.edu/pub/Linux/libs/X/!INDEX.html | It's likely you have this library already available, if your system has an installed X-Environment.

You may wish to enhance GD to deal with different fonts. The following font libraries are supported:

표 2. Supported font libraries

Font library | Download | Notes
FreeType 1.x | http://www.freetype.org/ |
FreeType 2 | http://www.freetype.org/ |
T1lib | ftp://sunsite.unc.edu/pub/Linux/libs/graphics/) | Support for Type 1 fonts.

If you have PHP compiled with --enable-exif you are able to work with information stored in headers of JPEG and TIFF images. This way you can read meta data generated by digital cameras as mentioned above. These functions do not require the GD library.

참고: PHP does not require any additional library for the exif module.

설치

To enable GD-support configure PHP --with-gd[=DIR], where DIR is the GD base install directory. To use the recommended bundled version of the GD library (which was first bundled in PHP 4.3.0), use the configure option --with-gd. In Windows, you'll include the GD2 DLL php_gd2.dll as an extension in php.ini. The GD1 DLL php_gd.dll was removed in PHP 4.3.2. Also note that the preferred truecolor image functions, such as imagecreatetruecolor(), require GD2.

To enable exif support in Windows, php_mbstring.dll must be loaded prior to php_exif.dll in php.ini.

To disable GD support in PHP 3 add --without-gd to your configure line.

Enhance the capabilities of GD to handle more image formats by specifying the --with-XXXX configure switch to your PHP configure line.

표 3. Supported image formats

Image Format | Configure Switch
jpeg-6b | To enable support for jpeg-6b add --with-jpeg-dir=DIR.
png | To enable support for png add --with-png-dir=DIR. Note, libpng requires the zlib library, therefore add --with-zlib-dir[=DIR] to your configure line.
xpm | To enable support for xpm add --with-xpm-dir=DIR. If configure is not able to find the required libraries, you may add the path to your X11 libraries.

참고: When compiling PHP with libpng, you must use the same version that was linked with the GD library.

Enhance the capabilities of GD to deal with different fonts by specifying the --with-XXXX configure switch to your PHP configure line.

표 4. Supported font libraries

Font library | Configure Switch
FreeType 1.x | To enable support for FreeType 1.x add --with-ttf[=DIR].
FreeType 2 | To enable support for FreeType 2 add --with-freetype-dir=DIR.
T1lib | To enable support for T1lib (Type 1 fonts) add --with-t1lib[=DIR].
Native TrueType string function | To enable support for native TrueType string function add --enable-gd-native-ttf.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

Exif supports automatically conversion for Unicode and JIS character encodings of user comments when module mbstring is available. This is done by first decoding the comment using the specified characterset. The result is then encoded with another characterset which should match your HTTP output.

표 5. Exif configuration options

Name | Default | Changeable
exif.encode_unicode | "ISO-8859-15" | PHP_INI_ALL
exif.decode_unicode_motorola | "UCS-2BE" | PHP_INI_ALL
exif.decode_unicode_intel | "UCS-2LE" | PHP_INI_ALL
exif.encode_jis | "" | PHP_INI_ALL
exif.decode_jis_motorola | "JIS" | PHP_INI_ALL
exif.decode_jis_intel | "JIS" | PHP_INI_ALL
For further details and definition of the PHP_INI_* constants see ini_set().

위 설정 지시어에 대한 간단한 설명입니다.

exif.encode_unicode string

exif.encode_unicode defines the characterset UNICODE user comments are handled. This defaults to ISO-8859-15 which should work for most non Asian countries. The setting can be empty or must be an encoding supported by mbstring. If it is empty the current internal encoding of mbstring is used.

exif.decode_unicode_motorola string

exif.decode_unicode_motorola defines the image internal characterset for Unicode encoded user comments if image is in motorola byte order (big-endian). This setting cannot be empty but you can specify a list of encodings supported by mbstring. The default is UCS-2BE.

exif.decode_unicode_intel string

exif.decode_unicode_intel defines the image internal characterset for Unicode encoded user comments if image is in intel byte order (little-endian). This setting cannot be empty but you can specify a list of encodings supported by mbstring. The default is UCS-2LE.

exif.encode_jis string

exif.encode_jis defines the characterset JIS user comments are handled. This defaults to an empty value which forces the functions to use the current internal encoding of mbstring.

exif.decode_jis_motorola string

exif.decode_jis_motorola defines the image internal characterset for JIS encoded user comments if image is in motorola byte order (big-endian). This setting cannot be empty but you can specify a list of encodings supported by mbstring. The default is JIS.

exif.decode_jis_intel string

exif.decode_jis_intel defines the image internal characterset for JIS encoded user comments if image is in intel byte order (little-endian). This setting cannot be empty but you can specify a list of encodings supported by mbstring. The default is JIS.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

IMG_GIF (integer)

IMG_JPG (integer)

IMG_JPEG (integer)

IMG_PNG (integer)

IMG_WBMP (integer)

IMG_XPM (integer)

IMG_COLOR_TILED (integer)

IMG_COLOR_STYLED (integer)

IMG_COLOR_BRUSHED (integer)

IMG_COLOR_STYLEDBRUSHED (integer)

IMG_COLOR_TRANSPARENT (integer)

IMG_ARC_ROUNDED (integer)

IMG_ARC_PIE (integer)

IMG_ARC_CHORD (integer)

IMG_ARC_NOFILL (integer)

IMG_ARC_EDGED (integer)

IMAGETYPE_GIF (integer)

IMAGETYPE_JPEG (integer)

IMAGETYPE_PNG (integer)

IMAGETYPE_SWF (integer)

IMAGETYPE_PSD (integer)

IMAGETYPE_BMP (integer)

IMAGETYPE_WBMP (integer)

IMAGETYPE_XBM (integer)

IMAGETYPE_TIFF_II (integer)

IMAGETYPE_TIFF_MM (integer)

IMAGETYPE_IFF (integer)

IMAGETYPE_JB2 (integer)

IMAGETYPE_JPC (integer)

IMAGETYPE_JP2 (integer)

IMAGETYPE_JPX (integer)

IMAGETYPE_SWC (integer)

예제

예 1. PNG creation with PHP

<?php
    header("Content-type: image/png");
    $string = $_GET['text'];
    $im     = imagecreatefrompng("images/button1.png");
    $orange = imagecolorallocate($im, 220, 210, 60);
    $px     = (imagesx($im) - 7.5 * strlen($string)) / 2;
    imagestring($im, 3, $px, 9, $string, $orange);
    imagepng($im);
    imagedestroy($im);
?>
This example would be called from a page with a tag like: <img src="button.php?text=text">. The above button.php script then takes this "text" string and overlays it on top of a base image which in this case is "images/button1.png" and outputs the resulting image. This is a very convenient way to avoid having to draw new button images every time you want to change the text of a button. With this method they are dynamically generated.

차례
exif_imagetype -- Determine the type of an image
exif_read_data -- Reads the EXIF headers from JPEG or TIFF. This way you can read meta data generated by digital cameras.
exif_thumbnail -- Retrieve the embedded thumbnail of a TIFF or JPEG image
gd_info -- Retrieve information about the currently installed GD library
getimagesize -- Get the size of an image
image_type_to_mime_type -- Get Mime-Type for image-type returned by getimagesize, exif_read_data, exif_thumbnail, exif_imagetype
image2wbmp -- Output image to browser or file
imagealphablending -- Set the blending mode for an image
imageantialias -- Should antialias functions be used or not
imagearc -- Draw a partial ellipse
imagechar -- Draw a character horizontally
imagecharup -- Draw a character vertically
imagecolorallocate -- Allocate a color for an image
imagecolorallocatealpha -- Allocate a color for an image
imagecolorat -- Get the index of the color of a pixel
imagecolorclosest -- Get the index of the closest color to the specified color
imagecolorclosestalpha -- Get the index of the closest color to the specified color + alpha
imagecolorclosesthwb -- Get the index of the color which has the hue, white and blackness nearest to the given color
imagecolordeallocate -- De-allocate a color for an image
imagecolorexact -- Get the index of the specified color
imagecolorexactalpha -- Get the index of the specified color + alpha
imagecolormatch -- Makes the colors of the palette version of an image more closely match the true color version
imagecolorresolve -- Get the index of the specified color or its closest possible alternative
imagecolorresolvealpha -- Get the index of the specified color + alpha or its closest possible alternative
imagecolorset -- Set the color for the specified palette index
imagecolorsforindex -- Get the colors for an index
imagecolorstotal -- Find out the number of colors in an image's palette
imagecolortransparent -- Define a color as transparent
imagecopy -- Copy part of an image
imagecopymerge -- Copy and merge part of an image
imagecopymergegray -- Copy and merge part of an image with gray scale
imagecopyresampled -- Copy and resize part of an image with resampling
imagecopyresized -- Copy and resize part of an image
imagecreate -- Create a new palette based image
imagecreatefromgd2 -- Create a new image from GD2 file or URL
imagecreatefromgd2part -- Create a new image from a given part of GD2 file or URL
imagecreatefromgd -- Create a new image from GD file or URL
imagecreatefromgif -- Create a new image from file or URL
imagecreatefromjpeg -- Create a new image from file or URL
imagecreatefrompng -- Create a new image from file or URL
imagecreatefromstring -- Create a new image from the image stream in the string
imagecreatefromwbmp -- Create a new image from file or URL
imagecreatefromxbm -- Create a new image from file or URL
imagecreatefromxpm -- Create a new image from file or URL
imagecreatetruecolor -- Create a new true color image
imagedashedline -- Draw a dashed line
imagedestroy -- Destroy an image
imageellipse -- Draw an ellipse
imagefill -- Flood fill
imagefilledarc -- Draw a partial ellipse and fill it
imagefilledellipse -- Draw a filled ellipse
imagefilledpolygon -- Draw a filled polygon
imagefilledrectangle -- Draw a filled rectangle
imagefilltoborder -- Flood fill to specific color
imagefilter -- Applies Filter an image using a custom angle
imagefontheight -- Get font height
imagefontwidth -- Get font width
imageftbbox -- Give the bounding box of a text using fonts via freetype2
imagefttext -- Write text to the image using fonts using FreeType 2
imagegammacorrect -- Apply a gamma correction to a GD image
imagegd2 -- Output GD2 image
imagegd -- Output GD image to browser or file
imagegif -- Output image to browser or file
imageinterlace -- Enable or disable interlace
imageistruecolor -- Finds whether an image is a truecolor image.
imagejpeg -- Output image to browser or file
imagelayereffect -- Set the alpha blending flag to use the bundled libgd layering effects
imageline -- Draw a line
imageloadfont -- Load a new font
imagepalettecopy -- Copy the palette from one image to another
imagepng -- Output a PNG image to either the browser or a file
imagepolygon -- Draw a polygon
imagepsbbox -- Give the bounding box of a text rectangle using PostScript Type1 fonts
imagepscopyfont -- Make a copy of an already loaded font for further modification
imagepsencodefont -- Change the character encoding vector of a font
imagepsextendfont -- Extend or condense a font
imagepsfreefont -- Free memory used by a PostScript Type 1 font
imagepsloadfont -- Load a PostScript Type 1 font from file
imagepsslantfont -- Slant a font
imagepstext -- To draw a text string over an image using PostScript Type1 fonts
imagerectangle -- Draw a rectangle
imagerotate -- Rotate an image with a given angle
imagesavealpha -- Set the flag to save full alpha channel information (as opposed to single-color transparency) when saving PNG images.
imagesetbrush -- Set the brush image for line drawing
imagesetpixel -- Set a single pixel
imagesetstyle -- Set the style for line drawing
imagesetthickness -- Set the thickness for line drawing
imagesettile -- Set the tile image for filling
imagestring -- Draw a string horizontally
imagestringup -- Draw a string vertically
imagesx -- Get image width
imagesy -- Get image height
imagetruecolortopalette -- Convert a true color image to a palette image
imagettfbbox -- Give the bounding box of a text using TrueType fonts
imagettftext -- Write text to the image using TrueType fonts
imagetypes -- Return the image types supported by this PHP build
imagewbmp -- Output image to browser or file
imagexbm -- Output XBM image to browser or file
iptcembed -- Embed binary IPTC data into a JPEG image
iptcparse -- Parse a binary IPTC http://www.iptc.org/ block into single tags.
jpeg2wbmp -- Convert JPEG image file to WBMP image file
png2wbmp -- Convert PNG image file to WBMP image file
read_exif_data -- Alias of exif_read_data()

이전 | 처음으로 | 다음
ob_iconv_handler | 위로 | exif_imagetype


exif_imagetype

(PHP 4 >= 4.3.0, PHP 5)

exif_imagetype -- Determine the type of an image

Description

int exif_imagetype ( string filename)

exif_imagetype() reads the first bytes of an image and checks its signature. When a correct signature is found a constant will be returned otherwise the return value is FALSE. The return value is the same value that getimagesize() returns in index 2 but this function is much faster.

The following constants are defined:

표 1. Imagetype Constants

Value | Constant
1 | IMAGETYPE_GIF
2 | IMAGETYPE_JPEG
3 | IMAGETYPE_PNG
4 | IMAGETYPE_SWF
5 | IMAGETYPE_PSD
6 | IMAGETYPE_BMP
7 | IMAGETYPE_TIFF_II (intel byte order)
8 | IMAGETYPE_TIFF_MM (motorola byte order)
9 | IMAGETYPE_JPC
10 | IMAGETYPE_JP2
11 | IMAGETYPE_JPX
12 | IMAGETYPE_JB2
13 | IMAGETYPE_SWC
14 | IMAGETYPE_IFF
15 | IMAGETYPE_WBMP
16 | IMAGETYPE_XBM

참고: Support for JPC, JP2, JPX, JB2, XBM, and WBMP became available in PHP 4.3.2. Support for SWC as of PHP 4.3.0.

This function can be used to avoid calls to other exif functions with unsupported file types or in conjunction with $_SERVER['HTTP_ACCEPT'] to check whether or not the viewer is able to see a specific image in the browser.

참고: This function is only available if PHP is compiled using --enable-exif.

참고: This function does not require the GD image library.

예 1. exif_imagetype() example

<?php

if (exif_imagetype("image.gif") != IMAGETYPE_GIF) {
    echo "The picture is not a gif";
}

?>

See also getimagesize().

이전 | 처음으로 | 다음
Image Functions | 위로 | exif_read_data


exif_read_data

(PHP 4 >= 4.2.0, PHP 5)

exif_read_data -- Reads the EXIF headers from JPEG or TIFF. This way you can read meta data generated by digital cameras.

Description

array exif_read_data ( string filename [, string sections [, bool arrays [, bool thumbnail]]])

The exif_read_data() function reads the EXIF headers from a JPEG or TIFF image file. It returns an associative array where the indexes are the header names and the values are the values associated with those headers. If no data can be returned the result is FALSE.

filename is the name of the file to read. This cannot be a URL.

sections is a comma separated list of sections that need to be present in file to produce a result array. If none of the requested sections could be found the return value is FALSE.

FILE | FileName, FileSize, FileDateTime, SectionsFound
COMPUTED | html, Width, Height, IsColor and some more if available.
ANY_TAG | Any information that has a Tag e.g. IFD0, EXIF, ...
IFD0 | All tagged data of IFD0. In normal imagefiles this contains image size and so forth.
THUMBNAIL | A file is supposed to contain a thumbnail if it has a second IFD. All tagged information about the embedded thumbnail is stored in this section.
COMMENT | Comment headers of JPEG images.
EXIF | The EXIF section is a sub section of IFD0. It contains more detailed information about an image. Most of these entries are digital camera related.

arrays specifies whether or not each section becomes an array. The sections COMPUTED, THUMBNAIL and COMMENT allways become arrays as they may contain values whose names are conflict with other sections.

thumbnail whether or not to read the thumbnail itself and not only its tagged data.

참고: Exif headers tend to be present in JPEG/TIFF images generated by digital cameras, but unfortunately each digital camera maker has a different idea of how to actually tag their images, so you can't always rely on a specific Exif header being present.

Windows ME/XP both can wipe the Exif headers when connecting to a camera. More information available at http://www.canon-asia.com/products/digital_cameras/winxp_problems.html.

예 1. exif_read_data() example

<?php

echo "test1.jpg:<br />\n";
$exif = exif_read_data('tests/test1.jpg', 'IFD0');
echo $exif===false ? "No header data found.<br />\n" : "Image contains headers<br />";

$exif = exif_read_data('tests/test2.jpg', 0, true);
echo "test2.jpg:<br />\n";
foreach ($exif as $key => $section) {
    foreach ($section as $name => $val) {
        echo "$key.$name: $val<br />\n";
    }
}
?>

The first call fails because the image has no header information.
test1.jpg:
No header data found.
test2.jpg:
FILE.FileName: test2.jpg
FILE.FileDateTime: 1017666176
FILE.FileSize: 1240
FILE.FileType: 2
FILE.SectionsFound: ANY_TAG, IFD0, THUMBNAIL, COMMENT
COMPUTED.html: width="1" height="1"
COMPUTED.Height: 1
COMPUTED.Width: 1
COMPUTED.IsColor: 1
COMPUTED.ByteOrderMotorola: 1
COMPUTED.UserComment: Exif test image.
COMPUTED.UserCommentEncoding: ASCII
COMPUTED.Copyright: Photo (c) M.Boerger, Edited by M.Boerger.
COMPUTED.Copyright.Photographer: Photo (c) M.Boerger
COMPUTED.Copyright.Editor: Edited by M.Boerger.
IFD0.Copyright: Photo (c) M.Boerger
IFD0.UserComment: ASCII
THUMBNAIL.JPEGInterchangeFormat: 134
THUMBNAIL.JPEGInterchangeFormatLength: 523
COMMENT.0: Comment #1.
COMMENT.1: Comment #2.
COMMENT.2: Comment #3end
THUMBNAIL.JPEGInterchangeFormat: 134
THUMBNAIL.Thumbnail.Height: 1
THUMBNAIL.Thumbnail.Height: 1

참고: If the image contains any IFD0 data then COMPUTED contains the entry ByteOrderMotorola which is 0 for little-endian (intel) and 1 for big-endian (motorola) byte order. This was added in PHP 4.3.

When an Exif header contains a Copyright note this itself can contain two values. As the solution is inconsistent in the Exif 2.10 standard the COMPUTED section will return both entries Copyright.Photographer and Copyright.Editor while the IFD0 sections contains the byte array with the NULL character that splits both entries. Or just the first entry if the datatype was wrong (normal behaviour of Exif). The COMPUTED will contain also an entry Copyright Which is either the original copyright string or it is a comma separated list of photo and editor copyright.

참고: The tag UserComment has the same problem as the Copyright tag. It can store two values first the encoding used and second the value itself. If so the IFD section only contains the encoding or a byte array. The COMPUTED section will store both in the entries UserCommentEncoding and UserComment. The entry UserComment is available in both cases so it should be used in preference to the value in IFD0 section.

If the user comment uses Unicode or JIS encoding and the module mbstring is available this encoding will automatically changed according to the exif ini settings in the php.ini. This was added in PHP 4.3.

참고: Height and Width are computed the same way getimagesize() does so their values must not be part of any header returned. Also html is a height/width text string to be used inside normal HTML.

참고: Starting from PHP 4.3 the function can read all embedded IFD data including arrays (returned as such). Also the size of an embedded thumbnail is returned in THUMBNAIL subarray and the function exif_read_data() can return thumbnails in TIFF format. Last but not least there is no longer a maximum length for returned values (not until memory limit is reached).

참고: This function is only available in PHP 4 compiled using --enable-exif. Its functionality and behaviour has changed in PHP 4.2. Earlier versions are very unstable.

Since PHP 4.3 user comment can automatically change encoding if PHP 4 was compiled using --enable-mbstring.

This function does not require the GD image library.

See also exif_thumbnail() and getimagesize().

이전 | 처음으로 | 다음
exif_imagetype | 위로 | exif_thumbnail


exif_thumbnail

(PHP 4 >= 4.2.0, PHP 5)

exif_thumbnail -- Retrieve the embedded thumbnail of a TIFF or JPEG image

Description

string exif_thumbnail ( string filename [, int &width [, int &height [, int &imagetype]]])

exif_thumbnail() reads the embedded thumbnail of a TIFF or JPEG image. If the image contains no thumbnail FALSE will be returned.

The parameters width, height and imagetype are available since PHP 4.3.0 and return the size of the thumbnail as well as its type. It is possible that exif_thumbnail() cannot create an image but can determine its size. In this case, the return value is FALSE but width and height are set.

If you want to deliver thumbnails through this function, you should send the mimetype information using the header() function. The following example demonstrates this:

예 1. exif_thumbnail() example

<?php
if (array_key_exists('file', $_REQUEST)) {
    $image = exif_thumbnail($_REQUEST['file'], $width, $height, $type);
} else {
    $image = false;
}
if ($image!==false) {
    header("Content-type: " .image_type_to_mime_type($type));
    echo $image;
    exit;
} else {
    // no thumbnail available, handle the error here
    echo "No thumbnail available";
}
?>

Starting from version PHP 4.3.0, the function exif_thumbnail() can return thumbnails in TIFF format.

참고: This function is only available in PHP 4 compiled using --enable-exif. Its functionality and behaviour has changed in PHP 4.2.0

참고: This function does not require the GD image library.

See also exif_read_data() and image_type_to_mime_type().

이전 | 처음으로 | 다음
exif_read_data | 위로 | gd_info


gd_info

(PHP 4 >= 4.3.0, PHP 5)

gd_info -- Retrieve information about the currently installed GD library

Description

array gd_info ( void )

Returns an associative array describing the version and capabilities of the installed GD library.

표 1. Elements of array returned by gd_info()

Attribute | Meaning
GD Version | string value describing the installed libgd version.
Freetype Support | boolean value. TRUE if Freetype Support is installed.
Freetype Linkage | string value describing the way in which Freetype was linked. Expected values are: 'with freetype', 'with TTF library', and 'with unknown library'. This element will only be defined if Freetype Support evaluated to TRUE.
T1Lib Support | boolean value. TRUE if T1Lib support is included.
GIF Read Support | boolean value. TRUE if support for reading GIF images is included.
GIF Create Support | boolean value. TRUE if support for creating GIF images is included.
JPG Support | boolean value. TRUE if JPG support is included.
PNG Support | boolean value. TRUE if PNG support is included.
WBMP Support | boolean value. TRUE if WBMP support is included.
XBM Support | boolean value. TRUE if XBM support is included.

예 1. Using gd_info()

<?php
var_dump(gd_info());
?>

The typical output is :

array(9) {
  ["GD Version"]=>
  string(24) "bundled (2.0 compatible)"
  ["FreeType Support"]=>
  bool(false)
  ["T1Lib Support"]=>
  bool(false)
  ["GIF Read Support"]=>
  bool(true)
  ["GIF Create Support"]=>
  bool(false)
  ["JPG Support"]=>
  bool(false)
  ["PNG Support"]=>
  bool(true)
  ["WBMP Support"]=>
  bool(true)
  ["XBM Support"]=>
  bool(false)
}

See also imagepng(),
imagejpeg(),
imagegif(),
imagewbmp(), and
imagetypes().

이전 | 처음으로 | 다음
exif_thumbnail | 위로 | getimagesize


getimagesize

(PHP 3, PHP 4 , PHP 5)

getimagesize -- Get the size of an image

Description

array getimagesize ( string filename [, array imageinfo])

The getimagesize() function will determine the size of any GIF, JPG, PNG, SWF, SWC, PSD, TIFF, BMP, IFF, JP2, JPX, JB2, JPC, XBM, or WBMP image file and return the dimensions along with the file type and a height/width text string to be used inside a normal HTML IMG tag.

참고: Support for JPC, JP2, JPX, JB2, XBM, and WBMP became available in PHP 4.3.2. Support for SWC as of PHP 4.3.0.

Returns an array with 4 elements. Index 0 contains the width of the image in pixels. Index 1 contains the height. Index 2 is a flag indicating the type of the image: 1 = GIF, 2 = JPG, 3 = PNG, 4 = SWF, 5 = PSD, 6 = BMP, 7 = TIFF(intel byte order), 8 = TIFF(motorola byte order), 9 = JPC, 10 = JP2, 11 = JPX, 12 = JB2, 13 = SWC, 14 = IFF, 15 = WBMP, 16 = XBM. These values correspond to the IMAGETYPE constants that were added in PHP 4.3. Index 3 is a text string with the correct height="yyy" width="xxx" string that can be used directly in an IMG tag.

예 1. getimagesize (file)

<?php
list($width, $height, $type, $attr) = getimagesize("img/flag.jpg");
echo "<img src=\"img/flag.jpg\" $attr alt=\"getimagesize() example\" />";
?>

예 2. getimagesize (URL)

<?php
$size = getimagesize("http://www.example.com/gifs/logo.gif");

// if the file name has space in it, encode it properly
$size = getimagesize("http://www.example.com/gifs/lo%20go.gif");

?>

With JPG images, two extra indexes are returned: channels and bits. channels will be 3 for RGB pictures and 4 for CMYK pictures. bits is the number of bits for each color.

Beginning with PHP 4.3, bits and channels are present for other image types, too. However, the presence of these values can be a bit confusing. As an example, GIF always uses 3 channels per pixel, but the number of bits per pixel cannot be calculated for an animated GIF with a global color table.

Some formats may contain no image or may contain multiple images. In these cases, getimagesize() might not be able to properly determine the image size. getimagesize() will return zero for width and height in these cases.

Beginning with PHP 4.3, getimagesize() also returns an additional parameter, mime, that corresponds with the MIME type of the image. This information can be used to deliver images with correct HTTP Content-type headers:

예 3. getimagesize() and MIME types

<?php
$size = getimagesize($filename);
$fp=fopen($filename, "rb");
if ($size && $fp) {
  header("Content-type: {$size['mime']}");
  fpassthru($fp);
  exit;
} else {
  // error
}
?>

If accessing the filename image is impossible, or if it isn't a valid picture, getimagesize() will return FALSE and generate a warning.

The optional imageinfo parameter allows you to extract some extended information from the image file. Currently, this will return the different JPG APP markers as an associative array. Some programs use these APP markers to embed text information in images. A very common one is to embed IPTC http://www.iptc.org/ information in the APP13 marker. You can use the iptcparse() function to parse the binary APP13 marker into something readable.

예 4. getimagesize() returning IPTC

<?php
$size = getimagesize("testimg.jpg", $info);
if (isset($info["APP13"])) {
    $iptc = iptcparse($info["APP13"]);
    var_dump($iptc);
}
?>

참고: JPEG 2000 support was added in PHP 4.3.2. Note that JPC and JP2 are capable of having components with different bit depths. In this case, the value for "bits" is the highest bit depth encountered. Also, JP2 files may contain multiple JPEG 2000 codestreams. In this case, getimagesize() returns the values for the first codestream it encounters in the root of the file.

참고: TIFF support was added in PHP 4.2.

This function does not require the GD image library.

See also image_type_to_mime_type(),
exif_imagetype(), exif_read_data()
and exif_thumbnail().

URL support was added in PHP 4.0.5.

이전 | 처음으로 | 다음
gd_info | 위로 | image_type_to_mime_type


image_type_to_mime_type

(PHP 4 >= 4.3.0, PHP 5)

image_type_to_mime_type -- Get Mime-Type for image-type returned by getimagesize, exif_read_data, exif_thumbnail, exif_imagetype

Description

string image_type_to_mime_type ( int imagetype)

The image_type_to_mime_type() function will determine the Mime-Type for an IMAGETYPE constant.

예 1. image_type_to_mime_type (file)

<?php
header("Content-type: " . image_type_to_mime_type(IMAGETYPE_PNG));
?>

The returned values are as follows

표 1. Returned values Constants

imagetype | Returned value
IMAGETYPE_GIF | image/gif
IMAGETYPE_JPEG | image/jpeg
IMAGETYPE_PNG | image/png
IMAGETYPE_SWF | application/x-shockwave-flash
IMAGETYPE_PSD | image/psd
IMAGETYPE_BMP | image/bmp
IMAGETYPE_TIFF_II (intel byte order) | image/tiff
IMAGETYPE_TIFF_MM (motorola byte order) | image/tiff
IMAGETYPE_JPC | application/octet-stream
IMAGETYPE_JP2 | image/jp2
IMAGETYPE_JPX | application/octet-stream
IMAGETYPE_JB2 | application/octet-stream
IMAGETYPE_SWC | application/x-shockwave-flash
IMAGETYPE_IFF | image/iff
IMAGETYPE_WBMP | image/vnd.wap.wbmp
IMAGETYPE_XBM | image/xbm

참고: This function does not require the GD image library.

See also getimagesize(),
exif_imagetype(),
exif_read_data() and
exif_thumbnail().

이전 | 처음으로 | 다음
getimagesize | 위로 | image2wbmp


image2wbmp

(PHP 4 >= 4.0.5, PHP 5)

image2wbmp -- Output image to browser or file

Description

int image2wbmp ( resource image [, string filename [, int threshold]])

image2wbmp() creates the WBMP file in filename from the image image. The image argument is the return from imagecreate().

The filename argument is optional, and if left off, the raw image stream will be output directly. By sending an image/vnd.wap.wbmp content-type using header(), you can create a PHP script that outputs WBMP images directly.

예 1. image2wbmp() example

<?php

$file = 'php.png';
$image = imagecreatefrompng($file);

header('Content-type: ' . image_type_to_mime_type(IMAGETYPE_WBMP));
image2wbmp($image); // output the stream directly

?>

참고: WBMP support is only available if PHP was compiled against GD-1.8 or later.

See also imagewbmp().

이전 | 처음으로 | 다음
image_type_to_mime_type | 위로 | imagealphablending


imagealphablending

(PHP 4 >= 4.0.6, PHP 5)

imagealphablending -- Set the blending mode for an image

Description

bool imagealphablending ( resource image, bool blendmode)

imagealphablending() allows for two different modes of drawing on truecolor images. In blending mode, the alpha channel component of the color supplied to all drawing function, such as imagesetpixel() determines how much of the underlying color should be allowed to shine through. As a result, gd automatically blends the existing color at that point with the drawing color, and stores the result in the image. The resulting pixel is opaque. In non-blending mode, the drawing color is copied literally with its alpha channel information, replacing the destination pixel. Blending mode is not available when drawing on palette images. If blendmode is TRUE, then blending mode is enabled, otherwise disabled. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: This function was added in PHP 4.0.6 and requires GD 2.0.1

이전 | 처음으로 | 다음
image2wbmp | 위로 | imageantialias


imageantialias

(PHP 4 >= 4.3.2, PHP 5)

imageantialias -- Should antialias functions be used or not

Description

bool imageantialias ( resource im, bool on)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: 이 함수는 PHP에 포함된 GD 라이브러리를 사용하여 컴파일하였을 경우에만 사용할 수 있습니다.

See also imagecreatetruecolor().

이전 | 처음으로 | 다음
imagealphablending | 위로 | imagearc


imagearc

(PHP 3, PHP 4 , PHP 5)

imagearc -- Draw a partial ellipse

Description

int imagearc ( resource image, int cx, int cy, int w, int h, int s, int e, int color)

imagearc() draws a partial ellipse centered at cx, cy (top left is 0, 0) in the image represented by image. W and h specifies the ellipse's width and height respectively while the start and end points are specified in degrees indicated by the s and e arguments. 0° is located at the three-o'clock position, and the arc is drawn counter-clockwise.

예 1. Drawing a circle with imagearc()

<?php

// create a 200*200 image
$img = imagecreate(200, 200);

// allocate some colors
$white = imagecolorallocate($img, 255, 255, 255);

// draw a white circle
imagearc($img, 100, 100, 150, 150, 0, 360, $white);

// output image in the browser
header("Content-type: image/png");
imagepng($img);

// free memory
imagedestroy($img);

?>

See also imageellipse(),
imagefilledellipse(), and
imagefilledarc().

이전 | 처음으로 | 다음
imageantialias | 위로 | imagechar


imagechar

(PHP 3, PHP 4 , PHP 5)

imagechar -- Draw a character horizontally

Description

int imagechar ( resource image, int font, int x, int y, string c, int color)

imagechar() draws the first character of c in the image identified by image with its upper-left at x,y (top left is 0, 0) with the color color. If font is 1, 2, 3, 4 or 5, a built-in font is used (with higher numbers corresponding to larger fonts).

예 1. imagechar() example

<?php

$im = imagecreate(100, 100);

$string = 'PHP';

$bg = imagecolorallocate($im, 255, 255, 255);
$black = imagecolorallocate($im, 0, 0, 0);

// prints a black "P" in the top left corner
imagechar($im, 1, 0, 0, $string, $black);

header('Content-type: image/png');
imagepng($im);

?>

See also imagecharup() and imageloadfont().

이전 | 처음으로 | 다음
imagearc | 위로 | imagecharup


imagecharup

(PHP 3, PHP 4 , PHP 5)

imagecharup -- Draw a character vertically

Description

int imagecharup ( resource image, int font, int x, int y, string c, int color)

imagecharup() draws the character c vertically in the image identified by image at coordinates x, y (top left is 0, 0) with the color color. If font is 1, 2, 3, 4 or 5, a built-in font is used.

예 1. imagecharup() example

<?php

$im = imagecreate(100, 100);

$string = 'Note that the first letter is a N';

$bg = imagecolorallocate($im, 255, 255, 255);
$black = imagecolorallocate($im, 0, 0, 0);

// prints a black "Z" on a white background
imagecharup($im, 3, 10, 10, $string, $black);

header('Content-type: image/png');
imagepng($im);

?>

See also imagechar() and imageloadfont().

이전 | 처음으로 | 다음
imagechar | 위로 | imagecolorallocate


imagecolorallocate

(PHP 3, PHP 4 , PHP 5)

imagecolorallocate -- Allocate a color for an image

Description

int imagecolorallocate ( resource image, int red, int green, int blue)

imagecolorallocate() returns a color identifier representing the color composed of the given RGB components. The image argument is the return from the imagecreate() function. red, green and blue are the values of the red, green and blue component of the requested color respectively. These parameters are integers between 0 and 255 or hexadecimals between 0x00 and 0xFF. imagecolorallocate() must be called to create each color that is to be used in the image represented by image.

참고: The first call to imagecolorallocate() fills the background color.

<?php

// sets background to red
$background = imagecolorallocate($im, 255, 0, 0);

// sets some colors
$white = imagecolorallocate($im, 255, 255, 255);
$black = imagecolorallocate($im, 0, 0, 0);

// hexadecimal way
$white = imagecolorallocate($im, 0xFF, 0xFF, 0xFF);
$black = imagecolorallocate($im, 0x00, 0x00, 0x00);

?>

Returns -1 if the allocation failed.

See also imagecolorallocatealpha() and imagecolordeallocate().

이전 | 처음으로 | 다음
imagecharup | 위로 | imagecolorallocatealpha


imagecolorallocatealpha

(PHP 4 >= 4.3.2, PHP 5)

imagecolorallocatealpha -- Allocate a color for an image

Description

int imagecolorallocatealpha ( resource image, int red, int green, int blue, int alpha)

imagecolorallocatealpha() behaves identically to imagecolorallocate() with the addition of the transparency parameter alpha which may have a value between 0 and 127. 0 indicates completely opaque while 127 indicates completely transparent.

Returns FALSE if the allocation failed.

예 1. Example of using imagecolorallocatealpha()

<?php
$size = 300;
$image=imagecreatetruecolor($size, $size);

// something to get a white background with black border
$back = imagecolorallocate($image, 255, 255, 255);
$border = imagecolorallocate($image, 0, 0, 0);
imagefilledrectangle($image, 0, 0, $size - 1, $size - 1, $back);
imagerectangle($image, 0, 0, $size - 1, $size - 1, $border);

$yellow_x = 100;
$yellow_y = 75;
$red_x    = 120;
$red_y    = 165;
$blue_x   = 187;
$blue_y   = 125;
$radius   = 150;

// allocate colors with alpha values
$yellow = imagecolorallocatealpha($image, 255, 255, 0, 75);
$red    = imagecolorallocatealpha($image, 255, 0, 0, 75);
$blue   = imagecolorallocatealpha($image, 0, 0, 255, 75);

// drawing 3 overlapped circle
imagefilledellipse($image, $yellow_x, $yellow_y, $radius, $radius, $yellow);
imagefilledellipse($image, $red_x, $red_y, $radius, $radius, $red);
imagefilledellipse($image, $blue_x, $blue_y, $radius, $radius, $blue);

// don't forget to output a correct header!
header('Content-type: image/png');

// and finally, output the result
imagepng($image);
imagedestroy($image);
?>

See also imagecolorallocate() and imagecolordeallocate().

이전 | 처음으로 | 다음
imagecolorallocate | 위로 | imagecolorat


imagecolorat

(PHP 3, PHP 4 , PHP 5)

imagecolorat -- Get the index of the color of a pixel

Description

int imagecolorat ( resource image, int x, int y)

Returns the index of the color of the pixel at the specified location in the image specified by image.

If PHP is compiled against GD library 2.0 or higher and the image is a truecolor image, this function returns the RGB value of that pixel as integer. Use bitshifting and masking to access the distinct red, green and blue component values:

예 1. Access distinct RGB values

<?php
$im = ImageCreateFromPng("rockym.png");
$rgb = ImageColorAt($im, 100, 100);
$r = ($rgb >> 16) & 0xFF;
$g = ($rgb >> 8) & 0xFF;
$b = $rgb & 0xFF;
?>

See also imagecolorset() and imagecolorsforindex().

이전 | 처음으로 | 다음
imagecolorallocatealpha | 위로 | imagecolorclosest


imagecolorclosest

(PHP 3, PHP 4 , PHP 5)

imagecolorclosest -- Get the index of the closest color to the specified color

Description

int imagecolorclosest ( resource image, int red, int green, int blue)

Returns the index of the color in the palette of the image which is "closest" to the specified RGB value.

The "distance" between the desired color and each color in the palette is calculated as if the RGB values represented points in three-dimensional space.

See also imagecolorexact().

이전 | 처음으로 | 다음
imagecolorat | 위로 | imagecolorclosestalpha


imagecolorclosestalpha

(PHP 4 >= 4.0.6, PHP 5)

imagecolorclosestalpha -- Get the index of the closest color to the specified color + alpha

Description

int imagecolorclosestalpha ( resource image, int red, int green, int blue, int alpha)

Returns the index of the color in the palette of the image which is "closest" to the specified RGB value and alpha level.

참고: This function was added in PHP 4.0.6 and requires GD 2.0.1

See also imagecolorexactalpha().

이전 | 처음으로 | 다음
imagecolorclosest | 위로 | imagecolorclosesthwb


imagecolorclosesthwb

(PHP 4 >= 4.0.1, PHP 5)

imagecolorclosesthwb -- Get the index of the color which has the hue, white and blackness nearest to the given color

Description

int imagecolorclosesthwb ( resource image, int red, int green, int blue)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
imagecolorclosestalpha | 위로 | imagecolordeallocate


imagecolordeallocate

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

imagecolordeallocate -- De-allocate a color for an image

Description

int imagecolordeallocate ( resource image, int color)

The imagecolordeallocate() function de-allocates a color previously allocated with imagecolorallocate() or imagecolorallocatealpha().

<?php
$white = imagecolorallocate($im, 255, 255, 255);
imagecolordeallocate($im, $white);
?>

See also imagecolorallocate() and imagecolorallocatealpha().

이전 | 처음으로 | 다음
imagecolorclosesthwb | 위로 | imagecolorexact


imagecolorexact

(PHP 3, PHP 4 , PHP 5)

imagecolorexact -- Get the index of the specified color

Description

int imagecolorexact ( resource image, int red, int green, int blue)

Returns the index of the specified color in the palette of the image.

If the color does not exist in the image's palette, -1 is returned.

See also imagecolorclosest().

이전 | 처음으로 | 다음
imagecolordeallocate | 위로 | imagecolorexactalpha


imagecolorexactalpha

(PHP 4 >= 4.0.6, PHP 5)

imagecolorexactalpha -- Get the index of the specified color + alpha

Description

int imagecolorexactalpha ( resource image, int red, int green, int blue, int alpha)

Returns the index of the specified color+alpha in the palette of the image.

If the color does not exist in the image's palette, -1 is returned.

See also imagecolorclosestalpha().

참고: This function was added in PHP 4.0.6 and requires GD 2.0.1 or later

이전 | 처음으로 | 다음
imagecolorexact | 위로 | imagecolormatch


imagecolormatch

(PHP 4 >= 4.3.0, PHP 5)

imagecolormatch -- Makes the colors of the palette version of an image more closely match the true color version

Description

bool imagecolormatch ( resource image1, resource image2)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

image1 must be Truecolor, image2 must be Palette, and both image1 and image2 must be the same size.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: 이 함수는 PHP에 포함된 GD 라이브러리를 사용하여 컴파일하였을 경우에만 사용할 수 있습니다.

See also imagecreatetruecolor().

이전 | 처음으로 | 다음
imagecolorexactalpha | 위로 | imagecolorresolve


imagecolorresolve

(PHP 3>= 3.0.2, PHP 4 , PHP 5)

imagecolorresolve -- Get the index of the specified color or its closest possible alternative

Description

int imagecolorresolve ( resource image, int red, int green, int blue)

This function is guaranteed to return a color index for a requested color, either the exact color or the closest possible alternative.

See also imagecolorclosest().

이전 | 처음으로 | 다음
imagecolormatch | 위로 | imagecolorresolvealpha


imagecolorresolvealpha

(PHP 4 >= 4.0.6, PHP 5)

imagecolorresolvealpha -- Get the index of the specified color + alpha or its closest possible alternative

Description

int imagecolorresolvealpha ( resource image, int red, int green, int blue, int alpha)

This function is guaranteed to return a color index for a requested color, either the exact color or the closest possible alternative.

See also imagecolorclosestalpha().

참고: This function was added in PHP 4.0.6 and requires GD 2.0.1

이전 | 처음으로 | 다음
imagecolorresolve | 위로 | imagecolorset


imagecolorset

(PHP 3, PHP 4 , PHP 5)

imagecolorset -- Set the color for the specified palette index

Description

bool imagecolorset ( resource image, int index, int red, int green, int blue)

This sets the specified index in the palette to the specified color. This is useful for creating flood-fill-like effects in palleted images without the overhead of performing the actual flood-fill.

See also imagecolorat().

이전 | 처음으로 | 다음
imagecolorresolvealpha | 위로 | imagecolorsforindex


imagecolorsforindex

(PHP 3, PHP 4 , PHP 5)

imagecolorsforindex -- Get the colors for an index

Description

array imagecolorsforindex ( resource image, int index)

This returns an associative array with red, green, blue and alpha keys that contain the appropriate values for the specified color index.

예 1. imagecolorsforindex() example

<?php

// open an image
$im = imagecreatefrompng('nexen.png');

// get a color
$start_x = 40;
$start_y = 50;
$color_index = imagecolorat($im, $start_x, $start_y);

// make it human readable
$color_tran = imagecolorsforindex($im, $color_index);

// what is it ?
echo '<pre>';
print_r($color_tran);
echo '</pre>';

?>

This example will output :

Array
(
    [red] => 226
    [green] => 222
    [blue] => 252
    [alpha] => 0
)

See also imagecolorat() and imagecolorexact().

이전 | 처음으로 | 다음
imagecolorset | 위로 | imagecolorstotal


imagecolorstotal

(PHP 3, PHP 4 , PHP 5)

imagecolorstotal -- Find out the number of colors in an image's palette

Description

int imagecolorstotal ( resource image)

This returns the number of colors in the specified image's palette.

See also imagecolorat() and imagecolorsforindex().

이전 | 처음으로 | 다음
imagecolorsforindex | 위로 | imagecolortransparent


imagecolortransparent

(PHP 3, PHP 4 , PHP 5)

imagecolortransparent -- Define a color as transparent

Description

int imagecolortransparent ( resource image [, int color])

imagecolortransparent() sets the transparent color in the image image to color. image is the image identifier returned by imagecreate() and color is a color identifier returned by imagecolorallocate().

참고: The transparent color is a property of the image, transparency is not a property of the color. Once you have a set a color to be the transparent color, any regions of the image in that color that were drawn previously will be transparent.

The identifier of the new (or current, if none is specified) transparent color is returned.

이전 | 처음으로 | 다음
imagecolorstotal | 위로 | imagecopy


imagecopy

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

imagecopy -- Copy part of an image

Description

int imagecopy ( resource dst_im, resource src_im, int dst_x, int dst_y, int src_x, int src_y, int src_w, int src_h)

Copy a part of src_im onto dst_im starting at the x,y coordinates src_x, src_y with a width of src_w and a height of src_h. The portion defined will be copied onto the x,y coordinates, dst_x and dst_y.

이전 | 처음으로 | 다음
imagecolortransparent | 위로 | imagecopymerge


imagecopymerge

(PHP 4 >= 4.0.1, PHP 5)

imagecopymerge -- Copy and merge part of an image

Description

int imagecopymerge ( resource dst_im, resource src_im, int dst_x, int dst_y, int src_x, int src_y, int src_w, int src_h, int pct)

Copy a part of src_im onto dst_im starting at the x,y coordinates src_x, src_y with a width of src_w and a height of src_h. The portion defined will be copied onto the x,y coordinates, dst_x and dst_y. The two images will be merged according to pct which can range from 0 to 100. When pct = 0, no action is taken, when 100 this function behaves identically to imagecopy().

참고: This function was added in PHP 4.0.6

이전 | 처음으로 | 다음
imagecopy | 위로 | imagecopymergegray


imagecopymergegray

(PHP 4 >= 4.0.6, PHP 5)

imagecopymergegray -- Copy and merge part of an image with gray scale

Description

int imagecopymergegray ( resource dst_im, resource src_im, int dst_x, int dst_y, int src_x, int src_y, int src_w, int src_h, int pct)

imagecopymergegray() copy a part of src_im onto dst_im starting at the x,y coordinates src_x, src_y with a width of src_w and a height of src_h. The portion defined will be copied onto the x,y coordinates, dst_x and dst_y. The two images will be merged according to pct which can range from 0 to 100. When pct = 0, no action is taken, when 100 this function behaves identically to imagecopy().

This function is identical to imagecopymerge() except that when merging it preserves the hue of the source by converting the destination pixels to gray scale before the copy operation.

참고: This function was added in PHP 4.0.6

이전 | 처음으로 | 다음
imagecopymerge | 위로 | imagecopyresampled


imagecopyresampled

(PHP 4 >= 4.0.6, PHP 5)

imagecopyresampled -- Copy and resize part of an image with resampling

Description

bool imagecopyresampled ( resource dst_im, resource src_im, int dstX, int dstY, int srcX, int srcY, int dstW, int dstH, int srcW, int srcH)

imagecopyresampled() copies a rectangular portion of one image to another image, smoothly interpolating pixel values so that, in particular, reducing the size of an image still retains a great deal of clarity. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. dst_im is the destination image, src_im is the source image identifier. If the source and destination coordinates and width and heights differ, appropriate stretching or shrinking of the image fragment will be performed. The coordinates refer to the upper left corner. This function can be used to copy regions within the same image (if dst_im is the same as src_im) but if the regions overlap the results will be unpredictable.

참고: There is a problem due to palette image limitations (255+1 colors). Resampling or filtering an image commonly needs more colors than 255, a kind of approximation is used to calculate the new resampled pixel and its color. With a palette image we try to allocate a new color, if that failed, we choose the closest (in theory) computed color. This is not always the closest visual color. That may produce a weird result, like blank (or visually blank) images. To skip this problem, please use a truecolor image as a destination image, such as one created by imagecreatetruecolor().

참고: imagecopyresampled() requires GD 2.0.l or greater.

See also imagecopyresized().

이전 | 처음으로 | 다음
imagecopymergegray | 위로 | imagecopyresized


imagecopyresized

(PHP 3, PHP 4 , PHP 5)

imagecopyresized -- Copy and resize part of an image

Description

int imagecopyresized ( resource dst_im, resource src_im, int dstX, int dstY, int srcX, int srcY, int dstW, int dstH, int srcW, int srcH)

imagecopyresized() copies a rectangular portion of one image to another image. Dst_im is the destination image, src_im is the source image identifier. If the source and destination coordinates and width and heights differ, appropriate stretching or shrinking of the image fragment will be performed. The coordinates refer to the upper left corner. This function can be used to copy regions within the same image (if dst_im is the same as src_im) but if the regions overlap the results will be unpredictable.

참고: There is a problem due to palette image limitations (255+1 colors). Resampling or filtering an image commonly needs more colors than 255, a kind of approximation is used to calculate the new resampled pixel and its color. With a palette image we try to allocate a new color, if that failed, we choose the closest (in theory) computed color. This is not always the closest visual color. That may produce a weird result, like blank (or visually blank) images. To skip this problem, please use a truecolor image as a destination image, such as one created by imagecreatetruecolor().

See also imagecopyresampled().

이전 | 처음으로 | 다음
imagecopyresampled | 위로 | imagecreate


imagecreate

(PHP 3, PHP 4 , PHP 5)

imagecreate -- Create a new palette based image

Description

resource imagecreate ( int x_size, int y_size)

imagecreate() returns an image identifier representing a blank image of size x_size by y_size.

We recommend the use of imagecreatetruecolor().

예 1. Creating a new GD image stream and outputting an image.

<?php
header("Content-type: image/png");
$im = @imagecreate(50, 100)
    or die("Cannot Initialize new GD image stream");
$background_color = imagecolorallocate($im, 255, 255, 255);
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  "A Simple Text String", $text_color);
imagepng($im);
imagedestroy($im);
?>

See also imagedestroy() and imagecreatetruecolor().

이전 | 처음으로 | 다음
imagecopyresized | 위로 | imagecreatefromgd2


imagecreatefromgd2

(PHP 4 >= 4.1.0, PHP 5)

imagecreatefromgd2 -- Create a new image from GD2 file or URL

Description

resource imagecreatefromgd2 ( string filename)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

작은 정보: fopen wrappers를 설정하면, 이 함수의 파일 이름으로 URL을 사용할 수 있습니다. 파일 이름을 지정하는 방법은 fopen()을 참고하고, 지원하는 URL 프로토콜 목록은 부록 J를 참고하십시오.

주의

PHP 4.3.0 이후의 Windows 버전 PHP에서는 이 함수를 이용하여 원격 파일에 접근할 수 없습니다. allow_url_fopen을 활성화하여도 마찬가지입니다.

이전 | 처음으로 | 다음
imagecreate | 위로 | imagecreatefromgd2part


imagecreatefromgd2part

(PHP 4 >= 4.1.0, PHP 5)

imagecreatefromgd2part -- Create a new image from a given part of GD2 file or URL

Description

resource imagecreatefromgd2part ( string filename, int srcX, int srcY, int width, int height)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

작은 정보: fopen wrappers를 설정하면, 이 함수의 파일 이름으로 URL을 사용할 수 있습니다. 파일 이름을 지정하는 방법은 fopen()을 참고하고, 지원하는 URL 프로토콜 목록은 부록 J를 참고하십시오.

주의

PHP 4.3.0 이후의 Windows 버전 PHP에서는 이 함수를 이용하여 원격 파일에 접근할 수 없습니다. allow_url_fopen을 활성화하여도 마찬가지입니다.

이전 | 처음으로 | 다음
imagecreatefromgd2 | 위로 | imagecreatefromgd


imagecreatefromgd

(PHP 4 >= 4.1.0, PHP 5)

imagecreatefromgd -- Create a new image from GD file or URL

Description

resource imagecreatefromgd ( string filename)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

작은 정보: fopen wrappers를 설정하면, 이 함수의 파일 이름으로 URL을 사용할 수 있습니다. 파일 이름을 지정하는 방법은 fopen()을 참고하고, 지원하는 URL 프로토콜 목록은 부록 J를 참고하십시오.

주의

PHP 4.3.0 이후의 Windows 버전 PHP에서는 이 함수를 이용하여 원격 파일에 접근할 수 없습니다. allow_url_fopen을 활성화하여도 마찬가지입니다.

이전 | 처음으로 | 다음
imagecreatefromgd2part | 위로 | imagecreatefromgif


imagecreatefromgif

(PHP 3, PHP 4 , PHP 5)

imagecreatefromgif -- Create a new image from file or URL

Description

resource imagecreatefromgif ( string filename)

imagecreatefromgif() returns an image identifier representing the image obtained from the given filename.

imagecreatefromgif() returns an empty string on failure. It also outputs an error message, which unfortunately displays as a broken link in a browser. To ease debugging the following example will produce an error GIF:

예 1. Example to handle an error during creation (courtesy vic at zymsys dot com)

<?php
function LoadGif ($imgname)
{
    $im = @imagecreatefromgif ($imgname); /* Attempt to open */
    if (!$im) { /* See if it failed */
        $im = imagecreate (150, 30); /* Create a blank image */
        $bgc = imagecolorallocate ($im, 255, 255, 255);
        $tc = imagecolorallocate ($im, 0, 0, 0);
        imagefilledrectangle ($im, 0, 0, 150, 30, $bgc);
        /* Output an errmsg */
        imagestring ($im, 1, 5, 5, "Error loading $imgname", $tc);
    }
    return $im;
}
?>

참고: Since all GIF support was removed from the GD library in version 1.6, this function is not available if you are using that version of the GD library.

작은 정보: fopen wrappers를 설정하면, 이 함수의 파일 이름으로 URL을 사용할 수 있습니다. 파일 이름을 지정하는 방법은 fopen()을 참고하고, 지원하는 URL 프로토콜 목록은 부록 J를 참고하십시오.

주의

PHP 4.3.0 이후의 Windows 버전 PHP에서는 이 함수를 이용하여 원격 파일에 접근할 수 없습니다. allow_url_fopen을 활성화하여도 마찬가지입니다.

이전 | 처음으로 | 다음
imagecreatefromgd | 위로 | imagecreatefromjpeg


imagecreatefromjpeg

(PHP 3>= 3.0.16, PHP 4 , PHP 5)

imagecreatefromjpeg -- Create a new image from file or URL

Description

resource imagecreatefromjpeg ( string filename)

imagecreatefromjpeg() returns an image identifier representing the image obtained from the given filename.

imagecreatefromjpeg() returns an empty string on failure. It also outputs an error message, which unfortunately displays as a broken link in a browser. To ease debugging the following example will produce an error JPEG:

예 1. Example to handle an error during creation (courtesy vic at zymsys dot com )

<?php
function LoadJpeg($imgname)
{
    $im = @imagecreatefromjpeg($imgname); /* Attempt to open */
    if (!$im) { /* See if it failed */
        $im  = imagecreate(150, 30); /* Create a blank image */
        $bgc = imagecolorallocate($im, 255, 255, 255);
        $tc  = imagecolorallocate($im, 0, 0, 0);
        imagefilledrectangle($im, 0, 0, 150, 30, $bgc);
        /* Output an errmsg */
        imagestring($im, 1, 5, 5, "Error loading $imgname", $tc);
    }
    return $im;
}
?>

작은 정보: fopen wrappers를 설정하면, 이 함수의 파일 이름으로 URL을 사용할 수 있습니다. 파일 이름을 지정하는 방법은 fopen()을 참고하고, 지원하는 URL 프로토콜 목록은 부록 J를 참고하십시오.

주의

PHP 4.3.0 이후의 Windows 버전 PHP에서는 이 함수를 이용하여 원격 파일에 접근할 수 없습니다. allow_url_fopen을 활성화하여도 마찬가지입니다.

이전 | 처음으로 | 다음
imagecreatefromgif | 위로 | imagecreatefrompng


imagecreatefrompng

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

imagecreatefrompng -- Create a new image from file or URL

Description

resource imagecreatefrompng ( string filename)

imagecreatefrompng() returns an image identifier representing the image obtained from the given filename.

imagecreatefrompng() returns an empty string on failure. It also outputs an error message, which unfortunately displays as a broken link in a browser. To ease debugging the following example will produce an error PNG:

예 1. Example to handle an error during creation (courtesy vic at zymsys dot com)

<?php
function LoadPNG($imgname)
{
    $im = @imagecreatefrompng($imgname); /* Attempt to open */
    if (!$im) { /* See if it failed */
        $im  = imagecreate(150, 30); /* Create a blank image */
        $bgc = imagecolorallocate($im, 255, 255, 255);
        $tc  = imagecolorallocate($im, 0, 0, 0);
        imagefilledrectangle($im, 0, 0, 150, 30, $bgc);
        /* Output an errmsg */
        imagestring($im, 1, 5, 5, "Error loading $imgname", $tc);
    }
    return $im;
}
?>

작은 정보: fopen wrappers를 설정하면, 이 함수의 파일 이름으로 URL을 사용할 수 있습니다. 파일 이름을 지정하는 방법은 fopen()을 참고하고, 지원하는 URL 프로토콜 목록은 부록 J를 참고하십시오.

주의

PHP 4.3.0 이후의 Windows 버전 PHP에서는 이 함수를 이용하여 원격 파일에 접근할 수 없습니다. allow_url_fopen을 활성화하여도 마찬가지입니다.

이전 | 처음으로 | 다음
imagecreatefromjpeg | 위로 | imagecreatefromstring


imagecreatefromstring

(PHP 4 >= 4.0.4, PHP 5)

imagecreatefromstring -- Create a new image from the image stream in the string

Description

resource imagecreatefromstring ( string image)

imagecreatefromstring() returns an image identifier representing the image obtained from the given string.

이전 | 처음으로 | 다음
imagecreatefrompng | 위로 | imagecreatefromwbmp


imagecreatefromwbmp

(PHP 4 >= 4.0.1, PHP 5)

imagecreatefromwbmp -- Create a new image from file or URL

Description

resource imagecreatefromwbmp ( string filename)

imagecreatefromwbmp() returns an image identifier representing the image obtained from the given filename.

imagecreatefromwbmp() returns an empty string on failure. It also outputs an error message, which unfortunately displays as a broken link in a browser. To ease debugging the following example will produce an error WBMP:

예 1. Example to handle an error during creation (courtesy vic at zymsys dot com)

<?php
function LoadWBMP($imgname)
{
    $im = @imagecreatefromwbmp($imgname); /* Attempt to open */
    if (!$im) { /* See if it failed */
        $im  = imagecreate (20, 20); /* Create a blank image */
        $bgc = imagecolorallocate($im, 255, 255, 255);
        $tc  = imagecolorallocate($im, 0, 0, 0);
        imagefilledrectangle($im, 0, 0, 10, 10, $bgc);
        /* Output an errmsg */
        imagestring($im, 1, 5, 5, "Error loading $imgname", $tc);
    }
    return $im;
}
?>

참고: WBMP support is only available if PHP was compiled against GD-1.8 or later.

작은 정보: fopen wrappers를 설정하면, 이 함수의 파일 이름으로 URL을 사용할 수 있습니다. 파일 이름을 지정하는 방법은 fopen()을 참고하고, 지원하는 URL 프로토콜 목록은 부록 J를 참고하십시오.

주의

PHP 4.3.0 이후의 Windows 버전 PHP에서는 이 함수를 이용하여 원격 파일에 접근할 수 없습니다. allow_url_fopen을 활성화하여도 마찬가지입니다.

이전 | 처음으로 | 다음
imagecreatefromstring | 위로 | imagecreatefromxbm


imagecreatefromxbm

(PHP 4 >= 4.0.1, PHP 5)

imagecreatefromxbm -- Create a new image from file or URL

Description

resource imagecreatefromxbm ( string filename)

imagecreatefromxbm() returns an image identifier representing the image obtained from the given filename.

작은 정보: fopen wrappers를 설정하면, 이 함수의 파일 이름으로 URL을 사용할 수 있습니다. 파일 이름을 지정하는 방법은 fopen()을 참고하고, 지원하는 URL 프로토콜 목록은 부록 J를 참고하십시오.

주의

PHP 4.3.0 이후의 Windows 버전 PHP에서는 이 함수를 이용하여 원격 파일에 접근할 수 없습니다. allow_url_fopen을 활성화하여도 마찬가지입니다.

이전 | 처음으로 | 다음
imagecreatefromwbmp | 위로 | imagecreatefromxpm


imagecreatefromxpm

(PHP 4 >= 4.0.1, PHP 5)

imagecreatefromxpm -- Create a new image from file or URL

Description

resource imagecreatefromxpm ( string filename)

imagecreatefromxpm() returns an image identifier representing the image obtained from the given filename.

참고: 이 함수는 PHP에 포함된 GD 라이브러리를 사용하여 컴파일하였을 경우에만 사용할 수 있습니다.

작은 정보: fopen wrappers를 설정하면, 이 함수의 파일 이름으로 URL을 사용할 수 있습니다. 파일 이름을 지정하는 방법은 fopen()을 참고하고, 지원하는 URL 프로토콜 목록은 부록 J를 참고하십시오.

주의

PHP 4.3.0 이후의 Windows 버전 PHP에서는 이 함수를 이용하여 원격 파일에 접근할 수 없습니다. allow_url_fopen을 활성화하여도 마찬가지입니다.

이전 | 처음으로 | 다음
imagecreatefromxbm | 위로 | imagecreatetruecolor


imagecreatetruecolor

(PHP 4 >= 4.0.6, PHP 5)

imagecreatetruecolor -- Create a new true color image

Description

resource imagecreatetruecolor ( int x_size, int y_size)

imagecreatetruecolor() returns an image identifier representing a black image of size x_size by y_size.

예 1. Creating a new GD image stream and outputting an image.

<?php
header ("Content-type: image/png");
$im = @imagecreatetruecolor(50, 100)
      or die("Cannot Initialize new GD image stream");
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  "A Simple Text String", $text_color);
imagepng($im);
imagedestroy($im);
?>

참고: This function was added in PHP 4.0.6 and requires GD 2.0.1 or later.

참고: This function will not work with GIF file formats.

See also imagedestroy() and imagecreate().

이전 | 처음으로 | 다음
imagecreatefromxpm | 위로 | imagedashedline


imagedashedline

(PHP 3, PHP 4 , PHP 5)

imagedashedline -- Draw a dashed line

Description

int imagedashedline ( resource image, int x1, int y1, int x2, int y2, int color)

This function is deprecated. Use combination of imagesetstyle() and imageline() instead.

이전 | 처음으로 | 다음
imagecreatetruecolor | 위로 | imagedestroy


imagedestroy

(PHP 3, PHP 4 , PHP 5)

imagedestroy -- Destroy an image

Description

int imagedestroy ( resource image)

imagedestroy() frees any memory associated with image image. image is the image identifier returned by the imagecreate() function.

이전 | 처음으로 | 다음
imagedashedline | 위로 | imageellipse


imageellipse

(PHP 4 >= 4.0.6, PHP 5)

imageellipse -- Draw an ellipse

Description

int imageellipse ( resource image, int cx, int cy, int w, int h, int color)

imageellipse() draws an ellipse centered at cx, cy (top left is 0, 0) in the image represented by image. W and h specifies the ellipse's width and height respectively. The color of the ellipse is specified by color.

참고: This function was added in PHP 4.0.6 and requires GD 2.0.2 or later which can be obtained at http://www.boutell.com/gd/

예 1. imageellipse() example

<?php

// create a blank image
$image = imagecreate(400, 300);

// fill the background color
$bg = imagecolorallocate($image, 0, 0, 0);

// choose a color for the ellipse
$col_ellipse = imagecolorallocate($image, 255, 255, 255);

// draw the ellipse
imageellipse($image, 200, 150, 300, 200, $col_ellipse);

// output the picture
header("Content-type: image/png");
imagepng($image);

?>

See also imagefilledellipse() and imagearc().

이전 | 처음으로 | 다음
imagedestroy | 위로 | imagefill


imagefill

(PHP 3, PHP 4 , PHP 5)

imagefill -- Flood fill

Description

int imagefill ( resource image, int x, int y, int color)

imagefill() performs a flood fill starting at coordinate x, y (top left is 0, 0) with color color in the image image.

이전 | 처음으로 | 다음
imageellipse | 위로 | imagefilledarc


imagefilledarc

(PHP 4 >= 4.0.6, PHP 5)

imagefilledarc -- Draw a partial ellipse and fill it

Description

bool imagefilledarc ( resource image, int cx, int cy, int w, int h, int s, int e, int color, int style)

imagefilledarc() draws a partial ellipse centered at cx, cy (top left is 0, 0) in the image represented by image. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. W and h specifies the ellipse's width and height respectively while the start and end points are specified in degrees indicated by the s and e arguments. style is a bitwise OR of the following possibilities:

  1. IMG_ARC_PIE

  2. IMG_ARC_CHORD

  3. IMG_ARC_NOFILL

  4. IMG_ARC_EDGED

IMG_ARC_PIE and IMG_ARC_CHORD are mutually exclusive; IMG_ARC_CHORD just connects the starting and ending angles with a straight line, while IMG_ARC_PIE produces a rounded edge. IMG_ARC_NOFILL indicates that the arc or chord should be outlined, not filled. IMG_ARC_EDGED, used together with IMG_ARC_NOFILL, indicates that the beginning and ending angles should be connected to the center - this is a good way to outline (rather than fill) a 'pie slice'.

예 1. Creating a 3D looking pie

<?php

// this example is provided by poxy at klam dot is

// create image
$image = imagecreate(100, 100);

// allocate some solors
$white    = imagecolorallocate($image, 0xFF, 0xFF, 0xFF);
$gray     = imagecolorallocate($image, 0xC0, 0xC0, 0xC0);
$darkgray = imagecolorallocate($image, 0x90, 0x90, 0x90);
$navy     = imagecolorallocate($image, 0x00, 0x00, 0x80);
$darknavy = imagecolorallocate($image, 0x00, 0x00, 0x50);
$red      = imagecolorallocate($image, 0xFF, 0x00, 0x00);
$darkred  = imagecolorallocate($image, 0x90, 0x00, 0x00);

// make the 3D effect
for ($i = 60; $i > 50; $i--) {
   imagefilledarc($image, 50, $i, 100, 50, 0, 45, $darknavy, IMG_ARC_PIE);
  imagefilledarc($image, 50, $i, 100, 50, 45, 75 , $darkgray, IMG_ARC_PIE);
  imagefilledarc($image, 50, $i, 100, 50, 75, 360 , $darkred, IMG_ARC_PIE);
}

imagefilledarc($image, 50, 50, 100, 50, 0, 45, $navy, IMG_ARC_PIE);
imagefilledarc($image, 50, 50, 100, 50, 45, 75 , $gray, IMG_ARC_PIE);
imagefilledarc($image, 50, 50, 100, 50, 75, 360 , $red, IMG_ARC_PIE);

// flush image
header('Content-type: image/png');
imagepng($image);
imagedestroy($image);
?>

참고: This function was added in PHP 4.0.6 and requires GD 2.0.1

이전 | 처음으로 | 다음
imagefill | 위로 | imagefilledellipse


imagefilledellipse

(PHP 4 >= 4.0.6, PHP 5)

imagefilledellipse -- Draw a filled ellipse

Description

bool imagefilledellipse ( resource image, int cx, int cy, int w, int h, int color)

imagefilledellipse() draws an ellipse centered at cx, cy (top left is 0, 0) in the image represented by image. W and h specifies the ellipse's width and height respectively. The ellipse is filled using color. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: This function was added in PHP 4.0.6 and requires GD 2.0.1 or later

예 1. imagefilledellipse() example

<?php

// create a blank image
$image = imagecreate(400, 300);

// fill the background color
$bg = imagecolorallocate($image, 0, 0, 0);

// choose a color for the ellipse
$col_ellipse = imagecolorallocate($image, 255, 255, 255);

// draw the white ellipse
imagefilledellipse($image, 200, 150, 300, 200, $col_ellipse);

// output the picture
header("Content-type: image/png");
imagepng($image);

?>

See also imageellipse() and imagefilledarc().

이전 | 처음으로 | 다음
imagefilledarc | 위로 | imagefilledpolygon


imagefilledpolygon

(PHP 3, PHP 4 , PHP 5)

imagefilledpolygon -- Draw a filled polygon

Description

int imagefilledpolygon ( resource image, array points, int num_points, int color)

imagefilledpolygon() creates a filled polygon in image image. points is a PHP array containing the polygon's vertices, i.e. points[0] = x0, points[1] = y0, points[2] = x1, points[3] = y1, etc. num_points is the total number of vertices.

예 1. imagefilledpolygon() example

<?php

// this example is provided by ecofarm at mullum dot com dot au

// set up array of points for polygon
$values = array(
  0  => 40,    // x1
  1  => 50,    // y1
  2  => 20,    // x2
  3  => 240,   // y2
  4  => 60,    // x3
  5  => 60,    // y3
  6  => 240,   // x4
  7  => 20,    // y4
  8  => 50,    // x5
  9  => 40,    // y5
  10 => 10,    // x6
  11 => 10,    // y6
);

// create image
$im = imagecreate(250, 250);

// some colors
$bg   = imagecolorallocate($im, 255, 255, 255);
$blue = imagecolorallocate($im, 0, 0, 255);

// draw a polygon
imagefilledpolygon($im, $values, 6, $blue );

// flush image
header('Content-type: image/png');
imagepng($im);
imagedestroy($im);

?>

이전 | 처음으로 | 다음
imagefilledellipse | 위로 | imagefilledrectangle


imagefilledrectangle

(PHP 3, PHP 4 , PHP 5)

imagefilledrectangle -- Draw a filled rectangle

Description

int imagefilledrectangle ( resource image, int x1, int y1, int x2, int y2, int color)

imagefilledrectangle() creates a filled rectangle of color color in image image starting at upper left coordinates x1, y1 and ending at bottom right coordinates x2, y2. 0, 0 is the top left corner of the image.

이전 | 처음으로 | 다음
imagefilledpolygon | 위로 | imagefilltoborder


imagefilltoborder

(PHP 3, PHP 4 , PHP 5)

imagefilltoborder -- Flood fill to specific color

Description

int imagefilltoborder ( resource image, int x, int y, int border, int color)

imagefilltoborder() performs a flood fill whose border color is defined by border. The starting point for the fill is x, y (top left is 0, 0) and the region is filled with color color.

이전 | 처음으로 | 다음
imagefilledrectangle | 위로 | imagefilter


imagefilter

(PHP 5)

imagefilter -- Applies Filter an image using a custom angle

Description

bool imagefilter ( resource src_im, int filtertype [, int args])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: 이 함수는 PHP에 포함된 GD 라이브러리를 사용하여 컴파일하였을 경우에만 사용할 수 있습니다.

이전 | 처음으로 | 다음
imagefilltoborder | 위로 | imagefontheight


imagefontheight

(PHP 3, PHP 4 , PHP 5)

imagefontheight -- Get font height

Description

int imagefontheight ( int font)

Returns the pixel height of a character in the specified font.

See also imagefontwidth() and imageloadfont().

이전 | 처음으로 | 다음
imagefilter | 위로 | imagefontwidth


imagefontwidth

(PHP 3, PHP 4 , PHP 5)

imagefontwidth -- Get font width

Description

int imagefontwidth ( int font)

Returns the pixel width of a character in font.

See also imagefontheight() and imageloadfont().

이전 | 처음으로 | 다음
imagefontheight | 위로 | imageftbbox


imageftbbox

(PHP 4 >= 4.1.0, PHP 5)

imageftbbox -- Give the bounding box of a text using fonts via freetype2

Description

array imageftbbox ( int size, int angle, string font_file, string text [, array extrainfo])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
imagefontwidth | 위로 | imagefttext


imagefttext

(PHP 4 >= 4.1.0, PHP 5)

imagefttext -- Write text to the image using fonts using FreeType 2

Description

array imagefttext ( resource image, int size, int angle, int x, int y, int col, string font_file, string text [, array extrainfo])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
imageftbbox | 위로 | imagegammacorrect


imagegammacorrect

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

imagegammacorrect -- Apply a gamma correction to a GD image

Description

int imagegammacorrect ( resource image, float inputgamma, float outputgamma)

The imagegammacorrect() function applies gamma correction to a gd image stream (image) given an input gamma, the parameter inputgamma and an output gamma, the parameter outputgamma.

이전 | 처음으로 | 다음
imagefttext | 위로 | imagegd2


imagegd2

(PHP 4 >= 4.1.0, PHP 5)

imagegd2 -- Output GD2 image

Description

int imagegd2 ( resource image [, string filename [, int chunk_size [, int type]]])

imagegd2() outputs GD2 image to browser or file.

The optional type parameter is either IMG_GD2_RAW or IMG_GD2_COMPRESSED. Default is IMG_GD2_RAW.

참고: The optional chunk_size and type parameters became available in PHP 4.3.2.

이전 | 처음으로 | 다음
imagegammacorrect | 위로 | imagegd


imagegd

(PHP 4 >= 4.1.0, PHP 5)

imagegd -- Output GD image to browser or file

Description

int imagegd ( resource image [, string filename])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
imagegd2 | 위로 | imagegif


imagegif

(PHP 3, PHP 4 , PHP 5)

imagegif -- Output image to browser or file

Description

int imagegif ( resource image [, string filename])

imagegif() creates the GIF file in filename from the image image. The image argument is the return from the imagecreate() function.

The image format will be GIF87a unless the image has been made transparent with imagecolortransparent(), in which case the image format will be GIF89a.

The filename argument is optional, and if left off, the raw image stream will be output directly. By sending an image/gif content-type using header(), you can create a PHP script that outputs GIF images directly.

참고: Since all GIF support was removed from the GD library in version 1.6, this function is not available if you are using that version of the GD library. Support is expected to return in a version subsequent to the rerelease of GIF support in the GD library in mid 2004. For more information, see the GD Project site.

The following code snippet allows you to write more portable PHP applications by auto-detecting the type of GD support which is available. Replace the sequence header ("Content-type: image/gif"); imagegif ($im); by the more flexible sequence:

<?php
if (function_exists("imagegif")) {
    header("Content-type: image/gif");
    imagegif($im);
} elseif (function_exists("imagejpeg")) {
    header("Content-type: image/jpeg");
    imagejpeg($im, "", 0.5);
} elseif (function_exists("imagepng")) {
    header("Content-type: image/png");
    imagepng($im);
} elseif (function_exists("imagewbmp")) {
    header("Content-type: image/vnd.wap.wbmp");
    imagewbmp($im);
} else {
    die("No image support in this PHP server");
}
?>

참고: As of version 3.0.18 and 4.0.2 you can use the function imagetypes() in place of function_exists() for checking the presence of the various supported image formats:

<?php
if (imagetypes() & IMG_GIF) {
    header ("Content-type: image/gif");
    imagegif ($im);
} elseif (imagetypes() & IMG_JPG) {
    /* ... etc. */
}
?>

See also imagepng(), imagewbmp(), imagejpeg() and imagetypes().

이전 | 처음으로 | 다음
imagegd | 위로 | imageinterlace


imageinterlace

(PHP 3, PHP 4 , PHP 5)

imageinterlace -- Enable or disable interlace

Description

int imageinterlace ( resource image [, int interlace])

imageinterlace() turns the interlace bit on or off. If interlace is 1 the image will be interlaced, and if interlace is 0 the interlace bit is turned off.

If the interlace bit is set and the image is used as a JPEG image, the image is created as a progressive JPEG.

This function returns whether the interlace bit is set for the image.

이전 | 처음으로 | 다음
imagegif | 위로 | imageistruecolor


imageistruecolor

(PHP 4 >= 4.3.2, PHP 5)

imageistruecolor -- Finds whether an image is a truecolor image.

Description

bool imageistruecolor ( resource image)

imageistruecolor() finds whether the image image is a truecolor image.

See also imagecreatetruecolor().

이전 | 처음으로 | 다음
imageinterlace | 위로 | imagejpeg


imagejpeg

(PHP 3>= 3.0.16, PHP 4 , PHP 5)

imagejpeg -- Output image to browser or file

Description

int imagejpeg ( resource image [, string filename [, int quality]])

imagejpeg() creates the JPEG file in filename from the image image. The image argument is the return from the imagecreate() function.

The filename argument is optional, and if left off, the raw image stream will be output directly. To skip the filename argument in order to provide a quality argument just use an empty string (''). By sending an image/jpeg content-type using header(), you can create a PHP script that outputs JPEG images directly.

참고: JPEG support is only available if PHP was compiled against GD-1.8 or later.

quality is optional, and ranges from 0 (worst quality, smaller file) to 100 (best quality, biggest file). The default is the default IJG quality value (about 75).

If you want to output Progressive JPEGs, you need to set interlacing on with imageinterlace().

See also
imagepng(),
imagegif(),
imagewbmp(),
imageinterlace() and
imagetypes().

이전 | 처음으로 | 다음
imageistruecolor | 위로 | imagelayereffect


imagelayereffect

(PHP 4 >= 4.3.0, PHP 5)

imagelayereffect -- Set the alpha blending flag to use the bundled libgd layering effects

Description

bool imagelayereffect ( resource image, int effect)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: 이 함수는 PHP에 포함된 GD 라이브러리를 사용하여 컴파일하였을 경우에만 사용할 수 있습니다.

이전 | 처음으로 | 다음
imagejpeg | 위로 | imageline


imageline

(PHP 3, PHP 4 , PHP 5)

imageline -- Draw a line

Description

int imageline ( resource image, int x1, int y1, int x2, int y2, int color)

imageline() draws a line from x1, y1 to x2, y2 (top left is 0, 0) in image image of color color.

예 1. Drawing a thick line

<?php

function imagelinethick($image, $x1, $y1, $x2, $y2, $color, $thick = 1)
{
    /* this way it works well only for orthogonal lines
    imagesetthickness($image, $thick);
    return imageline($image, $x1, $y1, $x2, $y2, $color);
    */
    if ($thick == 1) {
        return imageline($image, $x1, $y1, $x2, $y2, $color);
    }
    $t = $thick / 2 - 0.5;
    if ($x1 == $x2 || $y1 == $y2) {
        return imagefilledrectangle($image, round(min($x1, $x2) - $t), round(min($y1, $y2) - $t), round(max($x1, $x2) + $t), round(max($y1, $y2) + $t), $color);
    }
    $k = ($y2 - $y1) / ($x2 - $x1); //y = kx + q
    $a = $t / sqrt(1 + pow($k, 2));
    $points = array(
        round($x1 - (1+$k)*$a), round($y1 + (1-$k)*$a),
        round($x1 - (1-$k)*$a), round($y1 - (1+$k)*$a),
        round($x2 + (1+$k)*$a), round($y2 - (1-$k)*$a),
        round($x2 + (1-$k)*$a), round($y2 + (1+$k)*$a),
    );
    imagefilledpolygon($image, $points, 4, $color);
    return imagepolygon($image, $points, 4, $color);
}

?>

See also imagecreate() and imagecolorallocate().

이전 | 처음으로 | 다음
imagelayereffect | 위로 | imageloadfont


imageloadfont

(PHP 3, PHP 4 , PHP 5)

imageloadfont -- Load a new font

Description

int imageloadfont ( string file)

imageloadfont() loads a user-defined bitmap font and returns an identifier for the font (that is always greater than 5, so it will not conflict with the built-in fonts).

The font file format is currently binary and architecture dependent. This means you should generate the font files on the same type of CPU as the machine you are running PHP on.

표 1. Font file format

byte position | C data type | description
byte 0-3 | int | number of characters in the font
byte 4-7 | int | value of first character in the font (often 32 for space)
byte 8-11 | int | pixel width of each character
byte 12-15 | int | pixel height of each character
byte 16- | char | array with character data, one byte per pixel in each character, for a total of (nchars*width*height) bytes.

See also imagefontwidth() and imagefontheight().

이전 | 처음으로 | 다음
imageline | 위로 | imagepalettecopy


imagepalettecopy

(PHP 4 >= 4.0.1, PHP 5)

imagepalettecopy -- Copy the palette from one image to another

Description

int imagepalettecopy ( resource destination, resource source)

imagepalettecopy() copies the palette from the source image to the destination image.

이전 | 처음으로 | 다음
imageloadfont | 위로 | imagepng


imagepng

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

imagepng -- Output a PNG image to either the browser or a file

Description

int imagepng ( resource image [, string filename])

The imagepng() outputs a GD image stream (image) in PNG format to standard output (usually the browser) or, if a filename is given by the filename it outputs the image to the file.

<?php
$im = imagecreatefrompng("test.png");
imagepng($im);
?>

See also imagegif(), imagewbmp(), imagejpeg(), imagetypes().

이전 | 처음으로 | 다음
imagepalettecopy | 위로 | imagepolygon


imagepolygon

(PHP 3, PHP 4 , PHP 5)

imagepolygon -- Draw a polygon

Description

int imagepolygon ( resource image, array points, int num_points, int color)

imagepolygon() creates a polygon in image id. points is a PHP array containing the polygon's vertices, i.e. points[0] = x0, points[1] = y0, points[2] = x1, points[3] = y1, etc. num_points is the total number of points (vertices).

예 1. imagepolygon() example

<?php
// create a blank image
$image = imagecreate(400, 300);

// fill the background color
$bg = imagecolorallocate($image, 0, 0, 0);

// choose a color for the polygon
$col_poly = imagecolorallocate($image, 255, 255, 255);

// draw the polygon
imagepolygon($image,
             array (
                    0, 0,
                    100, 200,
                    300, 200
             ),
             3,
             $col_poly);

// output the picture
header("Content-type: image/png");
imagepng($image);

?>

See also imagecreate() and imagecreatetruecolor().

이전 | 처음으로 | 다음
imagepng | 위로 | imagepsbbox


imagepsbbox

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

imagepsbbox -- Give the bounding box of a text rectangle using PostScript Type1 fonts

Description

array imagepsbbox ( string text, int font, int size [, int space [, int tightness [, float angle]]])

size is expressed in pixels.

space allows you to change the default value of a space in a font. This amount is added to the normal value and can also be negative.

tightness allows you to control the amount of white space between characters. This amount is added to the normal character width and can also be negative.

angle is in degrees.

Parameters space and tightness are expressed in character space units, where 1 unit is 1/1000th of an em-square.

Parameters space, tightness, and angle are optional.

The bounding box is calculated using information available from character metrics, and unfortunately tends to differ slightly from the results achieved by actually rasterizing the text. If the angle is 0 degrees, you can expect the text to need 1 pixel more to every direction.

참고: 이 함수는 --enable-t1lib를 사용하여 PHP를 컴파일 했을 경우에만 사용할 수 있습니다.

This function returns an array containing the following elements:

0 | lower left x-coordinate
1 | lower left y-coordinate
2 | upper right x-coordinate
3 | upper right y-coordinate

See also imagepstext().

이전 | 처음으로 | 다음
imagepolygon | 위로 | imagepscopyfont


imagepscopyfont

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

imagepscopyfont -- Make a copy of an already loaded font for further modification

Description

int imagepscopyfont ( int fontindex)

Use this function if you need make further modifications to the font, for example extending/condensing, slanting it or changing its character encoding vector, but need to keep the original along as well. Note that the font you want to copy must be one obtained using imagepsloadfont(), not a font that is itself a copied one. You can although make modifications to it before copying.

If you use this function, you must free the fonts obtained this way yourself and in reverse order. Otherwise your script will hang.

In the case everything went right, a valid font index will be returned and can be used for further purposes. Otherwise the function returns FALSE and prints a message describing what went wrong.

참고: 이 함수는 --enable-t1lib를 사용하여 PHP를 컴파일 했을 경우에만 사용할 수 있습니다.

See also imagepsloadfont().

이전 | 처음으로 | 다음
imagepsbbox | 위로 | imagepsencodefont


imagepsencodefont

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

imagepsencodefont -- Change the character encoding vector of a font

Description

int imagepsencodefont ( int font_index, string encodingfile)

Loads a character encoding vector from a file and changes the fonts encoding vector to it. As a PostScript fonts default vector lacks most of the character positions above 127, you'll definitely want to change this if you use an other language than English. The exact format of this file is described in T1libs documentation. T1lib comes with two ready-to-use files, IsoLatin1.enc and IsoLatin2.enc.

If you find yourself using this function all the time, a much better way to define the encoding is to set ps.default_encoding in the configuration file to point to the right encoding file and all fonts you load will automatically have the right encoding.

참고: 이 함수는 --enable-t1lib를 사용하여 PHP를 컴파일 했을 경우에만 사용할 수 있습니다.

이전 | 처음으로 | 다음
imagepscopyfont | 위로 | imagepsextendfont


imagepsextendfont

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

imagepsextendfont -- Extend or condense a font

Description

bool imagepsextendfont ( int font_index, float extend)

Extend or condense a font (font_index), if the value of the extend parameter is less than one you will be condensing the font.

참고: 이 함수는 --enable-t1lib를 사용하여 PHP를 컴파일 했을 경우에만 사용할 수 있습니다.

이전 | 처음으로 | 다음
imagepsencodefont | 위로 | imagepsfreefont


imagepsfreefont

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

imagepsfreefont -- Free memory used by a PostScript Type 1 font

Description

void imagepsfreefont ( int fontindex)

imagepsfreefont() frees memory used by a PostScript Type 1 font.

참고: 이 함수는 --enable-t1lib를 사용하여 PHP를 컴파일 했을 경우에만 사용할 수 있습니다.

See also imagepsloadfont().

이전 | 처음으로 | 다음
imagepsextendfont | 위로 | imagepsloadfont


imagepsloadfont

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

imagepsloadfont -- Load a PostScript Type 1 font from file

Description

int imagepsloadfont ( string filename)

In the case everything went right, a valid font index will be returned and can be used for further purposes. Otherwise the function returns FALSE and prints a message describing what went wrong, which you cannot read directly, while the output type is image.

예 1. imagepsloadfont() example

<?php
header("Content-type: image/jpeg");
$im = imagecreate(350, 45);
$black = imagecolorallocate($im, 0, 0, 0);
$white = imagecolorallocate($im, 255, 255, 255);
$font = imagepsloadfont("bchbi.pfb"); // or locate your .pfb files on your machine
imagepstext($im, "Testing... It worked!", $font, 32, $white, $black, 32, 32);
imagepsfreefont($font);
imagejpeg($im, "", 100); //for best quality...your mileage may vary
imagedestroy($im);
?>

참고: 이 함수는 --enable-t1lib를 사용하여 PHP를 컴파일 했을 경우에만 사용할 수 있습니다.

See also imagepsfreefont().

이전 | 처음으로 | 다음
imagepsfreefont | 위로 | imagepsslantfont


imagepsslantfont

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

imagepsslantfont -- Slant a font

Description

bool imagepsslantfont ( int font_index, float slant)

Slant a font given by the font_index parameter with a slant of the value of the slant parameter.

참고: 이 함수는 --enable-t1lib를 사용하여 PHP를 컴파일 했을 경우에만 사용할 수 있습니다.

이전 | 처음으로 | 다음
imagepsloadfont | 위로 | imagepstext


imagepstext

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

imagepstext -- To draw a text string over an image using PostScript Type1 fonts

Description

array imagepstext ( resource image, string text, int font, int size, int foreground, int background, int x, int y [, int space [, int tightness [, float angle [, int antialias_steps]]]])

foreground is the color in which the text will be painted. Background is the color to which the text will try to fade in with antialiasing. No pixels with the color background are actually painted, so the background image does not need to be of solid color.

The coordinates given by x, y will define the origin (or reference point) of the first character (roughly the lower-left corner of the character). This is different from the imagestring(), where x, y define the upper-right corner of the first character. Refer to PostScript documentation about fonts and their measuring system if you have trouble understanding how this works.

space allows you to change the default value of a space in a font. This amount is added to the normal value and can also be negative.

tightness allows you to control the amount of white space between characters. This amount is added to the normal character width and can also be negative.

angle is in degrees.

size is expressed in pixels.

antialias_steps allows you to control the number of colours used for antialiasing text. Allowed values are 4 and 16. The higher value is recommended for text sizes lower than 20, where the effect in text quality is quite visible. With bigger sizes, use 4. It's less computationally intensive.

Parameters space and tightness are expressed in character space units, where 1 unit is 1/1000th of an em-square.

Parameters space, tightness, angle and antialias_steps are optional.

참고: 이 함수는 --enable-t1lib를 사용하여 PHP를 컴파일 했을 경우에만 사용할 수 있습니다.

This function returns an array containing the following elements:

0 | lower left x-coordinate
1 | lower left y-coordinate
2 | upper right x-coordinate
3 | upper right y-coordinate

See also imagepsbbox().

이전 | 처음으로 | 다음
imagepsslantfont | 위로 | imagerectangle


imagerectangle

(PHP 3, PHP 4 , PHP 5)

imagerectangle -- Draw a rectangle

Description

int imagerectangle ( resource image, int x1, int y1, int x2, int y2, int col)

imagerectangle() creates a rectangle of color col in image image starting at upper left coordinate x1, y1 and ending at bottom right coordinate x2, y2. 0, 0 is the top left corner of the image.

이전 | 처음으로 | 다음
imagepstext | 위로 | imagerotate


imagerotate

(PHP 4 >= 4.3.0, PHP 5)

imagerotate -- Rotate an image with a given angle

Description

resource imagerotate ( resource src_im, float angle, int bgd_color)

Rotates the src_im image using a given angle in degree. bgd_color specifies the color of the uncovered zone after the rotation.

참고: 이 함수는 PHP에 포함된 GD 라이브러리를 사용하여 컴파일하였을 경우에만 사용할 수 있습니다.

이전 | 처음으로 | 다음
imagerectangle | 위로 | imagesavealpha


imagesavealpha

(PHP 4 >= 4.3.2, PHP 5)

imagesavealpha -- Set the flag to save full alpha channel information (as opposed to single-color transparency) when saving PNG images.

Description

bool imagesavealpha ( resource image, bool saveflag)

imagesavealpha() sets the flag to attempt to save full alpha channel information (as opposed to single-color transparency) when saving PNG images.

You have to unset alphablending (imagealphablending($im, FALSE)), to use it.

Alpha channel is not supported by all browsers, if you have problem with your browser, try to load your script with an alpha channel compliant browser, e.g. latest Mozilla.

See also imagealphablending().

이전 | 처음으로 | 다음
imagerotate | 위로 | imagesetbrush


imagesetbrush

(PHP 4 >= 4.0.6, PHP 5)

imagesetbrush -- Set the brush image for line drawing

Description

int imagesetbrush ( resource image, resource brush)

imagesetbrush() sets the brush image to be used by all line drawing functions (such as imageline() and imagepolygon()) when drawing with the special colors IMG_COLOR_BRUSHED or IMG_COLOR_STYLEDBRUSHED.

참고: You need not take special action when you are finished with a brush, but if you destroy the brush image, you must not use the IMG_COLOR_BRUSHED or IMG_COLOR_STYLEDBRUSHED colors until you have set a new brush image!

참고: This function was added in PHP 4.0.6

이전 | 처음으로 | 다음
imagesavealpha | 위로 | imagesetpixel


imagesetpixel

(PHP 3, PHP 4 , PHP 5)

imagesetpixel -- Set a single pixel

Description

int imagesetpixel ( resource image, int x, int y, int color)

imagesetpixel() draws a pixel at x, y (top left is 0, 0) in image image of color color.

See also imagecreate() and imagecolorallocate().

이전 | 처음으로 | 다음
imagesetbrush | 위로 | imagesetstyle


imagesetstyle

(PHP 4 >= 4.0.6, PHP 5)

imagesetstyle -- Set the style for line drawing

Description

bool imagesetstyle ( resource image, array style)

imagesetstyle() sets the style to be used by all line drawing functions (such as imageline() and imagepolygon()) when drawing with the special color IMG_COLOR_STYLED or lines of images with color IMG_COLOR_STYLEDBRUSHED. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

The style parameter is an array of pixels. Following example script draws a dashed line from upper left to lower right corner of the canvas:

예 1. imagesetstyle() example

<?php
header("Content-type: image/jpeg");
$im  = imagecreate(100, 100);
$w   = imagecolorallocate($im, 255, 255, 255);
$red = imagecolorallocate($im, 255, 0, 0);

/* Draw a dashed line, 5 red pixels, 5 white pixels */
$style = array($red, $red, $red, $red, $red, $w, $w, $w, $w, $w);
imagesetstyle($im, $style);
imageline($im, 0, 0, 100, 100, IMG_COLOR_STYLED);

/* Draw a line of happy faces using imagesetbrush() with imagesetstyle */
$style = array($w, $w, $w, $w, $w, $w, $w, $w, $w, $w, $w, $w, $red);
imagesetstyle($im, $style);

$brush = imagecreatefrompng("http://www.libpng.org/pub/png/images/smile.happy.png");
$w2 = imagecolorallocate($brush, 255, 255, 255);
imagecolortransparent($brush, $w2);
imagesetbrush($im, $brush);
imageline($im, 100, 0, 0, 100, IMG_COLOR_STYLEDBRUSHED);

imagejpeg($im);
imagedestroy($im);
?>

See also imagesetbrush(), imageline().

참고: This function was added in PHP 4.0.6

이전 | 처음으로 | 다음
imagesetpixel | 위로 | imagesetthickness


imagesetthickness

(PHP 4 >= 4.0.6, PHP 5)

imagesetthickness -- Set the thickness for line drawing

Description

bool imagesetthickness ( resource image, int thickness)

imagesetthickness() sets the thickness of the lines drawn when drawing rectangles, polygons, ellipses etc. etc. to thickness pixels. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: This function was added in PHP 4.0.6 and requires GD 2.0.1 or later

이전 | 처음으로 | 다음
imagesetstyle | 위로 | imagesettile


imagesettile

(PHP 4 >= 4.0.6, PHP 5)

imagesettile -- Set the tile image for filling

Description

int imagesettile ( resource image, resource tile)

imagesettile() sets the tile image to be used by all region filling functions (such as imagefill() and imagefilledpolygon()) when filling with the special color IMG_COLOR_TILED.

A tile is an image used to fill an area with a repeated pattern. Any GD image can be used as a tile, and by setting the transparent color index of the tile image with imagecolortransparent(), a tile allows certain parts of the underlying area to shine through can be created.

참고: You need not take special action when you are finished with a tile, but if you destroy the tile image, you must not use the IMG_COLOR_TILED color until you have set a new tile image!

이전 | 처음으로 | 다음
imagesetthickness | 위로 | imagestring


imagestring

(PHP 3, PHP 4 , PHP 5)

imagestring -- Draw a string horizontally

Description

int imagestring ( resource image, int font, int x, int y, string s, int col)

imagestring() draws the string s in the image identified by image at coordinates x, y (top left is 0, 0) in color col. If font is 1, 2, 3, 4 or 5, a built-in font is used.

예 1. imagestring() example

<?php

  // create a 100*30 image
  $im = imagecreate(100, 30);

  // white background and blue text
  $bg = imagecolorallocate($im, 255, 255, 255);
  $textcolor = imagecolorallocate($im, 0, 0, 255);

  // write the string at the top left
  imagestring($im, 5, 0, 0, "Hello world!", $textcolor);

  // output the image
  header("Content-type: image/jpg");
  imagejpeg($im);
?>

See also imageloadfont().

이전 | 처음으로 | 다음
imagesettile | 위로 | imagestringup


imagestringup

(PHP 3, PHP 4 , PHP 5)

imagestringup -- Draw a string vertically

Description

int imagestringup ( resource image, int font, int x, int y, string s, int col)

imagestringup() draws the string s vertically in the image identified by image at coordinates x, y (top left is 0, 0) in color col. If font is 1, 2, 3, 4 or 5, a built-in font is used.

See also imageloadfont().

이전 | 처음으로 | 다음
imagestring | 위로 | imagesx


imagesx

(PHP 3, PHP 4 , PHP 5)

imagesx -- Get image width

Description

int imagesx ( resource image)

imagesx() returns the width of the image identified by image.

예 1. Using imagesx()

<?php

// create a 300*200 image
$img = imagecreate(300, 200);

echo imagesx($img); // 300

?>

See also imagecreate(),
getimagesize() and
imagesy().

이전 | 처음으로 | 다음
imagestringup | 위로 | imagesy


imagesy

(PHP 3, PHP 4 , PHP 5)

imagesy -- Get image height

Description

int imagesy ( resource image)

imagesy() returns the height of the image identified by image.

예 1. Using imagesy()

<?php

// create a 300*200 image
$img = imagecreate(300, 200);

echo imagesy($img); // 200

?>

See also imagecreate(),
getimagesize() and
imagesx().

이전 | 처음으로 | 다음
imagesx | 위로 | imagetruecolortopalette


imagetruecolortopalette

(PHP 4 >= 4.0.6, PHP 5)

imagetruecolortopalette -- Convert a true color image to a palette image

Description

void imagetruecolortopalette ( resource image, bool dither, int ncolors)

imagetruecolortopalette() converts a truecolor image to a palette image. The code for this function was originally drawn from the Independent JPEG Group library code, which is excellent. The code has been modified to preserve as much alpha channel information as possible in the resulting palette, in addition to preserving colors as well as possible. This does not work as well as might be hoped. It is usually best to simply produce a truecolor output image instead, which guarantees the highest output quality.

dither indicates if the image should be dithered - if it is TRUE then dithering will be used which will result in a more speckled image but with better color approximation.

ncolors sets the maximum number of colors that should be retained in the palette.

참고: This function was added in PHP 4.0.6 and requires GD 2.0.1 or later

이전 | 처음으로 | 다음
imagesy | 위로 | imagettfbbox


imagettfbbox

(PHP 3>= 3.0.1, PHP 4 , PHP 5)

imagettfbbox -- Give the bounding box of a text using TrueType fonts

Description

array imagettfbbox ( int size, int angle, string fontfile, string text)

This function calculates and returns the bounding box in pixels for a TrueType text.

text

The string to be measured.

size

The font size in pixels.

fontfile

The name of the TrueType font file. (Can also be a URL.) Depending on which version of the GD library that PHP is using, it may attempt to search for files that do not begin with a leading '/' by appending '.ttf' to the filename and searching along a library-defined font path.

angle

Angle in degrees in which text will be measured.

imagettfbbox() returns an array with 8 elements representing four points making the bounding box of the text:

0 | lower left corner, X position
1 | lower left corner, Y position
2 | lower right corner, X position
3 | lower right corner, Y position
4 | upper right corner, X position
5 | upper right corner, Y position
6 | upper left corner, X position
7 | upper left corner, Y position

The points are relative to the text regardless of the angle, so "upper left" means in the top left-hand corner seeing the text horizontally.

This function requires both the GD library and the FreeType library.

See also imagettftext().

이전 | 처음으로 | 다음
imagetruecolortopalette | 위로 | imagettftext


imagettftext

(PHP 3, PHP 4 , PHP 5)

imagettftext -- Write text to the image using TrueType fonts

Description

array imagettftext ( resource image, int size, int angle, int x, int y, int color, string fontfile, string text)

imagettftext() draws the string text in the image identified by image, starting at coordinates x, y (top left is 0, 0), at an angle of angle in color color, using the TrueType font file identified by fontfile. Depending on which version of the GD library that PHP is using, when fontfile does not begin with a leading '/', '.ttf' will be appended to the filename and the library will attempt to search for that filename along a library-defined font path.

The coordinates given by x, y will define the basepoint of the first character (roughly the lower-left corner of the character). This is different from the imagestring(), where x, y define the upper-right corner of the first character.

angle is in degrees, with 0 degrees being left-to-right reading text (3 o'clock direction), and higher values representing a counter-clockwise rotation. (i.e., a value of 90 would result in bottom-to-top reading text).

fontfile is the path to the TrueType font you wish to use.

text is the text string which may include UTF-8 character sequences (of the form: &#123;) to access characters in a font beyond the first 255.

color is the color index. Using the negative of a color index has the effect of turning off antialiasing.

imagettftext() returns an array with 8 elements representing four points making the bounding box of the text. The order of the points is lower left, lower right, upper right, upper left. The points are relative to the text regardless of the angle, so "upper left" means in the top left-hand corner when you see the text horizontally.

This example script will produce a black JPEG 400x30 pixels, with the words "Testing..." in white in the font Arial.

예 1. imagettftext() example

<?php
  header("Content-type: image/jpeg");
  $im = imagecreate(400, 30);
  $white = imagecolorallocate($im, 255, 255, 255);
  $black = imagecolorallocate($im, 0, 0, 0);

  // Replace path by your own font path
  imagettftext($im, 20, 0, 10, 20, $black, "/path/arial.ttf",
  "Testing... Omega: &amp;#937;");
  imagejpeg($im);
  imagedestroy($im);
?>

This function requires both the GD library and the FreeType library.

See also imagettfbbox().

이전 | 처음으로 | 다음
imagettfbbox | 위로 | imagetypes


imagetypes

(PHP 3 CVS only, PHP 4 >= 4.0.2, PHP 5)

imagetypes -- Return the image types supported by this PHP build

Description

int imagetypes ( void )

This function returns a bit-field corresponding to the image formats supported by the version of GD linked into PHP. The following bits are returned, IMG_GIF | IMG_JPG | IMG_PNG | IMG_WBMP | IMG_XPM. To check for PNG support, for example, do this:

예 1. imagetypes() example

<?php
if (imagetypes() & IMG_PNG) {
    echo "PNG Support is enabled";
}
?>

이전 | 처음으로 | 다음
imagettftext | 위로 | imagewbmp


imagewbmp

(PHP 3>= 3.0.15, PHP 4 >= 4.0.1, PHP 5)

imagewbmp -- Output image to browser or file

Description

int imagewbmp ( resource image [, string filename [, int foreground]])

imagewbmp() creates the WBMP file in filename from the image image. The image argument is the return from the imagecreate() function.

The filename argument is optional, and if left off, the raw image stream will be output directly. By sending an image/vnd.wap.wbmp content-type using header(), you can create a PHP script that outputs WBMP images directly.

참고: WBMP support is only available if PHP was compiled against GD-1.8 or later.

Using the optional foreground parameter, you can set the foreground color. Use an identifier obtained from imagecolorallocate(). The default foreground color is black.

See also image2wbmp(), imagepng(),
imagegif(), imagejpeg(),
imagetypes().

이전 | 처음으로 | 다음
imagetypes | 위로 | imagexbm


imagexbm

(PHP 5)

imagexbm -- Output XBM image to browser or file

Description

int imagexbm ( resource image, string filename [, int foreground])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: 이 함수는 PHP에 포함된 GD 라이브러리를 사용하여 컴파일하였을 경우에만 사용할 수 있습니다.

이전 | 처음으로 | 다음
imagewbmp | 위로 | iptcembed


iptcembed

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

iptcembed -- Embed binary IPTC data into a JPEG image

Description

array iptcembed ( string iptcdata, string jpeg_file_name [, int spool])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
imagexbm | 위로 | iptcparse


iptcparse

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

iptcparse -- Parse a binary IPTC http://www.iptc.org/ block into single tags.

Description

array iptcparse ( string iptcblock)

This function parses a binary IPTC block into its single tags. It returns an array using the tagmarker as an index and the value as the value. It returns FALSE on error or if no IPTC data was found. See getimagesize() for a sample.

이전 | 처음으로 | 다음
iptcembed | 위로 | jpeg2wbmp


jpeg2wbmp

(PHP 4 >= 4.0.5, PHP 5)

jpeg2wbmp -- Convert JPEG image file to WBMP image file

Description

int jpeg2wbmp ( string jpegname, string wbmpname, int d_height, int d_width, int threshold)

Converts the jpegname JPEG file to WBMP format, and saves it as wbmpname. With the d_height and d_width you specify the height and width of the destination image.

참고: WBMP support is only available if PHP was compiled against GD-1.8 or later.

See also png2wbmp().

이전 | 처음으로 | 다음
iptcparse | 위로 | png2wbmp


png2wbmp

(PHP 4 >= 4.0.5, PHP 5)

png2wbmp -- Convert PNG image file to WBMP image file

Description

int png2wbmp ( string pngname, string wbmpname, int d_height, int d_width, int threshold)

Converts the pngname PNG file to WBMP format, and saves it as wbmpname. With the d_height and d_width you specify the height and width of the destination image.

참고: WBMP support is only available if PHP was compiled against GD-1.8 or later.

See also jpeg2wbmp().

이전 | 처음으로 | 다음
jpeg2wbmp | 위로 | read_exif_data


read_exif_data

read_exif_data -- Alias of exif_read_data()

Description

This function is an alias of exif_read_data().

이전 | 처음으로 | 다음
png2wbmp | 위로 | IMAP, POP3 그리고 NNTP 함수


IMAP, POP3 그리고 NNTP 함수

PHP 매뉴얼
이전 다음

XLII. IMAP, POP3 그리고 NNTP 함수

이 함수를 작동시키려면, --with-imap 옵션으로 PHP를 컴파일해야 한다. 이 옵션은 c-client 라이브러리가 요구된다. ftp://ftp.cac.washington.edu/imap/으로부터 최신 버전을 내려받아 컴파일 하시오. 그리고 c-client/c-client.a파일을 /usr/local/lib/libc-client.a로,또는 다른 링크 경로에 복사하시오. c-client/rfc822.h, mail.h 과 linkage.h를 /usr/local/include이나 다른 include경로에 복사하시오.

이 함수는 그 이름에도 불구하고, IMAP 프로토콜에만 한정되어 있지 않다. 이함수의 기초를 이루는 c-client 라이브러리는 또한 NNTP, POP3 그리고 로컬 메일함 접근 메쏘드를 지원한다.

이 문서는 여기서 제공되는 함수에 관계된 모든 주제를 설명 할 수는 없다. 더 자세한 정보는 c-client 라이브러리 소스의 문서에 제공된다 (docs/internal.txt). 그리고 다음 RFC 문서들도 이와 관련된 정보를 제공한다:

  • RFC821: Simple Mail Transfer Protocol (SMTP).

  • RFC822: Standard for ARPA internet text messages.

  • RFC2060: Internet Message Access Protocol (IMAP) Version 4rev1.

  • RFC1939: Post Office Protocol Version 3 (POP3).

  • RFC977: Network News Transfer Protocol (NNTP).

  • RFC2076: Common Internet Message Headers.

  • RFC2045 , RFC2046 , RFC2047 , RFC2048 & RFC2049: Multipurpose Internet Mail Extensions (MIME).

더 자세한 사항은 David Wood씨가 저술한 Programming Internet Email 과 Dianna Mullet씨와 Kevin Mullet씨가 같이 저술한 Managing IMAP를 참고하시오.

차례
imap_8bit -- 8비트 문자열을 quoted-printable 문자열로 변환한다
imap_alerts -- 이 함수는 현재 페이지 요구(page request)동안이나,또는 경고 스택(alert stack)이 리셋(reset)된 이후에 발생한 경고(alert)메시지 (물론 있다면) 모두를 돌려준다
imap_append -- 특정 메일박스에 문자열 메시지를 덧붙인다.
imap_base64 -- BASE64로 엔코딩된 텍스트를 디코딩한다
imap_binary -- 8비트 문자열을 base64문자열로 변환한다
imap_body -- 메시지의 본문을 읽어온다
imap_bodystruct -- Read the structure of a specified body section of a specific message
imap_check -- 현재 메일 박스를 체크한다
imap_clearflag_full -- 메시지에서 플래그(flags)를 클리어(clear)한다
imap_close -- IMAP 스트림을 닫는다
imap_createmailbox -- 새 메일 박스를 만든다
imap_delete -- 현재 메일 박스에서 삭제될 메시지를 표시한다
imap_deletemailbox -- 메일 박스를 지운다
imap_errors -- 이 함수는 현재 페이지 요구(page request)동안에, 또는 에러 스택(error stack)이 리셋(reset)된 이후에 발생한 IMAP 에러(물론 있다면)를 모두 돌려준다
imap_expunge -- 지움 표시된 모든 메시지를 완전히 삭제한다
imap_fetch_overview -- 주어진 메시지 헤더의 전체 정보를 읽어 온다
imap_fetchbody -- 메시지의 본문중에서 특정 부분을 페치한다
imap_fetchheader -- 메시지에서 헤더를 돌려준다
imap_fetchstructure -- 특별한 메시지의 구조체를 읽어온다
imap_get_quota -- Retrieve the quota level settings, and usage statics per mailbox
imap_get_quotaroot -- Retrieve the quota settings per user
imap_getacl -- Gets the ACL for a given mailbox
imap_getmailboxes -- 메일박스의 목록을 읽어오고, 각 메일박스에 대한 상세한 정보를 돌려준다.
imap_getsubscribed -- subscribed된 모든 메일 박스의 목록을 보여준다.
imap_header -- Read the header of the message
imap_headerinfo -- 메시지의 머릿글을 읽어온다
imap_headers -- 메일박스에서 모든 메시지의 헤더를 돌려준다
imap_last_error -- 이 함수는 현재 페이지 요구(page request) 동안에 발생한 IMAP 에러(물론 있다면)의 가장 나중것을 돌려준다
imap_list -- Read the list of mailboxes
imap_listmailbox -- 메일박스의 목록을 읽어온다
imap_listscan -- Read the list of mailboxes, takes a string to search for in the text of the mailbox
imap_listsubscribed -- subscribed된 모든 메일박스의 목록을 보여준다
imap_lsub -- List all the subscribed mailboxes
imap_mail_compose -- 주어진 envelope와 body 섹션으로 구성된 MIME메시지를 만든다
imap_mail_copy -- 메일박스에 특정 메시지를 복사한다
imap_mail_move -- 메일박스에 특정 메시지를 이동시킨다
imap_mail -- 이메일 메시지를 보낸다
imap_mailboxmsginfo -- 현재 메일박스에 관한 정보를 가져온다
imap_mime_header_decode -- MIME 헤더 구성요소(element)를 디코딩한다
imap_msgno -- 이 함수는 주어진 UID값에 대해 메시지 일련번호(sequence number)을 넘겨준다
imap_num_msg -- 현재 메일박스의 메시지 갯수를 돌려준다
imap_num_recent -- 현재 메일박스의 새로운 메시지 갯수를 돌려준다
imap_open -- 메일박스에 IMAP 스트림(stream)을 연다
imap_ping -- IMAP 스트림(stream)이 아직 사용가능한지 체크한다
imap_qprint -- quoted-printable 문자열을 8비트 문자열로 변환한다
imap_renamemailbox -- 메일박스의 이름을 바꾼다
imap_reopen -- 새로운 메일박스에 IMAP 스트림(stream)을 다시 연다
imap_rfc822_parse_adrlist -- 주소 문자열을 해석한다
imap_rfc822_parse_headers -- 문자열에서 메일 헤더를 해석한다
imap_rfc822_write_address -- 주어진 메일박스, 호스트, 개인 정보로 적절히 형식화된 이메일 주소를 돌려준다
imap_scanmailbox -- 메일박스의 텍스트중에서 검색 문자열을 갖는 메일박스의 목록을 읽어 온다
imap_search -- 이 함수는 주어진 검색 기준(criteria)에 부합되는 메시지의 배열을 돌려준다
imap_set_quota -- Sets a quota for a given mailbox
imap_setacl -- Sets the ACL for a giving mailbox
imap_setflag_full -- 메시지에서 플래그(flags)를 셋(set)한다
imap_sort -- 메시지 헤더의 배열을 정렬한다
imap_status -- 이 함수는 현재 메일박스 이외의 다른 메일 박스의 상태 정보를 돌려준다
imap_subscribe -- 메일 박스에 Subscribe한다
imap_thread -- Return threaded by REFERENCES tree
imap_timeout -- Set or fetch imap timeout
imap_uid -- 이 함수는 주어진 메시지의 일련번호(sequence number)에 대한 UID를 돌려준다
imap_undelete -- 지움 표시된 메시지의 지움 표시를 제거한다
imap_unsubscribe -- 메일박스를 Unsubscribe한다
imap_utf7_decode -- modified UTF-7 인코딩된 문자열을 디코딩한다.
imap_utf7_encode -- 8비트 데이터를 UTF-7 텍스트로 변환한다.
imap_utf8 -- 텍스트를 UTF8로 변환한다

이전 | 처음으로 | 다음
read_exif_data | 위로 | imap_8bit


imap_8bit

(PHP 3, PHP 4 , PHP 5)

imap_8bit -- 8비트 문자열을 quoted-printable 문자열로 변환한다

Description

string imap_8bit ( string string)

8비트 문자열을 quoted-printable 문자열로 변환한다. (RFC2045, section 6.7에 따라)

quoted-printable 문자열을 돌려준다.

imap_qprint()함수도 보시오.

이전 | 처음으로 | 다음
IMAP, POP3 그리고 NNTP 함수 | 위로 | imap_alerts


imap_alerts

(PHP 3>= 3.0.12, PHP 4 , PHP 5)

imap_alerts -- 이 함수는 현재 페이지 요구(page request)동안이나,또는 경고 스택(alert stack)이 리셋(reset)된 이후에 발생한 경고(alert)메시지 (물론 있다면) 모두를 돌려준다

Description

array imap_alerts ( void )

이 함수는 가장 나중의 imap_alerts()함수의 호출 이후, 또는 페이지의 시작때부터 발생한 모든 IMAP 경고 메시지들의 배열을 돌려준다. imap_alerts()함수가 호출되면, 경고 스택(alert stack) 은 즉시 클리어(clear)된다. IMAP 사양에서는 이 메시지가 유저에게 넘겨질것을 요구하는 바이다.

이전 | 처음으로 | 다음
imap_8bit | 위로 | imap_append


imap_append

(PHP 3, PHP 4 , PHP 5)

imap_append -- 특정 메일박스에 문자열 메시지를 덧붙인다.

Description

int imap_append ( int imap_stream, string mbox, string message [, string flags])

성공하면 TRUE를 에러가 발생하면 FALSE를 리턴한다.

imap_append()함수는 특정 메일박스mbox에 문자열 메시지를 덧붙인다. 선택적 인수flags가 부여되면, flags도 그 메일박스에 쓴다.

Cyrus IMAP 서버에 접근할 때에는, end-of-line terminator로 "\n" 대신에 "\r\n"을 사용해야 한다. 그렇지 않으면 실패할 것이다.

예 1. imap_append() example

$stream = imap_open("{your.imap.host}INBOX.Drafts","username", "password");

$check = imap_check($stream);
print "Msg Count before append: ". $check->Nmsgs."\n";

imap_append($stream,"{your.imap.host}INBOX.Drafts"
                   ,"From: me@my.host\r\n"
                   ."To: you@your.host\r\n"
                   ."Subject: test\r\n"
                   ."\r\n"
                   ."this is a test message, please ignore\r\n"
                   );

$check = imap_check($stream);
print "Msg Count after append : ". $check->Nmsgs."\n";

imap_close($stream);

이전 | 처음으로 | 다음
imap_alerts | 위로 | imap_base64


imap_base64

(PHP 3, PHP 4 , PHP 5)

imap_base64 -- BASE64로 엔코딩된 텍스트를 디코딩한다

Description

string imap_base64 ( string text)

imap_base64()함수는 BASE-64로 엔코딩되어 있는 텍스트를 디코딩해준다 (RFC2045의 Section 6.8을 보라). 디코딩된 메시지가 문자열로 리턴되어 진다.

See also imap_binary().

이전 | 처음으로 | 다음
imap_append | 위로 | imap_binary


imap_binary

(PHP 3>= 3.0.2, PHP 4 , PHP 5)

imap_binary -- 8비트 문자열을 base64문자열로 변환한다

Description

string imap_binary ( string string)

8비트 문자열을 base64문자열로 변환한다. (RFC2045, Section 6.8에 따라)

base64 문자열을 돌려준다.

imap_base64()도 보시오.

이전 | 처음으로 | 다음
imap_base64 | 위로 | imap_body


imap_body

(PHP 3, PHP 4 , PHP 5)

imap_body -- 메시지의 본문을 읽어온다

Description

string imap_body ( int imap_stream, int msg_number [, int flags])

imap_body() returns the body of the message, numbered msg_number in the current mailbox. The optional flags are a bit mask with one or more of the following: imap_body()함수는 메시지의 본문을 리턴한다. 즉, 현재메일박스의 msg_number번째의 메시지 의 본문을 읽어 오게 된다. 선택적 인수 flags는 다음 리스트의 비트마스크 가 된다:

  • FT_UID - The msgno is a UID

  • FT_PEEK - Do not set the \Seen flag if not already set

  • FT_INTERNAL - The return string is in internal format, will not canonicalize to CRLF.

imap_body()함수는 메시지 본문을 완전히 복사해 올 것이다. multipart MIME-encoded 메시지의 한 부분을 뽑아내기 위해서는 본문의 구조를 분석하는 imap_fetchstructure()함수와 한개의 본문 구성요소의 복사물을 뽑아오는 imap_fetchbody()함수를 이용해야 한다.

이전 | 처음으로 | 다음
imap_binary | 위로 | imap_bodystruct


imap_bodystruct

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

imap_bodystruct -- Read the structure of a specified body section of a specific message

Description

object imap_bodystruct ( resource stream_id, int msg_no, int section)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
imap_body | 위로 | imap_check


imap_check

(PHP 3, PHP 4 , PHP 5)

imap_check -- 현재 메일 박스를 체크한다

Description

object imap_check ( int imap_stream)

현재 메일 박스에 대한 정보를 리턴한다. 실패하면 FALSE를 리턴한다.

imap_check() 함수는 서버에서 현재 메일박스의 상태를 체크하고 다음 속성을 갖는 객체로 정보를 리턴한다:

  • Date - last change of mailbox contents

  • Driver - protocol used to access this mailbox: POP3, IMAP, NNTP

  • Mailbox - the mailbox name

  • Nmsgs - number of messages in the mailbox

  • Recent - number of recent messages in the mailbox

이전 | 처음으로 | 다음
imap_bodystruct | 위로 | imap_clearflag_full


imap_clearflag_full

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

imap_clearflag_full -- 메시지에서 플래그(flags)를 클리어(clear)한다

Description

string imap_clearflag_full ( int stream, string sequence, string flag, string options)

This function causes a store to delete the specified flag to the flags set for the messages in the specified sequence. 이 함수는 지정된 일련번호의 메시지에서 지정된 플래그(flag)에 플래그 셋(flags set)을 제거한다. 언셋(unset)할 수 있는 플래그(flags)는 "\\Seen", "\\Answered", "\\Flagged", "\\Deleted", "\\Draft", 과 "\\Recent"이다. (RFC2060 문서에 정의된대로)

옵션은 다음의 한개 이상의 비트마스크(bit mask) 값이다:

ST_UID The sequence argument contains UIDs instead of
sequence numbers

이전 | 처음으로 | 다음
imap_check | 위로 | imap_close


imap_close

(PHP 3, PHP 4 , PHP 5)

imap_close -- IMAP 스트림을 닫는다

Description

int imap_close ( int imap_stream [, int flags])

imap 스트림을 닫는다. 선택적 인수 flag를 CL_EXPUNGE로 세팅하면, 스트림을 닫기 전에 조용히(silently) 메일 박스를 지울 것이다. 삭제 마크된 메시지만 모두 삭제한다.

이전 | 처음으로 | 다음
imap_clearflag_full | 위로 | imap_createmailbox


imap_createmailbox

(PHP 3, PHP 4 , PHP 5)

imap_createmailbox -- 새 메일 박스를 만든다

Description

int imap_createmailbox ( int imap_stream, string mbox)

imap_createmailbox()는 mbox인수에 주어진 이름으로 새 메일 박스를 만든다. 국제적인 문자들을 포함한 이름이면 imap_utf7_encode() 함수로 인코딩되어야 한다.

성공하면 TRUE를 실패하면 FALSE를 리턴한다.

See also imap_renamemailbox(),
imap_deletemailbox() and
imap_open() for the format
of mbox names.

예 1. imap_createmailbox() example

$mbox = imap_open("{your.imap.host}","username","password",OP_HALFOPEN)
     || die("can't connect: ".imap_last_error());

$name1 = "phpnewbox";
$name2 = imap_utf7_encode("phpnewb?x");

$newname = $name1;

echo "Newname will be '$name1'<br>\n";

# we will now create a new mailbox "phptestbox" in your inbox folder,
# check its status after creation and finaly remove it to restore
# your inbox to its initial state
if(@imap_createmailbox($mbox,imap_utf7_encode("{your.imap.host}INBOX.$newname"))) {
  $status = @imap_status($mbox,"{your.imap.host}INBOX.$newname",SA_ALL);
  if($status) {
    print("your new mailbox '$name1' has the following status:<br>\n");
    print("Messages:   ". $status->messages   )."<br>\n";
    print("Recent:     ". $status->recent     )."<br>\n";
    print("Unseen:     ". $status->unseen     )."<br>\n";
    print("UIDnext:    ". $status->uidnext    )."<br>\n";
    print("UIDvalidity:". $status->uidvalidity)."<br>\n";

    if(imap_renamemailbox($mbox,"{your.imap.host}INBOX.$newname","{your.imap.host}INBOX.$name2")) {
      echo "renamed new mailbox from '$name1' to '$name2'<br>\n";
      $newname=$name2;
    } else {
      print "imap_renamemailbox on new mailbox failed: ".imap_last_error()."<br>\n";
    }
  } else {
    print  "imap_status on new mailbox failed: ".imap_last_error()."<br>\n";
  }
  if(@imap_deletemailbox($mbox,"{your.imap.host}INBOX.$newname")) {
    print "new mailbox removed to restore initial state<br>\n";
  } else {
    print  "imap_deletemailbox on new mailbox failed: ".implode("<br>\n",imap_errors())."<br>\n";
  }

} else {
  print  "could not create new mailbox: ".implode("<br>\n",imap_errors())."<br>\n";
}

imap_close($mbox);

이전 | 처음으로 | 다음
imap_close | 위로 | imap_delete


imap_delete

(PHP 3, PHP 4 , PHP 5)

imap_delete -- 현재 메일 박스에서 삭제될 메시지를 표시한다

Description

int imap_delete ( int imap_stream, int msg_number [, int flags])

TRUE를 리턴한다.

imap_delete()함수는 msg_number번의 메시지를 지움 표시 한다. 선택적 인수flags는 오직 하나의 옵션만 있다. 즉, msg_number를 UID로 취급할것인지 함수에게 알려주는 FT_UID의 옵션만 있다. 지움 표시된 메시지는 imap_expunge()함수나 CL_EXPUNGE 옵션을 갖는 imap_close() 함수가 불려지기 전까지는 삭제되지 않는다.

예 1. imap_delete() Beispiel

$mbox = imap_open ("{your.imap.host}INBOX", "username", "password")
    || die ("can't connect: " . imap_last_error());

$check = imap_mailboxmsginfo ($mbox);
print "Messages before delete: " . $check->Nmsgs . "<br>\n" ;
imap_delete ($mbox, 1);
$check = imap_mailboxmsginfo ($mbox);
print "Messages after  delete: " . $check->Nmsgs . "<br>\n" ;
imap_expunge ($mbox);
$check = imap_mailboxmsginfo ($mbox);
print "Messages after expunge: " . $check->Nmsgs . "<br>\n" ;
imap_close ($mbox);

이전 | 처음으로 | 다음
imap_createmailbox | 위로 | imap_deletemailbox


imap_deletemailbox

(PHP 3, PHP 4 , PHP 5)

imap_deletemailbox -- 메일 박스를 지운다

Description

int imap_deletemailbox ( int imap_stream, string mbox)

imap_deletemailbox()함수는 특정 메일 박스를 지운다 (mbox 이름의 형식을 알려면 imap_open()함수를 보시오).

성공하면 TRUE를 실패하면 FALSE를 리턴한다.

See also imap_createmailbox(),
imap_renamemailbox(), and
imap_open() for the format of
mbox.

이전 | 처음으로 | 다음
imap_delete | 위로 | imap_errors


imap_errors

(PHP 3>= 3.0.12, PHP 4 , PHP 5)

imap_errors -- 이 함수는 현재 페이지 요구(page request)동안에, 또는 에러 스택(error stack)이 리셋(reset)된 이후에 발생한 IMAP 에러(물론 있다면)를 모두 돌려준다

Description

array imap_errors ( void )

이 함수는 가장 나중의 imap_errors()함수의 호출 이후, 또는 페이지의 시작때부터 발생한 모든 IMAP 에러 메시지들의 배열을 돌려준다. imap_errors()함수가 호출되면, 에러 스택(error stack) 은 즉시 클리어(clear)된다.

이전 | 처음으로 | 다음
imap_deletemailbox | 위로 | imap_expunge


imap_expunge

(PHP 3, PHP 4 , PHP 5)

imap_expunge -- 지움 표시된 모든 메시지를 완전히 삭제한다

Description

int imap_expunge ( int imap_stream)

imap_expunge()함수는 imap_delete(),
imap_mail_move() 또는
imap_setflag_full()함수에 의해 지움 표시된 모든
메시지를 완전히 삭제한다.

Returns TRUE.

이전 | 처음으로 | 다음
imap_errors | 위로 | imap_fetch_overview


imap_fetch_overview

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

imap_fetch_overview -- 주어진 메시지 헤더의 전체 정보를 읽어 온다

Description

array imap_fetch_overview ( int imap_stream, string sequence [, int flags])

이 함수는 주어진 sequence일련번호에 대한 헤더를 페치하고, 전체 정보를 돌려준다. sequence값은 flags가 FT_UID를 갖는다면 UID나 메시지 인덱스(indices)의 일련번호(sequence)가 된다. 돌려받는 값은 메시지 헤더의 각각을 서술하는 다음과 같은 속성을 갖는 객체의 배열이다:

  • subject - the messages subject

  • from - who sent it

  • date - when was it sent

  • message_id - Message-ID

  • references - is a reference to this message id

  • size - size in bytes

  • uid - UID the message has in the mailbox

  • msgno - message sequence number in the maibox

  • recent - this message is flagged as recent

  • flagged - this message is flagged

  • answered - this message is flagged as answered

  • deleted - this message is flagged for deletion

  • seen - this message is flagged as already read

  • draft - this message is flagged as being a draft

예 1. imap_fetch_overview() example

$mbox = imap_open("{your.imap.host:143}","username","password")
     || die("can't connect: ".imap_last_error());

$overview = imap_fetch_overview($mbox,"2,4:6",0);

if(is_array($overview)) {
        reset($overview);
        while( list($key,$val) = each($overview)) {
                print     $val->msgno
                . " - " . $val->date
                . " - " . $val->subject
                . "\n";
        }
}

imap_close($mbox);

이전 | 처음으로 | 다음
imap_expunge | 위로 | imap_fetchbody


imap_fetchbody

(PHP 3, PHP 4 , PHP 5)

imap_fetchbody -- 메시지의 본문중에서 특정 부분을 페치한다

Description

string imap_fetchbody ( int imap_stream, int msg_number, string part_number [, flags flags])

이 함수는 지정된 메시지의 본문중에서 특정 섹션을 텍스트 문자열로 페치하고, 그 텍스트 문자열을 가져온다. 섹션의 요구사양(specification)은 IMAP 4 요구사양(specification)대로 바디 부분(body part) 목록의 색인으로 구분되는 단락의 정수(integer)문자열이다. 본문 각 부분들은 이 함수에 의해 디코딩되지 않는다.

imap_fetchbody()함수에 대한 옵션은 다음 리스트의 하나 이상의 비트 마스크(bitmask)값이다:

  • FT_UID - The msg_number is a UID

  • FT_PEEK - Do not set the \Seen flag if not already set

  • FT_INTERNAL - The return string is in "internal" format, without any attempt to canonicalize CRLF.

이전 | 처음으로 | 다음
imap_fetch_overview | 위로 | imap_fetchheader


imap_fetchheader

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

imap_fetchheader -- 메시지에서 헤더를 돌려준다

Description

string imap_fetchheader ( int imap_stream, int msgno, int flags)

이 함수는 지정된 메시지에서 전체의(complete), 필터링되지않은(unfiltered) RFC822형식의 헤더를 텍스트 문자열로 페치하고, 그 텍스트 문자열을 돌려준다.

옵션은 다음과 같다:

FT_UID The msgno argument is a UID
FT_INTERNAL The return string is in "internal" format,
without any attempt to canonicalize to CRLF
newlines
FT_PREFETCHTEXT The RFC822.TEXT should be pre-fetched at the
same time. This avoids an extra RTT on an
IMAP connection if a full message text is
desired (e.g. in a "save to local file"
operation)

이전 | 처음으로 | 다음
imap_fetchbody | 위로 | imap_fetchstructure


imap_fetchstructure

(PHP 3, PHP 4 , PHP 5)

imap_fetchstructure -- 특별한 메시지의 구조체를 읽어온다

Description

object imap_fetchstructure ( int imap_stream, int msg_number [, int flags])

이 함수는 주어진 메시지의 구조화된 모든 정보를 페치한다. 선택적 인수flags는 오직 하나의 옵션만 있다. 즉, msg_number를 UID로 취급할것인지 함수에게 알려주는 FT_UID의 옵션만 있다. 리턴된 객체는 envelope, internal date, size, flags와 각 mime첨부파일과 비슷한 객체를 갖는 본문 구조체이다. 리턴되는 객체의 구조는 다음과 같다:

표 1. imap_fetchstructure()에 의해 리턴되는 객체

type | Primary body type
encoding | Body transfer encoding
ifsubtype | TRUE if there is a subtype string
subtype | MIME subtype
ifdescription | TRUE if there is a description string
description | Content description string
ifid | TRUE if there is an identification string
id | Identification string
lines | Number of lines
bytes | Number of bytes
ifdisposition | TRUE if there is a disposition string
disposition | Disposition string
ifdparameters | TRUE if the dparameters array exists
dparameters | Disposition parameter array
ifparameters | TRUE if the parameters array exists
parameters | MIME parameters array
parts | Array of objects describing each message part

  1. dparameters is an array of objects where each object has an "attribute" and a "value" property.

  2. Parameter is an array of objects where each object has an "attributte" and a "value" property.

  3. Parts is an array of objects identical in structure to the top-level object, with the limitation that it cannot contain further 'parts' objects.

표 2. Primary body type

0 | text
1 | multipart
2 | message
3 | application
4 | audio
5 | image
6 | video
7 | other

표 3. Transfer encodings

0 | 7BIT
1 | 8BIT
2 | BINARY
3 | BASE64
4 | QUOTED-PRINTABLE
5 | OTHER

이전 | 처음으로 | 다음
imap_fetchheader | 위로 | imap_get_quota


imap_get_quota

(PHP 4 >= 4.0.5, PHP 5)

imap_get_quota -- Retrieve the quota level settings, and usage statics per mailbox

Description

array imap_get_quota ( resource imap_stream, string quota_root)

Returns an array with integer values limit and usage for the given mailbox. The value of limit represents the total amount of space allowed for this mailbox. The usage value represents the mailboxes current level of capacity. Will return FALSE in the case of failure.

This function is currently only available to users of the c-client2000 or greater library.

NOTE: For this function to work, the mail stream is required to be opened as the mail-admin user. For a non-admin user version of this function, please see the imap_get_quotaroot() function of PHP.

imap_stream should be the value returned from an imap_open() call. NOTE: This stream is required to be opened as the mail admin user for the get_quota function to work. quota_root should normally be in the form of user.name where name is the mailbox you wish to retrieve information about.

예 1. imap_get_quota() example

<?php
$mbox = imap_open("{your.imap.host}", "mailadmin", "password", OP_HALFOPEN)
      or die("can't connect: " . imap_last_error());

$quota_value = imap_get_quota($mbox, "user.kalowsky");
if (is_array($quota_value)) {
    echo "Usage level is: " . $quota_value['usage'];
    echo "Limit level is: " . $quota_value['limit'];
}

imap_close($mbox);
?>

As of PHP 4.3, the function more properly reflects the functionality as dictated by the RFC 2087. The array return value has changed to support an unlimited number of returned resources (i.e. messages, or sub-folders) with each named resource receiving an individual array key. Each key value then contains an another array with the usage and limit values within it. The example below shows the updated returned output.

For backwards compatibility reasons, the originial access methods are still available for use, although it is suggested to update.

예 2. imap_get_quota() 4.3 or greater example

<?php
$mbox = imap_open("{your.imap.host}", "mailadmin", "password", OP_HALFOPEN)
      or die("can't connect: " . imap_last_error());

$quota_values = imap_get_quota($mbox, "user.kalowsky");
if (is_array($quota_values)) {
   $storage = $quota_values['STORAGE'];
   echo "STORAGE usage level is: " .  $storage['usage'];
   echo "STORAGE limit level is: " .  $storage['limit'];

   $message = $quota_values['MESSAGE'];
   echo "MESSAGE usage level is: " .  $message['usage'];
   echo "MESSAGE limit is: " .  $message['limit'];

   /* ...  */
}

imap_close($mbox);
?>

See also imap_open(),
imap_set_quota() and
imap_get_quotaroot().

이전 | 처음으로 | 다음
imap_fetchstructure | 위로 | imap_get_quotaroot


imap_get_quotaroot

(PHP 4 >= 4.3.0, PHP 5)

imap_get_quotaroot -- Retrieve the quota settings per user

Description

array imap_get_quotaroot ( resource imap_stream, string quota_root)

Returns an array of integer values pertaining to the specified user mailbox. All values contain a key based upon the resource name, and a corresponding array with the usage and limit values within.

The limit value represents the total amount of space allowed for this user's total mailbox usage. The usage value represents the user's current total mailbox capacity. This function will return FALSE in the case of call failure, and an array of information about the connection upon an un-parsable response from the server.

This function is currently only available to users of the c-client2000 or greater library.

imap_stream should be the value returned from an imap_open() call. This stream should be opened as the user whose mailbox you wish to check. quota_root should normally be in the form of which mailbox (i.e. INBOX).

예 1. imap_get_quotaroot() example

<?php
$mbox = imap_open("{your.imap.host}", "kalowsky", "password", OP_HALFOPEN)
      or die("can't connect: " . imap_last_error());

$quota = imap_get_quotaroot($mbox, "INBOX");
if (is_array($quota)) {
   $storage = $quota_values['STORAGE'];
   echo "STORAGE usage level is: " .  $storage['usage'];
   echo "STORAGE limit level is: " .  $storage['limit'];

   $message = $quota_values['MESSAGE'];
   echo "MESSAGE usage level is: " .  $message['usage'];
   echo "MESSAGE usage level is: " .  $message['limit'];

   /* ...  */

}

imap_close($mbox);
?>

See also imap_open(),
imap_set_quota() and
imap_get_quota().

이전 | 처음으로 | 다음
imap_get_quota | 위로 | imap_getacl


imap_getacl

(PHP 5)

imap_getacl -- Gets the ACL for a given mailbox

Description

array imap_getacl ( resource stream_id, string mailbox)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also: imap_setacl().

이전 | 처음으로 | 다음
imap_get_quotaroot | 위로 | imap_getmailboxes


imap_getmailboxes

(PHP 3>= 3.0.12, PHP 4 , PHP 5)

imap_getmailboxes -- 메일박스의 목록을 읽어오고, 각 메일박스에 대한 상세한 정보를 돌려준다.

Description

array imap_getmailboxes ( int imap_stream, string ref, string pattern)

메일박스 정보를 포함하는 객체의 배열을 돌려준다. 각 객체는 다음 속성을 갖는다. 메일박스의 완전한 이름을 갖는 name속성; 메일 박스안에 포함된 분류체계(hierarchy)의 부분을 위한 분류체계 한정자(hirerarchy delimiter) delimiter속성; 그리고 attributes. Attributes 속성은 다음에 대해서 테스트될 수 있는 비트마스크(bitmask)값이다:

  • LATT_NOINFERIORS - This mailbox has no "children" (there are no mailboxes below this one).

  • LATT_NOSELECT - This is only a container, not a mailbox - you cannot open it.

  • LATT_MARKED - This mailbox is marked. Only used by UW-IMAPD.

  • LATT_UNMARKED - This mailbox is not marked. Only used by UW-IMAPD.

메일 박스 이름이 출력가능한 아스키(ASCII)코드 범위 밖의 국제적인 문자를 포함한다면 인코딩해야 할것이고, imap_utf7_decode()함수로 디코딩해야 할것이다.

ref인수는 imap_open()함수 에서와 같이 서버의 사양이면 된다.그리고 pattern 인수는 검색을 시작할 메일 박스의 위치이다. 모든 메일 박스에 적용시키려면 pattern인수에 '*'라고 하면 된다.

pattern인수로 쓸 수 있는 두개의 특별한 문자들이 있다 : '*' 과 '%'문자이다. '*'은 모든 메일박스를 돌려줌을 의미한다. pattern인수에 '*'를 쓰면 모든 메일 박스 체계(hierarchy) 의 목록을 얻을 수 있다. '%'는 현재 레벨만을 돌려준다는 걸 의미한다. pattern인수에 '%'를 쓰면 최상위 레벨의 메일박스 만을 돌려줄 것이다; UW_IMAPD에 관해 '~/mail/%'을 쓰면 ~/mail 디렉토리의 모든 메일 박스를 돌려주지만, 하위디렉토리는 포함되지 않는다.

예 1. imap_getmailboxes() example

$mbox = imap_open("{your.imap.host}","username","password",OP_HALFOPEN)
      || die("can't connect: ".imap_last_error());

$list = imap_getmailboxes($mbox,"{your.imap.host}","*");
if(is_array($list)) {
  reset($list);
  while (list($key, $val) = each($list))
  {
    print "($key) ";
    print imap_utf7_decode($val->name).",";
    print "'".$val->delimiter."',";
    print $val->attributes."<br>\n";
  }
} else
  print "imap_getmailboxes failed: ".imap_last_error()."\n";

imap_close($mbox);

See also imap_getsubscribed().

이전 | 처음으로 | 다음
imap_getacl | 위로 | imap_getsubscribed


imap_getsubscribed

(PHP 3>= 3.0.12, PHP 4 , PHP 5)

imap_getsubscribed -- subscribed된 모든 메일 박스의 목록을 보여준다.

Description

array imap_getsubscribed ( int imap_stream, string ref, string pattern)

imap_getmailboxes()함수와 동일하다. 단 유저가 subscribed한 메일박스만 돌려줄 뿐이다.

이전 | 처음으로 | 다음
imap_getmailboxes | 위로 | imap_header


imap_header

(PHP 3, PHP 4 , PHP 5)

imap_header -- Read the header of the message

Description

object imap_header ( int imap_stream, int msg_number [, int fromlength [, int subjectlength [, string defaulthost]]])

This is an alias to imap_headerinfo() and is identical to this in any way.

이전 | 처음으로 | 다음
imap_getsubscribed | 위로 | imap_headerinfo


imap_headerinfo

(PHP 3, PHP 4 , PHP 5)

imap_headerinfo -- 메시지의 머릿글을 읽어온다

Description

object imap_headerinfo ( int imap_stream, int msg_number [, int fromlength [, int subjectlength [, string defaulthost]]])

이 함수는 다양한 머릿글 구성요소의 객체를 가져온다.

remail, date, Date, subject, Subject, in_reply_to, message_id,
newsgroups, followup_to, references

message flags:
Recent - 'R' if recent and seen,
'N' if recent and not seen,
' ' if not recent
Unseen - 'U' if not seen AND not recent,
' ' if seen OR not seen and recent
Answered -'A' if answered,
' ' if unanswered
Deleted - 'D' if deleted,
' ' if not deleted
Draft - 'X' if draft,
' ' if not draft
Flagged - 'F' if flagged,
' ' if not flagged

NOTE that the Recent/Unseen behavior is a little odd. If you want to
know if a message is Unseen, you must check for

Unseen == 'U' || Recent == 'N'

toaddress (full to: line, up to 1024 characters)

to[] (returns an array of objects from the To line, containing):
personal
adl
mailbox
host

fromaddress (full from: line, up to 1024 characters)

from[] (returns an array of objects from the From line, containing):
personal
adl
mailbox
host

ccaddress (full cc: line, up to 1024 characters)
cc[] (returns an array of objects from the Cc line, containing):
personal
adl
mailbox
host

bccaddress (full bcc line, up to 1024 characters)
bcc[] (returns an array of objects from the Bcc line, containing):
personal
adl
mailbox
host

reply_toaddress (full reply_to: line, up to 1024 characters)
reply_to[] (returns an array of objects from the Reply_to line,
containing):
personal
adl
mailbox
host

senderaddress (full sender: line, up to 1024 characters)
sender[] (returns an array of objects from the sender line, containing):
personal
adl
mailbox
host

return_path (full return-path: line, up to 1024 characters)
return_path[] (returns an array of objects from the return_path line,
containing):
personal
adl
mailbox
host

udate (mail message date in unix time)

fetchfrom (from line formatted to fit fromlength
characters)

fetchsubject (subject line formatted to fit subjectlength characters)

이전 | 처음으로 | 다음
imap_header | 위로 | imap_headers


imap_headers

(PHP 3, PHP 4 , PHP 5)

imap_headers -- 메일박스에서 모든 메시지의 헤더를 돌려준다

Description

array imap_headers ( int imap_stream)

Returns an array of string formatted with header info. One element per mail message. 헤더 정보를 갖는 형식화된 문자열의 배열을 돌려준다. 각 메일 메시지당 하나의 배열요소를 갖는다.

이전 | 처음으로 | 다음
imap_headerinfo | 위로 | imap_last_error


imap_last_error

(PHP 3>= 3.0.12, PHP 4 , PHP 5)

imap_last_error -- 이 함수는 현재 페이지 요구(page request) 동안에 발생한 IMAP 에러(물론 있다면)의 가장 나중것을 돌려준다

Description

string imap_last_error ( void )

이 함수는 현재 페이지에서 발생한 가장 나중의 IMAP 에러 메시지를 텍스트로 돌려준다; 에러 스택(error stack)은 건들지 않는다; 아무 에러도 없는데, imap_last_error()함수를 이어서 부르면 같은 에러를 돌려줄것이다.

이전 | 처음으로 | 다음
imap_headers | 위로 | imap_list


imap_list

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

imap_list -- Read the list of mailboxes

Description

array imap_list ( resource imap_stream, string ref, string pattern)

Returns an array containing the names of the mailboxes. See imap_getmailboxes() for a description of ref and pattern.

예 1. imap_list() example

<?php
$mbox = imap_open("{your.imap.host}", "username", "password", OP_HALFOPEN)
      or die("can't connect: " . imap_last_error());

$list = imap_list($mbox, "{your.imap.host}", "*");
if (is_array($list)) {
  reset($list);
  while (list($key, $val) = each($list)) {
    echo imap_utf7_decode($val) . "<br />\n";
  }
} else {
  echo "imap_list failed: " . imap_last_error() . "\n";
}

imap_close($mbox);
?>

See also: imap_getmailboxes().

이전 | 처음으로 | 다음
imap_last_error | 위로 | imap_listmailbox


imap_listmailbox

(PHP 3, PHP 4 , PHP 5)

imap_listmailbox -- 메일박스의 목록을 읽어온다

Description

array imap_listmailbox ( int imap_stream, string ref, string pattern)

Returns an array containing the names of the mailboxes. See imap_getmailboxes() for a description of ref and pattern. 메일박스의 이름을 포함한 배열을 돌려준다. 더 자세한 것은 ref과 pattern의 imap_getmailboxes()를 보라

예 1. imap_listmailbox() example

$mbox = imap_open("{your.imap.host}","username","password",OP_HALFOPEN)
      || die("can't connect: ".imap_last_error());

$list = imap_listmailbox($mbox,"{your.imap.host}","*");
if(is_array($list)) {
  reset($list);
  while (list($key, $val) = each($list))
    print imap_utf7_decode($val)."<br>\n";
} else
  print "imap_listmailbox failed: ".imap_last_error()."\n";

imap_close($mbox);

이전 | 처음으로 | 다음
imap_list | 위로 | imap_listscan


imap_listscan

(no version information, might be only in CVS)

imap_listscan -- Read the list of mailboxes, takes a string to search for in the text of the mailbox

Description

array imap_listscan ( resource imap_stream, string ref, string pattern, string content)

Returns an array containing the names of the mailboxes that have content in the text of the mailbox.

This function is similar to imap_listmailbox(), but it will additionally check for the presence of the string content inside the mailbox data.

See imap_getmailboxes() for a description of ref and pattern.

이전 | 처음으로 | 다음
imap_listmailbox | 위로 | imap_listsubscribed


imap_listsubscribed

(PHP 3, PHP 4 , PHP 5)

imap_listsubscribed -- subscribed된 모든 메일박스의 목록을 보여준다

Description

array imap_listsubscribed ( int imap_stream, string ref, string pattern)

subscribed된 모든 메일박스의 배열을 돌려준다. 이함수는 거의 imap_listmailbox()함수와 동일하다. 단지 로그인 한 유저가 subscribed한 메일박스만 돌려줄 뿐이다.

이전 | 처음으로 | 다음
imap_listscan | 위로 | imap_lsub


imap_lsub

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

imap_lsub -- List all the subscribed mailboxes

Description

array imap_lsub ( resource imap_stream, string ref, string pattern)

Returns an array of all the mailboxes that you have subscribed.

이전 | 처음으로 | 다음
imap_listsubscribed | 위로 | imap_mail_compose


imap_mail_compose

(PHP 3>= 3.0.5, PHP 4 , PHP 5)

imap_mail_compose -- 주어진 envelope와 body 섹션으로 구성된 MIME메시지를 만든다

Description

string imap_mail_compose ( array envelope, array body)

예 1. imap_mail_compose() example

<?php

$envelope["from"]="musone@afterfive.com";
$envelope["to"]="musone@darkstar";
$envelope["cc"]="musone@edgeglobal.com";

$part1["type"]=TYPEMULTIPART;
$part1["subtype"]="mixed";

$filename="/tmp/imap.c.gz";
$fp=fopen($filename,"r");
$contents=fread($fp,filesize($filename));
fclose($fp);

$part2["type"]=TYPEAPPLICATION;
$part2["encoding"]=ENCBINARY;
$part2["subtype"]="octet-stream";
$part2["description"]=basename($filename);
$part2["contents.data"]=$contents;

$part3["type"]=TYPETEXT;
$part3["subtype"]="plain";
$part3["description"]="description3";
$part3["contents.data"]="contents.data3\n\n\n\t";

$body[1]=$part1;
$body[2]=$part2;
$body[3]=$part3;

echo nl2br(imap_mail_compose($envelope,$body));

?>

이전 | 처음으로 | 다음
imap_lsub | 위로 | imap_mail_copy


imap_mail_copy

(PHP 3, PHP 4 , PHP 5)

imap_mail_copy -- 메일박스에 특정 메시지를 복사한다

Description

int imap_mail_copy ( int imap_stream, string msglist, string mbox [, int flags])

성공하면 TRUE를 에러가 발생하면 FALSE를 돌려준다.

msglist인수에 의해 지정된 메일 메시지를 특정 메일 박스에 복사한다.msglist인수는 메시지 번호만이 아니라 범위도 된다 (RFC2060문서에 기술 되어있다).

Flags인수는 다음 옵션들의 비트 마스트(bitmask)값이다.

  • CP_UID - the sequence numbers contain UIDS

  • CP_MOVE - Delete the messages from the current mailbox after copying

이전 | 처음으로 | 다음
imap_mail_compose | 위로 | imap_mail_move


imap_mail_move

(PHP 3, PHP 4 , PHP 5)

imap_mail_move -- 메일박스에 특정 메시지를 이동시킨다

Description

int imap_mail_move ( int imap_stream, string msglist, string mbox [, int flags])

msglist인수에 의해 지정된 메일 메시지를 특정 메일 박스에 이동시킨다.msglist인수는 메시지 번호만이 아니라 범위도 된다 (RFC2060문서에 기술 되어있다).

Flags인수는 비트마스크(bitmask)값이고 오직 하나의 옵션만을 갖는다

  • CP_UID - the sequence numbers contain UIDS

성공하면 TRUE를 에러가 발생하면 FALSE를 리턴한다.

이전 | 처음으로 | 다음
imap_mail_copy | 위로 | imap_mail


imap_mail

(PHP 3>= 3.0.14, PHP 4 , PHP 5)

imap_mail -- 이메일 메시지를 보낸다

Description

string imap_mail ( string to, string subject, string message [, string additional_headers [, string cc [, string bcc [, string rpath]]]])

이 함수는 현재 PHP 3에서만 유효하다.

이전 | 처음으로 | 다음
imap_mail_move | 위로 | imap_mailboxmsginfo


imap_mailboxmsginfo

(PHP 3>= 3.0.2, PHP 4 , PHP 5)

imap_mailboxmsginfo -- 현재 메일박스에 관한 정보를 가져온다

Description

object imap_mailboxmsginfo ( int imap_stream)

현재 메일박스에 관한 정보를 돌려준다. 실패하면 FALSE를 리턴한다.

imap_mailboxmsginfo()함수는 서버에서 현재 메일박스의 상태를 점검한다. 이 함수는 imap_status()함수와 유사하다. 단지 메일박스안의 모든 메시지 사이즈의 총량을 내는 것이 추가되었다. 이것은 곧 총량을 내기위해 실행할 추가적인 시간이 걸린다는 것을 의미한다. 다음 속성을 갖는 객체로 정보를 돌려준다.

표 1. Mailbox properties

Date | date of last change
Driver | driver
Mailbox | name of the mailbox
Nmsgs | number of messages
Recent | number of recent messages
Unread | number of unread messages
Deleted | number of deleted messages
Size | mailbox size

예 1. imap_mailboxmsginfo() example

<?php

$mbox = imap_open("{your.imap.host}INBOX","username", "password")
      || die("can't connect: ".imap_last_error());

$check = imap_mailboxmsginfo($mbox);

if($check) {
    print "Date: "    . $check->Date    ."<br>\n" ;
    print "Driver: "  . $check->Driver  ."<br>\n" ;
    print "Mailbox: " . $check->Mailbox ."<br>\n" ;
    print "Messages: ". $check->Nmsgs   ."<br>\n" ;
    print "Recent: "  . $check->Recent  ."<br>\n" ;
    print "Unread: "  . $check->Unread  ."<br>\n" ;
    print "Deleted: " . $check->Deleted ."<br>\n" ;
    print "Size: "    . $check->Size    ."<br>\n" ;
} else {
    print "imap_check() failed: ".imap_last_error(). "<br>\n";
}

imap_close($mbox);

?>

이전 | 처음으로 | 다음
imap_mail | 위로 | imap_mime_header_decode


imap_mime_header_decode

(PHP 3>= 3.0.17, PHP 4 , PHP 5)

imap_mime_header_decode -- MIME 헤더 구성요소(element)를 디코딩한다

Description

array imap_header_decode ( string text)

imap_mime_header_decode()함수는 ASCII 텍스트가 아닌 MIME 메시지 헤더 확장(MIME message header extensions)을 디코드한다. (RFC2047문서를 보라) 디코딩된 구성요소(elements)를 객체의 배열로 돌려준다. 이 객체는 두가지 속성을 갖는다, 즉 "charset" 과 "text" 이다. 구성요소가 인코딩되지 않았다면, 즉 평범한(plain) US-ASCII라면, 그 구성요소의 "charset" 속성은 "default"값을 갖는다.

예 1. imap_mime_header_decode() example

$text="=?ISO-8859-1?Q?Keld_J=F8rn_Simonsen?= <keld@dkuug.dk>";

$elements=imap_mime_header_decode($text);
for($i=0;$i<count($elements);$i++) {
    echo "Charset: {$elements[$i]->charset}\n";
    echo "Text: {$elements[$i]->text}\n\n";
}

In the above example we would have two elements, whereas the first element had previously been encoded with ISO-8859-1, and the second element would be plain US-ASCII.

이전 | 처음으로 | 다음
imap_mailboxmsginfo | 위로 | imap_msgno


imap_msgno

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

imap_msgno -- 이 함수는 주어진 UID값에 대해 메시지 일련번호(sequence number)을 넘겨준다

Description

int imap_msgno ( int imap_stream, int uid)

이 함수는 주어진 UID값에 대해 메시지 일련번호(sequence number)을 넘겨준다 imap_uid()함수의 반대이다.

이전 | 처음으로 | 다음
imap_mime_header_decode | 위로 | imap_num_msg


imap_num_msg

(PHP 3, PHP 4 , PHP 5)

imap_num_msg -- 현재 메일박스의 메시지 갯수를 돌려준다

Description

int imap_num_msg ( int imap_stream)

현재 메일박스의 메시지 갯수를 돌려준다.

이전 | 처음으로 | 다음
imap_msgno | 위로 | imap_num_recent


imap_num_recent

(PHP 3, PHP 4 , PHP 5)

imap_num_recent -- 현재 메일박스의 새로운 메시지 갯수를 돌려준다

Description

int imap_num_recent ( int imap_stream)

현재 메일박스의 새로운 메시지 갯수를 돌려준다.

이전 | 처음으로 | 다음
imap_num_msg | 위로 | imap_open


imap_open

(PHP 3, PHP 4 , PHP 5)

imap_open -- 메일박스에 IMAP 스트림(stream)을 연다

Description

int imap_open ( string mailbox, string username, string password [, int flags])

성공하면 IMAP 스트림(stream)을 돌려주고 에러가 발생하면 FALSE를 넘겨준다. 이 함수는 POP3나 NNTP서버의 스트림(stream)을 열 때에도 사용된다. 하지만 어떤 함수나 특성은 IMAP 서버에 적용되지 않는다.

메일박스의 이름은 서버와 관련한 서버 부분과 메일박스 경로로 구성된다. 특별한 이름을 갖는 INBOX는 현재 유저의 개인 메일박스이다. 서버 부분은 '{'과 '}'로 둘려싸여지고, 서버의 이름이나 ip 주소, 프로토콜 사양('/'로 시작하는곳) 그리고 ':'로 시작하는 선택적인 포트로 구성된다. 서버 부분은 모든 메일박스의 필수 인수이다. 메일박스 이름이 출력가능한 아스키(ASCII)범위를 벗어난 국제적인 문자를 포함하면 imap_utf7_encode()함수로 인코딩되어야 한다.

옵션은 다음을 한개이상 포함하는 비트마스크(bit mask)값이다.

  • OP_READONLY - Open mailbox read-only

  • OP_ANONYMOUS - Dont use or update a .newsrc for news (NNTP only)

  • OP_HALFOPEN - For IMAP and NNTP names, open a connection but dont open a mailbox

  • CL_EXPUNGE - Expunge mailbox automatically upon mailbox close

로컬 머신의 143포트에서 서비스되고 있는 IMAP서버에 접속하려면, 다음과 같이 하시오:

$mbox = imap_open ("{localhost:143}INBOX", "user_id", "password");

로컬 머신의 110포트에서 서비스되고 있는 POP3서버에 접속하려면, 다음과 같이 하시오:

$mbox = imap_open ("{localhost/pop3:110}INBOX", "user_id", "password");

로컬 머신의 119포트에서 서비스되고 있는 NNTP서버에 접속하려면, 다음과 같이 하시오:

$nntp = imap_open ("{localhost/nntp:119}comp.test", "", "");

원격 서버에 접속하려면 "localhost"대신에 접속할 원격의서버의 서버이름 또는 아이피 주소를 쓰시오.

예 1. imap_open() example

$mbox = imap_open ("{your.imap.host:143}", "username", "password");

echo "<p><h1>Mailboxes</h1>\n";
$folders = imap_listmailbox ($mbox, "{your.imap.host:143}", "*");

if ($folders == false) {
    echo "Call failed<br>\n";
} else {
    while (list ($key, $val) = each ($folders)) {
        echo $val."<br>\n";
    }
}

echo "<p><h1>Headers in INBOX</h1>\n";
$headers = imap_headers ($mbox);

if ($headers == false) {
    echo "Call failed<br>\n";
} else {
    while (list ($key,$val) = each ($headers)) {
        echo $val."<br>\n";
    }
}

imap_close($mbox);

이전 | 처음으로 | 다음
imap_num_recent | 위로 | imap_ping


imap_ping

(PHP 3, PHP 4 , PHP 5)

imap_ping -- IMAP 스트림(stream)이 아직 사용가능한지 체크한다

Description

int imap_ping ( int imap_stream)

Returns TRUE if the stream is still alive, FALSE otherwise. 스트림(stream)이 아직 살아있다면 TRUE를 리턴하고, 그외에는 FALSE를 리턴한다

imap_ping()함수는 스트림(stream)이 아직 사용가능한지 보기 위해 스트림에 핑(ping)을 한다. 이 함수는 새로운 메일을 발견한다; 이 함수는 주기적인 "새로운 메일 점검"은 물론 타임아웃(timeout)을 갖는 서버에게 "접속 유지"를 위한 방법으로 선호된다. ( PHP 스크립트는 오랜 시간동안 실행되지 않기 때문에, 나는 이 함수가 거의 유용하지 않을 것이라고 생각한다. )

이전 | 처음으로 | 다음
imap_open | 위로 | imap_qprint


imap_qprint

(PHP 3, PHP 4 , PHP 5)

imap_qprint -- quoted-printable 문자열을 8비트 문자열로 변환한다

Description

string imap_qprint ( string string)

quoted-printable 문자열을 8비트 문자열로 변환한다 . (RFC2045, section 6.7에 따라)

8비트(binary) 문자열을 돌려준다.

imap_8bit()함수도 보시오.

이전 | 처음으로 | 다음
imap_ping | 위로 | imap_renamemailbox


imap_renamemailbox

(PHP 3, PHP 4 , PHP 5)

imap_renamemailbox -- 메일박스의 이름을 바꾼다

Description

int imap_renamemailbox ( int imap_stream, string old_mbox, string new_mbox)

이 함수는 메일박스의 이름을 바꾼다(mbox이름의 형식은 imap_open()함수를 보면 알수 있다)

성공하면 TRUE를 리턴하고 에러가 발생하면 FALSE를 리턴한다.

mbox형식에 대해서는 또한
imap_createmailbox()함수,
imap_deletemailbox()함수, 그리고
imap_open()함수를 보시오.

이전 | 처음으로 | 다음
imap_qprint | 위로 | imap_reopen


imap_reopen

(PHP 3, PHP 4 , PHP 5)

imap_reopen -- 새로운 메일박스에 IMAP 스트림(stream)을 다시 연다

Description

int imap_reopen ( int imap_stream, string mailbox [, string flags])

이 함수는 IMAP 또는 NNTP 서버에서 새로운 메일박스에 특정 스트림(stream)을 다시 연다.

옵션은 다음의 한개 이상의 비트마스트(bit mask)값이다:

  • OP_READONLY - Open mailbox read-only

  • OP_ANONYMOUS - Dont use or update a .newsrc for news (NNTP only)

  • OP_HALFOPEN - For IMAP and NNTP names, open a connection but dont open a mailbox.

  • CL_EXPUNGE - Expunge mailbox automatically upon mailbox close (see also imap_delete() and imap_expunge())

성공하면 TRUE를 리턴하고 에러가 발생하면 FALSE를 리턴한다.

이전 | 처음으로 | 다음
imap_renamemailbox | 위로 | imap_rfc822_parse_adrlist


imap_rfc822_parse_adrlist

(PHP 3>= 3.0.2, PHP 4 , PHP 5)

imap_rfc822_parse_adrlist -- 주소 문자열을 해석한다

Description

array imap_rfc822_parse_adrlist ( string address, string default_host)

이 함수는 RFC822문서에 정의된대로 각 주소에 대해 주소 문자열을 해석하고 객체의 문자열을 돌려준다. 객체의 속성은 다음과 같다:

  • mailbox - the mailbox name (username)

  • host - the host name

  • personal - the personal name

  • adl - at domain source route

예 1. imap_rfc822_parse_adrlist() example

$address_string = "Hartmut Holzgraefe <hartmut@cvs.php.net>, postmaster@somedomain.net, root";
$address_array  = imap_rfc822_parse_adrlist($address_string,"somedomain.net");
if(! is_array($address_array)) die("somethings wrong\n");

reset($address_array);
while(list($key,$val)=each($address_array)){
  print "mailbox : ".$val->mailbox."<br>\n";
  print "host    : ".$val->host."<br>\n";
  print "personal: ".$val->personal."<br>\n";
  print "adl     : ".$val->adl."<p>\n";
}

이전 | 처음으로 | 다음
imap_reopen | 위로 | imap_rfc822_parse_headers


imap_rfc822_parse_headers

(PHP 4 , PHP 5)

imap_rfc822_parse_headers -- 문자열에서 메일 헤더를 해석한다

Description

object imap_rfc822_parse_headers ( string headers [, string defaulthost])

이함수는 다양한 헤더 구성요소의 객체를 돌려준다. imap_header()함수와 비슷하지만, flags 인수를 갖지 않는 것이 다르다.

이전 | 처음으로 | 다음
imap_rfc822_parse_adrlist | 위로 | imap_rfc822_write_address


imap_rfc822_write_address

(PHP 3>= 3.0.2, PHP 4 , PHP 5)

imap_rfc822_write_address -- 주어진 메일박스, 호스트, 개인 정보로 적절히 형식화된 이메일 주소를 돌려준다

Description

string imap_rfc822_write_address ( string mailbox, string host, string personal)

RFC822문서에 정의된대로 주어진 메일박스, 호스트, 개인 정보로 적절하게 형식화된 이메일 주소를 돌려준다.

예 1. imap_rfc822_write_address() example

print imap_rfc822_write_address("hartmut","cvs.php.net","Hartmut Holzgraefe")."\n";

이전 | 처음으로 | 다음
imap_rfc822_parse_headers | 위로 | imap_scanmailbox


imap_scanmailbox

(PHP 3, PHP 4 , PHP 5)

imap_scanmailbox -- 메일박스의 텍스트중에서 검색 문자열을 갖는 메일박스의 목록을 읽어 온다

Description

array imap_scanmailbox ( int imap_stream, string ref, string pattern, string content)

메일박스의 텍스트중에서 string의 문자열을 갖는 메일박스 이름을 포함하는 배열을 돌려준다. 이함수는 imap_listmailbox()함수와 유사하다, 단지 메일박스 데이터중에서 content문자열의 존재를 체크하는 것만 추가되었다.

이전 | 처음으로 | 다음
imap_rfc822_write_address | 위로 | imap_search


imap_search

(PHP 3>= 3.0.12, PHP 4 , PHP 5)

imap_search -- 이 함수는 주어진 검색 기준(criteria)에 부합되는 메시지의 배열을 돌려준다

Description

array imap_search ( int imap_stream, string criteria, int flags)

이 함수는 주어진 imap 스트림(stream)안의 현재 열려있는 메일박스에서 검색을 수행한다. criteria인수는 문자열이다. 공백(spaces)에 의해 구별(delimited)되고,아래의 키워드(keywords)가 허용된다. 두 단어 이상의 변수(arguments) (예를 들면, FROM "joey smith" )는 따옴표(quoted) 처리해야 한다.

  • ALL - return all messages matching the rest of the criteria

  • ANSWERED - match messages with the \\ANSWERED flag set

  • BCC "string" - match messages with "string" in the Bcc: field

  • BEFORE "date" - match messages with Date: before "date"

  • BODY "string" - match messages with "string" in the body of the message

  • CC "string" - match messages with "string" in the Cc: field

  • DELETED - match deleted messages

  • FLAGGED - match messages with the \\FLAGGED (sometimes referred to as Important or Urgent) flag set

  • FROM "string" - match messages with "string" in the From: field

  • KEYWORD "string" - match messages with "string" as a keyword

  • NEW - match new messages

  • OLD - match old messages

  • ON "date" - match messages with Date: matching "date"

  • RECENT - match messages with the \\RECENT flag set

  • SEEN - match messages that have been read (the \\SEEN flag is set)

  • SINCE "date" - match messages with Date: after "date"

  • SUBJECT "string" - match messages with "string" in the Subject:

  • TEXT "string" - match messages with text "string"

  • TO "string" - match messages with "string" in the To:

  • UNANSWERED - match messages that have not been answered

  • UNDELETED - match messages that are not deleted

  • UNFLAGGED - match messages that are not flagged

  • UNKEYWORD "string" - match messages that do not have the keyword "string"

  • UNSEEN - match messages which have not been read yet

예를 들어 Mom으로 부터 받은 아직 읽지 않은 모든 메시지를 검색하려면, 다음과 같이 하면 된다: "UNANSWERED FROM mom". 검색은 대소문자 구별을 하지 않는 것처럼 보인다. 검색기준의 목록은 UW c-client source code에 달려있어서 불완전하거나 부정확할 수 있다. (RFC2060, section 6.4.4 도 보시라).

플래그(flags)에 대한 유효한 값은 SE_UID이다. 이것은 메시지 일련번호(sequence number)대신에 UID를 포함하는 배열을 돌려준다.

이전 | 처음으로 | 다음
imap_scanmailbox | 위로 | imap_set_quota


imap_set_quota

(PHP 4 >= 4.0.5, PHP 5)

imap_set_quota -- Sets a quota for a given mailbox

Description

bool imap_set_quota ( resource imap_stream, string quota_root, int quota_limit)

Sets an upper limit quota on a per mailbox basis. This function requires the imap_stream to have been opened as the mail administrator account. It will not work if opened as any other user.

This function is currently only available to users of the c-client2000 or greater library.

imap_stream is the stream pointer returned from a imap_open() call. This stream must be opened as the mail administrator, other wise this function will fail. quota_root is the mailbox to have a quota set. This should follow the IMAP standard format for a mailbox, 'user.name'. quota_limit is the maximum size (in KB) for the quota_root.

Returns TRUE on success and FALSE on error.

예 1. imap_set_quota() example

<?php
$mbox = imap_open("{your.imap.host:143}", "mailadmin", "password");

if (!imap_set_quota($mbox, "user.kalowsky", 3000)) {
    echo "Error in setting quota\n";
    return;
}

imap_close($mbox);
?>

See also imap_open() and imap_set_quota().

이전 | 처음으로 | 다음
imap_search | 위로 | imap_setacl


imap_setacl

(PHP 4 >= 4.1.0, PHP 5)

imap_setacl -- Sets the ACL for a giving mailbox

Description

bool imap_setacl ( resource stream_id, string mailbox, string id, string rights)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also: imap_getacl().

이전 | 처음으로 | 다음
imap_set_quota | 위로 | imap_setflag_full


imap_setflag_full

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

imap_setflag_full -- 메시지에서 플래그(flags)를 셋(set)한다

Description

string imap_setflag_full ( int stream, string sequence, string flag, string options)

이 함수는 지정된 일련번호의 메시지에서 지정된 플래그(flag)에 플래그 셋(flags set)을 추가한다.

셋(set)할 수 있는 플래그(flags)는 "\\Seen", "\\Answered", "\\Flagged", "\\Deleted", "\\Draft", 과 "\\Recent"이다. (RFC2060 문서에 정의된대로)

옵션은 다음에서 한개 이상의 비트마스트(bit mask)값이다:

ST_UID The sequence argument contains UIDs instead of
sequence numbers

예 1. imap_setflag_full() example

$mbox = imap_open("{your.imap.host:143}","username","password")
     || die("can't connect: ".imap_last_error());

$status = imap_setflag_full($mbox,"2,5","\\Seen \\Flagged");

print gettype($status)."\n";
print $status."\n";

imap_close($mbox);

이전 | 처음으로 | 다음
imap_setacl | 위로 | imap_sort


imap_sort

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

imap_sort -- 메시지 헤더의 배열을 정렬한다

Description

array imap_sort ( int stream, int criteria, int reverse, int options)

주어진 인수로 정렬된 메시지 번호의 배열을 돌려준다.

Reverse인수는 역정렬(reverse-sorting)하기 위해서는 1의 값을 갖는다.

기준(Criteria)은 다음중 하나(오직 하나)가 될 수 있다:

SORTDATE message Date
SORTARRIVAL arrival date
SORTFROM mailbox in first From address
SORTSUBJECT message Subject
SORTTO mailbox in first To address
SORTCC mailbox in first cc address
SORTSIZE size of message in octets

플래그(flags)는 다음중 하나이상의 비트마스크(bitmask)값이다:

SE_UID Return UIDs instead of sequence numbers
SE_NOPREFETCH Don't prefetch searched messages.

이전 | 처음으로 | 다음
imap_setflag_full | 위로 | imap_status


imap_status

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

imap_status -- 이 함수는 현재 메일박스 이외의 다른 메일 박스의 상태 정보를 돌려준다

Description

object imap_status ( int imap_stream, string mailbox, int options)

이 함수는 상태 정보를 포함하는 객체를 돌려준다. 유효한 플래그(flags)는 다음과 같다:

  • SA_MESSAGES - set status->messages to the number of messages in the mailbox

  • SA_RECENT - set status->recent to the number of recent messages in the mailbox

  • SA_UNSEEN - set status->unseen to the number of unseen (new) messages in the mailbox

  • SA_UIDNEXT - set status->uidnext to the next uid to be used in the mailbox

  • SA_UIDVALIDITY - set status->uidvalidity to a constant that changes when uids for the mailbox may no longer be valid

  • SA_ALL - set all of the above

status->flags is also set, which contains a bitmask which can be checked against any of the above constants.

예 1. imap_status() example

$mbox = imap_open("{your.imap.host}","username","password",OP_HALFOPEN)
      || die("can't connect: ".imap_last_error());

$status = imap_status($mbox,"{your.imap.host}INBOX",SA_ALL);
if($status) {
  print("Messages:   ". $status->messages   )."<br>\n";
  print("Recent:     ". $status->recent     )."<br>\n";
  print("Unseen:     ". $status->unseen     )."<br>\n";
  print("UIDnext:    ". $status->uidnext    )."<br>\n";
  print("UIDvalidity:". $status->uidvalidity)."<br>\n";
} else
  print "imap_status failed: ".imap_lasterror()."\n";

imap_close($mbox);

이전 | 처음으로 | 다음
imap_sort | 위로 | imap_subscribe


imap_subscribe

(PHP 3, PHP 4 , PHP 5)

imap_subscribe -- 메일 박스에 Subscribe한다

Description

int imap_subscribe ( int imap_stream, string mbox)

새로운 메일박스를 Subscribe한다.

성공하면 TRUE를 리턴하고 에러가 발생하면 FALSE를 리턴한다.

이전 | 처음으로 | 다음
imap_status | 위로 | imap_thread


imap_thread

(PHP 4 >= 4.1.0, PHP 5)

imap_thread -- Return threaded by REFERENCES tree

Description

array imap_thread ( resource stream_id [, int options])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
imap_subscribe | 위로 | imap_timeout


imap_timeout

(PHP 4 >= 4.3.3, PHP 5)

imap_timeout -- Set or fetch imap timeout

Description

mixed imap_timeout ( int timeout_type [, int timeout])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
imap_thread | 위로 | imap_uid


imap_uid

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

imap_uid -- 이 함수는 주어진 메시지의 일련번호(sequence number)에 대한 UID를 돌려준다

Description

int imap_uid ( int imap_stream, int msgno)

이 함수는 주어진 메시지 일련번호(sequence number)에 대한 UID를 돌려준다. UID는 메일박스의 내용이 변화될 때마다 바뀌는 메시지 일련번호에 반하여 시간에 따라 바뀌지 않는 유일한 구별값(identifier)이다. 이 함수는 imap_msgno()함수의 반대이다.

이전 | 처음으로 | 다음
imap_timeout | 위로 | imap_undelete


imap_undelete

(PHP 3, PHP 4 , PHP 5)

imap_undelete -- 지움 표시된 메시지의 지움 표시를 제거한다

Description

int imap_undelete ( int imap_stream, int msg_number)

이함수는 특정 메시지의 지움 플래그(deletion flag)를 제거한다. 여기서 특정 메시지는 imap_delete()함수나 imap_mail_move()함수에 의해서 지움 표시된 메시지이다.

성공하면 TRUE를 리턴하고 에러가 발생하면 FALSE를 리턴한다.

이전 | 처음으로 | 다음
imap_uid | 위로 | imap_unsubscribe


imap_unsubscribe

(PHP 3, PHP 4 , PHP 5)

imap_unsubscribe -- 메일박스를 Unsubscribe한다

Description

int imap_unsubscribe ( int imap_stream, string mbox)

특정 메일박스에서 Unsubscribe한다.

성공하면 TRUE를 리턴하고 에러가 발생하면 FALSE를 리턴한다.

이전 | 처음으로 | 다음
imap_undelete | 위로 | imap_utf7_decode


imap_utf7_decode

(PHP 3>= 3.0.15, PHP 4 , PHP 5)

imap_utf7_decode -- modified UTF-7 인코딩된 문자열을 디코딩한다.

Description

string imap_utf7_decode ( string text)

modified UTF-7형식의 text를 8비트 데이터로 디코딩한다.

디코딩된 8비트 데이터를 돌려주거나, 입력 문자열이 유효한 modified UTF-7이 아니면 FALSE를 돌려준다. 이 함수는 출력가능한 아스키(ASCII)코드 범위를 벗어난 국제적인 문자를 갖는 메일박스 이름을 디코딩할 때 필요하다. modified UTF-7 인코딩은 RFC 2060 , section 5.1.3 문서에 정의되어 있다( original UTF-7 은 RFC1642문서에 정의되어 있었다).

이전 | 처음으로 | 다음
imap_unsubscribe | 위로 | imap_utf7_encode


imap_utf7_encode

(PHP 3>= 3.0.15, PHP 4 , PHP 5)

imap_utf7_encode -- 8비트 데이터를 UTF-7 텍스트로 변환한다.

Description

string imap_utf7_encode ( string data)

8비트 data를 modified UTF-7텍스트로 변경한다. 이 함수는 출력가능한 아스키(ASCII)코드 범위를 벗어난 국제적인 문자를 포함하는 메일박스 이름을 인코딩할 때 필요하다. modified UTF-7 인코딩은 RFC 2060, section 5.1.3문서에 정의되어 있다. ( original UTF-7은 RFC1642 문서에 정의되어 있다).

modified UTF-7 텍스트를 돌려준다.

이전 | 처음으로 | 다음
imap_utf7_decode | 위로 | imap_utf8


imap_utf8

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

imap_utf8 -- 텍스트를 UTF8로 변환한다

Description

string imap_utf8 ( string text)

주어진 text값을 UTF8로 변환한다 (RFC2044문서에 정의된대로).

이전 | 처음으로 | 다음
imap_utf7_encode | 위로 | Informix Functions


Informix Functions

PHP 매뉴얼
이전 다음

XLIII. Informix Functions

소개

The Informix driver for Informix (IDS) 7.x, SE 7.x, Universal Server (IUS) 9.x and IDS 2000 is implemented in "ifx.ec" and "php3_ifx.h" in the informix extension directory. IDS 7.x support is fairly complete, with full support for BYTE and TEXT columns. IUS 9.x support is partly finished: the new data types are there, but SLOB and CLOB support is still under construction.

요구 사항

Configuration notes: You need a version of ESQL/C to compile the PHP Informix driver. ESQL/C versions from 7.2x on should be OK. ESQL/C is now part of the Informix Client SDK.

Make sure that the "INFORMIXDIR" variable has been set, and that $INFORMIXDIR/bin is in your PATH before you run the "configure" script.

설치

To be able to use the functions defined in this module you must compile your PHP interpreter using the configure line --with_informix[=DIR], where DIR is the Informix base install directory, defaults to nothing.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

참고: Make sure that the Informix environment variables INFORMIXDIR and INFORMIXSERVER are available to the PHP ifx driver, and that the INFORMIX bin directory is in the PATH. Check this by running a script that contains a call to phpinfo() before you start testing. The phpinfo() output should list these environment variables. This is TRUE for both CGI php and Apache mod_php. You may have to set these environment variables in your Apache startup script.

The Informix shared libraries should also be available to the loader (check LD_LIBRARY_PATH or ld.so.conf/ldconfig).

Some notes on the use of BLOBs (TEXT and BYTE columns): BLOBs are normally addressed by BLOB identifiers. Select queries return a "blob id" for every BYTE and TEXT column. You can get at the contents with "string_var = ifx_get_blob($blob_id);" if you choose to get the BLOBs in memory (with: "ifx_blobinfile(0);"). If you prefer to receive the content of BLOB columns in a file, use "ifx_blobinfile(1);", and "ifx_get_blob($blob_id);" will get you the filename. Use normal file I/O to get at the blob contents.

For insert/update queries you must create these "blob id's" yourself with "ifx_create_blob();". You then plug the blob id's into an array, and replace the blob columns with a question mark (?) in the query string. For updates/inserts, you are responsible for setting the blob contents with ifx_update_blob().

The behaviour of BLOB columns can be altered by configuration variables that also can be set at runtime:

configuration variable: ifx.textasvarchar

configuration variable: ifx.byteasvarchar

runtime functions:

ifx_textasvarchar(0): use blob id's for select queries with TEXT columns

ifx_byteasvarchar(0): use blob id's for select queries with BYTE columns

ifx_textasvarchar(1): return TEXT columns as if they were VARCHAR columns, so that you don't need to use blob id's for select queries.

ifx_byteasvarchar(1): return BYTE columns as if they were VARCHAR columns, so that you don't need to use blob id's for select queries.

configuration variable: ifx.blobinfile

runtime function:

ifx_blobinfile_mode(0): return BYTE columns in memory, the blob id lets you get at the contents.

ifx_blobinfile_mode(1): return BYTE columns in a file, the blob id lets you get at the file name.

If you set ifx_text/byteasvarchar to 1, you can use TEXT and BYTE columns in select queries just like normal (but rather long) VARCHAR fields. Since all strings are "counted" in PHP, this remains "binary safe". It is up to you to handle this correctly. The returned data can contain anything, you are responsible for the contents.

If you set ifx_blobinfile to 1, use the file name returned by ifx_get_blob(..) to get at the blob contents. Note that in this case YOU ARE RESPONSIBLE FOR DELETING THE TEMPORARY FILES CREATED BY INFORMIX when fetching the row. Every new row fetched will create new temporary files for every BYTE column.

The location of the temporary files can be influenced by the environment variable "blobdir", default is "." (the current directory). Something like: putenv(blobdir=tmpblob"); will ease the cleaning up of temp files accidentally left behind (their names all start with "blb").

Automatically trimming "char" (SQLCHAR and SQLNCHAR) data: This can be set with the configuration variable

ifx.charasvarchar: if set to 1 trailing spaces will be automatically trimmed, to save you some "chopping".

NULL values: The configuration variable ifx.nullformat (and the runtime function ifx_nullformat()) when set to TRUE will return NULL columns as the string "NULL", when set to FALSE they return the empty string. This allows you to discriminate between NULL columns and empty columns.

표 1. Informix configuration options

Name | Default | Changeable
ifx.allow_persistent | "1" | PHP_INI_SYSTEM
ifx.max_persistent | "-1" | PHP_INI_SYSTEM
ifx.max_links | "-1" | PHP_INI_SYSTEM
ifx.default_host | NULL | PHP_INI_SYSTEM
ifx.default_user | NULL | PHP_INI_SYSTEM
ifx.default_password | NULL | PHP_INI_SYSTEM
ifx.blobinfile | "1" | PHP_INI_ALL
ifx.textasvarchar | "0" | PHP_INI_ALL
ifx.byteasvarchar | "0" | PHP_INI_ALL
ifx.charasvarchar | "0" | PHP_INI_ALL
ifx.nullformat | "0" | PHP_INI_ALL
For further details and definition of the PHP_INI_* constants see ini_set().

위 설정 지시어에 대한 간단한 설명입니다.

ifx.allow_persistent boolean

Whether to allow persistent Informix connections.

ifx.max_persistent integer

The maximum number of persistent Informix connections per process.

ifx.max_links integer

The maximum number of Informix connections per process, including persistent connections.

ifx.default_host string

The default host to connect to when no host is specified in ifx_connect() or ifx_pconnect(). Doesn't apply in 안전 모드.

ifx.default_user string

The default user id to use when none is specified in ifx_connect() or ifx_pconnect(). Doesn't apply in 안전 모드.

ifx.default_password string

The default password to use when none is specified in ifx_connect() or ifx_pconnect(). Doesn't apply in 안전 모드.

ifx.blobinfile boolean

Set to TRUE if you want to return blob columns in a file, FALSE if you want them in memory. You can override the setting at runtime with ifx_blobinfile_mode().

ifx.textasvarchar boolean

Set to TRUE if you want to return TEXT columns as normal strings in select statements, FALSE if you want to use blob id parameters. You can override the setting at runtime with ifx_textasvarchar().

ifx.byteasvarchar boolean

Set to TRUE if you want to return BYTE columns as normal strings in select queries, FALSE if you want to use blob id parameters. You can override the setting at runtime with ifx_textasvarchar().

ifx.charasvarchar boolean

Set to TRUE if you want to trim trailing spaces from CHAR columns when fetching them.

ifx.nullformat boolean

Set to TRUE if you want to return NULL columns as the literal string "NULL", FALSE if you want them returned as the empty string "". You can override this setting at runtime with ifx_nullformat().

리소스 종류

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
ifx_affected_rows -- Get number of rows affected by a query
ifx_blobinfile_mode -- Set the default blob mode for all select queries
ifx_byteasvarchar -- Set the default byte mode
ifx_close -- Close Informix connection
ifx_connect -- Open Informix server connection
ifx_copy_blob -- Duplicates the given blob object
ifx_create_blob -- Creates an blob object
ifx_create_char -- Creates an char object
ifx_do -- Execute a previously prepared SQL-statement
ifx_error -- Returns error code of last Informix call
ifx_errormsg -- Returns error message of last Informix call
ifx_fetch_row -- Get row as enumerated array
ifx_fieldproperties -- List of SQL fieldproperties
ifx_fieldtypes -- List of Informix SQL fields
ifx_free_blob -- Deletes the blob object
ifx_free_char -- Deletes the char object
ifx_free_result -- Releases resources for the query
ifx_get_blob -- Return the content of a blob object
ifx_get_char -- Return the content of the char object
ifx_getsqlca -- Get the contents of sqlca.sqlerrd[0..5] after a query
ifx_htmltbl_result -- Formats all rows of a query into a HTML table
ifx_nullformat -- Sets the default return value on a fetch row
ifx_num_fields -- Returns the number of columns in the query
ifx_num_rows -- Count the rows already fetched from a query
ifx_pconnect -- Open persistent Informix connection
ifx_prepare -- Prepare an SQL-statement for execution
ifx_query -- Send Informix query
ifx_textasvarchar -- Set the default text mode
ifx_update_blob -- Updates the content of the blob object
ifx_update_char -- Updates the content of the char object
ifxus_close_slob -- Deletes the slob object
ifxus_create_slob -- Creates an slob object and opens it
ifxus_free_slob -- Deletes the slob object
ifxus_open_slob -- Opens an slob object
ifxus_read_slob -- Reads nbytes of the slob object
ifxus_seek_slob -- Sets the current file or seek position
ifxus_tell_slob -- Returns the current file or seek position
ifxus_write_slob -- Writes a string into the slob object

이전 | 처음으로 | 다음
imap_utf8 | 위로 | ifx_affected_rows


ifx_affected_rows

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

ifx_affected_rows -- Get number of rows affected by a query

Description

int ifx_affected_rows ( int result_id)

result_id is a valid result id returned by ifx_query() or ifx_prepare().

Returns the number of rows affected by a query associated with result_id.

For inserts, updates and deletes the number is the real number (sqlerrd[2]) of affected rows. For selects it is an estimate (sqlerrd[0]). Don't rely on it. The database server can never return the actual number of rows that will be returned by a SELECT because it has not even begun fetching them at this stage (just after the "PREPARE" when the optimizer has determined the query plan).

Useful after ifx_prepare() to limit queries to reasonable result sets.

예 1. Informix affected rows

<?php
$rid = ifx_prepare("select * from emp
                     where name like " . $name, $connid);
if (! $rid) {
    /* ... error ... */
}
$rowcount = ifx_affected_rows($rid);
if ($rowcount > 1000) {
    printf ("Too many rows in result set (%d)\n<br />", $rowcount);
    die ("Please restrict your query<br />\n");
}
?>

See also ifx_num_rows().

이전 | 처음으로 | 다음
Informix Functions | 위로 | ifx_blobinfile_mode


ifx_blobinfile_mode

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifx_blobinfile_mode -- Set the default blob mode for all select queries

Description

void ifx_blobinfile_mode ( int mode)

Set the default blob mode for all select queries. Mode "0" means save Byte-Blobs in memory, and mode "1" means save Byte-Blobs in a file.

이전 | 처음으로 | 다음
ifx_affected_rows | 위로 | ifx_byteasvarchar


ifx_byteasvarchar

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifx_byteasvarchar -- Set the default byte mode

Description

void ifx_byteasvarchar ( int mode)

Sets the default byte mode for all select-queries. Mode "0" will return a blob id, and mode "1" will return a varchar with text content.

이전 | 처음으로 | 다음
ifx_blobinfile_mode | 위로 | ifx_close


ifx_close

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

ifx_close -- Close Informix connection

Description

int ifx_close ( [int link_identifier])

Returns: always TRUE.

ifx_close() closes the link to an Informix database that's associated with the specified link identifier. If the link identifier isn't specified, the last opened link is assumed.

Note that this isn't usually necessary, as non-persistent open links are automatically closed at the end of the script's execution.

ifx_close() will not close persistent links generated by ifx_pconnect().

예 1. Closing a Informix connection

<?php
$conn_id = ifx_connect ("mydb@ol_srv", "itsme", "mypassword");
/* ... some queries and stuff ... */
ifx_close($conn_id);
?>

See also ifx_connect() and ifx_pconnect().

이전 | 처음으로 | 다음
ifx_byteasvarchar | 위로 | ifx_connect


ifx_connect

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

ifx_connect -- Open Informix server connection

Description

int ifx_connect ( [string database [, string userid [, string password]]])

Returns a connection identifier on success, or FALSE on error.

ifx_connect() establishes a connection to an Informix server. All of the arguments are optional, and if they're missing, defaults are taken from values supplied in configuration file (ifx.default_host for the host (Informix libraries will use INFORMIXSERVER environment value if not defined), ifx.default_user for user, ifx.default_password for the password (none if not defined).

In case a second call is made to ifx_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned.

The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling ifx_close().

예 1. Connect to a Informix database

<?php
$conn_id = ifx_connect ("mydb@ol_srv1", "imyself", "mypassword");
?>

See also ifx_pconnect() and ifx_close().

이전 | 처음으로 | 다음
ifx_close | 위로 | ifx_copy_blob


ifx_copy_blob

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifx_copy_blob -- Duplicates the given blob object

Description

int ifx_copy_blob ( int bid)

Duplicates the given blob object. bid is the ID of the blob object.

Returns FALSE on error otherwise the new blob object-id.

이전 | 처음으로 | 다음
ifx_connect | 위로 | ifx_create_blob


ifx_create_blob

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifx_create_blob -- Creates an blob object

Description

int ifx_create_blob ( int type, int mode, string param)

Creates an blob object.

type: 1 = TEXT, 0 = BYTE

mode: 0 = blob-object holds the content in memory, 1 = blob-object holds the content in file.

param: if mode = 0: pointer to the content, if mode = 1: pointer to the filestring.

Return FALSE on error, otherwise the new blob object-id.

이전 | 처음으로 | 다음
ifx_copy_blob | 위로 | ifx_create_char


ifx_create_char

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

ifx_create_char -- Creates an char object

Description

int ifx_create_char ( string param)

Creates an char object. param should be the char content.

이전 | 처음으로 | 다음
ifx_create_blob | 위로 | ifx_do


ifx_do

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifx_do -- Execute a previously prepared SQL-statement

Description

int ifx_do ( int result_id)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

Executes a previously prepared query or opens a cursor for it.

Does NOT free result_id on error.

Also sets the real number of ifx_affected_rows() for non-select statements for retrieval by ifx_affected_rows()

See also: ifx_prepare().

이전 | 처음으로 | 다음
ifx_create_char | 위로 | ifx_error


ifx_error

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

ifx_error -- Returns error code of last Informix call

Description

string ifx_error ( void )

The Informix error codes (SQLSTATE & SQLCODE) formatted as follows :

x [SQLSTATE = aa bbb SQLCODE=cccc]

where x = space : no error

E : error

N : no more data

W : warning

? : undefined

If the "x" character is anything other than space, SQLSTATE and SQLCODE describe the error in more detail.

See the Informix manual for the description of SQLSTATE and SQLCODE

Returns in a string one character describing the general results of a statement and both SQLSTATE and SQLCODE associated with the most recent SQL statement executed. The format of the string is "(char) [SQLSTATE=(two digits) (three digits) SQLCODE=(one digit)]". The first character can be ' ' (space) (success), 'W' (the statement caused some warning), 'E' (an error happened when executing the statement) or 'N' (the statement didn't return any data).

See also: ifx_errormsg()

이전 | 처음으로 | 다음
ifx_do | 위로 | ifx_errormsg


ifx_errormsg

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifx_errormsg -- Returns error message of last Informix call

Description

string ifx_errormsg ( [int errorcode])

Returns the Informix error message associated with the most recent Informix error, or, when the optional "errorcode" parameter is present, the error message corresponding to "errorcode".

예 1. ifx_errormsg() example

printf("%s\n&lt;br>", ifx_errormsg(-201));

See also ifx_error().

이전 | 처음으로 | 다음
ifx_error | 위로 | ifx_fetch_row


ifx_fetch_row

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

ifx_fetch_row -- Get row as enumerated array

Description

array ifx_fetch_row ( int result_id [, mixed position])

Returns an associative array that corresponds to the fetched row, or FALSE if there are no more rows.

Blob columns are returned as integer blob id values for use in ifx_get_blob() unless you have used ifx_textasvarchar(1) or ifx_byteasvarchar(1), in which case blobs are returned as string values. Returns FALSE on error

result_id is a valid resultid returned by ifx_query() or ifx_prepare() (select type queries only!).

position is an optional parameter for a "fetch" operation on "scroll" cursors: "NEXT", "PREVIOUS", "CURRENT", "FIRST", "LAST" or a number. If you specify a number, an "absolute" row fetch is executed. This parameter is optional, and only valid for SCROLL cursors.

ifx_fetch_row() fetches one row of data from the result associated with the specified result identifier. The row is returned as an array. Each result column is stored in an array offset, starting at offset 0, with the column name as key.

Subsequent calls to ifx_fetch_row() would return the next row in the result set, or FALSE if there are no more rows.

예 1. Informix fetch rows

<?php
$rid = ifx_prepare ("select * from emp where name like " . $name,
                     $connid, IFX_SCROLL);
if (! $rid) {
    /* ... error ... */
}
$rowcount = ifx_affected_rows($rid);
if ($rowcount > 1000) {
    printf ("Too many rows in result set (%d)\n<br />", $rowcount);
    die ("Please restrict your query<br />\n");
}
if (! ifx_do ($rid)) {
   /* ... error ... */
}
$row = ifx_fetch_row ($rid, "NEXT");
while (is_array($row)) {
    for (reset($row); $fieldname=key($row); next($row)) {
        $fieldvalue = $row[$fieldname];
        printf ("%s = %s,", $fieldname, $fieldvalue);
    }
    printf("\n<br />");
    $row = ifx_fetch_row($rid, "NEXT");
}
ifx_free_result ($rid);
?>

이전 | 처음으로 | 다음
ifx_errormsg | 위로 | ifx_fieldproperties


ifx_fieldproperties

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

ifx_fieldproperties -- List of SQL fieldproperties

Description

array ifx_fieldproperties ( int result_id)

Returns an associative array with fieldnames as key and the SQL fieldproperties as data for a query with result_id. Returns FALSE on error.

Returns the Informix SQL fieldproperties of every field in the query as an associative array. Properties are encoded as: "SQLTYPE;length;precision;scale;ISNULLABLE" where SQLTYPE = the Informix type like "SQLVCHAR" etc. and ISNULLABLE = "Y" or "N".

예 1. Informix SQL fieldproperties

<?php
$properties = ifx_fieldproperties ($resultid);
if (! isset($properties)) {
    /* ... error ... */
}
for ($i = 0; $i < count($properties); $i++) {
    $fname = key ($properties);
    printf ("%s:\t type =  %s\n", $fname, $properties[$fname]);
    next ($properties);
}
?>

이전 | 처음으로 | 다음
ifx_fetch_row | 위로 | ifx_fieldtypes


ifx_fieldtypes

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

ifx_fieldtypes -- List of Informix SQL fields

Description

array ifx_fieldtypes ( int result_id)

Returns an associative array with fieldnames as key and the SQL fieldtypes as data for query with result_id. Returns FALSE on error.

예 1. Fieldnames and SQL fieldtypes

<?php
$types = ifx_fieldtypes ($resultid);
if (! isset ($types)) {
    /* ... error ... */
}
for ($i = 0; $i < count($types); $i++) {
    $fname = key($types);
    printf("%s :\t type =  %s\n", $fname, $types[$fname]);
    next($types);
}
?>

이전 | 처음으로 | 다음
ifx_fieldproperties | 위로 | ifx_free_blob


ifx_free_blob

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifx_free_blob -- Deletes the blob object

Description

int ifx_free_blob ( int bid)

Deletes the blobobject for the given blob object-id bid. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ifx_fieldtypes | 위로 | ifx_free_char


ifx_free_char

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

ifx_free_char -- Deletes the char object

Description

int ifx_free_char ( int bid)

Deletes the charobject for the given char object-id bid. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ifx_free_blob | 위로 | ifx_free_result


ifx_free_result

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

ifx_free_result -- Releases resources for the query

Description

int ifx_free_result ( int result_id)

Releases resources for the query associated with result_id. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ifx_free_char | 위로 | ifx_get_blob


ifx_get_blob

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifx_get_blob -- Return the content of a blob object

Description

int ifx_get_blob ( int bid)

Returns the content of the blob object for the given blob object-id bid.

이전 | 처음으로 | 다음
ifx_free_result | 위로 | ifx_get_char


ifx_get_char

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

ifx_get_char -- Return the content of the char object

Description

int ifx_get_char ( int bid)

Returns the content of the char object for the given char object-id bid.

이전 | 처음으로 | 다음
ifx_get_blob | 위로 | ifx_getsqlca


ifx_getsqlca

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

ifx_getsqlca -- Get the contents of sqlca.sqlerrd[0..5] after a query

Description

array ifx_getsqlca ( int result_id)

result_id is a valid result id returned by ifx_query() or ifx_prepare().

Returns a pseudo-row (associative array) with sqlca.sqlerrd[0] ... sqlca.sqlerrd[5] after the query associated with result_id.

For inserts, updates and deletes the values returned are those as set by the server after executing the query. This gives access to the number of affected rows and the serial insert value. For SELECTs the values are those saved after the PREPARE statement. This gives access to the *estimated* number of affected rows. The use of this function saves the overhead of executing a "select dbinfo('sqlca.sqlerrdx')" query, as it retrieves the values that were saved by the ifx driver at the appropriate moment.

예 1. Retrieve Informix sqlca.sqlerrd[x] values

<?php
/* assume the first column of 'sometable' is a serial */
$qid = ifx_query("insert into sometable
                  values (0, '2nd column', 'another column') ", $connid);
if (!$qid) {
    /* ... error ... */
}
$sqlca = ifx_getsqlca($qid);
$serial_value = $sqlca["sqlerrd1"];
echo "The serial value of the inserted row is : $serial_value<br />\n";
?>

이전 | 처음으로 | 다음
ifx_get_char | 위로 | ifx_htmltbl_result


ifx_htmltbl_result

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

ifx_htmltbl_result -- Formats all rows of a query into a HTML table

Description

int ifx_htmltbl_result ( int result_id [, string html_table_options])

Returns the number of rows fetched or FALSE on error.

Formats all rows of the result_id query into a HTML table. The optional second argument is a string of <table> tag options

예 1. Informix results as HTML table

<?php
$rid = ifx_prepare ("select * from emp where name like " . $name,
                     $connid, IFX_SCROLL);
if (! $rid) {
    /* ... error ... */
}
$rowcount = ifx_affected_rows ($rid);
if ($rowcount > 1000) {
    printf ("Too many rows in result set (%d)\n<br />", $rowcount);
    die ("Please restrict your query<br />\n");
}
if (! ifx_do($rid)) {
    /* ... error ... */
}

ifx_htmltbl_result ($rid, "border=\"2\"");

ifx_free_result($rid);
?>

이전 | 처음으로 | 다음
ifx_getsqlca | 위로 | ifx_nullformat


ifx_nullformat

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifx_nullformat -- Sets the default return value on a fetch row

Description

void ifx_nullformat ( int mode)

Sets the default return value of a NULL-value on a fetch row. Mode "0" returns "", and mode "1" returns "NULL".

이전 | 처음으로 | 다음
ifx_htmltbl_result | 위로 | ifx_num_fields


ifx_num_fields

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

ifx_num_fields -- Returns the number of columns in the query

Description

int ifx_num_fields ( int result_id)

Returns the number of columns in query for result_id or FALSE on error

After preparing or executing a query, this call gives you the number of columns in the query.

이전 | 처음으로 | 다음
ifx_nullformat | 위로 | ifx_num_rows


ifx_num_rows

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

ifx_num_rows -- Count the rows already fetched from a query

Description

int ifx_num_rows ( int result_id)

Gives the number of rows fetched so far for a query with result_id after a ifx_query() or ifx_do() query.

이전 | 처음으로 | 다음
ifx_num_fields | 위로 | ifx_pconnect


ifx_pconnect

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

ifx_pconnect -- Open persistent Informix connection

Description

int ifx_pconnect ( [string database [, string userid [, string password]]])

Returns: A positive Informix persistent link identifier on success, or FALSE on error

ifx_pconnect() acts very much like ifx_connect() with two major differences.

This function behaves exactly like ifx_connect() when PHP is not running as an Apache module. First, when connecting, the function would first try to find a (persistent) link that's already open with the same host, username and password. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (ifx_close() will not close links established by ifx_pconnect()).

This type of links is therefore called 'persistent'.

See also: ifx_connect().

이전 | 처음으로 | 다음
ifx_num_rows | 위로 | ifx_prepare


ifx_prepare

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifx_prepare -- Prepare an SQL-statement for execution

Description

int ifx_prepare ( string query, int conn_id [, int cursor_def, mixed blobidarray])

Returns an integer result_id for use by ifx_do(). Sets affected_rows for retrieval by the ifx_affected_rows() function.

Prepares query on connection conn_id. For "select-type" queries a cursor is declared and opened. The optional cursor_type parameter allows you to make this a "scroll" and/or "hold" cursor. It's a bitmask and can be either IFX_SCROLL, IFX_HOLD, or both or'ed together.

For either query type the estimated number of affected rows is saved for retrieval by ifx_affected_rows().

If you have BLOB (BYTE or TEXT) columns in the query, you can add a blobidarray parameter containing the corresponding "blob ids", and you should replace those columns with a "?" in the query text.

If the contents of the TEXT (or BYTE) column allow it, you can also use "ifx_textasvarchar(1)" and "ifx_byteasvarchar(1)". This allows you to treat TEXT (or BYTE) columns just as if they were ordinary (but long) VARCHAR columns for select queries, and you don't need to bother with blob id's.

With ifx_textasvarchar(0) or ifx_byteasvarchar(0) (the default situation), select queries will return BLOB columns as blob id's (integer value). You can get the value of the blob as a string or file with the blob functions (see below).

See also: ifx_do().

이전 | 처음으로 | 다음
ifx_pconnect | 위로 | ifx_query


ifx_query

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

ifx_query -- Send Informix query

Description

int ifx_query ( string query, int link_identifier [, int cursor_type [, mixed blobidarray]])

Returns a positive Informix result identifier on success, or FALSE on error.

A "result_id" resource used by other functions to retrieve the query results. Sets "affected_rows" for retrieval by the ifx_affected_rows() function.

ifx_query() sends a query to the currently active database on the server that's associated with the specified link identifier.

Executes query on connection conn_id. For "select-type" queries a cursor is declared and opened. The optional cursor_type parameter allows you to make this a "scroll" and/or "hold" cursor. It's a bitmask and can be either IFX_SCROLL, IFX_HOLD, or both or'ed together. Non-select queries are "execute immediate". IFX_SCROLL and IFX_HOLD are symbolic constants and as such shouldn't be between quotes. I you omit this parameter the cursor is a normal sequential cursor.

For either query type the number of (estimated or real) affected rows is saved for retrieval by ifx_affected_rows().

If you have BLOB (BYTE or TEXT) columns in an update query, you can add a blobidarray parameter containing the corresponding "blob ids", and you should replace those columns with a "?" in the query text.

If the contents of the TEXT (or BYTE) column allow it, you can also use "ifx_textasvarchar(1)" and "ifx_byteasvarchar(1)". This allows you to treat TEXT (or BYTE) columns just as if they were ordinary (but long) VARCHAR columns for select queries, and you don't need to bother with blob id's.

With ifx_textasvarchar(0) or ifx_byteasvarchar(0) (the default situation), select queries will return BLOB columns as blob id's (integer value). You can get the value of the blob as a string or file with the blob functions (see below).

예 1. Show all rows of the "orders" table as a HTML table

<?php
ifx_textasvarchar(1);      // use "text mode" for blobs
$res_id = ifx_query("select * from orders", $conn_id);
if (! $res_id) {
    printf("Can't select orders : %s\n<br />%s<br />\n", ifx_error());
    ifx_errormsg();
    die;
}
ifx_htmltbl_result($res_id, "border=\"1\"");
ifx_free_result($res_id);
?>

예 2. Insert some values into the "catalog" table

<?php

// create blob id's for a byte and text column
$textid = ifx_create_blob(0, 0, "Text column in memory");
$byteid = ifx_create_blob(1, 0, "Byte column in memory");

// store blob id's in a blobid array
$blobidarray[] = $textid;
$blobidarray[] = $byteid;

// launch query
$query = "insert into catalog (stock_num, manu_code, " .
         "cat_descr,cat_picture) values(1,'HRO',?,?)";
$res_id = ifx_query($query, $conn_id, $blobidarray);
if (! $res_id) {
    /* ... error ... */
}

// free result id
ifx_free_result($res_id);
?>

See also ifx_connect().

이전 | 처음으로 | 다음
ifx_prepare | 위로 | ifx_textasvarchar


ifx_textasvarchar

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifx_textasvarchar -- Set the default text mode

Description

void ifx_textasvarchar ( int mode)

Sets the default text mode for all select-queries. Mode "0" will return a blob id, and mode "1" will return a varchar with text content.

이전 | 처음으로 | 다음
ifx_query | 위로 | ifx_update_blob


ifx_update_blob

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifx_update_blob -- Updates the content of the blob object

Description

bool ifx_update_blob ( int bid, string content)

Updates the content of the blob object for the given blob object bid. content is a string with new data. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ifx_textasvarchar | 위로 | ifx_update_char


ifx_update_char

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

ifx_update_char -- Updates the content of the char object

Description

int ifx_update_char ( int bid, string content)

Updates the content of the char object for the given char object bid. content is a string with new data. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ifx_update_blob | 위로 | ifxus_close_slob


ifxus_close_slob

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifxus_close_slob -- Deletes the slob object

Description

int ifxus_close_slob ( int bid)

Deletes the slob object on the given slob object-id bid. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ifx_update_char | 위로 | ifxus_create_slob


ifxus_create_slob

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifxus_create_slob -- Creates an slob object and opens it

Description

int ifxus_create_slob ( int mode)

Creates an slob object and opens it. Modes: 1 = LO_RDONLY, 2 = LO_WRONLY, 4 = LO_APPEND, 8 = LO_RDWR, 16 = LO_BUFFER, 32 = LO_NOBUFFER -> or-mask. You can also use constants named IFX_LO_RDONLY, IFX_LO_WRONLY etc. Return FALSE on error otherwise the new slob object-id.

이전 | 처음으로 | 다음
ifxus_close_slob | 위로 | ifxus_free_slob


ifxus_free_slob

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifxus_free_slob -- Deletes the slob object

Description

int ifxus_free_slob ( int bid)

Deletes the slob object. bid is the Id of the slob object. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ifxus_create_slob | 위로 | ifxus_open_slob


ifxus_open_slob

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifxus_open_slob -- Opens an slob object

Description

int ifxus_open_slob ( long bid, int mode)

Opens an slob object. bid should be an existing slob id. Modes: 1 = LO_RDONLY, 2 = LO_WRONLY, 4 = LO_APPEND, 8 = LO_RDWR, 16 = LO_BUFFER, 32 = LO_NOBUFFER -> or-mask. Returns FALSE on error otherwise the new slob object-id.

이전 | 처음으로 | 다음
ifxus_free_slob | 위로 | ifxus_read_slob


ifxus_read_slob

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifxus_read_slob -- Reads nbytes of the slob object

Description

int ifxus_read_slob ( long bid, long nbytes)

Reads nbytes of the slob object. bid is a existing slob id and nbytes is the number of bytes read. Return FALSE on error otherwise the string.

이전 | 처음으로 | 다음
ifxus_open_slob | 위로 | ifxus_seek_slob


ifxus_seek_slob

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifxus_seek_slob -- Sets the current file or seek position

Description

int ifxus_seek_slob ( long bid, int mode, long offset)

Sets the current file or seek position of an open slob object. bid should be an existing slob id. Modes: 0 = LO_SEEK_SET, 1 = LO_SEEK_CUR, 2 = LO_SEEK_END and offset is an byte offset. Return FALSE on error otherwise the seek position.

이전 | 처음으로 | 다음
ifxus_read_slob | 위로 | ifxus_tell_slob


ifxus_tell_slob

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifxus_tell_slob -- Returns the current file or seek position

Description

int ifxus_tell_slob ( long bid)

Returns the current file or seek position of an open slob object bid should be an existing slob id. Return FALSE on error otherwise the seek position.

이전 | 처음으로 | 다음
ifxus_seek_slob | 위로 | ifxus_write_slob


ifxus_write_slob

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ifxus_write_slob -- Writes a string into the slob object

Description

int ifxus_write_slob ( long bid, string content)

Writes a string into the slob object. bid is an existing slob id and content the content to write. Return FALSE on error otherwise bytes written.

이전 | 처음으로 | 다음
ifxus_tell_slob | 위로 | InterBase Functions


InterBase Functions

PHP 매뉴얼
이전 다음

XLIV. InterBase Functions

소개

InterBase is a popular database put out by Borland/Inprise. More information about InterBase is available at http://www.interbase.com/. Oh, by the way, InterBase just joined the open source movement!

참고: Full support for InterBase 6 was added in PHP 4.0.

This database uses a single quote (') character for escaping, a behavior similar to the Sybase database, add to your php.ini the following directive:

magic_quotes_sybase = On

요구 사항

설치

To enable InterBase support configure PHP --with-interbase[=DIR], where DIR is the InterBase base install directory, which defaults to /usr/interbase.

Note to Win32 Users: In order to enable this module on a Windows environment, you must copy gds32.dll from the DLL folder of the PHP/Win32 binary package to the SYSTEM32 folder of your windows machine. (Ex: C:\WINNT\SYSTEM32 or C:\WINDOWS\SYSTEM32). In case you installed the InterBase database server on the same machine PHP is running on, you will have this DLL already. Therefore you don't need to copy gds32.dll from the DLL folder.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. InterBase configuration options

Name | Default | Changeable
ibase.allow_persistent | "1" | PHP_INI_SYSTEM
ibase.max_persistent | "-1" | PHP_INI_SYSTEM
ibase.max_links | "-1" | PHP_INI_SYSTEM
ibase.default_user | NULL | PHP_INI_ALL
ibase.default_password | NULL | PHP_INI_ALL
ibase.timestampformat | "%m/%d/%Y%H:%M:%S" | PHP_INI_ALL
ibase.dateformat | "%m/%d/%Y" | PHP_INI_ALL
ibase.timeformat | "%H:%M:%S" | PHP_INI_ALL
For further details and definition of the PHP_INI_* constants see ini_set().

리소스 종류

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

IBASE_DEFAULT (integer)

IBASE_TEXT (integer)

IBASE_UNIXTIME (integer)

IBASE_WRITE (integer)

Access mode

IBASE_READ (integer)

Access mode

IBASE_COMMITTED (integer)

Isolation level

IBASE_CONSISTENCY (integer)

Isolation level

IBASE_CONCURRENCY (integer)

Isolation level (default)

IBASE_REC_VERSION (integer)

IBASE_REC_NO_VERSION (integer)

IBASE_NOWAIT (integer)

Lock resolution

IBASE_WAIT (integer)

Lock resolution (default)

IBASE_TIMESTAMP (integer)

IBASE_DATE (integer)

IBASE_TIME (integer)

차례
ibase_add_user -- Add a user to a security database (only for IB6 or later)
ibase_affected_rows -- Return the number of rows that were affected by the previous query
ibase_backup -- Initiates a backup task in the service manager and returns immediately
ibase_blob_add -- Add data into a newly created blob
ibase_blob_cancel -- Cancel creating blob
ibase_blob_close -- Close blob
ibase_blob_create -- Create a new blob for adding data
ibase_blob_echo -- Output blob contents to browser
ibase_blob_get -- Get len bytes data from open blob
ibase_blob_import -- Create blob, copy file in it, and close it
ibase_blob_info -- Return blob length and other useful info
ibase_blob_open -- Open blob for retrieving data parts
ibase_close -- Close a connection to an InterBase database
ibase_commit_ret -- Commit a transaction without closing it
ibase_commit -- Commit a transaction
ibase_connect -- Open a connection to an InterBase database
ibase_db_info -- Request statistics about a database
ibase_delete_user -- Delete a user from a security database (only for IB6 or later)
ibase_drop_db -- Drops a database
ibase_errcode -- Return an error code
ibase_errmsg -- Return error messages
ibase_execute -- Execute a previously prepared query
ibase_fetch_assoc -- Fetch a result row from a query as an associative array
ibase_fetch_object -- Get an object from a InterBase database
ibase_fetch_row -- Fetch a row from an InterBase database
ibase_field_info -- Get information about a field
ibase_free_event_handler -- Cancels a registered event handler
ibase_free_query -- Free memory allocated by a prepared query
ibase_free_result -- Free a result set
ibase_gen_id -- Increments the named generator and returns its new value
ibase_maintain_db -- Execute a maintenance command on the database server
ibase_modify_user -- Modify a user to a security database (only for IB6 or later)
ibase_name_result -- Assigns a name to a result set
ibase_num_fields -- Get the number of fields in a result set
ibase_num_params -- Return the number of parameters in a prepared query
ibase_param_info -- Return information about a parameter in a prepared query
ibase_pconnect -- Open a persistent connection to an InterBase database
ibase_prepare -- Prepare a query for later binding of parameter placeholders and execution
ibase_query -- Execute a query on an InterBase database
ibase_restore -- Initiates a restore task in the service manager and returns immediately
ibase_rollback_ret -- Roll back a transaction without closing it
ibase_rollback -- Roll back a transaction
ibase_server_info -- Request information about a database server
ibase_service_attach -- Connect to the service manager
ibase_service_detach -- Disconnect from the service manager
ibase_set_event_handler -- Register a callback function to be called when events are posted
ibase_timefmt -- Sets the format of timestamp, date and time type columns returned from queries
ibase_trans -- Begin a transaction
ibase_wait_event -- Wait for an event to be posted by the database

이전 | 처음으로 | 다음
ifxus_write_slob | 위로 | ibase_add_user


ibase_add_user

(PHP 4 >= 4.2.0, PHP 5)

ibase_add_user -- Add a user to a security database (only for IB6 or later)

Description

bool ibase_add_user ( string server, string dba_user_name, string dba_user_password, string user_name, string password [, string first_name [, string middle_name [, string last_name]]])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also ibase_modify_user() and ibase_delete_user().

이전 | 처음으로 | 다음
InterBase Functions | 위로 | ibase_affected_rows


ibase_affected_rows

(PHP 5)

ibase_affected_rows -- Return the number of rows that were affected by the previous query

Description

int ibase_affected_rows ( resource link_identifier)

This function returns the number of rows that were affected by the previous query that was executed from within the transaction context specified by link_identifier. If link_identifier is a connection resource, its default transaction is used.

See also ibase_query() and ibase_execute().

이전 | 처음으로 | 다음
ibase_add_user | 위로 | ibase_backup


ibase_backup

(PHP 5)

ibase_backup -- Initiates a backup task in the service manager and returns immediately

Description

mixed ibase_backup ( resource service_handle, string source_db, string dest_file [, int options [, bool verbose]])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ibase_affected_rows | 위로 | ibase_blob_add


ibase_blob_add

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

ibase_blob_add -- Add data into a newly created blob

Description

bool ibase_blob_add ( resource blob_handle, string data)

ibase_blob_add() adds data into a blob created with ibase_blob_create(). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also
ibase_blob_cancel(),
ibase_blob_close(),
ibase_blob_create() and
ibase_blob_import().

이전 | 처음으로 | 다음
ibase_backup | 위로 | ibase_blob_cancel


ibase_blob_cancel

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

ibase_blob_cancel -- Cancel creating blob

Description

bool ibase_blob_cancel ( resource blob_handle)

This function will discard a BLOB created by ibase_create_blob() if it has not yet been closed by ibase_blob_close(). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also
ibase_blob_close(),
ibase_blob_create() and
ibase_blob_import().

이전 | 처음으로 | 다음
ibase_blob_add | 위로 | ibase_blob_close


ibase_blob_close

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

ibase_blob_close -- Close blob

Description

mixed ibase_blob_close ( resource blob_handle)

This function closes a BLOB that has either been opened for reading by ibase_open_blob() or has been opened for writing by ibase_create_blob(). If the BLOB was being read, this function returns TRUE on success, if the BLOB was being written to, this function returns a string containing the BLOB id that has been assigned to it by the database. On failure, this function returns FALSE.

See also ibase_blob_cancel() and ibase_blob_open().

이전 | 처음으로 | 다음
ibase_blob_cancel | 위로 | ibase_blob_create


ibase_blob_create

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

ibase_blob_create -- Create a new blob for adding data

Description

resource ibase_blob_create ( [resource link_identifier])

ibase_blob_create() creates a new BLOB for filling with data. It returns a BLOB handle for later use with ibase_blob_add() or FALSE on failure.

See also
ibase_blob_add(),
ibase_blob_cancel(),
ibase_blob_close() and
ibase_blob_import().

이전 | 처음으로 | 다음
ibase_blob_close | 위로 | ibase_blob_echo


ibase_blob_echo

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

ibase_blob_echo -- Output blob contents to browser

Description

bool ibase_blob_echo ( string blob_id)

This function opens a BLOB for reading and sends its contents directly to standard output (the browser, in most cases). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also
ibase_blob_open(),
ibase_blob_close() and
ibase_blob_get().

이전 | 처음으로 | 다음
ibase_blob_create | 위로 | ibase_blob_get


ibase_blob_get

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

ibase_blob_get -- Get len bytes data from open blob

Description

string ibase_blob_get ( resource blob_handle, int len)

This function returns at most len bytes from a BLOB that has been opened for reading by ibase_blob_open(). Returns FALSE on failure.

<?php
    $sql       = "SELECT blob_value FROM table";
    $result    = ibase_query($sql);
    $data      = ibase_fetch_object($result);
    $blob_data = ibase_blob_info($data->BLOB_VALUE);
    $blob_hndl = ibase_blob_open($data->BLOB_VALUE);
    echo         ibase_blob_get($blob_hndl, $blob_data[0]);
?>

Whilst this example doesn't do much more than a 'ibase_blob_echo($data->BLOB_VALUE)' would do, it does show you how to get information into a $variable to manipulate as you please.

참고: It is not possible to read from a BLOB that has been opened for writing by ibase_blob_create().

See also
ibase_blob_open(),
ibase_blob_close() and
ibase_blob_echo().

이전 | 처음으로 | 다음
ibase_blob_echo | 위로 | ibase_blob_import


ibase_blob_import

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

ibase_blob_import -- Create blob, copy file in it, and close it

Description

string ibase_blob_import ( [resource link_identifier, resource file_handle])

This function creates a BLOB, reads an entire file into it, closes it and returns the assigned BLOB id. The file handle is a handle returned by fopen(). Returns FALSE on failure.

See also
ibase_blob_add(),
ibase_blob_cancel(),
ibase_blob_close() and
ibase_blob_create().

이전 | 처음으로 | 다음
ibase_blob_get | 위로 | ibase_blob_info


ibase_blob_info

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

ibase_blob_info -- Return blob length and other useful info

Description

array ibase_blob_info ( string blob_id)

Returns an array containing information about a BLOB. The information returned consists of the length of the BLOB, the number of segments it contains, the size of the largest segment, and whether it is a stream BLOB or a segmented BLOB.

이전 | 처음으로 | 다음
ibase_blob_import | 위로 | ibase_blob_open


ibase_blob_open

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

ibase_blob_open -- Open blob for retrieving data parts

Description

resource ibase_blob_open ( string blob_id)

ibase_blob_open() opens an existing BLOB for reading. It returns a BLOB handle for later use with ibase_blob_get() or FALSE on failure.

See also
ibase_blob_close(),
ibase_blob_echo() and
ibase_blob_get().

이전 | 처음으로 | 다음
ibase_blob_info | 위로 | ibase_close


ibase_close

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

ibase_close -- Close a connection to an InterBase database

Description

bool ibase_close ( [resource connection_id])

Closes the link to an InterBase database that's associated with a connection id returned from ibase_connect(). If the connection id is omitted, the last opened link is assumed. Default transaction on link is committed, other transactions are rolled back. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also ibase_connect() and ibase_pconnect().

이전 | 처음으로 | 다음
ibase_blob_open | 위로 | ibase_commit_ret


ibase_commit_ret

(PHP 5)

ibase_commit_ret -- Commit a transaction without closing it

Description

bool ibase_commit_ret ( [resource link_identifier])

If called without an argument, this function commits the default transaction of the default link. If the argument is a connection identifier, the default transaction of the corresponding connection will be committed. If the argument is a transaction identifier, the corresponding transaction will be committed. The transaction context will be retained, so statements executed from within this transaction will not be invalidated. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ibase_close | 위로 | ibase_commit


ibase_commit

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

ibase_commit -- Commit a transaction

Description

bool ibase_commit ( [resource link_identifier])

If called without an argument, this function commits the default transaction of the default link. If the argument is a connection identifier, the default transaction of the corresponding connection will be committed. If the argument is a transaction identifier, the corresponding transaction will be committed. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ibase_commit_ret | 위로 | ibase_connect


ibase_connect

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

ibase_connect -- Open a connection to an InterBase database

Description

resource ibase_connect ( string database [, string username [, string password [, string charset [, int buffers [, int dialect [, string role]]]]]])

Establishes a connection to an InterBase server. The database argument has to be a valid path to database file on the server it resides on. If the server is not local, it must be prefixed with either 'hostname:' (TCP/IP), '//hostname/' (NetBEUI) or 'hostname@' (IPX/SPX), depending on the connection protocol used. username and password can also be specified with PHP configuration directives ibase.default_user and ibase.default_password. charset is the default character set for a database. buffers is the number of database buffers to allocate for the server-side cache. If 0 or omitted, server chooses its own default. dialect selects the default SQL dialect for any statement executed within a connection, and it defaults to the highest one supported by client libraries.

In case a second call is made to ibase_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned. The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling ibase_close().

예 1. ibase_connect() example

<?php
    $host = 'localhost:/path/to/your.gdb';

    $dbh = ibase_connect($host, $username, $password);
    $stmt = 'SELECT * FROM tblname';
    $sth = ibase_query($dbh, $stmt);
    while ($row = ibase_fetch_object($sth)) {
        echo $row->email, "\n";
    }
    ibase_free_result($sth);
    ibase_close($dbh);
?>

참고: The optional buffers parameter was added in PHP 4.0.0.

참고: The optional dialect parameter was added in PHP 4.0.0 and is functional only with InterBase 6 and up.

참고: The optional role parameter was added in PHP 4.0.0 and is functional only with InterBase 5 and up.

참고: If you get some error like "arithmetic exception, numeric overflow, or string truncation. Cannot transliterate character between character sets" (this occurs when you try use some character with accents) when using this and after ibase_query() you must set the character set (i.e. ISO8859_1 or your current character set).

See also ibase_pconnect() and ibase_close().

이전 | 처음으로 | 다음
ibase_commit | 위로 | ibase_db_info


ibase_db_info

(PHP 5)

ibase_db_info -- Request statistics about a database

Description

string ibase_db_info ( resource service_handle, string db, int action [, int argument])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ibase_connect | 위로 | ibase_delete_user


ibase_delete_user

(PHP 4 >= 4.2.0, PHP 5)

ibase_delete_user -- Delete a user from a security database (only for IB6 or later)

Description

bool ibase_delete_user ( string server, string dba_user_name, string dba_user_password, string user_name)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also ibase_add_user() and ibase_modify_user().

이전 | 처음으로 | 다음
ibase_db_info | 위로 | ibase_drop_db


ibase_drop_db

(PHP 5)

ibase_drop_db -- Drops a database

Description

bool ibase_drop_db ( resource connection)

This functions drops a database that was opened by either ibase_connect() or ibase_pconnect(). The database is closed and deleted from the server. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also ibase_connect() and ibase_pconnect().

이전 | 처음으로 | 다음
ibase_delete_user | 위로 | ibase_errcode


ibase_errcode

(PHP 5)

ibase_errcode -- Return an error code

Description

int ibase_errcode ( void )

Returns the error code that resulted from the most recent InterBase function call. Returns FALSE if no error occurred.

See also ibase_errmsg().

이전 | 처음으로 | 다음
ibase_drop_db | 위로 | ibase_errmsg


ibase_errmsg

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

ibase_errmsg -- Return error messages

Description

string ibase_errmsg ( void )

Returns the error message that resulted from the most recent InterBase function call. Returns FALSE if no error occurred.

See also ibase_errcode().

이전 | 처음으로 | 다음
ibase_errcode | 위로 | ibase_execute


ibase_execute

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

ibase_execute -- Execute a previously prepared query

Description

resource ibase_execute ( resource query [, int bind_args])

Execute a query prepared by ibase_prepare(). If the query raises an error, returns FALSE. If it is successful and there is a (possibly empty) result set (such as with a SELECT query), returns a result identifier. If the query was successful and there were no results, returns TRUE.

This is a lot more effective than using ibase_query() if you are repeating a same kind of query several times with only some parameters changing.

예 1. ibase_execute() example

<?php

    $dbh = ibase_connect($host, $username, $password);

    $updates = array(
        1 => 'Eric',
        5 => 'Filip',
        7 => 'Larry'
    );

    $query = ibase_prepare($dbh, "UPDATE FOO SET BAR = ? WHERE BAZ = ?");

    while (list($baz, $bar) = each($updates)) {
        ibase_execute($query, $bar, $baz);
    }
?>

참고: In PHP 5.0.0 and up, this function returns the number of rows affected by the query (if > 0 and applicable to the statement type). A query that succeeded, but did not affect any rows (e.g. an UPDATE of a non-existent record) will return TRUE.

See also ibase_query().

이전 | 처음으로 | 다음
ibase_errmsg | 위로 | ibase_fetch_assoc


ibase_fetch_assoc

(PHP 4 >= 4.3.0, PHP 5)

ibase_fetch_assoc -- Fetch a result row from a query as an associative array

Description

array ibase_fetch_assoc ( resource result [, int fetch_flag])

ibase_fetch_assoc() returns an associative array that corresponds to the fetched row. Subsequent calls will return the next row in the result set, or FALSE if there are no more rows.

ibase_fetch_assoc() fetches one row of data from the result. If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you either need to access the result with numeric indices by using ibase_fetch_row() or use alias names in your query.

fetch_flag is a combination of the constants IBASE_TEXT and IBASE_UNIXTIME ORed together. Passing IBASE_TEXT will cause this function to return BLOB contents instead of BLOB ids. Passing IBASE_UNIXTIME will cause this function to return date/time values as Unix timestamps instead of as formatted strings.

See also ibase_fetch_row() and ibase_fetch_object().

이전 | 처음으로 | 다음
ibase_execute | 위로 | ibase_fetch_object


ibase_fetch_object

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

ibase_fetch_object -- Get an object from a InterBase database

Description

object ibase_fetch_object ( resource result_id [, int fetch_flag])

Fetches a row as a pseudo-object from a result_id obtained either by ibase_query() or ibase_execute().

<?php
    $dbh = ibase_connect($host, $username, $password);
    $stmt = 'SELECT * FROM tblname';
    $sth = ibase_query($dbh, $stmt);
    while ($row = ibase_fetch_object($sth)) {
        echo $row->email . "\n";
    }
    ibase_close($dbh);
?>

Subsequent calls to ibase_fetch_object() return the next row in the result set, or FALSE if there are no more rows.

fetch_flag is a combination of the constants IBASE_TEXT and IBASE_UNIXTIME ORed together. Passing IBASE_TEXT will cause this function to return BLOB contents instead of BLOB ids. Passing IBASE_UNIXTIME will cause this function to return date/time values as Unix timestamps instead of as formatted strings.

See also ibase_fetch_row() and ibase_fetch_assoc().

이전 | 처음으로 | 다음
ibase_fetch_assoc | 위로 | ibase_fetch_row


ibase_fetch_row

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

ibase_fetch_row -- Fetch a row from an InterBase database

Description

array ibase_fetch_row ( resource result_identifier [, int fetch_flag])

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

ibase_fetch_row() fetches one row of data from the result associated with the specified result_identifier. The row is returned as an array. Each result column is stored in an array offset, starting at offset 0.

Subsequent calls to ibase_fetch_row() return the next row in the result set, or FALSE if there are no more rows.

fetch_flag is a combination of the constants IBASE_TEXT and IBASE_UNIXTIME ORed together. Passing IBASE_TEXT will cause this function to return BLOB contents instead of BLOB ids. Passing IBASE_UNIXTIME will cause this function to return date/time values as Unix timestamps instead of as formatted strings.

See also ibase_fetch_assoc() and ibase_fetch_object().

이전 | 처음으로 | 다음
ibase_fetch_object | 위로 | ibase_field_info


ibase_field_info

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

ibase_field_info -- Get information about a field

Description

array ibase_field_info ( resource result, int field_number)

Returns an array with information about a field after a select query has been run. The array is in the form of name, alias, relation, length, type.

<?php
    $rs = ibase_query("SELECT * FROM tablename");
    $coln = ibase_num_fields($rs);
    for ($i = 0; $i < $coln; $i++) {
        $col_info = ibase_field_info($rs, $i);
        echo "name: ". $col_info['name']. "\n";
        echo "alias: ". $col_info['alias']. "\n";
        echo "relation: ". $col_info['relation']. "\n";
        echo "length: ". $col_info['length']. "\n";
        echo "type: ". $col_info['type']. "\n";
    }
?>

See also: ibase_num_fields().

이전 | 처음으로 | 다음
ibase_fetch_row | 위로 | ibase_free_event_handler


ibase_free_event_handler

(PHP 5)

ibase_free_event_handler -- Cancels a registered event handler

Description

bool ibase_free_event_handler ( resource event)

This function causes the registered event handler specified by event to be cancelled. The callback function will no longer be called for the events it was registered to handle. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also ibase_set_event_handler().

이전 | 처음으로 | 다음
ibase_field_info | 위로 | ibase_free_query


ibase_free_query

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

ibase_free_query -- Free memory allocated by a prepared query

Description

bool ibase_free_query ( resource query)

Free a query prepared by ibase_prepare(). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ibase_free_event_handler | 위로 | ibase_free_result


ibase_free_result

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

ibase_free_result -- Free a result set

Description

bool ibase_free_result ( resource result_identifier)

Frees a result set that has been created by ibase_query() or ibase_execute(). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ibase_free_query | 위로 | ibase_gen_id


ibase_gen_id

(PHP 5)

ibase_gen_id -- Increments the named generator and returns its new value

Description

int ibase_gen_id ( [resource link_identifier [, string generator [, int increment]]])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ibase_free_result | 위로 | ibase_maintain_db


ibase_maintain_db

(PHP 5)

ibase_maintain_db -- Execute a maintenance command on the database server

Description

bool ibase_maintain_db ( resource service_handle, string db, int action [, int argument])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ibase_gen_id | 위로 | ibase_modify_user


ibase_modify_user

(PHP 4 >= 4.2.0, PHP 5)

ibase_modify_user -- Modify a user to a security database (only for IB6 or later)

Description

bool ibase_modify_user ( string server, string dba_user_name, string dba_user_password, string user_name, string password [, string first_name [, string middle_name [, string last_name]]])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also ibase_add_user() and ibase_delete_user().

이전 | 처음으로 | 다음
ibase_maintain_db | 위로 | ibase_name_result


ibase_name_result

(PHP 5)

ibase_name_result -- Assigns a name to a result set

Description

bool ibase_name_result ( resource result, string name)

This function assigns a name to a result set. This name can be used later in UPDATE|DELETE ... WHERE CURRENT OF name statements. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

<?php
$result = ibase_query("SELECT field1,field2 FROM table FOR UPDATE");
    ibase_name_result($result, "my_cursor");

    $updateqry = ibase_prepare("UPDATE table SET field2 = ? WHERE CURRENT OF my_cursor");

    for ($i = 0; ibase_fetch_row($result); ++$i) {
        ibase_execute($updateqry, $i);
    }
?>

See also ibase_prepare() and ibase_execute().

이전 | 처음으로 | 다음
ibase_modify_user | 위로 | ibase_num_fields


ibase_num_fields

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

ibase_num_fields -- Get the number of fields in a result set

Description

int ibase_num_fields ( resource result_id)

Returns an integer containing the number of fields in a result set.

<?php
    $rs = ibase_query("SELECT * FROM tablename");
    $coln = ibase_num_fields($rs);
    for ($i = 0; $i < $coln; $i++) {
        $col_info = ibase_field_info($rs, $i);
        echo "name: " . $col_info['name'] . "\n";
        echo "alias: " . $col_info['alias'] . "\n";
        echo "relation: " . $col_info['relation'] . "\n";
        echo "length: " . $col_info['length'] . "\n";
        echo "type: " . $col_info['type'] . "\n";
    }
?>

See also: ibase_field_info().

이전 | 처음으로 | 다음
ibase_name_result | 위로 | ibase_num_params


ibase_num_params

(PHP 5)

ibase_num_params -- Return the number of parameters in a prepared query

Description

int ibase_num_params ( resource query)

This function returns the number of parameters in the prepared query specified by query. This is the number of binding arguments that must be present when calling ibase_execute().

See also ibase_prepare() and ibase_param_info().

이전 | 처음으로 | 다음
ibase_num_fields | 위로 | ibase_param_info


ibase_param_info

(PHP 5)

ibase_param_info -- Return information about a parameter in a prepared query

Description

array ibase_param_info ( resource query, int param_number)

Returns an array with information about a parameter after a query has been prepared. The array is in the form of name, alias, relation, length, type.

See also ibase_field_info() and ibase_num_params().

이전 | 처음으로 | 다음
ibase_num_params | 위로 | ibase_pconnect


ibase_pconnect

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

ibase_pconnect -- Open a persistent connection to an InterBase database

Description

resource ibase_pconnect ( string database [, string username [, string password [, string charset [, int buffers [, int dialect [, string role]]]]]])

ibase_pconnect() acts very much like ibase_connect() with two major differences. First, when connecting, the function will first try to find a (persistent) link that's already opened with the same parameters. If one is found, an identifier for it will be returned instead of opening a new connection. Second, the connection to the InterBase server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (ibase_close() will not close links established by ibase_pconnect()). This type of link is therefore called 'persistent'.

참고: buffers was added in PHP4-RC2.

참고: dialect was added in PHP4-RC2. It is functional only with InterBase 6 and versions higher than that.

참고: role was added in PHP4-RC2. It is functional only with InterBase 5 and versions higher than that.

See also ibase_close() and ibase_connect() for the meaning of parameters passed to this function. They are exactly the same.

이전 | 처음으로 | 다음
ibase_param_info | 위로 | ibase_prepare


ibase_prepare

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

ibase_prepare -- Prepare a query for later binding of parameter placeholders and execution

Description

resource ibase_prepare ( [resource link_identifier, string query])

Prepare a query for later binding of parameter placeholders and execution (via ibase_execute()).

이전 | 처음으로 | 다음
ibase_pconnect | 위로 | ibase_query


ibase_query

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

ibase_query -- Execute a query on an InterBase database

Description

resource ibase_query ( [resource link_identifier, string query [, int bind_args]])

Performs a query on an InterBase database. If the query raises an error, returns FALSE. If it is successful and there is a (possibly empty) result set (such as with a SELECT query), returns a result identifier. If the query was successful and there were no results, returns TRUE.

예 1. ibase_query() example

<?php

    $host = 'localhost:/path/to/your.gdb';

    $dbh = ibase_connect($host, $username, $password);
    $stmt = 'SELECT * FROM tblname';

    $sth = ibase_query($dbh, $stmt) or die(ibase_errmsg());

?>

참고: In PHP 5.0.0 and up, this function will return the number of rows affected by the query for INSERT, UPDATE and DELETE statements. In order to retain backward compatibility, it will return TRUE for these statements if the query succeeded without affecting any rows.

참고: If you get some error like "arithmetic exception, numeric overflow, or string truncation. Cannot transliterate character between character sets" (this occurs when you try use some character with accents) when using this and after ibase_query() you must set the character set (i.e. ISO8859_1 or your current character set).

See also ibase_errmsg(),
ibase_fetch_row(),
ibase_fetch_object(), and
ibase_free_result().

이전 | 처음으로 | 다음
ibase_prepare | 위로 | ibase_restore


ibase_restore

(PHP 5)

ibase_restore -- Initiates a restore task in the service manager and returns immediately

Description

mixed ibase_restore ( resource service_handle, string source_file, string dest_db [, int options [, bool verbose]])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ibase_query | 위로 | ibase_rollback_ret


ibase_rollback_ret

(PHP 5)

ibase_rollback_ret -- Roll back a transaction without closing it

Description

bool ibase_rollback_ret ( [resource link_identifier])

If called without an argument, this function rolls back the default transaction of the default link. If the argument is a connection identifier, the default transaction of the corresponding connection will be rolled back. If the argument is a transaction identifier, the corresponding transaction will be rolled back. The transaction context will be retained, so statements executed from within this transaction will not be invalidated. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ibase_restore | 위로 | ibase_rollback


ibase_rollback

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

ibase_rollback -- Roll back a transaction

Description

bool ibase_rollback ( [resource link_identifier])

If called without an argument, this function rolls back the default transaction of the default link. If the argument is a connection identifier, the default transaction of the corresponding connection will be rolled back. If the argument is a transaction identifier, the corresponding transaction will be rolled back. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ibase_rollback_ret | 위로 | ibase_server_info


ibase_server_info

(PHP 5)

ibase_server_info -- Request information about a database server

Description

string ibase_server_info ( resource service_handle, int action)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ibase_rollback | 위로 | ibase_service_attach


ibase_service_attach

(PHP 5)

ibase_service_attach -- Connect to the service manager

Description

resource ibase_service_attach ( string host, string dba_username, string dba_password)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ibase_server_info | 위로 | ibase_service_detach


ibase_service_detach

(PHP 5)

ibase_service_detach -- Disconnect from the service manager

Description

bool ibase_service_detach ( resource service_handle)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ibase_service_attach | 위로 | ibase_set_event_handler


ibase_set_event_handler

(PHP 5)

ibase_set_event_handler -- Register a callback function to be called when events are posted

Description

resource ibase_set_event_handler ( [resource connection, callback event_handler, string event_name1 [, string event_name2 [, string ...]]])

This function registers a PHP user function as event handler for the specified events. The callback is called with the event name and the link resource as arguments whenever one of the specified events is posted by the database. The callback must return FALSE if the event handler should be canceled. Any other return value is ignored.

<?php

function event_handler($event_name, $link)
{
    if ($event_name=="NEW ORDER") {
        // process new order
        ibase_query($link, "UPDATE orders SET status='handled'");
    } else if ($event_name=="DB_SHUTDOWN") {
        // free event handler
        return false;
    }
}

ibase_set_event_handler($link, "event_handler", "NEW_ORDER", "DB_SHUTDOWN");
?>

The return value is an event resource. This resource can be used to free the event handler using ibase_free_event_handler().

See also ibase_free_event_handler() and ibase_wait_event().

이전 | 처음으로 | 다음
ibase_service_detach | 위로 | ibase_timefmt


ibase_timefmt

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

ibase_timefmt -- Sets the format of timestamp, date and time type columns returned from queries

Description

int ibase_timefmt ( string format [, int columntype])

Sets the format of timestamp, date or time type columns returned from queries. Internally, the columns are formatted by c-function strftime(), so refer to its documentation regarding to the format of the string. columntype is one of the constants IBASE_TIMESTAMP, IBASE_DATE and IBASE_TIME. If omitted, defaults to IBASE_TIMESTAMP for backwards compatibility.

<?php
    /* InterBase 6 TIME-type columns will be returned in
     * the form '05 hours 37 minutes'. */
    ibase_timefmt("%H hours %M minutes", IBASE_TIME);
?>

You can also set defaults for these formats with PHP configuration directives ibase.timestampformat, ibase.dateformat and ibase.timeformat.

참고: columntype was added in PHP 4.0. It has any meaning only with InterBase version 6 and higher.

참고: A backwards incompatible change happened in PHP 4.0 when PHP configuration directive ibase.timeformat was renamed to ibase.timestampformat and directives ibase.dateformat and ibase.timeformat were added, so that the names would match better their functionality.

이전 | 처음으로 | 다음
ibase_set_event_handler | 위로 | ibase_trans


ibase_trans

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

ibase_trans -- Begin a transaction

Description

resource ibase_trans ( [int trans_args [, resource link_identifier]])

Begins a transaction.

trans_args can be a combination of IBASE_READ, IBASE_WRITE, IBASE_COMMITTED, IBASE_CONSISTENCY, IBASE_CONCURRENCY, IBASE_REC_VERSION, IBASE_REC_NO_VERSION, IBASE_WAIT and IBASE_NOWAIT.

참고: The behaviour of this function has been changed in PHP 5.0.0. The first call to ibase_trans() will not return the default transaction of a connection. All transactions started by ibase_trans() will be rolled back at the end of the script if they were not committed or rolled back by either ibase_commit() or ibase_rollback().

참고: In PHP 5.0.0. and up, this function will accept multiple trans_args and link_identifier arguments. This allows transactions over multiple database connections, which are committed using a 2-phase commit algorithm. This means you can rely on the updates to either succeed in every database, or fail in every database. It does NOT mean you can use tables from different databases in the same query!

If you use transactions over multiple databases, you will have to specify both the link_id and transaction_id in calls to ibase_query() and ibase_prepare().

이전 | 처음으로 | 다음
ibase_timefmt | 위로 | ibase_wait_event


ibase_wait_event

(PHP 5)

ibase_wait_event -- Wait for an event to be posted by the database

Description

string ibase_wait_event ( [resource connection, string event_name1 [, string event_name2 [, string ...]]])

This function suspends execution of the script until one of the specified events is posted by the database. The name of the event that was posted is returned. This function accepts up to 15 event arguments.

See also ibase_set_event_handler() and ibase_free_event_handler().

이전 | 처음으로 | 다음
ibase_trans | 위로 | Ingres II Functions


Ingres II Functions

PHP 매뉴얼
이전 다음

XLV. Ingres II Functions

소개

These functions allow you to access Ingres II database servers.

참고: If you already used PHP extensions to access other database servers, note that Ingres doesn't allow concurrent queries and/or transaction over one connection, thus you won't find any result or transaction handle in this extension. The result of a query must be treated before sending another query, and a transaction must be committed or rolled back before opening another transaction (which is automatically done when sending the first query).

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

요구 사항

To compile PHP with Ingres support, you need the Open API library and header files included with Ingres II.

설치

In order to have these functions available, you must compile PHP with Ingres support by using the --with-ingres[=DIR] option, where DIR is the Ingres base directory, which defaults to /II/ingres. If the II_SYSTEM environment variable isn't correctly set you may have to use --with-ingres=DIR to specify your Ingres installation directory.

When using this extension with Apache, if Apache does not start and complains with "PHP Fatal error: Unable to start ingres_ii module in Unknown on line 0" then make sure the environment variable II_SYSTEM is correctly set. Adding "export II_SYSTEM="/home/ingres/II" in the script that starts Apache, just before launching httpd, should be fine.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. Ingres II configuration options

Name | Default | Changeable
ingres.allow_persistent | "1" | PHP_INI_SYSTEM
ingres.max_persistent | "-1" | PHP_INI_SYSTEM
ingres.max_links | "-1" | PHP_INI_SYSTEM
ingres.default_database | NULL | PHP_INI_ALL
ingres.default_user | NULL | PHP_INI_ALL
ingres.default_password | NULL | PHP_INI_ALL
For further details and definition of the PHP_INI_* constants see ini_set().

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

INGRES_ASSOC (integer)

INGRES_NUM (integer)

INGRES_BOTH (integer)

차례
ingres_autocommit -- Switch autocommit on or off
ingres_close -- Close an Ingres II database connection
ingres_commit -- Commit a transaction
ingres_connect -- Open a connection to an Ingres II database
ingres_fetch_array -- Fetch a row of result into an array
ingres_fetch_object -- Fetch a row of result into an object.
ingres_fetch_row -- Fetch a row of result into an enumerated array
ingres_field_length -- Get the length of a field
ingres_field_name -- Get the name of a field in a query result.
ingres_field_nullable -- Test if a field is nullable
ingres_field_precision -- Get the precision of a field
ingres_field_scale -- Get the scale of a field
ingres_field_type -- Get the type of a field in a query result
ingres_num_fields -- Get the number of fields returned by the last query
ingres_num_rows -- Get the number of rows affected or returned by the last query
ingres_pconnect -- Open a persistent connection to an Ingres II database
ingres_query -- Send a SQL query to Ingres II
ingres_rollback -- Roll back a transaction

이전 | 처음으로 | 다음
ibase_wait_event | 위로 | ingres_autocommit


ingres_autocommit

(PHP 4 >= 4.0.2, PHP 5)

ingres_autocommit -- Switch autocommit on or off

Description

bool ingres_autocommit ( [resource link])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ingres_autocommit() is called before opening a transaction (before the first call to ingres_query() or just after a call to ingres_rollback() or ingres_commit()) to switch the "autocommit" mode of the server on or off (when the script begins the autocommit mode is off).

When the autocommit mode is on, every query is automatically committed by the server, as if ingres_commit() was called after every call to ingres_query().

See also
ingres_query(),
ingres_rollback(), and
ingres_commit().

이전 | 처음으로 | 다음
Ingres II Functions | 위로 | ingres_close


ingres_close

(PHP 4 >= 4.0.2, PHP 5)

ingres_close -- Close an Ingres II database connection

Description

bool ingres_close ( [resource link])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Returns TRUE on success, or FALSE on failure.

ingres_close() closes the connection to the Ingres server that's associated with the specified link. If the link parameter isn't specified, the last opened link is used.

ingres_close() isn't usually necessary, as it won't close persistent connections and all non-persistent connections are automatically closed at the end of the script.

See also ingres_connect() and ingres_pconnect().

이전 | 처음으로 | 다음
ingres_autocommit | 위로 | ingres_commit


ingres_commit

(PHP 4 >= 4.0.2, PHP 5)

ingres_commit -- Commit a transaction

Description

bool ingres_commit ( [resource link])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ingres_commit() commits the currently open transaction, making all changes made to the database permanent.

This closes the transaction. A new one can be open by sending a query with ingres_query().

You can also have the server commit automatically after every query by calling ingres_autocommit() before opening the transaction.

See also
ingres_query(),
ingres_rollback(), and
ingres_autocommit().

이전 | 처음으로 | 다음
ingres_close | 위로 | ingres_connect


ingres_connect

(PHP 4 >= 4.0.2, PHP 5)

ingres_connect -- Open a connection to an Ingres II database

Description

resource ingres_connect ( [string database [, string username [, string password]]])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Returns a Ingres II link resource on success, or FALSE on failure.

ingres_connect() opens a connection with the Ingres database designated by database, which follows the syntax [node_id::]dbname[/svr_class].

If some parameters are missing, ingres_connect() uses the values in php.ini for ingres.default_database, ingres.default_user, and ingres.default_password.

The connection is closed when the script ends or when ingres_close() is called on this link.

All the other ingres functions use the last opened link as a default, so you need to store the returned value only if you use more than one link at a time.

예 1. ingres_connect() example

<?php
    $link = ingres_connect("mydb", "user", "pass")
        or die("Could not connect");
    echo "Connected successfully";
    ingres_close($link);
?>

예 2. ingres_connect() example using default link

<?php
    ingres_connect("mydb", "user", "pass")
        or die("Could not connect");
    echo "Connected successfully";
    ingres_close();
?>

See also ingres_pconnect() and ingres_close().

이전 | 처음으로 | 다음
ingres_commit | 위로 | ingres_fetch_array


ingres_fetch_array

(PHP 4 >= 4.0.2, PHP 5)

ingres_fetch_array -- Fetch a row of result into an array

Description

array ingres_fetch_array ( [int result_type [, resource link]])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ingres_fetch_array() Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

This function is an extended version of ingres_fetch_row(). In addition to storing the data in the numeric indices of the result array, it also stores the data in associative indices, using the field names as keys.

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you must use the numeric index of the column or make an alias for the column.

<?php

ingres_query("select t1.f1 as foo t2.f1 as bar from t1, t2");
$result = ingres_fetch_array();
$foo = $result["foo"];
$bar = $result["bar"];

?>

result_type can be INGRES_NUM for enumerated array, INGRES_ASSOC for associative array, or INGRES_BOTH (default).

Speed-wise, the function is identical to ingres_fetch_object(), and almost as quick as ingres_fetch_row() (the difference is insignificant).

예 1. ingres_fetch_array() example

<?php
ingres_connect($database, $user, $password);

ingres_query("select * from table");
while ($row = ingres_fetch_array()) {
    echo $row["user_id"];  // using associative array
    echo $row["fullname"];
    echo $row[1];          // using enumerated array
    echo $row[2];
}
?>

See also
ingres_query(),
ingres_num_fields(),
ingres_field_name(),
ingres_fetch_object(), and
ingres_fetch_row().

이전 | 처음으로 | 다음
ingres_connect | 위로 | ingres_fetch_object


ingres_fetch_object

(PHP 4 >= 4.0.2, PHP 5)

ingres_fetch_object -- Fetch a row of result into an object.

Description

object ingres_fetch_object ( [int result_type [, resource link]])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ingres_fetch_object() Returns an object that corresponds to the fetched row, or FALSE if there are no more rows.

This function is similar to ingres_fetch_array(), with one difference - an object is returned, instead of an array. Indirectly, that means that you can only access the data by the field names, and not by their offsets (numbers are illegal property names).

The optional argument result_type is a constant and can take the following values: INGRES_ASSOC, INGRES_NUM, and INGRES_BOTH.

Speed-wise, the function is identical to ingres_fetch_array(), and almost as quick as ingres_fetch_row() (the difference is insignificant).

예 1. ingres_fetch_object() example

<?php
ingres_connect($database, $user, $password);
ingres_query("select * from table");
while ($row = ingres_fetch_object()) {
    echo $row->user_id;
    echo $row->fullname;
}
?>

See also
ingres_query(),
ingres_num_fields(),
ingres_field_name(),
ingres_fetch_array(), and
ingres_fetch_row().

이전 | 처음으로 | 다음
ingres_fetch_array | 위로 | ingres_fetch_row


ingres_fetch_row

(PHP 4 >= 4.0.2, PHP 5)

ingres_fetch_row -- Fetch a row of result into an enumerated array

Description

array ingres_fetch_row ( [resource link])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ingres_fetch_row() returns an array that corresponds to the fetched row, or FALSE if there are no more rows. Each result column is stored in an array offset, starting at offset 1.

Subsequent call to ingres_fetch_row() would return the next row in the result set, or FALSE if there are no more rows.

예 1. ingres_fetch_row() example

<?php
ingres_connect($database, $user, $password);

ingres_query("select * from table");
while ($row = ingres_fetch_row()) {
    echo $row[1];
    echo $row[2];
}
?>

See also
ingres_num_fields(),
ingres_query(),
ingres_fetch_array(), and
ingres_fetch_object().

이전 | 처음으로 | 다음
ingres_fetch_object | 위로 | ingres_field_length


ingres_field_length

(PHP 4 >= 4.0.2, PHP 5)

ingres_field_length -- Get the length of a field

Description

int ingres_field_length ( int index [, resource link])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ingres_field_length() returns the length of a field. This is the number of bytes used by the server to store the field. For detailed information, see the Ingres/OpenAPI User Guide - Appendix C.

index is the number of the field and must be between 1 and the value given by ingres_num_fields().

See also
ingres_query(),
ingres_fetch_array(),
ingres_fetch_object(), and
ingres_fetch_row().

이전 | 처음으로 | 다음
ingres_fetch_row | 위로 | ingres_field_name


ingres_field_name

(PHP 4 >= 4.0.2, PHP 5)

ingres_field_name -- Get the name of a field in a query result.

Description

string ingres_field_name ( int index [, resource link])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ingres_field_name() returns the name of a field in a query result, or FALSE on failure.

index is the number of the field and must be between 1 and the value given by ingres_num_fields().

See also
ingres_query(),
ingres_fetch_array(),
ingres_fetch_object() and
ingres_fetch_row().

이전 | 처음으로 | 다음
ingres_field_length | 위로 | ingres_field_nullable


ingres_field_nullable

(PHP 4 >= 4.0.2, PHP 5)

ingres_field_nullable -- Test if a field is nullable

Description

bool ingres_field_nullable ( int index [, resource link])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ingres_field_nullable() returns TRUE if the field can be set to the NULL value and FALSE if it can't.

index is the number of the field and must be between 1 and the value given by ingres_num_fields().

See also
ingres_query(),
ingres_fetch_array(),
ingres_fetch_object(), and
ingres_fetch_row().

이전 | 처음으로 | 다음
ingres_field_name | 위로 | ingres_field_precision


ingres_field_precision

(PHP 4 >= 4.0.2, PHP 5)

ingres_field_precision -- Get the precision of a field

Description

int ingres_field_precision ( int index [, resource link])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ingres_field_precision() returns the precision of a field. This value is used only for decimal, float and money SQL data types. For detailed information, see the Ingres/OpenAPI User Guide - Appendix C.

index is the number of the field and must be between 1 and the value given by ingres_num_fields().

See also
ingres_query(),
ingres_fetch_array(),
ingres_fetch_object(), and
ingres_fetch_row().

이전 | 처음으로 | 다음
ingres_field_nullable | 위로 | ingres_field_scale


ingres_field_scale

(PHP 4 >= 4.0.2, PHP 5)

ingres_field_scale -- Get the scale of a field

Description

int ingres_field_scale ( int index [, resource link])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ingres_field_scale() returns the scale of a field. This value is used only for the decimal SQL data type. For detailed information, see the Ingres/OpenAPI User Guide - Appendix C.

index is the number of the field and must be between 1 and the value given by ingres_num_fields().

See also
ingres_query(),
ingres_fetch_array(),
ingres_fetch_object(), and
ingres_fetch_row().

이전 | 처음으로 | 다음
ingres_field_precision | 위로 | ingres_field_type


ingres_field_type

(PHP 4 >= 4.0.2, PHP 5)

ingres_field_type -- Get the type of a field in a query result

Description

string ingres_field_type ( int index [, resource link])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ingres_field_type() returns the type of a field in a query result, or FALSE on failure. Examples of types returned are "IIAPI_BYTE_TYPE", "IIAPI_CHA_TYPE", "IIAPI_DTE_TYPE", "IIAPI_FLT_TYPE", "IIAPI_INT_TYPE", "IIAPI_VCH_TYPE". Some of these types can map to more than one SQL type depending on the length of the field (see ingres_field_length()). For example "IIAPI_FLT_TYPE" can be a float4 or a float8. For detailed information, see the Ingres/OpenAPI User Guide - Appendix C.

index is the number of the field and must be between 1 and the value given by ingres_num_fields().

See also
ingres_query(),
ingres_fetch_array(),
ingres_fetch_object(), and
ingres_fetch_row().

이전 | 처음으로 | 다음
ingres_field_scale | 위로 | ingres_num_fields


ingres_num_fields

(PHP 4 >= 4.0.2, PHP 5)

ingres_num_fields -- Get the number of fields returned by the last query

Description

int ingres_num_fields ( [resource link])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ingres_num_fields() returns the number of fields in the results returned by the Ingres server after a call to ingres_query()

See also
ingres_query(),
ingres_fetch_array(),
ingres_fetch_object(), and
ingres_fetch_row().

이전 | 처음으로 | 다음
ingres_field_type | 위로 | ingres_num_rows


ingres_num_rows

(PHP 4 >= 4.0.2, PHP 5)

ingres_num_rows -- Get the number of rows affected or returned by the last query

Description

int ingres_num_rows ( [resource link])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

For delete, insert or update queries, ingres_num_rows() returns the number of rows affected by the query. For other queries, ingres_num_rows() returns the number of rows in the query's result.

참고: This function is mainly meant to get the number of rows modified in the database. If this function is called before using ingres_fetch_array(), ingres_fetch_object() or ingres_fetch_row() the server will delete the result's data and the script won't be able to get them.

You should instead retrieve the result's data using one of these fetch functions in a loop until it returns FALSE, indicating that no more results are available.

See also
ingres_query(),
ingres_fetch_array(),
ingres_fetch_object(), and
ingres_fetch_row().

이전 | 처음으로 | 다음
ingres_num_fields | 위로 | ingres_pconnect


ingres_pconnect

(PHP 4 >= 4.0.2, PHP 5)

ingres_pconnect -- Open a persistent connection to an Ingres II database

Description

resource ingres_pconnect ( [string database [, string username [, string password]]])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Returns a Ingres II link resource on success, or FALSE on failure.

See ingres_connect() for parameters details and examples. There are only 2 differences between ingres_pconnect() and ingres_connect() : First, when connecting, the function will first try to find a (persistent) link that's already opened with the same parameters. If one is found, an identifier for it will be returned instead of opening a new connection. Second, the connection to the Ingres server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (ingres_close() will not close links established by ingres_pconnect()). This type of link is therefore called 'persistent'.

See also ingres_connect() and ingres_close().

이전 | 처음으로 | 다음
ingres_num_rows | 위로 | ingres_query


ingres_query

(PHP 4 >= 4.0.2, PHP 5)

ingres_query -- Send a SQL query to Ingres II

Description

bool ingres_query ( string query [, resource link])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Returns TRUE on success, or FALSE on failure.

ingres_query() sends the given query to the Ingres server. This query must be a valid SQL query (see the Ingres SQL reference guide)

The query becomes part of the currently open transaction. If there is no open transaction, ingres_query() opens a new transaction. To close the transaction, you can either call ingres_commit() to commit the changes made to the database or ingres_rollback() to cancel these changes. When the script ends, any open transaction is rolled back (by calling ingres_rollback()). You can also use ingres_autocommit() before opening a new transaction to have every SQL query immediately committed.

Some types of SQL queries can't be sent with this function:

  • close (see ingres_close())

  • commit (see ingres_commit())

  • connect (see ingres_connect())

  • disconnect (see ingres_close())

  • get dbevent

  • prepare to commit

  • rollback (see ingres_rollback())

  • savepoint

  • set autocommit (see ingres_autocommit())

  • all cursor related queries are unsupported

예 1. ingres_query() example

<?php
ingres_connect($database, $user, $password);

ingres_query("select * from table");
while ($row = ingres_fetch_row()) {
    echo $row[1];
    echo $row[2];
}
?>

See also
ingres_fetch_array(),
ingres_fetch_object(),
ingres_fetch_row(),
ingres_commit(),
ingres_rollback(), and
ingres_autocommit().

이전 | 처음으로 | 다음
ingres_pconnect | 위로 | ingres_rollback


ingres_rollback

(PHP 4 >= 4.0.2, PHP 5)

ingres_rollback -- Roll back a transaction

Description

bool ingres_rollback ( [resource link])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ingres_rollback() rolls back the currently open transaction, actually canceling all changes made to the database during the transaction.

This closes the transaction. A new one can be open by sending a query with ingres_query().

See also
ingres_query(),
ingres_commit(), and
ingres_autocommit().

이전 | 처음으로 | 다음
ingres_query | 위로 | IRC Gateway Functions


IRC Gateway Functions

PHP 매뉴얼
이전 다음

XLVI. IRC Gateway Functions

소개

With IRCG you can rapidly stream XML data to thousands of concurrently connected users. This can be used to build powerful, extensible interactive platforms such as online games and webchats. IRCG also features support for a non-streaming mode where a helper application reformats incoming data and supplies static file snippets in special formats such as cHTML (i-mode) or WML (WAP). These static files are then delivered by the high-performance web server.

Up to v4, IRCG runs under these platforms:

  • AIX

  • FreeBSD

  • HP-UX

  • Irix

  • Linux

  • Solaris

  • Tru64

  • Windows

설치

Detailed installation instructions can be found at http://www.schumann.cx/ircg/. We urge you to use the provided installation script.

It is not recommended, but you can try enable IRCG support yourself. Provide the path to the ircg-config script, --with-ircg-config=path/to/irc-config and in addition add --with-ircg to your configure line.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
ircg_channel_mode -- Set channel mode flags for user
ircg_disconnect -- Close connection to server
ircg_fetch_error_msg -- Returns the error from previous IRCG operation
ircg_get_username -- Get username for connection
ircg_html_encode -- Encodes HTML preserving output
ircg_ignore_add -- Add a user to your ignore list on a server
ircg_ignore_del -- Remove a user from your ignore list on a server
ircg_invite -- Invites nickname to channel
ircg_is_conn_alive -- Check connection status
ircg_join -- Join a channel on a connected server
ircg_kick -- Kick a user out of a channel on server
ircg_list -- List topic/user count of channel(s)
ircg_lookup_format_messages -- Check for the existence of a format message set
ircg_lusers -- IRC network statistics
ircg_msg -- Send message to channel or user on server
ircg_nick -- Change nickname on server
ircg_nickname_escape -- Encode special characters in nickname to be IRC-compliant
ircg_nickname_unescape -- Decodes encoded nickname
ircg_notice -- Send a notice to a user on server
ircg_oper -- Elevates privileges to IRC OPER
ircg_part -- Leave a channel on server
ircg_pconnect -- Connect to an IRC server
ircg_register_format_messages -- Register a format message set
ircg_set_current -- Set current connection for output
ircg_set_file -- Set logfile for connection
ircg_set_on_die -- Set action to be executed when connection dies
ircg_topic -- Set topic for channel on server
ircg_who -- Queries server for WHO information
ircg_whois -- Query server for user information

이전 | 처음으로 | 다음
ingres_rollback | 위로 | ircg_channel_mode


ircg_channel_mode

(PHP 4 >= 4.0.5, PHP 5)

ircg_channel_mode -- Set channel mode flags for user

Description

bool ircg_channel_mode ( resource connection, string channel, string mode_spec, string nick)

Set channel mode flags for channel on server connected to by connection. Mode flags are passed in mode_spec and are applied to the user specified by nick.

Mode flags are set or cleared by specifying a mode character and prepending it with a plus or minus character, respectively. E.g. operator mode is granted by '+o' and revoked by '-o', as passed as mode_spec.

이전 | 처음으로 | 다음
IRC Gateway Functions | 위로 | ircg_disconnect


ircg_disconnect

(PHP 4 >= 4.0.4, PHP 5)

ircg_disconnect -- Close connection to server

Description

bool ircg_disconnect ( resource connection, string reason)

ircg_disconnect() will close a connection to a server previously established with ircg_pconnect().

See also: ircg_pconnect().

이전 | 처음으로 | 다음
ircg_channel_mode | 위로 | ircg_fetch_error_msg


ircg_fetch_error_msg

(PHP 4 >= 4.1.0, PHP 5)

ircg_fetch_error_msg -- Returns the error from previous IRCG operation

Description

array ircg_fetch_error_msg ( resource connection)

ircg_fetch_error_msg() returns the error from a failed connection.

참고: Error code is stored in first array element, error text in second. The error code is equivalent to IRC reply codes as defined by RFC 2812.

예 1. ircg_fetch_error_msg() example

<?php
if (!ircg_join ($id, "#php")) {
    $error = ircg_fetch_error_msg($id);
    echo "Can't join channel #php. Error code:
          $error[0] Description: $error[1]";
}
?>

이전 | 처음으로 | 다음
ircg_disconnect | 위로 | ircg_get_username


ircg_get_username

(PHP 4 >= 4.1.0, PHP 5)

ircg_get_username -- Get username for connection

Description

string ircg_get_username ( resource connection)

Function ircg_get_username() returns the username for the specified connection connection. Returns FALSE if connection died or is not valid.

이전 | 처음으로 | 다음
ircg_fetch_error_msg | 위로 | ircg_html_encode


ircg_html_encode

(PHP 4 >= 4.0.5, PHP 5)

ircg_html_encode -- Encodes HTML preserving output

Description

bool ircg_html_encode ( string html_string)

Encodes a HTML string html_string for output. This exposes the interface which the IRCG extension uses internally to reformat data coming from an IRC link. The function causes IRC color/font codes to be encoded in HTML and escapes certain entities.

이전 | 처음으로 | 다음
ircg_get_username | 위로 | ircg_ignore_add


ircg_ignore_add

(PHP 4 >= 4.0.5, PHP 5)

ircg_ignore_add -- Add a user to your ignore list on a server

Description

bool ircg_ignore_add ( resource connection, string nick)

This function adds user nick to the ignore list of connection connection. Afterwards, IRCG will suppress all messages from this user through the associated connection.

See also: ircg_ignore_del().

이전 | 처음으로 | 다음
ircg_html_encode | 위로 | ircg_ignore_del


ircg_ignore_del

(PHP 4 >= 4.0.5, PHP 5)

ircg_ignore_del -- Remove a user from your ignore list on a server

Description

bool ircg_ignore_del ( resource connection, string nick)

This function removes user nick from the IRCG ignore list associated with connection.

See also: ircg_ignore_add().

이전 | 처음으로 | 다음
ircg_ignore_add | 위로 | ircg_invite


ircg_invite

(PHP 4 >= 4.3.3, PHP 5)

ircg_invite -- Invites nickname to channel

Description

bool ircg_invite ( resource connection, string channel, string nickname)

ircg_invite() will send an invitation to the user nickname, prompting him to join channel. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ircg_ignore_del | 위로 | ircg_is_conn_alive


ircg_is_conn_alive

(PHP 4 >= 4.0.5, PHP 5)

ircg_is_conn_alive -- Check connection status

Description

bool ircg_is_conn_alive ( resource connection)

ircg_is_conn_alive() returns TRUE if connection is still alive and working or FALSE, if the connection has died for some reason.

이전 | 처음으로 | 다음
ircg_invite | 위로 | ircg_join


ircg_join

(PHP 4 >= 4.0.4, PHP 5)

ircg_join -- Join a channel on a connected server

Description

bool ircg_join ( resource connection, string channel [, string key])

Join the channel channel on the server connected to by connection. IRCG will optionally pass the room key key.

이전 | 처음으로 | 다음
ircg_is_conn_alive | 위로 | ircg_kick


ircg_kick

(PHP 4 >= 4.0.5, PHP 5)

ircg_kick -- Kick a user out of a channel on server

Description

bool ircg_kick ( resource connection, string channel, string nick, string reason)

Kick user nick from channel on server connected to by connection. reason should give a short message describing why this action was performed.

이전 | 처음으로 | 다음
ircg_join | 위로 | ircg_list


ircg_list

(PHP 4 >= 4.3.3, PHP 5)

ircg_list -- List topic/user count of channel(s)

Description

bool ircg_list ( resource connection, string channel)

ircg_list() will request a list of users in the channel. The answer is sent to the output defined by ircg_set_file() or ircg_set_current(). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. ircg_list() example

<?php

// connect to server
$id = ircg_pconnect($nickname, $ip, $port);

// set to output to a file
ircg_set_file($id, 'irc_output.html');

// try to join a channel
if (!ircg_join($id, $channel)) {
    echo "Cannot /join $channel<br />";
}

// send list command
ircg_list($id, $channel);

// wait for output to arrive
sleep(5);

// disconnect
ircg_disconnect($id,'Bye World');

// output everything
readfile('irc_output.html');

?>

This example will output something similar to:

...
Channel #channel has n users and the topic is 'Topic'
End of LIST
...

See also: ircg_set_file(),
ircg_set_current(), and
ircg_who().

이전 | 처음으로 | 다음
ircg_kick | 위로 | ircg_lookup_format_messages


ircg_lookup_format_messages

(PHP 4 >= 4.0.5, PHP 5)

ircg_lookup_format_messages -- Check for the existence of a format message set

Description

bool ircg_lookup_format_messages ( string name)

Check for the existence of the format message set name. Sets may be registered with ircg_register_format_messages(), a default set named ircg is always available. Returns TRUE, if the set exists and FALSE otherwise.

See also: ircg_register_format_messages()

이전 | 처음으로 | 다음
ircg_list | 위로 | ircg_lusers


ircg_lusers

(PHP 4 >= 4.3.3, PHP 5)

ircg_lusers -- IRC network statistics

Description

bool ircg_lusers ( resource connection)

ircg_lusers() will request a statistical breakdown of users on the network connected to on connection. The answer is sent to the output defined by ircg_set_file() or ircg_set_current(). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also: ircg_set_file(), and ircg_set_current().

이전 | 처음으로 | 다음
ircg_lookup_format_messages | 위로 | ircg_msg


ircg_msg

(PHP 4 >= 4.0.4, PHP 5)

ircg_msg -- Send message to channel or user on server

Description

bool ircg_msg ( resource connection, string recipient, string message [, boolean suppress])

ircg_msg() will send the message to a channel or user on the server connected to by connection. A recipient starting with # or & will send the message to a channel, anything else will be interpreted as a username.

Setting the optional parameter suppress to a TRUE value will suppress output of your message to your own connection. This so-called loopback is necessary, because the IRC server does not echo PRIVMSG commands back to us.

이전 | 처음으로 | 다음
ircg_lusers | 위로 | ircg_nick


ircg_nick

(PHP 4 >= 4.0.5, PHP 5)

ircg_nick -- Change nickname on server

Description

bool ircg_nick ( resource connection, string nick)

Change your nickname on the given connection to the one given in nick, if possible.

Will return TRUE on success and FALSE on failure.

이전 | 처음으로 | 다음
ircg_msg | 위로 | ircg_nickname_escape


ircg_nickname_escape

(PHP 4 >= 4.0.6, PHP 5)

ircg_nickname_escape -- Encode special characters in nickname to be IRC-compliant

Description

string ircg_nickname_escape ( string nick)

Function ircg_nickname_escape() returns an encoded nickname specified by nick which is IRC-compliant.

See also: ircg_nickname_unescape()

이전 | 처음으로 | 다음
ircg_nick | 위로 | ircg_nickname_unescape


ircg_nickname_unescape

(PHP 4 >= 4.0.6, PHP 5)

ircg_nickname_unescape -- Decodes encoded nickname

Description

string ircg_nickname_unescape ( string nick)

Function ircg_nickname_unescape() returns a decoded nickname, which is specified in nick.

See also: ircg_nickname_escape()

이전 | 처음으로 | 다음
ircg_nickname_escape | 위로 | ircg_notice


ircg_notice

(PHP 4 >= 4.0.5, PHP 5)

ircg_notice -- Send a notice to a user on server

Description

bool ircg_notice ( resource connection, string recipient, string message)

This function will send the message text to the user nick on the server connected to by connection. IRC servers and other software will not automatically generate replies to NOTICEs in contrast to other message types.

이전 | 처음으로 | 다음
ircg_nickname_unescape | 위로 | ircg_oper


ircg_oper

(PHP 4 >= 4.3.3, PHP 5)

ircg_oper -- Elevates privileges to IRC OPER

Description

bool ircg_oper ( resource connection, string name, string password)

ircg_oper() will authenticate the logged in user on connection as an IRC operator. name and password must match a registered IRC operator account. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ircg_notice | 위로 | ircg_part


ircg_part

(PHP 4 >= 4.0.4, PHP 5)

ircg_part -- Leave a channel on server

Description

bool ircg_part ( resource connection, string channel)

Leave the channel channel on the server connected to by connection.

이전 | 처음으로 | 다음
ircg_oper | 위로 | ircg_pconnect


ircg_pconnect

(PHP 4 >= 4.0.4, PHP 5)

ircg_pconnect -- Connect to an IRC server

Description

resource ircg_pconnect ( string username [, string server_ip [, int server_port [, string msg_format [, array ctcp_messages [, array user_settings]]]]])

ircg_pconnect() will try to establish a connection to an IRC server and return a connection resource handle for further use.

The only mandatory parameter is username, this will set your initial nickname on the server. server_ip and server_port are optional and default to 127.0.0.1 and 6667.

참고: For now parameter server_ip will not do any hostname lookups and will only accept IP addresses in numerical form. DNS lookups are expensive and should be done in the context of IRCG.

You can customize the output of IRC messages and events by selecting a format message set previously created with ircg_register_format_messages() by specifying the set's name in msg_format.

If you want to handle CTCP messages such as ACTION (/me), you need to define a mapping from CTCP type (e.g. ACTION) to a custom format string. Do this by passing an associative array as ctcp_messages. The keys of the array are the CTCP type and the respective value is the format message.

You can define "ident", "password", and "realname" tokens which are sent to the IRC server by setting these in an associative array. Pass that array as user_settings.

See also: ircg_disconnect(),
ircg_is_conn_alive(),
ircg_register_format_messages().

이전 | 처음으로 | 다음
ircg_part | 위로 | ircg_register_format_messages


ircg_register_format_messages

(PHP 4 >= 4.0.5, PHP 5)

ircg_register_format_messages -- Register a format message set

Description

bool ircg_register_format_messages ( string name, array messages)

With ircg_register_format_messages() you can customize the way your IRC output looks like or which script functions are invoked on the client side.

  • Plain channel message

  • Private message received

  • Private message sent

  • Some user leaves channel

  • Some user enters channel

  • Some user was kicked from the channel

  • Topic has been changed

  • Error

  • Fatal error

  • Join list end(?)

  • Self part(?)

  • Some user changes his nick

  • Some user quits his connection

  • Mass join begin

  • Mass join element

  • Mass join end

  • Whois user

  • Whois server

  • Whois idle

  • Whois channel

  • Whois end

  • Voice status change on user

  • Operator status change on user

  • Banlist

  • Banlist end

  • %f - from

  • %t - to

  • %c - channel

  • %r - plain message

  • %m - encoded message

  • %j - js encoded message

  • 1 - mod encode

  • 2 - nickname decode

See also: ircg_lookup_format_messages().

이전 | 처음으로 | 다음
ircg_pconnect | 위로 | ircg_set_current


ircg_set_current

(PHP 4 >= 4.0.4, PHP 5)

ircg_set_current -- Set current connection for output

Description

bool ircg_set_current ( resource connection)

Select the current HTTP connection for output in this execution context. Every output sent from the server connected to by connection will be copied to standard output while using default formatting or a format message set specified by ircg_register_format_messages().

See also: ircg_register_format_messages().

이전 | 처음으로 | 다음
ircg_register_format_messages | 위로 | ircg_set_file


ircg_set_file

(PHP 4 >= 4.2.0, PHP 5)

ircg_set_file -- Set logfile for connection

Description

bool ircg_set_file ( resource connection, string path)

Function ircg_set_file() specifies a logfile path in which all output from connection connection will be logged. Returns TRUE on success, otherwise FALSE.

이전 | 처음으로 | 다음
ircg_set_current | 위로 | ircg_set_on_die


ircg_set_on_die

(PHP 4 >= 4.2.0, PHP 5)

ircg_set_on_die -- Set action to be executed when connection dies

Description

bool ircg_set_on_die ( resource connection, string host, int port, string data)

In case of the termination of connection connection IRCG will connect to host at port (Note: host must be an IPv4 address, IRCG does not resolve host-names due to blocking issues), send data to the new host connection and will wait until the remote part closes connection. This can be used to trigger a PHP script for example.

This feature requires IRCG 3.

이전 | 처음으로 | 다음
ircg_set_file | 위로 | ircg_topic


ircg_topic

(PHP 4 >= 4.0.5, PHP 5)

ircg_topic -- Set topic for channel on server

Description

bool ircg_topic ( resource connection, string channel, string new_topic)

Change the topic for channel channel on the server connected to by connection to new_topic.

이전 | 처음으로 | 다음
ircg_set_on_die | 위로 | ircg_who


ircg_who

(PHP 4 >= 4.3.3, PHP 5)

ircg_who -- Queries server for WHO information

Description

bool ircg_who ( resource connection, string mask [, bool ops_only])

ircg_who() will request a list of users whose nickname is matching mask on connected network connection. The optional parameter ops_only will shrink the list to server operators only.

The answer is sent to the output defined by ircg_set_file() or ircg_set_current(). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also: ircg_set_file(), and ircg_set_current().

이전 | 처음으로 | 다음
ircg_topic | 위로 | ircg_whois


ircg_whois

(PHP 4 >= 4.0.5, PHP 5)

ircg_whois -- Query server for user information

Description

bool ircg_whois ( resource connection, string nick)

Sends a query to the connected server connection to ask for information about the specified user nick.

이전 | 처음으로 | 다음
ircg_who | 위로 | PHP / Java Integration


PHP / Java Integration

PHP 매뉴얼
이전 다음

XLVII. PHP / Java Integration

소개

There are two possible ways to bridge PHP and Java: you can either integrate PHP into a Java Servlet environment, which is the more stable and efficient solution, or integrate Java support into PHP. The former is provided by a SAPI module that interfaces with the Servlet server, the latter by this Java extension.

The Java extension provides a simple and effective means for creating and invoking methods on Java objects from PHP. The JVM is created using JNI, and everything runs in-process.

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

요구 사항

You need a Java VM installed on your machine to use this extension.

설치

To include Java support in your PHP build you must add the option --with-java[=DIR] where DIR points to the base install directory of your JDK. This extension can only be built as a shared dl. More build instructions for this extension can be found in php-src/ext/java/README.

Note to Win32 Users: In order to enable this module on a Windows environment with PHP <= 4.0.6, you must copy jvm.dll from the DLL folder of the PHP/Win32 binary package to the SYSTEM32 folder of your windows machine. (Ex: C:\WINNT\SYSTEM32 or C:\WINDOWS\SYSTEM32). For PHP > 4.0.6 you do not need any additional dll file.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. Java configuration options

Name | Default | Changeable
java.class.path | NULL | PHP_INI_ALL
java.home | NULL | PHP_INI_ALL
java.library.path | NULL | PHP_INI_ALL
java.library | JAVALIB | PHP_INI_ALL
For further details and definition of the PHP_INI_* constants see ini_set().

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

예제

예 1. Java Example

<?php
// get instance of Java class java.lang.System in PHP
$system = new Java('java.lang.System');

// demonstrate property access
echo 'Java version=' . $system->getProperty('java.version') . '<br />';
echo 'Java vendor=' . $system->getProperty('java.vendor') . '<br />';
echo 'OS=' . $system->getProperty('os.name') . ' ' .
             $system->getProperty('os.version') . ' on ' .
             $system->getProperty('os.arch') . ' <br />';

// java.util.Date example
$formatter = new Java('java.text.SimpleDateFormat',
                      "EEEE, MMMM dd, yyyy 'at' h:mm:ss a zzzz");

echo $formatter->format(new Java('java.util.Date'));
?>

예 2. AWT Example

<?php
// This example is only intended to be run as a CGI.

$frame  = new Java('java.awt.Frame', 'PHP');
$button = new Java('java.awt.Button', 'Hello Java World!');

$frame->add('North', $button);
$frame->validate();
$frame->pack();
$frame->visible = True;

$thread = new Java('java.lang.Thread');
$thread->sleep(10000);

$frame->dispose();
?>
Notes:

  • new Java() will create an instance of a class if a suitable constructor is available. If no parameters are passed and the default constructor is useful as it provides access to classes like java.lang.System which expose most of their functionallity through static methods.

  • Accessing a member of an instance will first look for bean properties then public fields. In other words, print $date.time will first attempt to be resolved as $date.getTime(), then as $date.time.

  • Both static and instance members can be accessed on an object with the same syntax. Furthermore, if the java object is of type java.lang.Class, then static members of the class (fields and methods) can be accessed.

  • Exceptions raised result in PHP warnings, and NULL results. The warnings may be eliminated by prefixing the method call with an "@" sign. The following APIs may be used to retrieve and reset the last error:

    • java_last_exception_get()

    • java_last_exception_clear()

  • Overload resolution is in general a hard problem given the differences in types between the two languages. The PHP Java extension employs a simple, but fairly effective, metric for determining which overload is the best match.

    Additionally, method names in PHP are not case sensitive, potentially increasing the number of overloads to select from.

    Once a method is selected, the parameters are coerced if necessary, possibly with a loss of data (example: double precision floating point numbers will be converted to boolean).

  • In the tradition of PHP, arrays and hashtables may pretty much be used interchangably. Note that hashtables in PHP may only be indexed by integers or strings; and that arrays of primitive types in Java can not be sparse. Also note that these constructs are passed by value, so may be expensive in terms of memory and time.

Java Servlet SAPI

The Java Servlet SAPI builds upon the mechanism defined by the Java extension to enable the entire PHP processor to be run as a servlet. The primary advanatage of this from a PHP perspective is that web servers which support servlets typically take great care in pooling and reusing JVMs. Build instructions for the Servlet SAPI module can be found in php4/sapi/README. Notes:

  • While this code is intended to be able to run on any servlet engine, it has only been tested on Apache's Jakarta/tomcat to date. Bug reports, success stories and/or patches required to get this code to run on other engines would be appreciated.

  • PHP has a habit of changing the working directory. sapi/servlet will eventually change it back, but while PHP is running the servlet engine may not be able to load any classes from the CLASSPATH which are specified using a relative directory syntax, or find the work directory used for administration and JSP compilation tasks.

차례
java_last_exception_clear -- Clear last Java exception
java_last_exception_get -- Get last Java exception

이전 | 처음으로 | 다음
ircg_whois | 위로 | java_last_exception_clear


java_last_exception_clear

(PHP 4 >= 4.0.2)

java_last_exception_clear -- Clear last Java exception

Description

void java_last_exception_clear ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

See java_last_exception_get() for an example.

이전 | 처음으로 | 다음
PHP / Java Integration | 위로 | java_last_exception_get


java_last_exception_get

(PHP 4 >= 4.0.2)

java_last_exception_get -- Get last Java exception

Description

exception java_last_exception_get ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

The following example demonstrates the usage of Java's exception handler from within PHP:

예 1. Java exception handler

<?php
$stack = new Java('java.util.Stack');
$stack->push(1);

// This should succeed
$result = $stack->pop();
$ex = java_last_exception_get();
if (!$ex) {
  echo "$result\n";
}

// This should fail (error suppressed by @)
$result = @$stack->pop();
$ex = java_last_exception_get();
if ($ex) {
  echo $ex->toString();
}

// Clear last exception
java_last_exception_clear();
?>

이전 | 처음으로 | 다음
java_last_exception_clear | 위로 | LDAP Functions


LDAP Functions

PHP 매뉴얼
이전 다음

XLVIII. LDAP Functions

소개

LDAP is the Lightweight Directory Access Protocol, and is a protocol used to access "Directory Servers". The Directory is a special kind of database that holds information in a tree structure.

The concept is similar to your hard disk directory structure, except that in this context, the root directory is "The world" and the first level subdirectories are "countries". Lower levels of the directory structure contain entries for companies, organisations or places, while yet lower still we find directory entries for people, and perhaps equipment or documents.

To refer to a file in a subdirectory on your hard disk, you might use something like:

/usr/local/myapp/docs

The forwards slash marks each division in the reference, and the sequence is read from left to right.

The equivalent to the fully qualified file reference in LDAP is the "distinguished name", referred to simply as "dn". An example dn might be:

cn=John Smith,ou=Accounts,o=My Company,c=US

The comma marks each division in the reference, and the sequence is read from right to left. You would read this dn as:

country = US
organization = My Company
organizationalUnit = Accounts
commonName = John Smith

In the same way as there are no hard rules about how you organise the directory structure of a hard disk, a directory server manager can set up any structure that is meaningful for the purpose. However, there are some conventions that are used. The message is that you can not write code to access a directory server unless you know something about its structure, any more than you can use a database without some knowledge of what is available.

Lots of information about LDAP can be found at

  • Netscape

  • OpenLDAP Project

  • LDAP World

The Netscape SDK contains a helpful Programmer's Guide in HTML format.

요구 사항

You will need to get and compile LDAP client libraries from either the University of Michigan ldap-3.3 package, Netscape Directory SDK 3.0 or OpenLDAP to compile PHP with LDAP support.

설치

LDAP support in PHP is not enabled by default. You will need to use the --with-ldap[=DIR] configuration option when compiling PHP to enable LDAP support. DIR is the LDAP base install directory.

Note to Win32 Users: In order to enable this module on a Windows environment, you must copy several files from the DLL folder of the PHP/Win32 binary package to the SYSTEM folder of your windows machine. (Ex: C:\WINNT\SYSTEM32, or C:\WINDOWS\SYSTEM). For PHP <= 4.2.0 copy libsasl.dll, for PHP >= 4.3.0 copy libeay32.dll and ssleay32.dll to your SYSTEM folder.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. LDAP configuration options

Name | Default | Changeable
ldap.max_links | "-1" | PHP_INI_SYSTEM
For further details and definition of the PHP_INI_* constants see ini_set().

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

LDAP_DEREF_NEVER (integer)

LDAP_DEREF_SEARCHING (integer)

LDAP_DEREF_FINDING (integer)

LDAP_DEREF_ALWAYS (integer)

LDAP_OPT_DEREF (integer)

LDAP_OPT_SIZELIMIT (integer)

LDAP_OPT_TIMELIMIT (integer)

LDAP_OPT_PROTOCOL_VERSION (integer)

LDAP_OPT_ERROR_NUMBER (integer)

LDAP_OPT_REFERRALS (integer)

LDAP_OPT_RESTART (integer)

LDAP_OPT_HOST_NAME (integer)

LDAP_OPT_ERROR_STRING (integer)

LDAP_OPT_MATCHED_DN (integer)

LDAP_OPT_SERVER_CONTROLS (integer)

LDAP_OPT_CLIENT_CONTROLS (integer)

LDAP_OPT_DEBUG_LEVEL (integer)

GSLC_SSL_NO_AUTH (integer)

GSLC_SSL_ONEWAY_AUTH (integer)

GSLC_SSL_TWOWAY_AUTH (integer)

예제

Retrieve information for all entries where the surname starts with "S" from a directory server, displaying an extract with name and email address.

예 1. LDAP search example

<?php
// basic sequence with LDAP is connect, bind, search, interpret search
// result, close connection

echo "<h3>LDAP query test</h3>";
echo "Connecting ...";
$ds=ldap_connect("localhost");  // must be a valid LDAP server!
echo "connect result is " . $ds . "<br />";

if ($ds) {
    echo "Binding ...";
    $r=ldap_bind($ds);     // this is an "anonymous" bind, typically
                           // read-only access
    echo "Bind result is " . $r . "<br />";

    echo "Searching for (sn=S*) ...";
    // Search surname entry
    $sr=ldap_search($ds, "o=My Company, c=US", "sn=S*");
    echo "Search result is " . $sr . "<br />";

    echo "Number of entires returned is " . ldap_count_entries($ds, $sr) . "<br />";

    echo "Getting entries ...<p>";
    $info = ldap_get_entries($ds, $sr);
    echo "Data for " . $info["count"] . " items returned:<p>";

    for ($i=0; $i<$info["count"]; $i++) {
        echo "dn is: " . $info[$i]["dn"] . "<br />";
        echo "first cn entry is: " . $info[$i]["cn"][0] . "<br />";
        echo "first email entry is: " . $info[$i]["mail"][0] . "<br /><hr />";
    }

    echo "Closing connection";
    ldap_close($ds);

} else {
    echo "<h4>Unable to connect to LDAP server</h4>";
}
?>

Using the PHP LDAP calls

Before you can use the LDAP calls you will need to know ..

  • The name or address of the directory server you will use

  • The "base dn" of the server (the part of the world directory that is held on this server, which could be "o=My Company,c=US")

  • Whether you need a password to access the server (many servers will provide read access for an "anonymous bind" but require a password for anything else)

The typical sequence of LDAP calls you will make in an application will follow this pattern:

ldap_connect() // establish connection to server
|
ldap_bind() // anonymous or authenticated "login"
|
do something like search or update the directory
and display the results
|
ldap_close() // "logout"

차례
ldap_8859_to_t61 -- Translate 8859 characters to t61 characters
ldap_add -- Add entries to LDAP directory
ldap_bind -- Bind to LDAP directory
ldap_close -- Close link to LDAP server
ldap_compare -- Compare value of attribute found in entry specified with DN
ldap_connect -- Connect to an LDAP server
ldap_count_entries -- Count the number of entries in a search
ldap_delete -- Delete an entry from a directory
ldap_dn2ufn -- Convert DN to User Friendly Naming format
ldap_err2str -- Convert LDAP error number into string error message
ldap_errno -- Return the LDAP error number of the last LDAP command
ldap_error -- Return the LDAP error message of the last LDAP command
ldap_explode_dn -- Splits DN into its component parts
ldap_first_attribute -- Return first attribute
ldap_first_entry -- Return first result id
ldap_first_reference -- Return first reference
ldap_free_result -- Free result memory
ldap_get_attributes -- Get attributes from a search result entry
ldap_get_dn -- Get the DN of a result entry
ldap_get_entries -- Get all result entries
ldap_get_option -- Get the current value for given option
ldap_get_values_len -- Get all binary values from a result entry
ldap_get_values -- Get all values from a result entry
ldap_list -- Single-level search
ldap_mod_add -- Add attribute values to current attributes
ldap_mod_del -- Delete attribute values from current attributes
ldap_mod_replace -- Replace attribute values with new ones
ldap_modify -- Modify an LDAP entry
ldap_next_attribute -- Get the next attribute in result
ldap_next_entry -- Get next result entry
ldap_next_reference -- Get next reference
ldap_parse_reference -- Extract information from reference entry
ldap_parse_result -- Extract information from result
ldap_read -- Read an entry
ldap_rename -- Modify the name of an entry
ldap_search -- Search LDAP tree
ldap_set_option -- Set the value of the given option
ldap_set_rebind_proc -- Set a callback function to do re-binds on referral chasing.
ldap_sort -- Sort LDAP result entries
ldap_start_tls -- Start TLS
ldap_t61_to_8859 -- Translate t61 characters to 8859 characters
ldap_unbind -- Unbind from LDAP directory

이전 | 처음으로 | 다음
java_last_exception_get | 위로 | ldap_8859_to_t61


ldap_8859_to_t61

(PHP 4 >= 4.0.2, PHP 5)

ldap_8859_to_t61 -- Translate 8859 characters to t61 characters

Description

string ldap_8859_to_t61 ( string value)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
LDAP Functions | 위로 | ldap_add


ldap_add

(PHP 3, PHP 4 , PHP 5)

ldap_add -- Add entries to LDAP directory

Description

bool ldap_add ( resource link_identifier, string dn, array entry)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

The ldap_add() function is used to add entries in the LDAP directory. The DN of the entry to be added is specified by dn. Array entry specifies the information about the entry. The values in the entries are indexed by individual attributes. In case of multiple values for an attribute, they are indexed using integers starting with 0.

entry["attribute1"] = value
entry["attribute2"][0] = value1
entry["attribute2"][1] = value2

예 1. Complete example with authenticated bind

<?php
$ds=ldap_connect("localhost");  // assuming the LDAP server is on this host

if ($ds) {
    // bind with appropriate dn to give update access
    $r=ldap_bind($ds, "cn=root, o=My Company, c=US", "secret");

    // prepare data
    $info["cn"]="John Jones";
    $info["sn"]="Jones";
    $info["mail"]="jonj@example.com";
    $info["objectclass"]="person";

    // add data to directory
    $r=ldap_add($ds, "cn=John Jones, o=My Company, c=US", $info);

    ldap_close($ds);
} else {
    echo "Unable to connect to LDAP server";
}
?>

이전 | 처음으로 | 다음
ldap_8859_to_t61 | 위로 | ldap_bind


ldap_bind

(PHP 3, PHP 4 , PHP 5)

ldap_bind -- Bind to LDAP directory

Description

bool ldap_bind ( resource link_identifier [, string bind_rdn [, string bind_password]])

Binds to the LDAP directory with specified RDN and password. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

ldap_bind() does a bind operation on the directory. bind_rdn and bind_password are optional. If not specified, anonymous bind is attempted.

예 1. Using LDAP Bind

<?php

// using ldap bind
$ldaprdn  = 'uname';     // ldap rdn or dn
$ldappass = 'password';  // associated password

// connect to ldap server
$ldapconn = ldap_connect("ldap.example.com")
    or die("Could not connect to LDAP server.");

if ($ldapconn) {

    // binding to ldap server
    $ldapbind = ldap_bind($ldapconn, $ldaprdn, $ldappass);

    // verify binding
    if ($ldapbind) {
        echo "LDAP bind successful...";
    } else {
        echo "LDAP bind failed...";
    }

}

?>

예 2. Using LDAP Bind Anonymously

<?php

//using ldap bind anonymously

// connect to ldap server
$ldapconn = ldap_connect("ldap.example.com")
    or die("Could not connect to LDAP server.");

if ($ldapconn) {

    // binding anonymously
    $ldapbind = ldap_bind($ldapconn);

    if ($ldapbind) {
        echo "LDAP bind anonymous successful...";
    } else {
        echo "LDAP bind anonymous failed...";
    }

}

?>

이전 | 처음으로 | 다음
ldap_add | 위로 | ldap_close


ldap_close

(PHP 3, PHP 4 , PHP 5)

ldap_close -- Close link to LDAP server

Description

bool ldap_close ( resource link_identifier)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

ldap_close() closes the link to the LDAP server that's associated with the specified link_identifier.

This call is internally identical to ldap_unbind(). The LDAP API uses the call ldap_unbind(), so perhaps you should use this in preference to ldap_close().

참고: This function is an alias of ldap_unbind().

이전 | 처음으로 | 다음
ldap_bind | 위로 | ldap_compare


ldap_compare

(PHP 4 >= 4.0.2, PHP 5)

ldap_compare -- Compare value of attribute found in entry specified with DN

Description

bool ldap_compare ( resource link_identifier, string dn, string attribute, string value)

Returns TRUE if value matches otherwise returns FALSE. Returns -1 on error.

ldap_compare() is used to compare value of attribute to value of same attribute in LDAP directory entry specified with dn.

The following example demonstrates how to check whether or not given password matches the one defined in DN specified entry.

예 1. Complete example of password check

<?php

$ds=ldap_connect("localhost");  // assuming the LDAP server is on this host

if ($ds) {

    // bind
    if (ldap_bind($ds)) {

        // prepare data
        $dn = "cn=Matti Meikku, ou=My Unit, o=My Company, c=FI";
        $value = "secretpassword";
        $attr = "password";

        // compare value
        $r=ldap_compare($ds, $dn, $attr, $value);

        if ($r === -1) {
            echo "Error: " . ldap_error($ds);
        } elseif ($r === true) {
            echo "Password correct.";
        } elseif ($r === false) {
            echo "Wrong guess! Password incorrect.";
        }

    } else {
        echo "Unable to bind to LDAP server.";
    }

    ldap_close($ds);

} else {
    echo "Unable to connect to LDAP server.";
}
?>

주의

ldap_compare() can NOT be used to compare BINARY values!

참고: This function was added in 4.0.2.

이전 | 처음으로 | 다음
ldap_close | 위로 | ldap_connect


ldap_connect

(PHP 3, PHP 4 , PHP 5)

ldap_connect -- Connect to an LDAP server

Description

resource ldap_connect ( [string hostname [, int port]])

Returns a positive LDAP link identifier on success, or FALSE on error.

ldap_connect() establishes a connection to a LDAP server on a specified hostname and port. Both the arguments are optional. If no arguments are specified then the link identifier of the already opened link will be returned. If only hostname is specified, then the port defaults to 389.

If you are using OpenLDAP 2.x.x you can specify a URL instead of the hostname. To use LDAP with SSL, compile OpenLDAP 2.x.x with SSL support, configure PHP with SSL, and use ldaps://hostname/ as host parameter. The port parameter is not used when using URLs.

참고: URL and SSL support were added in 4.0.4.

예 1. Example of connecting to LDAP server.

<?php

// LDAP variables
$ldaphost = "ldap.example.com";  // your ldap servers
$ldapport = 389;                 // your ldap server's port number

// Connecting to LDAP
$ldapconn = ldap_connect($ldaphost, $ldapport)
          or die("Could not connect to $ldaphost");

?>

예 2. Example of connecting securely to LDAP server.

<?php

// make sure your host is the correct one
// that you issued your secure certificate to
$ldaphost = "ldaps://ldap.example.com/";

// Connecting to LDAP
$ldapconn = ldap_connect($ldaphost)
          or die("Could not connect to {$ldaphost}");

?>

이전 | 처음으로 | 다음
ldap_compare | 위로 | ldap_count_entries


ldap_count_entries

(PHP 3, PHP 4 , PHP 5)

ldap_count_entries -- Count the number of entries in a search

Description

int ldap_count_entries ( resource link_identifier, resource result_identifier)

Returns number of entries in the result or FALSE on error.

ldap_count_entries() returns the number of entries stored in the result of previous search operations. result_identifier identifies the internal ldap result.

이전 | 처음으로 | 다음
ldap_connect | 위로 | ldap_delete


ldap_delete

(PHP 3, PHP 4 , PHP 5)

ldap_delete -- Delete an entry from a directory

Description

bool ldap_delete ( resource link_identifier, string dn)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

ldap_delete() function delete a particular entry in LDAP directory specified by dn.

이전 | 처음으로 | 다음
ldap_count_entries | 위로 | ldap_dn2ufn


ldap_dn2ufn

(PHP 3, PHP 4 , PHP 5)

ldap_dn2ufn -- Convert DN to User Friendly Naming format

Description

string ldap_dn2ufn ( string dn)

ldap_dn2ufn() function is used to turn a DN, specified by dn, into a more user-friendly form, stripping off type names.

이전 | 처음으로 | 다음
ldap_delete | 위로 | ldap_err2str


ldap_err2str

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ldap_err2str -- Convert LDAP error number into string error message

Description

string ldap_err2str ( int errno)

Returns string error message.

This function returns the string error message explaining the error number errno. While LDAP errno numbers are standardized, different libraries return different or even localized textual error messages. Never check for a specific error message text, but always use an error number to check.

See also ldap_errno() and ldap_error().

예 1. Enumerating all LDAP error messages

<?php
  for ($i=0; $i<100; $i++) {
    printf("Error $i: %s<br />\n", ldap_err2str($i));
  }
?>

이전 | 처음으로 | 다음
ldap_dn2ufn | 위로 | ldap_errno


ldap_errno

(PHP 3>= 3.0.12, PHP 4 , PHP 5)

ldap_errno -- Return the LDAP error number of the last LDAP command

Description

int ldap_errno ( resource link_identifier)

Return the LDAP error number of the last LDAP command for this link.

This function returns the standardized error number returned by the last LDAP command for the given link_identifier. This number can be converted into a textual error message using ldap_err2str().

Unless you lower your warning level in your php.ini sufficiently or prefix your LDAP commands with @ (at) characters to suppress warning output, the errors generated will also show up in your HTML output.

예 1. Generating and catching an error

<?php
// This example contains an error, which we will catch.
$ld = ldap_connect("localhost");
$bind = ldap_bind($ld);
// syntax error in filter expression (errno 87),
// must be "objectclass=*" to work.
$res =  @ldap_search($ld, "o=Myorg, c=DE", "objectclass");
if (!$res) {
    echo "LDAP-Errno: " . ldap_errno($ld) . "<br />\n";
    echo "LDAP-Error: " . ldap_error($ld) . "<br />\n";
    die("Argh!<br />\n");
}
$info = ldap_get_entries($ld, $res);
echo $info["count"] . " matching entries.<br />\n";
?>

See also ldap_err2str() and ldap_error().

이전 | 처음으로 | 다음
ldap_err2str | 위로 | ldap_error


ldap_error

(PHP 3>= 3.0.12, PHP 4 , PHP 5)

ldap_error -- Return the LDAP error message of the last LDAP command

Description

string ldap_error ( resource link_identifier)

Returns string error message.

This function returns the string error message explaining the error generated by the last LDAP command for the given link_identifier While LDAP errno numbers are standardized, different libraries return different or even localized textual error messages. Never check for a specific error message text, but always use an error number to check.

Unless you lower your warning level in your php.ini sufficiently or prefix your LDAP commands with @ (at) characters to suppress warning output, the errors generated will also show up in your HTML output.

See also ldap_err2str() and ldap_errno().

이전 | 처음으로 | 다음
ldap_errno | 위로 | ldap_explode_dn


ldap_explode_dn

(PHP 3, PHP 4 , PHP 5)

ldap_explode_dn -- Splits DN into its component parts

Description

array ldap_explode_dn ( string dn, int with_attrib)

ldap_explode_dn() function is used to split the DN returned by ldap_get_dn() and breaks it up into its component parts. Each part is known as Relative Distinguished Name, or RDN. ldap_explode_dn() returns an array of all those components. with_attrib is used to request if the RDNs are returned with only values or their attributes as well. To get RDNs with the attributes (i.e. in attribute=value format) set with_attrib to 0 and to get only values set it to 1.

이전 | 처음으로 | 다음
ldap_error | 위로 | ldap_first_attribute


ldap_first_attribute

(PHP 3, PHP 4 , PHP 5)

ldap_first_attribute -- Return first attribute

Description

string ldap_first_attribute ( resource link_identifier, resource result_entry_identifier, int ber_identifier)

Returns the first attribute in the entry on success and FALSE on error.

Similar to reading entries, attributes are also read one by one from a particular entry. ldap_first_attribute() returns the first attribute in the entry pointed by the result_entry_identifier. Remaining attributes are retrieved by calling ldap_next_attribute() successively. ber_identifier is the identifier to internal memory location pointer. It is passed by reference. The same ber_identifier is passed to the ldap_next_attribute() function, which modifies that pointer.

See also ldap_get_attributes()

이전 | 처음으로 | 다음
ldap_explode_dn | 위로 | ldap_first_entry


ldap_first_entry

(PHP 3, PHP 4 , PHP 5)

ldap_first_entry -- Return first result id

Description

resource ldap_first_entry ( resource link_identifier, resource result_identifier)

Returns the result entry identifier for the first entry on success and FALSE on error.

Entries in the LDAP result are read sequentially using the ldap_first_entry() and ldap_next_entry() functions. ldap_first_entry() returns the entry identifier for first entry in the result. This entry identifier is then supplied to ldap_next_entry() routine to get successive entries from the result.

See also ldap_get_entries().

이전 | 처음으로 | 다음
ldap_first_attribute | 위로 | ldap_first_reference


ldap_first_reference

(PHP 4 >= 4.0.5, PHP 5)

ldap_first_reference -- Return first reference

Description

resource ldap_first_reference ( resource link, resource result)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ldap_first_entry | 위로 | ldap_free_result


ldap_free_result

(PHP 3, PHP 4 , PHP 5)

ldap_free_result -- Free result memory

Description

bool ldap_free_result ( resource result_identifier)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

ldap_free_result() frees up the memory allocated internally to store the result and pointed by the result_identifier. All result memory will be automatically freed when the script terminates.

Typically all the memory allocated for the ldap result gets freed at the end of the script. In case the script is making successive searches which return large result sets, ldap_free_result() could be called to keep the runtime memory usage by the script low.

이전 | 처음으로 | 다음
ldap_first_reference | 위로 | ldap_get_attributes


ldap_get_attributes

(PHP 3, PHP 4 , PHP 5)

ldap_get_attributes -- Get attributes from a search result entry

Description

array ldap_get_attributes ( resource link_identifier, resource result_entry_identifier)

Returns a complete entry information in a multi-dimensional array on success and FALSE on error.

ldap_get_attributes() function is used to simplify reading the attributes and values from an entry in the search result. The return value is a multi-dimensional array of attributes and values.

Having located a specific entry in the directory, you can find out what information is held for that entry by using this call. You would use this call for an application which "browses" directory entries and/or where you do not know the structure of the directory entries. In many applications you will be searching for a specific attribute such as an email address or a surname, and won't care what other data is held.

return_value["count"] = number of attributes in the entry
return_value[0] = first attribute
return_value[n] = nth attribute

return_value["attribute"]["count"] = number of values for attribute
return_value["attribute"][0] = first value of the attribute
return_value["attribute"][i] = (i+1)th value of the attribute

예 1. Show the list of attributes held for a particular directory entry

<?php
// $ds is the link identifier for the directory

// $sr is a valid search result from a prior call to
// one of the ldap directory search calls

$entry = ldap_first_entry($ds, $sr);

$attrs = ldap_get_attributes($ds, $entry);

echo $attrs["count"] . " attributes held for this entry:<p>";

for ($i=0; $i<$attrs["count"]; $i++) {
    echo $attrs[$i] . "<br />";
}
?>

See also ldap_first_attribute() and ldap_next_attribute().

이전 | 처음으로 | 다음
ldap_free_result | 위로 | ldap_get_dn


ldap_get_dn

(PHP 3, PHP 4 , PHP 5)

ldap_get_dn -- Get the DN of a result entry

Description

string ldap_get_dn ( resource link_identifier, resource result_entry_identifier)

Returns the DN of the result entry and FALSE on error.

ldap_get_dn() function is used to find out the DN of an entry in the result.

이전 | 처음으로 | 다음
ldap_get_attributes | 위로 | ldap_get_entries


ldap_get_entries

(PHP 3, PHP 4 , PHP 5)

ldap_get_entries -- Get all result entries

Description

array ldap_get_entries ( resource link_identifier, resource result_identifier)

Returns a complete result information in a multi-dimensional array on success and FALSE on error.

ldap_get_entries() function is used to simplify reading multiple entries from the result, specified with result_identifier, and then reading the attributes and multiple values. The entire information is returned by one function call in a multi-dimensional array. The structure of the array is as follows.

The attribute index is converted to lowercase. (Attributes are case-insensitive for directory servers, but not when used as array indices.)

return_value["count"] = number of entries in the result
return_value[0] : refers to the details of first entry

return_value[i]["dn"] = DN of the ith entry in the result

return_value[i]["count"] = number of attributes in ith entry
return_value[i][j] = jth attribute in the ith entry in the result

return_value[i]["attribute"]["count"] = number of values for
attribute in ith entry
return_value[i]["attribute"][j] = jth value of attribute in ith entry

See also ldap_first_entry() and ldap_next_entry()

이전 | 처음으로 | 다음
ldap_get_dn | 위로 | ldap_get_option


ldap_get_option

(PHP 4 >= 4.0.4, PHP 5)

ldap_get_option -- Get the current value for given option

Description

bool ldap_get_option ( resource link_identifier, int option, mixed retval)

Sets retval to the value of the specified option. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

The parameter option can be one of: LDAP_OPT_DEREF, LDAP_OPT_SIZELIMIT, LDAP_OPT_TIMELIMIT, LDAP_OPT_PROTOCOL_VERSION, LDAP_OPT_ERROR_NUMBER, LDAP_OPT_REFERRALS, LDAP_OPT_RESTART, LDAP_OPT_HOST_NAME, LDAP_OPT_ERROR_STRING, LDAP_OPT_MATCHED_DN. These are described in draft-ietf-ldapext-ldap-c-api-xx.txt

참고: This function is only available when using OpenLDAP 2.x.x OR Netscape Directory SDK x.x, and was added in PHP 4.0.4

예 1. Check protocol version

<?php
// $ds is a valid link identifier for a directory server
if (ldap_get_option($ds, LDAP_OPT_PROTOCOL_VERSION, $version)) {
    echo "Using protocol version $version\n";
} else {
    echo "Unable to determine protocol version\n";
}
?>

See also ldap_set_option().

이전 | 처음으로 | 다음
ldap_get_entries | 위로 | ldap_get_values_len


ldap_get_values_len

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

ldap_get_values_len -- Get all binary values from a result entry

Description

array ldap_get_values_len ( resource link_identifier, resource result_entry_identifier, string attribute)

Returns an array of values for the attribute on success and FALSE on error.

ldap_get_values_len() function is used to read all the values of the attribute in the entry in the result. entry is specified by the result_entry_identifier. The number of values can be found by indexing "count" in the resultant array. Individual values are accessed by integer index in the array. The first index is 0.

This function is used exactly like ldap_get_values() except that it handles binary data and not string data.

참고: This function was added in 4.0.

이전 | 처음으로 | 다음
ldap_get_option | 위로 | ldap_get_values


ldap_get_values

(PHP 3, PHP 4 , PHP 5)

ldap_get_values -- Get all values from a result entry

Description

array ldap_get_values ( resource link_identifier, resource result_entry_identifier, string attribute)

Returns an array of values for the attribute on success and FALSE on error.

ldap_get_values() function is used to read all the values of the attribute in the entry in the result. entry is specified by the result_entry_identifier. The number of values can be found by indexing "count" in the resultant array. Individual values are accessed by integer index in the array. The first index is 0.

This call needs a result_entry_identifier, so needs to be preceded by one of the ldap search calls and one of the calls to get an individual entry.

You application will either be hard coded to look for certain attributes (such as "surname" or "mail") or you will have to use the ldap_get_attributes() call to work out what attributes exist for a given entry.

LDAP allows more than one entry for an attribute, so it can, for example, store a number of email addresses for one person's directory entry all labeled with the attribute "mail"

return_value["count"] = number of values for attribute
return_value[0] = first value of attribute
return_value[i] = ith value of attribute

예 1. List all values of the "mail" attribute for a directory entry

<?php
// $ds is a valid link identifier for a directory server

// $sr is a valid search result from a prior call to
//     one of the ldap directory search calls

// $entry is a valid entry identifier from a prior call to
//        one of the calls that returns a directory entry

$values = ldap_get_values($ds, $entry, "mail");

echo $values["count"] . " email addresses for this entry.<br />";

for ($i=0; $i < $values["count"]; $i++) {
    echo $values[$i] . "<br />";
}
?>

이전 | 처음으로 | 다음
ldap_get_values_len | 위로 | ldap_list


ldap_list

(PHP 3, PHP 4 , PHP 5)

ldap_list -- Single-level search

Description

resource ldap_list ( resource link_identifier, string base_dn, string filter [, array attributes [, int attrsonly [, int sizelimit [, int timelimit [, int deref]]]]])

Returns a search result identifier or FALSE on error.

ldap_list() performs the search for a specified filter on the directory with the scope LDAP_SCOPE_ONELEVEL.

LDAP_SCOPE_ONELEVEL means that the search should only return information that is at the level immediately below the base_dn given in the call. (Equivalent to typing "ls" and getting a list of files and folders in the current working directory.)

This call takes 5 optional parameters. See ldap_search() notes.

참고: These optional parameters were added in 4.0.2: attrsonly, sizelimit, timelimit, deref.

예 1. Produce a list of all organizational units of an organization

// $ds is a valid link identifier for a directory server

$basedn = "o=My Company, c=US";
$justthese = array("ou");

$sr=ldap_list($ds, $basedn, "ou=*", $justthese);

$info = ldap_get_entries($ds, $sr);

for ($i=0; $i<$info["count"]; $i++) {
    echo $info[$i]["ou"][0] ;
}

참고: From 4.0.5 on it's also possible to do parallel searches. See ldap_search() for details.

이전 | 처음으로 | 다음
ldap_get_values | 위로 | ldap_mod_add


ldap_mod_add

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

ldap_mod_add -- Add attribute values to current attributes

Description

bool ldap_mod_add ( resource link_identifier, string dn, array entry)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

This function adds attribute(s) to the specified dn. It performs the modification at the attribute level as opposed to the object level. Object-level additions are done by the ldap_add() function.

이전 | 처음으로 | 다음
ldap_list | 위로 | ldap_mod_del


ldap_mod_del

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

ldap_mod_del -- Delete attribute values from current attributes

Description

bool ldap_mod_del ( resource link_identifier, string dn, array entry)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

This function removes attribute(s) from the specified dn. It performs the modification at the attribute level as opposed to the object level. Object-level deletions are done by the ldap_delete() function.

이전 | 처음으로 | 다음
ldap_mod_add | 위로 | ldap_mod_replace


ldap_mod_replace

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

ldap_mod_replace -- Replace attribute values with new ones

Description

bool ldap_mod_replace ( resource link_identifier, string dn, array entry)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

This function replaces attribute(s) from the specified dn. It performs the modification at the attribute level as opposed to the object level. Object-level modifications are done by the ldap_modify() function.

이전 | 처음으로 | 다음
ldap_mod_del | 위로 | ldap_modify


ldap_modify

(PHP 3, PHP 4 , PHP 5)

ldap_modify -- Modify an LDAP entry

Description

bool ldap_modify ( resource link_identifier, string dn, array entry)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

ldap_modify() function is used to modify the existing entries in the LDAP directory. The structure of the entry is same as in ldap_add().

이전 | 처음으로 | 다음
ldap_mod_replace | 위로 | ldap_next_attribute


ldap_next_attribute

(PHP 3, PHP 4 , PHP 5)

ldap_next_attribute -- Get the next attribute in result

Description

string ldap_next_attribute ( resource link_identifier, resource result_entry_identifier, resource ber_identifier)

Returns the next attribute in an entry on success and FALSE on error.

ldap_next_attribute() is called to retrieve the attributes in an entry. The internal state of the pointer is maintained by the ber_identifier. It is passed by reference to the function. The first call to ldap_next_attribute() is made with the result_entry_identifier returned from ldap_first_attribute().

See also ldap_get_attributes()

이전 | 처음으로 | 다음
ldap_modify | 위로 | ldap_next_entry


ldap_next_entry

(PHP 3, PHP 4 , PHP 5)

ldap_next_entry -- Get next result entry

Description

resource ldap_next_entry ( resource link_identifier, resource result_entry_identifier)

Returns entry identifier for the next entry in the result whose entries are being read starting with ldap_first_entry(). If there are no more entries in the result then it returns FALSE.

ldap_next_entry() function is used to retrieve the entries stored in the result. Successive calls to the ldap_next_entry() return entries one by one till there are no more entries. The first call to ldap_next_entry() is made after the call to ldap_first_entry() with the result_entry_identifier as returned from the ldap_first_entry().

See also ldap_get_entries()

이전 | 처음으로 | 다음
ldap_next_attribute | 위로 | ldap_next_reference


ldap_next_reference

(PHP 4 >= 4.0.5, PHP 5)

ldap_next_reference -- Get next reference

Description

resource ldap_next_reference ( resource link, resource entry)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ldap_next_entry | 위로 | ldap_parse_reference


ldap_parse_reference

(PHP 4 >= 4.0.5, PHP 5)

ldap_parse_reference -- Extract information from reference entry

Description

bool ldap_parse_reference ( resource link, resource entry, array referrals)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ldap_next_reference | 위로 | ldap_parse_result


ldap_parse_result

(PHP 4 >= 4.0.5, PHP 5)

ldap_parse_result -- Extract information from result

Description

bool ldap_parse_result ( resource link, resource result, int errcode, string matcheddn, string errmsg, array referrals)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ldap_parse_reference | 위로 | ldap_read


ldap_read

(PHP 3, PHP 4 , PHP 5)

ldap_read -- Read an entry

Description

resource ldap_read ( resource link_identifier, string base_dn, string filter [, array attributes [, int attrsonly [, int sizelimit [, int timelimit [, int deref]]]]])

Returns a search result identifier or FALSE on error.

ldap_read() performs the search for a specified filter on the directory with the scope LDAP_SCOPE_BASE. So it is equivalent to reading an entry from the directory.

An empty filter is not allowed. If you want to retrieve absolutely all information for this entry, use a filter of "objectClass=*". If you know which entry types are used on the directory server, you might use an appropriate filter such as "objectClass=inetOrgPerson".

This call takes 5 optional parameters. See ldap_search() notes.

참고: These optional parameters were added in 4.0.2: attrsonly, sizelimit, timelimit, deref.

From 4.0.5 on it's also possible to do parallel searches. See ldap_search() for details.

이전 | 처음으로 | 다음
ldap_parse_result | 위로 | ldap_rename


ldap_rename

(PHP 4 >= 4.0.5, PHP 5)

ldap_rename -- Modify the name of an entry

Description

bool ldap_rename ( resource link_identifier, string dn, string newrdn, string newparent, bool deleteoldrdn)

The entry specified by dn is renamed/moved. The new RDN is specified by newrdn and the new parent/superior entry is specified by newparent. If the parameter deleteoldrdn is TRUE the old RDN value(s) is removed, else the old RDN value(s) is retained as non-distinguished values of the entry. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: This function currently only works with LDAPv3. You may have to use ldap_set_option() prior to binding to use LDAPv3. This function is only available when using OpenLDAP 2.x.x OR Netscape Directory SDK x.x, and was added in PHP 4.0.5.

이전 | 처음으로 | 다음
ldap_read | 위로 | ldap_search


ldap_search

(PHP 3, PHP 4 , PHP 5)

ldap_search -- Search LDAP tree

Description

resource ldap_search ( resource link_identifier, string base_dn, string filter [, array attributes [, int attrsonly [, int sizelimit [, int timelimit [, int deref]]]]])

Returns a search result identifier or FALSE on error.

ldap_search() performs the search for a specified filter on the directory with the scope of LDAP_SCOPE_SUBTREE. This is equivalent to searching the entire directory. base_dn specifies the base DN for the directory.

There is an optional fourth parameter, that can be added to restrict the attributes and values returned by the server to just those required. This is much more efficient than the default action (which is to return all attributes and their associated values). The use of the fourth parameter should therefore be considered good practice.

The fourth parameter is a standard PHP string array of the required attributes, e.g. array("mail", "sn", "cn") Note that the "dn" is always returned irrespective of which attributes types are requested.

Note too that some directory server hosts will be configured to return no more than a preset number of entries. If this occurs, the server will indicate that it has only returned a partial results set. This occurs also if the sixth parameter sizelimit has been used to limit the count of fetched entries.

The fifth parameter attrsonly should be set to 1 if only attribute types are wanted. If set to 0 both attributes types and attribute values are fetched which is the default behaviour.

With the sixth parameter sizelimit it is possible to limit the count of entries fetched. Setting this to 0 means no limit. NOTE: This parameter can NOT override server-side preset sizelimit. You can set it lower though.

The seventh parameter timelimit sets the number of seconds how long is spend on the search. Setting this to 0 means no limit. NOTE: This parameter can NOT override server-side preset timelimit. You can set it lower though.

The eighth parameter deref specifies how aliases should be handled during the search. It can be one of the following:

  • LDAP_DEREF_NEVER - (default) aliases are never dereferenced.

  • LDAP_DEREF_SEARCHING - aliases should be dereferenced during the search but not when locating the base object of the search.

  • LDAP_DEREF_FINDING - aliases should be dereferenced when locating the base object but not during the search.

  • LDAP_DEREF_ALWAYS - aliases should be dereferenced always.

참고: These optional parameters were added in 4.0.2: attrsonly, sizelimit, timelimit, deref.

The search filter can be simple or advanced, using boolean operators in the format described in the LDAP documentation (see the Netscape Directory SDK for full information on filters).

The example below retrieves the organizational unit, surname, given name and email address for all people in "My Company" where the surname or given name contains the substring $person. This example uses a boolean filter to tell the server to look for information in more than one attribute.

예 1. LDAP search

<?php
// $ds is a valid link identifier for a directory server

// $person is all or part of a person's name, eg "Jo"

$dn = "o=My Company, c=US";
$filter="(|(sn=$person*)(givenname=$person*))";
$justthese = array("ou", "sn", "givenname", "mail");

$sr=ldap_search($ds, $dn, $filter, $justthese);

$info = ldap_get_entries($ds, $sr);

echo $info["count"]." entries returned\n";
?>

From 4.0.5 on it's also possible to do parallel searches. To do this you use an array of link identifiers, rather than a single identifier, as the first argument. If you don't want the same base DN and the same filter for all the searches, you can also use an array of base DNs and/or an array of filters. Those arrays must be of the same size as the link identifier array since the first entries of the arrays are used for one search, the second entries are used for another, and so on. When doing parallel searches an array of search result identifiers is returned, except in case of error, then the entry corresponding to the search will be FALSE. This is very much like the value normally returned, except that a result identifier is always returned when a search was made. There are some rare cases where the normal search returns FALSE while the parallel search returns an identifier.

이전 | 처음으로 | 다음
ldap_rename | 위로 | ldap_set_option


ldap_set_option

(PHP 4 >= 4.0.4, PHP 5)

ldap_set_option -- Set the value of the given option

Description

bool ldap_set_option ( resource link_identifier, int option, mixed newval)

Sets the value of the specified option to be newval. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. on error.

The parameter option can be one of: LDAP_OPT_DEREF, LDAP_OPT_SIZELIMIT, LDAP_OPT_TIMELIMIT, LDAP_OPT_PROTOCOL_VERSION, LDAP_OPT_ERROR_NUMBER, LDAP_OPT_REFERRALS, LDAP_OPT_RESTART, LDAP_OPT_HOST_NAME, LDAP_OPT_ERROR_STRING, LDAP_OPT_MATCHED_DN, LDAP_OPT_SERVER_CONTROLS, LDAP_OPT_CLIENT_CONTROLS. Here's a brief description, see draft-ietf-ldapext-ldap-c-api-xx.txt for details.

The options LDAP_OPT_DEREF, LDAP_OPT_SIZELIMIT, LDAP_OPT_TIMELIMIT, LDAP_OPT_PROTOCOL_VERSION and LDAP_OPT_ERROR_NUMBER have integer value, LDAP_OPT_REFERRALS and LDAP_OPT_RESTART have boolean value, and the options LDAP_OPT_HOST_NAME, LDAP_OPT_ERROR_STRING and LDAP_OPT_MATCHED_DN have string value. The first example illustrates their use. The options LDAP_OPT_SERVER_CONTROLS and LDAP_OPT_CLIENT_CONTROLS require a list of controls, this means that the value must be an array of controls. A control consists of an oid identifying the control, an optional value, and an optional flag for criticality. In PHP a control is given by an array containing an element with the key oid and string value, and two optional elements. The optional elements are key value with string value and key iscritical with boolean value. iscritical defaults to FALSE if not supplied. See also the second example below.

참고: This function is only available when using OpenLDAP 2.x.x OR Netscape Directory SDK x.x, and was added in PHP 4.0.4.

예 1. Set protocol version

<?php
// $ds is a valid link identifier for a directory server
if (ldap_set_option($ds, LDAP_OPT_PROTOCOL_VERSION, 3)) {
    echo "Using LDAPv3";
} else {
    echo "Failed to set protocol version to 3";
}
?>

예 2. Set server controls

<?php
// $ds is a valid link identifier for a directory server
// control with no value
$ctrl1 = array("oid" => "1.2.752.58.10.1", "iscritical" => true);
// iscritical defaults to FALSE
$ctrl2 = array("oid" => "1.2.752.58.1.10", "value" => "magic");
// try to set both controls
if (!ldap_set_option($ds, LDAP_OPT_SERVER_CONTROLS, array($ctrl1, $ctrl2)))
    echo "Failed to set server controls";
?>

See also ldap_get_option().

이전 | 처음으로 | 다음
ldap_search | 위로 | ldap_set_rebind_proc


ldap_set_rebind_proc

(PHP 4 >= 4.2.0, PHP 5)

ldap_set_rebind_proc -- Set a callback function to do re-binds on referral chasing.

Description

bool ldap_set_rebind_proc ( resource link, string callback)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ldap_set_option | 위로 | ldap_sort


ldap_sort

(PHP 4 >= 4.2.0, PHP 5)

ldap_sort -- Sort LDAP result entries

Description

bool ldap_sort ( resource link, resource result, string sortfilter)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ldap_set_rebind_proc | 위로 | ldap_start_tls


ldap_start_tls

(PHP 4 >= 4.2.0, PHP 5)

ldap_start_tls -- Start TLS

Description

bool ldap_start_tls ( resource link)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ldap_sort | 위로 | ldap_t61_to_8859


ldap_t61_to_8859

(PHP 4 >= 4.0.2, PHP 5)

ldap_t61_to_8859 -- Translate t61 characters to 8859 characters

Description

string ldap_t61_to_8859 ( string value)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ldap_start_tls | 위로 | ldap_unbind


ldap_unbind

(PHP 3, PHP 4 , PHP 5)

ldap_unbind -- Unbind from LDAP directory

Description

bool ldap_unbind ( resource link_identifier)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

ldap_unbind() function unbinds from the LDAP directory.

이전 | 처음으로 | 다음
ldap_t61_to_8859 | 위로 | LZF Functions


LZF Functions

PHP 매뉴얼
이전 다음

XLIX. LZF Functions

소개

LZF is a very fast compression algorithm, ideal for saving space with only slight speed cost. It can be optimized for speed or space at the time of compilation.

설치

LZF is currently available through PECL http://pecl.php.net/package/lzf.

If PEAR is available on your *nix-like system you can use the pear installer to install the LZF extension, by the following command: pear -v install lzf.

You can always download the tar.gz package and install LZF by hand:

예 1. LZF install by hand

gunzip lzf-xxx.tgz
tar -xvf lzf-xxx.tar
cd lzf-xxx
phpize
./configure && make && make install

You can pass --enable-lzf-better-compression to optimize LZF for space rather then speed.

Windows users can download the extension dll php_lzf.dll from http://snaps.php.net/win32/PECL_STABLE/.

차례
lzf_compress -- LZF compression.
lzf_decompress -- LZF decompression.
lzf_optimized_for -- Determines what LZF extension was optimized for.

이전 | 처음으로 | 다음
ldap_unbind | 위로 | lzf_compress


lzf_compress

(no version information, might be only in CVS)

lzf_compress -- LZF compression.

Description

string lzf_compress ( string arg)

lzf_compress() compresses data in arg parameter.

Returns compressed data or FALSE if an error occured.

See also lzf_decompress().

이전 | 처음으로 | 다음
LZF Functions | 위로 | lzf_decompress


lzf_decompress

(no version information, might be only in CVS)

lzf_decompress -- LZF decompression.

Description

string lzf_decompress ( string arg)

lzf_decompress() decompresses data from parameter arg.

Returns decompressed data or FALSE if an error occured.

See also lzf_compress().

이전 | 처음으로 | 다음
lzf_compress | 위로 | lzf_optimized_for


lzf_optimized_for

(no version information, might be only in CVS)

lzf_optimized_for -- Determines what LZF extension was optimized for.

Description

int lzf_optimized_for ( void )

Returns 1 if LZF was optimized for speed, 0 for compression.

이전 | 처음으로 | 다음
lzf_decompress | 위로 | 메일 함수


메일 함수

PHP 매뉴얼
이전 다음

L. 메일 함수

소개

mail() 함수는 메일을 보낼 수 있게 합니다.

요구 사항

메일 함수를 사용하기 위해서는, PHP를 컴파일 할 때 시스템의 sendmail 바이너리에 접근할 수 있어야 합니다. qmail이나 postfix 등의 다른 메일 프로그램을 사용한다면, 포함되어있는 정확한 센드메일 랩퍼를 사용하게 하십시오. PHP는 센드메일을 PATH에서 찾고, 이후에 다음 순서를 적용합니다: /usr/bin:/usr/sbin:/usr/etc:/etc:/usr/ucblib:/usr/lib. PATH에 센드메일이 들어있도록 하는걸 권장합니다. 또한, PHP를 컴파일하는 유저가 센드메일 바이너리에 접근할 수 있는 권한이 있어야 합니다.

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. 메일 설정 옵션

이름 | 기본값 | 변경가능성
SMTP | "localhost" | PHP_INI_ALL
smtp_port | "25" | PHP_INI_ALL
sendmail_from | NULL | PHP_INI_ALL
sendmail_path | DEFAULT_SENDMAIL_PATH | PHP_INI_SYSTEM
PHP_INI_* 상수에 대한 자세한 내용 및 정의는 ini_set()을 참고하십시오

위 설정 지시어에 대한 간단한 설명입니다.

SMTP string

윈도우즈에서만 사용합니다: PHP가 mail() 함수를 사용하여 메일을 보낼때 사용할 SMTP 서버의 DNS 이름이나 IP 어드레스.

smtp_port int

윈도우즈에서만 사용합니다: mail()로 메일을 보낼 때 SMTP 설정에서 지정한 서버에 접속하기 위한 포트 번호; 기본값은 25. PHP 4.3.0부터 사용할 수 있습니다.

sendmail_from string

윈도우즈에서 PHP가 메일을 보낼 때 "From:"에 붙이는 메일 주소.

sendmail_path string

sendmail 프로그램이 있는 위치. 보통 /usr/sbin/sendmail이나 /usr/lib/sendmail. configure가 이 위치를 찾아서 기본값을 설정하지만, 실패했을 때는 이곳에 설정해야 합니다.

센드메일을 사용하지 않는 시스템은 이 지시어를 메일 시스템이 제공하는 센드메일 랩퍼/교체자로 설정해야합니다. 예를 들어, Qmail 사용자는 일반적으로 /var/qmail/bin/sendmail이나 /var/qmail/bin/qmail-inject으로 설정합니다.

qmail-inject는 메일을 정확하게 처리하기 위한 어떠한 옵션도 필요하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
ezmlm_hash -- EZMLM에 필요한 해쉬값을 계산합니다.
mail -- 메일을 보냅니다.

이전 | 처음으로 | 다음
lzf_optimized_for | 위로 | ezmlm_hash


ezmlm_hash

(PHP 3>= 3.0.17, PHP 4 >= 4.0.2, PHP 5)

ezmlm_hash -- EZMLM에 필요한 해쉬값을 계산합니다.

설명

int ezmlm_hash ( string addr)

ezmlm_hash()은 MySQL 데이터베이스에 EZMLM 메일링 리스트를 보존할 때 필요한 해쉬값을 계산합니다.

예 1. 해쉬를 계산하고 사용자를 추가합니다.

<?php

$user = "joecool@example.com";
$hash = ezmlm_hash($user);
$query = sprintf("INSERT INTO sample VALUES (%s, '%s')", $hash, $user);
$db->query($query); // PHPLIB db 인터페이스 사용.

?>

이전 | 처음으로 | 다음
메일 함수 | 위로 | mail


mail

(PHP 3, PHP 4 , PHP 5)

mail -- 메일을 보냅니다.

설명

bool mail ( string to, string subject, string message [, string additional_headers [, string additional_parameters]])

mail()은 자동적으로 message에 지정한 메세지를 to에 지정한 수신자에게 메일을 보냅니다. 복수 수신자는 to에 콤마로 구분한 각각의 어드레스를 지정할 수 있습니다. 부가 요소와 특별한 형태의 내용을 가진 Email을 이 함수를 이용하여 보낼 수 있습니다. MIME-encoding을 이용하여 이루어집니다 - 자세한 정보는 젠드 아티클이나 PEAR Mime 클래스를 참고하십시오.

다음의 RFC도 유용합니다: RFC 1896, RFC 2045, RFC 2046, RFC 2047, RFC 2048, RFC 2049.

mail()은 메일 전달이 성공하면 TRUE를, 그 외의 경우에는 FALSE를 반환합니다.

주의

mail()의 윈도우즈판은 유닉스판과 많은 점에서 차이가 있습니다. 첫번째, 메세지를 작성할 때 로컬 바이너리를 사용하지 않고, 단지 직접 소켓 연결을 합니다. MTA가 네트워크 소켓을 리스닝하고 있을 필요가 있습니다. (localhost나 원격 머신 어디든지 가능합니다) 둘째, From:, Cc:, Bcc:, Date: 등의 사용자 헤더는 MTA에서 해석하지 않고, PHP에서 처리를 합니다. PHP < 4.3은 Cc: 헤더 요소(대소문자 구별)만을 지원합니다. PHP >= 4.3은 위의 모든 헤더 요소를 지원하고, 대소문자를 구별하지 않습니다.

예 1. 메일 보내기.

<?php
mail("joecool@example.com", "My Subject", "Line 1\nLine 2\nLine 3");
?>

네번째 문자열 인자가 주어지면, 문자열은 헤더의 마지막에 추가됩니다. 일반적으로 기타 헤더를 추가할 때 사용합니다. 복수의 헤더는 캐리지리턴과 뉴라인으로 구별합니다.

참고: 헤더 구분에는 \r\n을 사용해야만 합니다. 일부 유닉스 메일 전송 에이전트는 하나의 뉴라인(\n)과는 작동하지 않습니다.

예 2. 추가 헤더를 지정해서 메일 보내기.

<?php
mail("nobody@example.com", "the subject", $message,
     "From: webmaster@{$_SERVER['SERVER_NAME']}\r\n" .
     "Reply-To: webmaster@{$_SERVER['SERVER_NAME']}\r\n" .
     "X-Mailer: PHP/" . phpversion());
?>

additional_parameters 인자는 메일을 보낼 때 사용하는 sendmail_path 설정에 있는 프로그램에 추가 인자를 넘깁니다. 예를 들어, 센드메일을 사용할때 인증 전송자 주소를 지정하는 -f 센드메일 옵션을 사용하게 할 수 있습니다. 이 방법으로 인증 전송자를 지정했을 때 'X-warning'헤더가 메세지에 추가되는 것을 막기 위해서는 센드메일 설정에 웹 서버를 실행하는 유저를 추가해야 합니다.

예 3. 추가 헤더와 추가 명령줄 인자를 지정하여 메일 보내기.

<?php
mail("nobody@example.com", "the subject", $message,
     "From: webmaster@{$_SERVER['SERVER_NAME']}", "-fwebmaster@{$_SERVER['SERVER_NAME']}");
?>

참고: 다섯번째 인자는 PHP 4.0.5에서 추가되었고, PHP 4.2.3부터 이 인자는 안전 모드에서는 사용할 수 없습니다. 이를 사용하려고 하면 mail() 함수는 경고 메세지를 출력하고 FALSE를 반환합니다.

복잡한 email 메세지를 작성하기 위해 간단한 문자열 작성 테크닉을 사용할 수 있습니다.

예 4. 복잡한 메일 보내기.

<?php
/* recipients */
$to  = "mary@example.com" . ", " ; // 콤마인 것에 주의.
$to .= "kelly@example.com";

/* subject */
$subject = "Birthday Reminders for August";

/* message */
$message = '
<html>
<head>
<title>Birthday Reminders for August</title>
</head>
<body>
<p>Here are the birthdays upcoming in August!</p>
<table>
<tr>
  <th>Person</th><th>Day</th><th>Month</th><th>Year</th>
</tr>
<tr>
  <td>Joe</td><td>3rd</td><td>August</td><td>1970</td>
</tr>
<tr>
  <td>Sally</td><td>17th</td><td>August</td><td>1973</td>
</tr>
</table>
</body>
</html>
';

/* HTML 메일을 보내려면, Content-type 헤더를 설정해야 합니다. */
$headers  = "MIME-Version: 1.0\r\n";
$headers .= "Content-type: text/html; charset=iso-8859-1\r\n";

/* 추가 헤더 */
$headers .= "To: Mary <mary@example.com>, Kelly <kelly@example.com>\r\n";
$headers .= "From: Birthday Reminder <birthday@example.com>\r\n";
$headers .= "Cc: birthdayarchive@example.com\r\n";
$headers .= "Bcc: birthdaycheck@example.com\r\n";

/* 그리고 메일을 보냅니다. */
mail($to, $subject, $message, $headers);
?>

참고: to나 subject에 어떠한 뉴라인 문자도 존재해서는 안됩니다. 그렇지 않으면, 메일은 정상적으로 보내지지 않을 수 있습니다.

참고: to 인자는 "Something <someone@example.com>" 형태로 주어져서는 안됩니다. mail 명령은 MTA와 통신할 때 이를 정상적으로 처리하지 못할 수 있습니다. (특히 윈도우즈에서)

참고: imap_mail().

이전 | 처음으로 | 다음
ezmlm_hash | 위로 | mailparse Functions


mailparse Functions

PHP 매뉴얼
이전 다음

LI. mailparse Functions

소개

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

This extension has been moved from PHP as of PHP 4.2.0 and now mailparse lives in PECL.

설치

These functions are only available if PHP was configured with --enable-mailparse.

차례
mailparse_determine_best_xfer_encoding -- Figures out the best way of encoding the content read from the file pointer fp, which must be seek-able
mailparse_msg_create -- Returns a handle that can be used to parse a message
mailparse_msg_extract_part_file -- Extracts/decodes a message section, decoding the transfer encoding
mailparse_msg_extract_part -- Extracts/decodes a message section. If callbackfunc is not specified, the contents will be sent to "stdout"
mailparse_msg_free -- Frees a handle allocated by mailparse_msg_create()
mailparse_msg_get_part_data -- Returns an associative array of info about the message
mailparse_msg_get_part -- Returns a handle on a given section in a mimemessage
mailparse_msg_get_structure -- Returns an array of mime section names in the supplied message
mailparse_msg_parse_file -- Parse file and return a resource representing the structure
mailparse_msg_parse -- Incrementally parse data into buffer
mailparse_rfc822_parse_addresses -- Parse addresses and returns a hash containing that data
mailparse_stream_encode -- Streams data from source file pointer, apply encoding and write to destfp
mailparse_uudecode_all -- Scans the data from fp and extract each embedded uuencoded file. Returns an array listing filename information

이전 | 처음으로 | 다음
mail | 위로 | mailparse_determine_best_xfer_encoding


mailparse_determine_best_xfer_encoding

(4.1.0 - 4.1.2 only)

mailparse_determine_best_xfer_encoding -- Figures out the best way of encoding the content read from the file pointer fp, which must be seek-able

Description

int mailparse_determine_best_xfer_encoding ( resource fp)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mailparse Functions | 위로 | mailparse_msg_create


mailparse_msg_create

(4.1.0 - 4.1.2 only)

mailparse_msg_create -- Returns a handle that can be used to parse a message

Description

int mailparse_msg_create ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mailparse_determine_best_xfer_encoding | 위로 | mailparse_msg_extract_part_file


mailparse_msg_extract_part_file

(4.1.0 - 4.1.2 only)

mailparse_msg_extract_part_file -- Extracts/decodes a message section, decoding the transfer encoding

Description

string mailparse_msg_extract_part_file ( resource rfc2045, string filename [, string callbackfunc])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mailparse_msg_create | 위로 | mailparse_msg_extract_part


mailparse_msg_extract_part

(4.1.0 - 4.1.2 only)

mailparse_msg_extract_part -- Extracts/decodes a message section. If callbackfunc is not specified, the contents will be sent to "stdout"

Description

void mailparse_msg_extract_part ( resource rfc2045, string msgbody [, string callbackfunc])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mailparse_msg_extract_part_file | 위로 | mailparse_msg_free


mailparse_msg_free

(4.1.0 - 4.1.2 only)

mailparse_msg_free -- Frees a handle allocated by mailparse_msg_create()

Description

void mailparse_msg_free ( resource rfc2045buf)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mailparse_msg_extract_part | 위로 | mailparse_msg_get_part_data


mailparse_msg_get_part_data

(4.1.0 - 4.1.2 only)

mailparse_msg_get_part_data -- Returns an associative array of info about the message

Description

array mailparse_msg_get_part_data ( resource rfc2045)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mailparse_msg_free | 위로 | mailparse_msg_get_part


mailparse_msg_get_part

(4.1.0 - 4.1.2 only)

mailparse_msg_get_part -- Returns a handle on a given section in a mimemessage

Description

int mailparse_msg_get_part ( resource rfc2045, string mimesection)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mailparse_msg_get_part_data | 위로 | mailparse_msg_get_structure


mailparse_msg_get_structure

(4.1.0 - 4.1.2 only)

mailparse_msg_get_structure -- Returns an array of mime section names in the supplied message

Description

array mailparse_msg_get_structure ( resource rfc2045)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mailparse_msg_get_part | 위로 | mailparse_msg_parse_file


mailparse_msg_parse_file

(4.1.0 - 4.1.2 only)

mailparse_msg_parse_file -- Parse file and return a resource representing the structure

Description

resource mailparse_msg_parse_file ( string filename)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mailparse_msg_get_structure | 위로 | mailparse_msg_parse


mailparse_msg_parse

(4.1.0 - 4.1.2 only)

mailparse_msg_parse -- Incrementally parse data into buffer

Description

void mailparse_msg_parse ( resource rfc2045buf, string data)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mailparse_msg_parse_file | 위로 | mailparse_rfc822_parse_addresses


mailparse_rfc822_parse_addresses

(4.1.0 - 4.1.2 only)

mailparse_rfc822_parse_addresses -- Parse addresses and returns a hash containing that data

Description

array mailparse_rfc822_parse_addresses ( string addresses)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mailparse_msg_parse | 위로 | mailparse_stream_encode


mailparse_stream_encode

(4.1.0 - 4.1.2 only)

mailparse_stream_encode -- Streams data from source file pointer, apply encoding and write to destfp

Description

bool mailparse_stream_encode ( resource sourcefp, resource destfp, string encoding)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mailparse_rfc822_parse_addresses | 위로 | mailparse_uudecode_all


mailparse_uudecode_all

(no version information, might be only in CVS)

mailparse_uudecode_all -- Scans the data from fp and extract each embedded uuencoded file. Returns an array listing filename information

Description

array mailparse_uudecode_all ( resource fp)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mailparse_stream_encode | 위로 | 수학 함수


수학 함수

PHP 매뉴얼
이전 다음

LII. 수학 함수

소개

수학 함수는 컴퓨터의 integer형과 float형만을 취급합니다. (현재 C에서의 long과 double형에 해당합니다) 더 큰 수를 다룰 필요가 있다면, 부정 정밀 수학 함수를 참고하십시오.

매뉴얼의 산술 연산자 페이지도 참고하십시오.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

아래 상수들은 PHP 코어의 일부로, 항상 사용할 수 있습니다.

표 1. 수학 상수

상수 | 값 | 설명
M_PI | 3.14159265358979323846 | pi
M_E | 2.7182818284590452354 | e
M_LOG2E | 1.4426950408889634074 | log_2 e
M_LOG10E | 0.43429448190325182765 | log_10 e
M_LN2 | 0.69314718055994530942 | log_e 2
M_LN10 | 2.30258509299404568402 | log_e 10
M_PI_2 | 1.57079632679489661923 | pi/2
M_PI_4 | 0.78539816339744830962 | pi/4
M_1_PI | 0.31830988618379067154 | 1/pi
M_2_PI | 0.63661977236758134308 | 2/pi
M_SQRTPI | 1.77245385090551602729 | sqrt(pi) [4.0.2]
M_2_SQRTPI | 1.12837916709551257390 | 2/sqrt(pi)
M_SQRT2 | 1.41421356237309504880 | sqrt(2)
M_SQRT3 | 1.73205080756887729352 | sqrt(3) [4.0.2]
M_SQRT1_2 | 0.70710678118654752440 | 1/sqrt(2)
M_LNPI | 1.14472988584940017414 | log_e(pi) [4.0.2]
M_EULER | 0.57721566490153286061 | Euler constant [4.0.2]
M_PI는 PHP 4.0.0을 포함하여 그 이상의 PHP 버전에서 사용 가능합니다. 다른 상수들은 PHP 4.0.0부터 사용 가능합니다. [4.0.2]라고 붙어있는 상수들은 PHP 4.0.2에서 추가되었습니다.

차례
abs -- 절대값
acos -- 아크 코사인
acosh -- 역 쌍곡선 코사인
asin -- 아크 사인
asinh -- 역 쌍곡선 사인
atan2 -- 두 변수의 아크 탄젠트
atan -- 아크 탄젠트
atanh -- 역 쌍곡선 탄젠트
base_convert -- 수를 임의의 진수로 변환합니다.
bindec -- 2진수를 10진수로 변환합니다.
ceil -- 소수점 이하 올림
cos -- 코사인
cosh -- 쌍곡선 코사인
decbin -- 10진수를 2진수로 변환합니다.
dechex -- 10진수를 16진수로 변환합니다.
decoct -- 10진수를 8진수로 변환합니다.
deg2rad -- 각도를 라디안으로 변환합니다.
exp -- e(자연로그 밑)의 승수를 계산합니다.
expm1 -- 수가 0에 가까울 경우에도 정밀한 방법으로 계산한 exp(number) - 1을 반환합니다.
floor -- 소수점 내림
fmod -- 인자의 나눗셈에 대한 소수점 나머지(modulo)를 반환합니다.
getrandmax -- 랜덤 값의 가장 큰 값을 보여줍니다.
hexdec -- 16진수를 10진수로 변환합니다.
hypot -- sqrt(num1*num1 + num2*num2)를 반환합니다.
is_finite -- 값이 허용된 범위의 수인지 확인합니다.
is_infinite -- 값이 무한인지 확인합니다.
is_nan -- 값이 수가 아닌지 확인합니다.
lcg_value -- 조합 선형 합동 생성기(Combined linear congruential generator)
log10 -- 상용로그
log1p -- 수가 0에 가까울 경우에도 정밀하게 계산한 log(1 + number)을 반환합니다.
log -- 자연로그
max -- 최고값을 찾습니다.
min -- 최소값을 찾습니다.
mt_getrandmax -- 가능한 가장 큰 랜덤 값을 보여줍니다.
mt_rand -- 향상된 난수를 생성합니다.
mt_srand -- 향상된 난수 생성기를 초기화합니다.
octdec -- 8진수를 10진수로 변환합니다.
pi -- 파이(pi)값을 얻는다.
pow -- 거듭제곱
rad2deg -- 라디안을 각도로 변환합니다.
rand -- 정수형의 난수를 생성합니다.
round -- 실수를 반올림합니다.
sin -- 사인
sinh -- 쌍곡선 사인
sqrt -- 평방 제곱근
srand -- 난수 생성기를 초기화합니다.
tan -- 탄젠트
tanh -- 쌍곡선 탄젠트

이전 | 처음으로 | 다음
mailparse_uudecode_all | 위로 | abs


abs

(PHP 3, PHP 4 , PHP 5)

abs -- 절대값

설명

number abs ( mixed number)

number의 절대값을 반환합니다. number 인자의 형이 float일 경우, 반환값도 float이고, integer일 경우에도 마찬가지입니다. (일반적으로 float 값의 범위가 integer 값의 범위보다 큽니다)

예 1. abs() 예제

<?php
$abs = abs(-4.2); // $abs = 4.2; (double/float)
$abs2 = abs(5);   // $abs2 = 5; (integer)
$abs3 = abs(-5);  // $abs3 = 5; (integer)
?>

이전 | 처음으로 | 다음
수학 함수 | 위로 | acos


acos

(PHP 3, PHP 4 , PHP 5)

acos -- 아크 코사인

설명

float acos ( float arg)

arg의 아크 코사인을 라디안으로 반환합니다. acos()은 cos()의 역함수로, acos()의 범위 안에 있는 모든 값에 대해서 a==cos(acos(a))가 성립합니다.

참고:
acosh(),
asin(),
atan().

이전 | 처음으로 | 다음
abs | 위로 | acosh


acosh

(PHP 4 >= 4.1.0, PHP 5)

acosh -- 역 쌍곡선 코사인

설명

float acosh ( float arg)

arg의 역 쌍곡선 코사인 값을 반환합니다. 즉, 반환값의 쌍곡선 코사인은 arg가 됩니다.

참고: 이 함수는 윈도우 플랫폼에서는 작동하지 않습니다.

참고:
acos(),
asinh(),
atanh().

이전 | 처음으로 | 다음
acos | 위로 | asin


asin

(PHP 3, PHP 4 , PHP 5)

asin -- 아크 사인

설명

float asin ( float arg)

arg의 아크 사인값을 라디안으로 반환합니다. asin()은 sin()의 역함수로, asin()의 범위 안에 들어가는 모든 값에 대하여 a==sin(asin(a))가 성립합니다.

참고:
asinh(),
acos(),
atan().

이전 | 처음으로 | 다음
acosh | 위로 | asinh


asinh

(PHP 4 >= 4.1.0, PHP 5)

asinh -- 역 쌍곡선 사인

설명

float asinh ( float arg)

arg의 역 쌍곡선 사인값을 반환합니다. 즉, 반환값의 쌍곡선 사인은 arg가 됩니다.

참고: 이 함수는 윈도우 플랫폼에서는 작동하지 않습니다.

참고:
asin(),
acosh(),
atanh().

이전 | 처음으로 | 다음
asin | 위로 | atan2


atan2

(PHP 3>= 3.0.5, PHP 4 , PHP 5)

atan2 -- 두 변수의 아크 탄젠트

설명

float atan2 ( float y, float x)

두 변수 x와 y의 아크 탄젠트를 계산합니다. 이것은 각 인자의 부호가 4분구간을 결정한다는 점을 제외하면 y / x의 아크 탄젠트와 동일합니다.

라디안으로 결과를 반환합니다. 그 값은 -PI와 PI(포함) 사이입니다.

참고: acos(), atan().

이전 | 처음으로 | 다음
asinh | 위로 | atan


atan

(PHP 3, PHP 4 , PHP 5)

atan -- 아크 탄젠트

설명

float atan ( float arg)

arg의 아크 탄젠트 값을 라디안으로 반환합니다. atan()는 tan()의 역함수로, atan()의 범위 안에 있는 모든 값에 대하여 a==tan(atan(a))가 성립합니다.

참고:
atanh(),
asin(),
acos().

이전 | 처음으로 | 다음
atan2 | 위로 | atanh


atanh

(PHP 4 >= 4.1.0, PHP 5)

atanh -- 역 쌍곡선 탄젠트

설명

float atanh ( float arg)

arg의 역 쌍곡선 탄젠트 값을 반환합니다. 즉, 반환값의 쌍곡선 탄젠트는 arg가 됩니다.

참고: 이 함수는 윈도우 플랫폼에서는 작동하지 않습니다.

참고:
atan(),
asinh(),
acosh().

이전 | 처음으로 | 다음
atan | 위로 | base_convert


base_convert

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

base_convert -- 수를 임의의 진수로 변환합니다.

설명

string base_convert ( string number, int frombase, int tobase)

tobase진수로 표현한 number를 포함하는 문자열을 반환합니다. number의 진수는 frombase로 주어집니다. frombase와 tobase는 2와 36(포함) 사이의 값이여야 합니다. 10 이상의 진수로 표현되는 자리수는 a-z로 표현되며, a는 10, b는 11, ..., z는 35를 의미합니다.

예 1. base_convert() 예제

<?php
$hexadecimal = 'A37334';
echo base_convert($hexadecimal, 16, 2);
?>

출력:

101000110111001100110100

주의

base_convert()는 큰 수에 대해서는 내부적으로 "double"이나 "float" 형을 사용하기 때문에, 부정확할 수 있습니다. 더욱 정확한 정보와 제한에 대해서는 부동소수점수 섹션을 참고하십시오.

이전 | 처음으로 | 다음
atanh | 위로 | bindec


bindec

(PHP 3, PHP 4 , PHP 5)

bindec -- 2진수를 10진수로 변환합니다.

설명

int bindec ( string binary_string)

binary_string 인자에 표현된 2진수와 동일한 10진수를 반환합니다.

bindec()는 이진수를 integer로 변환합니다. 변환 가능한 가장 큰 숫자는 1의 31비트로, 10진수 2147483647에 해당합니다.

예 1. bindec() 예제

<?php
echo bindec('110011') . "\n";
echo bindec('000110011') . "\n";

echo bindec('111');
?>

위 예제의 출력은:

51
51
7

참고: decbin(), octdec(), hexdec(), base_convert().

이전 | 처음으로 | 다음
base_convert | 위로 | ceil


ceil

(PHP 3, PHP 4 , PHP 5)

ceil -- 소수점 이하 올림

설명

float ceil ( float value)

필요하다면 value를 소수점 올림해서 다음으로 가장 높은 정수를 반환합니다. 보통 float의 범위가 integer형보다 크기 때문에, ceil()의 반환값은 여전히 float형입니다.

예 1. ceil() 예제

<?php
echo ceil(4.3);    // 5
echo ceil(9.999);  // 10
?>

참고: floor(), round().

이전 | 처음으로 | 다음
bindec | 위로 | cos


cos

(PHP 3, PHP 4 , PHP 5)

cos -- 코사인

설명

float cos ( float arg)

cos()은 arg 인수의 코사인값을 반환합니다. arg 인자는 라디안 값으로 주어집니다.

예 1. cos() 예제

<?php

echo cos(M_PI); // -1

?>

참고:
acos(),
sin(),
tan(),
deg2rad().

이전 | 처음으로 | 다음
ceil | 위로 | cosh


cosh

(PHP 4 >= 4.1.0, PHP 5)

cosh -- 쌍곡선 코사인

설명

float cosh ( float arg)

(exp(arg) + exp(-arg))/2로 정의되는, arg의 쌍곡선 코사인을 반환합니다.

참고:
cos(),
acosh(),
sin(),
tan().

이전 | 처음으로 | 다음
cos | 위로 | decbin


decbin

(PHP 3, PHP 4 , PHP 5)

decbin -- 10진수를 2진수로 변환합니다.

설명

string decbin ( int number)

주어진 number 인자에 대응하는 2진수 표현의 문자열을 반환합니다. 변환 가능한 가장 큰 숫자는 10진수 4294967295로, 결과값은 1이 32개 들어간 문자열이 됩니다.

예 1. decbin() 예제

<?php
echo decbin(12) . "\n";
echo decbin(26);
?>

위 예제의 출력은:

1101
11010

참고: bindec(), decoct(), dechex(), base_convert().

이전 | 처음으로 | 다음
cosh | 위로 | dechex


dechex

(PHP 3, PHP 4 , PHP 5)

dechex -- 10진수를 16진수로 변환합니다.

설명

string dechex ( int number)

주어진 number 인자에 해당하는 16진수 표현의 문자열을 반환합니다. 변환 가능한 가장 큰 숫자는 10진수 2147483647로, 결과값은 "7fffffff"이 됩니다.

예 1. dechex() 예제

<?php
echo dechex(10) . "\n";
echo dechex(47);
?>

위 예제의 출력은:

a
2f

참고: hexdec(), decbin(), decoct(), base_convert().

이전 | 처음으로 | 다음
decbin | 위로 | decoct


decoct

(PHP 3, PHP 4 , PHP 5)

decoct -- 10진수를 8진수로 변환합니다.

설명

string decoct ( int number)

주어진 number 인자에 해당하는 8진수 표현의 문자열을 반환합니다. 변환 가능한 가장 큰 숫자는 10진수 2147483647로, 결과값은 "17777777777"이 됩니다.

예 1. decoct() 예제

<?php
echo decoct(15) . "\n";
echo decoct(264);
?>

위 예제의 출력은:

17
410

참고: octdec(), decbin(), dechex(), base_convert().

이전 | 처음으로 | 다음
dechex | 위로 | deg2rad


deg2rad

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

deg2rad -- 각도를 라디안으로 변환합니다.

설명

float deg2rad ( float number)

number를 각도에서 라디안으로 변환합니다.

예 1. deg2rad() 예제

<?php

echo deg2rad(45); // 0.785398163397
var_dump(deg2rad(45) === M_PI_4); // bool(true)

?>

참고: rad2deg().

이전 | 처음으로 | 다음
decoct | 위로 | exp


exp

(PHP 3, PHP 4 , PHP 5)

exp -- e(자연로그 밑)의 승수를 계산합니다.

설명

float exp ( float arg)

e의 arg승을 반환합니다.

참고: 'e'는 자연로그의 밑으로, 약 2.718282입니다.

예 1. exp() 예제

<?php
echo exp(12) . "\n";
echo exp(5.7);
?>

위 예제의 출력은:

1.6257E+005
298.87

참고: log(), pow().

이전 | 처음으로 | 다음
deg2rad | 위로 | expm1


expm1

(PHP 4 >= 4.1.0, PHP 5)

expm1 -- 수가 0에 가까울 경우에도 정밀한 방법으로 계산한 exp(number) - 1을 반환합니다.

설명

float expm1 ( float number)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: 이 함수는 윈도우 플랫폼에서는 작동하지 않습니다.

이전 | 처음으로 | 다음
exp | 위로 | floor


floor

(PHP 3, PHP 4 , PHP 5)

floor -- 소수점 내림

설명

float floor ( float value)

필요할 경우 value를 소수점 내림한 다음으로 가장 작은 정수를 반환합니다. 보통 float의 범위가 integer의 범위보다 크기 때문에, floor()의 반환값은 여전히 float를 유지합니다.

예 1. floor() 예제

<?php
echo floor(4.3);   // 4
echo floor(9.999); // 9
?>

참고: ceil(), round().

이전 | 처음으로 | 다음
expm1 | 위로 | fmod


fmod

(PHP 4 >= 4.2.0, PHP 5)

fmod -- 인자의 나눗셈에 대한 소수점 나머지(modulo)를 반환합니다.

설명

float fmod ( float x, float y)

x를 y로 나누는 나눗셈의 소수점 나머지를 반환합니다. 나머지(r)는 특정한 정수 i와 함께 x = i * y + r로 정의됩니다. y가 0이 아니라면, r는 x와 같은 부호와 y의 크기보다 작은 크기를 가집니다.

예 1. fmod() 사용하기

<?php
$x = 5.7;
$y = 1.3;
$r = fmod($x, $y);
// 4 * 1.3 + 0.5 = 5.7이기 때문에, $r은 0.5가 된다.
?>

이전 | 처음으로 | 다음
floor | 위로 | getrandmax


getrandmax

(PHP 3, PHP 4 , PHP 5)

getrandmax -- 랜덤 값의 가장 큰 값을 보여줍니다.

설명

int getrandmax ( void )

rand()를 호출함으로써 얻을 수 있는 가장 큰 값을 반환합니다.

참고: rand(), srand(), mt_getrandmax().

이전 | 처음으로 | 다음
fmod | 위로 | hexdec


hexdec

(PHP 3, PHP 4 , PHP 5)

hexdec -- 16진수를 10진수로 변환합니다.

설명

int hexdec ( string hex_string)

hex_string 인자에 표현된 16진수와 동등한 10진수를 반환합니다. hexdec()는 16진수 문자열을 10진수 숫자로 변환합니다. 변환 가능한 가장 큰 수는 7fffffff로, 10진수 2147483647에 해당합니다.

hexdec()는 16진수를 나타내는 문자가 아닌 모든 문자를 무시합니다.

예 1. hexdec() 예제

<?php
var_dump(hexdec("See"));
var_dump(hexdec("ee"));
// 둘 다 "int(238)"을 출력합니다.

var_dump(hexdec("that")); // "int(10)"을 출력합니다.
var_dump(hexdec("a0")); // "int(160)"을 출력합니다.
?>

참고: dechex(),
bindec(),
octdec(),
base_convert().

이전 | 처음으로 | 다음
getrandmax | 위로 | hypot


hypot

(PHP 4 >= 4.1.0, PHP 5)

hypot -- sqrt(num1*num1 + num2*num2)를 반환합니다.

설명

float hypot ( float num1, float num2)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
hexdec | 위로 | is_finite


is_finite

(PHP 4 >= 4.2.0, PHP 5)

is_finite -- 값이 허용된 범위의 수인지 확인합니다.

설명

bool is_finite ( float val)

val가 이 플랫폼에서 PHP float에 허용된 범위 안에 존재하는 적합한 유한수일 경우 TRUE를 반환합니다.

참고: is_infinite(), is_nan().

이전 | 처음으로 | 다음
hypot | 위로 | is_infinite


is_infinite

(PHP 4 >= 4.2.0, PHP 5)

is_infinite -- 값이 무한인지 확인합니다.

설명

bool is_infinite ( float val)

val가 log(0)의 결과 등의 무한수이거나, 이 플랫폼에서 float로 처리할 수 없는 너무 큰 숫자일 경우 TRUE를 반환합니다.

참고: is_finite(), is_nan().

이전 | 처음으로 | 다음
is_finite | 위로 | is_nan


is_nan

(PHP 4 >= 4.2.0, PHP 5)

is_nan -- 값이 수가 아닌지 확인합니다.

설명

bool is_nan ( float val)

val가 숫자가 아닐(not a number) 경우 TRUE를 반환합니다. acos(1.01)의 결과 등이 해당합니다.

참고: is_finite(), is_infinite().

이전 | 처음으로 | 다음
is_infinite | 위로 | lcg_value


lcg_value

(PHP 4 , PHP 5)

lcg_value -- 조합 선형 합동 생성기(Combined linear congruential generator)

설명

float lcg_value ( void )

lcg_value()는 (0, 1)의 범위의 가상 난수를 반환합니다. 2^31 - 85와 2^31 - 249 구간의 두개의 CG를 조합합니다. 이 함수의 구간은 두 소수의 산물과 일치합니다.

이전 | 처음으로 | 다음
is_nan | 위로 | log10


log10

(PHP 3, PHP 4 , PHP 5)

log10 -- 상용로그

설명

float log10 ( float arg)

arg의 상용로그를 반환합니다.

참고: log()

이전 | 처음으로 | 다음
lcg_value | 위로 | log1p


log1p

(PHP 4 >= 4.1.0, PHP 5)

log1p -- 수가 0에 가까울 경우에도 정밀하게 계산한 log(1 + number)을 반환합니다.

설명

float log1p ( float number)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: 이 함수는 윈도우 플랫폼에서는 작동하지 않습니다.

이전 | 처음으로 | 다음
log10 | 위로 | log


log

(PHP 3, PHP 4 , PHP 5)

log -- 자연로그

설명

float log ( float arg [, float base])

부수적인 base 인자가 정의되면, log()는 logbase arg를 반환합니다. 그 외의 경우에는 log()는 arg의 자연로그를 반환합니다.

참고: base 인자는 PHP 4.3.0부터 사용할 수 있습니다.

밑이 b인 n에 대한 로그는 수학적인 방법을 이용해서 계산할 수 있습니다: 로그가 자연로그일 경우, logb(n) = log(n)/log(b)

참고: exp().

이전 | 처음으로 | 다음
log1p | 위로 | max


max

(PHP 3, PHP 4 , PHP 5)

max -- 최고값을 찾습니다.

설명

mixed max ( number arg1, number arg2 [, number ...])

mixed max ( array numbers [, array ...])

max()는 인자 중 수치적인 최고값을 반환합니다.

첫번째 인자만이 배열이라면, max()는 그 배열에서의 최고값을 반환합니다. 첫번째 인자가 정수, 문자열, 혹은 실수일 경우 최소한 2개의 인자가 필요하며, max()는 그 중에 최고값을 반환합니다. 비교할 수 있는 값의 수는 무제한입니다.

참고: PHP는 숫자가 아닌 string은 0으로 계산하지만, 그것이 가장 큰 값일 경우 그 문자열을 반환합니다. 0으로 계산된 여러 인자가 존재할 경우, max()는 가장 처음 나온 값을 사용합니다. (가장 왼쪽의 값)

예 1. max()의 사용 예제

<?php
echo max(1, 3, 5, 6, 7);  // 7
echo max(array(2, 4, 5)); // 5

echo max(0, 'hello');     // 0
echo max('hello', 0);     // hello
echo max(-1, 'hello');    // hello

// 복수 배열일 경우, max는 왼쪽에서 오른쪽으로 비교합니다.
// 이 예제에서는: 2 == 2, 그 다음에 4 < 5
$val = max(array(2, 4, 8), array(2, 5, 7)); // array(2, 5, 7)

// 배열과 배열이 아닌것이 주어질 때는 배열 중에서
// 가장 큰 배열을 반환합니다.
$val = max('string', array(2, 5, 7), 42);   // array(2, 5, 7)
?>

참고: min(), count().

이전 | 처음으로 | 다음
log | 위로 | min


min

(PHP 3, PHP 4 , PHP 5)

min -- 최소값을 찾습니다.

Description

mixed min ( number arg1, number arg2 [, number ...])

mixed min ( array numbers [, array ...])

min()은 인자 중 수치적인 최소값을 반환합니다.

단 하나의 인자가 배열로 주어지면, min()은 배열에서 최소값을 반환합니다. 첫번째 인자가 정수, 문자열, 실수일 경우에는 최소한 2개의 인자가 필요하며, min()은 이 값들 중 최소값을 반환합니다. 비교할 수 있는 값의 갯수는 무제한입니다.

참고: PHP는 숫자가 아닌 string을 0으로 계산하고, 수치적으로 최소값일 경우에는 그 문자열을 반환합니다. 복수의 인자가 0으로 계산될 경우, min()은 첫번째 것(가장 왼쪽의 값)을 반환합니다.

예 1. min()의 사용 예제

<?php
echo min(2, 3, 1, 6, 7));  // 1
echo min(array(2, 4, 5));  // 2

echo min(0, 'hello'));     // 0
echo min('hello', 0));     // hello
echo min('hello', -1));    // -1

// 복수의 배열에서, min은 왼쪽에서 오른쪽으로 비교합니다.
// 예제에서는: 2 == 2, 그리고 4 < 5
$val = min(array(2, 4, 8), array(2, 5, 1)); // array(2, 4, 8)
// 배열과 배열이 아닌 것이 주어지면, 배열은
// 가장 큰 것으로 생각되어 항상 반환되지 않습니다.
$val = min('string', array(2, 5, 7), 42);   // string
?>

참고: max(), count().

이전 | 처음으로 | 다음
max | 위로 | mt_getrandmax


mt_getrandmax

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

mt_getrandmax -- 가능한 가장 큰 랜덤 값을 보여줍니다.

설명

int mt_getrandmax ( void )

mt_rand()를 호출했을 때 반환될 수 있는 가장 큰 값을 반환합니다.

참고:
mt_rand(),
mt_srand(),
getrandmax().

이전 | 처음으로 | 다음
min | 위로 | mt_rand


mt_rand

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

mt_rand -- 향상된 난수를 생성합니다.

설명

int mt_rand ( [int min, int max])

사용해 온 libc들의 많은 난수 생성기는 이상하거나, 특성을 알 수 없거나, 느렸습니다. 기본적으로, PHP는 rand() 함수에서 libc 난수 생성기를 이용합니다. mt_rand()는 이를 대체합니다. Mersenne Twister를 사용하는 확실한 특성을 가진 난수 생성기를 이용합니다. 이것은 평균적인 libc 제공의 난수 생성기에 비해 4배 정도 빠릅니다.

선택적인 min, max 인자 없이 호출하면, mt_rand()는 0과 RAND_MAX 사이의 모조 난수를 반환합니다. 예를 들어, 5와 15(포함)사이의 난수를 원할 경우에는, mt_rand (5, 15)로 사용합니다.

예 1. mt_rand() 예제

<?php
echo mt_rand() . "\n";
echo mt_rand() . "\n";

echo mt_rand(5, 15);
?>

위 예제의 출력 예는:

1604716014
1478613278
6

참고: PHP 4.2.0부터 srand()나 mt_srand()를 이용해서 난수값 생성기를 초기화 할 필요가 없습니다. 자동적으로 이루어집니다.

참고: 3.0.7 이전 버전에서는 max의 의미는 range였습니다. 이 버전에서 위에 든 예처럼 5에서 15 사이의 난수를 얻기 위해서는 mt_rand (5, 11)로 사용해야 합니다.

참고:
mt_srand(),
mt_getrandmax(),
rand().

이전 | 처음으로 | 다음
mt_getrandmax | 위로 | mt_srand


mt_srand

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

mt_srand -- 향상된 난수 생성기를 초기화합니다.

설명

void mt_srand ( [int seed])

seed로 난수 생생기를 초기화합니다. PHP 4.2.0부터, seed는 선택적으로 변경되었고, 생략할 경우에도 기본값으로 난수를 생성합니다.

예 1. mt_srand() 예제

<?php
// 마이크로초로 초기화
function make_seed()
{
    list($usec, $sec) = explode(' ', microtime());
    return (float) $sec + ((float) $usec * 100000);
}
mt_srand(make_seed());
$randval = mt_rand();
?>

참고: PHP 4.2.0부터 srand()나 mt_srand()를 이용해서 난수값 생성기를 초기화 할 필요가 없습니다. 자동적으로 이루어집니다.

참고:
mt_rand(),
mt_getrandmax(),
srand().

이전 | 처음으로 | 다음
mt_rand | 위로 | octdec


octdec

(PHP 3, PHP 4 , PHP 5)

octdec -- 8진수를 10진수로 변환합니다.

설명

int octdec ( string octal_string)

octal_string 인수로 주어진 8진수에 해당하는 10진수를 반환합니다. 변환 가능한 가장 큰 숫자는 17777777777로, 10진수 2147483647에 해당합니다.

예 1. octdec() 예제

<?php
echo octdec('77') . "\n";
echo octdec(decoct(45));
?>

위 예제의 출력은:

63
45

참고:
decoct(),
bindec(),
hexdec(),
base_convert().

이전 | 처음으로 | 다음
mt_srand | 위로 | pi


pi

(PHP 3, PHP 4 , PHP 5)

pi -- 파이(pi)값을 얻는다.

Description

float pi ( void )

파이(pi)의 근사값을 반환합니다. 반환되는 float는 php.ini의 precision이 지시하는 정밀도를 가집니다. 기본값은 14입니다. 또는 pi()가 생성하는 결과와 똑같은 값을 가지는 M_PI 상수를 이용할 수도 있습니다.

예 1. pi() 예제

<?php
echo pi(); // 3.1415926535898
echo M_PI; // 3.1415926535898
?>

이전 | 처음으로 | 다음
octdec | 위로 | pow


pow

(PHP 3, PHP 4 , PHP 5)

pow -- 거듭제곱

설명

number pow ( number base, number exp)

base의 exp승을 반환합니다. 이 함수는 가능한 한 integer로 반환합니다.

계산을 할 수 없으면 경고가 발생하고, pow()는 FALSE를 반환합니다. PHP 4.2.0부터 pow()는 어떠한 경고도 발생하지 않습니다.

참고: PHP는 음수의 base를 다루지 못합니다.

예 1. pow() 예제

<?php

var_dump(pow(2, 8)); // int(256)
echo pow(-1, 20); // 1
echo pow(0, 0); // 1

echo pow(-1, 5.5); // 에러

?>

주의

PHP 4.0.6과 그 이전에는 pow()는 항상 float를 반환하고, 경고를 발생하지 않습니다.

참고:
exp(),
sqrt(),
bcpow(),
gmp_pow().

이전 | 처음으로 | 다음
pi | 위로 | rad2deg


rad2deg

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

rad2deg -- 라디안을 각도로 변환합니다.

설명

float rad2deg ( float number)

이 함수는 number를 라디안에서 각도로 변환합니다.

예 1. rad2deg() 예제

<?php

echo rad2deg(M_PI_4); // 45

?>

참고: deg2rad().

이전 | 처음으로 | 다음
pow | 위로 | rand


rand

(PHP 3, PHP 4 , PHP 5)

rand -- 정수형의 난수를 생성합니다.

설명

int rand ( [int min, int max])

부수적인 min, max 인수 없이 호출하면, rand()는 0과 RAND_MAX 사이의 임의의 난수를 반환합니다. 예를 들어, 5와 15(포함) 사이의 난수를 얻으려면, rand (5, 15)로 사용합니다.

예 1. rand() 예제

<?php
echo rand() . "\n";
echo rand() . "\n";
echo rand(5, 15);
?>

위 예제의 출력 예는:

7771
22264
11

참고: 몇몇 플래폼(Windows 등)에서는 RAND_MAX는 32768까지 입니다. 32768보다 큰 범위가 필요할 경우에는, min과 max를 지정하여 RAND_MAX보다 큰 범위를 만들거나, mt_rand()을 사용하십시오.

참고: PHP 4.2.0부터 srand()나 mt_srand()를 이용해서 난수값 생성기를 초기화 할 필요가 없습니다. 자동적으로 이루어집니다.

참고: 3.0.7 이전의 버전에서는 max의 의미는 range였습니다. 이 버전에서 위의 예제와 같이 5에서 15 사이의 난수를 얻기 위해서는 rand (5, 11)로 사용해야만 합니다.

참고:
srand(),
getrandmax(),
mt_rand().

이전 | 처음으로 | 다음
rad2deg | 위로 | round


round

(PHP 3, PHP 4 , PHP 5)

round -- 실수를 반올림합니다.

설명

float round ( float val [, int precision])

val를 주어진 precision(소수점 아래의 자리수)까지 반올림한 값을 반환합니다. precision는 음수나 0(기본값)을 가질 수 있습니다.

예 1. round() 예제

<?php
echo round(3.4);         // 3
echo round(3.5);         // 4
echo round(3.6);         // 4
echo round(3.6, 0);      // 4
echo round(1.95583, 2);  // 1.96
echo round(1241757, -3); // 1242000
echo round(5.045, 2);    // 5.05
echo round(5.055, 2);    // 5.06
?>

참고: PHP는 기본적으로 "12,300.2"과 같은 문자열을 정상적으로 다루지 못합니다. 문자열에서 변환하기를 참고하십시오.

참고: precision 인자는 PHP 4에서만 사용할 수 있습니다.

참고:
ceil(),
floor(),
number_format().

이전 | 처음으로 | 다음
rand | 위로 | sin


sin

(PHP 3, PHP 4 , PHP 5)

sin -- 사인

설명

float sin ( float arg)

sin()은 arg 인자의 사인값을 반환합니다. arg 인자는 라디안으로 주어집니다.

예 1. sin() 예제

<?php

// 정밀도는 precision 설정에 의존합니다.
echo sin(deg2rad(60));  //  0.866025403 ...
echo sin(60);           // -0.304810621 ...

?>

참고:
asin(),
cos(),
tan(),
deg2rad().

이전 | 처음으로 | 다음
round | 위로 | sinh


sinh

(PHP 4 >= 4.1.0, PHP 5)

sinh -- 쌍곡선 사인

설명

float sinh ( float arg)

(exp(arg) - exp(-arg))/2로 정의되는 arg의 쌍곡선 사인값을 반환합니다.

참고:
sin(),
asinh(),
cos(),
tan().

이전 | 처음으로 | 다음
sin | 위로 | sqrt


sqrt

(PHP 3, PHP 4 , PHP 5)

sqrt -- 평방 제곱근

설명

float sqrt ( float arg)

arg의 평방제곱근을 반환합니다.

예 1. sqrt() 예제

<?php
// 정밀도는 precision 설정에 의존합니다.
echo sqrt(9); // 3
echo sqrt(10); // 3.16227766 ...
?>

참고: pow().

이전 | 처음으로 | 다음
sinh | 위로 | srand


srand

(PHP 3, PHP 4 , PHP 5)

srand -- 난수 생성기를 초기화합니다.

설명

void srand ( [int seed])

seed로 난수 생성기를 초기화합니다. PHP 4.2.0부터 seed는 선택적이 되었고, 생략할 경우에도 기본값으로 난수값을 생성합니다.

예 1. srand() 예제

// 마이크로초로 초기화
function make_seed()
{
    list($usec, $sec) = explode(' ', microtime());
    return (float) $sec + ((float) $usec * 100000);
}
srand(make_seed());
$randval = rand();

참고: PHP 4.2.0부터 srand()나 mt_srand()를 이용해서 난수값 생성기를 초기화 할 필요가 없습니다. 자동적으로 이루어집니다.

참고:
rand(),
getrandmax(),
mt_srand().

이전 | 처음으로 | 다음
sqrt | 위로 | tan


tan

(PHP 3, PHP 4 , PHP 5)

tan -- 탄젠트

설명

float tan ( float arg)

tan()는 arg 인수의 탄젠트 값을 반환합니다. arg 인수는 라디안으로 주어집니다.

예 1. tan() 예제

<?php

echo tan(M_PI_2); // 1

?>

참고:
atan(),
sin(),
cos(),
deg2rad().

이전 | 처음으로 | 다음
srand | 위로 | tanh


tanh

(PHP 4 >= 4.1.0, PHP 5)

tanh -- 쌍곡선 탄젠트

설명

float tanh ( float arg)

sinh(arg)/cosh(arg)로 정의되는 arg의 쌍곡선 탄젠트 값을 반환합니다.

참고:
tan(),
atanh(),
sin(),
cos().

이전 | 처음으로 | 다음
tan | 위로 | Multibyte String Functions


Multibyte String Functions

PHP 매뉴얼
이전 다음

LIII. Multibyte String Functions

소개

While there are many languages in which every necessary character can be represented by a one-to-one mapping to a 8-bit value, there are also several languages which require so many characters for written communication that cannot be contained within the range a mere byte can code. Multibyte character encoding schemes were developed to express that many (more than 256) characters in the regular bytewise coding system.

When you manipulate (trim, split, splice, etc.) strings encoded in a multibyte encoding, you need to use special functions since two or more consecutive bytes may represent a single character in such encoding schemes. Otherwise, if you apply a non-multibyte-aware string function to the string, it probably fails to detect the beginning or ending of the multibyte character and ends up with a corrupted garbage string that most likely loses its original meaning.

mbstring provides these multibyte specific string functions that help you deal with multibyte encodings in PHP, which is basically supposed to be used with single byte encodings. In addition to that, mbstring handles character encoding conversion between the possible encoding pairs.

mbstring is also designed to handle Unicode-based encodings such as UTF-8 and UCS-2 and many single-byte encodings for convenience (listed below), whereas mbstring was originally developed for use in Japanese web pages.

PHP Character Encoding Requirements

Encodings of the following types are safely used with PHP.

  • A singlebyte encoding,

    • which has ASCII-compatible (ISO646 compatible) mappings for the characters in range of 00h to 7fh.

  • A multibyte encoding,

    • which has ASCII-compatible mappings for the characters in range of 00h to 7fh.

    • which don't use ISO2022 escape sequences.

    • which don't use a value from 00h to 7fh in any of the compounded bytes that represents a single character.

These are examples of character encodings that are unlikely to work with PHP.

JIS, SJIS, ISO-2022-JP, BIG-5

Although PHP scripts written in any of those encodings might not work, especially in the case where encoded strings appear as identifiers or literals in the script, you can almost avoid using these encodings by setting up the mbstring's transparent encoding filter function for incoming HTTP queries.

참고: It's highly discouraged to use SJIS, BIG5, CP936, CP949 and GB18030 for the internal encoding unless you are familiar with the parser, the scanner and the character encoding.

참고: If you have some database connected with PHP, it is recommended that you use the same character encoding for both database and the internal encoding for ease of use and better performance.

If you are using PostgreSQL, the character encoding used in the database and the one used in the PHP may differ as it supports automatic character set conversion between the backend and the frontend.

설치

mbstring is a non-default extension. This means it is not enabled by default. You must explicitly enable the module with the configure option. See the Install section for details.

The following configure options are related to the mbstring module.

  • --enable-mbstring=LANG: Enable mbstring functions. This option is required to use mbstring functions.

    As of PHP 4.3.0, mbstring extension provides
enhanced support for Simplified Chinese, Traditional Chinese,
Korean, and Russian in addition to Japanese.
To enable that feature, you will have to supply either one of the
following options to the LANG parameter;
--enable-mbstring=cn for Simplified Chinese support,
--enable-mbstring=tw for Traditional Chinese support,
--enable-mbstring=kr for Korean support,
--enable-mbstring=ru for Russian support, and
--enable-mbstring=ja for Japanese support.

    Also --enable-mbstring=all is convenient for you to enable all the supported languages listed above.

    참고: Japanese language support is also enabled by --enable-mbstring without any options for the sake of backwards compatibility.

  • --enable-mbstr-enc-trans : Enable HTTP input character encoding conversion using mbstring conversion engine. If this feature is enabled, HTTP input character encoding may be converted to mbstring.internal_encoding automatically.

    참고: As of PHP 4.3.0, the option --enable-mbstr-enc-trans was eliminated and replaced with the runtime setting mbstring.encoding_translation. HTTP input character encoding conversion is enabled when this is set to On (the default is Off).

  • --enable-mbregex: Enable regular expression functions with multibyte character support.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. mbstring configuration options

Name | Default | Changeable
mbstring.language | "neutral" | PHP_INI_SYSTEM | PHP_INI_PERDIR
mbstring.detect_order | NULL | PHP_INI_ALL
mbstring.http_input | "pass" | PHP_INI_ALL
mbstring.http_output | "pass" | PHP_INI_ALL
mbstring.internal_encoding | NULL | PHP_INI_ALL
mbstring.script_encoding | NULL | PHP_INI_ALL
mbstring.substitute_character | NULL | PHP_INI_ALL
mbstring.func_overload | "0" | PHP_INI_SYSTEM | PHP_INI_PERDIR
mbstring.encoding_translation | "0" | PHP_INI_SYSTEM | PHP_INI_PERDIR
For the definition of the PHP_INI_* constants, please refer to ini_set().

위 설정 지시어에 대한 간단한 설명입니다.

  • mbstring.language is the default national language setting (NLS) used in mbstring. Note that this option automagically defines mbstring.internal_encoding and mbstring.internal_encoding should be placed after mbstring.language in php.ini

  • mbstring.encoding_translation enables the transparent character encoding filter for the incoming HTTP queries, which performs detection and conversion of the input encoding to the internal character encoding.

  • mbstring.internal_encoding defines the default internal character encoding.

  • mbstring.http_input defines the default HTTP input character encoding.

  • mbstring.http_output defines the default HTTP output character encoding.

  • mbstring.detect_order defines default character code detection order. See also mb_detect_order().

  • mbstring.substitute_character defines character to substitute for invalid character encoding.

  • mbstring.func_overload overloads a set of single byte functions by the mbstring counterparts. See Funtion overloading for more information.

According to the HTML 4.01 specification, Web browsers are allowed to encode a form being submitted with a character encoding different from the one used for the page. See mb_http_input() to detect character encoding used by browsers.

Although popular browsers are capable of giving a reasonably accurate guess to the character encoding of a given HTML document, it would be better to set the charset parameter in the Content-Type HTTP header to the appropriate value by header() or default_charset ini setting.

예 1. php.ini setting examples

; Set default language
mbstring.language        = Neutral; Set default language to Neutral(UTF-8) (default)
mbstring.language        = English; Set default language to English
mbstring.language        = Japanese; Set default language to Japanese

;; Set default internal encoding
;; Note: Make sure to use character encoding works with PHP
mbstring.internal_encoding    = UTF-8  ; Set internal encoding to UTF-8

;; HTTP input encoding translation is enabled.
mbstring.encoding_translation = On

;; Set default HTTP input character encoding
;; Note: Script cannot change http_input setting.
mbstring.http_input           = pass    ; No conversion.
mbstring.http_input           = auto    ; Set HTTP input to auto
                                ; "auto" is expanded to "ASCII,JIS,UTF-8,EUC-JP,SJIS"
mbstring.http_input           = SJIS    ; Set HTTP2 input to  SJIS
mbstring.http_input           = UTF-8,SJIS,EUC-JP ; Specify order

;; Set default HTTP output character encoding
mbstring.http_output          = pass    ; No conversion
mbstring.http_output          = UTF-8   ; Set HTTP output encoding to UTF-8

;; Set default character encoding detection order
mbstring.detect_order         = auto    ; Set detect order to auto
mbstring.detect_order         = ASCII,JIS,UTF-8,SJIS,EUC-JP ; Specify order

;; Set default substitute character
mbstring.substitute_character = 12307   ; Specify Unicode value
mbstring.substitute_character = none    ; Do not print character
mbstring.substitute_character = long    ; Long Example: U+3000,JIS+7E7E

예 2. php.ini setting for EUC-JP users

;; Disable Output Buffering
output_buffering      = Off

;; Set HTTP header charset
default_charset       = EUC-JP

;; Set default language to Japanese
mbstring.language = Japanese

;; HTTP input encoding translation is enabled.
mbstring.encoding_translation = On

;; Set HTTP input encoding conversion to auto
mbstring.http_input   = auto

;; Convert HTTP output to EUC-JP
mbstring.http_output  = EUC-JP

;; Set internal encoding to EUC-JP
mbstring.internal_encoding = EUC-JP

;; Do not print invalid characters
mbstring.substitute_character = none

예 3. php.ini setting for SJIS users

;; Enable Output Buffering
output_buffering     = On

;; Set mb_output_handler to enable output conversion
output_handler       = mb_output_handler

;; Set HTTP header charset
default_charset      = Shift_JIS

;; Set default language to Japanese
mbstring.language = Japanese

;; Set http input encoding conversion to auto
mbstring.http_input  = auto

;; Convert to SJIS
mbstring.http_output = SJIS

;; Set internal encoding to EUC-JP
mbstring.internal_encoding = EUC-JP

;; Do not print invalid characters
mbstring.substitute_character = none

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

MB_OVERLOAD_MAIL (integer)

MB_OVERLOAD_STRING (integer)

MB_OVERLOAD_REGEX (integer)

HTTP Input and Output

HTTP input/output character encoding conversion may convert binary data also. Users are supposed to control character encoding conversion if binary data is used for HTTP input/output.

참고: In PHP 4.3.2 or earlier versions, there was a limitation in this functionality that mbstring does not perform character encoding conversion in POST data if the enctype attribute in the form element is set to multipart/form-data. So you have to convert the incoming data by yourself in this case if necessary.

Beginning with PHP 4.3.3, if enctype for HTML form is set to multipart/form-data and mbstring.encoding_translation is set to On in php.ini the POST'ed variables and the names of uploaded files will be converted to the internal character encoding as well. However, the conversion isn't applied to the query keys.

  • HTTP Input

    There is no way to control HTTP input character conversion from PHP script. To disable HTTP input character conversion, it has to be done in php.ini.

    예 4. Disable HTTP input conversion in php.ini

    ;; Disable HTTP Input conversion
    mbstring.http_input = pass
    ;; Disable HTTP Input conversion (PHP 4.3.0 or higher)
    mbstring.encoding_translation = Off

    When using PHP as an Apache module, it is possible to override those settings in each Virtual Host directive in httpd.conf or per directory with .htaccess. Refer to the Configuration section and Apache Manual for details.

  • HTTP Output

    There are several ways to enable output character encoding conversion. One is using php.ini, another is using ob_start() with mb_output_handler() as ob_start callback function.

    참고: PHP3-i18n users should note that mbstring's output conversion differs from PHP3-i18n. Character encoding is converted using output buffer.

예 5. php.ini setting example

;; Enable output character encoding conversion for all PHP pages

;; Enable Output Buffering
output_buffering    = On

;; Set mb_output_handler to enable output conversion
output_handler      = mb_output_handler

예 6. Script example

<?php

// Enable output character encoding conversion only for this page

// Set HTTP output character encoding to SJIS
mb_http_output('SJIS');

// Start buffering and specify "mb_output_handler" as
// callback function
ob_start('mb_output_handler');

?>

Supported Character Encodings

Currently the following character encodings are supported by the mbstring module. Any of those Character encodings can be specified in the encoding parameter of mbstring functions.

The following character encoding is supported in this PHP extension:

  • UCS-4

  • UCS-4BE

  • UCS-4LE

  • UCS-2

  • UCS-2BE

  • UCS-2LE

  • UTF-32

  • UTF-32BE

  • UTF-32LE

  • UTF-16

  • UTF-16BE

  • UTF-16LE

  • UTF-7

  • UTF7-IMAP

  • UTF-8

  • ASCII

  • EUC-JP

  • SJIS

  • eucJP-win

  • SJIS-win

  • ISO-2022-JP

  • JIS

  • ISO-8859-1

  • ISO-8859-2

  • ISO-8859-3

  • ISO-8859-4

  • ISO-8859-5

  • ISO-8859-6

  • ISO-8859-7

  • ISO-8859-8

  • ISO-8859-9

  • ISO-8859-10

  • ISO-8859-13

  • ISO-8859-14

  • ISO-8859-15

  • byte2be

  • byte2le

  • byte4be

  • byte4le

  • BASE64

  • HTML-ENTITIES

  • 7bit

  • 8bit

  • EUC-CN

  • CP936

  • HZ

  • EUC-TW

  • CP950

  • BIG-5

  • EUC-KR

  • UHC (CP949)

  • ISO-2022-KR

  • Windows-1251 (CP1251)

  • Windows-1252 (CP1252)

  • CP866 (IBM866)

  • KOI8-R

php.ini entry, which accepts encoding name, accepts "auto" and "pass" also. mbstring functions, which accepts encoding name, and accepts "auto".

If "pass" is set, no character encoding conversion is performed.

If "auto" is set, it is expanded to the list of encodings defined per the NLS. For instance, if the NLS is set to Japanese, the value is assumed to be "ASCII,JIS,UTF-8,EUC-JP,SJIS".

See also mb_detect_order()

Function Overloading Feature

You might often find it difficult to get an existing PHP application work in a given multibyte environment. That's mostly because lots of PHP applications out there are written with the standard string functions such as substr(), which are known to not properly handle multibyte-encoded strings.

mbstring supports 'function overloading' feature which enables you to add multibyte awareness to such an application without code modification by overloading multibyte counterparts on the standard string functions. For example, mb_substr() is called instead of substr() if function overloading is enabled. This feature makes it easy to port applications that only support single-byte encodings to a multibyte environment in many cases.

To use the function overloading, set mbstring.func_overload in php.ini to a positive value that represents a combination of bitmasks specifying the categories of functions to be overloaded. It should be set to 1 to overload the mail() function. 2 for string functions, 4 for regular expression functions. For example, if is set for 7, mail, strings and regular expression functions should be overloaded. The list of overloaded functions are shown below.

표 2. Functions to be overloaded

value of mbstring.func_overload | original function | overloaded function
1 | mail() | mb_send_mail()
2 | strlen() | mb_strlen()
2 | strpos() | mb_strpos()
2 | strrpos() | mb_strrpos()
2 | substr() | mb_substr()
2 | strtolower() | mb_strtolower()
2 | strtoupper() | mb_strtoupper()
2 | substr_count() | mb_substr_count()
4 | ereg() | mb_ereg()
4 | eregi() | mb_eregi()
4 | ereg_replace() | mb_ereg_replace()
4 | eregi_replace() | mb_eregi_replace()
4 | split() | mb_split()

참고: It is not recommended to use the function overloading option in the per-directory context, because it's not confirmed yet to be stable enough in a production environment and may lead to undefined behaviour.

Basics of Japanese multi-byte encodings

It is often said quite hard to figure out how Japanese texts are handled in the computer. This is not only because Japanese characters can only be represented by multibyte encodings, but because different encoding standards are adopted for different purposes / platforms. Moreover, not a few character set standards are used there, which are slightly different from one another. Those facts have often led developers to inevitable mess-up.

To create a working web application that would be put in the Japanese environment, it is important to use the proper character encoding and character set for the task in hand.

  • Storage for a character can be up to six bytes

  • Most of multibyte characters often appear twice as wide as a single-byte character on display. Those characters are called "zen-kaku" in Japanese which means "full width", and the other (narrower) characters are called "han-kaku" - means half width. However the graphical properties of the characters depend on the glyphs of the type faces used to display them or print them out.

  • Some character encodings use shift(escape) sequences defined in ISO2022 to switch the code map of the specific code area (00h to 7fh).

  • ISO-2022-JP should be used in SMTP/NNTP, and headers and entities should be reencoded as per RFC requirements. Although those are not requisites, it's still a good idea because several popular user agents cannot recognize any other encoding methods.

  • Webpages created for mobile phone services such as i-mode, Vodafone live!, or EZweb are supposed to use Shift_JIS.

References

Multibyte character encoding schemes and the related issues are very complicated. There should be too few space to cover in sufficient details. Please refer to the following URLs and other resources for further readings.

  • Unicode materials

    http://www.unicode.org/

  • Japanese/Korean/Chinese character information

    http://examples.oreilly.com/cjkvinfo/doc/cjk.inf

Summaries of supported encodings

Summaries of supported encodings

Name in the IANA character set registry: ISO-10646-UCS-4

Underlying character set: ISO 10646

Description: The Universal Character Set with 31-bit code space, standardized as UCS-4 by ISO/IEC 10646. It is kept synchronized with the latest version of the Unicode code map.

Additional note: If this name is used in the encoding conversion facility, the converter attempts to identify by the preceding BOM (byte order mark)in which endian the subsequent bytes are represented.

Name in the IANA character set registry: ISO-10646-UCS-4

Underlying character set: UCS-4

Description: See above.

Additional note: In contrast to UCS-4, strings are always assumed to be in big endian form.

Name in the IANA character set registry: ISO-10646-UCS-4

Underlying character set: UCS-4

Description: See above.

Additional note: In contrast to UCS-4, strings are always assumed to be in little endian form.

Name in the IANA character set registry: ISO-10646-UCS-2

Underlying character set: UCS-2

Description: The Universal Character Set with 16-bit code space, standardized as UCS-2 by ISO/IEC 10646. It is kept synchronized with the latest version of the unicode code map.

Additional note: If this name is used in the encoding conversion facility, the converter attempts to identify by the preceding BOM (byte order mark)in which endian the subsequent bytes are represented.

Name in the IANA character set registry: ISO-10646-UCS-2

Underlying character set: UCS-2

Description: See above.

Additional note: In contrast to UCS-2, strings are always assumed to be in big endian form.

Name in the IANA character set registry: ISO-10646-UCS-2

Underlying character set: UCS-2

Description: See above.

Additional note: In contrast to UCS-2, strings are always assumed to be in little endian form.

Name in the IANA character set registry: UTF-32

Underlying character set: Unicode

Description: Unicode Transformation Format of 32-bit unit width, whose encoding space refers to the Unicode's codeset standard. This encoding scheme wasn't identical to UCS-4 because the code space of Unicode were limited to a 21-bit value.

Additional note: If this name is used in the encoding conversion facility, the converter attempts to identify by the preceding BOM (byte order mark)in which endian the subsequent bytes are represented.

Name in the IANA character set registry: UTF-32BE

Underlying character set: Unicode

Description: See above

Additional note: In contrast to UTF-32, strings are always assumed to be in big endian form.

Name in the IANA character set registry: UTF-32LE

Underlying character set: Unicode

Description: See above

Additional note: In contrast to UTF-32, strings are always assumed to be in little endian form.

Name in the IANA character set registry: UTF-16

Underlying character set: Unicode

Description: Unicode Transformation Format of 16-bit unit width. It's worth a note that UTF-16 is no longer the same specification as UCS-2 because the surrogate mechanism has been introduced since Unicode 2.0 and UTF-16 now refers to a 21-bit code space.

Additional note: If this name is used in the encoding conversion facility, the converter attempts to identify by the preceding BOM (byte order mark)in which endian the subsequent bytes are represented.

Name in the IANA character set registry: UTF-16BE

Underlying character set: Unicode

Description: See above.

Additional note: In contrast to UTF-16, strings are always assumed to be in big endian form.

Name in the IANA character set registry: UTF-16BE

Underlying character set: Unicode

Description: See above.

Additional note: In contrast to UTF-16, strings are always assumed to be in big endian form.

Name in the IANA character set registry: UTF-8

Underlying character set: Unicode / UCS

Description: Unicode Transformation Format of 8-bit unit width.

Additional note: none

Name in the IANA character set registry: UTF-7

Underlying character set: Unicode

Description: A mail-safe transformation format of Unicode, specified in RFC2152.

Additional note: none

Name in the IANA character set registry: (none)

Underlying character set: Unicode

Description: A variant of UTF-7 which is specialized for use in the IMAP protocol.

Additional note: none

Name in the IANA character set registry: US-ASCII (preferred MIME name) / iso-ir-6 / ANSI_X3.4-1986 / ISO_646.irv:1991 / ASCII / ISO646-US / us / IBM367 / CP367 / csASCII

Underlying character set: ASCII / ISO 646

Description: American Standard Code for Information Interchange is a commonly-used 7-bit encoding. Also standardized as an international standard, ISO 646.

Additional note: (none)

Name in the IANA character set registry: EUC-JP (preferred MIME name) / Extended_UNIX_Code_Packed_Format_for_Japanese / csEUCPkdFmtJapanese

Underlying character set: Compound of US-ASCII / JIS X0201:1997 (hankaku kana part) / JIS X0208:1990 / JIS X0212:1990

Description: As you see the name is derived from an abbreviation of Extended UNIX Code Packed Format for Japanese, this encoding is mostly used on UNIX or alike platforms. The original encoding scheme, Extended UNIX Code, is designed on the basis of ISO 2022.

Additional note: The character set referred to by EUC-JP is different to IBM932 / CP932, which are used by OS/2® and Microsoft® Windows®. For information interchange with those platforms, use EUCJP-WIN instead.

Name in the IANA character set registry: Shift_JIS (preferred MIME name) / MS_Kanji / csShift_JIS

Underlying character set: Compound of JIS X0201:1997 / JIS X0208:1997

Description: Shift_JIS was developed in early 80's, at the time personal Japanese word processors were brought into the market, in order to maintain compatiblities with the legacy encoding scheme JIS X 0201:1976. According to the IANA definition the codeset of Shift_JIS is slightly different to IBM932 / CP932. However, the names "SJIS" / "Shift_JIS" are often wrongly used to refer to these codesets.

Additional note: For the CP932 codemap, use SJIS-WIN instead.

Name in the IANA character set registry: (none)

Underlying character set: Compound of JIS X0201:1997 / JIS X0208:1997 / IBM extensions / NEC extensions

Description: While this "encoding" uses the same encoding scheme as EUC-JP, the underlying character set is different. That is, some code points map to different characters than EUC-JP.

Additional note: none

Name in the IANA character set registry: Windows-31J / csWindows31J

Underlying character set: Compound of JIS X0201:1997 / JIS X0208:1997 / IBM extensions / NEC extensions

Description: While this "encoding" uses the same encoding scheme as Shift_JIS, the underlying character set is different. That means some code points map to different characters than Shift_JIS.

Additional note: (none)

Name in the IANA character set registry: ISO-2022-JP (preferred MIME name) / csISO2022JP

Underlying character set: US-ASCII / JIS X0201:1976 / JIS X0208:1978 / JIS X0208:1983

Description: RFC1468

Additional note: (none)

Name in the IANA character set registry: JIS

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: ISO-8859-1

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: ISO-8859-2

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: ISO-8859-3

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: ISO-8859-4

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: ISO-8859-5

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: ISO-8859-6

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: ISO-8859-7

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: ISO-8859-8

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: ISO-8859-9

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: ISO-8859-10

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: ISO-8859-13

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: ISO-8859-14

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: ISO-8859-15

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: byte2be

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: byte2le

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: byte4be

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: byte4le

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: BASE64

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: HTML-ENTITIES

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: 7bit

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: 8bit

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: EUC-CN

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: CP936

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: HZ

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: EUC-TW

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: CP950

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: BIG-5

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: EUC-KR

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: UHC (CP949)

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: ISO-2022-KR

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: Windows-1251 (CP1251)

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: Windows-1252 (CP1252)

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: CP866 (IBM866)

Underlying character set:

Description:

Additional note:

Name in the IANA character set registry: KOI8-R

Underlying character set:

Description:

Additional note:

차례
mb_convert_case -- Perform case folding on a string
mb_convert_encoding -- Convert character encoding
mb_convert_kana -- Convert "kana" one from another ("zen-kaku", "han-kaku" and more)
mb_convert_variables -- Convert character code in variable(s)
mb_decode_mimeheader -- Decode string in MIME header field
mb_decode_numericentity -- Decode HTML numeric string reference to character
mb_detect_encoding -- Detect character encoding
mb_detect_order -- Set/Get character encoding detection order
mb_encode_mimeheader -- Encode string for MIME header
mb_encode_numericentity -- Encode character to HTML numeric string reference
mb_ereg_match -- Regular expression match for multibyte string
mb_ereg_replace -- Replace regular expression with multibyte support
mb_ereg_search_getpos -- Returns start point for next regular expression match
mb_ereg_search_getregs -- Retrieve the result from the last multibyte regular expression match
mb_ereg_search_init -- Setup string and regular expression for multibyte regular expression match
mb_ereg_search_pos -- Return position and length of matched part of multibyte regular expression for predefined multibyte string
mb_ereg_search_regs -- Returns the matched part of multibyte regular expression
mb_ereg_search_setpos -- Set start point of next regular expression match
mb_ereg_search -- Multibyte regular expression match for predefined multibyte string
mb_ereg -- Regular expression match with multibyte support
mb_eregi_replace -- Replace regular expression with multibyte support ignoring case
mb_eregi -- Regular expression match ignoring case with multibyte support
mb_get_info -- Get internal settings of mbstring
mb_http_input -- Detect HTTP input character encoding
mb_http_output -- Set/Get HTTP output character encoding
mb_internal_encoding -- Set/Get internal character encoding
mb_language -- Set/Get current language
mb_output_handler -- Callback function converts character encoding in output buffer
mb_parse_str -- Parse GET/POST/COOKIE data and set global variable
mb_preferred_mime_name -- Get MIME charset string
mb_regex_encoding -- Returns current encoding for multibyte regex as string
mb_regex_set_options -- Set/Get the default options for mbregex functions
mb_send_mail -- Send encoded mail.
mb_split -- Split multibyte string using regular expression
mb_strcut -- Get part of string
mb_strimwidth -- Get truncated string with specified width
mb_strlen -- Get string length
mb_strpos -- Find position of first occurrence of string in a string
mb_strrpos -- Find position of last occurrence of a string in a string
mb_strtolower -- Make a string lowercase
mb_strtoupper -- Make a string uppercase
mb_strwidth -- Return width of string
mb_substitute_character -- Set/Get substitution character
mb_substr_count -- Count the number of substring occurrences
mb_substr -- Get part of string

이전 | 처음으로 | 다음
tanh | 위로 | mb_convert_case


mb_convert_case

(PHP 4 >= 4.3.0, PHP 5)

mb_convert_case -- Perform case folding on a string

Description

string mb_convert_case ( string str, int mode [, string encoding])

mb_convert_case() returns case folded version of string converted in the way specified by mode.

mode can be one of MB_CASE_UPPER, MB_CASE_LOWER or MB_CASE_TITLE.

encoding specifies the encoding of str; if omitted, the internal character encoding value will be used.

The return value is str with the appropriate case folding applied.

By contrast to the standard case folding functions such as strtolower() and strtoupper(), case folding is performed on the basis of the Unicode character properties. Thus the behaviour of this function is not affected by locale settings and it can convert any characters that have 'alphabetic' property, such as A-umlaut (?).

For more information about the Unicode properties, please see http://www.unicode.org/unicode/reports/tr21/.

예 1. mb_convert_case() example

<?php
$str = "mary had a Little lamb and she loved it so";
$str = mb_convert_case($str, MB_CASE_UPPER, "UTF-8");
echo $str; // Prints MARY HAD A LITTLE LAMB AND SHE LOVED IT SO
$str = mb_convert_case($str, MB_CASE_TITLE, "UTF-8");
echo $str; // Prints Mary Had A Little Lamb And She Loved It So
?>

See also mb_strtolower(),
mb_strtoupper(),
strtolower() and
strtoupper().

이전 | 처음으로 | 다음
Multibyte String Functions | 위로 | mb_convert_encoding


mb_convert_encoding

(PHP 4 >= 4.0.6, PHP 5)

mb_convert_encoding -- Convert character encoding

Description

string mb_convert_encoding ( string str, string to-encoding [, mixed from-encoding])

mb_convert_encoding() converts character encoding of string str from from-encoding to to-encoding.

str : String to be converted.

from-encoding is specified by character code name before conversion. it can be array or string - comma separated enumerated list. If it is not specified, the internal encoding will be used.

예 1. mb_convert_encoding() example

<?php
/* Convert internal character encoding to SJIS */
$str = mb_convert_encoding($str, "SJIS");

/* Convert EUC-JP to UTF-7 */
$str = mb_convert_encoding($str, "UTF-7", "EUC-JP");

/* Auto detect encoding from JIS, eucjp-win, sjis-win, then convert str to UCS-2LE */
$str = mb_convert_encoding($str, "UCS-2LE", "JIS, eucjp-win, sjis-win");

/* "auto" is expanded to "ASCII,JIS,UTF-8,EUC-JP,SJIS" */
$str = mb_convert_encoding($str, "EUC-JP", "auto");
?>

See also mb_detect_order().

이전 | 처음으로 | 다음
mb_convert_case | 위로 | mb_convert_kana


mb_convert_kana

(PHP 4 >= 4.0.6, PHP 5)

mb_convert_kana -- Convert "kana" one from another ("zen-kaku", "han-kaku" and more)

Description

string mb_convert_kana ( string str, string option [, mixed encoding])

mb_convert_kana() performs "han-kaku" - "zen-kaku" conversion for string str. It returns converted string. This function is only useful for Japanese.

option is conversion option. Default value is "KV".

encoding is character encoding. If it is omitted, internal character encoding is used.

Specify with combination of following options. Default value is KV.

표 1. Applicable Conversion Options

Option | Meaning
r | Convert "zen-kaku" alphabets to "han-kaku"
R | Convert "han-kaku" alphabets to "zen-kaku"
n | Convert "zen-kaku" numbers to "han-kaku"
N | Convert "han-kaku" numbers to "zen-kaku"
a | Convert "zen-kaku" alphabets and numbers to "han-kaku"
A | Convert "han-kaku" alphabets and numbers to "zen-kaku" (Characters included in "a", "A" options are U+0021 - U+007E excluding U+0022, U+0027, U+005C, U+007E)
s | Convert "zen-kaku" space to "han-kaku" (U+3000 -> U+0020)
S | Convert "han-kaku" space to "zen-kaku" (U+0020 -> U+3000)
k | Convert "zen-kaku kata-kana" to "han-kaku kata-kana"
K | Convert "han-kaku kata-kana" to "zen-kaku kata-kana"
h | Convert "zen-kaku hira-gana" to "han-kaku kata-kana"
H | Convert "han-kaku kata-kana" to "zen-kaku hira-gana"
c | Convert "zen-kaku kata-kana" to "zen-kaku hira-gana"
C | Convert "zen-kaku hira-gana" to "zen-kaku kata-kana"
V | Collapse voiced sound notation and convert them into a character. Use with "K","H"

예 1. mb_convert_kana() example

<?php
/* Convert all "kana" to "zen-kaku" "kata-kana" */
$str = mb_convert_kana($str, "KVC");

/* Convert "han-kaku" "kata-kana" to "zen-kaku" "kata-kana"
   and "zen-kaku" alpha-numeric to "han-kaku" */
$str = mb_convert_kana($str, "KVa");
?>

이전 | 처음으로 | 다음
mb_convert_encoding | 위로 | mb_convert_variables


mb_convert_variables

(PHP 4 >= 4.0.6, PHP 5)

mb_convert_variables -- Convert character code in variable(s)

Description

string mb_convert_variables ( string to-encoding, mixed from-encoding, mixed vars)

mb_convert_variables() convert character encoding of variables vars in encoding from-encoding to encoding to-encoding. It returns character encoding before conversion for success, FALSE for failure.

mb_convert_variables() join strings in Array or Object to detect encoding, since encoding detection tends to fail for short strings. Therefore, it is impossible to mix encoding in single array or object.

It from-encoding is specified by array or comma separated string, it tries to detect encoding from from-coding. When encoding is omitted, detect_order is used.

vars (3rd and larger) is reference to variable to be converted. String, Array and Object are accepted. mb_convert_variables() assumes all parameters have the same encoding.

예 1. mb_convert_variables() example

<?php
/* Convert variables $post1, $post2 to internal encoding */
$interenc = mb_internal_encoding();
$inputenc = mb_convert_variables($interenc, "ASCII,UTF-8,SJIS-win", $post1, $post2);
?>

이전 | 처음으로 | 다음
mb_convert_kana | 위로 | mb_decode_mimeheader


mb_decode_mimeheader

(PHP 4 >= 4.0.6, PHP 5)

mb_decode_mimeheader -- Decode string in MIME header field

Description

string mb_decode_mimeheader ( string str)

mb_decode_mimeheader() decodes encoded-word string str in MIME header.

It returns decoded string in internal character encoding.

See also mb_encode_mimeheader().

이전 | 처음으로 | 다음
mb_convert_variables | 위로 | mb_decode_numericentity


mb_decode_numericentity

(PHP 4 >= 4.0.6, PHP 5)

mb_decode_numericentity -- Decode HTML numeric string reference to character

Description

string mb_decode_numericentity ( string str, array convmap [, string encoding])

Convert numeric string reference of string str in specified block to character. It returns converted string.

convmap is array to specifies code area to convert.

encoding is character encoding. If it is omitted, internal character encoding is used.

예 1. convmap example

$convmap = array (
   int start_code1, int end_code1, int offset1, int mask1,
   int start_code2, int end_code2, int offset2, int mask2,
   ........
   int start_codeN, int end_codeN, int offsetN, int maskN );
// Specify Unicode value for start_codeN and end_codeN
// Add offsetN to value and take bit-wise 'AND' with maskN,
// then convert value to numeric string reference.

See also mb_encode_numericentity().

이전 | 처음으로 | 다음
mb_decode_mimeheader | 위로 | mb_detect_encoding


mb_detect_encoding

(PHP 4 >= 4.0.6, PHP 5)

mb_detect_encoding -- Detect character encoding

Description

string mb_detect_encoding ( string str [, mixed encoding-list])

mb_detect_encoding() detects character encoding in string str. It returns detected character encoding.

encoding-list is list of character encoding. Encoding order may be specified by array or comma separated list string.

If encoding_list is omitted, detect_order is used.

예 1. mb_detect_encoding() example

<?php
/* Detect character encoding with current detect_order */
echo mb_detect_encoding($str);

/* "auto" is expanded to "ASCII,JIS,UTF-8,EUC-JP,SJIS" */
echo mb_detect_encoding($str, "auto");

/* Specify encoding_list character encoding by comma separated list */
echo mb_detect_encoding($str, "JIS, eucjp-win, sjis-win");

/* Use array to specify encoding_list  */
$ary[] = "ASCII";
$ary[] = "JIS";
$ary[] = "EUC-JP";
echo mb_detect_encoding($str, $ary);
?>

See also mb_detect_order().

이전 | 처음으로 | 다음
mb_decode_numericentity | 위로 | mb_detect_order


mb_detect_order

(PHP 4 >= 4.0.6, PHP 5)

mb_detect_order -- Set/Get character encoding detection order

Description

array mb_detect_order ( [mixed encoding-list])

mb_detect_order() sets automatic character encoding detection order to encoding-list. It returns TRUE for success, FALSE for failure.

encoding-list is array or comma separated list of character encoding. ("auto" is expanded to "ASCII, JIS, UTF-8, EUC-JP, SJIS")

If encoding-list is omitted, it returns current character encoding detection order as array.

This setting affects mb_detect_encoding() and mb_send_mail().

참고: mbstring currently implements following encoding detection filters. If there is an invalid byte sequence for following encoding, encoding detection will fail.

참고: UTF-8, UTF-7, ASCII, EUC-JP,SJIS, eucJP-win, SJIS-win, JIS, ISO-2022-JP

For ISO-8859-*, mbstring always detects as ISO-8859-*.

For UTF-16, UTF-32, UCS2 and UCS4, encoding detection will fail always.

예 1. Useless detect order example

; Always detect as ISO-8859-1
detect_order = ISO-8859-1, UTF-8

; Always detect as UTF-8, since ASCII/UTF-7 values are
; valid for UTF-8
detect_order = UTF-8, ASCII, UTF-7

예 2. mb_detect_order() examples

<?php
/* Set detection order by enumerated list */
mb_detect_order("eucjp-win,sjis-win,UTF-8");

/* Set detection order by array */
$ary[] = "ASCII";
$ary[] = "JIS";
$ary[] = "EUC-JP";
mb_detect_order($ary);

/* Display current detection order */
echo implode(", ", mb_detect_order());
?>

See also mb_internal_encoding(),
mb_http_input(),
mb_http_output() and
mb_send_mail().

이전 | 처음으로 | 다음
mb_detect_encoding | 위로 | mb_encode_mimeheader


mb_encode_mimeheader

(PHP 4 >= 4.0.6, PHP 5)

mb_encode_mimeheader -- Encode string for MIME header

Description

string mb_encode_mimeheader ( string str [, string charset [, string transfer-encoding [, string linefeed]]])

mb_encode_mimeheader() encodes a given string str by the MIME header encoding scheme. Returns a converted version of the string represented in ASCII.

charset specifies the name of the character set in which str is represented in. The default value is determined by the current NLS setting (mbstring.language).

transfer-encoding specifies the scheme of MIME encoding. It should be either "B" (Base64) or "Q" (Quoted-Printable). Falls back to "B" if not given.

linefeed specifies the EOL (end-of-line) marker with which mb_encode_mime_header() performs line-folding (a RFC term, the act of breaking a line longer than a certain length into multiple lines. The length is currently hard-coded to 74 characters). Falls back to "\r\n" (CRLF) if not given.

예 1. mb_encode_mimeheader() example

<?php
$name = ""; // kanji
$mbox = "kru";
$doma = "gtinn.mon";
$addr = mb_encode_mimeheader($name, "UTF-7", "Q") . " <" . $mbox . "@" . $doma . ">";
echo $addr;
?>

참고: This function isn't designed to break lines at higher-level contextual break points (word boundaries, etc.). This behaviour may clutter up the original string with unexpected spaces.

See also mb_decode_mimeheader().

이전 | 처음으로 | 다음
mb_detect_order | 위로 | mb_encode_numericentity


mb_encode_numericentity

(PHP 4 >= 4.0.6, PHP 5)

mb_encode_numericentity -- Encode character to HTML numeric string reference

Description

string mb_encode_numericentity ( string str, array convmap [, string encoding])

mb_encode_numericentity() converts specified character codes in string str from HTML numeric character reference to character code. It returns converted string.

convmap is array specifies code area to convert.

encoding is character encoding.

예 1. convmap example

$convmap = array (
int start_code1, int end_code1, int offset1, int mask1,
int start_code2, int end_code2, int offset2, int mask2,
........
int start_codeN, int end_codeN, int offsetN, int maskN );
// Specify Unicode value for start_codeN and end_codeN
// Add offsetN to value and take bit-wise 'AND' with maskN, then
// it converts value to numeric string reference.

예 2. mb_encode_numericentity() example

<?php
/* Convert Left side of ISO-8859-1 to HTML numeric character reference */
$convmap = array(0x80, 0xff, 0, 0xff);
$str = mb_encode_numericentity($str, $convmap, "ISO-8859-1");

/* Convert user defined SJIS-win code in block 95-104 to numeric
   string reference */
$convmap = array(
       0xe000, 0xe03e, 0x1040, 0xffff,
       0xe03f, 0xe0bb, 0x1041, 0xffff,
       0xe0bc, 0xe0fa, 0x1084, 0xffff,
       0xe0fb, 0xe177, 0x1085, 0xffff,
       0xe178, 0xe1b6, 0x10c8, 0xffff,
       0xe1b7, 0xe233, 0x10c9, 0xffff,
       0xe234, 0xe272, 0x110c, 0xffff,
       0xe273, 0xe2ef, 0x110d, 0xffff,
       0xe2f0, 0xe32e, 0x1150, 0xffff,
       0xe32f, 0xe3ab, 0x1151, 0xffff );
$str = mb_encode_numericentity($str, $convmap, "sjis-win");
?>

See also mb_decode_numericentity().

이전 | 처음으로 | 다음
mb_encode_mimeheader | 위로 | mb_ereg_match


mb_ereg_match

(PHP 4 >= 4.2.0)

mb_ereg_match -- Regular expression match for multibyte string

Description

bool mb_ereg_match ( string pattern, string string [, string option])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

mb_ereg_match() returns TRUE if string matches regular expression pattern, FALSE if not.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

참고: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg().

이전 | 처음으로 | 다음
mb_encode_numericentity | 위로 | mb_ereg_replace


mb_ereg_replace

(PHP 4 >= 4.2.0)

mb_ereg_replace -- Replace regular expression with multibyte support

Description

string mb_ereg_replace ( string pattern, string replacement, string string [, array option])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

mb_ereg_replace() scans string for matches to pattern, then replaces the matched text with replacement and returns the result string or FALSE on error. Multibyte character can be used in pattern.

Matching condition can be set by option parameter. If i is specified for this parameter, the case will be ignored. If x is specified, white space will be ignored. If m is specified, match will be executed in multiline mode and line break will be included in '.'. If p is specified, match will be executed in POSIX mode, line break will be considered as normal character. If e is specified, replacement string will be evaluated as PHP expression.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

참고: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_eregi_replace().

이전 | 처음으로 | 다음
mb_ereg_match | 위로 | mb_ereg_search_getpos


mb_ereg_search_getpos

(PHP 4 >= 4.2.0)

mb_ereg_search_getpos -- Returns start point for next regular expression match

Description

array mb_ereg_search_getpos ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

mb_ereg_search_getpos() returns
the point to start regular expression match for
mb_ereg_search(),
mb_ereg_search_pos(),
mb_ereg_search_regs(). The position is
represented by bytes from the head of string.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

참고: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg_search_setpos().

이전 | 처음으로 | 다음
mb_ereg_replace | 위로 | mb_ereg_search_getregs


mb_ereg_search_getregs

(PHP 4 >= 4.2.0)

mb_ereg_search_getregs -- Retrieve the result from the last multibyte regular expression match

Description

array mb_ereg_search_getregs ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

mb_ereg_search_getregs() returns an array including the sub-string of matched part by last mb_ereg_search(), mb_ereg_search_pos(), mb_ereg_search_regs(). If there are some maches, the first element will have the matched sub-string, the second element will have the first part grouped with brackets, the third element will have the second part grouped with brackets, and so on. It returns FALSE on error;

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

참고: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg_search_init().

이전 | 처음으로 | 다음
mb_ereg_search_getpos | 위로 | mb_ereg_search_init


mb_ereg_search_init

(PHP 4 >= 4.2.0)

mb_ereg_search_init -- Setup string and regular expression for multibyte regular expression match

Description

array mb_ereg_search_init ( string string [, string pattern [, string option]])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

mb_ereg_search_init() sets string and pattern for multibyte regular expression. These values are used for mb_ereg_search(), mb_ereg_search_pos(), mb_ereg_search_regs(). It returns TRUE for success, FALSE for error.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

참고: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg_search_regs().

이전 | 처음으로 | 다음
mb_ereg_search_getregs | 위로 | mb_ereg_search_pos


mb_ereg_search_pos

(PHP 4 >= 4.2.0)

mb_ereg_search_pos -- Return position and length of matched part of multibyte regular expression for predefined multibyte string

Description

array mb_ereg_search_pos ( [string pattern [, string option]])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

mb_ereg_search_pos() returns an array including position of matched part for multibyte regular expression. The first element of the array will be the beginning of matched part, the second element will be length (bytes) of matched part. It returns FALSE on error.

The string for match is specified by mb_ereg_search_init(). It it is not specified, the previous one will be used.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

참고: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg_search_init().

이전 | 처음으로 | 다음
mb_ereg_search_init | 위로 | mb_ereg_search_regs


mb_ereg_search_regs

(PHP 4 >= 4.2.0)

mb_ereg_search_regs -- Returns the matched part of multibyte regular expression

Description

array mb_ereg_search_regs ( [string pattern [, string option]])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

mb_ereg_search_regs() executes the multibyte regular expression match, and if there are some matched part, it returns an array including substring of matched part as first element, the first grouped part with brackets as second element, the second grouped part as third element, and so on. It returns FALSE on error.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

참고: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg_search_init().

이전 | 처음으로 | 다음
mb_ereg_search_pos | 위로 | mb_ereg_search_setpos


mb_ereg_search_setpos

(PHP 4 >= 4.2.0)

mb_ereg_search_setpos -- Set start point of next regular expression match

Description

array mb_ereg_search_setpos ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

mb_ereg_search_setpos() sets the starting point of match for mb_ereg_search().

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

참고: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg_search_init().

이전 | 처음으로 | 다음
mb_ereg_search_regs | 위로 | mb_ereg_search


mb_ereg_search

(PHP 4 >= 4.2.0)

mb_ereg_search -- Multibyte regular expression match for predefined multibyte string

Description

bool mb_ereg_search ( [string pattern [, string option]])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

mb_ereg_search() returns TRUE if the multibyte string matches with the regular expression, FALSE for otherwise. The string for matching is set by mb_ereg_search_init(). If pattern is not specified, the previous one is used.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

참고: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg_search_init().

이전 | 처음으로 | 다음
mb_ereg_search_setpos | 위로 | mb_ereg


mb_ereg

(PHP 4 >= 4.2.0)

mb_ereg -- Regular expression match with multibyte support

Description

int mb_ereg ( string pattern, string string [, array regs])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

mb_ereg() executes the regular expression match with multibyte support, and returns 1 if matches are found. If the optional third parameter was specified, the function returns the byte length of matched part, and the array regs will contain the substring of matched string. The functions returns 1 if it matches with the empty string. If no matches found or error happend, FALSE will be returned.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

참고: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_eregi()

이전 | 처음으로 | 다음
mb_ereg_search | 위로 | mb_eregi_replace


mb_eregi_replace

(PHP 4 >= 4.2.0)

mb_eregi_replace -- Replace regular expression with multibyte support ignoring case

Description

string mb_eregi_replace ( string pattern, string replace, string string)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

mb_ereg_replace() scans string for matches to pattern, then replaces the matched text with replacement and returns the result string or FALSE on error. Multibyte character can be used in pattern. The case will be ignored.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

참고: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg_replace().

이전 | 처음으로 | 다음
mb_ereg | 위로 | mb_eregi


mb_eregi

(PHP 4 >= 4.2.0)

mb_eregi -- Regular expression match ignoring case with multibyte support

Description

int mb_eregi ( string pattern, string string [, array regs])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

mb_eregi() executes the regular expression match with multibyte support, and returns 1 if matches are found. This function ignore case. If the optional third parameter was specified, the function returns the byte length of matched part, and the array regs will contain the substring of matched string. The functions returns 1 if it matches with the empty string. If no matches found or error happend, FALSE will be returned.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

참고: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg().

이전 | 처음으로 | 다음
mb_eregi_replace | 위로 | mb_get_info


mb_get_info

(PHP 4 >= 4.2.0, PHP 5)

mb_get_info -- Get internal settings of mbstring

Description

string mb_get_info ( [string type])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

mb_get_info() returns internal setting parameter of mbstring.

If type isn't specified or is specified to "all", an array having the elements "internal_encoding", "http_output", "http_input", "func_overload" will be returned.

If type is specified for "http_output", "http_input", "internal_encoding", "func_overload", the specified setting parameter will be returned.

See also mb_internal_encoding(), mb_http_output().

이전 | 처음으로 | 다음
mb_eregi | 위로 | mb_http_input


mb_http_input

(PHP 4 >= 4.0.6, PHP 5)

mb_http_input -- Detect HTTP input character encoding

Description

string mb_http_input ( [string type])

mb_http_input() returns result of HTTP input character encoding detection.

type: Input string specifies input type. "G" for GET, "P" for POST, "C" for COOKIE. If type is omitted, it returns last input type processed.

Return Value: Character encoding name. If mb_http_input() does not process specified HTTP input, it returns FALSE.

See also mb_internal_encoding(),
mb_http_output(),
mb_detect_order().

이전 | 처음으로 | 다음
mb_get_info | 위로 | mb_http_output


mb_http_output

(PHP 4 >= 4.0.6, PHP 5)

mb_http_output -- Set/Get HTTP output character encoding

Description

string mb_http_output ( [string encoding])

If encoding is set, mb_http_output() sets HTTP output character encoding to encoding. Output after this function is converted to encoding. mb_http_output() returns TRUE for success and FALSE for failure.

If encoding is omitted, mb_http_output() returns current HTTP output character encoding.

See also mb_internal_encoding(),
mb_http_input(),
mb_detect_order().

이전 | 처음으로 | 다음
mb_http_input | 위로 | mb_internal_encoding


mb_internal_encoding

(PHP 4 >= 4.0.6, PHP 5)

mb_internal_encoding -- Set/Get internal character encoding

Description

mixed mb_internal_encoding ( [string encoding])

mb_internal_encoding() sets internal character encoding to encoding If parameter is omitted, it returns current internal encoding.

encoding is used for HTTP input character encoding conversion, HTTP output character encoding conversion and default character encoding for string functions defined by mbstring module.

encoding: Character encoding name

Return Value: If encoding is set,mb_internal_encoding() returns TRUE for success, otherwise returns FALSE. If encoding is omitted, it returns current character encoding name.

예 1. mb_internal_encoding() example

<?php
/* Set internal character encoding to UTF-8 */
mb_internal_encoding("UTF-8");

/* Display current internal character encoding */
echo mb_internal_encoding();
?>

See also mb_http_input(),
mb_http_output() and
mb_detect_order().

이전 | 처음으로 | 다음
mb_http_output | 위로 | mb_language


mb_language

(PHP 4 >= 4.0.6, PHP 5)

mb_language -- Set/Get current language

Description

string mb_language ( [string language])

mb_language() sets language. If language is omitted, it returns current language as string.

language setting is used for encoding e-mail messages. Valid languages are "Japanese", "ja","English","en" and "uni" (UTF-8). mb_send_mail() uses this setting to encode e-mail.

Language and its setting is ISO-2022-JP/Base64 for Japanese, UTF-8/Base64 for uni, ISO-8859-1/quoted printable for English.

Return Value: If language is set and language is valid, it returns TRUE. Otherwise, it returns FALSE. When language is omitted, it returns language name as string. If no language is set previously, it returns FALSE.

See also mb_send_mail().

이전 | 처음으로 | 다음
mb_internal_encoding | 위로 | mb_output_handler


mb_output_handler

(PHP 4 >= 4.0.6, PHP 5)

mb_output_handler -- Callback function converts character encoding in output buffer

Description

string mb_output_handler ( string contents, int status)

mb_output_handler() is
ob_start() callback
function. mb_output_handler() converts
characters in output buffer from internal character encoding to
HTTP output character encoding.

4.1.0 or later version, this handler adds charset HTTP header when following conditions are met:

  • Does not set Content-Type by header()

  • Default MIME type begins with text/

  • http_output setting is other than pass

contents : Output buffer contents

status : Output buffer status

Return Value: String converted

예 1. mb_output_handler() example

<?php
mb_http_output("UTF-8");
ob_start("mb_output_handler");
?>

참고: If you want to output some binary data such as image from PHP script with PHP 4.3.0 or later, Content-Type: header must be send using header() before any binary data was send to client (e.g. header("Content-Type: image/png")). If Content-Type: header was send, output character encoding conversion will not be performed.

Note that if 'Content-Type: text/*' was send using header(), the sending data is regarded as text, encoding conversion will be performed using character encoding settings.

If you want to output some binary data such as image from PHP script with PHP 4.2.x or earlier, you must set output encoding to "pass" using mb_http_output().

See also ob_start().

이전 | 처음으로 | 다음
mb_language | 위로 | mb_parse_str


mb_parse_str

(PHP 4 >= 4.0.6, PHP 5)

mb_parse_str -- Parse GET/POST/COOKIE data and set global variable

Description

bool mb_parse_str ( string encoded_string [, array result])

mb_parse_str() parses GET/POST/COOKIE data and sets global variables. Since PHP does not provide raw POST/COOKIE data, it can only used for GET data for now. It preses URL encoded data, detects encoding, converts coding to internal encoding and set values to result array or global variables.

encoded_string: URL encoded data.

result: Array contains decoded and character encoding converted values.

Return Value: It returns TRUE for success or FALSE for failure.

See also mb_detect_order(), mb_internal_encoding().

이전 | 처음으로 | 다음
mb_output_handler | 위로 | mb_preferred_mime_name


mb_preferred_mime_name

(PHP 4 >= 4.0.6, PHP 5)

mb_preferred_mime_name -- Get MIME charset string

Description

string mb_preferred_mime_name ( string encoding)

mb_preferred_mime_name() returns MIME charset string for character encoding encoding. It returns charset string.

예 1. mb_preferred_mime_string() example

<?php
$outputenc = "sjis-win";
mb_http_output($outputenc);
ob_start("mb_output_handler");
header("Content-Type: text/html; charset=" . mb_preferred_mime_name($outputenc));
?>

이전 | 처음으로 | 다음
mb_parse_str | 위로 | mb_regex_encoding


mb_regex_encoding

(PHP 4 >= 4.2.0)

mb_regex_encoding -- Returns current encoding for multibyte regex as string

Description

string mb_regex_encoding ( [string encoding])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

mb_regex_encoding() returns the character encoding used by multibyte regex functions.

If the optional parameter encoding is specified, it is set to the character encoding for multibyte regex. The default value is the internal character encoding.

참고: This function is supported in PHP 4.2.0 or higher.

See also: mb_internal_encoding(), mb_ereg()

이전 | 처음으로 | 다음
mb_preferred_mime_name | 위로 | mb_regex_set_options


mb_regex_set_options

(PHP 4 >= 4.3.0)

mb_regex_set_options -- Set/Get the default options for mbregex functions

Description

string mb_regex_set_options ( [string options])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

mb_regex_set_options() sets the default options described by options for multibyte regex functions.

Returns the previous options. If options is omitted, it returns the string that describes the current options.

참고: This function is supported in PHP 4.3.0 or higher.

See also
mb_split(),
mb_ereg() and
mb_eregi()

이전 | 처음으로 | 다음
mb_regex_encoding | 위로 | mb_send_mail


mb_send_mail

(PHP 4 >= 4.0.6, PHP 5)

mb_send_mail -- Send encoded mail.

Description

bool mb_send_mail ( string to, string subject, string message [, string additional_headers [, string additional_parameter]])

mb_send_mail() sends email. Headers and
message are converted and encoded according to
mb_language() setting.
mb_send_mail() is wrapper
function of mail(). See
mail() for details.

to is mail addresses send to. Multiple recipients can be specified by putting a comma between each address in to. This parameter is not automatically encoded.

subject is subject of mail.

message is mail message.

additional_headers is inserted at the end of the header. This is typically used to add extra headers. Multiple extra headers are separated with a newline ("\n").

additional_parameter is a MTA command line parameter. It is useful when setting the correct Return-Path header when using sendmail.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also mail(),
mb_encode_mimeheader(), and
mb_language().

이전 | 처음으로 | 다음
mb_regex_set_options | 위로 | mb_split


mb_split

(PHP 4 >= 4.2.0)

mb_split -- Split multibyte string using regular expression

Description

array mb_split ( string pattern, string string [, int limit])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

mb_split() split multibyte string using regular expression pattern and returns the result as an array.

If optional parameter limit is specified, it will be split in limit elements as maximum.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

참고: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg().

이전 | 처음으로 | 다음
mb_send_mail | 위로 | mb_strcut


mb_strcut

(PHP 4 >= 4.0.6, PHP 5)

mb_strcut -- Get part of string

Description

string mb_strcut ( string str, int start [, int length [, string encoding]])

mb_strcut() returns the portion of str specified by the start and length parameters.

mb_strcut() performs equivalent operation as mb_substr() with different method. If start position is multi-byte character's second byte or larger, it starts from first byte of multi-byte character.

It subtracts string from str that is shorter than length AND character that is not part of multi-byte string or not being middle of shift sequence.

encoding is character encoding. If it is not set, internal character encoding is used.

See also mb_substr(), mb_internal_encoding().

이전 | 처음으로 | 다음
mb_split | 위로 | mb_strimwidth


mb_strimwidth

(PHP 4 >= 4.0.6, PHP 5)

mb_strimwidth -- Get truncated string with specified width

Description

string mb_strimwidth ( string str, int start, int width, string trimmarker [, string encoding])

mb_strimwidth() truncates string str to specified width. It returns truncated string.

If trimmarker is set, trimmarker is appended to return value.

start is start position offset. Number of characters from the beginning of string. (First character is 0)

trimmarker is string that is added to the end of string when string is truncated.

encoding is character encoding. If it is omitted, internal encoding is used.

예 1. mb_strimwidth() example

<?php
$str = mb_strimwidth($str, 0, 40, "..>");
?>

See also mb_strwidth() and mb_internal_encoding().

이전 | 처음으로 | 다음
mb_strcut | 위로 | mb_strlen


mb_strlen

(PHP 4 >= 4.0.6, PHP 5)

mb_strlen -- Get string length

Description

string mb_strlen ( string str [, string encoding])

mb_strlen() returns number of characters in string str having character encoding encoding. A multi-byte character is counted as 1.

encoding is character encoding for str. If encoding is omitted, internal character encoding is used.

See also mb_internal_encoding(), strlen().

이전 | 처음으로 | 다음
mb_strimwidth | 위로 | mb_strpos


mb_strpos

(PHP 4 >= 4.0.6, PHP 5)

mb_strpos -- Find position of first occurrence of string in a string

Description

int mb_strpos ( string haystack, string needle [, int offset [, string encoding]])

mb_strpos() returns the numeric position of the first occurrence of needle in the haystack string. If needle is not found, it returns FALSE.

mb_strpos() performs multi-byte safe strpos() operation based on number of characters. needle position is counted from the beginning of the haystack. First character's position is 0. Second character position is 1, and so on.

If encoding is omitted, internal character encoding is used. mb_strrpos() accepts string for needle where strrpos() accepts only character.

offset is search offset. If it is not specified, 0 is used.

encoding is character encoding name. If it is omitted, internal character encoding is used.

See also mb_strpos(),
mb_internal_encoding(),
strpos()

이전 | 처음으로 | 다음
mb_strlen | 위로 | mb_strrpos


mb_strrpos

(PHP 4 >= 4.0.6, PHP 5)

mb_strrpos -- Find position of last occurrence of a string in a string

Description

int mb_strrpos ( string haystack, string needle [, string encoding])

mb_strrpos() returns the numeric position of the last occurrence of needle in the haystack string. If needle is not found, it returns FALSE.

mb_strrpos() performs multi-byte safe strrpos() operation based on number of characters. needle position is counted from the beginning of haystack. First character's position is 0. Second character position is 1.

If encoding is omitted, internal encoding is assumed. mb_strrpos() accepts string for needle where strrpos() accepts only character.

encoding is character encoding. If it is not specified, internal character encoding is used.

See also mb_strpos(),
mb_internal_encoding(),
strrpos().

이전 | 처음으로 | 다음
mb_strpos | 위로 | mb_strtolower


mb_strtolower

(PHP 4 >= 4.3.0, PHP 5)

mb_strtolower -- Make a string lowercase

Description

string mb_strtolower ( string str [, string encoding])

mb_strtolower() returns str with all alphabetic characters converted to lowercase.

encoding specifies the encoding of str; if omitted, the internal character encoding value will be used.

For more information about the Unicode properties, please see http://www.unicode.org/unicode/reports/tr21/.

By contrast to strtolower(), 'alphabetic' is determined by the Unicode character properties. Thus the behaviour of this function is not affected by locale settings and it can convert any characters that have 'alphabetic' property, such as A-umlaut (?).

예 1. mb_strtolower() example

<?php
$str = "Mary Had A Little Lamb and She LOVED It So";
$str = mb_strtolower($str);
echo $str; // Prints mary had a little lamb and she loved it so
?>

See also strtolower(),
mb_strtoupper() and
mb_convert_case().

이전 | 처음으로 | 다음
mb_strrpos | 위로 | mb_strtoupper


mb_strtoupper

(PHP 4 >= 4.3.0, PHP 5)

mb_strtoupper -- Make a string uppercase

Description

string mb_strtoupper ( string str [, string encoding])

mb_strtoupper() returns str with all alphabetic characters converted to uppercase.

encoding specifies the encoding of str; if omitted, the internal character encoding value will be used.

By contrast to strtoupper(), 'alphabetic' is determined by the Unicode character properties. Thus the behaviour of this function is not affected by locale settings and it can convert any characters that have 'alphabetic' property, such as a-umlaut (?).

For more information about the Unicode properties, please see http://www.unicode.org/unicode/reports/tr21/.

예 1. mb_strtoupper() example

<?php
$str = "Mary Had A Little Lamb and She LOVED It So";
$str = mb_strtoupper($str);
echo $str; // Prints MARY HAD A LITTLE LAMB AND SHE LOVED IT SO
?>

See also strtoupper(),
mb_strtolower() and
mb_convert_case().

이전 | 처음으로 | 다음
mb_strtolower | 위로 | mb_strwidth


mb_strwidth

(PHP 4 >= 4.0.6, PHP 5)

mb_strwidth -- Return width of string

Description

int mb_strwidth ( string str [, string encoding])

mb_strwidth() returns width of string str.

Multi-byte character usually twice of width compare to single byte character.

표 1. Characters width

Chars | Width
U+0000 - U+0019 | 0
U+0020 - U+1FFF | 1
U+2000 - U+FF60 | 2
U+FF61 - U+FF9F | 1
U+FFA0 - | 2

encoding is character encoding. If it is omitted, internal encoding is used.

See also: mb_strimwidth(), mb_internal_encoding().

이전 | 처음으로 | 다음
mb_strtoupper | 위로 | mb_substitute_character


mb_substitute_character

(PHP 4 >= 4.0.6, PHP 5)

mb_substitute_character -- Set/Get substitution character

Description

mixed mb_substitute_character ( [mixed substrchar])

mb_substitute_character() specifies substitution character when input character encoding is invalid or character code is not exist in output character encoding. Invalid characters may be substituted NULL(no output), string or integer value (Unicode character code value).

This setting affects mb_convert_encoding(),
mb_convert_variables(),
mb_output_handler(),
and mb_send_mail().

substchar : Specify Unicode value as integer or specify as string as follows

  • "none" : no output

  • "long" : Output character code value (Example: U+3000,JIS+7E7E)

Return Value: If substchar is set, it returns TRUE for success, otherwise returns FALSE. If substchar is not set, it returns Unicode value or "none"/"long".

예 1. mb_substitute_character() example

<?php
/* Set with Unicode U+3013 (GETA MARK) */
mb_substitute_character(0x3013);

/* Set hex format */
mb_substitute_character("long");

/* Display current setting */
echo mb_substitute_character();
?>

이전 | 처음으로 | 다음
mb_strwidth | 위로 | mb_substr_count


mb_substr_count

(PHP 4 >= 4.3.0, PHP 5)

mb_substr_count -- Count the number of substring occurrences

Description

int mb_substr_count ( string haystack, string needle [, string encoding])

mb_substr_count() returns the number of times the needle substring occurs in the haystack string.

encoding specifies the encoding for needle and haystack. If omitted, internal character encoding is used.

예 1. mb_substr_count() example

<?php
echo mb_substr_count("This is a test", "is"); // prints out 2
?>

See also substr_count(), mb_strpos(), mb_substr().

이전 | 처음으로 | 다음
mb_substitute_character | 위로 | mb_substr


mb_substr

(PHP 4 >= 4.0.6, PHP 5)

mb_substr -- Get part of string

Description

string mb_substr ( string str, int start [, int length [, string encoding]])

mb_substr() returns the portion of str specified by the start and length parameters.

mb_substr() performs multi-byte safe substr() operation based on number of characters. Position is counted from the beginning of str. First character's position is 0. Second character position is 1, and so on.

If encoding is omitted, internal encoding is assumed.

encoding is character encoding. If it is omitted, internal character encoding is used.

See also mb_strcut(), mb_internal_encoding().

이전 | 처음으로 | 다음
mb_substr_count | 위로 | MCAL Functions


MCAL Functions

PHP 매뉴얼
이전 다음

LIV. MCAL Functions

소개

MCAL stands for Modular Calendar Access Library.

Libmcal is a C library for accessing calendars. It's written to be very modular, with pluggable drivers. MCAL is the calendar equivalent of the IMAP module for mailboxes.

With mcal support, a calendar stream can be opened much like the mailbox stream with the IMAP support. Calendars can be local file stores, remote ICAP servers, or other formats that are supported by the mcal library.

Calendar events can be pulled up, queried, and stored. There is also support for calendar triggers (alarms) and recurring events.

With libmcal, central calendar servers can be accessed, removing the need for any specific database or local file programming.

Most of the functions use an internal event structure that is unique for each stream. This alleviates the need to pass around large objects between functions. There are convenience functions for setting, initializing, and retrieving the event structure values.

참고: 이 확장 모듈은 PHP 5에서 제거되어, PECL로 이동되었습니다.

참고: PHP had an ICAP extension previously, but the original library and the PHP extension is not supported anymore. The suggested replacement is MCAL.

참고: 이 확장 모듈은 윈도우 플랫폼에서는 사용할 수 없습니다.

요구 사항

This extension requires the mcal library to be installed. Grab the latest version from http://mcal.chek.com/ and compile and install it.

설치

After you installed the mcal library, to get these functions to work, you have to compile PHP -with-mcal[=DIR].

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

MCAL_SUNDAY (integer)

MCAL_MONDAY (integer)

MCAL_TUESDAY (integer)

MCAL_WEDNESDAY (integer)

MCAL_THURSDAY (integer)

MCAL_FRIDAY (integer)

MCAL_SATURDAY (integer)

MCAL_JANUARY (integer)

MCAL_FEBRUARY (integer)

MCAL_MARCH (integer)

MCAL_APRIL (integer)

MCAL_MAY (integer)

MCAL_JUNE (integer)

MCAL_JULY (integer)

MCAL_AUGUST (integer)

MCAL_SEPTEMBER (integer)

MCAL_OCTOBER (integer)

MCAL_NOVEMBER (integer)

MCAL_DECEMBER (integer)

MCAL_RECUR_NONE (integer)

MCAL_RECUR_DAILY (integer)

MCAL_RECUR_WEEKLY (integer)

MCAL_RECUR_MONTHLY_MDAY (integer)

MCAL_RECUR_MONTHLY_WDAY (integer)

MCAL_RECUR_YEARLY (integer)

MCAL_M_SUNDAY (integer)

MCAL_M_MONDAY (integer)

MCAL_M_TUESDAY (integer)

MCAL_M_WEDNESDAY (integer)

MCAL_M_THURSDAY (integer)

MCAL_M_FRIDAY (integer)

MCAL_M_SATURDAY (integer)

MCAL_M_WEEKDAYS (integer)

MCAL_M_WEEKEND (integer)

MCAL_M_ALLDAYS (integer)

차례
mcal_append_event -- Store a new event into an MCAL calendar
mcal_close -- Close an MCAL stream
mcal_create_calendar -- Create a new MCAL calendar
mcal_date_compare -- Compares two dates
mcal_date_valid -- Returns TRUE if the given year, month, day is a valid date
mcal_day_of_week -- Returns the day of the week of the given date
mcal_day_of_year -- Returns the day of the year of the given date
mcal_days_in_month -- Returns the number of days in a month
mcal_delete_calendar -- Delete an MCAL calendar
mcal_delete_event -- Delete an event from an MCAL calendar
mcal_event_add_attribute -- Adds an attribute and a value to the streams global event structure
mcal_event_init -- Initializes a streams global event structure
mcal_event_set_alarm -- Sets the alarm of the streams global event structure
mcal_event_set_category -- Sets the category of the streams global event structure
mcal_event_set_class -- Sets the class of the streams global event structure
mcal_event_set_description -- Sets the description of the streams global event structure
mcal_event_set_end -- Sets the end date and time of the streams global event structure
mcal_event_set_recur_daily -- Sets the recurrence of the streams global event structure
mcal_event_set_recur_monthly_mday -- Sets the recurrence of the streams global event structure
mcal_event_set_recur_monthly_wday -- Sets the recurrence of the streams global event structure
mcal_event_set_recur_none -- Sets the recurrence of the streams global event structure
mcal_event_set_recur_weekly -- Sets the recurrence of the streams global event structure
mcal_event_set_recur_yearly -- Sets the recurrence of the streams global event structure
mcal_event_set_start -- Sets the start date and time of the streams global event structure
mcal_event_set_title -- Sets the title of the streams global event structure
mcal_expunge -- Deletes all events marked for being expunged.
mcal_fetch_current_stream_event -- Returns an object containing the current streams event structure
mcal_fetch_event -- Fetches an event from the calendar stream
mcal_is_leap_year -- Returns if the given year is a leap year or not
mcal_list_alarms -- Return a list of events that has an alarm triggered at the given datetime
mcal_list_events -- Return a list of IDs for a date or a range of dates
mcal_next_recurrence -- Returns the next recurrence of the event
mcal_open -- Opens up an MCAL connection
mcal_popen -- Opens up a persistent MCAL connection
mcal_rename_calendar -- Rename an MCAL calendar
mcal_reopen -- Reopens an MCAL connection
mcal_snooze -- Turn off an alarm for an event
mcal_store_event -- Modify an existing event in an MCAL calendar
mcal_time_valid -- Returns TRUE if the given hour, minutes and seconds is a valid time
mcal_week_of_year -- Returns the week number of the given date

이전 | 처음으로 | 다음
mb_substr | 위로 | mcal_append_event


mcal_append_event

(PHP 4 )

mcal_append_event -- Store a new event into an MCAL calendar

Description

int mcal_append_event ( int mcal_stream)

mcal_append_event() stores the global event into an MCAL calendar for the stream mcal_stream.

Returns the id of the newly inserted event.

이전 | 처음으로 | 다음
MCAL Functions | 위로 | mcal_close


mcal_close

(PHP 3>= 3.0.13, PHP 4 )

mcal_close -- Close an MCAL stream

Description

int mcal_close ( int mcal_stream, int flags)

Closes the given mcal stream.

이전 | 처음으로 | 다음
mcal_append_event | 위로 | mcal_create_calendar


mcal_create_calendar

(PHP 3>= 3.0.13, PHP 4 )

mcal_create_calendar -- Create a new MCAL calendar

Description

bool mcal_create_calendar ( int stream, string calendar)

Creates a new calendar named calendar.

이전 | 처음으로 | 다음
mcal_close | 위로 | mcal_date_compare


mcal_date_compare

(PHP 3>= 3.0.13, PHP 4 )

mcal_date_compare -- Compares two dates

Description

int mcal_date_compare ( int a_year, int a_month, int a_day, int b_year, int b_month, int b_day)

mcal_date_compare() Compares the two given dates, returns <0, 0, >0 if a<b, a==b, a>b respectively.

이전 | 처음으로 | 다음
mcal_create_calendar | 위로 | mcal_date_valid


mcal_date_valid

(PHP 3>= 3.0.13, PHP 4 )

mcal_date_valid -- Returns TRUE if the given year, month, day is a valid date

Description

int mcal_date_valid ( int year, int month, int day)

mcal_date_valid() Returns TRUE if the given year, month and day is a valid date, FALSE if not.

이전 | 처음으로 | 다음
mcal_date_compare | 위로 | mcal_day_of_week


mcal_day_of_week

(PHP 3>= 3.0.13, PHP 4 )

mcal_day_of_week -- Returns the day of the week of the given date

Description

int mcal_day_of_week ( int year, int month, int day)

mcal_day_of_week() returns the day of the week of the given date. Possible return values range from 0 for Sunday through 6 for Saturday.

이전 | 처음으로 | 다음
mcal_date_valid | 위로 | mcal_day_of_year


mcal_day_of_year

(PHP 3>= 3.0.13, PHP 4 )

mcal_day_of_year -- Returns the day of the year of the given date

Description

int mcal_day_of_year ( int year, int month, int day)

mcal_day_of_year() returns the day of the year of the given date.

이전 | 처음으로 | 다음
mcal_day_of_week | 위로 | mcal_days_in_month


mcal_days_in_month

(PHP 3>= 3.0.13, PHP 4 )

mcal_days_in_month -- Returns the number of days in a month

Description

int mcal_days_in_month ( int month, int leap_year)

mcal_days_in_month() returns the number of days in the month month, taking into account if the considered year is a leap year or not.

이전 | 처음으로 | 다음
mcal_day_of_year | 위로 | mcal_delete_calendar


mcal_delete_calendar

(PHP 3>= 3.0.13, PHP 4 )

mcal_delete_calendar -- Delete an MCAL calendar

Description

string mcal_delete_calendar ( int stream, string calendar)

Deletes the calendar named calendar.

이전 | 처음으로 | 다음
mcal_days_in_month | 위로 | mcal_delete_event


mcal_delete_event

(PHP 3>= 3.0.13, PHP 4 )

mcal_delete_event -- Delete an event from an MCAL calendar

Description

int mcal_delete_event ( int mcal_stream [, int event_id])

mcal_delete_event() deletes the calendar event specified by the event_id.

Returns TRUE.

이전 | 처음으로 | 다음
mcal_delete_calendar | 위로 | mcal_event_add_attribute


mcal_event_add_attribute

(PHP 3>= 3.0.15, PHP 4 )

mcal_event_add_attribute -- Adds an attribute and a value to the streams global event structure

Description

void mcal_event_add_attribute ( int stream, string attribute, string value)

mcal_event_add_attribute() adds an attribute to the stream's global event structure with the value given by "value".

이전 | 처음으로 | 다음
mcal_delete_event | 위로 | mcal_event_init


mcal_event_init

(PHP 3>= 3.0.13, PHP 4 )

mcal_event_init -- Initializes a streams global event structure

Description

int mcal_event_init ( int stream)

mcal_event_init() initializes a streams global event structure. this effectively sets all elements of the structure to 0, or the default settings.

Returns TRUE.

이전 | 처음으로 | 다음
mcal_event_add_attribute | 위로 | mcal_event_set_alarm


mcal_event_set_alarm

(PHP 3>= 3.0.13, PHP 4 )

mcal_event_set_alarm -- Sets the alarm of the streams global event structure

Description

int mcal_event_set_alarm ( int stream, int alarm)

mcal_event_set_alarm() sets the streams global event structure's alarm to the given minutes before the event.

Returns TRUE.

이전 | 처음으로 | 다음
mcal_event_init | 위로 | mcal_event_set_category


mcal_event_set_category

(PHP 3>= 3.0.13, PHP 4 )

mcal_event_set_category -- Sets the category of the streams global event structure

Description

int mcal_event_set_category ( int stream, string category)

mcal_event_set_category() sets the streams global event structure's category to the given string.

Returns TRUE.

이전 | 처음으로 | 다음
mcal_event_set_alarm | 위로 | mcal_event_set_class


mcal_event_set_class

(PHP 3>= 3.0.13, PHP 4 )

mcal_event_set_class -- Sets the class of the streams global event structure

Description

int mcal_event_set_class ( int stream, int class)

mcal_event_set_class() sets the streams global event structure's class to the given value. The class is either 1 for public, or 0 for private.

Returns TRUE.

이전 | 처음으로 | 다음
mcal_event_set_category | 위로 | mcal_event_set_description


mcal_event_set_description

(PHP 3>= 3.0.13, PHP 4 )

mcal_event_set_description -- Sets the description of the streams global event structure

Description

int mcal_event_set_description ( int stream, string description)

mcal_event_set_description() sets the streams global event structure's description to the given string.

Returns TRUE.

이전 | 처음으로 | 다음
mcal_event_set_class | 위로 | mcal_event_set_end


mcal_event_set_end

(PHP 3>= 3.0.13, PHP 4 )

mcal_event_set_end -- Sets the end date and time of the streams global event structure

Description

int mcal_event_set_end ( int stream, int year, int month [, int day [, int hour [, int min [, int sec]]]])

mcal_event_set_end() sets the streams global event structure's end date and time to the given values.

Returns TRUE.

이전 | 처음으로 | 다음
mcal_event_set_description | 위로 | mcal_event_set_recur_daily


mcal_event_set_recur_daily

(PHP 3>= 3.0.13, PHP 4 )

mcal_event_set_recur_daily -- Sets the recurrence of the streams global event structure

Description

int mcal_event_set_recur_daily ( int stream, int year, int month, int day, int interval)

mcal_event_set_recur_daily() sets the streams global event structure's recurrence to the given value to be reoccurring on a daily basis, ending at the given date.

이전 | 처음으로 | 다음
mcal_event_set_end | 위로 | mcal_event_set_recur_monthly_mday


mcal_event_set_recur_monthly_mday

(PHP 3>= 3.0.13, PHP 4 )

mcal_event_set_recur_monthly_mday -- Sets the recurrence of the streams global event structure

Description

int mcal_event_set_recur_monthly_mday ( int stream, int year, int month, int day, int interval)

mcal_event_set_recur_monthly_mday() sets the streams global event structure's recurrence to the given value to be reoccurring on a monthly by month day basis, ending at the given date.

이전 | 처음으로 | 다음
mcal_event_set_recur_daily | 위로 | mcal_event_set_recur_monthly_wday


mcal_event_set_recur_monthly_wday

(PHP 3>= 3.0.13, PHP 4 )

mcal_event_set_recur_monthly_wday -- Sets the recurrence of the streams global event structure

Description

int mcal_event_set_recur_monthly_wday ( int stream, int year, int month, int day, int interval)

mcal_event_set_recur_monthly_wday() sets the streams global event structure's recurrence to the given value to be reoccurring on a monthly by week basis, ending at the given date.

이전 | 처음으로 | 다음
mcal_event_set_recur_monthly_mday | 위로 | mcal_event_set_recur_none


mcal_event_set_recur_none

(PHP 3>= 3.0.15, PHP 4 )

mcal_event_set_recur_none -- Sets the recurrence of the streams global event structure

Description

int mcal_event_set_recur_none ( int stream)

mcal_event_set_recur_none() sets the streams global event structure to not recur (event->recur_type is set to MCAL_RECUR_NONE).

이전 | 처음으로 | 다음
mcal_event_set_recur_monthly_wday | 위로 | mcal_event_set_recur_weekly


mcal_event_set_recur_weekly

(PHP 3>= 3.0.13, PHP 4 )

mcal_event_set_recur_weekly -- Sets the recurrence of the streams global event structure

Description

int mcal_event_set_recur_weekly ( int stream, int year, int month, int day, int interval, int weekdays)

mcal_event_set_recur_weekly() sets the streams global event structure's recurrence to the given value to be reoccurring on a weekly basis, ending at the given date.

이전 | 처음으로 | 다음
mcal_event_set_recur_none | 위로 | mcal_event_set_recur_yearly


mcal_event_set_recur_yearly

(PHP 3>= 3.0.13, PHP 4 )

mcal_event_set_recur_yearly -- Sets the recurrence of the streams global event structure

Description

int mcal_event_set_recur_yearly ( int stream, int year, int month, int day, int interval)

mcal_event_set_recur_yearly() sets the streams global event structure's recurrence to the given value to be reoccurring on a yearly basis,ending at the given date.

이전 | 처음으로 | 다음
mcal_event_set_recur_weekly | 위로 | mcal_event_set_start


mcal_event_set_start

(PHP 3>= 3.0.13, PHP 4 )

mcal_event_set_start -- Sets the start date and time of the streams global event structure

Description

int mcal_event_set_start ( int stream, int year, int month [, int day [, int hour [, int min [, int sec]]]])

mcal_event_set_start() sets the streams global event structure's start date and time to the given values.

Returns TRUE.

이전 | 처음으로 | 다음
mcal_event_set_recur_yearly | 위로 | mcal_event_set_title


mcal_event_set_title

(PHP 3>= 3.0.13, PHP 4 )

mcal_event_set_title -- Sets the title of the streams global event structure

Description

int mcal_event_set_title ( int stream, string title)

mcal_event_set_title() sets the streams global event structure's title to the given string.

Returns TRUE.

이전 | 처음으로 | 다음
mcal_event_set_start | 위로 | mcal_expunge


mcal_expunge

(no version information, might be only in CVS)

mcal_expunge -- Deletes all events marked for being expunged.

Description

int mcal_expunge ( int stream)

mcal_expunge() deletes all events which have been previously marked for deletion.

이전 | 처음으로 | 다음
mcal_event_set_title | 위로 | mcal_fetch_current_stream_event


mcal_fetch_current_stream_event

(PHP 3>= 3.0.13, PHP 4 )

mcal_fetch_current_stream_event -- Returns an object containing the current streams event structure

Description

object mcal_fetch_current_stream_event ( int stream)

mcal_fetch_current_stream_event() returns the current stream's event structure as an object containing:

  • int id - ID of that event.

  • int public - TRUE if the event if public, FALSE if it is private.

  • string category - Category string of the event.

  • string title - Title string of the event.

  • string description - Description string of the event.

  • int alarm - number of minutes before the event to send an alarm/reminder.

  • object start - Object containing a datetime entry.

  • object end - Object containing a datetime entry.

  • int recur_type - recurrence type

  • int recur_interval - recurrence interval

  • datetime recur_enddate - recurrence end date

  • int recur_data - recurrence data

All datetime entries consist of an object that contains:

  • int year - year

  • int month - month

  • int mday - day of month

  • int hour - hour

  • int min - minutes

  • int sec - seconds

  • int alarm - minutes before event to send an alarm

이전 | 처음으로 | 다음
mcal_expunge | 위로 | mcal_fetch_event


mcal_fetch_event

(PHP 3>= 3.0.13, PHP 4 )

mcal_fetch_event -- Fetches an event from the calendar stream

Description

object mcal_fetch_event ( int mcal_stream, int event_id [, int options])

mcal_fetch_event() fetches an event from the calendar stream specified by id.

Returns an event object consisting of:

  • int id - ID of that event.

  • int public - TRUE if the event if public, FALSE if it is private.

  • string category - Category string of the event.

  • string title - Title string of the event.

  • string description - Description string of the event.

  • int alarm - number of minutes before the event to send an alarm/reminder.

  • object start - Object containing a datetime entry.

  • object end - Object containing a datetime entry.

  • int recur_type - recurrence type

  • int recur_interval - recurrence interval

  • datetime recur_enddate - recurrence end date

  • int recur_data - recurrence data

All datetime entries consist of an object that contains:

  • int year - year

  • int month - month

  • int mday - day of month

  • int hour - hour

  • int min - minutes

  • int sec - seconds

  • int alarm - minutes before event to send an alarm

The possible values for recur_type are:

  • 0 - Indicates that this event does not recur

  • 1 - This event recurs daily

  • 2 - This event recurs on a weekly basis

  • 3 - This event recurs monthly on a specific day of the month (e.g. the 10th of the month)

  • 4 - This event recurs monthly on a sequenced day of the week (e.g. the 3rd Saturday)

  • 5 - This event recurs on an annual basis

이전 | 처음으로 | 다음
mcal_fetch_current_stream_event | 위로 | mcal_is_leap_year


mcal_is_leap_year

(PHP 3>= 3.0.13, PHP 4 )

mcal_is_leap_year -- Returns if the given year is a leap year or not

Description

int mcal_is_leap_year ( int year)

mcal_is_leap_year() returns 1 if the given year is a leap year, 0 if not.

이전 | 처음으로 | 다음
mcal_fetch_event | 위로 | mcal_list_alarms


mcal_list_alarms

(PHP 3>= 3.0.13, PHP 4 )

mcal_list_alarms -- Return a list of events that has an alarm triggered at the given datetime

Description

array mcal_list_alarms ( int mcal_stream [, int begin_year [, int begin_month [, int begin_day [, int end_year [, int end_month [, int end_day]]]]]])

Returns an array of event ID's that has an alarm going off between the start and end dates, or if just a stream is given, uses the start and end dates in the global event structure.

mcal_list_events() function takes in an optional beginning date and an end date for a calendar stream. An array of event id's that are between the given dates or the internal event dates are returned.

이전 | 처음으로 | 다음
mcal_is_leap_year | 위로 | mcal_list_events


mcal_list_events

(PHP 3>= 3.0.13, PHP 4 )

mcal_list_events -- Return a list of IDs for a date or a range of dates

Description

array mcal_list_events ( int mcal_stream, object begin_date [, object end_date])

Returns an array of ID's that are between the start and end dates, or if just a stream is given, uses the start and end dates in the global event structure.

mcal_list_events() takes in an beginning date and an optional end date for a calendar stream. An array of event id's that are between the given dates or the internal event dates are returned.

이전 | 처음으로 | 다음
mcal_list_alarms | 위로 | mcal_next_recurrence


mcal_next_recurrence

(PHP 3>= 3.0.13, PHP 4 )

mcal_next_recurrence -- Returns the next recurrence of the event

Description

int mcal_next_recurrence ( int stream, int weekstart, array next)

mcal_next_recurrence() returns an object filled with the next date the event occurs, on or after the supplied date. Returns empty date field if event does not occur or something is invalid. Uses weekstart to determine what day is considered the beginning of the week.

이전 | 처음으로 | 다음
mcal_list_events | 위로 | mcal_open


mcal_open

(PHP 3>= 3.0.13, PHP 4 )

mcal_open -- Opens up an MCAL connection

Description

int mcal_open ( string calendar, string username, string password [, int options])

Returns an MCAL stream on success, FALSE on error.

mcal_open() opens up an MCAL connection to the specified calendar store. If the optional options is specified, passes the options to that mailbox also. The streams internal event structure is also initialized upon connection.

이전 | 처음으로 | 다음
mcal_next_recurrence | 위로 | mcal_popen


mcal_popen

(PHP 3>= 3.0.13, PHP 4 )

mcal_popen -- Opens up a persistent MCAL connection

Description

int mcal_popen ( string calendar, string username, string password [, int options])

Returns an MCAL stream on success, FALSE on error.

mcal_popen() opens up an MCAL connection to the specified calendar store. If the optional options is specified, passes the options to that mailbox also. The streams internal event structure is also initialized upon connection.

이전 | 처음으로 | 다음
mcal_open | 위로 | mcal_rename_calendar


mcal_rename_calendar

(PHP 3>= 3.0.13, PHP 4 )

mcal_rename_calendar -- Rename an MCAL calendar

Description

string mcal_rename_calendar ( int stream, string old_name, string new_name)

Renames the calendar old_name to new_name.

이전 | 처음으로 | 다음
mcal_popen | 위로 | mcal_reopen


mcal_reopen

(PHP 3>= 3.0.13, PHP 4 )

mcal_reopen -- Reopens an MCAL connection

Description

int mcal_reopen ( string calendar [, int options])

Reopens an MCAL stream to a new calendar.

mcal_reopen() reopens an MCAL connection to the specified calendar store. If the optional options is specified, passes the options to that mailbox also.

이전 | 처음으로 | 다음
mcal_rename_calendar | 위로 | mcal_snooze


mcal_snooze

(PHP 3>= 3.0.13, PHP 4 )

mcal_snooze -- Turn off an alarm for an event

Description

bool mcal_snooze ( int stream_id, int event_id)

mcal_snooze() turns off an alarm for a calendar event specified by the stream_id and event_id.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
mcal_reopen | 위로 | mcal_store_event


mcal_store_event

(PHP 3>= 3.0.13, PHP 4 )

mcal_store_event -- Modify an existing event in an MCAL calendar

Description

int mcal_store_event ( int mcal_stream)

mcal_store_event() stores the modifications to the current global event for the given stream.

Returns the event id of the modified event on success and FALSE on error.

이전 | 처음으로 | 다음
mcal_snooze | 위로 | mcal_time_valid


mcal_time_valid

(PHP 3>= 3.0.13, PHP 4 )

mcal_time_valid -- Returns TRUE if the given hour, minutes and seconds is a valid time

Description

int mcal_time_valid ( int hour, int minutes, int seconds)

mcal_time_valid() Returns TRUE if the given hour, minutes and seconds is a valid time, FALSE if not.

이전 | 처음으로 | 다음
mcal_store_event | 위로 | mcal_week_of_year


mcal_week_of_year

(PHP 4 )

mcal_week_of_year -- Returns the week number of the given date

Description

int mcal_week_of_year ( int day, int month, int year)

mcal_week_of_year() returns the week number of the given date.

이전 | 처음으로 | 다음
mcal_time_valid | 위로 | Mcrypt Encryption Functions


Mcrypt Encryption Functions

PHP 매뉴얼
이전 다음

LV. Mcrypt Encryption Functions

소개

This is an interface to the mcrypt library, which supports a wide variety of block algorithms such as DES, TripleDES, Blowfish (default), 3-WAY, SAFER-SK64, SAFER-SK128, TWOFISH, TEA, RC2 and GOST in CBC, OFB, CFB and ECB cipher modes. Additionally, it supports RC6 and IDEA which are considered "non-free".

요구 사항

These functions work using mcrypt. To use it, download libmcrypt-x.x.tar.gz from http://mcrypt.sourceforge.net/ and follow the included installation instructions. Windows users will find all the needed compiled mcrypt binaries at http://ftp.emini.dk/pub/php/win32/mcrypt/.

If you linked against libmcrypt 2.4.x or higher, the following additional block algorithms are supported: CAST, LOKI97, RIJNDAEL, SAFERPLUS, SERPENT and the following stream ciphers: ENIGMA (crypt), PANAMA, RC4 and WAKE. With libmcrypt 2.4.x or higher another cipher mode is also available; nOFB.

설치

You need to compile PHP with the --with-mcrypt[=DIR] parameter to enable this extension. DIR is the mcrypt install directory. Make sure you compile libmcrypt with the option --disable-posix-threads.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. Mcrypt configuration options

Name | Default | Changeable
mcrypt.algorithms_dir | NULL | PHP_INI_ALL
mcrypt.modes_dir | NULL | PHP_INI_ALL
For further details and definition of the PHP_INI_* constants see ini_set().

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

Mcrypt can operate in four block cipher modes (CBC, OFB, CFB, and ECB). If linked against libmcrypt-2.4.x or higher the functions can also operate in the block cipher mode nOFB and in STREAM mode. Below you find a list with all supported encryption modes together with the constants that are defines for the encryption mode. For a more complete reference and discussion see Applied Cryptography by Schneier (ISBN 0-471-11709-9).

  • MCRYPT_MODE_ECB (electronic codebook) is suitable for random data, such as encrypting other keys. Since data there is short and random, the disadvantages of ECB have a favorable negative effect.

  • MCRYPT_MODE_CBC (cipher block chaining) is especially suitable for encrypting files where the security is increased over ECB significantly.

  • MCRYPT_MODE_CFB (cipher feedback) is the best mode for encrypting byte streams where single bytes must be encrypted.

  • MCRYPT_MODE_OFB (output feedback, in 8bit) is comparable to CFB, but can be used in applications where error propagation cannot be tolerated. It's insecure (because it operates in 8bit mode) so it is not recommended to use it.

  • MCRYPT_MODE_NOFB (output feedback, in nbit) is comparable to OFB, but more secure because it operates on the block size of the algorithm.

  • MCRYPT_MODE_STREAM is an extra mode to include some stream algorithms like WAKE or RC4.

Some other mode and random device constants:

MCRYPT_ENCRYPT (integer)

MCRYPT_DECRYPT (integer)

MCRYPT_DEV_RANDOM (integer)

MCRYPT_DEV_URANDOM (integer)

MCRYPT_RAND (integer)

Mcrypt ciphers

Here is a list of ciphers which are currently supported by the mcrypt extension. For a complete list of supported ciphers, see the defines at the end of mcrypt.h. The general rule with the mcrypt-2.2.x API is that you can access the cipher from PHP with MCRYPT_ciphername. With the libmcrypt-2.4.x and libmcrypt-2.5.x API these constants also work, but it is possible to specify the name of the cipher as a string with a call to mcrypt_module_open().

  • MCRYPT_3DES

  • MCRYPT_ARCFOUR_IV (libmcrypt > 2.4.x only)

  • MCRYPT_ARCFOUR (libmcrypt > 2.4.x only)

  • MCRYPT_BLOWFISH

  • MCRYPT_CAST_128

  • MCRYPT_CAST_256

  • MCRYPT_CRYPT

  • MCRYPT_DES

  • MCRYPT_DES_COMPAT (libmcrypt 2.2.x only)

  • MCRYPT_ENIGMA (libmcrypt > 2.4.x only, alias for MCRYPT_CRYPT)

  • MCRYPT_GOST

  • MCRYPT_IDEA (non-free)

  • MCRYPT_LOKI97 (libmcrypt > 2.4.x only)

  • MCRYPT_MARS (libmcrypt > 2.4.x only, non-free)

  • MCRYPT_PANAMA (libmcrypt > 2.4.x only)

  • MCRYPT_RIJNDAEL_128 (libmcrypt > 2.4.x only)

  • MCRYPT_RIJNDAEL_192 (libmcrypt > 2.4.x only)

  • MCRYPT_RIJNDAEL_256 (libmcrypt > 2.4.x only)

  • MCRYPT_RC2

  • MCRYPT_RC4 (libmcrypt 2.2.x only)

  • MCRYPT_RC6 (libmcrypt > 2.4.x only)

  • MCRYPT_RC6_128 (libmcrypt 2.2.x only)

  • MCRYPT_RC6_192 (libmcrypt 2.2.x only)

  • MCRYPT_RC6_256 (libmcrypt 2.2.x only)

  • MCRYPT_SAFER64

  • MCRYPT_SAFER128

  • MCRYPT_SAFERPLUS (libmcrypt > 2.4.x only)

  • MCRYPT_SERPENT(libmcrypt > 2.4.x only)

  • MCRYPT_SERPENT_128 (libmcrypt 2.2.x only)

  • MCRYPT_SERPENT_192 (libmcrypt 2.2.x only)

  • MCRYPT_SERPENT_256 (libmcrypt 2.2.x only)

  • MCRYPT_SKIPJACK (libmcrypt > 2.4.x only)

  • MCRYPT_TEAN (libmcrypt 2.2.x only)

  • MCRYPT_THREEWAY

  • MCRYPT_TRIPLEDES (libmcrypt > 2.4.x only)

  • MCRYPT_TWOFISH (for older mcrypt 2.x versions, or mcrypt > 2.4.x )

  • MCRYPT_TWOFISH128 (TWOFISHxxx are available in newer 2.x versions, but not in the 2.4.x versions)

  • MCRYPT_TWOFISH192

  • MCRYPT_TWOFISH256

  • MCRYPT_WAKE (libmcrypt > 2.4.x only)

  • MCRYPT_XTEA (libmcrypt > 2.4.x only)

You must (in CFB and OFB mode) or can (in CBC mode) supply an initialization vector (IV) to the respective cipher function. The IV must be unique and must be the same when decrypting/encrypting. With data which is stored encrypted, you can take the output of a function of the index under which the data is stored (e.g. the MD5 key of the filename). Alternatively, you can transmit the IV together with the encrypted data (see chapter 9.3 of Applied Cryptography by Schneier (ISBN 0-471-11709-9) for a discussion of this topic).

예제

Mcrypt can be used to encrypt and decrypt using the above mentioned ciphers. If you linked against libmcrypt-2.2.x, the four important mcrypt commands (mcrypt_cfb(), mcrypt_cbc(), mcrypt_ecb(), and mcrypt_ofb()) can operate in both modes which are named MCRYPT_ENCRYPT and MCRYPT_DECRYPT, respectively.

예 1. Encrypt an input value with TripleDES under 2.2.x in ECB mode

<?php
$key = "this is a secret key";
$input = "Let us meet at 9 o'clock at the secret place.";

$encrypted_data = mcrypt_ecb (MCRYPT_3DES, $key, $input, MCRYPT_ENCRYPT);
?>
This example will give you the encrypted data as a string in $encrypted_data.

If you linked against libmcrypt 2.4.x or 2.5.x, these functions are still available, but it is recommended that you use the advanced functions.

예 2. Encrypt an input value with TripleDES under 2.4.x and higher in ECB mode

<?php
    $key = "this is a secret key";
    $input = "Let us meet at 9 o'clock at the secret place.";

    $td = mcrypt_module_open('tripledes', '', 'ecb', '');
    $iv = mcrypt_create_iv (mcrypt_enc_get_iv_size($td), MCRYPT_RAND);
    mcrypt_generic_init($td, $key, $iv);
    $encrypted_data = mcrypt_generic($td, $input);
    mcrypt_generic_deinit($td);
    mcrypt_module_close($td);
?>
This example will give you the encrypted data as a string in $encrypted_data. For a full example see mcrypt_module_open().

차례
mcrypt_cbc -- Encrypt/decrypt data in CBC mode
mcrypt_cfb -- Encrypt/decrypt data in CFB mode
mcrypt_create_iv -- Create an initialization vector (IV) from a random source
mcrypt_decrypt -- Decrypts crypttext with given parameters
mcrypt_ecb -- Deprecated: Encrypt/decrypt data in ECB mode
mcrypt_enc_get_algorithms_name -- Returns the name of the opened algorithm
mcrypt_enc_get_block_size -- Returns the blocksize of the opened algorithm
mcrypt_enc_get_iv_size -- Returns the size of the IV of the opened algorithm
mcrypt_enc_get_key_size -- Returns the maximum supported keysize of the opened mode
mcrypt_enc_get_modes_name -- Returns the name of the opened mode
mcrypt_enc_get_supported_key_sizes -- Returns an array with the supported keysizes of the opened algorithm
mcrypt_enc_is_block_algorithm_mode -- Checks whether the encryption of the opened mode works on blocks
mcrypt_enc_is_block_algorithm -- Checks whether the algorithm of the opened mode is a block algorithm
mcrypt_enc_is_block_mode -- Checks whether the opened mode outputs blocks
mcrypt_enc_self_test -- This function runs a self test on the opened module
mcrypt_encrypt -- Encrypts plaintext with given parameters
mcrypt_generic_deinit -- This function deinitializes an encryption module
mcrypt_generic_end -- This function terminates encryption
mcrypt_generic_init -- This function initializes all buffers needed for encryption
mcrypt_generic -- This function encrypts data
mcrypt_get_block_size -- Get the block size of the specified cipher
mcrypt_get_cipher_name -- Get the name of the specified cipher
mcrypt_get_iv_size -- Returns the size of the IV belonging to a specific cipher/mode combination
mcrypt_get_key_size -- Get the key size of the specified cipher
mcrypt_list_algorithms -- Get an array of all supported ciphers
mcrypt_list_modes -- Get an array of all supported modes
mcrypt_module_close -- Close the mcrypt module
mcrypt_module_get_algo_block_size -- Returns the blocksize of the specified algorithm
mcrypt_module_get_algo_key_size -- Returns the maximum supported keysize of the opened mode
mcrypt_module_get_supported_key_sizes -- Returns an array with the supported keysizes of the opened algorithm
mcrypt_module_is_block_algorithm_mode -- returns if the specified module is a block algorithm or not
mcrypt_module_is_block_algorithm -- This function checks whether the specified algorithm is a block algorithm
mcrypt_module_is_block_mode -- Returns if the specified mode outputs blocks or not
mcrypt_module_open -- Opens the module of the algorithm and the mode to be used
mcrypt_module_self_test -- This function runs a self test on the specified module
mcrypt_ofb -- Encrypt/decrypt data in OFB mode
mdecrypt_generic -- Decrypt data

이전 | 처음으로 | 다음
mcal_week_of_year | 위로 | mcrypt_cbc


mcrypt_cbc

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

mcrypt_cbc -- Encrypt/decrypt data in CBC mode

Description

string mcrypt_cbc ( int cipher, string key, string data, int mode [, string iv])

string mcrypt_cbc ( string cipher, string key, string data, int mode [, string iv])

The first prototype is when linked against libmcrypt 2.2.x, the second when linked against libmcrypt 2.4.x or higher. The mode should be either MCRYPT_ENCRYPT or MCRYPT_DECRYPT.

This function should not be used anymore, see mcrypt_generic() and mdecrypt_generic() for replacements.

이전 | 처음으로 | 다음
Mcrypt Encryption Functions | 위로 | mcrypt_cfb


mcrypt_cfb

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

mcrypt_cfb -- Encrypt/decrypt data in CFB mode

Description

string mcrypt_cfb ( int cipher, string key, string data, int mode, string iv)

string mcrypt_cfb ( string cipher, string key, string data, int mode [, string iv])

The first prototype is when linked against libmcrypt 2.2.x, the second when linked against libmcrypt 2.4.x or higher. The mode should be either MCRYPT_ENCRYPT or MCRYPT_DECRYPT.

This function should not be used anymore, see mcrypt_generic() and mdecrypt_generic() for replacements.

이전 | 처음으로 | 다음
mcrypt_cbc | 위로 | mcrypt_create_iv


mcrypt_create_iv

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

mcrypt_create_iv -- Create an initialization vector (IV) from a random source

Description

string mcrypt_create_iv ( int size, int source)

mcrypt_create_iv() is used to create an IV.

mcrypt_create_iv() takes two arguments, size determines the size of the IV, source specifies the source of the IV.

The source can be MCRYPT_RAND (system random number generator), MCRYPT_DEV_RANDOM (read data from /dev/random) and MCRYPT_DEV_URANDOM (read data from /dev/urandom). If you use MCRYPT_RAND, make sure to call srand() before to initialize the random number generator. MCRYPT_RAND is the only one supported on Windows because Windows (of course) doesn't have /dev/random or /dev/urandom.

예 1. mcrypt_create_iv() example

<?php
    $size = mcrypt_get_iv_size(MCRYPT_CAST_256, MCRYPT_MODE_CFB);
    $iv = mcrypt_create_iv($size, MCRYPT_DEV_RANDOM);
?>

The IV is only meant to give an alternative seed to the encryption routines. This IV does not need to be secret at all, though it can be desirable. You even can send it along with your ciphertext without loosing security.

More information can be found at http://www.ciphersbyritter.com/GLOSSARY.HTM#IV, http://fn2.freenet.edmonton.ab.ca/~jsavard/crypto/co0409.htm and in chapter 9.3 of Applied Cryptography by Schneier (ISBN 0-471-11709-9) for a discussion of this topic.

이전 | 처음으로 | 다음
mcrypt_cfb | 위로 | mcrypt_decrypt


mcrypt_decrypt

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_decrypt -- Decrypts crypttext with given parameters

Description

string mcrypt_decrypt ( string cipher, string key, string data, string mode [, string iv])

mcrypt_decrypt() decrypts the data and returns the unencrypted data.

Cipher is one of the MCRYPT_ciphername constants of the name of the algorithm as string.

Key is the key with which the data is encrypted. If it's smaller that the required keysize, it is padded with '\0'.

Data is the data that will be decrypted with the given cipher and mode. If the size of the data is not n * blocksize, the data will be padded with '\0'.

Mode is one of the MCRYPT_MODE_modename constants of one of "ecb", "cbc", "cfb", "ofb", "nofb" or "stream".

The IV parameter is used for the initialisation in CBC, CFB, OFB modes, and in some algorithms in STREAM mode. If you do not supply an IV, while it is needed for an algorithm, the function issues a warning and uses an IV with all bytes set to '\0'.

이전 | 처음으로 | 다음
mcrypt_create_iv | 위로 | mcrypt_ecb


mcrypt_ecb

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

mcrypt_ecb -- Deprecated: Encrypt/decrypt data in ECB mode

Description

string mcrypt_ecb ( int cipher, string key, string data, int mode)

string mcrypt_ecb ( string cipher, string key, string data, int mode [, string iv])

The first prototype is when linked against libmcrypt 2.2.x, the second when linked against libmcrypt 2.4.x or higher. The mode should be either MCRYPT_ENCRYPT or MCRYPT_DECRYPT.

This function is deprecated and should not be used anymore, see mcrypt_generic() and mdecrypt_generic() for replacements.

이전 | 처음으로 | 다음
mcrypt_decrypt | 위로 | mcrypt_enc_get_algorithms_name


mcrypt_enc_get_algorithms_name

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_get_algorithms_name -- Returns the name of the opened algorithm

Description

string mcrypt_enc_get_algorithms_name ( resource td)

This function returns the name of the algorithm.

예 1. mcrypt_enc_get_algorithms_name() example

<?php
    $td = mcrypt_module_open(MCRYPT_CAST_256, '', MCRYPT_MODE_CFB, '');
    echo mcrypt_enc_get_algorithms_name($td). "\n";

    $td = mcrypt_module_open('cast-256', '', MCRYPT_MODE_CFB, '');
    echo mcrypt_enc_get_algorithms_name($td). "\n";
?>

Prints:
CAST-256
CAST-256

이전 | 처음으로 | 다음
mcrypt_ecb | 위로 | mcrypt_enc_get_block_size


mcrypt_enc_get_block_size

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_get_block_size -- Returns the blocksize of the opened algorithm

Description

int mcrypt_enc_get_block_size ( resource td)

This function returns the block size of the algorithm specified by the encryption descriptor td in bytes.

이전 | 처음으로 | 다음
mcrypt_enc_get_algorithms_name | 위로 | mcrypt_enc_get_iv_size


mcrypt_enc_get_iv_size

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_get_iv_size -- Returns the size of the IV of the opened algorithm

Description

int mcrypt_enc_get_iv_size ( resource td)

This function returns the size of the iv of the algorithm specified by the encryption descriptor in bytes. If it returns '0' then the IV is ignored in the algorithm. An IV is used in cbc, cfb and ofb modes, and in some algorithms in stream mode.

이전 | 처음으로 | 다음
mcrypt_enc_get_block_size | 위로 | mcrypt_enc_get_key_size


mcrypt_enc_get_key_size

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_get_key_size -- Returns the maximum supported keysize of the opened mode

Description

int mcrypt_enc_get_key_size ( resource td)

This function returns the maximum supported key size of the algorithm specified by the encryption descriptor td in bytes.

이전 | 처음으로 | 다음
mcrypt_enc_get_iv_size | 위로 | mcrypt_enc_get_modes_name


mcrypt_enc_get_modes_name

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_get_modes_name -- Returns the name of the opened mode

Description

string mcrypt_enc_get_modes_name ( resource td)

This function returns the name of the mode.

예 1. mcrypt_enc_get_modes_name() example

<?php
    $td = mcrypt_module_open (MCRYPT_CAST_256, '', MCRYPT_MODE_CFB, '');
    echo mcrypt_enc_get_modes_name($td). "\n";

    $td = mcrypt_module_open ('cast-256', '', 'ecb', '');
    echo mcrypt_enc_get_modes_name($td). "\n";
?>

Prints:

CFB
ECB

이전 | 처음으로 | 다음
mcrypt_enc_get_key_size | 위로 | mcrypt_enc_get_supported_key_sizes


mcrypt_enc_get_supported_key_sizes

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_get_supported_key_sizes -- Returns an array with the supported keysizes of the opened algorithm

Description

array mcrypt_enc_get_supported_key_sizes ( resource td)

Returns an array with the key sizes supported by the algorithm specified by the encryption descriptor. If it returns an empty array then all key sizes between 1 and mcrypt_enc_get_key_size() are supported by the algorithm.

예 1. mcrypt_enc_get_supported_key_sizes() example

<?php
    $td = mcrypt_module_open('rijndael-256', '', 'ecb', '');
    var_dump(mcrypt_enc_get_supported_key_sizes($td));
?>

This will print:

array(3) {
  [0]=>
  int(16)
  [1]=>
  int(24)
  [2]=>
  int(32)
}

이전 | 처음으로 | 다음
mcrypt_enc_get_modes_name | 위로 | mcrypt_enc_is_block_algorithm_mode


mcrypt_enc_is_block_algorithm_mode

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_is_block_algorithm_mode -- Checks whether the encryption of the opened mode works on blocks

Description

bool mcrypt_enc_is_block_algorithm_mode ( resource td)

This function returns TRUE if the mode is for use with block algorithms, otherwise it returns FALSE. (e.g. FALSE for stream, and TRUE for cbc, cfb, ofb).

이전 | 처음으로 | 다음
mcrypt_enc_get_supported_key_sizes | 위로 | mcrypt_enc_is_block_algorithm


mcrypt_enc_is_block_algorithm

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_is_block_algorithm -- Checks whether the algorithm of the opened mode is a block algorithm

Description

bool mcrypt_enc_is_block_algorithm ( resource td)

This function returns TRUE if the algorithm is a block algorithm, or FALSE if it is a stream algorithm.

이전 | 처음으로 | 다음
mcrypt_enc_is_block_algorithm_mode | 위로 | mcrypt_enc_is_block_mode


mcrypt_enc_is_block_mode

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_is_block_mode -- Checks whether the opened mode outputs blocks

Description

bool mcrypt_enc_is_block_mode ( resource td)

This function returns TRUE if the mode outputs blocks of bytes or FALSE if it outputs bytes. (e.g. TRUE for cbc and ecb, and FALSE for cfb and stream).

이전 | 처음으로 | 다음
mcrypt_enc_is_block_algorithm | 위로 | mcrypt_enc_self_test


mcrypt_enc_self_test

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_self_test -- This function runs a self test on the opened module

Description

bool mcrypt_enc_self_test ( resource td)

This function runs the self test on the algorithm specified by the descriptor td. If the self test succeeds it returns FALSE. In case of an error, it returns TRUE.

이전 | 처음으로 | 다음
mcrypt_enc_is_block_mode | 위로 | mcrypt_encrypt


mcrypt_encrypt

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_encrypt -- Encrypts plaintext with given parameters

Description

string mcrypt_encrypt ( string cipher, string key, string data, string mode [, string iv])

mcrypt_encrypt() encrypts the data and returns the encrypted data.

Cipher is one of the MCRYPT_ciphername constants of the name of the algorithm as string.

Key is the key with which the data will be encrypted. If it's smaller that the required keysize, it is padded with '\0'. It is better not to use ASCII strings for keys. It is recommended to use the mhash functions to create a key from a string.

Data is the data that will be encrypted with the given cipher and mode. If the size of the data is not n * blocksize, the data will be padded with '\0'. The returned crypttext can be larger that the size of the data that is given by data.

Mode is one of the MCRYPT_MODE_modename constants of one of "ecb", "cbc", "cfb", "ofb", "nofb" or "stream".

The IV parameter is used for the initialisation in CBC, CFB, OFB modes, and in some algorithms in STREAM mode. If you do not supply an IV, while it is needed for an algorithm, the function issues a warning and uses an IV with all bytes set to '\0'.

예 1. mcrypt_encrypt() Example

<?php
    $iv_size = mcrypt_get_iv_size(MCRYPT_RIJNDAEL_256, MCRYPT_MODE_ECB);
    $iv = mcrypt_create_iv($iv_size, MCRYPT_RAND);
    $key = "This is a very secret key";
    $text = "Meet me at 11 o'clock behind the monument.";
    echo strlen($text) . "\n";

    $crypttext = mcrypt_encrypt(MCRYPT_RIJNDAEL_256, $key, $text, MCRYPT_MODE_ECB, $iv);
    echo strlen($crypttext) . "\n";
?>

The above example will print out:
42
64

See also mcrypt_module_open() for a more advanced API and an example.

이전 | 처음으로 | 다음
mcrypt_enc_self_test | 위로 | mcrypt_generic_deinit


mcrypt_generic_deinit

(PHP 4 >= 4.1.1, PHP 5)

mcrypt_generic_deinit -- This function deinitializes an encryption module

Description

bool mcrypt_generic_deinit ( resource td)

This function terminates encryption specified by the encryption descriptor (td). It clears all buffers, but does not close the module. You need to call mcrypt_module_close() yourself. (But PHP does this for you at the end of the script.) Returns FALSE on error, or TRUE on success.

See for an example mcrypt_module_open() and the entry on mcrypt_generic_init().

이전 | 처음으로 | 다음
mcrypt_encrypt | 위로 | mcrypt_generic_end


mcrypt_generic_end

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_generic_end -- This function terminates encryption

Description

bool mcrypt_generic_end ( resource td)

주의

This function is deprecated, use mcrypt_generic_deinit() instead. It can cause crashes when used with mcrypt_module_close() due to multiple buffer frees.

This function terminates encryption specified by the encryption descriptor (td). Actually it clears all buffers, and closes all the modules used. Returns FALSE on error, or TRUE on success.

이전 | 처음으로 | 다음
mcrypt_generic_deinit | 위로 | mcrypt_generic_init


mcrypt_generic_init

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_generic_init -- This function initializes all buffers needed for encryption

Description

int mcrypt_generic_init ( resource td, string key, string iv)

The maximum length of the key should be the one obtained by calling mcrypt_enc_get_key_size() and every value smaller than this is legal. The IV should normally have the size of the algorithms block size, but you must obtain the size by calling mcrypt_enc_get_iv_size(). IV is ignored in ECB. IV MUST exist in CFB, CBC, STREAM, nOFB and OFB modes. It needs to be random and unique (but not secret). The same IV must be used for encryption/decryption. If you do not want to use it you should set it to zeros, but this is not recommended.

The function returns a negative value on error, -3 when the key length was incorrect, -4 when there was a memory allocation problem and any other return value is an unknown error. If an error occurs a warning will be displayed accordingly.

You need to call this function before every call to mcrypt_generic() or mdecrypt_generic().

See for an example mcrypt_module_open().

이전 | 처음으로 | 다음
mcrypt_generic_end | 위로 | mcrypt_generic


mcrypt_generic

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_generic -- This function encrypts data

Description

string mcrypt_generic ( resource td, string data)

This function encrypts data. The data is padded with "\0" to make sure the length of the data is n * blocksize. This function returns the encrypted data. Note that the length of the returned string can in fact be longer then the input, due to the padding of the data.

If you want to store the encrypted data in a database make sure to store the entire string as returned by mcrypt_generic, or the string will not entirely decrypt properly. If your original string is 10 characters long and the block size is 8 (use mcrypt_enc_get_block_size() to determine the blocksize), you would need at least 16 characters in your database field. Note the string returned by mdecrypt_generic() will be 16 characters as well...use rtrim()($str, "\0") to remove the padding.

If you are for example storing the data in a MySQL database remember that varchar fields automatically have trailing spaces removed during insertion. As encrypted data can end in a space (ASCII 32), the data will be damaged by this removal. Store data in a tinyblob/tinytext (or larger) field instead.

The encryption handle should always be initialized with mcrypt_generic_init() with a key and an IV before calling this function. Where the encryption is done, you should free the encryption buffers by calling mcrypt_generic_deinit(). See mcrypt_module_open() for an example.

See also mdecrypt_generic(),
mcrypt_generic_init(), and
mcrypt_generic_deinit().

이전 | 처음으로 | 다음
mcrypt_generic_init | 위로 | mcrypt_get_block_size


mcrypt_get_block_size

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

mcrypt_get_block_size -- Get the block size of the specified cipher

Description

int mcrypt_get_block_size ( int cipher)

int mcrypt_get_block_size ( string cipher, string module)

The first prototype is when linked against libmcrypt 2.2.x, the second when linked against libmcrypt 2.4.x or 2.5.x.

mcrypt_get_block_size() is used to get the size of a block of the specified cipher (in combination with an encryption mode).

It is more useful to use the mcrypt_enc_get_block_size() function as this uses the resource returned by mcrypt_module_open().

This example shows how to use this function when linked against libmcrypt 2.4.x and 2.5.x.

예 1. mcrypt_get_block_size() example

<?php
    echo mcrypt_get_block_size('tripledes', 'ecb');
?>

Prints:
8

See also: mcrypt_get_key_size(),
mcrypt_enc_get_block_size() and
mcrypt_encrypt().

이전 | 처음으로 | 다음
mcrypt_generic | 위로 | mcrypt_get_cipher_name


mcrypt_get_cipher_name

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

mcrypt_get_cipher_name -- Get the name of the specified cipher

Description

string mcrypt_get_cipher_name ( int cipher)

string mcrypt_get_cipher_name ( string cipher)

mcrypt_get_cipher_name() is used to get the name of the specified cipher.

mcrypt_get_cipher_name() takes the cipher number as an argument (libmcrypt 2.2.x) or takes the cipher name as an argument (libmcrypt 2.4.x or higher) and returns the name of the cipher or FALSE, if the cipher does not exist.

예 1. mcrypt_get_cipher_name() Example

<?php
   $cipher = MCRYPT_TripleDES;

   echo mcrypt_get_cipher_name($cipher);
?>

The above example will produce:
3DES

이전 | 처음으로 | 다음
mcrypt_get_block_size | 위로 | mcrypt_get_iv_size


mcrypt_get_iv_size

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_get_iv_size -- Returns the size of the IV belonging to a specific cipher/mode combination

Description

int mcrypt_get_iv_size ( string cipher, string mode)

mcrypt_get_iv_size() returns the size of the Initialisation Vector (IV) in bytes. On error the function returns FALSE. If the IV is ignored in the specified cipher/mode combination zero is returned.

cipher is one of the MCRYPT_ciphername constants of the name of the algorithm as string.

mode is one of the MCRYPT_MODE_modename constants or one of "ecb", "cbc", "cfb", "ofb", "nofb" or "stream". The IV is ignored in ECB mode as this mode does not require it. You will need to have the same IV (think: starting point) both at encryption and decryption stages, otherwise your encryption will fail.

It is more useful to use the mcrypt_enc_get_iv_size() function as this uses the resource returned by mcrypt_module_open().

예 1. mcrypt_get_iv_size() example

<?php
    echo mcrypt_get_iv_size(MCRYPT_CAST_256, MCRYPT_MODE_CFB) . "\n";

    echo mcrypt_get_iv_size('des', 'ecb') . "\n";
?>

See also
mcrypt_get_block_size(),
mcrypt_enc_get_iv_size() and
mcrypt_create_iv().

이전 | 처음으로 | 다음
mcrypt_get_cipher_name | 위로 | mcrypt_get_key_size


mcrypt_get_key_size

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

mcrypt_get_key_size -- Get the key size of the specified cipher

Description

int mcrypt_get_key_size ( int cipher)

int mcrypt_get_key_size ( string cipher, string module)

The first prototype is when linked against libmcrypt 2.2.x, the second when linked against libmcrypt 2.4.x or 2.5.x.

mcrypt_get_key_size() is used to get the size of a key of the specified cipher (in combination with an encryption mode).

This example shows how to use this function when linked against libmcrypt 2.4.x and 2.5.x. It is more useful to use the mcrypt_enc_get_key_size() function as this uses the resource returned by mcrypt_module_open().

예 1. mcrypt_get_block_size() example

<?php
    echo mcrypt_get_key_size('tripledes', 'ecb');
?>

Prints:
24

See also: mcrypt_get_block_size(),
mcrypt_end_get_key_size() and
mcrypt_encrypt().

이전 | 처음으로 | 다음
mcrypt_get_iv_size | 위로 | mcrypt_list_algorithms


mcrypt_list_algorithms

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_list_algorithms -- Get an array of all supported ciphers

Description

array mcrypt_list_algorithms ( [string lib_dir])

mcrypt_list_algorithms() is used to get an array of all supported algorithms in the lib_dir parameter.

mcrypt_list_algorithms() takes an optional lib_dir parameter which specifies the directory where all algorithms are located. If not specifies, the value of the mcrypt.algorithms_dir php.ini directive is used.

예 1. mcrypt_list_algorithms() Example

<?php
    $algorithms = mcrypt_list_algorithms("/usr/local/lib/libmcrypt");

    foreach ($algorithms as $cipher) {
        echo "$cipher<br />\n";
    }
?>

The above example will produce a list with all supported algorithms in the "/usr/local/lib/libmcrypt" directory.

이전 | 처음으로 | 다음
mcrypt_get_key_size | 위로 | mcrypt_list_modes


mcrypt_list_modes

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_list_modes -- Get an array of all supported modes

Description

array mcrypt_list_modes ( [string lib_dir])

mcrypt_list_modes() is used to get an array of all supported modes in the lib_dir.

mcrypt_list_modes() takes as optional parameter a directory which specifies the directory where all modes are located. If not specifies, the value of the mcrypt.modes_dir php.ini directive is used.

예 1. mcrypt_list_modes() Example

<?php
    $modes = mcrypt_list_modes();

    foreach ($modes as $mode) {
        echo "$mode <br />\n";
    }
?>

The above example will produce a list with all supported algorithms in the default mode directory. If it is not set with the ini directive mcrypt.modes_dir, the default directory of mcrypt is used (which is /usr/local/lib/libmcrypt).

이전 | 처음으로 | 다음
mcrypt_list_algorithms | 위로 | mcrypt_module_close


mcrypt_module_close

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_module_close -- Close the mcrypt module

Description

bool mcrypt_module_close ( resource td)

This function closes the specified encryption handle.

See mcrypt_module_open() for an example.

이전 | 처음으로 | 다음
mcrypt_list_modes | 위로 | mcrypt_module_get_algo_block_size


mcrypt_module_get_algo_block_size

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_module_get_algo_block_size -- Returns the blocksize of the specified algorithm

Description

int mcrypt_module_get_algo_block_size ( string algorithm [, string lib_dir])

This function returns the block size of the algorithm specified in bytes. The optional lib_dir parameter can contain the location where the mode module is on the system.

이전 | 처음으로 | 다음
mcrypt_module_close | 위로 | mcrypt_module_get_algo_key_size


mcrypt_module_get_algo_key_size

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_module_get_algo_key_size -- Returns the maximum supported keysize of the opened mode

Description

int mcrypt_module_get_algo_key_size ( string algorithm [, string lib_dir])

This function returns the maximum supported key size of the algorithm specified in bytes. The optional lib_dir parameter can contain the location where the mode module is on the system.

이전 | 처음으로 | 다음
mcrypt_module_get_algo_block_size | 위로 | mcrypt_module_get_supported_key_sizes


mcrypt_module_get_supported_key_sizes

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_module_get_supported_key_sizes -- Returns an array with the supported keysizes of the opened algorithm

Description

array mcrypt_module_get_supported_key_sizes ( string algorithm [, string lib_dir])

Returns an array with the key sizes supported by the specified algorithm. If it returns an empty array then all key sizes between 1 and mcrypt_module_get_algo_key_size() are supported by the algorithm. The optional lib_dir parameter can contain the location where the mode module is on the system.

See also mcrypt_enc_get_supported_key_sizes() which is used on open encryption modules.

이전 | 처음으로 | 다음
mcrypt_module_get_algo_key_size | 위로 | mcrypt_module_is_block_algorithm_mode


mcrypt_module_is_block_algorithm_mode

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_module_is_block_algorithm_mode -- returns if the specified module is a block algorithm or not

Description

bool mcrypt_module_is_block_algorithm_mode ( string mode [, string lib_dir])

This function returns TRUE if the mode is for use with block algorithms, otherwise it returns FALSE. (e.g. FALSE for stream, and TRUE for cbc, cfb, ofb). The optional lib_dir parameter can contain the location where the mode module is on the system.

이전 | 처음으로 | 다음
mcrypt_module_get_supported_key_sizes | 위로 | mcrypt_module_is_block_algorithm


mcrypt_module_is_block_algorithm

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_module_is_block_algorithm -- This function checks whether the specified algorithm is a block algorithm

Description

bool mcrypt_module_is_block_algorithm ( string algorithm [, string lib_dir])

This function returns TRUE if the specified algorithm is a block algorithm, or FALSE is it is a stream algorithm. The optional lib_dir parameter can contain the location where the algorithm module is on the system.

이전 | 처음으로 | 다음
mcrypt_module_is_block_algorithm_mode | 위로 | mcrypt_module_is_block_mode


mcrypt_module_is_block_mode

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_module_is_block_mode -- Returns if the specified mode outputs blocks or not

Description

bool mcrypt_module_is_block_mode ( string mode [, string lib_dir])

This function returns TRUE if the mode outputs blocks of bytes or FALSE if it outputs just bytes. (e.g. TRUE for cbc and ecb, and FALSE for cfb and stream). The optional lib_dir parameter can contain the location where the mode module is on the system.

이전 | 처음으로 | 다음
mcrypt_module_is_block_algorithm | 위로 | mcrypt_module_open


mcrypt_module_open

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_module_open -- Opens the module of the algorithm and the mode to be used

Description

resource mcrypt_module_open ( string algorithm, string algorithm_directory, string mode, string mode_directory)

This function opens the module of the algorithm and the mode to be used. The name of the algorithm is specified in algorithm, e.g. "twofish" or is one of the MCRYPT_ciphername constants. The module is closed by calling mcrypt_module_close(). Normally it returns an encryption descriptor, or FALSE on error.

The algorithm_directory and mode_directory are used to locate the encryption modules. When you supply a directory name, it is used. When you set one of these to the empty string (""), the value set by the mcrypt.algorithms_dir or mcrypt.modes_dir ini-directive is used. When these are not set, the default directories that are used are the ones that were compiled in into libmcrypt (usually /usr/local/lib/libmcrypt).

예 1. mcrypt_module_open() examples

<?php
    $td = mcrypt_module_open(MCRYPT_DES, '',
        MCRYPT_MODE_ECB, '/usr/lib/mcrypt-modes');

    $td = mcrypt_module_open('rijndael-256', '', 'ofb', '');
?>

The first line in the example above will try to open the DES cipher from the default directory and the EBC mode from the directory /usr/lib/mcrypt-modes. The second example uses strings as name for the cipher and mode, this only works when the extension is linked against libmcrypt 2.4.x or 2.5.x.

예 2. Using mcrypt_module_open() in encryption

<?php
    /* Open the cipher */
    $td = mcrypt_module_open('rijndael-256', '', 'ofb', '');

    /* Create the IV and determine the keysize length, used MCRYPT_RAND
     * on Windows instead */
    $iv = mcrypt_create_iv(mcrypt_enc_get_iv_size($td), MCRYPT_DEV_RANDOM);
    $ks = mcrypt_enc_get_key_size($td);

    /* Create key */
    $key = substr(md5('very secret key'), 0, $ks);

    /* Intialize encryption */
    mcrypt_generic_init($td, $key, $iv);

    /* Encrypt data */
    $encrypted = mcrypt_generic($td, 'This is very important data');

    /* Terminate encryption handler */
    mcrypt_generic_deinit($td);

    /* Initialize encryption module for decryption */
    mcrypt_generic_init($td, $key, $iv);

    /* Decrypt encrypted string */
    $decrypted = mdecrypt_generic($td, $encrypted);

    /* Terminate decryption handle and close module */
    mcrypt_generic_deinit($td);
    mcrypt_module_close($td);

    /* Show string */
    echo trim($decrypted) . "\n";
?>

The first line in the example above will try to open the DES cipher from the default directory and the EBC mode from the directory /usr/lib/mcrypt-modes. The second example uses strings as name for the cipher and mode, this only works when the extension is linked against libmcrypt 2.4.x or 2.5.x.

See also
mcrypt_module_close(),
mcrypt_generic(),
mdecrypt_generic(),
mcrypt_generic_init(), and
mcrypt_generic_deinit().

이전 | 처음으로 | 다음
mcrypt_module_is_block_mode | 위로 | mcrypt_module_self_test


mcrypt_module_self_test

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_module_self_test -- This function runs a self test on the specified module

Description

bool mcrypt_module_self_test ( string algorithm [, string lib_dir])

This function runs the self test on the algorithm specified. The optional lib_dir parameter can contain the location of where the algorithm module is on the system.

The function returns TRUE if the self test succeeds, or FALSE when if fails.

예 1. mcrypt_module_self_test() example

<?php
var_dump(mcrypt_module_self_test(MCRYPT_RIJNDAEL_128)) . "\n";
var_dump(mcrypt_module_self_test(MCRYPT_BOGUS_CYPHER));
?>

The above example will output:

bool(true)
bool(false)

이전 | 처음으로 | 다음
mcrypt_module_open | 위로 | mcrypt_ofb


mcrypt_ofb

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

mcrypt_ofb -- Encrypt/decrypt data in OFB mode

Description

string mcrypt_ofb ( int cipher, string key, string data, int mode, string iv)

string mcrypt_ofb ( string cipher, string key, string data, int mode [, string iv])

The first prototype is when linked against libmcrypt 2.2.x, the second when linked against libmcrypt 2.4.x or higher. The mode should be either MCRYPT_ENCRYPT or MCRYPT_DECRYPT.

This function should not be used anymore, see mcrypt_generic() and mdecrypt_generic() for replacements.

이전 | 처음으로 | 다음
mcrypt_module_self_test | 위로 | mdecrypt_generic


mdecrypt_generic

(PHP 4 >= 4.0.2, PHP 5)

mdecrypt_generic -- Decrypt data

Description

string mdecrypt_generic ( resource td, string data)

This function decrypts data. Note that the length of the returned string can in fact be longer then the unencrypted string, due to the padding of the data.

예 1. mdecrypt_generic() example

<?php
    /* Data */
    $key = 'this is a very long key, even too long for the cipher';
    $plain_text = 'very important data';

    /* Open module, and create IV */
    $td = mcrypt_module_open('des', '', 'ecb', '');
    $key = substr($key, 0, mcrypt_enc_get_key_size($td));
    $iv_size = mcrypt_enc_get_iv_size($td);
    $iv = mcrypt_create_iv($iv_size, MCRYPT_RAND);

    /* Initialize encryption handle */
    if (mcrypt_generic_init($td, $key, $iv) != -1) {

        /* Encrypt data */
        $c_t = mcrypt_generic($td, $plain_text);
        mcrypt_generic_deinit($td);

        /* Reinitialize buffers for decryption */
        mcrypt_generic_init($td, $key, $iv);
        $p_t = mdecrypt_generic($td, $c_t);

        /* Clean up */
        mcrypt_generic_deinit($td);
        mcrypt_module_close($td);
    }

    if (strncmp($p_t, $plain_text, strlen($plain_text)) == 0) {
        echo "ok\n";
    } else {
        echo "error\n";
    }
?>

The above example shows how to check if the data before the encryption is the same as the data after the decryption. It is very important to reinitialize the encryption buffer with mcrypt_generic_init() before you try to decrypt the data.

The decryption handle should always be initialized with mcrypt_generic_init() with a key and an IV before calling this function. Where the encryption is done, you should free the encryption buffers by calling mcrypt_generic_deinit(). See mcrypt_module_open() for an example.

See also mcrypt_generic(),
mcrypt_generic_init(), and
mcrypt_generic_deinit().

이전 | 처음으로 | 다음
mcrypt_ofb | 위로 | MCVE Payment Functions


MCVE Payment Functions

PHP 매뉴얼
이전 다음

LVI. MCVE Payment Functions

소개

These functions interface the MCVE API (libmcve), allowing you to work directly with MCVE from your PHP scripts. MCVE is Main Street Softworks' solution to direct credit card processing for Linux / Unix ( http://www.mainstreetsoftworks.com/ ). It lets you directly address the credit card clearing houses via your *nix box, modem and/or internet connection (bypassing the need for an additional service such as Authorize.Net or Pay Flow Pro). Using the MCVE module for PHP, you can process credit cards directly through MCVE via your PHP scripts. The following references will outline the process.

참고: MCVE is the replacement for RedHat's CCVS. They contracted with RedHat in late 2001 to migrate all existing clientele to the MCVE platform.

참고: 이 확장 모듈은 윈도우 플랫폼에서는 사용할 수 없습니다.

설치

To enable MCVE Support in PHP, first verify your LibMCVE installation directory. You will then need to configure PHP with the --with-mcve option. If you use this option without specifying the path to your MCVE installation, PHP will attempt to look in the default LibMCVE Install location (/usr/local). If MCVE is in a non-standard location, run configure with: --with-mcve=$mcve_path, where $mcve_path is the path to your MCVE installation. Please note that MCVE support requires that $mcve_path/lib and $mcve_path/include exist, and include mcve.h under the include directory and libmcve.so and/or libmcve.a under the lib directory.

Since MCVE has true server/client separation, there are no additional requirements for running PHP with MCVE support. To test your MCVE extension in PHP, you may connect to testbox.mcve.com on port 8333 for IP, or port 8444 for SSL using the MCVE PHP API. Use 'vitale' for your username, and 'test' for your password. Additional information about test facilities are available at http://www.mainstreetsoftworks.com/.

참고

Additional documentation about MCVE's PHP API can be found at http://www.mainstreetsoftworks.com/docs/phpapi.pdf. Main Street's documentation is complete and should be the primary reference for functions.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

MC_TRANTYPE (integer)

MC_USERNAME (integer)

MC_PASSWORD (integer)

MC_ACCOUNT (integer)

MC_TRACKDATA (integer)

MC_EXPDATE (integer)

MC_STREET (integer)

MC_ZIP (integer)

MC_CV (integer)

MC_COMMENTS (integer)

MC_CLERKID (integer)

MC_STATIONID (integer)

MC_APPRCODE (integer)

MC_AMOUNT (integer)

MC_PTRANNUM (integer)

MC_TTID (integer)

MC_USER (integer)

MC_PWD (integer)

MC_ACCT (integer)

MC_BDATE (integer)

MC_EDATE (integer)

MC_BATCH (integer)

MC_FILE (integer)

MC_ADMIN (integer)

MC_AUDITTYPE (integer)

MC_CUSTOM (integer)

MC_EXAMOUNT (integer)

MC_EXCHARGES (integer)

MC_RATE (integer)

MC_RENTERNAME (integer)

MC_RETURNCITY (integer)

MC_RETURNSTATE (integer)

MC_RETURNLOCATION (integer)

MC_PRIORITY (integer)

MC_INQUIRY (integer)

MC_CARDTYPES (integer)

MC_SUB (integer)

MC_MARKER (integer)

MC_DEVICETYPE (integer)

MC_ERRORCODE (integer)

MC_NEWBATCH (integer)

MC_CURR (integer)

MC_DESCMERCH (integer)

MC_DESCLOC (integer)

MC_ORIGTYPE (integer)

MC_PIN (integer)

MC_VOIDORIGTYPE (integer)

MC_TIMESTAMP (integer)

MC_PRIO_HIGH (integer)

MC_PRIO_NORMAL (integer)

MC_PRIO_LOW (integer)

MC_USER_PROC (integer)

MC_USER_USER (integer)

MC_USER_PWD (integer)

MC_USER_INDCODE (integer)

MC_USER_MERCHID (integer)

MC_USER_BANKID (integer)

MC_USER_TERMID (integer)

MC_USER_CLIENTNUM (integer)

MC_USER_STOREID (integer)

MC_USER_AGENTID (integer)

MC_USER_CHAINID (integer)

MC_USER_ZIPCODE (integer)

MC_USER_TIMEZONE (integer)

MC_USER_MERCHCAT (integer)

MC_USER_MERNAME (integer)

MC_USER_MERCHLOC (integer)

MC_USER_STATECODE (integer)

MC_USER_PHONE (integer)

MC_USER_SUB (integer)

MC_USER_CARDTYPES (integer)

MC_USER_MODE (integer)

MC_USER_VNUMBER (integer)

MC_USER_ROUTINGID (integer)

MC_USER_PPROPERTY (integer)

MC_USER_PID (integer)

MC_USER_PIDPWD (integer)

MC_USER_SMID (integer)

MC_USER_SMIDPWD (integer)

MC_USER_USDDIV (integer)

MC_USER_AUDDIV (integer)

MC_USER_DKKDIV (integer)

MC_USER_GBPDIV (integer)

MC_USER_HKDDIV (integer)

MC_USER_JPYDIV (integer)

MC_USER_NZDDIV (integer)

MC_USER_NOKDIV (integer)

MC_USER_SGDDIV (integer)

MC_USER_ZARDIV (integer)

MC_USER_SEKDIV (integer)

MC_USER_CHFDIV (integer)

MC_USER_CADDIV (integer)

MC_USER_DIVNUM (integer)

MC_CARD_VISA (integer)

MC_CARD_MC (integer)

MC_CARD_AMEX (integer)

MC_CARD_DISC (integer)

MC_CARD_JCB (integer)

MC_CARD_CB (integer)

MC_CARD_DC (integer)

MC_CARD_GIFT (integer)

MC_CARD_OTHER (integer)

MC_CARD_ALL (integer)

MC_MODE_AUTH (integer)

MC_MODE_SETTLE (integer)

MC_MODE_BOTH (integer)

MC_MODE_ALL (integer)

MC_EXCHARGES_REST (integer)

MC_EXCHARGES_GIFT (integer)

MC_EXCHARGES_MINI (integer)

MC_EXCHARGES_TELE (integer)

MC_EXCHARGES_OTHER (integer)

MC_EXCHARGES_LAUND (integer)

MC_EXCHARGES_NONE (integer)

MC_EXCHARGES_GAS (integer)

MC_EXCHARGES_MILE (integer)

MC_EXCHARGES_LATE (integer)

MC_EXCHARGES_1WAY (integer)

MC_EXCHARGES_VIOL (integer)

MC_TRAN_SALE (integer)

MC_TRAN_REDEMPTION (integer)

MC_TRAN_PREAUTH (integer)

MC_TRAN_VOID (integer)

MC_TRAN_PREAUTHCOMPLETE (integer)

MC_TRAN_FORCE (integer)

MC_TRAN_OVERRIDE (integer)

MC_TRAN_RETURN (integer)

MC_TRAN_RELOAD (integer)

MC_TRAN_CREDIT (integer)

MC_TRAN_SETTLE (integer)

MC_TRAN_INCREMENTAL (integer)

MC_TRAN_REVERSAL (integer)

MC_TRAN_ACTIVATE (integer)

MC_TRAN_BALANCEINQ (integer)

MC_TRAN_CASHOUT (integer)

MC_TRAN_TOREVERSAL (integer)

MC_TRAN_SETTLERFR (integer)

MC_TRAN_ISSUE (integer)

MC_TRAN_TIP (integer)

MC_TRAN_MERCHRETURN (integer)

MC_TRAN_IVRREQ (integer)

MC_TRAN_IVRRESP (integer)

MC_TRAN_ADMIN (integer)

MC_TRAN_PING (integer)

MC_TRAN_CHKPWD (integer)

MC_TRAN_CHNGPWD (integer)

MC_TRAN_LISTSTATS (integer)

MC_TRAN_LISTUSERS (integer)

MC_TRAN_GETUSERINFO (integer)

MC_TRAN_ADDUSER (integer)

MC_TRAN_EDITUSER (integer)

MC_TRAN_DELUSER (integer)

MC_TRAN_ENABLEUSER (integer)

MC_TRAN_DISABLEUSER (integer)

MC_TRAN_IMPORT (integer)

MC_TRAN_EXPORT (integer)

MC_TRAN_ERRORLOG (integer)

MC_TRAN_CLEARERRORLOG (integer)

MC_TRAN_GETSUBACCTS (integer)

MC_ADMIN_GUT (integer)

MC_ADMIN_GL (integer)

MC_ADMIN_GFT (integer)

MC_ADMIN_BT (integer)

MC_ADMIN_UB (integer)

MC_ADMIN_QC (integer)

MC_ADMIN_RS (integer)

MC_ADMIN_CTH (integer)

MC_ADMIN_CFH (integer)

MC_ADMIN_FORCESETTLE (integer)

MC_ADMIN_SETBATCHNUM (integer)

MC_ADMIN_RENUMBERBATCH (integer)

MC_ADMIN_FIELDEDIT (integer)

MC_ADMIN_CLOSEBATCH (integer)

MCVE_UNUSED (integer)

MCVE_NEW (integer)

MCVE_PENDING (integer)

MCVE_DONE (integer)

MCVE_GOOD (integer)

MCVE_BAD (integer)

MCVE_STREET (integer)

MCVE_ZIP (integer)

MCVE_UNKNOWN (integer)

MCVE_ERROR (integer)

MCVE_FAIL (integer)

MCVE_SUCCESS (integer)

MCVE_AUTH (integer)

MCVE_DENY (integer)

MCVE_CALL (integer)

MCVE_DUPL (integer)

MCVE_PKUP (integer)

MCVE_RETRY (integer)

MCVE_SETUP (integer)

MCVE_TIMEOUT (integer)

MCVE_SALE (integer)

MCVE_PREAUTH (integer)

MCVE_FORCE (integer)

MCVE_OVERRIDE (integer)

MCVE_RETURN (integer)

MCVE_SETTLE (integer)

MCVE_PROC (integer)

MCVE_USER (integer)

MCVE_PWD (integer)

MCVE_INDCODE (integer)

MCVE_MERCHID (integer)

MCVE_BANKID (integer)

MCVE_TERMID (integer)

MCVE_CLIENTNUM (integer)

MCVE_STOREID (integer)

MCVE_AGENTID (integer)

MCVE_CHAINID (integer)

MCVE_ZIPCODE (integer)

MCVE_TIMEZONE (integer)

MCVE_MERCHCAT (integer)

MCVE_MERNAME (integer)

MCVE_MERCHLOC (integer)

MCVE_STATECODE (integer)

MCVE_SERVICEPHONE (integer)

차례
mcve_adduser -- Add an MCVE user using usersetup structure
mcve_adduserarg -- Add a value to user configuration structure
mcve_bt -- Get unsettled batch totals
mcve_checkstatus -- Check to see if a transaction has completed
mcve_chkpwd -- Verify Password
mcve_chngpwd -- Change the system administrator's password
mcve_completeauthorizations -- Number of complete authorizations in queue, returning an array of their identifiers
mcve_connect -- Establish the connection to MCVE
mcve_connectionerror -- Get a textual representation of why a connection failed
mcve_deleteresponse -- Delete specified transaction from MCVE_CONN structure
mcve_deletetrans -- Delete specified transaction from MCVE_CONN structure
mcve_deleteusersetup -- Deallocate data associated with usersetup structure
mcve_deluser -- Delete an MCVE user account
mcve_destroyconn -- Destroy the connection and MCVE_CONN structure
mcve_destroyengine -- Free memory associated with IP/SSL connectivity
mcve_disableuser -- Disable an active MCVE user account
mcve_edituser -- Edit MCVE user using usersetup structure
mcve_enableuser -- Enable an inactive MCVE user account
mcve_force -- Send a FORCE to MCVE. (typically, a phone-authorization)
mcve_getcell -- Get a specific cell from a comma delimited response by column name
mcve_getcellbynum -- Get a specific cell from a comma delimited response by column number
mcve_getcommadelimited -- Get the RAW comma delimited data returned from MCVE
mcve_getheader -- Get the name of the column in a comma-delimited response
mcve_getuserarg -- Grab a value from usersetup structure
mcve_getuserparam -- Get a user response parameter
mcve_gft -- Audit MCVE for Failed transactions
mcve_gl -- Audit MCVE for settled transactions
mcve_gut -- Audit MCVE for Unsettled Transactions
mcve_initconn -- Create and initialize an MCVE_CONN structure
mcve_initengine -- Ready the client for IP/SSL Communication
mcve_initusersetup -- Initialize structure to store user data
mcve_iscommadelimited -- Checks to see if response is comma delimited
mcve_liststats -- List statistics for all users on MCVE system
mcve_listusers -- List all users on MCVE system
mcve_maxconntimeout -- The maximum amount of time the API will attempt a connection to MCVE
mcve_monitor -- Perform communication with MCVE (send/receive data) Non-blocking
mcve_numcolumns -- Number of columns returned in a comma delimited response
mcve_numrows -- Number of rows returned in a comma delimited response
mcve_override -- Send an OVERRIDE to MCVE
mcve_parsecommadelimited -- Parse the comma delimited response so mcve_getcell, etc will work
mcve_ping -- Send a ping request to MCVE
mcve_preauth -- Send a PREAUTHORIZATION to MCVE
mcve_preauthcompletion -- Complete a PREAUTHORIZATION... Ready it for settlement
mcve_qc -- Audit MCVE for a list of transactions in the outgoing queue
mcve_responseparam -- Get a custom response parameter
mcve_return -- Issue a RETURN or CREDIT to MCVE
mcve_returncode -- Grab the exact return code from the transaction
mcve_returnstatus -- Check to see if the transaction was successful
mcve_sale -- Send a SALE to MCVE
mcve_setblocking -- Set blocking/non-blocking mode for connection
mcve_setdropfile -- Set the connection method to Drop-File
mcve_setip -- Set the connection method to IP
mcve_setssl_files -- Set certificate key files and certificates if server requires client certificate verification
mcve_setssl -- Set the connection method to SSL
mcve_settimeout -- Set maximum transaction time (per trans)
mcve_settle -- Issue a settlement command to do a batch deposit
mcve_text_avs -- Get a textual representation of the return_avs
mcve_text_code -- Get a textual representation of the return_code
mcve_text_cv -- Get a textual representation of the return_cv
mcve_transactionauth -- Get the authorization number returned for the transaction (alpha-numeric)
mcve_transactionavs -- Get the Address Verification return status
mcve_transactionbatch -- Get the batch number associated with the transaction
mcve_transactioncv -- Get the CVC2/CVV2/CID return status
mcve_transactionid -- Get the unique system id for the transaction
mcve_transactionitem -- Get the ITEM number in the associated batch for this transaction
mcve_transactionssent -- Check to see if outgoing buffer is clear
mcve_transactiontext -- Get verbiage (text) return from MCVE or processing institution
mcve_transinqueue -- Number of transactions in client-queue
mcve_transnew -- Start a new transaction
mcve_transparam -- Add a parameter to a transaction
mcve_transsend -- Finalize and send the transaction
mcve_ub -- Get a list of all Unsettled batches
mcve_uwait -- Wait x microsecs
mcve_verifyconnection -- Set whether or not to PING upon connect to verify connection
mcve_verifysslcert -- Set whether or not to verify the server ssl certificate
mcve_void -- VOID a transaction in the settlement queue

이전 | 처음으로 | 다음
mdecrypt_generic | 위로 | mcve_adduser


mcve_adduser

(PHP 4 >= 4.2.0, PHP 5)

mcve_adduser -- Add an MCVE user using usersetup structure

Description

int mcve_adduser ( resource conn, string admin_password, int usersetup)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
MCVE Payment Functions | 위로 | mcve_adduserarg


mcve_adduserarg

(PHP 4 >= 4.2.0, PHP 5)

mcve_adduserarg -- Add a value to user configuration structure

Description

int mcve_adduserarg ( resource usersetup, int argtype, string argval)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_adduser | 위로 | mcve_bt


mcve_bt

(PHP 4 >= 4.2.0, PHP 5)

mcve_bt -- Get unsettled batch totals

Description

int mcve_bt ( resource conn, string username, string password)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_adduserarg | 위로 | mcve_checkstatus


mcve_checkstatus

(PHP 4 >= 4.2.0, PHP 5)

mcve_checkstatus -- Check to see if a transaction has completed

Description

int mcve_checkstatus ( resource conn, int identifier)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_bt | 위로 | mcve_chkpwd


mcve_chkpwd

(PHP 4 >= 4.2.0, PHP 5)

mcve_chkpwd -- Verify Password

Description

int mcve_chkpwd ( resource conn, string username, string password)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_checkstatus | 위로 | mcve_chngpwd


mcve_chngpwd

(PHP 4 >= 4.2.0, PHP 5)

mcve_chngpwd -- Change the system administrator's password

Description

int mcve_chngpwd ( resource conn, string admin_password, string new_password)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_chkpwd | 위로 | mcve_completeauthorizations


mcve_completeauthorizations

(PHP 4 >= 4.2.0, PHP 5)

mcve_completeauthorizations -- Number of complete authorizations in queue, returning an array of their identifiers

Description

int mcve_completeauthorizations ( resource conn, int &array)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_chngpwd | 위로 | mcve_connect


mcve_connect

(PHP 4 >= 4.2.0, PHP 5)

mcve_connect -- Establish the connection to MCVE

Description

int mcve_connect ( resource conn)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_completeauthorizations | 위로 | mcve_connectionerror


mcve_connectionerror

(PHP 4 >= 4.3.0, PHP 5)

mcve_connectionerror -- Get a textual representation of why a connection failed

Description

string mcve_connectionerror ( resource conn)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_connect | 위로 | mcve_deleteresponse


mcve_deleteresponse

(PHP 4 >= 4.2.0, PHP 5)

mcve_deleteresponse -- Delete specified transaction from MCVE_CONN structure

Description

bool mcve_deleteresponse ( resource conn, int identifier)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_connectionerror | 위로 | mcve_deletetrans


mcve_deletetrans

(PHP 4 >= 4.3.0, PHP 5)

mcve_deletetrans -- Delete specified transaction from MCVE_CONN structure

Description

bool mcve_deletetrans ( resource conn, int identifier)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_deleteresponse | 위로 | mcve_deleteusersetup


mcve_deleteusersetup

(PHP 4 >= 4.2.0, PHP 5)

mcve_deleteusersetup -- Deallocate data associated with usersetup structure

Description

void mcve_deleteusersetup ( resource usersetup)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_deletetrans | 위로 | mcve_deluser


mcve_deluser

(PHP 4 >= 4.2.0, PHP 5)

mcve_deluser -- Delete an MCVE user account

Description

int mcve_deluser ( resource conn, string admin_password, string username)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_deleteusersetup | 위로 | mcve_destroyconn


mcve_destroyconn

(PHP 4 >= 4.2.0, PHP 5)

mcve_destroyconn -- Destroy the connection and MCVE_CONN structure

Description

void mcve_destroyconn ( resource conn)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_deluser | 위로 | mcve_destroyengine


mcve_destroyengine

(PHP 4 >= 4.2.0, PHP 5)

mcve_destroyengine -- Free memory associated with IP/SSL connectivity

Description

void mcve_destroyengine ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_destroyconn | 위로 | mcve_disableuser


mcve_disableuser

(PHP 4 >= 4.2.0, PHP 5)

mcve_disableuser -- Disable an active MCVE user account

Description

int mcve_disableuser ( resource conn, string admin_password, string username)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_destroyengine | 위로 | mcve_edituser


mcve_edituser

(PHP 4 >= 4.2.0, PHP 5)

mcve_edituser -- Edit MCVE user using usersetup structure

Description

int mcve_edituser ( resource conn, string admin_password, int usersetup)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_disableuser | 위로 | mcve_enableuser


mcve_enableuser

(PHP 4 >= 4.2.0, PHP 5)

mcve_enableuser -- Enable an inactive MCVE user account

Description

int mcve_enableuser ( resource conn, string admin_password, string username)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_edituser | 위로 | mcve_force


mcve_force

(PHP 4 >= 4.2.0, PHP 5)

mcve_force -- Send a FORCE to MCVE. (typically, a phone-authorization)

Description

int mcve_force ( resource conn, string username, string password, string trackdata, string account, string expdate, float amount, string authcode, string comments, string clerkid, string stationid, int ptrannum)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_enableuser | 위로 | mcve_getcell


mcve_getcell

(PHP 4 >= 4.2.0, PHP 5)

mcve_getcell -- Get a specific cell from a comma delimited response by column name

Description

string mcve_getcell ( resource conn, int identifier, string column, int row)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_force | 위로 | mcve_getcellbynum


mcve_getcellbynum

(PHP 4 >= 4.2.0, PHP 5)

mcve_getcellbynum -- Get a specific cell from a comma delimited response by column number

Description

string mcve_getcellbynum ( resource conn, int identifier, int column, int row)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_getcell | 위로 | mcve_getcommadelimited


mcve_getcommadelimited

(PHP 4 >= 4.2.0, PHP 5)

mcve_getcommadelimited -- Get the RAW comma delimited data returned from MCVE

Description

string mcve_getcommadelimited ( resource conn, int identifier)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_getcellbynum | 위로 | mcve_getheader


mcve_getheader

(PHP 4 >= 4.2.0, PHP 5)

mcve_getheader -- Get the name of the column in a comma-delimited response

Description

string mcve_getheader ( resource conn, int identifier, int column_num)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_getcommadelimited | 위로 | mcve_getuserarg


mcve_getuserarg

(PHP 4 >= 4.2.0, PHP 5)

mcve_getuserarg -- Grab a value from usersetup structure

Description

string mcve_getuserarg ( resource usersetup, int argtype)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_getheader | 위로 | mcve_getuserparam


mcve_getuserparam

(PHP 4 >= 4.3.0, PHP 5)

mcve_getuserparam -- Get a user response parameter

Description

string mcve_getuserparam ( resource conn, long identifier, int key)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_getuserarg | 위로 | mcve_gft


mcve_gft

(PHP 4 >= 4.2.0, PHP 5)

mcve_gft -- Audit MCVE for Failed transactions

Description

int mcve_gft ( resource conn, string username, string password, int type, string account, string clerkid, string stationid, string comments, int ptrannum, string startdate, string enddate)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_getuserparam | 위로 | mcve_gl


mcve_gl

(PHP 4 >= 4.2.0, PHP 5)

mcve_gl -- Audit MCVE for settled transactions

Description

int mcve_gl ( int conn, string username, string password, int type, string account, string batch, string clerkid, string stationid, string comments, int ptrannum, string startdate, string enddate)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_gft | 위로 | mcve_gut


mcve_gut

(PHP 4 >= 4.2.0, PHP 5)

mcve_gut -- Audit MCVE for Unsettled Transactions

Description

int mcve_gut ( resource conn, string username, string password, int type, string account, string clerkid, string stationid, string comments, int ptrannum, string startdate, string enddate)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_gl | 위로 | mcve_initconn


mcve_initconn

(PHP 4 >= 4.2.0, PHP 5)

mcve_initconn -- Create and initialize an MCVE_CONN structure

Description

resource mcve_initconn ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_gut | 위로 | mcve_initengine


mcve_initengine

(PHP 4 >= 4.2.0, PHP 5)

mcve_initengine -- Ready the client for IP/SSL Communication

Description

int mcve_initengine ( string location)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_initconn | 위로 | mcve_initusersetup


mcve_initusersetup

(PHP 4 >= 4.2.0, PHP 5)

mcve_initusersetup -- Initialize structure to store user data

Description

resource mcve_initusersetup ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_initengine | 위로 | mcve_iscommadelimited


mcve_iscommadelimited

(PHP 4 >= 4.2.0, PHP 5)

mcve_iscommadelimited -- Checks to see if response is comma delimited

Description

int mcve_iscommadelimited ( resource conn, int identifier)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_initusersetup | 위로 | mcve_liststats


mcve_liststats

(PHP 4 >= 4.2.0, PHP 5)

mcve_liststats -- List statistics for all users on MCVE system

Description

int mcve_liststats ( resource conn, string admin_password)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_iscommadelimited | 위로 | mcve_listusers


mcve_listusers

(PHP 4 >= 4.2.0, PHP 5)

mcve_listusers -- List all users on MCVE system

Description

int mcve_listusers ( resource conn, string admin_password)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_liststats | 위로 | mcve_maxconntimeout


mcve_maxconntimeout

(PHP 4 >= 4.3.0, PHP 5)

mcve_maxconntimeout -- The maximum amount of time the API will attempt a connection to MCVE

Description

bool mcve_maxconntimeout ( resource conn, int secs)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_listusers | 위로 | mcve_monitor


mcve_monitor

(PHP 4 >= 4.2.0, PHP 5)

mcve_monitor -- Perform communication with MCVE (send/receive data) Non-blocking

Description

int mcve_monitor ( resource conn)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_maxconntimeout | 위로 | mcve_numcolumns


mcve_numcolumns

(PHP 4 >= 4.2.0, PHP 5)

mcve_numcolumns -- Number of columns returned in a comma delimited response

Description

int mcve_numcolumns ( resource conn, int identifier)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_monitor | 위로 | mcve_numrows


mcve_numrows

(PHP 4 >= 4.2.0, PHP 5)

mcve_numrows -- Number of rows returned in a comma delimited response

Description

int mcve_numrows ( resource conn, int identifier)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_numcolumns | 위로 | mcve_override


mcve_override

(PHP 4 >= 4.2.0, PHP 5)

mcve_override -- Send an OVERRIDE to MCVE

Description

int mcve_override ( resource conn, string username, string password, string trackdata, string account, string expdate, float amount, string street, string zip, string cv, string comments, string clerkid, string stationid, int ptrannum)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_numrows | 위로 | mcve_parsecommadelimited


mcve_parsecommadelimited

(PHP 4 >= 4.2.0, PHP 5)

mcve_parsecommadelimited -- Parse the comma delimited response so mcve_getcell, etc will work

Description

int mcve_parsecommadelimited ( resource conn, int identifier)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_override | 위로 | mcve_ping


mcve_ping

(PHP 4 >= 4.3.0, PHP 5)

mcve_ping -- Send a ping request to MCVE

Description

int mcve_ping ( resource conn)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_parsecommadelimited | 위로 | mcve_preauth


mcve_preauth

(PHP 4 >= 4.2.0, PHP 5)

mcve_preauth -- Send a PREAUTHORIZATION to MCVE

Description

int mcve_preauth ( resource conn, string username, string password, string trackdata, string account, string expdate, float amount, string street, string zip, string cv, string comments, string clerkid, string stationid, int ptrannum)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_ping | 위로 | mcve_preauthcompletion


mcve_preauthcompletion

(PHP 4 >= 4.2.0, PHP 5)

mcve_preauthcompletion -- Complete a PREAUTHORIZATION... Ready it for settlement

Description

int mcve_preauthcompletion ( resource conn, string username, string password, float finalamount, int sid, int ptrannum)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_preauth | 위로 | mcve_qc


mcve_qc

(PHP 4 >= 4.2.0, PHP 5)

mcve_qc -- Audit MCVE for a list of transactions in the outgoing queue

Description

int mcve_qc ( resource conn, string username, string password, string clerkid, string stationid, string comments, int ptrannum)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_preauthcompletion | 위로 | mcve_responseparam


mcve_responseparam

(PHP 4 >= 4.3.0, PHP 5)

mcve_responseparam -- Get a custom response parameter

Description

string mcve_responseparam ( resource conn, long identifier, string key)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_qc | 위로 | mcve_return


mcve_return

(PHP 4 >= 4.2.0, PHP 5)

mcve_return -- Issue a RETURN or CREDIT to MCVE

Description

int mcve_return ( int conn, string username, string password, string trackdata, string account, string expdate, float amount, string comments, string clerkid, string stationid, int ptrannum)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_responseparam | 위로 | mcve_returncode


mcve_returncode

(PHP 4 >= 4.2.0, PHP 5)

mcve_returncode -- Grab the exact return code from the transaction

Description

int mcve_returncode ( resource conn, int identifier)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_return | 위로 | mcve_returnstatus


mcve_returnstatus

(PHP 4 >= 4.2.0, PHP 5)

mcve_returnstatus -- Check to see if the transaction was successful

Description

int mcve_returnstatus ( resource conn, int identifier)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_returncode | 위로 | mcve_sale


mcve_sale

(PHP 4 >= 4.2.0, PHP 5)

mcve_sale -- Send a SALE to MCVE

Description

int mcve_sale ( resource conn, string username, string password, string trackdata, string account, string expdate, float amount, string street, string zip, string cv, string comments, string clerkid, string stationid, int ptrannum)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_returnstatus | 위로 | mcve_setblocking


mcve_setblocking

(PHP 4 >= 4.3.0, PHP 5)

mcve_setblocking -- Set blocking/non-blocking mode for connection

Description

int mcve_setblocking ( resource conn, int tf)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_sale | 위로 | mcve_setdropfile


mcve_setdropfile

(PHP 4 >= 4.2.0, PHP 5)

mcve_setdropfile -- Set the connection method to Drop-File

Description

int mcve_setdropfile ( resource conn, string directory)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_setblocking | 위로 | mcve_setip


mcve_setip

(PHP 4 >= 4.2.0, PHP 5)

mcve_setip -- Set the connection method to IP

Description

int mcve_setip ( resource conn, string host, int port)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_setdropfile | 위로 | mcve_setssl_files


mcve_setssl_files

(PHP 4 >= 4.3.3, PHP 5)

mcve_setssl_files -- Set certificate key files and certificates if server requires client certificate verification

Description

int mcve_setssl_files ( string sslkeyfile, string sslcertfile)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_setip | 위로 | mcve_setssl


mcve_setssl

(PHP 4 >= 4.2.0, PHP 5)

mcve_setssl -- Set the connection method to SSL

Description

int mcve_setssl ( resource conn, string host, int port)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_setssl_files | 위로 | mcve_settimeout


mcve_settimeout

(PHP 4 >= 4.2.0, PHP 5)

mcve_settimeout -- Set maximum transaction time (per trans)

Description

int mcve_settimeout ( resource conn, int seconds)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_setssl | 위로 | mcve_settle


mcve_settle

(PHP 4 >= 4.2.0, PHP 5)

mcve_settle -- Issue a settlement command to do a batch deposit

Description

int mcve_settle ( resource conn, string username, string password, string batch)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_settimeout | 위로 | mcve_text_avs


mcve_text_avs

(PHP 4 >= 4.3.0, PHP 5)

mcve_text_avs -- Get a textual representation of the return_avs

Description

string mcve_text_avs ( string code)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_settle | 위로 | mcve_text_code


mcve_text_code

(PHP 4 >= 4.3.0, PHP 5)

mcve_text_code -- Get a textual representation of the return_code

Description

string mcve_text_code ( string code)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_text_avs | 위로 | mcve_text_cv


mcve_text_cv

(PHP 4 >= 4.3.0, PHP 5)

mcve_text_cv -- Get a textual representation of the return_cv

Description

string mcve_text_cv ( int code)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_text_code | 위로 | mcve_transactionauth


mcve_transactionauth

(PHP 4 >= 4.2.0, PHP 5)

mcve_transactionauth -- Get the authorization number returned for the transaction (alpha-numeric)

Description

string mcve_transactionauth ( resource conn, int identifier)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_text_cv | 위로 | mcve_transactionavs


mcve_transactionavs

(PHP 4 >= 4.2.0, PHP 5)

mcve_transactionavs -- Get the Address Verification return status

Description

int mcve_transactionavs ( resource conn, int identifier)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_transactionauth | 위로 | mcve_transactionbatch


mcve_transactionbatch

(PHP 4 >= 4.2.0, PHP 5)

mcve_transactionbatch -- Get the batch number associated with the transaction

Description

int mcve_transactionbatch ( resource conn, int identifier)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_transactionavs | 위로 | mcve_transactioncv


mcve_transactioncv

(PHP 4 >= 4.2.0, PHP 5)

mcve_transactioncv -- Get the CVC2/CVV2/CID return status

Description

int mcve_transactioncv ( resource conn, int identifier)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_transactionbatch | 위로 | mcve_transactionid


mcve_transactionid

(PHP 4 >= 4.2.0, PHP 5)

mcve_transactionid -- Get the unique system id for the transaction

Description

int mcve_transactionid ( resource conn, int identifier)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_transactioncv | 위로 | mcve_transactionitem


mcve_transactionitem

(PHP 4 >= 4.2.0, PHP 5)

mcve_transactionitem -- Get the ITEM number in the associated batch for this transaction

Description

int mcve_transactionitem ( resource conn, int identifier)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_transactionid | 위로 | mcve_transactionssent


mcve_transactionssent

(PHP 4 >= 4.2.0, PHP 5)

mcve_transactionssent -- Check to see if outgoing buffer is clear

Description

int mcve_transactionssent ( resource conn)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_transactionitem | 위로 | mcve_transactiontext


mcve_transactiontext

(PHP 4 >= 4.2.0, PHP 5)

mcve_transactiontext -- Get verbiage (text) return from MCVE or processing institution

Description

string mcve_transactiontext ( resource conn, int identifier)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_transactionssent | 위로 | mcve_transinqueue


mcve_transinqueue

(PHP 4 >= 4.2.0, PHP 5)

mcve_transinqueue -- Number of transactions in client-queue

Description

int mcve_transinqueue ( resource conn)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_transactiontext | 위로 | mcve_transnew


mcve_transnew

(PHP 4 >= 4.3.0, PHP 5)

mcve_transnew -- Start a new transaction

Description

int mcve_transnew ( resource conn)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_transinqueue | 위로 | mcve_transparam


mcve_transparam

(PHP 4 >= 4.3.0, PHP 5)

mcve_transparam -- Add a parameter to a transaction

Description

int mcve_transparam ( resource conn, long identifier, int key)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_transnew | 위로 | mcve_transsend


mcve_transsend

(PHP 4 >= 4.3.0, PHP 5)

mcve_transsend -- Finalize and send the transaction

Description

int mcve_transsend ( resource conn, long identifier)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_transparam | 위로 | mcve_ub


mcve_ub

(PHP 4 >= 4.2.0, PHP 5)

mcve_ub -- Get a list of all Unsettled batches

Description

int mcve_ub ( resource conn, string username, string password)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_transsend | 위로 | mcve_uwait


mcve_uwait

(PHP 4 >= 4.3.0, PHP 5)

mcve_uwait -- Wait x microsecs

Description

int mcve_uwait ( long microsecs)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_ub | 위로 | mcve_verifyconnection


mcve_verifyconnection

(PHP 4 >= 4.3.0, PHP 5)

mcve_verifyconnection -- Set whether or not to PING upon connect to verify connection

Description

bool mcve_verifyconnection ( resource conn, int tf)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_uwait | 위로 | mcve_verifysslcert


mcve_verifysslcert

(PHP 4 >= 4.3.0, PHP 5)

mcve_verifysslcert -- Set whether or not to verify the server ssl certificate

Description

bool mcve_verifysslcert ( resource conn, int tf)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_verifyconnection | 위로 | mcve_void


mcve_void

(PHP 4 >= 4.2.0, PHP 5)

mcve_void -- VOID a transaction in the settlement queue

Description

int mcve_void ( resource conn, string username, string password, int sid, int ptrannum)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mcve_verifysslcert | 위로 | Mhash Functions


Mhash Functions

PHP 매뉴얼
이전 다음

LVII. Mhash Functions

소개

These functions are intended to work with mhash. Mhash can be used to create checksums, message digests, message authentication codes, and more.

This is an interface to the mhash library. mhash supports a wide variety of hash algorithms such as MD5, SHA1, GOST, and many others. For a complete list of supported hashes, refer to the documentation of mhash. The general rule is that you can access the hash algorithm from PHP with MHASH_HASHNAME. For example, to access TIGER you use the PHP constant MHASH_TIGER.

요구 사항

To use it, download the mhash distribution from its web site and follow the included installation instructions.

설치

You need to compile PHP with the --with-mhash[=DIR] parameter to enable this extension. DIR is the mhash install directory.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

Here is a list of hashes which are currently supported by mhash. If a hash is not listed here, but is listed by mhash as supported, you can safely assume that this documentation is outdated.

  • MHASH_MD5

  • MHASH_SHA1

  • MHASH_HAVAL256

  • MHASH_HAVAL192

  • MHASH_HAVAL160

  • MHASH_HAVAL128

  • MHASH_RIPEMD160

  • MHASH_GOST

  • MHASH_TIGER

  • MHASH_CRC32

  • MHASH_CRC32B

예제

예 1. Compute the MD5 digest and hmac and print it out as hex

<?php
$input = "what do ya want for nothing?";
$hash = mhash(MHASH_MD5, $input);
echo "The hash is " . bin2hex($hash) . "<br />\n";
$hash = mhash(MHASH_MD5, $input, "Jefe");
echo "The hmac is " . bin2hex($hash) . "<br />\n";
?>

This will produce:
The hash is d03cb659cbf9192dcd066272249f8412
The hmac is 750c783e6ab0b503eaa86e310a5db738

차례
mhash_count -- Get the highest available hash id
mhash_get_block_size -- Get the block size of the specified hash
mhash_get_hash_name -- Get the name of the specified hash
mhash_keygen_s2k -- Generates a key
mhash -- Compute hash

이전 | 처음으로 | 다음
mcve_void | 위로 | mhash_count


mhash_count

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

mhash_count -- Get the highest available hash id

Description

int mhash_count ( void )

mhash_count() returns the highest available hash id. Hashes are numbered from 0 to this hash id.

예 1. Traversing all hashes

<?php

$nr = mhash_count();

for ($i = 0; $i <= $nr; $i++) {
    echo sprintf("The blocksize of %s is %d\n",
        mhash_get_hash_name($i),
        mhash_get_block_size($i));
}
?>

이전 | 처음으로 | 다음
Mhash Functions | 위로 | mhash_get_block_size


mhash_get_block_size

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

mhash_get_block_size -- Get the block size of the specified hash

Description

int mhash_get_block_size ( int hash)

mhash_get_block_size() is used to get the size of a block of the specified hash.

mhash_get_block_size() takes one argument, the hash and returns the size in bytes or FALSE, if the hash does not exist.

이전 | 처음으로 | 다음
mhash_count | 위로 | mhash_get_hash_name


mhash_get_hash_name

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

mhash_get_hash_name -- Get the name of the specified hash

Description

string mhash_get_hash_name ( int hash)

mhash_get_hash_name() is used to get the name of the specified hash.

mhash_get_hash_name() takes the hash id as an argument and returns the name of the hash or FALSE, if the hash does not exist.

예 1. mhash_get_hash_name() example

<?php
$hash = MHASH_MD5;

echo mhash_get_hash_name($hash);
?>

The above example will print out:

MD5

이전 | 처음으로 | 다음
mhash_get_block_size | 위로 | mhash_keygen_s2k


mhash_keygen_s2k

(PHP 4 >= 4.0.4, PHP 5)

mhash_keygen_s2k -- Generates a key

Description

string mhash_keygen_s2k ( int hash, string password, string salt, int bytes)

mhash_keygen_s2k() generates a key that is bytes long, from a user given password. This is the Salted S2K algorithm as specified in the OpenPGP document (RFC 2440). That algorithm will use the specified hash algorithm to create the key. The salt must be different and random enough for every key you generate in order to create different keys. That salt must be known when you check the keys, thus it is a good idea to append the key to it. Salt has a fixed length of 8 bytes and will be padded with zeros if you supply less bytes.

Keep in mind that user supplied passwords are not really suitable to be used as keys in cryptographic algorithms, since users normally choose keys they can write on keyboard. These passwords use only 6 to 7 bits per character (or less). It is highly recommended to use some kind of transformation (like this function) to the user supplied key.

이전 | 처음으로 | 다음
mhash_get_hash_name | 위로 | mhash


mhash

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

mhash -- Compute hash

Description

string mhash ( int hash, string data [, string key])

mhash() applies a hash function specified by hash to the data and returns the resulting hash (also called digest). If the key is specified it will return the resulting HMAC. HMAC is keyed hashing for message authentication, or simply a message digest that depends on the specified key. Not all algorithms supported in mhash can be used in HMAC mode. In case of an error returns FALSE.

이전 | 처음으로 | 다음
mhash_keygen_s2k | 위로 | Mimetype Functions


Mimetype Functions

PHP 매뉴얼
이전 다음

LVIII. Mimetype Functions

소개

주의

This extension has been deprecated as the PECL extension fileinfo provides the same functionality (and more) in a much cleaner way.

The functions in this module try to guess the content type and encoding of a file by looking for certain magic byte sequences at specific positions within the file. While this is not a bullet proof approach the heuristics used do a very good job.

This extension is derived from Apache mod_mime_magic, which is itself based on the file command maintained by Ian F. Darwin. See the source code for further historic and copyright information.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

You must compile PHP with the configure switch --with-mime-magic to get support for mime-type functions. The extension needs a copy of the simplified magic file that is distributed with the Apache httpd.

참고: The configure option has been changed from --enable-mime-magic to --with-mime-magic since PHP 4.3.2

참고: This extension is not capable of handling the fully decorated magic file that generally comes with standard Linux distro's and is supposed to be used with recent versions of file command.

Note to Win32 Users: In order to use this module on a Windows environment, you must set the path to the bundled magic.mime file in your php.ini.

예 1. Setting the path to magic.mime

mime_magic.magicfile = "$PHP_INSTALL_DIR\magic.mime"

Remember to substitute the $PHP_INSTALL_DIR for your actual path to PHP in the above example. e.g. c:\php

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. Mimetype configuration options

Name | Default | Changeable
mime_magic.magicfile | "/usr/share/misc/magic.mime" | PHP_INI_SYSTEM
For further details and definition of the PHP_INI_* constants see ini_set().

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
mime_content_type -- Detect MIME Content-type for a file

이전 | 처음으로 | 다음
mhash | 위로 | mime_content_type


mime_content_type

(PHP 4 >= 4.3.0, PHP 5)

mime_content_type -- Detect MIME Content-type for a file

Description

string mime_content_type ( string filename)

Returns the MIME content type for a file as determined by using information from the magic.mime file. Content types are returned in MIME format, like text/plain or application/octet-stream.

예 1. mime_content_type() example

<?php
echo mime_content_type('php.gif') . "\n";
echo mime_content_type('test.php');
?>

The above example will output:

image/gif
text/plain

이전 | 처음으로 | 다음
Mimetype Functions | 위로 | Microsoft SQL Server Functions


Microsoft SQL Server Functions

PHP 매뉴얼
이전 다음

LIX. Microsoft SQL Server Functions

소개

These functions allow you to access MS SQL Server database.

요구 사항

Requirements for Win32 platforms.

The extension requires the MS SQL Client Tools to be installed on the system where PHP is installed. The Client Tools can be installed from the MS SQL Server CD or by copying ntwdblib.dll from \winnt\system32 on the server to \winnt\system32 on the PHP box. Copying ntwdblib.dll will only provide access. Configuration of the client will require installation of all the tools.

Requirements for Unix/Linux platforms.

To use the MSSQL extension on Unix/Linux, you first need to build and install the FreeTDS library. Source code and installation instructions are available at the FreeTDS home page: http://www.freetds.org/

참고: In Windows, the DBLIB from Microsoft is used. Functions that return a column name are based on the dbcolname() function in DBLIB. DBLIB was developed for SQL Server 6.x where the max identifier length is 30. For this reason, the maximum column length is 30 characters. On platforms where FreeTDS is used (Linux), this is not a problem.

설치

The MSSQL extension is enabled by adding extension=php_mssql.dll to php.ini.

To get these functions to work, you have to compile PHP with --with-mssql[=DIR], where DIR is the FreeTDS install prefix. And FreeTDS should be compiled using --enable-msdblib.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. MS SQL Server configuration options

Name | Default | Changeable
mssql.allow_persistent | "1" | PHP_INI_SYSTEM
mssql.max_persistent | "-1" | PHP_INI_SYSTEM
mssql.max_links | "-1" | PHP_INI_SYSTEM
mssql.min_error_severity | "10" | PHP_INI_ALL
mssql.min_message_severity | "10" | PHP_INI_ALL
mssql.compatability_mode | "0" | PHP_INI_ALL
mssql.connect_timeout | "5" | PHP_INI_ALL
mssql.timeout | "60" | PHP_INI_ALL
mssql.textsize | "-1" | PHP_INI_ALL
mssql.textlimit | "-1" | PHP_INI_ALL
mssql.batchsize | "0" | PHP_INI_ALL
mssql.datetimeconvert | "1" | PHP_INI_ALL
mssql.secure_connection | "0" | PHP_INI_SYSTEM
mssql.max_procs | "25" | PHP_INI_ALL
For further details and definition of the PHP_INI_* constants see ini_set().

리소스 종류

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

MSSQL_ASSOC (integer)

MSSQL_NUM (integer)

MSSQL_BOTH (integer)

SQLTEXT (integer)

SQLVARCHAR (integer)

SQLCHAR (integer)

SQLINT1 (integer)

SQLINT2 (integer)

SQLINT4 (integer)

SQLBIT (integer)

SQLFLT8 (integer)

차례
mssql_bind -- Adds a parameter to a stored procedure or a remote stored procedure
mssql_close -- Close MS SQL Server connection
mssql_connect -- Open MS SQL server connection
mssql_data_seek -- Moves internal row pointer
mssql_execute -- Executes a stored procedure on a MS SQL server database
mssql_fetch_array -- Fetch a result row as an associative array, a numeric array, or both
mssql_fetch_assoc -- Returns an associative array of the current row in the result set specified by result_id
mssql_fetch_batch -- Returns the next batch of records
mssql_fetch_field -- Get field information
mssql_fetch_object -- Fetch row as object
mssql_fetch_row -- Get row as enumerated array
mssql_field_length -- Get the length of a field
mssql_field_name -- Get the name of a field
mssql_field_seek -- Seeks to the specified field offset
mssql_field_type -- Gets the type of a field
mssql_free_result -- Free result memory
mssql_free_statement -- Free statement memory
mssql_get_last_message -- Returns the last message from the server
mssql_guid_string -- Converts a 16 byte binary GUID to a string
mssql_init -- Initializes a stored procedure or a remote stored procedure
mssql_min_error_severity -- Sets the lower error severity
mssql_min_message_severity -- Sets the lower message severity
mssql_next_result -- Move the internal result pointer to the next result
mssql_num_fields -- Gets the number of fields in result
mssql_num_rows -- Gets the number of rows in result
mssql_pconnect -- Open persistent MS SQL connection
mssql_query -- Send MS SQL query
mssql_result -- Get result data
mssql_rows_affected -- Returns the number of records affected by the query
mssql_select_db -- Select MS SQL database

이전 | 처음으로 | 다음
mime_content_type | 위로 | mssql_bind


mssql_bind

(PHP 4 >= 4.1.0, PHP 5)

mssql_bind -- Adds a parameter to a stored procedure or a remote stored procedure

Description

bool mssql_bind ( resource stmt, string param_name, mixed var, int type [, int is_output [, int is_null [, int maxlen]]])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also mssql_execute(),
mssql_free_statement(), and
mssql_init().

이전 | 처음으로 | 다음
Microsoft SQL Server Functions | 위로 | mssql_close


mssql_close

(PHP 3, PHP 4 , PHP 5)

mssql_close -- Close MS SQL Server connection

Description

bool mssql_close ( [resource link_identifier])

mssql_close() closes the link to a MS SQL Server database that's associated with the specified link identifier. If the link identifier isn't specified, the last opened link is assumed.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

Note that this isn't usually necessary, as non-persistent open links are automatically closed at the end of the script's execution.

mssql_close() will not close persistent links generated by mssql_pconnect().

See also mssql_connect(), and mssql_pconnect().

이전 | 처음으로 | 다음
mssql_bind | 위로 | mssql_connect


mssql_connect

(PHP 3, PHP 4 , PHP 5)

mssql_connect -- Open MS SQL server connection

Description

int mssql_connect ( [string servername [, string username [, string password]]])

Returns: A positive MS SQL link identifier on success, or FALSE on error.

mssql_connect() establishes a connection to a MS SQL server. The servername argument has to be a valid servername that is defined in the 'interfaces' file.

In case a second call is made to mssql_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned.

The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling mssql_close().

See also mssql_pconnect(), mssql_close().

이전 | 처음으로 | 다음
mssql_close | 위로 | mssql_data_seek


mssql_data_seek

(PHP 3, PHP 4 , PHP 5)

mssql_data_seek -- Moves internal row pointer

Description

bool mssql_data_seek ( resource result_identifier, int row_number)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

mssql_data_seek() moves the internal row pointer of the MS SQL result associated with the specified result identifier to point to the specified row number, first row being number 0. The next call to mssql_fetch_row() would return that row.

See also mssql_data_seek().

이전 | 처음으로 | 다음
mssql_connect | 위로 | mssql_execute


mssql_execute

(PHP 4 >= 4.1.0, PHP 5)

mssql_execute -- Executes a stored procedure on a MS SQL server database

Description

mixed mssql_execute ( resource stmt [, bool skip_results])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: If the stored procedure returns parameters or a return value these will be available after the call to mssql_execute() unless the stored procedure returns more than one result set. In that case use mssql_next_result() to shift through the results. When the last result has been processed the output parameters and return values will be available.

See also mssql_bind(),
mssql_free_statement(), and
mssql_init().

이전 | 처음으로 | 다음
mssql_data_seek | 위로 | mssql_fetch_array


mssql_fetch_array

(PHP 3, PHP 4 , PHP 5)

mssql_fetch_array -- Fetch a result row as an associative array, a numeric array, or both

Description

array mssql_fetch_array ( resource result [, int result_type])

Returns: An array that corresponds to the fetched row, or FALSE if there are no more rows.

mssql_fetch_array() is an extended version of mssql_fetch_row(). In addition to storing the data in the numeric indices of the result array, it also stores the data in associative indices, using the field names as keys.

An important thing to note is that using mssql_fetch_array() is NOT significantly slower than using mssql_fetch_row(), while it provides a significant added value.

참고: 이 함수가 반환하는 필드 이름은 대소문자를 구별합니다.

For further details, also see mssql_fetch_row().

이전 | 처음으로 | 다음
mssql_execute | 위로 | mssql_fetch_assoc


mssql_fetch_assoc

(PHP 4 >= 4.2.0, PHP 5)

mssql_fetch_assoc -- Returns an associative array of the current row in the result set specified by result_id

Description

array mssql_fetch_assoc ( resource result_id)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mssql_fetch_array | 위로 | mssql_fetch_batch


mssql_fetch_batch

(PHP 4 >= 4.0.4, PHP 5)

mssql_fetch_batch -- Returns the next batch of records

Description

int mssql_fetch_batch ( resource result_index)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mssql_fetch_assoc | 위로 | mssql_fetch_field


mssql_fetch_field

(PHP 3, PHP 4 , PHP 5)

mssql_fetch_field -- Get field information

Description

object mssql_fetch_field ( resource result [, int field_offset])

Returns an object containing field information.

mssql_fetch_field() can be used in order to obtain information about fields in a certain query result. If the field offset isn't specified, the next field that wasn't yet retrieved by mssql_fetch_field() is retrieved.

The properties of the object are:

  • name - column name. if the column is a result of a function, this property is set to computed#N, where #N is a serial number.

  • column_source - the table from which the column was taken

  • max_length - maximum length of the column

  • numeric - 1 if the column is numeric

  • type - the column type.

See also mssql_field_seek().

이전 | 처음으로 | 다음
mssql_fetch_batch | 위로 | mssql_fetch_object


mssql_fetch_object

(PHP 3, PHP 5)

mssql_fetch_object -- Fetch row as object

Description

object mssql_fetch_object ( resource result)

Returns: An object with properties that correspond to the fetched row, or FALSE if there are no more rows.

mssql_fetch_object() is similar to mssql_fetch_array(), with one difference - an object is returned, instead of an array. Indirectly, that means that you can only access the data by the field names, and not by their offsets (numbers are illegal property names).

참고: 이 함수가 반환하는 필드 이름은 대소문자를 구별합니다.

Speed-wise, the function is identical to mssql_fetch_array(), and almost as quick as mssql_fetch_row() (the difference is insignificant).

See also mssql_fetch_array(), and mssql_fetch_row().

이전 | 처음으로 | 다음
mssql_fetch_field | 위로 | mssql_fetch_row


mssql_fetch_row

(PHP 3, PHP 4 , PHP 5)

mssql_fetch_row -- Get row as enumerated array

Description

array mssql_fetch_row ( resource result)

Returns: An array that corresponds to the fetched row, or FALSE if there are no more rows.

mssql_fetch_row() fetches one row of data from the result associated with the specified result identifier. The row is returned as an array. Each result column is stored in an array offset, starting at offset 0.

Subsequent call to mssql_fetch_row() would return the next row in the result set, or FALSE if there are no more rows.

See also
mssql_fetch_array(),
mssql_fetch_object(),
mssql_data_seek(),
mssql_fetch_lengths(), and
mssql_result().

이전 | 처음으로 | 다음
mssql_fetch_object | 위로 | mssql_field_length


mssql_field_length

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

mssql_field_length -- Get the length of a field

Description

int mssql_field_length ( resource result [, int offset])

This function returns the length of field no. offset in result result. If offset is omitted, the current field is used.

Note to Win32 Users: Due to a limitation in the underlying API used by PHP (MS DbLib C API), the length of VARCHAR fields is limited to 255. If you need to store more data, use a TEXT field instead.

이전 | 처음으로 | 다음
mssql_fetch_row | 위로 | mssql_field_name


mssql_field_name

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

mssql_field_name -- Get the name of a field

Description

string mssql_field_name ( resource result [, int offset])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mssql_field_length | 위로 | mssql_field_seek


mssql_field_seek

(PHP 3, PHP 4 , PHP 5)

mssql_field_seek -- Seeks to the specified field offset

Description

bool mssql_field_seek ( resource result, int field_offset)

Seeks to the specified field offset. If the next call to mssql_fetch_field() won't include a field offset, this field would be returned.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also mssql_fetch_field().

이전 | 처음으로 | 다음
mssql_field_name | 위로 | mssql_field_type


mssql_field_type

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

mssql_field_type -- Gets the type of a field

Description

string mssql_field_type ( resource result [, int offset])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mssql_field_seek | 위로 | mssql_free_result


mssql_free_result

(PHP 3, PHP 4 , PHP 5)

mssql_free_result -- Free result memory

Description

bool mssql_free_result ( resource result)

mssql_free_result() only needs to be called if you are worried about using too much memory while your script is running. All result memory will automatically be freed when the script ends. You may call mssql_free_result() with the result identifier as an argument and the associated result memory will be freed.

이전 | 처음으로 | 다음
mssql_field_type | 위로 | mssql_free_statement


mssql_free_statement

(PHP 4 >= 4.3.2, PHP 5)

mssql_free_statement -- Free statement memory

Description

bool mssql_free_statement ( resource statement)

mssql_free_statement() only needs to be called if you are worried about using too much memory while your script is running. All statement memory will automatically be freed when the script ends. You may call mssql_free_statement() with the statement identifier as an argument and the associated statement memory will be freed.

See also mssql_bind(),
mssql_execute(), and
mssql_init()

이전 | 처음으로 | 다음
mssql_free_result | 위로 | mssql_get_last_message


mssql_get_last_message

(PHP 3, PHP 4 , PHP 5)

mssql_get_last_message -- Returns the last message from the server

Description

string mssql_get_last_message ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mssql_free_statement | 위로 | mssql_guid_string


mssql_guid_string

(PHP 4 >= 4.1.0, PHP 5)

mssql_guid_string -- Converts a 16 byte binary GUID to a string

Description

string mssql_guid_string ( string binary [, int short_format])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mssql_get_last_message | 위로 | mssql_init


mssql_init

(PHP 4 >= 4.1.0, PHP 5)

mssql_init -- Initializes a stored procedure or a remote stored procedure

Description

int mssql_init ( string sp_name [, resource conn_id])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

See also mssql_bind(),
mssql_execute(), and
mssql_free_statement()

이전 | 처음으로 | 다음
mssql_guid_string | 위로 | mssql_min_error_severity


mssql_min_error_severity

(PHP 3, PHP 4 , PHP 5)

mssql_min_error_severity -- Sets the lower error severity

Description

void mssql_min_error_severity ( int severity)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mssql_init | 위로 | mssql_min_message_severity


mssql_min_message_severity

(PHP 3, PHP 4 , PHP 5)

mssql_min_message_severity -- Sets the lower message severity

Description

void mssql_min_message_severity ( int severity)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mssql_min_error_severity | 위로 | mssql_next_result


mssql_next_result

(PHP 4 >= 4.0.5, PHP 5)

mssql_next_result -- Move the internal result pointer to the next result

Description

bool mssql_next_result ( resource result_id)

When sending more than one SQL statement to the server or executing a stored procedure with multiple results, it will cause the server to return multiple result sets. This function will test for additional results available form the server. If an additional result set exists it will free the existing result set and prepare to fetch the rows from the new result set. The function will return TRUE if an additional result set was available or FALSE otherwise.

예 1. mssql_next_result() example

<?php
    $link = mssql_connect("localhost", "userid", "secret");
    mssql_select_db("MyDB", $link);
    $SQL = "Select * from table1 select * from table2";
    $rs = mssql_query($SQL, $link);
    do {
        while ($row = mssql_fetch_row($rs)) {
        }
    } while (mssql_next_result($rs));
    mssql_free_result($rs);
    mssql_close($link);
?>

이전 | 처음으로 | 다음
mssql_min_message_severity | 위로 | mssql_num_fields


mssql_num_fields

(PHP 3, PHP 4 , PHP 5)

mssql_num_fields -- Gets the number of fields in result

Description

int mssql_num_fields ( resource result)

mssql_num_fields() returns the number of fields in a result set.

See also
mssql_query(),
mssql_fetch_field(), and
mssql_num_rows().

이전 | 처음으로 | 다음
mssql_next_result | 위로 | mssql_num_rows


mssql_num_rows

(PHP 3, PHP 4 , PHP 5)

mssql_num_rows -- Gets the number of rows in result

Description

int mssql_num_rows ( resource result)

mssql_num_rows() returns the number of rows in a result set.

See also mssql_query() and mssql_fetch_row().

이전 | 처음으로 | 다음
mssql_num_fields | 위로 | mssql_pconnect


mssql_pconnect

(PHP 3, PHP 4 , PHP 5)

mssql_pconnect -- Open persistent MS SQL connection

Description

int mssql_pconnect ( [string servername [, string username [, string password]]])

Returns: A positive MS SQL persistent link identifier on success, or FALSE on error.

mssql_pconnect() acts very much like mssql_connect() with two major differences.

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host, username and password. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (mssql_close() will not close links established by mssql_pconnect()).

This type of links is therefore called 'persistent'.

이전 | 처음으로 | 다음
mssql_num_rows | 위로 | mssql_query


mssql_query

(PHP 3, PHP 4 , PHP 5)

mssql_query -- Send MS SQL query

Description

resource mssql_query ( string query [, resource link_identifier [, int batch_size]])

Returns: A positive MS SQL result identifier on success, or FALSE on error.

mssql_query() sends a query to the currently active database on the server that's associated with the specified link identifier. If the link identifier isn't specified, the last opened link is assumed. If no link is open, the function tries to establish a link as if mssql_connect() was called, and use it.

See also mssql_select_db() and mssql_connect().

이전 | 처음으로 | 다음
mssql_pconnect | 위로 | mssql_result


mssql_result

(PHP 3, PHP 4 , PHP 5)

mssql_result -- Get result data

Description

string mssql_result ( resource result, int row, mixed field)

mssql_result() returns the contents of one cell from a MS SQL result set. The field argument can be the field's offset, the field's name or the field's table dot field's name (tablename.fieldname). If the column name has been aliased ('select foo as bar from...'), it uses the alias instead of the column name.

When working on large result sets, you should consider using one of the functions that fetch an entire row (specified below). As these functions return the contents of multiple cells in one function call, they're MUCH quicker than mssql_result(). Also, note that specifying a numeric offset for the field argument is much quicker than specifying a fieldname or tablename.fieldname argument.

Recommended high-performance alternatives:
mssql_fetch_row(),
mssql_fetch_array(), and
mssql_fetch_object().

이전 | 처음으로 | 다음
mssql_query | 위로 | mssql_rows_affected


mssql_rows_affected

(PHP 4 >= 4.0.4, PHP 5)

mssql_rows_affected -- Returns the number of records affected by the query

Description

int mssql_rows_affected ( resource conn_id)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
mssql_result | 위로 | mssql_select_db


mssql_select_db

(PHP 3, PHP 4 , PHP 5)

mssql_select_db -- Select MS SQL database

Description

bool mssql_select_db ( string database_name [, resource link_identifier])

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

mssql_select_db() sets the current active database on the server that's associated with the specified link identifier. If no link identifier is specified, the last opened link is assumed. If no link is open, the function will try to establish a link as if mssql_connect() was called, and use it.

Every subsequent call to mssql_query() will be made on the active database.

In order to select a database containing a space or a hyphen ("-") you need to enclose the database name in brackets, like is shown in the example below:

예 1. mssql_select_db() example

<?php
    $conn = mssql_connect('MYSQLSERVER', 'sa', 'password');
    mssql_select_db('[my data-base]', $conn);
?>

See also:
    mssql_connect(),
    mssql_pconnect(), and
    mssql_query()

이전 | 처음으로 | 다음
mssql_rows_affected | 위로 | Ming functions for Flash


Ming functions for Flash

PHP 매뉴얼
이전 다음

LX. Ming functions for Flash

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

소개

First of all: Ming is not an acronym. Ming is an open-source (LGPL) library which allows you to create SWF ("Flash") format movies. Ming supports almost all of Flash 4's features, including: shapes, gradients, bitmaps (pngs and jpegs), morphs ("shape tweens"), text, buttons, actions, sprites ("movie clips"), streaming mp3, and color transforms --the only thing that's missing is sound events.

Note that all values specifying length, distance, size, etc. are in "twips", twenty units per pixel. That's pretty much arbitrary, though, since the player scales the movie to whatever pixel size is specified in the embed/object tag, or the entire frame if not embedded.

Ming offers a number of advantages over the existing PHP/libswf module. You can use Ming anywhere you can compile the code, whereas libswf is closed-source and only available for a few platforms, Windows not one of them. Ming provides some insulation from the mundane details of the SWF file format, wrapping the movie elements in PHP objects. Also, Ming is still being maintained; if there's a feature that you want to see, just let us know ming@opaque.net.

Ming was added in PHP 4.0.5.

요구 사항

To use Ming with PHP, you first need to build and install the Ming library. Source code and installation instructions are available at the Ming home page: http://ming.sourceforge.net/ along with examples, a small tutorial, and the latest news.

Download the ming archive. Unpack the archive. Go in the Ming directory. make. make install.

This will build libming.so and install it into /usr/lib/, and copy ming.h into /usr/include/. Edit the PREFIX= line in the Makefile to change the installation directory.

설치

예 1. built into PHP (Unix)

mkdir <phpdir>/ext/ming
cp php_ext/* <phpdir>/ext/ming
cd <phpdir>
./buildconf
./configure --with-ming <other config options>

Build and install PHP as usual, restart web server if necessary.

Now either just add extension=php_ming.so to your php.ini file, or put dl('php_ming.so'); at the head of all of your Ming scripts.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

SWFBUTTON_HIT (integer)

SWFBUTTON_DOWN (integer)

SWFBUTTON_OVER (integer)

SWFBUTTON_UP (integer)

SWFBUTTON_MOUSEUPOUTSIDE (integer)

SWFBUTTON_DRAGOVER (integer)

SWFBUTTON_DRAGOUT (integer)

SWFBUTTON_MOUSEUP (integer)

SWFBUTTON_MOUSEDOWN (integer)

SWFBUTTON_MOUSEOUT (integer)

SWFBUTTON_MOUSEOVER (integer)

SWFFILL_RADIAL_GRADIENT (integer)

SWFFILL_LINEAR_GRADIENT (integer)

SWFFILL_TILED_BITMAP (integer)

SWFFILL_CLIPPED_BITMAP (integer)

SWFTEXTFIELD_HASLENGTH (integer)

SWFTEXTFIELD_NOEDIT (integer)

SWFTEXTFIELD_PASSWORD (integer)

SWFTEXTFIELD_MULTILINE (integer)

SWFTEXTFIELD_WORDWRAP (integer)

SWFTEXTFIELD_DRAWBOX (integer)

SWFTEXTFIELD_NOSELECT (integer)

SWFTEXTFIELD_HTML (integer)

SWFTEXTFIELD_ALIGN_LEFT (integer)

SWFTEXTFIELD_ALIGN_RIGHT (integer)

SWFTEXTFIELD_ALIGN_CENTER (integer)

SWFTEXTFIELD_ALIGN_JUSTIFY (integer)

SWFACTION_ONLOAD (integer)

SWFACTION_ENTERFRAME (integer)

SWFACTION_UNLOAD (integer)

SWFACTION_MOUSEMOVE (integer)

SWFACTION_MOUSEDOWN (integer)

SWFACTION_MOUSEUP (integer)

SWFACTION_KEYDOWN (integer)

SWFACTION_KEYUP (integer)

SWFACTION_DATA (integer)

클래스 정의

이 확장 모듈은 다음의 클래스를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

Ming introduces 13 new objects in PHP, all with matching methods and attributes. To use them, you need to know about objects.

swfshape

swffill

swfgradient

swfbitmap

swftext

swftextfield

swffont

swfdisplayitem

swfmovie

swfbutton

swfaction

swfmorph

swfsprite

차례
ming_setcubicthreshold -- Set cubic threshold (?)
ming_setscale -- Set scale (?)
ming_useswfversion -- Use SWF version (?)
SWFAction -- Creates a new Action.
SWFBitmap->getHeight -- Returns the bitmap's height.
SWFBitmap->getWidth -- Returns the bitmap's width.
SWFBitmap -- Loads Bitmap object
swfbutton_keypress -- Returns the action flag for keyPress(char)
SWFbutton->addAction -- Adds an action
SWFbutton->addShape -- Adds a shape to a button
SWFbutton->setAction -- Sets the action
SWFbutton->setdown -- Alias for addShape(shape, SWFBUTTON_DOWN)
SWFbutton->setHit -- Alias for addShape(shape, SWFBUTTON_HIT)
SWFbutton->setOver -- Alias for addShape(shape, SWFBUTTON_OVER)
SWFbutton->setUp -- Alias for addShape(shape, SWFBUTTON_UP)
SWFbutton -- Creates a new Button.
SWFDisplayItem->addColor -- Adds the given color to this item's color transform.
SWFDisplayItem->move -- Moves object in relative coordinates.
SWFDisplayItem->moveTo -- Moves object in global coordinates.
SWFDisplayItem->multColor -- Multiplies the item's color transform.
SWFDisplayItem->remove -- Removes the object from the movie
SWFDisplayItem->Rotate -- Rotates in relative coordinates.
SWFDisplayItem->rotateTo -- Rotates the object in global coordinates.
SWFDisplayItem->scale -- Scales the object in relative coordinates.
SWFDisplayItem->scaleTo -- Scales the object in global coordinates.
SWFDisplayItem->setDepth -- Sets z-order
SWFDisplayItem->setName -- Sets the object's name
SWFDisplayItem->setRatio -- Sets the object's ratio.
SWFDisplayItem->skewX -- Sets the X-skew.
SWFDisplayItem->skewXTo -- Sets the X-skew.
SWFDisplayItem->skewY -- Sets the Y-skew.
SWFDisplayItem->skewYTo -- Sets the Y-skew.
SWFDisplayItem -- Creates a new displayitem object.
SWFFill->moveTo -- Moves fill origin
SWFFill->rotateTo -- Sets fill's rotation
SWFFill->scaleTo -- Sets fill's scale
SWFFill->skewXTo -- Sets fill x-skew
SWFFill->skewYTo -- Sets fill y-skew
SWFFill -- Loads SWFFill object
swffont->getwidth -- Returns the string's width
SWFFont -- Loads a font definition
SWFGradient->addEntry -- Adds an entry to the gradient list.
SWFGradient -- Creates a gradient object
SWFMorph->getshape1 -- Gets a handle to the starting shape
SWFMorph->getshape2 -- Gets a handle to the ending shape
SWFMorph -- Creates a new SWFMorph object.
SWFMovie->add -- Adds any type of data to a movie.
SWFMovie->nextframe -- Moves to the next frame of the animation.
SWFMovie->output -- Dumps your lovingly prepared movie out.
swfmovie->remove -- Removes the object instance from the display list.
SWFMovie->save -- Saves your movie in a file.
SWFMovie->setbackground -- Sets the background color.
SWFMovie->setdimension -- Sets the movie's width and height.
SWFMovie->setframes -- Sets the total number of frames in the animation.
SWFMovie->setrate -- Sets the animation's frame rate.
SWFMovie->streammp3 -- Streams a MP3 file.
SWFMovie -- Creates a new movie object, representing an SWF version 4 movie.
SWFShape->addFill -- Adds a solid fill to the shape.
SWFShape->drawCurve -- Draws a curve (relative).
SWFShape->drawCurveTo -- Draws a curve.
SWFShape->drawLine -- Draws a line (relative).
SWFShape->drawLineTo -- Draws a line.
SWFShape->movePen -- Moves the shape's pen (relative).
SWFShape->movePenTo -- Moves the shape's pen.
SWFShape->setLeftFill -- Sets left rasterizing color.
SWFShape->setLine -- Sets the shape's line style.
SWFShape->setRightFill -- Sets right rasterizing color.
SWFShape -- Creates a new shape object.
swfsprite->add -- Adds an object to a sprite
SWFSprite->nextframe -- Moves to the next frame of the animation.
SWFSprite->remove -- Removes an object to a sprite
SWFSprite->setframes -- Sets the total number of frames in the animation.
SWFSprite -- Creates a movie clip (a sprite)
SWFText->addString -- Draws a string
SWFText->getWidth -- Computes string's width
SWFText->moveTo -- Moves the pen
SWFText->setColor -- Sets the current font color
SWFText->setFont -- Sets the current font
SWFText->setHeight -- Sets the current font height
SWFText->setSpacing -- Sets the current font spacing
SWFText -- Creates a new SWFText object.
SWFTextField->addstring -- Concatenates the given string to the text field
SWFTextField->align -- Sets the text field alignment
SWFTextField->setbounds -- Sets the text field width and height
SWFTextField->setcolor -- Sets the color of the text field.
SWFTextField->setFont -- Sets the text field font
SWFTextField->setHeight -- Sets the font height of this text field font.
SWFTextField->setindentation -- Sets the indentation of the first line.
SWFTextField->setLeftMargin -- Sets the left margin width of the text field.
SWFTextField->setLineSpacing -- Sets the line spacing of the text field.
SWFTextField->setMargins -- Sets the margins width of the text field.
SWFTextField->setname -- Sets the variable name
SWFTextField->setrightMargin -- Sets the right margin width of the text field.
SWFTextField -- Creates a text field object

이전 | 처음으로 | 다음
mssql_select_db | 위로 | ming_setcubicthreshold


ming_setcubicthreshold

(PHP 4 >= 4.0.5, PHP 5)

ming_setcubicthreshold -- Set cubic threshold (?)

Description

void ming_setcubicthreshold ( int threshold)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
Ming functions for Flash | 위로 | ming_setscale


ming_setscale

(PHP 4 >= 4.0.5, PHP 5)

ming_setscale -- Set scale (?)

Description

void ming_setscale ( int scale)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ming_setcubicthreshold | 위로 | ming_useswfversion


ming_useswfversion

(PHP 4 >= 4.2.0, PHP 5)

ming_useswfversion -- Use SWF version (?)

Description

void ming_useswfversion ( int version)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ming_setscale | 위로 | SWFAction


SWFAction

(PHP 4 >= 4.0.5)

SWFAction -- Creates a new Action.

Description

new swfaction ( string script)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfaction() creates a new Action, and compiles the given script into an SWFAction object.

The script syntax is based on the C language, but with a lot taken out- the SWF bytecode machine is just too simpleminded to do a lot of things we might like. For instance, we can't implement function calls without a tremendous amount of hackery because the jump bytecode has a hardcoded offset value. No pushing your calling address to the stack and returning- every function would have to know exactly where to return to.

So what's left? The compiler recognises the following tokens:

  • break

  • for

  • continue

  • if

  • else

  • do

  • while

There is no typed data; all values in the SWF action machine are stored as strings. The following functions can be used in expressions:

time()

Returns the number of milliseconds (?) elapsed since the movie started.

random(seed)

Returns a pseudo-random number in the range 0-seed.

length(expr)

Returns the length of the given expression.

int(number)

Returns the given number rounded down to the nearest integer.

concat(expr, expr)

Returns the concatenation of the given expressions.

ord(expr)

Returns the ASCII code for the given character

chr(num)

Returns the character for the given ASCII code

substr(string, location, length)

Returns the substring of length length at location location of the given string string.

Additionally, the following commands may be used:

duplicateClip(clip, name, depth)

Duplicate the named movie clip (aka sprite). The new movie clip has name name and is at depth depth.

removeClip(expr)

Removes the named movie clip.

trace(expr)

Write the given expression to the trace log. Doubtful that the browser plugin does anything with this.

startDrag(target, lock, [left, top, right, bottom])

Start dragging the movie clip target. The lock argument indicates whether to lock the mouse (?)- use 0 (FALSE) or 1 (TRUE). Optional parameters define a bounding area for the dragging.

stopDrag()

Stop dragging my heart around. And this movie clip, too.

callFrame(expr)

Call the named frame as a function.

getURL(url, target, [method])

Load the given URL into the named target. The target argument corresponds to HTML document targets (such as "_top" or "_blank"). The optional method argument can be POST or GET if you want to submit variables back to the server.

loadMovie(url, target)

Load the given URL into the named target. The target argument can be a frame name (I think), or one of the magical values "_level0" (replaces current movie) or "_level1" (loads new movie on top of current movie).

nextFrame()

Go to the next frame.

prevFrame()

Go to the last (or, rather, previous) frame.

play()

Start playing the movie.

stop()

Stop playing the movie.

toggleQuality()

Toggle between high and low quality.

stopSounds()

Stop playing all sounds.

gotoFrame(num)

Go to frame number num. Frame numbers start at 0.

gotoFrame(name)

Go to the frame named name. Which does a lot of good, since I haven't added frame labels yet.

setTarget(expr)

Sets the context for action. Or so they say- I really have no idea what this does.

And there's one weird extra thing. The expression frameLoaded(num) can be used in if statements and while loops to check if the given frame number has been loaded yet. Well, it's supposed to, anyway, but I've never tested it and I seriously doubt it actually works. You can just use /:framesLoaded instead.

Movie clips (all together now- aka sprites) have properties. You can read all of them (or can you?), you can set some of them, and here they are:

  • x

  • y

  • xScale

  • yScale

  • currentFrame - (read-only)

  • totalFrames - (read-only)

  • alpha - transparency level

  • visible - 1=on, 0=off (?)

  • width - (read-only)

  • height - (read-only)

  • rotation

  • target - (read-only) (???)

  • framesLoaded - (read-only)

  • name

  • dropTarget - (read-only) (???)

  • url - (read-only) (???)

  • highQuality - 1=high, 0=low (?)

  • focusRect - (???)

  • soundBufTime - (???)

So, setting a sprite's x position is as simple as /box.x = 100;. Why the slash in front of the box, though? That's how flash keeps track of the sprites in the movie, just like a Unix filesystem- here it shows that box is at the top level. If the sprite named box had another sprite named biff inside of it, you'd set its x position with /box/biff.x = 100;. At least, I think so; correct me if I'm wrong here.

This simple example will move the red square across the window.

예 1. swfaction() example

<?php
  $s = new SWFShape();
  $f = $s->addFill(0xff, 0, 0);
  $s->setRightFill($f);

  $s->movePenTo(-500, -500);
  $s->drawLineTo(500, -500);
  $s->drawLineTo(500, 500);
  $s->drawLineTo(-500, 500);
  $s->drawLineTo(-500, -500);

  $p = new SWFSprite();
  $i = $p->add($s);
  $i->setDepth(1);
  $p->nextFrame();

  for ($n=0; $n<5; ++$n) {
    $i->rotate(-15);
    $p->nextFrame();
  }

  $m = new SWFMovie();
  $m->setBackground(0xff, 0xff, 0xff);
  $m->setDimension(6000, 4000);

  $i = $m->add($p);
  $i->setDepth(1);
  $i->moveTo(-500,2000);
  $i->setName("box");

  $m->add(new SWFAction("/box.x += 3;"));
  $m->nextFrame();
  $m->add(new SWFAction("gotoFrame(0); play();"));
  $m->nextFrame();

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

This simple example tracks down your mouse on the screen.

예 2. swfaction() example

<?php

  $m = new SWFMovie();
  $m->setRate(36.0);
  $m->setDimension(1200, 800);
  $m->setBackground(0, 0, 0);

  /* mouse tracking sprite - empty, but follows mouse so we can
     get its x and y coordinates */

  $i = $m->add(new SWFSprite());
  $i->setName('mouse');

  $m->add(new SWFAction("
    startDrag('/mouse', 1); /* '1' means lock sprite to the mouse */
  "));

  /* might as well turn off antialiasing, since these are just squares. */

  $m->add(new SWFAction("
    this.quality = 0;
  "));

  /* morphing box */
  $r = new SWFMorph();
  $s = $r->getShape1();

  /* Note this is backwards from normal shapes.  No idea why. */
  $s->setLeftFill($s->addFill(0xff, 0xff, 0xff));
  $s->movePenTo(-40, -40);
  $s->drawLine(80, 0);
  $s->drawLine(0, 80);
  $s->drawLine(-80, 0);
  $s->drawLine(0, -80);

  $s = $r->getShape2();

  $s->setLeftFill($s->addFill(0x00, 0x00, 0x00));
  $s->movePenTo(-1, -1);
  $s->drawLine(2, 0);
  $s->drawLine(0, 2);
  $s->drawLine(-2, 0);
  $s->drawLine(0, -2);

  /* sprite container for morphing box -
     this is just a timeline w/ the box morphing */

  $box = new SWFSprite();
  $box->add(new SWFAction("
    stop();
  "));
  $i = $box->add($r);

  for ($n=0; $n<=20; ++$n) {
    $i->setRatio($n/20);
    $box->nextFrame();
  }

  /* this container sprite allows us to use the same action code many times */

  $cell = new SWFSprite();
  $i = $cell->add($box);
  $i->setName('box');

  $cell->add(new SWFAction("

    setTarget('box');

    /* ...x means the x coordinate of the parent, i.e. (..).x */
    dx = (/mouse.x + random(6)-3 - ...x)/5;
    dy = (/mouse.y + random(6)-3 - ...y)/5;
    gotoFrame(int(dx*dx + dy*dy));

  "));

  $cell->nextFrame();
  $cell->add(new SWFAction("

    gotoFrame(0);
    play();

  "));

  $cell->nextFrame();

  /* finally, add a bunch of the cells to the movie */

  for ($x=0; $x<12; ++$x) {
    for ($y=0; $y<8; ++$y) {
      $i = $m->add($cell);
      $i->moveTo(100*$x+50, 100*$y+50);
    }
  }

  $m->nextFrame();

  $m->add(new SWFAction("

    gotoFrame(1);
    play();

  "));

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Same as above, but with nice colored balls...

예 3. swfaction() example

<?php

  $m = new SWFMovie();
  $m->setDimension(11000, 8000);
  $m->setBackground(0x00, 0x00, 0x00);

  $m->add(new SWFAction("

this.quality = 0;
/frames.visible = 0;
startDrag('/mouse', 1);

  "));

  // mouse tracking sprite
  $t = new SWFSprite();
  $i = $m->add($t);
  $i->setName('mouse');

  $g = new SWFGradient();
  $g->addEntry(0, 0xff, 0xff, 0xff, 0xff);
  $g->addEntry(0.1, 0xff, 0xff, 0xff, 0xff);
  $g->addEntry(0.5, 0xff, 0xff, 0xff, 0x5f);
  $g->addEntry(1.0, 0xff, 0xff, 0xff, 0);

  // gradient shape thing
  $s = new SWFShape();
  $f = $s->addFill($g, SWFFILL_RADIAL_GRADIENT);
  $f->scaleTo(0.03);
  $s->setRightFill($f);
  $s->movePenTo(-600, -600);
  $s->drawLine(1200, 0);
  $s->drawLine(0, 1200);
  $s->drawLine(-1200, 0);
  $s->drawLine(0, -1200);

  // need to make this a sprite so we can multColor it
  $p = new SWFSprite();
  $p->add($s);
  $p->nextFrame();

  // put the shape in here, each frame a different color
  $q = new SWFSprite();
  $q->add(new SWFAction("gotoFrame(random(7)+1); stop();"));
  $i = $q->add($p);

  $i->multColor(1.0, 1.0, 1.0);
  $q->nextFrame();
  $i->multColor(1.0, 0.5, 0.5);
  $q->nextFrame();
  $i->multColor(1.0, 0.75, 0.5);
  $q->nextFrame();
  $i->multColor(1.0, 1.0, 0.5);
  $q->nextFrame();
  $i->multColor(0.5, 1.0, 0.5);
  $q->nextFrame();
  $i->multColor(0.5, 0.5, 1.0);
  $q->nextFrame();
  $i->multColor(1.0, 0.5, 1.0);
  $q->nextFrame();

  // finally, this one contains the action code
  $p = new SWFSprite();
  $i = $p->add($q);
  $i->setName('frames');
  $p->add(new SWFAction("

dx = (/:mousex-/:lastx)/3 + random(10)-5;
dy = (/:mousey-/:lasty)/3;
x = /:mousex;
y = /:mousey;
alpha = 100;

  "));
  $p->nextFrame();

  $p->add(new SWFAction("

this.x = x;
this.y = y;
this.alpha = alpha;
x += dx;
y += dy;
dy += 3;
alpha -= 8;

  "));
  $p->nextFrame();

  $p->add(new SWFAction("prevFrame(); play();"));
  $p->nextFrame();

  $i = $m->add($p);
  $i->setName('frames');
  $m->nextFrame();

  $m->add(new SWFAction("

lastx = mousex;
lasty = mousey;
mousex = /mouse.x;
mousey = /mouse.y;

++num;

if (num == 11)
  num = 1;

removeClip('char' & num);
duplicateClip(/frames, 'char' & num, num);

  "));

  $m->nextFrame();
  $m->add(new SWFAction("prevFrame(); play();"));

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

이전 | 처음으로 | 다음
ming_useswfversion | 위로 | SWFBitmap->getHeight


SWFBitmap->getHeight

(no version information, might be only in CVS)

SWFBitmap->getHeight -- Returns the bitmap's height.

Description

int swfbitmap->getheight ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfbitmap->getheight() returns the bitmap's height in pixels.

See also swfbitmap->getwidth().

이전 | 처음으로 | 다음
SWFAction | 위로 | SWFBitmap->getWidth


SWFBitmap->getWidth

(no version information, might be only in CVS)

SWFBitmap->getWidth -- Returns the bitmap's width.

Description

int swfbitmap->getwidth ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfbitmap->getwidth() returns the bitmap's width in pixels.

See also swfbitmap->getheight().

이전 | 처음으로 | 다음
SWFBitmap->getHeight | 위로 | SWFBitmap


SWFBitmap

(PHP 4 >= 4.0.5)

SWFBitmap -- Loads Bitmap object

Description

new swfbitmap ( string filename [, int alphafilename])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfbitmap() creates a new SWFBitmap object from the Jpeg or DBL file named filename. alphafilename indicates a MSK file to be used as an alpha mask for a Jpeg image.

참고: We can only deal with baseline (frame 0) jpegs, no baseline optimized or progressive scan jpegs!

SWFBitmap has the following methods : swfbitmap->getwidth() and swfbitmap->getheight().

You can't import png images directly, though- have to use the png2dbl utility to make a dbl ("define bits lossless") file from the png. The reason for this is that I don't want a dependency on the png library in ming- autoconf should solve this, but that's not set up yet.

예 1. Import PNG files

<?php
  $s = new SWFShape();
  $f = $s->addFill(new SWFBitmap("png.dbl"));
  $s->setRightFill($f);

  $s->drawLine(32, 0);
  $s->drawLine(0, 32);
  $s->drawLine(-32, 0);
  $s->drawLine(0, -32);

  $m = new SWFMovie();
  $m->setDimension(32, 32);
  $m->add($s);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

And you can put an alpha mask on a jpeg fill.

예 2. swfbitmap() example

<?php

  $s = new SWFShape();

  // .msk file generated with "gif2mask" utility
  $f = $s->addFill(new SWFBitmap("alphafill.jpg", "alphafill.msk"));
  $s->setRightFill($f);

  $s->drawLine(640, 0);
  $s->drawLine(0, 480);
  $s->drawLine(-640, 0);
  $s->drawLine(0, -480);

  $c = new SWFShape();
  $c->setRightFill($c->addFill(0x99, 0x99, 0x99));
  $c->drawLine(40, 0);
  $c->drawLine(0, 40);
  $c->drawLine(-40, 0);
  $c->drawLine(0, -40);

  $m = new SWFMovie();
  $m->setDimension(640, 480);
  $m->setBackground(0xcc, 0xcc, 0xcc);

  // draw checkerboard background
  for ($y=0; $y<480; $y+=40) {
    for ($x=0; $x<640; $x+=80) {
      $i = $m->add($c);
      $i->moveTo($x, $y);
    }

    $y+=40;

    for ($x=40; $x<640; $x+=80) {
      $i = $m->add($c);
      $i->moveTo($x, $y);
    }
  }

  $m->add($s);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

이전 | 처음으로 | 다음
SWFBitmap->getWidth | 위로 | swfbutton_keypress


swfbutton_keypress

(PHP 4 >= 4.0.5)

swfbutton_keypress -- Returns the action flag for keyPress(char)

Description

int swfbutton_keypress ( string str)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
SWFBitmap | 위로 | SWFbutton->addAction


SWFbutton->addAction

(no version information, might be only in CVS)

SWFbutton->addAction -- Adds an action

Description

void swfbutton->addaction ( resource action, int flags)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfbutton->addaction() adds the action action to this button for the given conditions. The following flags are valid: SWFBUTTON_MOUSEOVER, SWFBUTTON_MOUSEOUT, SWFBUTTON_MOUSEUP, SWFBUTTON_MOUSEUPOUTSIDE, SWFBUTTON_MOUSEDOWN, SWFBUTTON_DRAGOUT and SWFBUTTON_DRAGOVER.

See also swfbutton->addshape() and swfaction().

이전 | 처음으로 | 다음
swfbutton_keypress | 위로 | SWFbutton->addShape


SWFbutton->addShape

(no version information, might be only in CVS)

SWFbutton->addShape -- Adds a shape to a button

Description

void swfbutton->addshape ( resource shape, int flags)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfbutton->addshape() adds the shape shape to this button. The following flags' values are valid: SWFBUTTON_UP, SWFBUTTON_OVER, SWFBUTTON_DOWN or SWFBUTTON_HIT. SWFBUTTON_HIT isn't ever displayed, it defines the hit region for the button. That is, everywhere the hit shape would be drawn is considered a "touchable" part of the button.

이전 | 처음으로 | 다음
SWFbutton->addAction | 위로 | SWFbutton->setAction


SWFbutton->setAction

(no version information, might be only in CVS)

SWFbutton->setAction -- Sets the action

Description

void swfbutton->setaction ( resource action)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfbutton->setaction() sets the action to be performed when the button is clicked. Alias for addAction(shape, SWFBUTTON_MOUSEUP). action is a swfaction().

See also swfbutton->addshape() and swfaction().

이전 | 처음으로 | 다음
SWFbutton->addShape | 위로 | SWFbutton->setdown


SWFbutton->setdown

(no version information, might be only in CVS)

SWFbutton->setdown -- Alias for addShape(shape, SWFBUTTON_DOWN)

Description

void swfbutton->setdown ( resource shape)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfbutton->setdown() alias for addShape(shape, SWFBUTTON_DOWN).

See also swfbutton->addshape() and swfaction().

이전 | 처음으로 | 다음
SWFbutton->setAction | 위로 | SWFbutton->setHit


SWFbutton->setHit

(no version information, might be only in CVS)

SWFbutton->setHit -- Alias for addShape(shape, SWFBUTTON_HIT)

Description

void swfbutton->sethit ( resource shape)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfbutton->sethit() alias for addShape(shape, SWFBUTTON_HIT).

See also swfbutton->addshape() and swfaction().

이전 | 처음으로 | 다음
SWFbutton->setdown | 위로 | SWFbutton->setOver


SWFbutton->setOver

(no version information, might be only in CVS)

SWFbutton->setOver -- Alias for addShape(shape, SWFBUTTON_OVER)

Description

void swfbutton->setover ( resource shape)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfbutton->setover() alias for addShape(shape, SWFBUTTON_OVER).

See also swfbutton->addshape() and swfaction().

이전 | 처음으로 | 다음
SWFbutton->setHit | 위로 | SWFbutton->setUp


SWFbutton->setUp

(no version information, might be only in CVS)

SWFbutton->setUp -- Alias for addShape(shape, SWFBUTTON_UP)

Description

void swfbutton->setup ( resource shape)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfbutton->setup() alias for addShape(shape, SWFBUTTON_UP).

See also swfbutton->addshape() and swfaction().

이전 | 처음으로 | 다음
SWFbutton->setOver | 위로 | SWFbutton


SWFbutton

(PHP 4 >= 4.0.5)

SWFbutton -- Creates a new Button.

Description

new swfbutton ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfbutton() creates a new Button. Roll over it, click it, see it call action code. Swank.

SWFButton has the following methods : swfbutton->addshape(),
swfbutton->setup(), swfbutton->setover()
swfbutton->setdown(), swfbutton->sethit()
swfbutton->setaction() and
swfbutton->addaction().

This simple example will show your usual interactions with buttons : rollover, rollon, mouseup, mousedown, noaction.

예 1. swfbutton() example

<?php

  $f = new SWFFont("_serif");

  $p = new SWFSprite();

  function label($string)
  {
    global $f;

    $t = new SWFTextField();
    $t->setFont($f);
    $t->addString($string);
    $t->setHeight(200);
    $t->setBounds(3200, 200);
    return $t;
  }

  function addLabel($string)
  {
    global $p;

    $i = $p->add(label($string));
    $p->nextFrame();
    $p->remove($i);
  }

  $p->add(new SWFAction("stop();"));
  addLabel("NO ACTION");
  addLabel("SWFBUTTON_MOUSEUP");
  addLabel("SWFBUTTON_MOUSEDOWN");
  addLabel("SWFBUTTON_MOUSEOVER");
  addLabel("SWFBUTTON_MOUSEOUT");
  addLabel("SWFBUTTON_MOUSEUPOUTSIDE");
  addLabel("SWFBUTTON_DRAGOVER");
  addLabel("SWFBUTTON_DRAGOUT");

  function rect($r, $g, $b)
  {
    $s = new SWFShape();
    $s->setRightFill($s->addFill($r, $g, $b));
    $s->drawLine(600, 0);
    $s->drawLine(0, 600);
    $s->drawLine(-600, 0);
    $s->drawLine(0, -600);

    return $s;
  }

  $b = new SWFButton();
  $b->addShape(rect(0xff, 0, 0), SWFBUTTON_UP | SWFBUTTON_HIT);
  $b->addShape(rect(0, 0xff, 0), SWFBUTTON_OVER);
  $b->addShape(rect(0, 0, 0xff), SWFBUTTON_DOWN);

  $b->addAction(new SWFAction("setTarget('/label'); gotoFrame(1);"),
            SWFBUTTON_MOUSEUP);

  $b->addAction(new SWFAction("setTarget('/label'); gotoFrame(2);"),
        SWFBUTTON_MOUSEDOWN);

  $b->addAction(new SWFAction("setTarget('/label'); gotoFrame(3);"),
        SWFBUTTON_MOUSEOVER);

  $b->addAction(new SWFAction("setTarget('/label'); gotoFrame(4);"),
        SWFBUTTON_MOUSEOUT);

  $b->addAction(new SWFAction("setTarget('/label'); gotoFrame(5);"),
        SWFBUTTON_MOUSEUPOUTSIDE);

  $b->addAction(new SWFAction("setTarget('/label'); gotoFrame(6);"),
        SWFBUTTON_DRAGOVER);

  $b->addAction(new SWFAction("setTarget('/label'); gotoFrame(7);"),
        SWFBUTTON_DRAGOUT);

  $m = new SWFMovie();
  $m->setDimension(4000, 3000);

  $i = $m->add($p);
  $i->setName("label");
  $i->moveTo(400, 1900);

  $i = $m->add($b);
  $i->moveTo(400, 900);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

This simple example will enables you to drag draw a big red button on the windows. No drag-and-drop, just moving around.

예 2. swfbutton->addaction() example

<?php

  $s = new SWFShape();
  $s->setRightFill($s->addFill(0xff, 0, 0));
  $s->drawLine(1000,0);
  $s->drawLine(0,1000);
  $s->drawLine(-1000,0);
  $s->drawLine(0,-1000);

  $b = new SWFButton();
  $b->addShape($s, SWFBUTTON_HIT | SWFBUTTON_UP | SWFBUTTON_DOWN | SWFBUTTON_OVER);

  $b->addAction(new SWFAction("startDrag('/test', 0);"), // '0' means don't lock to mouse
        SWFBUTTON_MOUSEDOWN);

  $b->addAction(new SWFAction("stopDrag();"),
        SWFBUTTON_MOUSEUP | SWFBUTTON_MOUSEUPOUTSIDE);

  $p = new SWFSprite();
  $p->add($b);
  $p->nextFrame();

  $m = new SWFMovie();
  $i = $m->add($p);
  $i->setName('test');
  $i->moveTo(1000,1000);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

이전 | 처음으로 | 다음
SWFbutton->setUp | 위로 | SWFDisplayItem->addColor


SWFDisplayItem->addColor

(no version information, might be only in CVS)

SWFDisplayItem->addColor -- Adds the given color to this item's color transform.

Description

void swfdisplayitem->addcolor ( [int red [, int green [, int blue [, int a]]]])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfdisplayitem->addcolor() adds the color to this item's color transform. The color is given in its RGB form.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

이전 | 처음으로 | 다음
SWFbutton | 위로 | SWFDisplayItem->move


SWFDisplayItem->move

(no version information, might be only in CVS)

SWFDisplayItem->move -- Moves object in relative coordinates.

Description

void swfdisplayitem->move ( int dx, int dy)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfdisplayitem->move() moves the current object by (dx,dy) from its current position.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also swfdisplayitem->moveto().

이전 | 처음으로 | 다음
SWFDisplayItem->addColor | 위로 | SWFDisplayItem->moveTo


SWFDisplayItem->moveTo

(no version information, might be only in CVS)

SWFDisplayItem->moveTo -- Moves object in global coordinates.

Description

void swfdisplayitem->moveto ( int x, int y)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfdisplayitem->moveto() moves the current object to (x,y) in global coordinates.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also swfdisplayitem->move().

이전 | 처음으로 | 다음
SWFDisplayItem->move | 위로 | SWFDisplayItem->multColor


SWFDisplayItem->multColor

(no version information, might be only in CVS)

SWFDisplayItem->multColor -- Multiplies the item's color transform.

Description

void swfdisplayitem->multcolor ( [int red [, int green [, int blue [, int a]]]])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfdisplayitem->multcolor() multiplies the item's color transform by the given values.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

This simple example will modify your picture's atmospher to Halloween (use a landscape or bright picture).

예 1. swfdisplayitem->multcolor() example

<?php

  $b = new SWFBitmap("backyard.jpg");
  // note use your own picture :-)
  $s = new SWFShape();
  $s->setRightFill($s->addFill($b));
  $s->drawLine($b->getWidth(), 0);
  $s->drawLine(0, $b->getHeight());
  $s->drawLine(-$b->getWidth(), 0);
  $s->drawLine(0, -$b->getHeight());

  $m = new SWFMovie();
  $m->setDimension($b->getWidth(), $b->getHeight());

  $i = $m->add($s);

  for ($n=0; $n<=20; ++$n) {
    $i->multColor(1.0-$n/10, 1.0, 1.0);
    $i->addColor(0xff*$n/20, 0, 0);
    $m->nextFrame();
  }

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

이전 | 처음으로 | 다음
SWFDisplayItem->moveTo | 위로 | SWFDisplayItem->remove


SWFDisplayItem->remove

(no version information, might be only in CVS)

SWFDisplayItem->remove -- Removes the object from the movie

Description

void swfdisplayitem->remove ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfdisplayitem->remove() removes this object from the movie's display list.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also swfmovie->add().

이전 | 처음으로 | 다음
SWFDisplayItem->multColor | 위로 | SWFDisplayItem->Rotate


SWFDisplayItem->Rotate

(no version information, might be only in CVS)

SWFDisplayItem->Rotate -- Rotates in relative coordinates.

Description

void swfdisplayitem->rotate ( float ddegrees)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfdisplayitem->rotate() rotates the current object by ddegrees degrees from its current rotation.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also swfdisplayitem->rotateto().

이전 | 처음으로 | 다음
SWFDisplayItem->remove | 위로 | SWFDisplayItem->rotateTo


SWFDisplayItem->rotateTo

(no version information, might be only in CVS)

SWFDisplayItem->rotateTo -- Rotates the object in global coordinates.

Description

void swfdisplayitem->rotateto ( float degrees)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfdisplayitem->rotateto() set the current object rotation to degrees degrees in global coordinates.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

This example bring three rotating string from the background to the foreground. Pretty nice.

예 1. swfdisplayitem->rotateto() example

<?php
  $thetext =  "ming!";

  $f = new SWFFont("Bauhaus 93.fdb");

  $m = new SWFMovie();
  $m->setRate(24.0);
  $m->setDimension(2400, 1600);
  $m->setBackground(0xff, 0xff, 0xff);

  // functions with huge numbers of arbitrary
  // arguments are always a good idea!  Really!

  function text($r, $g, $b, $a, $rot, $x, $y, $scale, $string)
  {
    global $f, $m;

    $t = new SWFText();
    $t->setFont($f);
    $t->setColor($r, $g, $b, $a);
    $t->setHeight(960);
    $t->moveTo(-($f->getWidth($string))/2, $f->getAscent()/2);
    $t->addString($string);

    // we can add properties just like a normal PHP var,
    // as long as the names aren't already used.
    // e.g., we can't set $i->scale, because that's a function

    $i = $m->add($t);
    $i->x = $x;
    $i->y = $y;
    $i->rot = $rot;
    $i->s = $scale;
    $i->rotateTo($rot);
    $i->scale($scale, $scale);

    // but the changes are local to the function, so we have to
    // return the changed object.  kinda weird..

    return $i;
}

  function step($i)
  {
    $oldrot = $i->rot;
    $i->rot = 19*$i->rot/20;
    $i->x = (19*$i->x + 1200)/20;
    $i->y = (19*$i->y + 800)/20;
    $i->s = (19*$i->s + 1.0)/20;

    $i->rotateTo($i->rot);
    $i->scaleTo($i->s, $i->s);
    $i->moveTo($i->x, $i->y);

    return $i;
  }

  // see?  it sure paid off in legibility:

  $i1 = text(0xff, 0x33, 0x33, 0xff, 900, 1200, 800, 0.03, $thetext);
  $i2 = text(0x00, 0x33, 0xff, 0x7f, -560, 1200, 800, 0.04, $thetext);
  $i3 = text(0xff, 0xff, 0xff, 0x9f, 180, 1200, 800, 0.001, $thetext);

  for ($i=1; $i<=100; ++$i) {
    $i1 = step($i1);
    $i2 = step($i2);
    $i3 = step($i3);

    $m->nextFrame();
  }

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

See also swfdisplayitem->rotate().

이전 | 처음으로 | 다음
SWFDisplayItem->Rotate | 위로 | SWFDisplayItem->scale


SWFDisplayItem->scale

(no version information, might be only in CVS)

SWFDisplayItem->scale -- Scales the object in relative coordinates.

Description

void swfdisplayitem->scale ( int dx, int dy)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfdisplayitem->scale() scales the current object by (dx,dy) from its current size.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also swfdisplayitem->scaleto().

이전 | 처음으로 | 다음
SWFDisplayItem->rotateTo | 위로 | SWFDisplayItem->scaleTo


SWFDisplayItem->scaleTo

(no version information, might be only in CVS)

SWFDisplayItem->scaleTo -- Scales the object in global coordinates.

Description

void swfdisplayitem->scaleto ( int x, int y)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfdisplayitem->scaleto() scales the current object to (x,y) in global coordinates.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also swfdisplayitem->scale().

이전 | 처음으로 | 다음
SWFDisplayItem->scale | 위로 | SWFDisplayItem->setDepth


SWFDisplayItem->setDepth

(no version information, might be only in CVS)

SWFDisplayItem->setDepth -- Sets z-order

Description

void swfdisplayitem->setdepth ( float depth)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfdisplayitem->rotate() sets the object's z-order to depth. Depth defaults to the order in which instances are created (by adding a shape/text to a movie)- newer ones are on top of older ones. If two objects are given the same depth, only the later-defined one can be moved.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

이전 | 처음으로 | 다음
SWFDisplayItem->scaleTo | 위로 | SWFDisplayItem->setName


SWFDisplayItem->setName

(no version information, might be only in CVS)

SWFDisplayItem->setName -- Sets the object's name

Description

void swfdisplayitem->setname ( string name)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfdisplayitem->setname() sets the object's name to name, for targetting with action script. Only useful on sprites.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

이전 | 처음으로 | 다음
SWFDisplayItem->setDepth | 위로 | SWFDisplayItem->setRatio


SWFDisplayItem->setRatio

(no version information, might be only in CVS)

SWFDisplayItem->setRatio -- Sets the object's ratio.

Description

void swfdisplayitem->setratio ( float ratio)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfdisplayitem->setratio() sets the object's ratio to ratio. Obviously only useful for morphs.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

This simple example will morph nicely three concentric circles.

예 1. swfdisplayitem->setname() example

<?php

  $p = new SWFMorph();

  $g = new SWFGradient();
  $g->addEntry(0.0, 0, 0, 0);
  $g->addEntry(0.16, 0xff, 0xff, 0xff);
  $g->addEntry(0.32, 0, 0, 0);
  $g->addEntry(0.48, 0xff, 0xff, 0xff);
  $g->addEntry(0.64, 0, 0, 0);
  $g->addEntry(0.80, 0xff, 0xff, 0xff);
  $g->addEntry(1.00, 0, 0, 0);

  $s = $p->getShape1();
  $f = $s->addFill($g, SWFFILL_RADIAL_GRADIENT);
  $f->scaleTo(0.05);
  $s->setLeftFill($f);
  $s->movePenTo(-160, -120);
  $s->drawLine(320, 0);
  $s->drawLine(0, 240);
  $s->drawLine(-320, 0);
  $s->drawLine(0, -240);

  $g = new SWFGradient();
  $g->addEntry(0.0, 0, 0, 0);
  $g->addEntry(0.16, 0xff, 0, 0);
  $g->addEntry(0.32, 0, 0, 0);
  $g->addEntry(0.48, 0, 0xff, 0);
  $g->addEntry(0.64, 0, 0, 0);
  $g->addEntry(0.80, 0, 0, 0xff);
  $g->addEntry(1.00, 0, 0, 0);

  $s = $p->getShape2();
  $f = $s->addFill($g, SWFFILL_RADIAL_GRADIENT);
  $f->scaleTo(0.05);
  $f->skewXTo(1.0);
  $s->setLeftFill($f);
  $s->movePenTo(-160, -120);
  $s->drawLine(320, 0);
  $s->drawLine(0, 240);
  $s->drawLine(-320, 0);
  $s->drawLine(0, -240);

  $m = new SWFMovie();
  $m->setDimension(320, 240);
  $i = $m->add($p);
  $i->moveTo(160, 120);

  for ($n=0; $n<=1.001; $n+=0.01) {
    $i->setRatio($n);
    $m->nextFrame();
  }

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

이전 | 처음으로 | 다음
SWFDisplayItem->setName | 위로 | SWFDisplayItem->skewX


SWFDisplayItem->skewX

(no version information, might be only in CVS)

SWFDisplayItem->skewX -- Sets the X-skew.

Description

void swfdisplayitem->skewx ( float ddegrees)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfdisplayitem->skewx() adds ddegrees to current x-skew.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also
swfdisplayitem->skewx(),
swfdisplayitem->skewy() and
swfdisplayitem->skewyto().

이전 | 처음으로 | 다음
SWFDisplayItem->setRatio | 위로 | SWFDisplayItem->skewXTo


SWFDisplayItem->skewXTo

(no version information, might be only in CVS)

SWFDisplayItem->skewXTo -- Sets the X-skew.

Description

void swfdisplayitem->skewxto ( float degrees)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfdisplayitem->skewxto() sets the x-skew to degrees. For degrees is 1.0, it means a 45-degree forward slant. More is more forward, less is more backward.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also
swfdisplayitem->skewx(),
swfdisplayitem->skewy() and
swfdisplayitem->skewyto().

이전 | 처음으로 | 다음
SWFDisplayItem->skewX | 위로 | SWFDisplayItem->skewY


SWFDisplayItem->skewY

(no version information, might be only in CVS)

SWFDisplayItem->skewY -- Sets the Y-skew.

Description

void swfdisplayitem->skewy ( float ddegrees)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfdisplayitem->skewy() adds ddegrees to current y-skew.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also
swfdisplayitem->skewyto(),
swfdisplayitem->skewx() and
swfdisplayitem->skewxto().

이전 | 처음으로 | 다음
SWFDisplayItem->skewXTo | 위로 | SWFDisplayItem->skewYTo


SWFDisplayItem->skewYTo

(no version information, might be only in CVS)

SWFDisplayItem->skewYTo -- Sets the Y-skew.

Description

void swfdisplayitem->skewyto ( float degrees)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfdisplayitem->skewyto() sets the y-skew to degrees. For degrees is 1.0, it means a 45-degree forward slant. More is more upward, less is more downward.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also
swfdisplayitem->skewy(),
swfdisplayitem->skewx() and
swfdisplayitem->skewxto().

이전 | 처음으로 | 다음
SWFDisplayItem->skewY | 위로 | SWFDisplayItem


SWFDisplayItem

(no version information, might be only in CVS)

SWFDisplayItem -- Creates a new displayitem object.

Description

new swfdisplayitem ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfdisplayitem() creates a new swfdisplayitem object.

Here's where all the animation takes place. After you define a shape, a text object, a sprite, or a button, you add it to the movie, then use the returned handle to move, rotate, scale, or skew the thing.

SWFDisplayItem has the following methods : swfdisplayitem->move(),
swfdisplayitem->moveto(), swfdisplayitem->scaleto(),
swfdisplayitem->scale(), swfdisplayitem->rotate(),
swfdisplayitem->rotateto(), swfdisplayitem->skewxto(),
swfdisplayitem->skewx(), swfdisplayitem->skewyto()
swfdisplayitem->skewyto(), swfdisplayitem->setdepth()
swfdisplayitem->remove(), swfdisplayitem->setname()
swfdisplayitem->setratio(), swfdisplayitem->addcolor()
and swfdisplayitem->multcolor().

이전 | 처음으로 | 다음
SWFDisplayItem->skewYTo | 위로 | SWFFill->moveTo


SWFFill->moveTo

(no version information, might be only in CVS)

SWFFill->moveTo -- Moves fill origin

Description

void swffill->moveto ( int x, int y)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swffill->moveto() moves fill's origin to (x,y) in global coordinates.

이전 | 처음으로 | 다음
SWFDisplayItem | 위로 | SWFFill->rotateTo


SWFFill->rotateTo

(no version information, might be only in CVS)

SWFFill->rotateTo -- Sets fill's rotation

Description

void swffill->rotateto ( float degrees)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swffill->rotateto() sets fill's rotation to degrees degrees.

이전 | 처음으로 | 다음
SWFFill->moveTo | 위로 | SWFFill->scaleTo


SWFFill->scaleTo

(no version information, might be only in CVS)

SWFFill->scaleTo -- Sets fill's scale

Description

void swffill->scaleto ( int x, int y)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swffill->scaleto() sets fill's scale to x in the x-direction, y in the y-direction.

이전 | 처음으로 | 다음
SWFFill->rotateTo | 위로 | SWFFill->skewXTo


SWFFill->skewXTo

(no version information, might be only in CVS)

SWFFill->skewXTo -- Sets fill x-skew

Description

void swffill->skewxto ( float x)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swffill->skewxto() sets fill x-skew to x. For x is 1.0, it is a 45-degree forward slant. More is more forward, less is more backward.

이전 | 처음으로 | 다음
SWFFill->scaleTo | 위로 | SWFFill->skewYTo


SWFFill->skewYTo

(no version information, might be only in CVS)

SWFFill->skewYTo -- Sets fill y-skew

Description

void swffill->skewyto ( float y)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swffill->skewyto() sets fill y-skew to y. For y is 1.0, it is a 45-degree upward slant. More is more upward, less is more downward.

이전 | 처음으로 | 다음
SWFFill->skewXTo | 위로 | SWFFill


SWFFill

(PHP 4 >= 4.0.5)

SWFFill -- Loads SWFFill object

Description

new SWFFill ( void )

The swffill() object allows you to transform (scale, skew, rotate) bitmap and gradient fills. swffill() objects are created by the swfshape->addfill() methods.

SWFFill has the following methods : swffill->moveto() and swffill->scaleto(), swffill->rotateto(), swffill->skewxto() and swffill->skewyto().

이전 | 처음으로 | 다음
SWFFill->skewYTo | 위로 | swffont->getwidth


swffont->getwidth

(no version information, might be only in CVS)

swffont->getwidth -- Returns the string's width

Description

int swffont->getwidth ( string string)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swffont->getwidth() returns the string string's width, using font's default scaling. You'll probably want to use the swftext() version of this method which uses the text object's scale.

이전 | 처음으로 | 다음
SWFFill | 위로 | SWFFont


SWFFont

(PHP 4 >= 4.0.5)

SWFFont -- Loads a font definition

Description

new swffont ( string filename)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

If filename is the name of an FDB file (i.e., it ends in ".fdb"), load the font definition found in said file. Otherwise, create a browser-defined font reference.

FDB ("font definition block") is a very simple wrapper for the SWF DefineFont2 block which contains a full description of a font. One may create FDB files from SWT Generator template files with the included makefdb utility- look in the util directory off the main ming distribution directory.

Browser-defined fonts don't contain any information about the font other than its name. It is assumed that the font definition will be provided by the movie player. The fonts _serif, _sans, and _typewriter should always be available. For example:
<?php
$f = newSWFFont("_sans");
?>
will give you the standard sans-serif font, probably the same as what you'd get with <font name="sans-serif"> in HTML.

swffont() returns a reference to the font definition, for use in the swftext->setfont() and the swftextfield->setfont() methods.

SWFFont has the following methods : swffont->getwidth().

이전 | 처음으로 | 다음
swffont->getwidth | 위로 | SWFGradient->addEntry


SWFGradient->addEntry

(no version information, might be only in CVS)

SWFGradient->addEntry -- Adds an entry to the gradient list.

Description

void swfgradient->addentry ( float ratio, int red, int green, int blue [, int a])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfgradient->addentry() adds an entry to the gradient list. ratio is a number between 0 and 1 indicating where in the gradient this color appears. Thou shalt add entries in order of increasing ratio.

red, green, blue is a color (RGB mode). Last parameter a is optional.

이전 | 처음으로 | 다음
SWFFont | 위로 | SWFGradient


SWFGradient

(PHP 4 >= 4.0.5)

SWFGradient -- Creates a gradient object

Description

new swfgradient ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfgradient() creates a new SWFGradient object.

After you've added the entries to your gradient, you can use the gradient in a shape fill with the swfshape->addfill() method.

SWFGradient has the following methods : swfgradient->addentry().

This simple example will draw a big black-to-white gradient as background, and a reddish disc in its center.

예 1. swfgradient() example

<?php

  $m = new SWFMovie();
  $m->setDimension(320, 240);

  $s = new SWFShape();

  // first gradient- black to white
  $g = new SWFGradient();
  $g->addEntry(0.0, 0, 0, 0);
  $g->addEntry(1.0, 0xff, 0xff, 0xff);

  $f = $s->addFill($g, SWFFILL_LINEAR_GRADIENT);
  $f->scaleTo(0.01);
  $f->moveTo(160, 120);
  $s->setRightFill($f);
  $s->drawLine(320, 0);
  $s->drawLine(0, 240);
  $s->drawLine(-320, 0);
  $s->drawLine(0, -240);

  $m->add($s);

  $s = new SWFShape();

  // second gradient- radial gradient from red to transparent
  $g = new SWFGradient();
  $g->addEntry(0.0, 0xff, 0, 0, 0xff);
  $g->addEntry(1.0, 0xff, 0, 0, 0);

  $f = $s->addFill($g, SWFFILL_RADIAL_GRADIENT);
  $f->scaleTo(0.005);
  $f->moveTo(160, 120);
  $s->setRightFill($f);
  $s->drawLine(320, 0);
  $s->drawLine(0, 240);
  $s->drawLine(-320, 0);
  $s->drawLine(0, -240);

  $m->add($s);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

이전 | 처음으로 | 다음
SWFGradient->addEntry | 위로 | SWFMorph->getshape1


SWFMorph->getshape1

(no version information, might be only in CVS)

SWFMorph->getshape1 -- Gets a handle to the starting shape

Description

mixed swfmorph->getshape1 ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfmorph->getshape1() gets a handle to the morph's starting shape. swfmorph->getshape1() returns an swfshape() object.

이전 | 처음으로 | 다음
SWFGradient | 위로 | SWFMorph->getshape2


SWFMorph->getshape2

(no version information, might be only in CVS)

SWFMorph->getshape2 -- Gets a handle to the ending shape

Description

mixed swfmorph->getshape2 ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfmorph->getshape2() gets a handle to the morph's ending shape. swfmorph->getshape2() returns an swfshape() object.

이전 | 처음으로 | 다음
SWFMorph->getshape1 | 위로 | SWFMorph


SWFMorph

(PHP 4 >= 4.0.5)

SWFMorph -- Creates a new SWFMorph object.

Description

new swfmorph ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfmorph() creates a new SWFMorph object.

Also called a "shape tween". This thing lets you make those tacky twisting things that make your computer choke. Oh, joy!

The methods here are sort of weird. It would make more sense to just have newSWFMorph(shape1, shape2);, but as things are now, shape2 needs to know that it's the second part of a morph. (This, because it starts writing its output as soon as it gets drawing commands- if it kept its own description of its shapes and wrote on completion this and some other things would be much easier.)

SWFMorph has the following methods : swfmorph->getshape1() and swfmorph->getshape1().

This simple example will morph a big red square into a smaller blue black-bordered square.

예 1. swfmorph() example

<?php
  $p = new SWFMorph();

  $s = $p->getShape1();
  $s->setLine(0, 0, 0, 0);

  /* Note that this is backwards from normal shapes (left instead of right).
     I have no idea why, but this seems to work.. */

  $s->setLeftFill($s->addFill(0xff, 0, 0));
  $s->movePenTo(-1000,-1000);
  $s->drawLine(2000,0);
  $s->drawLine(0,2000);
  $s->drawLine(-2000,0);
  $s->drawLine(0,-2000);

  $s = $p->getShape2();
  $s->setLine(60,0,0,0);
  $s->setLeftFill($s->addFill(0, 0, 0xff));
  $s->movePenTo(0,-1000);
  $s->drawLine(1000,1000);
  $s->drawLine(-1000,1000);
  $s->drawLine(-1000,-1000);
  $s->drawLine(1000,-1000);

  $m = new SWFMovie();
  $m->setDimension(3000,2000);
  $m->setBackground(0xff, 0xff, 0xff);

  $i = $m->add($p);
  $i->moveTo(1500,1000);

  for ($r=0.0; $r<=1.0; $r+=0.1) {
    $i->setRatio($r);
    $m->nextFrame();
  }

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

이전 | 처음으로 | 다음
SWFMorph->getshape2 | 위로 | SWFMovie->add


SWFMovie->add

(no version information, might be only in CVS)

SWFMovie->add -- Adds any type of data to a movie.

Description

void swfmovie->add ( resource instance)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfmovie->add() adds instance to the current movie. instance is any type of data : Shapes, text, fonts, etc. must all be added to the movie to make this work.

For displayable types (shape, text, button, sprite), this returns an swfdisplayitem(), a handle to the object in a display list. Thus, you can add the same shape to a movie multiple times and get separate handles back for each separate instance.

See also all other objects (adding this later), and swfmovie->remove()

See examples in : swfdisplayitem->rotateto() and swfshape->addfill().

이전 | 처음으로 | 다음
SWFMorph | 위로 | SWFMovie->nextframe


SWFMovie->nextframe

(no version information, might be only in CVS)

SWFMovie->nextframe -- Moves to the next frame of the animation.

Description

void swfmovie->nextframe ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfmovie->nextframe() moves to the next frame of the animation.

이전 | 처음으로 | 다음
SWFMovie->add | 위로 | SWFMovie->output


SWFMovie->output

(no version information, might be only in CVS)

SWFMovie->output -- Dumps your lovingly prepared movie out.

Description

void swfmovie->output ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfmovie->output() dumps your lovingly prepared movie out. In PHP, preceding this with the command
<?php
header('Content-type: application/x-shockwave-flash');
?>
convinces the browser to display this as a flash movie.

See also swfmovie->save().

See examples in :
swfmovie->streammp3(),
swfdisplayitem->rotateto(),
swfaction()...
Any example will use this method.

이전 | 처음으로 | 다음
SWFMovie->nextframe | 위로 | swfmovie->remove


swfmovie->remove

(no version information, might be only in CVS)

swfmovie->remove -- Removes the object instance from the display list.

Description

void swfmovie->remove ( resource instance)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfmovie->remove() removes the object instance instance from the display list.

See also swfmovie->add().

이전 | 처음으로 | 다음
SWFMovie->output | 위로 | SWFMovie->save


SWFMovie->save

(no version information, might be only in CVS)

SWFMovie->save -- Saves your movie in a file.

Description

void swfmovie->save ( string filename)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfmovie->save() saves your movie to the file named filename.

See also output().

이전 | 처음으로 | 다음
swfmovie->remove | 위로 | SWFMovie->setbackground


SWFMovie->setbackground

(no version information, might be only in CVS)

SWFMovie->setbackground -- Sets the background color.

Description

void swfmovie->setbackground ( int red, int green, int blue)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfmovie->setbackground() sets the background color. Why is there no rgba version? Think about it. (Actually, that's not such a dumb question after all- you might want to let the HTML background show through. There's a way to do that, but it only works on IE4. Search the http://www.macromedia.com/ site for details.)

이전 | 처음으로 | 다음
SWFMovie->save | 위로 | SWFMovie->setdimension


SWFMovie->setdimension

(no version information, might be only in CVS)

SWFMovie->setdimension -- Sets the movie's width and height.

Description

void swfmovie->setdimension ( int width, int height)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfmovie->setdimension() sets the movie's width to width and height to height.

이전 | 처음으로 | 다음
SWFMovie->setbackground | 위로 | SWFMovie->setframes


SWFMovie->setframes

(no version information, might be only in CVS)

SWFMovie->setframes -- Sets the total number of frames in the animation.

Description

void swfmovie->setframes ( string numberofframes)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfmovie->setframes() sets the total number of frames in the animation to numberofframes.

이전 | 처음으로 | 다음
SWFMovie->setdimension | 위로 | SWFMovie->setrate


SWFMovie->setrate

(no version information, might be only in CVS)

SWFMovie->setrate -- Sets the animation's frame rate.

Description

void swfmovie->setrate ( int rate)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfmovie->setrate() sets the frame rate to rate, in frame per seconds. Animation will slow down if the player can't render frames fast enough- unless there's a streaming sound, in which case display frames are sacrificed to keep sound from skipping.

이전 | 처음으로 | 다음
SWFMovie->setframes | 위로 | SWFMovie->streammp3


SWFMovie->streammp3

(no version information, might be only in CVS)

SWFMovie->streammp3 -- Streams a MP3 file.

Description

void swfmovie->streammp3 ( string mp3FileName)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfmovie->streammp3() streams the mp3 file mp3FileName. Not very robust in dealing with oddities (can skip over an initial ID3 tag, but that's about it). Like swfshape->addjpegfill(), this isn't a stable function- we'll probably need to make a separate SWFSound object to contain sound types.

Note that the movie isn't smart enough to put enough frames in to contain the entire mp3 stream- you'll have to add (length of song * frames per second) frames to get the entire stream in.

Yes, now you can use ming to put that rock and roll devil worship music into your SWF files. Just don't tell the RIAA.

예 1. swfmovie->streammp3() example

<?php
  $m = new SWFMovie();
  $m->setRate(12.0);
  $m->streamMp3("distortobass.mp3");
  // use your own MP3

  // 11.85 seconds at 12.0 fps = 142 frames
  $m->setFrames(142);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

이전 | 처음으로 | 다음
SWFMovie->setrate | 위로 | SWFMovie


SWFMovie

(PHP 4 >= 4.0.5)

SWFMovie -- Creates a new movie object, representing an SWF version 4 movie.

Description

new swfmovie ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfmovie() creates a new movie object, representing an SWF version 4 movie.

SWFMovie has the following methods :
swfmovie->output(),swfmovie->save(),
swfmovie->add(), swfmovie->remove(),
swfmovie->nextframe(), swfmovie->setbackground(),
swfmovie->setrate(), swfmovie->setdimension(),
swfmovie->setframes() and swfmovie->streammp3().

See examples in : swfdisplayitem->rotateto(), swfshape->setline(), swfshape->addfill()... Any example will use this object.

이전 | 처음으로 | 다음
SWFMovie->streammp3 | 위로 | SWFShape->addFill


SWFShape->addFill

(no version information, might be only in CVS)

SWFShape->addFill -- Adds a solid fill to the shape.

Description

void swfshape->addfill ( int red, int green, int blue [, int a])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

void swfshape->addfill ( SWFbitmap bitmap [, int flags])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

void swfshape->addfill ( SWFGradient gradient [, int flags])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfshape->addfill() adds a solid fill to the shape's list of fill styles. swfshape->addfill() accepts three different types of arguments.

red, green, blue is a color (RGB mode). Last parameter a is optional.

The bitmap argument is an swfbitmap() object. The flags argument can be one of the following values : SWFFILL_CLIPPED_BITMAP or SWFFILL_TILED_BITMAP. Default is SWFFILL_TILED_BITMAP. I think.

The gradient argument is an swfgradient() object. The flags argument can be one of the following values : SWFFILL_RADIAL_GRADIENT or SWFFILL_LINEAR_GRADIENT. Default is SWFFILL_LINEAR_GRADIENT. I'm sure about this one. Really.

swfshape->addfill() returns an swffill()
object for use with the swfshape->setleftfill()
and swfshape->setrightfill() functions
described below.

See also swfshape->setleftfill() and swfshape->setrightfill().

This simple example will draw a frame on a bitmap. Ah, here's another buglet in the flash player- it doesn't seem to care about the second shape's bitmap's transformation in a morph. According to spec, the bitmap should stretch along with the shape in this example..

예 1. swfshape->addfill() example

<?php

  $p = new SWFMorph();

  $b = new SWFBitmap("alphafill.jpg");
  // use your own bitmap
  $width = $b->getWidth();
  $height = $b->getHeight();

  $s = $p->getShape1();
  $f = $s->addFill($b, SWFFILL_TILED_BITMAP);
  $f->moveTo(-$width/2, -$height/4);
  $f->scaleTo(1.0, 0.5);
  $s->setLeftFill($f);
  $s->movePenTo(-$width/2, -$height/4);
  $s->drawLine($width, 0);
  $s->drawLine(0, $height/2);
  $s->drawLine(-$width, 0);
  $s->drawLine(0, -$height/2);

  $s = $p->getShape2();
  $f = $s->addFill($b, SWFFILL_TILED_BITMAP);

  // these two have no effect!
  $f->moveTo(-$width/4, -$height/2);
  $f->scaleTo(0.5, 1.0);

  $s->setLeftFill($f);
  $s->movePenTo(-$width/4, -$height/2);
  $s->drawLine($width/2, 0);
  $s->drawLine(0, $height);
  $s->drawLine(-$width/2, 0);
  $s->drawLine(0, -$height);

  $m = new SWFMovie();
  $m->setDimension($width, $height);
  $i = $m->add($p);
  $i->moveTo($width/2, $height/2);

  for ($n=0; $n<1.001; $n+=0.03) {
    $i->setRatio($n);
    $m->nextFrame();
  }

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

이전 | 처음으로 | 다음
SWFMovie | 위로 | SWFShape->drawCurve


SWFShape->drawCurve

(no version information, might be only in CVS)

SWFShape->drawCurve -- Draws a curve (relative).

Description

void swfshape->drawcurve ( int controldx, int controldy, int anchordx, int anchordy)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfshape->drawcurve() draws a quadratic curve (using the current line style,set by swfshape->setline()) from the current pen position to the relative position (anchorx,anchory) using relative control point (controlx,controly). That is, head towards the control point, then smoothly turn to the anchor point.

See also
swfshape->drawlineto(),
swfshape->drawline(),
swfshape->movepento() and
swfshape->movepen().

이전 | 처음으로 | 다음
SWFShape->addFill | 위로 | SWFShape->drawCurveTo


SWFShape->drawCurveTo

(no version information, might be only in CVS)

SWFShape->drawCurveTo -- Draws a curve.

Description

void swfshape->drawcurveto ( int controlx, int controly, int anchorx, int anchory)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfshape->drawcurveto() draws a quadratic curve (using the current line style, set by swfshape->setline()) from the current pen position to (anchorx,anchory) using (controlx,controly) as a control point. That is, head towards the control point, then smoothly turn to the anchor point.

See also
swfshape->drawlineto(),
swfshape->drawline(),
swfshape->movepento() and
swfshape->movepen().

이전 | 처음으로 | 다음
SWFShape->drawCurve | 위로 | SWFShape->drawLine


SWFShape->drawLine

(no version information, might be only in CVS)

SWFShape->drawLine -- Draws a line (relative).

Description

void swfshape->drawline ( int dx, int dy)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfshape->drawline() draws a line (using the current line style set by swfshape->setline()) from the current pen position to displacement (dx,dy).

See also
swfshape->movepento(),
swfshape->drawcurveto(),
swfshape->movepen() and
swfshape->drawlineto().

이전 | 처음으로 | 다음
SWFShape->drawCurveTo | 위로 | SWFShape->drawLineTo


SWFShape->drawLineTo

(no version information, might be only in CVS)

SWFShape->drawLineTo -- Draws a line.

Description

void swfshape->drawlineto ( int x, int y)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfshape->setrightfill() draws a line (using the current line style, set by swfshape->setline()) from the current pen position to point (x,y) in the shape's coordinate space.

See also
swfshape->movepento(),
swfshape->drawcurveto(),
swfshape->movepen() and
swfshape->drawline().

이전 | 처음으로 | 다음
SWFShape->drawLine | 위로 | SWFShape->movePen


SWFShape->movePen

(no version information, might be only in CVS)

SWFShape->movePen -- Moves the shape's pen (relative).

Description

void swfshape->movepen ( int dx, int dy)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfshape->setrightfill() move the shape's pen from coordinates (current x,current y) to (current x + dx, current y + dy) in the shape's coordinate space.

See also
swfshape->movepento(),
swfshape->drawcurveto(),
swfshape->drawlineto() and
swfshape->drawline().

이전 | 처음으로 | 다음
SWFShape->drawLineTo | 위로 | SWFShape->movePenTo


SWFShape->movePenTo

(no version information, might be only in CVS)

SWFShape->movePenTo -- Moves the shape's pen.

Description

void swfshape->movepento ( int x, int y)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfshape->setrightfill() move the shape's pen to (x,y) in the shape's coordinate space.

See also
swfshape->movepen(),
swfshape->drawcurveto(),
swfshape->drawlineto() and
swfshape->drawline().

이전 | 처음으로 | 다음
SWFShape->movePen | 위로 | SWFShape->setLeftFill


SWFShape->setLeftFill

(no version information, might be only in CVS)

SWFShape->setLeftFill -- Sets left rasterizing color.

Description

void swfshape->setleftfill ( swfgradient fill)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

void swfshape->setleftfill ( int red, int green, int blue [, int a])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

What this nonsense is about is, every edge segment borders at most two fills. When rasterizing the object, it's pretty handy to know what those fills are ahead of time, so the swf format requires these to be specified.

swfshape->setleftfill() sets the fill on the left side of the edge- that is, on the interior if you're defining the outline of the shape in a counter-clockwise fashion. The fill object is an SWFFill object returned from one of the addFill functions above.

This seems to be reversed when you're defining a shape in a morph, though. If your browser crashes, just try setting the fill on the other side.

Shortcut for swfshape->setleftfill($s->addfill($r, $g, $b [, $a]));.

See also swfshape->setrightfill().

이전 | 처음으로 | 다음
SWFShape->movePenTo | 위로 | SWFShape->setLine


SWFShape->setLine

(no version information, might be only in CVS)

SWFShape->setLine -- Sets the shape's line style.

Description

void swfshape->setline ( int width [, int red [, int green [, int blue [, int a]]]])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfshape->setline() sets the shape's line style. width is the line's width. If width is 0, the line's style is removed (then, all other arguments are ignored). If width > 0, then line's color is set to red, green, blue. Last parameter a is optional.

swfshape->setline() accepts 1, 4 or 5 arguments (not 3 or 2).

You must declare all line styles before you use them (see example).

This simple example will draw a big "!#%*@", in funny colors and gracious style.

예 1. swfshape->setline() example

<?php
  $s = new SWFShape();
  $f1 = $s->addFill(0xff, 0, 0);
  $f2 = $s->addFill(0xff, 0x7f, 0);
  $f3 = $s->addFill(0xff, 0xff, 0);
  $f4 = $s->addFill(0, 0xff, 0);
  $f5 = $s->addFill(0, 0, 0xff);

  // bug: have to declare all line styles before you use them
  $s->setLine(40, 0x7f, 0, 0);
  $s->setLine(40, 0x7f, 0x3f, 0);
  $s->setLine(40, 0x7f, 0x7f, 0);
  $s->setLine(40, 0, 0x7f, 0);
  $s->setLine(40, 0, 0, 0x7f);

  $f = new SWFFont('Techno.fdb');

  $s->setRightFill($f1);
  $s->setLine(40, 0x7f, 0, 0);
  $s->drawGlyph($f, '!');
  $s->movePen($f->getWidth('!'), 0);

  $s->setRightFill($f2);
  $s->setLine(40, 0x7f, 0x3f, 0);
  $s->drawGlyph($f, '#');
  $s->movePen($f->getWidth('#'), 0);

  $s->setRightFill($f3);
  $s->setLine(40, 0x7f, 0x7f, 0);
  $s->drawGlyph($f, '%');
  $s->movePen($f->getWidth('%'), 0);

  $s->setRightFill($f4);
  $s->setLine(40, 0, 0x7f, 0);
  $s->drawGlyph($f, '*');
  $s->movePen($f->getWidth('*'), 0);

  $s->setRightFill($f5);
  $s->setLine(40, 0, 0, 0x7f);
  $s->drawGlyph($f, '@');

  $m = new SWFMovie();
  $m->setDimension(3000,2000);
  $m->setRate(12.0);
  $i = $m->add($s);
  $i->moveTo(1500-$f->getWidth("!#%*@")/2, 1000+$f->getAscent()/2);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

이전 | 처음으로 | 다음
SWFShape->setLeftFill | 위로 | SWFShape->setRightFill


SWFShape->setRightFill

(no version information, might be only in CVS)

SWFShape->setRightFill -- Sets right rasterizing color.

Description

void swfshape->setrightfill ( swfgradient fill)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

void swfshape->setrightfill ( int red, int green, int blue [, int a])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

See also swfshape->setleftfill().

Shortcut for swfshape->setrightfill($s->addfill($r, $g, $b [, $a]));.

이전 | 처음으로 | 다음
SWFShape->setLine | 위로 | SWFShape


SWFShape

(PHP 4 >= 4.0.5)

SWFShape -- Creates a new shape object.

Description

new swfshape ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfshape() creates a new shape object.

SWFShape has the following methods : swfshape->setline(),
swfshape->addfill(), swfshape->setleftfill(),
swfshape->setrightfill(), swfshape->movepento(),
swfshape->movepen(), swfshape->drawlineto(),
swfshape->drawline(), swfshape->drawcurveto()
and swfshape->drawcurve().

This simple example will draw a big red elliptic quadrant.

예 1. swfshape() example

<?php
  $s = new SWFShape();
  $s->setLine(40, 0x7f, 0, 0);
  $s->setRightFill($s->addFill(0xff, 0, 0));
  $s->movePenTo(200, 200);
  $s->drawLineTo(6200, 200);
  $s->drawLineTo(6200, 4600);
  $s->drawCurveTo(200, 4600, 200, 200);

  $m = new SWFMovie();
  $m->setDimension(6400, 4800);
  $m->setRate(12.0);
  $m->add($s);
  $m->nextFrame();

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

이전 | 처음으로 | 다음
SWFShape->setRightFill | 위로 | swfsprite->add


swfsprite->add

(no version information, might be only in CVS)

swfsprite->add -- Adds an object to a sprite

Description

void swfsprite->add ( resource object)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfsprite->add() adds a swfshape(), a
swfbutton(), a swftext(),
a swfaction() or a swfsprite() object.

For displayable types (swfshape(),
swfbutton(), swftext(),
swfaction() or swfsprite()),
this returns a handle  to the object in a display list.

이전 | 처음으로 | 다음
SWFShape | 위로 | SWFSprite->nextframe


SWFSprite->nextframe

(no version information, might be only in CVS)

SWFSprite->nextframe -- Moves to the next frame of the animation.

Description

void swfsprite->nextframe ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfsprite->setframes() moves to the next frame of the animation.

이전 | 처음으로 | 다음
swfsprite->add | 위로 | SWFSprite->remove


SWFSprite->remove

(no version information, might be only in CVS)

SWFSprite->remove -- Removes an object to a sprite

Description

void swfsprite->remove ( resource object)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfsprite->remove() remove a swfshape(), a
swfbutton(), a swftext(),
a swfaction() or a swfsprite() object
from the sprite.

이전 | 처음으로 | 다음
SWFSprite->nextframe | 위로 | SWFSprite->setframes


SWFSprite->setframes

(no version information, might be only in CVS)

SWFSprite->setframes -- Sets the total number of frames in the animation.

Description

void swfsprite->setframes ( int numberofframes)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfsprite->setframes() sets the total number of frames in the animation to numberofframes.

이전 | 처음으로 | 다음
SWFSprite->remove | 위로 | SWFSprite


SWFSprite

(PHP 4 >= 4.0.5)

SWFSprite -- Creates a movie clip (a sprite)

Description

new swfsprite ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swfsprite() are also known as a "movie clip", this allows one to create objects which are animated in their own timelines. Hence, the sprite has most of the same methods as the movie.

swfsprite() has the following methods :
swfsprite->add(),
swfsprite->remove(), swfsprite->nextframe()
and swfsprite->setframes().

This simple example will spin gracefully a big red square.

예 1. swfsprite() example

<?php
  $s = new SWFShape();
  $s->setRightFill($s->addFill(0xff, 0, 0));
  $s->movePenTo(-500, -500);
  $s->drawLineTo(500, -500);
  $s->drawLineTo(500, 500);
  $s->drawLineTo(-500, 500);
  $s->drawLineTo(-500, -500);

  $p = new SWFSprite();
  $i = $p->add($s);
  $p->nextFrame();
  $i->rotate(15);
  $p->nextFrame();
  $i->rotate(15);
  $p->nextFrame();
  $i->rotate(15);
  $p->nextFrame();
  $i->rotate(15);
  $p->nextFrame();
  $i->rotate(15);
  $p->nextFrame();

  $m = new SWFMovie();
  $i = $m->add($p);
  $i->moveTo(1500, 1000);
  $i->setName("blah");

  $m->setBackground(0xff, 0xff, 0xff);
  $m->setDimension(3000, 2000);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

이전 | 처음으로 | 다음
SWFSprite->setframes | 위로 | SWFText->addString


SWFText->addString

(no version information, might be only in CVS)

SWFText->addString -- Draws a string

Description

void swftext->addstring ( string string)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftext->addstring() draws the string string at the current pen (cursor) location. Pen is at the baseline of the text; i.e., ascending text is in the -y direction.

이전 | 처음으로 | 다음
SWFSprite | 위로 | SWFText->getWidth


SWFText->getWidth

(no version information, might be only in CVS)

SWFText->getWidth -- Computes string's width

Description

void swftext->getwidth ( string string)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftext->addstring() returns the rendered width of the string string at the text object's current font, scale, and spacing settings.

이전 | 처음으로 | 다음
SWFText->addString | 위로 | SWFText->moveTo


SWFText->moveTo

(no version information, might be only in CVS)

SWFText->moveTo -- Moves the pen

Description

void swftext->moveto ( int x, int y)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftext->moveto() moves the pen (or cursor, if that makes more sense) to (x,y) in text object's coordinate space. If either is zero, though, value in that dimension stays the same. Annoying, should be fixed.

이전 | 처음으로 | 다음
SWFText->getWidth | 위로 | SWFText->setColor


SWFText->setColor

(no version information, might be only in CVS)

SWFText->setColor -- Sets the current font color

Description

void swftext->setcolor ( int red, int green, int blue [, int a])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftext->setspacing() changes the current text color. Default is black. I think. Color is represented using the RGB system.

이전 | 처음으로 | 다음
SWFText->moveTo | 위로 | SWFText->setFont


SWFText->setFont

(no version information, might be only in CVS)

SWFText->setFont -- Sets the current font

Description

void swftext->setfont ( string font)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftext->setfont() sets the current font to font.

이전 | 처음으로 | 다음
SWFText->setColor | 위로 | SWFText->setHeight


SWFText->setHeight

(no version information, might be only in CVS)

SWFText->setHeight -- Sets the current font height

Description

void swftext->setheight ( int height)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftext->setheight() sets the current font height to height. Default is 240.

이전 | 처음으로 | 다음
SWFText->setFont | 위로 | SWFText->setSpacing


SWFText->setSpacing

(no version information, might be only in CVS)

SWFText->setSpacing -- Sets the current font spacing

Description

void swftext->setspacing ( float spacing)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftext->setspacing() sets the current font spacing to spacingspacing. Default is 1.0. 0 is all of the letters written at the same point. This doesn't really work that well because it inflates the advance across the letter, doesn't add the same amount of spacing between the letters. I should try and explain that better, prolly. Or just fix the damn thing to do constant spacing. This was really just a way to figure out how letter advances work, anyway.. So nyah.

이전 | 처음으로 | 다음
SWFText->setHeight | 위로 | SWFText


SWFText

(PHP 4 >= 4.0.5)

SWFText -- Creates a new SWFText object.

Description

new swftext ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftext() creates a new SWFText object, fresh for manipulating.

SWFText has the following methods : swftext->setfont(),
swftext->setheight(), swftext->setspacing(),
swftext->setcolor(), swftext->moveto(),
swftext->addstring() and swftext->getwidth().

This simple example will draw a big yellow "PHP generates Flash with Ming" text, on white background.

예 1. swftext() example

<?php
  $f = new SWFFont("Techno.fdb");
  $t = new SWFText();
  $t->setFont($f);
  $t->moveTo(200, 2400);
  $t->setColor(0xff, 0xff, 0);
  $t->setHeight(1200);
  $t->addString("PHP generates Flash with Ming!!");

  $m = new SWFMovie();
  $m->setDimension(5400, 3600);

  $m->add($t);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

이전 | 처음으로 | 다음
SWFText->setSpacing | 위로 | SWFTextField->addstring


SWFTextField->addstring

(no version information, might be only in CVS)

SWFTextField->addstring -- Concatenates the given string to the text field

Description

void swftextfield->addstring ( string string)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftextfield->setname() concatenates the string string to the text field.

이전 | 처음으로 | 다음
SWFText | 위로 | SWFTextField->align


SWFTextField->align

(no version information, might be only in CVS)

SWFTextField->align -- Sets the text field alignment

Description

void swftextfield->align ( int alignement)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftextfield->align() sets the text field alignment to alignement. Valid values for alignement are : SWFTEXTFIELD_ALIGN_LEFT, SWFTEXTFIELD_ALIGN_RIGHT, SWFTEXTFIELD_ALIGN_CENTER and SWFTEXTFIELD_ALIGN_JUSTIFY.

이전 | 처음으로 | 다음
SWFTextField->addstring | 위로 | SWFTextField->setbounds


SWFTextField->setbounds

(no version information, might be only in CVS)

SWFTextField->setbounds -- Sets the text field width and height

Description

void swftextfield->setbounds ( int width, int height)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftextfield->setbounds() sets the text field width to width and height to height. If you don't set the bounds yourself, Ming makes a poor guess at what the bounds are.

이전 | 처음으로 | 다음
SWFTextField->align | 위로 | SWFTextField->setcolor


SWFTextField->setcolor

(no version information, might be only in CVS)

SWFTextField->setcolor -- Sets the color of the text field.

Description

void swftextfield->setcolor ( int red, int green, int blue [, int a])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftextfield->setcolor() sets the color of the text field. Default is fully opaque black. Color is represented using RGB system.

이전 | 처음으로 | 다음
SWFTextField->setbounds | 위로 | SWFTextField->setFont


SWFTextField->setFont

(no version information, might be only in CVS)

SWFTextField->setFont -- Sets the text field font

Description

void swftextfield->setfont ( string font)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftextfield->setfont() sets the text field font to the [browser-defined?] font font.

이전 | 처음으로 | 다음
SWFTextField->setcolor | 위로 | SWFTextField->setHeight


SWFTextField->setHeight

(no version information, might be only in CVS)

SWFTextField->setHeight -- Sets the font height of this text field font.

Description

void swftextfield->setheight ( int height)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftextfield->setheight() sets the font height of this text field font to the given height height. Default is 240.

이전 | 처음으로 | 다음
SWFTextField->setFont | 위로 | SWFTextField->setindentation


SWFTextField->setindentation

(no version information, might be only in CVS)

SWFTextField->setindentation -- Sets the indentation of the first line.

Description

void swftextfield->setindentation ( int width)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftextfield->setindentation() sets the indentation of the first line in the text field, to width.

이전 | 처음으로 | 다음
SWFTextField->setHeight | 위로 | SWFTextField->setLeftMargin


SWFTextField->setLeftMargin

(no version information, might be only in CVS)

SWFTextField->setLeftMargin -- Sets the left margin width of the text field.

Description

void swftextfield->setleftmargin ( int width)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftextfield->setleftmargin() sets the left margin width of the text field to width. Default is 0.

이전 | 처음으로 | 다음
SWFTextField->setindentation | 위로 | SWFTextField->setLineSpacing


SWFTextField->setLineSpacing

(no version information, might be only in CVS)

SWFTextField->setLineSpacing -- Sets the line spacing of the text field.

Description

void swftextfield->setlinespacing ( int height)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftextfield->setlinespacing() sets the line spacing of the text field to the height of height. Default is 40.

이전 | 처음으로 | 다음
SWFTextField->setLeftMargin | 위로 | SWFTextField->setMargins


SWFTextField->setMargins

(no version information, might be only in CVS)

SWFTextField->setMargins -- Sets the margins width of the text field.

Description

void swftextfield->setmargins ( int left, int right)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftextfield->setmargins() set both margins at once, for the man on the go.

이전 | 처음으로 | 다음
SWFTextField->setLineSpacing | 위로 | SWFTextField->setname


SWFTextField->setname

(no version information, might be only in CVS)

SWFTextField->setname -- Sets the variable name

Description

void swftextfield->setname ( string name)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftextfield->setname() sets the variable name of this text field to name, for form posting and action scripting purposes.

이전 | 처음으로 | 다음
SWFTextField->setMargins | 위로 | SWFTextField->setrightMargin


SWFTextField->setrightMargin

(no version information, might be only in CVS)

SWFTextField->setrightMargin -- Sets the right margin width of the text field.

Description

void swftextfield->setrightmargin ( int width)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftextfield->setrightmargin() sets the right margin width of the text field to width. Default is 0.

이전 | 처음으로 | 다음
SWFTextField->setname | 위로 | SWFTextField


SWFTextField

(PHP 4 >= 4.0.5)

SWFTextField -- Creates a text field object

Description

new swftextfield ( [int flags])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

swftextfield() creates a new text field object. Text Fields are less flexible than swftext() objects- they can't be rotated, scaled non-proportionally, or skewed, but they can be used as form entries, and they can use browser-defined fonts.

The optional flags change the text field's behavior. It has the following possibles values :

  • SWFTEXTFIELD_DRAWBOX draws the outline of the textfield

  • SWFTEXTFIELD_HASLENGTH

  • SWFTEXTFIELD_HTML allows text markup using HTML-tags

  • SWFTEXTFIELD_MULTILINE allows multiple lines

  • SWFTEXTFIELD_NOEDIT indicates that the field shouldn't be user-editable

  • SWFTEXTFIELD_NOSELECT makes the field non-selectable

  • SWFTEXTFIELD_PASSWORD obscures the data entry

  • SWFTEXTFIELD_WORDWRAP allows text to wrap

Flags are combined with the bitwise OR operation. For example,
<?php
$t = newSWFTextField(SWFTEXTFIELD_PASSWORD | SWFTEXTFIELD_NOEDIT);
?>
creates a totally useless non-editable password field.

SWFTextField has the following methods : swftextfield->setfont(),
swftextfield->setbounds(), swftextfield->align(),
swftextfield->setheight(), swftextfield->setleftmargin(),
swftextfield->setrightmargin(), swftextfield->setmargins(),
swftextfield->setindentation(), swftextfield->setlinespacing(),
swftextfield->setcolor(), swftextfield->setname() and
swftextfield->addstring().

이전 | 처음으로 | 다음
SWFTextField->setrightMargin | 위로 | Miscellaneous Functions


Miscellaneous Functions

PHP 매뉴얼
이전 다음

LXI. Miscellaneous Functions

소개

These functions were placed here because none of the other categories seemed to fit.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. Misc. Configuration Options

Name | Default | Changeable
ignore_user_abort | "0" | PHP_INI_ALL
highlight.string | #DD0000 | PHP_INI_ALL
highlight.comment | #FF9900 | PHP_INI_ALL
highlight.keyword | #007700 | PHP_INI_ALL
highlight.bg | #FFFFFF | PHP_INI_ALL
highlight.default | #0000BB | PHP_INI_ALL
highlight.html | #000000 | PHP_INI_ALL
browscap | NULL | PHP_INI_SYSTEM
For further details and definition of the PHP_INI_* constants see ini_set().

위 설정 지시어에 대한 간단한 설명입니다.

ignore_user_abort boolean

TRUE by default. If changed to FALSE scripts will be terminated as soon as they try to output something after a client has aborted their connection.

See also ignore_user_abort().

highlight.comment string, highlight.default string, highlight.html string, highlight.keyword string, highlight.string string

Colors for Syntax Highlighting mode. Anything that's acceptable in <font color="??????"> would work.

browscap string

Name (e.g.: browscap.ini) and location of browser capabilities file. See also get_browser().

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

CONNECTION_ABORTED (integer)

CONNECTION_NORMAL (integer)

CONNECTION_TIMEOUT (integer)

차례
connection_aborted -- Returns TRUE if client disconnected
connection_status -- Returns connection status bitfield
connection_timeout -- Return TRUE if script timed out
constant -- Returns the value of a constant
define -- Defines a named constant.
defined -- Checks whether a given named constant exists
die -- Equivalent to exit()
eval -- Evaluate a string as PHP code
exit -- Output a message and terminate the current script
get_browser -- Tells what the user's browser is capable of
highlight_file -- Syntax highlighting of a file
highlight_string -- Syntax highlighting of a string
ignore_user_abort -- Set whether a client disconnect should abort script execution
pack -- Pack data into binary string.
show_source -- Alias of highlight_file()
sleep -- Delay execution
uniqid -- Generate a unique ID
unpack -- Unpack data from binary string
usleep -- Delay execution in microseconds

이전 | 처음으로 | 다음
SWFTextField | 위로 | connection_aborted


connection_aborted

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

connection_aborted -- Returns TRUE if client disconnected

Description

int connection_aborted ( void )

Returns TRUE if client disconnected. See the Connection Handling description in the Features chapter for a complete explanation.

See also connection_status(), and ignore_user_abort().

이전 | 처음으로 | 다음
Miscellaneous Functions | 위로 | connection_status


connection_status

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

connection_status -- Returns connection status bitfield

Description

int connection_status ( void )

Returns the connection status bitfield. See the Connection Handling description in the Features chapter for a complete explanation.

See also connection_aborted(), and ignore_user_abort().

이전 | 처음으로 | 다음
connection_aborted | 위로 | connection_timeout


connection_timeout

(PHP 3>= 3.0.7, PHP 4 <= 4.0.4)

connection_timeout -- Return TRUE if script timed out

Description

bool connection_timeout ( void )

Returns TRUE if script timed out.

Deprecated

This function is deprecated, and doesn't even exist anymore as of 4.0.5.

See the Connection Handling description in the Features chapter for a complete explanation.

이전 | 처음으로 | 다음
connection_status | 위로 | constant


constant

(PHP 4 >= 4.0.4, PHP 5)

constant -- Returns the value of a constant

Description

mixed constant ( string name)

constant() will return the value of the constant indicated by name.

constant() is useful if you need to retrieve the value of a constant, but do not know its name. i.e. It is stored in a variable or returned by a function.

예 1. constant() example

<?php

define("MAXSIZE", 100);

echo MAXSIZE;
echo constant("MAXSIZE"); // same thing as the previous line

?>

See also define(), defined() and the section on Constants.

이전 | 처음으로 | 다음
connection_timeout | 위로 | define


define

(PHP 3, PHP 4 , PHP 5)

define -- Defines a named constant.

Description

bool define ( string name, mixed value [, bool case_insensitive])

Defines a named constant. See the section on constants for more details.

The name of the constant is given by name; the value is given by value.

The optional third parameter case_insensitive is also available. If the value TRUE is given, then the constant will be defined case-insensitive. The default behaviour is case-sensitive; i.e. CONSTANT and Constant represent different values.

예 1. Defining Constants

<?php
define("CONSTANT", "Hello world.");
echo CONSTANT; // outputs "Hello world."
echo Constant; // outputs "Constant" and issues a notice.

define("GREETING", "Hello you.", true);
echo GREETING; // outputs "Hello you."
echo Greeting; // outputs "Hello you."

?>

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also defined(), constant() and the section on Constants.

이전 | 처음으로 | 다음
constant | 위로 | defined


defined

(PHP 3, PHP 4 , PHP 5)

defined -- Checks whether a given named constant exists

Description

bool defined ( string name)

Returns TRUE if the named constant given by name has been defined, FALSE otherwise.

예 1. Checking Constants

<?php
/* Note the use of quotes, this is important.  This example is checking
* if the string 'CONSTANT' is the name of a constant named CONSTANT */
if (defined('CONSTANT')) {
    echo CONSTANT;
}
?>

참고: If you want to see if a variable exists, use isset() as defined() only applies to constants. If you want to see if a function exists, use function_exists().

See also define(),
constant(),
get_defined_constants(),
function_exists(), and the section on
Constants.

이전 | 처음으로 | 다음
define | 위로 | die


die

die -- Equivalent to exit()

Description

This language construct is equivalent to exit().

이전 | 처음으로 | 다음
defined | 위로 | eval


eval

(PHP 3, PHP 4, PHP 5 )

eval -- Evaluate a string as PHP code

Description

mixed eval ( string code_str)

eval() evaluates the string given in code_str as PHP code. Among other things, this can be useful for storing code in a database text field for later execution.

There are some factors to keep in mind when using eval(). Remember that the string passed must be valid PHP code, including things like terminating statements with a semicolon so the parser doesn't die on the line after the eval(), and properly escaping things in code_str.

Also remember that variables given values under eval() will retain these values in the main script afterwards.

A return statement will terminate the evaluation of the string immediately. In PHP 4, eval() returns NULL unless return is called in the evaluated code, in which case the value passed to return is returned. In PHP 3, eval() does not return a value.

예 1. eval() example - simple text merge

<?php
$string = 'cup';
$name = 'coffee';
$str = 'This is a $string with my $name in it.';
echo $str. "\n";
eval("\$str = \"$str\";");
echo $str. "\n";
?>

The above example will show:

This is a $string with my $name in it.
This is a cup with my coffee in it.

작은 정보: 어떠한 결과가 브라우저로 직접 출력될 때, 출력 제어 함수를 이용해서 이 함수의 출력을 잡아내고, (예를 들면) string으로 저장할 수 있습니다.

이전 | 처음으로 | 다음
die | 위로 | exit


exit

(PHP 3, PHP 4, PHP 5 )

exit -- Output a message and terminate the current script

Description

void exit ( [string status])

void exit ( int status)

참고: This is not a real function, but a language construct.

참고: PHP >= 4.2.0 does NOT print the status if it is an integer.

The exit() function terminates execution of the script. It prints status just before exiting.

If status is an integer, that value will also be used as the exit status. Exit statuses should be in the range 1 to 254, the exit status 255 is reserved by PHP and shall not be used.

예 1. exit() example

<?php

$filename = '/path/to/data-file';
$file = fopen($filename, 'r')
    or exit("unable to open file ($filename)");

?>

참고: The die() function is an alias for exit().

See also: register_shutdown_function().

이전 | 처음으로 | 다음
eval | 위로 | get_browser


get_browser

(PHP 3, PHP 4 , PHP 5)

get_browser -- Tells what the user's browser is capable of

Description

object get_browser ( [string user_agent])

get_browser() attempts to determine the capabilities of the user's browser. This is done by looking up the browser's information in the browscap.ini file. By default, the value of HTTP_USER_AGENT is used; however, you can alter this (i.e., look up another browser's info) by passing the optional user_agent parameter to get_browser().

The information is returned in an object, which will contain various data elements representing, for instance, the browser's major and minor version numbers and ID string; TRUE/FALSE values for features such as frames, JavaScript, and cookies; and so forth.

While browscap.ini contains information on many browsers, it relies on user updates to keep the database current. The format of the file is fairly self-explanatory.

The following example shows how one might list all available information retrieved about the user's browser.

예 1. get_browser() example

<?php
echo $_SERVER['HTTP_USER_AGENT'] . "<hr />\n";

$browser = get_browser();

foreach ($browser as $name => $value) {
    echo "<b>$name</b> $value <br />\n";
}

?>

The output of the above script would look something like this:

Mozilla/4.5 [en] (X11; U; Linux 2.2.9 i586)<hr />
<b>browser_name_pattern:</b> Mozilla/4\.5.*<br />
<b>parent:</b> Netscape 4.0<br />
<b>platform:</b> Linux<br />
<b>majorver:</b> 4<br />
<b>minorver:</b> 5<br />
<b>browser:</b> Netscape<br />
<b>version:</b> 4<br />
<b>frames:</b> 1<br />
<b>tables:</b> 1<br />
<b>cookies:</b> 1<br />
<b>backgroundsounds:</b> <br />
<b>vbscript:</b> <br />
<b>javascript:</b> 1<br />
<b>javaapplets:</b> 1<br />
<b>activexcontrols:</b> <br />
<b>beta:</b> <br />
<b>crawler:</b> <br />
<b>authenticodeupdate:</b> <br />
<b>msn:</b> <br />

In order for this to work, your browscap configuration setting in php.ini must point to the correct location of the browscap.ini file on your system. browscap.ini is not bundled with PHP but you may find an up-to-date browscap.ini file here. By default, the browscap directive is commented out.

The cookies value simply means that the browser itself is capable of accepting cookies and does not mean the user has enabled the browser to accept cookies or not. The only way to test if cookies are accepted is to set one with setcookie(), reload, and check for the value.

참고: On versions older than PHP 4.0.6, you will have to pass the user agent in via the optional user_agent parameter if the PHP directive register_globals is off. In this case, you will pass in $HTTP_SERVER_VARS['HTTP_USER_AGENT'].

이전 | 처음으로 | 다음
exit | 위로 | highlight_file


highlight_file

(PHP 4 , PHP 5)

highlight_file -- Syntax highlighting of a file

Description

mixed highlight_file ( string filename [, bool return])

The highlight_file() function prints out a syntax highlighted version of the code contained in filename using the colors defined in the built-in syntax highlighter for PHP.

If the second parameter return is set to TRUE then highlight_file() will return the highlighted code as a string instead of printing it out. If the second parameter is not set to TRUE then highlight_file() will return TRUE on success, FALSE on failure.

참고: The return parameter became available in PHP 4.2.0. Before this time it behaved like the default, which is FALSE

경고

Care should be taken when using the show_source() and highlight_file() functions to make sure that you do not inadvertently reveal sensitive information such as passwords or any other type of information that might create a potential security risk.

참고: Since PHP 4.2.1 this function is also affected by safe_mode and open_basedir.

To setup a URL that can code hightlight any script that you pass to it, we will make use of the "ForceType" directive in Apache to generate a nice URL pattern, and use the function highlight_file() to show a nice looking code list.

In your httpd.conf you can add the following:

예 1. Creating a source highlighting URL

<Location /source>
    ForceType application/x-httpd-php
</Location>

And then make a file named "source" and put it in your web root directory.

<html>
<head>
<title>Source Display</title>
</head>
<body bgcolor="white">
<?php
    $script = getenv("PATH_TRANSLATED");
    if (!$script) {
        echo "<br /><b>ERROR: Script Name needed</b><br />";
    } else {
        if (ereg("(\\.php|\\.inc)$", $script)) {
            echo "<h1>Source of: " . getenv("PATH_INFO") . "</h1>\n<hr />\n";
            highlight_file($script);
        } else {
            echo "<h1>ERROR: Only PHP or include script names are allowed</h1>";
        }
    }
    echo "<hr />Processed: " . date("Y/M/d H:i:s", time());
?>
</BODY>
</HTML>

Then you can use a URL like the one below to display a colorized version of a script located in "/path/to/script.php" in your web site.

http://www.example.com/source/path/to/script.php

See also highlight_string().

이전 | 처음으로 | 다음
get_browser | 위로 | highlight_string


highlight_string

(PHP 4 , PHP 5)

highlight_string -- Syntax highlighting of a string

Description

mixed highlight_string ( string str [, bool return])

The highlight_string() function outputs a syntax highlighted version of str using the colors defined in the built-in syntax highlighter for PHP.

If the second parameter return is set to TRUE then highlight_string() will return the highlighted code as a string instead of printing it out. If the second parameter is not set to TRUE then highlight_string() will return TRUE on success, FALSE on failure.

참고: The return parameter became available in PHP 4.2.0. Before this time it behaved like the default, which is FALSE

See also highlight_file().

이전 | 처음으로 | 다음
highlight_file | 위로 | ignore_user_abort


ignore_user_abort

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

ignore_user_abort -- Set whether a client disconnect should abort script execution

Description

int ignore_user_abort ( [bool setting])

This function sets whether a client disconnect should cause a script to be aborted. It will return the previous setting and can be called without an argument to not change the current setting and only return the current setting. See the Connection Handling section in the Features chapter for a complete description of connection handling in PHP.

See also connection_aborted(), and connection_status().

이전 | 처음으로 | 다음
highlight_string | 위로 | pack


pack

(PHP 3, PHP 4 , PHP 5)

pack -- Pack data into binary string.

Description

string pack ( string format [, mixed args])

Pack given arguments into binary string according to format. Returns binary string containing data.

The idea to this function was taken from Perl and all formatting codes work the same as there, however, there are some formatting codes that are missing such as Perl's "u" format code. The format string consists of format codes followed by an optional repeater argument. The repeater argument can be either an integer value or * for repeating to the end of the input data. For a, A, h, H the repeat count specifies how many characters of one data argument are taken, for @ it is the absolute position where to put the next data, for everything else the repeat count specifies how many data arguments are consumed and packed into the resulting binary string. Currently implemented are

표 1. pack() format characters

Code | Description
a | NUL-padded string
A | SPACE-padded string
h | Hex string, low nibble first
H | Hex string, high nibble first
c | signed char
C | unsigned char
s | signed short (always 16 bit, machine byte order)
S | unsigned short (always 16 bit, machine byte order)
n | unsigned short (always 16 bit, big endian byte order)
v | unsigned short (always 16 bit, little endian byte order)
i | signed integer (machine dependent size and byte order)
I | unsigned integer (machine dependent size and byte order)
l | signed long (always 32 bit, machine byte order)
L | unsigned long (always 32 bit, machine byte order)
N | unsigned long (always 32 bit, big endian byte order)
V | unsigned long (always 32 bit, little endian byte order)
f | float (machine dependent size and representation)
d | double (machine dependent size and representation)
x | NUL byte
X | Back up one byte
@ | NUL-fill to absolute position

예 1. pack() example

<?php
$binarydata = pack("nvc*", 0x1234, 0x5678, 65, 66);
?>

The resulting binary string will be 6 bytes long and contain the byte sequence 0x12, 0x34, 0x78, 0x56, 0x41, 0x42.

Note that the distinction between signed and unsigned values only affects the function unpack(), where as function pack() gives the same result for signed and unsigned format codes.

Also note that PHP internally stores integer values as signed values of a machine dependent size. If you give it an unsigned integer value too large to be stored that way it is converted to a float which often yields an undesired result.

이전 | 처음으로 | 다음
ignore_user_abort | 위로 | show_source


show_source

show_source -- Alias of highlight_file()

Description

This function is an alias of highlight_file().

이전 | 처음으로 | 다음
pack | 위로 | sleep


sleep

(PHP 3, PHP 4 , PHP 5)

sleep -- Delay execution

Description

void sleep ( int seconds)

The sleep() function delays program execution for the given number of seconds.

예 1. sleep() example

<?php

// current time
echo date('h:i:s') . "\n";

// sleep for 10 seconds
sleep(10);

// wake up !
echo date('h:i:s') . "\n";

?>

This example will output (after 10 seconds)

05:31:23
05:31:33

See also usleep() and set_time_limit()

이전 | 처음으로 | 다음
show_source | 위로 | uniqid


uniqid

(PHP 3, PHP 4 , PHP 5)

uniqid -- Generate a unique ID

Description

string uniqid ( string prefix [, bool lcg])

uniqid() returns a prefixed unique identifier based on the current time in microseconds. The prefix can be useful for instance if you generate identifiers simultaneously on several hosts that might happen to generate the identifier at the same microsecond. Prefix can be up to 114 characters long.

If the optional lcg parameter is TRUE, uniqid() will add additional "combined LCG" entropy at the end of the return value, which should make the results more unique.

With an empty prefix, the returned string will be 13 characters long. If lcg is TRUE, it will be 23 characters.

참고: The lcg parameter is only available in PHP 4 and PHP 3.0.13 and later.

If you need a unique identifier or token and you intend to give out that token to the user via the network (i.e. session cookies), it is recommended that you use something along these lines:

<?php
// no prefix
$token = md5(uniqid(""));

// better, difficult to guess
$better_token = md5(uniqid(rand(), true));
?>

This will create a 32 character identifier (a 128 bit hex number) that is extremely difficult to predict.

이전 | 처음으로 | 다음
sleep | 위로 | unpack


unpack

(PHP 3, PHP 4 , PHP 5)

unpack -- Unpack data from binary string

Description

array unpack ( string format, string data)

unpack() from binary string into array according to format. Returns array containing unpacked elements of binary string.

unpack() works slightly different from Perl as the unpacked data is stored in an associative array. To accomplish this you have to name the different format codes and separate them by a slash /.

예 1. unpack() example

<?php
$array = unpack("c2chars/nint", $binarydata);
?>

The resulting array will contain the entries "chars1", "chars2" and "int".

경고

Note that PHP internally stores integral values as signed. If you unpack a large unsigned long and it is of the same size as PHP internally stored values the result will be a negative number even though unsigned unpacking was specified.

See also pack() for an explanation of the format codes.

이전 | 처음으로 | 다음
uniqid | 위로 | usleep


usleep

(PHP 3, PHP 4 , PHP 5)

usleep -- Delay execution in microseconds

Description

void usleep ( int micro_seconds)

The usleep() function delays program execution for the given number of micro_seconds. A microsecond is one millionth of a second.

참고: This function does not work on Windows systems.

See also sleep() and set_time_limit().

이전 | 처음으로 | 다음
unpack | 위로 | mnoGoSearch Functions


mnoGoSearch Functions

PHP 매뉴얼
이전 다음

LXII. mnoGoSearch Functions

소개

These functions allow you to access the mnoGoSearch (former UdmSearch) free search engine. mnoGoSearch is a full-featured search engine software for intranet and internet servers, distributed under the GNU license. mnoGoSearch has a number of unique features, which makes it appropriate for a wide range of applications from search within your site to a specialized search system such as cooking recipes or newspaper search, FTP archive search, news articles search, etc. It offers full-text indexing and searching for HTML, PDF, and text documents. mnoGoSearch consists of two parts. The first is an indexing mechanism (indexer). The purpose of the indexer is to walk through HTTP, FTP, NEWS servers or local files, recursively grabbing all the documents and storing meta-data about that documents in a SQL database in a smart and effective manner. After every document is referenced by its corresponding URL, meta-data is collected by the indexer for later use in a search process. The search is performed via Web interface. C, CGI, PHP and Perl search front ends are included.

More information about mnoGoSearch can be found at http://www.mnogosearch.ru/.

참고: 이 확장 모듈은 윈도우 플랫폼에서는 사용할 수 없습니다.

요구 사항

Download mnoGosearch from http://www.mnogosearch.ru/ and install it on your system. You need at least version 3.1.10 of mnoGoSearch installed to use these functions.

설치

In order to have these functions available, you must compile PHP with mnoGosearch support by using the --with-mnogosearchoption. If you use this option without specifying the path to mnoGosearch, PHP will look for mnoGosearch under /usr/local/mnogosearch path by default. If you installed mnoGosearch at a different location you should specify it: --with-mnogosearch=DIR.

참고: PHP contains built-in MySQL access library, which can be used to access MySQL. It is known that mnoGoSearch is not compatible with this built-in library and can work only with generic MySQL libraries. Thus, if you use mnoGoSearch with MySQL, during PHP configuration you have to indicate the directory of your MySQL installation, that was used during mnoGoSearch configuration, i.e. for example: --with-mnogosearch --with-mysql=/usr.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

UDM_FIELD_URLID (integer)

UDM_FIELD_URL (integer)

UDM_FIELD_CONTENT (integer)

UDM_FIELD_TITLE (integer)

UDM_FIELD_KEYWORDS (integer)

UDM_FIELD_DESC (integer)

UDM_FIELD_DESCRIPTION (integer)

UDM_FIELD_TEXT (integer)

UDM_FIELD_SIZE (integer)

UDM_FIELD_RATING (integer)

UDM_FIELD_SCORE (integer)

UDM_FIELD_MODIFIED (integer)

UDM_FIELD_ORDER (integer)

UDM_FIELD_CRC (integer)

UDM_FIELD_CATEGORY (integer)

UDM_FIELD_LANG (integer)

UDM_FIELD_CHARSET (integer)

UDM_PARAM_PAGE_SIZE (integer)

UDM_PARAM_PAGE_NUM (integer)

UDM_PARAM_SEARCH_MODE (integer)

UDM_PARAM_CACHE_MODE (integer)

UDM_PARAM_TRACK_MODE (integer)

UDM_PARAM_PHRASE_MODE (integer)

UDM_PARAM_CHARSET (integer)

UDM_PARAM_LOCAL_CHARSET (integer)

UDM_PARAM_BROWSER_CHARSET (integer)

UDM_PARAM_STOPTABLE (integer)

UDM_PARAM_STOP_TABLE (integer)

UDM_PARAM_STOPFILE (integer)

UDM_PARAM_STOP_FILE (integer)

UDM_PARAM_WEIGHT_FACTOR (integer)

UDM_PARAM_WORD_MATCH (integer)

UDM_PARAM_MAX_WORD_LEN (integer)

UDM_PARAM_MAX_WORDLEN (integer)

UDM_PARAM_MIN_WORD_LEN (integer)

UDM_PARAM_MIN_WORDLEN (integer)

UDM_PARAM_ISPELL_PREFIXES (integer)

UDM_PARAM_ISPELL_PREFIX (integer)

UDM_PARAM_PREFIXES (integer)

UDM_PARAM_PREFIX (integer)

UDM_PARAM_CROSS_WORDS (integer)

UDM_PARAM_CROSSWORDS (integer)

UDM_PARAM_VARDIR (integer)

UDM_PARAM_DATADIR (integer)

UDM_PARAM_HLBEG (integer)

UDM_PARAM_HLEND (integer)

UDM_PARAM_SYNONYM (integer)

UDM_PARAM_SEARCHD (integer)

UDM_PARAM_QSTRING (integer)

UDM_PARAM_REMOTE_ADDR (integer)

UDM_LIMIT_CAT (integer)

UDM_LIMIT_URL (integer)

UDM_LIMIT_TAG (integer)

UDM_LIMIT_LANG (integer)

UDM_LIMIT_DATE (integer)

UDM_PARAM_FOUND (integer)

UDM_PARAM_NUM_ROWS (integer)

UDM_PARAM_WORDINFO (integer)

UDM_PARAM_WORD_INFO (integer)

UDM_PARAM_SEARCHTIME (integer)

UDM_PARAM_SEARCH_TIME (integer)

UDM_PARAM_FIRST_DOC (integer)

UDM_PARAM_LAST_DOC (integer)

UDM_MODE_ALL (integer)

UDM_MODE_ANY (integer)

UDM_MODE_BOOL (integer)

UDM_MODE_PHRASE (integer)

UDM_CACHE_ENABLED (integer)

UDM_CACHE_DISABLED (integer)

UDM_TRACK_ENABLED (integer)

UDM_TRACK_DISABLED (integer)

UDM_PHRASE_ENABLED (integer)

UDM_PHRASE_DISABLED (integer)

UDM_CROSS_WORDS_ENABLED (integer)

UDM_CROSSWORDS_ENABLED (integer)

UDM_CROSS_WORDS_DISABLED (integer)

UDM_CROSSWORDS_DISABLED (integer)

UDM_PREFIXES_ENABLED (integer)

UDM_PREFIX_ENABLED (integer)

UDM_ISPELL_PREFIXES_ENABLED (integer)

UDM_ISPELL_PREFIX_ENABLED (integer)

UDM_PREFIXES_DISABLED (integer)

UDM_PREFIX_DISABLED (integer)

UDM_ISPELL_PREFIXES_DISABLED (integer)

UDM_ISPELL_PREFIX_DISABLED (integer)

UDM_ISPELL_TYPE_AFFIX (integer)

UDM_ISPELL_TYPE_SPELL (integer)

UDM_ISPELL_TYPE_DB (integer)

UDM_ISPELL_TYPE_SERVER (integer)

UDM_MATCH_WORD (integer)

UDM_MATCH_BEGIN (integer)

UDM_MATCH_SUBSTR (integer)

UDM_MATCH_END (integer)

차례
udm_add_search_limit -- Add various search limits
udm_alloc_agent_array -- Allocate mnoGoSearch session
udm_alloc_agent -- Allocate mnoGoSearch session
udm_api_version -- Get mnoGoSearch API version.
udm_cat_list -- Get all the categories on the same level with the current one.
udm_cat_path -- Get the path to the current category.
udm_check_charset -- Check if the given charset is known to mnogosearch
udm_check_stored -- Check connection to stored
udm_clear_search_limits -- Clear all mnoGoSearch search restrictions
udm_close_stored -- Close connection to stored
udm_crc32 -- Return CRC32 checksum of given string
udm_errno -- Get mnoGoSearch error number
udm_error -- Get mnoGoSearch error message
udm_find -- Perform search
udm_free_agent -- Free mnoGoSearch session
udm_free_ispell_data -- Free memory allocated for ispell data
udm_free_res -- Free mnoGoSearch result
udm_get_doc_count -- Get total number of documents in database.
udm_get_res_field -- Fetch mnoGoSearch result field
udm_get_res_param -- Get mnoGoSearch result parameters
udm_hash32 -- Return Hash32 checksum of gived string
udm_load_ispell_data -- Load ispell data
udm_open_stored -- Open connection to stored
udm_set_agent_param -- Set mnoGoSearch agent session parameters

이전 | 처음으로 | 다음
usleep | 위로 | udm_add_search_limit


udm_add_search_limit

(PHP 4 >= 4.0.5, PHP 5)

udm_add_search_limit -- Add various search limits

Description

bool udm_add_search_limit ( resource agent, int var, string val)

udm_add_search_limit() adds search restrictions. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

agent - a link to Agent, received after call to udm_alloc_agent().

var - defines parameter, indicating limit.

val - defines the value of the current parameter.

Possible var values:

  • UDM_LIMIT_URL - defines document URL limitations to limit the search through subsection of the database. It supports SQL % and _ LIKE wildcards, where % matches any number of characters, even zero characters, and _ matches exactly one character. E.g. http://www.example.___/catalog may stand for http://www.example.com/catalog and http://www.example.net/catalog.

  • UDM_LIMIT_TAG - defines site TAG limitations. In indexer-conf you can assign specific TAGs to various sites and parts of a site. Tags in mnoGoSearch 3.1.x are lines, that may contain metasymbols % and _. Metasymbols allow searching among groups of tags. E.g. there are links with tags ABCD and ABCE, and search restriction is by ABC_ - the search will be made among both of the tags.

  • UDM_LIMIT_LANG - defines document language limitations.

  • UDM_LIMIT_CAT - defines document category limitations. Categories are similar to tag feature, but nested. So you can have one category inside another and so on. You have to use two characters for each level. Use a hex number going from 0-F or a 36 base number going from 0-Z. Therefore a top-level category like 'Auto' would be 01. If it has a subcategory like 'Ford', then it would be 01 (the parent category) and then 'Ford' which we will give 01. Put those together and you get 0101. If 'Auto' had another subcategory named 'VW', then it's id would be 01 because it belongs to the 'Ford' category and then 02 because it's the next category. So it's id would be 0102. If VW had a sub category called 'Engine' then it's id would start at 01 again and it would get the 'VW' id 02 and 'Auto' id of 01, making it 010201. If you want to search for sites under that category then you pass it cat=010201 in the URL.

  • UDM_LIMIT_DATE - defines limitation by date the document was modified.

    Format of parameter value: a string with first character < or >, then with no space - date in unixtime format, for example:

    예 1.

    <?php
          Udm_Add_Search_Limit    ($udm, UDM_LIMIT_DATE, "&lt;908012006");
    ?>

    If > character is used, then the search will be restricted to those documents having a modification date greater than entered, if <, then smaller.

이전 | 처음으로 | 다음
mnoGoSearch Functions | 위로 | udm_alloc_agent_array


udm_alloc_agent_array

(PHP 4 >= 4.3.3, PHP 5)

udm_alloc_agent_array -- Allocate mnoGoSearch session

Description

resource udm_alloc_agent_array ( array databases)

udm_alloc_agent_array() will create an agent with multiple database connections. The array databases must contain one database URL per element, analog to the first parameter of udm_alloc_agent().

See also: udm_alloc_agent().

이전 | 처음으로 | 다음
udm_add_search_limit | 위로 | udm_alloc_agent


udm_alloc_agent

(PHP 4 >= 4.0.5, PHP 5)

udm_alloc_agent -- Allocate mnoGoSearch session

Description

resource udm_alloc_agent ( string dbaddr [, string dbmode])

Returns a mnogosearch agent identifier on success, FALSE on failure. This function creates a session with database parameters.

dbaddr - URL-style database description, with options (type, host, database name, port, user and password) to connect to SQL database. Do not matter for built-in text files support. Format for dbaddr: DBType:[//[DBUser[:DBPass]@]DBHost[:DBPort]]/DBName/. Currently supported DBType values are: mysql, pgsql, msql, solid, mssql, oracle, and ibase. Actually, it does not matter for native libraries support, but ODBC users should specify one of the supported values. If your database type is not supported, you may use unknown instead.

dbmode - You may select the SQL database mode of words storage. Possible values of dbmode are: single, multi, crc, or crc-multi. When single is specified, all words are stored in the same table. If multi is selected, words will be located in different tables depending of their lengths. "multi" mode is usually faster, but requires more tables in the database. If "crc" mode is selected, mnoGoSearch will store 32 bit integer word IDs calculated by CRC32 algorithm instead of words. This mode requires less disk space and it is faster comparing with "single" and "multi" modes. crc-multi uses the same storage structure with the "crc" mode, but also stores words in different tables depending on words lengths like in "multi" mode.

참고: dbaddr and dbmode must match those used during indexing.

참고: In fact this function does not open a connection to the database and thus does not check the entered login and password. Establishing a connection to the database and login/password verification is done by udm_find().

이전 | 처음으로 | 다음
udm_alloc_agent_array | 위로 | udm_api_version


udm_api_version

(PHP 4 >= 4.0.5, PHP 5)

udm_api_version -- Get mnoGoSearch API version.

Description

int udm_api_version ( void )

udm_api_version() returns the mnoGoSearch API version number. E.g. if mnoGoSearch 3.1.10 API is used, this function will return 30110.

This function allows the user to identify which API functions are available, e.g. udm_get_doc_count() function is only available in mnoGoSearch 3.1.11 or later.

예 1. udm_api_version() example

<?php
if (udm_api_version() >= 30111) {
    echo  "Total number of URLs in database: " . udm_get_doc_count($udm) . "<br />\n";
}
?>

이전 | 처음으로 | 다음
udm_alloc_agent | 위로 | udm_cat_list


udm_cat_list

(PHP 4 >= 4.0.6, PHP 5)

udm_cat_list -- Get all the categories on the same level with the current one.

Description

array udm_cat_list ( resource agent, string category)

Returns an array listing all categories of the same level as the current category in the categories tree. agent is the agent identifier returned by a previous call to >udm_alloc_agent().

The function can be useful for developing categories tree browser.

The returned array consists of pairs. Elements with even index numbers contain the category paths, odd elements contain the corresponding category names.

$array[0] will contain '020300'
  $array[1] will contain 'Audi'
  $array[2] will contain '020301'
  $array[3] will contain 'BMW'
  $array[4] will contain '020302'
  $array[5] will contain 'Opel'
  ...
 etc.

Following is an example of displaying links of the current level in format:
Audi
  BMW
  Opel
  ...

예 1. udm_cat_list()example

<?php
$cat_list_arr = udm_cat_list($udm_agent, $cat);
$cat_list = '';
for ($i=0; $i<count($cat_list_arr); $i+=2) {
    $path = $cat_list_arr[$i];
    $name = $cat_list_arr[$i+1];
    $cat_list .= "<a href=\"$_SERVER[PHP_SELF]?cat=$path\">$name</a><br />";
}
?>

See also udm_cat_path().

이전 | 처음으로 | 다음
udm_api_version | 위로 | udm_cat_path


udm_cat_path

(PHP 4 >= 4.0.6, PHP 5)

udm_cat_path -- Get the path to the current category.

Description

array udm_cat_path ( resource agent, string category)

Returns an array describing the path in the categories tree from the tree root to the current one, specified by category. agent is the agent identifier returned by a previous call to >udm_alloc_agent().

The returned array consists of pairs. Elements with even index numbers contain the category paths, odd elements contain the corresponding category names.

For example, the call $array=udm_cat_path($agent, '02031D'); may return the following array:
$array[0] will contain ''
 $array[1] will contain 'Root'
 $array[2] will contain '02'
 $array[3] will contain 'Sport'
 $array[4] will contain '0203'
 $array[5] will contain 'Auto'
 $array[4] will contain '02031D'
 $array[5] will contain 'Ferrari'

예 1. Specifying path to the current category in the following format: '> Root > Sport > Auto > Ferrari'

<?php
  $cat_path_arr = udm_cat_path($udm_agent, $cat);
  $cat_path = '';
  for ($i=0; $i<count($cat_path_arr); $i+=2) {
    $path = $cat_path_arr[$i];
    $name = $cat_path_arr[$i+1];
    $cat_path .= " > <a href=\"$_SERVER[PHP_SELF]?cat=$path\">$name</a> ";
  }
?>

See also udm_cat_list().

이전 | 처음으로 | 다음
udm_cat_list | 위로 | udm_check_charset


udm_check_charset

(PHP 4 >= 4.2.0, PHP 5)

udm_check_charset -- Check if the given charset is known to mnogosearch

Description

bool udm_check_charset ( resource agent, string charset)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
udm_cat_path | 위로 | udm_check_stored


udm_check_stored

(PHP 4 >= 4.2.0, PHP 5)

udm_check_stored -- Check connection to stored

Description

int udm_check_stored ( resource agent, int link, string doc_id)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
udm_check_charset | 위로 | udm_clear_search_limits


udm_clear_search_limits

(PHP 4 >= 4.0.5, PHP 5)

udm_clear_search_limits -- Clear all mnoGoSearch search restrictions

Description

bool udm_clear_search_limits ( resource agent)

udm_clear_search_limits() resets defined search limitations and returns TRUE.

See also udm_add_search_limit().

이전 | 처음으로 | 다음
udm_check_stored | 위로 | udm_close_stored


udm_close_stored

(PHP 4 >= 4.2.0, PHP 5)

udm_close_stored -- Close connection to stored

Description

int udm_close_stored ( resource agent, int link)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
udm_clear_search_limits | 위로 | udm_crc32


udm_crc32

(PHP 4 >= 4.2.0, PHP 5)

udm_crc32 -- Return CRC32 checksum of given string

Description

int udm_crc32 ( resource agent, string str)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
udm_close_stored | 위로 | udm_errno


udm_errno

(PHP 4 >= 4.0.5, PHP 5)

udm_errno -- Get mnoGoSearch error number

Description

int udm_errno ( resource agent)

udm_errno() returns mnoGoSearch error number, zero if no error.

agent - link to agent identifier, received after call to udm_alloc_agent().

Receiving numeric agent error code.

이전 | 처음으로 | 다음
udm_crc32 | 위로 | udm_error


udm_error

(PHP 4 >= 4.0.5, PHP 5)

udm_error -- Get mnoGoSearch error message

Description

string udm_error ( resource agent)

udm_error() returns mnoGoSearch error message, empty string if no error.

agent - link to agent identifier, received after call to udm_alloc_agent().

Receiving agent error message.

이전 | 처음으로 | 다음
udm_errno | 위로 | udm_find


udm_find

(PHP 4 >= 4.0.5, PHP 5)

udm_find -- Perform search

Description

resource udm_find ( resource agent, string query)

Returns a result link identifier on success, or FALSE on failure.

The search itself. The first argument - session, the next one - query itself. To find something just type words you want to find and press SUBMIT button. For example, "mysql odbc". You should not use quotes " in query, they are written here only to divide a query from other text. mnoGoSearch will find all documents that contain word "mysql" and/or word "odbc". Best documents having bigger weights will be displayed first. If you use search mode ALL, search will return documents that contain both (or more) words you entered. In case you use mode ANY, the search will return list of documents that contain any of the words you entered. If you want more advanced results you may use query language. You should select "bool" match mode in the search from.

mnoGoSearch understands the following boolean operators:

& - logical AND. For example, "mysql & odbc". mnoGoSearch will find any URLs that contain both "mysql" and "odbc".

| - logical OR. For example "mysql|odbc". mnoGoSearch will find any URLs, that contain word "mysql" or word "odbc".

~ - logical NOT. For example "mysql & ~odbc". mnoGoSearch will find URLs that contain word "mysql" and do not contain word "odbc" at the same time. Note that ~ just excludes given word from results. Query "~odbc" will find nothing!

() - group command to compose more complex queries. For example "(mysql | msql) & ~postgres". Query language is simple and powerful at the same time. Just consider query as usual boolean expression.

이전 | 처음으로 | 다음
udm_error | 위로 | udm_free_agent


udm_free_agent

(PHP 4 >= 4.0.5, PHP 5)

udm_free_agent -- Free mnoGoSearch session

Description

int udm_free_agent ( resource agent)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

agent - link to agent identifier, received ` after call to udm_alloc_agent().

Freeing up memory allocated for agent session.

이전 | 처음으로 | 다음
udm_find | 위로 | udm_free_ispell_data


udm_free_ispell_data

(PHP 4 >= 4.0.5, PHP 5)

udm_free_ispell_data -- Free memory allocated for ispell data

Description

bool udm_free_ispell_data ( int agent)

udm_free_ispell_data() always returns TRUE.

agent - agent link identifier, received after call to udm_alloc_agent().

참고: This function is supported beginning from version 3.1.12 of mnoGoSearch and it does not do anything in previous versions.

이전 | 처음으로 | 다음
udm_free_agent | 위로 | udm_free_res


udm_free_res

(PHP 4 >= 4.0.5, PHP 5)

udm_free_res -- Free mnoGoSearch result

Description

bool udm_free_res ( resource res)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

res - a link to result identifier, received after call to udm_find().

Freeing up memory allocated for results.

이전 | 처음으로 | 다음
udm_free_ispell_data | 위로 | udm_get_doc_count


udm_get_doc_count

(PHP 4 >= 4.0.5, PHP 5)

udm_get_doc_count -- Get total number of documents in database.

Description

int udm_get_doc_count ( resource agent)

udm_get_doc_count() returns the number of documents in the database.

agent - link to agent identifier, received after call to udm_alloc_agent().

참고: This function is supported only in mnoGoSearch 3.1.11 or later.

이전 | 처음으로 | 다음
udm_free_res | 위로 | udm_get_res_field


udm_get_res_field

(PHP 4 >= 4.0.5, PHP 5)

udm_get_res_field -- Fetch mnoGoSearch result field

Description

string udm_get_res_field ( resource res, int row, int field)

udm_get_res_field() returns result field value on success, FALSE on error.

res - a link to result identifier, received after call to udm_find().

row - the number of the link on the current page. May have values from 0 to UDM_PARAM_NUM_ROWS-1.

field - field identifier, may have the following values:

  • UDM_FIELD_URL - document URL field

  • UDM_FIELD_CONTENT - document Content-type field (for example, text/html).

  • UDM_FIELD_CATEGORY - document category field. Use udm_cat_path() to get full path to current category from the categories tree root. (This parameter is available only in PHP 4.0.6 or later).

  • UDM_FIELD_TITLE - document title field.

  • UDM_FIELD_KEYWORDS - document keywords field (from META KEYWORDS tag).

  • UDM_FIELD_DESC - document description field (from META DESCRIPTION tag).

  • UDM_FIELD_TEXT - document body text (the first couple of lines to give an idea of what the document is about).

  • UDM_FIELD_SIZE - document size.

  • UDM_FIELD_URLID - unique URL ID of the link.

  • UDM_FIELD_RATING - page rating (as calculated by mnoGoSearch).

  • UDM_FIELD_MODIFIED - last-modified field in unixtime format.

  • UDM_FIELD_ORDER - the number of the current document in set of found documents.

  • UDM_FIELD_CRC - document CRC.

이전 | 처음으로 | 다음
udm_get_doc_count | 위로 | udm_get_res_param


udm_get_res_param

(PHP 4 >= 4.0.5, PHP 5)

udm_get_res_param -- Get mnoGoSearch result parameters

Description

string udm_get_res_param ( resource res, int param)

udm_get_res_param() returns result parameter value on success, FALSE on error.

res - a link to result identifier, received after call to udm_find().

param - parameter identifier, may have the following values:

  • UDM_PARAM_NUM_ROWS - number of received found links on the current page. It is equal to UDM_PARAM_PAGE_SIZE for all search pages, on the last page - the rest of links.

  • UDM_PARAM_FOUND - total number of results matching the query.

  • UDM_PARAM_WORDINFO - information on the words found. E.g. search for "a good book" will return "a: stopword, good:5637, book: 120"

  • UDM_PARAM_SEARCHTIME - search time in seconds.

  • UDM_PARAM_FIRST_DOC - the number of the first document displayed on current page.

  • UDM_PARAM_LAST_DOC - the number of the last document displayed on current page.

이전 | 처음으로 | 다음
udm_get_res_field | 위로 | udm_hash32


udm_hash32

(PHP 4 >= 4.3.3, PHP 5)

udm_hash32 -- Return Hash32 checksum of gived string

Description

int udm_hash32 ( resource agent, string str)

udm_hash32() will take a string str and return a quite unique 32-bit hash number from it. Requires an allocated agent.

See also: udm_alloc_agent().

이전 | 처음으로 | 다음
udm_get_res_param | 위로 | udm_load_ispell_data


udm_load_ispell_data

(PHP 4 >= 4.0.5, PHP 5)

udm_load_ispell_data -- Load ispell data

Description

bool udm_load_ispell_data ( resource agent, int var, string val1, string val2, int flag)

udm_load_ispell_data() loads ispell data. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

agent - agent link identifier, received after call to udm_alloc_agent().

var - parameter, indicating the source for ispell data. May have the following values:

After using this function to free memory allocated for ispell data, please use udm_free_ispell_data(), even if you use UDM_ISPELL_TYPE_SERVER mode.

The fastest mode is UDM_ISPELL_TYPE_SERVER. UDM_ISPELL_TYPE_TEXT is slower and UDM_ISPELL_TYPE_DB is the slowest. The above pattern is TRUE for mnoGoSearch 3.1.10 - 3.1.11. It is planned to speed up DB mode in future versions and it is going to be faster than TEXT mode.

  • UDM_ISPELL_TYPE_DB - indicates that ispell data should be loaded from SQL. In this case, parameters val1 and val2 are ignored and should be left blank. flag should be equal to 1.

    참고: flag indicates that after loading ispell data from defined source it should be sorted (it is necessary for correct functioning of ispell). In case of loading ispell data from files there may be several calls to udm_load_ispell_data(), and there is no sense to sort data after every call, but only after the last one. Since in db mode all the data is loaded by one call, this parameter should have the value 1. In this mode in case of error, e.g. if ispell tables are absent, the function will return FALSE and code and error message will be accessible through udm_error() and udm_errno().

    예 1. udm_load_ispell_data()example

    <?php
    if (! udm_load_ispell_data($udm, UDM_ISPELL_TYPE_DB, '', '', 1)) {
          printf("Error #%d: '%s'\n", udm_errno($udm), udm_error($udm));
      exit;
    }
    ?>

  • UDM_ISPELL_TYPE_AFFIX - indicates that ispell data should be loaded from file and initiates loading affixes file. In this case val1 defines double letter language code for which affixes are loaded, and val2 - file path. Please note, that if a relative path entered, the module looks for the file not in UDM_CONF_DIR, but in relation to current path, i.e. to the path where the script is executed. In case of error in this mode, e.g. if file is absent, the function will return FALSE, and an error message will be displayed. Error message text cannot be accessed through udm_error() and udm_errno(), since those functions can only return messages associated with SQL. Please, see flag parameter description in UDM_ISPELL_TYPE_DB.

    예 2. udm_load_ispell_data() example

    <?php
    if ((! udm_load_ispell_data($udm, UDM_ISPELL_TYPE_AFFIX, 'en', '/opt/ispell/en.aff', 0)) ||
        (!     udm_load_ispell_data($udm, UDM_ISPELL_TYPE_AFFIX, 'ru', '/opt/ispell/ru.aff', 0)) ||
        (!     udm_load_ispell_data($udm, UDM_ISPELL_TYPE_SPELL, 'en', '/opt/ispell/en.dict', 0)) ||
        (!     udm_load_ispell_data($udm, UDM_ISPELL_TYPE_SPELL, 'ru', '/opt/ispell/ru.dict', 1))) {
        exit;
    }
    ?>

    참고: flag is equal to 1 only in the last call.

  • UDM_ISPELL_TYPE_SPELL - indicates that ispell data should be loaded from file and initiates loading of ispell dictionary file. In this case val1 defines double letter language code for which affixes are loaded, and val2 - file path. Please note, that if a relative path entered, the module looks for the file not in UDM_CONF_DIR, but in relation to current path, i.e. to the path where the script is executed. In case of error in this mode, e.g. if file is absent, the function will return FALSE, and an error message will be displayed. Error message text cannot be accessed through udm_error() and udm_errno(), since those functions can only return messages associated with SQL. Please, see flag parameter description in UDM_ISPELL_TYPE_DB.

    <?php
             if ((! Udm_Load_Ispell_Data($udm, UDM_ISPELL_TYPE_AFFIX, 'en', '/opt/ispell/en.aff', 0)) ||
            (!     Udm_Load_Ispell_Data($udm, UDM_ISPELL_TYPE_AFFIX, 'ru', '/opt/ispell/ru.aff', 0)) ||
            (!     Udm_Load_Ispell_Data($udm, UDM_ISPELL_TYPE_SPELL, 'en', '/opt/ispell/en.dict', 0)) ||
            (!     Udm_Load_Ispell_Data($udm, UDM_ISPELL_TYPE_SPELL, 'ru', '/opt/ispell/ru.dict', 1))) {
          exit;
          }
    ?>

    참고: flag is equal to 1 only in the last call.

  • UDM_ISPELL_TYPE_SERVER - enables spell server support. val1 parameter indicates address of the host running spell server. val2 ` is not used yet, but in future releases it is going to indicate number of port used by spell server. flag parameter in this case is not needed since ispell data is stored on spellserver already sorted.

    Spelld server reads spell-data from a separate configuration file (/usr/local/mnogosearch/etc/spelld.conf by default), sorts it and stores in memory. With clients server communicates in two ways: to indexer all the data is transferred (so that indexer starts faster), from search.cgi server receives word to normalize and then passes over to client (search.cgi) list of normalized word forms. This allows fastest, compared to db and text modes processing of search queries (by omitting loading and sorting all the spell data).

    udm_load_ispell_data() function in UDM_ISPELL_TYPE_SERVER mode does not actually load ispell data, but only defines server address. In fact, server is automatically used by udm_find() function when performing search. In case of errors, e.g. if spellserver is not running or invalid host indicated, there are no messages returned and ispell conversion does not work.

    참고: This function is available in mnoGoSearch 3.1.12 or later.

    Example:

    <?php
    if (!udm_load_ispell_data($udm, UDM_ISPELL_TYPE_SERVER, '', '', 1)) {
        echo     "Error loading ispell data from server<br />\n";
        exit;
    }
    ?>

이전 | 처음으로 | 다음
udm_hash32 | 위로 | udm_open_stored


udm_open_stored

(PHP 4 >= 4.2.0, PHP 5)

udm_open_stored -- Open connection to stored

Description

int udm_open_stored ( resource agent, string storedaddr)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
udm_load_ispell_data | 위로 | udm_set_agent_param


udm_set_agent_param

(PHP 4 >= 4.0.5, PHP 5)

udm_set_agent_param -- Set mnoGoSearch agent session parameters

Description

bool udm_set_agent_param ( resource agent, int var, string val)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. Defines mnoGoSearch session parameters.

The following parameters and their values are available:

  • UDM_PARAM_PAGE_NUM - used to choose search results page number (results are returned by pages beginning from 0, with UDM_PARAM_PAGE_SIZE results per page).

  • UDM_PARAM_PAGE_SIZE - number of search results displayed on one page.

  • UDM_PARAM_SEARCH_MODE - search mode. The following values available: UDM_MODE_ALL - search for all words; UDM_MODE_ANY - search for any word; UDM_MODE_PHRASE - phrase search; UDM_MODE_BOOL - boolean search. See udm_find() for details on boolean search.

  • UDM_PARAM_CACHE_MODE - turns on or off search result cache mode. When enabled, the search engine will store search results to disk. In case a similar search is performed later, the engine will take results from the cache for faster performance. Available values: UDM_CACHE_ENABLED, UDM_CACHE_DISABLED.

  • UDM_PARAM_TRACK_MODE - turns on or off trackquery mode. Since version 3.1.2 mnoGoSearch has a query tracking support. Note that tracking is implemented in SQL version only and not available in built-in database. To use tracking, you have to create tables for tracking support. For MySQL, use create/mysql/track.txt. When doing a search, front-end uses those tables to store query words, a number of found documents and current Unix timestamp in seconds. Available values: UDM_TRACK_ENABLED, UDM_TRACK_DISABLED.

  • UDM_PARAM_PHRASE_MODE - defines whether index database using phrases ("phrase" parameter in indexer.conf). Possible values: UDM_PHRASE_ENABLED and UDM_PHRASE_DISABLED. Please note, that if phrase search is enabled (UDM_PHRASE_ENABLED), it is still possible to do search in any mode (ANY, ALL, BOOL or PHRASE). In 3.1.10 version of mnoGoSearch phrase search is supported only in sql and built-in database modes, while beginning with 3.1.11 phrases are supported in cachemode as well.

    Examples of phrase search:

    "Arizona desert" - This query returns all indexed documents that contain "Arizona desert" as a phrase. Notice that you need to put double quotes around the phrase

  • UDM_PARAM_CHARSET - defines local charset. Available values: set of charsets supported by mnoGoSearch, e.g. koi8-r, cp1251, ...

  • UDM_PARAM_STOPFILE - Defines name and path to stopwords file. (There is a small difference with mnoGoSearch - while in mnoGoSearch if relative path or no path entered, it looks for this file in relation to UDM_CONF_DIR, the module looks for the file in relation to current path, i.e. to the path where the PHP script is executed.)

  • UDM_PARAM_STOPTABLE - Load stop words from the given SQL table. You may use several StopwordTable commands. This command has no effect when compiled without SQL database support.

  • UDM_PARAM_WEIGHT_FACTOR - represents weight factors for specific document parts. Currently body, title, keywords, description, url are supported. To activate this feature please use degrees of 2 in *Weight commands of the indexer.conf. Let's imagine that we have these weights:

    URLWeight 1
    BodyWeight 2
    TitleWeight 4
    KeywordWeight 8
    DescWeight 16

    As far as indexer uses bit OR operation for word weights when some word presents several time in the same document, it is possible at search time to detect word appearance in different document parts. Word which appears only in the body will have 00000010 aggregate weight (in binary notation). Word used in all document parts will have 00011111 aggregate weight.

    This parameter's value is a string of hex digits ABCDE. Each digit is a factor for corresponding bit in word weight. For the given above weights configuration:

    E is a factor for weight 1 (URL Weight bit)
    D is a factor for weight 2 (BodyWeight bit)
    C is a factor for weight 4 (TitleWeight bit)
    B is a factor for weight 8 (KeywordWeight bit)
    A is a factor for weight 16 (DescWeight bit)

    Examples:

    UDM_PARAM_WEIGHT_FACTOR=00001 will search through URLs only.

    UDM_PARAM_WEIGHT_FACTOR=00100 will search through Titles only.

    UDM_PARAM_WEIGHT_FACTOR=11100 will search through Title,Keywords,Description but not through URL and Body.

    UDM_PARAM_WEIGHT_FACTOR=F9421 will search through:

    Description with factor 15 (F hex)
    Keywords with factor 9
    Title with factor 4
    Body with factor 2
    URL with factor 1

    If UDM_PARAM_WEIGHT_FACTOR variable is omitted, original weight value is taken to sort results. For a given above weight configuration it means that document description has a most big weight 16.

  • UDM_PARAM_WORD_MATCH - word match. You may use this parameter to choose word match type. This feature works only in "single" and "multi" modes using SQL based and built-in database. It does not work in cachemode and other modes since they use word CRC and do not support substring search. Available values:

    UDM_MATCH_BEGIN - word beginning match;

    UDM_MATCH_END - word ending match;

    UDM_MATCH_WORD - whole word match;

    UDM_MATCH_SUBSTR - word substring match.

  • UDM_PARAM_MIN_WORD_LEN - defines minimal word length. Any word shorter this limit is considered to be a stopword. Please note that this parameter value is inclusive, i.e. if UDM_PARAM_MIN_WORD_LEN=3, a word 3 characters long will not be considered a stopword, while a word 2 characters long will be. Default value is 1.

  • UDM_PARAM_ISPELL_PREFIXES - Possible values: UDM_PREFIXES_ENABLED and UDM_PREFIXES_DISABLED, that respectively enable or disable using prefixes. E.g. if a word "tested" is in search query, also words like "test", "testing", etc. Only suffixes are supported by default. Prefixes usually change word meanings, for example if somebody is searching for the word "tested" one hardly wants "untested" to be found. Prefixes support may also be found useful for site's spelling checking purposes. In order to enable ispell, you have to load ispell data with udm_load_ispell_data().

  • UDM_PARAM_CROSS_WORDS - enables or disables crosswords support. Possible values: UDM_CROSS_WORDS_ENABLED and UDM_CROSS_WORDS_DISABLED.

    The crosswords feature allows to assign words between <a href="xxx"> and </a> also to a document this link leads to. It works in SQL database mode and is not supported in built-in database and Cachemode.

    참고: Crosswords are supported only in mnoGoSearch 3.1.11 or later.

  • UDM_PARAM_VARDIR - specifies a custom path to directory where indexer stores data when using built-in database and in cache mode. By default /var directory of mnoGoSearch installation is used. Can have only string values. The parameter is available in PHP 4.1.0 or later.

이전 | 처음으로 | 다음
udm_open_stored | 위로 | mSQL Functions


mSQL Functions

PHP 매뉴얼
이전 다음

LXIII. mSQL Functions

소개

These functions allow you to access mSQL database servers. More information about mSQL can be found at http://www.hughes.com.au/.

설치

In order to have these functions available, you must compile PHP with msql support by using the --with-msql[=DIR] option. DIR is the mSQL base install directory, defaults to /usr/local/msql3.

Note to Win32 Users: In order to enable this module on a Windows environment, you must copy msql.dll from the DLL folder of the PHP/Win32 binary package to the SYSTEM32 folder of your windows machine. (Ex: C:\WINNT\SYSTEM32 or C:\WINDOWS\SYSTEM32)

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. mSQL configuration options

Name | Default | Changeable
msql.allow_persistent | "On" | PHP_INI_SYSTEM
msql.max_persistent | "-1" | PHP_INI_SYSTEM
msql.max_links | "-1" | PHP_INI_SYSTEM
For further details and definition of the PHP_INI_* constants see ini_set().

위 설정 지시어에 대한 간단한 설명입니다.

msql.allow_persistent boolean

Whether to allow persistent mSQL connections.

msql.max_persistent integer

The maximum number of persistent mSQL connections per process.

msql.max_links integer

The maximum number of mSQL connections per process, including persistent connections.

리소스 종류

There are two resource types used in the mSQL module. The first one is the link identifier for a database connection, the second a resource which holds the result of a query.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

MSQL_ASSOC (integer)

MSQL_NUM (integer)

MSQL_BOTH (integer)

예제

This simple example shows how to connect, execute a query, print resulting rows and disconnect from a mSQL database.

예 1. mSQL usage example

<?php
/* Connecting, selecting database */
$link = msql_connect('localhost', 'username', 'password')
    or die('Could not connect : ' . msql_error($link));

msql_select_db('database')
    or die('Could not select database', $link);

/* Issue SQL query */
$query = 'SELECT * FROM my_table';
$result = msql_query($query, $link) or die('Query failed : ' . msql_error($link));

/* Printing results in HTML */
echo "<table>\n";
while ($row = msql_fetch_array($result, MSQL_ASSOC)) {
    echo "\t<tr>\n";
    foreach ($row as $col_value) {
        echo "\t\t<td>$col_value</td>\n";
    }
    echo "\t</tr>\n";
}
echo "</table>\n";

/* Free result set */
msql_free_result($result);

/* Close connection */
msql_close($link);
?>

차례
msql_affected_rows -- Returns number of affected rows
msql_close -- Close mSQL connection
msql_connect -- Open mSQL connection
msql_create_db -- Create mSQL database
msql_createdb -- Alias of msql_create_db()
msql_data_seek -- Move internal row pointer
msql -- Send mSQL query
msql_dbname -- Alias of msql_result()
msql_drop_db -- Drop (delete) mSQL database
msql_error -- Returns error message of last msql call
msql_fetch_array -- Fetch row as array
msql_fetch_field -- Get field information
msql_fetch_object -- Fetch row as object
msql_fetch_row -- Get row as enumerated array
msql_field_flags -- Get field flags
msql_field_len -- Get field length
msql_field_name -- Get field name
msql_field_seek -- Set field offset
msql_field_table -- Get table name for field
msql_field_type -- Get field type
msql_fieldflags -- Alias of msql_field_flags()
msql_fieldlen -- Alias of msql_field_len()
msql_fieldname -- Alias of msql_field_name()
msql_fieldtable -- Alias of msql_field_table()
msql_fieldtype -- Alias of msql_field_type()
msql_free_result -- Free result memory
msql_list_dbs -- List mSQL databases on server
msql_list_fields -- List result fields
msql_list_tables -- List tables in an mSQL database
msql_num_fields -- Get number of fields in result
msql_num_rows -- Get number of rows in result
msql_numfields -- Alias of msql_num_fields()
msql_numrows -- Alias of msql_num_rows()
msql_pconnect -- Open persistent mSQL connection
msql_query -- Send mSQL query
msql_regcase -- Alias of sql_regcase()
msql_result -- Get result data
msql_select_db -- Select mSQL database
msql_tablename -- Alias of msql_result()
msql -- Alias of msql_db_query()

이전 | 처음으로 | 다음
udm_set_agent_param | 위로 | msql_affected_rows


msql_affected_rows

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

msql_affected_rows -- Returns number of affected rows

Description

int msql_affected_rows ( resource query_identifier)

Returns number of affected ("touched") rows by a specific query (i.e. the number of rows returned by a SELECT, the number of rows modified by an update, or the number of rows removed by a delete).

See also: msql_query().

이전 | 처음으로 | 다음
mSQL Functions | 위로 | msql_close


msql_close

(PHP 3, PHP 4 , PHP 5)

msql_close -- Close mSQL connection

Description

int msql_close ( [resource link_identifier])

msql_close() closes the link to a mSQL database that's associated with the specified link identifier. If the link identifier isn't specified, the last opened link is assumed.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

Note that this isn't usually necessary, as non-persistent open links are automatically closed at the end of the script's execution.

msql_close() will not close persistent links generated by msql_pconnect().

See also: msql_connect() and msql_pconnect().

이전 | 처음으로 | 다음
msql_affected_rows | 위로 | msql_connect


msql_connect

(PHP 3, PHP 4 , PHP 5)

msql_connect -- Open mSQL connection

Description

int msql_connect ( [string hostname [, string username [, string password]]])

msql_connect() establishes a connection to a mSQL server. The hostname parameter can also include a port number. e.g. "hostname:port". It defaults to 'localhost'.

Returns a positive mSQL link identifier on success, or FALSE on error.

In case a second call is made to msql_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned.

The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling msql_close().

See also msql_pconnect() and msql_close().

이전 | 처음으로 | 다음
msql_close | 위로 | msql_create_db


msql_create_db

(PHP 3, PHP 4 , PHP 5)

msql_create_db -- Create mSQL database

Description

bool msql_create_db ( string database_name [, resource link_identifier])

msql_create_db() attempts to create a new database on the server associated with the specified link_identifier.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also msql_drop_db().

이전 | 처음으로 | 다음
msql_connect | 위로 | msql_createdb


msql_createdb

msql_createdb -- Alias of msql_create_db()

Description

This function is an alias of msql_create_db().

이전 | 처음으로 | 다음
msql_create_db | 위로 | msql_data_seek


msql_data_seek

(PHP 3, PHP 4 , PHP 5)

msql_data_seek -- Move internal row pointer

Description

bool msql_data_seek ( resource query_identifier, int row_number)

msql_data_seek() moves the internal row pointer of the mSQL result associated with the specified query identifier to point to the specified row number. The next call to msql_fetch_row() would return that row.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also msql_fetch_row().

이전 | 처음으로 | 다음
msql_createdb | 위로 | msql


msql

(PHP 3, PHP 4 , PHP 5)

msql -- Send mSQL query

Description

resouce msql_db_query ( string database, string query [, resource link_identifier])

Returns a positive mSQL query identifier to the query result, or FALSE on error.

msql_db_query() selects a database and executes a query on it. If the optional link_identifier is not specified, the function will try to find an open link to the mSQL server; if no such link is found it will try to create one as if msql_connect() was called with no arguments.

See also msql_connect().

이전 | 처음으로 | 다음
msql_data_seek | 위로 | msql_dbname


msql_dbname

msql_dbname -- Alias of msql_result()

Description

This function is an alias of msql_result().

이전 | 처음으로 | 다음
msql | 위로 | msql_drop_db


msql_drop_db

(PHP 3, PHP 4 , PHP 5)

msql_drop_db -- Drop (delete) mSQL database

Description

int msql_drop_db ( string database_name [, resource link_identifier])

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

msql_drop_db() attempts to drop (remove) an entire database from the server associated with the specified link identifier.

See also: msql_create_db().

이전 | 처음으로 | 다음
msql_dbname | 위로 | msql_error


msql_error

(PHP 3, PHP 4 , PHP 5)

msql_error -- Returns error message of last msql call

Description

string msql_error ( [resource link_identifier])

msql_error() returns the last issued error by the mSQL server or an empty string if no error was issued. If no link is explicitly passed, the last successful open link will be used to retrieve the error message. Note that only the last error message is accessible with msql_error().

이전 | 처음으로 | 다음
msql_drop_db | 위로 | msql_fetch_array


msql_fetch_array

(PHP 3, PHP 4 , PHP 5)

msql_fetch_array -- Fetch row as array

Description

int msql_fetch_array ( int query_identifier [, int result_type])

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

msql_fetch_array() is an extended version of msql_fetch_row(). In addition to storing the data in the numeric indices of the result array, it also stores the data in associative indices, using the field names as keys.

The second optional argument result_type in msql_fetch_array() is a constant and can take the following values: MSQL_ASSOC, MSQL_NUM, and MSQL_BOTH with MSQL_BOTH being the default.

Be careful if you are retrieving results from a query that may return a record that contains only one field that has a value of 0 (or an empty string, or NULL).

An important thing to note is that using msql_fetch_array() is NOT significantly slower than using msql_fetch_row(), while it provides a significant added value.

See also msql_fetch_row() and msql_fetch_object().

이전 | 처음으로 | 다음
msql_error | 위로 | msql_fetch_field


msql_fetch_field

(PHP 3, PHP 4 , PHP 5)

msql_fetch_field -- Get field information

Description

object msql_fetch_field ( resource query_identifier, int field_offset)

Returns an object containing field information

msql_fetch_field() can be used in order to obtain information about fields in a certain query result. If the field offset isn't specified, the next field that wasn't yet retrieved by msql_fetch_field() is retrieved.

The properties of the object are:

  • name - column name

  • table - name of the table the column belongs to

  • not_null - 1 if the column cannot be NULL

  • primary_key - 1 if the column is a primary key

  • unique - 1 if the column is a unique key

  • type - the type of the column

See also msql_field_seek().

이전 | 처음으로 | 다음
msql_fetch_array | 위로 | msql_fetch_object


msql_fetch_object

(PHP 3, PHP 4 , PHP 5)

msql_fetch_object -- Fetch row as object

Description

int msql_fetch_object ( int query_identifier)

Returns an object with properties that correspond to the fetched row, or FALSE if there are no more rows.

msql_fetch_object() is similar to msql_fetch_array(), with one difference - an object is returned, instead of an array. Indirectly, that means that you can only access the data by the field names, and not by their offsets (numbers are illegal property names).

Speed-wise, the function is identical to msql_fetch_array(), and almost as quick as msql_fetch_row() (the difference is insignificant).

See also: msql_fetch_array() and msql_fetch_row().

이전 | 처음으로 | 다음
msql_fetch_field | 위로 | msql_fetch_row


msql_fetch_row

(PHP 3, PHP 4 , PHP 5)

msql_fetch_row -- Get row as enumerated array

Description

array msql_fetch_row ( resource query_identifier)

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

msql_fetch_row() fetches one row of data from the result associated with the specified query identifier. The row is returned as an array. Each result column is stored in an array offset, starting at offset 0.

Subsequent call to msql_fetch_row() would return the next row in the result set, or FALSE if there are no more rows.

See also: msql_fetch_array(),
msql_fetch_object(),
msql_data_seek(), and
msql_result().

이전 | 처음으로 | 다음
msql_fetch_object | 위로 | msql_field_flags


msql_field_flags

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

msql_field_flags -- Get field flags

Description

string msql_field_flags ( resource query_identifier, int field_offset)

msql_field_flags() returns the field flags of the specified field. Currently this is either, "not NULL", "primary key", a combination of the two or "" (an empty string).

이전 | 처음으로 | 다음
msql_fetch_row | 위로 | msql_field_len


msql_field_len

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

msql_field_len -- Get field length

Description

int msql_field_len ( resource query_identifier, int field_offset)

msql_field_len() returns the length of the specified field or FALSE on error.

이전 | 처음으로 | 다음
msql_field_flags | 위로 | msql_field_name


msql_field_name

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

msql_field_name -- Get field name

Description

string msql_field_name ( resource query_identifier, int field)

msql_field_name() returns the name of the specified field from the result resource query_identifier. msql_field_name($result, 2); will return the name of the second field in the result set associated with the result identifier.

이전 | 처음으로 | 다음
msql_field_len | 위로 | msql_field_seek


msql_field_seek

(PHP 3, PHP 4 , PHP 5)

msql_field_seek -- Set field offset

Description

int msql_field_seek ( int query_identifier, int field_offset)

Seeks to the specified field offset. If the next call to msql_fetch_field() won't include a field offset, this field would be returned.

This function returns FALSE on failure.

See also: msql_fetch_field().

이전 | 처음으로 | 다음
msql_field_name | 위로 | msql_field_table


msql_field_table

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

msql_field_table -- Get table name for field

Description

int msql_field_table ( int query_identifier, int field)

Returns the name of the table field was fetched from.

This function returns FALSE on failure.

이전 | 처음으로 | 다음
msql_field_seek | 위로 | msql_field_type


msql_field_type

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

msql_field_type -- Get field type

Description

string msql_field_type ( resource query_identifier, int field_offset)

msql_field_type() is similar to the msql_field_name() function. The arguments are identical, but the field type is returned. This will be one of "int", "char" or "real".

This function returns FALSE on failure.

이전 | 처음으로 | 다음
msql_field_table | 위로 | msql_fieldflags


msql_fieldflags

msql_fieldflags -- Alias of msql_field_flags()

Description

This function is an alias of msql_field_flags().

이전 | 처음으로 | 다음
msql_field_type | 위로 | msql_fieldlen


msql_fieldlen

msql_fieldlen -- Alias of msql_field_len()

Description

This function is an alias of msql_field_len().

이전 | 처음으로 | 다음
msql_fieldflags | 위로 | msql_fieldname


msql_fieldname

msql_fieldname -- Alias of msql_field_name()

Description

This function is an alias of msql_field_name().

이전 | 처음으로 | 다음
msql_fieldlen | 위로 | msql_fieldtable


msql_fieldtable

msql_fieldtable -- Alias of msql_field_table()

Description

This function is an alias of msql_field_table().

이전 | 처음으로 | 다음
msql_fieldname | 위로 | msql_fieldtype


msql_fieldtype

msql_fieldtype -- Alias of msql_field_type()

Description

This function is an alias of msql_field_type().

이전 | 처음으로 | 다음
msql_fieldtable | 위로 | msql_free_result


msql_free_result

(PHP 3, PHP 4 , PHP 5)

msql_free_result -- Free result memory

Description

int msql_free_result ( resource query_identifier)

msql_free_result() frees the memory associated with query_identifier. When PHP completes a request, this memory is freed automatically, so you only need to call this function when you want to make sure you don't use too much memory while the script is running.

For downward compatibility, the alias named msql_freeresult() may be used. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
msql_fieldtype | 위로 | msql_list_dbs


msql_list_dbs

(PHP 3, PHP 4 , PHP 5)

msql_list_dbs -- List mSQL databases on server

Description

resource msql_list_dbs ( [resource link_identifier])

msql_list_dbs() will return a result pointer containing the databases available from the current msql daemon. Use the msql_result() function to traverse this result pointer.

For downward compatibility, the alias named msql_listtables() may be used. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
msql_free_result | 위로 | msql_list_fields


msql_list_fields

(PHP 3, PHP 4 , PHP 5)

msql_list_fields -- List result fields

Description

resource msql_list_fields ( string database, string tablename [, resource link_identifier])

msql_list_fields() retrieves information about the given tablename. The returned result set can be traversed with any function that fetches result sets, such as msql_fetch_array().

This function returns FALSE on failure.

For downward compatibility, the alias named msql_listfields() may be used. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
msql_list_dbs | 위로 | msql_list_tables


msql_list_tables

(PHP 3, PHP 4 , PHP 5)

msql_list_tables -- List tables in an mSQL database

Description

resource msql_list_tables ( string database [, resource link_identifier])

msql_list_tables() lists the tables on the specified database. It returns a result set which may be traversed with any function that fetches result sets, such as msql_fetch_array().

This function returns FALSE on failure.

For downward compatibility, the alias named msql_listtables() may be used. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
msql_list_fields | 위로 | msql_num_fields


msql_num_fields

(PHP 3, PHP 4 , PHP 5)

msql_num_fields -- Get number of fields in result

Description

int msql_num_fields ( resource query_identifier)

msql_num_fields() returns the number of fields in a result set.

For downwards compatability, the alias named msql_numfields() may be used. This, however, is deprecated and not recommended.

See also: msql_query(),
msql_fetch_field(), and
msql_num_rows().

이전 | 처음으로 | 다음
msql_list_tables | 위로 | msql_num_rows


msql_num_rows

(PHP 3, PHP 4 , PHP 5)

msql_num_rows -- Get number of rows in result

Description

int msql_num_rows ( resource query_identifier)

msql_num_rows() returns the number of rows in a result set.

For downwards compatability, the alias named msql_numrows() may be used. This, however is deprecated and not recommended.

See also: msql_db_query() and msql_query().

이전 | 처음으로 | 다음
msql_num_fields | 위로 | msql_numfields


msql_numfields

msql_numfields -- Alias of msql_num_fields()

Description

This function is an alias of msql_num_fields().

이전 | 처음으로 | 다음
msql_num_rows | 위로 | msql_numrows


msql_numrows

msql_numrows -- Alias of msql_num_rows()

Description

This function is an alias of msql_num_rows().

이전 | 처음으로 | 다음
msql_numfields | 위로 | msql_pconnect


msql_pconnect

(PHP 3, PHP 4 , PHP 5)

msql_pconnect -- Open persistent mSQL connection

Description

int msql_pconnect ( [string server [, string username [, string password]]])

msql_pconnect() acts very much like msql_connect() with two major differences.

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (msql_close() will not close links established by msql_pconnect()).

Returns a positive mSQL persistent link identifier on success, or FALSE on error.

이전 | 처음으로 | 다음
msql_numrows | 위로 | msql_query


msql_query

(PHP 3, PHP 4 , PHP 5)

msql_query -- Send mSQL query

Description

resource msql_query ( string query [, resource link_identifier])

msql_query() sends a query to the currently active database on the server that's associated with the specified link identifier. If the link identifier isn't specified, the last opened link is assumed. If no link is open, the function tries to establish a link as if msql_connect() was called, and use it.

Returns a positive mSQL query identifier on success, or FALSE on error.

예 1. msql_query() example

<?php
$link = msql_connect("dbserver")
   or die("unable to connect to msql server: " . msql_error());
msql_select_db("db", $link)
   or die("unable to select database 'db': " . msql_error());

$result = msql_query("SELECT * FROM table WHERE id=1", $link);
if (!$result) {
   die("query failed: " . msql_error());
}

while ($row = msql_fetch_array($result)) {
    echo $row["id"];
}
?>

See also
msql_db_query(),
msql_select_db(), and
msql_connect().

이전 | 처음으로 | 다음
msql_pconnect | 위로 | msql_regcase


msql_regcase

msql_regcase -- Alias of sql_regcase()

Description

This function is an alias of sql_regcase().

이전 | 처음으로 | 다음
msql_query | 위로 | msql_result


msql_result

(PHP 3, PHP 4 , PHP 5)

msql_result -- Get result data

Description

string msql_result ( resource query_identifier, int row [, mixed field])

Returns the contents of the cell at the row and offset in the specified mSQL result set.

msql_result() returns the contents of one cell from a mSQL result set. The field argument can be the field's offset, or the field's name, or the field's table dot field's name (fieldname.tablename). If the column name has been aliased ('select foo as bar from ...'), use the alias instead of the column name.

When working on large result sets, you should consider using one of the functions that fetch an entire row (specified below). As these functions return the contents of multiple cells in one function call, they are often much quicker than msql_result(). Also, note that specifying a numeric offset for the field argument is much quicker than specifying a fieldname or tablename.fieldname argument.

Recommended high-performance alternatives:
msql_fetch_row(),
msql_fetch_array(), and
msql_fetch_object().

For downward compatibility, the aliases named msql(), msql_tablename(), and msql_dbname() may be used. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
msql_regcase | 위로 | msql_select_db


msql_select_db

(PHP 3, PHP 4 , PHP 5)

msql_select_db -- Select mSQL database

Description

bool msql_select_db ( string database_name [, resource link_identifier])

msql_select_db() sets the current active database on the server that's associated with the specified link_identifier. If no link identifier is specified, the last opened link is assumed. If no link is open, the function will try to establish a link as if msql_connect() was called, and use it.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

Subsequent calls to msql_query() will be made on the active database.

For downward compatibility, the alias named msql_selectdb() may be used. This, however, is deprecated and not recommended.

See also
msql_connect(),
msql_pconnect(), and
msql_query().

이전 | 처음으로 | 다음
msql_result | 위로 | msql_tablename


msql_tablename

msql_tablename -- Alias of msql_result()

Description

This function is an alias of msql_result().

이전 | 처음으로 | 다음
msql_select_db | 위로 | msql


msql

msql -- Alias of msql_db_query()

Description

This function is an alias of msql_db_query().

이전 | 처음으로 | 다음
msql_tablename | 위로 | MySQL 함수


MySQL 함수

PHP 매뉴얼
이전 다음

LXIV. MySQL 함수

소개

이 함수들은 MySQL 데이터베이스 서버에 접근할 수 있도록 합니다. MySQL에 대한 정보는 http://www.mysql.com/에서 확인할 수 있습니다.

MySQL 문서는 http://dev.mysql.com/doc/에서 볼 수 있습니다.

요구 사항

이 함수들을 사용하려면, PHP가 MySQL을 지원하도록 컴파일해야 합니다.

설치

설정 옵션 --with-mysql[=DIR]을 사용하여 PHP가 MySQL 데이터베이스 접근을 활성화합니다.

PHP 4에서는, 옵션 --with-mysql은 기본값으로 활성화되어 있습니다. 이 기본 행동을 비활성화하기 위해서, 설정 옵션 --without-mysql을 사용할 수 있습니다. 또한 PHP 4에서는, MySQL 설치 DIR 경로를 지정하지 않고 MySQL을 활성화하면, PHP는 번들된 MySQL 클라이언트 라이브러리를 사용합니다. 윈도우즈에서는, DLL 없이, 단순히 PHP 4에 포함되어 있습니다. MySQL을 사용하는 다른 어플리케이션(예를들면, auth-mysql)을 사용하는 유저는 번들된 라이브러리를 사용하지 말고, 다음 방법으 MySQL의 설치 디렉토리 경로를 지정해야 합니다: --with-mysql=/path/to/mysql. 이는 PHP가 MySQL에 의해 설치한 클라이언트 라이브러리를 사용하도록 강제해서, 혼동을 피하게 합니다.

PHP 5에서는, MySQL은 더이상 기본값으로 활성화되어있지 않고, MySQL 라이브러리도 PHP에 번들되어 있지 않습니다. 자세한 이유에 대해서는 FAQ를 읽어보십시오.

MySQL 확장은 MySQL 4.1.0 이상의 모든 기능을 지원하지 않습니다. 대신, MySQLi를 사용하십시오.

mysqli 확장과 함께 mysql 확장을 설치하려 할 때는, 혼동을 피하기 위해 같은 클라이언트 라이브러리를 사용해야 합니다.

주의

레코드 확장과 함께 이 확장을 로드할 때, PHP의 충돌과 시작 문제가 발생할 수 있습니다. 자세한 정보는 레코드 확장을 참고하십시오.

참고: latin(기본값) 외의 문자셋이 필요하면, 문자셋 지원으로 컴파일한 외부(번들이 아닌) libmysql을 설치해야 합니다.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. MySQL 설정 옵션

이름 | 기본값 | 변경가능성
mysql.allow_persistent | "On" | PHP_INI_SYSTEM
mysql.max_persistent | "-1" | PHP_INI_SYSTEM
mysql.max_links | "-1" | PHP_INI_SYSTEM
mysql.default_port | NULL | PHP_INI_ALL
mysql.default_socket | NULL | PHP_INI_ALL
mysql.default_host | NULL | PHP_INI_ALL
mysql.default_user | NULL | PHP_INI_ALL
mysql.default_password | NULL | PHP_INI_ALL
mysql.connect_timeout | "0" | PHP_INI_SYSTEM
PHP_INI_* 상수에 대한 자세한 내용 및 정의는 ini_set()을 참고하십시오

위 설정 지시어에 대한 간단한 설명입니다.

mysql.allow_persistent boolean

MySQL에 지속 접속의 허용 여부.

mysql.max_persistent integer

프로세스 당 MySQL 지속 접속의 최대수.

mysql.max_links integer

지속 접속을 포함하여, 프로세스 당 MySQL 접속의 최대수.

mysql.default_port string

다른 포트를 지정하지 않았을 때, 데이터베이스 서버 접속에 사용하는 기본 TCP 포트. 기본값이 설정되지 않으면, MYSQL_TCP_PORT 환경 변수, /etc/services의 mysql_tcp, 컴파일 시의 MYSQL_PORT 상수를 순차적으로 확인합니다. Win32에서는 MYSQL_PORT 상수만을 사용합니다.

mysql.default_socket string

다른 소켓 이름을 지정하지 않았을 때, 로컬 데이터베이스 서버 접속에 사용하는 기본 소켓 이름.

mysql.default_host string

다른 호스트를 지정하지 않았을 때, 데이터베이스 서버에 접속할 때 사용하는 기본 서버 호스트. 안전 모드에서는 적용하지 않습니다.

mysql.default_user string

다른 이름을 지정하지 않았을 때, 데이터베이스 서버 접속에 사용하는 기본 유저 이름. 안전 모드에서는 적용하지 않습니다.

mysql.default_password string

다른 패스워드를 지정하지 않았을 때, 데이터베이스 서버 접속에 사용하는 기본 패스워드. 안전 모드에서는 적용하지 않습니다.

mysql.connect_timeout integer

초로 나타낸 접속 시간 초과. 리눅스에서는 이 시간 초과를 서버로부터 첫번째 응답이 오기를 기다리는 데에도 사용합니다.

리소스 종류

MySQL 모듈에서 사용하는 두가지 자원형이 존재합니다. 첫번째는 데이터베이스 접속을 위한 연결 확인자, 두번째는 쿼리의 결과를 가지는 자원입니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

PHP 4.3.0부터 mysql_connect()과 mysql_pconnect()에 추가 클라이언트 플래그를 지정할 수 있습니다. 다음의 상수가 정의되어 있습니다:

표 2. MySQL client constants

상수 | 설명
MYSQL_CLIENT_COMPRESS | 압축 프로토콜을 사용합니다.
MYSQL_CLIENT_IGNORE_SPACE | 함수 이름 뒤의 공백을 허용합니다.
MYSQL_CLIENT_INTERACTIVE | 접속을 종료하기 전 비활동의 (wait_timeout 대신) interactive_timeout 초를 허용합니다.

mysql_fetch_array()은 반환 배열을 다른 형식으로 나타내기 위한 상수를 사용합니다. 다음의 상수가 정의되어 있습니다:

표 3. MySQL fetch constants

상수 | 설명
MYSQL_ASSOC | 배열 인덱스로 필드 이름을 가지는 배열로 컬럼을 반환합니다.
MYSQL_BOTH | 배열 인덱스로 숫자 인덱스와 필드 이름을 둘 다 가지는 배열로 컬럼을 반환합니다.
MYSQL_NUM | 필드에 대한 숫자 인덱스를 가지는 배열로 컬럼을 반환합니다. 인덱스는 결과의 첫번째 필드를 0으로 시작합니다.

예제

MySQL 데이터베이스에 접속하여, 쿼리를 실행하고, 결과열을 출력하고, 접속을 끊는 방법을 보여주는 간단한 예제입니다.

예 1. MySQL 확장 개요 예제

<?php
/* 접속하고, 데이터베이스를 선택 */
$link = mysql_connect("mysql_host", "mysql_user", "mysql_password")
    or die("접속할 수 없습니다 : " . mysql_error());
echo "접속 성공";
mysql_select_db("my_database") or die("데이터베이스를 선택할 수 없습니다.");

/* SQL 쿼리 실행하기 */
$query = "SELECT * FROM my_table";
$result = mysql_query($query) or die("쿼리 실패 : " . mysql_error());

/* HTML로 결과 출력하기 */
echo "<table>\n";
while ($line = mysql_fetch_array($result, MYSQL_ASSOC)) {
    echo "\t<tr>\n";
    foreach ($line as $col_value) {
        echo "\t\t<td>$col_value</td>\n";
    }
    echo "\t</tr>\n";
}
echo "</table>\n";

/* 결과셋 해제하기 */
mysql_free_result($result);

/* 접속 종료 */
mysql_close($link);
?>

차례
mysql_affected_rows -- 최근 MySQL 작업으로 처리된 행(row) 개수를 얻음
mysql_change_user -- 현 접속에서 로그인된 사용자를 변경
mysql_client_encoding -- Returns the name of the character set
mysql_close -- MySQL 접속을 닫음
mysql_connect -- MySQL 서버에 접속
mysql_create_db -- MySQL 데이터베이스를 생성
mysql_data_seek -- 내부적인 결과 포인터를 이동
mysql_db_name -- 데이터 결과를 얻음
mysql_db_query -- MySQL 질의문을 전송
mysql_drop_db -- MySQL 데이터베이스를 삭제
mysql_errno -- 최근 MySQL 작업으로 발생한 에러 번호를 반환
mysql_error -- 최근 실행된 MySQL 작업으로 발생한 에러 메시지를 반환
mysql_escape_string -- Escapes a string for use in a mysql_query.
mysql_fetch_array -- 결과를 필드이름 색인 또는 숫자 색인으로 된 배열로 반환
mysql_fetch_assoc -- 결과를 필드이름 색인으로 된 배열로 반환
mysql_fetch_field -- 결과로부터 열 정보를 얻어서 객체로 반환
mysql_fetch_lengths -- 결과로부터 각 출력의 길이를 반환
mysql_fetch_object -- 행(row)의 결과를 객체로 얻음
mysql_fetch_row -- 결과를 숫자색인으로 된 배열로 반환
mysql_field_flags -- 결과로부터 특정 필드(field)의 상태정보(flag)를 반환
mysql_field_len -- 특정 필드의 길이를 반환
mysql_field_name -- 결과로부터 특정 필드 이름을 반환
mysql_field_seek -- 특정 필드의 오프셋(offset)으로 위치(pointer)를 이동
mysql_field_table -- 특정 필드가 속한 테이블 이름을 얻음
mysql_field_type -- 결과로부터 특정 필드의 데이터 형(type) 정보를 반환
mysql_free_result -- Free result memory
mysql_get_client_info -- Get MySQL client info
mysql_get_host_info -- Get MySQL host info
mysql_get_proto_info -- Get MySQL protocol info
mysql_get_server_info -- Get MySQL server info
mysql_info -- Get information about the most recent query
mysql_insert_id -- 최근 INSERT 작업으로부터 생성된 identifier 값을 반환
mysql_list_dbs -- MySQL 서버에 있는 데이터베이스 이름을 반환
mysql_list_fields -- MySQL 결과의 필드 리스트로 반환
mysql_list_processes -- List MySQL processes
mysql_list_tables -- MySQL 데이터베이스에 있는 테이블 목록을 반환
mysql_num_fields -- 결과로부터 필드 개수를 반환
mysql_num_rows -- 결과로부터 열 개수를 반환
mysql_pconnect -- MySQL 서버와 영구적인 데이터베이스 접속
mysql_ping -- Ping a server connection or reconnect if there is no connection
mysql_query -- Send a MySQL query
mysql_real_escape_string -- Escapes special characters in a string for use in a SQL statement, taking into account the current charset of the connection.
mysql_result -- 결과 데이터를 반환
mysql_select_db -- MySQL 데이터베이스를 선택
mysql_stat -- Get current system status
mysql_tablename -- 필드의 테이블이름을 얻음
mysql_thread_id -- Return the current thread ID
mysql_unbuffered_query -- Send an SQL query to MySQL, without fetching and buffering the result rows

이전 | 처음으로 | 다음
msql | 위로 | mysql_affected_rows


mysql_affected_rows

(PHP 3, PHP 4 , PHP 5)

mysql_affected_rows -- 최근 MySQL 작업으로 처리된 행(row) 개수를 얻음

설명

int mysql_affected_rows ( [int link_identifier])

mysql_affected_rows()는 link identifier로 접속되어 있는 서버에서 최근 실행된 INSERT, UPDATE, DELETE 질의로 처리된 행의 개수를 돌려준다. 만약 link identifier 인자를 생략하면, 최근 열려진 link를 사용한다.

마지막 질의가 WHERE 절이 없는 DELETE 질의라면, 테이블의 모든 레코드가 삭제되더라도 이 함수는 0값을 돌려준다.

이 함수는 SELECT 문에는 동작하지 않으며, 레코드가 수정되는 경우에만 동작한다. SELECT 구문으로부터 돌려받은 줄의 개수를 얻으려면, mysql_num_rows()를 쓰면 된다.

이전 | 처음으로 | 다음
MySQL 함수 | 위로 | mysql_change_user


mysql_change_user

(PHP 3>= 3.0.13)

mysql_change_user -- 현 접속에서 로그인된 사용자를 변경

설명

int mysql_change_user ( string user, string password [, string database [, int link_identifier]])

mysql_change_user() 함수는 현재 사용중인 접속 또는 link identifier 인자로 주어진 접속에서 로그인된 사용자를 변경한다. 데이터베이스 이름이 지정되면, 사용자가 변경된 다음 이 데이터베이스가 기본값으로 되며, 그렇지 않을 경우 현재 데이터베이스가 사용된다. 변경할 사용자와 비밀번호 인증에 실패하게되면, 현재 접속된 사용자는 접속이 그대로 유지된다.

참고: 이 함수는 PHP 3.0.13 과 MySQL 3.23.3 이상에서만 동작한다.

이전 | 처음으로 | 다음
mysql_affected_rows | 위로 | mysql_client_encoding


mysql_client_encoding

(PHP 4 >= 4.3.0, PHP 5)

mysql_client_encoding -- Returns the name of the character set

Description

string mysql_client_encoding ( [resource link_identifier])

mysql_client_encoding() returns the default character set name for the current connection.

예 1. mysql_client_encoding() example

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
$charset = mysql_client_encoding($link);
printf("current character set is %s\n", $charset);
?>

The above example would produce the following output:

current character set is latin1

See also mysql_real_escape_string()

이전 | 처음으로 | 다음
mysql_change_user | 위로 | mysql_close


mysql_close

(PHP 3, PHP 4 , PHP 5)

mysql_close -- MySQL 접속을 닫음

설명

int mysql_close ( [int link_identifier])

반환값: 성공하면 TRUE값을 실패하면 FALSE값을 반환

mysql_close() link identifier와 관련된 MySQL 접속을 닫는다. link identifier를 지정하지 않으면 마지막 열려진 link를 사용한다.

mysql_close()는 비영구적으로 열려진 링크에서는 일반적으로 스크립트(script) 실행 마지막 부분에서 자동으로 종료되기 때문에 사용할 필요가 없다.

참고: mysql_close()은 mysql_pconnect()로 생성된 영구적으로 접속된 링크에서는 종료가 안될 것이다.

예 1. MySQL close 예제

<?php
    $link = mysql_connect ("kraemer", "marliesle", "secret")
        or die ("접속할 수 없습니다");
    print ("접속되었습니다");
    mysql_close ($link);
?>

참조: mysql_connect(), mysql_pconnect().

이전 | 처음으로 | 다음
mysql_client_encoding | 위로 | mysql_connect


mysql_connect

(PHP 3, PHP 4 , PHP 5)

mysql_connect -- MySQL 서버에 접속

설명

int mysql_connect ( [string server [, string username [, string password]]])

접속에 성공하면 MySQL link identifier를, 그렇지 않으면 에러 메시지를 반환한다.

mysql_connect()을 이용하여 MySQL 서버에 접속을 할 수 있다. 아래 나열된 기본값은 인자를 입력하지 않았을 때 대신 사용되는 값이다. host:port는 'localhost:3306'로, username은 서버 프로세스(server process)의 소유자로, 그리고 password는 공백 비밀번호로 대체된다.

hostname은 "hostname:port"와 같이 포트 번호를 포함할 수 있다. 또한 로컬호스트에서 ":/path/to/socket"와 같이 소켓으로도 사용할 수 있다.

참고: ":port"는 PHP 3.0B4에서 추가된 기능이다.

":/path/to/socket"은 PHP 3.0.10에 추가된 기능이다.

함수 이름 앞에 '@'를 붙임으로써 에러 메시지가 출력되지 않도록 할 수 있다.

동일한 인수로 mysql_connect()을 다시 호출하면, 새로운 link가 생성되는 것이 아니라, 이미 생성된 link identifier 값을 돌려받게 된다.

link는 스크립트 종료 부분에서 자동으로 닫히지만, mysql_close()을 사용하면 스크립트 끝부분이 아니더라도 종료가 가능하다.

예 1. MySQL 접속 예제

<?php
    $link = mysql_connect ("kraemer", "marliesle", "secret")
        or die ("접속할 수 없습니다");
    print ("접속되었습니다");
    mysql_close ($link);
?>

참조: mysql_pconnect(), mysql_close().

이전 | 처음으로 | 다음
mysql_close | 위로 | mysql_create_db


mysql_create_db

(PHP 3, PHP 4 , PHP 5)

mysql_create_db -- MySQL 데이터베이스를 생성

설명

int mysql_create_db ( string database name [, int link_identifier])

mysql_create_db()는 link identifier로 연결된 서버에 새로운 데이터베이스를 생성하도록 한다.

예 1. MySQL 데이터베이스 생성 예제

<?php
    $link = mysql_pconnect ("kron", "jutta", "geheim")
        or die ("Could not connect");
    if (mysql_create_db ("my_db")) {
        print ("데이터베이스를 생성하였습니다\n");
    } else {
        printf ("데이터베이스 생성 에러: %s\n", mysql_error ());
    }
?>

하위 호환성을 가지는 mysql_createdb() 함수 역시 사용 가능하다.

참조: mysql_drop_db().

이전 | 처음으로 | 다음
mysql_connect | 위로 | mysql_data_seek


mysql_data_seek

(PHP 3, PHP 4 , PHP 5)

mysql_data_seek -- 내부적인 결과 포인터를 이동

설명

int mysql_data_seek ( int result_identifier, int row_number)

반환값: 성공하면 TRUE, 실패하면 FALSE 반환.

mysql_data_seek() 함수는 MySQL 결과중 인자로 지정된 행번호를 이용하여 내부적인 행 포인터를 이동시켜준다. mysql_fetch_row()를 사용하여 행의 내용을 얻을 수 있다.

row_number는 0부터 시작된다.

예 1. MySQL 데이터 검색 예제

<?php
    $link = mysql_pconnect ("kron", "jutta", "geheim")
        or die ("접속할 수 없습니다");

    mysql_select_db ("samp_db")
        or die ("데이터베이스를 선택할 수 없습니다");

    $query = "SELECT last_name, first_name FROM friends";
    $result = mysql_query ($query)
        or die ("질의 실패");

    # fetch rows in reverse order

    for ($i = mysql_num_rows ($result) - 1; $i >=0; $i--) {
        if (!mysql_data_seek ($result, $i)) {
            printf ("%d 번 행을 검색할 수 없습니다\n", $i);
            continue;
        }

        if(!($row = mysql_fetch_object ($result)))
            continue;

        printf ("%s %s<BR>\n", $row->last_name, $row->first_name);
    }

    mysql_free_result ($result);
?>

이전 | 처음으로 | 다음
mysql_create_db | 위로 | mysql_db_name


mysql_db_name

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

mysql_db_name -- 데이터 결과를 얻음

설명

int mysql_db_name ( int result, int row [, mixed field])

mysql_db_name()은 mysql_list_dbs()를 실행한 결과를 첫번째 인자로 갖는다. row 인자는 첫번째 인자로부터 얻어진 결과값을 얻기위한 색인이다.

만약 에러가 발생하면 FALSE값을 돌려준다. mysql_errno()와 mysql_error()를 사용하여 에러 메시지 처리를 할 수 있다.

예 1. mysql_db_name() 예제

<?php
error_reporting(E_ALL);

mysql_connect('dbhost', 'username', 'password');
$db_list = mysql_list_dbs();

$i = 0;
$cnt = mysql_num_rows($db_list);
while ($i < $cnt) {
    echo mysql_db_name($db_list, $i) . "\n";
    $i++;
}
?>

하위 호환성이 있는 mysql_dbname()를 사용할 수 있으나 현재 사용되지 않는다.

이전 | 처음으로 | 다음
mysql_data_seek | 위로 | mysql_db_query


mysql_db_query

(PHP 3, PHP 4 , PHP 5)

mysql_db_query -- MySQL 질의문을 전송

설명

int mysql_db_query ( string database, string query [, int link_identifier])

반환값: MySQL 질의로 발생한 result identifier값을, 에러가 발생했을 경우 FALSE를 반환.

mysql_db_query()는 데이터베이스를 선택하고, 동시에 질의문을 실행한다. 만약 link identifier가 지정되지 않는다면, 함수는 MySQL 서버에서 접속된 링크를 찾을 것이며, 찾지 못할 경우에는 인자없이 실행된 mysql_connect()와 같이 link를 생성하여 사용한다.

참조: mysql_connect().

하위 호환성을 가지는 mysql() 함수 역시 사용 가능하다.

이전 | 처음으로 | 다음
mysql_db_name | 위로 | mysql_drop_db


mysql_drop_db

(PHP 3, PHP 4 , PHP 5)

mysql_drop_db -- MySQL 데이터베이스를 삭제

설명

int mysql_drop_db ( string database_name [, int link_identifier])

반환값: 성공하면 TRUE, 실패하면 FALSE.

mysql_drop_db() attempts to drop (remove) an entire database from the server associated with the specified link identifier.

참조: mysql_create_db(). 하위 호환성이 있는 mysql_dropdb() 함수 역시 사용 가능하다.

이전 | 처음으로 | 다음
mysql_db_query | 위로 | mysql_errno


mysql_errno

(PHP 3, PHP 4 , PHP 5)

mysql_errno -- 최근 MySQL 작업으로 발생한 에러 번호를 반환

설명

int mysql_errno ( [int link_identifier])

최근 실행된 MySQL 함수의 에러번호를, 에러가 없을 경우 0값을 반환한다.

한번 MySQL 데이터베이스로부터의 발생된 에러는 다시 경고 메시지를 나타내지는 않는다. 그러나, mysql_errno()를 사용하면 에러 코드(code)를 얻을 수 있다. 이 함수는 최근에 실행된 MySQL 함수(mysql_error()와 mysql_errno()를 제외한)로 발생된 에러 코드만 얻을 수 있다. 그러나, 다른 MySQL 함수를 사용하기 이전에 사용해야만 한다.

<?php
mysql_connect("marliesle");
echo mysql_errno().": ".mysql_error()."<BR>";
mysql_select_db("nonexistentdb");
echo mysql_errno().": ".mysql_error()."<BR>";
$conn = mysql_query("SELECT * FROM nonexistenttable");
echo mysql_errno().": ".mysql_error()."<BR>";
?>

See also: mysql_error()

이전 | 처음으로 | 다음
mysql_drop_db | 위로 | mysql_error


mysql_error

(PHP 3, PHP 4 , PHP 5)

mysql_error -- 최근 실행된 MySQL 작업으로 발생한 에러 메시지를 반환

설명

string mysql_error ( [int link_identifier])

MySQL 함수로 발생된 에러 메시지를 얻을 수 있으며, 에러가 발생하지 않았을 경우에는 '' (공백문자)를 얻을 수 있다.

한번 MySQL 데이터베이스로부터의 발생된 에러는 또다시 경고 메시지를 나타내지는 않는다. 대신, mysql_error()를 사용하면 에러 메시지를 얻을 수 있다. 이 함수는 최근에 실행된 MySQL 함수(mysql_error()과 mysql_errno()를 제외한)로 발생된 에러 메시지를 얻을 수 있다. 그러나 사용하기 위해서는 다른 MySQL 함수를 사용하기 이전에 사용해야 한다.

<?php
mysql_connect("marliesle");
echo mysql_errno().": ".mysql_error()."<BR>";
mysql_select_db("nonexistentdb");
echo mysql_errno().": ".mysql_error()."<BR>";
$conn = mysql_query("SELECT * FROM nonexistenttable");
echo mysql_errno().": ".mysql_error()."<BR>";
?>

참조: mysql_errno().

이전 | 처음으로 | 다음
mysql_errno | 위로 | mysql_escape_string


mysql_escape_string

(PHP 4 >= 4.0.3, PHP 5)

mysql_escape_string -- Escapes a string for use in a mysql_query.

Description

string mysql_escape_string ( string unescaped_string)

This function will escape the unescaped_string, so that it is safe to place it in a mysql_query().

참고: mysql_escape_string() does not escape % and _.

This function is identical to mysql_real_escape_string() except that mysql_real_escape_string() takes a connection handler and escapes the string according to the current character set. mysql_escape_string() does not take a connection argument and does not respect the current charset setting.

예 1. mysql_escape_string() example

<?php
$item = "Zak's Laptop";
$escaped_item = mysql_escape_string($item);
printf("Escaped string: %s\n", $escaped_item);
?>

The above example would produce the following output:

Escaped string: Zak\'s Laptop

See also mysql_real_escape_string(), addslashes() and the magic_quotes_gpc directive.

이전 | 처음으로 | 다음
mysql_error | 위로 | mysql_fetch_array


mysql_fetch_array

(PHP 3, PHP 4 , PHP 5)

mysql_fetch_array -- 결과를 필드이름 색인 또는 숫자 색인으로 된 배열로 반환

설명

array mysql_fetch_array ( int result [, int result_type])

데이터베이스 테이블로부터 가져온 행에 대응되는 배열로 돌려주고, 더이상 가져올 행이 없을 경우 FALSE를 반환한다.

mysql_fetch_array()는 mysql_fetch_row()에서 확장된 함수이다. 결과 배열에 자료가 저장되고 배열의 색인으로 번호가 사용된다. 또한, 배열의 색인으로 테이블의 필드 이름으로도 사용할 수 있다.

결과로 두 개 이상의 동일한 필드 이름을 가진 열이 있다면, 마지막 열이 우선권을 가진다. 동일한 다른 열을 사용하기 위해서는 색인 번호를 이용하거나 질의 문장에서 열의 별명을 주어 이용하여야 한다.

select t1.f1 as foo t2.f1 as bar from t1, t2

mysql_fetch_array()는 필드 이름으로 된 색인이 추가되지만, mysql_fetch_row() 보다 느려지지는 않는다.

mysql_fetch_array()에서 두번째 옵션 인자 result_type은 상수이고, MYSQL_ASSOC, MYSQL_NUM, MYSQL_BOTH와 같은 값을 가질 수 있다(PHP 3.0.7에 추가되었음).

참조: mysql_fetch_row(), mysql_fetch_assoc().

예 1. mysql_fetch_array()

<?php
mysql_connect ($host, $user, $password);
$result = mysql_db_query ("database","select user_id, fullname from table");
while ($row = mysql_fetch_array ($result)) {
    echo "user_id: ".$row["user_id"]."<br>\n";
    echo "user_id: ".$row[0]."<br>\n";
    echo "fullname: ".$row["fullname"]."<br>\n";
    echo "fullname: ".$row[1]."<br>\n";
}
mysql_free_result ($result);
?>

이전 | 처음으로 | 다음
mysql_escape_string | 위로 | mysql_fetch_assoc


mysql_fetch_assoc

(PHP 4 >= 4.0.3, PHP 5)

mysql_fetch_assoc -- 결과를 필드이름 색인으로 된 배열로 반환

설명

array mysql_fetch_assoc ( int result)

필드이름의 색인을 가진 배열로 돌려주고, 가져올 행이 없을 경우 FALSE값을 반환한다.

mysql_fetch_assoc()는 mysql_fetch_array()의 두번째 인자로 MYSQL_ASSOC를 사용한 경우과 동일하게 작동한다. 이 방식은 mysql_fetch_array()의 본래의 동작 방법이다. 만일 숫자 색인 방식과 필드이름 색인을 동시에 사용하려면, mysql_fetch_array()를 사용하면 된다.

결과로 두개 이상의 동일한 필드 이름을 가진 열(column)이 있다면, 마지막 열이 우선권을 가진다. 동일한 다른 열을 사용하기 위해서는 색인 번호도 추가된 mysql_fetch_array()를 사용해야할 것이다.

mysql_fetch_assoc()는 필드이름으로 된 색인이 추가되지만, mysql_fetch_row() 보다 느려지지는 않는다.

참조: mysql_fetch_row(), mysql_fetch_array().

예 1. mysql_fetch_assoc()

<?php
mysql_connect ($host, $user, $password);
$result = mysql_db_query ("database","select * from table");
while ($row = mysql_fetch_assoc ($result)) {
    echo $row["user_id"];
    echo $row["fullname"];
}
mysql_free_result ($result);
?>

이전 | 처음으로 | 다음
mysql_fetch_array | 위로 | mysql_fetch_field


mysql_fetch_field

(PHP 3, PHP 4 , PHP 5)

mysql_fetch_field -- 결과로부터 열 정보를 얻어서 객체로 반환

설명

object mysql_fetch_field ( int result [, int field_offset])

필드 정보가 포함된 객체로 반환한다.

mysql_fetch_field()는 특정 질의 결과로부터 필드 정보를 얻을 목적으로 사용할 수 있다. 만일, field_offset을 지정하지 않으면, mysql_fetch_field()에 의해 아직 얻지 못한 다음 필드 정보를 얻게 된다.

객체에 대한 특성은 다음과 같다.

  • name - 열(column) 이름

  • table - 열이 속해있는 테이블 이름

  • max_length - 열의 최대 길이

  • not_null - 열 값이 NULL이 아니면 1

  • primary_key - 열이 primary key이면 1

  • unique_key - 열이 unique key이면 1

  • multiple_key - 열이 non-unique key이면 1

  • numeric - 열이 숫자이면 1

  • blob - 열이 BLOB이면 1

  • type - 열의 타입

  • unsigned - 열이 부호없음(unsigned)이면 1

  • zerofill - 열이 0으로 채움(zero-filled)이면 1

예 1. mysql_fetch_field()

<?php
mysql_connect ($host, $user, $password)
    or die ("접속할 수 없습니다");
$result = mysql_db_query ("database", "select * from table")
    or die ("질의 실패");
# get column metadata
$i = 0;
while ($i < mysql_num_fields ($result)) {
    echo "Information for column $i:<BR>\n";
    $meta = mysql_fetch_field ($result);
    if (!$meta) {
        echo "어떠한 정보도 없습니다.<BR>\n";
    }
    echo "<PRE>
blob:         $meta->blob
max_length:   $meta->max_length
multiple_key: $meta->multiple_key
name:         $meta->name
not_null:     $meta->not_null
numeric:      $meta->numeric
primary_key:  $meta->primary_key
table:        $meta->table
type:         $meta->type
unique_key:   $meta->unique_key
unsigned:     $meta->unsigned
zerofill:     $meta->zerofill
</PRE>";
    $i++;
}
mysql_free_result ($result);
?>

참조: mysql_field_seek().

이전 | 처음으로 | 다음
mysql_fetch_assoc | 위로 | mysql_fetch_lengths


mysql_fetch_lengths

(PHP 3, PHP 4 , PHP 5)

mysql_fetch_lengths -- 결과로부터 각 출력의 길이를 반환

설명

array mysql_fetch_lengths ( int result)

반환값: 최근 mysql_fetch_row()로 얻은 행(row)의 각 필드 길이를 배열로 얻거나, 에러 발생시에는 FALSE값을 얻는다.

mysql_fetch_lengths()는
 최근 mysql_fetch_row(),
 mysql_fetch_array(),
 mysql_fetch_object()로 얻은 행으로부터
 각 열(column)의 길이를 색인값이 0으로 시작하는 배열로 저장하여 반환한다.

참조: mysql_fetch_row().

이전 | 처음으로 | 다음
mysql_fetch_field | 위로 | mysql_fetch_object


mysql_fetch_object

(PHP 3, PHP 4 , PHP 5)

mysql_fetch_object -- 행(row)의 결과를 객체로 얻음

설명

object mysql_fetch_object ( int result [, int result_type])

행(row)에 대응되는 객체로 돌려주고, 가져올 행이 없을 경우 FALSE를 반환한다.

mysql_fetch_object()는 mysql_fetch_array()와 유사하나, 배열 대신 객체로 얻는다는 차이점이 있다. 다시말해, 오프셋(offset)에 의해서가 아닌 필드이름으로 데이터를 접근할 수 있다는 것이다.

두번째 인자인 result_type에는 상수가 오며, MYSQL_ASSOC, MYSQL_NUM, MYSQL_BOTH 값을 가질 수 있다.

속도면에서, 이 함수는 mysql_fetch_array()와 비슷하고, mysql_fetch_row()만큼이나 빠르다. 그러나 큰 차이는 없다.

예 1. mysql_fetch_object() 예제

<?php
mysql_connect ($host, $user, $password);
$result = mysql_db_query ("database", "select * from table");
while ($row = mysql_fetch_object ($result)) {
    echo $row->user_id;
    echo $row->fullname;
}
mysql_free_result ($result);
?>

See also: mysql_fetch_array() and mysql_fetch_row().

이전 | 처음으로 | 다음
mysql_fetch_lengths | 위로 | mysql_fetch_row


mysql_fetch_row

(PHP 3, PHP 4 , PHP 5)

mysql_fetch_row -- 결과를 숫자색인으로 된 배열로 반환

설명

array mysql_fetch_row ( int result)

반환값: 행(row)에 대응되는 객체로 돌려주고, 가져올 값이 없을 경우 FALSE를 반환한다.

mysql_fetch_row()는 특정 result identifier로부터 한 행의 데이터를 가져오며, 배열로 얻을 수 있다. 각 결과 열(column)은 0부터 시작하는 숫자색인으로 저장된다.

mysql_fetch_row()를 실행하면, 다음 행 데이터를 돌려주며, 가져올 행이 없을 경우 FALSE를 반환한다.

참조: mysql_fetch_array(),
mysql_fetch_object(),
mysql_data_seek(),
mysql_fetch_lengths(),
mysql_result().

이전 | 처음으로 | 다음
mysql_fetch_object | 위로 | mysql_field_flags


mysql_field_flags

(PHP 3, PHP 4 , PHP 5)

mysql_field_flags -- 결과로부터 특정 필드(field)의 상태정보(flag)를 반환

설명

string mysql_field_flags ( int result, int field_offset)

mysql_field_flags()은 특정 필드의 상태정보를 반환한다. 상태정보는 한개의 공백으로 구분된 단일 단어로 출력되며, 이 값은 explode()에 의해 나눠서 볼 수 있다.

사용중인 MySQL 버전이 "not_null", "primary_key", "unique_key", "multiple_key", "blob", "unsigned", "zerofill", "binary", "enum", "auto_increment", "timestamp"를 지원한다면, 필드 상태정보에 따라 위의 단어들이 출력될 것이다.

하위 호환성이 있는 mysql_fieldflags()도 사용 가능하다.

이전 | 처음으로 | 다음
mysql_fetch_row | 위로 | mysql_field_len


mysql_field_len

(PHP 3, PHP 4 , PHP 5)

mysql_field_len -- 특정 필드의 길이를 반환

설명

int mysql_field_len ( int result, int field_offset)

mysql_field_len()은 특정 필드의 길이를 얻는다.

하위 호환성이 있는 mysql_fieldlen()도 사용 가능하다.

이전 | 처음으로 | 다음
mysql_field_flags | 위로 | mysql_field_name


mysql_field_name

(PHP 3, PHP 4 , PHP 5)

mysql_field_name -- 결과로부터 특정 필드 이름을 반환

설명

string mysql_field_name ( int result, int field_index)

mysql_field_name()은 특정 필드 색인값을 얻는다. result는 result identifier는 유효한 결과값이어야 하고, field_index는 필드의 숫자 오프셋(offset)이어야 한다.

참고: field_index는 0부터 시작하는 값이다.

예를들어, 세번째 필드의 색인은 2이고, 네번째 필드의 색인은 3이 된다.

예 1. mysql_field_name() example

// 테이블이 세개의 필드로 아래와 같이 세개의 필드로 이루어져 있을 때:
//   user_id
//   username
//   password.

$res = mysql_db_query("users", "select * from users", $link);

echo mysql_field_name($res, 0) . "\n";
echo mysql_field_name($res, 2);

위의 예제는 아래와 같이 출력될 것이다:

user_id
password

하위 호환성이 있는 mysql_fieldname()도 사용 가능하다.

이전 | 처음으로 | 다음
mysql_field_len | 위로 | mysql_field_seek


mysql_field_seek

(PHP 3, PHP 4 , PHP 5)

mysql_field_seek -- 특정 필드의 오프셋(offset)으로 위치(pointer)를 이동

설명

int mysql_field_seek ( int result, int field_offset)

특정 필드 오프셋을 검색하는데 사용된다. mysql_fetch_field()을 실행하면서 필드 오프셋을 설정하지 않으면, mysql_field_seek()이 돌려준 값으로 지정된다.

참조: mysql_fetch_field().

이전 | 처음으로 | 다음
mysql_field_name | 위로 | mysql_field_table


mysql_field_table

(PHP 3, PHP 4 , PHP 5)

mysql_field_table -- 특정 필드가 속한 테이블 이름을 얻음

설명

string mysql_field_table ( int result, int field_offset)

특정 필드가 속한 테이블 이름을 얻는다.

하위 호환성이 있는 mysql_fieldtable()도 사용 가능하다.

이전 | 처음으로 | 다음
mysql_field_seek | 위로 | mysql_field_type


mysql_field_type

(PHP 3, PHP 4 , PHP 5)

mysql_field_type -- 결과로부터 특정 필드의 데이터 형(type) 정보를 반환

설명

string mysql_field_type ( int result, int field_offset)

mysql_field_type()는 mysql_field_name() 함수와 사용자에게 돌려주는 값의 형태에서는 비슷하다. 그러나, 필드타입은 "int", "real", "string", "blob" 등과 같은 단어로 반환한다는 것이 다르다. 필드타입의 더 자세한 종류를 보려면 MySQL 문서를 보면 된다.

예 1. mysql field types

<?php

mysql_connect ("localhost:3306");
mysql_select_db ("wisconsin");
$result = mysql_query ("SELECT * FROM onek");
$fields = mysql_num_fields ($result);
$rows   = mysql_num_rows ($result);
$i = 0;
$table = mysql_field_table ($result, $i);
echo "Your '".$table."' table has ".$fields." fields and ".$rows." records <BR>";
echo "The table has the following fields <BR>";
while ($i < $fields) {
    $type  = mysql_field_type  ($result, $i);
    $name  = mysql_field_name  ($result, $i);
    $len   = mysql_field_len   ($result, $i);
    $flags = mysql_field_flags ($result, $i);
    echo $type." ".$name." ".$len." ".$flags."<BR>";
    $i++;
}
mysql_close();

?>

하위 호환성이 있는 mysql_fieldtype()도 사용 가능하다.

이전 | 처음으로 | 다음
mysql_field_table | 위로 | mysql_free_result


mysql_free_result

(PHP 3, PHP 4 , PHP 5)

mysql_free_result -- Free result memory

설명

int mysql_free_result ( int result)

mysql_free_result()는 result에 대한 메모리(memory)에 있는 내용을 모두 제거한다.

mysql_free_result()는 결과로부터 얻은 질의 값이 커서 많은 메모리를 사용할 염려가 있을 때 사용된다. 단, 결과 값은 스크립트(script) 실행부가 종료되면서 메모리에서 자동적으로 지워진다.

mysql_freeresult()와는 하위 호환성이 있다.

이전 | 처음으로 | 다음
mysql_field_type | 위로 | mysql_get_client_info


mysql_get_client_info

(PHP 4 >= 4.0.5, PHP 5)

mysql_get_client_info -- Get MySQL client info

Description

string mysql_get_client_info ( void )

mysql_get_client_info() returns a string that represents the client library version.

예 1. mysql_get_client_info() example

<?php
printf("MySQL client info: %s\n", mysql_get_client_info());
?>

The above example would produce the following output:

MySQL client info: 3.23.39

See also
mysql_get_host_info(),
mysql_get_proto_info() and
mysql_get_server_info().

이전 | 처음으로 | 다음
mysql_free_result | 위로 | mysql_get_host_info


mysql_get_host_info

(PHP 4 >= 4.0.5, PHP 5)

mysql_get_host_info -- Get MySQL host info

Description

string mysql_get_host_info ( [resource link_identifier])

mysql_get_host_info() returns a string describing the type of connection in use for the connection link_identifier, including the server host name. If link_identifier is omitted, the last opened connection will be used.

예 1. mysql_get_host_info() example

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
printf("MySQL host info: %s\n", mysql_get_host_info());
?>

The above example would produce the following output:

MySQL host info: Localhost via UNIX socket

See also
mysql_get_client_info(),
mysql_get_proto_info() and
mysql_get_server_info().

이전 | 처음으로 | 다음
mysql_get_client_info | 위로 | mysql_get_proto_info


mysql_get_proto_info

(PHP 4 >= 4.0.5, PHP 5)

mysql_get_proto_info -- Get MySQL protocol info

Description

int mysql_get_proto_info ( [resource link_identifier])

mysql_get_proto_info() returns the protocol version used by connection link_identifier. If link_identifier is omitted, the last opened connection will be used.

예 1. mysql_get_proto_info() example

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
printf("MySQL protocol version: %s\n", mysql_get_proto_info());
?>

The above example would produce the following output:

MySQL protocol version: 10

See also
mysql_get_client_info(),
mysql_get_host_info() and
mysql_get_server_info().

이전 | 처음으로 | 다음
mysql_get_host_info | 위로 | mysql_get_server_info


mysql_get_server_info

(PHP 4 >= 4.0.5, PHP 5)

mysql_get_server_info -- Get MySQL server info

Description

string mysql_get_server_info ( [resource link_identifier])

mysql_get_server_info() returns the server version used by connection link_identifier. If link_identifier is omitted, the last opened connection will be used.

예 1. mysql_get_server_info() example

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
printf("MySQL server version: %s\n", mysql_get_server_info());
?>

The above example would produce the following output:

MySQL server version: 4.0.1-alpha

See also
mysql_get_client_info(),
mysql_get_host_info() and
mysql_get_proto_info().

이전 | 처음으로 | 다음
mysql_get_proto_info | 위로 | mysql_info


mysql_info

(PHP 4 >= 4.3.0, PHP 5)

mysql_info -- Get information about the most recent query

Description

string mysql_info ( [resource link_identifier])

mysql_info() returns detailed information about the last query using the given link_identifier. If link_identifier isn't specified, the last opened link is assumed.

mysql_info() returns a string for all statements listed below. For everything else, it returns FALSE. The string format depends on the given statement.

예 1. Relevant MySQL Statements

INSERT INTO ... SELECT ...
String format: Records: 23 Duplicates: 0 Warnings: 0
INSERT INTO ... VALUES (...),(...),(...)...
String format: Records: 37 Duplicates: 0 Warnings: 0
LOAD DATA INFILE ...
String format: Records: 42 Deleted: 0 Skipped: 0 Warnings: 0
ALTER TABLE
String format: Records: 60 Duplicates: 0 Warnings: 0
UPDATE
String format: Rows matched: 65 Changed: 65 Warnings: 0
The numbers are only for illustrating purpose; their values will correspond to the query.

참고: mysql_info() returns a non-FALSE value for the INSERT ... VALUES statement only if multiple value lists are specified in the statement.

See also mysql_affected_rows().

이전 | 처음으로 | 다음
mysql_get_server_info | 위로 | mysql_insert_id


mysql_insert_id

(PHP 3, PHP 4 , PHP 5)

mysql_insert_id -- 최근 INSERT 작업으로부터 생성된 identifier 값을 반환

설명

int mysql_insert_id ( [int link_identifier])

mysql_insert_id()는 link_identifier를 사용하면, INSERT 질의로 행(row)를 추가한 뒤 AUTO_INCREMENT로 생성된 테이블의 컬럼에 추가된 값을 얻을 수 있다. link_identifier를 지정하지 않으면, 마지막에 열려진 link를 사용한다.

mysql_insert_id()는 이전 질의가 AUTO_INCREMENT값으로 생성되지 않으면, 0을 반환한다. 마지막으로 저장된 값이 필요하다면, 질의로 값을 추가한 직후 mysql_insert_id()를 사용하면 된다.

참고: LAST_INSERT_ID()는 AUTO_INCREMENT 값으로 생성된 가장 최근 값이 보관되며, 질의할 동안에는 없어지지 않는다.

주의

mysql_insert_id()는 MySQL C API 내장 함수인 mysql_insert_id()로부터 long 타입으로 변환한다. 만일, AUTO_INCREMENT 열(column)의 타입이 BIGINT라면, mysql_insert_id()은 부정확한 값을 반환할 것이다. 그대신, 내부 MySQL 함수인 LAST_INSERT_ID()를 사용하면 된다.

이전 | 처음으로 | 다음
mysql_info | 위로 | mysql_list_dbs


mysql_list_dbs

(PHP 3, PHP 4 , PHP 5)

mysql_list_dbs -- MySQL 서버에 있는 데이터베이스 이름을 반환

설명

int mysql_list_dbs ( [int link_identifier])

mysql_list_dbs()는 현재 MySQL 데몬(daemon)으로부터 사용가능한 데이터베이스를 포함한 결과 포인터로 반환할 것이다. 이 결과 포인터를 사용하여 mysql_tablename() 함수도 사용할 수 있다.

예 1. mysql_list_dbs() 예제

$link = mysql_connect('localhost', 'myname', 'secret');
$db_list = mysql_list_dbs($link);

while ($row = mysql_fetch_object($db_list)) {
  echo $row->Database . "\n";
}

예제의 결과는 아래와 같다:

database1
database2
database3
...

참고: 위 코드는 mysql_fetch_row()나 이와 유사한 함수를 사용할 수도 있다.

하위 호환성이 있는 mysql_listdbs()도 사용 가능하다.

이전 | 처음으로 | 다음
mysql_insert_id | 위로 | mysql_list_fields


mysql_list_fields

(PHP 3, PHP 4 , PHP 5)

mysql_list_fields -- MySQL 결과의 필드 리스트로 반환

설명

int mysql_list_fields ( string database_name, string table_name [, int link_identifier])

mysql_list_fields()는 주어진 테이블 이름으로부터 정보를 가져온다.
 이 함수는 데이터베이스 이름과 테이블 이름을 인수(argument)로 갖는다.
 그리고 이 함수는 mysql_field_flags(),
 mysql_field_len(),
 mysql_field_name(),
 mysql_field_type() 등을 사용할 수 있도록
 결과 포인터를 반환한다.

결과 identifier는 양의 정수이며, 에러가 발생하면 -1 값이 반환된다. 에러 메시지는 $phperrmsg에 저장될 것이며, @mysql()과 같이 호출하지 않는한 항상 화면에 에러 메시지가 출력될 것이다.

예 1. mysql_list_fields() 예제

$link = mysql_connect('localhost', 'myname', 'secret');

$fields = mysql_list_fields("database1", "table1", $link);
$columns = mysql_num_fields($fields);

for ($i = 0; $i < $columns; $i++) {
  echo mysql_field_name($fields, $i) . "\n";;
}

위의 예제는 다음과 같이 출력될 것이다:

field1
field2
field3
...

하위 호환성이 있는 mysql_listfields()도 사용 가능하다.

이전 | 처음으로 | 다음
mysql_list_dbs | 위로 | mysql_list_processes


mysql_list_processes

(PHP 4 >= 4.3.0, PHP 5)

mysql_list_processes -- List MySQL processes

Description

resource mysql_list_processes ( [resource link_identifier])

mysql_list_processes() returns a result pointer describing the current server threads.

예 1. mysql_list_processes() example

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');

$result = mysql_list_processes($link);
while ($row = mysql_fetch_assoc($result)){
    printf("%s %s %s %s %s\n", $row["Id"], $row["Host"], $row["db"],
       $row["Command"], $row["Time"]);
}
mysql_free_result($result);
?>

The above example would produce the following output:

1 localhost test Processlist 0
4 localhost mysql sleep 5

See also mysql_thread_id().

이전 | 처음으로 | 다음
mysql_list_fields | 위로 | mysql_list_tables


mysql_list_tables

(PHP 3, PHP 4 , PHP 5)

mysql_list_tables -- MySQL 데이터베이스에 있는 테이블 목록을 반환

설명

int mysql_list_tables ( string database [, int link_identifier])

mysql_list_tables() 지정된 데이터베이스 이름으로 결과값을 얻고 mysql_db_query()등의 함수에 사용되는 결과 포인터를 반환한다. mysql_tablename() 함수는 결과 포인터로부터 실제 테이블 이름을 추출하는데 사용한다.

하위 호환성을 가지는 mysql_listtables() 함수 역시 사용 가능하다.

이전 | 처음으로 | 다음
mysql_list_processes | 위로 | mysql_num_fields


mysql_num_fields

(PHP 3, PHP 4 , PHP 5)

mysql_num_fields -- 결과로부터 필드 개수를 반환

설명

int mysql_num_fields ( int result)

mysql_num_fields() 함수는 결과셋으로부터 필드 개수를 반환한다.

참조:
mysql_db_query(),
mysql_query(),
mysql_fetch_field(),
mysql_num_rows().

하위 호환성을 가지는 mysql_numfields() 함수 역시 사용 가능하다.

이전 | 처음으로 | 다음
mysql_list_tables | 위로 | mysql_num_rows


mysql_num_rows

(PHP 3, PHP 4 , PHP 5)

mysql_num_rows -- 결과로부터 열 개수를 반환

설명

int mysql_num_rows ( int result)

mysql_num_rows() 함수는 결과셋으로부터 열의 개수를 반환한다. 이 함수는 SELECT절에서 반환된 결과셋만 사용이 가능하다. INSERT, UPDATE, DELETE로부터 열의 개수를 얻으려면 mysql_affected_rows()를 사용하면 된다.

예 1. mysql_num_rows 예제 (crubel@trilizio.org 제공) ()

<?php
$conn = mysql_connect("hostaddress", "username", "password");
mysql_select_db("database",$conn); // needed if you have m,ultiple db's
$Resultfornummembers = mysql_query("SELECT * FROM Accounts",$conn);
$NumMembers = mysql_num_rows($Resultfornummembers);
echo "$NumMembers Members";
?>

참조:
mysql_db_query(),
mysql_query() and,
mysql_fetch_row().

하위 호환성을 가지는 mysql_numrows() 함수 역시 사용 가능하다.

이전 | 처음으로 | 다음
mysql_num_fields | 위로 | mysql_pconnect


mysql_pconnect

(PHP 3, PHP 4 , PHP 5)

mysql_pconnect -- MySQL 서버와 영구적인 데이터베이스 접속

설명

int mysql_pconnect ( [string hostname [, string username [, string password]]])

반환값: 접속에 성공하면 MySQL 영구적 link identifier를 반환, 실패하면 에러를 출력.

mysql_pconnect()는 MySQL 서버로부터 접속을 설정하는 함수이다. 다음 기본 설정값은 옵션 파라미터를 설정하지 않으면 사용된다: host:port = 'localhost:3306', username = 서버 프로세서 소유자, password = 공백 비밀번호.

호스트명은 포트 번호를 포함 가능하다. "hostname:port"나 ":/path/to/socket"와 같이 로컬호스트의 소켓 경로 형태로 사용이 가능하다.

참고: ":port"는 3.0B4 버전부터 사용이 가능하다.

":/path/to/socket"는 3.0.10 버전부터 사용이 가능하다.

mysql_pconnect()은 mysql_connect()과 크게 두가지 부분에서 다르다.

첫째, 접속할 때, 함수는 동일한 호스트와 사용자이름, 비밀번호로 이미 열려진 영구적 접속된 링크가 있는지 찾아본다. 만일 찾게되면, 새로은 접속을 여는 대신 찾은 링크의 identifier를 반환한다.

둘째, SQL 서버로 접속은 스크립트 실행이 끝나도 계속 유지가 되며, 이후에도 사용이 가능하다. (주의: mysql_pconnect()로 열려진 링크는 mysql_close() 함수로 닫지는 못한다.)

그러므로, 이 형태의 링크를 '영구적(persistent)'으로 부른다.

이전 | 처음으로 | 다음
mysql_num_rows | 위로 | mysql_ping


mysql_ping

(PHP 4 >= 4.3.0, PHP 5)

mysql_ping -- Ping a server connection or reconnect if there is no connection

Description

bool mysql_ping ( [resource link_identifier])

mysql_ping() checks whether or not the connection to the server is working. If it has gone down, an automatic reconnection is attempted. This function can be used by scripts that remain idle for a long while, to check whether or not the server has closed the connection and reconnect if necessary. mysql_ping() returns TRUE if the connection to the server is working, otherwise FALSE.

See also mysql_thread_id() and mysql_list_processes().

이전 | 처음으로 | 다음
mysql_pconnect | 위로 | mysql_query


mysql_query

(PHP 3, PHP 4 , PHP 5)

mysql_query -- Send a MySQL query

설명

int mysql_query ( string query [, int link_identifier])

mysql_query()는 현재 서버에서 동작중인 데이터베이스로부터 특정 link identifier로 질의를 전송한다. 만일, link_identifier를 설정하지 않으면 가장 최근에 열려진 link를 사용하게 된다. 열려진 link가 없으면, 옵션 인자 없이 실행된 mysql_connect() 함수처럼 link를 생성하여 사용한다.

참고: 질의에 쓰이는 문자열 마지막에 세미콜론(;)를 붙이면 안된다.

mysql_query() 함수는 질의 성공 여부에 따라 TRUE(0이 아닌값) 또는 FALSE를 반환한다. 서버로부터 실행된 질의가 실행되고 그 질의 내용에 문제가 없어야만, TRUE값을 반환한다. 이 반환 값은 질의에 해당하는 열 개수 등과는 관련이 없다.

다음 질의는 틀린 문장이기 때문에 mysql_query()는 실패하며, FALSE값을 반환한다:

예 1. mysql_query()

<?php
$result = mysql_query ("SELECT * WHERE 1=1")
    or die ("잘못된 질의를 실행했습니다!!");
?>

다음 질의는 문법은 맞지만 실제로 테이블 my_tbl에 행 my_col이 없기 때문에 mysql_query() 함수는 실패하며, FALSE값을 반환한다:

예 2. mysql_query()

<?php
$result = mysql_query ("SELECT my_col FROM my_tbl")
    or die ("잘못된 질의를 실행했습니다!!");
?>

mysql_query()는 질의로 참조되는 테이블에 대한 접근 권한이 없다면 실패하며, FALSE값을 반환한다.

질의가 성공하면 mysql_num_rows() 함수를 사용하여 SELECT문으로 반환되는 행의 개수를 얻을 수 있으며, mysql_affected_rows() 함수를 사용하면, DELETE, INSERT, REPLACE, UPDATE로 적용된 행의 개수를 얻을 수 있다.

SELECT문을 위해 mysql_query() 함수는 mysql_result() 함수에서 사용할 수 있는 새로운 result identifier를 반환한다. 결과셋을 사용한 후, mysql_free_result() 함수를 사용하여 메모리에서 제거할 수 있다. 그러나, 스크립트가 종료되는 시점에 자동적으로 메모리에서 제거가 된다.

참조: mysql_affected_rows(),
mysql_db_query(),
mysql_free_result(),
mysql_result(),
mysql_select_db(),
mysql_connect().

이전 | 처음으로 | 다음
mysql_ping | 위로 | mysql_real_escape_string


mysql_real_escape_string

(PHP 4 >= 4.3.0, PHP 5)

mysql_real_escape_string -- Escapes special characters in a string for use in a SQL statement, taking into account the current charset of the connection.

Description

string mysql_real_escape_string ( string unescaped_string [, resource link_identifier])

This function will escape special characters in the unescaped_string, taking into account the current charset of the connection so that it is safe to place it in a mysql_query().

참고: mysql_real_escape_string() does not escape % and _.

예 1. mysql_real_escape_string() example

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
$item = "Zak's and Derick's Laptop";
$escaped_item = mysql_real_escape_string($item, $link);
printf("Escaped string: %s\n", $escaped_item);
?>

The above example would produce the following output:

Escaped string: Zak\'s and Derick\'s Laptop

See also mysql_escape_string() and mysql_client_encoding().

이전 | 처음으로 | 다음
mysql_query | 위로 | mysql_result


mysql_result

(PHP 3, PHP 4 , PHP 5)

mysql_result -- 결과 데이터를 반환

설명

mixed mysql_result ( int result, int row [, mixed field])

mysql_result() 함수는 MySQL 결과셋으로부터 한개의 셀(cell) 내용을 반환한다. field 인로는 필드 offset 또는 필드이름, 테이블이름과 필드이름 사이에 점(테이블이름.필드이름)으로 연결된 인자를 사용할 수 있다. 만약, 열(column)이름이 별명('select foo as bar from...')으로 되어 있다면 열이름 대신 별명(alias)를 사용해야한다.

큰 결과셋으로 작업할 경우, 전체 행을 얻어오는 함수중 하나를 사용하는 것이 좋을 것이다. 이 함수들은 한 번의 함수 호출로 다중 셀의 내용을 얻을 수 있는 장점이 있으며, mysql_result() 함수보다 더 빠르다. 또한 필드 인자로 숫자 offset을 사용하면 필드이름 또는 테이블이름.필드이름 인자를 사용한 것보다 더 빠르다.

mysql_result() 함수를 사용하면서 결과셋을 다른 함수에서 함께 사용할 수 없다.

성능 향상을 위해
     mysql_fetch_row(),
     mysql_fetch_array(),
     mysql_fetch_object() 함수를 사용하는 것이 좋다.

이전 | 처음으로 | 다음
mysql_real_escape_string | 위로 | mysql_select_db


mysql_select_db

(PHP 3, PHP 4 , PHP 5)

mysql_select_db -- MySQL 데이터베이스를 선택

설명

int mysql_select_db ( string database_name [, int link_identifier])

반환값: 성공하면 TRUE값, 실패하면 에러발생.

mysql_select_db() 함수는 link identifier로 지정된 연결을 이용하여 사용가능한 데이터베이스를 선택한다. link identifier를 지정하지 않으면 최근 열려진 link를 사용한다. 만약 열려진 link가 없다면, mysql_connect()를 호출하면 mysql_connect() 함수가 호출되며 link를 생성하며, 이를 사용한다.

Every subsequent call to mysql_query() will be made on the active database.

참조:
     mysql_connect(),
     mysql_pconnect(),
     mysql_query().

하위 호환성을 가지는 mysql_selectdb() 함수 역시 사용 가능하다.

이전 | 처음으로 | 다음
mysql_result | 위로 | mysql_stat


mysql_stat

(PHP 4 >= 4.3.0, PHP 5)

mysql_stat -- Get current system status

Description

string mysql_stat ( [resource link_identifier])

mysql_stat() returns the current server status.

참고: mysql_stat() currently only returns status for uptime, threads, queries, open tables, flush tables and queries per second. For a complete list of other status variables you have to use the SHOW STATUS SQL command.

예 1. mysql_stat() example

<?php
$link = mysql_connect('localhost', "mysql_user", "mysql_password");
$status = explode('  ', mysql_stat($link));
print_r($status);
?>

The above example would produce the following output:

Array
(
    [0] => Uptime: 5380
    [1] => Threads: 2
    [2] => Questions: 1321299
    [3] => Slow queries: 0
    [4] => Opens: 26
    [5] => Flush tables: 1
    [6] => Open tables: 17
    [7] => Queries per second avg: 245.595
)

이전 | 처음으로 | 다음
mysql_select_db | 위로 | mysql_tablename


mysql_tablename

(PHP 3, PHP 4 , PHP 5)

mysql_tablename -- 필드의 테이블이름을 얻음

설명

string mysql_tablename ( int result, int i)

mysql_tablename() 함수는 인자로 mysql_list_tables() 함수로 반환되는 결과 포인터와 동시에 테이블이름을 반환하고 정수형 인덱스를 가진다. mysql_num_rows() 함수는 결과 포인터에서 테이블 개수를 얻는데 사용된다.

예 1. mysql_tablename() 예제

<?php
mysql_connect ("localhost:3306");
$result = mysql_list_tables ("wisconsin");
$i = 0;
while ($i < mysql_num_rows ($result)) {
    $tb_names[$i] = mysql_tablename ($result, $i);
    echo $tb_names[$i] . "<BR>";
    $i++;
}
?>

이전 | 처음으로 | 다음
mysql_stat | 위로 | mysql_thread_id


mysql_thread_id

(PHP 4 >= 4.3.0, PHP 5)

mysql_thread_id -- Return the current thread ID

Description

int mysql_thread_id ( [resource link_identifier])

mysql_thread_id() returns the current thread ID. If the connection is lost and you reconnect with mysql_ping(), the thread ID will change. This means you should not get the thread ID and store it for later. You should get it when you need it.

예 1. mysql_thread_id() example

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
$thread_id = mysql_thread_id($link);
if ($thread_id){
    printf("current thread id is %d\n", $thread_id);
}
?>

The above example would produce the following output:

current thread id is 73

See also mysql_ping() and mysql_list_processes().

이전 | 처음으로 | 다음
mysql_tablename | 위로 | mysql_unbuffered_query


mysql_unbuffered_query

(PHP 4 >= 4.0.6, PHP 5)

mysql_unbuffered_query -- Send an SQL query to MySQL, without fetching and buffering the result rows

Description

resource mysql_unbuffered_query ( string query [, resource link_identifier])

mysql_unbuffered_query() sends a SQL query query to MySQL, without fetching and buffering the result rows automatically, as mysql_query() does. On the one hand, this saves a considerable amount of memory with SQL queries that produce large result sets. On the other hand, you can start working on the result set immediately after the first row has been retrieved: you don't have to wait until the complete SQL query has been performed. When using multiple DB-connects, you have to specify the optional parameter link_identifier.

참고: The benefits of mysql_unbuffered_query() come at a cost: You cannot use mysql_num_rows() and mysql_data_seek() on a result set returned from mysql_unbuffered_query(). You also have to fetch all result rows from an unbuffered SQL query, before you can send a new SQL query to MySQL.

See also mysql_query().

이전 | 처음으로 | 다음
mysql_thread_id | 위로 | Improved MySQL Extension


Improved MySQL Extension

PHP 매뉴얼
이전 다음

LXV. Improved MySQL Extension

소개

The mysqli extension allows you to access the functionality provided by MySQL 4.1 and above. More information about the MySQL Database server can be found at http://www.mysql.com/

Documentation for MySQL can be found at http://dev.mysql.com/doc/.

Parts of this documentation included from MySQL manual with permissions of MySQL AB.

요구 사항

In order to have these functions available, you must compile PHP with support for the mysqli extension.

참고: The mysqli extension is designed to work with the version 4.1.2 or above of MySQL. For previous versions, please see the MySQL extension documentation.

설치

To install the mysqli extension for PHP, use the --with-mysqli=mysql_config_path/mysql_config configuration option where mysql_config_path represents the location of the mysql_config program that comes with MySQL versions greater than 4.1.

If you would like to install the mysql extension along with the mysqli extension you have to use the same client library to avoid any conflicts.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. MySQLi Configuration Options

Name | Default | Changeable
mysqli.max_links | "-1" | PHP_INI_SYSTEM
mysqli.default_port | NULL | PHP_INI_ALL
mysqli.default_socket | NULL | PHP_INI_ALL
mysqli.default_host | NULL | PHP_INI_ALL
mysqli.default_user | NULL | PHP_INI_ALL
mysqli.default_pw | NULL | PHP_INI_ALL

For further details and definitions of the above PHP_INI_* constants, see the chapter on configuration changes.

위 설정 지시어에 대한 간단한 설명입니다.

mysqli.max_links integer

The maximum number of MySQL connections per process.

mysqli.default_port string

The default TCP port number to use when connecting to the database server if no other port is specified. If no default is specified, the port will be obtained from the MYSQL_TCP_PORT environment variable, the mysql-tcp entry in /etc/services or the compile-time MYSQL_PORT constant, in that order. Win32 will only use the MYSQL_PORT constant.

mysqli.default_socket string

The default socket name to use when connecting to a local database server if no other socket name is specified.

mysqli.default_host string

The default server host to use when connecting to the database server if no other host is specified. Doesn't apply in safe mode.

mysqli.default_user string

The default user name to use when connecting to the database server if no other name is specified. Doesn't apply in safe mode.

mysqli.default_password string

The default password to use when connecting to the database server if no other password is specified. Doesn't apply in safe mode.

클래스 정의

mysqli

Represents a connection between PHP and a MySQL database.

생성자

  • mysqli() - construct a new mysqli object

메쏘드

  • autocommit() - turns on or off auto-commiting database modifications

  • change_user() - changes the user of the specified database connection

  • character_set_name - returns the default character set for the database connection

  • close - closes a previously opened connection

  • commit - commits the current transaction

  • connect - opens a new connection to MySQL database server

  • debug - performs debugging operations

  • dump_debug_info - dumps debug information

  • get_client_info - returns client version

  • get_host_info - returns type of connection used

  • get_server_info - returns version of the MySQL server

  • get_server_version - returns version of the MySQL server

  • init - initializes mysqli object

  • info - retrieves information about the most recently executed query

  • kill - asks the server to kill a mysql thread

  • multi_query - performs multiple queries

  • more_results - check if more results exists from currently executed multi-query

  • next_result - reads next result from currently executed multi-query

  • options - set options

  • ping - pings a server connection or reconnects if there is no connection

  • prepare - prepares a SQL query

  • query - performs a query

  • real_connect - attempts to open a connection to MySQL database server

  • escape_string - Escapes special characters in a string for use in a SQL statement, taking into account the current charset of the connection

  • rollback - rolls back the current transaction

  • select_db - selects the default database

  • ssl_set - sets ssl parameters

  • stat - gets the current system status

  • stmt_initInitializes a statement for use with mysqli_stmt_prepare

  • store_result - transfers a resultset from last query

  • use_result - transfers an unbuffered resultset from last query

  • thread-safe - returns whether thread safety is given or not

속성

  • affected_rows - gets the number of affected rows in a previous MySQL operation

  • errno - returns the error code for the most recent function call

  • error - returns the error string for the most recent function call

  • field_count - returns the number of columns for the most recent query

  • host_info - returns a string representing the type of connection used

  • info - retrieves information about the most recently executed query

  • insert-id - returns the auto generated id used in the last query

  • protocol_version - returns the version of the MySQL protocol used

  • sqlstate - returns a string containing the SQLSTATE error code for the last error

  • thread_id - returns the thread ID for the current connection

  • warning-count - returns the number of warnings generated during execution of the previous SQL statement

mysqli_stmt

Represents a prepared statement.

메쏘드

  • bind_param - Binds variables to a prepared statement

  • bind_result - Binds variables to a prepared statement for result storage

  • close - Closes a prepared statement

  • data-seek - Seeks to an arbitrary row in a statement result set

  • execute - Executes a prepared statement

  • fetch - Fetches result from a prepared statement into bound variables

  • free_result - Frees stored result memory for the given statement handle

  • result_metadata - Retrieves a resultset from a prepared statement for metadata information

  • prepare - prepares a SQL query

  • send_long_data - Sends data in chunks

  • store_result - Buffers complete resultset from a prepared statement

속성

  • affected_rows - Returns affected rows from last statement execution

  • errno - Returns errorcode for last statement function

  • errno - Returns errormessage for last statement function

  • param_count - Returns number of parameter for a given prepare statement

  • sqlstate - returns a string containing the SQLSTATE error code for the last statement function

mysqli_result

Represents the result set obtained from a query against the database.

메쏘드

  • close - closes resultset

  • data_seek - moves internal result pointer

  • fetch_field - gets column information from a resultset

  • fetch_fields - gets information for all columns from a resulset

  • fetch_field_direct - gets column information for specified column

  • fetch_array - fetches a result row as an associative array, a numeric array, or both.

  • fetch_assoc - fetches a result row as an associative array

  • fetch_object - fetches a result row as an object

  • fetch_row - gets a result row as an enumerated array

  • close - frees result memory

  • field_seek - set result pointer to a specified field offset

속성

  • current_field - returns offset of current fieldpointer

  • field_count - returns number of fields in resultset

  • lengths - returns an array of columnlengths

  • num_rows - returns number of rows in resultset

상수 정의

표 2. MySQLi Constants

Name | Description
MYSQLI_READ_DEFAULT_GROUP (integer) | Read options from the named group from `my.cnf' or the file specified with MYSQLI_READ_DEFAULT_FILE
MYSQLI_READ_DEFAULT_FILE (integer) | Read options from the named option file instead of from my.cnf
MYSQLI_OPT_CONNECT_TIMEOUT (integer) | Connect timeout in seconds
MYSQLI_OPT_LOCAL_INFILE (integer) | Enables command LOAD LOCAL INFILE
MYSQLI_INIT_COMMAND (integer) | Command to execute when connecting to MySQL server. Will automatically be re-executed when reconnecting.
MYSQLI_CLIENT_SSL (integer) | Use SSL (encrypted protocol). This option should not be set by application programs; it is set internally in the MySQL client library
MYSQLI_CLIENT_COMPRESS (integer) | Use compression protocol
MYSQLI_CLIENT_INTERACTIVE (integer) | Allow interactive_timeout seconds (instead of wait_timeout seconds) of inactivity before closing the connection. The client's session wait_timeout variable will be set to the value of the session interactive_timeout variable.
MYSQLI_CLIENT_IGNORE_SPACE (integer) | Allow spaces after function names. Makes all functions names reserved words.
MYSQLI_CLIENT_NO_SCHEMA (integer) | Don't allow the db_name.tbl_name.col_name syntax.
MYSQLI_CLIENT_MULTI_QUERIES (integer) |
MYSQLI_STORE_RESULT (integer) | For using buffered resultsets
MYSQLI_USE_RESULT (integer) | For using unbuffered resultsets
MYSQLI_ASSOC (integer) | Columns are returned into the array having the fieldname as the array index.
MYSQLI_NUM (integer) | Columns are returned into the array having an enumerated index.
MYSQLI_BOTH (integer) | Columns are returned into the array having both a numerical index and the fieldname as the associative index.
MYSQLI_NOT_NULL_FLAG (integer) | Indicates that a field is defined as NOT NULL
MYSQLI_PRI_KEY_FLAG (integer) | Field is part of a primary index
MYSQLI_UNIQUE_KEY_FLAG (integer) | Field is part of an unique index.
MYSQLI_MULTIPLE_KEY_FLAG (integer) | Field is part of an index.
MYSQLI_BLOB_FLAG (integer) | Field is defined as BLOB
MYSQLI_UNSIGNED_FLAG (integer) | Field is defined as UNSIGNED
MYSQLI_ZEROFILL_FLAG (integer) | Field is defined as ZEROFILL
MYSQLI_AUTO_INCREMENT_FLAG (integer) | Field is defined as AUTO_INCREMENT
MYSQLI_TIMESTAMP_FLAG (integer) | Field is defined as TIMESTAMP
MYSQLI_SET_FLAG (integer) | Field is defined as SET
MYSQLI_NUM_FLAG (integer) | Field is defined as NUMERIC
MYSQLI_PART_KEY_FLAG (integer) | Field is part of an multi-index
MYSQLI_GROUP_FLAG (integer) | Field is part of GROUP BY
MYSQLI_TYPE_DECIMAL (integer) | Field is defined as DECIMAL
MYSQLI_TYPE_TINY (integer) | Field is defined as TINYINT
MYSQLI_TYPE_SHORT (integer) | Field is defined as INT
MYSQLI_TYPE_LONG (integer) | Field is defined as INT
MYSQLI_TYPE_FLOAT (integer) | Field is defined as FLOAT
MYSQLI_TYPE_DOUBLE (integer) | Field is defined as DOUBLE
MYSQLI_TYPE_NULL (integer) | Field is defined as DEFAULT NULL
MYSQLI_TYPE_TIMESTAMP (integer) | Field is defined as TIMESTAMP
MYSQLI_TYPE_LONGLONG (integer) | Field is defined as BIGINT
MYSQLI_TYPE_INT24 (integer) | Field is defined as MEDIUMINT
MYSQLI_TYPE_DATE (integer) | Field is defined as DATE
MYSQLI_TYPE_TIME (integer) | Field is defined as TIME
MYSQLI_TYPE_DATETIME (integer) | Field is defined as DATETIME
MYSQLI_TYPE_YEAR (integer) | Field is defined as YEAR
MYSQLI_TYPE_NEWDATE (integer) | Field is defined as DATE
MYSQLI_TYPE_ENUM (integer) | Field is defined as ENUM
MYSQLI_TYPE_SET (integer) | Field is defined as SET
MYSQLI_TYPE_TINY_BLOB (integer) | Field is defined as TINYBLOB
MYSQLI_TYPE_MEDIUM_BLOB (integer) | Field is defined as MEDIUMBLOB
MYSQLI_TYPE_LONG_BLOB (integer) | Field is defined as LONGBLOB
MYSQLI_TYPE_BLOB (integer) | Field is defined as BLOB
MYSQLI_TYPE_STRING (integer) | Field is defined as VARCHAR
MYSQLI_TYPE_CHAR (integer) | Field is defined as CHAR
MYSQLI_TYPE_GEOMETRY (integer) | Field is defined as GEOMETRY
MYSQLI_NEED_DATA (integer) | More data available for bind variable
MYSQLI_NO_DATA (integer) | No more data available for bind variable

Examples

All Examples in the MySQLI documentation use the world database from MySQL AB. The world database can be found at http://www.mysql.com/get/Downloads/Manual/world.sql.gz/from/pick

차례
mysqli_affected_rows -- Gets the number of affected rows in a previous MySQL operation
mysqli_autocommit -- Turns on or off auto-commiting database modifications
mysqli_bind_param -- Alias for mysqli_stmt_bind_param()
mysqli_bind_result -- Alias for mysqli_stmt_bind_result()
mysqli_change_user -- Changes the user of the specified database connection
mysqli_character_set_name -- Returns the default character set for the database connection
mysqli_client_encoding -- Alias of mysqli_character_set_name()
mysqli_close -- Closes a previously opened database connection
mysqli_commit -- Commits the current transaction
mysqli_connect_errno -- Returns the error code from last connect call
mysqli_connect_error -- Returns a string description of the last connect error
mysqli_connect -- Open a new connection to the MySQL server
mysqli_data_seek -- Adjusts the result pointer to an arbitary row in the result
mysqli_debug -- Performs debugging operations
mysqli_disable_reads_from_master --
mysqli_disable_rpl_parse --
mysqli_dump_debug_info -- Dump debugging information into the log
mysqli_embedded_connect -- Open a connection to an embedded mysql server.
mysqli_enable_reads_from_master --
mysqli_enable_rpl_parse --
mysqli_errno -- Returns the error code for the most recent function call
mysqli_error -- Returns a string description of the last error
mysqli_escape_string -- Alias of mysqli_real_escape_string()
mysqli_execute -- Alias for mysqli_stmt_execute()
mysqli_fetch_array -- Fetch a result row as an associative, a numeric array, or both.
mysqli_fetch_assoc -- Fetch a result row as an associative array
mysqli_fetch_field_direct -- Fetch meta-data for a single field
mysqli_fetch_field -- Returns the next field in the result set
mysqli_fetch_fields -- Returns an array of objects representing the fields in a result set
mysqli_fetch_lengths -- Returns the lengths of the columns of the current row in the result set
mysqli_fetch_object -- Returns the current row of a result set as an object
mysqli_fetch_row -- Get a result row as an enumerated array
mysqli_fetch -- Alias for mysqli_stmt_fetch()
mysqli_field_count -- Returns the number of columns for the most recent query
mysqli_field_seek -- Set result pointer to a specified field offset
mysqli_field_tell -- Get current field offset of a result pointer
mysqli_free_result -- Frees the memory associated with a result
mysqli_get_client_info -- Returns the MySQL client version as a string
mysqli_get_client_version -- Get MySQL client info.
mysqli_get_host_info -- Returns a string representing the type of connection used
mysqli_get_metadata -- Alias for mysqli_stmt_result_metadata()
mysqli_get_proto_info -- Returns the version of the MySQL protocol used
mysqli_get_server_info -- Returns the version of the MySQL server
mysqli_get_server_version -- Returns the version of the MySQL server as an integer
mysqli_info -- Retrieves information about the most recently executed query
mysqli_init -- Initializes MySQLi and returns an object for use with mysqli_real_connect
mysqli_insert_id -- Returns the auto generated id used in the last query
mysqli_kill -- Asks the server to kill a MySQL thread
mysqli_master_query -- Enforce execution of a query on the master in a master/slave setup.
mysqli_more_results -- Check if there any more query results from a multi query.
mysqli_multi_query -- Performs a query on the database
mysqli_next_result -- prepare next result from multi_query.
mysqli_num_fields -- Get the number of fields in a result
mysqli_num_rows -- Gets the number of rows in a result
mysqli_options -- set options
mysqli_param_count -- Alias for mysqli_stmt_param_count()
mysqli_ping -- Pings a server connection, or tries to reconnect if the connection has gone down.
mysqli_prepare -- Prepare a SQL statement for execution
mysqli_query -- Performs a query on the database
mysqli_real_connect -- Opens a connection to a mysql server
mysqli_real_escape_string -- Escapes special characters in a string for use in a SQL statement, taking into account the current charset of the connection
mysqli_real_query -- Execute an SQL query
mysqli_report -- enables or disables internal report functions
mysqli_rollback -- Rolls back current transaction
mysqli_rpl_parse_enabled --
mysqli_rpl_probe --
mysqli_rpl_query_type --
mysqli_select_db -- Selects the default database for database queries
mysqli_send_long_data -- Alias for mysqli_stmt_send_long_data()
mysqli_send_query --
mysqli_server_end --
mysqli_server_init -- Initialize embedded server.
mysqli_set_opt -- Alias of mysqli_options()
mysqli_sqlstate -- Returns the SQLSTATE error from previous MySQL operation.
mysqli_ssl_set -- Used for establishing secure connections using SSL.
mysqli_stat -- Gets the current system status
mysqli_stmt_affected_rows -- Returns the total number of rows changed, deleted, or inserted by the last executed statement
mysqli_stmt_bind_param -- Binds variables to a prepared statement as parameters
mysqli_stmt_bind_result -- Binds variables to a prepared statement for result storage
mysqli_stmt_close -- Closes a prepared statement
mysqli_stmt_data_seek -- Seeks to an arbitray row in statement result set
mysqli_stmt_errno -- Returns the error code for the most recent statement call
mysqli_stmt_error -- Returns a string description for last statement error
mysqli_stmt_execute -- Executes a prepared Query
mysqli_stmt_fetch -- Fetch results from a prepared statement into the bound variables
mysqli_stmt_free_result -- Frees stored result memory for the given statement handle
mysqli_stmt-init -- Initializes a statement and returns an object for use with mysqli_stmt_prepare
mysqli_stmt_num_rows -- Return the number of rows in statements result set.
mysqli_stmt_param_count -- Returns the number of parameter for the given statement
mysqli_stmt_prepare -- Prepare a SQL statement for execution
mysqli_stmt_result_metadata -- returns result set metadata from a prepared statement
mysqli_stmt_send_long_data -- Send data in blocks
mysqli_stmt_sqlstate -- returns SQLSTATE error from previous statement operation
mysqli_stmt_store_result -- Transfers a result set from a prepared statement
mysqli_store_result -- Transfers a result set from the last query
mysqli_thread_id -- Returns the thread ID for the current connection
mysqli_thread_safe -- Returns whether thread safety is given or not
mysqli_use_result -- Initiate a result set retrieval
mysqli_warning_count -- Returns the number of warnings from the last query for the given link

이전 | 처음으로 | 다음
mysql_unbuffered_query | 위로 | mysqli_affected_rows


mysqli_affected_rows

(PHP 5)

mysqli_affected_rows

(no version information, might be only in CVS)

mysqli->affected_rows -- Gets the number of affected rows in a previous MySQL operation

Description

Procedural style:

mixed mysqli_affected_rows ( object link)

Object oriented style (property):

class mysqli {

mixed affected_rows

}

mysqli_affected_rows() returns the number of rows affected by the last INSERT, UPDATE, or DELETE query associated with the provided link parameter. If the last query was invalid, this function will return -1.

참고: For SELECT statements mysqli_affected_rows() works like mysqli_num_rows().

The mysqli_affected_rows() function only works with queries which modify a table. In order to return the number of rows from a SELECT query, use the mysqli_num_rows() function instead.

Return Values

An integer greater than zero indicates the number of rows affected or retrieved. Zero indicates that no records where updated for an UPDATE statement, no rows matched the WHERE clause in the query or that no query has yet been executed. -1 indicates that the query returned an error.

참고: If the number of affected rows is greater than maximal int value, the number of affected rows will be returned as a string.

See also

mysqli_num_rows(), mysqli_info().

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Insert rows */
$mysqli->query("CREATE TABLE Language SELECT * from CountryLanguage");
printf("Affected rows (INSERT): %d\n", $mysqli->affected_rows);

$mysqli->query("ALTER TABLE Language ADD Status int default 0");

/* update rows */
$mysqli->query("UPDATE Language SET Status=1 WHERE Percentage > 50");
printf("Affected rows (UPDATE): %d\n", $mysqli->affected_rows);

/* delete rows */
$mysqli->query("DELETE FROM Language WHERE Percentage < 50");
printf("Affected rows (DELETE): %d\n", $mysqli->affected_rows);

/* select all rows */
$result = $mysqli->query("SELECT CountryCode FROM Language");
printf("Affected rows (SELECT): %d\n", $mysqli->affected_rows);

$result->close();

/* Delete table Language */
$mysqli->query("DROP TABLE Language");

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

if (!$link) {
    printf("Can't connect to localhost. Error: %s\n", mysqli_connect_error());
    exit();
}

/* Insert rows */
mysqli_query($link, "CREATE TABLE Language SELECT * from CountryLanguage");
printf("Affected rows (INSERT): %d\n", mysqli_affected_rows($link));

mysqli_query($link, "ALTER TABLE Language ADD Status int default 0");

/* update rows */
mysqli_query($link, "UPDATE Language SET Status=1 WHERE Percentage > 50");
printf("Affected rows (UPDATE): %d\n", mysqli_affected_rows($link));

/* delete rows */
mysqli_query($link, "DELETE FROM Language WHERE Percentage < 50");
printf("Affected rows (DELETE): %d\n", mysqli_affected_rows($link));

/* select all rows */
$result = mysqli_query($link, "SELECT CountryCode FROM Language");
printf("Affected rows (SELECT): %d\n", mysqli_affected_rows($link));

mysqli_free_result($result);

/* Delete table Language */
mysqli_query($link, "DROP TABLE Language");

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Affected rows (INSERT): 984
Affected rows (UPDATE): 168
Affected rows (DELETE): 815
Affected rows (SELECT): 169

이전 | 처음으로 | 다음
Improved MySQL Extension | 위로 | mysqli_autocommit


mysqli_autocommit

(PHP 5)

mysqli_autocommit

(no version information, might be only in CVS)

mysqli->auto_commit -- Turns on or off auto-commiting database modifications

Description

Procedural style:

bool mysqli_autocommit ( object link, bool mode)

Object oriented style (method)

class mysqli {

bool auto_commit ( bool mode)

}

mysqli_autocommit() is used to turn on or off auto-commit mode on queries for the database connection represented by the link object.

참고: mysqli_autocommit() doesn't work with non transactional table types (like MyISAM or ISAM).

To determine the current state of autocommit use the SQL command 'SELECT @@autocommit'.

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_commit(), mysqli_rollback().

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* turn autocommit on */
$mysqli->autocommit(TRUE);

if ($result = $mysqli->query("SELECT @@autocommit")) {
    $row = $result->fetch_row();
    printf("Autocommit is %s\n", $row[0]);
    $result->free();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

if (!$link) {
    printf("Can't connect to localhost. Error: %s\n", mysqli_connect_error());
    exit();
}

/* turn autocommit on */
mysqli_autocommit($link, TRUE);

if ($result = mysqli_query($link, "SELECT @@autocommit")) {
    $row = mysqli_fetch_row($result);
    printf("Autocommit is %s\n", $row[0]);
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Autocommit is 1

이전 | 처음으로 | 다음
mysqli_affected_rows | 위로 | mysqli_bind_param


mysqli_bind_param

mysqli_bind_param -- Alias for mysqli_stmt_bind_param()

Description

This function is an alias of mysqli_stmt_bind_param(). For a detailled descripton see description of mysqli_stmt_bind_param().

참고: mysqli_bind_param() is deprecated and will be removed.

See also

mysqli_stmt_bind_param()

이전 | 처음으로 | 다음
mysqli_autocommit | 위로 | mysqli_bind_result


mysqli_bind_result

mysqli_bind_result -- Alias for mysqli_stmt_bind_result()

Description

This function is an alias of mysqli_stmt_bind_result(). For a detailled descripton see description of mysqli_stmt_bind_result().

참고: mysqli_bind_result() is deprecated and will be removed.

See also

mysqli_stmt_bind_result()

이전 | 처음으로 | 다음
mysqli_bind_param | 위로 | mysqli_change_user


mysqli_change_user

(PHP 5)

mysqli_change_user

(no version information, might be only in CVS)

mysqli->change_user -- Changes the user of the specified database connection

Description

Procedural style:

bool mysqli_change_user ( object link, string user, string password, string database)

Object oriented style (method):

class mysqli {

bool change_user ( string user, string password, string database)

}

mysqli_change_user() is used to change the user of the specified database connection as given by the link parameter and to set the current database to that specified by the database parameter.

If desired, the NULL value may be passed in place of the database parameter resulting in only changing the user and not selecting a database. To select a database in this case use the mysqli_select_db() function.

In order to successfully change users a valid username and password parameters must be provided and that user must have sufficient permissions to access the desired database. If for any reason authorization fails, the current user authentication will remain.

참고: Using this command will always cause the current database connection to behave as if was a completely new database connection, regardless of if the operation was completed successfully. This reset includes performing a rollback on any active transactions, closing all temporary tables, and unlocking all locked tables.

Return Values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also:

mysqli_connect() mysqli_select_db()

Example

예 1. Object oriented style

<?php

/* connect database test */
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Set Variable a */
$mysqli->query("SET @a:=1");

/* reset all and select a new database */
$mysqli->change_user("my_user", "my_password", "world");

if ($result = $mysqli->query("SELECT DATABASE()")) {
    $row = $result->fetch_row();
    printf("Default database: %s\n", $row[0]);
    $result->close();
}

if ($result = $mysqli->query("SELECT @a")) {
    $row = $result->fetch_row();
    if ($row[0] === NULL) {
        printf("Value of variable a is NULL\n");
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
/* connect database test */
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Set Variable a */
mysqli_query($link, "SET @a:=1");

/* reset all and select a new database */
mysqli_change_user($link, "my_user", "my_password", "world");

if ($result = mysqli_query($link, "SELECT DATABASE()")) {
    $row = mysqli_fetch_row($result);
    printf("Default database: %s\n", $row[0]);
    mysqli_free_result($result);
}

if ($result = mysqli_query($link, "SELECT @a")) {
    $row = mysqli_fetch_row($result);
    if ($row[0] === NULL) {
        printf("Value of variable a is NULL\n");
    }
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Default database: world
Value of variable a is NULL

이전 | 처음으로 | 다음
mysqli_bind_result | 위로 | mysqli_character_set_name


mysqli_character_set_name

(PHP 5)

mysqli_character_set_name

(no version information, might be only in CVS)

mysqli->character_set_name -- Returns the default character set for the database connection

Description

Procedural style:

string mysqli_character_set_name ( object link)

Object oriented style (method):

class mysqli {

string character_set_name ( void )

}

Returns the current character set for the database connection specified by the link parameter.

Return values

The default character set for the current connection

See also

mysqli_client_encoding(). mysqli_real_escape_string().

Example

예 1. Object oriented style

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Print current character set */
$charset = $mysqli->character_set_name();
printf ("Current character set is %s\n", $charset);

$mysqli->close();
?>

예 2. Procedural style

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Print current character set */
$charset = mysqli_character_set_name($link);
printf ("Current character set is %s\n",$charset);

/* close connection */
mysqli_close($link);
?>

The above examples would be produce the following output:

Current character set is latin1_swedish_ci

이전 | 처음으로 | 다음
mysqli_change_user | 위로 | mysqli_client_encoding


mysqli_client_encoding

mysqli_client_encoding -- Alias of mysqli_character_set_name()

Description

This function is an alias of mysqli_character_set_name(). For a detailled descripton see description of mysqli_character_set_name().

See also

mysqli_client_encoding(). mysqli_real_escape_string().

이전 | 처음으로 | 다음
mysqli_character_set_name | 위로 | mysqli_close


mysqli_close

(PHP 5)

mysqli_close

(no version information, might be only in CVS)

mysqli->close -- Closes a previously opened database connection

Description

Procedural style:

bool mysqli_close ( object link)

Object oriented style (method):

class mysqli {

bool close ( void )

}

The mysqli_close() function closes a previously opened database connection specified by the link parameter.

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_connect(),
mysqli_init(),
mysqli_real_connect().

이전 | 처음으로 | 다음
mysqli_client_encoding | 위로 | mysqli_commit


mysqli_commit

(PHP 5)

mysqli_commit

(no version information, might be only in CVS)

mysqli->commit -- Commits the current transaction

Description

Procedural style:

bool mysqli_commit ( object link)

Object oriented style (method)

class mysqli {

bool commit ( void )

}

Commits the current transaction for the database connection specified by the link parameter.

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_autocommit(), mysqli_rollback().

Examples

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE Language LIKE CountryLanguage Type=InnoDB");

/* set autocommit to off */
$mysqli->autocommit(FALSE);

/* Insert some values */
$mysqli->query("INSERT INTO Language VALUES ('DEU', 'Bavarian', 'F', 11.2)");
$mysqli->query("INSERT INTO Language VALUES ('DEU', 'Swabian', 'F', 9.4)");

/* commit transaction */
$mysqli->commit();

/* drop table */
$mysqli->query("DROP TABLE Language");

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* set autocommit to off */
mysqli_autocommit($link, FALSE);

mysqli_query($link, "CREATE TABLE Language LIKE CountryLanguage Type=InnoDB");

/* Insert some values */
mysqli_query($link, "INSERT INTO Language VALUES ('DEU', 'Bavarian', 'F', 11.2)");
mysqli_query($link, "INSERT INTO Language VALUES ('DEU', 'Swabian', 'F', 9.4)");

/* commit transaction */
mysqli_commit($link);

/* close connection */
mysqli_close($link);
?>

이전 | 처음으로 | 다음
mysqli_close | 위로 | mysqli_connect_errno


mysqli_connect_errno

(PHP 5)

mysqli_connect_errno -- Returns the error code from last connect call

Description

int mysqli_connect_errno ( void )

The mysqli_connect_errno() function will return the last error code number for last call to mysqli_connect(). If no errors have occured, this function will return zero.

참고: Client error message numbers are listed in the MySQL errmsg.h header file, server error message numbers are listed in mysqld_error.h. In the MySQL source distribution you can find a complete list of error messages and error numbers in the file Docs/mysqld_error.txt.

Return values

An error code value for the last call to mysqli_connect(), if it failed. zero means no error occurred.

See also

mysqli_connect(),
mysqli_connect_error(),
mysqli_errno(),
mysqli_error(),
mysqli_sqlstate()

Example

예 1. mysqli_connect_errno sample

<?php

$link = @mysqli_connect("localhost", "nonexisting_user", "");

if (!$link) {
    printf("Can't connect to localhost. Errorcode: %d\n", mysqli_connect_errno());
}
?>

이전 | 처음으로 | 다음
mysqli_commit | 위로 | mysqli_connect_error


mysqli_connect_error

(PHP 5)

mysqli_connect_error -- Returns a string description of the last connect error

Description

string mysqli_connect_error ( void )

The mysqli_connect_error() function is identical to the corresponding mysqli_connect_errno() function in every way, except instead of returning an integer error code the mysqli_connect_error() function will return a string representation of the last error to occur for the last mysqli_connect() call. If no error has occured, this function will return an empty string.

Return values

A string that describes the error. An empty string if no error occurred.

See also

mysqli_connect(),
mysqli_connect_errno(),
mysqli_errno(),
mysqli_error(),
mysqli_sqlstate()

Example

예 1. mysqli_connect_error sample

<?php

$link = @mysqli_connect("localhost", "nonexisting_user", "");

if (!$link) {
    printf("Can't connect to localhost. Error: %s\n", mysqli_connect_error());
}
?>

이전 | 처음으로 | 다음
mysqli_connect_errno | 위로 | mysqli_connect


mysqli_connect

(PHP 5)

mysqli_connect

(no version information, might be only in CVS)

mysqli() -- Open a new connection to the MySQL server

Description

Procedural style

object mysqli_connect ( [string host [, string username [, string passwd [, string dbname [, int port [, string socket]]]]]])

Object oriented style (constructor):

class mysqli {

__construct ( [string host [, string username [, string passwd [, string dbname [, int port [, string socket]]]]]])

}

The mysqli_connect() function attempts to open a connection to the MySQL Server running on host which can be either a host name or an IP address. Passing the NULL value or the string "localhost" to this parameter, the local host is assumed. When possible, pipes will be used instead of the TCP/IP protocol. If successful, the mysqli_connect() will return an object representing the connection to the database, or FALSE on failure.

The username and password parameters specify the username and password under which to connect to the MySQL server. If the password is not provided (the NULL value is passed), the MySQL server will attempt to authenticate the user against those user records which have no password only. This allows one username to be used with different permissions (depending on if a password as provided or not).

The dbname parameter if provided will specify the default database to be used when performing queries.

The port and socket parameters are used in conjunction with the host parameter to further control how to connect to the database server. The port parameter specifies the port number to attempt to connect to the MySQL server on, while the socket parameter specifies the socket or named pipe that should be used.

참고: Specifying the socket parameter will not explicitly determine the type of connection to be used when connecting to the MySQL server. How the connection is made to the MySQL database is determined by the host parameter.

Return values

Returns a object which represents the connection to a MySQL Server or FALSE if the connection failed.

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

printf("Host information: %s\n", $mysqli->host_info);

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

printf("Host information: %s\n", mysqli_get_host_info($link));

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Host information: Localhost via UNIX socket

이전 | 처음으로 | 다음
mysqli_connect_error | 위로 | mysqli_data_seek


mysqli_data_seek

(PHP 5)

mysqli_data_seek

(no version information, might be only in CVS)

result->data_seek -- Adjusts the result pointer to an arbitary row in the result

Description

Procedural style:

bool mysqli_data_seek ( object result, int offset)

Object oriented style (method):

class result {

bool data_seek ( int offset)

}

The mysqli_data_seek() function seeks to an arbitrary result pointer specified by the offset in the result set represented by result. The offset parameter must be between zero and the total number of rows minus one (0..mysqli_num_rows() - 1).

참고: This function can only be used with unbuffered results attained from the use of the mysqli_store_result() or mysqli_query() functions.

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_store_result(),
mysqli_fetch_row(),
mysqli_num_rows().

Example

예 1. Object oriented style

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name";
if ($result = $mysqli->query( $query)) {

    /* seek to row no. 400 */
    $result->data_seek(399);

    /* fetch row */
    $row = $result->fetch_row();

    printf ("City: %s  Countrycode: %s\n", $row[0], $row[1]);

    /* free result set*/
    $result->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name";

if ($result = mysqli_query($link, $query)) {

    /* seek to row no. 400 */
    mysqli_data_seek($result, 399);

    /* fetch row */
    $row = mysqli_fetch_row($result);

    printf ("City: %s  Countrycode: %s\n", $row[0], $row[1]);

    /* free result set*/
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

City: Benin City  Countrycode: NGA

이전 | 처음으로 | 다음
mysqli_connect | 위로 | mysqli_debug


mysqli_debug

(PHP 5)

mysqli_debug -- Performs debugging operations

Description

void mysqli_debug ( string debug)

The mysqli_debug() function is used to perform debugging operations using the Fred Fish debugging library. The debug parameter is a string representing the debugging operation to perform.

참고: To use the mysqli_debug() function you must complile the MySQL client library to support debugging.

Return values

mysqli_debug() doesn't return any value.

See also

mysqli_dump_debug_info(), mysqli_report()

Example

예 1. Generating a Trace File

<?php

/* Create a trace file in '/tmp/client.trace' on the local (client) machine: */
mysqli_debug("d:t:0,/tmp/client.trace");

?>

이전 | 처음으로 | 다음
mysqli_data_seek | 위로 | mysqli_disable_reads_from_master


mysqli_disable_reads_from_master

(PHP 5)

mysqli_disable_reads_from_master --

Description

void mysqli_disable_reads_from_master ( resource link)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

이전 | 처음으로 | 다음
mysqli_debug | 위로 | mysqli_disable_rpl_parse


mysqli_disable_rpl_parse

(PHP 5)

mysqli_disable_rpl_parse --

Description

void mysqli_disable_rpl_parse ( object link)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

이전 | 처음으로 | 다음
mysqli_disable_reads_from_master | 위로 | mysqli_dump_debug_info


mysqli_dump_debug_info

(PHP 5)

mysqli_dump_debug_info

(no version information, might be only in CVS)

mysqli->dump_debug_info -- Dump debugging information into the log

Description

bool mysqli_dump_debug_info ( object link)

This function is designed to be executed by an user with the SUPER privlege and is used to dump debugging information into the log for the MySQL Server relating to the connection specified by the link parameter.

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_debug().

이전 | 처음으로 | 다음
mysqli_disable_rpl_parse | 위로 | mysqli_embedded_connect


mysqli_embedded_connect

(PHP 5)

mysqli_embedded_connect -- Open a connection to an embedded mysql server.

Description

object mysqli_embedded_connect ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

이전 | 처음으로 | 다음
mysqli_dump_debug_info | 위로 | mysqli_enable_reads_from_master


mysqli_enable_reads_from_master

(PHP 5)

mysqli_enable_reads_from_master --

Description

void mysqli_enable_reads_from_master ( object link)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

이전 | 처음으로 | 다음
mysqli_embedded_connect | 위로 | mysqli_enable_rpl_parse


mysqli_enable_rpl_parse

(PHP 5)

mysqli_enable_rpl_parse --

Description

void mysqli_enable_rpl_parse ( object link)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

이전 | 처음으로 | 다음
mysqli_enable_reads_from_master | 위로 | mysqli_errno


mysqli_errno

(PHP 5)

mysqli_errno

(no version information, might be only in CVS)

mysqli->errno -- Returns the error code for the most recent function call

Description

Procedural style:

int mysqli_errno ( object link)

Object oriented style (property):

class mysqli {

int errno

}

The mysqli_errno() function will return the last error code for the most recent MySQLi function call that can succeed or fail with respect to the database link defined by the link parameter. If no errors have occured, this function will return zero.

참고: Client error message numbers are listed in the MySQL errmsg.h header file, server error message numbers are listed in mysqld_error.h. In the MySQL source distribution you can find a complete list of error messages and error numbers in the file Docs/mysqld_error.txt.

Return values

An error code value for the last call, if it failed. zero means no error occurred.

See also

mysqli_connect_errno(),
mysqli_connect_error(),
mysqli_error(),
mysqli_sqlstate()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!$mysqli->query("SET a=1")) {
    printf("Errorcode: %d\n", $mysqli->errno);
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!mysqli_query($link, "SET a=1")) {
    printf("Errorcode: %d\n", mysqli_errno($link));
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Errorcode: 1193

이전 | 처음으로 | 다음
mysqli_enable_rpl_parse | 위로 | mysqli_error


mysqli_error

(PHP 5)

mysqli_error -- Returns a string description of the last error

Description

Procedural style:

string mysqli_error ( object link)

Object oriented style (property)

class mysqli {

string error

}

The mysqli_error() function is identical to the corresponding mysqli_errno() function in every way, except instead of returning an integer error code the mysqli_error() function will return a string representation of the last error to occur for the database connection represented by the link parameter. If no error has occured, this function will return an empty string.

Return values

A string that describes the error. An empty string if no error occurred.

See also

mysqli_connect_errno(),
mysqli_connect_error(),
mysqli_errno(),
mysqli_sqlstate()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!$mysqli->query("SET a=1")) {
    printf("Errormessage: %s\n", $mysqli->error);
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!mysqli_query($link, "SET a=1")) {
    printf("Errormessage: %s\n", mysqli_error($link));
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Errormessage: Unknown system variable 'a'

이전 | 처음으로 | 다음
mysqli_errno | 위로 | mysqli_escape_string


mysqli_escape_string

mysqli_escape_string -- Alias of mysqli_real_escape_string()

Description

This function is an alias of mysqli_real_escape_string().

이전 | 처음으로 | 다음
mysqli_error | 위로 | mysqli_execute


mysqli_execute

mysqli_execute -- Alias for mysqli_stmt_execute()

Description

This function is an alias of mysqli_stmt_execute(). For a detailled descripton see description of mysqli_stmt_execute().

참고: mysqli_execute() is deprecated and will be removed.

See also

mysqli_stmt_execute()

이전 | 처음으로 | 다음
mysqli_escape_string | 위로 | mysqli_fetch_array


mysqli_fetch_array

(PHP 5)

mysqli_fetch_array

(no version information, might be only in CVS)

result->fetch_array -- Fetch a result row as an associative, a numeric array, or both.

Description

Procedural style:

mixed mysqli_fetch_array ( object result [, int resulttype])

Object oriend style (method):

class result {

mixed fetch_array ( [int resulttype])

}

Returns an array that corresponds to the fetched row or NULL if there are no more rows for the resultset represented by the result parameter.

mysqli_fetch_array() is an extended version of the mysqli_fetch_row() function. In addition to storing the data in the numeric indices of the result array, the mysqli_fetch_array() function can also store the data in associative indices, using the field names of the result set as keys.

참고: 이 함수가 반환하는 필드 이름은 대소문자를 구별합니다.

If two or more columns of the result have the same field names, the last column will take precedence and overwrite the earlier data. In order to access multiple columns with the same name, the numerically indexed version of the row must be used.

The optional second argument resulttype is a constant indicating what type of array should be produced from the current row data. The possible values for this parameter are the constants MYSQLI_ASSOC, MYSQLI_NUM, or MYSQLI_BOTH. By default the mysqli_fetch_array() function will assume MYSQLI_BOTH for this parameter.

By using the MYSQLI_ASSOC constant this function will behave identically to the mysqli_fetch_assoc(), while MYSQLI_NUM will behave identically to the mysqli_fetch_row() function. The final option MYSQLI_BOTH will create a single array with the attributes of both.

Return values

Returns an array that corresponds to the fetched row or NULL if there are no more rows in resultset.

See also

mysqli_fetch_assoc(),
mysqli_fetch_row(),
mysqli_fetch_object().

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID LIMIT 3";
$result = $mysqli->query($query);

/* numeric array */
$row = $result->fetch_array(MYSQLI_NUM);
printf ("%s (%s)\n", $row[0], $row[1]);

/* associative array */
$row = $result->fetch_array(MYSQLI_ASSOC);
printf ("%s (%s)\n", $row["Name"], $row["CountryCode"]);

/* associative and numeric array */
$row = $result->fetch_array(MYSQLI_BOTH);
printf ("%s (%s)\n", $row[0], $row["CountryCode"]);

/* free result set */
$result->close();

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID LIMIT 3";
$result = mysqli_query($link, $query);

/* numeric array */
$row = mysqli_fetch_array($result, MYSQLI_NUM);
printf ("%s (%s)\n", $row[0], $row[1]);

/* associative array */
$row = mysqli_fetch_array($result, MYSQLI_ASSOC);
printf ("%s (%s)\n", $row["Name"], $row["CountryCode"]);

/* associative and numeric array */
$row = mysqli_fetch_array($result, MYSQLI_BOTH);
printf ("%s (%s)\n", $row[0], $row["CountryCode"]);

/* free result set */
mysqli_free_result($result);

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Kabul (AFG)
Qandahar (AFG)
Herat (AFG)

이전 | 처음으로 | 다음
mysqli_execute | 위로 | mysqli_fetch_assoc


mysqli_fetch_assoc

(PHP 5)

mysqli_fetch_assoc

(no version information, might be only in CVS)

mysqli->fetch_assoc -- Fetch a result row as an associative array

Description

Procedural style:

array mysqli_fetch_assoc ( object result)

Object oriend style (method):

class result {

array fetch_assoc ( void )

}

Returns an associative array that corresponds to the fetched row or NULL if there are no more rows.

The mysqli_fetch_assoc() function is used to return an associative array representing the next row in the result set for the result represented by the result parameter, where each key in the array represents the name of one of the result set's columns.

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you either need to access the result with numeric indices by using mysqli_fetch_row() or add alias names.

참고: 이 함수가 반환하는 필드 이름은 대소문자를 구별합니다.

Return values

Returns an array that corresponds to the fetched row or NULL if there are no more rows in resultset.

See also

mysqli_fetch_array(),
mysqli_fetch_row(),
mysqli_fetch_object().

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($result = $mysqli->query($query)) {

    /* fetch associative array */
    while ($row = $result->fetch_assoc()) {
        printf ("%s (%s)\n", $row["Name"], $row["CountryCode"]);
    }

    /* free result set */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($result = mysqli_query($link, $query)) {

    /* fetch associative array */
    while ($row = mysqli_fetch_assoc($result)) {
        printf ("%s (%s)\n", $row["Name"], $row["CountryCode"]);
    }

    /* free result set */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Pueblo (USA)
Arvada (USA)
Cape Coral (USA)
Green Bay (USA)
Santa Clara (USA)

이전 | 처음으로 | 다음
mysqli_fetch_array | 위로 | mysqli_fetch_field_direct


mysqli_fetch_field_direct

(PHP 5)

mysqli_fetch_field_direct

(no version information, might be only in CVS)

result->fetch_field_direct -- Fetch meta-data for a single field

Description

Procedural style:

mixed mysqli_fetch_field_direct ( object result, int fieldnr)

Object oriented style (method):

class result {

mixed fetch_field_direct ( int fieldnr)

}

mysqli_fetch_field_direct() returns an object which contains field definition informations from specified resultset. The value of fieldnr must be in the range from 0 to number of fields - 1.

Return values

Returns an object which contains field definition informations or FALSE if no field information for specified fieldnr is available.

표 1. Object attributes

Attribute | Description
name | The name of the column
orgname | Original column name if an alias was specified
table | The name of the table this field belongs to (if not calculated)
orgtable | Original table name if an alias was specified
def | The default value for this field, represented as a string
max_length | The maximum width of the field for the result set.
flags | An integer representing the bit-flags for the field.
type | The data type used for this field
decimals | The number of decimals used (for integer fields)

See also

mysqli_num_fields()
mysqli_fetch_field()
mysqli_fetch_fields()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Name LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Get field information for column 'SurfaceArea' */
    $finfo = $result->fetch_field_direct(1);

    printf("Name:     %s\n", $finfo->name);
    printf("Table:    %s\n", $finfo->table);
    printf("max. Len: %d\n", $finfo->max_length);
    printf("Flags:    %d\n", $finfo->flags);
    printf("Type:     %d\n", $finfo->type);

    $result->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Name LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Get field information for column 'SurfaceArea' */
    $finfo = mysqli_fetch_field_direct($result, 1);

    printf("Name:     %s\n", $finfo->name);
    printf("Table:    %s\n", $finfo->table);
    printf("max. Len: %d\n", $finfo->max_length);
    printf("Flags:    %d\n", $finfo->flags);
    printf("Type:     %d\n", $finfo->type);

    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Name:     SurfaceArea
Table:    Country
max. Len: 10
Flags:    32769
Type:     4

이전 | 처음으로 | 다음
mysqli_fetch_assoc | 위로 | mysqli_fetch_field


mysqli_fetch_field

(PHP 5)

mysqli_fetch_field

(no version information, might be only in CVS)

result->fetch_field -- Returns the next field in the result set

Description

Procedural style:

mixed mysqli_fetch_field ( object result)

Object oriented style (method):

class result {

mixed fetch_field ( void )

}

The mysqli_fetch_field() returns the definition of one column of a result set as an object. Call this function repeatedly to retrieve information about all columns in the result set. mysqli_fetch_field() returns FALSE when no more fields are left.

Return values

Returns an object which contains field definition informations or FALSE if no field information is available.

표 1. Object properties

Property | Description
name | The name of the column
orgname | Original column name if an alias was specified
table | The name of the table this field belongs to (if not calculated)
orgtable | Original table name if an alias was specified
def | The default value for this field, represented as a string
max_length | The maximum width of the field for the result set.
flags | An integer representing the bit-flags for the field.
type | The data type used for this field
decimals | The number of decimals used (for integer fields)

See also

mysqli_num_fields()
mysqli_fetch_field_direct()
mysqli_fetch_fields()
mysqli_field_seek()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Get field information for all columns */
    while ($finfo = $result->fetch_field()) {

        printf("Name:     %s\n", $finfo->name);
        printf("Table:    %s\n", $finfo->table);
        printf("max. Len: %d\n", $finfo->max_length);
        printf("Flags:    %d\n", $finfo->flags);
        printf("Type:     %d\n\n", $finfo->type);
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Get field information for all fields */
    while ($finfo = mysqli_fetch_field($result)) {

        printf("Name:     %s\n", $finfo->name);
        printf("Table:    %s\n", $finfo->table);
        printf("max. Len: %d\n", $finfo->max_length);
        printf("Flags:    %d\n", $finfo->flags);
        printf("Type:     %d\n\n", $finfo->type);
    }
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Name:     Name
Table:    Country
max. Len: 11
Flags:    1
Type:     254

Name:     SurfaceArea
Table:    Country
max. Len: 10
Flags:    32769
Type:     4

이전 | 처음으로 | 다음
mysqli_fetch_field_direct | 위로 | mysqli_fetch_fields


mysqli_fetch_fields

(PHP 5)

mysqli_fetch_fields

(no version information, might be only in CVS)

result->fetch_fields -- Returns an array of objects representing the fields in a result set

Description

Procedural Style:

mixed mysqli_fetch_fields ( object result)

Object oriented style (method):

class result {

mixed fetch_fields ( void )

}

This function serves an identical purpose to the mysqli_fetch_field() function with the single difference that, instead of returning one object at a time for each field, the columns are returned as an array of objects.

Return values

Returns an array of objects which contains field definition informations or FALSE if no field information is available.

표 1. Object properties

Property | Description
name | The name of the column
orgname | Original column name if an alias was specified
table | The name of the table this field belongs to (if not calculated)
orgtable | Original table name if an alias was specified
def | The default value for this field, represented as a string
max_length | The maximum width of the field for the result set.
flags | An integer representing the bit-flags for the field.
type | The data type used for this field
decimals | The number of decimals used (for integer fields)

See also

mysqli_num_fields()
mysqli_fetch_field()
mysqli_fetch_field_direct()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Get field information for all columns */
    $finfo = $result->fetch_fields();

    for ($i=0; $i < count($finfo); $i++) {
        printf("Name:     %s\n", $finfo[$i]->name);
        printf("Table:    %s\n", $finfo[$i]->table);
        printf("max. Len: %d\n", $finfo[$i]->max_length);
        printf("Flags:    %d\n", $finfo[$i]->flags);
        printf("Type:     %d\n\n", $finfo[$i]->type);
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Get field information for all columns */
    $finfo = mysqli_fetch_fields($result);

    for ($i=0; $i < count($finfo); $i++) {
        printf("Name:     %s\n", $finfo[$i]->name);
        printf("Table:    %s\n", $finfo[$i]->table);
        printf("max. Len: %d\n", $finfo[$i]->max_length);
        printf("Flags:    %d\n", $finfo[$i]->flags);
        printf("Type:     %d\n\n", $finfo[$i]->type);
    }
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Name:     Name
Table:    Country
max. Len: 11
Flags:    1
Type:     254

Name:     SurfaceArea
Table:    Country
max. Len: 10
Flags:    32769
Type:     4

이전 | 처음으로 | 다음
mysqli_fetch_field | 위로 | mysqli_fetch_lengths


mysqli_fetch_lengths

(PHP 5)

mysqli_fetch_lengths

(no version information, might be only in CVS)

result->lengths -- Returns the lengths of the columns of the current row in the result set

Description

Procedural style:

mixed mysqli_fetch_lengths ( object result)

Object oriented style (property):

class result {

mixed lengths

}

The mysqli_fetch_lengths() function returns an array containing the lengths of every column of the current row within the result set represented by the result parameter. If successful, a numerically indexed array representing the lengths of each column is returned or FALSE on failure.

Return values

An array of integers representing the size of each column (not including any terminating null characters). FALSE if an error occurred.

mysql_fetch_lengths() is valid only for the current row of the result set. It returns FALSE if you call it before calling mysql_fetch_row/array/object or after retrieving all rows in the result.

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT * from Country ORDER BY Code LIMIT 1";

if ($result = $mysqli->query($query)) {

    $row = $result->fetch_row();

    /* display column lengths */
    for ($i=0; $i < count($result->lengths); $i++) {
        printf("Field %2d has Length %2d\n", $i+1, $result->lengths[$i]);
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT * from Country ORDER BY Code LIMIT 1";

if ($result = mysqli_query($link, $query)) {

    $row = mysqli_fetch_row($result);

    /* display column lengths */
    $lengths = mysqli_fetch_lengths($result);
    for ($i=0; $i < count($lengths); $i++) {
        printf("Field %2d has Length %2d\n", $i+1, $lengths[$i]);
    }
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Field  1 has Length  3
Field  2 has Length  5
Field  3 has Length 13
Field  4 has Length  9
Field  5 has Length  6
Field  6 has Length  1
Field  7 has Length  6
Field  8 has Length  4
Field  9 has Length  6
Field 10 has Length  6
Field 11 has Length  5
Field 12 has Length 44
Field 13 has Length  7
Field 14 has Length  3
Field 15 has Length  2

이전 | 처음으로 | 다음
mysqli_fetch_fields | 위로 | mysqli_fetch_object


mysqli_fetch_object

(PHP 5)

mysqli_fetch_object

(no version information, might be only in CVS)

result->fetch_object -- Returns the current row of a result set as an object

Description

Procedural style:

mixed mysqli_fetch_object ( object result)

Object oriented style (method):

class result {

mixed fetch_object ( void )

}

The mysqli_fetch_object() will return the current row result set as an object where the attributes of the object represent the names of the fields found within the result set. If no more rows exist in the current result set, NULL is returned.

Return values

Returns an object that corresponds to the fetched row or NULL if there are no more rows in resultset.

참고: 이 함수가 반환하는 필드 이름은 대소문자를 구별합니다.

See also

mysqli_fetch_array(),
mysqli_fetch_assoc(),
mysqli_fetch_row().

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($result = $mysqli->query($query)) {

    /* fetch object array */
    while ($obj = $result->fetch_object()) {
        printf ("%s (%s)\n", $obj->Name, $obj->CountryCode);
    }

    /* free result set */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($result = mysqli_query($link, $query)) {

    /* fetch associative array */
    while ($obj = mysqli_fetch_object($result)) {
        printf ("%s (%s)\n", $obj->Name, $obj->CountryCode);
    }

    /* free result set */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Pueblo (USA)
Arvada (USA)
Cape Coral (USA)
Green Bay (USA)
Santa Clara (USA)

이전 | 처음으로 | 다음
mysqli_fetch_lengths | 위로 | mysqli_fetch_row


mysqli_fetch_row

(PHP 5)

mysqli_fetch_row

(no version information, might be only in CVS)

result->fetch_row -- Get a result row as an enumerated array

Description

Procedural style:

mixed mysqli_fetch_row ( object result)

Object oriented style (method):

class result {

mixed fetch_row ( void )

}

Returns an array that corresponds to the fetched row, or NULL if there are no more rows.

mysqli_fetch_row() fetches one row of data from the result set represented by result and returns it as an enumerated array, where each column is stored in an array offset starting from 0 (zero). Each subsequent call to the mysqli_fetch_row() function will return the next row within the result set, or FALSE if there are no more rows.

Return values

mysqli_fetch_row() returns an array that corresponds to the fetched row or NULL if there are no more rows in result set.

See also

mysqli_fetch_array(),
mysqli_fetch_assoc(),
mysqli_fetch_object().

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($result = $mysqli->query($query)) {

    /* fetch object array */
    while ($row = $result->fetch_row()) {
        printf ("%s (%s)\n", $row[0], $row[1]);
    }

    /* free result set */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($result = mysqli_query($link, $query)) {

    /* fetch associative array */
    while ($row = mysqli_fetch_row($result)) {
        printf ("%s (%s)\n", $row[0], $row[1]);
    }

    /* free result set */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Pueblo (USA)
Arvada (USA)
Cape Coral (USA)
Green Bay (USA)
Santa Clara (USA)

이전 | 처음으로 | 다음
mysqli_fetch_object | 위로 | mysqli_fetch


mysqli_fetch

mysqli_fetch -- Alias for mysqli_stmt_fetch()

Description

This function is an alias of mysqli_stmt_fetch(). For a detailled descripton see description of mysqli_stmt_fetch().

참고: mysqli_fetch() is deprecated and will be removed.

See also

mysqli_stmt_fetch()

이전 | 처음으로 | 다음
mysqli_fetch_row | 위로 | mysqli_field_count


mysqli_field_count

(PHP 5)

mysqli_field_count

(no version information, might be only in CVS)

mysqli->field_count -- Returns the number of columns for the most recent query

Description

Procedural style:

int mysqli_field_count ( object link)

Object oriented style (method):

class mysql {

int field_count ( void )

}

Returns the number of columns for the most recent query on the connection represented by the link parameter. This function can be useful when using the mysqli_store_result() function to determine if the query should have produced a non-empty result set or not without knowing the nature of the query.

Return values

An integer representing the number of fields in a result set

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

$mysqli->query( "DROP TABLE IF EXISTS friends");
$mysqli->query( "CREATE TABLE friends (id int, name varchar(20))");

$mysqli->query( "INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

$mysqli->real_query($HTTP_POST_VARS['query']);

if (mysql_field_count($link)) {
    /* this was a select/show or describe query */
    $result = $mysqli->store_result();

    /* process resultset */
    $row = $result->fetch_row();

    /* free resultset */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

mysqli_query($link, "DROP TABLE IF EXISTS friends");
mysqli_query($link, "CREATE TABLE friends (id int, name varchar(20))");

mysqli_query($link, "INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

mysqli_real_query($link, $HTTP_POST_VARS['query']);

if (mysql_field_count($link)) {
    /* this was a select/show or describe query */
    $result = mysqli_store_result($link);

    /* process resultset */
    $row = mysqli_fetch_row($result);

    /* free resultset */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

이전 | 처음으로 | 다음
mysqli_fetch | 위로 | mysqli_field_seek


mysqli_field_seek

(PHP 5)

mysqli_field_seek

(no version information, might be only in CVS)

result->field_seek -- Set result pointer to a specified field offset

Description

Procedural style:

int mysqli_field_seek ( object result, int fieldnr)

Object oriented style (method):

class result {

int field_seek ( int fieldnr)

}

Sets the field cursor to the given offset. The next call to mysqli_fetch_field() will retrieve the field definition of the column associated with that offset.

참고: To seek to the beginning of a row, pass an offset value of zero.

Return values

mysqli_field_seek() returns previuos value of field cursor.

See also

mysqli_fetch_field()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Get field information for 2nd column */
    $result->field_seek(1);
    $finfo = $result->fetch_field();

    printf("Name:     %s\n", $finfo->name);
    printf("Table:    %s\n", $finfo->table);
    printf("max. Len: %d\n", $finfo->max_length);
    printf("Flags:    %d\n", $finfo->flags);
    printf("Type:     %d\n\n", $finfo->type);

    $result->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Get field information for 2nd column */
    mysqli_field_seek($result, 1);
    $finfo = mysqli_fetch_field($result);

    printf("Name:     %s\n", $finfo->name);
    printf("Table:    %s\n", $finfo->table);
    printf("max. Len: %d\n", $finfo->max_length);
    printf("Flags:    %d\n", $finfo->flags);
    printf("Type:     %d\n\n", $finfo->type);

    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Name:     SurfaceArea
Table:    Country
max. Len: 10
Flags:    32769
Type:     4

이전 | 처음으로 | 다음
mysqli_field_count | 위로 | mysqli_field_tell


mysqli_field_tell

(PHP 5)

mysqli_field_tell

(no version information, might be only in CVS)

result->current_field -- Get current field offset of a result pointer

Description

Procedural style:

int mysqli_field_tell ( object result)

Object oriented style (property):

class result {

int current_field

}

Returns the position of the field cursor used for the last mysqli_fetch_field() call. This value can be used as an argument to mysqli_field_seek().

반환값

Returns current offset of field cursor.

참고

mysqli_fetch_field(), mysqli_field_seek()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Get field information for all columns */
    while ($finfo = $result->fetch_field()) {

        /* get fieldpointer offset */
        $currentfield = $result->current_field;

        printf("Column %d:\n", $currentfield);
        printf("Name:     %s\n", $finfo->name);
        printf("Table:    %s\n", $finfo->table);
        printf("max. Len: %d\n", $finfo->max_length);
        printf("Flags:    %d\n", $finfo->flags);
        printf("Type:     %d\n\n", $finfo->type);
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Get field information for all fields */
    while ($finfo = mysqli_fetch_field($result)) {

        /* get fieldpointer offset */
        $currentfield = mysqli_field_tell($result);

        printf("Column %d:\n", $currentfield);
        printf("Name:     %s\n", $finfo->name);
        printf("Table:    %s\n", $finfo->table);
        printf("max. Len: %d\n", $finfo->max_length);
        printf("Flags:    %d\n", $finfo->flags);
        printf("Type:     %d\n\n", $finfo->type);
    }
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Column 1:
Name:     Name
Table:    Country
max. Len: 11
Flags:    1
Type:     254

Column 2:
Name:     SurfaceArea
Table:    Country
max. Len: 10
Flags:    32769
Type:     4

이전 | 처음으로 | 다음
mysqli_field_seek | 위로 | mysqli_free_result


mysqli_free_result

(PHP 5)

mysqli_free_result

(no version information, might be only in CVS)

result->free -- Frees the memory associated with a result

Description

Procedural style:

void mysqli_free_result ( object result)

Object oriented style (method):

class result {

void free ( void )

}

The mysqli_free_result() function frees the memory associated with the result represented by the result parameter, which was allocated by mysqli_query(), mysqli_store_result() or mysqli_use_result().

참고: You should always free your result with mysqli_free_result(), when your result object is not needed anymore.

반환값

This function doesn't return any value.

참고

mysqli_query(),
mysqli_stmt_store_result(),
mysqli_store_result(),
mysqli_use_result().

이전 | 처음으로 | 다음
mysqli_field_tell | 위로 | mysqli_get_client_info


mysqli_get_client_info

(PHP 5)

mysqli_get_client_info -- Returns the MySQL client version as a string

Description

string mysqli_get_client_info ( void )

The mysqli_get_client_info() function is used to return a string representing the client version being used in the MySQLi extension.

반환값

A string that represents the MySQL client library version

See also

mysqli_get_client_version(),
mysqli_get_server_info(),
mysqli_get_server_version()

Example

예 1. mysqli_get_client_info

<?php

/* We don't need a connection to determine
   the version of mysql client library */

printf("Client library version: %s\n", mysqli_get_client_info());
?>

이전 | 처음으로 | 다음
mysqli_free_result | 위로 | mysqli_get_client_version


mysqli_get_client_version

(PHP 5)

mysqli_get_client_version -- Get MySQL client info.

Description

int mysqli_get_client_version ( void )

Returns client version number as an integer.

Return values

A number that represents the MySQL client library version in format: main_version*10000 + minor_version *100 + sub_version. For example, 4.1.0 is returned as 40100.

This is useful to quickly determine the version of the client library to know if some capability exits.

See also

mysqli_get_client_info(),
mysqli_get_server_info(),
mysqli_get_server_version()

Example

예 1. mysqli_get_client_version

<?php

/* We don't need a connection to determine
   the version of mysql client library */

printf("Client library version: %d\n", mysqli_get_client_version());
?>

이전 | 처음으로 | 다음
mysqli_get_client_info | 위로 | mysqli_get_host_info


mysqli_get_host_info

(PHP 5)

mysqli_get_host_info

(no version information, might be only in CVS)

mysqli->get_host_info -- Returns a string representing the type of connection used

Description

Procdural style:

string mysqli_get_host_info ( object link)

Object oriented style (property):

class mysqli {

string host_info

}

The mysqli_get_host_info() function returns a string describing the connection represented by the link parameter is using (including the server host name).

반환값

A character string representing the server hostname and the connection type.

See also

mysqli_get_proto_info()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print host information */
printf("Host info: %s\n", $mysqli->host_info);

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print host information */
printf("Host info: %s\n", mysqli_get_host_info($link));

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Host info: Localhost via UNIX socket

이전 | 처음으로 | 다음
mysqli_get_client_version | 위로 | mysqli_get_metadata


mysqli_get_metadata

mysqli_get_metadata -- Alias for mysqli_stmt_result_metadata()

Description

This function is an alias of mysqli_stmt_result_metadata(). For a detailled descripton see description of mysqli_stmt_result_metadata().

참고: mysqli_get_metadata() is deprecated and will be removed.

See also

mysqli_stmt_result_metadata()

이전 | 처음으로 | 다음
mysqli_get_host_info | 위로 | mysqli_get_proto_info


mysqli_get_proto_info

(PHP 5)

mysqli_get_proto_info

(no version information, might be only in CVS)

mysqli->protocol_version -- Returns the version of the MySQL protocol used

Description

Procedural style:

int mysqli_get_proto_info ( object link)

Object oriented style (property):

class mysqli {

string protocol_version

}

Returns an integer representing the MySQL protocol version used by the connection represented by the link parameter.

반환값

Returns an integer representing the protocol version.

See also

mysqli_get_host_info()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print protocol version */
printf("Protocol version: %d\n", $mysqli->protocol_version);

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print protocol version */
printf("Protocol version: %d\n", mysqli_get_proto_info($link));

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Protocol version: 10

이전 | 처음으로 | 다음
mysqli_get_metadata | 위로 | mysqli_get_server_info


mysqli_get_server_info

(PHP 5)

mysqli_get_server_info

(no version information, might be only in CVS)

mysqli->server_info -- Returns the version of the MySQL server

Description

Procedural style:

string mysqli_get_server_info ( object link)

Object oriented style (property):

class mysqli {

string server_info

}

Returns a string representing the version of the MySQL server that the MySQLi extension is connected to (represented by the link parameter).

반환값

A character string representing the server version.

See also

mysqli_get_client_info(),
mysqli_get_client_version(),
mysqli_get_server_version()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print server version */
printf("Server version: %s\n", $mysqli->server_info);

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print server version */
printf("Server version: %s\n", mysqli_get_server_info($link));

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Server version: 4.1.2-alpha-debug

이전 | 처음으로 | 다음
mysqli_get_proto_info | 위로 | mysqli_get_server_version


mysqli_get_server_version

(PHP 5)

mysqli_get_server_version -- Returns the version of the MySQL server as an integer

Description

Procedural style:

int mysqli_get_server_version ( object link)

Object oriented style (property):

class mysqli {

int server_version

}

The mysqli_get_server_version() function returns the version of the server connected to (represented by the link parameter) as an integer.

The form of this version number is main_version * 10000 + minor_version * 100 + sub_version (i.e. version 4.1.0 is 40100).

반환값

An integer representing the server version.

See also

mysqli_get_client_info(),
mysqli_get_client_version(),
mysqli_get_server_info()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print server version */
printf("Server version: %d\n", $mysqli->server_version);

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print server version */
printf("Server version: %d\n", mysqli_get_server_version($link));

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Server version: 40102

이전 | 처음으로 | 다음
mysqli_get_server_info | 위로 | mysqli_info


mysqli_info

(PHP 5)

mysqli_info

(no version information, might be only in CVS)

mysqli->info -- Retrieves information about the most recently executed query

Description

Procedural style:

string mysqli_info ( object link)

Object oriented style (property)

class mysqli {

string info

}

The mysqli_info() function returns a string providing information about the last query executed. The nature of this string is provided below:

표 1. Possible mysqli_info return values

Query type | Example result string
INSERT INTO...SELECT... | Records: 100 Duplicates: 0 Warnings: 0
INSERT INTO...VALUES (...),(...),(...) | Records: 3 Duplicates: 0 Warnings: 0
LOAD DATA INFILE ... | Records: 1 Deleted: 0 Skipped: 0 Warnings: 0
ALTER TABLE ... | Records: 3 Duplicates: 0 Warnings: 0
UPDATE ... | Rows matched: 40 Changed: 40 Warnings: 0

참고: Queries which do not fall into one of the above formats are not supported. In these situations, mysqli_info() will return an empty string.

반환값

A character string representing additional information about the most recently executed query.

참고

mysqli_affected_rows(),
mysqli_warning_count(),
mysqli_num_rows()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TEMPORARY TABLE t1 LIKE City");

/* INSERT INTO .. SELECT */
$mysqli->query("INSERT INTO t1 SELECT * FROM City ORDER BY ID LIMIT 150");
printf("%s\n", $mysqli->info);

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TEMPORARY TABLE t1 LIKE City");

/* INSERT INTO .. SELECT */
mysqli_query($link, "INSERT INTO t1 SELECT * FROM City ORDER BY ID LIMIT 150");
printf("%s\n", mysqli_info($link));

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Records: 150  Duplicates: 0  Warnings: 0

이전 | 처음으로 | 다음
mysqli_get_server_version | 위로 | mysqli_init


mysqli_init

(PHP 5)

mysqli_init -- Initializes MySQLi and returns an object for use with mysqli_real_connect

Description

object mysqli_init ( void )

Allocates or initializes a MYSQL object suitable for mysqli_options() and mysqli_real_connect().

참고: Any subsequent calls to any mysqli function (except mysqli_options()) will fail until mysqli_real_connect() was called.

반환값

Returns an object.

참고

mysqli_options(),
mysqli_close(),
mysqli_real_connect(),
mysqli_connect()

이전 | 처음으로 | 다음
mysqli_info | 위로 | mysqli_insert_id


mysqli_insert_id

(PHP 5)

mysqli_insert_id

(no version information, might be only in CVS)

mysqli->insert_id -- Returns the auto generated id used in the last query

Description

Procedural style:

mixed mysqli_insert_id ( object link)

Object oriented style (property):

class mysqli {

mixed insert_id

}

The mysqli_insert_id() function returns the ID generated by a query on a table with a column having the AUTO_INCREMENT attribute. If the last query wasn't an INSERT or UPDATE statement or if the modified table does not have a column with the AUTO_INCREMENT attribute, this function will return zero.

참고: Performing an INSERT or UPDATE statement using the LAST_INSERT_ID() function will also modify the value returned by the mysqli_insert_id() function.

반환값

The value of the AUTO_INCREMENT field that was updated by the previous query. Returns zero if there was no previous query on the connection or if the query did not update an AUTO_INCREMENT value.

참고: If the number is greater than maximal int value, mysqli_insert_id() will return a string.

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCity LIKE City");

$query = "INSERT INTO myCity VALUES (NULL, 'Stuttgart', 'DEU', 'Stuttgart', 617000)";
$mysqli->query($query);

printf ("New Record has id %d.\n", $mysqli->insert_id);

/* drop table */
$mysqli->query("DROP TABLE myCity");

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCity LIKE City");

$query = "INSERT INTO myCity VALUES (NULL, 'Stuttgart', 'DEU', 'Stuttgart', 617000)";
mysqli_query($link, $query);

printf ("New Record has id %d.\n", mysqli_insert_id($link));

/* drop table */
mysqli_query($link, "DROP TABLE myCity");

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

New Record has id 1.

이전 | 처음으로 | 다음
mysqli_init | 위로 | mysqli_kill


mysqli_kill

(PHP 5)

mysqli_kill

(no version information, might be only in CVS)

mysqli->kill -- Asks the server to kill a MySQL thread

Description

Procedural style:

bool mysqli_kill ( object link, int processid)

Object oriented style (method)

class mysqli {

bool kill ( int processid)

}

This function is used to ask the server to kill a MySQL thread specified by the processid parameter. This value must be retrieved by calling the mysqli_thread_id() function.

참고: To stop a running query you should use the SQL command KILL QUERY processid.

반환값

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고

mysqli_thread_id()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* determine our thread id */
$thread_id = $mysqli->thread_id;

/* Kill connection */
$mysqli->kill($thread_id);

/* This should produce an error */
if (!$mysqli->query("CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", $mysqli->error);
    exit;
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* determine our thread id */
$thread_id = mysqli_thread_id($link);

/* Kill connection */
mysqli_kill($link, $thread_id);

/* This should produce an error */
if (!mysqli_query($link, "CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", mysqli_error($link));
    exit;
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Error: MySQL server has gone away

이전 | 처음으로 | 다음
mysqli_insert_id | 위로 | mysqli_master_query


mysqli_master_query

(PHP 5)

mysqli_master_query -- Enforce execution of a query on the master in a master/slave setup.

Description

bool mysqli_master_query ( object link, string query)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

이전 | 처음으로 | 다음
mysqli_kill | 위로 | mysqli_more_results


mysqli_more_results

(PHP 5)

mysqli_more_results

(no version information, might be only in CVS)

mysqli->more_results -- Check if there any more query results from a multi query.

Description

bool mysqli_more_results ( object link)

mysqli_more_results() indicates if one or more result sets are available from a previous call to mysqli_multi_query().

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_multi_query(),
mysqli_next_result(),
mysqli_store_result(),
mysqli_use_result()

Example

See mysqli_multi_query().

이전 | 처음으로 | 다음
mysqli_master_query | 위로 | mysqli_multi_query


mysqli_multi_query

(PHP 5)

mysqli_multi_query

(no version information, might be only in CVS)

mysqli->multi_query -- Performs a query on the database

Description

Procedural style:

bool mysqli_multi_query ( object link, string query)

Object oriented style (method):

class mysqli {

bool multi_query ( string query)

}

The mysqli_multi_query() executes one or multiple queries which are concatenated by a semicolon.

To retrieve the resultset from the first query you can use mysqli_use_result() or mysqli_store_result(). All subsequent query results can be processed using mysqli_more_results() and mysqli_next_result().

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_use_result(),
mysqli_store_result(),
mysqli_next_result(),
mysqli_more_results()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query  = "SELECT CURRENT_USER();";
$query .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* execute multi query */
if ($mysqli->multi_query($query)) {
    do {
        /* store first result set */
        if ($result = $mysqli->store_result()) {
            while ($row = $result->fetch_row()) {
                printf("%s\n", $row[0]);
            }
            $result->close();
        }
        /* print divider */
        if ($mysqli->more_results()) {
            printf("-----------------\n");
        }
    } while ($mysqli->next_result());
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query  = "SELECT CURRENT_USER();";
$query .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* execute multi query */
if (mysqli_multi_query($link, $query)) {
    do {
        /* store first result set */
        if ($result = mysqli_store_result($link)) {
            while ($row = mysqli_fetch_row($result)) {
                printf("%s\n", $row[0]);
            }
            mysqli_free_result($result);
        }
        /* print divider */
        if (mysqli_more_results($link)) {
            printf("-----------------\n");
        }
    } while (mysqli_next_result($link));
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

my_user@localhost
-----------------
Amersfoort
Maastricht
Dordrecht
Leiden
Haarlemmermeer

이전 | 처음으로 | 다음
mysqli_more_results | 위로 | mysqli_next_result


mysqli_next_result

(PHP 5)

mysqli_next_result

(no version information, might be only in CVS)

mysqli->next_result -- prepare next result from multi_query.

Description

bool mysqli_next_result ( object link)

mysqli_next_result() prepares next result set from a previous call to mysqli_multi_query() which can be retrieved by mysqli_store_result() or mysqli_use_result().

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_multi_query(),
mysqli_more_results(),
mysqli_store_result(),
mysqli_use_result()

Example

See mysqli_multi_query().

이전 | 처음으로 | 다음
mysqli_multi_query | 위로 | mysqli_num_fields


mysqli_num_fields

(PHP 5)

mysqli_num_fields

(no version information, might be only in CVS)

result->field_count -- Get the number of fields in a result

Description

Procedural style:

int mysqli_num_fields ( object result)

Object oriented style (property):

class result {

int field_count

}

mysqli_num_fields() returns the number of fields from specified result set.

반환값

The number of fields from a result set

참고

mysqli_fetch_field()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($result = $mysqli->query("SELECT * FROM City ORDER BY ID LIMIT 1")) {

    /* determine number of fields in result set */
    $field_cnt = $result->field_count;

    printf("Result set has %d fields.\n", $field_cnt);

    /* close result set */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($result = mysqli_query($link, "SELECT * FROM City ORDER BY ID LIMIT 1")) {

    /* determine number of fields in result set */
    $field_cnt = mysqli_num_fields($result);

    printf("Result set has %d fields.\n", $field_cnt);

    /* close result set */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Result set has 5 fields.

이전 | 처음으로 | 다음
mysqli_next_result | 위로 | mysqli_num_rows


mysqli_num_rows

(PHP 5)

mysqli_num_rows -- Gets the number of rows in a result

Description

Procedural style:

mixed mysqli_num_rows ( object result)

Object oriented style (property):

class mysqli {

mixed num_rows

}

Returns the number of rows in the result set.

The use of mysqli_num_rows() depends on whether you use buffered or unbuffered result sets. In case you use unbuffered resultsets mysqli_num_rows() will not correct the correct number of rows until all the rows in the result have been retrieved.

반환값

Returns number of rows in the result set.

참고: If the number of rows is greater than maximal int value, the number will be returned as a string.

참고

mysqli_affected_rows()
mysqli_store_result()
mysqli_use_result()
mysqli_query()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($result = $mysqli->query("SELECT Code, Name FROM Country ORDER BY Name")) {

    /* determine number of rows result set */
    $row_cnt = $result->num_rows;

    printf("Result set has %d rows.\n", $row_cnt);

    /* close result set */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($result = mysqli_query($link, "SELECT Code, Name FROM Country ORDER BY Name")) {

    /* determine number of rows result set */
    $row_cnt = mysqli_num_rows($result);

    printf("Result set has %d rows.\n", $row_cnt);

    /* close result set */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Result set has 239 rows.

이전 | 처음으로 | 다음
mysqli_num_fields | 위로 | mysqli_options


mysqli_options

(PHP 5)

mysqli_options

(no version information, might be only in CVS)

mysqli->options -- set options

Description

Procedural style:

bool mysqli_options ( object link, int option, mixed value)

Object oriented style (method)

class mysqli {

bool options ( int option, mixed value)

}

mysqli_options() can be used to set extra connect options and affect behavior for a connection.

This function may be called multiple times to set several options.

mysqli_options() should be called after mysqli_init() and before mysqli_real_connect().

The parameter option is the option that you want to set, the value is the value for the option. The parameter option can be one of the following values:

표 1. Valid options

Name | Description
MYSQLI_OPT_CONNECT_TIMEOUT | connection timeout in seconds
MYSQLI_OPT_COMPRESS | use compression protocol
MYSQLI_OPT_LOCAL_INFILE | enable/disable use of LOAD LOCAL INFILE
MYSQLI_INIT_CMD | command to execute after when connecting to MySQL server
MYSQLI_READ_DEFAULT_FILE | Read options from named option file instead of my.cnf
MYSQLI_READ_DEFAULT_GROUP | Read options from the named group from my.cnf or the file specified with MYSQL_READ_DEFAULT_FILE.

반환값

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고

mysqli_init(), mysqli_real_connect()

Example

See mysqli_real_connect().

이전 | 처음으로 | 다음
mysqli_num_rows | 위로 | mysqli_param_count


mysqli_param_count

mysqli_param_count -- Alias for mysqli_stmt_param_count()

Description

This function is an alias of mysqli_stmt_param_count(). For a detailled descripton see description of mysqli_stmt_param_count().

참고: mysqli_param_count() is deprecated and will be removed.

See also

mysqli_stmt_param_count()

이전 | 처음으로 | 다음
mysqli_options | 위로 | mysqli_ping


mysqli_ping

(PHP 5)

mysqli_ping

(no version information, might be only in CVS)

mysqli->ping -- Pings a server connection, or tries to reconnect if the connection has gone down.

Description

Procedural style:

bool mysqli_ping ( object link)

Object oriented style (method):

class mysqli {

bool ping ( void )

}

Checks whether the connection to the server is working. If it has gone down, and global option mysqli.reconnect is enabled an automatic reconnection is attempted.

This function can be used by clients that remain idle for a long while, to check whether the server has closed the connection and reconnect if necessary.

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* check if server is alive */
if ($mysqli->ping()) {
    printf ("Our connection is ok!\n");
} else {
    printf ("Error: %s\n", $mysqli->error);
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* check if server is alive */
if (mysqli_ping($link)) {
    printf ("Our connection is ok!\n");
} else {
    printf ("Error: %s\n", mysqli_error($link));
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Our connection is ok!

이전 | 처음으로 | 다음
mysqli_param_count | 위로 | mysqli_prepare


mysqli_prepare

(PHP 5)

mysqli_prepare

(no version information, might be only in CVS)

mysqli->prepare -- Prepare a SQL statement for execution

Description

Procedure style:

mixed mysqli_prepare ( object link, string query)

Object oriented style (method)

class stmt {

mixed prepare ( string query)

}

mysqli_prepare() prepares the SQL query pointed to by the null-terminated string query, and returns a statement handle to be used for further operations on the statement. The query must consist of a single SQL statement.

참고: You should not add a terminating semicolon or \g to the statement.

The parameter query can include one or more parameter markers in the SQL statement by embedding question mark (?) characters at the appropriate positions.

참고: The markers are legal only in certain places in SQL statements. For example, they are allowed in the VALUES() list of an INSERT statement (to specify column values for a row), or in a comparison with a column in a WHERE clause to specify a comparison value.

However, they are not allowed for identifiers (such as table or column names), in the select list that names the columns to be returned by a SELECT statement), or to specify both operands of a binary operator such as the = equal sign. The latter restriction is necessary because it would be impossible to determine the parameter type. In general, parameters are legal only in Data Manipulation Languange (DML) statements, and not in Data Defination Language (DDL) statements.

The parameter markers must be bound to application variables using mysqli_stmt_bind_param() and/or mysqli_stmt_bind_result() before executing the statement or fetching rows.

반환값

mysqli_prepare() returns a statement object or FALSE if an error occured.

참고

mysqli_stmt_execute(),
mysqli_stmt_fetch(),
mysqli_stmt_bind_param(),
mysqli_stmt_bind_result(),
mysqli_stmt_close()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$city = "Amersfoort";

/* create a prepared statement */
if ($stmt = $mysqli->prepare("SELECT District FROM City WHERE Name=?")) {

    /* bind parameters for markers */
    $stmt->bind_param("s", $city);

    /* execute query */
    $stmt->execute();

    /* bind result variables */
    $stmt->bind_result($district);

    /* fetch value */
    $stmt->fetch();

    printf("%s is in district %s\n", $city, $district);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$city = "Amersfoort";

/* create a prepared statement */
if ($stmt = mysqli_prepare($link, "SELECT District FROM City WHERE Name=?")) {

    /* bind parameters for markers */
    mysqli_stmt_bind_param($stmt, "s", $city);

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* bind result variables */
    mysqli_stmt_bind_result($stmt, $district);

    /* fetch value */
    mysqli_stmt_fetch($stmt);

    printf("%s is in district %s\n", $city, $district);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Amersfoort is in district Utrecht

이전 | 처음으로 | 다음
mysqli_ping | 위로 | mysqli_query


mysqli_query

(PHP 5)

mysqli_query

(no version information, might be only in CVS)

mysqli->query -- Performs a query on the database

Description

Procedural style:

mixed mysqli_query ( object link, string query [, int resultmode])

Object oriented style (method):

class mysqli {

mixed query ( string query)

}

The mysqli_query() function is used to simplify the act of performing a query against the database represented by the link parameter.

Functionally, using this function is identical to calling mysqli_real_query() followed either by mysqli_use_result() or mysqli_store_result() where query is the query string itself and resultmode is either the constant MYSQLI_USE_RESULT or MYSQLI_STORE_RESULT depending on the desired behavior. By default, if the resultmode is not provided MYSQLI_STORE_RESULT is used.

If you execute mysqli_query() with resultmode MYSQLI_USE_RESULT all subsequent calls will return error Commands out of sync unless you call mysqli_free_result().

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. For SELECT, SHOW, DESCRIBE or EXPLAIN mysqli_query() will return a result object.

See also

mysqli_real_query(),
mysqli_multi_query(),
mysqli_free_result()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Create table doesn't return a resultset */
if ($mysqli->query("CREATE TEMPORARY TABLE myCity LIKE City") === TRUE) {
    printf("Table myCity successfully created.\n");
}

/* Select queries return a resultset */
if ($result = $mysqli->query("SELECT Name FROM City LIMIT 10")) {
    printf("Select returned %d rows.\n", $result->num_rows);

    /* free result set */
    $result->close();
}

/* If we have to retrieve large amount of data we use MYSQLI_USE_RESULT */
if ($result = $mysqli->query("SELECT * FROM City", MYSQLI_USE_RESULT)) {

    /* Note, that we can't execute any functions which interact with the
       server until result set was closed. All calls will return an
       'out of sync' error */
    if (!$mysqli->query("SET @a:='this will not work'")) {
        printf("Error: %s\n", $mysqli->error);
    }
    $result->close();
}

$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Create table doesn't return a resultset */
if (mysqli_query($link, "CREATE TEMPORARY TABLE myCity LIKE City") === TRUE) {
    printf("Table myCity successfully created.\n");
}

/* Select queries return a resultset */
if ($result = mysqli_query($link, "SELECT Name FROM City LIMIT 10")) {
    printf("Select returned %d rows.\n", mysqli_num_rows($result));

    /* free result set */
    mysqli_free_result($result);
}

/* If we have to retrieve large amount of data we use MYSQLI_USE_RESULT */
if ($result = mysqli_query($link, "SELECT * FROM City", MYSQLI_USE_RESULT)) {

    /* Note, that we can't execute any functions which interact with the
       server until result set was closed. All calls will return an
       'out of sync' error */
    if (!mysqli_query($link, "SET @a:='this will not work'")) {
        printf("Error: %s\n", mysqli_error($link));
    }
    mysqli_free_result($result);
}

mysqli_close($link);
?>

The above examples would produce the following output:

Table myCity successfully created.
Select returned 10 rows.
Error: Commands out of sync;  You can't run this command now

이전 | 처음으로 | 다음
mysqli_prepare | 위로 | mysqli_real_connect


mysqli_real_connect

(PHP 5)

mysqli_real_connect

(no version information, might be only in CVS)

mysqli->real_connect -- Opens a connection to a mysql server

Description

Procedural style

bool mysqli_real_connect ( object link [, string hostname [, string username [, string passwd [, string dbname [, int port [, string socket [, int flags]]]]]]])

Object oriented style (method)

class mysqli {

bool real_connect ( [string hostname [, string username [, string passwd [, string dbname [, int port [, string socket [, int flags]]]]]]])

}

mysql_real_connect() attempts to establish a connection to a MySQL database engine running on host.

This function differs from mysqli_connect():

  • mysqli_real_connect() needs a valid object which has to be created by function mysqli_init()

  • With function mysqli_options() you can set various options for connection.

  • With the parameter flags you can set diffrent connection options:

    표 1. Supported flags

    Name | Description
    MYSQLI_CLIENT_COMPRESS | Use compression protocol
    MYSQLI_CLIENT_FOUND_ROWS | return number of matched rows, not the number of affected rows
    MYSQLI_CLIENT_IGNORE_SPACE | Allow spaces after function names. Makes all function names reserved words.
    MYSQLI_CLIENT_INTERACTIVE | Allow interactive_timeout seconds (instead of wait_timeout seconds) of inactivity before closing the connection
    MYSQLI_CLIENT_SSL | Use SSL (encryption)

    참고: For security reasons the MULTI_STATEMENT flag is not supported in PHP. If you want to execute multiple queries use the mysqli_multi_query() function.

반환값

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고

mysqli_connect(),
mysqli_init(),
mysqli_options(),
mysqli_ssl_set(),
mysqli_close().

Example

예 1. Object oriented style

<?php

/* create a connection object which is not connected */
$mysqli = mysqli_init();

/* set connection options */
$mysqli->options(MYSQLI_INIT_COMMAND, "SET AUTOCOMMIT=0");
$mysqli->options(MYSQLI_OPT_CONNECT_TIMEOUT, 5);

/* connect to server */
$mysqli->real_connect('localhost', 'my_user', 'my_password', 'world');

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

printf ("Connection: %s\n.", $mysqli->host_info);

$mysqli->close();
?>

예 2. Procedural style

<?php

/* create a connection object which is not connected */
$link = mysqli_init();

/* set connection options */
mysqli_options($link, MYSQLI_INIT_COMMAND, "SET AUTOCOMMIT=0");
mysqli_options($link, MYSQLI_OPT_CONNECT_TIMEOUT, 5);

/* connect to server */
mysqli_real_connect($link, 'localhost', 'my_user', 'my_password', 'world');

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

printf ("Connection: %s\n.", mysqli_get_host_info($link));

mysqli_close($link);
?>

The above examples would produce the following output:

Connection: Localhost via UNIX socket

이전 | 처음으로 | 다음
mysqli_query | 위로 | mysqli_real_escape_string


mysqli_real_escape_string

(PHP 5)

mysqli_real_escape_string

(no version information, might be only in CVS)

mysqli->real_escape_string -- Escapes special characters in a string for use in a SQL statement, taking into account the current charset of the connection

Description

Procedural style:

string mysqli_real_escape_string ( object link, string escapestr)

Object oriented style (method):

class mysqli {

string real_escape_sring ( string query)

}

This function is used to create a legal SQL string that you can use in a SQL statement. The string escapestr is encoded to an escaped SQL string, taking into account the current character set of the connection.

Characters encoded are NUL (ASCII 0), \n, \r, \, ', ", and Control-Z.

Return values

Returns an escaped string.

See also

mysqli_character_set_name().

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TEMPORARY TABLE myCity LIKE City");

$city = "'s Hertogenbosch";

/* this query will fail, cause we didn't escape $city */
if (!$mysqli->query("INSERT into myCity (Name) VALUES ('$city')")) {
    printf("Error: %s\n", $mysqli->sqlstate);
}

$city = $mysqli->real_escape_string($city);

/* this query with escaped $city will work */
if ($mysqli->query("INSERT into myCity (Name) VALUES ('$city')")) {
    printf("%d Row inserted.\n", $mysqli->affected_rows);
}

$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TEMPORARY TABLE myCity LIKE City");

$city = "'s Hertogenbosch";

/* this query will fail, cause we didn't escape $city */
if (!mysqli_query($link, "INSERT into myCity (Name) VALUES ('$city')")) {
    printf("Error: %s\n", mysqli_sqlstate($link));
}

$city = mysqli_real_escape_string($link, $city);

/* this query with escaped $city will work */
if (mysqli_query($link, "INSERT into myCity (Name) VALUES ('$city')")) {
    printf("%d Row inserted.\n", mysqli_affected_rows($link));
}

mysqli_close($link);
?>

The above examples would produce the following output:

Error: 42000
1 Row inserted.

이전 | 처음으로 | 다음
mysqli_real_connect | 위로 | mysqli_real_query


mysqli_real_query

(PHP 5)

mysqli_real_query

(no version information, might be only in CVS)

mysqli->real_query -- Execute an SQL query

Description

Procedural style

bool mysqli_real_query ( object link, string query)

Object oriented style (method):

class mysqli {

bool real_query ( string query)

}

The mysqli_real_query() function is used to execute only a query against the database represented by the link whose result can then be retrieved or stored using the mysqli_store_result() or mysqli_use_result() functions.

참고: In order to determine if a given query should return a result set or not, see mysqli_field_count().

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_query()
mysqli_store_result()
mysqli_use_result()

이전 | 처음으로 | 다음
mysqli_real_escape_string | 위로 | mysqli_report


mysqli_report

(PHP 5)

mysqli_report -- enables or disables internal report functions

Description

bool mysqli_report ( int flags)

mysqli_report() is a powerful function to improve your queries and code during development and testing phase. Depending on the flags it reports errors from mysqli function calls or queries which don't use an index (or use a bad index).

표 1. Supported flags

Name | Description
MYSQLI_REPORT_OFF | Turns reporting off
MYSQLI_REPORT_ERROR | Report errors from mysqli function calls
MYSQLI_REPORT_INDEX | Report if no index or bad index was used in a query
MYSQLI_REPORT_ALL | Set all options (report all)

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_debug(), mysqli_dump_debug_info()

Example

예 1. Object oriented style

<?php
/* activate reporting */
mysqli_report(MYSQLI_REPORT_ALL);

$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* this query should report an error */
$result = $mysqli->query("SELECT Name FROM Nonexistingtable WHERE population > 50000");

/* this query should report a warning */
$result = $mysqli->query("SELECT Name FROM City WHERE population > 50000");
$result->close();

$mysqli->close();
?>

이전 | 처음으로 | 다음
mysqli_real_query | 위로 | mysqli_rollback


mysqli_rollback

(PHP 5)

mysqli_rollback

(no version information, might be only in CVS)

mysqli->rollback -- Rolls back current transaction

Description

bool mysqli_rollback ( object link)

class mysqli {

bool rollback ( void )

}

Rollbacks the current transaction for the database specified by the link parameter.

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_commit() mysqli_autocommit()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* disable autocommit */
$mysqli->autocommit(FALSE);

$mysqli->query("CREATE TABLE myCity LIKE City");
$mysqli->query("ALTER TABLE myCity Type=InnoDB");
$mysqli->query("INSERT INTO myCity SELECT * FROM City LIMIT 50");

/* commit insert */
$mysqli->commit();

/* delete all rows */
$mysqli->query("DELETE FROM myCity");

if ($result = $mysqli->query("SELECT COUNT(*) FROM myCity")) {
    $row = $result->fetch_row();
    printf("%d rows in table myCity.\n", $row[0]);
    /* Free result */
    $result->close();
}

/* Rollback */
$mysqli->rollback();

if ($result = $mysqli->query("SELECT COUNT(*) FROM myCity")) {
    $row = $result->fetch_row();
    printf("%d rows in table myCity (after rollback).\n", $row[0]);
    /* Free result */
    $result->close();
}

/* Drop table myCity */
$mysqli->query("DROP TABLE myCity");

$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* disable autocommit */
mysqli_autocommit($link, FALSE);

mysqli_query($link, "CREATE TABLE myCity LIKE City");
mysqli_query($link, "ALTER TABLE myCity Type=InnoDB");
mysqli_query($link, "INSERT INTO myCity SELECT * FROM City LIMIT 50");

/* commit insert */
mysqli_commit($link);

/* delete all rows */
mysqli_query($link, "DELETE FROM myCity");

if ($result = mysqli_query($link, "SELECT COUNT(*) FROM myCity")) {
    $row = mysqli_fetch_row($result);
    printf("%d rows in table myCity.\n", $row[0]);
    /* Free result */
    mysqli_free_result($result);
}

/* Rollback */
mysqli_rollback($link);

if ($result = mysqli_query($link, "SELECT COUNT(*) FROM myCity")) {
    $row = mysqli_fetch_row($result);
    printf("%d rows in table myCity (after rollback).\n", $row[0]);
    /* Free result */
    mysqli_free_result($result);
}

/* Drop table myCity */
mysqli_query($link, "DROP TABLE myCity");

mysqli_close($link);
?>

The above examples would produce the following output:

0 rows in table myCity.
50 rows in table myCity (after rollback).

이전 | 처음으로 | 다음
mysqli_report | 위로 | mysqli_rpl_parse_enabled


mysqli_rpl_parse_enabled

(PHP 5)

mysqli_rpl_parse_enabled --

Description

int mysqli_rpl_parse_enabled ( object link)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

이전 | 처음으로 | 다음
mysqli_rollback | 위로 | mysqli_rpl_probe


mysqli_rpl_probe

(PHP 5)

mysqli_rpl_probe --

Description

bool mysqli_rpl_probe ( object link)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

이전 | 처음으로 | 다음
mysqli_rpl_parse_enabled | 위로 | mysqli_rpl_query_type


mysqli_rpl_query_type

(PHP 5)

mysqli_rpl_query_type --

Description

int mysqli_rpl_query_type ( string query)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

이전 | 처음으로 | 다음
mysqli_rpl_probe | 위로 | mysqli_select_db


mysqli_select_db

(PHP 5)

mysqli_select_db

(no version information, might be only in CVS)

mysqli->select_db -- Selects the default database for database queries

Description

bool mysqli_select_db ( object link, string dbname)

The mysqli_select_db() function selects the default database (specified by the dbname parameter) to be used when performing queries against the database connection represented by the link parameter.

참고: This function should only be used to change the default database for the connection. You can select the default database with 4th parameter in mysqli_connect().

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_connect() mysqli_real_connect()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* return name of current default database */
if ($result = $mysqli->query("SELECT DATABASE()")) {
    $row = $result->fetch_row();
    printf("Default database is %s.\n", $row[0]);
    $result->close();
}

/* change db to world db */
$mysqli->select_db("world");

/* return name of current default database */
if ($result = $mysqli->query("SELECT DATABASE()")) {
    $row = $result->fetch_row();
    printf("Default database is %s.\n", $row[0]);
    $result->close();
}

$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* return name of current default database */
if ($result = mysqli_query($link, "SELECT DATABASE()")) {
    $row = mysqli_fetch_row($result);
    printf("Default database is %s.\n", $row[0]);
    mysqli_free_result($result);
}

/* change db to world db */
mysqli_select_db($link, "world");

/* return name of current default database */
if ($result = mysqli_query($link, "SELECT DATABASE()")) {
    $row = mysqli_fetch_row($result);
    printf("Default database is %s.\n", $row[0]);
    mysqli_free_result($result);
}

mysqli_close($link);
?>

The above examples would produce the following output:

Default database is test.
Default database is world.

이전 | 처음으로 | 다음
mysqli_rpl_query_type | 위로 | mysqli_send_long_data


mysqli_send_long_data

mysqli_send_long_data -- Alias for mysqli_stmt_send_long_data()

Description

This function is an alias of mysqli_stmt_send_long_data(). For a detailled descripton see description of mysqli_stmt_send_long_data().

참고: mysqli_send_long_data() is deprecated and will be removed.

See also

mysqli_stmt_send_long_data()

이전 | 처음으로 | 다음
mysqli_select_db | 위로 | mysqli_send_query


mysqli_send_query

(PHP 5)

mysqli_send_query --

Description

bool mysqli_send_query ( resource link, string query)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

이전 | 처음으로 | 다음
mysqli_send_long_data | 위로 | mysqli_server_end


mysqli_server_end

(PHP 5)

mysqli_server_end --

Description

void mysqli_server_end ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

이전 | 처음으로 | 다음
mysqli_send_query | 위로 | mysqli_server_init


mysqli_server_init

(PHP 5)

mysqli_server_init -- Initialize embedded server.

Description

bool mysqli_server_init ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

이전 | 처음으로 | 다음
mysqli_server_end | 위로 | mysqli_set_opt


mysqli_set_opt

mysqli_set_opt -- Alias of mysqli_options()

Description

This function is an alias of mysqli_options().

이전 | 처음으로 | 다음
mysqli_server_init | 위로 | mysqli_sqlstate


mysqli_sqlstate

(PHP 5)

mysqli_sqlstate

(no version information, might be only in CVS)

mysqli->sqlstate -- Returns the SQLSTATE error from previous MySQL operation.

Description

string mysqli_sqlstate ( object link)

Returns a string containing the SQLSTATE error code for the last error. The error code consists of five characters. '00000' means no error. The values are specified by ANSI SQL and ODBC. For a list of possible values, see http://dev.mysql.com/doc/mysql/en/Error-returns.html.

참고: Note that not all MySQL errors are yet mapped to SQLSTATE's. The value HY000 (general error) is used for unmapped errors.

Return values

Returns a string containing the SQLSTATE error code for the last error. The error code consists of five characters. '00000' means no error.

See also

mysqli_errno(), mysqli_error()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Table City already exists, so we should get an error */
if (!$mysqli->query("CREATE TABLE City (ID INT, Name VARCHAR(30))")) {
    printf("Error - SQLSTATE %s.\n", $mysqli->sqlstate);
}

$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Table City already exists, so we should get an error */
if (!mysqli_query($link, "CREATE TABLE City (ID INT, Name VARCHAR(30))")) {
    printf("Error - SQLSTATE %s.\n", mysqli_sqlstate($link));
}

mysqli_close($link);
?>

The above examples would produce the following output:

Error - SQLSTATE 42S01.

이전 | 처음으로 | 다음
mysqli_set_opt | 위로 | mysqli_ssl_set


mysqli_ssl_set

(PHP 5)

mysqli_ssl_set

(no version information, might be only in CVS)

mysqli->ssl_set -- Used for establishing secure connections using SSL.

Description

Procedural style:

bool mysqli_ssl_set ( object link [, string key [, string cert [, string ca [, string capath [, string cipher]]]]])

Object oriented style (method):

class mysqli {

bool ssl_set ( [string key [, string cert [, string ca [, string capath [, string cipher]]]]])

}

The function mysqli_ssl_set() is used for establishing secure connections using SSL. It must be called before mysqli_real_connect(). This function does nothing unless OpenSSL support is enabled.

key is the pathname to the key file. cert is the pathname to the certificate file. ca is the pathname to the certificate authority file. capath is the pathname to a directory that contains trusted SSL CA certificates in pem format. cipher is a list of allowable ciphers to use for SSL encryption. Any unused SSL parameters may be given as NULL

Return values

This function always returns TRUE value. If SSL setup is incorrect mysqli_real_connect() will return an error when you attempt to connect.

See also

mysqli_options(), mysqli_real_connect()

이전 | 처음으로 | 다음
mysqli_sqlstate | 위로 | mysqli_stat


mysqli_stat

(PHP 5)

mysqli_stat

(no version information, might be only in CVS)

mysqli->stat -- Gets the current system status

Description

Procedural style:

mixed mysqli_stat ( object link)

Object oriented style (method):

class mysqli {

mixed mysqli->stat ( void )

}

mysqli_stat() returns a string containing information similar to that provided by the 'mysqladmin status' command. This includes uptime in seconds and the number of running threads, questions, reloads, and open tables.

Return values

A string describing the server status. FALSE if an error occurred.

See also

mysqli_get_server_info()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

printf ("System status: %s\n", $mysqli->stat());

$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

printf("System status: %s\n", mysqli_stat($link));

mysqli_close($link);
?>

The above examples would produce the following output:

System status: Uptime: 272  Threads: 1  Questions: 5340  Slow queries: 0
Opens: 13  Flush tables: 1  Open tables: 0  Queries per second avg: 19.632
Memory in use: 8496K  Max memory used: 8560K

이전 | 처음으로 | 다음
mysqli_ssl_set | 위로 | mysqli_stmt_affected_rows


mysqli_stmt_affected_rows

(PHP 5)

mysqli_stmt_affected_rows

(no version information, might be only in CVS)

mysqli_stmt->affected_rows -- Returns the total number of rows changed, deleted, or inserted by the last executed statement

Description

Procedural style :

mixed mysqli_stmt_affected_rows ( object stmt)

Object oriented style (property):

class stmt {

mixed affected_rows

}

mysqli_stmt_affected_rows() returns the number of rows affected by INSERT, UPDATE, or DELETE query. If the last query was invalid, this function will return -1.

The mysqli_stmt_affected_rows() function only works with queries which update a table. In order to return the number of rows from a SELECT query, use the mysqli_stmt_num_rows() function instead.

Return Values

An integer greater than zero indicates the number of rows affected or retrieved. Zero indicates that no records where updated for an UPDATE/DELETE statement, no rows matched the WHERE clause in the query or that no query has yet been executed. -1 indicates that the query has returned an error.

참고: If the number of affected rows is greater than maximal PHP int value, the number of affected rows will be returned as a string value.

See also

mysqli_stmt_num_rows(), mysqli_prepare()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* create temp table */
$mysqli->query("CREATE TEMPORARY TABLE myCountry LIKE Country");

$query = "INSERT INTO myCountry SELECT * FROM Country WHERE Code LIKE ?";

/* prepare statement */
if ($stmt = $mysqli->prepare($query)) {

    /* Bind variable for placeholder */
    $code = 'A%';
    $stmt->bind_param("s", $code);

    /* execute statement */
    $stmt->execute();

    printf("rows inserted: %d\n", $stmt->affected_rows);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* create temp table */
mysqli_query($link, "CREATE TEMPORARY TABLE myCountry LIKE Country");

$query = "INSERT INTO myCountry SELECT * FROM Country WHERE Code LIKE ?";

/* prepare statement */
if ($stmt = mysqli_prepare($link, $query)) {

    /* Bind variable for placeholder */
    $code = 'A%';
    mysqli_stmt_bind_param($stmt, "s", $code);

    /* execute statement */
    mysqli_stmt_execute($stmt);

    printf("rows inserted: %d\n", mysqli_stmt_affected_rows($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

rows inserted: 17

이전 | 처음으로 | 다음
mysqli_stat | 위로 | mysqli_stmt_bind_param


mysqli_stmt_bind_param

(PHP 5)

mysqli_stmt_bind_param

(no version information, might be only in CVS)

stmt->bind_param -- Binds variables to a prepared statement as parameters

Description

Procedural style:

bool mysqli_stmt_bind_param ( object stmt, string types, mixed var1 [, mixed var2, ...])

Object oriented style (method):

class stmt {

bool bind_param ( array types, mixed var1 [, mixed var2, ...])

}

mysqli_stmt_bind_param() is used to bind variables for the parameter markers in the SQL statement that was passed to mysql_prepare(). The string types contains one or more characters which specify the types for the corresponding bind variables

표 1. Type specification chars

Character | Description
i | corresponding variable has type integer
d | corresponding variable has type double
s | corresponding variable has type string
b | corresponding variable is a blob and will be send in packages

참고: If data size of a variable exceeds max. allowed package size (max_allowed_package), you have to specify b in types and use mysqli_stmt_send_long_data() to send the data in packages.

The number of variables and length of string types must match the parameters in the statement.

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_stmt_bind_result(),
mysqli_stmt_execute(),
mysqli_stmt_fetch(),
mysqli_prepare(),
mysqli_stmt_send_long_data(),
mysqli_stmt_errno(),
mysqli_stmt_error()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli('localhost', 'my_user', 'my_password', 'world');

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$stmt = $mysqli->prepare("INSERT INTO CountryLanguage VALUES (?, ?, ?, ?)");
$stmt->bind_param('sssd', $code, $language, $official, $percent);

$code = 'DEU';
$language = 'Bavarian';
$official = "F";
$percent = 11.2;

/* execute prepared statement */
$stmt->execute();

printf("%d Row inserted.\n", $stmt->affected_rows);

/* close statement and connection */
$stmt->close();

/* Clean up table CountryLanguage */
$mysqli->query("DELETE FROM CountryLanguage WHERE Language='Bavarian'");
printf("%d Row deleted.\n", $mysqli->affected_rows);

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect('localhost', 'my_user', 'my_password', 'world');

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$stmt = mysqli_prepare($link, "INSERT INTO CountryLanguage VALUES (?, ?, ?, ?)");
mysqli_stmt_bind_param($stmt, 'sssd', $code, $language, $official, $percent);

$code = 'DEU';
$language = 'Bavarian';
$official = "F";
$percent = 11.2;

/* execute prepared statement */
mysqi_stmt_execute($stmt);

printf("%d Row inserted.\n", mysqli_stmt_affected_rows($stmt));

/* close statement and connection */
mysqli_stmt_close($stmt);

/* Clean up table CountryLanguage */
mysqli_query($link, "DELETE FROM CountryLanguage WHERE Language='Bavarian'");
printf("%d Row deleted.\n", mysqli_affected_rows($link));

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

1 Row inserted.
1 Row deleted.

이전 | 처음으로 | 다음
mysqli_stmt_affected_rows | 위로 | mysqli_stmt_bind_result


mysqli_stmt_bind_result

(PHP 5)

mysqli_stmt_bind_result

(no version information, might be only in CVS)

stmt->bind_result -- Binds variables to a prepared statement for result storage

Description

Procedural style:

bool mysqli_stnt_bind_result ( object stmt, mixed var1 [, mixed var2, ...])

Object oriented style (method):

class stmt {

bool bind_result ( mixed var1 [, mixed var2, ...])

}

mysqli_stmt_bind_result() is used to associate (bind) columns in the result set to variables. When mysqli_stmt_fetch() is called to fetch data, the MySQL client/server protocol places the data for the bound columns into the specified variables var1, ....

참고: Note that all columns must be bound prior to calling mysqli_stmt_fetch(). Depending on column types bound variables can silently change to the corresponding PHP type.

A column can be bound or rebound at any time, even after a result set has been partially retrieved. The new binding takes effect the next time mysqli_stmt_fetch() is called.

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_stmt_bind_param(),
mysqli_stmt_execute(),
mysqli_stmt_fetch(),
mysqli_prepare(),
mysqli_stmt_prepare(),
mysqli_stmt_init(),
mysqli_stmt_errno(),
mysqli_stmt_error()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* prepare statement */
if ($stmt = $mysqli->prepare("SELECT Code, Name FROM Country ORDER BY Name LIMIT 5")) {
    $stmt->execute();

    /* bind variables to prepared statement */
    $stmt->bind_result($col1, $col2);

    /* fetch values */
    while ($stmt->fetch()) {
        printf("%s %s\n", $col1, $col2);
    }

    /* close statement */
    $stmt->close();
}
/* close connection */
$mysqli->close();

?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* prepare statement */
if ($stmt = mysqli_prepare($link, "SELECT Code, Name FROM Country ORDER BY Name LIMIT 5")) {
    mysqli_stmt_execute($stmt);

    /* bind variables to prepared statement */
    mysqli_stmt_bind_result($stmt, $col1, $col2);

    /* fetch values */
    while (mysqli_stmt_fetch($stmt)) {
       printf("%s %s\n", $col1, $col2);
    }

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

AFG Afghanistan
ALB Albania
DZA Algeria
ASM American Samoa
AND Andorra

이전 | 처음으로 | 다음
mysqli_stmt_bind_param | 위로 | mysqli_stmt_close


mysqli_stmt_close

(PHP 5)

mysqli_stmt_close

(no version information, might be only in CVS)

mysqli_stmt->close -- Closes a prepared statement

Description

Procedural style:

bool mysqli_stmt_close ( object stmt)

Object oriented style (method):

class mysqli_stmt {

bool mysqli_stmt->close ( void )

}

Closes a prepared statement. mysql_stmt_close() also deallocates the statement handle pointed to by stmt. If the current statement has pending or unread results, this function cancels them so that the next query can be executed.

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_prepare(),

이전 | 처음으로 | 다음
mysqli_stmt_bind_result | 위로 | mysqli_stmt_data_seek


mysqli_stmt_data_seek

(PHP 5)

mysqli_stmt_data_seek

(no version information, might be only in CVS)

stmt->data_seek -- Seeks to an arbitray row in statement result set

Description

Procedural style:

bool mysqli_stmt_data_seek ( object statement, int offset)

Object oriented style (method):

class stmt {

bool data_seek ( int offset)

}

The mysqli_stmt_data_seek() function seeks to an arbitrary result pointer specified by the offset in the statement result set represented by statement. The offset parameter must be between zero and the total number of rows minus one (0..mysqli_stmt_num_rows() - 1).

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_prepare()

Example

예 1. Object oriented style

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name";
if ($stmt = $mysqli->prepare($query)) {

    /* execute query */
    $stmt->execute();

    /* bind result variables */
    $stmt->bind_result($name, $code);

    /* store result */
    $stmt->store_result();

    /* seek to row no. 400 */
    $stmt->data_seek(399);

    /* fetch values */
    $stmt->fetch();

    printf ("City: %s  Countrycode: %s\n", $name, $code);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name";
if ($stmt = mysqli_prepare($link, $query)) {

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* bind result variables */
    mysqli_stmt_bind_result($stmt, $name, $code);

    /* store result */
    mysqli_stmt_store_result($stmt);

    /* seek to row no. 400 */
    mysqli_stmt_data_seek($stmt, 399);

    /* fetch values */
    mysqli_stmt_fetch($stmt);

    printf ("City: %s  Countrycode: %s\n", $name, $code);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

City: Benin City  Countrycode: NGA

이전 | 처음으로 | 다음
mysqli_stmt_close | 위로 | mysqli_stmt_errno


mysqli_stmt_errno

(PHP 5)

mysqli_stmt_errno

(no version information, might be only in CVS)

mysqli_stmt->errno -- Returns the error code for the most recent statement call

Description

Procedural style :

int mysqli_stmt_errno ( object stmt)

Object oriented style (property):

class stmt {

int errno

}

For the statement specified by stmt, mysqli_stmt_errno() returns the error code for the most recently invoked statement function that can succeed or fail.

참고: Client error message numbers are listed in the MySQL errmsg.h header file, server error message numbers are listed in mysqld_error.h. In the MySQL source distribution you can find a complete list of error messages and error numbers in the file Docs/mysqld_error.txt.

Return values

An error code value. Zero means no error occurred.

See also

mysqli_stmt_error(), mysqli_stmt_sqlstate()

Example

예 1. Object oriented style

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCountry LIKE Country");
$mysqli->query("INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = $mysqli->prepare($query)) {

    /* drop table */
    $mysqli->query("DROP TABLE myCountry");

    /* execute query */
    $stmt->execute();

    printf("Error: %d.\n", $stmt->errno);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCountry LIKE Country");
mysqli_query($link, "INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = mysqli_prepare($link, $query)) {

    /* drop table */
    mysqli_query($link, "DROP TABLE myCountry");

    /* execute query */
    mysqli_stmt_execute($stmt);

    printf("Error: %d.\n", mysqli_stmt_errno($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Error: 1146.

이전 | 처음으로 | 다음
mysqli_stmt_data_seek | 위로 | mysqli_stmt_error


mysqli_stmt_error

(PHP 5)

mysqli_stmt_error

(no version information, might be only in CVS)

mysqli_stmt->error -- Returns a string description for last statement error

Description

Procedural style:

string mysqli_stmt_error ( object stmt)

Object oriented style (property):

class stmt {

string error

}

For the statement specified by stmt, mysql_stmt_error() returns a containing the error message for the most recently invoked statement function that can succeed or fail.

Return values

A string that describes the error. An empty string if no error occurred.

See also

mysqli_stmt_errno(), mysqli_stmt_sqlstate()

Example

예 1. Object oriented style

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCountry LIKE Country");
$mysqli->query("INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = $mysqli->prepare($query)) {

    /* drop table */
    $mysqli->query("DROP TABLE myCountry");

    /* execute query */
    $stmt->execute();

    printf("Error: %s.\n", $stmt->error);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCountry LIKE Country");
mysqli_query($link, "INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = mysqli_prepare($link, $query)) {

    /* drop table */
    mysqli_query($link, "DROP TABLE myCountry");

    /* execute query */
    mysqli_stmt_execute($stmt);

    printf("Error: %s.\n", mysqli_stmt_error($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Error: Table 'world.myCountry' doesn't exist.

이전 | 처음으로 | 다음
mysqli_stmt_errno | 위로 | mysqli_stmt_execute


mysqli_stmt_execute

(PHP 5)

mysqli_stmt_execute

(no version information, might be only in CVS)

stmt->execute -- Executes a prepared Query

Description

Procedural style:

bool mysqli_stmt_execute ( object stmt)

Object oriented style (method):

class mysql {

bool execute ( void )

}

The mysqli_stmt_execute() function executes a query that has been previously prepared using the mysqli_prepare() function represented by the stmt object. When executed any parameter markers which exist will automatically be replaced with the appropiate data.

If the statement is UPDATE, DELETE, or INSERT, the total number of affected rows can be determined by using the mysqli_stmt_affected_rows() function. Likewise, if the query yields a result set the mysqli_fetch() function is used.

참고: When using mysqli_stmt_execute(), the mysqli_fetch() function must be used to fetch the data prior to preforming any additional queries.

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_prepare() mysqli_stmt_bind_param().

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCity LIKE City");

/* Prepare an insert statement */
$query = "INSERT INTO myCity (Name, CountryCode, District) VALUES (?,?,?)";
$stmt = $mysqli->prepare($query);

$stmt->bind_param("sss", $val1, $val2, $val3);

$val1 = 'Stuttgart';
$val2 = 'DEU';
$val3 = 'Baden-Wuerttemberg';

/* Execute the statement */
$stmt->execute();

$val1 = 'Bordeaux';
$val2 = 'FRA';
$val3 = 'Aquitaine';

/* Execute the statement */
$stmt->execute();

/* close statement */
$stmt->close();

/* retrieve all rows from myCity */
$query = "SELECT Name, CountryCode, District FROM myCity";
if ($result = $mysqli->query($query)) {
    while ($row = $result->fetch_row()) {
        printf("%s (%s,%s)\n", $row[0], $row[1], $row[2]);
    }
    /* free result set */
    $result->close();
}

/* remove table */
$mysqli->query("DROP TABLE myCity");

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCity LIKE City");

/* Prepare an insert statement */
$query = "INSERT INTO myCity (Name, CountryCode, District) VALUES (?,?,?)";
$stmt = mysqli_prepare($link, $query);

mysqli_stmt_bind_param($stmt, "sss", $val1, $val2, $val3);

$val1 = 'Stuttgart';
$val2 = 'DEU';
$val3 = 'Baden-Wuerttemberg';

/* Execute the statement */
mysqli_stmt_execute($stmt);

$val1 = 'Bordeaux';
$val2 = 'FRA';
$val3 = 'Aquitaine';

/* Execute the statement */
mysqli_stmt_execute($stmt);

/* close statement */
mysqli_stmt_close($stmt);

/* retrieve all rows from myCity */
$query = "SELECT Name, CountryCode, District FROM myCity";
if ($result = mysqli_query($link, $query)) {
    while ($row = mysqli_fetch_row($result)) {
        printf("%s (%s,%s)\n", $row[0], $row[1], $row[2]);
    }
    /* free result set */
    mysqli_free_result($result);
}

/* remove table */
mysqli_query($link, "DROP TABLE myCity");

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Stuttgart (DEU,Baden-Wuerttemberg)
Bordeaux (FRA,Aquitaine)

이전 | 처음으로 | 다음
mysqli_stmt_error | 위로 | mysqli_stmt_fetch


mysqli_stmt_fetch

(PHP 5)

mysqli_stmt_fetch

(no version information, might be only in CVS)

stmt->fetch -- Fetch results from a prepared statement into the bound variables

Description

Procedural style:

mixed mysqli_stmt_fetch ( object stmt)

Object oriented style (method):

class stmt {

mixed fetch ( void )

}

mysqli_stmt_fetch() returns row data using the variables bound by mysqli_stmt_bind_result().

참고: Note that all columns must be bound by the application before calling mysqli_stmt_fetch().

Return values

표 1. Return values

Value | Description
TRUE | Success. Data has been fetched
FALSE | Error occured
NULL | No more rows/data exists

See also

mysqli_prepare(),
mysqli_stmt_errno(),
mysqli_stmt_error(),
mysqli_stmt_bind_result()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 150,5";

if ($stmt = $mysqli->prepare($query)) {

    /* execute statement */
    $stmt->execute();

    /* bind result variables */
    $stmt->bind_result($name, $code);

    /* fetch values */
    while ($stmt->fetch()) {
        printf ("%s (%s)\n", $name, $code);
    }

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 150,5";

if ($stmt = mysqli_prepare($link, $query)) {

    /* execute statement */
    mysqli_stmt_execute($stmt);

    /* bind result variables */
    mysqli_stmt_bind_result($stmt, $name, $code);

    /* fetch values */
    while (mysqli_stmt_fetch($stmt)) {
        printf ("%s (%s)\n", $name, $code);
    }

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Rockford (USA)
Tallahassee (USA)
Salinas (USA)
Santa Clarita (USA)
Springfield (USA)

이전 | 처음으로 | 다음
mysqli_stmt_execute | 위로 | mysqli_stmt_free_result


mysqli_stmt_free_result

(PHP 5)

mysqli_stmt_free_result

(no version information, might be only in CVS)

stmt->free_result -- Frees stored result memory for the given statement handle

Description

Procedural style:

void mysqli_stmt_free_result ( object stmt)

Object oriented style (method):

class stmt {

void free_result ( void )

}

The mysqli_stmt_free_result() function frees the result memory associated with the statement represented by the stmt parameter, which was allocated by mysqli_stmt_store_result().

반환값

This function doesn't return any value.

참고

mysqli_stmt_store_result()

이전 | 처음으로 | 다음
mysqli_stmt_fetch | 위로 | mysqli_stmt-init


mysqli_stmt-init

(PHP 5)

mysqli_stmt-init

(no version information, might be only in CVS)

mysqli->stmt->init -- Initializes a statement and returns an object for use with mysqli_stmt_prepare

Description

Procedural style :

object mysqli_stmt_init ( object link)

Object oriented style (property):

class mysqli {

object stmt_init ( void )

}

Allocates and initializes a statement object suitable for mysqli_stmt_prepare().

참고: Any subsequent calls to any mysqli_stmt function will fail until mysqli_stmt_prepare() was called.

반환값

Returns an object.

참고

mysqli_stmt_prepare()

이전 | 처음으로 | 다음
mysqli_stmt_free_result | 위로 | mysqli_stmt_num_rows


mysqli_stmt_num_rows

(PHP 5)

mysqli_stmt_num_rows

(no version information, might be only in CVS)

stmt->num_rows -- Return the number of rows in statements result set.

Description

mixed mysqli_stmt_num_rows ( object stmt)

class stmt {

int num_rows

}

Returns the number of rows in the result set. The use of mysqli_stmt_num_rows() depends on whether or not you used mysqli_stmt_store_result() to buffer the entire result set in the statement handle.

If you use mysqli_stmt_store_result(), mysqli_stmt_num_rows() may be called immediately.

Return values

An integer representing the number of rows in result set.

See also

mysqli_stmt_affected_rows(),
mysqli_prepare(),
mysqli_stmt_store_result()

Example

예 1. Object oriented style

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($stmt = $mysqli->prepare($query)) {

    /* execute query */
    $stmt->execute();

    /* store result */
    $stmt->store_result();

    printf("Number of rows: %d.\n", $stmt->num_rows);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($stmt = mysqli_prepare($link, $query)) {

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* store result */
    mysqli_stmt_store_result($stmt);

    printf("Number of rows: %d.\n", mysqli_stmt_num_rows($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Number of rows: 20.

이전 | 처음으로 | 다음
mysqli_stmt-init | 위로 | mysqli_stmt_param_count


mysqli_stmt_param_count

(PHP 5)

mysqli_stmt_param_count

(no version information, might be only in CVS)

stmt->param_count -- Returns the number of parameter for the given statement

Description

Procedural style:

int mysqli_stmt_param_count ( object stmt)

Object oriented style (property):

class stmt {

int param_count

}

mysqli_stmt_param_count() returns the number of parameter markers present in the prepared statement.

반환값

returns an integer representing the number of parameters.

참고

mysqli_prepare()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($stmt = $mysqli->prepare("SELECT Name FROM Country WHERE Name=? OR Code=?")) {

    $marker = $stmt->param_count;
    printf("Statement has %d markers.\n", $marker);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($stmt = mysqli_prepare($link, "SELECT Name FROM Country WHERE Name=? OR Code=?")) {

    $marker = mysqli_stmt_param_count($stmt);
    printf("Statement has %d markers.\n", $marker);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Statement has 2 markers.

이전 | 처음으로 | 다음
mysqli_stmt_num_rows | 위로 | mysqli_stmt_prepare


mysqli_stmt_prepare

(PHP 5)

mysqli_stmt_prepare

(no version information, might be only in CVS)

stmt->prepare -- Prepare a SQL statement for execution

Description

Procedure style:

bool mysqli_stmt_prepare ( object stmt, string query)

Object oriented style (method)

class stmt {

mixed prepare ( string query)

}

mysqli_stmt_prepare() prepares the SQL query pointed to by the null-terminated string query. The statement object has to be allocated by mysqli_stmt_init(). The query must consist of a single SQL statement.

참고: You should not add a terminating semicolon or \g to the statement.

The parameter query can include one or more parameter markers in the SQL statement by embedding question mark (?) characters at the appropriate positions.

참고: The markers are legal only in certain places in SQL statements. For example, they are allowed in the VALUES() list of an INSERT statement (to specify column values for a row), or in a comparison with a column in a WHERE clause to specify a comparison value.

However, they are not allowed for identifiers (such as table or column names), in the select list that names the columns to be returned by a SELECT statement), or to specify both operands of a binary operator such as the = equal sign. The latter restriction is necessary because it would be impossible to determine the parameter type. In general, parameters are legal only in Data Manipulation Languange (DML) statements, and not in Data Defination Language (DDL) statements.

The parameter markers must be bound to application variables using mysqli_stmt_bind_param() and/or mysqli_stmt_bind_result() before executing the statement or fetching rows.

반환값

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고

mysqli_stmt_init(),
mysqli_stmt_execute(),
mysqli_stmt_fetch(),
mysqli_stmt_bind_param(),
mysqli_stmt_bind_result(),
mysqli_stmt_close()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$city = "Amersfoort";

/* create a prepared statement */
$stmt =  $mysqli->stmt_init();
if ($stmt->prepare("SELECT District FROM City WHERE Name=?")) {

    /* bind parameters for markers */
    $stmt->bind_param("s", $city);

    /* execute query */
    $stmt->execute();

    /* bind result variables */
    $stmt->bind_result($district);

    /* fetch value */
    $stmt->fetch();

    printf("%s is in district %s\n", $city, $district);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$city = "Amersfoort";

/* create a prepared statement */
$stmt = mysqli_stmt_init();
if ($stmt = mysqli_stmt_prepare($stmt, "SELECT District FROM City WHERE Name=?")) {

    /* bind parameters for markers */
    mysqli_stmt_bind_param($stmt, "s", $city);

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* bind result variables */
    mysqli_stmt_bind_result($stmt, $district);

    /* fetch value */
    mysqli_stmt_fetch($stmt);

    printf("%s is in district %s\n", $city, $district);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Amersfoort is in district Utrecht

이전 | 처음으로 | 다음
mysqli_stmt_param_count | 위로 | mysqli_stmt_result_metadata


mysqli_stmt_result_metadata

(PHP 5)

mysqli_stmt_result_metadata -- returns result set metadata from a prepared statement

Description

Procedural style:

mixed mysqli_stmt_result_metadata ( object stmt)

Object oriented style (method):

class stmt {

mixed result_metadata ( void )

}

If a statement passed to mysqli_prepare() is one that produces a result set, mysqli_stmt_result_metadata() returns the result object that can be used to process the meta information such as total number of fields and individual field information.

참고: This result set pointer can be passed as an argument to any of the field-based functions that process result set metadata, such as:

  • mysqli_num_fields()

  • mysqli_fetch_field()

  • mysqli_fetch_field_direct()

  • mysqli_fetch_fields()

  • mysqli_field_count()

  • mysqli_field_seek()

  • mysqli_field_tell()

  • mysqli_free_result()

The result set structure should be freed when you are done with it, which you can do by passing it to mysqli_free_result()

참고: The result set returned by mysqli_stmt_result_metadata() contains only metadata. It does not contain any row results. The rows are obtained by using the statement handle with mysqli_fetch().

반환값

mysqli_stmt_result_metadata() returns a result object or FALSE if an error occured.

See also:

mysqli_prepare(), mysqli_free_result()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

$mysqli->query("DROP TABLE IF EXISTS friends");
$mysqli->query("CREATE TABLE friends (id int, name varchar(20))");

$mysqli->query("INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

$stmt = $mysqli->prepare("SELECT id, name FROM friends");
$stmt->execute();

/* get resultset for metadata */
$result = $stmt->result_metadata();

/* retrieve field information from metadata result set */
$field = $result->fetch_field();

printf("Fieldname: %s\n", $field->name);

/* close resultset */
$result->close();

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

mysqli_query($link, "DROP TABLE IF EXISTS friends");
mysqli_query($link, "CREATE TABLE friends (id int, name varchar(20))");

mysqli_query($link, "INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

$stmt = mysqli_prepare($link, "SELECT id, name FROM friends");
mysqli_stmt_execute($stmt);

/* get resultset for metadata */
$result = mysqli_stmt_result_metadata($stmt);

/* retrieve field information from metadata result set */
$field = mysqli_fetch_field($result);

printf("Fieldname: %s\n", $field->name);

/* close resultset */
mysqli_free_result($result);

/* close connection */
mysqli_close($link);
?>

이전 | 처음으로 | 다음
mysqli_stmt_prepare | 위로 | mysqli_stmt_send_long_data


mysqli_stmt_send_long_data

(PHP 5)

mysqli_stmt_send_long_data

(no version information, might be only in CVS)

stmt->send_long_data -- Send data in blocks

Description

Procedural style:

bool mysqli_stmt_send_long_data ( object stmt, int param_nr, string data)

Object oriented style (method)

class stmt {

bool stmt_send_long_data ( int param_nr, string data)

}

Allows to send parameter data to the server in pieces (or chunks), e.g. if the size of a blob exceeds the size of max_allowed_packet. This function can be called multiple times to send the parts of a character or binary data value for a column, which must be one of the TEXT or BLOB datatypes.

param_nr indicates which parameter to associate the data with. Parameters are numbered beginning with 0. data is a string containing data to be sent.

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_prepare(), mysqli_stmt_bind_param()

이전 | 처음으로 | 다음
mysqli_stmt_result_metadata | 위로 | mysqli_stmt_sqlstate


mysqli_stmt_sqlstate

(PHP 5)

mysqli_stmt_sqlstate -- returns SQLSTATE error from previous statement operation

Description

string mysqli_stmt_sqlstate ( object stmt)

Returns a string containing the SQLSTATE error code for the most recently invoked prepared statement function that can succeed or fail. The error code consists of five characters. '00000' means no error. The values are specified by ANSI SQL and ODBC. For a list of possible values, see http://dev.mysql.com/doc/mysql/en/Error-returns.html.

참고: Note that not all MySQL errors are yet mapped to SQLSTATE's. The value HY000 (general error) is used for unmapped errors.

Return values

Returns a string containing the SQLSTATE error code for the last error. The error code consists of five characters. '00000' means no error.

See also

mysqli_stmt_errno(), mysqli_stmt_error()

Example

예 1. Object oriented style

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCountry LIKE Country");
$mysqli->query("INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = $mysqli->prepare($query)) {

    /* drop table */
    $mysqli->query("DROP TABLE myCountry");

    /* execute query */
    $stmt->execute();

    printf("Error: %s.\n", $stmt->sqlstate);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCountry LIKE Country");
mysqli_query($link, "INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = mysqli_prepare($link, $query)) {

    /* drop table */
    mysqli_query($link, "DROP TABLE myCountry");

    /* execute query */
    mysqli_stmt_execute($stmt);

    printf("Error: %s.\n", mysqli_stmt_sqlstate($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Error: 42S02.

이전 | 처음으로 | 다음
mysqli_stmt_send_long_data | 위로 | mysqli_stmt_store_result


mysqli_stmt_store_result

(PHP 5)

mysqli_stmt_store_result

(no version information, might be only in CVS)

mysqli_stmt->store_result -- Transfers a result set from a prepared statement

Description

Procedural style:

bool mysqli_stmt_store_result ( object stmt)

Object oriented style (method):

class mysqli_stmt {

bool store_result ( void )

}

You must call mysql_stmt_store_result() for every query that successfully produces a result set (SELECT, SHOW, DESCRIBE, EXPLAIN), and only if you want to buffer the complete result set by the client, so that the subsequent mysql_fetch() call returns buffered data.

참고: It is unnecessary to call mysql_stmt_store_result() for other queries, but if you do, it will not harm or cause any notable performance in all cases. You can detect whether the query produced a result set by checking if mysql_stmt_result_metadata() returns NULL.

Return values

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also

mysqli_prepare(),
mysqli_stmt_result_metadata(),
mysqli_fetch()

Example

예 1. Object oriented style

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($stmt = $mysqli->prepare($query)) {

    /* execute query */
    $stmt->execute();

    /* store result */
    $stmt->store_result();

    printf("Number of rows: %d.\n", $stmt->num_rows);

    /* free result */
    $stmt->free_result();

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($stmt = mysqli_prepare($link, $query)) {

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* store result */
    mysqli_stmt_store_result($stmt);

    printf("Number of rows: %d.\n", mysqli_stmt_num_rows($stmt));

    /* free result */
    mysqli_stmt_free_result($stmt);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Number of rows: 20.

이전 | 처음으로 | 다음
mysqli_stmt_sqlstate | 위로 | mysqli_store_result


mysqli_store_result

(PHP 5)

mysqli_store_result

(no version information, might be only in CVS)

mysqli->store_result -- Transfers a result set from the last query

Description

Procedural style:

object mysqli_store_result ( object link)

Object oriented style (method):

class mysqli {

object store_result ( void )

}

Transfers the result set from the last query on the database connection represented by the link parameter to be used with the mysqli_data_seek() function.

참고: Although it is always good practice to free the memory used by the result of a query using the mysqli_free_result() function, when transfering large result sets using the mysqli_store_result() this becomes particularly important.

참고: mysqli_store_result() returns FALSE in case the query didn't return a result set (if the query was, for example an INSERT statement). This function also returns FALSE if the reading of the result set failed. You can check if you have got an error by checking if mysqli_error() doesn't return an empty string, if mysqli_errno() returns a non zero value, or if mysqli_field_count() returns a non zero value. Also possible reason for this function returning FALSE after successfull call to mysqli_query() can be too large result set (memory for it cannot be allocated). If mysqli_field_count() returns a non-zero value, the statement should have produced a non-empty result set.

Return values

Returns a buffered result object or FALSE if an error occured.

See also

mysqli_real_query(), mysqli_use_result().

Example

See mysqli_multi_query().

이전 | 처음으로 | 다음
mysqli_stmt_store_result | 위로 | mysqli_thread_id


mysqli_thread_id

(PHP 5)

mysqli_thread_id

(no version information, might be only in CVS)

mysqli->thread_id -- Returns the thread ID for the current connection

Description

Procedural style:

int mysqli_thread_id ( object link)

Object oriented style (property):

class mysqli {

int thread_id

}

The mysqli_thread_id() function returns the thread ID for the current connection which can then be killed using the mysqli_kill() function. If the connection is lost and you reconnect with mysqli_ping(), the thread ID will be other. Therefore you should get the thread ID only when you need it.

참고: The thread ID is assigned on a connection-by-connection basis. Hence, if the connection is broken and then re-established a new thread ID will be assigned.

To kill a running query you can use the SQL command KILL QUERY processid].

Return values

mysqli_thread_id() returns the Thread ID for the current connection.

See also

mysqli_kill()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* determine our thread id */
$thread_id = $mysqli->thread_id;

/* Kill connection */
$mysqli->kill($thread_id);

/* This should produce an error */
if (!$mysqli->query("CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", $mysqli->error);
    exit;
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* determine our thread id */
$thread_id = mysqli_thread_id($link);

/* Kill connection */
mysqli_kill($link, $thread_id);

/* This should produce an error */
if (!mysqli_query($link, "CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", mysqli_error($link));
    exit;
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Error: MySQL server has gone away

이전 | 처음으로 | 다음
mysqli_store_result | 위로 | mysqli_thread_safe


mysqli_thread_safe

(PHP 5)

mysqli_thread_safe -- Returns whether thread safety is given or not

Description

Procedural style:

bool mysqli_thread_safe ( void )

mysqli_thread_safe() indicates whether the client library is compiled as thread-safe.

Return values

TRUE if the client library is thread-safe, otherwise FALSE.

이전 | 처음으로 | 다음
mysqli_thread_id | 위로 | mysqli_use_result


mysqli_use_result

(PHP 5)

mysqli_use_result

(no version information, might be only in CVS)

mysqli->use_result -- Initiate a result set retrieval

Description

Procedural style:

mixed mysqli_use_result ( object link)

Object oriented style (method):

class mysqli {

mixed use_result ( void )

}

mysqli_use_result() is used to initiate the retrieval of a result set from the last query executed using the mysqli_real_query() function on the database connection specified by the link parameter. Either this or the mysqli_store_result() function must be called before the results of a query can be retrieved, and one or the other must be called to prevent the next query on that database connection from failing.

참고: The mysqli_use_result() function does not transfer the entire result set from the database and hence cannot be used functions such as mysqli_data_seek() to move to a particular row within the set. To use this functionality, the result set must be stored using mysqli_store_result(). One should not use mysqli_use_result() if a lot of processing on the client side is performed, since this will tie up the server and prevent other threads from updating any tables from which the data is being fetched.

Return values

Returns an unbuffered result object or FALSE if an error occured.

See also

mysqli_real_query(), mysqli_store_result().

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query  = "SELECT CURRENT_USER();";
$query .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* execute multi query */
if ($mysqli->multi_query($query)) {
    do {
        /* store first result set */
        if ($result = $mysqli->use_result()) {
            while ($row = $result->fetch_row()) {
                printf("%s\n", $row[0]);
            }
            $result->close();
        }
        /* print divider */
        if ($mysqli->more_results()) {
            printf("-----------------\n");
        }
    } while ($mysqli->next_result());
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query  = "SELECT CURRENT_USER();";
$query .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* execute multi query */
if (mysqli_multi_query($link, $query)) {
    do {
        /* store first result set */
        if ($result = mysqli_use_result($link)) {
            while ($row = mysqli_fetch_row($result)) {
                printf("%s\n", $row[0]);
            }
            mysqli_free_result($result);
        }
        /* print divider */
        if (mysqli_more_results($link)) {
            printf("-----------------\n");
        }
    } while (mysqli_next_result($link));
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

my_user@localhost
-----------------
Amersfoort
Maastricht
Dordrecht
Leiden
Haarlemmermeer

이전 | 처음으로 | 다음
mysqli_thread_safe | 위로 | mysqli_warning_count


mysqli_warning_count

(PHP 5)

mysqli_warning_count

(no version information, might be only in CVS)

mysqli->warning_count -- Returns the number of warnings from the last query for the given link

Description

Procedural style:

int mysqli_warning_count ( object link)

Object oriented style (property):

class mysqli {

int warning_count

}

mysqli_warning_count() returns the number of warnings from the last query in the connection represented by the link parameter.

참고: For retrieving warning messages you can use the SQL command SHOW WARNINGS [limit row_count].

Return values

Number of warnings or zero if there are no warnings.

See also

mysqli_errno(),
mysqli_error(),
mysqli_sqlstate()

Example

예 1. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCity LIKE City");

/* a remarkable city in Wales */
$query = "INSERT INTO myCity (CountryCode, Name) VALUES('GBR',
        'Llanfairpwllgwyngyllgogerychwyrndrobwllllantysiliogogogoch')";

$mysqli->query($query);

if ($mysqli->warning_count) {
    if ($result = $mysqli->query("SHOW WARNINGS")) {
        $row = $result->fetch_row();
        printf("%s (%d): %s\n", $row[0], $row[1], $row[2]);
        $result->close();
    }
}

/* close connection */
$mysqli->close();
?>

예 2. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCity LIKE City");

/* a remarkable long city name in Wales */
$query = "INSERT INTO myCity (CountryCode, Name) VALUES('GBR',
        'Llanfairpwllgwyngyllgogerychwyrndrobwllllantysiliogogogoch')";

mysqli_query($link, $query);

if (mysqli_warning_count($link)) {
    if ($result = mysqli_query($link, "SHOW WARNINGS")) {
        $row = mysqli_fetch_row($result);
        printf("%s (%d): %s\n", $row[0], $row[1], $row[2]);
        mysqli_free_result($result);
    }
}

/* close connection */
mysqli_close($link);
?>

The above examples would produce the following output:

Warning (1264): Data truncated for column 'Name' at row 1

이전 | 처음으로 | 다음
mysqli_use_result | 위로 | Mohawk Software Session Handler Functions


Mohawk Software Session Handler Functions

PHP 매뉴얼
이전 다음

LXVI. Mohawk Software Session Handler Functions

소개

msession is an interface to a high speed session daemon which can run either locally or remotely. It is designed to provide consistent session management for a PHP web farm. More Information about msession and the session server software itself can be found at http://devel.mohawksoft.com/msession.html.

참고: 이 확장 모듈은 윈도우 플랫폼에서는 사용할 수 없습니다.

요구 사항

설치

To enable Msession support configure PHP --with-msession[=DIR], where DIR is the Msession install directory.

런타임 설정

리소스 종류

상수 정의

차례
msession_connect -- Connect to msession server
msession_count -- Get session count
msession_create -- Create a session
msession_destroy -- Destroy a session
msession_disconnect -- Close connection to msession server
msession_find -- Find value
msession_get_array -- Get array of ... ?
msession_get -- Get value from session
msession_getdata -- Get data ... ?
msession_inc -- Increment value in session
msession_list -- List ... ?
msession_listvar -- List sessions with variable
msession_lock -- Lock a session
msession_plugin -- Call an escape function within the msession personality plugin
msession_randstr -- Get random string
msession_set_array -- Set array of ...
msession_set -- Set value in session
msession_setdata -- Set data ... ?
msession_timeout -- Set/get session timeout
msession_uniq -- Get uniq id
msession_unlock -- Unlock a session

이전 | 처음으로 | 다음
mysqli_warning_count | 위로 | msession_connect


msession_connect

(PHP 4 >= 4.2.0, PHP 5)

msession_connect -- Connect to msession server

Description

bool msession_connect ( string host, string port)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
Mohawk Software Session Handler Functions | 위로 | msession_count


msession_count

(PHP 4 >= 4.2.0, PHP 5)

msession_count -- Get session count

Description

int msession_count ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_connect | 위로 | msession_create


msession_create

(PHP 4 >= 4.2.0, PHP 5)

msession_create -- Create a session

Description

bool msession_create ( string session)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_count | 위로 | msession_destroy


msession_destroy

(PHP 4 >= 4.2.0, PHP 5)

msession_destroy -- Destroy a session

Description

bool msession_destroy ( string name)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_create | 위로 | msession_disconnect


msession_disconnect

(PHP 4 >= 4.2.0, PHP 5)

msession_disconnect -- Close connection to msession server

Description

void msession_disconnect ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_destroy | 위로 | msession_find


msession_find

(PHP 4 >= 4.2.0, PHP 5)

msession_find -- Find value

Description

array msession_find ( string name, string value)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_disconnect | 위로 | msession_get_array


msession_get_array

(PHP 4 >= 4.2.0, PHP 5)

msession_get_array -- Get array of ... ?

Description

array msession_get_array ( string session)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_find | 위로 | msession_get


msession_get

(PHP 4 >= 4.2.0, PHP 5)

msession_get -- Get value from session

Description

string msession_get ( string session, string name, string value)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_get_array | 위로 | msession_getdata


msession_getdata

(no version information, might be only in CVS)

msession_getdata -- Get data ... ?

Description

string msession_getdata ( string session)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_get | 위로 | msession_inc


msession_inc

(PHP 4 >= 4.2.0, PHP 5)

msession_inc -- Increment value in session

Description

string msession_inc ( string session, string name)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_getdata | 위로 | msession_list


msession_list

(PHP 4 >= 4.2.0, PHP 5)

msession_list -- List ... ?

Description

array msession_list ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_inc | 위로 | msession_listvar


msession_listvar

(PHP 4 >= 4.2.0, PHP 5)

msession_listvar -- List sessions with variable

Description

array msession_listvar ( string name)

Returns an associative array of value/session for all sessions with a variable named name.

Used for searching sessions with common attributes.

이전 | 처음으로 | 다음
msession_list | 위로 | msession_lock


msession_lock

(PHP 4 >= 4.2.0, PHP 5)

msession_lock -- Lock a session

Description

int msession_lock ( string name)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_listvar | 위로 | msession_plugin


msession_plugin

(PHP 4 >= 4.2.0, PHP 5)

msession_plugin -- Call an escape function within the msession personality plugin

Description

string msession_plugin ( string session, string val [, string param])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_lock | 위로 | msession_randstr


msession_randstr

(PHP 4 >= 4.2.0, PHP 5)

msession_randstr -- Get random string

Description

string msession_randstr ( int param)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_plugin | 위로 | msession_set_array


msession_set_array

(PHP 4 >= 4.2.0, PHP 5)

msession_set_array -- Set array of ...

Description

bool msession_set_array ( string session, array tuples)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_randstr | 위로 | msession_set


msession_set

(PHP 4 >= 4.2.0, PHP 5)

msession_set -- Set value in session

Description

bool msession_set ( string session, string name, string value)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_set_array | 위로 | msession_setdata


msession_setdata

(no version information, might be only in CVS)

msession_setdata -- Set data ... ?

Description

bool msession_setdata ( string session, string value)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_set | 위로 | msession_timeout


msession_timeout

(PHP 4 >= 4.2.0, PHP 5)

msession_timeout -- Set/get session timeout

Description

int msession_timeout ( string session [, int param])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_setdata | 위로 | msession_uniq


msession_uniq

(PHP 4 >= 4.2.0, PHP 5)

msession_uniq -- Get uniq id

Description

string msession_uniq ( int param)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_timeout | 위로 | msession_unlock


msession_unlock

(PHP 4 >= 4.2.0, PHP 5)

msession_unlock -- Unlock a session

Description

int msession_unlock ( string session, int key)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
msession_uniq | 위로 | muscat Functions


muscat Functions

PHP 매뉴얼
이전 다음

LXVII. muscat Functions

소개

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

설치

These functions are only available if PHP was configured with --with-muscat[=DIR].

차례
muscat_close -- Shuts down the muscat session and releases any memory back to PHP.
muscat_get -- Gets a line back from the core muscat API.
muscat_give -- Sends string to the core muscat API
muscat_setup_net -- Creates a new muscat session and returns the handle.
muscat_setup -- Creates a new muscat session and returns the handle.

이전 | 처음으로 | 다음
msession_unlock | 위로 | muscat_close


muscat_close

(4.0.5 - 4.2.3 only)

muscat_close -- Shuts down the muscat session and releases any memory back to PHP.

Description

int muscat_close ( resource muscat_handle)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

[Not back to the system, note!]

이전 | 처음으로 | 다음
muscat Functions | 위로 | muscat_get


muscat_get

(4.0.5 - 4.2.3 only)

muscat_get -- Gets a line back from the core muscat API.

Description

string muscat_get ( resource muscat_handle)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

주의

이 함수는 Boolean FALSE를 반환하지만, 0이나 ""와 같은 FALSE로 취급하는 Boolean이 아닌 값을 반환할 수도 있습니다. Booleans 섹션에서 자세한 정보를 얻을 수 있습니다. 이 함수의 반환값을 테스트하기 위해서 === 연산자를 이용하십시오.

이전 | 처음으로 | 다음
muscat_close | 위로 | muscat_give


muscat_give

(4.0.5 - 4.2.3 only)

muscat_give -- Sends string to the core muscat API

Description

int muscat_give ( resource muscat_handle, string string)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
muscat_get | 위로 | muscat_setup_net


muscat_setup_net

(4.0.5 - 4.2.3 only)

muscat_setup_net -- Creates a new muscat session and returns the handle.

Description

resource muscat_setup_net ( string muscat_host, int port)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

muscat_setup_net() creates a new muscat session and returns the handle.

muscat_host is the hostname to connect to. port is the port number to connect to.

이전 | 처음으로 | 다음
muscat_give | 위로 | muscat_setup


muscat_setup

(4.0.5 - 4.2.3 only)

muscat_setup -- Creates a new muscat session and returns the handle.

Description

resource muscat_setup ( int size [, string muscat_dir])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

size is the amount of memory in bytes to allocate for muscat. muscat_dir is the muscat installation dir e.g. "/usr/local/empower", it defaults to the compile time muscat directory.

이전 | 처음으로 | 다음
muscat_setup_net | 위로 | 네트워크 관련 함수


네트워크 관련 함수

PHP 매뉴얼
이전 다음

LXVIII. 네트워크 관련 함수

차례
checkdnsrr -- 인터넷 호스트 네임이나 IP 어드레스에 대응되는 DNS 레코드를 체크함
closelog -- 시스템 로그에 기록을 못하도록 연결을 닫습니다.
debugger_off -- PHP 내부 디버거 사용을 멈춥니다.
debugger_on -- PHP 내부 디버거를 사용합니다.
define_syslog_variables -- syslog에 연관된 모든 상수를 초기화합니다.
dns_check_record -- Synonym for checkdnsrr()
dns_get_mx -- Synonym for getmxrr()
dns_get_record -- Fetch DNS Resource Records associated with a hostname
fsockopen -- 인터넷이나 유닉스 도메인의 소켓 연결을 열어줍니다.
gethostbyaddr -- 주어진 IP 어드레스에 대응이 되는 인터넷 호스트 이름을 가져옵니다.
gethostbyname -- 주어진 인터넷 호스트 이름에 대응되는 IP 어드레스를 가져옵니다.
gethostbynamel -- 주어진 인터넷 호스트 이름에 대응이 되는 IP 어드레스의 목록을 가져옵니다.
getmxrr -- 주어진 인터넷 호스트 이름에 대응이 되는 MX 레코드를 가져옵니다.
getprotobyname -- 프로토콜과 조합된 프로토콜 번호를 가져옵니다.
getprotobynumber -- 프로토콜 번호와 조합된 프로토콜의 이름을 가져옵니다.
getservbyname -- 인터넷 서비스와 프로토콜과 조합이 되어있는 포트 번호를 가져옵니다.
getservbyport -- 포트와 프로토콜에 대응이 되는 인터넷 서비스를 가져옵니다.
ip2long -- (IPv4) 인터넷 프로토콜의 점이 찍혀 있는 주소를 포함한 문자열을 고유의 주소로 바꾸어줍니다.
long2ip -- (IPv4) 인터넷 네크워크 주소를 인터넷 표준의 점이 찍혀있는 문자열로 바꿉니다.
openlog -- 시스템 로그에 연결합니다
pfsockopen -- 지속적인 인터넷이나 유닉스 소켓 연결을 엽니다.
socket_get_status -- 존재하는 소켓의 자원에 대한 정보를 반환합니다.
socket_set_blocking -- 소켓의 모드를 설정 (blocking 모드/ non-blocking 모드)
socket_set_timeout -- 소켓에서의 시간초과 주기
syslog -- 시스템 로그 메시지를 생성합니다.

이전 | 처음으로 | 다음
muscat_setup | 위로 | checkdnsrr


checkdnsrr

(PHP 3, PHP 4 , PHP 5)

checkdnsrr -- 인터넷 호스트 네임이나 IP 어드레스에 대응되는 DNS 레코드를 체크함

Description

int checkdnsrr ( string host [, string type])

host에 대응이 되는 type의 레코드를 DNS에서 찾습니다. 어떠한 레코드라도 발견이 되면 TRUE를 반환합니다. 그리고 레코드가 발견되지 않거나 에러가 발생하면 FALSE를 반환합니다.

type은 A, MX, NS, SOA, PTR, CNAME 중에 있거나 다른 것이 올수도 있습니다. 디폴트 값은 MX 입니다.

Host는 IP 어드레스이거나 호스트 네임이 될 수 있습니다.

참조: getmxrr(),
gethostbyaddr(),
gethostbyname(),
gethostbynamel(), 그리고 named(8) 지침서.

이전 | 처음으로 | 다음
네트워크 관련 함수 | 위로 | closelog


closelog

(PHP 3, PHP 4 , PHP 5)

closelog -- 시스템 로그에 기록을 못하도록 연결을 닫습니다.

Description

int closelog ( void )

closelog()는 정보서술자가 시스템 로그에 기록해 오던 것을 닫습니다. closelog()를 사용하는 것은 선택사항입니다.

참조: define_syslog_variables(),
syslog()그리고
openlog().

이전 | 처음으로 | 다음
checkdnsrr | 위로 | debugger_off


debugger_off

(PHP 3)

debugger_off -- PHP 내부 디버거 사용을 멈춥니다.

Description

int debugger_off ( void )

PHP 내부 디버거 사용을 멈춥니다. 디버거는 계속해서 향상중입니다.

이전 | 처음으로 | 다음
closelog | 위로 | debugger_on


debugger_on

(PHP 3)

debugger_on -- PHP 내부 디버거를 사용합니다.

Description

int debugger_on ( string address)

address로 연결해서 PHP 내부 디버거를 사용합니다. 디버거는 계속해서 향상중입니다.

이전 | 처음으로 | 다음
debugger_off | 위로 | define_syslog_variables


define_syslog_variables

(PHP 3, PHP 4 , PHP 5)

define_syslog_variables -- syslog에 연관된 모든 상수를 초기화합니다.

Description

void define_syslog_varaibles ( void )

syslog 함수에 사용되던 모든 상수들을 초기화합니다.

참조:  openlog(),
syslog() 그리고
closelog().

이전 | 처음으로 | 다음
debugger_on | 위로 | dns_check_record


dns_check_record

(PHP 5)

dns_check_record -- Synonym for checkdnsrr()

Description

int dns_check_record ( string host [, string type])

Check DNS records corresponding to a given Internet host name or IP address

이전 | 처음으로 | 다음
define_syslog_variables | 위로 | dns_get_mx


dns_get_mx

(PHP 5)

dns_get_mx -- Synonym for getmxrr()

Description

int dns_get_mx ( string hostname, array mxhosts [, array &weight])

Get MX records corresponding to a given Internet host name.

이전 | 처음으로 | 다음
dns_check_record | 위로 | dns_get_record


dns_get_record

(PHP 5)

dns_get_record -- Fetch DNS Resource Records associated with a hostname

Description

array dns_get_record ( string hostname [, int type [, array &authns, array &addtl]])

참고: This function is not implemented on Windows platforms. Try the PEAR class Net_DNS.

This function returns an array of associative arrays. Each associative array contains at minimum the following keys:

표 1. Basic DNS attributes

Attribute | Meaning
host | The record in the DNS namespace to which the rest of the associated data refers.
class | dns_get_record() only returns Internet class records and as such this parameter will always return IN.
type | String containing the record type. Additional attributes will also be contained in the resulting array dependant on the value of type. See table below.
ttl | Time To Live remaining for this record. This will not equal the record's original ttl, but will rather equal the original ttl minus whatever length of time has passed since the authoritative name server was queried.

hostname should be a valid DNS hostname such as "www.example.com". Reverse lookups can be generated using in-addr.arpa notation, but gethostbyaddr() is more suitable for the majority of reverse lookups.

By default, dns_get_record() will search for any resource records associated with hostname. To limit the query, specify the optional type parameter. type may be any one of the following: DNS_A, DNS_CNAME, DNS_HINFO, DNS_MX, DNS_NS, DNS_PTR, DNS_SOA, DNS_TXT, DNS_AAAA, DNS_SRV, DNS_NAPTR, DNS_ALL or DNS_ANY. The default is DNS_ANY.

참고: Because of eccentricities in the performance of libresolv between platforms, DNS_ANY will not always return every record, the slower DNS_ALL will collect all records more reliably.

The optional third and fourth arguments to this function, authns and addtl are passed by reference and, if given, will be populated with Resource Records for the Authoritative Name Servers, and any Additional Records respectively. See the example below.

표 2. Other keys in associative arrays dependant on 'type'

Type | Extra Columns
A | ip: An IPv4 addresses in dotted decimal notation.
MX | pri: Priority of mail exchanger. Lower numbers indicate greater priority. target: FQDN of the mail exchanger. See also dns_get_mx().
CNAME | target: FQDN of location in DNS namespace to which the record is aliased.
NS | target: FQDN of the name server which is authoritative for this hostname.
PTR | target: Location within the DNS namespace to which this record points.
TXT | txt: Arbitrary string data associated with this record.
HINFO | cpu: IANA number designating the CPU of the machine referenced by this record. os: IANA number designating the Operating System on the machine referenced by this record. See IANA's Operating System Names for the meaning of these values.
SOA | mname: FQDN of the machine from which the resource records originated. rname: Email address of the administrative contain for this domain. serial: Serial # of this revision of the requested domain. refresh: Refresh interval (seconds) secondary name servers should use when updating remote copies of this domain. retry: Length of time (seconds) to wait after a failed refresh before making a second attempt. expire: Maximum length of time (seconds) a secondary DNS server should retain remote copies of the zone data without a successful refresh before discarding. minimum-ttl: Minimum length of time (seconds) a client can continue to use a DNS resolution before it should request a new resolution from the server. Can be overridden by individual resource records.
AAAA | ipv6: IPv6 address
SRV | pri: (Priority) lowest priorities should be used first. weight: Ranking to weight which of commonly prioritized targets should be chosen at random. target and port: hostname and port where the requested service can be found. For additional information see: RFC 2782
NAPTR | order and pref: Equivalent to pri and weight above. flags, services, regex, and replacement: Parameters as defined by RFC 2915.

참고: Per DNS standards, email addresses are given in user.host format (for example: hostmaster.example.com as opposed to hostmaster@example.com), be sure to check this value and modify if necessary before using it with a functions such as mail().

예 1. Using dns_get_record()

<?php
$result = dns_get_record("php.net");
print_r($result);
?>

Produces output similar to the following:

Array
(
    [0] => Array
        (
            [host] => php.net
            [type] => MX
            [pri] => 5
            [target] => pair2.php.net
            [class] => IN
            [ttl] => 6765
        )

    [1] => Array
        (
            [host] => php.net
            [type] => A
            [ip] => 64.246.30.37
            [class] => IN
            [ttl] => 8125
        )

)

Since it's very common to want the IP address of a mail server once the MX record has been resolved, dns_get_record() also returns an array in addtl which contains associate records. authns is returned as well containing a list of authoritative name servers.

예 2. Using dns_get_record() and DNS_ANY

<?php
/* Request "ANY" record for php.net,
   and create $authns and $addtl arrays
   containing list of name servers and
   any additional records which go with
   them */
$result = dns_get_record("php.net", DNS_ANY, $authns, $addtl);
echo "Result = ";
print_r($result);
echo "Auth NS = ";
print_r($authns);
echo "Additional = ";
print_r($addtl);
?>

Produces output similar to the following:

Result = Array
(
    [0] => Array
        (
            [host] => php.net
            [type] => MX
            [pri] => 5
            [target] => pair2.php.net
            [class] => IN
            [ttl] => 6765
        )

    [1] => Array
        (
            [host] => php.net
            [type] => A
            [ip] => 64.246.30.37
            [class] => IN
            [ttl] => 8125
        )

)
Auth NS = Array
(
    [0] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => remote1.easydns.com
            [class] => IN
            [ttl] => 10722
        )

    [1] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => remote2.easydns.com
            [class] => IN
            [ttl] => 10722
        )

    [2] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => ns1.easydns.com
            [class] => IN
            [ttl] => 10722
        )

    [3] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => ns2.easydns.com
            [class] => IN
            [ttl] => 10722
        )

)
Additional = Array
(
    [0] => Array
        (
            [host] => pair2.php.net
            [type] => A
            [ip] => 216.92.131.5
            [class] => IN
            [ttl] => 6766
        )

    [1] => Array
        (
            [host] => remote1.easydns.com
            [type] => A
            [ip] => 64.39.29.212
            [class] => IN
            [ttl] => 100384
        )

    [2] => Array
        (
            [host] => remote2.easydns.com
            [type] => A
            [ip] => 212.100.224.80
            [class] => IN
            [ttl] => 81241
        )

    [3] => Array
        (
            [host] => ns1.easydns.com
            [type] => A
            [ip] => 216.220.40.243
            [class] => IN
            [ttl] => 81241
        )

    [4] => Array
        (
            [host] => ns2.easydns.com
            [type] => A
            [ip] => 216.220.40.244
            [class] => IN
            [ttl] => 81241
        )

)

See also dns_get_mx(), and dns_check_record()

이전 | 처음으로 | 다음
dns_get_mx | 위로 | fsockopen


fsockopen

(PHP 3, PHP 4 , PHP 5)

fsockopen -- 인터넷이나 유닉스 도메인의 소켓 연결을 열어줍니다.

Description

int fsockopen ( [string udp://hostname, int port [, int errno [, string errstr [, double timeout]]]])

인터넷 (TCP 또는 UDP를 사용하는AF_INET) 또는 유닉스(AF_UNIX)도메인에서 스트림 연결을 시작합니다. 이것은 인터넷 도메인이라는 것 때문에 TCP 소켓을 port상에서 hostname에 연결하는 것을 열어줍니다. hostname은 이와 같은 경우에 완전히 증명이 된 도메인 네임이거나 IP 어드레스일 수 있습니다. UDP 연결에서는 프로토콜을 미리 정의해야 합니다 : udp://hostname. 유닉스 도메인에서는 hostname이 소켓의 경로로 사용될 수 있는데 이 경우에 port는 0 으로 설정되어야 합니다. 선택사항인 timeout은 시스템 호출에 연결되는 것에 대한 시간초과가 몇 초안에 이루어지도록 설정할 수 있습니다.

            fsockopen()은 다른 파일관련 함수(다음과 같은
    fgets(), fgetss(),
    fputs(), fclose() 그리고 feof())
와 사용할 수 있는 파일 포인터를 반환합니다.

호출에 실패하면 FALSE를 반환하고 임의항목인 errno와 errstr인수가 있다면 시스템 차원의 connect()호출 에서 발생한 실제의 시스템 차원의 에러를 측정하기 위해 설정될 수 있습니다. 반환되는 errno 가 0 이고 함수가 FALSE를 반환했다면 connect()호출 이전에 에러가 발생했다는 것을 알 수 있습니다. 이것은 소켓을 초기화하면서 발생한 문제일 가능성이 높습니다. 주의할 것은 errno와 errstr인수는 레러 passed by reference되어야 합니다.

환경에 따라 유닉스 도메인이나 선택사항인 연결 시간초과는 사용이 지원되지 않을 수도 있습니다.

소켓은 기본적으로 블로킹 모드(blocking mode)로 열려집니다. socket_set_blocking()을 사용해서 블로킹모드 해제상태(non-blocking mode) 로 전환할 수 있습니다..

예 1. fsockopen() 예문

$fp = fsockopen ("www.php.net", 80, $errno, $errstr, 30);
if (!$fp) {
    echo "$errstr ($errno)<br>\n";
} else {
    fputs ($fp, "GET / HTTP/1.0\r\n\r\n");
    while (!feof($fp)) {
        echo fgets ($fp,128);
    }
    fclose ($fp);
}
다음의 예문은 가지고 있는 장비에서 UDP 서비스인 "daytime" (port 13)을 이용해서 어떻게 날짜와 시간을 가져오는지 보여줍니다.

예 2. UDP 연결을 사용합니다

<?php
$fp = fsockopen("udp://127.0.0.1", 13, $errno, $errstr);
if (!$fp) {
    echo "ERROR: $errno - $errstr<br>\n";
} else {
    fwrite($fp,"\n");
    echo fread($fp, 26);
    fclose($fp);
}
?>

참고: 시간초과 매개변수는 PHP 3.0.9 에 소개가 되었고 UDP 지원은 PHP 4에 추가되었습니다.

참조: pfsockopen(), socket_set_blocking(), socket_set_timeout(), fgets(), fgetss(), fputs(), fclose(), 그리고 feof()).

이전 | 처음으로 | 다음
dns_get_record | 위로 | gethostbyaddr


gethostbyaddr

(PHP 3, PHP 4 , PHP 5)

gethostbyaddr -- 주어진 IP 어드레스에 대응이 되는 인터넷 호스트 이름을 가져옵니다.

Description

string gethostbyaddr ( string ip_address)

Returns the host name of the Internet host specified by ip_address에 정의된 인터넷 호스트의 호스트 이름을 반환합니다. 에러가 발생하면 ip_address를 반환합니다.

참조: gethostbyname().

이전 | 처음으로 | 다음
fsockopen | 위로 | gethostbyname


gethostbyname

(PHP 3, PHP 4 , PHP 5)

gethostbyname -- 주어진 인터넷 호스트 이름에 대응되는 IP 어드레스를 가져옵니다.

Description

string gethostbyname ( string hostname)

hostname에 정의된 인터넷 호스트의 IP 어드레스를 반환합니다.

참조: gethostbyaddr().

이전 | 처음으로 | 다음
gethostbyaddr | 위로 | gethostbynamel


gethostbynamel

(PHP 3, PHP 4 , PHP 5)

gethostbynamel -- 주어진 인터넷 호스트 이름에 대응이 되는 IP 어드레스의 목록을 가져옵니다.

Description

array gethostbynamel ( string hostname)

hostname분석에 정의된 인터넷 호스트의 IP 어드레스의 목록을 반환합니다.

참조: gethostbyname(),
gethostbyaddr(),
checkdnsrr(), getmxrr(),
그리고 named(8) 기능설명(manual) 페이지.

이전 | 처음으로 | 다음
gethostbyname | 위로 | getmxrr


getmxrr

(PHP 3, PHP 4 , PHP 5)

getmxrr -- 주어진 인터넷 호스트 이름에 대응이 되는 MX 레코드를 가져옵니다.

Description

int getmxrr ( string hostname, array mxhosts [, array weight])

Searches DNS for MX records corresponding to hostname에 대응이 되는 MX 레코드를 찾기위해 DNS를 찾습니다. 아무 레코드라도 발견이 되면 TRUE를 반환합니다. 레코드가 없거나 에러가 발생되면 FALSE를 반환합니다.

찾아낸 MX 레코드의 목록은 mxhosts 배열에 위치합니다. weight배열이 주어지면 수집된 weight 정보로 채워집니다.

참조: checkdnsrr(),
gethostbyname(),
gethostbynamel(),
gethostbyaddr() 그리고
named(8) 기능설명(manual) 페이지

이전 | 처음으로 | 다음
gethostbynamel | 위로 | getprotobyname


getprotobyname

(PHP 4 , PHP 5)

getprotobyname -- 프로토콜과 조합된 프로토콜 번호를 가져옵니다.

Description

int getprotobyname ( string name)

getprotobyname()은 /etc/protocols 각 프로토콜 name 과 조합이 된 프로토콜의 번호를 반환합니다.

참조: getprotobynumber().

이전 | 처음으로 | 다음
getmxrr | 위로 | getprotobynumber


getprotobynumber

(PHP 4 , PHP 5)

getprotobynumber -- 프로토콜 번호와 조합된 프로토콜의 이름을 가져옵니다.

Description

string getprotobynumber ( int number)

getprotobynumber() 은 /etc/protocols 각 프로토콜 number 와 조합이 된 프로토콜의 이름을 반환합니다.

참조: getprotobyname().

이전 | 처음으로 | 다음
getprotobyname | 위로 | getservbyname


getservbyname

(PHP 4 , PHP 5)

getservbyname -- 인터넷 서비스와 프로토콜과 조합이 되어있는 포트 번호를 가져옵니다.

Description

int getservbyname ( string service, string protocol)

getservbyname()은 /etc/services 에 정의된 protocol의 service에 대응이 되는 인터넷 포트를 반환합니다. protocol은 TCP 이거나 UDP입니다.

참조: getservbyport().

이전 | 처음으로 | 다음
getprotobynumber | 위로 | getservbyport


getservbyport

(PHP 4 , PHP 5)

getservbyport -- 포트와 프로토콜에 대응이 되는 인터넷 서비스를 가져옵니다.

Description

string getservbyport ( int port, string protocol)

getservbyport()는 /etc/services의 각 protocol 에 정의된 port와 조합이 되는 인터넷 서비스를 반환합니다. protocol은 TCP이거나 UDP입니다.

참조: getservbyname().

이전 | 처음으로 | 다음
getservbyname | 위로 | ip2long


ip2long

(PHP 4 , PHP 5)

ip2long -- (IPv4) 인터넷 프로토콜의 점이 찍혀 있는 주소를 포함한 문자열을 고유의 주소로 바꾸어줍니다.

Description

int ip2long ( string ip_address)

ip2long() 함수는 보통의(점이 찍혀 있는 문자열) 인터넷 표시 형식에서 IPv4 인터넷 네트워크 주소를 생성합니다.

예 1. ip2long() Example

<?php
$ip = gethostbyname("www.php.net");
$out = "아래의 URL과  같습니다:<br>\n";
$out .= "http://www.php.net/, http://".$ip."/, and http://".ip2long($ip)."/<br>\n";
echo $out;
?>

See also: long2ip()

이전 | 처음으로 | 다음
getservbyport | 위로 | long2ip


long2ip

(PHP 4 , PHP 5)

long2ip -- (IPv4) 인터넷 네크워크 주소를 인터넷 표준의 점이 찍혀있는 문자열로 바꿉니다.

Description

string long2ip ( int proper_address)

long2ip()는 고유의 주소 표시 형식을 점이 찍혀 있는 인터넷 주소 표시형식(예를 들면 : aaa.bbb.ccc.ddd)으로 바꾸어줍니다.

참조: ip2long()

이전 | 처음으로 | 다음
ip2long | 위로 | openlog


openlog

(PHP 3, PHP 4 , PHP 5)

openlog -- 시스템 로그에 연결합니다

Description

int openlog ( string ident, int option, int facility)

openlog()는 프로그램에 사용하는 시스템 로그 기록자에 연결을 열어줍니다. opens a connection to the system logger for a program. 문자열 ident는 각각의 메시지에 추가됩니다. option과 facility에 대한 값은 아래에 주어집니다. option의 인수는 로그 메시지를 생성할때 어떤 로긴 옵션이 사용되었는지 알아내는 데 사용됩니다. facility의 인수는 어떤 형식의 프로그램이 로그 메시지를 남기는 지 정의하는데 사용됩니다. 이것은 당신이 정의(기계의 syslog 설정)할 때 서로 다른 설비에서 들어오는 메시지 중 어떤 메시지를 핸들할지 정의할 수 있도록 합니다. openlog()의 사용은 선택적입니다. 이것은 ident가 기본적으로 FALSE일 경우 필요하다면 자동으로 syslog()에 의해 호출됩니다.

표 1. openlog() Options

Constant | Description
LOG_CONS | 시스템 로그 기록자에 데이터를 보내는 중에 에러가 발생한다면 직접적으로 시스템 콘솔에 기록합니다.
LOG_NDELAY | 로그기록자에 대한 연결을 즉시 엽니다.
LOG_ODELAY | (기본값) 첫번째 메시지가 로그에 기록될때까지 연결을 여는 것을 미룹니다.
LOG_PERROR | 로그 메시지 역시 표준 에러로 출력합니다.
LOG_PID | 각각의 메시지마다 PID를 포함시킵니다.
이 옵션들 중에서 한개 혹은 한개 이상을 사용할 수 있습니다. 여러개의 옵션을 사용할 경우 OR할 필요가 있습니다. 예를 들자면 즉시 연결을 열고, 콘솔에 기록하고, 각각의 메시지에 PID를 포함시킨다면 다음과 같이 사용합니다: LOG_CONS | LOG_NDELAY | LOG_PID

표 2. openlog() Facilities

Constant | Description
LOG_AUTH | 보안/인증 메시지 (상수가 정의된 시스템대신 LOG_AUTHPRIV 를 사용)
LOG_AUTHPRIV | 보안/인증 메시지 (private)
LOG_CRON | 클락 데몬clock daemon (cron and at)
LOG_DAEMON | 다른 시스템 데몬
LOG_KERN | 커널 메시지
LOG_LOCAL0 ... LOG_LOCAL7 | 로컬 사용을 위해 예약된 것
LOG_LPR | 라인 프린터 하위시스템
LOG_MAIL | 메일 하위 시스템
LOG_NEWS | USENET 뉴스 하위 시스템
LOG_SYSLOG | syslogd에 의해 내부적으로 생성된 메시지
LOG_USER | 일반적인 사용자 수준의 메시지
LOG_UUCP | UUCP 하위 시스템

참조: define_syslog_variables(),
syslog() 그리고
closelog().

이전 | 처음으로 | 다음
long2ip | 위로 | pfsockopen


pfsockopen

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

pfsockopen -- 지속적인 인터넷이나 유닉스 소켓 연결을 엽니다.

Description

int pfsockopen ( string hostname, int port [, int errno [, string errstr [, int timeout]]])

이 함수는 스크립트가 끝난뒤에도 연결이 닫히지 않는 차이점을 제외하고 fsockopen()과 정확히 똑같습니다. 이것은 fsockopen()의 지속적인 연결 버전입니다.

이전 | 처음으로 | 다음
openlog | 위로 | socket_get_status


socket_get_status

(PHP 4 , PHP 5)

socket_get_status -- 존재하는 소켓의 자원에 대한 정보를 반환합니다.

Description

array socket_get_status ( resource socket_get_status)

존재하는 소켓의 자원에 대한 정보를 반환합니다. 일반적으로 결과 배열안에 네개의 항목을 반환합니다.

  • timed_out (부울 값) - 데이터를 기다리는 소켓의 시간초과

  • blocked (부울 값) - 닫혀진 소켓

  • eof (부울 값) - EOF 이벤트 검사

  • unread_bytes (정수값) - 소켓의 버퍼에 남겨진 바이트 수

참조:
accept_connect(),
bind(),
connect(),
listen(),
strerror().

이전 | 처음으로 | 다음
pfsockopen | 위로 | socket_set_blocking


socket_set_blocking

(PHP 4 , PHP 5)

socket_set_blocking -- 소켓의 모드를 설정 (blocking 모드/ non-blocking 모드)

Description

int socket_set_blocking ( int socket descriptor, int mode)

mode가 FALSE이면, 소켓 서술자는 모드를 non-blocking 모드로 전환할 것입니다.the given socket 그리고 TRUE일 경우 서술자는 blocking 모드로 전환할 것입니다. 이것의 효과는 소켓에서 읽어들인 fgets()와 비슷합니다. non-blocking 모드에서 fgets()호출은 항상 소켓에서 사용가능하게 되기를 대기하고 있는 데이타를 blocking 모드일 때 바로 반환합니다. will always return right away while in blocking mode it will wait for data to become available on the socket.

이 함수는 이전에는 set_socket_blocking()로 불려 졌지만 지금은 그렇게 사용되지 않습니다.

이전 | 처음으로 | 다음
socket_get_status | 위로 | socket_set_timeout


socket_set_timeout

(PHP 4 , PHP 5)

socket_set_timeout -- 소켓에서의 시간초과 주기

Description

bool socket_set_timeout ( int socket descriptor, int seconds, int microseconds)

seconds와 microseconds의 합을 사용해서 socket descriptor의 시간초과 값을 설정합니다.

예 1. socket_set_timeout() Example

<?php
$fp = fsockopen("www.php.net", 80);
if(!$fp) {
    echo "열 수 없습니다\n";
} else {
    fputs($fp,"GET / HTTP/1.0\n\n");
    $start = time();
    socket_set_timeout($fp, 2);
    $res = fread($fp, 2000);
    var_dump(socket_get_status($fp));
    fclose($fp);
    print $res;
}
?>

이 함수는 이전에는set_socket_timeout()처럼 불려졌지만 지금은 그렇게 사용되지 않습니다.

참조: fsockopen(), fopen().

이전 | 처음으로 | 다음
socket_set_blocking | 위로 | syslog


syslog

(PHP 3, PHP 4 , PHP 5)

syslog -- 시스템 로그 메시지를 생성합니다.

Description

int syslog ( int priority, string message)

syslog()는 시스템 기록자에 의해 배분이 될 로그 메시지를 생성합니다. priority는 다음 장에서 주어진 값에 대한 난이도와 수준의 조합입니다. 남겨진 인수는 현재의 errno 값에 대응이 되는 에러 메시지 문자열(strerror)은 %m의 두개 문자로 대치가 되고 나머지는 보내지는 메시지 입니다.

표 1. syslog() 우선순위 (역순정렬)

Constant | Description
LOG_EMERG | 시스템을 사용할 수 없습니다.
LOG_ALERT | 즉시 수행해야 할 행동
LOG_CRIT | 위험한 상태
LOG_ERR | 에러 상태
LOG_WARNING | 경고 상태
LOG_NOTICE | 일반적이지만 중요한 상태
LOG_INFO | 정보 메시지
LOG_DEBUG | 디버그 수준 메시지

예 1. syslog()의 사용

<?php
define_syslog_variables();
// 프로세스 ID를 포함하고 있으며 로그를 표준 에러로 보내는 syslog를 열고
// 사용자에 의해 정의된 logging 메카니즘을 사용합니다.
openlog("myScripLog", LOG_PID | LOG_PERROR, LOG_LOCAL0);

// 코드가 들어갑니다.

if (authorized_client()) {
    // 무슨 일인가를 수행합니다.

} else {
    // 인증되지 않은 사용자!
    // 로그를 시도합니다.
    $access = date("Y/m/d H:i:s");
    syslog(LOG_WARNING,"인증되지 않은 사용자: $access $REMOTE_ADDR ($HTTP_USER_AGENT)");
}

closelog();
?>
사용자가 정의한 로그 핸들러를 설정하기 위한 정보는 syslog.conf(5)유닉스의 기능설명(manual) 페이지를 보세요. syslog 난이도와 옵션에 관해서 정보를 좀 더 알고 싶을 때는 syslog(3) 유닉스 머신의 man 페이지에서 찾아 볼 수 있습니다.

Windows NT에서 syslog 서비스는 이벤트 로그로 에뮬레이트 되어 사용됩니다.

참조: define_syslog_variables(),
openlog(),
closelog().

이전 | 처음으로 | 다음
socket_set_timeout | 위로 | Ncurses Terminal Screen Control Functions


Ncurses Terminal Screen Control Functions

PHP 매뉴얼
이전 다음

LXIX. Ncurses Terminal Screen Control Functions

소개

ncurses (new curses) is a free software emulation of curses in System V Rel 4.0 (and above). It uses terminfo format, supports pads, colors, multiple highlights, form characters and function key mapping. Because of the interactive nature of this library, it will be of little use for writing Web applications, but may be useful when writing scripts meant using PHP from the command line.

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

Ncurses is available for the following platforms:

  • AIX

  • BeOS

  • Cygwin

  • Digital Unix (aka OSF1)

  • FreeBSD

  • GNU/Linux

  • HPUX

  • IRIX

  • OS/2

  • SCO OpenServer

  • Solaris

  • SunOS

요구 사항

You need the ncurses libraries and headerfiles. Download the latest version from the ftp://ftp.gnu.org/pub/gnu/ncurses/ or from an other GNU-Mirror.

설치

To get these functions to work, you have to compile the CGI or CLI version of PHP with --with-ncurses[=DIR].

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. Ncurses configuration options

Name | Default | Changeable
ncurses.value | "42" | PHP_INI_ALL
ncurses.string | "foobar" | PHP_INI_ALL
For further details and definition of the PHP_INI_* constants see ini_set().

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

Error codes

On error ncurses functions return NCURSES_ERR.

Colors

표 2. ncurses color constants

constant | meaning
NCURSES_COLOR_BLACK | no color (black)
NCURSES_COLOR_WHITE | white
NCURSES_COLOR_RED | red - supported when terminal is in color mode
NCURSES_COLOR_GREEN | green - supported when terminal is in color mod
NCURSES_COLOR_YELLOW | yellow - supported when terminal is in color mod
NCURSES_COLOR_BLUE | blue - supported when terminal is in color mod
NCURSES_COLOR_CYAN | cyan - supported when terminal is in color mod
NCURSES_COLOR_MAGENTA | magenta - supported when terminal is in color mod

Keys

표 3. ncurses key constants

constant | meaning
NCURSES_KEY_F0 - NCURSES_KEY_F64 | function keys F1 - F64
NCURSES_KEY_DOWN | down arrow
NCURSES_KEY_UP | up arrow
NCURSES_KEY_LEFT | left arrow
NCURSES_KEY_RIGHT | right arrow
NCURSES_KEY_HOME | home key (upward+left arrow)
NCURSES_KEY_BACKSPACE | backspace
NCURSES_KEY_DL | delete line
NCURSES_KEY_IL | insert line
NCURSES_KEY_DC | delete character
NCURSES_KEY_IC | insert char or enter insert mode
NCURSES_KEY_EIC | exit insert char mode
NCURSES_KEY_CLEAR | clear screen
NCURSES_KEY_EOS | clear to end of screen
NCURSES_KEY_EOL | clear to end of line
NCURSES_KEY_SF | scroll one line forward
NCURSES_KEY_SR | scroll one line backward
NCURSES_KEY_NPAGE | next page
NCURSES_KEY_PPAGE | previous page
NCURSES_KEY_STAB | set tab
NCURSES_KEY_CTAB | clear tab
NCURSES_KEY_CATAB | clear all tabs
NCURSES_KEY_SRESET | soft (partial) reset
NCURSES_KEY_RESET | reset or hard reset
NCURSES_KEY_PRINT | print
NCURSES_KEY_LL | lower left
NCURSES_KEY_A1 | upper left of keypad
NCURSES_KEY_A3 | upper right of keypad
NCURSES_KEY_B2 | center of keypad
NCURSES_KEY_C1 | lower left of keypad
NCURSES_KEY_C3 | lower right of keypad
NCURSES_KEY_BTAB | back tab
NCURSES_KEY_BEG | beginning
NCURSES_KEY_CANCEL | cancel
NCURSES_KEY_CLOSE | close
NCURSES_KEY_COMMAND | cmd (command)
NCURSES_KEY_COPY | copy
NCURSES_KEY_CREATE | create
NCURSES_KEY_END | end
NCURSES_KEY_EXIT | exit
NCURSES_KEY_FIND | find
NCURSES_KEY_HELP | help
NCURSES_KEY_MARK | mark
NCURSES_KEY_MESSAGE | message
NCURSES_KEY_MOVE | move
NCURSES_KEY_NEXT | next
NCURSES_KEY_OPEN | open
NCURSES_KEY_OPTIONS | options
NCURSES_KEY_PREVIOUS | previous
NCURSES_KEY_REDO | redo
NCURSES_KEY_REFERENCE | ref (reference)
NCURSES_KEY_REFRESH | refresh
NCURSES_KEY_REPLACE | replace
NCURSES_KEY_RESTART | restart
NCURSES_KEY_RESUME | resume
NCURSES_KEY_SAVE | save
NCURSES_KEY_SBEG | shiftet beg (beginning)
NCURSES_KEY_SCANCEL | shifted cancel
NCURSES_KEY_SCOMMAND | shifted command
NCURSES_KEY_SCOPY | shifted copy
NCURSES_KEY_SCREATE | shifted create
NCURSES_KEY_SDC | shifted delete char
NCURSES_KEY_SDL | shifted delete line
NCURSES_KEY_SELECT | select
NCURSES_KEY_SEND | shifted end
NCURSES_KEY_SEOL | shifted end of line
NCURSES_KEY_SEXIT | shifted exit
NCURSES_KEY_SFIND | shifted find
NCURSES_KEY_SHELP | shifted help
NCURSES_KEY_SHOME | shifted home
NCURSES_KEY_SIC | shifted input
NCURSES_KEY_SLEFT | shifted left arrow
NCURSES_KEY_SMESSAGE | shifted message
NCURSES_KEY_SMOVE | shifted move
NCURSES_KEY_SNEXT | shifted next
NCURSES_KEY_SOPTIONS | shifted options
NCURSES_KEY_SPREVIOUS | shifted previous
NCURSES_KEY_SPRINT | shifted print
NCURSES_KEY_SREDO | shifted redo
NCURSES_KEY_SREPLACE | shifted replace
NCURSES_KEY_SRIGHT | shifted right arrow
NCURSES_KEY_SRSUME | shifted resume
NCURSES_KEY_SSAVE | shifted save
NCURSES_KEY_SSUSPEND | shifted suspend
NCURSES_KEY_UNDO | undo
NCURSES_KEY_MOUSE | mouse event has occurred
NCURSES_KEY_MAX | maximum key value

Mouse

표 4. mouse constants

Constant | meaning
NCURSES_BUTTON1_RELEASED - NCURSES_BUTTON4_RELEASED | button (1-4) released
NCURSES_BUTTON1_PRESSED - NCURSES_BUTTON4_PRESSED | button (1-4) pressed
NCURSES_BUTTON1_CLICKED - NCURSES_BUTTON4_CLICKED | button (1-4) clicked
NCURSES_BUTTON1_DOUBLE_CLICKED - NCURSES_BUTTON4_DOUBLE_CLICKED | button (1-4) double clicked
NCURSES_BUTTON1_TRIPLE_CLICKED - NCURSES_BUTTON4_TRIPLE_CLICKED | button (1-4) triple clicked
NCURSES_BUTTON_CTRL | ctrl pressed during click
NCURSES_BUTTON_SHIFT | shift pressed during click
NCURSES_BUTTON_ALT | alt pressed during click
NCURSES_ALL_MOUSE_EVENTS | report all mouse events
NCURSES_REPORT_MOUSE_POSITION | report mouse position
차례
ncurses_addch -- Add character at current position and advance cursor
ncurses_addchnstr -- Add attributed string with specified length at current position
ncurses_addchstr -- Add attributed string at current position
ncurses_addnstr -- Add string with specified length at current position
ncurses_addstr -- Output text at current position
ncurses_assume_default_colors -- Define default colors for color 0
ncurses_attroff -- Turn off the given attributes
ncurses_attron -- Turn on the given attributes
ncurses_attrset -- Set given attributes
ncurses_baudrate -- Returns baudrate of terminal
ncurses_beep -- Let the terminal beep
ncurses_bkgd -- Set background property for terminal screen
ncurses_bkgdset -- Control screen background
ncurses_border -- Draw a border around the screen using attributed characters
ncurses_bottom_panel -- Moves a visible panel to the bottom of the stack
ncurses_can_change_color -- Check if we can change terminals colors
ncurses_cbreak -- Switch of input buffering
ncurses_clear -- Clear screen
ncurses_clrtobot -- Clear screen from current position to bottom
ncurses_clrtoeol -- Clear screen from current position to end of line
ncurses_color_content -- Gets the RGB value for color
ncurses_color_set -- Set fore- and background color
ncurses_curs_set -- Set cursor state
ncurses_def_prog_mode -- Saves terminals (program) mode
ncurses_def_shell_mode -- Saves terminals (shell) mode
ncurses_define_key -- Define a keycode
ncurses_del_panel -- Remove panel from the stack and delete it (but not the associated window)
ncurses_delay_output -- Delay output on terminal using padding characters
ncurses_delch -- Delete character at current position, move rest of line left
ncurses_deleteln -- Delete line at current position, move rest of screen up
ncurses_delwin -- Delete a ncurses window
ncurses_doupdate -- Write all prepared refreshes to terminal
ncurses_echo -- Activate keyboard input echo
ncurses_echochar -- Single character output including refresh
ncurses_end -- Stop using ncurses, clean up the screen
ncurses_erase -- Erase terminal screen
ncurses_erasechar -- Returns current erase character
ncurses_filter --
ncurses_flash -- Flash terminal screen (visual bell)
ncurses_flushinp -- Flush keyboard input buffer
ncurses_getch -- Read a character from keyboard
ncurses_getmaxyx -- Returns the size of a window
ncurses_getmouse -- Reads mouse event
ncurses_getyx -- Returns the current cursor position for a window
ncurses_halfdelay -- Put terminal into halfdelay mode
ncurses_has_colors -- Check if terminal has colors
ncurses_has_ic -- Check for insert- and delete-capabilities
ncurses_has_il -- Check for line insert- and delete-capabilities
ncurses_has_key -- Check for presence of a function key on terminal keyboard
ncurses_hide_panel -- Remove panel from the stack, making it invisible
ncurses_hline -- Draw a horizontal line at current position using an attributed character and max. n characters long
ncurses_inch -- Get character and attribute at current position
ncurses_init_color -- Set new RGB value for color
ncurses_init_pair -- Allocate a color pair
ncurses_init -- Initialize ncurses
ncurses_insch -- Insert character moving rest of line including character at current position
ncurses_insdelln -- Insert lines before current line scrolling down (negative numbers delete and scroll up)
ncurses_insertln -- Insert a line, move rest of screen down
ncurses_insstr -- Insert string at current position, moving rest of line right
ncurses_instr -- Reads string from terminal screen
ncurses_isendwin -- Ncurses is in endwin mode, normal screen output may be performed
ncurses_keyok -- Enable or disable a keycode
ncurses_keypad -- Turns keypad on or off
ncurses_killchar -- Returns current line kill character
ncurses_longname -- Returns terminals description
ncurses_meta -- Enables/Disable 8-bit meta key information
ncurses_mouse_trafo -- Transforms coordinates
ncurses_mouseinterval -- Set timeout for mouse button clicks
ncurses_mousemask -- Sets mouse options
ncurses_move_panel -- Moves a panel so that its upper-left corner is at [startx, starty]
ncurses_move -- Move output position
ncurses_mvaddch -- Move current position and add character
ncurses_mvaddchnstr -- Move position and add attributed string with specified length
ncurses_mvaddchstr -- Move position and add attributed string
ncurses_mvaddnstr -- Move position and add string with specified length
ncurses_mvaddstr -- Move position and add string
ncurses_mvcur -- Move cursor immediately
ncurses_mvdelch -- Move position and delete character, shift rest of line left
ncurses_mvgetch -- Move position and get character at new position
ncurses_mvhline -- Set new position and draw a horizontal line using an attributed character and max. n characters long
ncurses_mvinch -- Move position and get attributed character at new position
ncurses_mvvline -- Set new position and draw a vertical line using an attributed character and max. n characters long
ncurses_mvwaddstr -- Add string at new position in window
ncurses_napms -- Sleep
ncurses_new_panel -- Create a new panel and associate it with window
ncurses_newpad -- Creates a new pad (window)
ncurses_newwin -- Create a new window
ncurses_nl -- Translate newline and carriage return / line feed
ncurses_nocbreak -- Switch terminal to cooked mode
ncurses_noecho -- Switch off keyboard input echo
ncurses_nonl -- Do not translate newline and carriage return / line feed
ncurses_noqiflush -- Do not flush on signal characters
ncurses_noraw -- Switch terminal out of raw mode
ncurses_pair_content -- Gets the RGB value for color
ncurses_panel_above -- Returns the panel above panel. If panel is null, returns the bottom panel in the stack
ncurses_panel_below -- Returns the panel below panel. If panel is null, returns the top panel in the stack
ncurses_panel_window -- Returns the window associated with panel
ncurses_pnoutrefresh -- Copies a region from a pad into the virtual screen
ncurses_prefresh -- Copies a region from a pad into the virtual screen
ncurses_putp --
ncurses_qiflush -- Flush on signal characters
ncurses_raw -- Switch terminal into raw mode
ncurses_refresh -- Refresh screen
ncurses_replace_panel -- Replaces the window associated with panel
ncurses_reset_prog_mode -- Resets the prog mode saved by def_prog_mode
ncurses_reset_shell_mode -- Resets the shell mode saved by def_shell_mode
ncurses_resetty -- Restores saved terminal state
ncurses_savetty -- Saves terminal state
ncurses_scr_dump -- Dump screen content to file
ncurses_scr_init -- Initialize screen from file dump
ncurses_scr_restore -- Restore screen from file dump
ncurses_scr_set -- Inherit screen from file dump
ncurses_scrl -- Scroll window content up or down without changing current position
ncurses_show_panel -- Places an invisible panel on top of the stack, making it visible
ncurses_slk_attr -- Returns current soft label key attribute
ncurses_slk_attroff --
ncurses_slk_attron --
ncurses_slk_attrset --
ncurses_slk_clear -- Clears soft labels from screen
ncurses_slk_color -- Sets color for soft label keys
ncurses_slk_init -- Initializes soft label key functions
ncurses_slk_noutrefresh -- Copies soft label keys to virtual screen
ncurses_slk_refresh -- Copies soft label keys to screen
ncurses_slk_restore -- Restores soft label keys
ncurses_slk_set -- Sets function key labels
ncurses_slk_touch -- Forces output when ncurses_slk_noutrefresh is performed
ncurses_standend -- Stop using 'standout' attribute
ncurses_standout -- Start using 'standout' attribute
ncurses_start_color -- Start using colors
ncurses_termattrs -- Returns a logical OR of all attribute flags supported by terminal
ncurses_termname -- Returns terminals (short)-name
ncurses_timeout -- Set timeout for special key sequences
ncurses_top_panel -- Moves a visible panel to the top of the stack
ncurses_typeahead -- Specify different filedescriptor for typeahead checking
ncurses_ungetch -- Put a character back into the input stream
ncurses_ungetmouse -- Pushes mouse event to queue
ncurses_update_panels -- Refreshes the virtual screen to reflect the relations between panels in the stack.
ncurses_use_default_colors -- Assign terminal default colors to color id -1
ncurses_use_env -- Control use of environment information about terminal size
ncurses_use_extended_names -- Control use of extended names in terminfo descriptions
ncurses_vidattr --
ncurses_vline -- Draw a vertical line at current position using an attributed character and max. n characters long
ncurses_waddch -- Adds character at current position in a window and advance cursor
ncurses_waddstr -- Outputs text at current postion in window
ncurses_wattroff -- Turns off attributes for a window
ncurses_wattron -- Turns on attributes for a window
ncurses_wattrset -- Set the attributes for a window
ncurses_wborder -- Draws a border around the window using attributed characters
ncurses_wclear -- Clears window
ncurses_wcolor_set -- Sets windows color pairings
ncurses_werase -- Erase window contents
ncurses_wgetch -- Reads a character from keyboard (window)
ncurses_whline -- Draws a horizontal line in a window at current position using an attributed character and max. n characters long
ncurses_wmouse_trafo -- Transforms window/stdscr coordinates
ncurses_wmove -- Moves windows output position
ncurses_wnoutrefresh -- Copies window to virtual screen
ncurses_wrefresh -- Refresh window on terminal screen
ncurses_wstandend -- End standout mode for a window
ncurses_wstandout -- Enter standout mode for a window
ncurses_wvline -- Draws a vertical line in a window at current position using an attributed character and max. n characters long

이전 | 처음으로 | 다음
syslog | 위로 | ncurses_addch


ncurses_addch

(PHP 4 >= 4.1.0, PHP 5)

ncurses_addch -- Add character at current position and advance cursor

Description

int ncurses_addch ( int ch)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
Ncurses Terminal Screen Control Functions | 위로 | ncurses_addchnstr


ncurses_addchnstr

(PHP 4 >= 4.2.0, PHP 5)

ncurses_addchnstr -- Add attributed string with specified length at current position

Description

int ncurses_addchnstr ( string s, int n)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_addch | 위로 | ncurses_addchstr


ncurses_addchstr

(PHP 4 >= 4.2.0, PHP 5)

ncurses_addchstr -- Add attributed string at current position

Description

int ncurses_addchstr ( string s)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_addchnstr | 위로 | ncurses_addnstr


ncurses_addnstr

(PHP 4 >= 4.2.0, PHP 5)

ncurses_addnstr -- Add string with specified length at current position

Description

int ncurses_addnstr ( string s, int n)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_addchstr | 위로 | ncurses_addstr


ncurses_addstr

(PHP 4 >= 4.2.0, PHP 5)

ncurses_addstr -- Output text at current position

Description

int ncurses_addstr ( string text)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_addnstr | 위로 | ncurses_assume_default_colors


ncurses_assume_default_colors

(PHP 4 >= 4.2.0, PHP 5)

ncurses_assume_default_colors -- Define default colors for color 0

Description

int ncurses_assume_default_colors ( int fg, int bg)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_addstr | 위로 | ncurses_attroff


ncurses_attroff

(PHP 4 >= 4.1.0, PHP 5)

ncurses_attroff -- Turn off the given attributes

Description

int ncurses_attroff ( int attributes)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_assume_default_colors | 위로 | ncurses_attron


ncurses_attron

(PHP 4 >= 4.1.0, PHP 5)

ncurses_attron -- Turn on the given attributes

Description

int ncurses_attron ( int attributes)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_attroff | 위로 | ncurses_attrset


ncurses_attrset

(PHP 4 >= 4.1.0, PHP 5)

ncurses_attrset -- Set given attributes

Description

int ncurses_attrset ( int attributes)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_attron | 위로 | ncurses_baudrate


ncurses_baudrate

(PHP 4 >= 4.1.0, PHP 5)

ncurses_baudrate -- Returns baudrate of terminal

Description

int ncurses_baudrate ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_attrset | 위로 | ncurses_beep


ncurses_beep

(PHP 4 >= 4.1.0, PHP 5)

ncurses_beep -- Let the terminal beep

Description

int ncurses_beep ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_beep() sends an audible alert (bell) and if its not possible flashes the screen. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also ncurses_flash()

이전 | 처음으로 | 다음
ncurses_baudrate | 위로 | ncurses_bkgd


ncurses_bkgd

(PHP 4 >= 4.1.0, PHP 5)

ncurses_bkgd -- Set background property for terminal screen

Description

int ncurses_bkgd ( int attrchar)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_beep | 위로 | ncurses_bkgdset


ncurses_bkgdset

(PHP 4 >= 4.1.0, PHP 5)

ncurses_bkgdset -- Control screen background

Description

void ncurses_bkgdset ( int attrchar)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_bkgd | 위로 | ncurses_border


ncurses_border

(PHP 4 >= 4.2.0, PHP 5)

ncurses_border -- Draw a border around the screen using attributed characters

Description

int ncurses_border ( int left, int right, int top, int bottom, int tl_corner, int tr_corner, int bl_corner, int br_corner)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_border() draws the specified lines and corners around the main window. Each parameter expects 0 to draw a line and 1 to skip it. The corners are top left, top right, bottom left and bottom right.

Use ncurses_wborder() for borders around subwindows!

See also ncurses_wborder().

이전 | 처음으로 | 다음
ncurses_bkgdset | 위로 | ncurses_bottom_panel


ncurses_bottom_panel

(PHP 4 >= 4.3.0, PHP 5)

ncurses_bottom_panel -- Moves a visible panel to the bottom of the stack

Description

int ncurses_bottom_panel ( resource panel)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_border | 위로 | ncurses_can_change_color


ncurses_can_change_color

(PHP 4 >= 4.1.0, PHP 5)

ncurses_can_change_color -- Check if we can change terminals colors

Description

bool ncurses_can_change_color ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

The function ncurses_can_change_color() returns TRUE or FALSE, depending on whether the terminal has color capabilities and whether the programmer can change the colors.

이전 | 처음으로 | 다음
ncurses_bottom_panel | 위로 | ncurses_cbreak


ncurses_cbreak

(PHP 4 >= 4.1.0, PHP 5)

ncurses_cbreak -- Switch of input buffering

Description

bool ncurses_cbreak ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_cbreak() disables line buffering and character processing (interrupt and flow control characters are unaffected), making characters typed by the user immediately available to the program.

ncurses_cbreak() returns TRUE or NCURSES_ERR if any error occurred.

See also: ncurses_nocbreak()

이전 | 처음으로 | 다음
ncurses_can_change_color | 위로 | ncurses_clear


ncurses_clear

(PHP 4 >= 4.1.0, PHP 5)

ncurses_clear -- Clear screen

Description

bool ncurses_clear ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_clear() clears the screen completely without setting blanks. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

Note: ncurses_clear() clears the screen without setting blanks, which have the current background rendition. To clear screen with blanks, use ncurses_erase().

See also ncurses_erase().

이전 | 처음으로 | 다음
ncurses_cbreak | 위로 | ncurses_clrtobot


ncurses_clrtobot

(PHP 4 >= 4.1.0, PHP 5)

ncurses_clrtobot -- Clear screen from current position to bottom

Description

bool ncurses_clrtobot ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_clrtobot() erases all lines from cursor to end of screen and creates blanks. Blanks created by ncurses_clrtobot() have the current background rendition. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also ncurses_clear(), and ncurses_clrtoeol()

이전 | 처음으로 | 다음
ncurses_clear | 위로 | ncurses_clrtoeol


ncurses_clrtoeol

(PHP 4 >= 4.1.0, PHP 5)

ncurses_clrtoeol -- Clear screen from current position to end of line

Description

bool ncurses_clrtoeol ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_clrtoeol() erases the current line from cursor position to the end. Blanks created by ncurses_clrtoeol() have the current background rendition. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also ncurses_clear(), and ncurses_clrtobot()

이전 | 처음으로 | 다음
ncurses_clrtobot | 위로 | ncurses_color_content


ncurses_color_content

(PHP 4 >= 4.3.0, PHP 5)

ncurses_color_content -- Gets the RGB value for color

Description

int ncurses_color_content ( int color, int &r, int &g, int &b)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_clrtoeol | 위로 | ncurses_color_set


ncurses_color_set

(PHP 4 >= 4.1.0, PHP 5)

ncurses_color_set -- Set fore- and background color

Description

int ncurses_color_set ( int pair)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_color_content | 위로 | ncurses_curs_set


ncurses_curs_set

(PHP 4 >= 4.1.0, PHP 5)

ncurses_curs_set -- Set cursor state

Description

int ncurses_curs_set ( int visibility)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_color_set | 위로 | ncurses_def_prog_mode


ncurses_def_prog_mode

(PHP 4 >= 4.1.0, PHP 5)

ncurses_def_prog_mode -- Saves terminals (program) mode

Description

bool ncurses_def_prog_mode ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_def_prog_mode() saves the current terminal modes for program (in curses) for use by ncurses_reset_prog_mode(). Returns FALSE on success, otherwise TRUE.

See also: ncurses_reset_prog_mode()

이전 | 처음으로 | 다음
ncurses_curs_set | 위로 | ncurses_def_shell_mode


ncurses_def_shell_mode

(PHP 4 >= 4.1.0, PHP 5)

ncurses_def_shell_mode -- Saves terminals (shell) mode

Description

bool ncurses_def_shell_mode ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_def_shell_mode() saves the current terminal modes for shell (not in curses) for use by ncurses_reset_shell_mode(). Returns FALSE on success, otherwise TRUE.

See also: ncurses_reset_shell_mode()

이전 | 처음으로 | 다음
ncurses_def_prog_mode | 위로 | ncurses_define_key


ncurses_define_key

(PHP 4 >= 4.2.0, PHP 5)

ncurses_define_key -- Define a keycode

Description

int ncurses_define_key ( string definition, int keycode)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_def_shell_mode | 위로 | ncurses_del_panel


ncurses_del_panel

(PHP 4 >= 4.3.0, PHP 5)

ncurses_del_panel -- Remove panel from the stack and delete it (but not the associated window)

Description

int ncurses_del_panel ( resource panel)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_define_key | 위로 | ncurses_delay_output


ncurses_delay_output

(PHP 4 >= 4.1.0, PHP 5)

ncurses_delay_output -- Delay output on terminal using padding characters

Description

int ncurses_delay_output ( int milliseconds)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_del_panel | 위로 | ncurses_delch


ncurses_delch

(PHP 4 >= 4.1.0, PHP 5)

ncurses_delch -- Delete character at current position, move rest of line left

Description

bool ncurses_delch ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_delch() deletes the character under the cursor. All characters to the right of the cursor on the same line are moved to the left one position and the last character on the line is filled with a blank. The cursor position does not change. Returns FALSE on success, otherwise TRUE.

See also: ncurses_deleteln()

이전 | 처음으로 | 다음
ncurses_delay_output | 위로 | ncurses_deleteln


ncurses_deleteln

(PHP 4 >= 4.1.0, PHP 5)

ncurses_deleteln -- Delete line at current position, move rest of screen up

Description

bool ncurses_deleteln ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_deleteln() deletes the current line under cursorposition. All lines below the current line are moved up one line. The bottom line of window is cleared. Cursor position does not change. Returns FALSE on success, otherwise TRUE.

See also: ncurses_delch()

이전 | 처음으로 | 다음
ncurses_delch | 위로 | ncurses_delwin


ncurses_delwin

(PHP 4 >= 4.1.0, PHP 5)

ncurses_delwin -- Delete a ncurses window

Description

int ncurses_delwin ( resource window)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_deleteln | 위로 | ncurses_doupdate


ncurses_doupdate

(PHP 4 >= 4.1.0, PHP 5)

ncurses_doupdate -- Write all prepared refreshes to terminal

Description

bool ncurses_doupdate ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_doupdate()() compares the virtual screen to the physical screen and updates the physical screen. This way is more effective than using multiple refresh calls. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ncurses_delwin | 위로 | ncurses_echo


ncurses_echo

(PHP 4 >= 4.1.0, PHP 5)

ncurses_echo -- Activate keyboard input echo

Description

bool ncurses_echo ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_echo() enables echo mode. All characters typed by user are echoed by ncurses_getch(). Returns FALSE on success, TRUE if any error occurred.

To disable echo mode use ncurses_noecho().

이전 | 처음으로 | 다음
ncurses_doupdate | 위로 | ncurses_echochar


ncurses_echochar

(PHP 4 >= 4.1.0, PHP 5)

ncurses_echochar -- Single character output including refresh

Description

int ncurses_echochar ( int character)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_echo | 위로 | ncurses_end


ncurses_end

(PHP 4 >= 4.1.0, PHP 5)

ncurses_end -- Stop using ncurses, clean up the screen

Description

int ncurses_end ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_echochar | 위로 | ncurses_erase


ncurses_erase

(PHP 4 >= 4.1.0, PHP 5)

ncurses_erase -- Erase terminal screen

Description

bool ncurses_erase ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_erase() fills the terminal screen with blanks. Created blanks have the current background rendition, set by ncurses_bkgd(). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also ncurses_bkgd(), and ncurses_clear()

이전 | 처음으로 | 다음
ncurses_end | 위로 | ncurses_erasechar


ncurses_erasechar

(PHP 4 >= 4.1.0, PHP 5)

ncurses_erasechar -- Returns current erase character

Description

string ncurses_erasechar ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_erasechar() returns the current erase char character.

See also: ncurses_killchar()

이전 | 처음으로 | 다음
ncurses_erase | 위로 | ncurses_filter


ncurses_filter

(PHP 4 >= 4.1.0, PHP 5)

ncurses_filter --

Description

int ncurses_filter ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_erasechar | 위로 | ncurses_flash


ncurses_flash

(PHP 4 >= 4.1.0, PHP 5)

ncurses_flash -- Flash terminal screen (visual bell)

Description

bool ncurses_flash ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_flash() flashes the screen, and if its not possible, sends an audible alert (bell). Returns FALSE on success, otherwise TRUE.

See also: ncurses_beep()

이전 | 처음으로 | 다음
ncurses_filter | 위로 | ncurses_flushinp


ncurses_flushinp

(PHP 4 >= 4.1.0, PHP 5)

ncurses_flushinp -- Flush keyboard input buffer

Description

bool ncurses_flushinp ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

The ncurses_flushinp() throws away any typeahead that has been typed and has not yet been read by your program. Returns FALSE on success, otherwise TRUE.

이전 | 처음으로 | 다음
ncurses_flash | 위로 | ncurses_getch


ncurses_getch

(PHP 4 >= 4.1.0, PHP 5)

ncurses_getch -- Read a character from keyboard

Description

int ncurses_getch ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_flushinp | 위로 | ncurses_getmaxyx


ncurses_getmaxyx

(PHP 4 >= 4.3.0, PHP 5)

ncurses_getmaxyx -- Returns the size of a window

Description

void ncurses_getmaxyx ( resource window, int &y, int &x)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_getmaxyx() puts the horizontal and vertical size of the window window into the given variables &y and &x. Variables must be passed as reference, so they are updated when the user changes terminal size.

이전 | 처음으로 | 다음
ncurses_getch | 위로 | ncurses_getmouse


ncurses_getmouse

(PHP 4 >= 4.2.0, PHP 5)

ncurses_getmouse -- Reads mouse event

Description

bool ncurses_getmouse ( array mevent)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_getmouse() reads mouse event out of queue. Function ncurses_getmouse() will return ;FALSE if a mouse event is actually visible in the given window, otherwise it will return TRUE. Event options will be delivered in parameter mevent, which has to be an array, passed by reference (see example below). On success an associative array with following keys will be delivered:

  • "id" : Id to distinguish multiple devices

  • "x" : screen relative x-position in character cells

  • "y" : screen relative y-position in character cells

  • "z" : currently not supported

  • "mmask" : Mouse action

예 1. ncurses_getmouse() example

<?php
switch (ncurses_getch()){
  case NCURSES_KEY_MOUSE:
    if (!ncurses_getmouse(&$mevent)){
      if ($mevent["mmask"] & NCURSES_MOUSE_BUTTON1_PRESSED){
        $mouse_x = $mevent["x"]; // Save mouse position
        $mouse_y = $mevent["y"];
      }
    }
  break;

  default:
    /* .... */
}
?>

See also ncurses_ungetmouse()

이전 | 처음으로 | 다음
ncurses_getmaxyx | 위로 | ncurses_getyx


ncurses_getyx

(PHP 4 >= 4.3.0, PHP 5)

ncurses_getyx -- Returns the current cursor position for a window

Description

void ncurses_getyx ( resource window, int &y, int &x)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_getmouse | 위로 | ncurses_halfdelay


ncurses_halfdelay

(PHP 4 >= 4.1.0, PHP 5)

ncurses_halfdelay -- Put terminal into halfdelay mode

Description

int ncurses_halfdelay ( int tenth)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_getyx | 위로 | ncurses_has_colors


ncurses_has_colors

(PHP 4 >= 4.1.0, PHP 5)

ncurses_has_colors -- Check if terminal has colors

Description

bool ncurses_has_colors ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_has_colors() returns TRUE or FALSE depending on whether the terminal has color capacities.

See also: ncurses_can_change_color()

이전 | 처음으로 | 다음
ncurses_halfdelay | 위로 | ncurses_has_ic


ncurses_has_ic

(PHP 4 >= 4.1.0, PHP 5)

ncurses_has_ic -- Check for insert- and delete-capabilities

Description

bool ncurses_has_ic ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_has_ic() checks terminals insert- and delete capabilities. It returns TRUE when terminal has insert/delete-capabilities, otherwise FALSE.

See also: ncurses_has_il()

이전 | 처음으로 | 다음
ncurses_has_colors | 위로 | ncurses_has_il


ncurses_has_il

(PHP 4 >= 4.1.0, PHP 5)

ncurses_has_il -- Check for line insert- and delete-capabilities

Description

bool ncurses_has_il ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_has_il() checks terminals insert- and delete-line-capabilities. It returns TRUE when terminal has insert/delete-line capabilities, otherwise FALSE

See also: ncurses_has_ic()

이전 | 처음으로 | 다음
ncurses_has_ic | 위로 | ncurses_has_key


ncurses_has_key

(PHP 4 >= 4.1.0, PHP 5)

ncurses_has_key -- Check for presence of a function key on terminal keyboard

Description

int ncurses_has_key ( int keycode)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_has_il | 위로 | ncurses_hide_panel


ncurses_hide_panel

(PHP 4 >= 4.3.0, PHP 5)

ncurses_hide_panel -- Remove panel from the stack, making it invisible

Description

int ncurses_hide_panel ( resource panel)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_has_key | 위로 | ncurses_hline


ncurses_hline

(PHP 4 >= 4.2.0, PHP 5)

ncurses_hline -- Draw a horizontal line at current position using an attributed character and max. n characters long

Description

int ncurses_hline ( int charattr, int n)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_hide_panel | 위로 | ncurses_inch


ncurses_inch

(PHP 4 >= 4.1.0, PHP 5)

ncurses_inch -- Get character and attribute at current position

Description

string ncurses_inch ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_inch() returns the character from the current position.

이전 | 처음으로 | 다음
ncurses_hline | 위로 | ncurses_init_color


ncurses_init_color

(PHP 4 >= 4.2.0, PHP 5)

ncurses_init_color -- Set new RGB value for color

Description

int ncurses_init_color ( int color, int r, int g, int b)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_inch | 위로 | ncurses_init_pair


ncurses_init_pair

(PHP 4 >= 4.1.0, PHP 5)

ncurses_init_pair -- Allocate a color pair

Description

int ncurses_init_pair ( int pair, int fg, int bg)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_init_color | 위로 | ncurses_init


ncurses_init

(PHP 4 >= 4.1.0, PHP 5)

ncurses_init -- Initialize ncurses

Description

int ncurses_init ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_init() initializes the ncurses interface and must be used before any other ncurses function.

이전 | 처음으로 | 다음
ncurses_init_pair | 위로 | ncurses_insch


ncurses_insch

(PHP 4 >= 4.1.0, PHP 5)

ncurses_insch -- Insert character moving rest of line including character at current position

Description

int ncurses_insch ( int character)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_init | 위로 | ncurses_insdelln


ncurses_insdelln

(PHP 4 >= 4.1.0, PHP 5)

ncurses_insdelln -- Insert lines before current line scrolling down (negative numbers delete and scroll up)

Description

int ncurses_insdelln ( int count)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_insch | 위로 | ncurses_insertln


ncurses_insertln

(PHP 4 >= 4.1.0, PHP 5)

ncurses_insertln -- Insert a line, move rest of screen down

Description

bool ncurses_insertln ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_insertln() inserts a new line above the current line. The bottom line will be lost.

이전 | 처음으로 | 다음
ncurses_insdelln | 위로 | ncurses_insstr


ncurses_insstr

(PHP 4 >= 4.2.0, PHP 5)

ncurses_insstr -- Insert string at current position, moving rest of line right

Description

int ncurses_insstr ( string text)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_insertln | 위로 | ncurses_instr


ncurses_instr

(PHP 4 >= 4.2.0, PHP 5)

ncurses_instr -- Reads string from terminal screen

Description

int ncurses_instr ( string buffer)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_instr() returns the number of characters read from the current character position until end of line. buffer contains the characters. Attributes are stripped from the characters.

이전 | 처음으로 | 다음
ncurses_insstr | 위로 | ncurses_isendwin


ncurses_isendwin

(PHP 4 >= 4.1.0, PHP 5)

ncurses_isendwin -- Ncurses is in endwin mode, normal screen output may be performed

Description

bool ncurses_isendwin ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_isendwin() returns TRUE, if
ncurses_endwin() has been called without any
subsequent calls to ncurses_wrefresh(),
otherwise FALSE.

See also ncurses_endwin() and ncurses_wrefresh().

이전 | 처음으로 | 다음
ncurses_instr | 위로 | ncurses_keyok


ncurses_keyok

(PHP 4 >= 4.2.0, PHP 5)

ncurses_keyok -- Enable or disable a keycode

Description

int ncurses_keyok ( int keycode, bool enable)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_isendwin | 위로 | ncurses_keypad


ncurses_keypad

(PHP 4 >= 4.2.0, PHP 5)

ncurses_keypad -- Turns keypad on or off

Description

int ncurses_keypad ( resource window, bool bf)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_keyok | 위로 | ncurses_killchar


ncurses_killchar

(PHP 4 >= 4.1.0, PHP 5)

ncurses_killchar -- Returns current line kill character

Description

bool ncurses_killchar ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_killchar() returns the current line kill character.

See also: ncurses_erasechar()

이전 | 처음으로 | 다음
ncurses_keypad | 위로 | ncurses_longname


ncurses_longname

(PHP 4 >= 4.2.0, PHP 5)

ncurses_longname -- Returns terminals description

Description

string ncurses_longname ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_longname() returns a verbose description of the terminal. The description is truncated to 128 characters. On Error ncurses_longname() returns NULL.

See also: ncurses_termname()

이전 | 처음으로 | 다음
ncurses_killchar | 위로 | ncurses_meta


ncurses_meta

(PHP 4 >= 4.3.0, PHP 5)

ncurses_meta -- Enables/Disable 8-bit meta key information

Description

long ncurses_meta ( resource window, bool 8bit)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_longname | 위로 | ncurses_mouse_trafo


ncurses_mouse_trafo

(PHP 4 >= 4.2.0, PHP 5)

ncurses_mouse_trafo -- Transforms coordinates

Description

bool ncurses_mouse_trafo ( int &y, int &x, bool toscreen)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_meta | 위로 | ncurses_mouseinterval


ncurses_mouseinterval

(PHP 4 >= 4.1.0, PHP 5)

ncurses_mouseinterval -- Set timeout for mouse button clicks

Description

int ncurses_mouseinterval ( int milliseconds)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_mouse_trafo | 위로 | ncurses_mousemask


ncurses_mousemask

(PHP 4 >= 4.2.0, PHP 5)

ncurses_mousemask -- Sets mouse options

Description

int ncurses_mousemask ( int newmask, int oldmask)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Function ncurses_mousemask() will set mouse events to be reported. By default no mouse events will be reported. The function ncurses_mousemask() will return a mask to indicated which of the in parameter newmask specified mouse events can be reported. On complete failure, it returns 0. In parameter oldmask, which is passed by reference ncurses_mousemask() returns the previous value of mouse event mask. Mouse events are represented by NCURSES_KEY_MOUSE in the ncurses_wgetch() input stream. To read the event data and pop the event of of queue, call ncurses_getmouse().

As a side effect, setting a zero mousemask in newmask turns off the mouse pointer. Setting a non zero value turns mouse pointer on.

mouse mask options can be set with the following predefined constants:

  • NCURSES_BUTTON1_PRESSED

  • NCURSES_BUTTON1_RELEASED

  • NCURSES_BUTTON1_CLICKED

  • NCURSES_BUTTON1_DOUBLE_CLICKED

  • NCURSES_BUTTON1_TRIPLE_CLICKED

  • NCURSES_BUTTON2_PRESSED

  • NCURSES_BUTTON2_RELEASED

  • NCURSES_BUTTON2_CLICKED

  • NCURSES_BUTTON2_DOUBLE_CLICKED

  • NCURSES_BUTTON2_TRIPLE_CLICKED

  • NCURSES_BUTTON3_PRESSED

  • NCURSES_BUTTON3_RELEASED

  • NCURSES_BUTTON3_CLICKED

  • NCURSES_BUTTON3_DOUBLE_CLICKED

  • NCURSES_BUTTON3_TRIPLE_CLICKED

  • NCURSES_BUTTON4_PRESSED

  • NCURSES_BUTTON4_RELEASED

  • NCURSES_BUTTON4_CLICKED

  • NCURSES_BUTTON4_DOUBLE_CLICKED

  • NCURSES_BUTTON4_TRIPLE_CLICKED

  • NCURSES_BUTTON_SHIFT>

  • NCURSES_BUTTON_CTRL

  • NCURSES_BUTTON_ALT

  • NCURSES_ALL_MOUSE_EVENTS

  • NCURSES_REPORT_MOUSE_POSITION

예 1. ncurses_mousemask() example

<?php
$newmask = NCURSES_BUTTON1_CLICKED + NCURSES_BUTTON1_RELEASED;
$mask = ncurses_mousemask($newmask, &$oldmask);
if ($mask & $newmask){
  printf ("All specified mouse options will be supported\n");
}
?>

See also ncurses_getmouse(),
ncurses_ungetmouse() and
ncurese_getch().

이전 | 처음으로 | 다음
ncurses_mouseinterval | 위로 | ncurses_move_panel


ncurses_move_panel

(PHP 4 >= 4.3.0, PHP 5)

ncurses_move_panel -- Moves a panel so that its upper-left corner is at [startx, starty]

Description

int ncurses_move_panel ( resource panel, int startx, int starty)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_mousemask | 위로 | ncurses_move


ncurses_move

(PHP 4 >= 4.1.0, PHP 5)

ncurses_move -- Move output position

Description

int ncurses_move ( int y, int x)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_move_panel | 위로 | ncurses_mvaddch


ncurses_mvaddch

(PHP 4 >= 4.2.0, PHP 5)

ncurses_mvaddch -- Move current position and add character

Description

int ncurses_mvaddch ( int y, int x, int c)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_move | 위로 | ncurses_mvaddchnstr


ncurses_mvaddchnstr

(PHP 4 >= 4.2.0, PHP 5)

ncurses_mvaddchnstr -- Move position and add attributed string with specified length

Description

int ncurses_mvaddchnstr ( int y, int x, string s, int n)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_mvaddch | 위로 | ncurses_mvaddchstr


ncurses_mvaddchstr

(PHP 4 >= 4.2.0, PHP 5)

ncurses_mvaddchstr -- Move position and add attributed string

Description

int ncurses_mvaddchstr ( int y, int x, string s)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_mvaddchnstr | 위로 | ncurses_mvaddnstr


ncurses_mvaddnstr

(PHP 4 >= 4.2.0, PHP 5)

ncurses_mvaddnstr -- Move position and add string with specified length

Description

int ncurses_mvaddnstr ( int y, int x, string s, int n)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_mvaddchstr | 위로 | ncurses_mvaddstr


ncurses_mvaddstr

(PHP 4 >= 4.2.0, PHP 5)

ncurses_mvaddstr -- Move position and add string

Description

int ncurses_mvaddstr ( int y, int x, string s)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_mvaddnstr | 위로 | ncurses_mvcur


ncurses_mvcur

(PHP 4 >= 4.2.0, PHP 5)

ncurses_mvcur -- Move cursor immediately

Description

int ncurses_mvcur ( int old_y, int old_x, int new_y, int new_x)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_mvaddstr | 위로 | ncurses_mvdelch


ncurses_mvdelch

(PHP 4 >= 4.2.0, PHP 5)

ncurses_mvdelch -- Move position and delete character, shift rest of line left

Description

int ncurses_mvdelch ( int y, int x)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_mvcur | 위로 | ncurses_mvgetch


ncurses_mvgetch

(PHP 4 >= 4.2.0, PHP 5)

ncurses_mvgetch -- Move position and get character at new position

Description

int ncurses_mvgetch ( int y, int x)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_mvdelch | 위로 | ncurses_mvhline


ncurses_mvhline

(PHP 4 >= 4.2.0, PHP 5)

ncurses_mvhline -- Set new position and draw a horizontal line using an attributed character and max. n characters long

Description

int ncurses_mvhline ( int y, int x, int attrchar, int n)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_mvgetch | 위로 | ncurses_mvinch


ncurses_mvinch

(PHP 4 >= 4.2.0, PHP 5)

ncurses_mvinch -- Move position and get attributed character at new position

Description

int ncurses_mvinch ( int y, int x)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_mvhline | 위로 | ncurses_mvvline


ncurses_mvvline

(no version information, might be only in CVS)

ncurses_mvvline -- Set new position and draw a vertical line using an attributed character and max. n characters long

Description

int ncurses_mvvline ( int y, int x, int attrchar, int n)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_mvinch | 위로 | ncurses_mvwaddstr


ncurses_mvwaddstr

(PHP 4 >= 4.2.0, PHP 5)

ncurses_mvwaddstr -- Add string at new position in window

Description

int ncurses_mvwaddstr ( resource window, int y, int x, string text)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_mvvline | 위로 | ncurses_napms


ncurses_napms

(PHP 4 >= 4.1.0, PHP 5)

ncurses_napms -- Sleep

Description

int ncurses_napms ( int milliseconds)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_mvwaddstr | 위로 | ncurses_new_panel


ncurses_new_panel

(PHP 4 >= 4.3.0, PHP 5)

ncurses_new_panel -- Create a new panel and associate it with window

Description

resource ncurses_new_panel ( resource window)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_napms | 위로 | ncurses_newpad


ncurses_newpad

(PHP 4 >= 4.3.0, PHP 5)

ncurses_newpad -- Creates a new pad (window)

Description

resource ncurses_newpad ( int rows, int cols)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_new_panel | 위로 | ncurses_newwin


ncurses_newwin

(PHP 4 >= 4.1.0, PHP 5)

ncurses_newwin -- Create a new window

Description

resource ncurses_newwin ( int rows, int cols, int y, int x)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_newwin() creates a new window to draw elements in. Windows can be positioned using x, y, rows and cols. When creating additional windows, remember to use ncurses_getmaxyx() to check for available space, as terminal size is individual and may vary. The return value is a resource ID used to differ between multiple windows.

이전 | 처음으로 | 다음
ncurses_newpad | 위로 | ncurses_nl


ncurses_nl

(PHP 4 >= 4.1.0, PHP 5)

ncurses_nl -- Translate newline and carriage return / line feed

Description

bool ncurses_nl ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_newwin | 위로 | ncurses_nocbreak


ncurses_nocbreak

(PHP 4 >= 4.1.0, PHP 5)

ncurses_nocbreak -- Switch terminal to cooked mode

Description

bool ncurses_nocbreak ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_nocbreak() routine returns terminal to normal (cooked) mode. Initially the terminal may or may not in cbreak mode as the mode is inherited. Therefore a program should call ncurses_cbreak() and ncurses_nocbreak() explicitly. Returns TRUE if any error occurred, otherwise FALSE.

See also: ncurses_cbreak()

이전 | 처음으로 | 다음
ncurses_nl | 위로 | ncurses_noecho


ncurses_noecho

(PHP 4 >= 4.1.0, PHP 5)

ncurses_noecho -- Switch off keyboard input echo

Description

bool ncurses_noecho ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_noecho() prevents echoing of user typed characters. Returns TRUE if any error occurred, otherwise FALSE.

See also: ncurses_echo(), ncurses_getch()

이전 | 처음으로 | 다음
ncurses_nocbreak | 위로 | ncurses_nonl


ncurses_nonl

(PHP 4 >= 4.1.0, PHP 5)

ncurses_nonl -- Do not translate newline and carriage return / line feed

Description

bool ncurses_nonl ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_noecho | 위로 | ncurses_noqiflush


ncurses_noqiflush

(PHP 4 >= 4.1.0, PHP 5)

ncurses_noqiflush -- Do not flush on signal characters

Description

int ncurses_noqiflush ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_nonl | 위로 | ncurses_noraw


ncurses_noraw

(PHP 4 >= 4.1.0, PHP 5)

ncurses_noraw -- Switch terminal out of raw mode

Description

bool ncurses_noraw ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_noraw() switches the terminal out of raw mode. Raw mode is similar to cbreak mode, in that characters typed are immediately passed through to the user program. The differences that are that in raw mode, the interrupt, quit, suspend and flow control characters are all passed through uninterpreted, instead of generating a signal. Returns TRUE if any error occurred, otherwise FALSE.

See also: ncurses_raw(),
ncurses_cbreak(),
ncurses_nocbreak()

이전 | 처음으로 | 다음
ncurses_noqiflush | 위로 | ncurses_pair_content


ncurses_pair_content

(PHP 4 >= 4.3.0, PHP 5)

ncurses_pair_content -- Gets the RGB value for color

Description

int ncurses_pair_content ( int pair, int &f, int &b)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_noraw | 위로 | ncurses_panel_above


ncurses_panel_above

(PHP 4 >= 4.3.0, PHP 5)

ncurses_panel_above -- Returns the panel above panel. If panel is null, returns the bottom panel in the stack

Description

int ncurses_panel_above ( resource panel)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_pair_content | 위로 | ncurses_panel_below


ncurses_panel_below

(PHP 4 >= 4.3.0, PHP 5)

ncurses_panel_below -- Returns the panel below panel. If panel is null, returns the top panel in the stack

Description

int ncurses_panel_below ( resource panel)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_panel_above | 위로 | ncurses_panel_window


ncurses_panel_window

(PHP 4 >= 4.3.0, PHP 5)

ncurses_panel_window -- Returns the window associated with panel

Description

int ncurses_panel_window ( resource panel)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_panel_below | 위로 | ncurses_pnoutrefresh


ncurses_pnoutrefresh

(PHP 4 >= 4.3.0, PHP 5)

ncurses_pnoutrefresh -- Copies a region from a pad into the virtual screen

Description

int ncurses_pnoutrefresh ( resource pad, int pminrow, int pmincol, int sminrow, int smincol, int smaxrow, int smaxcol)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_panel_window | 위로 | ncurses_prefresh


ncurses_prefresh

(PHP 4 >= 4.3.0, PHP 5)

ncurses_prefresh -- Copies a region from a pad into the virtual screen

Description

int ncurses_prefresh ( resource pad, int pminrow, int pmincol, int sminrow, int smincol, int smaxrow, int smaxcol)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_pnoutrefresh | 위로 | ncurses_putp


ncurses_putp

(PHP 4 >= 4.2.0, PHP 5)

ncurses_putp --

Description

int ncurses_putp ( string text)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_prefresh | 위로 | ncurses_qiflush


ncurses_qiflush

(PHP 4 >= 4.1.0, PHP 5)

ncurses_qiflush -- Flush on signal characters

Description

int ncurses_qiflush ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_putp | 위로 | ncurses_raw


ncurses_raw

(PHP 4 >= 4.1.0, PHP 5)

ncurses_raw -- Switch terminal into raw mode

Description

bool ncurses_raw ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_raw() places the terminal in raw mode. Raw mode is similar to cbreak mode, in that characters typed are immediately passed through to the user program. The differences that are that in raw mode, the interrupt, quit, suspend and flow control characters are all passed through uninterpreted, instead of generating a signal. Returns TRUE if any error occurred, otherwise FALSE.

See also: ncurses_noraw(),
ncurses_cbreak(),
ncurses_nocbreak()

이전 | 처음으로 | 다음
ncurses_qiflush | 위로 | ncurses_refresh


ncurses_refresh

(PHP 4 >= 4.1.0, PHP 5)

ncurses_refresh -- Refresh screen

Description

int ncurses_refresh ( int ch)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_raw | 위로 | ncurses_replace_panel


ncurses_replace_panel

(PHP 4 >= 4.3.0, PHP 5)

ncurses_replace_panel -- Replaces the window associated with panel

Description

int ncurses_replace_panel ( resource panel, resource window)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_refresh | 위로 | ncurses_reset_prog_mode


ncurses_reset_prog_mode

(PHP 4 >= 4.3.0, PHP 5)

ncurses_reset_prog_mode -- Resets the prog mode saved by def_prog_mode

Description

int ncurses_reset_prog_mode ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_replace_panel | 위로 | ncurses_reset_shell_mode


ncurses_reset_shell_mode

(PHP 4 >= 4.3.0, PHP 5)

ncurses_reset_shell_mode -- Resets the shell mode saved by def_shell_mode

Description

int ncurses_reset_shell_mode ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_reset_prog_mode | 위로 | ncurses_resetty


ncurses_resetty

(PHP 4 >= 4.1.0, PHP 5)

ncurses_resetty -- Restores saved terminal state

Description

bool ncurses_resetty ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Function ncurses_resetty() restores the terminal state, which was previously saved by calling ncurses_savetty(). This function always returns FALSE.

See also: ncurses_savetty()

이전 | 처음으로 | 다음
ncurses_reset_shell_mode | 위로 | ncurses_savetty


ncurses_savetty

(PHP 4 >= 4.1.0, PHP 5)

ncurses_savetty -- Saves terminal state

Description

bool ncurses_savetty ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Function ncurses_savetty() saves the current terminal state. The saved terminal state can be restored with function ncurses_resetty(). ncurses_savetty() always returns FALSE.

See also: ncurses_resetty()

이전 | 처음으로 | 다음
ncurses_resetty | 위로 | ncurses_scr_dump


ncurses_scr_dump

(PHP 4 >= 4.2.0, PHP 5)

ncurses_scr_dump -- Dump screen content to file

Description

int ncurses_scr_dump ( string filename)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_savetty | 위로 | ncurses_scr_init


ncurses_scr_init

(PHP 4 >= 4.2.0, PHP 5)

ncurses_scr_init -- Initialize screen from file dump

Description

int ncurses_scr_init ( string filename)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_scr_dump | 위로 | ncurses_scr_restore


ncurses_scr_restore

(PHP 4 >= 4.2.0, PHP 5)

ncurses_scr_restore -- Restore screen from file dump

Description

int ncurses_scr_restore ( string filename)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_scr_init | 위로 | ncurses_scr_set


ncurses_scr_set

(PHP 4 >= 4.2.0, PHP 5)

ncurses_scr_set -- Inherit screen from file dump

Description

int ncurses_scr_set ( string filename)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_scr_restore | 위로 | ncurses_scrl


ncurses_scrl

(PHP 4 >= 4.1.0, PHP 5)

ncurses_scrl -- Scroll window content up or down without changing current position

Description

int ncurses_scrl ( int count)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_scr_set | 위로 | ncurses_show_panel


ncurses_show_panel

(PHP 4 >= 4.3.0, PHP 5)

ncurses_show_panel -- Places an invisible panel on top of the stack, making it visible

Description

int ncurses_show_panel ( resource panel)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_scrl | 위로 | ncurses_slk_attr


ncurses_slk_attr

(PHP 4 >= 4.1.0, PHP 5)

ncurses_slk_attr -- Returns current soft label key attribute

Description

bool ncurses_slk_attr ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_slk_attr() returns the current soft label key attribute. On error returns TRUE, otherwise FALSE.

이전 | 처음으로 | 다음
ncurses_show_panel | 위로 | ncurses_slk_attroff


ncurses_slk_attroff

(PHP 4 >= 4.1.0, PHP 5)

ncurses_slk_attroff --

Description

int ncurses_slk_attroff ( int intarg)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_slk_attr | 위로 | ncurses_slk_attron


ncurses_slk_attron

(PHP 4 >= 4.1.0, PHP 5)

ncurses_slk_attron --

Description

int ncurses_slk_attron ( int intarg)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_slk_attroff | 위로 | ncurses_slk_attrset


ncurses_slk_attrset

(PHP 4 >= 4.1.0, PHP 5)

ncurses_slk_attrset --

Description

int ncurses_slk_attrset ( int intarg)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_slk_attron | 위로 | ncurses_slk_clear


ncurses_slk_clear

(PHP 4 >= 4.1.0, PHP 5)

ncurses_slk_clear -- Clears soft labels from screen

Description

bool ncurses_slk_clear ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

The function ncurses_slk_clear() clears soft label keys from screen. Returns TRUE on error, otherwise FALSE.

이전 | 처음으로 | 다음
ncurses_slk_attrset | 위로 | ncurses_slk_color


ncurses_slk_color

(PHP 4 >= 4.1.0, PHP 5)

ncurses_slk_color -- Sets color for soft label keys

Description

int ncurses_slk_color ( int intarg)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_slk_clear | 위로 | ncurses_slk_init


ncurses_slk_init

(PHP 4 >= 4.1.0, PHP 5)

ncurses_slk_init -- Initializes soft label key functions

Description

bool ncurses_slk_init ( int format)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Function ncurses_slk_init() must be called before ncurses_initscr() or ncurses_newterm() is called. If ncurses_initscr() eventually uses a line from stdscr to emulate the soft labels, then format determines how the labels are arranged of the screen. Setting format to 0 indicates a 3-2-3 arrangement of the labels, 1 indicates a 4-4 arrangement and 2 indicates the PC like 4-4-4 mode, but in addition an index line will be created.

이전 | 처음으로 | 다음
ncurses_slk_color | 위로 | ncurses_slk_noutrefresh


ncurses_slk_noutrefresh

(PHP 4 >= 4.1.0, PHP 5)

ncurses_slk_noutrefresh -- Copies soft label keys to virtual screen

Description

bool ncurses_slk_noutrefresh ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_slk_init | 위로 | ncurses_slk_refresh


ncurses_slk_refresh

(PHP 4 >= 4.1.0, PHP 5)

ncurses_slk_refresh -- Copies soft label keys to screen

Description

bool ncurses_slk_refresh ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_slk_refresh() copies soft label keys from virtual screen to physical screen. Returns TRUE on error, otherwise FALSE.

이전 | 처음으로 | 다음
ncurses_slk_noutrefresh | 위로 | ncurses_slk_restore


ncurses_slk_restore

(PHP 4 >= 4.1.0, PHP 5)

ncurses_slk_restore -- Restores soft label keys

Description

bool ncurses_slk_restore ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

The function ncurses_slk_restore() restores the soft label keys after ncurses_slk_clear() has been performed.

이전 | 처음으로 | 다음
ncurses_slk_refresh | 위로 | ncurses_slk_set


ncurses_slk_set

(PHP 4 >= 4.2.0, PHP 5)

ncurses_slk_set -- Sets function key labels

Description

bool ncurses_slk_set ( int labelnr, string label, int format)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_slk_restore | 위로 | ncurses_slk_touch


ncurses_slk_touch

(PHP 4 >= 4.1.0, PHP 5)

ncurses_slk_touch -- Forces output when ncurses_slk_noutrefresh is performed

Description

bool ncurses_slk_touch ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

The ncurses_slk_touch() function forces all the soft labels to be output the next time a ncurses_slk_noutrefresh() is performed.

이전 | 처음으로 | 다음
ncurses_slk_set | 위로 | ncurses_standend


ncurses_standend

(PHP 4 >= 4.1.0, PHP 5)

ncurses_standend -- Stop using 'standout' attribute

Description

int ncurses_standend ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_slk_touch | 위로 | ncurses_standout


ncurses_standout

(PHP 4 >= 4.1.0, PHP 5)

ncurses_standout -- Start using 'standout' attribute

Description

int ncurses_standout ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_standend | 위로 | ncurses_start_color


ncurses_start_color

(PHP 4 >= 4.1.0, PHP 5)

ncurses_start_color -- Start using colors

Description

int ncurses_start_color ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_standout | 위로 | ncurses_termattrs


ncurses_termattrs

(PHP 4 >= 4.1.0, PHP 5)

ncurses_termattrs -- Returns a logical OR of all attribute flags supported by terminal

Description

bool ncurses_termattrs ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_start_color | 위로 | ncurses_termname


ncurses_termname

(PHP 4 >= 4.2.0, PHP 5)

ncurses_termname -- Returns terminals (short)-name

Description

string ncurses_termname ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_termname() returns terminals shortname. The shortname is truncated to 14 characters. On error ncurses_termname() returns NULL.

See also: ncurses_longname()

이전 | 처음으로 | 다음
ncurses_termattrs | 위로 | ncurses_timeout


ncurses_timeout

(PHP 4 >= 4.1.0, PHP 5)

ncurses_timeout -- Set timeout for special key sequences

Description

void ncurses_timeout ( int millisec)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_termname | 위로 | ncurses_top_panel


ncurses_top_panel

(PHP 4 >= 4.3.0, PHP 5)

ncurses_top_panel -- Moves a visible panel to the top of the stack

Description

int ncurses_top_panel ( resource panel)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_timeout | 위로 | ncurses_typeahead


ncurses_typeahead

(PHP 4 >= 4.1.0, PHP 5)

ncurses_typeahead -- Specify different filedescriptor for typeahead checking

Description

int ncurses_typeahead ( int fd)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_top_panel | 위로 | ncurses_ungetch


ncurses_ungetch

(PHP 4 >= 4.1.0, PHP 5)

ncurses_ungetch -- Put a character back into the input stream

Description

int ncurses_ungetch ( int keycode)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_typeahead | 위로 | ncurses_ungetmouse


ncurses_ungetmouse

(PHP 4 >= 4.2.0, PHP 5)

ncurses_ungetmouse -- Pushes mouse event to queue

Description

bool ncurses_ungetmouse ( array mevent)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_getmouse() pushes a KEY_MOUSE event onto the unput queue and associates with this event the given state sata and screen-relative character cell coordinates, specified in mevent. Event options will be specified in associative array mevent:

  • "id" : Id to distinguish multiple devices

  • "x" : screen relative x-position in character cells

  • "y" : screen relative y-position in character cells

  • "z" : currently not supported

  • "mmask" : Mouse action

ncurses_ungetmouse() returns FALSE on success, otherwise TRUE.

See also: ncurses_getmouse()

이전 | 처음으로 | 다음
ncurses_ungetch | 위로 | ncurses_update_panels


ncurses_update_panels

(PHP 4 >= 4.3.0, PHP 5)

ncurses_update_panels -- Refreshes the virtual screen to reflect the relations between panels in the stack.

Description

void ncurses_update_panels ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_ungetmouse | 위로 | ncurses_use_default_colors


ncurses_use_default_colors

(PHP 4 >= 4.1.0, PHP 5)

ncurses_use_default_colors -- Assign terminal default colors to color id -1

Description

bool ncurses_use_default_colors ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_update_panels | 위로 | ncurses_use_env


ncurses_use_env

(PHP 4 >= 4.1.0, PHP 5)

ncurses_use_env -- Control use of environment information about terminal size

Description

void ncurses_use_env ( bool flag)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_use_default_colors | 위로 | ncurses_use_extended_names


ncurses_use_extended_names

(PHP 4 >= 4.1.0, PHP 5)

ncurses_use_extended_names -- Control use of extended names in terminfo descriptions

Description

int ncurses_use_extended_names ( bool flag)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_use_env | 위로 | ncurses_vidattr


ncurses_vidattr

(PHP 4 >= 4.1.0, PHP 5)

ncurses_vidattr --

Description

int ncurses_vidattr ( int intarg)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_use_extended_names | 위로 | ncurses_vline


ncurses_vline

(PHP 4 >= 4.2.0, PHP 5)

ncurses_vline -- Draw a vertical line at current position using an attributed character and max. n characters long

Description

int ncurses_vline ( int charattr, int n)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_vidattr | 위로 | ncurses_waddch


ncurses_waddch

(PHP 4 >= 4.3.0, PHP 5)

ncurses_waddch -- Adds character at current position in a window and advance cursor

Description

int ncurses_waddch ( resource window, int ch)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_vline | 위로 | ncurses_waddstr


ncurses_waddstr

(PHP 4 >= 4.2.0, PHP 5)

ncurses_waddstr -- Outputs text at current postion in window

Description

int ncurses_waddstr ( resource window, string str [, int n])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_waddch | 위로 | ncurses_wattroff


ncurses_wattroff

(PHP 4 >= 4.3.0, PHP 5)

ncurses_wattroff -- Turns off attributes for a window

Description

int ncurses_wattroff ( resource window, int attrs)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_waddstr | 위로 | ncurses_wattron


ncurses_wattron

(PHP 4 >= 4.3.0, PHP 5)

ncurses_wattron -- Turns on attributes for a window

Description

int ncurses_wattron ( resource window, int attrs)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_wattroff | 위로 | ncurses_wattrset


ncurses_wattrset

(PHP 4 >= 4.3.0, PHP 5)

ncurses_wattrset -- Set the attributes for a window

Description

int ncurses_wattrset ( resource window, int attrs)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_wattron | 위로 | ncurses_wborder


ncurses_wborder

(PHP 4 >= 4.3.0, PHP 5)

ncurses_wborder -- Draws a border around the window using attributed characters

Description

int ncurses_wborder ( resource window, int left, int right, int top, int bottom, int tl_corner, int tr_corner, int bl_corner, int br_corner)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

ncurses_wborder() draws the specified lines and corners around the passed window window. Each parameter expects 0 to draw a line and 1 to skip it. The corners are top left, top right, bottom left and bottom right.

Use ncurses_border() for borders around the main window.

See also ncurses_border().

이전 | 처음으로 | 다음
ncurses_wattrset | 위로 | ncurses_wclear


ncurses_wclear

(PHP 4 >= 4.2.0, PHP 5)

ncurses_wclear -- Clears window

Description

int ncurses_wclear ( resource window)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_wborder | 위로 | ncurses_wcolor_set


ncurses_wcolor_set

(PHP 4 >= 4.2.0, PHP 5)

ncurses_wcolor_set -- Sets windows color pairings

Description

int ncurses_wcolor_set ( resource window, int color_pair)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_wclear | 위로 | ncurses_werase


ncurses_werase

(PHP 4 >= 4.3.0, PHP 5)

ncurses_werase -- Erase window contents

Description

long ncurses_werase ( resource window)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_wcolor_set | 위로 | ncurses_wgetch


ncurses_wgetch

(PHP 4 >= 4.2.0, PHP 5)

ncurses_wgetch -- Reads a character from keyboard (window)

Description

int ncurses_wgetch ( resource window)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_werase | 위로 | ncurses_whline


ncurses_whline

(PHP 4 >= 4.3.0, PHP 5)

ncurses_whline -- Draws a horizontal line in a window at current position using an attributed character and max. n characters long

Description

int ncurses_whline ( resource window, int charattr, int n)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_wgetch | 위로 | ncurses_wmouse_trafo


ncurses_wmouse_trafo

(PHP 4 >= 4.2.0, PHP 5)

ncurses_wmouse_trafo -- Transforms window/stdscr coordinates

Description

bool ncurses_wmouse_trafo ( resource window, int &y, int &x, bool toscreen)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_whline | 위로 | ncurses_wmove


ncurses_wmove

(PHP 4 >= 4.2.0, PHP 5)

ncurses_wmove -- Moves windows output position

Description

int ncurses_wmove ( resource window, int y, int x)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_wmouse_trafo | 위로 | ncurses_wnoutrefresh


ncurses_wnoutrefresh

(PHP 4 >= 4.2.0, PHP 5)

ncurses_wnoutrefresh -- Copies window to virtual screen

Description

int ncurses_wnoutrefresh ( resource window)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_wmove | 위로 | ncurses_wrefresh


ncurses_wrefresh

(PHP 4 >= 4.2.0, PHP 5)

ncurses_wrefresh -- Refresh window on terminal screen

Description

int ncurses_wrefresh ( resource window)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_wnoutrefresh | 위로 | ncurses_wstandend


ncurses_wstandend

(PHP 4 >= 4.3.0, PHP 5)

ncurses_wstandend -- End standout mode for a window

Description

int ncurses_wstandend ( resource window)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_wrefresh | 위로 | ncurses_wstandout


ncurses_wstandout

(PHP 4 >= 4.3.0, PHP 5)

ncurses_wstandout -- Enter standout mode for a window

Description

int ncurses_wstandout ( resource window)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_wstandend | 위로 | ncurses_wvline


ncurses_wvline

(PHP 4 >= 4.3.0, PHP 5)

ncurses_wvline -- Draws a vertical line in a window at current position using an attributed character and max. n characters long

Description

int ncurses_wvline ( resource window, int charattr, int n)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ncurses_wstandout | 위로 | Lotus Notes Functions


Lotus Notes Functions

PHP 매뉴얼
이전 다음

LXX. Lotus Notes Functions

소개

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

참고: 이 확장 모듈은 PHP 5에서 제거되어, PECL로 이동되었습니다.

차례
notes_body -- Open the message msg_number in the specified mailbox on the specified server (leave serv
notes_copy_db -- Create a note using form form_name
notes_create_db -- Create a Lotus Notes database
notes_create_note -- Create a note using form form_name
notes_drop_db -- Drop a Lotus Notes database
notes_find_note -- Returns a note id found in database_name. Specify the name of the note. Leaving type bla
notes_header_info -- Open the message msg_number in the specified mailbox on the specified server (leave serv
notes_list_msgs -- Returns the notes from a selected database_name
notes_mark_read -- Mark a note_id as read for the User user_name
notes_mark_unread -- Mark a note_id as unread for the User user_name
notes_nav_create -- Create a navigator name, in database_name
notes_search -- Find notes that match keywords in database_name
notes_unread -- Returns the unread note id's for the current User user_name
notes_version -- Get the version Lotus Notes

이전 | 처음으로 | 다음
ncurses_wvline | 위로 | notes_body


notes_body

(PHP 4 >= 4.0.5)

notes_body -- Open the message msg_number in the specified mailbox on the specified server (leave serv

Description

array notes_body ( string server, string mailbox, int msg_number)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
Lotus Notes Functions | 위로 | notes_copy_db


notes_copy_db

(PHP 4 >= 4.0.5)

notes_copy_db -- Create a note using form form_name

Description

string notes_copy_db ( string from_database_name, string to_database_name)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
notes_body | 위로 | notes_create_db


notes_create_db

(PHP 4 >= 4.0.5)

notes_create_db -- Create a Lotus Notes database

Description

bool notes_create_db ( string database_name)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
notes_copy_db | 위로 | notes_create_note


notes_create_note

(PHP 4 >= 4.0.5)

notes_create_note -- Create a note using form form_name

Description

string notes_create_note ( string database_name, string form_name)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
notes_create_db | 위로 | notes_drop_db


notes_drop_db

(PHP 4 >= 4.0.5)

notes_drop_db -- Drop a Lotus Notes database

Description

bool notes_drop_db ( string database_name)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
notes_create_note | 위로 | notes_find_note


notes_find_note

(PHP 4 >= 4.0.5)

notes_find_note -- Returns a note id found in database_name. Specify the name of the note. Leaving type bla

Description

bool notes_find_note ( string database_name, string name [, string type])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
notes_drop_db | 위로 | notes_header_info


notes_header_info

(PHP 4 >= 4.0.5)

notes_header_info -- Open the message msg_number in the specified mailbox on the specified server (leave serv

Description

object notes_header_info ( string server, string mailbox, int msg_number)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
notes_find_note | 위로 | notes_list_msgs


notes_list_msgs

(PHP 4 >= 4.0.5)

notes_list_msgs -- Returns the notes from a selected database_name

Description

bool notes_list_msgs ( string db)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
notes_header_info | 위로 | notes_mark_read


notes_mark_read

(PHP 4 >= 4.0.5)

notes_mark_read -- Mark a note_id as read for the User user_name

Description

string notes_mark_read ( string database_name, string user_name, string note_id)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
notes_list_msgs | 위로 | notes_mark_unread


notes_mark_unread

(PHP 4 >= 4.0.5)

notes_mark_unread -- Mark a note_id as unread for the User user_name

Description

string notes_mark_unread ( string database_name, string user_name, string note_id)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
notes_mark_read | 위로 | notes_nav_create


notes_nav_create

(PHP 4 >= 4.0.5)

notes_nav_create -- Create a navigator name, in database_name

Description

bool notes_nav_create ( string database_name, string name)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
notes_mark_unread | 위로 | notes_search


notes_search

(PHP 4 >= 4.0.5)

notes_search -- Find notes that match keywords in database_name

Description

string notes_search ( string database_name, string keywords)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
notes_nav_create | 위로 | notes_unread


notes_unread

(PHP 4 >= 4.0.5)

notes_unread -- Returns the unread note id's for the current User user_name

Description

string notes_unread ( string database_name, string user_name)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
notes_search | 위로 | notes_version


notes_version

(PHP 4 >= 4.0.5)

notes_version -- Get the version Lotus Notes

Description

string notes_version ( string database_name)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
notes_unread | 위로 | NSAPI-specific Functions


NSAPI-specific Functions

PHP 매뉴얼
이전 다음

LXXI. NSAPI-specific Functions

소개

These functions are only available when running PHP as a NSAPI module in Netscape/iPlanet/SunONE webservers.

설치

For PHP installation on Netscape/iPlanet/SunONE webservers see the NSAPI section in the installation chapter.

런타임 설정

The behaviour of the NSAPI PHP module is affected by settings in php.ini. Configuration settings from php.ini may be overridden by additional parameters to the php4_execute call in obj.conf

표 1. NSAPI configuration options

Name | Default | Changeable | Function
nsapi.read_timeout | 60 | PHP_INI_ALL | sets the time in seconds the plugin is waiting for POST data from the client

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

참고

NSAPI implements a subset of the functions from the Apache module for maximum compatibility.

표 2. Apache functions implemented by NSAPI

Apache function (only as alias) | NSAPI function | Description
apache_request_headers() | nsapi_request_headers() | Fetch all HTTP request headers
apache_response_headers() | nsapi_response_headers() | Fetch all HTTP response headers
getallheaders() | nsapi_request_headers() | Fetch all HTTP request headers
virtual() | nsapi_virtual() | Make NSAPI sub-request

차례
nsapi_request_headers -- Fetch all HTTP request headers
nsapi_response_headers -- Fetch all HTTP response headers
nsapi_virtual -- Perform an NSAPI sub-request

이전 | 처음으로 | 다음
notes_version | 위로 | nsapi_request_headers


nsapi_request_headers

(PHP 4 >= 4.3.3, PHP 5)

nsapi_request_headers -- Fetch all HTTP request headers

Description

array nsapi_request_headers ( void )

nsapi_request_headers() returns an associative array of all the HTTP headers in the current request. This is only supported when PHP runs as a NSAPI module.

예 1. nsapi_request_headers() example

<?php
$headers = nsapi_request_headers();

foreach ($headers as $header => $value) {
    echo "$header: $value <br />\n";
}
?>

참고: Prior to PHP 4.3.3, getallheaders() was only available for the Apache servers. After PHP 4.3.3, getallheaders() is an alias for nsapi_request_headers() if you use the NSAPI module.

참고: You can also get at the value of the common CGI variables by reading them from the $_SERVER superglobal, which works whether or not you are using PHP as a NSAPI module.

이전 | 처음으로 | 다음
NSAPI-specific Functions | 위로 | nsapi_response_headers


nsapi_response_headers

(PHP 4 >= 4.3.3, PHP 5)

nsapi_response_headers -- Fetch all HTTP response headers

Description

array nsapi_response_headers ( void )

Returns an array of all NSAPI response headers. This functionality is only available in PHP 4.3.3 and greater.

See also nsapi_request_headers() and headers_sent().

이전 | 처음으로 | 다음
nsapi_request_headers | 위로 | nsapi_virtual


nsapi_virtual

(PHP 4 >= 4.3.3, PHP 5)

nsapi_virtual -- Perform an NSAPI sub-request

Description

int nsapi_virtual ( string uri)

nsapi_virtual() is an NSAPI-specific function which is equivalent to <!--#include virtual...--> in SSI (.shtml files). It does an NSAPI sub-request. It is useful for including CGI scripts or .shtml files, or anything else that you'd parse through webserver.

To run the sub-request, all buffers are terminated and flushed to the browser, pending headers are sent too.

You cannot make recursive requests with this function to other PHP scripts. If you want to include PHP scripts, use include() or require().

참고: This function depends on a undocumented feature of the Netscape/iPlanet/SunONE webservers. Use phpinfo() to determine if it is available. In the Unix environment it should always work, in windows it depends on the name of a ns-httpdXX.dll file. Read the note about subrequests in the install section if you experience this problem.

이전 | 처음으로 | 다음
nsapi_response_headers | 위로 | Unified ODBC Functions


Unified ODBC Functions

PHP 매뉴얼
이전 다음

LXXII. Unified ODBC Functions

소개

In addition to normal ODBC support, the Unified ODBC functions in PHP allow you to access several databases that have borrowed the semantics of the ODBC API to implement their own API. Instead of maintaining multiple database drivers that were all nearly identical, these drivers have been unified into a single set of ODBC functions.

The following databases are supported by the Unified ODBC functions: Adabas D, IBM DB2, iODBC, Solid, and Sybase SQL Anywhere.

참고: There is no ODBC involved when connecting to the above databases. The functions that you use to speak natively to them just happen to share the same names and syntax as the ODBC functions. The exception to this is iODBC. Building PHP with iODBC support enables you to use any ODBC-compliant drivers with your PHP applications. iODBC is maintained by OpenLink Software. More information on iODBC, as well as a HOWTO, is available at www.iodbc.org.

요구 사항

To access any of the supported databases you need to have the required libraries installed.

설치

--with-adabas[=DIR]

Include Adabas D support. DIR is the Adabas base install directory, defaults to /usr/local.

--with-sapdb[=DIR]

Include SAP DB support. DIR is SAP DB base install directory, defaults to /usr/local.

--with-solid[=DIR]

Include Solid support. DIR is the Solid base install directory, defaults to /usr/local/solid.

--with-ibm-db2[=DIR]

Include IBM DB2 support. DIR is the DB2 base install directory, defaults to /home/db2inst1/sqllib.

--with-empress[=DIR]

Include Empress support. DIR is the Empress base install directory, defaults to $EMPRESSPATH. From PHP 4, this option only supports Empress Version 8.60 and above.

--with-empress-bcs[=DIR]

Include Empress Local Access support. DIR is the Empress base install directory, defaults to $EMPRESSPATH. From PHP 4, this option only supports Empress Version 8.60 and above.

--with-birdstep[=DIR]

Include Birdstep support. DIR is the Birdstep base install directory, defaults to /usr/local/birdstep.

--with-custom-odbc[=DIR]

Include a user defined ODBC support. The DIR is ODBC install base directory, which defaults to /usr/local. Make sure to define CUSTOM_ODBC_LIBS and have some odbc.h in your include dirs. E.g., you should define following for Sybase SQL Anywhere 5.5.00 on QNX, prior to run configure script: CPPFLAGS="-DODBC_QNX -DSQLANY_BUG" LDFLAGS=-lunix CUSTOM_ODBC_LIBS="-ldblib -lodbc".

--with-iodbc[=DIR]

Include iODBC support. DIR is the iODBC base install directory, defaults to /usr/local.

--with-esoob[=DIR]

Include Easysoft OOB support. DIR is the OOB base install directory, defaults to /usr/local/easysoft/oob/client.

--with-unixODBC[=DIR]

Include unixODBC support. DIR is the unixODBC base install directory, defaults to /usr/local.

--with-openlink[=DIR]

Include OpenLink ODBC support. DIR is the OpenLink base install directory, defaults to /usr/local. This is the same as iODBC.

--with-dbmaker[=DIR]

Include DBMaker support. DIR is the DBMaker base install directory, defaults to where the latest version of DBMaker is installed (such as /home/dbmaker/3.6).

To disable unified ODBC support in PHP 3 add --disable-unified-odbc to your configure line. Only applicable if iODBC, Adabas, Solid, Velocis or a custom ODBC interface is enabled.

PHP 윈도우 버전에서는 이 확장 모듈에 대한 지원이 포함되어 있습니다. 이 함수들을 이용하기 위해서 추가로 확장 모듈을 읽어들일 필요가 없습니다.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. Unified ODBC Configuration Options

Name | Default | Changeable
odbc.default_db * | NULL | PHP_INI_ALL
odbc.default_user * | NULL | PHP_INI_ALL
odbc.default_pw * | NULL | PHP_INI_ALL
odbc.allow_persistent | "1" | PHP_INI_SYSTEM
odbc.check_persistent | "1" | PHP_INI_SYSTEM
odbc.max_persistent | "-1" | PHP_INI_SYSTEM
odbc.max_links | "-1" | PHP_INI_SYSTEM
odbc.defaultlrl | "4096" | PHP_INI_ALL
odbc.defaultbinmode | "1" | PHP_INI_ALL

참고: Entries marked with * are not implemented yet.

For further details and definition of the PHP_INI_* constants see ini_set().

위 설정 지시어에 대한 간단한 설명입니다.

odbc.default_db string

ODBC data source to use if none is specified in odbc_connect() or odbc_pconnect().

odbc.default_user string

User name to use if none is specified in odbc_connect() or odbc_pconnect().

odbc.default_pw string

Password to use if none is specified in odbc_connect() or odbc_pconnect().

odbc.allow_persistent boolean

Whether to allow persistent ODBC connections.

odbc.check_persistent boolean

Check that a connection is still valid before reuse.

odbc.max_persistent integer

The maximum number of persistent ODBC connections per process.

odbc.max_links integer

The maximum number of ODBC connections per process, including persistent connections.

odbc.defaultlrl integer

Handling of LONG fields. Specifies the number of bytes returned to variables.

odbc.defaultbinmode integer

Handling of binary data.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

ODBC_TYPE (integer)

ODBC_BINMODE_PASSTHRU (integer)

ODBC_BINMODE_RETURN (integer)

ODBC_BINMODE_CONVERT (integer)

SQL_ODBC_CURSORS (integer)

SQL_CUR_USE_DRIVER (integer)

SQL_CUR_USE_IF_NEEDED (integer)

SQL_CUR_USE_ODBC (integer)

SQL_CONCURRENCY (integer)

SQL_CONCUR_READ_ONLY (integer)

SQL_CONCUR_LOCK (integer)

SQL_CONCUR_ROWVER (integer)

SQL_CONCUR_VALUES (integer)

SQL_CURSOR_TYPE (integer)

SQL_CURSOR_FORWARD_ONLY (integer)

SQL_CURSOR_KEYSET_DRIVEN (integer)

SQL_CURSOR_DYNAMIC (integer)

SQL_CURSOR_STATIC (integer)

SQL_KEYSET_SIZE (integer)

SQL_CHAR (integer)

SQL_VARCHAR (integer)

SQL_LONGVARCHAR (integer)

SQL_DECIMAL (integer)

SQL_NUMERIC (integer)

SQL_BIT (integer)

SQL_TINYINT (integer)

SQL_SMALLINT (integer)

SQL_INTEGER (integer)

SQL_BIGINT (integer)

SQL_REAL (integer)

SQL_FLOAT (integer)

SQL_DOUBLE (integer)

SQL_BINARY (integer)

SQL_VARBINARY (integer)

SQL_LONGVARBINARY (integer)

SQL_DATE (integer)

SQL_TIME (integer)

SQL_TIMESTAMP (integer)

SQL_TYPE_DATE (integer)

SQL_TYPE_TIME (integer)

SQL_TYPE_TIMESTAMP (integer)

SQL_BEST_ROWID (integer)

SQL_ROWVER (integer)

SQL_SCOPE_CURROW (integer)

SQL_SCOPE_TRANSACTION (integer)

SQL_SCOPE_SESSION (integer)

SQL_NO_NULLS (integer)

SQL_NULLABLE (integer)

SQL_INDEX_UNIQUE (integer)

SQL_INDEX_ALL (integer)

SQL_ENSURE (integer)

SQL_QUICK (integer)

차례
odbc_autocommit -- Toggle autocommit behaviour
odbc_binmode -- Handling of binary column data
odbc_close_all -- Close all ODBC connections
odbc_close -- Close an ODBC connection
odbc_columnprivileges -- Returns a result identifier that can be used to fetch a list of columns and associated privileges
odbc_columns -- Lists the column names in specified tables. Returns a result identifier containing the information.
odbc_commit -- Commit an ODBC transaction
odbc_connect -- Connect to a datasource
odbc_cursor -- Get cursorname
odbc_data_source -- Returns information about a current connection
odbc_do -- Synonym for odbc_exec()
odbc_error -- Get the last error code
odbc_errormsg -- Get the last error message
odbc_exec -- Prepare and execute a SQL statement
odbc_execute -- Execute a prepared statement
odbc_fetch_array -- Fetch a result row as an associative array
odbc_fetch_into -- Fetch one result row into array
odbc_fetch_object -- Fetch a result row as an object
odbc_fetch_row -- Fetch a row
odbc_field_len -- Get the length (precision) of a field
odbc_field_name -- Get the columnname
odbc_field_num -- Return column number
odbc_field_precision -- Synonym for odbc_field_len()
odbc_field_scale -- Get the scale of a field
odbc_field_type -- Datatype of a field
odbc_foreignkeys -- Returns a list of foreign keys in the specified table or a list of foreign keys in other tables that refer to the primary key in the specified table
odbc_free_result -- Free resources associated with a result
odbc_gettypeinfo -- Returns a result identifier containing information about data types supported by the data source.
odbc_longreadlen -- Handling of LONG columns
odbc_next_result -- Checks if multiple results are available
odbc_num_fields -- Number of columns in a result
odbc_num_rows -- Number of rows in a result
odbc_pconnect -- Open a persistent database connection
odbc_prepare -- Prepares a statement for execution
odbc_primarykeys -- Returns a result identifier that can be used to fetch the column names that comprise the primary key for a table
odbc_procedurecolumns -- Retrieve information about parameters to procedures
odbc_procedures -- Get the list of procedures stored in a specific data source. Returns a result identifier containing the information.
odbc_result_all -- Print result as HTML table
odbc_result -- Get result data
odbc_rollback -- Rollback a transaction
odbc_setoption -- Adjust ODBC settings. Returns FALSE if an error occurs, otherwise TRUE.
odbc_specialcolumns -- Returns either the optimal set of columns that uniquely identifies a row in the table or columns that are automatically updated when any value in the row is updated by a transaction
odbc_statistics -- Retrieve statistics about a table
odbc_tableprivileges -- Lists tables and the privileges associated with each table
odbc_tables -- Get the list of table names stored in a specific data source. Returns a result identifier containing the information.

이전 | 처음으로 | 다음
nsapi_virtual | 위로 | odbc_autocommit


odbc_autocommit

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_autocommit -- Toggle autocommit behaviour

Description

bool odbc_autocommit ( resource connection_id [, bool OnOff])

Without the OnOff parameter, this function returns auto-commit status for connection_id. TRUE is returned if auto-commit is on, FALSE if it is off or an error occurs.

If OnOff is TRUE, auto-commit is enabled, if it is FALSE auto-commit is disabled. Returns TRUE on success, FALSE on failure.

By default, auto-commit is on for a connection. Disabling auto-commit is equivalent with starting a transaction.

See also odbc_commit() and odbc_rollback().

이전 | 처음으로 | 다음
Unified ODBC Functions | 위로 | odbc_binmode


odbc_binmode

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_binmode -- Handling of binary column data

Description

int odbc_binmode ( resource result_id, int mode)

(ODBC SQL types affected: BINARY, VARBINARY, LONGVARBINARY)

  • ODBC_BINMODE_PASSTHRU: Passthru BINARY data

  • ODBC_BINMODE_RETURN: Return as is

  • ODBC_BINMODE_CONVERT: Convert to char and return

When binary SQL data is converted to character C data, each byte (8 bits) of source data is represented as two ASCII characters. These characters are the ASCII character representation of the number in its hexadecimal form. For example, a binary 00000001 is converted to "01" and a binary 11111111 is converted to "FF".

표 1. LONGVARBINARY handling

binmode | longreadlen | result
ODBC_BINMODE_PASSTHRU | 0 | passthru
ODBC_BINMODE_RETURN | 0 | passthru
ODBC_BINMODE_CONVERT | 0 | passthru
ODBC_BINMODE_PASSTHRU | 0 | passthru
ODBC_BINMODE_PASSTHRU | >0 | passthru
ODBC_BINMODE_RETURN | >0 | return as is
ODBC_BINMODE_CONVERT | >0 | return as char

If odbc_fetch_into() is used, passthru means that an empty string is returned for these columns.

If result_id is 0, the settings apply as default for new results.

참고: Default for longreadlen is 4096 and binmode defaults to ODBC_BINMODE_RETURN. Handling of binary long columns is also affected by odbc_longreadlen()

이전 | 처음으로 | 다음
odbc_autocommit | 위로 | odbc_close_all


odbc_close_all

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_close_all -- Close all ODBC connections

Description

void odbc_close_all ( void )

odbc_close_all() will close down all connections to database server(s).

참고: This function will fail if there are open transactions on a connection. This connection will remain open in this case.

이전 | 처음으로 | 다음
odbc_binmode | 위로 | odbc_close


odbc_close

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_close -- Close an ODBC connection

Description

void odbc_close ( resource connection_id)

odbc_close() will close down the connection to the database server associated with the given connection identifier.

참고: This function will fail if there are open transactions on this connection. The connection will remain open in this case.

이전 | 처음으로 | 다음
odbc_close_all | 위로 | odbc_columnprivileges


odbc_columnprivileges

(PHP 4 , PHP 5)

odbc_columnprivileges -- Returns a result identifier that can be used to fetch a list of columns and associated privileges

Description

int odbc_columnprivileges ( resource connection_id [, string qualifier [, string owner [, string table_name [, string column_name]]]])

Lists columns and associated privileges for the given table. Returns an ODBC result identifier or FALSE on failure.

The result set has the following columns:

  • TABLE_QUALIFIER

  • TABLE_OWNER

  • TABLE_NAME

  • GRANTOR

  • GRANTEE

  • PRIVILEGE

  • IS_GRANTABLE

The result set is ordered by TABLE_QUALIFIER, TABLE_OWNER and TABLE_NAME.

The column_name argument accepts search patterns ('%' to match zero or more characters and '_' to match a single character).

이전 | 처음으로 | 다음
odbc_close | 위로 | odbc_columns


odbc_columns

(PHP 4 , PHP 5)

odbc_columns -- Lists the column names in specified tables. Returns a result identifier containing the information.

Description

resource odbc_columns ( resource connection_id [, string qualifier [, string schema [, string table_name [, string column_name]]]])

Lists all columns in the requested range. Returns an ODBC result identifier or FALSE on failure.

The result set has the following columns:

  • TABLE_QUALIFIER

  • TABLE_SCHEM

  • TABLE_NAME

  • COLUMN_NAME

  • DATA_TYPE

  • TYPE_NAME

  • PRECISION

  • LENGTH

  • SCALE

  • RADIX

  • NULLABLE

  • REMARKS

The result set is ordered by TABLE_QUALIFIER, TABLE_SCHEM and TABLE_NAME.

The schema, table_name and column_name arguments accept search patterns ('%' to match zero or more characters and '_' to match a single character).

See also odbc_columnprivileges() to retrieve associated privileges.

이전 | 처음으로 | 다음
odbc_columnprivileges | 위로 | odbc_commit


odbc_commit

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_commit -- Commit an ODBC transaction

Description

bool odbc_commit ( resource connection_id)

odbc_commit() commits all pending transactions on the connection_id connection. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
odbc_columns | 위로 | odbc_connect


odbc_connect

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_connect -- Connect to a datasource

Description

resource odbc_connect ( string dsn, string user, string password [, int cursor_type])

Returns an ODBC connection id or 0 (FALSE) on error.

The connection id returned by this functions is needed by other ODBC functions. You can have multiple connections open at once as long as they either use different db or different credentials. The optional fourth parameter sets the type of cursor to be used for this connection. This parameter is not normally needed, but can be useful for working around problems with some ODBC drivers.

With some ODBC drivers, executing a complex stored procedure may fail with an error similar to: "Cannot open a cursor on a stored procedure that has anything other than a single select statement in it". Using SQL_CUR_USE_ODBC may avoid that error. Also, some drivers don't support the optional row_number parameter in odbc_fetch_row(). SQL_CUR_USE_ODBC might help in that case, too.

The following constants are defined for cursortype:

  • SQL_CUR_USE_IF_NEEDED

  • SQL_CUR_USE_ODBC

  • SQL_CUR_USE_DRIVER

  • SQL_CUR_DEFAULT

For persistent connections see odbc_pconnect().

이전 | 처음으로 | 다음
odbc_commit | 위로 | odbc_cursor


odbc_cursor

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_cursor -- Get cursorname

Description

string odbc_cursor ( resource result_id)

odbc_cursor will return a cursorname for the given result_id.

이전 | 처음으로 | 다음
odbc_connect | 위로 | odbc_data_source


odbc_data_source

(PHP 4 >= 4.3.0, PHP 5)

odbc_data_source -- Returns information about a current connection

Description

resource odbc_data_source ( resource connection_id, constant fetch_type)

Returns FALSE on error, and an array upon success.

This function will return information about the active connection following the information from within the DSN. The connection_id is required to be a valid ODBC connection. The fetch_type can be one of two constant types: SQL_FETCH_FIRST, SQL_FETCH_NEXT. Use SQL_FETCH_FIRST the first time this function is called, thereafter use the SQL_FETCH_NEXT.

이전 | 처음으로 | 다음
odbc_cursor | 위로 | odbc_do


odbc_do

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_do -- Synonym for odbc_exec()

Description

resource odbc_do ( resource conn_id, string query)

odbc_do() will execute a query on the given connection.

이전 | 처음으로 | 다음
odbc_data_source | 위로 | odbc_error


odbc_error

(PHP 4 >= 4.0.5, PHP 5)

odbc_error -- Get the last error code

Description

string odbc_error ( [resource connection_id])

Returns a six-digit ODBC state, or an empty string if there has been no errors. If connection_id is specified, the last state of that connection is returned, else the last state of any connection is returned.

See also: odbc_errormsg() and odbc_exec().

이전 | 처음으로 | 다음
odbc_do | 위로 | odbc_errormsg


odbc_errormsg

(PHP 4 >= 4.0.5, PHP 5)

odbc_errormsg -- Get the last error message

Description

string odbc_errormsg ( [resource connection_id])

Returns a string containing the last ODBC error message, or an empty string if there has been no errors. If connection_id is specified, the last state of that connection is returned, else the last state of any connection is returned.

See also: odbc_error() and odbc_exec().

이전 | 처음으로 | 다음
odbc_error | 위로 | odbc_exec


odbc_exec

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_exec -- Prepare and execute a SQL statement

Description

resource odbc_exec ( resource connection_id, string query_string)

Returns FALSE on error. Returns an ODBC result identifier if the SQL command was executed successfully.

odbc_exec() will send an SQL statement to the database server specified by connection_id. This parameter must be a valid identifier returned by odbc_connect() or odbc_pconnect().

See also: odbc_prepare() and odbc_execute() for multiple execution of SQL statements.

이전 | 처음으로 | 다음
odbc_errormsg | 위로 | odbc_execute


odbc_execute

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_execute -- Execute a prepared statement

Description

bool odbc_execute ( resource result_id [, array parameters_array])

Executes a statement prepared with odbc_prepare().성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. The array parameters_array only needs to be given if you really have parameters in your statement.

Parameters in parameter_array will be substituted for placeholders in the prepared statement in order.

Any parameters in parameter_array which start and end with single quotes will be taken as the name of a file to read and send to the database server as the data for the appropriate placeholder.

참고: As of PHP 4.1.1, this file reading functionality has the following restrictions:

  • File reading is not subject to any 안전 모드 or open-basedir restrictions. This is fixed in PHP 4.2.0.

  • Remote files are not supported.

  • If you wish to store a string which actually begins and ends with single quotes, you must escape them or add a space or other non-single-quote character to the beginning or end of the parameter, which will prevent the parameter's being taken as a file name. If this is not an option, then you must use another mechanism to store the string, such as executing the query directly with odbc_exec()).

이전 | 처음으로 | 다음
odbc_exec | 위로 | odbc_fetch_array


odbc_fetch_array

(PHP 4 >= 4.0.2, PHP 5)

odbc_fetch_array -- Fetch a result row as an associative array

Description

array odbc_fetch_array ( resource result [, int rownumber])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
odbc_execute | 위로 | odbc_fetch_into


odbc_fetch_into

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_fetch_into -- Fetch one result row into array

Description

bool odbc_fetch_into ( resource result_id [, int rownumber, array result_array])

resource odbc_fetch_into ( resource result_id, array result_array [, int rownumber])

Returns the number of columns in the result; FALSE on error. result_array must be passed by reference, but it can be of any type since it will be converted to type array. The array will contain the column values starting at array index 0.

As of PHP 4.0.5 the result_array does not need to be passed by reference any longer.

As of PHP 4.0.6 the rownumber cannot be passed as a constant, but rather as a variable.

As of PHP 4.2.0 the result_array and rownumber have been swapped. This allows the rownumber to be a constant again. This change will also be the last one to this function.

예 1. odbc_fetch_into() pre 4.0.6 example

<?php
$rc = odbc_fetch_into($res_id, $my_array);
?>

or

<?php
$rc = odbc_fetch_into($res_id, $row, $my_array);

$rc = odbc_fetch_into($res_id, 1, $my_array);
?>

예 2. odbc_fetch_into() 4.0.6 example

<?php
$rc = odbc_fetch_into($res_id, $my_array);
?>

or

<?php
$row = 1;
$rc = odbc_fetch_into($res_id, $row, $my_array);
?>

예 3. odbc_fetch_into() 4.2.0 example

<?php
$rc = odbc_fetch_into($res_id, $my_array);
?>

or

<?php
$rc = odbc_fetch_into($res_id, $my_array, 2);
?>

이전 | 처음으로 | 다음
odbc_fetch_array | 위로 | odbc_fetch_object


odbc_fetch_object

(PHP 4 >= 4.0.2, PHP 5)

odbc_fetch_object -- Fetch a result row as an object

Description

object odbc_fetch_object ( resource result [, int rownumber])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
odbc_fetch_into | 위로 | odbc_fetch_row


odbc_fetch_row

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_fetch_row -- Fetch a row

Description

bool odbc_fetch_row ( resource result_id [, int row_number])

If odbc_fetch_row() was successful (there was a row), TRUE is returned. If there are no more rows, FALSE is returned.

odbc_fetch_row() fetches a row of the data that was returned by odbc_do() / odbc_exec(). After odbc_fetch_row() is called, the fields of that row can be accessed with odbc_result().

If row_number is not specified, odbc_fetch_row() will try to fetch the next row in the result set. Calls to odbc_fetch_row() with and without row_number can be mixed.

To step through the result more than once, you can call odbc_fetch_row() with row_number 1, and then continue doing odbc_fetch_row() without row_number to review the result. If a driver doesn't support fetching rows by number, the row_number parameter is ignored.

이전 | 처음으로 | 다음
odbc_fetch_object | 위로 | odbc_field_len


odbc_field_len

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_field_len -- Get the length (precision) of a field

Description

int odbc_field_len ( resource result_id, int field_number)

odbc_field_len() will return the length of the field referenced by number in the given ODBC result identifier. Field numbering starts at 1.

See also: odbc_field_scale() to get the scale of a floating point number.

이전 | 처음으로 | 다음
odbc_fetch_row | 위로 | odbc_field_name


odbc_field_name

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_field_name -- Get the columnname

Description

string odbc_field_name ( resource result_id, int field_number)

odbc_field_name() will return the name of the field occupying the given column number in the given ODBC result identifier. Field numbering starts at 1. FALSE is returned on error.

이전 | 처음으로 | 다음
odbc_field_len | 위로 | odbc_field_num


odbc_field_num

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_field_num -- Return column number

Description

int odbc_field_num ( resource result_id, string field_name)

odbc_field_num() will return the number of the column slot that corresponds to the named field in the given ODBC result identifier. Field numbering starts at 1. FALSE is returned on error.

이전 | 처음으로 | 다음
odbc_field_name | 위로 | odbc_field_precision


odbc_field_precision

(PHP 4 , PHP 5)

odbc_field_precision -- Synonym for odbc_field_len()

Description

string odbc_field_precision ( resource result_id, int field_number)

odbc_field_precision() will return the precision of the field referenced by number in the given ODBC result identifier.

See also: odbc_field_scale() to get the scale of a floating point number.

이전 | 처음으로 | 다음
odbc_field_num | 위로 | odbc_field_scale


odbc_field_scale

(PHP 4 , PHP 5)

odbc_field_scale -- Get the scale of a field

Description

string odbc_field_scale ( resource result_id, int field_number)

odbc_field_precision() will return the scale of the field referenced by number in the given ODBC result identifier.

이전 | 처음으로 | 다음
odbc_field_precision | 위로 | odbc_field_type


odbc_field_type

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_field_type -- Datatype of a field

Description

string odbc_field_type ( resource result_id, int field_number)

odbc_field_type() will return the SQL type of the field referenced by number in the given ODBC result identifier. Field numbering starts at 1.

이전 | 처음으로 | 다음
odbc_field_scale | 위로 | odbc_foreignkeys


odbc_foreignkeys

(PHP 4 , PHP 5)

odbc_foreignkeys -- Returns a list of foreign keys in the specified table or a list of foreign keys in other tables that refer to the primary key in the specified table

Description

resource odbc_foreignkeys ( resource connection_id, string pk_qualifier, string pk_owner, string pk_table, string fk_qualifier, string fk_owner, string fk_table)

odbc_foreignkeys() retrieves information about foreign keys. Returns an ODBC result identifier or FALSE on failure.

The result set has the following columns:

  • PKTABLE_QUALIFIER

  • PKTABLE_OWNER

  • PKTABLE_NAME

  • PKCOLUMN_NAME

  • FKTABLE_QUALIFIER

  • FKTABLE_OWNER

  • FKTABLE_NAME

  • FKCOLUMN_NAME

  • KEY_SEQ

  • UPDATE_RULE

  • DELETE_RULE

  • FK_NAME

  • PK_NAME

If pk_table contains a table name, odbc_foreignkeys() returns a result set containing the primary key of the specified table and all of the foreign keys that refer to it.

If fk_table contains a table name, odbc_foreignkeys() returns a result set containing all of the foreign keys in the specified table and the primary keys (in other tables) to which they refer.

If both pk_table and fk_table contain table names, odbc_foreignkeys() returns the foreign keys in the table specified in fk_table that refer to the primary key of the table specified in pk_table. This should be one key at most.

이전 | 처음으로 | 다음
odbc_field_type | 위로 | odbc_free_result


odbc_free_result

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_free_result -- Free resources associated with a result

Description

bool odbc_free_result ( resource result_id)

Always returns TRUE.

odbc_free_result() only needs to be called if you are worried about using too much memory while your script is running. All result memory will automatically be freed when the script is finished. But, if you are sure you are not going to need the result data anymore in a script, you may call odbc_free_result(), and the memory associated with result_id will be freed.

참고: If auto-commit is disabled (see odbc_autocommit()) and you call odbc_free_result() before committing, all pending transactions are rolled back.

이전 | 처음으로 | 다음
odbc_foreignkeys | 위로 | odbc_gettypeinfo


odbc_gettypeinfo

(PHP 4 , PHP 5)

odbc_gettypeinfo -- Returns a result identifier containing information about data types supported by the data source.

Description

int odbc_gettypeinfo ( resource connection_id [, int data_type])

Retrieves information about data types supported by the data source. Returns an ODBC result identifier or FALSE on failure. The optional argument data_type can be used to restrict the information to a single data type.

The result set has the following columns:

  • TYPE_NAME

  • DATA_TYPE

  • PRECISION

  • LITERAL_PREFIX

  • LITERAL_SUFFIX

  • CREATE_PARAMS

  • NULLABLE

  • CASE_SENSITIVE

  • SEARCHABLE

  • UNSIGNED_ATTRIBUTE

  • MONEY

  • AUTO_INCREMENT

  • LOCAL_TYPE_NAME

  • MINIMUM_SCALE

  • MAXIMUM_SCALE

The result set is ordered by DATA_TYPE and TYPE_NAME.

이전 | 처음으로 | 다음
odbc_free_result | 위로 | odbc_longreadlen


odbc_longreadlen

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_longreadlen -- Handling of LONG columns

Description

int odbc_longreadlen ( resource result_id, int length)

(ODBC SQL types affected: LONG, LONGVARBINARY) The number of bytes returned to PHP is controlled by the parameter length. If it is set to 0, Long column data is passed through to the client.

참고: Handling of LONGVARBINARY columns is also affected by odbc_binmode().

이전 | 처음으로 | 다음
odbc_gettypeinfo | 위로 | odbc_next_result


odbc_next_result

(PHP 4 >= 4.0.5, PHP 5)

odbc_next_result -- Checks if multiple results are available

Description

bool odbc_next_result ( resource result_id)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
odbc_longreadlen | 위로 | odbc_num_fields


odbc_num_fields

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_num_fields -- Number of columns in a result

Description

int odbc_num_fields ( resource result_id)

odbc_num_fields() will return the number of fields (columns) in an ODBC result. This function will return -1 on error. The argument is a valid result identifier returned by odbc_exec().

이전 | 처음으로 | 다음
odbc_next_result | 위로 | odbc_num_rows


odbc_num_rows

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_num_rows -- Number of rows in a result

Description

int odbc_num_rows ( resource result_id)

odbc_num_rows() will return the number of rows in an ODBC result. This function will return -1 on error. For INSERT, UPDATE and DELETE statements odbc_num_rows() returns the number of rows affected. For a SELECT clause this can be the number of rows available.

Note: Using odbc_num_rows() to determine the number of rows available after a SELECT will return -1 with many drivers.

이전 | 처음으로 | 다음
odbc_num_fields | 위로 | odbc_pconnect


odbc_pconnect

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_pconnect -- Open a persistent database connection

Description

resource odbc_pconnect ( string dsn, string user, string password [, int cursor_type])

Returns an ODBC connection id or 0 (FALSE) on error. This function is much like odbc_connect(), except that the connection is not really closed when the script has finished. Future requests for a connection with the same dsn, user, password combination (via odbc_connect() and odbc_pconnect()) can reuse the persistent connection.

참고: Persistent connections have no effect if PHP is used as a CGI program.

For information about the optional cursor_type parameter see the odbc_connect() function. For more information on persistent connections, refer to the PHP FAQ.

이전 | 처음으로 | 다음
odbc_num_rows | 위로 | odbc_prepare


odbc_prepare

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_prepare -- Prepares a statement for execution

Description

resource odbc_prepare ( resource connection_id, string query_string)

Returns FALSE on error.

Returns an ODBC result identifier if the SQL command was prepared successfully. The result identifier can be used later to execute the statement with odbc_execute().

이전 | 처음으로 | 다음
odbc_pconnect | 위로 | odbc_primarykeys


odbc_primarykeys

(PHP 4 , PHP 5)

odbc_primarykeys -- Returns a result identifier that can be used to fetch the column names that comprise the primary key for a table

Description

resource odbc_primarykeys ( resource connection_id, string qualifier, string owner, string table)

Returns the column names that comprise the primary key for a table. Returns an ODBC result identifier or FALSE on failure.

The result set has the following columns:

  • TABLE_QUALIFIER

  • TABLE_OWNER

  • TABLE_NAME

  • COLUMN_NAME

  • KEY_SEQ

  • PK_NAME

이전 | 처음으로 | 다음
odbc_prepare | 위로 | odbc_procedurecolumns


odbc_procedurecolumns

(PHP 4 , PHP 5)

odbc_procedurecolumns -- Retrieve information about parameters to procedures

Description

resource odbc_procedurecolumns ( resource connection_id [, string qualifier [, string owner [, string proc [, string column]]]])

Returns the list of input and output parameters, as well as the columns that make up the result set for the specified procedures. Returns an ODBC result identifier or FALSE on failure.

The result set has the following columns:

  • PROCEDURE_QUALIFIER

  • PROCEDURE_OWNER

  • PROCEDURE_NAME

  • COLUMN_NAME

  • COLUMN_TYPE

  • DATA_TYPE

  • TYPE_NAME

  • PRECISION

  • LENGTH

  • SCALE

  • RADIX

  • NULLABLE

  • REMARKS

The result set is ordered by PROCEDURE_QUALIFIER, PROCEDURE_OWNER, PROCEDURE_NAME and COLUMN_TYPE.

The owner, proc and column arguments accept search patterns ('%' to match zero or more characters and '_' to match a single character).

이전 | 처음으로 | 다음
odbc_primarykeys | 위로 | odbc_procedures


odbc_procedures

(PHP 4 , PHP 5)

odbc_procedures -- Get the list of procedures stored in a specific data source. Returns a result identifier containing the information.

Description

resource odbc_procedures ( resource connection_id [, string qualifier [, string owner [, string name]]])

Lists all procedures in the requested range. Returns an ODBC result identifier or FALSE on failure.

The result set has the following columns:

  • PROCEDURE_QUALIFIER

  • PROCEDURE_OWNER

  • PROCEDURE_NAME

  • NUM_INPUT_PARAMS

  • NUM_OUTPUT_PARAMS

  • NUM_RESULT_SETS

  • REMARKS

  • PROCEDURE_TYPE

The owner and name arguments accept search patterns ('%' to match zero or more characters and '_' to match a single character).

이전 | 처음으로 | 다음
odbc_procedurecolumns | 위로 | odbc_result_all


odbc_result_all

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_result_all -- Print result as HTML table

Description

int odbc_result_all ( resource result_id [, string format])

Returns the number of rows in the result or FALSE on error.

odbc_result_all() will print all rows from a result identifier produced by odbc_exec(). The result is printed in HTML table format. With the optional string argument format, additional overall table formatting can be done.

이전 | 처음으로 | 다음
odbc_procedures | 위로 | odbc_result


odbc_result

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_result -- Get result data

Description

string odbc_result ( resource result_id, mixed field)

Returns the contents of the field.

field can either be an integer containing the column number of the field you want; or it can be a string containing the name of the field. For example:

$item_3 = odbc_result($Query_ID, 3);
$item_val = odbc_result($Query_ID, "val");

The first call to odbc_result() returns the value of the third field in the current record of the query result. The second function call to odbc_result() returns the value of the field whose field name is "val" in the current record of the query result. An error occurs if a column number parameter for a field is less than one or exceeds the number of columns (or fields) in the current record. Similarly, an error occurs if a field with a name that is not one of the fieldnames of the table(s) that is(are) being queried.

Field indices start from 1. Regarding the way binary or long column data is returned refer to odbc_binmode() and odbc_longreadlen().

이전 | 처음으로 | 다음
odbc_result_all | 위로 | odbc_rollback


odbc_rollback

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_rollback -- Rollback a transaction

Description

int odbc_rollback ( resource connection_id)

Rolls back all pending statements on connection_id. Returns TRUE on success, FALSE on failure.

이전 | 처음으로 | 다음
odbc_result | 위로 | odbc_setoption


odbc_setoption

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

odbc_setoption -- Adjust ODBC settings. Returns FALSE if an error occurs, otherwise TRUE.

Description

int odbc_setoption ( resource id, int function, int option, int param)

This function allows fiddling with the ODBC options for a particular connection or query result. It was written to help find work around to problems in quirky ODBC drivers. You should probably only use this function if you are an ODBC programmer and understand the effects the various options will have. You will certainly need a good ODBC reference to explain all the different options and values that can be used. Different driver versions support different options.

Because the effects may vary depending on the ODBC driver, use of this function in scripts to be made publicly available is strongly discouraged. Also, some ODBC options are not available to this function because they must be set before the connection is established or the query is prepared. However, if on a particular job it can make PHP work so your boss doesn't tell you to use a commercial product, that's all that really matters.

id is a connection id or result id on which to change the settings.For SQLSetConnectOption(), this is a connection id. For SQLSetStmtOption(), this is a result id.

Function is the ODBC function to use. The value should be 1 for SQLSetConnectOption() and 2 for SQLSetStmtOption().

Parameter option is the option to set.

Parameter param is the value for the given option.

예 1. ODBC Setoption Examples

<?php
// 1. Option 102 of SQLSetConnectOption() is SQL_AUTOCOMMIT.
//    Value 1 of SQL_AUTOCOMMIT is SQL_AUTOCOMMIT_ON.
//    This example has the same effect as
//    odbc_autocommit($conn, true);

odbc_setoption($conn, 1, 102, 1);

// 2. Option 0 of SQLSetStmtOption() is SQL_QUERY_TIMEOUT.
//    This example sets the query to timeout after 30 seconds.

$result = odbc_prepare($conn, $sql);
odbc_setoption($result, 2, 0, 30);
odbc_execute($result);
?>

이전 | 처음으로 | 다음
odbc_rollback | 위로 | odbc_specialcolumns


odbc_specialcolumns

(PHP 4 , PHP 5)

odbc_specialcolumns -- Returns either the optimal set of columns that uniquely identifies a row in the table or columns that are automatically updated when any value in the row is updated by a transaction

Description

resource odbc_specialcolumns ( resource connection_id, int type, string qualifier, string owner, string table, int scope, int nullable)

When the type argument is SQL_BEST_ROWID, odbc_specialcolumns() returns the column or columns that uniquely identify each row in the table.

When the type argument is SQL_ROWVER, odbc_specialcolumns() returns the optimal column or set of columns that, by retrieving values from the column or columns, allows any row in the specified table to be uniquely identified.

Returns an ODBC result identifier or FALSE on failure.

The result set has the following columns:

  • SCOPE

  • COLUMN_NAME

  • DATA_TYPE

  • TYPE_NAME

  • PRECISION

  • LENGTH

  • SCALE

  • PSEUDO_COLUMN

The result set is ordered by SCOPE.

이전 | 처음으로 | 다음
odbc_setoption | 위로 | odbc_statistics


odbc_statistics

(PHP 4 , PHP 5)

odbc_statistics -- Retrieve statistics about a table

Description

resource odbc_statistics ( resource connection_id, string qualifier, string owner, string table_name, int unique, int accuracy)

Get statistics about a table and its indexes. Returns an ODBC result identifier or FALSE on failure.

The result set has the following columns:

  • TABLE_QUALIFIER

  • TABLE_OWNER

  • TABLE_NAME

  • NON_UNIQUE

  • INDEX_QUALIFIER

  • INDEX_NAME

  • TYPE

  • SEQ_IN_INDEX

  • COLUMN_NAME

  • COLLATION

  • CARDINALITY

  • PAGES

  • FILTER_CONDITION

The result set is ordered by NON_UNIQUE, TYPE, INDEX_QUALIFIER, INDEX_NAME and SEQ_IN_INDEX.

이전 | 처음으로 | 다음
odbc_specialcolumns | 위로 | odbc_tableprivileges


odbc_tableprivileges

(PHP 4 , PHP 5)

odbc_tableprivileges -- Lists tables and the privileges associated with each table

Description

int odbc_tableprivileges ( resource connection_id [, string qualifier [, string owner [, string name]]])

Lists tables in the requested range and the privileges associated with each table. Returns an ODBC result identifier or FALSE on failure.

The result set has the following columns:

  • TABLE_QUALIFIER

  • TABLE_OWNER

  • TABLE_NAME

  • GRANTOR

  • GRANTEE

  • PRIVILEGE

  • IS_GRANTABLE

The result set is ordered by TABLE_QUALIFIER, TABLE_OWNER and TABLE_NAME.

The owner and name arguments accept search patterns ('%' to match zero or more characters and '_' to match a single character).

이전 | 처음으로 | 다음
odbc_statistics | 위로 | odbc_tables


odbc_tables

(PHP 3>= 3.0.17, PHP 4 , PHP 5)

odbc_tables -- Get the list of table names stored in a specific data source. Returns a result identifier containing the information.

Description

int odbc_tables ( resource connection_id [, string qualifier [, string owner [, string name [, string types]]]])

Lists all tables in the requested range. Returns an ODBC result identifier or FALSE on failure.

The result set has the following columns:

  • TABLE_QUALIFIER

  • TABLE_OWNER

  • TABLE_NAME

  • TABLE_TYPE

  • REMARKS

The result set is ordered by TABLE_TYPE, TABLE_QUALIFIER, TABLE_OWNER and TABLE_NAME.

The owner and name arguments accept search patterns ('%' to match zero or more characters and '_' to match a single character).

To support enumeration of qualifiers, owners, and table types, the following special semantics for the qualifier, owner, name, and table_type are available:

  • If qualifier is a single percent character (%) and owner and name are empty strings, then the result set contains a list of valid qualifiers for the data source. (All columns except the TABLE_QUALIFIER column contain NULLs.)

  • If owner is a single percent character (%) and qualifier and name are empty strings, then the result set contains a list of valid owners for the data source. (All columns except the TABLE_OWNER column contain NULLs.)

  • If table_type is a single percent character (%) and qualifier, owner and name are empty strings, then the result set contains a list of valid table types for the data source. (All columns except the TABLE_TYPE column contain NULLs.)

If table_type is not an empty string, it must contain a list of comma-separated values for the types of interest; each value may be enclosed in single quotes (') or unquoted. For example, "'TABLE','VIEW'" or "TABLE, VIEW". If the data source does not support a specified table type, odbc_tables() does not return any results for that type.

See also odbc_tableprivileges() to retrieve associated privileges.

이전 | 처음으로 | 다음
odbc_tableprivileges | 위로 | Object Aggregation/Composition Functions


Object Aggregation/Composition Functions

PHP 매뉴얼
이전 다음

LXXIII. Object Aggregation/Composition Functions

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

소개

In Object Oriented Programming, it is common to see the composition of simple classes (and/or instances) into a more complex one. This is a flexible strategy for building complicated objects and object hierarchies and can function as a dynamic alternative to multiple inheritance. There are two ways to perform class (and/or object) composition depending on the relationship between the composed elements: Association and Aggregation.

An Association is a composition of independently constructed and externally visible parts. When we associate classes or objects, each one keeps a reference to the ones it is associated with. When we associate classes statically, one class will contain a reference to an instance of the other class. For example:

예 1. Class association

<?php
class DateTime {

   function DateTime()
   {
       // empty constructor
   }

   function now()
   {
       return date("Y-m-d H:i:s");
   }
}

class Report {
   var $_dt;
   // more properties ...

   function Report()
   {
       $this->_dt = new DateTime();
       // initialization code ...
   }

   function generateReport()
   {
       $dateTime = $_dt->now();
       // more code ...
   }

   // more methods ...
}

$rep = new Report();
?>
We can also associate instances at runtime by passing a reference in a constructor (or any other method), which allow us to dynamically change the association relationship between objects. We will modify the example above to illustrate this point:

예 2. Object association

<?php
class DateTime {
   // same as previous example
}

class DateTimePlus {
   var $_format;

   function DateTimePlus($format="Y-m-d H:i:s")
   {
       $this->_format = $format;
   }

   function now()
   {
       return date($this->_format);
   }
}

class Report {
   var $_dt;    // we'll keep the reference to DateTime here
   // more properties ...

   function Report()
   {
       // do some initialization
   }

   function setDateTime(&$dt)
   {
       $this->_dt =& $dt;
   }

   function generateReport()
   {
       $dateTime = $this->_dt->now();
       // more code ...
   }

   // more methods ...
}

$rep = new Report();
$dt = new DateTime();
$dtp = new DateTimePlus("l, F j, Y (h:i:s a, T)");

// generate report with simple date for web display
$rep->setDateTime(&$dt);
echo $rep->generateReport();

// later on in the code ...

// generate report with fancy date
$rep->setDateTime(&$dtp);
$output = $rep->generateReport();
// save $output in database
// ... etc ...
?>

Aggregation, on the other hand, implies encapsulation (hidding) of the parts of the composition. We can aggregate classes by using a (static) inner class (PHP does not yet support inner classes), in this case the aggregated class definition is not accessible, except through the class that contains it. The aggregation of instances (object aggregation) involves the dynamic creation of subobjects inside an object, in the process, expanding the properties and methods of that object.

Object aggregation is a natural way of representing a whole-part relationship, (for example, molecules are aggregates of atoms), or can be used to obtain an effect equivalent to multiple inheritance, without having to permanently bind a subclass to two or more parent classes and their interfaces. In fact object aggregation can be more flexible, in which we can select what methods or properties to "inherit" in the aggregated object.

예제

We define 3 classes, each implementing a different storage method:

예 3. storage_classes.inc

<?php
class FileStorage {
    var $data;

    function FileStorage($data)
    {
        $this->data = $data;
    }

    function write($name)
    {
        $fp = fopen(name, "w");
        fwrite($fp, $this->data);
        fclose($data);
    }
}

class WDDXStorage {
    var $data;
    var $version = "1.0";
    var $_id; // "private" variable

    function WDDXStorage($data)
    {
        $this->data = $data;
        $this->_id = $this->_genID();
    }

    function store()
    {
        if ($this->_id) {
            $pid = wddx_packet_start($this->_id);
            wddx_add_vars($pid, "this->data");
            $packet = wddx_packet_end($pid);
        } else {
            $packet = wddx_serialize_value($this->data);
        }
        $dbh = dba_open("varstore", "w", "gdbm");
        dba_insert(md5(uniqid("", true)), $packet, $dbh);
        dba_close($dbh);
    }

    // a private method
    function _genID()
    {
        return md5(uniqid(rand(), true));
    }
}

class DBStorage {
    var $data;
    var $dbtype = "mysql";

    function DBStorage($data)
    {
        $this->data = $data;
    }

    function save()
    {
        $dbh = mysql_connect();
        mysql_select_db("storage", $dbh);
        $serdata = serialize($this->data);
        mysql_query("insert into vars ('$serdata',now())", $dbh);
        mysql_close($dbh);
    }
}

?>

We then instantiate a couple of objects from the defined classes, and perform some aggregations and deaggregations, printing some object information along the way:

예 4. test_aggregation.php

<?php
include "storageclasses.inc";

// some utilty functions

function p_arr($arr)
{
    foreach ($arr as $k => $v)
        $out[] = "\t$k => $v";
    return implode("\n", $out);
}

function object_info($obj)
{
    $out[] = "Class: " . get_class($obj);
    foreach (get_object_vars($obj) as $var=>$val) {
        if (is_array($val)) {
            $out[] = "property: $var (array)\n" . p_arr($val);
        } else {
            $out[] = "property: $var = $val";
        }
    }
    foreach (get_class_methods($obj) as $method) {
        $out[] = "method: $method";
    }
    return implode("\n", $out);
}

$data = array(M_PI, "kludge != cruft");

// we create some basic objects
$fs = new FileStorage($data);
$ws = new WDDXStorage($data);

// print information on the objects
echo "\$fs object\n";
echo object_info($fs) . "\n";
echo "\n\$ws object\n";
echo object_info($ws) . "\n";

// do some aggregation

echo "\nLet's aggregate \$fs to the WDDXStorage class\n";
aggregate($fs, "WDDXStorage");
echo "\$fs object\n";
echo object_info($fs) . "\n";

echo "\nNow let us aggregate it to the DBStorage class\n";
aggregate($fs, "DBStorage");
echo "\$fs object\n";
echo object_info($fs) . "\n";

echo "\nAnd finally deaggregate WDDXStorage\n";
deaggregate($fs, "WDDXStorage");
echo "\$fs object\n";
echo object_info($fs) . "\n";

?>

We will now consider the output to understand some of the side-effects and limitation of object aggregation in PHP. First, the newly created $fs and $ws objects give the expected output (according to their respective class declaration). Note that for the purposes of object aggregation, private elements of a class/object begin with an underscore character ("_"), even though there is not real distinction between public and private class/object elements in PHP.

$fs object
Class: filestorage
property: data (array)
    0 => 3.1415926535898
    1 => kludge != cruft
method: filestorage
method: write

$ws object
Class: wddxstorage
property: data (array)
    0 => 3.1415926535898
    1 => kludge != cruft
property: version = 1.0
property: _id = ID::9bb2b640764d4370eb04808af8b076a5
method: wddxstorage
method: store
method: _genid

We then aggregate $fs with the WDDXStorage class, and print out the object information. We can see now that even though nominally the $fs object is still of FileStorage, it now has the property $version, and the method store(), both defined in WDDXStorage. One important thing to note is that it has not aggregated the private elements defined in the class, which are present in the $ws object. Also absent is the constructor from WDDXStorage, which will not be logical to aggegate.

Let's aggregate $fs to the WDDXStorage class
$fs object
Class: filestorage
property: data (array)
    0 => 3.1415926535898
    1 => kludge != cruft
property: version = 1.0
method: filestorage
method: write
method: store

The proccess of aggregation is cummulative, so when we aggregate $fs with the class DBStorage, generating an object that can use the storage methods of all the defined classes.

Now let us aggregate it to the DBStorage class
$fs object
Class: filestorage
property: data (array)
    0 => 3.1415926535898
    1 => kludge != cruft
property: version = 1.0
property: dbtype = mysql
method: filestorage
method: write
method: store
method: save

Finally, the same way we aggregated properties and methods dynamically, we can also deaggregate them from the object. So, if we deaggregate the class WDDXStorage from $fs, we will obtain:

And deaggregate the WDDXStorage methods and properties
$fs object
Class: filestorage
property: data (array)
    0 => 3.1415926535898
    1 => kludge != cruft
property: dbtype = mysql
method: filestorage
method: write
method: save

One point that we have not mentioned above, is that the process of aggregation will not override existing properties or methods in the objects. For example, the class FileStorage defines a $data property, and the class WDDXStorage also defines a similar property which will not override the one in the object acquired during instantiation from the class FileStorage.

차례
aggregate_info -- Returns an associative array of the methods and properties from each class that has been aggregated to the object.
aggregate_methods_by_list -- Selective dynamic class methods aggregation to an object
aggregate_methods_by_regexp -- Selective class methods aggregation to an object using a regular expression
aggregate_methods -- Dynamic class and object aggregation of methods
aggregate_properties_by_list -- Selective dynamic class properties aggregation to an object
aggregate_properties_by_regexp -- Selective class properties aggregation to an object using a regular expression
aggregate_properties -- Dynamic aggregation of class properties to an object
aggregate -- Dynamic class and object aggregation of methods and properties
aggregation_info -- Alias of aggregate_info()
deaggregate -- Removes the aggregated methods and properties from an object

이전 | 처음으로 | 다음
odbc_tables | 위로 | aggregate_info


aggregate_info

(no version information, might be only in CVS)

aggregate_info -- Returns an associative array of the methods and properties from each class that has been aggregated to the object.

Description

array aggregate_info ( object object)

Will return the aggregation information for a particular object as an associative array of arrays of methods and properties. The key for the main array is the name of the aggregated class.

For example the code below

예 1. Using aggregate_info()

<?php

class Slicer {
    var $vegetable;

    function Slicer($vegetable)
    {
        $this->vegetable = $vegetable;
    }

    function slice_it($num_cuts)
    {
        echo "Doing some simple slicing\n";
        for ($i=0; $i < $num_cuts; $i++) {
            // do some slicing
        }
    }
}

class Dicer {
    var $vegetable;
    var $rotation_angle = 90;   // degrees

    function Dicer($vegetable)
    {
        $this->vegetable = $vegetable;
    }

    function dice_it($num_cuts)
    {
        echo "Cutting in one direction\n";
        for ($i=0; $i < $num_cuts; $i++) {
            // do some cutting
        }
        $this->rotate($this->rotation_angle);
        echo "Cutting in a second direction\n";
        for ($i=0; $i < $num_cuts; $i++) {
            // do some more cutting
        }
    }

    function rotate($deg)
    {
        echo "Now rotating {$this->vegetable} {$deg} degrees\n";
    }

    function _secret_super_dicing($num_cuts)
    {
        // so secret we cannot show you ;-)
    }
}

$obj = new Slicer('onion');
aggregate($obj, 'Dicer');
print_r(aggregate_info($obj));
?>

Will produce the output

Array
(
    [dicer] => Array
        (
            [methods] => Array
                (
                    [0] => dice_it
                    [1] => rotate
                )

            [properties] => Array
                (
                    [0] => rotation_angle
                )

        )

)
As you can see, all properties and methods of the Dicer class have been aggregated into our new object, with the exception of the class constructor and the method _secret_super_dicing

See also
aggregate(),
aggregate_methods(),
aggregate_methods_by_list(),
aggregate_methods_by_regexp(),
aggregate_properties(),
aggregate_properties_by_list(),
aggregate_properties_by_regexp(),
deaggregate()

이전 | 처음으로 | 다음
Object Aggregation/Composition Functions | 위로 | aggregate_methods_by_list


aggregate_methods_by_list

(PHP 4 >= 4.2.0)

aggregate_methods_by_list -- Selective dynamic class methods aggregation to an object

Description

void aggregate_methods_by_list ( object object, string class_name, array methods_list [, bool exclude])

Aggregates methods from a class to an existing object using a list of method names. The optional paramater exclude is used to decide whether the list contains the names of methods to include in the aggregation (i.e. exclude is FALSE, which is the default value), or to exclude from the aggregation (exclude is TRUE).

The class constructor or methods whose names start with an underscore character (_), which are considered private to the aggregated class, are always excluded.

See also
aggregate(),
aggregate_info(),
aggregate_methods(),
aggregate_methods_by_regexp(),
aggregate_properties(),
aggregate_properties_by_list(),
aggregate_properties_by_regexp(),
deaggregate()

이전 | 처음으로 | 다음
aggregate_info | 위로 | aggregate_methods_by_regexp


aggregate_methods_by_regexp

(PHP 4 >= 4.2.0)

aggregate_methods_by_regexp -- Selective class methods aggregation to an object using a regular expression

Description

void aggregate_methods_by_regexp ( object object, string class_name, string regexp [, bool exclude])

Aggregates methods from a class to an existing object using a regular expresion to match method names. The optional paramater exclude is used to decide whether the regular expression will select the names of methods to include in the aggregation (i.e. exclude is FALSE, which is the default value), or to exclude from the aggregation (exclude is TRUE).

The class constructor or methods whose names start with an underscore character (_), which are considered private to the aggregated class, are always excluded.

See also
aggregate(),
aggregate_info(),
aggregate_methods(),
aggregate_methods_by_list(),
aggregate_properties(),
aggregate_properties_by_list(),
aggregate_properties_by_regexp(),
deaggregate()

이전 | 처음으로 | 다음
aggregate_methods_by_list | 위로 | aggregate_methods


aggregate_methods

(PHP 4 >= 4.2.0)

aggregate_methods -- Dynamic class and object aggregation of methods

Description

void aggregate_methods ( object object, string class_name)

Aggregates all methods defined in a class to an existing object, except for the class constructor, or methods whose names start with an underscore character (_) which are considered private to the aggregated class.

See also
aggregate(),
aggregate_info(),
aggregate_methods_by_list(),
aggregate_methods_by_regexp(),
aggregate_properties(),
aggregate_properties_by_list(),
aggregate_properties_by_regexp(),
deaggregate()

이전 | 처음으로 | 다음
aggregate_methods_by_regexp | 위로 | aggregate_properties_by_list


aggregate_properties_by_list

(PHP 4 >= 4.2.0)

aggregate_properties_by_list -- Selective dynamic class properties aggregation to an object

Description

void aggregate_properties_by_list ( object object, string class_name, array properties_list [, bool exclude])

Aggregates properties from a class to an existing object using a list of property names. The optional paramater exclude is used to decide whether the list contains the names of class properties to include in the aggregation (i.e. exclude is FALSE, which is the default value), or to exclude from the aggregation (exclude is TRUE).

The properties whose names start with an underscore character (_), which are considered private to the aggregated class, are always excluded.

See also
aggregate(),
aggregate_methods(),
aggregate_methods_by_list(),
aggregate_methods_by_regexp(),
aggregate_properties(),
aggregate_properties_by_regexp(),
aggregate_info(),
deaggregate()

이전 | 처음으로 | 다음
aggregate_methods | 위로 | aggregate_properties_by_regexp


aggregate_properties_by_regexp

(PHP 4 >= 4.2.0)

aggregate_properties_by_regexp -- Selective class properties aggregation to an object using a regular expression

Description

void aggregate_properties_by_regexp ( object object, string class_name, string regexp [, bool exclude])

Aggregates properties from a class to an existing object using a regular expresion to match their names. The optional paramater exclude is used to decide whether the regular expression will select the names of class properties to include in the aggregation (i.e. exclude is FALSE, which is the default value), or to exclude from the aggregation (exclude is TRUE).

The properties whose names start with an underscore character (_), which are considered private to the aggregated class, are always excluded.

See also
aggregate(),
aggregate_methods(),
aggregate_methods_by_list(),
aggregate_methods_by_regexp(),
aggregate_properties(),
aggregate_properties_by_list(),
aggregate_info(),
deaggregate()

이전 | 처음으로 | 다음
aggregate_properties_by_list | 위로 | aggregate_properties


aggregate_properties

(PHP 4 >= 4.2.0)

aggregate_properties -- Dynamic aggregation of class properties to an object

Description

void aggregate_properties ( object object, string class_name)

Aggregates all properties defined in a class to an existing object, except for properties whose names start with an underscore character (_) which are considered private to the aggregated class.

See also
aggregate(),
aggregate_methods(),
aggregate_methods_by_list(),
aggregate_methods_by_regexp(),
aggregate_properties_by_list(),
aggregate_properties_by_regexp(),
aggregate_info(),
deaggregate()

이전 | 처음으로 | 다음
aggregate_properties_by_regexp | 위로 | aggregate


aggregate

(PHP 4 >= 4.2.0)

aggregate -- Dynamic class and object aggregation of methods and properties

Description

void aggregate ( object object, string class_name)

Aggregates methods and properties defined in a class to an existing object. Methods and properties with names starting with an underscore character (_) are considered private to the aggregated class and are not used, constructors are also excluded from the aggregation procedure.

See also
aggregate_info(),
aggregate_methods(),
aggregate_methods_by_list(),
aggregate_methods_by_regexp(),
aggregate_properties(),
aggregate_properties_by_list(),
aggregate_properties_by_regexp(),
deaggregate()

이전 | 처음으로 | 다음
aggregate_properties | 위로 | aggregation_info


aggregation_info

aggregation_info -- Alias of aggregate_info()

Description

This function is an alias of aggregate_info().

이전 | 처음으로 | 다음
aggregate | 위로 | deaggregate


deaggregate

(PHP 4 >= 4.2.0)

deaggregate -- Removes the aggregated methods and properties from an object

Description

void deaggregate ( object object [, string class_name])

Removes the methods and properties from classes that were aggregated to an object. If the optional class_name parameters is passed, only those methods and properties defined in that class are removed, otherwise all aggregated methods and properties are eliminated.

See also
aggregate(),
aggregate_methods(),
aggregate_methods_by_list(),
aggregate_methods_by_regexp(),
aggregate_properties(),
aggregate_properties_by_list(),
aggregate_properties_by_regexp(),
aggregate_info()

이전 | 처음으로 | 다음
aggregation_info | 위로 | 오라클 8 함수


오라클 8 함수

PHP 매뉴얼
이전 다음

LXXIV. 오라클 8 함수

이 함수들을 통해 오라클 8과 오라클 7 데이터베이스를 연동하여 사용한다. Oracle8 Call-Interface (OCI8)를 사용하며, 이 함수들을 사용하려면 오라클8 클라이언트 라이브러리(Oracle8 client libraries)가 필요하다.

이 함수는 표준 오라클 함수보다 유연하다. PHP의 전역 변수와 지역 변수들의 오라클 위치보유자(Oracle placeholder) 로의 연계(binding), full LOB, FILE, ROWID를 지원하며, user-supplied define variable을 사용할 수 있도록 해 준다.

이 함수를 사용하기 전에 오라클 계정과 웹 데몬 계정에 유효한 오라클 환경변수를 적용했는지 확인해야한다. 적용시킬 환경변수:

  • ORACLE_HOME

  • ORACLE_SID

  • LD_PRELOAD

  • LD_LIBRARY_PATH

  • NLS_LANG

  • ORA_NLS33

웹서버 계정으로 위 환경변수를 적용한후에, 웹서버 계정(nobody, www)을 오라클 그룹에 추가했는지 확인해야 한다.

웹서버가 시작하지 않거나 시작시 제대로 작동하지 않으면: 아파치가 pthread 라이브러리에 링크되어있는지 체크하라:

# ldd /www/apache/bin/httpd
    libpthread.so.0 => /lib/libpthread.so.0 (0x4001c000)
    libm.so.6 => /lib/libm.so.6 (0x4002f000)
    libcrypt.so.1 => /lib/libcrypt.so.1 (0x4004c000)
    libdl.so.2 => /lib/libdl.so.2 (0x4007a000)
    libc.so.6 => /lib/libc.so.6 (0x4007e000)
    /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

libpthread가 보이지 않으면 아파치를 다시 설치해야한다 :

# cd /usr/src/apache_1.3.xx
# make clean
# LIBS=-lpthread ./config.status
# make
# make install

예 1. OCI Hints

<?php
// by sergo@bacup.ru

// Use option: OCI_DEFAULT for execute command to delay execution
OCIExecute($stmt, OCI_DEFAULT);

// for retrieve data use (after fetch):

$result = OCIResult($stmt, $n);
if (is_object ($result)) $result = $result->load();

// For INSERT or UPDATE statement use:

$sql = "insert into table (field1, field2) values (field1 = 'value',
field2 = empty_clob()) returning field2 into :field2";
OCIParse($conn, $sql);
$clob = OCINewDescriptor($conn, OCI_D_LOB);
OCIBindByName ($stmt, ":field2", &amp;$clob, -1, OCI_B_CLOB);
OCIExecute($stmt, OCI_DEFAULT);
$clob->save ("some text");
OCICommit($conn);

?&gt;

커맨드 라인(command-line)에서의 사용 방식과 동일하게 내장 프로시저(stored procedures)를 사용할 수 있다.

예 2. 내장 프로시저(Stored Procedures) 사용하기

<?php
// by webmaster@remoterealty.com
$sth = OCIParse ( $dbh, "begin sp_newaddress( :address_id, '$firstname',
'$lastname', '$company', '$address1', '$address2', '$city', '$state',
'$postalcode', '$country', :error_code );end;" );

// This calls stored procedure sp_newaddress, with :address_id being an
// in/out variable and :error_code being an out variable.
// Then you do the binding:

   OCIBindByName ( $sth, ":address_id", $addr_id, 10 );
   OCIBindByName ( $sth, ":error_code", $errorcode, 10 );
   OCIExecute ( $sth );

?>

차례
oci_bind_by_name -- Binds the PHP variable to the Oracle placeholder
oci_cancel -- Cancels reading from cursor
oci_close -- Closes Oracle connection
collection->append -- Appends an object to the collection
collection->assign -- Assigns a value to the collection from another existing collection
collection->assignElem -- Assigns a value to the element of the collection
collection->getElem -- Returns value of the element
collection->max -- Gets the maximum number of elements in the collection
collection->size -- Returns size of the collection
collection->trim -- Trims elements from the end of the collection
oci_commit -- Commits outstanding statements
oci_connect -- Establishes a connection to Oracle server
oci_define_by_name -- Uses a PHP variable for the define-step during a SELECT
oci_error -- Returns the last error found
oci_execute -- Executes a statement
oci_fetch_all -- Fetches all rows of result data into an array
oci_fetch_array -- Returns the next row from the result data as an associative or numeric array, or both
oci_fetch_assoc -- Returns the next row from the result data as an associative array
oci_fetch_object -- Returns the next row from the result data as an object
oci_fetch_row -- Returns the next row from the result data as a numeric array
oci_fetch -- Fetches the next row into result-buffer
oci_field_is_null -- Checks if the field is NULL
oci_field_name -- Returns the name of a field from the statement
oci_field_precision -- Tell the precision of a field
oci_field_scale -- Tell the scale of the field
oci_field_size -- Returns field's size
oci_field_type_raw -- Tell the raw Oracle data type of the field
oci_field_type -- Returns field's data type
collection->free -- Frees resources associated with collection object
descriptor->free -- Frees resources associated with descriptor
oci_free_statement -- Frees all resources associated with statement or cursor
oci_internal_debug -- Enables or disables internal debug output
lob->append -- Appends data from the large object to another large object
lob->close -- Closes LOB descriptor
oci_lob_copy -- Copies large object
lob->eof -- Tests for end-of-file on a large object's descriptor
lob->erase -- Erases a specified portion of the internal LOB data
lob->export -- Exports LOB's contents to a file
lob->flush -- Flushes/writes buffer of the LOB to the server
lob->import -- Imports file data to the LOB
oci_lob_is_equal -- Compares two LOB/FILE locators for equality
lob->load -- Returns large object's contents
lob->read -- Reads part of large object
lob->rewind -- Moves the internal pointer to the beginning of the large object
lob->save -- Saves data to the large object
lob->seek -- Sets the internal pointer of the large object
lob->size -- Returns size of large object
lob->tell -- Returns current position of internal pointer of large object
lob->truncate -- Truncates large object
lob->writeTemporary -- Writes temporary large object
lob->write -- Writes data to the large object
oci_new_collection -- Allocates new collection object
oci_new_connect -- Establishes a new connection to the Oracle server
oci_new_cursor -- Allocates and returns a new cursor (statement handle)
oci_new_descriptor -- Initializes a new empty LOB or FILE descriptor
oci_num_fields -- Returns the number of result columns in a statement
oci_num_rows -- Returns number of rows affected during statement execution
oci_parse -- Prepares Oracle statement for execution
oci_password_change -- Changes password of Oracle's user
oci_pconnect -- Connect to an Oracle database using a persistent connection
oci_result -- Returns field's value from the fetched row
oci_rollback -- Rolls back outstanding transaction
oci_server_version -- Returns server version
oci_set_prefetch -- Sets number of rows to be prefetched
oci_statement_type -- Returns the type of an OCI statement
OCIBindByName -- 오라클 위치보유자(Placeholder)를 PHP 변수에 연계(bind)시킨다.
OCICancel -- 커서로부터 읽기를 취소한다
ocicloselob -- Closes lob descriptor
ocicollappend -- Append an object to the collection
ocicollassign -- Assign a collection from another existing collection
ocicollassignelem -- Assign element val to collection at index ndx
ocicollgetelem -- Retrieve the value at collection index ndx
ocicollmax -- Return the max value of a collection. For a varray this is the maximum length of the array
ocicollsize -- Return the size of a collection
ocicolltrim -- Trim num elements from the end of a collection
OCIColumnIsNULL -- 결과 컬럼이 널(NULL)인지 테스트한다
OCIColumnName -- 컬럼의 이름을 리턴한다.
ocicolumnprecision -- Tell the precision of a column
ocicolumnscale -- Tell the scale of a column
OCIColumnSize -- 결과 컬럼 사이즈를 리턴한다
OCIColumnType -- 컬럼의 데이터 타입을 리턴한다.
ocicolumntyperaw -- Tell the raw oracle data type of a column
OCICommit -- 미결정된 트랜잭션을 커밋시킨다.
OCIDefineByName -- 한 SELECT 구문사용시 정의단계(define-step)를 위한 PHP 변수를 할당한다.
OCIError -- stmt|conn|global의 제일 마지막 에러를 리턴한다. 아무 에러도 없었다면 FALSE를 리턴한다.
OCIExecute -- SQL 구문(Statement)을 수행한다.
OCIFetch -- 결과 버퍼(result-buffer)로 다음 열을 페치한다
OCIFetchInto -- 결과 배열(result-array)에 다음 열을 페치한다
OCIFetchStatement -- 배열에 모든 열의 결과 값을 페치한다.
ocifreecollection -- Deletes collection object
OCIFreeCursor -- 커서(cursor)에 연관된 모든 자원을 해제한다.
OCIFreeDesc -- 큰 객체(large object) descriptor를 삭제한다.
OCIFreeStatement -- 구문(statement)에 연관된 모든 자원을 해제한다.
lob->getBuffering -- Returns current state of buffering for large object
OCIInternalDebug -- 내부 디버그 출력을 활성화 시키거나, 비활성화 시킨다. 기본값으로 비활성화 되어있다.
ociloadlob -- Loads a large object
OCILogOff -- 오라클로부터 접속을 해제한다.
OCILogon -- 오라클 데이터베이스에 접속한다.
ocinewcollection -- Initialize a new collection
OCINewCursor -- 새로운 커서(구문 핸들)를 리턴한다 - ref-cursor를 연계하기위함.
OCINewDescriptor -- LOB/FILE의 비어있는 새로운 descriptor를 초기화한다 (LOB 이 기본값이다)
OCINLogon -- 오라클 데이터베이스에 접속하고 새로운 접속을 이용해서 로그온한다. 새로운 세션(session)을 넘겨준다.
OCINumCols -- 구문 결과값의 컬럼의 갯수를 리턴한다
OCIParse -- 질의(query)를 해석하고 구문(statement)를 리턴한다
OCIPLogon -- 오라클 데이터베이스에 접속하고 영속적 DB 접속 (persistant connection) 을 이용해서 로그온한다. 또다른 새로운 세션(session)을 넘겨준다.
OCIResult -- 페치된 열의 컬럼 값을 리턴한다
OCIRollback -- 미결정된 트랜잭션을 롤백한다.
OCIRowCount -- 적용되어진 열의 갯수를 가져온다
ocisavelob -- Saves a large object
ocisavelobfile -- Saves a large object file
ociserverversion -- Return a string containing server version information
lob->setBuffering -- Changes current state of buffering for large object
OCISetPrefetch -- 사용할 열의 갯수를 설정한다
OCIStatementType -- OCI 구문(statement)의 타입을 리턴한다.
ociwritelobtofile -- Saves a large object file
ociwritetemporarylob -- Writes temporary blob

이전 | 처음으로 | 다음
deaggregate | 위로 | oci_bind_by_name


oci_bind_by_name

(PHP 5)

oci_bind_by_name -- Binds the PHP variable to the Oracle placeholder

Description

bool oci_bind_by_name ( resource stmt, string ph_name, mixed &variable [, int maxlength [, int type]])

oci_bind_by_name() binds the PHP variable variable to the Oracle placeholder ph_name. Whether it will be used for input or output will be determined at run-time and the necessary storage space will be allocated. The length parameter sets the maximum length for the bind. If you set length to -1 oci_bind_by_name() will use the current length of variable to set the maximum length.

If you need to bind an abstract datatype (LOB/ROWID/BFILE) you need to allocate it first using the oci_new_descriptor() function. The length is not used for abstract datatypes and should be set to -1. The type parameter tells Oracle which descriptor is used. Possible values are:

  • OCI_B_FILE - for BFILEs;

  • OCI_B_CFILE - for CFILEs;

  • OCI_B_CLOB - for CLOBs;

  • OCI_B_BLOB - for BLOBs;

  • OCI_B_ROWID - for ROWIDs;

  • OCI_B_NTY - for named datatypes;

  • OCI_B_CURSOR - for cursors, that were created before with oci_new_cursor().

예 1. oci_bind_by_name()example

<?php
/* oci_bind_by_name example thies at thieso dot net (980221)
  inserts 3 records into emp, and uses the ROWID for updating the
  records just after the insert.
*/

$conn = oci_connect("scott", "tiger");

$stmt = oci_parse($conn, "
                          INSERT INTO
                                     emp (empno, ename)
                                              VALUES
                                     (:empno,:ename)
                            RETURNING
                                     ROWID
                                 INTO
                                     :rid
                                         ");

$data = array(
              1111 => "Larry",
              2222 => "Bill",
              3333 => "Jim"
             );

$rowid = oci_new_descriptor($conn, OCI_D_ROWID);

oci_bind_by_name($stmt, ":empno", $empno, 32);
oci_bind_by_name($stmt, ":ename", $ename, 32);
oci_bind_by_name($stmt, ":rid",   $rowid, -1, OCI_B_ROWID);

$update = oci_parse($conn, "
                            UPDATE
                                  emp
                               SET
                                  sal = :sal
                             WHERE
                                  ROWID = :rid
                             ");
oci_bind_by_name($update, ":rid", $rowid, -1, OCI_B_ROWID);
oci_bind_by_name($update, ":sal", $sal,   32);

$sal = 10000;

while (list($empno, $ename) = each($data)) {
    oci_execute($stmt);
oci_execute($update);
}

$rowid->free();

oci_free_statement($update);
oci_free_statement($stmt);

$stmt = oci_parse($conn, "
                          SELECT
                                *
                            FROM
                                emp
                           WHERE
                                empno
                              IN
                                (1111,2222,3333)
                              ");
oci_execute($stmt);

while ($row = oci_fetch_assoc($stmt)) {
    var_dump($row);
}

oci_free_statement($stmt);

/* delete our "junk" from the emp table.... */
$stmt = oci_parse($conn, "
                          DELETE FROM
                                     emp
                                WHERE
                                     empno
                                   IN
                                     (1111,2222,3333)
                                   ");
oci_execute($stmt);
oci_free_statement($stmt);

oci_close($conn);
?>

Remember, that this function strips trailing whitespace. See the following example:

예 2. oci_bind_by_name() example

<?php
    $connection = oci_connect('apelsin','kanistra');
    $query = "INSERT INTO test_table VALUES(:id, :text)";

    $statement = oci_parse($query);
    oci_bind_by_name($statement, ":id", 1);
    oci_bind_by_name($statement, ":text", "trailing spaces follow     ");
    oci_execute($statement);
    /*
     This code will insert into DB string 'trailing spaces follow', without
     trailing spaces
    */
?>

예 3. oci_bind_by_name() example

<?php
    $connection = oci_connect('apelsin','kanistra');
    $query = "INSERT INTO test_table VALUES(:id, 'trailing spaces follow      ')";

    $statement = oci_parse($query);
    oci_bind_by_name($statement, ":id", 1);
    oci_execute($statement);
    /*
     And this code will add 'trailing spaces follow      ', preserving
     trailing whitespaces
    */
?>

주의

Do not use magic_quotes_gpc or addslashes() and oci_bind_by_name() simultaneously as no quoting is needed and any magically applied quotes will be written into your database as oci_bind_by_name() is not able to distinguish magically added quotings from those added intentionally.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: In PHP versions before 5.0.0 you must use ocibindbyname() instead. This name still can be used, it was left as alias of oci_bind_by_name() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
오라클 8 함수 | 위로 | oci_cancel


oci_cancel

(PHP 5)

oci_cancel -- Cancels reading from cursor

Description

bool oci_cancel ( resource stmt)

oci_cancel() invalidates a cursor, freeing all associated resources and cancels the ability to read from it.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

In PHP versions before 5.0.0 you must use ocicancel() instead. This name still can be used, it was left as alias of oci_cancel() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
oci_bind_by_name | 위로 | oci_close


oci_close

(PHP 5)

oci_close -- Closes Oracle connection

Description

bool oci_close ( resource connection)

oci_close() closes the Oracle connection connection.

참고: As non-persistent links are closed automatically at the end of script execution, calling this function is not required. Because of this and the method the extension uses to handle connection resources, oci_close() currently provides no actual functionality.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: In PHP versions before 5.0.0 you must use ociclose() instead. This name still can be used, it was left as alias of oci_close() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
oci_cancel | 위로 | collection->append


collection->append

(no version information, might be only in CVS)

collection->append -- Appends an object to the collection

Description

bool collection->append ( mixed value)

Appends an object to the end of the collection. Parameter value can be a string or a number.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
oci_close | 위로 | collection->assign


collection->assign

(no version information, might be only in CVS)

collection->assign -- Assigns a value to the collection from another existing collection

Description

bool collection->assign ( object from)

Assigns a value to the collection from another, previously created collection. Both collections must be created with oci_new_collection() prior to using them.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
collection->append | 위로 | collection->assignElem


collection->assignElem

(no version information, might be only in CVS)

collection->assignElem -- Assigns a value to the element of the collection

Description

bool collection->assignElem ( int index, mixed value)

Assigns a value to the element with index index. Parameter value can be a string or a number.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
collection->assign | 위로 | collection->getElem


collection->getElem

(no version information, might be only in CVS)

collection->getElem -- Returns value of the element

Description

mixed collection->getElem ( int index)

Method collection->getElem() returns value of the element with index index (1-based).

collection->getElem() will return FALSE if such element doesn't exist; NULL if element is NULL; string if element is column of a string datatype or number if element is numeric field.

collection->getElem() will return FALSE in case of error.

이전 | 처음으로 | 다음
collection->assignElem | 위로 | collection->max


collection->max

(no version information, might be only in CVS)

collection->max -- Gets the maximum number of elements in the collection

Description

int collection->max ( void )

Returns the maximum number of elements in the collection. If the returned value is 0, then the number of elements is not limited. collection->max() returns FALSE in case of error.

See also oci_collection_size().

이전 | 처음으로 | 다음
collection->getElem | 위로 | collection->size


collection->size

(no version information, might be only in CVS)

collection->size -- Returns size of the collection

Description

int collection->size ( void )

Returns the number of elements in the collection.

See also oci_collection_max().

이전 | 처음으로 | 다음
collection->max | 위로 | collection->trim


collection->trim

(no version information, might be only in CVS)

collection->trim -- Trims elements from the end of the collection

Description

bool collection->trim ( int num)

Trims num of elements from the end of the collection.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also oci_collection_size().

이전 | 처음으로 | 다음
collection->size | 위로 | oci_commit


oci_commit

(PHP 5)

oci_commit -- Commits outstanding statements

Description

bool oci_commit ( resource connection)

oci_commit() commits all outstanding statements for the active transaction on the Oracle connection connection.

예 1. oci_commit() example

<?php
    // Login to Oracle server
    $conn = oci_connect('scott', 'tiger');

    // Parse SQL
    $stmt = oci_parse($conn, "
                              INSERT INTO
                                         employees (name, surname)
                                   VALUES
                                         ('Maxim', 'Maletsky')
                             ");

    /* Execute statement
       OCI_DEFAULT tells oci_execute()
       not to commit statement immediately */
    oci_execute($stmt, OCI_DEFAULT);

    /*
    ....
    Parsing and executing other statements here ...
    ....
    */

    // Commit transaction
    $committed = oci_commit($conn);

    // Test whether commit was successful. If error occurred, return error message
    if (!$committed) {
        $error = oci_error($conn);
        echo 'Commit failed. Oracle reports: ' . $error['message'];
    }

?>

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: In PHP versions before 5.0.0 you must use ocicommit() instead. This name still can be used, it was left as alias of oci_commit() for downwards compatability. This, however, is deprecated and not recommended.

See also oci_rollback() and oci_execute().

이전 | 처음으로 | 다음
collection->trim | 위로 | oci_connect


oci_connect

(PHP 5)

oci_connect -- Establishes a connection to Oracle server

Description

resource oci_connect ( string username, string password [, string db])

oci_connect() returns a connection identifier needed for most other OCI calls. The optional third parameter can either contain the name of the local Oracle instance or the name of the entry in tnsnames.ora to which you want to connect. If the optional third parameter is not specified, PHP uses the environment variables ORACLE_SID (Oracle instance) or TWO_TASK (tnsnames.ora) to determine which database to connect to.

참고: oci_connect() does not reestablish the connection, if a connection with such parameters was established before. In this case, oci_connect() will return identifier of previously opened connection. This means, that you cannot use this function to separate transactions. To establish a distinctly new connection, use oci_new_connect().

예 1. oci_connect() example

<?php
echo "<pre>";
$db = "";

$c1 = oci_connect("scott", "tiger", $db);
$c2 = oci_connect("scott", "tiger", $db);

function create_table($conn)
{
  $stmt = oci_parse($conn, "create table scott.hallo (test varchar2(64))");
  oci_execute($stmt);
  echo $conn . " created table\n\n";
}

function drop_table($conn)
{
  $stmt = oci_parse($conn, "drop table scott.hallo");
  oci_execute($stmt);
  echo $conn . " dropped table\n\n";
}

function insert_data($conn)
{
  $stmt = oci_parse($conn, "insert into scott.hallo
            values('$conn' || ' ' || to_char(sysdate,'DD-MON-YY HH24:MI:SS'))");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn . " inserted hallo\n\n";
}

function delete_data($conn)
{
  $stmt = oci_parse($conn, "delete from scott.hallo");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn . " deleted hallo\n\n";
}

function commit($conn)
{
  oci_commit($conn);
  echo $conn . " committed\n\n";
}

function rollback($conn)
{
  oci_rollback($conn);
  echo $conn . " rollback\n\n";
}

function select_data($conn)
{
  $stmt = oci_parse($conn, "select * from scott.hallo");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn."----selecting\n\n";
  while (oci_fetch($stmt)) {
    echo $conn . " [" . oci_result($stmt, "TEST") . "]\n\n";
  }
  echo $conn . "----done\n\n";
}

create_table($c1);
insert_data($c1);   // Insert a row using c1
insert_data($c2);   // Insert a row using c2

select_data($c1);   // Results of both inserts are returned
select_data($c2);

rollback($c1);      // Rollback using c1

select_data($c1);   // Both inserts have been rolled back
select_data($c2);

insert_data($c2);   // Insert a row using c2
commit($c2);        // Commit using c2

select_data($c1);   // Result of c2 insert is returned

delete_data($c1);   // Delete all rows in table using c1
select_data($c1);   // No rows returned
select_data($c2);   // No rows returned
commit($c1);        // Commit using c1

select_data($c1);   // No rows returned
select_data($c2);   // No rows returned

drop_table($c1);
echo "</pre>";
?>

oci_connect() returns FALSE if an error occured.

참고: In PHP versions before 5.0.0 you must use ocilogon() instead. This name still can be used, it was left as alias of oci_connect() for downwards compatability. This, however, is deprecated and not recommended.

See also oci_pconnect() and oci_new_connect().

이전 | 처음으로 | 다음
oci_commit | 위로 | oci_define_by_name


oci_define_by_name

(PHP 5)

oci_define_by_name -- Uses a PHP variable for the define-step during a SELECT

Description

bool oci_define_by_name ( resource statement, string column_name, mixed &variable [, int type])

oci_define_by_name() defines PHP variables for fetches of SQL-Columns. Be careful that Oracle uses ALL-UPPERCASE column names, whereby in your select you can also write lowercase. oci_define_by_name() expects the column_name to be in uppercase. If you define a variable that doesn't exists in your select statement, no error will issued.

If you need to define an abstract datatype (LOB/ROWID/BFILE) you must allocate it first using oci_new_descriptor(). See also the oci_bind_by_name() function.

예 1. oci_define_by_name() example

<?php
/* oci_define_by_name example - thies at thieso dot net (980219) */

$conn = oci_connect("scott", "tiger");

$stmt = oci_parse($conn, "SELECT empno, ename FROM emp");

/* the define MUST be done BEFORE oci_execute! */

oci_define_by_name($stmt, "EMPNO", $empno);
oci_define_by_name($stmt, "ENAME", $ename);

oci_execute($stmt);

while (oci_fetch($stmt)) {
    echo "empno:" . $empno . "\n";
    echo "ename:" . $ename . "\n";
}

oci_free_statement($stmt);
oci_close($conn);
?>

참고: In PHP versions before 5.0.0 you must use ocidefinebyname() instead. This name still can be used, it was left as alias of oci_define_by_name() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
oci_connect | 위로 | oci_error


oci_error

(PHP 5)

oci_error -- Returns the last error found

Description

array ocierror ( [resource source])

oci_error() returns the last error found. If the optional source is not provided, the last error encountered is returned. You can use connection or statement resources as value of parameter source. If no error is found, oci_error() returns FALSE. oci_error() returns the error as an associative array. In this array, code consists the oracle error code and message the oracle error string.

As of PHP 4.3: offset and sqltext will also be included in the return array to indicate the location of the error and the original SQL text which caused it.

참고: In PHP versions before 5.0.0 you must use ocierror() instead. This name still can be used, it was left as alias of oci_error() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
oci_define_by_name | 위로 | oci_execute


oci_execute

(PHP 5)

oci_execute -- Executes a statement

Description

bool oci_execute ( resource stmt [, int mode])

oci_execute() executes a previously parsed statement (see oci_parse()). The optional mode allows you to specify the execution mode (default is OCI_COMMIT_ON_SUCCESS). If you don't want statements to be committed automatically, you should specify OCI_DEFAULT as your mode.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: In PHP versions before 5.0.0 you must use ociexecute() instead. This name still can be used, it was left as alias of oci_execute() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
oci_error | 위로 | oci_fetch_all


oci_fetch_all

(PHP 5)

oci_fetch_all -- Fetches all rows of result data into an array

Description

int oci_fetch_all ( resource statement, array &output [, int skip [, int maxrows [, int flags]]])

oci_fetch_all() fetches all the rows from a result into a user-defined array. oci_fetch_all() returns the number of rows fetched or FALSE in case of error. skip is the number of initial rows to ignore when fetching the result (default value of 0, to start at the first line). maxrows is the number of rows to read, starting at the skipth row (default to -1, meaning all the rows).

Parameter flags can be any combination of the following:

OCI_FETCHSTATEMENT_BY_ROW
OCI_FETCHSTATEMENT_BY_COLUMN (default value)
OCI_NUM
OCI_ASSOC

예 1. oci_fetch_all() example

<?php
/* oci_fetch_all example mbritton at verinet dot com (990624) */

$conn = oci_connect("scott", "tiger");

$stmt = oci_parse($conn, "select * from emp");

oci_execute($stmt);

$nrows = oci_fetch_all($stmt, $results);
if ($nrows > 0) {
   echo "<table border=\"1\">\n";
   echo "<tr>\n";
   while (list($key, $val) = each($results)) {
      echo "<th>$key</th>\n";
   }
   echo "</tr>\n";

   for ($i = 0; $i < $nrows; $i++) {
      reset($results);
      echo "<tr>\n";
      while ($column = each($results)) {
         $data = $column['value'];
         echo "<td>$data[$i]</td>\n";
      }
      echo "</tr>\n";
   }
   echo "</table>\n";
} else {
   echo "No data found<br />\n";
}
echo "$nrows Records Selected<br />\n";

oci_free_statement($stmt);
oci_close($conn);
?>

oci_fetch_all() returns FALSE in case of error.

참고: In PHP versions before 5.0.0 you must use ocifetchstatement() instead. This name still can be used, it was left as alias of oci_fetch_all() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
oci_execute | 위로 | oci_fetch_array


oci_fetch_array

(PHP 5)

oci_fetch_array -- Returns the next row from the result data as an associative or numeric array, or both

Description

array oci_fetch_array ( resource statement [, int mode])

Returns an array, which corresponds to the next result row or FALSE in case of error or there is no more rows in the result.

oci_fetch_array() returns an array with both associative and numeric indices.

Optional second paramater can be any combination of the following constants:

OCI_BOTH - return an array with both associative and numeric indices (the same as OCI_ASSOC + OCI_NUM). This is the default behavior.
OCI_ASSOC - return an associative array (as oci_fetch_assoc() works).
OCI_NUM - return a numeric array, (as oci_fetch_row() works).
OCI_RETURN_NULLS - create empty elements for the NULL fields.
OCI_RETURN_LOBS - return the value of a LOB of the descriptor.

Default mode is OCI_BOTH.

It should be mentioned here, that oci_fetch_array() is insignificantly slower, than oci_fetch_row(), but much more handy.

참고: Don't forget, that Oracle returns all field names in uppercase and associative indices in the result array will be uppercased too.

예 1. oci_fetch_array() with OCI_BOTH example

<?php
$connection = oci_connect("apelsin", "kanistra");

$query = "SELECT id, name FROM fruits";

$statement = oci_parse ($connection, $query);
oci_execute ($statement);

while ($row = oci_fetch_array ($statement, OCI_BOTH)) {
    echo $row[0]." and ".$row['ID']." is the same<br>";
    echo $row[1]." and ".$row['NAME']." is the same<br>";
}
?>

예 2. oci_fetch_array() with OCI_NUM example

<?php
$connection = oci_connect("user", "password");

$query = "SELECT id, name, lob_field FROM fruits";

$statement = oci_parse ($connection, $query);
oci_execute ($statement);

while ($row = oci_fetch_array ($statement, OCI_NUM)) {
    echo $row[0]."<br>";
    echo $row[1]."<br>";
    echo $row[2]->read(100)."<br>";  //this will output first 100 bytes from LOB
}
?>

예 3. oci_fetch_array() with OCI_ASSOC example

<?php
$connection = oci_connect("user", "password");

$query = "SELECT id, name, lob_field FROM fruits";

$statement = oci_parse ($connection, $query);
oci_execute ($statement);

while ($row = oci_fetch_array ($statement, OCI_NUM)) {
    echo $row['ID']."<br>";
    echo $row['NAME']."<br>";
    echo $row['LOB_FIELD']."<br>";  //this will output "Object id #1"
}
?>

예 4. oci_fetch_array() with OCI_RETURN_LOBS example

<?php
$connection = oci_connect("user", "password");

$query = "SELECT id, name, lob_field FROM fruits";

$statement = oci_parse ($connection, $query);
oci_execute ($statement);

while ($row = oci_fetch_array ($statement, OCI_NUM)) {
    echo $row[0]."<br>";
    echo $row[1]."<br>";
    echo $row['LOB_FIELD']."<br>";  //this will output LOB's content
}
?>

See also oci_fetch_assoc(),
oci_fetch_object(),
oci_fetch_row() and
oci_fetch_all().

이전 | 처음으로 | 다음
oci_fetch_all | 위로 | oci_fetch_assoc


oci_fetch_assoc

(PHP 5)

oci_fetch_assoc -- Returns the next row from the result data as an associative array

Description

array oci_fetch_assoc ( resource statement)

oci_fetch_assoc() returns the next row from the result data as an associative array (identical to oci_fetch_array() call with OCI_ASSOC flag).

Subsequent call to oci_fetch_assoc() will return next row or FALSE if there is no more rows.

참고: Don't forget, that Oracle returns all field names in uppercase and associative indices in the result array will be uppercased too.

See also oci_fetch_array(),
oci_fetch_object(),
oci_fetch_row() and
oci_fetch_all().

이전 | 처음으로 | 다음
oci_fetch_array | 위로 | oci_fetch_object


oci_fetch_object

(PHP 5)

oci_fetch_object -- Returns the next row from the result data as an object

Description

object oci_fetch_object ( resource statement)

oci_fetch_object() returns the next row from the result data as an object, which attributes correspond to fields in statement.

Subsequent calls to oci_fetch_object() will return the next row from the result or FALSE if there is no more rows.

참고: Don't forget, that Oracle returns all field names in uppercase and attributes' names in the result object will be in uppercase as well.

See also oci_fetch_array(),
oci_fetch_assoc(),
oci_fetch_row() and
oci_fetch_all().

이전 | 처음으로 | 다음
oci_fetch_assoc | 위로 | oci_fetch_row


oci_fetch_row

(PHP 5)

oci_fetch_row -- Returns the next row from the result data as a numeric array

Description

array oci_fetch_row ( resource statement)

Calling oci_fetch_row() is identical to oci_fetch_array() with OCI_NUM flag and returns the next row from the result data as a numeric array.

Subsequent calls to oci_fetch_row() will return the next row from the result data or FALSE if there is no more rows.

See also oci_fetch_array(),
oci_fetch_object(),
oci_fetch_assoc() and
oci_fetch_all().

이전 | 처음으로 | 다음
oci_fetch_object | 위로 | oci_fetch


oci_fetch

(PHP 5)

oci_fetch -- Fetches the next row into result-buffer

Description

bool oci_fetch ( resource statement)

oci_fetch() fetches the next row (for SELECT statements) into the internal result-buffer.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: In PHP versions before 5.0.0 you must use ocifetch() instead. This name still can be used, it was left as alias of oci_fetch() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
oci_fetch_row | 위로 | oci_field_is_null


oci_field_is_null

(PHP 5)

oci_field_is_null -- Checks if the field is NULL

Description

bool oci_field_is_null ( resource stmt, mixed field)

oci_field_is_null() returns TRUE if field field from the statement is NULL. Parameter field could be a field's index or a field's name (uppercased).

참고: In PHP versions before 5.0.0 you must use ocicolumnisnull() instead. This name still can be used, it was left as alias of oci_field_is_null() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
oci_fetch | 위로 | oci_field_name


oci_field_name

(PHP 5)

oci_field_name -- Returns the name of a field from the statement

Description

string oci_field_name ( resource statement, int field)

oci_field_name() returns the name of the field corresponding to the field number (1-based).

예 1. oci_field_name() example

<?php
    $conn = oci_connect("scott", "tiger");
    $stmt = oci_parse($conn, "SELECT * FROM emp");
    oci_execute($stmt);

    echo "<table border=\"1\">";
    echo "<tr>";
    echo "<th>Name</th>";
    echo "<th>Type</th>";
    echo "<th>Length</th>";
    echo "</tr>";

    $ncols = oci_num_fields($stmt);

    for ($i = 1; $i <= $ncols; $i++) {
        $column_name  = oci_field_name($stmt, $i);
        $column_type  = oci_field_type($stmt, $i);
        $column_size  = oci_field_size($stmt, $i);

        echo "<tr>";
        echo "<td>$column_name</td>";
        echo "<td>$column_type</td>";
        echo "<td>$column_size</td>";
        echo "</tr>";
    }

    echo "</table>\n";
    oci_free_statement($stmt);
    oci_close($conn);
?>

참고: In PHP versions before 5.0.0 you must use ocicolumnname() instead. This name still can be used, it was left as alias of oci_field_name() for downwards compatability. This, however, is deprecated and not recommended.

See also oci_num_fields(),
oci_field_type(),
and oci_field_size().

이전 | 처음으로 | 다음
oci_field_is_null | 위로 | oci_field_precision


oci_field_precision

(PHP 5)

oci_field_precision -- Tell the precision of a field

Description

int oci_field_precision ( resource statement, int field)

Returns precision of the field with field index (1-based).

For FLOAT columns, precision is nonzero and scale is -127. If precision is 0, then column is NUMBER. Else it's NUMBER(precision, scale).

참고: In PHP versions before 5.0.0 you must use ocicolumnprecision() instead. This name still can be used, it was left as alias of oci_field_precision() for downwards compatability. This, however, is deprecated and not recommended.

See also oci_field_scale() and oci_field_type().

이전 | 처음으로 | 다음
oci_field_name | 위로 | oci_field_scale


oci_field_scale

(PHP 5)

oci_field_scale -- Tell the scale of the field

Description

int oci_field_scale ( resource statement, int field)

Returns scale of the column with field index (1-based) or FALSE if there is no such field.

For FLOAT columns, precision is nonzero and scale is -127. If precision is 0, then column is NUMBER. Else it's NUMBER(precision, scale).

참고: In PHP versions before 5.0.0 you must use ocicolumnscale() instead. This name still can be used, it was left as alias of oci_field_scale() for downwards compatability. This, however, is deprecated and not recommended.

See also oci_field_precision() and oci_field_type().

이전 | 처음으로 | 다음
oci_field_precision | 위로 | oci_field_size


oci_field_size

(PHP 5)

oci_field_size -- Returns field's size

Description

int oci_field_size ( resource stmt, mixed field)

oci_field_size() returns the size of a field in bytes. Value of field parameter can be the field's index (1-based) or it's name.

예 1. oci_field_size()example

<?php
    $conn = oci_connect("scott", "tiger");
    $stmt = oci_parse($conn, "SELECT * FROM emp");
    oci_execute($stmt);

    echo "<table border=\"1\">";
    echo "<tr>";
    echo "<th>Name</th>";
    echo "<th>Type</th>";
    echo "<th>Length</th>";
    echo "</tr>";

    $ncols = oci_num_fields($stmt);

    for ($i = 1; $i <= $ncols; $i++) {
        $column_name  = oci_field_name($stmt, $i);
        $column_type  = oci_field_type($stmt, $i);
        $column_size  = oci_field_size($stmt, $i);
        echo "<tr>";
        echo "<td>$column_name</td>";
        echo "<td>$column_type</td>";
        echo "<td>$column_size</td>";
        echo "</tr>";
    }

    echo "</table>";

    oci_free_statement($stmt);
    oci_close($conn);
?>

참고: In PHP versions before 5.0.0 you must use ocicolumnsize() instead. This name still can be used, it was left as alias of oci_field_size() for downwards compatability. This, however, is deprecated and not recommended.

See also oci_num_fields() and oci_field_name().

이전 | 처음으로 | 다음
oci_field_scale | 위로 | oci_field_type_raw


oci_field_type_raw

(PHP 5)

oci_field_type_raw -- Tell the raw Oracle data type of the field

Description

int oci_field_type_raw ( resource statement, int field)

oci_field_type_raw() returns Oracle's raw data type of the field.

참고: In PHP versions before 5.0.0 you must use ocicolumntyperaw() instead. This name still can be used, it was left as alias of oci_field_type_raw() for downwards compatability. This, however, is deprecated and not recommended.

However, if you want to get field's type, then oci_field_type() will suit you better. See oci_field_type() for additional information.

이전 | 처음으로 | 다음
oci_field_size | 위로 | oci_field_type


oci_field_type

(PHP 5)

oci_field_type -- Returns field's data type

Description

mixed ocicolumntype ( resource stmt, int field)

oci_field_type() returns a field's data type. Parameter field is an index of the field in the statement (1-based).

예 1. oci_field_type() example

<?php
    $conn = oci_connect("scott", "tiger");
    $stmt = oci_parse($conn, "SELECT * FROM emp");
    oci_execute($stmt);

    echo "<table border=\"1\">";
    echo "<tr>";
    echo "<th>Name</th>";
    echo "<th>Type</th>";
    echo "<th>Length</th>";
    echo "</tr>";

    $ncols = oci_num_fields($stmt);

    for ($i = 1; $i <= $ncols; $i++) {
        $column_name  = oci_field_name($stmt, $i);
        $column_type  = oci_field_type($stmt, $i);
        $column_size  = oci_field_size($stmt, $i);

        echo "<tr>";
        echo "<td>$column_name</td>";
        echo "<td>$column_type</td>";
        echo "<td>$column_size</td>";
        echo "</tr>";
    }

    echo "</table>\n";

    oci_free_statement($stmt);
    oci_close($conn);
?>

참고: In PHP versions before 5.0.0 you must use ocicolumntype() instead. This name still can be used, it was left as alias of oci_field_type() for downwards compatability. This, however, is deprecated and not recommended.

See also oci_num_fields(),
oci_field_name(),
and oci_field_size().

이전 | 처음으로 | 다음
oci_field_type_raw | 위로 | collection->free


collection->free

(no version information, might be only in CVS)

collection->free -- Frees resources associated with collection object

Description

bool collection->free ( void )

Frees resources associated with collection object.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
oci_field_type | 위로 | descriptor->free


descriptor->free

(no version information, might be only in CVS)

descriptor->free -- Frees resources associated with descriptor

Description

bool descriptor->free ( void )

descriptor->free() frees resources associated with descriptor, previously allocated with oci_new_descriptor().

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
collection->free | 위로 | oci_free_statement


oci_free_statement

(PHP 5)

oci_free_statement -- Frees all resources associated with statement or cursor

Description

bool oci_free_statement ( resource statement)

oci_free_statement() frees resources associated with Oracle's cursor or statement, which was received from as a result of oci_parse() or obtained from Oracle.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
descriptor->free | 위로 | oci_internal_debug


oci_internal_debug

(PHP 5)

oci_internal_debug -- Enables or disables internal debug output

Description

void oci_internal_debug ( int onoff)

oci_internal_debug() enables or disables internal debug output. Set onoff to 0 to turn debug output off or 1 to turn it on.

참고: In PHP versions before 5.0.0 you must use ociinternaldebug() instead. This name still can be used, it was left as alias of oci_internal_debug() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
oci_free_statement | 위로 | lob->append


lob->append

(no version information, might be only in CVS)

lob->append -- Appends data from the large object to another large object

Description

bool lob->append ( object lob_from)

Appends data from the large object to the end of another large object.

Writing to the large object with lob->append() will fail if buffering was previously enabled. You must disable buffering before appending. You may need to flush buffers with oci_lob_flush() before disabling buffering.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also oci_lob_flush(),
ocisetbufferinglob() and
ocigetbufferinglob().

이전 | 처음으로 | 다음
oci_internal_debug | 위로 | lob->close


lob->close

(no version information, might be only in CVS)

lob->close -- Closes LOB descriptor

Description

bool lob->close ( void )

lob->close() closes descriptor of LOB or FILE. This function should be used only with lob->writeTemporary().

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: In PHP versions before 5.0.0 you must use ocicloselob() instead. This name still can be used, it was left as alias of oci_lob_close() for downwards compatability. This, however, is deprecated and not recommended.

See also oci_lob_write_temporary().

이전 | 처음으로 | 다음
lob->append | 위로 | oci_lob_copy


oci_lob_copy

(PHP 5)

oci_lob_copy -- Copies large object

Description

bool oci_lob_copy ( [int length])

Copies large object or a part of large object to another large object. Parameter length indicates the length of data to be copied. Old data of LOB-recipient will be overwritten.

If you need to copy a particular part of LOB to a particular position of LOB, you can use oci_lob_seek() to move internal pointers of LOBs.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
lob->close | 위로 | lob->eof


lob->eof

(no version information, might be only in CVS)

lob->eof -- Tests for end-of-file on a large object's descriptor

Description

bool lob->eof ( void )

Returns TRUE if internal pointer of large object is at the end of LOB. Otherwise returns FALSE.

See also oci_lob_size().

이전 | 처음으로 | 다음
oci_lob_copy | 위로 | lob->erase


lob->erase

(no version information, might be only in CVS)

lob->erase -- Erases a specified portion of the internal LOB data

Description

int lob->erase ( [int offset [, int length]])

Erases a specified portion of the internal LOB data starting at a specified offset. Parameters length and offset are optional. lob->erase() erases all LOB data by default.

For BLOBs, erasing means that the existing LOB value is overwritten with zero-bytes. For CLOBs, the existing LOB value is overwritten with spaces.

lob->erase() returns the actual number of characters/bytes erased or FALSE in case of error.

이전 | 처음으로 | 다음
lob->eof | 위로 | lob->export


lob->export

(no version information, might be only in CVS)

lob->export -- Exports LOB's contents to a file

Description

bool ociwritelobtofile ( string filename [, int start [, int length]])

Exports LOB's contents to a file, which name is given in parameter filename. Optional parameter start indicates from what position to start export and parameter length - length of data to be exported.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
lob->erase | 위로 | lob->flush


lob->flush

(no version information, might be only in CVS)

lob->flush -- Flushes/writes buffer of the LOB to the server

Description

bool lob->flush ( [int flag])

lob->flush() actually writes data to the server. By default, resources are not freed, but using flag OCI_LOB_BUFFER_FREE you can do it explicitly. Be sure you know what you're doing - next read/write operation to the same part of LOB will involve a round-trip to the server and initialize new buffer resources. Tt is recommended to use OCI_LOB_BUFFER_FREE flag only when you are not going to work with the LOB anymore.

lob->flush() returns FALSE if buffering was not enabled or an error occurred.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
lob->export | 위로 | lob->import


lob->import

(no version information, might be only in CVS)

lob->import -- Imports file data to the LOB

Description

bool lob->import ( string filename)

Writes data from filename in to the current position of large object.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: In PHP versions before 5.0.0 you must use ocisavelobfile() instead. This name still can be used, it was left as alias of oci_lob_import() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
lob->flush | 위로 | oci_lob_is_equal


oci_lob_is_equal

(PHP 5)

oci_lob_is_equal -- Compares two LOB/FILE locators for equality

Description

bool oci_lob_is_equal ( object lob1, object lob2)

Compares two LOB/FILE locators. Returns TRUE if these objects are equal and FALSE otherwise.

이전 | 처음으로 | 다음
lob->import | 위로 | lob->load


lob->load

(no version information, might be only in CVS)

lob->load -- Returns large object's contents

Description

string lob->load ( void )

Returns large object's contents. As script execution is terminated when the memory_limit is reached, ensure that the LOB does not exceed this limit. In most cases it's recommended to use oci_lob_read() instead. In case of error lob->load() returns FALSE.

참고: In PHP versions before 5.0.0 you must use ociloadlob() instead. This name still can be used, it was left as alias of oci_lob_load() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
oci_lob_is_equal | 위로 | lob->read


lob->read

(no version information, might be only in CVS)

lob->read -- Reads part of large object

Description

string lob->read ( int length)

Reads length bytes from the current position of LOB's internal pointer. Reading stops when length bytes have been read or end of large object is reached. Internal pointer of large object will be shifted on the amount of bytes read.

Returns FALSE in case of error.

See also oci_lob_eof(),
oci_lob_seek(),
oci_lob_tell() and
oci_lob_write().

이전 | 처음으로 | 다음
lob->load | 위로 | lob->rewind


lob->rewind

(no version information, might be only in CVS)

lob->rewind -- Moves the internal pointer to the beginning of the large object

Description

bool lob->rewind ( void )

Sets the internal pointer to the beginning of the large object.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also oci_lob_seek() and oci_lob_tell().

이전 | 처음으로 | 다음
lob->read | 위로 | lob->save


lob->save

(no version information, might be only in CVS)

lob->save -- Saves data to the large object

Description

bool lob->save ( string data [, int offset])

Saves data to the large object. Parameter offset can be used to indicate offset from the beginning of the large object.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: In PHP versions before 5.0.0 you must use ocisavelob() instead. This name still can be used, it was left as alias of oci_lob_save() for downwards compatability. This, however, is deprecated and not recommended.

See also oci_lob_write() and oci_lob_import().

이전 | 처음으로 | 다음
lob->rewind | 위로 | lob->seek


lob->seek

(no version information, might be only in CVS)

lob->seek -- Sets the internal pointer of the large object

Description

bool lob->seek ( int offset [, int whence])

Sets the internal pointer of the large object. Parameter offset indicates the amount of bytes, on which internal pointer should be moved from the position, pointed by whence:

OCI_SEEK_SET - sets the position equal to offset
OCI_SEEK_CUR - adds offset bytes to the current position
OCI_SEEK_END - adds offset bytes to the end of large object (use negative value to move to a position before the end of large object)

See also oci_lob_rewind() and oci_lob_tell().

이전 | 처음으로 | 다음
lob->save | 위로 | lob->size


lob->size

(no version information, might be only in CVS)

lob->size -- Returns size of large object

Description

int lob->size ( void )

Returns length of large object value or FALSE in case of error. Empty objects have zero length.

이전 | 처음으로 | 다음
lob->seek | 위로 | lob->tell


lob->tell

(no version information, might be only in CVS)

lob->tell -- Returns current position of internal pointer of large object

Description

int lob->tell ( void )

Returns current position of a LOB's internal pointer or FALSE if an error occured.

See also oci_lob_size() and oci_lob_eof().

이전 | 처음으로 | 다음
lob->size | 위로 | lob->truncate


lob->truncate

(no version information, might be only in CVS)

lob->truncate -- Truncates large object

Description

bool lob->truncate ( [int length])

If parameter length is given, lob->truncate() truncates large object to length bytes. Otherwise, lob->truncate() will purge the LOB completely.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also oci_lob_erase().

이전 | 처음으로 | 다음
lob->tell | 위로 | lob->writeTemporary


lob->writeTemporary

(no version information, might be only in CVS)

lob->writeTemporary -- Writes temporary large object

Description

bool lob->writeTemporary ( string data [, int lob_type])

Creates a temporary large object and writes data to it.

Parameter lob_type can be one of the following:

OCI_TEMP_BLOB is used to create temporary BLOBs
OCI_TEMP_CLOB is used to create temporary CLOBs

lob->writeTemporary() creates a CLOB by default.

You should use oci_lob_close() when the work with the object is over.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: In PHP versions before 5.0.0 you must use ociwritetemporarylob() instead. This name still can be used, it was left as alias of oci_lob_write_temporary() for downwards compatability. This, however, is deprecated and not recommended.

See also oci_lob_close().

이전 | 처음으로 | 다음
lob->truncate | 위로 | lob->write


lob->write

(no version information, might be only in CVS)

lob->write -- Writes data to the large object

Description

int lob->write ( string data [, int length])

Writes data from the parameter data into the current position of LOB's internal pointer. If the parameter length is given, writing will stop after length bytes have been written or the end of data is reached, whichever comes first.

lob->write() returns the number of bytes written or FALSE in case of error.

See also oci_lob_read().

이전 | 처음으로 | 다음
lob->writeTemporary | 위로 | oci_new_collection


oci_new_collection

(PHP 5)

oci_new_collection -- Allocates new collection object

Description

object oci_new_collection ( resource connection, string tdo [, string schema])

Allocates new collection object. Parameter tdo should be a valid named type (uppercased). Third, optional parameter schema should point to the scheme, where the named type was created. oci_new_collection() uses name of the current user as default value of schema.

oci_new_collection() returns FALSE on error.

참고: In PHP versions before 5.0.0 you must use ocinewcollection() instead. This name still can be used, it was left as alias of oci_new_collection() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
lob->write | 위로 | oci_new_connect


oci_new_connect

(PHP 5)

oci_new_connect -- Establishes a new connection to the Oracle server

Description

resource oci_new_connect ( string username, string password [, string db])

oci_new_connect() creates a new connection to an Oracle server and logs on. The optional third parameter can either contain the name of the local Oracle instance or the name of the entry in tnsnames.ora. If the third parameter is not specified, PHP uses environment variables ORACLE_SID and TWO_TASK to determine the name of local Oracle instance and location of tnsnames.ora accordingly.

oci_new_connect() forces the creation of a new connection. This should be used if you need to isolate a set of transactions. By default, connections are shared and subsequent calls to oci_connect() will return the same connection identifier.

The following demonstrates how you can separate connections.

예 1. oci_new_connect() example

<?php
echo "<html><pre>";
$db = "";

$c1 = oci_connect("scott", "tiger", $db);
$c2 = oci_new_connect("scott", "tiger", $db);

function create_table($conn)
{
  $stmt = oci_parse($conn, "create table scott.hallo (test
varchar2(64))");
  oci_execute($stmt);
  echo $conn . " created table\n\n";
}

function drop_table($conn)
{
  $stmt = oci_parse($conn, "drop table scott.hallo");
  oci_execute($stmt);
  echo $conn . " dropped table\n\n";
}

function insert_data($conn)
{
  $stmt = oci_parse($conn, "insert into scott.hallo
            values('$conn' || ' ' || to_char(sysdate,'DD-MON-YY HH24:MI:SS'))");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn . " inserted hallo\n\n";
}

function delete_data($conn)
{
  $stmt = oci_parse($conn, "delete from scott.hallo");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn . " deleted hallo\n\n";
}

function commit($conn)
{
  oci_commit($conn);
  echo $conn . " committed\n\n";
}

function rollback($conn)
{
  oci_rollback($conn);
  echo $conn . " rollback\n\n";
}

function select_data($conn)
{
  $stmt = oci_parse($conn, "select * from scott.hallo");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn . "----selecting\n\n";
  while (oci_fetch($stmt)) {
    echo $conn . " <" . oci_result($stmt, "TEST") . ">\n\n";
  }
  echo $conn . "----done\n\n";
}

create_table($c1);
insert_data($c1);

select_data($c1);
select_data($c2);

rollback($c1);

select_data($c1);
select_data($c2);

insert_data($c2);
commit($c2);

select_data($c1);

delete_data($c1);
select_data($c1);
select_data($c2);
commit($c1);

select_data($c1);
select_data($c2);

drop_table($c1);
echo "</pre></html>";
?>

oci_new_connect() returns FALSE on error.

참고: In PHP versions before 5.0.0 you must use ocinlogon() instead. This name still can be used, it was left as alias of oci_new_connect() for downwards compatability. This, however, is deprecated and not recommended.

See also oci_connect() and oci_pconnect().

이전 | 처음으로 | 다음
oci_new_collection | 위로 | oci_new_cursor


oci_new_cursor

(PHP 5)

oci_new_cursor -- Allocates and returns a new cursor (statement handle)

Description

resource oci_new_cursor ( resource connection)

oci_new_cursor() allocates a new statement handle on the specified connection.

예 1. Using REF CURSOR in an Oracle's stored procedure

<?php
// suppose your stored procedure info.output returns a ref cursor in :data

$conn = oci_connect("scott", "tiger");
$curs = oci_new_cursor($conn);
$stmt = oci_parse($conn, "begin info.output(:data); end;");

oci_bind_by_name($stmt, "data", &$curs, -1, OCI_B_CURSOR);
oci_execute($stmt);
oci_execute($curs);

while ($data = oci_fetch_row($curs)) {
    var_dump($data);
}

oci_free_statement($stmt);
oci_free_statement($curs);
oci_close($conn);
?>

예 2. Using REF CURSOR in an Oracle's select statement

<?php
echo "<html><body>";
$conn = oci_connect("scott", "tiger");
$count_cursor = "CURSOR(select count(empno) num_emps from emp " .
                "where emp.deptno = dept.deptno) as EMPCNT from dept";
$stmt = oci_parse($conn, "select deptno,dname,$count_cursor");

oci_execute($stmt);
echo "<table border=\"1\">";
echo "<tr>";
echo "<th>DEPT NAME</th>";
echo "<th>DEPT #</th>";
echo "<th># EMPLOYEES</th>";
echo "</tr>";

while ($data = oci_fetch_assoc($stmt)) {
    echo "<tr>";
    $dname  = $data["DNAME"];
    $deptno = $data["DEPTNO"];
    echo "<td>$dname</td>";
    echo "<td>$deptno</td>";
    oci_execute($data["EMPCNT"]);
    while ($subdata = oci_fetch_assoc($data["EMPCNT"])) {
        $num_emps = $subdata["NUM_EMPS"];
        echo  "<td>$num_emps</td>";
    }
    echo "</tr>";
}
echo "</table>";
echo "</body></html>";
oci_free_statement($stmt);
oci_close($conn);
?>

oci_new_cursor() returns FALSE on error.

참고: In PHP versions before 5.0.0 you must use ocinewcursor() instead. This name still can be used, it was left as alias of oci_new_cursor() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
oci_new_connect | 위로 | oci_new_descriptor


oci_new_descriptor

(PHP 5)

oci_new_descriptor -- Initializes a new empty LOB or FILE descriptor

Description

object oci_new_descriptor ( resource connection [, int type])

oci_new_descriptor() allocates resources to hold descriptor or LOB locator. Valid values for type are: OCI_D_FILE, OCI_D_LOB and OCI_D_ROWID.

예 1. oci_new_descriptor() example

<?php
    /* This script is designed to be called from a HTML form.
     * It expects $user, $password, $table, $where, and $commitsize
     * to be passed in from the form.  The script then deletes
     * the selected rows using the ROWID and commits after each
     * set of $commitsize rows. (Use with care, there is no rollback)
     */
    $conn = oci_connect($user, $password);
    $stmt = oci_parse($conn, "select rowid from $table $where");
    $rowid = oci_new_descriptor($conn, OCI_D_ROWID);
    oci_define_by_name($stmt, "ROWID", $rowid);
    oci_execute($stmt);
    while (oci_fetch($stmt)) {
       $nrows = oci_num_rows($stmt);
       $delete = oci_parse($conn, "delete from $table where ROWID = :rid");
       oci_bind_by_name($delete, ":rid", $rowid, -1, OCI_B_ROWID);
       oci_execute($delete);
       echo "$nrows\n";
       if (($nrows % $commitsize) == 0) {
           oci_commit($conn);
       }
    }
    $nrows = oci_num_rows($stmt);
    echo "$nrows deleted...\n";
    oci_free_statement($stmt);
    oci_close($conn);
?>
<?php
    /* This script demonstrates file upload to LOB columns
     * The formfield used for this example looks like this
     * <form action="upload.php" method="post" enctype="multipart/form-data">
     * <input type="file" name="lob_upload" />
     * ...
     */
  if (!isset($lob_upload) || $lob_upload == 'none'){
?>
<form action="upload.php" method="post" enctype="multipart/form-data">
Upload file: <input type="file" name="lob_upload" /><br />
<input type="submit" value="Upload" /> - <input type="reset" value="Reset" />
</form>
<?php
  } else {

     // $lob_upload contains the temporary filename of the uploaded file

     // see also the features section on file upload,
     // if you would like to use secure uploads

     $conn = oci_connect($user, $password);
     $lob = oci_new_descriptor($conn, OCI_D_LOB);
     $stmt = oci_parse($conn, "insert into $table (id, the_blob)
               values(my_seq.NEXTVAL, EMPTY_BLOB()) returning the_blob into :the_blob");
     oci_bind_by_name($stmt, ':the_blob', $lob, -1, OCI_B_BLOB);
     oci_execute($stmt, OCI_DEFAULT);
     if ($lob->savefile($lob_upload)){
        oci_execute($conn);
        echo "Blob successfully uploaded\n";
     }else{
        echo "Couldn't upload Blob\n";
     }
     oci_free_descriptor($lob);
     oci_free_statement($stmt);
     oci_close($conn);
  }
?>

예 2. oci_new_descriptor() example

<?php
    /* Calling PL/SQL stored procedures which contain clobs as input
     * parameters (PHP 4 >= 4.0.6).
     * Example PL/SQL stored procedure signature is:
     *
     * PROCEDURE save_data
     *   Argument Name                  Type                    In/Out Default?
     *   ------------------------------ ----------------------- ------ --------
     *   KEY                            NUMBER(38)              IN
     *   DATA                           CLOB                    IN
     *
     */

    $conn = oci_connect($user, $password);
    $stmt = oci_parse($conn, "begin save_data(:key, :data); end;");
    $clob = oci_new_descriptor($conn, OCI_D_LOB);
    oci_bind_by_name($stmt, ':key', $key);
    oci_bind_by_name($stmt, ':data', $clob, -1, OCI_B_CLOB);
    $clob->write($data);
    oci_execute($stmt, OCI_DEFAULT);
    oci_commit($conn);
    $clob->free();
    oci_free_statement($stmt);
?>

oci_new_descriptor() returns FALSE on error.

참고: In PHP versions before 5.0.0 you must use ocinewdescriptor() instead. This name still can be used, it was left as alias of oci_new_descriptor() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
oci_new_cursor | 위로 | oci_num_fields


oci_num_fields

(PHP 5)

oci_num_fields -- Returns the number of result columns in a statement

Description

int oci_num_fields ( resource statement)

oci_num_fields() returns the number of columns in the statement.

예 1. oci_num_fields() example

<?php
    echo "<pre>\n";
    $conn = oci_connect("scott", "tiger");
    $stmt = oci_parse($conn, "select * from emp");

    oci_execute($stmt);

    while (oci_fetch($stmt)) {
        echo "\n";
        $ncols = oci_num_fields($stmt);
        for ($i = 1; $i <= $ncols; $i++) {
            $column_name  = oci_field_name($stmt, $i);
            $column_value = oci_result($stmt, $i);
            echo $column_name . ': ' . $column_value . "\n";
        }
        echo "\n";
    }

    oci_free_statement($stmt);
    oci_close($conn);

    echo "</pre>";
?>

oci_num_fields() returns FALSE on error.

참고: In PHP versions before 5.0.0 you must use ocinumcols() instead. This name still can be used, it was left as alias of oci_num_fields() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
oci_new_descriptor | 위로 | oci_num_rows


oci_num_rows

(PHP 5)

oci_num_rows -- Returns number of rows affected during statement execution

Description

int oci_num_rows ( resource stmt)

oci_num_rows() returns number of rows affected during statement execution.

참고: This function does not return number of rows selected! For SELECT statements this function will return the number of rows, that were fetched to the buffer with oci_fetch*() functions.

예 1. oci_num_rows() example

<?php
    echo "<pre>";
    $conn = oci_connect("scott", "tiger");

    $stmt = oci_parse($conn, "create table emp2 as select * from emp");
    oci_execute($stmt);
    echo oci_num_rows($stmt) . " rows inserted.<br />";
    oci_free_statement($stmt);

    $stmt = oci_parse($conn, "delete from emp2");
    oci_execute($stmt, OCI_DEFAULT);
    echo oci_num_rows($stmt) . " rows deleted.<br />";
    oci_commit($conn);
    oci_free_statement($stmt);

    $stmt = oci_parse($conn, "drop table emp2");
    oci_execute($stmt);
    oci_free_statement($stmt);

    oci_close($conn);
    echo "</pre>";
?>

oci_num_rows() returns FALSE on error.

참고: In PHP versions before 5.0.0 you must use ocirowcount() instead. This name still can be used, it was left as alias of oci_num_rows() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
oci_num_fields | 위로 | oci_parse


oci_parse

(PHP 5)

oci_parse -- Prepares Oracle statement for execution

Description

resource oci_parse ( resource connection, string query)

oci_parse() prepares the query using connection and returns the statement identifier, which can be used with oci_bind_by_name(), oci_execute() and other functions.

참고: This function does not validate query. The only way to find out if query is valid SQL or PL/SQL statement - is to execute it.

oci_parse() returns FALSE on error.

참고: In PHP versions before 5.0.0 you must use ociparse() instead. This name still can be used, it was left as alias of oci_parse() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
oci_num_rows | 위로 | oci_password_change


oci_password_change

(PHP 5)

oci_password_change -- Changes password of Oracle's user

Description

bool oci_password_change ( resource connection, string username, string old_password, string new_password)

Changes password for user with username. Parameters old_password and new_password should indicate old and new passwords respectively.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: In PHP versions before 5.0.0 you must use ocipasswordchange() instead. This name still can be used, it was left as alias of oci_password_change() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
oci_parse | 위로 | oci_pconnect


oci_pconnect

(PHP 5)

oci_pconnect -- Connect to an Oracle database using a persistent connection

Description

resource oci_pconnect ( string username, string password [, string db])

oci_pconnect() creates a new persistent connection to an Oracle server and logs on. The optional third parameter can either contain the name of the local Oracle instance or the name of the entry in tnsnames.ora. If the third parameter is not specified, PHP uses environment variables ORACLE_SID and TWO_TASK to determine the name of local Oracle instance and location of tnsnames.ora accordingly.

oci_pconnect() returns connection identifier or FALSE on error.

참고: Note, that these kind of links only work if you are using a module version of PHP. See the Persistent Database Connections section for more information.

참고: In PHP versions before 5.0.0 you must use ociplogon() instead. This name still can be used, it was left as alias of oci_pconnect() for downwards compatability. This, however, is deprecated and not recommended.

See also oci_connect() and oci_new_connect().

이전 | 처음으로 | 다음
oci_password_change | 위로 | oci_result


oci_result

(PHP 5)

oci_result -- Returns field's value from the fetched row

Description

mixed oci_result ( resource statement, mixed field)

oci_result() returns the data from the field field in the current row, fetched by oci_fetch(). oci_result() returns everything as strings except for abstract types (ROWIDs, LOBs and FILEs). oci_result() returns FALSE on error.

You can either use the column number (1-based) or the column name (in uppercase) for the field() parameter.

참고: In PHP versions before 5.0.0 you must use ociresult() instead. This name still can be used, it was left as alias of oci_result() for downwards compatability. This, however, is deprecated and not recommended.

See also oci_fetch_array(),
oci_fetch_assoc(),
oci_fetch_object(),
oci_fetch_row() and
oci_fetch_all().

이전 | 처음으로 | 다음
oci_pconnect | 위로 | oci_rollback


oci_rollback

(PHP 5)

oci_rollback -- Rolls back outstanding transaction

Description

bool oci_rollback ( resource connection)

oci_rollback() rolls back all outstanding statements for Oracle connection connection.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: In PHP versions before 5.0.0 you must use ocirollback() instead. This name still can be used, it was left as alias of oci_rollback() for downwards compatability. This, however, is deprecated and not recommended.

See also oci_commit().

이전 | 처음으로 | 다음
oci_result | 위로 | oci_server_version


oci_server_version

(PHP 5)

oci_server_version -- Returns server version

Description

string oci_server_version ( resource connection)

Returns a string with version information of the Oracle server, which uses connection connection or returns FALSE on error.

예 1. oci_server_version() example

<?php
    $conn = oci_connect("scott", "tiger");
    echo "Server Version: " . oci_server_version($conn);
    oci_close($conn);
?>

참고: In PHP versions before 5.0.0 you must use ociserverversion() instead. This name still can be used, it was left as alias of oci_server_version() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
oci_rollback | 위로 | oci_set_prefetch


oci_set_prefetch

(PHP 5)

oci_set_prefetch -- Sets number of rows to be prefetched

Description

bool oci_set_prefetch ( resource statement [, int rows])

Sets the number of rows to be prefetched after successful call to oci_execute(). The default value for rows is 1.

참고: In PHP versions before 5.0.0 you must use ocisetprefetch() instead. This name still can be used, it was left as alias of oci_set_prefetch() for downwards compatability. This, however, is deprecated and not recommended.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
oci_server_version | 위로 | oci_statement_type


oci_statement_type

(PHP 5)

oci_statement_type -- Returns the type of an OCI statement

Description

string oci_statement_type ( resource statement)

oci_statement_type() returns the query type of statement statement as one of the following values:

  1. SELECT

  2. UPDATE

  3. DELETE

  4. INSERT

  5. CREATE

  6. DROP

  7. ALTER

  8. BEGIN

  9. DECLARE

  10. UNKNOWN

Parameter statement is a valid OCI statement identifier, returned from oci_parse().

예 1. oci_statement_type() example

<?php
    $conn = oci_connect("scott", "tiger");
    $sql  = "delete from emp where deptno = 10";

    $stmt = oci_parse($conn, $sql);
    if (oci_statement_type($stmt) == "DELETE") {
        die("You are not allowed to delete from this table<br />");
    }

    oci_close($conn);
?>

oci_statement_type() returns FALSE on error.

참고: In PHP versions before 5.0.0 you must use ocistatementtype() instead. This name still can be used, it was left as alias of oci_statement_type() for downwards compatability. This, however, is deprecated and not recommended.

이전 | 처음으로 | 다음
oci_set_prefetch | 위로 | OCIBindByName


OCIBindByName

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

OCIBindByName -- 오라클 위치보유자(Placeholder)를 PHP 변수에 연계(bind)시킨다.

Description

int OCIBindByName ( int stmt, string ph_name, mixed & variable, int length [, int type])

OCIBindByName()함수는 PHP 변수 variable에 오라클 위치보유자(Oracle placeholder)인 ph_name변수에 연계시킨다. 용도가 입력인지 출력인지는 실시간으로 결정될것이고, 충분한 저장 공간이 할당될 필요가 있다. length인수 는 연계를 위한 최대 용량을 세팅한다. length인수를 -1로 세팅하면 OCIBindByName()함수는 연계를 위한 최대 용량을 variable의 현재 용량으로 사용할것이다.

추상형 데이터타입(LOB/ROWID/BFILE)을 연계 할 필요가 있다면 우선은 OCINewDescriptor()함수를 사용해서 변수를 할당해야 한다. length인수는 추상형 데이터타입 을 위해 사용되지 않는다. 이때 이 값은 -1이 되어야 한다. type변수는 오라클에서 현재 어떤 종류의 descriptor가 사용되는지 알려준다. 가능한 값은 다음과 같다: OCI_B_FILE (Binary-File), OCI_B_CFILE (Character-File), OCI_B_CLOB (Character-LOB), OCI_B_BLOB (Binary-LOB) and OCI_B_ROWID (ROWID).

예 1. OCIDefineByName

<?php
/* OCIBindByPos example thies@thieso.net (980221)
  inserts 3 records into emp, and uses the ROWID for updating the
  records just after the insert.
*/

$conn = OCILogon("scott","tiger");

$stmt = OCIParse($conn,"insert into emp (empno, ename) ".
               "values (:empno,:ename) ".
               "returning ROWID into :rid");

$data = array(1111 => "Larry", 2222 => "Bill", 3333 => "Jim");

$rowid = OCINewDescriptor($conn,OCI_D_ROWID);

OCIBindByName($stmt,":empno",&amp;$empno,32);
OCIBindByName($stmt,":ename",&amp;$ename,32);
OCIBindByName($stmt,":rid",&amp;$rowid,-1,OCI_B_ROWID);

$update = OCIParse($conn,"update emp set sal = :sal where ROWID = :rid");
OCIBindByName($update,":rid",&amp;$rowid,-1,OCI_B_ROWID);
OCIBindByName($update,":sal",&amp;$sal,32);

$sal = 10000;

while (list($empno,$ename) = each($data)) {
    OCIExecute($stmt);
    OCIExecute($update);
}

$rowid->free();

OCIFreeStatement($update);
OCIFreeStatement($stmt);

$stmt = OCIParse($conn,"select * from emp where empno in (1111,2222,3333)");
OCIExecute($stmt);
while (OCIFetchInto($stmt,&amp;$arr,OCI_ASSOC)) {
    var_dump($arr);
}
OCIFreeStatement($stmt);

/* delete our "junk" from the emp table.... */
$stmt = OCIParse($conn,"delete from emp where empno in (1111,2222,3333)");
OCIExecute($stmt);
OCIFreeStatement($stmt);

OCILogoff($conn);
?>

주의

It is a bad idea to use magic quotes and OciBindByName() simultaneously as no quoting is needed on quoted variables and any quotes magically applied will be written into your database as OciBindByName() is not able to distinguish magically added quotings from those added by intention.

이전 | 처음으로 | 다음
oci_statement_type | 위로 | OCICancel


OCICancel

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

OCICancel -- 커서로부터 읽기를 취소한다

Description

int OCICancel ( int stmt)

커서로부터 더이상 데이터를 읽기를 원치않으면, OCICancel()함수를 쓰라.

이전 | 처음으로 | 다음
OCIBindByName | 위로 | ocicloselob


ocicloselob

(no version information, might be only in CVS)

ocicloselob -- Closes lob descriptor

Description

bool ocicloselob ( void )

참고: This function was renamed to oci_lob_close() after PHP >= 5.0.0. For downward compatibility ocicloselob() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
OCICancel | 위로 | ocicollappend


ocicollappend

(PHP 4 >= 4.0.6, PHP 5)

ocicollappend -- Append an object to the collection

Description

bool ocicollappend ( string value)

참고: This function was renamed to oci_collection_append() after PHP >= 5.0.0. For downward compatibility ocicollappend() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
ocicloselob | 위로 | ocicollassign


ocicollassign

(PHP 4 >= 4.0.6)

ocicollassign -- Assign a collection from another existing collection

Description

bool ocicollassign ( object from)

참고: This function was renamed to oci_collection_assign() after PHP >= 5.0.0. For downward compatibility ocicollassign() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
ocicollappend | 위로 | ocicollassignelem


ocicollassignelem

(PHP 4 >= 4.0.6, PHP 5)

ocicollassignelem -- Assign element val to collection at index ndx

Description

bool ocicollassignelem ( int ndx, string val)

참고: This function was renamed to oci_collection_element_assign() after PHP >= 5.0.0. For downward compatibility ocicollassignelem() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
ocicollassign | 위로 | ocicollgetelem


ocicollgetelem

(PHP 4 >= 4.0.6, PHP 5)

ocicollgetelem -- Retrieve the value at collection index ndx

Description

string ocicollgetelem ( int ndx)

참고: This function was renamed to oci_collection_element_get() after PHP >= 5.0.0. For downward compatibility ocicollgetelem() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
ocicollassignelem | 위로 | ocicollmax


ocicollmax

(PHP 4 >= 4.0.6, PHP 5)

ocicollmax -- Return the max value of a collection. For a varray this is the maximum length of the array

Description

int ocicollmax ( void )

참고: This function was renamed to oci_collection_max() after PHP >= 5.0.0. For downward compatibility ocicollmax() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
ocicollgetelem | 위로 | ocicollsize


ocicollsize

(PHP 4 >= 4.0.6, PHP 5)

ocicollsize -- Return the size of a collection

Description

int ocicollsize ( void )

참고: This function was renamed to oci_collection_size() after PHP >= 5.0.0. For downward compatibility ocicollsize() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
ocicollmax | 위로 | ocicolltrim


ocicolltrim

(PHP 4 >= 4.0.6, PHP 5)

ocicolltrim -- Trim num elements from the end of a collection

Description

bool ocicolltrim ( int num)

참고: This function was renamed to oci_collection_trim() after PHP >= 5.0.0. For downward compatibility ocicolltrim() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
ocicollsize | 위로 | OCIColumnIsNULL


OCIColumnIsNULL

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

OCIColumnIsNULL -- 결과 컬럼이 널(NULL)인지 테스트한다

Description

int OCIColumnIsNULL ( int stmt, mixed column)

OCIColumnIsNULL()함수는 구문 stmt의 결과값에서 리턴된 컬럼 column 값이 널(NULL)이면 TRUE를 리턴한다. col 인수를 위해 컬럼 숫자(column-number(1-Based))나 컬럼 이름(column-name)을 사용할 수 있다.

이전 | 처음으로 | 다음
ocicolltrim | 위로 | OCIColumnName


OCIColumnName

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

OCIColumnName -- 컬럼의 이름을 리턴한다.

Description

string OCIColumnName ( int stmt, int col)

OCIColumnName() 함수는 컬럼 숫자(1-based)에 부합되는 컬럼 이름을 리턴한다.

예 1. OCIColumnName

<?php
    print "<HTML><PRE>\n";
    $conn = OCILogon("scott", "tiger");
    $stmt = OCIParse($conn,"select * from emp");
    OCIExecute($stmt);
    print "<TABLE BORDER=\"1\">";
    print "<TR>";
    print "<TH>Name</TH>";
    print "<TH>Type</TH>";
    print "<TH>Length</TH>";
    print "</TR>";
    $ncols = OCINumCols($stmt);
    for ( $i = 1; $i <= $ncols; $i++ ) {
        $column_name  = OCIColumnName($stmt,$i);
        $column_type  = OCIColumnType($stmt,$i);
        $column_size  = OCIColumnSize($stmt,$i);
        print "<TR>";
        print "<TD>$column_name</TD>";
        print "<TD>$column_type</TD>";
        print "<TD>$column_size</TD>";
        print "</TR>";
    }
    OCIFreeStatement($stmt);
    OCILogoff($conn);
    print "</PRE>";
    print "</HTML>\n";
?>

See also OCINumCols(),
OCIColumnType(),
and OCIColumnSize().

이전 | 처음으로 | 다음
OCIColumnIsNULL | 위로 | ocicolumnprecision


ocicolumnprecision

(PHP 4 , PHP 5)

ocicolumnprecision -- Tell the precision of a column

Description

int ocicolumnprecision ( resource stmt, int col)

Returns precision of the field with col index (1-based).

For FLOAT columns precision is nonzero and scale is -127. If precision is 0, then columnt is NUMBER. Else it's NUMBER(precision, scale).

참고: This function was renamed to oci_field_precision() after PHP >= 5.0.0. For downward compatibility ocicolumnprecision() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
OCIColumnName | 위로 | ocicolumnscale


ocicolumnscale

(PHP 4 , PHP 5)

ocicolumnscale -- Tell the scale of a column

Description

int ocicolumnscale ( resource stmt, int col)

참고: This function was renamed to oci_field_scale() after PHP >= 5.0.0. For downward compatibility ocicolumnscale() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
ocicolumnprecision | 위로 | OCIColumnSize


OCIColumnSize

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

OCIColumnSize -- 결과 컬럼 사이즈를 리턴한다

Description

int OCIColumnSize ( int stmt, mixed column)

OCIColumnSize()함수는 오라클에 의해 주어진 컬럼의 사이즈를 리턴한다. col 인수에는 컬럼 숫자(column-number (1-Based))나 컬럼 이름을 사용할 수 있다.

예 1. OCIColumnSize

<?php
    print "<HTML><PRE>\n";
    $conn = OCILogon("scott", "tiger");
    $stmt = OCIParse($conn,"select * from emp");
    OCIExecute($stmt);
    print "<TABLE BORDER=\"1\">";
    print "<TR>";
    print "<TH>Name</TH>";
    print "<TH>Type</TH>";
    print "<TH>Length</TH>";
    print "</TR>";
    $ncols = OCINumCols($stmt);
    for ( $i = 1; $i <= $ncols; $i++ ) {
        $column_name  = OCIColumnName($stmt,$i);
        $column_type  = OCIColumnType($stmt,$i);
        $column_size  = OCIColumnSize($stmt,$i);
        print "<TR>";
        print "<TD>$column_name</TD>";
        print "<TD>$column_type</TD>";
        print "<TD>$column_size</TD>";
        print "</TR>";
    }
    print "</TABLE>";
    OCIFreeStatement($stmt);
    OCILogoff($conn);
    print "</PRE>";
    print "</HTML>\n";
?>

See also OCINumCols(),
OCIColumnName(), and
OCIColumnSize().

이전 | 처음으로 | 다음
ocicolumnscale | 위로 | OCIColumnType


OCIColumnType

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

OCIColumnType -- 컬럼의 데이터 타입을 리턴한다.

Description

mixed OCIColumnType ( int stmt, int col)

OCIColumnType()함수는 컬럼 숫자(1-based)에 부합되는 컬럼의 데이터 타입을 리턴한다.

예 1. OCIColumnType

<?php
    print "<HTML><PRE>\n";
    $conn = OCILogon("scott", "tiger");
    $stmt = OCIParse($conn,"select * from emp");
    OCIExecute($stmt);
    print "<TABLE BORDER=\"1\">";
    print "<TR>";
    print "<TH>Name</TH>";
    print "<TH>Type</TH>";
    print "<TH>Length</TH>";
    print "</TR>";
    $ncols = OCINumCols($stmt);
    for ( $i = 1; $i <= $ncols; $i++ ) {
        $column_name  = OCIColumnName($stmt,$i);
        $column_type  = OCIColumnType($stmt,$i);
        $column_size  = OCIColumnSize($stmt,$i);
        print "<TR>";
        print "<TD>$column_name</TD>";
        print "<TD>$column_type</TD>";
        print "<TD>$column_size</TD>";
        print "</TR>";
    }
    OCIFreeStatement($stmt);
    OCILogoff($conn);
    print "</PRE>";
    print "</HTML>\n";
?>

See also OCINumCols(),
OCIColumnName(),
and OCIColumnSize().

이전 | 처음으로 | 다음
OCIColumnSize | 위로 | ocicolumntyperaw


ocicolumntyperaw

(PHP 4 , PHP 5)

ocicolumntyperaw -- Tell the raw oracle data type of a column

Description

mixed ocicolumntyperaw ( resource stmt, int col)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: This function was renamed to oci_field_type_raw() after PHP >= 5.0.0. For downward compatibility ocicolumntyperaw() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
OCIColumnType | 위로 | OCICommit


OCICommit

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

OCICommit -- 미결정된 트랜잭션을 커밋시킨다.

Description

int OCICommit ( int connection)

OCICommit()함수는 오라클 접속 인수인 connection에 대해서 미결정된 모든 구문(outstanding statements)을 커밋한다.

이전 | 처음으로 | 다음
ocicolumntyperaw | 위로 | OCIDefineByName


OCIDefineByName

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

OCIDefineByName -- 한 SELECT 구문사용시 정의단계(define-step)를 위한 PHP 변수를 할당한다.

Description

int OCIDefineByName ( int stmt, string Column-Name, mixed variable [, int type])

OCIDefineByName()함수는 페치(fetch)한 컬럼을 사용자정의 PHP변수 에 할당한다. 물론, 오라클 유저는 select 구문에서 소문자 컬럼명을 쓸수 있지만, OCIDefineByName()함수의 Column-Name인수는 반드시 대문자로 적어야 한다. select 구문에서 존재하지도 않는 변수를 선언해도, 에러는 발생하지않을것이다!

추상 데이터타입(LOB/ROWID/BFILE)을 다룰 때는 OCINewDescriptor()함수를 사용하여 그 컬럼에 대한 변수영역을 미리 할당해야 한다. OCIBindByName()를 보시오.

예 1. OCIDefineByName

<?php
/* OCIDefineByPos example thies@thieso.net (980219) */

$conn = OCILogon("scott","tiger");

$stmt = OCIParse($conn,"select empno, ename from emp");

/* the define MUST be done BEFORE ociexecute! */

OCIDefineByName($stmt,"EMPNO",$empno);
OCIDefineByName($stmt,"ENAME",$ename);

OCIExecute($stmt);

while (OCIFetch($stmt)) {
    echo "empno:".$empno."\n";
    echo "ename:".$ename."\n";
}

OCIFreeStatement($stmt);
OCILogoff($conn);
?>

이전 | 처음으로 | 다음
OCICommit | 위로 | OCIError


OCIError

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

OCIError -- stmt|conn|global의 제일 마지막 에러를 리턴한다. 아무 에러도 없었다면 FALSE를 리턴한다.

Description

array OCIError ( [int stmt|conn|global])

OCIError()함수는 마지막 에러를 리턴한다. 선택적 인수stmt|conn|global가 제공되지않으면, 제일 마지막에 발행한 에러가 리턴된다. 아무 에러도 없었다면 OCIError()함수는 FALSE를 리턴한다. OCIError()함수는 연관배열(associative array)로서 에러를 리턴한다. 이 배열은 오라클 에러 코드인 code인수와 오라클 에러문자열인 message인수로 구성된다.

이전 | 처음으로 | 다음
OCIDefineByName | 위로 | OCIExecute


OCIExecute

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

OCIExecute -- SQL 구문(Statement)을 수행한다.

Description

int OCIExecute ( int statement [, int mode])

OCIExecute()함수는 미리 해석된 구문(statement)을 실행한다. (OCIParse()함수를 보라.) 선택적인 인수 mode에 execution-mode(디폴트는 OCI_COMMIT_ON_SUCCESS)를 지정할 수 있다. 각 구문이 자동적으로 커밋(commit)되지 않기를 원하면 OCI_DEFAULT로 설정하면 된다.

이전 | 처음으로 | 다음
OCIError | 위로 | OCIFetch


OCIFetch

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

OCIFetch -- 결과 버퍼(result-buffer)로 다음 열을 페치한다

Description

int OCIFetch ( int statement)

OCIFetch()함수는 다음 열(SELECT 구문을 위해)을 내부 결과 버퍼(internal result-buffer)에 페치한다.

이전 | 처음으로 | 다음
OCIExecute | 위로 | OCIFetchInto


OCIFetchInto

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

OCIFetchInto -- 결과 배열(result-array)에 다음 열을 페치한다

Description

int OCIFetchInto ( int stmt, array & result [, int mode])

OCIFetchInto()함수는 다음열(SELECT 구문을 위해)을 result배열에 페치한다. OCIFetchInto()함수는 result 변수의 이전값을 덮어 쓸것이다. 기본적으로 result변수는 NULL이 아닌 모든 컬럼의 일차원 배열을 포함할것이다.

mode인수는 이 함수의 기본값을 변화시킨다. 한개 이상의 플래그를 추가할수있다(OCI_ASSOC+OCI_RETURN_NULLS와 같이). 알려진 플래그는 다음과 같다:

OCI_ASSOC 연관배열(associative array)을 리턴한다.
OCI_NUM 키값이 0부터 시작하는 배열을 리턴한다. (디폴트)
OCI_RETURN_NULLS 빈 컬럼도 리턴한다.
OCI_RETURN_LOBSdescriptor 대신에 LOB의 값을 리턴한다.

이전 | 처음으로 | 다음
OCIFetch | 위로 | OCIFetchStatement


OCIFetchStatement

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

OCIFetchStatement -- 배열에 모든 열의 결과 값을 페치한다.

Description

int OCIFetchStatement ( int stmt, array & variable)

OCIFetchStatement()함수는 사용자 정의 배열로 결과값의 모든 열을 페치한다. OCIFetchStatement()함수는 페치된 열의 갯수를 리턴한다.

예 1. OCIFetchStatement

<?php
/* OCIFetchStatement example mbritton@verinet.com (990624) */

$conn = OCILogon("scott","tiger");

$stmt = OCIParse($conn,"select * from emp");

OCIExecute($stmt);

$nrows = OCIFetchStatement($stmt,$results);
if ( $nrows > 0 ) {
   print "<TABLE BORDER=\"1\">\n";
   print "<TR>\n";
   while ( list( $key, $val ) = each( $results ) ) {
      print "<TH>$key</TH>\n";
   }
   print "</TR>\n";

   for ( $i = 0; $i < $nrows; $i++ ) {
      reset($results);
      print "<TR>\n";
      while ( $column = each($results) ) {
         $data = $column['value'];
         print "<TD>$data[$i]</TD>\n";
      }
      print "</TR>\n";
   }
   print "</TABLE>\n";
} else {
   echo "No data found<BR>\n";
}
print "$nrows Records Selected<BR>\n";

OCIFreeStatement($stmt);
OCILogoff($conn);
?>

이전 | 처음으로 | 다음
OCIFetchInto | 위로 | ocifreecollection


ocifreecollection

(PHP 4 >= 4.1.0, PHP 5)

ocifreecollection -- Deletes collection object

Description

bool ocifreecollection ( void )

참고: This function was renamed to oci_free_collection() after PHP >= 5.0.0. For downward compatibility ocifreecollection() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
OCIFetchStatement | 위로 | OCIFreeCursor


OCIFreeCursor

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

OCIFreeCursor -- 커서(cursor)에 연관된 모든 자원을 해제한다.

Description

int OCIFreeCursor ( int stmt)

OCIFreeCursor() 함수는 자원 해제에 성공하면 TRUE를, 실패하면 FALSE를 리턴한다.

이전 | 처음으로 | 다음
ocifreecollection | 위로 | OCIFreeDesc


OCIFreeDesc

(PHP 4 , PHP 5)

OCIFreeDesc -- 큰 객체(large object) descriptor를 삭제한다.

Description

int OCIFreeDesc ( object lob)

OCIFreeDesc()함수는 성공하면 TRUE를, 실패하면 FALSE를 리턴한다.

이전 | 처음으로 | 다음
OCIFreeCursor | 위로 | OCIFreeStatement


OCIFreeStatement

(PHP 3>= 3.0.5, PHP 4 , PHP 5)

OCIFreeStatement -- 구문(statement)에 연관된 모든 자원을 해제한다.

Description

int OCIFreeStatement ( int stmt)

OCIFreeStatement()함수는 자원 해제에 성공하면 TRUE를 리턴하고, 실패하면 FALSE를 리턴한다.

이전 | 처음으로 | 다음
OCIFreeDesc | 위로 | lob->getBuffering


lob->getBuffering

(no version information, might be only in CVS)

lob->getBuffering -- Returns current state of buffering for large object

Description

bool lob->getBuffering ( void )

Returns FALSE if buffering for the large object is off and TRUE if buffering is used.

See also ocisetbufferinglob().

이전 | 처음으로 | 다음
OCIFreeStatement | 위로 | OCIInternalDebug


OCIInternalDebug

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

OCIInternalDebug -- 내부 디버그 출력을 활성화 시키거나, 비활성화 시킨다. 기본값으로 비활성화 되어있다.

Description

void OCIInternalDebug ( int onoff)

OCIInternalDebug()함수는 내부 디버그 출력을 활성화 시킨다. onoff인수를 0으로 놓으면 비활성화 되고, 1로 놓으면 활성화 된다.

이전 | 처음으로 | 다음
lob->getBuffering | 위로 | ociloadlob


ociloadlob

(PHP 4 , PHP 5)

ociloadlob -- Loads a large object

Description

string ociloadlob ( void )

참고: This function was renamed to oci_lob_load() after PHP >= 5.0.0. For downward compatibility ociloadlob() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
OCIInternalDebug | 위로 | OCILogOff


OCILogOff

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

OCILogOff -- 오라클로부터 접속을 해제한다.

Description

int OCILogOff ( int connection)

OCILogOff() 오라클 접속을 해제한다.

이전 | 처음으로 | 다음
ociloadlob | 위로 | OCILogon


OCILogon

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

OCILogon -- 오라클 데이터베이스에 접속한다.

Description

int OCILogon ( string username, string password [, string db])

OCILogon()함수는 다른 OCI 함수 호출에 필요한 접속 변수를 넘겨준다. 세번째 인수는 로컬 오라클 인스턴스명이나 tnsnames.ora 설정파일에 설정된 엔트리(entry)명이 될 수 있다. 세번째 인수를 생략할 경우, PHP는 접속할 데이터베이스를 결정하기 위해서 환경변수 ORACLE_SID(Oracle instance) 또는 TWO_TASK(tnsnames.ora)를 이용한다.

OCILogon() 함수를 사용할때마다 각 접속은 페이지 레벨에서 분배되어진다. 즉, 페이지 안에서 열린 모든 트랜잭션에 커밋(commits)과 롤백(rollbacks)이 적용되어진다는 것을 의미한다. 두개이상의 접속을 만들지라도.

아래 예제는 접속이 어떻게 분배되는가를 보여준다.

예 1. OCILogon

<?php
print "<HTML><PRE>";
$db = "";

$c1 = ocilogon("scott","tiger",$db);
$c2 = ocilogon("scott","tiger",$db);

function create_table($conn)
{ $stmt = ociparse($conn,"create table scott.hallo (test varchar2(64))");
  ociexecute($stmt);
  echo $conn." created table\n\n";
}

function drop_table($conn)
{ $stmt = ociparse($conn,"drop table scott.hallo");
  ociexecute($stmt);
  echo $conn." dropped table\n\n";
}

function insert_data($conn)
{ $stmt = ociparse($conn,"insert into scott.hallo
            values('$conn' || ' ' || to_char(sysdate,'DD-MON-YY HH24:MI:SS'))");
  ociexecute($stmt,OCI_DEFAULT);
  echo $conn." inserted hallo\n\n";
}

function delete_data($conn)
{ $stmt = ociparse($conn,"delete from scott.hallo");
  ociexecute($stmt,OCI_DEFAULT);
  echo $conn." deleted hallo\n\n";
}

function commit($conn)
{ ocicommit($conn);
  echo $conn." committed\n\n";
}

function rollback($conn)
{ ocirollback($conn);
  echo $conn." rollback\n\n";
}

function select_data($conn)
{ $stmt = ociparse($conn,"select * from scott.hallo");
  ociexecute($stmt,OCI_DEFAULT);
  echo $conn."----selecting\n\n";
  while (ocifetch($stmt))
    echo $conn." <".ociresult($stmt,"TEST").">\n\n";
  echo $conn."----done\n\n";
}

create_table($c1);
insert_data($c1);   // Insert a row using c1
insert_data($c2);   // Insert a row using c2

select_data($c1);   // Results of both inserts are returned
select_data($c2);

rollback($c1);      // Rollback using c1

select_data($c1);   // Both inserts have been rolled back
select_data($c2);

insert_data($c2);   // Insert a row using c2
commit($c2);        // commit using c2

select_data($c1);   // result of c2 insert is returned

delete_data($c1);   // delete all rows in table using c1
select_data($c1);   // no rows returned
select_data($c2);   // no rows returned
commit($c1);        // commit using c1

select_data($c1);   // no rows returned
select_data($c2);   // no rows returned

drop_table($c1);
print "</PRE></HTML>";
?>

See also OCIPLogon() and OCINLogon().

이전 | 처음으로 | 다음
OCILogOff | 위로 | ocinewcollection


ocinewcollection

(PHP 4 >= 4.0.6, PHP 5)

ocinewcollection -- Initialize a new collection

Description

object ocinewcollection ( resource connection, string tdo [, string schema])

참고: This function was renamed to oci_new_collection() after PHP >= 5.0.0. For downward compatibility ocinewcollection() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
OCILogon | 위로 | OCINewCursor


OCINewCursor

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

OCINewCursor -- 새로운 커서(구문 핸들)를 리턴한다 - ref-cursor를 연계하기위함.

Description

int OCINewCursor ( int conn)

OCINewCursor()함수는 특정 접속점에 관한 새로운 구문 핸들을 할당한다.

예 1. 스토어드 프로시저에 REF CURSOR 사용하기

<?php
// suppose your stored procedure info.output returns a ref cursor in :data

$conn = OCILogon("scott","tiger");
$curs = OCINewCursor($conn);
$stmt = OCIParse($conn,"begin info.output(:data); end;");

ocibindbyname($stmt,"data",&amp;$curs,-1,OCI_B_CURSOR);
ociexecute($stmt);
ociexecute($curs);

while (OCIFetchInto($curs,&amp;$data)) {
    var_dump($data);
}

OCIFreeCursor($stmt);
OCIFreeStatement($curs);
OCILogoff($conn);
?>

예 2. SELECT 구문에 REF CURSOR 사용하기

<?php
print "<HTML><BODY>";
$conn = OCILogon("scott","tiger");
$count_cursor = "CURSOR(select count(empno) num_emps from emp " .
                "where emp.deptno = dept.deptno) as EMPCNT from dept";
$stmt = OCIParse($conn,"select deptno,dname,$count_cursor");

ociexecute($stmt);
print "<TABLE BORDER=\"1\">";
print "<TR>";
print "<TH>DEPT NAME</TH>";
print "<TH>DEPT #</TH>";
print "<TH># EMPLOYEES</TH>";
print "</TR>";

while (OCIFetchInto($stmt,&amp;$data,OCI_ASSOC)) {
    print "<TR>";
    $dname  = $data["DNAME"];
    $deptno = $data["DEPTNO"];
    print "<TD>$dname</TD>";
    print "<TD>$deptno</TD>";
    ociexecute($data[ "EMPCNT" ]);
    while (OCIFetchInto($data[ "EMPCNT" ],&amp;$subdata,OCI_ASSOC)) {
        $num_emps = $subdata["NUM_EMPS"];
        print  "<TD>$num_emps</TD>";
    }
    print "</TR>";
}
print "</TABLE>";
print "</BODY></HTML>";
OCIFreeStatement($stmt);
OCILogoff($conn);
?>

이전 | 처음으로 | 다음
ocinewcollection | 위로 | OCINewDescriptor


OCINewDescriptor

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

OCINewDescriptor -- LOB/FILE의 비어있는 새로운 descriptor를 초기화한다 (LOB 이 기본값이다)

Description

string OCINewDescriptor ( int connection [, int type])

OCINewDescriptor()함수는 descpriptor나 LOB locator를 위한 저장공간을 할당한다. 유효한 type인수값은 OCI_D_FILE, OCI_D_LOB, OCI_D_ROWID 이다. LOB descriptor은 load, save, savefile 메쏘드를 사용할수 있고, BFILE은 load 메쏘드만 사용가능하다. See the second example usage hints.

예 1. OCINewDescriptor

<?php
    /* This script is designed to be called from a HTML form.
     * It expects $user, $password, $table, $where, and $commitsize
     * to be passed in from the form.  The script then deletes
     * the selected rows using the ROWID and commits after each
     * set of $commitsize rows. (Use with care, there is no rollback)
     */
    $conn = OCILogon($user, $password);
    $stmt = OCIParse($conn,"select rowid from $table $where");
    $rowid = OCINewDescriptor($conn,OCI_D_ROWID);
    OCIDefineByName($stmt,"ROWID",&amp;$rowid);
    OCIExecute($stmt);
    while ( OCIFetch($stmt) ) {
       $nrows = OCIRowCount($stmt);
       $delete = OCIParse($conn,"delete from $table where ROWID = :rid");
       OCIBindByName($delete,":rid",&amp;$rowid,-1,OCI_B_ROWID);
       OCIExecute($delete);
       print "$nrows\n";
       if ( ($nrows % $commitsize) == 0 ) {
           OCICommit($conn);
       }
    }
    $nrows = OCIRowCount($stmt);
    print "$nrows deleted...\n";
    OCIFreeStatement($stmt);
    OCILogoff($conn);
?>
<?php
    /* This script demonstrates file upload to LOB columns
     * The formfield used for this example looks like this
     * <form action="upload.php3" method="post" enctype="multipart/form-data">
     * <input type="file" name="lob_upload">
     * ...
     */
  if(!isset($lob_upload) || $lob_upload == 'none'){
?>
<form action="upload.php3" method="post" enctype="multipart/form-data">
Upload file: <input type="file" name="lob_upload"><br>
<input type="submit" value="Upload"> - <input type="reset">
</form>
<?php
  } else {
     // $lob_upload contains the temporary filename of the uploaded file
     $conn = OCILogon($user, $password);
     $lob = OCINewDescriptor($conn, OCI_D_LOB);
     $stmt = OCIParse($conn,"insert into $table (id, the_blob)
               values(my_seq.NEXTVAL, EMPTY_BLOB()) returning the_blob into :the_blob");
     OCIBindByName($stmt, ':the_blob', &amp;$lob, -1, OCI_B_BLOB);
     OCIExecute($stmt);
     if($lob->savefile($lob_upload)){
        OCICommit($conn);
        echo "Blob successfully uploaded\n";
     }else{
        echo "Couldn't upload Blob\n";
     }
     OCIFreeDesc($lob);
     OCIFreeStatement($stmt);
     OCILogoff($conn);
  }
?>

예 2. OCINewDescriptor

<?php
    /* Calling PL/SQL stored procedures which contain clobs as input
     * parameters (PHP 4 >= 4.0.6).
     * Example PL/SQL stored procedure signature is:
     *
     * PROCEDURE save_data
     *   Argument Name                  Type                    In/Out Default?
     *   ------------------------------ ----------------------- ------ --------
     *   KEY                            NUMBER(38)              IN
     *   DATA                           CLOB                    IN
     *
     */

    $conn = OCILogon($user, $password);
    $stmt = OCIParse($conn, "begin save_data(:key, :data); end;");
    $clob = OCINewDescriptor($conn, OCI_D_LOB);
    OCIBindByName($stmt, ':key', $key);
    OCIBindByName($stmt, ':data', $clob, -1, OCI_B_CLOB);
    $clob->WriteTemporary($data);
    OCIExecute($stmt, OCI_DEFAULT);
    OCICommit($conn);
    $clob->close();
    $clob->free();
    OCIFreeStatement($stmt);
?>

이전 | 처음으로 | 다음
OCINewCursor | 위로 | OCINLogon


OCINLogon

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

OCINLogon -- 오라클 데이터베이스에 접속하고 새로운 접속을 이용해서 로그온한다. 새로운 세션(session)을 넘겨준다.

Description

int OCINLogon ( string username, string password [, string db])

OCINLogon() 오라클8 DB에 새로운 접속을 형성하고, 로그온 한다. 세번째 인수는 로컬 오라클 인스턴스명이나 tnsnames.ora 설정파일의 엔트리(entry)명이 될수 있다. 세번째 인수가 생략되면, PHP는 접속할 오라클 데이터베이스를 결정하기 위해 환경변수 ORACLE_SID(Oracle instance)나 TWO_TASK(tnsnames.ora)를 이용한다.

OCINLogon()함수는 새로운 접속을 강제로 형성한다. 각 트랜잭션들을 분리할 필요가 있을때 사용해야 할것이다. 기본적으로, OCILogon()함수를 사용하면 접속은 페이지 레벨에서 분배되어지고, OCIPLogon()함수는 웹서버 프로세스 레벨에서 분배되어진다. OCINLogon()함수로 두개 이상의 접속을 연다면, 모든 커밋(commits)과 롤백(rollbacks)은 특정 접속에만 적용되어진다.

이 예제는 접속이 어떻게 분리되는지 보여준다.

예 1. OCINLogon

<?php
print "<HTML><PRE>";
$db = "";

$c1 = ocilogon("scott","tiger",$db);
$c2 = ocinlogon("scott","tiger",$db);

function create_table($conn)
{ $stmt = ociparse($conn,"create table scott.hallo (test
varchar2(64))");
  ociexecute($stmt);
  echo $conn." created table\n\n";
}

function drop_table($conn)
{ $stmt = ociparse($conn,"drop table scott.hallo");
  ociexecute($stmt);
  echo $conn." dropped table\n\n";
}

function insert_data($conn)
{ $stmt = ociparse($conn,"insert into scott.hallo
            values('$conn' || ' ' || to_char(sysdate,'DD-MON-YY HH24:MI:SS'))");
  ociexecute($stmt,OCI_DEFAULT);
  echo $conn." inserted hallo\n\n";
}

function delete_data($conn)
{ $stmt = ociparse($conn,"delete from scott.hallo");
  ociexecute($stmt,OCI_DEFAULT);
  echo $conn." deleted hallo\n\n";
}

function commit($conn)
{ ocicommit($conn);
  echo $conn." committed\n\n";
}

function rollback($conn)
{ ocirollback($conn);
  echo $conn." rollback\n\n";
}

function select_data($conn)
{ $stmt = ociparse($conn,"select * from scott.hallo");
  ociexecute($stmt,OCI_DEFAULT);
  echo $conn."----selecting\n\n";
  while (ocifetch($stmt))
    echo $conn." <".ociresult($stmt,"TEST").">\n\n";
  echo $conn."----done\n\n";
}

create_table($c1);
insert_data($c1);

select_data($c1);
select_data($c2);

rollback($c1);

select_data($c1);
select_data($c2);

insert_data($c2);
commit($c2);

select_data($c1);

delete_data($c1);
select_data($c1);
select_data($c2);
commit($c1);

select_data($c1);
select_data($c2);

drop_table($c1);
print "</PRE></HTML>";
?>

See also OCILogon() and OCIPLogon().

이전 | 처음으로 | 다음
OCINewDescriptor | 위로 | OCINumCols


OCINumCols

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

OCINumCols -- 구문 결과값의 컬럼의 갯수를 리턴한다

Description

int OCINumCols ( int stmt)

OCINumCols()함수는 구문에서 컬럼의 갯수를 리턴한다.

예 1. OCINumCols

<?php
    print "<HTML><PRE>\n";
    $conn = OCILogon("scott", "tiger");
    $stmt = OCIParse($conn,"select * from emp");
    OCIExecute($stmt);
    while ( OCIFetch($stmt) ) {
        print "\n";
        $ncols = OCINumCols($stmt);
        for ( $i = 1; $i <= $ncols; $i++ ) {
            $column_name  = OCIColumnName($stmt,$i);
            $column_value = OCIResult($stmt,$i);
            print $column_name . ': ' . $column_value . "\n";
        }
        print "\n";
    }
    OCIFreeStatement($stmt);
    OCILogoff($conn);
    print "</PRE>";
    print "</HTML>\n";
?>

이전 | 처음으로 | 다음
OCINLogon | 위로 | OCIParse


OCIParse

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

OCIParse -- 질의(query)를 해석하고 구문(statement)를 리턴한다

Description

int OCIParse ( int conn, strint query)

OCIParse() 함수는 conn인수를 사용하는 query를 해석한다. 질의(query)가 유효하면 구문(statement)를 리턴한다. 그렇지 않으면 FALSE를 리턴한다. query인수는 유효한 SQL 구문(statement)이나 PL/SQL블록이 될 수 있다.

이전 | 처음으로 | 다음
OCINumCols | 위로 | OCIPLogon


OCIPLogon

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

OCIPLogon -- 오라클 데이터베이스에 접속하고 영속적 DB 접속 (persistant connection) 을 이용해서 로그온한다. 또다른 새로운 세션(session)을 넘겨준다.

Description

int OCIPLogon ( string username, string password [, string db])

OCIPLogon() 오라클8 DB에 영속적인 접속을 형성하고, 로그온 한다. 세번째 인수는 로컬 오라클 인스턴스(local Oracle instanace)의 이름, 또는 tnsnames.ora설정파일의 엔트리(entry) 이름이 될수 있다. 세번째 인수가 생략되면, PHP는 접속할 오라클 데이터베이스를 결정하기 위해 환경변수 ORACLE_SID (Oracle instance)나 TWO_TASK(tnsnames.ora)를 이용한다.

See also OCILogon() and OCINLogon().

이전 | 처음으로 | 다음
OCIParse | 위로 | OCIResult


OCIResult

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

OCIResult -- 페치된 열의 컬럼 값을 리턴한다

Description

mixed OCIResult ( int statement, mixed column)

OCIResult()함수는 현재 열의 컬럼 column에 대한 데이터를 리턴한다 (OCIFetch()함수를 보라). OCIResult()함수는 추상형데이터타입(ROWID, LOB, FILE)을 제외한 문자열로서 모든 것을 리턴할 것이다.

이전 | 처음으로 | 다음
OCIPLogon | 위로 | OCIRollback


OCIRollback

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

OCIRollback -- 미결정된 트랜잭션을 롤백한다.

Description

int OCIRollback ( int connection)

OCIRollback()함수는 오라클 접속 인수 connection에 대해서 미결정된 모든 구문(outstanding statements)을 롤백 처리한다.

이전 | 처음으로 | 다음
OCIResult | 위로 | OCIRowCount


OCIRowCount

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

OCIRowCount -- 적용되어진 열의 갯수를 가져온다

Description

int OCIRowCount ( int statement)

OCIRowCount()함수는 update같은 구문에 의해 적용되어진 열의 갯수를 리턴한다. 이 함수는 select 가 리턴할 열의 갯수를 말해 주진 않을 것이다!

예 1. OCIRowCount

<?php
    print "<HTML><PRE>";
    $conn = OCILogon("scott","tiger");
    $stmt = OCIParse($conn,"create table emp2 as select * from emp");
    OCIExecute($stmt);
    print OCIRowCount($stmt) . " rows inserted.<BR>";
    OCIFreeStatement($stmt);
    $stmt = OCIParse($conn,"delete from emp2");
    OCIExecute($stmt);
    print OCIRowCount($stmt) . " rows deleted.<BR>";
    OCICommit($conn);
    OCIFreeStatement($stmt);
    $stmt = OCIParse($conn,"drop table emp2");
    OCIExecute($stmt);
    OCIFreeStatement($stmt);
    OCILogOff($conn);
    print "</PRE></HTML>";
?>

이전 | 처음으로 | 다음
OCIRollback | 위로 | ocisavelob


ocisavelob

(PHP 4 , PHP 5)

ocisavelob -- Saves a large object

Description

bool ocisavelob ( void )

참고: This function was renamed to oci_lob_save() after PHP >= 5.0.0. For downward compatibility ocisavelob() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
OCIRowCount | 위로 | ocisavelobfile


ocisavelobfile

(PHP 4 , PHP 5)

ocisavelobfile -- Saves a large object file

Description

bool ocisavelobfile ( void )

참고: This function was renamed to oci_lob_import() after PHP >= 5.0.0. For downward compatibility ocisavelobfile() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
ocisavelob | 위로 | ociserverversion


ociserverversion

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

ociserverversion -- Return a string containing server version information

Description

string ociserverversion ( resource conn)

예 1. ociserverversion() example

<?php
   $conn = OCILogon("scott", "tiger");
   echo "Server Version: " . OCIServerVersion($conn);
   OCILogOff($conn);
?>

참고: This function was renamed to oci_server_version() after PHP >= 5.0.0. For downward compatibility ociserverversion() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
ocisavelobfile | 위로 | lob->setBuffering


lob->setBuffering

(no version information, might be only in CVS)

lob->setBuffering -- Changes current state of buffering for large object

Description

bool lob->setBuffering ( bool on_off)

lob->setBuffering() sets the buffering for the large object, depending on the value of the on_off parameter. Repeated calls to lob->setBuffering() with the same flag will return TRUE. The values for on_off are: TRUE for on and FALSE for off.

Use of this function may provide perfomance improvements by buffering small reads and writes of LOBs by reducing the number of network round-trips and LOB versions. oci_lob_flush() should be used to flush buffers, when you have finished working with the large object.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also ocigetbufferinglob().

이전 | 처음으로 | 다음
ociserverversion | 위로 | OCISetPrefetch


OCISetPrefetch

(PHP 3>= 3.0.12, PHP 4 , PHP 5)

OCISetPrefetch -- 사용할 열의 갯수를 설정한다

Description

int OCISetPrefetch ( int stmt, int rows)

사용할 열의 갯수를 설정한다. 기본값은 1열이다.

이전 | 처음으로 | 다음
lob->setBuffering | 위로 | OCIStatementType


OCIStatementType

(PHP 3>= 3.0.5, PHP 4 , PHP 5)

OCIStatementType -- OCI 구문(statement)의 타입을 리턴한다.

Description

string OCIStatementType ( int stmt)

OCIStatementType() 함수는 다음중 하나를 리턴한다:

  1. "SELECT"

  2. "UPDATE"

  3. "DELETE"

  4. "INSERT"

  5. "CREATE"

  6. "DROP"

  7. "ALTER"

  8. "BEGIN"

  9. "DECLARE"

  10. "UNKNOWN"

예 1. Code examples

<?php
    print "<HTML><PRE>";
    $conn = OCILogon("scott","tiger");
    $sql  = "delete from emp where deptno = 10";

    $stmt = OCIParse($conn,$sql);
    if ( OCIStatementType($stmt) == "DELETE" ) {
        die "You are not allowed to delete from this table<BR>";
    }

    OCILogoff($conn);
    print "</PRE></HTML>";
?>

이전 | 처음으로 | 다음
OCISetPrefetch | 위로 | ociwritelobtofile


ociwritelobtofile

(PHP 4 , PHP 5)

ociwritelobtofile -- Saves a large object file

Description

bool ociwritelobtofile ( [string filename [, int start [, int length]]])

참고: This function was renamed to oci_lob_export() after PHP >= 5.0.0. For downward compatibility ociwritelobtofile() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
OCIStatementType | 위로 | ociwritetemporarylob


ociwritetemporarylob

(no version information, might be only in CVS)

ociwritetemporarylob -- Writes temporary blob

Description

bool ociwritetemporarylob ( string var [, int lob_type])

참고: This function was renamed to oci_lob_write_temporary() after PHP >= 5.0.0. For downward compatibility ociwritetemporarylob() can also be used. This is deprecated, however.

이전 | 처음으로 | 다음
ociwritelobtofile | 위로 | OpenSSL Functions


OpenSSL Functions

PHP 매뉴얼
이전 다음

LXXV. OpenSSL Functions

소개

This module uses the functions of OpenSSL for generation and verification of signatures and for sealing (encrypting) and opening (decrypting) data. OpenSSL offers many features that this module currently doesn't support. Some of these may be added in the future.

요구 사항

In order to use the OpenSSL functions you need to install the OpenSSL package. PHP-4.0.4pl1 requires OpenSSL >= 0.9.6, but PHP-4.0.5 and greater will also work with OpenSSL >= 0.9.5.

설치

To use PHP's OpenSSL support you must also compile PHP --with-openssl[=DIR].

Note to Win32 Users: In order to enable this module on a Windows environment, you must copy libeay32.dll from the DLL folder of the PHP/Win32 binary package to the SYSTEM32 folder of your windows machine. (Ex: C:\WINNT\SYSTEM32 or C:\WINDOWS\SYSTEM32)

Additionally, if you are planning to use the key generation and certificate signing functions, you will need to install a valid openssl.cnf on your system. As of PHP 4.3.0, we include a sample configuration file in the openssl folder of our win32 binary distribution. If you are using PHP 4.2.0 or later and are missing the file, you can obtain it from the OpenSSL home page or by downloading the PHP 4.3.0 release and using the configuration file from there.

Note to Win32 Users: PHP will search for the openssl.cnf using the following logic:

  • the OPENSSL_CONF environmental variable, if set, will be used as the path (including filename) of the configuration file.

  • the SSLEAY_CONF environmental variable, if set, will be used as the path (including filename) of the configuration file.

  • The file openssl.cnf will be assumed to be found in the default certificate area, as configured at the time that the openssl DLL was compiled. This is usually means that the default filename is c:\usr\local\ssl\openssl.cnf.

In your installation, you need to decide whether to install the configuration file at c:\usr\local\ssl\openssl.cnf or whether to install it someplace else and use environmental variables (possibly on a per-virtual-host basis) to locate the configuration file. Note that it is possible to override the default path from the script using the configargs of the functions that require a configuration file.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

Key/Certificate parameters

Quite a few of the openssl functions require a key or a certificate parameter. PHP 4.0.5 and earlier have to use a key or certificate resource returned by one of the openssl_get_xxx functions. Later versions may use one of the following methods:

  • Certificates

    1. An X.509 resource returned from openssl_x509_read()

    2. A string having the format file://path/to/cert.pem; the named file must contain a PEM encoded certificate

    3. A string containing the content of a certificate, PEM encoded

  • Public/Private Keys

    1. A key resource returned from openssl_get_publickey() or openssl_get_privatekey()

    2. For public keys only: an X.509 resource

    3. A string having the format file://path/to/file.pem - the named file must contain a PEM encoded certificate/private key (it may contain both)

    4. A string containing the content of a certificate/key, PEM encoded

    5. For private keys, you may also use the syntax array($key, $passphrase) where $key represents a key specified using the file:// or textual content notation above, and $passphrase represents a string containing the passphrase for that private key

Certificate Verification

When calling a function that will verify a signature/certificate, the cainfo parameter is an array containing file and directory names that specify the locations of trusted CA files. If a directory is specified, then it must be a correctly formed hashed directory as the openssl command would use.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

Purpose checking flags

X509_PURPOSE_SSL_CLIENT (integer)

X509_PURPOSE_SSL_SERVER (integer)

X509_PURPOSE_NS_SSL_SERVER (integer)

X509_PURPOSE_SMIME_SIGN (integer)

X509_PURPOSE_SMIME_ENCRYPT (integer)

X509_PURPOSE_CRL_SIGN (integer)

X509_PURPOSE_ANY (integer)

Padding flags

OPENSSL_PKCS1_PADDING (integer)

OPENSSL_SSLV23_PADDING (integer)

OPENSSL_NO_PADDING (integer)

OPENSSL_PKCS1_OAEP_PADDING (integer)

Key types

OPENSSL_KEYTYPE_RSA (integer)

OPENSSL_KEYTYPE_DSA (integer)

OPENSSL_KEYTYPE_DH (integer)

PKCS7 Flags/Constants

The S/MIME functions make use of flags which are specified using a bitfield which can include one or more of the following values:

표 1. PKCS7 CONSTANTS

Constant | Description
PKCS7_TEXT | Adds text/plain content type headers to encrypted/signed message. If decrypting or verifying, it strips those headers from the output - if the decrypted or verified message is not of MIME type text/plain then an error will occur.
PKCS7_BINARY | Normally the input message is converted to "canonical" format which is effectively using CR and LF as end of line: as required by the S/MIME specification. When this options is present, no translation occurs. This is useful when handling binary data which may not be in MIME format.
PKCS7_NOINTERN | When verifying a message, certificates (if any) included in the message are normally searched for the signing certificate. With this option only the certificates specified in the extracerts parameter of openssl_pkcs7_verify() are used. The supplied certificates can still be used as untrusted CAs however.
PKCS7_NOVERIFY | Do not verify the signers certificate of a signed message.
PKCS7_NOCHAIN | Do not chain verification of signers certificates: that is don't use the certificates in the signed message as untrusted CAs.
PKCS7_NOCERTS | When signing a message the signer's certificate is normally included - with this option it is excluded. This will reduce the size of the signed message but the verifier must have a copy of the signers certificate available locally (passed using the extracerts to openssl_pkcs7_verify() for example).
PKCS7_NOATTR | Normally when a message is signed, a set of attributes are included which include the signing time and the supported symmetric algorithms. With this option they are not included.
PKCS7_DETACHED | When signing a message, use cleartext signing with the MIME type multipart/signed. This is the default if you do not specify any flags to openssl_pkcs7_sign(). If you turn this option off, the message will be signed using opaque signing, which is more resistant to translation by mail relays but cannot be read by mail agents that do not support S/MIME.
PKCS7_NOSIGS | Don't try and verify the signatures on a message

참고: These constants were added in 4.0.6.

차례
openssl_csr_export_to_file -- Exports a CSR to a file
openssl_csr_export -- Exports a CSR as a string
openssl_csr_new -- Generates a CSR
openssl_csr_sign -- Sign a CSR with another certificate (or itself) and generate a certificate
openssl_error_string -- Return openSSL error message
openssl_free_key -- Free key resource
openssl_get_privatekey -- Get a private key
openssl_get_publickey -- Extract public key from certificate and prepare it for use
openssl_open -- Open sealed data
openssl_pkcs7_decrypt -- Decrypts an S/MIME encrypted message
openssl_pkcs7_encrypt -- Encrypt an S/MIME message
openssl_pkcs7_sign -- sign an S/MIME message
openssl_pkcs7_verify -- Verifies the signature of an S/MIME signed message
openssl_pkey_export_to_file -- Gets an exportable representation of a key into a file
openssl_pkey_export -- Gets an exportable representation of a key into a string
openssl_pkey_get_private -- Get a private key
openssl_pkey_get_public -- Extract public key from certificate and prepare it for use
openssl_pkey_new -- Generates a new private key
openssl_private_decrypt -- Decrypts data with private key
openssl_private_encrypt -- Encrypts data with private key
openssl_public_decrypt -- Decrypts data with public key
openssl_public_encrypt -- Encrypts data with public key
openssl_seal -- Seal (encrypt) data
openssl_sign -- Generate signature
openssl_verify -- Verify signature
openssl_x509_check_private_key -- Checks if a private key corresponds to a certificate
openssl_x509_checkpurpose -- Verifies if a certificate can be used for a particular purpose
openssl_x509_export_to_file -- Exports a certificate to file
openssl_x509_export -- Exports a certificate as a string
openssl_x509_free -- Free certificate resource
openssl_x509_parse -- Parse an X509 certificate and return the information as an array
openssl_x509_read -- Parse an X.509 certificate and return a resource identifier for it

이전 | 처음으로 | 다음
ociwritetemporarylob | 위로 | openssl_csr_export_to_file


openssl_csr_export_to_file

(PHP 4 >= 4.2.0, PHP 5)

openssl_csr_export_to_file -- Exports a CSR to a file

Description

bool openssl_csr_export_to_file ( resource csr, string outfilename [, bool notext])

openssl_csr_export_to_file() takes the Certificate Signing Request represented by csr and saves it as ascii-armoured text into the file named by outfilename.

The optional parameter notext affects the verbosity of the output; if it is FALSE then additional human-readable information is included in the output. The default value of notext is TRUE.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also openssl_csr_export(),
openssl_csr_new() and
openssl_csr_sign().

이전 | 처음으로 | 다음
OpenSSL Functions | 위로 | openssl_csr_export


openssl_csr_export

(PHP 4 >= 4.2.0, PHP 5)

openssl_csr_export -- Exports a CSR as a string

Description

bool openssl_csr_export ( resource csr, string &out [, bool notext])

openssl_csr_export() takes the Certificate Signing Request represented by csr and stores it as ascii-armoured text into out, which is passed by reference.

The optional parameter notext affects the verbosity of the output; if it is FALSE then additional human-readable information is included in the output. The default value of notext is TRUE.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also openssl_csr_export_to_file(),
openssl_csr_new() and
openssl_csr_sign().

이전 | 처음으로 | 다음
openssl_csr_export_to_file | 위로 | openssl_csr_new


openssl_csr_new

(PHP 4 >= 4.2.0, PHP 5)

openssl_csr_new -- Generates a CSR

Description

bool openssl_csr_new ( array dn, resource privkey [, array configargs [, array extraattribs]])

openssl_csr_new() generates a new CSR (Certificate Signing Request) based on the information provided by dn, which represents the Distinguished Name to be used in the certificate.

privkey should be set to a private key that was previously generated by openssl_pkey_new() (or otherwise obtained from the other openssl_pkey family of functions). The corresponding public portion of the key will be used to sign the CSR.

extraattribs is used to specify additional configuration options for the CSR. Both dn and extraattribs are associative arrays whose keys are converted to OIDs and applied to the relevant part of the request.

참고: You need to have a valid openssl.cnf installed for this function to operate correctly. See the notes under the installation section for more information.

By default, the information in your system openssl.conf is used to initialize the request; you can specify a configuration file section by setting the config_section_section key of configargs. You can also specify an alternative openssl configuration file by setting the value of the config key to the path of the file you want to use. The following keys, if present in configargs behave as their equivalents in the openssl.conf, as listed in the table below.

표 1. Configuration overrides

configargs key | type | openssl.conf equivalent | description
digest_alg | string | default_md | Selects which digest method to use
x509_extensions | string | x509_extensions | Selects which extensions should be used when creating an x509 certificate
req_extensions | string | req_extensions | Selects which extensions should be used when creating a CSR
private_key_bits | string | default_bits | Specifies how many bits should be used to generate a private key
private_key_type | integer | none | Specifies the type of private key to create. This can be one of OPENSSL_KEYTYPE_DSA, OPENSSL_KEYTYPE_DH or OPENSSL_KEYTYPE_RSA. The default value is OPENSSL_KEYTYPE_RSA which is currently the only supported key type.
encrypt_key | boolean | encrypt_key | Should an exported key (with passphrase) be encrypted?

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. openssl_csr_new() example - creating a self-signed-certificate

<?php
// Fill in data for the distinguished name to be used in the cert
// You must change the values of these keys to match your name and
// company, or more precisely, the name and company of the person/site
// that you are generating the certificate for.
// For SSL certificates, the commonName is usually the domain name of
// that will be using the certificate, but for S/MIME certificates,
// the commonName will be the name of the individual who will use the
// certificate.
$dn = array(
    "countryName" => "UK",
    "stateOrProvinceName" => "Somerset",
    "localityName" => "Glastonbury",
    "organizationName" => "The Brain Room Limited",
    "organizationalUnitName" => "PHP Documentation Team",
    "commonName" => "Wez Furlong",
    "emailAddress" => "wez@example.com"
);

// Generate a new private (and public) key pair
$privkey = openssl_pkey_new();

// Generate a certificate signing request
$csr = openssl_csr_new($dn, $privkey);

// You will usually want to create a self-signed certificate at this
// point until your CA fulfills your request.
// This creates a self-signed cert that is valid for 365 days
$sscert = openssl_csr_sign($csr, null, $privkey, 365);

// Now you will want to preserve your private key, CSR and self-signed
// cert so that they can be installed into your web server, mail server
// or mail client (depending on the intended use of the certificate).
// This example shows how to get those things into variables, but you
// can also store them directly into files.
// Typically, you will send the CSR on to your CA who will then issue
// you with the "real" certificate.
openssl_csr_export($csr, $csrout) and var_dump($csrout);
openssl_x509_export($sscert, $certout) and var_dump($certout);
openssl_pkey_export($privkey, $pkeyout, "mypassword") and var_dump($pkeyout);

// Show any errors that occurred here
while (($e = openssl_error_string()) !== false) {
    echo $e . "\n";
}
?>

이전 | 처음으로 | 다음
openssl_csr_export | 위로 | openssl_csr_sign


openssl_csr_sign

(PHP 4 >= 4.2.0, PHP 5)

openssl_csr_sign -- Sign a CSR with another certificate (or itself) and generate a certificate

Description

resource openssl_csr_sign ( mixed csr, mixed cacert, mixed priv_key, int days [, array configargs [, int serial]])

openssl_csr_sign() generates an x509 certificate resource from the csr previously generated by openssl_csr_new(), but it can also be the path to a PEM encoded CSR when specified as file://path/to/csr or an exported string generated by openssl_csr_export(). The generated certificate will be signed by cacert. If cacert is NULL, the generated certificate will be a self-signed certificate. priv_key is the private key that corresponds to cacert. days specifies the length of time for which the generated certificate will be valid, in days. You can finetune the CSR signing by configargs. See openssl_csr_new() for more information about configargs. Since PHP 4.3.3 you can specify the serial number of issued certificate by serial. In earlier versions, it was always 0.

Returns an x509 certificate resource on success, FALSE on failure.

참고: You need to have a valid openssl.cnf installed for this function to operate correctly. See the notes under the installation section for more information.

예 1. openssl_csr_sign() example - signing a CSR (how to implement your own CA)

<?php
// Let's assume that this script is set to receive a CSR that has
// been pasted into a textarea from another page
$csrdata = $_POST["CSR"];

// We will sign the request using our own "certificate authority"
// certificate.  You can use any certificate to sign another, but
// the process is worthless unless the signing certificate is trusted
// by the software/users that will deal with the newly signed certificate

// We need our CA cert and its private key
$cacert = "file://path/to/ca.crt";
$privkey = array("file://path/to/ca.key", "your_ca_key_passphrase");

$userscert = openssl_csr_sign($csrdata, $cacert, $privkey, 365);

// Now display the generated certificate so that the user can
// copy and paste it into their local configuration (such as a file
// to hold the certificate for their SSL server)
openssl_x509_export($usercert, $certout);
echo $certout;

// Show any errors that occurred here
while (($e = openssl_error_string()) !== false) {
    echo $e . "\n";
}
?>

이전 | 처음으로 | 다음
openssl_csr_new | 위로 | openssl_error_string


openssl_error_string

(PHP 4 >= 4.0.6, PHP 5)

openssl_error_string -- Return openSSL error message

Description

mixed openssl_error_string ( void )

Returns an error message string, or FALSE if there are no more error messages to return.

openssl_error_string() returns the last error from the openSSL library. Error messages are stacked, so this function should be called multiple times to collect all of the information.

예 1. openssl_error_string() example

<?php
// lets assume you just called an openssl function that failed
while ($msg = openssl_error_string())
    echo $msg . "<br />\n";
?>

이전 | 처음으로 | 다음
openssl_csr_sign | 위로 | openssl_free_key


openssl_free_key

(PHP 4 >= 4.0.4, PHP 5)

openssl_free_key -- Free key resource

Description

void openssl_free_key ( resource key_identifier)

openssl_free_key() frees the key associated with the specified key_identifier from memory.

이전 | 처음으로 | 다음
openssl_error_string | 위로 | openssl_get_privatekey


openssl_get_privatekey

(PHP 4 >= 4.0.4, PHP 5)

openssl_get_privatekey -- Get a private key

Description

resource openssl_get_privatekey ( mixed key [, string passphrase])

This is an alias for openssl_pkey_get_private().

이전 | 처음으로 | 다음
openssl_free_key | 위로 | openssl_get_publickey


openssl_get_publickey

(PHP 4 >= 4.0.4, PHP 5)

openssl_get_publickey -- Extract public key from certificate and prepare it for use

Description

resource openssl_get_publickey ( mixed certificate)

This is an alias for openssl_pkey_get_public().

이전 | 처음으로 | 다음
openssl_get_privatekey | 위로 | openssl_open


openssl_open

(PHP 4 >= 4.0.4, PHP 5)

openssl_open -- Open sealed data

Description

bool openssl_open ( string sealed_data, string &open_data, string env_key, mixed priv_key_id)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. If successful the opened data is returned in open_data.

openssl_open() opens (decrypts) sealed_data using the private key associated with the key identifier priv_key_id and the envelope key env_key, and fills open_data with the decrypted data. The envelope key is generated when the data are sealed and can only be used by one specific private key. See openssl_seal() for more information.

예 1. openssl_open() example

<?php
// $sealed and $env_key are assumed to contain the sealed data
// and our envelope key, both given to us by the sealer.

// fetch private key from file and ready it
$fp = fopen("/src/openssl-0.9.6/demos/sign/key.pem", "r");
$priv_key = fread($fp, 8192);
fclose($fp);
$pkeyid = openssl_get_privatekey($priv_key);

// decrypt the data and store it in $open
if (openssl_open($sealed, $open, $env_key, $pkeyid)) {
    echo "here is the opened data: ", $open;
} else {
    echo "failed to open data";
}

// free the private key from memory
openssl_free_key($pkeyid);
?>

See also openssl_seal().

이전 | 처음으로 | 다음
openssl_get_publickey | 위로 | openssl_pkcs7_decrypt


openssl_pkcs7_decrypt

(PHP 4 >= 4.0.6, PHP 5)

openssl_pkcs7_decrypt -- Decrypts an S/MIME encrypted message

Description

bool openssl_pkcs7_decrypt ( string infilename, string outfilename, mixed recipcert [, mixed recipkey])

Decrypts the S/MIME encrypted message contained in the file specified by infilename using the certificate and its associated private key specified by recipcert and recipkey.

The decrypted message is output to the file specified by outfilename

예 1. openssl_pkcs7_decrypt() example

<?php
// $cert and $key are assumed to contain your personal certificate and private
// key pair, and that you are the recipient of an S/MIME message
$infilename = "encrypted.msg";  // this file holds your encrypted message
$outfilename = "decrypted.msg"; // make sure you can write to this file

if (openssl_pkcs7_decrypt($infilename, $outfilename, $cert, $key)) {
    echo "decrypted!";
} else {
    echo "failed to decrypt!";
}
?>

이전 | 처음으로 | 다음
openssl_open | 위로 | openssl_pkcs7_encrypt


openssl_pkcs7_encrypt

(PHP 4 >= 4.0.6, PHP 5)

openssl_pkcs7_encrypt -- Encrypt an S/MIME message

Description

bool openssl_pkcs7_encrypt ( string infile, string outfile, mixed recipcerts, array headers [, int flags])

openssl_pkcs7_encrypt() takes the contents of the file named infile and encrypts them using an RC2 40-bit cipher so that they can only be read by the intended recipients specified by recipcerts, which is either a lone X.509 certificate, or an array of X.509 certificates. headers is an array of headers that will be prepended to the data after it has been encrypted. flags can be used to specify options that affect the encoding process - see PKCS7 constants. headers can be either an associative array keyed by header name, or an indexed array, where each element contains a single header line.

예 1. openssl_pkcs7_encrypt() example

<?php
// the message you want to encrypt and send to your secret agent
// in the field, known as nighthawk.  You have his certificate
// in the file nighthawk.pem
$data = <<<EOD
Nighthawk,

Top secret, for your eyes only!

The enemy is closing in! Meet me at the cafe at 8.30am
to collect your forged passport!

HQ
EOD;
// load key
$key = file_get_contents("nighthawk.pem");

// save message to file
$fp = fopen("msg.txt", "w");
fwrite($fp, $data);
fclose($fp);

// encrypt it
if (openssl_pkcs7_encrypt("msg.txt", "enc.txt", $key,
    array("To" => "nighthawk@example.com", // keyed syntax
          "From: HQ <hq@example.com>", // indexed syntax
          "Subject" => "Eyes only"))) {
    // message encrypted - send it!
    exec(ini_get("sendmail_path") . " < enc.txt");
}
?>

이전 | 처음으로 | 다음
openssl_pkcs7_decrypt | 위로 | openssl_pkcs7_sign


openssl_pkcs7_sign

(PHP 4 >= 4.0.6, PHP 5)

openssl_pkcs7_sign -- sign an S/MIME message

Description

bool openssl_pkcs7_sign ( string infilename, string outfilename, mixed signcert, mixed privkey, array headers [, int flags [, string extracerts]])

openssl_pkcs7_sign() takes the contents of the file named infilename and signs them using the certificate and its matching private key specified by signcert and privkey parameters.

headers is an array of headers that will be prepended to the data after it has been signed (see openssl_pkcs7_encrypt() for more information about the format of this parameter.

flags can be used to alter the output - see PKCS7 constants - if not specified, it defaults to PKCS7_DETACHED.

extracerts specifies the name of a file containing a bunch of extra certificates to include in the signature which can for example be used to help the recipient to verify the certificate that you used.

예 1. openssl_pkcs7_sign() example

<?php
// the message you want to sign so that recipient can be sure it was you that
// sent it
$data = <<<EOD

You have my authorization to spend $10,000 on dinner expenses.

The CEO
EOD;// save message to file
$fp = fopen("msg.txt", "w");
fwrite($fp, $data);
fclose($fp);
// encrypt it
if (openssl_pkcs7_sign("msg.txt", "signed.txt", "mycert.pem",
    array("mycert.pem", "mypassphrase"),
    array("To" => "joes@example.com", // keyed syntax
          "From" => "HQ <ceo@example.com>", // indexed syntax
          "Subject" => "Eyes only")
    )) {
    // message signed - send it!
    exec(ini_get("sendmail_path") . " < signed.txt");
}
?>

이전 | 처음으로 | 다음
openssl_pkcs7_encrypt | 위로 | openssl_pkcs7_verify


openssl_pkcs7_verify

(PHP 4 >= 4.0.6, PHP 5)

openssl_pkcs7_verify -- Verifies the signature of an S/MIME signed message

Description

bool openssl_pkcs7_verify ( string filename, int flags [, string outfilename [, array cainfo [, string extracerts]]])

openssl_pkcs7_verify() reads the S/MIME message contained in the filename specified by filename and examines the digital signature. It returns TRUE if the signature is verified, FALSE if it is not correct (the message has been tampered with, or the signing certificate is invalid), or -1 on error.

flags can be used to affect how the signature is verified - see PKCS7 constants for more information.

If the outfilename is specified, it should be a string holding the name of a file into which the certificates of the persons that signed the messages will be stored in PEM format.

If the cainfo is specified, it should hold information about the trusted CA certificates to use in the verification process - see certificate verification for more information about this parameter.

If the extracerts is specified, it is the filename of a file containing a bunch of certificates to use as untrusted CAs.

이전 | 처음으로 | 다음
openssl_pkcs7_sign | 위로 | openssl_pkey_export_to_file


openssl_pkey_export_to_file

(PHP 4 >= 4.2.0, PHP 5)

openssl_pkey_export_to_file -- Gets an exportable representation of a key into a file

Description

bool openssl_pkey_export_to_file ( mixed key, string outfilename [, string passphrase [, array configargs]])

openssl_pkey_export_to_file() saves an ascii-armoured (PEM encoded) rendition of key into the file named by outfilename. The key can be optionally protected by a passphrase. configargs can be used to fine-tune the export process by specifying and/or overriding options for the openssl configuration file. See openssl_csr_new() for more information about configargs. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: You need to have a valid openssl.cnf installed for this function to operate correctly. See the notes under the installation section for more information.

이전 | 처음으로 | 다음
openssl_pkcs7_verify | 위로 | openssl_pkey_export


openssl_pkey_export

(PHP 4 >= 4.2.0, PHP 5)

openssl_pkey_export -- Gets an exportable representation of a key into a string

Description

bool openssl_pkey_export ( mixed key, string &out [, string passphrase [, array configargs]])

openssl_pkey_export() exports key as a PEM encoded string and stores it into out (which is passed by reference). The key is optionally protected by passphrase. configargs can be used to fine-tune the export process by specifying and/or overriding options for the openssl configuration file. See openssl_csr_new() for more information about configargs. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: You need to have a valid openssl.cnf installed for this function to operate correctly. See the notes under the installation section for more information.

이전 | 처음으로 | 다음
openssl_pkey_export_to_file | 위로 | openssl_pkey_get_private


openssl_pkey_get_private

(PHP 4 >= 4.2.0, PHP 5)

openssl_pkey_get_private -- Get a private key

Description

resource openssl_get_privatekey ( mixed key [, string passphrase])

Returns a positive key resource identifier on success, or FALSE on error.

openssl_get_privatekey() parses key and prepares it for use by other functions. key can be one of the following:

  1. a string having the format file://path/to/file.pem. The named file must contain a PEM encoded certificate/private key (it may contain both).

  2. A PEM formatted private key.

The optional parameter passphrase must be used if the specified key is encrypted (protected by a passphrase).

이전 | 처음으로 | 다음
openssl_pkey_export | 위로 | openssl_pkey_get_public


openssl_pkey_get_public

(PHP 4 >= 4.2.0, PHP 5)

openssl_pkey_get_public -- Extract public key from certificate and prepare it for use

Description

resource openssl_pkey_get_public ( mixed certificate)

Returns a positive key resource identifier on success, or FALSE on error.

openssl_get_publickey() extracts the public key from certificate and prepares it for use by other functions. certificate can be one of the following:

  1. an X.509 certificate resource

  2. a string having the format file://path/to/file.pem. The named file must contain a PEM encoded certificate/private key (it may contain both).

  3. A PEM formatted private key.

이전 | 처음으로 | 다음
openssl_pkey_get_private | 위로 | openssl_pkey_new


openssl_pkey_new

(PHP 4 >= 4.2.0, PHP 5)

openssl_pkey_new -- Generates a new private key

Description

resource openssl_pkey_new ( [array configargs])

openssl_pkey_new() generates a new private and public key pair. The public component of the key can be obtained using openssl_pkey_get_public(). You can finetune the key generation (such as specifying the number of bits) using configargs. See openssl_csr_new() for more information about configargs.

참고: You need to have a valid openssl.cnf installed for this function to operate correctly. See the notes under the installation section for more information.

이전 | 처음으로 | 다음
openssl_pkey_get_public | 위로 | openssl_private_decrypt


openssl_private_decrypt

(PHP 4 >= 4.0.6, PHP 5)

openssl_private_decrypt -- Decrypts data with private key

Description

bool openssl_private_decrypt ( string data, string &decrypted, mixed key [, int padding])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

openssl_private_decrypt() decrypts data that was previous encrypted via openssl_public_encrypt() and stores the result into decrypted. key must be the private key corresponding that was used to encrypt the data. padding defaults to OPENSSL_PKCS1_PADDING, but can also be one of OPENSSL_SSLV23_PADDING, OPENSSL_PKCS1_OAEP_PADDING, OPENSSL_NO_PADDING.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

You can use this function e.g. to decrypt data which were supposed only to you.

See also openssl_public_encrypt() and openssl_public_decrypt().

이전 | 처음으로 | 다음
openssl_pkey_new | 위로 | openssl_private_encrypt


openssl_private_encrypt

(PHP 4 >= 4.0.6, PHP 5)

openssl_private_encrypt -- Encrypts data with private key

Description

bool openssl_private_encrypt ( string data, string &crypted, mixed key [, int padding])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

openssl_private_encrypt() encrypts data with private key and stores the result into crypted. Encrypted data can be decrypted via openssl_public_decrypt. padding defaults to OPENSSL_PKCS1_PADDING, but can also be OPENSSL_NO_PADDING.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

This function can be used e.g. to sign data (or its hash) to prove that it is not written by someone else.

See also openssl_public_decrypt() and openssl_public_encrypt().

이전 | 처음으로 | 다음
openssl_private_decrypt | 위로 | openssl_public_decrypt


openssl_public_decrypt

(PHP 4 >= 4.0.6, PHP 5)

openssl_public_decrypt -- Decrypts data with public key

Description

bool openssl_public_decrypt ( string data, string &decrypted, mixed key [, int padding])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

openssl_public_decrypt() decrypts data that was previous encrypted via openssl_private_encrypt() and stores the result into decrypted. key must be the public key corresponding that was used to encrypt the data. padding defaults to OPENSSL_PKCS1_PADDING, but can also be OPENSSL_NO_PADDING.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

You can use this function e.g. to check if the message was written by the owner of the private key.

See also openssl_private_encrypt() and openssl_private_decrypt().

이전 | 처음으로 | 다음
openssl_private_encrypt | 위로 | openssl_public_encrypt


openssl_public_encrypt

(PHP 4 >= 4.0.6, PHP 5)

openssl_public_encrypt -- Encrypts data with public key

Description

bool openssl_public_encrypt ( string data, string &crypted, mixed key [, int padding])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

openssl_public_encrypt() encrypts data with public key and stores the result into crypted. Encrypted data can be decrypted via openssl_private_decrypt. padding defaults to OPENSSL_PKCS1_PADDING, but can also be one of OPENSSL_SSLV23_PADDING, OPENSSL_PKCS1_OAEP_PADDING, OPENSSL_NO_PADDING.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

This function can be used e.g. to encrypt message which can be then read only by owner of the private key. It can be also used to store secure data in database.

See also openssl_private_decrypt() and openssl_private_encrypt().

이전 | 처음으로 | 다음
openssl_public_decrypt | 위로 | openssl_seal


openssl_seal

(PHP 4 >= 4.0.4, PHP 5)

openssl_seal -- Seal (encrypt) data

Description

int openssl_seal ( string data, string &sealed_data, array &env_keys, array pub_key_ids)

Returns the length of the sealed data on success, or FALSE on error. If successful the sealed data is returned in sealed_data, and the envelope keys in env_keys.

openssl_seal() seals (encrypts) data by using RC4 with a randomly generated secret key. The key is encrypted with each of the public keys associated with the identifiers in pub_key_ids and each encrypted key is returned in env_keys. This means that one can send sealed data to multiple recipients (provided one has obtained their public keys). Each recipient must receive both the sealed data and the envelope key that was encrypted with the recipient's public key.

예 1. openssl_seal() example

<?php
// $data is assumed to contain the data to be sealed

// fetch public keys for our recipients, and ready them
$fp = fopen("/src/openssl-0.9.6/demos/maurice/cert.pem", "r");
$cert = fread($fp, 8192);
fclose($fp);
$pk1 = openssl_get_publickey($cert);
// Repeat for second recipient
$fp = fopen("/src/openssl-0.9.6/demos/sign/cert.pem", "r");
$cert = fread($fp, 8192);
fclose($fp);
$pk2 = openssl_get_publickey($cert);

// seal message, only owners of $pk1 and $pk2 can decrypt $sealed with keys
// $ekeys[0] and $ekeys[1] respectively.
openssl_seal($data, $sealed, $ekeys, array($pk1, $pk2));

// free the keys from memory
openssl_free_key($pk1);
openssl_free_key($pk2);
?>

See also openssl_open().

이전 | 처음으로 | 다음
openssl_public_encrypt | 위로 | openssl_sign


openssl_sign

(PHP 4 >= 4.0.4, PHP 5)

openssl_sign -- Generate signature

Description

bool openssl_sign ( string data, string signature, mixed priv_key_id)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. If successful the signature is returned in signature.

openssl_sign() computes a signature for the specified data by using SHA1 for hashing followed by encryption using the private key associated with priv_key_id. Note that the data itself is not encrypted.

예 1. openssl_sign() example

<?php
// $data is assumed to contain the data to be signed

// fetch private key from file and ready it
$fp = fopen("/src/openssl-0.9.6/demos/sign/key.pem", "r");
$priv_key = fread($fp, 8192);
fclose($fp);
$pkeyid = openssl_get_privatekey($priv_key);

// compute signature
openssl_sign($data, $signature, $pkeyid);

// free the key from memory
openssl_free_key($pkeyid);
?>

See also openssl_verify().

이전 | 처음으로 | 다음
openssl_seal | 위로 | openssl_verify


openssl_verify

(PHP 4 >= 4.0.4, PHP 5)

openssl_verify -- Verify signature

Description

int openssl_verify ( string data, string signature, mixed pub_key_id)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Returns 1 if the signature is correct, 0 if it is incorrect, and -1 on error.

openssl_verify() verifies that the signature is correct for the specified data using the public key associated with pub_key_id. This must be the public key corresponding to the private key used for signing.

예 1. openssl_verify() example

<?php
// $data and $signature are assumed to contain the data and the signature

// fetch public key from certificate and ready it
$fp = fopen("/src/openssl-0.9.6/demos/sign/cert.pem", "r");
$cert = fread($fp, 8192);
fclose($fp);
$pubkeyid = openssl_get_publickey($cert);

// state whether signature is okay or not
$ok = openssl_verify($data, $signature, $pubkeyid);
if ($ok == 1) {
    echo "good";
} elseif ($ok == 0) {
    echo "bad";
} else {
    echo "ugly, error checking signature";
}
// free the key from memory
openssl_free_key($pubkeyid);
?>

See also openssl_sign().

이전 | 처음으로 | 다음
openssl_sign | 위로 | openssl_x509_check_private_key


openssl_x509_check_private_key

(PHP 4 >= 4.2.0, PHP 5)

openssl_x509_check_private_key -- Checks if a private key corresponds to a certificate

Description

bool openssl_x509_check_private_key ( mixed cert, mixed key)

openssl_x509_check_private_key() returns TRUE if key is the private key that corresponds to cert, or FALSE otherwise.

이전 | 처음으로 | 다음
openssl_verify | 위로 | openssl_x509_checkpurpose


openssl_x509_checkpurpose

(PHP 4 >= 4.0.6, PHP 5)

openssl_x509_checkpurpose -- Verifies if a certificate can be used for a particular purpose

Description

bool openssl_x509_checkpurpose ( mixed x509cert, int purpose, array cainfo [, string untrustedfile])

Returns TRUE if the certificate can be used for the intended purpose, FALSE if it cannot, or -1 on error.

openssl_x509_checkpurpose() examines the certificate specified by x509cert to see if it can be used for the purpose specified by purpose.

cainfo should be an array of trusted CA files/dirs as described in Certificate Verification.

untrustedfile, if specified, is the name of a PEM encoded file holding certificates that can be used to help verify the certificate, although no trust in placed in the certificates that come from that file.

표 1. openssl_x509_checkpurpose() purposes

Constant | Description
X509_PURPOSE_SSL_CLIENT | Can the certificate be used for the client side of an SSL connection?
X509_PURPOSE_SSL_SERVER | Can the certificate be used for the server side of an SSL connection?
X509_PURPOSE_NS_SSL_SERVER | Can the cert be used for Netscape SSL server?
X509_PURPOSE_SMIME_SIGN | Can the cert be used to sign S/MIME email?
X509_PURPOSE_SMIME_ENCRYPT | Can the cert be used to encrypt S/MIME email?
X509_PURPOSE_CRL_SIGN | Can the cert be used to sign a certificate revocation list (CRL)?
X509_PURPOSE_ANY | Can the cert be used for Any/All purposes?
These options are not bitfields - you may specify one only!

이전 | 처음으로 | 다음
openssl_x509_check_private_key | 위로 | openssl_x509_export_to_file


openssl_x509_export_to_file

(PHP 4 >= 4.2.0, PHP 5)

openssl_x509_export_to_file -- Exports a certificate to file

Description

bool openssl_x509_export_to_file ( mixed x509, string outfilename [, bool notext])

openssl_x509_export_to_file() stores x509 into a file named by outfilename in a PEM encoded format.

The optional parameter notext affects the verbosity of the output; if it is FALSE then additional human-readable information is included in the output. The default value of notext is TRUE.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
openssl_x509_checkpurpose | 위로 | openssl_x509_export


openssl_x509_export

(PHP 4 >= 4.2.0, PHP 5)

openssl_x509_export -- Exports a certificate as a string

Description

bool openssl_x509_export ( mixed x509, string &output [, bool notext])

openssl_x509_export() stores x509 into a string named by output in a PEM encoded format.

The optional parameter notext affects the verbosity of the output; if it is FALSE then additional human-readable information is included in the output. The default value of notext is TRUE.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
openssl_x509_export_to_file | 위로 | openssl_x509_free


openssl_x509_free

(PHP 4 >= 4.0.6, PHP 5)

openssl_x509_free -- Free certificate resource

Description

void openssl_x509_free ( resource x509cert)

openssl_x509_free() frees the certificate associated with the specified x509cert resource from memory.

이전 | 처음으로 | 다음
openssl_x509_export | 위로 | openssl_x509_parse


openssl_x509_parse

(PHP 4 >= 4.0.6, PHP 5)

openssl_x509_parse -- Parse an X509 certificate and return the information as an array

Description

array openssl_x509_parse ( mixed x509cert [, bool shortnames])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

openssl_x509_parse() returns information about the supplied x509cert, including fields such as subject name, issuer name, purposes, valid from and valid to dates etc. shortnames controls how the data is indexed in the array - if shortnames is TRUE (the default) then fields will be indexed with the short name form, otherwise, the long name form will be used - e.g.: CN is the shortname form of commonName.

The structure of the returned data is (deliberately) not yet documented, as it is still subject to change.

이전 | 처음으로 | 다음
openssl_x509_free | 위로 | openssl_x509_read


openssl_x509_read

(PHP 4 >= 4.0.6, PHP 5)

openssl_x509_read -- Parse an X.509 certificate and return a resource identifier for it

Description

resource openssl_x509_read ( mixed x509certdata)

openssl_x509_read() parses the certificate supplied by x509certdata and returns a resource identifier for it.

이전 | 처음으로 | 다음
openssl_x509_parse | 위로 | Oracle Functions


Oracle Functions

PHP 매뉴얼
이전 다음

LXXVI. Oracle Functions

소개

This extension adds support for Oracle database server access. See also the OCI8 extension.

설치

You have to compile PHP with the option --with-oracle[=DIR], where DIR defaults to your environment variable ORACLE_HOME.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

ORA_BIND_INOUT (integer)

ORA_BIND_IN (integer)

ORA_BIND_OUT (integer)

ORA_FETCHINTO_ASSOC (integer)

ORA_FETCHINTO_NULLS (integer)

차례
ora_bind -- Binds a PHP variable to an Oracle parameter
ora_close -- Closes an Oracle cursor
ora_columnname -- Gets the name of an Oracle result column
ora_columnsize -- Returns the size of an Oracle result column
ora_columntype -- Gets the type of an Oracle result column
ora_commit -- Commit an Oracle transaction
ora_commitoff -- Disable automatic commit
ora_commiton -- Enable automatic commit
ora_do -- Parse, Exec, Fetch
ora_error -- Gets an Oracle error message
ora_errorcode -- Gets an Oracle error code
ora_exec -- Execute a parsed statement on an Oracle cursor
ora_fetch_into -- Fetch a row into the specified result array
ora_fetch -- Fetch a row of data from a cursor
ora_getcolumn -- Get data from a fetched column
ora_logoff -- Close an Oracle connection
ora_logon -- Open an Oracle connection
ora_numcols -- Returns the number of columns
ora_numrows -- Returns the number of rows
ora_open -- Opens an Oracle cursor
ora_parse -- Parse an SQL statement with Oracle
ora_plogon -- Open a persistent Oracle connection
ora_rollback -- Rolls back a transaction

이전 | 처음으로 | 다음
openssl_x509_read | 위로 | ora_bind


ora_bind

(PHP 3, PHP 4 , PHP 5)

ora_bind -- Binds a PHP variable to an Oracle parameter

Description

bool ora_bind ( resource cursor, string PHP_variable_name, string SQL_parameter_name, int length [, int type])

This function binds the named PHP variable with a SQL parameter. The SQL parameter must be in the form ":name". With the optional type parameter, you can define whether the SQL parameter is an in/out (0, default), in (1) or out (2) parameter. As of PHP 3.0.1, you can use the constants ORA_BIND_INOUT, ORA_BIND_IN and ORA_BIND_OUT instead of the numbers.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

ora_bind() must be called after ora_parse() and before ora_exec(). Input values can be given by assignment to the bound PHP variables, after calling ora_exec() the bound PHP variables contain the output values if available.

예 1. ora_bind() example

<?php
  ora_parse($curs, "declare tmp INTEGER; begin tmp := :in; :out := tmp; :x := 7.77; end;");
  ora_bind($curs, "result", ":x", $len, 2);
  ora_bind($curs, "input", ":in", 5, 1);
  ora_bind($curs, "output", ":out", 5, 2);
  $input = 765;
  ora_exec($curs);
  echo "Result: $result<br />Out: $output<br />In: $input";
?>

이전 | 처음으로 | 다음
Oracle Functions | 위로 | ora_close


ora_close

(PHP 3, PHP 4 , PHP 5)

ora_close -- Closes an Oracle cursor

Description

bool ora_close ( resource cursor)

This function closes a data cursor opened with ora_open().

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

이전 | 처음으로 | 다음
ora_bind | 위로 | ora_columnname


ora_columnname

(PHP 3, PHP 4 , PHP 5)

ora_columnname -- Gets the name of an Oracle result column

Description

string ora_columnname ( resource cursor, int column)

Returns the name of the field/column column on the cursor cursor. The returned name is in all uppercase letters. Column 0 is the first column.

이전 | 처음으로 | 다음
ora_close | 위로 | ora_columnsize


ora_columnsize

(PHP 3, PHP 4 , PHP 5)

ora_columnsize -- Returns the size of an Oracle result column

Description

int ora_columnsize ( resource cursor, int column)

Returns the size of the Oracle column column on the cursor cursor. Column 0 is the first column.

이전 | 처음으로 | 다음
ora_columnname | 위로 | ora_columntype


ora_columntype

(PHP 3, PHP 4 , PHP 5)

ora_columntype -- Gets the type of an Oracle result column

Description

string ora_columntype ( resource cursor, int column)

Returns the Oracle data type name of the field/column column on the cursor cursor. Column 0 is the first column. The returned type will be one of the following:

"VARCHAR2"
"VARCHAR"
"CHAR"
"NUMBER"
"LONG"
"LONG RAW"
"ROWID"
"DATE"
"CURSOR"

이전 | 처음으로 | 다음
ora_columnsize | 위로 | ora_commit


ora_commit

(PHP 3, PHP 4 , PHP 5)

ora_commit -- Commit an Oracle transaction

Description

bool ora_commit ( resource conn)

This function commits an Oracle transaction. A transaction is defined as all the changes on a given connection since the last commit/rollback, autocommit was turned off or when the connection was established.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

See also ora_commiton() and ora_commitoff().

이전 | 처음으로 | 다음
ora_columntype | 위로 | ora_commitoff


ora_commitoff

(PHP 3, PHP 4 , PHP 5)

ora_commitoff -- Disable automatic commit

Description

bool ora_commitoff ( resource conn)

This function turns off automatic commit after each ora_exec() on the given connection.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

See also ora_commiton() and ora_commit().

이전 | 처음으로 | 다음
ora_commit | 위로 | ora_commiton


ora_commiton

(PHP 3, PHP 4 , PHP 5)

ora_commiton -- Enable automatic commit

Description

bool ora_commiton ( resource conn)

This function turns on automatic commit after each ora_exec() on the given connection.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

See also ora_commitoff() and ora_commit().

이전 | 처음으로 | 다음
ora_commitoff | 위로 | ora_do


ora_do

(PHP 3, PHP 4 , PHP 5)

ora_do -- Parse, Exec, Fetch

Description

resource ora_do ( resource conn, string query)

ora_do() is quick combination of ora_parse(), ora_exec() and ora_fetch(). It will parse and execute a statement, then fetch the first result row.

This function returns a cursor index or FALSE on failure. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

See also ora_parse(),ora_exec(), and ora_fetch().

이전 | 처음으로 | 다음
ora_commiton | 위로 | ora_error


ora_error

(PHP 3, PHP 4 , PHP 5)

ora_error -- Gets an Oracle error message

Description

string ora_error ( resource cursor_or_connection)

Returns an error message of the form XXX-NNNNN where XXX is where the error comes from and NNNNN identifies the error message.

참고: Support for connection ids was added in 3.0.4.

On Unix versions of Oracle, you can find details about an error message like this: $ oerr ora 00001 00001, 00000, "unique constraint (%s.%s) violated" // *Cause: An update or insert statement attempted to insert a duplicate key // For Trusted ORACLE configured in DBMS MAC mode, you may see // this message if a duplicate entry exists at a different level. // *Action: Either remove the unique restriction or do not insert the key

이전 | 처음으로 | 다음
ora_do | 위로 | ora_errorcode


ora_errorcode

(PHP 3, PHP 4 , PHP 5)

ora_errorcode -- Gets an Oracle error code

Description

int ora_errorcode ( resource cursor_or_connection)

Returns the numeric error code of the last executed statement on the specified cursor or connection.

참고: Support for connection ids was added in 3.0.4.

이전 | 처음으로 | 다음
ora_error | 위로 | ora_exec


ora_exec

(PHP 3, PHP 4 , PHP 5)

ora_exec -- Execute a parsed statement on an Oracle cursor

Description

bool ora_exec ( resource cursor)

ora_exec() execute the parsed statement cursor, already parsed by ora_parse().

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

See also ora_parse(), ora_fetch(), and ora_do().

이전 | 처음으로 | 다음
ora_errorcode | 위로 | ora_fetch_into


ora_fetch_into

(PHP 3, PHP 4 , PHP 5)

ora_fetch_into -- Fetch a row into the specified result array

Description

int ora_fetch_into ( resource cursor, array result [, int flags])

Fetches a row of data into an array. The flags has two flag values: if the ORA_FETCHINTO_NULLS flag is set, columns with NULL values are set in the array; and if the ORA_FETCHINTO_ASSOC flag is set, an associative array is created.

Returns the number of columns fetched.

예 1. ora_fetch_into()

<?php
$results = array();
ora_fetch_into($cursor, $results);
echo $results[0];
echo $results[1];
$results = array();
ora_fetch_into($cursor, $results, ORA_FETCHINTO_NULLS|ORA_FETCHINTO_ASSOC);
echo $results['MyColumn'];
?>

See also ora_parse(),ora_exec(), ora_fetch(), and ora_do().

이전 | 처음으로 | 다음
ora_exec | 위로 | ora_fetch


ora_fetch

(PHP 3, PHP 4 , PHP 5)

ora_fetch -- Fetch a row of data from a cursor

Description

bool ora_fetch ( resource cursor)

Retrieves a row of data from the specified cursor.

Returns TRUE (a row was fetched) or FALSE (no more rows, or an
error occurred). If an error occurred, details can be retrieved
using the ora_error() and
ora_errorcode() functions. If there was no
error, ora_errorcode() will return 0.

See also ora_parse(),ora_exec(), and ora_do().

이전 | 처음으로 | 다음
ora_fetch_into | 위로 | ora_getcolumn


ora_getcolumn

(PHP 3, PHP 4 , PHP 5)

ora_getcolumn -- Get data from a fetched column

Description

mixed ora_getcolumn ( resource cursor, int column)

Fetches the data for a column or function result.

Returns the column data. If an error occurs, FALSE is returned and ora_errorcode() will return a non-zero value. Note, however, that a test for FALSE on the results from this function may be TRUE in cases where there is not error as well (NULL result, empty string, the number 0, the string "0").

이전 | 처음으로 | 다음
ora_fetch | 위로 | ora_logoff


ora_logoff

(PHP 3, PHP 4 , PHP 5)

ora_logoff -- Close an Oracle connection

Description

bool ora_logoff ( resource connection)

Logs out the user and disconnects from the server.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

See also ora_logon().

이전 | 처음으로 | 다음
ora_getcolumn | 위로 | ora_logon


ora_logon

(PHP 3, PHP 4 , PHP 5)

ora_logon -- Open an Oracle connection

Description

resource ora_logon ( string user, string password)

Establishes a connection between PHP and an Oracle database with the given username user and password password.

Connections can be made using SQL*Net by supplying the TNS name to user like this:

<?php
$conn = Ora_Logon("user@TNSNAME", "pass");
?>

If you have character data with non-ASCII characters, you should make sure that NLS_LANG is set in your environment. For server modules, you should set it in the server's environment before starting the server.

Returns a connection index on success, or FALSE on failure. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

이전 | 처음으로 | 다음
ora_logoff | 위로 | ora_numcols


ora_numcols

(PHP 3, PHP 4 , PHP 5)

ora_numcols -- Returns the number of columns

Description

int ora_numcols ( resource cursor)

ora_numcols() returns the number of columns in a result. Only returns meaningful values after an parse/exec/fetch sequence.

See also ora_parse(),ora_exec(), ora_fetch(), and ora_do().

이전 | 처음으로 | 다음
ora_logon | 위로 | ora_numrows


ora_numrows

(PHP 3, PHP 4 , PHP 5)

ora_numrows -- Returns the number of rows

Description

int ora_numrows ( resource cursor)

ora_numrows() returns the number of rows in a result.

이전 | 처음으로 | 다음
ora_numcols | 위로 | ora_open


ora_open

(PHP 3, PHP 4 , PHP 5)

ora_open -- Opens an Oracle cursor

Description

resource ora_open ( resource connection)

Opens an Oracle cursor associated with connection.

Returns a cursor index or FALSE on failure. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

이전 | 처음으로 | 다음
ora_numrows | 위로 | ora_parse


ora_parse

(PHP 3, PHP 4 , PHP 5)

ora_parse -- Parse an SQL statement with Oracle

Description

bool ora_parse ( resource cursor, string sql_statement, int defer)

This function parses an SQL statement or a PL/SQL block and associates it with the given cursor.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also ora_exec(), ora_fetch(), and ora_do().

이전 | 처음으로 | 다음
ora_open | 위로 | ora_plogon


ora_plogon

(PHP 3, PHP 4 , PHP 5)

ora_plogon -- Open a persistent Oracle connection

Description

resource ora_plogon ( string user, string password)

Establishes a persistent connection between PHP and an Oracle database with the username user and password password.

See also ora_logon().

이전 | 처음으로 | 다음
ora_parse | 위로 | ora_rollback


ora_rollback

(PHP 3, PHP 4 , PHP 5)

ora_rollback -- Rolls back a transaction

Description

bool ora_rollback ( resource connection)

This function undoes an Oracle transaction. (See ora_commit() for the definition of a transaction.)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

이전 | 처음으로 | 다음
ora_plogon | 위로 | Ovrimos SQL Functions


Ovrimos SQL Functions

PHP 매뉴얼
이전 다음

LXXVII. Ovrimos SQL Functions

소개

Ovrimos SQL Server, is a client/server, transactional RDBMS combined with Web capabilities and fast transactions.

참고: 이 확장 모듈은 윈도우 플랫폼에서는 사용할 수 없습니다.

요구 사항

You'll need to install the sqlcli library available in the Ovrimos SQL Server distribution.

설치

To enable Ovrimos support in PHP just compile PHP with the --with-ovrimos[=DIR] parameter to your configure line. DIR is the Ovrimos' libsqlcli install directory.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

예제

예 1. Connect to Ovrimos SQL Server and select from a system table

<?php
$conn = ovrimos_connect("server.domain.com", "8001", "admin", "password");
if ($conn != 0) {
    echo "Connection ok!";
    $res = ovrimos_exec($conn, "select table_id, table_name from sys.tables");
    if ($res != 0) {
        echo "Statement ok!";
        ovrimos_result_all($res);
        ovrimos_free_result($res);
    }
    ovrimos_close($conn);
}
?>
This will just connect to an Ovrimos SQL server.

차례
ovrimos_close -- Closes the connection to ovrimos
ovrimos_commit -- Commits the transaction
ovrimos_connect -- Connect to the specified database
ovrimos_cursor -- Returns the name of the cursor
ovrimos_exec -- Executes an SQL statement
ovrimos_execute -- Executes a prepared SQL statement
ovrimos_fetch_into -- Fetches a row from the result set
ovrimos_fetch_row -- Fetches a row from the result set
ovrimos_field_len -- Returns the length of the output column
ovrimos_field_name -- Returns the output column name
ovrimos_field_num -- Returns the (1-based) index of the output column
ovrimos_field_type -- Returns the (numeric) type of the output column
ovrimos_free_result -- Frees the specified result_id
ovrimos_longreadlen -- Specifies how many bytes are to be retrieved from long datatypes
ovrimos_num_fields -- Returns the number of columns
ovrimos_num_rows -- Returns the number of rows affected by update operations
ovrimos_prepare -- Prepares an SQL statement
ovrimos_result_all -- Prints the whole result set as an HTML table
ovrimos_result -- Retrieves the output column
ovrimos_rollback -- Rolls back the transaction

이전 | 처음으로 | 다음
ora_rollback | 위로 | ovrimos_close


ovrimos_close

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_close -- Closes the connection to ovrimos

Description

void ovrimos_close ( int connection)

ovrimos_close() is used to close the specified connection to Ovrimos. This has the effect of rolling back uncommitted transactions.

이전 | 처음으로 | 다음
Ovrimos SQL Functions | 위로 | ovrimos_commit


ovrimos_commit

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_commit -- Commits the transaction

Description

bool ovrimos_commit ( int connection_id)

ovrimos_commit() is used to commit the transaction. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ovrimos_close | 위로 | ovrimos_connect


ovrimos_connect

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_connect -- Connect to the specified database

Description

int ovrimos_connect ( string host, string db, string user, string password)

ovrimos_connect() is used to connect to the specified database.

ovrimos_connect() returns a connection id (greater than 0) or 0 for failure. The meaning of host and db are those used everywhere in Ovrimos APIs. host is a host name or IP address and db is either a database name, or a string containing the port number.

예 1. ovrimos_connect() Example

<?php
$conn = ovrimos_connect("server.domain.com", "8001", "admin", "password");
if ($conn != 0) {
    echo "Connection ok!";
    $res=ovrimos_exec($conn, "select table_id, table_name from sys.tables");
    if ($res != 0) {
        echo "Statement ok!";
        ovrimos_result_all($res);
        ovrimos_free_result($res);
    }
    ovrimos_close($conn);
}
?>
The above example will connect to the database and print out the specified table.

이전 | 처음으로 | 다음
ovrimos_commit | 위로 | ovrimos_cursor


ovrimos_cursor

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_cursor -- Returns the name of the cursor

Description

string ovrimos_cursor ( int result_id)

ovrimos_cursor() returns the name of the cursor. Useful when wishing to perform positioned updates or deletes.

이전 | 처음으로 | 다음
ovrimos_connect | 위로 | ovrimos_exec


ovrimos_exec

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_exec -- Executes an SQL statement

Description

int ovrimos_exec ( int connection_id, string query)

ovrimos_exec() executes an SQL statement (query or update) and returns a result_id or FALSE. Evidently, the SQL statement should not contain parameters.

이전 | 처음으로 | 다음
ovrimos_cursor | 위로 | ovrimos_execute


ovrimos_execute

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_execute -- Executes a prepared SQL statement

Description

bool ovrimos_execute ( int result_id [, array parameters_array])

ovrimos_execute() executes a prepared statement. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. If the prepared statement contained parameters (question marks in the statement), the correct number of parameters should be passed in an array. Notice that I don't follow the PHP convention of placing just the name of the optional parameter inside square brackets. I couldn't bring myself on liking it.

이전 | 처음으로 | 다음
ovrimos_exec | 위로 | ovrimos_fetch_into


ovrimos_fetch_into

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_fetch_into -- Fetches a row from the result set

Description

bool ovrimos_fetch_into ( int result_id, array result_array [, string how [, int rownumber]])

ovrimos_fetch_into() fetches a row from the result set into result_array, which should be passed by reference. Which row is fetched is determined by the two last parameters. how is one of Next (default), Prev, First, Last, Absolute, corresponding to forward direction from current position, backward direction from current position, forward direction from the start, backward direction from the end and absolute position from the start (essentially equivalent to 'first' but needs 'rownumber'). Case is not significant. rownumber is optional except for absolute positioning. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. A fetch into example

<?php
$conn=ovrimos_connect("neptune", "8001", "admin", "password");
if ($conn!=0) {
    echo "Connection ok!";
    $res=ovrimos_exec($conn, "select table_id, table_name from sys.tables");
    if ($res != 0) {
        echo "Statement ok!";
        if (ovrimos_fetch_into($res, &$row)) {
            list($table_id, $table_name) = $row;
            echo "table_id=" . $table_id . ", table_name=" . $table_name . "\n";
            if (ovrimos_fetch_into($res, &$row)) {
                list($table_id, $table_name) = $row;
                echo "table_id=" . $table_id . ", table_name=" . $table_name . "\n";
            } else {
                echo "Next: error\n";
            }
        } else {
            echo "First: error\n";
        }
        ovrimos_free_result($res);
    }
    ovrimos_close($conn);
}
?>
This example will fetch a row.

이전 | 처음으로 | 다음
ovrimos_execute | 위로 | ovrimos_fetch_row


ovrimos_fetch_row

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_fetch_row -- Fetches a row from the result set

Description

bool ovrimos_fetch_row ( int result_id [, int how [, int row_number]])

ovrimos_fetch_row() fetches a row from the result set. Column values should be retrieved with other calls. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. A fetch row example

<?php
$conn = ovrimos_connect("remote.host", "8001", "admin", "password");
if ($conn != 0) {
    echo "Connection ok!";
    $res=ovrimos_exec($conn, "select table_id, table_name from sys.tables");
    if ($res != 0) {
        echo "Statement ok!";
        if (ovrimos_fetch_row($res, "First")) {
            $table_id = ovrimos_result($res, 1);
            $table_name = ovrimos_result($res, 2);
            echo "table_id=" . $table_id . ", table_name=" . $table_name . "\n";
            if (ovrimos_fetch_row($res, "Next")) {
                $table_id = ovrimos_result($res, "table_id");
                $table_name = ovrimos_result($res, "table_name");
                echo "table_id=" . $table_id . ", table_name=" . $table_name . "\n";
            } else {
                echo "Next: error\n";
            }
        } else {
            echo "First: error\n";
        }
        ovrimos_free_result($res);
    }
    ovrimos_close($conn);
}
?>
This will fetch a row and print the result.

이전 | 처음으로 | 다음
ovrimos_fetch_into | 위로 | ovrimos_field_len


ovrimos_field_len

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_field_len -- Returns the length of the output column

Description

int ovrimos_field_len ( int result_id, int field_number)

ovrimos_field_len() is used to get the length of the output column with number field_number (1-based), in result result_id.

이전 | 처음으로 | 다음
ovrimos_fetch_row | 위로 | ovrimos_field_name


ovrimos_field_name

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_field_name -- Returns the output column name

Description

string ovrimos_field_name ( int result_id, int field_number)

ovrimos_field_name() returns the output column name at the (1-based) index specified.

이전 | 처음으로 | 다음
ovrimos_field_len | 위로 | ovrimos_field_num


ovrimos_field_num

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_field_num -- Returns the (1-based) index of the output column

Description

int ovrimos_field_num ( int result_id, string field_name)

ovrimos_field_num() returns the (1-based) index of the output column specified by field_name, or FALSE.

이전 | 처음으로 | 다음
ovrimos_field_name | 위로 | ovrimos_field_type


ovrimos_field_type

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_field_type -- Returns the (numeric) type of the output column

Description

int ovrimos_field_type ( int result_id, int field_number)

ovrimos_field_type() returns the (numeric) type of the output column at the (1-based) index specified by field_number.

이전 | 처음으로 | 다음
ovrimos_field_num | 위로 | ovrimos_free_result


ovrimos_free_result

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_free_result -- Frees the specified result_id

Description

bool ovrimos_free_result ( int result_id)

ovrimos_free_result() frees the specified result_id. Returns TRUE.

이전 | 처음으로 | 다음
ovrimos_field_type | 위로 | ovrimos_longreadlen


ovrimos_longreadlen

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_longreadlen -- Specifies how many bytes are to be retrieved from long datatypes

Description

bool ovrimos_longreadlen ( int result_id, int length)

ovrimos_longreadlen() specifies how many bytes are to be retrieved from long datatypes (long varchar and long varbinary). Default is zero. It currently sets this parameter the specified result set. Returns TRUE.

이전 | 처음으로 | 다음
ovrimos_free_result | 위로 | ovrimos_num_fields


ovrimos_num_fields

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_num_fields -- Returns the number of columns

Description

int ovrimos_num_fields ( int result_id)

ovrimos_num_fields() returns the number of columns in a result_id resulting from a query.

이전 | 처음으로 | 다음
ovrimos_longreadlen | 위로 | ovrimos_num_rows


ovrimos_num_rows

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_num_rows -- Returns the number of rows affected by update operations

Description

int ovrimos_num_rows ( int result_id)

ovrimos_num_rows() returns the number of rows affected by update operations.

이전 | 처음으로 | 다음
ovrimos_num_fields | 위로 | ovrimos_prepare


ovrimos_prepare

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_prepare -- Prepares an SQL statement

Description

int ovrimos_prepare ( int connection_id, string query)

ovrimos_prepare() prepares an SQL statement and returns a result_id (or FALSE on failure).

예 1. Connect to Ovrimos SQL Server and prepare a statement

<?php
$conn=ovrimos_connect("db_host", "8001", "admin", "password");
if ($conn!=0) {
    echo "Connection ok!";
    $res=ovrimos_prepare($conn, "select table_id, table_name
                                  from sys.tables where table_id=1");
    if ($res != 0) {
        echo "Prepare ok!";
        if (ovrimos_execute($res)) {
            echo "Execute ok!\n";
            ovrimos_result_all($res);
        } else {
            echo "Execute not ok!";
        }
        ovrimos_free_result($res);
    } else {
        echo "Prepare not ok!\n";
    }
    ovrimos_close($conn);
}
?>
This will connect to Ovrimos SQL Server, prepare a statement and the execute it.

이전 | 처음으로 | 다음
ovrimos_num_rows | 위로 | ovrimos_result_all


ovrimos_result_all

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_result_all -- Prints the whole result set as an HTML table

Description

int ovrimos_result_all ( int result_id [, string format])

ovrimos_result_all() prints the whole result set as an HTML table. Returns the number of rows in the generated table.

예 1. Prepare a statement, execute, and view the result

<?php
$conn = ovrimos_connect("db_host", "8001", "admin", "password");
if ($conn != 0) {
    echo "Connection ok!";
    $res = ovrimos_prepare($conn, "select table_id, table_name
                                    from sys.tables where table_id = 7");
    if ($res != 0) {
        echo "Prepare ok!";
        if (ovrimos_execute($res, array(3))) {
            echo "Execute ok!\n";
            ovrimos_result_all($res);
        } else {
            echo "Execute not ok!";
        }
        ovrimos_free_result($res);
    } else {
        echo "Prepare not ok!\n";
    }
    ovrimos_close($conn);
}
?>
This will execute an SQL statement and print the result in an HTML table.

예 2. ovrimos_result_all() with meta-information

<?php
$conn = ovrimos_connect("db_host", "8001", "admin", "password");
if ($conn != 0) {
    echo "Connection ok!";
    $res = ovrimos_exec($conn, "select table_id, table_name
                                 from sys.tables where table_id = 1");
    if ($res != 0) {
        echo "Statement ok! cursor=" . ovrimos_cursor($res) . "\n";
        $colnb = ovrimos_num_fields($res);
        echo "Output columns=" . $colnb . "\n";
        for ($i=1; $i <= $colnb; $i++) {
            $name = ovrimos_field_name($res, $i);
            $type = ovrimos_field_type($res, $i);
            $len = ovrimos_field_len($res, $i);
            echo "Column " . $i . " name=" . $name . " type=" . $type . " len=" . $len . "\n";
        }
        ovrimos_result_all($res);
        ovrimos_free_result($res);
    }
    ovrimos_close($conn);
}
?>

예 3. ovrimos_result_all() example

<?php
$conn = ovrimos_connect("db_host", "8001", "admin", "password");
if ($conn != 0) {
    echo "Connection ok!";
    $res = ovrimos_exec($conn, "update test set i=5");
    if ($res != 0) {
        echo "Statement ok!";
        echo ovrimos_num_rows($res)." rows affected\n";
        ovrimos_free_result($res);
    }
    ovrimos_close($conn);
}
?>

이전 | 처음으로 | 다음
ovrimos_prepare | 위로 | ovrimos_result


ovrimos_result

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_result -- Retrieves the output column

Description

string ovrimos_result ( int result_id, mixed field)

ovrimos_result() retrieves the output column specified by field, either as a string or as an 1-based index. Returns FALSE on failure.

이전 | 처음으로 | 다음
ovrimos_result_all | 위로 | ovrimos_rollback


ovrimos_rollback

(PHP 4 >= 4.0.3, PHP 5)

ovrimos_rollback -- Rolls back the transaction

Description

bool ovrimos_rollback ( int connection_id)

ovrimos_rollback() is used to roll back the transaction. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
ovrimos_result | 위로 | 출력 제어 함수


출력 제어 함수

PHP 매뉴얼
이전 다음

LXXVIII. 출력 제어 함수

소개

출력 제어 함수는 스크립트의 출력 전송을 제어할 수 있도록 합니다. 이는 여러 상황에서, 특히 스크립트가 브라우저로 데이터를 출력한 뒤에 헤더를 전송할 필요가 있을 경우에 유용합니다. 출력 제어 함수는 header()나 setcookie()를 사용하는 헤더 전송에는 영향을 주지 않으며, echo() 등의 함수나 PHP 코드 블럭 사이의 데이터에만 적용됩니다.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. 출력 제어 설정 옵션

이름 | 기본값 | 변경가능성
output_buffering | "0" | PHP_INI_PERDIR|PHP_INI_SYSTEM
output_handler | NULL | PHP_INI_PERDIR|PHP_INI_SYSTEM
implicit_flush | "0" | PHP_INI_PERDIR|PHP_INI_SYSTEM
PHP_INI_* 상수에 대한 자세한 내용 및 정의는 ini_set()을 참고하십시오

위 설정 지시어에 대한 간단한 설명입니다.

output_buffering boolean/integer

이 지시어를 'On'으로 설정하여 모든 파일에 출력 버퍼링을 활성화 할 수 있습니다. 버퍼의 크기를 제한하려면 이 지시어의 값으로 'On' 대신 최대 바이트 수를 사용하십시오. (예. output_buffering=4096)

output_handler string

스크립트의 모든 출력을 어떤 함수를 통하게 할 수 있습니다. 예를 들면, output_handler를 mb_output_handler()로 설정하면, 문자 인코딩을 지정한 인코딩으로 변경할 수 있습니다. 출력 핸들러 설정은 자동적으로 출력 버퍼링을 켭니다.

참고:
      mb_output_hadler()와
      ob_iconv_handler()를 동시에 사용할 수 없고,
      ob_gzhandler()와 zlib.output_compression도
      동시에 사용할 수 없습니다.

implicit_flush boolean

기본값으로 FALSE입니다. TRUE로 변경하면 PHP가 모든 출력 블럭 뒤에 바로 전송하도록 출력 레이어를 설정합니다. 이는 PHP 함수 flush()를 모든 printf(), echo(), HTML 블럭 뒤에 호출하는 것과 동일합니다.

PHP를 웹 환경에서 사용할 때, 이 옵션을 켜는 것은 심각한 성능 저하를 일으킵니다. 일반적으로 디버깅 목적으로만 사용할 것을 권장합니다. CLI SAPI에서는 기본값으로 TRUE입니다.

참고: ob_implicit_flush().

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

예제

예 1. 출력 제어 예제

<?php

ob_start();
echo "Hello\n";

setcookie("cookiename", "cookiedata");

ob_end_flush();

?>

위 예제에서, echo()의 출력은
ob_end_flush()를 호출할 때까지 출력 버퍼에 저장됩니다.
그리하여 setcookie() 호출은 에러를 발생하지 않고
성공적으로 쿠키를 저장합니다. (보통은 브라우저로 데이터를 전송한 뒤에
헤더를 전송할 수 없습니다)

참고: PHP 4.1(과 4.2)에서 4.3으로 업그레이드 할 때 이전 버전의 버그로 인해, php.ini에서 implict_flush가 OFF인지 확인해야만 합니다. 그렇지 않으면 ob_start()는 어떠한 출력도 숨기지 못합니다.

참고

참고: header(), setcookie().

차례
flush -- 출력 버퍼를 비웁니다.
ob_clean -- 출력 버퍼를 지웁니다.
ob_end_clean -- 출력 버퍼를 지우고 출력 버퍼링을 종료합니다.
ob_end_flush -- 출력 버퍼를 전송하고 출력 버퍼링을 종료합니다.
ob_flush -- 출력 버퍼를 전송합니다.
ob_get_clean -- 현재 버퍼 내용을 얻은 뒤에 현재 출력 버퍼를 지웁니다.
ob_get_contents -- 출력 버퍼의 내용을 반환합니다.
ob_get_flush -- Flush the output buffer, return it as a string and turn off output buffering
ob_get_length -- 출력 버퍼의 길이를 반환합니다.
ob_get_level -- 출력 버퍼링 메카니즘의 겹친 레벨을 반환합니다.
ob_get_status -- 출력 버퍼의 상태를 얻습니다.
ob_gzhandler -- gzip 출력 버퍼를 위한 ob_start 콜백 함수입니다.
ob_implicit_flush -- 절대 출력의 여부를 결정합니다.
ob_list_handlers -- List all output handlers in use
ob_start -- 출력 버퍼링을 켭니다.
output_add_rewrite_var -- Add URL rewriter values
output_reset_rewrite_vars -- Reset URL rewriter values

이전 | 처음으로 | 다음
ovrimos_rollback | 위로 | flush


flush

(PHP 3, PHP 4 , PHP 5)

flush -- 출력 버퍼를 비웁니다.

설명

void flush ( void )

PHP가 사용하는 백엔드(CGI, 웹 서버 등)에 관계 없이 PHP의 출력 버퍼를 비웁니다. 이는 사실상 모든 출력을 사용자 브라우저에 보냅니다.

flush()는 웹 서버나 클라이언트 브라우저의 버퍼링 방식에는 영향을 주지 않습니다.

몇몇 서버들은, 특히 Win32에서, 스크립트가 종료할 때까지 결과를 브라우저에 전송하지 않고 버퍼를 지속합니다.

아파치 mod_gzip 등의 서버 모듈은 자신의 버퍼를 가지고 있기에, flush()는 데이터를 클라이언트에 즉시 전송할 수 없습니다.

브라우저도 표시하기 전에 입력을 받아들이는 버퍼를 가질 수 있습니다. 예를 들어, 넷스케이프는 줄이 끝나거나 태그가 시작할때까지 텍스트를 버퍼에 보관하고, 표는 </table>가 나올때까지 표시를 하지 않습니다.

Microsoft Internet Explorer의 몇몇 버전은 256바이트의 출력을 받았을 때만 페이지를 표시하기 시작하기에, 이러한 브라우저가 바로 표시를 나타나게 하려면 여분의 공백을 전송해두어야 합니다.

이전 | 처음으로 | 다음
출력 제어 함수 | 위로 | ob_clean


ob_clean

(PHP 4 >= 4.2.0, PHP 5)

ob_clean -- 출력 버퍼를 지웁니다.

설명

void ob_clean ( void )

출력 버퍼의 모든 내용을 버립니다.

이 함수는 ob_enc_clean()처럼 출력 버퍼를 파괴하지는 않습니다.

참고: ob_flush(),
ob_end_flush(),
ob_end_clean().

이전 | 처음으로 | 다음
flush | 위로 | ob_end_clean


ob_end_clean

(PHP 4 , PHP 5)

ob_end_clean -- 출력 버퍼를 지우고 출력 버퍼링을 종료합니다.

설명

bool ob_end_clean ( void )

이 함수는 가장 최근의 출력 버퍼의 내용을 버리고 그 출력 버퍼링을 종료합니다. ob_end_clean()를 호출하면 버퍼 내용은 버려지기 때문에, 버퍼의 내용으로 다른 작업을 하기 위해서는 ob_end_clean()를 호출하기 전에 ob_get_contents()를 호출해야 합니다. 하나의 버퍼를 버리는데 성공하면 TRUE, 그 외의 경우에는 FALSE를 반환합니다. 실패하는 원인은 활성화된 버퍼 없이 이 함수를 호출하였거나, 어떠한 이유로 인해 버퍼를 삭제할 수 없는 경우(특수 버퍼의 경우)입니다.

다음 예제는 모든 출력 버퍼를 제거하는 간단한 방법입니다:

예 1. ob_end_clean() 예제

<?php
while (@ob_end_clean());
?>

참고: 이 함수가 실패하면 E_NOTICE를 생성합니다.

불린 반환값은 PHP 4.2.0에서 추가되었습니다.

참고: ob_start(),
ob_get_contents(),
ob_flush().

이전 | 처음으로 | 다음
ob_clean | 위로 | ob_end_flush


ob_end_flush

(PHP 4 , PHP 5)

ob_end_flush -- 출력 버퍼를 전송하고 출력 버퍼링을 종료합니다.

설명

bool ob_end_flush ( void )

이 함수는 (존재한다면) 최상위 출력 버퍼의 내용을 전송하고 출력 버퍼를 종료합니다. ob_end_flush()를 호출하면 버퍼의 내용이 비워지기 때문에, 버퍼의 내용으로 다른 작업을 하려면 ob_end_flush()를 호출하기 전에 ob_get_contents()를 호출해야 합니다. 하나의 버퍼를 처리하는데 성공하면 TRUE를, 그 외의 경우에는 FALSE를 반환합니다. 실패의 원인으로는 활성화된 버퍼 없이 함수를 호출했거나, 어떠한 이유로 버퍼를 삭제할 수 없는 경우(특수 버퍼의 경우)입니다.

참고: 이 함수는 ob_get_flush()가 버퍼를 문자열로 반환하는 점을 제외하면, ob_get_flush()와 동일합니다.

다음 예제는 모든 출력 버퍼를 전송 및 종료하는 간단한 방법을 보여줍니다:

예 1. ob_end_flush() 예제

<?php
  while (@ob_end_flush());
?>

참고: 함수가 실패하면 E_NOTICE를 발생합니다.

불린 반환값은 PHP 4.2.0에서 추가되었습니다.

참고: ob_start(),
ob_get_contents(),
ob_get_flush(),
ob_flush(),
ob_end_clean().

이전 | 처음으로 | 다음
ob_end_clean | 위로 | ob_flush


ob_flush

(PHP 4 >= 4.2.0, PHP 5)

ob_flush -- 출력 버퍼를 전송합니다.

설명

void ob_flush ( void )

(존재한다면) 출력 버퍼의 내용을 전송합니다.
ob_flush()를 호출하면 버퍼 내용이 비워지기 때문에,
버퍼의 내용으로 다른 작업을 하려면 ob_flush()를
호출하기 전에 ob_get_contents()를 호출해야 합니다.

이 함수는 ob_end_flush()처럼 출력 버퍼를 종료하지는 않습니다.

참고: ob_get_contents(),
ob_clean(),
ob_end_flush(),
ob_end_clean().

이전 | 처음으로 | 다음
ob_end_flush | 위로 | ob_get_clean


ob_get_clean

(PHP 4 >= 4.3.0, PHP 5)

ob_get_clean -- 현재 버퍼 내용을 얻은 뒤에 현재 출력 버퍼를 지웁니다.

설명

string ob_get_clean ( void )

출력 버퍼의 내용을 반환하고 출력 버퍼링을 종료합니다. 출력 버퍼링이
존재하지 않으면 FALSE를 반환합니다. ob_get_clean()은
ob_get_contents()와
ob_end_clean()을 실행한 것과 동일합니다.

예 1. 간단한 ob_get_clean() 예제

<?php

ob_start();

echo "Hello World";

$out = ob_get_clean();
$out = strtolower($out);

var_dump($out);
?>

이 예제의 출력은:

string(11) "hello world"

참고: ob_start(), ob_get_contents().

이전 | 처음으로 | 다음
ob_flush | 위로 | ob_get_contents


ob_get_contents

(PHP 4 , PHP 5)

ob_get_contents -- 출력 버퍼의 내용을 반환합니다.

설명

string ob_get_contents ( void )

출력 버퍼의 내용을 반환합니다. 출력 버퍼링이 작동하고 있지 않으면 FALSE를 반환합니다.

참고: ob_start(), ob_get_length().

이전 | 처음으로 | 다음
ob_get_clean | 위로 | ob_get_flush


ob_get_flush

(PHP 4 >= 4.3.0, PHP 5)

ob_get_flush -- Flush the output buffer, return it as a string and turn off output buffering

Description

string ob_get_flush ( void )

ob_get_flush() flushs the output buffer, return it as a string and turns off output buffering. ob_get_flush() returns FALSE if no buffering is active.

참고: This function is similar to ob_end_flush(), except that this function returns the buffer as a string.

예 1. ob_get_flush() example

<?php
//using output_buffering=On
print_r(ob_list_handlers());

//save buffer in a file
$buffer = ob_get_flush();
file_put_contents('buffer.txt', $buffer);

print_r(ob_list_handlers());
?>

The above example will output:

Array
(
    [0] => default output handler
)
Array
(
)

See also ob_end_clean(),
ob_end_flush() and
ob_list_handlers().

이전 | 처음으로 | 다음
ob_get_contents | 위로 | ob_get_length


ob_get_length

(PHP 4 >= 4.0.2, PHP 5)

ob_get_length -- 출력 버퍼의 길이를 반환합니다.

설명

int ob_get_length ( void )

출력 버퍼 내용의 길이를 반환합니다. 출력 버퍼링을 활성화하지 않았을 경우 FALSE를 반환합니다.

참고: ob_start(), ob_get_contents().

이전 | 처음으로 | 다음
ob_get_flush | 위로 | ob_get_level


ob_get_level

(PHP 4 >= 4.2.0, PHP 5)

ob_get_level -- 출력 버퍼링 메카니즘의 겹친 레벨을 반환합니다.

설명

int ob_get_level ( void )

겹쳐져 있는 출력 버퍼링 핸들러의 레벨을 반환합니다. 출력 버퍼링을 하고 있지 않을 경우에는 0을 반환합니다.

참고: ob_start(), ob_get_contents().

이전 | 처음으로 | 다음
ob_get_length | 위로 | ob_get_status


ob_get_status

(PHP 4 >= 4.2.0, PHP 5)

ob_get_status -- 출력 버퍼의 상태를 얻습니다.

설명

array ob_get_status ( [bool full_status])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

출력 버퍼의 현재 상태를 반환합니다. 버퍼 상태를 가지는 배열이나, 오류가 발생하면 FALSE를 반환합니다.

참고: ob_get_level().

이전 | 처음으로 | 다음
ob_get_level | 위로 | ob_gzhandler


ob_gzhandler

(PHP 4 >= 4.0.4, PHP 5)

ob_gzhandler -- gzip 출력 버퍼를 위한 ob_start 콜백 함수입니다.

설명

string ob_gzhandler ( string buffer [, int mode])

참고: mode는 PHP 4.0.5에서 추가되었습니다.

ob_gzhandler()는 웹 페이지 압축을 지원하는 웹 브라우저에 gz-인코드 데이터를 전송하기 위한 ob_start()의 콜백 함수로 사용하도록 준비되었습니다. ob_gzhandler()가 실제로 압축 데이터를 전송하기 전에, 브라우저가 어떠한 내용 인코딩 형태("gzip", "deflate", 그 외에는 none)를 받아들이는지 확인하여, 그에 따라서 출력합니다. 웹 페이지 압축을 허용하는 올바른 헤더를 전송하는 모든 브라우저를 지원합니다.

예 1. ob_gzhandler() 예제

<?php

ob_start("ob_gzhandler");

?>
<html>
<body>
<p>This should be a compressed page.
</html>
<body>

참고: ob_start(), ob_end_flush().

참고: ob_gzhandler()와 ini.zlib.output_compression을 둘 다 사용할 수는 없습니다. ob_gzhandler()보다 ini.zlib.output_compression을 권장합니다.

이전 | 처음으로 | 다음
ob_get_status | 위로 | ob_implicit_flush


ob_implicit_flush

(PHP 4 , PHP 5)

ob_implicit_flush -- 절대 출력의 여부를 결정합니다.

설명

void ob_implicit_flush ( [int flag])

ob_implicit_flush()는 절대 출력을 켜거나 끕니다. (flag를 주지 않으면, 기본값으로 켭니다) 절대 출력은 모든 출력 호출 뒤에 flush 작동을 하기에, 따로 flush()을 호출할 필요가 없어집니다.

절대 출력을 켜면 출력 버퍼링을 비활성화하며, 출력 버퍼는 ob_end_flush()를 호출하였을 때와 동일하게 현재 출력을 전송합니다.

참고: flush(),
ob_start(),
ob_end_flush().

이전 | 처음으로 | 다음
ob_gzhandler | 위로 | ob_list_handlers


ob_list_handlers

(PHP 4 >= 4.3.0, PHP 5)

ob_list_handlers -- List all output handlers in use

Description

array ob_list_handlers ( void )

This will return an array with the output handlers in use (if any). If output_buffering is enabled, ob_list_handlers() will return "default output handler".

예 1. ob_list_handlers() example

<?php
//using output_buffering=On
print_r(ob_list_handlers());
ob_end_flush();

ob_start("ob_gzhandler");
print_r(ob_list_handlers());
ob_end_flush();
?>

The above example will output:

Array
(
    [0] => default output handler
)
Array
(
    [0] => ob_gzhandler
)

See also ob_end_clean(),
ob_end_flush(),
ob_get_flush(), and ob_start().

이전 | 처음으로 | 다음
ob_implicit_flush | 위로 | ob_start


ob_start

(PHP 4 , PHP 5)

ob_start -- 출력 버퍼링을 켭니다.

설명

bool ob_start ( [callback output_callback])

출력 버퍼링을 켭니다. 출력 버퍼링을 활성화하면, (헤더를 제외한) 스크립트의 모든 출력을 내부 버퍼에 저장하고, 실제로 전송하지 않습니다.

이 내부 버퍼의 내용은 ob_get_contents()를 사용하여 문자열 변수로 복사할 수 있습니다. 내부 버퍼에 저장한 내용을 출력하려면, ob_end_flush()를 사용하십시오. 반대로 ob_end_clean()은 버퍼 내용을 버립니다.

선택적인 output_callback 함수를 지정할 수 있습니다. 이 함수는 문자열을 인자로 받고, 문자열을 반환해야 합니다. 이 함수는 ob_end_flush()를 호출하거나, 요청이 끝날 때 출력 버퍼가 브라우저로 전송할 때 호출됩니다. output_callback은 출력 버퍼의 모든 내용을 인자로 받아서 브라우저로 전송할 새 출력 버퍼를 결과로 반환할 것이 기대됩니다. output_callback가 호출할 수 있는 함수가 아니라면, 이 함수는 FALSE를 반환합니다.

참고: PHP 4.0.4에서, ob_gzhandler()가 웹 페이지 압축을 지원하는 웹 브라우저에 gz-인코드 데이터를 전송하기 위한 방법으로 생겼습니다. ob_gzhandler()는 브라우저가 허용하는 내용 인코딩 형태를 확인하고 그에 따라 출력합니다.

참고: PHP 4.3.2 이전에는 실행할 수 없는 output_callback을 지정해도 FALSE를 반환하지 않았습니다.

출력 버퍼는 쌓여질 수 있기에, 다른 ob_start()가 활성화 중이라도 ob_start()를 호출할 수 있습니다. 단지 정확한 횟수의 ob_end_flush()를 호출하도록 하십시오. 다중 출력 콜백 함수를 활성화하면, 출력은 감싸진 순서대로 빠져나가면서 변경됩니다.

ob_end_clean(), ob_end_flush(), ob_clean(), ob_flush(), ob_start()는 콜백 함수에서 호출할 수 없습니다. 이들을 콜백 함수에서 호출할 시의 행동은 정의되어 있지 않습니다. 버퍼의 내용을 지우려면 콜백 함수에서 ""(빈 문자열)을 반환하십시오.

예 1. 사용자 정의 콜백 함수 예제

<?php

function callback($buffer)
{
  // 모든 apples를 oranges로 치환합니다.
  return (str_replace("apples", "oranges", $buffer));
}

ob_start("callback");

?>

<html>
<body>
<p>It's like comparing apples to oranges.
</body>
</html>

<?php

ob_end_flush();

?>

출력은:

<html>
<body>
<p>It's like comparing oranges to oranges.
</body>
</html>

참고: ob_get_contents(),
ob_end_flush(),
ob_end_clean(),
ob_implicit_flush(),
ob_gzhandler().

이전 | 처음으로 | 다음
ob_list_handlers | 위로 | output_add_rewrite_var


output_add_rewrite_var

(PHP 4 >= 4.3.0, PHP 5)

output_add_rewrite_var -- Add URL rewriter values

Description

bool output_add_rewrite_var ( string name, string value)

This function rewrite the URLs and forms with the given variable.

참고: This function buffers the output.

예 1. output_add_rewrite_var() example

<?php
output_add_rewrite_var('var', 'value');

// a link
echo '<a href="file.php">link</a>';

// a form
echo '<form action="script.php" method="post">
<input type="text" name="var2" />
</form>';

print_r(ob_list_handlers());
?>

The above example will output:

<a href="file.php?var=value">link</a>

<form action="script.php" method="post">
<input type="hidden" name="var" value="value" />
<input type="text" name="var2" />
</form>

Array
(
    [0] => URL-Rewriter
)

See also output_reset_rewrite_vars(), ob_flush() and ob_list_handlers().

이전 | 처음으로 | 다음
ob_start | 위로 | output_reset_rewrite_vars


output_reset_rewrite_vars

(PHP 4 >= 4.3.0, PHP 5)

output_reset_rewrite_vars -- Reset URL rewriter values

Description

bool output_reset_rewrite_vars ( void )

This function resets the URL rewriter and undo the changes made by output_add_rewrite_var() and/or by session_start() that are still in the buffer.

예 1. output_reset_rewrite_vars() example

<?php
session_start();
output_add_rewrite_var('var', 'value');

echo '<a href="file.php">link</a>';
ob_flush();

output_reset_rewrite_vars();
echo '<a href="file.php">link</a>';
?>

The above example will output:

<a href="file.php?PHPSESSID=xxx&var=value">link</a>
<a href="file.php">link</a>

See also output_add_rewrite_var(),
ob_flush(), ob_list_handlers() and
session_start().

이전 | 처음으로 | 다음
output_add_rewrite_var | 위로 | Object property and method call overloading


Object property and method call overloading

PHP 매뉴얼
이전 다음

LXXIX. Object property and method call overloading

소개

The purpose of this extension is to allow overloading of object property access and method calls. Only one function is defined in this extension, overload() which takes the name of the class that should have this functionality enabled. The class named has to define appropriate methods if it wants to have this functionality: __get(), __set() and __call() respectively for getting/setting a property, or calling a method. This way overloading can be selective. Inside these handler functions the overloading is disabled so you can access object properties normally.

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

In order to use these functions, you must compile PHP with the --enable-overload option. Starting with PHP 4.3.0 this extension is enabled by default. You can disable overload support with --disable--overload.

PHP 윈도우 버전에서는 이 확장 모듈에 대한 지원이 포함되어 있습니다. 이 함수들을 이용하기 위해서 추가로 확장 모듈을 읽어들일 필요가 없습니다.

참고: Builtin support for overload is available with PHP 4.3.0.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

예제

Some simple examples on using the overload() function:

예 1. Overloading a PHP class

<?php

class OO {
    var $a = 111;
    var $elem = array('b' => 9, 'c' => 42);

    // Callback method for getting a property
    function __get($prop_name, &$prop_value)
    {
        if (isset($this->elem[$prop_name])) {
            $prop_value = $this->elem[$prop_name];
            return true;
        } else {
            return false;
        }
    }

    // Callback method for setting a property
    function __set($prop_name, $prop_value)
    {
        $this->elem[$prop_name] = $prop_value;
        return true;
    }
}

// Here we overload the OO object
overload('OO');

$o = new OO;
echo "\$o->a: $o->a\n"; // print: $o->a:
echo "\$o->b: $o->b\n"; // print: $o->b: 9
echo "\$o->c: $o->c\n"; // print: $o->c: 42
echo "\$o->d: $o->d\n"; // print: $o->d:

// add a new item to the $elem array in OO
$o->x = 56;

// instantiate stdclass (it is built-in in PHP 4)
// $val is not overloaded!
$val = new stdclass;
$val->prop = 555;

// Set "a" to be an array with the $val object in it
// But __set() will put this in the $elem array
$o->a = array($val);
var_dump($o->a[0]->prop);

?>

주의

As this is an experimental extension, not all things work. There is no __call() support currently, you can only overload the get and set operations for properties. You cannot invoke the original overloading handlers of the class, and __set() only works to one level of property access.

차례
overload -- Enable property and method call overloading for a class

이전 | 처음으로 | 다음
output_reset_rewrite_vars | 위로 | overload


overload

(PHP 4 >= 4.2.0)

overload -- Enable property and method call overloading for a class

Description

void overload ( [string class_name])

The overload() function will enable property and method call overloading for a class identified by class_name. See an example in the introductory section of this part.

이전 | 처음으로 | 다음
Object property and method call overloading | 위로 | PDF functions


PDF functions

PHP 매뉴얼
이전 다음

LXXX. PDF functions

소개

The PDF functions in PHP can create PDF files using the PDFlib library created by Thomas Merz.

The documentation in this section is only meant to be an overview of the available functions in the PDFlib library and should not be considered an exhaustive reference. Please consult the documentation included in the source distribution of PDFlib for the full and detailed explanation of each function here. It provides a very good overview of what PDFlib is capable of doing and contains the most up-to-date documentation of all functions.

All of the functions in PDFlib and the PHP module have identical function names and parameters. You will need to understand some of the basic concepts of PDF and PostScript to efficiently use this extension. All lengths and coordinates are measured in PostScript points. There are generally 72 PostScript points to an inch, but this depends on the output resolution. Please see the PDFlib documentation included with the source distribution of PDFlib for a more thorough explanation of the coordinate system used.

Please note that most of the PDF functions require a pdfdoc as its first parameter. Please see the examples below for more information.

참고: If you're interested in alternative free PDF generators that do not utilize external PDF libraries, see this related FAQ.

요구 사항

PDFlib is available for download at http://www.pdflib.com/products/pdflib/index.html, but requires that you purchase a license for commercial use. The JPEG and TIFF libraries are required to compile this extension.

Issues with older versions of PDFlib

Any version of PHP 4 after March 9, 2000 does not support versions of PDFlib older than 3.0.

PDFlib 3.0 or greater is supported by PHP 3.0.19 and later.

설치

To get these functions to work, you have to compile PHP with --with-pdflib[=DIR]. DIR is the PDFlib base install directory, defaults to /usr/local. In addition you can specify the jpeg, tiff, and pnglibrary for PDFlib to use, which is optional for PDFlib 4.x. To do so add to your configure line the options --with-jpeg-dir[=DIR] --with-png-dir[=DIR] --with-tiff-dir[=DIR].

When using version 3.x of PDFlib, you should configure PDFlib with the option --enable-shared-pdflib.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

Confusion with old PDFlib versions

Starting with PHP 4.0.5, the PHP extension for PDFlib is officially supported by PDFlib GmbH. This means that all the functions described in the PDFlib manual (V3.00 or greater) are supported by PHP 4 with exactly the same meaning and the same parameters. Only the return values may differ from the PDFlib manual, because the PHP convention of returning FALSE was adopted. For compatibility reasons, this binding for PDFlib still supports the old functions, but they should be replaced by their new versions. PDFlib GmbH will not support any problems arising from the use of these deprecated functions.

표 1. Deprecated functions and their replacements

Old function | Replacement
pdf_put_image() | Not needed anymore.
pdf_execute_image() | Not needed anymore.
pdf_get_annotation() | pdf_get_bookmark() using the same parameters.
pdf_get_font() | pdf_get_value() passing "font" as the second parameter.
pdf_get_fontsize() | pdf_get_value() passing "fontsize" as the second parameter.
pdf_get_fontname() | pdf_get_parameter() passing "fontname" as the second parameter.
pdf_set_info_creator() | pdf_set_info() passing "Creator" as the second parameter.
pdf_set_info_title() | pdf_set_info() passing "Title" as the second parameter.
pdf_set_info_subject() | pdf_set_info() passing "Subject" as the second parameter.
pdf_set_info_author() | pdf_set_info() passing "Author" as the second parameter.
pdf_set_info_keywords() | pdf_set_info() passing "Keywords" as the second parameter.
pdf_set_leading() | pdf_set_value() passing "leading" as the second parameter.
pdf_set_text_rendering() | pdf_set_value() passing "textrendering" as the second parameter.
pdf_set_text_rise() | pdf_set_value() passing "textrise" as the second parameter.
pdf_set_horiz_scaling() | pdf_set_value() passing "horizscaling" as the second parameter.
pdf_set_text_matrix() | Not available anymore
pdf_set_char_spacing() | pdf_set_value() passing "charspacing" as the second parameter.
pdf_set_word_spacing() | pdf_set_value() passing "wordspacing" as the second parameter.
pdf_set_transition() | pdf_set_parameter() passing "transition" as the second parameter.
pdf_open() | pdf_new() plus an subsequent call of pdf_open_file()
pdf_set_font() | pdf_findfont() plus an subsequent call of pdf_setfont()
pdf_set_duration() | pdf_set_value() passing "duration" as the second parameter.
pdf_open_gif() | pdf_open_image_file() passing "gif" as the second parameter.
pdf_open_jpeg() | pdf_open_image_file() passing "jpeg" as the second parameter.
pdf_open_tiff() | pdf_open_image_file() passing "tiff" as the second parameter.
pdf_open_png() | pdf_open_image_file() passing "png" as the second parameter.
pdf_get_image_width() | pdf_get_value() passing "imagewidth" as the second parameter and the image as the third parameter.
pdf_get_image_height() | pdf_get_value() passing "imageheight" as the second parameter and the image as the third parameter.

예제

Most of the functions are fairly easy to use. The most difficult part is probably creating your first PDF document. The following example should help to get you started. It creates test.pdf with one page. The page contains the text "Times Roman outlined" in an outlined, 30pt font. The text is also underlined.

예 1. Creating a PDF document with PDFlib

<?php
$pdf = pdf_new();
pdf_open_file($pdf, "test.pdf");
pdf_set_info($pdf, "Author", "Uwe Steinmann");
pdf_set_info($pdf, "Title", "Test for PHP wrapper of PDFlib 2.0");
pdf_set_info($pdf, "Creator", "See Author");
pdf_set_info($pdf, "Subject", "Testing");
pdf_begin_page($pdf, 595, 842);
pdf_add_outline($pdf, "Page 1");
$font = pdf_findfont($pdf, "Times New Roman", "winansi", 1);
pdf_setfont($pdf, $font, 10);
pdf_set_value($pdf, "textrendering", 1);
pdf_show_xy($pdf, "Times Roman outlined", 50, 750);
pdf_moveto($pdf, 50, 740);
pdf_lineto($pdf, 330, 740);
pdf_stroke($pdf);
pdf_end_page($pdf);
pdf_close($pdf);
pdf_delete($pdf);
echo "<A HREF=getpdf.php>finished</A>";
?>
The script getpdf.php just returns the pdf document.

예 2. Outputting a precalculated PDF

<?php
$len = filesize($filename);
header("Content-type: application/pdf");
header("Content-Length: $len");
header("Content-Disposition: inline; filename=foo.pdf");
readfile($filename);
?>

The PDFlib distribution contains a more complex example which creates a page with an analog clock. Here we use the in-memory creation feature of PDFlib to alleviate the need to use temporary files. The example was converted to PHP from the PDFlib example. (The same example is available in the CLibPDF documentation.)

예 3. pdfclock example from PDFlib distribution

<?php
$radius = 200;
$margin = 20;
$pagecount = 10;

$pdf = pdf_new();

if (!pdf_open_file($pdf, "")) {
    echo error;
    exit;
};

pdf_set_parameter($pdf, "warning", "true");

pdf_set_info($pdf, "Creator", "pdf_clock.php");
pdf_set_info($pdf, "Author", "Uwe Steinmann");
pdf_set_info($pdf, "Title", "Analog Clock");

while ($pagecount-- > 0) {
    pdf_begin_page($pdf, 2 * ($radius + $margin), 2 * ($radius + $margin));

    pdf_set_parameter($pdf, "transition", "wipe");
    pdf_set_value($pdf, "duration", 0.5);

    pdf_translate($pdf, $radius + $margin, $radius + $margin);
    pdf_save($pdf);
    pdf_setrgbcolor($pdf, 0.0, 0.0, 1.0);

    /* minute strokes */
    pdf_setlinewidth($pdf, 2.0);
    for ($alpha = 0; $alpha < 360; $alpha += 6) {
        pdf_rotate($pdf, 6.0);
        pdf_moveto($pdf, $radius, 0.0);
        pdf_lineto($pdf, $radius-$margin/3, 0.0);
        pdf_stroke($pdf);
    }

    pdf_restore($pdf);
    pdf_save($pdf);

    /* 5 minute strokes */
    pdf_setlinewidth($pdf, 3.0);
    for ($alpha = 0; $alpha < 360; $alpha += 30) {
        pdf_rotate($pdf, 30.0);
        pdf_moveto($pdf, $radius, 0.0);
        pdf_lineto($pdf, $radius-$margin, 0.0);
        pdf_stroke($pdf);
    }

    $ltime = getdate();

    /* draw hour hand */
    pdf_save($pdf);
    pdf_rotate($pdf,-(($ltime['minutes']/60.0)+$ltime['hours']-3.0)*30.0);
    pdf_moveto($pdf, -$radius/10, -$radius/20);
    pdf_lineto($pdf, $radius/2, 0.0);
    pdf_lineto($pdf, -$radius/10, $radius/20);
    pdf_closepath($pdf);
    pdf_fill($pdf);
    pdf_restore($pdf);

    /* draw minute hand */
    pdf_save($pdf);
    pdf_rotate($pdf,-(($ltime['seconds']/60.0)+$ltime['minutes']-15.0)*6.0);
    pdf_moveto($pdf, -$radius/10, -$radius/20);
    pdf_lineto($pdf, $radius * 0.8, 0.0);
    pdf_lineto($pdf, -$radius/10, $radius/20);
    pdf_closepath($pdf);
    pdf_fill($pdf);
    pdf_restore($pdf);

    /* draw second hand */
    pdf_setrgbcolor($pdf, 1.0, 0.0, 0.0);
    pdf_setlinewidth($pdf, 2);
    pdf_save($pdf);
    pdf_rotate($pdf, -(($ltime['seconds'] - 15.0) * 6.0));
    pdf_moveto($pdf, -$radius/5, 0.0);
    pdf_lineto($pdf, $radius, 0.0);
    pdf_stroke($pdf);
    pdf_restore($pdf);

    /* draw little circle at center */
    pdf_circle($pdf, 0, 0, $radius/30);
    pdf_fill($pdf);

    pdf_restore($pdf);

    pdf_end_page($pdf);

    # to see some difference
    sleep(1);
}

pdf_close($pdf);

$buf = pdf_get_buffer($pdf);
$len = strlen($buf);

header("Content-type: application/pdf");
header("Content-Length: $len");
header("Content-Disposition: inline; filename=foo.pdf");
echo $buf;

pdf_delete($pdf);
?>

참고

참고: An alternative PHP module for PDF document creation based on FastIO's ClibPDF is available. Please see the ClibPDF section for details. Note that ClibPDF has a slightly different API than PDFlib.

차례
pdf_add_annotation -- Deprecated: Adds annotation
pdf_add_bookmark -- Adds bookmark for current page
pdf_add_launchlink -- Add a launch annotation for current page
pdf_add_locallink -- Add a link annotation for current page
pdf_add_note -- Sets annotation for current page
pdf_add_outline -- Deprecated: Adds bookmark for current page
pdf_add_pdflink -- Adds file link annotation for current page
pdf_add_thumbnail -- Adds thumbnail for current page
pdf_add_weblink -- Adds weblink for current page
pdf_arc -- Draws an arc (counterclockwise)
pdf_arcn -- Draws an arc (clockwise)
pdf_attach_file -- Adds a file attachment for current page
pdf_begin_page -- Starts new page
pdf_begin_pattern -- Starts new pattern
pdf_begin_template -- Starts new template
pdf_circle -- Draws a circle
pdf_clip -- Clips to current path
pdf_close_image -- Closes an image
pdf_close_pdi_page -- Close the page handle
pdf_close_pdi -- Close the input PDF document
pdf_close -- Closes a pdf resource
pdf_closepath_fill_stroke -- Closes, fills and strokes current path
pdf_closepath_stroke -- Closes path and draws line along path
pdf_closepath -- Closes path
pdf_concat -- Concatenate a matrix to the CTM
pdf_continue_text -- Outputs text in next line
pdf_curveto -- Draws a curve
pdf_delete -- Deletes a PDF object
pdf_end_page -- Ends a page
pdf_end_pattern -- Finish pattern
pdf_end_template -- Finish template
pdf_endpath -- Deprecated: Ends current path
pdf_fill_stroke -- Fills and strokes current path
pdf_fill -- Fills current path
pdf_findfont -- Prepare font for later use with pdf_setfont().
pdf_get_buffer -- Fetch the buffer containing the generated PDF data.
pdf_get_font -- Deprecated: font handling
pdf_get_fontname -- Deprecated: font handling
pdf_get_fontsize -- Deprecated: font handling
pdf_get_image_height -- Deprecated: returns height of an image
pdf_get_image_width -- Deprecated: Returns width of an image
pdf_get_majorversion -- Returns the major version number of the PDFlib
pdf_get_minorversion -- Returns the minor version number of the PDFlib
pdf_get_parameter -- Gets certain parameters
pdf_get_pdi_parameter -- Get some PDI string parameters
pdf_get_pdi_value -- Gets some PDI numerical parameters
pdf_get_value -- Gets certain numerical value
pdf_initgraphics -- Resets graphic state
pdf_lineto -- Draws a line
pdf_makespotcolor -- Makes a spotcolor
pdf_moveto -- Sets current point
pdf_new -- Creates a new pdf resource
pdf_open_CCITT -- Opens a new image file with raw CCITT data
pdf_open_file -- Opens a new pdf object
pdf_open_gif -- Deprecated: Opens a GIF image
pdf_open_image_file -- Reads an image from a file
pdf_open_image -- Versatile function for images
pdf_open_jpeg -- Deprecated: Opens a JPEG image
pdf_open_memory_image -- Opens an image created with PHP's image functions
pdf_open_pdi_page -- Prepare a page
pdf_open_pdi -- Opens a PDF file
pdf_open_png -- Deprecated: Opens a PNG image
pdf_open_tiff -- Deprecated: Opens a TIFF image
pdf_open -- Deprecated: Open a new pdf object
pdf_place_image -- Places an image on the page
pdf_place_pdi_page -- Places an image on the page
pdf_rect -- Draws a rectangle
pdf_restore -- Restores formerly saved environment
pdf_rotate -- Sets rotation
pdf_save -- Saves the current environment
pdf_scale -- Sets scaling
pdf_set_border_color -- Sets color of border around links and annotations
pdf_set_border_dash -- Sets dash style of border around links and annotations
pdf_set_border_style -- Sets style of border around links and annotations
pdf_set_char_spacing -- Deprecated: Sets character spacing
pdf_set_duration -- Deprecated: Sets duration between pages
pdf_set_font -- Deprecated: Selects a font face and size
pdf_set_horiz_scaling -- Sets horizontal scaling of text [deprecated]
pdf_set_info_author -- Deprecated: Fills the author field of the document
pdf_set_info_creator -- Deprecated: Fills the creator field of the document
pdf_set_info_keywords -- Deprecated: Fills the keywords field of the document
pdf_set_info_subject -- Deprecated: Fills the subject field of the document
pdf_set_info_title -- Deprecated: Fills the title field of the document
pdf_set_info -- Fills a field of the document information
pdf_set_leading -- Deprecated: Sets distance between text lines
pdf_set_parameter -- Sets certain parameters
pdf_set_text_matrix -- Deprecated: Sets the text matrix
pdf_set_text_pos -- Sets text position
pdf_set_text_rendering -- Deprecated: Determines how text is rendered
pdf_set_text_rise -- Deprecated: Sets the text rise
pdf_set_value -- Sets certain numerical value
pdf_set_word_spacing -- Deprecated: Sets spacing between words
pdf_setcolor -- Sets fill and stroke color
pdf_setdash -- Sets dash pattern
pdf_setflat -- Sets flatness
pdf_setfont -- Set the current font
pdf_setgray_fill -- Sets filling color to gray value
pdf_setgray_stroke -- Sets drawing color to gray value
pdf_setgray -- Sets drawing and filling color to gray value
pdf_setlinecap -- Sets linecap parameter
pdf_setlinejoin -- Sets linejoin parameter
pdf_setlinewidth -- Sets line width
pdf_setmatrix -- Sets current transformation matrix
pdf_setmiterlimit -- Sets miter limit
pdf_setpolydash -- Deprecated: Sets complicated dash pattern
pdf_setrgbcolor_fill -- Sets filling color to rgb color value
pdf_setrgbcolor_stroke -- Sets drawing color to rgb color value
pdf_setrgbcolor -- Sets drawing and filling color to rgb color value
pdf_show_boxed -- Output text in a box
pdf_show_xy -- Output text at given position
pdf_show -- Output text at current position
pdf_skew -- Skews the coordinate system
pdf_stringwidth -- Returns width of text using current font
pdf_stroke -- Draws line along path
pdf_translate -- Sets origin of coordinate system

이전 | 처음으로 | 다음
overload | 위로 | pdf_add_annotation


pdf_add_annotation

pdf_add_annotation -- Deprecated: Adds annotation

Description

This function is deprecated, use pdf_add_note() instead.

이전 | 처음으로 | 다음
PDF functions | 위로 | pdf_add_bookmark


pdf_add_bookmark

(PHP 4 >= 4.0.1, PHP 5)

pdf_add_bookmark -- Adds bookmark for current page

Description

int pdf_add_bookmark ( resource pdfdoc, string text [, int parent [, int open]])

Add a nested bookmark under parent, or a new top-level bookmark if parent = 0. Returns a bookmark descriptor which may be used as parent for subsequent nested bookmarks. If open = 1, child bookmarks will be folded out, and invisible if open = 0.

예 1. pdf_add_bookmark() example

<?php
// create a new PDF

$pdf = pdf_new();
pdf_open_file($pdf);
pdf_set_info($pdf, "Author", "Bob Nijman");

// begin a new page
pdf_begin_page($pdf, 300, 300);

// add a top-level bookmark
$bookmark = pdf_add_bookmark($pdf, "People");

// add a nested bookmark
pdf_add_bookmark($pdf, "Rasmus", $bookmark);

// and some text
pdf_set_font($pdf, "Helvetica", 20, "host");
$text = "This is R's page";
$width = pdf_stringwidth($pdf, $text);
pdf_set_text_pos($pdf, (300-$width)/2, 100);
pdf_show($pdf, $text);

// close the page and the PDF
pdf_end_page($pdf);
pdf_close($pdf);

?>

이전 | 처음으로 | 다음
pdf_add_annotation | 위로 | pdf_add_launchlink


pdf_add_launchlink

(PHP 4 >= 4.0.5, PHP 5)

pdf_add_launchlink -- Add a launch annotation for current page

Description

bool pdf_add_launchlink ( resource pdfdoc, float llx, float lly, float urx, float ury, string filename)

Adds a link to a web resource specified by filename. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pdf_add_locallink().

이전 | 처음으로 | 다음
pdf_add_bookmark | 위로 | pdf_add_locallink


pdf_add_locallink

(PHP 4 >= 4.0.5, PHP 5)

pdf_add_locallink -- Add a link annotation for current page

Description

bool pdf_add_locallink ( resource pdfdoc, float lowerleftx, float lowerlefty, float upperrightx, float upperrighty, int page, string dest)

Add a link annotation to a target within the current PDF file. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

dest is the zoom setting on the destination page, it can be one of retain, fitpage, fitwidth, fitheight or fitbbox.

See also pdf_add_launchlink().

이전 | 처음으로 | 다음
pdf_add_launchlink | 위로 | pdf_add_note


pdf_add_note

(PHP 4 >= 4.0.5, PHP 5)

pdf_add_note -- Sets annotation for current page

Description

bool pdf_add_note ( resource pdfdoc, float llx, float lly, float urx, float ury, string contents, string title, string icon, int open)

Sets an annotation for the current page. icon is one of comment, insert, note, paragraph, newparagraph, key, or help. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_add_locallink | 위로 | pdf_add_outline


pdf_add_outline

pdf_add_outline -- Deprecated: Adds bookmark for current page

Description

This function is deprecated, use pdf_add_bookmark() instead.

이전 | 처음으로 | 다음
pdf_add_note | 위로 | pdf_add_pdflink


pdf_add_pdflink

(PHP 3>= 3.0.12, PHP 4 , PHP 5)

pdf_add_pdflink -- Adds file link annotation for current page

Description

bool pdf_add_pdflink ( resource pdfdoc, float bottom_left_x, float bottom_left_y, float up_right_x, float up_right_y, string filename, int page, string dest)

Add a file link annotation (to a PDF target). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pdf_add_locallink() and pdf_add_weblink().

이전 | 처음으로 | 다음
pdf_add_outline | 위로 | pdf_add_thumbnail


pdf_add_thumbnail

(PHP 4 >= 4.0.5, PHP 5)

pdf_add_thumbnail -- Adds thumbnail for current page

Description

bool pdf_add_thumbnail ( resource pdfdoc, int image)

Adds an existing image as thumbnail for the current page. Thumbnail images must not be wider or higher than 106 pixels. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pdf_open_image(),
pdf_open_image_file(),
pdf_open_memory_image().

이전 | 처음으로 | 다음
pdf_add_pdflink | 위로 | pdf_add_weblink


pdf_add_weblink

(PHP 3>= 3.0.12, PHP 4 , PHP 5)

pdf_add_weblink -- Adds weblink for current page

Description

bool pdf_add_weblink ( resource pdfdoc, float lowerleftx, float lowerlefty, float upperrightx, float upperrighty, string url)

Add a weblink annotation to a target url on the Web. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_add_thumbnail | 위로 | pdf_arc


pdf_arc

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_arc -- Draws an arc (counterclockwise)

Description

bool pdf_arc ( resource pdfdoc, float x, float y, float r, float alpha, float beta)

Add a counterclockwise circular arc from alpha to beta degrees with center (x; y) and radius r. Actual drawing of the circle is performed by the next stroke or fill operation.

예 1. pdf_arcn() example

<?php
// prepare document
$pdf = pdf_new();
pdf_open_file($pdf, "");
pdf_begin_page($pdf, 595, 842);

// an outlined arc
pdf_arc($pdf, 200, 700, 100, 0, 90);
pdf_stroke($pdf);

// a filled arc
pdf_arc($pdf, 200, 700, 50, 0, 90);
pdf_fill($pdf);

// an outlined and filled arc
pdf_setcolor($pdf, "fill", "gray", 0.8);
pdf_arc($pdf, 400, 700, 50, 0, 90);
pdf_fill_stroke($pdf);

// finish document
pdf_end_page($pdf);
pdf_close($pdf);

header("Content-type: application/pdf");
echo pdf_get_buffer($pdf);

pdf_delete($pdf);
?>

See also: pdf_arcn(),
pdf_circle(), pdf_stroke(),
pdf_fill() and pdf_fill_stroke().

이전 | 처음으로 | 다음
pdf_add_weblink | 위로 | pdf_arcn


pdf_arcn

(PHP 4 >= 4.0.5, PHP 5)

pdf_arcn -- Draws an arc (clockwise)

Description

bool pdf_arcn ( resource pdfdoc, float x, float y, float r, float alpha, float beta)

Add a clockwise circular arc from alpha to beta degrees with center (x; y) and radius r. Actual drawing of the circle is performed by the next stroke or fill operation.

예 1. pdf_arcn() example

<?php

// prepare document
$pdf = pdf_new();
pdf_open_file($pdf, "");
pdf_begin_page($pdf, 595, 842);

// an outlined arcn
pdf_arcn($pdf, 200, 700, 100, 0, 90);
pdf_stroke($pdf);

// a filled arcn
pdf_arcn($pdf, 200, 700, 50, 0, 90);
pdf_fill($pdf);

// an outlined and filled arcn
pdf_setcolor($pdf, "fill", "gray", 0.8);
pdf_arcn($pdf, 400, 700, 50, 0, 90);
pdf_fill_stroke($pdf);

// finish document
pdf_end_page($pdf);
pdf_close($pdf);

header("Content-type: application/pdf");
echo pdf_get_buffer($pdf);

pdf_delete($pdf);
?>

See also: pdf_arc(), pdf_circle(),
pdf_stroke(), pdf_fill() and
pdf_fillstroke().

이전 | 처음으로 | 다음
pdf_arc | 위로 | pdf_attach_file


pdf_attach_file

(PHP 4 >= 4.0.5, PHP 5)

pdf_attach_file -- Adds a file attachment for current page

Description

bool pdf_attach_file ( resource pdfdoc, float llx, float lly, float urx, float ury, string filename, string description, string author, string mimetype, string icon)

Add a file attachment annotation. icon is one of graph, paperclip, pushpin, or tag. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: Only the 'Full' Acrobat software will be able to display these file attachments. All other PDF viewers will either show nothing or display a question mark.

이전 | 처음으로 | 다음
pdf_arcn | 위로 | pdf_begin_page


pdf_begin_page

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_begin_page -- Starts new page

Description

bool pdf_begin_page ( resource pdfdoc, float width, float height)

Add a new page to the document. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. The width and height are specified in points, which are 1/72 of an inch.

표 1. Common Page Sizes in Points

name | size
A0 | 2380?3368
A1 | 1684?2380
A2 | 1190?1684
A3 | 842?1190
A4 | 595?842
A5 | 421?595
A6 | 297?421
B5 | 501?709
letter (8.5"?11") | 612?792
legal (8.5"?14") | 612?1008
ledger (17"?11") | 1224?792
11"?17" | 792?1224

See also pdf_end_page().

이전 | 처음으로 | 다음
pdf_attach_file | 위로 | pdf_begin_pattern


pdf_begin_pattern

(PHP 4 >= 4.0.5, PHP 5)

pdf_begin_pattern -- Starts new pattern

Description

int pdf_begin_pattern ( resource pdfdoc, float width, float height, float xstep, float ystep, int painttype)

Starts a new pattern definition and returns a pattern handle. width, and height define the bounding box for the pattern. xstep and ystep give the repeated pattern offsets. painttype=1 means that the pattern has its own colour settings whereas a value of 2 indicates that the current colour is used when the pattern is applied.

See also pdf_end_pattern().

이전 | 처음으로 | 다음
pdf_begin_page | 위로 | pdf_begin_template


pdf_begin_template

(PHP 4 >= 4.0.5, PHP 5)

pdf_begin_template -- Starts new template

Description

int pdf_begin_template ( resource pdfdoc, float width, float height)

Start a new template definition.

이전 | 처음으로 | 다음
pdf_begin_pattern | 위로 | pdf_circle


pdf_circle

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_circle -- Draws a circle

Description

bool pdf_circle ( resource pdfdoc, float x, float y, float r)

Add a circle with center (x, y) and radius r to the current page. Actual drawing of the circle is performed by the next stroke or fill operation.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. pdf_circle() example

<?php
// prepare document
$pdf = pdf_new();
pdf_open_file($pdf, "");
pdf_begin_page($pdf, 595, 842);

// an outlined circle
pdf_circle($pdf, 200, 700, 100);
pdf_stroke($pdf);

    // a filled circle
pdf_circle($pdf, 200, 700, 50);
pdf_fill($pdf);

// an outlined and filled circle
pdf_setcolor($pdf, "fill", "gray", 0.3);
pdf_circle($pdf, 400, 700, 50);
pdf_fill_stroke($pdf);

// finish document
pdf_end_page($pdf);
pdf_close($pdf);

header("Content-type: application/pdf");
echo pdf_get_buffer($pdf);

pdf_delete($pdf);
?>

See also: pdf_arc(),
pdf_arcn(), pdf_curveto(),
pdf_stroke(), pdf_fill() and
pdf_fill_stroke().

이전 | 처음으로 | 다음
pdf_begin_template | 위로 | pdf_clip


pdf_clip

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_clip -- Clips to current path

Description

bool pdf_clip ( resource pdfdoc)

Use the current path as clipping path. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_circle | 위로 | pdf_close_image


pdf_close_image

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

pdf_close_image -- Closes an image

Description

void pdf_close_image ( resource pdfdoc, int image)

Close an image retrieved with the pdf_open_image() function.

이전 | 처음으로 | 다음
pdf_clip | 위로 | pdf_close_pdi_page


pdf_close_pdi_page

(PHP 4 >= 4.0.5, PHP 5)

pdf_close_pdi_page -- Close the page handle

Description

bool pdf_close_pdi_page ( resource pdfdoc, int pagehandle)

Close the page handle, and free all page-related resources. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_close_image | 위로 | pdf_close_pdi


pdf_close_pdi

(PHP 4 >= 4.0.5, PHP 5)

pdf_close_pdi -- Close the input PDF document

Description

bool pdf_close_pdi ( resource pdfdoc, int dochandle)

Close all open page handles, and close the input PDF document. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pdf_open_pdi().

이전 | 처음으로 | 다음
pdf_close_pdi_page | 위로 | pdf_close


pdf_close

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_close -- Closes a pdf resource

Description

bool pdf_close ( resource pdfdoc)

Close the generated PDF file, and free all document-related resources. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pdf_new().

이전 | 처음으로 | 다음
pdf_close_pdi | 위로 | pdf_closepath_fill_stroke


pdf_closepath_fill_stroke

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_closepath_fill_stroke -- Closes, fills and strokes current path

Description

bool pdf_closepath_fill_stroke ( resource pdfdoc)

Close the path, fill, and stroke it. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pdf_closepath() and pdf_closepath_stroke().

이전 | 처음으로 | 다음
pdf_close | 위로 | pdf_closepath_stroke


pdf_closepath_stroke

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_closepath_stroke -- Closes path and draws line along path

Description

bool pdf_closepath_stroke ( resource pdfdoc)

Close the path, and stroke it. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pdf_closepath() and pdf_closepath_fil_stroke().

이전 | 처음으로 | 다음
pdf_closepath_fill_stroke | 위로 | pdf_closepath


pdf_closepath

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_closepath -- Closes path

Description

bool pdf_closepath ( resource pdfdoc)

Close the current path. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pdf_closepath_stroke() and pdf_closepath_fil_stroke().

이전 | 처음으로 | 다음
pdf_closepath_stroke | 위로 | pdf_concat


pdf_concat

(PHP 4 >= 4.0.5, PHP 5)

pdf_concat -- Concatenate a matrix to the CTM

Description

bool pdf_concat ( resource pdfdoc, float a, float b, float c, float d, float e, float f)

Concatenate a matrix to the CTM. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_closepath | 위로 | pdf_continue_text


pdf_continue_text

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_continue_text -- Outputs text in next line

Description

bool pdf_continue_text ( resource pdfdoc, string text)

Print text at the next line. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_concat | 위로 | pdf_curveto


pdf_curveto

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_curveto -- Draws a curve

Description

bool pdf_curveto ( resource pdfdoc, float x1, float y1, float x2, float y2, float x3, float y3)

Draw a Bezier curve from the current point, using 3 more control points. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_continue_text | 위로 | pdf_delete


pdf_delete

(PHP 4 >= 4.0.5, PHP 5)

pdf_delete -- Deletes a PDF object

Description

bool pdf_delete ( resource pdfdoc)

Delete the PDF resource, and free all internal resources. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pdf_new().

이전 | 처음으로 | 다음
pdf_curveto | 위로 | pdf_end_page


pdf_end_page

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_end_page -- Ends a page

Description

bool pdf_end_page ( resource pdfdoc)

Finish the page. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pdf_begin_page().

이전 | 처음으로 | 다음
pdf_delete | 위로 | pdf_end_pattern


pdf_end_pattern

(PHP 4 >= 4.0.5, PHP 5)

pdf_end_pattern -- Finish pattern

Description

bool pdf_end_pattern ( resource pdfdoc)

Finish the pattern definition. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pdf_begin_pattern().

이전 | 처음으로 | 다음
pdf_end_page | 위로 | pdf_end_template


pdf_end_template

(PHP 4 >= 4.0.5, PHP 5)

pdf_end_template -- Finish template

Description

bool pdf_end_template ( resource pdfdoc)

Finish the template definition. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_end_pattern | 위로 | pdf_endpath


pdf_endpath

pdf_endpath -- Deprecated: Ends current path

Description

This function is deprecated, use one of the pdf_stroke(), pdf_clip() or pdf_closepath_fill_stroke() functions instead.

이전 | 처음으로 | 다음
pdf_end_template | 위로 | pdf_fill_stroke


pdf_fill_stroke

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_fill_stroke -- Fills and strokes current path

Description

bool pdf_fill_stroke ( resource pdfdoc)

Fill and stroke the path with the current fill and stroke color. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pdf_setcolor().

이전 | 처음으로 | 다음
pdf_endpath | 위로 | pdf_fill


pdf_fill

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_fill -- Fills current path

Description

bool pdf_fill ( resource pdfdoc)

Fill the interior of the path with the current fill color. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pdf_setcolor().

이전 | 처음으로 | 다음
pdf_fill_stroke | 위로 | pdf_findfont


pdf_findfont

(PHP 4 >= 4.0.5, PHP 5)

pdf_findfont -- Prepare font for later use with pdf_setfont().

Description

int pdf_findfont ( resource pdfdoc, string fontname, string encoding [, int embed])

Prepare a font for later use with pdf_setfont(). The metrics will be loaded, and if embed is nonzero, the font file will be checked, but not yet used. encoding is one of builtin, macroman, winansi, host, a user-defined encoding name or the name of a CMap.

pdf_findfont() returns a font handle or FALSE on error.

예 1. pdf_findfont() example

<?php

$font = pdf_findfont($pdf, "Times New Roman", "winansi", 1);
if ($font) {
    pdf_setfont($pdf, $font, 10);
}

?>

이전 | 처음으로 | 다음
pdf_fill | 위로 | pdf_get_buffer


pdf_get_buffer

(PHP 4 >= 4.0.5, PHP 5)

pdf_get_buffer -- Fetch the buffer containing the generated PDF data.

Description

string pdf_get_buffer ( resource pdfdoc)

Get the contents of the PDF output buffer. The result must be used by the client before calling any other PDFlib function.

이전 | 처음으로 | 다음
pdf_findfont | 위로 | pdf_get_font


pdf_get_font

pdf_get_font -- Deprecated: font handling

Description

This function is deprecated, use pdf_get_value() instead.

이전 | 처음으로 | 다음
pdf_get_buffer | 위로 | pdf_get_fontname


pdf_get_fontname

pdf_get_fontname -- Deprecated: font handling

Description

This function is deprecated, use pdf_get_parameter() instead.

이전 | 처음으로 | 다음
pdf_get_font | 위로 | pdf_get_fontsize


pdf_get_fontsize

pdf_get_fontsize -- Deprecated: font handling

Description

This function is deprecated, use pdf_get_value() instead.

이전 | 처음으로 | 다음
pdf_get_fontname | 위로 | pdf_get_image_height


pdf_get_image_height

pdf_get_image_height -- Deprecated: returns height of an image

Description

This function is deprecated, use pdf_get_value() instead.

이전 | 처음으로 | 다음
pdf_get_fontsize | 위로 | pdf_get_image_width


pdf_get_image_width

pdf_get_image_width -- Deprecated: Returns width of an image

Description

This function is deprecated, use pdf_get_value() instead.

이전 | 처음으로 | 다음
pdf_get_image_height | 위로 | pdf_get_majorversion


pdf_get_majorversion

(PHP 4 >= 4.2.0, PHP 5)

pdf_get_majorversion -- Returns the major version number of the PDFlib

Description

int pdf_get_majorversion ( void )

Returns the major version number of the PDFlib.

See also pdf_get_minorversion().

이전 | 처음으로 | 다음
pdf_get_image_width | 위로 | pdf_get_minorversion


pdf_get_minorversion

(PHP 4 >= 4.2.0, PHP 5)

pdf_get_minorversion -- Returns the minor version number of the PDFlib

Description

int pdf_get_minorversion ( void )

Returns the minor version number of the PDFlib.

See also pdf_get_majorversion().

이전 | 처음으로 | 다음
pdf_get_majorversion | 위로 | pdf_get_parameter


pdf_get_parameter

(PHP 4 >= 4.0.1, PHP 5)

pdf_get_parameter -- Gets certain parameters

Description

string pdf_get_parameter ( resource pdfdoc, string key [, float modifier])

Get the contents of some PDFlib parameter with string type.

이전 | 처음으로 | 다음
pdf_get_minorversion | 위로 | pdf_get_pdi_parameter


pdf_get_pdi_parameter

(PHP 4 >= 4.0.5, PHP 5)

pdf_get_pdi_parameter -- Get some PDI string parameters

Description

string pdf_get_pdi_parameter ( resource pdfdoc, string key, int document, int page, int index)

Get the contents of some PDI document parameter with string type.

이전 | 처음으로 | 다음
pdf_get_parameter | 위로 | pdf_get_pdi_value


pdf_get_pdi_value

(PHP 4 >= 4.0.5, PHP 5)

pdf_get_pdi_value -- Gets some PDI numerical parameters

Description

string pdf_get_pdi_value ( resource pdfdoc, string key, int doc, int page, int index)

Get the contents of some PDI document parameter with numerical type.

이전 | 처음으로 | 다음
pdf_get_pdi_parameter | 위로 | pdf_get_value


pdf_get_value

(PHP 4 >= 4.0.1, PHP 5)

pdf_get_value -- Gets certain numerical value

Description

float pdf_get_value ( resource pdfdoc, string key [, float modifier])

Get the contents of some PDFlib parameter with float type.

이전 | 처음으로 | 다음
pdf_get_pdi_value | 위로 | pdf_initgraphics


pdf_initgraphics

(PHP 4 >= 4.0.5, PHP 5)

pdf_initgraphics -- Resets graphic state

Description

bool pdf_initgraphics ( resource pdfdoc)

Reset all implicit color and graphics state parameters to their defaults. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_get_value | 위로 | pdf_lineto


pdf_lineto

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_lineto -- Draws a line

Description

bool pdf_lineto ( resource pdfdoc, float x, float y)

Draw a line from the current point to (x, y). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_initgraphics | 위로 | pdf_makespotcolor


pdf_makespotcolor

(PHP 4 >= 4.0.5, PHP 5)

pdf_makespotcolor -- Makes a spotcolor

Description

bool pdf_makespotcolor ( resource pdfdoc, string spotname)

Make a named spot color from the current color. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pdf_setcolor().

이전 | 처음으로 | 다음
pdf_lineto | 위로 | pdf_moveto


pdf_moveto

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_moveto -- Sets current point

Description

bool pdf_moveto ( resource pdfdoc, float x, float y)

Set the current point to (x, y. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: The current point for graphics and the current text output position are maintained separately. See pdf_set_text_pos() to set the text output position.

이전 | 처음으로 | 다음
pdf_makespotcolor | 위로 | pdf_new


pdf_new

(PHP 4 >= 4.0.5, PHP 5)

pdf_new -- Creates a new pdf resource

Description

resource pdf_new ( )

Create a new PDF resource, using default error handling and memory management.

See also pdf_close().

이전 | 처음으로 | 다음
pdf_moveto | 위로 | pdf_open_CCITT


pdf_open_CCITT

(PHP 4 >= 4.0.5, PHP 5)

pdf_open_CCITT -- Opens a new image file with raw CCITT data

Description

int pdf_open_CCITT ( resource pdfdoc, string filename, int width, int height, int BitReverse, int k, int Blackls1)

Open a raw CCITT image.

이전 | 처음으로 | 다음
pdf_new | 위로 | pdf_open_file


pdf_open_file

(PHP 4 >= 4.0.5, PHP 5)

pdf_open_file -- Opens a new pdf object

Description

bool pdf_open_file ( resource pdfdoc [, string filename])

Create a new PDF file using the supplied file name. If filename is empty the PDF document will be generated in memory instead of on file. The result must be fetched by the client with the pdf_get_buffer() function. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

The following example shows how to create a pdf document in memory and how to output it correctly.

예 1. Creating a PDF document in memory

<?php

$pdf = pdf_new();

pdf_open_file($pdf);
pdf_begin_page($pdf, 595, 842);
pdf_set_font($pdf, "Times-Roman", 30, "host");
pdf_set_value($pdf, "textrendering", 1);
pdf_show_xy($pdf, "A PDF document created in memory!", 50, 750);
pdf_end_page($pdf);
pdf_close($pdf);

$data = pdf_get_buffer($pdf);

header("Content-type: application/pdf");
header("Content-disposition: inline; filename=test.pdf");
header("Content-length: " . strlen($data));

echo $data;

?>

이전 | 처음으로 | 다음
pdf_open_CCITT | 위로 | pdf_open_gif


pdf_open_gif

pdf_open_gif -- Deprecated: Opens a GIF image

Description

This function is deprecated, use pdf_open_image() instead.

이전 | 처음으로 | 다음
pdf_open_file | 위로 | pdf_open_image_file


pdf_open_image_file

(PHP 3 CVS only, PHP 4 , PHP 5)

pdf_open_image_file -- Reads an image from a file

Description

int pdf_open_image_file ( resource pdfdoc, string imagetype, string filename [, string stringparam [, string intparam]])

Open an image file. Supported types are jpeg, tiff, gif, and png. stringparam is either , mask, masked, or page. intparamis either 0, the image id of the applied mask, or the page.

이전 | 처음으로 | 다음
pdf_open_gif | 위로 | pdf_open_image


pdf_open_image

(PHP 4 >= 4.0.5, PHP 5)

pdf_open_image -- Versatile function for images

Description

int pdf_open_image ( resource PDF-document, string imagetype, string source, string data, long length, int width, int height, int components, int bpc, string params)

Use image data from a variety of data sources. Supported types are jpeg, ccitt, raw. Supported sources are memory, fileref, url. len is only used when type is raw, params is only used when type is ccitt.

이전 | 처음으로 | 다음
pdf_open_image_file | 위로 | pdf_open_jpeg


pdf_open_jpeg

pdf_open_jpeg -- Deprecated: Opens a JPEG image

Description

This function is deprecated, use pdf_open_image() instead.

이전 | 처음으로 | 다음
pdf_open_image | 위로 | pdf_open_memory_image


pdf_open_memory_image

(PHP 3>= 3.0.10, PHP 4 , PHP 5)

pdf_open_memory_image -- Opens an image created with PHP's image functions

Description

int pdf_open_memory_image ( resource pdfdoc, resource image)

The pdf_open_memory_image() function takes an image created with the PHP's image functions and makes it available for the pdf resource. The function returns a pdf image identifier.

예 1. Including a memory image

<?php
$im = imagecreate(100, 100);
$col = imagecolorallocate($im, 80, 45, 190);
imagefill($im, 10, 10, $col);
$pim = pdf_open_memory_image($pdf, $im);
imagedestroy($im);
pdf_place_image($pdf, $pim, 100, 100, 1);
pdf_close_image($pdf, $pim);
?>

See also pdf_close_image() and pdf_place_image().

이전 | 처음으로 | 다음
pdf_open_jpeg | 위로 | pdf_open_pdi_page


pdf_open_pdi_page

(PHP 4 >= 4.0.5, PHP 5)

pdf_open_pdi_page -- Prepare a page

Description

int pdf_open_pdi_page ( resource pdfdoc, int dochandle, int pagenumber, string pagelabel)

Prepare a page for later use with pdf_place_image()

이전 | 처음으로 | 다음
pdf_open_memory_image | 위로 | pdf_open_pdi


pdf_open_pdi

(PHP 4 >= 4.0.5, PHP 5)

pdf_open_pdi -- Opens a PDF file

Description

int pdf_open_pdi ( resource pdfdoc, string filename, string stringparam, int intparam)

Opens an existing PDF document and prepares it for later use.

See also pdf_close_pdi().

이전 | 처음으로 | 다음
pdf_open_pdi_page | 위로 | pdf_open_png


pdf_open_png

pdf_open_png -- Deprecated: Opens a PNG image

Description

This function is deprecated, use pdf_open_image() instead.

이전 | 처음으로 | 다음
pdf_open_pdi | 위로 | pdf_open_tiff


pdf_open_tiff

pdf_open_tiff -- Deprecated: Opens a TIFF image

Description

This function is deprecated, use pdf_open_image() instead.

이전 | 처음으로 | 다음
pdf_open_png | 위로 | pdf_open


pdf_open

pdf_open -- Deprecated: Open a new pdf object

Description

This function is deprecated, use pdf_new() plus pdf_open_file() instead.

이전 | 처음으로 | 다음
pdf_open_tiff | 위로 | pdf_place_image


pdf_place_image

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

pdf_place_image -- Places an image on the page

Description

bool pdf_place_image ( resource pdfdoc, int image, float x, float y, float scale)

Place an image with the lower left corner at (x, y), and scale it. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_open | 위로 | pdf_place_pdi_page


pdf_place_pdi_page

(PHP 4 >= 4.0.6, PHP 5)

pdf_place_pdi_page -- Places an image on the page

Description

bool pdf_place_pdi_page ( resource pdfdoc, int page, float x, float y, float sx, float sy)

Place a PDI page with the lower left corner at (x, y), and scale it. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_place_image | 위로 | pdf_rect


pdf_rect

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_rect -- Draws a rectangle

Description

bool pdf_rect ( resource pdfdoc, float x, float y, float width, float height)

Draw a (width * height) rectangle at lower left (x, y). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_place_pdi_page | 위로 | pdf_restore


pdf_restore

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_restore -- Restores formerly saved environment

Description

bool pdf_restore ( resource pdfdoc)

Restore the most recently saved graphics state. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_rect | 위로 | pdf_rotate


pdf_rotate

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_rotate -- Sets rotation

Description

bool pdf_rotate ( resource pdfdoc, float phi)

Rotate the coordinate system by phi degrees. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_restore | 위로 | pdf_save


pdf_save

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_save -- Saves the current environment

Description

bool pdf_save ( resource pdfdoc)

Save the current graphics state. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_rotate | 위로 | pdf_scale


pdf_scale

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_scale -- Sets scaling

Description

bool pdf_scale ( resource pdfdoc, float x-scale, float y-scale)

Scale the coordinate system. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_save | 위로 | pdf_set_border_color


pdf_set_border_color

(PHP 3>= 3.0.12, PHP 4 , PHP 5)

pdf_set_border_color -- Sets color of border around links and annotations

Description

bool pdf_set_border_color ( resource pdfdoc, float red, float green, float blue)

Set the border color for all kinds of annotations. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_scale | 위로 | pdf_set_border_dash


pdf_set_border_dash

(PHP 4 >= 4.0.1, PHP 5)

pdf_set_border_dash -- Sets dash style of border around links and annotations

Description

bool pdf_set_border_dash ( resource pdfdoc, float black, float white)

Sets the border dash style for all kinds of annotations. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pdf_setdash().

이전 | 처음으로 | 다음
pdf_set_border_color | 위로 | pdf_set_border_style


pdf_set_border_style

(PHP 3>= 3.0.12, PHP 4 , PHP 5)

pdf_set_border_style -- Sets style of border around links and annotations

Description

bool pdf_set_border_style ( resource pdfdoc, string style, float width)

Sets the border style for all kinds of annotations. style is solid or dashed. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_set_border_dash | 위로 | pdf_set_char_spacing


pdf_set_char_spacing

pdf_set_char_spacing -- Deprecated: Sets character spacing

Description

This function is deprecated, use pdf_set_value() instead.

이전 | 처음으로 | 다음
pdf_set_border_style | 위로 | pdf_set_duration


pdf_set_duration

pdf_set_duration -- Deprecated: Sets duration between pages

Description

This function is deprecated, use pdf_set_value() instead.

이전 | 처음으로 | 다음
pdf_set_char_spacing | 위로 | pdf_set_font


pdf_set_font

pdf_set_font -- Deprecated: Selects a font face and size

Description

This function is deprecated, use pdf_findfont() plus pdf_setfont() instead.

이전 | 처음으로 | 다음
pdf_set_duration | 위로 | pdf_set_horiz_scaling


pdf_set_horiz_scaling

pdf_set_horiz_scaling -- Sets horizontal scaling of text [deprecated]

Description

This function is deprecated, use pdf_set_value() instead.

이전 | 처음으로 | 다음
pdf_set_font | 위로 | pdf_set_info_author


pdf_set_info_author

pdf_set_info_author -- Deprecated: Fills the author field of the document

Description

This function is deprecated, use pdf_set_info() instead.

이전 | 처음으로 | 다음
pdf_set_horiz_scaling | 위로 | pdf_set_info_creator


pdf_set_info_creator

pdf_set_info_creator -- Deprecated: Fills the creator field of the document

Description

This function is deprecated, use pdf_set_info() instead.

이전 | 처음으로 | 다음
pdf_set_info_author | 위로 | pdf_set_info_keywords


pdf_set_info_keywords

pdf_set_info_keywords -- Deprecated: Fills the keywords field of the document

Description

This function is deprecated, use pdf_set_info() instead.

이전 | 처음으로 | 다음
pdf_set_info_creator | 위로 | pdf_set_info_subject


pdf_set_info_subject

pdf_set_info_subject -- Deprecated: Fills the subject field of the document

Description

This function is deprecated, use pdf_set_info() instead.

이전 | 처음으로 | 다음
pdf_set_info_keywords | 위로 | pdf_set_info_title


pdf_set_info_title

pdf_set_info_title -- Deprecated: Fills the title field of the document

Description

This function is deprecated, use pdf_set_info() instead.

이전 | 처음으로 | 다음
pdf_set_info_subject | 위로 | pdf_set_info


pdf_set_info

(PHP 4 >= 4.0.1, PHP 5)

pdf_set_info -- Fills a field of the document information

Description

bool pdf_set_info ( resource pdfdoc, string key, string value)

Fill document information field key with value. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. key is one of Subject, Title, Creator, Author, Keywords, or a user-defined key.

이전 | 처음으로 | 다음
pdf_set_info_title | 위로 | pdf_set_leading


pdf_set_leading

pdf_set_leading -- Deprecated: Sets distance between text lines

Description

This function is deprecated, use pdf_set_value() instead.

이전 | 처음으로 | 다음
pdf_set_info | 위로 | pdf_set_parameter


pdf_set_parameter

(PHP 4 , PHP 5)

pdf_set_parameter -- Sets certain parameters

Description

bool pdf_set_parameter ( resource pdfdoc, string key, string value)

Sets some PDFlib parameters with string type. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pdf_set_value().

이전 | 처음으로 | 다음
pdf_set_leading | 위로 | pdf_set_text_matrix


pdf_set_text_matrix

pdf_set_text_matrix -- Deprecated: Sets the text matrix

Description

This function is deprecated, use pdf_set_paramter() instead.

이전 | 처음으로 | 다음
pdf_set_parameter | 위로 | pdf_set_text_pos


pdf_set_text_pos

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_set_text_pos -- Sets text position

Description

bool pdf_set_text_pos ( resource pdfdoc, float x, float y)

Set the text output position specified by x and y. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_set_text_matrix | 위로 | pdf_set_text_rendering


pdf_set_text_rendering

pdf_set_text_rendering -- Deprecated: Determines how text is rendered

Description

This function is deprecated, use pdf_set_value() instead.

이전 | 처음으로 | 다음
pdf_set_text_pos | 위로 | pdf_set_text_rise


pdf_set_text_rise

pdf_set_text_rise -- Deprecated: Sets the text rise

Description

This function is deprecated, use pdf_set_value() instead.

이전 | 처음으로 | 다음
pdf_set_text_rendering | 위로 | pdf_set_value


pdf_set_value

(PHP 4 >= 4.0.1, PHP 5)

pdf_set_value -- Sets certain numerical value

Description

bool pdf_set_value ( resource pdfdoc, string key, float value)

Set the value of some PDFlib parameter with float type. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pdf_set_parameter().

이전 | 처음으로 | 다음
pdf_set_text_rise | 위로 | pdf_set_word_spacing


pdf_set_word_spacing

pdf_set_word_spacing -- Deprecated: Sets spacing between words

Description

This function is deprecated, use pdf_set_value() instead.

이전 | 처음으로 | 다음
pdf_set_value | 위로 | pdf_setcolor


pdf_setcolor

(PHP 4 >= 4.0.5, PHP 5)

pdf_setcolor -- Sets fill and stroke color

Description

bool pdf_setcolor ( resource pdfdoc, string type, string colorspace, float c1 [, float c2 [, float c3 [, float c4]]])

Set the current color space and color. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. The parameter type can be fill, stroke or both to specify that the color is set for filling, stroking or both filling and stroking. The parameter colorspace can be gray, rgb, cmyk, spot or pattern. The parameters c1, c2, c3 and c4 represent the color components for the color space specified by colorspace. Except as otherwise noted, the color components are floating-point values that range from 0 to 1.

For gray only c1 is used.

For rgb parameters c1, c2, and c3 specify the red, green and blue values respectively.

<?php
// Set fill and stroke colors to white.
pdf_setcolor($pdf, "both", "rgb", 1, 1, 1);
?>

For cmyk, parameters c1, c2, c3, and c4 are the cyan, magenta, yellow and black values, respectively.

<?php
// Set fill and stroke colors to black.
pdf_setcolor($pdf, "both", "cmyk", 0, 0, 0, 1);
?>

For spot, c1 should be a spot color handles returned by pdf_makespotcolor() and c2 is a tint value between 0 and 1.

For pattern, c1 should be a pattern handle returned by pdf_begin_pattern().

이전 | 처음으로 | 다음
pdf_set_word_spacing | 위로 | pdf_setdash


pdf_setdash

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_setdash -- Sets dash pattern

Description

bool pdf_setdash ( resource pdfdoc, float b, float w)

Set the current dash pattern to b black and w white units. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_setcolor | 위로 | pdf_setflat


pdf_setflat

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_setflat -- Sets flatness

Description

bool pdf_setflat ( resource pdfdoc, float flatness)

Sets the flatness to a value between 0 and 100 inclusive. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_setdash | 위로 | pdf_setfont


pdf_setfont

(PHP 4 >= 4.0.5, PHP 5)

pdf_setfont -- Set the current font

Description

bool pdf_setfont ( resource pdfdoc, int font, float size)

Set the current font in the given size, using a font handle returned by pdf_findfont(). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pdf_findfont().

이전 | 처음으로 | 다음
pdf_setflat | 위로 | pdf_setgray_fill


pdf_setgray_fill

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_setgray_fill -- Sets filling color to gray value

Description

bool pdf_setgray_fill ( resource pdfdoc, float gray)

Set the current fill color to a gray value between 0 and 1 inclusive. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: PDFlib V4.0: Deprecated, use pdf_setcolor() instead.

이전 | 처음으로 | 다음
pdf_setfont | 위로 | pdf_setgray_stroke


pdf_setgray_stroke

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_setgray_stroke -- Sets drawing color to gray value

Description

bool pdf_setgray_stroke ( resource pdfdoc, float gray)

Set the current stroke color to a gray value between 0 and 1 inclusive. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: PDFlib V4.0: Deprecated, use pdf_setcolor() instead.

이전 | 처음으로 | 다음
pdf_setgray_fill | 위로 | pdf_setgray


pdf_setgray

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_setgray -- Sets drawing and filling color to gray value

Description

bool pdf_setgray ( resource pdfdoc, float gray)

Set the current fill and stroke color. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: PDFlib V4.0: Deprecated, use pdf_setcolor() instead.

이전 | 처음으로 | 다음
pdf_setgray_stroke | 위로 | pdf_setlinecap


pdf_setlinecap

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_setlinecap -- Sets linecap parameter

Description

void pdf_setlinecap ( resource pdfdoc, int linecap)

Set the linecap parameter to a value between 0 and 2 inclusive.

이전 | 처음으로 | 다음
pdf_setgray | 위로 | pdf_setlinejoin


pdf_setlinejoin

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_setlinejoin -- Sets linejoin parameter

Description

bool pdf_setlinejoin ( resource pdfdoc, int value)

Sets the line join parameter to a value between 0 and 2 inclusive. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_setlinecap | 위로 | pdf_setlinewidth


pdf_setlinewidth

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_setlinewidth -- Sets line width

Description

void pdf_setlinewidth ( resource pdfdoc, float width)

Sets the current linewidth to width. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_setlinejoin | 위로 | pdf_setmatrix


pdf_setmatrix

(PHP 4 >= 4.0.5, PHP 5)

pdf_setmatrix -- Sets current transformation matrix

Description

bool pdf_setmatrix ( resource pdfdoc, float a, float b, float c, float d, float e, float f)

Explicitly set the current transformation matrix. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_setlinewidth | 위로 | pdf_setmiterlimit


pdf_setmiterlimit

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_setmiterlimit -- Sets miter limit

Description

bool pdf_setmiterlimit ( resource pdfdoc, float miter)

Set the miter limit to a value greater than or equal to 1. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_setmatrix | 위로 | pdf_setpolydash


pdf_setpolydash

pdf_setpolydash -- Deprecated: Sets complicated dash pattern

Description

This function is deprecated, use pdf_setdash() instead.

이전 | 처음으로 | 다음
pdf_setmiterlimit | 위로 | pdf_setrgbcolor_fill


pdf_setrgbcolor_fill

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_setrgbcolor_fill -- Sets filling color to rgb color value

Description

bool pdf_setrgbcolor_fill ( resource pdfdoc, float red_value, float green_value, float blue_value)

Set the current fill color to the supplied RGB values. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: PDFlib V4.0: Deprecated, use pdf_setcolor() instead.

이전 | 처음으로 | 다음
pdf_setpolydash | 위로 | pdf_setrgbcolor_stroke


pdf_setrgbcolor_stroke

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_setrgbcolor_stroke -- Sets drawing color to rgb color value

Description

bool pdf_setrgbcolor_stroke ( resource pdfdoc, float red_value, float green_value, float blue_value)

Set the current stroke color to the supplied RGB values. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: PDFlib V4.0: Deprecated, use pdf_setcolor() instead.

이전 | 처음으로 | 다음
pdf_setrgbcolor_fill | 위로 | pdf_setrgbcolor


pdf_setrgbcolor

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_setrgbcolor -- Sets drawing and filling color to rgb color value

Description

bool pdf_setrgbcolor ( resource pdfdoc, float red_value, float green_value, float blue_value)

Set the current fill and stroke color to the supplied RGB values. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: PDFlib V4.0: Deprecated, use pdf_setcolor() instead.

이전 | 처음으로 | 다음
pdf_setrgbcolor_stroke | 위로 | pdf_show_boxed


pdf_show_boxed

(PHP 4 , PHP 5)

pdf_show_boxed -- Output text in a box

Description

int pdf_show_boxed ( resource pdfdoc, string text, float left, float top, float width, float height, string mode [, string feature])

Format text in the current font and size into the supplied text box according to the requested formatting mode, which must be one of left, right, center, justify or fulljustify. If width and height are 0, only a single line is placed at the point (left, top) in the requested mode.

Returns the number of characters that did not fit in the specified box. Returns 0 if all characters fit or the width and height parameters were set to 0 for single-line formatting.

이전 | 처음으로 | 다음
pdf_setrgbcolor | 위로 | pdf_show_xy


pdf_show_xy

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_show_xy -- Output text at given position

Description

bool pdf_show_xy ( resource pdfdoc, string text, float x, float y)

Print text in the current font at ( x, y). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_show_boxed | 위로 | pdf_show


pdf_show

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_show -- Output text at current position

Description

bool pdf_show ( resource pdfdoc, string text)

Print text in the current font and size at the current position. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_show_xy | 위로 | pdf_skew


pdf_skew

(PHP 4 , PHP 5)

pdf_skew -- Skews the coordinate system

Description

bool pdf_skew ( resource pdfdoc, float alpha, float beta)

Skew the coordinate system in x and y direction by alpha and beta degrees. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_show | 위로 | pdf_stringwidth


pdf_stringwidth

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_stringwidth -- Returns width of text using current font

Description

float pdf_stringwidth ( resource pdfdoc, string text [, int font [, float size]])

Returns the width of text using the last font set by pdf_setfont(). If the optional parameters font and size are specified, the width will be calculated using that font and size instead. Please note that font is a font handle returned by pdf_findfont().

참고: Both the font and size parameters must be used together.

See also pdf_setfont() and pdf_findfont().

이전 | 처음으로 | 다음
pdf_skew | 위로 | pdf_stroke


pdf_stroke

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_stroke -- Draws line along path

Description

bool pdf_stroke ( resource pdfdoc)

Stroke the path with the current color and line width, and clear it. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pdf_stringwidth | 위로 | pdf_translate


pdf_translate

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

pdf_translate -- Sets origin of coordinate system

Description

bool pdf_translate ( resource pdfdoc, float tx, float ty)

Translate the origin of the coordinate system.

이전 | 처음으로 | 다음
pdf_stroke | 위로 | Verisign Payflow Pro Functions


Verisign Payflow Pro Functions

PHP 매뉴얼
이전 다음

LXXXI. Verisign Payflow Pro Functions

소개

This extension allows you to process credit cards and other financial transactions using Verisign Payment Services, formerly known as Signio (http://www.verisign.com/products/payflow/pro/index.html).

When using these functions, you may omit calls to pfpro_init() and pfpro_cleanup() as this extension will do so automatically if required. However the functions are still available in case you are processing a number of transactions and require fine control over the library. You may perform any number of transactions using pfpro_process() between the two.

These functions were added in PHP 4.0.2.

참고: These functions only provide a link to Verisign Payment Services. Be sure to read the Payflow Pro Developers Guide for full details of the required parameters.

참고: 이 확장 모듈은 윈도우 플랫폼에서는 사용할 수 없습니다.

요구 사항

You will require the appropriate SDK for your platform, which may be downloaded from within the manager interface once you have registered. If you are going to use this extension in an SSL-enabled webserver or with other SSL components (such as the CURL+SSL extension) you MUST get the beta SDK.

Once you have downloaded the SDK you should copy the files from the lib directory of the distribution. Copy the header file pfpro.h to /usr/local/include and the library file libpfpro.so to /usr/local/lib.

설치

These functions are only available if PHP has been compiled with the --with-pfpro[=DIR] option.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. Verisign Payflow Pro configuration options

Name | Default | Changeable
pfpro.defaulthost/PFPRO_VERSION < 3 | "test.signio.com" | PHP_INI_ALL
pfpro.defaulthost | "test-payflow.verisign.com" | PHP_INI_ALL
pfpro.defaultport | "443" | PHP_INI_ALL
pfpro.defaulttimeout | "30" | PHP_INI_ALL
pfpro.proxyaddress | "" | PHP_INI_ALL
pfpro.proxyport | "" | PHP_INI_ALL
pfpro.proxylogon | "" | PHP_INI_ALL
pfpro.proxypassword | "" | PHP_INI_ALL
For further details and definition of the PHP_INI_* constants see ini_set().

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
pfpro_cleanup -- Shuts down the Payflow Pro library
pfpro_init -- Initialises the Payflow Pro library
pfpro_process_raw -- Process a raw transaction with Payflow Pro
pfpro_process -- Process a transaction with Payflow Pro
pfpro_version -- Returns the version of the Payflow Pro software

이전 | 처음으로 | 다음
pdf_translate | 위로 | pfpro_cleanup


pfpro_cleanup

(PHP 4 >= 4.0.2, PHP 5)

pfpro_cleanup -- Shuts down the Payflow Pro library

Description

void pfpro_cleanup ( void )

pfpro_cleanup() is used to shutdown the Payflow Pro library cleanly. It should be called after you have processed any transactions and before the end of your script. However you may omit this call, in which case this extension will automatically call pfpro_cleanup() after your script terminates.

See also pfpro_init().

이전 | 처음으로 | 다음
Verisign Payflow Pro Functions | 위로 | pfpro_init


pfpro_init

(PHP 4 >= 4.0.2, PHP 5)

pfpro_init -- Initialises the Payflow Pro library

Description

void pfpro_init ( void )

pfpro_init() is used to initialise the Payflow Pro library. You may omit this call, in which case this extension will automatically call pfpro_init() before the first transaction.

See also pfpro_cleanup().

이전 | 처음으로 | 다음
pfpro_cleanup | 위로 | pfpro_process_raw


pfpro_process_raw

(PHP 4 >= 4.0.2, PHP 5)

pfpro_process_raw -- Process a raw transaction with Payflow Pro

Description

string pfpro_process_raw ( string parameters [, string address [, int port [, int timeout [, string proxy_address [, int proxy_port [, string proxy_logon [, string proxy_password]]]]]]])

Returns: A string containing the response.

pfpro_process_raw() processes a raw transaction string with Payflow Pro. You should really use pfpro_process() instead, as the encoding rules of these transactions are non-standard.

The first parameter in this case is a string containing the raw transaction request. All other parameters are the same as with pfpro_process(). The return value is a string containing the raw response.

참고: Be sure to read the Payflow Pro Developers Guide for full details of the required parameters and encoding rules. You would be well advised to use pfpro_process() instead.

예 1. Payflow Pro raw example

<?php

pfpro_init();

$response = pfpro_process_raw("USER=mylogin&PWD[5]=m&ndy&PARTNER=VeriSign&TRXTYPE=S&TENDER=C&AMT=1.50&ACCT=4111111111111111&EXPDATE=0904");

if (!$response) {
  die("Couldn't establish link to Verisign.\n");
}

echo "Verisign raw response was " . $response;

pfpro_cleanup();

?>

See also pfpro_process().

이전 | 처음으로 | 다음
pfpro_init | 위로 | pfpro_process


pfpro_process

(PHP 4 >= 4.0.2, PHP 5)

pfpro_process -- Process a transaction with Payflow Pro

Description

array pfpro_process ( array parameters [, string address [, int port [, int timeout [, string proxy_address [, int proxy_port [, string proxy_logon [, string proxy_password]]]]]]])

Returns: An associative array containing the response

pfpro_process() processes a transaction with Payflow Pro. The first parameter is an associative array containing keys and values that will be encoded and passed to the processor.

The second parameter is optional and specifies the host to connect to. By default this is "test.signio.com", so you will certainly want to change this to "connect.signio.com" in order to process live transactions.

The third parameter specifies the port to connect on. It defaults to 443, the standard SSL port.

The fourth parameter specifies the timeout to be used, in seconds. This defaults to 30 seconds. Note that this timeout appears to only begin once a link to the processor has been established and so your script could potentially continue for a very long time in the event of DNS or network problems.

The fifth parameter, if required, specifies the hostname of your SSL proxy. The sixth parameter specifies the port to use.

The seventh and eighth parameters specify the logon identity and password to use on the proxy.

The function returns an associative array of the keys and values in the response.

참고: Be sure to read the Payflow Pro Developers Guide for full details of the required parameters.

예 1. Payflow Pro example

<?php

pfpro_init();

$transaction = array('USER'    => 'mylogin',
                     'PWD'     => 'mypassword',
                     'PARTNER' => 'VeriSign',
                     'TRXTYPE' => 'S',
                     'TENDER'  => 'C',
                     'AMT'     => 1.50,
                     'ACCT'    => '4111111111111111',
                     'EXPDATE' => '0904'
                    );

$response = pfpro_process($transaction);

if (!$response) {
  die("Couldn't establish link to Verisign.\n");
}

echo "Verisign response code was " . $response['RESULT'];
echo ", which means: " . $response['RESPMSG'] . "\n";

echo "\nThe transaction request: ";
print_r($transaction);

echo "\nThe response: ";
print_r($response);

pfpro_cleanup();

?>

이전 | 처음으로 | 다음
pfpro_process_raw | 위로 | pfpro_version


pfpro_version

(PHP 4 >= 4.0.2, PHP 5)

pfpro_version -- Returns the version of the Payflow Pro software

Description

string pfpro_version ( void )

pfpro_version() returns the version string of the Payflow Pro library. At the time of writing, this was L211.

이전 | 처음으로 | 다음
pfpro_process | 위로 | PHP 옵션&정보


PHP 옵션&정보

PHP 매뉴얼
이전 다음

LXXXII. PHP 옵션&정보

소개

이 함수들은 실행 설정, 읽어들인 확장 모듈, 버전 등, PHP에 대한 많은 정보를 얻을 수 있게 합니다. 또한 실행중인 PHP의 설정을 변경하는 함수도 있습니다. PHP에서 가장 널리 알려진 함수 - phpinfo()도 여기에 속합니다.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. PHP 옵션/정보 설정 옵션

이름 | 기본값 | 변경가능성
assert.active | "1" | PHP_INI_ALL
assert.bail | "0" | PHP_INI_ALL
assert.warning | "1" | PHP_INI_ALL
assert.callback | NULL | PHP_INI_ALL
assert.quiet_eval | "0" | PHP_INI_ALL
enable_dl | "1" | PHP_INI_SYSTEM
max_execution_time | "30" | PHP_INI_ALL
max_input_time | "60" | PHP_INI_ALL
magic_quotes_gpc | "1" | PHP_INI_PERDIR|PHP_INI_SYSTEM
magic_quotes_runtime | "0" | PHP_INI_ALL
PHP_INI_* 상수에 대한 자세한 내용 및 정의는 ini_set()을 참고하십시오

위 설정 지시어에 대한 간단한 설명입니다.

assert.active boolean

assert() 평가를 활성화합니다.

assert.bail boolean

assertion 실패시에 스크립트 실행을 종료합니다.

assert.warning boolean

실패하는 assertion마다 PHP 경고를 발생합니다.

assert.callback string

assertion 실패시에 호출할 사용자 함수.

assert.quiet_eval boolean

assertion 표현 평가 중에 error_reporting()의 현재 설정을 사용합니다. 활성화하면, 평가 도중에 에러가 보여지지 않습니다. (error_reporting(0)에 상당) 비활성화하면, 에러는 error_reporting() 설정에 따라 보여집니다.

enable_dl boolean

이 지시어는 PHP의 아파치 모듈 버전에서만 유용합니다. dl()로 PHP 확장 모듈을 동적으로 읽어들일 수 있는지 여부를, 가상 서버나 디렉토리 단위로 설정할 수 있습니다.

동적 로딩을 끄는 주 이유는 보안입니다. 동적 로딩으로, 모든 open_basedir 제한을 무시할 수 있습니다. 기본값은 안전 모드를 사용할 때를 제외하고 동적 로딩을 허용합니다. 안전 모드에서는 항상 dl()을 사용할 수 없습니다.

max_execution_time integer

스크립트가 실행할 수 있는 최대 시간을 설정합니다. 이는 잘못 쓰여진 스크립트가 서버를 멈추는 것을 방지합니다. 기본값은 30입니다.

최대 실행 시간은 시스템 호출, 스트림 작업 등에는 영향을 받지 않습니다. 자세한 내용은 set_time_limit()를 참고하십시오.

안전 모드로 실행할 때는 이 설정을 ini_set()으로 변경할 수 없습니다. 안전 모드를 끄거나 php.ini에서 시간 제한을 변경해야 합니다.

max_input_time integer

스크립트가 POST, GET, 파일 업로드 등의 입력 데이터를 받아들이는 최대 시간을 초 단위로 설정합니다. 기본값은 60입니다.

magic_quotes_gpc boolean

GPC (Get/Post/쿠키) 작동의 magic_quotes 상태를 설정합니다. magic_quotes가 on이면, 모든 ' (작은 따옴표), " (큰 따옴표), \ (백슬래쉬), NUL은 자동적으로 백슬래쉬로 이스케이프됩니다.

참고: magic_quotes_sybase 지시어도 ON이면 magic_quotes_gpc가 완전히 교체됩니다. 두 지시어를 모두 활성화하면 작은 따음표는 ''로 이스케이프합니다. 큰 따옴표, 백슬래쉬, NUL은 건들이지 않고, 이스케이프 하지 않습니다.

참고: get_magic_quotes_gpc()

magic_quotes_runtime boolean

magic_quotes_runtime를 활성화하면, 데이터베이스나 텍스트 파일를 포함한, 어떠한 외부 소스에서 데이터를 가져오는 대부분의 함수는 백슬래쉬로 인용됩니다. magic_quotes-sybase도 on이면, 작은 따옴표는 백슬래쉬 대신 작은 따옴표로 이스케이프합니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

아래 상수들은 PHP 코어의 일부로, 항상 사용할 수 있습니다.

표 2. 미리 정의된 phpcredits() 상수

상수 | 값 | 설명
CREDITS_GROUP | 1 | 코어 개발자 목록
CREDITS_GENERAL | 2 | 일반 공로: 언어 디자인과 컨셉, PHP 4.0 저자와 SAPI 모듈.
CREDITS_SAPI | 4 | PHP의 서버 API 모듈 목록과 그 저자.
CREDITS_MODULES | 8 | PHP의 확장 모듈 목록과 그 저자.
CREDITS_DOCS | 16 | 문서 팀을 위한 공로.
CREDITS_FULLPAGE | 32 | 보통 다른 플래그와 결합해서 사용합니다. 지정한 다른 플래그의 정보를 포함하는 완전한 개별 HTML 페이지 출력이 필요하다는 것을 지시합니다.
CREDITS_QA | 64 | 품질 보증 팀을 위한 공로.
CREDITS_ALL | -1 | 모든 공로, 다음과 동일합니다: CREDITS_DOCS + CREDITS_GENERAL + CREDITS_GROUP + CREDITS_MODULES + CREDITS_QA + CREDITS_FULLPAGE. 모든 태그를 가지는 완전한 개별 HTML 페이지를 생성합니다. 기본값입니다.

표 3. phpinfo() 상수

상수 | 값 | 설명
INFO_GENERAL | 1 | 설정 옵션줄, php.ini 위치, 빌드 날짜, 웹 서버, 시스템 등.
INFO_CREDITS | 2 | PHP 4 공로. phpcreadits() 참고.
INFO_CONFIGURATION | 4 | PHP 지시어의 현재 로컬과 마스터 값. ini_get() 참고.
INFO_MODULES | 8 | 읽어들인 모듈과 관련 설정.
INFO_ENVIRONMENT | 16 | 환경 변수 정보. $_ENV으로 사용 가능.
INFO_VARIABLES | 32 | EGPCS(환경, GET, POST, 쿠키, 서버)의 모든 정의된 변수.
INFO_LICENSE | 64 | PHP 라이센스 정보. 라이센스 faq 참고.
INFO_ALL | -1 | 위의 모든 정보를 보여줍니다. 기본값입니다.

ASSERT_ACTIVE (integer)

ASSERT_CALLBACK (integer)

ASSERT_BAIL (integer)

ASSERT_WARNING (integer)

ASSERT_QUIET_EVAL (integer)

차례
assert_options -- Set/get the various assert flags
assert -- Checks if assertion is FALSE
dl -- Loads a PHP extension at runtime
extension_loaded -- Find out whether an extension is loaded
get_cfg_var -- PHP 설정 옵션의 값을 얻습니다.
get_current_user -- 현재 PHP 스크립트 소유자의 이름을 얻습니다.
get_defined_constants -- 모든 상수와 그 값의 연관 배열을 반환합니다.
get_extension_funcs -- 모듈의 함수명을 배열로 반환합니다.
get_include_path -- Gets the current include_path configuration option
get_included_files -- include나 require한 파일명의 배열을 반환합니다.
get_loaded_extensions -- 적재된 모든 모듈명을 배열로 반환합니다.
get_magic_quotes_gpc -- Gets the current active configuration setting of magic quotes gpc
get_magic_quotes_runtime -- Gets the current active configuration setting of magic_quotes_runtime
get_required_files -- get_included_files()의 별칭.
getenv -- 환경 변수값을 얻습니다.
getlastmod -- 페이지를 수정한 최종 시간을 얻습니다.
getmygid -- Get PHP script owner's GID
getmyinode -- Gets the inode of the current script
getmypid -- Gets PHP's process ID
getmyuid -- Gets PHP script owner's UID
getopt -- Gets options from the command line argument list
getrusage -- Gets the current resource usages
ini_alter -- ini_set()의 별칭
ini_get_all -- 모든 설정 옵션을 얻습니다.
ini_get -- Gets the value of a configuration option
ini_restore -- 설정 옵션의 값을 복구합니다.
ini_set -- Sets the value of a configuration option
main -- Dummy for main()
memory_get_usage -- Returns the amount of memory allocated to PHP
php_ini_scanned_files -- Return a list of .ini files parsed from the additional ini dir
php_logo_guid -- Gets the logo guid
php_sapi_name -- 웹 서버와 PHP 간의 접근 형태를 반환합니다.
php_uname -- Returns information about the operating system PHP was built on
phpcredits -- Prints out the credits for PHP
phpinfo -- Outputs lots of PHP information
phpversion -- Gets the current PHP version
putenv -- Sets the value of an environment variable
restore_include_path -- Restores the value of the include_path configuration option
set_include_path -- Sets the include_path configuration option
set_magic_quotes_runtime -- Sets the current active configuration setting of magic_quotes_runtime
set_time_limit -- 최대 실행 시간을 제한합니다.
version_compare -- Compares two "PHP-standardized" version number strings
zend_logo_guid -- Gets the Zend guid
zend_version -- 현재 젠드 엔진의 버전을 얻습니다.

이전 | 처음으로 | 다음
pfpro_version | 위로 | assert_options


assert_options

(PHP 4 , PHP 5)

assert_options -- Set/get the various assert flags

Description

mixed assert_options ( int what [, mixed value])

Using assert_options() you may set the various assert() control options or just query their current settings.

표 1. Assert Options

option | ini-parameter | default | description
ASSERT_ACTIVE | assert.active | 1 | enable assert() evaluation
ASSERT_WARNING | assert.warning | 1 | issue a PHP warning for each failed assertion
ASSERT_BAIL | assert.bail | 0 | terminate execution on failed assertions
ASSERT_QUIET_EVAL | assert.quiet_eval | 0 | disable error_reporting during assertion expression evaluation
ASSERT_CALLBACK | assert.callback | (NULL) | user function to call on failed assertions

assert_options() will return the original setting of any option or FALSE on errors.

이전 | 처음으로 | 다음
PHP 옵션&정보 | 위로 | assert


assert

(PHP 4 , PHP 5)

assert -- Checks if assertion is FALSE

Description

int assert ( mixed assertion)

assert() will check the given assertion and take appropriate action if its result is FALSE.

If the assertion is given as a string it will be evaluated as PHP code by assert(). The advantages of a string assertion are less overhead when assertion checking is off and messages containing the assertion expression when an assertion fails. This means that if you pass a boolean condition as assertion this condition will not show up as parameter to the assertion function which you may have defined with the assert_options() function, the condition is converted to a string before calling that handler function, and the boolean FALSE is converted as the empty string.

Assertions should be used as a debugging feature only. You may use them for sanity-checks that test for conditions that should always be TRUE and that indicate some programming errors if not or to check for the presence of certain features like extension functions or certain system limits and features.

Assertions should not be used for normal runtime operations like input parameter checks. As a rule of thumb your code should always be able to work correctly if assertion checking is not activated.

The behavior of assert() may be configured by assert_options() or by .ini-settings described in that functions manual page.

The assert_options() function and/or ASSERT_CALLBACK configuration directive allow a callback function to be set to handle failed assertions.

assert() callbacks are particularly useful for building automated test suites because they allow you to easily capture the code passed to the assertion, along with information on where the assertion was made. While this information can be captured via other methods, using assertions makes it much faster and easier!

The callback function should accept three arguments. The first argument will contain the file the assertion failed in. The second argument will contain the line the assertion failed on and the third argument will contain the expression that failed (if any - literal values such as 1 or "two" will not be passed via this argument)

예 1. Handle a failed assertion with a custom handler

<?php
// Active assert and make it quiet
assert_options(ASSERT_ACTIVE, 1);
assert_options(ASSERT_WARNING, 0);
assert_options(ASSERT_QUIET_EVAL, 1);

// Create a handler function
function my_assert_handler($file, $line, $code)
{
    echo "<hr>Assertion Failed:
        File '$file'<br />
        Line '$line'<br />
        Code '$code'<br /><hr />";
}

// Set up the callback
assert_options(ASSERT_CALLBACK, 'my_assert_handler');

// Make an assertion that should fail
assert('mysql_query("")');
?>

이전 | 처음으로 | 다음
assert_options | 위로 | dl


dl

(PHP 3, PHP 4 , PHP 5)

dl -- Loads a PHP extension at runtime

Description

int dl ( string library)

Loads the PHP extension given by the parameter library. The library parameter is only the filename of the extension to load which also depends on your platform. For example, the sockets extension (if compiled as a shared module, not the default!) would be called sockets.so on Unix platforms whereas it is called php_sockets.dll on the Windows platform.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. If the functionality of loading modules is not available (see Note) or has been disabled (either by turning it off enable_dl or by enabling 안전 모드 in php.ini) an E_ERROR is emitted and execution is stopped. If dl() fails because the specified library couldn't be loaded, in addition to FALSE an E_WARNING message is emitted.

Use extension_loaded() to test whether a given extension is already available or not. This works on both built-in extensions and dynamically loaded ones (either through php.ini or dl()).

예 1. dl() examples

<?php
// Example loading an extension based on OS
if (!extension_loaded('sqlite')) {
    if (strtoupper(substr(PHP_OS, 0, 3) == 'WIN')) {
        dl('php_sqlite.dll');
    } else {
        dl('sqlite.so');
    }
}

// Or, the PHP_SHLIB_SUFFIX constant is available as of PHP 4.3.0
if (!extension_loaded('sqlite')) {
    $prefix = (PHP_SHLIB_SUFFIX == 'dll') ? 'php_' : '';
    dl($prefix . 'sqlite.' . PHP_SHLIB_SUFFIX);
}
?>

The directory where the extension is loaded from depends on your platform:

Windows - If not explicitly set in the php.ini, the extension is loaded from c:\php4\extensions\ by default.

Unix - If not explicitly set in the php.ini, the default extension directory depends on

  • whether PHP has been built with --enable-debug or not

  • whether PHP has been built with (experimental) ZTS (Zend Thread Safety) support or not

  • the current internal ZEND_MODULE_API_NO (Zend internal module API number, which is basically the date on which a major module API change happened, e.g. 20010901)

Taking into account the above, the directory then defaults to <install-dir>/lib/php/extensions/ <debug-or-not>-<zts-or-not>-ZEND_MODULE_API_NO, e.g. /usr/local/php/lib/php/extensions/debug-non-zts-20010901 or /usr/local/php/lib/php/extensions/no-debug-zts-20010901.

참고: dl() is not supported in multithreaded Web servers. Use the extensions statement in your php.ini when operating under such an environment. However, the CGI and CLI build are not affected !

참고: dl() is case sensitive on Unix platforms.

참고: 이 함수는 안전 모드에서 사용할 수 없습니다.

See also Extension Loading Directives and extension_loaded().

이전 | 처음으로 | 다음
assert | 위로 | extension_loaded


extension_loaded

(PHP 3>= 3.0.10, PHP 4 , PHP 5)

extension_loaded -- Find out whether an extension is loaded

Description

bool extension_loaded ( string name)

Returns TRUE if the extension identified by name is loaded, FALSE otherwise.

예 1. extension_loaded() example

<?php
if (!extension_loaded('gd')) {
    if (!dl('gd.so')) {
        exit;
    }
}
?>

You can see the names of various extensions by using phpinfo() or if you're using the CGI or CLI version of PHP you can use the -m switch to list all available extensions:
$ php -m
[PHP Modules]
xml
tokenizer
standard
sockets
session
posix
pcre
overload
mysql
mbstring
ctype

[Zend Modules]

참고: extension_loaded() uses the internal extension name to test whether a certain extension is available or not. Most internal extension names are written in lower case but there may be extension available which also use uppercase letters. Be warned that this function compares case sensitive !

See also
get_loaded_extensions(),
get_extension_funcs(),
phpinfo(), and
dl().

이전 | 처음으로 | 다음
dl | 위로 | get_cfg_var


get_cfg_var

(PHP 3, PHP 4 , PHP 5)

get_cfg_var -- PHP 설정 옵션의 값을 얻습니다.

설명

string get_cfg_var ( string varname)

varname으로 지정한 PHP 설정 변수의 값을 반환하거나, 에러가 발생했을 때 FALSE를 반환합니다.

PHP 컴파일시에 설정했거나, (php3_configuration_option 지시어를 이용하여) 아파치 설정 파일에서 읽는 정보는 반환하지 않습니다.

시스템이 어떤 설정 파일를 사용하는지 확인하려면, cfg_file_path 설정값을 확인해보십시오. 존재한다면, 그 설정 파일을 사용합니다.

참고: ini_get().

이전 | 처음으로 | 다음
extension_loaded | 위로 | get_current_user


get_current_user

(PHP 3, PHP 4 , PHP 5)

get_current_user -- 현재 PHP 스크립트 소유자의 이름을 얻습니다.

Description

string get_current_user ( void )

현재 PHP 스크립트 소유자의 이름을 반환합니다.

참고: getmyuid(),
getmygid(), getmypid(),
getmyinode(),
getlastmod().

이전 | 처음으로 | 다음
get_cfg_var | 위로 | get_defined_constants


get_defined_constants

(PHP 4 >= 4.1.0, PHP 5)

get_defined_constants -- 모든 상수와 그 값의 연관 배열을 반환합니다.

설명

array get_defined_constants ( void )

현재 정의된 모든 상수의 이름과 값을 반환합니다. 여기에는 확장 모듈에서 작성한 상수와 define() 함수로 작성한 상수를 포함합니다.

아래는 예제입니다:

<?php
print_r(get_defined_constants());
?>

다음과 같이 출력할 것입니다:

Array
(
    [E_ERROR] => 1
    [E_WARNING] => 2
    [E_PARSE] => 4
    [E_NOTICE] => 8
    [E_CORE_ERROR] => 16
    [E_CORE_WARNING] => 32
    [E_COMPILE_ERROR] => 64
    [E_COMPILE_WARNING] => 128
    [E_USER_ERROR] => 256
    [E_USER_WARNING] => 512
    [E_USER_NOTICE] => 1024
    [E_ALL] => 2047
    [TRUE] => 1
)

참고: get_loaded_extensions(),
get_defined_functions(),
get_defined_vars().

이전 | 처음으로 | 다음
get_current_user | 위로 | get_extension_funcs


get_extension_funcs

(PHP 4 , PHP 5)

get_extension_funcs -- 모듈의 함수명을 배열로 반환합니다.

설명

array get_extension_funcs ( string module_name)

module_name가 지시하는 모듈에 정의된 모든 함수명을 반환합니다.

아래는 예제입니다.

<?php
print_r(get_extension_funcs("xml"));
print_r(get_extension_funcs("gd"));
?>

xml과 gd 모듈에 존재하는 함수 목록을 출력할 것입니다.

참고: get_loaded_extensions()

이전 | 처음으로 | 다음
get_defined_constants | 위로 | get_include_path


get_include_path

(PHP 4 >= 4.3.0, PHP 5)

get_include_path -- Gets the current include_path configuration option

Description

string get_include_path ( void )

Gets the current include_path configuration option value.

예 1. get_include_path() example

<?php
// Works as of PHP 4.3.0
echo get_include_path();

// Works in all PHP versions
echo ini_get('include_path');
?>

See also ini_get(),
restore_include_path(),
set_include_path(), and
include().

이전 | 처음으로 | 다음
get_extension_funcs | 위로 | get_included_files


get_included_files

(PHP 4 , PHP 5)

get_included_files -- include나 require한 파일명의 배열을 반환합니다.

설명

array get_included_files ( void )

include(), include_once(), require(), require_once()를 사용하여 포함한 파일명을 배열로 반환합니다.

호출한 스크립트 파일은 "포함한 파일"로 처리하기에, include() 등으로 참조한 파일과 같이 나옵니다.

여러번 include나 require한 파일은 반환하는 배열에 한번만 나옵니다.

참고: auto_prepend_file 설정 지시어를 사용하여 포함한 파일은 반환 배열에 나오지 않습니다.

예 1. get_included_files() 예제 (abc.php)

<?php

include 'test1.php';
include_once 'test2.php';
require 'test3.php';
require_once 'test4.php';

$included_files = get_included_files();

foreach ($included_files as $filename) {
    echo "$filename\n";
}

?>

이는 다음을 출력할 것입니다:

abc.php
test1.php
test2.php
test3.php
test4.php

참고: PHP 4.0.1pl2 이전 버전에서 get_included_files()는, .php 확장자로 끝나는 파일만 반환하고, 다른 확장자는 반환하지 않았습니다. get_included_files()가 반환하는 배열은 include()와 include_once()로 포함한 파일만 가지는 연관 배열이였습니다.

참고:
include(),
include_once(),
require(),
require_once(),
get_required_files().

이전 | 처음으로 | 다음
get_include_path | 위로 | get_loaded_extensions


get_loaded_extensions

(PHP 4 , PHP 5)

get_loaded_extensions -- 적재된 모든 모듈명을 배열로 반환합니다.

설명

array get_loaded_extensions ( void )

PHP 인터프리터에 적재된 모든 모듈명을 반환합니다.

아래는 예는

<?php
print_r(get_loaded_extensions());
?>

다음과 비슷하게 출력합니다:

Array
(
   [0] => xml
   [1] => wddx
   [2] => standard
   [3] => session
   [4] => posix
   [5] => pgsql
   [6] => pcre
   [7] => gd
   [8] => ftp
   [9] => db
   [10] => calendar
   [11] => bcmath
)

참고:
get_extension_funcs(),
extension_loaded(),
dl(),
phpinfo().

이전 | 처음으로 | 다음
get_included_files | 위로 | get_magic_quotes_gpc


get_magic_quotes_gpc

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

get_magic_quotes_gpc -- Gets the current active configuration setting of magic quotes gpc

Description

int get_magic_quotes_gpc ( void )

Returns the current active configuration setting of magic_quotes_gpc (0 for off, 1 for on).

참고: If the directive magic_quotes_sybase is ON it will completely override magic_quotes_gpc. So even when get_magic_quotes() returns TRUE neither double quotes, backslashes or NUL's will be escaped. Only single quotes will be escaped. In this case they'll look like: ''

Keep in mind that magic_quotes_gpc can not be set at runtime.

예 1. get_magic_quotes_gpc() example

<?php
echo get_magic_quotes_gpc();         // 1
echo $_POST['lastname'];             // O\'reilly
echo addslashes($_POST['lastname']); // O\\\'reilly

if (!get_magic_quotes_gpc()) {
    $lastname = addslashes($_POST['lastname']);
} else {
    $lastname = $_POST['lastname'];
}

echo $lastname; // O\'reilly
$sql = "INSERT INTO lastnames (lastname) VALUES ('$lastname')";
?>

See also addslashes(),
stripslashes(),
get_magic_quotes_runtime(), and
ini_get().

이전 | 처음으로 | 다음
get_loaded_extensions | 위로 | get_magic_quotes_runtime


get_magic_quotes_runtime

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

get_magic_quotes_runtime -- Gets the current active configuration setting of magic_quotes_runtime

Description

int get_magic_quotes_runtime ( void )

Returns the current active configuration setting of magic_quotes_runtime (0 for off, 1 for on).

See also get_magic_quotes_gpc() and set_magic_quotes_runtime().

이전 | 처음으로 | 다음
get_magic_quotes_gpc | 위로 | get_required_files


get_required_files

get_required_files -- get_included_files()의 별칭.

설명

이 함수는 get_included_files()의 별칭입니다.

이전 | 처음으로 | 다음
get_magic_quotes_runtime | 위로 | getenv


getenv

(PHP 3, PHP 4 , PHP 5)

getenv -- 환경 변수값을 얻습니다.

설명

string getenv ( string varname)

환경 변수 varname의 값을 반환하거나, 에러가 있을 경우 FALSE를 반환합니다.

<?php
$ip = getenv("REMOTE_ADDR"); // 사용자의 ip 번호를 얻습니다.
?>

모든 환경 변수 목록을 phpinfo()를 사용하여 볼 수 있습니다. 대부분의 의미는 CGI 규정에서, 정확히는 환경 변수 페이지에서 확인할 수 있습니다.

참고: ISAPI 모드에서는 작동하지 않습니다.

참고: putenv().

이전 | 처음으로 | 다음
get_required_files | 위로 | getlastmod


getlastmod

(PHP 3, PHP 4 , PHP 5)

getlastmod -- 페이지를 수정한 최종 시간을 얻습니다.

설명

int getlastmod ( void )

현재 페이지를 마지막으로 수정한 시간을 반환합니다. 반환값은 date()에 적합한 유닉스 타임스탬프입니다. 오류가 발생하면 FALSE를 반환합니다.

예 1. getlastmod() 예제

<?php
// 출력 예. 'Last modified: March 04 1998 20:43:59.'
echo "Last modified: " . date ("F d Y H:i:s.", getlastmod());
?>

참고: 다른 파일의 수정 시간을 얻고자 한다면, filemtime()을 사용하십시오.

참고:
date(),
getmyuid(),
getmygid(),
get_current_user(),
getmyinode(),
getmypid(),
filemtime().

이전 | 처음으로 | 다음
getenv | 위로 | getmygid


getmygid

(PHP 4 >= 4.1.0, PHP 5)

getmygid -- Get PHP script owner's GID

Description

int getmygid ( void )

Returns the group ID of the current script, or FALSE on error.

See also getmyuid(),
getmypid(),
get_current_user(),
getmyinode(), and
getlastmod().

이전 | 처음으로 | 다음
getlastmod | 위로 | getmyinode


getmyinode

(PHP 3, PHP 4 , PHP 5)

getmyinode -- Gets the inode of the current script

Description

int getmyinode ( void )

Returns the current script's inode, or FALSE on error.

See also
getmygid(),
getmyuid(),
get_current_user(),
getmypid(), and
getlastmod().

참고: 이 함수는 윈도우 플랫폼에서는 작동하지 않습니다.

이전 | 처음으로 | 다음
getmygid | 위로 | getmypid


getmypid

(PHP 3, PHP 4 , PHP 5)

getmypid -- Gets PHP's process ID

Description

int getmypid ( void )

Returns the current PHP process ID, or FALSE on error.

주의

Process IDs are not unique, thus they are a weak entropy source. We recommend against relying on pids in security-dependent contexts.

See also
getmygid(),
getmyuid(),
get_current_user(),
getmyinode(), and
getlastmod().

이전 | 처음으로 | 다음
getmyinode | 위로 | getmyuid


getmyuid

(PHP 3, PHP 4 , PHP 5)

getmyuid -- Gets PHP script owner's UID

Description

int getmyuid ( void )

Returns the user ID of the current script, or FALSE on error.

See also getmygid(),
getmypid(),
get_current_user(),
getmyinode(), and
getlastmod().

이전 | 처음으로 | 다음
getmypid | 위로 | getopt


getopt

(PHP 4 >= 4.3.0, PHP 5)

getopt -- Gets options from the command line argument list

Description

array getopt ( string options)

Returns an associative array of option / argument pairs based on the options format specified in options, or FALSE on an error.

<?php
// parse the command line ($GLOBALS['argv'])
$options = getopt("f:hp:");
?>

The options parameter may contain the following elements: individual characters, and characters followed by a colon to indicate an option argument is to follow. For example, an option string x recognizes an option -x, and an option string x: recognizes an option and argument -x argument. It does not matter if an argument has leading white space.

This function will return an array of option / argument pairs. If an option does not have an argument, the value will be set to FALSE.

참고: 이 함수는 윈도우 플랫폼에서는 작동하지 않습니다.

이전 | 처음으로 | 다음
getmyuid | 위로 | getrusage


getrusage

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

getrusage -- Gets the current resource usages

Description

array getrusage ( [int who])

This is an interface to getrusage(2). It returns an associative array containing the data returned from the system call. If who is 1, getrusage will be called with RUSAGE_CHILDREN.

All entries are accessible by using their documented field names.

예 1. getrusage() example

<?php
$dat = getrusage();
echo $dat["ru_nswap"];         // number of swaps
echo $dat["ru_majflt"];        // number of page faults
echo $dat["ru_utime.tv_sec"];  // user time used (seconds)
echo $dat["ru_utime.tv_usec"]; // user time used (microseconds)
?>
See your system's man page on getrusage(2) for more details.

참고: 이 함수는 윈도우 플랫폼에서는 작동하지 않습니다.

이전 | 처음으로 | 다음
getopt | 위로 | ini_alter


ini_alter

ini_alter -- ini_set()의 별칭

설명

이 함수는 ini_set()의 별칭입니다.

이전 | 처음으로 | 다음
getrusage | 위로 | ini_get_all


ini_get_all

(PHP 4 >= 4.2.0, PHP 5)

ini_get_all -- 모든 설정 옵션을 얻습니다.

설명

array ini_get_all ( [string extension])

등록된 모든 설정 옵션을 연관 배열로 반환합니다. 선택적인 extension을 설정하면, 그 확장에 해당하는 옵션만을 반환합니다.

지시어 이름을 배열 키로, global_value(php.ini에서 설정), local_value(ini_set()이나 .htaccess로 설정), access(접근 레벨)를 배열 요소로 가지는 배열의 배열을 반환합니다. 접근 레벨에 대한 정보는 매뉴얼 섹션 설정 변경를 참고하십시오.

참고: 지시어가 복수의 접근 레벨을 가질 수 있기에, access는 적절한 비트마스트 값을 가집니다.

예 1. A ini_get_all() 예제

<?php
$inis = ini_get_all();

print_r($inis);

?>

부분적인 출력 예:

Array
(
    [allow_call_time_pass_reference] => Array
    (
        [global_value] => 1
        [local_value] => 1
        [access] => 6
    )
    [allow_url_fopen] => Array
    (
        [global_value] => 1
        [local_value] => 1
        [access] => 7
    )

    ...

)

참고: ini_get(),
ini_restore(),
ini_set(),
get_loaded_extensions(),
phpinfo().

이전 | 처음으로 | 다음
ini_alter | 위로 | ini_get


ini_get

(PHP 4 , PHP 5)

ini_get -- Gets the value of a configuration option

Description

string ini_get ( string varname)

Returns the value of the configuration option on success. Failure, such as querying for a non-existant value, will return an empty string.

When querying boolean values: A boolean ini value of off will be returned as an empty string while a boolean ini value of on will be returned as "1".

When querying memory size values: Many ini memory size values, such as upload_max_filesize are stored in the php.ini file in shorthand notation. ini_get() will return the exact string stored in the php.ini file, NOT its integer equivalent. Attempting normal arithmetic functions on these values will not have otherwise expected results.

<?php
/*
Our php.ini contains the following settings:

display_errors = On
register_globals = Off
post_max_size = 8M
*/

echo 'display_errors = ' . ini_get('display_errors') . "\n";
echo 'register_globals = ' . ini_get('register_globals') . "\n";
echo 'post_max_size = ' . ini_get('post_max_size') . "\n";
echo 'post_max_size+1 = ' . (ini_get('post_max_size')+1) . "\n";

?>

This script will produce:

display_errors = 1
register_globals = 0
post_max_size = 8M
post_max_size+1 = 9

See also
get_cfg_var(),
ini_get_all(),
ini_restore(), and
ini_set().

이전 | 처음으로 | 다음
ini_get_all | 위로 | ini_restore


ini_restore

(PHP 4 , PHP 5)

ini_restore -- 설정 옵션의 값을 복구합니다.

설명

void ini_restore ( string varname)

주어진 설정 옵션을 기본값으로 복구합니다.

참고:
ini_get(),
ini_get_all(),
ini_set().

이전 | 처음으로 | 다음
ini_get | 위로 | ini_set


ini_set

(PHP 4 , PHP 5)

ini_set -- Sets the value of a configuration option

Description

string ini_set ( string varname, string newvalue)

Sets the value of the given configuration option. Returns the old value on success, FALSE on failure. The configuration option will keep this new value during the script's execution, and will be restored at the script's ending.

Not all the available options can be changed using ini_set(). Below is a table with a list of all PHP options (as of PHP 4.2.0), indicating which ones can be changed/set and at what level.

표 1. Configuration options

Name | Default | Changeable
com.allow_dcom | "0" | PHP_INI_SYSTEM
com.autoregister_typelib | "0" | PHP_INI_SYSTEM
com.autoregister_verbose | "0" | PHP_INI_SYSTEM
com.autoregister_casesensitive | "1" | PHP_INI_SYSTEM
com.typelib_file | "" | PHP_INI_SYSTEM
crack.default_dictionary | NULL | PHP_INI_SYSTEM
exif.encode_unicode | "ISO-8859-15" | PHP_INI_ALL
exif.decode_unicode_motorola | "UCS-2BE" | PHP_INI_ALL
exif.decode_unicode_intel | "UCS-2LE" | PHP_INI_ALL
exif.encode_jis | "" | PHP_INI_ALL
exif.decode_jis_motorola | "JIS" | PHP_INI_ALL
exif.decode_jis_intel | "JIS" | PHP_INI_ALL
fbsql.allow_persistent | "1" | PHP_INI_SYSTEM
fbsql.generate_warnings | "0" | PHP_INI_SYSTEM
fbsql.autocommit | "1" | PHP_INI_SYSTEM
fbsql.max_persistent | "-1" | PHP_INI_SYSTEM
fbsql.max_links | "128" | PHP_INI_SYSTEM
fbsql.max_connections | "128" | PHP_INI_SYSTEM
fbsql.max_results | "128" | PHP_INI_SYSTEM
fbsql.batchSize | "1000" | PHP_INI_SYSTEM
fbsql.default_host | NULL | PHP_INI_SYSTEM
fbsql.default_user | "_SYSTEM" | PHP_INI_SYSTEM
fbsql.default_password | "" | PHP_INI_SYSTEM
fbsql.default_database | "" | PHP_INI_SYSTEM
fbsql.default_database_password | "" | PHP_INI_SYSTEM
hwapi.allow_persistent | "0" | PHP_INI_SYSTEM
hyperwave.allow_persistent | "0" | PHP_INI_SYSTEM
hyperwave.default_port | "418" | PHP_INI_ALL
iconv.input_encoding | ICONV_INPUT_ENCODING | PHP_INI_ALL
iconv.output_encoding | ICONV_OUTPUT_ENCODING | PHP_INI_ALL
iconv.internal_encoding | ICONV_INTERNAL_ENCODING | PHP_INI_ALL
ifx.allow_persistent | "1" | PHP_INI_SYSTEM
ifx.max_persistent | "-1" | PHP_INI_SYSTEM
ifx.max_links | "-1" | PHP_INI_SYSTEM
ifx.default_host | NULL | PHP_INI_SYSTEM
ifx.default_user | NULL | PHP_INI_SYSTEM
ifx.default_password | NULL | PHP_INI_SYSTEM
ifx.blobinfile | "1" | PHP_INI_ALL
ifx.textasvarchar | "0" | PHP_INI_ALL
ifx.byteasvarchar | "0" | PHP_INI_ALL
ifx.charasvarchar | "0" | PHP_INI_ALL
ifx.nullformat | "0" | PHP_INI_ALL
ingres.allow_persistent | "1" | PHP_INI_SYSTEM
ingres.max_persistent | "-1" | PHP_INI_SYSTEM
ingres.max_links | "-1" | PHP_INI_SYSTEM
ingres.default_database | NULL | PHP_INI_ALL
ingres.default_user | NULL | PHP_INI_ALL
ingres.default_password | NULL | PHP_INI_ALL
ibase.allow_persistent | "1" | PHP_INI_SYSTEM
ibase.max_persistent | "-1" | PHP_INI_SYSTEM
ibase.max_links | "-1" | PHP_INI_SYSTEM
ibase.default_user | NULL | PHP_INI_ALL
ibase.default_password | NULL | PHP_INI_ALL
ibase.timestampformat | "%m/%d/%Y%H:%M:%S" | PHP_INI_ALL
ibase.dateformat | "%m/%d/%Y" | PHP_INI_ALL
ibase.timeformat | "%H:%M:%S" | PHP_INI_ALL
java.class.path | NULL | PHP_INI_ALL
java.home | NULL | PHP_INI_ALL
java.library.path | NULL | PHP_INI_ALL
java.library | JAVALIB | PHP_INI_ALL
java.library | NULL | PHP_INI_ALL
ldap.max_links | "-1" | PHP_INI_SYSTEM
mbstring.detect_order | NULL | PHP_INI_ALL
mbstring.http_input | NULL | PHP_INI_ALL
mbstring.http_output | NULL | PHP_INI_ALL
mbstring.internal_encoding | NULL | PHP_INI_ALL
mbstring.substitute_character | NULL | PHP_INI_ALL
mbstring.func_overload | "0" | PHP_INI_SYSTEM
mcrypt.algorithms_dir | NULL | PHP_INI_ALL
mcrypt.modes_dir | NULL | PHP_INI_ALL
mime_magic.magicfile | "/usr/share/misc/magic.mime" | PHP_INI_SYSTEM
mssql.allow_persistent | "1" | PHP_INI_SYSTEM
mssql.max_persistent | "-1" | PHP_INI_SYSTEM
mssql.max_links | "-1" | PHP_INI_SYSTEM
mssql.max_procs | "25" | PHP_INI_ALL
mssql.min_error_severity | "10" | PHP_INI_ALL
mssql.min_message_severity | "10" | PHP_INI_ALL
mssql.compatability_mode | "0" | PHP_INI_ALL
mssql.connect_timeout | "5" | PHP_INI_ALL
mssql.timeout | "60" | PHP_INI_ALL
mssql.textsize | "-1" | PHP_INI_ALL
mssql.textlimit | "-1" | PHP_INI_ALL
mssql.batchsize | "0" | PHP_INI_ALL
mssql.datetimeconvert | "1" | PHP_INI_ALL
mssql.secure_connection | "0" | PHP_INI_SYSTEM
mysql.allow_persistent | "1" | PHP_INI_SYSTEM
mysql.max_persistent | "-1" | PHP_INI_SYSTEM
mysql.max_links | "-1" | PHP_INI_SYSTEM
mysql.default_host | NULL | PHP_INI_ALL
mysql.default_user | NULL | PHP_INI_ALL
mysql.default_password | NULL | PHP_INI_ALL
mysql.default_port | NULL | PHP_INI_ALL
mysql.default_socket | NULL | PHP_INI_ALL
ncurses.value | "42" | PHP_INI_ALL
ncurses.string | "foobar" | PHP_INI_ALL
odbc.allow_persistent | "1" | PHP_INI_SYSTEM
odbc.max_persistent | "-1" | PHP_INI_SYSTEM
odbc.max_links | "-1" | PHP_INI_SYSTEM
odbc.default_db | NULL | PHP_INI_ALL
odbc.default_user | NULL | PHP_INI_ALL
odbc.default_pw | NULL | PHP_INI_ALL
odbc.defaultlrl | "4096" | PHP_INI_ALL
odbc.defaultbinmode | "1" | PHP_INI_ALL
odbc.check_persistent | "1" | PHP_INI_SYSTEM
pfpro.defaulthost | "test.signio.com" |
pfpro.defaulthost | "test-payflow.verisign.com" |
pfpro.defaultport | "443" | PHP_INI_ALL
pfpro.defaulttimeout | "30" | PHP_INI_ALL
pfpro.proxyaddress | "" | PHP_INI_ALL
pfpro.proxyport | "" | PHP_INI_ALL
pfpro.proxylogon | "" | PHP_INI_ALL
pfpro.proxypassword | "" | PHP_INI_ALL
pgsql.allow_persistent | "1" | PHP_INI_SYSTEM
pgsql.max_persistent | "-1" | PHP_INI_SYSTEM
pgsql.max_links | "-1" | PHP_INI_SYSTEM
pgsql.auto_reset_persistent | "0" | PHP_INI_SYSTEM
pgsql.ignore_notice | "0" | PHP_INI_ALL
pgsql.log_notice | "0" | PHP_INI_ALL
session.save_path | "/tmp" | PHP_INI_ALL
session.name | "PHPSESSID" | PHP_INI_ALL
session.save_handler | "files" | PHP_INI_ALL
session.auto_start | "0" | PHP_INI_ALL
session.gc_probability | "1" | PHP_INI_ALL
session.gc_divisor | "100" | PHP_INI_ALL
session.gc_maxlifetime | "1440" | PHP_INI_ALL
session.serialize_handler | "php" | PHP_INI_ALL
session.cookie_lifetime | "0" | PHP_INI_ALL
session.cookie_path | "/" | PHP_INI_ALL
session.cookie_domain | "" | PHP_INI_ALL
session.cookie_secure | "" | PHP_INI_ALL
session.use_cookies | "1" | PHP_INI_ALL
session.use_only_cookies | "0" | PHP_INI_ALL
session.referer_check | "" | PHP_INI_ALL
session.entropy_file | "" | PHP_INI_ALL
session.entropy_length | "0" | PHP_INI_ALL
session.cache_limiter | "nocache" | PHP_INI_ALL
session.cache_expire | "180" | PHP_INI_ALL
session.use_trans_sid | "0" | PHP_INI_SYSTEM|PHP_INI_PERDIR
session.encode_sources | "globals,track" | PHP_INI_ALL
assert.active | "1" | PHP_INI_ALL
assert.bail | "0" | PHP_INI_ALL
assert.warning | "1" | PHP_INI_ALL
assert.callback | NULL | PHP_INI_ALL
assert.quiet_eval | "0" | PHP_INI_ALL
safe_mode_protected_env_vars | SAFE_MODE_PROTECTED_ENV_VARS | PHP_INI_SYSTEM
safe_mode_allowed_env_vars | SAFE_MODE_ALLOWED_ENV_VARS | PHP_INI_SYSTEM
url_rewriter.tags | "a=href,area=href,frame=src,form=fakeentry" | PHP_INI_ALL
sybct.allow_persistent | "1" | PHP_INI_SYSTEM
sybct.max_persistent | "-1" | PHP_INI_SYSTEM
sybct.max_links | "-1" | PHP_INI_SYSTEM
sybct.min_server_severity | "10" | PHP_INI_ALL
sybct.min_client_severity | "10" | PHP_INI_ALL
sybct.hostname | NULL | PHP_INI_ALL
vpopmail.directory | "" | PHP_INI_ALL
zlib.output_compression | "0" | PHP_INI_SYSTEM|PHP_INI_PERDIR
zlib.output_compression_level | "-1" | PHP_INI_ALL
define_syslog_variables | "0" | PHP_INI_ALL
highlight.bg | HL_BG_COLOR | PHP_INI_ALL
highlight.comment | HL_COMMENT_COLOR | PHP_INI_ALL
highlight.default | HL_DEFAULT_COLOR | PHP_INI_ALL
highlight.html | HL_HTML_COLOR | PHP_INI_ALL
highlight.keyword | HL_KEYWORD_COLOR | PHP_INI_ALL
highlight.string | HL_STRING_COLOR | PHP_INI_ALL
allow_call_time_pass_reference | "1" | PHP_INI_SYSTEM|PHP_INI_PERDIR
asp_tags | "0" | PHP_INI_SYSTEM|PHP_INI_PERDIR
display_errors | "1" | PHP_INI_ALL
display_startup_errors | "0" | PHP_INI_ALL
enable_dl | "1" | PHP_INI_SYSTEM
expose_php | "1" | PHP_INI_SYSTEM
html_errors | "1" | PHP_INI_ALL
xmlrpc_errors | "0" | PHP_INI_SYSTEM
xmlrpc_error_number | "0" | PHP_INI_ALL
ignore_user_abort | "0" | PHP_INI_ALL
implicit_flush | "0" | PHP_INI_ALL
log_errors | "0" | PHP_INI_ALL
log_errors_max_len | "1024" | PHP_INI_ALL
ignore_repeated_errors | "0" | PHP_INI_ALL
ignore_repeated_source | "0" | PHP_INI_ALL
magic_quotes_gpc | "1" | PHP_INI_PERDIR|PHP_INI_SYSTEM
magic_quotes_runtime | "0" | PHP_INI_ALL
magic_quotes_sybase | "0" | PHP_INI_ALL
output_buffering | "0" | PHP_INI_PERDIR|PHP_INI_SYSTEM
output_handler | NULL | PHP_INI_PERDIR|PHP_INI_SYSTEM
register_argc_argv | "1" | PHP_INI_PERDIR|PHP_INI_SYSTEM
register_globals | "0" | PHP_INI_PERDIR|PHP_INI_SYSTEM
safe_mode | "1" | PHP_INI_SYSTEM
safe_mode | "0" | PHP_INI_SYSTEM
safe_mode_include_dir | NULL | PHP_INI_SYSTEM
safe_mode_gid | "0" | PHP_INI_SYSTEM
short_open_tag | DEFAULT_SHORT_OPEN_TAG | PHP_INI_SYSTEM|PHP_INI_PERDIR
sql.safe_mode | "0" | PHP_INI_SYSTEM
track_errors | "0" | PHP_INI_ALL
y2k_compliance | "0" | PHP_INI_ALL
unserialize_callback_func | NULL | PHP_INI_ALL
arg_separator.output | "&" | PHP_INI_ALL
arg_separator.input | "&" | PHP_INI_SYSTEM|PHP_INI_PERDIR
auto_append_file | NULL | PHP_INI_SYSTEM|PHP_INI_PERDIR
auto_prepend_file | NULL | PHP_INI_SYSTEM|PHP_INI_PERDIR
doc_root | NULL | PHP_INI_SYSTEM
default_charset | SAPI_DEFAULT_CHARSET | PHP_INI_ALL
default_mimetype | SAPI_DEFAULT_MIMETYPE | PHP_INI_ALL
error_log | NULL | PHP_INI_ALL
extension_dir | PHP_EXTENSION_DIR | PHP_INI_SYSTEM
gpc_order | "GPC" | PHP_INI_ALL
include_path | PHP_INCLUDE_PATH | PHP_INI_ALL
max_execution_time | "30" | PHP_INI_ALL
open_basedir | NULL | PHP_INI_SYSTEM
safe_mode_exec_dir | "1" | PHP_INI_SYSTEM
upload_max_filesize | "2M" | PHP_INI_SYSTEM|PHP_INI_PERDIR
file_uploads | "1" | PHP_INI_SYSTEM
post_max_size | "8M" | PHP_INI_SYSTEM|PHP_INI_PERDIR
upload_tmp_dir | NULL | PHP_INI_SYSTEM
user_dir | NULL | PHP_INI_SYSTEM
variables_order | NULL | PHP_INI_ALL
error_append_string | NULL | PHP_INI_ALL
error_prepend_string | NULL | PHP_INI_ALL
SMTP | "localhost" | PHP_INI_ALL
smtp_port | 25 | PHP_INI_ALL
browscap | NULL | PHP_INI_SYSTEM
error_reporting | NULL | PHP_INI_ALL
memory_limit | "8M" | PHP_INI_ALL
precision | "14" | PHP_INI_ALL
sendmail_from | NULL | PHP_INI_ALL
sendmail_path | DEFAULT_SENDMAIL_PATH | PHP_INI_SYSTEM
disable_classes | "" | php.ini only
disable_functions | "" | php.ini only
allow_url_fopen | "1" | PHP_INI_ALL
always_populate_raw_post_data | "0" | PHP_INI_SYSTEM|PHP_INI_PERDIR
xbithack | "0" | PHP_INI_ALL
engine | "1" | PHP_INI_ALL
last_modified | "0" | PHP_INI_ALL
child_terminate | "0" | PHP_INI_ALL
async_send | "0" | PHP_INI_ALL

표 2. Definition of PHP_INI_* constants

Constant | Value | Meaning
PHP_INI_USER | 1 | Entry can be set in user scripts
PHP_INI_PERDIR | 2 | Entry can be set in php.ini, .htaccess or httpd.conf
PHP_INI_SYSTEM | 4 | Entry can be set in php.ini or httpd.conf
PHP_INI_ALL | 7 | Entry can be set anywhere

See also: get_cfg_var(),
ini_get(),
ini_get_all(), and
ini_restore()

이전 | 처음으로 | 다음
ini_restore | 위로 | main


main

main -- Dummy for main()

Description

There is no function named main() except in the PHP source. In PHP 4.3.0, a new type of error handling in the PHP source (php_error_docref) was introduced. One feature is to provide links to a manual page in PHP error messages when the PHP directives html_errors (on by default) and docref_root (on by default until PHP 4.3.2) are set.

Sometimes error messages refer to a manual page for the function main() which is why this page exists. Please add a user comment below that mentions what PHP function caused the error that linked to main() and it will be fixed and properly documented.

표 1. Known errors that point to main()

Function name | No longer points here as of
include() | 4.3.2
include_once() | 4.3.2
require() | 4.3.2
require_once() | 4.3.2

See also html_errors and display_errors.

이전 | 처음으로 | 다음
ini_set | 위로 | memory_get_usage


memory_get_usage

(PHP 4 >= 4.3.2, PHP 5)

memory_get_usage -- Returns the amount of memory allocated to PHP

Description

int memory_get_usage ( void )

Returns the amount of memory, in bytes, that's currently being allocated to your PHP script.

memory_get_usage() will only be defined if your PHP is compiled with the --enable-memory-limit configuration option.

예 1. A memory_get_usage() example

<?php
// This is only an example, the numbers below will
// differ depending on your system

echo memory_get_usage() . "\n"; // 36640

$a = str_repeat("Hello", 4242);

echo memory_get_usage() . "\n"; // 57960

unset($a);

echo memory_get_usage() . "\n"; // 36744

?>

See also memory_limit.

이전 | 처음으로 | 다음
main | 위로 | php_ini_scanned_files


php_ini_scanned_files

(PHP 4 >= 4.3.0, PHP 5)

php_ini_scanned_files -- Return a list of .ini files parsed from the additional ini dir

Description

string php_ini_scanned_files ( void )

php_ini_scanned_files() returns a comma-separated list of configuration files parsed after php.ini. These files are found in a directory defined by the --with-config-file-scan-dir. option which is set during compilation.

Returns a comma-separated string of .ini files on success. If the directive --with-config-files-scan-dir wasn't set, FALSE is returned. If it was set and the directory was empty, an empty string is returned. If a file is unrecognizable, the file will still make it into the returned string but a PHP error will also result. This PHP error will be seen both at compile time and while using php_ini_scanned_files().

The returned configuration files also include the path as declared in the --with-config-file-scan-dir directive. Also, each comma is followed by a newline.

예 1. A simple example to list the returned ini files

<?php
if ($filelist = php_ini_scanned_files()) {
    if (strlen($filelist) > 0) {
        $files = explode(',', $filelist);

        foreach ($files as $file) {
            echo "<li>" . trim($file) . "</li>\n";
        }
    }
}
?>

See also ini_set() and phpinfo().

이전 | 처음으로 | 다음
memory_get_usage | 위로 | php_logo_guid


php_logo_guid

(PHP 4 , PHP 5)

php_logo_guid -- Gets the logo guid

Description

string php_logo_guid ( void )

This function returns the ID which can be used to display the PHP logo using the built-in image.

예 1. php_logo_guid() example

<?php

echo '<img src="' . $_SERVER['PHP_SELF'] .
     '?=' . php_logo_guid() . '" alt="PHP Logo !" />';

?>

See also
phpinfo(),
phpversion(),
phpcredits() and
zend_logo_guid().

이전 | 처음으로 | 다음
php_ini_scanned_files | 위로 | php_sapi_name


php_sapi_name

(PHP 4 >= 4.0.1, PHP 5)

php_sapi_name -- 웹 서버와 PHP 간의 접근 형태를 반환합니다.

설명

string php_sapi_name ( void )

php_sapi_name()은 웹 서버와 PHP(서버 API, SAPI) 사이의 접근 형태를 설명하는 소문자 문자열을 반환합니다. CGI PHP에서, 문자열은 "cgi"이고, 아파치의 mod_php에서, 문자열은 "apache"인 형태입니다.

예 1. php_sapi_name() 예제

<?php
$sapi_type = php_sapi_name();
if ($sapi_type == "cgi") {
    echo "You are using CGI PHP\n";
} else {
    echo "You are not using CGI PHP\n";
}
?>

이전 | 처음으로 | 다음
php_logo_guid | 위로 | php_uname


php_uname

(PHP 4 >= 4.0.2, PHP 5)

php_uname -- Returns information about the operating system PHP was built on

Description

string php_uname ( void )

php_uname() returns a string with a description of the operating system PHP is built on. If you're just wanting the name of the operating system, consider using the PHP_OS constant.

예 1. Some php_uname() examples

<?php
echo php_uname();
echo PHP_OS;

/* Some possible outputs:
Linux localhost 2.4.21-0.13mdk #1 Fri Mar 14 15:08:06 EST 2003 i686
Linux

FreeBSD localhost 3.2-RELEASE #15: Mon Dec 17 08:46:02 GMT 2001
FreeBSD

Windows NT XN1 5.1 build 2600
WINNT
*/

if (strtoupper(substr(PHP_OS, 0, 3)) === 'WIN') {
    echo 'This is a server using Windows!';
} else {
    echo 'This is a server not using Windows!';
}

?>

There are also some related Predefined PHP constants that may come in handy, for example:

예 2. A few OS related constant examples

<?php
// *nix
echo DIRECTORY_SEPARATOR; // /
echo PHP_SHLIB_SUFFIX;    // so
echo PATH_SEPARATOR;      // :

// Win*
echo DIRECTORY_SEPARATOR; // \
echo PHP_SHLIB_SUFFIX;    // dll
echo PATH_SEPARATOR;      // ;
?>

See also phpversion(),
php_sapi_name(), and
phpinfo().

이전 | 처음으로 | 다음
php_sapi_name | 위로 | phpcredits


phpcredits

(PHP 4 , PHP 5)

phpcredits -- Prints out the credits for PHP

Description

void phpcredits ( [int flag])

This function prints out the credits listing the PHP developers, modules, etc. It generates the appropriate HTML codes to insert the information in a page. flag is optional, and it defaults to CREDITS_ALL. To generate a custom credits page, you may want to use the flag parameter. For example to print the general credits, you will use somewhere in your code:

<?php
phpcredits(CREDITS_GENERAL);
?>

And if you want to print the core developers and the documentation group, in a page of its own, you will use:

<?php
phpcredits(CREDITS_GROUP + CREDITS_DOCS + CREDITS_FULLPAGE);
?>

And if you feel like embedding all the credits in your page, then code like the one below will do it:

<html>
<head>
  <title>My credits page</title>
</head>
<body>
<?php
// some code of your own
phpcredits(CREDITS_ALL - CREDITS_FULLPAGE);
// some more code
?>
 </body>
</html>

표 1. Pre-defined phpcredits() flags

name | description
CREDITS_ALL | All the credits, equivalent to using: CREDITS_DOCS + CREDITS_GENERAL + CREDITS_GROUP + CREDITS_MODULES + CREDITS_FULLPAGE. It generates a complete stand-alone HTML page with the appropriate tags.
CREDITS_DOCS | The credits for the documentation team
CREDITS_FULLPAGE | Usually used in combination with the other flags. Indicates that the a complete stand-alone HTML page needs to be printed including the information indicated by the other flags.
CREDITS_GENERAL | General credits: Language design and concept, PHP 4.0 authors and SAPI module.
CREDITS_GROUP | A list of the core developers
CREDITS_MODULES | A list of the extension modules for PHP, and their authors
CREDITS_SAPI | A list of the server API modules for PHP, and their authors

See also phpinfo(),
phpversion() and
php_logo_guid().

이전 | 처음으로 | 다음
php_uname | 위로 | phpinfo


phpinfo

(PHP 3, PHP 4 , PHP 5)

phpinfo -- Outputs lots of PHP information

Description

int phpinfo ( [int what])

Outputs a large amount of information about the current state of PHP. This includes information about PHP compilation options and extensions, the PHP version, server information and environment (if compiled as a module), the PHP environment, OS version information, paths, master and local values of configuration options, HTTP headers, and the PHP License.

Because every system is setup differently, phpinfo() is commonly used to check configuration settings and for available predefined variables on a given system. Also, phpinfo() is a valuable debugging tool as it contains all EGPCS (Environment, GET, POST, Cookie, Server) data.

The output may be customized by passing one or more of the following constants bitwise values summed together in the optional what parameter. One can also combine the respective constants or bitwise values together with the or operator.

표 1. phpinfo() options

Name (constant) | Value | Description
INFO_GENERAL | 1 | The configuration line, php.ini location, build date, Web Server, System and more.
INFO_CREDITS | 2 | PHP 4 Credits. See also phpcredits().
INFO_CONFIGURATION | 4 | Current Local and Master values for PHP directives. See also ini_get().
INFO_MODULES | 8 | Loaded modules and their respective settings. See also get_loaded_modules().
INFO_ENVIRONMENT | 16 | Environment Variable information that's also available in $_ENV.
INFO_VARIABLES | 32 | Shows all predefined variables from EGPCS (Environment, GET, POST, Cookie, Server).
INFO_LICENSE | 64 | PHP License information. See also the license faq.
INFO_ALL | -1 | Shows all of the above. This is the default value.

예 1. phpinfo() examples

<?php

// Show all information, defaults to INFO_ALL
phpinfo();

// Show just the module information.
// phpinfo(8) yields identical results.
phpinfo(INFO_MODULES);

?>

참고: Parts of the information displayed are disabled when the expose_php configuration setting is set to off. This includes the PHP and Zend logos, and the credits.

참고: Since PHP 4.3.0, if html_errors is off, phpinfo() outputs plain text instead of HTML.

See also phpversion(),
phpcredits(),
php_logo_guid(),
ini_get(),
ini_set(),
get_loaded_modules(),
and the section on Predefined
Variables.

이전 | 처음으로 | 다음
phpcredits | 위로 | phpversion


phpversion

(PHP 3, PHP 4 , PHP 5)

phpversion -- Gets the current PHP version

Description

string phpversion ( void )

Returns a string containing the version of the currently running PHP parser.

참고: This information is also available in the predefined constant PHP_VERSION.

예 1. phpversion() example

<?php
// prints e.g. 'Current PHP version: 4.1.1'
echo 'Current PHP version: ' . phpversion();
?>

See also
version_compare(),
phpinfo(),
phpcredits(),
php_logo_guid(), and
zend_version().

이전 | 처음으로 | 다음
phpinfo | 위로 | putenv


putenv

(PHP 3, PHP 4 , PHP 5)

putenv -- Sets the value of an environment variable

Description

void putenv ( string setting)

Adds setting to the server environment. The environment variable will only exist for the duration of the current request. At the end of the request the environment is restored to its original state.

Setting certain environment variables may be a potential security breach. The safe_mode_allowed_env_vars directive contains a comma-delimited list of prefixes. In Safe Mode, the user may only alter environment variables whose names begin with the prefixes supplied by this directive. By default, users will only be able to set environment variables that begin with PHP_ (e.g. PHP_FOO=BAR). Note: if this directive is empty, PHP will let the user modify ANY environment variable!

The safe_mode_protected_env_vars directive contains a comma-delimited list of environment variables, that the end user won't be able to change using putenv(). These variables will be protected even if safe_mode_allowed_env_vars is set to allow to change them.

주의

These directives have only effect when safe-mode itself is enabled!

예 1. Setting an environment variable

<?php
putenv("UNIQID=$uniqid");
?>

See also getenv().

이전 | 처음으로 | 다음
phpversion | 위로 | restore_include_path


restore_include_path

(PHP 4 >= 4.3.0, PHP 5)

restore_include_path -- Restores the value of the include_path configuration option

Description

void restore_include_path ( void )

Restores the include_path configuration option back to its original master value as set in php.ini

예 1. restore_include_path() example

<?php

echo get_include_path();  // .:/usr/local/lib/php

set_include_path('/inc');

echo get_include_path();  // /inc

// Works as of PHP 4.3.0
restore_include_path();

// Works in all PHP versions
ini_restore('include_path');

echo get_include_path();  // .:/usr/local/lib/php

?>

See also ini_restore(),
set_include_path(),
get_include_path(), and
include().

이전 | 처음으로 | 다음
putenv | 위로 | set_include_path


set_include_path

(PHP 4 >= 4.3.0, PHP 5)

set_include_path -- Sets the include_path configuration option

Description

string set_include_path ( string new_include_path)

Sets the include_path configuration option for the duration of the script. Returns the old include_path on success or FALSE on failure.

예 1. set_include_path() example

<?php
// Works as of PHP 4.3.0
set_include_path('/inc');

// Works in all PHP versions
ini_set('include_path', '/inc');
?>

See also ini_set(),
get_include_path(),
restore_include_path(), and
include().

이전 | 처음으로 | 다음
restore_include_path | 위로 | set_magic_quotes_runtime


set_magic_quotes_runtime

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

set_magic_quotes_runtime -- Sets the current active configuration setting of magic_quotes_runtime

Description

bool set_magic_quotes_runtime ( int new_setting)

Set the current active configuration setting of magic_quotes_runtime (0 for off, 1 for on).

See also: get_magic_quotes_gpc() and get_magic_quotes_runtime().

이전 | 처음으로 | 다음
set_include_path | 위로 | set_time_limit


set_time_limit

(PHP 3, PHP 4 , PHP 5)

set_time_limit -- 최대 실행 시간을 제한합니다.

설명

void set_time_limit ( int seconds)

스크립트가 실행 가능한 시간을 초 단위로 설정합니다. 이 시간에 도달하면 스크립트는 치명적인 오류를 발생합니다. 기본 제한은 30초이거나, php.ini에 정의한 max_execution_time 값입니다. seconds를 0으로 설정하면, 시간 제한은 사라집니다.

호출할 때, set_time_limit()은 종료 시간을 0부터 다시 시작합니다. 즉, 기본 설정이 30초이고, 25초간 스크립트가 실행한 시점에서 set_time_limit(20)를 호출하면, 스크립트는 시간 제한까지 총 45초를 실행할 수 있습니다.

주의

set_time_limit()는 PHP가 안전 모드일 때는 작동하지 않습니다. 이 경우, 안전 모드를 설정하지 않거나, php.ini에서 시간 제한을 변경해야 합니다.

참고: set_time_limit() 함수와 설정 지시어 max_execution_time는 스크립트 자신의 실행 시간에만 영향을 받습니다. system()을 사용하는 시스템 콜이나, 스트림 작동, 데이터베이스 쿼리 등의 스크립트 밖에서 발생하는 행동은 스크립트 실행 시간을 측정할 때 포함하지 않습니다.

참고: ini 지시어 max_execution_time과 max_input_time.

이전 | 처음으로 | 다음
set_magic_quotes_runtime | 위로 | version_compare


version_compare

(PHP 4 >= 4.1.0, PHP 5)

version_compare -- Compares two "PHP-standardized" version number strings

Description

int version_compare ( string version1, string version2 [, string operator])

version_compare() compares two "PHP-standardized" version number strings. This is useful if you would like to write programs working only on some versions of PHP.

version_compare() returns -1 if the first version is lower than the second, 0 if they are equal, and +1 if the second is lower.

The function first replaces _, - and + with a dot . in the version strings and also inserts dots . before and after any non number so that for example '4.3.2RC1' becomes '4.3.2.RC.1'. Then it splits the results like if you were using explode('.', $ver). Then it compares the parts starting from left to right. If a part contains special version strings these are handled in the following order: dev < alpha = a < beta = b < RC < pl. This way not only versions with different levels like '4.1' and '4.1.2' can be compared but also any PHP specific version containing development state.

If you specify the third optional operator argument, you can test for a particular relationship. The possible operators are: <, lt, <=, le, >, gt, >=, ge, ==, =, eq, !=, <>, ne respectively. Using this argument, the function will return 1 if the relationship is the one specified by the operator, 0 otherwise.

예 1. version_compare() example

<?php
// prints -1
echo version_compare("4.0.4", "4.0.6");

// these all print 1
echo version_compare("4.0.4", "4.0.6", "<");
echo version_compare("4.0.6", "4.0.6", "eq");
?>

이전 | 처음으로 | 다음
set_time_limit | 위로 | zend_logo_guid


zend_logo_guid

(PHP 4 , PHP 5)

zend_logo_guid -- Gets the Zend guid

Description

string zend_logo_guid ( void )

This function returns the ID which can be used to display the Zend logo using the built-in image.

예 1. zend_logo_uid() example

<?php

echo '<img src="' . $_SERVER['PHP_SELF'] .
     '?=' . zend_logo_guid() . '" alt="Zend Logo !" />';

?>

See also php_logo_guid().

이전 | 처음으로 | 다음
version_compare | 위로 | zend_version


zend_version

(PHP 4 , PHP 5)

zend_version -- 현재 젠드 엔진의 버전을 얻습니다.

설명

string zend_version ( void )

현재 실행 중인 젠드 엔진 버전을 가지는 문자열을 반환합니다.

예 1. zend_version() 예제

<?php
// 출력 예. 'Zend engine version: 1.0.4'
echo "Zend engine version: " . zend_version();
?>

참고: phpinfo(),
phpcredits(),
php_logo_guid(),
phpversion().

이전 | 처음으로 | 다음
zend_logo_guid | 위로 | POSIX Functions


POSIX Functions

PHP 매뉴얼
이전 다음

LXXXIII. POSIX Functions

소개

This module contains an interface to those functions defined in the IEEE 1003.1 (POSIX.1) standards document which are not accessible through other means. POSIX.1 for example defined the open(), read(), write() and close() functions, too, which traditionally have been part of PHP 3 for a long time. Some more system specific functions have not been available before, though, and this module tries to remedy this by providing easy access to these functions.

주의

Sensitive data can be retrieved with the POSIX functions, e.g. posix_getpwnam() and friends. None of the POSIX function perform any kind of access checking when safe mode is enabled. It's therefore strongly advised to disable the POSIX extension at all (use --disable-posix in your configure line) if you're operating in such an environment.

참고: 이 확장 모듈은 윈도우 플랫폼에서는 사용할 수 없습니다.

설치

POSIX functions are enabled by default. You can disable POSIX-like functions with --disable-posix.

참고

The section about Process Control Functions maybe of interest for you.

차례
posix_ctermid -- Get path name of controlling terminal
posix_get_last_error -- Retrieve the error number set by the last posix function that failed.
posix_getcwd -- Pathname of current directory
posix_getegid -- Return the effective group ID of the current process
posix_geteuid -- Return the effective user ID of the current process
posix_getgid -- Return the real group ID of the current process
posix_getgrgid -- Return info about a group by group id
posix_getgrnam -- Return info about a group by name
posix_getgroups -- Return the group set of the current process
posix_getlogin -- Return login name
posix_getpgid -- Get process group id for job control
posix_getpgrp -- Return the current process group identifier
posix_getpid -- Return the current process identifier
posix_getppid -- Return the parent process identifier
posix_getpwnam -- Return info about a user by username
posix_getpwuid -- Return info about a user by user id
posix_getrlimit -- Return info about system resource limits
posix_getsid -- Get the current sid of the process
posix_getuid -- Return the real user ID of the current process
posix_isatty -- Determine if a file descriptor is an interactive terminal
posix_kill -- Send a signal to a process
posix_mkfifo -- Create a fifo special file (a named pipe)
posix_setegid -- Set the effective GID of the current process
posix_seteuid -- Set the effective UID of the current process
posix_setgid -- Set the GID of the current process
posix_setpgid -- set process group id for job control
posix_setsid -- Make the current process a session leader
posix_setuid -- Set the UID of the current process
posix_strerror -- Retrieve the system error message associated with the given errno.
posix_times -- Get process times
posix_ttyname -- Determine terminal device name
posix_uname -- Get system name

이전 | 처음으로 | 다음
zend_version | 위로 | posix_ctermid


posix_ctermid

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

posix_ctermid -- Get path name of controlling terminal

Description

string posix_ctermid ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
POSIX Functions | 위로 | posix_get_last_error


posix_get_last_error

(PHP 4 >= 4.2.0, PHP 5)

posix_get_last_error -- Retrieve the error number set by the last posix function that failed.

Description

int posix_get_last_error ( void )

Returns the errno (error number) set by the last posix function that failed. If no errors exist, 0 is returned. If you're wanting the system error message associated with the errno, use posix_strerror().

See also posix_strerror().

이전 | 처음으로 | 다음
posix_ctermid | 위로 | posix_getcwd


posix_getcwd

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

posix_getcwd -- Pathname of current directory

Description

string posix_getcwd ( void )

posix_getcwd() returns the absolute pathname of the script's current working directory. posix_getcwd() returns FALSE on error.

이전 | 처음으로 | 다음
posix_get_last_error | 위로 | posix_getegid


posix_getegid

(PHP 3>= 3.0.10, PHP 4 , PHP 5)

posix_getegid -- Return the effective group ID of the current process

Description

int posix_getegid ( void )

Return the numeric effective group ID of the current process. See also posix_getgrgid() for information on how to convert this into a useable group name.

이전 | 처음으로 | 다음
posix_getcwd | 위로 | posix_geteuid


posix_geteuid

(PHP 3>= 3.0.10, PHP 4 , PHP 5)

posix_geteuid -- Return the effective user ID of the current process

Description

int posix_geteuid ( void )

Return the numeric effective user ID of the current process. See also posix_getpwuid() for information on how to convert this into a useable username.

이전 | 처음으로 | 다음
posix_getegid | 위로 | posix_getgid


posix_getgid

(PHP 3>= 3.0.10, PHP 4 , PHP 5)

posix_getgid -- Return the real group ID of the current process

Description

int posix_getgid ( void )

Return the numeric real group ID of the current process. See also posix_getgrgid() for information on how to convert this into a useable group name.

이전 | 처음으로 | 다음
posix_geteuid | 위로 | posix_getgrgid


posix_getgrgid

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

posix_getgrgid -- Return info about a group by group id

Description

array posix_getgrgid ( int gid)

Returns an array of information about a group and FALSE on failure. If gid isn't a number then NULL is returned and an E_WARNING level error is generated.

예 1. Example use of posix_getgrgid()

<?php

$groupid   = posix_getegid();
$groupinfo = posix_getgrgid($groupid);

print_r($groupinfo);

?>

An example output:

Array
(
    [name]    => toons
    [passwd]  => x
    [members] => Array
        (
            [0] => tom
            [1] => jerry
        )
    [gid]     => 42
)

참고: As of PHP 4.2.0, members is returned as an array of member usernames in the group. Before this time it was simply an integer (the number of members in the group) and the member names were returned with numerical indices.

See also posix_getegid(),
filegroup(),
stat(), and
safe_mode_gid.

이전 | 처음으로 | 다음
posix_getgid | 위로 | posix_getgrnam


posix_getgrnam

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

posix_getgrnam -- Return info about a group by name

Description

array posix_getgrnam ( string name)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
posix_getgrgid | 위로 | posix_getgroups


posix_getgroups

(PHP 3>= 3.0.10, PHP 4 , PHP 5)

posix_getgroups -- Return the group set of the current process

Description

array posix_getgroups ( void )

Returns an array of integers containing the numeric group ids of the group set of the current process. See also posix_getgrgid() for information on how to convert this into useable group names.

이전 | 처음으로 | 다음
posix_getgrnam | 위로 | posix_getlogin


posix_getlogin

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

posix_getlogin -- Return login name

Description

string posix_getlogin ( void )

Returns the login name of the user owning the current process. See posix_getpwnam() for information how to get more information about this user.

이전 | 처음으로 | 다음
posix_getgroups | 위로 | posix_getpgid


posix_getpgid

(PHP 3>= 3.0.10, PHP 4 , PHP 5)

posix_getpgid -- Get process group id for job control

Description

int posix_getpgid ( int pid)

Returns the process group identifier of the process pid.

This is not a POSIX function, but is common on BSD and System V systems. If your system does not support this function at system level, this PHP function will always return FALSE.

이전 | 처음으로 | 다음
posix_getlogin | 위로 | posix_getpgrp


posix_getpgrp

(PHP 3>= 3.0.10, PHP 4 , PHP 5)

posix_getpgrp -- Return the current process group identifier

Description

int posix_getpgrp ( void )

Return the process group identifier of the current process. See POSIX.1 and the getpgrp(2) manual page on your POSIX system for more information on process groups.

이전 | 처음으로 | 다음
posix_getpgid | 위로 | posix_getpid


posix_getpid

(PHP 3>= 3.0.10, PHP 4 , PHP 5)

posix_getpid -- Return the current process identifier

Description

int posix_getpid ( void )

Return the process identifier of the current process.

이전 | 처음으로 | 다음
posix_getpgrp | 위로 | posix_getppid


posix_getppid

(PHP 3>= 3.0.10, PHP 4 , PHP 5)

posix_getppid -- Return the parent process identifier

Description

int posix_getppid ( void )

Return the process identifier of the parent process of the current process.

이전 | 처음으로 | 다음
posix_getpid | 위로 | posix_getpwnam


posix_getpwnam

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

posix_getpwnam -- Return info about a user by username

Description

array posix_getpwnam ( string username)

Returns an associative array containing information about a user referenced by an alphanumeric username, passed in the username parameter.

The array elements returned are:

표 1. The user information array

Element | Description
name | The name element contains the username of the user. This is a short, usually less than 16 character "handle" of the user, not her real, full name. This should be the same as the username parameter used when calling the function, and hence redundant.
passwd | The passwd element contains the user's password in an encrypted format. Often, for example on a system employing "shadow" passwords, an asterisk is returned instead.
uid | User ID of the user in numeric form.
gid | The group ID of the user. Use the function posix_getgrgid() to resolve the group name and a list of its members.
gecos | GECOS is an obsolete term that refers to the finger information field on a Honeywell batch processing system. The field, however, lives on, and its contents have been formalized by POSIX. The field contains a comma separated list containing the user's full name, office phone, office number, and home phone number. On most systems, only the user's full name is available.
dir | This element contains the absolute path to the home directory of the user.
shell | The shell element contains the absolute path to the executable of the user's default shell.

이전 | 처음으로 | 다음
posix_getppid | 위로 | posix_getpwuid


posix_getpwuid

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

posix_getpwuid -- Return info about a user by user id

Description

array posix_getpwuid ( int uid)

Returns an associative array containing information about a user referenced by a numeric user ID, passed in the uid parameter.

The array elements returned are:

표 1. The user information array

Element | Description
name | The name element contains the username of the user. This is a short, usually less than 16 character "handle" of the user, not her real, full name.
passwd | The passwd element contains the user's password in an encrypted format. Often, for example on a system employing "shadow" passwords, an asterisk is returned instead.
uid | User ID, should be the same as the uid parameter used when calling the function, and hence redundant.
gid | The group ID of the user. Use the function posix_getgrgid() to resolve the group name and a list of its members.
gecos | GECOS is an obsolete term that refers to the finger information field on a Honeywell batch processing system. The field, however, lives on, and its contents have been formalized by POSIX. The field contains a comma separated list containing the user's full name, office phone, office number, and home phone number. On most systems, only the user's full name is available.
dir | This element contains the absolute path to the home directory of the user.
shell | The shell element contains the absolute path to the executable of the user's default shell.

이전 | 처음으로 | 다음
posix_getpwnam | 위로 | posix_getrlimit


posix_getrlimit

(PHP 3>= 3.0.10, PHP 4 , PHP 5)

posix_getrlimit -- Return info about system resource limits

Description

array posix_getrlimit ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
posix_getpwuid | 위로 | posix_getsid


posix_getsid

(PHP 3>= 3.0.10, PHP 4 , PHP 5)

posix_getsid -- Get the current sid of the process

Description

int posix_getsid ( int pid)

Return the sid of the process pid. If pid is 0, the sid of the current process is returned.

This is not a POSIX function, but is common on System V systems. If your system does not support this function at system level, this PHP function will always return FALSE.

이전 | 처음으로 | 다음
posix_getrlimit | 위로 | posix_getuid


posix_getuid

(PHP 3>= 3.0.10, PHP 4 , PHP 5)

posix_getuid -- Return the real user ID of the current process

Description

int posix_getuid ( void )

Return the numeric real user ID of the current process. See also posix_getpwuid() for information on how to convert this into a useable username.

이전 | 처음으로 | 다음
posix_getsid | 위로 | posix_isatty


posix_isatty

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

posix_isatty -- Determine if a file descriptor is an interactive terminal

Description

bool posix_isatty ( int fd)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
posix_getuid | 위로 | posix_kill


posix_kill

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

posix_kill -- Send a signal to a process

Description

bool posix_kill ( int pid, int sig)

Send the signal sig to the process with the process identifier pid. Returns FALSE, if unable to send the signal, TRUE otherwise.

See also the kill(2) manual page of your POSIX system, which contains additional information about negative process identifiers, the special pid 0, the special pid -1, and the signal number 0.

이전 | 처음으로 | 다음
posix_isatty | 위로 | posix_mkfifo


posix_mkfifo

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

posix_mkfifo -- Create a fifo special file (a named pipe)

Description

bool posix_mkfifo ( string pathname, int mode)

posix_mkfifo() creates a special FIFO file which exists in the file system and acts as a bidirectional communication endpoint for processes.

The second parameter mode has to be given in octal notation (e.g. 0644). The permission of the newly created FIFO also depends on the setting of the current umask(). The permissions of the created file are (mode & ~umask).

참고: 안전 모드를 활성화했을 경우, PHP는 작업하려는 디렉토리가 실행중인 스크립트와 같은 UID(owner)를 가지고 있는지 확인합니다.

이전 | 처음으로 | 다음
posix_kill | 위로 | posix_setegid


posix_setegid

(PHP 4 >= 4.0.2, PHP 5)

posix_setegid -- Set the effective GID of the current process

Description

bool posix_setegid ( int gid)

Set the effective group ID of the current process. This is a privileged function and you need appropriate privileges (usually root) on your system to be able to perform this function.

Returns TRUE on success, FALSE otherwise.

이전 | 처음으로 | 다음
posix_mkfifo | 위로 | posix_seteuid


posix_seteuid

(PHP 4 >= 4.0.2, PHP 5)

posix_seteuid -- Set the effective UID of the current process

Description

bool posix_seteuid ( int uid)

Set the real user ID of the current process. This is a privileged function and you need appropriate privileges (usually root) on your system to be able to perform this function.

Returns TRUE on success, FALSE otherwise. See also posix_setgid().

이전 | 처음으로 | 다음
posix_setegid | 위로 | posix_setgid


posix_setgid

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

posix_setgid -- Set the GID of the current process

Description

bool posix_setgid ( int gid)

Set the real group ID of the current process. This is a privileged function and you need appropriate privileges (usually root) on your system to be able to perform this function. The appropriate order of function calls is posix_setgid() first, posix_setuid() last.

Returns TRUE on success, FALSE otherwise.

이전 | 처음으로 | 다음
posix_seteuid | 위로 | posix_setpgid


posix_setpgid

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

posix_setpgid -- set process group id for job control

Description

int posix_setpgid ( int pid, int pgid)

Let the process pid join the process group pgid. See POSIX.1 and the setsid(2) manual page on your POSIX system for more informations on process groups and job control. Returns TRUE on success, FALSE otherwise.

이전 | 처음으로 | 다음
posix_setgid | 위로 | posix_setsid


posix_setsid

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

posix_setsid -- Make the current process a session leader

Description

int posix_setsid ( void )

Make the current process a session leader. See POSIX.1 and the setsid(2) manual page on your POSIX system for more informations on process groups and job control. Returns the session id.

이전 | 처음으로 | 다음
posix_setpgid | 위로 | posix_setuid


posix_setuid

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

posix_setuid -- Set the UID of the current process

Description

bool posix_setuid ( int uid)

Set the real user ID of the current process. This is a privileged function and you need appropriate privileges (usually root) on your system to be able to perform this function.

Returns TRUE on success, FALSE otherwise. See also posix_setgid().

이전 | 처음으로 | 다음
posix_setsid | 위로 | posix_strerror


posix_strerror

(PHP 4 >= 4.2.0, PHP 5)

posix_strerror -- Retrieve the system error message associated with the given errno.

Description

string posix_strerror ( int errno)

Returns the POSIX system error message associated with the given errno. If errno is 0, then the string "Success" is returned. The function posix_get_last_error() is used for retrieving the last POSIX errno.

See also posix_get_last_error().

이전 | 처음으로 | 다음
posix_setuid | 위로 | posix_times


posix_times

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

posix_times -- Get process times

Description

array posix_times ( void )

Returns a hash of strings with information about the current process CPU usage. The indices of the hash are

  • ticks - the number of clock ticks that have elapsed since reboot.

  • utime - user time used by the current process.

  • stime - system time used by the current process.

  • cutime - user time used by current process and children.

  • cstime - system time used by current process and children.

이전 | 처음으로 | 다음
posix_strerror | 위로 | posix_ttyname


posix_ttyname

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

posix_ttyname -- Determine terminal device name

Description

string posix_ttyname ( int fd)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
posix_times | 위로 | posix_uname


posix_uname

(PHP 3>= 3.0.10, PHP 4 , PHP 5)

posix_uname -- Get system name

Description

array posix_uname ( void )

Returns a hash of strings with information about the system. The indices of the hash are

  • sysname - operating system name (e.g. Linux)

  • nodename - system name (e.g. valiant)

  • release - operating system release (e.g. 2.2.10)

  • version - operating system version (e.g. #4 Tue Jul 20 17:01:36 MEST 1999)

  • machine - system architecture (e.g. i586)

  • domainname - DNS domainname (e.g. php.net)

domainname is a GNU extension and not part of POSIX.1, so this field is only available on GNU systems or when using the GNU libc.

Posix requires that you must not make any assumptions about the format of the values, e.g. you cannot rely on three digit version numbers or anything else returned by this function.

이전 | 처음으로 | 다음
posix_ttyname | 위로 | PostgreSQL 함수


PostgreSQL 함수

PHP 매뉴얼
이전 다음

LXXXIV. PostgreSQL 함수

소개

PostgreSQL 데이터베이스는 비용이 필요 없는 오픈 소스 프로덕트입니다. 본래 UC Berkeley Computer Science Department에서 개발한 Postgres는 현재 몇몇 상용 데이터베이스에서 채용한 객체관계 개념을 이끌었습니다. SQL92/SQL99 언어 지원, 트랜젝션, 참조 관계, 저장 프로시저, 확장 가능한 타입을 제공합니다. PostgreSQL은 원래의 버클리 코드에서 오픈 소스로 이어졌습니다.

요구 사항

PostgreSQL 지원을 사용하려면, PostgreSQL 6.5 이상이 필요하며, 모든 PostgreSQL 모듈 기능을 사용하려면 PostgreSQL 7.0 이상이 필요합니다. PostgreSQL은 멀티바이트 문자 인코딩을 포함하여 많은 문자 인코딩을 지원합니다. PostgreSQL의 현재 버전과 관련 정보는 http://www.postgresql.org/과 http://techdocs.postgresql.org/에 있습니다.

설치

PostgreSQL 지원을 활성화하려면, PHP를 컴파일 할 때 --with-pgsql[=DIR]이 필요합니다. DIR은 PostgreSQL 베이스 설치 디렉토리로, 기본값은 /usr/local/pgsql입니다. 공유 오브젝트 모듈을 이용할 수 있으면, php.ini에서 extension 지시자나 dl()을 사용하여 PostgreSQL 모듈을 읽어들일 수 있습니다.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. PostgreSQL 설정 옵션

이름 | 기본값 | 변경가능성
pgsql.allow_persistent | "1" | PHP_INI_SYSTEM
pgsql.max_persistent | "-1" | PHP_INI_SYSTEM
pgsql.max_links | "-1" | PHP_INI_SYSTEM
pgsql.auto_reset_persistent | "0" | PHP_INI_SYSTEM
pgsql.ignore_notice | "0" | PHP_INI_ALL
pgsql.log_notice | "0" | PHP_INI_ALL
PHP_INI_* 상수에 대한 자세한 내용 및 정의는 ini_set()을 참고하십시오

위 설정 지시어에 대한 간단한 설명입니다.

pgsql.allow_persistent boolean

Postgre 지속 접속 허용 여부.

pgsql.max_persistent integer

프로세스 당 Postgre 지속 연결의 최대수.

pgsql.max_links integer

지속 연결을 포함하여, 프로세스 당 Postgres 연결의 최대수.

pgsql.auto_reset_persistent integer

깨어진 pg_pconnect() 지속 연결의 검출. 약간의 오버헤드가 필요합니다.

pgsql.ignore_notice integer

PostgreSQL 백엔드 경고의 무시 여부.

pgsql.log_notice integer

PostgreSQL 백엔드 경고 메세지의 기록 여부. 경고 메세지를 기록하기 위해서는 PHP 지시어 pgsql.ignore_notice를 off로 설정해야만 합니다.

사용법과 힌트

주의

PostgreSQL 모듈을 PHP 4.0.6과 함께 사용하는 것은 경고 메세지 핸들링의 버그로 인해 권장하지 않습니다. 4.1.0 이상을 사용하십시오.

주의

PostgreSQL 함수 이름은 현재 코딩 표준을 지키기 위해서 4.2.0 릴리즈부터 변경되었습니다. 대부분의 새 이름은 pg_lo_poen()과 같이 언더스코어가 추가되었습니다. 몇몇 함수는 일관성을 위해 pg_exec()에서 pg_query()와 같이 다른 이름으로 변경되었습니다. 옛 이름은 4.2.0과 이후의 몇몇 릴리즈에서는 사용할 수 있을 것이지만, 차후에 삭제될 것입니다.

표 2. 함수 이름 변경

옛 이름 | 새 이름
pg_cmdtuples() | pg_affected_rows()
pg_errormessage() | pg_last_error()
pg_exec() | pg_query()
pg_fieldname() | pg_field_name()
pg_fieldsize() | pg_field_size()
pg_fieldnum() | pg_field_num()
pg_fieldprtlen() | pg_field_prtlen()
pg_fieldisnull() | pg_field_is_null()
pg_freeresult() | pg_free_result()
pg_getlastoid() | pg_last_oid()
pg_loreadall() | pg_lo_read_all()
pg_locreate() | pg_lo_create()
pg_lounlink() | pg_lo_unlink()
pg_loopen() | pg_lo_open()
pg_loclose() | pg_lo_close()
pg_loread() | pg_lo_read()
pg_lowrite() | pg_lo_write()
pg_loimport() | pg_lo_import()
pg_loexport() | pg_lo_export()
pg_numrows() | pg_num_rows()
pg_numfields() | pg_num_fields()
pg_result() | pg_fetch_result()

이전의 pg_connect()/pg_pconnect() 구문은 차후에 비동기 접속을 지원하기 위해서 배제되어집니다. pg_connect()과 pg_pconnect()을 위한 접속 문자열을 사용하시기 바랍니다.

모든 빌드에서 모든 함수가 지원되는 것은 아닙니다. libpq (PostgreSQL C 클라이언트 인터페이스) 버전과 어떻게 컴파일하였는가에 의존합니다. 빠진 함수가 존재하면, libpq가 그 함수에 필요한 기능을 제공하지 않는 것입니다.

접속하려는 PostgreSQL 서버보다 오래된 libpq를 사용하지 않아야만 합니다. PostgreSQL 서버가 요구하는 것보다 오래된 libpq를 사용하면, 문제가 발생할 수 있습니다.

버전 6.3 (1998/03/02)부터 PostgreSQL은 기본값으로 유닉스 도메인 소켓을 사용합니다. 기본값으로 TCP 포트는 열지 않습니다. 아래의 표는 이 새로운 접속의 허용을 나타냅니다. 이 소켓은 /tmp/.s.PGSQL.5432에서 발견할 수 있습니다. postmaster에 "유닉스 도메인 소켓과 함께 TCP/IP 소켓을 리슨하라"는 의미의 '-i' 플래그를 지정하여 이 옵션을 활성화 할 수 있습니다.

표 3. Postmaster와 PHP

Postmaster | PHP | 상태
postmaster & | pg_connect("dbname=MyDbName"); | OK
postmaster -i & | pg_connect("dbname=MyDbName"); | OK
postmaster & | pg_connect("host=localhost dbname=MyDbName"); | Unable to connect to PostgreSQL server: connectDB() failed: Is the postmaster running and accepting TCP/IP (with -i) connection at 'localhost' on port '5432'? in /path/to/file.php on line 20.
postmaster -i & | pg_connect("host=localhost dbname=MyDbName"); | OK

PostgreSQL 서버에 접속은 명령 문자열에 다음의 값들을 지정해서 이루어집니다: $conn = pg_connect("host=myHost port=myPort tty=myTTY options=myOptions dbname=myDB user=myUser password=myPassword ");

이전의 구문: $conn = pg_connect ("host", "port", "options", "tty", "dbname") 은 배제되었습니다.

환경 변수가 PostgreSQL 서버/클라이언트 동작에 영향을 줍니다. 예를 들면, PostgreSQL 모듈은 접속 문자열에 hostname이 빠져 있으면 PGHOST 환경 변수를 찾아봅니다. 지원하는 환경 변수는 버전에 따라 다릅니다. 자세한 내용은 PostgreSQL 프로그래머 매뉴얼 (libpq - 환경 변수)를 참고하십시오.

적절한 유저로 환경 변수를 지정하였는지 확인하십시오. 현재 프로세스가 어떤 환경 변수를 사용할 수 있는지 확인하려면 $_ENV나 getenv()를 사용하십시오.

예 1. 기본 파라메터 설정하기

PGHOST=pgsql.example.com
PGPORT=7890
PGDATABASE=web-system
PGUSER=web-user
PGPASSWORD=secret
PGDATESTYLE=ISO
PGTZ=JST
PGCLIENTENCODING=EUC-JP

export PGHOST PGPORT PGDATABASE PGUSER PGPASSWORD PGDATESTYLE PGTZ PGCLIENTENCODING

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

PGSQL_ASSOC (integer)

PGSQL_NUM (integer)

PGSQL_BOTH (integer)

PGSQL_CONNECTION_BAD (integer)

PGSQL_CONNECTION_OK (integer)

PGSQL_SEEK_SET (integer)

PGSQL_SEEK_CUR (integer)

PGSQL_SEEK_END (integer)

PGSQL_ESCAPE_STRING (integer)

PGSQL_ESCAPE_BYTEA (integer)

PGSQL_EMPTY_QUERY (integer)

PGSQL_COMMAND_OK (integer)

PGSQL_TUPLES_OK (integer)

PGSQL_COPY_OUT (integer)

PGSQL_COPY_IN (integer)

PGSQL_BAD_RESPONSE (integer)

PGSQL_NONFATAL_ERROR (integer)

PGSQL_FATAL_ERROR (integer)

예제

PostgreSQL 7.1.0부터, text 타입의 필드에 1GB까지 저장할 수 있습니다. 이전 버전에서는, 블록 사이즈(기본값은 8KN, 최대값은 32KB, 컴파일 시에 지정)으로 제한되었었습니다.

대형 객체 (lo) 인터페이스를 사용하려면, 트랜젝션 블록에 대형 객체 함수를 포함할 필요가 있습니다. 트랜젝션 블록은 SQL 구문 BEGIN로 시작하고, 트랜젝션이 유효하다면 COMMIT나 END로 종료합니다. 트랜젝션이 실패하면 트랜젝션은 ROLLBACK이나 ABORT로 닫아야만 합니다.

예 2. 대형 객체 사용하지

<?php
    $database = pg_connect("dbname=jacarta");
    pg_query($database, "begin");
    $oid = pg_lo_create($database);
    echo "$oid\n";
    $handle = pg_lo_open($database, $oid, "w");
    echo "$handle\n";
    pg_lo_write($handle, "large object data");
    pg_lo_close($handle);
    pg_query($database, "commit");
?>
대형 객체를 닫기 전에 PostgreSQL 서버와의 접속을 끊어서는 안됩니다.

차례
pg_affected_rows -- 쿼리에 의해 변경된 레코드(튜플)의 개수를 반환한다.
pg_cancel_query -- 비동기 쿼리를 취소한다.
pg_client_encoding -- 클라이언트의 인코딩 정보를 받는다.
pg_close -- PostgreSQL과의 접속을 끊는다.
pg_connect -- PostgreSQL에 접속한다.
pg_connection_busy -- Get connection is busy or not
pg_connection_reset -- Reset connection (reconnect)
pg_connection_status -- Get connection status
pg_convert -- Convert associative array value into suitable for SQL statement.
pg_copy_from -- Insert records into a table from an array
pg_copy_to -- Copy a table to an array
pg_dbname -- 데이터베이스의 이름을 돌려준다.
pg_delete -- Deletes records.
pg_end_copy -- PostgreSQL 백엔드에 동기화한다.
pg_escape_bytea -- Escape binary for bytea type
pg_escape_string -- Escape string for text/char type
pg_fetch_all -- Fetches all rows from a result as an array
pg_fetch_array -- 데이터베이스의 행을 배열로 가져온다.
pg_fetch_assoc -- Fetch a row as an associative array
pg_fetch_object -- 데이터베이스의 행을 오브젝트로 가져온다.
pg_fetch_result -- Returns values from a result resource
pg_fetch_row -- 데이터베이스의 행을 숫자를 인덱스로 하는 배열로 가져온다.
pg_field_is_null -- Test if a field is NULL
pg_field_name -- Returns the name of a field
pg_field_num -- Returns the field number of the named field
pg_field_prtlen -- Returns the printed length
pg_field_size -- Returns the internal storage size of the named field
pg_field_type -- Returns the type name for the corresponding field number
pg_free_result -- Free result memory
pg_get_notify -- Ping database connection
pg_get_pid -- Ping database connection
pg_get_result -- Get asynchronous query result
pg_host -- Returns the host name associated with the connection
pg_insert -- Insert array into table.
pg_last_error -- Get the last error message string of a connection
pg_last_notice -- Returns the last notice message from PostgreSQL server
pg_last_oid -- Returns the last object's oid
pg_lo_close -- Close a large object
pg_lo_create -- Create a large object
pg_lo_export -- Export a large object to file
pg_lo_import -- Import a large object from file
pg_lo_open -- Open a large object
pg_lo_read_all -- Reads an entire large object and send straight to browser
pg_lo_read -- Read a large object
pg_lo_seek -- Seeks position of large object
pg_lo_tell -- Returns current position of large object
pg_lo_unlink -- Delete a large object
pg_lo_write -- Write a large object
pg_meta_data -- Get meta data for table.
pg_num_fields -- Returns the number of fields
pg_num_rows -- Returns the number of rows
pg_options -- Get the options associated with the connection
pg_pconnect -- Open a persistent PostgreSQL connection
pg_ping -- Ping database connection
pg_port -- Return the port number associated with the connection
pg_put_line -- Send a NULL-terminated string to PostgreSQL backend
pg_query -- Execute a query
pg_result_error -- Get error message associated with result
pg_result_seek -- Set internal row offset in result resource
pg_result_status -- Get status of query result
pg_select -- Select records.
pg_send_query -- Sends asynchronous query
pg_set_client_encoding -- Set the client encoding
pg_trace -- Enable tracing a PostgreSQL connection
pg_tty -- Return the tty name associated with the connection
pg_unescape_bytea -- Unescape binary for bytea type
pg_untrace -- Disable tracing of a PostgreSQL connection
pg_update -- Update table.

이전 | 처음으로 | 다음
posix_uname | 위로 | pg_affected_rows


pg_affected_rows

(PHP 4 >= 4.2.0, PHP 5)

pg_affected_rows -- 쿼리에 의해 변경된 레코드(튜플)의 개수를 반환한다.

함수 설명

int pg_affected_rows ( resource result)

pg_affected_rows()은 pg_query()로 수행한 INSERT, UPDATE, DELETE 쿼리에 의해 변경된 튜플(인스턴스/레코드/로우)의 개수를 반환한다. 변경된 튜플이 없으면 0을 반환한다.

예 1. pg_affected_rows()

<?php
     $result = pg_query ($conn, "INSERT INTO publisher VALUES ('Author')");
     $cmdtuples = pg_affected_rows ($result);
     echo $cmdtuples . " tuples are affected.";
?>

참고: 이 함수는 pg_cmdtuples() 으로도 사용할 수 있다.

pg_query() 와 pg_num_rows() 도 참조하라.

이전 | 처음으로 | 다음
PostgreSQL 함수 | 위로 | pg_cancel_query


pg_cancel_query

(PHP 4 >= 4.2.0, PHP 5)

pg_cancel_query -- 비동기 쿼리를 취소한다.

함수 설명

bool pg_cancel_query ( resource connection)

pg_cancel_query()는
pg_send_query()가 보낸 비동기 쿼리를 취소한다.
pg_query()로 실행한 쿼리는 취소할 수 없다.

pg_send_query() 와 pg_connection_busy() 도 참조하라.

이전 | 처음으로 | 다음
pg_affected_rows | 위로 | pg_client_encoding


pg_client_encoding

(PHP 3 CVS only, PHP 4 >= 4.0.3, PHP 5)

pg_client_encoding -- 클라이언트의 인코딩 정보를 받는다.

설명

string pg_client_encoding ( [resource connection])

pg_client_encoding()은 클라이언트 인코딩 정보를 문자열로 받는다. 클라이언트 인코딩 정보는 다음 중 하나여야 한다: SQL_ASCII, EUC_JP, EUC_CN, EUC_KR, EUC_TW, UNICODE, MULE_INTERNAL, LATINX (X=1...9), KOI8, WIN, ALT, SJIS, BIG5, WIN1250.

참고: 이 함수는 PHP-4.0.3 이상 버젼과 PostgreSQL-7.0 이상 버젼이 필요하다. 멀티바이트 지원기능 없이 컴파일 되었다면, pg_set_client_encoding()은 항상 "SQL_ASCII"를 반환한다. 지원되는 인코딩 정보는 PostgreSQL 버젼에 의해 정해진다. 멀티바이트 지원과 사용가능한 인코딩에 대한 자세한 정보는 PostreSQL 매뉴얼을 참조하라.

이 함수는 pg_clientencoding() 으로도 사용할 수 있다.

pg_set_client_encoding() 도 참조하라.

이전 | 처음으로 | 다음
pg_cancel_query | 위로 | pg_close


pg_close

(PHP 3, PHP 4 , PHP 5)

pg_close -- PostgreSQL과의 접속을 끊는다.

함수 설명

bool pg_close ( int connection)

올바른 접속지시자(a valid connection index)가 아니라면 거짓(FALSE)를 돌려주고, 반대의 경우 참(TRUE)을 돌려준다. 인수로 주어진 접속지시자에 해당하는 PostgreSQL로의 접속을 끊는다.

참고: 영구적이지 않은 접속은 PHP 스크립트의 종료시 자동으로 닫히므로 대부분의 경우 이 함수를 이용하여 접속을 끊지 않아도 된다.

pg_close() 함수는 pg_pconnect()를 이용한 접속을 끊지 못한다.

이전 | 처음으로 | 다음
pg_client_encoding | 위로 | pg_connect


pg_connect

(PHP 3, PHP 4 , PHP 5)

pg_connect -- PostgreSQL에 접속한다.

함수 설명

int pg_connect ( string conn_string)

접속에 성공하면 접속지시자(a connection index)를 돌려주고, 실패하면 거짓(FALSE)을 돌려준다. 이 함수의 목적은 PostgreSQL에 접속하는 것이다. 인수들은 인용부호안에 표기해야 한다.

예 1. Using pg_connect arguments

<?php
$dbconn = pg_Connect ("dbname=mary");
// "mary"라는 이름의 데이터베이스에 접속
$dbconn2 = pg_Connect ("host=localhost port=5432 dbname=mary");
// "localhost"의 "5432"포트를 통해 "mary"라는 이름의 데이터베이스에 접속
$dbconn3 = pg_Connect ("user=lamb password=baaaa dbname=mary ");
// 유저명과 패스워드가 지정된 "mary"라는 이름의 데이터베이스에 접속
?>
이 함수와 함께 사용 가능한 인수는 dbname port, host, tty, options, user, 그리고 password이다.

이 함수는 PHP의 다른 PostgreSQL 함수에서 필요로 하는 접속지시자를 돌려준다. 필요하다면 한번에 여러개의 접속을 만들 수 있다.

예전에 사용하던 접속구문 $conn = pg_connect ("host", "port", "options", "tty", "dbname") 은 추천하지 않는다.

pg_pconnect()도 참고하라.

이전 | 처음으로 | 다음
pg_close | 위로 | pg_connection_busy


pg_connection_busy

(PHP 4 >= 4.2.0, PHP 5)

pg_connection_busy -- Get connection is busy or not

Description

bool pg_connection_busy ( resource connection)

pg_connection_busy() returns TRUE if the connection is busy. If it is busy, a previous query is still executing. If pg_get_result() is called, it will be blocked.

예 1. pg_connection_busy() example

<?php
    $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
    $bs = pg_connection_busy($dbconn);
    if ($bs) {
        echo 'connection is busy';
    } else {
       echo 'connection is not busy';
    }
?>

See also pg_connection_status() and pg_get_result().

이전 | 처음으로 | 다음
pg_connect | 위로 | pg_connection_reset


pg_connection_reset

(PHP 4 >= 4.2.0, PHP 5)

pg_connection_reset -- Reset connection (reconnect)

Description

bool pg_connection_reset ( resource connection)

pg_connection_reset() resets the connection. It is useful for error recovery. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. pg_connection_reset() example

<?php
    $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
    $dbconn2 = pg_connection_reset($dbconn);
    if ($dbconn2) {
        echo "reset successful\n";
    } else {
        echo "reset failed\n";
    }
?>

See also pg_connect(),
pg_pconnect() and
pg_connection_status().

이전 | 처음으로 | 다음
pg_connection_busy | 위로 | pg_connection_status


pg_connection_status

(PHP 4 >= 4.2.0, PHP 5)

pg_connection_status -- Get connection status

Description

int pg_connection_status ( resource connection)

pg_connection_status() returns a connection status. Possible statuses are PGSQL_CONNECTION_OK and PGSQL_CONNECTION_BAD. The return value 0 as integer indicates a valid connection.

예 1. pg_connection_status() example

<?php
    $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
    $stat = pg_connection_status($dbconn);
    if ($stat === 0) {
        echo 'Connection status ok';
    } else {
        echo 'Connection status bad';
    }
?>

See also pg_connection_busy().

이전 | 처음으로 | 다음
pg_connection_reset | 위로 | pg_convert


pg_convert

(PHP 4 >= 4.3.0, PHP 5)

pg_convert -- Convert associative array value into suitable for SQL statement.

Description

array pg_convert ( resource connection, string table_name, array assoc_array [, int options])

pg_convert() checks and converts the values in assoc_array into suitable values for use in a SQL statement. Precondition for pg_convert() is the existence of a table table_name which has at least as many columns as assoc_array has elements. The fieldnames as well as the fieldvalues in table_name must match the indices and values of assoc_array. Returns an array with the converted values on success, FALSE otherwise.

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

See also pg_meta_data().

이전 | 처음으로 | 다음
pg_connection_status | 위로 | pg_copy_from


pg_copy_from

(PHP 4 >= 4.2.0, PHP 5)

pg_copy_from -- Insert records into a table from an array

Description

bool pg_copy_from ( resource connection, string table_name, array rows [, string delimiter [, string null_as]])

pg_copy_from() insert records into a table from rows. It issues COPY FROM SQL command internally to insert records. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also pg_copy_to().

이전 | 처음으로 | 다음
pg_convert | 위로 | pg_copy_to


pg_copy_to

(PHP 4 >= 4.2.0, PHP 5)

pg_copy_to -- Copy a table to an array

Description

array pg_copy_to ( resource connection, string table_name [, string delimiter [, string null_as]])

pg_copy_to() copies a table to an array. It issues COPY TO SQL command internally to retrieve records. The resulting array is returned. It returns FALSE on failure.

See also pg_copy_from().

이전 | 처음으로 | 다음
pg_copy_from | 위로 | pg_dbname


pg_dbname

(PHP 3, PHP 4 , PHP 5)

pg_dbname -- 데이터베이스의 이름을 돌려준다.

함수 설명

string pg_dbname ( int connection)

인수로 주어진 접속지시자 (connection index)에 해당하는 데이터베이스 이름을 돌려준다. 올바른 접속지시자가 아니면 거짓(FALSE)을 돌려준다.

이전 | 처음으로 | 다음
pg_copy_to | 위로 | pg_delete


pg_delete

(PHP 4 >= 4.3.0, PHP 5)

pg_delete -- Deletes records.

Description

mixed pg_delete ( resource connection, string table_name, array assoc_array [, int options])

pg_delete() deletes record condition specified by assoc_array which has field=>value. If option is specified, pg_convert() is applied to assoc_array with specified option.

예 1. pg_delete() example

<?php
    $db = pg_connect('dbname=foo');
    // This is safe, since $_POST is converted automatically
    $res = pg_delete($db, 'post_log', $_POST);
    if ($res) {
        echo "POST data is deleted: $res\n";
    } else {
        echo "User must have sent wrong inputs\n";
    }
?>

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

See also pg_convert().

이전 | 처음으로 | 다음
pg_dbname | 위로 | pg_end_copy


pg_end_copy

(PHP 4 >= 4.0.3, PHP 5)

pg_end_copy -- PostgreSQL 백엔드에 동기화한다.

함수 설명

bool pg_end_copy ( [resource connection])

pg_end_copy() syncs PostgreSQL frontend with the backend after doing a copy operation. It must be issued or the backend may get "out of sync" with the frontend. Returns TRUE if successfull, FALSE otherwise.

For further details and an example, see also pg_put_line().

이전 | 처음으로 | 다음
pg_delete | 위로 | pg_escape_bytea


pg_escape_bytea

(PHP 4 >= 4.2.0, PHP 5)

pg_escape_bytea -- Escape binary for bytea type

Description

string pg_escape_bytea ( string data)

pg_escape_bytea() escapes string for bytea datatype. It returns escaped string.

참고: When you SELECT bytea type, PostgreSQL returns octal byte value prefixed by \ (e.g. \032). Users are supposed to convert back to binary format by yourself.

This function requires PostgreSQL 7.2 or later. With PostgreSQL 7.2.0 and 7.2.1, bytea type must be casted when you enable multi-byte support. i.e. INSERT INTO test_table (image) VALUES ('$image_escaped'::bytea); PostgreSQL 7.2.2 or later does not need cast. Exception is when client and backend character encoding does not match, there may be multi-byte stream error. User must cast to bytea to avoid this error.

See also pg_unescape_bytea() and pg_escape_string().

이전 | 처음으로 | 다음
pg_end_copy | 위로 | pg_escape_string


pg_escape_string

(PHP 4 >= 4.2.0, PHP 5)

pg_escape_string -- Escape string for text/char type

Description

string pg_escape_string ( string data)

pg_escape_string() escapes string for text/char datatype. It returns escaped string for PostgreSQL. Use of this function is recommended instead of addslashes().

참고: This function requires PostgreSQL 7.2 or later.

See also pg_escape_bytea()

이전 | 처음으로 | 다음
pg_escape_bytea | 위로 | pg_fetch_all


pg_fetch_all

(PHP 4 >= 4.3.0, PHP 5)

pg_fetch_all -- Fetches all rows from a result as an array

Description

array pg_fetch_all ( resource result)

pg_fetch_all() returns an array that contains all rows (tuples/records) in result resource. It returns FALSE, if there are no rows.

예 1. PostgreSQL fetch all

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
    echo "An error occured.\n";
    exit;
}

$result = pg_query($conn, "SELECT * FROM authors");
if (!$result) {
    echo "An error occured.\n";
    exit;
}

$arr = pg_fetch_all($result);

var_dump($arr);

?>

See also pg_fetch_row(),
pg_fetch_array(),
pg_fetch_object() and
pg_fetch_result().

이전 | 처음으로 | 다음
pg_escape_string | 위로 | pg_fetch_array


pg_fetch_array

(PHP 3>= 3.0.1, PHP 4 , PHP 5)

pg_fetch_array -- 데이터베이스의 행을 배열로 가져온다.

함수 설명

array pg_fetch_array ( int result, int row [, int result_type])

이 함수는 데이터베이스에서 가져온 행을 배열로 돌려주며, 만약 더이상 가져올 행이 없는 경우 거짓(FALSE)을 돌려준다.

pg_fetch_array() 함수는 pg_fetch_row() 함수의 확장된 버전으로, 숫자를 인덱스로 하는 배열은 물론이고 각 필드이름을 인덱스로 하는 배열 두가지 형태를 고를 수 있다.

세번째로 정의된 result_type 인수는 선택적으로 주어질 수 있는 상수의 형태로 다음과 같은 값을 취할 수 있다: PGSQL_ASSOC, PGSQL_NUM, 그리고 PGSQL_BOTH.

참고: Result_type 인수는 PHP 4.0 버전부터 추가되었다.

한가지 중요한 사실은 pg_fetch_array() 함수에 pg_fetch_row() 함수보다 요긴하게 사용될 수 있는 기능(siginificant added value)이 추가되었지만 실행속도는 그다지 느리지 않다는 것이다.

pg_fetch_row()도 참고하라.

예 1. PostgreSQL fetch array

<?php
$conn = pg_pconnect ("dbname=publisher");
if (!$conn) {
    echo "An error occured.\n";
    exit;
}

$result = pg_Exec ($conn, "SELECT * FROM authors");
if (!$result) {
    echo "An error occured.\n";
    exit;
}

$arr = pg_fetch_array ($result, 0);
echo $arr[0] . " <- array\n";

$arr = pg_fetch_array ($result, 1);
echo $arr["author"] . " <- array\n";
?>

이전 | 처음으로 | 다음
pg_fetch_all | 위로 | pg_fetch_assoc


pg_fetch_assoc

(PHP 4 >= 4.3.0, PHP 5)

pg_fetch_assoc -- Fetch a row as an associative array

Description

array pg_fetch_assoc ( resource result [, int row])

pg_fetch_assoc() returns an associative array that corresponds to the fetched row (tuples/records). It returns FALSE, if there are no more rows.

pg_fetch_assoc() is equivalent to calling pg_fetch_array() with PGSQL_ASSOC for the optional third parameter. It only returns an associative array. If you need the numeric indices, use pg_fetch_row().

row is row (record) number to be retrieved. First row is 0.

pg_fetch_assoc() is NOT significantly slower than using pg_fetch_row(), while it provides a significant ease of use.

예 1. pg_fetch_assoc() example

<?php
$conn = pg_connect("dbname=publisher");
if (!$conn) {
    echo "An error occured.\n";
    exit;
}

$result = pg_query($conn, "SELECT id, author, email FROM authors");
if (!$result) {
    echo "An error occured.\n";
    exit;
}

while ($row = pg_fetch_assoc($result)) {
    echo $row['id'];
    echo $row['author'];
    echo $row['email'];
}
?>

See also
pg_fetch_row(),
pg_fetch_array(),
pg_fetch_object() and
pg_fetch_result().

이전 | 처음으로 | 다음
pg_fetch_array | 위로 | pg_fetch_object


pg_fetch_object

(PHP 3>= 3.0.1, PHP 4 , PHP 5)

pg_fetch_object -- 데이터베이스의 행을 오브젝트로 가져온다.

함수 설명

object pg_fetch_object ( int result, int row [, int result_type])

데이터베이스의 행을 그 행이 가진 프로퍼티와 함께 오브젝트의 형태로 돌려주며, 더이상 가져올 행이 없을 경우 거짓(FALSE)을 돌려준다.

pg_fetch_object() 함수는 pg_fetch_array() 함수와 거의 비슷하지만, 중요한 한가지가 다르다 -- 배열을 돌려주는 대신 오브젝트를 돌려준다. 간접적인 의미로, 여러분은 그 데이터를 오직 그 필드의 이름으로만 접근(access)할 수 있으며 오프셋(offsets)으로는 접근이 불가능하다. (숫자는 올바른 프로퍼티 이름이 아니다)

세번째로 정의된 result_type 인수는 선택적으로 주어질 수 있는 상수의 형태로 다음과 같은 값을 취할 수 있다: PGSQL_ASSOC, PGSQL_NUM, 그리고 PGSQL_BOTH.

참고: Result_type 은 PHP 4.0 버전부터 추가되었다.

함수 실행 속도는 pg_fetch_array() 함수와 마찬가지로, pg_fetch_row() 함수만큼 충분히 빠르다. (그 차이는 미미하다)

pg_fetch_array() 와 pg_fetch_row() 도 참고하라.

예 1. Postgres fetch object

<?php
$database = "verlag";
$db_conn = pg_connect ("host=localhost port=5432 dbname=$database");
if (!$db_conn): ?>
    <H1>Failed connecting to postgres database <?php echo $database ?></H1> <?php
    exit;
endif;

$qu = pg_exec ($db_conn, "SELECT * FROM verlag ORDER BY autor");
$row = 0; // postgres는 다른 데이터베이스들이 필요로 하지 않는 행카운터(row counter)를 필요로 한다

while ($data = pg_fetch_object ($qu, $row)):
    echo $data->autor." (";
    echo $data->jahr ."): ";
    echo $data->titel."<BR>";
    $row++;
endwhile; ?>

<PRE><?php
$fields[] = Array ("autor", "Author");
$fields[] = Array ("jahr",  "  Year");
$fields[] = Array ("titel", " Title");

$row= 0; // postgres는 다른 데이터베이스들이 필요로 하지 않는 행카운터를 필요로 한다
while ($data = pg_fetch_object ($qu, $row)):
    echo "----------\n";
    reset ($fields);
    while (list (,$item) = each ($fields)):
        echo $item[1].": ".$data->$item[0]."\n";
    endwhile;
    $row++;
endwhile;
echo "----------\n"; ?>
</PRE> <?php
pg_freeResult ($qu);
pg_close ($db_conn);
?>

이전 | 처음으로 | 다음
pg_fetch_assoc | 위로 | pg_fetch_result


pg_fetch_result

(PHP 4 >= 4.2.0, PHP 5)

pg_fetch_result -- Returns values from a result resource

Description

mixed pg_fetch_result ( resource result, int row, mixed field)

pg_fetch_result() returns values from a result resource returned by pg_query(). row is integer. field is field name (string) or field index (integer). The row and field specify what cell in the table of results to return. Row numbering starts from 0. Instead of naming the field, you may use the field index as an unquoted number. Field indices start from 0.

PostgreSQL has many built in types and only the basic ones are directly supported here. All forms of integer types are returned as integer values. All forms of float, and real types are returned as float values. Boolean is returned as "t" or "f". All other types, including arrays are returned as strings formatted in the same default PostgreSQL manner that you would see in the psql program.

이전 | 처음으로 | 다음
pg_fetch_object | 위로 | pg_fetch_row


pg_fetch_row

(PHP 3>= 3.0.1, PHP 4 , PHP 5)

pg_fetch_row -- 데이터베이스의 행을 숫자를 인덱스로 하는 배열로 가져온다.

함수 설명

array pg_fetch_row ( int result, int row)

데이터베이스로부터 가져온 행을 배열형태로 돌려주며, 더이상 가져올 행이 없을 경우 거짓(FALSE)을 돌려준다.

pg_fetch_row() 함수는 인수로 주어진 결과지시자(result identifier)가 가리키는 쿼리의 결과로부터 데이터베이스의 한 행을 배열 형태로 가져온다. 각 결과컬럼 은 0으로 시작되는 배열오프셋(array offset)에 저장된다.

pg_fetch_array(), pg_fetch_object(), pg_result() 도 참고하라.

예 1. Postgres fetch row

<?php
$conn = pg_pconnect ("dbname=publisher");
if (!$conn) {
    echo "An error occured.\n";
    exit;
}

$result = pg_Exec ($conn, "SELECT * FROM authors");
if (!$result) {
    echo "An error occured.\n";
    exit;
}

$num = pg_numrows($result);

for ($i=0; $i<$num; $i++) {
  $r = pg_fetch_row($result, $i);

  for ($j=0; $j<count($r); $j++) {
    echo "$r[$j]&nbsp;";
  }

  echo "<BR>";

}

?>

이전 | 처음으로 | 다음
pg_fetch_result | 위로 | pg_field_is_null


pg_field_is_null

(PHP 4 >= 4.2.0, PHP 5)

pg_field_is_null -- Test if a field is NULL

Description

int pg_field_is_null ( resource result, int row, mixed field)

pg_field_is_null() tests if a field is NULL or not. It returns 1 if the field in the given row is NULL. It returns 0 if the field in the given row is NOT NULL. Field can be specified as column index (number) or fieldname (string). Row numbering starts at 0.

예 1. pg_field_is_null() example

<?php
    $dbconn = pg_connect("dbname=publisher") or die ("Could not connect");
    $res = pg_query($dbconn, "select * from authors where author = 'Orwell'");
    if ($res) {
        if (pg_field_is_null($res, 0, "year") == 1) {
            echo "The value of the field year is null.\n";
        }
        if (pg_field_is_null($res, 0, "year") == 0) {
            echo "The value of the field year is not null.\n";
      }
   }
?>

참고: This function used to be called pg_fieldisnull().

이전 | 처음으로 | 다음
pg_fetch_row | 위로 | pg_field_name


pg_field_name

(PHP 4 >= 4.2.0, PHP 5)

pg_field_name -- Returns the name of a field

Description

string pg_field_name ( resource result, int field_number)

pg_field_name() returns the name of the field occupying the given field_number in the given PostgreSQL result resource. Field numbering starts from 0.

예 1. Getting informations about fields

<?php
    $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

    $res = pg_query($dbconn, "select * from authors where author = 'Orwell'");
    $i = pg_num_fields($res);
    for ($j = 0; $j < $i; $j++) {
        echo "column $j\n";
        $fieldname = pg_field_name($res, $j);
        echo "fieldname: $fieldname\n";
        echo "printed length: " . pg_field_prtlen($res, $fieldname) . " characters\n";
        echo "storage length: " . pg_field_size($res, $j) . " bytes\n";
        echo "field type: " . pg_field_type($res, $j) . " \n\n";
    }
?>

The above example would produce the following output:

column 0
fieldname: author
printed length: 6 characters
storage length: -1 bytes
field type: varchar

column 1
fieldname: year
printed length: 4 characters
storage length: 2 bytes
field type: int2

column 2
fieldname: title
printed length: 24 characters
storage length: -1 bytes
field type: varchar

참고: This function used to be called pg_fieldname().

See also pg_field_num().

이전 | 처음으로 | 다음
pg_field_is_null | 위로 | pg_field_num


pg_field_num

(PHP 4 >= 4.2.0, PHP 5)

pg_field_num -- Returns the field number of the named field

Description

int pg_field_num ( resource result, string field_name)

pg_field_num() will return the number of the column (field) slot that corresponds to the field_name in the given PostgreSQL result resource. Field numbering starts at 0. This function will return -1 on error.

See the example given at the pg_field_name() page.

참고: This function used to be called pg_fieldnum().

See also pg_field_name().

이전 | 처음으로 | 다음
pg_field_name | 위로 | pg_field_prtlen


pg_field_prtlen

(PHP 4 >= 4.2.0, PHP 5)

pg_field_prtlen -- Returns the printed length

Description

int pg_field_prtlen ( resource result, int row_number, string field_name)

pg_field_prtlen() returns the actual printed length (number of characters) of a specific value in a PostgreSQL result. Row numbering starts at 0. This function will return -1 on an error.

See the example given at the pg_field_name() page.

참고: This function used to be called pg_fieldprtlen().

See also pg_field_size().

이전 | 처음으로 | 다음
pg_field_num | 위로 | pg_field_size


pg_field_size

(PHP 4 >= 4.2.0, PHP 5)

pg_field_size -- Returns the internal storage size of the named field

Description

int pg_field_size ( resource result, int field_number)

pg_field_size() returns the internal storage size (in bytes) of the field number in the given PostgreSQL result. Field numbering starts at 0. A field size of -1 indicates a variable length field. This function will return FALSE on error.

See the example given at the pg_field_name() page.

참고: This function used to be called pg_fieldsize().

See also pg_field_prtlen() and pg_field_type().

이전 | 처음으로 | 다음
pg_field_prtlen | 위로 | pg_field_type


pg_field_type

(PHP 4 >= 4.2.0, PHP 5)

pg_field_type -- Returns the type name for the corresponding field number

Description

string pg_field_type ( resource result, int field_number)

pg_field_type() returns a string containing the type name of the given field_number in the given PostgreSQL result resource. Field numbering starts at 0.

See the example given at the pg_field_name() page.

참고: This function used to be called pg_fieldtype().

See also pg_field_prtlen() and pg_field_name().

이전 | 처음으로 | 다음
pg_field_size | 위로 | pg_free_result


pg_free_result

(PHP 4 >= 4.2.0, PHP 5)

pg_free_result -- Free result memory

Description

bool pg_free_result ( resource result)

pg_free_result() only needs to be called if you are worried about using too much memory while your script is running. All result memory will automatically be freed when the script is finished. But, if you are sure you are not going to need the result data anymore in a script, you may call pg_free_result() with the result resource as an argument and the associated result memory will be freed. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: This function used to be called pg_freeresult().

See also pg_query().

이전 | 처음으로 | 다음
pg_field_type | 위로 | pg_get_notify


pg_get_notify

(PHP 4 >= 4.3.0, PHP 5)

pg_get_notify -- Ping database connection

Description

array pg_get_notify ( resource connection [, int result_type])

pg_get_notify() gets notify message sent by NOTIFY SQL command. To receive notify messages, LISTEN SQL command must be issued. If there is notify message on the connection, array contains message name and backend PID is returned. If there is no message, FALSE is returned.

See also pg_get_pid()

예 1. PostgreSQL NOTIFY message

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
    echo "An error occured.\n";
    exit;
}

// Listen 'author_updated' message from other processes
pg_query($conn, 'LISTEN author_updated;');
$notify = pg_get_notify($conn);
if (!$notify) {
    echo "No messages\n";
} else {
    print_r($notify);
}
?>

이전 | 처음으로 | 다음
pg_free_result | 위로 | pg_get_pid


pg_get_pid

(PHP 4 >= 4.3.0, PHP 5)

pg_get_pid -- Ping database connection

Description

int pg_get_pid ( resource connection)

pg_get_pid() gets backend (database server process) PID. PID is useful to check if NOTIFY message is sent from other process or not.

예 1. PostgreSQL backend PID

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
    echo "An error occured.\n";
    exit;
}

// Backend process PID. Use PID with pg_get_notify()
$pid = pg_get_pid($conn);
?>

See also pg_get_notify().

이전 | 처음으로 | 다음
pg_get_notify | 위로 | pg_get_result


pg_get_result

(PHP 4 >= 4.2.0, PHP 5)

pg_get_result -- Get asynchronous query result

Description

resource pg_get_result ( [resource connection])

pg_get_result() get result resource from async query executed by pg_send_query(). pg_send_query() can send multiple queries to PostgreSQL server and pg_get_result() is used to get query result one by one. It returns result resource. If there is no more results, it returns FALSE.

이전 | 처음으로 | 다음
pg_get_pid | 위로 | pg_host


pg_host

(PHP 3, PHP 4 , PHP 5)

pg_host -- Returns the host name associated with the connection

Description

string pg_host ( resource connection)

pg_host() returns the host name of the given PostgreSQL connection resource is connected to.

See also pg_connect() and pg_pconnect().

이전 | 처음으로 | 다음
pg_get_result | 위로 | pg_insert


pg_insert

(PHP 4 >= 4.3.0, PHP 5)

pg_insert -- Insert array into table.

Description

bool pg_insert ( resource connection, string table_name, array assoc_array [, int options])

pg_insert() inserts the values of assoc_array into the table specified by table_name. table_name must at least have as many columns as assoc_array has elements. The fieldnames as well as the fieldvalues in table_name must match the indices and values of assoc_array. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. If options is specified, pg_insert() is applied to assoc_array with specified option.

예 1. pg_insert() example

<?php
    $dbconn = pg_connect('dbname=foo');
    // This is safe, since $_POST is converted automatically
    $res = pg_insert($dbconn, 'post_log', $_POST);
    if ($res) {
        echo "POST data is successfully logged\n";
    } else {
        echo "User must have sent wrong inputs\n";
    }
?>

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

See also pg_convert().

이전 | 처음으로 | 다음
pg_host | 위로 | pg_last_error


pg_last_error

(PHP 4 >= 4.2.0, PHP 5)

pg_last_error -- Get the last error message string of a connection

Description

string pg_last_error ( [resource connection])

pg_last_error() returns the last error message for given connection.

Error messages may be overwritten by internal PostgreSQL(libpq) function calls. It may not return appropriate error message, if multiple errors are occurred inside a PostgreSQL module function.

Use pg_result_error(),
pg_result_status() and
pg_connection_status() for better error handling.

참고: This function used to be called pg_errormessage().

See also pg_result_error().

이전 | 처음으로 | 다음
pg_insert | 위로 | pg_last_notice


pg_last_notice

(PHP 4 >= 4.0.6, PHP 5)

pg_last_notice -- Returns the last notice message from PostgreSQL server

Description

string pg_last_notice ( resource connection)

pg_last_notice() returns the last notice message from the PostgreSQL server specified by connection. The PostgreSQL server sends notice messages in several cases, e.g. if the transactions can't be continued. With pg_last_notice(), you can avoid issuing useless queries, by checking whether the notice is related to the transaction or not.

주의

This function is EXPERIMENTAL and it is not fully implemented yet. pg_last_notice() was added in PHP 4.0.6. However, PHP 4.0.6 has problem with notice message handling. Use of the PostgreSQL module with PHP 4.0.6 is not recommended even if you are not using pg_last_notice().

This function is fully implemented in PHP 4.3.0. PHP earlier than PHP 4.3.0 ignores database connection parameter.

Notice message tracking can be set to optional by setting 1 for pgsql.ignore_notice in php.ini from PHP 4.3.0.

Notice message logging can be set to optional by setting 0 for pgsql.log_notice in php.ini from PHP 4.3.0. Unless pgsql.ignore_notice is set to 0, notice message cannot be logged.

See also pg_query() and pg_last_error().

이전 | 처음으로 | 다음
pg_last_error | 위로 | pg_last_oid


pg_last_oid

(PHP 4 >= 4.2.0, PHP 5)

pg_last_oid -- Returns the last object's oid

Description

int pg_last_oid ( resource result)

pg_last_oid() is used to retrieve the oid assigned to an inserted tuple (record) if the result resource is used from the last command sent via pg_query() and was an SQL INSERT. Returns a positive integer if there was a valid oid. It returns FALSE if an error occurs or the last command sent via pg_query() was not an INSERT or INSERT is failed.

OID field became an optional field from PostgreSQL 7.2. When OID field is not defined in a table, programmer must use pg_result_status() to check if record is is inserted successfully or not.

참고: This function used to be called pg_getlastoid().

See also pg_query() and pg_result_status()

이전 | 처음으로 | 다음
pg_last_notice | 위로 | pg_lo_close


pg_lo_close

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_close -- Close a large object

Description

bool pg_lo_close ( resource large_object)

pg_lo_close() closes a Large Object. large_object is a resource for the large object from pg_lo_open().

To use the large object (lo) interface, it is necessary to enclose it within a transaction block.

참고: This function used to be called pg_loclose().

See also pg_lo_open(),
pg_lo_create() and
pg_lo_import().

이전 | 처음으로 | 다음
pg_last_oid | 위로 | pg_lo_create


pg_lo_create

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_create -- Create a large object

Description

int pg_lo_create ( resource connection)

pg_lo_create() creates a Large Object and returns the oid of the large object. connection specifies a valid database connection opened by pg_connect() or pg_pconnect(). PostgreSQL access modes INV_READ, INV_WRITE, and INV_ARCHIVE are not supported, the object is created always with both read and write access. INV_ARCHIVE has been removed from PostgreSQL itself (version 6.3 and above). It returns large object oid, otherwise it returns FALSE if an error occurred.

To use the large object (lo) interface, it is necessary to enclose it within a transaction block.

참고: This function used to be called pg_locreate().

이전 | 처음으로 | 다음
pg_lo_close | 위로 | pg_lo_export


pg_lo_export

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_export -- Export a large object to file

Description

bool pg_lo_export ( [resource connection, int oid, string pathname])

The oid argument specifies oid of the large object to export and the pathname argument specifies the pathname of the file. It returns FALSE if an error occurred, TRUE otherwise.

To use the large object (lo) interface, it is necessary to enclose it within a transaction block.

참고: This function used to be called pg_loexport().

See also pg_lo_import().

이전 | 처음으로 | 다음
pg_lo_create | 위로 | pg_lo_import


pg_lo_import

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_import -- Import a large object from file

Description

int pg_lo_import ( [resource connection, string pathname])

In versions before PHP 4.2.0 the syntax of this function was different, see the following definition:

int pg_lo_import ( string pathname [, resource connection])

The pathname argument specifies the pathname of the file to be imported as a large object. It returns FALSE if an error occurred, oid of the just created large object otherwise.

To use the large object (lo) interface, it is necessary to enclose it within a transaction block.

참고: 안전 모드일때, PHP는 조작하려는 파일이나 디렉토리가 같은 UID(owner)인지 확인한 후에 실행합니다.

참고: This function used to be called pg_loimport().

See also pg_lo_export() and pg_lo_open().

이전 | 처음으로 | 다음
pg_lo_export | 위로 | pg_lo_open


pg_lo_open

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_open -- Open a large object

Description

resource pg_lo_open ( resource connection, int oid, string mode)

pg_lo_open() opens a Large Object and returns large object resource. The resource encapsulates information about the connection. oid specifies a valid large object oid and mode can be either "r", "w", or "rw". It returns FALSE if there is an error.

주의

Do not close the database connection before closing the large object resource.

To use the large object (lo) interface, it is necessary to enclose it within a transaction block.

참고: This function used to be called pg_loopen().

See also pg_lo_close() and pg_lo_create().

이전 | 처음으로 | 다음
pg_lo_import | 위로 | pg_lo_read_all


pg_lo_read_all

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_read_all -- Reads an entire large object and send straight to browser

Description

int pg_lo_read_all ( resource large_object)

pg_lo_read_all() reads a large object and passes it straight through to the browser after sending all pending headers. Mainly intended for sending binary data like images or sound. It returns number of bytes read. It returns FALSE, if an error occurred.

To use the large object (lo) interface, it is necessary to enclose it within a transaction block.

참고: This function used to be called pg_loreadall().

See also pg_lo_read().

이전 | 처음으로 | 다음
pg_lo_open | 위로 | pg_lo_read


pg_lo_read

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_read -- Read a large object

Description

string pg_lo_read ( resource large_object, int len)

pg_lo_read() reads at most len bytes from a large object and returns it as a string. large_object specifies a valid large object resource andlen specifies the maximum allowable size of the large object segment. It returns FALSE if there is an error.

To use the large object (lo) interface, it is necessary to enclose it within a transaction block.

참고: This function used to be called pg_loread().

See also pg_lo_read_all().

이전 | 처음으로 | 다음
pg_lo_read_all | 위로 | pg_lo_seek


pg_lo_seek

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_seek -- Seeks position of large object

Description

bool pg_lo_seek ( resource large_object, int offset [, int whence])

pg_lo_seek() seeks position of large object resource. whence is PGSQL_SEEK_SET, PGSQL_SEEK_CUR or PGSQL_SEEK_END.

See also pg_lo_tell().

이전 | 처음으로 | 다음
pg_lo_read | 위로 | pg_lo_tell


pg_lo_tell

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_tell -- Returns current position of large object

Description

int pg_lo_tell ( resource large_object)

pg_lo_tell() returns current position (offset from the beginning of large object).

See also pg_lo_seek().

이전 | 처음으로 | 다음
pg_lo_seek | 위로 | pg_lo_unlink


pg_lo_unlink

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_unlink -- Delete a large object

Description

bool pg_lo_unlink ( resource connection, int oid)

pg_lo_unlink() deletes a large object with the oid. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

To use the large object (lo) interface, it is necessary to enclose it within a transaction block.

참고: This function used to be called pg_lo_unlink().

See also pg_lo_create() and pg_lo_import().

이전 | 처음으로 | 다음
pg_lo_tell | 위로 | pg_lo_write


pg_lo_write

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_write -- Write a large object

Description

int pg_lo_write ( resource large_object, string data)

pg_lo_write() writes at most to a large object from a variable data and returns the number of bytes actually written, or FALSE in the case of an error. large_object is a large object resource from pg_lo_open().

To use the large object (lo) interface, it is necessary to enclose it within a transaction block.

참고: This function used to be called pg_lowrite().

See also pg_lo_create() and pg_lo_open().

이전 | 처음으로 | 다음
pg_lo_unlink | 위로 | pg_meta_data


pg_meta_data

(PHP 4 >= 4.3.0, PHP 5)

pg_meta_data -- Get meta data for table.

Description

array pg_meta_data ( resource connection, string table_name)

pg_meta_data() returns table definition for table_name as an array. If there is error, it returns FALSE

예 1. Getting table metadata

<?php
    $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

    $meta = pg_meta_data($dbconn, 'authors');
    if (is_array($meta)) {
        echo '<pre>';
        var_dump($meta);
        echo '</pre>';
    }
?>

The above example would produce the following output:

array(3) {
  ["author"]=>
  array(5) {
    ["num"]=>
    int(1)
    ["type"]=>
    string(7) "varchar"
    ["len"]=>
    int(-1)
    ["not null"]=>
    bool(false)
    ["has default"]=>
    bool(false)
  }
  ["year"]=>
  array(5) {
    ["num"]=>
    int(2)
    ["type"]=>
    string(4) "int2"
    ["len"]=>
    int(2)
    ["not null"]=>
    bool(false)
    ["has default"]=>
    bool(false)
  }
  ["title"]=>
  array(5) {
    ["num"]=>
    int(3)
    ["type"]=>
    string(7) "varchar"
    ["len"]=>
    int(-1)
    ["not null"]=>
    bool(false)
    ["has default"]=>
    bool(false)
  }
}

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

See also pg_convert().

이전 | 처음으로 | 다음
pg_lo_write | 위로 | pg_num_fields


pg_num_fields

(PHP 4 >= 4.2.0, PHP 5)

pg_num_fields -- Returns the number of fields

Description

int pg_num_fields ( resource result)

pg_num_fields() returns the number of fields (columns) in a PostgreSQL result. The argument is a result resource returned by pg_query(). This function will return -1 on error.

참고: This function used to be called pg_numfields().

See also pg_num_rows() and pg_affected_rows().

이전 | 처음으로 | 다음
pg_meta_data | 위로 | pg_num_rows


pg_num_rows

(PHP 4 >= 4.2.0, PHP 5)

pg_num_rows -- Returns the number of rows

Description

int pg_num_rows ( resource result)

pg_num_rows() will return the number of rows in a PostgreSQL result resource. result is a query result resource returned by pg_query(). This function will return -1 on error.

참고: Use pg_affected_rows() to get number of rows affected by INSERT, UPDATE and DELETE query.

참고: This function used to be called pg_numrows().

See also pg_num_fields() and pg_affected_rows().

이전 | 처음으로 | 다음
pg_num_fields | 위로 | pg_options


pg_options

(PHP 3, PHP 4 , PHP 5)

pg_options -- Get the options associated with the connection

Description

string pg_options ( resource connection)

pg_options() will return a string containing the options specified on the given PostgreSQL connection resource.

이전 | 처음으로 | 다음
pg_num_rows | 위로 | pg_pconnect


pg_pconnect

(PHP 3, PHP 4 , PHP 5)

pg_pconnect -- Open a persistent PostgreSQL connection

Description

resource pg_pconnect ( string connection_string)

pg_pconnect() opens a connection to a PostgreSQL database. It returns a connection resource that is needed by other PostgreSQL functions.

For a description of the connection_string parameter, see pg_connect().

To enable persistent connection, the pgsql.allow_persistent php.ini directive must be set to "On" (which is the default). The maximum number of persistent connection can be defined with the pgsql.max_persistent php.ini directive (defaults to -1 for no limit). The total number of connections can be set with the pgsql.max_links php.ini directive.

pg_close() will not close persistent links generated by pg_pconnect().

See also pg_connect(), and the section Persistent Database Connections for more information.

이전 | 처음으로 | 다음
pg_options | 위로 | pg_ping


pg_ping

(PHP 4 >= 4.3.0, PHP 5)

pg_ping -- Ping database connection

Description

bool pg_ping ( resource connection)

pg_ping() ping database connection, try to reconnect if it is broken. It returns TRUE if connection is alive, otherwise FALSE.

예 1. pg_ping() example

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
    echo "An error occured.\n";
    exit;
}

if (!pg_ping($conn))
    die("Connection is broken\n");
?>

See also pg_connection_status() and pg_connection_reset().

이전 | 처음으로 | 다음
pg_pconnect | 위로 | pg_port


pg_port

(PHP 3, PHP 4 , PHP 5)

pg_port -- Return the port number associated with the connection

Description

int pg_port ( resource connection)

pg_port() returns the port number that the given PostgreSQL connection resource is connected to.

이전 | 처음으로 | 다음
pg_ping | 위로 | pg_put_line


pg_put_line

(PHP 4 >= 4.0.3, PHP 5)

pg_put_line -- Send a NULL-terminated string to PostgreSQL backend

Description

bool pg_put_line ( [resource connection, string data])

pg_put_line() sends a NULL-terminated string to the PostgreSQL backend server. This is useful for example for very high-speed inserting of data into a table, initiated by starting a PostgreSQL copy-operation. That final NULL-character is added automatically. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: The application must explicitly send the two characters "\." on the last line to indicate to the backend that it has finished sending its data.

예 1. High-speed insertion of data into a table

<?php
    $conn = pg_pconnect("dbname=foo");
    pg_query($conn, "create table bar (a int4, b char(16), d float8)");
    pg_query($conn, "copy bar from stdin");
    pg_put_line($conn, "3\thello world\t4.5\n");
    pg_put_line($conn, "4\tgoodbye world\t7.11\n");
    pg_put_line($conn, "\\.\n");
    pg_end_copy($conn);
?>

See also pg_end_copy().

이전 | 처음으로 | 다음
pg_port | 위로 | pg_query


pg_query

(PHP 4 >= 4.2.0, PHP 5)

pg_query -- Execute a query

Description

resource pg_query ( resource connection, string query)

pg_query() returns a query result resource if query could be executed. It returns FALSE on failure or if connection is not a valid connection. Details about the error can be retrieved using the pg_last_error() function if connection is valid. pg_query() sends an SQL statement to the PostgreSQL database specified by the connection resource. The connection must be a valid connection that was returned by pg_connect() or pg_pconnect(). The return value of this function is an query result resource to be used to access the results from other PostgreSQL functions such as pg_fetch_array().

참고: connection is an optional parameter for pg_query(). If connection is not set, default connection is used. Default connection is the last connection made by pg_connect() or pg_pconnect().

Although connection can be omitted, it is not recommended, since it could be a cause of hard to find bug in script.

참고: This function used to be called pg_exec(). pg_exec() is still available for compatibility reasons but users are encouraged to use the newer name.

See also pg_connect(),
pg_pconnect(),
pg_fetch_array(),
pg_fetch_object(),
pg_num_rows() and
pg_affected_rows().

이전 | 처음으로 | 다음
pg_put_line | 위로 | pg_result_error


pg_result_error

(PHP 4 >= 4.2.0, PHP 5)

pg_result_error -- Get error message associated with result

Description

string pg_result_error ( resource result)

pg_result_error() returns error message associated with result resource. Therefore, user has better chance to get better error message than pg_last_error().

See also pg_query(),
pg_send_query(),
pg_get_result(),
pg_last_error() and
pg_last_notice()

이전 | 처음으로 | 다음
pg_query | 위로 | pg_result_seek


pg_result_seek

(PHP 4 >= 4.3.0, PHP 5)

pg_result_seek -- Set internal row offset in result resource

Description

array pg_result_seek ( resource result, int offset)

pg_result_seek() set internal row offset in result resource. It returns FALSE, if there is error.

 See also pg_fetch_row(),
pg_fetch_assoc(),
pg_fetch_array(),
pg_fetch_object() and
pg_fetch_result().

이전 | 처음으로 | 다음
pg_result_error | 위로 | pg_result_status


pg_result_status

(PHP 4 >= 4.2.0, PHP 5)

pg_result_status -- Get status of query result

Description

int pg_result_status ( resource result)

pg_result_status() returns status of result resource. Possible return values are PGSQL_EMPTY_QUERY, PGSQL_COMMAND_OK, PGSQL_TUPLES_OK, PGSQL_COPY_TO, PGSQL_COPY_FROM, PGSQL_BAD_RESPONSE, PGSQL_NONFATAL_ERROR and PGSQL_FATAL_ERROR.

See also pg_connection_status().

이전 | 처음으로 | 다음
pg_result_seek | 위로 | pg_select


pg_select

(PHP 4 >= 4.3.0, PHP 5)

pg_select -- Select records.

Description

array pg_select ( resource connection, string table_name, array assoc_array [, int options])

pg_select() selects records specified by assoc_array which has field=>value. For successful query, it returns array contains all records and fields that match the condition specified by assoc_array. If options is specified, pg_convert() is applied to assoc_array with specified option.

예 1. pg_select() example

<?php
    $db = pg_connect('dbname=foo');
    // This is safe, since $_POST is converted automatically
    $rec = pg_select($db, 'post_log', $_POST);
    if ($rec) {
        echo "Records selected\n";
        var_dump($rec);
    } else {
        echo "User must have sent wrong inputs\n";
    }
?>

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

See also pg_convert()

이전 | 처음으로 | 다음
pg_result_status | 위로 | pg_send_query


pg_send_query

(PHP 4 >= 4.2.0, PHP 5)

pg_send_query -- Sends asynchronous query

Description

bool pg_send_query ( resource connection, string query)

bool pg_send_query ( string query)

pg_send_query() send asynchronous query to the connection. Unlike pg_query(), it can send multiple query to PostgreSQL and get the result one by one using pg_get_result(). Script execution is not blocked while query is executing. Use pg_connection_busy() to check connection is busy (i.e. query is executing). Query may be cancelled by calling pg_cancel_query().

Although user can send multiple query at once, user cannot send multiple query over busy connection. If query is sent while connection is busy, it waits until last query is finished and discards all result.

예 1. Asynchronous Queries

<?php
    $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

    if (!pg_connection_busy($dbconn)) {
        pg_send_query($dbconn, "select * from authors; select count(*) from authors;");
    }

    $res1 = pg_get_result($dbconn);
    echo "First call to pg_get_result(): $res1\n";
    $rows1 = pg_num_rows($res1);
    echo "$res1 has $rows1 records\n\n";

    $res2 = pg_get_result($dbconn);
    echo "second call to pg_get_result(): $res2\n";
    $rows2 = pg_num_rows($res2);
    echo "$res2 has $rows2 records\n";
?>

The above example would produce the following output:

first call to pg_get_result(): Resource id #3
Resource id #3 has 3 records

second call to pg_get_result(): Resource id #4
Resource id #4 has 1 records

See also pg_query(),
pg_cancel_query(),
pg_get_result() and
pg_connection_busy().

이전 | 처음으로 | 다음
pg_select | 위로 | pg_set_client_encoding


pg_set_client_encoding

(PHP 3 CVS only, PHP 4 >= 4.0.3, PHP 5)

pg_set_client_encoding -- Set the client encoding

Description

int pg_set_client_encoding ( [resource connection, string encoding])

pg_set_client_encoding() sets the client encoding and returns 0 if success or -1 if error.

encoding is the client encoding and can be either : SQL_ASCII, EUC_JP, EUC_CN, EUC_KR, EUC_TW, UNICODE, MULE_INTERNAL, LATINX (X=1...9), KOI8, WIN, ALT, SJIS, BIG5, WIN1250. Available encoding depends on your PostgreSQL and libpq version. Refer to PostgreSQL manual for supported encodings for your PostgreSQL.

참고: This function requires PHP-4.0.3 or higher and PostgreSQL-7.0 or higher. Supported encoding depends on PostgreSQL version. Refer to PostgreSQL manual for details.

The function used to be called pg_setclientencoding().

See also pg_client_encoding().

이전 | 처음으로 | 다음
pg_send_query | 위로 | pg_trace


pg_trace

(PHP 4 >= 4.0.1, PHP 5)

pg_trace -- Enable tracing a PostgreSQL connection

Description

bool pg_trace ( string pathname [, string mode [, resource connection]])

pg_trace() enables tracing of the PostgreSQL frontend/backend communication to a debugging file specified as pathname. To fully understand the results, one needs to be familiar with the internals of PostgreSQL communication protocol. For those who are not, it can still be useful for tracing errors in queries sent to the server, you could do for example grep '^To backend' trace.log and see what query actually were sent to the PostgreSQL server. For more information, refer to PostgreSQL manual.

pathname and mode are the same as in fopen() (mode defaults to 'w'), connection specifies the connection to trace and defaults to the last one opened.

pg_trace() returns TRUE if pathname could be opened for logging, FALSE otherwise.

See also fopen() and pg_untrace().

이전 | 처음으로 | 다음
pg_set_client_encoding | 위로 | pg_tty


pg_tty

(PHP 3, PHP 4 , PHP 5)

pg_tty -- Return the tty name associated with the connection

Description

string pg_tty ( resource connection)

pg_tty() returns the tty name that server side debugging output is sent to on the given PostgreSQL connection resource.

이전 | 처음으로 | 다음
pg_trace | 위로 | pg_unescape_bytea


pg_unescape_bytea

(PHP 4 >= 4.3.0, PHP 5)

pg_unescape_bytea -- Unescape binary for bytea type

Description

string pg_unescape_bytea ( string data)

pg_unescape_bytea() unescapes string from bytea datatype. It returns unescaped string (binary).

참고: When you SELECT bytea type, PostgreSQL returns octal byte value prefixed by \ (e.g. \032). Users are supposed to convert back to binary format by yourself.

This function requires PostgreSQL 7.2 or later. With PostgreSQL 7.2.0 and 7.2.1, bytea type must be casted when you enable multi-byte support. i.e. INSERT INTO test_table (image) VALUES ('$image_escaped'::bytea); PostgreSQL 7.2.2 or later does not need cast. Exception is when client and backend character encoding does not match, there may be multi-byte stream error. User must cast to bytea to avoid this error.

See also pg_escape_bytea() and pg_escape_string()

이전 | 처음으로 | 다음
pg_tty | 위로 | pg_untrace


pg_untrace

(PHP 4 >= 4.0.1, PHP 5)

pg_untrace -- Disable tracing of a PostgreSQL connection

Description

bool pg_untrace ( [resource connection])

Stop tracing started by pg_trace(). connection specifies the connection that was traced and defaults to the last one opened.

Returns always TRUE.

See also pg_trace().

이전 | 처음으로 | 다음
pg_unescape_bytea | 위로 | pg_update


pg_update

(PHP 4 >= 4.3.0, PHP 5)

pg_update -- Update table.

Description

mixed pg_update ( resource connection, string table_name, array data, array condition [, int options])

pg_update() updates records that matches condition with data. If options is specified, pg_convert() is applied to data with specified options.

예 1. pg_update() example

<?php
    $db = pg_connect('dbname=foo');
    $data = array('field1'=>'AA', 'field2'=>'BB');

    // This is safe, since $_POST is converted automatically
    $res = pg_update($db, 'post_log', $_POST, $data);
    if ($res) {
        echo "Data is updated: $res\n";
    } else {
        echo "User must have sent wrong inputs\n";
    }
?>

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

See also pg_convert().

이전 | 처음으로 | 다음
pg_untrace | 위로 | Process Control Functions


Process Control Functions

PHP 매뉴얼
이전 다음

LXXXV. Process Control Functions

소개

Process Control support in PHP implements the Unix style of process creation, program execution, signal handling and process termination. Process Control should not be enabled within a webserver environment and unexpected results may happen if any Process Control functions are used within a webserver environment.

This documentation is intended to explain the general usage of each of the Process Control functions. For detailed information about Unix process control you are encouraged to consult your systems documentation including fork(2), waitpid(2) and signal(2) or a comprehensive reference such as Advanced Programming in the UNIX Environment by W. Richard Stevens (Addison-Wesley).

PCNTL now uses ticks as the signal handle callback mechanism, which is much faster than the previous mechanism. This change follows the same semantics as using "user ticks". You use the declare() statement to specify the locations in your program where callbacks are allowed to occur. This allows you to minimize the overhead of handling asynchronous events. In the past, compiling PHP with pcntl enabled would always incur this overhead, whether or not your script actually used pcntl.

There is one adjustment that all pcntl scripts prior to PHP 4.3.0 must make for them to work which is to either to use declare() on a section where you wish to allow callbacks or to just enable it across the entire script using the new global syntax of declare().

참고: 이 확장 모듈은 윈도우 플랫폼에서는 사용할 수 없습니다.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

Process Control support in PHP is not enabled by default. You have to compile the CGI or CLI version of PHP with --enable-pcntl configuration option when compiling PHP to enable Process Control support.

참고: Currently, this module will not function on non-Unix platforms (Windows).

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

The following list of signals are supported by the Process Control functions. Please see your systems signal(7) man page for details of the default behavior of these signals.

WNOHANG (integer)

WUNTRACED (integer)

SIG_IGN (integer)

SIG_DFL (integer)

SIG_ERR (integer)

SIGHUP (integer)

SIGINT (integer)

SIGQUIT (integer)

SIGILL (integer)

SIGTRAP (integer)

SIGABRT (integer)

SIGIOT (integer)

SIGBUS (integer)

SIGFPE (integer)

SIGKILL (integer)

SIGUSR1 (integer)

SIGSEGV (integer)

SIGUSR2 (integer)

SIGPIPE (integer)

SIGALRM (integer)

SIGTERM (integer)

SIGSTKFLT (integer)

SIGCLD (integer)

SIGCHLD (integer)

SIGCONT (integer)

SIGSTOP (integer)

SIGTSTP (integer)

SIGTTIN (integer)

SIGTTOU (integer)

SIGURG (integer)

SIGXCPU (integer)

SIGXFSZ (integer)

SIGVTALRM (integer)

SIGPROF (integer)

SIGWINCH (integer)

SIGPOLL (integer)

SIGIO (integer)

SIGPWR (integer)

SIGSYS (integer)

SIGBABY (integer)

예제

This example forks off a daemon process with a signal handler.

예 1. Process Control Example

<?php
declare(ticks=1);

$pid = pcntl_fork();
if ($pid == -1) {
     die("could not fork");
} else if ($pid) {
     exit(); // we are the parent
} else {
     // we are the child
}

// detatch from the controlling terminal
if (!posix_setsid()) {
    die("could not detach from terminal");
}

// setup signal handlers
pcntl_signal(SIGTERM, "sig_handler");
pcntl_signal(SIGHUP, "sig_handler");

// loop forever performing tasks
while (1) {

    // do something interesting here

}

function sig_handler($signo)
{

     switch ($signo) {
         case SIGTERM:
             // handle shutdown tasks
             exit;
             break;
         case SIGHUP:
             // handle restart tasks
             break;
         default:
             // handle all other signals
     }

}

?>

참고

A look at the section about POSIX functions may be useful.

차례
pcntl_alarm -- Set an alarm clock for delivery of a signal
pcntl_exec -- Executes specified program in current process space
pcntl_fork -- Forks the currently running process
pcntl_getpriority -- Get the priority of any process
pcntl_setpriority -- Change the priority of any process
pcntl_signal -- Installs a signal handler
pcntl_wait -- Waits on or returns the status of a forked child
pcntl_waitpid -- Waits on or returns the status of a forked child
pcntl_wexitstatus -- Returns the return code of a terminated child
pcntl_wifexited -- Returns TRUE if status code represents a successful exit
pcntl_wifsignaled -- Returns TRUE if status code represents a termination due to a signal
pcntl_wifstopped -- Returns TRUE if child process is currently stopped
pcntl_wstopsig -- Returns the signal which caused the child to stop
pcntl_wtermsig -- Returns the signal which caused the child to terminate

이전 | 처음으로 | 다음
pg_update | 위로 | pcntl_alarm


pcntl_alarm

(PHP 4 >= 4.3.0, PHP 5)

pcntl_alarm -- Set an alarm clock for delivery of a signal

Description

int pcntl_alarm ( int seconds)

The pcntl_alarm() function creates a timer that will send a SIGALRM signal to the process after seconds seconds. If seconds is zero, no new alarm is created. Any call to pcntl_alarm() will cancel any previously set alarm.

pcntl_alarm() will return the time in seconds that any previously scheduled alarm had remaining before it was to be delivered, or 0 if there was no previously scheduled alarm.

이전 | 처음으로 | 다음
Process Control Functions | 위로 | pcntl_exec


pcntl_exec

(PHP 4 >= 4.2.0, PHP 5)

pcntl_exec -- Executes specified program in current process space

Description

bool pcntl_exec ( string path [, array args [, array envs]])

pcntl_exec() executes the program path with arguments args. path must be the path to a binary executable or a script with a valid path pointing to an executable in the shebang ( #!/usr/local/bin/perl for example) as the first line. See your system's man execve(2) page for additional information.

args is an array of argument strings passed to the program.

envs is an array of strings which are passed as environment to the program. The array is in the format of name => value, the key being the name of the environmental variable and the value being the value of that variable.

pcntl_exec() returns FALSE on error and does not return on success.

이전 | 처음으로 | 다음
pcntl_alarm | 위로 | pcntl_fork


pcntl_fork

(PHP 4 >= 4.1.0, PHP 5)

pcntl_fork -- Forks the currently running process

Description

int pcntl_fork ( void )

The pcntl_fork() function creates a child process that differs from the parent process only in its PID and PPID. Please see your system's fork(2) man page for specific details as to how fork works on your system.

On success, the PID of the child process is returned in the parent's thread of execution, and a 0 is returned in the child's thread of execution. On failure, a -1 will be returned in the parent's context, no child process will be created, and a PHP error is raised.

예 1. pcntl_fork() example

<?php

$pid = pcntl_fork();
if ($pid == -1) {
     die("could not fork");
} else if ($pid) {
     // we are the parent
} else {
     // we are the child
}

?>

See also pcntl_waitpid() and pcntl_signal().

이전 | 처음으로 | 다음
pcntl_exec | 위로 | pcntl_getpriority


pcntl_getpriority

(PHP 5)

pcntl_getpriority -- Get the priority of any process

Description

int pcntl_getpriority ( [int pid])

pcntl_getpriority() gets the priority of pid. If pid is not specified, the pid of the current process is used. Because priority levels can differ between system types and kernel versions, please see your system's getpriority(2) man page for specific details.

pcntl_getpriority() returns the priority of the process or FALSE on error. A lower numerical value causes more favorable scheduling.

주의

이 함수는 Boolean FALSE를 반환하지만, 0이나 ""와 같은 FALSE로 취급하는 Boolean이 아닌 값을 반환할 수도 있습니다. Booleans 섹션에서 자세한 정보를 얻을 수 있습니다. 이 함수의 반환값을 테스트하기 위해서 === 연산자를 이용하십시오.

이전 | 처음으로 | 다음
pcntl_fork | 위로 | pcntl_setpriority


pcntl_setpriority

(PHP 5)

pcntl_setpriority -- Change the priority of any process

Description

bool pcntl_setpriority ( int priority [, int pid])

pcntl_setpriority() sets the priority of pid to priority. If pid is not specified, the pid of the current process is used.

priority is generally a value in the range -20 to 20. The default priority is 0 while a lower numerical value causes more favorable scheduling. Because priority levels can differ between system types and kernel versions, please see your system's setpriority(2) man page for specific details.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
pcntl_getpriority | 위로 | pcntl_signal


pcntl_signal

(PHP 4 >= 4.1.0, PHP 5)

pcntl_signal -- Installs a signal handler

Description

bool pcntl_signal ( int signo, callback handle [, bool restart_syscalls])

The pcntl_signal() function installs a new signal handler for the signal indicated by signo. The signal handler is set to handler which may be the name of a user created function, or either of the two global constants SIG_IGN or SIG_DFL. The optional restart_syscalls specifies whether system call restarting should be used when this signal arrives and defaults to TRUE.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: The optional restart_syscalls parameter became available in PHP 4.3.0.

참고: The ability to use an object method as a callback became available in PHP 4.3.0. Note that when you set a handler to an object method, that object's reference count is increased which makes it persist until you either change the handler to something else, or your script ends.

예 1. pcntl_signal() example

<?php
// tick use required as of PHP 4.3.0
declare(ticks = 1);

// signal handler function
function sig_handler($signo)
{

     switch ($signo) {
         case SIGTERM:
             // handle shutdown tasks
             exit;
             break;
         case SIGHUP:
             // handle restart tasks
             break;
         case SIGUSR1:
             echo "Caught SIGUSR1...\n";
             break;
         default:
             // handle all other signals
     }

}

echo "Installing signal handler...\n";

// setup signal handlers
pcntl_signal(SIGTERM, "sig_handler");
pcntl_signal(SIGHUP,  "sig_handler");
pcntl_signal(SIGUSR1, "sig_handler");

// or use an object, available as of PHP 4.3.0
// pcntl_signal(SIGUSR1, array($obj, "do_something");

echo"Generating signal SIGTERM to self...\n";

// send SIGUSR1 to current process id
posix_kill(posix_getpid(), SIGUSR1);

echo "Done\n"

?>

참고: As of PHP 4.3.0 PCNTL uses ticks as the signal handle callback mechanism, which is much faster than the previous mechanism. This change follows the same semantics as using "user ticks". You must use the declare() statement to specify the locations in your program where callbacks are allowed to occur for the signal handler to function properly (as used in the above example).

See also pcntl_fork() and pcntl_waitpid().

이전 | 처음으로 | 다음
pcntl_setpriority | 위로 | pcntl_wait


pcntl_wait

(PHP 5)

pcntl_wait -- Waits on or returns the status of a forked child

Description

int pcntl_wait ( int &status [, int options])

The wait function suspends execution of the current process until a child has exited, or until a signal is delivered whose action is to terminate the current process or to call a signal handling function. If a child has already exited by the time of the call (a so-called "zombie" process), the function returns immediately. Any system resources used by the child are freed. Please see your system's wait(2) man page for specific details as to how wait works on your system.

pcntl_wait() returns the process ID of the child which exited, -1 on error or zero if WNOHANG was provided as an option (on wait3-available systems) and no child was available.

If wait3 is available on your system (mostly BSD-style systems), you can provide the optional options parameter. If this parameter is not provided, wait will be used for the system call. If wait3 is not available, providing a value for options will have no effect. The value of options is the value of zero or more of the following two constants OR'ed together:

표 1. Possible values for options if wait3 is available

WNOHANG | Return immediately if no child has exited.
WUNTRACED | Return for children which are stopped, and whose status has not been reported.

pcntl_wait() will store status information
in the status parameter which can be
evaluated using the following functions:
pcntl_wifexited(),
pcntl_wifstopped(),
pcntl_wifsignaled(),
pcntl_wexitstatus(),
pcntl_wtermsig() and
pcntl_wstopsig().

참고: This function is equivalent to calling pcntl_waitpid() with a -1 pid and no options.

See also pcntl_fork(),
pcntl_signal(),
pcntl_wifexited(),
pcntl_wifstopped(),
pcntl_wifsignaled(),
pcntl_wexitstatus(),
pcntl_wtermsig(),
pcntl_wstopsig() and
pcntl_waitpid().

이전 | 처음으로 | 다음
pcntl_signal | 위로 | pcntl_waitpid


pcntl_waitpid

(PHP 4 >= 4.1.0, PHP 5)

pcntl_waitpid -- Waits on or returns the status of a forked child

Description

int pcntl_waitpid ( int pid, int &status, int options)

The pcntl_waitpid() function suspends execution of the current process until a child as specified by the pid argument has exited, or until a signal is delivered whose action is to terminate the current process or to call a signal handling function. If a child as requested by pid has already exited by the time of the call (a so-called "zombie" process), the function returns immediately. Any system resources used by the child are freed. Please see your system's waitpid(2) man page for specific details as to how waitpid works on your system.

pcntl_waitpid() returns the process ID of the child which exited, -1 on error or zero if WNOHANG was used and no child was available

The value of pid can be one of the following:

표 1. possible values for pid

< -1 | wait for any child process whose process group ID is equal to the absolute value of pid.
-1 | wait for any child process; this is the same behaviour that the wait function exhibits.
0 | wait for any child process whose process group ID is equal to that of the calling process.
> 0 | wait for the child whose process ID is equal to the value of pid.

참고: Specifying -1 as the pid is equivalent to the functionality pcntl_wait() provides (minus options).

pcntl_waitpid() will store status information
in the status parameter which can be
evaluated using the following functions:
pcntl_wifexited(),
pcntl_wifstopped(),
pcntl_wifsignaled(),
pcntl_wexitstatus(),
pcntl_wtermsig() and
pcntl_wstopsig().

The value of options is the value of zero or more of the following two global constants OR'ed together:

표 2. possible values for options

WNOHANG | return immediately if no child has exited.
WUNTRACED | return for children which are stopped, and whose status has not been reported.

See also pcntl_fork(),
pcntl_signal(),
pcntl_wifexited(),
pcntl_wifstopped(),
pcntl_wifsignaled(),
pcntl_wexitstatus(),
pcntl_wtermsig() and
pcntl_wstopsig().

이전 | 처음으로 | 다음
pcntl_wait | 위로 | pcntl_wexitstatus


pcntl_wexitstatus

(PHP 4 >= 4.1.0, PHP 5)

pcntl_wexitstatus -- Returns the return code of a terminated child

Description

int pcntl_wexitstatus ( int status)

Returns the return code of a terminated child. This function is only useful if pcntl_wifexited() returned TRUE.

The parameter status is the status parameter supplied to a successfull call to pcntl_waitpid().

See also pcntl_waitpid() and pcntl_wifexited().

이전 | 처음으로 | 다음
pcntl_waitpid | 위로 | pcntl_wifexited


pcntl_wifexited

(PHP 4 >= 4.1.0, PHP 5)

pcntl_wifexited -- Returns TRUE if status code represents a successful exit

Description

int pcntl_wifexited ( int status)

Returns TRUE if the child status code represents a successful exit.

The parameter status is the status parameter supplied to a successfull call to pcntl_waitpid().

See also pcntl_waitpid() and pcntl_wexitstatus().

이전 | 처음으로 | 다음
pcntl_wexitstatus | 위로 | pcntl_wifsignaled


pcntl_wifsignaled

(PHP 4 >= 4.1.0, PHP 5)

pcntl_wifsignaled -- Returns TRUE if status code represents a termination due to a signal

Description

int pcntl_wifsignaled ( int status)

Returns TRUE if the child process exited because of a signal which was not caught.

The parameter status is the status parameter supplied to a successfull call to pcntl_waitpid().

See also pcntl_waitpid() and pcntl_signal().

이전 | 처음으로 | 다음
pcntl_wifexited | 위로 | pcntl_wifstopped


pcntl_wifstopped

(PHP 4 >= 4.1.0, PHP 5)

pcntl_wifstopped -- Returns TRUE if child process is currently stopped

Description

int pcntl_wifstopped ( int status)

Returns TRUE if the child process which caused the return is currently stopped; this is only possible if the call to pcntl_waitpid() was done using the option WUNTRACED.

The parameter status is the status parameter supplied to a successfull call to pcntl_waitpid().

See also pcntl_waitpid().

이전 | 처음으로 | 다음
pcntl_wifsignaled | 위로 | pcntl_wstopsig


pcntl_wstopsig

(PHP 4 >= 4.1.0, PHP 5)

pcntl_wstopsig -- Returns the signal which caused the child to stop

Description

int pcntl_wstopsig ( int status)

Returns the number of the signal which caused the child to stop. This function is only useful if pcntl_wifstopped() returned TRUE.

The parameter status is the status parameter supplied to a successfull call to pcntl_waitpid().

See also pcntl_waitpid() and pcntl_wifstopped().

이전 | 처음으로 | 다음
pcntl_wifstopped | 위로 | pcntl_wtermsig


pcntl_wtermsig

(PHP 4 >= 4.1.0, PHP 5)

pcntl_wtermsig -- Returns the signal which caused the child to terminate

Description

int pcntl_wtermsig ( int status)

Returns the number of the signal that caused the child process to terminate. This function is only useful if pcntl_wifsignaled() returned TRUE.

The parameter status is the status parameter supplied to a successfull call to pcntl_waitpid().

See also pcntl_waitpid(),
pcntl_signal() and
pcntl_wifsignaled().

이전 | 처음으로 | 다음
pcntl_wstopsig | 위로 | Program Execution Functions


Program Execution Functions

PHP 매뉴얼
이전 다음

LXXXVI. Program Execution Functions

소개

Those functions provides means to executes commands on the system itself, and means secure such commands.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

참고

These functions are also closely related to the backtick operator. Also, while in 안전 모드 you must consider the safe_mode_exec_dir directive.

차례
escapeshellarg -- escape a string to be used as a shell argument
escapeshellcmd -- escape shell metacharacters
exec -- Execute an external program
passthru -- Execute an external program and display raw output
proc_close -- Close a process opened by proc_open() and return the exit code of that process.
proc_get_status -- Get information about a process opened by proc_open()
proc_nice -- Change the priority of the current process
proc_open -- Execute a command and open file pointers for input/output
proc_terminate -- kills a process opened by proc_open
shell_exec -- Execute command via shell and return the complete output as a string
system -- Execute an external program and display the output

이전 | 처음으로 | 다음
pcntl_wtermsig | 위로 | escapeshellarg


escapeshellarg

(PHP 4 >= 4.0.3, PHP 5)

escapeshellarg -- escape a string to be used as a shell argument

Description

string escapeshellarg ( string arg)

escapeshellarg() adds single quotes around a string and quotes/escapes any existing single quotes allowing you to pass a string directly to a shell function and having it be treated as a single safe argument. This function should be used to escape individual arguments to shell functions coming from user input. The shell functions include exec(), system() and the backtick operator. A standard use would be:

<?php
system('ls '.escapeshellarg($dir));
?>

See also escapeshellcmd(), exec(), popen(), system(), and the backtick operator.

이전 | 처음으로 | 다음
Program Execution Functions | 위로 | escapeshellcmd


escapeshellcmd

(PHP 3, PHP 4 , PHP 5)

escapeshellcmd -- escape shell metacharacters

Description

string escapeshellcmd ( string command)

escapeshellcmd() escapes any characters in a string that might be used to trick a shell command into executing arbitrary commands. This function should be used to make sure that any data coming from user input is escaped before this data is passed to the exec() or system() functions, or to the backtick operator. A standard use would be:

<?php
$e = escapeshellcmd($userinput);

// here we don't care if $e has spaces
system("echo $e");
$f = escapeshellcmd($filename);

// and here we do, so we use quotes
system("touch \"/tmp/$f\"; ls -l \"/tmp/$f\"");
?>

See also escapeshellarg(), exec(), popen(), system(), and the backtick operator.

이전 | 처음으로 | 다음
escapeshellarg | 위로 | exec


exec

(PHP 3, PHP 4 , PHP 5)

exec -- Execute an external program

Description

string exec ( string command [, array output [, int return_var]])

exec() executes the given command, however it does not output anything. It simply returns the last line from the result of the command. If you need to execute a command and have all the data from the command passed directly back without any interference, use the passthru() function.

If the output argument is present, then the specified array will be filled with every line of output from the command. Line endings, such as \n, are not included in this array. Note that if the array already contains some elements, exec() will append to the end of the array. If you do not want the function to append elements, call unset() on the array before passing it to exec().

If the return_var argument is present along with the output argument, then the return status of the executed command will be written to this variable.

예 1. An exec() example

<?php
// outputs the username that owns the running php/httpd process
// (on a system with the "whoami" executable in the path)
echo exec('whoami');
?>

주의

사용자가 입력한 데이터를 이 함수로 넘길 때는, escapeshellarg()나 escapeshellcmd()를 사용하여, 사용자가 어떠한 명령을 실행하여 시스템을 조작하지 못하게 하여야 합니다.

참고: 이 함수를 사용하여 프로그램을 실행하고, 백그라운드에서 작업하게 내버려두려면, 그 프로그램의 출력이 파일이나 다른 출력 스트림을 향하게 하여야 합니다. 그렇지 않으면 PHP는 그 프로그램이 종료할 때까지 정지합니다.

참고: 안전 모드에서 실행 명령은 safe_mode_exec_dir 안에서만 실행할 수 있습니다. 실용적인 이유로, 실행 경로에 ..을 허용하지 않습니다.

주의

안전 모드에서는 처음 명령어 이후에 따라오는 모든 단어를 하나의 인수로 취급합니다. 그러므로, echo y | echo x은 echo "y | echo x"가 됩니다.

See also system(),
passthru(), popen(),
escapeshellcmd()
pcntl_exec(), and the backtick operator.

이전 | 처음으로 | 다음
escapeshellcmd | 위로 | passthru


passthru

(PHP 3, PHP 4 , PHP 5)

passthru -- Execute an external program and display raw output

Description

void passthru ( string command [, int return_var])

The passthru() function is similar to the exec() function in that it executes a command. If the return_var argument is present, the return status of the Unix command will be placed here. This function should be used in place of exec() or system() when the output from the Unix command is binary data which needs to be passed directly back to the browser. A common use for this is to execute something like the pbmplus utilities that can output an image stream directly. By setting the Content-type to image/gif and then calling a pbmplus program to output a gif, you can create PHP scripts that output images directly.

주의

사용자가 입력한 데이터를 이 함수로 넘길 때는, escapeshellarg()나 escapeshellcmd()를 사용하여, 사용자가 어떠한 명령을 실행하여 시스템을 조작하지 못하게 하여야 합니다.

참고: 이 함수를 사용하여 프로그램을 실행하고, 백그라운드에서 작업하게 내버려두려면, 그 프로그램의 출력이 파일이나 다른 출력 스트림을 향하게 하여야 합니다. 그렇지 않으면 PHP는 그 프로그램이 종료할 때까지 정지합니다.

참고: 안전 모드에서 실행 명령은 safe_mode_exec_dir 안에서만 실행할 수 있습니다. 실용적인 이유로, 실행 경로에 ..을 허용하지 않습니다.

주의

안전 모드에서는 처음 명령어 이후에 따라오는 모든 단어를 하나의 인수로 취급합니다. 그러므로, echo y | echo x은 echo "y | echo x"가 됩니다.

See also exec(), system(), popen(), escapeshellcmd(), and the backtick operator.

이전 | 처음으로 | 다음
exec | 위로 | proc_close


proc_close

(PHP 4 >= 4.3.0, PHP 5)

proc_close -- Close a process opened by proc_open() and return the exit code of that process.

Description

int proc_close ( resource process)

proc_close() is similar to pclose() except that it only works on processes opened by proc_open(). proc_close() waits for the process to terminate, and returns its exit code. If you have open pipes to that process, you should fclose() them prior to calling this function in order to avoid a deadlock - the child process may not be able to exit while the pipes are open.

이전 | 처음으로 | 다음
passthru | 위로 | proc_get_status


proc_get_status

(PHP 5)

proc_get_status -- Get information about a process opened by proc_open()

Description

array proc_get_status ( resource process)

proc_get_status() fetches data about a process opened using proc_open(). The collected information is returned in an array containing the following elements:

element | type | description
command | string | The command string that was passed to proc_open()
pid | int | process id
running | bool | TRUE if the process is still running, FALSE if it has terminated
signaled | bool | TRUE if the child process has been terminated by an uncaught signal. Always set to FALSE on Windows.
stopped | bool | TRUE if the child process has been stopped by a signal. Always set to FALSE on Windows.
exitcode | int | the exit code returned by the process (which is only meaningful if running is FALSE)
termsig | int | the number of the signal that caused the child process to terminate its execution (only meaningful if signaled is TRUE)
stopsig | int | the number of the signal that caused the child process to stop its execution (only meaningful if stopped is TRUE)

See also proc_open().

이전 | 처음으로 | 다음
proc_close | 위로 | proc_nice


proc_nice

(PHP 5)

proc_nice -- Change the priority of the current process

Description

bool proc_nice ( int priority)

proc_nice() changes the priority of the current process. If an error occurs, like the user lacks permission to change the priority, an error of level E_WARNING is generated and FALSE is returned. Otherwise, TRUE is returned.

참고: proc_nice() will only exist if your system has 'nice' capabilities. 'nice' conforms to: SVr4, SVID EXT, AT&T, X/OPEN, BSD 4.3. This means that proc_nice() is not available on Windows.

proc_nice() is not related to proc_open() and its associated functions in any way.

이전 | 처음으로 | 다음
proc_get_status | 위로 | proc_open


proc_open

(PHP 4 >= 4.3.0, PHP 5)

proc_open -- Execute a command and open file pointers for input/output

Description

resource proc_open ( string cmd, array descriptorspec, array pipes)

proc_open() is similar to popen() but provides a much greater degree of control over the program execution. cmd is the command to be executed by the shell. descriptorspec is an indexed array where the key represents the descriptor number and the value represents how PHP will pass that descriptor to the child process. pipes will be set to an indexed array of file pointers that correspond to PHP's end of any pipes that are created. The return value is a resource representing the process; you should free it using proc_close() when you are finished with it.

<?php
$descriptorspec = array(
   0 => array("pipe", "r"),  // stdin is a pipe that the child will read from
   1 => array("pipe", "w"),  // stdout is a pipe that the child will write to
   2 => array("file", "/tmp/error-output.txt", "a") // stderr is a file to write to
);
$process = proc_open("php", $descriptorspec, $pipes);
if (is_resource($process)) {
    // $pipes now looks like this:
    // 0 => writeable handle connected to child stdin
    // 1 => readable handle connected to child stdout
    // Any error output will be appended to /tmp/error-output.txt

    fwrite($pipes[0], "<?php echo \"Hello World!\"; ?>");
    fclose($pipes[0]);

    while (!feof($pipes[1])) {
        echo fgets($pipes[1], 1024);
    }
    fclose($pipes[1]);
    // It is important that you close any pipes before calling
    // proc_close in order to avoid a deadlock
    $return_value = proc_close($process);

    echo "command returned $return_value\n";
}
?>

PHP 5RC2 introduces pty support for systems with Unix98 ptys. This allows your script to interact with applications that expect to be talking to a terminal. A pty works like a pipe, but is bi-directional, so there is no need to specify a read/write mode. The example below shows how to use a pty; note that you don't have to have all descriptors talking to a pty. Also note that only one pty is created, even though pty is specified 3 times. In a future version of PHP, it might be possible to do more than just read and write to the pty.

<?php
// Create a psuedo terminal for the child process
$descriptorspec = array(
   0 => array("pty"),
   1 => array("pty"),
   2 => array("pty")
);
$process = proc_open("cvs -d:pserver:cvsread@cvs.php.net:/repository login", $descriptorspec, $pipes);
if (is_resource($process)) {
   // work with it here
}
?>

The file descriptor numbers in descriptorspec are not limited to 0, 1 and 2 - you may specify any valid file descriptor number and it will be passed to the child process. This allows your script to interoperate with other scripts that run as "co-processes". In particular, this is useful for passing passphrases to programs like PGP, GPG and openssl in a more secure manner. It is also useful for reading status information provided by those programs on auxiliary file descriptors.

참고: Windows compatibility: Descriptors beyond 2 (stderr) are made available to the child process as inheritable handles, but since the Windows architecture does not associate file descriptor numbers with low-level handles, the child process does not (yet) have a means of accessing those handles. Stdin, stdout and stderr work as expected.

참고: If you only need a uni-directional (one-way) process pipe, use popen() instead, as it is much easier to use.

See also stream_select(), exec(),
system(),
passthru(), popen(),
escapeshellcmd(), and the backtick operator.

이전 | 처음으로 | 다음
proc_nice | 위로 | proc_terminate


proc_terminate

(PHP 5)

proc_terminate -- kills a process opened by proc_open

Description

int proc_terminate ( resource process [, int signal])

Signals a process (created using proc_open()) that it should terminate. proc_terminate() returns immediately and does not wait for the process to terminate.

The optional signal is only useful on POSIX operating systems; you may specify a signal to send to the process using the kill(2) system call. The default is SIGTERM.

proc_terminate() allows you terminate the process and continue with other tasks. You may poll the process (to see if it has stopped yet) by using the proc_get_status() function.

See also proc_open(), proc_close(), and proc_get_status().

이전 | 처음으로 | 다음
proc_open | 위로 | shell_exec


shell_exec

(PHP 4 , PHP 5)

shell_exec -- Execute command via shell and return the complete output as a string

Description

string shell_exec ( string cmd)

This function is identical to the backtick operator.

참고: 이 함수는 안전 모드에서 사용할 수 없습니다.

이전 | 처음으로 | 다음
proc_terminate | 위로 | system


system

(PHP 3, PHP 4 , PHP 5)

system -- Execute an external program and display the output

Description

string system ( string command [, int return_var])

system() is just like the C version of the function in that it executes the given command and outputs the result. If a variable is provided as the second argument, then the return status code of the executed command will be written to this variable.

주의

사용자가 입력한 데이터를 이 함수로 넘길 때는, escapeshellarg()나 escapeshellcmd()를 사용하여, 사용자가 어떠한 명령을 실행하여 시스템을 조작하지 못하게 하여야 합니다.

참고: 이 함수를 사용하여 프로그램을 실행하고, 백그라운드에서 작업하게 내버려두려면, 그 프로그램의 출력이 파일이나 다른 출력 스트림을 향하게 하여야 합니다. 그렇지 않으면 PHP는 그 프로그램이 종료할 때까지 정지합니다.

The system() call also tries to automatically flush the web server's output buffer after each line of output if PHP is running as a server module.

Returns the last line of the command output on success, and FALSE on failure.

If you need to execute a command and have all the data from the command passed directly back without any interference, use the passthru() function.

예 1. system() example

<?php
echo '<pre>';

// Outputs all the result of shellcommand "ls", and returns
// the last output line into $last_line. Stores the return value
// of the shell command in $retval.
$last_line = system('ls', $retval);

// Printing additional info
echo '
</pre>
<hr />Last line of the output: ' . $last_line . '
<hr />Return value: ' . $retval;
?>

참고: 안전 모드에서 실행 명령은 safe_mode_exec_dir 안에서만 실행할 수 있습니다. 실용적인 이유로, 실행 경로에 ..을 허용하지 않습니다.

주의

안전 모드에서는 처음 명령어 이후에 따라오는 모든 단어를 하나의 인수로 취급합니다. 그러므로, echo y | echo x은 echo "y | echo x"가 됩니다.

See also exec(),
passthru(), popen(),
escapeshellcmd(),
pcntl_exec(), and the backtick operator.

이전 | 처음으로 | 다음
shell_exec | 위로 | Printer Functions


Printer Functions

PHP 매뉴얼
이전 다음

LXXXVII. Printer Functions

소개

These functions are only available under Windows 9.x, ME, NT4 and 2000. They have been added in PHP 4.0.4.

설치

Add the line extension=php_printer.dll to your php.ini file.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. Printer configuration options

Name | Default | Changeable
printer.default_printer | "" | PHP_INI_ALL
For further details and definition of the PHP_INI_* constants see ini_set().

차례
printer_abort -- Deletes the printer's spool file
printer_close -- Close an open printer connection
printer_create_brush -- Create a new brush
printer_create_dc -- Create a new device context
printer_create_font -- Create a new font
printer_create_pen -- Create a new pen
printer_delete_brush -- Delete a brush
printer_delete_dc -- Delete a device context
printer_delete_font -- Delete a font
printer_delete_pen -- Delete a pen
printer_draw_bmp -- Draw a bmp
printer_draw_chord -- Draw a chord
printer_draw_elipse -- Draw an ellipse
printer_draw_line -- Draw a line
printer_draw_pie -- Draw a pie
printer_draw_rectangle -- Draw a rectangle
printer_draw_roundrect -- Draw a rectangle with rounded corners
printer_draw_text -- Draw text
printer_end_doc -- Close document
printer_end_page -- Close active page
printer_get_option -- Retrieve printer configuration data
printer_list -- Return an array of printers attached to the server
printer_logical_fontheight -- Get logical font height
printer_open -- Open connection to a printer
printer_select_brush -- Select a brush
printer_select_font -- Select a font
printer_select_pen -- Select a pen
printer_set_option -- Configure the printer connection
printer_start_doc -- Start a new document
printer_start_page -- Start a new page
printer_write -- Write data to the printer

이전 | 처음으로 | 다음
system | 위로 | printer_abort


printer_abort

(no version information, might be only in CVS)

printer_abort -- Deletes the printer's spool file

Description

void printer_abort ( resource handle)

This function deletes the printers spool file.

handle must be a valid handle to a printer.

예 1. printer_abort() example

<?php
$handle = printer_open();
printer_abort($handle);
printer_close($handle);
?>

이전 | 처음으로 | 다음
Printer Functions | 위로 | printer_close


printer_close

(no version information, might be only in CVS)

printer_close -- Close an open printer connection

Description

void printer_close ( resource handle)

This function closes the printer connection. printer_close() also closes the active device context.

handle must be a valid handle to a printer.

예 1. printer_close() example

<?php
$handle = printer_open();
printer_close($handle);
?>

이전 | 처음으로 | 다음
printer_abort | 위로 | printer_create_brush


printer_create_brush

(no version information, might be only in CVS)

printer_create_brush -- Create a new brush

Description

mixed printer_create_brush ( int style, string color)

The function creates a new brush and returns a handle to it. A brush is used to fill shapes. For an example see printer_select_brush(). color must be a color in RGB hex format, i.e. "000000" for black, style must be one of the following constants:

  • PRINTER_BRUSH_SOLID: creates a brush with a solid color.

  • PRINTER_BRUSH_DIAGONAL: creates a brush with a 45-degree upward left-to-right hatch ( / ).

  • PRINTER_BRUSH_CROSS: creates a brush with a cross hatch ( + ).

  • PRINTER_BRUSH_DIAGCROSS: creates a brush with a 45 cross hatch ( x ).

  • PRINTER_BRUSH_FDIAGONAL: creates a brush with a 45-degree downward left-to-right hatch ( \ ).

  • PRINTER_BRUSH_HORIZONTAL: creates a brush with a horizontal hatch ( - ).

  • PRINTER_BRUSH_VERTICAL: creates a brush with a vertical hatch ( | ).

  • PRINTER_BRUSH_CUSTOM: creates a custom brush from an BMP file. The second parameter is used to specify the BMP instead of the RGB color code.

이전 | 처음으로 | 다음
printer_close | 위로 | printer_create_dc


printer_create_dc

(no version information, might be only in CVS)

printer_create_dc -- Create a new device context

Description

void printer_create_dc ( resource handle)

The function creates a new device context. A device context is used to customize the graphic objects of the document. handle must be a valid handle to a printer.

예 1. printer_create_dc() example

<?php
$handle = printer_open();
printer_start_doc($handle);
printer_start_page($handle);

printer_create_dc($handle);
/* do some stuff with the dc */
printer_set_option($handle, PRINTER_TEXT_COLOR, "333333");
printer_draw_text($handle, 1, 1, "text");
printer_delete_dc($handle);

/* create another dc */
printer_create_dc($handle);
printer_set_option($handle, PRINTER_TEXT_COLOR, "000000");
printer_draw_text($handle, 1, 1, "text");
/* do some stuff with the dc */

printer_delete_dc($handle);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

이전 | 처음으로 | 다음
printer_create_brush | 위로 | printer_create_font


printer_create_font

(no version information, might be only in CVS)

printer_create_font -- Create a new font

Description

mixed printer_create_font ( string face, int height, int width, int font_weight, bool italic, bool underline, bool strikeout, int orientaton)

The function creates a new font and returns a handle to it. A font is used to draw text. For an example see printer_select_font(). face must be a string specifying the font face. height specifies the font height, and width the font width. The font_weight specifies the font weight (400 is normal), and can be one of the following predefined constants.

  • PRINTER_FW_THIN: sets the font weight to thin (100).

  • PRINTER_FW_ULTRALIGHT: sets the font weight to ultra light (200).

  • PRINTER_FW_LIGHT: sets the font weight to light (300).

  • PRINTER_FW_NORMAL: sets the font weight to normal (400).

  • PRINTER_FW_MEDIUM: sets the font weight to medium (500).

  • PRINTER_FW_BOLD: sets the font weight to bold (700).

  • PRINTER_FW_ULTRABOLD: sets the font weight to ultra bold (800).

  • PRINTER_FW_HEAVY: sets the font weight to heavy (900).

italic can be TRUE or FALSE, and sets whether the font should be italic.

underline can be TRUE or FALSE, and sets whether the font should be underlined.

strikeout can be TRUE or FALSE, and sets whether the font should be stroked out.

orientation specifies a rotation. For an example see printer_select_font().

이전 | 처음으로 | 다음
printer_create_dc | 위로 | printer_create_pen


printer_create_pen

(no version information, might be only in CVS)

printer_create_pen -- Create a new pen

Description

mixed printer_create_pen ( int style, int width, string color)

The function creates a new pen and returns a handle to it. A pen is used to draw lines and curves. For an example see printer_select_pen(). color must be a color in RGB hex format, i.e. "000000" for black, width specifies the width of the pen whereas style must be one of the following constants:

  • PRINTER_PEN_SOLID: creates a solid pen.

  • PRINTER_PEN_DASH: creates a dashed pen.

  • PRINTER_PEN_DOT: creates a dotted pen.

  • PRINTER_PEN_DASHDOT: creates a pen with dashes and dots.

  • PRINTER_PEN_DASHDOTDOT: creates a pen with dashes and double dots.

  • PRINTER_PEN_INVISIBLE: creates an invisible pen.

이전 | 처음으로 | 다음
printer_create_font | 위로 | printer_delete_brush


printer_delete_brush

(no version information, might be only in CVS)

printer_delete_brush -- Delete a brush

Description

bool printer_delete_brush ( resource handle)

The function deletes the selected brush. For an example see printer_select_brush(). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. handle must be a valid handle to a brush.

이전 | 처음으로 | 다음
printer_create_pen | 위로 | printer_delete_dc


printer_delete_dc

(no version information, might be only in CVS)

printer_delete_dc -- Delete a device context

Description

bool printer_delete_dc ( resource handle)

The function deletes the device context. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. For an example see printer_create_dc(). handle must be a valid handle to a printer.

이전 | 처음으로 | 다음
printer_delete_brush | 위로 | printer_delete_font


printer_delete_font

(no version information, might be only in CVS)

printer_delete_font -- Delete a font

Description

bool printer_delete_font ( resource handle)

The function deletes the selected font. For an example see printer_select_font(). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. handle must be a valid handle to a font.

이전 | 처음으로 | 다음
printer_delete_dc | 위로 | printer_delete_pen


printer_delete_pen

(no version information, might be only in CVS)

printer_delete_pen -- Delete a pen

Description

bool printer_delete_pen ( resource handle)

The function deletes the selected pen. For an example see printer_select_pen(). 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. handle must be a valid handle to a pen.

이전 | 처음으로 | 다음
printer_delete_font | 위로 | printer_draw_bmp


printer_draw_bmp

(no version information, might be only in CVS)

printer_draw_bmp -- Draw a bmp

Description

void printer_draw_bmp ( resource handle, string filename, int x, int y)

The function simply draws an bmp the bitmap filename at position x, y. handle must be a valid handle to a printer.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. printer_draw_bmp() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

printer_draw_bmp($handle, "c:\\image.bmp", 1, 1);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

이전 | 처음으로 | 다음
printer_delete_pen | 위로 | printer_draw_chord


printer_draw_chord

(no version information, might be only in CVS)

printer_draw_chord -- Draw a chord

Description

void printer_draw_chord ( resource handle, int rec_x, int rec_y, int rec_x1, int rec_y1, int rad_x, int rad_y, int rad_x1, int rad_y1)

The function simply draws an chord. handle must be a valid handle to a printer.

rec_x is the upper left x coordinate of the bounding rectangle.

rec_y is the upper left y coordinate of the bounding rectangle.

rec_x1 is the lower right x coordinate of the bounding rectangle.

rec_y1 is the lower right y coordinate of the bounding rectangle.

rad_x is x coordinate of the radial defining the beginning of the chord.

rad_y is y coordinate of the radial defining the beginning of the chord.

rad_x1 is x coordinate of the radial defining the end of the chord.

rad_y1 is y coordinate of the radial defining the end of the chord.

예 1. printer_draw_chord() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 2, "000000");
printer_select_pen($handle, $pen);

$brush = printer_create_brush(PRINTER_BRUSH_SOLID, "2222FF");
printer_select_brush($handle, $brush);

printer_draw_chord($handle, 1, 1, 500, 500, 1, 1, 500, 1);

printer_delete_brush($brush);
printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

이전 | 처음으로 | 다음
printer_draw_bmp | 위로 | printer_draw_elipse


printer_draw_elipse

(no version information, might be only in CVS)

printer_draw_elipse -- Draw an ellipse

Description

void printer_draw_elipse ( resource handle, int ul_x, int ul_y, int lr_x, int lr_y)

The function simply draws an ellipse. handle must be a valid handle to a printer.

ul_x is the upper left x coordinate of the ellipse.

ul_y is the upper left y coordinate of the ellipse.

lr_x is the lower right x coordinate of the ellipse.

lr_y is the lower right y coordinate of the ellipse.

예 1. printer_draw_elipse() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 2, "000000");
printer_select_pen($handle, $pen);

$brush = printer_create_brush(PRINTER_BRUSH_SOLID, "2222FF");
printer_select_brush($handle, $brush);

printer_draw_elipse($handle, 1, 1, 500, 500);

printer_delete_brush($brush);
printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

이전 | 처음으로 | 다음
printer_draw_chord | 위로 | printer_draw_line


printer_draw_line

(no version information, might be only in CVS)

printer_draw_line -- Draw a line

Description

void printer_draw_line ( resource printer_handle, int from_x, int from_y, int to_x, int to_y)

The function simply draws a line from position from_x, from_y to position to_x, to_y using the selected pen. printer_handle must be a valid handle to a printer.

예 1. printer_draw_line() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 30, "000000");
printer_select_pen($handle, $pen);

printer_draw_line($handle, 1, 10, 1000, 10);
printer_draw_line($handle, 1, 60, 500, 60);

printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

이전 | 처음으로 | 다음
printer_draw_elipse | 위로 | printer_draw_pie


printer_draw_pie

(no version information, might be only in CVS)

printer_draw_pie -- Draw a pie

Description

void printer_draw_pie ( resource handle, int rec_x, int rec_y, int rec_x1, int rec_y1, int rad1_x, int rad1_y, int rad2_x, int rad2_y)

The function simply draws an pie. handle must be a valid handle to a printer.

rec_x is the upper left x coordinate of the bounding rectangle.

rec_y is the upper left y coordinate of the bounding rectangle.

rec_x1 is the lower right x coordinate of the bounding rectangle.

rec_y1 is the lower right y coordinate of the bounding rectangle.

rad1_x is x coordinate of the first radial's ending.

rad1_y is y coordinate of the first radial's ending.

rad2_x is x coordinate of the second radial's ending.

rad2_y is y coordinate of the second radial's ending.

예 1. printer_draw_pie() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 2, "000000");
printer_select_pen($handle, $pen);

$brush = printer_create_brush(PRINTER_BRUSH_SOLID, "2222FF");
printer_select_brush($handle, $brush);

printer_draw_pie($handle, 1, 1, 500, 500, 1, 1, 500, 1);

printer_delete_brush($brush);
printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

이전 | 처음으로 | 다음
printer_draw_line | 위로 | printer_draw_rectangle


printer_draw_rectangle

(no version information, might be only in CVS)

printer_draw_rectangle -- Draw a rectangle

Description

void printer_draw_rectangle ( resource handle, int ul_x, int ul_y, int lr_x, int lr_y)

The function simply draws a rectangle.

handle must be a valid handle to a printer.

ul_x is the upper left x coordinate of the rectangle.

ul_y is the upper left y coordinate of the rectangle.

lr_x is the lower right x coordinate of the rectangle.

lr_y is the lower right y coordinate of the rectangle.

예 1. printer_draw_rectangle() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 2, "000000");
printer_select_pen($handle, $pen);

$brush = printer_create_brush(PRINTER_BRUSH_SOLID, "2222FF");
printer_select_brush($handle, $brush);

printer_draw_rectangle($handle, 1, 1, 500, 500);

printer_delete_brush($brush);
printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

이전 | 처음으로 | 다음
printer_draw_pie | 위로 | printer_draw_roundrect


printer_draw_roundrect

(no version information, might be only in CVS)

printer_draw_roundrect -- Draw a rectangle with rounded corners

Description

void printer_draw_roundrect ( resource handle, int ul_x, int ul_y, int lr_x, int lr_y, int width, int height)

The function simply draws a rectangle with rounded corners.

handle must be a valid handle to a printer.

ul_x is the upper left x coordinate of the rectangle.

ul_y is the upper left y coordinate of the rectangle.

lr_x is the lower right x coordinate of the rectangle.

lr_y is the lower right y coordinate of the rectangle.

width is the width of the ellipse.

height is the height of the ellipse.

예 1. printer_draw_roundrect() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 2, "000000");
printer_select_pen($handle, $pen);

$brush = printer_create_brush(PRINTER_BRUSH_SOLID, "2222FF");
printer_select_brush($handle, $brush);

printer_draw_roundrect($handle, 1, 1, 500, 500, 200, 200);

printer_delete_brush($brush);
printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

이전 | 처음으로 | 다음
printer_draw_rectangle | 위로 | printer_draw_text


printer_draw_text

(no version information, might be only in CVS)

printer_draw_text -- Draw text

Description

void printer_draw_text ( resource printer_handle, string text, int x, int y)

The function simply draws text at position x, y using the selected font. printer_handle must be a valid handle to a printer.

예 1. printer_draw_text() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$font = printer_create_font("Arial", 72, 48, 400, false, false, false, 0);
printer_select_font($handle, $font);
printer_draw_text($handle, "test", 10, 10);
printer_delete_font($font);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

이전 | 처음으로 | 다음
printer_draw_roundrect | 위로 | printer_end_doc


printer_end_doc

(no version information, might be only in CVS)

printer_end_doc -- Close document

Description

bool printer_end_doc ( resource handle)

Closes a new document in the printer spooler. The document is now ready for printing. For an example see printer_start_doc(). handle must be a valid handle to a printer.

이전 | 처음으로 | 다음
printer_draw_text | 위로 | printer_end_page


printer_end_page

(no version information, might be only in CVS)

printer_end_page -- Close active page

Description

bool printer_end_page ( resource handle)

The function closes the active page in the active document. For an example see printer_start_doc(). handle must be a valid handle to a printer.

이전 | 처음으로 | 다음
printer_end_doc | 위로 | printer_get_option


printer_get_option

(no version information, might be only in CVS)

printer_get_option -- Retrieve printer configuration data

Description

mixed printer_get_option ( resource handle, string option)

The function retrieves the configuration setting of option. handle must be a valid handle to a printer. Take a look at printer_set_option() for the settings that can be retrieved, additionally the following settings can be retrieved:

  • PRINTER_DEVICENAME returns the devicename of the printer.

  • PRINTER_DRIVERVERSION returns the printer driver version.

예 1. printer_get_option() example

<?php
$handle = printer_open();
echo printer_get_option($handle, PRINTER_DRIVERVERSION);
printer_close($handle);
?>

이전 | 처음으로 | 다음
printer_end_page | 위로 | printer_list


printer_list

(no version information, might be only in CVS)

printer_list -- Return an array of printers attached to the server

Description

array printer_list ( int enumtype [, string name [, int level]])

The function enumerates available printers and their capabilities. level sets the level of information request. Can be 1,2,4 or 5. enumtype must be one of the following predefined constants:

  • PRINTER_ENUM_LOCAL: enumerates the locally installed printers.

  • PRINTER_ENUM_NAME: enumerates the printer of name, can be a server, domain or print provider.

  • PRINTER_ENUM_SHARED: this parameter can't be used alone, it has to be OR'ed with other parameters, i.e. PRINTER_ENUM_LOCAL to detect the locally shared printers.

  • PRINTER_ENUM_DEFAULT: (Win9.x only) enumerates the default printer.

  • PRINTER_ENUM_CONNECTIONS: (WinNT/2000 only) enumerates the printers to which the user has made connections.

  • PRINTER_ENUM_NETWORK: (WinNT/2000 only) enumerates network printers in the computer's domain. Only valid if level is 1.

  • PRINTER_ENUM_REMOTE: (WinNT/2000 only) enumerates network printers and print servers in the computer's domain. Only valid if level is 1.

예 1. printer_list() example

<?php
/* detect locally shared printer */
var_dump(printer_list(PRINTER_ENUM_LOCAL | PRINTER_ENUM_SHARED));
?>

이전 | 처음으로 | 다음
printer_get_option | 위로 | printer_logical_fontheight


printer_logical_fontheight

(no version information, might be only in CVS)

printer_logical_fontheight -- Get logical font height

Description

int printer_logical_fontheight ( resource handle, int height)

The function calculates the logical font height of height. handle must be a valid handle to a printer.

예 1. printer_logical_fontheight() example

<?php
$handle = printer_open();
echo printer_logical_fontheight($handle, 72);
printer_close($handle);
?>

이전 | 처음으로 | 다음
printer_list | 위로 | printer_open


printer_open

(no version information, might be only in CVS)

printer_open -- Open connection to a printer

Description

mixed printer_open ( [string devicename])

This function tries to open a connection to the printer devicename, and returns a handle on success or FALSE on failure.

If no parameter was given it tries to open a connection to the default printer (if not specified in php.ini as printer.default_printer, PHP tries to detect it).

printer_open() also starts a device context.

예 1. printer_open() example

<?php
$handle = printer_open("HP Deskjet 930c");
$handle = printer_open();
?>

이전 | 처음으로 | 다음
printer_logical_fontheight | 위로 | printer_select_brush


printer_select_brush

(no version information, might be only in CVS)

printer_select_brush -- Select a brush

Description

void printer_select_brush ( resource printer_handle, resource brush_handle)

The function selects a brush as the active drawing object of the actual device context. A brush is used to fill shapes. If you draw an rectangle the brush is used to draw the shapes, while the pen is used to draw the border. If you haven't selected a brush before drawing shapes, the shape won't be filled. printer_handle must be a valid handle to a printer. brush_handle must be a valid handle to a brush.

예 1. printer_select_brush() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 2, "000000");
printer_select_pen($handle, $pen);
$brush = printer_create_brush(PRINTER_BRUSH_CUSTOM, "c:\\brush.bmp");
printer_select_brush($handle, $brush);

printer_draw_rectangle($handle, 1, 1, 500, 500);

printer_delete_brush($brush);

$brush = printer_create_brush(PRINTER_BRUSH_SOLID, "000000");
printer_select_brush($handle, $brush);
printer_draw_rectangle($handle, 1, 501, 500, 1001);
printer_delete_brush($brush);

printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

이전 | 처음으로 | 다음
printer_open | 위로 | printer_select_font


printer_select_font

(no version information, might be only in CVS)

printer_select_font -- Select a font

Description

void printer_select_font ( resource printer_handle, resource font_handle)

The function selects a font to draw text. printer_handle must be a valid handle to a printer. font_handle must be a valid handle to a font.

예 1. printer_select_font() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$font = printer_create_font("Arial", 148, 76, PRINTER_FW_MEDIUM, false, false, false, -50);
printer_select_font($handle, $font);
printer_draw_text($handle, "PHP is simply cool", 40, 40);
printer_delete_font($font);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

이전 | 처음으로 | 다음
printer_select_brush | 위로 | printer_select_pen


printer_select_pen

(no version information, might be only in CVS)

printer_select_pen -- Select a pen

Description

void printer_select_pen ( resource printer_handle, resource pen_handle)

The function selects a pen as the active drawing object of the actual device context. A pen is used to draw lines and curves. I.e. if you draw a single line the pen is used. If you draw an rectangle the pen is used to draw the borders, while the brush is used to fill the shape. If you haven't selected a pen before drawing shapes, the shape won't be outlined. printer_handle must be a valid handle to a printer. pen_handle must be a valid handle to a pen.

예 1. printer_select_pen() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 30, "2222FF");
printer_select_pen($handle, $pen);

printer_draw_line($handle, 1, 60, 500, 60);

printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

이전 | 처음으로 | 다음
printer_select_font | 위로 | printer_set_option


printer_set_option

(no version information, might be only in CVS)

printer_set_option -- Configure the printer connection

Description

bool printer_set_option ( resource handle, int option, mixed value)

The function sets the following options for the current connection. handle must be a valid handle to a printer. For option can be one of the following constants:

  • PRINTER_COPIES: sets how many copies should be printed, value must be an integer.

  • PRINTER_MODE: specifies the type of data (text, raw or emf), value must be a string.

  • PRINTER_TITLE: specifies the name of the document, value must be a string.

  • PRINTER_ORIENTATION: specifies the orientation of the paper, value can be either PRINTER_ORIENTATION_PORTRAIT or PRINTER_ORIENTATION_LANDSCAPE

  • PRINTER_RESOLUTION_Y: specifies the y-resolution in DPI, value must be an integer.

  • PRINTER_RESOLUTION_X: specifies the x-resolution in DPI, value must be an integer.

  • PRINTER_PAPER_FORMAT: specifies the a predefined paper format, set value to PRINTER_FORMAT_CUSTOM if you want to specify a custom format with PRINTER_PAPER_WIDTH and PRINTER_PAPER_LENGTH. value can be one of the following constants.

    • PRINTER_FORMAT_CUSTOM: let's you specify a custom paper format.

    • PRINTER_FORMAT_LETTER: specifies standard letter format (8 1/2- by 11-inches).

    • PRINTER_FORMAT_LETTER: specifies standard legal format (8 1/2- by 14-inches).

    • PRINTER_FORMAT_A3: specifies standard A3 format (297- by 420-millimeters).

    • PRINTER_FORMAT_A4: specifies standard A4 format (210- by 297-millimeters).

    • PRINTER_FORMAT_A5: specifies standard A5 format (148- by 210-millimeters).

    • PRINTER_FORMAT_B4: specifies standard B4 format (250- by 354-millimeters).

    • PRINTER_FORMAT_B5: specifies standard B5 format (182- by 257-millimeter).

    • PRINTER_FORMAT_FOLIO: specifies standard FOLIO format (8 1/2- by 13-inch).

  • PRINTER_PAPER_LENGTH: if PRINTER_PAPER_FORMAT is set to PRINTER_FORMAT_CUSTOM, PRINTER_PAPER_LENGTH specifies a custom paper length in mm, value must be an integer.

  • PRINTER_PAPER_WIDTH: if PRINTER_PAPER_FORMAT is set to PRINTER_FORMAT_CUSTOM, PRINTER_PAPER_WIDTH specifies a custom paper width in mm, value must be an integer.

  • PRINTER_SCALE: specifies the factor by which the printed output is to be scaled. the page size is scaled from the physical page size by a factor of scale/100. for example if you set the scale to 50, the output would be half of its original size. value must be an integer.

  • PRINTER_BACKGROUND_COLOR: specifies the background color for the actual device context, value must be a string containing the rgb information in hex format i.e. "005533".

  • PRINTER_TEXT_COLOR: specifies the text color for the actual device context, value must be a string containing the rgb information in hex format i.e. "005533".

  • PRINTER_TEXT_ALIGN: specifies the text alignment for the actual device context, value can be combined through OR'ing the following constants:

    • PRINTER_TA_BASELINE: text will be aligned at the base line.

    • PRINTER_TA_BOTTOM: text will be aligned at the bottom.

    • PRINTER_TA_TOP: text will be aligned at the top.

    • PRINTER_TA_CENTER: text will be aligned at the center.

    • PRINTER_TA_LEFT: text will be aligned at the left.

    • PRINTER_TA_RIGHT: text will be aligned at the right.

예 1. printer_set_option() example

<?php
$handle = printer_open();
printer_set_option($handle, PRINTER_SCALE, 75);
printer_set_option($handle, PRINTER_TEXT_ALIGN, PRINTER_TA_LEFT);
printer_close($handle);
?>

이전 | 처음으로 | 다음
printer_select_pen | 위로 | printer_start_doc


printer_start_doc

(no version information, might be only in CVS)

printer_start_doc -- Start a new document

Description

bool printer_start_doc ( resource handle [, string document])

The function creates a new document in the printer spooler. A document can contain multiple pages, it's used to schedule the print job in the spooler. handle must be a valid handle to a printer. The optional parameter document can be used to set an alternative document name.

예 1. printer_start_doc() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

이전 | 처음으로 | 다음
printer_set_option | 위로 | printer_start_page


printer_start_page

(no version information, might be only in CVS)

printer_start_page -- Start a new page

Description

bool printer_start_page ( resource handle)

The function creates a new page in the active document. For an example see printer_start_doc(). handle must be a valid handle to a printer.

이전 | 처음으로 | 다음
printer_start_doc | 위로 | printer_write


printer_write

(no version information, might be only in CVS)

printer_write -- Write data to the printer

Description

bool printer_write ( resource handle, string content)

Writes content directly to the printer. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

handle must be a valid handle to a printer.

예 1. printer_write() example

<?php
$handle = printer_open();
printer_write($handle, "Text to print");
printer_close($handle);
?>

이전 | 처음으로 | 다음
printer_start_page | 위로 | Pspell 함수


Pspell 함수

PHP 매뉴얼
이전 다음

LXXXVIII. Pspell 함수

이 함수는 단어의 철자를 검사하고 추천하는 단어를 제시합니다.

이 함수를 사용하기 위해서는 aspell 라이브러리와 pspell 라이브러리가 필요합니다. 각각 http://aspell.sourceforge.net/ 와 http://aspell.net/ 에서 다운로드 할 수 있습니다. 그리고 PHP 컴파일시 --with-pspell[=dir] 옵션을 추가해야합니다.

차례
pspell_add_to_personal -- 사용자 단어목록에 단어 추가
pspell_add_to_session -- 현재 세션의 단어목록에 단어 추가
pspell_check -- 단어 검사
pspell_clear_session -- 현재 연결된 세션 제거
pspell_config_create -- 사전을 열때 사용할 설정을 생성
pspell_config_ignore -- 문자의 길이가 n보다 작은 단어는 무시
pspell_config_mode -- 반환되는 추천단어의 수를 결정하는 실행모드 변경
pspell_config_personal -- 사용자 단어목록을 저장하고 있는 파일 지정
pspell_config_repl -- 교정내용을 포함하고 있는 파일을 지정
pspell_config_runtogether -- 연결되는 단어를 정당한 합성어로 고려
pspell_config_save_repl -- 교정내용목록을 단어목록과 같이 저장할지를 결정
pspell_new_config -- 주어진 설정으로 새 사전 열기
pspell_new_personal -- 사용자 단어목록으로 새 사전 열기
pspell_new -- 새 사전 열기
pspell_save_wordlist -- 사용자 단어목록을 파일로 저장
pspell_store_replacement -- 단어 교정목록을 저장
pspell_suggest -- 단어의 철자 제안

이전 | 처음으로 | 다음
printer_write | 위로 | pspell_add_to_personal


pspell_add_to_personal

(PHP 4 >= 4.0.2, PHP 5)

pspell_add_to_personal -- 사용자 단어목록에 단어 추가

설명

int pspell_add_to_personal ( int dictionary_link, string word)

pspell_add_to_personal() 함수는 사용자 단어목록에 단어를 추가합니다. 만약 사전을 열때pspell_new_config() 함수와 pspell_config_personal() 함수를 사용하면 나중에 pspell_save_wordlist()함수를 사용해서 단어목록을 저장할 수 있습니다. 이 함수는 pspell .11.2와 aspell .32.5 또는 이후의 버전에서만 실행됩니다.

예 1. pspell_add_to_personal()

$pspell_config = pspell_config_create ("en");
pspell_config_personal ($pspell_config, "/var/dictionaries/custom.pws");
$pspell_link = pspell_new_config ($pspell_config);

pspell_add_to_personal ($pspell_link, "Vlad");
pspell_save_wordlist ($pspell_link);

이전 | 처음으로 | 다음
Pspell 함수 | 위로 | pspell_add_to_session


pspell_add_to_session

(PHP 4 >= 4.0.2, PHP 5)

pspell_add_to_session -- 현재 세션의 단어목록에 단어 추가

설명

int pspell_add_to_session ( int dictionary_link, string word)

pspell_add_to_session() 함수는 현재 세션의 단어목록에 단어를 추가합니다. 이것은 pspell_add_to_personal()함수와 매우 비슷합니다

이전 | 처음으로 | 다음
pspell_add_to_personal | 위로 | pspell_check


pspell_check

(PHP 4 >= 4.0.2, PHP 5)

pspell_check -- 단어 검사

설명

boolean pspell_check ( int dictionary_link, string word)

pspell_check() 함수는 단어의 철자를 검사하고 올바를 경우 TRUE, 틀릴경우 FALSE를 반환합니다.

예 1. pspell_check()

$pspell_link = pspell_new ("en");

if (pspell_check ($pspell_link, "testt")) {
    echo "This is a valid spelling";
} else {
    echo "Sorry, wrong spelling";
}

이전 | 처음으로 | 다음
pspell_add_to_session | 위로 | pspell_clear_session


pspell_clear_session

(PHP 4 >= 4.0.2, PHP 5)

pspell_clear_session -- 현재 연결된 세션 제거

설명

int pspell_clear_session ( int dictionary_link)

pspell_clear_session()함수는 현재 연결된 세션을 제거합니다. 현재 단어목록은 비워집니다. 예를들어 pspell_save_wordlist()함수를 사용해서 단어목록에 저장할려고 하면 아무일도 생기지 않습니다.

예 1. pspell_add_to_personal()

$pspell_config = pspell_config_create ("en");
pspell_config_personal ($pspell_config, "/var/dictionaries/custom.pws");
$pspell_link = pspell_new_config ($pspell_config);

pspell_add_to_personal ($pspell_link, "Vlad");
pspell_clear_session ($pspell_link);
pspell_save_wordlist ($pspell_link);    //"Vlad" will not be saved

이전 | 처음으로 | 다음
pspell_check | 위로 | pspell_config_create


pspell_config_create

(PHP 4 >= 4.0.2, PHP 5)

pspell_config_create -- 사전을 열때 사용할 설정을 생성

설명

int pspell_config_create ( string language [, string spelling [, string jargon [, string encoding]]])

pspell_config_create() 함수는 pspell_new()함수와 매우비슷한 문법입니다. 사실 pspell_new_config()함수를 사용한 이후에 pspell_config_create()함수를 사용하게 되면 동일한 결과를 나타낼 것입니다. 향상된 기능을 사용하기 위해서는 새로운 설정을 만들었더라도 pspell_new_config() 함수를 호출하기 전에 pspell_config_*() 함수를 사용해야 합니다.

language 파라미터는 두자로 된 ISO 639 언어 코드입니다. 선택적으로 ISO 639 언어 코드 이후 '-' 나 '_' 를 적고 두자로 된 ISO 3166 국가코드를 추가할 수 있습니다.

spelling 파라미터는 English 와 같이 한 철자 이상의 철자가 있는 언어에 대해 철자를 지정합니다. English 의 경우 알려진 값에는 'american', 'british', and 'canadian' 가 있습니다.

jargon 파라미터는 동일한 language와 spelling 파라미터를 가지고 있는 두 다른 단어 목록을 구별하기 위한 추가정보입니다.

encoding 파라미터는 단어의 인코딩 정보입니다. 가능한 값에는 'utf-8', 'iso8859-*', 'koi8-r', 'viscii', 'cp1252', 'machine unsigned 16', 'machine unsigned 32' 가 있습니다. 이 파라미터는 거의 테스트되지 않았으니, 사용할 때 주의하세요.

mode 파라미터는 단어검사기의 실행모드입니다. 아래에 몇가지 가능한 모드가 있습니다.

  • PSPELL_FAST - 빠른 실행모드 (최소한의 추천단어)

  • PSPELL_NORMAL - 보통 실행모드 (더 많은 추천단어)

  • PSPELL_BAD_SPELLERS - 느린 실행모드 (가장많은 추천단어)

자세한 정보와 예제는 pspell 웹사이트(http://aspell.net/)의 매뉴얼을 참고하세요.

예 1. pspell_config_create()

$pspell_config = pspell_config_create ("en");
pspell_config_personal ($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl ($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_personal (pspell_config);

이전 | 처음으로 | 다음
pspell_clear_session | 위로 | pspell_config_ignore


pspell_config_ignore

(PHP 4 >= 4.0.2, PHP 5)

pspell_config_ignore -- 문자의 길이가 n보다 작은 단어는 무시

설명

int pspell_config_ignore ( int dictionary_link, int n)

pspell_config_ignore() 함수는pspell_new_config()함수를 호출하기 전에 설정되어야 합니다. 이 함수는 문자길이가 n보다 작은 단어는 검사하지 않고 무시합니다.

예 1. pspell_config_ignore()

$pspell_config = pspell_config_create ("en");
pspell_config_ignore($pspell_config, 5);
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "abcd");    //will not result in an error

이전 | 처음으로 | 다음
pspell_config_create | 위로 | pspell_config_mode


pspell_config_mode

(PHP 4 >= 4.0.2, PHP 5)

pspell_config_mode -- 반환되는 추천단어의 수를 결정하는 실행모드 변경

설명

int pspell_config_mode ( int dictionary_link, int mode)

pspell_config_mode()함수는 pspell_new_config()함수를 호출하기 전에 설정되어야 합니다. 이 함수는 pspell_suggest()함수에 의해 반환되는 추천 단어의 수를 결정합니다.

mode 파라미터는 단어검사기의 실행모드입니다. 아래에 몇가지 가능한 모드가 있습니다.

  • PSPELL_FAST - 빠른 실행모드 (최소한의 추천단어)

  • PSPELL_NORMAL - 보통 실행모드 (더 많은 추천단어)

  • PSPELL_BAD_SPELLERS - 느린 실행모드 (가장많은 추천단어)

예 1. pspell_config_mode()

$pspell_config = pspell_config_create ("en");
pspell_config_mode($pspell_config, PSPELL_FAST);
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "thecat");

이전 | 처음으로 | 다음
pspell_config_ignore | 위로 | pspell_config_personal


pspell_config_personal

(PHP 4 >= 4.0.2, PHP 5)

pspell_config_personal -- 사용자 단어목록을 저장하고 있는 파일 지정

설명

int pspell_config_personal ( int dictionary_link, string file)

pspell_config_personal()는pspell_new_config()함수를 호출하기 전에 설정되어야 합니다. 사용자 단어목록은 읽혀지고 pspell_new_config()함수를 호출한 후에 표준 단어목록에 추가적으로 사용됩니다. 파일이 존재하지 않을경우 생성됩니다. 파일은 pspell_save_wordlist()함수에서 사용자 단어목록을 저장하는 파일이기도 합니다. 파일은 PHP 실행 사용자(예, nobody) 가 쓰기가능한 모드로 되어있어야 합니다. 이 함수는 pspell .11.2와 aspell .32.5 또는 이후의 버전에서만 실행됩니다.

예 1. pspell_config_personal()

$pspell_config = pspell_config_create ("en");
pspell_config_personal ($pspell_config, "/var/dictionaries/custom.pws");
$pspell_link = pspell_new_config ($pspell_config);
pspell_check ($pspell_link, "thecat");

이전 | 처음으로 | 다음
pspell_config_mode | 위로 | pspell_config_repl


pspell_config_repl

(PHP 4 >= 4.0.2, PHP 5)

pspell_config_repl -- 교정내용을 포함하고 있는 파일을 지정

설명

int pspell_config_repl ( int dictionary_link, string file)

pspell_config_repl()함수는 pspell_new_config()함수를 호출하기 전에 설정되어야 합니다. 교정내용은 단어검사기의 질적 성능을 향상시킵니다. 단어의 철자가 틀리고 목록에서 적당한 추천단어를 찾지 못했을 경우,pspell_store_replacement()함수는 교정목록을 저장하고 pspell_save_wordlist()함수는 교정목록을 포함한 단어목록을 저장하는데 사용할 수 있습니다. 파일은 PHP 실행 사용자(예, nobody)가 쓰기 가능한 모드로 되어 있어야 합니다. 이 함수는 pspell .11.2와 aspell .32.5 또는 이후의 버전에서만 실행됩니다.

예 1. pspell_config_repl()

$pspell_config = pspell_config_create ("en");
pspell_config_personal ($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl ($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_config ($pspell_config);
pspell_check ($pspell_link, "thecat");

이전 | 처음으로 | 다음
pspell_config_personal | 위로 | pspell_config_runtogether


pspell_config_runtogether

(PHP 4 >= 4.0.2, PHP 5)

pspell_config_runtogether -- 연결되는 단어를 정당한 합성어로 고려

설명

int pspell_config_runtogether ( int dictionary_link, boolean flag)

pspell_config_runtogether()함수는 pspell_new_config()함수를 호출하기 전에 설정되어야 합니다. 이 함수는 연결된 단어를 정당한 합성어로 고려할지를 결정합니다. 즉, 말하자면 두 단어 사이에 공백(space)이 있어야 할지라도 "thecat"은 정당한 합성어가 됩니다. 이 설정을 바꾸면 pspell_check()함수에 의해 반환되는 결과값에만 영향을 미칩니다. pspell_suggest()함수는 여전히 추천단어를 반환합니다.

예 1. pspell_config_runtogether()

$pspell_config = pspell_config_create ("en");
pspell_config_runtogether ($pspell_config, true);
$pspell_link = pspell_new_config ($pspell_config);
pspell_check ($pspell_link, "thecat");

이전 | 처음으로 | 다음
pspell_config_repl | 위로 | pspell_config_save_repl


pspell_config_save_repl

(PHP 4 >= 4.0.2, PHP 5)

pspell_config_save_repl -- 교정내용목록을 단어목록과 같이 저장할지를 결정

설명

int pspell_config_save_repl ( int dictionary_link, boolean flag)

pspell_config_save_repl()함수는 pspell_new_config()함수를 호출하기 전에 설정되어야 합니다. 이 함수는pspell_save_wordlist()함수가 교정내용목록을 단어목록과 같이 저장할지를 결정합니다. 일반적으로 이 함수는 사용할 필요가 없습니다. 만약pspell_config_repl()함수를 사용했을 경우, 교정내용은 pspell_save_wordlist()함수에 의해 자동으로 저장이 되기 때문입니다. 만약 pspell_config_repl()함수를 사용하지 않았을경우 교정내용은 저장되지 않습니다. 이 함수는 pspell .11.2와 aspell .32.5 또는 이후의 버전에서만 실행됩니다.

이전 | 처음으로 | 다음
pspell_config_runtogether | 위로 | pspell_new_config


pspell_new_config

(PHP 4 >= 4.0.2, PHP 5)

pspell_new_config -- 주어진 설정으로 새 사전 열기

설명

int pspell_new_config ( int config)

pspell_new_config()함수는 pspell_config_create()함수에 의해서 생성되고, pspell_config_*()함수로 수정된 설정을 사용해서 새 사전을 엽니다. 이 방법은 가장 융통성이 있고,pspell_new()함수와 pspell_new_personal()함수에 의해 제공되는 모든 기능을 을 제공합니다.

config 파라미터는 설정이 생성될 때 pspell_config_create()함수에 의해 반환되는 것입니다.

예 1. pspell_new_config()

$pspell_config = pspell_config_create ("en");
pspell_config_personal ($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl ($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_personal (pspell_config);

이전 | 처음으로 | 다음
pspell_config_save_repl | 위로 | pspell_new_personal


pspell_new_personal

(PHP 4 >= 4.0.2, PHP 5)

pspell_new_personal -- 사용자 단어목록으로 새 사전 열기

설명

int pspell_new_personal ( string personal, string language [, string spelling [, string jargon [, string encoding [, int mode]]]])

pspell_new_personal()함수는 사용자 단어목록으로 새 사전을 열고 다른 pspell 함수에서
 사용하기위한 사전열기 identifier를 반환합니다. 원할경우, 단어목록은
pspell_save_wordlist()함수에 의해 수정되고 저장될수 있습니다.
 교정목록이 저장되지 않았더라도, 교정목록을 저장하기 위해서는
pspell_config_create()함수를 사용해서 설정을 생성하고,
pspell_config_personal()함수를 사용해서 사용자 단어목록파일을 지정하고,
pspell_config_repl()함수를 사용해서 교정목록파일을 지정하고,
pspell_new_config()함수를 사용해서 새 사전을 열어야만 합니다.

personal 파라미터는 단어가 추가되고 저장될 사용자 단어목록 파일을 지정합니다. personal 파라미터는 "/"로 시작하는 절대경로 파일명이어야 합니다. 왜냐하면 그렇지 않을 경우 거의 모든 시스템에서 $HOME의 경로인 "/root"로 부터 상대경로가 됩니다. 그것은 아마도 당신이 원하는 경로가 아닐 것입니다.

language 파라미터는 두자로 된 ISO 639 language 코드입니다. 선택적으로 ISO 639 language 코드 이후 '-' 나 '_' 를 적고 두자로 된 ISO 3166 국가코드를 추가 할 수 있습니다.

spelling 파라미터는 English 와 같이 한 철자 이상의 철자가 있는 언어에 대해 철자를 지정합니다. English 의 경우 알려진 값에는 'american', 'british', and 'canadian' 가 있습니다.

jargon 파라미터는 동일한 language와 spelling 파라미터를 가지고 있는 두 다른 단어 목록을 구별하기 위한 추가정보입니다.

encoding 파라미터는 단어의 인코딩 정보입니다. 가능한 값에는 'utf-8', 'iso8859-*', 'koi8-r', 'viscii', 'cp1252', 'machine unsigned 16', 'machine unsigned 32' 가 있습니다. 이 파라미터는 거의 테스트되지 않았으니, 사용할 때 주의하세요.

mode 파라미터는 단어검사기의 실행모드입니다. 아래에 몇가지 가능한 모드가 있습니다.

  • PSPELL_FAST - 빠른 실행모드 (최소한의 추천단어)

  • PSPELL_NORMAL - 보통 실행모드 (더 많은 추천단어)

  • PSPELL_BAD_SPELLERS - 느린 실행모드 (가장많은 추천단어)

  • PSPELL_RUN_TOGETHER - 연결된 단어를 정당한 합성어로 고려할지를 결정합니다. 즉, 말하자면 두 단어 사이에 공백(space)이 있어야 할지라도 "thecat"은 정당한 합성어가 됩니다. 이 설정을 바꾸면 pspell_check()함수에 의해 반환되는 결과값에만 영향을 미칩니다. pspell_suggest()함수는 여전히 추천단어를 반환합니다.

모드는 위에 나열된 서로 다른 상수로 구성된 bitmask 입니다. PSPELL_FAST, PSPELL_NORMAL, PSPELL_BAD_SPELLERS 이 서로 배타적일지라도, 이것들중에 하나만을 선택해야합니다.

자세한 정보와 예제는 pspell 웹사이트(http://aspell.net/)의 매뉴얼을 참고하세요.

예 1. pspell_new_personal()

$pspell_link = pspell_new_personal ("/var/dictionaries/custom.pws",
        "en", "", "", "", PSPELL_FAST|PSPELL_RUN_TOGETHER));

이전 | 처음으로 | 다음
pspell_new_config | 위로 | pspell_new


pspell_new

(PHP 4 >= 4.0.2, PHP 5)

pspell_new -- 새 사전 열기

설명

int pspell_new ( string language [, string spelling [, string jargon [, string encoding [, int mode]]]])

pspell_new()함수는 새 사전을 열고 다른 pspell함수에서 사용할수 있도록 사전 연결 identifier를 반환합니다.

language 파라미터는 두자로 된 ISO 639 언어 코드입니다. 선택적으로 ISO 639 언어 코드 이후 '-' 나 '_' 를 적고 두자로 된 ISO 3166 국가코드를 추가할 수 있습니다.

spelling 파라미터는 English 와 같이 한 철자 이상의 철자가 있는 언어에 대해 철자를 지정합니다. English 의 경우 알려진 값에는 'american', 'british', and 'canadian' 가 있습니다.

jargon 파라미터는 동일한 language와 spelling 파라미터를 가지고 있는 두 다른 단어 목록을 구별하기 위한 추가정보입니다.

encoding 파라미터는 단어의 인코딩 정보입니다. 가능한 값에는 'utf-8', 'iso8859-*', 'koi8-r', 'viscii', 'cp1252', 'machine unsigned 16', 'machine unsigned 32' 가 있습니다. 이 파라미터는 거의 테스트되지 않았으니, 사용할 때 주의하세요.

mode 파라미터는 단어검사기의 실행모드입니다. 아래에 몇가지 가능한 모드가 있습니다.

  • PSPELL_FAST - 빠른 실행모드 (최소한의 추천단어)

  • PSPELL_NORMAL - 보통 실행모드 (더 많은 추천단어)

  • PSPELL_BAD_SPELLERS - 느린 실행모드 (가장많은 추천단어)

  • PSPELL_RUN_TOGETHER - 연결된 단어를 정당한 합성어로 고려할지를 결정합니다. 즉, 말하자면 두 단어 사이에 공백(space)이 있어야 할지라도 "thecat"은 정당한 합성어가 됩니다. 이 설정을 바꾸면 pspell_check()함수에 의해 반환되는 결과값에만 영향을 미칩니다.; pspell_suggest()함수는 여전히 추천단어를 반환합니다.

모드는 위에 나열된 서로 다른 상수로 구성된 bitmask 입니다. PSPELL_FAST, PSPELL_NORMAL, PSPELL_BAD_SPELLERS 이 서로 배타적일지라도, 이것들중에 하나만을 선택해야합니다.

자세한 정보와 예제는 pspell 웹사이트(http://aspell.net/)의 매뉴얼을 참고하세요.

예 1. pspell_new()

$pspell_link = pspell_new ("en", "", "", "",
                           (PSPELL_FAST|PSPELL_RUN_TOGETHER));

이전 | 처음으로 | 다음
pspell_new_personal | 위로 | pspell_save_wordlist


pspell_save_wordlist

(PHP 4 >= 4.0.2, PHP 5)

pspell_save_wordlist -- 사용자 단어목록을 파일로 저장

설명

int pspell_save_wordlist ( int dictionary_link)

pspell_save_wordlist()함수는 현재 세션의 사용자 단어목록을 저장합니다.
 사전은 pspell_new_personal()함수를 사용해서 열고, 저장된
파일의 위치는 pspell_config_personal()함수를 사용해서 지정되어야 하고,
선택적으로pspell_config_repl()함수를 사용할수 있습니다.
이 함수는 pspell .11.2와 aspell .32.5 또는 이후의 버전에서만 실행됩니다.

예 1. pspell_add_to_personal()

$pspell_config = pspell_config_create ("en");
pspell_config_personal ($pspell_config, "/tmp/dicts/newdict");
$pspell_link = pspell_new_config ($pspell_config);

pspell_add_to_personal ($pspell_link, "Vlad");
pspell_save_wordlist ($pspell_link);

이전 | 처음으로 | 다음
pspell_new | 위로 | pspell_store_replacement


pspell_store_replacement

(PHP 4 >= 4.0.2, PHP 5)

pspell_store_replacement -- 단어 교정목록을 저장

설명

int pspell_store_replacement ( int dictionary_link, string misspelled, string correct)

pspell_store_replacement()함수는 단어의 교정목록을 저장합니다. 나중에 pspell_suggest()함수를 사용해서 교정내용을 반환할 수 있습니다. 이 함수를 사용할 수 있게 하기 위해서 사전을 열때 pspell_new_personal()함수를 사용해야 합니다. 교정목록을 영구적으로 저장하기위해서는 pspell_config_personal()함수와 pspell_config_repl()함수를 사용해서 사용자 단어목록을 저장할 경로를 지정해야 합니다. 그리고 변경된 것을 디스크에 저장하기 위해pspell_save_wordlist() 함수를 사용해야 합니다. 이 함수는 pspell .11.2와 aspell .32.5 또는 이후의 버전에서만 실행됩니다.

예 1. pspell_store_replacement()

$pspell_config = pspell_config_create ("en");
pspell_config_personal ($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl ($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_config ($pspell_config);

pspell_store_replacement ($pspell_link, $misspelled, $correct);
pspell_save_wordlist ($pspell_link);

이전 | 처음으로 | 다음
pspell_save_wordlist | 위로 | pspell_suggest


pspell_suggest

(PHP 4 >= 4.0.2, PHP 5)

pspell_suggest -- 단어의 철자 제안

설명

array pspell_suggest ( int dictionary_link, string word)

pspell_suggest()함수는 주어진 단어에 대한 가능한 철자를 배열형으로 반환합니다.

예 1. pspell_suggest()

$pspell_link = pspell_new ("en");

if (!pspell_check ($pspell_link, "testt")) {
    $suggestions = pspell_suggest ($pspell_link, "testt");

    for ($i=0; $i < count ($suggestions); $i++) {
        echo "Possible spelling: " . $suggestions[$i] . "<br>";
    }
}

이전 | 처음으로 | 다음
pspell_store_replacement | 위로 | GNU Readline


GNU Readline

PHP 매뉴얼
이전 다음

LXXXIX. GNU Readline

소개

The readline() functions implement an interface to the GNU Readline library. These are functions that provide editable command lines. An example being the way Bash allows you to use the arrow keys to insert characters or scroll through command history. Because of the interactive nature of this library, it will be of little use for writing Web applications, but may be useful when writing scripts meant using PHP from the command line.

참고: 이 확장 모듈은 윈도우 플랫폼에서는 사용할 수 없습니다.

요구 사항

To use the readline functions, you need to install libreadline. You can find libreadline on the home page of the GNU Readline project, at http://cnswww.cns.cwru.edu/~chet/readline/rltop.html. It's maintained by Chet Ramey, who's also the author of Bash.

You can also use this functions with the libedit library, a non-GPL replacement for the readline library. The libedit library is BSD licensed and available for download from http://sourceforge.net/projects/libedit/.

설치

To use this functions you must compile the CGI or CLI version of PHP with readline support. You need to configure PHP --with-readline[=DIR]. In order you want to use the libedit readline replacement, configure PHP --with-libedit[=DIR].

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
readline_add_history -- Adds a line to the history
readline_clear_history -- Clears the history
readline_completion_function -- Registers a completion function
readline_info -- Gets/sets various internal readline variables
readline_list_history -- Lists the history
readline_read_history -- Reads the history
readline_write_history -- Writes the history
readline -- Reads a line

이전 | 처음으로 | 다음
pspell_suggest | 위로 | readline_add_history


readline_add_history

(PHP 4 , PHP 5)

readline_add_history -- Adds a line to the history

Description

void readline_add_history ( string line)

This function adds a line to the command line history.

이전 | 처음으로 | 다음
GNU Readline | 위로 | readline_clear_history


readline_clear_history

(PHP 4 , PHP 5)

readline_clear_history -- Clears the history

Description

bool readline_clear_history ( void )

This function clears the entire command line history.

이전 | 처음으로 | 다음
readline_add_history | 위로 | readline_completion_function


readline_completion_function

(PHP 4 , PHP 5)

readline_completion_function -- Registers a completion function

Description

bool readline_completion_function ( string line)

This function registers a completion function. You must supply the name of an existing function which accepts a partial command line and returns an array of possible matches. This is the same kind of functionality you'd get if you hit your tab key while using Bash.

이전 | 처음으로 | 다음
readline_clear_history | 위로 | readline_info


readline_info

(PHP 4 , PHP 5)

readline_info -- Gets/sets various internal readline variables

Description

mixed readline_info ( [string varname [, string newvalue]])

If called with no parameters, this function returns an array of values for all the setting readline uses. The elements will be indexed by the following values: done, end, erase_empty_line, library_version, line_buffer, mark, pending_input, point, prompt, readline_name, and terminal_name.

If called with one parameter, the value of that setting is returned. If called with two parameters, the setting will be changed to the given value.

이전 | 처음으로 | 다음
readline_completion_function | 위로 | readline_list_history


readline_list_history

(PHP 4 , PHP 5)

readline_list_history -- Lists the history

Description

array readline_list_history ( void )

This function returns an array of the entire command line history. The elements are indexed by integers starting at zero.

이전 | 처음으로 | 다음
readline_info | 위로 | readline_read_history


readline_read_history

(PHP 4 , PHP 5)

readline_read_history -- Reads the history

Description

bool readline_read_history ( string filename)

This function reads a command history from a file.

이전 | 처음으로 | 다음
readline_list_history | 위로 | readline_write_history


readline_write_history

(PHP 4 , PHP 5)

readline_write_history -- Writes the history

Description

bool readline_write_history ( string filename)

This function writes the command history to a file.

이전 | 처음으로 | 다음
readline_read_history | 위로 | readline


readline

(PHP 4 , PHP 5)

readline -- Reads a line

Description

string readline ( [string prompt])

This function returns a single string from the user. You may specify a string with which to prompt the user. The line returned has the ending newline removed. You must add this line to the history yourself using readline_add_history().

예 1. readline()

<?php
//get 3 commands from user
for ($i=0; $i < 3; $i++) {
        $line = readline("Command: ");
        readline_add_history($line);
}

//dump history
print_r(readline_list_history());

//dump variables
print_r(readline_info());
?>

이전 | 처음으로 | 다음
readline_write_history | 위로 | GNU Recode Functions


GNU Recode Functions

PHP 매뉴얼
이전 다음

XC. GNU Recode Functions

소개

This module contains an interface to the GNU Recode library. The GNU Recode library converts files between various coded character sets and surface encodings. When this cannot be achieved exactly, it may get rid of the offending characters or fall back on approximations. The library recognises or produces nearly 150 different character sets and is able to convert files between almost any pair. Most RFC 1345 character sets are supported.

참고: 이 확장 모듈은 윈도우 플랫폼에서는 사용할 수 없습니다.

요구 사항

You must have GNU Recode 3.5 or higher installed on your system. You can download the package from http://www.gnu.org/directory/All_GNU_Packages/recode.html.

주의

The Recode library version 3.6 adds weird characters behind converted strings under certain circumstances. Thus it's safer to use Recode v3.5 or one of the available alternatives like the iconv or mbstring extension.

설치

To be able to use the functions defined in this module you must compile your PHP interpreter using the --with-recode[=DIR] option.

주의

Crashes and startup problems of PHP may be encountered when loading the recode as extension after loading any extension of mysql or imap. Loading the recode before those extension has proved to fix the problem. This is due a technical problem that both the c-client library used by imap and recode have their own hash_lookup() function and both mysql and recode have their own hash_insert function.

주의

IMAP 확장 모듈은 recode나 YAZ 확장 모듈과 함께 사용할 수 없습니다. 이들은 같은 내부 심볼을 사용합니다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
recode_file -- Recode from file to file according to recode request
recode_string -- Recode a string according to a recode request
recode -- Alias of recode_string()

이전 | 처음으로 | 다음
readline | 위로 | recode_file


recode_file

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

recode_file -- Recode from file to file according to recode request

Description

bool recode_file ( string request, resource input, resource output)

Recode the file referenced by file handle input into the file referenced by file handle output according to the recode request. Returns FALSE, if unable to comply, TRUE otherwise.

This function does not currently process filehandles referencing remote files (URLs). Both filehandles must refer to local files.

예 1. Basic recode_file() example

<?php
$input = fopen('input.txt', 'r');
$output = fopen('output.txt', 'w');
recode_file("us..flat", $input, $output);
?>

이전 | 처음으로 | 다음
GNU Recode Functions | 위로 | recode_string


recode_string

(PHP 3>= 3.0.13, PHP 4 , PHP 5)

recode_string -- Recode a string according to a recode request

Description

string recode_string ( string request, string string)

Recode the string string according to the recode request request. Returns the recoded string or FALSE, if unable to perform the recode request.

A simple recode request may be "lat1..iso646-de". See also the GNU Recode documentation of your installation for detailed instructions about recode requests.

예 1. Basic recode_string() example:

<?php
echo recode_string("us..flat", "The following character has a diacritical mark: &aacute;");
?>

이전 | 처음으로 | 다음
recode_file | 위로 | recode


recode

recode -- Alias of recode_string()

Description

This function is an alias of recode_string().

이전 | 처음으로 | 다음
recode_string | 위로 | 정규표현식 함수 (펄-호환)


정규표현식 함수 (펄-호환)

PHP 매뉴얼
이전 다음

XCI. 정규표현식 함수 (펄-호환)

소개

이 함수들에서 사용되는 패턴 문법은 펄에 가깝습니다. 표현식은 구분자로 감싸주어야 합니다. 예를 들면, 슬래쉬(/)로 감싸줍니다. 영문자와 숫자, 백슬래쉬(\)를 제외한 어떠한 문자라도 구분자로 사용할 수 있습니다. 구분자가 표현식 안에서 사용될 경우, 백슬래쉬로 이스케이프해야합니다. PHP 4.0.4부터, 펄 형식의 (), {}, [], <> 매칭 구분자를 사용할 수 있습니다. 자세한 설명은 패턴 문법을 참고하십시오.

종료 구분자 뒤에는 매칭에 영향을 주는 여러가지 변경자(midifier)를 쓸 수 있습니다. 패턴 변경자를 참고하십시오.

PHP는 POSIX 확장 정규표현식 함수로 POSIX 확장 문법을 사용하는 정규표현식을 지원합니다.

주의

PCRE의 몇몇 제한에 주의를 해야합니다. 자세한 정보는 http://www.pcre.org/pcre.txt을 참고하십시오.

요구 사항

정규표현식 지원은 Philip Hazel이 작성한 PCRE 라이브러리 패키지에 의해 제공됩니다. 저작권은 University of Cambridge, England에 있습니다. ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/에 존재합니다.

설치

PHP 4.2.0부터 이 함수들은 기본값으로 사용 가능합니다. --without-pcre-regex로 PCRE 함수를 사용하지 않을 수 있습니다. 번들된 라이브러리를 사용하지 않는다면, --with-pcre-regex=DIR을 이용하여 PCRE의 인크루드와 라이브러리 파일이 있는 특정한 디렉토리를 지정하십시오. 이전 버전에서는 이 함수들을 사용하기 위해서는 PHP를 --with-pcre-regex[=DIR]를 주어서 설정하고 컴파일해야합니다.

PHP 윈도우 버전에서는 이 확장 모듈에 대한 지원이 포함되어 있습니다. 이 함수들을 이용하기 위해서 추가로 확장 모듈을 읽어들일 필요가 없습니다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

표 1. PREG 상수

상수 | 설명
PREG_PATTERN_ORDER | $matches[0] 배열은 패턴 전체를 가지고, $matches[1] 배열이 처음 괄호에 들은 서브패턴의 문자열을 가지도록 결과를 지정합니다. 이 플래그는 preg_match_all()에서만 사용합니다.
PREG_SET_ORDER | $matches[0] 배열은 매치된 첫번째 집합을 가지고, $matches[1]는 두번째 집합을 가지도록 결과를 지정합니다. 이 플래그는 preg_match_all()에서만 사용합니다.
PREG_OFFSET_CAPTURE | PREG_SPLIT_OFFSET_CAPTURE의 설명을 보십시오. 이 플래그는 PHP 4.3.0부터 사용할 수 있습니다.
PREG_SPLIT_NO_EMPTY | 이 플래그는 preg_split()가 비어있지 않은 조각만을 반환하게 합니다.
PREG_SPLIT_DELIM_CAPTURE | 이 플래그는 preg_split()가 구분자 안의 괄호로 둘러싸인 표현식도 잡아내게 합니다. PHP 4.0.5부터 사용할 수 있습니다.
PREG_SPLIT_OFFSET_CAPTURE | 이 플래그를 설정하면, 매치하는 모든 문자열 요소의 시작 위치를 함께 반환합니다. 매치된 문자열을 0으로, 문자열 시작 위치를 1로 가지는 배열을 원소로 가지는 배열을 반환합니다. 이 플래그는 PHP 4.3.0부터 사용할 수 있고, preg_split()에서만 사용합니다.

예제

예 1. 유효한 패턴 예제

  • /<\/\w+>/

  • |(\d{3})-\d+|Sm

  • /^(?i)php[34]/

  • {^\s+(\s+)?$}

예 2. 유효하지 않은 패턴 예제

  • /href='(.*)' - 종료 구분자가 없습니다

  • /\w+\s*\w+/J - 알 수 없는 변경자 'J'

  • 1-\d3-\d3-\d4| - 시작 구분자가 없습니다

차례
패턴 변경자 -- 정규표현식 패턴에 존재하는 변경자의 설명
패턴 문법 -- PCRE 정규표현식 문법 설명
preg_grep -- 패턴 매치의 배열을 반환합니다.
preg_match_all -- 전역 정규 표현식 매치를 수행합니다.
preg_match -- 정규표현식 매치를 수행합니다.
preg_quote -- 정규 표현식 문자를 인용합니다.
preg_replace_callback -- 콜백을 이용한 정규 표현식 검색과 치환을 수행합니다.
preg_replace -- 정규 표현식 검색과 치환을 수행합니다.
preg_split -- 정규 표션식에 따라 문자열을 나눕니다.

이전 | 처음으로 | 다음
recode | 위로 | 패턴 변경자


패턴 변경자

패턴 변경자 -- 정규표현식 패턴에 존재하는 변경자의 설명

설명

아래 목록은 현재 존재하는 PCRE 변경자입니다. 괄호 안의 이름은 각 변경자에 대한 PCRE 내부의 이름입니다.

i (PCRE_CASELESS)

이 변경자를 지정하면, 패턴의 문자는 대문자와 소문자를 구별하지 않습니다.

m (PCRE_MULTILINE)

기본적으로, PCRE는 주어진 문자열을 하나의 "줄"로 취급합니다. (실제로 몇개의 라인을 가지더라도) "줄 시작" 메타문자(^)는 문자열의 처음만을 인식하며, "줄 끝" 메타문자($)는 문자열의 끝이나 (D 변경자가 지정되지 않는 한) 마지막 뉴라인의 직전만을 인식합니다. 이는 펄과 같습니다.

이 변경자를 지정하면, "줄 시작"과 "줄 끝"은 주어진 문자열의 모든 뉴라인 직후와 직전을 인식합니다. respectively, as well as at the very start and end. 이는 펄의 /m 변경자와 동일합니다. 주어진 문자열에 "\n" 문자가 존재하지 않거나 ^나 $ 패턴이 일어나지 않으면 이 변경자는 아무런 효과가 없습니다.

s (PCRE_DOTALL)

이 변경자가 지정되면, 패턴의 점 메타문자는 뉴라인을 포함하는 모든 문자를 인식합니다. 지정하지 않으면, 뉴라인은 제외됩니다. 이 변경자는 펄의 /s 변경자와 동일합니다. [^a]와 같은 부정클래스는 이 변경자에 관계 없이 항상 뉴라인 문자를 포함합니다.

x (PCRE_EXTENDED)

이 변경자가 지정되면, 공백 문자는 이스케이프 되거나 문자 클래스 안에 있을 경우를 제외하고, 완전히 무시합니다. 문자 클래스 밖에서 이스케이프 되지 않은 # 사이와 뉴라인 문자 다음의 문자도 무시합니다. 이는 펄의 /x 변경자와 같고, 복잡한 패턴 안에 코멘트를 사용할 수 있게 합니다. 그러나 이는 데이터 문자에만 해당하는 점에 주의하십시오. 공백 문자는 패턴의 특별한 문자 시퀀스 안에는 존재할 수 없습니다. 예를 들면, 조건 서브 패턴을 나타내는 (?( 시퀀스에는 나와서는 안됩니다.

e

이 변경자를 지정하면, preg_replace()는 변경할 문자열을 PHP 코드로 처리하고, 그 결과를 검색된 문자열의 이용하여 일반적인 치환을 합니다.

preg_replace()만 이 변경자를 사용합니다; 다른 PCRE 함수는 무시합니다.

참고: 이 변경자는 PHP 3에서는 사용할 수 없습니다.

A (PCRE_ANCHORED)

이 변경자를 지정하면, 패턴을 강제적으로 "고정"합니다. 이는 ("주어진 문자열"에서) 검색된 문자열의 시작에만 매치도록 강제합니다. 패턴 자체에서 특정한 구조를 가지게 하는, 펄에서는 유일한 방법으로 같은 효과를 얻을 수 있습니다.

D (PCRE_DOLLAR_ENDONLY)

이 변경자가 설정되면, 패턴의 달러($) 메타문자는 주어진 문자열의 마지막에만 대응합니다. 이 변경자 없이는, 달러는 마지막 문자가 뉴라인일 경우에는 바로 직전의 문자에도 매칭합니다. (마지막이 아닌 뉴라인은 제외합니다) 이 변경자는 m 변경자가 지정되었을때는 무시됩니다. 펄에는 이 변경자가 존재하지 않습니다.

S

패턴이 여러번 이용되면, 매칭에 걸리는 시간을 절약하기 위해서 분석에 더 많은 시간을 들일 가치가 있습니다. 이 변경자를 지정하면, 추가 분석을 행합니다. 현 시점에서, 패턴의 분석은 하나의 고정된 시작 문자를 가지지 않는 비고정 패턴에만 유용합니다.

U (PCRE_UNGREEDY)

이 변경자는 수량 지시의 "greediness"를 뒤집습니다. 그리하여 기본값으로 not greedy하게 합니다. 하지만 "?"가 붙으면 greedy하게 됩니다. 이는 펄과 호환되지 않습니다. 패턴 안에서 (?U) 변경자 설정으로 지정할 수 있습니다.

X (PCRE_EXTRA)

이 변경자는 펄과 호환되지 않는 PCRE의 추가 기능을 사용하게 합니다. 패턴의 문자와 결합된 백슬래쉬가 특별한 의미를 지니지 않을 경우에 에러를 발생시켜서, 차후에 추가 기능을 위해 예약해둡니다. 기본적으로 펄은, 문자와 결합된 백슬래쉬가 특별한 의미를 지니지 않을 경우에는 글자로 취급합니다. 이 변경자는 다른 기능을 제어하지 않습니다.

u (PCRE_UTF8)

이 변경자는 펄과 호환되지 않는 PCRE의 추가 기능을 사용하게 합니다. 패턴 문자열을 UTF-8으로 취급합니다. 유닉스에서는 PHP 4.1.0부터, win32에서는 PHP 4.2.3부터 사용할 수 있습니다.

이전 | 처음으로 | 다음
정규표현식 함수 (펄-호환) | 위로 | 패턴 문법


패턴 문법

패턴 문법 -- PCRE 정규표현식 문법 설명

설명

PCRE 라이브러리는 아주 약간의 차이(아래를 참고)를 제외하고, 펄 5와 동일한 구문과 의미를 사용하여 정규표현식 패턴 매칭을 수행하는 함수의 집합입니다. 현재 수행은 펄 5.005에 대응합니다.

펄과의 차이

여기에서 설명한 차이는 펄 5.005 기준입니다.

  1. PCRE는 다른 문자 집합으로 컴파일할 수 있지만, 기본적으로 공백 문자는 C 라이브러리 함수 isspace()가 인식하는 모든 문자입니다. 보통 isspace()는 스페이스, 폼피드, 줄바꿈, 캐리지 리턴, 수평 탭, 수직 탭을 인식합니다. 펄 5는 공백 문자에 수직 탭을 포함하지 않습니다. 오랜 기간동안 펄 문서의 \v 이스케이프는 사실상 인정되지 않았습니다. 그러나 문자 자체는 적어도 5.002까지 공백으로 취급되었으며, 5.004와 5.005는 \s에서 인식하지 않습니다.

  2. PCRE는 lookahead 단정에서 반복 횟수를 허용하지 않습니다. 펄은 허용하지만, 생각하는 그대로의 의미를 갖지 않습니다. 예를 들어, (?!a){3}는 다음 세 문자가 "a"가 아닌 것을 의미하지 않습니다. 단지, 다음 문자가 "a"가 아니라는 것을 세번 확인할 뿐입니다.

  3. 부정 lookahead 단정 안에서 일어나는 서브패턴 검출을 카운트를 하지만, 시작 위치 벡터에 그 엔트리를 설정하지는 않습니다. 펄은 부정 lookahead 단정이 단 하나의 브랜치를 가지고 있을 경우에 한하여, 그 단정이 매치에 실패(결과적으로 성공)하기 전에 매치한 어떠한 패턴에 대해서만 그에 대한 숫자 변수를 설정합니다.

  4. 바이너리 제로 문자는 목표 문자열에서는 지원하지만, 패턴 문자열에서는 허용하지 않습니다. 패턴은 제로로 종료하는 보통의 C 문자열로 처리하기 때문입니다. 패턴에서 바이너리 제로를 표현하기 위해서는 이스케이프 시퀀스 "\\x00"로 사용할 수 있습니다.

  5. 다음의 펄 이스케이프 시퀀스는 지원하지 않습니다: \l, \u, \L, \U, \E, \Q. 사실, 이들은 펄의 일반 문자열 핸들링이며, 패턴 매칭 엔진의 부분이 아닙니다.

  6. 펄의 \G는 싱글 패턴 매치에 적절하지 않기 때문에 지원하지 않습니다.

  7. 당연하게도, PCRE는 (?{code}) 구조를 지원하지 않습니다.

  8. 패턴의 일부가 반복될 때, 잡아낸 문자열의 설정에 관해서, 펄 5.005_02에서 일부 이상한 동작이 존재합니다. 예를 들어, "aba"에 대해서 패턴 /^(a(b)?)+$/를 매칭하면 $2를 "b" 값으로 설정하지만, "aabbaa"에 대해서 /^(aa(bb)?)+$/를 매칭하면 $2를 설정하지 않습니다. 하지만 패턴을 /^(aa(b(b))?)+$/로 변경하면 $2(와 $3)를 설정합니다. 펄 5.004에서는 $2를 두 경우 모두 설정했으며, PCRE에서도 TRUE입니다. 앞으로 펄이 이 차이를 일관성 있게 변경한다면, PCRE는 그 변경에 따를 것입니다.

  9. 또다른 해결되지 않은 모순점은 펄 5.005_02가 패턴 /^(a)?(?(1)a|b)+$/를 문자열 "a"에 매치하지만, PCRE는 하지 않습니다. 그러나 펄과 PCRE 모두 /^(a)?a/를 "a"에 매치하고 $1을 설정하지 않습니다.

  10. PCRE는 펄 정규표현식 기능의 몇가지 확장을 지원합니다:

    1. lookbehind 단정은 고정 길이 문자열에만 매치해야하지만, 양자 택일의 lookbehind 단정에서는 다른 길이의 문자열을 매치할 수 있습니다. 펄 5.005에서는 모두 같은 길이를 가질 것을 요구합니다.

    2. PCRE_DOLLAR_ENDONLY를 설정하고 PCRE_MULTILINE를 설정하지 않으면 $ 메타 문자는 문자열의 가장 마지막에만 매치합니다.

    3. PCRE_EXTRA를 설정하면, 백슬래쉬 뒤에 특별한 의미를 가지지 않는 문자의 사용은 실패하게 됩니다.

    4. PCRE_UNGREEDY를 설정하면, 반복 수량어의 greediness가 뒤집어져서, 기본값으로 greedy하지 않게 됩니다. 하지만 뒤에 물음표가 붙으면 greedy하게 됩니다.

정규표현식 상세

소개

아래 설명은 PCRE가 지원하는 정규표현식의 문법과 의미입니다. 정규표현식은 펄 문서 및 많은 책들에 설명이 있으며, 그 중 일부에는 풍부한 예제를 가지고 있습니다. O'Reilly에서 출판한 Jeffrey Friedl의 "Mastering Regular Expressions"(ISBN 1-56592-257-3)는 예제들을 매우 자세하게 다루고 있습니다. 여기의 설명은 레퍼런스 문서에 따릅니다.

정규표현식은 주어진 문자열에 대하여 왼쪽에서 오른쪽으로 매치하는 패턴입니다. 문자열은 패턴으로 준비하고, 목표에서 대응하는 문자열에 매치합니다. 간단한 예로, 패턴 The quick brown fox는 목표 문자열의 동일한 부분에 매치합니다.

메타 문자

정규표현식이 강력한 이유는 패턴에 선택과 반복을 포함할 수 있다는 점입니다. 이는 특별한 방법으로 해석하는 메타 문자를 사용하여 패턴에 넣습니다.

메타 문자는 두가지 종류가 존재합니다: 대괄호 안을 제외하고 패턴의 어디에서라도 작동하는 종류와, 대괄호 안에서만 작동하는 종류입니다. 다음은 대괄호 밖에서 사용하는 메타 문자들입니다.

\

여러가지로 사용하는 일반적인 이스케이프 문자

^

목표의 처음 (멀티라인 모드에서는 줄의 처음)

$

목표의 마지막 (멀티라인 모드에서는 줄의 끝)

.

(기본값으로) 줄바꿈을 제외한 아무 문자

[

클래스 정의 시작 문자

]

클래스 정의 끝 문자

|

선택 브랜치 시작

(

서브패턴 시작

)

서브패턴 끝

?

( 의미 확장, 또는 0회나 1회, 또는 수량어 minimizer

*

0회 이상의 횟수

+

1회 이상의 횟수

{

최소/최대 횟수 시작

}

최소/최대 횟수 끝

대괄호 안쪽의 패턴은 "문자 클래스"라고 부릅니다. 다음은 문자 클래스에서 사용하는 메타 문자들입니다:

\

일반적인 이스케이프 문자

^

처음 문자로 올 때, 부정 클래스로 설정

-

문자 범위 지정

]

문자 클래스 종료

다음 섹션은 각 메타 문자의 사용을 설명합니다.

백슬래쉬

백슬래쉬 문자는 여러가지 사용법을 가집니다. 먼저, 뒤에 영숫자가 아닌 문자가 붙는다면, 그 문자가 가지고 있는 특별한 의미가 사라집니다. 이러한 이스케이프 문자로 백슬래쉬를 사용하는 것은 문자 클래스 안과 밖 양쪽에 모두 적용됩니다.

예를 들어, "*" 문자를 매치하길 원한다면, 패턴에는 "\*"로 써야합니다. 이는 따라오는 문자가 메타 문자이던 아니던간에 관계 없이 적용하기 떄문에, 영숫자가 아닌 문자에 그 자체를 사용하기 위해 "\"를 붙이는 것이 항상 안전합니다. 특히, 백슬래쉬를 매치하고자 한다면, "\\"로 써야합니다.

패턴에 PCRE_EXTENDED 옵션을 사용하면, 패턴에 존재하는 (문자 클래스 안이 아닌) 공백, 그리고 문자 클래스 밖의 "#"사이의 문자와 바로 뒤의 줄바꿈 문자를 무시합니다. 이스케이프하는 백슬래쉬를 공백이나 "#"문자를 패턴에 넣기 위해 사용할 수 있습니다.

백슬래쉬의 두번째 사용법은 패턴에서 출력할 수 없는 문자를 보여지게 인코딩하는 방법을 제공합니다. 바이너리 제로가 패턴 종료를 의미하는걸 제외하면, 출력할 수 없는 문자가 나타나는 제한은 존재하지 않습니다. 그러나 패턴을 텍스트 편집으로 준비할 때는, 다음의 이스케이프 시퀀스를 사용하는 편이 바이너리 문자를 직접 표현하는 것보다 간편합니다:

\a

알람, BEL 문자(hex 07)

\cx

"control-x", x는 임의의 문자

\e

이스케이프 (hex 1B)

\f

폼피드 (hex 0C)

\n

줄바꿈 (hex 0A)

\r

캐리지 리턴 (hex 0D)

\t

탭 (hex 09)

\xhh

16진 코드 hh 문자

\ddd

8진 코드 ddd 문자, 혹은 역참조

"\cx"의 효과는 다음과 같이 계산합니다: "x"가 소문자라면, 대문자로 변환합니다. 그 후, 문자의 6번째 비트(hex 40)가 뒤집어집니다. 즉 "\cz"은 hex 1A가 되고, "\c{"은 hex 3B, 그리고 "\c;"은 hex 7B가 됩니다.

"\x" 뒤에, 두개의 16진 숫자를 읽습니다. (대소문자는 구별하지 않습니다)

"\0"은 다음의 두자리의 8진수를 읽습니다. 양쪽 모두, 두자리가 되지 않을 경우, 그 표현을 그대로 사용합니다. 즉 "\0\x\07" 시퀀스는 두개의 바이너리 제로에 이어지는 BEL 문자를 정의합니다. 바로 뒤에 8진수로 인식되는 문자가 이어질 경우에는 처음의 제로 뒤에 두자리 수를 써야한다는 것을 잊지 마십시오.

백슬래쉬 뒤에 0이 아닌 수가 올 경우에 혼동할 수 있습니다. 문자 클래스 밖에서, PCRE는 그것과 따라오는 수를 10진수로 읽습니다. 수가 10보다 작거나, 표현식에서 수 이상의 묶음을 잡아냈다면, 이 시퀀스는 역참조가 됩니다. 이 작동에 관해서는 아래에, 묶음 서브패턴에 설명이 있습니다.

문자 클래스 안이나, 10진수 9 이상이 없고 서브패턴이 그만큼 존재하지 않을 경우, PCRE는 백슬래쉬 뒤의 세자리 8진수로 다시 읽어들여, 해당하는 8비트 값으로 하나의 바이트를 생성합니다. 어떠한 수라도 사용할 수 있습니다. 예를 들면:

\040

스페이스의 다른 표현 방법

\40

40개 미만의 서브 패턴을 검출하였을때, 동일한 의미

\7

항상 역참조

\11

역참조, 혹은 탭의 다른 표현 방법

\011

항상 탭

\0113

문자 "3"이 따라오는 탭

\113

8진 코드 113 문자 (역참조는 99까지입니다)

\377

1비트만을 제외한 바이트

\81

역참조이거나 "8"과 "1"의 두 문자가 붙는 바이너리 제로

100이상의 8진 값은 앞에 제로가 붙지 않아야만 합니다. 세자리를 넘어가는 8진 값은 읽지 않습니다.

하나의 바이트값을 정의하는 모든 시퀀스는 문자 클래스 내외, 어디에서도 사용할 수 있습니다. 추가로, 문자 클래스 안에서 "\b" 시퀀스는 백스페이스 문자(hex 08)로 해석합니다. 문자 클래스 밖에서는 다른 의미를 가집니다. (아래를 참고)

백슬래쉬의 세번째 사용법은 일반적인 문자 타입의 지정입니다:

\d

임의의 10진 숫자

\D

10진 숫자가 아닌 임의의 문자

\s

임의의 공백 문자

\S

공백이 아닌 임의의 문자

\w

임의의 "word" 문자

\W

임의의 "non-word" 문자

각 이스케이프 시퀀스 조합은 완전한 문자 세트를 두개의 개별 세트로 분리합니다. 주어진 문자는 각 조합의 한쪽에만 매치합니다.

"word" 문자는 어떠한 문자나 숫자, 혹은 언더스코어(_)입니다. 즉, 펄의 "word"에 해당하는 어떠한 문자입니다. 문자와 숫자의 정의는 PCRE의 문자 테이블이 제어하고, 로케일 특정 매칭이 존재할 경우에는 다양할 수 있습니다. (위쪽의 "로케일 지원" 참고) 예를 들어, "fr"(프랑스어) 로케일에서는, 128 이상의 몇몇 코드를 엑센트 문자를 나타내는데 사용하며, 이들은 \w에 매치합니다.

문자형 시퀀스는 문자 클래스 안과 밖에서 모두 사용할 수 있습니다. 각각 해당하는 형의 한 문자에 매치합니다. 현재 매칭 위치가 목표 문자열의 마지막이라면, 전부 실패하고, 어떠한 문자도 매치하지 않습니다.

백슬래쉬의 네번째 사용법은 간단한 단정입니다. 단정은 조건이 목표 문자열에서 다른 부분에 매치하지 않고, 특정한 위치에만 매치하도록 지정합니다. 복잡한 단정을 위한 서브패턴의 사용법은 아래에 설명이 있습니다. 백슬래쉬 단정은 다음과 같습니다.

\b

word 경계

\B

word 경계가 아님

\A

목표의 처음 (멀티라인 모드와 무관)

\Z

목표의 마지막이나 마지막에서 줄바꿈 (멀티라인 모드와 무관)

\z

목표의 마지막 (멀티라인 모드와 무관)

단정은 문자 클래스 안에서 사용할 수 없습니다. ("\b"가 문자 클래스 안에서는 백스페이스 문자를 나타내는 점에 주의하십시오)

word 경계는 현재 문자와 이전 문자가 둘 다 \w에 매치하지 않거나 둘 다 \W에 매치하지 않는 (즉, 하나는 \w에 매치하고 다른 하나는 \W에 매치) 목표 문자열의 위치이거나, 처음이나 마지막 문자가 \w에 매치할 경우는 문자열의 처음이나 마지막입니다.

\A, \Z, \z 단정은 전통적인 circumflex와 달러와는 달리 옵션과 관계 없이 목표 문자열의 가장 처음이나 가장 마지막에만 매치합니다. 이들은 PCRE_MULTILINE이나 PCRE_DOLLAR_ENDONLU 옵션에 영향을 받지 않습니다. \Z와 \z의 차이는, \Z가 문자열의 마지막뿐만 아니라 문자열 마지막 문자가 줄바꿈일 경우에는 바로 앞에도 매치하지만, \z는 마지막에만 매치합니다.

Circumflex와 달러

문자열 클래스의 밖, 기본 매칭 모드에서는 circumflex 문자는 현재 매칭 위치가 목표 문자열의 시작일 경우에만 성공하는 단정입니다. 문자열 클래스 안에서 cicumflex는 완전히 다른 의미를 가집니다. (아래 참고)

여러 개의 선택을 가질 경우 circumflex는 패턴의 처음 문자일 필요가 없지만, 패턴이 그 브랜치에 처음 매치할 경우를 나타내는 각 선택에서의 처음 문자여야 합니다. 모든 선택이 circumflex로 시작하는, 목표의 처음에만 매치하는 패턴은 "고정" 패턴이라 불려집니다. (패턴을 고정하는 다른 구조도 존재합니다)

달러 문자는 매칭 위치가 목표 문자열의 마지막이거나, (기본값으로) 문자열 마지막 줄바꿈의 바로 전에 해당하는 경우에만 TRUE인 단정입니다. 선택을 가지는 패턴에서는 달러가 패턴의 마지막일 필요가 없지만, 마지막을 나타내는 모든 브랜치에서 마지막 문자여야 합니다. 달러는 문자 클래스 안에서는 특별한 의미를 가지지 않습니다.

달러의 의미는 컴파일시나 매치를 할 때 PCRE_DOLLAR_ENDONLY 옵션을 설정해서 문자열의 마지막에만 매치하도록 변경할 수 있습니다. 이는 \Z 단정에는 영향을 주지 않습니다.

PCRE_MULTILINE 옵션을 설정하면, circumflex와 달러 문자의 의미가 달라집니다. 이 경우, 목표 문자열의 처음과 마지막에 더하여, 내부의 "\n" 문자의 뒤와 앞에도 매치합니다. 예를 들어, 패턴 /^abc$/는 멀티라인 모드에서는 목표 문자열 "def\nabc"에 매치하지만, 그렇지 않다면 매치하지 않습니다. 따라서, 모든 브랜치가 "^"로 시작하는 브랜치는 단일라인 모드에서는 고정이지만, 멀티라인 모드에서는 고정이 아닙니다. PCRE_MULTILINE을 설정하면, PCRE_DOLLOR_ENDONLY 옵션을 무시합니다.

어떤 모드에서라도 \A, \Z, \z 시퀀스는 목표의 처음과 마지막에 매치할 때 사용할 수 있습니다. PCRE_MULTILINE에 관계 없이 모든 브랜치가 \A로 시작하는 패턴은 항상 고정입니다.

마침표

문자 클래스 밖에서, 패턴의 마침표는 패턴의 아무 문자에 매치합니다. 출력할 수 없는 문자도 포함하지만, (기본값으로) 줄바꿈은 포함하지 않습니다. PCRE_DOTALL 옵션을 설정하면, 마침표가 줄바꿈에도 매치합니다. 마침표의 처리는 circumflex와 달러의 처리와는 완전히 독립이며, 유일한 관계는 두 경우 모두 줄바꿈 문자에 해당한다는 점입니다. 마침표는 문자 클래스 안에서는 특별한 의미를 가지지 않습니다.

대괄호

여는 대괄호로 문자 클래스를 시작하고, 닫는 대괄호로 종료합니다. 닫는 대괄호는 그 자체로는 특별한 의미가 없습니다. 닫는 대괄호를 클래스의 멤버로 사용하려면 클래스의 가장 처음(존재한다면 시작 circumflex 뒤에)에 위치하거나 백슬래쉬로 이스케이프해야 합니다.

문자 클래스는 목표에서 하나의 문자에 매치합니다; 그 문자는 클래스가 정의하는 문자 세트에 존재해야 합니다. 클래스가 circumflex로 시작할 경우에는, 목표 문자는 클래스 정의 세트에 존재하지 않아야 합니다. circumflex가 클래스 멤버로 필요할 때는, 처음에 위치시키지 않거나 백슬래쉬로 이스케이프해야 합니다.

예를 들면, 문자 클래스 [aeiou]는 모든 소문자 모음에 매치하지만, [^aeiow]는 소문자 모음이 아닌 모든 문자에 매치합니다. circumflex는 단지 클래스에 존재하는 문자가 아닌 것들을 지정하는 편리한 방법일 뿐이라는 점에 주의하십시오. 단정이 아닙니다: 목표 문자열에서 문자를 찾아내며, 현재 위치가 문자열의 끝이면 실패합니다.

대소문자를 구별하지 않는 매칭을 설정하면, 클래스 안의 모든 문자는 대문자와 소문자 모두 매치합니다. 예를 들면, 대소문자 구별 없는 [aeiou]는 "a"와 함께 "A"도 매치하며, 대소문자 구별 없는 [^aeiou]는 구별하는 버전일 경우 매치하는 "A"에는 매치하지 않습니다.

줄바꿈 문자는 PCRE_DOTALL나 PCRE_MULTILINE 옵션의 설정에 관계 없이, 문자 클래스 안에서 특별한 방법으로 취급하지 않습니다. [^a]와 같은 클래스는 항상 줄바꿈에 매치합니다.

빼기(하이픈) 문자는 문자 클래스에서 문자의 범위를 지정하는데 사용할 수 있습니다. 예를 들어, [d-m]은 d부터 m까지의 모든 문자에 매치합니다. 빼기 문자가 클래스에서 필요하면, 백슬래쉬로 이스케이프하거나, 클래스의 맨 처음이나 마지막처럼 범위로 해석할 수 없는 위치에 나타나야 합니다.

문자 "]"를 범위의 마지막으로 지정하는 것은 불가능합니다. [W-]46]과 같은 패턴은 두 문자를 가지는 클래스("W"와 "-") 뒤에 일반 문자열 "46]"이 붙는 형태로 해석합니다. 그러므로 "W46]"이나 "-46]"에 매치합니다. 그러나, "]"를 백슬래쉬로 이스케이프하면 범위의 끝으로 해석하기에, [W-\]46]은 범위와 두개의 개별 문자를 가지는 하나의 클래스로 해석합니다. 범위의 마지막으로 "]"의 8진수 및 16진수 표현을 사용할 수도 있습니다.

범위는 아스키 순서에 따라 정해집니다. [\000-\037]처럼 숫자로 지정한 문자를 사용할 수도 있습니다. 대소문자 구별 없는 매칭을 설정하면, 범위 안의 문자들도 대소문자 구별 없이 매칭합니다. 예를 들면, [W-c]는 대소문자 구별 없는 [][\^_`wxyzabc]와 동일하며, "fr" 로케일의 문자표를 사용하면, [\xc8-\xcb]는 대소문자 구별 없이 엑센트 E 문자에 매치합니다.

문자형 \d, \D, \s, \S, \w, \W도 문자 클래스에서 사용할 수 있고, 해당하는 문자들을 클래스에 추가합니다. 예를 들어, [\dABCDEF]는 모든 16진수에 매치합니다. circumflex와 위에서 대문자형을 지정하여 소문자형을 매칭하는 데에 편리하게 제한을 할 수 있습니다. 예를 들어, 클래스 [^\W_]는 언더스코어를 제외한 모든 문자와 숫자에 매치합니다.

\, -, ^(시작 위치), 종료 ]를 제외한 모든 영숫자가 아닌 문자는 문자 클래스에서 특별한 의미를 가지지 않지만, 이스케이프 해도 문제가 발생하지는 않습니다.

수직 바

수직 바 문자는 선택 패턴을 구별할 때 사용합니다. 예를 들어, 패턴 gilbert|sullivan은 "gilbert"나 "sullivan"에 매치합니다. 어떠한 수의 선택도 사용할 수 있고, 빈 선택도 허용합니다. (빈 문자열에 매칭합니다) 매칭 프로세스는 각 선택을 왼쪽에서 오른쪽으로 시도하며, 가장 먼저 선택한 것을 사용합니다. 서브패턴(아래에서 정의) 안에서 선택을 하면, "성공"은 서브패턴의 선택과 함께 메인 패턴의 나머지 부분도 매치하는 것을 의미합니다.

내부 옵션 설정

PCRE_CASELESS, PCRE_MULTILINE, PCRE_DOTALL, PCRE_EXTENDED의 설정은 "(?"와 ")" 사이에 펄 옵션 문자 시퀀스로 패턴 안에서 변경할 수 있습니다. 옵션 문자는 다음과 같습니다.

표 1. 내부 옵션 문자

i | PCRE_CASELESS에 해당
m | PCRE_MULTILINE에 해당
s | PCRE_DOTALL에 해당
i | PCRE_EXTENDED에 해당

예를 들어, (?im)은 대소문자 구별 없는 멀티라인 매칭을 설정합니다. 하이픈과 함께 사용하여 옵션을 해제할 수도 있습니다. 설정과 해제를 동시에 하는 것도 허용합니다. (?im-sx)를 지정하면, PCRE_CASELESS와 PCRE_MULTILINE를 설정하고 PCRE_DOTALL와 PCRE_EXTENDED를 해제합니다. 문자가 하이픈 앞과 뒤에 모두 나타나면, 옵션을 해제합니다.

옵션이 미치는 위치는 패턴의 어디에서 설정을 했는지에 의존합니다. 모든 서브패턴(아래에서 정의) 밖에서 설정하면, 효과는 옵션을 매칭 시작 지점에서 설정 및 해제한 것과 같습니다. 다음 패턴들은 모두 완전히 동일한 작동을 합니다:

(?i)abc
a(?i)bc
ab(?i)c
abc(?i)

이들은 PCRE_CASELESS를 설정하여 패턴 abc를 처리하는 것과 동일합니다. 즉, "최고 레벨" 설정은 (서브패턴 안에서 다른 변화를 주지 않는 한) 모든 패턴에 적용합니다. 최고 레벨에서 같은 옵션의 설정이 하나 이상 존재하면, 가장 오른쪽에 나오는 설정을 사용합니다.

서브패턴 안에서 옵션을 변경하면, 효과가 다릅니다. 이는 펄 5.005에서 작동 변경점입니다. 서브패턴 안에서 옵션 변경은 따라오는 서브패턴의 부분에만 영향을 미칩니다. 그러므로 (a(?i)b)c은 abc와 aBc만을 매치합니다. (PCRE_CASELESS를 사용하지 않는 경우) 이 의미로, 옵션을 패턴의 다른 부분에서 다른 설정으로 할 수 있습니다. 하나의 선택에서 변경한 것은 같은 서브패턴에서 지속적으로 사용합니다. 예를 들면, (a(?i)b|c)는 "ab", "aB", "c", "C"에 매치합니다. "C"는 옵션을 설정하기 전에 나누어진 브랜치에 해당하지만, 이상한 동작일지라도, 처리 시에 옵션 설정의 효율성을 위해서 매치합니다.

PCRE 전용 옵션 PCRE_UNGREEDY와 PCRE_EXTRA는 U와 X 문자를 사용하여 펄 호환 옵션과 같은 방법으로 변경할 수 있습니다. (?X) 플래그는 특별하기에, 최고 레벨에서라도 다른 기능을 켜기 전에 위치해야만 합니다. 가장 처음에 놓는 편이 좋습니다.

서브패턴

서브패턴은 괄호로 구분하며, 중첩할 수 있습니다. 패턴의 부분을 서브패턴으로 만드는 것은 두가지 일을 합니다:

1. 선택 세트를 지역화합니다. 예를 들어, 패턴 cat(aract|erpillar|)는 "cat", "cataract", "caterpillar" 중에 하나에 매치합니다. 괄호가 없으면, "cataract", "erpillar", 또는 빈 문자열에 매치할 것입니다.

2. It sets up the subpattern as a capturing subpattern (as defined above). When the whole pattern matches, that portion of the subject string that matched the subpattern is passed back to the caller via the ovector argument of pcre_exec(). Opening parentheses are counted from left to right (starting from 1) to obtain the numbers of the capturing subpatterns.

예를 들어, 문자열 "the red king"이 패턴 the ((read|white) (king|queen)에 매치한다면, "red king", "red", "king" 부분 문자열을 잡아내고, 1, 2, 3의 숫자를 부여합니다.

The fact that plain parentheses fulfil two functions is not always helpful. There are often times when a grouping subpattern is required without a capturing requirement. If an opening parenthesis is followed by "?:", the subpattern does not do any capturing, and is not counted when computing the number of any subsequent capturing subpatterns. For example, if the string "the white queen" is matched against the pattern the ((?:red|white) (king|queen)) the captured substrings are "white queen" and "queen", and are numbered 1 and 2. The maximum number of captured substrings is 99, and the maximum number of all subpatterns, both capturing and non-capturing, is 200.

As a convenient shorthand, if any option settings are required at the start of a non-capturing subpattern, the option letters may appear between the "?" and the ":". Thus the two patterns

(?i:saturday|sunday)
(?:(?i)saturday|sunday)

match exactly the same set of strings. Because alternative branches are tried from left to right, and options are not reset until the end of the subpattern is reached, an option setting in one branch does affect subsequent branches, so the above patterns match "SUNDAY" as well as "Saturday".

반복

반복은 다음 항목들에 덧붙이는 수량어로 지정합니다:

  • 이스케이프할 수 있는 하나의 문자

  • . 메타 문자

  • 문자 클래스

  • 역참조 (다음 섹션 참고)

  • 서브 패턴 묶음(단정이 아닌 경우 - 아래 참고

일반적인 반복 수량어는 허용하는 매치 수의 최소값과 최대값을 중괄호 안에 쉼표로 구분하여 지정합니다. 수는 65535보다 작아야하며, 처음 수는 두번째 수보다 작거나 같아야만 합니다. 예를 들면: z{2,4}는 "zz", "zzz", "zzzz"에 매치합니다. 닫는 괄호 자체는 특수 문자가 아닙니다. 두번째 수를 생략하고, 쉼표가 존재하면 최대 제한이 없어집니다; 두번째 수와 쉼표를 모두 생략하면, 수량어는 요구하는 매치 수의 정확한 수를 지정합니다. 그러므로, [aeiou]{3,}는 3개 이상의 모음에 매치하지만, \d{8}은 8자리 수에만 매치합니다. 수량어를 허용하지 않는 위치에서 중괄호를 여는 것은 수량어 구문으로 매치하지 않고, 일반 문자로 취급합니다. 예를 들어, {,6}는 수량어가 아닌, 4 문자의 일반 문자열입니다.

수량어 {0}을 허용하며, 이는 이전의 항목과 수량어가 존재하지 않는 표현식으로 작동합니다.

편의성을 위해서 (그리고 역사적인 호환성을 위해서) 가장 일반적인 세 수량어는 단일 표현을 가지고 있습니다:

표 2. 단일 문자 수량어

* | {0,}과 동일
+ | {1,}과 동일
? | {0,1}과 동일

It is possible to construct infinite loops by following a subpattern that can match no characters with a quantifier that has no upper limit, for example: (a?)*

Earlier versions of Perl and PCRE used to give an error at compile time for such patterns. However, because there are cases where this can be useful, such patterns are now accepted, but if any repetition of the subpattern does in fact match no characters, the loop is forcibly broken.

By default, the quantifiers are "greedy", that is, they match as much as possible (up to the maximum number of permitted times), without causing the rest of the pattern to fail. The classic example of where this gives problems is in trying to match comments in C programs. These appear between the sequences /* and */ and within the sequence, individual * and / characters may appear. An attempt to match C comments by applying the pattern /\*.*\*/ to the string /* first command */ not comment /* second comment */ fails, because it matches the entire string due to the greediness of the .* item.

However, if a quantifier is followed by a question mark, then it ceases to be greedy, and instead matches the minimum number of times possible, so the pattern /\*.*?\*/ does the right thing with the C comments. The meaning of the various quantifiers is not otherwise changed, just the preferred number of matches. Do not confuse this use of question mark with its use as a quantifier in its own right. Because it has two uses, it can sometimes appear doubled, as in \d??\d which matches one digit by preference, but can match two if that is the only way the rest of the pattern matches.

If the PCRE_UNGREEDY option is set (an option which is not available in Perl) then the quantifiers are not greedy by default, but individual ones can be made greedy by following them with a question mark. In other words, it inverts the default behaviour.

When a parenthesized subpattern is quantified with a minimum repeat count that is greater than 1 or with a limited maximum, more store is required for the compiled pattern, in proportion to the size of the minimum or maximum.

If a pattern starts with .* or .{0,} and the PCRE_DOTALL option (equivalent to Perl's /s) is set, thus allowing the . to match newlines, then the pattern is implicitly anchored, because whatever follows will be tried against every character position in the subject string, so there is no point in retrying the overall match at any position after the first. PCRE treats such a pattern as though it were preceded by \A. In cases where it is known that the subject string contains no newlines, it is worth setting PCRE_DOTALL when the pattern begins with .* in order to obtain this optimization, or alternatively using ^ to indicate anchoring explicitly.

When a capturing subpattern is repeated, the value captured is the substring that matched the final iteration. For example, after (tweedle[dume]{3}\s*)+ has matched "tweedledum tweedledee" the value of the captured substring is "tweedledee". However, if there are nested capturing subpatterns, the corresponding captured values may have been set in previous iterations. For example, after /(a|(b))+/ matches "aba" the value of the second captured substring is "b".

역참조

Outside a character class, a backslash followed by a digit greater than 0 (and possibly further digits) is a back reference to a capturing subpattern earlier (i.e. to its left) in the pattern, provided there have been that many previous capturing left parentheses.

However, if the decimal number following the backslash is less than 10, it is always taken as a back reference, and causes an error only if there are not that many capturing left parentheses in the entire pattern. In other words, the parentheses that are referenced need not be to the left of the reference for numbers less than 10. See the section entitled "Backslash" above for further details of the handling of digits following a backslash.

A back reference matches whatever actually matched the capturing subpattern in the current subject string, rather than anything matching the subpattern itself. So the pattern (sens|respons)e and \1ibility matches "sense and sensibility" and "response and responsibility", but not "sense and responsibility". If caseful matching is in force at the time of the back reference, then the case of letters is relevant. For example, ((?i)rah)\s+\1 matches "rah rah" and "RAH RAH", but not "RAH rah", even though the original capturing subpattern is matched caselessly.

There may be more than one back reference to the same subpattern. If a subpattern has not actually been used in a particular match, then any back references to it always fail. For example, the pattern (a|(bc))\2 always fails if it starts to match "a" rather than "bc". Because there may be up to 99 back references, all digits following the backslash are taken as part of a potential back reference number. If the pattern continues with a digit character, then some delimiter must be used to terminate the back reference. If the PCRE_EXTENDED option is set, this can be whitespace. Otherwise an empty comment can be used.

A back reference that occurs inside the parentheses to which it refers fails when the subpattern is first used, so, for example, (a\1) never matches. However, such references can be useful inside repeated subpatterns. For example, the pattern (a|b\1)+ matches any number of "a"s and also "aba", "ababaa" etc. At each iteration of the subpattern, the back reference matches the character string corresponding to the previous iteration. In order for this to work, the pattern must be such that the first iteration does not need to match the back reference. This can be done using alternation, as in the example above, or by a quantifier with a minimum of zero.

단정

An assertion is a test on the characters following or preceding the current matching point that does not actually consume any characters. The simple assertions coded as \b, \B, \A, \Z, \z, ^ and $ are described above. More complicated assertions are coded as subpatterns. There are two kinds: those that look ahead of the current position in the subject string, and those that look behind it.

An assertion subpattern is matched in the normal way, except that it does not cause the current matching position to be changed. Lookahead assertions start with (?= for positive assertions and (?! for negative assertions. For example, \w+(?=;) matches a word followed by a semicolon, but does not include the semicolon in the match, and foo(?!bar) matches any occurrence of "foo" that is not followed by "bar". Note that the apparently similar pattern (?!foo)bar does not find an occurrence of "bar" that is preceded by something other than "foo"; it finds any occurrence of "bar" whatsoever, because the assertion (?!foo) is always TRUE when the next three characters are "bar". A lookbehind assertion is needed to achieve this effect.

Lookbehind assertions start with (?<= for positive assertions and (?<! for negative assertions. For example, (?<!foo)bar does find an occurrence of "bar" that is not preceded by "foo". The contents of a lookbehind assertion are restricted such that all the strings it matches must have a fixed length. However, if there are several alternatives, they do not all have to have the same fixed length. Thus (?<=bullock|donkey) is permitted, but (?<!dogs?|cats?) causes an error at compile time. Branches that match different length strings are permitted only at the top level of a lookbehind assertion. This is an extension compared with Perl 5.005, which requires all branches to match the same length of string. An assertion such as (?<=ab(c|de)) is not permitted, because its single top-level branch can match two different lengths, but it is acceptable if rewritten to use two top-level branches: (?<=abc|abde) The implementation of lookbehind assertions is, for each alternative, to temporarily move the current position back by the fixed width and then try to match. If there are insufficient characters before the current position, the match is deemed to fail. Lookbehinds in conjunction with once-only subpatterns can be particularly useful for matching at the ends of strings; an example is given at the end of the section on once-only subpatterns.

Several assertions (of any sort) may occur in succession. For example, (?<=\d{3})(?<!999)foo matches "foo" preceded by three digits that are not "999". Notice that each of the assertions is applied independently at the same point in the subject string. First there is a check that the previous three characters are all digits, then there is a check that the same three characters are not "999". This pattern does not match "foo" preceded by six characters, the first of which are digits and the last three of which are not "999". For example, it doesn't match "123abcfoo". A pattern to do that is (?<=\d{3}...)(?<!999)foo

This time the first assertion looks at the preceding six characters, checking that the first three are digits, and then the second assertion checks that the preceding three characters are not "999".

Assertions can be nested in any combination. For example, (?<=(?<!foo)bar)baz matches an occurrence of "baz" that is preceded by "bar" which in turn is not preceded by "foo", while (?<=\d{3}(?!999)...)foo is another pattern which matches "foo" preceded by three digits and any three characters that are not "999". Assertion subpatterns are not capturing subpatterns, and may not be repeated, because it makes no sense to assert the same thing several times. If any kind of assertion contains capturing subpatterns within it, these are counted for the purposes of numbering the capturing subpatterns in the whole pattern. However, substring capturing is carried out only for positive assertions, because it does not make sense for negative assertions. Assertions count towards the maximum of 200 parenthesized subpatterns.

Once-only subpatterns

With both maximizing and minimizing repetition, failure of what follows normally causes the repeated item to be reevaluated to see if a different number of repeats allows the rest of the pattern to match. Sometimes it is useful to prevent this, either to change the nature of the match, or to cause it fail earlier than it otherwise might, when the author of the pattern knows there is no point in carrying on.

Consider, for example, the pattern \d+foo when applied to the subject line 123456bar

After matching all 6 digits and then failing to match "foo", the normal action of the matcher is to try again with only 5 digits matching the \d+ item, and then with 4, and so on, before ultimately failing. Once-only subpatterns provide the means for specifying that once a portion of the pattern has matched, it is not to be re-evaluated in this way, so the matcher would give up immediately on failing to match "foo" the first time. The notation is another kind of special parenthesis, starting with (?> as in this example: (?>\d+)bar

This kind of parenthesis "locks up" the part of the pattern it contains once it has matched, and a failure further into the pattern is prevented from backtracking into it. Backtracking past it to previous items, however, works as normal.

An alternative description is that a subpattern of this type matches the string of characters that an identical standalone pattern would match, if anchored at the current point in the subject string.

Once-only subpatterns are not capturing subpatterns. Simple cases such as the above example can be thought of as a maximizing repeat that must swallow everything it can. So, while both \d+ and \d+? are prepared to adjust the number of digits they match in order to make the rest of the pattern match, (?>\d+) can only match an entire sequence of digits.

This construction can of course contain arbitrarily complicated subpatterns, and it can be nested.

Once-only subpatterns can be used in conjunction with lookbehind assertions to specify efficient matching at the end of the subject string. Consider a simple pattern such as abcd$ when applied to a long string which does not match. Because matching proceeds from left to right, PCRE will look for each "a" in the subject and then see if what follows matches the rest of the pattern. If the pattern is specified as ^.*abcd$ then the initial .* matches the entire string at first, but when this fails (because there is no following "a"), it backtracks to match all but the last character, then all but the last two characters, and so on. Once again the search for "a" covers the entire string, from right to left, so we are no better off. However, if the pattern is written as ^(?>.*)(?<=abcd) then there can be no backtracking for the .* item; it can match only the entire string. The subsequent lookbehind assertion does a single test on the last four characters. If it fails, the match fails immediately. For long strings, this approach makes a significant difference to the processing time.

When a pattern contains an unlimited repeat inside a subpattern that can itself be repeated an unlimited number of times, the use of a once-only subpattern is the only way to avoid some failing matches taking a very long time indeed. The pattern (\D+|<\d+>)*[!?] matches an unlimited number of substrings that either consist of non-digits, or digits enclosed in <>, followed by either ! or ?. When it matches, it runs quickly. However, if it is applied to aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa it takes a long time before reporting failure. This is because the string can be divided between the two repeats in a large number of ways, and all have to be tried. (The example used [!?] rather than a single character at the end, because both PCRE and Perl have an optimization that allows for fast failure when a single character is used. They remember the last single character that is required for a match, and fail early if it is not present in the string.) If the pattern is changed to ((?>\D+)|<\d+>)*[!?] sequences of non-digits cannot be broken, and failure happens quickly.

Conditional subpatterns

It is possible to cause the matching process to obey a subpattern conditionally or to choose between two alternative subpatterns, depending on the result of an assertion, or whether a previous capturing subpattern matched or not. The two possible forms of conditional subpattern are

(?(condition)yes-pattern)
(?(condition)yes-pattern|no-pattern)

If the condition is satisfied, the yes-pattern is used; otherwise the no-pattern (if present) is used. If there are more than two alternatives in the subpattern, a compile-time error occurs.

There are two kinds of condition. If the text between the parentheses consists of a sequence of digits, then the condition is satisfied if the capturing subpattern of that number has previously matched. Consider the following pattern, which contains non-significant white space to make it more readable (assume the PCRE_EXTENDED option) and to divide it into three parts for ease of discussion: ( \( )? [^()]+ (?(1) \) )

The first part matches an optional opening parenthesis, and if that character is present, sets it as the first captured substring. The second part matches one or more characters that are not parentheses. The third part is a conditional subpattern that tests whether the first set of parentheses matched or not. If they did, that is, if subject started with an opening parenthesis, the condition is TRUE, and so the yes-pattern is executed and a closing parenthesis is required. Otherwise, since no-pattern is not present, the subpattern matches nothing. In other words, this pattern matches a sequence of non-parentheses, optionally enclosed in parentheses.

If the condition is not a sequence of digits, it must be an assertion. This may be a positive or negative lookahead or lookbehind assertion. Consider this pattern, again containing non-significant white space, and with the two alternatives on the second line:

(?(?=[^a-z]*[a-z])
\d{2}-[a-z]{3}-\d{2} | \d{2}-\d{2}-\d{2} )

The condition is a positive lookahead assertion that matches an optional sequence of non-letters followed by a letter. In other words, it tests for the presence of at least one letter in the subject. If a letter is found, the subject is matched against the first alternative; otherwise it is matched against the second. This pattern matches strings in one of the two forms dd-aaa-dd or dd-dd-dd, where aaa are letters and dd are digits.

주석

The sequence (?# marks the start of a comment which continues up to the next closing parenthesis. Nested parentheses are not permitted. The characters that make up a comment play no part in the pattern matching at all.

If the PCRE_EXTENDED option is set, an unescaped # character outside a character class introduces a comment that continues up to the next newline character in the pattern.

재귀 패턴

Consider the problem of matching a string in parentheses, allowing for unlimited nested parentheses. Without the use of recursion, the best that can be done is to use a pattern that matches up to some fixed depth of nesting. It is not possible to handle an arbitrary nesting depth. Perl 5.6 has provided an experimental facility that allows regular expressions to recurse (among other things). The special item (?R) is provided for the specific case of recursion. This PCRE pattern solves the parentheses problem (assume the PCRE_EXTENDED option is set so that white space is ignored): \( ( (?>[^()]+) | (?R) )* \)

First it matches an opening parenthesis. Then it matches any number of substrings which can either be a sequence of non-parentheses, or a recursive match of the pattern itself (i.e. a correctly parenthesized substring). Finally there is a closing parenthesis.

This particular example pattern contains nested unlimited repeats, and so the use of a once-only subpattern for matching strings of non-parentheses is important when applying the pattern to strings that do not match. For example, when it is applied to (aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa() it yields "no match" quickly. However, if a once-only subpattern is not used, the match runs for a very long time indeed because there are so many different ways the + and * repeats can carve up the subject, and all have to be tested before failure can be reported.

The values set for any capturing subpatterns are those from the outermost level of the recursion at which the subpattern value is set. If the pattern above is matched against (ab(cd)ef) the value for the capturing parentheses is "ef", which is the last value taken on at the top level. If additional parentheses are added, giving \( ( ( (?>[^()]+) | (?R) )* ) \) then the string they capture is "ab(cd)ef", the contents of the top level parentheses. If there are more than 15 capturing parentheses in a pattern, PCRE has to obtain extra memory to store data during a recursion, which it does by using pcre_malloc, freeing it via pcre_free afterwards. If no memory can be obtained, it saves data for the first 15 capturing parentheses only, as there is no way to give an out-of-memory error from within a recursion.

성능

패턴에 사용하는 몇몇 항목은 다른 항목에 비해서 더욱 효율적입니다. (a|e|i|o|u)처럼 선택을 설정하는 것 보다 [aeiou]처럼 문자 클래스를 사용하는 편이 더욱 효율적입니다. 보통, 요구하는 행동을 제공하는 가장 간단한 구조가 가장 효율적입니다. Jeffrey Friedl의 책은 효율적인 성능을 위한 정규표현식 최적화에 관한 많은 내용을 담고 있습니다.

When a pattern begins with .* and the PCRE_DOTALL option is set, the pattern is implicitly anchored by PCRE, since it can match only at the start of a subject string. However, if PCRE_DOTALL is not set, PCRE cannot make this optimization, because the . metacharacter does not then match a newline, and if the subject string contains newlines, the pattern may match from the character immediately following one of them instead of from the very start. For example, the pattern (.*) second matches the subject "first\nand second" (where \n stands for a newline character) with the first captured substring being "and". In order to do this, PCRE has to retry the match starting after every newline in the subject.

If you are using such a pattern with subject strings that do not contain newlines, the best performance is obtained by setting PCRE_DOTALL, or starting the pattern with ^.* to indicate explicit anchoring. That saves PCRE from having to scan along the subject looking for a newline to restart at.

Beware of patterns that contain nested indefinite repeats. These can take a long time to run when applied to a string that does not match. Consider the pattern fragment (a+)*

This can match "aaaa" in 33 different ways, and this number increases very rapidly as the string gets longer. (The * repeat can match 0, 1, 2, 3, or 4 times, and for each of those cases other than 0, the + repeats can match different numbers of times.) When the remainder of the pattern is such that the entire match is going to fail, PCRE has in principle to try every possible variation, and this can take an extremely long time.

An optimization catches some of the more simple cases such as (a+)*b where a literal character follows. Before embarking on the standard matching procedure, PCRE checks that there is a "b" later in the subject string, and if there is not, it fails the match immediately. However, when there is no following literal this optimization cannot be used. You can see the difference by comparing the behaviour of (a+)*\d with the pattern above. The former gives a failure almost instantly when applied to a whole line of "a" characters, whereas the latter takes an appreciable time with strings longer than about 20 characters.

이전 | 처음으로 | 다음
패턴 변경자 | 위로 | preg_grep


preg_grep

(PHP 4 , PHP 5)

preg_grep -- 패턴 매치의 배열을 반환합니다.

설명

array preg_grep ( string pattern, array input [, int flags])

preg_grep()은 주어진 pattern에 매치되는 input 배열의 요소를 포함하는 배열을 반환합니다.

PHP 4.0.4부터, preg_grep()가 반환하는 결과는 입력 배열의 키를 사용합니다. 이 작동이 적합하다고 생각하지 않으면, preg_grep()이 반환한 배열에 array_values()를 사용해서 값을 인덱싱하십시오.

flags에는 다음 플래그를 지정할 수 있습니다:

PREG_GREP_INVERT

이 플래그를 넘기면, preg_grep()은 주어진 pattern에 매치하지 않는 입력 배열의 원소를 반환합니다. 이 플래그는 PHP 4.2.0부터 사용할 수 있습니다.

예 1. preg_grep() 예제

<?php
// 실수를 포함하는 모든 배열 요소를 반환합니다.
$fl_array = preg_grep("/^(\d+)?\.\d+$/", $array);
?>

이전 | 처음으로 | 다음
패턴 문법 | 위로 | preg_match_all


preg_match_all

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

preg_match_all -- 전역 정규 표현식 매치를 수행합니다.

설명

int preg_match_all ( string pattern, string subject, array matches [, int flags [, int offset]])

pattern에 주어진 정규 표현식으로 subject에서 모든 매치를 찾아내고, flags에 지정한 방법에 따라서 matches에 넣습니다.

처음 매치가 발견된 후, 이후 검색은 마지막 매치의 끝에서부터 이루어집니다.

flags는 다음 플래그들을 조합할 수 있습니다 (PREG_PATTERN_ORDER와 PREG_SET_ORDER를 동시에 사용하지 마십시오):

PREG_PATTERN_ORDER

$matches[0] 배열이 전체 패턴을 가지고, $matches[1] 배열부터 괄호 안의 서브 패턴을 가지도록 결과를 지정합니다.

<?php
preg_match_all("|<[^>]+>(.*)</[^>]+>|U",
    "<b>example: </b><div align=left>this is a test</div>",
    $out, PREG_PATTERN_ORDER);
echo $out[0][0].", ".$out[0][1]."\n";
echo $out[1][0].", ".$out[1][1]."\n";
?>

이 예제의 결과:

<b>example: </b>, <div align=left>this is a test</div>
example: , this is a test

$out[0]는 전체 패턴의 문자열 배열을 가지고, $out[1]은 태그 안의 문자열 배열을 가집니다.

PREG_SET_ORDER

$matchs[0]가 처음 매치의 배열을 가지도록 하고, $matches[1]가 두번째 매치의 배열을 가지도록 결과를 지정합니다.

<?php
preg_match_all("|<[^>]+>(.*)</[^>]+>|U",
    "<b>example: </b><div align=left>this is a test</div>",
    $out, PREG_SET_ORDER);
echo $out[0][0].", ".$out[0][1]."\n";
echo $out[1][0].", ".$out[1][1]."\n";
?>

이 예제의 결과:

<b>example: </b>, example:
<div align="left">this is a test</div>, this is a test

이 경우에는, $matches[0]는 처음 매치의 집합으로, $matches[0][0]는 전체 패턴을 가지고, $matches[0][1]부터 처음 서브 패턴을 가지게 됩니다. 동일하게, $matches[1]는 두번째 매치의 집합입니다.

PREG_OFFSET_CAPTURE

이 플래그를 넘기면, 발생한 모든 매치에 대한 문자열의 시작 위치를 함께 반환합니다. 0에 매치한 문자열을, 1에 subject의 문자열 시작 위치를 가지는 배열을 원소로 하는 배열을 반환합니다. 이 플래그는 PHP 4.3.0부터 사용할 수 있습니다.

보통, 검색은 목표 문자열의 처음에서 시작합니다. 선택적인 인자 offset으로 검색을 시작할 다른 위치를 지정할 수 있습니다. 이는 preg_match()의 목표 문자열에 substr()($subject, $offset)을 넘기는 것과 동일합니다. offset 인자는 PHP 4.3.3부터 사용할 수 있습니다.

플러그가 주어지지 않으면, PREG_PATTERN_ORDER가 지정됩니다.

전체 패턴이 매치된 횟수(0이 될 수 있음)나, 에러 발생시에 FALSE를 반환합니다.

예 1. 어떤 텍스트로부터 모든 전화번호 가져오기

<?php
preg_match_all("/\(?  (\d{3})?  \)?  (?(1)  [\-\s] ) \d{3}-\d{4}/x",
               "Call 555-1212 or 1-800-555-1212", $phones);
?>

예 2. HTML 태그 찾기 (greedy)

<?php
// \\2는 역참조의 예제입니다. 이는 PCRE가 정규표현식 자체의
// 두번째 괄호를 가르키며, 이 경우에는 ([\w]+)입니다.
// 문자열이 더블 쿼터(")안에 있을 경우에는 백슬래쉬가 하나 더 필요합니다.
$html = "<b>bold text</b><a href=howdy.html>click me</a>";

preg_match_all("/(<([\w]+)[^>]*>)(.*)(<\/\\2>)/", $html, $matches);

for ($i=0; $i< count($matches[0]); $i++) {
  echo "matched: " . $matches[0][$i] . "\n";
  echo "part 1: " . $matches[1][$i] . "\n";
  echo "part 2: " . $matches[3][$i] . "\n";
  echo "part 3: " . $matches[4][$i] . "\n\n";
}
?>

이 예제의 결과:

matched: <b>bold text</b>
part 1: <b>
part 2: bold text
part 3: </b>

matched: <a href=howdy.html>click me</a>
part 1: <a href=howdy.html>
part 2: click me
part 3: </a>

참고: preg_match(),
preg_replace(),
preg_split().

이전 | 처음으로 | 다음
preg_grep | 위로 | preg_match


preg_match

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

preg_match -- 정규표현식 매치를 수행합니다.

설명

int preg_match ( string pattern, string subject [, array matches [, int flags [, int offset]]])

pattern에 주어진 정규표현식을 subject에서 찾습니다.

matches가 주어지면, 검색 결과를 채워넣습니다. $matches[0]는 전체 패턴 텍스트가 들어가고, $matches[1]부터 괄호로 둘러싸인 서브 패턴을 채워넣습니다.

flags는 다음과 같은 플래그를 사용할 수 있습니다:

PREG_OFFSET_CAPTURE

이 플래그를 넘기면, 모든 매치에 대한 문자열 시작 위치를 함께 반환합니다. 반환값을 0에 매치한 문자열을 가지고, 1에 문자열 시작 위치를 가지는 배열을 원소로 갖는 배열로 변경하는 점에 주의하십시오. 이 플래그는 PHP 4.3.0부터 사용할 수 있습니다.

flags 인자는 PHP 4.3.0부터 사용할 수 있습니다.

보통, 검색은 목표 문자열의 처음에서 시작합니다. 선택적인 인자 offset으로 검색을 시작할 다른 위치를 지정할 수 있습니다. 이는 preg_match()의 목표 문자열에 substr()($subject, $offset)을 넘기는 것과 동일합니다. offset 인자는 PHP 4.3.3부터 사용할 수 있습니다.

preg_match()는 pattern이 매치된 횟수를 반환합니다. 이는 0(매치 없음)이나 1입니다. preg_match()는 처음 매치 후에 검색을 중지하기 때문입니다. 대조적으로, preg_match_all()는 subject의 끝까지 계속해서 실행합니다. 에러가 발생하면, preg_match()는 FALSE를 반환합니다.

작은 정보: 단순히 하나의 문자열이 다른 문자열에 들어있는지를 확인하고 싶을때는 preg_match()를 사용하지 마십시오. 대신, strpos()나 strstr()를 사용하는 편이 더욱 빠릅니다.

예 1. 문자열 "php" 찾기

<?php
// 패턴 구분자 뒤의 "i"는 대소문자를 구별하지 않게 합니다.
if (preg_match("/php/i", "PHP is the web scripting language of choice.")) {
    echo "발견하였습니다.";
} else {
    echo "발견하지 못했습니다.";
}
?>

예 2. 단어 "Web" 찾기

<?php
/* 패턴에서 \b는 단어를 지시합니다. 단어 "web"만 매치하고,
* "webbing"이나 "cobweb" 등의 부분적인 경우에는 매치하지 않습니다. */
if (preg_match("/\bweb\b/i", "PHP is the web scripting language of choice.")) {
    echo "발견하였습니다.";
} else {
    echo "발견하지 못했습니다.";
}

if (preg_match("/\bweb\b/i", "PHP is the website scripting language of choice.")) {
    echo "발견하였습니다.";
} else {
    echo "발견하지 못했습니다.";
}
?>

예 3. URL에서 도메인 이름 얻기

<?php
// URL에서 호스트 이름 얻기
preg_match("/^(http:\/\/)?([^\/]+)/i",
    "http://www.php.net/index.html", $matches);
$host = $matches[2];

// 호스트 이름에서 마지막 두 세그멘트 얻기
preg_match("/[^\.\/]+\.[^\.\/]+$/", $host, $matches);
echo "도메인 이름은: {$matches[0]}\n";
?>

이 예제의 결과:

도메인 이름은: php.net

참고: preg_match_all(),
preg_replace(),
preg_split().

이전 | 처음으로 | 다음
preg_match_all | 위로 | preg_quote


preg_quote

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

preg_quote -- 정규 표현식 문자를 인용합니다.

설명

string preg_quote ( string str [, string delimiter])

preg_quote()는 str에서 정규 표현식 문법에 포함되는 모든 문자의 앞에 백슬래쉬를 덧붙입니다. 어떠한 텍스트에 특수 정규 표현식 문자를 포함하는 런타임 문자열을 처리할 때 유용합니다.

delimiter를 정의하면, 그 문자들도 이스케이프합니다. PCRE 함수에서 요구하는 구분자를 이스케이프 할 때 유용합니다. /는 가장 널리 사용되는 구분자입니다.

특수 정규 표현식 문자: . \\ + * ? [ ^ ] $ ( ) { } = ! < > | :

예 1. preg_quote() 예제

<?php
$keywords = "$40 for a g3/400";
$keywords = preg_quote($keywords, "/");
echo $keywords; // \$40 for a g3\/400 를 반환합니다.
?>

예 2. 텍스트 안의 단어를 이탤릭체로

<?php
// 이 예제에서, preg_quote($word)는 정규 표현식에서
// 특별한 의미를 지니는 별표(*)의 처리에 사용됩니다.

$textbody = "This book is *very* difficult to find.";
$word = "*very*";
$textbody = preg_replace("/" . preg_quote($word) . "/",
                         "<i>" . $word . "</i>",
                         $textbody);
?>

이전 | 처음으로 | 다음
preg_match | 위로 | preg_replace_callback


preg_replace_callback

(PHP 4 >= 4.0.5, PHP 5)

preg_replace_callback -- 콜백을 이용한 정규 표현식 검색과 치환을 수행합니다.

설명

mixed preg_replace_callback ( mixed pattern, callback callback, mixed subject [, int limit])

이 함수의 작동은 replacement 대신 callback를 지정하는 것을 제외하면, preg_replace()와 거의 동일합니다. callback는 주어진 문자열에 매치되는 요소의 배열을 콜해서 넘깁니다. 콜백은 치환된 문자열을 반환해야 합니다.

예 1. preg_replace_callback() 예제

<?php
  // 이 문장은 2002년에 사용되었습니다.
  // 2003년에 적합하게 업데이트합니다.
  $text = "April fools day is 04/01/2002\n";
  $text.= "Last christmas was 12/24/2001\n";

  // 콜백 함수
  function next_year($matches)
  {
    // 보통: $matches[0]는 전채 매치입니다.
    // $matches[1]은 첫번째 '(...)'에 들어있는
    // 서브 패턴 매치로 이어집니다.
    return $matches[1].($matches[2]+1);
  }

  echo preg_replace_callback(
              "|(\d{2}/\d{2}/)(\d{4})|",
              "next_year", $text);

  // 결과는:
  // April fools day is 04/01/2003
  // Last christmas was 12/24/2002
?>

종종 단 한번의 preg_replace_callback()에서 사용하기 위한 callback 함수가 필요합니다. 이 경우에, create_function()을 사용해서 preg_replace_callback() 호출 안에서 익명의 함수를 만들 수 있습니다. 이 방법으로 호출에 필요한 모든 정보를 한군데에 위치하게 하여, 다른곳에서 사용되지 않는 콜백함수의 네임스페이스를 절약할 수 있습니다.

예 2. preg_replace_callback()과 create_function()

<?php
  /* 문단 첫번째의 대문자를 소문자로 변경하는
   * 유닉스 스타일 명령줄 필터 */

  $fp = fopen("php://stdin", "r") or die("can't read stdin");
  while (!feof($fp)) {
      $line = fgets($fp);
      $line = preg_replace_callback(
          '|<p>\s*\w|',
          create_function(
              // 여기에선 싱글 쿼트(')가 적합합니다.
              // 그렇지 않으면 모든 $를 \$로 이스케이프 해야합니다.
              '$matches',
              'return strtolower($matches[0]);'
          ),
          $line
      );
      echo $line;
  }
  fclose($fp);
?>

참고: preg_replace(), create_function().

이전 | 처음으로 | 다음
preg_quote | 위로 | preg_replace


preg_replace

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

preg_replace -- 정규 표현식 검색과 치환을 수행합니다.

설명

mixed preg_replace ( mixed pattern, mixed replacement, mixed subject [, int limit])

subject를 검색하여 매치된 pattern을 replacement로 치환합니다. limit가 지정되면, limit회의 매치만을 치환합니다; limit가 -1라면, 모든 매치를 치환합니다.

Replacement는 \\n나 (PHP 4.0.4부터) $n 형태의 참조를 포함할 수 있습니다. 그러한 모든 참조는 n번째로 잡힌 괄호 패턴으로 대체됩니다. n은 0에서 99까지 가능하고, \\0나 $0는 전체 패턴에 매치된 텍스트를 의미합니다. 괄호를 여는것은 서브패턴을 포함하여 왼쪽에서 오른쪽(1로부터 시작)으로 카운트합니다.

역참조 바로 뒤에 다른 숫자가 따라오는 패턴을 사용할 때는(즉, 매치된 패턴 바로 뒤에 수 문자가 위치), \\1 식의 역참조를 사용할 수 없습니다. 예를 들면, \\11은 preg_replace()에서 문자 1이 따라오는 역참조 \\1인지, 역참조 \\1인지를 구분할 수 없습니다. 이 경우, 해결책은 \${1}1를 사용합니다. 이는 독립된 역참조 $1를 작성하고, 1을 문자로 남겨놓습니다.

예 1. 숫자에 대해 역참조 사용하기

<?php
$string = "April 15, 2003";
$pattern = "/(\w+) (\d+), (\d+)/i";
$replacement = "\${1}1,\$3";
echo preg_replace($pattern, $replacement, $string);
?>

이 예제의 출력은:

April1,2003

매치가 발견되면, 변환된 subject를 반환하고, 그렇지 않으면 변경되지 않은 subject를 반환합니다.

(limit를 제외한) preg_replace()의 모든 인자에는 일차원 배열을 사용할 수 있습니다. pattern과 replacement에 배열을 사용할 때는, 배열에 나타나는 순서대로 키를 생성합니다. 똑같은 숫자 인덱스 순서를 가질 필요가 없습니다. 어떤 pattern을 어떠한 replacement로 교체할건지를 결정하기 위해서는, preg_replace()를 호출하기 전에 각각의 배열에 ksort()를 실행해야만 합니다.

예 2. 정렬을 통해 preg_replace() 사용하기

<?php
$string = "The quick brown fox jumped over the lazy dog.";

$patterns[0] = "/quick/";
$patterns[1] = "/brown/";
$patterns[2] = "/fox/";

$replacements[2] = "bear";
$replacements[1] = "black";
$replacements[0] = "slow";

echo preg_replace($patterns, $replacements, $string);
?>

출력:

The bear black slow jumped over the lazy dog.

patterns와 replacemets를 ksort함으로써, 원하던 결과를 얻게 됩니다.

<?php
ksort($patterns);
ksort($replacements);

echo preg_replace($patterns, $replacements, $string);
?>

출력:

The slow black bear jumped over the lazy dog.

subject가 배열이면, subject의 모든 엔트리에 검색과 교체를 실행하고, 배열을 반환합니다.

pattern과 replacement가 배열이면, preg_replace()는 각각의 배열에서 값을 가져와서 subject를 검색하고 치환하는데에 이용합니다. replacement가 pattern보다 적으면, 대응하는 치환값으로 빈 문자열을 사용합니다. pattern 이 배열이고 replacement가 문자열이면, 치환 문자열을 모든 pattern값에 사용합니다. 물론, 이 경우들의 반대는 말이 안됩니다.

/e 변경자는 preg_replace()가 replacement 인자를 참조 치환을 한 후에 PHP 코드로 취급합니다. 팁: replacement가 정상적인 PHP 코드 문자열을 가지게 하십시오. 그렇지 않으면, PHP는 preg_replace()를 포함하는 줄에서 파싱 에러를 출력합니다.

예 3. 여러 값을 치환하기

<?php
$patterns = array ("/(19|20)(\d{2})-(\d{1,2})-(\d{1,2})/",
                   "/^\s*{(\w+)}\s*=/");
$replace = array ("\\3/\\4/\\1\\2", "$\\1 =");
echo preg_replace($patterns, $replace, "{startDate} = 1999-5-27");
?>

이 예제의 결과:

$startDate = 5/27/1999

예 4. /e 변경자 사용하기

<?php
preg_replace("/(<\/?)(\w+)([^>]*>)/e",
             "'\\1'.strtoupper('\\2').'\\3'",
             $html_body);
?>

입력된 텍스트의 모든 HTML 태그를 대문자로 변경합니다.

예 5. HTML을 텍스트로 변환하기

<?php
// $document는 HTML 문서를 포함합니다.
// 이는 HTML 태그, 자바스크립트 섹션, 공백을
// 제거합니다. 또한, 몇몇 일반적인 HTML 엔티티를
// 동일한 텍스트로 변환합니다.

$search = array ("'<script[^>]*?>.*?</script>'si",  // 자바 스크립트 제거
                 "'<[\/\!]*?[^<>]*?>'si",           // HTML 태그 제거
                 "'([\r\n])[\s]+'",                 // 공백 제거
                 "'&(quot|#34);'i",                 // HTML 엔티티 치환
                 "'&(amp|#38);'i",
                 "'&(lt|#60);'i",
                 "'&(gt|#62);'i",
                 "'&(nbsp|#160);'i",
                 "'&(iexcl|#161);'i",
                 "'&(cent|#162);'i",
                 "'&(pound|#163);'i",
                 "'&(copy|#169);'i",
                 "'&#(\d+);'e");                    // php로 실행

$replace = array ("",
                  "",
                  "\\1",
                  "\"",
                  "&",
                  "<",
                  ">",
                  " ",
                  chr(161),
                  chr(162),
                  chr(163),
                  chr(169),
                  "chr(\\1)");

$text = preg_replace($search, $replace, $document);
?>

참고: limit 인자는 PHP 4.0.1pl2 이후에 추가되었습니다.

참고: preg_match(),
preg_match_all(),
preg_split().

이전 | 처음으로 | 다음
preg_replace_callback | 위로 | preg_split


preg_split

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

preg_split -- 정규 표션식에 따라 문자열을 나눕니다.

설명

array preg_split ( string pattern, string subject [, int limit [, int flags]])

pattern에 매치된 경계에 따라서 나눠진 subject의 문자열을 포함하는 배열을 반환합니다.

limit를 지정하면, limit 횟수까지의 나눠진 문자열을 반환하며, limit가 -1이면 "무제한"을 의미합니다. 이 값은 flags를 지정할 때 유용합니다.

flags는 다음 플래그들의 조합을 사용할 수 있습니다 (bitwise | 연산자로 결합합니다) :

PREG_SPLIT_NO_EMPTY

이 플래그를 설정하면, preg_split()에 의해 비어있지 않은 (non-empty) 조각만을 반환합니다.

PREG_SPLIT_DELIM_CAPTURE

이 플래그를 설정하면, delimiter 패턴 안의 서브패턴도 검출하고 반환합니다. 이 플래그는 4.0.5에서 추가되었습니다.

PREG_SPLIT_OFFSET_CAPTURE

이 플래그를 설정하면, 문자열의 시작 위치도 반환합니다. 반환값이 매치된 문자열을 오프셋 0으로, 문자열 시작 위치를 오프셋 1로 가지는 배열을 원소로 갖는 배열로 변하는 점에 주의하십시오. 이 플래그는 PHP 4.3.0부터 사용할 수 있습니다.

예 1. preg_split() 예제 : 검색 문자열의 일부만을 얻기

<?php
// " ", \r, \t, \n, \f를 포함하여
// 임의 갯수의 콤마와 스페이스로 구문을 나눕니다.
$keywords = preg_split("/[\s,]+/", "hypertext language, programming");
?>

예 2. 문자열을 구성 문자로 나누기.

<?php
$str = 'string';
$chars = preg_split('//', $str, -1, PREG_SPLIT_NO_EMPTY);
print_r($chars);
?>

예 3. 매치와 시작위치로 문자열을 나누기.

<?php
$str = 'hypertext language programming';
$chars = preg_split('/ /', $str, -1, PREG_SPLIT_OFFSET_CAPTURE);
print_r($chars);
?>

결과는:

Array
(
    [0] => Array
        (
            [0] => hypertext
            [1] => 0
        )

    [1] => Array
        (
            [0] => language
            [1] => 10
        )

    [2] => Array
        (
            [0] => programming
            [1] => 19
        )

)

참고: flags인자는 PHP 4 베타 3에서 추가되었습니다.

참고: spliti(), split(),
implode(), preg_match(),
preg_match_all(), preg_replace().

이전 | 처음으로 | 다음
preg_replace | 위로 | qtdom Functions


qtdom Functions

PHP 매뉴얼
이전 다음

XCII. qtdom Functions

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

참고: 이 확장 모듈은 윈도우 플랫폼에서는 사용할 수 없습니다.

참고: 이 확장 모듈은 PHP 5에서 제거되어, PECL로 이동되었습니다.

요구 사항

You need the Qt-library >=2.2.0

설치

Configure PHP --with-qtdom to use these functions.

차례
qdom_error -- Returns the error string from the last QDOM operation or FALSE if no errors occurred
qdom_tree -- Creates a tree of an XML string

이전 | 처음으로 | 다음
preg_split | 위로 | qdom_error


qdom_error

(PHP 4 >= 4.0.5)

qdom_error -- Returns the error string from the last QDOM operation or FALSE if no errors occurred

Description

string qdom_error ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
qtdom Functions | 위로 | qdom_tree


qdom_tree

(PHP 4 >= 4.0.4)

qdom_tree -- Creates a tree of an XML string

Description

object qdom_tree ( string )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
qdom_error | 위로 | Regular Expression Functions (POSIX Extended)


Regular Expression Functions (POSIX Extended)

PHP 매뉴얼
이전 다음

XCIII. Regular Expression Functions (POSIX Extended)

소개

작은 정보: PHP also supports regular expressions using a Perl-compatible syntax using the PCRE functions. Those functions support non-greedy matching, assertions, conditional subpatterns, and a number of other features not supported by the POSIX-extended regular expression syntax.

주의

These regular expression functions are not binary-safe. The PCRE functions are.

Regular expressions are used for complex string manipulation in PHP. The functions that support regular expressions are:

  • ereg()

  • ereg_replace()

  • eregi()

  • eregi_replace()

  • split()

  • spliti()

These functions all take a regular expression string as their first argument. PHP uses the POSIX extended regular expressions as defined by POSIX 1003.2. For a full description of POSIX regular expressions see the regex man pages included in the regex directory in the PHP distribution. It's in manpage format, so you'll want to do something along the lines of man /usr/local/src/regex/regex.7 in order to read it.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

주의

Do not change the TYPE unless you know what you are doing.

To enable regexp support configure PHP --with-regex[=TYPE]. TYPE can be one of system, apache, php. The default is to use php.

PHP 윈도우 버전에서는 이 확장 모듈에 대한 지원이 포함되어 있습니다. 이 함수들을 이용하기 위해서 추가로 확장 모듈을 읽어들일 필요가 없습니다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

예제

예 1. Regular Expression Examples

<?php
// Returns true if "abc" is found anywhere in $string.
ereg("abc", $string);

// Returns true if "abc" is found at the beginning of $string.
ereg("^abc", $string);

// Returns true if "abc" is found at the end of $string.
ereg("abc$", $string);

// Returns true if client browser is Netscape 2, 3 or MSIE 3.
eregi("(ozilla.[23]|MSIE.3)", $HTTP_USER_AGENT);

// Places three space separated words into $regs[1], $regs[2] and $regs[3].
ereg("([[:alnum:]]+) ([[:alnum:]]+) ([[:alnum:]]+)", $string, $regs);

// Put a <br /> tag at the beginning of $string.
$string = ereg_replace("^", "<br />", $string);

// Put a <br /> tag at the end of $string.
$string = ereg_replace("$", "<br />", $string);

// Get rid of any newline characters in $string.
$string = ereg_replace("\n", "", $string);
?>

참고

For regular expressions in Perl-compatible syntax have a look at the PCRE functions. The simpler shell style wildcard pattern matching is provided by fnmatch().

차례
ereg_replace -- Replace regular expression
ereg -- Regular expression match
eregi_replace -- replace regular expression case insensitive
eregi -- case insensitive regular expression match
split -- split string into array by regular expression
spliti -- Split string into array by regular expression case insensitive
sql_regcase -- Make regular expression for case insensitive match

이전 | 처음으로 | 다음
qdom_tree | 위로 | ereg_replace


ereg_replace

(PHP 3, PHP 4 , PHP 5)

ereg_replace -- Replace regular expression

Description

string ereg_replace ( string pattern, string replacement, string string)

This function scans string for matches to pattern, then replaces the matched text with replacement.

The modified string is returned. (Which may mean that the original string is returned if there are no matches to be replaced.)

If pattern contains parenthesized substrings, replacement may contain substrings of the form \\digit, which will be replaced by the text matching the digit'th parenthesized substring; \\0 will produce the entire contents of string. Up to nine substrings may be used. Parentheses may be nested, in which case they are counted by the opening parenthesis.

If no matches are found in string, then string will be returned unchanged.

For example, the following code snippet prints "This was a test" three times:

예 1. ereg_replace() example

<?php

$string = "This is a test";
echo str_replace(" is", " was", $string);
echo ereg_replace("( )is", "\\1was", $string);
echo ereg_replace("(( )is)", "\\2was", $string);

?>

One thing to take note of is that if you use an integer value as the replacement parameter, you may not get the results you expect. This is because ereg_replace() will interpret the number as the ordinal value of a character, and apply that. For instance:

예 2. ereg_replace() example

<?php
/* This will not work as expected. */
$num = 4;
$string = "This string has four words.";
$string = ereg_replace('four', $num, $string);
echo $string;   /* Output: 'This string has   words.' */

/* This will work. */
$num = '4';
$string = "This string has four words.";
$string = ereg_replace('four', $num, $string);
echo $string;   /* Output: 'This string has 4 words.' */
?>

예 3. Replace URLs with links

<?php
$text = ereg_replace("[[:alpha:]]+://[^<>[:space:]]+[[:alnum:]/]",
                     "<a href=\"\\0\">\\0</a>", $text);
?>

작은 정보: preg_replace(), which uses a Perl-compatible regular expression syntax, is often a faster alternative to ereg_replace().

See also ereg(), eregi(),
eregi_replace(), str_replace(), and
preg_match().

이전 | 처음으로 | 다음
Regular Expression Functions (POSIX Extended) | 위로 | ereg


ereg

(PHP 3, PHP 4 , PHP 5)

ereg -- Regular expression match

Description

bool ereg ( string pattern, string string [, array regs])

참고: preg_match(), which uses a Perl-compatible regular expression syntax, is often a faster alternative to ereg().

Searches a string for matches to the regular expression given in pattern in a case-sensitive way.

If matches are found for parenthesized substrings of pattern and the function is called with the third argument regs, the matches will be stored in the elements of the array regs. $regs[1] will contain the substring which starts at the first left parenthesis; $regs[2] will contain the substring starting at the second, and so on. $regs[0] will contain a copy of the complete string matched.

참고: Up to (and including) PHP 4.1.0 $regs will be filled with exactly ten elements, even though more or fewer than ten parenthesized substrings may actually have matched. This has no effect on ereg()'s ability to match more substrings. If no matches are found, $regs will not be altered by ereg().

Returns TRUE if a match for pattern was found in string, or FALSE if no matches were found or an error occurred.

The following code snippet takes a date in ISO format (YYYY-MM-DD) and prints it in DD.MM.YYYY format:

예 1. ereg() example

<?php
if (ereg ("([0-9]{4})-([0-9]{1,2})-([0-9]{1,2})", $date, $regs)) {
    echo "$regs[3].$regs[2].$regs[1]";
} else {
    echo "Invalid date format: $date";
}
?>

See also eregi(), ereg_replace(),
eregi_replace(), preg_match(),
strpos(), and strstr().

이전 | 처음으로 | 다음
ereg_replace | 위로 | eregi_replace


eregi_replace

(PHP 3, PHP 4 , PHP 5)

eregi_replace -- replace regular expression case insensitive

Description

string eregi_replace ( string pattern, string replacement, string string)

This function is identical to ereg_replace() except that this ignores case distinction when matching alphabetic characters.

See also ereg(), eregi(), and ereg_replace().

이전 | 처음으로 | 다음
ereg | 위로 | eregi


eregi

(PHP 3, PHP 4 , PHP 5)

eregi -- case insensitive regular expression match

Description

bool eregi ( string pattern, string string [, array regs])

This function is identical to ereg() except that this ignores case distinction when matching alphabetic characters.

예 1. eregi() example

<?php
if (eregi("z", $string)) {
    echo "'$string' contains a 'z' or 'Z'!";
}
?>

See also ereg(), ereg_replace(),
eregi_replace(), stripos(), and
stristr().

이전 | 처음으로 | 다음
eregi_replace | 위로 | split


split

(PHP 3, PHP 4 , PHP 5)

split -- split string into array by regular expression

Description

array split ( string pattern, string string [, int limit])

작은 정보: preg_split(), which uses a Perl-compatible regular expression syntax, is often a faster alternative to split(). If you don't require the power of regular expressions, it is faster to use explode(), which doesn't incur the overhead of the regular expression engine.

Returns an array of strings, each of which is a substring of string formed by splitting it on boundaries formed by the case-sensitive regular expression pattern. If limit is set, the returned array will contain a maximum of limit elements with the last element containing the whole rest of string. If an error occurs, split() returns FALSE.

To split off the first four fields from a line from /etc/passwd:

예 1. split() example

<?php
list($user, $pass, $uid, $gid, $extra) =
    split(":", $passwd_line, 5);
?>

If there are n occurrences of pattern, the returned array will contain n+1 items. For example, if there is no occurrence of pattern, an array with only one element will be returned. Of course, this is also true if string is empty.

To parse a date which may be delimited with slashes, dots, or hyphens:

예 2. split() example

<?php
// Delimiters may be slash, dot, or hyphen
$date = "04/30/1973";
list($month, $day, $year) = split('[/.-]', $date);
echo "Month: $month; Day: $day; Year: $year<br />\n";
?>

For users looking for a way to emulate Perl's @chars = split('', $str) behaviour, please see the examples for preg_split().

Please note that pattern is a regular expression. If you want to split on any of the characters which are considered special by regular expressions, you'll need to escape them first. If you think split() (or any other regex function, for that matter) is doing something weird, please read the file regex.7, included in the regex/ subdirectory of the PHP distribution. It's in manpage format, so you'll want to do something along the lines of man /usr/local/src/regex/regex.7 in order to read it.

See also: preg_split(), spliti(),
explode(), implode(),
chunk_split(), and wordwrap().

이전 | 처음으로 | 다음
eregi | 위로 | spliti


spliti

(PHP 4 >= 4.0.1, PHP 5)

spliti -- Split string into array by regular expression case insensitive

Description

array spliti ( string pattern, string string [, int limit])

This function is identical to split() except that this ignores case distinction when matching alphabetic characters.

See also preg_spliti(), split(), explode(), and implode().

이전 | 처음으로 | 다음
split | 위로 | sql_regcase


sql_regcase

(PHP 3, PHP 4 , PHP 5)

sql_regcase -- Make regular expression for case insensitive match

Description

string sql_regcase ( string string)

Returns a valid regular expression which will match string, ignoring case. This expression is string with each alphabetic character converted to a bracket expression; this bracket expression contains that character's uppercase and lowercase form. Other characters remain unchanged.

예 1. sql_regcase() example

<?php
echo sql_regcase("Foo - bar.");
?>

prints:

[Ff][Oo][Oo] - [Bb][Aa][Rr].

This can be used to achieve case insensitive pattern matching in products which support only case sensitive regular expressions.

이전 | 처음으로 | 다음
spliti | 위로 | 세마포어(semaphore)와 공유 메모리(shared memory) 함수


세마포어(semaphore)와 공유 메모리(shared memory) 함수

PHP 매뉴얼
이전 다음

XCIV. 세마포어(semaphore)와 공유 메모리(shared memory) 함수

이 모듈은 System V 세마포어가 사용하는 세마포어 함수를 포함한다. 세마포어는 현재 머신에 자원을 한정적으로 접근하는데 사용되거나 프로세스가 일제히 자원을 사용하는 개수를 제한하는데 사용된다.

이 모듈은 또한 System V의 공유 메모리를 사용하기 위한 공유 메모리 함수도 포함한다. 공유 메모리는 전역 변수에 접근하는데 사용된다. 각기 다른 httpd-daemon과 다른 프로그램(Perl, C와 같은) 조차도 전역 데이터 교환을 지원하여 이 데이터를 접근할 수 있다. 주의할 점은, 공유 메모리는 동시 접근에는 안전하지 않다는 것이다. 동기화를 위해서는 세마포어를 사용하면 된다.

표 1. Unix OS에 의한 공유 메모리의 제한

SHMMAX | 공유 메모리의 최대값, 보통 131072 바이트임.
SHMMIN | 공유 메모리의 최소값, 보통 1바이트임.
SHMMNI | 시스템 상의 공유 메모리 세그먼트의 최대 합계, 보통 100임.
SHMSEG | 프로세서당 공유 메모리 세그먼트의 최대 합계, 보통 6임.

참고: 이 함수는 윈도우즈 시스템에서 동작하지 않는다.

차례
ftok -- Convert a pathname and a project identifier to a System V IPC key
msg_get_queue -- Create or attach to a message queue
msg_receive -- Receive a message from a message queue
msg_remove_queue -- Destroy a message queue
msg_send -- Send a message to a message queue
msg_set_queue -- Set information in the message queue data structure
msg_stat_queue -- Returns information from the message queue data structure
sem_acquire -- 세마포어를 획득
sem_get -- 세마포어 id를 얻음
sem_release -- 세마포어 릴리즈
sem_remove -- Remove a semaphore
shm_attach -- 공유 메모리 세그먼트를 열거나 생성
shm_detach -- 공유 메모리 세그먼트 접속을 종료
shm_get_var -- 공유 메모리로부터 변수를 반환
shm_put_var -- 공유 메모리 변수를 삽입하거나 경신
shm_remove_var -- 공유 메모리로부터 변수를 제거
shm_remove -- Unix 시스템에서 공유 메모리를 제거

이전 | 처음으로 | 다음
sql_regcase | 위로 | ftok


ftok

(PHP 4 >= 4.2.0, PHP 5)

ftok -- Convert a pathname and a project identifier to a System V IPC key

Description

int ftok ( string pathname, string proj)

The function converts the pathname of an existing accessible file and a project identifier (proj) into a integer for use with for example shmop_open() and other System V IPC keys. The proj parameter should be a one character string.

On success the return value will be the created key value, otherwise -1 is returned.

See also shmop_open() and sem_get().

이전 | 처음으로 | 다음
세마포어(semaphore)와 공유 메모리(shared memory) 함수 | 위로 | msg_get_queue


msg_get_queue

(PHP 4 >= 4.3.0, PHP 5)

msg_get_queue -- Create or attach to a message queue

Description

resource msg_get_queue ( int key [, int perms])

msg_get_queue() returns an id that can be used to access the System V message queue with the given key. The first call creates the message queue with the optional perms (default: 0666). A second call to msg_get_queue() for the same key will return a different message queue identifier, but both identifiers access the same underlying message queue. If the message queue already exists, the perms will be ignored.

See also msg_remove_queue(),
msg_receive(), msg_send(),
msg_stat_queue() and
msg_set_queue().

이전 | 처음으로 | 다음
ftok | 위로 | msg_receive


msg_receive

(PHP 4 >= 4.3.0, PHP 5)

msg_receive -- Receive a message from a message queue

Description

bool msg_receive ( resource queue, int desiredmsgtype, int msgtype, int maxsize, mixed message [, bool unserialize [, int flags [, int errorcode]]])

msg_receive() will receive the first message from the specified queue of the type specified by desiredmsgtype. The type of the message that was received will be stored in msgtype. The maximum size of message to be accepted is specified by the maxsize; if the message in the queue is larger than this size the function will fail (unless you set flags as described below). The received message will be stored in message, unless there were errors receiving the message, in which case the optional errorcode will be set to the value of the system errno variable to help you identify the cause.

If desiredmsgtype is 0, the message from the front of the queue is returned. If desiredmsgtype is greater than 0, then the first message of that type is returned. If desiredmsgtype is less than 0, the first message on the queue with the lowest type less than or equal to the absolute value of desiredmsgtype will be read. If no messages match the criteria, your script will wait until a suitable message arrives on the queue. You can prevent the script from blocking by specifying MSG_IPC_NOWAIT in the flags parameter.

unserialize defaults to TRUE; if it is set to TRUE, the message is treated as though it was serialized using the same mechanism as the session module. The message will be unserialized and then returned to your script. This allows you to easily receive arrays or complex object structures from other PHP scripts, or if you are using the WDDX serializer, from any WDDX compatible source. If unserialize is FALSE, the message will be returned as a binary-safe string.

The optional flags allows you to pass flags to the low-level msgrcv system call. It defaults to 0, but you may specify one or more of the following values (by adding or ORing them together).

표 1. Flag values for msg_receive

MSG_IPC_NOWAIT | If there are no messages of the desiredmsgtype, return immediately and do not wait. The function will fail and return an integer value corresponding to ENOMSG.
MSG_EXCEPT | Using this flag in combination with a desiredmsgtype greater than 0 will cause the function to receive the first message that is not equal to desiredmsgtype.
MSG_NOERROR | If the message is longer than maxsize, setting this flag will truncate the message to maxsize and will not signal an error.

Upon successful completion the message queue data structure is updated as follows: msg_lrpid is set to the process-ID of the calling process, msg_qnum is decremented by 1 and msg_rtime is set to the current time.

msg_receive() returns TRUE on success or FALSE on failure. If the function fails, the optional errorcode will be set to the value of the system errno variable.

See also msg_remove_queue(),
msg_send(),
msg_stat_queue() and
msg_set_queue().

이전 | 처음으로 | 다음
msg_get_queue | 위로 | msg_remove_queue


msg_remove_queue

(PHP 4 >= 4.3.0, PHP 5)

msg_remove_queue -- Destroy a message queue

Description

bool msg_remove_queue ( resource queue)

msg_remove_queue() destroys the message queue specified by the queue. Only use this function when all processes have finished working with the message queue and you need to release the system resources held by it.

See also msg_remove_queue(),
msg_receive(),
msg_stat_queue() and
msg_set_queue().

이전 | 처음으로 | 다음
msg_receive | 위로 | msg_send


msg_send

(PHP 4 >= 4.3.0, PHP 5)

msg_send -- Send a message to a message queue

Description

bool msg_send ( resource queue, int msgtype, mixed message [, bool serialize [, bool blocking [, int errorcode]]])

msg_send() sends a message of type msgtype (which MUST be greater than 0) to a the message queue specified by queue.

If the message is too large to fit in the queue, your script will wait until another process reads messages from the queue and frees enough space for your message to be sent. This is called blocking; you can prevent blocking by setting the optional blocking parameter to FALSE, in which case msg_send() will immediately return FALSE if the message is too big for the queue, and set the optional errorcode to EAGAIN, indicating that you should try to send your message again a little later on.

The optional serialize controls how the message is sent. serialize defaults to TRUE which means that the message is serialized using the same mechanism as the session module before being sent to the queue. This allows complex arrays and objects to be sent to other PHP scripts, or if you are using the WDDX serializer, to any WDDX compatible client.

Upon successful completion the message queue data structure is updated as follows: msg_lspid is set to the process-ID of the calling process, msg_qnum is incremented by 1 and msg_stime is set to the current time.

See also msg_remove_queue(),
msg_receive(),
msg_stat_queue() and
msg_set_queue().

이전 | 처음으로 | 다음
msg_remove_queue | 위로 | msg_set_queue


msg_set_queue

(PHP 4 >= 4.3.0, PHP 5)

msg_set_queue -- Set information in the message queue data structure

Description

bool msg_set_queue ( resource queue, array data)

msg_set_queue() allows you to change the values of the msg_perm.uid, msg_perm.gid, msg_perm.mode and msg_qbytes fields of the underlying message queue data structure. You specify the values you require by setting the value of the keys that you require in the data array.

Changing the data structure will require that PHP be running as the same user that created the queue, owns the queue (as determined by the existing msg_perm.xxx fields), or be running with root privileges. root privileges are required to raise the msg_qbytes values above the system defined limit.

See also msg_remove_queue(),
msg_receive(),
msg_stat_queue() and
msg_set_queue().

이전 | 처음으로 | 다음
msg_send | 위로 | msg_stat_queue


msg_stat_queue

(PHP 4 >= 4.3.0, PHP 5)

msg_stat_queue -- Returns information from the message queue data structure

Description

array msg_stat_queue ( resource queue)

msg_stat_queue() returns the message queue meta data for the message queue specified by the queue. This is useful, for example, to determine which process sent the message that was just received.

The return value is an array whose keys and values have the following meanings:

표 1. Array structure for msg_stat_queue

msg_perm.uid | The uid of the owner of the queue.
msg_perm.gid | The gid of the owner of the queue.
msg_perm.mode | The file access mode of the queue.
msg_stime | The time that the last message was sent to the queue.
msg_rtime | The time that the last message was received from the queue.
msg_ctime | The time that the queue was last changed.
msg_qnum | The number of messages waiting to be read from the queue.
msg_qbytes | The number of bytes of space currently available in the queue to hold sent messages until they are received.
msg_lspid | The pid of the process that sent the last message to the queue.
msg_lrpid | The pid of the process that received the last message from the queue.

See also msg_remove_queue(),
msg_receive(),
msg_stat_queue() and
msg_set_queue().

이전 | 처음으로 | 다음
msg_set_queue | 위로 | sem_acquire


sem_acquire

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

sem_acquire -- 세마포어를 획득

설명

int sem_acquire ( int sem_identifier)

반환값: 성공하면 TRUE, 실패하면 에러를 출력한다.

sem_acquire()함수는 (만일 필요하다면)세마포어를 획득할 수 있을 때까지 막는다. 이미 획득된 세마포어를 획득하려는 프로세서가 세마포어의 max_acquire를 초과한다면 영원히 중단될 것이다.

리퀘스트 처리후, 명백하게 릴리즈되지 않은 프로세서에 의해 획득된 어떤 세마포어도 자동적으로 릴리즈 되며, 경고를 발생시킬 것이다. (After processing a request, any semaphores acquired by the process but not explicitly released will be released automatically and a warning will be generated.)

참조: sem_get(), sem_release().

이전 | 처음으로 | 다음
msg_stat_queue | 위로 | sem_get


sem_get

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

sem_get -- 세마포어 id를 얻음

설명

int sem_get ( int key [, int max_acquire [, int perm]])

반환값: 성공하면 실제적인 세마포어 identifier가, 실패하면 에러가 발생한다.

sem_get()는 주어진 키와 함께 System V 세마포어에 접근하는데 사용하는 id를 반환한다. 세마포어는 퍼미션에서 특정 퍼미션 비트가 사용될 필요성이 있을 때 생성된다(기본값은 0666). 세마포어가 동시에 필요로 할 수 있는 프로세서의 개수는 max_acquire(기본값은 1)로 설정할 수 있다. 실제로 이 값은 설정된다. 얻은 프로세서가 일반적으로 세마포어에 첨부된 것일 경우에만 설정한다.

동일 키로 sem_get()를 두 번 호출하면, 각기 다른 세마포어 identifier로 반환되겠지만, 양쪽 identifier들은 동일한 세마포어에서 접근이 가능하다.

참조: sem_acquire(), sem_release().

참고: 이 함수는 윈도우즈 시스템에서 동작하지 않는다.

이전 | 처음으로 | 다음
sem_acquire | 위로 | sem_release


sem_release

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

sem_release -- 세마포어 릴리즈

설명

int sem_release ( int sem_identifier)

반환값: 성공하면 TRUE, 실패하면 에러 출력.

sem_release()는 호출 과정에 의해 일반적으로 획득된 세마포어를 릴리즈한다. 그렇지 않으면, 경고를 발생시킨다.

세마포어를 릴리즈한 후, sem_acquire()함수는 이를 재획득하려고 호출될 것이다.

참조: sem_get(), sem_acquire().

참고: 이 함수는 윈도우즈 시스템에서는 동작하지 않는다.

이전 | 처음으로 | 다음
sem_get | 위로 | sem_remove


sem_remove

(PHP 4 >= 4.1.0, PHP 5)

sem_remove -- Remove a semaphore

Description

bool sem_remove ( resource sem_identifier)

sem_remove() removes the semaphore sem_identifier if it has been created by sem_get(), otherwise generates a warning.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

After removing the semaphore, it is no more accessible.

See also sem_get(),
sem_release() and
sem_acquire().

이전 | 처음으로 | 다음
sem_release | 위로 | shm_attach


shm_attach

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

shm_attach -- 공유 메모리 세그먼트를 열거나 생성

설명

int shm_attach ( int key [, int memsize [, int perm]])

shm_attach()함수는 주어진 키와 함께 System V 공유 메모리를 접근하기위해 사용되는 id를 반환한다. 첫 호출은 mem_size(기본값: 설정 파일에서의 sysvshm.init_mem 값, 그렇지 않으면, 10000 바이트)과 임의의 perm-bit(기본값: 0666)과 함께 공유 메모리 세그먼트를 생성한다.

동일한 key 인자로 shm_attach()함수의 두번째 호출은 또다른 공유 메모리 identifier를 반환할 것이다. Memsize 인자와 perm 인자는 무시될 것이다.

참고: 이 함수는 윈도우즈 시스템에서는 동작하지 않는다.

이전 | 처음으로 | 다음
sem_remove | 위로 | shm_detach


shm_detach

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

shm_detach -- 공유 메모리 세그먼트 접속을 종료

설명

int shm_detach ( int shm_identifier)

shm_detach()함수는 shm_attach()에 의해 생성되는 shm_identifier 인자에 의해 주어진 공유 메모리를 종료시킨다. 주의할 점은, 함수를 호출하더라도 Unix 시스템에서의 공유메모리는 여전히 존재하며, 데이터 역시 존재하고 있다는 것이다.

이전 | 처음으로 | 다음
shm_attach | 위로 | shm_get_var


shm_get_var

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

shm_get_var -- 공유 메모리로부터 변수를 반환

설명

mixed shm_get_var ( int id, int variable_key)

shm_get_var()함수는 variable_key 인자로 주어진 변수를 반환한다. 공유메모리에서의 변수는 여전히 존재한다.

참고: 이 함수는 윈도우즈 시스템에서는 동작하지 않는다.

이전 | 처음으로 | 다음
shm_detach | 위로 | shm_put_var


shm_put_var

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

shm_put_var -- 공유 메모리 변수를 삽입하거나 경신

설명

int shm_put_var ( int shm_identifier, int variable_key, mixed variable)

variable_key 인자로 주어진 variable 인자를 삽입하거나 경신한다. 모든 변수 타입(double, int, string, array)가 지원된다.

참고: 이 함수는 윈도우즈 시스템에서는 동작하지 않는다.

이전 | 처음으로 | 다음
shm_get_var | 위로 | shm_remove_var


shm_remove_var

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

shm_remove_var -- 공유 메모리로부터 변수를 제거

설명

int shm_remove_var ( int id, int variable_key)

variable_key로 주어진 변수를 제거하고 점유된 메모리에서 제거한다.

참고: 이 함수는 윈도우즈 시스템에서 동작하지 않는다.

이전 | 처음으로 | 다음
shm_put_var | 위로 | shm_remove


shm_remove

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

shm_remove -- Unix 시스템에서 공유 메모리를 제거

설명

int shm_remove ( int shm_identifier)

Unix 시스템에서 공유 메모리를 제거하며, 모든 데이터가 제거된다.

참고: 이 함수는 윈도우즈 시스템에서는 동작하지 않는다.

이전 | 처음으로 | 다음
shm_remove_var | 위로 | SESAM Database Functions


SESAM Database Functions

PHP 매뉴얼
이전 다음

XCV. SESAM Database Functions

소개

SESAM/SQL-Server is a mainframe database system, developed by Fujitsu Siemens Computers, Germany. It runs on high-end mainframe servers using the operating system BS2000/OSD.

In numerous productive BS2000 installations, SESAM/SQL-Server has proven

  • the ease of use of Java-, Web- and client/server connectivity,

  • the capability to work with an availability of more than 99.99%,

  • the ability to manage tens and even hundreds of thousands of users.

There is a PHP3 SESAM interface available which allows database operations via PHP-scripts.

참고: Access to SESAM is only available with the latest CVS-Version of PHP3. PHP 4 does not support the SESAM database.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

sesam_oml string

Name of BS2000 PLAM library containing the loadable SESAM driver modules. Required for using SESAM functions. The BS2000 PLAM library must be set ACCESS=READ,SHARE=YES because it must be readable by the apache server's user id.

sesam_configfile string

Name of SESAM application configuration file. Required for using SESAM functions. The BS2000 file must be readable by the apache server's user id.

The application configuration file will usually contain a configuration like (see SESAM reference manual):

CNF=B
NAM=K
NOTYPE

sesam_messagecatalog string

Name of SESAM message catalog file. In most cases, this directive is not necessary. Only if the SESAM message file is not installed in the system's BS2000 message file table, it can be set with this directive.

The message catalog must be set ACCESS=READ,SHARE=YES because it must be readable by the apache server's user id.

Configuration notes

There is no standalone support for the PHP SESAM interface, it works only as an integrated Apache module. In the Apache PHP module, this SESAM interface is configured using Apache directives.

표 1. SESAM Configuration directives

Directive Meaning
php3_sesam_oml Name of BS2000 PLAM library containing the loadable SESAM driver modules. Required for using SESAM functions.

Example:

php3_sesam_oml $.SYSLNK.SESAM-SQL.030

php3_sesam_configfile Name of SESAM application configuration file. Required for using SESAM functions.

Example:

php3_sesam_configfile $SESAM.SESAM.CONF.AW

It will usually contain a configuration like (see SESAM reference manual):

CNF=B
NAM=K
NOTYPE

php3_sesam_messagecatalog Name of SESAM message catalog file. In most cases, this directive is not necessary. Only if the SESAM message file is not installed in the system's BS2000 message file table, it can be set with this directive.

Example:

php3_sesam_messagecatalog $.SYSMES.SESAM-SQL.030

In addition to the configuration of the PHP/SESAM interface, you have to configure the SESAM-Database server itself on your mainframe as usual. That means:

  • starting the SESAM database handler (DBH), and

  • connecting the databases with the SESAM database handler

To get a connection between a PHP script and the database handler, the CNF and NAM parameters of the selected SESAM configuration file must match the id of the started database handler.

In case of distributed databases you have to start a SESAM/SQL-DCN agent with the distribution table including the host and database names.

The communication between PHP (running in the POSIX subsystem) and the database handler (running outside the POSIX subsystem) is realized by a special driver module called SQLSCI and SESAM connection modules using common memory. Because of the common memory access, and because PHP is a static part of the web server, database accesses are very fast, as they do not require remote accesses via ODBC, JDBC or UTM.

Only a small stub loader (SESMOD) is linked with PHP, and the SESAM connection modules are pulled in from SESAM's OML PLAM library. In the configuration, you must tell PHP the name of this PLAM library, and the file link to use for the SESAM configuration file (As of SESAM V3.0, SQLSCI is available in the SESAM Tool Library, which is part of the standard distribution).

Because the SQL command quoting for single quotes uses duplicated single quotes (as opposed to a single quote preceded by a backslash, used in some other databases), it is advisable to set the PHP configuration directives php3_magic_quotes_gpc and php3_magic_quotes_sybase to On for all PHP scripts using the SESAM interface.

Runtime considerations

Because of limitations of the BS2000 process model, the driver can be loaded only after the Apache server has forked off its server child processes. This will slightly slow down the initial SESAM request of each child, but subsequent accesses will respond at full speed.

When explicitly defining a Message Catalog for SESAM, that catalog will be loaded each time the driver is loaded (i.e., at the initial SESAM request). The BS2000 operating system prints a message after successful load of the message catalog, which will be sent to Apache's error_log file. BS2000 currently does not allow suppression of this message, it will slowly fill up the log.

Make sure that the SESAM OML PLAM library and SESAM configuration file are readable by the user id running the web server. Otherwise, the server will be unable to load the driver, and will not allow to call any SESAM functions. Also, access to the database must be granted to the user id under which the Apache server is running. Otherwise, connections to the SESAM database handler will fail.

Cursor Types

The result cursors which are allocated for SQL "select type" queries can be either "sequential" or "scrollable". Because of the larger memory overhead needed by "scrollable" cursors, the default is "sequential".

When using "scrollable" cursors, the cursor can be freely positioned on the result set. For each "scrollable" query, there are global default values for the scrolling type (initialized to: SESAM_SEEK_NEXT) and the scrolling offset which can either be set once by sesam_seek_row() or each time when fetching a row using sesam_fetch_row(). When fetching a row using a "scrollable" cursor, the following post-processing is done for the global default values for the scrolling type and scrolling offset:

표 2. Scrolled Cursor Post-Processing

Scroll Type | Action
SESAM_SEEK_NEXT | none
SESAM_SEEK_PRIOR | none
SESAM_SEEK_FIRST | set scroll type to SESAM_SEEK_NEXT
SESAM_SEEK_LAST | set scroll type to SESAM_SEEK_PRIOR
SESAM_SEEK_ABSOLUTE | Auto-Increment internal offset value
SESAM_SEEK_RELATIVE | none. (maintain global default offset value, which allows for, e.g., fetching each 10th row backwards)

Porting note

Because in the PHP world it is natural to start indexes at zero (rather than 1), some adaptions have been made to the SESAM interface: whenever an indexed array is starting with index 1 in the native SESAM interface, the PHP interface uses index 0 as a starting point. E.g., when retrieving columns with sesam_fetch_row(), the first column has the index 0, and the subsequent columns have indexes up to (but not including) the column count ($array["count"]). When porting SESAM applications from other high level languages to PHP, be aware of this changed interface. Where appropriate, the description of the respective PHP sesam functions include a note that the index is zero based.

Security concerns

When allowing access to the SESAM databases, the web server user should only have as little privileges as possible. For most databases, only read access privilege should be granted. Depending on your usage scenario, add more access rights as you see fit. Never allow full control to any database for any user from the 'net! Restrict access to PHP scripts which must administer the database by using password control and/or SSL security.

Migration from other SQL databases

No two SQL dialects are ever 100% compatible. When porting SQL applications from other database interfaces to SESAM, some adaption may be required. The following typical differences should be noted:

  • Vendor specific data types

    Some vendor specific data types may have to be replaced by standard SQL data types (e.g., TEXT could be replaced by VARCHAR(max. size)).

  • Keywords as SQL identifiers

    In SESAM (as in standard SQL), such identifiers must be enclosed in double quotes (or renamed).

  • Display length in data types

    SESAM data types have a precision, not a display length. Instead of int(4) (intended use: integers up to '9999'), SESAM requires simply int for an implied size of 31 bits. Also, the only datetime data types available in SESAM are: DATE, TIME(3) and TIMESTAMP(3).

  • SQL types with vendor-specific unsigned, zerofill, or auto_increment attributes

    Unsigned and zerofill are not supported. Auto_increment is automatic (use "INSERT ... VALUES(*, ...)" instead of "... VALUES(0, ...)" to take advantage of SESAM-implied auto-increment.

  • int ... DEFAULT '0000'

    Numeric variables must not be initialized with string constants. Use DEFAULT 0 instead. To initialize variables of the datetime SQL data types, the initialization string must be prefixed with the respective type keyword, as in: CREATE TABLE exmpl ( xtime timestamp(3) DEFAULT TIMESTAMP '1970-01-01 00:00:00.000' NOT NULL );

  • $count = xxxx_num_rows();

    Some databases promise to guess/estimate the number of the rows in a query result, even though the returned value is grossly incorrect. SESAM does not know the number of rows in a query result before actually fetching them. If you REALLY need the count, try SELECT COUNT(...) WHERE ..., it will tell you the number of hits. A second query will (hopefully) return the results.

  • DROP TABLE thename;

    In SESAM, in the DROP TABLE command, the table name must be either followed by the keyword RESTRICT or CASCADE. When specifying RESTRICT, an error is returned if there are dependent objects (e.g., VIEWs), while with CASCADE, dependent objects will be deleted along with the specified table.

Notes on the use of various SQL types

SESAM does not currently support the BLOB type. A future version of SESAM will have support for BLOB.

At the PHP interface, the following type conversions are automatically applied when retrieving SQL fields:

표 3. SQL to PHP Type Conversions

SQL Type | PHP Type
SMALLINT, INTEGER | integer
NUMERIC, DECIMAL, FLOAT, REAL, DOUBLE | float
DATE, TIME, TIMESTAMP | string
VARCHAR, CHARACTER | string
When retrieving a complete row, the result is returned as an array. Empty fields are not filled in, so you will have to check for the existence of the individual fields yourself (use isset() or empty() to test for empty fields). That allows more user control over the appearance of empty fields (than in the case of an empty string as the representation of an empty field).

Support of SESAM's "multiple fields" feature

The special "multiple fields" feature of SESAM allows a column to consist of an array of fields. Such a "multiple field" column can be created like this:

예 1. Creating a "multiple field" column

CREATE TABLE multi_field_test (
    pkey CHAR(20) PRIMARY KEY,
    multi(3) CHAR(12)
)
and can be filled in using:

예 2. Filling a "multiple field" column

INSERT INTO multi_field_test (pkey, multi(2..3) )
    VALUES ('Second', <'first_val', 'second_val'>)
Note that (like in this case) leading empty sub-fields are ignored, and the filled-in values are collapsed, so that in the above example the result will appear as multi(1..2) instead of multi(2..3).

When retrieving a result row, "multiple columns" are accessed like "inlined" additional columns. In the example above, "pkey" will have the index 0, and the three "multi(1..3)" columns will be accessible as indices 1 through 3.

참고

For specific SESAM details, please refer to the SESAM/SQL-Server documentation (english) or the SESAM/SQL-Server documentation (german), both available online, or use the respective manuals.

차례
sesam_affected_rows -- Get number of rows affected by an immediate query
sesam_commit -- Commit pending updates to the SESAM database
sesam_connect -- Open SESAM database connection
sesam_diagnostic -- Return status information for last SESAM call
sesam_disconnect -- Detach from SESAM connection
sesam_errormsg -- Returns error message of last SESAM call
sesam_execimm -- Execute an "immediate" SQL-statement
sesam_fetch_array -- Fetch one row as an associative array
sesam_fetch_result -- Return all or part of a query result
sesam_fetch_row -- Fetch one row as an array
sesam_field_array -- Return meta information about individual columns in a result
sesam_field_name -- Return one column name of the result set
sesam_free_result -- Releases resources for the query
sesam_num_fields -- Return the number of fields/columns in a result set
sesam_query -- Perform a SESAM SQL query and prepare the result
sesam_rollback -- Discard any pending updates to the SESAM database
sesam_seek_row -- Set scrollable cursor mode for subsequent fetches
sesam_settransaction -- Set SESAM transaction parameters

이전 | 처음으로 | 다음
shm_remove | 위로 | sesam_affected_rows


sesam_affected_rows

(PHP 3 CVS only)

sesam_affected_rows -- Get number of rows affected by an immediate query

Description

int sesam_affected_rows ( string result_id)

result_id is a valid result id returned by sesam_query().

Returns the number of rows affected by a query associated with result_id.

The sesam_affected_rows() function can only return useful values when used in combination with "immediate" SQL statements (updating operations like INSERT, UPDATE and DELETE) because SESAM does not deliver any "affected rows" information for "select type" queries. The number returned is the number of affected rows.

예 1. sesam_affected_rows() example

<?php
$result = sesam_execimm("DELETE FROM PHONE WHERE LASTNAME = '" . strtoupper($name) . "'");
if (!$result) {
    /* ... error ... */
}
echo sesam_affected_rows($result).
    " entries with last name " . $name . " deleted.\n";
?>

See also sesam_query() and sesam_execimm().

이전 | 처음으로 | 다음
SESAM Database Functions | 위로 | sesam_commit


sesam_commit

(PHP 3 CVS only)

sesam_commit -- Commit pending updates to the SESAM database

Description

bool sesam_commit ( void )

Returns: TRUE on success, FALSE on errors

sesam_commit() commits any pending updates to the database.

Note that there is no "auto-commit" feature as in other databases, as it could lead to accidental data loss. Uncommitted data at the end of the current script (or when calling sesam_disconnect()) will be discarded by an implied sesam_rollback() call.

See also: sesam_rollback().

예 1. Committing an update to the SESAM database

<?php
if (sesam_connect ("mycatalog", "myschema", "otto")) {
    if (!sesam_execimm ("INSERT INTO mytable VALUES (*, 'Small Test', <0, 8, 15>)"))
        die("insert failed");
    if (!sesam_commit())
        die("commit failed");
}
?>

이전 | 처음으로 | 다음
sesam_affected_rows | 위로 | sesam_connect


sesam_connect

(PHP 3 CVS only)

sesam_connect -- Open SESAM database connection

Description

bool sesam_connect ( string catalog, string schema, string user)

Returns TRUE if a connection to the SESAM database was made, or FALSE on error.

sesam_connect() establishes a connection to an SESAM database handler task. The connection is always "persistent" in the sense that only the very first invocation will actually load the driver from the configured SESAM OML PLAM library. Subsequent calls will reuse the driver and will immediately use the given catalog, schema, and user.

When creating a database, the "catalog" name is specified in the SESAM configuration directive //ADD-SQL-DATABASE-CATALOG-LIST ENTRY-1 = *CATALOG(CATALOG-NAME = catalogname,...)

The "schema" references the desired database schema (see SESAM handbook).

The "user" argument references one of the users which are allowed to access this "catalog" / "schema" combination. Note that "user" is completely independent from both the system's user id's and from HTTP user/password protection. It appears in the SESAM configuration only.

See also sesam_disconnect().

예 1. Connect to a SESAM database

<?php
if (!sesam_connect ("mycatalog", "myschema", "otto")) {
    die("Unable to connect to SESAM");
}
?>

이전 | 처음으로 | 다음
sesam_commit | 위로 | sesam_diagnostic


sesam_diagnostic

(PHP 3 CVS only)

sesam_diagnostic -- Return status information for last SESAM call

Description

array sesam_diagnostic ( void )

Returns an associative array of status and return codes for the last SQL query/statement/command. Elements of the array are:

표 1. Status information returned by sesam_diagnostic()

Element | Contents
$array["sqlstate"] | 5 digit SQL return code (see the SESAM manual for the description of the possible values of SQLSTATE)
$array["rowcount"] | number of affected rows in last update/insert/delete (set after "immediate" statements only)
$array["errmsg"] | "human readable" error message string (set after errors only)
$array["errcol"] | error column number of previous error (0-based; or -1 if undefined. Set after errors only)
$array["errlin"] | error line number of previous error (0-based; or -1 if undefined. Set after errors only)

In the following example, a syntax error (E SEW42AE ILLEGAL CHARACTER) is displayed by including the offending SQL statement and pointing to the error location:

예 1. Displaying SESAM error messages with error position

<?php
// Function which prints a formatted error message,
// displaying a pointer to the syntax error in the
// SQL statement
function PrintReturncode($exec_str)
{
    $err = Sesam_Diagnostic();
    $colspan=4; // 4 cols for: sqlstate, errlin, errcol, rowcount
    if ($err["errlin"] == -1)
        --$colspan;
    if ($err["errcol"] == -1)
        --$colspan;
    if ($err["rowcount"] == 0)
        --$colspan;
    echo "<table border=\"1\">\n";
    echo "<tr><th colspan=\"" . $colspan . "\"><span class=\"spanred\">ERROR:</span> ".
              htmlspecialchars($err["errmsg"]) . "</th></tr>\n";
    if ($err["errcol"] >= 0) {
        echo "<tr><td colspan=\"" . $colspan . "\"><pre>\n";
        $errstmt = $exec_str . "\n";
        for ($lin=0; $errstmt != ""; ++$lin) {
            if ($lin != $err["errlin"]) { // $lin is less or greater than errlin
                if (!($i = strchr($errstmt, "\n")))
                    $i = "";
                $line = substr ($errstmt, 0, strlen($errstmt)-strlen($i)+1);
                $errstmt = substr($i, 1);
                if ($line != "\n")
                    echo htmlspecialchars($line);
            } else {
                if (! ($i = strchr ($errstmt, "\n")))
                    $i = "";
                $line = substr ($errstmt, 0, strlen ($errstmt)-strlen($i)+1);
                $errstmt = substr($i, 1);
                for ($col=0; $col < $err["errcol"]; ++$col) {
                    echo (substr($line, $col, 1) == "\t") ? "\t" : ".";
                }
                echo "<span class=\"spanred\">\\</span>\n";
                echo "<span class=\"normal\">" . htmlspecialchars($line) . "</span>";
                for ($col=0; $col < $err["errcol"]; ++$col) {
                    echo (substr ($line, $col, 1) == "\t") ? "\t" : ".";
                }
                echo "<span class=\"spanred\">/</span>\n";
            }
        }
        echo "</pre></td></tr>\n";
    }
    echo "<tr>\n";
    echo " <td>sqlstate=" . $err["sqlstate"] . "</td>\n";
    if ($err["errlin"] != -1)
        echo " <td>errlin=" . $err["errlin"] . "</td>\n";
    if ($err["errcol"] != -1)
        echo " <td>errcol=" . $err["errcol"] . "</td>\n";
    if ($err["rowcount"] != 0)
         echo " <td>rowcount=" . $err["rowcount"] . "</td>\n";
    echo "</tr>\n";
    echo "</table>\n";
}

if (!sesam_connect ("mycatalog", "phoneno", "otto"))
  die ("cannot connect");

$stmt = "SELECT * FROM phone\n" .
        " WHERE@ LASTNAME='KRAEMER'\n" .
        " ORDER BY FIRSTNAME";
if (!($result = sesam_query ($stmt)))
    PrintReturncode ($stmt);
?>

See also: sesam_errormsg() for simple access to the error string only

이전 | 처음으로 | 다음
sesam_connect | 위로 | sesam_disconnect


sesam_disconnect

(PHP 3 CVS only)

sesam_disconnect -- Detach from SESAM connection

Description

bool sesam_disconnect ( void )

Returns: always TRUE.

sesam_disconnect() closes the logical link to a SESAM database (without actually disconnecting and unloading the driver).

Note that this isn't usually necessary, as the open connection is automatically closed at the end of the script's execution. Uncommitted data will be discarded, because an implicit sesam_rollback() is executed.

sesam_disconnect() will not close the persistent link, it will only invalidate the currently defined "catalog", "schema" and "user" triple, so that any sesam function called after sesam_disconnect() will fail.

예 1. Closing a SESAM connection

<?php
if (sesam_connect ("mycatalog", "myschema", "otto")) {
    /* ... some queries and stuff ... */
    sesam_disconnect();
}
?>

See also sesam_connect().

이전 | 처음으로 | 다음
sesam_diagnostic | 위로 | sesam_errormsg


sesam_errormsg

(PHP 3 CVS only)

sesam_errormsg -- Returns error message of last SESAM call

Description

string sesam_errormsg ( void )

Returns the SESAM error message associated with the most recent SESAM error.

예 1. sesam_errormsg() example

<?php
if (!sesam_execimm($stmt)) {
  echo sesam_errormsg() . "<br />\n";
}
?>

See also sesam_diagnostic() for the full set of SESAM SQL status information.

이전 | 처음으로 | 다음
sesam_disconnect | 위로 | sesam_execimm


sesam_execimm

(PHP 3 CVS only)

sesam_execimm -- Execute an "immediate" SQL-statement

Description

string sesam_execimm ( string query)

Returns: A SESAM "result identifier" on success, or FALSE on error.

sesam_execimm() executes an "immediate" statement (i.e., a statement like UPDATE, INSERT or DELETE which returns no result, and has no INPUT or OUTPUT variables). "select type" queries can not be used with sesam_execimm(). Sets the affected_rows value for retrieval by the sesam_affected_rows() function.

Note that sesam_query() can handle both "immediate" and "select-type" queries. Use sesam_execimm() only if you know beforehand what type of statement will be executed. An attempt to use SELECT type queries with sesam_execimm() will return $err["sqlstate"] == "42SBW".

The returned "result identifier" can not be used for retrieving anything but the sesam_affected_rows(); it is only returned for symmetry with the sesam_query() function.

<?php
$stmt = "INSERT INTO mytable VALUES ('one', 'two')";
$result = sesam_execimm($stmt);
$err = sesam_diagnostic();
echo "sqlstate = " . $err["sqlstate"] . "\n".
       "Affected rows = " . $err["rowcount"] . " == " .
       sesam_affected_rows($result) . "\n";
?>

See also sesam_query() and sesam_affected_rows().

이전 | 처음으로 | 다음
sesam_errormsg | 위로 | sesam_fetch_array


sesam_fetch_array

(PHP 3 CVS only)

sesam_fetch_array -- Fetch one row as an associative array

Description

array sesam_fetch_array ( string result_id [, int whence [, int offset]])

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

sesam_fetch_array() is an alternative version of sesam_fetch_row(). Instead of storing the data in the numeric indices of the result array, it stores the data in associative indices, using the field names as keys.

result_id is a valid result id returned by sesam_query() (select type queries only!).

For the valid values of the optional whenceand offset parameters, see the sesam_fetch_row() function for details.

sesam_fetch_array() fetches one row of data from the result associated with the specified result identifier. The row is returned as an associative array. Each result column is stored with an associative index equal to its column (aka. field) name. The column names are converted to lower case.

Columns without a field name (e.g., results of arithmetic operations) and empty fields are not stored in the array. Also, if two or more columns of the result have the same column names, the later column will take precedence. In this situation, either call sesam_fetch_row() or make an alias for the column.

SELECT TBL1.COL AS FOO, TBL2.COL AS BAR FROM TBL1, TBL2

A special handling allows fetching "multiple field" columns (which would otherwise all have the same column names). For each column of a "multiple field", the index name is constructed by appending the string "(n)" where n is the sub-index of the multiple field column, ranging from 1 to its declared repetition factor. The indices are NOT zero based, in order to match the nomenclature used in the respective query syntax. For a column declared as:

CREATE TABLE ... ( ... MULTI(3) INT )

the associative indices used for the individual "multiple field" columns would be "multi(1)", "multi(2)", and "multi(3)" respectively.

Subsequent calls to sesam_fetch_array() would return the next (or prior, or n'th next/prior, depending on the scroll attributes) row in the result set, or FALSE if there are no more rows.

예 1. SESAM fetch array

<?php
$result = sesam_query("SELECT * FROM phone\n" .
                       "  WHERE LASTNAME='" . strtoupper($name) . "'\n".
                       "  ORDER BY FIRSTNAME", 1);
if (!$result) {
    /* ... error ... */
}
// print the table:
echo "<table border=\"1\">\n";
while (($row = sesam_fetch_array($result)) && count($row) > 0) {
    echo "<tr>\n";
    echo "<td>" . htmlspecialchars($row["firstname"]) . "</td>\n";
    echo "<td>" . htmlspecialchars($row["lastname"]) . "</td>\n";
    echo "<td>" . htmlspecialchars($row["phoneno"]) . "</td>\n";
    echo "</tr>\n";
}
echo "</table>\n";
sesam_free_result($result);
?>

See also: sesam_fetch_row() which returns an indexed array.

이전 | 처음으로 | 다음
sesam_execimm | 위로 | sesam_fetch_result


sesam_fetch_result

(PHP 3 CVS only)

sesam_fetch_result -- Return all or part of a query result

Description

mixed sesam_fetch_result ( string result_id [, int max_rows])

Returns a mixed array with the query result entries, optionally limited to a maximum of max_rows rows. Note that both row and column indexes are zero-based.

표 1. Mixed result set returned by sesam_fetch_result()

Array Element | Contents
int $arr["count"] | number of columns in result set (or zero if this was an "immediate" query)
int $arr["rows"] | number of rows in result set (between zero and max_rows)
bool $arr["truncated"] | TRUE if the number of rows was at least max_rows, FALSE otherwise. Note that even when this is TRUE, the next sesam_fetch_result() call may return zero rows because there are no more result entries.
mixed $arr[col][row] | result data for all the fields at row(row) and column(col), (where the integer index row is between 0 and $arr["rows"]-1, and col is between 0 and $arr["count"]-1). Fields may be empty, so you must check for the existence of a field by using the php isset() function. The type of the returned fields depend on the respective SQL type declared for its column (see SESAM overview for the conversions applied). SESAM "multiple fields" are "inlined" and treated like a sequence of columns.
Note that the amount of memory used up by a large query may be gigantic. Use the max_rows parameter to limit the maximum number of rows returned, unless you are absolutely sure that your result will not use up all available memory.

See also: sesam_fetch_row(), and sesam_field_array() to check for "multiple fields". See the description of the sesam_query() function for a complete example using sesam_fetch_result().

이전 | 처음으로 | 다음
sesam_fetch_array | 위로 | sesam_fetch_row


sesam_fetch_row

(PHP 3 CVS only)

sesam_fetch_row -- Fetch one row as an array

Description

array sesam_fetch_row ( string result_id [, int whence [, int offset]])

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

The number of columns in the result set is returned in an associative array element $array["count"]. Because some of the result columns may be empty, the count() function can not be used on the result row returned by sesam_fetch_row().

result_id is a valid result id returned by sesam_query() (select type queries only!).

whence is an optional parameter for a fetch operation on "scrollable" cursors, which can be set to the following predefined constants:

표 1. Valid values for "whence" parameter

Value | Constant | Meaning
0 | SESAM_SEEK_NEXT | read sequentially (after fetch, the internal default is set to SESAM_SEEK_NEXT)
1 | SESAM_SEEK_PRIOR | read sequentially backwards (after fetch, the internal default is set to SESAM_SEEK_PRIOR)
2 | SESAM_SEEK_FIRST | rewind to first row (after fetch, the default is set to SESAM_SEEK_NEXT)
3 | SESAM_SEEK_LAST | seek to last row (after fetch, the default is set to SESAM_SEEK_PRIOR)
4 | SESAM_SEEK_ABSOLUTE | seek to absolute row number given as offset (Zero-based. After fetch, the internal default is set to SESAM_SEEK_ABSOLUTE, and the internal offset value is auto-incremented)
5 | SESAM_SEEK_RELATIVE | seek relative to current scroll position, where offset can be a positive or negative offset value.
This parameter is only valid for "scrollable" cursors.

When using "scrollable" cursors, the cursor can be freely positioned on the result set. If the whence parameter is omitted, the global default values for the scrolling type (initialized to: SESAM_SEEK_NEXT, and settable by sesam_seek_row()) are used. If whence is supplied, its value replaces the global default.

offset is an optional parameter which is only evaluated (and required) if whence is either SESAM_SEEK_RELATIVE or SESAM_SEEK_ABSOLUTE. This parameter is only valid for "scrollable" cursors.

sesam_fetch_row() fetches one row of data from the result associated with the specified result identifier. The row is returned as an array (indexed by values between 0 and $array["count"]-1). Fields may be empty, so you must check for the existence of a field by using the isset() function. The type of the returned fields depend on the respective SQL type declared for its column (see SESAM overview for the conversions applied). SESAM "multiple fields" are "inlined" and treated like a sequence of columns.

Subsequent calls to sesam_fetch_row() would return the next (or prior, or n'th next/prior, depending on the scroll attributes) row in the result set, or FALSE if there are no more rows.

예 1. SESAM fetch rows

<?php
$result = sesam_query("SELECT * FROM phone\n" .
                       "  WHERE LASTNAME='" . strtoupper($name) . "'\n" .
                       "  ORDER BY FIRSTNAME", 1);
if (!$result) {
    /* ... error ... */
}
// print the table in backward order
echo "<table border=\"1\">\n";
$row = sesam_fetch_row($result, SESAM_SEEK_LAST);
while (is_array($row)) {
    echo "<tr>\n";
    for ($col = 0; $col < $row["count"]; ++$col) {
        echo "<td>" . htmlspecialchars($row[$col]) . "</td>\n";
    }
    echo "</tr>\n";
    // use implied SESAM_SEEK_PRIOR
    $row = sesam_fetch_row($result);
}
echo "</table>\n";
sesam_free_result($result);
?>

See also: sesam_fetch_array() which returns an associative array, and sesam_fetch_result() which returns many rows per invocation.

이전 | 처음으로 | 다음
sesam_fetch_result | 위로 | sesam_field_array


sesam_field_array

(PHP 3 CVS only)

sesam_field_array -- Return meta information about individual columns in a result

Description

array sesam_field_array ( string result_id)

result_id is a valid result id returned by sesam_query().

Returns a mixed associative/indexed array with meta information (column name, type, precision, ...) about individual columns of the result after the query associated with result_id.

표 1. Mixed result set returned by sesam_field_array()

Array Element | Contents
int $arr["count"] | Total number of columns in result set (or zero if this was an "immediate" query). SESAM "multiple fields" are "inlined" and treated like the respective number of columns.
string $arr[col]["name"] | column name for column(col), where col is between 0 and $arr["count"]-1. The returned value can be the empty string (for dynamically computed columns). SESAM "multiple fields" are "inlined" and treated like the respective number of columns, each with the same column name.
string $arr[col]["count"] | The "count" attribute describes the repetition factor when the column has been declared as a "multiple field". Usually, the "count" attribute is 1. The first column of a "multiple field" column however contains the number of repetitions (the second and following column of the "multiple field" contain a "count" attribute of 1). This can be used to detect "multiple fields" in the result set. See the example shown in the sesam_query() description for a sample use of the "count" attribute.
string $arr[col]["type"] PHP variable type of the data for column(col), where col is between 0 and $arr["count"]-1. The returned value can be one of

  • integer

  • float

  • string

depending on the SQL type of the result. SESAM "multiple fields" are "inlined" and treated like the respective number of columns, each with the same PHP type.
string $arr[col]["sqltype"] SQL variable type of the column data for column(col), where col is between 0 and $arr["count"]-1. The returned value can be one of

  • "CHARACTER"

  • "VARCHAR"

  • "NUMERIC"

  • "DECIMAL"

  • "INTEGER"

  • "SMALLINT"

  • "FLOAT"

  • "REAL"

  • "DOUBLE"

  • "DATE"

  • "TIME"

  • "TIMESTAMP"

describing the SQL type of the result. SESAM "multiple fields" are "inlined" and treated like the respective number of columns, each with the same SQL type.
string $arr[col]["length"] | The SQL "length" attribute of the SQL variable in column(col), where col is between 0 and $arr["count"]-1. The "length" attribute is used with "CHARACTER" and "VARCHAR" SQL types to specify the (maximum) length of the string variable. SESAM "multiple fields" are "inlined" and treated like the respective number of columns, each with the same length attribute.
string $arr[col]["precision"] | The "precision" attribute of the SQL variable in column(col), where col is between 0 and $arr["count"]-1. The "precision" attribute is used with numeric and time data types. SESAM "multiple fields" are "inlined" and treated like the respective number of columns, each with the same precision attribute.
string $arr[col]["scale"] | The "scale" attribute of the SQL variable in column(col), where col is between 0 and $arr["count"]-1. The "scale" attribute is used with numeric data types. SESAM "multiple fields" are "inlined" and treated like the respective number of columns, each with the same scale attribute.

See also sesam_query() for an example of the sesam_field_array() use.

이전 | 처음으로 | 다음
sesam_fetch_row | 위로 | sesam_field_name


sesam_field_name

(PHP 3 CVS only)

sesam_field_name -- Return one column name of the result set

Description

int sesam_field_name ( string result_id, int index)

Returns the name of a field (i.e., the column name) in the result set, or FALSE on error.

For "immediate" queries, or for dynamic columns, an empty string is returned.

참고: The column index is zero-based, not one-based as in SESAM.

See also: sesam_field_array(). It provides an easier interface to access the column names and types, and allows for detection of "multiple fields".

이전 | 처음으로 | 다음
sesam_field_array | 위로 | sesam_free_result


sesam_free_result

(PHP 3 CVS only)

sesam_free_result -- Releases resources for the query

Description

int sesam_free_result ( string result_id)

Releases resources for the query associated with result_id. Returns FALSE on error.

이전 | 처음으로 | 다음
sesam_field_name | 위로 | sesam_num_fields


sesam_num_fields

(PHP 3 CVS only)

sesam_num_fields -- Return the number of fields/columns in a result set

Description

int sesam_num_fields ( string result_id)

After calling sesam_query() with a "select type" query, this function gives you the number of columns in the result. Returns an integer describing the total number of columns (aka. fields) in the current result_id result set or FALSE on error.

For "immediate" statements, the value zero is returned. The SESAM "multiple field" columns count as their respective dimension, i.e., a three-column "multiple field" counts as three columns.

See also: sesam_query() and sesam_field_array() for a way to distinguish between "multiple field" columns and regular columns.

이전 | 처음으로 | 다음
sesam_free_result | 위로 | sesam_query


sesam_query

(PHP 3 CVS only)

sesam_query -- Perform a SESAM SQL query and prepare the result

Description

string sesam_query ( string query [, bool scrollable])

Returns: A SESAM "result identifier" on success, or FALSE on error.

A "result_id" resource is used by other functions to retrieve the query results.

sesam_query() sends a query to the currently active database on the server. It can execute both "immediate" SQL statements and "select type" queries. If an "immediate" statement is executed, then no cursor is allocated, and any subsequent sesam_fetch_row() or sesam_fetch_result() call will return an empty result (zero columns, indicating end-of-result). For "select type" statements, a result descriptor and a (scrollable or sequential, depending on the optional boolean scrollable parameter) cursor will be allocated. If scrollable is omitted, the cursor will be sequential.

When using "scrollable" cursors, the cursor can be freely positioned on the result set. For each "scrollable" query, there are global default values for the scrolling type (initialized to: SESAM_SEEK_NEXT) and the scrolling offset which can either be set once by sesam_seek_row() or each time when fetching a row using sesam_fetch_row().

For "immediate" statements, the number of affected rows is saved for retrieval by the sesam_affected_rows() function.

See also: sesam_fetch_row() and sesam_fetch_result().

예 1. Show all rows of the "phone" table as a HTML table

<?php
if (!sesam_connect("phonedb", "demo", "otto"))
    die("cannot connect");
$result = sesam_query("select * from phone");
if (!$result) {
    $err = sesam_diagnostic();
    die $err["errmsg"]);
}
echo "<table border>\n";
// Add title header with column names above the result:
if ($cols = sesam_field_array($result)) {
    echo "<tr><th colspan=" . $cols["count"] . ">Result:</th></tr>\n";
    echo "<tr>\n";
    for ($col = 0; $col < $cols["count"]; ++$col) {
        $colattr = $cols[$col];
        /* Span the table head over SESAM's "Multiple Fields": */
        if ($colattr["count"] > 1) {
            echo "<th colspan=\"" . $colattr["count"] . "\">" . $colattr["name"] .
                "(1.." . $colattr["count"] . ")</th>\n";
            $col += $colattr["count"] - 1;
        } else
            echo "<th>" . $colattr["name"] . "</th>\n";
    }
    echo "</tr>\n";
}

do {
    // Fetch the result in chunks of 100 rows max.
    $ok = sesam_fetch_result($result, 100);
    for ($row=0; $row < $ok["rows"]; ++$row) {
        echo " <tr>\n";
        for ($col = 0; $col < $ok["cols"]; ++$col) {
            if (isset($ok[$col][$row])) {
                echo "<td>" . $ok[$col][$row] . "</td>\n";
            } else {
                echo "<td>-empty-</td>\n";
            }
        }
        echo "</tr>\n";
    }
} while ($ok["truncated"]); // while there may be more data

echo "</table>\n";
// free result id
sesam_free_result($result);
?>

이전 | 처음으로 | 다음
sesam_num_fields | 위로 | sesam_rollback


sesam_rollback

(PHP 3 CVS only)

sesam_rollback -- Discard any pending updates to the SESAM database

Description

bool sesam_rollback ( void )

Returns: TRUE on success, FALSE on errors

sesam_rollback() discards any pending updates to the database. Also affected are result cursors and result descriptors.

At the end of each script, and as part of the sesam_disconnect() function, an implied sesam_rollback() is executed, discarding any pending changes to the database.

See also: sesam_commit().

예 1. Discarding an update to the SESAM database

<?php
if (sesam_connect ("mycatalog", "myschema", "otto")) {
    if (sesam_execimm ("INSERT INTO mytable VALUES (*, 'Small Test', <0, 8, 15>)")
        && sesam_execimm ("INSERT INTO othertable VALUES (*, 'Another Test', 1)")) {
        sesam_commit();
    } else {
        sesam_rollback();
    }
}
?>

이전 | 처음으로 | 다음
sesam_query | 위로 | sesam_seek_row


sesam_seek_row

(PHP 3 CVS only)

sesam_seek_row -- Set scrollable cursor mode for subsequent fetches

Description

bool sesam_seek_row ( string result_id, int whence [, int offset])

result_id is a valid result id (select type queries only, and only if a "scrollable" cursor was requested when calling sesam_query()).

whence sets the global default value for the scrolling type, it specifies the scroll type to use in subsequent fetch operations on "scrollable" cursors, which can be set to the following predefined constants:

표 1. Valid values for "whence" parameter

Value | Constant | Meaning
0 | SESAM_SEEK_NEXT | read sequentially
1 | SESAM_SEEK_PRIOR | read sequentially backwards
2 | SESAM_SEEK_FIRST | fetch first row (after fetch, the default is set to SESAM_SEEK_NEXT)
3 | SESAM_SEEK_LAST | fetch last row (after fetch, the default is set to SESAM_SEEK_PRIOR)
4 | SESAM_SEEK_ABSOLUTE | fetch absolute row number given as offset (Zero-based. After fetch, the default is set to SESAM_SEEK_ABSOLUTE, and the offset value is auto-incremented)
5 | SESAM_SEEK_RELATIVE | fetch relative to current scroll position, where offset can be a positive or negative offset value (this also sets the default "offset" value for subsequent fetches).

offset is an optional parameter which is only evaluated (and required) if whence is either SESAM_SEEK_RELATIVE or SESAM_SEEK_ABSOLUTE.

이전 | 처음으로 | 다음
sesam_rollback | 위로 | sesam_settransaction


sesam_settransaction

(PHP 3 CVS only)

sesam_settransaction -- Set SESAM transaction parameters

Description

bool sesam_settransaction ( int isolation_level, int read_only)

Returns: TRUE if the values are valid, and the settransaction() operation was successful, FALSE otherwise.

sesam_settransaction() overrides the default values for the "isolation level" and "read-only" transaction parameters (which are set in the SESAM configuration file), in order to optimize subsequent queries and guarantee database consistency. The overridden values are used for the next transaction only.

sesam_settransaction() can only be called before starting a transaction, not after the transaction has been started already.

To simplify the use in PHP scripts, the following constants have been predefined in PHP (see SESAM handbook for detailed explanation of the semantics):

표 1. Valid values for "Isolation_Level" parameter

Value | Constant | Meaning
1 | SESAM_TXISOL_READ_UNCOMMITTED | Read Uncommitted
2 | SESAM_TXISOL_READ_COMMITTED | Read Committed
3 | SESAM_TXISOL_REPEATABLE_READ | Repeatable Read
4 | SESAM_TXISOL_SERIALIZABLE | Serializable

표 2. Valid values for "Read_Only" parameter

Value | Constant | Meaning
0 | SESAM_TXREAD_READWRITE | Read/Write
1 | SESAM_TXREAD_READONLY | Read-Only

The values set by sesam_settransaction() will override the default setting specified in the SESAM configuration file.

예 1. Setting SESAM transaction parameters

<?php
sesam_settransaction (SESAM_TXISOL_REPEATABLE_READ,
                     SESAM_TXREAD_READONLY);
?>

이전 | 처음으로 | 다음
sesam_seek_row | 위로 | Session Handling Functions


Session Handling Functions

PHP 매뉴얼
이전 다음

XCVI. Session Handling Functions

소개

Session support in PHP consists of a way to preserve certain data across subsequent accesses. This enables you to build more customized applications and increase the appeal of your web site.

A visitor accessing your web site is assigned an unique id, the so-called session id. This is either stored in a cookie on the user side or is propagated in the URL.

The session support allows you to register arbitrary numbers of variables to be preserved across requests. When a visitor accesses your site, PHP will check automatically (if session.auto_start is set to 1) or on your request (explicitly through session_start() or implicitly through session_register()) whether a specific session id has been sent with the request. If this is the case, the prior saved environment is recreated.

경고

If you do turn on session.auto_start then you cannot put objects into your sessions since the class definition has to be loaded before starting the session in order to recreate the objects in your session.

All registered variables are serialized after the request finishes. Registered variables which are undefined are marked as being not defined. On subsequent accesses, these are not defined by the session module unless the user defines them later.

참고: Session handling was added in PHP 4.0.

참고: Please note when working with sessions that a record of a session is not created until a variable has been registered using the session_register() function or by adding a new key to the $_SESSION superglobal array. This holds true regardless of if a session has been started using the session_start() function.

Sessions and security

External links: Session fixation

The session module cannot guarantee that the information you store in a session is only viewed by the user who created the session. You need to take additional measures to actively protect the integrity of the session, depending on the value associated with it.

Assess the importance of the data carried by your sessions and deploy additional protections -- this usually comes at a price, reduced convenience for the user. For example, if you want to protect users from simple social engineering tactics, you need to enable session.use_only_cookies. In that case, cookies must be enabled unconditionally on the user side, or sessions will not work.

There are several ways to leak an existing session id to third parties. A leaked session id enables the third party to access all resources which are associated with a specific id. First, URLs carrying session ids. If you link to an external site, the URL including the session id might be stored in the external site's referrer logs. Second, a more active attacker might listen to your network traffic. If it is not encrypted, session ids will flow in plain text over the network. The solution here is to implement SSL on your server and make it mandatory for users.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

참고: Optionally you can use shared memory allocation (mm), developed by Ralf S. Engelschall, for session storage. You have to download mm and install it. This option is not available for Windows platforms. Note that the session storage module for mm does not guarantee that concurrent accesses to the same session are properly locked. It might be more appropriate to use a shared memory based filesystem (such as tmpfs on Solaris/Linux, or /dev/md on BSD) to store sessions in files, because they are properly locked.

설치

Session support is enabled in PHP by default. If you would not like to build your PHP with session support, you should specify the --disable-session option to configure. To use shared memory allocation (mm) for session storage configure PHP --with-mm[=DIR] .

PHP 윈도우 버전에서는 이 확장 모듈에 대한 지원이 포함되어 있습니다. 이 함수들을 이용하기 위해서 추가로 확장 모듈을 읽어들일 필요가 없습니다.

참고: By default, all data related to a particular session will be stored in a file in the directory specified by the session.save_path INI option. A file for each session (regardless of if any data is associated with that session) will be created. This is due to the fact that a session is opened (a file is created) but no data is even written to that file. Note that this behavior is a side-effect of the limitations of working with the file system and it is possible that a custom session handler (such as one which uses a database) does not keep track of sessions which store no data.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. Session configuration options

Name | Default | Changeable
session.save_path | "/tmp" | PHP_INI_ALL
session.name | "PHPSESSID" | PHP_INI_ALL
session.save_handler | "files" | PHP_INI_ALL
session.auto_start | "0" | PHP_INI_ALL
session.gc_probability | "1" | PHP_INI_ALL
session.gc_divisor | "100" | PHP_INI_ALL
session.gc_maxlifetime | "1440" | PHP_INI_ALL
session.serialize_handler | "php" | PHP_INI_ALL
session.cookie_lifetime | "0" | PHP_INI_ALL
session.cookie_path | "/" | PHP_INI_ALL
session.cookie_domain | "" | PHP_INI_ALL
session.cookie_secure | "" | PHP_INI_ALL
session.use_cookies | "1" | PHP_INI_ALL
session.use_only_cookies | "0" | PHP_INI_ALL
session.referer_check | "" | PHP_INI_ALL
session.entropy_file | "" | PHP_INI_ALL
session.entropy_length | "0" | PHP_INI_ALL
session.cache_limiter | "nocache" | PHP_INI_ALL
session.cache_expire | "180" | PHP_INI_ALL
session.use_trans_sid | "0" | PHP_INI_SYSTEM | PHP_INI_PERDIR
session.bug_compat_42 | "1" | PHP_INI_ALL
session.bug_compat_warn | "1" | PHP_INI_ALL
session.hash_function | "0" | PHP_INI_ALL
session.hash_bits_per_character | "4" | PHP_INI_ALL
url_rewriter.tags | "a=href,area=href,frame=src,input=src,form=fakeentry" | PHP_INI_ALL
For further details and definition of the PHP_INI_* constants see ini_set().

The session management system supports a number of configuration options which you can place in your php.ini file. We will give a short overview.

session.save_handler string

session.save_handler defines the name of the handler which is used for storing and retrieving data associated with a session. Defaults to files. See also session_set_save_handler().

session.save_path string

session.save_path defines the argument which is passed to the save handler. If you choose the default files handler, this is the path where the files are created. Defaults to /tmp. See also session_save_path().

There is an optional N argument to this directive that determines the number of directory levels your session files will be spread around in. For example, setting to '5;/tmp' may end up creating a session file and location like /tmp/4/b/1/e/3/sess_4b1e384ad74619bd212e236e52a5a174If . In order to use N you must create all of these directories before use. A small shell script exists in ext/session to do this, it's called mod_files.sh. Also note that if N is used and greater than 0 then automatic garbage collection will not be performed, see a copy of php.ini for further information. Also, if you use N, be sure to surround session.save_path in "quotes" because the separator (;) is also used for comments in php.ini.

주의

If you leave this set to a world-readable directory, such as /tmp (the default), other users on the server may be able to hijack sessions by getting the list of files in that directory.

참고: Windows users have to change this variable in order to use PHP's session functions. Make sure to specify a valid path, e.g.: c:/temp.

session.name string

session.name specifies the name of the session which is used as cookie name. It should only contain alphanumeric characters. Defaults to PHPSESSID. See also session_name().

session.auto_start boolean

session.auto_start specifies whether the session module starts a session automatically on request startup. Defaults to 0 (disabled).

session.serialize_handler string

session.serialize_handler defines the name of the handler which is used to serialize/deserialize data. Currently, a PHP internal format (name php) and WDDX is supported (name wddx). WDDX is only available, if PHP is compiled with WDDX support. Defaults to php.

session.gc_probability integer

session.gc_probability in conjunction with session.gc_divisor is used to manage probability that the gc (garbage collection) routine is started. Defaults to 1. See session.gc_divisor for details.

session.gc_divisor integer

session.gc_divisor coupled with session.gc_probability defines the probability that the gc (garbage collection) process is started on every session initialization. The probability is calculated by using gc_probability/gc_divisor, e.g. 1/100 means there is a 1% chance that the GC process starts on each request. session.gc_divisor defaults to 100.

session.gc_maxlifetime integer

session.gc_maxlifetime specifies the number of seconds after which data will be seen as 'garbage' and cleaned up.

참고: If you are using the default file-based session handler, your filesystem must keep track of access times (atime). Windows FAT does not so you will have to come up with another way to handle garbage collecting your session if you are stuck with a FAT filesystem or any other fs where atime tracking is not available. Since PHP 4.2.3 it has used mtime (modified date) instead of atime. So, you won't have problems with filesystems where atime tracking is not available.

session.referer_check string

session.referer_check contains the substring you want to check each HTTP Referer for. If the Referer was sent by the client and the substring was not found, the embedded session id will be marked as invalid. Defaults to the empty string.

session.entropy_file string

session.entropy_file gives a path to an external resource (file) which will be used as an additional entropy source in the session id creation process. Examples are /dev/random or /dev/urandom which are available on many Unix systems.

session.entropy_length integer

session.entropy_length specifies the number of bytes which will be read from the file specified above. Defaults to 0 (disabled).

session.use_cookies boolean

session.use_cookies specifies whether the module will use cookies to store the session id on the client side. Defaults to 1 (enabled).

session.use_only_cookies boolean

session.use_only_cookies specifies whether the module will only use cookies to store the session id on the client side. Defaults to 0 (disabled, for backward compatibility). Enabling this setting prevents attacks involved passing session ids in URLs. This setting was added in PHP 4.3.0.

session.cookie_lifetime integer

session.cookie_lifetime specifies the lifetime of the cookie in seconds which is sent to the browser. The value 0 means "until the browser is closed." Defaults to 0.See also session_get_cookie_params() and session_set_cookie_params().

session.cookie_path string

session.cookie_path specifies path to set in session_cookie. Defaults to /.See also session_get_cookie_params() and session_set_cookie_params().

session.cookie_domain string

session.cookie_domain specifies the domain to set in session_cookie. Default is none at all. See also session_get_cookie_params() and session_set_cookie_params().

session.cookie_secure boolean

session.cookie_secure specifies whether cookies should only be sent over secure connections. Defaults to off. This setting was added in PHP 4.0.4. See also session_get_cookie_params() and session_set_cookie_params().

session.cache_limiter string

session.cache_limiter specifies cache control method to use for session pages (none/nocache/private/private_no_expire/public). Defaults to nocache. See also session_cache_limiter().

session.cache_expire integer

session.cache_expire specifies time-to-live for cached session pages in minutes, this has no effect for nocache limiter. Defaults to 180. See also session_cache_expire().

session.use_trans_sid boolean

session.use_trans_sid whether transparent sid support is enabled or not. Defaults to 0 (disabled).

참고: For PHP 4.1.2 or less, it is enabled by compiling with --enable-trans-sid. From PHP 4.2.0, trans-sid feature is always compiled.

URL based session management has additional security risks compared to cookie based session management. Users may send a URL that contains an active session ID to their friends by email or users may save a URL that contains a session ID to their bookmarks and access your site with the same session ID always, for example.

session.bug_compat_42 boolean

PHP versions 4.2.0 and lower have an undocumented feature/bug that allows you to to initialize a session variable in the global scope, albeit register_globals is disabled. PHP 4.3.0 and later will warn you, if this feature is used, and if session.bug_compat_warn is also enabled.

session.bug_compat_warn boolean

PHP versions 4.2.0 and lower have an undocumented feature/bug that allows you to to initialize a session variable in the global scope, albeit register_globals is disabled. PHP 4.3.0 and later will warn you, if this feature is used by enabling both session.bug_compat_42 and session.bug_compat_warn.

session.hash_function integer

session.hash_function allows you to specify the hash algorithm used to generate the session IDs. '0' means MD5 (128 bits) and '1' means SHA-1 (160 bits).

참고: This was introduced in PHP 5.

session.hash_bits_per_character integer

session.hash_bits_per_character allows you to define how many bits are stored in each character when converting the binary hash data to something readable. The possible values are '4' (0-9, a-f), '5' (0-9, a-v), and '6' (0-9, a-z, A-Z, "-", ",").

참고: This was introduced in PHP 5.

url_rewriter.tags string

url_rewriter.tags specifies which HTML tags are rewritten to include session id if transparent sid support is enabled. Defaults to a=href,area=href,frame=src,input=src,form=fakeentry,fieldset=

참고: If you want XHTML conformity, remove the form entry and use the <fieldset> tags around your form fields.

The track_vars and register_globals configuration settings influence how the session variables get stored and restored.

참고: As of PHP 4.0.3, track_vars is always turned on.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

SID (string)

Constant containing either the session name and session ID in the form of "name=ID" or empty string if session ID was set in an appropriate session cookie.

예제

참고: As of PHP 4.1.0, $_SESSION is available as a global variable just like $_POST, $_GET, $_REQUEST and so on. Unlike $HTTP_SESSION_VARS, $_SESSION is always global. Therefore, you do not need to use the global keyword for $_SESSION. Please note that this documentation has been changed to use $_SESSION everywhere. You can substitute $HTTP_SESSION_VARS for $_SESSION, if you prefer the former. Also note that you must start your session using session_start() before use of $_SESSION becomes available.

The keys in the $_SESSION associative array are subject to the same limitations as regular variable names in PHP, i.e. they cannot start with a number and must start with a letter or underscore. For more details see the section on variables in this manual.

If register_globals is disabled, only members of the global associative array $_SESSION can be registered as session variables. The restored session variables will only be available in the array $_SESSION.

Use of $_SESSION (or $HTTP_SESSION_VARS with PHP 4.0.6 or less) is recommended for improved security and code readability. With $_SESSION, there is no need to use the session_register(), session_unregister(), session_is_registered() functions. Session variables are accessible like any other variables.

예 1. Registering a variable with $_SESSION.

<?php
session_start();
// Use $HTTP_SESSION_VARS with PHP 4.0.6 or less
if (!isset($_SESSION['count'])) {
    $_SESSION['count'] = 0;
} else {
    $_SESSION['count']++;
}
?>

예 2. Unregistering a variable with $_SESSION and register_globals disabled.

<?php
session_start();
// Use $HTTP_SESSION_VARS with PHP 4.0.6 or less
unset($_SESSION['count']);
?>

경고

Do NOT unset the whole $_SESSION with unset($_SESSION) as this will disable the registering of session variables through the $_SESSION superglobal.

예 3. Unregistering a variable with register_globals enabled, after registering it using $_SESSION.

<?php
session_start();
// With PHP 4.3 and later, you can also simply use the prior example.
session_unregister('count');
?>

If register_globals is enabled, then each global variable can be registered as session variable. Upon a restart of a session, these variables will be restored to corresponding global variables. Since PHP must know which global variables are registered as session variables, users need to register variables with session_register() function. You can avoid this by simply setting entries in $_SESSION.

경고

If you are using $_SESSION and disable register_globals, do not use session_register(), session_is_registered() and session_unregister(), if your scripts shall work in PHP 4.2 and earlier. You can use these functions in 4.3 and later.

If you enable register_globals, session_unregister() should be used since session variables are registered as global variables when session data is deserialized. Disabling register_globals is recommended for both security and performance reasons.

예 4. Registering a variable with register_globals enabled

<?php
if (! isset($_SESSION['count'])) {
    $_SESSION['count'] = 1;
} else {
    $_SESSION['count']++;
}
?>

If register_globals is enabled, then the global variables and the $_SESSION entries will automatically reference the same values which were registered in the prior session instance.

There is a defect in PHP 4.2.3 and earlier. If you register a new session variable by using session_register(), the entry in the global scope and the $_SESSION entry will not reference the same value until the next session_start(). I.e. a modification to the newly registered global variable will not be reflected by the $_SESSION entry. This has been corrected in PHP 4.3.

Passing the Session ID

There are two methods to propagate a session id:

  • Cookies

  • URL parameter

The session module supports both methods. Cookies are optimal, but because they are not always available, we also provide an alternative way. The second method embeds the session id directly into URLs.

PHP is capable of transforming links transparently. Unless you are using PHP 4.2 or later, you need to enable it manually when building PHP. Under Unix, pass --enable-trans-sid to configure. If this build option and the run-time option session.use_trans_sid are enabled, relative URIs will be changed to contain the session id automatically.

참고: The arg_separator.output php.ini directive allows to customize the argument seperator. For full XHTML conformance, specify &amp; there.

Alternatively, you can use the constant SID which is always defined. If the client did not send an appropriate session cookie, it has the form session_name=session_id. Otherwise, it expands to an empty string. Thus, you can embed it unconditionally into URLs.

The following example demonstrates how to register a variable, and how to link correctly to another page using SID.

예 5. Counting the number of hits of a single user

<?php
if (!session_is_registered('count')) {
    session_register('count');
    $count = 1;
} else {
    $count++;
}
?>

<p>
Hello visitor, you have seen this page <?php echo $count; ?> times.
</p>

<p>
To continue, <a href="nextpage.php?<?php echo strip_tags(SID); ?>">click
here</a>.
</p>

The strip_tags() is used when printing the SID in order to prevent XSS related attacks.

Printing the SID, like shown above, is not necessary if --enable-trans-sid was used to compile PHP.

참고: Non-relative URLs are assumed to point to external sites and hence don't append the SID, as it would be a security risk to leak the SID to a different server.

Custom Session Handlers

To implement database storage, or any other storage method, you will need to use session_set_save_handler() to create a set of user-level storage functions.

차례
session_cache_expire -- Return current cache expire
session_cache_limiter -- Get and/or set the current cache limiter
session_commit -- Alias of session_write_close()
session_decode -- Decodes session data from a string
session_destroy -- Destroys all data registered to a session
session_encode -- Encodes the current session data as a string
session_get_cookie_params -- Get the session cookie parameters
session_id -- Get and/or set the current session id
session_is_registered -- Find out whether a global variable is registered in a session
session_module_name -- Get and/or set the current session module
session_name -- Get and/or set the current session name
session_regenerate_id -- Update the current session id with a newly generated one
session_register -- Register one or more global variables with the current session
session_save_path -- Get and/or set the current session save path
session_set_cookie_params -- Set the session cookie parameters
session_set_save_handler -- Sets user-level session storage functions
session_start -- Initialize session data
session_unregister -- Unregister a global variable from the current session
session_unset -- Free all session variables
session_write_close -- Write session data and end session

이전 | 처음으로 | 다음
sesam_settransaction | 위로 | session_cache_expire


session_cache_expire

(PHP 4 >= 4.2.0, PHP 5)

session_cache_expire -- Return current cache expire

Description

int session_cache_expire ( [int new_cache_expire])

session_cache_expire() returns the current setting of session.cache_expire. The value returned should be read in minutes, defaults to 180. If new_cache_expire is given, the current cache expire is replaced with new_cache_expire.

The cache expire is reset to the default value of 180 stored in session.cache_limiter at request startup time. Thus, you need to call session_cache_expire() for every request (and before session_start() is called).

예 1. session_cache_expire() example

<?php

/* set the cache limiter to 'private' */

session_cache_limiter('private');
$cache_limiter = session_cache_limiter();

/* set the cache expire to 30 minutes */
session_cache_expire(30);
$cache_expire = session_cache_expire();

/* start the session */

session_start();

echo "The cache limiter is now set to $cache_limiter</ br>";
echo "The cached session pages expire after $cache_expire minutes";
?>

참고: Setting new_cache_expire is of value only, if session.cache_limiter is set to a value different from nocache.

See also the configuration settings session.cache_expire, session.cache_limiter and session_cache_limiter().

이전 | 처음으로 | 다음
Session Handling Functions | 위로 | session_cache_limiter


session_cache_limiter

(PHP 4 >= 4.0.3, PHP 5)

session_cache_limiter -- Get and/or set the current cache limiter

Description

string session_cache_limiter ( [string cache_limiter])

session_cache_limiter() returns the name of the current cache limiter. If cache_limiter is specified, the name of the current cache limiter is changed to the new value.

The cache limiter defines which cache control HTTP headers are sent to the client. These headers determine the rules by which the page content may be cached by the client and intermediate proxies. Setting the cache limiter to nocache disallows any client/proxy caching. A value of public permits caching by proxies and the client, whereas private disallows caching by proxies and permits the client to cache the contents.

In private mode, the Expire header sent to the client may cause confusion for some browsers, including Mozilla. You can avoid this problem by using private_no_expire mode. The expire header is never sent to the client in this mode.

참고: private_no_expire was added in PHP 4.2.0.

The cache limiter is reset to the default value stored in session.cache_limiter at request startup time. Thus, you need to call session_cache_limiter() for every request (and before session_start() is called).

예 1. session_cache_limiter() example

<?php

/* set the cache limiter to 'private' */

session_cache_limiter('private');
$cache_limiter = session_cache_limiter();

echo "The cache limiter is now set to $cache_limiter<p>";
?>

Also see the session.cache_limiter configuration directive.

이전 | 처음으로 | 다음
session_cache_expire | 위로 | session_commit


session_commit

session_commit -- Alias of session_write_close()

Description

This function is an alias of session_write_close().

이전 | 처음으로 | 다음
session_cache_limiter | 위로 | session_decode


session_decode

(PHP 4 , PHP 5)

session_decode -- Decodes session data from a string

Description

bool session_decode ( string data)

session_decode() decodes the session data in data, setting variables stored in the session.

See also session_encode().

이전 | 처음으로 | 다음
session_commit | 위로 | session_destroy


session_destroy

(PHP 4 , PHP 5)

session_destroy -- Destroys all data registered to a session

Description

bool session_destroy ( void )

session_destroy() destroys all of the data associated with the current session. It does not unset any of the global variables associated with the session, or unset the session cookie.

This function returns TRUE on success and FALSE on failure to destroy the session data.

예 1. Destroying a session

<?php

// Initialize the session.
// If you are using session_name("something"), don't forget it now!
session_start();
// Unset all of the session variables.
session_unset();
// Finally, destroy the session.
session_destroy();

?>

예 2. Destroying a session with $_SESSION

<?php

// Initialize the session.
// If you are using session_name("something"), don't forget it now!
session_start();
// Unset all of the session variables.
$_SESSION = array();
// Finally, destroy the session.
session_destroy();

?>

이전 | 처음으로 | 다음
session_decode | 위로 | session_encode


session_encode

(PHP 4 , PHP 5)

session_encode -- Encodes the current session data as a string

Description

string session_encode ( void )

session_encode() returns a string with the contents of the current session encoded within.

See also session_decode()

이전 | 처음으로 | 다음
session_destroy | 위로 | session_get_cookie_params


session_get_cookie_params

(PHP 4 , PHP 5)

session_get_cookie_params -- Get the session cookie parameters

Description

array session_get_cookie_params ( void )

The session_get_cookie_params() function returns an array with the current session cookie information, the array contains the following items:

  • "lifetime" - The lifetime of the cookie in seconds.

  • "path" - The path where information is stored.

  • "domain" - The domain of the cookie.

  • "secure" - The cookie should only be sent over secure connections. (This item was added in PHP 4.0.4.)

See also the configuration directives session.cookie_lifetime, session.cookie_path, session.cookie_domain, session.cookie_secure, and session_set_cookie_params().

이전 | 처음으로 | 다음
session_encode | 위로 | session_id


session_id

(PHP 4 , PHP 5)

session_id -- Get and/or set the current session id

Description

string session_id ( [string id])

session_id() returns the session id for the current session.

If id is specified, it will replace the current session id. session_id() needs to be called before session_start() for that purpose. Depending on the session handler, not all characters are allowed within the session id. For example, the file session handler only allows characters in the range a-z, A-Z and 0-9!

참고: When using session cookies, specifying an id for session_id() will always send a new cookie when session_start() is called, regardless if the current session id is identical to the one being set.

The constant SID can also be used to retrieve the current name and session id as a string suitable for adding to URLs. Note that SID is only defined if the client didn't send the right cookie. See also Session handling.

See also session_start(), session_set_save_handler(), and session.save_handler.

이전 | 처음으로 | 다음
session_get_cookie_params | 위로 | session_is_registered


session_is_registered

(PHP 4 , PHP 5)

session_is_registered -- Find out whether a global variable is registered in a session

Description

bool session_is_registered ( string name)

session_is_registered() returns TRUE if there is a global variable with the name name registered in the current session.

참고: If $_SESSION (or $HTTP_SESSION_VARS for PHP 4.0.6 or less) is used, use isset() to check a variable is registered in $_SESSION.

경고

If you are using $_SESSION (or $HTTP_SESSION_VARS), do not use session_register(), session_is_registered() and session_unregister().

이전 | 처음으로 | 다음
session_id | 위로 | session_module_name


session_module_name

(PHP 4 , PHP 5)

session_module_name -- Get and/or set the current session module

Description

string session_module_name ( [string module])

session_module_name() returns the name of the current session module. If module is specified, that module will be used instead.

이전 | 처음으로 | 다음
session_is_registered | 위로 | session_name


session_name

(PHP 4 , PHP 5)

session_name -- Get and/or set the current session name

Description

string session_name ( [string name])

session_name() returns the name of the current session. If name is specified, the name of the current session is changed to its value.

The session name references the session id in cookies and URLs. It should contain only alphanumeric characters; it should be short and descriptive (i.e. for users with enabled cookie warnings). The session name is reset to the default value stored in session.name at request startup time. Thus, you need to call session_name() for every request (and before session_start() or session_register() are called).

예 1. session_name() examples

<?php

/* set the session name to WebsiteID */

$previous_name = session_name("WebsiteID");

echo "The previous session name was $previous_name<p>";
?>

See also the session.name configuration directive.

이전 | 처음으로 | 다음
session_module_name | 위로 | session_regenerate_id


session_regenerate_id

(PHP 4 >= 4.3.2, PHP 5)

session_regenerate_id -- Update the current session id with a newly generated one

Description

bool session_regenerate_id ( void )

session_regenerate_id() will replace the current session id with a new one, and keep the current session information.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. A session_regenerate_id() example

<?php
session_start();

$old_sessionid = session_id();

session_regenerate_id();

$new_sessionid = session_id();

echo "Old Session: $old_sessionid<br />";
echo "New Session: $new_sessionid<br />";

print_r($_SESSION);
?>

참고: As of PHP 4.3.3, if session cookies are enabled, use of session_regenerate_id() will also submit a new session cookie with the new session id.

See also session_id(),
session_start(), and
session_name().

이전 | 처음으로 | 다음
session_name | 위로 | session_register


session_register

(PHP 4 , PHP 5)

session_register -- Register one or more global variables with the current session

Description

bool session_register ( mixed name [, mixed ...])

session_register() accepts a variable number of arguments, any of which can be either a string holding the name of a variable or an array consisting of variable names or other arrays. For each name, session_register() registers the global variable with that name in the current session.

경고

If you want your script to work regardless of register_globals, you need to instead use the $_SESSION array as $_SESSION entries are automatically registered. If your script uses session_register(), it will not work in environments where the PHP directive register_globals is disabled.

register_globals: 중요 경고: PHP 4.2.0부터는 PHP 설정 register_globals의 기본값은 off입니다. PHP 커뮤니티에서는, 이 설정에 의존하지 않는 superglobals와 같은 다른 방법을 이용하기를 권장합니다.

경고

This registers a global variable. If you want to register a session variable from within a function, you need to make sure to make it global using the global keyword or the $GLOBALS[] array, or use the special session arrays as noted below.

경고

If you are using $_SESSION (or $HTTP_SESSION_VARS), do not use session_register(), session_is_registered(), and session_unregister().

This function returns TRUE when all of the variables are successfully registered with the session.

If session_start() was not called before this function is called, an implicit call to session_start() with no parameters will be made. $_SESSION does not mimic this behavior and requires session_start() before use.

You can also create a session variable by simply setting the appropriate member of the $_SESSION or $HTTP_SESSION_VARS (PHP < 4.1.0) array.

<?php
// Use of session_register() is deprecated
$barney = "A big purple dinosaur.";
session_register("barney");

// Use of $_SESSION is preferred, as of PHP 4.1.0
$_SESSION["zim"] = "An invader from another planet.";

// The old way was to use $HTTP_SESSION_VARS
$HTTP_SESSION_VARS["spongebob"] = "He's got square pants.";
?>

참고: It is currently impossible to register resource variables in a session. For example, you cannot create a connection to a database and store the connection id as a session variable and expect the connection to still be valid the next time the session is restored. PHP functions that return a resource are identified by having a return type of resource in their function definition. A list of functions that return resources are available in the resource types appendix.

If $_SESSION (or $HTTP_SESSION_VARS for PHP 4.0.6 or less) is used, assign values to $_SESSION. For example: $_SESSION['var'] = 'ABC';

See also session_is_registered(), session_unregister(), and $_SESSION.

이전 | 처음으로 | 다음
session_regenerate_id | 위로 | session_save_path


session_save_path

(PHP 4 , PHP 5)

session_save_path -- Get and/or set the current session save path

Description

string session_save_path ( [string path])

session_save_path() returns the path of the current directory used to save session data. If path is specified, the path to which data is saved will be changed. session_save_path() needs to be called before session_start() for that purpose.

참고: On some operating systems, you may want to specify a path on a filesystem that handles lots of small files efficiently. For example, on Linux, reiserfs may provide better performance than ext2fs.

See also the session.save_path configuration directive.

이전 | 처음으로 | 다음
session_register | 위로 | session_set_cookie_params


session_set_cookie_params

(PHP 4 , PHP 5)

session_set_cookie_params -- Set the session cookie parameters

Description

void session_set_cookie_params ( int lifetime [, string path [, string domain [, bool secure]]])

Set cookie parameters defined in the php.ini file. The effect of this function only lasts for the duration of the script. Thus, you need to call session_set_cookie_params() for every request and before session_start() is called.

참고: The secure parameter was added in PHP 4.0.4.

See also the configuration directives session.cookie_lifetime, session.cookie_path, session.cookie_domain, session.cookie_secure, and session_get_cookie_params().

이전 | 처음으로 | 다음
session_save_path | 위로 | session_set_save_handler


session_set_save_handler

(PHP 4 , PHP 5)

session_set_save_handler -- Sets user-level session storage functions

Description

bool session_set_save_handler ( string open, string close, string read, string write, string destroy, string gc)

session_set_save_handler() sets the user-level session storage functions which are used for storing and retrieving data associated with a session. This is most useful when a storage method other than those supplied by PHP sessions is preferred. i.e. Storing the session data in a local database. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: The "write" handler is not executed until after the output stream is closed. Thus, output from debugging statements in the "write" handler will never be seen in the browser. If debugging output is necessary, it is suggested that the debug output be written to a file instead.

참고: The write handler is not executed if the session contains no data; this applies even if empty session variables are registered. This differs to the default file-based session save handler, which creates empty session files.

The following example provides file based session storage similar to the PHP sessions default save handler files. This example could easily be extended to cover database storage using your favorite PHP supported database engine.

Read function must return string value always to make save handler work as expected. Return empty string if there is no data to read. Return values from other handlers are converted to boolean expression. TRUE for success, FALSE for failure.

예 1. session_set_save_handler() example

<?php
function open($save_path, $session_name)
{
  global $sess_save_path, $sess_session_name;

  $sess_save_path = $save_path;
  $sess_session_name = $session_name;
  return(true);
}

function close()
{
  return(true);
}

function read($id)
{
  global $sess_save_path, $sess_session_name;

  $sess_file = "$sess_save_path/sess_$id";
  if ($fp = @fopen($sess_file, "r")) {
    $sess_data = fread($fp, filesize($sess_file));
    return($sess_data);
  } else {
    return(""); // Must return "" here.
  }

}

function write($id, $sess_data)
{
  global $sess_save_path, $sess_session_name;

  $sess_file = "$sess_save_path/sess_$id";
  if ($fp = @fopen($sess_file, "w")) {
    return(fwrite($fp, $sess_data));
  } else {
    return(false);
  }

}

function destroy($id)
{
  global $sess_save_path, $sess_session_name;

  $sess_file = "$sess_save_path/sess_$id";
  return(@unlink($sess_file));
}

/*********************************************
* WARNING - You will need to implement some *
* sort of garbage collection routine here.  *
*********************************************/
function gc($maxlifetime)
{
  return true;
}

session_set_save_handler("open", "close", "read", "write", "destroy", "gc");

session_start();

// proceed to use sessions normally

?>

See also the session.save_handler configuration directive.

이전 | 처음으로 | 다음
session_set_cookie_params | 위로 | session_start


session_start

(PHP 4 , PHP 5)

session_start -- Initialize session data

Description

bool session_start ( void )

session_start() creates a session or resumes the current one based on the current session id that's being passed via a request, such as GET, POST, or a cookie.

This function always returns TRUE.

참고: If you are using cookie-based sessions, you must call session_start() before anything is outputted to the browser.

예 1. A session example: page1.php

<?php
// page1.php

session_start();

echo 'Welcome to page #1';

$_SESSION['favcolor'] = 'green';
$_SESSION['animal']   = 'cat';
$_SESSION['time']     = time();

// Works if session cookie was accepted
echo '<br /><a href="page2.php">page 2</a>';

// Or maybe pass along the session id, if needed
echo '<br /><a href="page2.php?' . SID . '">page 2</a>';
?>

After viewing page1.php, the second page page2.php will magically contain the session data. Read the session reference for information on propagating session ids as it, for example, explains what the constant SID is all about.

예 2. A session example: page2.php

<?php
// page2.php

session_start();

echo 'Welcome to page #2<br />';

echo $_SESSION['favcolor']; // green
echo $_SESSION['animal'];   // cat
echo date('Y m d H:i:s', $_SESSION['time']);

// You may want to use SID here, like we did in page1.php
echo '<br /><a href="page1.php">page 1</a>';
?>

If you want to use a named session, you must call session_name() before calling session_start().

session_start() will register internal output handler for URL rewriting when trans-sid is enabled. If a user uses ob_gzhandler or like with ob_start(), the order of output handler is important for proper output. For example, user must register ob_gzhandler before session start.

참고: Use of zlib.output_compression is recommended rather than ob_gzhandler()

참고: As of PHP 4.3.3, calling session_start() while the session has already been started will result in an error of level E_NOTICE. Also, the second session start will simply be ignored.

See also $_SESSION, session.auto_start, and session_id().

이전 | 처음으로 | 다음
session_set_save_handler | 위로 | session_unregister


session_unregister

(PHP 4 , PHP 5)

session_unregister -- Unregister a global variable from the current session

Description

bool session_unregister ( string name)

session_unregister() unregisters the global variable named name from the current session.

This function returns TRUE when the variable is successfully unregistered from the session.

참고: If $_SESSION (or $HTTP_SESSION_VARS for PHP 4.0.6 or less) is used, use unset() to unregister a session variable. Do not unset() $_SESSION itself as this will disable the special function of the $_SESSION superglobal.

경고

This function does not unset the corresponding global variable for name, it only prevents the variable from being saved as part of the session. You must call unset() to remove the corresponding global variable.

경고

If you are using $_SESSION (or $HTTP_SESSION_VARS), do not use session_register(), session_is_registered() and session_unregister().

이전 | 처음으로 | 다음
session_start | 위로 | session_unset


session_unset

(PHP 4 , PHP 5)

session_unset -- Free all session variables

Description

void session_unset ( void )

The session_unset() function frees all session variables currently registered.

참고: If $_SESSION (or $HTTP_SESSION_VARS for PHP 4.0.6 or less) is used, use unset() to unregister a session variable, i.e. unset ($_SESSION['varname']);.

경고

Do NOT unset the whole $_SESSION with unset($_SESSION) as this will disable the registering of session variables through the $_SESSION superglobal.

이전 | 처음으로 | 다음
session_unregister | 위로 | session_write_close


session_write_close

(PHP 4 >= 4.0.4, PHP 5)

session_write_close -- Write session data and end session

Description

void session_write_close ( void )

End the current session and store session data.

Session data is usually stored after your script terminated without the need to call session_write_close(), but as session data is locked to prevent concurrent writes only one script may operate on a session at any time. When using framesets together with sessions you will experience the frames loading one by one due to this locking. You can reduce the time needed to load all the frames by ending the session as soon as all changes to session variables are done.

이전 | 처음으로 | 다음
session_unset | 위로 | 공유 메모리 함수


공유 메모리 함수

PHP 매뉴얼
이전 다음

XCVII. 공유 메모리 함수

Shmop는 Unix 공유 메모리 세그먼트를 php에서 읽고, 기록하고, 생성하고, 삭제하기 쉽도록 하는 함수 모음이다. 이 함수는 윈도우즈에서는 공유 메모리를 지원하지 않기 때문에 동작하지 않는다. shmop를 사용하기 위해서는 --enable-shmop 인자로 php를 컴파일해야한다.

참고: 이번 장에서는 PHP 4.0.3의 shm_() 단어로 시작되는 함수를 설명할 것이다. 그러나 PHP 4.0.4 이후 버전의 경우 shmop_()로 이름만 바뀌었다.

예 1. 공유 메모리 작동의 개관

<?php

// Create 100 byte shared memory block with system id if 0xff3
$shm_id = shmop_open(0xff3, "c", 0644, 100);
if(!$shm_id) {
    echo "Couldn't create shared memory segment\n";
}

// Get shared memory block's size
$shm_size = shmop_size($shm_id);
echo "SHM Block Size: ".$shm_size. " has been created.\n";

// Lets write a test string into shared memory
$shm_bytes_written = shmop_write($shm_id, "my shared memory block", 0);
if($shm_bytes_written != strlen("my shared memory block")) {
    echo "Couldn't write the entire length of data\n";
}

// Now lets read the string back
$my_string = shmop_read($shm_id, 0, $shm_size);
if(!$my_string) {
    echo "Couldn't read from shared memory block\n";
}
echo "The data inside shared memory was: ".$my_string."\n";

//Now lets delete the block and close the shared memory segment
if(!shmop_delete($shm_id)) {
    echo "Couldn't mark shared memory block for deletion.";
}
shmop_close($shm_id);

?>

차례
shmop_close -- 공유 메모리 블럭을 닫음
shmop_delete -- 공유 메모리 블럭을 삭제
shmop_open -- 공유 메모리 블럭을 열거나 생성
shmop_read -- 공유 메모리 블럭으로부터 데이터를 판독
shmop_size -- Get size of shared memory block
shmop_write -- 공유 메모리 블럭에 자료 기록

이전 | 처음으로 | 다음
session_write_close | 위로 | shmop_close


shmop_close

(PHP 4 >= 4.0.4, PHP 5)

shmop_close -- 공유 메모리 블럭을 닫음

설명

int shmop_close ( int shmid)

shmop_close()는 공유 메모리 블럭을 닫는데 사용된다.

shmop_close()는 shmop_open()으로 생성된 공유 메모리 블럭 identifier인 shmid를 인자로 가진다.

예 1. 공유 메모리 블럭 닫기

<?php
shmop_close($shm_id);
?>

위의 예제는 $shm_id 인자로 지정된 공유 메모리 블럭을 닫는다.

이전 | 처음으로 | 다음
공유 메모리 함수 | 위로 | shmop_delete


shmop_delete

(PHP 4 >= 4.0.4, PHP 5)

shmop_delete -- 공유 메모리 블럭을 삭제

설명

int shmop_delete ( int shmid)

shmop_delete()는 공유 메모리 블럭을 삭제하는데 사용된다.

shmop_delete()함수는 shmop_open()으로 생성된 공유 메모리 블럭 identifier인 shmid를 인자로 가진다. 성공하면 1을 반환하고 실패하면 0을 반환한다.

예 1. 공유 메모리 블럭 삭제

<?php
shmop_delete($shm_id);
?>

위 예제는 $shm_id 인자로 지정된 공유 메모리 블럭을 삭제한다.

이전 | 처음으로 | 다음
shmop_close | 위로 | shmop_open


shmop_open

(PHP 4 >= 4.0.4, PHP 5)

shmop_open -- 공유 메모리 블럭을 열거나 생성

Description

int shmop_open ( int key, string flags, int mode, int size)

shmop_open()은 공유 메모리 블럭을 생성하거나 여는데 쓰인다.

shmop_open()은 4가지 인자가 쓰인다: 첫번째 인자인 공유 메모리 블럭의 시스템의 id를 위한 key. 이 인자는 10진수 또는 16진수로 지정된다. 두번째 인자는 flags로 다음과 같이 쓰인다:

  • "a" : 접근 (IPC_EXCL 상수로 설정) 존재하고 있는 공유 메모리 세그먼트를 여는데 이 flag를 사용.

  • "c" : 생성 (IPC_CREATE 상수로 설정) 새로운 공유 메모리 세그먼트를 생성하려할 때 이 flag를 사용.

세번째 인자는 메모리 세그컨트를 할당하기를 원하는 파일의 퍼미션과 동일한 방식의 퍼미션 모드이다. 퍼미션은 0644와 같이 8진수로 지정되어야 한다. 마지막 인자는 바이트 단위의 생성할 공유 메모리 블럭 크기이다.

참고: 주의: 세번째와 네번째 인자는 존재하고 있는 메모리 세그먼트를 열때는 0을 지정해야만 한다. shmop_open()함수가 성공하면 생성된 공유 메모리 세그먼트를 접근하기 위해 사용될 id를 반환할 것이다.

예 1. Create a new shared memory block

<?php
$shm_id = shmop_open(0x0fff, "c", 0644, 100);
?>

위의 예제는 시스템 id 0x0fff를 가진 공유 메모리 블럭을 열도록 한다.

이전 | 처음으로 | 다음
shmop_delete | 위로 | shmop_read


shmop_read

(PHP 4 >= 4.0.4, PHP 5)

shmop_read -- 공유 메모리 블럭으로부터 데이터를 판독

설명

string shmop_read ( int shmid, int start, int count)

shmop_read()함수는 공유 메모리 블럭으로부터 문자열을 읽는다.

shmop_read()함수는 3개의 인자를 가진다: shmop_open()에 의해 생성된 공유 메모리 블럭 identifier인 shmid, 읽기 시작할 offset, 읽어낼 바이트 수를 나타내는 count.

예 1. 공유 메모리 블럭 판독

<?php
$shm_data = shmop_read($shm_id, 0, 50);
?>

위의 예제는 공유 메모리 블럭에서 50 바이트를 읽어 $shm_data 변수에 기록할 것이다.

이전 | 처음으로 | 다음
shmop_open | 위로 | shmop_size


shmop_size

(PHP 4 >= 4.0.4, PHP 5)

shmop_size -- Get size of shared memory block

Description

int shmop_size ( int shmid)

shmop_size() is used to get the size, in bytes of the shared memory block.

shmop_size() takes the shmid, which is the shared memory block identifier created by shmop_open(), the function will return and int, which represents the number of bytes the shared memory block occupies.

예 1. Getting the size of the shared memory block

<?php
$shm_size = shmop_size($shm_id);
?>

This example will put the size of shared memory block identified by $shm_id into $shm_size.

이전 | 처음으로 | 다음
shmop_read | 위로 | shmop_write


shmop_write

(PHP 4 >= 4.0.4, PHP 5)

shmop_write -- 공유 메모리 블럭에 자료 기록

설명

int shmop_write ( int shmid, string data, int offset)

shmop_write()함수는 공유 메모리 블럭으로 문자열을 기록할 것이다.

shmop_write()함수는 3개의 인자를 가진다: shmop_open()에 의해 생성된 공유 메모리 블럭 identifier인 shmid, 공유 메모리 블럭에 기록하기를 원하는 문자열인 data, 공유 메모리 세그먼트 내부에 기록을 시작할 데이터의 위치를 지정한 offset.

예 1. 공유 메모리 블럭으로 기록

<?php
$shm_bytes_written = shmop_write($shm_id, $my_string, 0);
?>

위의 예제는 $my_string을 공유 메모리 블럭에 기록하고, 기록된 바이트 수를 $shm_bytes_written에 반환한다.

이전 | 처음으로 | 다음
shmop_size | 위로 | SimpleXML functions


SimpleXML functions

PHP 매뉴얼
이전 다음

XCVIII. SimpleXML functions

소개

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

The SimpleXML extension provides a very simple and easily usable toolset to convert XML to an object that can be processed with normal property selectors and array iterators.

설치

This extension is only available if PHP was configured with --enable-simplexml. The PHP configuration script does this by default.

예제

Many examples in this reference require an XML string. Instead of repeating this string in every example, we put it into a file which we include in each example. This included file is shown in the following example section. Alternatively, you could create an XML document and read it with simplexml_load_file().

예 1. Include file example.php with XML string

<?php
$xmlstr = <<<XML
<?xml version='1.0' standalone='yes'?>
<movies>
<movie>
  <title>PHP: Behind the Parser</title>
  <characters>
   <character>
    <name>Ms. Coder</name>
    <actor>Onlivia Actora</actor>
   </character>
   <character>
    <name>Mr. Coder</name>
    <actor>El Act&#211;r</actor>
   </character>
  </characters>
  <plot>
   So, this language. It's like, a programming language. Or is it a
   scripting language? All is revealed in this thrilling horror spoof
   of a documentary.
  </plot>
  <rating type="thumbs">7</rating>
  <rating type="stars">5</rating>
</movie>
</movies>
XML;?>

The simplicity of SimpleXML appears most clearly when one extracts a string or number from a basic XML document.

예 2. Getting <plot>

<?php
include 'example.php';

$xml = simplexml_load_string($xmlstr);

echo $xml->movie[0]->plot; // "So this language. It's like..."
?>

예 3. Accessing non-unique elements in SimpleXML

When multiple instances of an element exist as children of a single parent element, normal iteration techniques apply.

<?php
include 'example.php';

$xml = simplexml_load_string($xmlstr);

/* For each <movie> node, we echo a separate <plot>. */
foreach ($xml->movie as $movie) {
   echo $movie->plot, '<br />';
}

?>

예 4. Using attributes

So far, we have only covered the work of reading element names and their values. SimpleXML can also access element attributes. Access attributes of an element just as you would elements of an array.

<?php
include 'example.php';

$xml = simplexml_load_string($xmlstr);

/* Access the <rating> nodes of the first movie.
* Output the rating scale, too. */
foreach ($xml->movie[0]->rating as $rating) {
    switch((string) $rating['type']) { // Get attributes as element indices
    case 'thumbs':
        echo $rating, ' thumbs up';
        break;
    case 'stars':
        echo $rating, ' stars';
        break;
    }
}
?>

예 5. Comparing Elements and Attributes with Text

To compare an element or attribute with a string or pass it into a function that requires a string, you must cast it to a string using (string). Otherwise, PHP treats the element as an object.

<?php
include 'example.php';

$xml = simplexml_load_string($xmlstr);

if ((string) $xml->movie->title == 'PHP: Behind the Parser') {
    print 'My favorite movie.';
}

htmlentities((string) $xml->movie->title);
?>

예 6. Using Xpath

SimpleXML includes builtin Xpath support. To find all <character> elements:

<?php
include 'example.php';
$xml = simplexml_load_string($xmlstr);

foreach ($xml->xpath('//character') as $character) {
    echo $character->name, 'played by ', $character->actor, '<br />';
}
?>

'//' serves as a wildcard. To specify absolute paths, omit one of the slashes.

예 7. Setting values

Data in SimpleXML doesn't have to be constant. The object allows for manipulation of all of its elements.

<?php
include 'example.php';
$xml = simplexml_load_string($xmlstr);

$xml->movie[0]->actor[0]->age = '21';

echo $xml->asXML();
?>

The above code will output a new XML document, just like the original, except that the new XML will define Ms. Coder's age as 21.

예 8. DOM Interoperability

PHP has a mechanism to convert XML nodes between SimpleXML and DOM formats. This example shows how one might change a DOM element to SimpleXML.

<?php
$dom = new domDocument;
$dom->loadXML('<books><book><title>blah</title></book></books>');
if (!$dom) {
     echo 'Error while parsing the document';
     exit;
}

$s = simplexml_import_dom($dom);

echo $s->book[0]->title;
?>

차례
simplexml_element->asXML -- Return a well-formed XML string based on SimpleXML element.
simplexml_element->attributes -- Identifies an element's attributes.
simplexml_element->children -- Finds children of given node.
simplexml_element->xpath -- Runs Xpath query on XML data.
simplexml_import_dom -- Get a simplexml_element object from a DOM node.
simplexml_load_file -- Interprets an XML file into an object.
simplexml_load_string -- Interprets a string of XML into an object.

이전 | 처음으로 | 다음
shmop_write | 위로 | simplexml_element->asXML


simplexml_element->asXML

(no version information, might be only in CVS)

simplexml_element->asXML -- Return a well-formed XML string based on SimpleXML element.

Description

string simplexml_element->asXML ( void )

The asXML method formats the parent object's data in XML version 1.0.

예 1. Get XML

<?php
$string = <<<XML
<a>
<b>
  <c>text</c>
  <c>stuff</c>
</b>
<d>
  <c>code</c>
</d>
</a>
XML;
$xml = simplexml_load_string($string);

echo $xml->asXML(); // <?xml ... <a><b><c>text</c><c>stuff</c> ...

?>

asXML also works on Xpath results:

예 2. Using asXML() on Xpath results

<?php
// Continued from example XML above.

/* Search for <a><b><c> */
$result = $xml->xpath('/a/b/c');

while(list( , $node) = each($result)) {
    echo $node->asXML(); // <c>text</c> and <c>stuff</c>
}
?>

이전 | 처음으로 | 다음
SimpleXML functions | 위로 | simplexml_element->attributes


simplexml_element->attributes

(no version information, might be only in CVS)

simplexml_element->attributes -- Identifies an element's attributes.

Description

object simplexml_element simplexml_element->attributes ( string data)

This function provides the attributes and values defined within an xml tag.

참고: SimpleXML은 대부분의 메쏘드에 반복하여 속성을 추가하는 규칙을 가지고 있습니다. 이들은 var_dump()나 객체를 조사하는 어떠한 것으로도 볼 수 없습니다.

예 1. Interpret an XML string

<?php
$string = <<<XML
<a>
<foo name="one" game="lonely">1</foo>
</a>
XML;
$xml = simplexml_load_string($string);
foreach($xml->foo[0]->attributes() as $a => $b) {
    echo $a,'="',$b,"\"\n";
}
?>

This script will display:

name="one"
game="lonely"

이전 | 처음으로 | 다음
simplexml_element->asXML | 위로 | simplexml_element->children


simplexml_element->children

(no version information, might be only in CVS)

simplexml_element->children -- Finds children of given node.

Description

object simplexml_element simplexml_element->children ( void )

This method finds the children of the element of which it is a member. The result follows normal iteration rules.

참고: SimpleXML은 대부분의 메쏘드에 반복하여 속성을 추가하는 규칙을 가지고 있습니다. 이들은 var_dump()나 객체를 조사하는 어떠한 것으로도 볼 수 없습니다.

예 1. Traversing a children() pseudo-array

<?php
$xml = simplexml_load_string(
'<person>
<child role="son">
  <child role="daughter"/>
</child>
<child role="daughter">
  <child role="son">
   <child role="son"/>
  </child>
</child>
</person>');

foreach ($xml->children() as $second_gen) {
    echo ' The person begot a ' . $second_gen['role'];

    foreach ($second_gen->children() as $third_gen) {
        echo ' who begot a ' . $third_gen['role'] . ';';

        foreach ($third_gen->children() as $fourth_gen) {
            echo ' and that ' . $third_gen['role'] .
                ' begot a ' . $fourth_gen['role'];
        }
    }
}
?>

This script will output:

The person begot a son who begot a daughter; The person
begot a daughter who begot a son; and that son begot a son

이전 | 처음으로 | 다음
simplexml_element->attributes | 위로 | simplexml_element->xpath


simplexml_element->xpath

(no version information, might be only in CVS)

simplexml_element->xpath -- Runs Xpath query on XML data.

Description

array simplexml_element->xpath ( string path)

The xpath method searches the SimpleXML node for children matching the Xpath path. It always returns an array of simplexml_element objects.

예 1. Xpath

<?php
$string = <<<XML
<a>
<b>
  <c>text</c>
  <c>stuff</c>
</b>
<d>
  <c>code</c>
</d>
</a>
XML;
$xml = simplexml_load_string($string);

/* Search for <a><b><c> */
$result = $xml->xpath('/a/b/c');

while(list( , $node) = each($result)) {
    echo '/a/b/c: ',$node,"\n";
}

/* Relative paths also work... */
$result = $xml->xpath('b/c');

while(list( , $node) = each($result)) {
    echo 'b/c: ',$node,"\n";
}
?>

This script will display:

/a/b/c: text
/a/b/c: stuff
b/c: text
b/c: stuff

Notice that the two results are equal.

이전 | 처음으로 | 다음
simplexml_element->children | 위로 | simplexml_import_dom


simplexml_import_dom

(PHP 5)

simplexml_import_dom -- Get a simplexml_element object from a DOM node.

Description

object simplexml_element simplexml_import_dom ( domNode node)

This function takes a node of a DOM document and makes it into a SimpleXML node. This new object can then be used as a native SimpleXML element. If any errors occur, it returns FALSE.

예 1. Import DOM

<?php
$dom = new domDocument;
$dom->loadXML('<books><book><title>blah</title></book></books>');
if (!$dom) {
    echo 'Error while parsing the document';
    exit;
}

$s = simplexml_import_dom($dom);

echo $s->book[0]->title; // blah
?>

이전 | 처음으로 | 다음
simplexml_element->xpath | 위로 | simplexml_load_file


simplexml_load_file

(PHP 5)

simplexml_load_file -- Interprets an XML file into an object.

Description

object simplexml_element simplexml_load_file ( string filename)

This function will convert the well-formed XML document in the file specified by filename to an object of class simplexml_element. If any errors occur during file access or interpretation, the function returns FALSE.

예 1. Interpret an XML document

<?php
// The file test.xml contains an XML document with a root element
// and at least an element /[root]/title.

if (file_exists('test.xml')) {
    $xml = simplexml_load_file('test.xml');

    var_dump($xml);
} else {
    exit('Failed to open test.xml.');
}
?>

This script will display, on success:

simplexml_element Object
(
  [title] => Example Title
  ...
)

At this point, you can go about using $xml->title and any other elements.

See also: simplexml_load_string()

이전 | 처음으로 | 다음
simplexml_import_dom | 위로 | simplexml_load_string


simplexml_load_string

(PHP 5)

simplexml_load_string -- Interprets a string of XML into an object.

Description

object simplexml_element simplexml_load_string ( string data)

This function will take the well-formed xml string data and return an object with properties containing the data held within the xml document. If any errors occur, it returns FALSE.

예 1. Interpret an XML string

<?php
$string = <<<XML
<?xml version='1.0'?>
<document>
<title>Forty What?</title>
<from>Joe</from>
<to>Jane</to>
<body>
  I know that's the answer -- but what's the question?
</body>
</document>
XML;
$xml = simplexml_load_string($string);

var_dump($xml);
?>

This script will display:

simplexml_element Object
(
  [title] => Forty What?
  [from] => Joe
  [to] => Jane
  [body] =>
   I know that's the answer -- but what's the question?
)

At this point, you can go about using $xml->body and such.

See also: simplexml_load_file().

이전 | 처음으로 | 다음
simplexml_load_file | 위로 | SOAP Functions


SOAP Functions

PHP 매뉴얼
이전 다음

XCIX. SOAP Functions

소개

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

The SOAP extension can be used to write SOAP Servers and Clients. It supports subsets of SOAP 1.1, SOAP 1.2 and WSDL 1.1 specifications.

요구 사항

This extension makes use of the GNOME xml library. Download and install this library. You will need at least libxml-2.5.4.

설치

This extension is only available if PHP was configured with --enable-soap.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. SOAP Configuration Options

Name | Default | Changeable
soap.wsdl_cache_enabled | "1" | PHP_INI_ALL
soap.wsdl_cache_dir | "/tmp" | PHP_INI_ALL
soap.wsdl_cache_ttl | 86400 | PHP_INI_ALL
For further details and definition of the PHP_INI_* constants see ini_set().

위 설정 지시어에 대한 간단한 설명입니다.

soap.wsdl_cache_enabled boolean

Enables or disables WSDL caching feature.

soap.wsdl_cache_dir string

Sets the directory name where SOAP extension will put cache files.

soap.wsdl_cache_ttl int

(time to live) Sets the number of second while cached file will be used instead of original one.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

SOAP_1_1 (integer)

SOAP_1_2 (integer)

SOAP_PERSISTENCE_SESSION (integer)

SOAP_PERSISTENCE_REQUEST (integer)

SOAP_FUNCTIONS_ALL (integer)

SOAP_ENCODED (integer)

SOAP_LITERAL (integer)

SOAP_RPC (integer)

SOAP_DOCUMENT (integer)

SOAP_ACTOR_NEXT (integer)

SOAP_ACTOR_NONE (integer)

SOAP_ACTOR_UNLIMATERECEIVER (integer)

UNKNOWN_TYPE (integer)

XSD_STRING (integer)

XSD_BOOLEAN (integer)

XSD_DECIMAL (integer)

XSD_FLOAT (integer)

XSD_DOUBLE (integer)

XSD_DURATION (integer)

XSD_DATETIME (integer)

XSD_TIME (integer)

XSD_DATE (integer)

XSD_GYEARMONTH (integer)

XSD_GYEAR (integer)

XSD_GMONTHDAY (integer)

XSD_GDAY (integer)

XSD_GMONTH (integer)

XSD_HEXBINARY (integer)

XSD_BASE64BINARY (integer)

XSD_ANYURI (integer)

XSD_QNAME (integer)

XSD_NOTATION (integer)

XSD_NORMALIZEDSTRING (integer)

XSD_TOKEN (integer)

XSD_LANGUAGE (integer)

XSD_NMTOKEN (integer)

XSD_NAME (integer)

XSD_NCNAME (integer)

XSD_ID (integer)

XSD_IDREF (integer)

XSD_IDREFS (integer)

XSD_ENTITY (integer)

XSD_ENTITIES (integer)

XSD_INTEGER (integer)

XSD_NONPOSITIVEINTEGER (integer)

XSD_NEGATIVEINTEGER (integer)

XSD_LONG (integer)

XSD_INT (integer)

XSD_SHORT (integer)

XSD_BYTE (integer)

XSD_NONNEGATIVEINTEGER (integer)

XSD_UNSIGNEDLONG (integer)

XSD_UNSIGNEDINT (integer)

XSD_UNSIGNEDSHORT (integer)

XSD_UNSIGNEDBYTE (integer)

XSD_POSITIVEINTEGER (integer)

XSD_NMTOKENS (integer)

XSD_ANYTYPE (integer)

SOAP_ENC_OBJECT (integer)

SOAP_ENC_ARRAY (integer)

XSD_1999_TIMEINSTANT (integer)

XSD_NAMESPACE (string)

XSD_1999_NAMESPACE (string)

차례
SoapClient::SoapClient -- SoapClient constructor
SoapClient::__call -- Calls a SOAP function
SoapClient::__getFunctions -- Returns list of SOAP functions
SoapClient::__getLastRequest -- Returns last SOAP request
SoapClient::__getLastResponse -- Returns last SOAP response
SoapClient::__getTypes -- Returns list of SOAP types
SoapFault::SoapFault -- SoapFault constructor
SoapHeader::SoapHeader -- SoapHeader constructor
SoapParam::SoapParam -- SoapParam constructor
SoapServer::SoapServer -- SoapServer constructor
SoapServer::addFunction -- Adds one or several functions those will handle SOAP requests
SoapServer::getFunctions -- Returns list of defined functions
SoapServer::handle -- Handles a SOAP request
SoapServer::setClass -- Sets class which will handle SOAP requests
SoapServer::setPersistence -- Sets persistence mode of SoapServer
SoapVar::SoapVar -- SoapVar constructor
is_soap_fault -- Checks if SOAP call was failed

이전 | 처음으로 | 다음
simplexml_load_string | 위로 | SoapClient::SoapClient


SoapClient::SoapClient

(no version information, might be only in CVS)

SoapClient::SoapClient -- SoapClient constructor

Description

object SoapClient::SoapClient ( mixed wsdl [, array options])

This constructor allows creating SoapClient objects in WSDL or non-WSDL mode. The first case requires the URI of WSDL file as the first parameter and an optional options array. The second case requires NULL as the first parameter and the options array with location and uri options set, where location is a URL to request and uri is a target namespace of the SOAP service.

The style and use options only work in non-WSDL mode. In WSDL mode, they comes from the WSDL file.

The soap_version option specifies whether to use SOAP 1.1, or SOAP 1.2 client.

For HTTP authentication, you may use the login and password options. For making a HTTP connection through a proxy server, use the options proxy_host, proxy_port, proxy_login and proxy_password.

예 1. SoapClient examples

<?php

$client = new SoapClient("some.wsdl");

$client = new SoapClient("some.wsdl", array('soap_version'   => SOAP_1_2));

$client = new SoapClient("some.wsdl", array('login'          => "some_name",
                                            'password'       => "some_password"));

$client = new SoapClient("some.wsdl", array('proxy_host'     => "localhost",
                                            'proxy_port'     => 8080));

$client = new SoapClient("some.wsdl", array('proxy_host'     => "localhost",
                                            'proxy_port'     => 8080,
                                            'proxy_login'    => "some_name",
                                            'proxy_password' => "some_password"));

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/",
                                     'style'    => SOAP_DOCUMENT,
                                     'use'      => SOAP_LITERAL));

?>

이전 | 처음으로 | 다음
SOAP Functions | 위로 | SoapClient::__call


SoapClient::__call

(no version information, might be only in CVS)

SoapClient::__call -- Calls a SOAP function

Description

mixed SoapClient::__call ( string function_name [, array arguments [, array options [, array input_headers [, array output_headers]]]])

This is a low level API function to make a SOAP call. Usually in WSDL mode you can simply call SOAP functions as SoapClient methods. It is useful for non-WSDL mode when soapaction is unknown, uri differs from the default or when you like to send and/or receive SOAP Headers. On error, a call to a SOAP function can cause PHP exceptions or return a SoapFault object if exceptions was disabled. To check if the function call failed catch the SoapFault exceptions or check the result with the is_soap_fault() function.

SOAP functions may return one or several values. In the first case it will return just the value of output parameter, in the second it will return the associative array with named output parameters.

예 1. SoapClient::__call() examples

<?php
$client = new SoapClient("some.wsdl");
$client->SomeFunction($a, $b, $c);
$client->__call("SomeFunction", array($a, $b, $c));
$client->__call("SomeFunction", array($a, $b, $c), NULL,
                new SoapHeader(...), $output_headers);

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$client->SomeFunction($a, $b, $c);
$client->__call("SomeFunction", array($a, $b, $c));
$client->__call("SomeFunction", array($a, $b, $c),
                 array('soapaction' => 'some_action',
                       'uri'        => 'some_uri'));
?>

See also
SoapClient::SoapClient(),
SoapParam::SoapParam(),
SoapVar::SoapVar(),
SoapHeader::SoapHeader(),
SoapFault::SoapFault(), and
is_soap_fault().

이전 | 처음으로 | 다음
SoapClient::SoapClient | 위로 | SoapClient::__getFunctions


SoapClient::__getFunctions

(no version information, might be only in CVS)

SoapClient::__getFunctions -- Returns list of SOAP functions

Description

array SoapClient::__getFunctions ( void )

This function works only in WSDL mode.

예 1. SoapClient::__getFunctions() example

<?php
$client = SoapClient("some.wsdl");
var_dump($client->__getFunctions());
?>

See also SoapClient::SoapClient().

이전 | 처음으로 | 다음
SoapClient::__call | 위로 | SoapClient::__getLastRequest


SoapClient::__getLastRequest

(no version information, might be only in CVS)

SoapClient::__getLastRequest -- Returns last SOAP request

Description

string SoapClient::__getLastRequest ( void )

This function works only with SoapClient which was created with the trace option.

예 1. SoapClient::__getLastRequest() example

<?php
$client = SoapClient("some.wsdl", array('trace' => 1));
$result = $client->SomeFunction(...);
echo "REQUEST:\n" . $client->__getLastRequest() . "\n";
?>

See also SoapClient::SoapClient().

이전 | 처음으로 | 다음
SoapClient::__getFunctions | 위로 | SoapClient::__getLastResponse


SoapClient::__getLastResponse

(no version information, might be only in CVS)

SoapClient::__getLastResponse -- Returns last SOAP response

Description

object SoapClient::__getLastResponse ( void )

This function works only with SoapClient which was created with the trace option.

예 1. SoapClient::__getLastResponse() example

<?php
$client = SoapClient("some.wsdl", array('trace' => 1));
$result = $client->SomeFunction(...);
echo "RESPONSE:\n" . $client->__getLastResponse() . "\n";
?>

See also SoapClient::SoapClient().

이전 | 처음으로 | 다음
SoapClient::__getLastRequest | 위로 | SoapClient::__getTypes


SoapClient::__getTypes

(no version information, might be only in CVS)

SoapClient::__getTypes -- Returns list of SOAP types

Description

array SoapClient::__getTypes ( void )

This function works only in WSDL mode.

예 1. SoapClient::__getTypes() example

<?php
$client = SoapClient("some.wsdl");
var_dump($client->__getTypes());
?>

See also SoapClient::SoapClient().

이전 | 처음으로 | 다음
SoapClient::__getLastResponse | 위로 | SoapFault::SoapFault


SoapFault::SoapFault

(no version information, might be only in CVS)

SoapFault::SoapFault -- SoapFault constructor

Description

object SoapFault::SoapFault ( string faultcode, string faultstring [, string faultactor [, mixed detail [, string faultname [, mixed headerfault]]]])

This class is useful when you would like to send SOAP fault responses from the PHP handler. faultcode, faultstring, faultactor and details are standard elements of SOAP Fault; faultname is an optional parameter that can be used to select proper fault encoding from WSDL; headerfault is an optional parameter that can be used during SOAP header handling to report an error in the response header.

예 1. Some examples

<?php
function test($x)
{
    return new SoapFault("Server", "Some error message");
}

$server = new SoapServer(null, array('uri' => "http://test-uri/"));
$server->addFunction("test");
$server->handle();
?>

It is possible to use PHP exception mechanism to throw SOAP Fault.

예 2. Some examples

<?php
function test($x)
{
    throw new SoapFault("Server", "Some error message");
}

$server = new SoapServer(null, array('uri' => "http://test-uri/"));
$server->addFunction("test");
$server->handle();
?>

See also
SoapClient::SoapClient(),
SoapClient::__call(),
SoapParam::SoapParam(),
SoapVar::SoapVar(), and
is_soap_fault().

이전 | 처음으로 | 다음
SoapClient::__getTypes | 위로 | SoapHeader::SoapHeader


SoapHeader::SoapHeader

(no version information, might be only in CVS)

SoapHeader::SoapHeader -- SoapHeader constructor

Description

object SoapHeader::SoapHeader ( string namespace, string name [, mixed data [, bool mustUnderstand [, mixed actor]]])

SoapHeader is a special low-level class for passing or returning SOAP headers. It is just a data holder and it does not have any special methods except a constructor. It can be used in the SoapClient::__call() method to pass a SOAP header or in a SOAP header handler to return the header in a SOAP response. namespace and name are namespace and name of the SOAP header element. data is a SOAP header's content. It can be a PHP value or SoapVar object. mustUnderstand and actor are values for mustUnderstand and actor attributes of this SOAP Header element.

예 1. Some examples

<?php
$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$client->__call("echoVoid", null, null,
                new SoapHeader('http://soapinterop.org/echoheader/',
                               'echoMeStringRequest',
                               'hello world'));
?>

See also
SoapClient::__call(),
SoapParam::SoapParam(), and
SoapVar::SoapVar().

이전 | 처음으로 | 다음
SoapFault::SoapFault | 위로 | SoapParam::SoapParam


SoapParam::SoapParam

(no version information, might be only in CVS)

SoapParam::SoapParam -- SoapParam constructor

Description

object SoapParam::SoapParam ( mixed data, string name)

SoapParam is a special low-level class for naming parameters and return ing values in non-WSDL mode. It is just a data holder and it does not have any special methods except the constructor. The constructor takes data to pass or return and name. It is possible to pass parameters directly as PHP values, but in this case it will be named as paramN and the SOAP Service may not understand them.

예 1. Some examples

<?php
$client = new SoapClient(null,array('location' => "http://localhost/soap.php",
                                    'uri'      => "http://test-uri/"));
$client->SomeFunction(new SoapParam($a, "a"),
                      new SoapParam($b, "b"),
                      new SoapParam($c, "c"));
?>

See also SoapClient::__call(), and SoapVar::SoapVar().

이전 | 처음으로 | 다음
SoapHeader::SoapHeader | 위로 | SoapServer::SoapServer


SoapServer::SoapServer

(no version information, might be only in CVS)

SoapServer::SoapServer -- SoapServer constructor

Description

object SoapServer::SoapServer ( mixed wsdl [, array options])

This constuctor allows the creatiion of SoapServer objects in WSDL or non-WSDL mode. In the first case, wsdl must be set to the URI of a WSDL file. In the second case, wsdl must be set to NULL and the uri option must be set. Additional options allow setting a default SOAP version (soap_version) and actor URI (actor).

예 1. Some examples

<?php

$server = new SoapServer("some.wsdl");

$server = new SoapServer("some.wsdl", array('soap_version' => SOAP_1_2));

$server = new SoapServer("some.wsdl", array('actor' => "http://example.org/ts-tests/C"));

$server = new SoapServer(null, array('uri' => "http://test-uri/"));

?>

이전 | 처음으로 | 다음
SoapParam::SoapParam | 위로 | SoapServer::addFunction


SoapServer::addFunction

(no version information, might be only in CVS)

SoapServer::addFunction -- Adds one or several functions those will handle SOAP requests

Description

void SoapServer::addFunction ( mixed functions)

Exports one or more functions for remote clients.

To export one function, pass the function name into the functions parameter as a string. To export several functions pass an array of function names, and to export all functions pass a special constant SOAP_FUNCTIONS_ALL.

functions must receive all input arguments in the same order as defined in the WSDL file (They should not receive any output parameters as arguments) and return one or more values. To return several values they must return an array with named output parameters.

예 1. Some examples

<?php

function echoString($inputString)
{
    return $inputString;
}

$server->addFunction("echoString");

function echoTwoStrings($inputString1, $inputString2)
{
    return array("outputString1" => $inputString1,
                 "outputString2" => $inputString2);
}
$server->addFunction(array("echoString", "echoTwoStrings"));

$server->addFunction(SOAP_FUNCTIONS_ALL);

?>

See also SoapServer::SoapServer(), and SoapServer::SetClass().

이전 | 처음으로 | 다음
SoapServer::SoapServer | 위로 | SoapServer::getFunctions


SoapServer::getFunctions

(no version information, might be only in CVS)

SoapServer::getFunctions -- Returns list of defined functions

Description

array SoapServer::getFunctions ( void )

This functions returns the list of all functions which was added by SoapServer::addFunction() or SoapServer::setCalss().

예 1. Some examples

<?php
$server = new SoapServer(NULL, array("uri" => "http://test-uri"));
$server->addFunction(SOAP_FUNCTIONS_ALL);
if ($_SERVER["REQUEST_METHOD"] == "POST") {
  $server->handle();
} else {
  echo "This SOAP server can handle following functions: ";
  $functions = $server->getFunctions();
  foreach($functions as $func) {
    echo $func . "\n";
  }
}
?>

See also
SoapServer::SoapServer(),
SoapServer::addFunction(), and
SoapServer::SetClass().

이전 | 처음으로 | 다음
SoapServer::addFunction | 위로 | SoapServer::handle


SoapServer::handle

(no version information, might be only in CVS)

SoapServer::handle -- Handles a SOAP request

Description

void SoapServer::handle ( [string soap_request])

Processes a SOAP request, calls necessary functions, and sends a response back. It assumes a request in input parameter soap_request or in the global $HTTP_RAW_POST_DATA PHP variable if the argument is omitted.

예 1. Some examples

<?php
function test($x)
{
    return $x;
}

$server = new SoapServer(null, array('uri' => "http://test-uri/"));
$server->addFunction("test");
$server->handle();
?>

See also SoapServer::SoapServer().

이전 | 처음으로 | 다음
SoapServer::getFunctions | 위로 | SoapServer::setClass


SoapServer::setClass

(no version information, might be only in CVS)

SoapServer::setClass -- Sets class which will handle SOAP requests

Description

void SoapServer::setClass ( string class_name [, mixed args])

Exports all methods from specified class. Additional parameters args will be passed to the default class constructor during object creation. The object can be made persistent across request for a given PHP session with the SoapServer::setPersistence() method.

예 1. Some examples

<?php

class foo {
    function foo()
    {
    }
}
$server->setClass("foo");

class bar {
    function bar($x, $y)
    {
    }
}
$server->setClass("bar", $arg1, $arg2);

?>

See also
SoapServer::SoapServer(),
SoapServer::addFunction(), and
SoapServer::setPersistence().

이전 | 처음으로 | 다음
SoapServer::handle | 위로 | SoapServer::setPersistence


SoapServer::setPersistence

(no version information, might be only in CVS)

SoapServer::setPersistence -- Sets persistence mode of SoapServer

Description

void SoapServer::setPersistence ( int mode)

This function allows saving data between requests in a PHP session. It works only with a server that exports functions from a class with SoapServer::setClass().

예 1. Some examples

<?php

$server->setPersistence(SOAP_PERSISTENCE_SESSION);

$server->setPersistence(SOAP_PERSISTENCE_REQUEST);

?>

See also SoapServer::SoapServer(), and SoapServer::SetClass().

이전 | 처음으로 | 다음
SoapServer::setClass | 위로 | SoapVar::SoapVar


SoapVar::SoapVar

(no version information, might be only in CVS)

SoapVar::SoapVar -- SoapVar constructor

Description

object SoapVar::SoapVar ( mixed data, int encoding [, string type_name [, string type_namespace [, string node_name [, string node_namespace]]]])

SoapVar is a special low-level class for encoding parameters and returning values in non-WSDL mode. It is just a data holder and does not have any special methods except the constructor. It is useful when you would like to set the type property in SOAP request or response. The constructor takes data to pass or return, encoding ID to encode it (see XSD_... constants) and as option type name and namespace and XML node name and namespace.

예 1. Some examples

<?php
class SOAPStruct {
    function SOAPStruct($s, $i, $f)
    {
        $this->varString = $s;
        $this->varInt = $i;
        $this->varFloat = $f;
    }
}
$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$struct = new SOAPStruct('arg', 34, 325.325);
$soapstruct = new SoapVar($struct, SOAP_ENC_OBJECT, "SOAPStruct", "http://soapinterop.org/xsd");
$client->echoStruct(new SoapParam($soapstruct, "inputStruct"));
?>

See also SoapClient::__call() and SoapParam::SoapParam().

이전 | 처음으로 | 다음
SoapServer::setPersistence | 위로 | is_soap_fault


is_soap_fault

(PHP 5)

is_soap_fault -- Checks if SOAP call was failed

Description

bool is_soap_fault ( mixed obj)

This function is useful when you like to check if the SOAP call failed, but don't like to use exceptions. To use it you must create a SoapClient object with exceptions option set to zero or FALSE. In this case, the SOAP method will return a special SoapFault object which encapsulates the fault details (faultcode, faultstring, faultactor and faultdetails).

If exceptions is not set then SOAP call will throw an exception on error. is_soap_fault() checks if the given parameter is a SoapFault object.

예 1. is_soap_fault() example

<?php
$client = SoapClient("some.wsdl", array('exceptions' => 0));
$result = $client->SomeFunction(...);
if (is_soap_fault($result)) {
    trigger_error("SOAP Fault: (faultcode: {$result->faultcode}, faultstring: {$result->faulstring})", E_ERROR);
}
?>

예 2. SOAP's standard method for error reporting is exceptions

<?php
try {
    $client = SoapClient("some.wsdl");
    $result = $client->SomeFunction(...);
} catch (SoapFault $fault) {
    trigger_error("SOAP Fault: (faultcode: {$fault->faultcode}, faultstring: {$fault->faulstring})", E_ERROR);
}
?>

See also SoapClient::SoapClient(), and SoapFault::SoapFault().

이전 | 처음으로 | 다음
SoapVar::SoapVar | 위로 | SQLite


SQLite

PHP 매뉴얼
이전 다음

C. SQLite

소개

This is an extension for the SQLite Embeddable SQL Database Engine. SQLite is a C library that implements an embeddable SQL database engine. Programs that link with the SQLite library can have SQL database access without running a separate RDBMS process.

SQLite is not a client library used to connect to a big database server. SQLite is the server. The SQLite library reads and writes directly to and from the database files on disk.

참고: For further information see the SQLite Website (http://sqlite.org/).

Installation

Read the INSTALL file, which comes with the package. Or just use the PEAR installer with "pear install sqlite". SQLite itself is already included, You do not need to install any additional software.

Windows users may download the DLL version of the SQLite extension here: (php_sqlite.dll).

In PHP 5, the SQLite extension and the engine itself are bundled and compilled by default.

요구 사항

In order to have these functions available, you must compile PHP with SQLite support, or load the SQLite extension dynamically from your php.ini.

리소스 종류

There are two resources used in the SQLite Interface. The first one is the database connection, the second one the result set.

Predefined Constants

The functions sqlite_fetch_array() and sqlite_current() use a constant for the different types of result arrays. The following constants are defined:

표 1. SQLite fetch constants

constant | meaning
SQLITE_ASSOC | Columns are returned into the array having the fieldname as the array index.
SQLITE_BOTH | Columns are returned into the array having both a numerical index and the fieldname as the array index.
SQLITE_NUM | Columns are returned into the array having a numerical index to the fields. This index starts with 0, the first field in the result.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 2. SQLite Configuration Options

Name | Default | Changeable
sqlite.assoc_case | 0 | PHP_INI_ALL
For further details and definition of the PHP_INI_* constants see ini_set().

위 설정 지시어에 대한 간단한 설명입니다.

sqlite.assoc_case int

Whether to use mixed case (0), upper case (1) or lower case (2) hash indexes.

This option is primarily useful when you need compatibility with other database systems, where the names of the columns are always returned as uppercase or lowercase, regardless of the case of the actual field names in the database schema.

The SQLite library returns the column names in their natural case (that matches the case you used in your schema). When sqlite.assoc_case is set to 0 the natural case will be preserved. When it is set to 1 or 2, PHP will apply case folding on the hash keys to upper- or lower-case the keys, respectively.

Use of this option incurs a slight performance penalty, but is MUCH faster than performing the case folding yourself using PHP script.

차례
sqlite_array_query -- Execute a query against a given database and returns an array.
sqlite_busy_timeout -- Set busy timeout duration, or disable busy handlers.
sqlite_changes -- Returns the number of rows that were changed by the most recent SQL statement.
sqlite_close -- Closes an open SQLite database.
sqlite_column -- Fetches a column from the current row of a result set.
sqlite_create_aggregate -- Register an aggregating UDF for use in SQL statements.
sqlite_create_function -- Registers a "regular" User Defined Function for use in SQL statements.
sqlite_current -- Fetches the current row from a result set as an array.
sqlite_error_string -- Returns the textual description of an error code.
sqlite_escape_string -- Escapes a string for use as a query parameter
sqlite_fetch_array -- Fetches the next row from a result set as an array.
sqlite_fetch_single -- Fetches the first column of a result set as a string.
sqlite_fetch_string -- Alias of sqlite_fetch_single()
sqlite_field_name -- Returns the name of a particular field.
sqlite_has_more -- Returns whether or not more rows are available.
sqlite_last_error -- Returns the error code of the last error for a database.
sqlite_last_insert_rowid -- Returns the rowid of the most recently inserted row.
sqlite_libencoding -- Returns the encoding of the linked SQLite library.
sqlite_libversion -- Returns the version of the linked SQLite library.
sqlite_next -- Seek to the next row number.
sqlite_num_fields -- Returns the number of fields in a result set.
sqlite_num_rows -- Returns the number of rows in a buffered result set.
sqlite_open -- Opens a SQLite database. Will create the database if it does not exist
sqlite_popen -- Opens a persistent handle to an SQLite database. Will create the database if it does not exist.
sqlite_query -- Executes a query against a given database and returns a result handle.
sqlite_rewind -- Seek to the first row number.
sqlite_seek -- Seek to a particular row number of a buffered result set.
sqlite_udf_decode_binary -- Decode binary data passed as parameters to an UDF.
sqlite_udf_encode_binary -- Encode binary data before returning it from an UDF.
sqlite_unbuffered_query -- Execute a query that does not prefetch and buffer all data

이전 | 처음으로 | 다음
is_soap_fault | 위로 | sqlite_array_query


sqlite_array_query

(PHP 5)

sqlite_array_query -- Execute a query against a given database and returns an array.

Description

array sqlite_array_query ( resource dbhandle, string query [, int result_type [, bool decode_binary]])

array sqlite_array_query ( string query, resource dbhandle [, int result_type [, bool decode_binary]])

sqlite_array_query() is similar to calling sqlite_query() and then sqlite_fetch_array() for each row of the result set and storing it into an array, as shown in the example below. Calling sqlite_array_query() is significantly faster than using such a script.

예 1. sqlite_array_query() implemented yourself

<?php
$q = sqlite_query($dbhandle, "SELECT * from foo LIMIT 100");
$rows = array();
while ($r = sqlite_fetch_array($q)) {
    $rows[] = $r;
}
?>

작은 정보: sqlite_array_query() is best suited to queries returning 45 rows or less. If you have more data than that, it is recommended that you write your scripts to use sqlite_unbuffered_query() instead for more optimal performance.

See also sqlite_query(),
sqlite_fetch_array(), and
sqlite_fetch_string().

이전 | 처음으로 | 다음
SQLite | 위로 | sqlite_busy_timeout


sqlite_busy_timeout

(PHP 5)

sqlite_busy_timeout -- Set busy timeout duration, or disable busy handlers.

Description

void sqlite_busy_timeout ( resource dbhandle, int milliseconds)

Set the maximum time that sqlite will wait for a dbhandle to become ready for use to milliseconds. If milliseconds is 0, busy handlers will be disabled and sqlite will return immediately with a SQLITE_BUSY status code if another process/thread has the database locked for an update.

PHP sets the default busy timeout to be 60 seconds when the database is opened.

참고: There are one thousand (1000) milliseconds in one second.

See also sqlite_open().

이전 | 처음으로 | 다음
sqlite_array_query | 위로 | sqlite_changes


sqlite_changes

(PHP 5)

sqlite_changes -- Returns the number of rows that were changed by the most recent SQL statement.

Description

int sqlite_changes ( resource dbhandle)

Returns the numbers of rows that were changed by the most recent SQL statement executed against the dbhandle database handle.

See also sqlite_num_rows().

이전 | 처음으로 | 다음
sqlite_busy_timeout | 위로 | sqlite_close


sqlite_close

(PHP 5)

sqlite_close -- Closes an open SQLite database.

Description

void sqlite_close ( resource dbhandle)

Closes the given database handle. If the database was persistent, it will be closed and removed from the persistent list.

See also sqlite_open() and sqlite_popen().

이전 | 처음으로 | 다음
sqlite_changes | 위로 | sqlite_column


sqlite_column

(PHP 5)

sqlite_column -- Fetches a column from the current row of a result set.

Description

mixed sqlite_column ( resource result, mixed index_or_name [, bool decode_binary])

Fetches the value of a column named index_or_name (if it is a string), or of the ordinal column numbered index_or_name (if it is an integer) from the current row of the query result handle result. The decode binary flag operates in the same way as described under sqlite_fetch_array().

Use this function when you are iterating a large result set with many columns, or with columns that contain large amounts of data.

See also sqlite_fetch_string().

이전 | 처음으로 | 다음
sqlite_close | 위로 | sqlite_create_aggregate


sqlite_create_aggregate

(PHP 5)

sqlite_create_aggregate -- Register an aggregating UDF for use in SQL statements.

Description

bool sqlite_create_aggregate ( resource dbhandle, string function_name, mixed step_func, mixed finalize_func [, int num_args])

sqlite_create_aggregate() is similar to sqlite_create_function() except that it registers functions that can be used to calculate a result aggregated across all the rows of a query.

The key difference between this function and sqlite_create_function() is that two functions are required to manage the aggregate; step_func is called for each row of the result set. Your PHP function should accumulate the result and store it into the aggregation context. Once all the rows have been processed, finalize_func will be called and it should then take the data from the aggregation context and return the result.

예 1. max_length aggregation function example

<?php
$data = array(
   'one',
   'two',
   'three',
   'four',
   'five',
   'six',
   'seven',
   'eight',
   'nine',
   'ten',
   );
$dbhandle = sqlite_open(':memory:');
sqlite_query($dbhandle, "CREATE TABLE strings(a)");
foreach ($data as $str) {
    $str = sqlite_escape_string($str);
    sqlite_query($dbhandle, "INSERT INTO strings VALUES ('$str')");
}

function max_len_step(&$context, $string)
{
    if (strlen($string) > $context) {
        $context = strlen($string);
    }
}

function max_len_finalize(&$context)
{
    return $context;
}

sqlite_create_aggregate($dbhandle, 'max_len', 'max_len_step', 'max_len_finalize');

var_dump(sqlite_array_query($dbhandle, 'SELECT max_len(a) from strings'));

?>

In this example, we are creating an aggregating function that will calculate the length of the longest string in one of the columns of the table. For each row, the max_len_step function is called and passed a context parameter. The context parameter is just like any other PHP variable and be set to hold an array or even an object value. In this example, we are simply using it to hold the maximum length we have seen so far; if the string has a length longer than the current maximum, we update the context to hold this new maximum length.

After all of the rows have been processed, SQLite calls the max_len_finalize function to determine the aggregate result. Here, we could perform some kind of calculation based on the data found in the context. In our simple example though, we have been calculating the result as the query progressed, so we simply need to return the context value.

참고: The example above will not work correctly if the column contains binary data. Take a look at the manual page for sqlite_udf_decode_binary() for an explanation of why this is so, and an example of how to make it respect the binary encoding.

작은 정보: It is NOT recommended for you to store a copy of the values in the context and then process them at the end, as you would cause SQLite to use a lot of memory to process the query - just think of how much memory you would need if a million rows were stored in memory, each containing a string 32 bytes in length.

작은 정보: You can use sqlite_create_function() and sqlite_create_aggregate() to override SQLite native SQL functions.

See also sqlite_create_function(),
sqlite_udf_encode_binary() and
sqlite_udf_decode_binary().

이전 | 처음으로 | 다음
sqlite_column | 위로 | sqlite_create_function


sqlite_create_function

(PHP 5)

sqlite_create_function -- Registers a "regular" User Defined Function for use in SQL statements.

Description

bool sqlite_create_function ( resource dbhandle, string function_name, mixed callback [, int num_args])

sqlite_create_function() allows you to register a PHP function with SQLite as an UDF (User Defined Function), so that it can be called from within your SQL statements.

dbhandle specifies the database handle that you wish to extend, function_name specifies the name of the function that you will use in your SQL statements, callback is any valid PHP callback to specify a PHP function that should be called to handle the SQL function. The optional parameter num_args is used as a hint by the SQLite expression parser/evaluator. It is recommended that you specify a value if your function will only ever accept a fixed number of parameters.

The UDF can be used in any SQL statement that can call functions, such as SELECT and UPDATE statements and also in triggers.

예 1. sqlite_create_function() example

<?php
function md5_and_reverse($string)
{
    return strrev(md5($string));
}

if ($dbhandle = sqlite_open('mysqlitedb', 0666, $sqliteerror)) {

    sqlite_create_function($dbhandle, 'md5rev', 'md5_and_reverse', 1);

    $sql  = 'SELECT md5rev(filename) FROM files';
    $rows = sqlite_array_query($dbhandle, $sql);
} else {
    echo 'Error opening sqlite db: ' . $sqliteerror;
    exit;
}
?>

In this example, we have a function that calculates the md5 sum of a string, and then reverses it. When the SQL statement executes, it returns the value of the filename transformed by our function. The data returned in $rows contains the processed result.

The beauty of this technique is that you do not need to process the result using a foreach() loop after you have queried for the data.

PHP registers a special function named php when the database is first opened. The php function can be used to call any PHP function without having to register it first.

예 2. Example of using the PHP function

<?php
$rows = sqlite_array_query($dbhandle, "SELECT php('md5', filename) from files");
?>

This example will call the md5() on each filename column in the database and return the result into $rows

참고: For performance reasons, PHP will not automatically encode/decode binary data passed to and from your UDF's. You need to manually encode/decode the parameters and return values if you need to process binary data in this way. Take a look at sqlite_udf_encode_binary() and sqlite_udf_decode_binary() for more details.

작은 정보: It is not recommended to use UDF's to handle processing of binary data, unless high performance is not a key requirement of your application.

작은 정보: You can use sqlite_create_function() and sqlite_create_aggregate() to override SQLite native SQL functions.

See also sqlite_create_aggregate().

이전 | 처음으로 | 다음
sqlite_create_aggregate | 위로 | sqlite_current


sqlite_current

(PHP 5)

sqlite_current -- Fetches the current row from a result set as an array.

Description

array sqlite_current ( resource result [, int result_type [, bool decode_binary]])

sqlite_current() is identical to sqlite_fetch_array() except that it does not advance to the next row prior to returning the data; it returns the data from the current position only.

If the current position is beyond the final row, this function returns FALSE

참고: This function will not work on unbuffered result handles.

See also sqlite_seek(),
sqlite_next(), and
sqlite_fetch_array().

이전 | 처음으로 | 다음
sqlite_create_function | 위로 | sqlite_error_string


sqlite_error_string

(PHP 5)

sqlite_error_string -- Returns the textual description of an error code.

Description

string sqlite_error_string ( int error_code)

Returns a human readable description of the error_code returned from sqlite_last_error().

See also sqlite_last_error().

이전 | 처음으로 | 다음
sqlite_current | 위로 | sqlite_escape_string


sqlite_escape_string

(PHP 5)

sqlite_escape_string -- Escapes a string for use as a query parameter

Description

string sqlite_escape_string ( string item)

sqlite_escape_string() will correctly quote the string specified by item for use in an SQLite SQL statement. This includes doubling up single-quote characters (') and checking for binary-unsafe characters in the query string.

If the item contains a NUL character, or if it begins with a character whose ordinal value is 0x01, PHP will apply a binary encoding scheme so that you can safely store and retrieve binary data.

Although the encoding makes it safe to insert the data, it will render simple text comparisons and LIKE clauses in your queries unusable for the columns that contain the binary data. In practice, this shouldn't be a problem, as your schema should be such that you don't use such things on binary columns (in fact, it might be better to store binary data using other means, such as in files).

주의

addslashes() should NOT be used to quote your strings for SQLite queries; it will lead to strange results when retrieving your data.

참고:
    Do not use this function to encode the return values from UDF's created
    using sqlite_create_function() or
    sqlite_create_aggregate() - use
    sqlite_udf_encode_binary() instead.

See also sqlite_udf_encode_binary().

이전 | 처음으로 | 다음
sqlite_error_string | 위로 | sqlite_fetch_array


sqlite_fetch_array

(PHP 5)

sqlite_fetch_array -- Fetches the next row from a result set as an array.

Description

array sqlite_fetch_array ( resource result [, int result_type [, bool decode_binary]])

Fetches the next row from the given result handle. If there are no more rows, returns FALSE, otherwise returns an associative array representing the row data.

result_type can be used to specify how you want the results to be returned. The default value is SQLITE_BOTH which returns columns indexed by their ordinal column number and by column name. SQLITE_ASSOC causes the array to be indexed only by column names, and SQLITE_NUM to be indexed only by ordinal column numbers.

The column names returned by SQLITE_ASSOC and SQLITE_BOTH will be case-folded according to the value of the sqlite.assoc_case configuration option.

When decode_binary is set to TRUE (the default), PHP will decode the binary encoding it applied to the data if it was encoded using the sqlite_escape_string(). You will usually always leave this value at its default, unless you are interoperating with databases created by other sqlite capable applications.

See also sqlite_array_query() and sqlite_fetch_string().

이전 | 처음으로 | 다음
sqlite_escape_string | 위로 | sqlite_fetch_single


sqlite_fetch_single

(PHP 5)

sqlite_fetch_single -- Fetches the first column of a result set as a string.

Description

string sqlite_fetch_single ( resource result [, int result_type [, bool decode_binary]])

sqlite_fetch_single() is identical to sqlite_fetch_array() except that it returns the value of the first column of the rowset.

This is the most optimal way to retrieve data when you are only interested in the values from a single column of data.

예 1. A sqlite_fetch_single() example

<?php
if ($dbhandle = sqlite_open('mysqlitedb', 0666, $sqliteerror)) {

    $sql = "SELECT id FROM sometable WHERE id = 42";
    $res = sqlite_query($dbhandle, $sql);

    if (sqlite_num_rows($res) > 0) {
        echo sqlite_fetch_single($res); // 42
    }

    sqlite_close($dbhandle);
}
?>

See also sqlite_fetch_array().

이전 | 처음으로 | 다음
sqlite_fetch_array | 위로 | sqlite_fetch_string


sqlite_fetch_string

sqlite_fetch_string -- Alias of sqlite_fetch_single()

Description

This function is an alias of sqlite_fetch_single().

이전 | 처음으로 | 다음
sqlite_fetch_single | 위로 | sqlite_field_name


sqlite_field_name

(PHP 5)

sqlite_field_name -- Returns the name of a particular field.

Description

string sqlite_field_name ( resource result, int field_index)

Given the ordinal column number, field_index, returns the name of that field in the result handle result.

이전 | 처음으로 | 다음
sqlite_fetch_string | 위로 | sqlite_has_more


sqlite_has_more

(PHP 5)

sqlite_has_more -- Returns whether or not more rows are available.

Description

bool sqlite_has_more ( resource result)

sqlite_has_more() returns TRUE if there are more rows available from the result handle, or FALSE otherwise.

See also sqlite_num_rows() and sqlite_changes().

이전 | 처음으로 | 다음
sqlite_field_name | 위로 | sqlite_last_error


sqlite_last_error

(PHP 5)

sqlite_last_error -- Returns the error code of the last error for a database.

Description

int sqlite_last_error ( resource dbhandle)

Returns the error code from the last operation performed on dbhandle, the database handle. A human readable description of the error code can be retrieved using sqlite_error_string().

See also sqlite_error_string().

이전 | 처음으로 | 다음
sqlite_has_more | 위로 | sqlite_last_insert_rowid


sqlite_last_insert_rowid

(PHP 5)

sqlite_last_insert_rowid -- Returns the rowid of the most recently inserted row.

Description

int sqlite_last_insert_rowid ( resource dbhandle)

Returns the rowid of the row that was most recently inserted into the database dbhandle, if it was created as an auto-increment field.

작은 정보: You can create auto-increment fields in SQLite by declaring them as INTEGER PRIMARY KEY in your table schema.

이전 | 처음으로 | 다음
sqlite_last_error | 위로 | sqlite_libencoding


sqlite_libencoding

(PHP 5)

sqlite_libencoding -- Returns the encoding of the linked SQLite library.

Description

string sqlite_libencoding ( void )

The SQLite library may be compiled in either ISO-8859-1 or UTF-8 compatible modes. This function allows you to determine which encoding scheme is used by your version of the library.

주의

The default PHP distribution builds libsqlite in ISO-8859-1 encoding mode. However, this is a misnomer; rather than handling ISO-8859-1, it operates according to your current locale settings for string comparisons and sort ordering. So, rather than ISO-8859-1, you should think of it as being '8-bit' instead.

When compiled with UTF-8 support, sqlite handles encoding and decoding of UTF-8 multi-byte character sequences, but does not yet do a complete job when working with the data (no normalization is performed for example), and some comparison operations may still not be carried out correctly.

주의

It is not recommended that you use PHP in a web-server configuration with a version of the SQLite library compiled with UTF-8 support, since libsqlite will abort the process if it detects a problem with the UTF-8 encoding.

See also sqlite_libversion().

이전 | 처음으로 | 다음
sqlite_last_insert_rowid | 위로 | sqlite_libversion


sqlite_libversion

(PHP 5)

sqlite_libversion -- Returns the version of the linked SQLite library.

Description

string sqlite_libversion ( void )

Returns the version of the linked SQLite library as a string.

See also sqlite_libencoding().

이전 | 처음으로 | 다음
sqlite_libencoding | 위로 | sqlite_next


sqlite_next

(PHP 5)

sqlite_next -- Seek to the next row number.

Description

bool sqlite_next ( resource result)

sqlite_next() advances the result handle result to the next row. Returns FALSE if there are no more rows, TRUE otherwise.

참고: This function cannot be used with unbuffered result handles.

See also sqlite_seek(),
sqlite_current() and
sqlite_rewind().

이전 | 처음으로 | 다음
sqlite_libversion | 위로 | sqlite_num_fields


sqlite_num_fields

(PHP 5)

sqlite_num_fields -- Returns the number of fields in a result set.

Description

int sqlite_num_fields ( resource result)

Returns the number of fields in the result set.

See also sqlite_column() and sqlite_num_rows().

이전 | 처음으로 | 다음
sqlite_next | 위로 | sqlite_num_rows


sqlite_num_rows

(PHP 5)

sqlite_num_rows -- Returns the number of rows in a buffered result set.

Description

int sqlite_num_rows ( resource result)

Returns the number of rows in the buffered result set.

참고: This function cannot be used with unbuffered result sets.

See also sqlite_changes() and sqlite_query().

이전 | 처음으로 | 다음
sqlite_num_fields | 위로 | sqlite_open


sqlite_open

(PHP 5)

sqlite_open -- Opens a SQLite database. Will create the database if it does not exist

Description

resource sqlite_open ( string filename [, int mode [, string &error_message]])

Returns a resource (database handle) on success, FALSE on error.

The filename parameter is the name of the database. It can be a relative or absolute path to the file that sqlite will use to store your data. If the file does not exist, sqlite will attempt to create it. You MUST have write permissions to the file if you want to insert data or modify the database schema.

The mode parameter specifies the mode of the file and is intended to be used to open the database in read-only mode. Presently, this parameter is ignored by the sqlite library. The default value for mode is the octal value 0666 and this is the recommended value to use if you need access to the errmessage parameter.

errmessage is passed by reference and is set to hold a descriptive error message explaining why the database could not be opened if there was an error.

예 1. sqlite_open() example

<?php
if ($db = sqlite_open('mysqlitedb', 0666, $sqliteerror)) {
    sqlite_query($db, 'CREATE TABLE foo (bar varchar(10))');
    sqlite_query($db, "INSERT INTO foo VALUES ('fnord')");
    $result = sqlite_query($db, 'select bar from foo');
    var_dump(sqlite_fetch_array($result));
} else {
    die($sqliteerror);
}
?>

작은 정보: On Unix platforms, SQLite is sensitive to scripts that use the fork() system call. If you do have such a script, it is recommended that you close the handle prior to forking and then re-open it in the child and/or parent. For more information on this issue, see The C language interface to the SQLite library in the section entitled Multi-Threading And SQLite.

작은 정보: It is not recommended to work with SQLite databases mounted on NFS partitions. Since NFS is notoriously bad when it comes to locking you may find that you cannot even open the database at all, and if it succeeds, the locking behaviour may be undefined.

참고: Starting with SQLite library version 2.8.2, you can specify :memory: as the filename to create a database that lives only in the memory of the computer. This is useful mostly for temporary processing, as the in-memory database will be destroyed when the process ends. It can also be useful when coupled with the ATTACH DATABASE SQL statement to load other databases and move and query data between them.

참고: SQLite is 안전 모드 and open_basedir aware.

See also sqlite_popen(),
sqlite_close() and
sqlite_query().

이전 | 처음으로 | 다음
sqlite_num_rows | 위로 | sqlite_popen


sqlite_popen

(PHP 5)

sqlite_popen -- Opens a persistent handle to an SQLite database. Will create the database if it does not exist.

Description

resource sqlite_popen ( string filename [, int mode [, string &error_message]])

This function behaves identically to sqlite_open() except that is uses the persistent resource mechanism of PHP. For information about the meaning of the parameters, read the sqlite_open() manual page.

sqlite_popen() will first check to see if a persistent handle has already been opened for the given filename. If it finds one, it returns that handle to your script, otherwise it opens a fresh handle to the database.

The benefit of this approach is that you don't incur the performance cost of re-reading the database and index schema on each page hit served by persistent web server SAPI's (any SAPI except for regular CGI or CLI).

참고: If you use persistent handles and have the database updated by a background process (perhaps via a crontab), and that process re-creates the database by overwriting it (either by unlinking and rebuilding, or moving the updated version to replace the current version), you may experience undefined behaviour when a persistent handle on the old version of the database is recycled.

To avoid this situation, have your background processes open the same database file and perform their updates in a transaction.

See also sqlite_open(),
sqlite_close() and
sqlite_query().

이전 | 처음으로 | 다음
sqlite_open | 위로 | sqlite_query


sqlite_query

(PHP 5)

sqlite_query -- Executes a query against a given database and returns a result handle.

Description

resource sqlite_query ( resource dbhandle, string query)

resource sqlite_query ( string query, resource dbhandle)

Executes an SQL statement given by the query against a given database handle (specified by the dbhandle parameter).

For queries that return rows, this function will return a result handle which can then be used with functions such as sqlite_fetch_array() and sqlite_seek().

For other kinds of queries, this function will return a boolean result; TRUE for success or FALSE for failure.

Regardless of the query type, this function will return FALSE if the query failed.

sqlite_query() returns a buffered, seekable result handle. This is useful for reasonably small queries where you need to be able to randomly access the rows. Buffered result handles will allocate memory to hold the entire result and will not return until it has been fetched. If you only need sequential access to the data, it is recommended that you use the much higher performance sqlite_unbuffered_query() instead.

참고: Two alternative syntaxes are supported for compatibility with other database extensions (such as MySQL). The preferred form is the first one, where the db parameter is the first parameter to the function.

주의

SQLite will execute multiple queries separated by semicolons, so you can use it to execute a batch of SQL that you have loaded from a file or have embedded in a script.

When executing multiple queries, the return value of this function will be FALSE if the was an error, but undefined otherwise (it might be TRUE for success or it might return a result handle).

See also sqlite_unbuffered_query() and sqlite_array_query().

이전 | 처음으로 | 다음
sqlite_popen | 위로 | sqlite_rewind


sqlite_rewind

(PHP 5)

sqlite_rewind -- Seek to the first row number.

Description

bool sqlite_rewind ( resource result)

sqlite_rewind() seeks back to the first row in the result set. Returns FALSE if there are no rows in the result set, TRUE otherwise.

참고: This function cannot be used with unbuffered result sets.

See also sqlite_next(),
sqlite_current(), and
sqlite_seek().

이전 | 처음으로 | 다음
sqlite_query | 위로 | sqlite_seek


sqlite_seek

(PHP 5)

sqlite_seek -- Seek to a particular row number of a buffered result set.

Description

bool sqlite_seek ( resource result, int rownum)

sqlite_seek() seeks to the row given by the parameter rownum. The row number is zero-based (0 is the first row). Returns FALSE if the row does not exist, TRUE otherwise.

참고: This function cannot be used with unbuffered result handles.

See also sqlite_next(),
sqlite_current() and
sqlite_rewind().

이전 | 처음으로 | 다음
sqlite_rewind | 위로 | sqlite_udf_decode_binary


sqlite_udf_decode_binary

(PHP 5)

sqlite_udf_decode_binary -- Decode binary data passed as parameters to an UDF.

Description

string sqlite_udf_decode_binary ( string data)

sqlite_udf_decode_binary() decodes the binary encoding that was applied to the parameter by either sqlite_udf_encode_binary() or sqlite_escape_string().

You must call this function on parameters passed to your UDF if you need them to handle binary data, as the binary encoding employed by PHP will obscure the content and of the parameter in its natural, non-coded form.

PHP does not perform this encode/decode operation automatically as it would severely impact performance if it did.

예 1. binary-safe max_length aggregation function example

<?php
$data = array(
   'one',
   'two',
   'three',
   'four',
   'five',
   'six',
   'seven',
   'eight',
   'nine',
   'ten',
   );
$db = sqlite_open(':memory:');
sqlite_query($db, "CREATE TABLE strings(a)");
foreach ($data as $str) {
    $str = sqlite_escape_string($str);
    sqlite_query($db, "INSERT INTO strings VALUES ('$str')");
}

function max_len_step(&$context, $string)
{
    $string = sqlite_udf_decode_binary($string);
    if (strlen($string) > $context) {
        $context = strlen($string);
    }
}

function max_len_finalize(&$context)
{
    return $context;
}

sqlite_create_aggregate($db, 'max_len', 'max_len_step', 'max_len_finalize');

var_dump(sqlite_array_query($db, 'SELECT max_len(a) from strings'));

?>

See also sqlite_udf_encode_binary(),
sqlite_create_function() and
sqlite_create_aggregate().

이전 | 처음으로 | 다음
sqlite_seek | 위로 | sqlite_udf_encode_binary


sqlite_udf_encode_binary

(PHP 5)

sqlite_udf_encode_binary -- Encode binary data before returning it from an UDF.

Description

string sqlite_udf_encode_binary ( string data)

sqlite_udf_encode_binary() applies a binary encoding to the data so that it can be safely returned from queries (since the underlying libsqlite API is not binary safe).

If there is a chance that your data might be binary unsafe (e.g.: it contains a NUL byte in the middle rather than at the end, or if it has and 0x01 byte as the first character) then you must call this function to encode the return value from your UDF.

PHP does not perform this encode/decode operation automatically as it would severely impact performance if it did.

참고: Do not use sqlite_escape_string() to quote strings returned from UDF's as it will lead to double-quoting of the data. Use sqlite_udf_encode_binary() instead!

See also sqlite_udf_decode_binary(),
sqlite_escape_string(),
sqlite_create_function() and
sqlite_create_aggregate().

이전 | 처음으로 | 다음
sqlite_udf_decode_binary | 위로 | sqlite_unbuffered_query


sqlite_unbuffered_query

(PHP 5)

sqlite_unbuffered_query -- Execute a query that does not prefetch and buffer all data

Description

resource sqlite_unbuffered_query ( resource dbhandle, string query)

resource sqlite_unbuffered_query ( string query, resource dbhandle)

sqlite_unbuffered_query() is identical to sqlite_query() except that the result that is returned is a sequential forward-only result set that can only be used to read each row, one after the other.

This function is ideal for generating things such as HTML tables where you only need to process one row at a time and don't need to randomly access the row data.

참고:
    Functions such as sqlite_seek(),
    sqlite_rewind(), sqlite_next(),
    sqlite_current(), and
    sqlite_num_rows() do not work on result handles
    returned from sqlite_unbuffered_query().

See also sqlite_query().

이전 | 처음으로 | 다음
sqlite_udf_encode_binary | 위로 | Shockwave Flash Functions


Shockwave Flash Functions

PHP 매뉴얼
이전 다음

CI. Shockwave Flash Functions

소개

PHP offers the ability to create Shockwave Flash files via Paul Haeberli's libswf module.

참고: SWF support was added in PHP 4 RC2.

The libswf does not have support for Windows. The development of that library has been stopped, and the source is not available to port it to another systems.

For up to date SWF support take a look at the MING functions.

요구 사항

You need the libswf library to compile PHP with support for this extension. You can download libswf at ftp://ftp.sgi.com/sgi/graphics/grafica/flash/.

설치

Once you have libswf all you need to do is to configure --with-swf[=DIR] where DIR is a location containing the directories include and lib. The include directory has to contain the swf.h file and the lib directory has to contain the libswf.a file. If you unpack the libswf distribution the two files will be in one directory. Consequently you will have to copy the files to the proper location manually.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

MOD_COLOR (integer)

MOD_MATRIX (integer)

TYPE_PUSHBUTTON (integer)

TYPE_MENUBUTTON (integer)

BSHitTest (float)

BSDown (float)

BSOver (float)

BSUp (float)

OverDowntoIdle (integer)

IdletoOverDown (integer)

OutDowntoIdle (integer)

OutDowntoOverDown (integer)

OverDowntoOutDown (integer)

OverUptoOverDown (integer)

OverUptoIdle (integer)

IdletoOverUp (integer)

ButtonEnter (integer)

ButtonExit (integer)

MenuEnter (integer)

MenuExit (integer)

예제

Once you've successfully installed PHP with Shockwave Flash support you can then go about creating Shockwave files from PHP. You would be surprised at what you can do, take the following code:

예 1. SWF example

<?php
swf_openfile("test.swf", 256, 256, 30, 1, 1, 1);
swf_ortho2(-100, 100, -100, 100);
swf_defineline(1, -70, 0, 70, 0, .2);
swf_definerect(4, 60, -10, 70, 0, 0);
swf_definerect(5, -60, 0, -70, 10, 0);
swf_addcolor(0, 0, 0, 0);

swf_definefont(10, "Mod");
swf_fontsize(5);
swf_fontslant(10);
swf_definetext(11, "This be Flash wit PHP!", 1);

swf_pushmatrix();
swf_translate(-50, 80, 0);
swf_placeobject(11, 60);
swf_popmatrix();

for ($i = 0; $i < 30; $i++) {
    $p = $i/(30-1);
    swf_pushmatrix();
    swf_scale(1-($p*.9), 1, 1);
    swf_rotate(60*$p, 'z');
    swf_translate(20+20*$p, $p/1.5, 0);
    swf_rotate(270*$p,  'z');
    swf_addcolor($p, 0, $p/1.2, -$p);
    swf_placeobject(1, 50);
    swf_placeobject(4, 50);
    swf_placeobject(5, 50);
    swf_popmatrix();
    swf_showframe();
}

for ($i = 0; $i < 30; $i++) {
    swf_removeobject(50);
    if (($i%4) == 0) {
        swf_showframe();
    }
}

swf_startdoaction();
swf_actionstop();
swf_enddoaction();

swf_closefile();
?>

차례
swf_actiongeturl -- Get a URL from a Shockwave Flash movie
swf_actiongotoframe -- Play a frame and then stop
swf_actiongotolabel -- Display a frame with the specified label
swf_actionnextframe -- Go forward one frame
swf_actionplay -- Start playing the flash movie from the current frame
swf_actionprevframe -- Go backwards one frame
swf_actionsettarget -- Set the context for actions
swf_actionstop -- Stop playing the flash movie at the current frame
swf_actiontogglequality -- Toggle between low and high quality
swf_actionwaitforframe -- Skip actions if a frame has not been loaded
swf_addbuttonrecord -- Controls location, appearance and active area of the current button
swf_addcolor -- Set the global add color to the rgba value specified
swf_closefile -- Close the current Shockwave Flash file
swf_definebitmap -- Define a bitmap
swf_definefont -- Defines a font
swf_defineline -- Define a line
swf_definepoly -- Define a polygon
swf_definerect -- Define a rectangle
swf_definetext -- Define a text string
swf_endbutton -- End the definition of the current button
swf_enddoaction -- End the current action
swf_endshape -- Completes the definition of the current shape
swf_endsymbol -- End the definition of a symbol
swf_fontsize -- Change the font size
swf_fontslant -- Set the font slant
swf_fonttracking -- Set the current font tracking
swf_getbitmapinfo -- Get information about a bitmap
swf_getfontinfo -- The height in pixels of a capital A and a lowercase x
swf_getframe -- Get the frame number of the current frame
swf_labelframe -- Label the current frame
swf_lookat -- Define a viewing transformation
swf_modifyobject -- Modify an object
swf_mulcolor -- Sets the global multiply color to the rgba value specified
swf_nextid -- Returns the next free object id
swf_oncondition -- Describe a transition used to trigger an action list
swf_openfile -- Open a new Shockwave Flash file
swf_ortho2 -- Defines 2D orthographic mapping of user coordinates onto the current viewport
swf_ortho -- Defines an orthographic mapping of user coordinates onto the current viewport
swf_perspective -- Define a perspective projection transformation
swf_placeobject -- Place an object onto the screen
swf_polarview -- Define the viewer's position with polar coordinates
swf_popmatrix -- Restore a previous transformation matrix
swf_posround -- Enables or Disables the rounding of the translation when objects are placed or moved
swf_pushmatrix -- Push the current transformation matrix back unto the stack
swf_removeobject -- Remove an object
swf_rotate -- Rotate the current transformation
swf_scale -- Scale the current transformation
swf_setfont -- Change the current font
swf_setframe -- Switch to a specified frame
swf_shapearc -- Draw a circular arc
swf_shapecurveto3 -- Draw a cubic bezier curve
swf_shapecurveto -- Draw a quadratic bezier curve between two points
swf_shapefillbitmapclip -- Set current fill mode to clipped bitmap
swf_shapefillbitmaptile -- Set current fill mode to tiled bitmap
swf_shapefilloff -- Turns off filling
swf_shapefillsolid -- Set the current fill style to the specified color
swf_shapelinesolid -- Set the current line style
swf_shapelineto -- Draw a line
swf_shapemoveto -- Move the current position
swf_showframe -- Display the current frame
swf_startbutton -- Start the definition of a button
swf_startdoaction -- Start a description of an action list for the current frame
swf_startshape -- Start a complex shape
swf_startsymbol -- Define a symbol
swf_textwidth -- Get the width of a string
swf_translate -- Translate the current transformations
swf_viewport -- Select an area for future drawing

이전 | 처음으로 | 다음
sqlite_unbuffered_query | 위로 | swf_actiongeturl


swf_actiongeturl

(PHP 4 )

swf_actiongeturl -- Get a URL from a Shockwave Flash movie

Description

void swf_actiongeturl ( string url, string target)

The swf_actiongeturl() function gets the URL specified by the parameter url with the target target.

이전 | 처음으로 | 다음
Shockwave Flash Functions | 위로 | swf_actiongotoframe


swf_actiongotoframe

(PHP 4 )

swf_actiongotoframe -- Play a frame and then stop

Description

void swf_actiongotoframe ( int framenumber)

The swf_actiongotoframe() function will go to the frame specified by framenumber, play it, and then stop.

이전 | 처음으로 | 다음
swf_actiongeturl | 위로 | swf_actiongotolabel


swf_actiongotolabel

(PHP 4 )

swf_actiongotolabel -- Display a frame with the specified label

Description

void swf_actiongotolabel ( string label)

The swf_actiongotolabel() function displays the frame with the label given by the label parameter and then stops.

이전 | 처음으로 | 다음
swf_actiongotoframe | 위로 | swf_actionnextframe


swf_actionnextframe

(PHP 4 )

swf_actionnextframe -- Go forward one frame

Description

void swf_actionnextframe ( void )

Go forward one frame.

이전 | 처음으로 | 다음
swf_actiongotolabel | 위로 | swf_actionplay


swf_actionplay

(PHP 4 )

swf_actionplay -- Start playing the flash movie from the current frame

Description

void swf_actionplay ( void )

Start playing the flash movie from the current frame.

이전 | 처음으로 | 다음
swf_actionnextframe | 위로 | swf_actionprevframe


swf_actionprevframe

(PHP 4 )

swf_actionprevframe -- Go backwards one frame

Description

void swf_actionprevframe ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
swf_actionplay | 위로 | swf_actionsettarget


swf_actionsettarget

(PHP 4 )

swf_actionsettarget -- Set the context for actions

Description

void swf_actionsettarget ( string target)

The swf_actionsettarget() function sets the context for all actions. You can use this to control other flash movies that are currently playing.

이전 | 처음으로 | 다음
swf_actionprevframe | 위로 | swf_actionstop


swf_actionstop

(PHP 4 )

swf_actionstop -- Stop playing the flash movie at the current frame

Description

void swf_actionstop ( void )

Stop playing the flash movie at the current frame.

이전 | 처음으로 | 다음
swf_actionsettarget | 위로 | swf_actiontogglequality


swf_actiontogglequality

(PHP 4 )

swf_actiontogglequality -- Toggle between low and high quality

Description

void swf_actiontogglequality ( void )

Toggle the flash movie between high and low quality.

이전 | 처음으로 | 다음
swf_actionstop | 위로 | swf_actionwaitforframe


swf_actionwaitforframe

(PHP 4 )

swf_actionwaitforframe -- Skip actions if a frame has not been loaded

Description

void swf_actionwaitforframe ( int framenumber, int skipcount)

The swf_actionwaitforframe() function will check to see if the frame, specified by the framenumber parameter has been loaded, if not it will skip the number of actions specified by the skipcount parameter. This can be useful for "Loading..." type animations.

이전 | 처음으로 | 다음
swf_actiontogglequality | 위로 | swf_addbuttonrecord


swf_addbuttonrecord

(PHP 4 )

swf_addbuttonrecord -- Controls location, appearance and active area of the current button

Description

void swf_addbuttonrecord ( int states, int shapeid, int depth)

The swf_addbuttonrecord() function allows you to define the specifics of using a button. The first parameter, states, defines what states the button can have, these can be any or all of the following constants: BSHitTest, BSDown, BSOver or BSUp. The second parameter, the shapeid is the look of the button, this is usually the object id of the shape of the button. The depth parameter is the placement of the button in the current frame.

예 1. swf_addbuttonrecord() example

<?php
swf_startButton($objid, TYPE_MENUBUTTON);
swf_addButtonRecord(BSDown|BSOver, $buttonImageId, 340);
swf_onCondition(MenuEnter);
swf_actionGetUrl("http://www.example.com", "_level1");
swf_onCondition(MenuExit);
swf_actionGetUrl("", "_level1");
swf_endButton();
?>

이전 | 처음으로 | 다음
swf_actionwaitforframe | 위로 | swf_addcolor


swf_addcolor

(PHP 4 )

swf_addcolor -- Set the global add color to the rgba value specified

Description

void swf_addcolor ( float r, float g, float b, float a)

The swf_addcolor() function sets the global add color to the rgba color specified. This color is then used (implicitly) by the swf_placeobject(), swf_modifyobject() and the swf_addbuttonrecord() functions. The color of the object will be add by the rgba values when the object is written to the screen.

참고: The rgba values can be either positive or negative.

이전 | 처음으로 | 다음
swf_addbuttonrecord | 위로 | swf_closefile


swf_closefile

(PHP 4 )

swf_closefile -- Close the current Shockwave Flash file

Description

void swf_closefile ( [int return_file])

Close a file that was opened by the swf_openfile() function. If the return_file parameter is set then the contents of the SWF file are returned from the function.

예 1. Creating a simple flash file based on user input and outputting it and saving it in a database

<?php

// The $text variable is submitted by the
// user

// Global variables for database
// access (used in the swf_savedata() function)
$DBHOST = "localhost";
$DBUSER = "sterling";
$DBPASS = "secret";

swf_openfile("php://stdout", 256, 256, 30, 1, 1, 1);

    swf_definefont(10, "Ligon-Bold");
        swf_fontsize(12);
        swf_fontslant(10);

    swf_definetext(11, $text, 1);

    swf_pushmatrix();
        swf_translate(-50, 80, 0);
        swf_placeobject(11, 60);
    swf_popmatrix();

    swf_showframe();

    swf_startdoaction();
        swf_actionstop();
    swf_enddoaction();

$data = swf_closefile(1);

$data ?
  swf_savedata($data) :
  die("Error could not save SWF file");

// void swf_savedata(string data)
// Save the generated file a database
// for later retrieval
function swf_savedata($data)
{
    global $DBHOST,
           $DBUSER,
           $DBPASS;

    $dbh = @mysql_connect($DBHOST, $DBUSER, $DBPASS);

    if (!$dbh) {
        die (sprintf("Error [%d]: %s",
                      mysql_errno(), mysql_error()));
    }

    $stmt = "INSERT INTO swf_files (file) VALUES ('$data')";

    $sth = @mysql_query($stmt, $dbh);

    if (!$sth) {
        die (sprintf("Error [%d]: %s",
                      mysql_errno(), mysql_error()));
    }

    @mysql_free_result($sth);
    @mysql_close($dbh);
}
?>

이전 | 처음으로 | 다음
swf_addcolor | 위로 | swf_definebitmap


swf_definebitmap

(PHP 4 )

swf_definebitmap -- Define a bitmap

Description

void swf_definebitmap ( int objid, string image_name)

The swf_definebitmap() function defines a bitmap given a GIF, JPEG, RGB or FI image. The image will be converted into a Flash JPEG or Flash color map format.

이전 | 처음으로 | 다음
swf_closefile | 위로 | swf_definefont


swf_definefont

(PHP 4 )

swf_definefont -- Defines a font

Description

void swf_definefont ( int fontid, string fontname)

The swf_definefont() function defines a font given by the fontname parameter and gives it the id specified by the fontid parameter. It then sets the font given by fontname to the current font.

이전 | 처음으로 | 다음
swf_definebitmap | 위로 | swf_defineline


swf_defineline

(PHP 4 )

swf_defineline -- Define a line

Description

void swf_defineline ( int objid, float x1, float y1, float x2, float y2, float width)

The swf_defineline() defines a line starting from the x coordinate given by x1 and the y coordinate given by y1 parameter. Up to the x coordinate given by the x2 parameter and the y coordinate given by the y2 parameter. It will have a width defined by the width parameter.

이전 | 처음으로 | 다음
swf_definefont | 위로 | swf_definepoly


swf_definepoly

(PHP 4 )

swf_definepoly -- Define a polygon

Description

void swf_definepoly ( int objid, array coords, int npoints, float width)

The swf_definepoly() function defines a polygon given an array of x, y coordinates (the coordinates are defined in the parameter coords). The parameter npoints is the number of overall points that are contained in the array given by coords. The width is the width of the polygon's border, if set to 0.0 the polygon is filled.

이전 | 처음으로 | 다음
swf_defineline | 위로 | swf_definerect


swf_definerect

(PHP 4 )

swf_definerect -- Define a rectangle

Description

void swf_definerect ( int objid, float x1, float y1, float x2, float y2, float width)

The swf_definerect() defines a rectangle with an upper left hand coordinate given by the x, x1, and the y, y1. And a lower right hand coordinate given by the x coordinate, x2, and the y coordinate, y2 . Width of the rectangles border is given by the width parameter, if the width is 0.0 then the rectangle is filled.

이전 | 처음으로 | 다음
swf_definepoly | 위로 | swf_definetext


swf_definetext

(PHP 4 )

swf_definetext -- Define a text string

Description

void swf_definetext ( int objid, string str, int docenter)

Define a text string (the str parameter) using the current font and font size. The docenter is where the word is centered, if docenter is 1, then the word is centered in x.

이전 | 처음으로 | 다음
swf_definerect | 위로 | swf_endbutton


swf_endbutton

(PHP 4 )

swf_endbutton -- End the definition of the current button

Description

void swf_endbutton ( void )

The swf_endbutton() function ends the definition of the current button.

이전 | 처음으로 | 다음
swf_definetext | 위로 | swf_enddoaction


swf_enddoaction

(PHP 4 )

swf_enddoaction -- End the current action

Description

void swf_enddoaction ( void )

Ends the current action started by the swf_startdoaction() function.

이전 | 처음으로 | 다음
swf_endbutton | 위로 | swf_endshape


swf_endshape

(PHP 4 )

swf_endshape -- Completes the definition of the current shape

Description

void swf_endshape ( void )

The swf_endshape() completes the definition of the current shape.

이전 | 처음으로 | 다음
swf_enddoaction | 위로 | swf_endsymbol


swf_endsymbol

(PHP 4 )

swf_endsymbol -- End the definition of a symbol

Description

void swf_endsymbol ( void )

The swf_endsymbol() function ends the definition of a symbol that was started by the swf_startsymbol() function.

이전 | 처음으로 | 다음
swf_endshape | 위로 | swf_fontsize


swf_fontsize

(PHP 4 )

swf_fontsize -- Change the font size

Description

void swf_fontsize ( float size)

The swf_fontsize() function changes the font size to the value given by the size parameter.

이전 | 처음으로 | 다음
swf_endsymbol | 위로 | swf_fontslant


swf_fontslant

(PHP 4 )

swf_fontslant -- Set the font slant

Description

void swf_fontslant ( float slant)

Set the current font slant to the angle indicated by the slant parameter. Positive values create a forward slant, negative values create a negative slant.

이전 | 처음으로 | 다음
swf_fontsize | 위로 | swf_fonttracking


swf_fonttracking

(PHP 4 )

swf_fonttracking -- Set the current font tracking

Description

void swf_fonttracking ( float tracking)

Set the font tracking to the value specified by the tracking parameter. This function is used to increase the spacing between letters and text, positive values increase the space and negative values decrease the space between letters.

이전 | 처음으로 | 다음
swf_fontslant | 위로 | swf_getbitmapinfo


swf_getbitmapinfo

(PHP 4 )

swf_getbitmapinfo -- Get information about a bitmap

Description

array swf_getbitmapinfo ( int bitmapid)

The swf_getbitmapinfo() function returns an array of information about a bitmap given by the bitmapid parameter. The returned array has the following elements:

  • "size" - The size in bytes of the bitmap.

  • "width" - The width in pixels of the bitmap.

  • "height" - The height in pixels of the bitmap.

이전 | 처음으로 | 다음
swf_fonttracking | 위로 | swf_getfontinfo


swf_getfontinfo

(PHP 4 )

swf_getfontinfo -- The height in pixels of a capital A and a lowercase x

Description

array swf_getfontinfo ( void )

The swf_getfontinfo() function returns an associative array with the following parameters:

  • Aheight - The height in pixels of a capital A.

  • xheight - The height in pixels of a lowercase x.

이전 | 처음으로 | 다음
swf_getbitmapinfo | 위로 | swf_getframe


swf_getframe

(PHP 4 )

swf_getframe -- Get the frame number of the current frame

Description

int swf_getframe ( void )

The swf_getframe() function gets the number of the current frame.

이전 | 처음으로 | 다음
swf_getfontinfo | 위로 | swf_labelframe


swf_labelframe

(PHP 4 )

swf_labelframe -- Label the current frame

Description

void swf_labelframe ( string name)

Label the current frame with the name given by the name parameter.

이전 | 처음으로 | 다음
swf_getframe | 위로 | swf_lookat


swf_lookat

(PHP 4 )

swf_lookat -- Define a viewing transformation

Description

void swf_lookat ( float view_x, float view_y, float view_z, float reference_x, float reference_y, float reference_z, float twist)

The swf_lookat() function defines a viewing transformation by giving the viewing position (the parameters view_x, view_y, and view_z) and the coordinates of a reference point in the scene, the reference point is defined by the reference_x, reference_y , and reference_z parameters. The twist controls the rotation along with viewer's z axis.

이전 | 처음으로 | 다음
swf_labelframe | 위로 | swf_modifyobject


swf_modifyobject

(PHP 4 )

swf_modifyobject -- Modify an object

Description

void swf_modifyobject ( int depth, int how)

Updates the position and/or color of the object at the specified depth, depth. The parameter how determines what is updated. how can either be the constant MOD_MATRIX or MOD_COLOR or it can be a combination of both (MOD_MATRIX|MOD_COLOR).

MOD_COLOR uses the current mulcolor (specified by the function swf_mulcolor()) and addcolor (specified by the function swf_addcolor()) to color the object. MOD_MATRIX uses the current matrix to position the object.

이전 | 처음으로 | 다음
swf_lookat | 위로 | swf_mulcolor


swf_mulcolor

(PHP 4 )

swf_mulcolor -- Sets the global multiply color to the rgba value specified

Description

void swf_mulcolor ( float r, float g, float b, float a)

The swf_mulcolor() function sets the global multiply color to the rgba color specified. This color is then used (implicitly) by the swf_placeobject(), swf_modifyobject() and the swf_addbuttonrecord() functions. The color of the object will be multiplied by the rgba values when the object is written to the screen.

참고: The rgba values can be either positive or negative.

이전 | 처음으로 | 다음
swf_modifyobject | 위로 | swf_nextid


swf_nextid

(PHP 4 )

swf_nextid -- Returns the next free object id

Description

int swf_nextid ( void )

The swf_nextid() function returns the next available object id.

이전 | 처음으로 | 다음
swf_mulcolor | 위로 | swf_oncondition


swf_oncondition

(PHP 4 )

swf_oncondition -- Describe a transition used to trigger an action list

Description

void swf_oncondition ( int transition)

The swf_oncondition() function describes a transition that will trigger an action list. There are several types of possible transitions, the following are for buttons defined as TYPE_MENUBUTTON:

  • IdletoOverUp

  • OverUptoIdle

  • OverUptoOverDown

  • OverDowntoOverUp

  • IdletoOverDown

  • OutDowntoIdle

  • MenuEnter (IdletoOverUp|IdletoOverDown)

  • MenuExit (OverUptoIdle|OverDowntoIdle)

For TYPE_PUSHBUTTON there are the following options:

  • IdletoOverUp

  • OverUptoIdle

  • OverUptoOverDown

  • OverDowntoOverUp

  • OverDowntoOutDown

  • OutDowntoOverDown

  • OutDowntoIdle

  • ButtonEnter (IdletoOverUp|OutDowntoOverDown)

  • ButtonExit (OverUptoIdle|OverDowntoOutDown)

이전 | 처음으로 | 다음
swf_nextid | 위로 | swf_openfile


swf_openfile

(PHP 4 )

swf_openfile -- Open a new Shockwave Flash file

Description

void swf_openfile ( string filename, float width, float height, float framerate, float r, float g, float b)

The swf_openfile() function opens a new file named filename with a width of width and a height of height a frame rate of framerate and background with a red color of r a green color of g and a blue color of b.

The swf_openfile() must be the first function you call, otherwise your script will cause a segfault. If you want to send your output to the screen make the filename: "php://stdout" (support for this is in 4.0.1 and up).

이전 | 처음으로 | 다음
swf_oncondition | 위로 | swf_ortho2


swf_ortho2

(PHP 4 )

swf_ortho2 -- Defines 2D orthographic mapping of user coordinates onto the current viewport

Description

void swf_ortho2 ( float xmin, float xmax, float ymin, float ymax)

The swf_ortho2() function defines a two dimensional orthographic mapping of user coordinates onto the current viewport, this defaults to one to one mapping of the area of the Flash movie. If a perspective transformation is desired, the swf_perspective () function can be used.

이전 | 처음으로 | 다음
swf_openfile | 위로 | swf_ortho


swf_ortho

(PHP 4 >= 4.0.1)

swf_ortho -- Defines an orthographic mapping of user coordinates onto the current viewport

Description

void swf_ortho ( float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)

The swf_ortho() function defines an orthographic mapping of user coordinates onto the current viewport.

이전 | 처음으로 | 다음
swf_ortho2 | 위로 | swf_perspective


swf_perspective

(PHP 4 )

swf_perspective -- Define a perspective projection transformation

Description

void swf_perspective ( float fovy, float aspect, float near, float far)

The swf_perspective() function defines a perspective projection transformation. The fovy parameter is field-of-view angle in the y direction. The aspect parameter should be set to the aspect ratio of the viewport that is being drawn onto. The near parameter is the near clipping plane and the far parameter is the far clipping plane.

참고: Various distortion artifacts may appear when performing a perspective projection, this is because Flash players only have a two dimensional matrix. Some are not to pretty.

이전 | 처음으로 | 다음
swf_ortho | 위로 | swf_placeobject


swf_placeobject

(PHP 4 )

swf_placeobject -- Place an object onto the screen

Description

void swf_placeobject ( int objid, int depth)

Places the object specified by objid in the current frame at a depth of depth. The objid parameter and the depth must be between 1 and 65535.

This uses the current mulcolor (specified by swf_mulcolor()) and the current addcolor (specified by swf_addcolor()) to color the object and it uses the current matrix to position the object.

참고: Full RGBA colors are supported.

이전 | 처음으로 | 다음
swf_perspective | 위로 | swf_polarview


swf_polarview

(PHP 4 )

swf_polarview -- Define the viewer's position with polar coordinates

Description

void swf_polarview ( float dist, float azimuth, float incidence, float twist)

The swf_polarview() function defines the viewer's position in polar coordinates. The dist parameter gives the distance between the viewpoint to the world space origin. The azimuth parameter defines the azimuthal angle in the x,y coordinate plane, measured in distance from the y axis. The incidence parameter defines the angle of incidence in the y,z plane, measured in distance from the z axis. The incidence angle is defined as the angle of the viewport relative to the z axis. Finally the twist specifies the amount that the viewpoint is to be rotated about the line of sight using the right hand rule.

이전 | 처음으로 | 다음
swf_placeobject | 위로 | swf_popmatrix


swf_popmatrix

(PHP 4 )

swf_popmatrix -- Restore a previous transformation matrix

Description

void swf_popmatrix ( void )

The swf_popmatrix() function pushes the current transformation matrix back onto the stack.

이전 | 처음으로 | 다음
swf_polarview | 위로 | swf_posround


swf_posround

(PHP 4 )

swf_posround -- Enables or Disables the rounding of the translation when objects are placed or moved

Description

void swf_posround ( int round)

The swf_posround() function enables or disables the rounding of the translation when objects are placed or moved, there are times when text becomes more readable because rounding has been enabled. The round is whether to enable rounding or not, if set to the value of 1, then rounding is enabled, if set to 0 then rounding is disabled.

이전 | 처음으로 | 다음
swf_popmatrix | 위로 | swf_pushmatrix


swf_pushmatrix

(PHP 4 )

swf_pushmatrix -- Push the current transformation matrix back unto the stack

Description

void swf_pushmatrix ( void )

The swf_pushmatrix() function pushes the current transformation matrix back onto the stack.

이전 | 처음으로 | 다음
swf_posround | 위로 | swf_removeobject


swf_removeobject

(PHP 4 )

swf_removeobject -- Remove an object

Description

void swf_removeobject ( int depth)

Removes the object at the depth specified by depth.

이전 | 처음으로 | 다음
swf_pushmatrix | 위로 | swf_rotate


swf_rotate

(PHP 4 )

swf_rotate -- Rotate the current transformation

Description

void swf_rotate ( float angle, string axis)

The swf_rotate() rotates the current transformation by the angle given by the angle parameter around the axis given by the axis parameter. Valid values for the axis are 'x' (the x axis), 'y' (the y axis) or 'z' (the z axis).

이전 | 처음으로 | 다음
swf_removeobject | 위로 | swf_scale


swf_scale

(PHP 4 )

swf_scale -- Scale the current transformation

Description

void swf_scale ( float x, float y, float z)

The swf_scale() scales the x coordinate of the curve by the value of the x parameter, the y coordinate of the curve by the value of the y parameter, and the z coordinate of the curve by the value of the z parameter.

이전 | 처음으로 | 다음
swf_rotate | 위로 | swf_setfont


swf_setfont

(PHP 4 )

swf_setfont -- Change the current font

Description

void swf_setfont ( int fontid)

The swf_setfont() sets the current font to the value given by the fontid parameter.

이전 | 처음으로 | 다음
swf_scale | 위로 | swf_setframe


swf_setframe

(PHP 4 )

swf_setframe -- Switch to a specified frame

Description

void swf_setframe ( int framenumber)

The swf_setframe() changes the active frame to the frame specified by framenumber.

이전 | 처음으로 | 다음
swf_setfont | 위로 | swf_shapearc


swf_shapearc

(PHP 4 )

swf_shapearc -- Draw a circular arc

Description

void swf_shapearc ( float x, float y, float r, float ang1, float ang2)

The swf_shapearc() function draws a circular arc from angle A given by the ang1 parameter to angle B given by the ang2 parameter. The center of the circle has an x coordinate given by the x parameter and a y coordinate given by the y, the radius of the circle is given by the r parameter.

이전 | 처음으로 | 다음
swf_setframe | 위로 | swf_shapecurveto3


swf_shapecurveto3

(PHP 4 )

swf_shapecurveto3 -- Draw a cubic bezier curve

Description

void swf_shapecurveto3 ( float x1, float y1, float x2, float y2, float x3, float y3)

Draw a cubic bezier curve using the x,y coordinate pairs x1, y1 and x2,y2 as off curve control points and the x,y coordinate x3, y3 as an endpoint. The current position is then set to the x,y coordinate pair given by x3,y3.

이전 | 처음으로 | 다음
swf_shapearc | 위로 | swf_shapecurveto


swf_shapecurveto

(PHP 4 )

swf_shapecurveto -- Draw a quadratic bezier curve between two points

Description

void swf_shapecurveto ( float x1, float y1, float x2, float y2)

The swf_shapecurveto() function draws a quadratic bezier curve from the current location, though the x coordinate given by x1 and the y coordinate given by y1 to the x coordinate given by x2 and the y coordinate given by y2. The current position is then set to the x,y coordinates given by the x2 and y2 parameters

이전 | 처음으로 | 다음
swf_shapecurveto3 | 위로 | swf_shapefillbitmapclip


swf_shapefillbitmapclip

(PHP 4 )

swf_shapefillbitmapclip -- Set current fill mode to clipped bitmap

Description

void swf_shapefillbitmapclip ( int bitmapid)

Sets the fill to bitmap clipped, empty spaces will be filled by the bitmap given by the bitmapid parameter.

이전 | 처음으로 | 다음
swf_shapecurveto | 위로 | swf_shapefillbitmaptile


swf_shapefillbitmaptile

(PHP 4 )

swf_shapefillbitmaptile -- Set current fill mode to tiled bitmap

Description

void swf_shapefillbitmaptile ( int bitmapid)

Sets the fill to bitmap tile, empty spaces will be filled by the bitmap given by the bitmapid parameter (tiled).

이전 | 처음으로 | 다음
swf_shapefillbitmapclip | 위로 | swf_shapefilloff


swf_shapefilloff

(PHP 4 )

swf_shapefilloff -- Turns off filling

Description

void swf_shapefilloff ( void )

The swf_shapefilloff() function turns off filling for the current shape.

이전 | 처음으로 | 다음
swf_shapefillbitmaptile | 위로 | swf_shapefillsolid


swf_shapefillsolid

(PHP 4 )

swf_shapefillsolid -- Set the current fill style to the specified color

Description

void swf_shapefillsolid ( float r, float g, float b, float a)

The swf_shapefillsolid() function sets the current fill style to solid, and then sets the fill color to the values of the rgba parameters.

이전 | 처음으로 | 다음
swf_shapefilloff | 위로 | swf_shapelinesolid


swf_shapelinesolid

(PHP 4 )

swf_shapelinesolid -- Set the current line style

Description

void swf_shapelinesolid ( float r, float g, float b, float a, float width)

The swf_shapelinesolid() function sets the current line style to the color of the rgba parameters and width to the width parameter. If 0.0 is given as a width then no lines are drawn.

이전 | 처음으로 | 다음
swf_shapefillsolid | 위로 | swf_shapelineto


swf_shapelineto

(PHP 4 )

swf_shapelineto -- Draw a line

Description

void swf_shapelineto ( float x, float y)

The swf_shapelineto() draws a line to the x,y coordinates given by the x parameter & the y parameter. The current position is then set to the x,y parameters.

이전 | 처음으로 | 다음
swf_shapelinesolid | 위로 | swf_shapemoveto


swf_shapemoveto

(PHP 4 )

swf_shapemoveto -- Move the current position

Description

void swf_shapemoveto ( float x, float y)

The swf_shapemoveto() function moves the current position to the x coordinate given by the x parameter and the y position given by the y parameter.

이전 | 처음으로 | 다음
swf_shapelineto | 위로 | swf_showframe


swf_showframe

(PHP 4 )

swf_showframe -- Display the current frame

Description

void swf_showframe ( void )

The swf_showframe function will output the current frame.

이전 | 처음으로 | 다음
swf_shapemoveto | 위로 | swf_startbutton


swf_startbutton

(PHP 4 )

swf_startbutton -- Start the definition of a button

Description

void swf_startbutton ( int objid, int type)

The swf_startbutton() function starts off the definition of a button. The type parameter can either be TYPE_MENUBUTTON or TYPE_PUSHBUTTON. The TYPE_MENUBUTTON constant allows the focus to travel from the button when the mouse is down, TYPE_PUSHBUTTON does not allow the focus to travel when the mouse is down.

이전 | 처음으로 | 다음
swf_showframe | 위로 | swf_startdoaction


swf_startdoaction

(PHP 4 )

swf_startdoaction -- Start a description of an action list for the current frame

Description

void swf_startdoaction ( void )

The swf_startdoaction() function starts the description of an action list for the current frame. This must be called before actions are defined for the current frame.

이전 | 처음으로 | 다음
swf_startbutton | 위로 | swf_startshape


swf_startshape

(PHP 4 )

swf_startshape -- Start a complex shape

Description

void swf_startshape ( int objid)

The swf_startshape() function starts a complex shape, with an object id given by the objid parameter.

이전 | 처음으로 | 다음
swf_startdoaction | 위로 | swf_startsymbol


swf_startsymbol

(PHP 4 )

swf_startsymbol -- Define a symbol

Description

void swf_startsymbol ( int objid)

Define an object id as a symbol. Symbols are tiny flash movies that can be played simultaneously. The objid parameter is the object id you want to define as a symbol.

이전 | 처음으로 | 다음
swf_startshape | 위로 | swf_textwidth


swf_textwidth

(PHP 4 )

swf_textwidth -- Get the width of a string

Description

float swf_textwidth ( string str)

The swf_textwidth() function gives the width of the string, str, in pixels, using the current font and font size.

이전 | 처음으로 | 다음
swf_startsymbol | 위로 | swf_translate


swf_translate

(PHP 4 )

swf_translate -- Translate the current transformations

Description

void swf_translate ( float x, float y, float z)

The swf_translate() function translates the current transformation by the x, y, and z values given.

이전 | 처음으로 | 다음
swf_textwidth | 위로 | swf_viewport


swf_viewport

(PHP 4 )

swf_viewport -- Select an area for future drawing

Description

void swf_viewport ( float xmin, float xmax, float ymin, float ymax)

The swf_viewport() function selects an area for future drawing for xmin to xmax and ymin to ymax, if this function is not called the area defaults to the size of the screen.

이전 | 처음으로 | 다음
swf_translate | 위로 | SNMP Functions


SNMP Functions

PHP 매뉴얼
이전 다음

CII. SNMP Functions

소개

요구 사항

In order to use the SNMP functions on Unix you need to install the NET-SNMP package. On Windows these functions are only available on NT and not on Win95/98.

설치

Important: In order to use the UCD SNMP package, you need to define NO_ZEROLENGTH_COMMUNITY to 1 before compiling it. After configuring UCD SNMP, edit config.h and search for NO_ZEROLENGTH_COMMUNITY. Uncomment the #define line. It should look like this afterwards:
#define NO_ZEROLENGTH_COMMUNITY 1
Now compile PHP --with-snmp[=DIR].

If you see strange segmentation faults in combination with SNMP commands, you did not follow the above instructions. If you do not want to recompile UCD SNMP, you can compile PHP with the --enable-ucd-snmp-hack switch which will work around the misfeature.

The Windows distribution contains support files for SNMP in the mibs directory. This directory should be moved to DRIVE:\usr\mibs, where DRIVE must be replaced with the driveletter where PHP is installed on, e.g.: c:\usr\mibs.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
snmp_get_quick_print -- Fetches the current value of the UCD library's quick_print setting
snmp_set_quick_print -- Set the value of quick_print within the UCD SNMP library
snmpget -- Fetch an SNMP object
snmprealwalk -- Return all objects including their respective object ID within the specified one
snmpset -- Set an SNMP object
snmpwalk -- Fetch all the SNMP objects from an agent
snmpwalkoid -- Query for a tree of information about a network entity

이전 | 처음으로 | 다음
swf_viewport | 위로 | snmp_get_quick_print


snmp_get_quick_print

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

snmp_get_quick_print -- Fetches the current value of the UCD library's quick_print setting

Description

bool snmp_get_quick_print ( void )

Returns the current value stored in the UCD Library for quick_print. quick_print is off by default.

예 1. snmp_get_quick_print() example

<?php
  $quickprint = snmp_get_quick_print();
?>

Above function call would return FALSE if quick_print is off, and TRUE if quick_print is on.

snmp_get_quick_print() is only available when using the UCD SNMP library. This function is not available when using the Windows SNMP library.

See also snmp_set_quick_print() for a full description of what quick_print does.

이전 | 처음으로 | 다음
SNMP Functions | 위로 | snmp_set_quick_print


snmp_set_quick_print

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

snmp_set_quick_print -- Set the value of quick_print within the UCD SNMP library

Description

void snmp_set_quick_print ( bool quick_print)

Sets the value of quick_print within the UCD SNMP library. When this is set (1), the SNMP library will return 'quick printed' values. This means that just the value will be printed. When quick_print is not enabled (default) the UCD SNMP library prints extra information including the type of the value (i.e. IpAddress or OID). Additionally, if quick_print is not enabled, the library prints additional hex values for all strings of three characters or less.

Setting quick_print is often used when using the information returned rather then displaying it.

<?php
snmp_set_quick_print(0);
$a = snmpget("127.0.0.1", "public", ".1.3.6.1.2.1.2.2.1.9.1");
echo "$a< br />\n";
snmp_set_quick_print(1);
$a = snmpget("127.0.0.1", "public", ".1.3.6.1.2.1.2.2.1.9.1");
echo "$a<br />\n";
?>

The first value printed might be: 'Timeticks: (0) 0:00:00.00', whereas with quick_print enabled, just '0:00:00.00' would be printed.

By default the UCD SNMP library returns verbose values, quick_print is used to return only the value.

Currently strings are still returned with extra quotes, this will be corrected in a later release.

snmp_set_quick_print() is only available when using the UCD SNMP library. This function is not available when using the Windows SNMP library.

이전 | 처음으로 | 다음
snmp_get_quick_print | 위로 | snmpget


snmpget

(PHP 3, PHP 4 , PHP 5)

snmpget -- Fetch an SNMP object

Description

string snmpget ( string hostname, string community, string object_id [, int timeout [, int retries]])

Returns SNMP object value on success and FALSE on error.

The snmpget() function is used to read the value of an SNMP object specified by the object_id. SNMP agent is specified by the hostname and the read community is specified by the community parameter.

<?php
$syscontact = snmpget("127.0.0.1", "public", "system.SysContact.0");
?>

이전 | 처음으로 | 다음
snmp_set_quick_print | 위로 | snmprealwalk


snmprealwalk

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

snmprealwalk -- Return all objects including their respective object ID within the specified one

Description

array snmprealwalk ( string host, string community, string object_id [, int timeout [, int retries]])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
snmpget | 위로 | snmpset


snmpset

(PHP 3>= 3.0.12, PHP 4 , PHP 5)

snmpset -- Set an SNMP object

Description

bool snmpset ( string hostname, string community, string object_id, string type, mixed value [, int timeout [, int retries]])

Sets the specified SNMP object value, returning TRUE on success and FALSE on error.

The snmpset() function is used to set the value of an SNMP object specified by the object_id. SNMP agent is specified by the hostname and the read community is specified by the community parameter.

이전 | 처음으로 | 다음
snmprealwalk | 위로 | snmpwalk


snmpwalk

(PHP 3, PHP 4 , PHP 5)

snmpwalk -- Fetch all the SNMP objects from an agent

Description

array snmpwalk ( string hostname, string community, string object_id [, int timeout [, int retries]])

Returns an array of SNMP object values starting from the object_id as root and FALSE on error.

snmpwalk() function is used to read all the values from an SNMP agent specified by the hostname. Community specifies the read community for that agent. A NULL object_id is taken as the root of the SNMP objects tree and all objects under that tree are returned as an array. If object_id is specified, all the SNMP objects below that object_id are returned.

<?php
$a = snmpwalk("127.0.0.1", "public", "");
?>

Above function call would return all the SNMP objects from the SNMP agent running on localhost. One can step through the values with a loop

<?php
for ($i=0; $i < count($a); $i++) {
    echo $a[$i];
}
?>

이전 | 처음으로 | 다음
snmpset | 위로 | snmpwalkoid


snmpwalkoid

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

snmpwalkoid -- Query for a tree of information about a network entity

Description

array snmpwalkoid ( string hostname, string community, string object_id [, int timeout [, int retries]])

Returns an associative array with object ids and their respective object value starting from the object_id as root and FALSE on error.

snmpwalkoid() function is used to read all object ids and their respective values from an SNMP agent specified by the hostname. Community specifies the read community for that agent. A NULL object_id is taken as the root of the SNMP objects tree and all objects under that tree are returned as an array. If object_id is specified, all the SNMP objects below that object_id are returned.

The existence of snmpwalkoid() and snmpwalk() has historical reasons. Both functions are provided for backward compatibility.

<?php
$a = snmpwalkoid("127.0.0.1", "public", "");
?>

Above function call would return all the SNMP objects from the SNMP agent running on localhost. One can step through the values with a loop

<?php
for (reset($a); $i = key($a); next($a)) {
    echo "$i: $a[$i]<br />\n";
}
?>

이전 | 처음으로 | 다음
snmpwalk | 위로 | Socket Functions


Socket Functions

PHP 매뉴얼
이전 다음

CIII. Socket Functions

소개

The socket extension implements a low-level interface to the socket communication functions based on the popular BSD sockets, providing the possibility to act as a socket server as well as a client.

For a more generic client-side socket interface, see
stream_socket_client(),
stream_socket_server(),
fsockopen(), and
pfsockopen().

When using these functions, it is important to remember that while many of them have identical names to their C counterparts, they often have different declarations. Please be sure to read the descriptions to avoid confusion.

Those unfamiliar with socket programming can find a lot of useful material in the appropriate Unix man pages, and there is a great deal of tutorial information on socket programming in C on the web, much of which can be applied, with slight modifications, to socket programming in PHP. The Unix Socket FAQ might be a good start.

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

The socket functions described here are part of an extension to PHP which must be enabled at compile time by giving the --enable-sockets option to configure.

참고: IPv6는 PHP 5.0.0부터 지원합니다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

AF_UNIX (integer)

AF_INET (integer)

AF_INET6 (integer)

SOCK_STREAM (integer)

SOCK_DGRAM (integer)

SOCK_RAW (integer)

SOCK_SEQPACKET (integer)

SOCK_RDM (integer)

MSG_OOB (integer)

MSG_WAITALL (integer)

MSG_PEEK (integer)

MSG_DONTROUTE (integer)

SO_DEBUG (integer)

SO_REUSEADDR (integer)

SO_KEEPALIVE (integer)

SO_DONTROUTE (integer)

SO_LINGER (integer)

SO_BROADCAST (integer)

SO_OOBINLINE (integer)

SO_SNDBUF (integer)

SO_RCVBUF (integer)

SO_SNDLOWAT (integer)

SO_RCVLOWAT (integer)

SO_SNDTIMEO (integer)

SO_RCVTIMEO (integer)

SO_TYPE (integer)

SO_ERROR (integer)

SOL_SOCKET (integer)

PHP_NORMAL_READ (integer)

PHP_BINARY_READ (integer)

SOL_TCP (integer)

SOL_UDP (integer)

Socket Errors

The socket extension was written to provide a useable interface to the powerful BSD sockets. Care has been taken that the functions work equally well on Win32 and Unix implementations. Almost all of the sockets functions may fail under certain conditions and therefore emit an E_WARNING message describing the error. Sometimes this doesn't happen to the desire of the developer. For example the function socket_read() may suddenly emit an E_WARNING message because the connection broke unexpectedly. It's common to suppress the warning with the @-operator and catch the error code within the application with the socket_last_error() function. You may call the socket_strerror() function with this error code to retrieve a string describing the error. See their description for more information.

참고: The E_WARNING messages generated by the socket extension are in English though the retrieved error message will appear depending on the current locale (LC_MESSAGES):
Warning - socket_bind() unable to bind address [98]: Die Adresse wird bereits verwendet

예제

예 1. Socket example: Simple TCP/IP server

This example shows a simple talkback server. Change the address and port variables to suit your setup and execute. You may then connect to the server with a command similar to: telnet 192.168.1.53 10000 (where the address and port match your setup). Anything you type will then be output on the server side, and echoed back to you. To disconnect, enter 'quit'.

#!/usr/local/bin/php -q
<?php
error_reporting(E_ALL);

/* Allow the script to hang around waiting for connections. */
set_time_limit(0);

/* Turn on implicit output flushing so we see what we're getting
* as it comes in. */
ob_implicit_flush();

$address = '192.168.1.53';
$port = 10000;

if (($sock = socket_create(AF_INET, SOCK_STREAM, SOL_TCP)) < 0) {
    echo "socket_create() failed: reason: " . socket_strerror($sock) . "\n";
}

if (($ret = socket_bind($sock, $address, $port)) < 0) {
    echo "socket_bind() failed: reason: " . socket_strerror($ret) . "\n";
}

if (($ret = socket_listen($sock, 5)) < 0) {
    echo "socket_listen() failed: reason: " . socket_strerror($ret) . "\n";
}

do {
    if (($msgsock = socket_accept($sock)) < 0) {
        echo "socket_accept() failed: reason: " . socket_strerror($msgsock) . "\n";
        break;
    }
    /* Send instructions. */
    $msg = "\nWelcome to the PHP Test Server. \n" .
        "To quit, type 'quit'. To shut down the server type 'shutdown'.\n";
    socket_write($msgsock, $msg, strlen($msg));

    do {
        if (false === ($buf = socket_read($msgsock, 2048, PHP_NORMAL_READ))) {
            echo "socket_read() failed: reason: " . socket_strerror($ret) . "\n";
            break 2;
        }
        if (!$buf = trim($buf)) {
            continue;
        }
        if ($buf == 'quit') {
            break;
        }
        if ($buf == 'shutdown') {
            socket_close($msgsock);
            break 2;
        }
        $talkback = "PHP: You said '$buf'.\n";
        socket_write($msgsock, $talkback, strlen($talkback));
        echo "$buf\n";
    } while (true);
    socket_close($msgsock);
} while (true);

socket_close($sock);
?>

예 2. Socket example: Simple TCP/IP client

This example shows a simple, one-shot HTTP client. It simply connects to a page, submits a HEAD request, echoes the reply, and exits.

<?php
error_reporting(E_ALL);

echo "<h2>TCP/IP Connection</h2>\n";

/* Get the port for the WWW service. */
$service_port = getservbyname('www', 'tcp');

/* Get the IP address for the target host. */
$address = gethostbyname('www.example.com');

/* Create a TCP/IP socket. */
$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
if ($socket < 0) {
    echo "socket_create() failed: reason: " . socket_strerror($socket) . "\n";
} else {
    echo "OK.\n";
}

echo "Attempting to connect to '$address' on port '$service_port'...";
$result = socket_connect($socket, $address, $service_port);
if ($result < 0) {
    echo "socket_connect() failed.\nReason: ($result) " . socket_strerror($result) . "\n";
} else {
    echo "OK.\n";
}

$in = "HEAD / HTTP/1.1\r\n";
$in .= "Host: www.example.com\r\n";
$in .= "Connection: Close\r\n\r\n";
$out = '';

echo "Sending HTTP HEAD request...";
socket_write($socket, $in, strlen($in));
echo "OK.\n";

echo "Reading response:\n\n";
while ($out = socket_read($socket, 2048)) {
    echo $out;
}

echo "Closing socket...";
socket_close($socket);
echo "OK.\n\n";
?>

차례
socket_accept -- Accepts a connection on a socket
socket_bind -- Binds a name to a socket
socket_clear_error -- Clears the error on the socket or the last error code
socket_close -- Closes a socket resource
socket_connect -- Initiates a connection on a socket
socket_create_listen -- Opens a socket on port to accept connections
socket_create_pair -- Creates a pair of indistinguishable sockets and stores them in an array.
socket_create -- Create a socket (endpoint for communication)
socket_get_option -- Gets socket options for the socket
socket_getpeername -- Queries the remote side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type.
socket_getsockname -- Queries the local side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type.
socket_iovec_add -- Adds a new vector to the scatter/gather array
socket_iovec_alloc -- Builds a 'struct iovec' for use with sendmsg, recvmsg, writev, and readv
socket_iovec_delete -- Deletes a vector from an array of vectors
socket_iovec_fetch -- Returns the data held in the iovec specified by iovec_id[iovec_position]
socket_iovec_free -- Frees the iovec specified by iovec_id
socket_iovec_set -- Sets the data held in iovec_id[iovec_position] to new_val
socket_last_error -- Returns the last error on the socket
socket_listen -- Listens for a connection on a socket
socket_read -- Reads a maximum of length bytes from a socket
socket_readv -- Reads from an fd, using the scatter-gather array defined by iovec_id
socket_recv -- Receives data from a connected socket
socket_recvfrom -- Receives data from a socket, connected or not
socket_recvmsg -- Used to receive messages on a socket, whether connection-oriented or not
socket_select -- Runs the select() system call on the given arrays of sockets with a specified timeout
socket_send -- Sends data to a connected socket
socket_sendmsg -- Sends a message to a socket, regardless of whether it is connection-oriented or not
socket_sendto -- Sends a message to a socket, whether it is connected or not
socket_set_block -- Sets blocking mode on a socket resource
socket_set_nonblock -- Sets nonblocking mode for file descriptor fd
socket_set_option -- Sets socket options for the socket
socket_shutdown -- Shuts down a socket for receiving, sending, or both.
socket_strerror -- Return a string describing a socket error
socket_write -- Write to a socket
socket_writev -- Writes to a file descriptor, fd, using the scatter-gather array defined by iovec_id

이전 | 처음으로 | 다음
snmpwalkoid | 위로 | socket_accept


socket_accept

(PHP 4 >= 4.1.0, PHP 5)

socket_accept -- Accepts a connection on a socket

Description

resource socket_accept ( resource socket)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

After the socket socket has been created using socket_create(), bound to a name with socket_bind(), and told to listen for connections with socket_listen(), this function will accept incoming connections on that socket. Once a successful connection is made, a new socket resource is returned, which may be used for communication. If there are multiple connections queued on the socket, the first will be used. If there are no pending connections, socket_accept() will block until a connection becomes present. If socket has been made non-blocking using socket_set_blocking() or socket_set_nonblock(), FALSE will be returned.

The socket resource returned by socket_accept() may not be used to accept new connections. The original listening socket socket, however, remains open and may be reused.

Returns a new socket resource on success, or FALSE on error. The actual error code can be retrieved by calling socket_last_error(). This error code may be passed to socket_strerror() to get a textual explanation of the error.

See also
socket_bind(),
socket_connect(),
socket_listen(),
socket_create(), and
socket_strerror().

이전 | 처음으로 | 다음
Socket Functions | 위로 | socket_bind


socket_bind

(PHP 4 >= 4.1.0, PHP 5)

socket_bind -- Binds a name to a socket

Description

bool socket_bind ( resource socket, string address [, int port])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

socket_bind() binds the name given in address to the socket described by socket, which must be a valid socket resource created with socket_create().

The address parameter is either an IP address in dotted-quad notation (e.g. 127.0.0.1), if the socket is of the AF_INET family; or the pathname of a Unix-domain socket, if the socket family is AF_UNIX.

The port parameter is only used when connecting to an AF_INET socket, and designates the port on the remote host to which a connection should be made.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. The error code can be retrieved with socket_last_error(). This code may be passed to socket_strerror() to get a textual explanation of the error. Note that socket_last_error() is reported to return an invalid error code in case you are trying to bind the socket to a wrong address that does not belong to your Windows 9x/ME machine.

See also
socket_connect(),
socket_listen(),
socket_create(),
socket_last_error() and
socket_strerror().

이전 | 처음으로 | 다음
socket_accept | 위로 | socket_clear_error


socket_clear_error

(PHP 4 >= 4.2.0, PHP 5)

socket_clear_error -- Clears the error on the socket or the last error code

Description

void socket_clear_error ( [resource socket])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

This function clears the error code on the given socket or the global last socket error.

This function allows explicitly resetting the error code value either of a socket or of the extension global last error code. This may be useful to detect within a part of the application if an error occurred or not.

See also socket_last_error() and socket_strerror().

이전 | 처음으로 | 다음
socket_bind | 위로 | socket_close


socket_close

(PHP 4 >= 4.1.0, PHP 5)

socket_close -- Closes a socket resource

Description

void socket_close ( resource socket)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

socket_close() closes the socket resource given by socket.

참고: socket_close() can't be used on PHP file resources created with fopen(), popen(), fsockopen(), or pfsockopen(); it is meant for sockets created with socket_create() or socket_accept().

See also socket_bind(), socket_listen(),
socket_create() and
socket_strerror().

이전 | 처음으로 | 다음
socket_clear_error | 위로 | socket_connect


socket_connect

(PHP 4 >= 4.1.0, PHP 5)

socket_connect -- Initiates a connection on a socket

Description

bool socket_connect ( resource socket, string address [, int port])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

Initiates a connection using the socket resource socket, which must be a valid socket resource created with socket_create().

The address parameter is either an IP address in dotted-quad notation (e.g. 127.0.0.1), if the socket is of the AF_INET family; or the pathname of a Unix domain socket, if the socket family is AF_UNIX.

The port parameter is only used when connecting to an AF_INET socket, and designates the port on the remote host to which a connection should be made.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. The error code can be retrieved with socket_last_error(). This code may be passed to socket_strerror() to get a textual explanation of the error.

See also
socket_bind(),
socket_listen(),
socket_create(),
socket_last_error() and
socket_strerror().

이전 | 처음으로 | 다음
socket_close | 위로 | socket_create_listen


socket_create_listen

(PHP 4 >= 4.1.0, PHP 5)

socket_create_listen -- Opens a socket on port to accept connections

Description

resource socket_create_listen ( int port [, int backlog])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

This function is meant to ease the task of creating a new socket which only listens to accept new connections.

socket_create_listen() creates a new socket resource of type AF_INET listening on all local interfaces on the given port waiting for new connections.

The backlog parameter defines the maximum length the queue of pending connections may grow to. SOMAXCONN may be passed as backlog parameter, see socket_listen() for more information.

socket_create_listen() returns a new socket resource on success or FALSE on error. The error code can be retrieved with socket_last_error(). This code may be passed to socket_strerror() to get a textual explanation of the error.

참고: If you want to create a socket which only listens on a certain interface you need to use socket_create(), socket_bind() and socket_listen().

See also
socket_create(),
socket_bind(),
socket_listen(),
socket_last_error() and
socket_strerror().

이전 | 처음으로 | 다음
socket_connect | 위로 | socket_create_pair


socket_create_pair

(PHP 4 >= 4.1.0, PHP 5)

socket_create_pair -- Creates a pair of indistinguishable sockets and stores them in an array.

Description

bool socket_create_pair ( int domain, int type, int protocol, array &fd)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

socket_create_pair() creates two connected and indistinguishable sockets, and stores them in &fd. This function is commonly used in IPC (InterProcess Communication).

The domain parameter specifies the protocol family to be used by the socket.

표 1. Available address/protocol families

Domain | Description
AF_INET | IPv4 Internet based protocols. TCP and UDP are common protocols of this protocol family. Supported only in windows.
AF_INET6 | IPv6 Internet based protocols. TCP and UDP are common protocols of this protocol family. Support added in PHP 5.0.0. Supported only in windows.
AF_UNIX | Local communication protocol family. High efficiency and low overhead make it a great form of IPC (Interprocess Communication).

The type parameter selects the type of communication to be used by the socket.

표 2. Available socket types

Type | Description
SOCK_STREAM | Provides sequenced, reliable, full-duplex, connection-based byte streams. An out-of-band data transmission mechanism may be supported. The TCP protocol is based on this socket type.
SOCK_DGRAM | Supports datagrams (connectionless, unreliable messages of a fixed maximum length). The UDP protocol is based on this socket type.
SOCK_SEQPACKET | Provides a sequenced, reliable, two-way connection-based data transmission path for datagrams of fixed maximum length; a consumer is required to read an entire packet with each read call.
SOCK_RAW | Provides raw network protocol access. This special type of socket can be used to manually construct any type of protocol. A common use for this socket type is to perform ICMP requests (like ping, traceroute, etc).
SOCK_RDM | Provides a reliable datagram layer that does not guarantee ordering. This is most likely not implemented on your operating system.

The protocol parameter sets the specific protocol within the specified domain to be used when communicating on the returned socket. The proper value can be retrieved by name by using getprotobyname(). If the desired protocol is TCP, or UDP the corresponding constants SOL_TCP, and SOL_UDP can also be used.

표 3. Common protocols

Name | Description
icmp | The Internet Control Message Protocol is used primarily by gateways and hosts to report errors in datagram communication. The "ping" command (present in most modern operating systems) is an example application of ICMP.
udp | The User Datagram Protocol is a connectionless, unreliable, protocol with fixed record lengths. Due to these aspects, UDP requires a minimum amount of protocol overhead.
tcp | The Transmission Control Protocol is a reliable, connection based, stream oriented, full duplex protocol. TCP guarantees that all data packets will be received in the order in which they were sent. If any packet is somehow lost during communication, TCP will automatically retransmit the packet until the destination host acknowledges that packet. For reliability and performance reasons, the TCP implementation itself decides the appropriate octet boundaries of the underlying datagram communication layer. Therefore, TCP applications must allow for the possibility of partial record transmission.

예 1. socket_create_pair() example

<?php
$sockets = array();
$uniqid = uniqid('');
if (file_exists("/tmp/$uniqid.sock")) {
    die('Temporary socket already exists.');
}
/* Setup socket pair */
if (!socket_create_pair(AF_UNIX, SOCK_STREAM, 0, $sockets)) {
    echo socket_strerror(socket_last_error());
}
/* Send and Recieve Data */
if (!socket_write($sockets[0], "ABCdef123\n", strlen("ABCdef123\n"))) {
    echo socket_strerror(socket_last_error());
}
if (!$data = socket_read($sockets[1], strlen("ABCdef123\n"), PHP_BINARY_READ)) {
    echo socket_strerror(socket_last_error());
}
var_dump($data);

/* Close sockets */
socket_close($sockets[0]);
socket_close($sockets[1]);
?>

예 2. socket_create_pair() IPC example

<?php
$ary = array();
$strone = 'Message From Parent.';
$strtwo = 'Message From Child.';
if (!socket_create_pair(AF_UNIX, SOCK_STREAM, 0, $ary)) {
    echo socket_strerror(socket_last_error());
}
$pid = pcntl_fork();
if ($pid == -1) {
    echo 'Could not fork Process.';
} elseif ($pid) {
    /*parent*/
    socket_close($ary[0]);
    if (!socket_write($ary[1], $strone, strlen($strone))) {
        echo socket_strerror(socket_last_error());
    }
    if (socket_read($ary[1], strlen($strtwo), PHP_BINARY_READ) == $strtwo) {
        echo "Recieved $strtwo\n";
    }
    socket_close($ary[1]);
} else {
    /*child*/
    socket_close($ary[1]);
    if (!socket_write($ary[0], $strtwo, strlen($strtwo))) {
        echo socket_strerror(socket_last_error());
    }
    if (socket_read($ary[0], strlen($strone), PHP_BINARY_READ) == $strone) {
        echo "Recieved $strone\n";
    }
    socket_close($ary[0]);
}
?>

이전 | 처음으로 | 다음
socket_create_listen | 위로 | socket_create


socket_create

(PHP 4 >= 4.1.0, PHP 5)

socket_create -- Create a socket (endpoint for communication)

Description

resource socket_create ( int domain, int type, int protocol)

Creates and returns a socket resource, also referred to as an endpoint of communication. A typical network connection is made up of 2 sockets, one performing the role of the client, and another performing the role of the server.

The domain parameter specifies the protocol family to be used by the socket.

표 1. Available address/protocol families

Domain | Description
AF_INET | IPv4 Internet based protocols. TCP and UDP are common protocols of this protocol family.
AF_INET6 | IPv6 Internet based protocols. TCP and UDP are common protocols of this protocol family. Support added in PHP 5.0.0.
AF_UNIX | Local communication protocol family. High efficiency and low overhead make it a great form of IPC (Interprocess Communication).

The type parameter selects the type of communication to be used by the socket.

표 2. Available socket types

Type | Description
SOCK_STREAM | Provides sequenced, reliable, full-duplex, connection-based byte streams. An out-of-band data transmission mechanism may be supported. The TCP protocol is based on this socket type.
SOCK_DGRAM | Supports datagrams (connectionless, unreliable messages of a fixed maximum length). The UDP protocol is based on this socket type.
SOCK_SEQPACKET | Provides a sequenced, reliable, two-way connection-based data transmission path for datagrams of fixed maximum length; a consumer is required to read an entire packet with each read call.
SOCK_RAW | Provides raw network protocol access. This special type of socket can be used to manually construct any type of protocol. A common use for this socket type is to perform ICMP requests (like ping, traceroute, etc).
SOCK_RDM | Provides a reliable datagram layer that does not guarantee ordering. This is most likely not implemented on your operating system.

The protocol parameter sets the specific protocol within the specified domain to be used when communicating on the returned socket. The proper value can be retrieved by name by using getprotobyname(). If the desired protocol is TCP, or UDP the corresponding constants SOL_TCP, and SOL_UDP can also be used.

표 3. Common protocols

Name | Description
icmp | The Internet Control Message Protocol is used primarily by gateways and hosts to report errors in datagram communication. The "ping" command (present in most modern operating systems) is an example application of ICMP.
udp | The User Datagram Protocol is a connectionless, unreliable, protocol with fixed record lengths. Due to these aspects, UDP requires a minimum amount of protocol overhead.
tcp | The Transmission Control Protocol is a reliable, connection based, stream oriented, full duplex protocol. TCP guarantees that all data packets will be received in the order in which they were sent. If any packet is somehow lost during communication, TCP will automatically retransmit the packet until the destination host acknowledges that packet. For reliability and performance reasons, the TCP implementation itself decides the appropriate octet boundaries of the underlying datagram communication layer. Therefore, TCP applications must allow for the possibility of partial record transmission.

socket_create() Returns a socket resource on success, or FALSE on error. The actual error code can be retrieved by calling socket_last_error(). This error code may be passed to socket_strerror() to get a textual explanation of the error.

참고: If an invalid domain or type is given, socket_create() defaults to AF_INET and SOCK_STREAM respectively and additionally emits an E_WARNING message.

See also
socket_accept(),
socket_bind(),
socket_connect(),
socket_listen(),
socket_last_error(), and
socket_strerror().

이전 | 처음으로 | 다음
socket_create_pair | 위로 | socket_get_option


socket_get_option

(PHP 4 >= 4.3.0, PHP 5)

socket_get_option -- Gets socket options for the socket

Description

mixed socket_get_option ( resource socket, int level, int optname)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

The socket_get_option() function retrieves the value for the option specified by the optname parameter for the socket specified by the socket parameter. socket_get_option() will return FALSE on failure.

The level parameter specifies the protocol level at which the option resides. For example, to retrieve options at the socket level, a level parameter of SOL_SOCKET would be used. Other levels, such as TCP, can be used by specifying the protocol number of that level. Protocol numbers can be found by using the getprotobyname() function.

표 1. Available Socket Options

Option | Description
SO_DEBUG | Reports whether debugging information is being recorded.
SO_ACCEPTCONN | Reports whether socket listening is enabled.
SO_BROADCAST | Reports whether transmission of broadcast messages is supported.
SO_REUSEADDR | Reports whether local addresses can be reused.
SO_KEEPALIVE | Reports whether connections are kept active with periodic transmission of messages. If the connected socket fails to respond to these messages, the connection is broken and processes writing to that socket are notified with a SIGPIPE signal.
SO_LINGER | Reports whether the socket lingers on socket_close() if data is present.
SO_OOBINLINE | Reports whether the socket leaves out-of-band data inline.
SO_SNDBUF | Reports send buffer size information.
SO_RCVBUF | Reports recieve buffer size information.
SO_ERROR | Reports information about error status and clears it.
SO_TYPE | Reports the socket type.
SO_DONTROUTE | Reports whether outgoing messages bypass the standard routing facilities.
SO_RCVLOWAT | Reports the minimum number of bytes to process for socket input operations. ( Defaults to 1 )
SO_RCVTIMEO | Reports the timeout value for input operations.
SO_SNDLOWAT | Reports the minimum number of bytes to process for socket output operations.
SO_SNDTIMEO | Reports the timeout value specifying the amount of time that an output function blocks because flow control prevents data from being sent.

참고: This function used to be called socket_getopt() prior to PHP 4.3.0

이전 | 처음으로 | 다음
socket_create | 위로 | socket_getpeername


socket_getpeername

(PHP 4 >= 4.1.0, PHP 5)

socket_getpeername -- Queries the remote side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type.

Description

bool socket_getpeername ( resource socket, string &addr [, int &port])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

If the given socket is of type AF_INET or AF_INET6, socket_getpeername() will return the peers (remote) IP address in appropriate notation (e.g. 127.0.0.1 or fe80::1) in the address parameter and, if the optional port parameter is present, also the associated port.

If the given socket is of type AF_UNIX, socket_getpeername() will return the Unix filesystem path (e.g. /var/run/daemon.sock) in the address parameter.

참고: socket_getpeername() should not be used with AF_UNIX sockets created with socket_accept(). Only sockets created with socket_connect() or a primary server socket following a call to socket_bind() will return meaningful values.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. socket_getpeername() may also return FALSE if the socket type is not any of AF_INET, AF_INET6, or AF_UNIX, in which case the last socket error code is not updated.

See also
socket_getsockname(),
socket_last_error() and
socket_strerror().

이전 | 처음으로 | 다음
socket_get_option | 위로 | socket_getsockname


socket_getsockname

(PHP 4 >= 4.1.0, PHP 5)

socket_getsockname -- Queries the local side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type.

Description

bool socket_getsockname ( resource socket, string &addr [, int &port])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

If the given socket is of type AF_INET or AF_INET6, socket_getsockname() will return the local IP address in appropriate notation (e.g. 127.0.0.1 or fe80::1) in the address parameter and, if the optional port parameter is present, also the associated port.

If the given socket is of type AF_UNIX, socket_getsockname() will return the Unix filesystem path (e.g. /var/run/daemon.sock) in the address parameter.

참고: socket_getsockname() should not be used with AF_UNIX sockets created with socket_connect(). Only sockets created with socket_accept() or a primary server socket following a call to socket_bind() will return meaningful values.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. socket_getsockname() may also return FALSE if the socket type is not any of AF_INET, AF_INET6, or AF_UNIX, in which case the last socket error code is not updated.

See also
socket_getpeername(),
socket_last_error() and
socket_strerror().

이전 | 처음으로 | 다음
socket_getpeername | 위로 | socket_iovec_add


socket_iovec_add

(PHP 4 >= 4.1.0)

socket_iovec_add -- Adds a new vector to the scatter/gather array

Description

bool socket_iovec_add ( resource iovec, int iov_len)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
socket_getsockname | 위로 | socket_iovec_alloc


socket_iovec_alloc

(PHP 4 >= 4.1.0)

socket_iovec_alloc -- Builds a 'struct iovec' for use with sendmsg, recvmsg, writev, and readv

Description

resource socket_iovec_alloc ( int num_vectors [, int ])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
socket_iovec_add | 위로 | socket_iovec_delete


socket_iovec_delete

(PHP 4 >= 4.1.0)

socket_iovec_delete -- Deletes a vector from an array of vectors

Description

bool socket_iovec_delete ( resource iovec, int iov_pos)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
socket_iovec_alloc | 위로 | socket_iovec_fetch


socket_iovec_fetch

(PHP 4 >= 4.1.0)

socket_iovec_fetch -- Returns the data held in the iovec specified by iovec_id[iovec_position]

Description

string socket_iovec_fetch ( resource iovec, int iovec_position)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
socket_iovec_delete | 위로 | socket_iovec_free


socket_iovec_free

(PHP 4 >= 4.1.0)

socket_iovec_free -- Frees the iovec specified by iovec_id

Description

bool socket_iovec_free ( resource iovec)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
socket_iovec_fetch | 위로 | socket_iovec_set


socket_iovec_set

(PHP 4 >= 4.1.0)

socket_iovec_set -- Sets the data held in iovec_id[iovec_position] to new_val

Description

bool socket_iovec_set ( resource iovec, int iovec_position, string new_val)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
socket_iovec_free | 위로 | socket_last_error


socket_last_error

(PHP 4 >= 4.1.0, PHP 5)

socket_last_error -- Returns the last error on the socket

Description

int socket_last_error ( [resource socket])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

This function returns a socket error code.

If a socket resource is passed to this function, the last error which occurred on this particular socket is returned. If the socket resource is omitted, the error code of the last failed socket function is returned. The latter is in particular helpful for functions like socket_create() which don't return a socket on failure and socket_select() which can fail for reasons not directly tied to a particular socket. The error code is suitable to be fed to socket_strerror() which returns a string describing the given error code.
<?php
if (false == ($socket = @socket_create(AF_INET, SOCK_STREAM, SOL_TCP))) {
    die("Couldn't create socket, error code is: " . socket_last_error() .
        ",error message is: " . socket_strerror(socket_last_error()));
}
?>

참고: socket_last_error() does not clear the error code, use socket_clear_error() for this purpose.

이전 | 처음으로 | 다음
socket_iovec_set | 위로 | socket_listen


socket_listen

(PHP 4 >= 4.1.0, PHP 5)

socket_listen -- Listens for a connection on a socket

Description

bool socket_listen ( resource socket [, int backlog])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

After the socket socket has been created using socket_create() and bound to a name with socket_bind(), it may be told to listen for incoming connections on socket.

A maximum of backlog incoming connections will be queued for processing. If a connection request arrives with the queue full the client may receive an error with an indication of ECONNREFUSED, or, if the underlying protocol supports retransmission, the request may be ignored so that retries may succeed.

참고: The maximum number passed to the backlog parameter highly depends on the underlying platform. On Linux, it is silently truncated to SOMAXCONN. On win32, if passed SOMAXCONN, the underlying service provider responsible for the socket will set the backlog to a maximum reasonable value. There is no standard provision to find out the actual backlog value on this platform.

socket_listen() is applicable only to sockets of type SOCK_STREAM or SOCK_SEQPACKET.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. The error code can be retrieved with socket_last_error(). This code may be passed to socket_strerror() to get a textual explanation of the error.

See also
socket_accept(),
socket_bind(),
socket_connect(),
socket_create() and
socket_strerror().

이전 | 처음으로 | 다음
socket_last_error | 위로 | socket_read


socket_read

(PHP 4 >= 4.1.0, PHP 5)

socket_read -- Reads a maximum of length bytes from a socket

Description

string socket_read ( resource socket, int length [, int type])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

The function socket_read() reads from the socket resource socket created by the socket_create() or socket_accept() functions. The maximum number of bytes read is specified by the length parameter. Otherwise you can use \r, \n, or \0 to end reading (depending on the type parameter, see below).

socket_read() returns the data as a string on success, or FALSE on error. The error code can be retrieved with socket_last_error(). This code may be passed to socket_strerror() to get a textual representation of the error.

참고: socket_read() may return a zero length string ("") indicating the end of communication (i.e. the remote end point has closed the connection).

Optional type parameter is a named constant:

  • PHP_BINARY_READ - use the system read() function. Safe for reading binary data. (Default in PHP >= 4.1.0)

  • PHP_NORMAL_READ - reading stops at \n or \r. (Default in PHP <= 4.0.6)

See also
socket_accept(),
socket_bind(),
socket_connect(),
socket_listen(),
socket_last_error(),
socket_strerror() and
socket_write().

이전 | 처음으로 | 다음
socket_listen | 위로 | socket_readv


socket_readv

(PHP 4 >= 4.1.0)

socket_readv -- Reads from an fd, using the scatter-gather array defined by iovec_id

Description

bool socket_readv ( resource socket, resource iovec_id)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
socket_read | 위로 | socket_recv


socket_recv

(PHP 4 >= 4.1.0, PHP 5)

socket_recv -- Receives data from a connected socket

Description

int socket_recv ( resource socket, string &buf, int len, int flags)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
socket_readv | 위로 | socket_recvfrom


socket_recvfrom

(PHP 4 >= 4.1.0, PHP 5)

socket_recvfrom -- Receives data from a socket, connected or not

Description

int socket_recvfrom ( resource socket, string &buf, int len, int flags, string &name [, int &port])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
socket_recv | 위로 | socket_recvmsg


socket_recvmsg

(PHP 4 >= 4.1.0)

socket_recvmsg -- Used to receive messages on a socket, whether connection-oriented or not

Description

bool socket_recvmsg ( resource socket, resource iovec, array &control, int &controllen, int &flags, string &addr [, int &port])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
socket_recvfrom | 위로 | socket_select


socket_select

(PHP 4 >= 4.1.0, PHP 5)

socket_select -- Runs the select() system call on the given arrays of sockets with a specified timeout

Description

int socket_select ( array &read, array &write, array &except, int tv_sec [, int tv_usec])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

socket_select() accepts arrays of sockets and waits for them to change status. Those coming with BSD sockets background will recognize that those socket resource arrays are in fact the so-called file descriptor sets. Three independent arrays of socket resources are watched.

The sockets listed in the read array will be watched to see if characters become available for reading (more precisely, to see if a read will not block - in particular, a socket resource is also ready on end-of-file, in which case a socket_read() will return a zero length string).

The sockets listed in the write array will be watched to see if a write will not block.

The sockets listed in the except array will be watched for exceptions.

주의

On exit, the arrays are modified to indicate which socket resource actually changed status.

You do not need to pass every array to socket_select(). You can leave it out and use an empty array or NULL instead. Also do not forget that those arrays are passed by reference and will be modified after socket_select() returns.

예 1. socket_select() example

<?php
/* Prepare the read array */
$read = array($socket1, $socket2);

$num_changed_sockets = socket_select($read, $write = NULL, $except = NULL, 0);

if ($num_changed_sockets === false) {
    /* Error handling */
} else if ($num_changed_sockets > 0) {
    /* At least at one of the sockets something interesting happened */
}
?>

참고: Due a limitation in the current Zend Engine it is not possible to pass a constant modifier like NULL directly as a parameter to a function which expects this parameter to be passed by reference. Instead use a temporary variable or an expression with the leftmost member being a temporary variable:

예 2. Using NULL with socket_select()

<?php
socket_select($r, $w, $e = NULL, 0);
?>

The tv_sec and tv_usec together form the timeout parameter. The timeout is an upper bound on the amount of time elapsed before socket_select() return. tv_sec may be zero , causing socket_select() to return immediately. This is useful for polling. If tv_sec is NULL (no timeout), socket_select() can block indefinitely.

On success socket_select() returns the number of socket resources contained in the modified arrays, which may be zero if the timeout expires before anything interesting happens. On error FALSE is returned. The error code can be retrieved with socket_last_error().

참고: Be sure to use the === operator when checking for an error. Since the socket_select() may return 0 the comparison with == would evaluate to TRUE:

예 3. Understanding socket_select()'s result

<?php
if (false === socket_select($r, $w, $e = NULL, 0)) {
    echo "socket_select() failed, reason: " .
        socket_strerror(socket_last_error()) . "\n";
}
?>

참고: Be aware that some socket implementations need to be handled very carefully. A few basic rules:

  • You should always try to use socket_select() without timeout. Your program should have nothing to do if there is no data available. Code that depends on timeouts is not usually portable and difficult to debug.

  • No socket resource must be added to any set if you do not intend to check its result after the socket_select() call, and respond appropriately. After socket_select() returns, all socket resources in all arrays must be checked. Any socket resource that is available for writing must be written to, and any socket resource available for reading must be read from.

  • If you read/write to a socket returns in the arrays be aware that they do not necessarily read/write the full amount of data you have requested. Be prepared to even only be able to read/write a single byte.

  • It's common to most socket implementations that the only exception caught with the except array is out-of-bound data received on a socket.

See also
socket_read(),
socket_write(),
socket_last_error() and
socket_strerror().

이전 | 처음으로 | 다음
socket_recvmsg | 위로 | socket_send


socket_send

(PHP 4 >= 4.1.0, PHP 5)

socket_send -- Sends data to a connected socket

Description

int socket_send ( resource socket, string buf, int len, int flags)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

The function socket_send() sends len bytes to the socket socket from buf

The value of flags can be any ORed combination of the following:

표 1. possible values for flags

0x1 | Process OOB (out-of-band) data
0x2 | Peek at incoming message
0x4 | Bypass routing, use direct interface
0x8 | Data completes record
0x100 | Data completes transaction

See also socket_sendmsg() and socket_sendto().

이전 | 처음으로 | 다음
socket_select | 위로 | socket_sendmsg


socket_sendmsg

(PHP 4 >= 4.1.0)

socket_sendmsg -- Sends a message to a socket, regardless of whether it is connection-oriented or not

Description

bool socket_sendmsg ( resource socket, resource iovec, int flags, string addr [, int port])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
socket_send | 위로 | socket_sendto


socket_sendto

(PHP 4 >= 4.1.0, PHP 5)

socket_sendto -- Sends a message to a socket, whether it is connected or not

Description

int socket_sendto ( resource socket, string buf, int len, int flags, string addr [, int port])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

The function socket_sendto() sends len bytes from buf through the socket socket to the port at the address addr

The value of flags can be one of the following:

표 1. possible values for flags

0x1 | Process OOB (out-of-band) data.
0x2 | Peek at incoming message.
0x4 | Bypass routing, use direct interface.
0x8 | Data completes record.
0x100 | Data completes transaction.

예 1. socket_sendto() Example

<?php
    $sh = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
    if (socket_bind($sh, '127.0.0.1', 4242)) {
        echo "Socket bound correctly";
    }
    $buf = 'Test Message';
    $len = strlen($buf);
    if (socket_sendto($sh, $buf, $len, 0x100, '192.168.0.2', 4242) !== false) {
        echo "Message sent correctly";
    }
    socket_close($sh);
?>

See also socket_send() and socket_sendmsg().

이전 | 처음으로 | 다음
socket_sendmsg | 위로 | socket_set_block


socket_set_block

(PHP 4 >= 4.2.0, PHP 5)

socket_set_block -- Sets blocking mode on a socket resource

Description

bool socket_set_block ( resource socket)

The socket_set_block() function removes the O_NONBLOCK flag on the socket specified by the socket parameter.

예 1. socket_set_block() example

<?php

$port = 9090;
if (!$socket = socket_create_listen($port)) {
    echo socket_strerror(socket_last_error());
}

if (!socket_set_option($socket, SOL_SOCKET, SO_REUSEADDR, 1)) {
    echo socket_strerror(socket_last_error());
}

if (!socket_set_nonblock($socket)) { // $socket is now nonblocking
    echo socket_strerror(socket_last_error());
}

if (!socket_set_block($socket)) {     // $socket is now blocking
    echo socket_strerror(socket_last_error());
}

?>

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also socket_set_nonblock() and socket_set_option()

이전 | 처음으로 | 다음
socket_sendto | 위로 | socket_set_nonblock


socket_set_nonblock

(PHP 4 >= 4.1.0, PHP 5)

socket_set_nonblock -- Sets nonblocking mode for file descriptor fd

Description

bool socket_set_nonblock ( resource socket)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

The socket_set_nonblock() function sets the O_NONBLOCK flag on the socket specified by the socket parameter.

예 1. socket_set_nonblock() example

<?php
$port = 9090;
if (!$socket = socket_create_listen($port)) {
    echo socket_strerror(socket_last_error());
}

if (!socket_set_option($socket, SOL_SOCKET, SO_REUSEADDR, 1)) {
    echo socket_strerror(socket_last_error());
}

if (!socket_set_nonblock($socket)) {
    echo socket_strerror(socket_last_error());
}
?>

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also socket_set_block() and socket_set_option()

이전 | 처음으로 | 다음
socket_set_block | 위로 | socket_set_option


socket_set_option

(PHP 4 >= 4.3.0, PHP 5)

socket_set_option -- Sets socket options for the socket

Description

bool socket_set_option ( resource socket, int level, int optname, mixed optval)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

The socket_set_option() function sets the option specified by the optname parameter, at the protocol level specified by the level parameter, to the value pointed to by the optval parameter for the socket specified by the socket parameter. socket_set_option() will return FALSE on failure.

The level parameter specifies the protocol level at which the option resides. For example, to retrieve options at the socket level, a level parameter of SOL_SOCKET would be used. Other levels, such as TCP, can be used by specifying the protocol number of that level. Protocol numbers can be found by using the getprotobyname() function.

The available socket options are the same as those for the socket_get_option() function.

참고: This function used to be called socket_setopt() prior to PHP 4.3.0

이전 | 처음으로 | 다음
socket_set_nonblock | 위로 | socket_shutdown


socket_shutdown

(PHP 4 >= 4.1.0, PHP 5)

socket_shutdown -- Shuts down a socket for receiving, sending, or both.

Description

bool socket_shutdown ( resource socket [, int how])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

The socket_shutdown() function allows you to stop incoming, outgoing or all data (the default) from being sent through the socket

The value of how can be one of the following:

표 1. possible values for how

0 | Shutdown socket reading
1 | Shutdown socket writing
2 | Shutdown socket reading and writing

이전 | 처음으로 | 다음
socket_set_option | 위로 | socket_strerror


socket_strerror

(PHP 4 >= 4.1.0, PHP 5)

socket_strerror -- Return a string describing a socket error

Description

string socket_strerror ( int errno)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

socket_strerror() takes as its errno parameter a socket error code as returned by socket_last_error() and returns the corresponding explanatory text. This makes it a bit more pleasant to figure out why something didn't work; for instance, instead of having to track down a system include file to find out what '-111' means, you just pass it to socket_strerror(), and it tells you what happened.

예 1. socket_strerror() example

<?php
if (false == ($socket = @socket_create(AF_INET, SOCK_STREAM, SOL_TCP))) {
   echo "socket_create() failed: reason: " . socket_strerror(socket_last_error()) . "\n";
}

if (false == (@socket_bind($socket, '127.0.0.1', 80))) {
   echo "socket_bind() failed: reason: " . socket_strerror(socket_last_error($socket)) . "\n";
}
?>

The expected output from the above example (assuming the script is not run with root privileges):
socket_bind() failed: reason: Permission denied

See also
socket_accept(),
socket_bind(),
socket_connect(),
socket_listen(), and
socket_create().

이전 | 처음으로 | 다음
socket_shutdown | 위로 | socket_write


socket_write

(PHP 4 >= 4.1.0, PHP 5)

socket_write -- Write to a socket

Description

int socket_write ( resource socket, string buffer [, int length])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

The function socket_write() writes to the socket socket from buffer.

The optional parameter length can specify an alternate length of bytes written to the socket. If this length is greater then the buffer length, it is silently truncated to the length of the buffer.

Returns the number of bytes successfully written to the socket or FALSE one error. The error code can be retrieved with socket_last_error(). This code may be passed to socket_strerror() to get a textual explanation of the error.

참고: socket_write() does not necessarily write all bytes from the given buffer. It's valid that, depending on the network buffers etc., only a certain amount of data, even one byte, is written though your buffer is greater. You have to watch out so you don't unintentionally forget to transmit the rest of your data.

참고: It is perfectly valid for socket_write() to return zero which means no bytes have been written. Be sure to use the === operator to check for FALSE in case of an error.

See also
socket_accept(),
socket_bind(),
socket_connect(),
socket_listen(),
socket_read() and
socket_strerror().

이전 | 처음으로 | 다음
socket_strerror | 위로 | socket_writev


socket_writev

(PHP 4 >= 4.1.0)

socket_writev -- Writes to a file descriptor, fd, using the scatter-gather array defined by iovec_id

Description

bool socket_writev ( resource socket, resource iovec_id)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
socket_write | 위로 | Standard PHP Library (SPL) Functions


Standard PHP Library (SPL) Functions

PHP 매뉴얼
이전 다음

CIV. Standard PHP Library (SPL) Functions

소개

SPL is a collection of interfaces and classes that are meant to solve standard problems.

설치

This extension is available and compiled by default in PHP 5.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

RIT_LEAVES_ONLY (integer)

RIT_SELF_FIRST (integer)

RIT_CHILD_FIRST (integer)

CIT_CALL_TOSTRING (integer)

CIT_CATCH_GET_CHILD (integer)

차례
ArrayIterator::current -- Return current array entry
ArrayIterator::key -- Return current array key
ArrayIterator::next -- Move to next entry
ArrayIterator::rewind -- Rewind array back to the start
ArrayIterator::valid -- Check whether array contains more entries
ArrayObject::__construct -- Construct a new array object
ArrayObject::getIterator -- Create a new iterator from an ArrayObject instance
DirectoryIterator::__construct -- Constructs a new dir iterator from a path.
DirectoryIterator::current -- Return this (needed for Iterator interface)
DirectoryIterator::fileATime -- Get last access time of file
DirectoryIterator::fileCTime -- Get inode modification time of file
DirectoryIterator::fileGroup -- Get file group
DirectoryIterator::fileInode -- Get file inode
DirectoryIterator::fileMTime -- Get last modification time of file
DirectoryIterator::fileOwner -- Get file owner
DirectoryIterator::filePerms -- Get file permissions
DirectoryIterator::fileSize -- Get file size
DirectoryIterator::fileType -- Get file type
DirectoryIterator::getFilename -- Return filename of current dir entry
DirectoryIterator::getPath -- Return directory path
DirectoryIterator::getPathname -- Return path and filename of current dir entry
DirectoryIterator::hasMore -- Check whether dir contains more entries
DirectoryIterator::isDir -- Returns true if file is directory
DirectoryIterator::isDot -- Returns true if current entry is '.' or '..'
DirectoryIterator::isExecutable -- Returns true if file is executable
DirectoryIterator::isFile -- Returns true if file is a regular file
DirectoryIterator::isLink -- Returns true if file is symbolic link
DirectoryIterator::isReadable -- Returns true if file can be read
DirectoryIterator::isWritable -- Returns true if file can be written
DirectoryIterator::key -- Return current dir entry
DirectoryIterator::next -- Move to next entry
DirectoryIterator::rewind -- Rewind dir back to the start
RecursiveDirectoryIterator::getChildren -- Returns an iterator for the current entry if it is a directory
RecursiveDirectoryIterator::hasChildren -- Returns whether current entry is a directory and not '.' or '..'
RecursiveDirectoryIterator::key -- Return path and filename of current dir entry
RecursiveDirectoryIterator::next -- Move to next entry
RecursiveDirectoryIterator::rewind -- Rewind dir back to the start
SimpleXMLIterator::current -- Return current SimpleXML entry
SimpleXMLIterator::getChildren -- Returns an iterator for the current entry if it is a SimpleXML object
SimpleXMLIterator::hasChildren -- Returns whether current entry is a SimpleXML object
SimpleXMLIterator::key -- Return current SimpleXML key
SimpleXMLIterator::next -- Move to next entry
SimpleXMLIterator::rewind -- Rewind SimpleXML back to the start
SimpleXMLIterator::valid -- Check whether SimpleXML contains more entries

이전 | 처음으로 | 다음
socket_writev | 위로 | ArrayIterator::current


ArrayIterator::current

(no version information, might be only in CVS)

ArrayIterator::current -- Return current array entry

Description

mixed ArrayIterator::current ( void )

This function returns the current array entry

예 1. ArrayIterator::current() example

<?php
$array = array('1' => 'one',
               '2' => 'two',
               '3' => 'three');

$arrayobject = new ArrayObject($array);
$iterator = $arrayobject->getIterator();

for($iterator = $arrayobject->getIterator();
    $iterator->valid();
    $iterator->next()) {

    echo $iterator->key() . ' => ' . $iterator->current() . "\n";
}
?>

The above example will output:

1 => one
2 => two
3 => three

이전 | 처음으로 | 다음
Standard PHP Library (SPL) Functions | 위로 | ArrayIterator::key


ArrayIterator::key

(no version information, might be only in CVS)

ArrayIterator::key -- Return current array key

Description

mixed ArrayIterator::key ( void )

This function returns the current array key

예 1. ArrayIterator::key() example

<?php
$array = array('key' => 'value');

$arrayobject = new ArrayObject($array);
$iterator = $arrayobject->getIterator();

echo $iterator->key(); //key
?>

이전 | 처음으로 | 다음
ArrayIterator::current | 위로 | ArrayIterator::next


ArrayIterator::next

(no version information, might be only in CVS)

ArrayIterator::next -- Move to next entry

Description

void ArrayIterator::next ( void )

This function moves the iterator to the next entry.

예 1. ArrayIterator::next() example

<?php
$arrayobject = new ArrayObject();

$arrayobject[] = 'zero';
$arrayobject[] = 'one';

$iterator = $arrayobject->getIterator();

while($iterator->valid()) {
    echo $iterator->key() . ' => ' . $iterator->current() . "\n";

    $iterator->next();
}
?>

The above example will output:

0 => zero
1 => one

이전 | 처음으로 | 다음
ArrayIterator::key | 위로 | ArrayIterator::rewind


ArrayIterator::rewind

(no version information, might be only in CVS)

ArrayIterator::rewind -- Rewind array back to the start

Description

void ArrayIterator::rewind ( void )

This function rewinds the iterator to the begining.

예 1. ArrayObject::rewind() example

<?php
$arrayobject = new ArrayObject();

$arrayobject[] = 'zero';
$arrayobject[] = 'one';
$arrayobject[] = 'two';

$iterator = $arrayobject->getIterator();

$iterator->next();
echo $iterator->key(); //1

$iterator->rewind(); //rewinding to the begining
echo $iterator->key(); //0
?>

이전 | 처음으로 | 다음
ArrayIterator::next | 위로 | ArrayIterator::valid


ArrayIterator::valid

(no version information, might be only in CVS)

ArrayIterator::valid -- Check whether array contains more entries

Description

bool ArrayIterator::valid ( void )

This function checks if the array contains any more entries.

예 1. ArrayIterator::valid() example

<?php
$array = array('1' => 'one');

$arrayobject = new ArrayObject($array);
$iterator = $arrayobject->getIterator();

var_dump($iterator->valid()); //bool(true)

$iterator->next(); // advance to the next item

//bool(false) because there is only one array element
var_dump($iterator->valid());
?>

이전 | 처음으로 | 다음
ArrayIterator::rewind | 위로 | ArrayObject::__construct


ArrayObject::__construct

(no version information, might be only in CVS)

ArrayObject::__construct -- Construct a new array object

Description

void ArrayObject::__construct ( mixed input)

This constructs a new array object. The input parameter accepts an array or another ArrayObject.

예 1. ArrayObject::__construct() example

<?php
$array = array('1' => 'one',
               '2' => 'two',
               '3' => 'three');

$arrayobject = new ArrayObject($array);

var_dump($arrayobject);
?>

The above example will output:

object(ArrayObject)#1 (3) {
  [1]=>
  string(3) "one"
  [2]=>
  string(3) "two"
  [3]=>
  string(5) "three"
}

이전 | 처음으로 | 다음
ArrayIterator::valid | 위로 | ArrayObject::getIterator


ArrayObject::getIterator

(no version information, might be only in CVS)

ArrayObject::getIterator -- Create a new iterator from an ArrayObject instance

Description

ArrayIterator ArrayObject::getIterator ( void )

This function will return an iterator from an ArrayObject.

예 1. ArrayObject::getIterator() example

<?php
$array = array('1' => 'one',
               '2' => 'two',
               '3' => 'three');

$arrayobject = new ArrayObject($array);

$iterator = $arrayobject->getIterator();

while($iterator->valid()) {
    echo $iterator->key() . ' => ' . $iterator->current() . "\n";

    $iterator->next();
}
?>

The above example will output:

1 => one
2 => two
3 => three

이전 | 처음으로 | 다음
ArrayObject::__construct | 위로 | DirectoryIterator::__construct


DirectoryIterator::__construct

(no version information, might be only in CVS)

DirectoryIterator::__construct -- Constructs a new dir iterator from a path.

Description

void DirectoryIterator::__construct ( string path)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ArrayObject::getIterator | 위로 | DirectoryIterator::current


DirectoryIterator::current

(no version information, might be only in CVS)

DirectoryIterator::current -- Return this (needed for Iterator interface)

Description

DirectoryIterator DirectoryIterator::current ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::__construct | 위로 | DirectoryIterator::fileATime


DirectoryIterator::fileATime

(no version information, might be only in CVS)

DirectoryIterator::fileATime -- Get last access time of file

Description

int DirectoryIterator::fileATime ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::current | 위로 | DirectoryIterator::fileCTime


DirectoryIterator::fileCTime

(no version information, might be only in CVS)

DirectoryIterator::fileCTime -- Get inode modification time of file

Description

int DirectoryIterator::fileCTime ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::fileATime | 위로 | DirectoryIterator::fileGroup


DirectoryIterator::fileGroup

(no version information, might be only in CVS)

DirectoryIterator::fileGroup -- Get file group

Description

int DirectoryIterator::fileGroup ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::fileCTime | 위로 | DirectoryIterator::fileInode


DirectoryIterator::fileInode

(no version information, might be only in CVS)

DirectoryIterator::fileInode -- Get file inode

Description

int DirectoryIterator::fileInode ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::fileGroup | 위로 | DirectoryIterator::fileMTime


DirectoryIterator::fileMTime

(no version information, might be only in CVS)

DirectoryIterator::fileMTime -- Get last modification time of file

Description

int DirectoryIterator::fileMTime ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::fileInode | 위로 | DirectoryIterator::fileOwner


DirectoryIterator::fileOwner

(no version information, might be only in CVS)

DirectoryIterator::fileOwner -- Get file owner

Description

int DirectoryIterator::fileOwner ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::fileMTime | 위로 | DirectoryIterator::filePerms


DirectoryIterator::filePerms

(no version information, might be only in CVS)

DirectoryIterator::filePerms -- Get file permissions

Description

int DirectoryIterator::filePerms ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::fileOwner | 위로 | DirectoryIterator::fileSize


DirectoryIterator::fileSize

(no version information, might be only in CVS)

DirectoryIterator::fileSize -- Get file size

Description

int DirectoryIterator::fileSize ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::filePerms | 위로 | DirectoryIterator::fileType


DirectoryIterator::fileType

(no version information, might be only in CVS)

DirectoryIterator::fileType -- Get file type

Description

string DirectoryIterator::fileType ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::fileSize | 위로 | DirectoryIterator::getFilename


DirectoryIterator::getFilename

(no version information, might be only in CVS)

DirectoryIterator::getFilename -- Return filename of current dir entry

Description

string DirectoryIterator::getFilename ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::fileType | 위로 | DirectoryIterator::getPath


DirectoryIterator::getPath

(no version information, might be only in CVS)

DirectoryIterator::getPath -- Return directory path

Description

string DirectoryIterator::getPath ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::getFilename | 위로 | DirectoryIterator::getPathname


DirectoryIterator::getPathname

(no version information, might be only in CVS)

DirectoryIterator::getPathname -- Return path and filename of current dir entry

Description

string DirectoryIterator::getPathname ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::getPath | 위로 | DirectoryIterator::hasMore


DirectoryIterator::hasMore

(no version information, might be only in CVS)

DirectoryIterator::hasMore -- Check whether dir contains more entries

Description

string DirectoryIterator::hasMore ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::getPathname | 위로 | DirectoryIterator::isDir


DirectoryIterator::isDir

(no version information, might be only in CVS)

DirectoryIterator::isDir -- Returns true if file is directory

Description

bool DirectoryIterator::isDir ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::hasMore | 위로 | DirectoryIterator::isDot


DirectoryIterator::isDot

(no version information, might be only in CVS)

DirectoryIterator::isDot -- Returns true if current entry is '.' or '..'

Description

bool DirectoryIterator::isDot ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::isDir | 위로 | DirectoryIterator::isExecutable


DirectoryIterator::isExecutable

(no version information, might be only in CVS)

DirectoryIterator::isExecutable -- Returns true if file is executable

Description

bool DirectoryIterator::isExecutable ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::isDot | 위로 | DirectoryIterator::isFile


DirectoryIterator::isFile

(no version information, might be only in CVS)

DirectoryIterator::isFile -- Returns true if file is a regular file

Description

bool DirectoryIterator::isFile ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::isExecutable | 위로 | DirectoryIterator::isLink


DirectoryIterator::isLink

(no version information, might be only in CVS)

DirectoryIterator::isLink -- Returns true if file is symbolic link

Description

bool DirectoryIterator::isLink ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::isFile | 위로 | DirectoryIterator::isReadable


DirectoryIterator::isReadable

(no version information, might be only in CVS)

DirectoryIterator::isReadable -- Returns true if file can be read

Description

bool DirectoryIterator::isReadable ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::isLink | 위로 | DirectoryIterator::isWritable


DirectoryIterator::isWritable

(no version information, might be only in CVS)

DirectoryIterator::isWritable -- Returns true if file can be written

Description

bool DirectoryIterator::isWritable ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::isReadable | 위로 | DirectoryIterator::key


DirectoryIterator::key

(no version information, might be only in CVS)

DirectoryIterator::key -- Return current dir entry

Description

string DirectoryIterator::key ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::isWritable | 위로 | DirectoryIterator::next


DirectoryIterator::next

(no version information, might be only in CVS)

DirectoryIterator::next -- Move to next entry

Description

void DirectoryIterator::next ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::key | 위로 | DirectoryIterator::rewind


DirectoryIterator::rewind

(no version information, might be only in CVS)

DirectoryIterator::rewind -- Rewind dir back to the start

Description

void DirectoryIterator::rewind ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::next | 위로 | RecursiveDirectoryIterator::getChildren


RecursiveDirectoryIterator::getChildren

(no version information, might be only in CVS)

RecursiveDirectoryIterator::getChildren -- Returns an iterator for the current entry if it is a directory

Description

object RecursiveDirectoryIterator::getChildren ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
DirectoryIterator::rewind | 위로 | RecursiveDirectoryIterator::hasChildren


RecursiveDirectoryIterator::hasChildren

(no version information, might be only in CVS)

RecursiveDirectoryIterator::hasChildren -- Returns whether current entry is a directory and not '.' or '..'

Description

bool RecursiveDirectoryIterator::hasChildren ( [bool $allow_links [, = false]])

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
RecursiveDirectoryIterator::getChildren | 위로 | RecursiveDirectoryIterator::key


RecursiveDirectoryIterator::key

(no version information, might be only in CVS)

RecursiveDirectoryIterator::key -- Return path and filename of current dir entry

Description

string RecursiveDirectoryIterator::key ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
RecursiveDirectoryIterator::hasChildren | 위로 | RecursiveDirectoryIterator::next


RecursiveDirectoryIterator::next

(no version information, might be only in CVS)

RecursiveDirectoryIterator::next -- Move to next entry

Description

void RecursiveDirectoryIterator::next ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
RecursiveDirectoryIterator::key | 위로 | RecursiveDirectoryIterator::rewind


RecursiveDirectoryIterator::rewind

(no version information, might be only in CVS)

RecursiveDirectoryIterator::rewind -- Rewind dir back to the start

Description

void RecursiveDirectoryIterator::rewind ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
RecursiveDirectoryIterator::next | 위로 | SimpleXMLIterator::current


SimpleXMLIterator::current

(no version information, might be only in CVS)

SimpleXMLIterator::current -- Return current SimpleXML entry

Description

mixed SimpleXMLIterator::current ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
RecursiveDirectoryIterator::rewind | 위로 | SimpleXMLIterator::getChildren


SimpleXMLIterator::getChildren

(no version information, might be only in CVS)

SimpleXMLIterator::getChildren -- Returns an iterator for the current entry if it is a SimpleXML object

Description

object SimpleXMLIterator::getChildren ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
SimpleXMLIterator::current | 위로 | SimpleXMLIterator::hasChildren


SimpleXMLIterator::hasChildren

(no version information, might be only in CVS)

SimpleXMLIterator::hasChildren -- Returns whether current entry is a SimpleXML object

Description

bool SimpleXMLIterator::hasChildren ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
SimpleXMLIterator::getChildren | 위로 | SimpleXMLIterator::key


SimpleXMLIterator::key

(no version information, might be only in CVS)

SimpleXMLIterator::key -- Return current SimpleXML key

Description

mixed SimpleXMLIterator::key ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
SimpleXMLIterator::hasChildren | 위로 | SimpleXMLIterator::next


SimpleXMLIterator::next

(no version information, might be only in CVS)

SimpleXMLIterator::next -- Move to next entry

Description

void SimpleXMLIterator::next ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
SimpleXMLIterator::key | 위로 | SimpleXMLIterator::rewind


SimpleXMLIterator::rewind

(no version information, might be only in CVS)

SimpleXMLIterator::rewind -- Rewind SimpleXML back to the start

Description

void SimpleXMLIterator::rewind ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
SimpleXMLIterator::next | 위로 | SimpleXMLIterator::valid


SimpleXMLIterator::valid

(no version information, might be only in CVS)

SimpleXMLIterator::valid -- Check whether SimpleXML contains more entries

Description

bool SimpleXMLIterator::valid ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
SimpleXMLIterator::rewind | 위로 | Stream Functions


Stream Functions

PHP 매뉴얼
이전 다음

CV. Stream Functions

소개

Streams were introduced with PHP 4.3.0 as a way of generalizing file, network, data compression, and other operations which share a common set of functions and uses. In its simplest definition, a stream is a resource object which exhibits streamable behavior. That is, it can be read from or written to in a linear fashion, and may be able to fseek() to an arbitrary locations within the stream.

A wrapper is additional code which tells the stream how to handle specific protocols/encodings. For example, the http wrapper knows how to translate a URL into an HTTP/1.0 request for a file on a remote server. There are many wrappers built into PHP by default (See 부록 J), and additional, custom wrappers may be added either within a PHP script using stream_wrapper_register(), or directly from an extension using the API Reference in 43장. Because any variety of wrapper may be added to PHP, there is no set limit on what can be done with them. To access the list of currently registered wrappers, use stream_get_wrappers().

A stream is referenced as: scheme://target

  • scheme(string) - The name of the wrapper to be used. Examples include: file, http, https, ftp, ftps, compress.zlib, compress.bz2, and php. See 부록 J for a list of PHP builtin wrappers. If no wrapper is specified, the function default is used (typically file://).

  • target - Depends on the wrapper used. For filesystem related streams this is typically a path and filename of the desired file. For network related streams this is typically a hostname, often with a path appended. Again, see 부록 J for a description of targets for builtin streams.

Stream Filters

A filter is a final piece of code which may perform operations on data as it is being read from or written to a stream. Any number of filters may be stacked onto a stream. Custom filters can be defined in a PHP script using stream_filter_register() or in an extension using the API Reference in 43장. To access the list of currently registered filters, use stream_get_filters().

Stream Contexts

A context is a set of parameters and wrapper specific options which modify or enhance the behavior of a stream. Contexts are created using stream_context_create() and can be passed to most filesystem related stream creation functions (i.e. fopen(), file(), file_get_contents(), etc...).

Options can be specified when calling stream_context_create(), or later using stream_context_set_option(). A list of wrapper specific options can be found with the list of built-in wrappers (See 부록 J).

In addition, parameters may be set on a context using stream_context_set_params(). Currently the only context parameter supported by PHP is notification. The value of this parameter must be the name of a function to be called when an event occurs on a stream. The notification function called during an event should accept the following six parameters:

void my_notifier ( int notification_code, int severity, string message, int message_code, int bytes_transferred, int bytes_max)

notification_code and severity are numerical values which correspond to the STREAM_NOTIFY_* constants listed below. If a descriptive message is available from the stream, message and message_code will be populated with the appropriate values. The meaning of these values is dependent on the specific wrapper in use. bytes_transferred and bytes_max will be populated when applicable.

설치

Streams are an integral part of PHP as of version 4.3.0. No steps are required to enable them.

Stream Classes

User designed wrappers can be registered via stream_wrapper_register(), using the class definition shown on that manual page.

class php_user_filter is predefined and is an abstract baseclass for use with user defined filters. See the manual page for stream_filter_register() for details on implementing user defined filters.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

Constant | Description
STREAM_FILTER_READ | Used with stream_filter_append() and stream_filter_prepend() to indicate that the specified filter should only be applied when reading
STREAM_FILTER_WRITE | Used with stream_filter_append() and stream_filter_prepend() to indicate that the specified filter should only be applied when writing
STREAM_FILTER_ALL | This constant is equivalent to STREAM_FILTER_READ | STREAM_FILTER_WRITE
PSFS_PASS_ON | Return Code indicating that the userspace filter returned buckets in $out.
PSFS_FEED_ME | Return Code indicating that the userspace filter did not return buckets in $out (i.e. No data available).
PSFS_ERR_FATAL | Return Code indicating that the userspace filter encountered an unrecoverable error (i.e. Invalid data received).
STREAM_USE_PATH | Flag indicating if the stream used the include path.
STREAM_REPORT_ERRORS | Flag indicating if the wrapper is responsible for raising errors using trigger_error() during opening of the stream. If this flag is not set, you should not raise any errors.
STREAM_CLIENT_ASYNC_CONNECT | Open client socket asynchronously. Used with stream_socket_client().
STREAM_CLIENT_PERSISTENT | Client socket opened with stream_socket_client() should remain persistent between page loads.
STREAM_SERVER_BIND | Tells a stream created with stream_socket_server() to bind to the specified target. Server sockets should always include this flag.
STREAM_SERVER_LISTEN | Tells a stream created with stream_socket_server() and bound using the STREAM_SERVER_BIND flag to start listening on the socket. Server sockets should always include this flag.
STREAM_NOTIFY_RESOLVE | A remote address required for this stream has been resolved, or the resolution failed. See severity for an indication of which happened.
STREAM_NOTIFY_CONNECT | A connection with an external resource has been established.
STREAM_NOTIFY_AUTH_REQUIRED | Additional authorization is required to access the specified resource. Typical issued with severity level of STREAM_NOTIFY_SEVERITY_ERR.
STREAM_NOTIFY_MIME_TYPE_IS | The mime-type of resource has been identified, refer to message for a description of the discovered type.
STREAM_NOTIFY_FILE_SIZE_IS | The size of the resource has been discovered.
STREAM_NOTIFY_REDIRECTED | The external resource has redirected the stream to an alternate location. Refer to message.
STREAM_NOTIFY_PROGRESS | Indicates current progress of the stream transfer in bytes_transferred and possibly bytes_max as well.
STREAM_NOTIFY_COMPLETED | There is no more data available on the stream.
STREAM_NOTIFY_FAILURE | A generic error occurred on the stream, consult message and message_code for details.
STREAM_NOTIFY_AUTH_RESULT | Authorization has been completed (with or without success).
STREAM_NOTIFY_SEVERITY_INFO | Normal, non-error related, notification.
STREAM_NOTIFY_SEVERITY_WARN | Non critical error condition. Processing may continue.
STREAM_NOTIFY_SEVERITY_ERR | A critical error occurred. Processing cannot continue.

Stream Errors

As with any file or socket related function, an operation on a stream may fail for a variety of normal reasons (i.e.: Unable to connect to remote host, file not found, etc...). A stream related call may also fail because the desired stream is not registered on the running system. See the array returned by stream_get_wrappers() for a list of streams supported by your installation of PHP. As with most PHP internal functions if a failure occurs an E_WARNING message will be generated describing the nature of the error.

예제

예 1. Using file_get_contents() to retrieve data from multiple sources

<?php
/* Read local file from /home/bar */
$localfile = file_get_contents("/home/bar/foo.txt");

/* Identical to above, explicitly naming FILE scheme */
$localfile = file_get_contents("file:///home/bar/foo.txt");

/* Read remote file from www.example.com using HTTP */
$httpfile  = file_get_contents("http://www.example.com/foo.txt");

/* Read remote file from www.example.com using HTTPS */
$httpsfile = file_get_contents("https://www.example.com/foo.txt");

/* Read remote file from ftp.example.com using FTP */
$ftpfile   = file_get_contents("ftp://user:pass@ftp.example.com/foo.txt");

/* Read remote file from ftp.example.com using FTPS */
$ftpsfile  = file_get_contents("ftps://user:pass@ftp.example.com/foo.txt");
?>

예 2. Making a POST request to an https server

<?php
/* Send POST request to https://secure.example.com/form_action.php
* Include form elements named "foo" and "bar" with dummy values
*/

$sock = fsockopen("ssl://secure.example.com", 443, $errno, $errstr, 30);
if (!$sock) die("$errstr ($errno)\n");

$data = "foo=" . urlencode("Value for Foo") . "&bar=" . urlencode("Value for Bar");

fwrite($sock, "POST /form_action.php HTTP/1.0\r\n");
fwrite($sock, "Host: secure.example.com\r\n");
fwrite($sock, "Content-type: application/x-www-form-urlencoded\r\n");
fwrite($sock, "Content-length: " . strlen($data) . "\r\n");
fwrite($sock, "Accept: */*\r\n");
fwrite($sock, "\r\n");
fwrite($sock, "$data\r\n");
fwrite($sock, "\r\n");

$headers = "";
while ($str = trim(fgets($sock, 4096)))
  $headers .= "$str\n";

echo "\n";

$body = "";
while (!feof($sock))
  $body .= fgets($sock, 4096);

fclose($sock);
?>

예 3. Writing data to a compressed file

<?php
/* Create a compressed file containing an arbitrarty string
* File can be read back using compress.zlib stream or just
* decompressed from the command line using 'gzip -d foo-bar.txt.gz'
*/
$fp = fopen("compress.zlib://foo-bar.txt.gz", "wb");
if (!$fp) die("Unable to create file.");

fwrite($fp, "This is a test.\n");

fclose($fp);
?>

차례
stream_context_create -- Create a streams context
stream_context_get_options -- Retrieve options for a stream/wrapper/context
stream_context_set_option -- Sets an option for a stream/wrapper/context
stream_context_set_params -- Set parameters for a stream/wrapper/context
stream_copy_to_stream -- Copies data from one stream to another
stream_filter_append -- Attach a filter to a stream.
stream_filter_prepend -- Attach a filter to a stream.
stream_filter_register -- Register a stream filter implemented as a PHP class derived from php_user_filter
stream_get_contents -- Reads remainder of a stream into a string
stream_get_filters -- Retrieve list of registered filters
stream_get_line -- Gets line from stream resource up to a given delimiter
stream_get_meta_data -- Retrieves header/meta data from streams/file pointers
stream_get_transports -- Retrieve list of registered socket transports
stream_get_wrappers -- Retrieve list of registered streams
stream_register_wrapper -- Alias of stream_wrapper_register()
stream_select -- Runs the equivalent of the select() system call on the given arrays of streams with a timeout specified by tv_sec and tv_usec
stream_set_blocking -- Set blocking/non-blocking mode on a stream
stream_set_timeout -- Set timeout period on a stream
stream_set_write_buffer -- Sets file buffering on the given stream
stream_socket_accept -- Accept a connection on a socket created by stream_socket_server()
stream_socket_client -- Open Internet or Unix domain socket connection
stream_socket_get_name -- Retrieve the name of the local or remote sockets
stream_socket_recvfrom -- Receives data from a socket, connected or not
stream_socket_sendto -- Sends a message to a socket, whether it is connected or not
stream_socket_server -- Create an Internet or Unix domain server socket
stream_wrapper_register -- Register a URL wrapper implemented as a PHP class

이전 | 처음으로 | 다음
SimpleXMLIterator::valid | 위로 | stream_context_create


stream_context_create

(PHP 4 >= 4.3.0, PHP 5)

stream_context_create -- Create a streams context

Description

resource stream_context_create ( array options)

Creates and returns a stream context with any options supplied in options preset.

options must be an associative array of associative arrays in the format $arr['wrapper']['option'] = $value.

예 1. Using stream_context_create()

<?php
$opts = array(
  'http'=>array(
    'method'=>"GET",
    'header'=>"Accept-language: en\r\n" .
              "Cookie: foo=bar\r\n"
  )
);

$context = stream_context_create($opts);

/* Sends an http request to www.example.com
   with additional headers shown above */
$fp = fopen('http://www.example.com', 'r', false, $context);
fpassthru($fp);
fclose($fp);
?>

See Also: stream_context_set_option(), and Listing of supported wrappers with context options (부록 J)

이전 | 처음으로 | 다음
Stream Functions | 위로 | stream_context_get_options


stream_context_get_options

(PHP 4 >= 4.3.0, PHP 5)

stream_context_get_options -- Retrieve options for a stream/wrapper/context

Description

array stream_context_get_options ( resource stream|context)

Returns an array of options on the specified stream or context.

이전 | 처음으로 | 다음
stream_context_create | 위로 | stream_context_set_option


stream_context_set_option

(PHP 4 >= 4.3.0, PHP 5)

stream_context_set_option -- Sets an option for a stream/wrapper/context

Description

bool stream_context_set_option ( resource context|stream, string wrapper, string option, mixed value)

Sets an option on the specified context. value is set to option for wrapper

이전 | 처음으로 | 다음
stream_context_get_options | 위로 | stream_context_set_params


stream_context_set_params

(PHP 4 >= 4.3.0, PHP 5)

stream_context_set_params -- Set parameters for a stream/wrapper/context

Description

bool stream_context_set_params ( resource stream|context, array params)

params should be an associative array of the structure: $params['paramname'] = "paramvalue";.

표 1. Parameters

Parameters | Purpose
notification | Name of user-defined callback function to be called whenever a stream triggers a notification.

이전 | 처음으로 | 다음
stream_context_set_option | 위로 | stream_copy_to_stream


stream_copy_to_stream

(PHP 5)

stream_copy_to_stream -- Copies data from one stream to another

Description

int stream_copy_to_stream ( resource source, resource dest [, int maxlength])

Makes a copy of up to maxlength bytes of data from the current position in source to dest. If maxlength is not specified, all remaining content in source will be copied. Returns the total count of bytes copied.

예 1. stream_copy_to_stream() example

<?php
$src = fopen('http://www.example.com', 'r');
$dest1 = fopen('first1k.txt', 'w');
$dest2 = fopen('remainder.txt', 'w');

echo stream_copy_to_stream($src, $dest1, 1024) . " bytes copied to first1k.txt\n";
echo stream_copy_to_stream($src, $dest2) . " bytes copied to remainder.txt\n";

?>

See also copy().

이전 | 처음으로 | 다음
stream_context_set_params | 위로 | stream_filter_append


stream_filter_append

(PHP 4 >= 4.3.0, PHP 5)

stream_filter_append -- Attach a filter to a stream.

Description

bool stream_filter_append ( resource stream, string filtername [, int read_write [, mixed params]])

Adds filtername to the list of filters attached to stream. This filter will be added with the specified params to the end of the list and will therefore be called last during stream operations. To add a filter to the beginning of the list, use stream_filter_prepend().

By default, stream_filter_append() will attach the filter to the read filter chain if the file was opened for reading (i.e. File Mode: r, and/or +). The filter will also be attached to the write filter chain if the file was opened for writing (i.e. File Mode: w, a, and/or +). STREAM_FILTER_READ, STREAM_FILTER_WRITE, and/or STREAM_FILTER_ALL can also be passed to the read_write parameter to override this behavior.

예 1. Controlling where filters are applied

<?php
/* Open a test file for reading and writing */
$fp = fopen("test.txt", "rw");

/* Apply the ROT13 filter to the
* write filter chain, but not the
* read filter chain */
stream_filter_append($fp, "string.rot13", STREAM_FILTER_WRITE);

/* Write a simple string to the file
* it will be ROT13 transformed on the
* way out */
fwrite($fp, "This is a test\n");

/* Back up to the beginning of the file */
rewind($fp);

/* Read the contents of the file back out.
* Had the filter been applied to the
* read filter chain as well, we would see
* the text ROT13ed back to its original state */
fpassthru($fp);

fclose($fp);

/* Expected Output
   ---------------

Guvf vf n grfg

*/
?>

When using custom (user) filters: stream_filter_register() must be called first in order to register the desired user filter to filtername.

참고: Stream data is read from resources (both local and remote) in chunks, with any unconsumed data kept in internal buffers. When a new filter is appended to a stream, data in the internal buffers is processed through the new filter at that time. This differs from the behavior of stream_filter_prepend().

See also stream_filter_register(), and stream_filter_prepend()

이전 | 처음으로 | 다음
stream_copy_to_stream | 위로 | stream_filter_prepend


stream_filter_prepend

(PHP 4 >= 4.3.0, PHP 5)

stream_filter_prepend -- Attach a filter to a stream.

Description

bool stream_filter_prepend ( resource stream, string filtername [, int read_write [, mixed params]])

Adds filtername to the list of filters attached to stream. This filter will be added with the specified params to the beginning of the list and will therefore be called first during stream operations. To add a filter to the end of the list, use stream_filter_append().

By default, stream_filter_prepend() will attach the filter to the read filter chain if the file was opened for reading (i.e. File Mode: r, and/or +). The filter will also be attached to the write filter chain if the file was opened for writing (i.e. File Mode: w, a, and/or +). STREAM_FILTER_READ, STREAM_FILTER_WRITE, and/or STREAM_FILTER_ALL can also be passed to the read_write parameter to override this behavior. See stream_filter_append() for an example of using this parameter.

When using custom (user) filters: stream_filter_register() must be called first in order to register the desired user filter to filtername.

참고: Stream data is read from resources (both local and remote) in chunks, with any unconsumed data kept in internal buffers. When a new filter is prepended to a stream, data in the internal buffers, which has already been processed through other filters will not be reprocessed through the new filter at that time. This differs from the behavior of stream_filter_append().

See also stream_filter_register(), and stream_filter_append()

이전 | 처음으로 | 다음
stream_filter_append | 위로 | stream_filter_register


stream_filter_register

(PHP 5)

stream_filter_register -- Register a stream filter implemented as a PHP class derived from php_user_filter

Description

bool stream_filter_register ( string filtername, string classname)

stream_filter_register() allows you to implement your own filter on any registered stream used with all the other filesystem functions (such as fopen(), fread() etc.).

To implement a filter, you need to define a class as an extension of php_user_filter with a number of member functions as defined below. When performing read/write operations on the stream to which your filter is attached, PHP will pass the data through your filter (and any other filters attached to that stream) so that the data may be modified as desired. You must implement the methods exactly as described below - doing otherwise will lead to undefined behaviour.

stream_filter_register() will return FALSE if the filtername is already defined.

int filter ( resource in, resource out, int &consumed, bool closing)

This method is called whenever data is read from or written to the attached stream (such as with fread() or fwrite()). in is a resource pointing to a bucket brigade which contains one or more bucket objects containing data to be filtered. out is a resource pointing to a second bucket brigade into which your modified buckets should be placed. consumed, which must always be declared by reference, should be incremented by the length of the data which your filter reads in and alters. In most cases this means you will increment consumed by $bucket->datalen for each $bucket. If the stream is in the process of closing (and therefore this is the last pass through the filterchain), the closing parameter will be set to TRUE The filter method must return one of three values upon completion.

Return Value | Meaning
PSFS_PASS_ON | Filter processed successfully with data available in the out bucket brigade.
PSFS_FEED_ME | Filter processed successfully, however no data was available to return. More data is required from the stream or prior filter.
PSFS_ERR_FATAL (default) | The filter experienced an unrecoverable error and cannot continue.

void onCreate ( void )

This method is called during instantiation of the filter class object. If your filter allocates or initializes any other resources (such as a buffer), this is the place to do it. Your implementation of this method should return FALSE on failure, or TRUE on success.

When your filter is first instantiated, and yourfilter->onCreate() is called, a number of properties will be available as shown in the table below.

Property | Contents
FilterClass->filtername | A string containing the name the filter was instantiated with. Filters may be registered under multiple names or under wildcards. Use this property to determine which name was used.
FilterClass->params | The contents of the params parameter passed to stream_filter_append() or stream_filter_prepend().

void onClose ( void )

This method is called upon filter shutdown (typically, this is also during stream shutdown), and is executed after the flush method is called. If any resources were allocated or initialzed during onCreate this would be the time to destroy or dispose of them.

The example below implements a filter named strtoupper on the foo-bar.txt stream which will capitalize all letter characters written to/read from that stream.

예 1. Filter for capitalizing characters on foo-bar.txt stream

<?php

/* Define our filter class */
class strtoupper_filter extends php_user_filter {
  function filter($in, $out, &$consumed, $closing)
  {
    while ($bucket = stream_bucket_make_writeable($in)) {
      $bucket->data = strtoupper($bucket->data);
      $consumed += $bucket->datalen;
      stream_bucket_append($out, $bucket);
    }
    return PSFS_PASS_ON;
  }
}

/* Register our filter with PHP */
stream_filter_register("strtoupper", "strtoupper_filter")
    or die("Failed to register filter");

$fp = fopen("foo-bar.txt", "w");

/* Attach the registered filter to the stream just opened */
stream_filter_append($fp, "strtoupper");

fwrite($fp, "Line1\n");
fwrite($fp, "Word - 2\n");
fwrite($fp, "Easy As 123\n");

fclose($fp);

/* Read the contents back out
*/
readfile("foo-bar.txt");

?>

Output

LINE1
WORD - 2
EASY AS 123

예 2. Registering a generic filter class to match multiple filter names.

<?php

/* Define our filter class */
class string_filter extends php_user_filter {
  var $mode;

  function filter($in, $out, &$consumed, $closing)
  {
    while ($bucket = stream_bucket_make_writeable($in)) {
      if ($this->mode == 1) {
        $bucket->data = strtoupper($bucket->data);
      } elseif ($this->mode == 0) {
        $bucket->data = strtolower($bucket->data);
      }

      $consumed += $bucket->datalen;
      stream_bucket_append($out, $bucket);
    }
    return PSFS_PASS_ON;
  }

  function onCreate()
  {
    if ($this->filtername == 'str.toupper') {
      $this->mode = 1;
    } elseif ($this->filtername == 'str.tolower') {
      $this->mode = 0;
    } else {
      /* Some other str.* filter was asked for,
         report failure so that PHP will keep looking */
      return false;
    }

    return true;
  }
}

/* Register our filter with PHP */
stream_filter_register("str.*", "string_filter")
    or die("Failed to register filter");

$fp = fopen("foo-bar.txt", "w");

/* Attach the registered filter to the stream just opened
   We could alternately bind to str.tolower here */
stream_filter_append($fp, "str.toupper");

fwrite($fp, "Line1\n");
fwrite($fp, "Word - 2\n");
fwrite($fp, "Easy As 123\n");

fclose($fp);

/* Read the contents back out
*/
readfile("foo-bar.txt");

/* Output
* ------

LINE1
WORD - 2
EASY AS 123

*/

?>

See Also:
stream_wrapper_register(),
stream_filter_prepend(), and
stream_filter_append()

이전 | 처음으로 | 다음
stream_filter_prepend | 위로 | stream_get_contents


stream_get_contents

(PHP 5)

stream_get_contents -- Reads remainder of a stream into a string

Description

string stream_get_contents ( resource handle [, int maxlength])

Identical to file_get_contents(), except that stream_get_contents() operates on an already open file resource and returns the remaining contents, up to maxlength bytes, in a string.

참고: 이 함수는 바이너리 호환(binary-safe)입니다.

See also:
fgets(),
fread(), and
fpassthru().

이전 | 처음으로 | 다음
stream_filter_register | 위로 | stream_get_filters


stream_get_filters

(PHP 5)

stream_get_filters -- Retrieve list of registered filters

Description

array stream_get_filters ( void )

Returns an indexed array containing the name of all stream filters available on the running system.

예 1. Using stream_get_filters()

<?php
$streamlist = stream_get_filters();
print_r($streamlist);
?>

Output will be similar to the following Note: there may be more or fewer filters in your version of PHP.

Array (
  [0] => string.rot13
  [1] => string.toupper
  [2] => string.tolower
  [3] => string.base64
  [4] => string.quoted-printable
)

See also stream_filter_register(), and stream_get_wrappers()

이전 | 처음으로 | 다음
stream_get_contents | 위로 | stream_get_line


stream_get_line

(PHP 5)

stream_get_line -- Gets line from stream resource up to a given delimiter

Description

string stream_get_line ( resource handle, int length, string ending)

Returns a string of up to length bytes read from the file pointed to by handle. Reading ends when length bytes have been read, when the string specified by ending is found (which is not included in the return value), or on EOF (whichever comes first).

If an error occurs, returns FALSE.

This function is nearly identical to fgets() except in that it allows end of line delimiters other than the standard \n, \r, and \r\n, and does not return the delimiter itself.

See also fread(),
fgets(), and
fgetc(),

이전 | 처음으로 | 다음
stream_get_filters | 위로 | stream_get_meta_data


stream_get_meta_data

(PHP 4 >= 4.3.0, PHP 5)

stream_get_meta_data -- Retrieves header/meta data from streams/file pointers

Description

array stream_get_meta_data ( resource stream)

Returns information about an existing stream. The stream can be any stream created by fopen(), fsockopen() and pfsockopen(). The result array contains the following items:

  • timed_out (bool) - TRUE if the stream timed out while waiting for data on the last call to fread() or fgets().

  • blocked (bool) - TRUE if the stream is in blocking IO mode. See stream_set_blocking().

  • eof (bool) - TRUE if the stream has reached end-of-file. Note that for socket streams this member can be TRUE even when unread_bytes is non-zero. To determine if there is more data to be read, use feof() instead of reading this item.

  • unread_bytes (int) - the number of bytes currently contained in the read buffer.

The following items were added in PHP 4.3:

  • stream_type (string) - a label describing the underlying implementation of the stream.

  • wrapper_type (string) - a label describing the protocol wrapper implementation layered over the stream. See 부록 J for more information about wrappers.

  • wrapper_data (mixed) - wrapper specific data attached to this stream. See 부록 J for more information about wrappers and their wrapper data.

  • filters (array) - and array containing the names of any filters that have been stacked onto this stream. Filters are currently undocumented.

참고: This function was introduced in PHP 4.3, but prior to this version, socket_get_status() could be used to retrieve the first four items, for socket based streams only.

In PHP 4.3 and later, socket_get_status() is an alias for this function.

참고: This function does NOT work on sockets created by the Socket extension.

The following items were added in PHP 5.0:

  • mode (string) - the mode (or permissions) of the URI associated with this stream.

  • seakable (bool) - whether the current stream can be seeked in.

  • uri (string) - the URI/filename associated with this stream.

이전 | 처음으로 | 다음
stream_get_line | 위로 | stream_get_transports


stream_get_transports

(PHP 5)

stream_get_transports -- Retrieve list of registered socket transports

Description

array stream_get_transports ( void )

Returns an indexed array containing the name of all socket transports available on the running system.

예 1. Using stream_get_transports()

<?php
$xportlist = stream_get_transports();
print_r($xportlist);
?>

Output will be similar to the following Note: there may be more or fewer transports in your version of PHP

Array (
  [0] => tcp
  [1] => udp
  [2] => unix
  [3] => udg
)

See also stream_get_filters(), and stream_get_wrappers()

이전 | 처음으로 | 다음
stream_get_meta_data | 위로 | stream_get_wrappers


stream_get_wrappers

(PHP 5)

stream_get_wrappers -- Retrieve list of registered streams

Description

array stream_get_wrappers ( void )

Returns an indexed array containing the name of all stream wrappers available on the running system.

See also stream_wrapper_register()

이전 | 처음으로 | 다음
stream_get_transports | 위로 | stream_register_wrapper


stream_register_wrapper

stream_register_wrapper -- Alias of stream_wrapper_register()

Description

This function is an alias of stream_wrapper_register(). This function is included for compatability with PHP 4.3.0 and PHP 4.3.1 only. stream_wrapper_register() should be used instead.

이전 | 처음으로 | 다음
stream_get_wrappers | 위로 | stream_select


stream_select

(PHP 4 >= 4.3.0, PHP 5)

stream_select -- Runs the equivalent of the select() system call on the given arrays of streams with a timeout specified by tv_sec and tv_usec

Description

int stream_select ( array &read, array &write, array &except, int tv_sec [, int tv_usec])

The stream_select() function accepts arrays of streams and waits for them to change status. Its operation is equivalent to that of the socket_select() function except in that it acts on streams.

The streams listed in the read array will be watched to see if characters become available for reading (more precisely, to see if a read will not block - in particular, a stream resource is also ready on end-of-file, in which case an fread() will return a zero length string).

The streams listed in the write array will be watched to see if a write will not block.

The streams listed in the except array will be watched for high priority exceptional ("out-of-band") data arriving.

참고: When stream_select() returns, the arrays read, write and except are modified to indicate which stream resource(s) actually changed status.

The tv_sec and tv_usec together form the timeout parameter, tv_sec specifies the number of seconds while tv_usec the number of microseconds. The timeout is an upper bound on the amount of time that stream_select() will wait before it returns. If tv_sec and tv_usec are both set to 0, stream_select() will not wait for data - instead it will return immediately, indicating the current status of the streams. If tv_sec is NULL stream_select() can block indefinitely, returning only when an event on one of the watched streams occurs (or if a signal interrupts the system call).

On success stream_select() returns the number of stream resources contained in the modified arrays, which may be zero if the timeout expires before anything interesting happens. On error FALSE is returned and a warning raised (this can happen if the system call is interrupted by an incoming signal).

주의

Using a timeout value of 0 allows you to instantaneously poll the status of the streams, however, it is NOT a good idea to use a 0 timeout value in a loop as it will cause your script to consume too much CPU time.

It is much better to specify a timeout value of a few seconds, although if you need to be checking and running other code concurrently, using a timeout value of at least 200000 microseconds will help reduce the CPU usage of your script.

Remember that the timeout value is the maximum time that will elapse; stream_select() will return as soon as the requested streams are ready for use.

You do not need to pass every array to stream_select(). You can leave it out and use an empty array or NULL instead. Also do not forget that those arrays are passed by reference and will be modified after stream_select() returns.

This example checks to see if data has arrived for reading on either $stream1 or $stream2. Since the timeout value is 0 it will return immediately:
<?php
/* Prepare the read array */
$read = array($stream1, $stream2);

if (false === ($num_changed_streams = stream_select($read, $write = NULL, $except = NULL, 0))) {
    /* Error handling */
} elseif ($num_changed_streams > 0) {
    /* At least on one of the streams something interesting happened */
}
?>

참고: Due to a limitation in the current Zend Engine it is not possible to pass a constant modifier like NULL directly as a parameter to a function which expects this parameter to be passed by reference. Instead use a temporary variable or an expression with the leftmost member being a temporary variable:
<?php
stream_select($r, $w, $e = NULL, 0);
?>

참고: Be sure to use the === operator when checking for an error. Since the stream_select() may return 0 the comparison with == would evaluate to TRUE:
<?php
if (false === stream_select($r, $w, $e = NULL, 0)) {
    echo "stream_select() failed\n";
}
?>

참고: If you read/write to a stream returned in the arrays be aware that they do not necessarily read/write the full amount of data you have requested. Be prepared to even only be able to read/write a single byte.

Windows 98 Note: stream_select() used on a pipe returned from proc_open() may cause data loss under Windows 98.

See also stream_set_blocking()

이전 | 처음으로 | 다음
stream_register_wrapper | 위로 | stream_set_blocking


stream_set_blocking

(PHP 4 >= 4.3.0, PHP 5)

stream_set_blocking -- Set blocking/non-blocking mode on a stream

Description

bool stream_set_blocking ( resource stream, int mode)

If mode is FALSE, the given stream will be switched to non-blocking mode, and if TRUE, it will be switched to blocking mode. This affects calls like fgets() and fread() that read from the stream. In non-blocking mode an fgets() call will always return right away while in blocking mode it will wait for data to become available on the stream.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

This function was previously called as set_socket_blocking() and later socket_set_blocking() but this usage is deprecated.

참고: Prior to PHP 4.3, this function only worked on socket based streams. Since PHP 4.3, this function works for any stream that supports non-blocking mode (currently, regular files and socket streams).

See also stream_select().

이전 | 처음으로 | 다음
stream_select | 위로 | stream_set_timeout


stream_set_timeout

(PHP 4 >= 4.3.0, PHP 5)

stream_set_timeout -- Set timeout period on a stream

Description

bool stream_set_timeout ( resource stream, int seconds [, int microseconds])

Sets the timeout value on stream, expressed in the sum of seconds and microseconds. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. stream_set_timeout() example

<?php
$fp = fsockopen("www.example.com", 80);
if (!$fp) {
    echo "Unable to open\n";
} else {
    fwrite($fp, "GET / HTTP/1.0\n\n");
    stream_set_timeout($fp, 2);
    $res = fread($fp, 2000);
    var_dump(stream_get_meta_data($fp));
    fclose($fp);
    echo $res;
}
?>

참고: As of PHP 4.3, this function can (potentially) work on any kind of stream. In PHP 4.3, socket based streams are still the only kind supported in the PHP core, although streams from other extensions may support this function.

This function was previously called as set_socket_timeout() and later socket_set_timeout() but this usage is deprecated.

See also: fsockopen() and fopen().

이전 | 처음으로 | 다음
stream_set_blocking | 위로 | stream_set_write_buffer


stream_set_write_buffer

(PHP 4 >= 4.3.0, PHP 5)

stream_set_write_buffer -- Sets file buffering on the given stream

Description

int stream_set_write_buffer ( resource stream, int buffer)

Output using fwrite() is normally buffered at 8K. This means that if there are two processes wanting to write to the same output stream (a file), each is paused after 8K of data to allow the other to write. stream_set_write_buffer() sets the buffering for write operations on the given filepointer stream to buffer bytes. If buffer is 0 then write operations are unbuffered. This ensures that all writes with fwrite() are completed before other processes are allowed to write to that output stream.

The function returns 0 on success, or EOF if the request cannot be honored.

The following example demonstrates how to use stream_set_write_buffer() to create an unbuffered stream.

예 1. stream_set_write_buffer() example

<?php
$fp = fopen($file, "w");
if ($fp) {
  stream_set_write_buffer($fp, 0);
  fwrite($fp, $output);
  fclose($fp);
}
?>

See also fopen() and fwrite().

이전 | 처음으로 | 다음
stream_set_timeout | 위로 | stream_socket_accept


stream_socket_accept

(PHP 5)

stream_socket_accept -- Accept a connection on a socket created by stream_socket_server()

Description

resource stream_socket_accept ( resource server_socket [, int timeout [, string &peername]])

Accept a connection on a socket previously created by stream_socket_server(). If timeout is specified, the default socket accept timeout will be overridden with the time specified in seconds. The name (address) of the client which connected will be passed back in peername if included and available from the selected transport.

peername can also be determined later using stream_socket_get_name().

If the call fails, it will return FALSE.

See also stream_socket_server(),
stream_socket_get_name(),
stream_set_blocking(),
stream_set_timeout(),
fgets(),
fgetss(), fwrite(),
fclose(), feof(), and
the Curl extension.

이전 | 처음으로 | 다음
stream_set_write_buffer | 위로 | stream_socket_client


stream_socket_client

(PHP 5)

stream_socket_client -- Open Internet or Unix domain socket connection

Description

resource stream_socket_client ( string remote_socket [, int &errno [, string &errstr [, float timeout [, int flags [, resource context]]]]])

Initiates a stream or datagram connection to the destination specified by remote_socket. The type of socket created is determined by the transport specified using standard URL formatting: transport://target. For Internet Domain sockets (AF_INET) such as TCP and UDP, the target portion of the remote_socket parameter should consist of a hostname or IP address followed by a colon and a port number. For Unix domain sockets, the target portion should point to the socket file on the filesystem. The optional timeout can be used to set a timeout in seconds for the connect system call. flags is a bitmask field which may be set to any combination of connection flags. Currently the selection of connection flags is limited to STREAM_CLIENT_ASYNC_CONNECT and STREAM_CLIENT_PERSISTENT.

참고: If you need to set a timeout for reading/writing data over the socket, use stream_set_timeout(), as the timeout parameter to stream_socket_client() only applies while connecting the socket.

stream_socket_client() returns a
stream resource which may
be used together with the other file functions (such as
fgets(), fgetss(),
fwrite(), fclose(), and
feof()).

If the call fails, it will return FALSE and if the optional errno and errstr arguments are present they will be set to indicate the actual system level error that occurred in the system-level connect() call. If the value returned in errno is 0 and the function returned FALSE, it is an indication that the error occurred before the connect() call. This is most likely due to a problem initializing the socket. Note that the errno and errstr arguments will always be passed by reference.

Depending on the environment, the Unix domain or the optional connect timeout may not be available. A list of available transports can be retrieved using stream_get_transports(). See 부록 L for a list of built in transports.

The stream will by default be opened in blocking mode. You can switch it to non-blocking mode by using stream_set_blocking().

예 1. stream_socket_client() Example

<?php
$fp = stream_socket_client("tcp://www.example.com:80", $errno, $errstr, 30);
if (!$fp) {
    echo "$errstr ($errno)<br />\n";
} else {
    fwrite($fp, "GET / HTTP/1.0\r\nHost: www.example.com\r\nAccept: */*\r\n\r\n");
    while (!feof($fp)) {
        echo fgets($fp, 1024);
    }
    fclose($fp);
}
?>
The example below shows how to retrieve the day and time from the UDP service "daytime" (port 13) in your own machine.

예 2. Using UDP connection

<?php
$fp = stream_socket_client("udp://127.0.0.1:13", $errno, $errstr);
if (!$fp) {
    echo "ERROR: $errno - $errstr<br />\n";
} else {
    fwrite($fp, "\n");
    echo fread($fp, 26);
    fclose($fp);
}
?>

주의

UDP sockets will sometimes appear to have opened without an error, even if the remote host is unreachable. The error will only become apparent when you read or write data to/from the socket. The reason for this is because UDP is a "connectionless" protocol, which means that the operating system does not try to establish a link for the socket until it actually needs to send or receive data.

참고: 숫자로 이루어진 IPv6 주소(예. fe80::1)를 지정할 때는 IP를 대괄호로 감싸줘야합니다. 예를 들면, tcp://[fe80::1]:80.

See also stream_socket_server(), stream_set_blocking(), stream_set_timeout(), stream_select(), fgets(), fgetss(), fwrite(), fclose(), feof(), and the Curl extension.

이전 | 처음으로 | 다음
stream_socket_accept | 위로 | stream_socket_get_name


stream_socket_get_name

(PHP 5)

stream_socket_get_name -- Retrieve the name of the local or remote sockets

Description

string stream_socket_get_name ( resource handle, bool want_peer)

Returns the local or remote name of a given socket connection. If want_peer is set to TRUE the remote socket name will be returned, if it is set to FALSE the local socket name will be returned.

See also stream_socket_accept()

이전 | 처음으로 | 다음
stream_socket_client | 위로 | stream_socket_recvfrom


stream_socket_recvfrom

(PHP 5)

stream_socket_recvfrom -- Receives data from a socket, connected or not

Description

string stream_socket_recvfrom ( resource socket, int length [, int flags [, string &address]])

The function stream_socket_recvfrom() accepts data from a remote socket up to length bytes. If address is provided it will be populated with the address of the remote socket.

The value of flags can be any combination of the following:

표 1. possible values for flags

STREAM_OOB | Process OOB (out-of-band) data.
STREAM_PEEK | Retrieve data from the socket, but do not consume the buffer. Subsequent calls to fread() or stream_socket_recvfrom() will see the same data.

예 1. stream_socket_recvfrom() Example

<?php
/* Open a server socket to port 1234 on localhost */
$server = stream_socket_server('tcp://127.0.0.1:1234');

/* Accept a connection */
$socket = stream_socket_accept($server);

/* Grab a packet (1500 is a typical MTU size) of OOB data */
echo "Received Out-Of-Band: '" . stream_socket_recvfrom($socket, 1500, STREAM_OOB) . "'\n";

/* Take a peek at the normal in-band data, but don't comsume it. */
echo "Data: '" . stream_socket_recvfrom($socket, 1500, STREAM_PEEK) . "'\n";

/* Get the exact same packet again, but remove it from the buffer this time. */
echo "Data: '" . stream_socket_recvfrom($socket, 1500) . "'\n";

/* Close it up */
fclose($socket);
fclose($server);
?>

See also
stream_socket_sendto(),
stream_socket_client(), and
stream_socket_server().

이전 | 처음으로 | 다음
stream_socket_get_name | 위로 | stream_socket_sendto


stream_socket_sendto

(PHP 5)

stream_socket_sendto -- Sends a message to a socket, whether it is connected or not

Description

int stream_socket_sendto ( resource socket, string data [, int flags [, string address]])

The function stream_socket_sendto() sends the data specified by data through the socket specified by socket. The address specified when the socket stream was created will be used unless an alternate address is specified in address.

The value of flags can be any combination of the following:

표 1. possible values for flags

STREAM_OOB Process OOB (out-of-band) data.

예 1. stream_socket_sendto() Example

<?php
/* Open a socket to port 1234 on localhost */
$socket = stream_socket_client('tcp://127.0.0.1:1234');

/* Send ordinary data via ordinary channels. */
fwrite($socket, "Normal data transmit.");

/* Send more data out of band. */
stream_socket_sendto($socket, "Out of Band data.", STREAM_OOB);

/* Close it up */
fclose($socket);
?>

See also
stream_socket_recvfrom(),
stream_socket_client(), and
stream_socket_server().

이전 | 처음으로 | 다음
stream_socket_recvfrom | 위로 | stream_socket_server


stream_socket_server

(PHP 5)

stream_socket_server -- Create an Internet or Unix domain server socket

Description

resource stream_socket_server ( string local_socket [, int &errno [, string &errstr [, int flags [, resource context]]]])

Creates a stream or datagram socket on the specified local_socket. The type of socket created is determined by the transport specified using standard URL formatting: transport://target. For Internet Domain sockets (AF_INET) such as TCP and UDP, the target portion of the remote_socket parameter should consist of a hostname or IP address followed by a colon and a port number. For Unix domain sockets, the target portion should point to the socket file on the filesystem. flags is a bitmask field which may be set to any combination of socket creation flags. The default value of flags is STREAM_SERVER_BIND | STREAM_SERVER_LISTEN.

This function only creates a socket, to begin accepting connections use stream_socket_accept().

If the call fails, it will return FALSE and if the optional errno and errstr arguments are present they will be set to indicate the actual system level error that occurred in the system-level socket(), bind(), and listen() calls. If the value returned in errno is 0 and the function returned FALSE, it is an indication that the error occurred before the bind() call. This is most likely due to a problem initializing the socket. Note that the errno and errstr arguments will always be passed by reference.

Depending on the environment, Unix domain sockets may not be available. A list of available transports can be retrieved using stream_get_transports(). See 부록 L for a list of bulitin transports.

예 1. stream_socket_server() Example

<?php
$socket = stream_socket_server("tcp://0.0.0.0:8000", $errno, $errstr);
if (!$socket) {
  echo "$errstr ($errno)<br />\n";
} else {
  while ($conn = stream_socket_accept($socket)) {
    fwrite($conn, 'The local time is ' . date('n/j/Y g:i a') . "\n");
    fclose($conn);
  }
  fclose($socket);
}
?>

The example below shows how to act as a time server which can respond to time queries as shown in an example on stream_socket_client().

참고: Most systems require root access to create a server socket on a port below 1024.

예 2. Using UDP server sockets

<?php
$socket = stream_socket_server("udp://0.0.0.0:13", $errno, $errstr, STREAM_SERVER_BIND);
if (!$socket) {
    echo "ERROR: $errno - $errstr<br />\n";
} else {
  while ($conn = stream_socket_accept($socket)) {
    fwrite($conn, date("D M j H:i:s Y\r\n"));
    fclose($conn);
  }
  fclose($socket);
}
?>

참고: 숫자로 이루어진 IPv6 주소(예. fe80::1)를 지정할 때는 IP를 대괄호로 감싸줘야합니다. 예를 들면, tcp://[fe80::1]:80.

See also stream_socket_client(),
stream_set_blocking(),
stream_set_timeout(),
fgets(),
fgetss(), fwrite(),
fclose(), feof(), and
the Curl extension.

이전 | 처음으로 | 다음
stream_socket_sendto | 위로 | stream_wrapper_register


stream_wrapper_register

(PHP 4 >= 4.3.2, PHP 5)

stream_wrapper_register -- Register a URL wrapper implemented as a PHP class

Description

bool stream_wrapper_register ( string protocol, string classname)

stream_wrapper_register() allows you to implement your own protocol handlers and streams for use with all the other filesystem functions (such as fopen(), fread() etc.).

To implement a wrapper, you need to define a class with a number of member functions, as defined below. When someone fopens your stream, PHP will create an instance of classname and then call methods on that instance. You must implement the methods exactly as described below - doing otherwise will lead to undefined behaviour.

참고: As of PHP 5.0.0 the instance of classname will be populated with a context property referencing a Context Resource which may be accessed with stream_context_get_options(). If no context was passed to the stream creation function, context will be set to NULL.

stream_wrapper_register() will return FALSE if the protocol already has a handler.

bool stream_open ( string path, string mode, int options, string opened_path)

This method is called immediately after your stream object is created. path specifies the URL that was passed to fopen() and that this object is expected to retrieve. You can use parse_url() to break it apart.

mode is the mode used to open the file, as detailed for fopen(). You are responsible for checking that mode is valid for the path requested.

options holds additional flags set by the streams API. It can hold one or more of the following values OR'd together.

Flag | Description
STREAM_USE_PATH | If path is relative, search for the resource using the include_path.
STREAM_REPORT_ERRORS | If this flag is set, you are responsible for raising errors using trigger_error() during opening of the stream. If this flag is not set, you should not raise any errors.

If the path is opened successfully, and STREAM_USE_PATH is set in options, you should set opened_path to the full path of the file/resource that was actually opened.

If the requested resource was opened successfully, you should return TRUE, otherwise you should return FALSE

void stream_close ( void )

This method is called when the stream is closed, using fclose(). You must release any resources that were locked or allocated by the stream.

string stream_read ( int count)

This method is called in response to fread() and fgets() calls on the stream. You must return up-to count bytes of data from the current read/write position as a string. If there are less than count bytes available, return as many as are available. If no more data is available, return either FALSE or an empty string. You must also update the read/write position of the stream by the number of bytes that were successfully read.

int stream_write ( string data)

This method is called in response to fwrite() calls on the stream. You should store data into the underlying storage used by your stream. If there is not enough room, try to store as many bytes as possible. You should return the number of bytes that were successfully stored in the stream, or 0 if none could be stored. You must also update the read/write position of the stream by the number of bytes that were successfully written.

bool stream_eof ( void )

This method is called in response to feof() calls on the stream. You should return TRUE if the read/write position is at the end of the stream and if no more data is available to be read, or FALSE otherwise.

int stream_tell ( void )

This method is called in response to ftell() calls on the stream. You should return the current read/write position of the stream.

bool stream_seek ( int offset, int whence)

This method is called in response to fseek() calls on the stream. You should update the read/write position of the stream according to offset and whence. See fseek() for more information about these parameters. Return TRUE if the position was updated, FALSE otherwise.

bool stream_flush ( void )

This method is called in response to fflush() calls on the stream. If you have cached data in your stream but not yet stored it into the underlying storage, you should do so now. Return TRUE if the cached data was successfully stored (or if there was no data to store), or FALSE if the data could not be stored.

array stream_stat ( void )

This method is called in response to fstat() calls on the stream and should return an array containing the same values as appropriate for the stream.

bool unlink ( string path)

This method is called in response to unlink() calls on URL paths associated with the wrapper and should attempt to delete the item specified by path. It should return TRUE on success or FALSE on failure. In order for the appropriate error message to be returned, do not define this method if your wrapper does not support unlinking.

참고: Userspace wrapper unlink method is not supported prior to PHP 5.0.0.

bool rename ( string path_from, string path_to)

This method is called in response to rename() calls on URL paths associated with the wrapper and should attempt to rename the item specified by path_from to the specification given by path_to. It should return TRUE on success or FALSE on failure. In order for the appropriate error message to be returned, do not define this method if your wrapper does not support renaming.

참고: Userspace wrapper rename method is not supported prior to PHP 5.0.0.

bool mkdir ( string path, int mode, int options)

This method is called in response to mkdir() calls on URL paths associated with the wrapper and should attempt to create the directory specified by path. It should return TRUE on success or FALSE on failure. In order for the appropriate error message to be returned, do not define this method if your wrapper does not support creating directories. Posible values for options include STREAM_REPORT_ERRORS and STREAM_MKDIR_RECURSIVE.

참고: Userspace wrapper mkdir method is not supported prior to PHP 5.0.0.

bool rmdir ( string path, int options)

This method is called in response to rmdir() calls on URL paths associated with the wrapper and should attempt to remove the directory specified by path. It should return TRUE on success or FALSE on failure. In order for the appropriate error message to be returned, do not define this method if your wrapper does not support removing directories. Possible values for options include STREAM_REPORT_ERRORS.

참고: Userspace wrapper rmdir method is not supported prior to PHP 5.0.0.

bool dir_opendir ( string path, int options)

This method is called immediately when your stream object is created for examining directory contents with opendir(). path specifies the URL that was passed to opendir() and that this object is expected to explore. You can use parse_url() to break it apart.

array url_stat ( string path, int flags)

This method is called in response to stat() calls on the URL paths associated with the wrapper and should return as many elements in common with the system function as possible. Unknown or unavailable values should be set to a rational value (usually 0).

flags holds additional flags set by the streams API. It can hold one or more of the following values OR'd together.

Flag | Description
STREAM_URL_STAT_LINK | For resources with the ability to link to other resource (such as an HTTP Location: forward, or a filesystem symlink). This flag specified that only information about the link itself should be returned, not the resource pointed to by the link. This flag is set in response to calls to lstat(), is_link(), or filetype().
STREAM_URL_STAT_QUIET | If this flag is set, your wrapper should not raise any errors. If this flag is not set, you are responsible for reporting errors using the trigger_error() function during stating of the path.

string dir_readdir ( void )

This method is called in response to readdir() and should return a string representing the next filename in the location opened by dir_opendir().

bool dir_rewinddir ( void )

This method is called in response to rewinddir() and should reset the output generated by dir_readdir(). i.e.: The next call to dir_readdir() should return the first entry in the location returned by dir_opendir().

bool dir_closedir ( void )

This method is called in response to closedir(). You should release any resources which were locked or allocated during the opening and use of the directory stream.

The example below implements a var:// protocol handler that allows read/write access to a named global variable using standard filesystem stream functions such as fread(). The var:// protocol implemented below, given the URL "var://foo" will read/write data to/from $GLOBALS["foo"].

예 1. A Stream for reading/writing global variables

<?php

class VariableStream {
    var $position;
    var $varname;

    function stream_open($path, $mode, $options, &$opened_path)
    {
        $url = parse_url($path);
        $this->varname = $url["host"];
        $this->position = 0;

        return true;
    }

    function stream_read($count)
    {
        $ret = substr($GLOBALS[$this->varname], $this->position, $count);
        $this->position += strlen($ret);
        return $ret;
    }

    function stream_write($data)
    {
        $left = substr($GLOBALS[$this->varname], 0, $this->position);
        $right = substr($GLOBALS[$this->varname], $this->position + strlen($data));
        $GLOBALS[$this->varname] = $left . $data . $right;
        $this->position += strlen($data);
        return strlen($data);
    }

    function stream_tell()
    {
        return $this->position;
    }

    function stream_eof()
    {
        return $this->position >= strlen($GLOBALS[$this->varname]);
    }

    function stream_seek($offset, $whence)
    {
        switch ($whence) {
            case SEEK_SET:
                if ($offset < strlen($GLOBALS[$this->varname]) && $offset >= 0) {
                     $this->position = $offset;
                     return true;
                } else {
                     return false;
                }
                break;

            case SEEK_CUR:
                if ($offset >= 0) {
                     $this->position += $offset;
                     return true;
                } else {
                     return false;
                }
                break;

            case SEEK_END:
                if (strlen($GLOBALS[$this->varname]) + $offset >= 0) {
                     $this->position = strlen($GLOBALS[$this->varname]) + $offset;
                     return true;
                } else {
                     return false;
                }
                break;

            default:
                return false;
        }
    }
}

stream_wrapper_register("var", "VariableStream")
    or die("Failed to register protocol");

$myvar = "";

$fp = fopen("var://myvar", "r+");

fwrite($fp, "line1\n");
fwrite($fp, "line2\n");
fwrite($fp, "line3\n");

rewind($fp);
while (!feof($fp)) {
    echo fgets($fp);
}
fclose($fp);
var_dump($myvar);

?>

이전 | 처음으로 | 다음
stream_socket_server | 위로 | 문자열 함수


문자열 함수

PHP 매뉴얼
이전 다음

CVI. 문자열 함수

소개

이 함수들은 문자열을 여러가지 방법으로 다룹니다. 좀 더 특화된 섹션으로 정규표현식과 URL 다루기 섹션이 있습니다.

문자열이 어떻게 작동하는지, 특히 작은 따옴표, 큰 따옴표, 이스케이프 시퀀스의 사용에 대해서 매뉴얼 타입 섹션의 문자열 부분을 참고하십시오.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

CRYPT_SALT_LENGTH integer

CRYPT_STD_DES integer

CRYPT_EXT_DES integer

CRYPT_MD5 integer

CRYPT_BLOWFISH integer

HTML_SPECIALCHARS (integer)

HTML_ENTITIES (integer)

ENT_COMPAT (integer)

ENT_QUOTES (integer)

ENT_NOQUOTES (integer)

CHAR_MAX (integer)

LC_CTYPE (integer)

LC_NUMERIC (integer)

LC_TIME (integer)

LC_COLLATE (integer)

LC_MONETARY (integer)

LC_ALL (integer)

LC_MESSAGES (integer)

STR_PAD_LEFT (integer)

STR_PAD_RIGHT (integer)

STR_PAD_BOTH (integer)

참고

더 강력하게 문자열을 다루고 조작하는 함수를 원한다면, POSIX 정규표현식 함수와 펄 호환 정규표현식 함수를 살펴보십시오.

차례
AddCSlashes -- C 형식으로 문자열에 슬래쉬를 덧붙입니다.
addslashes -- 문자열에 슬래쉬를 덧붙입니다.
bin2hex -- 바이너리 데이터를 16진수 표현으로 바꿉니다.
chop -- rtrim()의 별칭.
chr -- 특정 문자를 반환합니다.
chunk_split -- 문자열을 작은 조각으로 나눕니다.
convert_cyr_string -- 키릴 문자셋을 다른 것으로 변환합니다.
count_chars -- 문자열 안에 사용한 문자에 대한 정보를 반환합니다.
crc32 -- 문자열의 crc32값을 계산합니다.
crypt -- 단방향 문자열 암호화(해슁).
echo -- 하나 이상의 문자열을 출력합니다.
explode -- 문자열을 주어진 문자열을 기준으로 분리합니다.
fprintf -- 문자열을 형식화하여 스트림에 기록합니다.
get_html_translation_table -- htmlspecialchars()와 htmlentities()에서 사용하는 변환표를 반환합니다.
hebrev -- 논리 헤브라이어 텍스트를 표시 텍스트로 변환합니다.
hebrevc -- 개행 문자를 포함하여 논리 헤브라이어 텍스트를 표시 텍스트로 변환합니다.
html_entity_decode -- 모든 HTML 엔티티를 해당하는 문자로 변환합니다.
htmlentities -- 해당하는 모든 문자를 HTML 엔티티로 변환합니다.
htmlspecialchars -- 특수 문자를 HTML 엔터티로 변환합니다.
implode -- 문자열로 배열 요소를 결합합니다.
join -- implode()의 별칭.
levenshtein -- 두 문자열 사이의 Levenshtein distance를 계산합니다.
localeconv -- 숫자 형식화 정보를 얻습니다.
ltrim -- 문자열 시작 부분의 공백을 제거합니다.
md5_file -- 주어진 파일명의 md5 해쉬를 계산합니다.
md5 -- 문자열의 md5 해쉬를 계산합니다.
metaphone -- 문자열의 메타폰 키를 계산합니다.
money_format -- Formats a number as a currency string
nl_langinfo -- 언어와 로케일 정보를 얻습니다.
nl2br -- 문자열의 모든 줄바꿈 앞에 HTML 줄바꿈 태그를 삽입합니다.
number_format -- Format a number with grouped thousands
ord -- 문자의 아스키 값을 반환합니다.
parse_str -- 문자열을 처리하여 변수를 생성합니다.
print -- 문자열을 출력합니다.
printf -- 형식화한 문자열을 출력합니다.
quoted_printable_decode -- 인용되어 있는 출력 가능 문자열을 8비트 문자열로 변환합니다.
quotemeta -- 메타 문자를 인용합니다.
rtrim -- 문자열 끝 부분의 공백을 제거합니다.
setlocale -- 지역적보를 지정한다.
sha1_file -- 파일의 sha1 해쉬를 계산합니다.
sha1 -- 문자열의 sha1 해쉬를 계산합니다.
similar_text -- 두 문자열 간의 유사성을 계산합니다.
soundex -- 문자열의 soundex 키를 계산합니다.
sprintf -- 형식화한 문자열을 반환합니다.
sscanf -- 문자열을 형식에 따라 처리합니다.
str_ireplace -- 대소문자를 구별하지 않는 str_replace().
str_pad -- 문자열을 어떠한 길이가 되도록 다른 문자열로 채웁니다.
str_repeat -- 문자열을 반복합니다.
str_replace -- 발견한 모든 검색 문자열을 치환 문자열로 교체합니다.
str_rot13 -- 문자열에 rot13 변환을 수행합니다.
str_shuffle -- 문자열을 랜덤하게 섞습니다.
str_split -- 문자열을 배열로 변환합니다.
str_word_count -- 문자열에서 사용한 단어에 대한 정보를 반환합니다.
strcasecmp -- 대소문자를 구별하지 않는 바이너리 호환 문자열 비교
strchr -- strstr()의 별칭.
strcmp -- 바이너리 호환 문자열 비교
strcoll -- 로케일 기반 문자열 비교
strcspn -- 마스크에 매칭하지 않는 처음 세그먼트의 길이를 찾습니다.
strip_tags -- 문자열에서 HTML과 PHP 태그를 제거합니다.
stripcslashes -- addcslashes()로 처리한 문자열을 되돌립니다.
stripos -- 대소문자를 구별하지 않고 문자열이 처음 나타나는 위치를 찾습니다.
stripslashes -- addslashes()로 처리한 문자열을 되돌립니다.
stristr -- 대소문자를 구별하지 않는 strstr()
strlen -- 문자열의 길이를 구합니다.
strnatcasecmp -- "natural order" 알고리즘을 이용한 대소문자를 구별하지 않는 문자열 비교.
strnatcmp -- "natural order" 알고리즘을 이용한 문자열 비교
strncasecmp -- 대소문자를 구별하지 않는 처음 n 문자의 이진 호환 문자열 비교
strncmp -- 처음 n 문자의 이진 호환 문자열 비교
strpos -- 문자열이 처음 나타나는 위치를 찾습니다.
strrchr -- 문자열에서 문자가 마지막으로 나오는 부분을 찾습니다.
strrev -- 문자열을 뒤집습니다.
strripos -- 문자열에서 대소문자 구별 없이 문자열이 나타나는 마지막 위치를 찾습니다.
strrpos -- 문자열에서 마지막 문자의 위치를 찾습니다.
strspn -- 마스크에 매칭되는 초기 세그먼트의 길이를 찾는다.
strstr -- 문자열이 처음으로 나타나는 부분을 찾습니다.
strtok -- 문자열을 토큰화 합니다.
strtolower -- 문자열을 소문자로 만듭니다.
strtoupper -- 문자열을 대문자로 만듭니다.
strtr -- 특정 문자를 번역한다.
substr_compare -- Binary safe optionally case insensitive comparison of 2 strings from an offset, up to length characters
substr_count -- 부분문자열의 수를 센다
substr_replace -- 문자열의 일부를 치환한다.
substr -- 문자열의 일부를 반환한다.
trim -- 문자열의 처음과 끝에 있는 공백을 제거한다.
ucfirst -- 문자열의 처음 글자를 대문자로 만든다.
ucwords -- 문자열에 있는 각 단어의 처음 글자를 대문자로 바꾼다.
vprintf -- Output a formatted string
vsprintf -- Return a formatted string
wordwrap -- 정지문자를 이용해 주어진 수 만큼의 문자를 래핑한다.

이전 | 처음으로 | 다음
stream_wrapper_register | 위로 | AddCSlashes


AddCSlashes

(PHP 4 , PHP 5)

AddCSlashes -- C 형식으로 문자열에 슬래쉬를 덧붙입니다.

설명

string addcslashes ( string str, string charlist)

charlist 인자에 주어진 문자 목록 앞에 백슬래쉬를 추가한 문자열을 반환합니다. C 형식으로 \n, \r 등을 이스케이프하고, 32보다 작거나 126보다 큰 ASCII 코드는 팔진 표현으로 변환합니다.

0, a, b, f, n, r, t, v를 이스케이프할 때 주의하십시오. 이는 \0, \a, \b, \f, \n, \r, \t, \v로 변환됩니다. C에서는 이 모든 것이 예약 정의된 이스케이프 시퀀스지만, PHP에서는 \0 (NULL), \r (캐리지 리턴), \n (뉴라인), \t (탭)만이 예약 정의된 이스케이프 시퀀스입니다.

charlist을 "\0..\37"처럼 하면, 0에서 37사이의 모든 ASCII코드를 이스케이프합니다.

예 1. addcslashes() 예제

<?php
$escaped = addcslashes($not_escaped, "\0..\37!@\177..\377");
?>

charlist 인자에 문자 시퀀스를 정의할 때, 처음에서 끝 범위에 어떠한 문자가 들어가는지 확인하십시오.

<?php
echo addcslashes('foo[ ]', 'A..z');
// 출력:  \f\o\o\[ \]
// 모든 대문자와 소문자를 이스케이프합니다.
// ... 하지만 [\]^_`와 탭, 라인 피드,
// 캐리지 리턴 등도 이스케이프합니다.
?>

또한, 범위 지정에서 처음 문자가 나중 문자보다 큰 ASCII 값을 가지면 범위를 형성하지 않습니다. 단지 처음과 마지막, 피리오드(.)문자만을 이스케이프합니다. 문자의 ASCII 값을 찾아보려면 ord() 함수를 이용하십시오.

echo addcslashes("zoo['.']", 'z..A');
// 출력:  \zoo['\.']
?>

참고: stripcslashes(),
stripslashes(),
htmlspecialchars(),
quotemeta().

이전 | 처음으로 | 다음
문자열 함수 | 위로 | addslashes


addslashes

(PHP 3, PHP 4 , PHP 5)

addslashes -- 문자열에 슬래쉬를 덧붙입니다.

설명

string addslashes ( string str)

데이터베이스 쿼리 등에서 처리할 필요가 있는 문자 앞에 백슬래쉬를 붙인 문자열을 반환합니다. 이 문자들은 작은 따옴표('), 큰 따옴표("), 백슬래쉬(\), NUL(NULL 바이트)입니다.

addslashes()를 사용하는 대표적인 예는 데이터베이스에 데이터를 넣을 때 입니다. 예를 들어, 데이터베이스에 O'reilly라는 이름을 넣으려고 할때, 이스케이프할 필요가 있습니다. 대부분의 데이터베이스는 \을 사용하기에 O\'reilly가 되어야 합니다. 이 데이터를 데이터베이스에 넣으면 추가한 \은 저장되지 않습니다. PHP 지시어 magic_quotes_sybase를 on으로 설정하면 '은 '을 이용하여 이스케이프합니다.

PHP 지시어 magic_quotes_gpc는 기본값으로 on이고, 자동적으로 모든 GET, POST, COOKIE 데이터에 addslashes()을 실행합니다. magic_quotes_gpc로 이스케이프된 문자열에 addslashes()를 사용하지 마십시오. 그렇지 않으면 두번 이스케이프하게 됩니다. 이를 확인하기 위해서 get_magic_quotes_gpc()를 사용할 수 있습니다.

예 1. addslashes() 예제

<?php
$str = "Is your name O'reilly?";

// 출력: Is your name O\'reilly?
echo addslashes($str);
?>

참고: stripslashes(),
htmlspecialchars(),
quotemeta(), and
get_magic_quotes_gpc().

이전 | 처음으로 | 다음
AddCSlashes | 위로 | bin2hex


bin2hex

(PHP 3>= 3.0.9, PHP 4 , PHP 5)

bin2hex -- 바이너리 데이터를 16진수 표현으로 바꿉니다.

설명

string bin2hex ( string str)

str의 16진수 표현을 가지는 ASCII 문자열을 반환합니다. 변환은 하이-니블(high-nibble) 우선의 바이트 와이즈(byte-wise)로 이루어집니다.

참고: pack(), unpack().

이전 | 처음으로 | 다음
addslashes | 위로 | chop


chop

chop -- rtrim()의 별칭.

설명

이 함수는 rtrim()의 별칭입니다.

참고: chop()은 문자열의 마지막 글자를 제거하는 펄의 chop() 함수와 다릅니다.

이전 | 처음으로 | 다음
bin2hex | 위로 | chr


chr

(PHP 3, PHP 4 , PHP 5)

chr -- 특정 문자를 반환합니다.

설명

string chr ( int ascii)

ascii에 지정한 문자를 가지는 한 글자의 문자열을 반환합니다.

예 1. chr() 예제

<?php
$str = "The string ends in escape: ";
$str .= chr(27); /* $str의 마지막에 이스케이프 문자를 추가합니다. */

/* 종종 다음이 더욱 유용합니다. */

$str = sprintf("The string ends in escape: %c", 27);
?>

ASCII 표는 여기서 볼 수 있습니다: http://www.asciitable.com

이 함수는 ord()를 보충합니다. 참고: sprintf()의 포맷 문자열 %c.

이전 | 처음으로 | 다음
chop | 위로 | chunk_split


chunk_split

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

chunk_split -- 문자열을 작은 조각으로 나눕니다.

설명

string chunk_split ( string body [, int chunklen [, string end]])

문자열을 작은 조각으로 나눕니다. base64_encode 출력을 RFC 2045 의미에 맞게 변환할 때 쓸 수 있습니다. 모든 chunklen 문자마다 (기본값 76) end(기본값 "\r\n")를 추가합니다. 원 문자열은 변경하지 않고, 새로운 문자열을 반환합니다.

예 1. chunk_split() 예제

<?php
// RFC 2045 의의에 맞게 $data를 형식화
$new_string = chunk_split(base64_encode($data));
?>

참고: str_split(),
explode(), split(),
wordwrap(),
RFC 2045.

이전 | 처음으로 | 다음
chr | 위로 | convert_cyr_string


convert_cyr_string

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

convert_cyr_string -- 키릴 문자셋을 다른 것으로 변환합니다.

설명

string convert_cyr_string ( string str, string from, string to)

이 함수는 주어진 키릴 문자셋을 다른 것으로 변환합니다. from과 to 인자는 소스와 타겟 키릴 문자셋을 나타내는 하나의 문자입니다. 지원하는 타입은:

  • k - koi8-r

  • w - windows-1251

  • i - iso8859-5

  • a - x-cp866

  • d - x-cp866

  • m - x-mac-cyrillic

이전 | 처음으로 | 다음
chunk_split | 위로 | count_chars


count_chars

(PHP 4 , PHP 5)

count_chars -- 문자열 안에 사용한 문자에 대한 정보를 반환합니다.

설명

mixed count_chars ( string string [, int mode])

string 안의 모든 바이트값(0..255)의 발견 수를 세고 여러 방법으로 반환합니다. 선택적인 인자 mode의 기본값은 0입니다. mode에 따른 count_chars()의 반환값은 다음과 같습니다:

  • 0 - 바이트 값을 키로, 모든 바이트의 빈도를 값으로 가지는 배열.

  • 1 - 0과 같지만, 빈도가 1 이상인 바이트값만 반환합니다.

  • 2 - 0과 같지만, 빈도가 0인 바이트값만 반환합니다.

  • 3 - 사용한 모든 바이트값을 가지는 문자열을 반환합니다.

  • 4 - 사용하지 않은 모든 바이트값을 가지는 문자열을 반환합니다.

예 1. count_chars() 예제

<?php

$data = "Two Ts and one F.";

$result = count_chars($data, 0);

for ($i=0; $i < count($result); $i++) {
   if ($result[$i] != 0)
       echo "There were $result[$i] instance(s) of \"" , chr($i) , "\" in the string.\n";
}

?>

출력은:

There were 4 instance(s) of " " in the string.
There were 1 instance(s) of "." in the string.
There were 1 instance(s) of "F" in the string.
There were 2 instance(s) of "T" in the string.
There were 1 instance(s) of "a" in the string.
There were 1 instance(s) of "d" in the string.
There were 1 instance(s) of "e" in the string.
There were 2 instance(s) of "n" in the string.
There were 2 instance(s) of "o" in the string.
There were 1 instance(s) of "s" in the string.
There were 1 instance(s) of "w" in the string.

참고: strpos(), substr_count().

이전 | 처음으로 | 다음
convert_cyr_string | 위로 | crc32


crc32

(PHP 4 >= 4.0.1, PHP 5)

crc32 -- 문자열의 crc32값을 계산합니다.

설명

int crc32 ( string str)

str의 32비트 순환 반복 체크섬 값을 생성합니다. 보통 모든 데이터가 전송되었는지 확인하는 데에 사용합니다.

PHP의 정수형은 부호가 존재하기에, 많은 crc32 체크섬은 음수값을 가집니다. 부호 없는 crc32 체크섬의 문자 표현을 얻기 위해서는 sprintf()나 printf()에서 "%u" 형식을 사용할 필요가 있습니다.

이 예제는 printf() 함수로 어떻게 변환한 체크섬을 출력하는지 보여줍니다:

예 1. crc32 체크섬 표시하기

<?php
$checksum = crc32("The quick brown fox jumped over the lazy dog.");
printf("%u\n", $checksum);
?>

참고: md5(), sha1().

이전 | 처음으로 | 다음
count_chars | 위로 | crypt


crypt

(PHP 3, PHP 4 , PHP 5)

crypt -- 단방향 문자열 암호화(해슁).

설명

string crypt ( string str [, string salt])

crypt()는 표준 유닉스 DES 기반 암호화 알고리즘이나 시스템에서 사용할 수 있는 다양한 알고리즘을 사용하여 암호화한 문자열을 반환합니다. 인자는 암화화할 문자열과 암호화의 베이스로 사용하는 선택적인 salt를 가집니다. 자세한 정보는 ctype 함수에 관한 유닉스 man 페이지를 참고하십시오.

salt 인자를 지정하지 않으면, PHP가 무작위로 생성합니다.

몇몇 운영체제는 한가지 이상의 암호화 방식을 제공합니다. 사실, 종종 표준 DES 기반 암호화는 MD5 기반 암호화 알고리즘으로 대체되기도 합니다. 암호화 타입은 slat 인자에 의해 변경됩니다. 설치시에, PHP는 사용할 수 있는 암호화 함수를 판단하고, 다른 암호화 방식을 위한 salt를 받아들입니다. salt를 지정하지 않으면, PHP는 기본값으로 두 문자 salt를 자동 생성합니다. 단, 시스템의 기본 암호화 방식이 MD5라면, 무작위의 MD5 호환 salt를 생성합니다. PHP는 시스템에 일반적인 두 문자 salt를 적용할지 더 긴 12 문자 salt를 적용할 수 있는지를 알려주는 CRYPT_SALT_LENGTH 상수를 설정합니다.

자동 생성된 salt를 사용한다면, salt가 한번만 생성되는 점에 주의하십시오. 이 함수를 재귀 호출한다면, 표현과 보안 양쪽에 영향을 미칩니다.

표준 DES 기반 암호화 crypt()는 처음 두 문자가 salt 인 문자열을 출력합니다. 또한 str의 처음 8 문자만 사용하기에, 같은 8문자로 시작하는 긴 문자열은 (같은 salt를 사용하는 한) 같은 결과를 생성합니다.

crypt() 함수가 다양한 암호화 방식을 지원하는 시스템에서, 주어진 방식의 사용 가능 여부에 따라 다음 상수들이 0이나 1로 설정됩니다:

  • CRYPT_STD_DES - 2문자 salt를 가지는 표준 DES 기반 암호화

  • CRYPT_EXT_DES - 9문자 salt를 가지는 확장 DES 기반 암호화

  • CRYPT_MD5 - $1$로 시작하는 12문자 salt를 가지는 MD5 암호화

  • CRYPT_BLOWFISH - $2$로 시작하는 16문자 salt를 가지는 Blowfish 암호화

참고: crypt()는 단방향 알고리즘을 사용하기 때문에, decrypt 함수는 존재하지 않습니다.

예 1. crypt() 예제

<?php
$password = crypt("My1sTpassword"); // salt가 생성됩니다.

# 패스워드를 비교할 때, 다른 해슁 알고리즘을 사용하는 문제를
# 피하기 위해서, crypt()가 생성한 전체 결과를 salt로 주어야
# 합니다. (위에서 밝혔듯이, 표준 DES 기반 암호 해슁은 2 문자
# salt를 사용하지만, MD5 기반 해슁은 12 문자를 사용합니다)
if (crypt($user_input, $password) == $password) {
   echo "패스워드 확인!";
}
?>

참고: md5(), Mcrypt 확장.

이전 | 처음으로 | 다음
crc32 | 위로 | echo


echo

(PHP 3, PHP 4, PHP 5 )

echo -- 하나 이상의 문자열을 출력합니다.

설명

void echo ( string arg1 [, string argn...])

모든 인자를 출력합니다.

echo()은 실제 함수가 아니기에 (언어 구조입니다) 괄호를 사용할 필요가 없습니다. 실제로, 둘 이상의 인자를 사용할 때는 괄호를 사용해서는 안됩니다.

예 1. echo() 예제

<?php
echo "Hello World";

echo "이는 여러
줄을 표현합니다. 물론 뉴라인도
출력합니다.";

echo "이는 여러\n줄을 표현합니다. 물론 뉴라인도\n출력합니다.";

echo "문자 이스케이핑은 \"이렇게\" 합니다.";

// echo 구문 안에 변수를 사용할 수 있습니다.
$foo = "foobar";
$bar = "barbaz";

echo "foo는 $foo"; // foo는 foobar

// 배열을 사용할 수도 있습니다.
$bar = array("value" => "foo");

echo "이것은 {$bar['value']} !"; // 이것은 foo !

// 작은 따옴표는 변수값이 아닌, 변수명을 출력합니다.
echo 'foo는 $foo'; // foo는 $foo

// 다른 문자를 사용하지 않는다면, 바로 변수를 echo할 수 있습니다.
echo $foo;          // foobar
echo $foo,$bar;     // foobarbarbaz

// 몇몇 사람들은 결합 echo보다 복수 인자 사용을 선호합니다.
echo 'This ', 'string ', 'was ', 'made ', 'with multiple parameters.', chr(10);
echo 'This ' . 'string ' . 'was ' . 'made ' . 'with concatenation.' . "\n";

echo <<<END
이는 $variable 인터폴레이션을 가지는 여러 줄을
출력하는 "here document" 구문을 사용합니다. here
document 종료어는 줄에 세미콜론만을 가지고 있어야
하며, 어떠한 공백도 없어야하는 점에 주의하십시오!
END;
// echo는 함수가 아니기에, 다음 코드는 유효하지 않습니다.
($some_var) ? echo 'true' : echo 'false';

// 그러나, 다음 예제는 작동합니다.
($some_var) ? print('true'): print('false'); // print는 함수입니다.
echo $some_var ? 'true': 'false'; // 구문을 변경하여 처리
?>

echo()는 오프닝 태그에 이어지는 등호를 사용하는 짧은 구문을 가지고 있습니다. 이 짧은 구문은 short_open_tag 설정을 활성화 했을 때만 작동합니다.

I have <?=$foo?> foo.

print()와 echo()의 차이에 대해서는, FAQT의 Knowledge Base Article을 읽어보십시오: http://www.faqts.com/knowledge_base/view.phtml/aid/1/fid/40

참고: 이것은 함수가 아닌 언어 구조이기 때문에, 변수 함수 방식으로 호출할 수 없습니다.

참고:
print(),
printf(),
flush().

이전 | 처음으로 | 다음
crypt | 위로 | explode


explode

(PHP 3, PHP 4 , PHP 5)

explode -- 문자열을 주어진 문자열을 기준으로 분리합니다.

설명

array explode ( string separator, string string [, int limit])

separator 문자열을 경계로 나누어진 string의 부분 문자열로 이루어지는 배열을 반환합니다. limit를 지정하면 마지막 원소가 나머지 문자열 전체를 가지는 최대 limit개 원소의 배열을 반환합니다.

separator가 빈 문자열("")이면, explode()은 FALSE를 반환합니다. separator가 string에 존재하지 않으면, explode()는 string를 포함하는 배열을 반환합니다.

비록 implode()가 관습에 의해 인자의 순서를 뒤바뀌는 것을 허용하더라도, explode()는 그렇지 않습니다. 반드시 separator 인자가 string 인자 앞에 위치하도록 해야합니다.

참고: limit 인자는 PHP 4.0.1 에서 추가되었습니다.

예 1. explode() 예제

<?php
// 예제 1
$pizza  = "piece1 piece2 piece3 piece4 piece5 piece6";
$pieces = explode (" ", $pizza);
echo $pieces[0]; // piece1
echo $pieces[1]; // piece2

// 예제 2
$data = "foo:*:1023:1000::/home/foo:/bin/sh";
list($user, $pass, $uid, $gid, $gecos, $home, $shell) = explode(":", $data);
echo $user; // foo
echo $pass; // *

?>

참고: preg_split(), spliti(), split(), implode().

이전 | 처음으로 | 다음
echo | 위로 | fprintf


fprintf

(PHP 5)

fprintf -- 문자열을 형식화하여 스트림에 기록합니다.

설명

int fprintf ( resource handle, string format [, mixed args])

형식화 문자열 format에 따라 생성한 문자열을 handle에 지정한 스트림 리소스에 기록합니다.

포맷 문자열은 0개 이상의 지시어로 작성합니다: 보통의 문자(%을 제외)는 결과에 직접 복사되고, 변환 특정어는 각각의 인자로 치환됩니다. 이는 fprintf(), sprintf(), printf()에 적용됩니다.

각각의 변환 특정어는 퍼센트 사인(%) 뒤에 한개 이상의 요소를 순서대로 가집니다:

  1. 선택적인 패딩 지정어는 적합한 문자열 크기를 맞추기 위해 사용하는 문자를 결정합니다. 이는 스페이스 문자나 0(제로 문자)일 수 있습니다. 기본값은 스페이스입니다. 다른 패딩 문자는 작은 따옴표(')를 앞에 붙여서 지정할 수 있습니다. 아래의 예제를 참고하십시오.

  2. 선택적인 정렬 지정어는 결과를 좌측 정렬할지, 우측 정렬할지를 결정합니다. 기본값은 우측 정렬입니다; - 문자로 좌측 정렬로 변경합니다.

  3. 선택적인 수 폭 지정어는 얼마나 많은 문자를 (최소한) 이 변환의 결과에 포함할지를 결정합니다.

  4. 선택적인 정확도 지정어는 부동소수점 수에 소수점 아래에 몇자리까지 표시할지를 결정합니다. 이 옵션은 float가 아닌 형에는 유효하지 않습니다. (수를 형식화하는 다른 좋은 함수로 number_format()이 존재합니다.)

  5. 형 지정어는 인자의 데이터를 어떻게 취급할지 결정합니다. 가능한 형은:

    % - 단순한 퍼센트 문자. 인자는 필요하지 않습니다.
    b - 인자를 정수형으로 취급하고, 이진수로 표현합니다.
    c - 인자를 정수형으로 취급하고, ASCII 값에 해당하는 문자로 표현합니다.
    d - 인자를 정수형으로 취급하고, (부호 있는) 10진수로 표현합니다.
    u - 인자를 정수형으로 취급하고, 부호 없는 10진수로 표현합니다.
    f - 인자를 float로 취급하고, 부동소수점 수로 표현합니다.
    o - 인자를 정수형으로 취급하고, 8진수로 표현합니다.
    s - 인자를 문자열로 취급/표현합니다.
    x - 인자를 정수형으로 취급하고, (소문자를 사용하여) 16진수로 표현합니다.
    X - 인자를 정수형으로 취급하고, (대문자를 사용하여) 16진수로 표현합니다.

참고: printf(),
sprintf(),
sscanf(), fscanf(),
vsprintf(),
number_format().

예제

예 1. sprintf(): 제로 패드 정수형

<?php
$isodate = sprintf("%04d-%02d-%02d", $year, $month, $day);
?>

예 2. sprintf(): 통화 형식화

<?php
$money1 = 68.75;
$money2 = 54.35;
$money = $money1 + $money2;
// echo $money 는 "123.1"를 출력합니다;
$formatted = sprintf("%01.2f", $money);
// echo $formatted 는 "123.10"를 출력합니다.
?>

이전 | 처음으로 | 다음
explode | 위로 | get_html_translation_table


get_html_translation_table

(PHP 4 , PHP 5)

get_html_translation_table -- htmlspecialchars()와 htmlentities()에서 사용하는 변환표를 반환합니다.

설명

array get_html_translation_table ( int table [, int quote_style])

get_html_translation_table()은
htmlspecialchars()와
htmlentities()에서 내부적으로 사용하는 변환표를
반환합니다.

원하는 테이블을 지정할 수 있게 하는 두가지 새로운 상수(HTML_ENTITIES, HTML_SPECIALCHARS)가 존재합니다. 그리고 htmlspecialchars()와 htmlentities() 함수와 마찬가지로, 사용할 quote_style을 선택적으로 지정할 수 있습니다. 기본값은 ENT_COMPAT 모드입니다. 이 모드들에 대한 설명은 htmlspecialchars()를 참고하십시오.

예 1. 변환표 예제

<?php
$trans = get_html_translation_table(HTML_ENTITIES);
$str = "Hallo & <Frau> & Kr?mer";
$encoded = strtr($str, $trans);
?>
$encoded 변수는 다음을 가지게 됩니다: "Hallo &amp; &lt;Frau&gt; &amp; Kr&auml;mer".

다른 사용법으로, array_flip()과 함께 이 함수를 사용하여 역변환을 할 수 있습니다.

<?php
$trans = array_flip($trans);
$original = strtr($encoded, $trans);
?>

$original의 내용은: "Hallo & <Frau> & Kr?mer".

참고: htmlspecialchars(),
htmlentities(), strtr(),
array_flip().

이전 | 처음으로 | 다음
fprintf | 위로 | hebrev


hebrev

(PHP 3, PHP 4 , PHP 5)

hebrev -- 논리 헤브라이어 텍스트를 표시 텍스트로 변환합니다.

설명

string hebrev ( string hebrew_text [, int max_chars_per_line])

선택적인 max_chars_per_line 인자는 한 줄에 출력할 최대 문자 수를 지시합니다. 이 함수는 단어 중간에서 줄바꿈을 하지 않습니다.

참고: hebrevc().

이전 | 처음으로 | 다음
get_html_translation_table | 위로 | hebrevc


hebrevc

(PHP 3, PHP 4 , PHP 5)

hebrevc -- 개행 문자를 포함하여 논리 헤브라이어 텍스트를 표시 텍스트로 변환합니다.

설명

string hebrevc ( string hebrew_text [, int max_chars_per_line])

개행 문자(\n)를 "<br>\n"로 바꾼는 점을 제외하면, hebrev()와 동일합니다. 선택적인 max_chars_per_line 인자는 한 줄에 출력할 최대 문자 수를 지시합니다. 단어 중간에서는 줄바꿈을 하지 않습니다.

참고: hebrev().

이전 | 처음으로 | 다음
hebrev | 위로 | html_entity_decode


html_entity_decode

(PHP 4 >= 4.3.0, PHP 5)

html_entity_decode -- 모든 HTML 엔티티를 해당하는 문자로 변환합니다.

설명

string html_entity_decode ( string string [, int quote_style [, string charset]])

html_entity_decode()는 string의 모든 HTML 엔티티를 해당하는 문자로 변환합니다. htmlentities()의 역함수입니다.

두번째에 위치하는 선택적인 quote_style 인자는 '작은 따옴표'와 "큰 따옴표"를 어떻게 처리할지 정의합니다. 아래의 상수들을 사용할 수 있으며, 기본값은 ENT_COMPAT입니다:

표 1. 사용할 수 있는 quote_style 상수

상수명 | 설명
ENT_COMPAT | 큰 따옴표만 변환합니다.
ENT_QUOTES | 작은 따옴표와 큰 따옴표 둘 다 변환합니다.
ENT_NOQUOTES | 작은 따옴표와 큰 따옴표 둘 다 변환하지 않습니다.

세번째에 위치하는 선택적인 charset의 기본값은 ISO-8859-1 문자셋입니다. 이는 변환에 사용할 문자셋을 정의합니다.

PHP 4.3.0 이상에서 다음 문자셋을 지원합니다.

표 2. 지원 문자셋

문자셋 | 다른 이름 | 설명
ISO-8859-1 | ISO8859-1 | 서부 유럽어, Latin-1.
ISO-8859-15 | ISO8859-15 | 서부 유럽어, Latin-9. 유로 사인, Latin-1(ISO-8859-1)에 빠진 프랑스어와 핀란드어 문자 추가.
UTF-8 |  | ASCII 호환 멀티바이트 8비트 유니코드.
cp866 | ibm866, 866 | DOS-특정 키릴 문자셋. 이 문자셋은 4.3.2부터 지원합니다.
cp1251 | Windows-1251, win-1251, 1251 | 윈도우즈-특정 키릴 문자셋. 이 문자셋은 4.3.2부터 지원합니다.
cp1252 | Windows-1252, 1252 | 윈도우즈 특정 서부 유럽어 문자셋
KOI8-R | koi8-ru, koi8r | 러시아어. 이 문자셋은 4.3.2부터 지원합니다.
BIG5 | 950 | 중국어 번체, 주로 대만에서 사용.
GB2312 | 936 | 중국어 간체, 국가 표준 문자셋.
BIG5-HKSCS |  | 홍콩 확장을 포함한 Big5, 중국어 번체.
Shift_JIS | SJIS, 932 | 일본어.
EUC-JP | EUCJP | 일본어.

참고: 다른 문자셋에 대해서는 ISO-8859-1을 사용합니다.

예 1. HTML 엔티티 디코딩

<?php
$orig = "I'll \"walk\" the <b>dog</b> now";

$a = htmlentities($orig);

$b = html_entity_decode($a);

echo $a; // I'll &quot;walk&quot; the &lt;b&gt;dog&lt;/b&gt; now

echo $b; // I'll "walk" the <b>dog</b> now

// PHP 4.3.0 이전 사용자는 이렇게 할 수 있습니다:
function unhtmlentities($string)
{
    $trans_tbl = get_html_translation_table(HTML_ENTITIES);
    $trans_tbl = array_flip($trans_tbl);
    return strtr($string, $trans_tbl);
}

$c = unhtmlentities($a);

echo $c; // I'll "walk" the <b>dog</b> now

?>

참고: trim(html_entity_decode('&nbsp;'));는 문자열을 빈 문자열로 변환하지 않습니다. 이는 기본값인 ISO-8859-1 문자셋에서 '&nbsp;' 엔티티가 아스키 코드 32(trim()에서 잘라냄)가 아닌 아스키 코드 160(0xa0)이기 때문입니다.

참고: htmlentities(),
htmlspecialchars(),
get_html_translation_table(),
urldecode().

이전 | 처음으로 | 다음
hebrevc | 위로 | htmlentities


htmlentities

(PHP 3, PHP 4 , PHP 5)

htmlentities -- 해당하는 모든 문자를 HTML 엔티티로 변환합니다.

설명

string htmlentities ( string string [, int quote_style [, string charset]])

htmlentities()는 HTML 문자 엔티티에 존재하는 모든 문자를 엔티티로 변환하는 점을 제외하면, htmlspecialchars()와 완전히 동일합니다.

htmlspecialchars()와 같게, 두번째에 위치하는 선택적인 quote_style 인자는 '작은 따옴표'와 "큰 따옴표"를 어떻게 처리할지 정의합니다. 아래의 세 상수 중 하나를 가질 수 있으며, 기본값은 ENT_COMPAT입니다:

표 1. 사용할 수 있는 quote_style 상수

상수명 | 설명
ENT_COMPAT | 큰 따옴표만 변환합니다.
ENT_QUOTES | 작은 따옴표와 큰 따옴표 둘 다 변환합니다.
ENT_NOQUOTES | 작은 따옴표와 큰 따옴표 둘 다 변환하지 않습니다.

선택적인 quote 인자는 PHP 4.0.3부터 지원합니다.

htmlspecialchars()와 같게, 세번째에 위치하는 선택적인 charset 인자는 변환에 사용할 문자셋을 정의합니다. 이 인자는 PHP 4.1.0부터 지원합니다. 현재 기본값은 ISO-8859-1 문자셋입니다.

PHP 4.3.0 이상에서 다음 문자셋을 지원합니다.

표 2. 지원 문자셋

문자셋 | 다른 이름 | 설명
ISO-8859-1 | ISO8859-1 | 서부 유럽어, Latin-1.
ISO-8859-15 | ISO8859-15 | 서부 유럽어, Latin-9. 유로 사인, Latin-1(ISO-8859-1)에 빠진 프랑스어와 핀란드어 문자 추가.
UTF-8 |  | ASCII 호환 멀티바이트 8비트 유니코드.
cp866 | ibm866, 866 | DOS-특정 키릴 문자셋. 이 문자셋은 4.3.2부터 지원합니다.
cp1251 | Windows-1251, win-1251, 1251 | 윈도우즈-특정 키릴 문자셋. 이 문자셋은 4.3.2부터 지원합니다.
cp1252 | Windows-1252, 1252 | 윈도우즈 특정 서부 유럽어 문자셋
KOI8-R | koi8-ru, koi8r | 러시아어. 이 문자셋은 4.3.2부터 지원합니다.
BIG5 | 950 | 중국어 번체, 주로 대만에서 사용.
GB2312 | 936 | 중국어 간체, 국가 표준 문자셋.
BIG5-HKSCS |  | 홍콩 확장을 포함한 Big5, 중국어 번체.
Shift_JIS | SJIS, 932 | 일본어.
EUC-JP | EUCJP | 일본어.

참고: 다른 문자셋에 대해서는 ISO-8859-1을 사용합니다.

디코드(역변환)를 하려면 html_entity_decode()을 사용할 수 있습니다.

예 1. htmlentities() 예제

<?php
$str = "A 'quote' is <b>bold</b>";

// 출력: A 'quote' is &lt;b&gt;bold&lt;/b&gt;
echo htmlentities($str);

// 출력: A &#039;quote&#039; is &lt;b&gt;bold&lt;/b&gt;
echo htmlentities($str, ENT_QUOTES);
?>

참고: html_entity_decode(),
get_html_translation_table(),
htmlspecialchars(), nl2br(),
urlencode().

이전 | 처음으로 | 다음
html_entity_decode | 위로 | htmlspecialchars


htmlspecialchars

(PHP 3, PHP 4 , PHP 5)

htmlspecialchars -- 특수 문자를 HTML 엔터티로 변환합니다.

설명

string htmlspecialchars ( string string [, int quote_style [, string charset]])

어떤 문자들은 HTML에서 특별한 정의를 가지기에, 그 의미를 보존하려면, HTML 엔터티로 표현해야 합니다. 이 함수는 이러한 변환을 수행한 문자열을 반환합니다; 이 번역은 모든 웹 프로그래밍에서 매우 유용합니다. 모든 HTML 문자 엔터티를 번역해야 한다면, 이 함수 대신 htmlentities()를 사용하십시오.

이 함수로 게시판이나 방명록 등의 프로그램에서, HTML을 포함하는 사용자 입력 텍스트를 막을 수 있습니다. 선택적인 두번째 인자 quote_style은 작은 따옴표와 큰 따옴표를 어떻게 처리할지 결정합니다. 기본 모드는 하위 호환 모드 ENT_COMPAT로, 큰 따옴표만 변환합니다. ENT_QUOTES를 지정하면 작은 따옴표와 큰 따옴표 둘 다 변환하고, ENT_NOQUOTES를 지정하면 작은 따옴표와 큰 따옴표 둘 다 변환하지 않습니다.

다음 문자들을 변역합니다:

  • '&'(앰퍼샌드)는 '&amp;'가 됩니다.

  • '"'(큰 따옴표)는 ENT_NOQUOTES를 지정하지 않았을 때 '&quot;'가 됩니다.

  • '''(작은 따옴표)는 ENT_QUOTES를 지정했을 때만 '&#039;'가 됩니다.

  • '<'(보다 작음)는 '&lt;'가 됩니다.

  • '>'(보다 큼)는 '&gt;'가 됩니다.

예 1. htmlspecialchars() 예제

<?php
$new = htmlspecialchars("<a href='test'>Test</a>", ENT_QUOTES);
echo $new; // &lt;a href=&#039;test&#039;&gt;TEST&lt;/a&gt;
?>

이 함수는 위 목록 이외에는 아무 것도 번역하지 않는 점에 주의하십시오. 완전한 엔터티 번역을 위해서는, htmlentities()를 참고하십시오. 선택적인 두번째 인자는 PHP 3.0.17과 PHP 4.0.3에서 추가되었습니다.

선택적인 세번째 인자 charset은 변환에 사용하는 문자셋을 정의합니다. 기본 문자셋은 ISO-8859-1입니다. 세번째 인자는 PHP 4.1.0부터 지원합니다.

PHP 4.3.0 이상에서 다음 문자셋을 지원합니다.

표 1. 지원 문자셋

문자셋 | 다른 이름 | 설명
ISO-8859-1 | ISO8859-1 | 서부 유럽어, Latin-1.
ISO-8859-15 | ISO8859-15 | 서부 유럽어, Latin-9. 유로 사인, Latin-1(ISO-8859-1)에 빠진 프랑스어와 핀란드어 문자 추가.
UTF-8 |  | ASCII 호환 멀티바이트 8비트 유니코드.
cp866 | ibm866, 866 | DOS-특정 키릴 문자셋. 이 문자셋은 4.3.2부터 지원합니다.
cp1251 | Windows-1251, win-1251, 1251 | 윈도우즈-특정 키릴 문자셋. 이 문자셋은 4.3.2부터 지원합니다.
cp1252 | Windows-1252, 1252 | 윈도우즈 특정 서부 유럽어 문자셋
KOI8-R | koi8-ru, koi8r | 러시아어. 이 문자셋은 4.3.2부터 지원합니다.
BIG5 | 950 | 중국어 번체, 주로 대만에서 사용.
GB2312 | 936 | 중국어 간체, 국가 표준 문자셋.
BIG5-HKSCS |  | 홍콩 확장을 포함한 Big5, 중국어 번체.
Shift_JIS | SJIS, 932 | 일본어.
EUC-JP | EUCJP | 일본어.

참고: 다른 문자셋에 대해서는 ISO-8859-1을 사용합니다.

참고: get_html_translation_table(),
strip_tags(),
htmlentities(), nl2br().

이전 | 처음으로 | 다음
htmlentities | 위로 | implode


implode

(PHP 3, PHP 4 , PHP 5)

implode -- 문자열로 배열 요소를 결합합니다.

설명

string implode ( string glue, array pieces)

모든 배열 원소를 순서대로, 각각의 원소 사이에 glue 문자열을 덧붙인 문자열 표현을 반환합니다.

예 1. implode() 예제

<?php

$array = array('lastname', 'email', 'phone');
$comma_separated = implode(",", $array);

echo $comma_separated; // lastname,email,phone

?>

참고: implode()는 관습적인 이유로 인자의 순서를 바꾸는 것을 허용합니다. 그러나, explode()와의 일관성을 위해서 문서에 나온 인자의 순서를 사용하는 편이 혼동이 적을 것입니다.

참고: PHP 4.3.0부터 implode()의 glue 인자는 선택적이 되었고, 기본값으로 빈 문자열('')입니다. 이는 implode()의 권장하지 않는 사용법입니다. 이전 버전과의 호환을 위해서 항상 두개의 인자를 사용하기를 권장합니다.

참고: explode(), split().

이전 | 처음으로 | 다음
htmlspecialchars | 위로 | join


join

join -- implode()의 별칭.

설명

이 함수는 implode()의 별칭입니다.

이전 | 처음으로 | 다음
implode | 위로 | levenshtein


levenshtein

(PHP 3>= 3.0.17, PHP 4 >= 4.0.1, PHP 5)

levenshtein -- 두 문자열 사이의 Levenshtein distance를 계산합니다.

설명

int levenshtein ( string str1, string str2)

int levenshtein ( string str1, string str2, int cost_ins, int cost_rep, int cost_del)

int levenshtein ( string str1, string str2, function cost)

이 함수는 두 문자열 인자 사이의 Levenshtein-Distance를 반환합니다. 문자열 인자 중 하나가 255 문자 제한을 넘어갈 경우에는 -1을 반환합니다. (255는 이름이나 사전 비교에 충분하며, 누구도 PHP로 복잡한 일반 분석을 행하지 않습니다)

Levenshtein distance는 str1를 str2로 변환할 때 필요한 치환, 삽입, 삭제할 최소 문자 수로 정의됩니다. O(m*n)의 복잡한 알고리즘입니다. 여기서 n과 m은 str1과 str2의 길이입니다. (similar_test()의 O(max(n,m)**3)과 비교하면 좋지만, 여전히 비쌉니다)

함수의 가장 간단한 형식은 두 문자열을 받아서, str1을 str2로 변환하는데 필요한 삽입, 치환, 삭제 시행 수를 계산합니다.

두번째 형식은 삽입, 치환, 삭제 시행의 비용을 정의하는 세개의 추가 인자를 줄 수 있습니다. 이는 더욱 일반적이고 적용성이 높지만, 효율적이지 않습니다.

세번째 형식은 (아직 사용할 수 없습니다) 가장 일반적이고 적용성이 높지만, 또한 가장 느린 방법입니다. 이는 모든 시행의 비용을 계산하는 사용자 제공 함수를 호출합니다.

사용자 제공 함수는 다음 인자로 호출합니다:

  • 적용하는 시행: 'I', 'R' or 'D'

  • 문자열 1의 해당 문자

  • 문자열 2의 해당 문자

  • 문자열 1의 위치

  • 문자열 2의 위치

  • 문자열 1의 나머지 문자

  • 문자열 2의 나머지 문자

사용자 제공 함수는 해당하는 시행의 비용을 나타내는 양의 정수를 반환해야 합니다. 제공한 인자의 일부만을 사용하여 결정하여도 됩니다.

The user-supplied function approach offers the possibility to take into account the relevance of and/or difference between certain symbols (characters) or even the context those symbols appear in to determine the cost of insert, replace and delete operations, but at the cost of losing all optimizations done regarding cpu register utilization and cache misses that have been worked into the other two variants.

참고: soundex(),
similar_text(),
metaphone().

이전 | 처음으로 | 다음
join | 위로 | localeconv


localeconv

(PHP 4 >= 4.0.5, PHP 5)

localeconv -- 숫자 형식화 정보를 얻습니다.

설명

array localeconv ( void )

로케일의 숫자와 통화 형식화 정보를 포함하는 연관 배열을 반환합니다.

localeconv()는 setlocale()로 설정한 현재 로케일에 기반한 데이터를 반환합니다. 반환하는 연관 배열은 다음 필드를 포함하고 있습니다:

배열 원소 | 설명
decimal_point | 소수점 문자
thousands_sep | 천단위 구분자
grouping | 숫자 그루핑을 포함하는 배열
int_curr_symbol | 국제 통화 기호 (예. USD)
currency_symbol | 지역 통화 기호 (예. $)
mon_decimal_point | 통화 소수점 문자
mon_thousands_sep | 통화 천단위 구분자
mon_grouping | 통화 그루핑을 포함하는 배열
positive_sign | 양수 기호
negative_sign | 음수 기호
int_frac_digits | 국제 fractional 수
frac_digits | 지역 fractional 수
p_cs_precedes | TRUE if currency_symbol precedes a positive value, FALSE if it succeeds one
p_sep_by_space | 양수에서 currency_symbol을 공백으로 구분하면 TRUE 아니라면 FALSE
n_cs_precedes | TRUE if currency_symbol precedes a negative value, FALSE if it succeeds one
n_sep_by_space | 음수에서 currency_symbol을 공백으로 구분하면 TRUE 아니라면 FALSE
p_sign_posn

0 | Parentheses surround the quantity and currency_symbol
1 | The sign string precedes the quantity and currency_symbol
2 | The sign string succeeds the quantity and currency_symbol
3 | The sign string immediately precedes the currency_symbol
4 | The sign string immediately succeeds the currency_symbol

n_sign_posn

0 | Parentheses surround the quantity and currency_symbol
1 | The sign string precedes the quantity and currency_symbol
2 | The sign string succeeds the quantity and currency_symbol
3 | The sign string immediately precedes the currency_symbol
4 | The sign string immediately succeeds the currency_symbol

The grouping fields contain arrays that define the way numbers should be grouped. For example, the grouping field for the en_US locale, would contain a 2 item array with the values 3 and 3. The higher the index in the array, the farther left the grouping is. If an array element is equal to CHAR_MAX, no further grouping is done. If an array element is equal to 0, the previous element should be used.

예 1. localeconv() example

<?php
setlocale(LC_ALL, "en_US");

$locale_info = localeconv();

echo "<PRE>\n";
echo "--------------------------------------------\n";
echo "  Monetary information for current locale:  \n";
echo "--------------------------------------------\n\n";

echo "int_curr_symbol:   {$locale_info["int_curr_symbol"]}\n";
echo "currency_symbol:   {$locale_info["currency_symbol"]}\n";
echo "mon_decimal_point: {$locale_info["mon_decimal_point"]}\n";
echo "mon_thousands_sep: {$locale_info["mon_thousands_sep"]}\n";
echo "positive_sign:     {$locale_info["positive_sign"]}\n";
echo "negative_sign:     {$locale_info["negative_sign"]}\n";
echo "int_frac_digits:   {$locale_info["int_frac_digits"]}\n";
echo "frac_digits:       {$locale_info["frac_digits"]}\n";
echo "p_cs_precedes:     {$locale_info["p_cs_precedes"]}\n";
echo "p_sep_by_space:    {$locale_info["p_sep_by_space"]}\n";
echo "n_cs_precedes:     {$locale_info["n_cs_precedes"]}\n";
echo "n_sep_by_space:    {$locale_info["n_sep_by_space"]}\n";
echo "p_sign_posn:       {$locale_info["p_sign_posn"]}\n";
echo "n_sign_posn:       {$locale_info["n_sign_posn"]}\n";
echo "</PRE>\n";
?>

위와 같은 사용을 위해 CHAR_MAX 상수도 정의합니다.

참고: setlocale().

이전 | 처음으로 | 다음
levenshtein | 위로 | ltrim


ltrim

(PHP 3, PHP 4 , PHP 5)

ltrim -- 문자열 시작 부분의 공백을 제거합니다.

설명

string ltrim ( string str [, string charlist])

참고: 두번째 인자는 PHP 4.1.0에서 추가되었습니다.

str의 시작 부분에서 공백을 제거한 문자열을 반환합니다. 두번째 인자를 주지 않으면 ltrim()은 다음의 문자들을 제거합니다:

  • " " (ASCII 32 (0x20)), 일반적인 공백.

  • "\t" (ASCII 9 (0x09)), 탭.

  • "\n" (ASCII 10 (0x0A)), 뉴 라인 (줄 바꿈).

  • "\r" (ASCII 13 (0x0D)), 캐리지 리턴.

  • "\0" (ASCII 0 (0x00)), NUL-바이트.

  • "\x0B" (ASCII 11 (0x0B)), 수직 탭.

제거하고 싶은 문자들을 charlist 인자로 지정할 수 있습니다. 단순히 제거하고 싶은 모든 문자를 쓰면 됩니다. ..로 문자의 범위를 지정할 수 있습니다.

예 1. ltrim() 사용 예제

<?php

$text = "\t\tThese are a few words :) ...  ";
$trimmed = ltrim($text);
// $trimmed = "These are a few words :) ...  "
$trimmed = ltrim($text, " \t.");
// $trimmed = "These are a few words :) ...  "
$clean = ltrim($binary, "\0x00..\0x1F");
// $binary의 시작 부분에서 아스키 제어 문자를 제거합니다.
// (0부터 31까지)

?>

참고: trim(), rtrim().

이전 | 처음으로 | 다음
localeconv | 위로 | md5_file


md5_file

(PHP 4 >= 4.2.0, PHP 5)

md5_file -- 주어진 파일명의 md5 해쉬를 계산합니다.

설명

string md5_file ( string filename [, bool raw_output])

RSA Data Security, Inc. MD5 Message-Digest Algorithm를 사용하여 지정한 filename의 MD5 해쉬를 계산하여 반환합니다. 해쉬는 16진수의 32문자입니다. 선택적인 raw_output를 TRUE로 설정하면, md5 다이제스트는 16의 길이를 가지는 순수 바이너리 형식을 반환합니다.

참고: 선택적인 raw_output 인자는 PHP 5.0.0에서 추가되었으며, 기본값으로 FALSE입니다.

이 함수는 명령줄 유틸리티 md5sum과 동일한 목적을 가집니다.

참고: md5(), crc32(), sha1_file().

이전 | 처음으로 | 다음
ltrim | 위로 | md5


md5

(PHP 3, PHP 4 , PHP 5)

md5 -- 문자열의 md5 해쉬를 계산합니다.

설명

string md5 ( string str [, bool raw_output])

RSA Data Security, Inc. MD5 Message-Digest Algorithm을 사용하여 str의 MD5 해쉬를 계산하여 반환합니다. 해쉬는 16진수의 32문자입니다. 선택적인 raw_output를 TRUE로 설정하면, md5 다이제스트는 16의 길이를 가지는 순수 바이너리 형식으로 반환합니다.

참고: 선택적인 raw_output 인자는 PHP 5.0.0에서 추가되었고, 기본값으로 FALSE입니다.

예 1. md5() 예제

<?php
$str = 'apple';

if (md5($str) === '1f3870be274f6c49b3e31a0c6728957f') {
    echo "Would you like a green or red apple?";
    exit;
}
?>

참고: crc32(), md5_file(), sha1().

이전 | 처음으로 | 다음
md5_file | 위로 | metaphone


metaphone

(PHP 4 , PHP 5)

metaphone -- 문자열의 메타폰 키를 계산합니다.

설명

string metaphone ( string str)

str의 메타폰 키를 계산합니다.

soundex()처럼 메타폰은 유사한 발음의 단어에 대해 동일한 키를 생성합니다. 이 함수는 영어 발음의 기본 법칙을 사용하는soundex()보다 훨씬 정확합니다. 메타폰 생성 키는 가변 길이를 가집니다.

메타폰은 Lawrence Philips <lphilips at verity dot com>가 개발하였습니다. 이는 ["Practical Algorithms for Programmers", Binstock & Rex, Addison Wesley, 1995]에 수록되어 있습니다.

이전 | 처음으로 | 다음
md5 | 위로 | money_format


money_format

(PHP 4 >= 4.3.0, PHP 5)

money_format -- Formats a number as a currency string

Description

string money_format ( string format, float number)

money_format() returns a formatted version of number. This function wraps the C library function strfmon(), with the difference that this implementation converts only one number at a time.

참고: The function money_format() is only defined if the system has strfmon capabilities. For example, Windows does not, so money_format() is undefined in Windows.

The format specification consists of the following sequence:

  • a % character

  • optional flags

  • optional field width

  • optional left precision

  • optional right precision

  • a required conversion character

Flags. One or more of the optional flags below can be used:

=f

The character = followed by a a (single byte) character f to be used as the numeric fill character. The default fill character is space.

^

Disable the use of grouping characters (as defined by the current locale).

+ or (

Specify the formatting style for positive and negative numbers. If + is used, the locale's equivalent for + and - will be used. If ( is used, negative amounts are enclosed in parenthesis. If no specification is given, the default is +.

!

Suppress the currency symbol from the output string.

-

If present, it will make all fields left-justified (padded to the right), as opposed to the default which is for the fields to be right-justified (padded to the left).

Field width.

w

A decimal digit string specifying a minimum field width. Field will be right-justified unless the flag - is used. Default value is 0 (zero).

Left precision.

#n

The maximum number of digits (n) expected to the left of the decimal character (e.g. the decimal point). It is used usually to keep formatted output aligned in the same columns, using the fill character if the number of digits is less than n. If the number of actual digits is bigger than n, then this specification is ignored.

If grouping has not been suppressed using the ^ flag, grouping separators will be inserted before the fill characters (if any) are added. Grouping separators will not be applied to fill characters, even if the fill character is a digit.

To ensure alignment, any characters appearing before or after the number in the formatted output such as currency or sign symbols are padded as necessary with space characters to make their positive and negative formats an equal length.

Right precision .

.p

A period followed by the number of digits (p) after the decimal character. If the value of p is 0 (zero), the decimal character and the digits to its right will be omitted. If no right precision is included, the default will dictated by the current local in use. The amount being formatted is rounded to the specified number of digits prior to formatting.

Conversion characters .

i

The number is formatted according to the locale's international currency format (e.g. for the USA locale: USD 1,234.56).

n

The number is formatted according to the locale's national currency format (e.g. for the de_DE locale: DM1.234,56).

%

Returns the % character.

참고: The LC_MONETARY category of the locale settings, affects the behavior of this function. Use setlocale() to set to the appropriate default locale before using this function.

Characters before and after the formatting string will be returned unchanged.

예 1. money_format() Example

We will use different locales and format specifications to illustrate the use of this function.

<?php

$number = 1234.56;

// let's print the international format for the en_US locale
setlocale(LC_MONETARY, 'en_US');
echo money_format('%i', $number) . "\n";
// USD 1,234.56

// Italian national format with 2 decimals`
setlocale(LC_MONETARY, 'it_IT');
echo money_format('%.2n', $number) . "\n";
// L. 1.234,56

// Using a negative number
$number = -1234.5672;

// US national format, using () for negative numbers
// and 10 digits for left precision
setlocale(LC_MONETARY, 'en_US');
echo money_format('%(#10n', $number) . "\n";
// ($        1,234.57)

// Similar format as above, adding the use of 2 digits of right
// precision and '*' as a fill character
echo money_format('%=*(#10.2n', $number) . "\n";
// ($********1,234.57)

// Let's justify to the left, with 14 positions of width, 8 digits of
// left precision, 2 of right precision, withouth grouping character
// and using the international format for the de_DE locale.
setlocale(LC_MONETARY, 'de_DE');
echo money_format('%=*^-14#8.2i', 1234.56) . "\n";
// DEM 1234,56****

// Let's add some blurb before and after the conversion specification
setlocale(LC_MONETARY, 'en_GB');
$fmt = 'The final value is %i (after a 10%% discount)';
echo money_format($fmt, 1234.56) . "\n";
// The final value is  GBP 1,234.56 (after a 10% discount)

?>

See also: setlocale(),
number_format(),sprintf(),
printf() and sscanf().

이전 | 처음으로 | 다음
metaphone | 위로 | nl_langinfo


nl_langinfo

(PHP 4 >= 4.1.0, PHP 5)

nl_langinfo -- 언어와 로케일 정보를 얻습니다.

설명

string nl_langinfo ( int item)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
money_format | 위로 | nl2br


nl2br

(PHP 3, PHP 4 , PHP 5)

nl2br -- 문자열의 모든 줄바꿈 앞에 HTML 줄바꿈 태그를 삽입합니다.

설명

string nl2br ( string string)

모든 줄바꿈 앞에 '<br />'를 삽입한 string을 반환합니다.

참고: PHP 4.0.5부터, nl2br()은 XHTML과 호환합니다. 4.0.5 이전의 모든 버전은 줄바꿈 앞에 '<br />' 대신 '<br>'를 삽입한 string를 반환합니다.

예 1. nl2br() 사용하기

<?php
echo nl2br("foo isn't\n bar");
?>

출력은:

foo isn't<br />
 bar

참고: htmlspecialchars(),
htmlentities(),
wordwrap(),
str_replace().

이전 | 처음으로 | 다음
nl_langinfo | 위로 | number_format


number_format

(PHP 3, PHP 4 , PHP 5)

number_format -- Format a number with grouped thousands

Description

string number_format ( float number [, int decimals])

string number_format ( float number, int decimals, string dec_point, string thousands_sep)

number_format() returns a formatted version of number. This function accepts either one, two or four parameters (not three):

If only one parameter is given, number will be formatted without decimals, but with a comma (",") between every group of thousands.

If two parameters are given, number will be formatted with decimals decimals with a dot (".") in front, and a comma (",") between every group of thousands.

If all four parameters are given, number will be formatted with decimals decimals, dec_point instead of a dot (".") before the decimals and thousands_sep instead of a comma (",") between every group of thousands.

Only the first character of thousands_sep is used. For example, if you use foo as thousands_sep on the number 1000, number_format() will return 1f000.

예 1. number_format() Example

For instance, French notation usually use two decimals, comma (',') as decimal separator, and space (' ') as thousand separator. This is achieved with this line :

<?php

$number = 1234.56;

// english notation (default)
$english_format_number = number_format($number);
// 1,234

// French notation
$nombre_format_francais = number_format($number, 2, ',', ' ');
// 1 234,56

$number = 1234.5678;

// english notation without thousands seperator
$english_format_number = number_format($number, 2, '.', '');
// 1234.57

?>

See also: sprintf(), printf() and sscanf().

이전 | 처음으로 | 다음
nl2br | 위로 | ord


ord

(PHP 3, PHP 4 , PHP 5)

ord -- 문자의 아스키 값을 반환합니다.

설명

int ord ( string string)

string에서 첫번째 문자의 아스키 값을 반환합니다. 이 함수는 chr()을 보충합니다.

예 1. ord() 예제

$str = "\n";
if (ord($str) == 10) {
    echo "\$str의 첫번째 문자는 줄바꿈입니다.\n";
}

아스키 표는 http://www.asciitable.com에서 확인할 수 있습니다.

참고: chr().

이전 | 처음으로 | 다음
number_format | 위로 | parse_str


parse_str

(PHP 3, PHP 4 , PHP 5)

parse_str -- 문자열을 처리하여 변수를 생성합니다.

설명

void parse_str ( string str [, array arr])

str을 URL을 통한 질의 문자열처럼 처리하여, 현재 위치에 변수를 설정합니다. 두번째 인자 arr이 존재하면, 변수를 설정하는 대신 이 배열 변수의 원소로 저장합니다.

참고: 선택적인 두번째 인자는 PHP 4.0.3에서 추가되었습니다.

참고: 현지 QUERY_STRING을 얻으려면, $_SERVER['QUERY_STRING']를 사용할 수 있습니다. 또한, PHP 외부에서 들어오는 변수 섹션을 읽어보는 편이 좋습니다.

예 1. parse_str() 사용하기

<?php
$str = "first=value&arr[]=foo+bar&arr[]=baz";
parse_str($str);
echo $first;  // value
echo $arr[0]; // foo bar
echo $arr[1]; // baz

parse_str($str, $output);
echo $output['first'];  // value
echo $output['arr'][0]; // foo bar
echo $output['arr'][1]; // baz

?>

참고: parse_url(), pathinfo(),
set_magic_quotes_runtime(),
urldecode().

이전 | 처음으로 | 다음
ord | 위로 | print


print

(PHP 3, PHP 4, PHP 5 )

print -- 문자열을 출력합니다.

설명

int print ( string arg)

arg를 출력합니다. 항상 1을 반환합니다.

print()는 실제 함수가 아닙니다. (언어 구조입니다) 그러므로, 인자 목록에 괄호를 사용할 필요가 없습니다.

예 1. print() 예제

<?php
print("Hello World");

print "print()는 괄호 없이도 작동합니다.";

print "여러 줄로
사용할 수 있습니다. 줄바꿈 문자도
제대로 출력합니다";

print "여러 줄로\n사용할 수 있습니다. 줄바꿈 문자도\n제대로 출력합니다.";

print "이스케이핑 문자는 \"이렇게\" 합니다.";

// print 구문 안에서 변수를 사용할 수 있습니다.
$foo = "foobar";
$bar = "barbaz";

print "foo는 $foo"; // foo는 foobar

// 배열을 사용할 수 있습니다.
$bar = array("value" => "foo");

print "이것은 {$bar['value']} !"; // 이것은 foo !

// 변수값이 아닌, 변수명을 출력하려면 작은 따옴표를 사용하십시오.
print 'foo는 $foo'; // foo는 $foo

// 다른 문자을 사용하지 않는다면, 변수만 출력할 수 있습니다.
print $foo;          // foobar

print <<<END
이는 $varialbe을 써넣으면서 여러 줄을 출력하는
"here document"(여기는 문서) 구문의 사용입니다.
문서 종료어는 아무런 공백도 없이 단지 세미콜론
만을 가지는 점에 주의하십시오.
END;?>

print()와 echo()의 차이에 관한 간단한 설명은 FAQT의 Knowledge Base Article에서 볼 수 있습니다: http://www.faqts.com/knowledge_base/view.phtml/aid/1/fid/40

참고: 이것은 함수가 아닌 언어 구조이기 때문에, 변수 함수 방식으로 호출할 수 없습니다.

참고: echo(), printf(), flush().

이전 | 처음으로 | 다음
parse_str | 위로 | printf


printf

(PHP 3, PHP 4 , PHP 5)

printf -- 형식화한 문자열을 출력합니다.

설명

void printf ( string format [, mixed args])

sprintf() 문서에서 설명한 방법대로, format에 따른 출력을 생성합니다.

참고: print(), sprintf(),
vprintf(), sscanf(),
fscanf(), flush().

이전 | 처음으로 | 다음
print | 위로 | quoted_printable_decode


quoted_printable_decode

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

quoted_printable_decode -- 인용되어 있는 출력 가능 문자열을 8비트 문자열로 변환합니다.

설명

string quoted_printable_decode ( string str)

이 함수는 디코드된 인용되어 있는 출력 가능 문자열에 해당하는 8비트 바이너리 문자열을 반환합니다. IMAP 모듈이 없어도 작동한다는 점을 제외하고, imap_qprint()와 동일합니다.

이전 | 처음으로 | 다음
printf | 위로 | quotemeta


quotemeta

(PHP 3, PHP 4 , PHP 5)

quotemeta -- 메타 문자를 인용합니다.

설명

string quotemeta ( string str)

모든
. \\ + * ? [ ^ ] ( $ )
문자 앞에 백슬래쉬(\)를 덧붙인 str을 반환합니다.

참고: addslashes(),
htmlentities(),
htmlspecialchars(),
nl2br(),
stripslashes().

이전 | 처음으로 | 다음
quoted_printable_decode | 위로 | rtrim


rtrim

(PHP 3, PHP 4 , PHP 5)

rtrim -- 문자열 끝 부분의 공백을 제거합니다.

설명

string rtrim ( string str [, string charlist])

참고: 두번째 인자는 PHP 4.1.0에서 추가되었습니다.

str의 끝 부분에서 공백을 제거한 문자열을 반환합니다. 두번째 인자가 없으면, rtrim()은 다음 문자들을 제거합니다:

  • " " (ASCII 32 (0x20)), 보통의 공백.

  • "\t" (ASCII 9 (0x09)), 탭.

  • "\n" (ASCII 10 (0x0A)), 뉴라인. (줄바꿈)

  • "\r" (ASCII 13 (0x0D)), 캐리지 리턴.

  • "\0" (ASCII 0 (0x00)), NUL 바이트.

  • "\x0B" (ASCII 11 (0x0B)), 수직 탭.

charlist 인자를 통해서 제거하기를 원하는 문자를 지정할 수 있습니다. 간단히 제거하기를 원하는 모든 문자를 기록하면 됩니다. ..로 문자의 범위를 지정할 수 있습니다.

예 1. rtrim() 사용 예제

<?php

$text = "\t\tThese are a few words :) ...  ";
$trimmed = rtrim($text);
// $trimmed = "\t\tThese are a few words :) ..."
$trimmed = rtrim($text, " \t.");
// $trimmed = "\t\tThese are a few words :)"
$clean = rtrim($binary, "\0x00..\0x1F");
// $binary의 마지막 부분에서 아스키 제어 문자를 제거합니다.
// (0에서 31까지)

?>

참고: trim(), ltrim().

이전 | 처음으로 | 다음
quotemeta | 위로 | setlocale


setlocale

(PHP 3, PHP 4 , PHP 5)

setlocale -- 지역적보를 지정한다.

설명

string setlocale ( string category, string locale)

Category는 지역 세팅에 의해 영향을 받는 함수의 범주를 특성화 하는 문자열이다 :

  • LC_ALL - 이후 나오는 모든 것을 위해

  • LC_COLLATE - 문자열 비교를 위함 - 통상적으로 PHP에서는 실핻외지 않는다

  • LC_CTYPE - strtoupper()와 같이 문자 정형화와 변환을 위해.

  • LC_MONETARY - localeconv() 를 위해 - 통상적으로 PHP에서는 실핻외지 않는다

  • LC_NUMERIC - 십진 구분자를 위해

  • LC_TIME - strftime()와 함께 날자와 시간 표매팅을 위해

만약 locale이 빈 문자열 ""일 경우 로케일 이름은 위 카타고리의 이름과 같은 이름을 갖는 환경변수나 "LANG"으로 부터 세팅된다.

만약 로케일이 0 이거나 문자 "0"일 경우, 로케일 세팅은 영향을 받지 않고 단지 현재의 설정만이 반환된다.

Setlocale 은 새로운 현재 로케일이나, 로케일 기능이 플랫폼이서 수행되지 않거나, 특정 로케일이 존재하지 않거나 혹은 카테고리 이름이 유효하지 않을 경우 거짓을 반환한다. 유효하지 않은 카테고리 이름 역시 경고 메시지를 야기시킨다.

이전 | 처음으로 | 다음
rtrim | 위로 | sha1_file


sha1_file

(PHP 4 >= 4.3.0, PHP 5)

sha1_file -- 파일의 sha1 해쉬를 계산합니다.

설명

string sha1_file ( string filename [, bool raw_output])

US Secure Hash Algorithm 1을 사용하여, filename의 sha1 해쉬를 계산하여 반환합니다. 해쉬는 16진수를 나타내는 40 문자입니다. 실패하면 FALSE를 반환합니다. 선택적인 raw_output를 TRUE로 설정하면, 길이 20인 무변환 바이너리 형식의 sha1 다이제스트를 반환합니다.

참고: 선택적인 raw_output 인자는 PHP 5.0.0에서 추가되었고, 기본값은 FALSE입니다.

참고: sha1(), crc32(), md5_file()

이전 | 처음으로 | 다음
setlocale | 위로 | sha1


sha1

(PHP 4 >= 4.3.0, PHP 5)

sha1 -- 문자열의 sha1 해쉬를 계산합니다.

설명

string sha1 ( string str [, bool raw_output])

US Secure Hash Algorithm 1을 사용하여, str의 sha1 해쉬를 계산하여 반환합니다. 해쉬는 16진수를 나타내는 40 문자입니다. 선택적인 raw_output를 TRUE로 설정하면, 길이 20인 무변환 바이너리 형식의 sha1 다이제스트를 반환합니다.

참고: 선택적인 raw_output 인자는 PHP 5.0.0에서 추가되었고, 기본값은 FALSE입니다.

예 1. sha1() 예제

<?php
$str = 'apple';

if (sha1($str) === 'd0be2dc421be4fcd0172e5afceea3970e2f3d940') {
    echo "Would you like a green or red apple?";
    exit;
}
?>

참고: sha1_file(), crc32(), md5()

이전 | 처음으로 | 다음
sha1_file | 위로 | similar_text


similar_text

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

similar_text -- 두 문자열 간의 유사성을 계산합니다.

설명

int similar_text ( string first, string second [, float percent])

Oliver [1993]에서 설명한 방법으로 두 문자열 간의 유사성을 계산합니다. 이 수행은 Oliver's 표현 코드처럼 스택을 사용하지 않고, 전체 프로세스 속도를 향상하거나 저하할 수 있는 재귀 호출을 사용하는 점에 주의하십시오. 이 알고리즘의 복잡도는 O(N**3)이고, N은 가장 긴 문자열의 길이를 나타냅니다.

세번째 인자를 참조로 전달하면, similar_text()가 유사성을 백분율로 계산해줍니다. 이 함수는 두 문자열에서 매치하는 문자 수를 반환합니다.

이전 | 처음으로 | 다음
sha1 | 위로 | soundex


soundex

(PHP 3, PHP 4 , PHP 5)

soundex -- 문자열의 soundex 키를 계산합니다.

설명

string soundex ( string str)

str의 soundex 키를 계산합니다.

발음이 유사한 단어들은 같은 soundex 키를 생성하기에, 발음은 알고 있지만 스펠은 모르는 단어를 데이터베이스에서 쉽게 찾을 수 있습니다. soundex 함수는 문자로 시작하는 4 문자 문자열을 반환합니다.

이 soundex 함수는 "The Art Of Computer Programming, vol. 3: Sorting And Searching", Addison-Wesley (1973), 391-392쪽에서 Donald Knuth가 기술한 것입니다.

예 1. Soundex 예제

<?php
soundex("Euler") == soundex("Ellery"); // E460
soundex("Gauss") == soundex("Ghosh"); // G200
soundex("Hilbert") == soundex("Heilbronn"); // H416
soundex("Knuth") == soundex("Kant"); // K530
soundex("Lloyd") == soundex("Ladd"); // L300
soundex("Lukasiewicz") == soundex("Lissajous"); // L222
?>

참고: levenshtein(), metaphone(), similar_text().

이전 | 처음으로 | 다음
similar_text | 위로 | sprintf


sprintf

(PHP 3, PHP 4 , PHP 5)

sprintf -- 형식화한 문자열을 반환합니다.

설명

string sprintf ( string format [, mixed args])

포맷 문자열 format에 따라 생성한 문자열을 반환합니다.

포맷 문자열은 0개 이상의 지시어를 조합합니다: 일반 문자는 (%을 제외하고) 결과에 그대로 복사하고, 변환 특정어는 각각의 인자로 교체한 결과를 가집니다. 이는 sprintf()와 printf()에 모두 적용됩니다.

각각의 변환 특정어는 퍼센트 기호(%)에 다음의 요소들이 붙어서 구성됩니다:

  1. 선택적인 패딩 지정어는 적합한 문자열의 크기를 얻기 위한 패딩에 사용하는 문자를 지정합니다. 이는 스페이스 문자나 0 (제로 문자)일 수 있습니다. 기본값은 스페이스로 채웁니다. 다른 패딩 문자는 작은 따옴표(')를 앞에 붙여서 지정할 수 있습니다. 아래의 예제를 참고하십시오.

  2. 선택적인 정렬 지정어는 결과를 왼쪽 정렬할지, 오른쪽 정렬할 지를 결정합니다. 기본값은 오른쪽 정렬입니다; 여기에 - 문자를 사용하면 왼쪽 정렬이 됩니다.

  3. 선택적인 수, 너비 지정어는 얼마나 많은 문자(최소한)가 결과에 들어갈지를 결정합니다.

  4. 선택적인 정밀도 지정어는 부동 소수점 실수에서 얼마나 많은 소수점 아래의 수를 표시할지를 결정합니다. 이 옵션은 float형 이외에는 영향을 주지 않습니다. (수를 포맷하는 다른 유용한 함수에는 number_format()이 존재합니다.)

  5. 형 지정어는 인자 데이터를 어떤 형으로 취급할지 결정합니다. 가능한 형은:

    % - 퍼센트 문자. 인자는 필요하지 않습니다.
    b - 인자를 정수로 취급하고, 2진수로 표현합니다.
    c - 인자를 정수로 취급하고, ASCII 값에 해당하는 문자로 표현합니다.
    d - 인자를 정수로 취급하고, (부호 있는) 10진수로 표현합니다.
    u - 인자를 정수로 취급하고, 부호 없는 10진수로 표현합니다.
    f - 인자를 float로 취급하고, 실수로 표현합니다.
    o - 인자를 정수로 취급하고, 8진수로 표현합니다.
    s - 인자를 문자열로 취급하고 표현합니다.
    x - 인자를 정수로 취급하고 16진수(소문자 표시)로 표현합니다.
    X - 인자를 정수로 취급하고, 16진수(대문자 표시)로 표현합니다.

PHP 4.0.6부터 포맷 문자열은 인자 넘버링/교환을 지원합니다. 다음은 예제입니다:

예 1. 인자 교환

<?php
$format = "There are %d monkeys in the %s";
printf($format, $num, $location);
?>
이는 "There are 5 monkeys in the tree"를 출력할 것입니다. 그러나, 국제화를 위해서 포맷 문자열을 별도의 파일로 작성하고, 이것을 다음과 같이 재작성했다고 생각해봅시다:

예 2. 인자 교환

<?php
$format = "The %s contains %d monkeys";
printf($format, $num, $location);
?>
문제가 생겼습니다. 포맷 문자열에서의 순서와 코드에서 인자의 순서가 일치하지 않습니다. 여기서 코드를 수정하지 않고, 단순히 포맷 문자열에 어떤 인자를 가져올지를 지정할 수 있습니다. 포맷 문자열을 다음과 같이 작성하면 됩니다:

예 3. 인자 교환

<?php
$format = "The %2\$s contains %1\$d monkeys";
printf($format, $num, $location);
?>
코드에 많은 인자를 추가하지 않고도 반복해서 출력할 수 있다는 추가적인 장점이 존재합니다. 예를 들면:

예 4. 인자 교환

<?php
$format = "The %2\$s contains %1\$d monkeys.
           That's a nice %2\$s full of %1\$d monkeys.";
printf($format, $num, $location);
?>

참고: printf(),
sscanf(), fscanf(),
vsprintf(),
number_format().

예제

예 5. sprintf(): 제로로 채운 정수

<?php
$isodate = sprintf("%04d-%02d-%02d", $year, $month, $day);
?>

예 6. sprintf(): 통화 표현하기

<?php
$money1 = 68.75;
$money2 = 54.35;
$money = $money1 + $money2;
// echo $money 는 "123.1"를 출력합니다;
$formatted = sprintf("%01.2f", $money);
// echo $formatted 는 "123.10"를 출력합니다.
?>

이전 | 처음으로 | 다음
soundex | 위로 | sscanf


sscanf

(PHP 4 >= 4.0.1, PHP 5)

sscanf -- 문자열을 형식에 따라 처리합니다.

설명

mixed sscanf ( string str, string format [, string var1])

sscanf()은 printf()의 입력 형태입니다. sscanf()는 문자열 str을 읽어서 지정한 format에 따라 해석합니다. 인자를 두개만 지정하면, 처리한 값을 배열로 반환합니다.

포맷 문자열의 모든 종류의 공백은 입력 문자열의 어떠한 공백에도 매치합니다. 이는 포맷 문자열의 탭 \t이 입력 문자열의 하나의 스페이스 문자에도 매치한다는 것을 의미합니다.

예 1. sscanf() 예제

<?php
// 시리얼 번호 얻기
$serial = sscanf("SN/2350001", "SN/%d");
// 제조일 얻기
$mandate = "January 01 2000";
list($month, $day, $year) = sscanf($mandate, "%s %d %d");
echo "Item $serial was manufactured on: $year-" . substr($month, 0, 3) . "-$day\n";
?>
선택적인 인자를 지정하면, 할당한 값의 수를 반환합니다. 선택 인자는 참조로 전달해야 합니다.

예 2. sscanf() - 선택 인자 사용하기

<?php
// 작가 정보를 얻어서 DocBook 엔트리를 생성합니다.
$auth = "24\tLewis Carroll";
$n = sscanf($auth, "%d\t%s %s", &$id, &$first, &$last);
echo "<author id='$id'>
    <firstname>$first</firstname>
    <surname>$last</surname>
</author>\n";
?>

참고: fscanf(), printf(), sprintf().

이전 | 처음으로 | 다음
sprintf | 위로 | str_ireplace


str_ireplace

(PHP 5)

str_ireplace -- 대소문자를 구별하지 않는 str_replace().

설명

mixed str_ireplace ( mixed search, mixed replace, mixed subject [, int &count])

subject에서 (대소문자 구별 없이) 모든 search를 주어진 replace로 치환합니다. 복잡한 치환 규칙이 필요하지 않다면, eregi_replace()이나 preg_replace()에 i 변경자를 사용하는 대신, 이 함수를 사용하십시오.

subject가 배열이면, 검색 및 치환을 subject의 모든 원소에서 수행하고, 배열을 반환합니다.

search와 replace가 배열이면, str_ireplace()는 각각의 배열값을 subject에서 검색하고 치환하는 데에 사용합니다. replace가 search보다 적은 값을 가지고 있으면, 나머지 치환값은 빈 문자열을 사용합니다. search가 배열이고 replace가 문자열이면; 치환 문자열을 search의 모든 값에 사용합니다.

예 1. str_ireplace() 예제

<?php
$bodytag = str_ireplace("%body%", "black", "<body text=%BODY%>");
?>

이 함수는 바이너리 안전입니다.

참고: PHP 5.0.0부터 매치하여 교체한 needles의 수를 참조로 전달한 count로 반환합니다. PHP 5.0.0 이전에 이 인자는 사용할 수 없습니다.

참고:
str_replace(),
ereg_replace(),
preg_replace(),
strtr().

이전 | 처음으로 | 다음
sscanf | 위로 | str_pad


str_pad

(PHP 4 >= 4.0.1, PHP 5)

str_pad -- 문자열을 어떠한 길이가 되도록 다른 문자열로 채웁니다.

설명

string str_pad ( string input, int pad_length [, string pad_string [, int pad_type]])

지정한 길이가 되도록 왼쪽, 오른쪽, 혹은 양쪽 모두를 채워넣은 input 문자열을 반환합니다. 선택적인 인자 pad_string를 제공하지 않으면, input을 공백으로 채웁니다. 그렇지 않으면, pad_string의 문자들로 제한까지 채워넣습니다.

선택적인 인자 pad_type에는 STR_PAD_RIGHT, STR_PAD_LEFT, STR_PAD_BOTH를 사용할 수 있습니다. pad_type를 지정하지 않으면 STR_PAD_RIGHT를 사용합니다.

pad_length가 음수이거나 입력 문자열보다 작으면, 아무런 수행도 하지 않습니다.

예 1. str_pad() 예제

<?php
$input = "Alien";
echo str_pad($input, 10);                      // "Alien     "을 생성.
echo str_pad($input, 10, "-=", STR_PAD_LEFT);  // "-=-=-Alien"을 생성.
echo str_pad($input, 10, "_", STR_PAD_BOTH);   // "__Alien___"을 생성.
echo str_pad($input, 6 , "___");               // "Alien_"을 생성.
?>

참고: 채워넣을 문자 수가 pad_string의 길이로 정확히 나누어 지지 않을 경우, pad_string은 중간에 잘라집니다.

이전 | 처음으로 | 다음
str_ireplace | 위로 | str_repeat


str_repeat

(PHP 4 , PHP 5)

str_repeat -- 문자열을 반복합니다.

설명

string str_repeat ( string input, int multiplier)

multiplier번 반복한 input_str을 반환합니다. multiplier는 0 이상이여야 합니다. multiplier를 0으로 설정하면, 빈 문자열을 반환합니다.

예 1. str_repeat() 예제

<?php
echo str_repeat("-=", 10);
?>

이는 "-=-=-=-=-=-=-=-=-=-="를 출력합니다.

참고: for, str_pad(), substr_count().

이전 | 처음으로 | 다음
str_pad | 위로 | str_replace


str_replace

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

str_replace -- 발견한 모든 검색 문자열을 치환 문자열로 교체합니다.

설명

mixed str_replace ( mixed search, mixed replace, mixed subject [, int &count])

subject에서 발견한 모든 search를 주어진 replace 값으로 치환한 문자열이나 배열을 반환합니다. (정규표현식처럼) 복잡한 치환 규칙이 필요하지 않다면, 항상 ereg_replace()나 preg_replace() 대신 이 함수를 사용해야 합니다.

PHP 4.0.5부터, str_replace()의 모든 인자를 array로 지정할 수 있습니다.

주의

PHP 4.3.3 이전 버전에는 search와 replace 인자에 모두 배열을 사용할 경우, 빈 search 인덱스를 replace 배열의 내부 포인터를 옮기지 않은 채 넘어가는 버그가 존재했습니다. PHP 4.3.3에서 수정했기에, 이 버그에 관련된 모든 스크립트는 이전의 동작을 하려면 이 함수를 호출 하기 전에 빈 search값을 제거해야 합니다.

subject가 배열이면, 검색 및 치환을 subject의 모든 원소에서 수행하고, 배열을 반환합니다.

search와 replace가 배열이면, str_replace()는 각각의 배열에서 가져온 값을 subject의 검색과 치환에 사용합니다. replace가 search보다 적은 값을 가지면, 나머지 치환값은 빈 문자열을 사용합니다. search가 배열이고 replace가 문자열이면; 치환 문자열을 모든 search 값에 사용합니다.

예 1. str_replace() 예제

<?php
// 결과: <body text='black'>
$bodytag = str_replace("%body%", "black", "<body text='%body%'>");

// 결과: Hll Wrld f PHP
$vowels = array("a", "e", "i", "o", "u", "A", "E", "I", "O", "U");
$onlyconsonants = str_replace($vowels, "", "Hello World of PHP");

// 결과: You should eat pizza, beer, and ice cream every day
$phrase  = "You should eat fruits, vegetables, and fiber every day.";
$healthy = array("fruits", "vegetables", "fiber");
$yummy   = array("pizza", "beer", "ice cream");

$newphrase = str_replace($healthy, $yummy, $phrase);

// PHP 5.0.0부터 사용할 수있는 count 인자 사용
$str = str_replace("ll", "", "good golly miss molly!", $count);
echo $count; // 2
?>

참고: 이 함수는 바이너리 호환(binary-safe)입니다.

참고: PHP 5.0.0부터 매치하고 치환한 횟수를 참조로 전달하는 count로 반환할 수 있습니다. PHP 5.0.0 이전에는 이 인자를 사용할 수 없습니다.

참고:
str_ireplace(),
substr_replace(),
ereg_replace(),
preg_replace(),
strtr().

이전 | 처음으로 | 다음
str_repeat | 위로 | str_rot13


str_rot13

(PHP 4 >= 4.2.0, PHP 5)

str_rot13 -- 문자열에 rot13 변환을 수행합니다.

설명

string str_rot13 ( string str)

str 인자에 ROT13 인코딩을 수행하여, 결과 문자열을 반환합니다. ROT13 인코딩은 단순히 알파벳의 모든 문자를 13자리 쉬프트하고, 나머지 문자는 그대로 놔둡니다. 인코딩과 디코딩은 동일한 함수로 이루어집니다. 인코드한 문자열을 인자로 넘기면 원래 버전을 반환합니다.

예 1. str_rot13() 예제

<?php

echo str_rot13('PHP 4.3.0'); // CUC 4.3.0

?>

참고: PHP 4.3.0까지 이 함수에 버그가 있었습니다. 이 이전에는, str도 참조로 넘긴 것처럼 변경했습니다.

이전 | 처음으로 | 다음
str_replace | 위로 | str_shuffle


str_shuffle

(PHP 4 >= 4.3.0, PHP 5)

str_shuffle -- 문자열을 랜덤하게 섞습니다.

설명

string str_shuffle ( string str)

str_shuffle()은 문자열을 섞습니다. 가능한 모든 순열을 작성합니다.

예 1. str_shuffle() 예제

<?php
$str = 'abcdef';
$shuffled = str_shuffle($str);

// 이와 비슷한 출력을 보여줍니다: bfdaec
echo $shuffled;
?>

참고: shuffle(), rand().

이전 | 처음으로 | 다음
str_rot13 | 위로 | str_split


str_split

(PHP 5)

str_split -- 문자열을 배열로 변환합니다.

설명

array str_split ( string string [, int split_length])

문자열을 배열로 변환합니다. 선택적인 split_length 인자를 지정하면, 반환하는 배열은 split_length 길이의 원소로 나누어집니다. 지정하지 않으면 하나의 원소에 한 문자가 들어갑니다.

split_length가 1보다 작을 경우에는 FALSE를 반환합니다. split_length 길이가 string의 길이보다 클 경우, 문자열 전체를 첫번째 배열 원소로 반환합니다.

예 1. str_split() 사용 예제

<?php

$str = "Hello Friend";

$arr1 = str_split($str);
$arr2 = str_split($str, 3);

print_r($arr1);
print_r($arr2);

?>

출력은:

Array
(
    [0] => H
    [1] => e
    [2] => l
    [3] => l
    [4] => o
    [5] =>
    [6] => F
    [7] => r
    [8] => i
    [9] => e
    [10] => n
    [11] => d
)

Array
(
    [0] => Hel
    [1] => lo
    [2] => Fri
    [3] => end
)

예 2. str_split()에 관련한 예제

<?php

$str = "Hello Friend";

echo $str{0};  // H
echo $str{8};  // i

// 결과: array('H','e','l','l','o',' ','F','r','i','e','n','d')
$arr1 = preg_split('//', $str, -1, PREG_SPLIT_NO_EMPTY);

?>

참고: chuck_split(),
preg_split(),
split(),
count_chars(),
str_word_count(),
for.

이전 | 처음으로 | 다음
str_shuffle | 위로 | str_word_count


str_word_count

(PHP 4 >= 4.3.0, PHP 5)

str_word_count -- 문자열에서 사용한 단어에 대한 정보를 반환합니다.

설명

mixed str_word_count ( string string [, int format])

string 안의 단어 수를 셉니다. 선택적인 format을 지정하지 않으면, 반환값은 단어 수를 나타내는 정수입니다. format를 지정하면, 반환값은 배열로써, 내용은 format에 따라 결정됩니다. 아래 목록은 format으로 사용할 수 있는 값과 그에 따른 출력입니다.

  • 1 - string에서 발견한 모든 단어를 포함하는 배열을 반환합니다.

  • 2 - string 안에서 단어 위치를 키로, 그 단어를 값으로 가지는 연관 배열을 반환합니다.

이 함수의 작동에서, '단어'는 알파벳 문자를 포함하는 로케일 의존 문자열로, "'"'와 "-" 문자로 시작하지 않는 문자들을 포함합니다.

예 1. str_word_count() 사용 예제

<?php

$str = "Hello friend, you're
        looking          good today!";

$a   = str_word_count($str, 1);
$b   = str_word_count($str, 2);
$c   = str_word_count($str);

print_r($a);
print_r($b);
echo $c;
?>

출력은:

Array
(
    [0] => Hello
    [1] => friend
    [2] => you're
    [3] => looking
    [4] => good
    [5] => today
)

Array
(
    [0] => Hello
    [6] => friend
    [14] => you're
    [29] => looking
    [46] => good
    [51] => today
)

6

참고: explode(),
preg_split(),
split(),
count_chars(),
substr_count().

이전 | 처음으로 | 다음
str_split | 위로 | strcasecmp


strcasecmp

(PHP 3>= 3.0.2, PHP 4 , PHP 5)

strcasecmp -- 대소문자를 구별하지 않는 바이너리 호환 문자열 비교

설명

int strcasecmp ( string str1, string str2)

str1이 str2보다 작다면 < 0 을 반환하고; str1이 str2보다 크다면 > 0 을 반환합니다. 동일하다면 0을 반환합니다.

예 1. strcasecmp() 예제

<?php
$var1 = "Hello";
$var2 = "hello";
if (strcasecmp($var1, $var2) == 0) {
    echo '대소문자를 구별하지 않는 문자열 비교에서 $var1은 $var2와 동일합니다.';
}
?>

참고: ereg(), strcmp(),
substr(), stristr(),
strncasecmp(), strstr().

이전 | 처음으로 | 다음
str_word_count | 위로 | strchr


strchr

strchr -- strstr()의 별칭.

설명

이 함수는 strstr()의 별칭입니다.

이전 | 처음으로 | 다음
strcasecmp | 위로 | strcmp


strcmp

(PHP 3, PHP 4 , PHP 5)

strcmp -- 바이너리 호환 문자열 비교

설명

int strcmp ( string str1, string str2)

str1이 str2보다 작다면 < 0을 반환하고; str1이 str2보다 크다면 > 0을 반환합니다. 동일하면 0을 반환합니다.

이 비교가 대소문자를 구별하는 점에 주의하십시오.

참고: ereg(),
strcasecmp(), substr(),
stristr(), strncasecmp(),
strncmp(), strstr().

이전 | 처음으로 | 다음
strchr | 위로 | strcoll


strcoll

(PHP 4 >= 4.0.5, PHP 5)

strcoll -- 로케일 기반 문자열 비교

설명

int strcoll ( string str1, string str2)

str1이 str2보다 작으면 < 0를; str1이 str2보다 크면 > 0를, 동일하면 0을 반환합니다. strcoll()은 비교에 현재 로케일을 사용합니다. 현재 로케일이 C나 POSIX이면, 이 함수는 strcmp()와 동일합니다.

이 비교는 대소문자를 구별하며, strcmp()와는 다르게 바이너리 호환이 아닙니다.

참고: strcoll()은 PHP 4.0.5에서 추가되었지만, win32에서는 4.2.3까지 사용할 수 없었습니다.

참고: ereg(), strcmp(),
strcasecmp(), substr(),
stristr(), strncasecmp(),
strncmp(), strstr(),
setlocale().

이전 | 처음으로 | 다음
strcmp | 위로 | strcspn


strcspn

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

strcspn -- 마스크에 매칭하지 않는 처음 세그먼트의 길이를 찾습니다.

설명

int strcspn ( string str1, string str2)

str1에서 str2 내의 어떠한 문자도 포함하지 않는 첫번째 세그먼트의 길이를 반환합니다.

참고: strspn().

이전 | 처음으로 | 다음
strcoll | 위로 | strip_tags


strip_tags

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

strip_tags -- 문자열에서 HTML과 PHP 태그를 제거합니다.

설명

string strip_tags ( string str [, string allowable_tags])

주어진 str에서 모든 HTML과 PHP 태그를 제거한 문자열을 반환합니다. 이 함수는 fgetss() 함수와 동일한 태그 제거 방식을 사용합니다.

선택적인 두번째 인자로 제거하지 않을 태그를 지정할 수 있습니다.

참고: allowable_tags은 PHP 3.0.13과 PHP 4.0b3에서 추가되었습니다. PHP 4.3부터 HTML 주석도 제거합니다.

주의

strip_tags()는 HTML의 유효성을 검사하지 않기 때문에, 부분적이거나 깨진 태그는 예상 외의 텍스트/데이터를 제거할 수 있습니다.

예 1. strip_tags() 예제

<?php
$text = '
<p>테스트 문단.</p>
<!-- 주석 -->
다른 텍스트';

echo strip_tags($text);

echo "\n\n--------\n";

// <p>를 허용.
echo strip_tags($text, '<p>');
?>

위 예제의 출력은:

테스트 문단.

다른 텍스트

--------

<p>테스트 문단.</p>

다른 텍스트

주의

이 함수는 allowable_tags를 사용하여 허용한 태그 안의 어떠한 속성도 변경하지 않습니다. 악성 사용자가 다른 사용자에게 보여지는 텍스트를 게시할 때 style이나 onmouserover 속성을 사용하여 악용할 수 있습니다.

참고: htmlspecialchars().

이전 | 처음으로 | 다음
strcspn | 위로 | stripcslashes


stripcslashes

(PHP 4 , PHP 5)

stripcslashes -- addcslashes()로 처리한 문자열을 되돌립니다.

설명

string stripcslashes ( string str)

백슬래쉬를 제거한 문자열을 반환합니다. C 형식의 \n, \r ..., 8진과 16진 표현도 인식합니다.

참고: addcslashes().

이전 | 처음으로 | 다음
strip_tags | 위로 | stripos


stripos

(PHP 5)

stripos -- 대소문자를 구별하지 않고 문자열이 처음 나타나는 위치를 찾습니다.

설명

int stripos ( string haystack, string needle [, int offset])

haystack string에서 needle이 처음 나타나는 수 위치를 반환합니다. strpos()와 달리, stripos()는 대소문자를 구별하지 않습니다.

needle는 한 문자 이상의 문자열이여야 합니다.

needle을 발견하지 못하면, stripos()는 boolean FALSE를 반환합니다.

주의

이 함수는 Boolean FALSE를 반환하지만, 0이나 ""와 같은 FALSE로 취급하는 Boolean이 아닌 값을 반환할 수도 있습니다. Booleans 섹션에서 자세한 정보를 얻을 수 있습니다. 이 함수의 반환값을 테스트하기 위해서 === 연산자를 이용하십시오.

예 1. stripos() 예제

<?php
$findme    = 'a';
$mystring1 = 'xyz';
$mystring2 = 'ABC';

$pos1 = stripos($mystring1, $findme);
$pos2 = stripos($mystring2, $findme);

// 'a'는 'xyz' 안에 없습니다.
if ($pos1 === false) {
    echo "문자열 '$findme'은 문자열 '$mystring1'에서 발견할 수 없습니다.";
}

// ===를 사용하는 점에 주의하십시오. ==는 'a'가 0번째
// (처음) 문자기에, 기대하는대로 작동하지 않습니다.
if ($pos2 !== false) {
    echo "'$findme'를 '$mystring2' 위치 $pos2에서 찾았습니다.";
}
?>

needle이 문자열이 아니라면, 정수로 변환하여, 해당하는 값의 문자로 적용합니다.

선택적인 offset 인자로 haystack의 몇번째 문자에서 검색을 시작할지 지정할 수 있습니다. 위치는 여전히 haystack의 처음부터 세어집니다.

참고: strpos(), strrpos(),
strrchr(), substr(),
stristr(), strstr(),
strripos(), str_ireplace().

이전 | 처음으로 | 다음
stripcslashes | 위로 | stripslashes


stripslashes

(PHP 3, PHP 4 , PHP 5)

stripslashes -- addslashes()로 처리한 문자열을 되돌립니다.

설명

string stripslashes ( string str)

백슬래쉬를 제거한 문자열을 반환합니다. (\'이 '로 되는 방식입니다) 이중 백슬래쉬(\\)는 단일 백슬래쉬(\)로 만듭니다.

PHP 지시어 magic_quotes_gpc가 on(기본값으로 on입니다)일 때, 데이터를 이스케이프가 필요한 장소(데이터베이스 등)에 놓지 않을 경우의 사용 예제입니다. 예를 들면, HTML 폼에서 전달한 데이터를 단순히 바로 출력할 경우입니다.

예 1. stripslashes() 예제

<?php
$str = "Is your name O\'reilly?";

// 출력: Is your name O'reilly?
echo stripslashes($str);
?>

참고: addslashes(), get_magic_quotes_gpc().

이전 | 처음으로 | 다음
stripos | 위로 | stristr


stristr

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

stristr -- 대소문자를 구별하지 않는 strstr()

설명

string stristr ( string haystack, string needle)

haystack에서 첫번째 나타나는 needle부터 마지막까지 반환합니다. needle과 haystack은 대소문자를 구별하지 않습니다.

needle이 발견되지 않으면 FALSE를 반환합니다.

needle이 문자열이 아니면, 정수로 변환하고, 해당하는 순서의 문자값을 적용합니다.

예 1. stristr() 예제

<?php
  $email = 'USER@EXAMPLE.com';
  $domain = stristr($email, 'e');
  echo $domain;
// 출력: ER@EXAMPLE.com
?>

참고: strchr(),
strrchr(), substr(),
ereg().

이전 | 처음으로 | 다음
stripslashes | 위로 | strlen


strlen

(PHP 3, PHP 4 , PHP 5)

strlen -- 문자열의 길이를 구합니다.

설명

int strlen ( string str)

string의 길이를 반환합니다.

예 1. strlen() 예제

<?php
$str = 'abcdef';
echo strlen($str); // 6

$str = ' ab cd ';
echo strlen($str); // 7
?>

참고: count().

이전 | 처음으로 | 다음
stristr | 위로 | strnatcasecmp


strnatcasecmp

(PHP 4 , PHP 5)

strnatcasecmp -- "natural order" 알고리즘을 이용한 대소문자를 구별하지 않는 문자열 비교.

설명

int strnatcasecmp ( string str1, string str2)

사람이 하는 것과 동일한 방법으로 알파벳과 숫자 문자열의 순서를 비교하는 알고리즘을 수행합니다. 이 작동은 대소문자를 구별하지 않는 점을 제외하면, strnatcmp()와 동일합니다. 자세한 정보는 Martin Pool의 Natural Order String Comparison 페이지를 참고하십시오.

다른 문자열 비교 함수와 동일하게, str1이 str2보다 작다면 < 0을, str1이 str2보다 크다면 > 0을, 같다면 0을 반환합니다.

참고: ereg(),
strcasecmp(), substr(),
stristr(), strcmp(),
strncmp(), strncasecmp(),
strnatcmp(), strstr().

이전 | 처음으로 | 다음
strlen | 위로 | strnatcmp


strnatcmp

(PHP 4 , PHP 5)

strnatcmp -- "natural order" 알고리즘을 이용한 문자열 비교

설명

int strnatcmp ( string str1, string str2)

사람이 하는 것과 같은 방법으로 알파벳과 숫자로 이루어진 문자열의 비교 알고리즘, "natural ordering"을 수행합니다. 아래는 이 알고리즘과 컴퓨터가 사용하는 정렬 알고리즘(strcmp()에서 사용)의 차이입니다:

<?php
$arr1 = $arr2 = array("img12.png", "img10.png", "img2.png", "img1.png");
echo "표준 문자열 비교\n";
usort($arr1, "strcmp");
print_r($arr1);
echo "\nNatural order 문자열 비교\n";
usort($arr2, "strnatcmp");
print_r($arr2);
?>

위 코드는 아래의 결과를 생성합니다:

표준 문자열 비교
Array
(
    [0] => img1.png
    [1] => img10.png
    [2] => img12.png
    [3] => img2.png
)

Natural order 문자열 비교
Array
(
    [0] => img1.png
    [1] => img2.png
    [2] => img10.png
    [3] => img12.png
)

자세한 정보는 Martin Pool의 Natural Order String Comparison 페이지를 참고하십시오.

다른 문자열 비교 함수와 동일하게, str1이 str2보다 작으면 < 0을; str1이 str2보다 크면 > 0을, 같으면 0을 반환합니다.

이 비교는 대소문자를 구별함에 주의하십시오.

참고: ereg(),
strcasecmp(), substr(),
stristr(), strcmp(),
strncmp(), strncasecmp(),
strnatcasecmp(), strstr(),
natsort(), natcasesort().

이전 | 처음으로 | 다음
strnatcasecmp | 위로 | strncasecmp


strncasecmp

(PHP 4 >= 4.0.2, PHP 5)

strncasecmp -- 대소문자를 구별하지 않는 처음 n 문자의 이진 호환 문자열 비교

설명

int strncasecmp ( string str1, string str2, int len)

비교에 사용하는 각각의 문자열에서 (길이 제한) 비교할 문자 수(len)를 지정할 수 있는 차이를 제외하면, strcasecmp()와 동일합니다.

str1이 str2보다 작으면 < 0을; str1이 str2보다 크면 > 0을, 같으면 0을 반환합니다.

참고: ereg(), strcasecmp(),
strcmp(), substr(),
stristr(), strstr().

이전 | 처음으로 | 다음
strnatcmp | 위로 | strncmp


strncmp

(PHP 4 , PHP 5)

strncmp -- 처음 n 문자의 이진 호환 문자열 비교

설명

int strncmp ( string str1, string str2, int len)

이 함수는 비교에 사용하는 각각의 문자열에서 (길이를 제한하는) 문자 수(len)를 지정할 수 있는 차이를 제외하면, strcmp()와 동일합니다.

str1이 str2보다 작으면 < 0을; str1이 str2보다 크면 > 0을, 같으면 0을 반환합니다.

이 비교가 대소문자를 구별하는 점에 주의하십시오.

참고: ereg(), strncasecmp(),
strcasecmp(), substr(),
stristr(), strcmp(),
strstr().

이전 | 처음으로 | 다음
strncasecmp | 위로 | strpos


strpos

(PHP 3, PHP 4 , PHP 5)

strpos -- 문자열이 처음 나타나는 위치를 찾습니다.

설명

int strpos ( string haystack, string needle [, int offset])

haystack 문자열에서 needle이 처음 나타나는 수 위치를 반환합니다. strrpos()와는 달리, 이 함수는 needle 인자로 완전한 문자열을 받아서 전체 문자열을 사용합니다.

needle을 발견하지 못하면, strpos()는 boolean FALSE를 반환합니다.

주의

이 함수는 Boolean FALSE를 반환하지만, 0이나 ""와 같은 FALSE로 취급하는 Boolean이 아닌 값을 반환할 수도 있습니다. Booleans 섹션에서 자세한 정보를 얻을 수 있습니다. 이 함수의 반환값을 테스트하기 위해서 === 연산자를 이용하십시오.

예 1. strpos() 예제

<?php
$mystring = 'abc';
$findme   = 'a';
$pos = strpos($mystring, $findme);

// ===를 사용하는 점에 주의하십시오. ==는 'a'가 0번째
// (처음) 문자이기에 기대하는 대로 작동하지 않습니다.
if ($pos === false) {
    echo "'$findme' 문자열을 '$mystring' 문자열에서 찾지 못했습니다.";
} else {
    echo "'$findme' 문자열을 '$mystring' 문자열에서 찾았습니다.";
    echo "위치 $pos에 존재합니다.";
}

// offset 전의 모든걸 무시하고 문자를 찾을 수 있습니다.
$newstring = 'abcdef abcdef';
$pos = strpos($newstring, 'a', 1); // $pos = 7, not 0
?>

needle이 문자열이 아니라면, 정수로 변환하여 해당하는 값의 문자를 적용합니다.

선택적인 offset 인자로 haystack에서 검색을 시작할 문자 위치를 지정할 수 있습니다. 반환하는 위치는 여전히 haystack의 시작 위치로부터 세어집니다.

참고: strrpos(),
stripos(),
strripos(),
strrchr(),
substr(),
stristr(),
strstr().

이전 | 처음으로 | 다음
strncmp | 위로 | strrchr


strrchr

(PHP 3, PHP 4 , PHP 5)

strrchr -- 문자열에서 문자가 마지막으로 나오는 부분을 찾습니다.

설명

string strrchr ( string haystack, string needle)

이 함수는 needle가 마지막으로 나오는 위치부터 haystack의 마지막까지의 haystack 문자열 부분을 반환합니다.

needle이 발견되지 않으면, FALSE를 반환합니다.

needle이 한 문자 이상을 포함하고 있으면, 첫번째 문자를 사용합니다.

needle이 문자열이 아닐 경우, 정수형으로 변환하여 그 수에 해당하는 문자를 적용합니다.

예 1. strrchr() 예제

<?php
// $PATH에서 마지막 디렉토리를 얻는다.
$dir = substr(strrchr($PATH, ":"), 1);

// 마지막 줄바꿈 다음의 문자열을 얻는다.
$text = "줄 1\n줄 2\n줄 3";
$last = substr(strrchr($text, 10), 1);
?>

참고: strchr(), substr(), stristr(), strstr().

이전 | 처음으로 | 다음
strpos | 위로 | strrev


strrev

(PHP 3, PHP 4 , PHP 5)

strrev -- 문자열을 뒤집습니다.

설명

string strrev ( string string)

뒤집은 string을 반환합니다.

예 1. strrev()를 사용하여 문자열 뒤집기

<?php
echo strrev("Hello world!"); // "!dlrow olleH"를 출력
?>

이전 | 처음으로 | 다음
strrchr | 위로 | strripos


strripos

(PHP 5)

strripos -- 문자열에서 대소문자 구별 없이 문자열이 나타나는 마지막 위치를 찾습니다.

설명

int strripos ( string haystack, string needle [, int offset])

haystack 문자열에서 마지막으로 needle가 나타나는 숫자 위치를 반환합니다. strrpos()와는 달리, strripos()는 대소문자를 구별하지 않습니다. 문자열 위치는 1이 아닌, 0에서 시작하는 점에 주의하십시오.

needle은 하나 이상의 문자를 가지는 문자열이여야 합니다.

needle이 발견되지 않으면, FALSE를 반환합니다.

주의

이 함수는 Boolean FALSE를 반환하지만, 0이나 ""와 같은 FALSE로 취급하는 Boolean이 아닌 값을 반환할 수도 있습니다. Booleans 섹션에서 자세한 정보를 얻을 수 있습니다. 이 함수의 반환값을 테스트하기 위해서 === 연산자를 이용하십시오.

예 1. 간단한 strripos() 예제

<?php
$haystack = 'ababcd';
$needle   = 'aB';

$pos      = strripos($haystack, $needle);

if ($pos === false) {
    echo "($haystack)에서 ($needle)를 찾지 못했습니다.";
} else {
    echo "축하합니다!\n";
    echo "($haystack)의 위치 ($pos)에서 마지막 ($needle)를 찾았습니다.";
}
?>

출력:

축하합니다!
   (ababcd)의 위치 (2)에서 마지막 (aB)를 찾았습니다.

offset 인수는 문자열에서 찾기 시작할 위치를 지정합니다. 음수는 문자열의 마지막으로부터 해당 위치에서 검색을 중단합니다.

참고: strrpos(),
strrchr(),
substr(), stripos(),
stristr().

이전 | 처음으로 | 다음
strrev | 위로 | strrpos


strrpos

(PHP 3, PHP 4 , PHP 5)

strrpos -- 문자열에서 마지막 문자의 위치를 찾습니다.

설명

int strrpos ( string haystack, string needle [, int offset])

haystack 문자열에서 마지막으로 나오는 needle의 위치를 수로 반환합니다. PHP 4에서 needle은 하나의 문자만 사용할 수 있습니다. 문자열을 needle로 전달하면, 문자열의 첫번째 문자만을 사용합니다.

needle이 발견되지 않으면, FALSE를 반환합니다.

"문자를 위치 0에서 찾았습니다"와 "문자를 존재하지 않습니다"의 반환값을 혼동하기 쉽습니다. 두개의 차이를 확인하는 방법입니다:

<?php

// PHP 4.0b3 이상:
$pos = strrpos($mystring, "b");
if ($pos === false) { // 주의: 등호 3개
    // 발견되지 않았습니다...
}

// 4.0b3 미만:
$pos = strrpos($mystring, "b");
if (is_bool($pos) && !$pos) {
    // 발견되지 않았습니다...
}
?>

needle가 문자열이 아니면, 정수형으로 변환하여 해당하는 코드의 문자를 적용합니다.

참고: PHP 5.0.0부터 offset으로 문자열에서 찾기 시작할 위치를 지정할 수 있습니다. 음수는 문자열 마지막으로부터 해당 위치에서 찾기를 멈춥니다.

참고: PHP 5.0.0부터 needle은 하나의 문자 이상을 다룹니다.

참고: strpos(),
strripos(),
strrchr(),
substr(),
stristr(),
strstr().

이전 | 처음으로 | 다음
strripos | 위로 | strspn


strspn

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

strspn -- 마스크에 매칭되는 초기 세그먼트의 길이를 찾는다.

설명

int strspn ( string str1, string str2)

str2 안의 모든 문자들을 가지는 str1의 초기 세그먼트의 길이를 반환합니다.

간단한 코드:

<?php
$var = strspn ("42 is the answer, what is the question ...", "1234567890");
?>

문자열 "42"가 "1234567890"으로 구성되는 가장 긴 세그먼트이기에, $var에 2가 들어갑니다.

참고: strcspn().

이전 | 처음으로 | 다음
strrpos | 위로 | strstr


strstr

(PHP 3, PHP 4 , PHP 5)

strstr -- 문자열이 처음으로 나타나는 부분을 찾습니다.

설명

string strstr ( string haystack, string needle)

needle에서 haystack이 처음 발견된 곳부터 끝까지의 부분 문자열을 반환합니다.

needle이 발견되지 않으면, FALSE를 반환합니다.

needle이 문자열이 아니라면, 정수형으로 변환하여 그 수에 해당하는 문자를 적용합니다.

참고: 이 함수는 대소문자를 구별합니다. 구별하지 않으려면, stristr()을 사용하십시오.

예 1. strstr() 예제

<?php
$email = 'user@example.com';
$domain = strstr($email, '@');
echo $domain; // @example.com 을 출력.
?>

참고: needle이 haystack에 존재하는지만을 확인하려 한다면, 더 빠르고 메모리를 적게 쓰는 strpos() 함수를 사용하십시오.

참고: ereg(), preg_match(),
strchr(), stristr(),
strpos(), strrchr(),
substr().

이전 | 처음으로 | 다음
strspn | 위로 | strtok


strtok

(PHP 3, PHP 4 , PHP 5)

strtok -- 문자열을 토큰화 합니다.

설명

string strtok ( string arg1, string arg2)

strtok()는 arg2안의 어떠한 문자를 기준으로 하여, 문자열(arg1)을 작은 문자열들(토큰)로 나눕니다. 즉, "This is an example string"이라는 문자열이 있을 때, 공백 문자를 사용하여 각각의 단어를 토큰으로 만들 수 있습니다.

예 1. strtok() 예제

<?php
$string = "This is\tan example\nstring";
/* 탭과 줄바꿈도 토큰화 문자열로 사용합니다. */
$tok = strtok($string, " \n\t");
while ($tok) {
    echo "단어=$tok<br />";
    $tok = strtok(" \n\t");
}
?>

처음 strtok를 호출할 때만 문자열 인자를 사용하는 점에 주의하십시오. 이후의 모든 strtok 호출은 토큰만 사용하며, strtok는 현재 문자열을 계속해서 추적합니다. 새로 시작하거나, 새로운 문자열을 토큰화 하려면 간단히 strtok를 그 문자열로 다시 초기화하십시오. 토큰 인자로 여러 문자를 넣을 수 있는 점에 주의하십시오. 문자열은 그 중의 어떠한 하나라도 발견하였을때 토큰이 됩니다.

빈 부분을 발견하였을때 동작이 PHP 4.1.0에서 바뀌었습니다. 이전의 동작은 빈 문자열을 반환하였지만, 새로운, 올바른 동작은 그 문자열 부분을 넘어갑니다.

예 2. 이전 strtok() 동작

<?php
$first_token  = strtok('/something', '/');
$second_token = strtok('/');
var_dump($first_token, $second_token);
?>

출력:

string(0) ""
    string(9) "something"

예 3. 새로운 strtok() 동작

<?php
$first_token  = strtok('/something', '/');
$second_token = strtok('/');
var_dump($first_token, $second_token);
?>

출력:

string(9) "something"
    bool(false)

토큰이 "0"일수 있는 점에 주의하십시오. 이는 조건문에서 FALSE로 판단합니다.

참고: split() explode().

이전 | 처음으로 | 다음
strstr | 위로 | strtolower


strtolower

(PHP 3, PHP 4 , PHP 5)

strtolower -- 문자열을 소문자로 만듭니다.

설명

string strtolower ( string str)

string의 모든 알파벳을 소문자로 바꾼 문자열을 반환합니다.

'알파벳'은 현재 로케일에 의해 정해집니다. 즉, 기본값인 "C" 로케일에서는 umlaut-A (?) 등의 문자는 변환하지 않습니다.

예 1. strtolower() 예제

<?php
$str = "Mary Had A Little Lamb and She LOVED It So";
$str = strtolower($str);
echo $str; // mary had a little lamb and she loved it so 를 출력합니다.
?>

참고: strtoupper(), ucfirst(), ucwords(), mb_strtolower().

이전 | 처음으로 | 다음
strtok | 위로 | strtoupper


strtoupper

(PHP 3, PHP 4 , PHP 5)

strtoupper -- 문자열을 대문자로 만듭니다.

설명

string strtoupper ( string string)

string의 모든 알파벳을 대문자로 바꾼 문자열을 반환합니다.

'알파벳'은 현재 로케일에 의해 정해집니다. 즉, 기본값인 "C" 로케일에서는 umlaut-a(?) 등의 문자는 변환하지 않습니다.

예 1. strtoupper() 예제

<?php
$str = "Mary Had A Little Lamb and She LOVED It So";
$str = strtoupper ($str);
echo $str; // MARY HAD A LITTLE LAMB AND SHE LOVED IT SO 를 출력합니다.
?>

참고: strtolower(), ucfirst(), ucwords(), mb_strtoupper().

이전 | 처음으로 | 다음
strtolower | 위로 | strtr


strtr

(PHP 3, PHP 4 , PHP 5)

strtr -- 특정 문자를 번역한다.

설명

string strtr ( string str, string from, string to)

이 함수는 str에 대해 from에 표함되는 각각의 문자를 to에 있는 대응되는 문자로 번역하고 그 결과를 반환한다.

from과 to가 다른 길이일 때 둘 중 긴 문자열의 나머지 문자들은 무시된다.

예 1. strtr() 예

$addr = strtr($addr, "?", "aao");

strtr()은 단지 두개의 인자를 가질 수 도 있다. 만약 두개의 인자만 가지고 호출된다면 새로운 방식으로 동작한다.: 이때 from은 소스에서 변환 될 문자열 -> 문자열 쌍을 갖는 배열이어야 한다. strtr()은 항상 처음에 가장 긴 번역 가능한 매치를 찾고 그 후 이미 번역된 것은 다시 치환하려고 하지 않을 것이다.

예:

$trans = array ("hello" => "hi", "hi" => "hello");

echo strtr("hi all, I said hello", $trans) . "\n";

This will show: "hello all, I said hi",

참고: 두 인수를 이용하는 방법은 PHP 4.0 에서 추가되었다.

ereg_replace()를 참고하라.

이전 | 처음으로 | 다음
strtoupper | 위로 | substr_compare


substr_compare

(PHP 5)

substr_compare -- Binary safe optionally case insensitive comparison of 2 strings from an offset, up to length characters

Description

int substr_compare ( string main_str, string str, int offset [, int length [, bool case_sensitivity]])

substr_compare() compares main_str from position offset with str up to length characters.

Returns < 0 if main_str from position offset is less than str, > 0 if it is greater than str, and 0 if they are equal. If length is equal or greater than length of main_str and length is set, substr_compare() prints warning and returns FALSE.

If case_sensitivity is TRUE, comparison is case sensitive.

예 1. A substr_compare() example

<?php
echo substr_compare("abcde", "bc", 1, 2); // 0
echo substr_compare("abcde", "bcg", 1, 2); // 0
echo substr_compare("abcde", "BC", 1, 2, true); // 0
echo substr_compare("abcde", "bc", 1, 3); // 1
echo substr_compare("abcde", "cd", 1, 2); // -1
echo substr_compare("abcde", "abc", 5, 1); // warning
?>

이전 | 처음으로 | 다음
strtr | 위로 | substr_count


substr_count

(PHP 4 , PHP 5)

substr_count -- 부분문자열의 수를 센다

설명

int substr_count ( string haystrack, string needle)

substr_count()은 haystack 문자열에 있는 needle 부분 문자열의 수를 반환한다.

예 1. substr_count() 예

print substr_count("This is a test", "is"); // 2를 출력한다.

이전 | 처음으로 | 다음
substr_compare | 위로 | substr_replace


substr_replace

(PHP 4 , PHP 5)

substr_replace -- 문자열의 일부를 치환한다.

설명

string substr_replace ( string string, string replacement, int start [, int length])

substr_replace() 는 string의 start 와 (선택적으로) length로 정해진 구간에 해당하는 부분을 replacement로 치환하고 그 결과를 반환한다.

start가 양수라면 string의 start번째 치환이 일어난다.

start가 음수라면, string의 끝에서 부터 start번째 문자까지의 문자열을 치환한다.

length이 양수라면, 이는 치환 될 string의 일부분의 길이를 나타낸다. 만약 음수라면, string의 끝에서 부터의 문자의 수를 나타낸다. 만약 주어지지 않는다면 기본 값으로 strlen(string) 즉, string의 끝에서 치환이 끝남을 의미한다.

예 1. substr_replace() 예

<?php

$var = 'ABCDEFGH:/MNRPQR/';

echo "Original: $var<hr>\n";

/* 다음 두가지 예는 $var의 모든 문자열을  'bob'으로 치환한다. */

echo substr_replace ($var, 'bob', 0) . "<br>\n";

echo substr_replace ($var, 'bob', 0, strlen ($var)) . "<br>\n";

/* $var의 첫부분에 'bob' 을 삽입한다. */

echo substr_replace ($var, 'bob', 0, 0) . "<br>\n";

/* 다음 두 에는 $var 내의 'MNRPQR' 을  'bob'으로 치환한다. */

echo substr_replace ($var, 'bob', 10, -1) . "<br>\n";

echo substr_replace ($var, 'bob', -7, -1) . "<br>\n";

/* $var로 부터'MNRPQR' 을 지운다. */

echo substr_replace ($var, '', 10, -1) . "<br>\n";

?>

str_replace() 그리고 substr()을 참고하라.

참고: substr_replace() 는 PHP 4.0에서 추가되었다.

이전 | 처음으로 | 다음
substr_count | 위로 | substr


substr

(PHP 3, PHP 4 , PHP 5)

substr -- 문자열의 일부를 반환한다.

설명

string substr ( string string, int start [, int length])

Substr은 start와 length 매개변수에 의해 지정된 string 문자열의 일부를 반환한다.

만약 start양수라면, 반환되는 문자열은 0부터 시작되는 string의 start번째 위치에서 시작하는 문자열이 될 것이다. 예를 들어 문자열 'abcdef'이 있다고 하자. 0의 위치에 있는 문자는 'a'가 되고, 2의 위치에 있는 문자는 'c'가 되는 식이다.

예:

$rest = substr ("abcdef", 1);    //  "bcdef" 을 반환한다.

$rest = substr ("abcdef", 1, 3); //  "bcd" 을 반환한다.

만약 start가 음수라면, 반환되는 문자열은 string의 끝에서부터 start번째 부터 시작하는 문자열이 된다.

예:

$rest = substr ("abcdef", -1);    // "f" 를 반환

$rest = substr ("abcdef", -2);    // "ef" 를 반환

$rest = substr ("abcdef", -3, 1); // "d" 를 반환

만약 length이 주어지고 양의 값이라면, 반환되는 문자열은 start에서 시작해서 length에서 끝나는 문자열이 될 것이다. 만약 (시작이 문자열의 끝을 지나기 때문에) 문자열이 음의 길이를 갖는 결과가 된다면, 반환되는 문자열은 start의 문자 하나가 될 것이다. (역자주: 빈문자열이 출력된다.)

만약 length이 음의 값이라면, 스트링의 끝에서 부터 시작해서 length의 위치에 있는 문자가 반환되는 문자열의 끝이 되는 문자열이 된다. 만약 문자열이 음의 길이를 갖는 결과가 나온다면, 반환되는 문자열은 start의 문자 하나가 될 것이다. (역자주: 빈문자열이 출력된다.)

예:

$rest = substr ("abcdef", 1, -1); // "bcde"를 반환한다.

strrchr() 그리고 ereg()를 참고하라.

이전 | 처음으로 | 다음
substr_replace | 위로 | trim


trim

(PHP 3, PHP 4 , PHP 5)

trim -- 문자열의 처음과 끝에 있는 공백을 제거한다.

설명

string trim ( string str)

이 함수는 문자열의 처음과 끝에 있는 공백문자를 제거하고 이 문자열을 반환한다. 공백문자라 함은 "\n", "\r", "\t", "\v", "\0", 그리고 공백을 말한다.

chop(), rtrim() 그리고 ltrim()을 참고하라.

이전 | 처음으로 | 다음
substr | 위로 | ucfirst


ucfirst

(PHP 3, PHP 4 , PHP 5)

ucfirst -- 문자열의 처음 글자를 대문자로 만든다.

설명

string ucfirst ( string str)

만약 문자열 str의 처음 문자가 알파벳이라면, 그 처음 글자를 대문자로 만든다.

'알파벳'은 현재 로케일에 의해 정의된다. 예를들면 로케일 디폴트가 "C" 로케일로 되어 있을 경우 umlaut-a(? 같은 문자는 바뀌지 않는다.

예 1. ucfirst() 예

$text = 'mary had a little lamb and she loved it so.';

$text = ucfirst ($text); // $text 는 Mary had a little lamb

                         // and she loved it so. 로 바뀐다.

strtoupper() 그리고 strtolower()을 참고하라.

이전 | 처음으로 | 다음
trim | 위로 | ucwords


ucwords

(PHP 3>= 3.0.3, PHP 4 , PHP 5)

ucwords -- 문자열에 있는 각 단어의 처음 글자를 대문자로 바꾼다.

설명

string ucwords ( string str)

str의 각각의 단어의 첫문자가 알파벳이라면 그 글자를 대문자로 바꾼다.

예 1. ucwords() 예

$text = "mary had a little lamb and she loved it so.";

$text = ucwords($text); // $text 는 : Mary Had A Little

                        // Lamb And She Loved It So. 이 된다.

참고: 단어의 정의는 뒤에 화이트스페이스가 올 때 까지의 문자를 말한다. (화이트스페이스란 공백, 폼피드, 누라인, 케리지리턴, 수직탭, 수평탭 을 일컫는다.)

strtoupper(), strtolower() 그리고 ucfirst()을 참고하라.

이전 | 처음으로 | 다음
ucfirst | 위로 | vprintf


vprintf

(PHP 4 >= 4.1.0, PHP 5)

vprintf -- Output a formatted string

Description

void vprintf ( string format, array args)

Display array values as a formatted string according to format (which is described in the documentation for sprintf()).

Operates as printf() but accepts an array of arguments, rather than a variable number of arguments.

See also printf(), sprintf(), vsprintf()

이전 | 처음으로 | 다음
ucwords | 위로 | vsprintf


vsprintf

(PHP 4 >= 4.1.0, PHP 5)

vsprintf -- Return a formatted string

Description

string vsprintf ( string format, array args)

Return array values as a formatted string according to format (which is described in the documentation for sprintf()).

Operates as sprintf() but accepts an array of arguments, rather than a variable number of arguments.

See also sprintf() and vprintf()

이전 | 처음으로 | 다음
vprintf | 위로 | wordwrap


wordwrap

(PHP 4 >= 4.0.2, PHP 5)

wordwrap -- 정지문자를 이용해 주어진 수 만큼의 문자를 래핑한다.

설명

string wordwrap ( string str [, int width [, string break [, int cut]]])

str문자열을 width 매개변수의 지정된 길이만큼(선택적) 랩핑한다. 줄은 break 매개변수(선택적)에 의해 분리된다.

wordwrap()은 자동적으로 75컬럼에서 랩을 하며, 브레이크로는 '\n'(뉴라인)을 사용한다.

cut이 1로 지정되면, 문자열은 항상 지정된 길이로 랩핑되며, 주어진 넓이보다 더 긴 단어가 있다면, 그 단어는 나누어 진다.(두번째 예제를 보라) (See second example).

참고: cut 매개변수는 PHP 4.0.3 에서 추가되었다.

예 1. wordwrap() 예

$text = "The quick brown fox jumped over the lazy dog.";

$newtext = wordwrap( $text, 20 );

echo "$newtext\n";

이 예는 다음을 출력한다.:

The quick brown fox

jumped over the lazy dog.

예 2. wordwrap() 예

$text = "A very long woooooooooooord.";

$newtext = wordwrap( $text, 8, "\n", 1);

echo "$newtext\n";

이 예는 다음을 출력한다.:

A very

long

wooooooo

ooooord.

nl2br()를 참고하라.

이전 | 처음으로 | 다음
vsprintf | 위로 | Sybase Functions


Sybase Functions

PHP 매뉴얼
이전 다음

CVII. Sybase Functions

소개

요구 사항

설치

To enable Sybase-DB support configure PHP --with-sybase[=DIR]. DIR is the Sybase home directory, defaults to /home/sybase. To enable Sybase-CT support configure PHP --with-sybase-ct[=DIR]. DIR is the Sybase home directory, defaults to /home/sybase.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. Sybase configuration options

Name | Default | Changeable
sybase.allow_persistent | "On" | PHP_INI_SYSTEM
sybase.max_persistent | "-1" | PHP_INI_SYSTEM
sybase.max_links | "-1" | PHP_INI_SYSTEM
sybase.interface_file | "/usr/sybase/interfaces" | PHP_INI_SYSTEM
sybase.min_error_severity | "10" | PHP_INI_ALL
sybase.min_message_severity | "10" | PHP_INI_ALL
sybase.compatability_mode | "Off" | PHP_INI_SYSTEM
magic_quotes_sybase | "Off" | PHP_INI_ALL

위 설정 지시어에 대한 간단한 설명입니다.

sybase.allow_persistent boolean

Whether to allow persistent Sybase connections.

sybase.max_persistent integer

The maximum number of persistent Sybase connections per process. -1 means no limit.

sybase.max_links integer

The maximum number of Sybase connections per process, including persistent connections. -1 means no limit.

sybase.min_error_severity integer

Minimum error severity to display.

sybase.min_message_severity integer

Minimum message severity to display.

sybase.compatability_mode boolean

Compatability mode with old versions of PHP 3.0. If on, this will cause PHP to automatically assign types to results according to their Sybase type, instead of treating them all as strings. This compatability mode will probably not stay around forever, so try applying whatever necessary changes to your code, and turn it off.

magic_quotes_sybase boolean

If magic_quotes_sybase is on, a single-quote is escaped with a single-quote instead of a backslash if magic_quotes_gpc or magic_quotes_runtime are enabled.

참고: Note that when magic_quotes_sybase is ON it completely overrides magic_quotes_gpc . In this case even when magic_quotes_gpc is enabled neither double quotes, backslashes or NUL's will be escaped.

표 2. Sybase-CT configuration options

Name | Default | Changeable
sybct.allow_persistent | "On" | PHP_INI_SYSTEM
sybct.max_persistent | "-1" | PHP_INI_SYSTEM
sybct.max_links | "-1" | PHP_INI_SYSTEM
sybct.min_server_severity | "10" | PHP_INI_ALL
sybct.min_client_severity | "10" | PHP_INI_ALL
sybct.hostname | NULL | PHP_INI_ALL
sybct.deadlock_retry_count | "-1" | PHP_INI_ALL

위 설정 지시어에 대한 간단한 설명입니다.

sybct.allow_persistent boolean

Whether to allow persistent Sybase-CT connections. The default is on.

sybct.max_persistent integer

The maximum number of persistent Sybase-CT connections per process. The default is -1 meaning unlimited.

sybct.max_links integer

The maximum number of Sybase-CT connections per process, including persistent connections. The default is -1 meaning unlimited.

sybct.min_server_severity integer

Server messages with severity greater than or equal to sybct.min_server_severity will be reported as warnings. This value can also be set from a script by calling sybase_min_server_severity(). The default is 10 which reports errors of information severity or greater.

sybct.min_client_severity integer

Client library messages with severity greater than or equal to sybct.min_client_severity will be reported as warnings. This value can also be set from a script by calling sybase_min_client_severity(). The default is 10 which effectively disables reporting.

sybct.hostname string

The name of the host you claim to be connecting from, for display by sp_who. The default is none.

sybct.deadlock_retry_count int

Allows you to to define how often deadlocks are to be retried. The default is -1, or "forever".

For further details and definition of the PHP_INI_* constants see ini_set().

리소스 종류

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
sybase_affected_rows -- 가장 최근 쿼리에 의해 적용된 데이타 수를 구한다.
sybase_close -- Sybase서버로의 연결을 종료한다.
sybase_connect -- Sybase server로 연결한다.
sybase_data_seek -- move internal row pointer 내부 결과 데이타셋내의 위치 포인터를 이동한다.
sybase_deadlock_retry_count -- Sets the deadlock retry count
sybase_fetch_array -- 데이타를 배열로서 가져온다.
sybase_fetch_assoc -- Fetch a result row as an associative array
sybase_fetch_field -- 데이타 셋의 필드 정보를 얻는다.
sybase_fetch_object -- 객체타입으로 데이타를 추출한다.
sybase_fetch_row -- 배열로 데이타를 추출한다.(인덱스는 숫자 타입이다.)
sybase_field_seek -- 필드 offset(위치값)을 정한다.(이동한다.)
sybase_free_result -- 추출된 데이타가 저장된 메모리를 해제한다.
sybase_get_last_message -- 서버로부터온 최종 메세지를 반환한다.
sybase_min_client_severity -- 클라이언트의 최소 가혹 레벨을 정한다.
sybase_min_error_severity -- 최저 가혹 에러 레벨을 정한다.
sybase_min_message_severity -- 최저 메시지 가혹 레벨을 정한다.
sybase_min_server_severity -- 최저 서버 가혹 레베을 정한다.
sybase_num_fields -- 결과 데이타셋에서 필드수를 구한다.
sybase_num_rows -- 결과값의 데이타(열)수를 구한다.
sybase_pconnect -- Sybase 서버로의 영속적인(persistent) 연결을 만든다.
sybase_query -- Sybase서버에 query(쿼리)를 보낸다.
sybase_result -- 결과 데이타를 추출한다.
sybase_select_db -- 사용할 database를 선택한다.
sybase_set_message_handler -- Sets the handler called when a server message is raised
sybase_unbuffered_query -- Send a Sybase query and do not block

이전 | 처음으로 | 다음
wordwrap | 위로 | sybase_affected_rows


sybase_affected_rows

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

sybase_affected_rows -- 가장 최근 쿼리에 의해 적용된 데이타 수를 구한다.

Description

int sybase_affected_rows ( [int link_identifier])

가장 최근 쿼리에서 적용된 데이타(줄)수를 반환합니다.

sybase_affected_rows() 함수는 link_identifier에 정의된 특정 링크로 서버에 접속된 'INSERT, UPDATE or DELETE' 쿼리에 영향을 받은 데이타의 수를 반환합니다. 만약 link identifier가 정의되지 않으면 가장 최근에 열린 링크로 가정한다.

이 명령은 'SELECT' 구문에는 영향을 받지 않는다. 단지 데이타를 수정하는 구문에만 영향을 받는다. 'SELECT' 구문에 적용된 데이타수를 알려면 sybase_num_rows()함수를 사용한면 된다.

참고: 이 함수는 DB 라이브러리 인터페이스가 아닌 CT라이브러리 인터페이스에서만 사용이 가능하다.

이전 | 처음으로 | 다음
Sybase Functions | 위로 | sybase_close


sybase_close

(PHP 3, PHP 4 , PHP 5)

sybase_close -- Sybase서버로의 연결을 종료한다.

Description

bool sybase_close ( int link_identifier)

연결에 성공하면 'TRUE'를 실패하면 'error'를 반환한다.

sybase_close() 는 link identifier에 의해 생성된 Sybase database에의 접속을 종료한다. 만약 link identifier가 정의되어 있지 않다면, 마지막으로 연결된 링크로 가정한다.

Note that this isn't usually necessary, as non-persistent open links are automatically closed at the end of the script's execution. 주의해야 할 점은 스크립트 종료시 링크가 Persistent link가 아닌 경우에는 링크가 자동으로 종료된다는 점이다.

sybase_close() 함수는 sybase_pconnect()함수에 의해 생성된 Persistent link는 종료시키지 않는다.

See also: sybase_connect(), sybase_pconnect().

이전 | 처음으로 | 다음
sybase_affected_rows | 위로 | sybase_connect


sybase_connect

(PHP 3, PHP 4 , PHP 5)

sybase_connect -- Sybase server로 연결한다.

Description

int sybase_connect ( string servername, string username, string password [, string charset])

수행이 성공적으로 이루어지면 양수의 Sybase link identifier(식별자)가 반환되며, 에러가 발생하면 FALSE가 반환된다.

sybase_connect() 함수는 Sybase 서버로 연결하는 함수이다. "servername" 인자는 'interface'파일에 의해 정의된 실제 servername이여야 한다.

만약 sybase_connect()함수가 같은 인자를 가지고 두번 호출된다면, 새로운 연결이 생성되는 대신에 먼저 열렸던 link identifier(식별자)가 반환된다.

스크립트의 실행이 끝나자 마자 서버로의 링크는 끝나게 된다. 그렇지 않다면 sybase_close()함수에 의해 이전에 종료된 것이다.

See also sybase_pconnect(), sybase_close().

이전 | 처음으로 | 다음
sybase_close | 위로 | sybase_data_seek


sybase_data_seek

(PHP 3, PHP 4 , PHP 5)

sybase_data_seek -- move internal row pointer 내부 결과 데이타셋내의 위치 포인터를 이동한다.

Description

bool sybase_data_seek ( int result_identifier, int row_number)

수행 성공시 'TRUE', 실패시 'FALSE'를 반환한다.

sybase_data_seek() 함수는 result_identifire에 의해 정의된 결과 데이타셋의 위치 포인터를 row_number 의 위치로 이동한다. 이후, sybase_fetch_row()함수가 호출되면 이동한 위치의 데이타를 읽어올수 있다.

See also: sybase_data_seek().

이전 | 처음으로 | 다음
sybase_connect | 위로 | sybase_deadlock_retry_count


sybase_deadlock_retry_count

(PHP 4 >= 4.3.0, PHP 5)

sybase_deadlock_retry_count -- Sets the deadlock retry count

Description

void sybase_deadlock_retry_count ( int retry_count)

Using sybase_deadlock_retry_count(), the number of retries can be defined in cases of deadlocks. By default, every deadlock is retried an infinite number of times or until the process is killed by Sybase, the executing script is killed (for instance, by set_time_limit()) or the query succeeds.

표 1. Values for retry_count

-1 | Retry forever (default)
0 | Do not retry
n | Retry n times

참고: 이 함수는 Sybase를 CT 라이브러리 인터페이스를 이용할 때만 사용할 수 있으며, DB 라이브러리로는 사용할 수 없습니다.

이전 | 처음으로 | 다음
sybase_data_seek | 위로 | sybase_fetch_array


sybase_fetch_array

(PHP 3, PHP 4 , PHP 5)

sybase_fetch_array -- 데이타를 배열로서 가져온다.

Description

array sybase_fetch_array ( int result)

결과값으로는 추출된 데이타가 배열로 반환되며, 추출된 데이타가 없을 경우에는 'FALSE'이 반환된다.

sybase_fetch_array()함수는 sybase_fetch_row()의 확장버젼이다. 게다가 이 함수는 결과 배열의 숫자인덱스뿐만 아니라 필드 값을 배열의 인덱스로 가진 배열을 반환하다.

비록 sybase_fetch_array() 함수가 특정 값(필드값을 인덱스로 가짐)을 추가되었다 하더라고 sybase_fetch_row()함수에 비해 눈에 띌만큼 느리진 않다.

For further details, also see sybase_fetch_row()

이전 | 처음으로 | 다음
sybase_deadlock_retry_count | 위로 | sybase_fetch_assoc


sybase_fetch_assoc

(PHP 4 >= 4.3.0, PHP 5)

sybase_fetch_assoc -- Fetch a result row as an associative array

Description

array sybase_fetch_assoc ( resource result)

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

sybase_fetch_assoc() is a version of sybase_fetch_row() that uses column names instead of integers for indices in the result array. Columns from different tables with the same names are returned as name, name1, name2, ..., nameN.

An important thing to note is that using sybase_fetch_assoc() is NOT significantly slower than using sybase_fetch_row(), while it provides a significant added value.

See also
sybase_fetch_array(),
sybase_fetch_object() and
sybase_fetch_row().

이전 | 처음으로 | 다음
sybase_fetch_array | 위로 | sybase_fetch_field


sybase_fetch_field

(PHP 3, PHP 4 , PHP 5)

sybase_fetch_field -- 데이타 셋의 필드 정보를 얻는다.

Description

object sybase_fetch_field ( int result [, int field_offset])

field 값에 대한 정보를 가진 객체를 반환한다.

sybase_fetch_field() 함수는 특정 쿼리 결과값에서 필드에 정보를 얻는데 사용되어 진다. 만약 field_offet값이 정해지지 않으면 이전 sybase_fetch_field()함수에 의해 얻어진 필드의 다음 필드가 반환된다.

정보 객체의 내부 속성값들은 다음과 같다.

  • name - 이름 컬럼이다, 만약 컬럼이 함수의 결과값이면 이 속성은 계산된 #N값이고 이 #N은 serial number 이다.

  • column_source - 컬럼 값을 가져온 대상 table

  • max_length - 컬럼의 최대길이

  • numeric - 만약 컬럼이 숫자값이면 1을 가진다.

  • type - 컬럼의 datatype

See also sybase_field_seek()

이전 | 처음으로 | 다음
sybase_fetch_assoc | 위로 | sybase_fetch_object


sybase_fetch_object

(PHP 3, PHP 4 , PHP 5)

sybase_fetch_object -- 객체타입으로 데이타를 추출한다.

Description

int sybase_fetch_object ( int result)

성공적으로 수행되면 추출된 행에 관한 속성을 가진 객체를 반환하고, 추출된 행이 없으면 FALSE를 반환한다.

sybase_fetch_object() 함수는 배열 대신에 객체를 반환한다는 점 한가지 차이점을 빼놓고는 sybase_fetch_array()와 비슷하다. 달리 말해, 데이타에 접근하려면 반드시 필드 이름을 사용해야 하면 offset을 사용할 수 없다는 것이다.(속성이름으로서 숫자값은 사용되어 질수 없다.)

얼핏 보면 sybase_fetch_array() 와 비슷하게 빠른sybase_fetch_row() (차이점이 경미하다.)

See also: sybase_fetch-array() and sybase_fetch-row().

이전 | 처음으로 | 다음
sybase_fetch_field | 위로 | sybase_fetch_row


sybase_fetch_row

(PHP 3, PHP 4 , PHP 5)

sybase_fetch_row -- 배열로 데이타를 추출한다.(인덱스는 숫자 타입이다.)

Description

array sybase_fetch_row ( int result)

성공적으로 수행되면 추출된 데이타의 배열이 반환되고, 추출된 데이타가 없다면 'FALSE'가 반환된다.

sybase_fetch_row()는 특정 result identifier에 의한 결과에서 한 데이타 열를 추출한다. 그 데이타 열은 배열로 반환된다. 각 결과 컬럼은 0으로 시작하는 배열 인덱스값을 가진다.

두번째 이상으로 호출되는 sybase_fetch_rows()의 결과값은 결과값 셋에서 다음 행의 결과값이 반환되고, 더이상의 결과행이 없으면 FALSE를 반환한다.

See also: sybase_fetch_array(),
          sybase_fetch_object(),
          sybase_data_seek(),
          sybase_fetch_lengths(), and
          sybase_result().

이전 | 처음으로 | 다음
sybase_fetch_object | 위로 | sybase_field_seek


sybase_field_seek

(PHP 3, PHP 4 , PHP 5)

sybase_field_seek -- 필드 offset(위치값)을 정한다.(이동한다.)

Description

int sybase_field_seek ( int result, int field_offset)

Seeks to the specified field offset. If the next call to sybase_fetch_field() won't include a field offset, this field would be returned. 특정 위치의 필드값을 찾는다. 만약, 이후에 sybase_fetch_field()함수가 다시 불려졌을 때의 반환 필드 offset을 가지지 못한다면, 이전에 추출된 필드값이 반환될 것이다.

See also: sybase_fetch_field().

이전 | 처음으로 | 다음
sybase_fetch_row | 위로 | sybase_free_result


sybase_free_result

(PHP 3, PHP 4 , PHP 5)

sybase_free_result -- 추출된 데이타가 저장된 메모리를 해제한다.

Description

bool sybase_free_result ( int result)

sybase_free_result()함수는 스크립트가 작동하는 동안에 너무 많은 메모리가 사용될 것이 걱정될 경우에만 사용되어진다. 스크립트가 끝날 경우에는 모든 결과값이 저잗되었던 메모리는 해제되기는 하지만, 인수로서 result identifier를 가진 함수 sybase_free_result()는 result identifier에 연관된 메모리를 해제 할 것이다.

이전 | 처음으로 | 다음
sybase_field_seek | 위로 | sybase_get_last_message


sybase_get_last_message

(PHP 3, PHP 4 , PHP 5)

sybase_get_last_message -- 서버로부터온 최종 메세지를 반환한다.

Description

string sybase_get_last_message ( void )

sybase_get_last_message() 함수는 서버로부터 최종적으로 보고된 메세지를 반환한다.

이전 | 처음으로 | 다음
sybase_free_result | 위로 | sybase_min_client_severity


sybase_min_client_severity

(PHP 3, PHP 4 , PHP 5)

sybase_min_client_severity -- 클라이언트의 최소 가혹 레벨을 정한다.

Description

void sybase_min_client_severity ( int severity)

sybase_min_client_severity()함수는 최저 클라이언트 가혹 레벨을 정한다.

참고: 이 함수는 CT library interface 모드에서만 사용가능하고, DB library 모드에서는 사용할 수 없다.

See also: sybase_min_server_severity().

이전 | 처음으로 | 다음
sybase_get_last_message | 위로 | sybase_min_error_severity


sybase_min_error_severity

(PHP 3, PHP 4 , PHP 5)

sybase_min_error_severity -- 최저 가혹 에러 레벨을 정한다.

Description

void sybase_min_error_severity ( int severity)

sybase_min_error_severity()함수는 최저 에러 가혹 레벨을 정한다.

See also: sybase_min_message_severity().

이전 | 처음으로 | 다음
sybase_min_client_severity | 위로 | sybase_min_message_severity


sybase_min_message_severity

(PHP 3, PHP 4 , PHP 5)

sybase_min_message_severity -- 최저 메시지 가혹 레벨을 정한다.

Description

void sybase_min_message_severity ( int severity)

sybase_min_message_severity()함수는 최저 메시지 가혹 레벨을 정한다.

See also: sybase_min_error_severity().

이전 | 처음으로 | 다음
sybase_min_error_severity | 위로 | sybase_min_server_severity


sybase_min_server_severity

(PHP 3, PHP 4 , PHP 5)

sybase_min_server_severity -- 최저 서버 가혹 레베을 정한다.

Description

void sybase_min_server_severity ( int severity)

sybase_min_server_severity() 함수는 최저 서버 가혹 레벨을 정한다.

참고: 이 함수는 단지 CT library interface 모드에서만 사용이 가능하고 DB library interface 모드에서는 사용할 수 없다.

See also: sybase_min_client_severity().

이전 | 처음으로 | 다음
sybase_min_message_severity | 위로 | sybase_num_fields


sybase_num_fields

(PHP 3, PHP 4 , PHP 5)

sybase_num_fields -- 결과 데이타셋에서 필드수를 구한다.

Description

int sybase_num_fields ( int result)

sybase_num_fields()함수는 결과 셋에서 필드 수를 구해 반환한다.

See also:
sybase_db_query(),
sybase_query(),
sybase_fetch_field(),
sybase_num_rows().

이전 | 처음으로 | 다음
sybase_min_server_severity | 위로 | sybase_num_rows


sybase_num_rows

(PHP 3, PHP 4 , PHP 5)

sybase_num_rows -- 결과값의 데이타(열)수를 구한다.

Description

int sybase_num_rows ( int result)

sybase_num_rows()함수는 결과셋의 데이타(열)수를 반환한다.

See also:
sybase_db_query(),
sybase_query() and,
sybase_fetch_row().

이전 | 처음으로 | 다음
sybase_num_fields | 위로 | sybase_pconnect


sybase_pconnect

(PHP 3, PHP 4 , PHP 5)

sybase_pconnect -- Sybase 서버로의 영속적인(persistent) 연결을 만든다.

Description

int sybase_pconnect ( string servername, string username, string password [, string charset])

성공적으로 수행시 양수의 Sybase persistent link identifier(사이베이스 영속 연결 식별자)를 반환하고, 에러가 났을경우 FALSE를 반환한다.

sybase_pconnect()함수는 두가지 다른점을 제외하고는 sybase_connect()함수와 거의 같다.

첫째로 접속시 함수는 같은 host,username,password를 가진 열려있는 영속(persistent) 링크를 찾는다. 만약 발견되면 새로 연결하지 않고 발견된 연결의 identifier(식별자)가 반환된다.

두번째는 SQL 서버로의 연결이 스크립트가 끝났음에도 종료가 되지 않는다는 점이다. 대신에 그 연결은 나중에 사용된다. (sybase_pconnect()함수에 의해 생성된 연결은 sybase_close()함수에 의해 종료되지 않는다.)

그러므로 이러한 종류의 링크를 'persistent(영속적인)'이라고 표현한다.

이전 | 처음으로 | 다음
sybase_num_rows | 위로 | sybase_query


sybase_query

(PHP 3, PHP 4 , PHP 5)

sybase_query -- Sybase서버에 query(쿼리)를 보낸다.

Description

int sybase_query ( string query, int link_identifier)

성공적으로 수행되면 양수의 Sybase result identifier(사이베이스 결과 식별자)가 반환되고, 에러가 발생하면 FALSE가 반환된다.

sybase_query()함수는 link_identifier 인수에 의해 정의된 연결로 현재 활동중인 서버의 database에 query(쿼리)를 보낸다. 만약 link identifier(연결 식별자)가 정의되어 있지 않다면 최근에 마지막으로 열린 링크로 가정한다. 만약 열려 있는 링크가 없다면 sybase_connect()함수가 호출된 것처럼 링크를 만들어 사용한다.

See also:
sybase_db_query(),
sybase_select_db(), and
sybase_connect().

이전 | 처음으로 | 다음
sybase_pconnect | 위로 | sybase_result


sybase_result

(PHP 3, PHP 4 , PHP 5)

sybase_result -- 결과 데이타를 추출한다.

Description

string sybase_result ( int result, int row, mixed field)

result 인수에 의한 특정 결과 셋에서 row 와 field 인수의 의해 정해진 특정한 하나의 셀의 내용을 반환한다.

sybase_result() 함수는 Sybase 결과 셋에서 한셀의 내용을 반환한다. field 인수는 필드의 offset(위치값) 또는 필드의 이름이거나, 필드의 테이블 점 필드의 이름의 형태(tablename.fieldname) 이다. 만약 컬럼 이름이 alias된다면 ('select foo as bar from...')형식으로 컬럼 이름 대신에 alias된 이름을 사용한다.

결과 셋의 크기가 클 경우, 한번 의 호출로 대용량의 데이타를 추출할수 있는 함수들을 사용하는 것을 고려해 보는 것이 좋을 것이다. 그 함수들은 sybase_result()합수보다 많이 빠르다. 또한 field 인수로 필드 이름이나 테이블이름.필드이름의 형태를 사용하는 것보다 숫자 offset(위치)값을 사용하는 것이 속도가 더 빠르다.

한꺼번에 대용량의 데이타를 추출할경우 다음의 함수를 추천한다.:
sybase_fetch_row(),
sybase_fetch_array(),
sybase_fetch_object().

이전 | 처음으로 | 다음
sybase_query | 위로 | sybase_select_db


sybase_select_db

(PHP 3, PHP 4 , PHP 5)

sybase_select_db -- 사용할 database를 선택한다.

Description

bool sybase_select_db ( string database_name, int link_identifier)

성공적으로 수행시 TRUE를 반환하고, 에러 발생시 FALSE를 반환한다.

sybase_select_db함수는 link identifier함수에 의해 연결된 서버상의 (활성화된) 데이타베이스를 선택한다. 만약 link identifier인수가 없다면, sybase_connect()함수에 의해 호출된 것 과 같이 link를 생성하여 사용한다.

계속 이어져 호출되는 sybase_query()함수는 이전에 선택된 데이타베이스상에서 실행될 것이다.

See also:
    sybase_connect(),
    sybase_pconnect(), and
    sybase_query()

이전 | 처음으로 | 다음
sybase_result | 위로 | sybase_set_message_handler


sybase_set_message_handler

(PHP 4 >= 4.3.0, PHP 5)

sybase_set_message_handler -- Sets the handler called when a server message is raised

Description

bool sybase_set_message_handler ( callback handler [, resource connection])

sybase_set_message_handler() sets a user function to handle messages generated by the server. You may specify the name of a global function, or use an array to specify an object reference and a method name.

The handler expects five arguments in the following order: message number, severity, state, line number and description. The first four are integers. The last is a string. If the function returns FALSE, PHP generates an ordinary error message.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: The connection parameter was added in PHP 4.3.5.

예 1. sybase_set_message_handler() callback function

<?php
    function msg_handler($msgnumber, $severity, $state, $line, $text)
    {
        var_dump($msgnumber, $severity, $state, $line, $text);
    }

    sybase_set_message_handler('msg_handler');
?>

예 2. sybase_set_message_handler() callback to a class

<?php
    class Sybase {
        function handler($msgnumber, $severity, $state, $line, $text)
        {
            var_dump($msgnumber, $severity, $state, $line, $text);
        }
    }

    $sybase= new Sybase();
    sybase_set_message_handler(array($sybase, 'handler'));
?>

예 3. sybase_set_message_handler() unhandled messages

<?php
    // Return FALSE from this function to indicate you can't handle
    // this. The error is printed out as a warning, the way you're used
    // to it if there is no handler installed.
    function msg_handler($msgnumber, $severity, $state, $line, $text)
    {
        if (257 == $msgnumber) {
            return false;
        }
        var_dump($msgnumber, $severity, $state, $line, $text);
    }

    sybase_set_message_handler('msg_handler');
?>

이전 | 처음으로 | 다음
sybase_select_db | 위로 | sybase_unbuffered_query


sybase_unbuffered_query

(PHP 4 >= 4.3.0, PHP 5)

sybase_unbuffered_query -- Send a Sybase query and do not block

Description

resource sybase_unbuffered_query ( string query, resource link_identifier [, bool store_result])

Returns a positive Sybase result identifier on success, or FALSE on error.

sybase_unbuffered_query() sends a query to the currently active database on the server that's associated with the specified link identifier. If the link identifier isn't specified, the last opened link is assumed. If no link is open, the function tries to establish a link as if sybase_connect() was called, and use it.

Unlike sybase_query(), sybase_unbuffered_query() reads only the first row of the result set. sybase_fetch_array() and similar function read more rows as needed. sybase_data_seek() reads up to the target row. The behavior may produce better performance for large result sets.

sybase_num_rows() will only return the correct number of rows if all result sets have been read. To Sybase, the number of rows is not known and is therefore computed by the client implementation.

참고: If you don't read all of the resultsets prior to executing the next query, PHP will raise a warning and cancel all of the pending results. To get rid of this, use sybase_free_result() which will cancel pending results of an unbuffered query.

The optional store_result can be FALSE to indicate the resultsets shouldn't be fetched into memory, thus minimizing memory usage which is particularly interesting with very large resultsets.

예 1. sybase_unbuffered_query() example

<?php

$dbh = sybase_connect('SYBASE', '', '');
$q = sybase_unbuffered_query('select firstname, lastname from huge_table', $dbh, false);
sybase_data_seek($q, 10000);
$i = 0;

while ($row = sybase_fetch_row($q)) {
    echo $row[0], ' ', $row[1], '<br />';
    if ($i++ > 40000) {
        break;
    }
}

sybase_free_result($q);
sybase_close($dbh);

?>

이전 | 처음으로 | 다음
sybase_set_message_handler | 위로 | TCP Wrappers Functions


TCP Wrappers Functions

PHP 매뉴얼
이전 다음

CVIII. TCP Wrappers Functions

소개

The TCP wrappers provides a classical unix mechanism which has been designed to check if the remote client is able to connect from the given IP address.

설치

Tcpwrap is currently available through PECL http://pecl.php.net/package/tcpwrap.

If PEAR is available on your *nix-like system you can use the pear installer to install the tcpwrap extension, by the following command: pear -v install tcpwrap.

You can always download the tar.gz package and install tcpwrap by hand:

예 1. tcpwrap install by hand

gunzip tcpwrap-xxx.tgz
tar -xvf tcpwrap-xxx.tar
cd tcpwrap-xxx
phpize
./configure && make && make install

차례
tcpwrap_check -- tcpwrap check

이전 | 처음으로 | 다음
sybase_unbuffered_query | 위로 | tcpwrap_check


tcpwrap_check

(no version information, might be only in CVS)

tcpwrap_check -- tcpwrap check

Description

bool tcpwrap_check ( string daemon, string address [, string user [, bool nodns]])

This function consults /etc/hosts.allow and /etc/hosts.deny files to check if access to service daemon should be granted or denied for client with remote address address (and optional username user). address can be either IP address or domain name. user can be NULL.

If address looks like domain name then DNS is used to resolve it to IP address; set nodns to TRUE to avoid this.

For more details please consult hosts_access(3) man page.

This function returns TRUE if access should be granted, FALSE otherwise.

이전 | 처음으로 | 다음
TCP Wrappers Functions | 위로 | Tidy Functions


Tidy Functions

PHP 매뉴얼
이전 다음

CIX. Tidy Functions

소개

Tidy is a binding for the Tidy HTML clean and repair utility which allows you to not only clean and otherwise manipluate HTML documents, but also traverse the document tree.

요구 사항

To use Tidy, you will need libtidy installed, available on the tidy homepage http://tidy.sourceforge.net/.

설치

Tidy is currently available for PHP 4.3.x and PHP 5 as a PECL extension from http://pecl.php.net/package/tidy.

참고: Tidy 1.0 is just for PHP 4.3.x, while Tidy 2.0 is just for PHP 5.

If PEAR is available on your *nix-like system you can use the pear installer to install the tidy extension, by the following command: pear -v install tidy.

You can always download the tar.gz package and install tidy by hand:

예 1. tidy install by hand in PHP 4.3.x

gunzip tidy-xxx.tgz
tar -xvf tidy-xxx.tar
cd tidy-xxx
phpize
./configure && make && make install

Windows users can download the extension dll php_tidy.dll from http://snaps.php.net/win32/PECL_STABLE/.

In PHP 5 you need only to compile using the --with-tidy option.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. Tidy Configuration Options

Name | Default | Changeable | Function
tidy.default_config | "" | PHP_INI_SYSTEM | default path for tidy config file
tidy.clean_output | 0 | PHP_INI_PERDIR | turns on/off the output repairing by Tidy
For further details and definition of the PHP_INI_* constants see ini_set().

주의

Do not turn on tidy.clean_output if you are generating non-html content such as dynamic images.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

The following constants are defined:

표 2. tidy tag constants

constant | description
TIDY_TAG_UNKNOWN |
TIDY_TAG_A |
TIDY_TAG_ABBR |
TIDY_TAG_ACRONYM |
TIDY_TAG_ALIGN |
TIDY_TAG_APPLET |
TIDY_TAG_AREA |
TIDY_TAG_B |
TIDY_TAG_BASE |
TIDY_TAG_BASEFONT |
TIDY_TAG_BDO |
TIDY_TAG_BGSOUND |
TIDY_TAG_BIG |
TIDY_TAG_BLINK |
TIDY_TAG_BLOCKQUOTE |
TIDY_TAG_BODY |
TIDY_TAG_BR |
TIDY_TAG_BUTTON |
TIDY_TAG_CAPTION |
TIDY_TAG_CENTER |
TIDY_TAG_CITE |
TIDY_TAG_CODE |
TIDY_TAG_COL |
TIDY_TAG_COLGROUP |
TIDY_TAG_COMMENT |
TIDY_TAG_DD |
TIDY_TAG_DEL |
TIDY_TAG_DFN |
TIDY_TAG_DIR |
TIDY_TAG_DIV |
TIDY_TAG_DL |
TIDY_TAG_DT |
TIDY_TAG_EM |
TIDY_TAG_EMBED |
TIDY_TAG_FIELDSET |
TIDY_TAG_FONT |
TIDY_TAG_FORM |
TIDY_TAG_FRAME |
TIDY_TAG_FRAMESET |
TIDY_TAG_H1 |
TIDY_TAG_H2 |
TIDY_TAG_H3 |
TIDY_TAG_H4 |
TIDY_TAG_H5 |
TIDY_TAG_6 |
TIDY_TAG_HEAD |
TIDY_TAG_HR |
TIDY_TAG_HTML |
TIDY_TAG_I |
TIDY_TAG_IFRAME |
TIDY_TAG_ILAYER |
TIDY_TAG_IMG |
TIDY_TAG_INPUT |
TIDY_TAG_INS |
TIDY_TAG_ISINDEX |
TIDY_TAG_KBD |
TIDY_TAG_KEYGEN |
TIDY_TAG_LABEL |
TIDY_TAG_LAYER |
TIDY_TAG_LEGEND |
TIDY_TAG_LI |
TIDY_TAG_LINK |
TIDY_TAG_LISTING |
TIDY_TAG_MAP |
TIDY_TAG_MARQUEE |
TIDY_TAG_MENU |
TIDY_TAG_META |
TIDY_TAG_MULTICOL |
TIDY_TAG_NOBR |
TIDY_TAG_NOEMBED |
TIDY_TAG_NOFRAMES |
TIDY_TAG_NOLAYER |
TIDY_TAG_NOSAFE |
TIDY_TAG_NOSCRIPT |
TIDY_TAG_OBJECT |
TIDY_TAG_OL |
TIDY_TAG_OPTGROUP |
TIDY_TAG_OPTION |
TIDY_TAG_P |
TIDY_TAG_PARAM |
TIDY_TAG_PLAINTEXT |
TIDY_TAG_PRE |
TIDY_TAG_Q |
TIDY_TAG_RP |
TIDY_TAG_RT |
TIDY_TAG_RTC |
TIDY_TAG_RUBY |
TIDY_TAG_S |
TIDY_TAG_SAMP |
TIDY_TAG_SCRIPT |
TIDY_TAG_SELECT |
TIDY_TAG_SERVER |
TIDY_TAG_SERVLET |
TIDY_TAG_SMALL |
TIDY_TAG_SPACER |
TIDY_TAG_SPAN |
TIDY_TAG_STRIKE |
TIDY_TAG_STRONG |
TIDY_TAG_STYLE |
TIDY_TAG_SUB |
TIDY_TAG_TABLE |
TIDY_TAG_TBODY |
TIDY_TAG_TD |
TIDY_TAG_TEXTAREA |
TIDY_TAG_TFOOT |
TIDY_TAG_TH |
TIDY_TAG_THEAD |
TIDY_TAG_TITLE |
TIDY_TAG_TR |
TIDY_TAG_TR |
TIDY_TAG_TT |
TIDY_TAG_U |
TIDY_TAG_UL |
TIDY_TAG_VAR |
TIDY_TAG_WBR |
TIDY_TAG_XMP |

표 3. tidy attribute constants

constant | description
TIDY_ATTR_UNKNOWN |
TIDY_ATTR_ABBR |
TIDY_ATTR_ACCEPT |
TIDY_ATTR_ACCEPT_CHARSET |
TIDY_ATTR_ACCESSKEY |
TIDY_ATTR_ACTION |
TIDY_ATTR_ADD_DATE |
TIDY_ATTR_ALIGN |
TIDY_ATTR_ALINK |
TIDY_ATTR_ALT |
TIDY_ATTR_ARCHIVE |
TIDY_ATTR_AXIS |
TIDY_ATTR_BACKGROUND |
TIDY_ATTR_BGCOLOR |
TIDY_ATTR_BGPROPERTIES |
TIDY_ATTR_BORDER |
TIDY_ATTR_BORDERCOLOR |
TIDY_ATTR_BOTTOMMARGIN |
TIDY_ATTR_CELLPADDING |
TIDY_ATTR_CELLSPACING |
TIDY_ATTR_CHAR |
TIDY_ATTR_CHAROFF |
TIDY_ATTR_CHARSET |
TIDY_ATTR_CHECKED |
TIDY_ATTR_CITE |
TIDY_ATTR_CLASS |
TIDY_ATTR_CLASSID |
TIDY_ATTR_CLEAR |
TIDY_ATTR_CODE |
TIDY_ATTR_CODEBASE |
TIDY_ATTR_CODETYPE |
TIDY_ATTR_COLOR |
TIDY_ATTR_COLS |
TIDY_ATTR_COLSPAN |
TIDY_ATTR_COMPACT |
TIDY_ATTR_CONTENT |
TIDY_ATTR_COORDS |
TIDY_ATTR_DATA |
TIDY_ATTR_DATAFLD |
TIDY_ATTR_DATAPAGESIZE |
TIDY_ATTR_DATASRC |
TIDY_ATTR_DATETIME |
TIDY_ATTR_DECLARE |
TIDY_ATTR_DEFER |
TIDY_ATTR_DIR |
TIDY_ATTR_DISABLED |
TIDY_ATTR_ENCODING |
TIDY_ATTR_ENCTYPE |
TIDY_ATTR_FACE |
TIDY_ATTR_FOR |
TIDY_ATTR_FRAME |
TIDY_ATTR_FRAMEBORDER |
TIDY_ATTR_FRAMESPACING |
TIDY_ATTR_GRIDX |
TIDY_ATTR_GRIDY |
TIDY_ATTR_HEADERS |
TIDY_ATTR_HEIGHT |
TIDY_ATTR_HREF |
TIDY_ATTR_HREFLANG |
TIDY_ATTR_HSPACE |
TIDY_ATTR_HTTP_EQUIV |
TIDY_ATTR_ID |
TIDY_ATTR_ISMAP |
TIDY_ATTR_LABEL |
TIDY_ATTR_LANG |
TIDY_ATTR_LANGUAGE |
TIDY_ATTR_LAST_MODIFIED |
TIDY_ATTR_LAST_VISIT |
TIDY_ATTR_LEFTMARGIN |
TIDY_ATTR_LINK |
TIDY_ATTR_LONGDESC |
TIDY_ATTR_LOWSRC |
TIDY_ATTR_MARGINHEIGHT |
TIDY_ATTR_MARGINWIDTH |
TIDY_ATTR_MAXLENGTH |
TIDY_ATTR_MEDIA |
TIDY_ATTR_METHOD |
TIDY_ATTR_MULTIPLE |
TIDY_ATTR_NAME |
TIDY_ATTR_NOHREF |
TIDY_ATTR_NORESIZE |
TIDY_ATTR_NOSHADE |
TIDY_ATTR_NOWRAP |
TIDY_ATTR_OBJECT |
TIDY_ATTR_OnAFTERUPDATE |
TIDY_ATTR_OnBEFOREUNLOAD |
TIDY_ATTR_OnBEFOREUPDATE |
TIDY_ATTR_OnBLUR |
TIDY_ATTR_OnCHANGE |
TIDY_ATTR_OnCLICK |
TIDY_ATTR_OnDATAAVAILABLE |
TIDY_ATTR_OnDATASETCHANGED |
TIDY_ATTR_OnDATASETCOMPLETE |
TIDY_ATTR_OnDBLCLICK |
TIDY_ATTR_OnERRORUPDATE |
TIDY_ATTR_OnFOCUS |
TIDY_ATTR_OnKEYDOWN |
TIDY_ATTR_OnKEYPRESS |
TIDY_ATTR_OnKEYUP |
TIDY_ATTR_OnLOAD |
TIDY_ATTR_OnMOUSEDOWN |
TIDY_ATTR_OnMOUSEMOVE |
TIDY_ATTR_OnMOUSEOUT |
TIDY_ATTR_OnMOUSEOVER |
TIDY_ATTR_OnMOUSEUP |
TIDY_ATTR_OnRESET |
TIDY_ATTR_OnROWENTER |
TIDY_ATTR_OnROWEXIT |
TIDY_ATTR_OnSELECT |
TIDY_ATTR_OnSUBMIT |
TIDY_ATTR_OnUNLOAD |
TIDY_ATTR_PROFILE |
TIDY_ATTR_PROMPT |
TIDY_ATTR_RBSPAN |
TIDY_ATTR_READONLY |
TIDY_ATTR_REL |
TIDY_ATTR_REV |
TIDY_ATTR_RIGHTMARGIN |
TIDY_ATTR_ROWS |
TIDY_ATTR_ROWSPAN |
TIDY_ATTR_RULES |
TIDY_ATTR_SCHEME |
TIDY_ATTR_SCOPE |
TIDY_ATTR_SCROLLING |
TIDY_ATTR_SELECTED |
TIDY_ATTR_SHAPE |
TIDY_ATTR_SHOWGRID |
TIDY_ATTR_SHOWGRIDX |
TIDY_ATTR_SHOWGRIDY |
TIDY_ATTR_SIZE |
TIDY_ATTR_SPAN |
TIDY_ATTR_SRC |
TIDY_ATTR_STANDBY |
TIDY_ATTR_START |
TIDY_ATTR_STYLE |
TIDY_ATTR_SUMMARY |
TIDY_ATTR_TABINDEX |
TIDY_ATTR_TARGET |
TIDY_ATTR_TEXT |
TIDY_ATTR_TITLE |
TIDY_ATTR_TOPMARGIN |
TIDY_ATTR_TYPE |
TIDY_ATTR_USEMAP |
TIDY_ATTR_VALIGN |
TIDY_ATTR_VALUE |
TIDY_ATTR_VALUETYPE |
TIDY_ATTR_VERSION |
TIDY_ATTR_VLINK |
TIDY_ATTR_VSPACE |
TIDY_ATTR_WIDTH |
TIDY_ATTR_WRAP |
TIDY_ATTR_XML_LANG |
TIDY_ATTR_XML_SPACE |
TIDY_ATTR_XMLNS |

표 4. tidy nodetype constants

constant | description
TIDY_NODETYPE_ROOT |
TIDY_NODETYPE_DOCTYPE |
TIDY_NODETYPE_COMMENT |
TIDY_NODETYPE_PROCINS |
TIDY_NODETYPE_TEXT |
TIDY_NODETYPE_START |
TIDY_NODETYPE_END |
TIDY_NODETYPE_STARTEND |
TIDY_NODETYPE_CDATA |
TIDY_NODETYPE_SECTION |
TIDY_NODETYPE_ASP |
TIDY_NODETYPE_JSTE |
TIDY_NODETYPE_PHP |
TIDY_NODETYPE_XMLDECL |

차례
ob_tidyhandler -- ob_start callback function to repair the buffer
tidy_access_count -- Returns the Number of Tidy accessibility warnings encountered for specified document.
tidy_clean_repair -- Execute configured cleanup and repair operations on parsed markup
tidy_config_count -- Returns the Number of Tidy configuration errors encountered for specified document.
tidy_diagnose -- Run configured diagnostics on parsed and repaired markup.
tidy_error_count -- Returns the Number of Tidy errors encountered for specified document.
tidy_get_body -- Returns a TidyNode Object starting from the <body> tag of the tidy parse tree
tidy_get_config -- Get current Tidy configuration
tidy_get_error_buffer -- Return warnings and errors which occurred parsing the specified document
tidy_get_head -- Returns a TidyNode Object starting from the <head> tag of the tidy parse tree
tidy_get_html_ver -- Get the Detected HTML version for the specified document.
tidy_get_html -- Returns a TidyNode Object starting from the <html> tag of the tidy parse tree
tidy_get_output -- Return a string representing the parsed tidy markup
tidy_get_release -- Get release date (version) for Tidy library
tidy_get_root -- Returns a TidyNode Object representing the root of the tidy parse tree
tidy_get_status -- Get status of specified document.
tidy_getopt -- Returns the value of the specified configuration option for the tidy document.
tidy_is_xhtml -- Indicates if the document is a XHTML document.
tidy_is_xml -- Indicates if the document is a generic (non HTML/XHTML) XML document.
tidy_load_config -- Load an ASCII Tidy configuration file with the specified encoding
tidy_node->attributes -- Returns an array of attribute objects for node
tidy_node->children -- Returns an array of child nodes
tidy_node->get_attr -- Return the attribute with the provided attribute id
tidy_node->get_nodes -- Return an array of nodes under this node with the specified id
tidy_node->hasChildren -- Returns true if this node has children
tidy_node->hasSiblings -- Returns true if this node has siblings
tidy_node->isAsp -- Returns true if this node is ASP
tidy_node->isComment -- Returns true if this node represents a comment
tidy_node->isHtml -- Returns true if this node is part of a HTML document
tidy_node->isJste -- Returns true if this node is JSTE
tidy_node->isPhp -- Returns true if this node is PHP
tidy_node->isText -- Returns true if this node represents text (no markup)
tidy_node->isXhtml -- Returns true if this node is part of a XHTML document
tidy_node->isXml -- Returns true if this node is part of a XML document
tidy_node->next -- Returns the next sibling to this node
tidy_node->prev -- Returns the previous sibling to this node
tidy_node->tidy_node -- Constructor.
tidy_parse_file -- Parse markup in file or URI
tidy_parse_string -- Parse a document stored in a string
tidy_repair_file -- Repair a file and return it as a string
tidy_repair_string -- Repair a string using an optionally provided configuration file
tidy_reset_config -- Restore Tidy configuration to default values
tidy_save_config -- Save current settings to named file. Only non-default values are written.
tidy_set_encoding -- Set the input/output character encoding for parsing markup.
tidy_setopt -- Updates the configuration settings for the specified tidy document.
tidy_warning_count -- Returns the Number of Tidy warnings encountered for specified document.

이전 | 처음으로 | 다음
tcpwrap_check | 위로 | ob_tidyhandler


ob_tidyhandler

(PHP 5)

ob_tidyhandler -- ob_start callback function to repair the buffer

Description

string ob_tidyhandler ( string input [, int mode])

ob_tidyhandler() is intended to be used as a callback function for ob_start() to repair the buffer.

예 1. ob_tidyhandler() example

<?php
ob_start('ob_tidyhandler');

echo '<p>test</i>';
?>

The above example will output:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title></title>
</head>
<body>
<p>test</p>
</body>
</html>

See also ob_start().

이전 | 처음으로 | 다음
Tidy Functions | 위로 | tidy_access_count


tidy_access_count

(PHP 5)

tidy_access_count -- Returns the Number of Tidy accessibility warnings encountered for specified document.

Description

int tidy_access_count ( resource tidy)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
ob_tidyhandler | 위로 | tidy_clean_repair


tidy_clean_repair

(PHP 5)

tidy_clean_repair -- Execute configured cleanup and repair operations on parsed markup

Description

bool tidy_clean_repair ( resource tidy)

This function cleans and repairs the given tidy resource.

예 1. tidy_clean_repair() example

<?php
$html = '<p>test</I>';

$tidy = tidy_parse_string($html);
tidy_clean_repair($tidy);

echo $tidy;
?>

The above example will output:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title></title>
</head>
<body>
<p>test</p>
</body>
</html>

See also tidy_repair_file() and tidy_repair_string().

이전 | 처음으로 | 다음
tidy_access_count | 위로 | tidy_config_count


tidy_config_count

(PHP 5)

tidy_config_count -- Returns the Number of Tidy configuration errors encountered for specified document.

Description

int tidy_config_count ( resource tidy)

tidy_config_count() returns the number of errors encountered in the given configuration.

예 1. tidy_config_count() example

<?php
$html = '<p>test</I>';

$config = array('foo' => 'bar');

$tidy = tidy_parse_string($html, $config);

echo tidy_config_count($tidy); //1
?>

이전 | 처음으로 | 다음
tidy_clean_repair | 위로 | tidy_diagnose


tidy_diagnose

(PHP 5)

tidy_diagnose -- Run configured diagnostics on parsed and repaired markup.

Description

bool tidy_diagnose ( resource tidy)

tidy_diagnose() runs diagnostic tests on the given resource.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
tidy_config_count | 위로 | tidy_error_count


tidy_error_count

(PHP 5)

tidy_error_count -- Returns the Number of Tidy errors encountered for specified document.

Description

int tidy_error_count ( resource tidy)

tidy_error_count() returns the number of Tidy errors encountered for the specified document.

예 1. tidy_error_count() example

<?php
$html = '<p>test</i>
<bogustag>bogus</bogustag>';

$tidy = tidy_parse_string($html);

echo tidy_error_count($tidy) . "\n"; //1

echo $tidy->error_buf;
?>

The above example will output:

1
line 1 column 1 - Warning: missing <!DOCTYPE> declaration
line 1 column 8 - Warning: discarding unexpected </i>
line 2 column 1 - Error: <bogustag> is not recognized!
line 2 column 1 - Warning: discarding unexpected <bogustag>
line 2 column 16 - Warning: discarding unexpected </bogustag>
line 1 column 1 - Warning: inserting missing 'title' element

See also tidy_access_count() and tidy_warning_count().

이전 | 처음으로 | 다음
tidy_diagnose | 위로 | tidy_get_body


tidy_get_body

(PHP 5)

tidy_get_body -- Returns a TidyNode Object starting from the <body> tag of the tidy parse tree

Description

object tidy_get_body ( resource tidy)

This function returns a TidyNode object starting from the <body> tag of the tidy parse tree.

예 1. tidy_get_body() example

<?php
$html = '
<html>
  <head>
    <title>test</title>
  </head>
  <body>
    <p>paragraph</p>
  </body>
</html>';

$tidy = tidy_parse_string($html);

$body = tidy_get_body($tidy);
echo $body->value;
?>

The above example will output:

<body>
<p>paragraph</p>
</body>

참고: 이 함수는 Zend Engine 2(PHP >= 5.0.0)에서만 사용할 수 있습니다.

See also tidy_get_head() and tidy_get_html().

이전 | 처음으로 | 다음
tidy_error_count | 위로 | tidy_get_config


tidy_get_config

(PHP 5)

tidy_get_config -- Get current Tidy configuration

Description

array tidy_get_config ( resource tidy)

tidy_get_config() returns an array with the configuration options in use by the given resource.

For a explanation about each option, visit http://tidy.sourceforge.net/docs/quickref.html.

예 1. tidy_get_config() example

<?php
$html = '<p>test</p>';
$config = array('indent' => TRUE,
                'output-xhtml' => TRUE,
                'wrap', 200);

$tidy = tidy_parse_string($html, $config);

print_r(tidy_get_config($tidy));
?>

The above example will output:

Array
(
    [indent-spaces] => 2
    [wrap] => 68
    [tab-size] => 8
    [char-encoding] => 1
    [input-encoding] => 3
    [output-encoding] => 1
    [newline] => 1
    [doctype-mode] => 1
    [doctype] =>
    [repeated-attributes] => 1
    [alt-text] =>
    [slide-style] =>
    [error-file] =>
    [output-file] =>
    [write-back] =>
    [markup] => 1
    [show-warnings] => 1
    [quiet] =>
    [indent] => 1
    [hide-endtags] =>
    [input-xml] =>
    [output-xml] => 1
    [output-xhtml] => 1
    [output-html] =>
    [add-xml-decl] =>
    [uppercase-tags] =>
    [uppercase-attributes] =>
    [bare] =>
    [clean] =>
    [logical-emphasis] =>
    [drop-proprietary-attributes] =>
    [drop-font-tags] =>
    [drop-empty-paras] => 1
    [fix-bad-comments] => 1
    [break-before-br] =>
    [split] =>
    [numeric-entities] =>
    [quote-marks] =>
    [quote-nbsp] => 1
    [quote-ampersand] => 1
    [wrap-attributes] =>
    [wrap-script-literals] =>
    [wrap-sections] => 1
    [wrap-asp] => 1
    [wrap-jste] => 1
    [wrap-php] => 1
    [fix-backslash] => 1
    [indent-attributes] =>
    [assume-xml-procins] =>
    [add-xml-space] =>
    [enclose-text] =>
    [enclose-block-text] =>
    [keep-time] =>
    [word-2000] =>
    [tidy-mark] =>
    [gnu-emacs] =>
    [gnu-emacs-file] =>
    [literal-attributes] =>
    [show-body-only] =>
    [fix-uri] => 1
    [lower-literals] => 1
    [hide-comments] =>
    [indent-cdata] =>
    [force-output] => 1
    [show-errors] => 6
    [ascii-chars] => 1
    [join-classes] =>
    [join-styles] => 1
    [escape-cdata] =>
    [language] =>
    [ncr] => 1
    [output-bom] => 2
    [replace-color] =>
    [css-prefix] =>
    [new-inline-tags] =>
    [new-blocklevel-tags] =>
    [new-empty-tags] =>
    [new-pre-tags] =>
    [accessibility-check] => 0
    [vertical-space] =>
    [punctuation-wrap] =>
)

See also tidy_reset_config() and tidy_save_config().

이전 | 처음으로 | 다음
tidy_get_body | 위로 | tidy_get_error_buffer


tidy_get_error_buffer

(PHP 5)

tidy_get_error_buffer -- Return warnings and errors which occurred parsing the specified document

Description

string tidy_get_error_buffer ( resource tidy)

tidy_get_error_buffer() returns warnings and errors which occurred parsing the specified document.

예 1. tidy_get_error_buffer() example

<?php
$html = '<p>paragraph</p>';

$tidy = tidy_parse_string($html);
echo tidy_get_error_buffer($tidy);
?>

The above example will output:

line 1 column 1 - Warning: missing <!DOCTYPE> declaration
line 1 column 1 - Warning: inserting missing 'title' element

See also tidy_access_count(),
tidy_error_count() and
tidy_warning_count().

이전 | 처음으로 | 다음
tidy_get_config | 위로 | tidy_get_head


tidy_get_head

(PHP 5)

tidy_get_head -- Returns a TidyNode Object starting from the <head> tag of the tidy parse tree

Description

object tidy_get_head ( resource tidy)

This function returns a TidyNode object starting from the <head> tag of the tidy parse tree.

예 1. tidy_get_head() example

<?php
$html = '
<html>
  <head>
    <title>test</title>
  </head>
  <body>
    <p>paragraph</p>
  </body>
</html>';

$tidy = tidy_parse_string($html);

$head = tidy_get_head($tidy);
echo $head->value;
?>

The above example will output:

<head>
<title>test</title>
</head>

참고: 이 함수는 Zend Engine 2(PHP >= 5.0.0)에서만 사용할 수 있습니다.

See also tidy_get_body() and tidy_get_html().

이전 | 처음으로 | 다음
tidy_get_error_buffer | 위로 | tidy_get_html_ver


tidy_get_html_ver

(PHP 5)

tidy_get_html_ver -- Get the Detected HTML version for the specified document.

Description

int tidy_get_html_ver ( resource tidy)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
tidy_get_head | 위로 | tidy_get_html


tidy_get_html

(PHP 5)

tidy_get_html -- Returns a TidyNode Object starting from the <html> tag of the tidy parse tree

Description

object tidy_get_html ( resource tidy)

This function returns a TidyNode object starting from the <html> tag of the tidy parse tree.

예 1. tidy_get_html() example

<?php
$html = '
<html>
  <head>
    <title>test</title>
  </head>
  <body>
    <p>paragraph</p>
  </body>
</html>';

$tidy = tidy_parse_string($html);

$html = tidy_get_html($tidy);
echo $html->value;
?>

The above example will output:

<html>
<head>
<title>test</title>
</head>
<body>
<p>paragraph</p>
</body>
</html>

참고: 이 함수는 Zend Engine 2(PHP >= 5.0.0)에서만 사용할 수 있습니다.

See also tidy_get_body() and tidy_get_head().

이전 | 처음으로 | 다음
tidy_get_html_ver | 위로 | tidy_get_output


tidy_get_output

(PHP 5)

tidy_get_output -- Return a string representing the parsed tidy markup

Description

string tidy_get_output ( resource tidy)

tidy_get_output() returns a string with the repaired html.

예 1. tidy_get_output() example

<?php

$html = '<p>paragraph</i>';
$tidy = tidy_parse_string($html);

$tidy->CleanRepair();

echo tidy_get_output($tidy);
?>

The above example will output:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title></title>
</head>
<body>
<p>paragraph</p>
</body>
</html>

이전 | 처음으로 | 다음
tidy_get_html | 위로 | tidy_get_release


tidy_get_release

(PHP 5)

tidy_get_release -- Get release date (version) for Tidy library

Description

string tidy_get_release ( void )

This function returns a string with the release date of the Tidy library.

이전 | 처음으로 | 다음
tidy_get_output | 위로 | tidy_get_root


tidy_get_root

(PHP 5)

tidy_get_root -- Returns a TidyNode Object representing the root of the tidy parse tree

Description

object tidy_get_root ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: 이 함수는 Zend Engine 2(PHP >= 5.0.0)에서만 사용할 수 있습니다.

이전 | 처음으로 | 다음
tidy_get_release | 위로 | tidy_get_status


tidy_get_status

(PHP 5)

tidy_get_status -- Get status of specified document.

Description

int tidy_get_status ( resource tidy)

tidy_get_status() returns the status for the specified tidy resource. It returns 0 if no error/warning was raised, 1 for warnings or accessibility errors, or 2 for errors.

예 1. tidy_get_status() example

<?php
$html = '<p>paragraph</i>';
$tidy = tidy_parse_string($html);

$html2 = '<bogus>test</bogus>';
$tidy2 = tidy_parse_string($html2);

echo tidy_get_status($tidy); //1

echo tidy_get_status($tidy2); //2
?>

이전 | 처음으로 | 다음
tidy_get_root | 위로 | tidy_getopt


tidy_getopt

(PHP 5)

tidy_getopt -- Returns the value of the specified configuration option for the tidy document.

Description

mixed tidy_getopt ( string option)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
tidy_get_status | 위로 | tidy_is_xhtml


tidy_is_xhtml

(PHP 5)

tidy_is_xhtml -- Indicates if the document is a XHTML document.

Description

bool tidy_is_xhtml ( resource tidy)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
tidy_getopt | 위로 | tidy_is_xml


tidy_is_xml

(PHP 5)

tidy_is_xml -- Indicates if the document is a generic (non HTML/XHTML) XML document.

Description

bool tidy_is_xml ( resource tidy)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
tidy_is_xhtml | 위로 | tidy_load_config


tidy_load_config

(no version information, might be only in CVS)

tidy_load_config -- Load an ASCII Tidy configuration file with the specified encoding

Description

void tidy_load_config ( string filename, string encoding)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: This function is only avaliable in Tidy 1.0. It became obsolete in Tidy 2.0 and thus has been removed.

이전 | 처음으로 | 다음
tidy_is_xml | 위로 | tidy_node->attributes


tidy_node->attributes

(no version information, might be only in CVS)

tidy_node->attributes -- Returns an array of attribute objects for node

Description

array tidy_node->attributes ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
tidy_load_config | 위로 | tidy_node->children


tidy_node->children

(no version information, might be only in CVS)

tidy_node->children -- Returns an array of child nodes

Description

array tidy_node->children ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
tidy_node->attributes | 위로 | tidy_node->get_attr


tidy_node->get_attr

(no version information, might be only in CVS)

tidy_node->get_attr -- Return the attribute with the provided attribute id

Description

tidy_attr tidy_node->get_attr ( int attrib_id)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
tidy_node->children | 위로 | tidy_node->get_nodes


tidy_node->get_nodes

(no version information, might be only in CVS)

tidy_node->get_nodes -- Return an array of nodes under this node with the specified id

Description

array tidy_node->get_nodes ( int node_id)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
tidy_node->get_attr | 위로 | tidy_node->hasChildren


tidy_node->hasChildren

(no version information, might be only in CVS)

tidy_node->hasChildren -- Returns true if this node has children

Description

bool tidy_node->hasChildren ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: This functions was named tidy_node->has_children() in PHP 4/Tidy 1.

이전 | 처음으로 | 다음
tidy_node->get_nodes | 위로 | tidy_node->hasSiblings


tidy_node->hasSiblings

(no version information, might be only in CVS)

tidy_node->hasSiblings -- Returns true if this node has siblings

Description

bool tidy_node->hasSiblings ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: This functions was named tidy_node->has_siblings() in PHP 4/Tidy 1.

이전 | 처음으로 | 다음
tidy_node->hasChildren | 위로 | tidy_node->isAsp


tidy_node->isAsp

(no version information, might be only in CVS)

tidy_node->isAsp -- Returns true if this node is ASP

Description

bool tidy_node->isAsp ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: This functions was named tidy_node->is_asp() in PHP 4/Tidy 1.

이전 | 처음으로 | 다음
tidy_node->hasSiblings | 위로 | tidy_node->isComment


tidy_node->isComment

(no version information, might be only in CVS)

tidy_node->isComment -- Returns true if this node represents a comment

Description

bool tidy_node->isComment ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: This functions was named tidy_node->is_comment() in PHP 4/Tidy 1.

이전 | 처음으로 | 다음
tidy_node->isAsp | 위로 | tidy_node->isHtml


tidy_node->isHtml

(no version information, might be only in CVS)

tidy_node->isHtml -- Returns true if this node is part of a HTML document

Description

bool tidy_node->isHtml ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: This functions was named tidy_node->is_html() in PHP 4/Tidy 1.

이전 | 처음으로 | 다음
tidy_node->isComment | 위로 | tidy_node->isJste


tidy_node->isJste

(no version information, might be only in CVS)

tidy_node->isJste -- Returns true if this node is JSTE

Description

bool tidy_node->isJste ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: This functions was named tidy_node->is_jste() in PHP 4/Tidy 1.

이전 | 처음으로 | 다음
tidy_node->isHtml | 위로 | tidy_node->isPhp


tidy_node->isPhp

(no version information, might be only in CVS)

tidy_node->isPhp -- Returns true if this node is PHP

Description

bool tidy_node->isPhp ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: This functions was named tidy_node->is_php() in PHP 4/Tidy 1.

이전 | 처음으로 | 다음
tidy_node->isJste | 위로 | tidy_node->isText


tidy_node->isText

(no version information, might be only in CVS)

tidy_node->isText -- Returns true if this node represents text (no markup)

Description

bool tidy_node->isText ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: This functions was named tidy_node->is_text() in PHP 4/Tidy 1.

이전 | 처음으로 | 다음
tidy_node->isPhp | 위로 | tidy_node->isXhtml


tidy_node->isXhtml

(no version information, might be only in CVS)

tidy_node->isXhtml -- Returns true if this node is part of a XHTML document

Description

bool tidy_node->isXhtml ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: This functions was named tidy_node->is_xhtml() in PHP 4/Tidy 1.

이전 | 처음으로 | 다음
tidy_node->isText | 위로 | tidy_node->isXml


tidy_node->isXml

(no version information, might be only in CVS)

tidy_node->isXml -- Returns true if this node is part of a XML document

Description

bool tidy_node->isXml ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: This functions was named tidy_node->is_xml() in PHP 4/Tidy 1.

이전 | 처음으로 | 다음
tidy_node->isXhtml | 위로 | tidy_node->next


tidy_node->next

(no version information, might be only in CVS)

tidy_node->next -- Returns the next sibling to this node

Description

tidy_node tidy_node->next ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
tidy_node->isXml | 위로 | tidy_node->prev


tidy_node->prev

(no version information, might be only in CVS)

tidy_node->prev -- Returns the previous sibling to this node

Description

tidy_node tidy_node->prev ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
tidy_node->next | 위로 | tidy_node->tidy_node


tidy_node->tidy_node

(no version information, might be only in CVS)

tidy_node->tidy_node -- Constructor.

Description

void tidy_node->tidy_node ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
tidy_node->prev | 위로 | tidy_parse_file


tidy_parse_file

(PHP 5)

tidy_parse_file -- Parse markup in file or URI

Description

resource tidy_parse_file ( string filename [, mixed config [, string encoding [, bool use_include_path]]])

This function parses the given file.

config 인수는 배열이나 문자열을 전달할 수 있습니다. 문자열을 넘기면, 설정 파일의 이름을 의미합니다. 그 외에는 옵션 자체로 해석합니다. 각 옵션의 설명은 http://tidy.sourceforge.net/docs/quickref.html를 확인하십시오. encoding 인수는 입출력 문서의 인코등을 지정합니다. 가능한 encoding 값은: ascii, latin1, raw, utf8, iso2022, mac, win1252, utf16le, utf16be, utf16, big5, shiftjis.

예 1. tidy_parse_file() example

<?php
$tidy = tidy_parse_file('file.html');

$tidy->cleanRepair();

if(!empty($tidy->error_buf)) {
    echo "The following errors or warnings occured:\n";
    echo $tidy->error_buf;
}
?>

참고: The optional parameters config and encoding were added in Tidy 2.0.

See also tidy_parse_string(),
tidy_parse_string() and
tidy_repair_string().

이전 | 처음으로 | 다음
tidy_node->tidy_node | 위로 | tidy_parse_string


tidy_parse_string

(PHP 5)

tidy_parse_string -- Parse a document stored in a string

Description

resource tidy_parse_string ( string input [, mixed config [, string encoding]])

tidy_parse_string() parses a document stored in a string.

config 인수는 배열이나 문자열을 전달할 수 있습니다. 문자열을 넘기면, 설정 파일의 이름을 의미합니다. 그 외에는 옵션 자체로 해석합니다. 각 옵션의 설명은 http://tidy.sourceforge.net/docs/quickref.html를 확인하십시오. encoding 인수는 입출력 문서의 인코등을 지정합니다. 가능한 encoding 값은: ascii, latin1, raw, utf8, iso2022, mac, win1252, utf16le, utf16be, utf16, big5, shiftjis.

예 1. tidy_parse_string() example

<?php
ob_start();
?>

<html>
  <head>
   <title>test</title>
  </head>
  <body>
   <p>error<br>another line</i>
  </body>
</html>

<?php

$buffer = ob_get_clean();
$config = array('indent' => TRUE,
                'output-xhtml' => TRUE,
                'wrap', 200);

$tidy = tidy_parse_string($buffer, $config, 'UTF8');

$tidy->cleanRepair();
echo $tidy;
?>

The above example will output:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
  <head>
    <title>
      test
    </title>
  </head>
  <body>
    <p>
      error<br />
      another line
    </p>
  </body>
</html>

참고: The optional parameters config and encoding were added in Tidy 2.0.

See also tidy_parse_file(),
tidy_repair_file() and
tidy_repair_string().

이전 | 처음으로 | 다음
tidy_parse_file | 위로 | tidy_repair_file


tidy_repair_file

(PHP 5)

tidy_repair_file -- Repair a file and return it as a string

Description

string tidy_repair_file ( string filename [, mixed config [, string encoding [, bool use_include_path]]])

This function repairs the given file and returns it as a string.

config 인수는 배열이나 문자열을 전달할 수 있습니다. 문자열을 넘기면, 설정 파일의 이름을 의미합니다. 그 외에는 옵션 자체로 해석합니다. 각 옵션의 설명은 http://tidy.sourceforge.net/docs/quickref.html를 확인하십시오. encoding 인수는 입출력 문서의 인코등을 지정합니다. 가능한 encoding 값은: ascii, latin1, raw, utf8, iso2022, mac, win1252, utf16le, utf16be, utf16, big5, shiftjis.

예 1. tidy_repair_file() example

<?php
$file = 'file.html';

$repaired = tidy_repair_file($file);
rename($file, $file . '.bak');

file_put_contents($file, $repaired);
?>

참고: The optional parameters config and encoding were added in Tidy 2.0.

See also tidy_parse_file(),
tidy_parse_string() and
tidy_repair_string().

이전 | 처음으로 | 다음
tidy_parse_string | 위로 | tidy_repair_string


tidy_repair_string

(PHP 5)

tidy_repair_string -- Repair a string using an optionally provided configuration file

Description

string tidy_repair_string ( string data [, mixed config [, string encoding]])

This function repairs the given string.

config 인수는 배열이나 문자열을 전달할 수 있습니다. 문자열을 넘기면, 설정 파일의 이름을 의미합니다. 그 외에는 옵션 자체로 해석합니다. 각 옵션의 설명은 http://tidy.sourceforge.net/docs/quickref.html를 확인하십시오. encoding 인수는 입출력 문서의 인코등을 지정합니다. 가능한 encoding 값은: ascii, latin1, raw, utf8, iso2022, mac, win1252, utf16le, utf16be, utf16, big5, shiftjis.

예 1. tidy_repair_string() example

<?php
ob_start();
?>

<html>
  <head>
    <title>test</title>
  </head>
  <body>
    <p>error</i>
  </body>
</html>

<?php

$buffer = ob_get_clean();
$tidy = tidy_repair_string($buffer);

echo $tidy;
?>

The above example will output:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title>test</title>
</head>
<body>
<p>error</p>
</body>
</html>

참고: The optional parameters config and encoding were added in Tidy 2.0.

See also tidy_parse_file(),
tidy_parse_string() and
tidy_repair_file().

이전 | 처음으로 | 다음
tidy_repair_file | 위로 | tidy_reset_config


tidy_reset_config

(no version information, might be only in CVS)

tidy_reset_config -- Restore Tidy configuration to default values

Description

bool tidy_reset_config ( void )

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: This function is only avaliable in Tidy 1.0. It became obsolete in Tidy 2.0 and thus has been removed.

이전 | 처음으로 | 다음
tidy_repair_string | 위로 | tidy_save_config


tidy_save_config

(no version information, might be only in CVS)

tidy_save_config -- Save current settings to named file. Only non-default values are written.

Description

bool tidy_save_config ( string filename)

tidy_save_config() saves current settings to the specified file. Only non-default values are written.

See also tidy_get_config(),
tidy_getopt(),
tidy_reset_config() and
tidy_setopt().

참고: This function is only avaliable in Tidy 1.0. It became obsolete in Tidy 2.0 and thus has been removed.

이전 | 처음으로 | 다음
tidy_reset_config | 위로 | tidy_set_encoding


tidy_set_encoding

(no version information, might be only in CVS)

tidy_set_encoding -- Set the input/output character encoding for parsing markup.

Description

bool tidy_set_encoding ( string encoding)

Sets the encoding for input/output documents. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다. Possible values for encoding are ascii, latin1, raw, utf8, iso2022, mac, win1252, utf16le, utf16be, utf16, big5 and shiftjis.

참고: This function is only avaliable in Tidy 1.0. It became obsolete in Tidy 2.0 and thus has been removed.

이전 | 처음으로 | 다음
tidy_save_config | 위로 | tidy_setopt


tidy_setopt

(no version information, might be only in CVS)

tidy_setopt -- Updates the configuration settings for the specified tidy document.

Description

bool tidy_setopt ( string option, mixed value)

tidy_setopt() updates the specified option with a new value.

예 1. tidy_setopt() example

<?php
$html = '<p>test</i>';

$tidy = tidy_parse_string($html);

tidy_setopt('indent', FALSE);
?>

See also tidy_getopt(),
tidy_get_config(),
tidy_reset_config() and
tidy_save_config().

참고: This function is only avaliable in Tidy 1.0. It became obsolete in Tidy 2.0 and thus has been removed.

이전 | 처음으로 | 다음
tidy_set_encoding | 위로 | tidy_warning_count


tidy_warning_count

(PHP 5)

tidy_warning_count -- Returns the Number of Tidy warnings encountered for specified document.

Description

int tidy_warning_count ( resource tidy)

tidy_warning_count() returns the number of Tidy warnings encountered for the specified document.

예 1. tidy_warning_count() example

<?php
$html = '<p>test</i>
<bogustag>bogus</bogustag>';

$tidy = tidy_parse_string($html);

echo tidy_error_count($tidy) . "\n"; //1
echo tidy_warning_count($tidy) . "\n"; //5
?>

See also tidy_access_count() and tidy_error_count().

이전 | 처음으로 | 다음
tidy_setopt | 위로 | Tokenizer Functions


Tokenizer Functions

PHP 매뉴얼
이전 다음

CX. Tokenizer Functions

소개

The tokenizer functions provide an interface to the PHP tokenizer embedded in the Zend Engine. Using these functions you may write your own PHP source analyzing or modification tools without having to deal with the language specification at the lexical level.

See also the appendix about tokens.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

Beginning with PHP 4.3.0 these functions are enabled by default. For older versions you have to configure and compile PHP with --enable-tokenizer. You can disable tokenizer support with --disable-tokenizer.

PHP 윈도우 버전에서는 이 확장 모듈에 대한 지원이 포함되어 있습니다. 이 함수들을 이용하기 위해서 추가로 확장 모듈을 읽어들일 필요가 없습니다.

참고: Builtin support for tokenizer is available with PHP 4.3.0.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

T_INCLUDE (integer)

T_INCLUDE_ONCE (integer)

T_EVAL (integer)

T_REQUIRE (integer)

T_REQUIRE_ONCE (integer)

T_LOGICAL_OR (integer)

T_LOGICAL_XOR (integer)

T_LOGICAL_AND (integer)

T_PRINT (integer)

T_PLUS_EQUAL (integer)

T_MINUS_EQUAL (integer)

T_MUL_EQUAL (integer)

T_DIV_EQUAL (integer)

T_CONCAT_EQUAL (integer)

T_MOD_EQUAL (integer)

T_AND_EQUAL (integer)

T_OR_EQUAL (integer)

T_XOR_EQUAL (integer)

T_SL_EQUAL (integer)

T_SR_EQUAL (integer)

T_BOOLEAN_OR (integer)

T_BOOLEAN_AND (integer)

T_IS_EQUAL (integer)

T_IS_NOT_EQUAL (integer)

T_IS_IDENTICAL (integer)

T_IS_NOT_IDENTICAL (integer)

T_IS_SMALLER_OR_EQUAL (integer)

T_IS_GREATER_OR_EQUAL (integer)

T_SL (integer)

T_SR (integer)

T_INC (integer)

T_DEC (integer)

T_INT_CAST (integer)

T_DOUBLE_CAST (integer)

T_STRING_CAST (integer)

T_ARRAY_CAST (integer)

T_OBJECT_CAST (integer)

T_BOOL_CAST (integer)

T_UNSET_CAST (integer)

T_NEW (integer)

T_EXIT (integer)

T_IF (integer)

T_ELSEIF (integer)

T_ELSE (integer)

T_ENDIF (integer)

T_LNUMBER (integer)

T_DNUMBER (integer)

T_STRING (integer)

T_STRING_VARNAME (integer)

T_VARIABLE (integer)

T_NUM_STRING (integer)

T_INLINE_HTML (integer)

T_CHARACTER (integer)

T_BAD_CHARACTER (integer)

T_ENCAPSED_AND_WHITESPACE (integer)

T_CONSTANT_ENCAPSED_STRING (integer)

T_ECHO (integer)

T_DO (integer)

T_WHILE (integer)

T_ENDWHILE (integer)

T_FOR (integer)

T_ENDFOR (integer)

T_FOREACH (integer)

T_ENDFOREACH (integer)

T_DECLARE (integer)

T_ENDDECLARE (integer)

T_AS (integer)

T_SWITCH (integer)

T_ENDSWITCH (integer)

T_CASE (integer)

T_DEFAULT (integer)

T_BREAK (integer)

T_CONTINUE (integer)

T_OLD_FUNCTION (integer)

T_FUNCTION (integer)

T_CONST (integer)

T_RETURN (integer)

T_USE (integer)

T_GLOBAL (integer)

T_STATIC (integer)

T_VAR (integer)

T_UNSET (integer)

T_ISSET (integer)

T_EMPTY (integer)

T_CLASS (integer)

T_EXTENDS (integer)

T_OBJECT_OPERATOR (integer)

T_DOUBLE_ARROW (integer)

T_LIST (integer)

T_ARRAY (integer)

T_LINE (integer)

T_FILE (integer)

T_COMMENT (integer)

T_ML_COMMENT (integer)

참고: T_ML_COMMENT is not defined in PHP 5. All comments in PHP 5 are of token T_COMMENT.

T_DOC_COMMENT (integer)

참고: T_DOC_COMMENT was introduced in PHP 5.

T_OPEN_TAG (integer)

T_OPEN_TAG_WITH_ECHO (integer)

T_CLOSE_TAG (integer)

T_WHITESPACE (integer)

T_START_HEREDOC (integer)

T_END_HEREDOC (integer)

T_DOLLAR_OPEN_CURLY_BRACES (integer)

T_CURLY_OPEN (integer)

T_PAAMAYIM_NEKUDOTAYIM (integer)

T_DOUBLE_COLON (integer)

예제

Here is a simple example PHP scripts using the tokenizer that will read in a PHP file, strip all comments from the source and print the pure code only.

예 1. Strip comments with the tokenizer

<?php
  $source = file_get_contents("somefile.php");
  $tokens = token_get_all($source);
  /* T_ML_COMMENT does not exist in PHP 5.
   * The following three lines define it in order to
   * preserve backwards compatibility.
   *
   * The next two lines define the PHP 5-only T_DOC_COMMENT,
   * which we will mask as T_ML_COMMENT for PHP 4.
   */
  if (!defined('T_ML_COMMENT')) {
    define('T_ML_COMMENT', T_COMMENT);
  } else {
    define('T_DOC_COMMENT', T_ML_COMMENT);
  }
  foreach ($tokens as $token) {
    if (is_string($token)) {
      // simple 1-character token
      echo $token;
    } else {
      // token array
      list($id, $text) = $token;
      switch ($id) {
        case T_COMMENT:
        case T_ML_COMMENT: // we've defined this
        case T_DOC_COMMENT: // and this
          // no action on comments
          break;
        default:
          // anything else -> output "as is"
          echo $text;
          break;
      }
    }
  }
?>
차례
token_get_all -- Split given source into PHP tokens
token_name -- Get the symbolic name of a given PHP token

이전 | 처음으로 | 다음
tidy_warning_count | 위로 | token_get_all


token_get_all

(PHP 4 >= 4.2.0, PHP 5)

token_get_all -- Split given source into PHP tokens

Description

array token_get_all ( string source)

token_get_all() parses the given source string into PHP language tokens using the Zend engine's lexical scanner. The function returns an array of token identifiers. Each individual token identifier is either a single character (i.e.: ;, ., >, !, etc...), or a two element array containing the token index in element 0, and the string content of the original token in element 1.

For a list of parser tokens, see 부록 N, or use token_name() to translate a token value into its string representation.

예 1. token_get_all() examples

<?php
  $tokens = token_get_all('<?php'); // => array(array(T_OPEN_TAG, '<?'));
  $tokens = token_get_all('<?php echo; ?>'); /* => array(
                                                    array(T_OPEN_TAG, '<?php'),
                                                    array(T_ECHO, 'echo'),
                                                    ';',
                                                    array(T_CLOSE_TAG, '?>') ); */

/* Note in the following example that the string is parsed as T_INLINE_HTML
   rather than the otherwise expected T_COMMENT (T_ML_COMMENT in PHP <5).
   This is because no open/close tags were used in the "code" provided.
   This would be equivalent to putting a comment outside of <?php ?> tags in a normal file. */
  $tokens = token_get_all('/* comment */'); // => array(array(T_INLINE_HTML, '/* comment */'));
?>

이전 | 처음으로 | 다음
Tokenizer Functions | 위로 | token_name


token_name

(PHP 4 >= 4.2.0, PHP 5)

token_name -- Get the symbolic name of a given PHP token

Description

string token_name ( int token)

token_name() returns the symbolic name for a PHP token value. The symbolic name returned matches the name of the matching token constant.

예 1. token_name() example

<?php
  // 260 is the token value for the T_REQUIRE token
  echo token_name(260);        // -> "T_REQUIRE"

  // a token constant maps to its own name
  echo token_name(T_FUNCTION); // -> "T_FUNCTION"
?>

이전 | 처음으로 | 다음
token_get_all | 위로 | URL 함수


URL 함수

PHP 매뉴얼
이전 다음

CXI. URL 함수

소개

URL 문자열을 다룹니다: 인코딩, 디코딩, 파싱.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
base64_decode -- MIME base64 인코드 데이터를 디코드합니다.
base64_encode -- 데이터를 MIME base64로 인코드합니다.
get_headers -- Fetches all the headers sent by the server in response to a HTTP request
get_meta_tags -- 파일에서 모든 메타 태그 내용 요소를 추출하여 배열로 반환합니다.
http_build_query -- URL 인코드한 쿼리 문자열을 생성합니다.
parse_url -- URL을 처리해서 구성요소를 반환합니다.
rawurldecode -- URL 인코드 문자열을 디코드합니다.
rawurlencode -- RFC 1738에 따라 URL을 인코드합니다.
urldecode -- URL 인코드 문자열을 디코드합니다.
urlencode -- 문자열을 URL 인코드합니다.

이전 | 처음으로 | 다음
token_name | 위로 | base64_decode


base64_decode

(PHP 3, PHP 4 , PHP 5)

base64_decode -- MIME base64 인코드 데이터를 디코드합니다.

설명

string base64_decode ( string encoded_data)

base64_decode()는 encoded_data를 디코드하고 원 데이터를 반환하거나, 실패시에 FALSE를 반환합니다. 반환 데이터는 바이너리일 수 있습니다.

예 1. base64_decode() 예제

<?php
$str = 'VGhpcyBpcyBhbiBlbmNvZGVkIHN0cmluZw==';
echo base64_decode($str);
?>

이 예제의 결과는 :

This is an encoded string

참고: base64_encode(), RFC 2045 섹션 6.8.

이전 | 처음으로 | 다음
URL 함수 | 위로 | base64_encode


base64_encode

(PHP 3, PHP 4 , PHP 5)

base64_encode -- 데이터를 MIME base64로 인코드합니다.

설명

string base64_encode ( string data)

base64_encode()는 base64로 인코드한 data를 반환합니다. 이 인코딩은 메일 본문과 같이 8비트를 사용할 수 없는 전송층에서 바이너리 데이터를 안전하게 전송하기 위해 설계되었습니다.

Base64 인코드 데이터는 원 데이터보다 약 33% 많은 공간을 차지합니다.

예 1. base64_encode() 예제

<?php
  $str = 'This is an encoded string';
  echo base64_encode($str);
?>

이 예제의 결과는 :

VGhpcyBpcyBhbiBlbmNvZGVkIHN0cmluZw==

참고: base64_decode(), chunk_split(), RFC 2045 섹션 6.8.

이전 | 처음으로 | 다음
base64_decode | 위로 | get_headers


get_headers

(PHP 5)

get_headers -- Fetches all the headers sent by the server in response to a HTTP request

Description

array get_headers ( string url)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
base64_encode | 위로 | get_meta_tags


get_meta_tags

(PHP 3>= 3.0.4, PHP 4 , PHP 5)

get_meta_tags -- 파일에서 모든 메타 태그 내용 요소를 추출하여 배열로 반환합니다.

설명

array get_meta_tags ( string filename [, int use_include_path])

filename을 열어서 파일에서 줄 단위로 <meta> 태그를 처리합니다. 이는 로컬 파일이나 URL이 가능합니다. </head>을 만나면 중지합니다.

use_include_path를 1로 설정하면 PHP는 파일을 표준 인크루드 경로 include_path 지시어에 따라 찾습니다. 이는 로컬 파일에 사용하여, URL은 적용하지 않습니다.

예 1. get_meta_tags()가 처리하는 것

<meta name="author" content="name">
<meta name="keywords" content="php documentation">
<meta name="DESCRIPTION" content="a php manual">
<meta name="geo.position" content="49.33;-86.59">
</head> <!-- 여기서 파싱 정지 -->
(라인 끝에 주의하십시오 - PHP는 입력을 처리하는 내부 함수를 사용하기 때문에 맥 파일은 유닉스에서 작동하지 않습니다.)

name 속성값이 키가 되고, content 속성값이 반환 배열의 값이 됩니다. 간단히 표준 배열 함수로 변환하거나, 하나의 값에 접근할 수 있습니다. name 속성값의 특수 문자는 '_'로 치환하고, 나머지는 소문자로 변경합니다. 두 메타 태그가 같은 이름을 가지면, 마지막 것만을 반환합니다.

예 2. get_meta_tags()가 반환하는 것

<?php
// 위의 태그가 www.example.com에 있다고 가정하면
$tags = get_meta_tags('http://www.example.com/');

// 키가 전부 소문자가 되었고,
// .이 _로 치환되었다는 점에 주의하십시오.
echo $tags['author'];       // name
echo $tags['keywords'];     // php documentation
echo $tags['description'];  // a php manual
echo $tags['geo_position']; // 49.33;-86.59
?>

참고: PHP 4.0.5 부터, get_meta_tags()은 따옴표 없는 HTML 속성을 지원합니다.

참고: htmlentities(), urlencode().

이전 | 처음으로 | 다음
get_headers | 위로 | http_build_query


http_build_query

(PHP 5)

http_build_query -- URL 인코드한 쿼리 문자열을 생성합니다.

설명

string http_build_query ( array formdata [, string numeric_prefix])

주어진 연관(혹은 인덱스) 배열에서 URL 인코드한 쿼리 문자열을 생성합니다. formdata는 배열이나 속성을 가지는 객체일 수 있습니다. formdata는 단순한 1차원 구조일수도, 혹은 (다른 배열을 포함한)배열의 배열일 수 있습니다. 기본 배열에 숫자 인덱스를 사용하고 numeric_prefix가 주어지면, 기본 배열 안의 숫자 인덱스 앞에 덧붙여집니다. 이는 PHP나 다른 CGI 어플리케이션에 적합한 변수명을 가지도록 합니다.

예 1. http_build_query()의 간단한 사용법

<?php
$data = array('foo'=>'bar',
              'baz'=>'boom',
              'cow'=>'milk',
              'php'=>'hypertext processor');

echo http_build_query($data); // foo=bar&baz=boom&cow=milk&php=hypertext+processor
?>

예 2. http_build_query()와 숫자 인덱스 요소.

<?php
$data = array('foo', 'bar', 'baz', 'boom', 'cow' => 'milk', 'php' =>'hypertext processor');

echo http_build_query($data);
/* 출력:
      0=foo&1=bar&2=baz&3=boom&cow=milk&php=hypertext+processor
*/

echo http_build_query($data, 'myvar_');
/* 출력:
      myvar_0=foo&myvar_1=bar&myvar_2=baz&myvar_3=boom&cow=milk&php=hypertext+processor
*/
?>

예 3. http_build_query()와 복잡한 배열

<?php
$data = array('user'=>array('name'=>'Bob Smith',
                            'age'=>47,
                            'sex'=>'M',
                            'dob'=>'5/12/1956'),
              'pastimes'=>array('golf', 'opera', 'poker', 'rap'),
              'children'=>array('bobby'=>array('age'=>12,
                                               'sex'=>'M'),
                                'sally'=>array('age'=>8,
                                               'sex'=>'F')),
              'CEO');

echo http_build_query($data, 'flags_');
?>

출력은(읽기 편하도록 줄바꿈 처리):

user[name]=Bob+Smith&user[age]=47&user[sex]=M&user[dob]=5%1F12%1F1956&
pastimes[0]=golf&pastimes[1]=opera&pastimes[2]=poker&pastimes[3]=rap&
children[bobby][age]=12&children[bobby][sex]=M&children[sally][age]=8&
children[sally][sex]=F&flags_0=CEO

참고: 기본 배열의 숫자 인덱스 요소인 "CEO"만이 전치사를 가집니다. 내부에 존재하는 다른 숫자 인덱스는, 적합한 변수명을 가지기 위한 문자열 전치사가 필요하지 않습니다.

예 4. http_build_query()에 객체 사용하기

<?php
class myClass {
  var $foo;
  var $baz;

  function myClass()
  {
    $this->foo = 'bar';
    $this->baz = 'boom';
  }
}

$data = new myClass();

echo http_build_query($data); // foo=bar&baz=boom
?>

참고:
parse_str(),
parse_url(),
urlencode(),
array_walk()

이전 | 처음으로 | 다음
get_meta_tags | 위로 | parse_url


parse_url

(PHP 3, PHP 4 , PHP 5)

parse_url -- URL을 처리해서 구성요소를 반환합니다.

설명

array parse_url ( string url)

이 함수는 존재하는 URL의 다양한 구성요소를 포함하는 연관 배열을 반환합니다. 구성요소가 빠져있으면, 엔트리는 만들어지지 않습니다. 구성요소는 :

  • scheme - 예. http

  • host

  • port

  • user

  • pass

  • path

  • query - 물음표 ? 뒤

  • fragment - 해쉬마크 # 뒤

이 함수는 주어진 URL의 유효성을 검증하는 것이 아닙니다. 단지 위의 목록 부분으로 구분할 뿐입니다. 부분적인 URL도 받아들여지고, parse_url()은 가장 적합하게 처리하도록 시도합니다.

참고: 이 함수는 상대 URL에는 작동하지 않습니다.

예 1. parse_url() 예제

$ php -r 'print_r(parse_url("http://username:password@hostname/path?arg=value#anchor"));'
Array
(
    [scheme] => http
    [host] => hostname
    [user] => username
    [pass] => password
    [path] => /path
    [query] => arg=value
    [fragment] => anchor
)

$ php -r 'print_r(parse_url("http://invalid_host..name/"));'
Array
(
    [scheme] => http
    [host] => invalid_host..name
    [path] => /
)

참고: pathinfo(), parse_str(), dirname(), basename().

이전 | 처음으로 | 다음
http_build_query | 위로 | rawurldecode


rawurldecode

(PHP 3, PHP 4 , PHP 5)

rawurldecode -- URL 인코드 문자열을 디코드합니다.

설명

string rawurldecode ( string str)

퍼센트(%)에 이어지는 두 16진수 시퀀스를 표시 문자로 교체한 문자열을 반환합니다.

예 1. rawurldecode() 예제

<?php

echo rawurldecode('foo%20bar%40baz'); // foo bar@baz

?>

참고: rawurldecode()는 플러스 심볼('+')을 공백으로 변환하지 않습니다. urldecode()는 변환합니다.

참고: rawurlencode(),
urldecode(),
urlencode().

이전 | 처음으로 | 다음
parse_url | 위로 | rawurlencode


rawurlencode

(PHP 3, PHP 4 , PHP 5)

rawurlencode -- RFC 1738에 따라 URL을 인코드합니다.

설명

string rawurlencode ( string str)

-_.을 제외한 모든 영숫자가 아닌 문자를 퍼센트(%) 사인에 이어지는 두 16진수로 교체한 문자열을 반환합니다. 이는 표시 문자가 특별한 URL 구분자로 해석되는걸 방지하고, 문자 변환이 이루어지는 전송 매체(몇몇 email 시스템 등)에서 URL을 보호하기 위한 RFC 1738에 설명된 인코딩입니다. 예를 들어, FTP URL에 패스워드를 포함하고자 한다면:

예 1. rawurlencode() 예제 1

<?php
echo '<a href="ftp://user:', rawurlencode('foo @+%/'),
     '@ftp.example.com/x.txt">';
?>

혹은, URL의 PATH_INFO 안에 경로 정보를 전달하고자 한다면:

예 2. rawurlencode() 예제 2

<?php
echo '<a href="http://example.com/department_list_script/',
    rawurlencode('sales and marketing/Miami'), '">';
?>

참고: rawurldecode(),
urldecode(),
urlencode(),
RFC 1738.

이전 | 처음으로 | 다음
rawurldecode | 위로 | urldecode


urldecode

(PHP 3, PHP 4 , PHP 5)

urldecode -- URL 인코드 문자열을 디코드합니다.

설명

string urldecode ( string str)

주어진 문자열의 %## 인코딩을 디코드합니다. 디코드한 문자열을 반환합니다.

예 1. urldecode() 예제

<?php
$a = explode('&', $QUERY_STRING);
$i = 0;
while ($i < count($a)) {
    $b = split('=', $a[$i]);
    echo 'Value for parameter ', htmlspecialchars(urldecode($b[0])),
         ' is ', htmlspecialchars(urldecode($b[1])), "<br />\n";
    $i++;
}
?>

참고: urlencode(),
rawurlencode(),
rawurldecode().

이전 | 처음으로 | 다음
rawurlencode | 위로 | urlencode


urlencode

(PHP 3, PHP 4 , PHP 5)

urlencode -- 문자열을 URL 인코드합니다.

설명

string urlencode ( string str)

-_.을 제외한 모든 영숫자가 아닌 문자를 퍼센트(%) 사인에 이어지는 두 16진수로 교체하고 공백은 플러스(+) 사인으로 교체한 문자열을 반환합니다. 이는 WWW 폼에서 인코드한 포스트 데이터, application/x-www-form-urlencoded 매체형과 같은 방식의 인코드입니다. 역사적인 이유로 공백을 플러스(+) 사인으로 인코드 하는 점이 RFC1738 인코딩(rawurlencode() 참고)과 다릅니다. 이 함수는 URL의 쿼리 부분에 사용하는 문자열을 인코딩할 때 편리합니다. 다음과 같이 다음 페이지로 변수를 전달합니다:

예 1. urlencode() 예제

<?php
echo '<a href="mycgi?foo=', urlencode($userinput), '">';
?>

주의: HTML 엔티티가 들어있는 변수에는 주의를 기울이십시오. &amp, &copy, &pound 같은 것은 브라우저에 의해 파싱되어 변수명 대신에 엔티티가 사용됩니다. 이는 몇년동안 W3C가 두드러지게 이야기해온 문제입니다. 레퍼런스는 여기에 있습니다: http://www.w3.org/TR/html4/appendix/notes.html#h-B.2.2 PHP는 .ini 지시어의 arg_seperator를 통하여 W3C가 제시한 세미콜론 인수 구분자 변경을 지원합니다. 불행하게도 대부분의 유저 에이전트는 폼 데이터를 세미콜론 구분 형태로 전송하지 않습니다. 이를 해결하는 가장 현실적인 방법은 구분자로 &를 사용하는 대신 &amp;를 사용하는 것입니다. 이렇게 하면, PHP의 arg_separator를 변경할 필요가 없습니다. &로 내버려두고, 간단히 URL을 htmlentities(urlencode($data))를 사용하여 인코드하십시오.

예 2. urlencode()와 htmlentities() 예제

<?php
echo '<a href="mycgi?foo=', htmlentities(urlencode($userinput)), '">';
?>

참고: urldecode(),
htmlentities(),
rawurldecode(),
rawurlencode().

이전 | 처음으로 | 다음
urldecode | 위로 | 변수 관련 함수


변수 관련 함수

PHP 매뉴얼
이전 다음

CXII. 변수 관련 함수

소개

변수가 가지는 성질에 대한 정보는, 매뉴얼 언어 레퍼런스 섹션의 변수 엔트리를 참고하십시오.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. 변수 설정 옵션

이름 | 기본값 | 변경가능성
unserialize_callback_func | "" | PHP_INI_ALL
PHP_INI_* 상수에 관한 자세한 내용과 정의는 ini_set()을 참고하십시오.

위 설정 지시어에 대한 간단한 설명입니다.

unserialize_callback_func string

unserializer가 작성할 필요가 있는 미정의 클래스를 발견하면, (미정의 클래스 이름을 인자로) unserialize 콜백 함수를 호출합니다. 지정한 함수가 정의되어 있지 않거나, 함수가 존재하지 않는 클래스를 포함/상속하지 못하면 경고를 발생합니다. 콜백 함수가 필요한 경우에만, 이 엔트리를 지정하십시오.

참고: unserialize().

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
doubleval -- floatval()의 별칭
empty -- 변수가 비어있는지 검사합니다.
floatval -- 변수의 실수값을 얻습니다.
get_defined_vars -- 모든 정의된 변수의 배열을 반환합니다.
get_resource_type -- 자원형을 반환합니다.
gettype -- 변수 형을 얻습니다.
import_request_variables -- GET/POST/쿠키 변수를 전역으로 가져옵니다.
intval -- 변수의 정수값을 얻습니다.
is_array -- 변수가 배열인지 확인합니다.
is_bool -- 변수가 불린인지 확인합니다.
is_callable -- 변수의 내용이 함수처럼 호출할 수 있는지 확인합니다.
is_double -- is_float()의 별칭.
is_float -- 변수가 실수인지 확인합니다.
is_int -- 변수가 정수인지 확인합니다.
is_integer -- is_int()의 별칭.
is_long -- is_int()의 별칭.
is_null -- 변수가 NULL인지 확인합니다.
is_numeric -- 변수가 수나 수 문자열인지 확인합니다.
is_object -- 변수가 객체인지 확인합니다.
is_real -- is_float()의 별칭.
is_resource -- 변수가 자원인지 확인합니다.
is_scalar -- 변수가 스칼라인지 확인합니다.
is_string -- 변수가 문자열인지 확인합니다.
isset -- 존재하는 변수인지 확인합니다.
print_r -- 변수에 관한 정보를 사람이 읽기 좋게 출력합니다.
serialize -- 값의 저장 표현을 생성합니다.
settype -- 변수형을 설정합니다.
strval -- 변수의 문자열값을 얻습니다.
unserialize -- 저장 표현에서 PHP 값을 작성합니다.
unset -- 주어진 변수를 제거합니다.
var_dump -- 변수에 관한 정보를 덤프합니다.
var_export -- 변수의 표현을 출력하거나 문자열로 반환합니다.

이전 | 처음으로 | 다음
urlencode | 위로 | doubleval


doubleval

doubleval -- floatval()의 별칭

설명

이 함수는 floatval()의 별칭입니다.

참고: 함수명 변경시에 별칭으로 남겨졌습니다. 이전의 PHP에서는 floatval()이 존재하지 않았기 때문에, floatval() 대신 이 함수명을 사용해야 합니다.

이전 | 처음으로 | 다음
변수 관련 함수 | 위로 | empty


empty

(PHP 3, PHP 4, PHP 5 )

empty -- 변수가 비어있는지 검사합니다.

설명

bool empty ( mixed var)

empty()는 var가 비어있지 않고 제로가 아닌 값이라면 FALSE를 반환합니다. 즉, "", 0, "0", NULL, FALSE, array(), var $var, 비어있는 프로퍼티의 객체를 비어있는 것으로 판단합니다. var가 비어있다면 TRUE를 반환합니다.

empty()는 변수값이 지정되지 않았을 때 경고를 출력하지 않는 것을 제외하고, (boolean) var의 반대입니다. 자세한 정보는 불린으로 변경을 참고하십시오.

예 1. 간단한 empty() / isset() 비교입니다.

<?php
$var = 0;

// $var가 비어있기 때문에 true로 판단합니다.
if (empty($var)) {
    echo '$var is either 0, empty, or not set at all';
}

// $var가 지정되어 있기 때문에 true로 판단합니다.
if (isset($var)) {
    echo '$var is set even though it is empty';
}
?>

참고: 이것은 함수가 아닌 언어 구조이기 때문에, 변수 함수 방식으로 호출할 수 없습니다.

참고: 구문 에러일 경우를 제외하고 empty()은 변수를 확인할 뿐입니다. 즉, 다음과 같은 것은 작동하지 않습니다: empty(addslashes($name)).

참고: isset(),
unset(),
array_key_exists(),
count(),
strlen(),
타입 비교표.

이전 | 처음으로 | 다음
doubleval | 위로 | floatval


floatval

(PHP 4 >= 4.2.0, PHP 5)

floatval -- 변수의 실수값을 얻습니다.

설명

float floatval ( mixed var)

var의 float값을 반환합니다.

Var는 스칼라형을 받아들입니다. floatval()에 배열이나 객체를 사용할 수 없습니다.

<?php
$var = '122.34343The';
$float_value_of_var = floatval ($var);
echo $float_value_of_var; // 122.34343를 출력
?>

참고: intval(), strval(), settype(), 타입 저글링.

이전 | 처음으로 | 다음
empty | 위로 | get_defined_vars


get_defined_vars

(PHP 4 >= 4.0.4, PHP 5)

get_defined_vars -- 모든 정의된 변수의 배열을 반환합니다.

설명

array get_defined_vars ( void )

이 함수는 환경변수, 서버나 유저 정의 변수 등 모든 정의된 변수 목록을 포함하는 다차원 배열을 반환합니다.

<?php
$b = array(1, 1, 2, 3, 5, 8);

$arr = get_defined_vars();

// $b를 출력
print_r($arr["b"]);

/* PHP 인터프리터의 경로를 출력 (CGI로 사용할 때)
* 즉, /usr/local/bin/php */
echo $arr["_"];

// 명령줄 인자가 존재한다면 출력
print_r($arr["argv"]);

// 모든 서버 변수를 출력
print_r($arr["_SERVER"]);

// 변수 배열의 모든 키를 출력
print_r(array_keys(get_defined_vars()));
?>

참고: get_defined_functions(), get_defined_constants().

이전 | 처음으로 | 다음
floatval | 위로 | get_resource_type


get_resource_type

(PHP 4 >= 4.0.2, PHP 5)

get_resource_type -- 자원형을 반환합니다.

설명

string get_resource_type ( resource handle)

이 함수는 resource에 들어있는 형의 문자열 표현을 반환합니다. 인자가 유효하지 않은 resource라면, 에러를 발생합니다.

<?php
// 출력: mysql link
$c = mysql_connect();
echo get_resource_type($c) . "\n";

// 출력: file
$fp = fopen("foo", "w");
echo get_resource_type($fp) . "\n";

// 출력: domxml document
$doc = new_xmldoc("1.0");
echo get_resource_type($doc->doc) . "\n";
?>

이전 | 처음으로 | 다음
get_defined_vars | 위로 | gettype


gettype

(PHP 3, PHP 4 , PHP 5)

gettype -- 변수 형을 얻습니다.

설명

string gettype ( mixed var)

PHP 변수 var의 형을 반환합니다.

주의

gettype()을 어떤 형인지 시험하기 위해 사용하지 마십시오. 반환 문자열은 앞으로의 버전에서 바뀔 수 있습니다. 추가로, 문자열 비교를 수행하기 때문에 느립니다.

대신, is_* 함수를 사용하십시오.

반환 문자열의 가능한 값은:

  • "boolean" (PHP 4부터)

  • "integer"

  • "double" (역사적인 이유로 float의 경우에도 단순한 "float"가 아닌 "double"을 반환합니다)

  • "string"

  • "array"

  • "object"

  • "resource" (PHP 4부터)

  • "NULL" (PHP 4부터)

  • "user function" (PHP 3만, 배제됨)

  • "unknown type"

PHP 4에서는, 이전에 함수에 사용하던 gettype()
대신 function_exists()와
method_exists()을 사용해야 합니다.

참고:
settype(),
is_array(),
is_bool(),
is_float(),
is_integer(),
is_null(),
is_numeric(),
is_object(),
is_resource(),
is_scalar(),
is_string().

이전 | 처음으로 | 다음
get_resource_type | 위로 | import_request_variables


import_request_variables

(PHP 4 >= 4.1.0, PHP 5)

import_request_variables -- GET/POST/쿠키 변수를 전역으로 가져옵니다.

설명

bool import_request_variables ( string types [, string prefix])

GET/POST/쿠키 변수를 전역으로 가져옵니다. register_globals을 비활성화한 상태에서 몇몇 변수를 전역으로 다루고 싶을 때 유용합니다.

types 인수를 사용하여, 어떠한 요청 변수를 가져올지 지정할 수 있습니다. 'G', 'P', 'C' 문자가 GET, POST, 쿠키에 대응합니다. 대소문자는 구별하지 않습니다. 문자의 순서에 주의하십시오. "gp"를 사용하면, 같은 이름을 가지는 POST 변수가 GET 변수를 덮어씌웁니다. GPC 외의 문자는 무시합니다.

prefix 인자는 변수 이름 prefix로, 전역으로 가져오는 모든 변수의 이름 앞에 덧붙입니다. "userid"라는 이름의 GET 값을 prefix "pref_"와 함께 사용한다면, $pref_userid 이름의 전역 변수를 얻게 됩니다.

SERVER 등의 다른 변수를 전역으로 쓰고 싶다면, extract()를 사용할 수 있습니다.

참고: prefix 인자는 선택적이지만, 아무런 prefix를 지정하지 않거나, 빈 문자열을 사용한다면 E_NOTICE 레벨의 에러를 출력합니다. 이는 보안 문제가 발생할 수 있기 때문입니다. Notice 레벨 에러는 기본 에러 레포팅을 사용할 경우에는 표시되지 않습니다.

<?php
// 이는 GET과 POST 값을
// "rvar_" prefix로 가져옵니다.
import_request_variables("gP", "rvar_");

echo $rvar_foo;
?>

참고: $_REQUEST, register_globals, 예약 정의 변수, extract().

이전 | 처음으로 | 다음
gettype | 위로 | intval


intval

(PHP 3, PHP 4 , PHP 5)

intval -- 변수의 정수값을 얻습니다.

설명

int intval ( mixed var [, int base])

지정한 base 값에 따른 var의 integer값을 반환합니다. (기본 base는 10입니다)

var는 어떠한 스칼라형일 수 있습니다. intval()에 array나 object를 사용할 수 없습니다.

참고: intval()의 base 인자는 var 인자가 문자열이 아니라면 영향을 주지 않습니다.

참고: floatval(), strval(), settype(), 타입 저글링.

이전 | 처음으로 | 다음
import_request_variables | 위로 | is_array


is_array

(PHP 3, PHP 4 , PHP 5)

is_array -- 변수가 배열인지 확인합니다.

설명

bool is_array ( mixed var)

var가 array면 TRUE를, 아니라면 FALSE를 반환합니다.

예 1. 변수가 배열인지 확인

<?php
$yes = array('이', '변수는', '배열');

echo is_array($yes) ? '배열' : '배열 아님';
echo "\n"

$no = '이 변수는 문자열';

echo is_array($no) ? '배열' : '배열 아님';
?>

이 예제의 출력은:

배열
배열 아님

참고:
is_float(),
is_int(),
is_integer(),
is_string(),
is_object().

이전 | 처음으로 | 다음
intval | 위로 | is_bool


is_bool

(PHP 4 , PHP 5)

is_bool -- 변수가 불린인지 확인합니다.

설명

bool is_bool ( mixed var)

var 인자가 boolean이면 TRUE를 반환합니다.

예 1. is_bool() 예제

<?php
$a = false;
$b = 0;

// $a는 불린이기 때문에, true입니다.
if (is_bool($a)) {
    echo "불린입니다.";
}

// $b는 불린이 아니기 때문에, true가 아닙니다.
if (is_bool($b)) {
    echo "불린입니다.";
}
?>

참고:
is_array(),
is_float(),
is_int(),
is_integer(),
is_string(),
is_object().

이전 | 처음으로 | 다음
is_array | 위로 | is_callable


is_callable

(PHP 4 >= 4.0.6, PHP 5)

is_callable -- 변수의 내용이 함수처럼 호출할 수 있는지 확인합니다.

설명

bool is_callable ( mixed var [, bool syntax_only [, string callable_name]])

변수의 내용이 함수처럼 호출할 수 있는지 확인합니다. 변수가 유효한 함수의 이름을 포함하고 있는지, 혹은 인코드된 객체와 함수 이름을 가지는 배열인지를 간단히 확인할 수 있습니다.

var 인자는 문자열 변수에 저장한 함수의 이름이거나, 객체 안의 객체와 메쏘드의 이름일 수 있습니다. 예:
array($SomeObject, 'MethodName')

syntax_only 인자가 TRUE 라면 이 함수는 var가 함수나 메쏘드일 수 있는지만을 확인합니다. 이는 단순히 문자열이 아닌 변수나 유효하게 콜백에 사용할 수 있는 구조가 아닌 배열을 거부합니다. 유효한 것은 2 엔트리뿐이며, 첫번째는 객체나 문자열, 두번째는 문자열입니다.

callable_name 인자는 "호출할 수 있는 이름"을 받습니다. 아래의 예제에서 이는 "someClass:someMethod"입니다. 그러나 somClass::SomeMethod()가 호출할 수 있는 정적 메쏘드라면, 불가능하다는 점에 주의하십시오.

<?php
//  변수를 함수처럼 호출할 수 있는지
//  체크하는 방법.

//
//  함수를 포함하는 간단한 변수
//

function someFunction()
{
}

$functionVariable = 'someFunction';

var_dump(is_callable($functionVariable, false, $callable_name));  // bool(true)

echo $callable_name, "\n";  // someFunction

//
//  메쏘드를 포함하는 배열
//

class someClass {

  function someMethod()
  {
  }

}

$anObject = new someClass();

$methodVariable = array($anObject, 'someMethod');

var_dump(is_callable($methodVariable, true, $callable_name));  //  bool(true)

echo $callable_name, "\n";  //  someClass:someMethod

?>

이전 | 처음으로 | 다음
is_bool | 위로 | is_double


is_double

is_double -- is_float()의 별칭.

설명

이 함수는 is_float()의 별칭입니다.

이전 | 처음으로 | 다음
is_callable | 위로 | is_float


is_float

(PHP 3, PHP 4 , PHP 5)

is_float -- 변수가 실수인지 확인합니다.

설명

bool is_float ( mixed var)

var가 float라면 TRUE, 아니라면 FALSE를 반환합니다.

참고: 변수가 숫자나 숫자 문자열(폼 입력 등은 항상 문자열입니다)인지 확인하려면, is_numeric()을 사용해야 합니다.

참고:
is_bool(),
is_int(),
is_integer(),
is_numeric(),
is_string(),
is_array(),
is_object(),

이전 | 처음으로 | 다음
is_double | 위로 | is_int


is_int

(PHP 3, PHP 4 , PHP 5)

is_int -- 변수가 정수인지 확인합니다.

설명

bool is_int ( mixed var)

var가 integer이면 TRUE를, 아니라면 FALSE를 반환합니다.

참고: 변수가 수나 수 문자열(항상 문자열인 폼 입력 등)인지를 확인하려면, is_numeric()을 사용해야 합니다.

참고: is_bool(),
is_float(),
is_integer(),
is_numeric(),
is_string(),
is_array(),
is_object().

이전 | 처음으로 | 다음
is_float | 위로 | is_integer


is_integer

is_integer -- is_int()의 별칭.

설명

이 함수는 is_int()의 별칭입니다.

이전 | 처음으로 | 다음
is_int | 위로 | is_long


is_long

is_long -- is_int()의 별칭.

설명

이 함수는 is_int()의 별칭입니다.

이전 | 처음으로 | 다음
is_integer | 위로 | is_null


is_null

(PHP 4 >= 4.0.4, PHP 5)

is_null -- 변수가 NULL인지 확인합니다.

설명

bool is_null ( mixed var)

var가 null이면 TRUE를, 아니라면 FALSE를 반환합니다.

언제 변수를 NULL로 판단하는지에 대해 NULL형을 참고하십시오.

참고: NULL,
is_bool(),
is_numeric(),
is_float(),
is_int(),
is_string(),
is_object(),
is_array(),
is_integer(),
is_real().

이전 | 처음으로 | 다음
is_long | 위로 | is_numeric


is_numeric

(PHP 4 , PHP 5)

is_numeric -- 변수가 수나 수 문자열인지 확인합니다.

설명

bool is_numeric ( mixed var)

var가 수나 수 문자열이라면 TRUE를, 아니라면 FALSE를 반환합니다.

참고: is_bool(),
is_float(),
is_int(),
is_string(),
is_object(),
is_array(),
is_integer().

이전 | 처음으로 | 다음
is_null | 위로 | is_object


is_object

(PHP 3, PHP 4 , PHP 5)

is_object -- 변수가 객체인지 확인합니다.

설명

bool is_object ( mixed var)

var가 object면 TRUE를, 아니라면 FALSE를 반환합니다.

참고: is_bool(),
is_int(),
is_integer(),
is_float(),
is_string(),
is_array().

이전 | 처음으로 | 다음
is_numeric | 위로 | is_real


is_real

is_real -- is_float()의 별칭.

설명

이 함수는 is_float()의 별칭입니다.

이전 | 처음으로 | 다음
is_object | 위로 | is_resource


is_resource

(PHP 4 , PHP 5)

is_resource -- 변수가 자원인지 확인합니다.

설명

bool is_resource ( mixed var)

is_resource()은 var 인자에 주어진 변수가 resource면 TRUE를, 아니라면 FALSE를 반환합니다.

예 1. is_resource() 사용하기

<?php

$db_link = @mysql_connect('localhost', 'mysql_user', 'mysql_pass');
if (!is_resource($db_link)) {
    die('접속할 수 없습니다 : ' . mysql_error());
}

?>

자세한 정보는 resource형 문서를 참고하십시오.

이전 | 처음으로 | 다음
is_real | 위로 | is_scalar


is_scalar

(PHP 4 >= 4.0.5, PHP 5)

is_scalar -- 변수가 스칼라인지 확인합니다.

설명

bool is_scalar ( mixed var)

is_scalar()는 var 인자에 주어진 변수가 스칼라면 TRUE를, 아니라면 FALSE를 반환합니다.

스칼라 변수는 interger, float, string, boolean입니다. array, object, resource형은 스칼라가 아닙니다.

<?php
function show_var($var)
{
    if (is_scalar($var)) {
        echo $var;
    } else {
        var_dump($var);
    }
}
$pi = 3.1416;
$proteins = array("hemoglobin", "cytochrome c oxidase", "ferredoxin");

show_var($pi);
// prints: 3.1416

show_var($proteins)
// 출력:
// array(3) {
//   [0]=>
//   string(10) "hemoglobin"
//   [1]=>
//   string(20) "cytochrome c oxidase"
//   [2]=>
//   string(10) "ferredoxin"
// }
?>

참고: is_scalar()는 resource가 interger 기반으로 표현함에도 불구하고 resource형 값을 스칼라로 판단하지 않습니다. 이는 앞으로 변경될 수도 있습니다.

참고: is_bool(),
is_numeric(),
is_float(),
is_int(),
is_real(),
is_string(),
is_object(),
is_array(),
is_integer().

이전 | 처음으로 | 다음
is_resource | 위로 | is_string


is_string

(PHP 3, PHP 4 , PHP 5)

is_string -- 변수가 문자열인지 확인합니다.

설명

bool is_string ( mixed var)

var가 string이면 TRUE를, 아니라면 FALSE를 반환합니다.

참고:
is_bool(),
is_int(),
is_integer(),
is_float(),
is_real(),
is_object(),
is_array().

이전 | 처음으로 | 다음
is_scalar | 위로 | isset


isset

(PHP 3, PHP 4, PHP 5 )

isset -- 존재하는 변수인지 확인합니다.

설명

bool isset ( mixed var [, mixed var [, ...]])

var가 존재하면 TRUE를, 존재하지 않는 다면 FALSE를 반환합니다.

변수를 unset()으로 지우면, 더 이상 존재하지 않습니다. NULL로 지정한 변수를 확인하면 isset()은 FALSE를 반환합니다. NULL 바이트("\0")는 PHP NULL 상수와 다릅니다.

경고: isset()은 변수만을 받아들이며, 다른 것에는 문법 에러를 발생합니다. 상수가 정의되었는지 확인하려면 defined() 함수를 사용하십시오.

<?php

$var = '';

// TRUE이기에 텍스트를 출력합니다.
if (isset($var)) {
    echo "이 변수는 존재하기에 출력합니다.";
}

// 다음 예제는 isset()의 반환값을
// 출력하기 위해서 var_dump를 사용합니다.

$a = "test";
$b = "anothertest";

var_dump(isset($a));     // TRUE
var_dump(isset($a, $b)); // TRUE

unset ($a);

var_dump(isset($a));     // FALSE
var_dump(isset($a, $b)); // FALSE

$foo = NULL;
var_dump(isset($foo));   // FALSE

?>

배열 요소와도 작동합니다:

<?php

$a = array ('test' => 1, 'hello' => NULL);

var_dump(isset($a['test']));             // TRUE
var_dump(isset($a['foo']));              // FALSE
var_dump(isset($a['hello']));            // FALSE

// 'hello' 키는 NULL이기에 정의되지 않은 것으로 판단합니다.
// NULL 키를 확인하려면 다음을 실행하십시오:
var_dump(array_key_exists('hello', $a)); // TRUE

?>

참고: 이것은 함수가 아닌 언어 구조이기 때문에, 변수 함수 방식으로 호출할 수 없습니다.

참고: empty(), unset(), defined(), 타입 비교표, array_key_exists(), 에러 제어 @ 연산자.

이전 | 처음으로 | 다음
is_string | 위로 | print_r


print_r

(PHP 4 , PHP 5)

print_r -- 변수에 관한 정보를 사람이 읽기 좋게 출력합니다.

설명

bool print_r ( mixed expression [, bool return])

참고: return 인자는 PHP 4.3.0에서 추가되었습니다.

print_r()은 변수에 대한 정보를 사람이 읽을 수 있는 방법으로 표시합니다. string, integer, float이 주어지면, 값을 그대로 출력합니다. array가 주어지면, 키와 요소를 알아볼 수 있는 형태로 표현합니다. object에 대해서도 비슷하게 표현합니다. var_dump()와는 달리, print_r()과 var_export()는 PHP 5에서 protected 및 private 속성도 보여줍니다.

print_r()은 배열 포인터를 마지막으로 이동합니다. 처음으로 되돌리려면 reset()을 사용하십시오.

<pre>
<?php
    $a = array ('a' => 'apple', 'b' => 'banana', 'c' => array ('x', 'y', 'z'));
    print_r ($a);
?>
</pre>

출력은:

<pre>
Array
(
    [a] => apple
    [b] => banana
    [c] => Array
        (
            [0] => x
            [1] => y
            [2] => z
        )
)
</pre>

print_r()의 출력을 가져오려면, return 인자를 사용하십시오. 이 인자를 TRUE로 설정하면, print_r()은 출력을 표시(기본값)하는 대신, 반환값으로 내보냅니다.

예 1. return 인자 예제

<?php
    $b = array ('m' => 'monkey', 'foo' => 'bar', 'x' => array ('x', 'y', 'z'));
    $results = print_r($b, true); //$results가 print_r의 출력을 가집니다.
?>

참고: 4.3.0 이전 버전의 PHP에서 print_r()의 출력을 가져오려면, 출력 제어 함수를 이용하십시오.

참고: PHP 4.0.4 이전에는, 주어진 array이나 object가 자기 자신에의 직접적/비직접적 참조를 포함하고 있으면 print_r()은 무한 루프에 빠졌습니다. 예를 들면, print_r($GLOBALS)가 해당합니다. $GLOBALS는 자기 자신에의 참조를 포함하고 있는 전역 변수이기 때문입니다.

참고: ob_start(),
var_dump(),
var_export().

이전 | 처음으로 | 다음
isset | 위로 | serialize


serialize

(PHP 3>= 3.0.5, PHP 4 , PHP 5)

serialize -- 값의 저장 표현을 생성합니다.

설명

string serialize ( mixed value)

serialize()는 어디에도 저장할 수 있도록 value의 바이트 스트림 표현을 포함하는 문자열을 반환합니다.

이는 PHP 값을 저장하거나 전달할 때 형이나 구조를 잃어버리지 않게 합니다.

serialize된 문자열을 다시 PHP 변수로 만들때는, unserialize()를 사용합니다. serialize()는 resource형을 제외한 모든 형을 다릅니다. 심지어 자기 자신을 참조하는 배열을 serialize()할 수도 있습니다. 배열/객체 안의 참조는 serialize()할 때 저장됩니다.

객체를 일렬화할 때, 일렬화에 앞서 __sleep() 멤버 함수를 호출합니다. 이는 일렬화하기 전에 객체를 마지막으로 정리할 수 있도록 합니다. 비슷하게, unserialize()을 사용하려 객체를 되돌릴 때, __wakeup() 멤버 함수를 호출합니다.

참고: PHP 3에서, 객체 속성은 일렬화되지만, 메쏘드는 잃어버립니다. PHP 4에서는 이런 제한이 사라졌고, 속성과 메쏘드를 둘다 복구합니다. 자세한 정보는 클래스와 객체의 객체 일렬화하기 섹션을 참고하십시오.

예 1. serialize() 예제

<?php
// $session_data는 현재 사용자의 세션 정보를 다차원 배열로
// 가집니다. 요청의 마지막에 이것을 데이터베이스에 저장하기
// 위해서 serialize()를 사용합니다.

$conn = odbc_connect("webdb", "php", "chicken");
$stmt = odbc_prepare($conn,
      "UPDATE sessions SET data = ? WHERE id = ?");
$sqldata = array (serialize($session_data), $PHP_AUTH_USER);
if (!odbc_execute($stmt, &$sqldata)) {
    $stmt = odbc_prepare($conn,
     "INSERT INTO sessions (id, data) VALUES(?, ?)");
    if (!odbc_execute($stmt, &$sqldata)) {
        /* 무언가 잘못되었을때 할 일.. */
    }
}
?>

참고: unserialize().

이전 | 처음으로 | 다음
print_r | 위로 | settype


settype

(PHP 3, PHP 4 , PHP 5)

settype -- 변수형을 설정합니다.

설명

bool settype ( mixed var, string type)

var의 변수형을 type로 설정합니다.

사용할 수 있는 type의 값은:

  • "boolean" (혹은, PHP 4.2.0부터, "bool")

  • "integer" (혹은, PHP 4.2.0부터, "int")

  • "float" (PHP 4.2.0부터만 가능하고, 이전의 버전은 배제된 표현 "double"을 사용합니다)

  • "string"

  • "array"

  • "object"

  • "null" (PHP 4.2.0부터)

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

예 1. settype() 예제

<?php
$foo = "5bar"; // string
$bar = true;   // boolean

settype($foo, "integer"); // $foo는 5   (integer)
settype($bar, "string");  // $bar는 "1" (string)
?>

참고: gettype(), 타입 캐스팅, 타입 저글링.

이전 | 처음으로 | 다음
serialize | 위로 | strval


strval

(PHP 3, PHP 4 , PHP 5)

strval -- 변수의 문자열값을 얻습니다.

설명

string strval ( mixed var)

var의 string값을 반환합니다. 문자열로의 변환에 대한 자세한 정보는 string 문서를 참고하십시오.

var는 어떠한 스칼라형입니다. strval()에 배열이나 객체를 사용할 수 없습니다.

참고: floatval(), intval(), settype(), 타입 저글링.

이전 | 처음으로 | 다음
settype | 위로 | unserialize


unserialize

(PHP 3>= 3.0.5, PHP 4 , PHP 5)

unserialize -- 저장 표현에서 PHP 값을 작성합니다.

설명

mixed unserialize ( string str)

unserialize()은 하나의 일렬화된 변수(serialize() 참고)를 받아서 PHP 값으로 변환합니다. 변환한 값을 반환합니다. integer, float, string, array, object형이 될 수 있습니다. unserialize할 수 없는 문자열일 경우에는, FALSE를 반환합니다.

unserialize_callback_func 지시어: unserialize중에 정의되지 않은 클래스를 작성해야 할 경우에 콜백 함수를 호출할 수 있습니다. (완전하지 않은 object "__PHP_Incomplete_Class"를 얻는것을 방지할 수 있습니다) php.ini나 ini_set()이나 .htaccess를 이용하여 'unserialize_callback_func'를 정의하십시오. 정의되지 않은 클래스를 작성해야 할 때 마다, 호출됩니다. 이 기능을 비활성화 하려면 간단히 이 설정을 비워두십시오. unserialize_callback_func 지시어는 PHP 4.2.0부터 사용할 수 있습니다.

변수가 객체로 unserialize되고, 성공적으로 객체로 재구성되면, PHP는 자동적으로 __wakeup() 멤버 함수를 호출합니다. (존재한다면)

예 1. unserialize_callback_func 예제

<?php
$serialized_object='O:1:"a":1:{s:5:"value";s:3:"100";}';

// unserialize_callback_func 지시어는 PHP 4.2.0부터 사용할 수 있습니다.
ini_set('unserialize_callback_func', 'mycallback'); // 콜백 함수를 설정

function mycallback($classname)
{
    // 단지 클래스를 정의하는 파일을 포함합니다.
    // 어떤 클래스 정의가 필요한가는 $classname에서 얻을 수 있습니다.
}
?>

참고: PHP 3에서, 메쏘드는 일렬화된 객체를 unserialize할 때 복구되지 않습니다. PHP 4는 이 제한을 제거했고, 속성과 메쏘드를 둘 다 복구합니다. 자세한 정보는 클래스와 객체의 객체 일렬화하기 섹션을 참고하십시오.

예 2. unserialize() 예제

<?php
// 여기서는, 데이터베이스에서 가져온 문자열로부터 $session_data
// 배열에 세션 데이터를 읽어들일 때 unserialize()를 사용합니다.
// 이 예제는 serialize()에 설명된 예제를 보완합니다.

$conn = odbc_connect("webdb", "php", "chicken");
$stmt = odbc_prepare($conn, "SELECT data FROM sessions WHERE id = ?");
$sqldata = array ($PHP_AUTH_USER);
if (!odbc_execute($stmt, &$sqldata) || !odbc_fetch_into($stmt, &$tmp)) {
    // excute나 fetch가 실패하면, 빈 배열로 초기화합니다.
    $session_data = array();
} else {
    // 여기서는 일렬화된 데이터를 $tmp[0]에 가집니다.
    $session_data = unserialize($tmp[0]);
    if (!is_array($session_data)) {
        // 무언가 잘못되면, 빈 배열로 초기화합니다.
        $session_data = array();
    }
}
?>

참고: serialize().

이전 | 처음으로 | 다음
strval | 위로 | unset


unset

(PHP 3, PHP 4, PHP 5 )

unset -- 주어진 변수를 제거합니다.

설명

void unset ( mixed var [, mixed var [, mixed ...]])

unset()은 주어진 변수를 파괴합니다. PHP 3에서, unset()은 항상 TRUE를 반환했습니다. (정확히는, 정수값 1) 그러나 PHP 4에서, unset()은 true 함수가 아닙니다: 이제 구문입니다. 아무 값도 반환하지 않고, unset()의 결과를 가져오려고 하면 parse 에러가 생성됩니다.

예 1. unset() 예제

<?php
// 하나의 변수를 파괴
unset($foo);

// 배열의 한 요소를 파괴
unset($bar['quux']);

// 하나 이상의 변수를 파괴
unset($foo1, $foo2, $foo3);
?>

함수 안에서 unset()의 행동은 어떠한 변수형을 파괴하려 했는지에 따라 달라집니다.

함수 안에서 전역 변수를 unset()하면, 로컬 변수만 파괴됩니다. 호출한 환경에서 변수는 unset()을 호출하기 전과 같은 값을 유지합니다.

<?php
function destroy_foo()
{
    global $foo;
    unset($foo);
}

$foo = 'bar';
destroy_foo();
echo $foo;
?>

위 예제의 출력:

bar

함수 안에서 참조로 넘겨진 변수를 unset()하면, 로컬 변수만이 파괴됩니다. 호출한 함수에서 변수는 unset()을 호출하기 전과 동일한 값을 유지합니다.

<?php
function foo(&$bar)
{
    unset($bar);
    $bar = "blah";
}

$bar = 'something';
echo "$bar\n";

foo($bar);
echo "$bar\n";
?>

위 예제의 출력:

something
something

함수 안에서 정적 변수를 unset()하면, unset()은 변수와 모든 참조를 파괴합니다.

<?php
function foo() {
    static $a;
    $a++;
    echo "$a\n";
    unset($a);
}

foo();
foo();
foo();
?>

위 예제의 출력:

1
2
3

함수 안에서 전역 변수를 unset()하려면, $GLOBALS 배열을 사용할 수 있습니다:

<?php
function foo() {
    unset($GLOBALS['bar']);
}

$bar = "something";
foo();
?>

참고: 이것은 함수가 아닌 언어 구조이기 때문에, 변수 함수 방식으로 호출할 수 없습니다.

참고: isset(),
empty(),
array_splice().

이전 | 처음으로 | 다음
unserialize | 위로 | var_dump


var_dump

(PHP 3>= 3.0.5, PHP 4 , PHP 5)

var_dump -- 변수에 관한 정보를 덤프합니다.

설명

void var_dump ( mixed expression [, mixed expression [, ...]])

이 함수는 형과 값을 포함하는 하나 이상의 표현을 구조화된 정보로 보여줍니다. 배열과 객체는 구조를 보여주기 위해서 재귀적으로 확장합니다.

PHP 객체의 public 속성만을 출력으로 반환합니다. var_export()와 print_r()은 protected 및 private 속성도 반환합니다.

작은 정보: 어떠한 결과가 브라우저로 직접 출력될 때, 출력 제어 함수를 이용해서 이 함수의 출력을 잡아내고, (예를 들면) string으로 저장할 수 있습니다.

예 1. var_dump() 예제

<?php
$a = array (1, 2, array ("a", "b", "c"));
var_dump($a);
?>

출력:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  array(3) {
    [0]=>
    string(1) "a"
    [1]=>
    string(1) "b"
    [2]=>
    string(1) "c"
  }
}
<?php
$b = 3.1;
$c = true;
var_dump($b, $c);
?>

출력:

float(3.1)
bool(true)

참고: var_export(), print_r().

이전 | 처음으로 | 다음
unset | 위로 | var_export


var_export

(PHP 4 >= 4.2.0, PHP 5)

var_export -- 변수의 표현을 출력하거나 문자열로 반환합니다.

설명

mixed var_export ( mixed expression [, bool return])

이 함수는 넘겨진 변수에 대한 구조 정보를 반환합니다. 두가지 차이를 제외하고, var_dump()와 동일합니다. 첫번째는 반환하는 표현이 유효한 PHP 코드인 점이고, 두번째는 PHP 5에서 객체의 protected 및 private 속성을 반환하는 점입니다.

이 함수의 두번째 인자를 TRUE로 사용해서 변수 표현을 반환하도록 할 수 있습니다.

<?php
$a = array (1, 2, array ("a", "b", "c"));
var_export($a);
?>

출력:

array (
  0 => 1,
  1 => 2,
  2 =>
  array (
    0 => 'a',
    1 => 'b',
    2 => 'c',
  ),
)
<?php
$b = 3.1;
$v = var_export($b, true);
echo $v;
?>

출력:

3.1

참고: var_dump(), print_r().

이전 | 처음으로 | 다음
var_dump | 위로 | vpopmail Functions


vpopmail Functions

PHP 매뉴얼
이전 다음

CXIII. vpopmail Functions

소개

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

This extension has been moved from PHP as of PHP 4.3.0 and now vpopmail lives in PECL.

설치

In PHP 4, these functions are only available if PHP was configured with --with-vpopmail[=DIR].

차례
vpopmail_add_alias_domain_ex -- Add alias to an existing virtual domain
vpopmail_add_alias_domain -- Add an alias for a virtual domain
vpopmail_add_domain_ex -- Add a new virtual domain
vpopmail_add_domain -- Add a new virtual domain
vpopmail_add_user -- Add a new user to the specified virtual domain
vpopmail_alias_add -- insert a virtual alias
vpopmail_alias_del_domain -- deletes all virtual aliases of a domain
vpopmail_alias_del -- deletes all virtual aliases of a user
vpopmail_alias_get_all -- get all lines of an alias for a domain
vpopmail_alias_get -- get all lines of an alias for a domain
vpopmail_auth_user -- Attempt to validate a username/domain/password. Returns true/false
vpopmail_del_domain_ex -- Delete a virtual domain
vpopmail_del_domain -- Delete a virtual domain
vpopmail_del_user -- Delete a user from a virtual domain
vpopmail_error -- Get text message for last vpopmail error. Returns string
vpopmail_passwd -- Change a virtual user's password
vpopmail_set_user_quota -- Sets a virtual user's quota

이전 | 처음으로 | 다음
var_export | 위로 | vpopmail_add_alias_domain_ex


vpopmail_add_alias_domain_ex

(4.0.5 - 4.2.3 only)

vpopmail_add_alias_domain_ex -- Add alias to an existing virtual domain

Description

bool vpopmail_add_alias_domain_ex ( string olddomain, string newdomain)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
vpopmail Functions | 위로 | vpopmail_add_alias_domain


vpopmail_add_alias_domain

(4.0.5 - 4.2.3 only)

vpopmail_add_alias_domain -- Add an alias for a virtual domain

Description

bool vpopmail_add_alias_domain ( string domain, string aliasdomain)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
vpopmail_add_alias_domain_ex | 위로 | vpopmail_add_domain_ex


vpopmail_add_domain_ex

(4.0.5 - 4.2.3 only)

vpopmail_add_domain_ex -- Add a new virtual domain

Description

bool vpopmail_add_domain_ex ( string domain, string passwd [, string quota [, string bounce [, bool apop]]])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
vpopmail_add_alias_domain | 위로 | vpopmail_add_domain


vpopmail_add_domain

(4.0.5 - 4.2.3 only)

vpopmail_add_domain -- Add a new virtual domain

Description

bool vpopmail_add_domain ( string domain, string dir, int uid, int gid)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
vpopmail_add_domain_ex | 위로 | vpopmail_add_user


vpopmail_add_user

(4.0.5 - 4.2.3 only)

vpopmail_add_user -- Add a new user to the specified virtual domain

Description

bool vpopmail_add_user ( string user, string domain, string password [, string gecos [, bool apop]])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
vpopmail_add_domain | 위로 | vpopmail_alias_add


vpopmail_alias_add

(4.1.0 - 4.2.3 only)

vpopmail_alias_add -- insert a virtual alias

Description

bool vpopmail_alias_add ( string user, string domain, string alias)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
vpopmail_add_user | 위로 | vpopmail_alias_del_domain


vpopmail_alias_del_domain

(4.1.0 - 4.2.3 only)

vpopmail_alias_del_domain -- deletes all virtual aliases of a domain

Description

bool vpopmail_alias_del_domain ( string domain)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
vpopmail_alias_add | 위로 | vpopmail_alias_del


vpopmail_alias_del

(4.1.0 - 4.2.3 only)

vpopmail_alias_del -- deletes all virtual aliases of a user

Description

bool vpopmail_alias_del ( string user, string domain)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
vpopmail_alias_del_domain | 위로 | vpopmail_alias_get_all


vpopmail_alias_get_all

(4.1.0 - 4.2.3 only)

vpopmail_alias_get_all -- get all lines of an alias for a domain

Description

array vpopmail_alias_get_all ( string domain)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
vpopmail_alias_del | 위로 | vpopmail_alias_get


vpopmail_alias_get

(4.1.0 - 4.2.3 only)

vpopmail_alias_get -- get all lines of an alias for a domain

Description

array vpopmail_alias_get ( string alias, string domain)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
vpopmail_alias_get_all | 위로 | vpopmail_auth_user


vpopmail_auth_user

(4.0.5 - 4.2.3 only)

vpopmail_auth_user -- Attempt to validate a username/domain/password. Returns true/false

Description

bool vpopmail_auth_user ( string user, string domain, string password [, string apop])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
vpopmail_alias_get | 위로 | vpopmail_del_domain_ex


vpopmail_del_domain_ex

(4.0.5 - 4.2.3 only)

vpopmail_del_domain_ex -- Delete a virtual domain

Description

bool vpopmail_del_domain_ex ( string domain)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
vpopmail_auth_user | 위로 | vpopmail_del_domain


vpopmail_del_domain

(4.0.5 - 4.2.3 only)

vpopmail_del_domain -- Delete a virtual domain

Description

bool vpopmail_del_domain ( string domain)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
vpopmail_del_domain_ex | 위로 | vpopmail_del_user


vpopmail_del_user

(4.0.5 - 4.2.3 only)

vpopmail_del_user -- Delete a user from a virtual domain

Description

bool vpopmail_del_user ( string user, string domain)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
vpopmail_del_domain | 위로 | vpopmail_error


vpopmail_error

(4.0.5 - 4.2.3 only)

vpopmail_error -- Get text message for last vpopmail error. Returns string

Description

string vpopmail_error ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
vpopmail_del_user | 위로 | vpopmail_passwd


vpopmail_passwd

(4.0.5 - 4.2.3 only)

vpopmail_passwd -- Change a virtual user's password

Description

bool vpopmail_passwd ( string user, string domain, string password)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
vpopmail_error | 위로 | vpopmail_set_user_quota


vpopmail_set_user_quota

(4.0.5 - 4.2.3 only)

vpopmail_set_user_quota -- Sets a virtual user's quota

Description

bool vpopmail_set_user_quota ( string user, string domain, string quota)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
vpopmail_passwd | 위로 | W32api Functions


W32api Functions

PHP 매뉴얼
이전 다음

CXIV. W32api Functions

소개

This extension is a generic extension API to DLLs. This was originally written to allow access to the Win32 API from PHP, although you can also access other functions exported via other DLLs.

Currently supported types are generic PHP types (strings, booleans, floats, integers and nulls) and types you define with w32api_deftype().

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

요구 사항

This extension will only work on Windows systems.

설치

이 함수들은 설치하지 않아도 사용할 수 있습니다; PHP 코어의 일부입니다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

This extension defines one resource type, used for user defined types. The name of this resource is "dynaparm".

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

DC_MICROSOFT (integer)

DC_BORLAND (integer)

DC_CALL_CDECL (integer)

DC_CALL_STD (integer)

DC_RETVAL_MATH4 (integer)

DC_RETVAL_MATH8 (integer)

DC_CALL_STD_BO (integer)

DC_CALL_STD_MS (integer)

DC_CALL_STD_M8 (integer)

DC_FLAG_ARGPTR (integer)

예제

This example gets the amount of time the system has been running and displays it in a message box.

예 1. Get the uptime and display it in a message box

<?php
// Define constants needed, taken from
// Visual Studio/Tools/Winapi/WIN32API.txt
define("MB_OK", 0);

// Load the extension in
dl("php_w32api.dll");

// Register the GetTickCount function from kernel32.dll
w32api_register_function("kernel32.dll",
                         "GetTickCount",
                         "long");

// Register the MessageBoxA function from User32.dll
w32api_register_function("User32.dll",
                         "MessageBoxA",
                         "long");

// Get uptime information
$ticks = GetTickCount();

// Convert it to a nicely displayable text
$secs  = floor($ticks / 1000);
$mins  = floor($secs / 60);
$hours = floor($mins / 60);

$str = sprintf("You have been using your computer for:" .
                "\r\n %d Milliseconds, or \r\n %d Seconds" .
                "or \r\n %d mins or\r\n %d hours %d mins.",
                $ticks,
                $secs,
                $mins,
                $hours,
                $mins - ($hours*60));

// Display a message box with only an OK button and the uptime text
MessageBoxA(NULL,
            $str,
            "Uptime Information",
            MB_OK);
?>
차례
w32api_deftype -- Defines a type for use with other w32api_functions
w32api_init_dtype -- Creates an instance of the data type typename and fills it with the values passed
w32api_invoke_function -- Invokes function funcname with the arguments passed after the function name
w32api_register_function -- Registers function function_name from library with PHP
w32api_set_call_method -- Sets the calling method used

이전 | 처음으로 | 다음
vpopmail_set_user_quota | 위로 | w32api_deftype


w32api_deftype

(4.2.0 - 4.2.3 only)

w32api_deftype -- Defines a type for use with other w32api_functions

Description

bool w32api_deftype ( string typename, string member1_type, string member1_name [, string ... [, string ...]])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

If you would like to define a type for a w32api call, you need to call w32api_deftype(). This function takes 2n+1 arguments, where n is the number of members the type has. The first argument is the name of the type. After that is the type of the member followed by the members name (in pairs). A member type can be a user defined type. All the type names are case sensitive. Built in type names should be provided in lowercase. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
W32api Functions | 위로 | w32api_init_dtype


w32api_init_dtype

(4.2.0 - 4.2.3 only)

w32api_init_dtype -- Creates an instance of the data type typename and fills it with the values passed

Description

resource w32api_init_dtype ( string typename, mixed value [, mixed ...])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

This function creates an instance of the data type named typename, filling in the values of the data type. The typename parameter is case sensitive. You should give the values in the same order as you defined the data type with w32api_deftype(). The type of the resource returned is dynaparm.

이전 | 처음으로 | 다음
w32api_deftype | 위로 | w32api_invoke_function


w32api_invoke_function

(4.2.0 - 4.2.3 only)

w32api_invoke_function -- Invokes function funcname with the arguments passed after the function name

Description

mixed w32api_invoke_function ( string funcname, mixed argument [, mixed ...])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

w32api_invoke_function() tries to find the previously registered function, named funcname, passing the parameters you provided. The return type is the one you set when you registered the function, the value is the one returned by the function itself. Any of the arguments can be of any PHP type or w32api_deftype() defined type, as needed.

이전 | 처음으로 | 다음
w32api_init_dtype | 위로 | w32api_register_function


w32api_register_function

(4.2.0 - 4.2.3 only)

w32api_register_function -- Registers function function_name from library with PHP

Description

bool w32api_register_function ( string library, string function_name, string return_type)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

This function tries to find the function_name function in libary, and tries to import it into PHP. The function will be registered with the given return_type. This type can be a generic PHP type, or a type defined with w32api_deftype(). All type names are case sensitive. Built in type names should be provided in lowercase. 성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
w32api_invoke_function | 위로 | w32api_set_call_method


w32api_set_call_method

(4.2.0 - 4.2.3 only)

w32api_set_call_method -- Sets the calling method used

Description

void w32api_set_call_method ( int method)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

This function sets the method call type. The parameter can be one of the constants DC_CALL_CDECL or DC_CALL_STD. The extension default is DC_CALL_STD.

이전 | 처음으로 | 다음
w32api_register_function | 위로 | WDDX Functions


WDDX Functions

PHP 매뉴얼
이전 다음

CXV. WDDX Functions

소개

These functions are intended for work with WDDX.

요구 사항

In order to use WDDX, you will need to install the expat library (which comes with Apache 1.3.7 or higher).

설치

After installing expat compile PHP with --enable-wddx.

PHP 윈도우 버전에서는 이 확장 모듈에 대한 지원이 포함되어 있습니다. 이 함수들을 이용하기 위해서 추가로 확장 모듈을 읽어들일 필요가 없습니다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

예제

All the functions that serialize variables use the first element of an array to determine whether the array is to be serialized into an array or structure. If the first element has string key, then it is serialized into a structure, otherwise, into an array.

예 1. Serializing a single value with WDDX

<?php
echo wddx_serialize_value("PHP to WDDX packet example", "PHP packet");
?>

This example will produce:

<wddxPacket version='1.0'><header comment='PHP packet'/><data>
<string>PHP to WDDX packet example</string></data></wddxPacket>

예 2. Using incremental packets with WDDX

<?php
$pi = 3.1415926;
$packet_id = wddx_packet_start("PHP");
wddx_add_vars($packet_id, "pi");

/* Suppose $cities came from database */
$cities = array("Austin", "Novato", "Seattle");
wddx_add_vars($packet_id, "cities");

$packet = wddx_packet_end($packet_id);
echo $packet;
?>

This example will produce:

<wddxPacket version='1.0'><header comment='PHP'/><data><struct>
<var name='pi'><number>3.1415926</number></var><var name='cities'>
<array length='3'><string>Austin</string><string>Novato</string>
<string>Seattle</string></array></var></struct></data></wddxPacket>

참고: If you want to serialize non-ASCII characters you have to set the appropriate locale before doing so (see setlocale()).

차례
wddx_add_vars -- Add variables to a WDDX packet with the specified ID
wddx_deserialize -- Deserializes a WDDX packet
wddx_packet_end -- Ends a WDDX packet with the specified ID
wddx_packet_start -- Starts a new WDDX packet with structure inside it
wddx_serialize_value -- Serialize a single value into a WDDX packet
wddx_serialize_vars -- Serialize variables into a WDDX packet

이전 | 처음으로 | 다음
w32api_set_call_method | 위로 | wddx_add_vars


wddx_add_vars

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

wddx_add_vars -- Add variables to a WDDX packet with the specified ID

Description

bool wddx_add_vars ( int packet_id, mixed name_var [, mixed ...])

wddx_add_vars() is used to serialize passed variables and add the result to the packet specified by the packet_id. The variables to be serialized are specified in exactly the same way as wddx_serialize_vars().

이전 | 처음으로 | 다음
WDDX Functions | 위로 | wddx_deserialize


wddx_deserialize

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

wddx_deserialize -- Deserializes a WDDX packet

Description

mixed wddx_deserialize ( string packet)

wddx_deserialize() takes a packet string and deserializes it. It returns the result which can be string, number, or array. Note that structures are deserialized into associative arrays.

이전 | 처음으로 | 다음
wddx_add_vars | 위로 | wddx_packet_end


wddx_packet_end

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

wddx_packet_end -- Ends a WDDX packet with the specified ID

Description

string wddx_packet_end ( int packet_id)

wddx_packet_end() ends the WDDX packet specified by the packet_id and returns the string with the packet.

이전 | 처음으로 | 다음
wddx_deserialize | 위로 | wddx_packet_start


wddx_packet_start

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

wddx_packet_start -- Starts a new WDDX packet with structure inside it

Description

int wddx_packet_start ( [string comment])

Use wddx_packet_start() to start a new WDDX packet for incremental addition of variables. It takes an optional comment string and returns a packet ID for use in later functions. It automatically creates a structure definition inside the packet to contain the variables.

이전 | 처음으로 | 다음
wddx_packet_end | 위로 | wddx_serialize_value


wddx_serialize_value

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

wddx_serialize_value -- Serialize a single value into a WDDX packet

Description

string wddx_serialize_value ( mixed var [, string comment])

wddx_serialize_value() is used to create a WDDX packet from a single given value. It takes the value contained in var, and an optional comment string that appears in the packet header, and returns the WDDX packet.

이전 | 처음으로 | 다음
wddx_packet_start | 위로 | wddx_serialize_vars


wddx_serialize_vars

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

wddx_serialize_vars -- Serialize variables into a WDDX packet

Description

string wddx_serialize_vars ( mixed var_name [, mixed ...])

wddx_serialize_vars() is used to create a WDDX packet with a structure that contains the serialized representation of the passed variables.

wddx_serialize_vars() takes a variable number of arguments, each of which can be either a string naming a variable or an array containing strings naming the variables or another array, etc.

예 1. wddx_serialize_vars() example

<?php
$a = 1;
$b = 5.5;
$c = array("blue", "orange", "violet");
$d = "colors";

$clvars = array("c", "d");
echo wddx_serialize_vars("a", "b", $clvars);
?>

The above example will produce:
<wddxPacket version='1.0'><header/><data><struct><var name='a'><number>1</number></var>
<var name='b'><number>5.5</number></var><var name='c'><array length='3'>
<string>blue</string><string>orange</string><string>violet</string></array></var>
<var name='d'><string>colors</string></var></struct></data></wddxPacket>

이전 | 처음으로 | 다음
wddx_serialize_value | 위로 | XML 해석기 함수


XML 해석기 함수

PHP 매뉴얼
이전 다음

CXVI. XML 해석기 함수

소개

XML(eXtensible Markup Language)은 웹에서 구조화된 문서 교환을 위한 데이터 형식입니다. The World Wide Web consortium(W3C)에서 정의한 표준입니다. XML과 관련 기술에 대한 정보는 http://www.w3.org/XML/에서 볼 수 있습니다.

PHP 확장은 James Clark의 expat를 사용합니다. 이 툴킷은 XML 문서를 처리할 수 있게 하지만, 유효성을 검증하지는 않습니다. PHP에서도 지원하는 세가지 문자 인코딩을 지원합니다: US_ASCII, ISO-8859-1, UTF-8. UTF-16은 지원하지 않습니다.

이 확장은 XML 파서를 작성하고 여러가지 XML 이벤트에 대한 핸들러를 정의할 수 있게 합니다. 각각의 XML 파서는 조절할 수 있는 약간의 인자를 가집니다.

요구 사항

이 확장은 http://www.jclark.com/xml/expat.html에서 찾을 수 있는 expat를 사용합니다. expat에 들어있는 Makefile은 기본값으로 라이브러리를 생성하지 않기 때문에, 다음의 make 규칙을 사용할 수 있습니다:
libexpat.a: $(OBJS)
    ar -rc $@ $(OBJS)
    ranlib $@
expat의 소스 RPM 패키지는 http://sourceforge.net/projects/expat/에서 찾을 수 있습니다.

설치

이 함수들은 번들된 expat 라이브러리를 이용하여 기본값으로 활성화되어 있습니다. XML 지원을 비활성화 하려면 --disable-xml을 사용하십시오. PHP를 아파치 1.3.9 이상의 모듈로 컴파일한다면, PHP는 자동적으로 아파치에 번들된 expat를 사용합니다. 번들된 expat 라이브러리를 사용하지 않으려면, PHP 설정에 --with-expat-dir=DIR을 지정하십시오. DIR은 expat를 설치한 베이스 디렉토리를 지정해야 합니다.

PHP 윈도우 버전에서는 이 확장 모듈에 대한 지원이 포함되어 있습니다. 이 함수들을 이용하기 위해서 추가로 확장 모듈을 읽어들일 필요가 없습니다.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

xml

xml_parser_create()와 xml_parser_create_ns()가 반환하는 xml 자원은 xml 파서 인스탠스를 참조하고, 이 확장이 제공하는 함수들이 사용합니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

XML_ERROR_NONE (integer)

XML_ERROR_NO_MEMORY (integer)

XML_ERROR_SYNTAX (integer)

XML_ERROR_NO_ELEMENTS (integer)

XML_ERROR_INVALID_TOKEN (integer)

XML_ERROR_UNCLOSED_TOKEN (integer)

XML_ERROR_PARTIAL_CHAR (integer)

XML_ERROR_TAG_MISMATCH (integer)

XML_ERROR_DUPLICATE_ATTRIBUTE (integer)

XML_ERROR_JUNK_AFTER_DOC_ELEMENT (integer)

XML_ERROR_PARAM_ENTITY_REF (integer)

XML_ERROR_UNDEFINED_ENTITY (integer)

XML_ERROR_RECURSIVE_ENTITY_REF (integer)

XML_ERROR_ASYNC_ENTITY (integer)

XML_ERROR_BAD_CHAR_REF (integer)

XML_ERROR_BINARY_ENTITY_REF (integer)

XML_ERROR_ATTRIBUTE_EXTERNAL_ENTITY_REF (integer)

XML_ERROR_MISPLACED_XML_PI (integer)

XML_ERROR_UNKNOWN_ENCODING (integer)

XML_ERROR_INCORRECT_ENCODING (integer)

XML_ERROR_UNCLOSED_CDATA_SECTION (integer)

XML_ERROR_EXTERNAL_ENTITY_HANDLING (integer)

XML_OPTION_CASE_FOLDING (integer)

XML_OPTION_TARGET_ENCODING (integer)

XML_OPTION_SKIP_TAGSTART (integer)

XML_OPTION_SKIP_WHITE (integer)

이벤트 핸들러

정의된 XML 이벤트 핸들러는:

표 1. 지원하는 XML 핸들러

핸들러를 설정하는 PHP 함수 | 이벤트 설명
xml_set_element_handler() | 엘레멘트 이벤트는 XML 파서가 시작과 끝 태그에 도달했을 때 발생합니다. 시작 태그와 끝 태그에 별도의 핸들러가 존재합니다.
xml_set_character_data_handler() | Character data is roughly all the non-markup contents of XML documents, including whitespace between tags. Note that the XML parser does not add or remove any whitespace, it is up to the application (you) to decide whether whitespace is significant.
xml_set_processing_instruction_handler() | PHP 프로그래머는 이미 프로세싱 인스트럭션(PIs)에 익숙할 것입니다. <?php ?>는 프로세싱 인스트럭션이고, php은 "PI 타겟"이라 불립니다. 예약된 "XML"로 시작하는 PI 타겟들을 제외하면, 이들에 대한 핸들링은 어플리케이션 특화입니다.
xml_set_default_handler() | What goes not to another handler goes to the default handler. You will get things like the XML and document type declarations in the default handler.
xml_set_unparsed_entity_decl_handler() | 이 핸들러는 unparsed (NDATA) 엔트리의 정의를 호출합니다.
xml_set_notation_decl_handler() | 이 핸들러는 notation의 정의를 호출합니다.
xml_set_external_entity_ref_handler() | This handler is called when the XML parser finds a reference to an external parsed general entity. This can be a reference to a file or URL, for example. See the external entity example for a demonstration.

케이스 폴딩

The element handler functions may get their element names case-folded. Case-folding is defined by the XML standard as "a process applied to a sequence of characters, in which those identified as non-uppercase are replaced by their uppercase equivalents". In other words, when it comes to XML, case-folding simply means uppercasing.

By default, all the element names that are passed to the handler functions are case-folded. This behaviour can be queried and controlled per XML parser with the xml_parser_get_option() and xml_parser_set_option() functions, respectively.

오류 코드

다음 상수들이 XML 오류 코드로 정의되어 있습니다 (xml_parse()가 반환합니다):

XML_ERROR_NONE
XML_ERROR_NO_MEMORY
XML_ERROR_SYNTAX
XML_ERROR_NO_ELEMENTS
XML_ERROR_INVALID_TOKEN
XML_ERROR_UNCLOSED_TOKEN
XML_ERROR_PARTIAL_CHAR
XML_ERROR_TAG_MISMATCH
XML_ERROR_DUPLICATE_ATTRIBUTE
XML_ERROR_JUNK_AFTER_DOC_ELEMENT
XML_ERROR_PARAM_ENTITY_REF
XML_ERROR_UNDEFINED_ENTITY
XML_ERROR_RECURSIVE_ENTITY_REF
XML_ERROR_ASYNC_ENTITY
XML_ERROR_BAD_CHAR_REF
XML_ERROR_BINARY_ENTITY_REF
XML_ERROR_ATTRIBUTE_EXTERNAL_ENTITY_REF
XML_ERROR_MISPLACED_XML_PI
XML_ERROR_UNKNOWN_ENCODING
XML_ERROR_INCORRECT_ENCODING
XML_ERROR_UNCLOSED_CDATA_SECTION
XML_ERROR_EXTERNAL_ENTITY_HANDLING

문자 인코딩

PHP의 XML 확장은 유니코드 문자셋을 통해 서로 다른 문자 인코딩을 지원합니다. 문자 인코딩에는 소스 인코딩과 타겟 인코딩의 두 종류가 존재합니다. PHP 내부에서 문서 표현은 항상 UTF-8로 인코드되어 있습니다.

소스 인코딩은 XML 문서가 parse되었을 때 이루어집니다. XML 파서를 작성할 때, 소스 인코딩을 지정할 수 있습니다. (이 인코딩은 XML 파서가 종료될때까지 변경할 수 없습니다) 지원하는 소스 인코딩은 ISO-8859-1, US-ASCII, UTF-8입니다. 앞쪽의 두개는 싱글-바이트 인코딩이기에, 각각의 문자는 하나의 바이트로 표현됩니다. UTF-8은 1에서 4바이트 사이에서 다양한 수의 비트(21까지)를 조합하여 인코드할 수 있습니다. PHP에서 사용하는 기본 소스 인코딩은 ISO-8859-1입니다.

타겟 인코딩은 PHP가 XML 핸들러 함수에 데이터를 넘길 때 이루어집니다. XML 파서를 작성하면, 타겟 인코딩을 소스 인코딩과 동일하게 설정하지만, 이는 언제라도 변경할 수 있습니다. 타켓 인코딩은 문자 데이터뿐만 아니라 태그 이름과 프로세싱 인스트럭션 타겟에도 영향을 미칩니다.

If the XML parser encounters characters outside the range that its source encoding is capable of representing, it will return an error.

If PHP encounters characters in the parsed XML document that can not be represented in the chosen target encoding, the problem characters will be "demoted". Currently, this means that such characters are replaced by a question mark.

예제

XML 문서를 파싱하는 몇몇 예제 PHP 스크립트입니다.

XML 엘레멘트 구조 예제

This first example displays the structure of the start elements in a document with indentation.

예 1. XML 엘레멘트 구조 보기

<?php
$file = "data.xml";
$depth = array();

function startElement($parser, $name, $attrs)
{
    global $depth;
    for ($i = 0; $i < $depth[$parser]; $i++) {
        echo "  ";
    }
    echo "$name\n";
    $depth[$parser]++;
}

function endElement($parser, $name)
{
    global $depth;
    $depth[$parser]--;
}

$xml_parser = xml_parser_create();
xml_set_element_handler($xml_parser, "startElement", "endElement");
if (!($fp = fopen($file, "r"))) {
    die("XML 입력을 열 수 없습니다.");
}

while ($data = fread($fp, 4096)) {
    if (!xml_parse($xml_parser, $data, feof($fp))) {
        die(sprintf("XML 에러: %s at line %d",
                    xml_error_string(xml_get_error_code($xml_parser)),
                    xml_get_current_line_number($xml_parser)));
    }
}
xml_parser_free($xml_parser);
?>

XML 태그 매핑 예제

예 2. XML을 HTML로 맵

이 예제는 XML 문서의 태그를 직접 HTML 태그로 매핑합니다. "맵 배열"에 존재하지 않는 요소는 무시합니다. 물론, 이 예제는 특정한 XML 문서형에만 작동합니다.

<?php
$file = "data.xml";
$map_array = array(
    "BOLD"     => "B",
    "EMPHASIS" => "I",
    "LITERAL"  => "TT"
);

function startElement($parser, $name, $attrs)
{
    global $map_array;
    if (isset($map_array[$name])) {
        echo "<$map_array[$name]>";
    }
}

function endElement($parser, $name)
{
    global $map_array;
    if (isset($map_array[$name])) {
        echo "</$map_array[$name]>";
    }
}

function characterData($parser, $data)
{
    echo $data;
}

$xml_parser = xml_parser_create();
// use case-folding so we are sure to find the tag in $map_array
xml_parser_set_option($xml_parser, XML_OPTION_CASE_FOLDING, true);
xml_set_element_handler($xml_parser, "startElement", "endElement");
xml_set_character_data_handler($xml_parser, "characterData");
if (!($fp = fopen($file, "r"))) {
    die("XML 입력을 열 수 없습니다.");
}

while ($data = fread($fp, 4096)) {
    if (!xml_parse($xml_parser, $data, feof($fp))) {
        die(sprintf("XML 에러: %s at line %d",
                    xml_error_string(xml_get_error_code($xml_parser)),
                    xml_get_current_line_number($xml_parser)));
    }
}
xml_parser_free($xml_parser);
?>

XML 외부 엔티티 예제

This example highlights XML code. It illustrates how to use an external entity reference handler to include and parse other documents, as well as how PIs can be processed, and a way of determining "trust" for PIs containing code.

XML documents that can be used for this example are found below the example (xmltest.xml and xmltest2.xml.)

예 3. External Entity Example

<?php
$file = "xmltest.xml";

function trustedFile($file)
{
    // only trust local files owned by ourselves
    if (!eregi("^([a-z]+)://", $file)
        && fileowner($file) == getmyuid()) {
            return true;
    }
    return false;
}

function startElement($parser, $name, $attribs)
{
    echo "&lt;<font color=\"#0000cc\">$name</font>";
    if (sizeof($attribs)) {
        while (list($k, $v) = each($attribs)) {
            echo " <font color=\"#009900\">$k</font>=\"<font
                   color=\"#990000\">$v</font>\"";
        }
    }
    echo "&gt;";
}

function endElement($parser, $name)
{
    echo "&lt;/<font color=\"#0000cc\">$name</font>&gt;";
}

function characterData($parser, $data)
{
    echo "<b>$data</b>";
}

function PIHandler($parser, $target, $data)
{
    switch (strtolower($target)) {
        case "php":
            global $parser_file;
            // If the parsed document is "trusted", we say it is safe
            // to execute PHP code inside it.  If not, display the code
            // instead.
            if (trustedFile($parser_file[$parser])) {
                eval($data);
            } else {
                printf("Untrusted PHP code: <i>%s</i>",
                        htmlspecialchars($data));
            }
            break;
    }
}

function defaultHandler($parser, $data)
{
    if (substr($data, 0, 1) == "&" && substr($data, -1, 1) == ";") {
        printf('<font color="#aa00aa">%s</font>',
                htmlspecialchars($data));
    } else {
        printf('<font size="-1">%s</font>',
                htmlspecialchars($data));
    }
}

function externalEntityRefHandler($parser, $openEntityNames, $base, $systemId,
                                  $publicId) {
    if ($systemId) {
        if (!list($parser, $fp) = new_xml_parser($systemId)) {
            printf("Could not open entity %s at %s\n", $openEntityNames,
                   $systemId);
            return false;
        }
        while ($data = fread($fp, 4096)) {
            if (!xml_parse($parser, $data, feof($fp))) {
                printf("XML error: %s at line %d while parsing entity %s\n",
                       xml_error_string(xml_get_error_code($parser)),
                       xml_get_current_line_number($parser), $openEntityNames);
                xml_parser_free($parser);
                return false;
            }
        }
        xml_parser_free($parser);
        return true;
    }
    return false;
}

function new_xml_parser($file)
{
    global $parser_file;

    $xml_parser = xml_parser_create();
    xml_parser_set_option($xml_parser, XML_OPTION_CASE_FOLDING, 1);
    xml_set_element_handler($xml_parser, "startElement", "endElement");
    xml_set_character_data_handler($xml_parser, "characterData");
    xml_set_processing_instruction_handler($xml_parser, "PIHandler");
    xml_set_default_handler($xml_parser, "defaultHandler");
    xml_set_external_entity_ref_handler($xml_parser, "externalEntityRefHandler");

    if (!($fp = @fopen($file, "r"))) {
        return false;
    }
    if (!is_array($parser_file)) {
        settype($parser_file, "array");
    }
    $parser_file[$xml_parser] = $file;
    return array($xml_parser, $fp);
}

if (!(list($xml_parser, $fp) = new_xml_parser($file))) {
    die("could not open XML input");
}

echo "<pre>";
while ($data = fread($fp, 4096)) {
    if (!xml_parse($xml_parser, $data, feof($fp))) {
        die(sprintf("XML error: %s at line %d\n",
                    xml_error_string(xml_get_error_code($xml_parser)),
                    xml_get_current_line_number($xml_parser)));
    }
}
echo "</pre>";
echo "parse complete\n";
xml_parser_free($xml_parser);

?>

예 4. xmltest.xml

<?xml version='1.0'?>
<!DOCTYPE chapter SYSTEM "/just/a/test.dtd" [
<!ENTITY plainEntity "FOO entity">
<!ENTITY systemEntity SYSTEM "xmltest2.xml">
]>
<chapter>
 <TITLE>Title &plainEntity;</TITLE>
 <para>
  <informaltable>
   <tgroup cols="3">
    <tbody>
     <row><entry>a1</entry><entry morerows="1">b1</entry><entry>c1</entry></row>
     <row><entry>a2</entry><entry>c2</entry></row>
     <row><entry>a3</entry><entry>b3</entry><entry>c3</entry></row>
    </tbody>
   </tgroup>
  </informaltable>
 </para>
 &systemEntity;
 <section id="about">
  <title>About this Document</title>
  <para>
   <!-- this is a comment -->
   <?php echo 'Hi!  This is PHP version '.phpversion(); ?>
  </para>
 </section>
</chapter>

이 파일은 xmltest.xml에서 포함합니다:

예 5. xmltest2.xml

<?xml version="1.0"?>
<!DOCTYPE foo [
<!ENTITY testEnt "test entity">
]>
<foo>
   <element attrib="value"/>
   &testEnt;
   <?php echo "This is some more PHP code being executed."; ?>
</foo>

차례
utf8_decode -- Converts a string with ISO-8859-1 characters encoded with UTF-8 to single-byte ISO-8859-1.
utf8_encode -- Encodes an ISO-8859-1 string to UTF-8
xml_error_string -- Get XML parser error string
xml_get_current_byte_index -- Get current byte index for an XML parser
xml_get_current_column_number -- Get current column number for an XML parser
xml_get_current_line_number -- Get current line number for an XML parser
xml_get_error_code -- Get XML parser error code
xml_parse_into_struct -- Parse XML data into an array structure
xml_parse -- Start parsing an XML document
xml_parser_create_ns -- Create an XML parser with namespace support
xml_parser_create -- Create an XML parser
xml_parser_free -- Free an XML parser
xml_parser_get_option -- Get options from an XML parser
xml_parser_set_option -- Set options in an XML parser
xml_set_character_data_handler -- Set up character data handler
xml_set_default_handler -- Set up default handler
xml_set_element_handler -- Set up start and end element handlers
xml_set_end_namespace_decl_handler -- Set up end namespace declaration handler
xml_set_external_entity_ref_handler -- Set up external entity reference handler
xml_set_notation_decl_handler -- Set up notation declaration handler
xml_set_object -- Use XML Parser within an object
xml_set_processing_instruction_handler -- Set up processing instruction (PI) handler
xml_set_start_namespace_decl_handler -- Set up start namespace declaration handler
xml_set_unparsed_entity_decl_handler -- Set up unparsed entity declaration handler

이전 | 처음으로 | 다음
wddx_serialize_vars | 위로 | utf8_decode


utf8_decode

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

utf8_decode -- Converts a string with ISO-8859-1 characters encoded with UTF-8 to single-byte ISO-8859-1.

Description

string utf8_decode ( string data)

This function decodes data, assumed to be UTF-8 encoded, to ISO-8859-1.

See also utf8_encode() for an explanation of UTF-8 encoding.

이전 | 처음으로 | 다음
XML 해석기 함수 | 위로 | utf8_encode


utf8_encode

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

utf8_encode -- Encodes an ISO-8859-1 string to UTF-8

Description

string utf8_encode ( string data)

This function encodes the string data to UTF-8, and returns the encoded version. UTF-8 is a standard mechanism used by Unicode for encoding wide character values into a byte stream. UTF-8 is transparent to plain ASCII characters, is self-synchronized (meaning it is possible for a program to figure out where in the bytestream characters start) and can be used with normal string comparison functions for sorting and such. PHP encodes UTF-8 characters in up to four bytes, like this:

표 1. UTF-8 encoding

bytes | bits | representation
1 | 7 | 0bbbbbbb
2 | 11 | 110bbbbb 10bbbbbb
3 | 16 | 1110bbbb 10bbbbbb 10bbbbbb
4 | 21 | 11110bbb 10bbbbbb 10bbbbbb 10bbbbbb
Each b represents a bit that can be used to store character data.

이전 | 처음으로 | 다음
utf8_decode | 위로 | xml_error_string


xml_error_string

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

xml_error_string -- Get XML parser error string

Description

string xml_error_string ( int code)

code

An error code from xml_get_error_code().

Returns a string with a textual description of the error code, or FALSE if no description was found.

이전 | 처음으로 | 다음
utf8_encode | 위로 | xml_get_current_byte_index


xml_get_current_byte_index

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

xml_get_current_byte_index -- Get current byte index for an XML parser

Description

int xml_get_current_byte_index ( resource parser)

parser

A reference to the XML parser to get byte index from.

This function returns FALSE if parser does not refer to a valid parser, or else it returns which byte index the parser is currently at in its data buffer (starting at 0).

이전 | 처음으로 | 다음
xml_error_string | 위로 | xml_get_current_column_number


xml_get_current_column_number

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

xml_get_current_column_number -- Get current column number for an XML parser

Description

int xml_get_current_column_number ( resource parser)

parser

A reference to the XML parser to get column number from.

This function returns FALSE if parser does not refer to a valid parser, or else it returns which column on the current line (as given by xml_get_current_line_number()) the parser is currently at.

이전 | 처음으로 | 다음
xml_get_current_byte_index | 위로 | xml_get_current_line_number


xml_get_current_line_number

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

xml_get_current_line_number -- Get current line number for an XML parser

Description

int xml_get_current_line_number ( resource parser)

parser

A reference to the XML parser to get line number from.

This function returns FALSE if parser does not refer to a valid parser, or else it returns which line the parser is currently at in its data buffer.

이전 | 처음으로 | 다음
xml_get_current_column_number | 위로 | xml_get_error_code


xml_get_error_code

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

xml_get_error_code -- Get XML parser error code

Description

int xml_get_error_code ( resource parser)

parser

A reference to the XML parser to get error code from.

This function returns FALSE if parser does not refer to a valid parser, or else it returns one of the error codes listed in the error codes section.

See also xml_error_string().

이전 | 처음으로 | 다음
xml_get_current_line_number | 위로 | xml_parse_into_struct


xml_parse_into_struct

(PHP 3>= 3.0.8, PHP 4 , PHP 5)

xml_parse_into_struct -- Parse XML data into an array structure

Description

int xml_parse_into_struct ( resource parser, string data, array &values [, array &index])

This function parses an XML file into 2 parallel array structures, one (index) containing pointers to the location of the appropriate values in the values array. These last two parameters must be passed by reference.

Below is an example that illustrates the internal structure of the arrays being generated by the function. We use a simple note tag embedded inside a para tag, and then we parse this and print out the structures generated:

예 1. xml_parse_into_struct() example

<?php
$simple = "<para><note>simple note</note></para>";
$p = xml_parser_create();
xml_parse_into_struct($p, $simple, $vals, $index);
xml_parser_free($p);
echo "Index array\n";
print_r($index);
echo "\nVals array\n";
print_r($vals);
?>

When we run that code, the output will be:

Index array
Array
(
    [PARA] => Array
        (
            [0] => 0
            [1] => 2
        )

    [NOTE] => Array
        (
            [0] => 1
        )

)

Vals array
Array
(
    [0] => Array
        (
            [tag] => PARA
            [type] => open
            [level] => 1
        )

    [1] => Array
        (
            [tag] => NOTE
            [type] => complete
            [level] => 2
            [value] => simple note
        )

    [2] => Array
        (
            [tag] => PARA
            [type] => close
            [level] => 1
        )

)

Event-driven parsing (based on the expat library) can get complicated when you have an XML document that is complex. This function does not produce a DOM style object, but it generates structures amenable of being transversed in a tree fashion. Thus, we can create objects representing the data in the XML file easily. Let's consider the following XML file representing a small database of aminoacids information:

예 2. moldb.xml - small database of molecular information

<?xml version="1.0"?>
<moldb>

    <molecule>
        <name>Alanine</name>
        <symbol>ala</symbol>
        <code>A</code>
        <type>hydrophobic</type>
    </molecule>

    <molecule>
        <name>Lysine</name>
        <symbol>lys</symbol>
        <code>K</code>
        <type>charged</type>
    </molecule>

</moldb>
And some code to parse the document and generate the appropriate objects:

예 3. parsemoldb.php - parses moldb.xml into an array of molecular objects

<?php

class AminoAcid {
    var $name;  // aa name
    var $symbol;    // three letter symbol
    var $code;  // one letter code
    var $type;  // hydrophobic, charged or neutral

    function AminoAcid ($aa)
    {
        foreach ($aa as $k=>$v)
            $this->$k = $aa[$k];
    }
}

function readDatabase($filename)
{
    // read the XML database of aminoacids
    $data = implode("", file($filename));
    $parser = xml_parser_create();
    xml_parser_set_option($parser, XML_OPTION_CASE_FOLDING, 0);
    xml_parser_set_option($parser, XML_OPTION_SKIP_WHITE, 1);
    xml_parse_into_struct($parser, $data, $values, $tags);
    xml_parser_free($parser);

    // loop through the structures
    foreach ($tags as $key=>$val) {
        if ($key == "molecule") {
            $molranges = $val;
            // each contiguous pair of array entries are the
            // lower and upper range for each molecule definition
            for ($i=0; $i < count($molranges); $i+=2) {
                    $offset = $molranges[$i] + 1;
                $len = $molranges[$i + 1] - $offset;
                $tdb[] = parseMol(array_slice($values, $offset, $len));
            }
        } else {
            continue;
        }
    }
    return $tdb;
}

function parseMol($mvalues)
{
    for ($i=0; $i < count($mvalues); $i++) {
        $mol[$mvalues[$i]["tag"]] = $mvalues[$i]["value"];
    }
    return new AminoAcid($mol);
}

$db = readDatabase("moldb.xml");
echo "** Database of AminoAcid objects:\n";
print_r($db);

?>
After executing parsemoldb.php, the variable $db contains an array of AminoAcid objects, and the output of the script confirms that:

** Database of AminoAcid objects:
Array
(
    [0] => aminoacid Object
        (
            [name] => Alanine
            [symbol] => ala
            [code] => A
            [type] => hydrophobic
        )

    [1] => aminoacid Object
        (
            [name] => Lysine
            [symbol] => lys
            [code] => K
            [type] => charged
        )

)

이전 | 처음으로 | 다음
xml_get_error_code | 위로 | xml_parse


xml_parse

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

xml_parse -- Start parsing an XML document

Description

bool xml_parse ( resource parser, string data [, bool is_final])

parser

A reference to the XML parser to use.

data

Chunk of data to parse. A document may be parsed piece-wise by calling xml_parse() several times with new data, as long as the is_final parameter is set and TRUE when the last data is parsed.

is_final (optional)

If set and TRUE, data is the last piece of data sent in this parse.

When the XML document is parsed, the handlers for the configured events are called as many times as necessary, after which this function returns TRUE or FALSE.

TRUE is returned if the parse was successful, FALSE if it was not
successful, or if parser does not refer to
a valid parser.  For unsuccessful parses, error information can
be retrieved with xml_get_error_code(),
xml_error_string(),
xml_get_current_line_number(),
xml_get_current_column_number() and
xml_get_current_byte_index().

이전 | 처음으로 | 다음
xml_parse_into_struct | 위로 | xml_parser_create_ns


xml_parser_create_ns

(PHP 4 >= 4.0.5, PHP 5)

xml_parser_create_ns -- Create an XML parser with namespace support

Description

resource xml_parser_create_ns ( [string encoding [, string separator]])

xml_parser_create_ns() creates a new XML parser with XML namespace support and returns a resource handle referencing it to be used by the other XML functions.

With a namespace aware parser tag parameters passed to the various handler functions will consist of namespace and tag name separated by the string specified in seperator or ':' by default.

The optional encoding specifies the character encoding of the XML input to be parsed. Supported encodings are "ISO-8859-1", which is also the default if no encoding is specified, "UTF-8" and "US-ASCII".

See also xml_parser_create(), and xml_parser_free().

이전 | 처음으로 | 다음
xml_parse | 위로 | xml_parser_create


xml_parser_create

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

xml_parser_create -- Create an XML parser

Description

resource xml_parser_create ( [string encoding])

xml_parser_create() creates a new XML parser and returns a resource handle referencing it to be used by the other XML functions.

The optional encoding specifies the character encoding of the XML input to be parsed. Supported encodings are "ISO-8859-1", which is also the default if no encoding is specified, "UTF-8" and "US-ASCII".

See also xml_parser_create_ns() and xml_parser_free().

이전 | 처음으로 | 다음
xml_parser_create_ns | 위로 | xml_parser_free


xml_parser_free

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

xml_parser_free -- Free an XML parser

Description

bool xml_parser_free ( resource parser)

parser

A reference to the XML parser to free.

This function returns FALSE if parser does not refer to a valid parser, or else it frees the parser and returns TRUE.

이전 | 처음으로 | 다음
xml_parser_create | 위로 | xml_parser_get_option


xml_parser_get_option

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

xml_parser_get_option -- Get options from an XML parser

Description

mixed xml_parser_get_option ( resource parser, int option)

parser

A reference to the XML parser to get an option from.

option

Which option to fetch. See xml_parser_set_option() for a list of options.

This function returns FALSE if parser does not refer to a valid parser, or if the option could not be set. Else the option's value is returned.

See xml_parser_set_option() for the list of options.

이전 | 처음으로 | 다음
xml_parser_free | 위로 | xml_parser_set_option


xml_parser_set_option

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

xml_parser_set_option -- Set options in an XML parser

Description

bool xml_parser_set_option ( resource parser, int option, mixed value)

parser

A reference to the XML parser to set an option in.

option

Which option to set. See below.

value

The option's new value.

This function returns FALSE if parser does not refer to a valid parser, or if the option could not be set. Else the option is set and TRUE is returned.

The following options are available:

표 1. XML parser options

Option constant | Data type | Description
XML_OPTION_CASE_FOLDING | integer | Controls whether case-folding is enabled for this XML parser. Enabled by default.
XML_OPTION_TARGET_ENCODING | string | Sets which target encoding to use in this XML parser. By default, it is set to the same as the source encoding used by xml_parser_create(). Supported target encodings are ISO-8859-1, US-ASCII and UTF-8.

이전 | 처음으로 | 다음
xml_parser_get_option | 위로 | xml_set_character_data_handler


xml_set_character_data_handler

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

xml_set_character_data_handler -- Set up character data handler

Description

bool xml_set_character_data_handler ( resource parser, callback handler)

Sets the character data handler function for the XML parser parser. handler is a string containing the name of a function that must exist when xml_parse() is called for parser.

The function named by handler must accept two parameters: handler ( resource parser, string data)

parser

The first parameter, parser, is a reference to the XML parser calling the handler.

data

The second parameter, data, contains the character data as a string.

If a handler function is set to an empty string, or FALSE, the handler in question is disabled.

TRUE is returned if the handler is set up, FALSE if parser is not a parser.

참고: 함수 이름을 대신해서 객체 레퍼런스와 메쏘드 이름을 가진 배열을 사용할 수 있습니다.

이전 | 처음으로 | 다음
xml_parser_set_option | 위로 | xml_set_default_handler


xml_set_default_handler

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

xml_set_default_handler -- Set up default handler

Description

bool xml_set_default_handler ( resource parser, callback handler)

Sets the default handler function for the XML parser parser. handler is a string containing the name of a function that must exist when xml_parse() is called for parser.

The function named by handler must accept two parameters: handler ( resource parser, string data)

parser

The first parameter, parser, is a reference to the XML parser calling the handler.

data

The second parameter, data, contains the character data. This may be the XML declaration, document type declaration, entities or other data for which no other handler exists.

If a handler function is set to an empty string, or FALSE, the handler in question is disabled.

TRUE is returned if the handler is set up, FALSE if parser is not a parser.

참고: 함수 이름을 대신해서 객체 레퍼런스와 메쏘드 이름을 가진 배열을 사용할 수 있습니다.

이전 | 처음으로 | 다음
xml_set_character_data_handler | 위로 | xml_set_element_handler


xml_set_element_handler

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

xml_set_element_handler -- Set up start and end element handlers

Description

bool xml_set_element_handler ( resource parser, callback start_element_handler, callback end_element_handler)

Sets the element handler functions for the XML parser parser. start_element_handler and end_element_handler are strings containing the names of functions that must exist when xml_parse() is called for parser.

The function named by start_element_handler must accept three parameters: start_element_handler ( resource parser, string name, array attribs)

parser

The first parameter, parser, is a reference to the XML parser calling the handler.

name

The second parameter, name, contains the name of the element for which this handler is called. If case-folding is in effect for this parser, the element name will be in uppercase letters.

attribs

The third parameter, attribs, contains an associative array with the element's attributes (if any). The keys of this array are the attribute names, the values are the attribute values. Attribute names are case-folded on the same criteria as element names. Attribute values are not case-folded.

The original order of the attributes can be retrieved by walking through attribs the normal way, using each(). The first key in the array was the first attribute, and so on.

The function named by end_element_handler must accept two parameters: end_element_handler ( resource parser, string name)

parser

The first parameter, parser, is a reference to the XML parser calling the handler.

name

The second parameter, name, contains the name of the element for which this handler is called. If case-folding is in effect for this parser, the element name will be in uppercase letters.

If a handler function is set to an empty string, or FALSE, the handler in question is disabled.

TRUE is returned if the handlers are set up, FALSE if parser is not a parser.

참고: 함수 이름을 대신해서 객체 레퍼런스와 메쏘드 이름을 가진 배열을 사용할 수 있습니다.

이전 | 처음으로 | 다음
xml_set_default_handler | 위로 | xml_set_end_namespace_decl_handler


xml_set_end_namespace_decl_handler

(PHP 4 >= 4.0.5, PHP 5)

xml_set_end_namespace_decl_handler -- Set up end namespace declaration handler

Description

bool xml_set_end_namespace_decl_handler ( resource parser, callback handler)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: 함수 이름을 대신해서 객체 레퍼런스와 메쏘드 이름을 가진 배열을 사용할 수 있습니다.

이전 | 처음으로 | 다음
xml_set_element_handler | 위로 | xml_set_external_entity_ref_handler


xml_set_external_entity_ref_handler

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

xml_set_external_entity_ref_handler -- Set up external entity reference handler

Description

bool xml_set_external_entity_ref_handler ( resource parser, callback handler)

Sets the external entity reference handler function for the XML parser parser. handler is a string containing the name of a function that must exist when xml_parse() is called for parser.

The function named by handler must accept five parameters, and should return an integer value. If the value returned from the handler is FALSE (which it will be if no value is returned), the XML parser will stop parsing and xml_get_error_code() will return XML_ERROR_EXTERNAL_ENTITY_HANDLING. handler ( resource parser, string open_entity_names, string base, string system_id, string public_id)

parser

The first parameter, parser, is a reference to the XML parser calling the handler.

open_entity_names

The second parameter, open_entity_names, is a space-separated list of the names of the entities that are open for the parse of this entity (including the name of the referenced entity).

base

This is the base for resolving the system identifier (system_id) of the external entity. Currently this parameter will always be set to an empty string.

system_id

The fourth parameter, system_id, is the system identifier as specified in the entity declaration.

public_id

The fifth parameter, public_id, is the public identifier as specified in the entity declaration, or an empty string if none was specified; the whitespace in the public identifier will have been normalized as required by the XML spec.

If a handler function is set to an empty string, or FALSE, the handler in question is disabled.

TRUE is returned if the handler is set up, FALSE if parser is not a parser.

참고: 함수 이름을 대신해서 객체 레퍼런스와 메쏘드 이름을 가진 배열을 사용할 수 있습니다.

이전 | 처음으로 | 다음
xml_set_end_namespace_decl_handler | 위로 | xml_set_notation_decl_handler


xml_set_notation_decl_handler

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

xml_set_notation_decl_handler -- Set up notation declaration handler

Description

bool xml_set_notation_decl_handler ( resource parser, callback handler)

Sets the notation declaration handler function for the XML parser parser. handler is a string containing the name of a function that must exist when xml_parse() is called for parser.

A notation declaration is part of the document's DTD and has the following format:
<!NOTATION <parameter>name</parameter>
{ <parameter>systemId</parameter> | <parameter>publicId</parameter>?>
See section 4.7 of the XML 1.0 spec for the definition of notation declarations.

The function named by handler must accept five parameters: handler ( resource parser, string notation_name, string base, string system_id, string public_id)

parser

The first parameter, parser, is a reference to the XML parser calling the handler.

notation_name

This is the notation's name, as per the notation format described above.

base

This is the base for resolving the system identifier (system_id) of the notation declaration. Currently this parameter will always be set to an empty string.

system_id

System identifier of the external notation declaration.

public_id

Public identifier of the external notation declaration.

If a handler function is set to an empty string, or FALSE, the handler in question is disabled.

TRUE is returned if the handler is set up, FALSE if parser is not a parser.

참고: 함수 이름을 대신해서 객체 레퍼런스와 메쏘드 이름을 가진 배열을 사용할 수 있습니다.

이전 | 처음으로 | 다음
xml_set_external_entity_ref_handler | 위로 | xml_set_object


xml_set_object

(PHP 4 , PHP 5)

xml_set_object -- Use XML Parser within an object

Description

void xml_set_object ( resource parser, object object)

This function allows to use parser inside object. All callback functions could be set with xml_set_element_handler() etc and assumed to be methods of object.

예 1. xml_set_object() example

<?php
class xml  {
    var $parser;

    function xml()
    {
        $this->parser = xml_parser_create();

        xml_set_object($this->parser, $this);
        xml_set_element_handler($this->parser, "tag_open", "tag_close");
        xml_set_character_data_handler($this->parser, "cdata");
    }

    function parse($data)
    {
        xml_parse($this->parser, $data);
    }

    function tag_open($parser, $tag, $attributes)
    {
        var_dump($parser, $tag, $attributes);
    }

    function cdata($parser, $cdata)
    {
        var_dump($parser, $cdata);
    }

    function tag_close($parser, $tag)
    {
        var_dump($parser, $tag);
    }

} // end of class xml

$xml_parser = new xml();
$xml_parser->parse("<A ID='hallo'>PHP</A>");
?>

이전 | 처음으로 | 다음
xml_set_notation_decl_handler | 위로 | xml_set_processing_instruction_handler


xml_set_processing_instruction_handler

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

xml_set_processing_instruction_handler -- Set up processing instruction (PI) handler

Description

bool xml_set_processing_instruction_handler ( resource parser, callback handler)

Sets the processing instruction (PI) handler function for the XML parser parser. handler is a string containing the name of a function that must exist when xml_parse() is called for parser.

A processing instruction has the following format:

<?
       target
       data?>

You can put PHP code into such a tag, but be aware of one limitation: in an XML PI, the PI end tag (?>) can not be quoted, so this character sequence should not appear in the PHP code you embed with PIs in XML documents. If it does, the rest of the PHP code, as well as the "real" PI end tag, will be treated as character data.

The function named by handler must accept three parameters: handler ( resource parser, string target, string data)

parser

The first parameter, parser, is a reference to the XML parser calling the handler.

target

The second parameter, target, contains the PI target.

data

The third parameter, data, contains the PI data.

If a handler function is set to an empty string, or FALSE, the handler in question is disabled.

TRUE is returned if the handler is set up, FALSE if parser is not a parser.

참고: 함수 이름을 대신해서 객체 레퍼런스와 메쏘드 이름을 가진 배열을 사용할 수 있습니다.

이전 | 처음으로 | 다음
xml_set_object | 위로 | xml_set_start_namespace_decl_handler


xml_set_start_namespace_decl_handler

(PHP 4 >= 4.0.5, PHP 5)

xml_set_start_namespace_decl_handler -- Set up start namespace declaration handler

Description

bool xml_set_start_namespace_decl_handler ( resource parser, callback handler)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

참고: 함수 이름을 대신해서 객체 레퍼런스와 메쏘드 이름을 가진 배열을 사용할 수 있습니다.

이전 | 처음으로 | 다음
xml_set_processing_instruction_handler | 위로 | xml_set_unparsed_entity_decl_handler


xml_set_unparsed_entity_decl_handler

(PHP 3>= 3.0.6, PHP 4 , PHP 5)

xml_set_unparsed_entity_decl_handler -- Set up unparsed entity declaration handler

Description

bool xml_set_unparsed_entity_decl_handler ( resource parser, callback handler)

Sets the unparsed entity declaration handler function for the XML parser parser. handler is a string containing the name of a function that must exist when xml_parse() is called for parser.

This handler will be called if the XML parser encounters an external entity declaration with an NDATA declaration, like the following:
<!ENTITY <parameter>name</parameter> {<parameter>publicId</parameter> | <parameter>systemId</parameter>}
        NDATA <parameter>notationName</parameter>

See section 4.2.2 of the XML 1.0 spec for the definition of notation declared external entities.

The function named by handler must accept six parameters: handler ( resource parser, string entity_name, string base, string system_id, string public_id, string notation_name)

parser

The first parameter, parser, is a reference to the XML parser calling the handler.

entity_name

The name of the entity that is about to be defined.

base

This is the base for resolving the system identifier (systemId) of the external entity. Currently this parameter will always be set to an empty string.

system_id

System identifier for the external entity.

public_id

Public identifier for the external entity.

notation_name

Name of the notation of this entity (see xml_set_notation_decl_handler()).

If a handler function is set to an empty string, or FALSE, the handler in question is disabled.

TRUE is returned if the handler is set up, FALSE if parser is not a parser.

참고: 함수 이름을 대신해서 객체 레퍼런스와 메쏘드 이름을 가진 배열을 사용할 수 있습니다.

이전 | 처음으로 | 다음
xml_set_start_namespace_decl_handler | 위로 | XML-RPC Functions


XML-RPC Functions

PHP 매뉴얼
이전 다음

CXVII. XML-RPC Functions

소개

These functions can be used to write XML-RPC servers and clients. You can find more information about XML-RPC at http://www.xmlrpc.com/, and more documentation on this extension and its functions at http://xmlrpc-epi.sourceforge.net/.

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

요구 사항

이 확장 모듈을 빌드할 때 외부 라이브러리가 필요하지 않습니다.

설치

XML-RPC support in PHP is not enabled by default. You will need to use the --with-xmlrpc[=DIR] configuration option when compiling PHP to enable XML-RPC support. This extension is bundled into PHP as of 4.1.0.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

표 1. XML-RPC configuration options

Name | Default | Changeable
xmlrpc_errors | "0" | PHP_INI_SYSTEM
xmlrpc_error_number | "0" | PHP_INI_ALL
For further details and definition of the PHP_INI_* constants see ini_set().

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

차례
xmlrpc_decode_request -- Decodes XML into native PHP types
xmlrpc_decode -- Decodes XML into native PHP types
xmlrpc_encode_request -- Generates XML for a method request
xmlrpc_encode -- Generates XML for a PHP value
xmlrpc_get_type -- Gets xmlrpc type for a PHP value. Especially useful for base64 and datetime strings
xmlrpc_parse_method_descriptions -- Decodes XML into a list of method descriptions
xmlrpc_server_add_introspection_data -- Adds introspection documentation
xmlrpc_server_call_method -- Parses XML requests and call methods
xmlrpc_server_create -- Creates an xmlrpc server
xmlrpc_server_destroy -- Destroys server resources
xmlrpc_server_register_introspection_callback -- Register a PHP function to generate documentation
xmlrpc_server_register_method -- Register a PHP function to resource method matching method_name
xmlrpc_set_type -- Sets xmlrpc type, base64 or datetime, for a PHP string value

이전 | 처음으로 | 다음
xml_set_unparsed_entity_decl_handler | 위로 | xmlrpc_decode_request


xmlrpc_decode_request

(PHP 4 >= 4.1.0, PHP 5)

xmlrpc_decode_request -- Decodes XML into native PHP types

Description

array xmlrpc_decode_request ( string xml, string &method [, string encoding])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
XML-RPC Functions | 위로 | xmlrpc_decode


xmlrpc_decode

(PHP 4 >= 4.1.0, PHP 5)

xmlrpc_decode -- Decodes XML into native PHP types

Description

array xmlrpc_decode ( string xml [, string encoding])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xmlrpc_decode_request | 위로 | xmlrpc_encode_request


xmlrpc_encode_request

(PHP 4 >= 4.1.0, PHP 5)

xmlrpc_encode_request -- Generates XML for a method request

Description

string xmlrpc_encode_request ( string method, mixed params)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xmlrpc_decode | 위로 | xmlrpc_encode


xmlrpc_encode

(PHP 4 >= 4.1.0, PHP 5)

xmlrpc_encode -- Generates XML for a PHP value

Description

string xmlrpc_encode ( mixed value)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xmlrpc_encode_request | 위로 | xmlrpc_get_type


xmlrpc_get_type

(PHP 4 >= 4.1.0, PHP 5)

xmlrpc_get_type -- Gets xmlrpc type for a PHP value. Especially useful for base64 and datetime strings

Description

string xmlrpc_get_type ( mixed value)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xmlrpc_encode | 위로 | xmlrpc_parse_method_descriptions


xmlrpc_parse_method_descriptions

(PHP 4 >= 4.1.0, PHP 5)

xmlrpc_parse_method_descriptions -- Decodes XML into a list of method descriptions

Description

array xmlrpc_parse_method_descriptions ( string xml)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xmlrpc_get_type | 위로 | xmlrpc_server_add_introspection_data


xmlrpc_server_add_introspection_data

(PHP 4 >= 4.1.0, PHP 5)

xmlrpc_server_add_introspection_data -- Adds introspection documentation

Description

int xmlrpc_server_add_introspection_data ( resource server, array desc)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xmlrpc_parse_method_descriptions | 위로 | xmlrpc_server_call_method


xmlrpc_server_call_method

(PHP 4 >= 4.1.0, PHP 5)

xmlrpc_server_call_method -- Parses XML requests and call methods

Description

mixed xmlrpc_server_call_method ( resource server, string xml, mixed user_data [, array output_options])

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xmlrpc_server_add_introspection_data | 위로 | xmlrpc_server_create


xmlrpc_server_create

(PHP 4 >= 4.1.0, PHP 5)

xmlrpc_server_create -- Creates an xmlrpc server

Description

resource xmlrpc_server_create ( void )

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xmlrpc_server_call_method | 위로 | xmlrpc_server_destroy


xmlrpc_server_destroy

(PHP 4 >= 4.1.0, PHP 5)

xmlrpc_server_destroy -- Destroys server resources

Description

int xmlrpc_server_destroy ( resource server)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xmlrpc_server_create | 위로 | xmlrpc_server_register_introspection_callback


xmlrpc_server_register_introspection_callback

(PHP 4 >= 4.1.0, PHP 5)

xmlrpc_server_register_introspection_callback -- Register a PHP function to generate documentation

Description

bool xmlrpc_server_register_introspection_callback ( resource server, string function)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xmlrpc_server_destroy | 위로 | xmlrpc_server_register_method


xmlrpc_server_register_method

(PHP 4 >= 4.1.0, PHP 5)

xmlrpc_server_register_method -- Register a PHP function to resource method matching method_name

Description

bool xmlrpc_server_register_method ( resource server, string method_name, string function)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xmlrpc_server_register_introspection_callback | 위로 | xmlrpc_set_type


xmlrpc_set_type

(PHP 4 >= 4.1.0, PHP 5)

xmlrpc_set_type -- Sets xmlrpc type, base64 or datetime, for a PHP string value

Description

bool xmlrpc_set_type ( string value, string type)

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xmlrpc_server_register_method | 위로 | xdiff Functions


xdiff Functions

PHP 매뉴얼
이전 다음

CXVIII. xdiff Functions

소개

xdiff extension creates and applies patches to both text and binary files.

요구 사항

To use xdiff, you will need libxdiff installed, available on the libxdiff homepage http://www.xmailserver.org/xdiff-lib.html.

설치

xdiff is currently available through PECL http://pecl.php.net/package/xdiff.

If PEAR is available on your *nix-like system you can use the pear installer to install the xdiff extension, by the following command: pear -v install xdiff.

You can always download the tar.gz package and install xdiff by hand:

예 1. xdiff install by hand

gunzip xdiff-xxx.tgz
tar -xvf xdiff-xxx.tar
cd xdiff-xxx
phpize
./configure && make && make install

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

XDIFF_PATCH_NORMAL (integer)

XDIFF_PATCH_REVERSE (integer)

차례
xdiff_file_diff_binary -- Make binary diff of two files.
xdiff_file_diff -- Make unified diff of two files.
xdiff_file_merge3 -- Merge 3 files into one.
xdiff_file_patch_binary -- Patch a file with a binary diff.
xdiff_file_patch -- Patch a file with an unified diff.
xdiff_string_diff_binary -- Make binary diff of two strings.
xdiff_string_diff -- Make unified diff of two strings.
xdiff_string_merge3 -- Merge 3 strings into one.
xdiff_string_patch_binary -- Patch a string with a binary diff.
xdiff_string_patch -- Patch a string with an unified diff.

이전 | 처음으로 | 다음
xmlrpc_set_type | 위로 | xdiff_file_diff_binary


xdiff_file_diff_binary

(no version information, might be only in CVS)

xdiff_file_diff_binary -- Make binary diff of two files.

Description

bool xdiff_file_diff_binary ( string file1, string file2, string dest)

xdiff_file_diff_binary() makes binary diff of files file1 and file2 and stores result in file dest.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also xdiff_string_diff_binary().

이전 | 처음으로 | 다음
xdiff Functions | 위로 | xdiff_file_diff


xdiff_file_diff

(no version information, might be only in CVS)

xdiff_file_diff -- Make unified diff of two files.

Description

bool xdiff_file_diff ( string file1, string file2, string dest [, int context [, bool minimal]])

xdiff_file_diff() makes unified diff of files file1 and file2 and stores result in file dest. context indicated how many lines of context you want to include in diff result. Set minimal to TRUE if you want to minimalize size of diff (can take a long time).

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also xdiff_string_diff().

이전 | 처음으로 | 다음
xdiff_file_diff_binary | 위로 | xdiff_file_merge3


xdiff_file_merge3

(no version information, might be only in CVS)

xdiff_file_merge3 -- Merge 3 files into one.

Description

mixed xdiff_file_merge3 ( string file1, string file2, string file3, string dest)

xdiff_file_merge3() merges files file1, file2 and file3 into one and stores result in file dest.

Returns TRUE if merge was successful, string with rejected chunks if it was not or FALSE if an internal error happened.

See also xdiff_string_merge3().

이전 | 처음으로 | 다음
xdiff_file_diff | 위로 | xdiff_file_patch_binary


xdiff_file_patch_binary

(no version information, might be only in CVS)

xdiff_file_patch_binary -- Patch a file with a binary diff.

Description

bool xdiff_file_patch_binary ( string file, string patch, string dest)

xdiff_file_patch_binary() patches file file with binary patch in file patch and stores result in file dest.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

See also xdiff_string_patch_binary().

이전 | 처음으로 | 다음
xdiff_file_merge3 | 위로 | xdiff_file_patch


xdiff_file_patch

(no version information, might be only in CVS)

xdiff_file_patch -- Patch a file with an unified diff.

Description

mixed xdiff_file_patch ( string file, string patch, string dest [, int flags])

xdiff_file_patch() patches file file with unified patch in file patch and stores result in file dest.

flags can be either XDIFF_PATCH_NORMAL (default mode, normal patch) or XDIFF_PATCH_REVERSE (reversed patch).

Returns FALSE if an internal error happened, string with rejected chunks of patch or TRUE if patch has been successfully applied.

See also xdiff_string_patch().

이전 | 처음으로 | 다음
xdiff_file_patch_binary | 위로 | xdiff_string_diff_binary


xdiff_string_diff_binary

(no version information, might be only in CVS)

xdiff_string_diff_binary -- Make binary diff of two strings.

Description

mixed xdiff_string_diff_binary ( string str1, string str2)

xdiff_string_diff_binary() makes binary diff of strings str1 and str2.

Returns string with result or FALSE if an internal error happened.

See also xdiff_file_diff_binary().

이전 | 처음으로 | 다음
xdiff_file_patch | 위로 | xdiff_string_diff


xdiff_string_diff

(no version information, might be only in CVS)

xdiff_string_diff -- Make unified diff of two strings.

Description

mixed xdiff_string_diff ( string str1, string str2 [, int context [, bool minimal]])

xdiff_string_diff() makes unified diff of strings str1 and str2. context indicated how many lines of context you want to include in diff result. Set minimal to TRUE if you want to minimalize size of diff (can take a long time).

Returns string with result or FALSE if an internal error happened.

See also xdiff_file_diff().

이전 | 처음으로 | 다음
xdiff_string_diff_binary | 위로 | xdiff_string_merge3


xdiff_string_merge3

(no version information, might be only in CVS)

xdiff_string_merge3 -- Merge 3 strings into one.

Description

string xdiff_string_merge3 ( string str1, string str2, string str3 [, string & error])

xdiff_string_merge3() merges strings str1, str2 and str3 into one.

If error is passed then rejected parts are stored inside this variable.

Returns merged string or FALSE if an internal error happened.

See also xdiff_file_merge3().

이전 | 처음으로 | 다음
xdiff_string_diff | 위로 | xdiff_string_patch_binary


xdiff_string_patch_binary

(no version information, might be only in CVS)

xdiff_string_patch_binary -- Patch a string with a binary diff.

Description

string xdiff_string_patch_binary ( string str, string patch)

xdiff_string_patch_binary() patches string str with binary patch in string patch.

Returns a patched string.

See also xdiff_file_patch_binary().

이전 | 처음으로 | 다음
xdiff_string_merge3 | 위로 | xdiff_string_patch


xdiff_string_patch

(no version information, might be only in CVS)

xdiff_string_patch -- Patch a string with an unified diff.

Description

string xdiff_string_patch ( string str, string patch [, int flags [, string & error]])

xdiff_string_patch() patches string str with unified patch in string patch.

flags can be either XDIFF_PATCH_NORMAL (default mode, normal patch) or XDIFF_PATCH_REVERSE (reversed patch).

If error is passed then rejected parts are stored inside this variable.

Returns a patched string.

See also xdiff_file_patch().

이전 | 처음으로 | 다음
xdiff_string_patch_binary | 위로 | XSL functions


XSL functions

PHP 매뉴얼
이전 다음

CXIX. XSL functions

소개

주의

이 확장 모듈은 실험적입니다. 이 확장 모듈의 작동 -- 함수의 이름과 이 확장 모듈에 대한 모든 문서 자료에 대해서 -- 은 이후의 PHP 릴리즈에서 예고 없이 변경될 수 있습니다. 이 확장 모듈의 사용은 사용자의 책임하에 이루어집니다.

The XSL extension implements the XSL standard, performing XSLT transformations using the libxslt library.

설치

PHP 5 includes the XSL extension by default and it can be enabled by adding the argument --with-xsl[=DIR] to your configure line. DIR is the libxslt installation directory. libxslt version 1.0.18 or greater is required.

예제

In this small tutorial we will learn how to transform an XML document into HTML.

예 1. A simple XSL tree

<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
 <xsl:output method="html" encoding="iso-8859-1" indent="no"/>
 <xsl:template match="collection">
  Hey! Welcome to my sweet CD collection!
  <xsl:apply-templates/>
 </xsl:template>
 <xsl:template match="cd">
  <h1><xsl:value-of select="title"/></h1>
  <h2>by <xsl:value-of select="artist"/></h2>
  <h3> - <xsl:value-of select="year"/></h3>
 </xsl:template>
</xsl:stylesheet>

예 2. Corresponding XML tree

<collection>
 <cd>
  <title>PHP Rock</title>
  <artist>Joe Coder</artist>
  <year>2003</year>
 </cd>
 <cd>
  <title>Squashing Typos on a Winter's Eve</title>
  <artist>kennyt</artist>
  <year>2004</year>
 </cd>
</collection>

예 3. Making XML into HTML

The following PHP code uses the XML and XSL extensions to transform XML into presentable HTML.

<?php
/* Load the two XML sources */
$xml = new DomDocument; // from /ext/dom
$xml->load('example.xml');

$xsl = new DomDocument;
$xsl->load('example.xsl');

/* Configure the transformer */
$proc = new xsltprocessor;
$proc->importStyleSheet($xsl); // attach the xsl rules
echo $proc->transformToXML($xml); // actual transformation
?>

This should produce an HTML fragment similar to the following:

Hey! Welcome to my sweet CD collection!

<h1>PHP Rock</h1>
<h2>by Joe Coder</h2>
<h3> - 2003</h3>

<h1>Squashing Typos on a Winter's Eve</h1>
<h2> by kennyt</h2>
<h3> - 2004</h3>

차례
xsl_xsltprocessor_get_parameter --
xsl_xsltprocessor_has_exslt_support -- Determine if PHP has EXSLT support
xsl_xsltprocessor_import_stylesheet --
xsl_xsltprocessor_register_php_functions -- Enables the ability to use PHP functions as XSLT functions
xsl_xsltprocessor_remove_parameter --
xsl_xsltprocessor_set_parameter --
xsl_xsltprocessor_transform_to_doc --
xsl_xsltprocessor_transform_to_uri --
xsl_xsltprocessor_transform_to_xml --

이전 | 처음으로 | 다음
xdiff_string_patch | 위로 | xsl_xsltprocessor_get_parameter


xsl_xsltprocessor_get_parameter

(no version information, might be only in CVS)

xsl_xsltprocessor_get_parameter --

Description

Procedural style

bool xsl_xsltprocessor_get_parameter ( string namespace, string name)

Object oriented style (method)

class xsltprocessor {

xsl_xsltdocucument getParameter ( string namespace, string name)

}

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
XSL functions | 위로 | xsl_xsltprocessor_has_exslt_support


xsl_xsltprocessor_has_exslt_support

(no version information, might be only in CVS)

xsl_xsltprocessor_has_exslt_support -- Determine if PHP has EXSLT support

Description

Procedural style

bool xsl_xsltprocessor_has_exslt_support ( void )

Object oriented style (method)

class xsltprocessor {

bool hasExsltSupport ( void )

}

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

xsl_xsltprocessor_has_exslt_support() returns TRUE if PHP was built with the EXSLT library , FALSE otherwise.

이전 | 처음으로 | 다음
xsl_xsltprocessor_get_parameter | 위로 | xsl_xsltprocessor_import_stylesheet


xsl_xsltprocessor_import_stylesheet

(no version information, might be only in CVS)

xsl_xsltprocessor_import_stylesheet --

Description

Procedural style

bool xsl_xsltprocessor_import_stylesheet ( node index)

Object oriented style (method)

class xsltprocessor {

bool importStylesheet ( node index)

}

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xsl_xsltprocessor_has_exslt_support | 위로 | xsl_xsltprocessor_register_php_functions


xsl_xsltprocessor_register_php_functions

(no version information, might be only in CVS)

xsl_xsltprocessor_register_php_functions -- Enables the ability to use PHP functions as XSLT functions

Description

Procedural style

void xsl_xsltprocessor_register_php_functions ( void )

Object oriented style (method)

class xsltprocessor {

void registerPHPFunctions ( void )

}

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

xsl_xsltprocessor_register_php_functions() enables the ability to use PHP functions as XSLT functions within XSL stylesheets.

이전 | 처음으로 | 다음
xsl_xsltprocessor_import_stylesheet | 위로 | xsl_xsltprocessor_remove_parameter


xsl_xsltprocessor_remove_parameter

(no version information, might be only in CVS)

xsl_xsltprocessor_remove_parameter --

Description

Procedural style

bool xsl_xsltprocessor_remove_parameter ( string namespace, string name)

Object oriented style (method)

class xsltprocessor {

bool removeParameter ( string namespace, string name)

}

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xsl_xsltprocessor_register_php_functions | 위로 | xsl_xsltprocessor_set_parameter


xsl_xsltprocessor_set_parameter

(no version information, might be only in CVS)

xsl_xsltprocessor_set_parameter --

Description

Procedural style

bool xsl_xsltprocessor_set_parameter ( string namespace, string name, string value)

Object oriented style (method)

class xsltprocessor {

bool setParameter ( string namespace, string name, string value)

}

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xsl_xsltprocessor_remove_parameter | 위로 | xsl_xsltprocessor_transform_to_doc


xsl_xsltprocessor_transform_to_doc

(no version information, might be only in CVS)

xsl_xsltprocessor_transform_to_doc --

Description

Procedural style

bool >xsl_xsltprocessor_transform_to_doc ( node doc [, bool clone])

Object oriented style (method)

class xsltprocessor {

bool transformToDoc ( node doc [, bool clone])

}

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xsl_xsltprocessor_set_parameter | 위로 | xsl_xsltprocessor_transform_to_uri


xsl_xsltprocessor_transform_to_uri

(no version information, might be only in CVS)

xsl_xsltprocessor_transform_to_uri --

Description

Procedural style

bool xsl_xsltprocessor_transform_to_uri ( node doc, string uri [, bool clone])

Object oriented style (method)

class xsltprocessor {

bool transformToUri ( node doc, string uri [, bool clone])

}

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xsl_xsltprocessor_transform_to_doc | 위로 | xsl_xsltprocessor_transform_to_xml


xsl_xsltprocessor_transform_to_xml

(no version information, might be only in CVS)

xsl_xsltprocessor_transform_to_xml --

Description

Procedural style

bool xsl_xsltprocessor_transform_to_xml ( node doc [, bool clone])

Object oriented style (method)

class xsltprocessor {

bool transformToXml ( node doc [, bool clone])

}

주의

이 함수는 실험적입니다. 이 함수의 작동, 함수의 이름, 그리고 이 함수에 대해 모든 문서는 이후의 PHP 릴리즈에서 예고 없이 변경할 수 있습니다. 이 함수의 사용에 관한 것은 사용자 책임입니다.

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xsl_xsltprocessor_transform_to_uri | 위로 | XSLT Functions


XSLT Functions

PHP 매뉴얼
이전 다음

CXX. XSLT Functions

소개

This PHP extension provides a processor independent API to XSLT transformations. Currently this extension only supports the Sablotron library from the Ginger Alliance. Support is planned for other libraries, such as the Xalan library or the libxslt library.

XSLT (Extensible Stylesheet Language (XSL) Transformations) is a language for transforming XML documents into other XML documents. It is a standard defined by The World Wide Web Consortium (W3C). Information about XSLT and related technologies can be found at http://www.w3.org/TR/xslt.

참고: This extension is different than the sablotron extension distributed with versions of PHP prior to PHP 4.1, currently only the new XSLT extension in PHP 4.1 is supported. If you need support for the old extension, please ask your questions on the PHP mailing lists.

참고: 이 확장 모듈은 PHP 5에서 제거되어, PECL로 이동되었습니다.

요구 사항

This extension uses Sablotron and expat, which can both be found at http://www.gingerall.com/. Binaries are provided as well as source.

설치

On Unix, run configure with the --enable-xslt --with-xslt-sablot options. The Sablotron library should be installed somewhere your compiler can find it.

Make sure you have the same libraries linked to the Sablotron library as those, which are linked with PHP. The configuration options: --with-expat-dir=DIR --with-iconv-dir=DIR are there to help you specify them. When asking for support, always mention these directives, and whether there are other versions of those libraries installed on your system somewhere. Naturally, provide all the version numbers.

경고

Be sure your Sablot library is linked to -lstdc++ as otherwise your configure will fail, or PHP will fail to run or load.

JavaScript E-XSLT support: If you compiled Sablotron with JavaScript support, you must specify the option: --with-sablot-js=DIR.

Note to Win32 Users: In order to enable this module on a Windows environment, you must copy several files from the DLL folder of the PHP/Win32 binary package to the SYSTEM32 folder of your windows machine. (Ex: C:\WINNT\SYSTEM32 or C:\WINDOWS\SYSTEM32). For PHP <= 4.2.0 copy sablot.dll and expat.dll to your SYSTEM32 folder. For PHP >= 4.2.1 copy sablot.dll, expat.dll and iconv.dll to your SYSTEM32 folder.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

XSLT_OPT_SILENT (integer)

Drop all logging and error reporting. This is a generic option for all backends that may be added in the future.

XSLT_SABOPT_PARSE_PUBLIC_ENTITIES (integer)

Tell Sablotron to parse public entities. By default this has been turned off.

XSLT_SABOPT_DISABLE_ADDING_META (integer)

Do not add the meta tag "Content-Type" for HTML output. The default is set during compilation of Sablotron.

XSLT_SABOPT_DISABLE_STRIPPING (integer)

Suppress the whitespace stripping (on data files only).

XSLT_SABOPT_IGNORE_DOC_NOT_FOUND (integer)

Consider unresolved documents (the document() function) non-lethal.

XSLT_ERR_UNSUPPORTED_SCHEME (integer)

Error return code, for scheme handlers.

차례
xslt_create -- Create a new XSLT processor
xslt_errno -- Returns an error number
xslt_error -- Returns an error string
xslt_free -- Free XSLT processor
xslt_process -- Perform an XSLT transformation
xslt_set_base -- Set the base URI for all XSLT transformations
xslt_set_encoding -- Set the encoding for the parsing of XML documents
xslt_set_error_handler -- Set an error handler for a XSLT processor
xslt_set_log -- Set the log file to write log messages to
xslt_set_sax_handler -- Set SAX handlers for a XSLT processor
xslt_set_sax_handlers -- Set the SAX handlers to be called when the XML document gets processed
xslt_set_scheme_handler -- Set Scheme handlers for a XSLT processor
xslt_set_scheme_handlers -- Set the scheme handlers for the XSLT processor

이전 | 처음으로 | 다음
xsl_xsltprocessor_transform_to_xml | 위로 | xslt_create


xslt_create

(PHP 4 >= 4.0.3)

xslt_create -- Create a new XSLT processor

Description

resource xslt_create ( void )

Create and return a new XSLT processor resource for manipulation by the other XSLT functions.

예 1. xslt_create() example

<?php
function xml2html($xmldata, $xsl)
{
    /* $xmldata -> your XML */
    /* $xsl -> XSLT file */

    $path = 'include';
    $arguments = array('/_xml' => $xmldata);
    $xsltproc = xslt_create();
    xslt_set_encoding($xsltproc, 'ISO-8859-1');
    $html =
        xslt_process($xsltproc, 'arg:/_xml', "$path/$xsl", NULL, $arguments);

    if (empty($html)) {
       die('XSLT processing error: '. xslt_error($xsltproc));
    }
    xslt_free($xsltproc);
    return $html;
}
?>

See also xslt_free().

이전 | 처음으로 | 다음
XSLT Functions | 위로 | xslt_errno


xslt_errno

(PHP 4 >= 4.0.3)

xslt_errno -- Returns an error number

Description

int xslt_errno ( resource xh)

Returns an error code describing the last error that occurred on the passed XSLT processor.

이전 | 처음으로 | 다음
xslt_create | 위로 | xslt_error


xslt_error

(PHP 4 >= 4.0.3)

xslt_error -- Returns an error string

Description

mixed xslt_error ( resource xh)

Returns a string describing the last error that occurred on the passed XSLT processor.

예 1. Handling errors using the xslt_error() and xslt_errno() functions.

<?php

$xh = xslt_create();
$result = xslt_process($xh, 'dog.xml', 'pets.xsl');
if (!$result) {
    die(sprintf("Cannot process XSLT document [%d]: %s",
                xslt_errno($xh), xslt_error($xh)));
}

echo $result;

xslt_free($xh);
?>

이전 | 처음으로 | 다음
xslt_errno | 위로 | xslt_free


xslt_free

(PHP 4 >= 4.0.3)

xslt_free -- Free XSLT processor

Description

void xslt_free ( resource xh)

Free the XSLT processor identified by the given handle.

See also xslt_create()

이전 | 처음으로 | 다음
xslt_error | 위로 | xslt_process


xslt_process

(PHP 4 >= 4.0.3)

xslt_process -- Perform an XSLT transformation

Description

mixed xslt_process ( resource xh, string xmlcontainer, string xslcontainer [, string resultcontainer [, array arguments [, array parameters]]])

The xslt_process() function is the crux of the new XSLT extension. It allows you to perform an XSLT transformation using almost any type of input source - the containers. This is accomplished through the use of argument buffers -- a concept taken from the Sablotron XSLT processor (currently the only XSLT processor this extension supports). The input containers default to a filename 'containing' the document to be processed. The result container defaults to a filename for the transformed document. If the result container is not specified - i.e. NULL - than the result is returned.

주의

This function has changed its arguments, sinceversion 4.0.6. Do NOT provide the actual XML or XSL content as 2nd and 3rd argument, as this will create a segmentation fault, in Sablotron versions up to and including 0.95.

Containers can also be set via the $arguments array (see below).

The simplest type of transformation with the xslt_process() function is the transformation of an XML file with an XSLT file, placing the result in a third file containing the new XML (or HTML) document. Doing this with sablotron is really quite easy...

예 1. Using the xslt_process() to transform an XML file and a XSL file to a new XML file

<?php

// Allocate a new XSLT processor
$xh = xslt_create();

// Process the document
if (xslt_process($xh, 'sample.xml', 'sample.xsl', 'result.xml')) {
    echo "SUCCESS, sample.xml was transformed by sample.xsl into result.xml";
    echo ", result.xml has the following contents\n<br />\n";
    echo "<pre>\n";
    readfile('result.xml');
    echo "</pre>\n";
} else {
    echo "Sorry, sample.xml could not be transformed by sample.xsl into";
    echo "  result.xml the reason is that " . xslt_error($xh) . " and the ";
    echo "error code is " . xslt_errno($xh);
}

xslt_free($xh);

?>

While this functionality is great, many times, especially in a web environment, you want to be able to print out your results directly. Therefore, if you omit the third argument to the xslt_process() function (or provide a NULL value for the argument), it will automatically return the value of the XSLT transformation, instead of writing it to a file...

예 2. Using the xslt_process() to transform an XML file and a XSL file to a variable containing the resulting XML data

<?php

// Allocate a new XSLT processor
$xh = xslt_create();

// Process the document, returning the result into the $result variable
$result = xslt_process($xh, 'sample.xml', 'sample.xsl');
if ($result) {
    echo "SUCCESS, sample.xml was transformed by sample.xsl into the \$result";
    echo " variable, the \$result variable has the following contents\n<br />\n";
    echo "<pre>\n";
    echo $result;
    echo "</pre>\n";
} else {
    echo "Sorry, sample.xml could not be transformed by sample.xsl into";
    echo "  the \$result variable the reason is that " . xslt_error($xh);
    echo " and the error code is " . xslt_errno($xh);
}

xslt_free($xh);

?>

The above two cases are the two simplest cases there are when it comes to XSLT transformation and I'd dare say that they are the most common cases, however, sometimes you get your XML and XSLT code from external sources, such as a database or a socket. In these cases you'll have the XML and/or XSLT data in a variable -- and in production applications the overhead of dumping these to file may be too much. This is where XSLT's "argument" syntax, comes to the rescue. Instead of files as the XML and XSLT arguments to the xslt_process() function, you can specify "argument place holders" which are then substituted by values given in the arguments array (5th parameter to the xslt_process() function). The following is an example of processing XML and XSLT into a result variable without the use of files at all.

예 3. Using the xslt_process() to transform a variable containing XML data and a variable containing XSL data into a variable containing the resulting XML data

<?php
// $xml and $xsl contain the XML and XSL data

$arguments = array(
     '/_xml' => $xml,
     '/_xsl' => $xsl
);

// Allocate a new XSLT processor
$xh = xslt_create();

// Process the document
$result = xslt_process($xh, 'arg:/_xml', 'arg:/_xsl', NULL, $arguments);
if ($result) {
    echo "SUCCESS, sample.xml was transformed by sample.xsl into the \$result";
    echo " variable, the \$result variable has the following contents\n<br />\n";
    echo "<pre>\n";
    echo $result;
    echo "</pre>\n";
} else {
    echo "Sorry, sample.xml could not be transformed by sample.xsl into";
    echo "  the \$result variable the reason is that " . xslt_error($xh) .
    echo " and the error code is " . xslt_errno($xh);
}
xslt_free($xh);
?>

Finally, the last argument to the xslt_process() function represents an array for any top-level parameters that you want to pass to the XSLT document. These parameters can then be accessed within your XSL files using the <xsl:param name="parameter_name"> instruction. The parameters must be UTF-8 encoded and their values will be interpreted as strings by the Sablotron processor. In other words - you cannot pass node-sets as parameters to the XSLT document.

참고: Please note that file:// is needed in front of path if you use Windows.

이전 | 처음으로 | 다음
xslt_free | 위로 | xslt_set_base


xslt_set_base

(PHP 4 >= 4.0.5)

xslt_set_base -- Set the base URI for all XSLT transformations

Description

void xslt_set_base ( resource xh, string uri)

Sets the base URI for all XSLT transformations, the base URI is used with Xpath instructions to resolve document() and other commands which access external resources. It is also used to resolve URIs for the <xsl:include> and <xsl:import> elements.

As of 4.3, the default base URI is the directory of the executing script. In effect, it is the directory name value of the __FILE__ constant. Prior to 4.3, the default base URI was less predictable.

참고: Please note that file:// is needed in front of path if you use Windows.

이전 | 처음으로 | 다음
xslt_process | 위로 | xslt_set_encoding


xslt_set_encoding

(PHP 4 >= 4.0.5)

xslt_set_encoding -- Set the encoding for the parsing of XML documents

Description

void xslt_set_encoding ( resource xh, string encoding)

Set the output encoding for the XSLT transformations. When using the Sablotron backend this option is only available when you compile Sablotron with encoding support.

이전 | 처음으로 | 다음
xslt_set_base | 위로 | xslt_set_error_handler


xslt_set_error_handler

(PHP 4 >= 4.0.4)

xslt_set_error_handler -- Set an error handler for a XSLT processor

Description

void xslt_set_error_handler ( resource xh, mixed handler)

Set an error handler function for the XSLT processor given by xh, this function will be called whenever an error occurs in the XSLT transformation (this function is also called for notices).

이전 | 처음으로 | 다음
xslt_set_encoding | 위로 | xslt_set_log


xslt_set_log

(PHP 4 >= 4.0.6)

xslt_set_log -- Set the log file to write log messages to

Description

void xslt_set_log ( resource xh, mixed log)

xh

A reference to the XSLT parser.

log

This parameter is either a boolean value which toggles logging on and off, or a string containing the logfile in which log errors too.

This function allows you to set the file in which you want XSLT log messages to, XSLT log messages are different than error messages, in that log messages are not actually error messages but rather messages related to the state of the XSLT processor. They are useful for debugging XSLT, when something goes wrong.

By default logging is disabled, in order to enable logging you must first call xslt_set_log() with a boolean parameter which enables logging, then if you want to set the log file to debug to, you must then pass it a string containing the filename:

예 1. Using the XSLT Logging features

<?php

$xh = xslt_create();
xslt_set_log($xh, true);
xslt_set_log($xh, getcwd() . '/myfile.log');

$result = xslt_process($xh, 'dog.xml', 'pets.xsl');
echo $result;

xslt_free($xh);
?>

참고: Please note that file:// is needed in front of path if you use Windows.

이전 | 처음으로 | 다음
xslt_set_error_handler | 위로 | xslt_set_sax_handler


xslt_set_sax_handler

(4.0.3 - 4.0.6 only)

xslt_set_sax_handler -- Set SAX handlers for a XSLT processor

Description

void xslt_set_sax_handler ( resource xh, array handlers)

Set SAX handlers on the resource handle given by xh. SAX handlers should be a two dimensional array with the format (all top level elements are optional):

array(
[document] =>
    array(
        start document handler,
        end document handler
    ),
[element] =>
    array(
        start element handler,
        end element handler
    ),
[namespace] =>
    array(
        start namespace handler,
        end namespace handler
    ),
[comment] => comment handler,
[pi] => processing instruction handler,
[character] => character data handler
)

이전 | 처음으로 | 다음
xslt_set_log | 위로 | xslt_set_sax_handlers


xslt_set_sax_handlers

(PHP 4 >= 4.0.6)

xslt_set_sax_handlers -- Set the SAX handlers to be called when the XML document gets processed

Description

void xslt_set_sax_handlers ( resource processor, array handlers)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xslt_set_sax_handler | 위로 | xslt_set_scheme_handler


xslt_set_scheme_handler

(4.0.5 - 4.0.6 only)

xslt_set_scheme_handler -- Set Scheme handlers for a XSLT processor

Description

void xslt_set_scheme_handler ( resource xh, array handlers)

Set Scheme handlers on the resource handle given by xh. Scheme handlers should be an array with the format (all elements are optional):

array(
[get_all] => get all handler,
[open] => open handler,
[get] => get handler,
[put] => put handler,
[close] => close handler
)

이전 | 처음으로 | 다음
xslt_set_sax_handlers | 위로 | xslt_set_scheme_handlers


xslt_set_scheme_handlers

(PHP 4 >= 4.0.6)

xslt_set_scheme_handlers -- Set the scheme handlers for the XSLT processor

Description

void xslt_set_scheme_handlers ( resource processor, array handlers)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
xslt_set_scheme_handler | 위로 | YAZ functions


YAZ functions

PHP 매뉴얼
이전 다음

CXXI. YAZ functions

Introduction

이 익스텐션은 정보검색을 위한 Z39.50 프로토콜을 사용하는YAZ툴킷의 PHP 인터페이스를 제공한다. 이 익스텐션은 Z39.50 origin(client)에게 쉽게 Z39.50 targets (servers)을 병렬 검색할 수 있는 도구를 제공한다.

YAZ는 http://www.indexdata.dk/yaz/서 만나볼 수 있다. 뉴스, 예제 스크립트, 등등 이 익스텐션은 http://www.indexdata.dk/phpyaz/여기서 구할 수 있다.

이 모듈은 Z39.50의 복잡성은 대부분 감추어져 있어서 매우 사용하기 쉽다. 이것은 PHP가 이용할 수 있는 다양한 SQL APIs와 매우 유사한 persistent stateless connections 을 제공한다. 이것은 세션들이 stateless 하지만 사용자들에게 분배된다는 것을 의미한다. 결국. 대부분의 경우 연결은 저장되고 상태의 진행은 초기화 된다.

설치

YAZ를 컴파일 하고 설치를 한다. PHP를 필요한 모듈과 빌드 할때 --with-yaz 옵션을 추가한다. 작업은 대개 다음과 같다.:

gunzip -c yaz-1.6.tar.gz|tar xf -
gunzip -c php-4.0.X.tar.gz|tar xf -
cd yaz-1.6
./configure --prefix=/usr
make
make install
cd ../php-4.0.X
./configure --with-yaz=/usr/bin
make
make install

Example

PHP/YAZ는 targets(Z-Associations)의 연결을 유지한다. positive integer는 ID of a particular를 나타낸다.

아래의 예제 스크립트는 API의 parallel searching을 보여준다. 독립변수 업시 불러낼때 query form을 출력하고 그렇지 않은경우(독립변수가 주어질때) 주어진 배열에서 targets을 찾아낸다

예 1. YAZ()

$num_hosts = count ($host);
if (empty($term) || count($host) == 0) {
    echo '<form method="get">
    <input type="checkbox"
    name="host[]" value="bagel.indexdata.dk/gils">
        GILS test
    <input type="checkbox"
    name="host[]" value="localhost:9999/Default">
        local test
    <input type="checkbox" checked="1"
    name="host[]" value="z3950.bell-labs.com/books">
        BELL Labs Library
    <br>
    RPN Query:
    <input type="text" size="30" name="term">
    <input type="submit" name="action" value="Search">
    ';
} else {
    echo 'You searced for ' . htmlspecialchars($term) . '<br>';
    for ($i = 0; $i < $num_hosts; $i++) {
        $id[] = yaz_connect($host[$i]);
        yaz_syntax($id[$i],"sutrs");
        yaz_search($id[$i],"rpn",$term);
    }
    yaz_wait();
    for ($i = 0; $i < $num_hosts; $i++) {
        echo '<hr>' . $host[$i] . ":";
        $error = yaz_error($id[$i]);
        if (!empty($error)) {
            echo "Error: $error";
        } else {
            $hits = yaz_hits($id[$i]);
            echo "Result Count $hits";
        }
        echo '<dl>';
        for ($p = 1; $p <= 10; $p++) {
            $rec = yaz_record($id[$i],$p,"string");
            if (empty($rec)) continue;
            echo "<dt><b>$p</b></dt><dd>";
            echo ereg_replace("\n", "<br>\n",$rec);
            echo "</dd>";
        }
        echo '</dl>';
    }
}

차례
yaz_addinfo -- 추가적인 error 정보를 리턴한다.
yaz_ccl_conf -- Configure CCL parser
yaz_ccl_parse -- Invoke CCL Parser
yaz_close -- YAZ의 연결을 닫는다.
yaz_connect -- 성공한 경우 양의 association ID를 리턴한다 : 실패의 경우 "0"을 리턴
yaz_database -- Specifies the databases within a session
yaz_element -- Specifies Element-Set Name for retrieval
yaz_errno -- error number를 리턴한다.
yaz_error -- error내용을 리턴한다.
yaz_es_result -- Inspects Extended Services Result
yaz_get_option -- Returns value of option for connection
yaz_hits -- 마지막 검색에 대한 히트수를 리턴한다.
yaz_itemorder -- Prepares for Z39.50 Item Order with an ILL-Request package
yaz_present -- Prepares for retrieval (Z39.50 present).
yaz_range -- 검색결과를 나타낼 범위를 지정한다.
yaz_record -- 레코드를 리턴한다.
yaz_scan_result -- Returns Scan Response result
yaz_scan -- Prepares for a scan
yaz_schema -- Specifies schema for retrieval.
yaz_search -- 검색을 준비한다.
yaz_set_option -- Sets one or more options for connection
yaz_sort -- Sets sorting criteria
yaz_syntax -- Specifies the preferred record syntax for retrieval.
yaz_wait -- Wait for Z39.50 requests to complete

이전 | 처음으로 | 다음
xslt_set_scheme_handlers | 위로 | yaz_addinfo


yaz_addinfo

(PHP 4 >= 4.0.1, PHP 5)

yaz_addinfo -- 추가적인 error 정보를 리턴한다.

Description

int yaz_addinfo ( int id)

부가적인 target (마지막 요청한)에 관한 정보를 리턴한다. 만일 마지막 작업이 성공적으로 이루어지거나 target이 제공하는 추가정보가 없는 경우 공백문자(A empty string)를 리턴한다.

이전 | 처음으로 | 다음
YAZ functions | 위로 | yaz_ccl_conf


yaz_ccl_conf

(PHP 4 >= 4.0.5, PHP 5)

yaz_ccl_conf -- Configure CCL parser

Description

int yaz_ccl_conf ( resource id, array config)

This function configures the CCL query parser for a server with definitions of access points (CCL qualifiers) and their mapping to RPN. To map a specific CCL query to RPN afterwards call the yaz_ccl_parse() function. Each index of the array config is the name of a CCL field and the corresponding value holds a string that specifies a mapping to RPN. The mapping is a sequence of attribute-type, attribute-value pairs. Attribute-type and attribute-value is separated by an equal sign (=). Each pair is separated by white space.

예 1. CCL configuration

In the example below, the CCL parser is configured to support three CCL fields: ti, au and isbn. Each field is mapped to their BIB-1 equivalent. It is assumed that variable $id is the connection ID.

<?php
$fields["ti"] = "1=4";
$fields["au"] = "1=1";
$fields["isbn"] = "1=7";
yaz_ccl_conf($id, $fields);
?>

이전 | 처음으로 | 다음
yaz_addinfo | 위로 | yaz_ccl_parse


yaz_ccl_parse

(PHP 4 >= 4.0.5, PHP 5)

yaz_ccl_parse -- Invoke CCL Parser

Description

bool yaz_ccl_parse ( resource id, string query, array & result)

This function invokes a CCL parser. It converts a given CCL FIND query to an RPN query which may be passed to the yaz_search() function to perform a search. To define a set of valid CCL fields call yaz_ccl_conf() prior to this function. If the supplied query was successfully converted to RPN, this function returns TRUE, and the index rpn of the supplied array result holds a valid RPN query. If the query could not be converted (because of invalid syntax, unknown field, etc.) this function returns FALSE and three indexes are set in the resulting array to indicate the cause of failure: errorcode CCL error code (integer), errorstring CCL error string, and errorpos approximate position in query of failure (integer is character position).

예 1. CCL Parsing

We will try to search using CCL. In the example below, $ccl is a CCL query.

<?php
yaz_ccl_conf($id, $fields);  // see example for yaz_ccl_conf
if (!yaz_ccl_parse($id, $ccl, &$cclresult)) {
    echo 'Error: ' . $cclresult["errorstring"];
} else {
    $rpn = $cclresult["rpn"];
    yaz_search($id, "rpn", $rpn);
}
?>

이전 | 처음으로 | 다음
yaz_ccl_conf | 위로 | yaz_close


yaz_close

(PHP 4 >= 4.0.1, PHP 5)

yaz_close -- YAZ의 연결을 닫는다.

Description

int yaz_close ( int id)

target과의 연결을 닫는다. application은 주어진 ID로 target에 조회할 수 없다.

이전 | 처음으로 | 다음
yaz_ccl_parse | 위로 | yaz_connect


yaz_connect

(PHP 4 >= 4.0.1, PHP 5)

yaz_connect -- 성공한 경우 양의 association ID를 리턴한다 : 실패의 경우 "0"을 리턴

Description

int yaz_connect ( string zurl)

yaz_connect()은 Z39.50 target과의 연결을 준비한다. zurl 변수는 host[:port][/database]형태를 취한다. 만일 port가 주어지지 않으면 "210"이 사용되고, database가 주어지지 않으면 "Default"를 사용한다. non-blocking함수이고, socket을 만들려고 시도하지 않는다. - 이것은 단지 마지막으로 yaz_wait()가 호출되었을때 수행된 연결을 준비한다.

이전 | 처음으로 | 다음
yaz_close | 위로 | yaz_database


yaz_database

(PHP 4 >= 4.0.6, PHP 5)

yaz_database -- Specifies the databases within a session

Description

bool yaz_database ( resource id, string databases)

This function specifies one or more databases to be used in search, retrieval, etc. - overriding databases specified in call to yaz_connect(). Multiple databases are separated by a plus sign +.

This function allows you to use different sets of databases within a session.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
yaz_connect | 위로 | yaz_element


yaz_element

(PHP 4 >= 4.0.1, PHP 5)

yaz_element -- Specifies Element-Set Name for retrieval

Description

bool yaz_element ( resource id, string elementset)

This function sets the element set name for retrieval. Call this function before yaz_search() or yaz_present() to specify the element set name for records to be retrieved. Most servers support F (for full records) and B (for brief records).

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
yaz_database | 위로 | yaz_errno


yaz_errno

(PHP 4 >= 4.0.1, PHP 5)

yaz_errno -- error number를 리턴한다.

Description

int yaz_errno ( int id)

target (last request)에 관한 error을 리턴한다. target이 진단코드(diagnostic code)를 리턴한 경우 양의 값을; 성공하여 에러가 없는 경우는 "0"의 값을; 요청에 대한 에러를 나타내지 못하는 경우 음의 값을 리턴한다.

yaz_errno()은 마지막 작업이 success/failure가 결정된 target에 대한 네트워크가 활성화(yaz_wait()라 리턴된 후에) 된 다음에 호출되어야 한다. (예. search)

이전 | 처음으로 | 다음
yaz_element | 위로 | yaz_error


yaz_error

(PHP 4 >= 4.0.1, PHP 5)

yaz_error -- error내용을 리턴한다.

Description

int yaz_error ( int id)

target (마지막 요청한)의 error 메세지를 리턴한다. 마지막 행한 작업이 성공적인 경우 공백문자(empty string)을 리턴한다.

yaz_error()는 yaz_errno()에 의해 리터된 마지막 에러번호에 일치하는 영문 메세지를 리턴한다.

이전 | 처음으로 | 다음
yaz_errno | 위로 | yaz_es_result


yaz_es_result

(PHP 4 >= 4.2.0, PHP 5)

yaz_es_result -- Inspects Extended Services Result

Description

array yaz_es_result ( resource id)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
yaz_error | 위로 | yaz_get_option


yaz_get_option

(PHP 5)

yaz_get_option -- Returns value of option for connection

Description

string yaz_get_option ( resource id, string name)

Returns the value of the option specified with name. If an option is not set, an empty string is returned.

See the description of yaz_set_option() for available options.

이전 | 처음으로 | 다음
yaz_es_result | 위로 | yaz_hits


yaz_hits

(PHP 4 >= 4.0.1, PHP 5)

yaz_hits -- 마지막 검색에 대한 히트수를 리턴한다.

Description

int yaz_hits ( int id)

yaz_hits() 마지막 검색에 대한 히트수를 리턴한다.

이전 | 처음으로 | 다음
yaz_get_option | 위로 | yaz_itemorder


yaz_itemorder

(PHP 4 >= 4.0.5, PHP 5)

yaz_itemorder -- Prepares for Z39.50 Item Order with an ILL-Request package

Description

int yaz_itemorder ( resource id, array args)

This function prepares for an Extended Services request using the Profile for the Use of Z39.50 Item Order Extended Service to Transport ILL (Profile/1). See this and the specification. The args parameter must be a hash array with information about the Item Order request to be sent. The key of the hash is the name of the corresponding ASN.1 tag path. For example, the ISBN below the Item-ID has the key item-id,ISBN.

The ILL-Request parameters are:

protocol-version-num
transaction-id,initial-requester-id,person-or-institution-symbol,person
transaction-id,initial-requester-id,person-or-institution-symbol,institution
transaction-id,initial-requester-id,name-of-person-or-institution,name-of-person
transaction-id,initial-requester-id,name-of-person-or-institution,name-of-institution
transaction-id,transaction-group-qualifier
transaction-id,transaction-qualifier
transaction-id,sub-transaction-qualifier
service-date-time,this,date
service-date-time,this,time
service-date-time,original,date
service-date-time,original,time
requester-id,person-or-institution-symbol,person
requester-id,person-or-institution-symbol,institution
requester-id,name-of-person-or-institution,name-of-person
requester-id,name-of-person-or-institution,name-of-institution
responder-id,person-or-institution-symbol,person
responder-id,person-or-institution-symbol,institution
responder-id,name-of-person-or-institution,name-of-person
responder-id,name-of-person-or-institution,name-of-institution
transaction-type
delivery-address,postal-address,name-of-person-or-institution,name-of-person
delivery-address,postal-address,name-of-person-or-institution,name-of-institution
delivery-address,postal-address,extended-postal-delivery-address
delivery-address,postal-address,street-and-number
delivery-address,postal-address,post-office-box
delivery-address,postal-address,city
delivery-address,postal-address,region
delivery-address,postal-address,country
delivery-address,postal-address,postal-code
delivery-address,electronic-address,telecom-service-identifier
delivery-address,electronic-address,telecom-service-addreess
billing-address,postal-address,name-of-person-or-institution,name-of-person
billing-address,postal-address,name-of-person-or-institution,name-of-institution
billing-address,postal-address,extended-postal-delivery-address
billing-address,postal-address,street-and-number
billing-address,postal-address,post-office-box
billing-address,postal-address,city
billing-address,postal-address,region
billing-address,postal-address,country
billing-address,postal-address,postal-code
billing-address,electronic-address,telecom-service-identifier
billing-address,electronic-address,telecom-service-addreess
ill-service-type
requester-optional-messages,can-send-RECEIVED
requester-optional-messages,can-send-RETURNED
requester-optional-messages,requester-SHIPPED
requester-optional-messages,requester-CHECKED-IN
search-type,level-of-service
search-type,need-before-date
search-type,expiry-date
search-type,expiry-flag
place-on-hold
client-id,client-name
client-id,client-status
client-id,client-identifier
item-id,item-type
item-id,call-number
item-id,author
item-id,title
item-id,sub-title
item-id,sponsoring-body
item-id,place-of-publication
item-id,publisher
item-id,series-title-number
item-id,volume-issue
item-id,edition
item-id,publication-date
item-id,publication-date-of-component
item-id,author-of-article
item-id,title-of-article
item-id,pagination
item-id,ISBN
item-id,ISSN
item-id,additional-no-letters
item-id,verification-reference-source
copyright-complicance
retry-flag
forward-flag
requester-note
forward-note

There are also a few parameters that are part of the Extended Services Request package and the ItemOrder package:

package-name
user-id
contact-name
contact-phone
contact-email
itemorder-item

이전 | 처음으로 | 다음
yaz_hits | 위로 | yaz_present


yaz_present

(PHP 4 >= 4.0.5, PHP 5)

yaz_present -- Prepares for retrieval (Z39.50 present).

Description

bool yaz_present ( resource id)

This function prepares for retrieval of records after a successful search. The yaz_range() should be called prior to this function to specify the range of records to be retrieved.

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

이전 | 처음으로 | 다음
yaz_itemorder | 위로 | yaz_range


yaz_range

(PHP 4 >= 4.0.1, PHP 5)

yaz_range -- 검색결과를 나타낼 범위를 지정한다.

Description

int yaz_range ( int id, int start, int number)

이 함수는 yaz_search()와 조합하여 시작위치(start)와 검색내용 중 나열할 최대값(number)을 나타내는데 이용된다. start의 디폴트 값은 "1"이고, number의 디폴트 값은 "10"이다.( 단지 yaz_search()만이 있는경우)

성공하면 TRUE를 : 에러가 난 경우는 FALSE 를 반환한다.

이전 | 처음으로 | 다음
yaz_present | 위로 | yaz_record


yaz_record

(PHP 4 >= 4.0.1, PHP 5)

yaz_record -- 레코드를 리턴한다.

Description

int yaz_record ( int id, int pos, string type)

주어진 포지션에 레코드가 없는경우 공백문자를 반환하고, 있는경우 레코드를 반환한다.

yaz_record()는 지정된 위치의 result set에서의 레코드를 점검한다. 만일 주어진 위치에서 database record 존재하지 않으면 공백문자를 리턴한다. 변수는 리턴될 레코드의 type를 지정한다. 만일 "string"이 주어지면 레코드는 (XML과 SUTRS)출력에 적합한 문자로 리턴된다. 만일 "array"로 지정하면 (structured records위한) 배열로 리턴된다.

이전 | 처음으로 | 다음
yaz_range | 위로 | yaz_scan_result


yaz_scan_result

(PHP 4 >= 4.0.5, PHP 5)

yaz_scan_result -- Returns Scan Response result

Description

array yaz_scan_result ( resource id [, array & result])

yaz_scan_result() returns terms and associated information as received from the server in the last performed yaz_scan(). This function returns an array (0..n-1) where n is the number of terms returned. Each value is a pair where the first item is the term, and the second item is the result-count. If the optional parameter result is given it will be modified to hold additional information taken from the Scan Response: number (number of entries returned), stepsize (Step-size), position (position of term), status (Scan Status).

이전 | 처음으로 | 다음
yaz_record | 위로 | yaz_scan


yaz_scan

(PHP 4 >= 4.0.5, PHP 5)

yaz_scan -- Prepares for a scan

Description

int yaz_scan ( resource id, string type, string startterm [, array flags])

This function prepares for a Z39.50 Scan Request, where parameter id specifies connection. Starting term point for the scan is given by startterm. The form in which the starting term is specified is given by parameter type. Currently only type rpn is supported. The optional parameter flags specifies additional information to control the behaviour of the scan request. Three indexes are currently read from the flags: number (number of terms requested), position (preferred position of term) and stepSize (preferred step size). To actually transfer the Scan Request to the server and receive the Scan Response, yaz_wait() must be called. Upon completion of yaz_wait() call yaz_error() and yaz_scan_result() to handle the response.

The syntax of startterm is similar to the RPN query as described in yaz_search(). The startterm consists of zero or more @attr-operator specifications, then followed by exactly one token.

예 1. PHP function that scans titles

<?php
function scan_titles($id, $startterm)
{
  yaz_scan($id, "rpn", "@attr 1=4 " . $startterm);
  yaz_wait();
  $errno = yaz_errno($id);
  if ($errno == 0) {
    $ar = yaz_scan_result($id, &$options);
    echo 'Scan ok; ';
    while (list($key, $val) = each($options)) {
      echo "$key = $val &nbsp;";
    }
    echo '<br /><table>';
    while (list($key, list($k, $term, $tcount)) = each($ar)) {
      if (empty($k)) continue;
      echo "<tr><td>$term</td><td>$tcount</td></tr>";
    }
    echo '</table>';
  } else {
    echo "Scan failed. Error: " . yaz_error($id) . "<br />";
  }
}
?>

이전 | 처음으로 | 다음
yaz_scan_result | 위로 | yaz_schema


yaz_schema

(PHP 4 >= 4.2.0, PHP 5)

yaz_schema -- Specifies schema for retrieval.

Description

int yaz_schema ( resource id, string schema)

The schema must be specified as an OID (Object Identifier) in a raw dot-notation (like 1.2.840.10003.13.4) or as one of the known registered schemas: GILS-schema, Holdings, Zthes, ... This function should be called before yaz_search() or yaz_present().

이전 | 처음으로 | 다음
yaz_scan | 위로 | yaz_search


yaz_search

(PHP 4 >= 4.0.1, PHP 5)

yaz_search -- 검색을 준비한다.

Description

int yaz_search ( int id, string type, string query)

yaz_search()은 주어진 ID로 target에 검색을 준비한다. type은 쿼리 타입을 나타낸다.-세번째 변수로 지정된 Type-1 query (RPN)인 경우 단지 "rpn"만을 지원한다. yaz_connect()처럼 non-blocking 이고 yaz_wait()이 호출된 이후에 검색을 준비한다.

The RPN query

The RPN query is a textual represenation of the Type-1 query as defined by the Z39.50 standard. However, in the text representation as used by YAZ a prefix notation is used, that is the operater precedes the operands. The query string is a sequence of tokens where white space is ignored is ignored unless surrounded by double quotes. Tokens beginning with an at-character (@) are considered operators, otherwise they are treated as search terms.

표 1. RPN Operators

Syntax | Description
@and query1 query2 | intersection of query1 and query2
@or query1 query2 | union of query1 and query2
@not query1 query2 | query1 and not query2
@set name | result set reference
@attrset set query | specifies attribute-set for query. This construction is only allowed once - in the beginning of the whole query
@attr set type=value query | applies attribute to query. The type and value are integers specifying the attribute-type and attribute-value respectively. The set, if given, specifies the attribute-set.

The following illustrates valid query constructions:

computer

Matches documents where "computer" occur. No attributes are specified.

"donald knuth"

Matches documents where "donald knuth" occur.

@attr 1=4 art

Attribute type is 1 (Bib-1 use), attribute value is 4 Title), so this should match documents where "art" occur in the title.

@attrset gils @and @attr 1=4 art @attr 1=1003 "donald knuth"

The query as a whole uses the GILS attributeset. The query matches documents where "art" occur in the title and in which "donald knuth" occur in the author.

이전 | 처음으로 | 다음
yaz_schema | 위로 | yaz_set_option


yaz_set_option

(PHP 5)

yaz_set_option -- Sets one or more options for connection

Description

string yaz_set_option ( resource id, string name, string value)

Sets option name to value.

표 1. PYP/YAZ Connection Options

Name | Description
implementationName | implementation name of server
implementationVersion | implementation version of server
implementationId | implementation ID of server
schema | schema for retrieval. By default, no schema is used. Setting this option is equivalent to using function yaz_schema()
preferredRecordSyntax | record syntax for retrieval. By default, no syntax is used. Setting this option is equivalent to using function yaz_syntax()
start | offset for first record to be retrieved via yaz_search() or yaz_present(). First record is numbered has a start value of 0. Second record has start value 1. Setting this option in combination with option count has the same effect as calling yaz_range() except that records are numbered from 1 in yaz_range()
count | maximum number of records to be retrieved via yaz_search() or yaz_present().
elementSetName | element-set-name for retrieval. Setting this option is equivalent to calling yaz_element().

이전 | 처음으로 | 다음
yaz_search | 위로 | yaz_sort


yaz_sort

(PHP 4 >= 4.1.0, PHP 5)

yaz_sort -- Sets sorting criteria

Description

int yaz_sort ( resource id, string criteria)

This function sets sorting criteria and enables Z39.50 Sort. Call this function before yaz_search(). Using this function alone does not have any effect. When used in conjunction with yaz_search(), a Z39.50 Sort will be sent after a search response has been received and before any records are retrieved with Z39.50 Present (yaz_present(). The parameter criteria takes the form

field1 flags1 field2 flags2 ...

where field1 specifies the primary attributes for sort, field2 seconds, etc.. The field specifies either a numerical attribute combinations consisting of type=value pairs separated by comma (e.g. 1=4,2=1) ; or the field may specify a plain string criteria (e.g. title. The flags is a sequence of the following characters which may not be separated by any white space.

Sort Flags

a

Sort ascending

d

Sort descending

i

Case insensitive sorting

s

Case sensitive sorting

예 1. Sort Criterias

To sort on Bib1 attribute title, case insensitive, and ascending you would use the following sort criteria:
1=4 ia

If the secondary sorting criteria should be author, case sensitive and ascending you would use:
1=4 ia 1=1003 sa

이전 | 처음으로 | 다음
yaz_set_option | 위로 | yaz_syntax


yaz_syntax

(PHP 4 >= 4.0.1, PHP 5)

yaz_syntax -- Specifies the preferred record syntax for retrieval.

Description

int yaz_syntax ( resource id, string syntax)

The syntax must be specified as an OID (Object Identifier) in a raw dot-notation (like 1.2.840.10003.5.10) or as one of the known registered record syntaxes (sutrs, usmarc, grs1, xml, etc.). This function should be called before yaz_search() or yaz_present().

이전 | 처음으로 | 다음
yaz_sort | 위로 | yaz_wait


yaz_wait

(PHP 4 >= 4.0.1, PHP 5)

yaz_wait -- Wait for Z39.50 requests to complete

Description

int yaz_wait ( [array options])

This function carries out networked (blocked) activity for outstanding requests which have been prepared by the functions yaz_connect(), yaz_search(), yaz_present(), yaz_scan() and yaz_itemorder(). yaz_wait() returns when all servers have either completed all requests or aborted (in case of errors).

If the options array is given that holds options that change the behaviour of yaz_wait().

timeout

Sets timeout in seconds. If a server has not responded within the timeout it is considered dead and yaz_wait() returns. The default value for timeout is 15 seconds.

이전 | 처음으로 | 다음
yaz_syntax | 위로 | YP/NIS 관련 함수


YP/NIS 관련 함수

PHP 매뉴얼
이전 다음

CXXII. YP/NIS 관련 함수

NIS (이전에는 옐로우 페이지(Yellow Pages)라고 불려졌습니다)는 중요한 관리자용 파일(예를 들면 패스워드 파일같은)을 네트워크 관리가 가능하도록 합니다. 더 이상의 정보는 NIS의 man 페이지와 Introduction to YP/NIS 에 좀 더 참조할 만한 정보가 있습니다. 또 Managing NFS and NIS라고 부르는 Hal Stern의 책도 있습니다.

이 함수가 동작하도록 하고 싶다면 PHP를 --with-yp(PHP 3)이나 --enable-yp(PHP 4)로 설정해야 합니다.

차례
yp_all -- Traverse the map and call a function on each entry
yp_cat -- Return an array containing the entire map
yp_err_string -- Returns the error string associated with the given error code
yp_errno -- Returns the error code of the previous operation
yp_first -- 이름 붙여진 맵(map)에서 첫 번째 key-value 쌍을 반환합니다.
yp_get_default_domain -- 머신의 NIS 도메인의 기본값을 가져옵니다.
yp_master -- 맵(map)에 사용되는 마스터 NIS 서버의 머신 이름을 반환합니다.
yp_match -- 매치(match)된 라인을 반환합니다.
yp_next -- 이름 붙여진 맵(map)에서 다음의 key-value 쌍을 반환합니다.
yp_order -- map에 사용되는 순서번호를 반환합니다

이전 | 처음으로 | 다음
yaz_wait | 위로 | yp_all


yp_all

(PHP 4 >= 4.0.6, PHP 5)

yp_all -- Traverse the map and call a function on each entry

Description

void yp_all ( string domain, string map, string callback)

주의

이 함수는 현재 문서화 되어있지 않습니다; 인자 목록만을 제공합니다.

이전 | 처음으로 | 다음
YP/NIS 관련 함수 | 위로 | yp_cat


yp_cat

(PHP 4 >= 4.0.6, PHP 5)

yp_cat -- Return an array containing the entire map

Description

array yp_cat ( string domain, string map)

yp_cat() returns all map entries as an array with the maps key values as array indices and the maps entries as array data.

이전 | 처음으로 | 다음
yp_all | 위로 | yp_err_string


yp_err_string

(PHP 4 >= 4.0.6, PHP 5)

yp_err_string -- Returns the error string associated with the given error code

Description

string yp_err_string ( int errorcode)

yp_err_string() returns the error message associated with the given error code. Useful to indicate what exactly went wrong.

예 1. Example for NIS errors

<?php
    echo "Error: " . yp_err_string(yp_errno());
?>

See also yp_errno().

이전 | 처음으로 | 다음
yp_cat | 위로 | yp_errno


yp_errno

(PHP 4 >= 4.0.6, PHP 5)

yp_errno -- Returns the error code of the previous operation

Description

int yp_errno ( void )

yp_errno() returns the error code of the previous operation.

Possible errors are:

1 args to function are bad
2 RPC failure - domain has been unbound
3 can't bind to server on this domain
4 no such map in server's domain
5 no such key in map
6 internal yp server or client error
7 resource allocation failure
8 no more records in map database
9 can't communicate with portmapper
10 can't communicate with ypbind
11 can't communicate with ypserv
12 local domain name not set
13 yp database is bad
14 yp version mismatch
15 access violation
16 database busy

See also yp_err_string().

이전 | 처음으로 | 다음
yp_err_string | 위로 | yp_first


yp_first

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

yp_first -- 이름 붙여진 맵(map)에서 첫 번째 key-value 쌍을 반환합니다.

Description

array yp_first ( string domain, string map)

yp_first()는 이름 붙여진 도메인의 이름 붙여진 맵(map)의 첫 번째 key-value 쌍을 반환하고, 그렇지 않은 경우에는 FALSE를 반환합니다.

예 1. 첫번째 NIS 예문

<?php
    $entry = yp_first($domain, "passwd.byname");
    $key = key($entry);
    echo "이 목록에서 키 값을 가지고 있는 첫 번째 키는 " . $key
          . " 그리고 값은  " . $entry[$key];
?>

참조: yp-get-default-domain()

이전 | 처음으로 | 다음
yp_errno | 위로 | yp_get_default_domain


yp_get_default_domain

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

yp_get_default_domain -- 머신의 NIS 도메인의 기본값을 가져옵니다.

Description

int yp_get_default_domain ( void )

yp_get_default_domain()는 노드의 기본값을 반환하거나 FALSE를 반환합니다. 계속적인 NIS 호출을 위한 도메인의 매개변수로 사용될 수 있습니다.

NIS 도메인은 NIS 맵(map)으로 설명될 수 있습니다. 모든 호스트는 어떤 도메인에 대한 자신의 바인드 정보를 찾아야 할 필요가 있습니다. 좀 더 상세한 정보를 얻기 위해서 앞부분에 언급한 문서를 참조 하십시오.

예 1. 기본 도메인에 관한 예문

<?php
$domain = yp_get_default_domain();
echo "기본 NIS 도메인은: " . $domain;
?>

이전 | 처음으로 | 다음
yp_first | 위로 | yp_master


yp_master

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

yp_master -- 맵(map)에 사용되는 마스터 NIS 서버의 머신 이름을 반환합니다.

Description

string yp_master ( string domain, string map)

yp_master()는 맵(map)에 사용되는 마스터 NIS 서버의 머신 이름을 반환합니다.

예 1. NIS 마스터(master)의 예문

<?php
$number = yp_master ($domain, $mapname);
echo "이 맵(map)의 마스터는: " . $master;
?>

참조: yp-get-default-domain().

이전 | 처음으로 | 다음
yp_get_default_domain | 위로 | yp_match


yp_match

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

yp_match -- 매치(match)된 라인을 반환합니다.

Description

string yp_match ( string domain, string map, string key)

yp_match()지정된 맵(map)의 범위외에서 통과된 키와 조합된 값이나 FALSE를 반환합니다. 이 키 값은 정확한 것이어야 합니다.

예 1. NIS 매치(match)의 예문

<?php
$entry = yp_match ($domain, "passwd.byname", "joe");
echo "매치(Match)된 목록 : " . $entry;
?>

이 경우에는 이렇게 될 수 있습니다: joe:##joe:11111:100:Joe User:/home/j/joe:/usr/local/bin/bash

참조: yp-get-default-domain()

이전 | 처음으로 | 다음
yp_master | 위로 | yp_next


yp_next

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

yp_next -- 이름 붙여진 맵(map)에서 다음의 key-value 쌍을 반환합니다.

Description

array yp_next ( string domain, string map, string key)

yp_next()키가 지정된 후에 이름 붙여진 맵(map)에서 다음의 key-value쌍을 반환하거나 FALSE를 반환합니다.

예 1. NIS next 예문

<?php
$entry = yp_next ($domain, "passwd.byname", "joe");

if (!$entry) {
    echo yp_errno() . ": " . yp_err_string();
}

$key = key ($entry);

echo "joe가 키를 가진 뒤의 다음 목록" . $key
      . " 값 " . $entry[$key];
?>

참조: yp-get-default-domain().

이전 | 처음으로 | 다음
yp_match | 위로 | yp_order


yp_order

(PHP 3>= 3.0.7, PHP 4 , PHP 5)

yp_order -- map에 사용되는 순서번호를 반환합니다

Description

int yp_order ( string domain, string map)

yp_order()는 맵(map)의 순서번호를 반환하거나 FALSE를 반환합니다.

예 1. NIS 순서 예문

<?php
    $number = yp_order($domain,$mapname);
    echo "이 맵(map)의 순서 번호는 : " . $order;
?>

참조: yp-get-default-domain().

이전 | 처음으로 | 다음
yp_next | 위로 | Zip File Functions (Read Only Access)


Zip File Functions (Read Only Access)

PHP 매뉴얼
이전 다음

CXXIII. Zip File Functions (Read Only Access)

소개

This module enables you to transparently read ZIP compressed archives and the files inside them.

요구 사항

This module uses the functions of the ZZIPlib library by Guido Draheim. You need ZZIPlib version >= 0.10.6.

Note that ZZIPlib only provides a subset of functions provided in a full implementation of the ZIP compression algorithm and can only read ZIP file archives. A normal ZIP utility is needed to create the ZIP file archives read by this library.

설치

Zip support in PHP is not enabled by default. You will need to use the --with-zip[=DIR] configuration option when compiling PHP to enable zip support.

참고: Zip support before PHP 4.1.0 is experimental. This section reflects the Zip extension as it exists in PHP 4.1.0 and later.

런타임 설정

이 확장 모듈은 php.ini 설정이 존재하지 않습니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 상수를 정의하지 않습니다.

예제

This example opens a ZIP file archive, reads each file in the archive and prints out its contents. The test2.zip archive used in this example is one of the test archives in the ZZIPlib source distribution.

예 1. Zip Usage Example

<?php

$zip = zip_open("/tmp/test2.zip");

if ($zip) {

    while ($zip_entry = zip_read($zip)) {
        echo "Name:               " . zip_entry_name($zip_entry) . "\n";
        echo "Actual Filesize:    " . zip_entry_filesize($zip_entry) . "\n";
        echo "Compressed Size:    " . zip_entry_compressedsize($zip_entry) . "\n";
        echo "Compression Method: " . zip_entry_compressionmethod($zip_entry) . "\n";

        if (zip_entry_open($zip, $zip_entry, "r")) {
            echo "File Contents:\n";
            $buf = zip_entry_read($zip_entry, zip_entry_filesize($zip_entry));
            echo "$buf\n";

            zip_entry_close($zip_entry);
        }
        echo "\n";

    }

    zip_close($zip);

}

?>
차례
zip_close -- Close a Zip File Archive
zip_entry_close -- Close a Directory Entry
zip_entry_compressedsize -- Retrieve the Compressed Size of a Directory Entry
zip_entry_compressionmethod -- Retrieve the Compression Method of a Directory Entry
zip_entry_filesize -- Retrieve the Actual File Size of a Directory Entry
zip_entry_name -- Retrieve the Name of a Directory Entry
zip_entry_open -- Open a Directory Entry for Reading
zip_entry_read -- Read From an Open Directory Entry
zip_open -- Open a Zip File Archive
zip_read -- Read Next Entry in a Zip File Archive

이전 | 처음으로 | 다음
yp_order | 위로 | zip_close


zip_close

(PHP 4 >= 4.1.0)

zip_close -- Close a Zip File Archive

Description

void zip_close ( resource zip)

Closes a zip file archive. The parameter zip must be a zip archive previously opened by zip_open().

This function has no return value.

See also zip_open() and zip_read().

이전 | 처음으로 | 다음
Zip File Functions (Read Only Access) | 위로 | zip_entry_close


zip_entry_close

(PHP 4 >= 4.1.0)

zip_entry_close -- Close a Directory Entry

Description

void zip_entry_close ( resource zip_entry)

Closes a directory entry specified by zip_entry. The parameter zip_entry must be a valid directory entry opened by zip_entry_open().

This function has no return value.

See also zip_entry_open() and zip_entry_read().

이전 | 처음으로 | 다음
zip_close | 위로 | zip_entry_compressedsize


zip_entry_compressedsize

(PHP 4 >= 4.1.0)

zip_entry_compressedsize -- Retrieve the Compressed Size of a Directory Entry

Description

int zip_entry_compressedsize ( resource zip_entry)

Returns the compressed size of the directory entry specified by zip_entry. The parameter zip_entry is a valid directory entry returned by zip_read().

See also zip_open() and zip_read().

이전 | 처음으로 | 다음
zip_entry_close | 위로 | zip_entry_compressionmethod


zip_entry_compressionmethod

(PHP 4 >= 4.1.0)

zip_entry_compressionmethod -- Retrieve the Compression Method of a Directory Entry

Description

string zip_entry_compressionmethod ( resource zip_entry)

Returns the compression method of the directory entry specified by zip_entry. The parameter zip_entry is a valid directory entry returned by zip_read().

See also zip_open() and zip_read().

이전 | 처음으로 | 다음
zip_entry_compressedsize | 위로 | zip_entry_filesize


zip_entry_filesize

(PHP 4 >= 4.1.0)

zip_entry_filesize -- Retrieve the Actual File Size of a Directory Entry

Description

int zip_entry_filesize ( resource zip_entry)

Returns the actual size of the directory entry specified by zip_entry. The parameter zip_entry is a valid directory entry returned by zip_read().

See also zip_open() and zip_read().

이전 | 처음으로 | 다음
zip_entry_compressionmethod | 위로 | zip_entry_name


zip_entry_name

(PHP 4 >= 4.1.0)

zip_entry_name -- Retrieve the Name of a Directory Entry

Description

string zip_entry_name ( resource zip_entry)

Returns the name of the directory entry specified by zip_entry. The parameter zip_entry is a valid directory entry returned by zip_read().

See also zip_open() and zip_read().

이전 | 처음으로 | 다음
zip_entry_filesize | 위로 | zip_entry_open


zip_entry_open

(PHP 4 >= 4.1.0)

zip_entry_open -- Open a Directory Entry for Reading

Description

bool zip_entry_open ( resource zip, resource zip_entry [, string mode])

Opens a directory entry in a zip file for reading. The parameter zip is a valid resource handle returned by zip_open(). The parameter zip_entry is a directory entry resource returned by zip_read(). The optional parameter mode can be any of the modes specified in the documentation for fopen().

참고: Currently, mode is ignored and is always "rb". This is due to the fact that zip support in PHP is read only access. Please see fopen() for an explanation of various modes, including "rb".

성공일 경우 TRUE를, 실패일 경우 FALSE를 반환합니다.

참고: Unlike fopen() and other similar functions, the return value of zip_entry_open() only indicates the result of the operation and is not needed for reading or closing the directory entry.

See also zip_entry_read() and zip_entry_close().

이전 | 처음으로 | 다음
zip_entry_name | 위로 | zip_entry_read


zip_entry_read

(PHP 4 >= 4.1.0)

zip_entry_read -- Read From an Open Directory Entry

Description

string zip_entry_read ( resource zip_entry [, int length])

Reads up to length bytes from an open directory entry. If length is not specified, then zip_entry_read() will attempt to read 1024 bytes. The parameter zip_entry is a valid directory entry returned by zip_read().

참고: The length parameter should be the uncompressed length you wish to read.

Returns the data read, or FALSE if the end of the file is reached.

See also zip_entry_open(),
zip_entry_close() and
zip_entry_filesize().

이전 | 처음으로 | 다음
zip_entry_open | 위로 | zip_open


zip_open

(PHP 4 >= 4.1.0)

zip_open -- Open a Zip File Archive

Description

resource zip_open ( string filename)

Opens a new zip archive for reading. The filename parameter is the filename of the zip archive to open.

Returns a resource handle for later use with zip_read() and zip_close() or returns FALSE if filename does not exist.

See also zip_read() and zip_close().

이전 | 처음으로 | 다음
zip_entry_read | 위로 | zip_read


zip_read

(PHP 4 >= 4.1.0)

zip_read -- Read Next Entry in a Zip File Archive

Description

resource zip_read ( resource zip)

Reads the next entry in a zip file archive. The parameter zip must be a zip archive previously opened by zip_open().

Returns a directory entry resource for later use with the zip_entry_...() functions or FALSE if there's no more entries to read.

See also zip_open(),
zip_close(),
zip_entry_open(), and
zip_entry_read().

이전 | 처음으로 | 다음
zip_open | 위로 | Zlib 압축 함수


Zlib 압축 함수

PHP 매뉴얼
이전 다음

CXXIV. Zlib 압축 함수

소개

이 모듈은 gzip (.gz) 압축 파일을 읽고 쓸 수 있게 하며, 버전에 따라서는 대부분의 파일시스템 함수에서 gzip-압축 파일 작업을 할 수 있게 합니다. (비압축 파일도 가능하지만, 소켓에는 불가능합니다)

참고: 버전 4.0.4에서 .gz 파일을 위해 'zlib:' URL로 접근하는 fopen-랩퍼가 추가되었습니다. fopen()을 호출할 때 파일 이름이나 경로 앞에 'zlib:'을 덧붙여서 보통의 f*() 파일 접근 함수에서 압축 파일에 자유롭게 접근할 수 있습니다.

버전 4.3.0에서 이 특별한 전치사는 ':'을 포함하는 파일 이름과의 혼동을 막기 위해서 'zlib://'으로 변경되었습니다.

이 기능은 fopencookie() 함수를 제공하는 C 런타임 라이브러리가 필요합니다. 현재 알려진 바로는 GNU libc가 이 기능을 제공하는 유일한 라이브러리입니다.

요구 사항

이 모듈을 Jean-loup Gailly와 Mark Adler가 작성한 zlib의 함수들을 사용합니다. 이 모듈에서는 zlib 버전 >= 1.0.9를 사용해야 합니다.

설치

PHP의 Zlib 지원은 기본값으로 활성화되어 있지 않습니다. PHP를 --with-zlib[=DIR]로 설정해야 합니다.

PHP 윈도우 버전에서는 이 확장 모듈에 대한 지원이 포함되어 있습니다. 이 함수들을 이용하기 위해서 추가로 확장 모듈을 읽어들일 필요가 없습니다.

참고: 윈도우즈에서 zlib 지원 내장은 PHP 4.3.0에서 이루어졌습니다.

런타임 설정

이 함수의 작동은 php.ini 설정에 영향을 받습니다.

zlib 확장은 브라우저가 지원한다면, 페이지를 전송할 때 압축할 수 있는 옵션을 제공합니다. 설정 파일 php.ini에 세가지 옵션이 존재합니다.

표 1. Zlib 설정 옵션

이름 | 기본값 | 변경가능성
zlib.output_compression | "Off" | PHP_INI_ALL
zlib.output_compression_level | "-1" | PHP_INI_ALL
zlib.output_handler | "" | PHP_INI_ALL
PHP_INI_* 상수에 대한 자세한 내용 및 정의는 ini_set()을 참고하십시오

위 설정 지시어에 대한 간단한 설명입니다.

zlib.output_compression boolean/integer

페이지 압축의 사용 여부. 이 옵션을 php.ini나 아파치 설정에서 "On"으로 지정하면, 브라우저가 "Accept-Encoding: gzip"이나 "deflate" 헤더를 보냈을때, 페이지를 압축합니다. "Content-Encoding: gzip"(혹은 "deflate")과 "Vary: Accept-Encoding" 헤더을 출력에 추가합니다.

헤더를 전송하기 전에 ini_set()을 사용해서 스크립트 내부에서 무효화할 수 있습니다. "Content-Type: image/" 헤더를 출력해도 압축을 무효화합니다(넷스케이프 버그로 인해). 이미지 content-type 헤더 호출을 추가한 뒤에 "ini_set('zlib.output_compression', 'On')"을 추가하여 다시 활성화 할 수 있습니다.

boolean "On"/"Off" 외에 정수값을 지정하여, 출력 버퍼 크기를 설정할 수 있습니다. (기본값은 4KB) (default is 4KB).

참고: 'On'으로 지정했을 때, output_handler는 zlib.output_handler를 사용하지 말고, 비어있어야 합니다!

zlib.output_compression_level integer

출력 압축에 사용하는 압축 레벨.

zlib.output_handler string

zlib.output_compression을 활성화 했을 때, 추가 출력 핸들러를 지정할 수 없습니다. 이 설정은 output_handler와 동일한 다른 명령입니다.

리소스 종류

이 확장 모듈은 리소스형을 정의하지 않습니다.

상수 정의

이 확장 모듈은 다음의 상수를 정의합니다. 이는 확장 모듈을 PHP에 내장했거나, 실행시에 동적으로 읽어들일 경우에만 사용할 수 있습니다.

FORCE_GZIP (integer)

FORCE_DEFLATE (integer)

예제

이 예제는 임시 파일을 열어서 테스트 문자열을 쓰고, 이 파일의 내용을 두번 출력합니다.

예 1. 작은 Zlib 예제

<?php

$filename = tempnam('/tmp', 'zlibtest') . '.gz';
echo "<html>\n<head></head>\n<body>\n<pre>\n";
$s = "Only a test, test, test, test, test, test, test, test!\n";

// 최대 압축으로 쓰기 위한 파일을 엽니다.
$zp = gzopen($filename, "w9");

// 파일에 문자열을 씁니다.
gzwrite($zp, $s);

// 파일을 닫습니다.
gzclose($zp);

// 읽기 위해 파일을 엽니다.
$zp = gzopen($filename, "r");

// 3 문자를 읽습니다.
echo gzread($zp, 3);

// 파일을 끝까지 출력하고 닫습니다.
gzpassthru($zp);
gzclose($zp);

echo "\n";

// 파일을 읽어서 내용을 출력합니다. (두번째)
if (readgzfile($filename) != strlen($s)) {
        echo "zlib 함수의 에러!";
}
unlink($filename);
echo "</pre>\n</body>\n</html>\n";

?>
차례
gzclose -- 지정된 .gz 파일을 닫는다.
gzcompress -- .gz로 문자를 압축한다.
gzdeflate -- Deflate a string
gzencode -- Create a gzip compressed string
gzeof -- 지정된 .gz 파일의 끝을 테스트한다.
gzfile -- gz 파일 내용을 배열로 읽어들인다.
gzgetc -- 지정된 .gz파일로부터 문자를 추출한다.
gzgets -- 지정된 파일로 부터 라인을 읽어 들인다.
gzgetss -- .gz 파일로부터 HTML 태그를 제외하고 한 라인을 읽는다,
gzinflate -- Inflate a deflated string
gzopen -- .gz파일을 연다
gzpassthru -- 지정된 파일의 남아있는 모든 데이타를 출력한다.
gzputs -- 지정된 .gz 파일에 기록한다.
gzread -- .gz로부터 바이트값을 읽어들인다
gzrewind -- 지정된 .gz파일을 리와인드한다
gzseek -- 지정된 .gz 파일을 검색한다.
gztell -- 지정된 .gz 파일의 read/write position을 리턴한다
gzuncompress -- gz로 압축된 문자를 압축해제 한다.
gzwrite -- 지정된 string을 .gz파일 스트림에 기록한다.
readgzfile -- .gz파일을 출력한다
zlib_get_coding_type -- Returns the coding type used for output compression

이전 | 처음으로 | 다음
zip_read | 위로 | gzclose


gzclose

(PHP 3, PHP 4 , PHP 5)

gzclose -- 지정된 .gz 파일을 닫는다.

Description

int gzclose ( int zp)

zp에의해 지정된 .gz 파일이 닫혀진다.

성공시 TRUE를 실패시 failure를 반환한다.

.gz파일의 지정은 정확해야 하고, gzopen()에 의해 성공적으로 열린 파일을 지정해야 한다.

이전 | 처음으로 | 다음
Zlib 압축 함수 | 위로 | gzcompress


gzcompress

(PHP 4 >= 4.0.1, PHP 5)

gzcompress -- .gz로 문자를 압축한다.

Description

string gzcompress ( string data [, int level])

이 함수는 입력된data의 gzip압축버젼을 리턴하거나 에러발생시 FALSE를 반환한다. 옵션의 파라미터인 level은 압축률이 0인 0부터 최대압축률인 9까지 주어진다.

참고 gzuncompress().

이전 | 처음으로 | 다음
gzclose | 위로 | gzdeflate


gzdeflate

(PHP 4 >= 4.0.4, PHP 5)

gzdeflate -- Deflate a string

Description

string gzdeflate ( string data [, int level])

This function returns a compressed version of the input data using the DEFLATE data format, or FALSE if an error is encountered. The optional parameter level can be given as 0 for no compression up to 9 for maximum compression. If level is not given the default compression level will be the default compression level of the zlib library.

For details on the DEFLATE compression algorithm see the document "DEFLATE Compressed Data Format Specification version 1.3" (RFC 1951).

See also
gzinflate(),
gzcompress(),
gzuncompress(),
gzencode().

이전 | 처음으로 | 다음
gzcompress | 위로 | gzencode


gzencode

(PHP 4 >= 4.0.4, PHP 5)

gzencode -- Create a gzip compressed string

Description

string gzencode ( string data [, int level [, int encoding_mode]])

This function returns a compressed version of the input data compatible with the output of the gzip program, or FALSE if an error is encountered. The optional parameter level can be given as 0 for no compression up to 9 for maximum compression, if not given the default compression level will be the default compression level of the zlib library.

You can also give FORCE_GZIP (the default) or FORCE_DEFLATE as optional third parameter encoding_mode. If you use FORCE_DEFLATE, you get a standard zlib deflated string (inclusive zlib headers) after the gzip file header but without the trailing crc32 checksum.

참고: level was added in PHP 4.2, before PHP 4.2 gzencode() only had the data and (optional) encoding_mode parameters..

The resulting data contains the appropriate headers and data structure to make a standard .gz file, e.g.:

예 1. Creating a gzip file

<?php
    $data = implode("", file("bigfile.txt"));
    $gzdata = gzencode($data, 9);
    $fp = fopen("bigfile.txt.gz", "w");
    fwrite($fp, $gzdata);
    fclose($fp);
?>

For more information on the GZIP file format, see the document: GZIP file format specification version 4.3 (RFC 1952).

See also gzcompress().
gzuncompress(),
gzdeflate(),
gzinflate().

이전 | 처음으로 | 다음
gzdeflate | 위로 | gzeof


gzeof

(PHP 3, PHP 4 , PHP 5)

gzeof -- 지정된 .gz 파일의 끝을 테스트한다.

Description

int gzeof ( int zp)

지정된 .gz 파일의 끝이거나 에러가 일어나면 TRUE를 반환하고; 그렇지 않은 경우 FALSE를 반환한다.

.gz 파일지정은 정확해야 하고, gzopen()에 의해 성공적으로 열린 파일을 지정해야 한다.

이전 | 처음으로 | 다음
gzencode | 위로 | gzfile


gzfile

(PHP 3, PHP 4 , PHP 5)

gzfile -- gz 파일 내용을 배열로 읽어들인다.

Description

array gzfile ( string filename [, int use_include_path])

readgzfile()와 동일하나, gzfile()은 파일을 배열로 반환한다.

만일 include_path안의 파일을 검색하기 원한다면, 두번째 옵션의 파라미터에 "1"을 넣으면 된다.

참고readgzfile(), 와 gzopen().

이전 | 처음으로 | 다음
gzeof | 위로 | gzgetc


gzgetc

(PHP 3, PHP 4 , PHP 5)

gzgetc -- 지정된 .gz파일로부터 문자를 추출한다.

Description

string gzgetc ( int zp)

zp에 의해 지정된 파일로부터 문자열에 포함된 단문자(압축되지 않은)를 반환한다. EOF의 경우 FALSE를 반환한다(마치 gzeof()처럼).

.gz 파일의 지정은 정확해야 하고 ,gzopen()에 의해 성공적으로 열린 파일이어야 한다.

참고 gzopen(), 과 gzgets().

이전 | 처음으로 | 다음
gzfile | 위로 | gzgets


gzgets

(PHP 3, PHP 4 , PHP 5)

gzgets -- 지정된 파일로 부터 라인을 읽어 들인다.

Description

string gzgets ( int zp, int length)

fp에 의해 지정된 파일로부터 length - 1 bytes의 문장을 리턴한다. length - 1 bytes를 읽거나, 새로운 라인을 만나거나, EOF의 경우 (혹 처음으로 돌아가든지), 읽는것을 그만둔다.

에러가 일어난 경우 FALSE를 반환한다.

파일의 지정은 정확해야 하고, gzopen()에 의해 성공적으로 열린 파일이어야 한다.

참고 gzopen(), gzgetc(), fgets().

이전 | 처음으로 | 다음
gzgetc | 위로 | gzgetss


gzgetss

(PHP 3, PHP 4 , PHP 5)

gzgetss -- .gz 파일로부터 HTML 태그를 제외하고 한 라인을 읽는다,

Description

string gzgetss ( int zp, int length [, string allowable_tags])

gzgets()와 동일하나, gzgetss()은 읽은 문자에서 HTML과 PHP 태그를 제외한다.

세번째 옵션의 파라미터를 사용하여 명시한 태그를 제외하지 않을 수 있다.You can use the optional third parameter to specify tags which should not be stripped.

참고: Allowable_tags는 PHP 3.0.13, PHP4B3에 포함되었다.

참고 gzgets(), gzopen(), strip_tags().

이전 | 처음으로 | 다음
gzgets | 위로 | gzinflate


gzinflate

(PHP 4 >= 4.0.4, PHP 5)

gzinflate -- Inflate a deflated string

Description

string gzinflate ( string data [, int length])

This function takes data compressed by gzdeflate() and returns the original uncompressed data or FALSE on error. The function will return an error if the uncompressed data is more than 32768 times the length of the compressed input data or more than the optional parameter length.

See also gzcompress().
gzuncompress(),
gzdeflate(), and
gzencode().

이전 | 처음으로 | 다음
gzgetss | 위로 | gzopen


gzopen

(PHP 3, PHP 4 , PHP 5)

gzopen -- .gz파일을 연다

Description

int gzopen ( string filename, string mode [, int use_include_path])

gzip (.gz)파일을 읽기 또는 쓰기위해 연다. mode 파라미터는 fopen() ("rb" or "wb")와 같고, 또한 압축레벨 ("wb9") 또는 stategy를 포함한다: 'f' for filtered data as in "wb6f", 'h' for Huffman only compression as in "wb1h". (strategy parameter에 관한 보다 많은 정보를 원한다면 the description of deflateInit2 in zlib.h보라.)

gzopen()은 gzip 포멧이 아닌 파일을 읽는데 사용될 수 있다.; 이 경우 gzread()로 압축해제 없이 바로 파일로 부터 읽을 수 있다.

gzopen()은 열고자 지정한 파일을 리턴 한다. 그리고는 읽고자 하는 모든것을 압축해제하고, 기록하고 압축할 수 있다.

만일 열기에 실패하면 FALSE를 리턴한다.

세번째 옵션의 파라미터에 "1"을 넣으면 include_path안의 파일을 검색 할수 있다.

예 1. gzopen() Example

$fp = gzopen ("/tmp/file.gz", "r");

참고 gzclose().

이전 | 처음으로 | 다음
gzinflate | 위로 | gzpassthru


gzpassthru

(PHP 3, PHP 4 , PHP 5)

gzpassthru -- 지정된 파일의 남아있는 모든 데이타를 출력한다.

Description

int gzpassthru ( int zp)

지정된 .gz파일의 EOF을 읽으면 standard output으로 결과(압축되지 않은) 결과를 출력한다.

에러가 나면 FALSE를 리턴한다.

파일의 지정은 정확해야하고, gzopen()의해 성공적으로 열린 파일이어야 한다.

gzpassthru()가 읽는것을 마치면 .gz파일은 닫힌다.(leaving zp는 불필요하다).

이전 | 처음으로 | 다음
gzopen | 위로 | gzputs


gzputs

(PHP 3, PHP 4 , PHP 5)

gzputs -- 지정된 .gz 파일에 기록한다.

Description

int gzputs ( int zp, string str [, int length])

gzputs()은 gzwrite()와 모든면에서 동일하다.

이전 | 처음으로 | 다음
gzpassthru | 위로 | gzread


gzread

(PHP 3, PHP 4 , PHP 5)

gzread -- .gz로부터 바이트값을 읽어들인다

Description

string gzread ( int zp, int length)

gzread()은 zp로부터 참조된 지정된 .gz 파일로부터 length만큼의 byte값을 읽어들인다. length (압축되지 않은)만큼의 byte를 읽거나 EOF에 다다르면 읽기를 멈춘다. (처음으로 돌아가는것 포함)

// get contents of a gz-file into a string
$filename = "/usr/local/something.txt.gz";
$zd = gzopen ($filename, "r");
$contents = gzread ($zd, 10000);
gzclose ($zd);

참고 gzwrite(), gzopen(),
 gzgets(), gzgetss(),
 gzfile(), gzpassthru().

이전 | 처음으로 | 다음
gzputs | 위로 | gzrewind


gzrewind

(PHP 3, PHP 4 , PHP 5)

gzrewind -- 지정된 .gz파일을 리와인드한다

Description

int gzrewind ( int zp)

zp를 지시자로 파일스트림의 시작위치로 파일 포지션을 둔다.

error가 발생하면 0을 반환한다.

파일의 지어은 정확해야 하고, gzopen()에 의해 성공적으로 열린 파일이어야 한다.

참고 gzseek(), gztell().

이전 | 처음으로 | 다음
gzread | 위로 | gzseek


gzseek

(PHP 3, PHP 4 , PHP 5)

gzseek -- 지정된 .gz 파일을 검색한다.

Description

int gzseek ( int zp, int offset)

파일 스트림 내부에서 zp참조로 지정된 파일 포지션을 offset으로 이동한다. C에서 gzseek( zp, offset, SEEK_SET )의 호출과 동일하다.

만약 파일이 읽기속성으로 열린 경우, 이 함수는 에뮬레이트 될 수 있지만 매우 느릴수도 있다. 만일 쓰기 속성으로 열린경우에는, 오직 순차검색만을 지원한다. :gzseek는 새 시작위치까지 0의 연속으로 압축한다.(이상해서 원문을 포함합니다.) 원문:If the file is opened for reading, this function is emulated but can be extremely slow. If the file is opened for writing, only forward seeks are supported; gzseek then compresses a sequence of zeroes up to the new starting position.

성공할 경우 0을 반환하고; 그렇지 않은 경우 -1을 반환한다. EOF를 지나는 검색은 error을 고려하지 않는다.

참고 gztell(), gzrewind().

이전 | 처음으로 | 다음
gzrewind | 위로 | gztell


gztell

(PHP 3, PHP 4 , PHP 5)

gztell -- 지정된 .gz 파일의 read/write position을 리턴한다

Description

int gztell ( int zp)

zp에의해 참조된 파일위치의 포인터를 반환한다; 즉, 파일스트림 내부의 offset

만일 에러가 발생하면 FALSE를 반환.

파일은 정확히 지정되어야 하고, gzopen()에의해 성공적으로 열린 파일이어야 한다.

참고 gzopen(), gzseek(), gzrewind().

이전 | 처음으로 | 다음
gzseek | 위로 | gzuncompress


gzuncompress

(PHP 4 >= 4.0.1, PHP 5)

gzuncompress -- gz로 압축된 문자를 압축해제 한다.

Description

string gzuncompress ( string data [, int length])

이 함수는 gzcompress()로 압축된 data를 취하여, 압축되지않은 원본데이터를 반환하거나 에러의 경우 FALSE를 반환한다. 만일 압축해제된 데이타가 압축되어 입력된 data보다 256배 이상이거나 옵션의 파라미터의 length이상인 경우 에러를 반환한다.

참고 gzcompress().

이전 | 처음으로 | 다음
gztell | 위로 | gzwrite


gzwrite

(PHP 3, PHP 4 , PHP 5)

gzwrite -- 지정된 string을 .gz파일 스트림에 기록한다.

Description

int gzwrite ( int zp, string string [, int length])

gzwrite()는 zp에 의해 지정된 .gz파일스트림에 string을 기록한다. 만일 length가 주어지면, length (압축되지않은) 바이트마큼 쓰여지거나, string의 끝에 도달하거나, 혹은 초기화되거나하면 '쓰기'가 중지된다.

만일 length항목이 주어지면, magic_quotes_runtime 환경설정은 무시되어지고, string에서 '/'은 제거되지 않는다는것을 유의하라.

참고 gzread(), gzopen(), gzputs().

이전 | 처음으로 | 다음
gzuncompress | 위로 | readgzfile


readgzfile

(PHP 3, PHP 4 , PHP 5)

readgzfile -- .gz파일을 출력한다

Description

int readgzfile ( string filename [, int use_include_path])

파일을 읽고, 압축해제를하고 standard output으로 출력한다.

readgzfile()은 gzip format이 아니더라도 읽을 수 있다.; 이 경우 readgzfile()은 바로 압축해제없이 파일을 읽어들이 수 있다.

파일로부터 읽어들인 바이트수(압축되지 않은)를 리턴한다. 만일 에러가 발생하면, -@readgzfile라고 불리우는 경우가 아닌한- FALSE를 반환하고, 에러메세지를 출력한다.

filename은 파일시스템으로부터 열려지고, 그 내용은 standard output으로 출력된다.

include_path안의 파일을 검색하고자 원한다면, 두번째 옵션의 파라미터를 "1"을 넣으면 된다.

참고 gzpassthru(), gzfile(), gzopen().

이전 | 처음으로 | 다음
gzwrite | 위로 | zlib_get_coding_type


zlib_get_coding_type

(PHP 4 >= 4.3.2, PHP 5)

zlib_get_coding_type -- Returns the coding type used for output compression

Description

string zlib_get_coding_type ( void )

Returns the coding type used for output compression. Possible return values are gzip, deflate, or FALSE

See also the zlib.output_compression directive.

이전 | 처음으로 | 다음
readgzfile | 위로 | Zend API


Zend API

PHP 매뉴얼
이전 다음

VI. Zend API

Hacking the Core of PHP

Those who know don't talk.

Those who talk don't know.

Sometimes, PHP "as is" simply isn't enough. Although these cases are rare for the average user, professional applications will soon lead PHP to the edge of its capabilities, in terms of either speed or functionality. New functionality cannot always be implemented natively due to language restrictions and inconveniences that arise when having to carry around a huge library of default code appended to every single script, so another method needs to be found for overcoming these eventual lacks in PHP.

As soon as this point is reached, it's time to touch the heart of PHP and take a look at its core, the C code that makes PHP go.

차례
24. Overview
25. Extension Possibilities
26. Source Layout
27. PHP's Automatic Build System
28. Creating Extensions
29. Using Extensions
30. Troubleshooting
31. Source Discussion
32. Accepting Arguments
33. Creating Variables
34. Duplicating Variable Contents: The Copy Constructor
35. Returning Values
36. Printing Information
37. Startup and Shutdown Functions
38. Calling User Functions
39. Initialization File Support
40. Where to Go from Here
41. Reference: Some Configuration Macros
42. API Macros
Hacking the Core of PHP

이전 | 처음으로 | 다음
zlib_get_coding_type |  | Overview


Overview

PHP 매뉴얼
이전 다음

24. 장. Overview

차례
What Is Zend? and What Is PHP?

"Extending PHP" is easier said than done. PHP has evolved to a full-fledged tool consisting of a few megabytes of source code, and to hack a system like this quite a few things have to be learned and considered. When structuring this chapter, we finally decided on the "learn by doing" approach. This is not the most scientific and professional approach, but the method that's the most fun and gives the best end results. In the following sections, you'll learn quickly how to get the most basic extensions to work almost instantly. After that, you'll learn about Zend's advanced API functionality. The alternative would have been to try to impart the functionality, design, tips, tricks, etc. as a whole, all at once, thus giving a complete look at the big picture before doing anything practical. Although this is the "better" method, as no dirty hacks have to be made, it can be very frustrating as well as energy- and time-consuming, which is why we've decided on the direct approach.

Note that even though this chapter tries to impart as much knowledge as possible about the inner workings of PHP, it's impossible to really give a complete guide to extending PHP that works 100% of the time in all cases. PHP is such a huge and complex package that its inner workings can only be understood if you make yourself familiar with it by practicing, so we encourage you to work with the source.

What Is Zend? and What Is PHP?

The name Zend refers to the language engine, PHP's core. The term PHP refers to the complete system as it appears from the outside. This might sound a bit confusing at first, but it's not that complicated (see 그림 24-1). To implement a Web script interpreter, you need three parts:

  1. The interpreter part analyzes the input code, translates it, and executes it.

  2. The functionality part implements the functionality of the language (its functions, etc.).

  3. The interface part talks to the Web server, etc.

Zend takes part 1 completely and a bit of part 2; PHP takes parts 2 and 3. Together they form the complete PHP package. Zend itself really forms only the language core, implementing PHP at its very basics with some predefined functions. PHP contains all the modules that actually create the language's outstanding capabilities.

그림 24-1. The internal structure of PHP.

The following sections discuss where PHP can be extended and how it's done.

이전 | 처음으로 | 다음
Zend API | 위로 | Extension Possibilities


Extension Possibilities

PHP 매뉴얼
이전 다음

25. 장. Extension Possibilities

차례
External Modules
Built-in Modules
The Zend Engine

As shown in 그림 24-1 above, PHP can be extended primarily at three points: external modules, built-in modules, and the Zend engine. The following sections discuss these options.

External Modules

External modules can be loaded at script runtime using the function dl(). This function loads a shared object from disk and makes its functionality available to the script to which it's being bound. After the script is terminated, the external module is discarded from memory. This method has both advantages and disadvantages, as described in the following table:

Advantages | Disadvantages
External modules don't require recompiling of PHP. | The shared objects need to be loaded every time a script is being executed (every hit), which is very slow.
The size of PHP remains small by "outsourcing" certain functionality. | External additional files clutter up the disk.
 | Every script that wants to use an external module's functionality has to specifically include a call to dl(), or the extension tag in php.ini needs to be modified (which is not always a suitable solution).

To sum up, external modules are great for third-party products, small additions to PHP that are rarely used, or just for testing purposes. To develop additional functionality quickly, external modules provide the best results. For frequent usage, larger implementations, and complex code, the disadvantages outweigh the advantages.

Third parties might consider using the extension tag in php.ini to create additional external modules to PHP. These external modules are completely detached from the main package, which is a very handy feature in commercial environments. Commercial distributors can simply ship disks or archives containing only their additional modules, without the need to create fixed and solid PHP binaries that don't allow other modules to be bound to them.

이전 | 처음으로 | 다음
Overview | 위로 | Built-in Modules


Built-in Modules

Built-in modules are compiled directly into PHP and carried around with every PHP process; their functionality is instantly available to every script that's being run. Like external modules, built-in modules have advantages and disadvantages, as described in the following table:

Advantages | Disadvantages
No need to load the module specifically; the functionality is instantly available. | Changes to built-in modules require recompiling of PHP.
No external files clutter up the disk; everything resides in the PHP binary. | The PHP binary grows and consumes more memory.

Built-in modules are best when you have a solid library of functions that remains relatively unchanged, requires better than poor-to-average performance, or is used frequently by many scripts on your site. The need to recompile PHP is quickly compensated by the benefit in speed and ease of use. However, built-in modules are not ideal when rapid development of small additions is required.

이전 | 처음으로 | 다음
Extension Possibilities | 위로 | The Zend Engine


The Zend Engine

Of course, extensions can also be implemented directly in the Zend engine. This strategy is good if you need a change in the language behavior or require special functions to be built directly into the language core. In general, however, modifications to the Zend engine should be avoided. Changes here result in incompatibilities with the rest of the world, and hardly anyone will ever adapt to specially patched Zend engines. Modifications can't be detached from the main PHP sources and are overridden with the next update using the "official" source repositories. Therefore, this method is generally considered bad practice and, due to its rarity, is not covered in this book.

이전 | 처음으로 | 다음
Built-in Modules | 위로 | Source Layout


Source Layout

PHP 매뉴얼
이전 다음

26. 장. Source Layout

차례
Extension Conventions
Macros
Memory Management
Directory and File Functions
String Handling
Complex Types

참고: Prior to working through the rest of this chapter, you should retrieve clean, unmodified source trees of your favorite Web server. We're working with Apache (available at http://www.apache.org/) and, of course, with PHP (available at http://www.php.net/ - does it need to be said?).

Make sure that you can compile a working PHP environment by yourself! We won't go into this issue here, however, as you should already have this most basic ability when studying this chapter.

Before we start discussing code issues, you should familiarize yourself with the source tree to be able to quickly navigate through PHP's files. This is a must-have ability to implement and debug extensions.

The following table describes the contents of the major directories.

Directory | Contents
php4 | Main PHP source files and main header files; here you'll find all of PHP's API definitions, macros, etc. (important). Everything else is below this directory.
php4/ext | Repository for dynamic and built-in modules; by default, these are the "official" PHP modules that have been integrated into the main source tree. From PHP 4.0, it's possible to compile these standard extensions as dynamic loadable modules (at least, those that support it).
php4/main | This directory contains the main php macros and definitions. (important)
php4/pear | Directory for the PHP Extension and Application Repository. This directory contains core PEAR files.
php4/sapi | Contains the code for the different server abstraction layers.
php4/TSRM | Location of the "Thread Safe Resource Manager" (TSRM) for Zend and PHP.
php4/Zend | Location of the Zend Engine files; here you'll find all of Zend's API definitions, macros, etc. (important).

Discussing all the files included in the PHP package is beyond the scope of this chapter. However, you should take a close look at the following files:

  • php4/main/php.h, located in the main PHP directory. This file contains most of PHP's macro and API definitions.

  • php4/Zend/zend.h, located in the main Zend directory. This file contains most of Zend's macros and definitions.

  • php4/Zend/zend_API.h, also located in the Zend directory, which defines Zend's API.

You should also follow some sub-inclusions from these files; for example, the ones relating to the Zend executor, the PHP initialization file support, and such. After reading these files, take the time to navigate around the package a little to see the interdependencies of all files and modules - how they relate to each other and especially how they make use of each other. This also helps you to adapt to the coding style in which PHP is authored. To extend PHP, you should quickly adapt to this style.

Extension Conventions

Zend is built using certain conventions; to avoid breaking its standards, you should follow the rules described in the following sections.

이전 | 처음으로 | 다음
The Zend Engine | 위로 | Macros


Macros

For almost every important task, Zend ships predefined macros that are extremely handy. The tables and figures in the following sections describe most of the basic functions, structures, and macros. The macro definitions can be found mainly in zend.h and zend_API.h. We suggest that you take a close look at these files after having studied this chapter. (Although you can go ahead and read them now, not everything will make sense to you yet.)

이전 | 처음으로 | 다음
Source Layout | 위로 | Memory Management


Memory Management

Resource management is a crucial issue, especially in server software. One of the most valuable resources is memory, and memory management should be handled with extreme care. Memory management has been partially abstracted in Zend, and you should stick to this abstraction for obvious reasons: Due to the abstraction, Zend gets full control over all memory allocations. Zend is able to determine whether a block is in use, automatically freeing unused blocks and blocks with lost references, and thus prevent memory leaks. The functions to be used are described in the following table:

Function | Description
emalloc() | Serves as replacement for malloc().
efree() | Serves as replacement for free().
estrdup() | Serves as replacement for strdup().
estrndup() | Serves as replacement for strndup(). Faster than estrdup() and binary-safe. This is the recommended function to use if you know the string length prior to duplicating it.
ecalloc() | Serves as replacement for calloc().
erealloc() | Serves as replacement for realloc().

emalloc(), estrdup(), estrndup(), ecalloc(), and erealloc() allocate internal memory; efree() frees these previously allocated blocks. Memory handled by the e*() functions is considered local to the current process and is discarded as soon as the script executed by this process is terminated.

주의

To allocate resident memory that survives termination of the current script, you can use malloc() and free(). This should only be done with extreme care, however, and only in conjunction with demands of the Zend API; otherwise, you risk memory leaks.

Zend also features a thread-safe resource manager to provide better native support for multithreaded Web servers. This requires you to allocate local structures for all of your global variables to allow concurrent threads to be run. Because the thread-safe mode of Zend was not finished back when this was written, it is not yet extensively covered here.

이전 | 처음으로 | 다음
Macros | 위로 | Directory and File Functions


Directory and File Functions

The following directory and file functions should be used in Zend modules. They behave exactly like their C counterparts, but provide virtual working directory support on the thread level.

Zend Function | Regular C Function
V_GETCWD() | getcwd()
V_FOPEN() | fopen()
V_OPEN() | open()
V_CHDIR() | chdir()
V_GETWD() | getwd()
V_CHDIR_FILE() | Takes a file path as an argument and changes the current working directory to that file's directory.
V_STAT() | stat()
V_LSTAT() | lstat()

이전 | 처음으로 | 다음
Memory Management | 위로 | String Handling


String Handling

Strings are handled a bit differently by the Zend engine than other values such as integers, Booleans, etc., which don't require additional memory allocation for storing their values. If you want to return a string from a function, introduce a new string variable to the symbol table, or do something similar, you have to make sure that the memory the string will be occupying has previously been allocated, using the aforementioned e*() functions for allocation. (This might not make much sense to you yet; just keep it somewhere in your head for now - we'll get back to it shortly.)

이전 | 처음으로 | 다음
Directory and File Functions | 위로 | Complex Types


Complex Types

Complex types such as arrays and objects require different treatment. Zend features a single API for these types - they're stored using hash tables.

참고: To reduce complexity in the following source examples, we're only working with simple types such as integers at first. A discussion about creating more advanced types follows later in this chapter.

이전 | 처음으로 | 다음
String Handling | 위로 | PHP's Automatic Build System


PHP's Automatic Build System

PHP 매뉴얼
이전 다음

27. 장. PHP's Automatic Build System

PHP 4 features an automatic build system that's very flexible. All modules reside in a subdirectory of the ext directory. In addition to its own sources, each module consists of a config.m4 file, for extension configuration. (for example, see http://www.gnu.org/manual/m4/html_mono/m4.html)

All these stub files are generated automatically, along with .cvsignore, by a little shell script named ext_skel that resides in the ext directory. As argument it takes the name of the module that you want to create. The shell script then creates a directory of the same name, along with the appropriate stub files.

Step by step, the process looks like this:
:~/cvs/php4/ext:> ./ext_skel --extname=my_module
Creating directory my_module
Creating basic files: config.m4 .cvsignore my_module.c php_my_module.h CREDITS EXPERIMENTAL tests/001.phpt my_module.php [done].

To use your new extension, you will have to execute the following steps:

1.  $ cd ..
2.  $ vi ext/my_module/config.m4
3.  $ ./buildconf
4.  $ ./configure --[with|enable]-my_module
5.  $ make
6.  $ ./php -f ext/my_module/my_module.php
7.  $ vi ext/my_module/my_module.c
8.  $ make

Repeat steps 3-6 until you are satisfied with ext/my_module/config.m4 and
step 6 confirms that your module is compiled into PHP. Then, start writing
code and repeat the last two steps as often as necessary.
This instruction creates the aforementioned files. To include the new module in the automatic configuration and build process, you have to run buildconf, which regenerates the configure script by searching through the ext directory and including all found config.m4 files.

The default config.m4 shown in 예 27-1 is a bit more complex:

예 27-1. The default config.m4.

dnl $Id: Extending_Zend_Build.xml,v 1.8 2002/10/10 18:13:11 imajes Exp $
dnl config.m4 for extension my_module

dnl Comments in this file start with the string 'dnl'.
dnl Remove where necessary. This file will not work
dnl without editing.

dnl If your extension references something external, use with:

dnl PHP_ARG_WITH(my_module, for my_module support,
dnl Make sure that the comment is aligned:
dnl [  --with-my_module             Include my_module support])

dnl Otherwise use enable:

dnl PHP_ARG_ENABLE(my_module, whether to enable my_module support,
dnl Make sure that the comment is aligned:
dnl [  --enable-my_module           Enable my_module support])

if test "$PHP_MY_MODULE" != "no"; then
  dnl Write more examples of tests here...

  dnl # --with-my_module -> check with-path
  dnl SEARCH_PATH="/usr/local /usr"     # you might want to change this
  dnl SEARCH_FOR="/include/my_module.h"  # you most likely want to change this
  dnl if test -r $PHP_MY_MODULE/; then # path given as parameter
  dnl   MY_MODULE_DIR=$PHP_MY_MODULE
  dnl else # search default path list
  dnl   AC_MSG_CHECKING([for my_module files in default path])
  dnl   for i in $SEARCH_PATH ; do
  dnl     if test -r $i/$SEARCH_FOR; then
  dnl       MY_MODULE_DIR=$i
  dnl       AC_MSG_RESULT(found in $i)
  dnl     fi
  dnl   done
  dnl fi
  dnl
  dnl if test -z "$MY_MODULE_DIR"; then
  dnl   AC_MSG_RESULT([not found])
  dnl   AC_MSG_ERROR([Please reinstall the my_module distribution])
  dnl fi

  dnl # --with-my_module -> add include path
  dnl PHP_ADD_INCLUDE($MY_MODULE_DIR/include)

  dnl # --with-my_module -> chech for lib and symbol presence
  dnl LIBNAME=my_module # you may want to change this
  dnl LIBSYMBOL=my_module # you most likely want to change this

  dnl PHP_CHECK_LIBRARY($LIBNAME,$LIBSYMBOL,
  dnl [
  dnl   PHP_ADD_LIBRARY_WITH_PATH($LIBNAME, $MY_MODULE_DIR/lib, MY_MODULE_SHARED_LIBADD)
  dnl   AC_DEFINE(HAVE_MY_MODULELIB,1,[ ])
  dnl ],[
  dnl   AC_MSG_ERROR([wrong my_module lib version or lib not found])
  dnl ],[
  dnl   -L$MY_MODULE_DIR/lib -lm -ldl
  dnl ])
  dnl
  dnl PHP_SUBST(MY_MODULE_SHARED_LIBADD)

  PHP_NEW_EXTENSION(my_module, my_module.c, $ext_shared)
fi

If you're unfamiliar with M4 files (now is certainly a good time to get familiar), this might be a bit confusing at first; but it's actually quite easy.

Note: Everything prefixed with dnl is treated as a comment and is not parsed.

The config.m4 file is responsible for parsing the command-line options passed to configure at configuration time. This means that it has to check for required external files and do similar configuration and setup tasks.

The default file creates two configuration directives in the configure script: --with-my_module and --enable-my_module. Use the first option when referring external files (such as the --with-apache directive that refers to the Apache directory). Use the second option when the user simply has to decide whether to enable your extension. Regardless of which option you use, you should uncomment the other, unnecessary one; that is, if you're using --enable-my_module, you should remove support for --with-my_module, and vice versa.

By default, the config.m4 file created by ext_skel accepts both directives and automatically enables your extension. Enabling the extension is done by using the PHP_EXTENSION macro. To change the default behavior to include your module into the PHP binary when desired by the user (by explicitly specifying --enable-my_module or --with-my_module), change the test for $PHP_MY_MODULE to == "yes":
if test "$PHP_MY_MODULE" == "yes"; then dnl
    Action.. PHP_EXTENSION(my_module, $ext_shared)
    fi
This would require you to use --enable-my_module each time when reconfiguring and recompiling PHP.

Note: Be sure to run buildconf every time you change config.m4!

We'll go into more details on the M4 macros available to your configuration scripts later in this chapter. For now, we'll simply use the default files.

이전 | 처음으로 | 다음
Complex Types | 위로 | Creating Extensions


Creating Extensions

PHP 매뉴얼
이전 다음

28. 장. Creating Extensions

차례
Compiling Modules

We'll start with the creation of a very simple extension at first, which basically does nothing more than implement a function that returns the integer it receives as parameter. 예 28-1 shows the source.

예 28-1. A simple extension.

/* include standard header */
#include "php.h"

/* declaration of functions to be exported */
ZEND_FUNCTION(first_module);

/* compiled function list so Zend knows what's in this module */
zend_function_entry firstmod_functions[] =
{
    ZEND_FE(first_module, NULL)
    {NULL, NULL, NULL}
};

/* compiled module information */
zend_module_entry firstmod_module_entry =
{
    STANDARD_MODULE_HEADER,
    "First Module",
    firstmod_functions,
    NULL,
    NULL,
    NULL,
    NULL,
    NULL,
    NO_VERSION_YET,
    STANDARD_MODULE_PROPERTIES
};

/* implement standard "stub" routine to introduce ourselves to Zend */
#if COMPILE_DL_FIRST_MODULE
ZEND_GET_MODULE(firstmod)
#endif

/* implement function that is meant to be made available to PHP */
ZEND_FUNCTION(first_module)
{
    long parameter;

    if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "l", &parameter) == FAILURE) {
        return;
    }

    RETURN_LONG(parameter);
}

This code contains a complete PHP module. We'll explain the source code in detail shortly, but first we'd like to discuss the build process. (This will allow the impatient to experiment before we dive into API discussions.)

참고: The example source makes use of some features introduced with the Zend version used in PHP 4.1.0 and above, it won't compile with older PHP 4.0.x versions.

Compiling Modules

There are basically two ways to compile modules:

  • Use the provided "make" mechanism in the ext directory, which also allows building of dynamic loadable modules.

  • Compile the sources manually.

The first method should definitely be favored, since, as of PHP 4.0, this has been standardized into a sophisticated build process. The fact that it is so sophisticated is also its drawback, unfortunately - it's hard to understand at first. We'll provide a more detailed introduction to this later in the chapter, but first let's work with the default files.

The second method is good for those who (for some reason) don't have the full PHP source tree available, don't have access to all files, or just like to juggle with their keyboard. These cases should be extremely rare, but for the sake of completeness we'll also describe this method.

Compiling Using Make. To compile the sample sources using the standard mechanism, copy all their subdirectories to the ext directory of your PHP source tree. Then run buildconf, which will create an updated configure script containing appropriate options for the new extension. By default, all the sample sources are disabled, so you don't have to fear breaking your build process.

After you run buildconf, configure --help shows the following additional modules:

--enable-array_experiments   BOOK: Enables array experiments
  --enable-call_userland       BOOK: Enables userland module
  --enable-cross_conversion    BOOK: Enables cross-conversion module
  --enable-first_module        BOOK: Enables first module
  --enable-infoprint           BOOK: Enables infoprint module
  --enable-reference_test      BOOK: Enables reference test module
  --enable-resource_test       BOOK: Enables resource test module
  --enable-variable_creation   BOOK: Enables variable-creation module

The module shown earlier in 예 28-1 can be enabled with --enable-first_module or --enable-first_module=yes.

Compiling Manually. To compile your modules manually, you need the following commands:

Action | Command
Compiling | cc -fpic -DCOMPILE_DL=1 -I/usr/local/include -I. -I.. -I../Zend -c -o <your_object_file> <your_c_file>
Linking | cc -shared -L/usr/local/lib -rdynamic -o <your_module_file> <your_object_file(s)>

The command to compile the module simply instructs the compiler to generate position-independent code (-fpic shouldn't be omitted) and additionally defines the constant COMPILE_DL to tell the module code that it's compiled as a dynamically loadable module (the test module above checks for this; we'll discuss it shortly). After these options, it specifies a number of standard include paths that should be used as the minimal set to compile the source files.

Note: All include paths in the example are relative to the directory ext. If you're compiling from another directory, change the pathnames accordingly. Required items are the PHP directory, the Zend directory, and (if necessary), the directory in which your module resides.

The link command is also a plain vanilla command instructing linkage as a dynamic module.

You can include optimization options in the compilation command, although these have been omitted in this example (but some are included in the makefile template described in an earlier section).

Note: Compiling and linking manually as a static module into the PHP binary involves very long instructions and thus is not discussed here. (It's not very efficient to type all those commands.)

이전 | 처음으로 | 다음
PHP's Automatic Build System | 위로 | Using Extensions


Using Extensions

PHP 매뉴얼
이전 다음

29. 장. Using Extensions

Depending on the build process you selected, you should either end up with a new PHP binary to be linked into your Web server (or run as CGI), or with an .so (shared object) file. If you compiled the example file first_module.c as a shared object, your result file should be first_module.so. To use it, you first have to copy it to a place from which it's accessible to PHP. For a simple test procedure, you can copy it to your htdocs directory and try it with the source in 예 29-1. If you compiled it into the PHP binary, omit the call to dl(), as the module's functionality is instantly available to your scripts.

주의

For security reasons, you should not put your dynamic modules into publicly accessible directories. Even though it can be done and it simplifies testing, you should put them into a separate directory in production environments.

예 29-1. A test file for first_module.so.

<?php

// remove next comment if necessary
// dl("first_module.so");

$param = 2;
$return = first_module($param);

print("We sent '$param' and got '$return'");

?>

Calling this PHP file in your Web browser should give you the output shown in 그림 29-1.

그림 29-1. Output of first_module.php.

If required, the dynamic loadable module is loaded by calling the dl() function. This function looks for the specified shared object, loads it, and makes its functions available to PHP. The module exports the function first_module(), which accepts a single parameter, converts it to an integer, and returns the result of the conversion.

If you've gotten this far, congratulations! You just built your first extension to PHP.

이전 | 처음으로 | 다음
Creating Extensions | 위로 | Troubleshooting


Troubleshooting

PHP 매뉴얼
이전 다음

30. 장. Troubleshooting

Actually, not much troubleshooting can be done when compiling static or dynamic modules. The only problem that could arise is that the compiler will complain about missing definitions or something similar. In this case, make sure that all header files are available and that you specified their path correctly in the compilation command. To be sure that everything is located correctly, extract a clean PHP source tree and use the automatic build in the ext directory with the fresh files; this will guarantee a safe compilation environment. If this fails, try manual compilation.

PHP might also complain about missing functions in your module. (This shouldn't happen with the sample sources if you didn't modify them.) If the names of external functions you're trying to access from your module are misspelled, they'll remain as "unlinked symbols" in the symbol table. During dynamic loading and linkage by PHP, they won't resolve because of the typing errors - there are no corresponding symbols in the main binary. Look for incorrect declarations in your module file or incorrectly written external references. Note that this problem is specific to dynamic loadable modules; it doesn't occur with static modules. Errors in static modules show up at compile time.

이전 | 처음으로 | 다음
Using Extensions | 위로 | Source Discussion


Source Discussion

PHP 매뉴얼
이전 다음

31. 장. Source Discussion

차례
Module Structure
Header File Inclusions
Declaring Exported Functions
Declaration of the Zend Function Block
Declaration of the Zend Module Block
Creation of get_module()
Implementation of All Exported Functions
Summary

Now that you've got a safe build environment and you're able to include the modules into PHP files, it's time to discuss how everything works.

Module Structure

All PHP modules follow a common structure:

  • Header file inclusions (to include all required macros, API definitions, etc.)

  • C declaration of exported functions (required to declare the Zend function block)

  • Declaration of the Zend function block

  • Declaration of the Zend module block

  • Implementation of get_module()

  • Implementation of all exported functions

이전 | 처음으로 | 다음
Troubleshooting | 위로 | Header File Inclusions


Header File Inclusions

The only header file you really have to include for your modules is php.h, located in the PHP directory. This file makes all macros and API definitions required to build new modules available to your code.

Tip: It's good practice to create a separate header file for your module that contains module-specific definitions. This header file should contain all the forward definitions for exported functions and include php.h. If you created your module using ext_skel you already have such a header file prepared.

이전 | 처음으로 | 다음
Source Discussion | 위로 | Declaring Exported Functions


Declaring Exported Functions

To declare functions that are to be exported (i.e., made available to PHP as new native functions), Zend provides a set of macros. A sample declaration looks like this:
ZEND_FUNCTION ( my_function );

ZEND_FUNCTION declares a new C function that complies with Zend's internal API. This means that the function is of type void and accepts INTERNAL_FUNCTION_PARAMETERS (another macro) as parameters. Additionally, it prefixes the function name with zif. The immediately expanded version of the above definitions would look like this:
void zif_my_function ( INTERNAL_FUNCTION_PARAMETERS );
Expanding INTERNAL_FUNCTION_PARAMETERS results in the following:
void zif_my_function( int ht
                    , zval * return_value
                    , zval * this_ptr
                    , int return_value_used
                    , zend_executor_globals * executor_globals
                    );

Since the interpreter and executor core have been separated from the main PHP package, a second API defining macros and function sets has evolved: the Zend API. As the Zend API now handles quite a few of the responsibilities that previously belonged to PHP, a lot of PHP functions have been reduced to macros aliasing to calls into the Zend API. The recommended practice is to use the Zend API wherever possible, as the old API is only preserved for compatibility reasons. For example, the types zval and pval are identical. zval is Zend's definition; pval is PHP's definition (actually, pval is an alias for zval now). As the macro INTERNAL_FUNCTION_PARAMETERS is a Zend macro, the above declaration contains zval. When writing code, you should always use zval to conform to the new Zend API.

The parameter list of this declaration is very important; you should keep these parameters in mind (see 표 31-1 for descriptions).

표 31-1. Zend's Parameters to Functions Called from PHP

Parameter | Description
ht | The number of arguments passed to the Zend function. You should not touch this directly, but instead use ZEND_NUM_ARGS() to obtain the value.
return_value | This variable is used to pass any return values of your function back to PHP. Access to this variable is best done using the predefined macros. For a description of these see below.
this_ptr | Using this variable, you can gain access to the object in which your function is contained, if it's used within an object. Use the function getThis() to obtain this pointer.
return_value_used | This flag indicates whether an eventual return value from this function will actually be used by the calling script. 0 indicates that the return value is not used; 1 indicates that the caller expects a return value. Evaluation of this flag can be done to verify correct usage of the function as well as speed optimizations in case returning a value requires expensive operations (for an example, see how array.c makes use of this).
executor_globals | This variable points to global settings of the Zend engine. You'll find this useful when creating new variables, for example (more about this later). The executor globals can also be introduced to your function by using the macro TSRMLS_FETCH().

이전 | 처음으로 | 다음
Header File Inclusions | 위로 | Declaration of the Zend Function Block


Declaration of the Zend Function Block

Now that you have declared the functions to be exported, you also have to introduce them to Zend. Introducing the list of functions is done by using an array of zend_function_entry. This array consecutively contains all functions that are to be made available externally, with the function's name as it should appear in PHP and its name as defined in the C source. Internally, zend_function_entry is defined as shown in 예 31-1.

예 31-1. Internal declaration of zend_function_entry.

typedef struct _zend_function_entry {
    char *fname;
    void (*handler)(INTERNAL_FUNCTION_PARAMETERS);
    unsigned char *func_arg_types;
} zend_function_entry;

Entry | Description
fname | Denotes the function name as seen in PHP (for example, fopen, mysql_connect, or, in our example, first_module).
handler | Pointer to the C function responsible for handling calls to this function. For example, see the standard macro INTERNAL_FUNCTION_PARAMETERS discussed earlier.
func_arg_types | Allows you to mark certain parameters so that they're forced to be passed by reference. You usually should set this to NULL.

In the example above, the declaration looks like this:
zend_function_entry firstmod_functions[] =
{
    ZEND_FE(first_module, NULL)
    {NULL, NULL, NULL}
};
You can see that the last entry in the list always has to be {NULL, NULL, NULL}. This marker has to be set for Zend to know when the end of the list of exported functions is reached.

참고: You cannot use the predefined macros for the end marker, as these would try to refer to a function named "NULL"!

The macro ZEND_FE (short for 'Zend Function Entry') simply expands to a structure entry in zend_function_entry. Note that these macros introduce a special naming scheme to your functions - your C functions will be prefixed with zif_, meaning that ZEND_FE(first_module) will refer to a C function zif_first_module(). If you want to mix macro usage with hand-coded entries (not a good practice), keep this in mind.

Tip: Compilation errors that refer to functions named zif_*() relate to functions defined with ZEND_FE.

표 31-2 shows a list of all the macros that you can use to define functions.

표 31-2. Macros for Defining Functions

Macro Name | Description
ZEND_FE(name, arg_types) | Defines a function entry of the name name in zend_function_entry. Requires a corresponding C function. arg_types needs to be set to NULL. This function uses automatic C function name generation by prefixing the PHP function name with zif_. For example, ZEND_FE("first_module", NULL) introduces a function first_module() to PHP and links it to the C function zif_first_module(). Use in conjunction with ZEND_FUNCTION.
ZEND_NAMED_FE(php_name, name, arg_types) | Defines a function that will be available to PHP by the name php_name and links it to the corresponding C function name. arg_types needs to be set to NULL. Use this function if you don't want the automatic name prefixing introduced by ZEND_FE. Use in conjunction with ZEND_NAMED_FUNCTION.
ZEND_FALIAS(name, alias, arg_types) | Defines an alias named alias for name. arg_types needs to be set to NULL. Doesn't require a corresponding C function; refers to the alias target instead.
PHP_FE(name, arg_types) | Old PHP API equivalent of ZEND_FE.
PHP_NAMED_FE(runtime_name, name, arg_types) | Old PHP API equivalent of ZEND_NAMED_FE.

Note: You can't use ZEND_FE in conjunction with PHP_FUNCTION, or PHP_FE in conjunction with ZEND_FUNCTION. However, it's perfectly legal to mix ZEND_FE and ZEND_FUNCTION with PHP_FE and PHP_FUNCTION when staying with the same macro set for each function to be declared. But mixing is not recommended; instead, you're advised to use the ZEND_* macros only.

이전 | 처음으로 | 다음
Declaring Exported Functions | 위로 | Declaration of the Zend Module Block


Declaration of the Zend Module Block

This block is stored in the structure zend_module_entry and contains all necessary information to describe the contents of this module to Zend. You can see the internal definition of this module in 예 31-2.

예 31-2. Internal declaration of zend_module_entry.

typedef struct _zend_module_entry zend_module_entry;

    struct _zend_module_entry {
    unsigned short size;
    unsigned int zend_api;
    unsigned char zend_debug;
    unsigned char zts;
    char *name;
    zend_function_entry *functions;
    int (*module_startup_func)(INIT_FUNC_ARGS);
    int (*module_shutdown_func)(SHUTDOWN_FUNC_ARGS);
    int (*request_startup_func)(INIT_FUNC_ARGS);
    int (*request_shutdown_func)(SHUTDOWN_FUNC_ARGS);
    void (*info_func)(ZEND_MODULE_INFO_FUNC_ARGS);
    char *version;

[ Rest of the structure is not interesting here ]

};

Entry | Description
size, zend_api, zend_debug and zts | Usually filled with the "STANDARD_MODULE_HEADER", which fills these four members with the size of the whole zend_module_entry, the ZEND_MODULE_API_NO, whether it is a debug build or normal build (ZEND_DEBUG) and if ZTS is enabled (USING_ZTS).
name | Contains the module name (for example, "File functions", "Socket functions", "Crypt", etc.). This name will show up in phpinfo(), in the section "Additional Modules."
functions | Points to the Zend function block, discussed in the preceding section.
module_startup_func | This function is called once upon module initialization and can be used to do one-time initialization steps (such as initial memory allocation, etc.). To indicate a failure during initialization, return FAILURE; otherwise, SUCCESS. To mark this field as unused, use NULL. To declare a function, use the macro ZEND_MINIT.
module_shutdown_func | This function is called once upon module shutdown and can be used to do one-time deinitialization steps (such as memory deallocation). This is the counterpart to module_startup_func(). To indicate a failure during deinitialization, return FAILURE; otherwise, SUCCESS. To mark this field as unused, use NULL. To declare a function, use the macro ZEND_MSHUTDOWN.
request_startup_func | This function is called once upon every page request and can be used to do one-time initialization steps that are required to process a request. To indicate a failure here, return FAILURE; otherwise, SUCCESS. Note: As dynamic loadable modules are loaded only on page requests, the request startup function is called right after the module startup function (both initialization events happen at the same time). To mark this field as unused, use NULL. To declare a function, use the macro ZEND_RINIT.
request_shutdown_func | This function is called once after every page request and works as counterpart to request_startup_func(). To indicate a failure here, return FAILURE; otherwise, SUCCESS. Note: As dynamic loadable modules are loaded only on page requests, the request shutdown function is immediately followed by a call to the module shutdown handler (both deinitialization events happen at the same time). To mark this field as unused, use NULL. To declare a function, use the macro ZEND_RSHUTDOWN.
info_func | When phpinfo() is called in a script, Zend cycles through all loaded modules and calls this function. Every module then has the chance to print its own "footprint" into the output page. Generally this is used to dump environmental or statistical information. To mark this field as unused, use NULL. To declare a function, use the macro ZEND_MINFO.
version | The version of the module. You can use NO_VERSION_YET if you don't want to give the module a version number yet, but we really recommend that you add a version string here. Such a version string can look like this (in chronological order): "2.5-dev", "2.5RC1", "2.5" or "2.5pl3".
Remaining structure elements | These are used internally and can be prefilled by using the macro STANDARD_MODULE_PROPERTIES_EX. You should not assign any values to them. Use STANDARD_MODULE_PROPERTIES_EX only if you use global startup and shutdown functions; otherwise, use STANDARD_MODULE_PROPERTIES directly.

In our example, this structure is implemented as follows:
zend_module_entry firstmod_module_entry =
{
    STANDARD_MODULE_HEADER,
    "First Module",
    firstmod_functions,
    NULL, NULL, NULL, NULL, NULL,
    NO_VERSION_YET,
    STANDARD_MODULE_PROPERTIES,
};
This is basically the easiest and most minimal set of values you could ever use. The module name is set to First Module, then the function list is referenced, after which all startup and shutdown functions are marked as being unused.

For reference purposes, you can find a list of the macros involved in declared startup and shutdown functions in 표 31-3. These are not used in our basic example yet, but will be demonstrated later on. You should make use of these macros to declare your startup and shutdown functions, as these require special arguments to be passed (INIT_FUNC_ARGS and SHUTDOWN_FUNC_ARGS), which are automatically included into the function declaration when using the predefined macros. If you declare your functions manually and the PHP developers decide that a change in the argument list is necessary, you'll have to change your module sources to remain compatible.

표 31-3. Macros to Declare Startup and Shutdown Functions

Macro | Description
ZEND_MINIT(module) | Declares a function for module startup. The generated name will be zend_minit_<module> (for example, zend_minit_first_module). Use in conjunction with ZEND_MINIT_FUNCTION.
ZEND_MSHUTDOWN(module) | Declares a function for module shutdown. The generated name will be zend_mshutdown_<module> (for example, zend_mshutdown_first_module). Use in conjunction with ZEND_MSHUTDOWN_FUNCTION.
ZEND_RINIT(module) | Declares a function for request startup. The generated name will be zend_rinit_<module> (for example, zend_rinit_first_module). Use in conjunction with ZEND_RINIT_FUNCTION.
ZEND_RSHUTDOWN(module) | Declares a function for request shutdown. The generated name will be zend_rshutdown_<module> (for example, zend_rshutdown_first_module). Use in conjunction with ZEND_RSHUTDOWN_FUNCTION.
ZEND_MINFO(module) | Declares a function for printing module information, used when phpinfo() is called. The generated name will be zend_info_<module> (for example, zend_info_first_module). Use in conjunction with ZEND_MINFO_FUNCTION.

이전 | 처음으로 | 다음
Declaration of the Zend Function Block | 위로 | Creation of get_module()


Implementation of All Exported Functions

Implementing the exported functions is the final step. The example function in first_module looks like this:
ZEND_FUNCTION(first_module)
{
    long parameter;

    if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "l", &parameter) == FAILURE) {
        return;
    }

    RETURN_LONG(parameter);
}
The function declaration is done using ZEND_FUNCTION, which corresponds to ZEND_FE in the function entry table (discussed earlier).

After the declaration, code for checking and retrieving the function's arguments, argument conversion, and return value generation follows (more on this later).

이전 | 처음으로 | 다음
Creation of get_module() | 위로 | Summary


Summary

That's it, basically - there's nothing more to implementing PHP modules. Built-in modules are structured similarly to dynamic modules, so, equipped with the information presented in the previous sections, you'll be able to fight the odds when encountering PHP module source files.

Now, in the following sections, read on about how to make use of PHP's internals to build powerful extensions.

이전 | 처음으로 | 다음
Implementation of All Exported Functions | 위로 | Accepting Arguments


Accepting Arguments

PHP 매뉴얼
이전 다음

32. 장. Accepting Arguments

차례
Determining the Number of Arguments
Retrieving Arguments
Old way of retrieving arguments (deprecated)
Dealing with a Variable Number of Arguments/Optional Parameters
Accessing Arguments
Dealing with Arguments Passed by Reference
Assuring Write Safety for Other Parameters

One of the most important issues for language extensions is accepting and dealing with data passed via arguments. Most extensions are built to deal with specific input data (or require parameters to perform their specific actions), and function arguments are the only real way to exchange data between the PHP level and the C level. Of course, there's also the possibility of exchanging data using predefined global values (which is also discussed later), but this should be avoided by all means, as it's extremely bad practice.

PHP doesn't make use of any formal function declarations; this is why call syntax is always completely dynamic and never checked for errors. Checking for correct call syntax is left to the user code. For example, it's possible to call a function using only one argument at one time and four arguments the next time - both invocations are syntactically absolutely correct.

Determining the Number of Arguments

Since PHP doesn't have formal function definitions with support for call syntax checking, and since PHP features variable arguments, sometimes you need to find out with how many arguments your function has been called. You can use the ZEND_NUM_ARGS macro in this case. In previous versions of PHP, this macro retrieved the number of arguments with which the function has been called based on the function's hash table entry, ht, which is passed in the INTERNAL_FUNCTION_PARAMETERS list. As ht itself now contains the number of arguments that have been passed to the function, ZEND_NUM_ARGS has been stripped down to a dummy macro (see its definition in zend_API.h). But it's still good practice to use it, to remain compatible with future changes in the call interface. Note: The old PHP equivalent of this macro is ARG_COUNT.

The following code checks for the correct number of arguments:
if(ZEND_NUM_ARGS() != 2) WRONG_PARAM_COUNT;
If the function is not called with two arguments, it exits with an error message. The code snippet above makes use of the tool macro WRONG_PARAM_COUNT, which can be used to generate a standard error message (see 그림 32-1).

그림 32-1. WRONG_PARAM_COUNT in action.

This macro prints a default error message and then returns to the caller. Its definition can also be found in zend_API.h and looks like this:
ZEND_API void wrong_param_count(void);

#define WRONG_PARAM_COUNT { wrong_param_count(); return; }
As you can see, it calls an internal function named wrong_param_count() that's responsible for printing the warning. For details on generating customized error messages, see the later section "Printing Information."

이전 | 처음으로 | 다음
Summary | 위로 | Retrieving Arguments


Retrieving Arguments

New parameter parsing API: This chapter documents the new Zend parameter parsing API introduced by Andrei Zmievski. It was introduced in the development stage between PHP 4.0.6 and 4.1.0 .

Parsing parameters is a very common operation and it may get a bit tedious. It would also be nice to have standardized error checking and error messages. Since PHP 4.1.0, there is a way to do just that by using the new parameter parsing API. It greatly simplifies the process of receiving parameteres, but it has a drawback in that it can't be used for functions that expect variable number of parameters. But since the vast majority of functions do not fall into those categories, this parsing API is recommended as the new standard way.

The prototype for parameter parsing function looks like this:
int zend_parse_parameters(int num_args TSRMLS_DC, char *type_spec, ...);
The first argument to this function is supposed to be the number of actual parameters passed to your function, so ZEND_NUM_ARGS() can be used for that. The second parameter should always be TSRMLS_CC macro. The third argument is a string that specifies the number and types of arguments your function is expecting, similar to how printf format string specifies the number and format of the output values it should operate on. And finally the rest of the arguments are pointers to variables which should receive the values from the parameters.

zend_parse_parameters() also performs type conversions whenever possible, so that you always receive the data in the format you asked for. Any type of scalar can be converted to another one, but conversions between complex types (arrays, objects, and resources) and scalar types are not allowed.

If the parameters could be obtained successfully and there were no errors during type conversion, the function will return SUCCESS, otherwise it will return FAILURE. The function will output informative error messages, if the number of received parameters does not match the requested number, or if type conversion could not be performed.

Here are some sample error messages:
Warning - ini_get_all() requires at most 1 parameter, 2 given
     Warning - wddx_deserialize() expects parameter 1 to be string, array given
Of course each error message is accompanied by the filename and line number on which it occurs.

Here is the full list of type specifiers:

  • l - long

  • d - double

  • s - string (with possible null bytes) and its length

  • b - boolean

  • r - resource, stored in zval*

  • a - array, stored in zval*

  • o - object (of any class), stored in zval*

  • O - object (of class specified by class entry), stored in zval*

  • z - the actual zval*

The following characters also have a meaning in the specifier string:

  • | - indicates that the remaining parameters are optional. The storage variables corresponding to these parameters should be initialized to default values by the extension, since they will not be touched by the parsing function if the parameters are not passed.

  • / - the parsing function will call SEPARATE_ZVAL_IF_NOT_REF() on the parameter it follows, to provide a copy of the parameter, unless it's a reference.

  • ! - the parameter it follows can be of specified type or NULL (only applies to a, o, O, r, and z). If NULL value is passed by the user, the storage pointer will be set to NULL.

The best way to illustrate the usage of this function is through examples:
/* Gets a long, a string and its length, and a zval. */
long l;
char *s;
int s_len;
zval *param;
if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC,
                          "lsz", &l, &s, &s_len, &param) == FAILURE) {
    return;
}

/* Gets an object of class specified by my_ce, and an optional double. */
zval *obj;
double d = 0.5;
if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC,
                          "O|d", &obj, my_ce, &d) == FAILURE) {
    return;
}

/* Gets an object or null, and an array.
   If null is passed for object, obj will be set to NULL. */
zval *obj;
zval *arr;
if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "O!a", &obj, &arr) == FAILURE) {
    return;
}

/* Gets a separated array. */
zval *arr;
if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "a/", &arr) == FAILURE) {
    return;
}

/* Get only the first three parameters (useful for varargs functions). */
zval *z;
zend_bool b;
zval *r;
if (zend_parse_parameters(3, "zbr!", &z, &b, &r) == FAILURE) {
    return;
}

Note that in the last example we pass 3 for the number of received parameters, instead of ZEND_NUM_ARGS(). What this lets us do is receive the least number of parameters if our function expects a variable number of them. Of course, if you want to operate on the rest of the parameters, you will have to use zend_get_parameters_array_ex() to obtain them.

The parsing function has an extended version that allows for an additional flags argument that controls its actions.
int zend_parse_parameters_ex(int flags, int num_args TSRMLS_DC, char *type_spec, ...);

The only flag you can pass currently is ZEND_PARSE_PARAMS_QUIET, which instructs the function to not output any error messages during its operation. This is useful for functions that expect several sets of completely different arguments, but you will have to output your own error messages.

For example, here is how you would get either a set of three longs or a string:
long l1, l2, l3;
char *s;
if (zend_parse_parameters_ex(ZEND_PARSE_PARAMS_QUIET,
                             ZEND_NUM_ARGS() TSRMLS_CC,
                             "lll", &l1, &l2, &l3) == SUCCESS) {
    /* manipulate longs */
} else if (zend_parse_parameters_ex(ZEND_PARSE_PARAMS_QUIET,
                                    ZEND_NUM_ARGS(), "s", &s, &s_len) == SUCCESS) {
    /* manipulate string */
} else {
    php_error(E_WARNING, "%s() takes either three long values or a string as argument",
              get_active_function_name(TSRMLS_C));
    return;
}

With all the abovementioned ways of receiving function parameters you should have a good handle on this process. For even more example, look through the source code for extensions that are shipped with PHP - they illustrate every conceivable situation.

이전 | 처음으로 | 다음
Accepting Arguments | 위로 | Old way of retrieving arguments (deprecated)


Old way of retrieving arguments (deprecated)

Deprecated parameter parsing API: This API is deprecated and superseded by the new ZEND parameter parsing API.

After having checked the number of arguments, you need to get access to the arguments themselves. This is done with the help of zend_get_parameters_ex():
zval **parameter;

if(zend_get_parameters_ex(1, &parameter) != SUCCESS)
  WRONG_PARAM_COUNT;
All arguments are stored in a zval container, which needs to be pointed to twice. The snippet above tries to retrieve one argument and make it available to us via the parameter pointer.

zend_get_parameters_ex() accepts at least two arguments. The first argument is the number of arguments to retrieve (which should match the number of arguments with which the function has been called; this is why it's important to check for correct call syntax). The second argument (and all following arguments) are pointers to pointers to pointers to zvals. (Confusing, isn't it?) All these pointers are required because Zend works internally with **zval; to adjust a local **zval in our function,zend_get_parameters_ex() requires a pointer to it.

The return value of zend_get_parameters_ex() can either be SUCCESS or FAILURE, indicating (unsurprisingly) success or failure of the argument processing. A failure is most likely related to an incorrect number of arguments being specified, in which case you should exit with WRONG_PARAM_COUNT.

To retrieve more than one argument, you can use a similar snippet:
zval **param1, **param2, **param3, **param4;

if(zend_get_parameters_ex(4, &param1, &param2, &param3, &param4) != SUCCESS)
    WRONG_PARAM_COUNT;

zend_get_parameters_ex() only checks whether you're trying to retrieve too many parameters. If the function is called with five arguments, but you're only retrieving three of them with zend_get_parameters_ex(), you won't get an error but will get the first three parameters instead. Subsequent calls of zend_get_parameters_ex() won't retrieve the remaining arguments, but will get the same arguments again.

이전 | 처음으로 | 다음
Retrieving Arguments | 위로 | Dealing with a Variable Number of Arguments/Optional Parameters


Dealing with a Variable Number of Arguments/Optional Parameters

If your function is meant to accept a variable number of arguments, the snippets just described are sometimes suboptimal solutions. You have to create a line calling zend_get_parameters_ex() for every possible number of arguments, which is often unsatisfying.

For this case, you can use the function zend_get_parameters_array_ex(), which accepts the number of parameters to retrieve and an array in which to store them:
zval **parameter_array[4];

/* get the number of arguments */
argument_count = ZEND_NUM_ARGS();

/* see if it satisfies our minimal request (2 arguments) */
/* and our maximal acceptance (4 arguments) */
if(argument_count < 2 || argument_count > 5)
    WRONG_PARAM_COUNT;

/* argument count is correct, now retrieve arguments */
if(zend_get_parameters_array_ex(argument_count, parameter_array) != SUCCESS)
    WRONG_PARAM_COUNT;
First, the number of arguments is checked to make sure that it's in the accepted range. After that, zend_get_parameters_array_ex() is used to fill parameter_array with valid pointers to the argument values.

A very clever implementation of this can be found in the code handling PHP's fsockopen() located in ext/standard/fsock.c, as shown in 예 32-1. Don't worry if you don't know all the functions used in this source yet; we'll get to them shortly.

예 32-1. PHP's implementation of variable arguments in fsockopen().

pval **args[5];
int *sock=emalloc(sizeof(int));
int *sockp;
int arg_count=ARG_COUNT(ht);
int socketd = -1;
unsigned char udp = 0;
struct timeval timeout = { 60, 0 };
unsigned short portno;
unsigned long conv;
char *key = NULL;
FLS_FETCH();

if (arg_count > 5 || arg_count < 2 || zend_get_parameters_array_ex(arg_count,args)==FAILURE) {
    CLOSE_SOCK(1);
    WRONG_PARAM_COUNT;
}

switch(arg_count) {
    case 5:
        convert_to_double_ex(args[4]);
        conv = (unsigned long) (Z_DVAL_P(args[4]) * 1000000.0);
        timeout.tv_sec = conv / 1000000;
        timeout.tv_usec = conv % 1000000;
        /* fall-through */
    case 4:
        if (!PZVAL_IS_REF(*args[3])) {
            php_error(E_WARNING,"error string argument to fsockopen not passed by reference");
        }
        pval_copy_constructor(*args[3]);
        ZVAL_EMPTY_STRING(*args[3]);
        /* fall-through */
    case 3:
        if (!PZVAL_IS_REF(*args[2])) {
            php_error(E_WARNING,"error argument to fsockopen not passed by reference");
            return;
        }
        ZVAL_LONG(*args[2], 0);
        break;
}

convert_to_string_ex(args[0]);
convert_to_long_ex(args[1]);
portno = (unsigned short) Z_LVAL_P(args[1]);

key = emalloc(Z_STRLEN_P(args[0]) + 10);

fsockopen() accepts two, three, four, or five parameters. After the obligatory variable declarations, the function checks for the correct range of arguments. Then it uses a fall-through mechanism in a switch() statement to deal with all arguments. The switch() statement starts with the maximum number of arguments being passed (five). After that, it automatically processes the case of four arguments being passed, then three, by omitting the otherwise obligatory break keyword in all stages. After having processed the last case, it exits the switch() statement and does the minimal argument processing needed if the function is invoked with only two arguments.

This multiple-stage type of processing, similar to a stairway, allows convenient processing of a variable number of arguments.

이전 | 처음으로 | 다음
Old way of retrieving arguments (deprecated) | 위로 | Accessing Arguments


Accessing Arguments

To access arguments, it's necessary for each argument to have a clearly defined type. Again, PHP's extremely dynamic nature introduces some quirks. Because PHP never does any kind of type checking, it's possible for a caller to pass any kind of data to your functions, whether you want it or not. If you expect an integer, for example, the caller might pass an array, and vice versa - PHP simply won't notice.

To work around this, you have to use a set of API functions to force a type conversion on every argument that's being passed (see 표 32-1).

Note: All conversion functions expect a **zval as parameter.

표 32-1. Argument Conversion Functions

Function | Description
convert_to_boolean_ex() | Forces conversion to a Boolean type. Boolean values remain untouched. Longs, doubles, and strings containing 0 as well as NULL values will result in Boolean 0 (FALSE). Arrays and objects are converted based on the number of entries or properties, respectively, that they have. Empty arrays and objects are converted to FALSE; otherwise, to TRUE. All other values result in a Boolean 1 (TRUE).
convert_to_long_ex() | Forces conversion to a long, the default integer type. NULL values, Booleans, resources, and of course longs remain untouched. Doubles are truncated. Strings containing an integer are converted to their corresponding numeric representation, otherwise resulting in 0. Arrays and objects are converted to 0 if empty, 1 otherwise.
convert_to_double_ex() | Forces conversion to a double, the default floating-point type. NULL values, Booleans, resources, longs, and of course doubles remain untouched. Strings containing a number are converted to their corresponding numeric representation, otherwise resulting in 0.0. Arrays and objects are converted to 0.0 if empty, 1.0 otherwise.
convert_to_string_ex() | Forces conversion to a string. Strings remain untouched. NULL values are converted to an empty string. Booleans containing TRUE are converted to "1", otherwise resulting in an empty string. Longs and doubles are converted to their corresponding string representation. Arrays are converted to the string "Array" and objects to the string "Object".
convert_to_array_ex(value) | Forces conversion to an array. Arrays remain untouched. Objects are converted to an array by assigning all their properties to the array table. All property names are used as keys, property contents as values. NULL values are converted to an empty array. All other values are converted to an array that contains the specific source value in the element with the key 0.
convert_to_object_ex(value) | Forces conversion to an object. Objects remain untouched. NULL values are converted to an empty object. Arrays are converted to objects by introducing their keys as properties into the objects and their values as corresponding property contents in the object. All other types result in an object with the property scalar , having the corresponding source value as content.
convert_to_null_ex(value) | Forces the type to become a NULL value, meaning empty.

참고: You can find a demonstration of the behavior in cross_conversion.php on the accompanying CD-ROM. 그림 32-2 shows the output.

그림 32-2. Cross-conversion behavior of PHP.

Using these functions on your arguments will ensure type safety for all data that's passed to you. If the supplied type doesn't match the required type, PHP forces dummy contents on the resulting value (empty strings, arrays, or objects, 0 for numeric values, FALSE for Booleans) to ensure a defined state.

Following is a quote from the sample module discussed previously, which makes use of the conversion functions:
zval **parameter;

if((ZEND_NUM_ARGS() != 1) || (zend_get_parameters_ex(1, &parameter) != SUCCESS))
{
    WRONG_PARAM_COUNT;
}

convert_to_long_ex(parameter);

RETURN_LONG(Z_LVAL_P(parameter));
After retrieving the parameter pointer, the parameter value is converted to a long (an integer), which also forms the return value of this function. Understanding access to the contents of the value requires a short discussion of the zval type, whose definition is shown in 예 32-2.

예 32-2. PHP/Zend zval type definition.

typedef pval zval;

typedef struct _zval_struct zval;

typedef union _zvalue_value {
    long lval;					/* long value */
    double dval;				/* double value */
    struct {
        char *val;
        int len;
    } str;
    HashTable *ht;				/* hash table value */
    struct {
        zend_class_entry *ce;
        HashTable *properties;
    } obj;
} zvalue_value;

struct _zval_struct {
    /* Variable information */
    zvalue_value value;		/* value */
    unsigned char type;	/* active type */
    unsigned char is_ref;
    short refcount;
};

Actually, pval (defined in php.h) is only an alias of zval (defined in zend.h), which in turn refers to _zval_struct. This is a most interesting structure. _zval_struct is the "master" structure, containing the value structure, type, and reference information. The substructure zvalue_value is a union that contains the variable's contents. Depending on the variable's type, you'll have to access different members of this union. For a description of both structures, see 표 32-2, 표 32-3 and 표 32-4.

표 32-2. Zend zval Structure

Entry | Description
value | Union containing this variable's contents. See 표 32-3 for a description.
type | Contains this variable's type. For a list of available types, see 표 32-4.
is_ref | 0 means that this variable is not a reference; 1 means that this variable is a reference to another variable.
refcount | The number of references that exist for this variable. For every new reference to the value stored in this variable, this counter is increased by 1. For every lost reference, this counter is decreased by 1. When the reference counter reaches 0, no references exist to this value anymore, which causes automatic freeing of the value.

표 32-3. Zend zvalue_value Structure

Entry | Description
lval | Use this property if the variable is of the type IS_LONG, IS_BOOLEAN, or IS_RESOURCE.
dval | Use this property if the variable is of the type IS_DOUBLE.
str | This structure can be used to access variables of the type IS_STRING. The member len contains the string length; the member val points to the string itself. Zend uses C strings; thus, the string length contains a trailing 0x00.
ht | This entry points to the variable's hash table entry if the variable is an array.
obj | Use this property if the variable is of the type IS_OBJECT.

표 32-4. Zend Variable Type Constants

Constant | Description
IS_NULL | Denotes a NULL (empty) value.
IS_LONG | A long (integer) value.
IS_DOUBLE | A double (floating point) value.
IS_STRING | A string.
IS_ARRAY | Denotes an array.
IS_OBJECT | An object.
IS_BOOL | A Boolean value.
IS_RESOURCE | A resource (for a discussion of resources, see the appropriate section below).
IS_CONSTANT | A constant (defined) value.

To access a long you access zval.value.lval, to access a double you use zval.value.dval, and so on. Because all values are stored in a union, trying to access data with incorrect union members results in meaningless output.

Accessing arrays and objects is a bit more complicated and is discussed later.

이전 | 처음으로 | 다음
Dealing with a Variable Number of Arguments/Optional Parameters | 위로 | Dealing with Arguments Passed by Reference


Dealing with Arguments Passed by Reference

If your function accepts arguments passed by reference that you intend to modify, you need to take some precautions.

What we didn't say yet is that under the circumstances presented so far, you don't have write access to any zval containers designating function parameters that have been passed to you. Of course, you can change any zval containers that you created within your function, but you mustn't change any zvals that refer to Zend-internal data!

We've only discussed the so-called *_ex() API so far. You may have noticed that the API functions we've used are called zend_get_parameters_ex() instead of zend_get_parameters(), convert_to_long_ex() instead of convert_to_long(), etc. The *_ex() functions form the so-called new "extended" Zend API. They give a minor speed increase over the old API, but as a tradeoff are only meant for providing read-only access.

Because Zend works internally with references, different variables may reference the same value. Write access to a zval container requires this container to contain an isolated value, meaning a value that's not referenced by any other containers. If a zval container were referenced by other containers and you changed the referenced zval, you would automatically change the contents of the other containers referencing this zval (because they'd simply point to the changed value and thus change their own value as well).

zend_get_parameters_ex() doesn't care about this situation, but simply returns a pointer to the desired zval containers, whether they consist of references or not. Its corresponding function in the traditional API, zend_get_parameters(), immediately checks for referenced values. If it finds a reference, it creates a new, isolated zval container; copies the referenced data into this newly allocated space; and then returns a pointer to the new, isolated value.

This action is called zval separation (or pval separation). Because the *_ex() API doesn't perform zval separation, it's considerably faster, while at the same time disabling write access.

To change parameters, however, write access is required. Zend deals with this situation in a special way: Whenever a parameter to a function is passed by reference, it performs automatic zval separation. This means that whenever you're calling a function like this in PHP, Zend will automatically ensure that $parameter is being passed as an isolated value, rendering it to a write-safe state:
my_function(&$parameter);

But this is not the case with regular parameters! All other parameters that are not passed by reference are in a read-only state.

This requires you to make sure that you're really working with a reference - otherwise you might produce unwanted results. To check for a parameter being passed by reference, you can use the macro PZVAL_IS_REF. This macro accepts a zval* to check if it is a reference or not. Examples are given in in 예 32-3.

예 32-3. Testing for referenced parameter passing.

zval *parameter;

if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "z", &parameter) == FAILURE)
    return;

/* check for parameter being passed by reference */
if (!PZVAL_IS_REF(*parameter)) {
{
    zend_error(E_WARNING, "Parameter wasn't passed by reference");
    RETURN_NULL();
}

/* make changes to the parameter */
ZVAL_LONG(*parameter, 10);

이전 | 처음으로 | 다음
Accessing Arguments | 위로 | Assuring Write Safety for Other Parameters


Assuring Write Safety for Other Parameters

You might run into a situation in which you need write access to a parameter that's retrieved with zend_get_parameters_ex() but not passed by reference. For this case, you can use the macro SEPARATE_ZVAL, which does a zval separation on the provided container. The newly generated zval is detached from internal data and has only a local scope, meaning that it can be changed or destroyed without implying global changes in the script context:
zval **parameter;

/* retrieve parameter */
zend_get_parameters_ex(1, &parameter);

/* at this stage, <parameter> still is connected */
/* to Zend's internal data buffers */

/* make <parameter> write-safe */
SEPARATE_ZVAL(parameter);

/* now we can safely modify <parameter> */
/* without implying global changes */
SEPARATE_ZVAL uses emalloc() to allocate the new zval container, which means that even if you don't deallocate this memory yourself, it will be destroyed automatically upon script termination. However, doing a lot of calls to this macro without freeing the resulting containers will clutter up your RAM.

Note: As you can easily work around the lack of write access in the "traditional" API (with zend_get_parameters() and so on), this API seems to be obsolete, and is not discussed further in this chapter.

이전 | 처음으로 | 다음
Dealing with Arguments Passed by Reference | 위로 | Creating Variables


Creating Variables

PHP 매뉴얼
이전 다음

33. 장. Creating Variables

차례
Overview
Longs (Integers)
Doubles (Floats)
Strings
Booleans
Arrays
Objects
Resources
Macros for Automatic Global Variable Creation
Creating Constants

When exchanging data from your own extensions with PHP scripts, one of the most important issues is the creation of variables. This section shows you how to deal with the variable types that PHP supports.

Overview

To create new variables that can be seen "from the outside" by the executing script, you need to allocate a new zval container, fill this container with meaningful values, and then introduce it to Zend's internal symbol table. This basic process is common to all variable creations:

zval *new_variable;

/* allocate and initialize new container */
MAKE_STD_ZVAL(new_variable);

/* set type and variable contents here, see the following sections */

/* introduce this variable by the name "new_variable_name" into the symbol table */
ZEND_SET_SYMBOL(EG(active_symbol_table), "new_variable_name", new_variable);

/* the variable is now accessible to the script by using $new_variable_name */

The macro MAKE_STD_ZVAL allocates a new zval container using ALLOC_ZVAL and initializes it using INIT_ZVAL. As implemented in Zend at the time of this writing, initializing means setting the reference count to 1 and clearing the is_ref flag, but this process could be extended later - this is why it's a good idea to keep using MAKE_STD_ZVAL instead of only using ALLOC_ZVAL. If you want to optimize for speed (and you don't have to explicitly initialize the zval container here), you can use ALLOC_ZVAL, but this isn't recommended because it doesn't ensure data integrity.

ZEND_SET_SYMBOL takes care of introducing the new variable to Zend's symbol table. This macro checks whether the value already exists in the symbol table and converts the new symbol to a reference if so (with automatic deallocation of the old zval container). This is the preferred method if speed is not a crucial issue and you'd like to keep memory usage low.

Note that ZEND_SET_SYMBOL makes use of the Zend executor globals via the macro EG. By specifying EG(active_symbol_table), you get access to the currently active symbol table, dealing with the active, local scope. The local scope may differ depending on whether the function was invoked from within a function.

If you need to optimize for speed and don't care about optimal memory usage, you can omit the check for an existing variable with the same value and instead force insertion into the symbol table by using zend_hash_update():
zval *new_variable;

/* allocate and initialize new container */
MAKE_STD_ZVAL(new_variable);

/* set type and variable contents here, see the following sections */

/* introduce this variable by the name "new_variable_name" into the symbol table */
zend_hash_update(
    EG(active_symbol_table),
    "new_variable_name",
    strlen("new_variable_name") + 1,
    &new_variable,
    sizeof(zval *),
    NULL
);
This is actually the standard method used in most modules.

The variables generated with the snippet above will always be of local scope, so they reside in the context in which the function has been called. To create new variables in the global scope, use the same method but refer to another symbol table:
zval *new_variable;

// allocate and initialize new container
MAKE_STD_ZVAL(new_variable);

//
// set type and variable contents here
//

// introduce this variable by the name "new_variable_name" into the global symbol table
ZEND_SET_SYMBOL(&EG(symbol_table), "new_variable_name", new_variable);
The macro ZEND_SET_SYMBOL is now being called with a reference to the main, global symbol table by referring EG(symbol_table).

Note: The active_symbol_table variable is a pointer, but symbol_table is not. This is why you have to use EG(active_symbol_table) and &EG(symbol_table) as parameters to ZEND_SET_SYMBOL - it requires a pointer.

Similarly, to get a more efficient version, you can hardcode the symbol table update:
zval *new_variable;

// allocate and initialize new container
MAKE_STD_ZVAL(new_variable);

//
// set type and variable contents here
//

// introduce this variable by the name "new_variable_name" into the global symbol table
zend_hash_update(
    &EG(symbol_table),
    "new_variable_name",
    strlen("new_variable_name") + 1,
    &new_variable,
    sizeof(zval *),
    NULL
);
예 33-1 shows a sample source that creates two variables - local_variable with a local scope and global_variable with a global scope (see Figure 9.7). The full example can be found on the CD-ROM.

Note: You can see that the global variable is actually not accessible from within the function. This is because it's not imported into the local scope using global $global_variable; in the PHP source.

예 33-1. Creating variables with different scopes.

ZEND_FUNCTION(variable_creation)
{
    zval *new_var1, *new_var2;

    MAKE_STD_ZVAL(new_var1);
    MAKE_STD_ZVAL(new_var2);

    ZVAL_LONG(new_var1, 10);
    ZVAL_LONG(new_var2, 5);

    ZEND_SET_SYMBOL(EG(active_symbol_table), "local_variable", new_var1);
    ZEND_SET_SYMBOL(&EG(symbol_table), "global_variable", new_var2);

    RETURN_NULL();

}

이전 | 처음으로 | 다음
Assuring Write Safety for Other Parameters | 위로 | Longs (Integers)


Longs (Integers)

Now let's get to the assignment of data to variables, starting with longs. Longs are PHP's integers and are very simple to store. Looking at the zval.value container structure discussed earlier in this chapter, you can see that the long data type is directly contained in the union, namely in the lval field. The corresponding type value for longs is IS_LONG (see 예 33-2).

예 33-2. Creation of a long.

zval *new_long;

MAKE_STD_ZVAL(new_long);

new_long->type = IS_LONG;
new_long->value.lval = 10;
Alternatively, you can use the macro ZVAL_LONG:
zval *new_long;

MAKE_STD_ZVAL(new_long);
ZVAL_LONG(new_long, 10);

이전 | 처음으로 | 다음
Creating Variables | 위로 | Doubles (Floats)


Doubles (Floats)

Doubles are PHP's floats and are as easy to assign as longs, because their value is also contained directly in the union. The member in the zval.value container is dval; the corresponding type is IS_DOUBLE.
zval *new_double;

MAKE_STD_ZVAL(new_double);

new_double->type = IS_DOUBLE;
new_double->value.dval = 3.45;
Alternatively, you can use the macro ZVAL_DOUBLE:
zval *new_double;

MAKE_STD_ZVAL(new_double);
ZVAL_DOUBLE(new_double, 3.45);

이전 | 처음으로 | 다음
Longs (Integers) | 위로 | Strings


Strings

Strings need slightly more effort. As mentioned earlier, all strings that will be associated with Zend's internal data structures need to be allocated using Zend's own memory-management functions. Referencing of static strings or strings allocated with standard routines is not allowed. To assign strings, you have to access the structure str in the zval.value container. The corresponding type is IS_STRING:
zval *new_string;
char *string_contents = "This is a new string variable";

MAKE_STD_ZVAL(new_string);

new_string->type = IS_STRING;
new_string->value.str.len = strlen(string_contents);
new_string->value.str.val = estrdup(string_contents);
Note the usage of Zend's estrdup() here. Of course, you can also use the predefined macro ZVAL_STRING:
zval *new_string;
char *string_contents = "This is a new string variable";

MAKE_STD_ZVAL(new_string);
ZVAL_STRING(new_string, string_contents, 1);
ZVAL_STRING accepts a third parameter that indicates whether the supplied string contents should be duplicated (using estrdup()). Setting this parameter to 1 causes the string to be duplicated; 0 simply uses the supplied pointer for the variable contents. This is most useful if you want to create a new variable referring to a string that's already allocated in Zend internal memory.

If you want to truncate the string at a certain position or you already know its length, you can use ZVAL_STRINGL(zval, string, length, duplicate), which accepts an explicit string length to be set for the new string. This macro is faster than ZVAL_STRING and also binary-safe.

To create empty strings, set the string length to 0 and use empty_string as contents:
new_string->type = IS_STRING;
new_string->value.str.len = 0;
new_string->value.str.val = empty_string;
Of course, there's a macro for this as well (ZVAL_EMPTY_STRING):
MAKE_STD_ZVAL(new_string);
ZVAL_EMPTY_STRING(new_string);

이전 | 처음으로 | 다음
Doubles (Floats) | 위로 | Booleans


Booleans

Booleans are created just like longs, but have the type IS_BOOL. Allowed values in lval are 0 and 1:
zval *new_bool;

MAKE_STD_ZVAL(new_bool);

new_bool->type = IS_BOOL;
new_bool->value.lval = 1;
The corresponding macros for this type are ZVAL_BOOL (allowing specification of the value) as well as ZVAL_TRUE and ZVAL_FALSE (which explicitly set the value to TRUE and FALSE, respectively).

이전 | 처음으로 | 다음
Strings | 위로 | Arrays


Arrays

Arrays are stored using Zend's internal hash tables, which can be accessed using the zend_hash_*() API. For every array that you want to create, you need a new hash table handle, which will be stored in the ht member of the zval.value container.

There's a whole API solely for the creation of arrays, which is extremely handy. To start a new array, you call array_init().
zval *new_array;

MAKE_STD_ZVAL(new_array);

array_init(new_array);
array_init() always returns SUCCESS.

To add new elements to the array, you can use numerous functions, depending on what you want to do. 표 33-1, 표 33-2 and 표 33-3 describe these functions. All functions return FAILURE on failure and SUCCESS on success.

표 33-1. Zend's API for Associative Arrays

Function | Description
add_assoc_long(zval *array, char *key, long n);() | Adds an element of type long.
add_assoc_unset(zval *array, char *key);() | Adds an unset element.
add_assoc_bool(zval *array, char *key, int b);() | Adds a Boolean element.
add_assoc_resource(zval *array, char *key, int r);() | Adds a resource to the array.
add_assoc_double(zval *array, char *key, double d);() | Adds a floating-point value.
add_assoc_string(zval *array, char *key, char *str, int duplicate);() | Adds a string to the array. The flag duplicate specifies whether the string contents have to be copied to Zend internal memory.
add_assoc_stringl(zval *array, char *key, char *str, uint length, int duplicate); () | Adds a string with the desired length length to the array. Otherwise, behaves like add_assoc_string().
add_assoc_zval(zval *array, char *key, zval *value);() | Adds a zval to the array. Useful for adding other arrays, objects, streams, etc...

표 33-2. Zend's API for Indexed Arrays, Part 1

Function | Description
add_index_long(zval *array, uint idx, long n);() | Adds an element of type long.
add_index_unset(zval *array, uint idx);() | Adds an unset element.
add_index_bool(zval *array, uint idx, int b);() | Adds a Boolean element.
add_index_resource(zval *array, uint idx, int r);() | Adds a resource to the array.
add_index_double(zval *array, uint idx, double d);() | Adds a floating-point value.
add_index_string(zval *array, uint idx, char *str, int duplicate);() | Adds a string to the array. The flag duplicate specifies whether the string contents have to be copied to Zend internal memory.
add_index_stringl(zval *array, uint idx, char *str, uint length, int duplicate);() | Adds a string with the desired length length to the array. This function is faster and binary-safe. Otherwise, behaves like add_index_string()().
add_index_zval(zval *array, uint idx, zval *value);() | Adds a zval to the array. Useful for adding other arrays, objects, streams, etc...

표 33-3. Zend's API for Indexed Arrays, Part 2

Function | Description
add_next_index_long(zval *array, long n);() | Adds an element of type long.
add_next_index_unset(zval *array);() | Adds an unset element.
add_next_index_bool(zval *array, int b);() | Adds a Boolean element.
add_next_index_resource(zval *array, int r);() | Adds a resource to the array.
add_next_index_double(zval *array, double d);() | Adds a floating-point value.
add_next_index_string(zval *array, char *str, int duplicate);() | Adds a string to the array. The flag duplicate specifies whether the string contents have to be copied to Zend internal memory.
add_next_index_stringl(zval *array, char *str, uint length, int duplicate);() | Adds a string with the desired length length to the array. This function is faster and binary-safe. Otherwise, behaves like add_index_string()().
add_next_index_zval(zval *array, zval *value);() | Adds a zval to the array. Useful for adding other arrays, objects, streams, etc...

All these functions provide a handy abstraction to Zend's internal hash API. Of course, you can also use the hash functions directly - for example, if you already have a zval container allocated that you want to insert into an array. This is done using zend_hash_update()() for associative arrays (see 예 33-3) and zend_hash_index_update() for indexed arrays (see 예 33-4):

예 33-3. Adding an element to an associative array.

zval *new_array, *new_element;
char *key = "element_key";

MAKE_STD_ZVAL(new_array);
MAKE_STD_ZVAL(new_element);

array_init(new_array);

ZVAL_LONG(new_element, 10);

if(zend_hash_update(new_array->value.ht, key, strlen(key) + 1, (void *)&new_element, sizeof(zval *), NULL) == FAILURE)
{
    // do error handling here
}

예 33-4. Adding an element to an indexed array.

zval *new_array, *new_element;
int key = 2;

MAKE_STD_ZVAL(new_array);
MAKE_STD_ZVAL(new_element);

array_init(new_array);

ZVAL_LONG(new_element, 10);

if(zend_hash_index_update(new_array->value.ht, key, (void *)&new_element, sizeof(zval *), NULL) == FAILURE)
{
    // do error handling here
}

To emulate the functionality of add_next_index_*(), you can use this:

zend_hash_next_index_insert(ht, zval **new_element, sizeof(zval *), NULL)

Note: To return arrays from a function, use array_init() and all following actions on the predefined variable return_value (given as argument to your exported function; see the earlier discussion of the call interface). You do not have to use MAKE_STD_ZVAL on this.

Tip: To avoid having to write new_array->value.ht every time, you can use HASH_OF(new_array), which is also recommended for compatibility and style reasons.

이전 | 처음으로 | 다음
Booleans | 위로 | Objects


Objects

Since objects can be converted to arrays (and vice versa), you might have already guessed that they have a lot of similarities to arrays in PHP. Objects are maintained with the same hash functions, but there's a different API for creating them.

To initialize an object, you use the function object_init():
zval *new_object;

MAKE_STD_ZVAL(new_object);

if(object_init(new_object) != SUCCESS)
{
    // do error handling here
}
You can use the functions described in 표 33-4 to add members to your object.

표 33-4. Zend's API for Object Creation

Function | Description
add_property_long(zval *object, char *key, long l);() | Adds a long to the object.
add_property_unset(zval *object, char *key);() | Adds an unset property to the object.
add_property_bool(zval *object, char *key, int b);() | Adds a Boolean to the object.
add_property_resource(zval *object, char *key, long r);() | Adds a resource to the object.
add_property_double(zval *object, char *key, double d);() | Adds a double to the object.
add_property_string(zval *object, char *key, char *str, int duplicate);() | Adds a string to the object.
add_property_stringl(zval *object, char *key, char *str, uint length, int duplicate);() | Adds a string of the specified length to the object. This function is faster than add_property_string() and also binary-safe.
add_property_zval(zval *obect, char *key, zval *container):() | Adds a zval container to the object. This is useful if you have to add properties which aren't simple types like integers or strings but arrays or other objects.

이전 | 처음으로 | 다음
Arrays | 위로 | Resources


Resources

Resources are a special kind of data type in PHP. The term resources doesn't really refer to any special kind of data, but to an abstraction method for maintaining any kind of information. Resources are kept in a special resource list within Zend. Each entry in the list has a correspondending type definition that denotes the kind of resource to which it refers. Zend then internally manages all references to this resource. Access to a resource is never possible directly - only via a provided API. As soon as all references to a specific resource are lost, a corresponding shutdown function is called.

For example, resources are used to store database links and file descriptors. The de facto standard implementation can be found in the MySQL module, but other modules such as the Oracle module also make use of resources.

참고: In fact, a resource can be a pointer to anything you need to handle in your functions (e.g. pointer to a structure) and the user only has to pass a single resource variable to your function.

To create a new resource you need to register a resource destruction handler for it. Since you can store any kind of data as a resource, Zend needs to know how to free this resource if its not longer needed. This works by registering your own resource destruction handler to Zend which in turn gets called by Zend whenever your resource can be freed (whether manually or automatically). Registering your resource handler within Zend returns you the resource type handle for that resource. This handle is needed whenever you want to access a resource of this type later and is most of time stored in a global static variable within your extension. There is no need to worry about thread safety here because you only register your resource handler once during module initialization.

The Zend function to register your resource handler is defined as:
ZEND_API int zend_register_list_destructors_ex(rsrc_dtor_func_t ld, rsrc_dtor_func_t pld, char *type_name, int module_number);

There are two different kinds of resource destruction handlers you can pass to this function: a handler for normal resources and a handler for persistent resources. Persistent resources are for example used for database connection. When registering a resource, either of these handlers must be given. For the other handler just pass NULL.

zend_register_list_destructors_ex() accepts the following parameters:

ld | Normal resource destruction handler callback
pld | Pesistent resource destruction handler callback
type_name | A string specifying the name of your resource. It's always a good thing to specify an unique name within PHP for the resource type so when the user for example calls var_dump($resource); he also gets the name of the resource.
module_number | The module_number is automatically available in your PHP_MINIT_FUNCTION function and therefore you just pass it over.

The return value is an unique integer ID for your resource type.

The resource destruction handler (either normal or persistent resources) has the following prototype:
void resource_destruction_handler(zend_rsrc_list_entry *rsrc TSRMLS_DC);
The passed rsrc is a pointer to the following structure:
typedef struct _zend_rsrc_list_entry {

    void *ptr;
    int type;
    int refcount;

} zend_rsrc_list_entry;
The member void *ptr is the actual pointer to your resource.

Now we know how to start things, we define our own resource we want register within Zend. It is only a simple structure with two integer members:
typedef struct {

    int resource_link;
    int resource_type;

} my_resource;
Our resource destruction handler is probably going to look something like this:
void my_destruction_handler(zend_rsrc_list_entry *rsrc TSRMLS_DC) {

    // You most likely cast the void pointer to your structure type

    my_resource *my_rsrc = (my_resource *) rsrc->ptr;

    // Now do whatever needs to be done with you resource. Closing
    // Files, Sockets, freeing additional memory, etc.
    // Also, don't forget to actually free the memory for your resource too!

    do_whatever_needs_to_be_done_with_the_resource(my_rsrc);
}

참고: One important thing to mention: If your resource is a rather complex structure which also contains pointers to memory you allocated during runtime you have to free them before freeing the resource itself!

Now that we have defined

  1. what our resource is and

  2. our resource destruction handler

we can go on and do the rest of the steps:

  1. create a global variable within the extension holding the resource ID so it can be accessed from every function which needs it

  2. define the resource name

  3. write the resource destruction handler

  4. and finally register the handler

// Somewhere in your extension, define the variable for your registered resources.
    // If you wondered what 'le' stands for: it simply means 'list entry'.
    static int le_myresource;

    // It's nice to define your resource name somewhere
    #define le_myresource_name  "My type of resource"

    [...]

    // Now actually define our resource destruction handler
    void my_destruction_handler(zend_rsrc_list_entry *rsrc TSRMLS_DC) {

        my_resource *my_rsrc = (my_resource *) rsrc->ptr;
        do_whatever_needs_to_be_done_with_the_resource(my_rsrc);
    }

    [...]

    PHP_MINIT_FUNCTION(my_extension) {

        // Note that 'module_number' is already provided through the
        // PHP_MINIT_FUNCTION() function definition.

        le_myresource = zend_register_resource_destructors_ex(my_destruction_handler, NULL, le_myresource_name, module_number);

        // You can register additional resources, initialize
        // your global vars, constants, whatever.
    }

To actually register a new resource you use can either use the zend_register_resource() function or the ZEND_REGISTER_RESOURE() macro, both defined in zend_list.h . Although the arguments for both map 1:1 it's a good idea to always use macros to be upwards compatible:
int ZEND_REGISTER_RESOURCE(zval *rsrc_result, void *rsrc_pointer, int rsrc_type);

rsrc_result | This is an already initialized zval * container.
rsrc_pointer | Your resource pointer you want to store.
rsrc_type | The type which you received when you registered the resource destruction handler. If you followed the naming scheme this would be le_myresource.

The return value is an unique integer identifier for that resource.

What is really going on when you register a new resource is it gets inserted in an internal list in Zend and the result is just stored in the given zval * container:
rsrc_id = zend_list_insert(rsrc_pointer, rsrc_type);

    if (rsrc_result) {
        rsrc_result->value.lval = rsrc_id;
        rsrc_result->type = IS_RESOURCE;
    }

    return rsrc_id;
The returned rsrc_id uniquly identifies the newly registered resource. You can use the macro RETURN_RESOURE to return it to the user:
RETURN_RESOURCE(rsrc_id)

참고: It is common practice that if you want to return the resource immidiately to the user you specify the return_value as the zval * container.

Zend now keeps track of all references to this resource. As soon as all references to the resource are lost, the destructor that you previously registered for this resource is called. The nice thing about this setup is that you don't have to worry about memory leakages introduced by allocations in your module - just register all memory allocations that your calling script will refer to as resources. As soon as the script decides it doesn't need them anymore, Zend will find out and tell you.

Now that the user got his resource, at some point he is passing it back to one of your functions. The value.lval inside the zval * container contains the key to your resource and thus can be used to fetch the resource with the following macro: ZEND_FETCH_RESOURCE:
ZEND_FETCH_RESOURCE(rsrc, rsrc_type, rsrc_id, default_rsrc_id, resource_type_name, resource_type)

rsrc | This is your pointer which will point to your previously registered resource.
rsrc_type | This is the typecast argument for your pointer, e.g. myresource *.
rsrc_id | This is the address of the zval *container the user passed to your function, e.g. &z_resource if zval *z_resource is given.
default_rsrc_id | This integer specifies the default resource ID if no resource could be fetched or -1.
resource_type_name | This is the name of the requested resource. It's a string and is used when the resource can't be found or is invalid to form a meaningful error message.
resource_type | The resource_type you got back when registering the resource destruction handler. In our example this was le_myresource.

This macro has no return value. It is for the developers convenience and takes care of TSRMLS arguments passing and also does check if the resource could be fetched. It throws a warning message and returns the current PHP function with NULL if there was a problem retrieving the resource.

To force removal of a resource from the list, use the function zend_list_delete(). You can also force the reference count to increase if you know that you're creating another reference for a previously allocated value (for example, if you're automatically reusing a default database link). For this case, use the function zend_list_addref(). To search for previously allocated resource entries, use zend_list_find(). The complete API can be found in zend_list.h.

이전 | 처음으로 | 다음
Objects | 위로 | Macros for Automatic Global Variable Creation


Macros for Automatic Global Variable Creation

In addition to the macros discussed earlier, a few macros allow easy creation of simple global variables. These are nice to know in case you want to introduce global flags, for example. This is somewhat bad practice, but Table 표 33-5 describes macros that do exactly this task. They don't need any zval allocation; you simply have to supply a variable name and value.

표 33-5. Macros for Global Variable Creation

Macro | Description
SET_VAR_STRING(name, value) | Creates a new string.
SET_VAR_STRINGL(name, value, length) | Creates a new string of the specified length. This macro is faster than SET_VAR_STRING and also binary-safe.
SET_VAR_LONG(name, value) | Creates a new long.
SET_VAR_DOUBLE(name, value) | Creates a new double.

이전 | 처음으로 | 다음
Resources | 위로 | Creating Constants


Creating Constants

Zend supports the creation of true constants (as opposed to regular variables). Constants are accessed without the typical dollar sign ($) prefix and are available in all scopes. Examples include TRUE and FALSE, to name just two.

To create your own constants, you can use the macros in 표 33-6. All the macros create a constant with the specified name and value.

You can also specify flags for each constant:

  • CONST_CS - This constant's name is to be treated as case sensitive.

  • CONST_PERSISTENT - This constant is persistent and won't be "forgotten" when the current process carrying this constant shuts down.

To use the flags, combine them using a inary OR:
// register a new constant of type "long"
     REGISTER_LONG_CONSTANT("NEW_MEANINGFUL_CONSTANT", 324, CONST_CS |
     CONST_PERSISTENT);
There are two types of macros - REGISTER_*_CONSTANT andREGISTER_MAIN_*_CONSTANT. The first type creates constants bound to the current module. These constants are dumped from the symbol table as soon as the module that registered the constant is unloaded from memory. The second type creates constants that remain in the symbol table independently of the module.

표 33-6. Macros for Creating Constants

Macro | Description
REGISTER_LONG_CONSTANT(name, value, flags) REGISTER_MAIN_LONG_CONSTANT(name, value, flags) | Registers a new constant of type long.
REGISTER_DOUBLE_CONSTANT(name, value, flags) REGISTER_MAIN_DOUBLE_CONSTANT(name, value, flags) | Registers a new constant of type double.
REGISTER_STRING_CONSTANT(name, value, flags) REGISTER_MAIN_STRING_CONSTANT(name, value, flags) | Registers a new constant of type string. The specified string must reside in Zend's internal memory.
REGISTER_STRINGL_CONSTANT(name, value, length, flags) REGISTER_MAIN_STRINGL_CONSTANT(name, value, length, flags) | Registers a new constant of type string. The string length is explicitly set to length. The specified string must reside in Zend's internal memory.

이전 | 처음으로 | 다음
Macros for Automatic Global Variable Creation | 위로 | Duplicating Variable Contents: The Copy Constructor


Duplicating Variable Contents: The Copy Constructor

PHP 매뉴얼
이전 다음

34. 장. Duplicating Variable Contents: The Copy Constructor

Sooner or later, you may need to assign the contents of one zval container to another. This is easier said than done, since the zval container doesn't contain only type information, but also references to places in Zend's internal data. For example, depending on their size, arrays and objects may be nested with lots of hash table entries. By assigning one zval to another, you avoid duplicating the hash table entries, using only a reference to them (at most).

To copy this complex kind of data, use the copy constructor. Copy constructors are typically defined in languages that support operator overloading, with the express purpose of copying complex types. If you define an object in such a language, you have the possibility of overloading the "=" operator, which is usually responsible for assigning the contents of the lvalue (result of the evaluation of the left side of the operator) to the rvalue (same for the right side).

Overloading means assigning a different meaning to this operator, and is usually used to assign a function call to an operator. Whenever this operator would be used on such an object in a program, this function would be called with the lvalue and rvalue as parameters. Equipped with that information, it can perform the operation it intends the "=" operator to have (usually an extended form of copying).

This same form of "extended copying" is also necessary for PHP's zval containers. Again, in the case of an array, this extended copying would imply re-creation of all hash table entries relating to this array. For strings, proper memory allocation would have to be assured, and so on.

Zend ships with such a function, called zend_copy_ctor() (the previous PHP equivalent was pval_copy_constructor()).

A most useful demonstration is a function that accepts a complex type as argument, modifies it, and then returns the argument:

zval *parameter;

if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "z", &parameter) == FAILURE)
   return;
}

// do modifications to the parameter here

// now we want to return the modified container:
*return_value == *parameter;
zval_copy_ctor(return_value);

The first part of the function is plain-vanilla argument retrieval. After the (left out) modifications, however, it gets interesting: The container of parameter is assigned to the (predefined) return_value container. Now, in order to effectively duplicate its contents, the copy constructor is called. The copy constructor works directly with the supplied argument, and the standard return values are FAILURE on failure and SUCCESS on success.

If you omit the call to the copy constructor in this example, both parameter and return_value would point to the same internal data, meaning that return_value would be an illegal additional reference to the same data structures. Whenever changes occurred in the data that parameter points to, return_value might be affected. Thus, in order to create separate copies, the copy constructor must be used.

The copy constructor's counterpart in the Zend API, the destructor zval_dtor(), does the opposite of the constructor.

이전 | 처음으로 | 다음
Creating Constants | 위로 | Returning Values


Returning Values

PHP 매뉴얼
이전 다음

35. 장. Returning Values

Returning values from your functions to PHP was described briefly in an earlier section; this section gives the details. Return values are passed via the return_value variable, which is passed to your functions as argument. The return_value argument consists of a zval container (see the earlier discussion of the call interface) that you can freely modify. The container itself is already allocated, so you don't have to run MAKE_STD_ZVAL on it. Instead, you can access its members directly.

To make returning values from functions easier and to prevent hassles with accessing the internal structures of the zval container, a set of predefined macros is available (as usual). These macros automatically set the correspondent type and value, as described in 표 35-1 and 표 35-2.

참고: The macros in 표 35-1 automatically return from your function, those in 표 35-2 only set the return value; they don't return from your function.

표 35-1. Predefined Macros for Returning Values from a Function

Macro | Description
RETURN_RESOURCE(resource) | Returns a resource.
RETURN_BOOL(bool) | Returns a Boolean.
RETURN_NULL() | Returns nothing (a NULL value).
RETURN_LONG(long) | Returns a long.
RETURN_DOUBLE(double) | Returns a double.
RETURN_STRING(string, duplicate) | Returns a string. The duplicate flag indicates whether the string should be duplicated using estrdup().
RETURN_STRINGL(string, length, duplicate) | Returns a string of the specified length; otherwise, behaves like RETURN_STRING. This macro is faster and binary-safe, however.
RETURN_EMPTY_STRING() | Returns an empty string.
RETURN_FALSE | Returns Boolean false.
RETURN_TRUE | Returns Boolean true.

표 35-2. Predefined Macros for Setting the Return Value of a Function

Macro | Description
RETVAL_RESOURCE(resource) | Sets the return value to the specified resource.
RETVAL_BOOL(bool) | Sets the return value to the specified Boolean value.
RETVAL_NULL | Sets the return value to NULL.
RETVAL_LONG(long) | Sets the return value to the specified long.
RETVAL_DOUBLE(double) | Sets the return value to the specified double.
RETVAL_STRING(string, duplicate) | Sets the return value to the specified string and duplicates it to Zend internal memory if desired (see also RETURN_STRING).
RETVAL_STRINGL(string, length, duplicate) | Sets the return value to the specified string and forces the length to become length (see also RETVAL_STRING). This macro is faster and binary-safe, and should be used whenever the string length is known.
RETVAL_EMPTY_STRING | Sets the return value to an empty string.
RETVAL_FALSE | Sets the return value to Boolean false.
RETVAL_TRUE | Sets the return value to Boolean true.

Complex types such as arrays and objects can be returned by using array_init() and object_init(), as well as the corresponding hash functions on return_value. Since these types cannot be constructed of trivial information, there are no predefined macros for them.

이전 | 처음으로 | 다음
Duplicating Variable Contents: The Copy Constructor | 위로 | Printing Information


Printing Information

PHP 매뉴얼
이전 다음

36. 장. Printing Information

차례
zend_printf()
zend_error()
Including Output in phpinfo()
Execution Information

Often it's necessary to print messages to the output stream from your module, just as print() would be used within a script. PHP offers functions for most generic tasks, such as printing warning messages, generating output for phpinfo(), and so on. The following sections provide more details. Examples of these functions can be found on the CD-ROM.

zend_printf()

zend_printf() works like the standard printf(), except that it prints to Zend's output stream.

이전 | 처음으로 | 다음
Returning Values | 위로 | zend_error()


Execution Information

You can also print execution information, such as the current file being executed. The name of the function currently being executed can be retrieved using the function get_active_function_name(). This function returns a pointer to the function name and doesn't accept any arguments. To retrieve the name of the file currently being executed, use zend_get_executed_filename(). This function accesses the executor globals, which are passed to it using the TSRMLS_C macro. The executor globals are automatically available to every function that's called directly by Zend (they're part of the INTERNAL_FUNCTION_PARAMETERS described earlier in this chapter). If you want to access the executor globals in another function that doesn't have them available automatically, call the macro TSRMLS_FETCH() once in that function; this will introduce them to your local scope.

Finally, the line number currently being executed can be retrieved using the function zend_get_executed_lineno(). This function also requires the executor globals as arguments. For examples of these functions, see 예 36-2.

예 36-2. Printing execution information.

zend_printf("The name of the current function is %s<br>", get_active_function_name(TSRMLS_C));
zend_printf("The file currently executed is %s<br>", zend_get_executed_filename(TSRMLS_C));
zend_printf("The current line being executed is %i<br>", zend_get_executed_lineno(TSRMLS_C));

이전 | 처음으로 | 다음
Including Output in phpinfo() | 위로 | Startup and Shutdown Functions


Startup and Shutdown Functions

PHP 매뉴얼
이전 다음

37. 장. Startup and Shutdown Functions

Startup and shutdown functions can be used for one-time initialization and deinitialization of your modules. As discussed earlier in this chapter (see the description of the Zend module descriptor block), there are module, and request startup and shutdown events.

The module startup and shutdown functions are called whenever a module is loaded and needs initialization; the request startup and shutdown functions are called every time a request is processed (meaning that a file is being executed).

For dynamic extensions, module and request startup/shutdown events happen at the same time.

Declaration and implementation of these functions can be done with macros; see the earlier section "Declaration of the Zend Module Block" for details.

이전 | 처음으로 | 다음
Execution Information | 위로 | Calling User Functions


Calling User Functions

PHP 매뉴얼
이전 다음

38. 장. Calling User Functions

You can call user functions from your own modules, which is very handy when implementing callbacks; for example, for array walking, searching, or simply for event-based programs.

User functions can be called with the function call_user_function_ex(). It requires a hash value for the function table you want to access, a pointer to an object (if you want to call a method), the function name, return value, number of arguments, argument array, and a flag indicating whether you want to perform zval separation.

ZEND_API int call_user_function_ex(HashTable *function_table, zval *object,
zval *function_name, zval **retval_ptr_ptr,
int param_count, zval **params[],
int no_separation);

Note that you don't have to specify both function_table and object; either will do. If you want to call a method, you have to supply the object that contains this method, in which case call_user_function()automatically sets the function table to this object's function table. Otherwise, you only need to specify function_table and can set object to NULL.

Usually, the default function table is the "root" function table containing all function entries. This function table is part of the compiler globals and can be accessed using the macro CG. To introduce the compiler globals to your function, call the macro TSRMLS_FETCH once.

The function name is specified in a zval container. This might be a bit surprising at first, but is quite a logical step, since most of the time you'll accept function names as parameters from calling functions within your script, which in turn are contained in zval containers again. Thus, you only have to pass your arguments through to this function. This zval must be of type IS_STRING.

The next argument consists of a pointer to the return value. You don't have to allocate memory for this container; the function will do so by itself. However, you have to destroy this container (using zval_dtor()) afterward!

Next is the parameter count as integer and an array containing all necessary parameters. The last argument specifies whether the function should perform zval separation - this should always be set to 0. If set to 1, the function consumes less memory but fails if any of the parameters need separation.

예 38-1 shows a small demonstration of calling a user function. The code calls a function that's supplied to it as argument and directly passes this function's return value through as its own return value. Note the use of the constructor and destructor calls at the end - it might not be necessary to do it this way here (since they should be separate values, the assignment might be safe), but this is bulletproof.

예 38-1. Calling user functions.

zval **function_name;
zval *retval;

if((ZEND_NUM_ARGS() != 1) || (zend_get_parameters_ex(1, &function_name) != SUCCESS))
{
    WRONG_PARAM_COUNT;
}

if((*function_name)->type != IS_STRING)
{
    zend_error(E_ERROR, "Function requires string argument");
}

TSRMSLS_FETCH();

if(call_user_function_ex(CG(function_table), NULL, *function_name, &retval, 0, NULL, 0) != SUCCESS)
{
    zend_error(E_ERROR, "Function call failed");
}

zend_printf("We have %i as type<br>", retval->type);

*return_value = *retval;
zval_copy_ctor(return_value);
zval_ptr_dtor(&retval);

<?php

dl("call_userland.so");

function test_function()
{

    print("We are in the test function!<br>");

    return("hello");

}

$return_value = call_userland("test_function");

print("Return value: \"$return_value\"<br>");
?>

이전 | 처음으로 | 다음
Startup and Shutdown Functions | 위로 | Initialization File Support


Initialization File Support

PHP 매뉴얼
이전 다음

39. 장. Initialization File Support

PHP 4 features a redesigned initialization file support. It's now possible to specify default initialization entries directly in your code, read and change these values at runtime, and create message handlers for change notifications.

To create an .ini section in your own module, use the macros PHP_INI_BEGIN() to mark the beginning of such a section and PHP_INI_END() to mark its end. In between you can use PHP_INI_ENTRY() to create entries.
PHP_INI_BEGIN()
PHP_INI_ENTRY("first_ini_entry",  "has_string_value", PHP_INI_ALL, NULL)
PHP_INI_ENTRY("second_ini_entry", "2",                PHP_INI_SYSTEM, OnChangeSecond)
PHP_INI_ENTRY("third_ini_entry",  "xyz",              PHP_INI_USER, NULL)
PHP_INI_END()
The PHP_INI_ENTRY() macro accepts four parameters: the entry name, the entry value, its change permissions, and a pointer to a change-notification handler. Both entry name and value must be specified as strings, regardless of whether they really are strings or integers.

The permissions are grouped into three sections:PHP_INI_SYSTEM allows a change only directly in the php.ini file; PHP_INI_USER allows a change to be overridden by a user at runtime using additional configuration files, such as .htaccess; and PHP_INI_ALL allows changes to be made without restrictions. There's also a fourth level, PHP_INI_PERDIR, for which we couldn't verify its behavior yet.

The fourth parameter consists of a pointer to a change-notification handler. Whenever one of these initialization entries is changed, this handler is called. Such a handler can be declared using the PHP_INI_MH macro:
PHP_INI_MH(OnChangeSecond);             // handler for ini-entry "second_ini_entry"

// specify ini-entries here

PHP_INI_MH(OnChangeSecond)
{

    zend_printf("Message caught, our ini entry has been changed to %s<br>", new_value);

    return(SUCCESS);

}
The new value is given to the change handler as string in the variable new_value. When looking at the definition of PHP_INI_MH, you actually have a few parameters to use:
#define PHP_INI_MH(name) int name(php_ini_entry *entry, char *new_value,
                                  uint new_value_length, void *mh_arg1,
                                  void *mh_arg2, void *mh_arg3)
All these definitions can be found in php_ini.h. Your message handler will have access to a structure that contains the full entry, the new value, its length, and three optional arguments. These optional arguments can be specified with the additional macros PHP_INI_ENTRY1 (allowing one additional argument), PHP_INI_ENTRY2 (allowing two additional arguments), and PHP_INI_ENTRY3 (allowing three additional arguments).

The change-notification handlers should be used to cache initialization entries locally for faster access or to perform certain tasks that are required if a value changes. For example, if a constant connection to a certain host is required by a module and someone changes the hostname, automatically terminate the old connection and attempt a new one.

Access to initialization entries can also be handled with the macros shown in 표 39-1.

표 39-1. Macros to Access Initialization Entries in PHP

Macro | Description
INI_INT(name) | Returns the current value of entry name as integer (long).
INI_FLT(name) | Returns the current value of entry name as float (double).
INI_STR(name) | Returns the current value of entry name as string. Note: This string is not duplicated, but instead points to internal data. Further access requires duplication to local memory.
INI_BOOL(name) | Returns the current value of entry name as Boolean (defined as zend_bool, which currently means unsigned char).
INI_ORIG_INT(name) | Returns the original value of entry name as integer (long).
INI_ORIG_FLT(name) | Returns the original value of entry name as float (double).
INI_ORIG_STR(name) | Returns the original value of entry name as string. Note: This string is not duplicated, but instead points to internal data. Further access requires duplication to local memory.
INI_ORIG_BOOL(name) | Returns the original value of entry name as Boolean (defined as zend_bool, which currently means unsigned char).

Finally, you have to introduce your initialization entries to PHP. This can be done in the module startup and shutdown functions, using the macros REGISTER_INI_ENTRIES() and UNREGISTER_INI_ENTRIES():
ZEND_MINIT_FUNCTION(mymodule)
{

    REGISTER_INI_ENTRIES();

}

ZEND_MSHUTDOWN_FUNCTION(mymodule)
{

    UNREGISTER_INI_ENTRIES();

}

이전 | 처음으로 | 다음
Calling User Functions | 위로 | Where to Go from Here


Where to Go from Here

PHP 매뉴얼
이전 다음

40. 장. Where to Go from Here

You've learned a lot about PHP. You now know how to create dynamic loadable modules and statically linked extensions. You've learned how PHP and Zend deal with internal storage of variables and how you can create and access these variables. You know quite a set of tool functions that do a lot of routine tasks such as printing informational texts, automatically introducing variables to the symbol table, and so on.

Even though this chapter often had a mostly "referential" character, we hope that it gave you insight on how to start writing your own extensions. For the sake of space, we had to leave out a lot; we suggest that you take the time to study the header files and some modules (especially the ones in the ext/standard directory and the MySQL module, as these implement commonly known functionality). This will give you an idea of how other people have used the API functions - particularly those that didn't make it into this chapter.

이전 | 처음으로 | 다음
Initialization File Support | 위로 | Reference: Some Configuration Macros


Reference: Some Configuration Macros

PHP 매뉴얼
이전 다음

41. 장. Reference: Some Configuration Macros

차례
config.m4

config.m4

The file config.m4 is processed by buildconf and must contain all the instructions to be executed during configuration. For example, these can include tests for required external files, such as header files, libraries, and so on. PHP defines a set of macros that can be used in this process, the most useful of which are described in 표 41-1.

표 41-1. M4 Macros for config.m4

Macro | Description
AC_MSG_CHECKING(message) | Prints a "checking <message>" text during configure.
AC_MSG_RESULT(value) | Gives the result to AC_MSG_CHECKING; should specify either yes or no as value.
AC_MSG_ERROR(message) | Prints message as error message during configure and aborts the script.
AC_DEFINE(name,value,description) | Adds #define to php_config.h with the value of value and a comment that says description (this is useful for conditional compilation of your module).
AC_ADD_INCLUDE(path) | Adds a compiler include path; for example, used if the module needs to add search paths for header files.
AC_ADD_LIBRARY_WITH_PATH(libraryname,librarypath) | Specifies an additional library to link.
AC_ARG_WITH(modulename,description,unconditionaltest,conditionaltest) | Quite a powerful macro, adding the module with description to the configure --help output. PHP checks whether the option --with-<modulename> is given to the configure script. If so, it runs the script unconditionaltest (for example, --with-myext=yes), in which case the value of the option is contained in the variable $withval. Otherwise, it executes conditionaltest.
PHP_EXTENSION(modulename, [shared]) | This macro is a must to call for PHP to configure your extension. You can supply a second argument in addition to your module name, indicating whether you intend compilation as a shared module. This will result in a definition at compile time for your source as COMPILE_DL_<modulename>.

이전 | 처음으로 | 다음
Where to Go from Here | 위로 | API Macros


API Macros

PHP 매뉴얼
이전 다음

42. 장. API Macros

A set of macros was introduced into Zend's API that simplify access to zval containers (see 표 42-1).

표 42-1. API Macros for Accessing zval Containers

Macro | Refers to
Z_LVAL(zval) | (zval).value.lval
Z_DVAL(zval) | (zval).value.dval
Z_STRVAL(zval) | (zval).value.str.val
Z_STRLEN(zval) | (zval).value.str.len
Z_ARRVAL(zval) | (zval).value.ht
Z_LVAL_P(zval) | (*zval).value.lval
Z_DVAL_P(zval) | (*zval).value.dval
Z_STRVAL_P(zval_p) | (*zval).value.str.val
Z_STRLEN_P(zval_p) | (*zval).value.str.len
Z_ARRVAL_P(zval_p) | (*zval).value.ht
Z_LVAL_PP(zval_pp) | (**zval).value.lval
Z_DVAL_PP(zval_pp) | (**zval).value.dval
Z_STRVAL_PP(zval_pp) | (**zval).value.str.val
Z_STRLEN_PP(zval_pp) | (**zval).value.str.len
Z_ARRVAL_PP(zval_pp) | (**zval).value.ht

이전 | 처음으로 | 다음
Reference: Some Configuration Macros | 위로 | PHP API: 확장 모듈 제작자를 위한 인터페이스


PHP API: 확장 모듈 제작자를 위한 인터페이스

PHP 매뉴얼
이전 다음

VII. PHP API: 확장 모듈 제작자를 위한 인터페이스

차례
43. Streams API for PHP Extension Authors

이전 | 처음으로 | 다음
API Macros |  | Streams API for PHP Extension Authors


Streams API for PHP Extension Authors

PHP 매뉴얼
이전 다음

43. 장. Streams API for PHP Extension Authors

차례
Overview
Streams Basics
Streams as Resources
Streams Common API Reference
Streams Dir API Reference
Streams File API Reference
Streams Socket API Reference
Streams Structures
Streams Constants

Overview

The PHP Streams API introduces a unified approach to the handling of files and sockets in PHP extension. Using a single API with standard functions for common operations, the streams API allows your extension to access files, sockets, URLs, memory and script-defined objects. Streams is a run-time extensible API that allows dynamically loaded modules (and scripts!) to register new streams.

The aim of the Streams API is to make it comfortable for developers to open files, URLs and other streamable data sources with a unified API that is easy to understand. The API is more or less based on the ANSI C stdio family of functions (with identical semantics for most of the main functions), so C programmers will have a feeling of familiarity with streams.

The streams API operates on a couple of different levels: at the base level, the API defines php_stream objects to represent streamable data sources. On a slightly higher level, the API defines php_stream_wrapper objects which "wrap" around the lower level API to provide support for retrieving data and meta-data from URLs. An additional context parameter, accepted by most stream creation functions, is passed to the wrapper's stream_opener method to fine-tune the behavior of the wrapper.

Any stream, once opened, can also have any number of filters applied to it, which process data as it is read from/written to the stream.

Streams can be cast (converted) into other types of file-handles, so that they can be used with third-party libraries without a great deal of trouble. This allows those libraries to access data directly from URL sources. If your system has the fopencookie() or funopen() function, you can even pass any PHP stream to any library that uses ANSI stdio!

참고: The functions in this chapter are for use in the PHP source code and are not PHP functions. Userland stream functions can be found in the Stream Reference.

이전 | 처음으로 | 다음
PHP API: 확장 모듈 제작자를 위한 인터페이스 | 위로 | Streams Basics


Streams Basics

Using streams is very much like using ANSI stdio functions. The main difference is in how you obtain the stream handle to begin with. In most cases, you will use php_stream_open_wrapper() to obtain the stream handle. This function works very much like fopen, as can be seen from the example below:

예 43-1. simple stream example that displays the PHP home page

php_stream * stream = php_stream_open_wrapper("http://www.php.net", "rb", REPORT_ERRORS, NULL);
if (stream) {
    while(!php_stream_eof(stream)) {
        char buf[1024];

        if (php_stream_gets(stream, buf, sizeof(buf))) {
            printf(buf);
        } else {
            break;
        }
    }
    php_stream_close(stream);
}

The table below shows the Streams equivalents of the more common ANSI stdio functions. Unless noted otherwise, the semantics of the functions are identical.

표 43-1. ANSI stdio equivalent functions in the Streams API

ANSI Stdio Function | PHP Streams Function | Notes
fopen | php_stream_open_wrapper | Streams includes additional parameters
fclose | php_stream_close |
fgets | php_stream_gets |
fread | php_stream_read | The nmemb parameter is assumed to have a value of 1, so the prototype looks more like read(2)
fwrite | php_stream_write | The nmemb parameter is assumed to have a value of 1, so the prototype looks more like write(2)
fseek | php_stream_seek |
ftell | php_stream_tell |
rewind | php_stream_rewind |
feof | php_stream_eof |
fgetc | php_stream_getc |
fputc | php_stream_putc |
fflush | php_stream_flush |
puts | php_stream_puts | Same semantics as puts, NOT fputs
fstat | php_stream_stat | Streams has a richer stat structure

이전 | 처음으로 | 다음
Streams API for PHP Extension Authors | 위로 | Streams as Resources


Streams as Resources

All streams are registered as resources when they are created. This ensures that they will be properly cleaned up even if there is some fatal error. All of the filesystem functions in PHP operate on streams resources - that means that your extensions can accept regular PHP file pointers as parameters to, and return streams from their functions. The streams API makes this process as painless as possible:

예 43-2. How to accept a stream as a parameter

PHP_FUNCTION(example_write_hello)
{
    zval *zstream;
    php_stream *stream;

    if (FAILURE == zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "r", &zstream))
        return;

    php_stream_from_zval(stream, &zstream);

    /* you can now use the stream.  However, you do not "own" the
        stream, the script does.  That means you MUST NOT close the
        stream, because it will cause PHP to crash! */

    php_stream_write(stream, "hello\n");

    RETURN_TRUE();
}

예 43-3. How to return a stream from a function

PHP_FUNCTION(example_open_php_home_page)
{
    php_stream *stream;

    stream = php_stream_open_wrapper("http://www.php.net", "rb", REPORT_ERRORS, NULL);

    php_stream_to_zval(stream, return_value);

    /* after this point, the stream is "owned" by the script.
        If you close it now, you will crash PHP! */
}

Since streams are automatically cleaned up, it's tempting to think that we can get away with being sloppy programmers and not bother to close the streams when we are done with them. Although such an approach might work, it is not a good idea for a number of reasons: streams hold locks on system resources while they are open, so leaving a file open after you have finished with it could prevent other processes from accessing it. If a script deals with a large number of files, the accumulation of the resources used, both in terms of memory and the sheer number of open files, can cause web server requests to fail. Sounds bad, doesn't it? The streams API includes some magic that helps you to keep your code clean - if a stream is not closed by your code when it should be, you will find some helpful debugging information in you web server error log.

참고: Always use a debug build of PHP when developing an extension (--enable-debug when running configure), as a lot of effort has been made to warn you about memory and stream leaks.

In some cases, it is useful to keep a stream open for the duration of a request, to act as a log or trace file for example. Writing the code to safely clean up such a stream is not difficult, but it's several lines of code that are not strictly needed. To save yourself the trouble of writing the code, you can mark a stream as being OK for auto cleanup. What this means is that the streams API will not emit a warning when it is time to auto-cleanup a stream. To do this, you can use php_stream_auto_cleanup().

이전 | 처음으로 | 다음
Streams Basics | 위로 | Streams Common API Reference


Streams Common API Reference

차례
php_stream_stat_path -- Gets the status for a file or URL
php_stream_stat -- Gets the status for the underlying storage associated with a stream
php_stream_open_wrapper -- Opens a stream on a file or URL
php_stream_read -- Read a number of bytes from a stream into a buffer
php_stream_write -- Write a number of bytes from a buffer to a stream
php_stream_eof -- Check for an end-of-file condition on a stream
php_stream_getc -- Read a single byte from a stream
php_stream_gets -- Read a line of data from a stream into a buffer
php_stream_close -- Close a stream
php_stream_flush -- Flush stream buffers to storage
php_stream_seek -- Reposition a stream
php_stream_tell -- Determine the position of a stream
php_stream_copy_to_stream -- Copy data from one stream to another
php_stream_copy_to_mem -- Copy data from stream and into an allocated buffer
php_stream_make_seekable -- Convert a stream into a stream is seekable
php_stream_cast -- Convert a stream into another form, such as a FILE* or socket
php_stream_can_cast -- Determines if a stream can be converted into another form, such as a FILE* or socket
php_stream_is_persistent -- Determines if a stream is a persistent stream
php_stream_is -- Determines if a stream is of a particular type
php_stream_passthru -- Outputs all remaining data from a stream
php_register_url_stream_wrapper -- Registers a wrapper with the Streams API
php_unregister_url_stream_wrapper -- Unregisters a wrapper from the Streams API
php_stream_open_wrapper_ex -- Opens a stream on a file or URL, specifying context
php_stream_open_wrapper_as_file -- Opens a stream on a file or URL, and converts to a FILE*
php_stream_filter_register_factory -- Registers a filter factory with the Streams API
php_stream_filter_unregister_factory -- Deregisters a filter factory with the Streams API

이전 | 처음으로 | 다음
Streams as Resources | 위로 | php_stream_stat_path


Streams Dir API Reference

차례
php_stream_opendir -- Open a directory for file enumeration
php_stream_readdir -- Fetch the next directory entry from an opened dir
php_stream_rewinddir -- Rewind a directory stream to the first entry
php_stream_closedir -- Close a directory stream and release resources

The functions listed in this section work on local files, as well as remote files (provided that the wrapper supports this functionality!).

이전 | 처음으로 | 다음
php_stream_filter_unregister_factory | 위로 | php_stream_opendir


Streams File API Reference

차례
php_stream_fopen_from_file -- Convert an ANSI FILE* into a stream
php_stream_fopen_tmpfile -- Open a FILE* with tmpfile() and convert into a stream
php_stream_fopen_temporary_file -- Generate a temporary file name and open a stream on it

이전 | 처음으로 | 다음
php_stream_closedir | 위로 | php_stream_fopen_from_file


Streams Socket API Reference

차례
php_stream_sock_open_from_socket -- Convert a socket descriptor into a stream
php_stream_sock_open_host -- Open a connection to a host and return a stream
php_stream_sock_open_unix -- Open a Unix domain socket and convert into a stream

이전 | 처음으로 | 다음
php_stream_fopen_temporary_file | 위로 | php_stream_sock_open_from_socket


Streams Structures

차례
struct php_stream_statbuf -- Holds information about a file or URL
struct php_stream_dirent -- Holds information about a single file during dir scanning
struct php_stream_ops -- Holds member functions for a stream implementation
struct php_stream_wrapper -- Holds wrapper properties and pointer to operations
struct php_stream_wrapper_ops -- Holds member functions for a stream wrapper implementation
struct php_stream_filter -- Holds filter properties and pointer to operations
struct php_stream_filter_ops -- Holds member functions for a stream filter implementation

이전 | 처음으로 | 다음
php_stream_sock_open_unix | 위로 | struct php_stream_statbuf


Streams Constants

차례
Stream open options -- Affects the operation of stream factory functions

이전 | 처음으로 | 다음
struct php_stream_filter_ops | 위로 | Stream open options


FAQ: 자주 물어보는 질문들

PHP 매뉴얼
이전 다음

VIII. FAQ: 자주 물어보는 질문들

차례
44. 일반적인 정보
45. 메일링리스트
46. PHP 구하기
47. 데이터베이스와 관련된 문제
48. 설치
49. 빌드(build)시의 문제
50. PHP 사용하기
51. PHP와 HTML
52. PHP와 COM
53. PHP와 다른 프로그래밍 언어
54. PHP 2 에서 PHP 3로 마이그레이션 하기
55. PHP 3에서 PHP 4로의 마이그레이션
56. 기타 문제들

이전 | 처음으로 | 다음
Stream open options |  | 일반적인 정보


일반적인 정보

PHP 매뉴얼
이전 다음

44. 장. 일반적인 정보

이 섹션은 PHP에 관한 일반적인 정보를 다룬다: PHP가 무엇이고 무엇을 하는지에 관해.

1. PHP는 무엇입니까?
2. PHP라는 약자는 무엇을 의미합니까?
3. 각 버전 사이의 관계를 알고 싶습니다
4. 동시에 여러 버전의 PHP를 사용할수 있습니까?
5. PHP 3와 PHP 4는 무엇이 다릅니까?
6. 버그를 발견한것 같아요! 누구에게 이 사실을 알려줘야 하나요?

1. PHP는 무엇입니까?

preface of the manual을 참고하면:

PHP는 HTML 내장 스크립트 언어입니다. 문법의 대부분이 C, Java, Perl 로부터 차용되었으며 PHP고유의 특성도 함께 내포되어있습니다. 이 언어의 목적은 웹개발자에게 동적으로 생성되는 페이지를 빨리 만들수 있도록 하는 데 있습니다.

Stig Sæther Bakken 가 집필하였으며 PHP를 잘 소개한 안내서는 Zend 웹사이트의 여기서 구할 수 있습니다. 또, PHP Conference Material도 도움이 될것입니다.

2. PHP라는 약자는 무엇을 의미합니까?

PHP약어를 풀어쓰면 PHP: Hypertext Preprocessor입니다. 약어의 첫번째 글자가 약어이기 때문에 많은 사람에게 혼란을 줍니다. 이와 같은 약어를 재귀적 약어라고 부릅니다. 궁금하신 분은 Free On-Line Dictionary of Computing사이트를 방문해보세요.

3. 각 버전 사이의 관계를 알고 싶습니다

PHP/FI 2.0는 PHP의 초기 버전이며 더이상 지원되지 않습니다. PHP 3는 PHP/FI 2.0의 다음 버전으로서 좀 더 나아진 단계입니다. PHP 4는 PHP의 현재 버전이고 젠드 엔진(Zend engine)을 사용합니다. PHP 5는 젠드 엔진 2(Zend engine 2)를 사용하며 더 많은 추가적인 OOP특성도 가지고 있습니다. PHP 5는 현재 시험단계입니다.

4. 동시에 여러 버전의 PHP를 사용할수 있습니까?

네, PHP 4 소스 디렉토리 밑의 INSTALL문서를 참고하세요. 이것과 관련된 섹션은 appendix입니다.

5. PHP 3와 PHP 4는 무엇이 다릅니까?

PHP 4 제작자가 이에 관련된 몇가지 글 을 썼습니다. 다음은 좀 더 중요한 새로운 특성에 대한 것을 정리했습니다.

  • 확장된 API 모듈

  • UNIX 상의 통일된 빌드 과정

  • 멀티-쓰레드 웹서버를 지원하는 통일된 웹서버 인터페이스

  • 향상된 문법 하이라이터(highlighter)

  • 고유의 HTTP 세션 지원

  • 출력 버퍼링 지원

  • 좀 더 강화된 설정 시스템

  • 레퍼런스 카운팅(Reference counting)

이 특정은 물론 다른 특성에 대해 더 자세히 알고 싶다면 What's new in PHP 4 overview문서를 참고하세요. PHP 3에서 PHP 4로 마이그레이션하려 한다면 appendix섹션도 참고 하세요.

6. 버그를 발견한것 같아요! 누구에게 이 사실을 알려줘야 하나요?

PHP 버그 데이터베이스로 가서 그 버그가 이미 보고가 되었는지 확인해야 합니다. 그 데이터베이스에서 그 버그가 보고되지 않았다면 버그 보고 제출폼을 사용하세요. 버그는 할당된 트래킹 번호(tracking number)를 부여해야 하고 나중에 보고자가 되돌릴수 있도록 해주며 버그의 상태를 점검할수 있도록 하기 때문에 메일링리스트에 보내는것 보다는 버그 데이터베이스를 사용하는것이 좋습니다. 버그 데이터베이스는 http://bugs.php.net/에 가면 보실수 있습니다.

이전 | 처음으로 | 다음
FAQ: 자주 물어보는 질문들 | 위로 | 메일링리스트


메일링리스트

PHP 매뉴얼
이전 다음

45. 장. 메일링리스트

이 섹션은 어떻게 PHP 커뮤니티에 참가할수 있는지 알려줍니다. 최고의 방법은 메일링리스트입니다.

1. 어떠한 PHP 메일링리스트가 있습니까?
2. 다른 커뮤니티도 있습니까?
3. 도와주세요! 메일링리스트에 구독신청/구독취소 할수 없는것 같습니다!
4. 메일링리스트의 옛기록(아카이브:archive)은 어디에 있습니까?
5. 메일링리스트에 무엇을 물어볼수 있나요?
6. 메일링리스트에 글을 올릴때 포함해야 하는 정보는 어떤것이 있나요?

1. 어떠한 PHP 메일링리스트가 있습니까?

여러가지 목적을 위한 메일링리스트가 있습니다. 메일링리스트의 전체 목록은 Support 페이지에서 볼 수 있습니다.

대부분의 일반적인 메일링리스트는 php-general입니다. 이것을 구독하려면 php-general-subscribe@lists.php.net로 메일을 보내세요. 메일 메시지의 제목과 본문에 특별한것을 포함할 필요는 없습니다. 구독을 취소하려면 php-general-unsubscribe@lists.php.net로 메일을 보냅니다.

Support페이지의 웹인터페이스를 통해서 구독요청(subscribe)이나 구독취소(unsubscribe)를 할수 있습니다.

2. 다른 커뮤니티도 있습니까?

전세계에 셀수없이 존재합니다. 우리는 예를 들어 몇몇의 IRC 서버와 외국어 메일링리스트에 대한 목록을 Support 페이지에 제공하고 있습니다.

3. 도와주세요! 메일링리스트에 구독신청/구독취소 할수 없는것 같습니다!

php-general 메일링리스트에 구독신청이나 구독취소를 하는데 문제가 있으면 메일링리스트 프로그램이 정확한 메일링 주소를 이해할수없기 때문일수도 있습니다. 당신의 이메일주소가 joeblow@example.com이었다면, php-general-subscribe-joeblow=example.com@lists.php.net로 구독신청폼을 전송할수 있습니다. 또는 php-general-unsubscribe-joeblow=example.com@lists.php.net로 구독취소폼을 전송할수 있습니다. 다른 메일링리스트도 비슷한 주소를 사용하십시오.

4. 메일링리스트의 옛기록(아카이브:archive)은 어디에 있습니까?

Support페이지에서 archive sites 목록을 발견할수 있습니다. 메일링리스트 기사는 뉴스 메시지로도 저장이 됩니다. 뉴스리더로 news://news.php.net/ 뉴스서버에 접속할수 있습니다. 뉴스서버를 위한 실험적인 웹 인터페이스도 또한 존재합니다. http://news.php.net/입니다.

5. 메일링리스트에 무엇을 물어볼수 있나요?

PHP는 나날이 성장해가고 있기 때문에 php-general 메일링리스트로 트래픽이 증가하고 있습니다. 매일 약 150에서 200개의 글이 올라가고 있습니다. 이 때문에 다른곳에서 찾을수 있을때에는 최후의 수단으로 메일링리스트를 사용하는것이 모든사람에게 좋습니다.

메일링리스트로 글을 올리기 전에 FAQ를 살펴보거나 매뉴얼을 보십시오. 거기에 없다면 메일링리스트 옛기록(archives)을 찾아보십시오 (위를 보세요) PHP를 설치하거나 설정할때 문제가 발생하는것이라면 포함된 모든 문서와 README 파일을 읽어주십시오. 아직도 도움이 될만한 어떤 정보도 얻지 못했다면 그때 메일링리스트를 사용해주십시오.

질문을 하기전에, 좀더 나은 질문을 하기위한 방법이란 글을 읽는것이 모두에게 유익할것입니다.

6. 메일링리스트에 글을 올릴때 포함해야 하는 정보는 어떤것이 있나요?

"PHP를 올리고 실행시킬수 없어요! 도와주세요! 뭐가 문제죠?"와 같은 질문은 절대적으로 아무에게도 도움이 안됩니다. PHP를 올리고 실행시키는데 문제가 있다면 무슨 운영체제이고 PHP의 버전이 무엇인지 어떤 형태의 배포본인지 (pre-compiled, CVS, RPMS 등등)에 대한 정보, 무엇을 했는지, 어디서 멈췄는지, 정확한 에러 메시지에 대해서도 포함시켜야 합니다.

물론 다른 문제에도 해당됩니다. 무엇을 했는지, 어디서 멈쳤는지, 무엇을 하려고 했는지, 가능하다면 정확한 에러메시지까지도 포함시켜야 합니다. 소스코드에 문제가 있다면 작동하지 않는 코드의 일부분을 포함시킬 필요가 있습니다. 필요 이상의 코드를 포함시키지는 마세요! 그것은 그 글을 읽기 어렵게 만들고 많은 사람들이 이 때문에 모두 그 글을 그냥 지나칠지도 모릅니다. 메일에 포함된 정보가 얼마나 필요한지에 대해 확신할수 없으면 적지않게 포함하는것이 낫습니다.

기억해야 또다른 중요한 사항은 제목에 문제점을 요약하라는것입니다. "도와주세요~~!!!"나 "여기서 문제가 뭔가요?"는 구독자의 대다수에 의해 무시당할것입니다.

그리고 마지막으로 당부하건데 좀더 나은 질문을 하기위한 방법이란 글을 읽어주시기 바랍니다. 이글은 모두에게 큰 도움이 될것이고 특별히 당신에게도 도움이 됩니다.

이전 | 처음으로 | 다음
일반적인 정보 | 위로 | PHP 구하기


PHP 구하기

PHP 매뉴얼
이전 다음

46. 장. PHP 구하기

이 섹션은 PHP를 다운로드할수 있는곳과 OS에 관련된 정보를 다룹니다.

1. PHP는 어디서 구할수 있습니까?
2. pre-compiled 바이너리 버전도 있습니까?
3. 추가적인 PHP 확장을 컴파일하기 위해서 필요한 라이브러리는 어디서 구할수 있습니까?
4. 이 라이브러리를 작동시키려면 어떻게 해야 합니까?
5. 윈도우 머신에 CVS 저장소로부터 최종 PHP 소스 코드를 받아왔습니다. 그것을 컴파일하려면 어떻게 해야 합니까?
6. Browser Capabilities File을 어디서 구할수 있나요?

1. PHP는 어디서 구할수 있습니까?

PHP는 PHP 관련 사이트들로부터 구할수 있습니다. http://www.php.net/에 정리되어있습니다. 또한 익명 CVS를 사용하여 가장 최종 버전을 다운로드 받을수도 있습니다. http://www.php.net/anoncvs.php에 자세한 정보가 있습니다.

2. pre-compiled 바이너리 버전도 있습니까?

모든 주요 리눅스/유닉스 플랫폼을 모든 확장 옵션을 가진 PHP로 컴파일 할수 없기 때문에, 윈도우 시스템에서만 precompiled 바이너리를 제공합니다. 알려진대로, 많은 리눅스 배포판은 요즘 PHP가 내장되어 나옵니다. 윈도우 바이너리는 Downloads페이지 에서 내려받을수 있습니다. 리눅스는 현재 사용중인 배포판 웹사이트를 방문하세요.

3. 추가적인 PHP 확장을 컴파일하기 위해서 필요한 라이브러리는 어디서 구할수 있습니까?

참고: *로 표시된것은 thread-safe 라이브러리가 아닙니다. 그래서 multi-thread 윈도우 웹서버(IIS, netscape)에서 서버 모듈로 PHP와 사용해서는 안됩니다. 아직까지는 유닉스 환경에서는 상관없습니다.

  • LDAP (Unix).

  • LDAP* (Unix).

  • LDAP (Unix/Win) : Netscape Directory (LDAP) SDK 1.1.

  • free LDAP server.

  • Berkeley DB2 (Unix/Win) : http://www.sleepycat.com/.

  • SNMP* (Unix): .

  • GD* (Unix/Win).

  • mSQL* (Unix).

  • PostgreSQL (Unix).

  • IMAP* (Win/Unix).

  • Sybase-CT* (Linux, libc5) : Available locally.

  • FreeType (libttf):.

  • ZLib (Unix/Win32).

  • expat XML parser (Unix/Win32).

  • PDFLib.

  • mcrypt.

  • mhash.

  • t1lib.

  • dmalloc.

  • aspell.

  • readline.

4. 이 라이브러리를 작동시키려면 어떻게 해야 합니까?

라이브러리를 제공하는 다음 지시가 필요합니다. 이 라이브러리 중 어떤것은 PHP의 'configure'스크립트 명령을 실행할때 자동적으로 인식이 됩니다. (GD 라이브러리 같은 경우). 다른것은 'configure'의 '--with-EXTENSION' 옵션을 사용하여 활성화시켜야 합니다. 이에 관련되 리스트를 보려면 'configure --help'명령을 실행하세요.

5. 윈도우 머신에 CVS 저장소로부터 최종 PHP 소스 코드를 받아왔습니다. 그것을 컴파일하려면 어떻게 해야 합니까?

우선 Microsoft Visual C++ v6 (v5도 가능하지만 우리는 v6를 사용한다) 가 필요합니다. 그리고 다른 지원 파일이 필요합니다. building PHP from source on Windows에 관한 섹션을 참고하시기 바랍니다.

6. Browser Capabilities File을 어디서 구할수 있나요?

http://www.garykeith.com/browsers/downloads.asp 에서 browscap.ini파일을 찾을수 있습니다.

이전 | 처음으로 | 다음
메일링리스트 | 위로 | 데이터베이스와 관련된 문제


데이터베이스와 관련된 문제

PHP 매뉴얼
이전 다음

47. 장. 데이터베이스와 관련된 문제

이 섹션은 PHP와 데이터베이스의 연동에 관련되어 자주 묻는 질문들을 다룹니다. 네, PHP는 오늘날 거의 모든 데이터베이스와 연동이 가능합니다.

1. PHP로 Microsoft SQL 서버로 접근이 가능하다고 들었습니다. 어떻게요?
2. MS 액세스 데이터베이스(Microsoft Access database)에 접속할수있습니까?
3. PHP 5 부터는 더이상 MySQL 클라이언트 라이브러리를 함께 제공하지 않는다고 하는데, 이말은 무슨 의미인가요? PHP로 계속 MySQL을 사용할수 있나요? MySQL을 사용하려고 하면 "function undefined"라는 에러 메시지를 보여줍니다. 뭣때문인지요?
4. I upgraded to PHP 4, and now mysql keeps telling me "Warning: MySQL: Unable to save result set in ...". What's up? PHP 4로 업그레이드했습니다. 그런데 mysql이 다음과같은 메시지를 보여줍니다. "Warning: MySQL: Unable to save result set in ...". 뭐죠?
5. 공유 MySQL 지원(shared MySQL support)을 설치한후에, 아파치가 libphp4.so를 로드할때마다 코어 덤프가 일어납니다. 이것을 고칠수 있나요?
6. 왜 다음과 같은 에러가 발생합니까: "Warning: 0 is not a MySQL result index in <file> on line <x>" 또는 "Warning: Supplied argument is not a valid MySQL result resource in <file> on line <x>?

1. PHP로 Microsoft SQL 서버로 접근이 가능하다고 들었습니다. 어떻게요?

윈도우 머신상에서, 인클루드 ODBC 지원(included ODBC support)과 ODBC 드라이버(correct ODBC driver)를 사용할수 있습니다.

유닉스 머신에서, 사이베이스-CT(Sybase-CT)드라이버를 사용할수있습니다. 왜냐하면 둘은 프로토콜이 호환되기 때문입니다. 사이베이스는 리눅스 시스템에 필요한 무료버전 을 만들었습니다. 다른 유닉스 운영체제에서는 적합 라이브러리(correct library) 로 사이베이스와 연동해야 합니다. 또한 다음 FAQ를 보세요.

2. MS 액세스 데이터베이스(Microsoft Access database)에 접속할수있습니까?

네, 윈도우 9x/Me나 NT/2000 상에서 운영하고 있다면 그리고 그 운영체제에서 ODBC를 사용할수 있고 MS 액세스 데이터베이스를 위한 ODBC 드라이버를 사용할수 있다면 필요한 모든 툴은 이미 보유한 것입니다.

유닉스에서 PHP를 사용하고 있고 윈도우 박스의 MS 액세스와 연동하기를 원한다면 유닉스 ODBC 드라이버가 필요합니다. OpenLink Software에 이를 수행할수 있는 유닉스 기반(Unix-based) ODBC 드라이버가 있습니다. 그곳에는 시험판(evalution)을 다운로드 할수 있는 안내용 프로그램(pilot program)이 있고, 그리고 675달러이상하는 상업용 버전도 있습니다.

다른 방법은 윈도우 ODBC 드라이버까지 포함되있고 데이터도 저장할수 있는 SQL 서버를 사용하는것입니다. 그 데이터는 MS 액세스에서 접근할수 있고(ODBC로), PHP로(내장 드라이버)로 접근할수 있습니다. 또는 액세스와 PHP 모두에게 가용한 파일 형식을 이용하는것입니다. 즉 일반 파일(flat files)이나 dBase 형식으로요. 이에 관련된 글을 OpenLink software의 Tim Hayes가 쓴글을 참고하세요:
Using another database as an intermediary is not a good idea, when you can
      use ODBC from PHP straight to your database - i.e. with OpenLink's drivers. If
      you do need to use an intermediary file format, OpenLink have now released
      Virtuoso (a virtual database engine) for NT, Linux and other unix platforms.
      Please visit our website for a free download.

다른 방법은 MySQL을 사용하고, 윈도우상에서 MyODBC드라이버를 사용하여 데이터베이스를 일치(synchronizing)시키는 것입니다. Steve Lawrence의 글을 참고하세요:

  • MySQL의 지시에 따라 사용중인 플래폼에 MySQL을 설치합니다. www.mysql.com(미러에서 받을수있슴!)에서 받을수 있습니다. 데이터베이스를 설치할때 외에는 특별한 설정이 필요치않습니다. 계정을 설정하고, host 필드에는 %로 놓거나 MySQL을 접속하고자하는 윈도우 컴퓨터의 호스트명을 넣습니다. 서버명, 계정, 비밀번호를 넣습니다.

  • MySQL사이트에서 윈도우드라이버용 MyODBC를 다운받습니다. 최종버전은 dbc-2_50_19-win95.zip입니다(NT도 사용할수 있을뿐만아니라 소스도 있습니다) 윈도우 머신에 그것을 설치합니다. 이 프로그램에 포함되어있는 유틸로 동작을 테스트할수있습니다.

  • ODBC 관리자 유저나 시스템 dsn을 만듭니다. 제어판에 위치합니다. dsn 이름을 만들고 스텝1에서 설정한 MySQL데이터베이스에 대한 호스트명, 유저명, 패스워드, 포트등을 넣습니다.

  • 전체 설치(full install)로 액세스를 설치합니다. 이렇게 하면 적절한 추가항목(add-ins)도 같이 설치가 됩니다. 최소한 ODBC 지원과 링크드 테이블 매니저(linked table manager)가 필요합니다.

  • 이제부터 중요한 부분입니다! 새 액세스 데이터베이스를 만듭니다. 그 테이블에서 오른쪽 클릭하고 링크 테이블(Link Tables)를 선택하거나, 파일 메뉴 옵션에서 Get External Data를 선택한후에 링크 테이블(Link Tables)을 선택하세요. 파일 브라우저 박스가 나올때 files of type: ODBC 를 선택하세요. 시스템 dsn과 스텝 3에서 만든 dsn의 이름을 선택하세요. 연결된 테이블을 선택하고, OK를 클릭하세요 이젠 테이블을 열수 있고 MySQL서버에 데이터를 넣거나/지우거나/수정 할수 있습니다. 질의(query)를 수행할수도 있고 MySQL에 테이블을 임포트(import)/익스포트(export)할수 있습니다. 폼이나 레포트도 만들수있고 기타등등...

팁과 트릭:

  • 액세스에서 테이블을 만들수 있고 MySQL로 그 테이블을 익스포트(export)할수 있고, 거기에 링크를 걸수 있습니다. 이렇게 하면 테이블을 빨리 만들어냅니다.

  • 액세스에서 테이블을 만들때, 액세스에서 테이블에 쓸수있는 권한을 부여하기 위해 정의한 프라이머리 키(primary key)가 있어야 합니다. 액세스에 링크를 걸기전에 MySQL에 프라이머리 키를 만들었는지 확인합니다.

  • MySQL에서 테이블을 변경한다면, 액세스로 다시 링크를 걸어야 합니다. tools>add-ins>linked table manager로 가서 ODBC DSN을 보고, 거기에서 다시 링크할 테이블을 선택합니다. 거기서 dsn의 원본을 옮길수 있습니다. OK하기 전에 새 위치(new location) 항상 확인 체크박스를 클릭하면 됩니다.

3. PHP 5 부터는 더이상 MySQL 클라이언트 라이브러리를 함께 제공하지 않는다고 하는데, 이말은 무슨 의미인가요? PHP로 계속 MySQL을 사용할수 있나요? MySQL을 사용하려고 하면 "function undefined"라는 에러 메시지를 보여줍니다. 뭣때문인지요?

네, PHP에서는 앞으로도 계속 MySQL지원이 될것입니다. PHP 5의 단 하나의 변화가 클라이언트 라이브러리 자체를 함께 제공하지 않는다는 것입니다. 그 이유는 특별한 순서없이 아래글에서 설명하도록 하겠습니다:

1. 요근래의 대부분의 시스템은 이미 클라이언트 라이브러리가 설치되어있습니다.

2. 위에서 언급한대로, 라이브러리를 여러가지 버전을 갖게 되면 혼란스러워질수 있습니다. 예를 들면 어떤 버전은 mod_auth_mysql을 링크하고 다른 버전에는 PHP를 링크하고나서 아파치안에서 두개 버전을 모두 활성화시키면, 큰 충돌이 발생하게 됩니다. 또한, 함께 제공된 라이브러리가 설치된 서버버전과 항상 잘 작동하지도 않습니다. 이런 경우를 잘 보여주는 예가 mysql.socket 유닉스 도메인 소켓 파일이 있는 곳을 찾을수 없을때입니다.

3. 유지관리가 약간 더디게 되고 최신판 버전에 점점더 뒤떨어지게 될것입니다.

4. 앞으로의 라이브러리 버전은 GPL을 따르고 따라서 우리가 BSD/아파치 스타일의 라이센스 프로젝트인 GPL의 라이브러리를 함께 제공할수 없기 때문에 업그레이드 경로를 갖을수 없습니다. PHP 5에서 이런 깨끗한 중단이 최고의 선택으로 보입니다.

이와 같은 사실은 실제로 많은 사람들에게 영향이 있지는 않을것입니다. 유닉스 유저, 최소한 그들이 무엇을 하는지 아는 유저,는 PHP를 빌드할때 단순히 --with-mysql=/usr 을 추가시킴으로써 시스템의 libmysqlclient에 대한 PHP 를 빌드하려 할것이기 때문입니다. 윈도우 유저는 php.ini안에 php_mysql.dll 확장을 활성화시킬수 있습니다. 또한 dll 디렉토리에 함께 제공된 다른 모든 DLL을 사용하듯이, 적절한 %SYSTEMROOT% 디렉토리안에 libmySQL.dll파일을 카피할수 있습니다.

4. I upgraded to PHP 4, and now mysql keeps telling me "Warning: MySQL: Unable to save result set in ...". What's up? PHP 4로 업그레이드했습니다. 그런데 mysql이 다음과같은 메시지를 보여줍니다. "Warning: MySQL: Unable to save result set in ...". 뭐죠?

대부분 PHP 4는 MySQL에대한 경로를 지정하지 않으면 '--with-mysql' 옵션으로 컴파일됩니다. 이것은 PHP가 내장(built-in) MySQL 클라이언트 라이브러리(MySQL client library)를 사용한다는 것입니다. 시스템이 응용프로그램을 실행할때 아파치 모듈로서의 PHP3나 auth-mysql과 같이 다른 버전의 MySQL클라이언트를 사용하면, 다른 버전의 클라이언트 사이에는 충돌이 발생합니다.

PHP 4를 다시 컴파일하세요. 그리고 플래그값으로 MySQL경로를 넣으세요. '--with-mysql=/your/path/to/mysql' 보통 이렇게 하면 해결됩니다.

5. 공유 MySQL 지원(shared MySQL support)을 설치한후에, 아파치가 libphp4.so를 로드할때마다 코어 덤프가 일어납니다. 이것을 고칠수 있나요?

MySQL libs가 pthreads로 링크되어있다면 이런 현상이 발생합니다. ldd로 점검해보세요. 그렇다면 MySQL 타볼(tarball)를 가져와서 소스로 컴파일하거나 소스 RPM에서 재컴파일해서 spec 파일에서 thread 클라이언트 코드로 변경하는 곳을 제거하세요. 이 방법 모두 이런 현상을 고칠수 있습니다. 그리고나서 새로운 MySQL libs와 함께 PHP를 재컴파일하세요.

6. 왜 다음과 같은 에러가 발생합니까: "Warning: 0 is not a MySQL result index in <file> on line <x>" 또는 "Warning: Supplied argument is not a valid MySQL result resource in <file> on line <x>?

0으로 되어있는 결과 식별자(result identifier)를 사용하려 하고 있습니다. 0이라는것은 어떤 이유로 질의가 실패했다는것을 말합니다. 질의를 보내고 돌아온 결과 식별자를 사용하기 전에 에러를 점검할 필요가 있습니다. 다음과 비슷한 방법이면 됩니다.
$result = mysql_query("SELECT * FROM tables_priv");
if (!$result) {
    echo mysql_error();
    exit;
}
or
$result = mysql_query("SELECT * FROM tables_priv")
    or die("Bad query: ".mysql_error());

이전 | 처음으로 | 다음
PHP 구하기 | 위로 | 설치


설치

PHP 매뉴얼
이전 다음

48. 장. 설치

이 섹션은 PHP 설치에 관련되어 자주 문의되는 것들을 다룹니다. PHP는 거의 모든 OS에서 사용가능합니다 (현재까지 OS X 이전의 MacOS는 제외된다) 그리고 거의 모든 웹서버와 연동이 가능합니다.

PHP 설치시에는 설치 디렉토리(PHP소스를 압축풀어놓은곳)밑의 INSTALL파일에 적힌 설치방법을 따릅니다. 윈도우 사용자는 install.txt파일도 살펴봐야 합니다. 이 링크도 윈도우 사용자에게 도움이 됩니다.

1. 유닉스/윈도우: php.ini 파일은 어느곳에 있어야 합니까?
2. 유닉스: PHP를 설치했습니다. 그런데 PHP파일을 읽으려고 하면, 'Document Contains No Data'라는 메시지가 보입니다. 대체 뭐가 잘못된거죠?
3. 유닉스: RPM으로 PHP를 설치했습니다. 그런데 아파치가 PHP 페이지를 제대로 처리하지 못합니다.
4. 유닉스: RPM으로 PHP3를 설치했습니다. 그런데 필요한 데이터베이스와의 연동은 어떻게 해야 합니까?
5. 유닉스: 아파치를 Frontpage확장이 가능하도록 패치했습니다. 그런데 갑자기 PHP작동이 중단되었습니다. 아파치 FrontPage확장과 PHP는 호환되지 않습니까?
6. 유닉스/윈도우: PHP를 설치했습니다. 그런데 웹브라우저로 PHP스크립트 파일을 읽으려고 하면 하얀 화면만 보입니다.
7. 유닉스/윈도우: PHP를 설치했습니다. 웹브라우저로 PHP스크립트를 보려고 하면 500 서버 에러가 발생합니다.
8. 특정 운영체제: 에러없이 PHP를 설치했습니다. 그런데 아파치를 실행하려하면 undefined symbol error 가 발생합니다.
[mybox:user /src/php4] root# apachectl configtest
 apachectl: /usr/local/apache/bin/httpd Undefined symbols:
  _compress
  _uncompress
9. 윈도우: PHP를 설치했습니다. 그런데 웹브라우저로 PHP스크립트 파일을 보려하면 다음과 같은 에러가 발생합니다.
cgi error:
 The specified CGI application misbehaved by not
 returning a complete set of HTTP headers.
 The headers it did return are:
10. 윈도우: 모든 지시대로 따랐습니다. 그런데 여전히 PHP가 IIS와 연동이 되지 않습니다.
11. IIS나 PWS나 OmniHTTPD나 Xitami과 함께 PHP를 CGI로 실행시킬때, 다음과 같은 에러가 발생합니다. Security Alert! PHP CGI cannot be accessed directly..
12. 변경한 php.ini파일이 적용되고 있는지 어떻게 알수 있습니까? 설정이 변경된대로 적용이 되고 있는것 같지 않습니다.

1. 유닉스/윈도우: php.ini 파일은 어느곳에 있어야 합니까?

유닉스에서는 기본값이 /usr/local/lib입니다. <install-path>/lib과 같은 디렉토리입니다. --with-config-file-path이라는 옵션으로 그 위치를 변경할수 있습니다. 예를 들면,
--with-config-file-path=/etc
그리고 나서 설치 디렉토리 안의 php.ini-dist파일을 /etc/php.ini으로 복사하고 원하는 설정값으로 바꾸면 됩니다.

--with-config-file-scan-dir=PATH

윈도우에서는 php.ini위치 기본값은 윈도우(Windows) 디렉토리입니다. 아파치(Apache)가 설치되어 있으면, 최초 php.ini탐색 위치는 아파치 설치디렉토리가 됩니다. 즉 c:\program files\apache group\apache경로에서 제일 먼저 찾게 됩니다. 이런 방식으로 서로다른 아파치 버전별로 php.ini파일을 둘 수 있게 해줍니다.

설치 파일에 관한 챕터도 보세오.

2. 유닉스: PHP를 설치했습니다. 그런데 PHP파일을 읽으려고 하면, 'Document Contains No Data'라는 메시지가 보입니다. 대체 뭐가 잘못된거죠?

PHP의 에러로 인해 코어 덤프(core-dumping)가 되었을 가능성이 높습니다. 무슨 문제인지 알라보려면 웹서버의 에러 로그(error log)을 확인하세요. 좀더 원인을 밝히기 위해서는 에러가 일어나는 상황을 재연해야 합니다. gdb를 사용할줄 안다면, 버그 레포트(bug report)를 포함하는 실행추적(backtrace)를 개발자에게 보냄으로써 원인을 밝히는데 큰 도움을 줄 수 있습니다. 아파치 모듈로 PHP를 사용한다면 다음처럼 하세요.

  • 아파치 프로세스를 멈춘다

  • gdb httpd 명령을 실행한다

  • 아파치 프로세스를 멈춘다

  • > run -X -f /path/to/httpd.conf (gdb에서)

  • 웹브라우저에서 아까의 에러를 발생시키는 URL을 읽어들임

  • > run -X -f /path/to/httpd.conf (gdb에서)

  • 코어덤프(core dump)가 생긴다면, gdb는 이 사실을 보고함

  • type: bt

  • 버그 레포드(bug report)안에 실행추적(backtrace)한 과정을 넣어서 http://bugs.php.net/에 보내세요.

PHP스크립트 내에 정규표현식(regular expression)함수 (ereg()관련 함수들)를 사용하면 PHP와 아파치가 같은 정규표현식 패키지여야 합니다. 이것은 PHP와 아파치 1.3.x버전에서는 자동적으로 일치시켜줍니다.

3. 유닉스: RPM으로 PHP를 설치했습니다. 그런데 아파치가 PHP 페이지를 제대로 처리하지 못합니다.

아파치와 PHP 모두 RPM으로 설치했다고 가정하면, httpd.conf파일에서 주석 처리해줄 부분과 추가해줘야 할 부분이 있습니다. 다음 줄을 보고 설치된 버전에 맞게 처리해 주기 바랍니다.
# Extra Modules
AddModule mod_php.c
AddModule mod_php3.c
AddModule mod_perl.c

# Extra Modules
LoadModule php_module         modules/mod_php.so
LoadModule php3_module        modules/libphp3.so     /* for PHP 3 */
LoadModule php4_module        modules/libphp4.so     /* for PHP 4 */
LoadModule perl_module        modules/libperl.so
And add:
AddType application/x-httpd-php3 .php3    /* for PHP 3 */
AddType application/x-httpd-php .php      /* for PHP 4 */
아파치의 전역적인 설정으로 놓던가, 아니면 PHP를 지원해줄 버추얼 도메인(VirtualDomain)내에 설정하면 됩니다.

4. 유닉스: RPM으로 PHP3를 설치했습니다. 그런데 필요한 데이터베이스와의 연동은 어떻게 해야 합니까?

PHP3가 빌드되는 방법때문에, 유연한 PHP RPM을 만들기는 쉽지 않습니다. 이와 관련된 이슈가 PHP4에 설명이 되어있습니다. PHP3설치를 위해서는 PHP 설치디렉토리 밑의 INSTALL.REDHAT 파일을 참조하세요. PHP3를 RPM으로 설치하고자 한다면 반드시 읽어야 합니다.

RPM 배포자들은 설치를 단순화시키기 위해 데이터베이스 지원없이 설치되도록 설정해놓습니다. 그리고 또다른 이유는 RPM은 표준적인 /usr/local/이 아니라 /usr/디렉토리를 사용하기 때문입니다. 따라서 지원할 데이터베이스와 데이터베이스 서버의 상위디렉토리를 RPM spec 파일에 설정해야 합니다.

다음은 아파치의 모듈로 설치하여 MySQL 데이터베이스 지원이 되도록 설치하는 과정을 소개합니다.

여기에서 소개하는 것은 PHP를 지원하는 데이터베이스에 맞게 변경해야 합니다. 이 예는 RPM버전으로 MySQL과 아파치를 설치했다고 가정한것입니다.

  • 우선 mod_php3를 제거한다:
    rpm -e mod_php3

  • 그리고 소스 rpm을 구해서 설치한다, --rebuild가 아니다.
    rpm -Uvh mod_php3-3.0.5-2.src.rpm

  • /usr/src/redhat/SPECS/mod_php3.spec파일을 편집한다.

    %build 섹션에서 원하는 데이터베이스 지원에 관한 정보와 경로를 넣는다.

    MySQL일 경우에는
    --with-mysql=/usr \
    %build 섹션은 다음처럼 되었을것이다.
    ./configure --prefix=/usr \
    --with-apxs=/usr/sbin/apxs \
    --with-config-file-path=/usr/lib \
    --enable-debug=no \
    --enable-safe-mode \
    --with-exec-dir=/usr/bin \
    --with-mysql=/usr \
    --with-system-regex

  • 여기까지 되었으면 다음처럼 rpm 파일을 만든다:
    rpm -bb /usr/src/redhat/SPECS/mod_php3.spec

  • 그리고나서 rpm을 설치한다.
    rpm -ivh /usr/src/redhat/RPMS/i386/mod_php3-3.0.5-2.i386.rpm

아파치를 재시동합니다. 이제 RPM으로 MySQL 지원이 되는 PHP 3설치가 된것입니다. 이 방법은 PHP3의 타볼(tarball) 배포형식에서 설치하는 것보다 싶습니다. 그리고 INSTALL.REDHAT파일내의 지시대로 하면 됩니다.

5. 유닉스: 아파치를 Frontpage확장이 가능하도록 패치했습니다. 그런데 갑자기 PHP작동이 중단되었습니다. 아파치 FrontPage확장과 PHP는 호환되지 않습니까?

아닙니다. PHP는 FrontPage 확장과 잘 동작합니다. 문제는 FrontPage패치가 아파치의 구조를 변경시키는데 있습니다. 이 구조가 PHP와 관련되어있는부분입니다. FP 패치 후에 PHP를 다시 컴파일하세요(make clean; make). 그러면 해결됩니다.

6. 유닉스/윈도우: PHP를 설치했습니다. 그런데 웹브라우저로 PHP스크립트 파일을 읽으려고 하면 하얀 화면만 보입니다.

웹브라우저에서 '소스 보기'를 해보면 PHP스크립트의 소스를 볼수도 있습니다. 이것은 웹서버가 PHP를 해석한 후에 보내주지 않았다는 것이고, 웹서버 설정이 잘못되었다는 것입니다. PHP와 관련되어 있는 서버 설정을 다시 점검하십시오.

7. 유닉스/윈도우: PHP를 설치했습니다. 웹브라우저로 PHP스크립트를 보려고 하면 500 서버 에러가 발생합니다.

이 에러는 웹서버가 PHP를 실행하려고 할때 무슨 문제가 있다는것입니다. 좀더 구체적인 에러 메시지를 보려면, 커맨드 라인에서 PHP 실행파일 (윈도우는 php.exe)이 있는 디렉토리로 이동하세요. 그리고 php -i명령을 실행하세요. PHP가 어떤 문제가 있다면, 관련된 에러 메시지가 보일것입니다. 이 에러메시지를 통해서 다음에 해야할 일들을 위한 단서를 얻을 수 있습니다. PHP의 html변환된 코드를 볼수 있다면(phpinfo()함수의 실행결과) PHP는 작동하는것입니다다. 웹서버 설정과 관련된 문제라면, 다시 점검하십시오.

8. 특정 운영체제: 에러없이 PHP를 설치했습니다. 그런데 아파치를 실행하려하면 undefined symbol error 가 발생합니다.
[mybox:user /src/php4] root# apachectl configtest
 apachectl: /usr/local/apache/bin/httpd Undefined symbols:
  _compress
  _uncompress

이 에러는 PHP와 관련된것이 아닙니다. MySQL의 클라이언트 라이브러리 (client libraris)와 관련된 문제입니다. --with-zlib옵션이 필요할수도 있습니다. 이것과 관련된 문제는 MySQL FAQ를 참조하세요.

9. 윈도우: PHP를 설치했습니다. 그런데 웹브라우저로 PHP스크립트 파일을 보려하면 다음과 같은 에러가 발생합니다.
cgi error:
 The specified CGI application misbehaved by not
 returning a complete set of HTTP headers.
 The headers it did return are:

이 에러 메시지는 PHP가 출력에 실패했다는것을 의미합니다. 좀더 구체적인 에러 메시지를 보려면, 커맨드 라인에서 PHP 실행파일 (윈도우는 php.exe)이 있는 디렉토리로 이동하세요. 그리고 php -i명령을 실행하세요. PHP가 어떤 문제가 있다면, 관련된 에러 메시지가 보일것입니다. 이 에러메시지를 통해서 다음에 해야할 일들을 위한 단서를 얻을 수 있습니다. PHP의 html변환된 코드를 볼수 있다면(phpinfo()함수의 실행결과) PHP는 작동하는것입니다.

PHP가 커맨드 라인에서 일단 잘동한다면, 다시 웹브라우저상에서 접근을 시도합니다. 아직도 문제가 발생한다면 원인은 다음중에 있을 가능성이 있습니다.

  • PHP 스크립트 파일, php.exe, php4ts.dll, php.ini 그리고 다른 PHP 확장 파일들은 익명 인터넷 유저(anonymous internet user) 인 ISUR_<machinename> 가 접근할 수 있도록 파일 권한을 설정해야 합니다.

  • 이 스크립트 파일이 존재하지 않는것입니다 (또는 웹서버의 루트 디렉토리와 관련되어 있는 그 파일이 거기 없던가). IIS에서는 인터넷 서버 매니저(Internet Server Manager)내의 스크립트 매핑을 설정할 때 'check file exists'박스를 클릭함으로써 이 에러를 잡을수 있습니다. 스크립트가 거기에 없다면 웹서버는 404에러를 발생시킵니다. There is also the additional benefit that IIS will do any authentication required for you based on the NTLanMan permissions on your script file.

10. 윈도우: 모든 지시대로 따랐습니다. 그런데 여전히 PHP가 IIS와 연동이 되지 않습니다.

PHP를 실행시키려고 하는 유저가 php.exe를 실행할 권한이 있는지 확인하세요! IIS는 익명 유저(anonymouse user)가 필요합니다. 이 유저는 IIS 가 설치될때 추가됩니다. 이 유저가 php.exe 을 실행시킬 권한이 필요합니다. 또한, 다른 검증된 유저도 php.exe를 실행시킬 권한이 필요합니다. IIS4에서는 PHP가 스크립트 엔진이라는것을 알려줄필요가 있습니다. 좀 더 알아보려면, 이 faq 를 참조하세요.

11. IIS나 PWS나 OmniHTTPD나 Xitami과 함께 PHP를 CGI로 실행시킬때, 다음과 같은 에러가 발생합니다. Security Alert! PHP CGI cannot be accessed directly..

cgi.force_redirect를 0으로 놓아야 합니다. 기본값(default)은 1 입니다. 모든 설정치(directive)는 php.ini파일에서 설정됩니다.

기본값(default)는 1이기 때문에 현재의 php.ini파일이 적용되는지 확인하는것이 매우 중요하다. 더 자세한 것은 이 faq를 참고하세요.

12. 변경한 php.ini파일이 적용되고 있는지 어떻게 알수 있습니까? 설정이 변경된대로 적용이 되고 있는것 같지 않습니다.

php.ini파일이 PHP에 의해 읽히고 있는지 확인하기 위해서는 phpinfo()를 실행시켜서 제일 윗쪽에 Configuration File (php.ini)부분을 확인해야 합니다다. 이 부분을 보면 PHP가 어디에서 php.ini파일을 찾는지 알수 있습니다. 단지 디렉토리 경로(PATH)만 존재한다면 읽히지 않는것입니다. 그 경로로 php.ini파일을 놓아야 합니다. 그 경로 안에 php.ini도 같이 있으면 읽히고 있는것입니다.

php.ini파일이 읽히고 있지 않고 모듈로 PHP가 실행되고 있다면 php.ini파일을 변경한 후에 PHP를 재시동해야 합니다.

이전 | 처음으로 | 다음
데이터베이스와 관련된 문제 | 위로 | 빌드(build)시의 문제


빌드(build)시의 문제

PHP 매뉴얼
이전 다음

49. 장. 빌드(build)시의 문제

이 절은 빌드 시에 가장 자주 발생하는 에러에 대해서 정리합니다.

1. 익명 CVS 서버스에서 PHP의 가장 최종 버전을 가져왔습니다. 그런데 거기에는 configure 스크립트가 없네요!?
2. 아파치와 연동하여 PHP 를 설정하려 하는데 문제가 발생합니다. httpd.h를 찾을 수 없다는 군요. 하지만 그 파일은 거기에 있거든요!
3. PHP를 설정하려 하는데 (./configure), 다음과 같은 에러 를 본적이 있습니까?
4. 제가 아파치를 시작하려하면, 다음과 같은 메시지가 뜹니다.
5. configure를 실행하려하는데, GD, gdbm 이나 다른 패키지에 대한 라이브러리(library)와 인클루드(include) 파일을 읽지 못한다는 에러가 나네요!
6. language-parser.tab.c파일을 컴파일할때, yytname undeclared라는 에러메시지를 보여주네요.
7. make명령을 실행시킬때, 처음엔 잘나가다가 마지막에서 프로그램을 링크하려고 할때 특정 파일을 찾지 못한다고 하며 종료되어 버립니다.
8. PHP를 링크할때, 엄청나게 많은 수의 undefined reference 에러메시지를 뿌려줍니다.
9. 아파치 1.3 버전과 같이 설치하는 방법을 잘 모르겠습니다.
10. UNIX상에서 아파치 모듈을 인스톨하기 위한 모든 단계를 따라했습니다. 그리고 브라우저에서 PHP 스크립트를 보려고하면 저장하겠냐고 묻습니다.
11. --activate-module=src/modules/php4/libphp4.a옵션으로 실행하라고 하지만 그 파일은 존재하지않습니다. 그래서 --activate-module=src/modules/php4/libmodphp4.a으로 변경을 했습니다. 근데, 제대로 설치가 안되네요!? 무엇이 잘못되었나요?
12. PHP를 정적인 모듈로 아파치와 연동하려고 --activate-module=src/modules/php4/libphp4.a 옵션으로 빌드하려 했습니다. 그런데 컴파일러가 ANSI 호환이 아니라고 나옵니다.
13. --with-apxs옵션으로 PHP를 빌드하려고 하는데 이상한 메시지를 봤습니다.
14. make명령 실행 중에 몇몇개의 에러메시지와 많은 RUSAGE_관련 에러 메시지가 발생합니다.
15. MySQL과 연동하여 PHP를 컴파일하려고 할때 configure는 잘 진행되지만 make명령 실행중에는 다음과 같은 에러가 납니다. ext/mysql/libmysql/my_tempnam.o(.text+0x46): In function my_tempnam': /php4/ext/mysql/libmysql/my_tempnam.c:103: the use of tempnam' is dangerous, better use mkstemp', 무엇이 잘못된 건가요?
16. PHP를 업그레이드 하고 싶습니다. 현재 PHP 설치를 위해 사용되었던 ./configure 실행 옵션을 어디서 발견할수 있습니까?
17. GD라이브러리와 연동하여 PHP를 빌드하려 하면 이상한 컴파일 에러를 보이거나 실행중 세그먼테이션 폴트(segfault)를 발생시킵니다.
18. When compiling PHP I seemingly get random errors, like it hangs. I'm using Solaris if that matters.

1. 익명 CVS 서버스에서 PHP의 가장 최종 버전을 가져왔습니다. 그런데 거기에는 configure 스크립트가 없네요!?

configure.in파일이 configure 스크립트를 생성할수 있도록 GNU autoconf 패키지가 설치되어 있어야 합니다. 그리고 나서 CVS 서버에서 소스를 가져오신 후에 최상위 디렉토리에서 ./buildconf명령을 실행하세요. (또한, --enable-maintainer-mode옵션으로 configure를 실행하지 않으면, configure.in파일이 갱신되었을때, configure 스크립트는 자동적으로 재생성 되지 않을겁니다. 그래서 configure.in 파일이 갱신되었다는것을 알고나서 손수 재생성해야 할것입니다. 이것을 알아챌수 있는 방법은 configure 나 config.status이 실행된후 Makefile의 @VARIABLE@같은 것을 찾아 보는 것입니다.)

2. 아파치와 연동하여 PHP 를 설정하려 하는데 문제가 발생합니다. httpd.h를 찾을 수 없다는 군요. 하지만 그 파일은 거기에 있거든요!

configure/setup 스크립트에게 아파치 소스 트리의 최상위 디렉토리의 위치를 알려줄 필요가 있습니다. 즉, --with-apache=/path/to/apache을 적어주세요. --with-apache=/path/to/apache/src이 아닙니다.

3. PHP를 설정하려 하는데 (./configure), 다음과 같은 에러 를 본적이 있습니까?

checking lex output file root... ./configure: lex: command not found
       configure: error: cannot find output from lex; giving up

installation섹션을 주의깊게 읽어보세요. PHP를 컴파일하기 위해서는 flex와 bison 이 필요합니다. bison과 flex를 소스나 RPM패키지를 구해서 설치하세요.

4. 제가 아파치를 시작하려하면, 다음과 같은 메시지가 뜹니다.

fatal: relocation error: file /path/to/libphp4.so:
       symbol ap_block_alarms: referenced symbol not found

이 에러는 공유 사용 목적의 DSO 라이브러리로 아파치 프로그램을 컴파일 할때 주로 발생합니다. 아파치를 재설정(reconfigure)하세요 최소한 다음 옵션이 붙어야 합니다.

--enable-shared=max --enable-rule=SHARED_CORE

더 자세한 정보는 아파치 디렉토리의 최상위에 위치한 INSTALL 파일이나 아파치의 DSO manual page를 보세요.

5. configure를 실행하려하는데, GD, gdbm 이나 다른 패키지에 대한 라이브러리(library)와 인클루드(include) 파일을 읽지 못한다는 에러가 나네요!

비표준적인 위치에 존재하는 헤더파일이나 라이브러리를 찾을 수 있도록 configure 스크립트를 조정할수 있습니다. C 전처리기나 링커를 넘겨주기 위한 다음과같은 플래그를 설정함으로써 가능합니다.
CPPFLAGS=-I/path/to/include LDFLAGS=-L/path/to/library ./configure
로그인 셸이 csh계열이라면(왜?) 다음처럼 처리합니다
env CPPFLAGS=-I/path/to/include LDFLAGS=-L/path/to/library ./configure

6. language-parser.tab.c파일을 컴파일할때, yytname undeclared라는 에러메시지를 보여주네요.

Bison 을 업그레이드할필요가 있습니다. http://www.gnu.org/software/bison/bison.html에서 최신버전을 받을수 있을겁니다.

7. make명령을 실행시킬때, 처음엔 잘나가다가 마지막에서 프로그램을 링크하려고 할때 특정 파일을 찾지 못한다고 하며 종료되어 버립니다.

make의 구버전 중 일부는 functions 디렉토리안에 functions 디렉토리에 들어있는 파일을 정확하게 옮겨놓지 못합니다. cp *.o functions 명령을 실행하고 나서 make명령을 재실행시켜보세요. 이래도 똑같은 증상을 보이면, GNU make를 최신버전으로 업그레이드하세요

8. PHP를 링크할때, 엄청나게 많은 수의 undefined reference 에러메시지를 뿌려줍니다.

링크 관련 줄을 보고 정확하게 라이브러리가 설정되었는지 확인하기 바랍니다. 보통 '-ldl'이라는 옵션을 빠뜨리거나, 데이터베이스 지원을 위한 라이브러리를 빠뜨린 경우가 대부분입니다.

아파치 1.2.x 버전과 같이 설치하는것이라면, 설정파일의 EXTRA_LIBS에 적절한 정보를 추가했는지, 아파치 설정 스크립트를 재실행했는지 확인하세요. 아파치에 포함되어있는 INSTALL파일을 확인하는것도 도움이 될것입니다.

어떤분들의 보고에 따르면 아파치와 같이 설치할때에는 libphp4.a파일 다음에 '-ldl'옵션을 추가해야한다고 합니다.

9. 아파치 1.3 버전과 같이 설치하는 방법을 잘 모르겠습니다.

매우 쉽습니다. 다음 단계를 차근차근 따라해보세요.

  • http://www.apache.org/dist/httpd/에서 아파치 1.3 최신 버전을 다운받는다.

  • 그 파일을 특정 디렉토리에 압축을 풉니다. 예를 들면, /usr/local/src/apache-1.3와 같은 디렉토리가 될수 있습니다.

  • 우선 다음명령을 실행시킵니다. ./configure --with-apache=/<path>/apache-1.3 (여기서 <path>는 아파치 1.3 디렉토리의 실제 경로로 대치하십시오.

  • 그리고 make명령과 make install명령을 차례대로 실행시킵니다. 이것이 완료되면 아파치의 하위 디렉토리에 필요한 파일들이 복사가 되는것입니다.

  • /<path>/apache-1.3/src디렉토리로 들어가서 Configuration파일을 변경하십시오. 설정 파일에 다음줄을 추가하세요. AddModule modules/php4/libphp4.a.

  • Type: ./configure명령실행후에 make명령을 실행하면 됩니다.

  • 이제 PHP가 연동되는 아파치 실행파일이 생겼을겁니다!

Note: 새로운 아파치의 ./configure스크립트 를 사용할수 있습니다. 아파치 디렉토리의 README.configure파일을 보거나, PHP 디렉토리의 INSTALL파일을 참고하세요.

10. UNIX상에서 아파치 모듈을 인스톨하기 위한 모든 단계를 따라했습니다. 그리고 브라우저에서 PHP 스크립트를 보려고하면 저장하겠냐고 묻습니다.

이것은 어떤 이유로 PHP 모듈을 제대로 불려오지 못한 결과입니다. 우선은 다음의 세가지 경우를 체크하시기 바랍니다

  • 현재 실행되고있는 아파치의 실행파일이 새로 빌드된 실행파일인지 확인해야 합니다. 다음 명령을 실행하세요 /path/to/binary/httpd -l

    출력된 리스트중에서 mod_php4.c파일이 보이지 않으면, 잘못된 파일을 실행하고 있는것입니다. 올바른 파일을 찾아서 실행하세요.

  • 아파치의 .conf파일에 다음과 같은 Mime 타입 설정을 추가했는지 확인하세요. AddType application/x-httpd-php3 .php3 (for PHP 3)

    또는 AddType application/x-httpd-php .php (for PHP 4)

    그리고 <Virtualhost> 이나 <Directory> 블록안에 이 AddType 줄이 숨겨져 있는지 확인하시기 바랍니다. 이렇게 되면 PHP 스크립트의 위치에 따라서 적용이 안될수 있기 때문입니다.

  • 마지막으로, 아파치 1.2와 아파치 1.3 버전간에 설정파일의 기본(default) 디렉토리가 바뀔수도 있습니다. 따라서 실질적으로 AddType 줄이 추가된 설정파일이 정확한 위치에 있는지 체크해야 합니다. httpd.conf파일에 일부러 문법에러(Syntax error)를 일으킬만한 설정을 해보거나 다른 방법으로 이 파일이 실제로 적용되는 파일인지 확인할수 있습니다.

11. --activate-module=src/modules/php4/libphp4.a옵션으로 실행하라고 하지만 그 파일은 존재하지않습니다. 그래서 --activate-module=src/modules/php4/libmodphp4.a으로 변경을 했습니다. 근데, 제대로 설치가 안되네요!? 무엇이 잘못되었나요?

처음에는 libphp4.a파일은 존재하지 않습니다. 그 파일은 아파치 설치 과정중에 생기는것입니다!

12. PHP를 정적인 모듈로 아파치와 연동하려고 --activate-module=src/modules/php4/libphp4.a 옵션으로 빌드하려 했습니다. 그런데 컴파일러가 ANSI 호환이 아니라고 나옵니다.

이 에러 메시지는 잘못된 것입니다. 요즘의 아파치버전은 이런 에러 메시지가 수정되었다고 합니다.

13. --with-apxs옵션으로 PHP를 빌드하려고 하는데 이상한 메시지를 봤습니다.

이경우에는 다음 세가지 경우를 확인해봐야 합니다. 첫째, 아파치가 apxs 펄 스크립트를 빌드 할때, 어떤 이유로 종종 적절한 컴파일러와 플래그 변수(flag variables)들 없이 끝나버리는 경우가 있습니다. ( which apxs 명령을수행) 대부분 /usr/local/apache/bin/apxs나 /usr/sbin/apxs 인 경우가 많습니다. 그 파일을 열어서 다음과 비슷한지 점검하십시오.
my $CFG_CFLAGS_SHLIB  = ' ';          # substituted via Makefile.tmpl
my $CFG_LD_SHLIB      = ' ';          # substituted via Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = ' ';          # substituted via Makefile.tmpl
이렇게 되어있다면 이것이 바로 문제입니다. 이외에 공백이나 잘못된 값이 채워져있을수 있습니다. 예를 들어서 'q()' 같은 경우입니다. 이 줄들은 다음으로 변경합니다
my $CFG_CFLAGS_SHLIB  = '-fpic -DSHARED_MODULE'; # substituted via Makefile.tmpl
my $CFG_LD_SHLIB      = 'gcc';                   # substituted via Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = q(-shared);              # substituted via Makefile.tmpl
두번째는 레드햇 6.1과 레드햇 6.2에 관련된 경우입니다. 레드햇 배포판의 apxs가 깨지는 경우인데. 다음처럼 되어있습니다
my $CFG_LIBEXECDIR    = 'modules';         # substituted via APACI install
이렇다면 다음으로 변경합니다
my $CFG_LIBEXECDIR    = '/usr/lib/apache'; # substituted via APACI install
마지막으로, 아파치를 재설정/재설치했을경우에 make clean 명령을 ./configure 명령 후와 make 명령 전에 실행해보는 것입니다.

14. make명령 실행 중에 몇몇개의 에러메시지와 많은 RUSAGE_관련 에러 메시지가 발생합니다.

make명령 실행 중에 다음과 비슷한 상황이 벌어진다면:
microtime.c: In function `php_if_getrusage':
microtime.c:94: storage size of `usg' isn't known
microtime.c:97: `RUSAGE_SELF' undeclared (first use in this function)
microtime.c:97: (Each undeclared identifier is reported only once
microtime.c:97: for each function it appears in.)
microtime.c:103: `RUSAGE_CHILDREN' undeclared (first use in this function)
make[3]: *** [microtime.lo] Error 1
make[3]: Leaving directory `/home/master/php-4.0.1/ext/standard'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/master/php-4.0.1/ext/standard'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/master/php-4.0.1/ext'
make: *** [all-recursive] Error 1

당신의 시스템은 정상이 아닙니다. glibc-devel 패키지를 설치해서 /usr/include밑의 파일들을 고칠필요가 있습니다. 이것이 PHP를 위해 절대적인것은 아닙니다. 이런것을 해결하기 위해서는 다음과 같은 테스트를 해보세요.
$ cat >test.c <<X
#include <sys/resource.h>
X
$ gcc -E test.c >/dev/null
이 테스트 결과 에러가 발생한다면 그 include파일들은 확실히 정상이 아닙니다.

15. MySQL과 연동하여 PHP를 컴파일하려고 할때 configure는 잘 진행되지만 make명령 실행중에는 다음과 같은 에러가 납니다. ext/mysql/libmysql/my_tempnam.o(.text+0x46): In function my_tempnam': /php4/ext/mysql/libmysql/my_tempnam.c:103: the use of tempnam' is dangerous, better use mkstemp', 무엇이 잘못된 건가요?

우선, 이것이 경고(Warning)이고 치명적인 에러(Fatal Error)가 아니라는 것을 파악하는 것이 중요합니다. 이 메시지들이 make명령이 실행되는 동안 종종 마지막에 나오기 때문에 치명적인 에러(Fatal Error)처럼 보일지도 모르지만, 그렇지는 않습니다. 즉 컴파일러가 경고(Warning)메시지를 안보이도록 할수 있다면, 아무 메시지도 보여주지 않게 되는것입니다. 또 명심할것은 MySQL 은 기본적으로(default) 지원이 된다는것입니다.

16. PHP를 업그레이드 하고 싶습니다. 현재 PHP 설치를 위해 사용되었던 ./configure 실행 옵션을 어디서 발견할수 있습니까?

현재 PHP설치 디렉토리의 config.nice 파일이나 다음스크립트를 실행시키면 확인할수 있습니다.
<?php phpinfo(); ?>
이 스크립트의 결과 페이지에서 상단에 ./configure실행 옵션이 보이므로 그 옵션을 쓰시면 됩니다.

17. GD라이브러리와 연동하여 PHP를 빌드하려 하면 이상한 컴파일 에러를 보이거나 실행중 세그먼테이션 폴트(segfault)를 발생시킵니다.

GD라이브러리와 PHP가 관련 라이브러리(예를 들면, libpng)와 제대로 링크가 되었는지 확인하십시오.

18. When compiling PHP I seemingly get random errors, like it hangs. I'm using Solaris if that matters.

Using non-GNU utilities while compiling PHP may cause problems. Be sure to use GNU tools in order to be certain that compiling PHP will work. For example, on Solaris, using either the SunOS BSD-compatible or Solaris versions of sed will not work, but using the GNU or Sun POSIX (xpg4) versions of sed will work. Links: GNU sed, GNU flex, and GNU bison.

이전 | 처음으로 | 다음
설치 | 위로 | PHP 사용하기


PHP 사용하기

PHP 매뉴얼
이전 다음

50. 장. PHP 사용하기

이 섹션은 PHP스크립트를 작성할때 직면할수 있는 매우 일반적인 에러를 정리했습니다.

1. 폼으로부터 데이터를 제어할수 있는 PHP스크립트를 작성하려합니다. POST 메쏘드에서 사용가능한 변수를 알 수 있을까요?
2. 작은따옴표(')에 역슬래쉬를 앞에(\') 붙여줄 필요가 있습니다. 이와 같은 일은 어떻게 정규표현식(regular expression)으로 처리할수 있을까요? 그리고 "를 \"로, \를 \\로 변환하고 싶습니다.
3. All my " turn into \" and my ' turn into \', how do I get rid of all these unwanted backslashes? How and why did they get there? "은 \"으로, '는 \'으로 변경이 되어있습니다. 어떻게하면 이런 원치않는 역슬래쉬를 제거할수 있을까요? 어떻게 그리고 왜 이런 역슬래쉬가 생긴거죠?
4. 다음과 같은 처리를 할때, 출력이 잘못된 순서로 됩니다:
<?php
function myfunc($argument)
{
    echo $argument + 10;
}
$variable = 10;
echo "myfunc($variable) = " . myfunc($variable);
?>
무엇이 잘못된건가요?
5. 헤이, 새줄(newline)이 왜 안생기나요?
<pre>
<?php echo "This should be the first line."; ?>
<?php echo "This should show up after the new line above."; ?>
</pre>
6. 'Warning: Cannot send session cookie - headers already sent...' 나 'Cannot add header information - headers already sent...'같은 메시지를 봤습니다.
7. 요청 헤더값을 직접 확인하고 싶습니다. 어떻게 하면 되죠?
8. IIS로 인증을 하려합니다. 그런데 'No Input file specified'과 같은 메시지가 출력되는군요.
9. PHP 스크립트는 IE와 Lynx에서는 동작을 합니다. 그러나 네스케이프에서는 출력의 일부가 사라져버립니다. "소스보기"를 하면 IE에서는 볼수 있지만 네스케이프에서는 볼수없습니다.
10. 어떻게 XML과 PHP를 섞어쓸수 있다고 생각할수 있습니까? <?xml태그에 불만을 터트린단 말입니다!
11. 이미 짜여진 코드를 옮기기 위해서 FrontPage나 다른 HTML 편집기를 어떻게 사용할수 있습니까?
12. PHP에서 가용한 모든 변수 목록을 어디서 볼수 있습니까?
13. 유료이고 상용 라이브러리인 ClibPDF와 PDFLib를 사용하지 않고 어떻게 하면 PDF 파일을 만들수 있습니까? 무료이면서 외부의 PDF 라이브러리가 필요없는 것을 사용하고 싶습니다.
14. 유저 정의 함수에서 표준적인 CGI변수($DOCUMENT_ROOT나 $HTTP_REFERER)중 하나에 접근하여하였습니다. 그런데 그 변수를 찾을수가 없는것처럼 보입니다. 무엇이 잘못된건가요?

1. 폼으로부터 데이터를 제어할수 있는 PHP스크립트를 작성하려합니다. POST 메쏘드에서 사용가능한 변수를 알 수 있을까요?

PHP는 많은 미리 정의된 변수들 을 갖습니다. 슈퍼 글로벌(superglobal)변수인 $_POST처럼요. $_POST변수는 포스팅된 모든 변수의 연관배열이기 때문에 이 변수로 루프를 돌릴수도 있다. 예를 들어서 간단하게 foreach로 루프를 돌린다고 하면 empty()함수 값을 체크하고 그 값을 출력하면된다.
<?php
$empty = $post = array();
foreach ($_POST as $varname => $varvalue) {
    if (empty($varvalue)) {
        $empty[$varname] = $varvalue;
    } else {
        $post[$varname] = $varvalue;
    }
}

print "<pre>";
if (empty($empty)) {
    print "None of the POSTed values are empty, posted:\n";
    var_dump($post);
} else {
    print "We have " . count($empty) . " empty values\n";
    print "Posted:\n"; var_dump($post);
    print "Empty:\n";  var_dump($empty);
    exit;
}
?>

자동 전역: 사용상 주의: PHP 4.1.0부터, $_GET, $_POST, $_SERVER 등의 자동 전역 배열을 사용할 수 있습니다. 더 자세한 내용은 매뉴얼 superglobals 섹션을 읽어보십시오.

2. 작은따옴표(')에 역슬래쉬를 앞에(\') 붙여줄 필요가 있습니다. 이와 같은 일은 어떻게 정규표현식(regular expression)으로 처리할수 있을까요? 그리고 "를 \"로, \를 \\로 변환하고 싶습니다.

addslashes()함수로 이와 같은 일을 처리할수있습니다.
mysql_escape_string()함수도 참고하십시오.
또한 stripslashes()함수로 역슬래쉬를 벗길 수 있습니다.

directive 주의: magic_quotes_gpc: PHP 설정 magic_quotes_gpc의 기본값은 on입니다. 이것은 모든 GET, POST, COOKIE 데이터에 대해 addslashes()를 실행합니다. 이를 제거하기 위해서 stripslashes()를 사용할 수 있습니다.

3. All my " turn into \" and my ' turn into \', how do I get rid of all these unwanted backslashes? How and why did they get there? "은 \"으로, '는 \'으로 변경이 되어있습니다. 어떻게하면 이런 원치않는 역슬래쉬를 제거할수 있을까요? 어떻게 그리고 왜 이런 역슬래쉬가 생긴거죠?

stripslashes()함수로 이 string에서 이런 역슬래쉬를 벗길수가 있습니다. 이런 마술적인 역슬래쉬가 존재하는 이유는 magic_quotes_gpc옵션이 활성화되어 있기 때문입니다.

directive 주의: magic_quotes_gpc: PHP 설정 magic_quotes_gpc의 기본값은 on입니다. 이것은 모든 GET, POST, COOKIE 데이터에 대해 addslashes()를 실행합니다. 이를 제거하기 위해서 stripslashes()를 사용할 수 있습니다.

4. 다음과 같은 처리를 할때, 출력이 잘못된 순서로 됩니다:
<?php
function myfunc($argument)
{
    echo $argument + 10;
}
$variable = 10;
echo "myfunc($variable) = " . myfunc($variable);
?>
무엇이 잘못된건가요?

이 함수의 결과를 사용하기 위해서는 (위 예처럼 다른 스트링과 합치는) echo() 함수대신에 return()를 사용해야 합니다.

5. 헤이, 새줄(newline)이 왜 안생기나요?
<pre>
<?php echo "This should be the first line."; ?>
<?php echo "This should show up after the new line above."; ?>
</pre>

PHP에서는 코드 블럭이 "?>" 나 "?>\n"로 끝날수 있습니다. 그래서 위 예에서 문장은 한줄로 출력이 될것입니다. 왜냐하면 블럭의 끝에 새줄표시(newline)를 빠뜨렸기 때문이요. 이와 같은 이유로 새줄쓰기를 하려면 각 블럭의 끝에 새줄표시(newline)를 해줘야합니다.

왜 이와같은 일을 할까요? 왜냐하면 일반적인 HTML을 만들때, 새줄을 쓰지 않고 매우 긴 줄을 만들거나 이런 효과를 이용해서 읽을수 없는 소스 페이지 를 만들어야 할때도 있기 때문이고,이는 당신의 삶을 좀더 안락하게 해줍니다.

6. 'Warning: Cannot send session cookie - headers already sent...' 나 'Cannot add header information - headers already sent...'같은 메시지를 봤습니다.

header()함수, setcookie()함수, 세션 함수는 헤더에 출력을 합니다. 그러나 헤더는 모든 다른 컨텐트 전에 와야 합니다. 이 함수를 사용하기 전에 어떤 출력(HTML같은)도 있어서는 안됩니다. headers_sent()함수가 스크립트에서 이미 헤더를 보냈는지 체크해줍니다. Output Control Functions도 참고하세요.

7. 요청 헤더값을 직접 확인하고 싶습니다. 어떻게 하면 되죠?

아파치 모듈로 PHP설치하셨다면 getallheaders()함수로 이와 같은 일을 할수 있습니다. 다음과 같은 코드로 요청 헤더의 모든값을 확인하실수 있습니다:
<?php
$headers = getallheaders();
foreach ($headers as $name => $content) {
    echo "headers[$name] = $content<br>\n";
}
?>

apache_lookup_uri(),
apache_response_headers(),
fsockopen()함수도 참고하세요.

8. IIS로 인증을 하려합니다. 그런데 'No Input file specified'과 같은 메시지가 출력되는군요.

IIS의 보안 모델은 여기서 결함이 있습니다. 이와같은 결함은 IIS하에서 실행되는 모든 CGI 프로그램에 있어서는 일반적인 현상입니다. 이와같은 에러를 피하는 방법으로는 일반 HTML 파일(PHP에 의해 파싱되지 않음)을 인증이 필요한 디렉토리 안에 엔트리 페이지로 만들어넣는것입니다. 그리고 나서 PHP 페이지로 리디렉트(redirect)하는 META 태그를 사용하거나, PHP 페이지로 링크를 거십시오. 이와같은 현상은 다른 NT 웹서버와는 상관이 없습니다. 더 많은 정보를 위해서 아래 링크로 가세요: http://support.microsoft.com/support/kb/articles/q160/4/22.asp 과 HTTP Authentication의 매뉴얼 섹션.

9. PHP 스크립트는 IE와 Lynx에서는 동작을 합니다. 그러나 네스케이프에서는 출력의 일부가 사라져버립니다. "소스보기"를 하면 IE에서는 볼수 있지만 네스케이프에서는 볼수없습니다.

네스케이프는 html 태그(테이블같은)에 관한한 IE보다 엄격합니다. validator.w3.org와 같은 html validator로 html 출력을 검증한다면 무엇이 문제인지 도움을 받을수 있습니다. 예를 들면, </table> 태그가 빠지면 이와같은 문제가 발생할수 있습니다.

또한 IE와 Lynx 모두 HTML 스트림(stream)에서 널문자(\0)를 무시 하지만, 네스케이프는 그렇지 않습니다. 이 널문자를 체크하기위한 최고의 방법은 PHP의 커맨드 라인(command line)버전 (또는 CGI버전으로도 알려져있슴)으로 컴파일해서 그 커맨드라인에서 스크립트를 실행해 보는것입니다. *nix에서 스크립트를 od -c로 파이프(pipe)해서 \0문자가 있는지 찾아보는것입니다. 윈도우상에서는 에디터나 바이너리 파일을 볼수 있는 다른 프로그램이 있어야 합니다. 네스케이프는 파일 안에서 널값을 봤을때 표준적으로 그 라인안의 어떤것도 출력하지 않습니다. 반면에 IE와 Lynx는 출력해줍니다.

10. 어떻게 XML과 PHP를 섞어쓸수 있다고 생각할수 있습니까? <?xml태그에 불만을 터트린단 말입니다!

<?xml태그를 PHP코드안에 직접 넣기 위해서는 short_open_tags PHP 디렉티브 값을 0으로 설정함으로써 짧은 태그(short tags)를 비활성화해야 합니다. ini_set()함수로 이 디렉티브를 설정할수 없습니다. short_open_tags가 on이든 off든 관계없이 다음처럼 할수도 있습니다: <?php echo '<?xml'; ?> 이 디렉티브의 기본값(default)은 on입니다.

11. 이미 짜여진 코드를 옮기기 위해서 FrontPage나 다른 HTML 편집기를 어떻게 사용할수 있습니까?

가장 쉬운 방법은 PHP코드안에서 ASP 태그 사용하기를 활성화시키는 것입니다. 이렇게 하면 <%와 %>의 ASP 스타일 코드 경계기호(delimiter)를 사용할 수 있게해줍니다. 몇몇 유명한 HTML 펴집기는 매우 지능적으로 이런 태그를 다루어줍니다(현재까지는). ASP 스타일 태그를 활성화시키려면 php.ini의 asp_tags를 활성화시키거나, 적절한 아파치 디렉티브(directive)를 사용해야합니다.

12. PHP에서 가용한 모든 변수 목록을 어디서 볼수 있습니까?

미리 정의된 변수에 관한 매뉴얼 페이지를 보십시오. 이 페이지에서는 일부의 미리 정의된 변수 목록이 포함되어있습니다. 모든 변수 목록은 phpinfo()함수를 호출함으로써 확인하실수 있습니다. PHP밖에서 온 변수들의 매뉴얼 섹션을 읽으십시오. 그페이지에서는 HTML폼, 쿠키, URL같은 외부변수에 관한 일반적인 시나리오를 설명해줍니다.

register_globals: 중요 경고: PHP 4.2.0부터는 PHP 설정 register_globals의 기본값은 off입니다. PHP 커뮤니티에서는, 이 설정에 의존하지 않는 superglobals와 같은 다른 방법을 이용하기를 권장합니다.

13. 유료이고 상용 라이브러리인 ClibPDF와 PDFLib를 사용하지 않고 어떻게 하면 PDF 파일을 만들수 있습니까? 무료이면서 외부의 PDF 라이브러리가 필요없는 것을 사용하고 싶습니다.

이와같은 상용라이브러리를 대체하기 위해 PHP로 쓰여진것이 있습니다. 다음과 같습니다. http://www.ros.co.nz/pdf/, http://www.fpdf.org/, http://www.gnuvox.com/pdf4php/, and http://www.potentialtech.com/ppl.php. 이와 더불어 Panda모듈도 있습니다.

14. 유저 정의 함수에서 표준적인 CGI변수($DOCUMENT_ROOT나 $HTTP_REFERER)중 하나에 접근하여하였습니다. 그런데 그 변수를 찾을수가 없는것처럼 보입니다. 무엇이 잘못된건가요?

PHP 디렉티브 register_globals은 서버와 환경변수에 모두 영향을 미친다는것을 반드시 이해해야 합니다. register_globals = off (PHP 4.2.0버전 이래로 off가 디폴트)일때는 $DOCUMENT_ROOT변수는 존재하지 않을것입니다. 대신에 $_SERVER['DOCUMENT_ROOT']변수를 사용합니다. register_globals = on 이라면 $DOCUMENT_ROOT변수와 $GLOBALS['DOCUMENT_ROOT']변수 모두 존재할것입니다.

분명히 register_globals = on 인데, 함수 내에서 $DOCUMENT_ROOT 변수를 쓸수 없는 이유는 이 변수가 다른 변수와 같은 것이고 함수내에서는 global $DOCUMENT_ROOT와 같이 선언해야 합니다. 이와 더불어 변수 사용 범위 매뉴얼 페이지를 참고하세요. register_globals = off으로 놓는것이 바람직합니다.

자동 전역: 사용상 주의: PHP 4.1.0부터, $_GET, $_POST, $_SERVER 등의 자동 전역 배열을 사용할 수 있습니다. 더 자세한 내용은 매뉴얼 superglobals 섹션을 읽어보십시오.

이전 | 처음으로 | 다음
빌드(build)시의 문제 | 위로 | PHP와 HTML


PHP와 HTML

PHP 매뉴얼
이전 다음

51. 장. PHP와 HTML

PHP와 HTML은 많은 연관성을 가지고 있습니다: PHP는 HTML을 생성할 수있고, HTML은 PHP로 정보를 넘겨줄수 있습니다. 이 faq를 읽기전에 PHP로 변수를 가져오는 방법을 아는것이 필요합니다. 이 주제에 관한 매뉴얼 페이지는 많은 예제도 포함되있습니다. register_globals가 무슨 의미인지도 알아야 합니다.

1. 폼/URL을 통해서 변수를 넘겨줄때 인코딩(encoding)/디코딩(decoding)이 필요합니까?
2. <input type="image">태그를 사용하려 합니다. 그런데 $foo.x과 $foo.y변수를 사용할수 없습니다. $_GET['foo.x']도 존재하지 않습니다. 그것들은 어디 있습니까?
3. <form> 안에 어떻게 배열을 만들수 있습니까?
4. How do I get all the results from a select multiple HTML tag? 다중 선택 (select multiple) HTML 태그에서 어떻게 모든값을 가져올수 있습니까?
5. 어떻게 하면 자바스크립트에서 PHP로 변수를 넘겨줄수있습니까?

1. 폼/URL을 통해서 변수를 넘겨줄때 인코딩(encoding)/디코딩(decoding)이 필요합니까?

어떤 인코딩을 써야 하는지에 대해서 여러 경우가 존재합니다. string $data라는 변수를 사용한다고 가정하면 그리고 그 스트링의 값을 인코딩되는 않는 방식으로 넘겨주길 원하면, 다음과 같은 경우가 있습니다.

  • HTML 해석. 랜덤한 스트링을 지정하려면, 반드시 큰 따옴표로 막아줘야 합니다. 그리고 그 값을 htmlspecialchars()함수로 처리합니다.

  • URL: URL은 여러 부분으로 구성됩니다. 이 값전체를 하나의 항목으로 해석하길 원한다면, 반드시 urlencode()함수로 인코딩해야합니다.

예 51-1. 숨겨진 HTML 폼의 엘리먼트(element)

<?php
    echo "<input type=hidden value=\"" . htmlspecialchars($data) . "\">\n";
?>

참고: $data를 urlencode()함수로 처리하는것은 잘못된것입니다. 왜냐하면 그 데이터를 urlencode() 처리할 책임은 브라우저에 있기 때문입니다. 많이 사용되는 브라우저는 정확하게 이와같은 일을 처리합니다. 이와같은 일은 메소드(method) (즉, GET이나 POST)에 따라 발생한다는것을 명심하세요. GET 요구의 경우에만 이 일을 처리합니다. POST 요구일때는 숨겨지기때문입니다.

예 51-2. 유저에 의해 조장되는 데이터

<?php
    echo "<textarea name=mydata>\n";
    echo htmlspecialchars($data)."\n";
    echo "</textarea>";
?>

참고: 이 데이터는 브라우저에 의해 보여집니다. 왜냐하면 브라우저는 HTML 회피문자(escaped symbol)를 해석할것이기 때문입니다.

폼을 GET이나 POST로 보낼때, 데이터는 전송중에 브라우저에 의해 urlencode되고, PHP에 의해 직접적으로 urldecode될것입니다. 그래서 결국에는 urlencoding/urldecoding할 필요가 없는것입니다. 모든것은 자동적인 처리됩니다.

예 51-3. URL내에서

<?php
    echo "<a href=\"" . htmlspecialchars("/nextpage.php?stage=23&data=" .
        urlencode($data)) . "\">\n";
?>

참고: 사실 HTML GET 요구처럼 보이게 하는것이므로 이 데이터는 urlencode()를 할 필요가 있습니다.

참고: URL은 HTML속성 값으로 만들어지기 때문에 전체 URL을 htmlspecialchars()함수로 처리해야 합니다. 이 경우에 브라우저는 처음에 이 값을 un-htmlspecialchars()로 처리하고나서 URL을 넘겨주게 됩니다. PHP는 URL을 정확하게 이해할것입니다. 왜냐하면 그 데이터를 urlencoded()처리했기 때문입니다.

URL에서 &는 &amp;로 변환이 된다는것을 명심해야 합니다. 이것을 잊었다고 하더라도 대부분의 브라우저는 제대로 처리하겠지만, 항상 그렇지는 않습니다. 그래서 URL이 동적이지 않더라도 URL을 반드시 htmlspecialchars()처리해야 할 것입니다.

2. <input type="image">태그를 사용하려 합니다. 그런데 $foo.x과 $foo.y변수를 사용할수 없습니다. $_GET['foo.x']도 존재하지 않습니다. 그것들은 어디 있습니까?

폼을 보낼때 표준 submit 버튼을 사용하는 대신에 image버튼을 사용할수 있습니다
<input type="image" src="image.gif" name="foo">
유저가 image버튼을 클릭할때, 수행 폼은 추가적인 변수: foo.x와 foo.y을 보낼것입니다.

foo.x와 foo.y변수명은 PHP내에서 유효하지 않은 변수이기 때문에, 자동적으로 foo_x와 foo_y변수명으로 바뀝니다. 즉, 밑줄(underscore)로 변경이 됩니다. 그래서 PHP로 변수를 가져오는 방법에서 설명된것처럼 다른 방법으로 이 변수를 이용할수 있습니다. 예를 들면 $_GET['foo_x']과 같습니다.

3. <form> 안에 어떻게 배열을 만들수 있습니까?

To get your <form> result sent as an array to your PHP script you name the <input>, <select> or <textarea> elements like this: PHP스크립트에 배열을 보내는 <form>을 만들려면 <input>, <select> 또는 <textarea> 엘리먼트를 다음처럼 이름을 붙여봅니다:
<input name="MyArray[]">
<input name="MyArray[]">
<input name="MyArray[]">
<input name="MyArray[]">
변수명의 다음에 대괄호가 있습니다. 그것이 이 변수를 배열로 만들어줍니다. 다른 엘리먼트에 같은 이름을 부여함으로써 그 엘리먼트를 다른 배열로 그룹화할수 있습니다:
<input name="MyArray[]">
<input name="MyArray[]">
<input name="MyOtherArray[]">
<input name="MyOtherArray[]">
이것은 두 배열을 만들어냅니다. MyArray와 MyOtherArray배열은 PHP 스크립트로 보내집니다. 또한 배열에 특정 키값을 지정할수 있습니다:
<input name="AnotherArray[]">
<input name="AnotherArray[]">
<input name="AnotherArray[email]">
<input name="AnotherArray[phone]">
AnotherArray배열은 0, 1의 키와 email과 phone키를 내포하게 됩니다.

참고: 배열의 키는 HTML에서는 추가적인 특성입니다. 키로 지정하지 않으면 배열은 폼에 보여지는 엘리먼트 순서값으로 채워집니다. 첫번째 예제에서는 0, 1, 2, 3이 키값이 됩니다.

배열 함수 PHP로 변수를 가져오는 방법를 참고하세요.

4. How do I get all the results from a select multiple HTML tag? 다중 선택 (select multiple) HTML 태그에서 어떻게 모든값을 가져올수 있습니까?

The select multiple tag in an HTML construct allows users to select multiple items from a list. These items are then passed to the action handler for the form. The problem is that they are all passed with the same widget name. ie. 다중 선택 (select multiple)태그는 리스트 중에서 여러 아이템을 선택할수있게 합니다. 이 아이템들은 폼의 액션 핸들러로 보내집니다. 문제는 그들이 같은 위젯(widget)명으로 전달이 된다는 것입니다.
<select name="var" multiple>
선택된 각 옵션(option)값은 액션 핸들러에 다음처럼 도착합니다:
var=option1
var=option2
var=option3
각 옵션은 $var변수의 이전 값을 덮어쓸것입니다. 해결방법은 PHP의 "폼 엘리먼트의 배열" 특성을 이용하는 것입니다. 다음처럼 사용합니다.
<select name="var[]" multiple>
이것은 PHP가 $var변수를 배열로 취급하고 배열의 각 아이템이 var[]로 지정되도록 합니다. 첫번째 아이템은 $var[0] 다음은 $var[1], 등등이 됩니다. count()함수로 몇개의 옵션이 선택되었는지 알수 있습니다. 필요하다면 sort()함수로 옵션 배열을 정렬할수도 있을것입니다.

자바스크립트에서 각 엘리먼트에[]을 사용하는것은 문제가 발생한다는것을 명심해야 합니다. 대신에 숫자 폼의 ID를 사용하기 바랍니다. 또는 작은 따옴표로 변수명을 싸주십시오 그리고 엘리먼트 배열의 인덱스로 사용합니다. 예를 들면 다음과 같습니다.
variable = documents.forms[0].elements['var[]'];

5. 어떻게 하면 자바스크립트에서 PHP로 변수를 넘겨줄수있습니까?

자바스크립트는 (주로) 클라이언트측 기술이고 PHP는 (주로) 서버측 기술이기 때문에, 그리고 HTTP는 "statless" 프로토콜이기 때문에 두 언어는 직접적으로 변수를 공유하지 못합니다.

하지만, 둘 사이에 변수를 넘겨주는 것은 가능합니다. 이를 수행할수 있는 방법으로는 PHP로 자바스크립트 코드를 생성하는 방법입니다. 그리고 그것을 브라우저가 리프레쉬하도록 하고 PHP스크립트로 특정 변수를 넘겨주게 됩니다. 예를 들면 아래와 같이 이를 수행할수 있습니다. -- PHP코드는 스크린의 높이와 넓이를 보유하도록 해줍니다, 이것은 보통 클라이언트측에서만 가능한것입니다.

<?php
if (isset($_GET['width']) AND isset($_GET['height'])) {
  // output the geometry variables
  echo "Screen width is: ". $_GET['width'] ."<br />\n";
  echo "Screen height is: ". $_GET['height'] ."<br />\n";
} else {
  // pass the geometry variables
  // (preserve the original query string
  //   -- post variables will need to handled differently)

  echo "<script language=\"javascript\">\n";
  echo "  location.href=\"${_SERVER['SCRIPT_NAME']}?${_SERVER['QUERY_STRING']}"
            . "&width=\" + screen.width + \"&height=\" + screen.height;\n";
  echo "</script>\n";
  exit();
}
?>

이전 | 처음으로 | 다음
PHP 사용하기 | 위로 | PHP와 COM


PHP와 COM

PHP 매뉴얼
이전 다음

52. 장. PHP와 COM

PHP는 Win32 플랫폼의 COM과 DCOM 객체(object)에 접근할수 있습니다.

1. 어떤것을 계산하는 DLL을 빌드했습니다. PHP상에서 이 DLL을 실행시킬수 있는 방법 이 있습니까?
2. 'Unsupported variant type: xxxx (0xxxxx)'은 무엇을 의미합니까?
3. PHP에서 비주얼한 객체(visual object)를 조작할수 있습니까?
4. 세션안에 COM 객체를 저장할 수 있습니까?
5. COM 에러를 어떻게 추적할 수 있습니까?
6. 펄에서 쓰던 방법으로 PHP 스크립트에서 DLL 파일을 만들수 있습니까?
7. 'Unable to obtain IDispatch interface for CLSID {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}'의 의미는 무엇입니까?
8. 다른 서버(remote server)에서 COM 객체(object)를 어떻게 실행할수 있습니까?
9. 'DCOM is disabled in C:\path...\scriptname.php on line 6'라는 메시지를 봤습니다. 어떻게 해야 하나요?
10. PHP에서 ActiveX 객체(object)를 부르거나/변경할수 있습니까?
11. 특정 컴포넌트에서 실행중인 인스턴스(instance)에 접근 가능합니까?
12. COM 객체로부터 받은 이벤트를 제어할 방법이 있습니까?
13. 하나 이상의 인터페이스를 갖는 COM 객체의 메소드(method)를 불러 들이려고 하는데 문제에 봉착했습니다. 어떻게 해야 합니까?
14. 그래서 PHP와 COM이 작동하는군요. COM+는 어떤가요?
15. PHP가 COM 객체를 다룰수있다면, PHP로 컴포넌트 자원을 관리하는 MTS를 쓸수있지 않을까요?

1. 어떤것을 계산하는 DLL을 빌드했습니다. PHP상에서 이 DLL을 실행시킬수 있는 방법 이 있습니까?

간단한 DLL이라도 PHP에서 실행할 방법은 아직 없습니다. 접근가능한 COM서버를 포함하는 DLL이고, IDispatch 인터페이스로 구현되어있다면 가능할수도 있습니다.

2. 'Unsupported variant type: xxxx (0xxxxx)'은 무엇을 의미합니까?

몇가지의 VARIANT 타입과 그 타입간의 조합이 가능합니다. 그들 대부분은 거의 지원이 되고있지만 일부가 아직 구현되어있지 않습니다. 배열은 완전히 지원되지 않습니다. 오직 1차원 배열만이 PHP와 COM사이에서 전달이 가능합니다. 지원되지 않는 다른 타입을 발견했다면 그 타입을 버그 레포트로 알려주기랍니다 (아직 보고되지 않는것들이라면) 그리고 더 자세한 정보도 함께 제공해주십시오.

3. PHP에서 비주얼한 객체(visual object)를 조작할수 있습니까?

가능합니다. 하지만 PHP는 대부분 웹서버의 환경에서 웹 스크립트 언어로서 이용되고 있습니다. 따라서 서버가 비주얼 객체를 보여주지는 않을것입니다. 응용프로그램 스크립트를 위한 PHP(PHP-GTK같은)를 사용한다면 COM을 통해서 비주얼 객체(visual object)에 접근하고 조작하는데 아무 제한이 없습니다.

4. 세션안에 COM 객체를 저장할 수 있습니까?

그건 안됩니다. COM 인스턴스(instance)는 리소스로 취급되므로 오직 단일 스크립트의 컨텍스트(context)에서만 가용한것입니다.

5. COM 에러를 어떻게 추적할 수 있습니까?

현재 PHP 자체에서 제공되는 방법(@, track_errors, ..)으로는 COM 에러를 추적하기는 불가능합니다. 하지만 이것을 구현할 방법을 강구중입니다.

6. 펄에서 쓰던 방법으로 PHP 스크립트에서 DLL 파일을 만들수 있습니까?

만들수 없습니다. 재수없게도 PHP를 위해 그런 툴이 존재하지 않습니다.

7. 'Unable to obtain IDispatch interface for CLSID {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}'의 의미는 무엇입니까?

이 에러는 다음과 같은 원인일수 있습니다.

  • CLSID가 잘못되었다

  • 필요한 DLL이 존재하지 않는다

  • 필요한 컴포넌트가 IDispatch 인터페이스로 구현되지 않았다

8. 다른 서버(remote server)에서 COM 객체(object)를 어떻게 실행할수 있습니까?

로컬 객체를 실행시키는것과 완전히 똑같습니다. 단지 COM 생성자(constructor)의 두번째 인자(parameter)에 다른 서버의 IP를 넘겨주면 됩니다.

php.ini파일 내에서 com.allow_dcom=true값을 설정해야 한다는것을 잊지마십시오

9. 'DCOM is disabled in C:\path...\scriptname.php on line 6'라는 메시지를 봤습니다. 어떻게 해야 하나요?

php.ini파일 내에서 com.allow_dcom=true로 설정합니다.

10. PHP에서 ActiveX 객체(object)를 부르거나/변경할수 있습니까?

이것은 PHP에서 할일이 아닙니다. HTML 문서에서 ActiveX 객체가 포함되있으면 클라이언트 단에서 그 코드를 처리하는 것입니다. PHP 스크립트와는 전혀 관련이 없고 따라서 서버단과는 직접적인 관련이 없습니다.

11. 특정 컴포넌트에서 실행중인 인스턴스(instance)에 접근 가능합니까?

모니커(monikers)의 도움으로 가능합니다. 하나의 워드 인스턴스로 다방향 레퍼런스를 얻고 싶다면 다음처럼 그 인스턴스를 만들 수 있습니다.

$word = new COM("C:\docs\word.doc");

위처럼 하면 실행중인 인스턴스가 없을 때에는 새로운 인스턴스를 만들수 있고, 실행중인 인스턴스가 이미 존재하면 그 핸들을 넘겨주게 됩니다.

12. COM 객체로부터 받은 이벤트를 제어할 방법이 있습니까?

PHP 4.3.0을 실행하면, 아래 예제에서 볼수 있듯이 이벤트를 싱크(sink), 연결(bind) 할 수 있도록 정의할 수 있습니다. com_print_typeinfo()함수를 실행함으로써 이벤트 싱크(sink) 클래스에 대한 코드를 만들수 있습니다.

예 52-1. COM event sink example

<?php
class IEEventSinker {
  var $terminated = false;

  function ProgressChange($progress, $progressmax) {
    echo "Download progress: $progress / $progressmax\n";
  }

  function DocumentComplete(&$dom, $url) {
    echo "Document $url complete\n";
  }

  function OnQuit() {
    echo "Quit!\n";
    $this->terminated = true;
  }
}
$ie = new COM("InternetExplorer.Application");
$sink =& new IEEventSinker();
com_event_sink($ie, $sink, "DWebBrowserEvents2");
$ie->Visible = true;
$ie->Navigate("http://www.php.net");
while(!$sink->terminated) {
  com_message_pump(4000);
}
$ie = null;
?>

13. 하나 이상의 인터페이스를 갖는 COM 객체의 메소드(method)를 불러 들이려고 하는데 문제에 봉착했습니다. 어떻게 해야 합니까?

답은 불만스럽겠지만 간단합니다. 확실치는 않지만 당신은 아무것도 할수없습니다. 어떤사람은 이 문제와 관련된 정보를 가지고 있습니다. 저에게 알려주시라 :)

14. 그래서 PHP와 COM이 작동하는군요. COM+는 어떤가요?

MTS와 MTMQ를 통해서 컴포넌트를 관리하는 프레임워크가 추가되면서 COM에서 COM+로 발전된것입니다. 그런데 PHP는 그런 컴포넌트를 지원하지 않습니다.

15. PHP가 COM 객체를 다룰수있다면, PHP로 컴포넌트 자원을 관리하는 MTS를 쓸수있지 않을까요?

PHP자체로는 아직 트랜젝션(transaction)을 관리할수 없습니다. 따라서 에러가 발생하더라도 롤백(rollback)으로 초기화되지않습니다. 트랜젝션을 지원하는 컴포넌트를 사용한다면 트랜젝션 관리를 구현해서 써야합니다.

이전 | 처음으로 | 다음
PHP와 HTML | 위로 | PHP와 다른 프로그래밍 언어


PHP와 다른 프로그래밍 언어

PHP 매뉴얼
이전 다음

53. 장. PHP와 다른 프로그래밍 언어

PHP는 웹프로그래밍을 위한 최고의 프로그래밍 언어입니다. 다른 언어는 어떨까요?

1. PHP vs. ASP?
2. ASP를 PHP로 변환시켜주는것이 있나요?
3. PHP vs. Cold Fusion?
4. PHP vs. Perl?

1. PHP vs. ASP?

ASP 그 자체로는 실제로 언어라고 볼수 없습니다. ASP는 Active Server Pages의 약어입니다. ASP를 프로그래밍하기 위해 같이 다루어야 하는 언어가 Visual Basic Script와 JScript입니다. ASP의 최대 단점은 MS의 Internet Information Server (IIS)에서만 사용할수 있다는것입니다. 이 점으로 인해 ASP를 Win32기반 서버로 제한하게 됩니다. 다른 환경이나 웹서버에서 ASP를 작동하게 하는 몇개의 프로젝트가 진행중입니다: Halcyon의 InstantASP (상업용), Chili!Soft의 Chili!Soft ASP (상업용) ASP는 PHP보다 느리고 성가신 언어이며, 약간은 불안정하기까지 합니다. ASP의 문법(pros)은 그것이 VBScript를 사용하고 있기 때문에 만약에 비주얼 베이직(Visual Basic)을 다룰줄만 안다면 상대적으로 접근하기 쉽습니다. 또한 ASP는 IIS가 ASP를 올리고 실행시킬수 있도록 해놨기 때문에 기본적으로 지원이 됩니다. ASP내에 내장되어있는 컴포넌트는 제한되어있습니다. 그래서 FTP서버와 접속할수있도록하는 고급(advanced)기능을 사용할 필요가 생긴다면 추가적인 컴포넌트를 사야합니다.

2. ASP를 PHP로 변환시켜주는것이 있나요?

네, 서버측의 asp2php가 가장 많이 쓰이며, 클라언트측옵션도 있습니다.

3. PHP vs. Cold Fusion?

PHP는 복잡한 프로그래밍 작업과 새로운 아이디어를 시도하는데 가장 빠르며 가장 효율이 높습니다. 그 뿐만 아니라 PHP는 가장 안정적이며 적은 자원만이 필요합니다. 콜드 퓨전(Cold Fusion)은 더 낳은 에러 핸들링, 데이터베이스 추상화는 PHP 4에도 언급된것이긴 하지만, 더 낳은 데이터베이스 추상화(abstraction) 그리고 더 낳은 날짜 파싱이 가능합니다. 콜드 퓨전(Cold Fusion)의 다른 강점 중 하나는 최고의 검색 엔진입니다. 그러나 그 검색엔진은 웹 스크립트 언어에 포함되어 있어야 합니다. PHP는 거의 모든 플래폼에서 실행이됩니다; 콜드 퓨전(Cold Fusion)은 오직 Win32, Solaris, Linux and HP/UX 에서만 사용가능합니다. 콜드 퓨전은 좋은 IDE를 가졌고 보통 시작하기가 쉽습니다, 반면에 PHP는 초기에 더 많은 프로그래밍 지식이 요구됩니다. 콜드 퓨전은 프로그래머가 아닌사람들을 위해 설계되었지만, PHP는 프로그래머에게 초점을 맞췄습니다.

이 주제에 관해 Michael J Sheldon이 정리한 글이 PHP 메일링리스트에 게제되었습니다. http://marc.theaimsgroup.com/?l=php-general&m=95602167412542&w=1를 보세요.

4. PHP vs. Perl?

Perl에 비해 PHP의 가장 큰 장접은 웹을 위한 스크립트로 설계되었다는것입니다. 반명에 Perl은 더 많은 일을 할수 있도록 설계되었고 이로 인해 매우 복잡하게 되었습니다. Perl의 유연성/복잡성은 코드를 쓰기 쉽게 했지만 다른 저작자/코더가 읽기에는 어렵게 했습니다. PHP는 복잡성을 잃지않으면서 덜 헷까리고 덜 엄격한 포맷을 갖고 있습니다. Perl의 '좋은' 기능을 모두 갖고 있습니다: 컨스트럭트(construct), 문법 등등. 이는 Perl처럼 복잡하게 함이 없이 가능합니다. Perl은 많은 노력이 필요한 언어이기 때문에 80년대 말부터 지금까지 발전한것입니다. 그러나 PHP는 엄청난 속도로 성장하고 있습니다.

이전 | 처음으로 | 다음
PHP와 COM | 위로 | PHP 2 에서 PHP 3로 마이그레이션 하기


PHP 2 에서 PHP 3로 마이그레이션 하기

PHP 매뉴얼
이전 다음

54. 장. PHP 2 에서 PHP 3로 마이그레이션 하기

PHP는 오랜 기간동안 발전되어 왔다: 전설적인 PHP 1.0, PHP/FI, PHP 3.0 and PHP 4.0.

1. PHP 2 에서 PHP 3로 마이그레이션 하기?

1. PHP 2 에서 PHP 3로 마이그레이션 하기?

PHP/FI 2.0 더 이상 지원되지 않는다. PHP/FI 2.0에서 마이그레이션 하는 것에 대한 정보는 적합한 매뉴얼을 참조하라.

아직 PHP 2 를 사용중이라면 강력하게 PHP 4로 바로 업그레이드 할것을 권한다.

이전 | 처음으로 | 다음
PHP와 다른 프로그래밍 언어 | 위로 | PHP 3에서 PHP 4로의 마이그레이션


PHP 3에서 PHP 4로의 마이그레이션

PHP 매뉴얼
이전 다음

55. 장. PHP 3에서 PHP 4로의 마이그레이션

PHP는 그 뒤에 긴 역사를 가지고 있습니다 : 전설적인 PHP 1.0, PHP/FI와 PHP 3.0 와 PHP 4.0.

1. PHP3에서 PHP4로의 마이그레이션
2. PHP 3에서 세션이 작동합니까?
3. 호환되지 않는 기능은?

1. PHP3에서 PHP4로의 마이그레이션

PHP 4는 가능하면 PHP의 이전버전과 호환되도록 설계되었고 프로세스에서 거의 기능상의 문제를 발생시키지 않습니다. 테스트 환경에서 PHP 4를 설치해야하여 호환성에 대해서 확실할수 없다면 거기에서 스크립트를 실행시켜보십시오.

이 매뉴얼의 appropriate migration appendix도 참고하세요.

2. PHP 3에서 세션이 작동합니까?

PHP 3에서 고유한 세션 지원이 되지않더라도 써드파티(third-party) 응용프로그램이 이와같은 세션 기능을 제공합니다. 가장 대중화된 방법은 PHPLIB을 이용하는것입니다.

3. 호환되지 않는 기능은?

PHP 4는 기본적으로 전체 PHP 엔진을 재작성했기 때문에 변경된 기능이 거의 없고 단지 전에 없던 것들 몇가지만 존재합니다.

이전 | 처음으로 | 다음
PHP 2 에서 PHP 3로 마이그레이션 하기 | 위로 | 기타 문제들


기타 문제들

PHP 매뉴얼
이전 다음

56. 장. 기타 문제들

다른 곳으로 분류할수 없는 질문들에 대해서 다룹니다.

1. 윈도우에서 bz2로 압축된 매뉴얼을 제어할 수 있습니까?

1. 윈도우에서 bz2로 압축된 매뉴얼을 제어할 수 있습니까?

bz2 파일을 제어할 아카이브 툴을 갖고 있지 않다면 커맨드 라인 툴을 레드햇에서 다운로드합니다. (아래에서 더 많은 정보를 얻을수 있습니다).

커맨드 라인 툴이 내키지 않는다면 Stuffit Expander 나 UltimateZip, 7-Zip, Quick Zip같은 툴을 사용할수 있습니다. WinRAR나 Power Archiver같은 툴을 갖고 있다면, 이 툴로 쉽게 bz2파일을 압축해제할수 있습니다. 윈도우 코맨더(Windows Commander)를 사용중이라면 bz2 플러그인을 Windows Commander사이트에서 다운받으시면 됩니다.

레스햇의 bzip2 코맨드 라인 툴:

Win2k Sp2 유저는 1.0.2 최종 버전을 구할수 있습니다. 다른 윈도우 유저는 1.00을 구해야 합니다. 다운로드 후에 실행파일을 bzip2.exe로 이름을 변경합니다. 편의상 패스(path)로 지정된 디렉토리에 그 파일을 넣습니다. 즉 C:\Windows같은 경우입니다. 여기서 C는 윈도우가 설치되어있는 드라이버입니다.

주의: lang는 사용중인 랭귀지를 뜻하고, x는 요구되는 포맷입니다(즉, pdf). php_manual_lang.x.bz2파일을 압축해제하려면 다음 지시를 따릅니다:

  • 윈도우 커맨드라인을 엽니다

  • php_manual_lang.x.bz2 파일이 저장되어있는 폴더로 cd합니다.

  • bzip2 -d php_manual_lang.x.bz2 명령을 실행시키면, 같은 폴더에 php_manual_lang.x파일이 압축이 풀립니다.

그 안에 많은 html파일을 포함하고 있는 php_manual_lang.tar.bz2파일을 다운로드 받은경우에도 과정은 같습니다. 차이점은 php_manual_lang.tar만 얻을수 있다는것이고 이 타(tar)포맷은 윈도우 상에서 대부분의 아카이브를 취급할수 있는것으로 알려져있는 WinZip같은 툴로 압축을 해제할수 있습니다.

이전 | 처음으로 | 다음
PHP 3에서 PHP 4로의 마이그레이션 | 위로 | 부록


부록

PHP 매뉴얼
이전 다음

IX. 부록

차례
A. PHP와 PHP 관련 프로젝트의 역사
B. PHP 4에서 PHP 5로 이행
C. PHP 3 에서 PHP 4로 이주
D. PHP/FI 2 에서 PHP 3로 이주하기
E. PHP 디버깅하기
F. PHP 3 확장
G. 함수 별칭 목록
H. 예약어 목록
I. 리소스 타입 목록
J. 지원 프로토콜/래퍼 목록
K. List of Available Filters
L. 지원되는 소켓 전송 목록
M. PHP 타입 비교 테이블
N. 해석기 토큰 목록
O. 이 매뉴얼에 관하여
P. Open Publication License
Q. 함수 인덱스

이전 | 처음으로 | 다음
기타 문제들 |  | PHP와 PHP 관련 프로젝트의 역사


PHP와 PHP 관련 프로젝트의 역사

PHP 매뉴얼
이전 다음

A. 부록. PHP와 PHP 관련 프로젝트의 역사

차례
PHP의 역사
PHP 관련 프로젝트의 역사
PHP 관련 서적
PHP에 관한 출판물

PHP는 최근 몇년간 출세가도를 달려왔다. 웹을 강화하는 가장 부각되는 언어중 하나로 성장하는 것은 쉬운 일이 아니었다. 오늘날 PHP가 어떻게 성장했는지에 대해 간단히 보고자 한다면, 계속 읽어나가자. 구버전의 PHP는 PHP Museum에서 확인할수있다.

PHP의 역사

PHP/FI

PHP는 PHP/FI라는 이름의 오래된 소프트웨어를 계승했다. PHP/FI는 1995년에 Rasmus Lerdorf에 의해 만들어졌다. 그의 온라인 이력서의 접속수를 추적하기 위한 단순한 펄 스크립트 구성물로 시작되었다. 그는 그 스트립트 구성물을 'Personal Home Page Tools'라고 명명했다. 좀더 많은 기능이 요구됨에 따라, Rasmus는 좀 더 많은 C 구현물을 작성했다. 이 구현물은 데이터베이스와 의사소통을 하고, 유저가 단순한 동적 웹 애플리케이션을 작성할수 있게 하였다. Rasmus는 모든 사람이 볼수 있도록 PHP/FI의 소스 코드를 release하기로 결정했다. 그래서 모든 사람이 그것을 사용하고, 버그를 고칠수 있을뿐만 아니라 코드를 향상시킬수 있었다.

PHP/FI, Personal Home Page / Forms Interpreter의 약어, 는 오늘날 우리가 알고있는것처럼 PHP의 기본적인 기능의 일부를 포함하고 있다. 그것은 펄과 비슷하게 생긴 변수, 폼 변수의 자동 해석과 HTML 내장 문법을 갖고 있었다. 그 문법 자체는 좀더 제한적이고, 단순하고 약간은 일관성이 떨어지기는 하지만 펄과 비슷했다.

1997년까지, PHP/FI 2.0, C로 쓰여진 두번째 구현물,은 전세계에서 수천 사용자의 숭배자를 갖게 된다(추정치). 그리고 대략 50,000의 도메인에서 설치되었던것으로 보고되었고, 이수치는 인터넷 모든 도메인의 약 1%에 해당된다. 이 프로젝트에 많은 코드를 공헌한 몇명의 사람이 있었지만, 아직은 대체로 한사람의 프로젝트였다.

PHP/FI 2.0은 그 삶의 대부분을 베타 릴리즈로 보낸 이후, 1997년 11월에만 공식적으로 릴리즈되었다. 그후 얼마안되어 PHP 3.0의 첫번째 알파버전에 의해 계승되었다.

PHP 3

PHP 3.0은 오늘날 알려진 PHP와 매우 가깝게 닮아있는 첫번째 버전이었다. 그것은 1997년 Andi Gutmans 와 Zeev Suraski에 의해 의해 완전히 재작성되어 만들어졌다. 그들이 대학 프로젝트 수행시 이커머스(eCommerce) 응용프로그램을 개발하기 위해 기능이 떨어지는 PHP/FI 2.0을 발견한것이 계기가 되었다. PHP/FI의 기존 사용자 기반위에서 협력하고 개발을 시작할 의도를 가지고, Andi, Rasmus, Zeev는 PHP/FI 2.0의 공식적인 계승자로서 PHP 3.0을 발표하였고, PHP/FI 2.0의 개발을 대부분 중단하게 되었다.

PHP 3.0의 가장 큰 강점중의 하나는 강력한 확장 기능이었다. 엔드유저에게 다양한 데이터베이스접근를 위한 견고한 인프라구조, 여러가지 프로토콜과 API를 제공해주었고, 이런 PHP 3.0의 확장 기능은 수십명의 개발자가 개발에 참여하도록 유도했고, 그들은 새로운 확장 모듈을 개발해주었다. 확실하게, 이런 특징이 PHP 3.0의 엄청난 성공의 열쇠였다. PHP 3.0으로 유도하는 다른 핵심 기능이 객체 지향 문법 지원과 좀더 파워풀하고 일관성있는 언어 문법이었다.

모든 새로운 언어는 새로운 이름하에 릴리즈되었다. PHP/FI 2.0이라는 이름이 내포하는 제한된 개인 사용 목적에 대한 연루성을 제거하고, 그 이름을 'PHP'로 명명하였다. 이 단어는 PHP: Hypertext Preprocessor 의 재귀적 약어이다.

1998년 말까지, PHP는 수만명의 사용자가 설치(추정치)하였고 수십만의 웹사이트에 설치되었다고 보고되었다. 이런 급성장에서, PHP 3.0은 인터넷상의 웹서버중 거의 10%가 설치되었다.

PHP 3.0은 1998년 6월에 공식적으로 릴리즈되었다. 공개적인 테스트 이후 약 9개월만이었다.

PHP 4

1998년 겨울까지, PHP 3.0이 공식적으로 릴리즈된후 얼마안되어서, Andi Gutmans 와 Zeev Suraski는 PHP의 코어를 재작성하는 작업을 시작했다. 설계 목적은 복잡한 응용프로그램의 퍼포먼스를 향상시키고, PHP의 코드 베이스의 모듈화를 향상시키는것이었다. 그런 응용프로그램은 PHP 3.0의 새로운 기능과 다양하고 광범위한 서드파티 데이터베이스와 API의 지원으로 가능하게 되었다. 그러나, PHP 3.0은 그런 복잡한 응용 프로그램을 효율적으로 제어하도록 설계되지는 않았었다.

새로운 엔진, 'Zend Engine'로 명명됨(그들 Zeev와 Andi의 이름으로 구성됨), 은 이런 설계 목적에 성공적으로 부합하였다. 그리고 1999년 중반 처음으로 소개되었다. 이 엔진에 기반하였고, 광범위한 새 추가 기능과 같이 동작하는 PHP 4.0은 2000년 5월에 공식적으로 릴리즈되었다. 전임자인 PHP 3.0이 나온지 거의 2년만이다. 이 버전의 크게 향상된 퍼포먼스 뿐만아니라, PHP 4.0은 다른 핵심 기능도 제공하고 있다. 여러가지 웹서버에 대한 지원, HTTP 세션, 출력 버퍼링, 보안이 강화된 유저 입력 제어, 몇가지 새로운 언어 구조이다.

PHP 4는 현재까지 가장 마지막으로 릴리즈된 PHP 버전이다. PHP 5.0을 위해 설계된 기능을 구체화시키기 위해서 젠드 엔진을 변경하고 향상시키는 작업이 이미 시작되었다.

현재, PHP는 수십만명의 개발자들에 의해서 사용되고있고(추정치), 수백만 사이트에 설치되어있다고 보고되었다. 이 수치는 인터넷상에서 20% 이상의 도메인수가 된다.

PHP 개발팀은 수십명의 개발자들을 포함하고, 그외에 PEAR, 문서 프로젝트와 같은 PHP 관련 프로젝트에서 수십명이 참여 중이다.

PHP 5

PHP의 미래는 주로 그 코어, 젠드 엔진에 의해 운영된다. PHP 5는 새로운 젠드 엔진 2.0을 포함할것이다. 이 엔진에 대한 더 자세한 정보를 원한다면, 이 웹페이지를 참고한다.

이전 | 처음으로 | 다음
부록 | 위로 | PHP 관련 프로젝트의 역사


PHP 관련 프로젝트의 역사

PEAR

PEAR, PHP Extension 과 Application Repository (원래, PHP Extension 과 Add-on Repository)는 PHP의 기초 클래스 버전이다. 앞으로 개발자들 사이에서 PHP와 C기반 PHP확장 모두를 제공하는 핵심 수단의 하나로 성장할 것이다.

PEAR는 Tel Aviv에서 2000년 1월에 개최된 PHP Developers' Meeting (PDM) 의 논의를 거쳐 탄생하게 되었다. Stig S. Bakken가 만들었고, 그의 첫번째 딸인 Malin Bakken에게 헌정되었다.

2000 초기 이래로, PEAR는 거대하고, 중요한 프로젝트로 성장하였고, 수많은 개발자들이 공통된, 재사용가능한 기능을 전체 PHP 커뮤니티의 이익을 위해 개발하고 있다. 오늘날 PEAR는 데이터베이스 접속, 컨텐츠 캐슁, 수학적 계산, 이커머스(eCommerce) 등등을 위한 광범위한 인프라구조 기초 클래스를 포함한다.

PHP 품질 보증 발의

PHP 품질 보증 발의(PHP Quality Assurance Initiative)는 2000년 여름에 PHP 릴리즈가 제조 환경을 위해 충분히 테스트되지 않는다는 토론에 대응하여 설치되었다. 이 팀은 PHP 코드 베이스의 충분한 이해를 갖고있는 핵심 개발 그룹으로 구성되었다. 이 개발자들은 PHP를 지역화하고 PHP 내의 버그를 고치는데 그들 대부분의 시간을 보낸다. 추가로 다양한 플랫폼을 사용하여 이런 버그 수리에 대하여 많은 다른 팀 멤버도 피드백을 제공중이다.

PHP-GTK

PHP-GTK는 클라이언트측 GUI 응용프로그램을 작성하기 위한 PHP 솔루션이다. Andrei Zmievski는 PHP-GTK를 계획하고 창조한 과정을 다음과 같이 회고한다:

GUI 프로그래밍은 내가 항상 관심을 갖어왔었고, C안에서 이 언어로 프로그램하는것은 조금은 지루하지만 Gtk+가 가장 좋은 툴킷이라는것을 발견하였다. PyGtk 과 GTK-Perl 구현을 관찰한 후에, 나는 PHP가 최소한 Gtk+와 인터페이스되어 만들어질수 있는지 확인하기로 결정했다. 2000년 8월에 시작하여서, 실험을 시작할수 있는 때가 되도록 좀더 많은 자유 시간을 갖기 시작했다. 나의 주요 정책은 PyGtk 구현이었는데 그것은 기능적으로 충분히 완벽하게 동작하게 하고 적절한 객체 지향 인터페이스를 갖는것이었다. James Henstridge,파이썬의 저자, 는 이 초기 단계에서 매우 도움이 되는 조언을 제공해주었다.

모든 Gtk+ 함수의 인터페이스를 손으로 쓰는것은 문제가 있었다. PyGtk가 동작하는 방식과 비슷하게 동작하도록 만들기 위해 나는 코드 생성기에 대한 아이디어에 골몰하게 되었고, 이 코드 생성기는 Gtk+ 클래스, 상수, 메소드 정보를 포함하는 .defs 파일 구성체를 읽어들이고 그들과 같이 PHP와 인터페이스화하는 C 코드를 생성하는 PHP 프로그램이다. 자동적으로 생성될수 없는 것은 손으로 .overrides 파일을 작성하였다.

코드 생성기와 인프라구조의 작업은 약간의 시간이 걸렸다. 왜냐하면, 나는 2000년 가을에 PHP-GTK에 거의 시간을 쓸수 없었기 때문이다. Frank Kromann에게 PHP-GTK를 보여준 후, 그는 흥미을 보였고 코드 생성기 작업과 윈32 구현에 대해 나를 도와주기 시작했다. 우리가 처음으로 Hello World 프로그램을 작성하고 그 프로그램을 시작으로 극도로 흥분하게 되었다. 소개용 환경의 프로젝트를 마치는데 약 두달이 걸렸고 2001년 3월 1일에 첫번째 버전을 릴리즈했다. 이 이야기는 SlashDot에서 바로 히트하게 되었다.

PHP-GTK가 확장될수 있을거라는 생각으로, 나는 그것에 관한 별도의 메일링리스트와 CVS 저장소를 설치한다. 또한 Colin Viebrock의 도움으로 gtk.php.net 웹사이트도 만들게 된다. 문서화도 또한 필요했고 James Moore는 이 작업에 도움을 주었다.

릴리즈되고 나서 PHP-GTK는 유행하게 되었다. 우리는 문서화 팀을 구성했고 이 매뉴얼은 계속 향상되고 있다.그래서 사람들은 PHP-GTK의 확장을 쓰기 시작했고 더 많은 흥미로운 응용프로그램을 작성하게 되었다.

이전 | 처음으로 | 다음
PHP와 PHP 관련 프로젝트의 역사 | 위로 | PHP 관련 서적


PHP 관련 서적

PHP가 성장함에 따라, 그것은 전세계적으로 유행하는 개발 플랫폼으로 인식되기 시작했다. 이런 추세를 확인하는 가장 재미있는 방법이 몇년동안 나온 PHP 관련 서적을 찾아보는것이다.

우리가 알기로는, PHP에 관련된 최초의 서적은 'PHP - tvorba interaktivn?ch internetov?ch aplikac?' - 1999년 4월에 체코에서 출판된 책이다, Jirka Kosek가 저자이다. 다음해에 Egon Schmid, Christian Cartus, and Richard Blume 가 저술한 독일 서적이 출판되었다. PHP에 관한 최초의 영문 서적은 그후 얼마 안되어서 Leon Atkinson에 의해 저술된 'Core PHP Programming' 이었는데, 이 책 모두 PHP 3.0을 다루고 있다.

이런 책들이 PHP 관련의 최초 서적이었고, 다수의 저자와 출판인들에 의해 수많은 책들이 출판되었다. 영어로는 40권이상, 독일어로는 50권 이상, 프랑스어로는 20권 이상이다! 추가로, 다른 많은 언어의 PHP 관련서적을 발견할수 있다. 스페인어, 한국어, 일본어, 이스라엘어가 포함된다.

확실히, 이렇게 수많은 책들, 다양한 저자에 의해 저술되고, 많은 출판인들에 의해 출판되고, 매우 많은 언어로 쓰여졌다는것은 PHP의 전세계적인 성공에 대한 강력한 반증이다.

이전 | 처음으로 | 다음
PHP 관련 프로젝트의 역사 | 위로 | PHP에 관한 출판물


PHP에 관한 출판물

우리가 아는한, 잡지에서 PHP에 관한 최초의 기사는 1998년 봄의 Computerworld 체코 판에 출판되었다. 이 기사는 PHP 3.0을 다루고 있다. 이 기사는 많은 유명 잡지중에서 PHP 관련 시리즈물의 최초기사였다.

PHP에 관한 기사는 Dr. Dobbs, Linux Enterprise, Linux Magazine 등등에서 보이게 되었고, ASP기반 응용 프로그램을 윈도우의 PHP로 마이그레이션하는 기사는 마이크로소프트의 MSDN에도 보인다!

이전 | 처음으로 | 다음
PHP 관련 서적 | 위로 | PHP 4에서 PHP 5로 이행


PHP 4에서 PHP 5로 이행

PHP 매뉴얼
이전 다음

B. 부록. PHP 4에서 PHP 5로 이행

차례
PHP 5에서 바뀐 것들
이전 버전과 호환하지 않는 변경점
CLI와 CGI
설정 파일 이행
새로운 함수들
새로운 지시어
데이터베이스
새로운 객체 모델

PHP 5에서 바뀐 것들

PHP 5와 내장된 젠드 엔진 2는 PHP의 성능과 능력을 대폭 향상하면서, 기존의 코드를 가능한 그대로 사용할 수 있게 주의를 하였습니다. 그리하여, PHP 4의 코드를 PHP 5로 옮기는 일은 매우 쉽습니다. 기존 PHP 4 코드의 대부분은 아무런 변경 없이 실행할 수 있지만, 몇몇 차이점에 대해서 알고, 실제 환경에 적용할 때는 미리 테스트를 해 보아야 합니다.

이전 | 처음으로 | 다음
PHP에 관한 출판물 | 위로 | 이전 버전과 호환하지 않는 변경점


이전 버전과 호환하지 않는 변경점

기존 PHP 4 코드의 대부분은 변경 없이 작동하지만, 다음의 비호환 변경점에 주의를 해야 합니다:

  • strrpos()와 strripos()가 전체 문자열을 needle로 사용합니다.

  • 문자열 오프셋의 비정상적인 사용은 E_WARNING 대신 E_ERROR를 발생합니다.

  • array_merge()가 배열만을 받아들이게 변경되었습니다. 배열이 아닌 값을 넘기면, 그러한 인수마다 E_WARNING을 발생합니다. 코드가 갑작스레 E_WARNING를 표시하기 시작할 수 있으므로 주의하십시오.

  • 더이상 Apahce2 SAPI에서 PATH_TRANSLATED 서버 변수를 자동으로 설정하지 않습니다. PHP 4에서는 아파치가 생성하지 않았을 때, SCRIPT_FILENAME 서버 변수와 동일하게 설정했었습니다. 이 변경은 CGI 규격에 따르기 위한 점입니다. 자세한 정보는 버그 #23610를 참고하십시오.

  • Tokenizer 확장은 더 이상 T_ML_CONSTANT 상수를 정의하지 않습니다. error_reporting을 E_ALL로 설정하면, PHP가 주의문을 생성합니다. T_ML_CONSTANT는 사용되지 않았지만, PHP 4에서 정의되어 있었습니다. PHP 4와 PHP 5 둘 다, T_COMMENT 상수가 //와 /* */를 모두 인식합니다. 그러나 PHP 5에서 도입한, PHP가 처리하는 PHPDoc 스타일 주석 /** */은, T_DOC_COMMENT로 인식합니다.

  • variables_order가 "S"를 포함하고 있으면, $_SERVER는 argc와 argv를 가져야 합니다. 시스템이 $_SERVER를 생성하지 않게 설정하였다면, 물론 존재하지 않아야 합니다. 변경 후에는 variables_order 설정에 관계 없이, CLI 버전에서 argc와 argv를 사용할 수 있게 만듭니다. 또한, CLI 버전은 항상 전역의 $argc와 $argv도 가집게 되었습니다.

  • 프로퍼티가 없는 객체를 더 이상 "빈" 것으로 판단하지 않습니다.

  • 클래스는 사용하기 전에 정의해야 합니다.

예 B-1. strrpos()와 strripos()가 전체 문자열을 needle로 사용합니다.

<?php
var_dump(strrpos('ABCDEF','DEF')); //int(3)

var_dump(strrpos('ABCDEF','DAF')); //bool(false)
?>

예 B-2. 프로퍼티가 없는 객체를 더 이상 "빈" 것으로 판단하지 않습니다.

<?php
class test { }
$t = new test();

var_dump(empty($t)); // echo bool(false)

if (!$t) {
    // 이 부분이 실행됩니다.
}
?>

다음 예제는 PHP 4에서는 유효하지만, PHP 5에서는 치명적인 오류를 생성합니다.

예 B-3. 클래스는 사용하기 전에 정의해야 합니다.

<?php
$test = new fubar();
$test->barfu();

class fubar {
    function barfu() {
        echo 'fubar';
    }
}
?>

이전 | 처음으로 | 다음
PHP 4에서 PHP 5로 이행 | 위로 | CLI와 CGI


CLI와 CGI

PHP 5에서 CLI와 CGI 파일명이 변경되었습니다. PHP 5에서, CGI 버전은 php-cgi.exe로 변경되었고 (이전에는 php.exe) CLI 버전이 주 디렉토리에 위치합니다. (이전에는 cli/php.exe)

PHP 5에서, 새로운 모드가 존재합니다: php-win.exe. 이는 CLI 버전과 동일하지만, php-win은 아무것도 출력하지 않으며, 그렇기에 콘솔을 생성하지 않습니다. ("도스창"이 화면에 나타나지 않습니다) 이는 php-gtk와 비슷합니다.

PHP 5에서, CLI 버전은 항상 전역의 $argv와 $argc 변수를 가집니다.

이전 | 처음으로 | 다음
이전 버전과 호환하지 않는 변경점 | 위로 | 설정 파일 이행


설정 파일 이행

ISAPI 모듈들의 이름이 php4xxx에서 php5xxx로 바뀌었기에, 설정 파일에 약간의 변경이 필요합니다. 또한 CLI와 CGI 파일명도 바뀌었으며, 이에 대한 자세한 내용은 해당 섹션을 참고하십시오.

아파치 설정 파일을 이행하는 것은 매우 쉽습니다. 아래의 예제를 보고 필요한 변경을 하십시오:

# 이 줄을:
LoadModule php4_module /php/sapi/php4apache2.dll

# 이렇게 변경합니다:
LoadModule php5_module /php/php5apache2.dll

웹서버가 PHP를 CGI 모드로 실행한다면, CGI 버전의 이름이 php.exe에서 php-cgi.exe로 바뀐 점에 주의해야 합니다. 아파치에서는 다음과 같이 해야 합니다:

# 이 줄을:
Action application/x-httpd-php "/php/php.exe"

# 이렇게 변경합니다:
Action application/x-httpd-php "/php/php-cgi.exe"

다른 웹서버에서도 CGI나 ISAPI 모듈의 파일명을 변경해야 합니다.

이전 | 처음으로 | 다음
CLI와 CGI | 위로 | 새로운 함수들


새로운 함수들

PHP 5에서 새로운 함수가 추가되었습니다. 그 목록입니다:

배열:

  • array_combine() - 하나의 배열을 키로, 하나의 배열을 값으로 가지는 배열을 생성합니다.

  • array_diff_uassoc() - 사용자가 제공하는 콜백 함수를 통한 추가적인 인덱스 확인을 포함하여 배열의 차이를 계산합니다.

  • array_udiff() - 데이터 비교에 콜백 함수를 사용하여 배열의 차이를 계산합니다.

  • array_udiff_assoc() - 추가적인 인덱스 확인을 통한 배열의 차이를 계산합니다. 데이터 비교는 콜백 함수를 사용합니다.

  • array_udiff_uassoc() - 추가적인 인덱스 확인을 통한 배열의 차이를 계산합니다. 데이터 비교는 콜백 함수를 사용합니다. 인덱스 확인도 콜백 함수를 사용합니다.

  • array_walk_recursive() - 배열의 모든 원소에 사용자 함수를 적용합니다.

인터베이스:

  • ibase_affected_rows() - 이전의 질의에 영향을 받은 열의 수를 반환합니다.

  • ibase_backup() - 서비스 관리자에 백업 작업을 실행시키고, 바로 돌아옵니다.

  • ibase_commit_ret() - 트랜젝션을 열어둔 채로 작업을 기록합니다.

  • ibase_db_info() - 데이터베이스에 관한 통계를 요청합니다.

  • ibase_drop_db() - 데이터베이스를 지웁니다.

  • ibase_errcode() - 오류 코드를 반환합니다.

  • ibase_free_event_handler() - 등록되어 있는 이벤트 핸들러를 취소합니다.

  • ibase_gen_id() - Named generator를 증가하고 새로운 값을 반환합니다.

  • ibase_maintain_db() - 데이터베이스 서버에 관리 명령을 실행합니다.

  • ibase_name_result() - 이름을 결과셋에 할당합니다.

  • ibase_num_params() - 준비한 질의문의 인자 수를 반환합니다.

  • ibase_param_info() - 준비한 질의문의 인자에 대한 정보를 반환합니다.

  • ibase_restore() - 서비스 관리자에 복구 작업을 실행시키고, 바로 돌아옵니다.

  • ibase_rollback_ret() - 트랜젝션 내용은 유지한 채로 작업을 되돌립니다.

  • ibase_server_info() - 데이터베이스에 관한 통계를 요청합니다.

  • ibase_service_attach() - 서비스 관리자에 접속합니다.

  • ibase_service_detach() - 서비스 관리자 연결을 끊습니다.

  • ibase_set_event_handler() - 이벤트가 발생했을 때 호출할 콜백 함수를 등록합니다.

  • ibase_wait_event() - 데이터베이스에 의해 이벤트가 발생하기를 기다립니다.

iconv:

  • iconv_mime_decode() - MIME 헤더 필드를 디코드합니다.

  • iconv_mime_decode_headers() - 복수의 MIME 헤더 필드를 한번에 디코드합니다.

  • iconv_mime_encode() - MIME 헤더 필드를 작성합니다.

  • iconv_strlen() - 문자열의 문자 수를 반환합니다.

  • iconv_strpos() - haystack에서 needle이 처음으로 나타나는 위치를 찾습니다.

  • iconv_strrpos() - haystack에 지정한 범위에서 needle이 마지막으로 나타나는 위치를 찾습니다.

  • iconv_substr() - 문자열의 부분을 잘라냅니다.

스트림:

  • stream_copy_to_stream() - 한 스트림의 데이터를 다른 스트림으로 복제합니다.

  • stream_get_line() - 스트림 자원에서 주어진 구분자로 나타나는 열을 얻습니다.

  • stream_socket_accept() - stream_socket_server()로 생성한 소켓에 연결을 받아들입니다.

  • stream_socket_client() - 인터넷이나 유닉스 도메인 소켓 연결을 엽니다.

  • stream_socket_get_name() - 로컬이나 원격 소켓의 이름을 얻습니다.

  • stream_socket_recvfrom() - 연결 여부에 관계 없이, 소켓에서 데이터를 받습니다.

  • stream_socket_sendto() - 연결 여부에 관계 없이, 소켓에 메세지를 보냅니다.

  • stream_socket_server() - 인터넷이나 유닉스 도메인 소켓을 생성합니다.

기타:

  • convert_uudecode() - uuencode된 문자열을 디코드합니다.

  • convert_uuencode() - 문자열을 uuencode합니다.

  • curl_copy_handle() - 모든 속성과 함께 cURL 핸들을 복제합니다.

  • dba_key_split() - 문자열 표현에서 배열 표현으로 키를 분리합니다.

  • dbase_get_header_info() - dBase 데이터베이스의 헤더 정보를 얻습니다.

  • dbx_fetch_row() - DBX_RESULT_UNBUFFERED 플래그를 설정한 질의 결과에서 열을 가져옵니다.

  • fbsql_set_password() - 주어진 사용자의 암호를 변경합니다.

  • file_put_contents() - 문자열을 파일로 씁니다.

  • ftp_alloc() - 업로드할 파일의 공간을 할당합니다.

  • get_declared_interfaces() - 정의된 모든 인터페이스를 배열로 반환합니다.

  • get_headers() - HTTP 요청의 응답으로 서버가 보낸 모든 헤더를 가져옵니다.

  • headers_list() - 보내진 (혹은 보내질) 응답 해더의 목록을 반환합니다.

  • http_build_query() - URL-encode한 쿼리 문자열을 생성합니다.

  • idate() - 로컬 날짜/시간을 정수로 형식화합니다.

  • image_type_to_extension() -
getimagesize(),
exif_read_data(),
exif_thumbnail(),
exif_imagetype() 가 반환한 그림 형식으로 파일
확장자를 얻습니다.

  • imagefilter() - 사용자 각도를 사용하여 그림에 필터를 적용합니다.

  • imap_getacl() - 주어진 편지함을 위한 ACL을 얻습니다.

  • ldap_sasl_bind() - SASL을 사용하여 LDAP 디렉토리에 바인드합니다.

  • mb_list_encodings() - 지원하는 모든 인코딩을 배열로 반환합니다.

  • pcntl_getpriority() - 어떠한 프로세스의 우선권을 얻습니다.

  • pcntl_wait() - waitpid() 시스템 호출에 따라서 자식 프로세스의 상태를 얻거나 기다립니다.

  • pg_version() - 클라이언트, 프로토콜, (가능할 경우) 서버의 버전을 배열로 반환합니다.

  • php_check_syntax() - 지정한 파일의 문법을 확인합니다.

  • php_strip_whitespace() - 주석과 공백을 제거한 소스를 반환합니다.

  • proc_nice() - 현재 프로세스의 우선권을 변경합니다.

  • pspell_config_data_dir() - 언어 데이터 파일의 위치를 변경합니다.

  • pspell_config_dict_dir() - 주 단어 목록의 위치를 변경합니다.

  • setrawcookie() - 값을 url 인코딩 하지 않은 쿠키를 전송합니다.

  • snmp_read_mib() - MIB 파일을 읽어서 활성 MIB 트리에 넣습니다.

  • sqlite_fetch_column_types() - 특정 테이블의 컬럼형을 배열로 반환합니다.

  • str_split() - 문자열으로 배열로 변환합니다.

  • strpbrk() - 문자 집합의 어떠한 문자를 문자열에서 찾습니다.

  • substr_compare() - 이진 호환의 특정 위치에서 길이만큼 두 분자열을 비교합니다. 옵션으로 대소문자 구분을 하지 않을 수 있습니다.

  • time_nanosleep() - 나노초 단위로 지연합니다.

참고: Tidy 확장도 API가 완전히 바뀌었습니다.

이전 | 처음으로 | 다음
설정 파일 이행 | 위로 | 새로운 지시어


새로운 지시어

PHP 5는 몇몇 새로운 php.ini 지시어를 가집니다. 그 목록입니다:

  • mail.force_extra_paramaters - 지정한 인수를 센드메일 바이너리에 추가적인 인수로 전달하도록 강제합니다. 이 인수는 항상 mail()의 다섯번째 인수를 교체합니다. 안전 모드에서도 동작합니다.

  • register_long_arrays - 배제된 긴 형태의 $HTTP_*_VARS를 PHP가 등록할지를 지정합니다.

  • session.hash_function - 해쉬 함수를 선택합니다. (MD5나 SHA-1)

  • session.hash_bits_per_character - 바이너리 해쉬 데이터를 읽을 수 있는 형태로 변환 할 때, 각 문자당 몇 비트를 저장할지 지정합니다 (4에서 6)

  • zend.ze1_compatibility_mode - 젠드 엔진 1 (PHP 4) 호환 모드를 활성화합니다.

이전 | 처음으로 | 다음
새로운 함수들 | 위로 | 데이터베이스


데이터베이스

PHP 5에서 데이터베이스에 관한 변경이 있습니다. (MySQL과 SQLite)

PHP 5에서, 라이센스 문제 등으로 인해 MySQL 클라이언트 라이브러리를 포함하지 않습니다. 자세한 정보는 FAQ 내용을 읽어보십시오.

또한, MySQL 4.1 이상에서 작동하도록 설계된 새로운 확장 모듈, MySQLi (향상된 MySQL)이 추가되었습니다.

PHP 5부터, SQLite 확장 모듈이 PHP에 포함됩니다. SQLite는 임베디드 SQL 데이터베이스 엔진으로, (MySQL이나 PostgreSQL처럼) 커다란 데이터베이스 서버에 접속하기 위한 클라이언트 라이브러리가 아닙니다. SQLite 라이브러리는 디스크의 데이터베이스 파일을 직접 읽고 씁니다.

이전 | 처음으로 | 다음
새로운 지시어 | 위로 | 새로운 객체 모델


새로운 객체 모델

PHP 5에서 새로운 객체 모델이 존재합니다. PHP의 객체 조작은 완전히 새로 쓰여졌으며, 더 나은 성능과 많은 기능을 허용합니다. 자세한 정보는 http://www.php.net/zend-engine-2.php를 읽어보십시오.

이전 | 처음으로 | 다음
데이터베이스 | 위로 | PHP 3 에서 PHP 4로 이주


PHP 3 에서 PHP 4로 이주

PHP 매뉴얼
이전 다음

C. 부록. PHP 3 에서 PHP 4로 이주

차례
PHP 4에서 바뀐것
PHP 3와 PHP 4를 동시에 작동시키기
설정파일 이주하기
해석기(Parser) 동작
에러 보고
초기화
empty("0")
사라진 함수들
PHP 3 확장
Variable substitution in strings
쿠키
전역 변수 다루기

PHP 4에서 바뀐것

PHP 4 와 젠드 엔진은 PHP의 성능과 기능을 크게 향상시켰다. 그러면서도 기존의 코드가 잘 작동할수 있도록 하기위해 주의를 많이 기울였다. PHP 3에서 4로 이주하는 것은 PHP/FI 2에서 PHP 3로 이주하는 것보다는 훨씬 쉽다. 기존의 많은 PHP 3 코드를 변경없이 동작시킬수 있다. 그러나 아직은 약간의 차이를 알아야 하고, 개발 환경에서 버전을 전환하기 전에 코드를 테스트하는데 주의를 기울여야 한다. 다음글은 무엇에 주의해야 하는지에 대한 몇가지 힌트를 보여줄것이다.

이전 | 처음으로 | 다음
새로운 객체 모델 | 위로 | PHP 3와 PHP 4를 동시에 작동시키기


PHP 3와 PHP 4를 동시에 작동시키기

최근 운영 체제는 버전관리(versioning)와 영역관리(scoping) 기능을 제공한다. 이런 기능은 PHP 3와 PHP 3가 아파치 서버에서 동시에 동작하는 모듈로 운영될수 있게 해준다.

이 기능은 다음의 플랫폼에서 작동하는것으로 알려져있다:

  • 최신판의 binutils를 갖는 리눅스 (binutils 2.9.1.0.25가 테스트됨)

  • Solaris 2.5 이상

  • FreeBSD (3.2, 4.0 에서 테스트됨)

이 기능을 활성화시키려면, APXS(--with-apxs)와 필수 링크 확장(--enable-versioning)을 사용하여 PHP3와 PHP4를 설정한다. 그렇지 않으면, 모든 표준 설치 명령이 적용된다. 예를 들면:

$ ./configure \
  --with-apxs=/apache/bin/apxs \
  --enable-versioning \
  --with-mysql \
  --enable-track-vars

이전 | 처음으로 | 다음
PHP 3 에서 PHP 4로 이주 | 위로 | 설정파일 이주하기


설정파일 이주하기

전역 설정 파일, php3.ini, 는 php.ini로 이름이 변경되었다.

아파치 설정 파일에서는 약간의 변화가 생겼다. PHP 모듈에 의해 인식되는 MIME 타입이 변경되었다.

application/x-httpd-php3        -->    application/x-httpd-php
application/x-httpd-php3-source -->    application/x-httpd-php-source

두가지 버전의 PHP와 함께 작동하는 설정 파일을 만들수 있다(서버에 현재 결합되어있는 버전에 따라). 다음과 같은 문법을 사용한다.

AddType  application/x-httpd-php3        .php3
AddType  application/x-httpd-php3-source .php3s

AddType  application/x-httpd-php         .php
AddType  application/x-httpd-php-source  .phps

추가로, 아파치에 대한 PHP 디렉티브 이름도 변경되었다.

PHP 4.0부터는, 4가지의 아파치 디렉티브만이 PHP와 관련되어있다.

php_value [PHP directive name] [value]
php_flag [PHP directive name] [On|Off]
php_admin_value [PHP directive name] [value]
php_admin_flag [PHP directive name] [On|Off]

There are two differences between the Admin values and the non admin values: admin이 있는 디렉티브 값과 admin이 없는 값 사이에는 두가지 차이가 있다:

  • Admin 값(또는 플래그)는 서버-전반에 영향을 미치는 아파치 설정파일(e.g., httpd.conf)에만 존재한다.

  • 일반 값(또는 플래그)는 일부 PHP 디렉티브를 제어할수 없다. 예를 들면: 안전 모드 ( .htaccess에서 안전모드(safe mode) 설정을 덮어쓴다면, 안전 모드의 목적에 어긋나게 할것이다) . 이와 대조적으로, Admin 값은 모든 PHP 디렉티브의 값을 변경할수 있다.

변경 처리를 좀더 쉽게 하기 위해, PHP 4에서는 PHP 3와 PHP 4가 함께 동작하는 아파치 설정과 .htaccess 파일을 자동으로 변환해주는 스크립트를 함께 제공한다. 이 스크립트는 mime타입 라인을 변경하지 않는다! 이 부분은 직접 변환해야 한다.

아파치 설정 파일을 변경하기 위해서는, apconf-conv.sh 스크립트 (scripts/apache/ 디렉토리에 위치함)를 실행한다. 예를 들면:

~/php4/scripts/apache:#  ./apconf-conv.sh /usr/local/apache/conf/httpd.conf

원래 설정 파일은 httpd.conf.orig로 저장될것이다.

.htaccess 파일을 변환하기 위해서는, aphtaccess-conv.sh 스크립트 (scripts/apache/ 디렉토리에도 위치)를 실행한다:

~/php4/scripts/apache:#  find / -name .htaccess -exec ./aphtaccess-conv.sh {} \;

이것도 구버전의 .htaccess 파일을 .orig 어미가 붙어 저장할것이다.

변환 스크립트가 작동하기 위해서는 awk가 설치되어있어야 한다.

이전 | 처음으로 | 다음
PHP 3와 PHP 4를 동시에 작동시키기 | 위로 | 해석기(Parser) 동작


해석기(Parser) 동작

해석과 실행은 현재 두 단계로 완전히 따로 분리되어있다. 파일 코드의 실행은 그 파일전체와 그 파일이 필요로 하는 모든 것들이 성공적으로 해석되고나서야 비로소 이루어진다.

이런 분리를 위해 새로이 필요하게 된것 중 하나는 require와 include된 파일이 문법적으로 완벽해야 한다는 것이다. 이제 더이상 여러 파일간에 제어 구조의 서로 다른 제어 부분을 나눌수 없다. 어떤 파일 안에서 for나 while루프, if 구문이나 switch 블록으로 시작하거나 또 다른 파일 안에서 else, endif, case 나 break구문을 갖을수 없다.

루프나 다른 제어 구조안에서 추가코드를 include하는 것은 아직은 완전히 유효하다. 단, 제어 핵심어와 닫힌 중괄호 {...} 는 동일한 통합 유닛(파일이나 eval()이 적용된 문자열)안에 있어야 한다.

이와 같은 분리된 코드는 어쨋든 매우 나쁜 스타일이긴 하지만 크게 해를 끼치지는 않을것이다.

더이상 유효하지 않은 또다른 특징은 PHP 3 코드에서는 거의 보이지는 않지만 require된 파일로부터 리턴받는 값이다. include된 파일로부터 값을 리턴받는것은 아직까지는 유효하다.

이전 | 처음으로 | 다음
설정파일 이주하기 | 위로 | 에러 보고


에러 보고

변경된 설정

PHP 3에서 에러 보고 레벨은 단순하게 숫자값으로 설정되었다. 이런 숫자값은 다른 에러 레벨과 관련된 숫자를 합쳐서 구성된다. 이용가능한 값중에 15는 모든 에러를 보고하고 7은 나쁜 스타일에 대한것과 이와 비슷한 것들을 보고하는 단순한 경고메시지를 제외한 모든 것을 보고하는데 사용된다.

PHP 4는 에러/경고 레벨을 다량 보유하고 있고 이는 의도된 동작을 위한 설정에 사용되는 심볼릭 상수를 허용하는 설정 해석기로 인해 추가되었다.

현재의 에러 보고 레벨은 심볼릭 상수 E_ALL에서 원하지 않는 경고 레벨값을 x-or 연산을 수행하여 에러 메시지를 생성시키고 싶지 않은 경고 레벨을 명시적으로 제거하도록 설정해야 한다. 복잡해 보이는가? 자, 에러 보고시스템에게 심볼릭 상수 E_NOTICE로 분류되어있는 단순한 스타일 경고를 제외한 모든것을 보고하도록 해보자. php.ini에 다음 설정을 넣어야 할것이다: error_reporting = E_ALL & ~ ( E_NOTICE ). 이진수를 사용하거나 연산자 '|'를 사용하여 괄호 안에 적절한 상수를 추가함으로써 다른 경고도 감출수 있다: error_reporting= E_ALL & ~ ( E_NOTICE | E_WARNING).

주의

PHP 3에서 PHP 4로 코드나 서버를 업그레이드할때 이 설정을 체크해야 하고 error_reporting()를 호출하거나 새로운 에러 타입인 E_COMPILE_ERROR로 에러 보고를 비활성화시킬수 있다. 이 기능은 무슨일이 일어났고 문제가 발생한 장소가 어디인지에 대한 피드백 없이 비어있는 문서를 보여줄것이다.

주의

에러 보고를 설정하기 위해 구버전의 7과 15 값을 사용하는 것은 좋은 생각이 아니다. 왜냐하면 이 값들은 해석 에러를 포함한 새로 추가된 에러의 일부도 보이지 않게 하기 때문이다. 이 값들은 매우 이상한 동작으로 유도할수 있는데 스크립트가 모든 장소에서 에러 메시지를 보이며 작동할것이다.

과거에 잘못 설정된 에러 보고 시스템 때문에 require된 파일 안에 '}' 같은 것을 빠뜨렸을 경우를 TRUE로 보고 해석기가 보고하지 않아서 추적할수 없었던 스크립트 엔진의 문제점이 보고되었는데, 이것은 이런 버그 레포트가 더이상 생기지 않도록 해주었다.

그래서 에러 보고 설정을 체크하는것은 스크립트를 조용하게 die시킬때 우선적으로 해야할 일이다. 젠드 엔진은 현재 이런 종류의 이상한 동작을 발생시키지 않을만큼 충분히 성숙돼 있다고 판단된다.

추가된 경고 메시지

기존의 많은 PHP 3 코드는 좋지 않은 스타일의 언어 구조를 사용하였다. 이 코드는 다른 장소의 코드 변화에 의해 쉽게 파괴될수 있다. PHP 4는 그런 상황에서 PHP 3에서 하지않았던 많은 경고 메시지를 출력할것이다. 이런 경고메시지를 고치려면 단지 E_NOTICE 메시지를 꺼놓아도 되지만, 대신 그 코드를 고치는것이 더 좋은 생각이다.

현재 경고메시지를 발생할수 있는 가장 일반적인 경우가 따옴표로 둘러싸지않고 문자열 상수를 배열의 인덱스로 사용하는 것이다. PHP 3와 PHP 4 모두 이것이 그 이름으로 선언된 상수나 키워드가 아니면 문자열로 해석하게 될것이다. 그러나 그 코드이외의 곳에서 그 이름을 갖는 상수가 선언되기만 하면 그 스크립트를 제대로 작동할수 없게 할수 있다. 그 스크립트에서 침입자에게 주어서는 안될 권한을 줄수 있게 하는 방법으로 침입자가 문자열 상수를 재선언할수만 있다면 보안적인 위험이 될수도 있다. 그래서 PHP 4는 현재 따옴표로 둘러싸지 않은 문자열 상수를 사용할때마다 경고를 하게 될것이다. $_SERVER[REQUEST_METHOD]와 같은 예를 들수 있다. 이것을 $_SERVER['REQUEST_METHOD']으로 변경하면 해석기도 편해지고 스타일과 보안을 크게 향상시킬것이다.

PHP 4가 경고 할 수 있는 다른 것이 초기화되지 않은 변수나 배열 구성요소의 사용이다.

이전 | 처음으로 | 다음
해석기(Parser) 동작 | 위로 | 초기화


초기화

static 변수와 클래스 멤버 초기화는 오직 스칼라 값만을 허용한다. 반면에 PHP 3에서는 모든 유효 표현식이 허용된다. 이것은 ,다시 한번 말하지만, 해석과 실행이 분리되었기 때문이다. 즉 해석기가 생성자를 볼때는 아직 아무 코드도 실행되어 있지 않은 상태에 있다.

클래스에서는 멤버 변수를 초기화하기 위해 생성자를 사용해야 한다. 단순한 static 값을 제외한 모든 static 변수는 이것과는 거의 상관이 없다.

이전 | 처음으로 | 다음
에러 보고 | 위로 | empty("0")


사라진 함수들

PHP 4는 수많은 새로운 기능, 함수, 확장과 함께 릴리즈되었다. 그러나 버전 3에서 제공되던 함수가 몇개 빠졌다는것을 발견할수 있다. 소량의 핵심 함수는 그 함수들이 젠드가 4로 제공하는 해석과 실행을 분리하는 새로운 구조때문에 사라지게 되었다. 다른 함수와 완벽한 확장까지도 새로운 함수와 확장이 같은 작업을 더 잘수행하고 그리고/또는 좀더 일반화된 방식으로 수행되기 때문에 쓸모없게 되었다. 몇개의 함수들은 단순히 아직 포팅되지 않았고 마지막으로 몇개의 함수와 확장은 라이센스 때문에 사라질수도 있게 되었다.

구조적 변화때문에 사라진 함수들

현재 PHP 4는 실행과 해석을 분리했기 때문에 이미 해석기(젠드 엔진에 내장됨)에 의해 해석이 끝나고 나서 런타임시에는 해석기에 의해 동작을 변경할수 없다. 그래서 함수 short_tags()은 더이상 존재하지 않는다. 그러나 아직은 php.ini 파일에 적절한 값을 설정함으로써 해석기의 동작을 변경할수 있다.

PHP 4의 일부가 아니지만 PHP 3의 또다른 기능은 같이 제공된 디버깅 인터페이스이다. 같은 기능을 추가한 젠드 엔진용의 서드파티 애드온이 존재한다.

지원되지 않는 함수와 확장

Adabas 와 Solid 데이터베이스 확장은 더이상 지원되지 않는다. 대신 단일화된 ODBC 확장이 살아 남았다.

unset()을 위한 변경 상태

unset(), 아직 지원되지만, 함수로서보다는 언어 구조로서 구현되었다.

unset()의 동작에 대해 어떤 영향도 받지 않는다. function_exists()을 사용하여 "unset"을 테스트하면 FALSE를 리턴할것이다. echo()함수처럼 언어 구조로서의 역할을 담당한다.

좀더 실질적인 변화는 간접적으로 unset()을 호출할수 없다는 것이다. 즉, $func="unset"; $func($somevar)은 더이상 동작하지 않을것이다.

이전 | 처음으로 | 다음
empty("0") | 위로 | PHP 3 확장


PHP 3 확장

PHP 3를 위해 씌여진 확장은 PHP 4에서 작동하지 않을것이다. 이진파일도 안되고 소스 레벨도 되지 않는다. 원 소스를 접근할수 있다면 PHP 4로 확장을 포팅하는것은 어렵지 않다. 실제 포팅 방법에 대한 상세한 설명은 이 매뉴얼에는 존재하지 않는다.

이전 | 처음으로 | 다음
사라진 함수들 | 위로 | Variable substitution in strings


Variable substitution in strings

PHP 4는 문자열의 가변 치환이라는 새로운 메카니즘을 추가시켰다. 그래서 문자열 안에서 객체 멤버 변수와 다차원 배열의 구성요소에 접근할수 있다.

그렇게 하기 위해서는 달러사인이 바로 뒤에 붙고 중괄호로 막아놓은 변수를 사용해야 한다. 다음과 같은 형태의 중괄호: {$...}

문자열 안에 객체 멤버 변수의 값을 내장시키기 위해서는 간단히 "text {$obj->member} text"이라고 쓰면 된다. PHP 3에서는 "text ".$obj->member." text"와 같은 형태로 사용해야 했다.

이런 형태는 좀더 읽기 좋은 코드로 유도되어야 한다. PHP 3를 위해 쓰여진 기존의 스크립트를 동작시키지 않을수도 있기 때문이다. 그러나 이런 종류의 문제는 코드내에서 {$ 문자 조합을 체크함으로서 간단하게 확인될수 있다. 그리고 선호하는 검색-변경 툴을 사용하여 \{$으로 대체하면 된다.

이전 | 처음으로 | 다음
PHP 3 확장 | 위로 | 쿠키


쿠키

PHP 3는 코드내에서 setcookie() 호출은 반대방향으로 쿠키를 설정하는 좋지 않은 방식을 사용한다. PHP 4는 이런 방식에 의해 동작하지 않는다. 코드에서 쿠키를 설정하는 순대대로 정확하게 쿠키 헤더 줄을 만든다.

이런 동작은 몇몇 기존 코드를 파괴할수 있다. 그러나 구버전의 동작은 매우 이상해서 앞으로의 더 큰 문제를 차단하기 위해 변경할 필요가 있는지 이해할수 없다.

이전 | 처음으로 | 다음
Variable substitution in strings | 위로 | 전역 변수 다루기


전역 변수 다루기

PHP 3와 초기 PHP 4버전에서는 전역 변수를 좀 더 쉽게 다룰수 있지만 약점이 될수 있기 때문에 좀더 안전하게 바뀌었다. PHP 3에서 다음 예제 코드는 잘 작동하지만, PHP 4에서는 unset($GLOBALS["id"]);을 해야 한다. 이 이슈는 단지 전역 변수를 다루는 데만 한정된다. PHP 4의 최신 버전에서는 항상 $GLOBALS를 사용해야 하고 대부분의 경우에 그렇게 해야 할것이다. global 레퍼런스 섹션에서 이 주제에 대한 더 많은 정보를 볼수 있다.

예 C-1. 전역변수의 이주

<?php
$id = 1;
function test()
{
    global $id;
    unset($id);
}
test();
echo($id); // This will print out 1 in PHP 4
?>

이전 | 처음으로 | 다음
쿠키 | 위로 | PHP/FI 2 에서 PHP 3로 이주하기


PHP/FI 2 에서 PHP 3로 이주하기

PHP 매뉴얼
이전 다음

D. 부록. PHP/FI 2 에서 PHP 3로 이주하기

차례
3.0의 비호환성
old_function
Start/end tags
if..endif 문법
while 문법
표현식 타입
변경된 에러 메시지
짧은-순환 논리 비교
함수 TRUE/FALSE 리턴 값
다른 비호환성

3.0의 비호환성

PHP 3.0은 밑바닥부터 다시 작성되었다. 이 버전은 2.0보다 튼튼하고 견고한 해석기를 갖고 있다. 3.0은 또한 속도가 매우 빠르고 메모리를 거의 사용하지 않는다. 그러나, 이런 기능향상을 위해서는 문법과 기능 모두에 대해서 호환성을 위한 변경이 필요하다.

추가로, PHP 개발자는 PHP 3.0의 문법과 의미변화 모두에 대해 완벽하게 이해하도록 노력해야 한다. 이 두가지도 비호환성을 일으킬수 있다. 긴 안목으로 보면, 이런 변화들로 인해 더욱 낳아질거라고 확신한다.

이 챕터는 PHP/FI 2.0에서 PHP 3.0으로 이주할때 빠질수도 있는 비호환성에 대해서 설명하고 그 문제들을 해결하도록 도와주려고 한다. 새로운 기능은 필요치않으면 여기서 언급하지 않는다.

구버전의 PHP/FI 2.0스크립트를 자동으로 변환하는 프로그램이 제공된다. 그 프로그램은 PHP 3.0 배포판의 하위디렉토리인 convertor에서 찾을수 있다. 이 프로그램은 문법적인 변화만 변경할 뿐이기 때문에, 어쨋든 이 챕터를 주의깊게 읽어야 할것이다.

이전 | 처음으로 | 다음
전역 변수 다루기 | 위로 | old_function


Start/end tags

주의해야할 첫번째 사실은 PHP의 시작과 끝 태그가 변경되었다는 것이다. 구버전의 <? > 형태는 세가지 사용가능한 새 형태로 변경되었다:

예 D-1. 이주: 구버전의 시작/끝 태그

<? echo "This is PHP/FI 2.0 code.\n"; ?>
버전 2.0의 PHP/FI는 이런 변종도 지원한다:

예 D-2. 이주: 첫번째 새로운 시작/끝 태그

<? echo "This is PHP 3.0 code!\n"; ?>
끝 태그는 현재 단순히 보다-크다(>) 문자대신에 물음표와 보다-크다(>) 문자로 구성되어있다. 하지만, 서버에 XML을 사용할 계획이라면, 첫번째 새로운 변종으로는 문제가 발생할것이다. 왜냐하면 PHP는 XML 문서에 XML 마크업을 PHP 코드로 실행하려 할수 있기 때문이다. 이와 같은 이유로, 다음 변종이 제공된다:

예 D-3. 이주: 두번째 새로운 시작/끝 태그

<?php echo "This is PHP 3.0 code!\n"; ?>
일부사람들은 이런 태그를 처리명령 태그로 전혀 이해할수 없는 에디터를 사용하기 때문에 문제가 발생한다. 마이크로소프트 프론트페이지는 그런 에디터 중 하나이고, 이런 문제를 피하는 방법으로서 다음과 같은 변종도 함께 제공된다:

예 D-4. 이주: 세번째 새로운 시작/끝 태그

<script language="php">

  echo "This is PHP 3.0 code!\n";

</script>

이전 | 처음으로 | 다음
old_function | 위로 | if..endif 문법


if..endif 문법

if/elseif/else 구문을 작성하는 '부차적인' 방법인, if(); elseif(); else; endif; 는 3.0 해석기의 거대한 복잡성을 추가하지 않고는 효과적으로 구현될수 없다. 이런 이유때문에, 문법이 변경되었다:

예 D-5. 이주: 구버전의 if..endif 문법

if ($foo);
    echo "yep\n";
elseif ($bar);
    echo "almost\n";
else;
    echo "nope\n";
endif;

예 D-6. 이주: 새로운 if..endif 문법

if ($foo):
    echo "yep\n";
elseif ($bar):
    echo "almost\n";
else:
    echo "nope\n";
endif;
구문을 종료하는 하나(endif)를 제외하고 구문 전체에서 세미콜론이 콜론으로 변경되었다는것에 주의한다.

이전 | 처음으로 | 다음
Start/end tags | 위로 | while 문법


while 문법

if..endif 와 비슷하게, while..endwhile 문법도 변경되었다:

예 D-7. 이주: 구버전의 while..endwhile 문법

while ($more_to_come);
    ...
endwhile;

예 D-8. 이주: 새로운 while..endwhile 문법

while ($more_to_come):
    ...
endwhile;

주의

PHP 3.0에서 구버전의 while..endwhile 문법을 사용한다면, 루프를 결코 끝낼수 없을것이다.

이전 | 처음으로 | 다음
if..endif 문법 | 위로 | 표현식 타입


표현식 타입

PHP/FI 2.0은 결과값이 무슨 타입이 되어야 할지 결정하기 위해 표현식의 좌변을 사용한다. PHP 3.0은 결과 타입을 결정하는데 양변 모두를 취할 수 있다. 그리고 이런 형태는 2.0 스크립트가 3.0에서 기대하는대로 동작하지 않게 할수 있다.

다음 예제 코드를 보자:

$a[0]=5;
$a[1]=7;

$key = key($a);
while ("" != $key) {
    echo "$keyn";
    next($a);
}

PHP/FI 2.0에서, 이 예제코드는 $a의 인덱스를 출력할것이다. PHP 3.0에서는 아무것도 출력되지 않을것이다. 그 이유는 PHP 2.0 안에서 좌측 인자의 타입이 문자열이고, 문자열 비교가 수행되고, ""는 "0"과 같지 않아서 루프를 계속 돌기 때문이다. PHP 3.0에서는, 문자열이 정수와 비교될때, 정수 비교가 수행된다(문자열은 정수로 변환됨). 0이 되는 atoi("")와 비교되는데 variablelist도 0이 있어서, 0==0이기 때문에, 루프는 한번도 수행되지 않는다.

이것에 대한 변경은 간단하다. 다음과 같은 while 구문으로 변경한다:

while ((string)$key != "") {

이전 | 처음으로 | 다음
while 문법 | 위로 | 변경된 에러 메시지


변경된 에러 메시지

PHP 3.0의 에러 메시지는 대체로 2.0보다는 정확하다. 그러나 에러를 일으키는 코드 파편을 더이상 볼수 없다. 대신에, 에러가 발생하는 파일명과 라인 번호가 제공될 것이다.

이전 | 처음으로 | 다음
표현식 타입 | 위로 | 짧은-순환 논리 비교


짧은-순환 논리 비교

PHP 3.0의 논리 비교는 짧은-순환이다. 이 말은 의미는 (1 || test_me())와 같은 표현식에서, test_me() 함수는 1다음의 표현식이 결과값을 변경하지 않기 때문에 수행되지 않을것이다.

이것은 미세한 호환성 문제이지만, 기대치 않는 사이드-이펙트를 발생시킬것이다.

이전 | 처음으로 | 다음
변경된 에러 메시지 | 위로 | 함수 TRUE/FALSE 리턴 값


다른 비호환성

  • PHP 3.0의 아파치 모듈은 더이상 아파치 1.2 이전 버전을 지원하지 않는다. 아파치 1.2 이후 버전이 필요하다.

  • echo()는 더이상 포맷화된 문자열을 지원하지 않는다. 대신 printf() 함수를 사용하도록 한다.

  • PHP/FI 2.0에서, 구현상의 사이드-이펙트는 $foo와 같은 결과를 내기 위해서 $foo[0]를 사용한다. 이런 구현은 PHP 3.0에서는 사용되지 않는다.

  • $array[]로 배열을 읽는것은 더이상 지원되지 않는다.

    즉, $data = $array[]를 수행하는 루프를 통해서 배열을 돌아다닐수는 없다. 대신 current()와 next()를 사용한다.

    $array1[] = $array2는 $array1에 $array2값을 추가하지 않는다. 그러나 $array1의 마지막 구성요소로서 $array2을 추가한다. 다차원 배열 지원에 대한 것도 참고할것.

  • "+"는 그 인자를 숫자로 변환하고 숫자 덧셈을 수행하는 것 외의 문자열의 결합 연산자로 더이상 오버로드되지 않는다. 대신 "."을 사용하자.

예 D-11. 2.0으로부터의 이주: 문자열의 결합

echo "1" + "1";

PHP 2.0에서 이 코드는 11을 echo하지만, PHP 3.0에서는 대신 2를 echo한다:
echo "1"."1";
$a = 1;
$b = 1;
echo $a + $b;

이 코드는 PHP 2.0과 3.0 모두 2를 echo한다.
$a = 1;
$b = 1;
echo $a.$b;
이 코드는 PHP 3.0에서 11을 echo한다.

이전 | 처음으로 | 다음
함수 TRUE/FALSE 리턴 값 | 위로 | PHP 디버깅하기


PHP 디버깅하기

PHP 매뉴얼
이전 다음

E. 부록. PHP 디버깅하기

차례
디버거에 관하여
디버거 사용하기
디버거 프로토콜

디버거에 관하여

PHP 3는 네트워크-기반의 디버거가 지원된다.

PHP 4는 내장된 디버깅 기능을 갖지 않는다. 대신 외부 디버거 중 하나를 이용할수 있다. Zend IDE는 디버거를 내장하고 있고, http://dd.cron.ru/dbg/에서 DBG같은 몇가지 무료 디버거 확장을 볼수 있다. Advanced PHP Debugger (APD) 나 Xdebug는 이 섹션에서 설명하는 PHP 3의 디버깅 기능과 같은 디버거 인터페이스 호환성을 갖는다.

이전 | 처음으로 | 다음
다른 비호환성 | 위로 | 디버거 사용하기


디버거 사용하기

PHP 3의 내장 디버거는 파악하기 어려운 버그를 추적하는데 사용할수있다. 디버거는 PHP 3가 시작하는 모든 시간 동안 TCP 포트를 통한 접속에 의해 작동한다. 각 요구로부터 발생하는 모든 에러 메시지는 이 TCP 접속으로 수신될것이다. IDE나 프로그램용 에디터 (Emacs같은)안에서 실행되는 "디버깅 서버"에 대한 정보가 여기서 설명된다.

디버거를 설정하는 방법:

  1. configuration file에서 디버거를 위한 TCP 포트를 설정하고 (debugger.port), 활성화시킨다 (debugger.enabled).

  2. 그 포트에 TCP 리스너를 설정한다 (예를 들면 유닉스에서는 socket -l -s 1400).

  3. 코드에서, "debugger_on(host)"를 실행한다. 여기서 host는 IP 숫자나 TCP 리스너가 실행되고 있는 호스트의 이름이다.

이제부터는 모든 경고, 주의 등의 메시지가 그 리스너 소켓에서 보이게된다. 심지어 error_reporting()으로 활성화시키지 않아도 그렇게 된다.

이전 | 처음으로 | 다음
PHP 디버깅하기 | 위로 | 디버거 프로토콜


디버거 프로토콜

PHP 3 디버거 프로토콜은 줄-단위다. 각 줄은 각각 type을 갖고, 몇개의 줄이 message를 구성한다. 각 메시지는 start 타입의 줄로 시작되고 end 타입의 줄로 종료된다. PHP 3는 동시에 서로 다른 메시지 줄을 보낼수 있다.

각 줄은 다음과 같은 포맷을 갖을수 있다:

date time host(pid) type: message-data

date

ISO 8601 포맷의 날짜 (yyyy-mm-dd)

time

마이크로초를 포함하는 시간: hh:mm:uuuuuu

host

스크립트 에러가 발생하는 호스트의 DNS 이름이나 IP 주소

pid

이 에러를 발생하는 PHP 3 스크립트의 프로세스의 host상의 PID (프로세스 ID)

type

줄 타입. 수신 프로그램에게 다음 데이터를 취급해야 한다는것을 알려줌:

표 E-1. 디버거 줄 타입

Name | Meaning
start | 수신 프로그램에게 디버거 메시지가 여기서 시작됨을 알림. data의 내용이 아래 목록처럼 에러 메시지의 타입이 될것이다.
message | PHP 3 에러 메시지.
location | 에러가 발생한 파일명과 줄번호. 첫번째 location 줄은 항상 상단의 위치를 내포할것이다. data는 file:line을 포함한다. message와 모든 function 이후에 항상 location 줄이 될것이다.
frames | 다음 스택 덤프 안의 프레임 번호. 4개의 프레임이 존재한다면, 호출되는 함수의 네단계의 정보를 기대할수 있다. "frames"줄이 보이지 않으면, 스택의 깊이는 0이라고 볼수 있다 (상단에서 에러가 발생함).
function | 에러가 발생하는 함수명. 함수 호출 스택안의 모든 레벨에서 한번씩 반복될것이다.
end | 수신 프로그램에게 디버거 메시지가 여기서 끝난다고 알림.

data

Line data.

표 E-2. 디버거 에러 타입

Debugger | PHP 3 Internal
warning | E_WARNING
error | E_ERROR
parse | E_PARSE
notice | E_NOTICE
core-error | E_CORE_ERROR
core-warning | E_CORE_WARNING
unknown | (any other)

예 E-1. 예제 디버거 메시지

1998-04-05 23:27:400966 lucifer.guardian.no(20481) start: notice
1998-04-05 23:27:400966 lucifer.guardian.no(20481) message: Uninitialized variable
1998-04-05 23:27:400966 lucifer.guardian.no(20481) location: (null):7
1998-04-05 23:27:400966 lucifer.guardian.no(20481) frames: 1
1998-04-05 23:27:400966 lucifer.guardian.no(20481) function: display
1998-04-05 23:27:400966 lucifer.guardian.no(20481) location: /home/ssb/public_html/test.php3:10
1998-04-05 23:27:400966 lucifer.guardian.no(20481) end: notice

이전 | 처음으로 | 다음
디버거 사용하기 | 위로 | PHP 3 확장


PHP 3 확장

PHP 매뉴얼
이전 다음

F. 부록. PHP 3 확장

차례
Adding functions to PHP
Calling User Functions
Reporting Errors

이 섹션은 구버전의 PHP 3를 확장하는 방법을 설명한다. PHP 4에 관심이 있다면, Zend API의 섹션을 읽기 바란다. PHP 소스의 여러 파일과 README.SELF-CONTAINED-EXTENSIONS 와 README.EXT_SKEL 같은 파일들을 읽어야 할것이다.

Adding functions to PHP

Function Prototype

All functions look like this:
void php3_foo(INTERNAL_FUNCTION_PARAMETERS) {

}
Even if your function doesn't take any arguments, this is how it is called.

Function Arguments

Arguments are always of type pval. This type contains a union which has the actual type of the argument. So, if your function takes two arguments, you would do something like the following at the top of your function:

예 F-1. Fetching function arguments

pval *arg1, *arg2;
if (ARG_COUNT(ht) != 2 || getParameters(ht,2,&arg1,&arg2)==FAILURE) {
   WRONG_PARAM_COUNT;
}
NOTE: Arguments can be passed either by value or by reference. In both cases you will need to pass &(pval *) to getParameters. If you want to check if the n'th parameter was sent to you by reference or not, you can use the function, ParameterPassedByReference(ht,n). It will return either 1 or 0.

When you change any of the passed parameters, whether they are sent by reference or by value, you can either start over with the parameter by calling pval_destructor on it, or if it's an ARRAY you want to add to, you can use functions similar to the ones in internal_functions.h which manipulate return_value as an ARRAY.

Also if you change a parameter to IS_STRING make sure you first assign the new estrdup()'ed string and the string length, and only later change the type to IS_STRING. If you change the string of a parameter which already IS_STRING or IS_ARRAY you should run pval_destructor on it first.

Variable Function Arguments

A function can take a variable number of arguments. If your function can take either 2 or 3 arguments, use the following:

예 F-2. Variable function arguments

pval *arg1, *arg2, *arg3;
int arg_count = ARG_COUNT(ht);

if (arg_count < 2 || arg_count > 3 ||
    getParameters(ht,arg_count,&arg1,&arg2,&arg3)==FAILURE) {
    WRONG_PARAM_COUNT;
}

Using the Function Arguments

The type of each argument is stored in the pval type field. This type can be any of the following:

표 F-1. PHP Internal Types

IS_STRING | String
IS_DOUBLE | Double-precision floating point
IS_LONG | Long integer
IS_ARRAY | Array
IS_EMPTY | None
IS_USER_FUNCTION | ??
IS_INTERNAL_FUNCTION | ?? (if some of these cannot be passed to a function - delete)
IS_CLASS | ??
IS_OBJECT | ??

If you get an argument of one type and would like to use it as another, or if you just want to force the argument to be of a certain type, you can use one of the following conversion functions:
convert_to_long(arg1);
convert_to_double(arg1);
convert_to_string(arg1);
convert_to_boolean_long(arg1); /* If the string is "" or "0" it becomes 0, 1 otherwise */
convert_string_to_number(arg1);  /* Converts string to either LONG or DOUBLE depending on string */

These function all do in-place conversion. They do not return anything.

The actual argument is stored in a union; the members are:

  • IS_STRING: arg1->value.str.val

  • IS_LONG: arg1->value.lval

  • IS_DOUBLE: arg1->value.dval

Memory Management in Functions

Any memory needed by a function should be allocated with either emalloc() or estrdup(). These are memory handling abstraction functions that look and smell like the normal malloc() and strdup() functions. Memory should be freed with efree().

There are two kinds of memory in this program: memory which is returned to the parser in a variable, and memory which you need for temporary storage in your internal function. When you assign a string to a variable which is returned to the parser you need to make sure you first allocate the memory with either emalloc() or estrdup(). This memory should NEVER be freed by you, unless you later in the same function overwrite your original assignment (this kind of programming practice is not good though).

For any temporary/permanent memory you need in your functions/library you should use the three emalloc(), estrdup(), and efree() functions. They behave EXACTLY like their counterpart functions. Anything you emalloc() or estrdup() you have to efree() at some point or another, unless it's supposed to stick around until the end of the program; otherwise, there will be a memory leak. The meaning of "the functions behave exactly like their counterparts" is: if you efree() something which was not emalloc()'ed nor estrdup()'ed you might get a segmentation fault. So please take care and free all of your wasted memory.

If you compile with "-DDEBUG", PHP will print out a list of all memory that was allocated using emalloc() and estrdup() but never freed with efree() when it is done running the specified script.

Setting Variables in the Symbol Table

A number of macros are available which make it easier to set a variable in the symbol table:

  • SET_VAR_STRING(name,value)

  • SET_VAR_DOUBLE(name,value)

  • SET_VAR_LONG(name,value)

주의

Be careful with SET_VAR_STRING. The value part must be malloc'ed manually because the memory management code will try to free this pointer later. Do not pass statically allocated memory into a SET_VAR_STRING.

Symbol tables in PHP are implemented as hash tables. At any given time, &symbol_table is a pointer to the 'main' symbol table, and active_symbol_table points to the currently active symbol table (these may be identical like in startup, or different, if you're inside a function).

The following examples use 'active_symbol_table'. You should replace it with &symbol_table if you specifically want to work with the 'main' symbol table. Also, the same functions may be applied to arrays, as explained below.

예 F-3. Checking whether $foo exists in a symbol table

if (hash_exists(active_symbol_table,"foo",sizeof("foo"))) { exists... }
else { doesn't exist }

예 F-4. Finding a variable's size in a symbol table

hash_find(active_symbol_table,"foo",sizeof("foo"),&pvalue);
check(pvalue.type);
Arrays in PHP are implemented using the same hashtables as symbol tables. This means the two above functions can also be used to check variables inside arrays.

If you want to define a new array in a symbol table, you should do the following.

First, you may want to check whether it exists and abort appropriately, using hash_exists() or hash_find().

Next, initialize the array:

예 F-5. Initializing a new array

pval arr;

if (array_init(&arr) == FAILURE) { failed... };
hash_update(active_symbol_table,"foo",sizeof("foo"),&arr,sizeof(pval),NULL);
This code declares a new array, named $foo, in the active symbol table. This array is empty.

Here's how to add new entries to it:

예 F-6. Adding entries to a new array

pval entry;

entry.type = IS_LONG;
entry.value.lval = 5;

/* defines $foo["bar"] = 5 */
hash_update(arr.value.ht,"bar",sizeof("bar"),&entry,sizeof(pval),NULL);

/* defines $foo[7] = 5 */
hash_index_update(arr.value.ht,7,&entry,sizeof(pval),NULL);

/* defines the next free place in $foo[],
 * $foo[8], to be 5 (works like php2)
 */
hash_next_index_insert(arr.value.ht,&entry,sizeof(pval),NULL);
If you'd like to modify a value that you inserted to a hash, you must first retrieve it from the hash. To prevent that overhead, you can supply a pval ** to the hash add function, and it'll be updated with the pval * address of the inserted element inside the hash. If that value is NULL (like in all of the above examples) - that parameter is ignored.

hash_next_index_insert() uses more or less the same logic as "$foo[] = bar;" in PHP 2.0.

If you are building an array to return from a function, you can initialize the array just like above by doing:

if (array_init(return_value) == FAILURE) { failed...; }

...and then adding values with the helper functions:

add_next_index_long(return_value,long_value);
add_next_index_double(return_value,double_value);
add_next_index_string(return_value,estrdup(string_value));

Of course, if the adding isn't done right after the array initialization, you'd probably have to look for the array first:
pval *arr;

if (hash_find(active_symbol_table,"foo",sizeof("foo"),(void **)&arr)==FAILURE) { can't find... }
else { use arr->value.ht... }

Note that hash_find receives a pointer to a pval pointer, and not a pval pointer.

Just about any hash function returns SUCCESS or FAILURE (except for hash_exists(), which returns a boolean truth value).

Returning simple values

A number of macros are available to make returning values from a function easier.

The RETURN_* macros all set the return value and return from the function:

  • RETURN

  • RETURN_FALSE

  • RETURN_TRUE

  • RETURN_LONG(l)

  • RETURN_STRING(s,dup) If dup is TRUE, duplicates the string

  • RETURN_STRINGL(s,l,dup) Return string (s) specifying length (l).

  • RETURN_DOUBLE(d)

The RETVAL_* macros set the return value, but do not return.

  • RETVAL_FALSE

  • RETVAL_TRUE

  • RETVAL_LONG(l)

  • RETVAL_STRING(s,dup) If dup is TRUE, duplicates the string

  • RETVAL_STRINGL(s,l,dup) Return string (s) specifying length (l).

  • RETVAL_DOUBLE(d)

The string macros above will all estrdup() the passed 's' argument, so you can safely free the argument after calling the macro, or alternatively use statically allocated memory.

If your function returns boolean success/error responses, always use RETURN_TRUE and RETURN_FALSE respectively.

Returning complex values

Your function can also return a complex data type such as an object or an array.

Returning an object:

  1. Call object_init(return_value).

  2. Fill it up with values. The functions available for this purpose are listed below.

  3. Possibly, register functions for this object. In order to obtain values from the object, the function would have to fetch "this" from the active_symbol_table. Its type should be IS_OBJECT, and it's basically a regular hash table (i.e., you can use regular hash functions on .value.ht). The actual registration of the function can be done using:
    add_method( return_value, function_name, function_ptr );

The functions used to populate an object are:

  • add_property_long( return_value, property_name, l ) - Add a property named 'property_name', of type long, equal to 'l'

  • add_property_double( return_value, property_name, d ) - Same, only adds a double

  • add_property_string( return_value, property_name, str ) - Same, only adds a string

  • add_property_stringl( return_value, property_name, str, l ) - Same, only adds a string of length 'l'

Returning an array:

  1. Call array_init(return_value).

  2. Fill it up with values. The functions available for this purpose are listed below.

The functions used to populate an array are:

  • add_assoc_long(return_value,key,l) - add associative entry with key 'key' and long value 'l'

  • add_assoc_double(return_value,key,d)

  • add_assoc_string(return_value,key,str,duplicate)

  • add_assoc_stringl(return_value,key,str,length,duplicate) specify the string length

  • add_index_long(return_value,index,l) - add entry in index 'index' with long value 'l'

  • add_index_double(return_value,index,d)

  • add_index_string(return_value,index,str)

  • add_index_stringl(return_value,index,str,length) - specify the string length

  • add_next_index_long(return_value,l) - add an array entry in the next free offset with long value 'l'

  • add_next_index_double(return_value,d)

  • add_next_index_string(return_value,str)

  • add_next_index_stringl(return_value,str,length) - specify the string length

Using the resource list

PHP has a standard way of dealing with various types of resources. This replaces all of the local linked lists in PHP 2.0.

Available functions:

  • php3_list_insert(ptr, type) - returns the 'id' of the newly inserted resource

  • php3_list_delete(id) - delete the resource with the specified id

  • php3_list_find(id,*type) - returns the pointer of the resource with the specified id, updates 'type' to the resource's type

Typically, these functions are used for SQL drivers but they can be used for anything else; for instance, maintaining file descriptors.

Typical list code would look like this:

예 F-7. Adding a new resource

RESOURCE *resource;

/* ...allocate memory for resource and acquire resource... */
/* add a new resource to the list */
return_value->value.lval = php3_list_insert((void *) resource, LE_RESOURCE_TYPE);
return_value->type = IS_LONG;

예 F-8. Using an existing resource

pval *resource_id;
RESOURCE *resource;
int type;

convert_to_long(resource_id);
resource = php3_list_find(resource_id->value.lval, &type);
if (type != LE_RESOURCE_TYPE) {
    php3_error(E_WARNING,"resource index %d has the wrong type",resource_id->value.lval);
    RETURN_FALSE;
}
/* ...use resource... */

예 F-9. Deleting an existing resource

pval *resource_id;
RESOURCE *resource;
int type;

convert_to_long(resource_id);
php3_list_delete(resource_id->value.lval);
The resource types should be registered in php3_list.h, in enum list_entry_type. In addition, one should add shutdown code for any new resource type defined, in list.c's list_entry_destructor() (even if you don't have anything to do on shutdown, you must add an empty case).

Using the persistent resource table

PHP has a standard way of storing persistent resources (i.e., resources that are kept in between hits). The first module to use this feature was the MySQL module, and mSQL followed it, so one can get the general impression of how a persistent resource should be used by reading mysql.c. The functions you should look at are:

php3_mysql_do_connect
php3_mysql_connect()
php3_mysql_pconnect()

The general idea of persistence modules is this:

  1. Code all of your module to work with the regular resource list mentioned in section (9).

  2. Code extra connect functions that check if the resource already exists in the persistent resource list. If it does, register it as in the regular resource list as a pointer to the persistent resource list (because of 1., the rest of the code should work immediately). If it doesn't, then create it, add it to the persistent resource list AND add a pointer to it from the regular resource list, so all of the code would work since it's in the regular resource list, but on the next connect, the resource would be found in the persistent resource list and be used without having to recreate it. You should register these resources with a different type (e.g. LE_MYSQL_LINK for non-persistent link and LE_MYSQL_PLINK for a persistent link).

If you read mysql.c, you'll notice that except for the more complex connect function, nothing in the rest of the module has to be changed.

The very same interface exists for the regular resource list and the persistent resource list, only 'list' is replaced with 'plist':

  • php3_plist_insert(ptr, type) - returns the 'id' of the newly inserted resource

  • php3_plist_delete(id) - delete the resource with the specified id

  • php3_plist_find(id,*type) - returns the pointer of the resource with the specified id, updates 'type' to the resource's type

However, it's more than likely that these functions would prove to be useless for you when trying to implement a persistent module. Typically, one would want to use the fact that the persistent resource list is really a hash table. For instance, in the MySQL/mSQL modules, when there's a pconnect() call (persistent connect), the function builds a string out of the host/user/passwd that were passed to the function, and hashes the SQL link with this string as a key. The next time someone calls a pconnect() with the same host/user/passwd, the same key would be generated, and the function would find the SQL link in the persistent list.

Until further documented, you should look at mysql.c or msql.c to see how one should use the plist's hash table abilities.

One important thing to note: resources going into the persistent resource list must *NOT* be allocated with PHP's memory manager, i.e., they should NOT be created with emalloc(), estrdup(), etc. Rather, one should use the regular malloc(), strdup(), etc. The reason for this is simple - at the end of the request (end of the hit), every memory chunk that was allocated using PHP's memory manager is deleted. Since the persistent list isn't supposed to be erased at the end of a request, one mustn't use PHP's memory manager for allocating resources that go to it.

When you register a resource that's going to be in the persistent list, you should add destructors to it both in the non-persistent list and in the persistent list. The destructor in the non-persistent list destructor shouldn't do anything. The one in the persistent list destructor should properly free any resources obtained by that type (e.g. memory, SQL links, etc). Just like with the non-persistent resources, you *MUST* add destructors for every resource, even it requires no destruction and the destructor would be empty. Remember, since emalloc() and friends aren't to be used in conjunction with the persistent list, you mustn't use efree() here either.

Adding runtime configuration directives

Many of the features of PHP can be configured at runtime. These configuration directives can appear in either the designated php3.ini file, or in the case of the Apache module version in the Apache .conf files. The advantage of having them in the Apache .conf files is that they can be configured on a per-directory basis. This means that one directory may have a certain safemodeexecdir for example, while another directory may have another. This configuration granularity is especially handy when a server supports multiple virtual hosts.

The steps required to add a new directive:

  1. Add directive to php3_ini_structure struct in mod_php3.h.

  2. In main.c, edit the php3_module_startup function and add the appropriate cfg_get_string() or cfg_get_long() call.

  3. Add the directive, restrictions and a comment to the php3_commands structure in mod_php3.c. Note the restrictions part. RSRC_CONF are directives that can only be present in the actual Apache .conf files. Any OR_OPTIONS directives can be present anywhere, include normal .htaccess files.

  4. In either php3take1handler() or php3flaghandler() add the appropriate entry for your directive.

  5. In the configuration section of the _php3_info() function in functions/info.c you need to add your new directive.

  6. And last, you of course have to use your new directive somewhere. It will be addressable as php3_ini.directive.

이전 | 처음으로 | 다음
디버거 프로토콜 | 위로 | Calling User Functions


Calling User Functions

To call user functions from an internal function, you should use the call_user_function() function.

call_user_function() returns SUCCESS on success, and FAILURE in case the function cannot be found. You should check that return value! If it returns SUCCESS, you are responsible for destroying the retval pval yourself (or return it as the return value of your function). If it returns FAILURE, the value of retval is undefined, and you mustn't touch it.

All internal functions that call user functions must be reentrant. Among other things, this means they must not use globals or static variables.

call_user_function() takes six arguments:

HashTable *function_table

This is the hash table in which the function is to be looked up.

pval *object

This is a pointer to an object on which the function is invoked. This should be NULL if a global function is called. If it's not NULL (i.e. it points to an object), the function_table argument is ignored, and instead taken from the object's hash. The object *may* be modified by the function that is invoked on it (that function will have access to it via $this). If for some reason you don't want that to happen, send a copy of the object instead.

pval *function_name

The name of the function to call. Must be a pval of type IS_STRING with function_name.str.val and function_name.str.len set to the appropriate values. The function_name is modified by call_user_function() - it's converted to lowercase. If you need to preserve the case, send a copy of the function name instead.

pval *retval

A pointer to a pval structure, into which the return value of the invoked function is saved. The structure must be previously allocated - call_user_function() does NOT allocate it by itself.

int param_count

The number of parameters being passed to the function.

pval *params[]

An array of pointers to values that will be passed as arguments to the function, the first argument being in offset 0, the second in offset 1, etc. The array is an array of pointers to pval's; The pointers are sent as-is to the function, which means if the function modifies its arguments, the original values are changed (passing by reference). If you don't want that behavior, pass a copy instead.

이전 | 처음으로 | 다음
PHP 3 확장 | 위로 | Reporting Errors


Reporting Errors

To report errors from an internal function, you should call the php3_error() function. This takes at least two parameters -- the first is the level of the error, the second is the format string for the error message (as in a standard printf() call), and any following arguments are the parameters for the format string. The error levels are:

E_NOTICE

Notices are not printed by default, and indicate that the script encountered something that could indicate an error, but could also happen in the normal course of running a script. For example, trying to access the value of a variable which has not been set, or calling stat() on a file that doesn't exist.

E_WARNING

Warnings are printed by default, but do not interrupt script execution. These indicate a problem that should have been trapped by the script before the call was made. For example, calling ereg() with an invalid regular expression.

E_ERROR

Errors are also printed by default, and execution of the script is halted after the function returns. These indicate errors that can not be recovered from, such as a memory allocation problem.

E_PARSE

Parse errors should only be generated by the parser. The code is listed here only for the sake of completeness.

E_CORE_ERROR

This is like an E_ERROR, except it is generated by the core of PHP. Functions should not generate this type of error.

E_CORE_WARNING

This is like an E_WARNING, except it is generated by the core of PHP. Functions should not generate this type of error.

E_COMPILE_ERROR

This is like an E_ERROR, except it is generated by the Zend Scripting Engine. Functions should not generate this type of error.

E_COMPILE_WARNING

This is like an E_WARNING, except it is generated by the Zend Scripting Engine. Functions should not generate this type of error.

E_USER_ERROR

This is like an E_ERROR, except it is generated in PHP code by using the PHP function trigger_error(). Functions should not generate this type of error.

E_USER_WARNING

This is like an E_WARNING, except it is generated by using the PHP function trigger_error(). Functions should not generate this type of error.

E_USER_NOTICE

This is like an E_NOTICE, except it is generated by using the PHP function trigger_error(). Functions should not generate this type of error.

E_ALL

All of the above. Using this error_reporting level will show all error types.

이전 | 처음으로 | 다음
Calling User Functions | 위로 | 함수 별칭 목록


함수 별칭 목록

PHP 매뉴얼
이전 다음

G. 부록. 함수 별칭 목록

여기서는 함수 별칭 목록을 보인다. 모든 별칭들이 여기서 목록화된다. 별칭을 사용하는 것은 일반적으로 좋은 생각이 아니다. 왜냐하면, 그런 함수는 기능이 떨어지거나 새로운 이름으로 바뀌게 되어 호환되지 않는 스크립트로 유도될수 있기때문이다. 이 목록은 그런 오래된 스크립트를 새로운 문법으로 업그레이드하고자 하는 사람들에게 도움을 주고자 제공된다.

하지만, 몇가지 함수들은 단순히 두개의 이름을 갖고 있고, 실제 차이가 존재하지 않는다. (예를 들면, is_int() 와 is_integer() 은 모두 양호하다)

이 목록은 PHP 4.0.6 기준입니다. 매일 갱신하는 별칭 목록은 http://zend.com/phpfunc/all_aliases.php를 참고하십시오.

표 G-1. Aliases

Alias | Master function | Extension used
_ | gettext() | Gettext
add | swfmovie_add() | Ming (flash)
add | swfsprite_add() | Ming (flash)
add_root | domxml_add_root() | DOM XML
addaction | swfbutton_addAction() | Ming (flash)
addcolor | swfdisplayitem_addColor() | Ming (flash)
addentry | swfgradient_addEntry() | Ming (flash)
addfill | swfshape_addfill() | Ming (flash)
addshape | swfbutton_addShape() | Ming (flash)
addstring | swftext_addString() | Ming (flash)
addstring | swftextfield_addString() | Ming (flash)
align | swftextfield_align() | Ming (flash)
attributes | domxml_attributes() | DOM XML
children | domxml_children() | DOM XML
chop | rtrim() | Base syntax
close | closedir() | Base syntax
com_get | com_propget() | COM
com_propset | com_propput() | COM
com_set | com_propput() | COM
cv_add | ccvs_add() | CCVS
cv_auth | ccvs_auth() | CCVS
cv_command | ccvs_command() | CCVS
cv_count | ccvs_count() | CCVS
cv_delete | ccvs_delete() | CCVS
cv_done | ccvs_done() | CCVS
cv_init | ccvs_init() | CCVS
cv_lookup | ccvs_lookup() | CCVS
cv_new | ccvs_new() | CCVS
cv_report | ccvs_report() | CCVS
cv_return | ccvs_return() | CCVS
cv_reverse | ccvs_reverse() | CCVS
cv_sale | ccvs_sale() | CCVS
cv_status | ccvs_status() | CCVS
cv_textvalue | ccvs_textvalue() | CCVS
cv_void | ccvs_void() | CCVS
die | exit() | Miscellaneous functions
dir | getdir() | Base syntax
diskfreespace | disk_free_space() | Filesystem
domxml_getattr | domxml_get_attribute() | DOM XML
domxml_setattr | domxml_set_attribute() | DOM XML
doubleval | floatval() | Base syntax
drawarc | swfshape_drawarc() | Ming (flash)
drawcircle | swfshape_drawcircle() | Ming (flash)
drawcubic | swfshape_drawcubic() | Ming (flash)
drawcubicto | swfshape_drawcubicto() | Ming (flash)
drawcurve | swfshape_drawcurve() | Ming (flash)
drawcurveto | swfshape_drawcurveto() | Ming (flash)
drawglyph | swfshape_drawglyph() | Ming (flash)
drawline | swfshape_drawline() | Ming (flash)
drawlineto | swfshape_drawlineto() | Ming (flash)
dtd | domxml_intdtd() | DOM XML
dumpmem | domxml_dumpmem() | DOM XML
fbsql | fbsql_db_query() | FrontBase
fputs | fwrite() | Base syntax
get_attribute | domxml_get_attribute() | DOM XML
getascent | swffont_getAscent() | Ming (flash)
getascent | swftext_getAscent() | Ming (flash)
getattr | domxml_get_attribute() | DOM XML
getdescent | swffont_getDescent() | Ming (flash)
getdescent | swftext_getDescent() | Ming (flash)
getheight | swfbitmap_getHeight() | Ming (flash)
getleading | swffont_getLeading() | Ming (flash)
getleading | swftext_getLeading() | Ming (flash)
getshape1 | swfmorph_getShape1() | Ming (flash)
getshape2 | swfmorph_getShape2() | Ming (flash)
getwidth | swfbitmap_getWidth() | Ming (flash)
getwidth | swffont_getWidth() | Ming (flash)
getwidth | swftext_getWidth() | Ming (flash)
gzputs | gzwrite() | Zlib
i18n_convert | mb_convert_encoding() | Multi-bytes Strings
i18n_discover_encoding | mb_detect_encoding() | Multi-bytes Strings
i18n_http_input | mb_http_input() | Multi-bytes Strings
i18n_http_output | mb_http_output() | Multi-bytes Strings
i18n_internal_encoding | mb_internal_encoding() | Multi-bytes Strings
i18n_ja_jp_hantozen | mb_convert_kana() | Multi-bytes Strings
i18n_mime_header_decode | mb_decode_mimeheader() | Multi-bytes Strings
i18n_mime_header_encode | mb_encode_mimeheader() | Multi-bytes Strings
imap_create | imap_createmailbox() | IMAP
imap_fetchtext | imap_body() | IMAP
imap_getmailboxes | imap_list_full() | IMAP
imap_getsubscribed | imap_lsub_full() | IMAP
imap_header | imap_headerinfo() | IMAP
imap_listmailbox | imap_list() | IMAP
imap_listsubscribed | imap_lsub() | IMAP
imap_rename | imap_renamemailbox() | IMAP
imap_scan | imap_listscan() | IMAP
imap_scanmailbox | imap_listscan() | IMAP
ini_alter | ini_set() | Base syntax
is_double | is_float() | Base syntax
is_integer | is_int() | Base syntax
is_long | is_int() | Base syntax
is_real | is_float() | Base syntax
is_writeable | is_writable() | Base syntax
join | implode() | Base syntax
labelframe | swfmovie_labelFrame() | Ming (flash)
labelframe | swfsprite_labelFrame() | Ming (flash)
last_child | domxml_last_child() | DOM XML
lastchild | domxml_last_child() | DOM XML
ldap_close | ldap_unbind() | LDAP
magic_quotes_runtime | set_magic_quotes_runtime() | Base syntax
mbstrcut | mb_strcut() | Multi-bytes Strings
mbstrlen | mb_strlen() | Multi-bytes Strings
mbstrpos | mb_strpos() | Multi-bytes Strings
mbstrrpos | mb_strrpos() | Multi-bytes Strings
mbsubstr | mb_substr() | Multi-bytes Strings
ming_setcubicthreshold | ming_setCubicThreshold() | Ming (flash)
ming_setscale | ming_setScale() | Ming (flash)
move | swfdisplayitem_move() | Ming (flash)
movepen | swfshape_movepen() | Ming (flash)
movepento | swfshape_movepento() | Ming (flash)
moveto | swfdisplayitem_moveTo() | Ming (flash)
moveto | swffill_moveTo() | Ming (flash)
moveto | swftext_moveTo() | Ming (flash)
msql | msql_db_query() | mSQL
msql_createdb | msql_create_db() | mSQL
msql_dbname | msql_result() | mSQL
msql_dropdb | msql_drop_db() | mSQL
msql_fieldflags | msql_field_flags() | mSQL
msql_fieldlen | msql_field_len() | mSQL
msql_fieldname | msql_field_name() | mSQL
msql_fieldtable | msql_field_table() | mSQL
msql_fieldtype | msql_field_type() | mSQL
msql_freeresult | msql_free_result() | mSQL
msql_listdbs | msql_list_dbs() | mSQL
msql_listfields | msql_list_fields() | mSQL
msql_listtables | msql_list_tables() | mSQL
msql_numfields | msql_num_fields() | mSQL
msql_numrows | msql_num_rows() | mSQL
msql_regcase | sql_regcase() | mSQL
msql_selectdb | msql_select_db() | mSQL
msql_tablename | msql_result() | mSQL
mssql_affected_rows | sybase_affected_rows() | Sybase
mssql_affected_rows | sybase_affected_rows() | Sybase
mssql_close | sybase_close() | Sybase
mssql_close | sybase_close() | Sybase
mssql_connect | sybase_connect() | Sybase
mssql_connect | sybase_connect() | Sybase
mssql_data_seek | sybase_data_seek() | Sybase
mssql_data_seek | sybase_data_seek() | Sybase
mssql_fetch_array | sybase_fetch_array() | Sybase
mssql_fetch_array | sybase_fetch_array() | Sybase
mssql_fetch_field | sybase_fetch_field() | Sybase
mssql_fetch_field | sybase_fetch_field() | Sybase
mssql_fetch_object | sybase_fetch_object() | Sybase
mssql_fetch_object | sybase_fetch_object() | Sybase
mssql_fetch_row | sybase_fetch_row() | Sybase
mssql_fetch_row | sybase_fetch_row() | Sybase
mssql_field_seek | sybase_field_seek() | Sybase
mssql_field_seek | sybase_field_seek() | Sybase
mssql_free_result | sybase_free_result() | Sybase
mssql_free_result | sybase_free_result() | Sybase
mssql_get_last_message | sybase_get_last_message() | Sybase
mssql_get_last_message | sybase_get_last_message() | Sybase
mssql_min_client_severity | sybase_min_client_severity() | Sybase
mssql_min_error_severity | sybase_min_error_severity() | Sybase
mssql_min_message_severity | sybase_min_message_severity() | Sybase
mssql_min_server_severity | sybase_min_server_severity() | Sybase
mssql_num_fields | sybase_num_fields() | Sybase
mssql_num_fields | sybase_num_fields() | Sybase
mssql_num_rows | sybase_num_rows() | Sybase
mssql_num_rows | sybase_num_rows() | Sybase
mssql_pconnect | sybase_pconnect() | Sybase
mssql_pconnect | sybase_pconnect() | Sybase
mssql_query | sybase_query() | Sybase
mssql_query | sybase_query() | Sybase
mssql_result | sybase_result() | Sybase
mssql_result | sybase_result() | Sybase
mssql_select_db | sybase_select_db() | Sybase
mssql_select_db | sybase_select_db() | Sybase
multcolor | swfdisplayitem_multColor() | Ming (flash)
mysql | mysql_db_query() | MySQL
mysql_createdb | mysql_create_db() | MySQL
mysql_db_name | mysql_result() | MySQL
mysql_dbname | mysql_result() | MySQL
mysql_dropdb | mysql_drop_db() | MySQL
mysql_fieldflags | mysql_field_flags() | MySQL
mysql_fieldlen | mysql_field_len() | MySQL
mysql_fieldname | mysql_field_name() | MySQL
mysql_fieldtable | mysql_field_table() | MySQL
mysql_fieldtype | mysql_field_type() | MySQL
mysql_freeresult | mysql_free_result() | MySQL
mysql_listdbs | mysql_list_dbs() | MySQL
mysql_listfields | mysql_list_fields() | MySQL
mysql_listtables | mysql_list_tables() | MySQL
mysql_numfields | mysql_num_fields() | MySQL
mysql_numrows | mysql_num_rows() | MySQL
mysql_selectdb | mysql_select_db() | MySQL
mysql_tablename | mysql_result() | MySQL
name | domxml_attrname() | DOM XML
new_child | domxml_new_child() | DOM XML
new_xmldoc | domxml_new_xmldoc() | DOM XML
nextframe | swfmovie_nextFrame() | Ming (flash)
nextframe | swfsprite_nextFrame() | Ming (flash)
node | domxml_node() | DOM XML
oci8append | ocicollappend() | OCI8
oci8assign | ocicollassign() | OCI8
oci8assignelem | ocicollassignelem() | OCI8
oci8close | ocicloselob() | OCI8
oci8free | ocifreecoll() | OCI8
oci8free | ocifreedesc() | OCI8
oci8getelem | ocicollgetelem() | OCI8
oci8load | ociloadlob() | OCI8
oci8max | ocicollmax() | OCI8
oci8ocifreecursor | ocifreestatement() | OCI8
oci8save | ocisavelob() | OCI8
oci8savefile | ocisavelobfile() | OCI8
oci8size | ocicollsize() | OCI8
oci8trim | ocicolltrim() | OCI8
oci8writetemporary | ociwritetemporarylob() | OCI8
oci8writetofile | ociwritelobtofile() | OCI8
odbc_do | odbc_exec() | OCI8
odbc_field_precision | odbc_field_len() | OCI8
output | swfmovie_output() | Ming (flash)
parent | domxml_parent() | DOM XML
pdf_add_outline | pdf_add_bookmark() | PDF
pg_clientencoding | pg_client_encoding() | PostgreSQL
pg_setclientencoding | pg_set_client_encoding() | PostgreSQL
pos | current() | Base syntax
recode | recode_string() | Recode
remove | swfmovie_remove() | Ming (flash)
remove | swfsprite_remove() | Ming (flash)
rewind | rewinddir() | Base syntax
root | domxml_root() | DOM XML
rotate | swfdisplayitem_rotate() | Ming (flash)
rotateto | swfdisplayitem_rotateTo() | Ming (flash)
rotateto | swffill_rotateTo() | Ming (flash)
save | swfmovie_save() | Ming (flash)
savetofile | swfmovie_saveToFile() | Ming (flash)
scale | swfdisplayitem_scale() | Ming (flash)
scaleto | swfdisplayitem_scaleTo() | Ming (flash)
scaleto | swffill_scaleTo() | Ming (flash)
set_attribute | domxml_set_attribute() | DOM XML
set_content | domxml_set_content() | DOM XML
setaction | swfbutton_setAction() | Ming (flash)
setattr | domxml_set_attribute() | DOM XML
setbackground | swfmovie_setBackground() | Ming (flash)
setbounds | swftextfield_setBounds() | Ming (flash)
setcolor | swftext_setColor() | Ming (flash)
setcolor | swftextfield_setColor() | Ming (flash)
setdepth | swfdisplayitem_setDepth() | Ming (flash)
setdimension | swfmovie_setDimension() | Ming (flash)
setdown | swfbutton_setDown() | Ming (flash)
setfont | swftext_setFont() | Ming (flash)
setfont | swftextfield_setFont() | Ming (flash)
setframes | swfmovie_setFrames() | Ming (flash)
setframes | swfsprite_setFrames() | Ming (flash)
setheight | swftext_setHeight() | Ming (flash)
setheight | swftextfield_setHeight() | Ming (flash)
sethit | swfbutton_setHit() | Ming (flash)
setindentation | swftextfield_setIndentation() | Ming (flash)
setleftfill | swfshape_setleftfill() | Ming (flash)
setleftmargin | swftextfield_setLeftMargin() | Ming (flash)
setline | swfshape_setline() | Ming (flash)
setlinespacing | swftextfield_setLineSpacing() | Ming (flash)
setmargins | swftextfield_setMargins() | Ming (flash)
setmatrix | swfdisplayitem_setMatrix() | Ming (flash)
setname | swfdisplayitem_setName() | Ming (flash)
setname | swftextfield_setName() | Ming (flash)
setover | swfbutton_setOver() | Ming (flash)
setrate | swfmovie_setRate() | Ming (flash)
setratio | swfdisplayitem_setRatio() | Ming (flash)
setrightfill | swfshape_setrightfill() | Ming (flash)
setrightmargin | swftextfield_setRightMargin() | Ming (flash)
setspacing | swftext_setSpacing() | Ming (flash)
setup | swfbutton_setUp() | Ming (flash)
show_source | highlight_file () | Base syntax
sizeof | count() | Base syntax
skewx | swfdisplayitem_skewX() | Ming (flash)
skewxto | swfdisplayitem_skewXTo() | Ming (flash)
skewxto | swffill_skewXTo() | Ming (flash)
skewy | swfdisplayitem_skewY() | Ming (flash)
skewyto | swfdisplayitem_skewYTo() | Ming (flash)
skewyto | swffill_skewYTo() | Ming (flash)
snmpwalkoid | snmprealwalk() | SNMP
strchr | strstr() | Base syntax
streammp3 | swfmovie_streamMp3() | Ming (flash)
swfaction | swfaction_init() | Ming (flash)
swfbitmap | swfbitmap_init() | Ming (flash)
swfbutton | swfbutton_init() | Ming (flash)
swffill | swffill_init() | Ming (flash)
swffont | swffont_init() | Ming (flash)
swfgradient | swfgradient_init() | Ming (flash)
swfmorph | swfmorph_init() | Ming (flash)
swfmovie | swfmovie_init() | Ming (flash)
swfshape | swfshape_init() | Ming (flash)
swfsprite | swfsprite_init() | Ming (flash)
swftext | swftext_init() | Ming (flash)
swftextfield | swftextfield_init() | Ming (flash)
unlink | domxml_unlink_node() | DOM XML
xptr_new_context | xpath_new_context() | DOM XML

이전 | 처음으로 | 다음
Reporting Errors | 위로 | 예약어 목록


예약어 목록

PHP 매뉴얼
이전 다음

H. 부록. 예약어 목록

차례
키워드 목록
기선언 변수
기선언 클래스
예약 정의 상수

다음은 PHP에서 기선언된 식별자 목록이다. 이 식별자 목록 중 어느것도 스크립트에서 식별자로 사용될수 없다. 이 목록은 키워드와 기선언 변수, 상수, 클래스 명도 포함한다. 이 목록은 철저하지도 완벽하지도 않다.

키워드 목록

이 단어들은 PHP에서 특별한 의미를 갖는다. 이중 일부는 함수처럼 보여지기도하고 상수나 기타 등등 으로 보여질것이다-그러나 그렇지 않다. 실제로: 그들은 언어 구조이다. 다음 단어를 상수, 클래스명, 함수명으로 사용할수 없다. 이들을 변수명으로 사용하는 것은 괜찮을수도 있지만, 혼란스럽게 될것이다.

표 H-1. PHP 키워드

and | or | xor | __FILE__ | exception | php_user_filter
__LINE__ | array() | as | break | case
cfunction | class | const | continue | declare
default | die() | do | echo() | else
elseif | empty() | enddeclare | endfor | endforeach
endif | endswitch | endwhile | eval | exit()
extends | for | foreach | function | global
if | include() | include_once() | isset() | list()
new | old_function | print() | require() | require_once()
return() | static | switch | unset() | use
var | while | __FUNCTION__ | __CLASS__ | __METHOD__

이전 | 처음으로 | 다음
함수 별칭 목록 | 위로 | 기선언 변수


기선언 변수

PHP 4.1.0이후부터 외부 변수를 가져오는 가장 선호되는 방법은 아래에서 설명하는 슈퍼전역을 사용하는것이다. 그 이전버전에서는 register_globals이나 긴형태의 기선언 PHP 배열($HTTP_*_VARS)을 사용한다. PHP 5.0.0부터, 긴 형태의 PHP 예약 변수 배열을 register_long_arrays 지시어로 비활성화할 수 있습니다.

서버 변수: $_SERVER

참고: 4.1.0부터 지원됨. 이전 버전은 $HTTP_SERVER_VARS을 사용함

$_SERVER는 헤더, 경로, 스크립트 위치와 같은 정보를 포함하는 배열이다. 이 배열 안의 엔트리는 웹서버에 의해 생성된다. 모든 웹서버가 이런 것들을 제공한다는 보장은 없다. 서버는 어떤것은 빠뜨리거나 여기에서 목록화된 것 외의 것을 제공할수 도 있다. 이런 많은 수의 변수들은 CGI 1.1 specification에 기반하므로, 그런 변수들은 기대할수 있을것이다.

이 변수는 '슈퍼전역', 또는 자동 전역, 변수이다. 즉 스크립트내의 모든 유효영역안에서 사용가능하다는 의미를 갖는다. $HTTP_SERVER_VARS를 사용할때와 같이 함수나 메소드 안에서 사용하기 위해 global $_SERVER;를 할 필요는 없다.

$HTTP_SERVER_VARS는 동일한 초기 정보를 포함하지만, 자동전역은 아니다. ($HTTP_SERVER_VARS 와 $_SERVER는 다른 변수이고 PHP는 그변수들을 따로 다루게 된다는 것에 주의한다)

register_globals 디렉티브가 설정되어있으면, 이 변수들은 스크립트의 전역 유효영역에서 사용이 가능해 진다. 즉 $_SERVER 와 $HTTP_SERVER_VARS 배열과 분리된다. 관련정보는 전역 등록 사용하기라는 이름의 보안 챕터를 참고한다. 이들 각각의 전역은 자동전역이 아니다.

$_SERVER에서는 다음 구성요소를 확인할수도 있고 그렇지 않은수있다. 이 변수중 일부(심지어 모두)는 PHP가 커맨드 라인에서 수행되고 있을때에는 보여지지 않을것이다.

'PHP_SELF'

현재 실행중인 스크립트의 파일명이고, 도규먼트 루트에 상대적인 경로를 갖는다. 예를 들면, 주소 http://example.com/test.php/foo.bar의 스크립트에서 $_SERVER['PHP_SELF']은 /test.php/foo.bar이 될것이다.

PHP가 커맨드 라인 프로세서로 실행중이면, 이 변수는 나타나지 않는다.

'argv'

스크립트로 전달되는 인자의 배열. 스크립트가 커맨드 라인에서 실행중이면, 이 변수는 C-스타일의 커맨드 라인 인자로 제공된다. GET 메소드에 의해 호출될때에는 이 변수는 질의 문자열(query string)을 포함할것이다.

'argc'

스크립트로 전달되는 커맨드 라인 인자의 갯수 (커맨드 라인에서 실행중일때)

'GATEWAY_INTERFACE'

서버가 사용하는 CGI 사양(specification)의 버전: 예를 들면, 'CGI/1.1'.

'SERVER_NAME'

현재 스크립트가 수행되고 있는 서버 호스트의 이름. 스크립트가 가상 호스트에서 수행중이면, 이 변수는 그 가상 호스트를 위해 정의된 값이 될것이다.

'SERVER_SOFTWARE'

서버 식별 문자열. 요구(ruquest)에 응답할때 헤더안에서 보여준다.

'SERVER_PROTOCOL'

페이지가 요청되어진 정보 프로토콜의 이름과 버전: 예를 들면, 'HTTP/1.0';

'REQUEST_METHOD'

페이지에 접근할때 사용된 요청 메소드 종류. 예를 들면,'GET', 'HEAD', 'POST', 'PUT'.

'QUERY_STRING'

페이지가 접근될때의 질의 문자열

'DOCUMENT_ROOT'

현재 스크립트가 수행중인 다큐먼트 루트 디렉토리. 서버 설정 파일에서 정의된다.

'HTTP_ACCEPT'

현재 요청에 대한 Accept: 헤더의 내용.

'HTTP_ACCEPT_CHARSET'

현재 요청에 대한 Accept-Charset: 헤더의 내용. 예를 들면'iso-8859-1,*,utf-8'.

'HTTP_ACCEPT_ENCODING'

현재 요청에 대한 Accept-Encoding: 헤더의 내용. 예를 들면: 'gzip'.

'HTTP_ACCEPT_LANGUAGE'

현재 요청에 대한 Accept-Language: 헤더의 내용. 예를 들면: 'en'.

'HTTP_CONNECTION'

현재 요청에 대한 Connection: 헤더의 내용. 예를 들면: 'Keep-Alive'.

'HTTP_HOST'

현재 요청에 대한 Host: 헤더의 내용.

'HTTP_REFERER'

현재 페이지에 대한 유저 에이전트를 참조하는 페이지의 주소. 모든 에이전트가 이 값을 갖지 않는다. 일부 에이전트는 HTTP_REFERER를 각 특성에 맞게 변경하는 기능을 제공한다. 간단히 말해서, 이 값은 신뢰할수 없다.

'HTTP_USER_AGENT'

현재 요청에 대한 User-Agent: 헤더 내용. 이 값은 페이지에 접근 중인 유저 에이전트를 표시하는 문자열이다. 표준적인 예로는: Mozilla/4.5 [en] (X11; U; Linux 2.2.9 i586). get_browser()로 이 값을 사용하여 유저 에이전트의 능력에 맞게 페이지의 출력을 조절할수 있다.

'REMOTE_ADDR'

현재 페이지를 보고있는 유저의 IP 주소.

'REMOTE_HOST'

현재 페이지를 보고있는 유저의 호스트명. 역방향 dns 검색이 유저의 REMOTE_ADDR를 위해 사용된다.

참고: 웹서버는 이 변수를 생성할수 있도록 설정되어야 한다. 예를 들면 아파치에서는 httpd.conf안에서 HostnameLookups On 이 필요할것이다. gethostbyaddr()도 참고.

'REMOTE_PORT'

웹서버와 통신중인 유저 머신이 사용중인 포트.

'SCRIPT_FILENAME'

현재 수행되는 스크립트의 절대 경로명.

참고: file.php, ../file.php처럼 스크립트를 상대 경로로 지정하여 CLI로 실행할 경우, $_SERVER['SCRIPT_FILENAME']은 사용자가 지정한 상대 경로를 포함합니다.

'SERVER_ADMIN'

웹서버 설정 파일안의 SERVER_ADMIN (아파치용) 디렉티브에 주어지는 값. 스크립트가 가상 호스트에서 수행중이면, 이 값은 그 가상호스트를 위해 정의되는 값이 될것이다.

'SERVER_PORT'

웹서버가 통신을 위해 사용중인 서버 머신의 포트. 초기 설정값으로 '80';이 될것이다. 예를 들어, SSL을 사용중이면, 안전한 HTTP 포트로 정의된 어떤 값으로도 변경할수 있다.

'SERVER_SIGNATURE'

활설화되어있다면, 서버가 생성하는 페이지에 추가되는 서버 버전과 가상 호스트명을 갖는 문자열.

'PATH_TRANSLATED'

현재 스크립트에 대한 파일시스템(다큐먼트 루트가 아님) 기반의 경로 서버가 virtual-to-real 매핑으로 설정되면 보인다.

'SCRIPT_NAME'

현재 스크립트의 경로를 갖는다. 이 값은 가리킬 필요가 있는 페이지에 유용하다.

'REQUEST_URI'

이 페이지에 접근하기 위해 주어지는 URI; 예를 들면,'/index.html'.

'PHP_AUTH_USER'

HTTP 인증을 사용하는 모듈로서 아파치에서 수행될때, 이 변수는 유저에 의해 제공되는 username으로 설정된다.

'PHP_AUTH_PW'

HTTP 인증을 사용하는 모듈로서 아파치에서 수행될때, 이 변수는 유저가 제공하는 password로 설정된다.

'AUTH_TYPE'

HTTP 인증을 사용하는 모듈로서 아파치에서 수행될때, 이 변수는 인증 타입으로 설정된다.

환경 변수: $_ENV

참고: 4.1.0부터 지원됨. 그 이전 버전에서는, $HTTP_ENV_VARS이 사용되었다.

이 변수들은 PHP 해석기가 실행중인 환경에서 PHP의 전역 네임스페이스로 포함된다. PHP가 실행중인 셀과 다른 종류의 셀을 수행하는 시스템에 의해서 많은 변수가 제공된다. 확정적인 변수 목록을 제공하는것은 불가능 하다. 선언된 환경변수 목록에 대한 셀의 문서를 참고하라.

다른 환경 변수는 CGI 변수를 포함한다. PHP가 서버 모듈로 실행중인지 또는 CGI 프로세서로 실행중인지에 따라 달라진다.

이변수는 '슈퍼전역', 도는 자동 전역, 변수이다. 이 말의 의미는 스크립트 내의 모든 영역에서 사용가능하다는 것이다. $HTTP_ENV_VARS를 사용할때와 마찬가지로, 함수나 메소드에서 이 변수에 접근하기 위해 global $_ENV;를 사용할 필요는 없다.

$HTTP_ENV_VARS는 동일한 초기치 정보를 갖는다. 그러나 자동전역이 아니다. (HTTP_ENV_VARS 와 $_ENV는 다른 변수이며 PHP가 따로 다루게 된다는 것에 주의한다)

register_globals 디렉티브가 설정되어있으면, 이변수는 스크립트의 전역 유효영역에서 사용가능해진다. 즉,$_ENV과 $HTTP_ENV_VARS 배열에서 독립적으로 사용된다. 관련 정보는, 전역 등록 사용하기라는 보안 챕터를 참고한다. 이들 각각의 전역변수는 자동전역이 아니다.

HTTP 쿠키: $_COOKIE

참고: 4.1.0부터 지원됨. 이전 버전에서는 $HTTP_COOKIE_VARS를 사용했슴.

HTTP 쿠키를 통해 현재 스크립트로 전달되는 변수의 연관 배열. 어떤 영역에서는 자동으로 전역화된다.

이변수는 '슈퍼전역', 도는 자동 전역, 변수이다. 이 말의 의미는 스크립트 내의 모든 영역에서 사용가능하다는 것이다. $HTTP_COOKIE_VARS를 사용할때와 마찬가지로, 함수나 메소드에서 이 변수에 접근하기 위해 global $_COOKIE;를 사용할 필요는 없다.

$HTTP_COOKIE_VARS는 동일한 초기치 정보를 갖는다. 그러나 자동전역이 아니다. (HTTP_COOKIE_VARS 와 $_COOKIE는 다른 변수이며 PHP가 따로 다루게 된다는 것에 주의한다)

register_globals 디렉티브가 설정되어있으면, 이변수는 스크립트의 전역 유효영역에서 사용가능해진다. 즉,$_COOKIE와 $HTTP_COOKIE_VARS 배열에서 독립적으로 사용된다. 관련 정보는, 전역 등록 사용하기라는 보안 챕터를 참고한다. 이들 각각의 전역변수는 자동전역이 아니다.

HTTP GET 변수: $_GET

참고: 4.1.0부터 지원됨. 이전 버전에서는 $HTTP_GET_VARS를 사용했슴.

HTTP GET 메소드를 통해 현재 스크립트에 전달되는 변수의 연관 배열. 어떤 영역에서는 자동으로 전역화된다.

이변수는 '슈퍼전역', 도는 자동 전역, 변수이다. 이 말의 의미는 스크립트 내의 모든 영역에서 사용가능하다는 것이다. $HTTP_GET_VARS를 사용할때와 마찬가지로, 함수나 메소드에서 이 변수에 접근하기 위해 global $_GET;를 사용할 필요는 없다.

$HTTP_GET_VARS는 동일한 초기치 정보를 갖는다. 그러나 자동전역이 아니다. (HTTP_GET_VARS 와 $_GET는 다른 변수이며 PHP가 따로 다루게 된다는 것에 주의한다)

register_globals 디렉티브가 설정되어있으면, 이변수는 스크립트의 전역 유효영역에서 사용가능해진다. 즉,$_GET와 $HTTP_GET_VARS 배열에서 독립적으로 사용된다. 관련 정보는, 전역 등록 사용하기라는 보안 챕터를 참고한다. 이들 각각의 전역변수는 자동전역이 아니다.

HTTP POST 변수: $_POST

참고: 4.1.0부터 지원됨. 이전 버전에서는 $HTTP_POST_VARS를 사용했슴.

HTTP POST 메소드를 통해 현재 스크립트에 전달되는 변수의 연관 배열. 어떤 영역에서는 자동으로 전역화된다.

이변수는 '슈퍼전역', 도는 자동 전역, 변수이다. 이 말의 의미는 스크립트 내의 모든 영역에서 사용가능하다는 것이다. $HTTP_POST_VARS를 사용할때와 마찬가지로, 함수나 메소드에서 이 변수에 접근하기 위해 global $_POST;를 사용할 필요는 없다.

$HTTP_POST_VARS는 동일한 초기치 정보를 갖는다. 그러나 자동전역이 아니다. (HTTP_POST_VARS 와 $_POST는 다른 변수이며 PHP가 따로 다루게 된다는 것에 주의한다)

register_globals 디렉티브가 설정되어있으면, 이변수는 스크립트의 전역 유효영역에서 사용가능해진다. 즉,$_POST와 $HTTP_POST_VARS 배열에서 독립적으로 사용된다. 관련 정보는, 전역 등록 사용하기라는 보안 챕터를 참고한다. 이들 각각의 전역변수는 자동전역이 아니다.

HTTP File 업로드 변수: $_FILES

참고: 4.1.0부터 지원됨. 이전 버전에서는 $HTTP_POST_FILES를 사용했슴.

HTTP POST 메소드를 통해 현재 스크립트에 업로드되는 아이템의 연관 배열. 어떤 영역에서는 자동으로 전역화된다.

이변수는 '슈퍼전역', 도는 자동 전역, 변수이다. 이 말의 의미는 스크립트 내의 모든 영역에서 사용가능하다는 것이다. $HTTP_POST_FILES를 사용할때와 마찬가지로, 함수나 메소드에서 이 변수에 접근하기 위해 global $_FILES;를 사용할 필요는 없다.

$HTTP_POST_FILES는 같은 정보를 갖고 있지만, 자동 전역 변수가 아니다.

register_globals 디렉티브가 설정되어있으면, 이변수는 스크립트의 전역 유효영역에서 사용가능해진다. 즉,$_FILES와 $HTTP_POST_FILES 배열에서 독립적으로 사용된다. 관련 정보는, 전역 등록 사용하기라는 보안 챕터를 참고한다. 이들 각각의 전역변수는 자동전역이 아니다.

Request 변수: $_REQUEST

참고: 4.1.0부터 지원됨. 이전 버전에서는 관련된 배열이 없다.

참고: PHP 4.3.0 이전에는 $_REQUEST 안에도 $_FILES 정보가 포함되어 있었다.

$_GET, $_POST, $_COOKIE의 내용물로 구성된 연관 배열.

이변수는 '슈퍼전역', 도는 자동 전역, 변수이다. 이 말의 의미는 스크립트 내의 모든 영역에서 사용가능하다는 것이다. 함수나 메소드에서 이 변수에 접근하기 위해 global $_REQUEST;를 사용할 필요는 없다.

register_globals 디렉티브가 설정되어있으면, 이변수는 스크립트의 전역 유효영역에서 사용가능해진다. 즉,$_REQUEST 배열에서 독립적으로 사용된다. 관련 정보는, 전역 등록 사용하기라는 보안 챕터를 참고한다. 이들 각각의 전역변수는 자동전역이 아니다.

세션 변수: $_SESSION

참고: 4.1.0부터 지원됨. 이전 버전에서는 $HTTP_SESSION_VARS를 사용했슴.

현재 스크립트에서 사용가능한 세션 변수를 포함하는 연관배열. 이 변수를 사용하는 방법에 대한 자세한 정보는 Session functions 문서를 참고.

이변수는 '슈퍼전역', 도는 자동 전역, 변수이다. 이 말의 의미는 스크립트 내의 모든 영역에서 사용가능하다는 것이다. $HTTP_SESSION_VARS를 사용할때와 마찬가지로, 함수나 메소드에서 이 변수에 접근하기 위해 global $_SESSION;를 사용할 필요는 없다.

$HTTP_SESSION_VARS는 같은 정보를 갖고 있지만, 자동 전역 변수가 아니다.

register_globals 디렉티브가 설정되어있으면, 이변수는 스크립트의 전역 유효영역에서 사용가능해진다. 즉,$_SESSION와 $HTTP_SESSION_FILES 배열에서 독립적으로 사용된다. 관련 정보는, 전역 등록 사용하기라는 보안 챕터를 참고한다. 이들 각각의 전역변수는 자동전역이 아니다.

Global 변수: $GLOBALS

참고: $GLOBALS PHP 3.0.0부터 지원되었다.

현재 스크립트의 전역 유효영역내에서 선언되어있는 모든변수에 대한 참조를 포함하는 연관배열이다. 변수명은 배열의 키로 사용된다.

이변수는 '슈퍼전역', 도는 자동 전역, 변수이다. 이 말의 의미는 스크립트 내의 모든 영역에서 사용가능하다는 것이다. 함수나 메소드에서 이 변수에 접근하기 위해 global $GLOBALS;를 사용할 필요는 없다.

이전 에러 메시지: $php_errormsg

$php_errormsg는 PHP에 의해 생성되는 가장 최근의 에러 메시지 텍스트를 포함하는 변수이다. 이변수는 에러가 발생한 영역내에서만 유효하다. 그리고, track_errors 설정 옵션이 on되어있어야 한다(초기값은 off이다)

이전 | 처음으로 | 다음
예약어 목록 | 위로 | 기선언 클래스


기선언 클래스

기본적인 선언 클래스

이 클래스는 PHP 빌드에 포함되어있는 표준 함수 모음에 선언된다.

Directory

The class from which dir is instantiated.

stdClass

__PHP_Incomplete_Class

PHP 5의 기선언 클래스

여기 추가된 기선언 클래스는 PHP 5.0.0에서 소개되었다.

exception

php_user_filter

Ming 선언 클래스

이 클래스는 Ming 확장에서 정의되었다. 그래서 이 확장이 PHP와 같이 컴파일되었거나 런타임에서 동적으로 로드되야만 사용가능하다.

swfshape

swffill

swfgradient

swfbitmap

swftext

swftextfield

swffont

swfdisplayitem

swfmovie

swfbutton

swfaction

swfmorph

swfsprite

Oracle 8 선언 클래스

이 클래스는 Oracle 8 확장에서 정의되었다. 그래서 이 확장이 PHP와 같이 컴파일되었거나 런타임에서 동적으로 로드되야만 사용가능하다.

OCI-Lob

OCI-Collection

qtdom 선언 클래스

이 클래스는 qtdom 확장에서 정의되었다. 그래서 이 확장이 PHP와 같이 컴파일되었거나 런타임에서 동적으로 로드되야만 사용가능하다.

QDomDocument

QDomNode

이전 | 처음으로 | 다음
기선언 변수 | 위로 | 예약 정의 상수


예약 정의 상수

차례
코어 기선언 상수 -- PHP 코어, 젠드, SAPI 모듈에서 선언된 상수
표준 기선언 상수 -- PHP에서 선언되는 기본 상수

이전 | 처음으로 | 다음
기선언 클래스 | 위로 | 코어 기선언 상수


리소스 타입 목록

PHP 매뉴얼
이전 다음

I. 부록. 리소스 타입 목록

다음은 PHP 리소스를 생성, 사용, 파괴하는 함수 목록이다. 함수 is_resource()는 특정 변수가 리소스인지 확인하기 위해 사용될수 있고 get_resource_type()은 변수의 리소스 타입을 리턴할것이다.

표 I-1. 리소스 타입

리소스 타입명 | 생성 함수 | 사용 함수 | 파괴 함수 | 선언
aspell | aspell_new() | aspell_check(), aspell_check_raw(), aspell_suggest() | None | Aspell dictionary
bzip2 | bzopen() | bzerrno(), bzerror(), bzerrstr(), bzflush(), bzread(), bzwrite() | bzclose() | Bzip2 file
COM | com_load() | com_invoke(), com_propget(), com_get(), com_propput(), com_set(), com_propput() | None | COM 객체 레퍼런스
VARIANT
cpdf | cpdf_open() | cpdf_page_init(), cpdf_finalize_page(), cpdf_finalize(), cpdf_output_buffer(), cpdf_save_to_file(), cpdf_set_current_page(), cpdf_begin_text(), cpdf_end_text(), cpdf_show(), cpdf_show_xy(), cpdf_text(), cpdf_set_font(), cpdf_set_leading(), cpdf_set_text_rendering(), cpdf_set_horiz_scaling(), cpdf_set_text_rise(), cpdf_set_text_matrix(), cpdf_set_text_pos(), cpdf_set_text_pos(), cpdf_set_word_spacing(), cpdf_continue_text(), cpdf_stringwidth(), cpdf_save(), cpdf_translate(), cpdf_restore(), cpdf_scale(), cpdf_rotate(), cpdf_setflat(), cpdf_setlinejoin(), cpdf_setlinecap(), cpdf_setmiterlimit(), cpdf_setlinewidth(), cpdf_setdash(), cpdf_moveto(), cpdf_rmoveto(), cpdf_curveto(), cpdf_lineto(), cpdf_rlineto(), cpdf_circle(), cpdf_arc(), cpdf_rect(), cpdf_closepath(), cpdf_stroke(), cpdf_closepath_fill_stroke(), cpdf_fill_stroke(), cpdf_clip(), cpdf_fill(), cpdf_setgray_fill(), cpdf_setgray_stroke(), cpdf_setgray(), cpdf_setrgbcolor_fill(), cpdf_setrgbcolor_stroke(), cpdf_setrgbcolor(), cpdf_add_outline(), cpdf_set_page_animation(), cpdf_import_jpeg(), cpdf_place_inline_image(), cpdf_add_annotation() | cpdf_close() | CPDF lib에 의한 PDF 문서
cpdf outline
curl | curl_init() | curl_init(), curl_exec() | curl_close() | Curl session
dbm | dbmopen() | dbmexists(), dbmfetch(), dbminsert(), dbmreplace(), dbmdelete(), dbmfirstkey(), dbmnextkey() | dbmclose() | DBM database로의 연결
dba | dba_open() | dba_delete(), dba_exists(), dba_fetch(), dba_firstkey(), dba_insert(), dba_nextkey(), dba_optimize(), dba_replace(), dba_sync() | dba_close() | Link to DBA database
dba persistent | dba_popen() | dba_delete(), dba_exists(), dba_fetch(), dba_firstkey(), dba_insert(), dba_nextkey(), dba_optimize(), dba_replace(), dba_sync() | None | Persistent link to DBA database
dbase | dbase_open() | dbase_pack(), dbase_add_record(), dbase_replace_record(), dbase_delete_record(), dbase_get_record(), dbase_get_record_with_names(), dbase_numfields(), dbase_numrecords() | dbase_close() | Link to Dbase database
dbx_link_object | dbx_connect() | dbx_query() | dbx_close() | dbx connection
dbx_result_object | dbx_query() | None | dbx result
domxml attribute
domxml document
domxml node
xpath context
xpath object
fbsql database | fbsql_select_db() | None | fbsql database
fbsql link | fbsql_change_user(), fbsql_connect() | fbsql_autocommit(), fbsql_change_user(), fbsql_create_db(), fbsql_data_seek(), fbsql_db_query(), fbsql_drop_db(), (), fbsql_select_db(), fbsql_errno(), fbsql_error(), fbsql_insert_id(), fbsql_list_dbs() | fbsql_close() | Link to fbsql database
fbsql plink | fbsql_change_user(), fbsql_pconnect() | fbsql_autocommit(), fbsql_change_user(), fbsql_create_db(), fbsql_data_seek(), fbsql_db_query(), fbsql_drop_db(), (), fbsql_select_db(), fbsql_errno(), fbsql_error(), fbsql_insert_id(), fbsql_list_dbs() | None | Persistent link to fbsql database
fbsql result | fbsql_db_query(), fbsql_list_dbs(), fbsql_query(), fbsql_list_fields(), fbsql_list_tables(), fbsql_tablename() | fbsql_affected_rows(), fbsql_fetch_array(), fbsql_fetch_assoc(), fbsql_fetch_field(), fbsql_fetch_lengths(), fbsql_fetch_object(), fbsql_fetch_row(), fbsql_field_flags(), fbsql_field_name(), fbsql_field_len(), fbsql_field_seek(), fbsql_field_table(), fbsql_field_type(), fbsql_next_result(), fbsql_num_fields(), fbsql_num_rows(), fbsql_result(), fbsql_num_rows() | fbsql_free_result() | fbsql result
fdf | fdf_open() | fdf_create(), fdf_save(), fdf_get_value(), fdf_set_value(), fdf_next_field_name(), fdf_set_ap(), fdf_set_status(), fdf_get_status(), fdf_set_file(), fdf_get_file(), fdf_set_flags(), fdf_set_opt(), fdf_set_submit_form_action(), fdf_set_javascript_action() | fdf_close() | FDF File
ftp | ftp_connect() | ftp_login(), ftp_pwd(), ftp_cdup(), ftp_chdir(), ftp_mkdir(), ftp_rmdir(), ftp_nlist(), ftp_rawlist(), ftp_systype(), ftp_pasv(), ftp_get(), ftp_fget(), ftp_put(), ftp_fput(), ftp_size(), ftp_mdtm(), ftp_rename(), ftp_delete(), ftp_site() | ftp_quit() | FTP stream
gd | imagecreate(), imagecreatefromgif(), imagecreatefromjpeg(), imagecreatefrompng(), imagecreatefromwbmp(), imagecreatefromstring(), imagecreatetruecolor() | imagearc(), imagechar(), imagecharup(), imagecolorallocate(), imagecolorat(), imagecolorclosest(), imagecolorexact(), imagecolorresolve(), imagegammacorrect(), imagegammacorrect(), imagecolorset(), imagecolorsforindex(), imagecolorstotal(), imagecolortransparent(), imagecopy(), imagecopyresized(), imagedashedline(), imagefill(), imagefilledpolygon(), imagefilledrectangle(), imagefilltoborder(), imagegif(), imagepng(), imagejpeg(), imagewbmp(), imageinterlace(), imageline(), imagepolygon(), imagepstext(), imagerectangle(), imagesetpixel(), imagestring(), imagestringup(), imagesx(), imagesy(), imagettftext(), imagefilledarc(), imageellipse(), imagefilledellipse(), imagecolorclosestalpha(), imagecolorexactalpha(), imagecolorresolvealpha(), imagecopymerge(), imagecopymergegray(), imagecopyresampled(), imagetruecolortopalette(), imagesetbrush(), imagesettile(), imagesetthickness() | imagedestroy() | GD Image
gd font | imageloadfont() | imagechar(), imagecharup(), imagefontheight() | None | Font for GD
gd PS encoding
gd PS font | imagepsloadfont() | imagepstext(), imagepsslantfont(), imagepsextendfont(), imagepsencodefont(), imagepsbbox() | imagepsfreefont() | PS font for GD
GMP integer | gmp_init() | gmp_intval(), gmp_strval(), gmp_add(), gmp_sub(), gmp_mul(), gmp_div_q(), gmp_div_r(), gmp_div_qr(), gmp_div(), gmp_mod(), gmp_divexact(), gmp_cmp(), gmp_neg(), gmp_abs(), gmp_sign(), gmp_fact(), gmp_sqrt(), gmp_sqrtrm(), gmp_perfect_square(), gmp_pow(), gmp_powm(), gmp_prob_prime(), gmp_gcd(), gmp_gcdext(), gmp_invert(), gmp_legendre(), gmp_jacobi(), gmp_random(), gmp_and(), gmp_or(), gmp_xor(), gmp_setbit(), gmp_clrbit(), gmp_scan0(), gmp_scan1(), gmp_popcount(), gmp_hamdist() | None | GMP Number
hyperwave document | hw_cp(), hw_docbyanchor(), hw_getremote(), hw_getremotechildren() | hw_children(), hw_childrenobj(), hw_getparents(), hw_getparentsobj(), hw_getchildcoll(), hw_getchildcollobj(), hw_getremote(), hw_getsrcbydestobj(), hw_getandlock(), hw_gettext(), hw_getobjectbyquerycoll(), hw_getobjectbyquerycollobj(), hw_getchilddoccoll(), hw_getchilddoccollobj(), hw_getanchors(), hw_getanchorsobj(), hw_inscoll(), hw_pipedocument(), hw_unlock() | hw_deleteobject() | Hyperwave object
hyperwave link | hw_connect() | hw_children(), hw_childrenobj(), hw_cp(), hw_deleteobject(), hw_docbyanchor(), hw_docbyanchorobj(), hw_errormsg(), hw_edittext(), hw_error(), hw_getparents(), hw_getparentsobj(), hw_getchildcoll(), hw_getchildcollobj(), hw_getremote(), hw_getremotechildren(), hw_getsrcbydestobj(), hw_getobject(), hw_getandlock(), hw_gettext(), hw_getobjectbyquery(), hw_getobjectbyqueryobj(), hw_getobjectbyquerycoll(), hw_getobjectbyquerycollobj(), hw_getchilddoccoll(), hw_getchilddoccollobj(), hw_getanchors(), hw_getanchorsobj(), hw_mv(), hw_incollections(), hw_info(), hw_inscoll(), hw_insdoc(), hw_insertdocument(), hw_insertobject(), hw_mapid(), hw_modifyobject(), hw_pipedocument(), hw_unlock(), hw_who(), hw_getusername() | hw_close(), hw_free_document() | Link to Hyperwave server
hyperwave link persistent | hw_pconnect() | hw_children(), hw_childrenobj(), hw_cp(), hw_deleteobject(), hw_docbyanchor(), hw_docbyanchorobj(), hw_errormsg(), hw_edittext(), hw_error(), hw_getparents(), hw_getparentsobj(), hw_getchildcoll(), hw_getchildcollobj(), hw_getremote(), hw_getremotechildren(), hw_getsrcbydestobj(), hw_getobject(), hw_getandlock(), hw_gettext(), hw_getobjectbyquery(), hw_getobjectbyqueryobj(), hw_getobjectbyquerycoll(), hw_getobjectbyquerycollobj(), hw_getchilddoccoll(), hw_getchilddoccollobj(), hw_getanchors(), hw_getanchorsobj(), hw_mv(), hw_incollections(), hw_info(), hw_inscoll(), hw_insdoc(), hw_insertdocument(), hw_insertobject(), hw_mapid(), hw_modifyobject(), hw_pipedocument(), hw_unlock(), hw_who(), hw_getusername() | None | Persistent link to Hyperwave server
icap | icap_open() | icap_fetch_event(), icap_list_events(), icap_store_event(), icap_snooze(), icap_list_alarms(), icap_delete_event() | icap_close() | Link to icap server
imap | imap_open() | imap_append(), imap_body(), imap_check(), imap_createmailbox(), imap_delete(), imap_deletemailbox(), imap_expunge(), imap_fetchbody(), imap_fetchstructure(), imap_headerinfo(), imap_header(), imap_headers(), imap_listmailbox(), imap_getmailboxes(), imap_get_quota(), imap_status(), imap_listsubscribed(), imap_set_quota(), imap_set_quota(), imap_getsubscribed(), imap_mail_copy(), imap_mail_move(), imap_num_msg(), imap_num_recent(), imap_ping(), imap_renamemailbox(), imap_reopen(), imap_subscribe(), imap_undelete(), imap_unsubscribe(), imap_scanmailbox(), imap_mailboxmsginfo(), imap_fetchheader(), imap_uid(), imap_msgno(), imap_search(), imap_fetch_overview() | imap_close() | Link to IMAP, POP3 server
imap chain persistent
imap persistent
ingres | ingres_connect() | ingres_query(), ingres_num_rows(), ingres_num_fields(), ingres_field_name(), ingres_field_type(), ingres_field_nullable(), ingres_field_length(), ingres_field_precision(), ingres_field_scale(), ingres_fetch_array(), ingres_fetch_row(), ingres_fetch_object(), ingres_rollback(), ingres_commit(), ingres_autocommit() | ingres_close() | Link to ingresII base
ingres persistent | ingres_pconnect() | ingres_query(), ingres_num_rows(), ingres_num_fields(), ingres_field_name(), ingres_field_type(), ingres_field_nullable(), ingres_field_length(), ingres_field_precision(), ingres_field_scale(), ingres_fetch_array(), ingres_fetch_row(), ingres_fetch_object(), ingres_rollback(), ingres_commit(), ingres_autocommit() | None | Persistent link to ingresII base
interbase blob
interbase link | ibase_connect() | ibase_query(), ibase_prepare(), ibase_trans() | ibase_close() | Link to Interbase database
interbase link persistent | ibase_pconnect() | ibase_query(), ibase_prepare(), ibase_trans() | None | Persistent link to Interbase database
interbase query | ibase_prepare() | ibase_execute() | ibase_free_query() | Interbase query
interbase result | ibase_query() | ibase_fetch_row(), ibase_fetch_object(), ibase_field_info(), ibase_num_fields() | ibase_free_result() | Interbase Result
interbase transaction | ibase_trans() | ibase_commit() | ibase_rollback() | Interbase transaction
java
ldap link | ldap_connect(), ldap_search() | ldap_count_entries(), ldap_first_attribute(), ldap_first_entry(), ldap_get_attributes(), ldap_get_dn(), ldap_get_entries(), ldap_get_values(), ldap_get_values_len(), ldap_next_attribute(), ldap_next_entry() | ldap_close() | ldap connection
ldap result | ldap_read() | ldap_add(), ldap_compare(), ldap_bind(), ldap_count_entries(), ldap_delete(), ldap_errno(), ldap_error(), ldap_first_attribute(), ldap_first_entry(), ldap_get_attributes(), ldap_get_dn(), ldap_get_entries(), ldap_get_values(), ldap_get_values_len(), ldap_get_option(), ldap_list(), ldap_modify(), ldap_mod_add(), ldap_mod_replace(), ldap_next_attribute(), ldap_next_entry(), ldap_mod_del(), ldap_set_option(), ldap_unbind() | ldap_free_result() | ldap search result
ldap result entry
mcal | mcal_open(), mcal_popen() | mcal_create_calendar(), mcal_rename_calendar(), mcal_rename_calendar(), mcal_delete_calendar(), mcal_fetch_event(), mcal_list_events(), mcal_append_event(), mcal_store_event(), mcal_delete_event(), mcal_list_alarms(), mcal_event_init(), mcal_event_set_category(), mcal_event_set_title(), mcal_event_set_description(), mcal_event_set_start(), mcal_event_set_end(), mcal_event_set_alarm(), mcal_event_set_class(), mcal_next_recurrence(), mcal_event_set_recur_none(), mcal_event_set_recur_daily(), mcal_event_set_recur_weekly(), mcal_event_set_recur_monthly_mday(), mcal_event_set_recur_monthly_wday(), mcal_event_set_recur_yearly(), mcal_fetch_current_stream_event(), mcal_event_add_attribute(), mcal_expunge() | mcal_close() | Link to calendar server
SWFAction
SWFBitmap
SWFButton
SWFDisplayItem
SWFFill
SWFFont
SWFGradient
SWFMorph
SWFMovie
SWFShape
SWFSprite
SWFText
SWFTextField
mnogosearch agent
mnogosearch result
msql link | msql_connect() | msql(), msql_create_db(), msql_createdb(), msql_drop_db(), msql_drop_db(), msql_select_db(), msql_select_db() | msql_close() | Link to mSQL database
msql link persistent | msql_pconnect() | msql(), msql_create_db(), msql_createdb(), msql_drop_db(), msql_drop_db(), msql_select_db(), msql_select_db() | None | Persistent link to mSQL
msql query | msql_query() | msql(), msql_affected_rows(), msql_data_seek(), msql_dbname(), msql_fetch_array(), msql_fetch_field(), msql_fetch_object(), msql_fetch_row(), msql_fieldname(), msql_field_seek(), msql_fieldtable(), msql_fieldtype(), msql_fieldflags(), msql_fieldlen(), msql_num_fields(), msql_num_rows(), msql_numfields(), msql_numrows(), msql_result() | msql_free_result(), msql_free_result() | mSQL result
mssql link | mssql_connect() | mssql_query(), mssql_select_db() | mssql_close() | Link to Microsft SQL Server database
mssql link persistent | mssql_pconnect() | mssql_query(), mssql_select_db() | None | Persistent link to Microsft SQL Server
mssql result | mssql_query() | mssql_data_seek(), mssql_fetch_array(), mssql_fetch_field(), mssql_fetch_object(), mssql_fetch_row(), mssql_field_length(), mssql_field_name(), mssql_field_seek(), mssql_field_type(), mssql_num_fields(), mssql_num_rows(), mssql_result() | mssql_free_result() | Microsft SQL Server result
mysql link | mysql_connect() | mysql_affected_rows(), mysql_change_user(), mysql_create_db(), mysql_data_seek(), mysql_db_name(), mysql_db_query(), mysql_drop_db(), mysql_errno(), mysql_error(), mysql_insert_id(), mysql_list_dbs(), mysql_list_fields(), mysql_list_tables(), mysql_query(), mysql_result(), mysql_select_db(), mysql_tablename(), mysql_get_host_info(), mysql_get_proto_info(), mysql_get_server_info() | mysql_close() | Link to MySQL database
mysql link persistent | mysql_pconnect() | mysql_affected_rows(), mysql_change_user(), mysql_create_db(), mysql_data_seek(), mysql_db_name(), mysql_db_query(), mysql_drop_db(), mysql_errno(), mysql_error(), mysql_insert_id(), mysql_list_dbs(), mysql_list_fields(), mysql_list_tables(), mysql_query(), mysql_result(), mysql_select_db(), mysql_tablename(), mysql_get_host_info(), mysql_get_proto_info(), mysql_get_server_info() | None | Persistent link to MySQL database
mysql result | mysql_db_query(), mysql_list_dbs(), mysql_list_fields(), mysql_list_tables(), mysql_query() | mysql_data_seek(), mysql_db_name(), mysql_fetch_array(), mysql_fetch_assoc(), mysql_fetch_field(), mysql_fetch_lengths(), mysql_fetch_object(), mysql_fetch_row(), mysql_fetch_row(), mysql_field_flags(), mysql_field_name(), mysql_field_len(), mysql_field_seek(), mysql_field_table(), mysql_field_type(), mysql_num_fields(), mysql_num_rows(), mysql_result(), mysql_tablename() | mysql_free_result() | MySQL result
oci8 collection
oci8 connection | ocilogon(), ociplogon(), ocinlogon() | ocicommit(), ociserverversion(), ocinewcursor(), ociparse(), ocierror() | ocilogoff() | Link to Oracle database
oci8 descriptor
oci8 server
oci8 session
oci8 statement | ocinewdescriptor() | ocirollback(), ocinewdescriptor(), ocirowcount(), ocidefinebyname(), ocibindbyname(), ociexecute(), ocinumcols(), ociresult(), ocifetch(), ocifetchinto(), ocifetchstatement(), ocicolumnisnull(), ocicolumnname(), ocicolumnsize(), ocicolumntype(), ocistatementtype(), ocierror() | ocifreestatement() | Oracle Cursor
odbc link | odbc_connect() | odbc_autocommit(), odbc_commit(), odbc_error(), odbc_errormsg(), odbc_exec(), odbc_tables(), odbc_tableprivileges(), odbc_do(), odbc_prepare(), odbc_columns(), odbc_columnprivileges(), odbc_procedurecolumns(), odbc_specialcolumns(), odbc_rollback(), odbc_setoption(), odbc_gettypeinfo(), odbc_primarykeys(), odbc_foreignkeys(), odbc_procedures(), odbc_statistics() | odbc_close() | Link to ODBC database
odbc link persistent | odbc_connect() | odbc_autocommit(), odbc_commit(), odbc_error(), odbc_errormsg(), odbc_exec(), odbc_tables(), odbc_tableprivileges(), odbc_do(), odbc_prepare(), odbc_columns(), odbc_columnprivileges(), odbc_procedurecolumns(), odbc_specialcolumns(), odbc_rollback(), odbc_setoption(), odbc_gettypeinfo(), odbc_primarykeys(), odbc_foreignkeys(), odbc_procedures(), odbc_statistics() | None | Persistent link to ODBC database
odbc result | odbc_prepare() | odbc_binmode(), odbc_cursor(), odbc_execute(), odbc_fetch_into(), odbc_fetch_row(), odbc_field_name(), odbc_field_num(), odbc_field_type(), odbc_field_len(), odbc_field_precision(), odbc_field_scale(), odbc_longreadlen(), odbc_num_fields(), odbc_num_rows(), odbc_result(), odbc_result_all(), odbc_setoption() | odbc_free_result() | ODBC result
birdstep link
birdstep result
OpenSSL key | openssl_get_privatekey(), openssl_get_publickey() | openssl_sign(), openssl_seal(), openssl_open(), openssl_verify() | openssl_free_key() | OpenSSL key
OpenSSL X.509 | openssl_x509_read() | openssl_x509_parse(), openssl_x509_checkpurpose() | openssl_x509_free() | Public Key
oracle Cursor | ora_open() | ora_bind(), ora_columnname(), ora_columnsize(), ora_columntype(), ora_error(), ora_errorcode(), ora_exec(), ora_fetch(), ora_fetch_into(), ora_getcolumn(), ora_numcols(), ora_numrows(), ora_parse() | ora_close() | Oracle cursor
oracle link | ora_logon() | ora_do(), ora_error(), ora_errorcode(), ora_rollback(), ora_commitoff(), ora_commiton(), ora_open(), ora_commit() | ora_logoff() | Link to oracle database
oracle link persistent | ora_plogon() | ora_do(), ora_error(), ora_errorcode(), ora_rollback(), ora_commitoff(), ora_commiton(), ora_open(), ora_commit() | None | Persistent link to oracle database
pdf document | pdf_new() | pdf_add_bookmark(), pdf_add_launchlink(), pdf_add_locallink(), pdf_add_note(), pdf_add_pdflink(), pdf_add_weblink(), pdf_arc(), pdf_attach_file(), pdf_begin_page(), pdf_circle(), pdf_clip(), pdf_closepath(), pdf_closepath_fill_stroke(), pdf_closepath_stroke(), pdf_concat(), pdf_continue_text(), pdf_curveto(), pdf_end_page(), pdf_endpath(), pdf_fill(), pdf_fill_stroke(), pdf_findfont(), pdf_get_buffer(), pdf_get_image_height(), pdf_get_image_width(), pdf_get_parameter(), pdf_get_value(), pdf_lineto(), pdf_moveto(), pdf_open_ccitt(), pdf_open_file(), pdf_open_image_file(), pdf_place_image(), pdf_rect(), pdf_restore(), pdf_rotate(), pdf_save(), pdf_scale(), pdf_setdash(), pdf_setflat(), pdf_setfont(), pdf_setgray(), pdf_setgray_fill(), pdf_setgray_stroke(), pdf_setlinecap(), pdf_setlinejoin(), pdf_setlinewidth(), pdf_setmiterlimit(), pdf_setpolydash(), pdf_setrgbcolor(), pdf_setrgbcolor_fill(), pdf_setrgbcolor_stroke(), pdf_set_border_color(), pdf_set_border_dash(), pdf_set_border_style(), pdf_set_char_spacing(), pdf_set_duration(), pdf_set_font(), pdf_set_horiz_scaling(), pdf_set_parameter(), pdf_set_text_pos(), pdf_set_text_rendering(), pdf_set_value(), pdf_set_word_spacing(), pdf_show(), pdf_show_boxed(), pdf_show_xy(), pdf_skew(), pdf_stringwidth(), pdf_stroke(), pdf_translate(), pdf_open_memory_image() | pdf_close(), pdf_delete() | PDF document
pdf image | pdf_open_image(), pdf_open_image_file(), pdf_open_memory_image() | pdf_get_image_height(), pdf_get_image_width(), pdf_open_CCITT(), pdf_place_image() | pdf_close_image() | Image in PDF file
pdf object
pdf outline
pgsql large object | pg_lo_open() | pg_lo_open(), pg_lo_create(), pg_lo_read(), pg_lo_read_all(), pg_lo_seek(), pg_lo_tell(), pg_lo_unlink(), pg_lo_write() | pg_lo_close() | PostgreSQL Large Object
pgsql link | pg_connect() | pg_affected_rows(), pg_query(), pg_send_query(), pg_get_result(), pg_connection_busy(), pg_connection_reset(), pg_connection_status(), pg_last_error(), pg_last_notice(), pg_lo_create(), pg_lo_export(), pg_lo_import(), pg_lo_open(), pg_lo_unlink(), pg_host(), pg_port(), pg_dbname(), pg_options(), pg_copy_from(), pg_copy_to(), pg_end_copy(), pg_put_line(), pg_tty(), pg_trace(), pg_untrace(), pg_set_client_encoding(), pg_client_encoding(), pg_metadata(), pg_convert(), pg_insert(), pg_select(), pg_delete(), pg_update() | pg_close() | Link to PostgreSQL database
pgsql link persistent | pg_pconnect() | pg_affected_rows(), pg_query(), pg_send_query(), pg_get_result(), pg_connection_busy(), pg_connection_reset(), pg_connection_status(), pg_last_error(), pg_last_notice(), pg_lo_create(), pg_lo_export(), pg_lo_import(), pg_lo_open(), pg_lo_unlink(), pg_host(), pg_port(), pg_dbname(), pg_options(), pg_copy_from(), pg_copy_to(), pg_end_copy(), pg_put_line(), pg_tty(), pg_trace(), pg_untrace(), pg_set_client_encoding(), pg_client_encoding(), pg_metadata(), pg_convert(), pg_insert(), pg_select(), pg_delete(), pg_update() | None | Persistent link to PostgreSQL database
pgsql result | pg_query(), pg_get_result() | pg_fetch_array(), pg_fetch_object(), pg_fetch_result(), pg_fetch_row(), pg_field_is_null(), pg_field_name(), pg_field_num(), pg_field_prtlen(), pg_field_size(), pg_field_type(), pg_last_oid(), pg_num_fields(), pg_num_rows(), pg_result_error(), pg_result_status() | pg_free_result() | PostgreSQL result
pgsql string
printer
printer brush
printer font
printer pen
pspell | pspell_new(), pspell_new_config(), pspell_new_personal() | pspell_add_to_personal(), pspell_add_to_session(), pspell_check(), pspell_clear_session(), pspell_config_ignore(), pspell_config_mode(), pspell_config_personal(), pspell_config_repl(), pspell_config_runtogether(), pspell_config_save_repl(), pspell_save_wordlist(), pspell_store_replacement(), pspell_suggest() | None | pspell dictionary
pspell config | pspell_config_create() | pspell_new_config() | None | pspell configuration
Sablotron XSLT | xslt_create() | xslt_closelog(), xslt_openlog(), xslt_run(), xslt_set_sax_handler(), xslt_errno(), xslt_error(), xslt_fetch_result(), xslt_free() | xslt_free() | XSLT parser
shmop | shmop_open() | shmop_read(), shmop_write(), shmop_size(), shmop_delete() | shmop_close()
sockets file descriptor set | socket() | accept_connect(), bind(), connect(), listen(), read(), write() | close() | Socket
sockets i/o vector
dir | dir() | readdir(), rewinddir() | closedir() | Dir handle
file | fopen() | feof(), fflush(), fgetc(), fgetcsv(), fgets(), fgetss(), flock(), fpassthru(), fputs(), fwrite(), fread(), fseek(), ftell(), fstat(), ftruncate(), set_file_buffer(), rewind() | fclose() | File handle
pipe | popen() | feof(), fflush(), fgetc(), fgetcsv(), fgets(), fgetss(), fpassthru(), fputs(), fwrite(), fread() | pclose() | Process handle
socket | fsockopen() | fflush(), fgetc(), fgetcsv(), fgets(), fgetss(), fpassthru(), fputs(), fwrite(), fread() | fclose() | Socket handle
stream
sybase-db link | sybase_connect() | sybase_query(), sybase_select_db() | sybase_close() | Link to Sybase database using DB library
sybase-db link persistent | sybase_pconnect() | sybase_query(), sybase_select_db() | None | Persistent link to Sybase database using DB library
sybase-db result | sybase_query() | sybase_data_seek(), sybase_fetch_array(), sybase_fetch_field(), sybase_fetch_object(), sybase_fetch_row(), sybase_field_seek(), sybase_num_fields(), sybase_num_rows(), sybase_result() | sybase_free_result() | Sybase result using DB library
sybase-ct link | sybase_connect() | sybase_affected_rows(), sybase_query(), sybase_select_db() | sybase_close() | Link to Sybase database using CT library
sybase-ct link persistent | sybase_pconnect() | sybase_affected_rows(), sybase_query(), sybase_select_db() | None | Persistent link to Sybase database using CT library
sybase-ct result | sybase_query() | sybase_data_seek(), sybase_fetch_array(), sybase_fetch_field(), sybase_fetch_object(), sybase_fetch_row(), sybase_field_seek(), sybase_num_fields(), sybase_num_rows(), sybase_result() | sybase_free_result() | Sybase result using CT library
sysvsem | sem_get() | sem_acquire() | sem_release() | System V Semaphore
sysvshm | shm_attach() | shm_remove(), shm_put_var(), shm_get_var(), shm_remove_var() | shm_detach() | System V Shared Memory
wddx | wddx_packet_start() | wddx_add_vars() | wddx_packet_end() | WDDX packet
xml | xml_parser_create() | xml_set_object(), xml_set_element_handler(), xml_set_character_data_handler(), xml_set_processing_instruction_handler(), xml_set_default_handler(), xml_set_unparsed_entity_decl_handler(), xml_set_notation_decl_handler(), xml_set_external_entity_ref_handler(), xml_parse(), xml_get_error_code(), xml_error_string(), xml_get_current_line_number(), xml_get_current_column_number(), xml_get_current_byte_index(), xml_parse_into_struct(), xml_parser_set_option(), xml_parser_get_option() | xml_parser_free() | XML parser
zlib | gzopen() | gzeof(), gzgetc(), gzgets(), gzgetss(), gzpassthru(), gzputs(), gzread(), gzrewind(), gzseek(), gztell(), gzwrite() | gzclose() | gz-compressed file

이전 | 처음으로 | 다음
표준 기선언 상수 | 위로 | 지원 프로토콜/래퍼 목록


지원 프로토콜/래퍼 목록

PHP 매뉴얼
이전 다음

J. 부록. 지원 프로토콜/래퍼 목록

차례
파일시스템
HTTP 와 HTTPS
FTP 와 FTPS
PHP 입력/출력(input/output) 스트림
압축 스트림

다음은 fopen()과 copy() 등의 파일시스템 함수용으로 내장된 PHP의 다양한 URL 스타일 프로토콜의 목록이다. 이런 래퍼들은 물론, PHP 4.3.0에서는, PHP 스크립트와 stream_wrapper_register()를 사용하여 자신의 래퍼를 작성할 수 있다.

파일시스템

PHP의 모든 버전. 특히 PHP 4.3.0부터는 file:// 사용.

  • /path/to/file.ext

  • relative/path/to/file.ext

  • fileInCwd.ext

  • C:/path/to/winfile.ext

  • C:\path\to\winfile.ext

  • \\smbserver\share\path\to\winfile.ext

  • file:///path/to/file.ext

file://은 PHP에서 사용하는 기본 래퍼로, 로컬 파일시스템을 표현합니다. 상대 경로(/, \, \\, 윈도우 드라이브 문자로 시작하지 않는 경로)를 지정하면, 경로는 현재 작업 디렉토리로부터 적용합니다. 대부분의 경우에, 변경하지 않는 한 이는 스크립트가 존재하는 디렉토리입니다. CLI sapi를 사용할 때, 디렉토리의 기본값은 스크립트를 호출한 위치입니다.

fopen()과 file_get_contents() 등의 몇몇 함수는 include_path의 상대 경로도 검색합니다.

표 J-1. 래퍼 요약

속성 | 지원
allow_url_fopen으로 제한 | No
읽기 허용 | Yes
쓰기 허용 | Yes
추가 허용 | Yes
동시 읽기/쓰기 허용 | Yes
stat() 지원 | Yes
unlink() 지원 | Yes
rename() 지원 | Yes
mkdir() 지원 | Yes
rmdir() 지원 | Yes

이전 | 처음으로 | 다음
리소스 타입 목록 | 위로 | HTTP 와 HTTPS


HTTP 와 HTTPS

PHP 3, PHP 4. PHP 4.3.0 이후의 https://

  • http://example.com

  • http://user:password@example.com

  • https://example.com

  • https://user:password@example.com

HTTP GET 방식을 사용하여, HTTP 1.0으로 파일/자원에 읽기 전용 권한을 허용합니다. 이름 기반 가상 호스트를 처리하기 위해서 Host: 헤더를 전송합니다. ini 파일이나 스트림 환경을 사용하여 user_agent 문자열을 설정하면, 요청에 같이 포함합니다.

주의

IIS 등의 표준과 호환되지 않는 일부 웹서버에서는 이 방법으로 데이터를 전송할 때 PHP가 경고를 발생합니다. 이러한 웹서버에서 사용할 때는 error_reporting 레벨을 낮춰서, 경고를 포함하지 않도록 하십시오.

리다이렉트(Redirect)는 PHP 4.0.5부터 지원합니다; 이전 버전을 사용한다면 URL의 마지막에 슬래쉬를 포함해야 합니다. (모든 리다이렉트를 처리한 에후) 문서가 어떤 URL 오는지 파악해야 한다면, 스트림을 통해 반환하는 응답 헤더를 처리해야 합니다.

<?php
$url = 'http://www.example.com/redirecting_page.php';

$fp = fopen($url, 'r');

/* PHP 4.3.0 이전에서는 stream_get_meta_data()
   대신 $http_response_header를 사용하십시오 */
foreach(stream_get_meta_data($fp) as $response) {

  /* 어디로 리다이렉트합니까? */
  if (substr(strtolower($response), 0, 10) == 'location: ') {
    /* 리다이렉트 되는 곳으로 $url을 갱신합니다 */
    $url = substr($response, 10);
  }

}

?>

스트림은 리소스의 body에 접속할 권한이 있다; 헤더는 $http_response_header 변수에 저장된다. PHP 4.3.0 이후부터, 헤더는 stream_get_meta_data()를 사용하여 이용가능하다.

HTTP 접속은 읽기-전용이다; HTTP 리소스에 데이터를 쓰거나 파일을 복사할수 없다.

참고: HTTPS는 PHP 4.3.0부터 지원되었다. OpenSSL에 대한 지원 옵션으로 컴파일해야 한다.

표 J-2. 래퍼 요약

속성 | 지원
allow_url_fopen으로 제한 | Yes
읽기 허용 | Yes
쓰기 허용 | No
추가 허용 | No
동시 읽기/쓰기 허용 | N/A
stat() 지원 | No
unlink() 지원 | No
rename() 지원 | No
mkdir() 지원 | No
rmdir() 지원 | No

표 J-3. 컨텍스트 옵션(PHP 5.0.0의)

이름 | 사용 | 기본값
method | 원격 서버에 의해 지원되는 GET, POST과 다른 모든 HTTP 메소드 | GET
header | 요청시 전송되는 추가적인 헤더. 이 옵션 값은 다른 값들(User-agent:, Host:, Authentication:)에 의해 오버라이드될것이다. |
user_agent | User-Agent: 헤더에 의해 전송되는 값. 이 값은 user-agent가 header 컨텍스트 옵션에서 설정되지 않을때만 사용될것이다. | php.ini setting: user_agent
content | 헤더 다음에 전송되는 추가데이터. 표준적으로 POST나 PUT 요청에서 사용된다. |
proxy | 프록시 서버를 지정하는 URI. (예. tcp://proxy.example.com:5100) |
request_fulluri | TRUE로 설정하면, 전체 URI를 사용하여 요청을 작성합니다. (예. GET http://www.example.com/path/to/file.html HTTP/1.0) 이는 비표준 요청 형식이지만, 몇몇 프록시 서버는 이를 요구합니다. | FALSE

기저(Underlying) 소켓 스트림 컨텍스트 옵션: http:// 스트림에 대한 기저(underlying) 전송에 의해 지원될수 있는 추가 컨텍스트 옵션이고, tcp:// 전송 컨텍스트 옵션으로 참조된다. https:// 스트림에 대해서는 ssl:// 전송 컨텍스트 옵션으로 참조된다.

이전 | 처음으로 | 다음
지원 프로토콜/래퍼 목록 | 위로 | FTP 와 FTPS


FTP 와 FTPS

PHP 3, PHP 4. PHP 4.3.0이후부터 ftps://

  • ftp://example.com/pub/file.txt

  • ftp://user:password@example.com/pub/file.txt

  • ftps://example.com/pub/file.txt

  • ftps://user:password@example.com/pub/file.txt

FTP를 통해 기존 파일에 대한 읽기 권한과 새로운 파일의 생성 권한을 허용한다. 서버가 패시브 모드(passive mode) ftp를 지원하지않으면, 접속이 실패할것이다.

읽거나 쓰기 위해 파일을 열수 있다. 그러나 동시에 읽기/쓰기를 할수 없다. 원격 파일이 ftp 서버에 이미 존재하고 그 파일에 쓰기를 시도하려하는데 컨텍스트 옵션 overwrite 를 설정하지 않았다면, 접속이 실패할것이다. 차선책으로 FTP extension을 사용할수 있다.

덧붙이기: PHP 5.0.0부터 ftp:// URL 래퍼를 통해서 파일을 덧붙일 수 있습니다. 이전 버전에서, ftp://를 통한 파일 덧붙이기는 실패합니다.

PHP 4.3.0부터 ftps://를 지원한다. ftp://와 동일하지만, ftp 서버를 통해 안전한 접속 협상(negotiate)을 시도하려 한다. 서버가 SSL을 지원하지 않으면, 접속은 원래의 인코딩되지 않는 ftp로 되돌아간다.

참고: FTPS는 PHP 4.3.0부터 지원되었다. OpenSSL을 지원하도록 컴파일되어야 한다.

표 J-4. 래퍼 요약

속성 | PHP 4 | PHP 5
allow_url_fopen으로 제한 | Yes | Yes
읽기 허용 | Yes | Yes
쓰기 허용 | Yes (새 파일만) | Yes (새 파일/overwrite로 기존 파일)
추가 허용 | No | Yes
동시 읽기/쓰기 허용 | No | No
stat() 지원 | No | filesize(), filetype(), file_exists(), is_file(), is_dir() 요소만.
unlink() 지원 | No | Yes
rename() 지원 | No | Yes
mkdir() 지원 | No | Yes
rmdir() 지원 | No | Yes

표 J-5. 컨텍스트 옵션(PHP 5.0.0의)

이름 | 사용 | 기본값
overwrite | 원격 서버에 이미 존재하는 파일 덮어쓰기를 허용. 쓰기 모드(업로딩)에만 적용. | FALSE (Disabled)
resume_pos | 전송을 시작할 파일 위치. 읽기 모드(다운로딩)에만 적용. | 0 (파일 처음)

기저(Underlying) 소켓 스트림 컨텍스트 옵션: 기저(underlying) 전송에 ftp:// 스트림을 지원할수 있는 추가 컨텍스트 옵션이며 tcp:// 전송에 대한 컨텍스트 옵션으로 참조된다. ftps:// 스트림에 대해서는 ssl:// 전송에 대한 컨텍스트 옵션으로 참조된다.

이전 | 처음으로 | 다음
HTTP 와 HTTPS | 위로 | PHP 입력/출력(input/output) 스트림


PHP 입력/출력(input/output) 스트림

PHP 3.0.13 이후의, php://output PHP 4.3.0 이후의 php://input, PHP 5.0.0 이후의 php://filter

  • php://stdin

  • php://stdout

  • php://stderr

  • php://output

  • php://input

  • php://filter

php://stdin, php://stdout php://stderr은 PHP 프로세스의 입력이나 출력 스트림에 대한 접속 권한을 허용한다.

php://output은 print() 와 echo() 같은 출력 버퍼 메카니즘에 대한 쓰기 권한을 허용한다.

php://input은 raw POST 데이터를 읽을수 있는 권한을 허용한다. $HTTP_RAW_POST_DATA에 대한 메모리 집적에 대한 차선책이고, 특별한 php.ini 디렉티브 설정이 필요치 않다.

php://stdin 과 php://input 은 읽기 전용, 반면에 php://stdout, php://stderr 은 php://output 쓰기 전용이다.

php://filter는 스트림을 열때 필터의 응용을 허용하도록 설계된 메타-래퍼(meta-wrapper)의 한 종류이다. 컨텐츠를 읽기전에 스트림에 대한 필터를 적용할 기회가 전혀 없는 readfile(), file(), file_get_contents() 같은 올-인-원(all-in-one) 함수에 대한 가용성을 갖는다.

php://filter 타겟은 그 'path'의 부분으로서 다음 'parameters'를 취한다.

  • /resource=<필터링되는 스트림> (필수) 이 인자는 php://filter 사양의 끝부분에 위치해야 하고 필터링을 원하는 스트림을 가리켜야 한다.

    <?php
    /* This is equivalent to simply:
       readfile("http://www.example.com");
       since no filters are actually specified */

    readfile("php://filter/resource=http://www.example.com");
    ?>

  • /read=<읽기 체인에 적용되는 필터 리스트> (선택적) 이 인자는 | 파이프 문자로 구분되는 하나이상의 필터명이 적용된다.

    <?php
    /* This will output the contents of
       www.example.com entirely in uppercase */
    readfile("php://filter/read=string.toupper/resource=http://www.example.com");

    /* This will do the same as above
       but will also ROT13 encode it */
    readfile("php://filter/read=string.toupper|string.rot13/resource=http://www.example.com");
    ?>

  • /write=<쓰기 체인에 적용되는 필터 리스트> (선택적) 이 인자는 | 파이프 문자로 구분하는 하나이상의 필터명을 적용합니다.

    <?php
    /* This will filter the string "Hello World"
       through the rot13 filter, then write to
       example.txt in the current directory */
    file_set_contents("php://filter/write=string.rot13/resource=example.txt","Hello World");
    ?>

  • <양쪽 체인에 적용되는 필터 리스트> (선택적) read=나 write=에 선행하지 않는 모든 필터 목록은 읽기와 쓰기 양쪽 모두의 체인에 (적절하게) 적용합니다.

표 J-6. 래퍼(Wrapper) 요약(php://filter에 대한, 필터링 되는 래퍼의 요약으로 참조됨.)

속성 | 지원
allow_url_fopen으로 제한 | No
읽기 허용 | php://stdin, php://input 전용.
쓰기 허용 | php://stdout, php://stderr, php://output 전용.
추가 허용 | php://stdout, php://stderr, php://output only. (쓰기와 동일)
동시 읽기/쓰기 허용 | No. 이 래퍼는 방향성을 갖지 않는다.
stat() 지원 | No
unlink() 지원 | No
rename() 지원 | No
mkdir() 지원 | No
rmdir() 지원 | No

이전 | 처음으로 | 다음
FTP 와 FTPS | 위로 | 압축 스트림


압축 스트림

zlib: PHP 4.0.4 - PHP 4.2.3 (fopencookie만 갖는 시스템)

compress.zlib://과 compress.bzip2:// PHP 4.3.0 이상

  • zlib:

  • compress.zlib://

  • compress.bzip2://

zlib:는 gzopen()처럼 동작한다, fread()와 다른 파일시스템 함수와 함께 사용할수 없다. ':' 문자를 포함하는 파일명이 갖는 모호함때문에 PHP 4.3.0이후부터 사용되지 않는다. 대신 compress.zlib://를 사용한다.

compress.zlib:// 와 compress.bzip2:// 은 각각 gzopen() , bzopen()와 동일하게 동작하고, fopencookie를 지원하지 않는 시스템에서도 사용할수 있다.

표 J-7. 래퍼(Wrapper) 요약

속성 | 지원
allow_url_fopen으로 제한 | No
읽기 허용 | Yes
쓰기 허용 | Yes
추가 허용 | Yes
동시 읽기/쓰기 허용 | No
stat()지원 | No, 압축된 파일을 stat하기 위해서 보통의 file:// 래퍼를 사용한다.
unlink()지원 | No, 압축된 파일을 unlink하기 위해서 보통의 file:// 래퍼를 사용한다.
rename() 지원 | No
mkdir() 지원 | No
rmdir() 지원 | No

이전 | 처음으로 | 다음
PHP 입력/출력(input/output) 스트림 | 위로 | List of Available Filters


List of Available Filters

PHP 매뉴얼
이전 다음

K. 부록. List of Available Filters

차례
String Filters
Conversion Filters
Compression Filters

The following is a list of a few built-in stream filters for use with stream_filter_append(). Your version of PHP may have more filters (or fewer) than those listed here.

It is worth noting a slight asymmetry between stream_filter_append() and stream_filter_prepend(). Every PHP stream contains a small read buffer where it stores blocks of data retrieved from the filesystem or other resource in order to process data in the most efficient manner. As soon as data is pulled from the resource into the stream's internal buffer, it is immediately processed through any attached filters whether the PHP application is actually ready for the data or not. If data is sitting in the read buffer when a filter is appended, this data will be immediately processed through that buffer making the fact that is was sitting in the buffer seem transparent. However, if data is sitting in the read buffer when a filter is prepended, this data will NOT be processed through that filter. It will instead wait until the next block of data is retrieved from the resource.

For a list of filters installed in your version of PHP use stream_get_filters().

String Filters

Each of these filters does precisely what their name implies and correspond to the behavior of a built-in php string handling function. For more information on a given filter, refer to the manual page for the corresponding function.

string.rot13 (since PHP 4.3.0) Use of this filter is equivalent to processing all stream data through the str_rot13() function.

예 K-1. string.rot13

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.rot13');
fwrite($fp, "This is a test.\n");
/* Outputs:  Guvf vf n grfg.   */
?>

string.toupper (since PHP 5.0.0) Use of this filter is equivalent to processing all stream data through the strtoupper() function.

예 K-2. string.toupper

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.toupper');
fwrite($fp, "This is a test.\n");
/* Outputs:  THIS IS A TEST.   */
?>

string.tolower (since PHP 5.0.0) Use of this filter is equivalent to processing all stream data through the strtolower() function.

예 K-3. string.tolower

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.tolower');
fwrite($fp, "This is a test.\n");
/* Outputs:  this is a test.   */
?>

string.strip_tags (since PHP 5.0.0) Use of this filter is equivalent to processing all stream data through the strip_tags() function. It accepts parameters in one of two forms: Either as a string containing a list of tags similar to the second parameter of the strip_tags() function, or as an array of tag names.

예 K-4. string.strip_tags

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.strip_tags', STREAM_FILTER_WRITE, "<b><i><u>");
fwrite($fp, "<b>bolded text</b> enlarged to a <h1>level 1 heading</h1>\n");
fclose($fp);
/* Outputs:  <b>bolded text</b> enlarged to a level 1 heading   */

$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.strip_tags', STREAM_FILTER_WRITE, array('b','i','u'));
fwrite($fp, "<b>bolded text</b> enlarged to a <h1>level 1 heading</h1>\n");
fclose($fp);
/* Outputs:  <b>bolded text</b> enlarged to a level 1 heading   */
?>

이전 | 처음으로 | 다음
압축 스트림 | 위로 | Conversion Filters


Conversion Filters

Like the string.* filters, the convert.* filters perform actions similar to their names. The convert filters were added with PHP 5.0.0. For more information on a given filter, refer to the manual page for the corresponding function.

convert.base64-encode and convert.base64-decode Use of these filters are equivalent to processing all stream data through the base64_encode() and base64_decode() functions respectively. convert.base64-encode supports parameters given as an associative array. If line-length is given, the base64 output will be split into chunks of line-length characters each. If line-break-chars is given, each chunk will be delimited by the characters given. These parameters give the same effect as using base64_encode() with chunk_split().

예 K-5. convert.base64-encode & convert.base64-decode

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.base64-encode');
fwrite($fp, "This is a test.\n");
fclose($fp);
/* Outputs:  VGhpcyBpcyBhIHRlc3QuCg==  */

$param = array('line-length' => 8, 'line-break-chars' => "\r\n");
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.base64-encode', STREAM_FILTER_WRITE, $param);
fwrite($fp, "This is a test.\n");
fclose($fp);
/* Outputs:  VGhpcyBp
          :  cyBhIHRl
          :  c3QuCg==  */

$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.base64-decode');
fwrite($fp, "VGhpcyBpcyBhIHRlc3QuCg==");
fclose($fp);
/* Outputs:  This is a test.  */
?>

convert.quoted-printable-encode and convert.quoted-printable-decode Use of the decode version of this filter is equivalent to processing all stream data through the quoted_printable_decode() functions. There is no function equivalent to convert.quoted-printable-encode. convert.quoted-printable-encode supports parameters given as an associative array. In addition to the parameters supported by convert.base64-encode, convert.quoted-printable-encode also supports boolean arguments binary and force-encode-first. convert.base64-decode only supports the line-break-chars parameter as a type-hint for striping from the encoded payload.

예 K-6. convert.quoted-printable-encode & convert.quoted-printable-decode

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.quoted-printable-encode');
fwrite($fp, "This is a test.\n");
/* Outputs:  =This is a test.=0A  */
?>

이전 | 처음으로 | 다음
List of Available Filters | 위로 | Compression Filters


Compression Filters

While the `압축 스트림' 절의 부록 J provide a way of creating gzip and bz2 compatable files on the local filesystem, they do not provide a means for generalized compression over network streams, nor do they provide a means to begin with a non-compressed stream and transition to a compressed one. For this, a compression filter may be applied to any stream resource at any time.

참고: Compression filters do not generate headers and trailers used by commandline utilites such as gzip. They only compress and decompress the payload portions of compressed data streams.

zlib.deflate (compression) and zlib.inflate (decompression) are implementations of the compression methods described in RFC 1951. The deflate filter takes up to three parameters passed as an associative array. level describes the compression strength to use (1-9). Higher numbers will generally yield smaller payloads at the cost of additional processing time. Two special compression levels also exist: 0 (for no compression at all), and -1 (zlib internal default -- currently 6). window is the base-2 log of the compression loopback window size. Higher values (up to 15 -- 32768 bytes) yield better compression at a cost of memory, while lower values (down to 9 -- 512 bytes) yield worse compression in a smaller memory footprint. Default window size is currently 15. memory is a scale indicating how much work memory should be allocated. Valid values range from 1 (minimal allocation) to 9 (maximum allocation). This memory allocation affects speed only and does not impact the size of the generated payload.

참고: Because compression level is the most commonly used parameter, it may be alternatively provided as a simple integer value (rather than an array element).

참고: The zlib.* filters are not currently built into the PHP core. To enable these filters in PHP 5, install the zlib_filter package from PECL. These filters are not available for PHP 4.

예 K-7. zlib.deflate and zlib.inflate

<?php
$params = array('level' => 6, 'window' => 15, 'memory' => 9);

$original_text = "This is a test.\nThis is only a test.\nThis is not an important string.\n";
echo "The original text is " . strlen($original_text) . " characters long.\n";

$fp = fopen('test.deflated', 'w');
stream_filter_append($fp, 'zlib.deflate', STREAM_FILTER_WRITE, $params);
fwrite($fp, $original_text);
fclose($fp);

echo "The compressed file is " . filesize('test.deflated') . " bytes long.\n";
echo "The original text was:\n";
/* Use readfile and zlib.inflate to decompress on the fly */
readfile('php://filter/zlib.inflate/resource=test.deflated');

/* Generates output:

The original text is 70 characters long.
The compressed file is 56 bytes long.
The original text was:
This is a test.
This is only a test.
This is not an important string.

*/
?>

예 K-8. zlib.deflate simple

<?php
$original_text = "This is a test.\nThis is only a test.\nThis is not an important string.\n";
echo "The original text is " . strlen($original_text) . " characters long.\n";

$fp = fopen('test.deflated', 'w');
/* Here "6" indicates compression level 6 */
stream_filter_append($fp, 'zlib.deflate', STREAM_FILTER_WRITE, 6);
fwrite($fp, $original_text);
fclose($fp);

echo "The compressed file is " . filesize('test.deflated') . " bytes long.\n";

/* Generates output:

The original text is 70 characters long.
The compressed file is 56 bytes long.

*/
?>

bzip2.compress and bzip2.decompress work in the same manner as the zlib filters described above. The bzip2.compress filter accepts up to two parameters given as elements of an associative array: blocks is an integer value from 1 to 9 specifying the number of 100kbyte blocks of memory to allocate for workspace. work is also an integer value ranging from 0 to 250 indicating how much effort to expend using the normal compression method before falling back on a slower, but more reliable method. Tuning this parameter effects only compression speed. Neither size of compressed output nor memory usage are changed by this setting. A work factor of 0 instructs the bzip library to use an internal default. The bzip2.decompress filter only accepts one parameter, which can be passed as either an ordinary boolean value as the small element of an associative array. small, when set to a TRUE value, instructs the bzip library to perform decompression in a minimal memory footprint at the cost of speed.

참고: The bzip2.* filters are not currently built into the PHP core. To enable these filters in PHP 5, install the bz2_filter package from PECL. These filters are not available for PHP 4.

예 K-9. bzip2.compress and bzip2.decompress

<?php
$param = array('blocks' => 9, 'work' => 0);

echo "The original file is " . filesize('LICENSE') . " bytes long.\n";

$fp = fopen('LICENSE.compressed', 'w');
stream_filter_append($fp, 'bzip2.compress', STREAM_FILTER_WRITE, $param);
fwrite($fp, file_get_contents('LICENSE'));
fclose($fp);

echo "The compressed file is " . filesize('LICENSE.compressed') . " bytes long.\n";

/* Generates output:

The original text is 3288 characters long.
The compressed file is 1488 bytes long.

*/
?>

이전 | 처음으로 | 다음
Conversion Filters | 위로 | 지원되는 소켓 전송 목록


지원되는 소켓 전송 목록

PHP 매뉴얼
이전 다음

L. 부록. 지원되는 소켓 전송 목록

차례
인터넷 도메인: TCP, UDP, SSL, TLS
유닉스 도메인: UNIX와 UDG

다음은 fsockopen()과 stream_socket_client()같은 스트림 기반 소켓 함수를 사용하기 위해 PHP가 내장하고 있는 다양한 URL 스타일의 소켓 전송 목록이다. 이런 전송들은 Sockets Extension에 적용되지 않는다.

설치된 PHP 버전안에 사용가능한 전송 리스트를 보려면 stream_get_transports()를 사용하라.

인터넷 도메인: TCP, UDP, SSL, TLS

PHP 3, PHP 4. ssl:// & PHP 4.3이후의 tls://

참고: 전송이 표시되지 않으면 tcp://라고 가정할것이다.

  • 127.0.0.1

  • fe80::1

  • www.example.com

  • tcp://127.0.0.1

  • tcp://fe80::1

  • tcp://www.example.com

  • udp://www.example.com

  • ssl://www.example.com

  • tls://www.example.com

인터넷 도메인 소켓은 목표 주소에 더하여 포트 번호가 올것을 예상할수 있다. fsockopen()의 경우 이것은 두번째 인수에서 설정되고 따라서 전송 url의 구성에 영향을 주지 않는다. stream_socket_client()와 이와 관련된 함수는 전통적인 URL을 갖는다. 포트 번호는 전송 URL의 끝에 콜론으로 구분되어 덧붙여진다.

  • tcp://127.0.0.1:80

  • tcp://[fe80::1]:80

  • tcp://www.example.com:80

포트 번호를 갖는 IPv6 숫자 주소: 위 예제중 두번째는, IPv4의 호스트명 예제가 콜른과 포트번호의 추가와는 별개로 남겨져있는데 반하여, IPv6 주소는 대괄호: [fe80::1]에 둘러쌓여 있다. 이것은 IPv6 주소에서 사용되는 콜론과 포트번호를 구분하기 위해 사용되는 콜론을 구별하기 위한 것이다.

ssl:// 과 tls:// 전송은 (openssl 지원이 PHP안에 컴파일되었을때만 가용) SSL 암호화를 포함하는 tcp:// 전송의 확장이다. PHP 4.3.0이후에 OpenSSL 지원은 PHP와 정적으로 컴파일되어야 한다. PHP 5.0.0 이후부터는 모듈이건 정적이건 아무거나 컴파일 되어 사용될수 있을것이다.

표 L-1. ssl://와 tls://에 대한 환경 옵션 (PHP 4.3.2 이후 버전)

이름 | 용도 | 기본값
verify_peer | TRUE or FALSE. 사용되는 SSL 인증의 조회를 요구 | FALSE
allow_self_signed | TRUE or FALSE. 자체-사인된 인증을 허용 | FALSE
cafile | 원격단의 신원을 인증하기 위한 verify_peer 환경 옵션으로 사용될수 있는 로컬 파일시스템상의 인증 증명서 파일의 위치 |
capath | cafile에서 설정되지 않거나 인증서를 거기서 찾을수 없다면, capath에 의해 지정된 디렉토리에서 적절한 인증서를 검색한다. capath는 정확하게 해쉬된 인증서 디렉토리여야 한다. |
local_cert | 파일시스템 상의 로컬 인증서 파일로의 경로. 인증과 개인키를 포함하는 인코딩된 PEM 파일이 되어야 한다. 이것은 요구자의 인증 체인을 선택적으로 포함할수 있다. |
passphrase | 인코딩된 local_cert파일의 패스구절(passphrase). |
CN_match | Common Name 이 와야 함. PHP는 제한된 와일드카드 비교를 수행할것이다. Common Name이 이와 일치하지 않으면, 접속시도가 실패할것이다. |

참고: ssl://은 https://와 ftps:// 래퍼를 위한 중요한 전송이기 때문에, ssl://에 적용되는 환경 옵션은 https://와 ftps://에도 적용된다.

이전 | 처음으로 | 다음
Compression Filters | 위로 | 유닉스 도메인: UNIX와 UDG


유닉스 도메인: UNIX와 UDG

PHP 3 이후의 unix://, PHP 5 이후의 udg://

  • unix:///tmp/mysock

  • udg:///tmp/mysock

unix://는 유닉스 도메인에 대한 소켓 스트림 접속 시도를 제공한다. udg://는 user datagram protocol을 사용하는 유닉스 도메인 소켓에 대한 대체 전송을 제공한다.

유닉스 도메인 소켓은 인터넷 도메인 소켓과는 달리 포트 번호를 쓰지 않는다. fsockopen()에서 portno 인자는 0이 되어야 한다.

이전 | 처음으로 | 다음
지원되는 소켓 전송 목록 | 위로 | PHP 타입 비교 테이블


PHP 타입 비교 테이블

PHP 매뉴얼
이전 다음

M. 부록. PHP 타입 비교 테이블

다음 테이블은 PHP 타입 과 느슨한 비교와 엄격한 비교를 위한 비교 연산자의 동작을 설명한다. 이 부록은 타입 저글링에 관한 매뉴얼 섹션과도 관련이 있다. 다양한 유저 주석과 BlueShoes의 보고서를 통해 영감을 얻을수 있다.

이 테이블을 이용하기 전에, 타입과 각 타입의 의미를 이해해야 한다. 예를 들면, "42"는 string타입이고, 반면에 42는 integer타입이다. FALSE는 boolean타입이고, "false"는 string타입이 되는것이다.

참고: HTML 폼은 정수, 부동소수점, 논리 타입으로 전달하지 않는다. 문자열 타입으로 전달한다. 문자열이 숫자값인지 확인하기 위해서는 is_numeric()를 사용할수 있다.

참고: $x가 선언되지 않았는데 단순히 if ($x)를 수행하면 E_NOTICE 레벨의 에러가 발생할것이다. 대신 empty()나 isset()을 사용하고 그 변수를 초기화시키도록 한다.

표 M-1. PHP 함수로 $x 비교하기

Expression | gettype() | empty() | is_null() | isset() | boolean : if($x)
$x = ""; | string | TRUE | FALSE | TRUE | FALSE
$x = NULL | NULL | TRUE | TRUE | FALSE | FALSE
var $x; | NULL | TRUE | TRUE | FALSE | FALSE
$x is undefined | NULL | TRUE | TRUE | FALSE | FALSE
$x = array(); | array | TRUE | FALSE | TRUE | FALSE
$x = false; | boolean | TRUE | FALSE | TRUE | FALSE
$x = true; | boolean | FALSE | FALSE | TRUE | TRUE
$x = 1; | integer | FALSE | FALSE | TRUE | TRUE
$x = 42; | integer | FALSE | FALSE | TRUE | TRUE
$x = 0; | integer | TRUE | FALSE | TRUE | FALSE
$x = -1; | integer | FALSE | FALSE | TRUE | TRUE
$x = "1"; | string | FALSE | FALSE | TRUE | TRUE
$x = "0"; | string | TRUE | FALSE | TRUE | FALSE
$x = "-1"; | string | FALSE | FALSE | TRUE | TRUE
$x = "php"; | string | FALSE | FALSE | TRUE | TRUE
$x = "true"; | string | FALSE | FALSE | TRUE | TRUE
$x = "false"; | string | FALSE | FALSE | TRUE | TRUE

표 M-2. ==로 느슨한 비교

 | TRUE | FALSE | 1 | 0 | -1 | "1" | "0" | "-1" | NULL | array() | "php"
TRUE | TRUE | FALSE | TRUE | FALSE | TRUE | TRUE | FALSE | TRUE | FALSE | FALSE | TRUE
FALSE | FALSE | TRUE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | TRUE | TRUE | FALSE
1 | TRUE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE
0 | FALSE | TRUE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | TRUE | FALSE | TRUE
-1 | TRUE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE
"1" | TRUE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE
"0" | FALSE | TRUE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE
"-1" | TRUE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE
NULL | FALSE | TRUE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | TRUE | TRUE | FALSE
array() | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE
"php" | TRUE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE

표 M-3. ===로 엄격한 비교

 | TRUE | FALSE | 1 | 0 | -1 | "1" | "0" | "-1" | NULL | array() | "php"
TRUE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE
FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE
1 | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE
0 | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE
-1 | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE
"1" | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE
"0" | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE
"-1" | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE
NULL | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE
array() | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE
"php" | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE

PHP 3.0 주의 사항: 문자열 값 "0"은 PHP 3에서 비어있다고 처리되지 않는다. 이런 동작은 PHP 4에서 비어있다고 처리되도록 변경되었다.

이전 | 처음으로 | 다음
유닉스 도메인: UNIX와 UDG | 위로 | 해석기 토큰 목록


해석기 토큰 목록

PHP 매뉴얼
이전 다음

N. 부록. 해석기 토큰 목록

PHP 언어의 많은 부분은 내부적으로 T_SR같은 타입으로 표현된다. PHP는 해석 에러에서 이와 같은 식별자를 출력한다. 다음과 같은 형태이다. "Parse error: unexpected T_SR, expecting ',' or ';' in script.php on line 10."

위는 T_SR이 무슨 의미인지 안다고 가정한다. 그 의미를 알지못하는 모든 사람을 위해 그런 식별자,PHP-문법,매뉴얼에 위치한 적절한 레퍼런스의 테이블을 보인다.

표 N-1. 토큰

토큰 | 문법 | 레퍼런스
T_AND_EQUAL | &= | assignment operators
T_ARRAY | array() | array(), array syntax
T_ARRAY_CAST | (array) | type-casting
T_AS | as | foreach
T_BAD_CHARACTER |  | anything below ASCII 32 except \t (0x09), \n (0x0a) and \r (0x0d)
T_BOOLEAN_AND | && | logical operators
T_BOOLEAN_OR | || | logical operators
T_BOOL_CAST | (bool) or (boolean) | type-casting
T_BREAK | break | break
T_CASE | case | switch
T_CHARACTER |  |
T_CLASS | class | classes and objects
T_CLOSE_TAG | ?> or %> |
T_COMMENT | // or # | comments
T_CONCAT_EQUAL | .= | assignment operators
T_CONST | const |
T_CONSTANT_ENCAPSED_STRING | "foo" or 'bar' | string syntax
T_CONTINUE | continue |
T_CURLY_OPEN |  |
T_DEC | -- | incrementing/decrementing operators
T_DECLARE | declare | declare
T_DEFAULT | default | switch
T_DIV_EQUAL | /= | assignment operators
T_DNUMBER | 0.12, etc | floating point numbers
T_DO | do | do..while
T_DOLLAR_OPEN_CURLY_BRACES | ${ | complex variable parsed syntax
T_DOUBLE_ARROW | => | array syntax
T_DOUBLE_CAST | (real), (double) or (float) | type-casting
T_ECHO | echo | echo()
T_ELSE | else | else
T_ELSEIF | elseif | elseif
T_EMPTY | empty | empty()
T_ENCAPSED_AND_WHITESPACE |  |
T_ENDDECLARE | enddeclare | declare, alternative syntax
T_ENDFOR | endfor | for, alternative syntax
T_ENDFOREACH | endforeach | foreach, alternative syntax
T_ENDIF | endif | if, alternative syntax
T_ENDSWITCH | endswitch | switch, alternative syntax
T_ENDWHILE | endwhile | while, alternative syntax
T_END_HEREDOC |  | heredoc syntax
T_EVAL | eval() | eval()
T_EXIT | exit or die | exit(), die()
T_EXTENDS | extends | extends, classes and objects
T_FILE | __FILE__ | constants
T_FOR | for | for
T_FOREACH | foreach | foreach
T_FUNCTION | function or cfunction | functions
T_GLOBAL | global | variable scope
T_IF | if | if
T_INC | ++ | incrementing/decrementing operators
T_INCLUDE | include() | include()
T_INCLUDE_ONCE | include_once() | include_once()
T_INLINE_HTML |  |
T_INT_CAST | (int) or (integer) | type-casting
T_ISSET | isset() | isset()
T_IS_EQUAL | == | comparison operators
T_IS_GREATER_OR_EQUAL | >= | comparison operators
T_IS_IDENTICAL | === | comparison operators
T_IS_NOT_EQUAL | != or <> | comparison operators
T_IS_NOT_IDENTICAL | !== | comparison operators
T_SMALLER_OR_EQUAL | <= | comparison operators
T_LINE | __LINE__ | constants
T_LIST | list() | list()
T_LNUMBER | 123, 012, 0x1ac, etc | integers
T_LOGICAL_AND | and | logical operators
T_LOGICAL_OR | or | logical operators
T_LOGICAL_XOR | xor | logical operators
T_MINUS_EQUAL | -= | assignment operators
T_ML_COMMENT | /* and */ | comments
T_MOD_EQUAL | %= | assignment operators
T_MUL_EQUAL | *= | assignment operators
T_NEW | new | classes and objects
T_NUM_STRING |  |
T_OBJECT_CAST | (object) | type-casting
T_OBJECT_OPERATOR | -> | classes and objects
T_OLD_FUNCTION | old_function | old_function
T_OPEN_TAG | <?php, <? or <% | escaping from HTML
T_OPEN_TAG_WITH_ECHO | <?= or <%= | escaping from HTML
T_OR_EQUAL | |= | assignment operators
T_PAAMAYIM_NEKUDOTAYIM | :: | ::
T_PLUS_EQUAL | += | assignment operators
T_PRINT | print() | print()
T_REQUIRE | require() | require()
T_REQUIRE_ONCE | require_once() | require_once()
T_RETURN | return | returning values
T_SL | << | bitwise operators
T_SL_EQUAL | <<= | assignment operators
T_SR | >> | bitwise operators
T_SR_EQUAL | >>= | assignment operators
T_START_HEREDOC | <<< | heredoc syntax
T_STATIC | static | variable scope
T_STRING |  |
T_STRING_CAST | (string) | type-casting
T_STRING_VARNAME |  |
T_SWITCH | switch | switch
T_UNSET | unset() | unset()
T_UNSET_CAST | (unset) | (not documented; casts to NULL)
T_USE | use | (not implemented)
T_VAR | var | classes and objects
T_VARIABLE | $foo | variables
T_WHILE | while | while, do..while
T_WHITESPACE |  |
T_XOR_EQUAL | ^= | assignment operators
T_FUNC_C | __FUNCTION__ | constants, since PHP 4.3.0
T_CLASS_C | __CLASS__ | constants, since PHP 4.3.0

이전 | 처음으로 | 다음
PHP 타입 비교 테이블 | 위로 | 이 매뉴얼에 관하여


이 매뉴얼에 관하여

PHP 매뉴얼
이전 다음

O. 부록. 이 매뉴얼에 관하여

차례
포맷
user notes에 관하여
함수 선언(prototype)을 읽는 방법
PHP 버전에 대해서 이 매뉴얼에 문서화되어있다
PHP에 관한 더 많은 정보를 찾는 방법
문서화 향상을 위해 도울수 있는 방법
포맷을 어떤 방법으로 만들었는가
번역

포맷

PHP 매뉴얼은 여러 종류의 포맷으로 제공되고 있다. 이 포맷들은 두가지 그룹으로 나눌수 있는데, 다음과 같다: 온라인상에서 읽을수 있는 포맷, 다운로드될수 있는 패키지.

참고: 이 매뉴얼을 출력한 형태로 만들수 있으나, 이렇게 하는것을 추천하지 않는다. 왜냐하면, 이런 출력물은 최신판에서 매우 빨리 뒤쳐질것이기 때문이다.

온라인 상의 http://www.php.net/과 그외 여러 미러사이트를 통해서 이 매뉴얼을 볼 수 있다. 빠른 속도를 위해서는 접속지역과 가장 가까운 미러사이트에 접속해야 할것이다. 이 매뉴얼을 단순한(출력용) HTML 포맷이나 PHP 웹사이트 자체에 통합된 매뉴얼의 HTML 포맷으로도 볼수 있다.

대부분의 오프라인 포맷에 비해 온라인 매뉴얼의 장점은 user-contributed notes의 통합이다. 확실한 단점은 온라인 포맷의 매뉴얼을 보기 위해서 온라인상에 있어야 한다는 것이다.

몇가지의 오프라인 매뉴얼 포맷이 제공되며, 이중 가장 적합한 포맷은 사용중인 운영체제와 개인적인 독서 스타일에 달려있다. 그런 많은 매뉴얼들이 어떻게 생성되는지 알기 위해서는 이 부록의 'How we generate the formats' 섹션을 참고한다.

이 매뉴얼 포맷중 가장 운영체제간 호환성이 높은것은 HTML과 단순-텍스트 버전이다. HTML 포맷은 단일의 HTML 파일과 섹션 파일들로 구성된 패키지로 제공된다. (각 섹션은 몇천개의 파일 묶음으로 되어있다) HTML과 단순텍스트 포맷은 bzip2 아카이브를 이용하여 압축된 타(tar)파일로 제공된다.

또다른 호환성 높고 가장 일반적인 포맷이며 가장 출력하기 적합한 포맷이 PDF (어도브 아크로뱃이라고 하기도 함)이다. 이 포맷을 다운로드하고 출력 버튼을 누르기 전에, 이 매뉴얼이 거의 2000 페이지 가량된다는 것과 지속적으로 개정된다는 것을 명심해야 할것이다.

참고: PDF 포맷 파일을 볼수 있도록 하는 프로그램을 아직 설치하지 않았다면, Adobe Acrobat Reader을 다운로드해야 할것이다.

팜(Palm) 호환 핸드헬드 사용자라면, 팜 문서와 아이실로(iSilo) 포맷이 이 플랫폼에 가장 적합하다. 통근중에 이 핸드헬드를 갖고다니면서 DOC이나 iSilo 리더를 사용하여 PHP 지식을 연마할수 있다. 또는 퀵 레퍼런스로 이 포맷을 사용할수있다.

윈도우 플랫폼을 위해 이 매뉴얼을 윈도우 HTML 헬프 버전으로 제공된다. 이 버전은 윈도우 HTML 헬프 응용프로그램에서 사용하는 HTML 포맷으로 구성되며, 문서전체 검색과 전체 인덱스, 북마크도 제공한다. 많이 사용되는 윈도우의 PHP 개발 환경은 쉬운 접근을 위해 이 문서 형태도 함께 제공된다.

이전 | 처음으로 | 다음
해석기 토큰 목록 | 위로 | user notes에 관하여


user notes에 관하여

user-contributed notes는 이 매뉴얼 개발에 있어서 매우 중요한 역할을 담당하고 있다. 브라우저상에서 매뉴얼의 독자에게 예제코드, 경고, 좀더 자세한 설명을 제공해줌으로써, 매뉴얼의 주요 텍스트안에 피드백을 함께 추가시킬수 있다. 이런 notes가 통합되어 않으면, 온라인이나 일부 오프라인 포맷에서 제출폼이 보일것이다.

참고: user-contributed notes가 온라인상에 보여지기 전에 조정되지 않기때문에, 거기에 쓰여지는 내용이나 코드 예제의 질, 심지어 그 내용이 정확한지에 대한 어떤 보장도 할수 없다. (매뉴얼 내용 자체의 질이나 정확도에 대해 모두 보장한 다는 것은 아니다)

참고: 라이센스 보호의 목적을 위해 user-contributed notes는 PHP 매뉴얼의 부속물로 본다. 따라서 이 문서를 보호하는 라이센스와 똑같이 보호된다(GPL).자세한 정보는 Manual's Copyright 페이지를 참고한다.

이전 | 처음으로 | 다음
이 매뉴얼에 관하여 | 위로 | 함수 선언(prototype)을 읽는 방법


함수 선언(prototype)을 읽는 방법

각 함수는 퀵 레퍼런스를 위해 문서화되어있다. 매뉴얼을 읽고 이해하는 방법을 아는 것은 PHP 사용을 더욱 쉽게 해줄것이다. 예제코드나 cut/paster에 의지하기 보다는, 함수 선언(prototypes)을 읽는 방법을 알고 싶을 것이다. 시작하자:

필수 조건: 타입에 대한 기본적인 이해: PHP가 느슨한 타입 언어임에도 불구하고, 타입의 기본적인 이해는 중요하다. 왜냐하면 타입은 중요한 의미를 내포하기 때문이다.

함수 선언은 어떤 타입의 값이 returned되는지 알려준다. 첫번째 예제로써 strlen()에 대한 선언을 보도록하자:

strlen

(PHP 3, PHP 4 >= 4.0.0)
strlen -- Get string length

Description
int strlen ( string str )

Returns the length of string.

표 O-1. 함수 선언 해설

Part | Description
strlen | The function name.
(PHP 3, PHP 4 >= 4.0.0) | strlen()는 PHP 3와 PHP 4 모두 사용가능하다
int | 이함수가 리턴하는 값의 타입은 integer이다. (즉, 문자열의 길이가 숫자로 측정된다)
( string str ) | 함수 strlen()에 대한 첫번째 (이경우에는 하나이다) 패러미터/인자는 str이라는 이름을 갖고, string이다.

위 함수 선언을 일반적인 방법으로 다시 작성할수 있다:

returned type    function name    ( parameter type   parameter name )

in_array()와 같이, 많은 함수는 여러 패러미터를 갖는다. 프로토타입은 다음과 같다:

bool in_array ( mixed needle, array haystack [, bool strict])

이 선언은 무엇을 의미할까? in_array() boolean값을 리턴한다. 성공하면 TRUE (needle이 haystack에서 발견됨) 실패하면 FALSE (needle을 haystack에서 찾을수 없슴) 첫번째 패러미터는 needle이라는 이름을 갖고 있고 여러가지 다양한 타입이 될수 있다. 따라서 이런 타입을 "mixed"라고 부른다. mixed needle(찾는것)는 스칼라 값( string, integer, 또는 float)이나 array가 될수 있다. haystack (검색하는 배열)은 두번째 패러미터이다. 세번째 optional 패러미터는 strict라는 이름을 갖는다. 그외 추가적인 패러미터는 [ brackets ]안에 보여진다. 매뉴얼에서는 strict 패러미터가 기본값으로 boolean FALSE라고 되어있다. 각 함수의 어떻게 동작하는지에 대한 자세한 설명은 매뉴얼 패이지를 보도록 한다.

이전 | 처음으로 | 다음
user notes에 관하여 | 위로 | PHP 버전에 대해서 이 매뉴얼에 문서화되어있다


PHP 버전에 대해서 이 매뉴얼에 문서화되어있다

이 문서는 PHP 4에 관한 정보를 갖고 있다. PHP 3에서는 추가된 마이그레이션이나 호환성에 대한 주의사항도 갖는다. 동작, 패러미터, 리턴값과 다른 PHP 버전사이의 차이점이 notes와 매뉴얼은 인라인 텍스트에 문서화된다.

PHP의 CVS 버전에 대한 문서 부분을 찾을수 있을것이다. PHP의 CVS 버전은 CVS 버전 제어 시스템을 통해 받을수 있는 최종 개발 버전을 말한다. PHP 자체의 개발자가 아니고, PHP의 최종 버전을 사용하려하지 않는다면, "available in CVS"라고 표시되어있는 기능은 접근할수 없다. 이 기능들이 어쩌면 다음 안정 버전에서 사용가능할수도 있을것이다. CVS 버전을 내려받고자 한다면, anonymous CVS access page를 참고.

아직 릴리즈되지 않은 PHP 버전에 대한 문서 내용도 볼수 있다 (PHP 4.3.0이 최종 안정 버전이기 때문에 PHP 5.0.0같은 버전). 대부분, 이런 문서는 문서안의 에러가 아니다. 현재 PHP 릴리즈에 포함되지 않은 기능도 설명이 들어가있다. 그러나 PHP 차후버전에서 사용가능할것이다.

이전 | 처음으로 | 다음
함수 선언(prototype)을 읽는 방법 | 위로 | PHP에 관한 더 많은 정보를 찾는 방법


PHP에 관한 더 많은 정보를 찾는 방법

이 매뉴얼은 일반적인 프로그래밍 연습을 위한 명령을 제공하지 않는다. 이제 방금 시작한, 초심자 프로그래머라면, 이 매뉴얼만으로 PHP를 프로그램하는 방법을 배우기 어렵다는 것을 알게 될것이다. 좀더 초심자 지향적인 텍스트를 찾아야 할것이다. http://www.php.net/books.php에 PHP 관련 서적의 목록을 찾을수 있다.

PHP 프로그래밍을 위한 모든 부문의 많은 수의 토론용 메일링 리스트가 활성화되어 있다. 해결책을 찾을수 없는 문제에 빠져있다면, 이런 메일링 리스트에서 다른사람들의 도움을 받을수도 있을것이다. http://www.php.net/support.php에서 메일링 리스트의 목록을 볼수 있을 뿐만아니라, 메일링 리스트 아카이브(저장된 목록)와 다른 온라인 지원 리소스를 찾을수 있다. 그외에 http://www.php.net/links.php에서는 PHP 관련기사, 토론, 코드를 제공하는 웹사이트의 목록을 볼수 있다.

이전 | 처음으로 | 다음
PHP 버전에 대해서 이 매뉴얼에 문서화되어있다 | 위로 | 문서화 향상을 위해 도울수 있는 방법


문서화 향상을 위해 도울수 있는 방법

독자가 이 문서화를 향상시키는데 도움을 줄수 있는 방법은 세가지가 있다.

이 문서, 어떤 언어에서 잘못된 부분을 발견한다면, http://bugs.php.net/에 있는 버그 시스템을 이용하여 그 부분을 보고하면 된다. 매뉴얼 포맷에 관련된 문제점도 보고될 수 있다.

참고: 도움 요청을 전송함으로써 버그 시스템을 남용하지 말도록 한다. 대신, 메일링 리스트나 이전에 언급한 커뮤니티 사이트를 사용하자.

기고 노트(contributing notes)를 통해서 추가적인 예제코드, 경고와 다른 독자를 위한 설명을 제공할수 있다. 그러나 제발 주석 시스템을 사용하여 버그 보고를 전송하지 않도록 한다. 이 부록의 'About user notes' 섹션에서 이 주석에 관해 더 많은 내용을 볼수 있다.

영어와 그외의 외국어를 사용한다면, 번역에 관한 도움을 받을수 있다. 새로운 번역을 시작하려면, 또는 번역 포로젝트에 대한 도움을 받고자 한다면 http://cvs.php.net/co.php/phpdoc/howto/howto.html.tar.gz을 읽도록 한다.

이전 | 처음으로 | 다음
PHP에 관한 더 많은 정보를 찾는 방법 | 위로 | 포맷을 어떤 방법으로 만들었는가


포맷을 어떤 방법으로 만들었는가

이 매뉴얼은 DocBook XML DTD, 포맷을 위한 DSSSL (문서 스타일과 구문 사양 언어)을 사용하고, 유지관리와 형식화를 위해 실험적으로 XSLT(확장 스타일시트 언어 변환) 를 사용하는 XML로 작성된다.

원본 포맷을 XML로 사용하면 원본 파일로부터 많은 출력 포맷을 생성할수 있고, 모든 포맷에 대해 하나의 원본 문서만을 유지관리할수 있다. HTML과 TeX버전을 포맷팅하기 위한 툴은 James Clark가 작성한 Jade와 Norman Walsh가 작성한 The Modular DocBook Stylesheets를 사용한다. 매뉴얼의 윈도우 HTML 도움말 포맷을 생성하기 위해 Microsoft HTML Help Workshop을 사용하며, 물론 PHP 자체에서도 몇가지 추가적인 변환과 포맷기능이 존재한다.

다양한 언어와 일반텍스트, 일반 HTML, PDF, PalmPilot DOC, PalmPilot iSilo와 윈도우 HTML 도움말 같은 다양한 포맷으로 되어있는 매뉴얼을 http://www.php.net/docs.php에서 내려받을수 있다. 매뉴얼은 그 내용이 업데이트되면 자동적으로 업데이트된다.

http://cvs.php.net/에서 이 문서의 XML 원본 코드를 다운받는 방법에 대한 더 많은 정보를 찾을수 있다. 매뉴얼은 phpdoc 모듈안에 저장된다.

이전 | 처음으로 | 다음
문서화 향상을 위해 도울수 있는 방법 | 위로 | 번역


번역

PHP 매뉴얼은 다양한 포맷 뿐만 아니라, 다양한 언어로도 제공된다. 매뉴얼의 내용은 처음에 영어로 작성되었고, 전세계 팀원들이 그들 지역 언어로 번역을 하고 있다. 특정 함수나 챕터에 대한 번역이 아직 되어있지않다면, 매뉴얼의 빌드 시스템은 그부분의 영어 버전으로 연결한다.

번역하는 사람은 http://cvs.php.net/에 있는 XML 소스 코드에서 시작하여 그들의 모국어로 번역한다. 이 시스템은 HTML, 일반 텍스트나 PDF버전을 사용하지 않는다. 이 빌드 시스템이 XML에서 읽기 쉬운 포맷으로의 변환을 담당한다.

참고: 독자의 지역 언어로 문서를 번역하는데 도움을 주고자 한다면, phpdoc 메일링리스트를 구독하는 번역/문서 팀과 연락을 하도록 한다: phpdoc-subscribe@lists.php.net에 아무 내용없는 메일을 보낸다. 메일링 리스트의 주소는 phpdoc@lists.php.net이다. 다른 언어로 매뉴얼을 번역하는데 관심이 있다는 메시지를 넣는다면 누군가가 당신에게 답장을 보낼것이고, 새로운 언어 번역을 시작하고 거주지역 언어의 기존 문서팀에 접근하는데 도움을 줄것이다.

현재는 다음 언어로 부분적이든 아니든 매뉴얼을 제공중에 있다: Brazilian Portuguese, Chinese (Simplified), Chinese (Traditional), Czech, Dutch, Finnish, French, German, Hebrew, Hungarian, Italian, Japanese, Korean, Polish, Romanian, Russian, Slovak, Slovenian, Spanish, Swedish, and Turkish.

그들 모두 여기서 내려받을수 있다: http://www.php.net/docs.php.

이전 | 처음으로 | 다음
포맷을 어떤 방법으로 만들었는가 | 위로 | Open Publication License


Open Publication License

PHP 매뉴얼
이전 다음

P. 부록. Open Publication License

차례
I. REQUIREMENTS ON BOTH UNMODIFIED AND MODIFIED VERSIONS
II. COPYRIGHT
III. SCOPE OF LICENSE
IV. REQUIREMENTS ON MODIFIED WORKS
V. GOOD-PRACTICE RECOMMENDATIONS
VI. LICENSE OPTIONS

v1.0, 8 June 1999

I. REQUIREMENTS ON BOTH UNMODIFIED AND MODIFIED VERSIONS

The Open Publication works may be reproduced and distributed in whole or in part, in any medium physical or electronic, provided that the terms of this license are adhered to, and that this license or an incorporation of it by reference (with any options elected by the author(s) and/or publisher) is displayed in the reproduction.

Proper form for an incorporation by reference is as follows:

Copyright (c) <year> by <author's name or designee>. This material may be distributed only subject to the terms and conditions set forth in the Open Publication License, vX.Y or later (the latest version is presently available at http://www.opencontent.org/openpub/

The reference must be immediately followed with any options elected by the author(s) and/or publisher of the document (see section VI). Commercial redistribution of Open Publication-licensed material is permitted. Any publication in standard (paper) book form shall require the citation of the original publisher and author. The publisher and author's names shall appear on all outer surfaces of the book. On all outer surfaces of the book the original publisher's name shall be as large as the title of the work and cited as possessive with respect to the title.

이전 | 처음으로 | 다음
번역 | 위로 | II. COPYRIGHT


II. COPYRIGHT

The copyright to each Open Publication is owned by its author(s) or designee.

이전 | 처음으로 | 다음
Open Publication License | 위로 | III. SCOPE OF LICENSE


III. SCOPE OF LICENSE

The following license terms apply to all Open Publication works, unless otherwise explicitly stated in the document.

Mere aggregation of Open Publication works or a portion of an Open Publication work with other works or programs on the same media shall not cause this license to apply to those other works. The aggregate work shall contain a notice specifying the inclusion of the Open Publication material and appropriate copyright notice.

SEVERABILITY. If any part of this license is found to be unenforceable in any jurisdiction, the remaining portions of the license remain in force.

NO WARRANTY. Open Publication works are licensed and provided "as is" without warranty of any kind, express or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose or a warranty of non-infringement.

이전 | 처음으로 | 다음
II. COPYRIGHT | 위로 | IV. REQUIREMENTS ON MODIFIED WORKS


IV. REQUIREMENTS ON MODIFIED WORKS

All modified versions of documents covered by this license, including translations, anthologies, compilations and partial documents, must meet the following requirements:

  1. The modified version must be labeled as such.

  2. The person making the modifications must be identified and the modifications dated.

  3. Acknowledgement of the original author and publisher if applicable must be retained according to normal academic citation practices.

  4. The location of the original unmodified document must be identified.

  5. The original author's (or authors') name(s) may not be used to assert or imply endorsement of the resulting document without the original author's (or authors') permission.

이전 | 처음으로 | 다음
III. SCOPE OF LICENSE | 위로 | V. GOOD-PRACTICE RECOMMENDATIONS


V. GOOD-PRACTICE RECOMMENDATIONS

In addition to the requirements of this license, it is requested from and strongly recommended of redistributors that:

  1. If you are distributing Open Publication works on hardcopy or CD-ROM, you provide email notification to the authors of your intent to redistribute at least thirty days before your manuscript or media freeze, to give the authors time to provide updated documents. This notification should describe modifications, if any, made to the document.

  2. All substantive modifications (including deletions) be either clearly marked up in the document or else described in an attachment to the document.

  3. Finally, while it is not mandatory under this license, it is considered good form to offer a free copy of any hardcopy and CD-ROM expression of an Open Publication-licensed work to its author(s).

이전 | 처음으로 | 다음
IV. REQUIREMENTS ON MODIFIED WORKS | 위로 | VI. LICENSE OPTIONS


VI. LICENSE OPTIONS

The author(s) and/or publisher of an Open Publication-licensed document may elect certain options by appending language to the reference to or copy of the license. These options are considered part of the license instance and must be included with the license (or its incorporation by reference) in derived works.

A. To prohibit distribution of substantively modified versions without the explicit permission of the author(s). "Substantive modification" is defined as a change to the semantic content of the document, and excludes mere changes in format or typographical corrections.

To accomplish this, add the phrase `Distribution of substantively modified versions of this document is prohibited without the explicit permission of the copyright holder.' to the license reference or copy.

B. To prohibit any publication of this work or derivative works in whole or in part in standard (paper) book form for commercial purposes is prohibited unless prior permission is obtained from the copyright holder.

To accomplish this, add the phrase 'Distribution of the work or derivative of the work in any standard (paper) book form is prohibited unless prior permission is obtained from the copyright holder.' to the license reference or copy.

이전 | 처음으로 | 다음
V. GOOD-PRACTICE RECOMMENDATIONS | 위로 | 함수 인덱스


함수 인덱스

PHP 매뉴얼
이전 다음

Q. 부록. 함수 인덱스

차례
함수 인덱스

이전 | 처음으로 | 다음
VI. LICENSE OPTIONS | 위로 | 함수 인덱스


함수 인덱스

A

abs()
acos()
acosh()
addcslashes()
addslashes()
aggregate()
aggregate_info()
aggregate_methods()
aggregate_methods_by_list()
aggregate_methods_by_regexp()
aggregate_properties()
aggregate_properties_by_list()
aggregate_properties_by_regexp()
aggregation_info()
apache_child_terminate()
apache_get_modules()
apache_get_version()
apache_getenv()
apache_lookup_uri()
apache_note()
apache_request_headers()
apache_response_headers()
apache_setenv()
array()
array_change_key_case()
array_chunk()
array_combine()
array_count_values()
array_diff()
array_diff_assoc()
array_diff_uassoc()
array_fill()
array_filter()
array_flip()
array_intersect()
array_intersect_assoc()
array_key_exists()
array_keys()
array_map()
array_merge()
array_merge_recursive()
array_multisort()
array_pad()
array_pop()
array_push()
array_rand()
array_reduce()
array_reverse()
array_search()
array_shift()
array_slice()
array_splice()
array_sum()
array_udiff()
array_udiff_assoc()
array_udiff_uassoc()
array_unique()
array_unshift()
array_values()
array_walk()
arsort()
ascii2ebcdic()
asin()
asinh()
asort()
aspell_check()
aspell_check_raw()
aspell_new()
aspell_suggest()
assert()
assert_options()
atan()
atan2()
atanh()

B

base64_decode()
base64_encode()
base_convert()
basename()
bcadd()
bccomp()
bcdiv()
bcmod()
bcmul()
bcpow()
bcpowmod()
bcscale()
bcsqrt()
bcsub()
bin2hex()
bind_textdomain_codeset()
bindec()
bindtextdomain()
bzclose()
bzcompress()
bzdecompress()
bzerrno()
bzerror()
bzerrstr()
bzflush()
bzopen()
bzread()
bzwrite()

C

cal_days_in_month()
cal_from_jd()
cal_info()
cal_to_jd()
call_user_func()
call_user_func_array()
call_user_method()
call_user_method_array()
ccvs_add()
ccvs_auth()
ccvs_command()
ccvs_count()
ccvs_delete()
ccvs_done()
ccvs_init()
ccvs_lookup()
ccvs_new()
ccvs_report()
ccvs_return()
ccvs_reverse()
ccvs_sale()
ccvs_status()
ccvs_textvalue()
ccvs_void()
ceil()
chdir()
checkdate()
checkdnsrr()
chgrp()
chmod()
chop()
chown()
chr()
chroot()
chunk_split()
class_exists()
clearstatcache()
closedir()
closelog()
com()
com_addref()
com_get()
com_invoke()
com_isenum()
com_load()
com_load_typelib()
com_propget()
com_propput()
com_propset()
com_release()
com_set()
compact()
connection_aborted()
connection_status()
connection_timeout()
constant()
convert_cyr_string()
copy()
cos()
cosh()
count()
count_chars()
cpdf_add_annotation()
cpdf_add_outline()
cpdf_arc()
cpdf_begin_text()
cpdf_circle()
cpdf_clip()
cpdf_close()
cpdf_closepath()
cpdf_closepath_fill_stroke()
cpdf_closepath_stroke()
cpdf_continue_text()
cpdf_curveto()
cpdf_end_text()
cpdf_fill()
cpdf_fill_stroke()
cpdf_finalize()
cpdf_finalize_page()
cpdf_global_set_document_limits()
cpdf_import_jpeg()
cpdf_lineto()
cpdf_moveto()
cpdf_newpath()
cpdf_open()
cpdf_output_buffer()
cpdf_page_init()
cpdf_place_inline_image()
cpdf_rect()
cpdf_restore()
cpdf_rlineto()
cpdf_rmoveto()
cpdf_rotate()
cpdf_rotate_text()
cpdf_save()
cpdf_save_to_file()
cpdf_scale()
cpdf_set_action_url()
cpdf_set_char_spacing()
cpdf_set_creator()
cpdf_set_current_page()
cpdf_set_font()
cpdf_set_font_directories()
cpdf_set_font_map_file()
cpdf_set_horiz_scaling()
cpdf_set_keywords()
cpdf_set_leading()
cpdf_set_page_animation()
cpdf_set_subject()
cpdf_set_text_matrix()
cpdf_set_text_pos()
cpdf_set_text_rendering()
cpdf_set_text_rise()
cpdf_set_title()
cpdf_set_viewer_preferences()
cpdf_set_word_spacing()
cpdf_setdash()
cpdf_setflat()
cpdf_setgray()
cpdf_setgray_fill()
cpdf_setgray_stroke()
cpdf_setlinecap()
cpdf_setlinejoin()
cpdf_setlinewidth()
cpdf_setmiterlimit()
cpdf_setrgbcolor()
cpdf_setrgbcolor_fill()
cpdf_setrgbcolor_stroke()
cpdf_show()
cpdf_show_xy()
cpdf_stringwidth()
cpdf_stroke()
cpdf_text()
cpdf_translate()
crack_check()
crack_closedict()
crack_getlastmessage()
crack_opendict()
crc32()
create_function()
crypt()
ctype_alnum()
ctype_alpha()
ctype_cntrl()
ctype_digit()
ctype_graph()
ctype_lower()
ctype_print()
ctype_punct()
ctype_space()
ctype_upper()
ctype_xdigit()
curl_close()
curl_errno()
curl_error()
curl_exec()
curl_getinfo()
curl_init()
curl_multi_add_handle()
curl_multi_close()
curl_multi_exec()
curl_multi_getcontent()
curl_multi_info_read()
curl_multi_init()
curl_multi_remove_handle()
curl_multi_select()
curl_setopt()
curl_version()
current()
cybercash_base64_decode()
cybercash_base64_encode()
cybercash_decr()
cybercash_encr()
cyrus_authenticate()
cyrus_bind()
cyrus_close()
cyrus_connect()
cyrus_query()
cyrus_unbind()

D

date()
dba_close()
dba_delete()
dba_exists()
dba_fetch()
dba_firstkey()
dba_handlers()
dba_insert()
dba_key_split()
dba_list()
dba_nextkey()
dba_open()
dba_optimize()
dba_popen()
dba_replace()
dba_sync()
dbase_add_record()
dbase_close()
dbase_create()
dbase_delete_record()
dbase_get_header_info()
dbase_get_record()
dbase_get_record_with_names()
dbase_numfields()
dbase_numrecords()
dbase_open()
dbase_pack()
dbase_replace_record()
dblist()
dbmclose()
dbmdelete()
dbmexists()
dbmfetch()
dbmfirstkey()
dbminsert()
dbmnextkey()
dbmopen()
dbmreplace()
dbplus_add()
dbplus_aql()
dbplus_chdir()
dbplus_close()
dbplus_curr()
dbplus_errcode()
dbplus_errno()
dbplus_find()
dbplus_first()
dbplus_flush()
dbplus_freealllocks()
dbplus_freelock()
dbplus_freerlocks()
dbplus_getlock()
dbplus_getunique()
dbplus_info()
dbplus_last()
dbplus_lockrel()
dbplus_next()
dbplus_open()
dbplus_prev()
dbplus_rchperm()
dbplus_rcreate()
dbplus_rcrtexact()
dbplus_rcrtlike()
dbplus_resolve()
dbplus_restorepos()
dbplus_rkeys()
dbplus_ropen()
dbplus_rquery()
dbplus_rrename()
dbplus_rsecindex()
dbplus_runlink()
dbplus_rzap()
dbplus_savepos()
dbplus_setindex()
dbplus_setindexbynumber()
dbplus_sql()
dbplus_tcl()
dbplus_tremove()
dbplus_undo()
dbplus_undoprepare()
dbplus_unlockrel()
dbplus_unselect()
dbplus_update()
dbplus_xlockrel()
dbplus_xunlockrel()
dbx_close()
dbx_compare()
dbx_connect()
dbx_error()
dbx_escape_string()
dbx_fetch_row()
dbx_query()
dbx_sort()
dcgettext()
dcngettext()
deaggregate()
debug_backtrace()
debug_print_backtrace()
debugger_off()
debugger_on()
decbin()
dechex()
decoct()
define()
define_syslog_variables()
defined()
deg2rad()
delete()
dgettext()
die()
dio_close()
dio_fcntl()
dio_open()
dio_read()
dio_seek()
dio_stat()
dio_tcsetattr()
dio_truncate()
dio_write()
dir()
dirname()
disk_free_space()
disk_total_space()
diskfreespace()
dl()
dngettext()
dns_check_record()
dns_get_mx()
dns_get_record()
domattribute->name()
domattribute->specified()
domattribute->value()
domdocument->add_root [deprecated]()
domdocument->create_attribute()
domdocument->create_cdata_section()
domdocument->create_comment()
domdocument->create_element()
domdocument->create_element_ns()
domdocument->create_entity_reference()
domdocument->create_processing_instruction()
domdocument->create_text_node()
domdocument->doctype()
domdocument->document_element()
domdocument->dump_file()
domdocument->dump_mem()
domdocument->get_element_by_id()
domdocument->get_elements_by_tagname()
domdocument->html_dump_mem()
domdocument->xinclude()
domdocumenttype->entities()
domdocumenttype->internal_subset()
domdocumenttype->name()
domdocumenttype->notations()
domdocumenttype->public_id()
domdocumenttype->system_id()
domelement->get_attribute()
domelement->get_attribute_node()
domelement->get_elements_by_tagname()
domelement->has_attribute()
domelement->remove_attribute()
domelement->set_attribute()
domelement->tagname()
domnode->add_namespace()
domnode->append_child()
domnode->append_sibling()
domnode->attributes()
domnode->child_nodes()
domnode->clone_node()
domnode->dump_node()
domnode->first_child()
domnode->get_content()
domnode->has_attributes()
domnode->has_child_nodes()
domnode->insert_before()
domnode->is_blank_node()
domnode->last_child()
domnode->next_sibling()
domnode->node_name()
domnode->node_type()
domnode->node_value()
domnode->owner_document()
domnode->parent_node()
domnode->prefix()
domnode->previous_sibling()
domnode->remove_child()
domnode->replace_child()
domnode->replace_node()
domnode->set_content()
domnode->set_name()
domnode->set_namespace()
domnode->unlink_node()
domprocessinginstruction->data()
domprocessinginstruction->target()
domxml_new_doc()
domxml_open_file()
domxml_open_mem()
domxml_version()
domxml_xmltree()
domxml_xslt_stylesheet()
domxml_xslt_stylesheet_doc()
domxml_xslt_stylesheet_file()
domxsltstylesheet->process()
domxsltstylesheet->result_dump_file()
domxsltstylesheet->result_dump_mem()
dotnet_load()
doubleval()

E

each()
easter_date()
easter_days()
ebcdic2ascii()
echo()
empty()
end()
ereg()
ereg_replace()
eregi()
eregi_replace()
error_log()
error_reporting()
escapeshellarg()
escapeshellcmd()
eval()
exec()
exif_imagetype()
exif_read_data()
exif_thumbnail()
exit()
exp()
explode()
expm1()
extension_loaded()
extract()
ezmlm_hash()

F

fam_cancel_monitor()
fam_close()
fam_monitor_collection()
fam_monitor_directory()
fam_monitor_file()
fam_next_event()
fam_open()
fam_pending()
fam_resume_monitor()
fam_suspend_monitor()
fbsql_affected_rows()
fbsql_autocommit()
fbsql_change_user()
fbsql_close()
fbsql_commit()
fbsql_connect()
fbsql_create_blob()
fbsql_create_clob()
fbsql_create_db()
fbsql_data_seek()
fbsql_database()
fbsql_database_password()
fbsql_db_query()
fbsql_db_status()
fbsql_drop_db()
fbsql_errno()
fbsql_error()
fbsql_fetch_array()
fbsql_fetch_assoc()
fbsql_fetch_field()
fbsql_fetch_lengths()
fbsql_fetch_object()
fbsql_fetch_row()
fbsql_field_flags()
fbsql_field_len()
fbsql_field_name()
fbsql_field_seek()
fbsql_field_table()
fbsql_field_type()
fbsql_free_result()
fbsql_get_autostart_info()
fbsql_hostname()
fbsql_insert_id()
fbsql_list_dbs()
fbsql_list_fields()
fbsql_list_tables()
fbsql_next_result()
fbsql_num_fields()
fbsql_num_rows()
fbsql_password()
fbsql_pconnect()
fbsql_query()
fbsql_read_blob()
fbsql_read_clob()
fbsql_result()
fbsql_rollback()
fbsql_select_db()
fbsql_set_lob_mode()
fbsql_set_transaction()
fbsql_start_db()
fbsql_stop_db()
fbsql_tablename()
fbsql_username()
fbsql_warnings()
fclose()
fdf_add_doc_javascript()
fdf_add_template()
fdf_close()
fdf_create()
fdf_enum_values()
fdf_errno()
fdf_error()
fdf_get_ap()
fdf_get_attachment()
fdf_get_encoding()
fdf_get_file()
fdf_get_flags()
fdf_get_opt()
fdf_get_status()
fdf_get_value()
fdf_get_version()
fdf_header()
fdf_next_field_name()
fdf_open()
fdf_open_string()
fdf_remove_item()
fdf_save()
fdf_save_string()
fdf_set_ap()
fdf_set_encoding()
fdf_set_file()
fdf_set_flags()
fdf_set_javascript_action()
fdf_set_opt()
fdf_set_status()
fdf_set_submit_form_action()
fdf_set_target_frame()
fdf_set_value()
fdf_set_version()
feof()
fflush()
fgetc()
fgetcsv()
fgets()
fgetss()
file()
file_exists()
file_get_contents()
file_put_contents()
fileatime()
filectime()
filegroup()
fileinode()
filemtime()
fileowner()
fileperms()
filepro()
filepro_fieldcount()
filepro_fieldname()
filepro_fieldtype()
filepro_fieldwidth()
filepro_retrieve()
filepro_rowcount()
filesize()
filetype()
floatval()
flock()
floor()
flush()
fmod()
fnmatch()
fopen()
fpassthru()
fprintf()
fputs()
fread()
frenchtojd()
fribidi_log2vis()
fscanf()
fseek()
fsockopen()
fstat()
ftell()
ftok()
ftp_alloc()
ftp_cdup()
ftp_chdir()
ftp_chmod()
ftp_close()
ftp_connect()
ftp_delete()
ftp_exec()
ftp_fget()
ftp_fput()
ftp_get()
ftp_get_option()
ftp_login()
ftp_mdtm()
ftp_mkdir()
ftp_nb_continue()
ftp_nb_fget()
ftp_nb_fput()
ftp_nb_get()
ftp_nb_put()
ftp_nlist()
ftp_pasv()
ftp_put()
ftp_pwd()
ftp_quit()
ftp_raw()
ftp_rawlist()
ftp_rename()
ftp_rmdir()
ftp_set_option()
ftp_site()
ftp_size()
ftp_ssl_connect()
ftp_systype()
ftruncate()
func_get_arg()
func_get_args()
func_num_args()
function_exists()
fwrite()

G

gd_info()
get_browser()
get_cfg_var()
get_class()
get_class_methods()
get_class_vars()
get_current_user()
get_declared_classes()
get_defined_constants()
get_defined_functions()
get_defined_vars()
get_extension_funcs()
get_html_translation_table()
get_include_path()
get_included_files()
get_loaded_extensions()
get_magic_quotes_gpc()
get_magic_quotes_runtime()
get_meta_tags()
get_object_vars()
get_parent_class()
get_required_files()
get_resource_type()
getallheaders()
getcwd()
getdate()
getenv()
gethostbyaddr()
gethostbyname()
gethostbynamel()
getimagesize()
getlastmod()
getmxrr()
getmygid()
getmyinode()
getmypid()
getmyuid()
getopt()
getprotobyname()
getprotobynumber()
getrandmax()
getrusage()
getservbyname()
getservbyport()
gettext()
gettimeofday()
gettype()
glob()
gmdate()
gmmktime()
gmp_abs()
gmp_add()
gmp_and()
gmp_clrbit()
gmp_cmp()
gmp_com()
gmp_div()
gmp_div_q()
gmp_div_qr()
gmp_div_r()
gmp_divexact()
gmp_fact()
gmp_gcd()
gmp_gcdext()
gmp_hamdist()
gmp_init()
gmp_intval()
gmp_invert()
gmp_jacobi()
gmp_legendre()
gmp_mod()
gmp_mul()
gmp_neg()
gmp_or()
gmp_perfect_square()
gmp_popcount()
gmp_pow()
gmp_powm()
gmp_prob_prime()
gmp_random()
gmp_scan0()
gmp_scan1()
gmp_setbit()
gmp_sign()
gmp_sqrt()
gmp_sqrtrem()
gmp_sqrtrm()
gmp_strval()
gmp_sub()
gmp_xor()
gmstrftime()
gregoriantojd()
gzclose()
gzcompress()
gzdeflate()
gzencode()
gzeof()
gzfile()
gzgetc()
gzgets()
gzgetss()
gzinflate()
gzopen()
gzpassthru()
gzputs()
gzread()
gzrewind()
gzseek()
gztell()
gzuncompress()
gzwrite()

H

header()
headers_list()
headers_sent()
hebrev()
hebrevc()
hexdec()
highlight_file()
highlight_string()
html_entity_decode()
htmlentities()
htmlspecialchars()
http_build_query()
hw_api->checkin()
hw_api->checkout()
hw_api->children()
hw_api->content()
hw_api->copy()
hw_api->dbstat()
hw_api->dcstat()
hw_api->dstanchors()
hw_api->dstofsrcanchors()
hw_api->find()
hw_api->ftstat()
hw_api->hwstat()
hw_api->identify()
hw_api->info()
hw_api->insert()
hw_api->insertanchor()
hw_api->insertcollection()
hw_api->insertdocument()
hw_api->link()
hw_api->lock()
hw_api->move()
hw_api->object()
hw_api->objectbyanchor()
hw_api->parents()
hw_api->remove()
hw_api->replace()
hw_api->setcommitedversion()
hw_api->srcanchors()
hw_api->srcsofdst()
hw_api->unlock()
hw_api->user()
hw_api->userlist()
hw_api_attribute()
hw_api_attribute->key()
hw_api_attribute->langdepvalue()
hw_api_attribute->value()
hw_api_attribute->values()
hw_api_content()
hw_api_content->mimetype()
hw_api_content->read()
hw_api_error->count()
hw_api_error->reason()
hw_api_object()
hw_api_object->assign()
hw_api_object->attreditable()
hw_api_object->count()
hw_api_object->insert()
hw_api_object->remove()
hw_api_object->title()
hw_api_object->value()
hw_api_reason->description()
hw_api_reason->type()
hw_array2objrec()
hw_changeobject()
hw_children()
hw_childrenobj()
hw_close()
hw_connect()
hw_connection_info()
hw_cp()
hw_deleteobject()
hw_docbyanchor()
hw_docbyanchorobj()
hw_document_attributes()
hw_document_bodytag()
hw_document_content()
hw_document_setcontent()
hw_document_size()
hw_dummy()
hw_edittext()
hw_error()
hw_errormsg()
hw_free_document()
hw_getanchors()
hw_getanchorsobj()
hw_getandlock()
hw_getchildcoll()
hw_getchildcollobj()
hw_getchilddoccoll()
hw_getchilddoccollobj()
hw_getobject()
hw_getobjectbyquery()
hw_getobjectbyquerycoll()
hw_getobjectbyquerycollobj()
hw_getobjectbyqueryobj()
hw_getparents()
hw_getparentsobj()
hw_getrellink()
hw_getremote()
hw_getremotechildren()
hw_getsrcbydestobj()
hw_gettext()
hw_getusername()
hw_identify()
hw_incollections()
hw_info()
hw_inscoll()
hw_insdoc()
hw_insertanchors()
hw_insertdocument()
hw_insertobject()
hw_mapid()
hw_modifyobject()
hw_mv()
hw_new_document()
hw_objrec2array()
hw_output_document()
hw_pconnect()
hw_pipedocument()
hw_root()
hw_setlinkroot()
hw_stat()
hw_unlock()
hw_who()
hwapi_hgcsp()
hypot()

I

ibase_add_user()
ibase_affected_rows()
ibase_blob_add()
ibase_blob_cancel()
ibase_blob_close()
ibase_blob_create()
ibase_blob_echo()
ibase_blob_get()
ibase_blob_import()
ibase_blob_info()
ibase_blob_open()
ibase_close()
ibase_commit()
ibase_commit_ret()
ibase_connect()
ibase_delete_user()
ibase_drop_db()
ibase_errcode()
ibase_errmsg()
ibase_execute()
ibase_fetch_assoc()
ibase_fetch_object()
ibase_fetch_row()
ibase_field_info()
ibase_free_event_handler()
ibase_free_query()
ibase_free_result()
ibase_gen_id()
ibase_modify_user()
ibase_name_result()
ibase_num_fields()
ibase_num_params()
ibase_param_info()
ibase_pconnect()
ibase_prepare()
ibase_query()
ibase_rollback()
ibase_rollback_ret()
ibase_set_event_handler()
ibase_timefmt()
ibase_trans()
ibase_wait_event()
iconv()
iconv_get_encoding()
iconv_mime_decode()
iconv_mime_decode_headers()
iconv_mime_encode()
iconv_set_encoding()
iconv_strlen()
iconv_strpos()
iconv_strrpos()
iconv_substr()
ifx_affected_rows()
ifx_blobinfile_mode()
ifx_byteasvarchar()
ifx_close()
ifx_connect()
ifx_copy_blob()
ifx_create_blob()
ifx_create_char()
ifx_do()
ifx_error()
ifx_errormsg()
ifx_fetch_row()
ifx_fieldproperties()
ifx_fieldtypes()
ifx_free_blob()
ifx_free_char()
ifx_free_result()
ifx_get_blob()
ifx_get_char()
ifx_getsqlca()
ifx_htmltbl_result()
ifx_nullformat()
ifx_num_fields()
ifx_num_rows()
ifx_pconnect()
ifx_prepare()
ifx_query()
ifx_textasvarchar()
ifx_update_blob()
ifx_update_char()
ifxus_close_slob()
ifxus_create_slob()
ifxus_free_slob()
ifxus_open_slob()
ifxus_read_slob()
ifxus_seek_slob()
ifxus_tell_slob()
ifxus_write_slob()
ignore_user_abort()
image2wbmp()
image_type_to_mime_type()
imagealphablending()
imageantialias()
imagearc()
imagechar()
imagecharup()
imagecolorallocate()
imagecolorallocatealpha()
imagecolorat()
imagecolorclosest()
imagecolorclosestalpha()
imagecolorclosesthwb()
imagecolordeallocate()
imagecolorexact()
imagecolorexactalpha()
imagecolormatch()
imagecolorresolve()
imagecolorresolvealpha()
imagecolorset()
imagecolorsforindex()
imagecolorstotal()
imagecolortransparent()
imagecopy()
imagecopymerge()
imagecopymergegray()
imagecopyresampled()
imagecopyresized()
imagecreate()
imagecreatefromgd()
imagecreatefromgd2()
imagecreatefromgd2part()
imagecreatefromgif()
imagecreatefromjpeg()
imagecreatefrompng()
imagecreatefromstring()
imagecreatefromwbmp()
imagecreatefromxbm()
imagecreatefromxpm()
imagecreatetruecolor()
imagedashedline()
imagedestroy()
imageellipse()
imagefill()
imagefilledarc()
imagefilledellipse()
imagefilledpolygon()
imagefilledrectangle()
imagefilltoborder()
imagefontheight()
imagefontwidth()
imageftbbox()
imagefttext()
imagegammacorrect()
imagegd()
imagegd2()
imagegif()
imageinterlace()
imageistruecolor()
imagejpeg()
imageline()
imageloadfont()
imagepalettecopy()
imagepng()
imagepolygon()
imagepsbbox()
imagepscopyfont()
imagepsencodefont()
imagepsextendfont()
imagepsfreefont()
imagepsloadfont()
imagepsslantfont()
imagepstext()
imagerectangle()
imagerotate()
imagesavealpha()
imagesetbrush()
imagesetpixel()
imagesetstyle()
imagesetthickness()
imagesettile()
imagestring()
imagestringup()
imagesx()
imagesy()
imagetruecolortopalette()
imagettfbbox()
imagettftext()
imagetypes()
imagewbmp()
imap_8bit()
imap_alerts()
imap_append()
imap_base64()
imap_binary()
imap_body()
imap_bodystruct()
imap_check()
imap_clearflag_full()
imap_close()
imap_createmailbox()
imap_delete()
imap_deletemailbox()
imap_errors()
imap_expunge()
imap_fetch_overview()
imap_fetchbody()
imap_fetchheader()
imap_fetchstructure()
imap_get_quota()
imap_get_quotaroot()
imap_getacl()
imap_getmailboxes()
imap_getsubscribed()
imap_header()
imap_headerinfo()
imap_headers()
imap_last_error()
imap_list()
imap_listmailbox()
imap_listscan()
imap_listsubscribed()
imap_lsub()
imap_mail()
imap_mail_compose()
imap_mail_copy()
imap_mail_move()
imap_mailboxmsginfo()
imap_mime_header_decode()
imap_msgno()
imap_num_msg()
imap_num_recent()
imap_open()
imap_ping()
imap_qprint()
imap_renamemailbox()
imap_reopen()
imap_rfc822_parse_adrlist()
imap_rfc822_parse_headers()
imap_rfc822_write_address()
imap_scanmailbox()
imap_search()
imap_set_quota()
imap_setacl()
imap_setflag_full()
imap_sort()
imap_status()
imap_subscribe()
imap_thread()
imap_timeout()
imap_uid()
imap_undelete()
imap_unsubscribe()
imap_utf7_decode()
imap_utf7_encode()
imap_utf8()
implode()
import_request_variables()
in_array()
ingres_autocommit()
ingres_close()
ingres_commit()
ingres_connect()
ingres_fetch_array()
ingres_fetch_object()
ingres_fetch_row()
ingres_field_length()
ingres_field_name()
ingres_field_nullable()
ingres_field_precision()
ingres_field_scale()
ingres_field_type()
ingres_num_fields()
ingres_num_rows()
ingres_pconnect()
ingres_query()
ingres_rollback()
ini_alter()
ini_get()
ini_get_all()
ini_restore()
ini_set()
intval()
ip2long()
iptcembed()
iptcparse()
ircg_channel_mode()
ircg_disconnect()
ircg_fetch_error_msg()
ircg_get_username()
ircg_html_encode()
ircg_ignore_add()
ircg_ignore_del()
ircg_is_conn_alive()
ircg_join()
ircg_kick()
ircg_lookup_format_messages()
ircg_msg()
ircg_nick()
ircg_nickname_escape()
ircg_nickname_unescape()
ircg_notice()
ircg_part()
ircg_pconnect()
ircg_register_format_messages()
ircg_set_current()
ircg_set_file()
ircg_set_on_die()
ircg_topic()
ircg_whois()
is_a()
is_array()
is_bool()
is_callable()
is_dir()
is_double()
is_executable()
is_file()
is_finite()
is_float()
is_infinite()
is_int()
is_integer()
is_link()
is_long()
is_nan()
is_null()
is_numeric()
is_object()
is_readable()
is_real()
is_resource()
is_scalar()
is_string()
is_subclass_of()
is_uploaded_file()
is_writable()
is_writeable()
isset()

J

java_last_exception_clear()
java_last_exception_get()
jddayofweek()
jdmonthname()
jdtofrench()
jdtogregorian()
jdtojewish()
jdtojulian()
jdtounix()
jewishtojd()
join()
jpeg2wbmp()
juliantojd()

K

key()
krsort()
ksort()

L

lcg_value()
ldap_8859_to_t61()
ldap_add()
ldap_bind()
ldap_close()
ldap_compare()
ldap_connect()
ldap_count_entries()
ldap_delete()
ldap_dn2ufn()
ldap_err2str()
ldap_errno()
ldap_error()
ldap_explode_dn()
ldap_first_attribute()
ldap_first_entry()
ldap_first_reference()
ldap_free_result()
ldap_get_attributes()
ldap_get_dn()
ldap_get_entries()
ldap_get_option()
ldap_get_values()
ldap_get_values_len()
ldap_list()
ldap_mod_add()
ldap_mod_del()
ldap_mod_replace()
ldap_modify()
ldap_next_attribute()
ldap_next_entry()
ldap_next_reference()
ldap_parse_reference()
ldap_parse_result()
ldap_read()
ldap_rename()
ldap_search()
ldap_set_option()
ldap_set_rebind_proc()
ldap_sort()
ldap_start_tls()
ldap_t61_to_8859()
ldap_unbind()
levenshtein()
link()
linkinfo()
list()
localeconv()
localtime()
log()
log10()
log1p()
long2ip()
lstat()
ltrim()
lzf_compress()
lzf_decompress()
lzf_optimized_for()

M

mail()
mailparse_determine_best_xfer_encoding()
mailparse_msg_create()
mailparse_msg_extract_part()
mailparse_msg_extract_part_file()
mailparse_msg_free()
mailparse_msg_get_part()
mailparse_msg_get_part_data()
mailparse_msg_get_structure()
mailparse_msg_parse()
mailparse_msg_parse_file()
mailparse_rfc822_parse_addresses()
mailparse_stream_encode()
mailparse_uudecode_all()
main()
max()
mb_convert_case()
mb_convert_encoding()
mb_convert_kana()
mb_convert_variables()
mb_decode_mimeheader()
mb_decode_numericentity()
mb_detect_encoding()
mb_detect_order()
mb_encode_mimeheader()
mb_encode_numericentity()
mb_ereg()
mb_ereg_match()
mb_ereg_replace()
mb_ereg_search()
mb_ereg_search_getpos()
mb_ereg_search_getregs()
mb_ereg_search_init()
mb_ereg_search_pos()
mb_ereg_search_regs()
mb_ereg_search_setpos()
mb_eregi()
mb_eregi_replace()
mb_get_info()
mb_http_input()
mb_http_output()
mb_internal_encoding()
mb_language()
mb_output_handler()
mb_parse_str()
mb_preferred_mime_name()
mb_regex_encoding()
mb_regex_set_options()
mb_send_mail()
mb_split()
mb_strcut()
mb_strimwidth()
mb_strlen()
mb_strpos()
mb_strrpos()
mb_strtolower()
mb_strtoupper()
mb_strwidth()
mb_substitute_character()
mb_substr()
mb_substr_count()
mcal_append_event()
mcal_close()
mcal_create_calendar()
mcal_date_compare()
mcal_date_valid()
mcal_day_of_week()
mcal_day_of_year()
mcal_days_in_month()
mcal_delete_calendar()
mcal_delete_event()
mcal_event_add_attribute()
mcal_event_init()
mcal_event_set_alarm()
mcal_event_set_category()
mcal_event_set_class()
mcal_event_set_description()
mcal_event_set_end()
mcal_event_set_recur_daily()
mcal_event_set_recur_monthly_mday()
mcal_event_set_recur_monthly_wday()
mcal_event_set_recur_none()
mcal_event_set_recur_weekly()
mcal_event_set_recur_yearly()
mcal_event_set_start()
mcal_event_set_title()
mcal_expunge()
mcal_fetch_current_stream_event()
mcal_fetch_event()
mcal_is_leap_year()
mcal_list_alarms()
mcal_list_events()
mcal_next_recurrence()
mcal_open()
mcal_popen()
mcal_rename_calendar()
mcal_reopen()
mcal_snooze()
mcal_store_event()
mcal_time_valid()
mcal_week_of_year()
mcrypt_cbc()
mcrypt_cfb()
mcrypt_create_iv()
mcrypt_decrypt()
mcrypt_ecb()
mcrypt_enc_get_algorithms_name()
mcrypt_enc_get_block_size()
mcrypt_enc_get_iv_size()
mcrypt_enc_get_key_size()
mcrypt_enc_get_modes_name()
mcrypt_enc_get_supported_key_sizes()
mcrypt_enc_is_block_algorithm()
mcrypt_enc_is_block_algorithm_mode()
mcrypt_enc_is_block_mode()
mcrypt_enc_self_test()
mcrypt_encrypt()
mcrypt_generic()
mcrypt_generic_deinit()
mcrypt_generic_end()
mcrypt_generic_init()
mcrypt_get_block_size()
mcrypt_get_cipher_name()
mcrypt_get_iv_size()
mcrypt_get_key_size()
mcrypt_list_algorithms()
mcrypt_list_modes()
mcrypt_module_close()
mcrypt_module_get_algo_block_size()
mcrypt_module_get_algo_key_size()
mcrypt_module_get_supported_key_sizes()
mcrypt_module_is_block_algorithm()
mcrypt_module_is_block_algorithm_mode()
mcrypt_module_is_block_mode()
mcrypt_module_open()
mcrypt_module_self_test()
mcrypt_ofb()
mcve_adduser()
mcve_adduserarg()
mcve_bt()
mcve_checkstatus()
mcve_chkpwd()
mcve_chngpwd()
mcve_completeauthorizations()
mcve_connect()
mcve_connectionerror()
mcve_deleteresponse()
mcve_deletetrans()
mcve_deleteusersetup()
mcve_deluser()
mcve_destroyconn()
mcve_destroyengine()
mcve_disableuser()
mcve_edituser()
mcve_enableuser()
mcve_force()
mcve_getcell()
mcve_getcellbynum()
mcve_getcommadelimited()
mcve_getheader()
mcve_getuserarg()
mcve_getuserparam()
mcve_gft()
mcve_gl()
mcve_gut()
mcve_initconn()
mcve_initengine()
mcve_initusersetup()
mcve_iscommadelimited()
mcve_liststats()
mcve_listusers()
mcve_maxconntimeout()
mcve_monitor()
mcve_numcolumns()
mcve_numrows()
mcve_override()
mcve_parsecommadelimited()
mcve_ping()
mcve_preauth()
mcve_preauthcompletion()
mcve_qc()
mcve_responseparam()
mcve_return()
mcve_returncode()
mcve_returnstatus()
mcve_sale()
mcve_setblocking()
mcve_setdropfile()
mcve_setip()
mcve_setssl()
mcve_setssl_files()
mcve_settimeout()
mcve_settle()
mcve_text_avs()
mcve_text_code()
mcve_text_cv()
mcve_transactionauth()
mcve_transactionavs()
mcve_transactionbatch()
mcve_transactioncv()
mcve_transactionid()
mcve_transactionitem()
mcve_transactionssent()
mcve_transactiontext()
mcve_transinqueue()
mcve_transnew()
mcve_transparam()
mcve_transsend()
mcve_ub()
mcve_uwait()
mcve_verifyconnection()
mcve_verifysslcert()
mcve_void()
md5()
md5_file()
mdecrypt_generic()
memory_get_usage()
metaphone()
method_exists()
mhash()
mhash_count()
mhash_get_block_size()
mhash_get_hash_name()
mhash_keygen_s2k()
microtime()
mime_content_type()
min()
ming_setcubicthreshold()
ming_setscale()
ming_useswfversion()
mkdir()
mktime()
money_format()
move_uploaded_file()
msession_connect()
msession_count()
msession_create()
msession_destroy()
msession_disconnect()
msession_find()
msession_get()
msession_get_array()
msession_getdata()
msession_inc()
msession_list()
msession_listvar()
msession_lock()
msession_plugin()
msession_randstr()
msession_set()
msession_set_array()
msession_setdata()
msession_timeout()
msession_uniq()
msession_unlock()
msg_get_queue()
msg_receive()
msg_remove_queue()
msg_send()
msg_set_queue()
msg_stat_queue()
msql()
msql_affected_rows()
msql_close()
msql_connect()
msql_create_db()
msql_createdb()
msql_data_seek()
msql_dbname()
msql_drop_db()
msql_dropdb()
msql_error()
msql_fetch_array()
msql_fetch_field()
msql_fetch_object()
msql_fetch_row()
msql_field_seek()
msql_fieldflags()
msql_fieldlen()
msql_fieldname()
msql_fieldtable()
msql_fieldtype()
msql_free_result()
msql_freeresult()
msql_list_dbs()
msql_list_fields()
msql_list_tables()
msql_listdbs()
msql_listfields()
msql_listtables()
msql_num_fields()
msql_num_rows()
msql_numfields()
msql_numrows()
msql_pconnect()
msql_query()
msql_regcase()
msql_result()
msql_select_db()
msql_selectdb()
msql_tablename()
mssql_bind()
mssql_close()
mssql_connect()
mssql_data_seek()
mssql_execute()
mssql_fetch_array()
mssql_fetch_assoc()
mssql_fetch_batch()
mssql_fetch_field()
mssql_fetch_object()
mssql_fetch_row()
mssql_field_length()
mssql_field_name()
mssql_field_seek()
mssql_field_type()
mssql_free_result()
mssql_free_statement()
mssql_get_last_message()
mssql_guid_string()
mssql_init()
mssql_min_error_severity()
mssql_min_message_severity()
mssql_next_result()
mssql_num_fields()
mssql_num_rows()
mssql_pconnect()
mssql_query()
mssql_result()
mssql_rows_affected()
mssql_select_db()
mt_getrandmax()
mt_rand()
mt_srand()
muscat_close()
muscat_get()
muscat_give()
muscat_setup()
muscat_setup_net()
mysql_affected_rows()
mysql_change_user()
mysql_client_encoding()
mysql_close()
mysql_connect()
mysql_create_db()
mysql_data_seek()
mysql_db_name()
mysql_db_query()
mysql_drop_db()
mysql_errno()
mysql_error()
mysql_escape_string()
mysql_fetch_array()
mysql_fetch_assoc()
mysql_fetch_field()
mysql_fetch_lengths()
mysql_fetch_object()
mysql_fetch_row()
mysql_field_flags()
mysql_field_len()
mysql_field_name()
mysql_field_seek()
mysql_field_table()
mysql_field_type()
mysql_free_result()
mysql_get_client_info()
mysql_get_host_info()
mysql_get_proto_info()
mysql_get_server_info()
mysql_info()
mysql_insert_id()
mysql_list_dbs()
mysql_list_fields()
mysql_list_processes()
mysql_list_tables()
mysql_num_fields()
mysql_num_rows()
mysql_pconnect()
mysql_ping()
mysql_query()
mysql_real_escape_string()
mysql_result()
mysql_select_db()
mysql_stat()
mysql_tablename()
mysql_thread_id()
mysql_unbuffered_query()
mysqli_affected_rows()
mysqli_autocommit()
mysqli_bind_param()
mysqli_bind_result()
mysqli_change_user()
mysqli_character_set_name()
mysqli_close()
mysqli_commit()
mysqli_connect()
mysqli_data_seek()
mysqli_debug()
mysqli_disable_reads_from_master()
mysqli_disable_rpl_parse()
mysqli_dump_debug_info()
mysqli_enable_reads_from_master()
mysqli_enable_rpl_parse()
mysqli_errno()
mysqli_error()
mysqli_execute()
mysqli_fetch()
mysqli_fetch_array()
mysqli_fetch_assoc()
mysqli_fetch_field()
mysqli_fetch_field_direct()
mysqli_fetch_fields()
mysqli_fetch_lengths()
mysqli_fetch_object()
mysqli_fetch_row()
mysqli_field_count()
mysqli_field_seek()
mysqli_field_tell()
mysqli_free_result()
mysqli_get_client_info()
mysqli_get_host_info()
mysqli_get_proto_info()
mysqli_get_server_info()
mysqli_get_server_version()
mysqli_info()
mysqli_init()
mysqli_insert_id()
mysqli_kill()
mysqli_master_query()
mysqli_num_fields()
mysqli_num_rows()
mysqli_options()
mysqli_param_count()
mysqli_ping()
mysqli_prepare()
mysqli_prepare_result()
mysqli_profiler()
mysqli_query()
mysqli_read_query_result()
mysqli_real_connect()
mysqli_real_escape_string()
mysqli_real_query()
mysqli_reload()
mysqli_rollback()
mysqli_rpl_parse_enabled()
mysqli_rpl_probe()
mysqli_rpl_query_type()
mysqli_select_db()
mysqli_send_long_data()
mysqli_send_query()
mysqli_slave_query()
mysqli_ssl_set()
mysqli_stat()
mysqli_stmt_affected_rows()
mysqli_stmt_close()
mysqli_stmt_errno()
mysqli_stmt_error()
mysqli_stmt_store_result()
mysqli_store_result()
mysqli_thread_id()
mysqli_thread_safe()
mysqli_use_result()
mysqli_warning_count()

N

natcasesort()
natsort()
ncurses_addch()
ncurses_addchnstr()
ncurses_addchstr()
ncurses_addnstr()
ncurses_addstr()
ncurses_assume_default_colors()
ncurses_attroff()
ncurses_attron()
ncurses_attrset()
ncurses_baudrate()
ncurses_beep()
ncurses_bkgd()
ncurses_bkgdset()
ncurses_border()
ncurses_bottom_panel()
ncurses_can_change_color()
ncurses_cbreak()
ncurses_clear()
ncurses_clrtobot()
ncurses_clrtoeol()
ncurses_color_content()
ncurses_color_set()
ncurses_curs_set()
ncurses_def_prog_mode()
ncurses_def_shell_mode()
ncurses_define_key()
ncurses_del_panel()
ncurses_delay_output()
ncurses_delch()
ncurses_deleteln()
ncurses_delwin()
ncurses_doupdate()
ncurses_echo()
ncurses_echochar()
ncurses_end()
ncurses_erase()
ncurses_erasechar()
ncurses_filter()
ncurses_flash()
ncurses_flushinp()
ncurses_getch()
ncurses_getmaxyx()
ncurses_getmouse()
ncurses_getyx()
ncurses_halfdelay()
ncurses_has_colors()
ncurses_has_ic()
ncurses_has_il()
ncurses_has_key()
ncurses_hide_panel()
ncurses_hline()
ncurses_inch()
ncurses_init()
ncurses_init_color()
ncurses_init_pair()
ncurses_insch()
ncurses_insdelln()
ncurses_insertln()
ncurses_insstr()
ncurses_instr()
ncurses_isendwin()
ncurses_keyok()
ncurses_keypad()
ncurses_killchar()
ncurses_longname()
ncurses_meta()
ncurses_mouse_trafo()
ncurses_mouseinterval()
ncurses_mousemask()
ncurses_move()
ncurses_move_panel()
ncurses_mvaddch()
ncurses_mvaddchnstr()
ncurses_mvaddchstr()
ncurses_mvaddnstr()
ncurses_mvaddstr()
ncurses_mvcur()
ncurses_mvdelch()
ncurses_mvgetch()
ncurses_mvhline()
ncurses_mvinch()
ncurses_mvvline()
ncurses_mvwaddstr()
ncurses_napms()
ncurses_new_panel()
ncurses_newpad()
ncurses_newwin()
ncurses_nl()
ncurses_nocbreak()
ncurses_noecho()
ncurses_nonl()
ncurses_noqiflush()
ncurses_noraw()
ncurses_pair_content()
ncurses_panel_above()
ncurses_panel_below()
ncurses_panel_window()
ncurses_pnoutrefresh()
ncurses_prefresh()
ncurses_putp()
ncurses_qiflush()
ncurses_raw()
ncurses_refresh()
ncurses_replace_panel()
ncurses_reset_prog_mode()
ncurses_reset_shell_mode()
ncurses_resetty()
ncurses_savetty()
ncurses_scr_dump()
ncurses_scr_init()
ncurses_scr_restore()
ncurses_scr_set()
ncurses_scrl()
ncurses_show_panel()
ncurses_slk_attr()
ncurses_slk_attroff()
ncurses_slk_attron()
ncurses_slk_attrset()
ncurses_slk_clear()
ncurses_slk_color()
ncurses_slk_init()
ncurses_slk_noutrefresh()
ncurses_slk_refresh()
ncurses_slk_restore()
ncurses_slk_set()
ncurses_slk_touch()
ncurses_standend()
ncurses_standout()
ncurses_start_color()
ncurses_termattrs()
ncurses_termname()
ncurses_timeout()
ncurses_top_panel()
ncurses_typeahead()
ncurses_ungetch()
ncurses_ungetmouse()
ncurses_update_panels()
ncurses_use_default_colors()
ncurses_use_env()
ncurses_use_extended_names()
ncurses_vidattr()
ncurses_vline()
ncurses_waddch()
ncurses_waddstr()
ncurses_wattroff()
ncurses_wattron()
ncurses_wattrset()
ncurses_wborder()
ncurses_wclear()
ncurses_wcolor_set()
ncurses_werase()
ncurses_wgetch()
ncurses_whline()
ncurses_wmouse_trafo()
ncurses_wmove()
ncurses_wnoutrefresh()
ncurses_wrefresh()
ncurses_wstandend()
ncurses_wstandout()
ncurses_wvline()
next()
ngettext()
nl2br()
nl_langinfo()
notes_body()
notes_copy_db()
notes_create_db()
notes_create_note()
notes_drop_db()
notes_find_note()
notes_header_info()
notes_list_msgs()
notes_mark_read()
notes_mark_unread()
notes_nav_create()
notes_search()
notes_unread()
notes_version()
nsapi_request_headers()
nsapi_response_headers()
nsapi_virtual()
number_format()

O

ob_clean()
ob_end_clean()
ob_end_flush()
ob_flush()
ob_get_clean()
ob_get_contents()
ob_get_flush()
ob_get_length()
ob_get_level()
ob_get_status()
ob_gzhandler()
ob_iconv_handler()
ob_implicit_flush()
ob_list_handlers()
ob_start()
ob_tidyhandler()
ocibindbyname()
ocicancel()
ocicloselob()
ocicollappend()
ocicollassign()
ocicollassignelem()
ocicollgetelem()
ocicollmax()
ocicollsize()
ocicolltrim()
ocicolumnisnull()
ocicolumnname()
ocicolumnprecision()
ocicolumnscale()
ocicolumnsize()
ocicolumntype()
ocicolumntyperaw()
ocicommit()
ocidefinebyname()
ocierror()
ociexecute()
ocifetch()
ocifetchinto()
ocifetchstatement()
ocifreecollection()
ocifreecursor()
ocifreedesc()
ocifreestatement()
ociinternaldebug()
ociloadlob()
ocilogoff()
ocilogon()
ocinewcollection()
ocinewcursor()
ocinewdescriptor()
ocinlogon()
ocinumcols()
ociparse()
ociplogon()
ociresult()
ocirollback()
ocirowcount()
ocisavelob()
ocisavelobfile()
ociserverversion()
ocisetprefetch()
ocistatementtype()
ociwritelobtofile()
ociwritetemporarylob()
octdec()
odbc_autocommit()
odbc_binmode()
odbc_close()
odbc_close_all()
odbc_columnprivileges()
odbc_columns()
odbc_commit()
odbc_connect()
odbc_cursor()
odbc_data_source()
odbc_do()
odbc_error()
odbc_errormsg()
odbc_exec()
odbc_execute()
odbc_fetch_array()
odbc_fetch_into()
odbc_fetch_object()
odbc_fetch_row()
odbc_field_len()
odbc_field_name()
odbc_field_num()
odbc_field_precision()
odbc_field_scale()
odbc_field_type()
odbc_foreignkeys()
odbc_free_result()
odbc_gettypeinfo()
odbc_longreadlen()
odbc_next_result()
odbc_num_fields()
odbc_num_rows()
odbc_pconnect()
odbc_prepare()
odbc_primarykeys()
odbc_procedurecolumns()
odbc_procedures()
odbc_result()
odbc_result_all()
odbc_rollback()
odbc_setoption()
odbc_specialcolumns()
odbc_statistics()
odbc_tableprivileges()
odbc_tables()
opendir()
openlog()
openssl_csr_export()
openssl_csr_export_to_file()
openssl_csr_new()
openssl_csr_sign()
openssl_error_string()
openssl_free_key()
openssl_get_privatekey()
openssl_get_publickey()
openssl_open()
openssl_pkcs7_decrypt()
openssl_pkcs7_encrypt()
openssl_pkcs7_sign()
openssl_pkcs7_verify()
openssl_pkey_export()
openssl_pkey_export_to_file()
openssl_pkey_get_private()
openssl_pkey_get_public()
openssl_pkey_new()
openssl_private_decrypt()
openssl_private_encrypt()
openssl_public_decrypt()
openssl_public_encrypt()
openssl_seal()
openssl_sign()
openssl_verify()
openssl_x509_check_private_key()
openssl_x509_checkpurpose()
openssl_x509_export()
openssl_x509_export_to_file()
openssl_x509_free()
openssl_x509_parse()
openssl_x509_read()
ora_bind()
ora_close()
ora_columnname()
ora_columnsize()
ora_columntype()
ora_commit()
ora_commitoff()
ora_commiton()
ora_do()
ora_error()
ora_errorcode()
ora_exec()
ora_fetch()
ora_fetch_into()
ora_getcolumn()
ora_logoff()
ora_logon()
ora_numcols()
ora_numrows()
ora_open()
ora_parse()
ora_plogon()
ora_rollback()
ord()
output_add_rewrite_var()
output_reset_rewrite_vars()
overload()
ovrimos_close()
ovrimos_commit()
ovrimos_connect()
ovrimos_cursor()
ovrimos_exec()
ovrimos_execute()
ovrimos_fetch_into()
ovrimos_fetch_row()
ovrimos_field_len()
ovrimos_field_name()
ovrimos_field_num()
ovrimos_field_type()
ovrimos_free_result()
ovrimos_longreadlen()
ovrimos_num_fields()
ovrimos_num_rows()
ovrimos_prepare()
ovrimos_result()
ovrimos_result_all()
ovrimos_rollback()

P

pack()
parse_ini_file()
parse_str()
parse_url()
passthru()
pathinfo()
pattern modifiers()
pattern syntax()
pclose()
pcntl_exec()
pcntl_fork()
pcntl_signal()
pcntl_waitpid()
pcntl_wexitstatus()
pcntl_wifexited()
pcntl_wifsignaled()
pcntl_wifstopped()
pcntl_wstopsig()
pcntl_wtermsig()
pdf_add_annotation()
pdf_add_bookmark()
pdf_add_launchlink()
pdf_add_locallink()
pdf_add_note()
pdf_add_outline()
pdf_add_pdflink()
pdf_add_thumbnail()
pdf_add_weblink()
pdf_arc()
pdf_arcn()
pdf_attach_file()
pdf_begin_page()
pdf_begin_pattern()
pdf_begin_template()
pdf_circle()
pdf_clip()
pdf_close()
pdf_close_image()
pdf_close_pdi()
pdf_close_pdi_page()
pdf_closepath()
pdf_closepath_fill_stroke()
pdf_closepath_stroke()
pdf_concat()
pdf_continue_text()
pdf_curveto()
pdf_delete()
pdf_end_page()
pdf_end_pattern()
pdf_end_template()
pdf_endpath()
pdf_fill()
pdf_fill_stroke()
pdf_findfont()
pdf_get_buffer()
pdf_get_font()
pdf_get_fontname()
pdf_get_fontsize()
pdf_get_image_height()
pdf_get_image_width()
pdf_get_majorversion()
pdf_get_minorversion()
pdf_get_parameter()
pdf_get_pdi_parameter()
pdf_get_pdi_value()
pdf_get_value()
pdf_initgraphics()
pdf_lineto()
pdf_makespotcolor()
pdf_moveto()
pdf_new()
pdf_open()
pdf_open_ccitt()
pdf_open_file()
pdf_open_gif()
pdf_open_image()
pdf_open_image_file()
pdf_open_jpeg()
pdf_open_memory_image()
pdf_open_pdi()
pdf_open_pdi_page()
pdf_open_png()
pdf_open_tiff()
pdf_place_image()
pdf_place_pdi_page()
pdf_rect()
pdf_restore()
pdf_rotate()
pdf_save()
pdf_scale()
pdf_set_border_color()
pdf_set_border_dash()
pdf_set_border_style()
pdf_set_char_spacing()
pdf_set_duration()
pdf_set_font()
pdf_set_horiz_scaling()
pdf_set_info()
pdf_set_info_author()
pdf_set_info_creator()
pdf_set_info_keywords()
pdf_set_info_subject()
pdf_set_info_title()
pdf_set_leading()
pdf_set_parameter()
pdf_set_text_matrix()
pdf_set_text_pos()
pdf_set_text_rendering()
pdf_set_text_rise()
pdf_set_value()
pdf_set_word_spacing()
pdf_setcolor()
pdf_setdash()
pdf_setflat()
pdf_setfont()
pdf_setgray()
pdf_setgray_fill()
pdf_setgray_stroke()
pdf_setlinecap()
pdf_setlinejoin()
pdf_setlinewidth()
pdf_setmatrix()
pdf_setmiterlimit()
pdf_setpolydash()
pdf_setrgbcolor()
pdf_setrgbcolor_fill()
pdf_setrgbcolor_stroke()
pdf_show()
pdf_show_boxed()
pdf_show_xy()
pdf_skew()
pdf_stringwidth()
pdf_stroke()
pdf_translate()
pfpro_cleanup()
pfpro_init()
pfpro_process()
pfpro_process_raw()
pfpro_version()
pfsockopen()
pg_affected_rows()
pg_cancel_query()
pg_client_encoding()
pg_close()
pg_connect()
pg_connection_busy()
pg_connection_reset()
pg_connection_status()
pg_convert()
pg_copy_from()
pg_copy_to()
pg_dbname()
pg_delete()
pg_end_copy()
pg_escape_bytea()
pg_escape_string()
pg_fetch_all()
pg_fetch_array()
pg_fetch_assoc()
pg_fetch_object()
pg_fetch_result()
pg_fetch_row()
pg_field_is_null()
pg_field_name()
pg_field_num()
pg_field_prtlen()
pg_field_size()
pg_field_type()
pg_free_result()
pg_get_notify()
pg_get_pid()
pg_get_result()
pg_host()
pg_insert()
pg_last_error()
pg_last_notice()
pg_last_oid()
pg_lo_close()
pg_lo_create()
pg_lo_export()
pg_lo_import()
pg_lo_open()
pg_lo_read()
pg_lo_read_all()
pg_lo_seek()
pg_lo_tell()
pg_lo_unlink()
pg_lo_write()
pg_meta_data()
pg_num_fields()
pg_num_rows()
pg_options()
pg_pconnect()
pg_ping()
pg_port()
pg_put_line()
pg_query()
pg_result_error()
pg_result_seek()
pg_result_status()
pg_select()
pg_send_query()
pg_set_client_encoding()
pg_trace()
pg_tty()
pg_unescape_bytea()
pg_untrace()
pg_update()
php_ini_scanned_files()
php_logo_guid()
php_sapi_name()
php_uname()
phpcredits()
phpinfo()
phpversion()
pi()
png2wbmp()
popen()
pos()
posix_ctermid()
posix_get_last_error()
posix_getcwd()
posix_getegid()
posix_geteuid()
posix_getgid()
posix_getgrgid()
posix_getgrnam()
posix_getgroups()
posix_getlogin()
posix_getpgid()
posix_getpgrp()
posix_getpid()
posix_getppid()
posix_getpwnam()
posix_getpwuid()
posix_getrlimit()
posix_getsid()
posix_getuid()
posix_isatty()
posix_kill()
posix_mkfifo()
posix_setegid()
posix_seteuid()
posix_setgid()
posix_setpgid()
posix_setsid()
posix_setuid()
posix_strerror()
posix_times()
posix_ttyname()
posix_uname()
pow()
preg_grep()
preg_match()
preg_match_all()
preg_quote()
preg_replace()
preg_replace_callback()
preg_split()
prev()
print()
print_r()
printer_abort()
printer_close()
printer_create_brush()
printer_create_dc()
printer_create_font()
printer_create_pen()
printer_delete_brush()
printer_delete_dc()
printer_delete_font()
printer_delete_pen()
printer_draw_bmp()
printer_draw_chord()
printer_draw_elipse()
printer_draw_line()
printer_draw_pie()
printer_draw_rectangle()
printer_draw_roundrect()
printer_draw_text()
printer_end_doc()
printer_end_page()
printer_get_option()
printer_list()
printer_logical_fontheight()
printer_open()
printer_select_brush()
printer_select_font()
printer_select_pen()
printer_set_option()
printer_start_doc()
printer_start_page()
printer_write()
printf()
proc_close()
proc_get_status()
proc_nice()
proc_open()
proc_terminate()
pspell_add_to_personal()
pspell_add_to_session()
pspell_check()
pspell_clear_session()
pspell_config_create()
pspell_config_ignore()
pspell_config_mode()
pspell_config_personal()
pspell_config_repl()
pspell_config_runtogether()
pspell_config_save_repl()
pspell_new()
pspell_new_config()
pspell_new_personal()
pspell_save_wordlist()
pspell_store_replacement()
pspell_suggest()
putenv()

Q

qdom_error()
qdom_tree()
quoted_printable_decode()
quotemeta()

R

rad2deg()
rand()
range()
rawurldecode()
rawurlencode()
read_exif_data()
readdir()
readfile()
readgzfile()
readline()
readline_add_history()
readline_clear_history()
readline_completion_function()
readline_info()
readline_list_history()
readline_read_history()
readline_write_history()
readlink()
realpath()
recode()
recode_file()
recode_string()
register_shutdown_function()
register_tick_function()
rename()
reset()
restore_error_handler()
restore_include_path()
rewind()
rewinddir()
rmdir()
round()
rsort()
rtrim()

S

scandir()
sem_acquire()
sem_get()
sem_release()
sem_remove()
serialize()
sesam_affected_rows()
sesam_commit()
sesam_connect()
sesam_diagnostic()
sesam_disconnect()
sesam_errormsg()
sesam_execimm()
sesam_fetch_array()
sesam_fetch_result()
sesam_fetch_row()
sesam_field_array()
sesam_field_name()
sesam_free_result()
sesam_num_fields()
sesam_query()
sesam_rollback()
sesam_seek_row()
sesam_settransaction()
session_cache_expire()
session_cache_limiter()
session_decode()
session_destroy()
session_encode()
session_get_cookie_params()
session_id()
session_is_registered()
session_module_name()
session_name()
session_regenerate_id()
session_register()
session_save_path()
session_set_cookie_params()
session_set_save_handler()
session_start()
session_unregister()
session_unset()
session_write_close()
set_error_handler()
set_file_buffer()
set_include_path()
set_magic_quotes_runtime()
set_time_limit()
setcookie()
setlocale()
settype()
sha1()
sha1_file()
shell_exec()
shm_attach()
shm_detach()
shm_get_var()
shm_put_var()
shm_remove()
shm_remove_var()
shmop_close()
shmop_delete()
shmop_open()
shmop_read()
shmop_size()
shmop_write()
show_source()
shuffle()
similar_text()
simplexml_element->asxml()
simplexml_element->attributes()
simplexml_element->children()
simplexml_element->xpath()
simplexml_load_dom()
simplexml_load_file()
simplexml_load_string()
sin()
sinh()
sizeof()
sleep()
snmp_get_quick_print()
snmp_set_quick_print()
snmpget()
snmprealwalk()
snmpset()
snmpwalk()
snmpwalkoid()
socket_accept()
socket_bind()
socket_clear_error()
socket_close()
socket_connect()
socket_create()
socket_create_listen()
socket_create_pair()
socket_get_option()
socket_get_status()
socket_getpeername()
socket_getsockname()
socket_iovec_add()
socket_iovec_alloc()
socket_iovec_delete()
socket_iovec_fetch()
socket_iovec_free()
socket_iovec_set()
socket_last_error()
socket_listen()
socket_read()
socket_readv()
socket_recv()
socket_recvfrom()
socket_recvmsg()
socket_select()
socket_send()
socket_sendmsg()
socket_sendto()
socket_set_block()
socket_set_blocking()
socket_set_nonblock()
socket_set_option()
socket_set_timeout()
socket_shutdown()
socket_strerror()
socket_write()
socket_writev()
sort()
soundex()
split()
spliti()
sprintf()
sql_regcase()
sqlite_array_query()
sqlite_busy_timeout()
sqlite_changes()
sqlite_close()
sqlite_column()
sqlite_create_aggregate()
sqlite_create_function()
sqlite_current()
sqlite_error_string()
sqlite_escape_string()
sqlite_fetch_array()
sqlite_fetch_single()
sqlite_fetch_string()
sqlite_field_name()
sqlite_has_more()
sqlite_last_error()
sqlite_last_insert_rowid()
sqlite_libencoding()
sqlite_libversion()
sqlite_next()
sqlite_num_fields()
sqlite_num_rows()
sqlite_open()
sqlite_popen()
sqlite_query()
sqlite_rewind()
sqlite_seek()
sqlite_udf_decode_binary()
sqlite_udf_encode_binary()
sqlite_unbuffered_query()
sqrt()
srand()
sscanf()
stat()
str_ireplace()
str_pad()
str_repeat()
str_replace()
str_rot13()
str_shuffle()
str_split()
str_word_count()
strcasecmp()
strchr()
strcmp()
strcoll()
strcspn()
stream_context_create()
stream_context_get_options()
stream_context_set_option()
stream_context_set_params()
stream_copy_to_stream()
stream_filter_append()
stream_filter_prepend()
stream_filter_register()
stream_get_contents()
stream_get_filters()
stream_get_line()
stream_get_meta_data()
stream_get_transports()
stream_get_wrappers()
stream_register_wrapper()
stream_select()
stream_set_blocking()
stream_set_timeout()
stream_set_write_buffer()
stream_socket_accept()
stream_socket_client()
stream_socket_get_name()
stream_socket_recvfrom()
stream_socket_sendto()
stream_socket_server()
stream_wrapper_register()
strftime()
strip_tags()
stripcslashes()
stripos()
stripslashes()
stristr()
strlen()
strnatcasecmp()
strnatcmp()
strncasecmp()
strncmp()
strpos()
strrchr()
strrev()
strripos()
strrpos()
strspn()
strstr()
strtok()
strtolower()
strtotime()
strtoupper()
strtr()
strval()
substr()
substr_compare()
substr_count()
substr_replace()
swf_actiongeturl()
swf_actiongotoframe()
swf_actiongotolabel()
swf_actionnextframe()
swf_actionplay()
swf_actionprevframe()
swf_actionsettarget()
swf_actionstop()
swf_actiontogglequality()
swf_actionwaitforframe()
swf_addbuttonrecord()
swf_addcolor()
swf_closefile()
swf_definebitmap()
swf_definefont()
swf_defineline()
swf_definepoly()
swf_definerect()
swf_definetext()
swf_endbutton()
swf_enddoaction()
swf_endshape()
swf_endsymbol()
swf_fontsize()
swf_fontslant()
swf_fonttracking()
swf_getbitmapinfo()
swf_getfontinfo()
swf_getframe()
swf_labelframe()
swf_lookat()
swf_modifyobject()
swf_mulcolor()
swf_nextid()
swf_oncondition()
swf_openfile()
swf_ortho()
swf_ortho2()
swf_perspective()
swf_placeobject()
swf_polarview()
swf_popmatrix()
swf_posround()
swf_pushmatrix()
swf_removeobject()
swf_rotate()
swf_scale()
swf_setfont()
swf_setframe()
swf_shapearc()
swf_shapecurveto()
swf_shapecurveto3()
swf_shapefillbitmapclip()
swf_shapefillbitmaptile()
swf_shapefilloff()
swf_shapefillsolid()
swf_shapelinesolid()
swf_shapelineto()
swf_shapemoveto()
swf_showframe()
swf_startbutton()
swf_startdoaction()
swf_startshape()
swf_startsymbol()
swf_textwidth()
swf_translate()
swf_viewport()
swfaction()
swfbitmap()
swfbitmap->getheight()
swfbitmap->getwidth()
swfbutton()
swfbutton->addaction()
swfbutton->addshape()
swfbutton->setaction()
swfbutton->setdown()
swfbutton->sethit()
swfbutton->setover()
swfbutton->setup()
swfbutton_keypress()
swfdisplayitem()
swfdisplayitem->addcolor()
swfdisplayitem->move()
swfdisplayitem->moveto()
swfdisplayitem->multcolor()
swfdisplayitem->remove()
swfdisplayitem->rotate()
swfdisplayitem->rotateto()
swfdisplayitem->scale()
swfdisplayitem->scaleto()
swfdisplayitem->setdepth()
swfdisplayitem->setname()
swfdisplayitem->setratio()
swfdisplayitem->skewx()
swfdisplayitem->skewxto()
swfdisplayitem->skewy()
swfdisplayitem->skewyto()
swffill()
swffill->moveto()
swffill->rotateto()
swffill->scaleto()
swffill->skewxto()
swffill->skewyto()
swffont()
swffont->getwidth()
swfgradient()
swfgradient->addentry()
swfmorph()
swfmorph->getshape1()
swfmorph->getshape2()
swfmovie()
swfmovie->add()
swfmovie->nextframe()
swfmovie->output()
swfmovie->remove()
swfmovie->save()
swfmovie->setbackground()
swfmovie->setdimension()
swfmovie->setframes()
swfmovie->setrate()
swfmovie->streammp3()
swfshape()
swfshape->addfill()
swfshape->drawcurve()
swfshape->drawcurveto()
swfshape->drawline()
swfshape->drawlineto()
swfshape->movepen()
swfshape->movepento()
swfshape->setleftfill()
swfshape->setline()
swfshape->setrightfill()
swfsprite()
swfsprite->add()
swfsprite->nextframe()
swfsprite->remove()
swfsprite->setframes()
swftext()
swftext->addstring()
swftext->getwidth()
swftext->moveto()
swftext->setcolor()
swftext->setfont()
swftext->setheight()
swftext->setspacing()
swftextfield()
swftextfield->addstring()
swftextfield->align()
swftextfield->setbounds()
swftextfield->setcolor()
swftextfield->setfont()
swftextfield->setheight()
swftextfield->setindentation()
swftextfield->setleftmargin()
swftextfield->setlinespacing()
swftextfield->setmargins()
swftextfield->setname()
swftextfield->setrightmargin()
sybase_affected_rows()
sybase_close()
sybase_connect()
sybase_data_seek()
sybase_deadlock_retry_count()
sybase_fetch_array()
sybase_fetch_assoc()
sybase_fetch_field()
sybase_fetch_object()
sybase_fetch_row()
sybase_field_seek()
sybase_free_result()
sybase_get_last_message()
sybase_min_client_severity()
sybase_min_error_severity()
sybase_min_message_severity()
sybase_min_server_severity()
sybase_num_fields()
sybase_num_rows()
sybase_pconnect()
sybase_query()
sybase_result()
sybase_select_db()
sybase_set_message_handler()
sybase_unbuffered_query()
symlink()
syslog()
system()

T

tan()
tanh()
tempnam()
textdomain()
tidy_access_count()
tidy_clean_repair()
tidy_config_count()
tidy_diagnose()
tidy_error_count()
tidy_get_body()
tidy_get_config()
tidy_get_error_buffer()
tidy_get_head()
tidy_get_html()
tidy_get_html_ver()
tidy_get_output()
tidy_get_release()
tidy_get_root()
tidy_get_status()
tidy_getopt()
tidy_is_xhtml()
tidy_load_config()
tidy_node->attributes()
tidy_node->children()
tidy_node->get_attr()
tidy_node->get_nodes()
tidy_node->has_children()
tidy_node->has_siblings()
tidy_node->is_asp()
tidy_node->is_comment()
tidy_node->is_html()
tidy_node->is_jsp()
tidy_node->is_jste()
tidy_node->is_text()
tidy_node->is_xhtml()
tidy_node->is_xml()
tidy_node->next()
tidy_node->prev()
tidy_node->tidy_node()
tidy_parse_file()
tidy_parse_string()
tidy_repair_file()
tidy_repair_string()
tidy_reset_config()
tidy_save_config()
tidy_set_encoding()
tidy_setopt()
tidy_warning_count()
time()
tmpfile()
token_get_all()
token_name()
touch()
trigger_error()
trim()

U

uasort()
ucfirst()
ucwords()
udm_add_search_limit()
udm_alloc_agent()
udm_api_version()
udm_cat_list()
udm_cat_path()
udm_check_charset()
udm_check_stored()
udm_clear_search_limits()
udm_close_stored()
udm_crc32()
udm_errno()
udm_error()
udm_find()
udm_free_agent()
udm_free_ispell_data()
udm_free_res()
udm_get_doc_count()
udm_get_res_field()
udm_get_res_param()
udm_load_ispell_data()
udm_open_stored()
udm_set_agent_param()
uksort()
umask()
uniqid()
unixtojd()
unlink()
unpack()
unregister_tick_function()
unserialize()
unset()
urldecode()
urlencode()
user_error()
usleep()
usort()
utf8_decode()
utf8_encode()

V

var_dump()
var_export()
variant()
version_compare()
virtual()
vpopmail_add_alias_domain()
vpopmail_add_alias_domain_ex()
vpopmail_add_domain()
vpopmail_add_domain_ex()
vpopmail_add_user()
vpopmail_alias_add()
vpopmail_alias_del()
vpopmail_alias_del_domain()
vpopmail_alias_get()
vpopmail_alias_get_all()
vpopmail_auth_user()
vpopmail_del_domain()
vpopmail_del_domain_ex()
vpopmail_del_user()
vpopmail_error()
vpopmail_passwd()
vpopmail_set_user_quota()
vprintf()
vsprintf()

W

w32api_deftype()
w32api_init_dtype()
w32api_invoke_function()
w32api_register_function()
w32api_set_call_method()
wddx_add_vars()
wddx_deserialize()
wddx_packet_end()
wddx_packet_start()
wddx_serialize_value()
wddx_serialize_vars()
wordwrap()

X

xml_error_string()
xml_get_current_byte_index()
xml_get_current_column_number()
xml_get_current_line_number()
xml_get_error_code()
xml_parse()
xml_parse_into_struct()
xml_parser_create()
xml_parser_create_ns()
xml_parser_free()
xml_parser_get_option()
xml_parser_set_option()
xml_set_character_data_handler()
xml_set_default_handler()
xml_set_element_handler()
xml_set_end_namespace_decl_handler()
xml_set_external_entity_ref_handler()
xml_set_notation_decl_handler()
xml_set_object()
xml_set_processing_instruction_handler()
xml_set_start_namespace_decl_handler()
xml_set_unparsed_entity_decl_handler()
xmlrpc_decode()
xmlrpc_decode_request()
xmlrpc_encode()
xmlrpc_encode_request()
xmlrpc_get_type()
xmlrpc_parse_method_descriptions()
xmlrpc_server_add_introspection_data()
xmlrpc_server_call_method()
xmlrpc_server_create()
xmlrpc_server_destroy()
xmlrpc_server_register_introspection_callback()
xmlrpc_server_register_method()
xmlrpc_set_type()
xpath_eval()
xpath_eval_expression()
xpath_new_context()
xptr_eval()
xptr_new_context()
xslt_create()
xslt_errno()
xslt_error()
xslt_free()
xslt_process()
xslt_set_base()
xslt_set_encoding()
xslt_set_error_handler()
xslt_set_log()
xslt_set_sax_handler()
xslt_set_sax_handlers()
xslt_set_scheme_handler()
xslt_set_scheme_handlers()

Y

yaz_addinfo()
yaz_ccl_conf()
yaz_ccl_parse()
yaz_close()
yaz_connect()
yaz_database()
yaz_element()
yaz_errno()
yaz_error()
yaz_es_result()
yaz_get_option()
yaz_hits()
yaz_itemorder()
yaz_present()
yaz_range()
yaz_record()
yaz_scan()
yaz_scan_result()
yaz_schema()
yaz_search()
yaz_set_option()
yaz_sort()
yaz_syntax()
yaz_wait()
yp_all()
yp_cat()
yp_err_string()
yp_errno()
yp_first()
yp_get_default_domain()
yp_master()
yp_match()
yp_next()
yp_order()

Z

zend_logo_guid()
zend_version()
zip_close()
zip_entry_close()
zip_entry_compressedsize()
zip_entry_compressionmethod()
zip_entry_filesize()
zip_entry_name()
zip_entry_open()
zip_entry_read()
zip_open()
zip_read()
zlib_get_coding_type()

이전 | 처음으로 | 다음
함수 인덱스 | 위로 | HTML 도움말 에디션


PHP 매뉴얼

저작권

Copyright ? 1997 - 2004 by the PHP Documentation Group. This material may be distributed only subject to the terms and conditions set forth in the Open Publication License, v1.0 or later (the latest version is presently available at http://www.opencontent.org/openpub/).

PHP 문서 그룹에 저작권이 있습니다. (Copyright ? 1997 - 2004 by the PHP Documentation Group) 이 저작물은 Open Publication License 1.0 또는 이후 버전(최신 버전은 http://www.opencontent.org/openpub/에 있습니다)의 조항과 제약에 따를 경우에만 재배포 할 수 있습니다.

Distribution of substantively modified versions of this document is prohibited without the explicit permission of the copyright holder.

Distribution of the work or derivative of the work in any standard (paper) book form is prohibited unless prior permission is obtained from the copyright holder.

저작권 부분에 대한 명시적 동의가 없을 경우, 이 문서의 변경된 버전에 대한 재배포를 금합니다. 저작권 부분에 따른 허가가 없을 경우, 어떠한 일반적인 (종이) 책 형태로의 재배포 작업 및 유사 작업을 금합니다.

PHP 문서 그룹의 구성원은 매뉴얼 첫 페이지에 나열되어 있습니다. 그룹과 접촉하기 위해서는, phpdoc@lists.php.net로 작성해 주십시오.

The 'Extending PHP 4.0' section of this manual is copyright ? 2000 by Zend Technologies, Ltd. This material may be distributed only subject to the terms and conditions set forth in the Open Publication License, v1.0 or later (the latest version is presently available at http://www.opencontent.org/openpub/).

이 매뉴얼의 'PHP 4.0 확장하기' 섹션은 젠드 테크놀로지 사에 저작권이 있습니다. (Copyright ? 2000 by Zend Technologies, Ltd.) 이 저작물은 Open Publication License 1.0 또는 이후 버전(최신 버전은 http://www.opencontent.org/openpub/에 있습니다)의 조항과 제약에 따를 경우에만 재배포 할 수 있습니다.

이 매뉴얼은 Open Publication License의 사본을 포함하고 있습니다.

처음으로


About This Edition

PHP 매뉴얼
이전 다음

57. 장. About This Edition

The Windows HTML Help Edition of the PHP Manual is aimed at developers, who want the manual at hand every time, and would like to read manual pages and user notes without waiting for a remote webpage to download. This edition gives you the full content of the manual plus the user notes, with some great features provided by the viewer application by the scripts we use to generate this format and by other contributors in the form of skins.

This distribution of the PHP Manual contains many files, including the main manual file php_manual_en.chm. You can view the manual by double clicking on this file (as you already guessed). The user notes are in php_manual_notes.chm. You only need to have one copy of this file on your computer, regardless of how many languages you use to read the PHP Manual. The only requirement is that you need to have all php_manual_LANG.chm files in one directory with php_manual_notes.chm. You may also see a php_manual_en.chw file in the directory, it's generated the first time you use the index tab, and it contains an index with the manual's pages.

For those interested in technical details about Microsoft HTML Help, http://www.helpware.net/ is a great resource. For more information and positioning of Windows HTML Help in the Microsoft help formats and services history, see this WinWriters article.

이전 | 처음으로 | 다음
HTML 도움말 에디션 | 위로 | Using PHP Manual CHM Edition


CHM Edition Credits

PHP 매뉴얼
이전

63. 장. CHM Edition Credits

This enhanced version of the PHP Manual would never come to existence, if the following people would not help with their contribution to the project (in no particular order):

  • Holger Eggert, who created the two default designs, and provided many useability tips

  • Gonzalo De la Pena Andreu, who added many comments on how it would be ideal to provide the skinnable interface

  • Olexandr Vynnychenko added countless comments and testing all the time

  • Brendan Ferguson, who provided many optimizations, improvements to the HTML and JS codes behind the manual pages

  • Sandor Hojtsy, who coded the manual preferences desktop application

  • And at last but not least, everybody, who provided feedback through our mailing list, and in the user survey

이전 | 처음으로
CSS classes | 위로


Integrating the PHP Manual

PHP 매뉴얼
이전 다음

61. 장. Integrating the PHP Manual

참고: The information provided here is mainly aimed at IDE authors, or advanced users who would like to integrate this CHM file to their favorite IDEs or other production environment components.

There are several editors out there with support for CHM integration, but you may need to know a few things about what the CHM contains to successfully integrate the manual into your environment.

The CHM is built using XSL style sheets from XML sources. This is unique currently in the PHP Manual family, as all other versions are generated using DSSSL style sheets. This also means, that non-intentional rendering differences may come up. A special conversion script is run on the XSLT output, adding several cute features, and packing up the manual with the preferences files and skin examples.

If you never worked with CHMs, you can think of them as compressed files with OS supported access for files inside and some added search and index support. However CHMs can only be viewed using the HTML Help Viewer, you can directly access files inside them using a special URL prefix, the CHM file name and the file you request from inside. As all the help content is stored in HTML files, you can show pages of the CHM in Internet Explorer.

Assume that you placed your php_manual_en.chm to c:\phpmanual the index file in the manual (which you see the first time) can be accessed with the following URL: mk:@MSITStore:C:\phpmanual\php_manual_en.chm::/_index.html. Here mk:@MSITStore: is the special "protocol", C:\phpmanual\php_manual_en.chm is the CHM with it's full path. The /_index.html part is the path to the index file inside the CHM and :: is just what you need to put between the CHM path and this file path.

참고: All files are in the root directory of the CHM, unlike the previous CHM versions which included a language directory. Images, style sheets and other supplemental files have names starting with an underscore (like the main index shown above), to avoid name collisions.

The names of generated files follow the same rules as the online manual, except that the extension is .html and not .php. The most important is that function documentation files are named function.FUNCNAME.html where FUNCNAME is the function name, with all underscores converted to hyphens. Some examples are function.echo.html, function.mysql-close.html, function.imagecopy.html.

Using all this information, you can show a manual page for a function requested by a user. A simple example is included in the distribution, named php_quickref.hta. This is a HTML Application to demonstrate the simple process of showing a manual page for a function. The quickRef() function defined therein does the job.

If you would like to integrate the manual into an IDE without direct support for the PHP manual (actually the underscore to hyphen conversion), you can use the included _function.html file to access a function page. This file is simply a redirector, and can be parameterized via the URL, as _function.html#mysql_close. This page will redirect you to the mysql_close function page (function.mysql-close.html) automatically. You can provide the full path of this file if your IDE supports context sensitive help, and provide the IDE specified string as the parameter. An example for this is the UltraEdit 9 intergation (see the edition's website).

The index of the manual (accessible via the index tab on the navigation pane) can also be used for integrational purposes. All the HTML pages are included in the index with their titles as index terms (including function description pages).

If you are a desktop application developer and would like to tightly integrate the CHM into your program (such as displaying the TOC tree in your IDE's help box), you can find more information at http://www.helpware.net/, as well as links to other useful resources. The official site for HTML Help is at http://msdn.microsoft.com/library/en-us/htmlhelp/html/vsconhh1start.asp.

이전 | 처음으로 | 다음
Presentational Specialities | 위로 | Skin development


The Full Text Search

PHP 매뉴얼
이전 다음

59. 장. The Full Text Search

차례
General searching rules
Searching for words or phrases
Defining search terms
Using nested expressions when searching
Manual Content and User Note Separation

This edition of the PHP Manual includes an advanced full text search possibility provided by the viewer application. This enables users to to search through every word in the help file to find a match. For example, if a user does a full-text search on the word "Apache", every topic that contains the word "Apache" will be listed. Advanced full-text search allows a user to search using boolean, wildcard, and nested expressions. A user can also limit the search to previous results, match similar words, or search topic titles only.

The usage of the search feature is fairly straightforward. Click on the search tab, type in the desired words and press ENTER (or click on "List Topics"). Then you'll receive a list of matches from the PHP Manual (and the notes). You can use the button with a right arrow on it to add boolean operators to your search (or you can type them in). As you see the results, you can use the column headings (Title, Location and Rank) to sort the topic list. The default order is by Rank. You can also adjust some parameters at the bottom of this tab.

The words found are highlighted on the current page in the Topic pane by default. You can turn off this feature by choosing the "Search Highlight Off" menu item in the Options menu. To can get this feature back similarly. If you are viewing a long topic, only the first 500 instances of a search word or phrase will be highlighted, due to a limitation of the viewer.

General searching rules

A basic search consists of the word or phrase you want to find. You can use wildcard expressions, nested expressions, boolean operators, similar word matches, a previous results list, or topic titles to further define your search.

The basic rules for formulating queries are as follows:

  • Searches are not case-sensitive, so you can type your search in uppercase or lowercase characters.

  • You may search for any combination of letters (a-z) and numbers (0-9). You cannot search for single letters (a, b, c, etc.) and common words, like: an, and, as, at, be, but, by, do, for, from, have, he, in, it, not, of, on, or, she, that, the, there, they, this, to, we, which, with, you.

  • Punctuation marks such as the period (.), colon (:), semicolon (;), comma (,), and hyphen (-) are ignored during a search.

  • Group the elements of your search using double quotes or parentheses to set apart each element. You cannot search for quotation marks.

참고: If you are searching for a file name with an extension, you should group the entire string in double quotes, ("filename.ext"). Otherwise, the period will break the file name into two separate terms. The default operation between terms is AND, so you will create the logical equivalent to "filename AND ext."

이전 | 처음으로 | 다음
Keyboard Shortcuts | 위로 | Searching for words or phrases


Using nested expressions when searching

Nested expressions allow you to create complex searches for information. For example, "html AND ((smtp OR pop3) NEAR mail)" finds topics containing the word "html" along with the words "smtp" and "mail" close together, or containing "html" along with the words "pop3" and "mail" close together.

The basic rules for searching help topics using nested expressions are as follows:

  • You can use parentheses to nest expressions within a query. The expressions in parentheses are evaluated before the rest of the query.

  • If a query does not contain a nested expression, it is evaluated from left to right. For example: "mail NOT pop3 OR smtp" finds topics containing the word "mail" without the word "pop3" or topics containing the word "smtp". On the other hand, "mail NOT (pop3 OR smtp)" finds topics containing the word "mail" without either of the words "pop3" or "smtp".

  • You cannot nest expressions more than five levels deep.

이전 | 처음으로 | 다음
Defining search terms | 위로 | Manual Content and User Note Separation


Manual Content and User Note Separation

The manual content and the user notes are separated to php_manual_LANG.chm and php_manual_notes.chm. There were several resons to do this, including:

  • This way you can update the user notes and the manual independently as you need.

  • You can have more than one language of the manual, while only need to have one notes file. All the CHM files need to be in the same directory, and all translations need to share the same preferences if you would not like to have more then one notes file.

  • You can bookmark manual pages with notes, or just a notes part of a page separately.

  • You can "turn off" user note display and user note search results by simply deleting php_manual_notes.chm, moving it out of the directory or renaming it.

All these benefits lead us to provide the manual the way you can see it right now. This distribution had the effect on the full text search that you get search results from the manual content and from the user notes as separate ones. The "Location" column shows the source of the result, also enabling you to "add precedence" to manual content results with ordering the results by "Location". User note page titles are also prefixed with "N:" to make them easily distinguishable in the favorites list (there's no location info in the favorites list).

이전 | 처음으로 | 다음
Using nested expressions when searching | 위로 | Specialities of this Edition


Defining search terms

The AND, OR, NOT, and NEAR operators enable you to precisely define your search by creating a relationship between search terms. The following table shows how you can use each of these operators. If no operator is specified, AND is used. For example, the query "server cgi security" is equivalent to "server AND cgi AND security".

표 59-2. Search operators

Search for | Example | Results
Both terms in the same topic | http AND apache | Topics containing both the words "http" and "apache".
Either term in a topic | ming OR swflib | Topics containing either the word "ming" or the word "swflib" or both.
The first term without the second term | xml NOT expat | Topics containing the word "xml" but not the word "expat".
Both terms in the same topic, close together | database NEAR security | Topics containing the word "database" within eight words of the word "security".

참고: The |, &, and ! characters can also be used in place of OR AND and NOT respectively. This may not work if you use a very old version of the viewer.

이전 | 처음으로 | 다음
Searching for words or phrases | 위로 | Using nested expressions when searching


Searching for words or phrases

You can search for words or phrases and use wildcard expressions. Wildcard expressions allow you to search for one or more characters using a question mark or asterisk. The table below describes the results of these different kinds of searches.

표 59-1. Word and phrase searches

Search for | Example | Results
A single word | select | Topics that contain the word "select". (You will also find its grammatical variations, such as "selector" and "selection".)
A phrase "new operator" or new operator

Topics that contain the literal phrase "new operator" and all its grammatical variations.

Without the quotation marks, the query is equivalent to specifying "new AND operator," which will find topics containing both of the individual words, instead of the phrase.

Wildcard expressions esc* or HT??

Results for the first example include topics that contain the terms "ESC", "escape", "escalation", and so on. The asterisk cannot be the only character in the term.

Results for the second example include topics that contain the terms "HTTP", "HTML" and so on. The question mark cannot be the only character in the term.

참고: Select the Match similar words check box to include minor grammatical variations for the phrase you search. This feature only locates variations of the word with common suffixes. For example, a search on the word "add" will find "added," but it will not find "additive". This option is independent of other options or syntax. If you do a titles-only search, variations in titles will be matched. If you use quotes (or any other query operator) any variation of the word can appear; for example, "stemmed search" will also match "stemming search".

이전 | 처음으로 | 다음
The Full Text Search | 위로 | Defining search terms


Skin development

PHP 매뉴얼
이전 다음

62. 장. Skin development

차례
Page Display Process
Page Elements
CSS classes

This edition of the PHP Manual allows users to choose from skins to display the contents, as well as develop custom skins to meet some special needs. We decided to support skins because we realized that one skin cannot satisfy everybodies needs in a such heavily used edition.

We included two skins by default inside the CHM. These cannot be modified or removed, so if you have the CHM, you have these two skins inside. The Low skin is optimized for small window display, the High skin is a variation of the Low one with some graphics added to spice it up.

A skin must have at least two files, a skin loader JavaScript file and a CSS file. The two inline skins have these files inside the CHM. The skin loader JS should at least load in the CSS file and display the page contents to the viewer. Theoretically there are two kinds of skins: CSS skins and Full skins. CSS skins only modify the CSS and does not amend the page layout. Full skins also modify the page layout. We have included sample skins for both the CSS skin type and the Full skin type ("greenlinks" and "headernostalgia" respectively).

주의

Note that though the current skin development methods are quite final, there may be heavy changes in used CSS classes or page elements while we refine the skin development ideas. As this edition is currently in development stage, the information described herein is not to be considered completely stable.

Page Display Process

If you are going to develop your own skin, you should know how one page is loaded and displayed to the user, and how a skin fits in this process. For these paragraphs, we assume that you have put your CHM into c:\phpmanual, so it's accessible as c:\phpmanual\php_manual_LANG.chm (where LANG is the language code), and you would like to see the function page of "echo", which is function.echo.html inside the CHM. See the sections about integration for more information on CHM contents.

  • First of all the HTML content is loaded in from function.echo.html from inside the CHM.

  • At the top of this file, there is a HTML <script> tag, which loads in the _script.js file from the CHM. This file contains all the JS code needed to move on with the process. Most importantly this JS defines many variables (like where the CHM is, or what is the actual page viewed) and many functions to print out the context menu or handle online functions.

  • At last _script.js loads in the preferences file from outside the CHM (c:\phpmanual\php_manual_prefs.js in our example). This JS file defines the preference variables, and calls back prefHandler() which is also defined in _script.js.

  • That function loads in the skin JS file as the preferences dictate. The skin JS file should load in the needed CSS file, and define a displayPage() function, which displays the page if called.

  • The HTML file (function.echo.html in this example) also contains a function call to load in the user notes, which simply puts the notes into this HTML file using DHTML to be displayed as if they were here before...

  • The HTML file also contains a body onload attribute which calls the skin-defined displayPage() function to show the page to the user. This is the last function called, it should present the page in it's complete form to the user.

Every action is synchronized with calling back a function in the previously loaded file when the JS is in memory. The notes loading and skin JS loading is only synchronized with the page's onload event (which as the Microsoft documentation says only fires if the page is completely loaded).

This load and callback chain may seem to be too complicated, but so far this seemed to be the best way to do as many things as possible parallel, while also synchronize some calls.

As you can see your skin JavaScript file is loaded in by _script.js and it's displayPage() function is called by the body onload event.

이전 | 처음으로 | 다음
Integrating the PHP Manual | 위로 | Page Elements


CSS classes

We cannot provide accurate documentation currently on useable CSS classes, as some of the DocBook XSL sheets classes are not used and some classes are added. Please see the sample CSS files included for first time reference.

이전 | 처음으로 | 다음
Page Elements | 위로 | CHM Edition Credits


Page Elements

The PHP Manual pages are all HTML files with several HTML tags in them for both presentational and divisional purposes. The HTML pages contain divisions to be used for skinning purposes and misc divisions added by the DocBook XSL sheets.

A HTML page can be either a function reference page or another kind of page (like a feature description). Skins should get ready to skin these two kinds of pages separately most of the time (depending on the actual design).

The pages are structured using <div> tags with appropriate IDs to ease the skin writers work. A page consists of these parts:

  • <div id="pageContent"></div> contains all the page contents. This begins right after <body> and ends just before </body>. This division is hidden by default, you need to show it after you are ready with the page rewriting process.

  • <div id="pageHeaders"></div> contains the page header parts. This includes the text only main title (in a <span id="pageTitle"></span>) and function properties, in case this is a function page (contained in <span id="funcPurpose"></span>, <span id="funcAvail"></span> and <span id="funcUsage"></span>). In case one of these three is not available, the current page is not a function page.

  • <div id="pageText"></div> contains the majority of the page contents, including examples, manual notes, warnings, etc. This also includes see also parts for now, as we still cannot differentiate between see also and normal text parts (may be a thing to change in the future).

  • <div id="pageNotes"></div> contains the user notes (itself loaded in from another HTML file by JS). It contains a heading, and then a <div> without ID for every user note and spans in that divs for every element of a user note (with "email", "date" and "text" IDs respectively).

  • <div id="pageNav"></div> contains the
navigation table, which is further divided into spans (<span
id="navPrev"></span>, <span
id="navPath"></span>, <span
id="navNext"></span>, <span
id="navOnline"></span>, <span
id="navThisOnline"></span> and <span
id="navReportBug"></span>), where navThisOnline
and navReportBug is inside navOnline.

If you would like to rewrite the page, you should first read in the parts you need from the page to JS variables, then clear the contents of pageContent (or just the part you would like to rewrite), write in the new content and show the pageContent div for the user. If you would not like to make any structural changes, you can simply display the pageContent div and only specify a special style sheet in your skin JS file (see the "greenlinks" skin for an example).

You can find a "Full skin" developed to show you how to make skins built on top of this structure. The skin name is "headernostalgia". It rewrites the header part and removes the footer navigational table.

이전 | 처음으로 | 다음
Skin development | 위로 | CSS classes


Specialities of this Edition

PHP 매뉴얼
이전 다음

60. 장. Specialities of this Edition

차례
User Preferences
Presentational Specialities

The Windows HTML Help Edition of the PHP Manual overperforms the presentational and interactive capabilities offered by other editions (including the online manual). This was possible because currently CHMs can only be viewed on Windows using Internet explorer, so we can develop for one browser family and one operating system. Viewers for other OSes may be developed in the future by third parties.

User Preferences

Most of the interactive features of this manual are provided by the viewer application (including full text search, index, favorites list), but we extended this list with PHP Manual specific tools. All these can be adjusted to your needs using a simple desktop application named php_manual_prefs.exe. If you run this program you can see three groups of settings: Online Functions, Context Menu, and Skin. All your settings are stored in php_manual_prefs.js.

Online functions enable you to have elements connected to websites. The two ones you can see on all manual pages are "This page online" and "Report a bug". As you can figure out the first one shows you the same page in the online manual, the second one opens a page from http://bugs.php.net/ and prefills some bug data for you. You need to select a mirror site to use for "php.net sensitive" online functions. We recommend choosing a close mirror site to get the best speed. Other components that may be limited by this online functions setting include context menu items opening new websites ("Google search selection" for example). Custom designs may also include elements restricted by this setting.

The context menu settings enables you to choose which context menu you prefer. This application provides you with an option to define your own context menu adding elements to it from a predefined set. You can have this custom context menu for the right click of your mouse, and have the original menu for CTRL+right click, or the opposite way. Three special types of custom context menu items exist:

표 60-1. Context menu items

Type | Examples | Comments
Page Jump | Function Reference, Function Index | These items jump to a specific page in the CHM. Page Jump options are not restricted to point inside the CHM though. They can point to websites or other resources. Page jump options with a protocol part in the URL open in new window.
Function Call | Print page, Select all, Copy selection to clipboard, Google Search Selection | These are "function calls" for internally defined context menu functions. The last two examples have the speciality that they only show up in the menu if you rightclicked on a selection. Currently there is no way to extend the context menu with skin defined functions.
Special display | Google SearchBox, AlltheWeb SearchBox | These are displayed as HTML forms, where you can enter search keywords, press ENTER, and receive a new window with the search issued in the appropriate search engine. Currently there is no way to extend the set of specially displayed context menu items.
Possible context menu elements and their "abstract implementations" are stored in context.ini. You have the ability to add possible page jump options there, but there is no way currently to extend the context menu system with user (skin) defined functions. The possible mirror sites are listed in mirrors.ini. Feel free to suggest more bundled context menu items to us at php-doc-chm@lists.php.net.

The skins setting enables you to choose from the two bundled default skins, or from any user defined skins. The Low skin is optimized to display correctly at any small size, the High skin is optimized for your viewing pleasure. Other skins may be developed according to our skins development guide. The recommended place for skins on the file system is the skins/SKINNAME subfolder of the PHP Manual directory. Though this is not required, some skins may define other rules (not recommended). We included sample skins for you to see examples of how to develop skins for the PHP Manual.

You have three buttons to choose from at the bottom. The Apply button applies your changes without exiting, the OK button applies and closes the application, the Cancel button does not modify your settings and closes the program.

이전 | 처음으로 | 다음
Manual Content and User Note Separation | 위로 | Presentational Specialities


Presentational Specialities

This edition of the PHP Manual is highly optimized for screen presentation. Skins may be developed to better support printing, as this was not the goal of the included skins. This approach allowed us to make many modifications to the presentation of different parts of the manual.

The first thing you'll notice is that all examples are color coded, using the PHP function show_source(). The actual colors used are defined by CSS classes. Examples also have links to PHP functions used in them to provide quick access to reference material. All code examples have a "copy to clipboard" link by the side of them with which you can copy the text contents of the example to the clipboard.

External links are marked with a special ? sign, and open in a new browser window. We also included the "path to this page" information on all pages for you to easily identify where you are and navigate as needed.

Other parts of the manual are quite similar to the online ones by default, though custom skins can modify many elements on the pages.

이전 | 처음으로 | 다음
Specialities of this Edition | 위로 | Integrating the PHP Manual


Using PHP Manual CHM Edition

PHP 매뉴얼
이전 다음

58. 장. Using PHP Manual CHM Edition

차례
The HTML Help Toolbar
The Navigation Pane
Keyboard Shortcuts

When you double click on a CHM, a HTML Help Viewer window opens with three panes. On the left side of the window is the Navigation pane. It contains four navigational tabs: the Contents, Index, Search and Favorites tabs. On the right side of the window is the Topic pane. It displays the selected help topic, or the default help topic on startup. The help pages are all separate HTML files, your Internet Explorer displays the pages in the Topic pane. The third pane is the toolbar, which is located below the help window title bar. You can adjust the horizontal layout with dragging the vertical border between the Navigation pane and the Topic pane.

Note, that when you open the CHM the first time, it may appear in a strange position and size. From then, Windows remembers the window position, size and the last opened tab. All these including your favorites are stored in a file named hh.dat. If you move your file to another directory, all these remembered settings will be lost (including your favorites listing!). If you replace your CHM file with a new one, with the same name, this is not a problem though. The file names and path values are stored in hh.dat.

The HTML Help Toolbar

The HTML Help Toolbar contains the following icons, when you view the PHP Manual:

  • Hide/Show - Hides/shows the navigation pane.

  • Locate - Locates a topic in the contents tab (in case you reached a topic with search, index or favorites, and would like to see where it is in the table of contents tree view).

  • Back - Goes back in the history.

  • Forward - Goes forward in the history.

  • Refresh - Reloads the current page.

  • Home - Opens the startup page of the CHM.

  • Print - Opens the print dialog box.

  • Options - Provides a dropdown with more options.

Using this toolbar is really easy, many of the toolbar icons are strongly related to their Internet Explorer equivalents.

이전 | 처음으로 | 다음
About This Edition | 위로 | The Navigation Pane


Keyboard Shortcuts

There are many keyboard shortcuts you can use to increase your productivity. Many users find it more appropriate to use these keyboard shortcuts to access topics, instead of clicking.

표 58-1. General Help Viewer Shortcuts

To | Press
Close the Help Viewer | ALT+F4
Display the Options menu | ALT+O
Hide or show the Navigation pane | ALT+O, and then T
Print a topic | ALT+O, and then P
Move back to the previous topic | ALT+LEFT ARROW
Move forward to the next topic (provided you have viewed it just previously) | ALT+RIGHT ARROW
Turn on or off search highlighting. | ALT+O, and then O
Return to the help file home page | ALT+O, and then H
Switch between the Navigation pane and the Topic pane | F6
Scroll through all the links in a topic or through all the options on a Navigation pane tab | TAB
Display context (right click) menu [see the User Preferences section] | SHIFT+F10

표 58-2. Contents Tab Shortcuts

To | Press
Display the Contents tab | ALT+C
Open and close a book or folder | PLUS SIGN and MINUS SIGN, or LEFT ARROW and RIGHT ARROW
Select a topic | DOWN ARROW and UP ARROW
Display the selected topic | ENTER

표 58-3. Index Tab Shortcuts

To | Press
Display the Index tab | ALT+N
Type a keyword to search for | ALT+W, and then type the word
Select a keyword in the list | UP ARROW and DOWN ARROW
Display the associated topic | ENTER or ALT+D

표 58-4. Search Tab shortcuts

To | Press
Display the Search tab | ALT+S
Type a keyword to search for | ALT+W, and then type the word
Start a search | ALT+L
Select a topic in the results list | ALT+T, and then UP ARROW and DOWN ARROW
Display the selected topic | ENTER or ALT+D
Search for a keyword in the result list of a prior search | ALT+U
Search for words similar to the keyword. For example, to find words like "running" and "runs" for the keyword "run" | ALT+M
Only search through topic titles | ALT+R

표 58-5. Favorites Tab Shortcuts

To | Press
Display the Favorites tab | ALT+I
Add the currently displayed topic to the Favorites list | ALT+A
Select a topic in the Favorites list | ALT+P, and then UP ARROW and DOWN ARROW
Display the selected topic | ENTER or ALT+D
Remove the selected topic from the list | ALT+R

표 58-6. Topic Pane Shortcuts

To | Press
Index Lookup | Select the words you would like to look up and press F1
Find on page | CTRL+F, and then adjust options
Refresh page | F5

이전 | 처음으로 | 다음
The Navigation Pane | 위로 | The Full Text Search


The Navigation Pane

The Navigation Pane contains four navigational tabs: the Contents, Index, Search and Favorites tabs. These all provide different methods to access a topic in the help file.

  • The contents tab reveals a tree like table of contents, where you can navigate to the desired topic by opening and closing parts of the tree. You can even access the deepest sections using this TOC. If you right click on an item here and choose "Print...", you'll have the option to print the selected topic or the selected topic and all subtopics. However printing is not the initial goal of this representation of the manual (the PDF version is suitable for printing).

  • The index tab lists a huge number of "keywords" (actually manual page titles). You can pick one, or start to type a keyword, see the list adjusting to your input, and then click on a topic, or press enter if the selected topic is the one you would like to see.

  • The search tab shows one of the most powerful features of the HTML Help Viewer, the full text search (also known as FTS). Here you can type in your search expression, optionally connecting words with AND/OR/NEAR/NOT. Before you click 'List topics', you can also set some options at the bottom. After the search results are displayed, you'll realize that manual text and user note results are separated. To sort out the two types, click on the 'Location' column header. Now from the search results list, you can pick a topic, and see it's page. The keywords you searched for are highlighted on the page.

  • The favorites tab enables you to store your most used topics in a list, easily accessible. Here you can see the list, add the current topic to it, remove one, or display a selected item. You can also specify your own title for the favorite, by typing it into the 'Current topic:' box. The user note page titles are prepended with a 'N:' string so you can distinguish them from normal manual pages in the favorites listing.

이전 | 처음으로 | 다음
Using PHP Manual CHM Edition | 위로 | Keyboard Shortcuts


HTML 도움말 에디션

PHP 매뉴얼
이전 다음

X. HTML 도움말 에디션

차례
57. About This Edition
58. Using PHP Manual CHM Edition
59. The Full Text Search
60. Specialities of this Edition
61. Integrating the PHP Manual
62. Skin development
63. CHM Edition Credits

이전 | 처음으로 | 다음
함수 인덱스 |  | About This Edition


break

break는 현재 for, foreach while, do..while 또는 switch절의 수행을 멈춘다.

break는 숫자 인자 옵션을 허용함으로써 내포된 구문구조의 깊이를 표시하고 거기서 빠져나올수 있게 해준다.

<?php
$arr = array('one', 'two', 'three', 'four', 'stop', 'five');
while (list (, $val) = each ($arr)) {
    if ($val == 'stop') {
        break;    /* 여기서는 'break 1;'으로 슬 수 있습니다. */
    }
    echo "$val<br />\n";
}

/* 옵션 인자 사용하기. */

$i = 0;
while (++$i) {
    switch ($i) {
    case 5:
        echo "At 5<br />\n";
        break 1;  /* switch만 빠져나갑니다. */
    case 10:
        echo "At 10; quitting<br />\n";
        break 2;  /* switch와 while을 빠져나갑니다. */
    default:
        break;
    }
}
?>

이전 | 처음으로 | 다음
foreach | 위로 | continue


continue

continue는 루프 구조의 절안에서 현재 루프 반복의 나머지부분을 건너뛰게 하고 다음 반복의 시작으로 실행을 속행시켜준다.

참고: PHP에서 switch구문은 continue에 의해 루프 구조로 사용할수 있다는것을 참고할것.

continue는 숫자 인자 옵션을 사용하여 루프의 깊이를 표시할수 있고, 루프의 끝까지 건너뛸수 있다.

<?php
while (list ($key, $value) = each ($arr)) {
    if (!($key % 2)) { // skip odd members
        continue;
    }
    do_something_odd ($value);
}

$i = 0;
while ($i++ < 5) {
    echo "Outer<br />\n";
    while (1) {
        echo "&nbsp;&nbsp;Middle<br />\n";
        while (1) {
            echo "&nbsp;&nbsp;Inner<br/ >\n";
            continue 3;
        }
        echo "This never gets output.<br />\n";
    }
    echo "Neither does this.<br />\n";
}
?>

continue 뒤의 세미콜론을 빼먹으면 혼란스러울 것입니다. 여기에 해서는 안되는 일의 예제입니다:

<?php
  for ($i = 0; $i < 5; ++$i) {
      if ($i == 2)
          continue
      print "$i\n";
  }
?>

기대했던 결과는:

0
1
3
4

하지만 스크립트의 출력은:

2

print() 호출의 반환값은 int(1)이기 때문에, 위에서 언급한 부수적인 수 인자로 보여집니다.

이전 | 처음으로 | 다음
break | 위로 | switch


declare

declare구문은 코드 블록의 수행 디렉티브(directive)를 활성화하기 위해 사용된다. declare문법은 다른 흐름 제어 구조의 문법과 비슷하다:

declare (directive) statement

directive부분은 declare블록의 동작이 활성화되도록 해준다. 현재는 오직 한 디렉티브만 인식된다: ticks 디렉티브. (더 자세한 정보는 ticks 디렉티브를 볼것)

declare블록의 statement부분이 수행될것이다 - 어떻게 수행이 되고 수행중에 어떤 사이드 이펙트가 발생할지는 directive블록의 디렉티브에 달려있다.

declare 구문은 전역 유효영역 안에서 사용할수 있다. 그래서 모든 코드가 그 디렉티브에 영향을 받는다.

<?php
// 이들은 동일합니다:

// 이를 사용할 수 있습니다:
declare(ticks=1) {
    // 여기에 전체 스크립트
}

// 또는 이렇게 사용할 수 있습니다:
declare(ticks=1);
// 여기에 전체 스크립트
?>

틱(Ticks)

틱은 declare블록에서 파서에 의해 수행되는 N 저레벨(low-level) 구문마다 발생하는 이벤트이다. N 값은 declare블록의 directive부분에서 ticks=N 으로 지정할수 있다.

각 틱에서 발생하는 이벤트(들)은 register_tick_function()함수 를 써서 지정한다. 자세한 것은 아래 예제를 볼것. 각 틱에서는 하나 이상의 이벤트가 발생할수 있음에 주의해야 한다.

예 11-1. PHP 각 코드 섹션의 분석표만들기(Profile)

<?php
// 호출될대의 시간을 기록하는 함수
function profile($dump = FALSE)
{
    static $profile;

    // Profile에 저장된 모든 시간 리턴하고, 삭제함
    if ($dump) {
        $temp = $profile;
        unset ($profile);
        return ($temp);
    }

    $profile[] = microtime ();
}

// 틱 핸들러 설정
register_tick_function("profile");

// declare 블록 전에 함수를 초기화
profile();

// 코드 블록의 실행하고, 두번째 구문에 틱을 부여함
declare(ticks=2) {
    for ($x = 1; $x < 50; ++$x) {
        echo similar_text(md5($x), md5($x*$x)), "<br />;";
    }
}

// 분석표에 저장된 데이터를 출력
print_r(profile (TRUE));
?>
위 예제 코드는 실행 블록안의 두번째 저레벨(low-level) 구문의 시간에 따라 'declare'블록 안의 PHP코드를 분석한다. 이런 정보로 어느 코드 부분에서 느려지는지 알아볼 수 있다. 이런 처리방법은 다른 기법으로 수행할수있다: 틱을 이용하는 것은 좀더 편하고 좀더 구현하기 쉽다.

틱은 디버깅, 단순한 멀티태스킹 구현, 백그라운드 I/O와 다른 많은 작업 에 적합하게 이용할수 있다.

register_tick_function()함수와 unregister_tick_function()함수를 참고하세요.

이전 | 처음으로 | 다음
switch | 위로 | return


do..while

do..while루프는 시작부분이 아니라 각 반복(iteration)의 끝부분에서 표현식이 참인지 체크한다는것을 제외하고 while루프와 매우 비슷하다. 일반적인 while문과의 주요한 차이점은 do..while문의 첫번째 반복이 반드시 수행된다는것이다 (반복의 끝부분에서 표현식이 참인지 체크한다), 이와 같은 경우는 일반 while루프로 수행시킬수 없을것이다. (while루프에서는 각 반복의 시작부분에서 표현식이 참인지 체크되고, 시작부터 바로 그 값이 FALSE이면 그 루프는 즉시 수행을 멈추게 된다)

다음에 do..while루프의 한가지 문법을 보인다:

<?php
$i = 0;
do {
   echo $i;
} while ($i > 0);
?>

위 루프는 정확히 한번 수행된다. 첫번째 반복(iteration) 이후에 표현식이 참인지 체크할때, FALSE가 되므로 ($i는 0보다 크지 않다) 루프 수행이 멈춘다.

고급 C 유저는 do..while루프의 다른 사용법에 익숙할것이다. 즉, do..while (0)로 감싸고, break절을 사용하여 코드 블록의 중간에서 수행을 멈출수 있습니다. 다음 코드 예는 이런 경우를 보여준다:

<?php
do {
    if ($i < 5) {
        echo "i는 충분히 크지 않다";
        break;
    }
    $i *= $factor;
    if ($i < $minimum_limit) {
        break;
    }
    echo "i is ok";

    /* process i */

} while (0);
?>

이 코드를 바로 또는 전혀 이해할수 없다고 걱정하지 마라. 이런 '기능'을 사용하지 않고도 일반스크립트나 심지어 굉장한 스크립트를 작성할 수 있다.

이전 | 처음으로 | 다음
while | 위로 | for


else

가끔은 특정 조건에 맞을때 구문을 수행하지 않고, 조건과 맞지 않을 때 다른 구문을 수행하게 하고 싶은 때가 있다. else 문은 이 목적을 위한 것이다. if문 다음의 else문은 if구문안의 표현식이 FALSE일때 수행된다. 예를 들면, 다음 코드는 $a가 $b보다 크다면 a는 b보다 크다 를 출력할것이고, 그렇지않다면 a는 b보다 크지 않다를 출력할것이다:

<?php
if ($a > $b) {
    echo "a는 b보다 크다";
} else {
    echo "a는 b보다 크지 않다";
}
?>

else문은 if문이 FALSE일때만 수행이 된다. 그리고 그들 모두 FALSE값이 될수있다면 elseif문 을 쓸수 있다. (elseif를 참고)

이전 | 처음으로 | 다음
제어 구조 | 위로 | elseif


elseif

elseif, 이 이름에서 알수 있듯이, if와 else의 조합이다. else처럼 이 구문은 if절 다음에 와서 원래 if표현식이 FALSE와 같은 경우에 다른 구문을 수행한다. 그러나, else와는 달리 elseif조건 표현식이 TRUE일 때만 대체 표현식을 수행할것이다. 예를 들면 다음 코드는 a는 b보다 크다, a는 b와 같다나 a는 b보다 작다을 출력할것이다.

<?php
if ($a > $b) {
    echo "a는 b보다 크다";
} elseif ($a == $b) {
    echo "a는 b와 같다";
} else {
    echo "a는 b보다 작다";
}
?>

같은 if절 안에 몇개의 elseif절이 존재할수 있다. 가장 먼저 TRUE가 되는 elseif표현식이 수행될것이다. PHP에서는 'else if' (두 단어)로 쓸수 있고 'elseif' (한 단어) 와 방식은 같다. 문장적(syntactic)으로는 다르다 (C에 익숙하다면, 이것은 같은 방식이다) 그러나 그 둘 모두 완전히 같은 결과를 보여줄것이다.

elseif절은 선행 if 표현식과 다른 elseif표현식이 FALSE이고, 이 elseif표현식이 TRUE일때만 수행된다.

이전 | 처음으로 | 다음
else | 위로 | 제어 구조의 대체 문법


for

for루프는 PHP에서 제일 복잡한 루프이다. C와 똑같은 방식으로 동작한다. for루프의 문법은 다음과 같다:

for (expr1; expr2; expr3) statement

첫번째 표현식(expr1)은 루프의 시작에서 바로 조건없이 평가된다 (수행된다).

각 반복(iteration)의 시작부분에서 expr2이 평 가된다. 이 표현식이 TRUE이면 루프는 계속되고 내포된 구문(들)이 수행된다. FALSE이면, 루프 수행을 멈춘다.

expr3표현식은 각 반복의 끝부분에서 평가된다 (수행된다).

각 표현식은 비어 있을수 있다. expr2이 비어있다는 것은 루프가 무제한 수행되어야 한다는 것을 의미한다 (PHP는 C처럼 TRUE로 인식) 이런 기법은 생각처럼 필요없지는 않다. 왜냐 하면 종종 for문의 표현식 대신에 break문으로 루프를 끝낼 필요가 있기 때문이다.

다음 예제 코드들을 보세요. 이 코드 모두 1부터 10까지의 숫자를 출력한다:

<?php
/* 예제 1 */

for ($i = 1; $i <= 10; $i++) {
    echo $i;
}

/* 예제 2 */

for ($i = 1; ; $i++) {
    if ($i > 10) {
        break;
    }
    echo $i;
}

/* 예제 3 */

$i = 1;
for (; ; ) {
    if ($i > 10) {
        break;
    }
    echo $i;
    $i++;
}

/* 예제 4 */

for ($i = 1; $i <= 10; echo $i, $i++);
?>

물론, 첫번째 예제(혹은 네번째) 코드가 가장 좋은 방법이다. 그러나 for루프에서 빈 표현식을 사용해야 하는 경우도 부딪히게 될것이다.

PHP는 for루프에 대한 대체 "콜른 문법"을 지원한다.

for (expr1; expr2; expr3): statement; ...; endfor;

다른 언어에서는 배열이나 해쉬를 편리하게 사용하기위해 foreach구문도 지원합니다. PHP 3는 이 구조를 지원하지 않지만, PHP 4는 지원합니다. (foreach를 보세요) PHP 3에서는 while문과 list(), each()함수를 조합하여 같은 효과를 볼수있습니다. 이런 예제는 위 함수에 대한 문서를 보세요.

이전 | 처음으로 | 다음
do..while | 위로 | foreach


foreach

PHP 4(PHP 3는 아님)는 펄이나 다른 언어와 같이 foreach구문을 지원합니다. 이런 구문은 간단하게 배열에 대한 작업을 수행하는 가장 쉬운 기법입니다. foreach는 배열에서만 작동하고 다른 데이터형을 갖는 변수나 초기화되지 않은 변수에 대해서 이 구문을 사용하려한다면 에러 메시지를 만날것입니다. 이 구문은 두가지 문법이 있습니다; 두번째보다는 첫번째문법이 더 유용한 사용법입니다:

foreach (array_expression as $value) statement
foreach (array_expression as $key => $value) statement

첫번째 형태는 array_expression에서 주어진 배열에 대해 루프를 돈다. 각 루프에서 현재 배열요소(element)의 값은 $value 로 지정되고 내부적인 배열 포인터는 하나씩 이동하게 된다 (그래서 다음 루프에서 다음 배열 요소를 보게 될것이다)

두번째 루프도 같은 일을 한다. 단 현재 배열요소의 키(key)값은 각 루프의 $key변수로 지정된다.

참고: foreach문이 처음 실행할때, 내부적인 배열 포인터는 자동적으로 배열의 첫번째 요소(element)로 리셋된다. 따라서 foreach절 이전에 reset()함수를 호출할 필요는 없다.

참고: foreach는 특정 배열의 복사본에 작용하는것이며 배열 자체를 직접 건드리지 않는다. 따라서, 배열 포인터는 each()함수 에 의해 변경이 되는것이 아니다. 넘어온 배열요소에 대한 변화는 원래 배열에는 영향을 주지 않는다. 하지만, 원래 배열의 내부적 포인터는 배열 처리에 의해 이동한다. foreach루프는 완료될때까지 루프를 돌고, 배열의 내부적 포인터는 배열 끝을 가리키게된다.

참고: foreach는 '@'를 사용해서 에러메시지를 출력하지 못하도록 할수는 없다.

다음 예는 기능적으로 동일하다는것을 알 필요가 있다:

<?php
$arr = array("one", "two", "three");
reset ($arr);
while (list(, $value) = each ($arr)) {
    echo "Value: $value<br />\n";
}

foreach ($arr as $value) {
    echo "Value: $value<br />\n";
}
?>

다음 예도 기능적으로 동일하다:

<?php
$arr = array("one", "two", "three");
reset ($arr);
while (list($key, $value) = each ($arr)) {
    echo "Key: $key; Value: $value<br />\n";
}

foreach ($arr as $key => $value) {
    echo "Key: $key; Value: $value<br />\n";
}
?>

더 많은 예제 코드들이 사용법에 대해서 설명해준다:

<?php
/* foreach 예제 1: 값만 */

$a = array(1, 2, 3, 17);

foreach ($a as $v) {
   echo "\$a의 현재 값: $v.\n";
}

/* foreach 예제 2: 값 (키는 가상으로 출력) */

$a = array(1, 2, 3, 17);

$i = 0; /* 가상 목적으로만 사용 */

foreach ($a as $v) {
    echo "\$a[$i] => $v.\n";
    $i++;
}

/* foreach 예제 3: 키와 값 */

$a = array(
    "one" => 1,
    "two" => 2,
    "three" => 3,
    "seventeen" => 17
);

foreach ($a as $k => $v) {
    echo "\$a[$k] => $v.\n";
}

/* foreach 예제 4: 다차원 배열 */

$a[0][0] = "a";
$a[0][1] = "b";
$a[1][0] = "y";
$a[1][1] = "z";

foreach ($a as $v1) {
    foreach ($v1 as $v2) {
        echo "$v2\n";
    }
}

/* foreach 예제 5: 동적 배열 */

foreach (array(1, 2, 3, 4, 5) as $v) {
    echo "$v\n";
}
?>

이전 | 처음으로 | 다음
for | 위로 | break


switch

switch구문은 연속적인 같은 표현식을 갖는 연속적인 IF구문과 비슷하다. 많은 경우, 하나의 변수(또는 표현식)으로 다른 많은 값과 비교할 필요가 있으며, 그 값이 동일한 코드의 파편들을 수행할 필요가 생기게 된다. 정확히 이런 목적을 위해 switch구문이 사용된다.

참고: 다른 언어와는 달리 continue문은 switch문에서 사용할수 있고, break문과 비슷하게 동작한다. 루프 내에 switch문을 포함하고 있고 바깥 루프의 다음 반복문으로 진행하고 싶다면 continue 2를 사용한다.

다음 예제 코드들은 같은 일을 서로 다르게 표현한 것입니다. 하나는 if와 elseif문을 사용한 것이고, 다른 하나는 switch문을 사용했습니다:

<?php
if ($i == 0) {
    echo "i는 0";
} elseif ($i == 1) {
    echo "i는 1";
} elseif ($i == 2) {
    echo "i는 2";
}

switch ($i) {
case 0:
    echo "i는 0";
    break;
case 1:
    echo "i는 1";
    break;
case 2:
    echo "i는 2";
    break;
}
?>

실수하지 않기 위해 switch문이 어떻게 동작하는지 이해할 필요가 있다. switch문은 한줄씩 수행된다 (실제는, 한구문씩). 처음에는 아무 코드도 수행되지 않는다. 오직 값을 갖는 case문이 발견될때에만 구문을 수행하기 시작한다. PHP는 switch블록의 끝부분이 될때까지, 또는 break문와 첫번째 조우를 할때까지 구문을 계속 수행해 간다. 만약 각 case 구문 목록의 끝부분에 break문을 쓰지않는다면 PHP는 다음 case문으로 계속 진행하게 된다. 예를 들면 다음과 같다:

<?php
switch ($i) {
case 0:
    echo "i는 0과 같다";
case 1:
    echo "i는 1과 같다";
case 2:
    echo "i는 2와 같다";
}
?>

여기에서, $i가 0이라면 PHP는 모든 echo문을 수행합니다! $i가 1이면 밑의 두 echo문을 수행합니다. $i가 2일때만 원하는 동작 ('i는 2와 같다'를 표시)을 합니다. 따라서 break문을 잊어서는 안됩니다. (어떤 경우에는 일부러 빠뜨릴수 있을지 모르지만)

switch구문에서, 조건문은 오직 한번만 평가되고 각 case문에서 결과가 비교되어진다. elseif문에서는 조건문은 다시 평가된다. 조건문이 한번 이상의 비교가 필요한 복잡한 것이거나 거친(tight) 루프안에 있다면 switch문 좀 더 빠를것이다.

case에 대한 구문 목록은 비어있을수 있다. 이것은 단순히 다음 case문으로 제어권을 넘겨줄 뿐이다.

<?php
switch ($i) {
case 0:
case 1:
case 2:
    echo "i는 3보다 작지만 음수는 아닙니다.";
    break;
case 3:
    echo "i는 3";
}
?>

특별한 case가 바로 default case문이다. 이것은 다른 case문과 모두 조건이 맞지 않을때의 경우를 위한것이고, case구문의 마지막에 위치해야 한다. 예제 코드는 다음과 같다:

<?php
switch ($i) {
case 0:
    echo "i는 0과 같다";
    break;
case 1:
    echo "i는 1과 같다";
    break;
case 2:
    echo "i는 2와 같다";
    break;
default:
    echo "i는 0, 1, 2 어느것도 아니다";
}
?>

case의 표현식은 정수나 부동소수점 수와 문자열같은 단순형으로 평가되는 어던 표현식도 될수 있다. 여기에 단순형으로 재참조(dereference)되지 않는 배열이나 객체를 사용할수는 없다.

switch문을 위한 제어 구조의 대체 문법이 지원된다. 더 자세한 정보는 제어 구조의 대체 문법을 참고.

<?php
switch ($i):
case 0:
    echo "i equals 0";
    break;
case 1:
    echo "i equals 1";
    break;
case 2:
    echo "i equals 2";
    break;
default:
    echo "i is not equal to 0, 1 or 2";
endswitch;
?>

이전 | 처음으로 | 다음
continue | 위로 | declare


while

while는 PHP에서 제일 간단한 루프형이다. C와 똑같은 방식으로 동작한다. while문의 기본적인 형태는 다음과 같다:

while (expr) statement

while문의 의미는 단순하다. while 표현식이 계속 TRUE이면, PHP에게 내포되어있는 구문(들)을 반복 수행하도 록 하라는것이다. 표현식의 값은 루프의 시작에서 매번 체크가 된다. 그래서 이 표현식 값이 내포된 구문(들)의 수행동안에 바뀔지라도 반복(iteration) 의 끝이 아니면 수행은 끝나지 않게 된다.(루프에서 PHP가 구문을 한번수행 할때 한번 반복(iteration)이다) 시작된지 얼마안되어 while표현식이 FALSE로 판명되면, 내포된 구문(들)은 즉시 수행을 멈출것이다.

if문과 마찬가지로 중괄호나 대체문법을 사용하여 구문의 그룹을 둘러쌉으로써 while루프 안에 여러 구문을 그룹화할수 있다

while (expr): statement ... endwhile;

다음 예는 모두 동일하다. 둘다 1부터 10까지의 숫자를 출력한다.:

<?php
/* example 1 */

$i = 1;
while ($i <= 10) {
    echo $i++;  /* 출력하는 값은 증가하기
                   전의 $i입니다.
                   (post-increment) */
}

/* example 2 */

$i = 1;
while ($i <= 10):
    echo $i;
    $i++;
endwhile;
?>

이전 | 처음으로 | 다음
제어 구조의 대체 문법 | 위로 | do..while


include

PHP 매뉴얼
이전 11. 장. 제어 구조 다음

include()

include()문은 특정 파일을 인클루드 하고, 적용시킨다.

이하 내용은 require()에도 적용되는 사항이다. 두가지 구조는 수행실패를 제어하는 방법을 제외하고 모든면에서 동일하다. include()는 Warning을 발생시키는 반면에 require()는 Fatal Error을 발생시킨다. 즉, 파일이 존재하지 않을때 페이지 처리를 중단시키 고자 한다면 require()를 쓰는데 주저할 필요가 없다. include()는 이와같이 동작하지 않으므로 파일이 없더라도 스크립트는 계속 실행될것이다. 또한 적절한 include_path설정인지 확인해야 한다. require한 파일 안에서의 처리 오류는 수행을 멈추지 않는 점에 주의하십시오.

파일을 포함할 경우 가장 먼저 현재 작업 디렉토리에 상대 경로로 include_path를 찾고, 다음으로 현재 스크립트의 디렉토리에 상대 경로로 include_path를 찾습니다. 예를 들어, include_path가 .이고, 현재 작업 디렉토리 /www/에서 include/a.php를 포함하였고, 그 파일 안에 include "b.php"이 존재하면, b.php는 우선 /www/에서 찾고, 다음으로 /www/inclde/에서 찾습니다.

파일이 인클루드 되면, 그 코드를 포함하는 코드는 인클루드가 발생한 줄의 변수 유효 범위를 물려받는다. 호출하는 파일의 그 줄에서 사용되는 어떤 변수도 그 줄부터는 호출된 파일안에서 사용이 가능하다.

예 11-3. 기본적인 include() 사용예

vars.php
<?php

$color = 'green';
$fruit = 'apple';

?>

test.php
<?php

echo "A $color $fruit"; // A

include 'vars.php';

echo "A $color $fruit"; // A green apple

?>

인클루드가 호출하는 파일안의 함수내에서 발생한다면, 호출된 파일안의 모든 코드가 그 함수에서 정의된것처럼 동작한다. 그래서, 그 함수의 변수 유효범위를 따를것이다.

예 11-4. 함수 내에서 인클루드하기

<?php

function foo()
{
    global $color;

    include 'vars.php';

    echo "A $color $fruit";
}

/* vars.php is in the scope of foo() so     *
* $fruit is NOT available outside of this  *
* scope.  $color is because we declared it *
* as global.                               */

foo();                    // A green apple
echo "A $color $fruit";   // A green

?>

파일이 인클루드되면, 파싱은 PHP모드의 밖으로 나가서 목적 파일의 시작부분은 HTML모드로 들어가게 되고, 끝부분에서 원래대로 회복된다. 이때문에, 목적 파일에서 PHP코드로서 수행되어야 하는 코드는 유효한 PHP 시작과 마침 태그 로 막아줘야 한다.

PHP에서 "URL fopen wrappers"가 활성화되어 있으면 (디폴트 설정임), URL(HTTP나 다른 지원 래퍼(wrapper) - 프로토콜 목록은 부록 J을 참고)을 사용하여 파일을 인클루드 할수 있다. 목적 서버가 목적 파일을 PHP코드로 해석한다면, HTTP GET으로 사용된 URL 리퀘스트 문자열은 변수로서 넘겨지게 될것이다. 이와같은 일은 파일을 인크루드 하고 부모 파일의 변수 유효범위를 상속하는 것과 같은 경우가 되지는 않는다. 스크립트는 실질적으로 원격 서버에서 실행이 되고 나서 로컬 스크립트에 포함된다.

주의

PHP 4.3.0 이후의 Windows 버전 PHP에서는 이 함수를 이용하여 원격 파일에 접근할 수 없습니다. allow_url_fopen을 활성화하여도 마찬가지입니다.

예 11-5. HTTP로 include()하기

<?php

/* This example assumes that www.example.com is configured to parse .php
* files and not .txt files. Also, 'Works' here means that the variables
* $foo and $bar are available within the included file. */

// Won't work; file.txt wasn't handled by www.example.com as PHP
include 'http://www.example.com/file.txt?foo=1&bar=2';

// Won't work; looks for a file named 'file.php?foo=1&bar=2' on the
// local filesystem.
include 'file.php?foo=1&bar=2';

// Works.
include 'http://www.example.com/file.php?foo=1&bar=2';

$foo = 1;
$bar = 2;
include 'file.txt';  // Works.
include 'file.php';  // Works.

?>
관련정보는 Remote files, fopen(), file()함수를 참고하세요.

include()와 require()는 특별한 언어 구조이기 때문에, 조건절 블록안에 들어가게 된다면, 구문 블록안으로 그들을 완벽하게 막아줘야 한다.

예 11-6. include()와 조건절 블록

<?php

// This is WRONG and will not work as desired.
if ($condition)
    include $file;
else
    include $other;

// This is CORRECT.
if ($condition) {
    include $file;
} else {
    include $other;
}

?>

반환 다루기: include한 파일 안에서 그 파일의 수행을 종료하고, 호출한 스크립트로 돌아가기 위해서 return()문을 실행할 수 있습니다. 또한, 값을 반환하는 일도 가능합니다. include 호출을 일반 함수를 사용한 것처럼 값을 받을 수 있습니다. 그러나, 원격 파일을 포함하였을 때, 그 파일의 출력이 (다른 로컬 파일처럼) 유효한 PHP 시작과 끝 태그를 가지지 않는다면 이 값을 받을 수 없습니다. 이 태그들 안에 필요한 값을 정의하면, include한 파일의 어떤 위치에서라도 사용할 수 있습니다.

참고: PHP 3에서 그 블록이 함수가 아니면 블록 안에 return이 보이지 않을것이다. 그런 경우에는 전체 파일이 아니고 그 함수로만 return()이 적용된다.

예 11-7. include()와 return()문

return.php
<?php

$var = 'PHP';

return $var;

?>

noreturn.php
<?php

$var = 'PHP';

?>

testreturns.php
<?php

$foo = include 'return.php';

echo $foo; // prints 'PHP'

$bar = include 'noreturn.php';

echo $bar; // prints 1

?>

인클루드가 성공하면 $bar는 1의 값을 갖는다. 위 두 예제의 차이점에 주의해야 한다. 첫번째 경우는 인클루드된 파일에서 return()을 사용하지만 다른 예는 그렇지 않다. 변수로 파일을 "인클루드"하는 다른 방법은 fopen(), file() 을 사용하거나, Output Control Functions와 함께 include()를 쓰는것이다.

참고: 이것은 함수가 아닌 언어 구조이기 때문에, 변수 함수 방식으로 호출할 수 없습니다.

require(), require_once(),
include_once(), readfile(),
virtual(), 그리고
include_path도 참고하세요.


include_once

PHP 매뉴얼
이전 11. 장. 제어 구조 다음

include_once()

include_once()문은 스크립트 수행기간동안 특정파일을 인클루드하고 적용시킨다. 이것은 include()문과 비슷하게 동작한다. 단지 파일의 특정 코드가 이미 인클루되었다면 그 코드는 다시는 인클루드 될수 없다는 차이점만 있다. 이 이름이 제시하듯이 한번만 인클루드할것이다.

include_once()는 특정 스크립트 수행기간동안 동일한 파일이 한번 이상 인클루드되고 적용될지도 모르는 상황에서 사용해야 할것이다. 그리고 함수 중복정의, 변수값 중복 지정 등의 문제를 회피하려면 정확히 한번만 인클루드할 때가 있을것이다.

require_once()와 include_once()의 더 많은 사용예는, 최신 PHP소스 내의 PEAR코드를 참고할것

참고: include_once()는 PHP 4.0.1pl2에서 추가됨

참고: include_once()와 require_once()는 대소문자를 구별하지 않는 운영체제(윈도우같은)에서 기대와 다르게 작동할수도 있다.

예 11-9. include_once()는 윈도우에서 대소문자를 구별하지 못합니다.

<?php
include_once("a.php"); // this will include a.php
include_once("A.php"); // this will include a.php again on Windows!
?>

주의

PHP 4.3.0 이후의 Windows 버전 PHP에서는 이 함수를 이용하여 원격 파일에 접근할 수 없습니다. allow_url_fopen을 활성화하여도 마찬가지입니다.

참고: include(),
require(), require_once(),
get_required_files(),
get_included_files(), readfile(),
virtual().

이전 | 처음으로 | 다음
require_once() | 위로 | 함수


require

PHP 매뉴얼
이전 11. 장. 제어 구조 다음

require()

require()문은 특정 파일을 인클루드하고, 적용시킨다.

require()문은 특정 파일을 인클루드하고, 적용시킨다. 이런 인클루드가 어떻게 동작하는지에 대한 자세한 정보는 include()에 대한 문서에서 설명한다.

require()와 include() 는 수행실패를 제어하는 방법을 제외하고 모든면에서 동일하다. include()는 Warning을 발생시키는 반면에 require()는 Fatal Error을 발생시킨다. 즉, 파일이 존재하지 않을때 페이지 처리를 중단시키 고자 한다면 require()를 쓰는데 주저할 필요가 없다. include()는 이와같이 동작하지 않으므로 파일이 없더라도 스크립트는 계속 실행될것이다. 또한 적절한 include_path설정인지 확인해야 한다.

예 11-2. 기본적인 require() 사용예

<?php

require 'prepend.php';

require $somefile;

require ('somefile.txt');

?>

더 많은 예제 코드는 include()문서에서 볼수있다.

참고: PHP 4.0.2 이전 버전에서는 다음 규칙이 적용된다: require()는 어떤줄도 수행되지 않는 목적 파일도 무작정 읽어 들이려 한다. 조건절에서는 require()가 효과적이지 않다. 하지만, require() 되는 어떤 줄도 수행되지 않으면 목적 파일의 어떤 코드도 수행되지 않을것이다. 이와 유사하게, 루프 구조에서도 require()는 효과적이지 않다. 목적파일내에 포함된 코드가 계속 루프를 반복한다면, require()는 오직 한번만 발생한다.

참고: 이것은 함수가 아닌 언어 구조이기 때문에, 변수 함수 방식으로 호출할 수 없습니다.

주의

PHP 4.3.0 이후의 Windows 버전 PHP에서는 이 함수를 이용하여 원격 파일에 접근할 수 없습니다. allow_url_fopen을 활성화하여도 마찬가지입니다.

include(), require_once(),
include_once(), eval(),
file(), readfile(),
virtual()과 include_path
섹션도 참고할것.

이전 | 처음으로 | 다음
return | 위로 | include()


require_once

PHP 매뉴얼
이전 11. 장. 제어 구조 다음

require_once()

require_once()문은 스크립트 수행기간 중에 특정파일을 인클루드하고 적용시킨다. 이것은 require()문과 비슷하게 동작한다. 오직 파일의 코드가 이미 인클루드되었다면 다시 인클루드되지 않을것 이라는 차이점이 있다. 이 구문이 어떻게 작용하는지에 대한 정보를 알아보려면 require()함수에 대한 문서를 보세요.

require_once()는 특정 스크립트 수행기간동안 한번이상 인클루드되고 적용될수 있는 상황에서 사용하도록 한다. 그리고 함수 중복 정의와 변수값 중복 지정 등에 대한 문제를 회피하기 위해서는 정확히 한번 인클루드될 필요가 있을것이다.

require_once()과 include_once()의 사용예는 최신 PHP 소스코드 안에 포함된 PEAR코드를 참고할것.

참고: require_once()는 PHP 4.0.1pl2에 추가되었다.

참고: require_once()와 include_once()은 대소문자를 구별하지 않는 운영체제(윈도우 같은)에서는 기대하던대로 동작하지 않을지 모른다.

예 11-8. require_once()는 윈도우에서 대소문자를 구별하지 못합니다.

<?php
require_once("a.php"); // this will include a.php
require_once("A.php"); // this will include a.php again on Windows!
?>

주의

PHP 4.3.0 이후의 Windows 버전 PHP에서는 이 함수를 이용하여 원격 파일에 접근할 수 없습니다. allow_url_fopen을 활성화하여도 마찬가지입니다.

참고: require(),
include(), include_once(),
get_required_files(),
get_included_files(), readfile(),
virtual().


extends

때때로 기존의 클래스와 비슷한 변수와 함수를 갖는 클래스가 필요할때 가 있다. 실제로, 모든 프로젝트에서 사용할수 있는 범용의 클래스를 선언하고, 특정 프로젝트에서 이런 클래스를 필요에 의해 변경하는 것은 좋은 습관이다. 이런 일을 수월하게 하기 위해서 클래스는 다른 클래스에서 확장(extension) 될수 있다. 이렇게 확장되거나 파생된 클래스는 원래 클래스의 모든 변수와 함수를 소유하고 (이런 경우를 아무도 죽지 않았음 에도 불구하고 '상속'이라고 부른다) 필요로 하는 확장된 선언을 추가할수 있다. 기존 클래스에서 기존 함수나 변수의 선언을 해제하여 뺄수는 없다. 확장 클래스는 항상 하나의 기존 클래스에만 연관되어있다. 즉 다중 상속은 지원되지 않는다. 클래스는 'extends'라는 키워드를 사용하여 확장된다.

<?php
class Named_Cart extends Cart
{
    var $owner;

    function set_owner ($name)
    {
        $this->owner = $name;
    }
}
?>

위 코드는 Cart의 모든 변수와 함수는 물론 추가된 변수 $owner 와 추가된 함수 set_owner()를 갖는 클래스를 선언한다. 이로써 이름이 있는 카트를 만들고 카트의 소유자를 설정하고 얻어올수 있다. 이름이 있는 카트에서는 물론 기존의 일반 카트 함수 도 쓸수 있다:

<?php
$ncart = new Named_Cart;    // 이름이 있는 카트 만들기
$ncart->set_owner("kris");  // 그 카트에 소유자를 설정
print $ncart->owner;        // 소유자 이름을 출력
$ncart->add_item("10", 1);  // (기존 cart에서 상속한 함수 사용)
?>

이런 경우를 "부모-자식" 관계라고 부르기도 한다. 부모 클래스를 만들고, 부모 클래스에 기반한 새 클래스를 만들려면 extends를 사용한다: 자식 클래스. 심지어 이런 새로운 자식 클래스를 사용하거나 이 자식 클래스에 기반한 다른 클래스도 만들수 있다.

참고: 클래스는 그것이 사용되기 전에 이미 선언되어 있어야 한다! Cart클래스를 상속하는 Named_Cart클래스가 필요하면 우선 Cart클래스를 먼저 선언해야 할것이다. Named_Cart클래스에 기반한 다른 클래스 Yellow_named_cart 를 생성하고자 한다면 Named_Cart클래스를 먼저 선언해야 한다. 짧게 말해서: 클래스가 선언되는 순서는 중요하다.

이전 | 처음으로 | 다음
클래스와 객체 | 위로 | 생성자


::

경고

다음은 PHP 4 이후에서만 적용되는 글이다.

때때로 원래 클래스의 함수와 변수를 참조하거나 아직 어떤 인스턴스도 갖지 않는 클래스의 함수를 참조할 필요가 있다. 이런 목적으로 :: 연산자를 사용한다.

<?php
class A
{
    function example()
    {
        echo "I am the original function A::example().<br>\n";
    }
}

class B extends A
{
    function example()
    {
        echo "I am the redefined function B::example().<br>\n";
        A::example();
    }
}

// 여기서는 클래스 A의 객체가 존재하지 않는다.
// 이 코드는
//   I am the original function A::example().<br>를 출력한다.
A::example();

// B 클래스의 객체를 생성한다.
$b = new B;

// 여기서는 다음과 같이 출력할것이다.
//   I am the redefined function B::example().<br>
//   I am the original function A::example().<br>
$b->example();
?>

위 예제 코드는 클래스 A의 함수 example()이 호출된다. 그러나 클래스 A의 객체가 존재하지 않는다. 그래서 $a->example()와 비슷한 코드를 쓸수 없다. 대신에 '클래스 함수'인 example()을 호출한다. 즉, 그 클래스의 객체가 아니라 클래스 자체의 함수를 호출하는 것이다.

클래스 함수는 존재하지만, 클래스 변수는 존재하지 않는다. 실제로, 호출의 모든 시간동안 전혀 객체가 없었고 따라서, 클래스 함수는 어떤 객체 변수도 사용할수 없다 (그러나 로컬 변수와 전역 변수는 사용할수 있다) 그래서 $this를 전혀 사용하지 않는다.

위 예제 코드에서 클래스 B는 함수 example()을 재선언한다. ::을 사용하여 클래스 A의 example 구현에 대해 특별히 참조하지 않으면, 클래스 A의 원래 선언은 가려지게 되고 더이상 가용하지 않다. 이와 같이 하려면 A::example()라고 써야 한다 (다음섹션에서 설명한대로 parent::example() 라고 써야 한다).

이런 환경에서는 현재 객체가 있고 그 객체는 객체 변수를 갖을수도 있다. 따라서 객체 함수 안에서 사용할때에는 $this와 객체 변수를 사용해야 할것이다.

이전 | 처음으로 | 다음
생성자 | 위로 | parent


parent

원래 클래스의 변수와 함수를 참조하는 코드를 짜야할 필요가 생길수 있다. 파생 클래스가 세분화되어 고안되었거나 원래 클래스의 코드에서 특수화되어 있는경우에는 더욱 그럴 필요성이 생긴다.

코드에서 원래 클래스명을 사용하는 대신에, 특별한 이름 parent 을 사용해야 한다. 이 용어는 현재 클래스의 extends선언 안에 주어진 원래 클래스를 참조한다는 의미를 갖는다. 이렇게 씀으로써 여러 곳에서 원래 클래스명을 쓰는것을 피할수 있다. 구현중에 상속이 세번 바뀌게 되면, 단순히 현재 클래스의 extends선언을 바꾸기만 하면 된다.

<?php
class A
{
    function example()
    {
        echo "I am A::example() and provide basic functionality.<br>\n";
    }
}

class B extends A
{
    function example()
    {
        echo "I am B::example() and provide additional functionality.<br>\n";
        parent::example();
    }
}

$b = new B;

// This will call B::example(), which will in turn call A::example().
$b->example();
?>

이전 | 처음으로 | 다음
:: | 위로 | 객체 일렬화 - 세션 내의 객체


생성자

경고

PHP 3와 PHP 4에서 생성자(constructor)는 서로 다르게 동작한다. PHP 4의 문법이 강력히 추천하는 바이다.

생성자는 new를 사용하여 클래스의 새 인스턴스를 생성할때 자동으로 호출되는 클래스 내의 함수를 말한다. PHP 3에서는 클래스의 이름과 동일한 함수가 생성자가 된다. PHP 4에서는 클래스가 선언될때의 클래스명과 동일한 이름을 갖는 함수가 생성자가 된다. - 차이는 미묘하지만 매우 중요하다 (다음 글을 보세요).

<?php
// PHP 3와  PHP 4에서 작동함
class Auto_Cart extends Cart
{
    function Auto_Cart()
    {
        $this->add_item ("10", 1);
    }
}
?>

위 코드는 Cart와 같은 Auto_Cart 클래스를 선언하고 "new"로 새로운 Auto_Cart가 생성될때마다 상품번호 "10"인 아이템 하나를 갖는 카트로 초기화하는 생성자를 만든다. 생성자는 인자를 취할수 있고 이런 인자로 인해 생성자를 더 유용하게 만들어주지만 없을수도 있다. 인자가 없는 클래스를 사용하려면 생성자의 모든 인자는 기본값을 제공해 줄수 있다.

<?php
// PHP 3와 PHP 4에서 동작함.
class Constructor_Cart extends Cart
{
    function Constructor_Cart($item = "10", $num = 1)
    {
        $this->add_item ($item, $num);
    }
}

// Shop the same old boring stuff.

$default_cart = new Constructor_Cart;

// Shop for real...

$different_cart = new Constructor_Cart("20", 17);
?>

생성자에서 발생할수 있는 에러 메시지를 보이지 않게 하려면 @연산자를 사용할수 있다.즉, @new를 쓸수 있다.

경고

PHP 3에서 파생 클래스와 생성자는 많은 제약을 갖는다. 다음 예제 코드는 이런 제약을 이해하기 위해 주의깊게 살펴봐야할것이다.

<?php
class A
{
    function A()
    {
      echo "I am the constructor of A.<br>\n";
    }
}

class B extends A
{
    function C()
    {
        echo "I am a regular function.<br>\n";
    }
}

// PHP 3에서는 어떤 생성자도 호출되지 않는다.
$b = new B;
?>

위 예제 코드는 PHP 3에서는 어떤 생성자도 호출되지 않는다. PHP 3의 규칙은 : '생성자는 클래스와 같은 이름을 갖는 함수이다'. 클래스명 이 B이고 이 클래스에서는 B()함수가 없으므로 아무일도 일어나지 않는다.

PHP 4에서는 다른 규칙이 적용되어서 이런 규칙의 문제가 해결되었다: 클래스가 생성자를 갖지 않을때, 원래 클래스에서 생성자가 존재하면 그 생성자가 호출된다. 위 예제 코드는 PHP 4에서 'I am the constructor of A.<br>' 를 출력할것이다.

<?php
class A
{
    function A()
    {
        echo "I am the constructor of A.<br>\n";
    }

    function B()
    {
        echo "I am a regular function named B in class A.<br>\n";
        echo "I am not a constructor in A.<br>\n";
    }
}

class B extends A
{
    function C()
    {
        echo "I am a regular function.<br>\n";
    }
}

// This will call B() as a constructor.
$b = new B;
?>

PHP 3에서 클래스 A의 함수 B()는 의도하지 않았을지라도 즉시 클래스 B의 생성자가 될것이다. PHP 3의 규칙: '생성자는 클래스와 같은 이름을 갖는 함수이다'. PHP 3에서는 그 함수가 클래스 B에서 선언되었는지 또는 거기서 상속되었는지는 상관하지 않는다.

위 규칙의 문제점을 PHP 4에서는 다음과 같은 규칙으로 해결했다 : '생성자는 그것이 선언된 클래스와 같은 이름을 갖는 함수이다'. 따라서 PHP 4는 클래스 B가 생성자를 갖지 않으므로 원래 클래스의 생성자가 호출되어서 'I am the constructor of A.<br>'를 출력한다.

경고

PHP 3와 PHP 4 모두 파생 클래스의 생성자에서 자동으로 원래 클래스의 생성자를 호출하지 않는다. 적절하게 상단에 생성자 호출을 전달할 책임은 당신에게 달려있다.

참고: PHP 3나 PHP 4에서는 소멸자(destructor)를 지원하지 않는다. 대신에 이런 소멸자의 기능을 수행하기 위해 register_shutdown_function() 함수를 사용할수 있다.

소멸자는 객체가 파괴될때, unset()함수나, 단순히 현재 영역을 벗어남으로써 자동으로 호출되는 함수이다. PHP에서는 소멸자가 없다.

이전 | 처음으로 | 다음
extends | 위로 | ::


매직함수 __sleep와 __wakeup

serialize()는 클래스가 __sleep라는 매직 이름을 갖는 함수를 갖는지 체크한다. 이 함수를 갖고있다면, 일렬화되기 전에 이 함수가 수행된다. 이 함수는 객체를 깨끗하게 비울수 있고, 일렬화되어야 하는 그 객체의 모든 변수명을 갖는 배열을 돌려준다.

__sleep의 의도된 사용은 그 객체가 소유할지도 모르는 모든 데이터베이스의 접속을 종료하고, 아직 수행되지 않은 커밋(commit) 을 수행하거나 청소작업을 수행한다. 또한, 완전히 저장할 필요가 없는 매우 거대한 객체를 갖고 있다면 이 함수를 유용하게 쓸수 있다.

반대로, unserialize()는 __wakeup라는 매직 이름을 갖는 함수의 존재를 체크한다. 이 함수가 존재하면, 객체가 갖고 있을지도 모르는 모든 자원을 해제할수 있다.

__wakeup의 의도된 사용은 일렬화동안에 소실될수 있는 모든 데이터베이스 접속을 재구축하고 다른 재초기화 작업을 수행 한다.

이전 | 처음으로 | 다음
객체 일렬화 - 세션 내의 객체 | 위로 | 생성자의 재참조


empty("0")

아마도 동작에 있어서 가장 쟁점이 되었던 변화가 empty()의 동작에 대한 것이다. 문자 '0' (제로) 만을 내포하는 문자열은 현재 비어있다고 본다. 반면에 PHP 3는 그렇지 않았다.

이런 새로운 동작은 숫자 입력이 요구될지라도 문자열을 리턴하는 입력 필드를 갖고, 자동으로 타입 변환을 하는 기능이 있는 PHP의 웹 응용프로그램에서는 적절하다. 그러나 다른면에서는 적절한 방식의 코드를 제대로 동작시키지 않을수도 있다. 무엇을 찾아야할지 알수 없다면 이런 잘못된 동작을 유도하는것을 추적하기 힘들것이다.

이전 | 처음으로 | 다음
초기화 | 위로 | 사라진 함수들


old_function

old_function 구문은 PHP/FI2와 동일한 문법을 사용하는 함수를 선언하도록 해준다. ('function'을 'old_function'으로 변경하는것만 빼고)

이것은 사라져가는 기능이고, PHP/FI2->PHP 3변환기만으로 사용해야 한다.

주의

old_function으로 선언된 함수는 PHP의 내부 코드에서 호출될수 없다. 이 말의 의미는 usort(), array_walk(), register_shutdown_function()과 같은 함수 안에서 이 함수를 사용할수 없다는것이다. old_function을 호출하기 위해 래퍼함수(일반적인 PHP 3 형태)를 작성함으로써 이런 제한을 극복할수 있다.

이전 | 처음으로 | 다음
PHP/FI 2 에서 PHP 3로 이주하기 | 위로 | Start/end tags


함수 TRUE/FALSE 리턴 값

대부분의 내장함수들은 성공하면 TRUE를 실패하면 FALSE를 리턴하도록 재작성되었다. PHP/FI 2.0은 각각 0과 -1을 리턴하는것과 반대된다. 이 새로운 동작은 $fp = fopen("/your/file")나 fail("darn!");같은 좀더 논리적인 코드를 작성할수 있도록 해준다. PHP/FI 2.0은 함수가 실패했을때 무엇을 리턴해야 하는지에 대한 명확한 규칙이 없기때문에, 대부분의 이런 스크립트들은 2.0에서 3.0으로의 변환기를 사용한 후에 수작업으로 확인해야 할것이다.

예 D-9. 2.0으로부터의 이주: 리턴 값, 구버전의 코드

$fp = fopen($file, "r");
if ($fp == -1);
    echo("Could not open $file for reading<br>\n");
endif;

예 D-10. 2.0으로부터의 이주: 리턴 값, 새로운 코드

$fp = @fopen($file, "r") or print("Could not open $file for reading<br>\n");

이전 | 처음으로 | 다음
짧은-순환 논리 비교 | 위로 | 다른 비호환성


코어 기선언 상수

코어 기선언 상수 -- PHP 코어, 젠드, SAPI 모듈에서 선언된 상수

해설

이 상수들은 PHP 코어에 의해 선언된다. 이 상수들은 PHP, 젠드 엔진, SAPI 모듈에도 포함된다.

PHP_VERSION (string)

PHP_OS (string)

DEFAULT_INCLUDE_PATH (string)

PEAR_INSTALL_DIR (string)

PEAR_EXTENSION_DIR (string)

PHP_EXTENSION_DIR (string)

PHP_BINDIR (string)

PHP_LIBDIR (string)

PHP_DATADIR (string)

PHP_SYSCONFDIR (string)

PHP_LOCALSTATEDIR (string)

PHP_CONFIG_FILE_PATH (string)

PHP_OUTPUT_HANDLER_START (string)

PHP_OUTPUT_HANDLER_CONT (integer)

PHP_OUTPUT_HANDLER_END (integer)

E_ERROR (integer)

E_WARNING (integer)

E_PARSE (integer)

E_NOTICE (integer)

E_CORE_ERROR (integer)

E_CORE_WARNING (integer)

E_COMPILE_ERROR (integer)

E_COMPILE_WARNING (integer)

E_USER_ERROR (integer)

E_USER_WARNING (integer)

E_USER_NOTICE (integer)

E_ALL (integer)

이전 | 처음으로 | 다음
예약 정의 상수 | 위로 | 표준 기선언 상수


표준 기선언 상수

표준 기선언 상수 -- PHP에서 선언되는 기본 상수

해설

이 상수는 기본적으로 PHP에서 선언된다.

EXTR_OVERWRITE (integer)

EXTR_SKIP (integer)

EXTR_PREFIX_SAME (integer)

EXTR_PREFIX_ALL (integer)

EXTR_PREFIX_INVALID (integer)

EXTR_PREFIX_IF_EXISTS (integer)

EXTR_IF_EXISTS (integer)

SORT_ASC (integer)

SORT_DESC (integer)

SORT_REGULAR (integer)

SORT_NUMERIC (integer)

SORT_STRING (integer)

CASE_LOWER (integer)

CASE_UPPER (integer)

COUNT_NORMAL (integer)

COUNT_RECURSIVE (integer)

ASSERT_ACTIVE (integer)

ASSERT_CALLBACK (integer)

ASSERT_BAIL (integer)

ASSERT_WARNING (integer)

ASSERT_QUIET_EVAL (integer)

CONNECTION_ABORTED (integer)

CONNECTION_NORMAL (integer)

CONNECTION_TIMEOUT (integer)

INI_USER (integer)

INI_PERDIR (integer)

INI_SYSTEM (integer)

INI_ALL (integer)

M_E (float)

M_LOG2E (float)

M_LOG10E (float)

M_LN2 (float)

M_LN10 (float)

M_PI (float)

M_PI_2 (float)

M_PI_4 (float)

M_1_PI (float)

M_2_PI (float)

M_2_SQRTPI (float)

M_SQRT2 (float)

M_SQRT1_2 (float)

CRYPT_SALT_LENGTH (integer)

CRYPT_STD_DES (integer)

CRYPT_EXT_DES (integer)

CRYPT_MD5 (integer)

CRYPT_BLOWFISH (integer)

DIRECTORY_SEPARATOR (integer)

SEEK_SET (integer)

SEEK_CUR (integer)

SEEK_END (integer)

LOCK_SH (integer)

LOCK_EX (integer)

LOCK_UN (integer)

LOCK_NB (integer)

HTML_SPECIALCHARS (integer)

HTML_ENTITIES (integer)

ENT_COMPAT (integer)

ENT_QUOTES (integer)

ENT_NOQUOTES (integer)

INFO_GENERAL (integer)

INFO_CREDITS (integer)

INFO_CONFIGURATION (integer)

INFO_MODULES (integer)

INFO_ENVIRONMENT (integer)

INFO_VARIABLES (integer)

INFO_LICENSE (integer)

INFO_ALL (integer)

CREDITS_GROUP (integer)

CREDITS_GENERAL (integer)

CREDITS_SAPI (integer)

CREDITS_MODULES (integer)

CREDITS_DOCS (integer)

CREDITS_FULLPAGE (integer)

CREDITS_QA (integer)

CREDITS_ALL (integer)

STR_PAD_LEFT (integer)

STR_PAD_RIGHT (integer)

STR_PAD_BOTH (integer)

PATHINFO_DIRNAME (integer)

PATHINFO_BASENAME (integer)

PATHINFO_EXTENSION (integer)

CHAR_MAX (integer)

LC_CTYPE (integer)

LC_NUMERIC (integer)

LC_TIME (integer)

LC_COLLATE (integer)

LC_MONETARY (integer)

LC_ALL (integer)

LC_MESSAGES (integer)

ABDAY_1 (integer)

ABDAY_2 (integer)

ABDAY_3 (integer)

ABDAY_4 (integer)

ABDAY_5 (integer)

ABDAY_6 (integer)

ABDAY_7 (integer)

DAY_1 (integer)

DAY_2 (integer)

DAY_3 (integer)

DAY_4 (integer)

DAY_5 (integer)

DAY_6 (integer)

DAY_7 (integer)

ABMON_1 (integer)

ABMON_2 (integer)

ABMON_3 (integer)

ABMON_4 (integer)

ABMON_5 (integer)

ABMON_6 (integer)

ABMON_7 (integer)

ABMON_8 (integer)

ABMON_9 (integer)

ABMON_10 (integer)

ABMON_11 (integer)

ABMON_12 (integer)

MON_1 (integer)

MON_2 (integer)

MON_3 (integer)

MON_4 (integer)

MON_5 (integer)

MON_6 (integer)

MON_7 (integer)

MON_8 (integer)

MON_9 (integer)

MON_10 (integer)

MON_11 (integer)

MON_12 (integer)

AM_STR (integer)

PM_STR (integer)

D_T_FMT (integer)

D_FMT (integer)

T_FMT (integer)

T_FMT_AMPM (integer)

ERA (integer)

ERA_YEAR (integer)

ERA_D_T_FMT (integer)

ERA_D_FMT (integer)

ERA_T_FMT (integer)

ALT_DIGITS (integer)

INT_CURR_SYMBOL (integer)

CURRENCY_SYMBOL (integer)

CRNCYSTR (integer)

MON_DECIMAL_POINT (integer)

MON_THOUSANDS_SEP (integer)

MON_GROUPING (integer)

POSITIVE_SIGN (integer)

NEGATIVE_SIGN (integer)

INT_FRAC_DIGITS (integer)

FRAC_DIGITS (integer)

P_CS_PRECEDES (integer)

P_SEP_BY_SPACE (integer)

N_CS_PRECEDES (integer)

N_SEP_BY_SPACE (integer)

P_SIGN_POSN (integer)

N_SIGN_POSN (integer)

DECIMAL_POINT (integer)

RADIXCHAR (integer)

THOUSANDS_SEP (integer)

THOUSEP (integer)

GROUPING (integer)

YESEXPR (integer)

NOEXPR (integer)

YESSTR (integer)

NOSTR (integer)

CODESET (integer)

LOG_EMERG (integer)

LOG_ALERT (integer)

LOG_CRIT (integer)

LOG_ERR (integer)

LOG_WARNING (integer)

LOG_NOTICE (integer)

LOG_INFO (integer)

LOG_DEBUG (integer)

LOG_KERN (integer)

LOG_USER (integer)

LOG_MAIL (integer)

LOG_DAEMON (integer)

LOG_AUTH (integer)

LOG_SYSLOG (integer)

LOG_LPR (integer)

LOG_NEWS (integer)

LOG_UUCP (integer)

LOG_CRON (integer)

LOG_AUTHPRIV (integer)

LOG_LOCAL0 (integer)

LOG_LOCAL1 (integer)

LOG_LOCAL2 (integer)

LOG_LOCAL3 (integer)

LOG_LOCAL4 (integer)

LOG_LOCAL5 (integer)

LOG_LOCAL6 (integer)

LOG_LOCAL7 (integer)

LOG_PID (integer)

LOG_CONS (integer)

LOG_ODELAY (integer)

LOG_NDELAY (integer)

LOG_NOWAIT (integer)

LOG_PERROR (integer)

이전 | 처음으로 | 다음
코어 기선언 상수 | 위로 | 리소스 타입 목록


Stream open options

Stream open options -- Affects the operation of stream factory functions

Description

One or more of these values can be combined using the OR operator.

IGNORE_PATH

This is the default option for streams; it requests that the include_path is not to be searched for the requested file.

USE_PATH

Requests that the include_path is to be searched for the requested file.

IGNORE_URL

Requests that registered URL wrappers are to be ignored when opening the stream. Other non-URL wrappers will be taken into consideration when decoding the path. There is no opposite form for this flag; the streams API will use all registered wrappers by default.

IGNORE_URL_WIN

On Windows systems, this is equivalent to IGNORE_URL. On all other systems, this flag has no effect.

ENFORCE_SAFE_MODE

Requests that the underlying stream implementation perform safe_mode checks on the file before opening the file. Omitting this flag will skip safe_mode checks and allow opening of any file that the PHP process has rights to access.

REPORT_ERRORS

If this flag is set, and there was an error during the opening of the file or URL, the streams API will call the php_error function for you. This is useful because the path may contain username/password information that should not be displayed in the browser output (it would be a security risk to do so). When the streams API raises the error, it first strips username/password information from the path, making the error message safe to display in the browser.

STREAM_MUST_SEEK

This flag is useful when your extension really must be able to randomly seek around in a stream. Some streams may not be seekable in their native form, so this flag asks the streams API to check to see if the stream does support seeking. If it does not, it will copy the stream into temporary storage (which may be a temporary file or a memory stream) which does support seeking. Please note that this flag is not useful when you want to seek the stream and write to it, because the stream you are accessing might not be bound to the actual resource you requested.

참고: If the requested resource is network based, this flag will cause the opener to block until the whole contents have been downloaded.

STREAM_WILL_CAST

If your extension is using a third-party library that expects a FILE* or file descriptor, you can use this flag to request the streams API to open the resource but avoid buffering. You can then use php_stream_cast() to retrieve the FILE* or file descriptor that the library requires.

The is particularly useful when accessing HTTP URLs where the start of the actual stream data is found after an indeterminate offset into the stream.

Since this option disables buffering at the streams API level, you may experience lower performance when using streams functions on the stream; this is deemed acceptable because you have told streams that you will be using the functions to match the underlying stream implementation. Only use this option when you are sure you need it.

이전 | 처음으로 | 다음
Streams Constants | 위로 | FAQ: 자주 물어보는 질문들


php_register_url_stream_wrapper

(no version information, might be only in CVS)

php_register_url_stream_wrapper -- Registers a wrapper with the Streams API

Description

int php_register_url_stream_wrapper ( char * protocol, php_stream_wrapper * wrapper, TSRMLS_DC )

php_register_url_stream_wrapper() registers wrapper as the handler for the protocol specified by protocol.

참고: If you call this function from a loadable module, you *MUST* call php_unregister_url_stream_wrapper() in your module shutdown function, otherwise PHP will crash.

이전 | 처음으로 | 다음
php_stream_passthru | 위로 | php_unregister_url_stream_wrapper


php_stream_can_cast

(no version information, might be only in CVS)

php_stream_can_cast -- Determines if a stream can be converted into another form, such as a FILE* or socket

Description

int php_stream_can_cast ( php_stream * stream, int castas)

This function is equivalent to calling php_stream_cast() with ret set to NULL and flags set to 0. It returns SUCCESS if the stream can be converted into the form requested, or FAILURE if the conversion cannot be performed.

참고: Although this function will not perform the conversion, some internal stream state *might* be changed by this call.

참고: You must explicitly compare the return value of this function with one of the constants, as described in php_stream_cast().

See also php_stream_cast() and php_stream_is().

이전 | 처음으로 | 다음
php_stream_cast | 위로 | php_stream_is_persistent


php_stream_cast

(no version information, might be only in CVS)

php_stream_cast -- Convert a stream into another form, such as a FILE* or socket

Description

int php_stream_cast ( php_stream * stream, int castas, void ** ret, int flags)

php_stream_cast() attempts to convert stream into a resource indicated by castas. If ret is NULL, the stream is queried to find out if such a conversion is possible, without actually performing the conversion (however, some internal stream state *might* be changed in this case). If flags is set to REPORT_ERRORS, an error message will be displayed is there is an error during conversion.

참고: This function returns SUCCESS for success or FAILURE for failure. Be warned that you must explicitly compare the return value with SUCCESS or FAILURE because of the underlying values of those constants. A simple boolean expression will not be interpreted as you intended.

표 43-1. Resource types for castas

Value | Meaning
PHP_STREAM_AS_STDIO | Requests an ANSI FILE* that represents the stream
PHP_STREAM_AS_FD | Requests a POSIX file descriptor that represents the stream
PHP_STREAM_AS_SOCKETD | Requests a network socket descriptor that represents the stream

In addition to the basic resource types above, the conversion process can be altered by using the following flags by using the OR operator to combine the resource type with one or more of the following values:

표 43-2. Resource types for castas

Value | Meaning
PHP_STREAM_CAST_TRY_HARD | Tries as hard as possible, at the expense of additional resources, to ensure that the conversion succeeds
PHP_STREAM_CAST_RELEASE | Informs the streams API that some other code (possibly a third party library) will be responsible for closing the underlying handle/resource. This causes the stream to be closed in such a way the underlying handle is preserved and returned in ret. If this function succeeds, stream should be considered closed and should no longer be used.

참고: If your system supports fopencookie() (systems using glibc 2 or later), the streams API will always be able to synthesize an ANSI FILE* pointer over any stream. While this is tremendously useful for passing any PHP stream to any third-party libraries, such behaviour is not portable. You are requested to consider the portability implications before distributing you extension. If the fopencookie synthesis is not desirable, you should query the stream to see if it naturally supports FILE* by using php_stream_is()

참고: If you ask a socket based stream for a FILE*, the streams API will use fdopen() to create it for you. Be warned that doing so may cause data that was buffered in the streams layer to be lost if you intermix streams API calls with ANSI stdio calls.

See also php_stream_is() and php_stream_can_cast().

이전 | 처음으로 | 다음
php_stream_make_seekable | 위로 | php_stream_can_cast


php_stream_close

(no version information, might be only in CVS)

php_stream_close -- Close a stream

Description

int php_stream_close ( php_stream * stream)

php_stream_close() safely closes stream and releases the resources associated with it. After stream has been closed, it's value is undefined and should not be used.

php_stream_close() returns 0 if the stream was closed or EOF to indicate an error. Regardless of the success of the call, stream is undefined and should not be used after a call to this function.

이전 | 처음으로 | 다음
php_stream_gets | 위로 | php_stream_flush


php_stream_closedir

(no version information, might be only in CVS)

php_stream_closedir -- Close a directory stream and release resources

Description

int php_stream_closedir ( php_stream * dirstream)

php_stream_closedir() closes a directory stream and releases resources associated with it. Returns 0 on success, but -1 on failure.

이전 | 처음으로 | 다음
php_stream_rewinddir | 위로 | Streams File API Reference


php_stream_copy_to_mem

(no version information, might be only in CVS)

php_stream_copy_to_mem -- Copy data from stream and into an allocated buffer

Description

size_t php_stream_copy_to_mem ( php_stream * src, char ** buf, size_t maxlen, int persistent)

php_stream_copy_to_mem() allocates a buffer maxlen+1 bytes in length using pemalloc() (passing persistent). It then reads maxlen bytes from src and stores them in the allocated buffer.

The allocated buffer is returned in buf, and the number of bytes successfully read. You, the caller, are responsible for freeing the buffer by passing it and persistent to pefree().

If you want to copy all remaining data from the src stream, pass the constant PHP_STREAM_COPY_ALL as the value of maxlen.

참고: This function will attempt to copy the data in the most efficient manner, using memory mapped files when possible.

이전 | 처음으로 | 다음
php_stream_copy_to_stream | 위로 | php_stream_make_seekable


php_stream_copy_to_stream

(no version information, might be only in CVS)

php_stream_copy_to_stream -- Copy data from one stream to another

Description

size_t php_stream_copy_to_stream ( php_stream * src, php_stream * dest, size_t maxlen)

php_stream_copy_to_stream() attempts to read up to maxlen bytes of data from src and write them to dest, and returns the number of bytes that were successfully copied.

If you want to copy all remaining data from the src stream, pass the constant PHP_STREAM_COPY_ALL as the value of maxlen.

참고: This function will attempt to copy the data in the most efficient manner, using memory mapped files when possible.

이전 | 처음으로 | 다음
php_stream_tell | 위로 | php_stream_copy_to_mem


php_stream_eof

(no version information, might be only in CVS)

php_stream_eof -- Check for an end-of-file condition on a stream

Description

int php_stream_eof ( php_stream * stream)

php_stream_eof() checks for an end-of-file condition on stream.

php_stream_eof() returns the 1 to indicate EOF, 0 if there is no EOF and -1 to indicate an error.

이전 | 처음으로 | 다음
php_stream_write | 위로 | php_stream_getc


php_stream_filter_register_factory

(no version information, might be only in CVS)

php_stream_filter_register_factory -- Registers a filter factory with the Streams API

Description

int php_stream_filter_register_factory ( const char * filterpattern, php_stream_filter_factory * factory)

Use this function to register a filter factory with the name given by filterpattern. filterpattern can be either a normal string name (i.e. myfilter) or a global pattern (i.e. myfilterclass.*) to allow a single filter to perform different operations depending on the exact name of the filter invoked (i.e. myfilterclass.foo, myfilterclass.bar, etc...)

참고: Filters registered by a loadable extension must be certain to call php_stream_filter_unregister_factory() during MSHUTDOWN.

이전 | 처음으로 | 다음
php_stream_open_wrapper_as_file | 위로 | php_stream_filter_unregister_factory


php_stream_filter_unregister_factory

(no version information, might be only in CVS)

php_stream_filter_unregister_factory -- Deregisters a filter factory with the Streams API

Description

int php_stream_filter_unregister_factory ( const char * filterpattern)

Deregisters the filterfactory specified by the filterpattern making it no longer available for use.

참고: Filters registered by a loadable extension must be certain to call php_stream_filter_unregister_factory() during MSHUTDOWN.

이전 | 처음으로 | 다음
php_stream_filter_register_factory | 위로 | Streams Dir API Reference


php_stream_flush

(no version information, might be only in CVS)

php_stream_flush -- Flush stream buffers to storage

Description

int php_stream_flush ( php_stream * stream)

php_stream_flush() causes any data held in write buffers in stream to be committed to the underlying storage.

php_stream_flush() returns 0 if the buffers were flushed, or if the buffers did not need to be flushed, but returns EOF to indicate an error.

이전 | 처음으로 | 다음
php_stream_close | 위로 | php_stream_seek


php_stream_fopen_from_file

(no version information, might be only in CVS)

php_stream_fopen_from_file -- Convert an ANSI FILE* into a stream

Description

php_stream * php_stream_fopen_from_file ( FILE * file, char * mode)

php_stream_fopen_from_file() returns a stream based on the file. mode must be the same as the mode used to open file, otherwise strange errors may occur when trying to write when the mode of the stream is different from the mode on the file.

이전 | 처음으로 | 다음
Streams File API Reference | 위로 | php_stream_fopen_tmpfile


php_stream_fopen_temporary_file

(no version information, might be only in CVS)

php_stream_fopen_temporary_file -- Generate a temporary file name and open a stream on it

Description

php_stream * php_stream_fopen_temporary_file ( const char * dir, const char * pfx, char ** opened)

php_stream_fopen_temporary_file() generates a temporary file name in the directory specified by dir and with a prefix of pfx. The generated file name is returns in the opened parameter, which you are responsible for cleaning up using efree(). A stream is opened on that generated filename in "w+b" mode. The file is NOT automatically deleted; you are responsible for unlinking or moving the file when you have finished with it.

이전 | 처음으로 | 다음
php_stream_fopen_tmpfile | 위로 | Streams Socket API Reference


php_stream_fopen_tmpfile

(no version information, might be only in CVS)

php_stream_fopen_tmpfile -- Open a FILE* with tmpfile() and convert into a stream

Description

php_stream * php_stream_fopen_tmpfile ( void )

php_stream_fopen_from_file() returns a stream based on a temporary file opened with a mode of "w+b". The temporary file will be deleted automatically when the stream is closed or the process terminates.

이전 | 처음으로 | 다음
php_stream_fopen_from_file | 위로 | php_stream_fopen_temporary_file


php_stream_getc

(no version information, might be only in CVS)

php_stream_getc -- Read a single byte from a stream

Description

int php_stream_getc ( php_stream * stream)

php_stream_getc() reads a single character from stream and returns it as an unsigned char cast as an int, or EOF if the end-of-file is reached, or an error occurred.

php_stream_getc() may block in the same way as php_stream_read() blocks.

The internal position of the stream is advanced by 1 if successful.

이전 | 처음으로 | 다음
php_stream_eof | 위로 | php_stream_gets


php_stream_gets

(no version information, might be only in CVS)

php_stream_gets -- Read a line of data from a stream into a buffer

Description

char * php_stream_gets ( php_stream * stream, char * buf, size_t maxlen)

php_stream_gets() reads up to count-1 bytes of data from stream and copies them into the buffer buf. Reading stops after an EOF or a newline. If a newline is read, it is stored in buf as part of the returned data. A NUL terminating character is stored as the last character in the buffer.

php_stream_read() returns buf when successful or NULL otherwise.

The internal position of the stream is advanced by the number of bytes that were read, so that subsequent reads will continue reading from that point.

This function may block in the same way as php_stream_read().

이전 | 처음으로 | 다음
php_stream_getc | 위로 | php_stream_close


php_stream_is

(no version information, might be only in CVS)

php_stream_is -- Determines if a stream is of a particular type

Description

int php_stream_is ( php_stream * stream, int istype)

php_stream_is() returns 1 if stream is of the type specified by istype, or 0 otherwise.

표 43-1. Values for istype

Value | Meaning
PHP_STREAM_IS_STDIO | The stream is implemented using the stdio implementation
PHP_STREAM_IS_SOCKET | The stream is implemented using the network socket implementation
PHP_STREAM_IS_USERSPACE | The stream is implemented using the userspace object implementation
PHP_STREAM_IS_MEMORY | The stream is implemented using the grow-on-demand memory stream implementation

참고: The PHP_STREAM_IS_XXX "constants" are actually defined as pointers to the underlying stream operations structure. If your extension (or some other extension) defines additional streams, it should also declare a PHP_STREAM_IS_XXX constant in it's header file that you can use as the basis of this comparison.

참고: This function is implemented as a simple (and fast) pointer comparison, and does not change the stream state in any way.

See also php_stream_cast() and php_stream_can_cast().

이전 | 처음으로 | 다음
php_stream_is_persistent | 위로 | php_stream_passthru


php_stream_is_persistent

(no version information, might be only in CVS)

php_stream_is_persistent -- Determines if a stream is a persistent stream

Description

int php_stream_is_persistent ( php_stream * stream)

php_stream_is_persistent() returns 1 if the stream is a persistent stream, 0 otherwise.

이전 | 처음으로 | 다음
php_stream_can_cast | 위로 | php_stream_is


php_stream_make_seekable

(no version information, might be only in CVS)

php_stream_make_seekable -- Convert a stream into a stream is seekable

Description

int php_stream_make_seekable ( php_stream * origstream, php_stream ** newstream, int flags)

php_stream_make_seekable() checks if origstream is seekable. If it is not, it will copy the data into a new temporary stream. If successful, newstream is always set to the stream that is valid to use, even if the original stream was seekable.

flags allows you to specify your preference for the seekable stream that is returned: use PHP_STREAM_NO_PREFERENCE to use the default seekable stream (which uses a dynamically expanding memory buffer, but switches to temporary file backed storage when the stream size becomes large), or use PHP_STREAM_PREFER_STDIO to use "regular" temporary file backed storage.

표 43-1. php_stream_make_seekable() return values

Value | Meaning
PHP_STREAM_UNCHANGED | Original stream was seekable anyway. newstream is set to the value of origstream.
PHP_STREAM_RELEASED | Original stream was not seekable and has been released. newstream is set to the new seekable stream. You should not access origstream anymore.
PHP_STREAM_FAILED | An error occurred while attempting conversion. newstream is set to NULL; origstream is still valid.
PHP_STREAM_CRITICAL | An error occurred while attempting conversion that has left origstream in an indeterminate state. newstream is set to NULL and it is highly recommended that you close origstream.

참고: If you need to seek and write to the stream, it does not make sense to use this function, because the stream it returns is not guaranteed to be bound to the same resource as the original stream.

참고: If you only need to seek forwards, there is no need to call this function, as the streams API will emulate forward seeks when the whence parameter is SEEK_CUR.

참고: If origstream is network based, this function will block until the whole contents have been downloaded.

참고: NEVER call this function with an origstream that is reference by a file pointer in a PHP script! This function may cause the underlying stream to be closed which could cause a crash when the script next accesses the file pointer!

참고: In many cases, this function can only succeed when origstream is a newly opened stream with no data buffered in the stream layer. For that reason, and because this function is complicated to use correctly, it is recommended that you use php_stream_open_wrapper() and pass in PHP_STREAM_MUST_SEEK in your options instead of calling this function directly.

이전 | 처음으로 | 다음
php_stream_copy_to_mem | 위로 | php_stream_cast


php_stream_open_wrapper

(no version information, might be only in CVS)

php_stream_open_wrapper -- Opens a stream on a file or URL

Description

php_stream * php_stream_open_wrapper ( char * path, char * mode, int options, char ** opened)

php_stream_open_wrapper() opens a stream on the file, URL or other wrapped resource specified by path. Depending on the value of mode, the stream may be opened for reading, writing, appending or combinations of those. See the table below for the different modes that can be used; in addition to the characters listed below, you may include the character 'b' either as the second or last character in the mode string. The presence of the 'b' character informs the relevant stream implementation to open the stream in a binary safe mode.

The 'b' character is ignored on all POSIX conforming systems which treat binary and text files in the same way. It is a good idea to specify the 'b' character whenever your stream is accessing data where the full 8 bits are important, so that your code will work when compiled on a system where the 'b' flag is important.

Any local files created by the streams API will have their initial permissions set according to the operating system defaults - under Unix based systems this means that the umask of the process will be used. Under Windows, the file will be owned by the creating process. Any remote files will be created according to the URL wrapper that was used to open the file, and the credentials supplied to the remote server.

r

Open text file for reading. The stream is positioned at the beginning of the file.

r+

Open text file for reading and writing. The stream is positioned at the beginning of the file.

w

Truncate the file to zero length or create text file for writing. The stream is positioned at the beginning of the file.

w+

Open text file for reading and writing. The file is created if it does not exist, otherwise it is truncated. The stream is positioned at the beginning of the file.

a

Open for writing. The file is created if it does not exist. The stream is positioned at the end of the file.

a+

Open text file for reading and writing. The file is created if it does not exist. The stream is positioned at the end of the file.

options affects how the path/URL of the stream is interpreted, safe mode checks and actions taken if there is an error during opening of the stream. See Stream open options for more information about options.

If opened is not NULL, it will be set to a string containing the name of the actual file/resource that was opened. This is important when the options include USE_PATH, which causes the include_path to be searched for the file. You, the caller, are responsible for calling efree() on the filename returned in this parameter.

참고: If you specified STREAM_MUST_SEEK in options, the path returned in opened may not be the name of the actual stream that was returned to you. It will, however, be the name of the original resource from which the seekable stream was manufactured.

이전 | 처음으로 | 다음
php_stream_stat | 위로 | php_stream_read


php_stream_open_wrapper_as_file

(no version information, might be only in CVS)

php_stream_open_wrapper_as_file -- Opens a stream on a file or URL, and converts to a FILE*

Description

FILE * php_stream_open_wrapper_as_file ( char * path, char * mode, int options, char ** opened)

php_stream_open_wrapper_as_file() is exactly like php_stream_open_wrapper(), but converts the stream into an ANSI stdio FILE* and returns that instead of the stream. This is a convenient shortcut for extensions that pass FILE* to third-party libraries.

이전 | 처음으로 | 다음
php_stream_open_wrapper_ex | 위로 | php_stream_filter_register_factory


php_stream_open_wrapper_ex

(no version information, might be only in CVS)

php_stream_open_wrapper_ex -- Opens a stream on a file or URL, specifying context

Description

php_stream * php_stream_open_wrapper_ex ( char * path, char * mode, int options, char ** opened, php_stream_context * context)

php_stream_open_wrapper_ex() is exactly like php_stream_open_wrapper(), but allows you to specify a php_stream_context object using context. To find out more about stream contexts, see XXX

이전 | 처음으로 | 다음
php_unregister_url_stream_wrapper | 위로 | php_stream_open_wrapper_as_file


php_stream_opendir

(no version information, might be only in CVS)

php_stream_opendir -- Open a directory for file enumeration

Description

php_stream * php_stream_opendir ( char * path, php_stream_context * context)

php_stream_opendir() returns a stream that can be used to list the files that are contained in the directory specified by path. This function is functionally equivalent to POSIX opendir(). Although this function returns a php_stream object, it is not recommended to try to use the functions from the common API on these streams.

이전 | 처음으로 | 다음
Streams Dir API Reference | 위로 | php_stream_readdir


php_stream_passthru

(no version information, might be only in CVS)

php_stream_passthru -- Outputs all remaining data from a stream

Description

size_t php_stream_passthru ( php_stream * stream)

php_stream_passthru() outputs all remaining data from stream to the active output buffer and returns the number of bytes output. If buffering is disabled, the data is written straight to the output, which is the browser making the request in the case of PHP on a web server, or stdout for CLI based PHP. This function will use memory mapped files if possible to help improve performance.

이전 | 처음으로 | 다음
php_stream_is | 위로 | php_register_url_stream_wrapper


php_stream_read

(no version information, might be only in CVS)

php_stream_read -- Read a number of bytes from a stream into a buffer

Description

size_t php_stream_read ( php_stream * stream, char * buf, size_t count)

php_stream_read() reads up to count bytes of data from stream and copies them into the buffer buf.

php_stream_read() returns the number of bytes that were read successfully. There is no distinction between a failed read or an end-of-file condition - use php_stream_eof() to test for an EOF.

The internal position of the stream is advanced by the number of bytes that were read, so that subsequent reads will continue reading from that point.

If less than count bytes are available to be read, this call will block (or wait) until the required number are available, depending on the blocking status of the stream. By default, a stream is opened in blocking mode. When reading from regular files, the blocking mode will not usually make any difference: when the stream reaches the EOF php_stream_read() will return a value less than count, and 0 on subsequent reads.

이전 | 처음으로 | 다음
php_stream_open_wrapper | 위로 | php_stream_write


php_stream_readdir

(no version information, might be only in CVS)

php_stream_readdir -- Fetch the next directory entry from an opened dir

Description

php_stream_dirent * php_stream_readdir ( php_stream * dirstream, php_stream_dirent * ent)

php_stream_readdir() reads the next directory entry from dirstream and stores it into ent. If the function succeeds, the return value is ent. If the function fails, the return value is NULL. See php_stream_dirent for more details about the information returned for each directory entry.

이전 | 처음으로 | 다음
php_stream_opendir | 위로 | php_stream_rewinddir


php_stream_rewinddir

(no version information, might be only in CVS)

php_stream_rewinddir -- Rewind a directory stream to the first entry

Description

int php_stream_rewinddir ( php_stream * dirstream)

php_stream_rewinddir() rewinds a directory stream to the first entry. Returns 0 on success, but -1 on failure.

이전 | 처음으로 | 다음
php_stream_readdir | 위로 | php_stream_closedir


php_stream_seek

(no version information, might be only in CVS)

php_stream_seek -- Reposition a stream

Description

int php_stream_seek ( php_stream * stream, off_t offset, int whence)

php_stream_seek() repositions the internal position of stream. The new position is determined by adding the offset to the position indicated by whence. If whence is set to SEEK_SET, SEEK_CUR or SEEK_END the offset is relative to the start of the stream, the current position or the end of the stream, respectively.

php_stream_seek() returns 0 on success, but -1 if there was an error.

참고: Not all streams support seeking, although the streams API will emulate a seek if whence is set to SEEK_CUR and offset is positive, by calling php_stream_read() to read (and discard) offset bytes.

The emulation is only applied when the underlying stream implementation does not support seeking. If the stream is (for example) a file based stream that is wrapping a non-seekable pipe, the streams api will not apply emulation because the file based stream implements a seek operation; the seek will fail and an error result will be returned to the caller.

이전 | 처음으로 | 다음
php_stream_flush | 위로 | php_stream_tell


php_stream_sock_open_from_socket

(no version information, might be only in CVS)

php_stream_sock_open_from_socket -- Convert a socket descriptor into a stream

Description

php_stream * php_stream_sock_open_from_socket ( int socket, int persistent)

php_stream_sock_open_from_socket() returns a stream based on the socket. persistent is a flag that controls whether the stream is opened as a persistent stream. Generally speaking, this parameter will usually be 0.

이전 | 처음으로 | 다음
Streams Socket API Reference | 위로 | php_stream_sock_open_host


php_stream_sock_open_host

(no version information, might be only in CVS)

php_stream_sock_open_host -- Open a connection to a host and return a stream

Description

php_stream * php_stream_sock_open_host ( const char * host, unsigned short port, int socktype, struct timeval * timeout, int persistent)

php_stream_sock_open_host() establishes a connect to the specified host and port. socktype specifies the connection semantics that should apply to the connection. Values for socktype are system dependent, but will usually include (at a minimum) SOCK_STREAM for sequenced, reliable, two-way connection based streams (TCP), or SOCK_DGRAM for connectionless, unreliable messages of a fixed maximum length (UDP).

persistent is a flag the controls whether the stream is opened as a persistent stream. Generally speaking, this parameter will usually be 0.

If not NULL, timeout specifies a maximum time to allow for the connection to be made. If the connection attempt takes longer than the timeout value, the connection attempt is aborted and NULL is returned to indicate that the stream could not be opened.

참고: The timeout value does not include the time taken to perform a DNS lookup. The reason for this is because there is no portable way to implement a non-blocking DNS lookup.

The timeout only applies to the connection phase; if you need to set timeouts for subsequent read or write operations, you should use php_stream_sock_set_timeout() to configure the timeout duration for your stream once it has been opened.

The streams API places no restrictions on the values you use for socktype, but encourages you to consider the portability of values you choose before you release your extension.

이전 | 처음으로 | 다음
php_stream_sock_open_from_socket | 위로 | php_stream_sock_open_unix


php_stream_sock_open_unix

(no version information, might be only in CVS)

php_stream_sock_open_unix -- Open a Unix domain socket and convert into a stream

Description

php_stream * php_stream_sock_open_unix ( const char * path, int pathlen, int persistent, struct timeval * timeout)

php_stream_sock_open_unix() attempts to open the Unix domain socket specified by path. pathlen specifies the length of path. If timeout is not NULL, it specifies a timeout period for the connection attempt. persistent indicates if the stream should be opened as a persistent stream. Generally speaking, this parameter will usually be 0.

참고: This function will not work under Windows, which does not implement Unix domain sockets. A possible exception to this rule is if your PHP binary was built using cygwin. You are encouraged to consider this aspect of the portability of your extension before it's release.

참고: This function treats path in a binary safe manner, suitable for use on systems with an abstract namespace (such as Linux), where the first character of path is a NUL character.

이전 | 처음으로 | 다음
php_stream_sock_open_host | 위로 | Streams Structures


php_stream_stat

(no version information, might be only in CVS)

php_stream_stat -- Gets the status for the underlying storage associated with a stream

Description

int php_stream_stat ( php_stream * stream, php_stream_statbuf * ssb)

php_stream_stat() examines the storage to which stream is bound, and returns information such as file size, access and creation times and so on. The return value is 0 on success, -1 on error. For more information about the information returned, see php_stream_statbuf.

이전 | 처음으로 | 다음
php_stream_stat_path | 위로 | php_stream_open_wrapper


php_stream_stat_path

(no version information, might be only in CVS)

php_stream_stat_path -- Gets the status for a file or URL

Description

int php_stream_stat_path ( char * path, php_stream_statbuf * ssb)

php_stream_stat_path() examines the file or URL specified by path and returns information such as file size, access and creation times and so on. The return value is 0 on success, -1 on error. For more information about the information returned, see php_stream_statbuf.

이전 | 처음으로 | 다음
Streams Common API Reference | 위로 | php_stream_stat


php_stream_tell

(no version information, might be only in CVS)

php_stream_tell -- Determine the position of a stream

Description

off_t php_stream_tell ( php_stream * stream)

php_stream_tell() returns the internal position of stream, relative to the start of the stream. If there is an error, -1 is returned.

이전 | 처음으로 | 다음
php_stream_seek | 위로 | php_stream_copy_to_stream


php_stream_write

(no version information, might be only in CVS)

php_stream_write -- Write a number of bytes from a buffer to a stream

Description

size_t php_stream_write ( php_stream * stream, const char * buf, size_t count)

php_stream_write() writes count bytes of data from buf into stream.

php_stream_write() returns the number of bytes that were written successfully. If there was an error, the number of bytes written will be less than count.

The internal position of the stream is advanced by the number of bytes that were written, so that subsequent writes will continue writing from that point.

이전 | 처음으로 | 다음
php_stream_read | 위로 | php_stream_eof


php_unregister_url_stream_wrapper

(no version information, might be only in CVS)

php_unregister_url_stream_wrapper -- Unregisters a wrapper from the Streams API

Description

int php_unregister_url_stream_wrapper ( char * protocol, TSRMLS_DC )

php_unregister_url_stream_wrapper() unregisters the wrapper associated with protocol.

이전 | 처음으로 | 다음
php_register_url_stream_wrapper | 위로 | php_stream_open_wrapper_ex


struct php_stream_dirent

struct php_stream_dirent -- Holds information about a single file during dir scanning

Description

php_stream_dirent
     char d_name[MAXPATHLEN]

d_name holds the name of the file, relative to the directory being scanned.

이전 | 처음으로 | 다음
struct php_stream_statbuf | 위로 | struct php_stream_ops


struct php_stream_filter

struct php_stream_filter -- Holds filter properties and pointer to operations

Description

struct _php_stream_filter {
            php_stream_filter_ops *fops;
            void *abstract; /* for use by filter implementation */
            php_stream_filter *next;
            php_stream_filter *prev;
            int is_persistent;

            /* link into stream and chain */
            php_stream_filter_chain *chain;

            /* buffered buckets */
            php_stream_bucket_brigade buffer;
        } php_stream_filter;

이전 | 처음으로 | 다음
struct php_stream_wrapper_ops | 위로 | struct php_stream_filter_ops


struct php_stream_filter_ops

struct php_stream_filter_ops -- Holds member functions for a stream filter implementation

Description

typedef struct _php_stream_filter_ops {
            php_stream_filter_status_t (*filter)(
                    php_stream *stream,
                    php_stream_filter *thisfilter,
                    php_stream_bucket_brigade *buckets_in,
                    php_stream_bucket_brigade *buckets_out,
                    size_t *bytes_consumed,
                    int flags
                    TSRMLS_DC);

            void (*dtor)(php_stream_filter *thisfilter TSRMLS_DC);

            const char *label;
} php_stream_filter_ops;

이전 | 처음으로 | 다음
struct php_stream_filter | 위로 | Streams Constants


struct php_stream_ops

struct php_stream_ops -- Holds member functions for a stream implementation

Description

typedef struct _php_stream_ops {
             /* all streams MUST implement these operations */
             size_t (*write)(php_stream *stream, const char *buf, size_t count TSRMLS_DC);
             size_t (*read)(php_stream *stream, char *buf, size_t count TSRMLS_DC);
             int (*close)(php_stream *stream, int close_handle TSRMLS_DC);
             int (*flush)(php_stream *stream TSRMLS_DC);

             const char *label; /* name describing this class of stream */

             /* these operations are optional, and may be set to NULL if the stream does not
              * support a particular operation */
            int (*seek)(php_stream *stream, off_t offset, int whence TSRMLS_DC);
            char *(*gets)(php_stream *stream, char *buf, size_t size TSRMLS_DC);
            int (*cast)(php_stream *stream, int castas, void **ret TSRMLS_DC);
            int (*stat)(php_stream *stream, php_stream_statbuf *ssb TSRMLS_DC);
        } php_stream_ops;

이전 | 처음으로 | 다음
struct php_stream_dirent | 위로 | struct php_stream_wrapper


struct php_stream_statbuf

struct php_stream_statbuf -- Holds information about a file or URL

Description

php_stream_statbuf
     struct stat sb

sb is a regular, system defined, struct stat.

이전 | 처음으로 | 다음
Streams Structures | 위로 | struct php_stream_dirent


struct php_stream_wrapper

struct php_stream_wrapper -- Holds wrapper properties and pointer to operations

Description

struct _php_stream_wrapper  {
            php_stream_wrapper_ops *wops;   /* operations the wrapper can perform */
            void *abstract;                 /* context for the wrapper */
            int is_url;                     /* so that PG(allow_url_fopen) can be respected */

            /* support for wrappers to return (multiple) error messages to the stream opener */
            int err_count;
            char **err_stack;
        } php_stream_wrapper;

이전 | 처음으로 | 다음
struct php_stream_ops | 위로 | struct php_stream_wrapper_ops


struct php_stream_wrapper_ops

struct php_stream_wrapper_ops -- Holds member functions for a stream wrapper implementation

Description

typedef struct _php_stream_wrapper_ops {
            /* open/create a wrapped stream */
            php_stream *(*stream_opener)(php_stream_wrapper *wrapper, char *filename, char *mode,
                    int options, char **opened_path, php_stream_context *context STREAMS_DC TSRMLS_DC);
            /* close/destroy a wrapped stream */
            int (*stream_closer)(php_stream_wrapper *wrapper, php_stream *stream TSRMLS_DC);
            /* stat a wrapped stream */
            int (*stream_stat)(php_stream_wrapper *wrapper, php_stream *stream, php_stream_statbuf *ssb TSR$
            /* stat a URL */
            int (*url_stat)(php_stream_wrapper *wrapper, char *url, php_stream_statbuf *ssb TSRMLS_DC);
            /* open a "directory" stream */
            php_stream *(*dir_opener)(php_stream_wrapper *wrapper, char *filename, char *mode,
                    int options, char **opened_path, php_stream_context *context STREAMS_DC TSRMLS_DC);

            const char *label;

            /* Delete/Unlink a file */
            int (*unlink)(php_stream_wrapper *wrapper, char *url, int options, php_stream_context *context TSRMLS_DC);
        } php_stream_wrapper_ops;

이전 | 처음으로 | 다음
struct php_stream_wrapper | 위로 | struct php_stream_filter


Including Output in phpinfo

PHP 매뉴얼
이전 36. 장. Printing Information 다음

Including Output in phpinfo()

After creating a real module, you'll want to show information about the module in phpinfo() (in addition to the module name, which appears in the module list by default). PHP allows you to create your own section in the phpinfo() output with the ZEND_MINFO() function. This function should be placed in the module descriptor block (discussed earlier) and is always called whenever a script calls phpinfo().

PHP automatically prints a section in phpinfo() for you if you specify the ZEND_MINFO function, including the module name in the heading. Everything else must be formatted and printed by you.

Typically, you can print an HTML table header using php_info_print_table_start() and then use the standard functions php_info_print_table_header() and php_info_print_table_row(). As arguments, both take the number of columns (as integers) and the column contents (as strings). 예 36-1 shows a source example and its output. To print the table footer, use php_info_print_table_end().

예 36-1. Source code and screenshot for output in phpinfo().

php_info_print_table_start();
php_info_print_table_header(2, "First column", "Second column");
php_info_print_table_row(2, "Entry in first row", "Another entry");
php_info_print_table_row(2, "Just to fill", "another row here");
php_info_print_table_end();

이전 | 처음으로 | 다음
zend_error() | 위로 | Execution Information


zend_error

PHP 매뉴얼
이전 36. 장. Printing Information 다음

zend_error()

zend_error() can be used to generate error messages. This function accepts two arguments; the first is the error type (see zend_errors.h), and the second is the error message.
zend_error(E_WARNING, "This function has been called with empty arguments");
표 36-1 shows a list of possible values (see 그림 36-1). These values are also referred to in php.ini. Depending on which error type you choose, your messages will be logged.

표 36-1. Zend's Predefined Error Messages.

Error | Description
E_ERROR | Signals an error and terminates execution of the script immediately .
E_WARNING | Signals a generic warning. Execution continues.
E_PARSE | Signals a parser error. Execution continues.
E_NOTICE | Signals a notice. Execution continues. Note that by default the display of this type of error messages is turned off in php.ini.
E_CORE_ERROR | Internal error by the core; shouldn't be used by user-written modules.
E_COMPILE_ERROR | Internal error by the compiler; shouldn't be used by user-written modules.
E_COMPILE_WARNING | Internal warning by the compiler; shouldn't be used by user-written modules.

그림 36-1. Display of warning messages in the browser.

이전 | 처음으로 | 다음
Printing Information | 위로 | Including Output in phpinfo()


Creation of get_module

PHP 매뉴얼
이전 31. 장. Source Discussion 다음

Creation of get_module()

This function is special to all dynamic loadable modules. Take a look at the creation via the ZEND_GET_MODULE macro first:

#if COMPILE_DL_FIRSTMOD
     ZEND_GET_MODULE(firstmod)
#endif

The function implementation is surrounded by a conditional compilation statement. This is needed since the function get_module() is only required if your module is built as a dynamic extension. By specifying a definition of COMPILE_DL_FIRSTMOD in the compiler command (see above for a discussion of the compilation instructions required to build a dynamic extension), you can instruct your module whether you intend to build it as a dynamic extension or as a built-in module. If you want a built-in module, the implementation of get_module() is simply left out.

get_module() is called by Zend at load time of the module. You can think of it as being invoked by the dl() call in your script. Its purpose is to pass the module information block back to Zend in order to inform the engine about the module contents.

If you don't implement a get_module() function in your dynamic loadable module, Zend will compliment you with an error message when trying to access it.

이전 | 처음으로 | 다음
Declaration of the Zend Module Block | 위로 | Implementation of All Exported Functions